Обзор средства анализа Microsoft Exchange Server

Дата последнего изменения раздела: 2005-07-08

Средство анализ Microsoft® Exchange Server — это средство диагностики, выполняющее следующие функции:

  • сбор информации о настройке из организации сервера Microsoft Exchange;

  • выполнение специальных тестов организации сервера Exchange;

  • отчеты о результатах тестов.

Средство анализа Exchange Server можно использовать для выполнения следующих задач:

  • профилактическая проверка соответствия настройки рекомендациям;

  • отчеты о параметрах, значения которых отличаются от значений по умолчанию;

  • отчеты о недавних изменениях организации сервера Exchange, что помогает диагностировать проблемы, вызванные изменениями организации сервера Exchange;

  • помощь в идентификации источника неполадки в некорректно работающей организации сервера Exchange;

  • сравнение набора серверов с базовой настройкой и выдача отчета о различиях в настройке.

Примечание.
Средство анализа Exchange Server может создавать отчеты о недавних изменениях только для тех объектов настройки, у которых есть свойство время последнего изменения .

Средство анализа Exchange Server использует файл настройки, чтобы определить, какую информацию об организации сервера Exchange нужно собирать. Оно сравнивает собранные данные с набором предопределенных правил, описывающих параметры и настройки сервера Exchange. После этого средство анализа выдает отчет о проблемах.

Для каждой проблемы средство анализа Exchange Server выдает данные трех типов:

  • что обнаружено при проверке организации Exchange Server;

  • рекомендуемая настройка;

  • ссылки на более подробные сведения о проблеме и на материалы по связанным темам.

Мы будем рады услышать ваши комментарии и предложения по средству анализа Exchange Server. Свои комментарии вы можете отправить нам разными способами:

  • Общедоступные группы новостей корпорации Майкрософт Члены группы разработки средства анализа Exchange Server довольно часто просматривают группу новостей microsoft.public.exchange.tools newsgroup на веб-узле news.microsoft.com. Для получения подробных сведений об участии в этой и в других группах новостей корпорации Майкрософт см. веб-узел средства анализа Exchange Server (http://go.microsoft.com/fwlink/?LinkId=33938) и на веб-узле групп поддержки продуктов корпорации Майкрософт (http://go.microsoft.com/fwlink/?LinkId=50219).

  • Обратная связь по документации к средству анализа Exchange Server Если у вас есть комментарии, вопросы или замечания по документации или статьям, прилагающимся к средству анализа Exchange Server, отправляйте их по адресу exbpadoc@microsoft.com.


Установка анализатора рекомендаций для сервера Microsoft Exchange

Установка анализатора рекомендаций для сервера Microsoft Exchange |
 | См. также
Обзор средства анализа Microsoft Exchange Server >

Дата последнего изменения раздела: 2006-02-08

Чтобы установить анализатор рекомендаций для сервера Microsoft® Exchange, запустите файл установщика ExBPA.msi на компьютере, на котором будет работать средство. Установщик создаст каталог по имени ExBPA, расположенный по умолчанию в папке <системный_диск>\Program Files\, и скопирует в этот новый каталог необходимые файлы.

Выбор компьютера для установки

Рекомендуемый компьютер для установки анализатора рекомендаций для сервера Exchange — выделенная станция управления. Дополнительные сведения об установке и использовании выделенной станции управления см. в Руководстве по администрированию Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?linkid=21769.

Чтобы установить данное средство на компьютер, не входящий в организацию Exchange, необходимо явно указать имена пользователей и пароли для входа в службу каталогов Active Directory® и на серверы Exchange. Дополнительные сведения о настройке учетных данных для учетной записи пользователя, с которой будет выполняться сканирование, см. в разделе Разрешения для средства анализа рекомендаций по серверу Microsoft Exchange.

Это средство можно установить также на сервере Exchange. Средство может работать на сервере Exchange. Однако оно будет потреблять большой объем системных ресурсов, особенно процессора и оперативной памяти. Поэтому рекомендуется установить средство на отдельном компьютере. Если все же средство установлено на сервере Exchange, рекомендуется сканировать только этот сервер Exchange.

Проверка наличия обновлений

При запуске анализатора рекомендаций для сервера Microsoft Exchange он определяет, есть ли новый файл с правилами рекомендаций на веб-узле www.microsoft.com. Если новая версия есть, можно загрузить этот файл. Чтобы загрузить файл, необходимо войти на компьютер в качестве администратора. Если не требуется загружать файл или средству не удается получить доступ к Интернету, оно будет пытаться использовать копию файла, доступную на данном компьютере при запуске средства.

Примечание.
Если для доступа к Интернету требуется проверка подлинности прокси-сервера, средство не сможет обратиться к новой версии файла конфигурации, чтобы выполнить загрузку. Однако можно вручную загрузить файл с веб-узла www.microsoft.com на локальный компьютер.
Чтобы вручную скопировать новую версию файла конфигурации

  1. В каталоге установки средства переименуйте существующий файл ExBPA.Config.xml.

  2. В веб-обозревателе перейдите по адресу http://go.microsoft.com/fwlink/?LinkId=34290.

  3. Загрузите самораспаковывающийся пакет и извлеките новые файлы в каталог установки средства (обычно C:\Program Files\ExBPA).

См. также

Понятия

Влияние на производительность анализатора Best Practices Analyzer сервера Microsoft Exchange
Разрешения для средства анализа рекомендаций по серверу Microsoft Exchange

Другие ресурсы

Настройка проверки в средстве анализа Microsoft® Exchange Server

© 2007 Microsoft Corporation. Все права защищены.


Условия выполнения средства Best Practices Analyzer сервера Microsoft Exchange
Обзор средства анализа Microsoft Exchange Server >

Дата последнего изменения раздела: 2005-07-08

Для корректного выполнения средства Best Practices Analyzer сервера Microsoft® Exchange компьютеры организации Exchange должны отвечать ряду требований. Если данные требования не выполнены, средство, скорее всего, будет работать, однако с неполной функциональностью или с пониженным быстродействием.

В разделах этой части приводятся сведений о разрешениях, требуемых для выполнения средства Best Practices Analyzer сервера Exchange, а также о других требованиях к организации Exchange и компьютеру, на котором выполняется это средство. Кроме того, в разделе «Другие требования» перечислены среды, поддерживающие выполнение данного средства.

В этом разделе

Разрешения для средства анализа рекомендаций по серверу Microsoft Exchange

Другие предварительные условия для работы средства анализа рекомендаций по серверу Microsoft Exchange


Разрешения для средства анализа рекомендаций по серверу Microsoft Exchange

Разрешения для средства анализа рекомендаций по серверу Microsoft Exchange |
 | См. также
Обзор средства анализа Microsoft Exchange Server > Условия выполнения средства Best Practices Analyzer сервера Microsoft Exchange >

Дата последнего изменения раздела: 2005-07-08

Средство анализа рекомендаций по серверу Microsoft® Exchange может получить доступ к службе каталогов Active Directory® и серверам Exchange только в том случае, если средство запускается с помощью учетных данных, которые обладают необходимыми разрешениями.

Разрешения

Для успешного запуска средства анализа рекомендаций по серверу Exchange требуются следующие разрешения:

  • Администратора домена или члена встроенной группы/группы администраторов на сервере Active Directory для перечисления сведений Active Directorу и вызова поставщиков инструментария управления Windows (Windows® Management Instrumentation, WMI) на контроллере домена и серверах глобального каталога.

  • Члена локальной группы администраторов на каждом сервере Exchange для вызова поставщиков WMI, а также для доступа к реестру и метабазе.

  • Хотя бы делегированные разрешения на просмотр Exchange для организации Exchange.

При входе в систему компьютера, на котором будет запускаться средство анализа рекомендаций по серверу Exchange, под учетной записью, не имеющей необходимых разрешений, предоставляется две возможности:

  1. Используйте команду runas, чтобы открыть окно командной строки, которое будет функционировать под учетной записью, имеющей необходимые разрешения, а затем запустите средство из этого окна. Для запуска этой команды используется следующий синтаксис:

    runas /netonly /user:<домен>\<имя_пользователя> exbpa.exe

  2. Установите учетные данные для учетных записей, которые будут использоваться в средстве на странице Подключение к Active Directory. Щелкните Показать расширенные параметры входа в систему, чтобы раскрыть доступные параметры. Можно ввести две учетные записи, одну для подключения к службе Active Directory и другую для подключения к серверам Exchange. Если не указать одну или другую из этих учетных записей, будет использоваться учетная запись, под которой запускается средство.

См. также

Понятия

Другие предварительные условия для работы средства анализа рекомендаций по серверу Microsoft Exchange

© 2007 Microsoft Corporation. Все права защищены.


Другие предварительные условия для работы средства анализа рекомендаций по серверу Microsoft Exchange

Другие предварительные условия для работы средства анализа рекомендаций по серверу Microsoft Exchange |
 | См. также
Обзор средства анализа Microsoft Exchange Server > Условия выполнения средства Best Practices Analyzer сервера Microsoft Exchange >

Дата последнего изменения раздела: 2007-05-16

Помимо запуска средства анализа рекомендаций по Microsoft® Exchange под учетной записью, обладающей требуемыми разрешениями на работу со службой каталогов Active Directory®, и наличия учетной записи, которая имеет необходимые разрешения на работу с серверами Exchange, следует проверить существование дополнительных предварительных условий, которые должны выполняться для успешной работы программного средства.

Предварительные условия

Для корректной работы анализатора рекомендаций по серверу Exchange должны соблюдаться следующие условия:

  • На компьютере, на котором должен запускаться анализатор рекомендаций по серверу Exchange, должно быть установлено программное обеспечение .NET Framework 1.1.

  • Чтобы предоставить возможность доступа к удаленной метабазе, на компьютере, на котором запускается анализатор рекомендаций по серверу Exchange, должны быть установлены общие файлы службы IIS (Internet Information Services).

    Примечание.
    Если устанавливаются службы IIS, администратор службы IIS или системный диспетчер Exchange, общие файлы служб IIS устанавливаются автоматически.
  • Компьютер, на котором запускается анализатор рекомендаций по серверу Exchange, должен иметь память произвольного доступа (ОЗУ) объемом, по крайней мере, 256 мегабайтов (МБ). Этого объема памяти достаточно для сканирования до 50 серверов Exchange. При добавлении в организацию Exchange дополнительных серверов, общим числом до 50 компьютеров, потребуются дополнительные 256 МБ ОЗУ на компьютере, на котором выполняется программное средство. Например, если в организации имеется от 50 до 100 серверов Exchange, компьютер, на котором выполняется программное средство, должен иметь ОЗУ объемом, по крайней мере, 512 МБ. Если количество серверов Exchange в организации находится в диапазоне между 100 и 150, на компьютере, на котором выполняется программное средство, должно быть установлено ОЗУ объемом хотя бы 768 МБ.

  • Для каждого сервера Exchange в сканируемой организации необходимо иметь, по крайней мере, 2 МБ свободного пространства на диске компьютера, на котором выполняется анализатор рекомендаций по серверу Exchange.

  • Служба Active Directory должна быть установлена в топологии операционной системы Microsoft Windows® 2000 Server или операционной системы Windows Server™ 2003.

  • В службе Active Directory должен быть установлен хотя бы один сервер Exchange 2003 или Exchange 2000.

  • Служба «Удаленный реестр» (RemoteRegistry) должна выполняться как на сервере Active Directory, так и на серверах Exchange.

  • Cлужба инструментария управления Windows (WMI) (winmgmt) должна выполняться как на сервере Active Directory, так и на серверах Exchange.

  • Служба управления Exchange (MSExchangeMGMT) должна выполняться на всех серверах Exchange 2000 и более поздних версиях серверов Exchange.

  • Пользователь, вошедший в систему и запускающий анализатор рекомендаций по серверу Exchange, должен иметь доступ на чтение и на запись к папке, из которой запускается программное средство.

  • На всех серверах, с которых требуется собирать сведения об адаптерах шины, должны быть установлены драйвер, совместимый с API адаптера шины, и служба удаленного управления (например, служба HBAnywhere компании Emulex). Кроме того, и на компьютере, на котором запускается анализатор рекомендаций по серверу Exchange, и на целевом сервере, на котором установлен адаптер шины, должен выполняться MOF-установщик (Managed Object Format) функций API адаптера шины. Если драйвер, совместимый с API адаптера шины, и служба удаленного управления не установлены, анализатор рекомендаций по серверу Exchange будет запускаться, но не будет собирать сведения об адаптерах шины.

Поддерживаемые среды

Анализатор рекомендаций по серверу Exchange может выполняться в следующих средах:

  • Exchange Server 5.5 на платформе Windows 2000 Server с пакетом обновления 3 (SP3) и более поздних версий

Примечание.
Сервер Exchange Server 5.5 должен быть частью организации Exchange, работающей в смешанном режиме и представленной в службе Active Directory.
  • Exchange 2000 Server (все пакеты обновлений) на платформе Windows 2000 Server с пакетом обновления 3 (SP3) и более поздних версий

Примечание.
Ни Windows 2000 Server, ни Exchange 2000 Server не поддерживают обширных WMI-поставщиков. Сбор и анализ данных могут выполняться в ограниченном объеме.
  • Exchange 2003 Server (все пакеты обновлений) на платформе Windows 2000 Server с пакетом обновления 3 (SP3) и более поздних версий

Примечание.
Операционная система Windows 2000 Server не поддерживает обширных WMI-поставщиков. Сбор и анализ данных могут выполняться в ограниченном объеме.
  • Exchange Server 2003 (с любыми пакетами обновления) в системе Windows Server 2003

  • Exchange Server 2007 в системе Windows Server 2003

См. также

Понятия

Разрешения для средства анализа рекомендаций по серверу Microsoft Exchange

© 2007 Microsoft Corporation. Все права защищены.


Сканирование организации Exchange с помощью средства анализа рекомендаций по серверу Microsoft Exchange
Обзор средства анализа Microsoft Exchange Server >

Дата последнего изменения раздела: 2005-07-08

Средство анализа рекомендаций по серверу Microsoft® Exchange сканирует в организации Exchange компьютеры, которые находятся в выбранной для сканирования области. Средство сравнивает параметры конфигурации с набором рекомендуемых значений и сообщает о результатах.

Во время сканирования динамически обновляется индикатор выполнения, отображающий процент завершенного сканирования. Показываемый процент основан на объеме данных, собираемых для определенного типа сканирование, и количестве серверов, входящих в область сканирования.

Оценка оставшегося времени обновляется динамически и пересчитывается каждые 60 секунд. Анализатор рекомендаций по серверу Exchange использует технологию многопоточности, так что он может сканировать одновременно более одного сервера Exchange. Анализатор рекомендаций по серверу Exchange может одновременно сканировать компьютеры максимум из 10 административных групп и до 50 серверов Exchange. Дополнительные серверы ставятся в очередь и сканируются после завершения сканирования компьютеров, находящихся в процессе проверки.

В окне Сведения о сканировании сервера показывается состояние каждого сервера, выбранного для сканирования. Серверы могут находиться в одном из трех состояний: «Ожидание», «Выполнение» или «Завершено». Если сервер находится в состоянии «Выполнение», индикатор выполнения показывает процент завершенного сканирования. После того как сервер перешел в состояние «Завершено», значок показывает, получил ли анализатор рекомендаций по серверу Exchange доступ к серверу. Зеленая галочка показывает, что анализатор рекомендаций по серверу Exchange смог получить доступ к серверу и что во время сканирования не было отказов и превышения порогового значения тайм-аута. Желтый предупреждающий значок показывает, что анализатор рекомендаций по серверу Exchange имел доступ к серверу, однако во время сканирования произошел сбой анализатора рекомендаций по серверу Exchange или было превышено пороговое значение тайм-аута. Красный значок «X» указывает, что анализатор рекомендаций по серверу Exchange не смог получить доступ к серверу, и сервер не просканирован.

Помимо сбора данных с серверов Exchange анализатор рекомендаций по серверу Exchange должен собирать данные из службы каталогов Active Directory®. Ход сбора данных из службы Active Directory показывается как часть индикатора выполнения и в виде оценки оставшегося времени вверху страницы, а не в окне Сведения о сканировании сервера. Поэтому общее состояние сканирования может изменяться, даже если все серверы Exchange находятся в состояниях «Ожидание» или «Завершено».

После того как анализатор рекомендаций по серверу Exchange завершит сканирование всех выбранных серверов, можно открыть страницу Просмотр отчета с рекомендациями.

В этом разделе

Настройка проверки в средстве анализа Microsoft® Exchange Server

Проверка сети и разрешений для средства анализатора рекомендаций сервера Microsoft Exchange Server

Настройка средства анализа Microsoft Exchange Server Best Practices Analyzer Tool


Настройка проверки в средстве анализа Microsoft® Exchange Server

Настройка проверки в средстве анализа Microsoft® Exchange Server |
 | См. также
Обзор средства анализа Microsoft Exchange Server > Сканирование организации Exchange с помощью средства анализа рекомендаций по серверу Microsoft Exchange >

Дата последнего изменения раздела: 2005-07-08

При запуске средства анализа Microsoft® Exchange Server необходимо установить параметры проверки. Во-первых, нужно выбрать, следует ли загрузить последнее обновление правил проверки. Для получения дополнительных сведений о проверке обновлений и загрузке последнего файла обновлений см. раздел Установка анализатора рекомендаций для сервера Microsoft Exchange.

Затем необходимо выбрать действие. На странице Добро пожаловать выберите Выбрать параметры новой проверки или Выбрать отчет для просмотра. Если вы решили просмотреть существующий отчет, можно выбрать файл в списке файлов выходных данных, хранящихся на локальном компьютере. Кроме того, можно импортировать файл выходных данных, хранящийся не на локальном компьютере. Когда файл выбран, можно просмотреть отчет, сохраненный в нем. Для получения дополнительных сведений об отчетах см. раздел Общие сведения о выходных данных средства анализатора рекомендаций для сервера Microsoft Exchange.

Если выбран пункт Выбрать параметры новой проверки, необходимо подключиться к службе каталога Active Directory® и запустить новую проверку. По умолчанию средство анализа Exchange Server обнаружит ближайший сервер Active Directory. Можно подключиться к этому серверу или выбрать другой сервер Active Directory, введя его имя вручную.

Средство анализа Exchange Server использует учетную запись, под которой средство работает по умолчанию. Чтобы использовать другую учетную запись для входа в Active Directory или для входа на сервер Exchange , щелкните Показать дополнительные параметры входа, чтобы раскрыть окно параметров. В верхней части раскрытого окна введите данные учетной записи для входа в Active Directory. В нижней части раскрытого окна введите данные учетной записи для входа на серверы Exchange.

Для входа в Active Directory и для входа на серверы Exchange можно использовать одну учетную запись, или же данные для входа в Active Directory и для входа на серверы Exchange могут различаться. Если оставить поля в верхней или нижней части раскрытого окна пустыми, средство анализа Exchange Server использует при входе учетную запись, под которой оно запущено.

См. также

Понятия

Установка анализатора рекомендаций для сервера Microsoft Exchange
Разрешения для средства анализа рекомендаций по серверу Microsoft Exchange
Настройка средства анализа Microsoft Exchange Server Best Practices Analyzer Tool

Другие ресурсы

Общие сведения о выходных данных средства анализатора рекомендаций для сервера Microsoft Exchange
Проверка сети и разрешений для средства анализатора рекомендаций сервера Microsoft Exchange Server

© 2007 Microsoft Corporation. Все права защищены.


Проверка сети и разрешений для средства анализатора рекомендаций сервера Microsoft Exchange Server

Проверка сети и разрешений для средства анализатора рекомендаций сервера Microsoft Exchange Server |
 | См. также
Обзор средства анализа Microsoft Exchange Server > Сканирование организации Exchange с помощью средства анализа рекомендаций по серверу Microsoft Exchange >

Дата последнего изменения раздела: 2005-07-08

Перед началом сканирования средства анализатора рекомендаций сервера Microsoft® Exchange Server выполняет проверку сети и разрешений, чтобы убедиться, что указанные учетные данные учетной записи являются верными и данное средство может подключиться к службе каталогов Active Directory®. Если при выполнении какой-либо из этих проверок будет выявлена ошибка, произойдет возврат на страницу Подключение к Active Directory, где можно повторно ввести как имя сервера, на котором выполняется Active Directory, так и учетные данные для входа на серверы Active Directory и Exchange.

См. также

Понятия

Разрешения для средства анализа рекомендаций по серверу Microsoft Exchange
Настройка средства анализа Microsoft Exchange Server Best Practices Analyzer Tool

Другие ресурсы

Настройка проверки в средстве анализа Microsoft® Exchange Server

© 2007 Microsoft Corporation. Все права защищены.


Настройка средства анализа Microsoft Exchange Server Best Practices Analyzer Tool

Настройка средства анализа Microsoft Exchange Server Best Practices Analyzer Tool |
 | См. также
Обзор средства анализа Microsoft Exchange Server > Сканирование организации Exchange с помощью средства анализа рекомендаций по серверу Microsoft Exchange >

Дата последнего изменения раздела: 2006-10-10

Прежде чем запускать проверку, необходимо выполнить несколько последних шагов:

  1. Установите метку для проверки.

  2. Установите область.

  3. Установите тип проверки.

  4. Установите скорость сети.

После того как метка, область, тип проверки и скорость сети установлены, средство анализа Microsoft® Exchange Server Best Practices Analyzer Tool начнет проверку.

Установка метки для проверки

Чтобы настроить метку проверки, на странице Начало новой проверки в поле Введите идентифицирующую метку проверки введите уникальную метку. Если в дальнейшем нужно будет просмотреть существующий отчет, его можно будет идентифицировать по метке, которая введена в поле Введите идентифицирующую метку проверки.

Существующий отчет можно просмотреть двумя способами:

  • На странице Приветствие выберите пункт Просмотреть отчет о рекомендациях.

  • На левой навигационной панели окна средства анализа Exchange Server Best Practices Analyzer выберите пункт Выберите проверку для просмотра.

Настройка области проверки

Чтобы указать область проверки, на странице Начало новой проверки выберите серверы или административные группы, которые необходимо проверить.

Можно выбрать одну из трех областей:

  • Можно выбрать всю организацию Exchange Server .

  • Можно выбрать одну или несколько административных групп.

  • Можно выбрать один или несколько серверов из любой административной группы организации Exchange Server.

Выбор типа проверки

Затем необходимо выбрать тип проверки. Можно выбрать один из трех типов:

  • проверка работоспособности;

  • проверка работоспособности и производительности;

  • тест подключения;

  • базовая проверка.

При Проверке работоспособности выполняется полная проверка. Выполняется проверка на предмет наличия ошибок, предупреждений, настроек, отличных от настройки по умолчанию, недавних изменений и проверка прочей информации о настройке. Проверку работоспособности нужно запускать, если требуется проверить работоспособность организации Exchange Server или решить какую-то определенную проблему.

При Проверке работоспособности и производительности выполняется Проверка работоспособности, а затем отображается ряд счетчиков производительности Exchange Server за двухчасовой период времени.

Тест подключения проверяет сетевые подключения и разрешения для каждого Exchange Server, указанного в области проверки. Тест подключения нужно выполнять, если вы подозреваете, что возникла проблема, связанная с разрешениями доступа, или если в топологии присутствует брандмауэр. Если Тест подключения пройден успешно, можно запустить Проверку работоспособности.

Тест подключения выполняется очень быстро. Средство анализа Exchange Server Best Practices Analyzer запрашивает один параметр реестра и два класса инструментария Microsoft Windows® Management Instrumentation (WMI). В первом запросе WMI проверяется доступ к хранилищу WMI. Во втором запросе WMI опрашиваются серверы службы каталогов Active Directory®, используемые сервером Exchange. После проверки всех серверов Exchange, указанных в области проверки, средство анализа Exchange Server Best Practices Analyzer пытается проверить сетевые подключения и разрешения серверов Active Directory, используемых Exchange Server.

При Базовой проверке выполняются следующие задания:

  • Выбираются свойства.

  • Устанавливаются базовые значения для выбранных свойств.

  • Выбираются серверы, для которых выбранные свойства сравниваются.

При Базовой проверке проверяются отклонения от установленных базовых значений. В отчете Базовой проверки в качестве несоответствующих базовым указываются все свойства выбранных серверов, значения которых отличаются от исходных значений выбранных свойств.

Запуск базовой проверки

  1. На странице Запуск новой проверки, в меню Выберите тип проверки укажите Базовая проверка и нажмите кнопку Параметры базовой проверки.

  2. В меню Параметры базовой проверки выберите существующую проверку или введите новую метку.

  3. Щелкните стрелку рядом с пунктом Исходные значения, чтобы раскрыть список базовых свойств.

    • Это свойства, которые собираются файлом ExBPA.config.xml. Выберите свойства, которые нужно сравнивать в ходе базовой проверки: снимите и установите соответствующие флажки. Значения свойств — это значения по умолчанию, хранящиеся в файле ExBPA.config.xml. Установите эти значения в текстовых полях.

  4. Щелкните стрелку рядом с пунктом Объекты тестирования, чтобы раскрыть список серверов.

  5. Выберите серверы, которые необходимо проверить на предмет несоответствия базовым значениям.

Установка скорости сети

После выбора типа проверки установите скорость сети. Для установки скорости сети выберите один из четырех вариантов:

  • Быстрая локальная сеть

  • Локальная сеть

  • Быстрая глобальная сеть

  • Глобальная сеть

Скорость сети используется для оценки времени, необходимого для выполнения проверки. Также скорость сети необходима для установки значения тайм-аута.

Во время проверки средство анализа Exchange Server Best Practices Analyzer ожидает ответа от сервера определенное время. Если средство анализа не получило ответ в течение указанного времени тайм-аута, оно продолжает проверку вместо того, чтобы продолжать ждать. В более медленных сетях указывается большее время тайм-аута, чтобы учесть большие задержки в сети. Рекомендуется при указании этого параметра выбрать самую медленную связь в топологии, чтобы средство анализа Exchange Server Best Practices Analyzer не прекращало ожидание слишком быстро.

Запуск проверки

Установив все параметры проверки, можно Начать проверку или Запланировать проверку. Если выбрать Начать проверку, средство анализа Exchange Server Best Practices Analyzer начнет проверку организации Exchange немедленно. Для получения дополнительных сведений см. раздел Сканирование организации Exchange с помощью средства анализа рекомендаций по серверу Microsoft Exchange.

Если выбрать Запланировать проверку, откроется страница Планирование проверки. Чтобы запланировать проверку, нужно ввести необходимые учетные данные и установить флажок Включить планирование сканирования. Дополнительные сведения о вводе необходимых учетных данных см. в разделе Настройка проверки в средстве анализа Microsoft® Exchange Server.

После этого указывается время начала проверки. Время начала — это день и время запуска первой запланированной проверки.

И наконец, указывается частота проверок. Частота определяет, как часто будут выполняться запланированные проверки. Чтобы закрыть средство анализа Exchange Server Best Practices Analyzer, щелкните Выйти из средства анализа. Для выполнения запланированной проверки запускать средство анализа Exchange Server Best Practices Analyzer не нужно. Если выйти из средства анализа Exchange Server Best Practices Analyzer, запланированная проверка запустится в фоновом режиме в указанный день и в указанное время. Чтобы просмотреть отчет запланированной проверки, необходимо перезапустить средство анализа Exchange Server Best Practices Analyzer.

См. также

Понятия

Виды выходных данных

Другие ресурсы

Сканирование организации Exchange с помощью средства анализа рекомендаций по серверу Microsoft Exchange

© 2007 Microsoft Corporation. Все права защищены.


Дополнительные параметры
Обзор средства анализа Microsoft Exchange Server > Сканирование организации Exchange с помощью средства анализа рекомендаций по серверу Microsoft Exchange >

Дата последнего изменения раздела: 2006-10-26

Средство анализа Microsoft® Exchange Server имеет следующие настраиваемые параметры реестра:

Место | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
Значение | OpenRelayTest
Тип | REG_DWORD
Описание | Установите значение 0x0, если анализатор рекомендаций не должен проверять возможности открытой пересылки на каждом сервере SMTP. Если этот параметр отсутствует, то анализатор рекомендаций установит значение по умолчанию, равное 0x1.

Место | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
Значение | OpenRelayTestSender
Тип | REG_SZ
Описание | Введите в качестве значения адрес SMTP, который будет использоваться в параметре MAIL FROM: при выполнении проверки открытой ретрансляции. Если этот параметр отсутствует, то анализатор рекомендаций установит значение по умолчанию ExBPA-OpenRelayTest@Fabrikam.com.

Место | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
Значение | TopoCreateTimeoutSecs
Тип | REG_SZ
Описание | Введите в качестве значения адрес SMTP, который будет использоваться в качестве адреса RCPT TO: при выполнении проверки открытой ретрансляции. Если этот параметр отсутствует, то анализатор рекомендаций установит значение по умолчанию ExBPA-OpenRelayTest@Fabrikam.com.

Место | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
Значение | SMTPTest
Тип | REG_DWORD
Описание | Установите значение 0x0, если анализатор рекомендаций не должен отправлять тестовое сообщение каждому сканируемому серверу SMTP. Если этот параметр отсутствует, то анализатор рекомендаций установит значение по умолчанию, равное 0x1.

Место | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
Значение | SMTPTestSender
Тип | REG_SZ
Описание | Введите в качестве значения адрес SMTP, который будет использоваться в параметре MAIL FROM: при выполнении проверки принятия почты SMTP. Если этот параметр отсутствует, то анализатор рекомендаций установит значение по умолчанию ExBPA-MailAcceptTest@Fabrikam.com.

Место | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
Значение | T SMTPTestRecipient
Тип | REG_SZ
Описание | Введите в качестве значения адрес SMTP, который будет использоваться в качестве адреса RCPT TO: при выполнении проверки принятия почты SMTP. Если этот параметр отсутствует, то анализатор рекомендаций установит значение по умолчанию, содержащее учетную запись администратора почтовой системы, определенную службой SMTP.


Общие сведения о выходных данных средства анализатора рекомендаций для сервера Microsoft Exchange
Обзор средства анализа Microsoft Exchange Server >

Дата последнего изменения раздела: 2006-02-08

В отчете средства анализатора рекомендаций для сервера Microsoft® Exchange отображается анализ данных, собранных в процессе проверки организации Exchange. Для выбора предоставляется три вида отчетов: «Отчеты по списку», «Отчеты по дереву» и «Другие отчеты».

  • Отчеты по списку включают следующие элементы:

    • «Критические проблемы»,

    • «Все элементы»,

    • «Настройки не по умолчанию»,

    • «Недавние изменения»,

    • «База»,

    • «Информационные элементы».

  • Отчеты по дереву включают следующие элементы:

    • «Подробный отчет»,

    • «Итоговый отчет»,

  • «Другие отчеты»,

    • «Скрытые элементы»,

    • «Файл журнала о ходе выполнения».

Отчеты по списку

Представлением по умолчанию является список критических проблем. В этом списке отображаются только найденные ошибки. Ошибки — это критические проблемы, оказывающие непосредственное влияние на быстродействие и доступность сервера Exchange. В списке «Все элементы» отображаются ошибки, предупреждения и сведения о несоблюдении рекомендаций. В списке «Настройки не по умолчанию» отображаются изменения конфигурации сервера с момента установки продукта Exchange Server. В списке «Недавние изменения» отображаются изменения настройки сервера за последние пять дней. К ним относится установка пакетов обновления и других обновлений. В списке «База» отображаются отличия в настройке узлов в кластере.

Отчеты по дереву

В подробном отчете отображаются все параметры настройки, собранные средством анализатора сервера Exchange. В итоговом отчете отображается иерархическое представление всех проблем, найденных в среде Exchange.

Другие отчеты

В отчете «Скрытые элементы» отображаются неполадки, выбранные администратором Exchange для исключения из других отчетов анализатора сервера Exchange. Элементы из этого списка могут быть включены в другие отчеты, если снять с них маску. В отчете «Файл журнала о ходе выполнения» отображаются сведения о важных этапах сбора данных и об ошибках, возвращенных в процессе сбора данных.

В списках «Критические проблемы», «Все элементы» и «Настройки не по умолчанию» можно щелкнуть любую ошибку или предупреждение, чтобы просмотреть пояснение. Затем можно щелкнуть Подробные сведения об этой проблеме и способах ее устранения для получения более подробных сведений.

Примечание.
XML-файл выходных данных и файл журнала проверки расположены в папке <системный диск>\Documents and Settings\<пользователь>\Application Data\Microsoft\ExBPA.

В этом разделе

Виды выходных данных

Устранение и скрытие проблем

Просмотр предыдущего отчета средства анализа рекомендаций по серверу Microsoft Exchange


Виды выходных данных

Виды выходных данных |
 | См. также
Обзор средства анализа Microsoft Exchange Server > Общие сведения о выходных данных средства анализатора рекомендаций для сервера Microsoft Exchange >

Дата последнего изменения раздела: 2006-09-29

Отчет анализатора рекомендаций сервера Microsoft® Exchange содержит шесть типов сведений:

  • Ошибка

  • Предупреждение

  • Конфигурация, отличающаяся от заданной по умолчанию

  • Недавнее изменение

  • Базовое несовпадение

  • Рекомендация

  • Сведения

Ошибка

Сообщение ошибки означает наличие критической неполадки, для устранения которой требуется внести изменения. Например, к ошибке относится наличие отключенного экземпляра сервера или недоступного сервера.

Сведения об ошибках включаются в следующие отчеты:

  • Список «Критические проблемы»

  • Список «Все проблемы»

  • Список «Подробный отчет»

  • Список «Подробный отчет — все проблемы»

Если отключить причину вывода сообщения об ошибке, анализатор рекомендаций сервера Exchange выведет сведения о ней в списке «Отключенные проблемы».

Анализатор рекомендаций сервера Exchange обозначает ошибку знаком «X» красного цвета (рис. 1).

Рисунок 1. Значок ошибки

Значок состояния ошибки

Предупреждение

Предупреждение указывает на то, что какой-либо параметр отличается от рекомендуемого. Для устранения этой проблемы может потребоваться внести соответствующие изменения. Проблема также может относиться к числу известных, для которых необязательно вносить изменения в организацию Exchange Server. Например, предупреждение выводится, если на сервере не запущена одна из служб.

Предупреждения включаются в следующие отчеты:

  • Список «Все проблемы»

  • Список «Подробный отчет»

  • Список «Подробный отчет — все проблемы»

Если отключить причину появления сообщения предупреждения, анализатор рекомендаций сервера Exchange выведет сведения об этом предупреждении в списке «Отключенные проблемы».

Анализатор рекомендаций сервера Exchange обозначает предупреждение желтым значком предупреждения (рис. 2).

Рисунок 2. Значок предупреждения

Значок предупреждения — желтый треугольник с черным восклицательным знаком

Конфигурация, отличающаяся от заданной по умолчанию

Сообщение о конфигурации, отличающейся от заданной по умолчанию указывает, что было изменено значение параметра, заданное по умолчанию. Если анализатор рекомендаций сервера Exchange обнаруживает, что такая конфигурация ведет к возникновению ошибки или предупреждения, сообщение о конфигурации, отличающейся от заданной по умолчанию, сопровождается в отчете значком ошибки или предупреждения в дополнение к значку конфигурации, отличающейся от заданной по умолчанию.

Сообщения о конфигурации, отличающейся от заданной по умолчанию, включаются в следующие отчеты:

  • Список «Все проблемы»

  • Список «Подробный отчет»

  • Список «Подробный отчет — все проблемы»

Если отключить причину появления сообщения о конфигурации, отличающейся от заданной по умолчанию, анализатор рекомендаций сервера Exchange выведет сведения о такой конфигурации в списке «Отключенные проблемы».

Анализатор рекомендаций сервера Exchange обозначает сообщение о конфигурации, отличающейся от заданной по умолчанию, значком указателя на документ (рис. 3).

Рисунок. 3 Значок конфигурации, отличающейся от заданной по умолчанию

Значок нестандартных свойств

Недавнее изменение

Недавнее изменение указывает, что параметр изменялся в течение последних 5 дней. Анализатор рекомендаций сервера Exchange выводит сообщение о недавних изменений только для параметров, которые имеют свойство время последнего изменения. Если анализатор рекомендаций сервера Exchange обнаруживает, что недавнее изменение ведет к возникновению ошибки, предупреждения или конфигурации, отличающейся от заданной по умолчанию, сообщение о недавнем изменении сопровождается в отчете значком ошибки, предупреждения или конфигурации, отличающейся от заданной по умолчанию, в дополнение к значку недавнего изменения.

Сообщения о недавних изменениях включаются в следующие отчеты:

  • Список «Все проблемы»

  • Список «Подробный отчет»

  • Список «Подробный отчет — все проблемы»

Если отключить причину появления сообщения о недавнем изменении, анализатор рекомендаций сервера Exchange выведет сведения об этом изменении в списке «Отключенные проблемы».

Анализатор рекомендаций сервера Exchange обозначает недавнее изменение значком изменения карандашом (рис. 4).

Рисунок 4. Значок недавнего изменения

Значок последнего изменения

Базовое несовпадение

Сообщение о базовом несовпадении указывает на наличие параметра, значение которого отличается от значения этого параметра на основном сервере. Чтобы просмотреть базовые несовпадения, необходимо выполнить базовое сканирование. Если анализатор рекомендаций сервера Exchange обнаруживает, что базовое несовпадение ведет к возникновению ошибки, предупреждения или конфигурации, отличающейся от заданной по умолчанию, сообщение о базовом несовпадении сопровождаются значком ошибки, предупреждения или конфигурации, отличающейся от заданной по умолчанию, в дополнение к значку базового несовпадения.

Сообщения о базовых несовпадениях включаются в следующие отчеты:

  • Список «Все проблемы»

  • Список «Подробный отчет»

  • Список «Подробный отчет — все проблемы»

Если отключить причину появления сообщения о базовом несовпадении, анализатор рекомендаций сервера Exchange выведет сведения об этом базовом несовпадении в списке «Отключенные проблемы».

Анализатор рекомендаций сервера Exchange отмечает базовое несовпадение значком блокнота с флажком (рис. 5).

Рисунок 5. Значок базового несовпадения

Значок базового отчета в ExBPA

Рекомендация

Сообщение рекомендации указывает, что значение параметра отличается от рекомендуемого. Сообщения с рекомендациями не являются предупреждениями, поскольку такие значения не влияют на общую стабильность организации Exchange Server. Сообщения с рекомендациями содержат рекомендуемые действия. Если анализатор рекомендаций сервера Exchange обнаруживает, что сообщение с рекомендацией связано с недавним изменением или конфигурацией, отличающейся от заданной по умолчанию, это сообщение с рекомендацией сопровождаются значком недавнего изменения или конфигурации, отличающейся от заданной по умолчанию, в дополнение к значку сообщения с рекомендацией.

Сообщения с рекомендациями включаются в следующие отчеты:

  • Список «Все проблемы»

  • Список «Подробный отчет»

  • Список «Подробный отчет — все проблемы»

Если отключить причину появления сообщения с рекомендацией, анализатор рекомендаций сервера Exchange выведет сведения об этой рекомендации в списке «Отключенные проблемы».

Анализатор рекомендаций сервера Exchange обозначает сообщение с рекомендацией восклицательным знаком синего цвета (рис. 6).

Рисунок 6. Значок рекомендации

Значок оповещения о наличии рекомендации

Сведения

Сообщение типа сведения содержит сведения, которые не относятся ни к одному из других пяти типов отчетов анализатора рекомендаций сервера Exchange. Например, это могут быть сведения о количестве объектов Exchange Server в службе каталогов Active Directory®.

Сообщения со сведениями включаются в следующие отчеты:

  • Список «Подробный отчет»

  • Список «Подробный отчет — все проблемы»

Анализатор рекомендаций сервера Exchange обозначает сообщение со сведениями буквой «i» в нижнем регистре (рис. 7).

Рисунок 7 Значок сведений

Значок дополнительных сведений

См. также

Понятия

Настройка средства анализа Microsoft Exchange Server Best Practices Analyzer Tool

Другие ресурсы

Устранение и скрытие проблем

© 2007 Microsoft Corporation. Все права защищены.


Устранение и скрытие проблем
Обзор средства анализа Microsoft Exchange Server > Общие сведения о выходных данных средства анализатора рекомендаций для сервера Microsoft Exchange >

Дата последнего изменения раздела: 2006-02-08

После запуска анализатора рекомендаций для сервера Microsoft® Exchange в организации Exchange в отчете могут быть перечислены проблемы, требующие разрешения. Если щелкнуть проблему, отображается объяснение и три варианта действий:

  • Выберите первый вариант, чтобы найти более подробные сведения о проблеме и путях ее устранения.

  • Выберите второй вариант, чтобы скрыть проблему по этому серверу.

  • Выберите третий вариант, чтобы скрыть проблему по всем серверам. Проблемы, которые находятся в списке «Скрытые проблемы», не будут отображаться в списках «Критические проблемы» и «Все проблемы» в этом отчете и всех других просматриваемых отчетах. Чтобы просмотреть скрытые проблемы, перейдите к списку «Скрытые проблемы». Из списка «Скрытые проблемы» можно открыть проблемы, чтобы они снова отображались в списках «Критические проблемы» и «Все проблемы».

Анализатор рекомендации по серверу Exchange не вносит изменений в организацию Exchange, чтобы разрешить проблемы. Он только отображает информацию о том, как устранить эти проблемы.

В этом разделе

Виды выходных данных


Просмотр предыдущего отчета средства анализа рекомендаций по серверу Microsoft Exchange

Просмотр предыдущего отчета средства анализа рекомендаций по серверу Microsoft Exchange |
 | См. также
Обзор средства анализа Microsoft Exchange Server > Общие сведения о выходных данных средства анализатора рекомендаций для сервера Microsoft Exchange >

Дата последнего изменения раздела: 2005-07-08

Вместо выполнения нового сканирования можно воспользоваться средством анализа рекомендаций по серверу Microsoft® Exchange и просмотреть отчет по предыдущему сканированию.

Чтобы просмотреть предыдущий отчет

  1. Откройте анализатор рекомендаций по серверу Exchange, запустив программу ExBPA.exe.

  2. Укажите, нужно ли загрузить новейшие правила.

  3. На странице Добро пожаловать выберите Выберите для просмотра отчет с рекомендациями.

  4. Выберите нужный отчет из списка отчетов, хранимых на локальном компьютере.

    Средство создает список из файлов, хранимых в папке <системный_диск>\Documents and Settings\<пользователь>\Application Data\Microsoft\ExBPA. При выборе отчета средство отображает подробную информацию о размере и области охвата этого отчета. Выберите Просмотреть этот отчет, чтобы просмотреть полный отчет.

    Можно также импортировать отчет из другого места, щелкнув Импорт отчета в правом верхнем углу страницы. Если версия файла ExBPA.Config.xml не соответствует версии, используемой для сбора данных в импортированном отчете, средство может повторно проанализировать импортированный файл после импорта.

  5. Просмотрите отчет анализатора рекомендаций по серверу Exchange.

См. также

Другие ресурсы

Общие сведения о выходных данных средства анализатора рекомендаций для сервера Microsoft Exchange

© 2007 Microsoft Corporation. Все права защищены.


Влияние на производительность анализатора Best Practices Analyzer сервера Microsoft Exchange

Влияние на производительность анализатора Best Practices Analyzer сервера Microsoft Exchange |
 | См. также
Обзор средства анализа Microsoft Exchange Server >

Дата последнего изменения раздела: 2005-07-08

Средство анализатора Best Practices Analyzer сервера Microsoft® Exchange может повлиять на производительность следующих компьютеров в организации Exchange:

  • Компьютер, на котором выполняется анализатор Best Practices Analyzer сервера Exchange

  • Сервер, на котором выполняется служба каталогов Active Directory®

  • Серверы Exchange, к которым данное средство осуществляет доступ

Производительность компьютера, на котором выполняется анализатор Best Practices Analyzer сервера Exchange

Анализатор Best Practices Analyzer сервера Exchange использует следующие ресурсы компьютера, на котором он выполняется:

  • 5-10 МБ ОЗУ для каждого сервера, сканируемого анализатором

  • 50-75% загрузки процессора во время сканирования организации Exchange

  • 0,5-2 МБ места на диске для данных XML

Дополнительные сведения о выборе компьютера для установки и использования анализатора Best Practices Analyzer сервера Exchange см. в статье, посвященной Установка анализатора рекомендаций для сервера Microsoft Exchange.

Производительность на сервере Active Directory

Анализатор Best Practices Analyzer сервера Exchange использует следующие ресурсы сервера Active Directory:

  • 25-50% загрузки процессора при обращении анализатора к серверу Active Directory

Примечание.
Анализатор обращается к серверу Active Directory время от времени, с интервалами 10-15 секунд. В крупных организациях Exchange возможен больший интервал.

Производительность на серверах Exchange

Во время сканирования организации анализатором Best Practices Analyzer сервера Exchange существенного снижения производительности серверов Exchange не наблюдается.

Примечание.
Время сбора данных на сервере Exchange анализатором может быть разным в зависимости от загруженности сервера Exchange и быстродействия сети. В медленных сетях анализатору может потребоваться час или более для сбора данных. В быстрых сетях серверу необходимо менее 10 минут для сбора данных.

См. также

Понятия

Установка анализатора рекомендаций для сервера Microsoft Exchange

© 2007 Microsoft Corporation. Все права защищены.


Использование средства анализа рекомендаций по серверу Microsoft Exchange, работающего в режиме командной строки

Использование средства анализа рекомендаций по серверу Microsoft Exchange, работающего в режиме командной строки |
 | См. также
Обзор средства анализа Microsoft Exchange Server >

Дата последнего изменения раздела: 2005-07-08

Доступна версия средства анализа рекомендаций по серверу Microsoft® Exchange, работающая в режиме командной строки. Исполняемый файл программы, работающей в режиме командной строки — это ExBPACmd.exe, установленный в каталоге <системный_диск>\Program Files\ExBPA, в котором установлена версия графического пользовательского интерфейса. В некоторых случаях может возникнуть желание использовать вместо версии графического пользовательского интерфейса программу, функционирующую в режиме командной строки. Например, программу с интерфейсом командной строки можно использовать для создания сценария, запускающего сканирования по расписанию. Еще одним примером может служить ситуация, когда представители службы поддержки продуктов Майкрософт просят запустить программу, работающую в режиме командной строки, для решения возникшей проблемы.

Синтаксис ExBPACmd.exe

Применение: ExBPACmd.exe [-cfg <XML-конфигурация>] [-dat <XML-данные>] [-d <имя контроллера домена>] [-n <имя>] [-u <контекст> <[домен\]пользователь> <пароль | *> ...] [-rs <диапазон> <sub1> ...] [-rc <категория>,...] [-rl <уровень>] [-th <максимальное число потоков>] [-to <тайм-аут>] [-a] [-c] [-e] [-?]

-cfg: Задает XML-файл конфигурации, который определяет, какие настройки будут извлекаться. Значение по умолчанию — ExBPA.Config.xml.

-dat: Указывает используемый XML-файл данных. Если указать имя XML-файла данных, которого нет в текущем каталоге, средство использует указанное имя файла для выходного файла. Если указать имя существующего XML-файла данных, когда выполняется сканирование с целью анализа данных, средство прочтет данные, собранные в указанном файле, проанализирует эти данные и перезапишет в указанный файл результаты сканирования. Если указать имя существующего XML-файла данных, когда выполняется сканирование с целью сбора данных, средство перезапишет в указанный файл результаты сканирования.

Если выполняется сканирование с целью анализа данных, значение по умолчанию — это выход.<ов>.xml, где <ов> — это последняя отметка времени в текущем каталоге. Если выполняется сканирование с целью сбора данных, значение по умолчанию — это выход.<ов>.xml, где <ов> — новая отметка времени.

-d: Указывает контроллер домена, используемый для доступа к службе каталогов Active Directory®. По умолчанию средство использует ближайший сервер службы Active Directory.

-n: Предоставляет описательное имя клиента, топологию которого сканирует программное средство.

-u: Предоставляет отдельные учетные данные в зависимости от контекста.

Допустимые контексты пользователей: ADLOGON для учетных данных, используемых для входа в Active Directory, или EXLOGON для учетных данных, используемых для входа на серверы Exchange.

-rs: Ограничивает сканирование только объектами, входящими в указанные диапазоны. Поля <sub> — это значения указываемого диапазона. Если переключатель -rs не используется, сканирование будет охватывать всю организацию Exchange. Если переключатель -rs используется, можно ограничить сканирование административными группами или серверами. Допускается указывать одну или несколько административных групп либо один или несколько серверов.

Допустимые диапазоны: AdminGroup, Server

-rc: Ограничивает сканирование только параметрами и объектами, которые соответствуют указанным категориям. XML-файл конфигурации определяет категории параметров и объектов. Если переключатель -rc используется для ограничения сканирования одной категорией, будут сканироваться только параметры, для которых определена эта категория. С помощью этого переключателя можно включить несколько категорий.

Допустимые категории, которые используются с переключателем -rc, могут варьироваться для разных версий XML-файла конфигурации. Чтобы определить категории, которые допустимы для применяемой версии XML-файла конфигурации, выполните команду ExBPACmd.exe -?.

-rl: Ограничивает сканирование только параметрами и объектами с указанным или меньшим уровнем детализации. XML-файл конфигурации определяет уровни детализации параметров и объектов. Значение по умолчанию равно 4.

Допустимые уровни, которые можно использовать с переключателем -rl, могут варьироваться в зависимости от версии XML-файла конфигурации. Чтобы определить уровни, которые допустимы для применяемой версии XML-файла конфигурации, выполните команду ExBPACmd.exe -?.

-th: Устанавливает максимальное количество одновременно выполняемых потоков. Значение по умолчанию равно 25.

-to: Устанавливает время по умолчанию (в секундах), в течение которого программное средство ожидает, пока данные будут собраны с сервера в организации Exchange. Значение по умолчанию равно 300 секундам.

-a: Анализ XML-файла данных с помощью правил из XML-файла конфигурации. Этот параметр можно использовать для анализа существующего выходного файла, который является результатом сканирования данных, посредством указания применяемого XML-файла данных. Этот параметр можно также использовать, чтобы собрать и проанализировать данные для нового сканирования путем указания XML-файла данных, находящегося вне текущего каталога, или без указания XML-файла данных.

-c: Сбор данных из организации Exchange, которая указана в XML-файле конфигурации. Программное средство не анализирует данные с помощью правил из XML-файла конфигурации, а только собирает данные. Если не заданы ни анализ (-a), ни сбор данных (-c), этот параметр будет включен по умолчанию.

-e: Указывает, что программное средство должно удалить значения всех параметров, которые помечены как NotForExport в XML-файле конфигурации.

-? Отображает сведения по синтаксису.

См. также

Другие ресурсы

Сканирование организации Exchange с помощью средства анализа рекомендаций по серверу Microsoft Exchange

© 2007 Microsoft Corporation. Все права защищены.


Анализатор сервера Microsoft Exchange — статьи

Дата последнего изменения раздела: 2006-10-06

Статьи этого раздела соответствуют правилам и сообщениям, созданным следующими средствами анализа Microsoft® Exchange:

  • анализатором соответствия рекомендациям для Exchange;

  • помощником по устранению неполадок Exchange.

Помощник по устранению неполадок Exchange обеспечивает доступ к следующим функциям:

  • средству диагностики проблем производительности Exchange;

  • средству устранения неисправностей баз данных Exchange;

  • средству управления восстановлением баз данных Exchange;

  • средству диагностики неполадок потока почты Exchange.

В каждой статье описывается одна ошибка, одно предупреждение или одно сообщение о нестандартной конфигурации, которые могут быть обнаружены анализатором сервера Exchange.

На веб-странице средств анализа Microsoft Exchange по адресу http://go.microsoft.com/fwlink/?linkid=34707 (на английском языке) содержатся материалы для загрузки для текущих версий анализатора соответствия рекомендациям для Exchange и помощника по устранению неполадок Exchange. Кроме того, на этой странице содержатся сведения о требованиях к системе и ссылка на группу новостей для обсуждения характеристик средств анализа.

При работе в среде, в которой невозможно использовать функцию автоматического обновления анализатора соответствия рекомендациям для Exchange, посетите страницу пакета обновления анализатора соответствия рекомендациям для Exchange через Интернет по адресу http://go.microsoft.com/fwlink/?linkid=34290. С этой страницы можно загрузить самую последнюю конфигурацию и файлы справки.

Примечание.
Если обновления применяются автоматически, их не нужно загружать с веб-страницы.


Active Directory
Анализатор сервера Microsoft Exchange — статьи >

Дата последнего изменения раздела: 2005-11-17

Статьи этого раздела содержит подробные сведения о возможностях средства анализа Microsoft® Exchange Server по отношению к службе каталога Active Directory. Кроме того, эти статьи описывают действия, которые можно предпринять для устранения неполадок, связанных с Active Directory, предупреждениях и нестандартных настройках, найденных средством анализа Exchange Server.


Сервер соединителя Active Directory остановлен или недоступен
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализа Microsoft® Exchange Server использует удаленный вызов процедур (RPC) для считывания значения строки CurrentVersion из следующего раздела реестра сервера соединителя Active Directory (ADC):

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Для компьютера, на котором работает Microsoft Windows® 2000 Server, значение строки CurrentVersion должно быть 5.0. Для компьютера, на котором работает Microsoft Windows Server™ 2003, должно быть значение 5.2.

Если средство анализа Exchange Server по какой-либо причине не может считать значение реестра, появляется сообщение об ошибке.

Устранение ошибки

  1. Убедитесь в том, что сервер ADC запущен и подключен к сети.

  2. Воспользуйтесь командой PING, чтобы определить, доступен ли сервер.

  3. Если используется брандмауэр, проверьте, не заблокированы ли порты RPC.

  4. Убедитесь в том, что на сервере ADC запущена служба удаленного реестра.

  5. Проверьте разрешения учетной записи, под которой работает анализатор сервера Exchange, убедитесь в том, что они достаточны для считывания реестра сервера ADC.

Для получения дополнительных сведений по устранению неполадок, связанных с сетевыми подключениями, ознакомьтесь со следующими материалами:

  • Статья 325487 базы знаний корпорации Майкрософт «Разрешение проблем, связанных с выполнением сетевого подключения» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

  • «Устранение неполадок с сетевыми подключениями в работе средства анализа Exchange Server» (http://go.microsoft.com/fwlink/?LinkId=56285)


Сервер Active Directory Connector не выполняет никакие соглашения о соединении и может быть удален
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchChildSyncAgreements, представляющего соглашения о соединении, выполняемые на сервере Active Directory Connector (ADC). Этот атрибут представляет собой строку с несколькими значениями и задается в следующем объекте Active Directory: CN=Active Directory Connector (ServerName),CN=Exchange Settings,CN=ServerName,CN=Servers,CN=SiteName,CN=Sites,CN=Configuration,DC=Domain,DC=com

Анализатор сервера Exchange извлекает количество записей (счетчик) в этом атрибуте. Если это количество равно 0, значит не выполняется ни одно соглашение о соединении, и отображается предупреждение.

Если определено, что все необходимые соглашения о соединении выполняются на других серверах ADC, следует удалить или отключить службу ADC на этом сервере. Работа службы ADC без соглашений о соединении не приводит к неполадкам. Однако рекомендуется не запускать службы, если они не требуются. Поэтому следует либо отключить службу ADC, либо удалить ее с этого сервера ADC.

Чтобы устранить причину появления этого предупреждения

  1. Чтобы отключить службу ADC на сервере, на котором выполняется служба ADC, щелкните правой кнопкой мыши Мой компьютер на рабочем столе и выберите команду Управление.

  2. Разверните узел Службы и приложения и щелкните узел Службы.

  3. В правой области щелкните правой кнопкой мыши Соединитель Microsoft Active Directory Connector и выберите команду Свойства.

  4. Измените значение Тип запуска на Отключено. В следующий раз при запуске компьютера служба ADC не будет запущена.

  5. Нажмите кнопку Применить, а затем — ОК.

Чтобы удалить службу ADC, можно использовать компакт-диск Microsoft Exchange 2000 Server или Exchange Server 2003. Откройте папку \ADC\I386 и дважды щелкните программу Setup.exe. Следуйте инструкциям для удаления службы ADC.

Для получения дополнительных сведений о соединителе Active Directory обратите внимание на следующие веб-трансляции службы технической поддержки продуктов корпорации Майкрософт:

  • Веб-презентация службы поддержки Майкрософт, посвященная знакомству с функциями соединителя Active Directory Connector (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325300).

  • Веб-презентация службы поддержки Майкрософт, посвященная подробному описанию соединителя Microsoft Active Directory Connector (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325221).

  • Дополнительные сведения об установке и настройке соединителя Active Directory Connector см. в базе знаний Майкрософт в статье 312632, содержащей инструкции по установке и настройке службы Active Directory Connector в Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=312632).


На сервере Active Directory Connector не установлен новейший пакет обновления для Windows 2000 Server
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_OperatingSystem, чтобы определить значение ключа ServicePackMajorVersion на сервере Active Directory Connector (ADC). Анализатор сервера Exchange также считывает следующий раздел реестра, чтобы определить версию Windows, под управлением которой работает сервер ADC:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Если анализатор сервера определяет, что сервер ADC работает под управлением операционной системы Microsoft Windows 2000 Server, но на компьютере не установлен пакет обновления 4 (SP4) для Windows 2000 Server, отображается предупреждение.

Корпорация Майкрософт рекомендует установить новейшие пакеты обновления для всех программ, относящихся к Exchange, включая серверы ADC.

Чтобы устранить эту ошибку

  1. Установите на сервер ADC и на все другие компьютеры, работающие под управлением операционной системы Windows 2000 Server, пакет обновления 4 и новейшие обновления и экстренные исправления с веб-узла Windows Update.

  2. Установите новейший пакет обновления и новейшие исправления на все остальные компьютеры Exchange Server, работающие под управлением операционной системы Windows 2000 Server.

Чтобы ознакомиться с дополнительными сведениями о получении и установке пакетов обновления для операционных систем Windows 2000 Server, см. http://go.microsoft.com/fwlink/?LinkId=18353.

Чтобы ознакомиться с дополнительными сведениями о получении и установке пакетов обновления и исправлений для Exchange Server, см. http://go.microsoft.com/fwlink/?LinkId=21573.


Возможно, сервер Active Directory Connector перегружен
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Для определения значений атрибута msExchChildSyncAgreements, представляющего соглашения о подключении, используемые на сервере Active Directory Connector (ADC), средство анализа Microsoft® Exchange Server Analyzer Tool направляет запрос службе каталогов Active Directory®. Этот атрибут является многозначной строкой, представляющей набор следующих объектов Active Directory: CN=Active Directory Connector (ServerName),CN=Exchange Settings,CN=ServerName,CN=Servers,CN=SiteName,CN=Sites,CN=Configuration,DC=Domain,DC=com

Exchange Server Analyzer получает число записей в этом атрибуте. Если это число больше 80, отображается предупреждение.

Рекомендуется работать не более чем с 80 подключениями на одном сервере ADC. Если дополнительные севреры ADC обслуживают максимальное рекомендуемое число соглашений о подключении, перенесите несколько соглашений о подключении с этих серверов на другие серверы ADC. Если другие серверы ADC отсутствуют, установите программу ADC, поставляемую вместе с Microsoft Exchange 2000 Server или Exchange Server 2003, на другой компьютер, работающий под управлением Microsoft Windows® 2000 Server или Windows Server™ 2003.

При перемещении соглашения о подключении с одного сервера ADC на другой основные параметры индивидуального соглашения о подключении не изменяются. Например, контейнеры источника и назначения, используемые при репликации, а также данные, настроенные для репликации, остаются неизменными. При перемещении соглашения о подключении изменяется только сервер ADC, обслуживавший соглашение о подключении.

Для устранения этого предупреждения

  1. Нажмите кнопку Пуск, выберите пункт меню Программы, выберите пункт Администрирование, затем выберите пункт меню Active Directory Connector Management для открытия консоли ADC Management.

  2. Левая панель консоли MMC отображает список серверов, использующих службы ADC. Выберите ADC для сервера, на котором расположено соглашение о подключении, которое нужно перенести.

  3. Панель «Сведения» консоли MMC отображает соглашения о подключении, обслуживаемые выбранным сервером ADC.

  4. Правой кнопкой мыши щелкните соглашение о подключении, которое нужно перенести, и выберите пункт меню Свойства.

  5. На вкладке Общие в списке Выбор сервера для запуска Соглашения о подключении выберите сервер, на котором нужно запустить это соглашение о подключении, и нажмите кнопку OK.

  6. В поле Подключить как (Windows Server)введите имя и пароль учетной записи службы ADC, затем нажмите кнопку OK.

  7. В поле Подключить как (Exchange Server) введите имя и пароль учетной записи службы Exchange, затем нажмите кнопку OK.

Для получения дополнительных сведений о перемещении соглашений о подключении см. статью 326060 базы знаний Microsoft «XADM: Перенос соглашения о подключении на другой сервер» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326060).

Для получения дополнительных сведения об установке программы Exchange 2000 Server ADC на другой сервер см. статью 312632 базы знаний Microsoft «Установка и настройка службы Active Directory Connector в Exchange 2000 Server» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=312632).

Для получения дополнительных сведений об установке программы ADC Exchange Server 2003 на другой сервер см. Руководство по развертыванию Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).


Необходимо обновить программу Active Directory Connector
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2006-10-10

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version для Adc.exe — файла соединителя Active Directory Connector (ADC). WMI-ключ Version указывает номер сборки для этого файла.

Анализатор сервера Exchange также запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msDS-Behavior-Version объекта леса в параметрах NTDS службы каталогов Active Directory. Это значение отражает функциональный уровень леса Active Directory. Допустимые значения атрибута msDS-Behavior-Version представлены в следующей таблице.

Значение | Функциональный уровень леса
0 | Microsoft Windows 2000 Server, смешанный режим
1 | Windows Server™ 2003, промежуточный режим
2 | Windows Server 2003, основной режим

Если анализатор сервера Exchange обнаруживает, что номер сборки для Adc.exe на компьютере, работающем под управлением сервера Exchange в лесу Active Directory в промежуточном или основном режиме Windows Server 2003, меньше 6.0.6615.0, отображается сообщение об ошибке. Это сообщение об ошибке указывает, что версия программы ADC для Exchange 2000 Server выполняется при несовместимом функциональном уровне леса Windows Server 2003 Active Directory. Для решения этой проблемы требуется обновление программы Exchange Active Directory Connection (ADC).

Использование более старой версии ADC при смешанном или основном функциональном уровне леса может привести к неполному обновлению каталогов и потере данных. Рекомендуется выполнить обновление до последней версии ADC для сервера Exchange Server 2003 на всех компьютерах организации.

Загрузить новейшую версию ADC, а также пакеты обновлений Exchange 2003 Server можно с веб-страницы файлов для загрузки сервера Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=25097 (на английском языке). Кроме того, можно установить финальную версию программы ADC для сервера Exchange Server 2003 с компакт-диска сервера Exchange Server.

Чтобы выполнить обновление до новейшей версии ADC

  1. На сервере, на котором выполняется более старая версия ADC, нажмите кнопку Пуск, выберите команду Выполнить и введите E:\setup\adc\i386\setup.exe, где E — местоположение загружаемых файлов пакета обновления Exchange Server.

  2. На первой странице мастера установки Active Directory Connector нажмите кнопку Далее.

  3. На странице Обнаружена предыдущая установка щелкните Переустановить, чтобы обновить ADC.

  4. На странице завершения работы мастера установки Active Directory Connector нажмите кнопку Готово.

Дополнительные сведения о влиянии функционального уровня леса на работу соединителя ADC см. в базе знаний Майкрософт в статье 825916, посвященной описанию ситуации, когда соединителю Exchange 2000 Active Directory Connector не удается выполнить репликацию изменений членства в группах в службе каталогов Windows Server 2003 Active Directory при функциональных уровнях леса 1 или 2 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=825916).

Дополнительные сведения о функциональных уровнях домена и леса см. в статье базы знаний 322692, содержащей инструкции по повышению функциональных уровней домена и леса в Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322692).


Лес Active Directory был настроен для среды Hosted Exchange
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить значение атрибута LinkID для каждого объекта атрибута схемы Global-Address-List. Объект Global-Address-List используется с контейнером Exchange для хранения различающегося имени созданного глобального списка адресов.

Если анализатор сервера Exchange обнаружит, что значение атрибута LinkID объекта Global-Address-List равно 4048, анализатор сервера Exchange отобразит сообщение о нестандартной конфигурации. Значение 4048 означает, что лес Active Directory настроен для работы со средой Hosted Exchange.

Анализатор сервера Exchange отображает эту конфигурацию только для сведений. Никаких действий выполнять не требуется.

Дополнительные сведения о средах Hosted Exchange см. в следующих статьях:

  • "статья, посвященная сведениям о средах размещения (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=46307);

  • глава 23, посвященная средам служб размещения, в наборе ресурсов для Exchange Server 2000(http://go.microsoft.com/fwlink/?LinkId=46326).


Сервер Active Directory остановлен или недоступен
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализа Microsoft® Exchange Server использует удаленные вызовы процедур (RPC) для считывания значения строки CurrentVersion из следующего раздела реестра сервера каталога Active Directory®:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Для компьютера, на котором работает Microsoft Windows® 2000 Server, значение строки CurrentVersion должно быть 5.0. Для компьютера, на котором работает Windows Server™ 2003, должно быть значение 5.2.

Если средство анализа Exchange Server по какой-либо причине не может считать значение реестра, появляется сообщение об ошибке.

Устранение ошибки

  1. Убедитесь в том, что сервер каталога запущен и подключен к сети.

  2. Воспользуйтесь командой PING, чтобы определить, доступен ли сервер.

  3. Если используется брандмауэр, проверьте, не заблокированы ли порты RPC.

  4. Убедитесь в том, что на сервере каталога запущена служба удаленного реестра.

  5. Проверьте разрешения учетной записи, под которой работает средство анализа Exchange Server, убедитесь в том, что они достаточны для считывания реестра сервера Active Directory.

Для получения дополнительных сведений по устранению неполадок, связанных с сетевыми подключениями, воспользуйтесь следующими источниками:

  • Статья 325487 базы знаний корпорации Майкрософт «Разрешение проблем, связанных с выполнением сетевого подключения» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)

  • Статья, «Устранение наиболее часто встречающихся неполадок в работе средства анализа Microsoft® Exchange Server, связанных с сетевыми подключениями» (http://go.microsoft.com/fwlink/?LinkId=56285)


Объем памяти сервера Active Directory меньше 1 ГБ, однако для него установлены переключатели /3GB и /USERVA=3030 в файле Boot.ini
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Анализатор сервера Microsoft® Exchange запрашивает два класса инструментария управления Windows (WMI), чтобы определить объем физической памяти на сервере Active Directory® и объем виртуального адресного пространства, выделенного для процессов пользовательского режима. В следующей таблице описываются классы и ключи, оцениваемые анализатором сервера Exchange.

Класс | Ключ | Описание
Win32_OperatingSystem | MaxProcessMemorySize | Максимальное количество килобайт памяти, которая может быть выделена для процесса.
Win32_OperatingSystem | OSProductSuite | Установленные и лицензированные дополнения системных продуктов для операционной системы.
Win32_ComputerSystem | TotalPhysicalMemory | Объем оперативной памяти (ОЗУ), установленной на компьютере.

Если анализатор сервера Exchange определяет, что объем ОЗУ сервера каталогов меньше 950 МБ и что значение MaxProcessMemorySize больше 2097024, но меньше 3104640, на экран выводится предупреждение.

Это предупреждение указывает, что сервер каталогов настроен неправильно для оптимального использования памяти по двум причинам.

  • Установлен ключ запуска /USERVA=3030. Этот ключ применяется только на компьютерах сервера Exchange, имеющих память объемом 1 ГБ и более и работающих под управлением операционной системы Microsoft Windows Server™ 2003.

  • Установлен ключ запуска /3GB. Этот ключ следует использовать только на серверах Exchange, имеющих память объемом 1 ГБ или более и работающих под управлением любой из следующих операционных систем:

    • Microsoft Windows Server 2003 Standard Edition

    • Microsoft Windows Server 2003 Enterprise Edition

    • Microsoft Windows Server 2003 Datacenter Edition

    • Microsoft Windows 2000 Advanced Server

    • Microsoft Windows 2000 Datacenter Server

Важно!
Ключ /3GB не должен использоваться в Windows 2000 Server, так как он не поддерживается и может быть причиной отказов приложений или операционной системы. Более того, ключ /3GB поддерживается указанными выше операционными системами только в том случае, если на компьютере установлена физическая память объемом 1 ГБ и более.

Если данное предупреждение выводится для системы, в которой установлена физическая память объемом 1 ГБ, это может указывать на то, что другому компоненту, например, видеоадаптеру, выделена часть этой физической памяти на аппаратном уровне, в связи с этим выделенная физическая память становится недоступной для операционной системы. В таких случаях объем установленной физически памяти согласно данным Windows будет меньше фактического объема физической памяти, установленной на компьютере. Если возникнет данная ситуация, следует сравнить объем установленной памяти, сообщаемой средствами BIOS, с объемом установленной памяти, сообщаемой системой Windows.

Чтобы устранить причины появления этого предупреждения в Windows Server 2003

  1. Щелкните правой кнопкой мыши Мой компьютер и в контекстном меню выберите Свойства. Появится диалоговое окно Свойства системы.

  2. Щелкните Дополнительно.

  3. В области «Загрузка и восстановление» щелкните Параметры. Появится диалоговое окно Загрузка и восстановление.

  4. В области «Загрузка операционной системы» щелкните Изменить. В результате этих действий в программе «Блокнот» откроется файл Boot.ini операционной системы Windows.

  5. В части [Operating Systems] (операционные системы) удалите из всех строк загрузки следующий ключ: /3GB /USERVA=3030

  6. Сохраните изменения и закройте Блокнот.

  7. Нажмите два раза кнопку OK, чтобы закрыть открытые диалоговые окна, и затем перезапустите компьютер, чтобы изменение вступило в силу.

Чтобы устранить причины появления этого предупреждения в Windows 2000 Server

  1. В проводнике Windows перейдите к системному разделу.

  2. Если файл Boot.ini не виден, возможно, в свойствах папки установлена настройка Скрывать защищенные системные файлы. Если это так, в проводнике Windows в меню Сервис выберите команду Свойства папки, а затем откройте вкладку Вид. Снимите флажок Скрывать защищенные системные файлы (рекомендуется). Когда появится окно предупреждения, щелкните Да.

  3. Если файл Boot.ini виден в проводнике Windows, щелкните правой кнопкой мыши этот файл, выберите в контекстном меню команду Открыть с помощью и щелкните Блокнот, чтобы открыть файл.

  4. В разделе [Operating Systems] удалите из всех строк запуска следующий ключ: /3GB /USERVA=3030

  5. Сохраните изменения и закройте Блокнот.

  6. Перезагрузите компьютер, чтобы изменение вступило в силу.

Дополнительные сведения об использовании ключей запуска /3GB и /USERVA см. в следующих статьях базы знаний Майкрософт:

  • 308356, описывающей использование памяти процессом Lsass.exe на контроллерах доменов, работающих под управлением Windows Server 2003 или Windows 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)

  • 297812, описывающей функцию настройки ОЗУ, 4GT (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, описывающей влияние настройки 4GT на системные элементы таблицы страниц (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739, описывающей использование переключателя /USERVA в файле Boot.ini для настройки конфигураций с переключателем /3GB (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044, инструкции по устранению проблем, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, описывающей оптимизацию использования памяти в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Объем памяти сервера Active Directory меньше 1 ГБ, однако для него установлен переключатель /3GB в файле Boot.ini
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает два WMI-класса (Microsoft Windows® Management Instrumentation), чтобы определить объем физической памяти на сервере Active Directory® и объем виртуального адресного пространства, выделенного для процессов пользовательского режима. В следующей таблице описываются классы и ключи, оцениваемые анализатором сервера Exchange.

Класс | Ключ | Описание
Win32_OperatingSystem | MaxProcessMemorySize | Максимальное количество килобайтов памяти, которая может быть выделена для процесса.
Win32_OperatingSystem | OSProductSuite | Установленные и лицензированные дополнения системных продуктов для операционной системы.
Win32_ComputerSystem | TotalPhysicalMemory | Количество байтов памяти с произвольной выборкой (ОЗУ), установленной на компьютере.

Если анализатор сервера Exchange определит, что сервер каталогов имеет меньше 950 МБ ОЗУ, и что значение MaxProcessMemorySize больше 2097024, но меньше 3104640, на экран будет выведено предупреждение.

Это предупреждение указывает, что сервер каталогов настроен неправильно для оптимального использования памяти. На этом компьютере установлен переключатель загрузки /3GB, который необходимо удалить. Этот переключатель следует использовать только на серверах Active Directory, имеющих память объемом 1 ГБ или более и работающих под управлением любой из следующих операционных систем:

  • Microsoft Windows Server™ 2003 Standard Edition,

  • Microsoft Windows Server™ 2003 Enterprise Edition,

  • Microsoft Windows Server 2003 Datacenter Edition,

  • Microsoft Windows 2000 Advanced Server,

  • Microsoft Windows 2000 Datacenter Server.

Важно!
Переключатель /3GB не должен использоваться в Windows 2000 Server, так как он не поддерживается и может быть причиной отказов приложений или операционной системы. Более того, переключатель /3GB поддерживается указанными выше операционными системами только в том случае, если на компьютере установлена физическая память объемом 1 ГБ и более.

Если данное предупреждение выводится для системы, в которой установлена физическая память объемом 1 ГБ, это может указывать на то, что другому компоненту, например, видеоадаптеру, выделена часть этой физической памяти на аппаратном уровне, в связи с этим выделенная физическая память становится недоступной для операционной системы. В таких случаях объем установленной физически памяти согласно данным Windows будет меньше фактического объема физической памяти, установленной на компьютере. Если возникнет данная ситуация, следует сравнить объем установленной памяти, сообщаемой средствами BIOS, с объемом установленной памяти, сообщаемой системой Windows.

Чтобы устранить причины появления этого предупреждения в Windows Server 2003

  1. Щелкните правой кнопкой мыши Мой компьютер и в контекстном меню выберите Свойства. Появится диалоговое окно Свойства системы.

  2. Щелкните Дополнительно.

  3. В области «Загрузка и восстановление» щелкните Параметры. Появится диалоговое окно Загрузка и восстановление.

  4. В области «Загрузка операционной системы» щелкните Изменить. В результате этих действий в «Блокноте» откроется файл Boot.ini операционной системы Windows.

  5. В части [Operating Systems] (операционные системы) удалите из всех строк загрузки следующий переключатель: /3GB

  6. Сохраните изменения и закройте «Блокнот».

  7. Нажмите два раза кнопку OK, чтобы закрыть открытые диалоговые окна, и затем перезапустите компьютер, чтобы изменение вступило в силу.

Чтобы устранить причины появления этого предупреждения в Windows 2000 Server

  1. В проводнике Windows перейдите к системному разделу.

  2. Если файл Boot.ini не виден, возможно, в свойствах папки установлена настройка Скрывать защищенные системные файлы. Если это так, в проводнике Windows последовательно щелкните Сервис, Свойства папки, а затем щелкните Вид. Снимите флажок Скрывать защищенные системные файлы (рекомендуется). Когда появится окно предупреждения, щелкните Да.

  3. Если файл Boot.ini виден в проводнике Windows, щелкните правой кнопкой мыши этот файл, выберите в контекстном меню команду Открыть с помощью и щелкните Блокнот, чтобы открыть файл.

  4. В части [Operating Systems] (операционные системы) удалите из всех строк загрузки следующий переключатель: /3GB

  5. Сохраните изменения и закройте «Блокнот».

  6. Перезагрузите компьютер, чтобы изменение вступило в силу.

Дополнительные сведения об использовании переключателя загрузки /3GB см. в следующих статьях базы знаний Майкрософт:

  • 308356, описывающая использование памяти процессом Lsass.exe на контроллерах доменов, работающих под управлением Windows Server 2003 или Windows 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)

  • 297812, описывающая функцию настройки ОЗУ, 4GT (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, описывающая влияние настройки 4GT на системные элементы таблицы страниц (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739, описывающая использование переключателя /USERVA в файле Boot.ini для настройки конфигураций с переключателем /3GB (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044, описывающая инструкции по устранению проблем, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkId=3052&kbid=325044).

  • 815372, описывающая оптимизацию использования памяти в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkId=3052&kbid=815372)


Сервер Active Directory работает под управлением Windows 2000 Server и для него установлен переключатель /3GB
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_OperatingSystem , чтобы определить объем виртуального адресного пространства (MaxProcessMemorySize), выделенного для процессов, выполняемых в пользовательском режиме, и чтобы узнать версию операционной системы Windows (OSProductSuite), под управлением которой работает сервер службы каталогов Active Directory®. В следующей таблице описываются классы и ключи, оцениваемые анализатором сервера Exchange.

Если анализатор сервера Exchange определит, что значение ключа MaxProcessMemorySize равно 3104640, и что значение ключа OSProductSuite соответствует операционной системе Windows 2000 Server, на экран будет выведено сообщение об ошибке.

Это сообщение об ошибке указывает, что на сервере каталогов, работающем под управлением Microsoft Windows 2000 Server, в файле Boot.ini установлен переключатель загрузки /3GB. Данный переключатель не поддерживается операционной системой Windows 2000 Server и должен использоваться только на компьютерах, оснащенных памятью объемом 1 ГБ или более и работающих под управлением любой из следующих операционных систем:

  • Microsoft Windows Server™ 2003 Standard Edition,

  • Microsoft Windows Server 2003 Enterprise Edition,

  • Microsoft Windows Server 2003 Datacenter Edition,

  • Microsoft Windows 2000 Advanced Server,

  • Microsoft Windows 2000 Datacenter Server.

Чтобы удалить переключатель /3GB из файла Boot.ini

  1. В проводнике Windows перейдите к системному разделу.

  2. Если файл Boot.ini не виден, возможно, в свойствах папки установлен флажок Скрывать защищенные системные файлы. Если это так, в проводнике Windows в меню Сервис выберите команду Свойства папки, а затем откройте вкладку Вид. Снимите флажок Скрывать защищенные системные файлы (рекомендуется). Когда появится окно предупреждения, нажмите Да.

  3. Если файл Boot.ini виден в проводнике Windows, щелкните правой кнопкой мыши этот файл, выберите в контекстном меню команду Открыть с помощью и щелкните Блокнот, чтобы открыть файл.

  4. В разделе [Operating Systems] (операционные системы) удалите из всех строк загрузки следующий переключатель: /3GB /USERVA=3030

  5. Сохраните изменения и закройте блокнот.

  6. Перезагрузите сервер каталогов, чтобы изменение вступило в силу.

Дополнительные сведения об использовании переключателя загрузки /3GB см. в следующих статьях базы знаний Майкрософт:

  • статья 297812, описывающая функцию настройки ОЗУ, 4GT (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812);

  • статья 311901, описывающая влияние настройки 4GT на системные элементы таблицы страниц (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901);

  • статья 316739, описывающая использование переключателя /USERVA в файле Boot.ini для настройки конфигураций с переключателем /3GB (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739);

  • статья 325044, посвященная устранению проблем, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044);

  • статья 815372, описывающая оптимизацию использования памяти в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372).


Недоступен реестр сервера Active Directory
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализа Microsoft® Exchange Server считывает следующий параметр реестра каждого контроллера домена:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion\CurrentVersion

Если средство анализа Exchange Server не может прочесть значение элемента реестра по какой-либо причине, выдается сообщение об ошибке.

Для устранения этой ошибки

  1. Убедитесь, что контроллер домена загружен и подключен к сети.

  2. Доступность контроллера домена проверяется командой PING.

  3. Если установлен брандмауэр, проверьте, не заблокированы ли порты удаленного вызова процедур (RPC).

  4. Убедитесь, что на контроллере домена запущена служба Remote Registry.

  5. Проверьте разрешения учетной записи, под которой запущен средство анализа Exchange Server. Учетная запись, под которой запускается средство анализа Exchange Server, должна иметь полномочия администратора на каждом проверяемом им контроллере домена.

Для получения дополнительных сведений об устранении неполадок, связанных с подключением, см. следующие материалы:

  • Статья 325487 базы знаний Microsoft «Устранение неполадок с сетевыми подключениями» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)

  • «Устранение неполадок с сетевыми подключениями при работе со средством анализа Microsoft® Exchange Server» (http://go.microsoft.com/fwlink/?LinkId=56285)

Для получения дополнительных сведений о требованиях к портам см. статью 832017 базы знаний «Обзор служб и требования к сетевым портам системы Windows Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Доступно обновление программного обеспечения для сервера Active Directory
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2007-02-20

Средство анализа Exchange запрашивает класс WMI Exchange_DSAccessDC из пространства имен ROOT\MicrosoftExchangeV2, чтобы определить значение свойства Name. Свойство Name определяет имя контроллера домена, используемого сервером Exchange Server для поиска данных в службе каталогов Active Directory.

Затем средство анализа Exchange запрашивает у службы Active Directory значения конкретных атрибутов этого контроллера домена для получения следующих сведений:

  • Работает ли контроллер домена Active Directory под управлением операционной системы Windows Server 2003.

  • Работает ли контроллер домена Active Directory под управлением неанглоязычной версии Microsoft Windows Server 2003.

  • Есть ли в организации Exchange сервер Microsoft Exchange Server 2007.

  • Имеет ключ Version файла ntdsa.dll на сервере значение меньше 2700.

Если средство анализа Exchange обнаруживает, что все эти условия выполняются, выводится предупреждение.

Это предупреждение свидетельствует о том, что клиенты Exchange Outlook Web Access могут столкнуться с проблемами при индексации адресной книги Exchange.

Outlook Web Access позволяет пользователям выбирать язык пользовательского интерфейса. Выбранный пользователем язык определяет региональные параметры. Кроме того, Outlook Web Access использует этот язык для сортировки результатов выполнения операций Active Directory, например адресной книги. Если сервер Exchange выполняет запрос представления виртуального списка, указывая язык, недоступный на контроллере домена, происходит ошибка. Эта проблема возникает из-за того, что в настоящее время нет механизма индексации по умолчанию, позволяющего серверу Exchange использовать другой язык, если язык, указанный для запроса представления виртуального списка, не соответствует языку, заданному на контроллере домена.

Чтобы устранить причины данного предупреждения, получите и установите обновление, упомянутое в статье 919166 базы знаний Майкрософт «Работа адресной книги в Exchange 2007 нарушается, если в клиенте Exchange Outlook Web Access и на контроллере домена с Windows Server 2003 используются разные региональные параметры» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=919166, на английском языке).


WMI сервера Active Directory недоступен
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_ComputerSystem, чтобы определить, установлено ли значение для ключа Name контроллера домена. Если запрос WMI-класса заканчивается неудачей, анализатор сервера Exchange выводит сообщение об ошибке.

У этой ошибки возможны две причины:

  • Учетная запись, от имени которой выполняется анализатор сервера Exchange, не обладает достаточными разрешениями на запрос WMI-данных

  • Проблема сети не дает анализатору сервера Exchange связаться с компьютером.

Устранение ошибки

  1. Убедитесь, что компьютер сервера Exchange включен и подключен к сети.

  2. С помощью команды PING проверьте доступность компьютера сервера Exchange.

  3. При использовании брандмауэра проверьте, не закрыты ли порты RPC.

  4. Проверьте разрешения учетной записи, от имени которой выполняется анализатор сервера Exchange. Учетная запись, от имени которой выполняется анализатор сервера Exchange, на каждом сканируемом компьютере сервера Exchange должна обладать разрешениями локального администратора.

    Либо можно предоставить учетной записи, от имени которой выполняется анализатор сервера Exchange, конкретное разрешение WMI.

    1. На компьютере Exchange откройте дерево консоли MMC Управление компьютером.

    2. В ветви Службы и приложения щелкните правой кнопкой мыши управляющий элемент WMI и выберите команду Свойства.

    3. На странице Свойства: Управляющий элемент WMI щелкните вкладку Безопасность и разверните дерево Root.

    4. Выберите папку CIMV2 и нажмите кнопку Безопасность.

    5. На странице Безопасность для ROOT\CIMV2 добавьте учетную запись, от имени которой выполняется анализатор сервера Exchange.

    6. Выберите учетную запись, добавленную на шаге e; в разделе Разрешения для Выбранная_учетная_запись, в столбце Разрешить, установите флажки Включить удаленно и Прочесть безопасность, а затем нажмите кнопку OK.

Дополнительные сведения об устранении неполадок сетевых подключений, см. в следующих материалах:

  • Статья 325487 базы знаний Майкрософт, посвященная устранению неполадок сетевых подключений, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487 (возможно, на английском языке).

  • «Проблемы устранения неполадок сетевых подключений средства Best Practices Analyzer сервера Microsoft Exchange» по адресу http://go.microsoft.com/fwlink/?LinkId=56285 (возможно, на английском языке)

Дополнительные сведения о требованиях к портам см. в статье базы знаний Майкрософт 832017, содержащей обзор служб и требования к сетевым портам для системы Windows Server, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017 (возможно, на английском языке).


Обнаружен атрибут ADCDisabledMail
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, в каком режиме находится организация Exchange — смешанном или основном. Если обнаружено, что организация Exchange находится в основном режиме, анализатор сервера Exchange Server Analyzer запрашивает Active Directory с целью определить, имеет ли какой-либо объект с поддержкой почты в доменах организации атрибут legacyExchangeDN со значениемADCDisabledMail. Если объект с поддержкой почты, у которого для атрибута legacyExchangeDN установлено значение ADCDisabledMail, найден, отображается предупреждение, в котором перечислены объекты и их домен.

Эта неполадка может происходить как в среде Exchange 2000 Server, так и в среде Exchange Server 2003 при удалении почтового ящика. Когда удаляется почтовый ящик, значением атрибута legacyExchangeDN учетной записи становится ADCDisabledMail. Это значение используется для того, чтобы приказать соединителю Active Directory удалить объекты из службы каталогов Exchange Server 5.5 при отключении поддержки почты для связанного объекта в службе каталогов Active Directory. Если было удалено несколько почтовых ящиков большой группы рассылки, сообщение не отображается, пока в Active Directory выполняется поиск уникального значения атрибута legacyExchangeDN — ADCDisabledMail. Поскольку несколько почтовых ящиков могут иметь одно и то же legacyExchangeDN attribute value, поиск занимает много времени. Это приводит к задержкам в передаче сообщений. Кроме того, задержки в передаче сообщений будут происходить, когда группа рассылки развернута в строках «Кому:/Копия:/СК:» сообщения от клиента Microsoft Office Outlook® 2003.

Чтобы устранить эту неполадку, можно либо удалить объекты, либо использовать средство Active Directory Service Interfaces (ADSI) Edit, cредство ldp.exe или другой клиент LDAP (Lightweight Directory Access Protocol) версии 3 для удаления содержимого атрибута legacyExchangeDn. Если для атрибута legacyExchangeDN установлено значение NULL, то для поиска в Active Directory будет задано «/O=NT5/ou=<objectGUID домена>/cn=<objectGUID пользователя>» и отчет о недоставке будет появляться значительно быстрее.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью ADSI Edit, средства LDP или другого клиента, использующего протокол LDAP версии 3, может привести к серьезным неполадкам. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих продуктов. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Чтобы удалить значение ADCDisabledMail атрибута legacyExchangeDN

  1. Запустите средство ADSI Edit из средств поддержки Windows 2000 или из средств поддержки Windows Server 2003.

  2. Разверните следующие узлы:

    • Domain Container (Контейнер домена)

    • DC=Имя_домена

    • Users Container (Контейнер пользователей)

  3. Щелкните правой кнопкой мыши Имя_пользователя и выберите Properties (Свойства).

  4. Щелкните legacyExchangeDN в списке Attributes (Атрибуты), а затем щелкните Edit (Изменить).

  5. Удалите исходное значение legacyExchangeDN, содержащее ADCDisabledMail, для чего выделите исходное значение и щелкните Clear (Очистить).

  6. Нажмите кнопку ОК два раза, чтобы изменения вступили в силу.

Для получения дополнительных сведений о работе с ADSI Edit см. раздел «Adsiedit.msc: ADSI Edit» в справке Windows Server.

Для получения дополнительных сведений об использовании средства LDP см. статью базы знаний Майкрософт 260745, посвященную использованию служебной программы LDP для изменения атрибутов объектов Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).


Настройка фильтра списка адресов может привести к тому, что новые получатели не будут отображаться в списках адресов
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Server запрашивает службу каталогов Active Directory®, чтобы определить атрибуты, заданные для атрибута purportedSearch каждого объекта списка адресов. Если анализатор сервера Exchange Server обнаружит, что атрибут purportedSearch включает строку "proxyAddresses=*", отображается ошибка.

После создания нового объекта-пользователя служба обновления получателей назначает конкретные атрибуты таким объектам-получателям, как адреса прокси-серверов. Однако служба обновления получателей может дать сбой при назначении атрибута ShowInAddressBook. Атрибут ShowInAddressBook объекта-получателя указывает списки адресов, членом которых является получатель. Объекты-получатели, которым этот атрибут не назначен, не отображаются в глобальном или в любом другом списке адресов, даже если этот объект удовлетворяет соответствующему критерию в фильтре списка адресов.

Данная ситуация может возникнуть, если один или несколько фильтров списка адресов включают атрибут proxyAddresses. Ее наличие можно определить, просмотрев свойства каждого списка адресов и осуществив поиск следующей строки в поле Правила фильтрации: "proxyAddresses=*".

Выполните следующую процедуру, чтобы обеспечить правильное назначение атрибутов объектам-получателям в службе обновления получателей, при котором они будут отображаться в глобальном и любом другом списке адресов.

Внимание!
Если неправильно изменить атрибуты объектов Active Directory с помощью средства ADSI Edit, средства LDP (ldp.exe) или другого клиента LDAP версии 3, могут возникнуть серьезные проблемы. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обеих программ. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Чтобы устранить эту ошибку

  1. Откройте диспетчер Exchange.

  2. Разверните Получатели, затем разверните Все глобальные списки адресов и выберите Политики получателей.

  3. В правой области щелкните правой кнопкой мыши список адресов, который требуется изменить, и выберите Свойства.

  4. На странице Свойства на вкладке Общие в разделе Правила фильтрации щелкните Изменить.

  5. В раскрывающемся списке Найти получателей Exchange выберите Пользовательский поиск. Если список адресов был первоначально создан посредством пользовательского поиска, отобразится страница Найти пользовательский поиск после выбора Изменить на шаге 3.

  6. Выберите запись Прокси-адрес (точно) * в списке критериев, а затем щелкните Удалить.

  7. Нажмите кнопку ОК, чтобы закрыть диалоговые окна.

  8. Щелкните правой кнопкой мыши политику получателей, а затем щелкните Применить эту политику.

Дополнительные сведения о службе обновления получателей см. в следующих статьях базы знаний Майкрософт:

  • 328738 — описывается, как служба обновления получателей применяет политики получателей (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328738)

  • 319065 — приводятся инструкции по работе со службой обновления получателей Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319065)


Режим административной группы неизвестен
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы удостовериться в режиме административной группы путем проверки атрибута msExchAdminGroupMode объекта административной группы в контейнере «Административные группы» в службе Active Directory. Если анализатор сервера Exchange обнаружит, что значение атрибута msExchAdminGroupMode не равно 0, 1 или 2, на экран будет выведено сообщение об ошибке.

Приложение Exchange использует режим административной группы, чтобы указать, может ли административная группа содержать серверы Exchange Server 5.5 или серверы Exchange Server 2003 (или серверы Exchange 2000 Server). Если значение этого атрибута не равно 0, 1 и 2, скорее всего, администратор вручную изменил значение. Программа установки Exchange и диспетчер Exchange не устанавливают это значение неправильно.

Это значение следует исправить, применяя, например, оснастку Edit интерфейса ADSI, средство LDP (ldp.exe) или любой другой клиент, использующий протокол LDAP версии 3.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью оснастки Edit интерфейса ADSI, средства LDP или другого клиента, использующего протокол LDAP версии 3, может привести к серьезным неполадкам. Для устранения этих неполадок может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы изменить атрибут MSExchAdminGroupMode

  1. Используя редактор службы Active Directory, например, оснастку Edit интерфейса ADSI, найдите объект административной группы в Active Directory.

    Атрибут MSExchAdminGroupMode можно найти по следующему пути:

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=Organization, CN=Administrative Groups, CN= Административная группа

  2. Введите одно из следующих целочисленных значений:

    0=основной режим (административная группа была создана с использованием Exchange 2000 Server или Exchange Server 2003);

    1=режим Exchange Server 5.5 (административная группа была создана с использованием Exchange Server 5.5 и содержит только серверы Exchange Server 5.5);

    2=смешанный режим (административная группа может содержать как серверы Exchange Server 5.5, так и серверы Exchange 2000 Server или Exchange Server 2003).

Дополнительные сведения об использовании средства LDP см. в базе знаний Майкрософт в статье 260745, посвященной использованию служебной программы LDP для изменения атрибутов объектов Active Directory (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Дополнительные сведения о работе с оснасткой Edit интерфейса ADSI см. в разделе, посвященном Adsiedit.msc: ADSI Edit, в интерактивной справке Windows Server.


Неправильная конфигурация прошедших проверку пользователей для размещаемых приложений Exchange
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, настроена ли среда сервера Exchange как среда размещаемых приложений Exchange (Hosted Exchange). Если среда сервера Exchange является средой Hosted Exchange, анализатор сервера Exchange запрашивает службу Active Directory, чтобы определить, является ли группа пользователей, прошедших проверку, частью группы «Пред-Windows 2000 доступ» этого домена.

Если группа пользователей, прошедших проверку, является частью группы «Пред-Windows 2000 доступ», анализатор сервера Exchange выводит предупреждение. Эта конфигурация не является рекомендуемой для решения Hosted Exchange.

Удаление группы пользователей, прошедших проверку, из группы безопасности «Пред-Windows 2000 доступ» необходимо для устранения причины этого предупреждения

  1. Откройте оснастку Active Directory — пользователи и компьютеры

  2. Разверните узел домена, а затем щелкните контейнер Встроенный.

  3. Щелкните правой кнопкой мыши группу безопасности Пред-Windows 2000 доступ и выберите команду Свойства.

  4. Откройте вкладку Члены.

  5. Выберите Пользователи, прошедшие проверку.

  6. Щелкните Удалить.

  7. Нажмите кнопку ОК.

Дополнительные сведения о средах Hosted Exchange см. в следующих статьях:

  • "Сведения для компаний, предоставляющих услуги размещения" по адресу http://go.microsoft.com/fwlink/?LinkId=46307 (возможно, на английском языке)

  • «Глава 23 - Среды размещения служб» в разделе Набор ресурсов Exchange Server 2000 по адресу http://go.microsoft.com/fwlink/?LinkId=46326 (возможно, на английском языке)


Несоответствие атрибута Principal сертификата
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2007-01-09

Средство анализатора сервера Microsoft® Exchange запрашивает объект Server Certificate на компьютере с сервером Exchange, чтобы получить различные свойства X509-сертификатов. Для каждого найденного SSL-сертификата анализатор сервера Exchange обрабатывает атрибутPrincipal, чтобы определить полное доменное имя, назначенное этому сертификату, например www.microsoft.com.

Анализатор севера Microsoft Exchange выдает предупреждение, когда полное доменное имя в атрибуте Principal не соответствует адресу узла или URL-адресу. Предупреждение о несоответствии сертификата Principal означает, что пользователи могут не иметь возможности подключиться к своим почтовым ящикам с помощью веб-клиента Microsoft Office Outlook® для Exchange Server 2003, мобильного Outlook для Exchange Server 2007, Exchange Server ActiveSync, а также RPC по протоколу HTTP.

Примечание.
Когда сервер работает по протоколу SSL, у него должен быть сертификат сервера. Дополнительно сервер может запросить сертификат клиента. Сертификат сервера содержит имя веб-узла. Обозреватель проверяет, что это имя веб-узла является введенным именем. Например, если имя веб-узла — https://www.example.com, именем сертификата должно быть www.example.com.

Несоответствие имеет место, если выполняется одно из следующих условий:

  • Сертификат случайно применен к неправильному серверу

  • Клиент получает доступ к данным на сервере через неверный URL-адрес узла, когда у серверов несколько имен узла

Чтобы ликвидировать несоответствие имени сертификата

  • Проверьте, что предоставление и применение SSL-сертификата было выполнено для правильного узла.

Дополнительные сведения

  • Дополнительные сведения об использовании сертификатов с виртуальными серверами в Exchange Server 2003 см. статью 823024 базы знаний Майкрософт (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823024).

  • Сведения об использовании протокола SSL и о том, как получить и установить сертификаты серверов, см. раздел о настройке Exchange Server 2003 для клиентского доступа в руководстве по клиентскому доступу в Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47568).

  • Сведения об использовании SSL и о получении и установке серверных сертификатов для Exchange Server 2007 см. в документе «How to Configure SSL for Outlook Anywhere» (http:// go.microsoft.com/fwlink/?LinkId =80875).


Для расписания активации соглашения о соединении установлено значение «Никогда»
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута activationStyle для каждого из объектов соглашения о соединении. Атрибут activationStyle отражает параметр расписания для данного соглашения о соединении. Если для расписания установлено Никогда, выводится предупреждение.

Если это соглашение о соединении больше не требуется, его следует удалить. Если это соглашение о соединении требуется, следует настроить для него нужное расписание.

Чтобы устранить причину появления этого предупреждения

  1. Нажмите кнопку Пуск, щелкните Программы, щелкните Администрирование, а затем щелкните Соединитель Active Directory.

  2. В левой области щелкните сервер соединителя Active Directory, который размещает соглашение о соединении, которое нужно изменить.

  3. В правой области щелкните правой кнопкой мыши соглашение о соединении, которое нужно изменить, и выберите команду Свойства.

  4. Откройте вкладку Расписание.

  5. Задайте для расписания параметр Всегда или Выбранное время. Если выбран последний параметр, щелкните соответствующие области решетки, чтобы данное соглашение о соединении выполнялось в нужное время.

Дополнительные сведения о настройке двустороннего соглашения получателей см. в статье базы знаний Майкрософт 296260 «XGEN: How to Configure a Two-Way Recipient Connection Agreement for Exchange 5.5 Users» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=296260) (Инструкции по настройке двустороннего соглашения о соединении получателей для пользователей Exchange 5.5).


Соглашение о подключении лишено ссылки
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализа Microsoft Exchange Server запрашивает службу каталогов Active Directory® для определения верности атрибута для msExchHomeSyncService для каждого соглашения о подключении. Если средство анализа Exchange Server Analyzer обнаруживает соглашение о подключении без действительного значения для данного атрибута, отображается предупреждение.

Атрибут msExchHomeSyncService содержит сервер Active Directory Connector (ADC), на котором расположено соглашение о подключении.

Это предупреждение появится при удалении сервера ADC без предварительного удаления ADC или при удалении соглашений о подключении на сервере ADC. При удалении сервера ADC между соглашениями о подключении и сервером ADC разрывается подключение. В результате объекты, за которые ответственны данные соглашения о подключении, более не будут выполнять репликацию. При использовании оснастки ADC Manager на другом сервере ADC соглашения о подключении, расположенные на удаленном сервере ADC, не будут отображаться. Однако эти соглашения о подключении все еще присутствуют в Active Directory.

Чтобы устранить это, повторно свяжите старые соглашения о подключении с новым сервером ADC. Одним из способов этого является создание нового соглашения о подключении на новом сервере ADC и последующие копирования и вставка атрибута msExchHomeSyncService из нового соглашения о подключении в старое.

Для повторной установки связи соглашения о подключении с сервером ADC

  1. Запустите оснастку ADC Manager.

  2. Создайте новое соглашение о подключении.

  3. Запустите редактирование интерфейсов службы Active Directory (ADSI).

  4. Разверните Configuration, разверните Services, разверните Microsoft Exchange, затем щелкните Active Directory Connections.

  5. В правой панели откройте свойства только что созданного соглашения о подключении.

  6. В раскрывающемся списке Select a property to view щелкните msExchHomeSyncService.

  7. Скопируйте весь атрибут из окна Value(s), затем щелкните OK.

  8. Откройте свойства соглашения о подключении, для которого необходимо повторно установить связь.

  9. Щелкните раскрывающийся список Select a property to view, затем щелкните атрибут msExchHomeSyncService.

  10. Вставьте скопированное значение в окно Edit Attribute.

  11. Щелкните Set, затем Apply, затем OK.

Дополнительные сведения о соглашениях о подключении с отсутствующими ссылками см. в статье 319486 базы знаний корпорации Майкрософт «XADM: Соглашения о подключении пропадают после удаления Active Directory Connector» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319486).


Изменено краткое имя по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Server запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута createDialog объектов, имеющих класс displaySpecifier. Объекты с классом displaySpecifier описывают контекстные меню и страницы свойств, которые будут использоваться с объектами в Active Directory. Если анализатор сервера Exchange Server определит, что атрибут createDialog задан, отображается сообщение о нестандартной настройке.

Когда новый объект-пользователь или объект-контакт создаются в Active Directory, поле «Полное имя» всегда создается в форматеFirst Name LastName. В свою очередь, это поле определяет при своем создании поле «Краткое имя». Таким образом, в результате получается форматированный глобальный список адресов FirstName LastName.

Если требуется, можно воспользоваться редактором Active Directory, например Active Directory Service Interfaces (ADSI) Edit, чтобы изменить способ построения поля «Краткое имя». Редактор ADSI Edit не только изменяет способ построения этого поля, но и поля «Полное имя». В результате пользователи отображаются в выбранном формате в оснастке «Active Directory — пользователи и компьютеры».

Внимание!
Могут возникнуть серьезные неполадки, если неправильно изменить атрибуты объектов Active Directory при использовании средства ADSI Edit, средства LDP (ldp.exe) или другого клиента LDAP версии 3. Для устранения этих неполадок может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на пользователе, производящем изменения.

Прежде чем вносить эти изменения, убедитесь, что они не приведут к противоположному эффекту. Дополнительные сведения о потенциальных последствиях таких изменений см. в базе знаний Майкрософт в статье в статье 276266, посвященной этой теме (http://go.microsoft.com/fwlink/?linkid=3052&kbid=276266).

Чтобы изменить формат отображения по умолчанию для объектов-пользователей и объектов-контактов

  1. Откройте редактор Active Directory, например ADSI Edit.

  2. Щелкните правой кнопкой мыши верхний узел, а затем щелкните Подключиться к.

  3. Измените контекст именования на «Контейнер конфигурации», а затем нажмите кнопку ОК, чтобы осуществить привязку и проверку подлинности.

  4. Разверните узел Контейнер конфигурации, а затем разверните узел Конфигурации.

  5. Разверните узел cn=DisplaySpecifiers, а затем дважды щелкните CN=409. Примечание. 409 является кодом языка для английского (США) языка. При работе в многоязыковой среде может потребоваться внести изменение в это значение и использовать другие коды.

  6. В правой области откройте свойства для CN=user-Display.

  7. Выполните прокрутку, чтобы отобразить дополнительный атрибут createDialog.

  8. Установите для этого атрибута значение %<sn>.%<givenName>, а затем щелкните Задать. Примечание. Могут форматироваться только маркеры %<sn>, %<givenName> и %<initials>.

  9. Чтобы закрыть диалоговое окно, нажмите кнопку ОК.

  10. Создайте нового пользователя в Active Directory, чтобы проверить, что созданные полное и краткое имена получились такими, как предполагалось. Примечание. В среде, в которой имеется несколько доменов, может потребоваться подождать завершения репликации, прежде чем в оснастке «Active Directory — пользователи и компьютеры» будут зафиксированы внесенные изменения.

В результате выполнения описанных выше шагов краткое имя будет отображаться в формате LastName.FirstName. Кроме того, описанная процедура относится к объектам-пользователям. Применительно к объектам-контактам следует изменить шаг 6 на contact-Display.

Дополнительные сведения об использовании сценария ADSI для выполнения данной задачи см. в базе знаний Майкрософт в статье в статье 277717, описывающей способ изменения кратких имен пользователей Active Directory с помощью сценария ADSI (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277717).

Международный союз телекоммуникаций (ITU) и Международная организация по стандартизации (ISO) определяют кодовые страницыcode pages. Для получения дополнительных сведений посетите следующие веб-страницы ITU и ISO:

  • http://www.itu.int

  • http://www.iso.ch/iso/en/ISOOnline.openerpage

    Примечание.
    Веб-адреса могут измениться, поэтому указанные веб-узлы могут быть недоступны.

Дополнительные сведения о поддержке локализованных клиентов Exchange см. в базе знаний Майкрософт в статье 150977, посвященной этой теме (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)


Хранение удаленных элементов для хранилища почтовых ящиков отключено
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Чтобы определить значение атрибута garbageCollPeriod для каждого хранилища почтовых ящиков, средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®. Если анализатор сервера Exchange обнаруживает, что атрибут garbageCollPeriod равен 0 для какого-либо хранилища почтовых ящиков, на экран выводится сообщение с рекомендациями.

Сборка мусора представляет собой внутренний процесс очистки Exchange, освобождающий пространство в базе данных хранилища почтовых ящиков. По умолчанию удаленные элементы хранятся в базе данных хранилища почтовых ящиков определенное количество дней, прежде чем Exchange удалит их окончательно. Срок хранения удаленных элементов можно задать либо с помощью параметров базы данных по умолчанию, либо указав число дней, в течение которых удаленный элемент будет храниться перед безвозвратным удалением.

Можно задать срок хранения удаленных элементов от 0 до 24 855 дней. Рекомендуется выбрать для этого параметра значение 7 дней. Если срок хранения удаленных элементов равен 0, удаленные элементы сразу удаляются с сервера без возможности восстановления. Если позволяет размер свободного места на диске, не рекомендуется отключать возможность хранения удаленных элементов. Чтобы задать число дней, в течение которых удаленные элементы будут храниться перед безвозвратным удалением, следуйте приведенным ниже процедурам.

Настройка хранения удаленных элементов в диспетчере Exchange

  1. Откройте диспетчер Exchange.

  2. Разверните узел административной группы или организации, щелкните Серверы, а затем щелкните Хранилище почтовых ящиков.

  3. Щелкните правой кнопкой мыши хранилище почтовых ящиков и в контекстном меню выберите Свойства.

  4. На вкладке Ограничения определите период хранения элементов, выполнив следующие действия:

    • Чтобы задать период хранения удаленных элементов, щелкните Срок хранения удаленных элементов (дней) и введите нужное значение.

    • Чтобы сохранять элементы до выполнения резервного копирования, установите флажок Не удалять почтовые ящики и элементы окончательно до создания резервной копии хранилища.

Настройка хранения удаленных элементов в оснастке «Active Directory — пользователи и компьютеры»

  1. Откройте оснастку «Active Directory — пользователи и компьютеры».

  2. В дереве консоли разверните узел домена.

  3. Дважды щелкните элемент Пользователи или дважды щелкните узел, содержащий данные о получателях, которые нужно изменить.

  4. В области сведений дважды щелкните получателя, которого нужно изменить.

  5. На вкладке Общие Exchange щелкните Ограничения хранилища.

  6. В диалоговом окне Ограничения хранилища в поле Хранение удаленных элементов снимите флажок Параметры хранилища почтовых ящиков по умолчанию и введите значение в поле Срок хранения удаленных элементов (дней).

    Чтобы предотвратить окончательное удаление элементов до их резервного копирования, установите флажок Не удалять и элементы окончательно до создания резервной копии хранилища.

Дополнительные сведения о настройке ограничений хранилищ почтовых ящиков см. в статье 319583 базы знаний Майкрософт, посвященной настройке ограничений хранения для почтовых ящиков Exchange 2000, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=319583.


Хранение удаленных элементов отключено для хранилища общих папок
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализа Microsoft® Exchange Server запрашивает службу каталога Active Directory, чтобы определить значение атрибута garbageCollPeriod для каждого хранилища общих папок. Если средство анализа Exchange Server обнаружит, что для атрибута garbageCollPeriod установлено значение 0 для какого-либо хранилища общих папок, появится сообщение с рекомендацией.

Сборка «мусора» - это внутренний служебный процесс Exchange для освобождения свободного пространства в базе данных хранилища общих папок. По умолчанию удаленные элементы хранятся в базе данных хранилища общих папок определенное количество дней, после чего они необратимо удаляются Exchange. Срок хранения удаленных элементов можно задать с помощью параметров базы данных хранилища общих папок по умолчанию, либо указав число дней, в течение которого удаленный элемент будет храниться перед безвозвратным удалением.

Срок хранения удаленных элементов может составлять от 0 до 24 855 дней. Рекомендуется указать для этого параметра значение 7 дней. Если срок хранения удаленных элементов равен 0, удаленные элементы сразу удаляются с сервера без возможности восстановления. Если позволяет размер свободного места на диске, не рекомендуется отключать возможность хранения удаленных элементов.

Для настройки хранения удаленных элементов в системном диспетчере Exchange

  1. Откройте системный диспетчер Exchange.

  2. Разверните Administrative Group or Servers, щелкните Servers, затем щелкните Public Folder Store.

  3. Щелкните правой кнопкой мыши хранилище общих папок и в контекстном меню выберите Properties.

  4. На вкладке Limits установите период хранения удаленных элементов следующим образом.

    • Для установки периода хранения для удаленных элементов щелкните Keep deleted items for (days), затем введите значение.

    • Для сохранения элементов до выполнения резервного копирования щелкните Do not permanently delete items until the store has been backed up.

Дополнительные сведения об установке пределов хранения для общих папок см. в статье 319439 базы знаний корпорации Майкрософт «ИНСТРУКЦИИ: Настройка пределов хранения для общих папок в Exchange 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319439).


Хранение удаленных почтовых ящиков отключено
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchMailboxRetentionPeriod для каждого из хранилищ почтовых ящиков. Если анализатор сервера Exchange обнаруживает, что значение атрибута msExchMailboxRetentionPeriod любого из хранилищ почтовых ящиков равно 0, выводится сообщение с рекомендациями.

Атрибут msExchMailboxRetentionPeriod указывает количество дней, в течение которого будут храниться удаленные почтовые ящики до окончательного удаления. При указании количества дней для хранения удаленного почтового ящика можно выбрать число от 0 до 24 855. По умолчанию период хранения удаленного почтового ящика равен 30 дням. Если период хранения почтового ящика установить равным 0, удаленные почтовые ящики сразу безвозвратно удаляются с сервера. Если на диске хватает места, рекомендуется не отключать функцию хранения удаленных почтовых ящиков.

Чтобы настроить хранение удаленных почтовых ящиков

  1. Откройте диспетчер Exchange

  2. Разверните узел Группы администрирования, разверните группу администрирования, разверните узел Серверы, а затем разверните нужную группу хранения. Если узел Группы администрированияне отображается в диспетчере Exchange, разверните узел Серверы, а затем разверните нужную группу хранения.

  3. Щелкните правой кнопкой мыши нужное хранилище почтовых ящиков и выберите команду Свойства.

  4. На вкладке Границы в поле Срок хранения удаленных почтовых ящиков (дней) введите срок хранения почтовых ящиков.

  5. Нажмите кнопку ОК, чтобы сохранить изменения.
Примечание.
Почтовый ящик можно восстановить, если срок его хранения не истек и связанный объект пользователя не удален.

Дополнительные сведения о восстановлении удаленных почтовых ящиков см. в следующих статьях базы знаний Майкрософт:

  • 274343, «How to Recover a Deleted Mailbox in Exchange» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=274343) (Инструкции по восстановлению удаленных почтовых ящиков в Exchange)

  • 813337, «How To Recover or Restore a Single Mailbox in Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=813337) (Инструкции по аварийному или обычному восстановлению отдельного почтового ящика в Exchange 2000 Server)

  • 823176, «How To Recover or Restore a Single Mailbox in Exchange 2003 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823176) (Инструкции по аварийному или обычному восстановлению отдельного почтового ящика в Exchange 2003 Server)


Домен содержит неизвестную подпись Exchange
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2006-12-04

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, какая версия DomainPrep последний раз запускалась в данном домене. Номер версии DomainPrep играет для домена роль подписи Exchange. Анализатор сервера Exchange проверяет атрибут objectVersion объекта Системные объекты Exchange данного домена. Существует два действительных целых значения:

  • Для Exchange 2000 Server значение атрибута objectVersion равно 4406.

  • Для Exchange Server 2003 значение атрибута objectVersion равно 6936.

  • Для сервера Exchange Server 2007 значение атрибута objectVersion равно 10628.

Если анализатор сервера Exchange не находит одного из вышеуказанных значений атрибута objectVersion, выводится сообщение об ошибке.

Это значение может быть неправильным, по всей видимости, если в данном домене установлена предварительная версия продуктов Exchange 2000 Server или Exchange Server 2003, но не работает выпущенная версия DomainPrep.

Примечание.
В Майкрософт Exchange 2000 Server и Exchange Server 2003 подготовительные действия Active Directory выполнялись путем запуска команд setup /forestprep и setup /domainprep. В Exchange 2007 параметры /forestprep и /domainprep отсутствуют. На сервере Exchange Server 2007 запустите команду setup /PrepareDomain или мастер настройки с учетной записью с разрешениями, необходимыми для подготовки службы Active Directory и домена.

Для устранения этой ошибки на сервере Exchange 2000 Server или Exchange Server 2003 запустите окончательную версию Exchange 2000 Server DomainPrep, Exchange Server 2003 DomainPrep, процедуры PrepareDomain или мастера настройки для сервера Exchange Server 2007. Учетная запись, используемая для запуска DomainPrep, PrepareDomain или мастера настройки должна быть членом группы безопасности «Администраторы домена» локального домена и группы администратора локального компьютера.

  • Корневой домен.

  • Все домены, которые будут содержать компьютеры с продуктами Exchange 2000 Server или Exchange Server 2003.

  • Все домены, которые будут содержать объекты Exchange 2000 Server или Exchange Server 2003 с включенными почтовыми ящиками (такие как пользователи и группы), даже если в этих доменах не будут установлены серверы Exchange.

  • Все домены, которые будут содержать серверы глобального каталога, которые потенциально могут использоваться компонентами Exchange, реализующими доступ к каталогу.

  • Все домены, которые будут содержать пользователей и группы Exchange 2000 Server или Exchange Server 2003, которые будут использоваться для управления организацией Exchange.

Запуск DomainPrep на сервере Exchange 2000 Server или Exchange Server 2003

  1. Вставьте компакт-диск Exchange в свой дисковод для компакт-дисков. Запустить DomainPrep можно на любом компьютере домена.

  2. В командной строке введите <диск>:\setup\i386\setup /DomainPrep, где <диск> - это буква дисковода для компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. В случае согласия с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов убедитесь, что в списке Действие выбрано значение DomainPrep. В противном случае щелкните стрелку раскрывающегося списка, а затем щелкните DomainPrep. Нажмите кнопку Далее.

  7. На странице Завершение мастера Microsoft Exchange нажмите кнопку Готово.

Запуск PrepareDomain на сервере Exchange Server 2007

  1. Выполните пошаговые рекомендации, содержащиеся в руководстве «Инструкции по подготовке службы Active Directory и доменов» по адресу http://go.microsoft.com/fwlink/?LinkId=78453 (на английском языке).

Для получения дополнительных сведений о выполнении команды DomainPrep в Exchange Server 2003 см. Руководство по развертыванию Exchange Server 2003 (может быть на английском языке) по адресу .

Для получения дополнительных сведений о выполнении команды DomainPrep в Exchange Server 2000 см. «Установка и настройка Microsoft Exchange Server 2000» (может быть на английском языке) по адресу http://go.microsoft.com/fwlink/?LinkId=5906.

Дополнительные сведения о подготовке службы Active Directory и доменов на сервере Exchange Server 2007 см. в руководстве «Инструкции по подготовке службы Active Directory и доменов» по адресу http://go.microsoft.com/fwlink/?LinkId=78453 (на английском языке).


На контроллере домена выполняется виртуальный сервер Virtual Server 2005, на котором установлен сервер Exchange с правами гостя
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Анализатор сервера Microsoft® Exchange запрашивает WMI-класс Win32_ComputerSystem, чтобы определить, установлено ли для ключа Model значение Virtual Machine.

Кроме того, анализатор сервера Exchange поверяет наличие следующего значения реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

Кроме того, анализатор сервера Exchange считывает значение Domain Role класса Win32_ComputerSystem на физическом компьютере, на котором работает Microsoft Virtual Server 2005. Значение, превышающее 3, означает, что физический компьютер является контроллером домена.

Если анализатор сервера Exchange обнаруживает, что ключ Model содержит строку Virtual Machine, существует указанный выше раздел реестра и значение Domain Role превышает 3, выводится сообщение об ошибке.

Значение Virtual Machine в ключе Model указывает, что данный компьютер с сервером Exchange Server работает как виртуальная машина с правами гостя под управлением Virtual Server 2005 или Microsoft Virtual PC 2004. Поскольку вышеуказанный раздел реестра создается только сервером Virtual Server 2005, его наличие означает, что данный компьютер сервера Exchange работает в качестве виртуальной машины с правами гостя на сервере Virtual Server 2005.

Майкрософт не поддерживает выполнение сервера Exchange на виртуальном компьютере или в эмуляторе. Это справедливо для серверов Exchange, работающих в Virtual Server 2005, Virtual PC 2004 или любом стороннем программном обеспечении, создающем виртуальные компьютеры. Платформы сервера Exchange созданы и проверены только на физическом оборудовании, особенно это касается тех платформ оборудования, которые приведены в каталоге серверов Windows (http://go.microsoft.com/fwlink/?linkid=17219).

Более того, выполнение Exchange с правами гостя на виртуальном сервере, установленном на контроллере домена, не рекомендуется, поскольку не обеспечивает нужного уровня избыточности между серверами.

Чтобы устранить эту ошибку

  1. Переместите почтовые ящики с сервера Exchange, работающего в Virtual Server 2005, на невиртуальный компьютер сервера Exchange.

  2. При необходимости измените связи публичных папок и переключите роли, присвоенные данному виртуальному серверу Exchange.

  3. Удалите Exchange с виртуального компьютера, чтобы списать его и удалить из инфраструктуры Exchange в службе каталогов Active Directory®.

Дополнительные сведения о перемещении почтовых ящиков см. в следующих статьях базы знаний Майкрософт:

  • статья 822892, описывающая улучшения, касающиеся перемещения почтовых ящиков в Exchange 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892);

  • статья 224975, посвященная различиям между методами перемещения почтовых ящиков быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975).

Дополнительные сведения о поддержке компьютеров Exchange Server, работающих в виртуальных средах, см. в статье 320220 базы знаний Майкрософт, посвященной ограничениям поддержки работы Exchange Server на виртуальных машинах и эмуляторах (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).

Дополнительные сведения о Microsoft Virtual Server 2005 см. на веб-узле http://go.microsoft.com/fwlink/?linkid=34938.

Дополнительные сведения о Microsoft Virtual PC 2004 см. на веб-узле http://go.microsoft.com/fwlink/?linkid=34663.


Не отвечает роль хозяина именования доменов FSMO
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализа Microsoft® Exchange Server запрашивает службу каталога Active Directory для определения значения атрибута fSMORoleOwner хозяина именования доменов в контексте именования конфигурации. Например, домен с названием contoso.com fSMORoleOwner для хозяина именования операций домена является атрибутом CN=Раздел, CN=Конфигурация, DC=contoso, DC=com. Затем средство анализа Exchange Server пытается открыть подключение LDAP к порту 389 протокола TCP контроллера домена, который в настоящее время поддерживает эту роль. Если средство анализа Exchange Server не может подключиться к контроллеру домена, появляется сообщение об ошибке.

Хозяин именования доменов - роль хозяина операций в масштабах леса, поскольку он управляет добавлением и удалением всех разделов каталога, независимо от домена, во всей иерархии леса. Контроллер домена, имеющий роль хозяина наименования доменов - единственный контроллер домена, который может делать следующее:

  • Добавлять новые домены в лес.

  • Удалять из леса существующие домены.

  • Добавлять или удалять взаимосвязанные объекты во внешних каталогах.

В лесу может существовать только один хозяин именования доменов.

Устранение этой ошибки

  1. Убедитесь, что указанный в сообщении об ошибке сервер каталогов подключен и доступен для серверов Exchange вашей организации.

  2. Если сервер каталогов списан, следует назначить роль мастера именования доменов другому контроллеру домена.

Для получения дополнительных сведений о передаче роли мастера именования доменов от одного контроллера домена другому см. следующие статьи базы знаний Майкрософт:

  • Для Microsoft Windows Server 2003 см. статью 324801 «Просмотр и передача ролей одиночного гибкого хозяина операций (FSMO) в Windows Server 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801).

  • Для Microsoft Windows2000 Server см. статью 255690, «ИНСТРУКЦИИ: Просмотр и передача ролей FSMO с помощью графического интерфейса пользователя» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Роль FSMO именования доменов не найдена
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализа Microsoft® Exchange Server Analyzer Tool направляет запрос службе каталогов Active Directory®, чтобы определить атрибут fSMORoleOwner хозяина именования доменов в контексте наименования конфигураций. Например, домен с названием contoso.com, fSMORoleOwner для хозяина именования домена является атрибутом CN=Раздел, CN=Конфгурация, DC=contoso, DC=com. Затем средство анализа сервера Exchange Server Analyzer пытается открыть подключение LDAP к контроллеру домена. Если средство анализа Exchange Server Analyzer обнаруживает, что контроллер домена, указанный в атрибуте fSMORoleOwner, не отвечает, появляется сообщение об ошибке .

Контроллер домена, исполняющий роль хозяина именования, управляет добавлением и удалением доменов из леса. В лесу может быть только один хозяин именования доменов.

Необходимо иметь хозяина именования домена, определенного в вашему лесу Active Directory. Программа установки Exchange и программа установки пакета обновления Exchange могут завершить работу, если контроллер домена, исполняющий роль хозяина именования, не подключен к Интернету во время установки. Если контроллер домена, обозначенный как хозяин именования, не подключен к Интернету, его следует подключить.

Исправление ошибки

  1. Проверьте наличие указанного сервера Active Directory.

  2. Если этот сервер был удален, назначьте роль хозяина именования другому контроллеру домена.

Для получения дополнительной информации о том, как назначить роль хозяина наименования другому контроллеру домена, обратитесь к следующим статьям базы знаний Майкрософт.

  • Для Microsoft Windows Server™ 2003 см. 324801 «Просмотр и передача ролей одиночного гибкого хозяина операций (FSMO) в Windows Server 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801).

  • Для Microsoft Windows® 2000 Server см. 255690, «ИНСТРУКЦИИ: Просмотр и передача ролей FSMO с помощью графического интерфейса пользователя» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Сбой при разрешении DNS-имени сервера каталогов
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange пытается отправить DNS-запрос заданным DNS-серверам для каждого сервера службы каталогов Active Directory®. Подключение устанавливается с помощью обработчика пользовательских объектов, который отправляет запрос разрешения имен и анализирует полученные результаты. Если анализатор сервера Exchange не получит IP-адрес в результатах запроса, будет выведено сообщение об ошибке.

Эта ошибка указывает на то, что в системе DNS не удалось обнаружить сервер каталогов. Для нормальной работы Exchange Server и Active Directory требуется наличие исправной и правильно настроенной системы DNS. Проблемы регистрации и разрешения DNS могут иметь крупномасштабные последствия для возможностей отправки, получения и доставки сообщений.

Для обеспечения правильной работы Active Directory и Exchange Server необходимо правильно настроить DNS. Более подробные сведения о настройке DNS для Active Directory см. в статье 237675 базы знаний Майкрософт (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=237675).

Чтобы устранить эту ошибку

  1. Проверьте следующие элементы конфигурации, чтобы убедиться в исправности системы DNS и правильной регистрации записей DNS для Active Directory:

    • Конфигурация IP в DNS

    • Динамические обновления зоны

    • Перенаправители DNS

  2. Убедитесь в наличии записи «Root Zone» (корневая зона). Проверьте зоны прямого просмотра в консоли управления DNS. Должна существовать запись для домена. Также могут существовать другие записи зон. Не должно присутствовать зоны точки («.»). Если зона точки существует, удалите ее. Зона точки идентифицирует сервер DNS как корневой сервер. В обычном случае домен Active Directory, для которого требуется внешний доступ (Интернет), не следует настраивать в качестве корневого сервера DNS. Вручную зарегистрируйте IP-адрес сервера каталогов с помощью команды Ipconfig /registerdns на сервере каталогов после удаления точки («.»). Также может потребоваться перезапустить службу Netlogon.

  3. Вручную заполните записи DNS для службы Active Directory с помощью команды netdiag /fix на сервере каталогов.

Дополнительные сведения об использовании системы DNS с Active Directory см. в статье 323418 базы знаний Майкрософт, описывающей интеграцию DNS с существующей инфраструктурой DNS при включенной службе Active Directory в Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=323418).

Дополнительные сведения об устранении неполадок в работе DNS и Active Directory см. в статье 260371 базы знаний Майкрософт, описывающей устранение наиболее типичных неполадок, связанных с настройкой Active Directory в Windows 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260371).


Значение dSHeuristics неправильно задано для Hosted Exchange
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, является ли данное развертывание развертыванием Hosted Exchange. Если развертывание Exchange работает в среде размещения, анализатор сервера Exchange Server запрашивает службу Active Directory, чтобы определить, правильно ли задан атрибут dSHeuristics контейнера Directory Service для развертывания Hosted Exchange.

Если значение dSHeuristics не равно 1, анализатор сервера Exchange выводит на экран предупреждение. В среде Hosted Exchange для атрибута dSHeuristics должно быть задано значение 1.

Внимание!
Могут возникнуть серьезные проблемы, если некорректно изменить атрибуты объектов Active Directory при использовании средства ADSI Edit (Active Directory Service Interfaces, ADSI), средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Чтобы устранить причину появления этого предупреждения

  1. Используйте редактор Active Directory, например ADSI Edit, чтобы разместить объект службы каталогов в Active Directory.

    Атрибут dSHeuristics может быть найден в

    CN=Configuration, CN=Services, CN=Windows NT, CN=Directory Service

  2. Введите значение 1 для dSHeuristics.

Дополнительные сведения о средах Hosted Exchange см. в следующих разделах:

  • "Сведения для поставщиков размещаемых в сети служб" (http://go.microsoft.com/fwlink/?LinkId=46307)

  • "Среды Hosted Service" в пакете Exchange Server 2000 Resource Kit (http://go.microsoft.com/fwlink/?LinkId=46326)


В Active Directory содержится дубликат контейнера системных объектов Microsoft Exchange
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, существует контейнер системных объектов Microsoft Exchange в контексте именования доменов.

Если анализатор сервера Exchange обнаруживает, что в Active Directory содержится дубликат контейнера системных объектов Microsoft Exchange, выводится следующее сообщение об ошибке: «Домен Active Directory подготовлен для Exchange, однако в нем присутствует несколько контейнеров «Системные объекты Microsoft Exchange». Может потребоваться очистка».

Эта неполадка может возникнуть в средах Exchange Server, где выполнены следующие условия:

  • Было удалено и заменено соглашение о подключении к двустороннему соединителю с Active Directory между Active Directory и Exchange Server 5.5.

  • Действует новое соглашение о подключении к одностороннему серверу соединителя с Active Directory от Exchange Server 5.5 к Active Directory.

  • Среда смешанных режимов, в которой выполнялся Exchange Server 5.5, была перемещена в среду Exchange Server 2003.

  • Была выполнена миграция Exchange Server 2003 с постороннего почтового сервера.

Если анализатор сервера Exchange выводит эту ошибку, необходимо удалить неверный дубликат контейнера или подразделения системных объектов Microsoft Exchange. Если присутствует дубликат контейнера системных объектов Microsoft Exchange, эту проблему нельзя решить повторным выполнением средства DomainPrep. Необходимо найти и удалить неправильный дубликат контейнера системных объектов Microsoft Exchange.

Чтобы удалить дубликат контейнера системных объектов Microsoft Exchange

  1. Войдите на контроллер домена с учетными данными администратора.

  2. Нажмите кнопку Пуск, щелкните Программы, щелкните Администрирование, а затем — Пользователи и компьютеры Active Directory.

  3. В области консоли управления Пользователи и компьютеры Active Directory на панели инструментов щелкните Вид и выберите Расширенные функции.

  4. В области консоли управления Пользователи и компьютеры Active Directory найдите дублирующий контейнер или подразделение системных объектов Microsoft Exchange.

  5. Убедитесь, что дубликат контейнера или подразделения системных объектов Microsoft Exchange не содержит допустимых объектов Active Directory.

  6. Щелкните правой кнопкой мыши дубликат контейнера или подразделения системных объектов Microsoft Exchange и нажмите кнопку Удалить.

  7. Подтвердите удаление, нажав кнопку Да в диалоговом окне Active Directory.

    Примечание.
    Если нужно незамедлительно выполнить репликацию изменений, необходимо вручную инициировать репликацию между контроллерами домена.

Дополнительные сведения об этой неполадке в Exchange Server см. в следующих статьях базы знаний Майкрософт:

  • 316280, «XADM: A Description of the 'ADC Global Names' Attribute» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=316280) (XADM: описание атрибута «Глобальные имена ADC»)

  • 252228, «XADM: ADC Appears to Create Duplicate Objects» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=252228) (XADM: возможно, в ADC создаются дублированные объекты)

  • 253800, «XADM: ADC May Create Duplicate Objects in Active Directory" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=253800) (XADM: возможно, ADC создает дублированные объекты в Active Directory)

  • 274480, «XADM: Duplicate Object Created When Replicating Objects from Exchange Server 5.5 to Windows 2000 Active Directory» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=274480) (XADM: при репликации объектов из Exchange Server 5.5 в Active Directory Windows 2000 создаются дублированные объекты)

  • 288578, «XADM: ADC Creates Duplicate Accounts in Exchange Server 5.5 and Active Directory» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=288578) (XADM: возможно, ADC создает дублированные учетные записи в Exchange Server 5.5 и Active Directory)


Ошибка при доступе к Active Directory
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange определило, что контроллер домена службы каталогов Active Directory® недоступен. Проверьте сетевое подключение к контроллеру домена Active Directory.

Чтобы устранить эту ошибку

  • Если в анализаторе сервера Exchange указан контроллер домена Active Directory, попытайтесь подключиться, не указывая контроллер домена.

  • Если контроллер домена не указан, укажите работающий и доступный контроллер домена.


Ошибка при доступе к административным группам Exchange
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange определило, что организация Exchange была установлена в лесу службы каталогов Active Directory® и доступ к сведениям о конфигурации организации Exchange получен успешно. Однако не были найдены административные группы, содержащие серверы Exchange.

Чтобы устранить эту ошибку:

  • Убедитесь, что имеются необходимые разрешения в службе каталогов Active Directory для доступа к контейнеру административных групп Exchange.

  • Если рабочая станция, на которой запущен анализатор сервера Exchange, принадлежит другому лесу Active Directory или если вход был выполнен не под учетной записью домена, может потребоваться подключиться к контроллеру домена Active Directory или к лесу, в котором находятся серверы Exchange.


Ошибка доступа к контейнеру конфигурации Exchange
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Анализатор сервера Microsoft® Exchange определил, что контейнер конфигурации Exchange недоступен. Сведения об организации, административных группах и конфигурации сервера Exchange хранятся в контексте именования «Конфигурация» в службе каталогов Active Directory®. Чтобы обратиться к любой информации конфигурации Exchange, необходимо иметь возможность читать ветви контейнера конфигурации Microsoft Exchange в Active Directory.

Чтобы устранить эту ошибку:

  • Убедитесь в наличии разрешений, необходимых для чтения контейнера конфигурации в Active Directory.

  • Убедитесь в наличии сетевого доступа к контроллеру домена Active Directory.


Группе безопасности «Все» разрешено создавать общие папки верхнего уровня
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2006-12-04

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, указан ли в атрибуте ntSecurityDescriptor объекта организации Exchange идентификатор безопасности (SID) для группы «Все». Если анализатор сервера Exchange обнаруживает, что в объекте организации ntSecurityDescriptor присутствует идентификатор безопасности для группы «Все», на экран выводится предупреждение. Это предупреждение означает, что группе безопасности «Все» разрешено создавать общие папки верхнего уровня.

В Exchange 2000 Server по умолчанию предоставляется право на создание общих папок верхнего уровня. Однако при запуске операции ForestPrep сервера Exchange Server 2003 или PrepareAD сервера Exchange Server 2007, группе безопасности «Все» будет запрещено создание общих папок наивысшего уровня. Этот запрет был реализован как мера безопасности. Предоставление группе безопасности «Все» права на создание общих папок верхнего уровня делает организацию уязвимой к атакам с отказом в облуживании.

Таким образом, рекомендуется лишить группу безопасности «Все» права создавать общие папки верхнего уровня. При работе с сервером Exchange Server 2003 или Exchange Server 2007 рекомендуется запускать версию ForestPrep для сервера Exchange Server 2003 или версию PrepareAD для сервера Exchange Server 2007 соответственно. Команду ForestPrep версии Exchange Server 2003 можно выполнять в среде Exchange 2000 Server. Однако последующие установки Exchange 2000 Server восстанавливают конфигурацию, разрешающую группе «Все» создавать общие папки верхнего уровня.

При отсутствии сервера Exchange Server 2003 или Exchange Server 2007 можно настроить данное разрешение вручную. Не забывайте, что последующие установки Exchange 2000 Server отменят эту настройку. Таким образом, необходимо вручную настраивать это разрешение после каждой установки Exchange 2000 Server. Прежде чем настраивать разрешение, необходимо включить отображение вкладки «Безопасность» в системном диспетчере Exchange. Это можно сделать, добавив запись «ShowSecurityPage» в реестр на компьютере с Exchange Server.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы добавить в реестр запись «ShowSecurityPage»

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKEY_CURRENT_USER\Software\Microsoft\Exchange\ExAdmin

  3. В меню Правка последовательно выберите Создать, Параметр DWORD.

  4. Введите новое имя записи, введите ShowSecurityPage, а затем нажмите клавишу ВВОД.

  5. Дважды щелкните ShowSecurityPage, введите 1 в поле Значение и нажмите кнопку ОК.

Чтобы вручную запретить группе безопасности «Все» создавать общие папки верхнего уровня в среде Exchange 2000 Server

  1. Откройте системный диспетчер Exchange

  2. Щелкните правой кнопкой мыши имя_организации и выберите Свойства.

  3. На странице Свойства имя_организации откройте вкладку Безопасность.

  4. На вкладке Безопасность в поле Группы или пользователи выберите Все. В поле Разрешения для всех выполните прокрутку до разрешения Создание общей папки верхнего уровня, снимите флажок в столбце Разрешить и нажмите кнопку Применить.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения по выполнению команды ForestPrep в Exchange Server 2003 см. в руководстве по развертыванию Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47569).

Дополнительные сведения о запуске команды PrepareAD сервера Exchange Server 2007 см. в статье «Подготовка службы Active Directory и доменов» по адресу http://go.microsoft.com/fwlink/?LinkId=78453 (на английском языке).

Дополнительные сведения о том, как запретить создание общей папки верхнего уровня для группы безопасности «Все» в Exchange 2000 Server см. в статье 328808 базы знаний Майкрософт, посвященной отключению разрешения «Создание общей папки верхнего уровня» для пользователей в Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328808).


Проблема с контейнером домена Exchange
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, существует ли в контексте именования доменов контейнер Системные объекты Microsoft Exchange. Если анализатор сервера Exchange обнаружит, что контейнер Системные объекты Microsoft Exchange не существует либо является недопустимым или имеет неправильный формат, на экран будет выведено сообщение об ошибке.

Контейнер Системные объекты Microsoft Exchange создается в каждом домене при запуске DomainPrep — средства Exchange.

Средство DomainPrep следует запустить в домене, в котором обнаружена эта ошибка. Имя домена, в котором отсутствует контейнер Системные объекты Microsoft Exchange, содержится в выходных данных анализатора сервера Exchange.

Учетная запись, под которой выполняется DomainPrep, должна входить в локальном домене в группу безопасности администраторов домена и должна принадлежать администратору локального компьютера.

В общем случае средство DomainPrep следует запускать в следующих доменах:

  • Корневой домен.

  • Все домены, которые будут содержать компьютеры с Exchange 2000 Server или Exchange Server 2003.

  • Все домены, которые будут содержать оснащенные почтовыми ящиками объекты (например, пользователей и группы) Exchange 2000 Server или Exchange Server 2003, даже если никакие серверы Exchange не будут устанавливаться в этих доменах.

  • Все домены, предусматривающие включение в свой состав серверов глобального каталога, которые возможно будут использоваться компонентами доступа к каталогу Exchange.

  • Все домены, которые будут содержать пользователей и группы Exchange 2000 Server или Exchange Server 2003, используемые для управления организацией Exchange.

Чтобы запустить средство DomainPrep

  1. Вставьте компакт-диск Exchange в дисковод компакт-дисков. Средство DomainPrep можно запустить на любом компьютере в домене.

  2. В командной строке введите <диск>:\setup\i386\setup /DomainPrep, где <диск> — это дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-значный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов убедитесь, что параметр Действие установлен равным DomainPrep. Если это не так, щелкните стрелку раскрывающегося списка и выберите DomainPrep. Нажмите кнопку Далее.

  7. На странице Завершение мастера Microsoft Exchange нажмите кнопку Готово.

Дополнительные сведения о выполнении команды DomainPrep в Exchange Server 2003 см. в руководстве по развертыванию Exchange 2003 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47569).

Дополнительные сведения о выполнении команды DomainPrep в Exchange 2000 Server см. в технической документации, описывающей установку и настройку Microsoft Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=5906).


Не найдена группа серверов домена Exchange
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить значение атрибута ntSecurityDescriptor объекта Системные объекты Microsoft Exchange, чтобы определить версию команды DomainPrep, выполненную в домене.

Существует два допустимых целых числа:

  • Для Exchange 2000 Server атрибут ntSecurityDescriptor имеет значение 4406.

  • Для Exchange Server 2003 атрибут ntSecurityDescriptor имеет значение 6936.

Если обнаружено, что была использована любая из указанных версий команды DomainPrep, анализатор сервера Exchange опрашивает службу Active Directory, считывая значение атрибута objectGuid объекта Системные объекты Microsoft Exchange, чтобы определить, существует ли группа Серверы домена Exchange. Если анализатор сервера Exchange обнаруживает, что данная группа не существует, выводится сообщение об ошибке.

Чтобы устранить эту ошибку, выполните команду DomainPrep окончательной версии Exchange 2000 Server или Exchange Server 2003. Учетная запись, используемая для запуска команды DomainPrep, должна быть членом группы безопасности администраторов домена в локальном домене, а также иметь разрешения локального администратора.

Необходимо выполнить команду DomainPrep в следующих доменах:

  • Корневой домен.

  • Все домены, которые будут включать компьютеры под управлением Exchange 2000 Server или Exchange Server 2003.

  • Все домены, которые будут включать объекты Exchange 2000 Server или Exchange Server 2003 с поддержкой электронной почты (например, пользователи и группы), даже если в этих доменах не будут устанавливаться серверы Exchange.

  • Все домены, включающие серверы глобального каталога, которые могут использоваться компонентами Exchange, осуществляющими доступ каталогу.

  • Все домены, включающие пользователей и группы Exchange 2000 Server или Exchange Server 2003, которые будут использоваться для управления организацией Exchange.

Чтобы выполнить команду DomainPrep

  1. Вставьте компакт-диск Exchange в устройство чтения компакт-дисков. Команду DomainPrep можно выполнить на любом компьютере домена.

  2. В командной строке введите <диск>:\setup\i386\setup /DomainPrep, где <диск> — устройство чтения компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если вы согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-значный ключ продукта и нажмите кнопку Далее.

  6. Убедитесь, что на странице Выбор компонентов для параметра Действие задано значение DomainPrep. Если задано другое значение, щелкните стрелку раскрывающегося списка и выберите DomainPrep. Нажмите кнопку Далее.

  7. На странице Завершение мастера Microsoft Exchange нажмите кнопку Готово.

Дополнительные сведения о выполнении команды DomainPrep в Exchange Server 2003 см. в руководстве по развертыванию Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47569).

Дополнительные сведения о выполнении команды DomainPrep в Exchange 2000 Server см. в руководстве по установке и настройке Microsoft Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=5906).


Группа «Серверы предприятия Exchange» не найдена
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Анализатор сервера Microsoft® Exchange Server запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута ntSecurityDescriptor объекта контейнера Системные объекты Microsoft Exchange для выяснения версии служебной программы DomainPrep, которая была запущена в домене.

Допустимы два целых числа:

  • Для Exchange 2000 Server значение ntSecurityDescriptor равно 4406.

  • Для Exchange Server 2003 значение ntSecurityDescriptor равно 6936.

Если определено, что использовалась любая из вышеупомянутых версий DomainPrep, анализатор сервера Exchange запрашивает Active Directory с целью определить значение атрибута objectGuid объекта Системные объекты Microsoft Exchange для выяснения, существует ли группа Серверы предприятия Exchange. Если анализатор сервера Exchange выясняет, что эта группа не существует, возвращается ошибка.

Чтобы устранить причину этой ошибки, запустите окончательную версию DomainPrep для Exchange 2000 Server или Exchange Server 2003. Учетная запись, используемая для запуска DomainPrep, должна быть членом группы безопасности «Администраторы домена» в локальном домене и быть администратором локального компьютера.

DomainPrep нужно запускать в следующих доменах:

  • В корневом домене.

  • Во всех доменах, которые будут содержать компьютеры Exchange 2000 Server или Exchange Server 2003.

  • Во всех доменах, которые будут содержать объекты Exchange 2000 Server или Exchange Server 2003, привязанные с почтовым ящикам (такие как пользователи и группы), даже если в этих доменах не будут установлены никакие серверы Exchange.

  • Во всех доменах, которые будут содержать серверы глобальных каталогов, которые потенциально могут быть использованы компонентами Exchange для доступа к каталогам.

  • Во всех доменах, которые будут содержать пользователей и группы Exchange 2000 Server или Exchange Server 2003, используемые для управления организацией Exchange.

Чтобы запустить DomainPrep

  1. Вставьте компакт-диск Exchange в привод компакт-дисков. DomainPrep можно запустить на любом компьютере в домене.

  2. В командной строке введите <диск>:\setup\i386\setup /DomainPrep, где <диск> — используемый привод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если вы согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов должно быть выбрано действие DomainPrep. Если это не так, щелкните стрелку раскрывающегося списка и выберите DomainPrep. Нажмите кнопку Далее.

  7. На странице Завершение мастера установки Microsoft Exchange нажмите кнопку Готово.

Для получения дополнительных сведений о запуске служебной программы DomainPrep для Exchange 2003 см. руководство по развертыванию Exchange Server 2003 (возможно, на английском языке) по адресу http://go.microsoft.com/fwlink/?LinkId=47569.

Дополнительные сведения о запуске DomainPrep для Exchange 2000 Server см. в руководстве по установке и настройке Exchange 2000 Server (возможно, на английском языке) (http://go.microsoft.com/fwlink/?LinkId=5906).


Объект Exchange в контейнере потерянных и найденных объектов
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2006-12-01

Средство анализа Microsoft® Exchange Server Analyzer запрашивает службу каталога Active Directory®, чтобы определить, существуют ли какие-либо объекты в контейнере LostAndFoundConfig контейнера Configuration. Если анализатор сервера Exchange обнаруживает объекты в контейнере LostAndFoundConfig, выводится сообщение об ошибке с указанием объекта и класса объекта, которому наследует объект.

Контейнер LostAndFoundConfig содержит объекты, которые не могут быть согласованы службой Active Directory. Необходимо удалить все объекты в контейнере LostAndFoundConfig, поскольку Exchange попытается использовать их. Например, когда Exchange опрашивает Active Directory по классу объекта (т.е. «Серверы»), все объекты (даже если они содержатся в контейнере LostAndFoundConfig) возвращаются как допустимые. В результате Exchange может произвести попытку подключения к серверу, находящемуся в контейнере the LostAndFoundConfig, вместо реального объекта. Это может привести к непредвиденному поведению Exchange и даже сбою сервера. Наличие этих объектов также может предотвратить создание новых объектов того же класса.

Чтобы устранить эту проблему, необходимо удалить элементы, содержащиеся в контейнере LostAndFoundConfig, из Active Directory с помощью средства ADSI Edit.

Внимание!
Могут возникнуть серьезные проблемы, если некорректно изменить атрибуты объектов Active Directory при использовании оснастки Edit интерфейса ADSI (Active Directory Service Interfaces), средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3. Для устранения этих проблем может потребоваться переустановка системы Microsoft Windows Server™ 2003, а также сервера Exchange Server 2003, сервера Exchange Server 2007 или обоих продуктов. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Примечание.
Средство ADSI Edit включено в набор средств поддержки Windows 2000 Server и Windows Server 2003.

Чтобы устранить эту ошибку

  1. Откройте оснастку Edit интерфейса ADSI в консоли MMC.

  2. В меню Действие выберите команду Подключиться.

  3. В диалоговом окне Параметры подключения в поле Имя введите имя для подключения ADSI. В группе Точка соединения выберите пункт Select a well known Naming Context (Выбрать известный контекст именования), а затем в раскрывающемся меню выберите пункт Конфигурация. Нажмите кнопку ОК.

  4. В левой области дважды щелкните объект Конфигурация, а затем дважды щелкните LostAndFoundConfig.

  5. В правой области удалите все объекты и контейнеры. Щелкните правой кнопкой мыши объект или контейнер, нажмите кнопку Удалить, а затем нажмите кнопку Да.

  6. Закройте редактор ADSI.


В организации Exchange отсутствуют политики получателей
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута Name в объекте политик получателей для каждой организации Exchange. Если анализатор Exchange определяет, что объект политик получателей отсутствует или что объект политик получателей не содержит никаких политик получателей, выводится сообщение об ошибке.

При установке сервера Exchange создается стандартная политика получателей, использующая для всех получателей в организации Exchange адреса SMTP и X.400. Можно изменить созданную по умолчанию стандартную политику или создать новые политики. Однако удалить стандартную политику нельзя. У всех получателей в организации Exchange должны быть как адреса SMTP, так и адреса X.400. Отсутствие в организации Exchange политик получателей приведет к проблемам с надежностью.

Создание политики получателей

  1. Нажмите кнопку Пуск, щелкните Все программы, щелкните Microsoft Exchange, а затем щелкните Диспетчер системы.

  2. В левой области диспетчера системы Exchange разверните узел организации, разверните узел Получатели, щелкните правой кнопкой Политики получателей, укажите на Создать, а затем щелкните Политика получателей.

  3. В диалоговом окне Создать политику выберите тип политики, который нужно создать, установив флажок Адреса электронной почты, флажок Параметры диспетчера почтовых ящиков или оба флажка, а затем нажмите кнопку OK.

  4. В диалоговом окне Свойства введите имя новой политики получателей, а затем нажмите кнопку Изменить, чтобы создать фильтр для политики получателей.

    Примечание.
    Если не создать фильтр, политика не будет применена ни к каким получателям.

  5. Чтобы настроить политику получателей, переключитесь на вкладку Адреса электронной почты (политика) или вкладку Параметры диспетчера почтовых ящиков (политика) в диалоговом окне Свойства. Используйте параметры этих вкладок для настройки политики получателей, а затем нажмите кнопку OK, чтобы создать политику.

  6. Щелкните правой кнопкой мыши политику получателей в диспетчере системы Exchange и выберите в контекстном меню Применить политику.

Дополнительные сведения о получателях и политиках получателей см. в разделе «Управление получателями и политиками получателей» Руководства по администрированию Exchange Server 2003(http://go.microsoft.com/fwlink/?LinkId=47617.

Дополнительные сведения о создании и настройке политик получателей см. в статье 249299 базы знаний Майкрософт, посвященной настройке политик получателей Exchange, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=291330.


В организации Exchange содержатся нулевые системные политики
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить имя каждой системной политики в объекте системных политик для каждой организации Exchange. Если анализатор сервера определяет, что объект системных политик отсутствует, или что объект системных политик не содержит никаких системных политик, на экран выдается сообщение об ошибке.

Можно использовать объекты системных политик для упрощения администрирования системы путем настройки параметров для нескольких серверов Exchange через один объект настройки, например хранилище почтовых ящиков, хранилище общих папок или параметры сервера. По умолчанию при запуске ForestPrep в вашей организации создаются следующие системные политики:

  • Скрытое членство списка рассылки

  • Получатель с включенной поддержкой почты

  • Пользователь с включенной поддержкой почтового ящика

Если указанные системные политики по умолчанию не существует в вашей организации Exchange, возникнут проблемы с надежностью. Чтобы создать системные политики по умолчанию, следует запустить ForestPrep.

Чтобы запустить ForestPrep для Exchange Server 2003

  1. Вставьте компакт диск с Exchange в дисковод для компакт дисков.

  2. В меню Пуск выберите команду Выполнить, а затем введите дисковод:\setup\i386\setup /ForestPrep, где дисковод — дисковод для компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов проверьте, чтобы в меню Действие было установлено значение ForestPrep. Если это не так, щелкните указывающую вниз стрелку и затем щелкните ForestPrep. Нажмите кнопку Далее.

    Важно!
    Если значение ForestPrep не появилось в меню Действие, на шаге 2 могла быть неправильно написана команда ForestPrep. Если сделана ошибка в написании команды ForestPrep, вернитесь обратно на шаг 2 и снова введите команду.

  7. На странице Учетная запись администратора Microsoft Exchange Server в поле Учетная запись введите имя учетной записи или группы, отвечающей за установку Exchange.

    Примечание.
    Указанная вами учетная запись также будет иметь разрешение на использование мастера делегирования административных полномочий для создания других учетных записей администратора Exchange. Для получения дополнительных сведений о мастере делегирования административных полномочий Exchange см. Руководство по администрированию Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47617).

  8. Чтобы запустить ForestPrep, нажмите кнопку Далее. После запуска ForestPrep процесс отменить нельзя.

    Примечание.
    В зависимости от топологии вашей сети и скорости контроллера домена Microsoft Windows® 2000 Server или Microsoft Windows Server™ 2003 для выполнения ForestPrep может потребоваться много времени.

  9. На странице Завершение работы мастера настройки безопасности нажмите кнопку Готово.

Дополнительные сведения о порядке использования системных политик в Exchange см. в базе знаний Майкрософт в статье 253838 "XADM: How the Recipient Update Service Applies System Policies" (XADM: как служба обновления получателя применяет системные политики) http://go.microsoft.com/fwlink/?LinkId=3052&kbid=253838).

Для получения дополнительных сведений о системных политиках, см. статью "Exchange System Manager Architecture" (Архитектура диспетчера Exchange) раздела Техническое справочное руководство по Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47891).

Сведения о порядке создания системных политик не по умолчанию см. в базе знаний Майкрософт в статье 256141, "How to Create System Policies in Exchange" (Инструкции по созданию системных политик в Exchange) http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256141).


Порт NSPI глобального каталога был изменен
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2007-01-15

Чтобы определить, задано ли значение параметра реестра TCP/IP Port, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Parameters\TCP/IP Port

Если анализатор обнаружит, что параметр TCP/IP Port существует и задан, отображается сообщение о нестандартной конфигурации.

Параметр реестра для порта TCP/IP требуется, когда серверу глобального каталога нужен определенный порт для обслуживания клиентов MAPI. Если это не требуется в имеющейся среде Exchange, можно удалить этот параметр реестра.

.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы удалить порт TCP/IP на сервере глобального каталога

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\SYSTEM\CurrentControlSet\Services\NTDS\Parameters

  3. Щелкните параметр TCP/IP Port правой кнопкой мыши и выберите команду Удалить.

  4. Закройте редактор реестра.

  5. Перезагрузите компьютер, чтобы эта настройка вступила в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о настройке удаленного вызова процедур через HTTP см. в следующих статьях базы знаний:

  • Статья 833401, содержащая инструкции по настройке удаленных вызовов процедур через HTTP на одиночном сервере Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401);

  • Статья 827330, посвященная устранению неполадок в клиенте удаленных вызовов процедур через подключения HTTP в Office Outlook 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  • Статья 298369, содержащая инструкции по настройке сервера удаленного каталога для использования конкретного порта при обслуживании клиентов MAPI (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298369)

  • Статья 24823, в которой описываются сценарии развертывания поддержки удаленного вызова процедур по протоколу HTTP в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=24823)


Не отвечает порт 3268 глобального каталога
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута isGlobalCatalogReady этого сервера. Значение True этого атрибута указывает, что сервер каталогов является также функционирующим сервером глобального каталога, а значение False указывает, что сервер каталогов не является сервером глобального каталога.

Затем анализатор сервера Exchange подключается к порту 3268 на сервере Exchange, чтобы убедиться, что порт отвечает.

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Сервер является сервером глобального каталога.

  • Порт 3268 не отвечает.

Примечание.
Это сообщение может отображаться в уведомлении об ошибке, если между компьютером, на котором выполняется анализатор сервера Exchange, и сервером глобального каталога существует сетевой экран.

Данная проблема обычно возникает, когда установлен флажок сервера глобального каталога, а сервер не был перезапущен.

Чтобы устранить эту проблему

  • Перезапустите сервер.

Дополнительные сведения о повышении роли контроллеров доменов см. в базе знаний Майкрософт в статье 304403, описывающей анализ, выполняемый в Exchange для выдвижения контроллера домена на роль сервера глобального каталога (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=304403).


Ошибка схемы класса группы
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2006-12-01

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, присутствует ли класс msExchBaseClass в атрибуте auxiliaryClass объектов групп схемы Active Directory.

В службе Active Directory предопределены классы, определяющие различные типы объектов, которые должны правильно обрабатываться в каталоге. Определения объектов создаются классами, вложенными друг в друга. Вложение классов образует родительски-дочерние отношения между ними.

Класс msExchBaseClass добавляется в службу Active Directory при установке серверов Exchange 2000 Server, Exchange Server 2003 и Exchange Server 2007. Класс msExchBaseClass является базовым дополнительным классом, который применяется ко всем классам, расширяемым объектами данных совместной работы для Exchange 2000 Server, Exchange Server 2003 и Exchange Server 2007 (CDOEX). CDOEX предоставляет фундаментальные классы и интерфейсы COM, используемые для управления большинством видов данных в хранилище Exchange.

Неправильное изменение схемы службы Active Directory может привести к нарушению отношений между классом msExchBaseClass и атрибутом auxiliaryClass объектов групп. Это нарушение может стать причиной неустойчивого поведения сервера Exchange, например к ошибкам обработки в службе Recipient Update Services, или помешать установке в организации новых серверов Exchange Server 200x.

Если анализатор Exchange обнаруживает отсутствие класса msExchBaseClass в атрибуте auxiliaryClass объектов групп в схеме Active Directory, то это свидетельствует о нарушении отношения. Если класс msExchBaseClass отсутствует в атрибуте auxiliaryClass объектов групп схемы Active Directory, анализатор сервера Exchange выводит сообщение об ошибке.

Чтобы устранить ошибку, обратитесь в службу поддержки пользователей Майкрософт (http://go.microsoft.com/fwlink/?LinkId=41364).


Для работы Exchange в размещеном режиме требуется наличие организации Exchange в основном режиме
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, настроена ли среда сервера Exchange как среда размещенного режима Exchange (Hosted Exchange). Если среда сервера Exchange является средой размещенного режима работы Exchange, анализатор сервера Exchange запрашивает Active Directory, чтобы определить, выполняется ли организация Exchange в смешанном режиме.

Если организация Exchange выполняется в смешанном режиме, выводится предупреждение. Для решений с работой Exchange в размещенном режиме требуется наличие организации в основном режиме.

После переключения в основной режим вновь переключиться в смешанный режим нельзя.

Чтобы переключиться в основной режим

  1. Запустите системный диспетчер Exchange: Нажмите кнопку Пуск и последовательно выберите Все программы, Microsoft Exchange, Диспетчер системы.

  2. В дереве консоли щелкните правой кнопкой мыши организацию, которую требуется переключить в основной режим, и выберите команду Свойства.

  3. На странице <Имя организации> Свойства в группе Изменить режим работы щелкните Изменить режим.

  4. Нажмите кнопку Да в окне предупреждения, если вы уверены, что хотите переключиться в основной режим без возможности отмены. Нажмите кнопку Применить, чтобы принять изменение режима Exchange.

Для использования всех возможностей основного режима Exchange необходимо перезапустить службу банка данных Microsoft Exchange на всех серверах Exchange в организации. Не требуется перезапускать все службы банка данных Microsoft Exchange одновременно, однако необходимо перезапустить службу на каждом сервере, чтобы этот сервер мог использовать все возможности основного режиме Exchange. Перезапустите эту службу на серверах после того, как будет завершена репликация изменения режима на локальный контроллер домена Microsoft Windows®.

Чтобы перезапустить службу банка данных Microsoft Exchange

  1. Нажмите кнопку Пуск, выберите команду Выполнить, введите services.msc и нажмите кнопку ОК.

  2. В области Службы (локальные) найдите службу Банк данных Microsoft Exchange.

  3. Щелкните эту службу правой кнопкой мыши и выберите команду Перезапустить.

Дополнительные сведения о средах работы Exchange в размещенном режиме см. в следующих статьях:

  • "Information for Hosters по адресу http://go.microsoft.com/fwlink/?LinkId=46307 (Сведения для компаний, предоставляющих услуги размещения)

  • «Chapter 23 - Hosted Service Environments» (Глава 23 - Среды размещенных служб) в документе Exchange Server 2000 Resource Kit (http://go.microsoft.com/fwlink/?LinkId=46326) (Набор ресурсов Exchange Server 2000)

Дополнительные сведения о переходе из смешанного режима в основной см. в статье 32779 базы знаний Майкрософт «How To Convert from Mixed Mode to Native Mode in Exchange» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779) (Инструкции по переходу от смешанного режима к основному в Exchange).


Роль сервера инфраструктуры FSMO не отвечает
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута fSMORoleOwner хозяина инфраструктуры в контексте именования доменов. Например, в домене с именем «contoso.com» fSMORoleOwner для хозяина инфраструктуры является атрибутом со значением CN=Infrastructure,DC=contoso,DC=com. Затем анализатор сервера Exchange пытается открыть LDP-подключение (Lightweight Directory Access Protocol) к TCP-порту 389 на контроллере домена, на котором в текущий момент находится эта роль. Если анализатору сервера Exchange не удается подключиться к этому контроллеру домена, на экран выводится сообщение об ошибке.

Хозяин инфраструктуры обновляет ссылки групп на пользователей при всяком переименовании или изменении членов групп внутри домена. Контроллер домена, на котором находится роль хозяина инфраструктуры домена группы, обновляет междоменную ссылку группы на пользователя, чтобы учесть новое имя пользователя. Периодически хозяин инфраструктуры сканирует учетные записи домена и проверяет членство в группах. Если учетная запись пользователя перемещается в новый домен, хозяин инфраструктуры идентифицирует новый домен учетной записи пользователя и обновляет соответствующим образом группу. После того как хозяин инфраструктуры обновит локально эти ссылки, он использует репликацию для обновления всех других реплик домена. Если хозяин инфраструктуры недоступен, эти обновления задерживаются. В любой момент в каждом домене может действовать в качестве хозяина инфраструктуры только один контроллер домена.

Чтобы устранить эту ошибку

  1. Убедитесь, что сервер каталогов, указанный в сообщении об ошибке, находится в оперативном режиме и доступен для серверов Exchange в используемой организации.

  2. Если этот сервер каталогов списан, роль хозяина инфраструктуры необходимо назначить другому контроллеру домена.

Дополнительные сведения о передаче роли хозяина инфраструктуры от одного контроллера домена другому контроллеру домена см. в следующих статьях базы знаний Майкрософт:

  • Сведения по приложению Microsoft Windows Server™ 2003 см. в статье 324801, содержащей инструкции по просмотру и передаче ролей FSMO в Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801).

  • Сведения по приложению Microsoft Windows 2000 Server см. в статье 255690, содержащей инструкции по просмотру и передаче ролей FSMO в графическом интерфейсе пользователя (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Неверный атрибут версии объекта организации Exchange
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2007-02-28

Средство анализа Microsoft Exchange Server запрашивает службу каталогов Active Directory для определения версии схемы Exchange. В частности, средство анализа Exchange Server проверяет следующий объект Active Directory для определения текущего значения атрибута rangeUpper:

CN=ms-Exch-Schema-Version-Pt,CN=Schema,CN=Configuration,DC=<DN-of-forest-root-domain>

Если значением атрибута rangeUpper является 4397, это означает, что Exchange 2000 Server установлен.

Если значением атрибута rangeUpper является 6870, это означает, что Exchange 2003 Server установлен.

Если для атрибута rangeUpper установлено значение 10637, это означает, что Exchange Server 2007 установлен.

При нахождении средством Exchange Server Analyzer других значений атрибута rangeUpper появится ошибка.

Значение атрибута rangeUpper вводится сервером Exchange 2000 Server или Exchange Server 2003 во время процесса ForestPrep. Значение, отличное от 4397, 6870 или 10637, обычно означает, что для выполнения команды ForestPrep была использована бета-версия или предварительная версия Exchange, либо, в случае с сервером Exchange Server 2007, использовался процесс PrepareDomain.

Чтобы решить эту проблему на серверах Exchange 2000 Server или Exchange Server 2003, еще раз запустите процесс ForestPrep с помощью установленной в среде финальной версии Exchange. Чтобы решить эту проблему на сервере Exchange Server 2007, еще раз запустите процесс PrepareSchema с помощью установленной в среде финальной версии Exchange. Запуск процесса ForestPrep или PrepareSchema должен осуществляться с учетной записью, имеющей как минимум следующие права:

  • Администратор предприятия

  • Администратор схемы

  • Администратор домена

  • Администратор локального компьютера (только при работе на рядовом сервере)

Исправление этой ошибки на сервере Exchange 2000 Server или Exchange Server 2003

  1. Запустите setup.exe /forestprep.

  2. Убедитесь, что процесс ForestPrep успешно выполнен.

Исправление этой ошибки на сервере Windows Server 2007

  1. Выполните команду setup.exe /PrepareSchema.

  2. Убедитесь, что процесс PrepareSchema успешно выполнен.

Дополнительные сведения об установке сервера Exchange и выполнении процесса PrepareSchema см. в следующей документации по продуктам:

  • «Инструкции по подготовке службы каталогов Active Directory и доменов» по адресу http://go.microsoft.com/fwlink/?LinkId=78453 (на английском языке)

Подробные сведения об установке Exchange и выполнении процесса ForestPrep см. в следующих статьях базы знаний корпорации Майкрософт:

  • 312371, «ИНСТРУКЦИИ: Подготовка леса с помощью процедуры ForestPrep в Exchange 2000 Server по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=312371 (на английском языке). Сведения, изложенные в данной статье, относятся к серверам Exchange 2000 Server и Exchange Server 2003.

  • 274737, «Проверка успешности выполнения процессов ForestPrep и DomainPrep на сервере Exchange 2000 Server и Exchange Server 2003» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=274737 (эта ссылка может указывать на содержимое полностью или частично на английском языке

  • 828765, «Разрешения, необходимые для установки компонентов Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828765) (эта ссылка может указывать на содержимое полностью или частично на английском языке).


Сведения об учетной записи ранней версии представляют административную группу в основном режиме
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, содержит ли данные атрибут msExchLegacyAccount каждого объекта административной группы Exchange.

Анализатор сервера Exchange Server также запрашивает службу Active Directory, чтобы определить значение атрибута msExchAdminGroupMode каждой административной группы. Значение атрибута msExchAdminGroupMode, равное 0, свидетельствует о том, что административная группа находится в основном режиме Exchange. Значение, равное 1, указывает на чистую среду Exchange Server 5.5, и значение, равное 2, указывает на смешанный режим Exchange.

Если анализатор сервера Exchange обнаружит, что атрибут msExchLegacyAccount содержит данные, и что значение атрибута msExchAdminGroupMode равно 0, на экран будет выведено сообщение об ошибке.

При переключении Exchange в основной режим атрибут msExchLegacyAccount удаляется. Этот атрибут используется только в смешанном режиме организаций Exchange, где все еще присутствует Exchange Server 5.5. Фактические данные атрибута — это учетная запись службы Exchange Server 5.5, и их наличие в атрибуте msExchLegacyAccount организации Exchange, находящейся в основном режиме, является причиной сбоев во время обновлений и установок пакетов обновлений. В действительности, даже наличие атрибута без каких-либо данных, содержащихся в нем, вызывает сбои. Это обусловлено тем, что программа установки Exchange использует этот атрибут в качестве средства определения, находится ли организация Exchange в смешанном режиме или в основном режиме. Если данный атрибут существует, программа установки Exchange выполняется в конфигурации смешанного режима для установки, которая на самом деле осуществляется в основном режиме.

Скорее всего, атрибут msExchLegacyAccount по-прежнему существует, если данные из службы Active Directory удалялись вручную с помощью оснастки Edit интерфейса ADSI (Active Directory Service Interfaces).

Эти данные необходимо удалить из msExchLegacyAccount вручную, изменив атрибут с помощью средства LDP (ldp.exe). Следует применять средство LDP или другой клиент, использующий протокол LDAP (Lightweight Directory Access Protocol) версии 3, которые полностью удаляют из каталога как данные, так и атрибут. В данном случае возможностей оснастки Edit интерфейса ADSI недостаточно, так как она удаляет только данные и оставляет атрибут. Программа LDP.exe включена в пакет средств поддержки Windows®.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью оснастки Edit интерфейса ADSI, средства LDP или другого клиента, использующего протокол LDAP версии 3, может привести к серьезным неполадкам. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы удалить атрибут msExchLegacyAccount

  1. Запустите программу LDP.exe.

  2. В меню Подключение щелкните Подключить; в диалоговом окне Подключение введите имя контроллера домена в том же лесу Active Directory, в котором находится используемая организация Exchange, а затем нажмите кнопку OK.

  3. В меню Подключение щелкните Привязать; в диалоговом окне Привязка введите учетные данные, обладающие, по крайней мере, всеми правами администратора Exchange на уровне группы администраторов, а затем нажмите кнопку OK.

  4. В меню Вид щелкните Дерево; в диалоговом окне Представление дерева оставьте поле пустым, если подключение выполняется из корневого домена, в противном случае введите CN=Конфигурация,DC=Имя_домена, DC=Суффикс_домена, где Имя_домена — корневой домен в лесу Active Directory, а Суффикс_домена — это суффикс домена, например, «com», «net» или «org». Нажмите кнопку ОК.

  5. Разверните представление иерархической структуры в левой области LDP, чтобы была открыта используемая административная группа. Чтобы сделать это, дважды щелкайте узлы в следующем порядке (обратите внимание, что каждый узел в LDP сопровождается полным различающимся именем; для ясности здесь приводятся только крайние левые различающиеся имена):

    1. DC=Имя_домена,

    2. CN=Конфигурация,

    3. CN=Службы,

    4. CN=Microsoft Exchange,

    5. CN=Имя_организации,

    6. CN=Административные группы,

    7. CN=Имя_административной_группы.

    В области сведений (справа) LDP, выполните прокрутку, чтобы просмотреть атрибуты своей административной группы. Если атрибут msExchLegacyAccount присутствует в списке, его следует удалить. Если атрибут msExchLegacyAccount присутствует, скорее всего, присутствуют также атрибуты msExchLegacyDomain и msExchEncryptedPassword. Если эти атрибуты содержатся в списке, их также необходимо удалить.

  6. В области иерархической структуры (слева) LDP щелкните правой кнопкой мыши Имя_административной_группы, а затем щелкните Изменить.

  7. В диалоговом окне Изменение убедитесь, что полное различающееся имя, содержащееся в поле Различающееся имя, правильно идентифицирует административную группу, которую требуется изменить. Административная группа должна быть представлена в следующем виде: CN=Имя_административной_группы,CN=Административные группы,CN=Имя_организации,CN=Microsoft Exchange,CN=Службы,CN=Конфигурация,DC=Имя_домена.

  8. В диалоговом окне Изменение в разделе Операции выберите Удалить; в разделе Изменить запись введите msExchLegacyAccount в поле Атрибут, а затем щелкните ВВОД. В результате этих действий атрибут msExchLegacyAccount добавится в Список записей. Элемент управления Список записей определяет атрибуты, которые будут удалены, если щелкнуть Выполнить.

  9. Если атрибут msExchLegacyDomain или атрибут msExchEncryptedPassword существует в административной группе, добавьте их в Список записей так, как описано на шаге 8.

  10. Если Список записей содержит атрибуты, которые необходимо удалить, щелкните Выполнить. В области сведений LDP появится сообщение о состоянии.

  11. В меню Подключение щелкните Создать, чтобы очистить область сведений LDP.

  12. Перейдите к CN=Имя_административной_группы и дважды щелкните объект. Ознакомьтесь с содержимым в правой области, чтобы убедиться, что атрибуты удалены.

Дополнительные сведения об изменении службы Active Directory с помощью средства LDP см. в базе знаний Майкрософт в статье 260745, описывающей: использование служебной программы LDP для изменения атрибутов объектов Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).


Недопустимый атрибут legacyExchangeDN для организации Exchange
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2007-02-01

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить формат атрибута legacyExchangeDN для объекта организации Exchange. Если анализатор сервера Exchange обнаружит, что атрибут legacyExchangeDN является недопустимым или имеет неправильный формат, на экран будет выведено сообщение об ошибке.

Это значение для данного атрибута представляется в следующем виде: /o=Организация, где Организация — это имя организации Exchange. Если значение начинается с выражения, отличного от /o= или /O=, считается, что оно имеет неправильный формат. Эту проблему необходимо устранить как можно скорее.

Исправление этой ошибки на серверах Exchange 2000 Server и Exchange Server 2003

  1. Выполните процедуру ForestPrep для сервера Exchange. Если во время выполнения этой процедуры программа установки определит, что атрибут legacyExchangeDN имеет неправильный формат, эта ошибка будет исправлена автоматически.

Исправление этой ошибки на сервере Windows Server 2007

  1. Выполните процесс PrepareAD сервера Exchange. Если во время этого процесса программа установки определяет, что атрибут legacyExchangeDN имеет неверный формат, то эта проблема будет автоматически устранена.

Дополнительные сведения о процедуре ForestPrep см. в базе знаний Майкрософт в статье 312371, описывающей инструкции по подготовке леса с помощью процедуры ForestPrep в Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=312371).

Дополнительные сведения о процессе PrepareAD см. в документе «Инструкции по подготовке службы Active Directory и доменов» по адресу http://go.microsoft.com/fwlink/?LinkId=78453 (на английском языке).

Дополнительные сведения об атрибуте legacyExchangeDN и его изменении см. в следующих статьях базы знаний Майкрософт:

  • Статья 324606 «Использование Legacydn.exe для правки имен организации Exchange или административных групп» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=324606 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 286783 «XADM: сообщение об ошибке при обновлении свободных и использующихся данных на сервере Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286783) (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 301585 «XADM: методы обхода проблем с MBconn.exe» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=301585 (эта ссылка может указывать на содержимое полностью или частично на английском языке).


Сведения о домене ранней версии представлены в административной группе основного режима
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, содержит ли данные атрибут msExchLegacyDomain каждого объекта административной группы Exchange.

Анализатор сервера Exchange Server также запрашивает службу Active Directory, чтобы определить значение атрибута msExchAdminGroupMode каждой административной группы. Значение атрибута msExchAdminGroupMode, равное 0, свидетельствует о том, что административная группа находится в основном режиме Exchange. Значение, равное 1, указывает на чистую среду Exchange Server 5.5, и значение, равное 2, указывает на смешанный режим Exchange.

Если анализатор сервера Exchange обнаружит, что атрибут msExchLegacyDomain содержит данные, и что значение атрибута msExchAdminGroupMode равно 0, на экран выводится сообщение об ошибке.

При переключении Exchange в основной режим атрибут msExchLegacyDomain удаляется. Этот атрибут используется только в смешанном режиме организаций Exchange, где все еще присутствует Exchange Server 5.5. Фактические данные атрибута — это домен учетных данных службы Exchange Server 5.5, и их наличие в атрибуте msExchLegacyDomain организации Exchange, находящейся в основном режиме, является причиной сбоев во время обновлений и установок пакетов обновлений. В действительности, даже наличие атрибута без каких-либо данных, содержащихся в нем, вызывает сбои. Это обусловлено тем, что программа установки Exchange использует этот атрибут в качестве способа определения, находится ли организация Exchange в смешанном режиме или в основном режиме. Если данный атрибут существует, программа установки Exchange выполняется в конфигурации смешанного режима для установки, которая на самом деле осуществляется в основном режиме.

Скорее всего, атрибут msExchLegacyDomain по-прежнему существует, если данные из службы Active Directory удалялись вручную с помощью оснастки Edit интерфейса ADSI (Active Directory Service Interfaces).

Эти данные необходимо удалить из msExchLegacyDomain вручную, изменив атрибут с помощью средства LDP (ldp.exe). Следует применять средство LDP или другой клиент, использующий протокол LDAP (Lightweight Directory Access Protocol) версии 3, которые полностью удаляют из каталога как данные, так и атрибут. В данном случае возможностей оснастки Edit интерфейса ADSI недостаточно, так как она удаляет только данные и оставляет атрибут. Программа LDP.exe включена в пакет средств поддержки Windows®.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью оснастки Edit интерфейса ADSI, средства LDP или другого клиента, использующего протокол LDAP версии 3, может привести к серьезным неполадкам. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы удалить атрибут msExchLegacyDomain

  1. Запустите программу LDP.exe.

  2. В меню Подключение щелкните Подключить; в диалоговом окне Подключение введите имя контроллера домена в том же лесу Active Directory, в котором находится используемая организация Exchange, а затем нажмите кнопку OK.

  3. В меню Подключение щелкните Привязать; в диалоговом окне Привязка введите учетные данные, обладающие, по крайней мере, всеми правами администратора Exchange на уровне группы администраторов, а затем нажмите кнопку OK.

  4. В меню Вид щелкните Дерево; в диалоговом окне Представление дерева оставьте поле пустым, если подключение выполняется из корневого домена, в противном случае введите CN=Конфигурация,DC=Имя_домена, DC=Суффикс_домена, где Имя_домена — корневой домен в лесу Active Directory, а Суффикс_домена — это суффикс домена, например, «com», «net» или «org». Нажмите кнопку ОК.

  5. Разверните представление иерархической структуры в левой области LDP, чтобы была открыта используемая административная группа. Чтобы сделать это, дважды щелкайте узлы в следующем порядке (обратите внимание, что каждый узел в LDP сопровождается полным различающимся именем; для ясности здесь приводятся только крайние левые различающиеся имена):

    • DC=Имя_домена,

    • CN=Конфигурация,

    • CN=Службы,

    • CN=Microsoft Exchange,

    • CN=Имя_организации,

    • CN=Административные группы,

    • CN=Имя_административной_группы.

    В области сведений (справа) LDP, выполните прокрутку, чтобы просмотреть атрибуты своей административной группы. Если атрибут msExchLegacyDomain присутствует в списке, его следует удалить. Если атрибут msExchLegacyDomain присутствует, скорее всего, присутствуют также атрибуты msExchLegacyDomain и msExchEncryptedPassword. Если эти атрибуты содержатся в списке, их также необходимо удалить.

  6. В области иерархической структуры (слева) LDP щелкните правой кнопкой мыши Имя_административной_группы, а затем щелкните Изменить.

  7. В диалоговом окне Изменение убедитесь, что полное различающееся имя, содержащееся в поле Различающееся имя, правильно идентифицирует административную группу, которую требуется изменить. Административная группа должна быть представлена в следующем виде: CN=Имя_административной_группы,CN=Административные группы,CN=Имя_организации,CN=Microsoft Exchange,CN=Службы,CN=Конфигурация,DC=Имя_домена.

  8. В диалоговом окне Изменение в разделе Операции выберите Удалить; в разделе Изменить запись введите msExchLegacyAccount в поле Атрибут, а затем щелкните ВВОД. В результате этих действий атрибут msExchLegacyAccount добавится в Список записей. Элемент управления Список записей определяет атрибуты, которые будут удалены, если щелкнуть Выполнить.

  9. Если атрибут msExchLegacyAccount или атрибут msExchEncryptedPassword существует в административной группе, добавьте их в Список записей так, как описано на шаге 8.

  10. Если Список записей содержит атрибуты, которые необходимо удалить, щелкните Выполнить. В области сведений LDP появится сообщение о состоянии.

  11. В меню Подключение щелкните Создать, чтобы очистить область сведений LDP.

  12. Перейдите к CN=Имя_административной_группы и дважды щелкните объект. Ознакомьтесь с содержимым в правой области, чтобы убедиться, что атрибуты удалены.

Дополнительные сведения об изменении службы Active Directory с помощью средства LDP см. в базе знаний Майкрософт в статье 260745, описывающей: использование служебной программы LDP для изменения атрибутов объектов Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).


Атрибут «LegacyExchangeDN» для данной административной группы не соответствует родительской организации
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2006-11-30

Чтобы определить значение атрибута legacyExchangeDN для объекта контейнера административной группы, анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®. Если анализатор сервера Exchange обнаруживает, что атрибут legacyExchangeDN административной группы не соответствует атрибуту legacyExchangeDN организации Exchange, выводится сообщение об ошибке.

Значение атрибута legacyExchangeDN используется в Exchange для идентификации объектов Exchange в Active Directory. Значение legacyExchangeDN представляет собой различающееся имя, которое указывает, соответствует ли данный объект организации Exchange. Например:

/o= организация /ou= административная группа

Такие объекты, как серверы и иерархии папок, частично наследуют значение атрибута legacyExchangeDN от соответствующей административной группы. Это означает, что неправильное имя административной группы будет унаследовано многими другими объектами.

Обычно проблемы с атрибутом legacyExchangeDN возникают в том случае, если администратор пытался непосредственным образом изменить данное значение. Это значение следует исправить, применяя, например, оснастку «Изменение ADSI», средство LDP (ldp.exe) или любой другой клиент, использующий протокол LDAP версии 3.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью оснастки «Изменение ADSI», средства LDP или другого клиента с LDAP версии 3, может привести к серьезным неполадкам. Для устранения этих проблем может потребоваться переустановка системы Microsoft Windows Server™ 2003, а также сервера Exchange Server 2003, сервера Exchange Server 2007 или обоих продуктов. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы устранить эту ошибку

  1. С помощью редактора Active Directory, например оснастки «Изменение ADSI», найдите в Active Directory нужный объект группы администрирования.

    Атрибут legacyExchangeDN находится в следующем местоположении:

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=Organization, CN=Administrative Groups, CN= Административная группа

  2. Введите новое строковое значение в следующей форме:

    /o= организация /ou= административная группа

Дополнительные сведения об использовании средства LDP см. в статье 260745 базы знаний Майкрософт «XADM: Using the LDP Utility to Modify Active Directory Object Attributes» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745) (Использование служебной программы LDP для изменения атрибутов объектов Active Directory).

Дополнительные сведения о работе с оснасткой «Изменение ADSI» см. в разделе «Adsiedit.msc: ADSI Edit» в справке Windows Server.


Параметр legacyExchangeDN для данной административной группы является недопустимым
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы проверить значение legacyExchangeDN административной группы. Это сообщение об ошибке отображается, если имя организации или административной группы, содержащееся в значении legacyExchangeDN, не соответствует фактическому имени организации или административной группы либо если отсутствует полностью часть значения.

Приложение Exchange использует значение legacyExchangeDN для идентификации объектов Exchange в службе Active Directory. Значение legacyExchangeDN — это различающееся имя, которое показывает, где находится объект в организации Exchange, например:

/o= организация /ou= административная группа

Объекты, такие как серверы и иерархические структуры папок, наследуют часть своих значений legacyExchangeDN из административной группы. Это означает, что если имеется проблема со значением административной группы, многие другие объекты могут наследовать ту же самую проблему.

В общем случае проблемы с legacyExchangeDN возникают, когда администратор пытается напрямую изменить значение. Это значение следует исправить, применяя, например, оснастку Edit интерфейса ADSI, средство LDP (ldp.exe) или любой другой клиент, использующий протокол LDAP версии 3.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью оснастки Edit интерфейса ADSI, средства LDP или другого клиента, использующего протокол LDAP версии 3, может привести к серьезным неполадкам. Для устранения этих неполадок может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение этих атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы устранить эту ошибку

  1. Используйте редактор службы Active Directory, например, оснастку Edit интерфейса ADSI, чтобы найти объект административной группы в Active Directory.

    Атрибут legacyExchangeDN можно найти по следующему пути:

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=Organization, CN=Administrative Groups, CN= Административная группа

  2. Введите новое строковое значение в следующем виде:

    /o= организация /ou= административная группа

Дополнительные сведения об использовании средства LDP см. в базе знаний Майкрософт в статье 260745, посвященной использованию служебной программы LDP для изменения атрибутов объектов Active Directory (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Дополнительные сведения о работе с оснасткой Edit интерфейса ADSI см. в разделе, описывающем «Adsiedit.msc: ADSI Edit», в интерактивной справке Windows Server.


Существуют неуниверсальные группы с включенной почтой
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить количество доменов в среде. Если анализатор сервера Exchange обнаружит несколько отдельных доменов Active Directory в лесу, тогда каждый домен опрашивается, чтобы определить, существует ли в этих доменах одна или несколько неуниверсальных групп с включенной почтой.

Если анализатор сервера Exchange определит, что в многодоменном лесу существуют неуниверсальные группы с включенной почтой, анализатор сервера Exchange выведет на экран предупреждение.

Если в многодоменном лесу используются локальные или глобальные группы рассылки доменов, проблемы с доставкой электронной почты могут возникать по следующим причинам:

  • Чтобы развернуть группы рассылки до уровня отдельных получателей, приложение Exchange связывается с сервером глобального каталога.

  • Хотя на сервере глобального каталога имеется список групп всех типов из каждого домена, сервер глобального каталога не содержит списка членов для локальных и глобальных групп доменов в удаленных доменах.

  • Если сообщение отправлено в глобальную группу рассылки, но распространено в домен, отличный от домашнего, приложению Exchange не удастся правильно доставить сообщение членам группы.

  • Так как классификатор не может расширить список рассылки, когда пользователь посылает сообщение в глобальную группу рассылки или в группу безопасности с включенной почтой в многодоменном лесу, пользователи в глобальной группе рассылки могут не получить сообщение.

  • Последней записью в журналах отслеживания является передача в классификатор. Отправитель сообщения не получает отчет о недоставке.

Чтобы устранить эту проблему и убедиться в доставке электронной почты, используйте в многодоменной среде универсальные группы рассылки. Членство в универсальных группах рассылки реплицируется на каждый сервер глобального каталога в каждом домене.

Дополнительные сведения об этой проблеме в частности и об универсальных группах рассылки в общем см. в следующих разделах:

  • Описание использования групп с включенной почтой в многодоменных средах в руководстве по администрированию Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47617).

  • Часть, посвященная областям действия групп, в разделе, содержащем общие сведения о группах, в Active Directory (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=51276).

  • Описание рекомендаций по созданию групп рассылки, основанных на запросах, в руководстве по администрированию Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47617).

Кроме того, дополнительные сведения содержатся в следующих статьях базы знаний Майкрософт:

  • Статья 231273, описывающая ситуацию, когда доставка сообщений в глобальные группы не выполняется (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=271930).

  • Статья 283051, описывающая ситуацию, когда электронная почта, отправленная в глобальную группу с включенной почтой, может исчезать (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=283051).

  • Статья 231273, описывающая использование типов и областей групп в Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231273).


Необходимо изменение системной политики подключения пользователей к почтовым ящикам
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2006-08-10

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута purportedSearch для всех объектов системной политики Exchange. Атрибут purportedSearch указывает аргумент поиска, используемый при применении политики.

Анализатор сервера Exchange также запрашивает Active Directory, чтобы определить значение атрибута msDS-Behavior-Version объекта леса в Active Directory в параметрах NTDS. Это значение отражает функциональный уровень леса Active Directory. Допустимые значения атрибута msDS-Behavior-Version представлены в следующей таблице.

Значение | Функциональный уровень леса
0 | Комбинированная операционная система Microsoft Windows® 2000 Server
1 | Промежуточная операционная система Microsoft Windows Server™ 2003
2 | Собственная операционная система Microsoft Windows Server 2003

Анализатор сервера Exchange также запрашивает Active Directory, чтобы определить значение атрибута revision контейнера Windows2003Update. Значение этого атрибута указывает, была ли выполнена служебная программа подготовки Active Directory (ADPrep.exe).

В заключение, анализатор сервера Exchange Server запрашивает WMI-класс (Microsoft Windows Management Instrumentation) Win32_OperatingSystem, чтобы определить значение раздела OSProductSuite. Значение раздела OSProductSuite указывает версию Windows, под управлением которой работает компьютер.

Если анализатор сервера Exchange обнаруживает, что следующие критерии должны быть верны, на экран выводится предупреждение.

  • Значение атрибута purportedSearch системной политики подключения пользователей к почтовым ящикам не равно (&(objectCategory=person)(objectClass=user)(mailnickname=*)(homeMdb=*))

  • Функциональный уровень леса Active Directory — режим промежуточной операционной системы Windows Server 2003 или собственной операционной системы Windows Server 2003.

  • Сервер Exchange работает не под управлением Windows Small Business Server 2003.

Чтобы избежать проблем с повторным присоединением почтового ящика, необходимо изменить системные политики. Это обновление можно сделать, используя ADSI Edit (ADSIEdit.msc), средство the LDP (ldp.exe) или другое средство редактора Active Directory.

Если Windows Server 2003 используется в качестве контроллера домена, а политика подключения пользователей к почтовым ящикам не обновлена, репликация связанных значений в Windows Server 2003 заставит службу обновления получателя переписать значение атрибута homeMDB новых пользователей, что вызовет повторное присоединение их почтовых ящиков к первому хранилищу на сервере.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью ADSI Edit, средства LDP или другого LDAP-клиента версии 3 может привести к возникновению серьезных неполадок. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Чтобы устранить эту ошибку

  1. Запустите ADSI Edit.

  2. Дважды щелкните контейнер Конфигурация, разверните последовательно CN=Services, CN=Microsoft Exchange и CN=<имя_организации_Exchange>.

  3. Выберите CN=System Policies.

  4. В правой области щелкните правой кнопкой мыши узел CN=Mailbox Enable User и выберите Свойства.

  5. Выполнив прокрутку вниз, выберите атрибут purportedSearch, а затем нажмите кнопку Изменить.

  6. Очистите значение атрибута, а затем настройте его с использованием следующего фильтра:

    (&(objectCategory=person)(objectClass=user)(mailnickname=*)(homeMdb=*))

    Примечание.
    Фильтр на шаге 6 показан в свернутом виде для удобства чтения. Убедитесь, что фильтр введен без пробелов и знаков возврата каретки.

  7. Нажмите кнопку OK, чтобы сохранить изменения и затем закройте ADSI Edit.

Дополнительные сведения об использовании средства LDP см. в статье 260745 базы знаний корпорации Майкрософт «XADM: использование служебной программы LDP для изменения свойств объектов Active Directory» по адресуhttp://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

Дополнительные сведения о данной проблеме и ее влиянии см. в базе знаний Майкрософт, в статье 903291, описывающей ситуацию, когда служба обновления получателей может перезаписать значение атрибута homeMDB для новых пользователей Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=903291).


В глобальном каталоге отключен интерфейс MAPI
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Чтобы установить, существует ли параметр реестра, средство анализа Microsoft® Exchange Server считывает его значение:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NTDS\Parameters\Initialize MAPI interface

Если Exchange Server Analyzer обнаружит наличие параметра Initialize MAPI interface, настроенного для хранения численного значения, Exchange Server Analyzer отобразит ошибку.

Если параметр реестра Initialize MAPI interface существует, клиенты Microsoft Office Outlook® не смогут связаться с адресной книгой, хранящейся на данном сервере. Для устранения этой проблемы удалите параметр реестра Initialize MAPI interface.

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что знаете, как восстановить реестр в случае возникновения проблем. Сведения о восстановлении реестра находятся в разделе справки «Восстановление реестра» файла Regedit.exe или Regedit32.exe.
Для устранения этого предупреждения

  1. Откройте редактор реестра, например, Regedit.exe или Regedit32.exe.

  2. Перейдите к разделу HKLM\System\CurrentControlSet\Services\NTDS\Parameters\Initialize MAPI interface

  3. Щелкните правой кнопкой мыши параметр Initialize MAPI interface и в контекстном меню выберите Удалить.

  4. Закройте редактор реестра и перезапустите сервер Exchange.

Перед правкой реестра для получения дополнительных сведений обратитесь к статье 256986 Базы Знаний Microsoft «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о параметре реестра Initialize MAPI interface находятся в статье 275127 Базы Знаний Microsoft «XADM:How to Configure Exchange Server 5.5 to Run on a Domain Controller that is a Global Catalog» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=275127)


Значение MaxActiveQueries было изменено
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить максимальное количество LDAP-запросов, которые могут быть обработаны одновременно. Это значение получается при просмотре текущих административных политик LDAP. В частности, анализатор сервера Exchange проверяет наличие параметра MaxActiveQueries. Если анализатор сервера Exchange обнаруживает, что параметр MaxActiveQueries существует и его значение не равняется 20, выводится сообщение о нестандартной конфигурации.

Административные ограничения LDAP помогают сбалансировать возможности и производительность Active Directory. Эти ограничения не дают отдельным операциям негативно влиять на производительность сервера. Превышение значения по умолчанию для этого параметра может негативно сказаться на инфраструктуре службы каталогов Active Directory.

С помощью значения MaxActiveQueries атрибута LDAPAdminLimits можно управлять максимальным количеством одновременных LDAP-запросов политики запросов по умолчанию. По умолчанию установлено ограничение, равное 20 запросам. Если ограничение превышено, служба каталогов Active Directory отображает сообщение «LDAP_ADMIN_LIMIT_EXCEEDED» и не обрабатывает дополнительные LDAP-запросы.

Чтобы запустить средство Ntdsutil.exe

  1. Нажмите кнопку Пуск, а затем щелкните Выполнить.

  2. В текстовом поле «Открыть» введите ntdsutil и нажмите клавишу ВВОД. Чтобы в любое время просмотреть справку, в командной строке введите ?.

Чтобы просмотреть параметры политики

  1. В окне командной строки средства Ntdsutil.exe введите LDAP policies, а затем нажмите клавишу ВВОД.

  2. В окне командной строки политики LDAP введите connections и нажмите клавишу ВВОД.

  3. В окне командной строки подключения сервера введите connect to server DNS-имя сервера, а затем нажмите клавишу ВВОД. Подключитесь к необходимому серверу.

  4. В командной строке подключения к серверу введите q и нажмите клавишу ВВОД, чтобы вернуться к предыдущему меню.

  5. В командной строке политики LDAP введите Show Values и нажмите клавишу ВВОД.

    Появится список существующих политик.
Примечание.
Эта процедура показывает только параметры политики домена по умолчанию. Если были применены особые параметры политики, здесь они отображаться не будут.

Чтобы изменить параметры политики

  1. В окне командной строки средства Ntdsutil.exe введите LDAP policies, а затем нажмите клавишу ВВОД.

  2. В окне командной строки политики LDAP введите Set MaxActiveQueries to 20 и нажмите клавишу ВВОД.

    Можно использовать команду Show Values для проверки внесенных изменений.

  3. Чтобы сохранить изменения, используйте команду Commit Changes.

  4. Завершив работу, введите q и нажмите клавишу ВВОД.

  5. Чтобы выйти из средства Ntdsutil.exe, в командной строке введите q и нажмите клавишу ВВОД.

Дополнительные сведения о настройке политики LDAP см. в статье 315071 базы знаний Майкрософт, посвященной инструкциям по просмотру и установке политики LDAP с помощью средства Ntdsutil.exe в Windows 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=315071).


Значение MaxPageSize отличается от заданного по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Анализатор сервера Microsoft® Exchange проверяет конфигурацию LDAP (Lightweight Directory Access Protocol) контроллера домена, оценивая атрибуты объекта политики стандартных запросов в контейнере Query-Policies в службе каталогов Active Directory®. Если анализатор сервера Exchange определяет, что значение MaxPageSize атрибута LDAPAdminLimits отличается от своего умолчания 1000, выводится сообщение о наличии нестандартной конфигурации.

Административные пределы LDAP балансируют функциональные возможности и производительность Active Directory. Эти пределы предотвращают неблагоприятное воздействие определенных операций на производительность сервера, а также повышают устойчивость сервера перед атаками типа «отказ в обслуживании». Увеличение этой настройки выше ее значения по умолчанию может иметь нежелательные последствия для инфраструктуры Active Directory.

Политики LDAP реализуются с помощью объектов класса queryPolicy. Объекты политики запросов могут быть созданы в контейнере Query-Policies, который является потомком контейнера Directory Service в контексте имен конфигурации.

Значение MaxPageSize из атрибута LDAPAdminLimits управляет числом записей, которое может быть возвращено для запроса LDAP. Значение по умолчанию: 1000 записей. Если возвращается более 1000 элементов, Active Directory увидит это максимальное значение и не вернет ничего.

Этот предел управляет поддерживаемыми количествами объектов Active Directory нескольких типов. Например, каждая организация может иметь до 1000 серверов, до 1000 административных групп и до 1000 списков адресов; каждая административная группа может иметь до 1000 групп маршрутизации; и каждая группа маршрутизации может иметь до 1000 соединителей.

Если использование другого значения не согласовано со службами поддержки по продуктам Майкрософт, следует восстановить для этого параметра значение 1000.

Чтобы запустить программу Ntdsutil.exe

  1. Нажмите кнопку Пуск и выберите команду Выполнить.

  2. В поле «Открыть» введите ntdsutil и нажмите клавишу ВВОД. Чтобы в любой момент просмотреть справку, введите в командной строке ?.

Чтобы просмотреть настройки политики

  1. В командной строке Ntdsutil.exe введите LDAP policies и нажмите клавишу ВВОД.

  2. В командной строке политики LDAP введите connections и нажмите клавишу ВВОД.

  3. В командной строке подключения к серверу введите connect to server DNS-имя_сервера и нажмите клавишу ВВОД. Будет выполнено подключение к серверу, с которым вы в данный момент работаете.

  4. В командной строке подключения к серверу введите q и нажмите клавишу ВВОД, чтобы вернуться к предыдущему меню.

  5. В командной строке политики LDAP введите Show Values и нажмите клавишу ВВОД.

    Появится экран с существующими политиками.

    Примечание.
    Эта процедура показывает только параметры стандартных политик домена. Если были применены пользовательские настройки политики, просмотреть их нельзя.

Чтобы изменить настройки политики

  1. В командной строке Ntdsutil.exe введите LDAP policies и нажмите клавишу ВВОД.

  2. В командной строке политики LDAP введите Set MaxPageSize to 1000 и нажмите клавишу ВВОД.

    Проверить изменения можно с помощью команды Show Values.

  3. Чтобы сохранить изменения, введите Commit Changes.

  4. По завершении введите q и нажмите клавишу ВВОД.

  5. Чтобы выйти из Ntdsutil.exe, в командной строке введите q и нажмите клавишу ВВОД.

Дополнительные сведения о настройке политик LDAP см. в статье 315071 базы знаний Майкрософт «» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=315071).


Слишком большое значение MaxPageSize
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение MaxPageSize для атрибута LDAPAdminLimits объекта используемой по умолчанию политики запросов в контейнере политик запросов. Если анализатор сервера Exchange обнаруживает, что значение параметра MaxPageSize больше 2500, на экран выводится сообщение об ошибке.

Административные предельные значения LDAP (Lightweight Directory Access Protocol) уравновешивают функциональные возможности и быстродействие службы каталогов Active Directory. Они позволяют предотвратить неблагоприятное воздействие некоторых операций на быстродействие сервера. Эти ограничения помогают серверу устоять в случае атак типа «отказ в обслуживании». Установка этого значения больше значения, используемого по умолчанию, может привести к неблагоприятным последствиям для инфраструктуры Active Directory.

Политики LDAP реализуются с использованием объектов класса queryPolicy. Объекты политики запросов могут создаваться в контейнере политик запросов, который является дочерним контейнером службы каталогов в контексте именования конфигурации.

Значение MaxPageSize атрибута LDAPAdminLimits определяет количество записей, которые могут быть возвращены в ответ на запрос LDAP. По умолчанию это количество составляет 1000 записей. Если возвращено больше 1 000 элементов, Active Directory учитывает это максимальное количество и ничего не возвращает.

От этого предельного значения зависит поддерживаемое число объектов Active Directory нескольких типов. Например, в каждой организации может быть до 1000 серверов, до 1000 административных групп и до 1000 списков адресов. Каждая административная группа может иметь до 1000 групп маршрутизации, а каждая группа маршрутизации может иметь до 1000 соединителей.

Если от служб технической поддержки продуктов корпорации Майкрософт не получено инструкций использовать другое значение, следует вернуть для этого параметра значение 1000.

Чтобы запустить программу Ntdsutil.exe

  1. Нажмите кнопку Пуск, а затем щелкните Выполнить.

  2. В текстовом поле «Открыть» введите команду ntdsutil и нажмите клавишу ВВОД. Чтобы просмотреть справку в любой момент, введите ? в командной строке.
Чтобы просмотреть параметры настройки политик

  1. В командной строке Ntdsutil.exe введите LDAP policies, а затем нажмите клавишу ВВОД.

  2. В командной строке политик LDAP введите connections, а затем нажмите клавишу ВВОД.

  3. В командной строке подключения к серверу введите connect to server <DNS-имя сервера> и нажмите клавишу ВВОД. Подключитесь к серверу, с которым вы работаете.

  4. В командной строке подключения к серверу введите q и нажмите клавишу ВВОД, чтобы вернуться в предыдущее меню.

  5. В командной строке политик LDAP введите Show Values и нажмите клавишу ВВОД.

    На экран будут выведены параметры настройки существующих политик.

    Примечание.
    Эта процедура позволяет просмотреть только параметры настройки политик, используемых по умолчанию в домене. Если применяются собственные параметры политик, просмотреть их таким образом не удастся.
Чтобы изменить параметры политик

  1. В командной строке Ntdsutil.exe введите LDAP policies, а затем нажмите клавишу ВВОД.

  2. В командной строке политик LDAP введите Set MaxPageSize to 1000 и нажмите клавишу ВВОД.

    Можно использовать команду Show Values для проверки изменений.

  3. Чтобы сохранить изменения используйте Commit Changes.

  4. По окончании введите q и нажмите клавишу ВВОД.

  5. Чтобы завершить работу программы Ntdsutil.exe в командной строке введите q и нажмите клавишу ВВОД.

Дополнительные сведения о настройке политик LDAP см. в базе знаний Майкрософт в статье 315071, содержащей инструкции по просмотру и настройке политики LDAP в службе каталогов Active Directory с помощью служебной программы Ntdsutil.exe (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=315071).


Имеется больше 800 списков адресов
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, превышает ли количество списков адресов в группе «Все списки адресов» в Active Directory значение 800. Если анализатор сервера Exchange обнаруживает, что в организации Exchange Server имеется больше 800 списков адресов, отображается предупреждение.

Рекомендуется сократить количество списков адресов в группе «Все списки адресов», чтобы оно было меньше 800, с целью избежать существенных задержек при выполнении операций службы обновления получателей. Если в организации Exchange Server имеется больше 800 списков адресов, при выполнении операций службы обновления получателей происходят существенные задержки, поскольку она помечает объекты с поддержкой почты.

Можно отключить службу обновления получателей и использовать сценарии для выполнения соответствующих задач.

Дополнительные сведения об отключении службы обновления получателей см. в базе знаний Майкрософт в статье 296479, посвященной описанию требований для отключения службы обновления получателей (http://go.microsoft.com/fwlink/?Linkid=3052&kbid=296479).

Дополнительные сведения о списках адресов и службе обновления получателей см. в разделе, посвященном управлению получателями и политиками получателей, руководства по администрированию Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).


Имеется более 800 списков глобальных адресов
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange Server запрашивает службу каталогов Active Directory®, чтобы определить, превышает ли количество списков адресов в группе All Global Address Lists в Active Directory значение 800. Если анализатор сервера Exchange Server обнаружит, что в организации Exchange Server имеется более 800 глобальных списков адресов, то отобразит соответствующее предупреждение.

Рекомендуется уменьшить количество списков адресов в группе всех глобальных списков адресов таким образом, чтобы их стало менее 800, чтобы избежать больших задержек при выполнении службы обновления получателей. Если в организации Exchange Server имеется более 800 глобальных списков адресов, работа службы обновления получателей значительно замедлится, когда она будет помечать объекты, для которых включена поддержка почты.

В качестве альтернативы можно отключить службу обновления получателей и использовать сценарии для обработки задач, выполняемых этой службой.

Дополнительные сведения об отключении службы обновления получателей см. в статье 296479 базы знаний Майкрософт, посвященной этой теме (http://go.microsoft.com/fwlink/?Linkid=3052&kbid=296479).

Дополнительные сведения о списках адресов и службе обновления получателей см. в разделе руководства по администрированию Exchange Server 2003, посвященном управлению получателями и политиками получателей (http://go.microsoft.com/fwlink/?LinkId=47617).


Атрибут msExchHomeMDB индексируется
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, настроен ли атрибут ссылки «Назад» группы маршрутизации для индексирования в службе Active Directory. В частности, анализатор сервера Exchange запрашивает службу Active Directory, чтобы определить текущее значение индексации для атрибута msExchHomeMDB, который является атрибутом объектов с включенной почтой в Active Directory. По умолчанию этот атрибут не индексируется. Если анализатор сервера Exchange обнаружит, что данный атрибут настроен для индексирования, на экран будет выведено сообщение о конфигурации, отличной от конфигурации по умолчанию.

Эффект от наличия индексированного атрибута msExchHomeMDB — минимальный. Из-за обслуживания индекса в памяти на серверах глобального каталога будет наблюдаться небольшое увеличение объема используемой памяти.

Возможен выигрыш от индексирования этого атрибута, если для организации выполняется любое из следующих условий:

  • Имеется много объектов с поддержкой электронной почты. В очень больших средах — имеющих 100 000 или более объектов с поддержкой почты — индексирование этого атрибута может также увеличить производительность системного диспетчера Exchange, а также задач, относящихся к Exchange, которые выполняются с помощью оснастки «Active Directory — пользователи и компьютеры».

  • Как было найдено, если часто используется программа слияния почтовых ящиков Exchange (ExMerge), индексирование атрибута msExchHomeMDB иногда необходимо в средних и больших средах, использующих средство ExMerge. Показано, что индексирование атрибута msExchHomeMDB увеличивает скорость и производительность работы средства ExMerge.

Если никакое из этих условий не соблюдается, рекомендуется вернуть эту настройку в значение по умолчанию, при котором индексация не выполняется.

Чтобы устранить эту ошибку

  • Никаких действий выполнять не требуется, так как сообщение выводится анализатором сервера Exchange исключительно в информационных целях.


Атрибут msExchRoutingGroupMembersBL проиндексирован
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, настроена ли индексация атрибута Routing Group Back-Link в Active Directory. В частности, чтобы определить текущее значение индексации для атрибута msExchRoutingGroupMembersBL, анализатор сервера Exchange проверяет следующий объект Active Directory:

CN=Configuration,DC=domain,DC=com, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Administrative Groups, CN=AdministrativeGroupName, CN=Routing Groups, CN=RoutingGroupName

По умолчанию этот атрибут не индексируется. Если анализатор сервера Exchange обнаруживает, что для этого атрибута настроена индексация, выводится сообщение о наличии конфигурации, не являющейся заданной по умолчанию.

Если оставить этот атрибут без индексации при развертывании Exchange в распределенной среде или в филиале, когда имеется множество групп маршрутизации, это может привести к снижению быстродействия. Например, если в организации Exchange имеются сотни групп маршрутизации, каждые 15 минут может наблюдаться повышенная активность на одном или нескольких серверах глобального каталога. Это повышение активности связано с повторным чтением конфигурации группы маршрутизации компонентом DSAccess в Exchange. В худшем случае эта активность может привести к загрузке всех ресурсов глобального каталога.

Чтобы свести к минимуму эту нагрузку на глобальный каталог, можно проиндексировать атрибут Routing Group Back-Link, что позволяет сократить время, затрачиваемое компонентом DSAccess на чтение сведений о группе маршрутизации, а также снизить нагрузку на глобальный каталог.

Чтобы устранить эту ошибку

  • Никаких действий выполнять не требуется, поскольку это сообщение, созданное анализатором сервера Exchange, носит исключительно информативный характер.

Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по быстродействию и масштабируемости Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47576).


Найдено несколько иерархий общих папок
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализа Microsoft® Exchange Server запрашивает службу каталогов Active Directory®, чтобы определить количество иерархий общих папок, для которых атрибут 1 имеет значение msExchPFTreeType. Значение 1 атрибута msExchPFTreeType говорит о том, что данная иерархия общих папок назначена в качестве иерархии общих папок для клиентов MAPI. Если средство анализа Exchange Server обнаружит, что атрибут msExchPFTreeType имеет значение 1 для нескольких иерархий общих папок, оно выдаст ошибку.

Это сообщение об ошибке говорит о том, что в организации Exchange было найдено более одной иерархии общих папок клиентов MAPI. Наличие нескольких иерархий общих папок клиентов MAPI может привести к возникновению проблем.

Чтобы решить эту проблему, можно воспользоваться средством правки Active Directory и установить для атрибута msExchPFTreeType всех иерархий общих папок, за исключением иерархии общих папок MAPI, значение 0. Если нужно, перенастройте хранилища почтовых ящиков на серверах Exchange, чтобы указать иерархию общих папок MAPI в качестве хранилища общих папок по умолчанию для клиентов MAPI.

Средства правки Active Directory:

  • ADSI Edit (AdsiEdit.msc);

  • средство LDP (ldp.exe).

Внимание!
Неправильное изменение атрибутов объектов Active Directory в программе ADSI Edit, средстве LDP (ldp.exe) или другом клиенте LDAP версии 3 может привести к серьезным ошибкам. В результате может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или и того, и другого. Будьте предельно осторожны, изменяя атрибуты объектов Active Directory.
Исправление ошибки

  1. Воспользовавшись средством правки Active Directory, найдите объекты общих папок в Active Directory. Объекты общих папок можно найти следующим образом: CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdminGroupName>, CN=Folder Hierarchies

  2. Измените значение атрибута msExchPFTreeType для всех объектов иерархии общих папок за исключением иерархии общих папок MAPI, установите новое значение 0.

  3. Закройте редактор Active Directory.

  4. Запустите системный диспетчер Exchange.

  5. Чтобы открыть свойства хранилища почтового ящика, щелкните Административные группы, раскройте вашу административную группу, раскройте Серверы, раскройте нужный сервер, а затем раскройте группу хранилища. Щелкните правой кнопкой мыши хранилище почтовых ящиков, свойства которого нужно просмотреть, и выберите Свойства.

  6. На вкладке Общие рядом с полем Хранилище общих папок по умолчанию нажмите кнопку Обзор.

  7. Выберите иерархию общих папок MAPI и нажмите кнопку OK дважды, чтобы сохранить изменения.

  8. Повторите шаги 5-7 для каждого хранилища почтовых ящиков.

Для получения дополнительных сведений об изменении Active Directory при помощи средства LDP см. статью 260745 базы знаний корпорации Майкрософт «XADM: Использование служебной программы LDP для изменения свойств объектов Active Directory» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Для получения дополнительных сведений об иерархиях общих папок для MAPI и приложений см. следующие источники:

  • Статья 258509 базы знаний корпорации Майкрософт «Описание типов деревьев общих папок в Exchange 2000 Server и Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258509)

  • Запись в блоге группы Exchange «Как работают общие папки с электронной почтой» (http://go.microsoft.com/fwlink/?LinkId=41913)


Рекомендуется параметр NeverPing
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2006-03-16

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить количество доверий, установленных для каждого домена. Если хотя бы для одного контроллера домена в каждом домене задано значение NeverPing, анализатор выводит сообщение с рекомендацией.

Анализатор сервера Exchange выводит предупреждение, если для каждого домена в среде Exchange Server 2003 выполняются следующие условия:

  • В домене установлено более 50 доверий

  • Для контроллеров домена в домене для параметра реестра NeverPing задано значение 0 (ноль).

Это предупреждение означает, что процесс LSASS.exe или процесс проверки подлинности пользователей на домене может быть отложен. LSASS (Local Security Authority Subsystem Service) — это процесс в операционных системах Microsoft Windows, который проверяет пользователя, входящего на компьютер или сервер на базе Windows.

Чтобы устранить причину проблемы, задайте для параметра реестра NeverPing для контроллеров домена значение 1 следующим образом.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неполадок. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы установить параметр NeverPing для контроллеров домена в среде Exchange 2003

  1. Нажмите кнопку Пуск, выберите команду Выполнить, введите regedit и нажмите кнопку ОК.

  2. Перейдите к следующему разделу реестра: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters.

  3. Щелкните раздел правой кнопкой мыши, в контекстном меню наведите указатель на пункт Создать, выберите Параметр DWORD, введите NeverPing и затем нажмите клавишу ВВОД.

  4. Щелкните правой кнопкой мыши NeverPing, в контекстном меню выберите Изменить, в поле «Значение» введите 1 и нажмите кнопку ОК.

  5. Закройте редактор реестра.

Перед началом редактирования реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт "Description of the Microsoft Windows registry" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения об этой проблеме и установке значения параметра NeverPing для контроллера домена см. в статье 825107 базы знаний Майкрософт «The Lsass.exe process may stop responding if you have many external trusts on a Windows 2000 Server-based domain controller» (Процесс Lsass.exe может прекратить отвечать на запросы, если на контроллере домена на основе Windows 2000 Server создано слишком много внешних доверий) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=825107).

Примечание.
Хотя в статье описывается Microsoft Windows 2000 Server, информация применима и к Windows Server™ 2003. Упомянутое в статье обновление для Windows Server 2003 не требуется.


Доступна более новая версия соединителя Active Directory
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить значение атрибута versionNumber для каждого объекта соглашения о соединении. Атрибут versionNumber представляет версию соединителя Active Directory, функционирующего на компьютере.

Средство анализатора сервера Microsoft® Exchange также запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version для Adc.exe — файла соединителя Active Directory Connector (ADC). WMI-ключ Version указывает номер сборки для этого файла.

Анализатор сервера Exchange выводит на экран предупреждение, если выполняются следующие условия:

  • Атрибут versionNumber объекта соглашения о соединении установлен равным 16973842.

  • Атрибут versionNumber объекта соглашения о соединении установлен равным 16973843, а значение ключа Version для Adc.exe меньше 7250.0.

Значение 16973842 указывает, что на компьютере выполняется исходная коммерческая версия соединителя Active Directory с компакт диска Exchange Server 2003, а значение 1697384 с ключом Version для Adc.exe меньшим, чем 7250.0, указывает, что на компьютере выполняется версия соединителя Active Directory, принадлежащая Exchange Server 2003 с пакетом обновления 1 (SP1).

В пакете обновления 2 (SP2) для Exchange Server 2003 доступна более новая версия соединителя Active Directory. Для обеспечения оптимальной работы рекомендуется использовать последнюю версию соединителя Active Directory.

Чтобы устранить причину появления этого предупреждения

  1. Перейдите к пакету обновления 2 (SP2) для Exchange Server 2003 по ссылке http://go.microsoft.com/fwlink/?LinkId=54751, чтобы загрузить последнюю версию соединителя Active Directory.

  2. Удалите существующую версию соединителя Active Directory и установите обновленную версию соединителя Active Directory.

Дополнительные сведения о соглашениях о соединении ADC см. в следующих статьях базы знаний Майкрософт:

  • статья 823601, «Active Directory Connector Requirements and Implications Throughout an Organization» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601) (Требования и условия использования в организации соединителя Active Directory Connector);

  • статья 303180, описывающая требования соглашения о соединении с соединителем Active Directory для смешанных административных групп (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180);

  • статья 317721, описывающая ситуацию, когда права владельца почтового ящика Exchange Server 5.5 удаляются при изменении соглашения о соединении с соединителем Active Directory, заключающемся в переходе от соглашения об одностороннем соединении на соглашение о двухстороннем соединении (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721).


Назначенный сервер Exchange для этого соглашения о соединении в организации не существует
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchServer2NetworkAddress для каждого объекта соглашения о соединении. Атрибут msExchServer2NetworkAddress представляет сетевой адрес сервера, участвующего в данном соглашении о соединении. Анализатор сервера Exchange просматривает административные группы в Active Directory для определения, входит ли имя этого сервера в число членов соглашения о соединении административной группы. Если имя этого сервера не перечислено в административной группе, возвращается ошибка.

В этой ошибке указывается потерянное соглашение о соединении. Это может произойти, если компьютер сервера Exchange был списан. Если компьютер сервера Exchange был удален из организации, следует изменить имя сервера Exchange на вкладке Подключения свойств соглашения о соединении в средстве администрирования Active Directory Connector (ADC). Если рассматриваемый сервер Exchange переведен в автономный режим для обслуживания или по каким-либо иным известным причинам, эту ошибку можно игнорировать.

Чтобы устранить эту ошибку

  1. Нажмите кнопку Пуск, щелкните Программы, щелкните Администрирование, а затем щелкните Соединитель Active Directory Connector.

  2. В левой области щелкните сервер ADC, поддерживающий соглашение о соединении, которое требуется изменить.

  3. В правой области щелкните правой кнопкой мыши соглашение о соединении, которое нужно изменить, и в контекстном меню выберите Свойства.

  4. Откройте вкладку Подключения.

  5. Измените имя сервера, используемого для подключения, на существующее.

Дополнительные сведения о соглашениях о соединении ADC см. в следующих статьях базы знаний Майкрософт:

  • 823601, «Active Directory Connector Requirements and Implications Throughout an Organization» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601) (Требования и условия использования в организации соединителя Active Directory Connector).

  • 303180, «Active Directory Connector Connection Agreement Requirements for Mixed Administration Groups» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180) (Требования для использования Active Directory Connector соглашения о соединении для смешанных административных групп).


Названный сервер автономной адресной книги в организации не существует.
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2006-12-03

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута offLineABServer объекта конфигурации автономной адресной книги. Атрибут offLineABServer является различающимся именем с одним значением, который хранит различающееся имя сервера Exchange, отвечающего за создание автономной адресной книги.

Анализатор сервера Exchange также проверяет значение атрибута distinguishedName сервера Exchange в Active Directory.

Если анализатор сервера обнаруживает, что сервер, указанный в атрибуте offLineABServer, не совпадает с обнаруженными атрибутами distinguishedName объектов сервера Exchange, и что атрибут offLineABServer не содержит строки DEL:, на экран выводится сообщение об ошибке.

Для каждой автономной адресной книги сервер Exchange на указанном сервере создает и сохраняет файлы автономной адресной книги в наборе общих папок. Если это сообщение появилось на экране, это означат, что сервер, указанный в объекте автономного списка адресов, не существует. Данная ситуация может произойти, если сервер автономной адресной книги списан или некорректно удален из топологии. Сервер Exchange не создает автономную адресную книгу до тех пор, пока не будет указан новый сервер.

Исправление этой ошибки на серверах Exchange 2000 Server и Exchange Server 2003

  1. В диспетчере Exchange в группе Получатели щелкните Автономные списки адресов. В правой области щелкните правой кнопкой мыши Автономный список адресов по умолчанию (или любой любой другой список автономных адресов, создавший это сообщение), и затем щелкните Свойства.

  2. На вкладке Общие в группе Сервер автономного списка адресов щелкните Обзор и затем щелкните сервер, который предполагается использовать.

Устранение причин появления этого предупреждения на сервере Windows Server 2007

  1. Откройте консоль управления Exchange.

  2. Разверните узлы Microsoft Exchange и Конфигурация организации, а затем выберите элемент Почтовый ящик.

  3. В области результатов перейдите на вкладку Автономная адресная книга.

  4. На вкладке Автономная адресная книга выберите параметр «Автономная адресная книга по умолчанию». В области действий нажмите Переместить для запуска мастера перемещения автономной адресной книги. Этот мастер позволяет переназначить формирование автономной адресной книги на другой сервер. Кроме того, он скопирует на указанный сервер уже существующие файлы адресных книг.

Использование среды управления Exchange для указания сервера, на котором будет выполняться формирование автономной адресной книги

  • Выполните следующую команду:

    Копировать код
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    где: <OAB> — это различающееся имя, имя в формате «домен\имя учетной записи» или идентификатор GUID автономной адресной книги, а <Server> указывает сервер Exchange Server, на котором будет выполняться выбранная операция.

    Например, для переназначения формирования автономной адресной книги на сервер SERVER01 необходимо ввести следующую команду:
Копировать код
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Дополнительные сведения о работе с автономными адресными книгами в Exchange Server 2003 см. в руководстве по настройке автономной адресной книги Exchange Server 2003 в статье Работа с хранилищем Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=47595 (на английском языке).

Дополнительные сведения о работе с автономными адресными книгами в Exchange Server 2007 см. в статье «Настройка организации > Почтовый ящик > Автономные адресные книги» по адресуhttp://go.microsoft.com/fwlink/?LinkId=79247 (на английском языке).


Сервер Exchange, выделенный для поддержки службы обновления получателей, не существует в организации
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2006-03-29

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута distinguishedName для каждого из объектов Exchange Server в каталоге. Анализатор сервера Exchange также запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchAddressListServiceLink для каждого из объектов службы обновления получателей в каталоге. Атрибут msExchAddressListServiceLink — это ссылка из службы списка адресов на компьютер сервера Exchange, на котором должен работать объект. Если Анализатор сервера Exchange определяет, что значение атрибута msExchAddressListServiceLink не содержит строку DEL: и атрибут не соответствует атрибуту distinguishedName для любого объекта-сервера Exchange в каталоге, возвращается ошибка.

Каждый экземпляр службы обновления получателей связан с одним компьютером сервера Exchange, на котором работает служба обновления получателей. Если выводится это сообщение, значит, экземпляр службы обновления получателей связан с компьютером сервера Exchange, который не существует в организации Exchange. Сервер, возможно, был списан или иным образом удален из топологии.

Чтобы этот экземпляр службы обновления получателей мог работать, его необходимо связать с существующим сервером Exchange.

Чтобы устранить эту ошибку

  1. Откройте диспетчер Exchange.

  2. В узле Получатели щелкните Службы обновления получателей. В правой области щелкните правой кнопкой мыши нужный экземпляр службы обновления получателей, и в контекстном меню выберите Свойства.

  3. На вкладке Общие в разделе Сервер Exchange нажмите кнопку Обзор и укажите новый сервер, на котором будет работать этот экземпляр.

  4. Нажмите кнопку ОК и затем снова ОК, чтобы изменение вступило в силу.

  5. Закройте диспетчер Exchange.

Дополнительные сведения о службе обновления получателей см. следующий документ и статьи базы знаний Майкрософт:

  • Раздел «Управление получателями и политиками получателей в Exchange Server 2003» в Руководстве администратора сервера Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47617) (может быть на английском языке);

  • Статья 328738, описывающая применение политик получателя службой обновления получателей (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738) (может быть на английском языке);

  • Статья 253828, описывающая заполнение списков адресов службой обновления получателей (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828) (может быть на английском языке);

  • Статья 246127, описывающая проверку работы службы обновления получателей (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127) (может быть на английском языке);

  • Статья 253770, описывающая задачи, выполняемые службой обновления получателей (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770) (может быть на английском языке).


Предложенный главный сервер группы маршрутизации не обнаружен в этой административной группе
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchRoutingMasterDN для каждого контейнера группы маршрутизации. Если анализатор сервера Exchange обнаружит, что значение атрибута msExchRoutingMasterDN не содержит допустимого имени сервера и атрибут не содержит строкового значения «DEL:», на экран будет выведено предупреждение.

Эта проблема может возникнуть, если предыдущий хозяин группы маршрутизации был списан или неправильно удален из топологии. Без хозяина группы маршрутизации приложение Exchange не сможет правильно обновлять и обслуживать топологию маршрутизации.

При создании группы маршрутизации первому серверу в этой группе маршрутизации назначается роль хозяина группы маршрутизации. Хозяин группы маршрутизации сохраняет сведения о текущем состоянии связи для своей группы маршрутизации и распространяет эти сведения на другие серверы в пределах группы маршрутизации. Хозяин группы маршрутизации наблюдает за конфигурацией маршрутизации, которая записывается в службу Active Directory только для его группы маршрутизации. Рядовые серверы могут передавать хозяину группы маршрутизации любые сведения о состоянии соединителя или доступности сервера. Например, если рядовой сервер пытается связаться с другим сервером в другой группе маршрутизации через соединитель, и эта связь оказывается недоступной, рядовой сервер немедленно уведомляет об этом хозяина группы маршрутизации. Подобным образом, когда сервер, не являющийся хозяином, получает новые сведения о состоянии связи, он немедленно передает сведения о состоянии соединителя хозяину группы маршрутизации, чтобы другие серверы могли получить сведения об изменении маршрутизации.

Чтобы устранить причину появления этого предупреждения

  1. В системном диспетчере Exchange и в разделе Административные группы разверните узел AdministrativeGroup, а затем разверните узел Группы маршрутизации.

  2. Разверните группу маршрутизации, а затем щелкните Члены.

  3. В правой области щелкните правой кнопкой мыши компьютер Exchange, который хотите настроить в качестве хозяина группы маршрутизации, а затем щелкните Установить как хозяина.

Дополнительные сведения о хозяинах групп маршрутизации см. в разделе, описывающем настройку топологии маршрутизации, в руководстве по транспорту и маршрутизации Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=47579).


Число соглашений о соединении общих папок меньше числа соглашений о соединении конфигураций
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, есть ли соглашение о соединении общей папки между Active Directory и каждым из сайтов Exchange Server 5.5. Для этого запрашивается как число соглашений о соединении общих папок, так и число соглашений о соединении конфигураций. Если анализатор сервера Exchange обнаруживает, что число соглашений о соединении общих папок меньше числа соглашений о соединении конфигураций, выводится предупреждение.

Это предупреждение означает, что по меньшей мере один сайт Exchange Server 5.5 не имеет соглашения о соединении общей папки с Active Directory и не может реплицировать объекты каталога для общих папок в Active Directory. Таким образом, отсутствует поток почты между почтовыми ящиками Exchange 2000 Server или Exchange Server 2003 и общими папками Exchange Server 5.5, а также поток почты между почтовыми ящиками Exchange Server 5.5 и общими папками почты Exchange 2000 Server или Exchange Server 2003.

Соглашения о соединении конфигураций создаются автоматически при установке компьютера Exchange 2000 Server или Exchange Server 2003 на сайт, содержащий только компьютеры Exchange Server 5.5. Соглашения о соединении публичных папок определяются пользователями. Если есть соглашение о соединении общей папки между каждым из сайтов Exchange Server 5.5 и Active Directory, будет по меньшей мере столько же соглашений о соединении общих папок, сколько присутствует соглашений о соединении конфигураций.

Чтобы создать соглашение о соединении общей папки

  1. На сервере соединителя Active Directory запустите диспетчер соединителя Active Directory. (В меню Пуск последовательно выберите Программы или Все программы и Microsoft Exchange, а затем щелкните Соединитель Active Directory).

  2. В дереве консоли щелкните узел Соединитель Active Directory. В правом окне приводятся соглашения о соединении. Определите с помощью этого списка, какие сайты не имеют соглашения о соединении общей папки.

  3. В меню Действия выберите команду Создать, а затем щелкните Соглашение о соединении общей папки. Откроется диалоговое окно Свойства.

  4. На вкладке Общие в поле Имя введите имя соглашения о соединении.

  5. В поле Служба соединителей Active Directory выберите сервер, на котором будет выполняться данное соглашение о соединении.

  6. На вкладке Подключения выберите сервер Active Directory и сервер Exchange Server 5.5, для которого нужно установить репликацию объектов общей папки, указав учетную запись и учетные данные для каждого из них.

  7. На вкладке Расписание укажите расписание репликации.

  8. Нажмите кнопку ОК.

Дополнительные сведения о соглашениях о соединении общих папок и конфигураций см. в следующих статьях базы знаний Майкрософт:

  • 264889, «XADM: Public Folder Connection Agreements» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=264889) (XADM: соглашения о соединении общих папок)

  • 281223, «Understanding Connection Agreements in Exchange» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=281223) (Общее представление о соглашениях о соединении в Exchange).


Создание автономной адресной книги настроено на постоянное обновление
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2006-12-04

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить, установлено ли значение атрибута offLineABSchedule в классе msExchOAB для создания автономной адресной книги. Значение атрибута offLineABSchedule определяет расписание создания автономного списка адресов. Если анализатор сервера Exchange обнаружит, что расписание создания автономной адресной книги настроено на постоянное обновление, на экран будет выведено сообщение об ошибке.

Автономная адресная книга — это контейнер, в котором хранится набор автономных списков адресов. Доступные автономные адресные книги настраиваются администраторами. Пользователи Microsoft Office Outlook® 2003 и Outlook 2007 могут выбирать автономные списки адресов для загрузки. Клиенты MAPI, такие как Outlook 2003 и Outlook 2007, позволяют загружать автономные списки адресов. Поэтому пользователи могут подготовить сообщения электронной почты даже тогда, когда не установлено подключение к серверу Exchange.

Время обновления автономных списков адресов можно планировать. Однако убедитесь, что в настроенном расписании обновлений предоставляется достаточно времени для завершения создания автономного адресного списка до запуска последующего обновления. Например, между соседними интервалами обновлений должен существовать промежуток равный, по крайней мере, 4 часам, если выполняются следующие условия:

  • Заданы три обновления в 24-часовом периоде.

  • Для обновления автономных списков адресов требуется четыре часа.

Частое обновление обычно не рекомендуется, поскольку оно может оказывать воздействие на производительность клиента и сервера следующими способами:

  • Сервер должен создавать автономную адресную книгу более часто. В зависимости от размера службы Active Directory создание может занимать несколько часов.

  • Для каждого обновления приложение Outlook должно создать копию автономной адресной книги на локальном компьютере и применить накопившиеся изменения, которые выбираются с сервера. Если объем автономной адресной книги на локальном компьютере равен 150 МБ, приложение Outlook должно создавать копию этих данных с каждым обновлением.

  • Приложение Outlook имеет механизм регулирования, который замедляет обновление автономной адресной книги при обнаружении активности пользователя. Когда активность пользователя постоянна, размер автономной адресной книги влияет на время выполнения обновлений. Этот временной период может варьироваться от одного часа до восьми часов.

Если необходимо увеличить частоту обновлений, убедитесь, что размер автономной адресной книги достаточно мал. Приемлемый размер несжатой автономной адресной книги должен находиться в диапазоне от 1 МБ до 25 МБ.

Установка времени обновления автономных списков адресов в серверах Exchange 2000 Server и Exchange Server 2003

  1. В окне Системный диспетчер дважды щелкните Получатели, а затем щелкните Автономные списки адресов.

  2. В области сведений дважды щелкните автономный список адресов, для которого хотите установить расписание обновлений.

    1. Чтобы установить предварительно настроенный интервал обновления, на вкладке Общие выберите один из предлагаемых интервалов в раскрывающемся списке Интервал обновления.

      Важно!
      Если в раскрывающемся списке выбрать Никогда не выполнять, автономный список адресов не будет обновляться.
    2. Чтобы установить особое расписание обновлений, щелкните Настройка. В диалоговом окне Расписание установите расписание обновлений в отображаемой сетке дат и времени, а затем нажмите кнопку OK.

Устранение причин появления этого предупреждения на сервере Windows Server 2007

  1. Откройте консоль управления Exchange.

  2. Разверните узлы Microsoft Exchange и Конфигурация организации, а затем выберите элемент Почтовый ящик.

  3. В области результатов перейдите на вкладку Автономная адресная книга.

  4. На вкладке Автономная адресная книга выберите параметр «Автономная адресная книга по умолчанию». В области действий щелкните Свойства.

  5. На вкладке Общие выберите время запуска из выпадающего списка Обновить расписание или щелкните Настройка для установки пользовательского расписания.

  6. Нажмите кнопку ОК, чтобы сохранить изменения.
Составление графика формирования автономных адресных книг в среде управления Exchange

  • Выполните следующую команду:

    Копировать код
    Set-OfflineAddressBook -Identity <OAB Name> -Schedule <Schedule>

    где: <OAB> — это различающееся имя, имя в формате «домен\имя_учетной_записи» или идентификатор GUID автономной адресной книги, а <Schedule> — это график формирования адресных книг в формате «день_начала.часы:минуты [AM/PM]». Для дней можно использовать следующие значения:

    • Полное название дня

    • Сокращенное название дня

    • Целое число от 0 до 6, где 0 соответствует воскресенью

    При использовании 24-часового формата времени, параметр AM/PM можно опустить.

    Например, чтобы настроить график формирования автономной адресной книги по умолчанию каждый день между 1:00 и 3:00 утра, необходимо ввести следующую строку:
Копировать код
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -Schedule 0.01:00-0.03:00,1.01:00-1.03:00,2.01:00-2.03:00,3.01:00-3.03:00,4.01:00-4.03:00,5.01:00-5.03:00,6.01:00-6.03:00

Дополнительные сведения см. в руководстве по оптимальному использованию автономной адресной книги (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47583).

Дополнительные сведения о работе с автономными адресными книгами в Exchange Server 2003 см. в руководстве по настройке автономной адресной книги Exchange Server 2003 в статье Работа с хранилищем Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=47595 (на английском языке).

Дополнительные сведения о работе с автономными адресными книгами в Exchange Server 2007 см. в статье «Настройка организации > Почтовый ящик > Автономные адресные книги» по адресуhttp://go.microsoft.com/fwlink/?LinkId=79247 (на английском языке).


Для расписания создания автономных адресных книг установлено значение "Never" (Никогда)
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2006-12-04

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута offLineABSchedule объекта конфигурации автономной адресной книги. Атрибут offLineABSchedule представляет расписание создания автономных адресных книг для объекта автономного списка адресов по умолчанию в контейнере списков адресов в Active Directory. Если анализатор сервера Exchange находит, что для атрибута offLineABSchedule установлено значение Never, на экран выводится предупреждение.

По умолчанию сервер Exchange поддерживает одну автономную адресную книгу. Сервер Exchange обновляет эту автономную адресную книгу (или создает ее новую версию) каждую ночь в течение цикла ее технического обслуживания. Можно создавать дополнительные автономные адресные книги и использовать следующую процедуру для проверки расписания их создания.

Данное предупреждение указывает, что расписание изменилось и теперь имеет значение Never. Сервер Exchange не обновляет существующую автономную адресную книгу до тех пор, пока не будет задано новое расписание. Это означает, что хотя пользователи могут загрузить существующую автономную адресную книгу, они не могут принимать обновлений.

Устранение причин этого предупреждения для серверов Exchange 2000 Server и Exchange Server 2003

  1. Откройте диспетчер Exchange.

  2. В группе Получатели щелкните Автономные списки адресов.

  3. В правой области щелкните правой кнопкой мыши По умолчанию Автономный список адресов и затем щелкните Свойства. Если нет необходимости в использовании автономной адресной книги, щелкните правой кнопкой мыши По умолчанию Автономная адресная книга и затем щелкните Удалить. В противном случае используйте эту процедуру для настройки расписания.

  4. На вкладке Общие выберите время запуска из раскрывающегося списка Интервал обновления и затем щелкните Настройка, чтобы задать настраиваемое расписание.

  5. Нажмите кнопку ОК, чтобы сохранить изменения.

Устранение причин появления этого предупреждения на сервере Windows Server 2007

  1. Откройте консоль управления Exchange.

  2. Разверните узлы Microsoft Exchange и Конфигурация организации, а затем выберите элемент Почтовый ящик.

  3. В области результатов перейдите на вкладку Автономная адресная книга.

  4. На вкладке Автономная адресная книга выберите параметр «Автономная адресная книга по умолчанию». В области действий щелкните Свойства.

  5. На вкладке Общие выберите время запуска из выпадающего списка Обновить расписание или щелкните Настройка для установки пользовательского расписания.

  6. Нажмите кнопку ОК, чтобы сохранить изменения.

Составление графика формирования автономных адресных книг в среде управления Exchange

  • Выполните следующую команду:

    Копировать код
    Set-OfflineAddressBook -Identity <OAB Name> -Schedule <Schedule>

    где: <OAB> — это различающееся имя, имя в формате «домен\имя_учетной_записи» или идентификатор GUID автономной адресной книги, а <Schedule> — это график формирования адресных книг в формате «день_начала.часы:минуты [AM/PM]». Для дней можно использовать следующие значения:

    • Полное название дня

    • Сокращенное название дня

    • Целое число от 0 до 6, где 0 соответствует воскресенью

    При использовании 24-часового формата времени, параметр AM/PM можно опустить.

    Например, чтобы настроить график формирования автономной адресной книги по умолчанию каждый день между 1:00 и 3:00 утра, необходимо ввести следующую строку:
Копировать код
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -Schedule 0.01:00-0.03:00,1.01:00-1.03:00,2.01:00-2.03:00,3.01:00-3.03:00,4.01:00-4.03:00,5.01:00-5.03:00,6.01:00-6.03:00

Дополнительные сведения о работе с автономными адресными книгами в Exchange Server 2003 см. в руководстве по настройке автономной адресной книги Exchange Server 2003 в статье Работа с хранилищем Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=47595 (на английском языке).

Дополнительные сведения о работе с автономными адресными книгами в Exchange Server 2007 см. в статье «Конфигурация организации > Почтовый ящик > Автономные адресные книги» по адресу http://go.microsoft.com/fwlink/?LinkId=79247 (на английском языке).


Обнаружена старая версия соглашения о подключении
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Для определения значений атрибута versionNumber объектов соглашений о подключении Active Directory Connector (ADC) средство анализа Microsoft® Exchange Server направляет запрос службе каталогов Active Directory®.

Если Exchange Server Analyzer определяет, что значение атрибута versionNumber хотя бы одного соглашения о подключении в организации Exchange, содержащей один и более компьютеров Exchange Server 2003, меньше 16973842, отображается предупреждение.

Значение, меньшее 16973842, означает, что соглашение о подключении было создано и находится под управлением ADC Exchange 2000 Server. Если в организации совместно с Exchange 2000 Server или Exchange Server 5.5 используется экземпляр Exchange Server 2003, замените все экземпляры ADC версиями, включенными в Exchange 2003. После установки версий ADC Exchange Server 2003 или Exchange Server 2003 с пакетом обновления 1 (SP1) будут обновлены и соглашения о подключении, используемые этой версией ADC. Атрибут versionNumber каждого соглашения о подключении получит самое новое значение.

Для устранения этого предупреждения

  1. Загрузите пакет обновления 1 (SP1) для Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=29090.

  2. Проведите полное резервное копирование на компьютере, использующем Exchange Server.

  3. На сервере, работающем с ADC Exchange 2000 Server, нажмите кнопку Пуск, выберите пункт меню Выполнить..., введите <путь>\adc\i386\setup.exe, где <путь>-- адрес, по которому загружен пакет обновления 1 (SP1) для Exchange Server 2003.

  4. На странице Добро пожаловать в Мастер установки Active Directory Connector нажмите кнопку Далее.

  5. На странице Обнаружена более ранняя установка выберите Переустановить для замены ADC Exchange 2000 Server на ADC Exchange Server 2003.

  6. На странице Завершение работы Мастера установки Active Directory Connector нажмите кнопку Готово.

Для получения дополнительных сведений об установке и обновлении ADC см. следующие статьи Базы знаний Microsoft:

  • 823601, «Требования и применения Active Directory Connector в пределах организации» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823601)

  • 822942, «Советы по установке Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822942)


Роль FSMO эмулятора основного контроллера домена не отвечает
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута fSMORoleOwner корня раздела каталога домена в контексте именования доменов. Например, в домене с именем contoso.com, fSMORoleOwner for эмулятор основного контроллера домена является атрибутом в DC=contoso,DC=com. Затем анализатор сервера Exchange пытается открыть LDAP-подключение к TCP-порту 389 на контроллере домена, на котором в текущий момент находится эта роль. Если анализатору сервера Exchange не удается подключиться к этому контроллеру домена, выводится сообщение об ошибке.

Эмулятор основного контроллера домена служит в качестве основного контроллера домена для совместимости с более ранними версиями операционных систем Microsoft Windows®. Microsoft Windows 2000 Server и Microsoft Windows Server™ 2003 взаимодействуют с рабочими станциями Microsoft Windows NT®, серверами-участниками и резервными контроллерами домена. Основной котроллер домена в домене Microsoft Windows NT 3.51 или Microsoft Windows NT 4.0 отвечает за следующие процессы:

  • Обработка изменения паролей пользователей и компьютеров

  • Репликация обновлений для резервных контроллеров домена

  • Запуск основного обозревателя домена

В любой момент главная роль хозяина эмулятора основного контроллера домена может быть назначена только одному контроллеру домена в каждом домене.

Чтобы устранить эту ошибку

  1. Убедитесь, что сервер каталогов, указанный в сообщении об ошибке, находится в оперативном режиме и доступен для серверов Exchange в организации.

  2. Если этот сервер каталогов был списан, необходимо привязать роль эмулятора основного контроллера домена к другому контроллеру домена.

Дополнительные сведения о передаче роли эмулятора основного контроллера домена от одного контроллера домена к другому контроллеру домена см. в следующих статьях базы знаний Майкрософт:

  • Для Windows Server 2003 см. статью 324801, содержащую инструкции по просмотру и передаче ролей FSMO в Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)

  • Для Windows 2000 Server см. статью 255690, содержащую инструкции по просмотру и передаче ролей FSMO в графическом интерфейсе пользователя (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Наследование разрешений заблокировано для объекта конфигурации
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2006-04-13

Средство анализатора сервера Microsoft® Exchange опрашивает каждый объект конфигурации Exchange в базе данных Active Directory®, чтобы определить, не заблокированы ли для него разрешения наследования. При обнаружении объекта конфигурации Exchange с заблокированными разрешениями наследования средство анализатора Exchange выводит сообщение об ошибке.

Анализатор сервера Exchange идентифицирует объект конфигурации, для которого заблокированы разрешения наследования.

Анализатор сервера Exchange извлекает избирательные списки управления доступом (Discretionary Access Control List, DACL) из Active Directory для объектов конфигурации Exchange. При установке Exchange для таких объектов конфигурации, как серверы Exchange и протоколы Exchange Server, по умолчанию задается наследование разрешений. При случайном отключении или изменении разрешений может быть заблокировано наследование разрешений для объекта конфигурации. В этом случае доступность Exchange Server может быть снижена из-за таких проблем потока почты, как задержка сообщений в очереди и сбои при подключении хранилищ.

Примечание.
Списком управления доступом (ACL) называется набор параметров безопасности, применяемый к целому объекту, группе свойств объекта или отдельному свойству объекта. Списки управления доступом бывают двух типов: избирательные и системные.

Проблему можно устранить, повторно включив разрешения наследования для объекта.

Чтобы повторно включить разрешения наследования для объекта конфигурации Exchange

  1. Активизируйте вкладку Безопасность окна свойств объекта в диспетчере Exchange, настроив соответствующий параметр реестра. Подробное описание процедуры см. в статье 264733 базы знаний Майкрософт, описывающей активизацию вкладки «Безопасность» для объекта организации в Exchange 2000 и Exchange 2003" (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264733).

    Примечание.
    По умолчанию вкладка Безопасность не активизирована в окне свойств объекта конфигурации.

  2. Откройте диспетчер Exchange, найдите нужный объект и включите для него наследование разрешений.

  3. Перезапустите Exchange Server.

Дополнительные сведения об избирательных списках управления доступом в Windows Server 2003 Active Directory см. в разделе, описывающем принципы работы дескрипторов безопасности и списков управления доступом

((может быть на английском языке) http://go.microsoft.com/fwlink/?LinkId=64193).

Дополнительные сведения о наследовании разрешений см. в разделе, описывающем принципы функционирования разрешений (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=64195).


Наследование разрешений заблокировано для объекта домена
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2006-04-13

Средство анализатора сервера Microsoft® Exchange проверяет объекты домена Active Directory®, такие как контейнеры и подразделения. Если наследование разрешений заблокировано для контейнеров или подразделений, анализатор выведет сообщение об ошибке.

Анализатор сервера Exchange идентифицирует определенный объект.

Если объект домена Active Directory был изменен, это перекрывает изменения списка управления доступом. Даже если вручную установлен параметр «Наследовать от родительского объекта», это наследование отключается при изменении списка управления доступом. Это приводит к неполадкам, связанным со службой обновления получателей, так как эта служба не имеет достаточных разрешений для подразделения Active Directory, в котором размещены учетные записи.

Такое поведение может возникнуть, если снять флажок Переносить наследуемые от родительского объекта разрешения на этот объект в подразделении Active Directory, в котором размещены учетные записи.

Чтобы устранить эту неполадку, используйте оснастку «Active Directory — пользователи и компьютеры» или средство «Edit» интерфейса ADSI, чтобы восстановить наследуемые разрешения для подразделения. Следуйте шагам, подробно описанным во втором сценарии статьи 254030 базы знаний Майкрософт, посвященной невозможности обработать учетные записи службой обновления получателей в Exchange 2000 Server и Exchange Server 2003 из-за отсутствующих разрешений (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=254030).

Дополнительные сведения о списках управления доступом в Active Directory операционной системы Microsoft Windows Server 2003™ см. в статье, посвященной работе дескрипторов безопасности и спискам управления доступом (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=64193).

Дополнительные сведения о наследовании разрешений см. на веб-узле, посвященном разрешениям (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=34203).


Иерархия общих папок не обнаружена
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить число иерархий общих папок, в которых значение, равное 1, присвоено атрибуту msExchPFTreeType. Значение 1 атрибута msExchPFTreeType показывает, что иерархия общих папок является иерархией общих папок, назначенных для клиентов MAPI. Если анализатор сервера Exchange определяет, что ни в одной из иерархий общих папок в организации Exchange значение 1 не присвоено атрибуту msExchPFTreeType, то он выводит на экран сообщение об ошибке.

Сообщение об ошибке указывает на то, что никакой иерархии общих папок для клиентов MAPI в организации не существует. Отсутствие иерархии общих папок для клиентов MAPI может создать проблемы. Например, отсутствие иерархии общих папок для клиентов MAPI может привести к неудаче обновления виртуального сервера Exchange, работающего в каластере Microsoft Windows® server.

Для решения этой проблемы можно использовать средство редактирования Active Directory, чтобы установить значение дляатрибута msExchPFTreeType иерархии общих папок для клиентов MAPI, равное 1. Следующие средства представляют собой средства редактирования Active Directory:

  • Средство ADSI Edit (AdsiEdit.msc)

  • Средство LDP (ldp.exe)

Необходимо изменить лишь иерархию общих папок MAPI. Если организация Exchange содержит иерархию общих папок, убедитесь, что вы изменяете атрибут лишь для иерархии общих папок MAPI.

После присвоения атрибуту msExchPFTreeType иерархии общих папок MAPI значения 1 следует настроить хранилища почтовых ящиков на ваших серверах Exchange так, чтобы иерархия общих папок MAPI указывалась в качестве хранилища общих папок по умолчанию.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью средства ADSI Edit, средства LDP или другого клиента, использующего протокол LDAP версии 3, может привести к серьезным неполадкам. Для устранения этих проблем может потребоваться переустановка Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Чтобы устранить эту ошибку

  1. Используйте средство редактирования Active Directory для определения местоположения объектов иерархии общих папок в Active Directory. Объекты иерархии общих папок можно найти в CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdminGroupName>, CN=Folder Hierarchies

  2. Изменение атрибута msExchPFTreeType посредством ввода 1 в качестве нового значения.

  3. Закройте редактор Active Directory.

  4. Откройте диспетчер Exchange.

  5. Для доступа к меню "Свойства" каждого хранилища почтовых ящиков щелкните Административные группы, последовательно разверните вашу административную группу, узел Серверы, ваш сервер и вашу группу хранения. Затем щелкните правой кнопкой мыши хранилище почтовых ящиков, свойства которого предполагается изменить, и выберите меню Свойства.

  6. На вкладке Общие для поля Общее хранилище по умолчанию нажмите кнопку Обзор.

  7. Выберите иерархию общих папок MAPI и затем дважды нажмите кнопку ОК, чтобы сохранить изменения.

  8. Повторите шаги 5—7 для каждого хранилища почтовых ящиков.

Дополнительные сведения об изменении службы Active Directory с помощью средства LDP см. в базе знаний Майкрософт в статье 260745 "XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (XADM: использование служебной программы LDP для изменения атрибутов объектов Active Directory) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Дополнительные сведения об иерархиях общих папок для MAPI и для приложений см. в следующих ресурсах:

  • База знаний Майкрософт, статья 258509, "Description of public folder tree types in Exchange 2000 Server and in Exchange Server 2003" (Описание типов деревьев общих папок в Exchange 2000 Server и в Exchange Server 2003) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258509)

  • Запись в Exchange Team Blog, "How mail-enabled Public Folders work" (Как работают общие папки с поддержкой почты) (http://go.microsoft.com/fwlink/?LinkId=41913)


Расписание репликации соглашения о соединении получателя не установлено как «Всегда»
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута activationStyle на каждом соглашении о соединении соединителя Active Directory. Атрибут activationStyle относится к тому, как часто выполняется соглашение о соединении соединителя Active Directory. Значение 0 указывает, что расписание репликации установлено как Никогда. Значение 1 указывает, что расписание установлено как В указанное время. Значение 2 указывает, что расписание установлено как Всегда.

Анализатор сервера Exchange Server также запрашивает службу каталогов Active Directory, чтобы определить значение атрибута msExchServer2SearchFilter на каждом объекте соглашении о соединении соединителя Active Directory. Атрибут msExchServer2SearchFilter представляет фильтр поиска, который будет использоваться при поиске в каталоге.

Если анализатор сервера Exchange обнаружит, что значение атрибута activationStyle не равняется Всегда и что атрибут msExchServer2SearchFilter реплицирует сведения получателя, отображается предупреждение.

Обычно рекомендуется устанавливать для расписания репликации на соглашении о соединении на стороне получателя значение «Всегда». В некоторых случаях, установка любого другого расписания на соглашении о соединении может привести к отчетам о недоставке после перемещения почтовых ящиков с сайтов Exchange Server 5.5 в организации Exchange Server 2003.

Чтобы устранить причину появления этого предупреждения

  1. Откройте оснастку «Службы соединителей Active Directory» консоли MMC.

  2. Откройте Соглашение о соединении.

  3. На странице Свойства соглашения_о_соединении выберите вкладку Расписание, выберите Всегда, затем нажмите кнопку ОК.

Дополнительные сведения о развертывании соединителей Active Directory и настройке соглашений о соединениях см. в руководстве по развертыванию Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47569).


Политика получателей включает переменные
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализа сервера Microsoft® Exchange запрашивает службу каталога Active Directory® для определения значения атрибута gatewayProxy для каждого объекта политики получателей. Если средство анализа сервера Exchange находит объект политики получателей, который содержит строку SMTP:% в атрибуте gatewayProxy, отображается сообщение об изменении настройки по умолчанию.

Если вы изменили политику получателей для создания адресов SMTP при помощи строк замены, в политике получателей будут содержаться переменные. Использование переменных в политике получателей по умолчанию может вызвать проблемы репликации в Exchange 2000 Server до установки пакета обновления 2 (SP2). Поэтому рекомендуется не использовать переменные в политиках получателей или обновить Exchange 2000 Server последним пакетом обновления. Exchange 2000 Server SP2 и выше поддерживают политику получатилей по умолчанию с переменными.

Чтобы изменить любую политику получателей, выполните следующее

  1. Запустите Системный диспетчер Exchange.

  2. Выберите Организация, затем Получатели, затем Политики получателей.

  3. Дважды щелкните политику, которую нужно изменить.

  4. Щелкните вкладку Электронная почта, затем исправьте нужные адреса SMTP или правило создания.

Для получения дополнительных сведений о настройке политик получателей см. статью 249299 базы знаний Майкрософт «ОПИСАНИЕ: Настройка политик получателей в Exchange» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=249299).

Для получения дополнительных сведений об использовании правил создания для индивидуальной настройки адресов SMTP см. статью 822447 базы знаний Майкрософт «Как изменить адрес электронной почты SMTP при помощи политик получателей» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822447).

Для получения дополнительных сведений о проблемах, возникающих с сервером Exchange 2000, если политика получателей по умолчанию содержит переменные, см. статью 271339 базы знаний Майкрософт «XADM: Появление сообщения «Невозможно подключить базу данных» и кода ошибки 9546» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=271339).

Для получения новейших пакетов обновлений Exchange 2000 Server см. раздел «Загрузка для Exchange 2000 Server» (http://go.microsoft.com/fwlink/?LinkId=33457).


По-видимому, произошел останов службы обновления получателей
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchServer1HighestUSN для всех объектов службы обновления получателей в Active Directory. Анализатор сервера Exchange также опрашивает службу каталогов Active Directory, чтобы определить значение атрибута activationStyle для всех объектов службы обновления получателей в Active Directory. Атрибут activationStyle показывает интервал обновления для службы обновления получателей.

Анализатор сервера Echange также опрашивает службу Active Directory, чтобы определить значение атрибута highestCommittedUSN для атрибута RootDSE контроллера домена, используемого службой обновления получателей. Атрибут highestCommittedUSN является максимальным порядковым номером обновления для всех объектов на сервере, которые сохранены в базе данных на данном контроллере домена.

Анализатор сервера Exchange также опрашивает службу каталогов Active Directory, чтобы определить значение атрибута msExchServer1LastUpdateTime для всех объектов службы обновления получателей. Атрибут msExchServer1LastUpdateTime показывает дату и время последнего обновления, выполненного при последней успешной синхронизации из данного каталога.

На экран будет выведено предупреждение, если анализатор сервера Exchange обнаружит, что выполнены три следующих условия:

  • Атрибут activationStyle, равный 2, указывает, что расписание для данной службы обновления получателей установлено в режим «Всегда».

  • Порядковый номер, содержащийся в значении msExchServer1HighestUSN меньше порядкового номера, содержащегося в значении highestCommittedUSN, на 5000 или более.

  • Прошло шесть или более часов после записи отметки времени в атрибут msExchServer1LastUpdateTime.

Это предупреждение указывает, что заданная служба обновления получателей не выполнялась в течение нескольких часов и, возможно, остановилась.

Чтобы устранить причину появления этого предупреждения

  1. Откройте диспетчер Exchange.

  2. Разверните узел Получатели и выберите Службы обновления получателей.

  3. Щелкните правой кнопкой мыши указанную службу обновления получателей и в контекстном меню выберите команду Обновить.

  4. Подождите в течение 30 минут, а затем повторно запустите анализатор сервера Exchange, чтобы увидеть, существует ли по-прежнему условие предупреждения. Если условие соблюдается, перейдите к шагу 5. Если условие больше не существует, никаких дополнительных действий выполнять не требуется.

  5. Запустите службу системного помощника Microsoft Exchange.

Дополнительные сведения о службе обновления получателей см. в следующих статьях базы знаний Майкрософт:

  • статья 253770, описывающая задачи, выполняемые службой обновления получателей ( может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770);

  • статья 253828, описывающая, как служба обновления получателей заполняет списки адресов (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828);

  • статья 253838, описывающая применение системных политик службой обновления получателей (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838);

  • статья 328738, описывающая применение политик получателя службой обновления получателей (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738).


Служба обновления получателей не обработала все изменения
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2006-03-16

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, существуют ли значения для атрибута gatewayProxy объекта службы обновления получателей в Active Directory. Если анализатор сервера Exchange обнаруживает заданные значения атрибута gatewayProxy какого-либо объекта службы обновления получателей, на экран выводится предупреждение.

Это предупреждение показывает, что атрибут gatewayProxy объекта службы обновления получателей содержит старые данные, которые не были полностью обработаны. Эти данные следует удалить вручную.

Старые данные из атрибута gatewayProxy необходимо удалить; в противном случае эти адреса будут находиться в состоянии применения. Если администратор решит изменить политику, используя варианты «Перестроить» или «Обновить сейчас», то правильные адреса пользователей могут быть случайно перезаписаны, что приведет к изменению SMTP-адресов для каждого пользователя. Дополнительные сведения см. в блоге Exchange в статье, посвященной политикам получателей и безупречным сайтам Exchange 2000 и Exchange 2003.

Примечание.
Ссылка на этот блог приводится только с информационной целью. Его содержимое может изменяться без уведомления.

Атрибут gatewayProxy объекта службы обновления получателей может содержать старые данные, которые не были полностью обработаны, если выполнено любое из следующих условий:

  • Имеются неполадки репликации Active Directory. Если диспетчер Exchange использует контроллер домена, отличный от используемого сервером Exchange, на котором выполняется служба обновления пользователей, могут возникать задержки и другие неполадки репликации Active Directory.

  • Существуют не связанные с транзакциями проблемы со временем выполнения операций, приводящие к потере изменений. Это может происходить, когда диспетчер Exchange и системный помощник одновременно обращаются к атрибуту gatewayProxy. И диспетчер Exchange, и системный помощник пытаются прочитать атрибут, внести изменения и записать атрибут обратно.

Необходимо удалить старые данные с помощью таких средств, как Active Directory Service Interfaces (ADSI) Edit (AdsiEdit.msc), LDP (ldp.exe), или другого клиента LDAP версии 3.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью оснастки ADSI Edit, средства LDP или другого клиента, использующего протокол LDAP версии 3, может привести к серьезным неполадкам. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Чтобы устранить причину появления этого предупреждения

  1. Установите интервал обновления Никогда для службы обновления получателей следующим образом:

    1. Откройте диспетчер Exchange.

    2. Разверните узел Получатели, а затем — Службы обновления получателей.

    3. Щелкните правой кнопкой мыши службу обновления получателей, в которую требуется внести изменения, и выберите команду Свойства.

    4. На вкладке Общие в списке Интервал обновления задайте расписание Никогда не выполнять.

  2. Подождите приблизительно одну-две минуты.

  3. Затем воспользуйтесь средством ADSI Edit или аналогичным инструментом, чтобы найти объект службы обновления получателей, для которого атрибут gatewayProxy содержит старые данные. Объекты службы обновления получателей имеют следующее размещение:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=организация,CN=Address Lists Container,CN=Recipient Update Services

    1. Щелкните правой кнопкой мыши объект службы обновления получателей, содержащий старые данные, и выберите команду Свойства.

    2. На вкладке Редактор атрибутов выполните прокрутку вниз и выберите атрибут gatewayProxy.

    3. Нажмите кнопку Правка для изменения данного атрибута.

    4. В поле «Значения» выберите устаревший тип данных для удаления, щелкните Удалить и нажмите кнопку ОК. Повторите это действие, пока все типы адресов не будут удалены.

    5. Нажмите кнопку ОК, чтобы сохранить изменения, а затем закройте редактор ADSI Edit.

  4. Запустите репликацию каталогов после очистки атрибута gatewayProxy. Перед повторным запуском службы обновления получателей убедитесь в том, что выполнена репликация.

  5. Заново настройте службу обновления получателей, чтобы использовалось исходное расписание.

  6. При необходимости повторно примените особые политики получателей. Используйте оснастку «Active Directory - сайты и службы» для выполнения репликации Active Directory вручную.

Дополнительные сведения по этому вопросу см. в базе знаний Майкрософт в статье 821743, посвященной описанию ситуации, когда атрибут gatewayProxy объекта службы обновления получателей не очищен (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821743).

Дополнительные сведения об использовании средства LDP см. в базе знаний Майкрософт в статье 260745, посвященной использованию служебной программы LDP для изменения атрибутов объектов Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Дополнительные сведения о принудительной репликации каталогов см. в базе знаний Майкрософт в статье 232072, в которой описывается процедура запуска репликации между партнерами по прямой репликации Active Directory (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072).

Дополнительные сведения об использовании средства ADSI Edit см. в разделе «Adsiedit.msc: ADSI Edit» справки Windows Server 2003.


Полная перестройка службы обновления получателей
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msDS-ReplAttributeMetaData объекта службы обновления из контроллера домена конфигурации, используемого Exchange Server. Атрибут msDS-ReplAttributeMetaData содержит дату и время последнего изменения атрибута, а также другие сведения. Если анализатор сервера Exchange обнаруживает, что с даты, указанной в атрибутеmsDS-ReplAttributeMetaData, прошло менее пяти дней, на экран выводится предупреждение.

Это предупреждение указывает на то, что недавно была запланирована полная перестройка службы обновления получателей. Если была назначена полная перестройка, то при следующем запуске службы обновления получателей по расписанию или с помощью команды Обновить, служба обновления получателей проверяет каждый объект вместо того, чтобы опросить только новые объекты. Данная процедура может занять много времени и привести к задержкам в системе.

Если требуется выполнить полную перестройку, можно игнорировать это предупреждение. Если полная перестройка не была запланирована, то для устранения данной проблемы можно воспользоваться оснасткой «Edit» интерфейса ADSI (AdsiEdit.msc) и следующей процедурой для изменения значения атрибута msExchDoFullReplication а службе Active Directory с «True» на «False».

Внимание!
Могут возникнуть серьезные проблемы, если некорректно изменить атрибуты объектов Active Directory при использовании оснастки «Edit» интерфейса ADSI (Active Directory Service Interfaces), средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Чтобы устранить причину появления этого предупреждения

  1. Воспользуйтесь средством ADSI Edit или аналогичным инструментом для поиска атрибута msExchDoFullReplication указанного объекта службы обновления получателей. Объекты службы обновления получателей имеют следующее размещение: CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=организация,CN=Address Lists Container,CN=Recipient Update Services

  2. Щелкните правой кнопкой мыши указанную службу обновления получателей и выберите команду Свойства.

  3. На вкладке Редактор атрибутов выполните прокрутку вниз и выберите атрибут msExchDoFullReplication.

  4. Нажмите кнопку Правка для изменения данного атрибута.

  5. В диалоговом окне «Редактор логических атрибутов» выберите вместо значения True значение False и нажмите кнопку ОК.

  6. Вновь нажмите кнопку ОК, чтобы сохранить изменения, и закройте средство ADSI Edit.

Дополнительные сведения о службе обновления получателей см. в следующих статьях базы знаний Майкрософт:

  • Статья 253770, описывающая задачи, выполняемые службой обновления получателей ( может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • Статья 253828, описывающая, как служба обновления получателей заполняет списки адресов (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • Статья 253838, описывающая применение системных политик службой обновления получателей (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • Статья 328738, описывающая применение политик получателя службой обновления получателей (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


Служба обновления получателей настроена для полной перестройки
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchDoFullReplication для каждого объекта службы обновления получателей в Active Directory. Если анализатор сервера Exchange обнаруживает, что значение атрибута msExchDoFullReplication для любого из объектов службы обновления получателей равно «True», на экран выводится предупреждение.

Предупреждение указывает на то, что служба обновления получателей настроена на выполнение полной перестройки в следующем цикле обработки. Если для атрибута msExchDoFullReplication задано значение «True», то при следующем запуске службы обновления получателей по расписанию или с помощью команды Обновить, служба обновления получателей проверяет каждый объект вместо того, чтобы опросить только новые объекты. Данная процедура может занять много времени и привести к задержкам в системе.

Если требуется выполнить полную перестройку, можно игнорировать это предупреждение. Если полная перестройка не была запланирована, то для устранения данной проблемы можно воспользоваться оснасткой Edit интерфейса ADSI (AdsiEdit.msc) и следующей процедурой для изменения значения атрибута msExchDoFullReplication а службе Active Directory с «True» на «False».

Внимание!
Могут возникнуть серьезные проблемы, если некорректно изменить атрибуты объектов Active Directory при использовании оснастки Edit интерфейса ADSI (Active Directory Service Interfaces), средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Чтобы устранить причину появления этого предупреждения

  1. Воспользуйтесь средством ADSI Edit или аналогичным инструментом для поиска атрибута msExchDoFullReplication указанного объекта службы обновления получателей. Объекты службы обновления получателей имеют следующее размещение: CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=организация,CN=Address Lists Container,CN=Recipient Update Services

  2. Щелкните правой кнопкой мыши указанную службу обновления получателей и выберите команду Свойства.

  3. На вкладке Редактор атрибутов выполните прокрутку вниз и выберите атрибут msExchDoFullReplication.

  4. Нажмите кнопку Правка для изменения данного атрибута.

  5. В диалоговом окне «Редактор логических атрибутов» выберите вместо значения True значение False и нажмите кнопку ОК.

  6. Вновь нажмите кнопку ОК, чтобы сохранить изменения, и закройте средство ADSI Edit.

Дополнительные сведения о службе обновления получателей см. в следующих статьях базы знаний Майкрософт:

  • Статья 253770, описывающая задачи, выполняемые службой обновления получателей ( может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • Статья 253828, описывающая, как служба обновления получателей заполняет списки адресов (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • Статья 253838, описывающая применение системных политик службой обновления получателей (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • Статья 328738, описывающая применение политик получателя службой обновления получателей (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


Служба Recipient Update Service неактивна
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализа Microsoft® Exchange Server Analyzer Tool направляет запрос службе каталогов Active Directory®, чтобы определить значение атрибута activationStyle для каждого объекта службы Recipient Update Service в Active Directory. Если анализатор обнаружит, что значение атрибута activationStyle для какого-либо объекта службы Recipient Update Service равно 0, появится предупреждение.

Это предупреждение говорит о том, что в расписании для данного объекта службы Recipient Update Service установлено значение Никогда. Если в расписании службы Recipient Update Service стоит значение Никогда, новые объекты не обрабатываются.

Если этот объект службы Recipient Update Service уже не используется, рекомендуется удалить его. Если этот объект службы Recipient Update Service еще нужен, рекомендуется настроить расписание для него.

Устранение ошибки: настройка расписания

  1. Запустите системный диспетчер Exchange System Manager.

  2. Раскройте Recipients и выберите Recipient Update Services.

  3. Щелкните правой кнопкой мыши объект службы Recipient Update Service, в расписании которого стоит Никогда, и выберите Свойства.

  4. Выберите предопределенное расписание в списке Интервал обновления или выберите Настроить, чтобы создать пользовательское расписание.

  5. Нажмите кнопку ОК, чтобы сохранить изменения.

  6. Щелкните правой кнопкой мыши объект службы Recipient Update Service и выберите Обновить сейчас.

Для получения дополнительных сведений о службе Recipient Update Service см. следующие статьи базы знаний корпорации Майкрософт:

  • 253770, «Задачи, выполняемые службой Recipient Update Service» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828, «Заполнение списков адресов службой Recipient Update Service» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838, «XADM: Как служба Recipient Update Service применяет системные политики» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738, «XADM: Как служба Recipient Update Service применяет политику получателей» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


Требуется обновление программного обеспечения службы обновления получателей
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс CIM_Datafile, чтобы определить значение ключа Version для службы представления адресной книги и динамических групп (abv_dg.dll), также называемой службой обновления получателей. WMI-ключ Version указывает номер сборки для этого файла.

Анализатор сервера Exchange также запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msDS-Behavior-Version объекта параметров NTDS. Это значение отражает функциональный уровень леса Active Directory. Допустимые значения атрибута msDS-Behavior-Version представлены в следующей таблице.

Значение | Функциональный уровень леса
0 | Microsoft Windows 2000 Server, смешанный режим
1 | Промежуточный сервер Microsoft Windows Server™ 2003
2 | Основной сервер Microsoft Windows Server 2003

Если анализатор сервера Exchange обнаруживает, что номер сборки для abv_dg.dll на сервере Exchange в лесу Active Directory в промежуточном или основном режиме Windows Server 2003 меньше 6.0.6615.0, отображается сообщение об ошибке. Это сообщение об ошибке указывает, что версия службы обновления получателей для Exchange 2000 Server выполняется при несовместимом функциональном уровне леса Windows Server 2003 Active Directory. Чтобы решить этот вопрос, требуется установка обновления службы обновления получателей.

При использовании службы обновления получателей в Exchange 2000 Server для обновления объектов получателей в лесу Windows Server 2003 объекты обновляются некорректно. Например, служба обновления получателей не распознает изменения членства в группах. Также если используется соединитель Active Directory для Exchange 2000 Server, этот соединитель может не реплицировать изменения членства в группах из службы каталогов Active Directory в каталог Exchange Server 5.5.

Чтобы обновить службу обновления получателей до самой последней версии

  1. Получите требуемое обновление, следуя шагам, описанным в статье 873059 базы знаний Майкрософт, посвященной невозможности правильно обновить объекты службой обновления получателей при работе в Exchange 2000 Server в лесу Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=873059).

  2. Примените обновление. Нет необходимости перезагружать компьютер после установки обновления. Однако службы, относящиеся к Exchange, автоматически перезапускаются при применении этого обновления.


Экземпляр RUS не существует в этом домене
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы получить список доменов в лесу. Анализатор сервера Exchange также опрашивает атрибут msExchangeDomainLink , чтобы получить список существующих экземпляров службы RUS (Recipient Update Service). Затем анализатор сервера Exchange сравнивает полученный список доменов со списком возвращенных экземпляров RUS, и определяет, существует ли совпадение. Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • домен существует;

  • экземпляр RUS не существует в этом домене.

Этот анализатор сервера Exchange отображает сообщение об ошибке, если домен был подготовлен с помощью средства DomainPrep, но экземпляра RUS в этом домене не существует. Несоответствие может возникнуть в тех сценариях, когда администратор добавляет новый домен Active Directory в лес, подготавливает этот домен для работы с Exchange с помощью средства DomainPrep, а затем забывает добавить в домен экземпляр RUS. Если это произошло, новые пользовательские объекты, созданные в домене, не получат адреса электронной почты, которые им выдаются. Если отображается это сообщение об ошибке, создайте новую службу Recipient Update Service в этом домене.

Чтобы устранить эту ошибку

  1. Откройте системный диспетчер Exchange.

  2. Разверните узел Получатели.

  3. Щелкните правой кнопкой мыши узел Recipient Update Services, щелкните Создать, затем Recipient Update Service.

  4. В окне нового объекта щелкните Обзор, чтобы найти имя домена.

  5. Выберите имя домена и нажмите кнопку OK.

  6. В окне нового объекта нажмите кнопку Далее, затем кнопку Готово.

Дополнительные сведения о службе Recipient Update Service см. в следующих статьях базы знаний Майкрософт:

  • статья 328738, посвященная применению службой Recipient Update Service политик получателей (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738);

  • статья 253828, посвященная заполнению службой Recipient Update Service списков адресов (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828);

  • статья 246127, посвященная проверке работы службы Exchange Recipient Update Service (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127);

  • статья 253770, посвященная задачам, выполняемым службой Exchange Recipient Update Service (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770).


Изменилось состояние репликации
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, был ли установлен атрибут ms-DS-ReplicationEpoch объекта NTDS Settings контроллера домена.

Век — это период, на протяжении которого домену присуще определенное имя. Новый век начинается при создании домена и при изменении имени домена.

Атрибут ms-DS-ReplicationEpoch применяется к веку, во время которого реплицируются все контроллеры домена. Если анализатор сервера Exchange обнаружит, что этому атрибуту присвоено значение, будет отображено сообщение о нестандартной конфигурации.

Наличие значения атрибута ms-DS-ReplicationEpoch обычно означает, что домен, в котором находится сервер, был переименован. В операционных системах Microsoft Windows Server™ 2003 Standard Edition, Windows Server 2003 Enterprise Edition и Windows Server 2003 Datacenter Edition администраторы могут переименовывать домены в лесу Active Directory после создания структуры леса. В операционной системе Windows® 2000 Server администраторы не могут переименовывать домены в лесу Active Directory после создания структуры леса.

Структура леса Active Directory определяется порядком создания доменов и именами этих доменов в иерархии. Все начинается с домена корня леса. Все дочерние домены получают свои различающиеся имена и имена DNS по умолчанию от имени домена корня леса. Это применимо к каждому дополнительному дереву в лесу.

Структура иерархии существующего дерева доменов изменяется путем переименования доменов. Например, можно переименовать дочерний домен, чтобы тот стал принадлежать другому родительскому объекту или стал новым корневым доменом дерева. В обоих примерах существующий домен создает другую структуру дерева доменов.

Также можно переименовывать домены, не влияя на структуру. Например, при переименовании корневого домена изменятся и имена всех дочерних доменов под этим корневым доменом. Однако новой структуры дерева доменов создано не будет.

Переименование доменов не поддерживается в лесах, содержащих серверы Exchange 2000 или Exchange 5.5. Средства переименования доменов в Windows Server 2003 были разработаны для переименования доменов в лесах Active Directory, в которых не содержится серверов Exchange 2000 Server или Exchange Server 5.5. Эти ограничения накладываются на средства переименования доменов в Windows Server 2003 по следующим причинам:

  • Переименование доменов затрагивает некоторые атрибуты Exchange.

  • Средства переименования доменов в Windows Server 2003 не имеют возможности исправить эти атрибуты.

Переименование доменов поддерживается в лесах, в которых содержится Exchange Server 2003. Средство исправления Exchange после переименования доменов (XDR-fixup.exe) исправляет атрибуты сервера Exchange после переименования домена, в котором содержатся серверы Exchange 2003 Server. Можно использовать это средство вместе со средством переименования каталогов в Windows Server 2003 (Rendom.exe).

Дополнительные сведения о средствах переименования доменов Active Directory в Windows Server 2003 и о загрузке этих средств см. на веб-узле, посвященном средствам переименования доменов Active Directory в Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=40992).

Чтобы переименовать домен, необходимо воспользоваться средством XDR-fixup. Это средство изменяет атрибуты Active Directory на сервере Exchange, чтобы правильно работать с новым именем домена. Средство XDR-fixup не заменяет средства переименования доменов в Windows Server 2003. Также средство XDR-fixup не увеличивает функциональность средств переименования доменов в Windows Server 2003. Необходимо использовать средство XDR-fixup каждый раз при использовании Rendom.exe.

Дополнительные сведения о переименовании доменов и влиянии этого процесса на серверы Exchange см. в следующих средствах и документах:

  • веб-узел, посвященный средствам переименования доменов в Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=40992);

  • веб-узел, посвященный общим сведениям о переименовании доменов (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=41906);

  • веб-узел, посвященный пошаговому руководству по переименованию доменов (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=41359);

  • веб-узел, посвященный исправлению серверов Exchange после переименования доменов (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=34171);

  • веб-узел, посвященный Exchange и процедурам переименования доменов (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=41908).


Реплика автономной адресной книги версии 2 не найдена
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2007-01-29

Средство анализа Microsoft Exchange Server запрашивает класс Exchange_Public_Folder инструментария Microsoft Windows Management Instrumentation (WMI) для определения текущего значения параметра HasLocalReplica. Если Exchange Server Analyzer обнаруживает, что для параметра HasLocalReplica установлено значение «Ложь» для автономной адресной книги версии 2, например для автономного списка адресов, отображается сообщение об ошибке.

Если для параметра HasLocalReplica устанавливается значение «Ложь» для адресной книги версии 2, например для автономного списка адресов, автономные списки адресов создаются неправильно. В результате пользователи Microsoft Outlook 2002 и более ранних версий не могут загрузить автономные списки адресов.

Проблема возникает, если хранилища общих папок настроены таким образом, что не могут содержать реплики автономной адресной книги версии 2. По умолчанию автономная адресная книга выполняет репликацию содержимого в хранилище общих папок сервера, на который она установлена. Если хранилище общих папок удалено из настройки репликации автономной адресной книги, возникает проблема, описанная выше.

Исправление ошибки

  1. Откройте системный диспетчер Exchange.

  2. Разверните Административные группы, затем нажмите Папки.

  3. Щелкните правой кнопкой мыши Общие папки и выберите Просмотр системных папок.

  4. Разверните объект АВТОНОМНАЯ АДРЕСНАЯ КНИГА.

  5. Щелкните правой кнопкой мыши параметр o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List в узле АВТОНОМНАЯ АДРЕСНАЯ КНИГА, затем выберите Свойства.

  6. Убедитесь, что на вкладке Репликация в поле Репликация содержимого в общие хранилища указано хранилище общих папок. Если хранилище общих папок не указано, нажмите Добавить и введите соответствующее хранилище общих папок для автономной адресной книги.

  7. Нажмите Применить, затем ОК.

  8. Разверните o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List.

  9. Щелкните правой кнопкой мыши автономная адресная книга версия 2 в узле o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List, затем выберите Свойства.

  10. Убедитесь, что на вкладке Репликация в поле Репликация содержимого в общие хранилища указано хранилище общих папок. Если хранилище общих папок не указано, нажмите Добавить и введите соответствующее хранилище общих папок для автономной адресной книги.

  11. Нажмите Применить, затем ОК.

Для получения дополнительных сведений об этой проблеме см. статью 286328 базы знаний Майкрософт «Offline Address Book Is Missing and Cannot Be Generated in Microsoft Exchange» (Автономная адресная книга отсутствует и ее невозможно создать в Microsoft Exchange) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328).

Дополнительные сведения о создании списка автономной адресной книги см. в статье «Offline Address List Generation Overview» (Обзор создания списка автономной адресной книги) (http://go.microsoft.com/fwlink/?LinkId=82242).

Для получения дополнительных сведений о правильном удалении первого сервера Exchange Server 2003 из группы администраторов см. статью 822931 базы знаний Майкрософт «How to remove the first Exchange Server 2003 computer from the administrative group» (Удаление первого сервера Exchange Server 2003 из группы администраторов) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822931).


Реплика автономной адресной книги версии 3а не найдена
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Exchange_Public_Folder, чтобы определить текущее значение ключа HasLocalReplica. Если анализатор сервера Exchange обнаружит, что значение HasLocalReplica установлено равным «False» для экземпляра автономной адресной книги версии 3а, на экран будет выведено сообщение об ошибке.

Если значение HasLocalReplica установлено равным «False» для автономного адресного списка в экземпляре автономной адресной книги версии 3а, автономные адресные списки создаются неправильно. В результате этого пользователям Microsoft Office Outlook® 2003 не удастся загрузить какие-либо автономные адресные списки.

Данная проблема может возникнуть, если не выполнена настройка каких-либо хранилищ общих папок с целью включения хранения реплик автономной адресной книги версии 3а. По умолчанию автономная адресная книга реплицирует свое содержимое в хранилище общих папок на сервере, на котором установлена эта автономная адресная книга. Если хранилище общих папок удалено из конфигурации репликации автономной адресной книги, возникнет проблема, описанная выше.

Чтобы устранить эту ошибку

  1. Откройте системный диспетчер Exchange.

  2. Разверните узел Административные группы и щелкните Папки.

  3. Щелкните правой кнопкой мыши Общие папки и в контекстном меню выберите команду Просмотреть системные папки.

  4. Щелкните, чтобы развернуть объект АВТОНОМНАЯ АДРЕСНАЯ КНИГА.

  5. В разделе АВТОНОМНАЯ АДРЕСНАЯ КНИГА щелкните правой кнопкой мыши o=org/cn=addrlists/cn=oabs/cn=Автономный адресный список по умолчанию и в контекстном меню выберите пункт Свойства.

  6. На вкладке Репликация убедитесь, что хранилище общих папок введено в поле Реплицировать содержимое в эти общие хранилища. Если хранилище общих папок не введено, щелкните Добавить, а затем введите соответствующее общее хранилище для автономной адресной книги.

  7. Нажмите Применить, затем — ОК.

  8. Щелкните, чтобы развернуть узел o=org/cn=addrlists/cn=oabs/cn=Автономный адресный список по умолчанию.

  9. В разделе o=org/cn=addrlists/cn=oabs/cn=Автономный адресный список по умолчанию щелкните правой кнопкой мыши Автономная адресная книга версии 3a и в контекстном меню выберите пункт Свойства.

  10. На вкладке Репликация убедитесь, что хранилище общих папок введено в поле Реплицировать содержимое в эти общие хранилища. Если хранилище общих папок не введено, щелкните Добавить, а затем введите соответствующее общее хранилище для автономной адресной книги.

  11. Нажмите Применить, затем — ОК.

Дополнительные сведения об этой проблеме см. в базе знаний Майкрософт в статье 286328, описывающей ситуацию, когда автономная адресная книга отсутствует и ее невозможно создать в Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328).

Дополнительные сведения о процедуре правильного удаления первого компьютера, на котором выполняется приложение Exchange Server 2003, из административной группы см. в базе знаний Майкрософт в статье 822931, содержащей инструкции по удалению первого компьютера, на котором выполняется приложение Exchange Server 2003, из административной группы (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822931).


Расписание соединителя репликации каталогов
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута activationSchedule для каждого из объектов соглашения о соединении Active Directory Connector (ADC). Атрибут activationSchedule определяет, как часто выполняется соглашение о соединении ADC. Значение 0 означает, что для расписания репликации установлено значение Никогда. Значение 1 означает, что для расписания установлено значение Заданное время. Значение 2 означает, что для расписания установлено значение Всегда.

Анализатор сервера Exchange Server также запрашивает службу Active Directory, чтобы определить значение атрибута msExchServer2SearchFilter каждого объекта соглашения о соединении ADC. Атрибут msExchServer2SearchFilter представляет поисковый фильтр, используемый при поиске каталога.

Если анализатор сервера Exchange определяет, что для атрибута activationSchedule установлено значение Заданное время с интервалом репликации больше 6 часов и атрибут msExchServer2SearchFilter задает репликацию данных получателей, выводится предупреждение.

Обычно для расписания репликации соглашения о соединении получателя рекомендуется задавать значение Всегда. В некоторых случаях настройка для соглашения о соединении какого-либо иного расписания может вызвать появление отчетов о недоставке после перемещения почтовых ящиков с веб-узлов сервера Exchange 5.5 на Exchange 2000 Server или Exchange Server 2003.

Чтобы устранить причину появления этого предупреждения

  1. Откройте оснастку «Службы соединителей Active Directory» консоли MMC.

  2. Выберите узел Соглашение о соединении.

  3. На странице Свойства: соглашение_о_соединении, откройте вкладку Расписание, выберите Всегда и нажмите кнопку ОК.

Дополнительные сведения о развертывании ADC и настройке соглашений о соединении см. в Руководстве по развертыванию Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).


Роль сервера RID FSMO не отвечает
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута fSMORoleOwner хозяина операций с относительными кодами (RID) в контексте именования доменов. Например, в домене с именем «contoso.com» значением fSMORoleOwner для хозяина операций RID является атрибут CN=RID Manager$, CN=System, DC=contoso, DC=com. Затем анализатор сервера Exchange пытается открыть LDAP-подключение к TCP-порту 389 на контроллере домена, на котором в текущий момент находится эта роль. Если анализатору сервера Exchange не удается подключиться к этому контроллеру домена, на экран выводится сообщение об ошибке.

Хозяин операций RID распределяет относительные коды всем контроллерам домена таким образом, чтобы все участники безопасности имели уникальный код. Новый объект участника безопасности (пользователь, группа или компьютер) можно создать на любом контроллере домена. При создании объекта участника безопасности контроллер домена присоединяет к объекту уникальный код безопасности (SID). Существует четыре элемента SID домена, один из которых — RID домена. Хозяин операций RID отвечает за обработку групповых RID-запросов от всех контроллеров домена в определенном домене. В любое время может быть только один контроллер домена, действующий как хозяин RID в домене.

Чтобы устранить эту ошибку

  1. Убедитесь, что сервер каталогов, указанный в ошибке, находится в оперативном режиме и доступен для серверов Exchange в организации.

  2. Если этот сервер каталогов был списан, необходимо привязать роль хозяина RID к другому контроллеру домена.

Дополнительные сведения о перемещении роли хозяина операций RID с одного контроллера домена на другой см. в следующих статьях базы знаний Майкрософт:

  • Сведения по приложению Microsoft Windows Server™ 2003 см. в статье 324801, содержащей инструкции по просмотру и передаче ролей FSMO в Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801).

  • Сведения для Microsoft Windows® 2000 Server см. в статье 255690, содержащей инструкции по просмотру и передаче ролей FSMO в графическом интерфейсе пользователя (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Роль FSMO схемы не найдена
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить контроллер домена, указанный в качестве FSMO схемы (fSMORoleOwner в контексте именования схемы). Если анализатор сервера Exchange обнаруживает, что контроллер домена, указанный в атрибуте fSMORoleOwner, отсутствует в лесу, отображается сообщение об ошибке.

Атрибут fSMORoleOwner в контексте именования схемы (CN=Schema,CN=Configuration,DC=domain,DC=com) определяет контроллер домена, являющийся хозяином схемы для леса. Контроллер домена, являющийся хозяином схемы, управляет всеми обновлениями и изменениями схемы. Чтобы обновить схему леса, необходимо иметь доступ к хозяину схемы. В лесу может быть только один хозяин схемы.

Для леса Active Directory должен быть определен хозяин схемы. Если во время установки Exchange 2000 Server или пакета обновления для Exchange 2000 контроллер домена, являющийся хозяином схемы, не подключен к сети, в работе программы установки произойдет сбой. Если контроллер домена, указанный как хозяин схемы, отключен от сети, необходимо его подключить. Это не относится к Exchange Server 2003. Программа установки Exchange Server 2003 обращается к хозяину схемы, только если определено, что схема не была расширена.

Чтобы устранить эту ошибку

  1. Проверьте, что соответствующий сервер Active Directory физически существует.

  2. Если этот сервер каталогов был списан, следует назначить роль хозяина схемы другому контроллеру домена.

Дополнительные сведения о назначении роли хозяина схемы другому контроллеру домена см. в следующих статьях базы знаний корпорации Майкрософт:

  • Статья 280178, в которой описывается ситуация, когда для установки Exchange 2000 требуется доступ к хозяину схемы (http://go.microsoft.com/fwlink/?linkid=3052&kbid=280178).

  • Для Microsoft Windows Server™ 2003 см. статью 324801, содержащую инструкции по просмотру и передаче ролей FSMO в Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801).

  • Для Microsoft Windows® 2000 Server см. статью 255690, содержащую инструкции по просмотру и передаче ролей FSMO в графическом интерфейсе пользователя (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Роль хозяина схемы не отвечает
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута fSMORoleOwner хозяина операций схемы в контексте именования схем. Например, в домене с именем «contoso.com» атрибутом fSMORoleOwner для хозяина операций схемы является атрибут со значением CN=Schema,CN=System,DC=contoso,DC=com. Затем анализатор сервера Exchange пытается открыть LDAP-подключение к TCP-порту 389 на контроллере домена, на котором в текущий момент находится эта роль. Если анализатору сервера Exchange не удается подключиться к этому контроллеру домена, выводится сообщение об ошибке.

Контроль домена, который содержит данную роль хозяина схемы, является единственным контроллером домена, который может выполнять операции записи в данную схему каталогов. Такие обновления схемы реплицируются из хозяина схемы во все остальные контроллеры домена данного леса. Хозяином схемы является роль хозяина операций на уровне леса, так как независимо от числа доменов в лесу существует только одна схема. Чтобы обновить схему леса, необходимо иметь доступ к хозяину схемы. В лесу может быть только один хозяин схемы.

Чтобы устранить эту ошибку

  1. Убедитесь, что сервер каталогов, указанный в сообщении об ошибке, находится в оперативном режиме и доступен для серверов Exchange в организации.

  2. Если этот сервер каталогов списан, роль хозяина схемы необходимо назначить другому контроллеру домена.

Дополнительные сведения о передаче роли хозяина схемы от одного контроллера домена другому см. в следующих статьях базы знаний Майкрософт:

  • Сведения о Microsoft Windows Server™ 2003 см. в статье 324801 «How To View and Transfer FSMO Roles in Windows Server 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801) (Инструкции по просмотру и передаче ролей FSMO в Windows Server 2003).

  • Сведения о Microsoft Windows 2000 Server см. в статье 255690 «HOW TO: View and Transfer FSMO Roles in the Graphical User Interface» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690) (Инструкции по просмотру и передаче ролей FSMO в графическом интерфейсе пользователя).


Скоро завершится срок действия сертификата SSL
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2007-01-09

Средство анализатора сервера Microsoft® Exchange опрашивает объект Server Certificate системы сервера Exchange, чтобы получить различные свойства сертификатов X509. Для каждого найденного сертификата SSL анализатор оценивает атрибут ExpirationDate, чтобы определить срок действия этого сертификата.

Примечание.
При работе с протоколом SSL серверу необходим сертификат сервера. Сертификат сервера содержит имя веб-узла. Обозреватель проверяет, что введенное имя является веб-узлом. Например, если веб-узлом является https://www.example.com, имя сертификата должно быть www.example.com.

Анализатор сервера Exchange отображает предупреждение, если до истечения срока действия, указанного в ExpirationDate, осталось от 3 до 20 дней. Анализатор сервера Exchange отображает сообщение об ошибке, если до истечения срока действия, указанного в ExpirationDate, осталось 3 дня.

Если срок действия сертификата закончился, SSL-подключения к указанному в этом сообщении URL-адресу завершатся с ошибкой. Таким же образом с ошибкой завершатся удаленные вызовы процедур через HTTP и подключения ActiveSync сервера Exchange.

Чтобы решить вопрос с предупреждением или сообщением об ошибке, относящимся к истекающему сроку действия сертификата, обновите сертификат, указанный в сообщении. Шаги, которые необходимо предпринять для обновления сертификата, зависят от используемого центра сертификации.

Дополнительные сведения

Дополнительные сведения о SSL и использовании сертификатов с виртуальными серверами в Exchange Server см. в следующих ресурсах.

  • Сведения об использовании сертификатов с виртуальными серверами в Exchange Server 2003 см. в статье 823024 базы знаний Майкрософт, посвященной инструкции по использованию сертификатов с виртуальными серверами в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823024).

  • Сведения об использовании SSL, а также о получении и установке сертификатов сервера см. в статье, посвященной настройке Exchange Server 2003 для клиентского доступа, в руководстве по клиентскому доступу к Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47568).

  • Сведения об использовании SSL и по получении и установке серверных сертификатов для Exchange Server 2007 см. в документе, посвященном настройке SSL для мобильного Outlook (http:// go.microsoft.com/fwlink/?LinkId =80875).


Отсутствует контейнер серверов
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2006-08-21

Средство анализатора сервера Microsoft® Exchange запрашивает в службе каталогов Active Directory® значение атрибута distingushedName для каждого объекта Routing Group, обнаруженного в текущей административной группе.

Затем анализатор сервера Exchange опрашивает службу каталогов Active Directory, чтобы определить, присутствует ли контейнер Серверы в текущей административной группе.

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Текущая административная группа содержит одну или несколько групп маршрутизации.

  • Контейнер Серверы не существует.

Эта ошибка указывает, что в административной группе нет установленных серверов и что сведения о маршрутизации, возможно, не распространяются динамически на серверы в организации Exchange.

Чтобы устранить эту ошибку, убедитесь, что организация Exchange находится в основном режиме, и выполните следующие шаги.

Шаги по устранению ошибки

  1. Создайте новую административную группу.

  2. Создайте в новой административной группе новый контейнер Группы маршрутизации.

  3. Перетащите существующие группы маршрутизации из прежнего контейнера Группы маршрутизации в новый контейнер.

  4. Повторно запустите все службы Exchange.

Дополнительные сведения об этой ошибке см. в базе знаний Майкрософт, в статье 318491, описывающей ситуацию, когда сведения о маршрутизации не распространяются в организации Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=318491).


Имя участника службы с сервера глобального каталога отсутствует
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2006-05-12

Средство анализатора сервера Microsoft® Exchange запрашивает сервер глобального каталога службы каталогов Active Directory®, чтобы найти значения, возвращенные для полного доменного имени (FQDN) и имени NetBIOS для атрибута servicePrincipalName ресурсов exchangeAB и HOST.

Анализатор сервера Exchange выводит сообщение об ошибке при возникновении любого из следующих условий:

  • В атрибуте servicePrincipalName для ресурса exchangeAB отсутствует одно из ожидаемых имен FQDN или NetBIOS.

  • В атрибуте servicePrincipalName для ресурса Exchange HOST отсутствует одно из ожидаемых имен FQDN или NetBIOS.

Имя участника службы (SPN) — уникальное имя, которое определяет экземпляр службы и связано с учетной записью для входа, под которой работает экземпляр службы. Без правильной настройки SPN проверка подлинности Kerberos для служб Exchange невозможна.

  • Если клиенты, работающие с приложением Microsoft Outlook® 2003 или его более поздней версией, сталкиваются с проблемами при проверке подлинности Active Directory, эти проблемы могут указывать на отсутствие допустимого SPN для ресурса exchangeAB.

  • Ошибки проверки подлинности между серверами могут указывать на отсутствие допустимого SPN для ресурса HOST.

Чтобы разрешить эти проблемы, выполните следующие шаги, чтобы добавить недостающие значения атрибута servicePrincipalName.

Используйте средство SETSPN.exe, чтобы добавить SPN с недостающими значениями

  1. Установите средство Setspn.exe. Чтобы получить средство Setspn.exe, см. раздел "Средство пакета ресурсов Windows 2000: Setspn.exe" (http://go.microsoft.com/fwlink/?LinkId=28103).

    Версия для Windows Server 2003 программы Setspn.exe, работающей в режиме командной строки, доступна в средствах поддержки Windows Server 2003, содержащихся на компакт-диске Windows Server 2003. Чтобы установить средства поддержки Windows Server 2003, дважды щелкните файл Suptools.msi в папке Support/Tools.

  2. Следуйте инструкциям в файле Setspn_d.txt программы SETSPN.EXE по добавлению недостающего значения к объекту Active Directory для сервера Exchange. В следующем примере демонстрируется добавление значения FQDN для SPN виртуального SMTP-сервера:

    • Запустите режим командной строки и перейдите в каталог установки программы Setspn.exe.

    • В командной строке введите следующую команду:

      setspn.exe-a SMTPSVC/ mail.домен.com имя_сервера

      Примечание.
      Замените mail.домен.com на FQDN своего виртуального SMTP-сервера, а имя_сервера — на имя сервера Exchange.
      Затем нажмите клавишу ВВОД.


В данной группе администрирования отсутствует хранилище общих папок сервера папки сайта
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута distinguishedName для каждого хранилища общих папок. Кроме того, анализатор сервера Exchange запрашивает Active Directory, чтобы определить значения атрибутов siteFolderServer и msExchAdminGroupMode для каждой из групп администрирования. Атрибут siteFolderServer указывает имя сервера, отвечающего за размещение папок сайта (как правило, это первый сервер на сайте или в группе администрирования). Атрибут msExchAdminGroupMode указывает один из следующих режимов для данной группы администрирования:

  • Только Exchange Server 5.5

  • Смешанный режим Exchange Server 5.5, Exchange 2000 Server и Exchange Server 2003

  • Основной режим Exchange 2000 Server или Exchange Server 2003

Если анализатор сервера Exchange обнаруживает, что группа администрирования находится не в основном режиме, значение атрибута siteFolderServer не соответствует значению атрибута distinguishedName любого из хранилищ общих папок, а значение атрибута siteFolderServer не содержит строки DEL:, выводится предупреждение.

По умолчанию сервером папки сайта является первый сервер, установленный в группе администрирования. Хранилище общих папок на этом сервере представляет собой расположение по умолчанию папок данных о занятости и папок автономной адресной книги для данной группы администрирования. При удалении или списании сервера папки сайта без репликации данных папок на другой сервер и последующего назначения этого сервера сервером автономной адресной книги у пользователей Outlook возникнут проблемы в работе с автономной адресной книгой и данными о занятости.

Внимание!
Могут возникнуть серьезные проблемы, если некорректно изменить атрибуты объектов Active Directory при использовании средства ADSI Edit (Active Directory Service Interfaces, ADSI), средства LDP (ldp.exe) или другого LDAP-клиента версии 3. Для устранения этих проблем может потребоваться переустановить Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор Active Directory, например, ADSI Edit.

  2. Найдите хранилище данных общих папок, которое нужно назначить сервером папки сайта, раскрыв следующие узлы: CN=<PublicFolderStoreName>, CN=<StorageGroupName>, CN=InformationStore, CN=<ServerName>, CN=Servers, CN=<AdministrativeGroupName> ,CN=Administrative Groups, CN=<OrganizationName>, CN=Microsoft Exchange, CN=Services, CN=Configuration,DC=<DomainName>,DC=com.

  3. В правой области щелкните правой кнопкой мыши CN=<PublicFolderStoreName> и выберите команду «Свойства».

  4. В поле «Атрибуты» выполните прокрутку вниз и выберите атрибут distinguishedName.

  5. Нажмите кнопку Изменить, а затем скопируйте весь атрибут в буфер обмена.

  6. Раскройте контейнер «Конфигурация», а затем — элементы CN=Administrative Groups,CN=<OrganizationName>,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=<DomainName>,DC=com.

  7. Щелкните правой кнопкой мыши группу администрирования, которую нужно изменить, и выберите команду «Свойства».

  8. В поле «Атрибуты» выполните прокрутку вниз и выберите атрибут siteFolderServer.

  9. Нажмите кнопку Изменить и вставьте значение атрибута distinguishedName в поле Значение.

  10. Внимательно проверьте содержимое поля Значение, убедитесь, что вставка выполнена верно, а затем нажмите кнопку ОК, чтобы сохранить внесенное изменение.

  11. Нажмите кнопку ОК, чтобы закрыть диалоговое окно свойств группы администрирования.

  12. Закройте редактор ADSI Edit и перезапустите службу информационного хранилища Microsoft Exchange на всех компьютерах сервера Exchange данного сайта, чтобы изменения вступили в силу.

Дополнительные сведения о воссоздании системных папок и возврате к прежнему серверу папки сайта см. в следующих статьях базы знаний Майкрософт:

  • 275171, «How to Reset System Folders on an Exchange 2000 Server» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372) (Инструкции по изменению системных папок на сервере Exchange 2000)

  • 284200, «Schedule+ Free/Busy System Folder Is Missing» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=284200) (Отсутствует системная папка расписания и данных о занятости)

Дополнительные сведения об использовании средства LDP см. в статье 260745 базы знаний Майкрософт «XADM: Using the LDP Utility to Modify Active Directory Object Attributes» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745) (Использование служебной программы LDP для изменения атрибутов объектов Active Directory).

Дополнительные сведения о работе с редактором оснасткой ADSI Edit см. в разделе «Adsiedit.msc: ADSI Edit» (Adsiedit.msc: редактор ADSI Edit) в справке Windows Server 2003.


Хранилище общих папок сервера папок узла, используемое автономной адресной книгой, не обнаружено
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2007-02-01

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active® Directory, чтобы определить значение для атрибута siteFolderServer всех хранилищ общих папок Exchange (хранилищ, имеющих для objectClass значение objectClass=msExchPublicMDB). Атрибут siteFolderServer представляет хранилище общих папок, используемое для сервера автономной адресной книги.

Если анализатор сервера Exchange определяет, что сервер не указан, указанный сервер выключен или не существует, на экран выводится предупреждение. Если атрибут siteFolderServer содержит строку DEL, анализатор сервера Exchange выводит на экран сообщение об ошибке.

По умолчанию сервер Exchange Server 2003 формирует файлы автономной адресной книги на сервере папок узла (первый сервер, установленный в административной группе). Если для работы в качестве сервера автономной адресной книги назначен другой сервер, указанное в данном атрибуте хранилище общих папок будет храниться на новом сервере автономной адресной книги и не будет храниться на реальном сервере папок узла административной группы

Когда приложение Exchange Server 2003 генерирует файлы автономной адресной книги, оно прикрепляет файлы к почтовым сообщениям в качестве вложенных и помещает сообщения в специальные общие папки. Приложение Microsoft Office Outlook® 2003 извлекает сообщения из папки и загружает вложенные файлы.

В сервере Exchange Server 2003 сообщения автономной адресной книги хранятся во вложенных папках папки OFFLINE ADDRESS BOOK, которая является одной из системных папок в дереве Public Folders по умолчанию. Данная папка содержит подпапку для каждой административной группы или узла в данной топологии. По умолчанию реплика содержимого конкретной папки административной группы размещается на первом сервере, установленном в административной группе (называемом сервером папок узла).

Если используется организация Exchange Server 2007 без клиентов нижнего уровня (Outlook 2003 или более ранние версии), то это предупреждение или ошибку можно пропустить. Если в организации Exchange Server 2007 размещены клиенты с Outlook 2003 или более ранней версии, выполните указанные ниже действия, чтобы включить распространение через общие папки для автономных файлов адресной книги. Распространение через общие папки - это метод распространения, посредством которого клиенты, на которых выполняется Outlook 2003 (или более ранней версии) и которые работают автономно либо с помощью подключения удаленного доступа, получают доступ к автономной адресной книге (OAB).

Устранение причин появления этого предупреждения на сервере Windows Server 2003

  1. Если известно, что сервер не существует, в диспетчере Exchange в узле Серверы, разверните сервер, разверните группу хранения и затем щелкните Хранилище общих папок. Чтобы убедиться что хранилище работает, проверьте правую область.

  2. Чтобы назначить новый сервер автономной адресной книги, в группе Получатели щелкните Автономные списки адресов. Затем в правой области щелкните Автономный список адресов по умолчанию (или любой любой другой автономный список адресов, создавший это сообщение).

    Если нет необходимости в использовании автономной адресной книги, щелкните правой кнопкой мыши По умолчанию Автономная адресная книга и затем щелкните Удалить. В противном случае используйте эту процедуру для настройки расписания.

  3. Щелкните правой кнопкой мыши По умолчанию Автономный список адресов и затем щелкните Свойства.

  4. На вкладке Общие в группе Сервер автономной адресной книги щелкните параметр Обзор, чтобы выбрать сервер.

Устранение причин появления этого предупреждения на сервере Windows Server 2007

  1. Откройте консоль управления Exchange.

  2. Разверните узлы Microsoft Exchange и Конфигурация организации, а затем выберите элемент Почтовый ящик.

  3. В области результатов перейдите на вкладку Автономная адресная книга.

  4. На вкладке Автономная адресная книга выберите параметр «Автономная адресная книга по умолчанию».

    1. Для того чтобы включить распространение общих папок, на вкладке Рассылка выберите Включить распространение общих папок.

    2. Нажмите кнопку ОК, чтобы сохранить изменения.

  5. Для назначения нового сервера автономной адресной книги в области действий щелкните Переместить, чтобы запустить мастер перемещения автономной книги. Этот мастер позволяет переназначить формирование автономной адресной книги на другой сервер. Кроме того, он скопирует на указанный сервер уже существующие файлы адресной книги.

Включение распространения общих папок для автономных файлов адресной книги с помощью среды управления Exchange.

  • Выполните следующую команду:

    Копировать код
    Set-OfflineAddressBook -Identity <OAB> -PublicFolderDistributionEnabled $true

    где: <OAB> указывает различающееся имя, имя в формате «домен\имя_учетной_записи» или идентификатор GUID автономной адресной книги.

    Например, чтобы включить распространение общих папок автономной адресной книги по умолчанию, необходимо ввести следующую команду:
Копировать код
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -PublicFolderDistributionEnabled $true

Использование среды управления Exchange для указания сервера, на котором будет выполняться формирование автономной адресной книги

  • Выполните следующую команду:

    Копировать код
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    где: <OAB> — это различающееся имя, имя в формате «домен\имя учетной записи» или идентификатор GUID автономной адресной книги, а <Server> указывает сервер Exchange Server, на котором будет выполняться выбранная операция.

    Например, для переназначения формирования автономной адресной книги на сервер SERVER01 необходимо ввести следующую команду:
Копировать код
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Дополнительные сведения о работе с автономными адресными книгами в Exchange Server 2003 см. в руководстве по настройке автономной адресной книги Exchange Server 2003 в статье Работа с хранилищем Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=47595 (на английском языке).

Дополнительные сведения о работе с автономными адресными книгами в Exchange Server 2007 см. в статье «Настройка организации > Почтовый ящик > Автономные адресные книги» по адресуhttp://go.microsoft.com/fwlink/?LinkId=79247 (на английском языке).


Параметр SiteName установлен жестко
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Для поиска параметра реестра SiteName Средство анализа сервера Microsoft® Exchange Server считывает следующий параметр реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Netlogon\Parameters\SiteName

Если средство анализа Exchange Server обнаруживает наличие параметра реестра SiteName, отображается предупреждение.

Это предупреждение указывает, что членство в сайте службы каталогов Active Directory® жестко установлено на данном компьютере, работающем под управлением операционной системы Microsoft Windows®. При использовании Exchange Server такая настройка не рекомендуется.

Если сайт Windows установлен жестко, могут возникнуть отказы службы Microsoft Exchange System Attendant и общие отказы Exchange Server. Следует подумать об удалении параметра реестра SiteName. Если параметр реестра SiteName будет удален, Windows автоматически присоединится к подходящему сайту Active Directory.

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Для получения сведений о восстановлении реестра см. раздел справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Для удаления параметра реестра SiteName

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите по адресу: HKLM\System\CurrentControlSet\Services\Netlogon\Parameters

  3. На правой панели найдите и удалите параметр реестра SiteName.

  4. Закройте редактор реестра и перезагрузите сервер, чтобы изменения вступили в силу.

Перед правкой реестра, а также для получения дополнительных сведений о правке реестра ознакомьтесь со статьей 256986 базы знаний Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Для получения дополнительных сведений о параметре реестра SiteName см. статью 322834 базы знаний «XADM: Событие 1005, Системный помощник не запускается» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322834).


В организации Exchange более 900 административных групп
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2006-04-21

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить количество административных групп в организации Exchange. Если анализатор сервера Exchange обнаружит более 900 административных групп, на экран выводится предупреждение.

Рекомендуется создавать не более 900 экземпляров любого отдельного объектного типа Exchange. Это объясняется тем, что в Active Directory для любого данного запроса как максимальный размер страницы по умолчанию возвращается значение 1000. Это означает, что если для объекта сделан LDAP-запрос и в Active Directory существует более 1000 экземпляров этого объекта, никакие результаты не будут возвращены, поскольку превышен максимальный размер страницы.

В случае Exchange различные процессы запрашивают создание экземпляров определенных объектных типов. Например, диспетчер Exchange отправляет LDAP-запрос к Active Directory, чтобы создать представление списка всех административных групп в организации Exchange. Если существует более 1000 административных групп, Active Directory не возвращает никаких результатов. В результате в диспетчере Exchange выводится ошибка и никакие административные группы не отображаются.

Хотя значение максимального размера страницы для Active Directory может быть увеличено, это не рекомендуется и в Exchange не поддерживается. В средах Exchange, где было повышено значение максимального размера страницы, наблюдались неправильная работа и отказы.

Хотя в Exchange для любого отдельного объектного типа рекомендуется не превышать число 900, поддерживается до 1000 объектных типов.

Чтобы устранить эту проблему, можно объединить административные группы.

Дополнительные сведения об объединении узлов и административных групп Exchange см. в материале

  • Развертывание решения по всемирной консолидации узлов для Exchange Server 2003 в корпорации Майкрософт (http://go.microsoft.com/fwlink/?LinkId=33531) (может быть на английском языке).


В организации Exchange имеется больше 900 серверов Exchange
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2006-03-30

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory® для получения количества объектов в каталоге, у которых параметр objectCategory имеет значение msExchExchangeServer. Это количество соответствует числу компьютеров с сервером Exchange в службе каталогов Active Directory. Если анализатор сервера Exchange находит больше 900 компьютеров с сервером Exchange, отображается предупреждение.

Рекомендуется использовать не более 900 экземпляров для каждого типа объектов Exchange. Это связано с тем, что по умолчанию в службе каталогов Active Directory установлен максимальный размер страницы, возвращаемой в ответ на любой запрос, равный 1000. Это означает, что если для объекта создан LDAP-запрос (LDAP — Lightweight Directory Access Protocol), а в службе каталогов Active Directory существует больше 1000 экземпляров этого объекта, не будет возвращено никаких результатов, поскольку превышен предельный размер страницы.

В случае сервера Exchange разные процессы запрашивают экземпляры особых типов объектов. Например, системный диспетчер Exchange создает LDAP-запрос к службе каталогов Active Directory, чтобы создать список всех серверов Exchange в организации Exchange. Если в ней больше 1000 серверов Exchange, Active Directory не возвратит никаких результатов. В результате в системном диспетчере Exchange отображается сообщение об ошибке и не отображается никаких компьютеров, работающих под управлением сервера Exchange.

Хотя значение максимального размера страницы для Active Directory можно увеличить, это не рекомендуется и не поддерживается для Exchange. При увеличении максимального размера страницы в средах Exchange наблюдались странные явления и сбои.

Рекомендуется оставить это значение на уровне 900 или ниже для каждого типа объектов в сервере Exchange, однако поддерживается до 1000 типов объектов.

Чтобы устранить причину появления этого предупреждения

  1. Рассмотрите возможность объединения серверов Exchange в организации.

  2. Проверьте службу каталогов Active Directory на наличие компьютеров с сервером Exchange, лишившихся ссылки, и удалите их из Active Directory.

Дополнительные сведения об объединении серверов Exchange см. в руководстве, посвященном объединению серверов с использованием Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47586).


На уровне организации делегировано более десяти администраторов
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2006-12-03

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить количество пользователей, которые имеют разрешения администраторов Exchange или разрешения полноправных администраторов Exchange. Анализатор сервера Exchange подсчитывает количество записей в атрибуте msExchAdmins, которые представляют ссылку на всех администраторов Exchange в организации вместе с соответствующими разрешениями. Если анализатор сервера Exchange обнаружит, что правами администраторов или полноправных администраторов наделены более 10 пользователей, отображается предупреждение.

Атрибут msExchAdmins является многозначным атрибутом корневого контейнера организации Exchange. Он содержит список идентификаторов SID, которые представляют учетные записи пользователей, имеющих делегированные разрешения Exchange.

Рекомендуется ограничивать количество пользователей, имеющих доступ на запись в организации Exchange. Рассмотрите возможность уменьшения количества администраторов и полноправных администраторов Exchange на уровне организации. Сравнивая административные роли с требованиями инфраструктуры системы обмена сообщениями, можно обнаружить, что многих пользователей можно наделить административными правами только на просмотр на уровне организации, делегировав им роль администратора Exchange на уровне административной группы.

Чтобы устранить причину появления этого предупреждения

  1. Рассмотрите возможность уменьшения количества пользователей, имеющих права администраторов или полных администраторов Exchange.

  2. Рассмотрите возможность аудита разрешений Exchange Server в организации, чтобы убедится в их адекватности.

Для получения дополнительных сведений о планировании и настройке разрешений в Exchange см. следующие ресурсы:

  • «Работа с разрешениями службы Active Directory на сервере Exchange Server 2003» по адресу http://go.microsoft.com/fwlink/?LinkId=47592 (на английском языке).

  • Microsoft Exchange Server 2007, действия, «Настройка разрешений» по адресу http://go.microsoft.com/fwlink/?LinkId=78432 (на английском языке).

  • Microsoft Exchange Server 2007, планирование и архитектура, планирование службы Active Directory, «Вопросы, связанные с разрешениями» по адресу http://go.microsoft.com/fwlink/?LinkId=78433(на английском языке).

Дополнительные сведения об административных ролях в Exchange Server 2003 см. в статье 823018 базы знаний Майкрософт, посвященной обзору разрешений административных ролей в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823018).

Дополнительные сведения об административных ролях в Exchange 2000 Server см. в статье 289811 базы знаний, посвященной разрешениям ролей Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=289811).


Данное соглашение о соединении не настроено на создание отключенных учетных записей при отсутствии совпадений
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchServer2NetworkAddress для каждого объекта соглашения о соединении. Если анализатор сервера Exchange находит, что для атрибута msExchServer1AlwaysCreateAs не установлено значение 1, на экран выводится предупреждение.

Атрибут msExchServer1AlwaysCreateAs определяет, как объекты X.500 синхронизируются с Active Directory. Значение, равное 0, указывает на то, что соглашение о соединении настроено на создание контактов Microsoft Windows®. Значение этого атрибута, равное 1, указывает на то, что соглашение о соединении настроено на создание отключенных учетных записей пользователей Windows в Active Directory. Значение, равное 2, указывает на то, что соглашение о соединении настроено на создание новых учетных записей пользователей Windows.

Анализатор сервера Exchange выдает предупреждение, т.к. в ситуации, когда приложение Exchange Server 5.5 должно сосуществовать с Active Directory и планируется полная миграция в Exchange Server 2003, важно, чтобы соединитель Active Directory Connector (ADC) создавал отключенные учетные записи пользователей Windows. Указанные отключенные учетные записи пользователей Windows являются записями "с поддержкой почтового ящика", что означает, что они логически связаны с почтовым ящиком, существующим на компьютере, на котором установлено приложение Exchange Server 5.5. Создание отключенных учетных записей пользователей Windows необходимо для объекта пользователя, представляющего данную отключенную запись Windows, чтобы, в конечном счете, получить доступ к общим папкам и другим защищенным объектам в Active Directory.

В пользовательском интерфейсе ADC имеется три параметра, предназначенных для создания новых объектов в случае, когда совпадающий объект не обнаружен в Active Directory для почтового ящика в Exchange Server 5.5. Они указаны на вкладке Дополнительно в свойствах соглашения о соединении в следующем виде:

  • Создать контакт Windows Не рекомендуется, т.к. объект Контакт не содержит контекст безопасности.

  • Создать новую учетную запись пользователя Windows Не рекомендуется, т.к. созданная новая учетная запись будет иметь новый SID и, следовательно, история SID учетной записи пользователя Microsoft Windows NT® Server 4.0 не будет перенесена на новую учетную запись во время миграции (поскольку SID отличаются друг от друга).

  • Создать отключенную учетную запись пользователя Windows Рекомендуется, т.к. позволяет пользователю Windows NT Server 4.0 сосуществовать (с правильным доступом к ресурсам) до тех пор, пока не будет выполнена полная миграция.

Чтобы устранить причину появления этого предупреждения

  1. Настройте соглашение о соединении получателей Active Directory на создание отключенных учетных записей пользователей Windows с поддержкой почтового ящика.

  2. Используйте средство миграции Active Directory, осуществляющее миграцию учетных записей пользователей Windows NT Server 4.0 в Active Directory, и создайте включенные учетные записи Windows. Указанные включенные учетные записи пользователей Windows будут иметь такой же SID, что и отключенные учетные записи Windows, созданные соединителем ADC.

  3. Используйте мастер очистки Active Directory (ADClean), который сливает информацию из учетной записи, созданной средством миграции Active Directory в учетную запись, созданную соединителем ADC.

Дополнительные сведения о соглашениях о соединении получателей соединителя Active Directory Connector см. в следующих статьях базы знаний Майкрософт:

  • 823601, в которой рассматриваются требования и последствия использования в организации соединителя Active Directory Connector (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601).

  • 303180, в которой рассматриваются требования для использования соединителя Active Directory Connector для смешанных административных групп (http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180).

  • 296260, в которой рассматривается порядок настройки двустороннего соглашения с получателем о соединении для пользователей приложения Exchange 5.5 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=296260)

  • Дополнительные сведения о мастере очистки Active Directory см. в следующей статье базы знаний Майкрософт:

  • 270652, в которой описываются возможные варианты использования мастера очистки учетной записи Active Directory (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270652)

  • Дополнительные сведения о средстве миграции Active Directory см. в следующей статье базы знаний Майкрософт:

  • 260871, в которой описывается порядок настройки средства миграции ADMT для Windows NT 4.0 для использования в миграции Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260871)


Это соглашение о соединении в одностороннем режиме
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Server запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchSynchronizationDirection по каждому объекту соглашения о соединении. Атрибут msExchSynchronizationDirection представляет направление, в котором будет проводиться синхронизация каталогов. Если значение этого атрибута установлено равным 2, отображается соответствующее предупреждение.

Атрибут msExchSynchronizationDirection может иметь значение 0 или 2. Если оно равняется 0, это свидетельствует о соглашении о соединении в двустороннем режиме. Если значение атрибута равняется 2, это указывает на соглашение о соединении в одностороннем режиме с компьютера с установленным сервером Exchange Server.

Рекомендуется использовать соглашения о соединении в двустороннем режиме. Для сред Exchange, работающих в смешанном режиме (например, когда Exchange Server 5.5 сосуществует с Exchange 2000 Server или Exchange Server 2003), требуется соглашение о соединении в двустороннем режиме.

Чтобы устранить причину появления этого предупреждения

  1. Удалите существующее соглашение о соединении в одностороннем режиме.

  2. Создайте замещающее соглашение о соединении в двустороннем режиме.

Дополнительные сведения о соглашениях о соединении ADC см. в следующих статьях базы знаний Майкрософт:

  • 823601 — описываются требования и условия использования соединителя ADC в организации (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601).

  • 303180 — описываются требования к использованию соединителя ADC для смешанных административных групп (http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)

  • 317721 — описывается ситуация, при которой происходит удаление прав владельца почтовых ящиков Exchange Server 5.5 при переходе от соглашения о соединении в одностороннем режиме к соглашению о соединении в двустороннем режиме (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721)


Это одностороннее соглашение о подключении из Windows
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Для определения значений атрибутов msExchSynchronizationDirection объектов соглашения о подключении средство анализа Microsoft® Exchange Server делает запрос к службе каталогов Active Directory® . Атрибут msExchSynchronizationDirection представляет направление синхронизации каталогов. Если значение атрибута равно 1, отображается предупреждение.

Значение атрибута msExchSynchronizationDirection может быть равно 0, 1 или 2. 0 обозначает двухстороннее соглашение о подключении, 1 - одностороннее соединение со стороны Active Directory, 2 - одностороннее соглашение о подключении со стороны компьютера Exchange Server.

Рекомендуется использование двухсторонних соглашений о подключении. Окружения Exchange, работающие в смешанном режиме (Exchange Server 5.5 c Exchange 2000 Server и/или Exchange Server 2003), требуют создания двухстороннего соглашения о подключении.

Устранение этого предупреждения

  1. Удалите существующее одностороннее соглашение о подключении.

  2. Создайте двухстороннее соглашение о подключении.

Дополнительные сведени о соглашениях о подключении Active Directory Connector (ADC) содержатся в статьях базы знаний Майкрософт:

  • 823601, «Требования и эффект использования Active Directory Connector в пределах организации» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180, «Требования соглашения о подключении Active Directory Connector для смешанных административных групп» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)

  • 317721, «XADM: Права владельца почтового ящика Exchange Server 5.5 удаляются, когда одностороннее соглашение о подключении ADC заменяется двусторонним» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721)


Разница метки времени между Exchange и Active Directory превышает 5 минут
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_UTCTime, чтобы определить дату и время для каждого из серверов Exchange. Анализатор сервера Exchange также извлекает текущую дату и время для контроллера домена по умолчанию. Если анализатор сервера Exchange обнаруживает, что разница между двумя серверами составляет более пяти минут, выводится ошибка.

В Microsoft Windows 2000 Server и Windows Server™ 2003 для синхронизации даты и времени на компьютерах в сети на платформе Windows используется служба времени Windows. Синхронизация времени критически важна для Windows 2000 Server и Windows Server 2003, поскольку протокол проверки подлинности по умолчанию предусматривает использование времени рабочей станции в процессе создания сертификата проверки подлинности. Протокол проверки подлинности по умолчанию — MIT Kerberos версии 5.

Служба времени Windows на всех серверах Windows домена службы каталогов Active Directory® автоматически настраивается с использованием службы времени Windows, доступной на контроллерах домена. Служба времени Windows настраивает контроллер домена в своем домене как надежный источник данных времени, а затем периодически синхронизирует себя с этим источником.

Чтобы устранить эту ошибку, синхронизируйте время сервера Exchange с сервером каталога.

Чтобы синхронизировать часы на сервере домена Active Directory

  1. Откройте окно командной строки.

  2. Введите w32tm /resync, а затем нажмите клавишу ВВОД.

Если ошибку не удается устранить или она происходит на многих компьютерах организации, проверьте, как была развернута и настроена служба времени Windows в лесе Active Directory. Дополнительные сведения о службе времени Windows см. в техническом справочнике по службе времени Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=40648).

Если серверы переднего плана Exchange не синхронизированы со службой каталога Active Directory, клиенты могут получать сообщения «HTTP 500 — Внутренняя ошибка сервера» при попытке подключения к веб-клиента Microsoft Office Outlook®. Дополнительные сведения см. в статье 841546 базы знаний Майкрософт, описывающей типичные причины возникновения ошибки «HTTP 500 — Внутренняя ошибка сервера» в веб-клиенте Exchange 2000 Outlook (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841546).


Разница метки времени между сервером соединителя Active Directory и Active Directory превышает 5 минут
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_UTCTime, чтобы определить дату и время для каждого из серверов соединителей Active Directory. Анализатор сервера Exchange также извлекает текущую дату и время для контроллера домена по умолчанию. Если анализатор сервера Exchange обнаруживает, что разница между двумя серверами составляет более пяти минут, выводится ошибка.

В Microsoft Windows 2000 Server and Windows Server™ 2003 для синхронизации даты и времени на компьютерах в сети на платформе Windows используется служба времени Windows. Синхронизация времени критически важна для Windows 2000 Server и Windows Server 2003, поскольку протокол проверки подлинности по умолчанию предусматривает использование времени рабочей станции в процессе создания сертификата проверки подлинности. Протокол проверки подлинности по умолчанию — MIT Kerberos версии 5.

Служба времени Windows на каждом из серверов Windows домена службы каталогов Active Directory® автоматически настраивается с использованием службы времени Windows, доступной на соответствующем контроллере домена. Служба времени Windows настраивает контроллер домена в своем домене как надежный источник данных времени, а затем периодически синхронизирует себя с этим источником.

Чтобы устранить эту ошибку, синхронизируйте время сервера соединителя Active Directory с сервером каталога.

Чтобы синхронизировать часы на сервере в домене Windows 2000 Server или Windows Server 2003

  1. Откройте окно командной строки.

  2. Введите w32tm /resync, а затем нажмите клавишу ВВОД.

Если ошибку не удается устранить или она происходит на многих компьютерах организации, изучите, как была развернута и настроена служба времени Windows в лесе Active Directory. Дополнительные сведения о службе времени Windows см. в материале "Windows Time Service Technical Reference" (http://go.microsoft.com/fwlink/?LinkId=40648) (Техническое руководство службы времени Windows).


Работает не последняя выпущенная сборка Windows Server 2003
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализа сервера Microsoft® Exchange запрашивает класс Win32_OperatingSystem инструментария Microsoft Windows® Management Instrumentation (WMI), чтобы определить значение параметра Version для серверов Active Directory Connector (ADC) в структуре Exchange. Анализатор сервера Exchange также проверяет следующий параметр реестра, чтобы определить версию Windows, под которой работают серверы ADC:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Если анализатор сервера Exchange обнаруживает, что значение для второго экземпляра CurrentVersion равно 5.2, а значение параметра Version не равно 5.2.3790, выводится сообщение об ошибке.

Значение CurrentVersion, равное 5.2, означает, что компьютер работает под операционной системой Windows Server 2003. Значение параметра Version для официальной версии всех операционных систем семейства Windows Server 2003 равно 5.2.3790. Любое другое значение параметра Version означает, что на компьютере используется предварительная версия Windows Server 2003.

Если только вы не являетесь участником Проекта внедрения технологий (TAP) или другой подобной партнерской программы Microsoft, корпорация Microsoft не поддерживает и не рекомендует использовать в производсте предварительные версии программных продуктов.

Чтобы исправить эту ошибку

  1. Обновите до последней официальной версии все серверы инфраструктуры Exchange, включая контроллеры доменов, серверы глобального каталога, серверы ADC и компьютеры, работающие под Exchange Server.

  2. Если функция обновления доступна или поддерживается, переустановите операционную систему и восстановите параметры и данные Exchange Server

Обновите до последней версии все серверы инфраструктуры Exchange, включая контроллеры доменов, серверы глобального каталога, серверы ADC и компьютеры, работающие под Exchange Server.

Для получения дополнительных сведений об обновлении программного обеспечения Windows Server 2003 см. веб-узел Windows Server 2003 Software Updates (http://go.microsoft.com/fwlink/?LinkId=33760).


Используется предварительная версия Windows Server 2003
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_OperatingSystem, чтобы определить значение ключа ServicePackMajorVersion. Чтобы определить версию Windows, работающую на целевом компьютере, анализатор сервера Exchange также проверяет следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Если значение второго экземпляра CurrentVersion равно 5.2, а значение ServicePackMajorVersion больше 1, анализатор сервера Exchange выводит на экран предупреждающее сообщение.

Значение CurrentVersion, равное 5.2, показывает, что на компьютере используется операционная система Windows Server™ 2003. Значение ServicePackMajorVersion, большее 1, свидетельствует об установке пакета обновлений, более позднего, чем Service Pack 1 (SP1) . Так как SP1 является единственным официально выпущенным пакетом обновлений для Windows Server 2003, любой иной установленный пакет обновлений Windows Server 2003 (SP2 и более поздний) является предварительным программным обеспечением.

Лицам, не являющимся участниками программы TAP (Technology Adoption Program) или другой аналогичной программы, проводимой Майкрософт, не рекомендуется использовать предварительное программное обеспечение в производственной среде.

Устранение причины появления этого предупреждения

  1. Удалите установленное предварительное программное обеспечение.

  2. Если удаление невозможно, восстановите операционную систему, а затем настройки и данные сервера Exchange.

Дополнительные сведения об обновлениях программного обеспечения Windows Server 2003 см. на веб-узле обновлений программного обеспечения Windows Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=33760.


На сервере Windows 2000 Server не установлен пакет обновления 4 (SP4)
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Анализатор сервера Microsoft® Exchange запрашивает класс инструментария управления Windows (WMI) Win32_OperatingSystem, чтобы определить значение параметра ServicePackMajorVersion. Анализатор сервера Exchange также считывает следующий раздел реестра, чтобы определить версию Microsoft Windows, под управлением которой работает данный компьютер:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Если анализатор сервера Exchange определяет, что на целевой системе работает операционная система Windows 2000 Server, но не установлен пакет обновления (SP4) для Windows 2000 Server, выводится предупреждение.

Для обеспечения наилучшей работы системы рекомендуется установит последние пакеты обновления для всего программного обеспечения, развернутого с Exchange.

Чтобы устранить причину появления этого предупреждения

  1. Обновите все контроллеры домена и серверы глобального каталога, работающие под управлением операционной системы Windows 2000 Server, с помощью пакета обновления 4 (SP4) и установите последние исправления и обновления с веб-узла обновления Windows.

  2. Обновите все компьютеры сервера Exchange с помощью последнего пакета обновления и сборки обновлений.

Сведения о получении и установке пакетов обновления для операционных систем Windows Server 2000 см. на веб-узле, посвященном пакетам обновления для Windows 2000 (http://go.microsoft.com/fwlink/?LinkId=18353).

Дополнительные сведения о получении и установке пакетов обновления и сборок обновлений для сервера Exchange см. на веб-узле, посвященном серверу Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=21573).


Операционная система Windows 2000 Server не является окончательной выпущенной версией сборки
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2005-11-17

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_OperatingSystem, чтобы определить значение раздела Version.

Чтобы определить версию операционной системы Windows, установленной на компьютере, анализатор сервера Exchange также проверяет следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Значение раздела CurrentVersion, равное 5.0, означает, что компьютер работает под операционной системой Microsoft Windows 2000 Server. Значение раздела Version для выпущенных версий всех операционных систем Windows 2000 Server равно 5.0.2195. Любое другое значение раздела Version означает, что используется предварительная версия операционной системы Windows 2000 Server.

Если анализатор сервера Exchange обнаруживает, что значение для второго экземпляра раздела CurrentVersion должно быть равно 5.0, а значение раздела Version не равно 5.0.2195, на экран выводится сообщение об ошибке.

Если вы не являетесь участником программы Technology Adoption Program (TAP) или другой подобной финансируемой корпорацией Майкрософт программы, корпорация Майкрософт не поддерживает и не рекомендует использовать программное обеспечение предварительных версий в рабочих целях.

Чтобы устранить эту ошибку

  1. Обновите все серверы Exchange инфраструктуры, в том числе контроллеры доменов, серверы глобальных каталогов, серверы соединителей Active Directory и компьютеры серверов Exchange до последних выпущенных версий программного обеспечения.

  2. Если параметр обновления доступен и поддерживается, перестройте операционную систему и восстановите параметры и данные сервера Exchange.

Сведения о получении и установке пакета обновления 4 для Windows 2000 см. на веб-узле (http://go.microsoft.com/fwlink/?LinkId=33241).


В адресе X.400 содержится недопустимый знак прерывания
Анализатор сервера Microsoft Exchange — статьи > Active Directory >

Дата последнего изменения раздела: 2006-12-03

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение параметра gatewayProxy политик получателей и проверить, что адрес X.400 заканчивается точкой с запятой.

Правильный формат адреса X.400 в политике получателей означает, что адрес должен заканчиваться точкой с запятой. Если точки с запятой не присутствует это может прервать маршрутизацию сообщения на адрес X.400.

Чтобы устранить эту неполадку, следует добавить точку с запятой в конец адреса с помощью оснастки «Edit» интерфейса ADSI или средства LDP.

Внимание!
Могут возникнуть серьезные проблемы, если некорректно изменить атрибуты объектов Active Directory при использовании оснастки «Edit» интерфейса ADSI (Active Directory Service Interfaces), средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3. Для устранения этих проблем может потребоваться переустановка системы Microsoft Windows Server™ 2003, а также сервера Exchange Server 2003, сервера Exchange Server 2007 или обоих продуктов. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Чтобы устранить эту ошибку

  1. Откройте редактор Active Directory, например, оснастку «Edit» интерфейса ADSI.

  2. Разверните Конфигурация [имя_домена], затем CN=Configuration, DC=имя_домена, DC=суффикс_домена.

  3. Разверните CN=Services, затем CN=Microsoft Exchange.

  4. Последовательно разверните узлы CN=имя_организации, CN=Administrative Groups и CN=Recipient Policies.

  5. Щелкните правой кнопкой мыши CN=имя_политики, а затем щелкните Свойства.

  6. Выполнив прокрутку вниз, выберите gatewayProxy, а затем нажмите кнопку Изменить.

  7. В поле значения введите правильное значение gatewayProxy.

  8. Закройте редактор Active Directory и перезапустите компьютер сервера Exchange, чтобы изменения вступили в силу.


Восстановление базы данных
Анализатор сервера Microsoft Exchange — статьи >

Дата последнего изменения раздела: 2007-01-22

Статьи в этом разделе посвящены ошибкам базы данных и предупреждениям, обнаруженным средством устранения неполадок с базами данных Microsoft® Exchange в журнале событий. Средство устранения неполадок с базами данных использует тот же механизм, что и помощник по устранению неполадок Microsoft Exchange, для программного выполнения последовательности действий по устранению неполадок, чтобы установить основную причину проблем подключения базы данных. Кроме того, в этих статьях содержатся советы по определению симптомов и устранению проблем, связанных с базой данных.

Для получения дополнительных сведений и загрузки см. страницу Microsoft Exchange Troubleshooting Assistant v1.0.


ESE 428 (0xfffff8f0): недостаточно свободного места на диске журнала операций
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-04-02

Средство устранения неполадок с базами данных Microsoft® Exchange обнаружило одно или несколько событий ESE 428 в журнале приложений. Это событие указывает, что на диске журнала транзакций недостаточно места. Если выводится эта ошибка, сервер Exchange Server не может создать новый файл журнала транзакций. Это вызовет переход всех баз данных, находящихся в соответствующей группе хранения, в автономный режим, так как обновления баз данных должны записываться в журнале транзакций.

Объяснение

Exchange Server содержит два механизма, предотвращающих переполнение диска журнала транзакций.

  • Циклическое ведение журналов. После прохождения контрольной точки журналы транзакций удаляются автоматически. В большинстве случаев место, используемое на диске для журналов транзакций, не превышает 50 МБ. Во время резервного копирования перемещение журналов транзакций будет приостановлено.

    Примечание.
    На сервере Microsoft Exchange 2000 Server и в более поздних версиях циклическое ведение журналов по умолчанию отключено.
  • Резервное копирование групп хранения. Exchange Server перемещает лишние журналы после полного или добавочного оперативного резервного копирования всех баз данных в группе хранения с помощью метода резервного копирования, применяющего службу теневого копирования томов или потокового оперативного резервного копирования интерфейсов API сервера Exchange Server.

Количество файлов журналов транзакций будет расти до тех пор, пока не закончится свободное место на жестком диске, если циклическое ведение журналов отключено и выполняется любое из следующих условий.

  • Файлы журналов транзакций не перемещаются программой архивации.

  • Программа архивации перестала запускаться.

  • Файлы журналов транзакций не очищаются с помощью других методов.

Если свободное место на жестком диске заканчивается, файлы журналов транзакций иногда можно перемещать вручную. Их также иногда можно перемещать вручную перед выполнением полного или добавочного оперативного резервного копирования всех баз данных в определенной группе хранения, если свободное место на жестком диске заканчивается. Если при перемещении журналов, находящихся до любой контрольной точки, база данных неожиданно прекратила работать, ее невозможно будет подключить до тех пор, пока необходимые журналы не будут возвращены в исходное место. Поэтому перед перемещением вручную любых файлов журналов транзакций сервера Exchange Server необходимо определить, какие журналы можно безопасно перемещать.

Эта ошибка также может регистрироваться как ошибка JET_errDiskFull или ошибка с кодом 0xfffff8f0. Эта ошибка применима к следующим версиям сервера Exchange Server:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Действия пользователя

Чтобы устранить данную ошибку, выберите любой из следующих способов:

  • Запустите средство управления восстановлением баз данных. На сервере Microsoft Exchange Server 2007 данное средство находится в разделе Восстановление баз данных на панели элементов консоли управления Exchange. Средство анализа Exchange Server автоматически определяет, какие файлы журналов безопасны для перемещения, и копирует их в папку резервного копирования. Настоятельно рекомендуется использовать для перемещения файлов журналов анализатор Exchange Server.

    Примечание.
    Средство анализа Exchange Server не будет работать на сервере Exchange 2007, если группа хранения, содержащая базу данных, включена для непрерывной репликации кластера (CCR).
  • Проверьте значения параметров State (Состояние) и Log Required (Необходимый файл журнала) во всех заголовках баз данных и выясните, какие файлы журналов транзакций безопасны для перемещения вручную.

    Примечание.
    В контексте этой статьи перемещение файла журнала транзакций означает его перемещение в другую папку, в которой можно создать архивировать, хранить или удалять его. Выбор действия зависит от конкретных требований. В контексте этой статьи удаление файла журнала транзакций означает его удаление без возможности его архивации или восстановления.

Чтобы определить, какие файлы журналов транзакций безопасны для перемещения вручную, выполните следующие подробные инструкции.

Просмотр заголовка базы данных и перемещение ненужных файлов журнала

  1. Отключите базу данных, заголовок которой необходимо просмотреть.

  2. Откройте меню Пуск, выберите пункт Выполнить и введите команду cmd, чтобы открыть окно командной строки.

  3. В командной строке переместите путь каталога, в котором находится файл баз данных.

    Примечание.
    Чтобы определить путь и имена EDB- и STM-файлов базы данных на серверах Exchange 2000 Server и Exchange Server 2003, в диспетчере Exchange просмотрите вкладку «База данных» диалогового окна свойств для каждого объекта базы данных. Чтобы определить путь и имя файла базы данных на сервере Exchange Server 2007, откройте консоль управления Exchange в разделе «Конфигурация сервера», нажмите кнопку «Почтовый ящик» и откройте вкладку «Управление базой данных».

  4. В командной строке введите команду Eseutil с параметром /MH.

    Копировать код
    "eseutil /MH databasefilename.edb"
    Примечание.
    В данной команде databasefilename — это имя базы данных, просмотр которой необходимо выполнить.

  5. В появившемся заголовке проверьте значения параметров State (Состояние) и Log Required (Необходимый файл журнала).

    Параметр State (Состояние) предоставляет сведения о том, правильно ли отключена база данных.

    • Если база данных отключена правильно, для параметра State (Состояние) выводится значение Clean Shutdown (Чистое отключение) или Consistent (Согласованная). Это значение различается в зависимости от используемой версии сервера Exchange Server. Все файлы журналов транзакций, кроме текущего файла, можно переместить.

      Примечание.
      Удаление текущего файла журнала, когда все базы данных находятся в состоянии чистого отключения, приведет к сбросу последовательности файла журнала. Это не предотвращает запуск баз данных. Однако сброс последовательности файла журнала влияет на способность восстановления базы данных из предыдущей резервной копии в случае возникновения такой ситуации.
    • Если база данных отключена некорректно, для параметра State (Состояние) выводится значение Dirty Shutdown (Грязное отключение) или Inconsistent (Несогласованная). Выясните, какие файлы журналов транзакций можно перемещать, проверив значение в поле Log Required (Необходимый файл журнала) заголовка базы данных.

      Примечание.
      Когда база данных находится в состоянии грязного или несогласованного отключения, это означает, что некоторые из существующих файлов журналов транзакций содержат невыполненные транзакции, требуемые базой данных. Если в этом случае переместить файлы журналов транзакций, база данных не сможет запуститься до тех пор, пока она не будет восстановлена с резервной копии. Кроме того, базу данных можно восстановить с помощью команд Eseutil и Isinteg.
      Перед перемещением любых журналов группы хранения необходимо проверить значение параметра Log Required (Необходимый файл журнала) для каждой базы данных в группе хранения.

      В поле Log Required (Необходимый файл журнала) содержится диапазон пронумерованных файлов журналов, необходимых для запуска этой базы данных. Если диапазон содержит значения 0—0, файлы журнала для запуска этой базы данных не требуются. Это означает, что база данных находится в состоянии чистого или согласованного отключения. Если имеются файлы журналов старше журнала контрольных точек, такие файлы журналов, кроме журнала контрольных точек, можно переместить.

      Если используемая версия сервера Exchange Server ниже Exchange Server 2003 с пакетом обновления 1 (SP1), необходимо преобразовать десятичный диапазон, указанный в поле Log Required (Необходимый файл журнала), в шестнадцатеричные значения. Например, если в поле Log Required (Необходимый файл журнала) содержатся значения 28217—28221, для запуска этой базы данных требуются файлы журналов от 06E39 до 06E3D. На сервере Exchange 2003 с пакетом обновления 1 (SP1) поле Log Required (Необходимый файл журнала) усовершенствовано и может содержать как десятичные, так и шестнадцатеричные значения.

      Примечание.
      Чтобы преобразовать десятичные значения в шестнадцатеричные, воспользуйтесь калькулятором Windows, переключившись в инженерный режим. Запустите калькулятор и в меню «Вид» выберите пункт «Инженерный». Введите десятичное значение и установите переключатель Hex.
      На серверах Exchange 2000 и Exchange 2003 может находиться до четырех групп хранения, каждая из которых имеет свой набор файлов журнала, поэтому префикс EDB отсутствует в именах файлов журналов транзакций. На серверах Exchange 2000 и Exchange 2003 префикс EDB заменяется на E00, E01, E02 или E03. В группе хранения для восстановления префикс EDB заменяется на R00. Префикс имени файла журнала группы хранения выводится для определенного объекта группы хранения в диспетчере Exchange на вкладке «Общие» диалогового окна свойств. Поэтому если префикс группы хранения E01, а в поле Log Required (Необходимый файл журнала) содержатся значения 28217—28221 (0x06E39—0x06E3D), фактически требуются журналы от E0106E39.log до E0106E3D.log.

  6. Пронумерованные файлы журналов, номера которых меньше наименьшего значения в поле Log Required (Необходимый файл журнала) для любой базы данных в группе хранения, можно безопасно перемещать.

    Примечание.
    Перемещайте, но не удаляйте файлы журналов.
    Примечание.
    Рекомендуется не удалять самый последний файл журнала транзакций. Это файл журнала, который имеет самую последнюю метку времени и еще не имеет номера последовательности в имени файла. Даже если выяснилось, что этот файл можно безопасно переместить, не перемещайте его во избежание сброса последовательности файла журнала до 0. Сброс последовательности файла журнала влияет на циклы резервного копирования. Если резервная копия создана до сброса, восстановление базы данных станет невозможным.


ESE 454 -515: отсутствует необходимый файл журнала транзакций
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-01-23

Анализатор Microsoft® Exchange Server обнаружил событие ESE 454 с кодом ошибки -515. Эта ошибка означает, что не удалось подключить базу данных Exchange из-за отсутствия необходимого файла журнала транзакций.

Объяснение

Событие ESE 454 с кодом ошибки -515 может произойти, если расширенный обработчик хранилищ (ESE) попытается привести все базы данных в группе хранения к согласованному состоянию в ходе процесса восстановления. Если любой из необходимых файлов журнала транзакций отсутствует, происходит сбой процесса восстановления, базу данных не удается подключить и возникает ошибка с кодом -515.

Действия пользователя

Для устранения этой проблемы выполните одно или несколько следующих действий.

  • Используя описанные ниже процедуры определите, какие файлы журнала транзакций отсутствуют и где они находятся. Затем переместите их обратно в папку журнала транзакций данной группы хранения.

  • Восстановите затронутые базы данных из архивных копий.

Внимание!
Не следует пытаться восстанавливать базы данных, если можно успешно применить описанное выше решение: найти и вернуть отсутствующие файлы журнала транзакций. При восстановлении баз данных из архивных копий значительное количество данных, измененных и добавленных после последней архивации, будет перезаписано.
Примечание.
Перед восстановлением баз данных переместите или удалите из папки назначения все файлы журнала транзакций, связанные с данной группой хранения.
Чтобы определить отсутствующие файлы журнала транзакций посредством помощника по устранению неполадок Microsoft Exchange в Exchange Server 2003 и Exchange Server 2007, выполните следующие действия.

  1. В окне Display Examining Event Log Results помощника по устранению неполадок Microsoft Exchange щелкните ссылку Use related Database Recovery Management task to verify and resolve this issue, чтобы определить, какие файлы журнала транзакций отсутствуют.

  2. Запишите имена файлов, полученные на шаге 1.

  3. Определите, где находятся эти файлы в настоящее время, и переместите их обратно в ту папку, где они должны находиться.
Примечание.
При поиске отсутствующих файлов не забудьте просмотреть содержимое корзины и папок карантина антивирусной программы.
  1. Попытайтесь подключить базу данных Exchange, для которой было отображено сообщение об ошибке.

 Чтобы вручную определить и восстановить отсутствующие файлы журнала транзакций в Exchange 2000 Server и Exchange Server 2003, выполните следующие действия.

  1. Запустите диспетчер Exchange.

  2. Разверните узел Административные группы, разверните нужную административную группу, разверните узел Серверы, щелкните правой кнопкой мыши группу хранения и выберите Свойства.

  3. На вкладке Общие запишите путь к файлам журнала транзакций, указанный в разделе Местоположение журнала транзакций.

  4. В командной строке откройте папку, в которой находится программа Eseutil.exe. В Exchange 2000 Server и Exchange Server 2003 программа Eseutil.exe по умолчанию находится в папке C:\program files\exchsrvr\bin.

  5. В командной строке введите следующую команду:

    Копировать код
    eseutil /ml "logpath\logprefix"

    Где logpath — путь к файлам журнала транзакций, записанный на шаге 3, а logprefix — префикс файлов журнала транзакций, обычно это e00.

    Пример такой команды со значениями по умолчанию:

    eseutil /ml "c:\program files\exchsrvr\mdbdata\e00".

  6. Сообщение об отсутствующих файлах журнала транзакций будет отображено в одном из двух приведенных ниже форматах в зависимости от того, какой из файлов отсутствует:

    • Missing log file: c:\program files\exchsrvr\mdbdata\E0002BE2.log

    • ERROR: Missing log file(s). Log file is generation 11,235 (0x2BE3), but expected generation is 11,234 (0x2BE2).

    Здесь 0x2BE2 — имя отсутствующего файла E0002BE2.log.

  7. Запишите имена файлов, полученные на шаге 6.

  8. Определите, где находятся эти файлы в настоящее время, и переместите их обратно в ту папку, где они должны находиться (путь к этой папке был записан на шаге 3).
Примечание.
При поиске отсутствующих файлов не забудьте просмотреть содержимое корзины и папок карантина антивирусной программы.
  1. Попытайтесь подключить базу данных Exchange, для которой было отображено сообщение об ошибке.

 Чтобы вручную определить и восстановить отсутствующие файлы журнала транзакций в Exchange Server 2007, выполните следующие действия.

  1. Запустите консоль управления Exchange на сервере, где находится данная группа хранения.

  2. В дереве консоли разверните узел Конфигурация сервера и щелкните Почтовый ящик.

  3. В области результатов выберите сервер почтовых ящиков, содержащий группу хранения, для которой нужно восстановить отсутствующие файлы журнала транзакций.

  4. Щелкните хранилище почтовых ящиков правой кнопкой мыши и выберите Свойства.

  5. . На вкладке Общие запишите путь к файлам журнала транзакций, указанный в разделе Путь к журналу.

  6. В командной строке откройте папку, в которой находится программа Eseutil.exe. В Exchange Server 2007 программа Eseutil находится в папке установки Exchange по умолчанию. Это папка <системный диск>:\Program Files\Microsoft\Exchange Server\Bin.

  7. В командной строке введите следующую команду:

    Копировать код
    eseutil /ml "logpath\logprefix"

    Где logpath — путь к файлам журнала транзакций, записанный на шаге 5, а logprefix — префикс файлов журнала транзакций, обычно это e00.

    Пример такой команды со значениями по умолчанию:

    eseutil /ml "c:\Program Files\Microsoft\Exchange Server\Bin\e00".

  8. Сообщение об отсутствующих файлах журнала транзакций будет отображено в одном из двух приведенных ниже форматах в зависимости от того, какой из файлов отсутствует:

    • Missing log file: c:\Program Files\Microsoft\Exchange Server\Bin\E000000049A.log

    • ERROR: Missing log file(s). Log file is generation 11,235 (0x2BE3), but expected generation is 11,234 (0x2BE2).

    Здесь 0x2BE2 — имя отсутствующего файла E0002BE2.log.

  9. Запишите имена файлов, полученные на шаге 8.

  10. Определите, где находятся эти файлы в настоящее время, и переместите их обратно в ту папку, где они должны находиться (путь к этой папке был записан на шаге 5).
Примечание.
При поиске отсутствующих файлов не забудьте просмотреть содержимое корзины и папок карантина антивирусной программы.
  1. Попытайтесь подключить базу данных Exchange, для которой было отображено сообщение об ошибке.

Дополнительные сведения о событии ESE 454 см. веб-узел «Events and Errors Message Center» (http://go.microsoft.com/fwlink/?LinkId=81883).


ESE 455 -1811 (0xfffff8ed): отсутствует текущий файл журнала транзакций (Exx.log)
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-05-31

Средство устранения неполадок с базами данных Microsoft Exchange обнаружило в журнале приложений одно или несколько событий ESE 455 с кодом ошибки -1811 (0xfffff8ed). Это событие указывает, что текущий файл журнала транзакций (exx.log) отсутствует, недоступен или имеет несовпадающую подпись.

Объяснение

Ниже перечислены возможные причины этой ошибки.

  • Ошибка 1811, которая соответствует ошибке JET_errFileNotFound. Эта проблема может быть связана с файлом журнала Exchange, который имеет несовпадающую подпись и внутренний номер журнала (LGeneration). Обычно файлом журнала Exchange является файл E00.log. Если файл E00.log имеет несовпадающую подпись, невозможно подключиться к банку данных, даже если база данных согласована.

  • Антивирусная программа отправляет на карантин или удаляет файл журнала Exchange.

  • Команда восстановления eseutil /p была применена к неисправным базам данных и файлы журнала транзакций не были удалены.

  • Команда восстановления eseutil /p была применена с неправильным основным именем файла журнала, например eseutil /r Exx.log, где Exx.log - трехсимвольное основное имя файла журнала.

Эта ошибка также может определяться как -1811, JET_errFileNotFound. Эта ошибка применима к следующим версиям сервера Exchange Server:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Действия пользователя

Для устранения этой проблемы воспользуйтесь указанными ниже способами.

  • Если файл журнала имеет несовпадающую подпись и номер версии, обратитесь в службу поддержки пользователей Майкрософт. Дополнительные сведения см. на странице «Контакты» веб-узла Справка и поддержка Microsoft.

  • Если антивирусная программа отправила на карантин или удалила файл журнала Exchange, выполните следующие действия.

    • Проверьте настройки антивирусной программы.

    • Убедитесь в том, что она не настроена на проверку каталогов сервера Exchange Server.

    • По умолчанию некоторые антивирусные программы еженедельно проверяют диски и каталоги в автоматическом режиме или после запуска вручную. Этот параметр можно легко упустить из виду. Убедитесь в том, что каталоги сервера Exchange Server добавлены в антивирусной программе в список каталогов, которые проверять не надо. Дополнительные сведения о настройке антивирусных программ для совместной работы с сервером Exchange Server см. в статье 823166 базы знаний Майкрософт, Использование антивирусных программ на сервере Exchange Server 2003.

    • Проверьте файлы журналов антивирусной программы, чтобы убедиться в том, что файл журнала Exchange был отправлен на карантин или удален.

    Восстановите файл журнала Exchange, используя один из описанных ниже способов.

Способ 1. Если файл журнала Exchange был отправлен на карантин

  1. Восстановите журнал Exchange в папку, содержащую файлы журналов рабочей среды.

  2. Запустите службу банка данных Microsoft Exchange. Если все остальные файлы журналов имеются в наличии, база данных подключается. Если другие файлы журналов отсутствуют, посмотрите, нет ли их в папке карантина антивирусной программы. Если их там нет, см. способ 2.

Если файл журнала Exchange был удален, необходимо восстановить базу данных группы хранения из резервной копии. Затем необходимо преобразовать файлы журналов. Чтобы восстановить имеющуюся базу данных, выполните следующие действия.

Способ 2. Если файл журнала Exchange был удален

  1. Переместите все несогласованные базы данных в папку резервных копий.

  2. Если был создан новый файл E00.log, переместите его в папку резервных копий. Кроме того, переместите в нее файл E00.chk.

  3. Скопируйте все существующие файлы журналов в папку резервных копий.Примечание. Файлы журналов необходимо скопировать, а не переместить.

  4. Присвойте последнему файлу E00*.log имя E00.log.

  5. Восстановите базу данных из резервной копии. После этого преобразуйте файлы журналов. Это приведет базу данных в согласованное состояние. Однако база данных не будет включать файл E00.log, который был скопирован в папку резервных копий. Несмотря на утрату некоторых данных, теперь базу данных можно подключить.

    Примечание.
    Если базу данных не удается восстановить из резервной копии, запустите для нее программу восстановления, чтобы перевести базу данных в согласованное состояние.

  6. Запустите службу банка данных Microsoft Exchange.

Если команда восстановления eseutil /p была выполнена для неисправных баз данных и файлы журнала не были удалены, выполните следующие действия.

Определение того, была ли выполнена команда eseutil /p

  1. Нажмите кнопку «Пуск», выберите пункт «Выполнить», введите «cmd» и нажмите кнопку ОК.

  2. Введите в командной строке следующую команду:

    Копировать код
    c:\program files\exchsrvr\bin\eseutil /mh "c:\program files\exchsrvr\mdbdata\<name of Exchange database.edb>"

    Синтаксис данной команды основан на следующих предположениях:

    • Программные файлы Exchange Server были установлены в папку c:\program files\exchsrvr.

    • База данных находится в папке c:\program files\exchsrvr\mdbdata.

  3. Прочитайте значение атрибута «количество исправлений». Если оно равно нулю, команда eseutil /p не выполнялась. Если оно отлично от нуля, команда eseutil /p была выполнена для базы данных.

Если общие и частные базы данных находятся в согласованном состоянии или состоянии чистого отключения, файлы журнала транзакций можно переместить в другую папку. Чтобы определить, находятся ли базы данных в этих состояниях, выполните следующие действия.

Определение того, находятся ли базы данных в согласованном состоянии или состоянии чистого отключения

  1. Нажмите кнопку «Пуск», выберите пункт «Выполнить», введите «cmd» и нажмите кнопку ОК.

  2. Чтобы проверить частный банк данных, выполните следующую команду:

    Копировать код
    c:\program files\exchsrvr\bin>eseutil /mh "drive:\program files\exchsrvr\mdbdata\priv1.edb"

  3. Чтобы проверить общий банк данных, выполните следующую команду:

    Копировать код
    c:\program files\exchsrvr\bin>eseutil /mh "drive:\program files\exchsrvr\mdbdata\pub1.edb"

    Синтаксис приведенных в примерах 2 и 3 команд основан на следующих предположениях:

    • Файлы сервера Exchange Server были установлены в папку c:\program files\exchsrvr.

    • База данных находится в папке c:\program files\exchsrvr\mdbdata.

  4. Изучите результаты проверки согласованности. Если база данных является согласованной (находится в состоянии чистого отключения), это означает, что все файлы журналов были сохранены в банке данных. Если база данных не является согласованной (находится в состоянии неправильного отключения), это не означает, что она повреждена. Возможно, файлы журналов еще не были сохранены в ней.

  5. Если база данных находится в состоянии чистого отключения, переместите все файлы журналов из всех каталогов mdbdata в папку резервных копий.

  6. Подключите базы данных.
  • Если команда восстановления eseutil /r была выполнена с неправильным основным именем файла журнала, выполните ее с правильным параметром. К универсальным основным именам файлов журналов относятся имена e00, e01, e02 и e03. Например, в следующей команде указано правильное основное имя файла журнала:

    Копировать код
    eseutil /r e00
  • Если после выполнения описанных выше действий проблема не исчезнет, обратитесь в службу поддержки пользователей корпорации Майкрософт. Дополнительные сведения см. на странице «Контакты» веб-узла Справка и поддержка Microsoft.


ESE 474 -1018: в базе данных обнаружена неустранимая ошибка
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-03-28

Средство устранения неполадок с базами данных Microsoft Exchange обнаружило в журнале приложений одно или несколько событий ESE 474 с кодом ошибки -1018. Такая ошибка создается, если компонент проверки целостности Microsoft Exchange определяет, что серверу Exchange Server не удалось правильно сохранить или получить данные файла базы данных Exchange с подсистемы жесткого диска.

Объяснение

Событие ESE 474 с кодом ошибки -1018 может произойти вследствие повреждения жесткого диска или из-за того, что драйверы или микропрограммы подсистемы жесткого диска устарели или несовместимы.

После возникновения ошибки -1018 диагностические тесты оборудования, запущенные на сервере, могут не выявить проблемы с дисковой подсистемой. В этом случае можно предположить, что причина проблемы заключается в сервере Exchange Server.

Масштабные исследования, проведенные корпорацией Майкрософт и поставщиками оборудования, показали, что причиной большинства ошибок с кодом -1018 являются трудноопределимые проблемы с компонентами оборудования дисковой подсистемы, поддержкой драйверов или микропрограмм.

Exchange сообщает об ошибке с кодом -1018 в случае обнаружения в файле базы данных инициализированной страницы, удовлетворяющей одному из следующих условий:

  • контрольная сумма, хранящаяся в странице, не соответствует результату пересчета контрольной суммы, который выполняется при ее чтении;

  • номер страницы, хранящийся в странице, не соответствует номеру, который страница должна иметь исходя из ее физического размещения в файле базы данных.

Exchange может самостоятельно создавать ошибку с кодом -1018 в одном из следующих случаев:

  • Exchange создает страницу с неправильной контрольной суммой;

  • Exchange создает страницу правильно, но указывает операционной системе записать страницу в неверное местоположение;

Exchange создает контрольную сумму для страницы, которая будет записываться на диск после того, как в страницу будут записаны все данные (включая ее номер). После того как Exchange добавляет к странице контрольную сумму, Exchange указывает операционной системе Windows записать страницу на диск с помощью стандартных опубликованных API Windows.

Временные ошибки памяти могут привести к тому, что страница будет записана в неправильное место на жестком диске.

Даже если контрольная сумма страницы будет правильная, Exchange сообщит об ошибке с кодом -1018, поскольку логический номер страницы не будет соответствовать ее физическому номеру.

Одиночная ошибка с кодом -1018 для базы данных Exchange обычно не приводит к остановке базы данных Exchange или другим последствиям (кроме самого сообщения об ошибке -1018). Проблемная страница может быть пустой или находиться в папке, доступ к которой осуществляется редко, например в папке «Отправленные» или «Удаленные», либо в редко открываемом вложении.

Хотя одиночная ошибка с кодом -1018, как правило, не приводит к потере большого объема данных, такие ошибки представляют собой проблему, поскольку они могут означать, что система хранения по крайней мере один раз не выполнила надежное хранение или получение данных. Ошибка с кодом -1018 является ранним предупреждением о проблеме, которая со временем может стать более серьезной. Даже если первая ошибка с кодом -1018 относилась к пустой странице базы данных, неизвестно, какая страница будет повреждена в следующий раз. Если будет повреждена критически важная глобальная таблица, база данных Exchange может не запуститься, а восстановление базы данных может оказаться безуспешным или успешным лишь частично.

После регистрации в журнале ошибки с кодом -1018 примите меры на случай отказа или случайного повреждения базы данных, пока не будет выявлена основная причина ошибки.

Действия пользователя

Перед тем как исправлять ошибки ESE 474 с кодом -1018, зарегистрированные в журнале приложений, убедитесь, что дисковая подсистема сервера стабильна.

Чтобы устранить проблемы с дисковой подсистемой, выполните указанные ниже действия.

  1. Откройте журнал приложений и найдите все события ESE 474. Для каждого события запишите полный путь к соответствующей базе данных. После составления списка затронутых баз данных запишите буквы дисков, указанные в путях к базам данных. Эти сведения позволят сосредоточить работу по устранению неполадок на этих физических дисках.

  2. Просмотрите системный журнал и убедитесь, что в нем отсутствуют ошибки, связанные с чтением или записью данных на диске либо с истечением времени ожидания.

  3. Воспользуйтесь предоставленными изготовителем средствами диагностики дисковой подсистемы и обратитесь к поставщику оборудования для получения помощи в проверке целостности дисковой подсистемы.

После устранения проблем с дисковой подсистемой или проверки ее стабильности воспользуйтесь указанными ниже способами для восстановления после ошибки с кодом -1018. Способы перечислены в порядке предпочтения.

Первый способ. Перемещение почтовых ящиков из баз данных, указанных в журнале приложений для событий ESE 474. Либо переместите почтовые ящики в существующее заведомо исправное хранилище, либо создайте новое хранилище почтовых ящиков специально для этой цели. После перемещения всех почтовых ящиков удалите поврежденные хранилища почтовых ящиков.

Перемещение почтовых ящиков (Exchange 2000 Server или Exchange Server 2003)

  1. В оснастке «Active Directory — пользователи и компьютеры» выберите пользователя, почтовые ящики которого требуется переместить.

  2. Щелкните правой кнопкой мыши пользователя, выбранного в предыдущем действии, и выберите команду Exchange Tasks (Задачи Exchange).

  3. В мастере задач Exchange на странице Available Tasks (Доступные задачи) выберите пункт Move Mailbox (Переместить почтовый ящик) и нажмите кнопку Next (Далее).

  4. Внимательно следуйте инструкциям мастера.
Перемещение почтовых ящиков (только для Exchange Server 2003)

  1. В диспетчере Exchange разверните узел Servers (Серверы), разверните узел сервера, с которого необходимо переместить почтовые ящики, разверните группу хранения, почтовые ящики которой необходимо переместить, разверните хранилище почтовых ящиков, содержащее требуемые почтовые ящики, и выберите пункт Mailboxes (Почтовые ящики).

  2. В области сведений щелкните правой кнопкой мыши пользователей, почтовые ящики которых необходимо переместить, и выберите команду Exchange Tasks (Задачи Exchange).

  3. В мастере задач Exchange на странице Available Tasks (Доступные задачи) выберите пункт Move Mailbox (Переместить почтовый ящик) и нажмите кнопку Next (Далее).

  4. Внимательно следуйте инструкциям мастера.
Перемещение почтовых ящиков с помощью консоли управления Exchange (только для Exchange Server 2007)

  1. Откройте консоль управления Exchange.

  2. В дереве консоли разверните узел Настройка получателей и выберите пункт Почтовый ящик.

  3. В области результатов выберите почтовые ящики, которые требуется переместить.

  4. На панели операций выберите ссылку Переместить почтовый ящик.

  5. В окне мастера перемещения почтовых ящиков на странице Введение выберите сервер, группу хранения и базу данных почтовых ящиков, куда необходимо переместить почтовый ящик, а затем нажмите кнопку Далее.

  6. На странице Параметры перемещения выберите вариант обработки поврежденных сообщений в почтовом ящике и нажмите кнопку Далее.

  7. На странице Расписание перемещения укажите время выполнения перемещения и нажмите кнопку Далее.

  8. На странице Переместить почтовый ящик просмотрите сводку о перемещении почтовых ящиков и нажмите кнопку Переместить.

  9. На странице Завершение нажмите кнопку Готово.

Дополнительные сведения о поддерживаемых сценариях использования мастера перемещения почтовых ящиков и командлета Move-Mailbox см. в разделе «Перемещение почтовых ящиков» (http://go.microsoft.com/fwlink/?LinkId=85754) документации на сервер Exchange Server 2007 (на английском языке).

Второй способ. Восстановление баз данных из надежной хорошей резервной копии. Дополнительные сведения о восстановлении баз данных Exchange Server см. в следующих статьях:

  • «Аварийное восстановление Exchange Server 2007» (http://go.microsoft.com/fwlink/?LinkId=85802) (на английском языке)

  • «Руководство по аварийному восстановлению Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=30250) (на английском языке)

Третий способ. Жесткое восстановление поврежденных баз данных с помощью средства Eseutil. Третий способ следует применять только в том случае, если первые два способа были неуспешными. После жесткого восстановления необходимо также выполнить автономную дефрагментацию восстановленной базы данных и запустить средство Isinteg для устранения логических повреждений. Эти действия можно выполнить с помощью задачи восстановления средства устранения неполадок с базами данных Exchange. Эта задача автоматически выполняет команды Eseutil /P, Eseutil /D и Isinteg.

Дополнительные сведения

Дополнительные сведения об этой проблеме см. в следующих статьях базы знаний Майкрософт и материалах по Exchange Server:

  • 314917, «Общие сведения об ошибках базы данных Exchange с кодами -1018, -1019, -1022 и их анализ» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314917) (на английском языке)

  • 867626, «В пакет обновления 1 (SP1) для Exchange Server 2003 входит новый код, исправляющий ошибки» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=867626) (на английском языке)

  • 259851, «Последствия выполнения команды eseutil /p или edbutil /d /r в Exchange» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=259851)

  • «Ошибка Exchange Server с кодом -1018» (http://go.microsoft.com/fwlink/?LinkId=85807) (на английском языке)


MSExchangeIS 1003: недостаточно свободного места на диске базы данных Exchange
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-01-22

Средство устранения неполадок с базами данных Microsoft® Exchange обнаружило в журнале одно или несколько событий MSExchangeIS 1003. Эта ошибка может возникать при недостаточном свободном месте на диске, содержащем базы данных, которые требуется подключить.

Объяснение

Когда на диске, содержащем базы данных Exchange, становится недостаточно свободного места, служба банка данных Microsoft Exchange занесет в журнал событие MSExchangeIS 1003, а эти базы данных будут отключены. После этого будет невозможно подключать базы данных для данной группы хранения. Это событие применимо к следующим версиям сервера Exchange Server:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Действия пользователя

Для устранения этой проблему освободите место на диске с базой данных, затем снова попытайтесь подключить ее. Дл этого выполните дно или несколько следующих действий.

  • Если на жестком диске находятся только файлы базы данных Exchange, выполните дефрагментацию баз данных (пока они отключены), чтобы освободить место на диске.

    Примечание.
    Это действие может решить проблему, но может и не решить ее, в зависимости от объема свободного места в базе данных.
    Дополнительные сведения см. в статье 328804 базы знаний Майкрософт Дефрагментация баз данных Exchange.

    Кроме того, см. раздел Инструкции по запуску Eseutil /D (дефрагментация).

  • Если на этом же диске находятся файлы журнала транзакций Exchange, можно освободить место, удалив ненужные файлы журнала.

    Дополнительные сведения см. в статье 240145 базы знаний Майкрософт How to remove Exchange Server transaction log files.


MSExchangeIS 1088: не удается подключить базу данных из-за недопустимого значения атрибута legacyExchangeDN
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-01-23

Средство устранения неполадок с базами данных Microsoft® Exchange обнаружило событие MSExchangeIS 1088. Это событие означает, что базу данных Exchange не удается подключить, поскольку значение атрибута legacyExchangeDN отличается от сохраненного в Active Directory.

Объяснение

Событие MSExchangeIS 1088 может произойти, если база данных Exchange восстановлена в административную группу, для которой значение атрибута legacyExchangeDN отличается от значения этого атрибута в исходной административной группе. Такое поведение используется преднамеренно. Для подключения хранилищ к серверу Exchange Server значение атрибута legacyExchangeDN для организации и административной группы баз данных Exchange должны совпадать со значением атрибута legacyExchangeDN для организации и административной группы в Active Directory.

Действия пользователя

Для устранения этой проблемы выполните следующие действия.

  • Восстановите базу данных Exchange в исходную административную группу.

  • Если базу данных Exchange невозможно установить в исходную административную группу, переименуйте объекты Active Directory предполагаемого назначения, чтобы атрибут legacyExchangeDN имел такое же значение, как для базы данных Exchange. Значение можно исправить при помощи такого средства, как редактор интерфейсов службы каталогов Active Directory (оснастка «Редактирование ADSI»), средства LDP (ldp.exe) или любого другого клиента LDAP версии 3.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью оснастки «Редактирование ADSI», средства LDP или другого клиента LDAP версии 3, может привести к серьезным неполадкам. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, а также сервера Exchange Server 2003, сервера Exchange Server 2007 или обоих продуктов. Пользователь изменяет атрибуты объектов Active Directory на собственный страх и риск.
Для устранения этой ошибки выполните следующие действия.

  1. При помощи редактора ADSI или подобного средства найдите объект группы администрирования в Active Directory.

    Атрибут legacyExchangeDN находится в следующем местоположении:

    CN=Конфигурация,CN=Службы,CN=Microsoft Exchange,CN=Структура,CN=Группы администрирования,CN=Группа администрирования

  2. Введите новое строковое значение в следующей форме:

    /o= организация /ou= административная группа

Дополнительные сведения об использовании средства LDP см. в статье 260745 базы знаний Майкрософт «XADM: Using the LDP Utility to Modify Active Directory Object Attributes» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745) (Использование служебной программы LDP для изменения атрибутов объектов Active Directory).

Дополнительные сведения о работе с оснасткой «Редактирование ADSI» см. в разделе «Adsiedit.msc: редактирование ADSI» в справке Windows Server 2003.

Дополнительные сведения о событии MSExchangeIS 1088 см. в следующих ресурсах:

  • Центр событий и сообщений об ошибках

  • Статья 280652 базы знаний Майкрософт «XADM: "Event ID 1088" Is Logged and Store Fails to Mount» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=280652)


MSExchangeIS 5000 (0x3f5): для службы банка данных настроена неверная учетная запись
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-02-27

Средство устранения неполадок с базами данных Microsoft® Exchange обнаружило в журнале одно или несколько событий MSExchangeIS 5000 с кодом ошибки 0x3f5. Эта ошибка происходит, когда служба банка данных Microsoft Exchange настроена для запуска с учетной записью, отличной от «Локальная система».

Объяснение

Эта проблема может возникать, если служба банка данных Microsoft Exchange (Store.exe) запускается с учетной записью, отличной от «Локальная система», либо контроллер домена, домен или политика безопасности локального компьютера не включают учетную запись «Локальная система» в политику создания аудитов безопасности. При возникновении этой проблемы служба банка данных Exchange не инициализируется. Ошибка применяется к следующим версиям сервера Exchange Server:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Действия пользователя

Для устранения этой проблемы выполните одно или несколько следующих действий.

  • По умолчанию служба банка данных Exchange использует учетную запись «Локальная система» для запуска службы банка данных (MACHINENAME$). Используйте оснастку Services.msc, чтобы проверить, какая учетная запись используется для запуска службы банка данных. Если используется учетная запись «Локальная система», надо предоставить ей право на создание аудитов безопасности. Дл этого используйте один из перечисленных ниже способов.

    • Заново выполните команду Exchange Setup /domainprep с этого компьютера.

    • Вручную предоставьте учетной записи «Локальная система» право на создание аудитов безопасности в одной из следующих политик:

    1. Политика контроллера домена

    2. Политика домена

    3. Политика безопасности локального компьютера

      Чтобы заново предоставить это право политике безопасности локального компьютера рядового сервера, выполните следующие действия.

      Примечание.
      Это решение рекомендуется в том случае, если проблема возникает только на одном сервере.
      Чтобы заново предоставить право на создание аудитов политике безопасности локального компьютера рядового сервера, выполните следующие действия.

      1. Нажмите кнопку Пуск, выберите Администрирование, а затем щелкните Локальная политика безопасности.

      2. Разверните Параметры безопасности, щелкните Локальные политики и Назначение прав пользователя.

      3. В области справа дважды щелкните Создание аудитов безопасности, нажмите кнопку Добавить пользователя или группу, введите MACHINENAME$, затем дважды нажмите кнопку ОК.

      4. Закройте оснастку групповой политики.
  • Если служба банка данных запускается с учетной записью, отличной от «Локальная система», следует настроить службу на использование данной учетной записи (MACHINENAME$). Затем попробуйте запустить службу банка данных. Дополнительные сведения о том, почему сервера Exchange 2000 Server и Exchange Server 2003 используют учетную запись «Локальная система» для запуска служб Exchange см. в статье 239762 базы знаний Майкрософт Exchange Services Run Under LocalSystem.

Дополнительные сведения

Дополнительные сведения см. в статье 281850 базы знаний Майкрософт Information store does not start with event ID 9530 and 5000 messages in Exchange 2000 Server and in Exchange Server 2003.


MSExchangeIS 5000 (0x80004005): не удается подключить базу данных из-за неверной служебной учетной записи, отсутствующих разрешений SeSecurityPrivilege или неверного членства в группах
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-02-19

Средство устранения неполадок с базами данных Microsoft Exchange обнаружило в журнале одно или несколько событий MSExchangeIS 5000 с кодом ошибки 0x80004005. Эта ошибка означает, что не удается подключить одну или несколько баз данных на сервере Exchange из-за неверной служебной учетной записи, отсутствующих разрешений SeSecurityPrivilege или неверного членства в группах.

Объяснение

Эта ошибка может возникать при выполнении любого из следующих условий:

  • Разрешение на управление аудитом и журналом безопасности (SeSecurityPrivilege) удалено из группы «Серверы предприятия Exchange» на одном или нескольких контроллерах домена. Группа «Серверы предприятия Exchange» должна иметь разрешение на управление аудитом и журналом безопасностью на всех контролерах в домене. Если это условие выполняется, то одна или несколько служб, связанных с Exchange Server, могут не запускаться.

  • Служба банка данных Microsoft Exchange запускается с учетной записью, отличной от локальной системы, либо контроллер домена, домен или политика безопасности локального компьютера не включают учетную запись локальной системы в политику создания аудитов безопасности. Если это условие выполняется, то служба банка данных Exchange не запускается.

  • Группа «Серверы предприятия Exchange» в родительском домене не содержит группу «Серверы домена Exchange» из дочернего домена.

Это событие также может быть идентифицировано как MAPI_E_CALL_FAILED. Это событие применимо к следующим версиям сервера Exchange Server:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Действия пользователя

Для устранения этой проблемы выполните одно или несколько следующих действий.

  • Если разрешение Управление аудитом и журналом безопасности (SeSecurityPrivilege) удалено из группы «Серверы предприятия Exchange» на одном или нескольких контроллерах домена, выполните указанные ниже действия.

    Добавление разрешений на одном или нескольких контроллерах домена

    1. Для устранения неполадок с разрешениями используйте программу Policytest.exe, которая находится в папке Support\Utils\I386 на компакт-диске Exchange 2000 или в папке Support\ExDeploy на компакт-диске Exchange Server 2003. Используйте программу Policytest.exe для определения того, имеется ли на контроллере домена разрешение Управление аудитом и журналом безопасности для группы «Серверы предприятия Exchange». В случае успеха будут выведены примерно следующие данные:

      Локальный домен — "<contoso.com>" (contoso); учетная запись — "CONTOSO\Exchange Enterprise Servers"; DC = "<имя_компьютера>"; узел = "<Default-First-Site-Name>"; обнаружено право "SeSecurityPrivilege"

      Примечание. Успешный результат свидетельствует о наличии разрешения «Управление аудитом и журналом безопасности». Для запуска программы Policytest.exe необходимы права администратора домена. Дополнительные сведения о программе Policytest.exe см. в статье 281537 базы знаний Майкрософт, XADM: Описание программы Policytest.exe (на английском языке).

    2. Восстановите действующие по умолчанию разрешения группы «Серверы предприятия Exchange» на уровне домена. Для этого выполните следующие действия.

      1. Выполните команду setup /domainprep с компакт-диска Exchange Server или точки сетевой установки. Команда «setup /domainprep» добавляет группу «Серверы предприятия Exchange» в домен, в котором действуют разрешения по умолчанию. При выполнении команды «setup /domainprep» разрешения незамедлительно добавляются на один контроллер домена. Затем данное изменение воспроизводится на других контроллерах домена.

      2. Восстановите наследование разрешений в других подразделениях. Затем подождите, пока контроллеры домена не воспроизведут изменения во всем домене.

      3. Запустите программу Policytest.exe. Обратите внимание на то, какие контроллеры домена возвратят следующий успешный результат:

        Обнаружено право "SeSecurityPrivilege"

        Если на всех контроллерах домена заданы нужные разрешения, перезапустите службы Exchange Server. Если ни на каких контроллерах домена нужные разрешения не заданы, см. этап 3.

    3. Проверьте политику контроллеров домена по умолчанию. Для этого выполните следующие действия.

      1. Откройте оснастку Active Directory — пользователи и компьютеры.

      2. Щелкните правой кнопкой мыши контейнер Контроллеры домена и выберите пункт Свойства.

      3. Откройте вкладку Групповая политика и убедитесь в том, что в поле Ссылки на объекты групповой политики отображается элемент Политика контроллеров домена по умолчанию.Примечание. Если элемент Default Domain Controllers Policy отсутствует, нажмите кнопку Добавить, щелкните пункт Политика контроллеров домена по умолчанию и нажмите кнопку ОК. Затем подождите, пока это изменение не будет воспроизведено на всех остальных контроллерах домена.

      4. Выполните команду setup /domainprep с компакт-диска Exchange Server или точки сетевой установки. Команда «setup /domainprep» добавляет группу «Серверы предприятия Exchange» в домен, в котором действуют разрешения по умолчанию.

      5. Запустите программу Policytest.exe. Обратите внимание на то, какие контроллеры домена возвратят следующий успешный результат:

      Обнаружено право "SeSecurityPrivilege"

      Если на всех контроллерах домена заданы нужные разрешения, перезапустите службы Exchange Server. Если на некоторых контроллерах домена нужные разрешения не заданы, см. этап 4.

    4. Добавьте разрешения на контроллере домена вручную. Служба репликации файлов (FRS) может не выполнить репликацию обновленной политики безопасности на одном или нескольких контроллерах домена после выполнения команды «setup /domainprep». Если возникла такая проблема, необходимо вручную назначить правильные разрешения группе «Серверы предприятия Exchange». Если на некоторых или всех контроллерах домена правильные разрешения не назначены, назначьте группе «Серверы предприятия Exchange» разрешение «Управление аудитом и журналом безопасности». Затем подождите, пока это изменение не будет воспроизведено на других контроллерах домена. Для этого выполните следующие действия.

      1. Откройте оснастку Active Directory — пользователи и компьютеры.

      2. Щелкните правой кнопкой мыши контейнер Контроллеры домена и выберите пункт Свойства.

      3. Откройте вкладку Групповая политика, щелкните элемент Политика контроллеров домена по умолчанию в поле Ссылки на объекты групповой политики и нажмите кнопку Изменить.

      4. Разверните последовательно узлы Конфигурация компьютера, Конфигурация Windows, Параметры безопасности и Локальные политики и щелкните узел Назначение прав пользователя.

      5. В правой области дважды щелкните элемент Управление аудитом и журналом безопасности, нажмите кнопку Добавить, нажмите кнопку Обзор и добавьте группу Серверы предприятия Exchange.

      6. В диалоговом окне Добавление пользователя или группы нажмите кнопку ОК. Затем нажмите кнопку ОК еще раз.

      7. Закройте оснастку групповой политики и нажмите кнопку ОК в диалоговом окне свойств контроллеров домена.Примечание. При нажатии кнопки Обзор в диалоговом окне «Добавление пользователя или группы» группа «Серверы предприятия Exchange» иногда не отображается. Если это так, добавьте группу «Серверы домена Exchange». Затем выполните команду «setup /domainprep» еще раз. В результате группа «Серверы предприятия Exchange» будет добавлена на всех контроллерах домена.
  • Если служба банка данных Exchange запускается с учетной записью, отличной от учетной записи локальной системы, либо контроллер домена, домен или политика безопасности локального компьютера не содержит учетной записи локальной системы в политике создания аудитов безопасности, воспользуйтесь предлагаемым в данной статье решением.

    По умолчанию служба банка данных Exchange использует для запуска службы банка данных (MACHINENAME$) учетную запись локальной системы. Выясните с помощью оснастки Services.msc, какая учетная запись используется для запуска службы банка данных. Если используется учетная запись «Локальная система», надо заново предоставить ей право на создание аудитов безопасности. Воспользуйтесь для этого одним из описанных ниже способов.

    Предоставление права на создание аудитов безопасности учетной записи «Локальная система»

    1. Выполните на компьютере команду Setup /domainprep.

    2. Вручную предоставьте учетной записи «Локальная система» право на создание аудитов безопасности в одной из следующих политик:

      • Политика контроллера домена

      • Политика домена

      • Политика безопасности локального компьютера

    Предоставление права на создание аудитов безопасности политике безопасности локального компьютера, действующей на рядовом сервере

    1. Нажмите кнопку Пуск, выберите пункт Администрирование, а затем щелкните элемент Локальная политика безопасности.

    2. Разверните узел Параметры безопасности, щелкните элемент Локальные политики, а затем — Назначение прав пользователя.

    3. В правой области дважды щелкните элемент Создание аудитов безопасности, нажмите кнопку Добавить, введите MACHINENAME$, а затем дважды нажмите кнопку ОК.

    4. Закройте оснастку групповой политики.
    Если служба банка данных запускается с учетной записью, отличной от учетной записи «Локальная система», следует настроить службу на использование данной учетной записи (MACHINENAME$). Затем попробуйте запустить службу банка данных. Дополнительные сведения о том, почему серверы Exchange 2000 Server и Exchange Server 2003 используют учетную запись «Локальная система» для запуска служб Exchange см. в статье 239762 базы знаний Майкрософт Службы Exchange выполняются в контексте учетной записи локальной системы (на английском языке).

  • Если группа «Серверы предприятия Exchange» в родительском домене не содержит группу «Серверы домена Exchange» из дочернего домена, добавьте группу «Серверы домена Exchange» из дочернего домена в группу «Серверы предприятия Exchange» в родительском домене. Эту проблему можно также решить, создав в корневом домене службу обновления получателей.

    Запустите для этого программу установки Exchange с параметром /domainprep на сервере в удаленном домене Windows. Затем создайте на сервере Exchange с помощью диспетчера Exchange службу обновления получателей для удаленного домена. Для этого выполните следующие действия.

    Создание службы обновления получателей для удаленного домена

    1. Нажмите кнопку Пуск и выберите по очереди пункты Программы, Microsoft Exchange и Диспетчер Exchange.

    2. Разверните объект Организация, а затем контейнер Получатели.

    3. Щелкните элемент Служба обновления получателей.

    4. В правой области щелкните правой кнопкой мыши элемент Создать и выберите пункт Служба обновления получателей.

    5. Щелкните домен, в котором нет экземпляра службы обновления получателей и есть пользователи, сведения о которых должны быть обновлены сервером Exchange.

    6. Нажмите кнопку Далее.

    7. Выберите сервер, на котором нужно выполнять службу обновления получателей и обрабатывать все необходимые данные пользователей с атрибутами Exchange.

    8. Нажмите кнопку Далее.

    9. Нажмите кнопку Готово.

    10. Чтобы вручную инициировать обновление получателей в домене, щелкните правой кнопкой мыши элемент Служба обновления получателей и выберите пункт Обновить.
    Дополнительные сведения см. в статье 253770 базы знаний Майкрософт Задачи, выполняемые службой обновления получателей Exchange (на английском языке).


MSExchangeIS 5000 (0x80040154): расширения службы SMTP отсутствуют или повреждены
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-02-19

Средство устранения неполадок с базами данных Microsoft Exchange обнаружило в журнале одно или несколько событий MSExchangeIS 5000 с кодом ошибки 0x80040154. Эта ошибка возникает, если расширения службы протокола SMTP отсутствуют или повреждены.

Объяснение

Эта проблема возникает, если расширения службы протокола SMTP Exchange отсутствуют или повреждены. При этом становятся недоступно взаимодействия сервера Exchange и службы SMTP. Служба SMTP является обязательной службой, устанавливаемой в составе Microsoft Internet Information Services (IIS).

Ошибка может возникать по следующим причинам:

  • Система IIS была удалена.

  • Компонент службы SMTP был удален из IIS.

  • Система IIS была удалена, а затем вновь установлена в виде компонента Windows, не имеющего службы SMTP.

  • Система IIS была удалена, а затем вновь установлена в виде компонента Windows с полным набором компонентов. Однако расширения службы SMTP Exchange не были установлены заново.

Это событие применимо к следующим версиям сервера Exchange Server:

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Действия пользователя

Сведения об устранении этой проблемы см. в статье 326305 базы знаний Майкрософт В Exchange 2000 Server или Exchange Server 2003 банк данных не запускается, а в журнале регистрируются события MSExchangeIS с кодом 5000 и 9538 (на английском языке).

Восстановление расширений службы SMTP

  1. Убедитесь в том, что расширения службы SMTP для Exchange отсутствуют. Для этого выполните следующие действия.

    1. Войдите в систему на компьютере с сервером Microsoft Exchange Server с учетной записью, имеющей права администратора.

    2. Нажмите кнопку Пуск, выберите пункт Выполнить, введите команду cmd и нажмите кнопку ОК.

    3. Введите в командной строке команду telnet 127.0.0.1 25, чтобы просмотреть запись «220 server.domain.com Microsoft ESMTP Mail Service».

    4. Введите команду EHLO и нажмите клавишу ВВОД, чтобы просмотреть список из 250 команд. Если в нем нет команд, начинающихся на «X», расширения службы SMTP отсутствуют.

  2. Создайте полную резервную копию системного раздела. Включите в нее файлы состояния системы и базы данных Exchange. Дополнительные сведения о том, как это сделать, см. в статье 258243 базы знаний Майкрософт, Архивация данных и восстановление сервера Exchange при помощи программы архивации данных Windows.

  3. Убедитесь в том, что службы IIS переустановлены правильно и включают необходимые компоненты, зависимые от сервера Exchange.

    IIS 6.0

    1. Нажмите кнопку Пуск, выделите пункт Настройка и выберите Панель управления.

    2. Дважды щелкните значок Установка и удаление программ.

    3. В левой панели щелкните элемент Установка компонентов Windows.

    4. В мастере компонентов Windows найдите в списке компонентов сервер приложений и нажмите кнопку Состав.

    5. Если какие-либо из перечисленных ниже компонентов не установлены, установите их.

      ASP.NET

      Поддержка доступа по протоколу COM+

      Службы IIS

    6. Щелкните элемент Internet Information Services (IIS) и нажмите кнопку Состав.

    7. Если какие-либо из перечисленных ниже компонентов не установлены, установите их.

      Общие файлы

      Диспетчер IIS

      Служба NNTP

      Служба SMTP

      Служба WWW

    8. Нажмите кнопку ОК два раза. На главной странице установки компонентов Windows нажмите кнопку Далее, а затем — Готово.

    IIS 5.0

    1. Нажмите кнопку Пуск, выделите пункт Настройка и выберите Панель управления.

    2. Дважды щелкните значок Установка и удаление программ.

    3. В левой панели щелкните элемент Установка компонентов Windows.

    4. В диалоговом окне мастера компонентов Windows найдите в списке компонентов службы IIS. Если флажок Internet Information Services (IIS) установлен, службы IIS установлены. Чтобы просмотреть установленные компоненты служб IIS, щелкните элемент Internet Information Services (IIS) и нажмите кнопку Состав.

    5. Если службы IIS не установлены, установите флажок Internet Information Services (IIS) и нажмите кнопку Состав. Установите компоненты служб IIS 5.0 и нажмите кнопку ОК. Перед установкой сервера Exchange 2000 должны быть установлены как минимум следующие компоненты служб IIS 5.0:

      Общие файлы

      Оснастка IIS

      Служба SMTP

      Служба NNTP (для групп новостей)

      Служба WWW

    6. Нажмите кнопку Далее, а затем — «Готово».

  4. Восстановите расширения службы SMTP для Exchange.

    Сервер Exchange Server 2003

    Если сервер Exchange 2003 устанавливается поверх существующего экземпляра Exchange 2003, файлы базы данных и разрешения остаются неизменными. Для этого выполните следующие действия.

    1. Вставьте в дисковод компакт-диск Exchange 2003.

    2. Откройте папку \SETUP\I386 и дважды щелкните файл Setup.exe.

    3. На странице приветствия нажимайте кнопку Далее, пока не откроется страница Выбор компонентов.

    4. На странице Выбор компонентов выберите команду Переустановить в столбце Действие, а затем нажмите кнопку Далее.

    5. Проверьте правильность выбора компонентов на странице Сводка по установке и нажмите кнопку Далее, чтобы продолжить установку сервера Exchange 2003.

    Exchange 2000 Server

    Возможность использования тех или иных способов восстановления службы SMTP для Exchange 2000 зависит от того, сколько компонентов служб IIS было удалено. Если служба SMTP является единственным удаленным компонентом служб IIS и для сервера Exchange 2000 Server установлен пакет обновления 2 (SP2) или более поздний, воспользуйтесь программой командной строки Smtpreinstall.exe. Она находится в папке Server\Support\Utils\I386.

    Использование программы Smtpreinstall.exe

    1. Скопируйте файл Smtpreinstall.exe в папку Exchsrvr\Bin.

    2. Перейдите в командной строке в папку Exchsrvr\Bin и введите следующую команду:

      smtpreinstall.exe

    3. Перезапустите компьютер, когда появится соответствующее предложение.

    Если служба IIS 5.0 была удалена или из нее кроме службы SMTP были удалены другие компоненты, переустановите сервер Exchange 2000 поверх существующего экземпляра в ходе интегрированной установки сервера Microsoft Small Business Server 2000.

    Переустановка сервера Exchange 2000 Server

    Примечание.
    Если сервер Exchange 2000 устанавливается поверх существующего экземпляра Exchange 2000, файлы базы данных и разрешения остаются неизменными.
    1. Вставьте в дисковод компакт-диск Exchange 2000 Server.

    2. Откройте папку \SETUP\I386 и дважды щелкните файл Setup.exe.

    3. На странице приветствия нажмите кнопку Далее.

    4. Если будет запрошен ключ компакт-диска, введите его и нажмите кнопку Далее.

    5. На странице Выбор компонентов выберите команду Переустановить в столбце Действие, а затем нажмите кнопку Далее.

    6. Проверьте правильность выбора компонентов на странице Сводка по установке и нажмите кнопку Далее, чтобы продолжить установку сервера Exchange 2000.

  5. Переустановите пакеты обновления и исправления для сервера Exchange

    Дополнительные сведения см. в следующих статьях базы знаний Майкрософт:

    836993 Как получить последний пакет обновления для Exchange Server 2003.

    301378 Как получить последний пакет обновления для Exchange 2000 Server.


MSExchangeIS 5000 (0xc004038a): не удается подключить базу данных из-за неверных разрешений или удаленной группы маршрутизации
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-05-31

Средство устранения неполадок с базами данных Microsoft Exchange обнаружило в журнале приложений одно или несколько событий MSExchangeIS 5000 с кодом ошибки 0xc004038a. Когда возникает такая ошибка, служба банка данных Microsoft Exchange не инициализируется и базы данных не подключается.

Объяснение

Событие MSExchangeIS 5000 с кодом ошибки 0xc004038a может возникать из-за неверной настройки разрешений или из-за удаленной группы маршрутизации. Это событие может быть вызвано одной из указанных ниже причин.

  • Сервер Exchange Server больше не является членом группы маршрутизации или его группа маршрутизации удалена из Active Directory.

  • Группа серверов домена Exchange не имеет необходимых разрешений в Active Directory.

Это событие применимо к следующим версиям сервера Exchange Server:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange Server 2000

Действия пользователя

Для устранения этой проблемы воспользуйтесь указанными ниже способами.

  • Если группа серверов домена Exchange не имеет необходимых разрешений, используйте редактор ADSI, чтобы предоставить этой группе требуемые разрешения в Active Directory. Убедитесь, что на вкладке Безопасность флажок Переносить наследуемые от родительского объекта разрешения на этот объект включен для групп «Администраторы», «Серверы домена Exchange» и для всех прочих необходимых групп.

    Примечание.
    При необходимости выполните репликацию в доменах контроллеров, чтобы распространить изменения на всех компьютерах домена.
    Примечание.
    Редактор ADSI входит в состав средств поддержки Microsoft Windows 2000 и средств поддержки Microsoft Windows Server 2003, доступных на компакт-дисках Windows 2000 и Windows 2003 соответственно.
  • Если сервер Exchange Server больше не является членом группы маршрутизации или его группа маршрутизации удалена из Active Directory, следует добавить или восстановить группу маршрутизации. Для решения проблемы воспользуйтесь наиболее подходящим из описанных ниже способов.

Способ 1. Добавьте сервер в группу маршрутизации. Убедитесь в том, что сервер больше не является членом группы маршрутизации, выполнив указанные ниже действия.

  1. Запустите диспетчер Exchange.

  2. Последовательно разверните узлы Организация, Административные группы, имя_административной_группы и Группы маршрутизации.

    Примечание.
    Здесь «имя_административной_группы» — это имя административной группы.
  3. Просмотрите все доступные группы маршрутизации и убедитесь в том, что данного сервера в них нет.

    Примечание.
    Если группы маршрутизации не отображаются, см. способ 2.
  4. Проверив, что данный сервер не является членом группы маршрутизации, снова добавьте сервер в существующую группу маршрутизации. Для этого выполните следующие действия.

    Важно!
    В случае неверного изменения атрибутов объектов Active Directory при использовании редактора ADSI, программы LDAP или любых других клиентов LDAP версии 3 могут возникнуть серьезные проблемы. Для устранения этих проблем может потребоваться переустановка Microsoft Windows 2000 Server, Microsoft Windows Server 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003 или как Windows, так и Exchange. Корпорация Майкрософт не гарантирует решения проблем, которые могут возникнуть в результате неправильного изменения атрибутов объектов Active Directory. Изменяйте эти атрибуты на свой страх и риск.
Добавление сервера в группу маршрутизации

  1. Нажмите кнопку Пуск, выберите пункт Выполнить, введите adsiedit.msc и нажмите кнопку ОК.

    Примечание.
    Редактор ADSI входит в число средств поддержки Microsoft Windows 2000 и Microsoft Windows Server 2003. Чтобы установить их, выполните указанные ниже действия.
    • На компьютере под управлением Windows 2000 Server дважды щелкните значок программы Setup.exe в папке Support\Tools на компакт-диске Windows 2000 и следуйте инструкциям мастера установки средств поддержки Windows.

    • На компьютере с операционной системой Windows Server 2003 щелкните правой кнопкой мыши файл Suptools.msi в папке Support\Tools на компакт-диске Windows Server 2003, выберите пункт «Установить» и следуйте инструкциям мастера установки средств поддержки Windows Server 2003.

  2. Разверните узел Configuration [ имя_сервера.имя_домена.com ], узел CN=Configuration, DC= имя_домена, DC= com, узел CN=Services, узел CN=Microsoft Exchange, узел CN= имя_организации, узел CN=Administrative Groups, узел CN= имя_административной_группы и щелкните узел CN=Routing Groups.

    Примечание.
    Здесь «имя_сервера» — это имя сервера, «имя_домена.com» — имя домена, «имя_организации» — имя организации Exchange Server, а «имя_административной группы» — имя административной группы.

  3. Щелкните правой кнопкой мыши группу маршрутизации, в которую нужно включить сервер, и выберите пункт Свойства.

  4. Щелкните атрибут distinguishedName и нажмите кнопку Изменить.

  5. Скопируйте значение атрибута distinguishedName в блокнот.

  6. Нажмите кнопку Отмена два раза, чтобы закрыть окно свойств.

  7. В редакторе ADSI разверните узел Configuration [ имя_сервера.имя_домена.com ], узел CN=Configuration,DC= имя_домена ,DC= com, узел CN=Services, узел CN=Microsoft Exchange, узел CN= имя_организации, узел CN=Administrative Groups, узел CN= имя_административной_группы и узел CN=Servers.

  8. Щелкните правой кнопкой мыши элемент имя_сервера и выберите пункт Свойства.

  9. Щелкните атрибут msExchHomeRoutingGroup и нажмите кнопку Изменить.

  10. Вставьте значение, скопированное в блокнот на этапе 5, и нажмите кнопку ОК два раза, чтобы сохранить новое значение.

  11. В диспетчере Exchange найдите группу маршрутизации, в которую был добавлен данный сервер.

  12. Обновите данные в диспетчере Exchange, чтобы увидеть сервер.

    Примечание.
    Если сервер Exchange не появится незамедлительно, подождите выполнения репликации Active Directory.

  13. Если ни для каких других серверов Exchange в данной группе маршрутизации параметру Тип сервера не присвоено значение Главный, щелкните сервер Exchange правой кнопкой мыши и выберите пункт Сделать главным сервером.

  14. Запустите службу банка данных и службу стеков агента передачи сообщений.

Способ 2. Восстановите группу маршрутизации. Если группа маршрутизации была случайно удалена, восстановите ее, используя последнюю резервную копию данных состояния системы. Если свежая резервная копия данных состояния системы отсутствует и используется несколько контроллеров домена, выполните принудительное восстановление удаленной группы маршрутизации.

Восстановление группы маршрутизации

  1. Запустите диспетчер Exchange и создайте группу маршрутизации с тем же именем, которое имела удаленная группа маршрутизации. Для этого выполните следующие действия.

    1. Последовательно разверните узлы Административные группы, имя_административной_группы и Группы маршрутизации.

      Здесь «имя_административной_группы» — это имя административной группы.

    2. Щелкните правой кнопкой мыши элемент Группы маршрутизации, наведите указатель мыши на пункт Создать и выберите вариант Группа маршрутизации.

    3. В поле Имя введите имя группы маршрутизации и нажмите кнопку ОК.

      Введите то же имя, которое имела случайно удаленная группа маршрутизации.

    4. Закройте диспетчер Exchange.

  2. Запустите редактор ADSI. Для этого нажмите кнопку Пуск, выберите пункт Выполнить, введите adsiedit.msc и нажмите кнопку ОК.

    Примечание.
    Редактор ADSI входит в число средств поддержки Microsoft Windows 2000 и Microsoft Windows Server 2003. Чтобы установить их, выполните следующие действия.
    • На компьютере под управлением Windows 2000 Server дважды щелкните значок программы Setup.exe в папке Support\Tools на компакт-диске Windows 2000 и следуйте инструкциям мастера установки средств поддержки Windows.

    • На компьютере с операционной системой Windows Server 2003 щелкните правой кнопкой мыши файл Suptools.msi в папке Support\Tools на компакт-диске Windows Server 2003, выберите пункт «Установить» и следуйте инструкциям мастера установки средств поддержки Windows Server 2003.

  3. Разверните узел Configuration [имя_сервера.имя_домена.com], узел CN=Configuration, DC=имя_домена, DC=com, узел CN=Services, узел CN=Microsoft Exchange, узел CN=имя_организации, узел CN=Administrative Groups, узел CN=имя_административной_группы и щелкните узел CN=Routing Groups.

    Здесь «имя_сервера» — это имя вашего сервера, «имя_домена.com» — имя вашего домена, «имя_организации» — имя вашей организации Exchange Server, а «имя_административной группы» — имя вашей административной группы.

  4. В правой области щелкните правой кнопкой мыши созданную группу маршрутизации и выберите пункт Свойства.

  5. Установите флажки Отображать обязательные атрибуты и Отображать дополнительные атрибуты, если они еще не установлены.

  6. В списке Атрибуты выберите атрибут msExchRoutingGroupMembersBL и нажмите кнопку Изменить.

    Список Значения будет пустым.

  7. Нажмите кнопку Отмена.

  8. В списке Атрибуты дважды щелкните атрибут distinguishedName.

  9. Щелкните правой кнопкой мыши различающееся имя в поле Значение и выберите команду Копировать.

  10. Запустите блокнот (или другой текстовый редактор) и выберите в меню Правка команду Вставить, чтобы вставить в документ различающееся имя.

  11. В диалоговом окне Редактор строковых атрибутов нажмите кнопку Отмена, а затем еще раз нажмите кнопку Отмена, чтобы закрыть диалоговое окно CN=имя_группы_маршрутизации.

    Здесь «имя_группы_маршрутизации» — это имя вашей группы маршрутизации.

  12. В редакторе ADSI в разделе CN=имя_административной_группы щелкните узел CN=Servers.

  13. В правой области щелкните правой кнопкой мыши элемент CN=имя_сервера и выберите пункт Свойства.

    Здесь «имя_сервера» — это имя одного из компьютеров Exchange в данной группе маршрутизации.

  14. В списке Атрибуты щелкните атрибут msExchHomeRoutingGroup и нажмите кнопку Изменить.

  15. Вставьте различающееся имя, скопированное на этапах 9 и 10, в поле Значение и нажмите кнопку ОК.

  16. Нажмите кнопку Применить, а затем — кнопку ОК.

  17. Повторите этапы 13-15 для каждого сервера, который был членом случайно удаленной группы маршрутизации.

  18. В разделе CN=имя_административной_группы щелкните элемент CN=Routing Groups.

  19. В правой области щелкните правой кнопкой мыши созданную группу маршрутизации и выберите пункт Свойства.

  20. В списке Атрибуты выберите атрибут msExchRoutingGroupMembersBL и нажмите кнопку Изменить.

    Список Значения больше не будет пустым.

  21. Нажмите кнопку Отмена два раза.

  22. Закройте редактор ADSI.

  23. Задайте с помощью диспетчера Exchange основной маршрутизатор группы маршрутизации. Для этого выполните следующие действия.

    1. Запустите диспетчер Exchange.

    2. Последовательно разверните узлы Административные группы, имя_административной_группы и Группы маршрутизации.

    3. Разверните созданную группу маршрутизации и щелкните элемент Члены.

    4. В правой области щелкните правой кнопкой мыши компьютер Exchange, который нужно настроить в качестве основного маршрутизатора группы маршрутизации, и выберите пункт Сделать основным маршрутизатором.

    5. Закройте диспетчер Exchange.

  24. Подождите, пока изменения не будут распространены во всем домене.

  25. Запустите остановленные службы Microsoft Exchange.


MSExchangeIS 5000 (0x8004010f): невозможно подключить базу данных из-за неправильных параметров разрешений или недопустимых символов в имени организации
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-01-23

Средство устранения неполадок с базами данных Microsoft® Exchange обнаружило одно или несколько событий MSExchangeIS 5000 с кодом ошибки 0x8004010f в журнале приложений. Это событие указывает, что одну или несколько баз данных на сервере Exchange невозможно подключить из-за неправильных параметров разрешений или недопустимых символов в имени организации Exchange.

Объяснение

Ниже перечислены условия, при которых могут происходить события MSExchangeIS 5000 с кодом ошибки 0x8004010f.

  • Пользователи, прошедшие проверку подлинности, не имеют доступа для чтения в домене или контейнерах конфигурации в службе Active Directory. Когда выполняется это условие, возможно, не удастся установить второй сервер Exchange в административной группе, которая уже содержит сервер Exchange. Кроме того, возможно, не запустится служба банка данных Microsoft Exchange.

  • Разрешение на доступ к чтению для учетной записи «Все» отсутствует в контейнере «Хорошо известные участники безопасности» под контейнером конфигурации в службе Active Directory. При выполнении этого условия служба банка данных Exchange не запускается на рядовом сервере.

  • Имя организации Exchange содержит недопустимые символы. При выполнении этого условия после установки Exchange 2000 Server или Exchange Server 2003 служба банка данных Exchange, возможно, не будет запущена и в журнале приложений будут зарегистрированы события MSExchangeIS 5000 и MSExchangeIS 1121.

Это событие может также определяться как MAPI_E_NOT_FOUND. Это событие применимо к следующим версиям сервера Exchange Server:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Действия пользователя

Чтобы решить эту проблему, выполните одно или несколько следующих действий.

Важно!
В случае неверного изменения свойств объектов Active Directory при использовании оснастки редактирования интерфейса ADSI, служебной программы LDP или любого другого клиента LDAP версии 3 могут возникнуть серьезные проблемы. Для устранения этих проблем может потребоваться переустановка Microsoft Windows® 2000 Server, Microsoft Windows Server™ 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003 или как Windows, так и Exchange. Майкрософт не может гарантировать разрешение проблем, которые возникают в результате неправильного изменения свойств объектов Active Directory. Изменяйте эти свойства на свой риск.
  • Если пользователи, прошедшие проверку, не имеют доступа к чтению в домене или контейнерах конфигурации в службе Active Directory, используйте средство редактирования интерфейса ADSI в Exchange Server 2003 и Exchange 2000 Server, чтобы предоставить таким пользователям доступ к чтению в домене и контейнере конфигурации в службе Active Directory. Выполните следующие действия.

    Примечание.
    Средство редактирования интерфейса ADSI находится в программах поддержки Microsoft Windows 2000 и программах поддержки Microsoft Windows Server 2003. Чтобы установить программы поддержки Windows, запустите программу установки Setup в папке Support\Tools на компакт-диске Windows. Дополнительные сведения о программах поддержки Windows см. в файле Sreadme.doc в папке Support\Tools на компакт-диске Windows.
Порядок предоставления пользователям, прошедшим проверку, доступа к чтению в домене или контейнерах конфигурации в службе Active Directory

  1. Щелкните Пуск, Выполнить, введите adsiedit.msc и затем нажмите кнопку ОК.

  2. Разверните контейнер Domain NC, щелкните правой кнопкой папку этого домена (DC=domain,DC=com) и затем - Свойства, чтобы открыть свойства папки.

  3. Щелкните вкладку Безопасность и затем убедитесь, что для группы Прошедшие проверку пользователи в столбце Разрешить выбран параметр доступа Чтение. Если параметр Чтение не выбран, щелкните его, чтобы выбрать Чтение, и затем нажмите ОК.

  4. Разверните Контейнер конфигурации, щелкните правой кнопкой папку конфигурации (CN=Configuration,DC=domain,DC=com) и затем щелкните Свойства, чтобы открыть свойства папки.

  5. Щелкните вкладку Безопасность и затем убедитесь, что для группы Прошедшие проверку пользователи в столбце Разрешить выбран параметр доступа Чтение. Если параметр Чтение не выбран, щелкните его, чтобы выбрать Чтение, и затем нажмите ОК.

  6. Закройте средство редактирования интерфейса ADSI.

  7. Подождите некоторое время, чтобы изменения были продублированы на контроллерах домена.

  8. Запустите службу банка данных.
  • Если разрешение на доступ к чтению для учетной записи «Все» отсутствует в контейнере «Хорошо известные участники безопасности» под контейнером конфигурации в службе Active Directory, выполните следующие шаги, чтобы разрешить эту проблему.

Разрешение на доступ к чтению для учетной записи «Все» в контейнере «Хорошо известные участники безопасности» в службе Active Directory

  1. Войдите в систему с правами администратора домена и затем запустите средство редактирования интерфейса ADSI.

  2. Разверните контейнер конфигурации и затем щелкните контейнер CN=WellKnown Security Principals

  3. Щелкните правой кнопкой Свойства и затем перейдите на вкладку Безопасность.

  4. Нажмите кнопку Добавить, введите в текстовом поле все и нажмите кнопку ОК.

  5. В столбце Разрешить и установите флажок Чтение.
  • Если в имени организации Exchange содержатся недопустимые символы, удалите их. Дополнительные сведения о недопустимых символах см. в статье 329599 базы знаний Майкрософт База данных Exchange не запускается и в журнале регистрируются события 1121 и 5000 (на английском языке).


MSExchangeIS 9518 (0xfffffddc): превышено максимальное число журналов транзакций для этой группы хранения
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-01-22

Средство устранения неполадок с базами данных Microsoft® Exchange обнаружило в журнале приложений одно или несколько событий MSExchangeIS 9518 с кодом ошибки 0xfffffddc. Это означает, что превышено максимальное число журналов транзакций для этой группы хранения.

Объяснение

Событие MSExchangeIS 9518 с кодом ошибки 0xfffffddc регистрируется в журнале при попытке подключения базы данных к группе хранения при возникновении следующих двух условий:

  • Максимальное число доступных журналов транзакций для этой группы хранения было превышено.

  • Все базы данных в этой группе хранения находятся в состоянии «чистого» отключения.

Кроме того, событие MSExchangeIS 9518 с кодом ошибки 0xfffffddc может быть зарегистрировано в журнале приложений перед отключением неисправной базы данных. Это событие указывает, что Exchange Server использовал все доступные файлы журналов транзакций для этой группы хранения. При заполнении последнего журнала транзакций все базы данных в этой группе хранения отключаются и не могут быть перезапущены.

Exchange использует файлы журналов транзакций, которые последовательно пронумерованы. В Exchange 2000 Server и Exchange Server 2003 номера файлов журналов транзакций начинаются с Exx00001.log и затем последовательно возрастают до ExxFFFF0.log. Максимальное число файлов журналов транзакций, которые могут быть созданы в одной последовательности, - 1 048 560 (0xFFFF0). Обычно этот процесс создания такого большого количества файлов журналов занимает несколько лет.

В Exchange Server 2007 максимальное число файлов журналов транзакций увеличено. В последовательности может быть до 2 147 483 647 файлов журнала (0x7FFFFFFF в шестнадцатеричной системе счисления, так как имена файлов журнала представлены в шестнадцатеричной форме). Размер каждого файла журнала транзакций равен 1 мегабайту (МБ). Маловероятно, что подобная ошибка может произойти в Exchange Server 2007.

Действия пользователя

Чтобы исправить ошибку, необходимо удалить все файлы журналов транзакций и сбросить последовательность этих файлов обратно до 1. После сброса последовательности файлов журнала, имя файла журнала приобретет вид Exx00001.log в Exchange Server 2003 и более старших версиях и Exx00000001.log в Exchange Server 2007.

Чтобы выполнить эту операцию, используйте задачу «Сбросить номер журнала» в средстве управления возвращением базы данных в исходное состояние, которое входит в состав Помощника по устранению неполадок Microsoft Exchange. С помощью этого средства будет выполнена проверка, чтобы все базы данных были выключены правильно, и затем все файлы журналов транзакций буду безопасно перемещены в место сохранения резервной копии.

Примечание.
Файлы журналов транзакций можно также удалить вручную, однако удаление вручную может привести к тому, что база данных в какой-нибудь группе хранения будет неправильно отключена и эту базу данных невозможно будет снова подключить. Чтобы избежать этих ошибок, рекомендуется использовать средство управления возвращением базы данных в исходное состояние.

Для получения дополнительных сведений и загрузки этого средства см. Microsoft Exchange Troubleshooting Assistant v1.0.


MSExchangeIS 9518 (0xfffff745): не удается создать временные файлы или получить доступ к ним
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-01-23

Средство устранения неполадок с базами данных Microsoft® Exchange обнаружило в журнале одно или несколько событий MSExchangeIS 9518 с кодом ошибки 0xfffff745. Эта ошибка возникает, если сервер Exchange не может создать файлы или получить доступ к файлам в папках, указанных в системных переменных TMP или TEMP.

Объяснение

Эта проблема может возникать при выполнении любого из следующих условий:

  • Путь, где находятся папки, указанные в переменных TMP или TEMP, недоступен или доступен только для чтения. Например, проблема может возникнуть, если переменная TMP соответствует удаленному накопителю или сетевому хранилищу данных, а этот накопитель или сетевое хранилище данных недоступны.

  • Для переменной TMP или TEMP неверно настроены параметры реестра.

  • Сервер Exchange не обладает полными правами доступа от корневой папки диска до журналов транзакций и баз данных.

Действия пользователя

Для устранения этой проблемы выполните одно или несколько следующих действий.

Примечание. Существует несколько версий Microsoft Windows, поэтому описанные ниже действия могут различаться на разных компьютерах. В этом случае для выполнения необходимых действий см. документацию по продукту.

  • Убедитесь, что переменные TMP и TEMP в Windows указывают на доступное расположение. Для этого выполните следующие действия.

    Укажите доступное расположение для папок, соответствующих системным переменным TEMP и TMP

    1. Нажмите кнопку «Пуск», щелкните «Настройка» и «Панель управления».

    2. Дважды щелкните значок Система, перейдите на вкладку Дополнительно и нажмите кнопку Переменные среды.

    3. В области «Системные переменные» выберите TEMP и нажмите кнопку Изменить.

    4. Если в поле Значение не отображается правильный путь, введите правильное расположение для переменной TEMP и нажмите кнопку ОК. Например, введите %systemroot%\Temp, затем нажмите кнопку «ОК».

    5. В области «Системные переменные» выберите TMP и нажмите кнопку Изменить.

    6. Если в поле Значение не отображается правильный путь, введите правильное расположение для переменной TMP и нажмите кнопку ОК. Например, введите %systemroot%\Temp, затем нажмите кнопку «ОК».

    7. Дважды нажмите кнопку ОК, чтобы закрыть окно Свойства системы.

    8. Перезагрузите компьютер.
  • Проверьте и назначьте группе локальных администраторов или учетной записи SYSTEM полный доступ к папке Temp. Если этого недостаточно назначьте полный доступ группе администраторов домена. По умолчанию для системных переменных TMP и TEMP указывается следующий путь:

    %SYSTEMROOT%\Temp

    Сервер Exchange должен получать доступ к этой папке посредством учетной записи SYSTEM. Для проверки разрешений выполните следующие действия:

    Проверьте разрешения доступа к папке Temp

    1. Щелкните правой кнопкой мыши кнопку Пуск и выберите команду Проводник.

    2. Щелкните правой кнопкой папку Temp, указанную в системной переменной, и выберите Свойства. Обычно это %systemroot%\Temp.

    3. Перейдите на вкладку Безопасность.

    4. В списке Группы или пользователи выберите SYSTEM и просмотрите разрешения, которые будут показаны в списке Разрешения.
    Если разрешения для папки Temp указаны верно, проверьте разрешения для всех дисков, содержащих базы данных и файлы журналов Exchange. Учетная запись SYSTEM должна иметь полный доступ к корневой папке диска и всем папкам, содержащим файлы баз данных и журналов транзакций Exchange. Например, если журналы транзакций хранятся в папке C:\Exchsrvr\Mdbdata, то учетная запись SYSTEM должна иметь полный доступ к корневой папке диска C, к папке Exchsrvr и к папке Mdbdata.

  • Проверьте правильность параметров реестра. Для этого выполните следующие действия.

    Проверьте параметры реестра.

    1. Нажмите кнопку Пуск, щелкните Выполнить, введите Regedt32.exe и нажмите кнопку ОК.

    2. Найдите следующий раздел реестра:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

    3. Найдите имя TMP (или TEMP). Параметр должен иметь тип REG_EXPAND_SZ.

    4. Если любой из параметров указан неверно, сделайте архивную копию раздела Environment и удалите значения TMP или TEMP в окне справа.

    5. Нажмите кнопку «Пуск», щелкните «Выполнить», введите Sysdm.cpl и нажмите кнопку «ОК».

    6. На вкладке «Дополнительно» нажмите кнопку Переменные среды.

    7. Убедитесь, что значения, удаленные на шаге 4, отсутствуют в списке «Системные переменные».

      Примечание.
      Для просмотра переменных TEMP и TMP может потребоваться прокрутить список вниз.

    8. Нажмите кнопку Создать. В поле Имя переменной введите имена, удаленные на шаге 4, например C:\Winnt\TEMP.

    9. Нажмите кнопку ОК три раза, затем перезагрузите компьютер.


MSExchangeIS 9518 0xfffffbc4: путь к файлу журнала уже используется
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-05-14

Средство устранения неполадок с базами данных Microsoft Exchange обнаружило в журнале приложений одно или несколько событий MSExchangeIS 9518 с кодом ошибки 0xfffffbc4. Этот код ошибки указывает на то, что одна или несколько групп хранения настроены на использование одного и того же пути к файлам журнала или системным файлам.

Объяснение

Эта ошибка может возникнуть, если несколько групп хранения настроены на использование одного и того же пути к файлам журнала или системным файлам. Сервер Exchange Server требует, чтобы каждая группа хранения имела уникальный путь к файлам журнала и системным файлам.

Действия пользователя

Чтобы устранить данную проблему, убедитесь, что каждая группа хранения настроена на использование уникального пути к файлам журнала и системным файлам.

Примечание.
Отдельная группа хранения может использовать один и тот же путь к файлам журнала и системным файлам. Но этот же самый путь нельзя использовать в качестве пути к файлам журнала или системным файлам для другой группы хранения.
Проверка или установка путей к файлам журнала и системным файлам в Exchange 2000 Server и Exchange Server 2003

  1. Откройте диспетчер Exchange.

  2. Последовательно разверните узел Administrative Groups (Административные группы), административную группу, узел Servers (Серверы), щелкните правой кнопкой мыши необходимую группу хранения и выберите команду Properties (Свойства).

  3. На вкладке General (Общие) в разделе Transaction log location (Местоположение журнала транзакций) нажмите кнопку Browse (Обзор).

  4. Убедитесь, что значения Log files path (Путь к файлам журнала) и System files path (Путь к системным файлам) для данной группы хранения являются уникальными.

  5. Если значения параметров Log files path (Путь к файлам журнала) и System files path (Путь к системным файлам) не уникальны для данной группы хранения, введите путь к новому местоположению файлов журнала или системных файлов и нажмите кнопку OK.

  6. Нажмите кнопку OK.
Проверка или установка путей к файлам журнала и системным файлам для группы хранения в Exchange Server 2007

  1. Откройте консоль управления Exchange.

  2. Разверните узел Настройка серверов и выберите пункт Почтовый ящик.

  3. В области Почтовый ящик выберите необходимый сервер.

  4. В области Управление базой данных щелкните правой кнопкой мыши требуемую группу хранения и выберите команду Свойства.

  5. Убедитесь, что параметры Путь к файлам журнала и Путь к системным файлам уникальны для данной группы хранения.

  6. Если параметры Путь к файлам журнала и Путь к системным файлам не уникальны для данной группы хранения, задайте уникальное местоположение для путей к файлам согласно рекомендациям, изложенным в разделе «Задание или изменение местоположения файлов журнала группы хранения» документации на сервер Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkId=80702) (на английском языке).

Дополнительные сведения о перемещении файлов журнала в Exchange Server 2003 см. в статье 821915 базы знаний Майкрософт «Перенос баз данных и журналов Exchange в Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915).

Дополнительные сведения о перемещении файлов журнала в Exchange 2000 Server см. в статье 239944 базы знаний Майкрософт «XADM. Перемещение журналов транзакций и системных журналов» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239944) (на английском языке).


MSExchangeIS 9518 (0xfffffd9a): отсутствует файл контрольных точек, существует свыше 1008 файлов журнала транзакций
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-01-23

Средство устранения неполадок с базами данных Microsoft® Exchange обнаружило в журнале одно или несколько событий MSExchangeIS 9518 с кодом ошибки 0xfffffd9a. Эта ошибка означает, что файл контрольных точек (Exx.chk) для данной группы хранения отсутствует или удален, и существует свыше 1008 файлов журнала транзакций.

Объяснение

Эта проблема может возникнуть в следующих условиях:

  • Файлы журнала и базы данных были правильно выключены. Поэтому нет сбоя, после которого их можно восстановить.

  • Файл контрольных точек Exx.chk переименован или удален.

  • Между контрольными точками накопилось более 1008 файлов журнала, которые должны быть воспроизведены на сервере.

  • В случае восстановления с «накатом» одна или несколько баз данных в группе хранения исчезают, однако файлы журнала остались на сервере во время восстановления. Операция восстановления с «накатом» не завершена успешно.

В такой ситуации служба банка данных Microsoft Exchange выполняет мягкое восстановление и воспроизводит все файлы журнала во время запуска. Файлы журнала и базы данных были правильно выключены, поэтому не запускается процедура восстановления. Так как отсутствует контрольная точка, сервер Exchange обрабатывает все файлы журнала подряд до тех пор, пока не будет найдена запись о чистом отключении. Поскольку количество файлов журнала превышает 1008, сервер Exchange просматривает предельное число файлов, равное 1008, и не находит запись о чистом отключении.

Примечание.
Описанные симптомы также могут возникнуть, если выполняются перечисленные выше условия, и выполняется воспроизведение файлов журнала при помощи команды eseutil /r. Команда eseutil /r также выполнят мягкое восстановление хранилища почтовых ящиков.

Эта ошибка также может быть идентифицирована как «error JET_errCheckpointDepthTooDeep, -614». Эта ошибка применима только к Microsoft Exchange Server 2003.

Действия пользователя

Для устранения этой проблемы в Exchange Server 2003 установите исправление, описанное в статье 836611 базы знаний Майкрософт Information Store databases do not mount and you receive an "Operation terminated with error -614" error message when you start a computer that is running Exchange Server 2003.


MSExchangeIS 9518 0xfffffb40: отсутствует файл базы данных
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-05-23

Средство устранения неполадок с базами данных Microsoft Exchange обнаружило в журнале приложений одно или несколько событий MSExchangeIS 9518 с кодом ошибки 0xfffffb40. Эта ошибка указывает на то, что для группы хранения отсутствует один или несколько файлов базы данных.

Объяснение

Эта ошибка может возникнуть, если в процессе восстановления подсистема ESE пытается согласовать все базы данных в группе хранения, но обнаруживает, что файлы базы данных отсутствуют или заменены другими версиями.

В случае отсутствия какого-либо файла базы данных из группы хранения или его замены файлом другой версии подсистема ESE возвращает ошибку -1216, прерывает восстановление и не запускает группу хранения.

Действия пользователя

Чтобы устранить данную проблему, выполните одно или несколько из указанных ниже действий.

  • Первый способ. Если отсутствующий файл базы данных был перемещен или переименован, найдите в журнале приложений все события ESE 494, которые произошли после попытки подключения базы данных. Для каждого события запишите конкретный файл базы данных, об отсутствии которого сообщается, найдите текущее местоположение этого файла и переместите его в нужное местоположение.

Примечание.
Если на сервере установлена антивирусная программа, выполняющая проверку на файловом уровне, и для нее были неправильно настроены исключения, возможно, база данных была удалена или помещена в карантин антивирусной программой. Чтобы определить, не произошло ли это, проверьте карантин антивирусной программы и журнал удалений.
  • Второй способ.

    • Второй способ, вариант А. Если отсутствующий файл базы данных был удален или утерян, восстановите его из резервной копии в рабочую группу хранения. Для проверки доступности восстановленного файла базы данных для восстановления можно воспользоваться задачей средства управления восстановлением баз данных Exchange Проверьте файлы журнала базы данных и транзакций.

      В процессе восстановления этого файла базы данных можно подключать другие неповрежденные базы данных в группе хранения и получать к ним доступ. Для этого выполните указанные ниже действия.

Включение доступа почтового ящика пользователя к неповрежденным базам данных

  1. Выполните команду eseutil /R /L <путь_к_файлам_журнала> /S <Path to System Files> Log Base Name /I (где «Log Base Name» — это первые три знака в имени файлов журнала для данной группы хранения, т. е. E00, E01 и т. д.). Это позволяет подсистеме ESE согласовать имеющиеся файлы базы данных, пропустив отсутствующие файлы. После выполнения этой команды все отсутствующие файлы базы данных необходимо будет восстановить из резервной копии.
Примечание.
Параметры /L и /S являются необязательными, и их не нужно использовать, если средство eseutil запускается из папки, в которой находятся файлы журнала и системные файлы.
  1. Подключите в группе хранения файлы базы данных, которые теперь присутствуют и согласованы.

  2. Пользователи, почтовые ящики которых находятся в подключенной базе данных, могут получать доступ к почте.
  • Второй способ, вариант Б. Восстановите файл базы данных из резервной копии в группу хранения для восстановления. Отправлять и получать почту можно сразу же после создания новой базы данных (этот процесс называется аварийным восстановлением). При этом клиенты видят пустой почтовый ящик, но они смогут отправлять и получать почту быстрее, чем если бы им было необходимо дожидаться окончания восстановления или исправления.

Примечание.
Аварийное восстановление потребует последующего слияния всех новых данных (созданных после аварийного восстановления) с восстановленными данными.

Дополнительные сведения об аварийном восстановлении см. в подразделе «Переносимость аварийного восстановления» () раздела «Аварийное восстановление» документации на Exchange Server 2007.

Дополнительные сведения о группах хранения для восстановления см. в подразделе «Общие сведения о группах хранения для восстановления» () раздела «Аварийное восстановление» документации на Exchange Server 2007.
  • Третий способ. Если для одной или нескольких баз данных в группе хранения было выполнено жесткое восстановление (как вручную, так и с помощью задачи Восстановить базу данных помощника по устранению неполадок Exchange) и эти базы данных согласованы, возможно, файлы журнала для группы хранения не были удалены. Если все базы данных для группы хранения находятся в правильном местоположении, проверьте, согласованы ли они, с помощью указанной ниже команды.

Проверка согласования файла базы данных вручную

  1. Выполните команду eseutil /mh <path to database .edb file>

  2. В выходных данных команды найдите поле State: (Состояние) и проверьте, имеет ли оно значение Clean Shutdown (Состояние «чистого» отключения).

  3. Если все базы данных в группе хранения находятся в состоянии «чистого» отключения, переместите все журналы транзакций и системные журналы для группы хранения в резервное местоположение, а затем попытайтесь подключить хранилище. Если удалось правильно подключить все базы данных, рекомендуется немедленно создать резервную копию группы хранения.

Дополнительные сведения

Дополнительные сведения о событии MSExchangeIS 9518 с кодом ошибки 0xfffffb40 см. на странице «Центр сообщений о событиях и ошибках» (http://go.microsoft.com/fwlink/?LinkId=91705) (на английском языке).

Дополнительные сведения о восстановлении после этой ошибки см. в статье 296843 базы знаний Майкрософт «Восстановление базы данных Exchange 2000 Server после ошибки с кодом -1216» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=296843) (на английском языке).

Дополнительные сведения о планировании аварийного восстановления для Exchange см. в статье «Руководство по планированию аварийного восстановления для Exchange» (http://go.microsoft.com/fwlink/?LinkId=91706) (на английском языке).

Дополнительные сведения об управлении восстановлением баз данных и мастерах устранения неполадок с базами данных см. в статье «Управление восстановлением баз данных и средство устранения неполадок с базами данных» (http://go.microsoft.com/fwlink/?LinkId=91707) (на английском языке).

Дополнительные сведения об аварийном восстановлении см. в подразделе «Переносимость аварийного восстановления» (http://go.microsoft.com/fwlink/?LinkId=91703) раздела «Аварийное восстановление» документации на Exchange Server 2007.

Дополнительные сведения о группах хранения для восстановления см. в подразделе «Общие сведения о группах хранения для восстановления» (http://go.microsoft.com/fwlink/?LinkID=80784) раздела «Аварийное восстановление» документации на Exchange Server 2007.


MSExchangeIS 9518 (0xfffffea8): несоответствие штампа времени базы данных в файле базы данных
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-01-23

Средство устранения неполадок с базами данных Microsoft® Exchange обнаружило в журнале одно или несколько событий MSExchangeIS 9518 с кодом ошибки 0xfffffea8. Эта ошибка возникает, если значение параметра dbtime на текущей странице базы данных превышает значение глобального параметра dbtime базы данных.

Объяснение

В случае возникновения этой ошибки соответствующие базы данных почтовых ящиков и общих папок не будут подключаться. Эта ошибка также может быть идентифицирована как «JET_errDbTimeCorrupted».

Ошибка применяется к следующим версиям сервера Exchange Server:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Действия пользователя

Чтобы устранить несоответствие штампа времени базы данных, запустите команду eseutil /d для дефрагментации базы данных, затем подключите эту базу данных. Дополнительные сведения о запуске команды eseutil /d см. в разделе Инструкции по запуску Eseutil /D (дефрагментация). Также см. статью 328804 базы знаний Майкрософт Дефрагментация баз данных Exchange.


MSExchangeIS 9518 (0xfffff764): потоковый файл отсутствует или недоступен
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-01-23

Средство устранения неполадок с базами данных Microsoft® Exchange обнаружило в журнале одно или несколько событий MSExchangeIS 9518 с кодом ошибки 0xfffff764. Эта ошибка возникает, если сервер Exchange не может получить доступ к потоковому файлу (STM-файлу), сопоставленному с базой данных.

Объяснение

Эта ошибка может возникать, если потоковый файл (STM-файл), сопоставленный с базой данных, был удален, перемещен, либо сервер Exchange не может получить доступ к этому файлу из-за изменений разрешений.

Примечание.
В некоторых обстоятельствах антивирусные программы могут удалять или изменять разрешения, назначенные файлам Exchange, включая STM-файл, если папки Exchange не были исключены из проверки рекомендациями Microsoft Exchange. Дополнительные сведения см. в статье 823166 базы знаний Майкрософт Использование антивирусных программ на сервере Exchange Server 2003.

Эта ошибка также может быть определена как «-2204». Эта ошибка применима к следующим версиям сервера Exchange Server:

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Действия пользователя

Для устранения этой проблемы выполните одно или несколько следующих действий.

  • Восстановите потоковый файл из архивной копии базы данных.

  • Проверьте, не был ли потоковый файл перемещен антивирусной программой в папку карантина. Если этот файл находится в папке карантина, переместите его в исходное расположение, а затем настройте антивирусную программу таким образом, чтобы она не проверяла папки Exchange Server 2003.

    Примечание.
    Некоторые антивирусные программы устанавливают файлам атрибут «Только чтение» при их перемещении в папку карантина. Если потоковый файл находится в папке карантина, щелкните этот файл правой кнопкой мыши и выберите Свойства. Снимите флажок Только чтение перед попыткой подключения базы данных.
  • Можно запустить средство Microsoft Exchange Database Recovery Management Tool, входящее в состав помощника по устранению неполадок Microsoft Exchange. Средство Database Recovery Management Tool может проанализировать файлы журнала базы данных и журнала транзакций для данной группы хранения и предоставить дополнительные данные об этой проблеме. Для получения дополнительных сведений и загрузки см. страницу Microsoft Exchange Troubleshooting Assistant v1.0.


MSExchangeIS 9518 (0xfffffbf8): отсутствуют необходимые разрешения на папку или диск с базой данных Exchange
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-03-15

Средство устранения неполадок с базами данных Microsoft Exchange обнаружило в журнале приложений одно или несколько событий MSExchangeIS 9518 с кодом ошибки 0xfffffbf8. Это означает, что для папки или диска, содержащих базы данных Exchange, не назначены соответствующие разрешения.

Объяснение

Эта ошибка указывает на то, что для папки или диска, содержащих файлы базы данных Exchange, не назначены разрешения, необходимые для выполнения основных функций. Пользователи могут испытывать трудности с доступом либо с подключением хранилищ почтовых ящиков или хранилищ общих папок.

Действия пользователя

Чтобы устранить данную проблему, установите для папки, содержащей базы данных Exchange, и диска, на котором расположена эта папка, разрешения по умолчанию.

Предоставление разрешений по умолчанию для папки, содержащей базы данных Exchange, в Exchange Server 2007

  1. Откройте проводник и перейдите к папке, содержащей базы данных Exchange. По умолчанию это папка C:\Program Files\Microsoft\Exchange\Mailbox\имя_группы_хранения\

  2. Щелкните эту папку правой кнопкой мыши и выберите команду Свойства.

  3. Откройте вкладку Безопасность и предоставьте указанные ниже разрешения по умолчанию.

Учетная запись | Разрешения
Администраторы | «Полный доступ»
Система | «Полный доступ»
 Предоставление разрешений по умолчанию для диска, содержащего базы данных Exchange, в Exchange Server 2007

  1. Откройте проводник.

  2. Щелкните правой кнопкой мыши объект локального диска, содержащего папку с базой данных Exchange, и выберите команду Свойства.

  3. Откройте вкладку Безопасность и предоставьте указанные ниже разрешения по умолчанию (в зависимости от установленной операционной системы).

Windows 2000 Server:

Учетная запись | Разрешения
Все | «Полный доступ»

Windows Server 2003:

Учетная запись | Разрешения
Администраторы | «Полный доступ»
Создатель-владелец | Нет
Все | Нет
Система | «Полный доступ»
Пользователи | «Чтение и выполнение», «Список содержимого папки», «Чтение»
 Предоставление разрешений по умолчанию для папки Mdbdata в Exchange 2000 Server и Exchange Server 2003

  1. Запустите проводник, перейдите к папке Exchsvr и откройте ее.

  2. Щелкните правой кнопкой мыши папку Mdbdata и выберите команду Свойства.

  3. Откройте вкладку Безопасность и предоставьте указанные ниже разрешения по умолчанию.

Учетная запись | Разрешения
Администраторы | «Полный доступ»
Прошедшие проверку | «Чтение и выполнение», «Список содержимого папки», «Чтение»
Создатель-владелец | Нет
Операторы сервера | «Изменение», «Чтение и выполнение», «Список содержимого папки», «Чтение», «Запись»
Система | «Полный доступ»
 Предоставление разрешений по умолчанию для диска, содержащего папку Mdbdata, в Exchange 2000 Server и Exchange Server 2003

  1. Откройте проводник.

  2. Щелкните правой кнопкой мыши объект локального диска, содержащего папку Mdbdata, и выберите команду Свойства.

  3. Откройте вкладку Безопасность и предоставьте указанные ниже разрешения по умолчанию (в зависимости от установленной операционной системы).

Windows 2000 Server:

Учетная запись | Разрешения
Все | «Полный доступ»

Windows Server 2003:

Учетная запись | Разрешения
Администраторы | «Полный доступ»
Создатель-владелец | Нет
Все | Нет
Система | «Полный доступ»
Пользователи | «Чтение и выполнение», «Список содержимого папки», «Чтение»

Дополнительные сведения

Дополнительные сведения о данной проблеме см. в статье 823022 базы знаний Майкрософт «При подключении почтового ящика или общего хранилища появляются сообщение об ошибке «ID No: c1041724» и сообщение с кодом (ID) 491» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823022).


MSExchangeIS 9518 (0xfffff743): слишком много временных файлов
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-03-14

Средство устранения неполадок с базами данных Microsoft Exchange обнаружило в журнале событий одно или несколько событий MSExchangeIS 9518 с кодом ошибки 0xfffff743. Это означает, что исчерпано пространство имен временных файлов для сервера либо недостаточно свободного места для записи во временную папку.

Объяснение

Серверы Exchange 2000 Server и Exchange Server 2003 создают временные файлы в папке Temp, когда крупный объект, например сообщение или файл, передается потоком в хранилище, а STM-файл слишком фрагментирован для записи объекта целиком.

В нормальном режиме работы при остановке служб Exchange эти файлы удаляются из папки Temp. При непредвиденной остановке сервера Exchange Server или служб Exchange эти файлы не удаляются. При последующем перезапуске служб Exchange создаются новые временные файлы. Это приводит к снижению производительности. При исчерпании пространства имен для 64 000 временных файлов происходит сбой запуска служб Exchange, а в журнале событий приложений оснастки «Просмотр событий» регистрируются события 9518 с кодом ошибки 0xfffff743.

Действия пользователя

Чтобы устранить данную проблему, выполните указанные ниже действия.

  • Проверьте папку Temp системы Windows на наличие файлов lb*.tmp. Если такие файлы существуют, для их удаления выполните указанные ниже действия.

  • Проверьте наличие свободного места на диске, на котором расположена папка Temp. Если на диске недостаточно свободного места, выполните указанные ниже действия для перемещения папок Temp и Tmp на другой диск.

Удаление файлов lb*.tmp из папки Temp системы Windows

  1. Нажмите кнопку Пуск и выберите последовательно пункты Программы, Администрирование и Службы.

  2. Прокрутите список вниз и выберите пункт Служба банка данных Microsoft Exchange.

  3. Если служба находится в состоянии Started, щелкните ее правой кнопкой мыши и выберите команду Стоп
Примечание.
Это приведет к отключению всех пользователей от почтовых ящиков.
  1. Перейдите в папку %windir%\temp, где %windir% — это корневая папка системы Windows (по умолчанию C:\Windows\Temp).

  2. Удалите все файлы lb*.tmp.

  3. В консоли управления Службы щелкните правой кнопкой службу банка данных Microsoft Exchange и выберите команду Пуск.

 Перемещение папок Temp и Tmp на другой диск

  1. На компьютере с сервером Exchange Server нажмите кнопку Пуск, выберите пункт Панель управления и дважды щелкните значок Система.

  2. Откройте вкладку Дополнительно и нажмите кнопку Переменные среды.

  3. В разделе Системные переменные выберите строку, в которой указаны переменная TEMP и диск, нажмите кнопку Изменить и введите новое местоположение диска.

  4. В разделе Системные переменные выберите строку, в которой указаны переменная TMP и диск, нажмите кнопку Изменить и введите новое местоположение диска.
Примечание.
Убедитесь, что изменения применяются к разделу Системные переменные, а не к разделу Переменные среды пользователя.
Примечание.
Если приведенные выше процедуры не помогли устранить проблему, см. статью 307242 базы знаний Майкрософт «Не удается подключить банк данных из-за ошибок 0xfffff745 и -2235» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307242) (на английском языке).

Дополнительные сведения

Дополнительные сведения об этой проблеме см. в следующих статьях базы знаний Майкрософт:

  • 294462, «Файлы Exchange lb*.tmp в папке Temp системы Windows вызывают ошибку ESE -2237» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=294462) (на английском языке)

  • 307242, «Не удается подключить банк данных из-за ошибок 0xfffff745 и -2235» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307242) (на английском языке)


MSExchangeIS 9519 (0xfffffb3a): обнаружено несколько используемых баз данных с одинаковой подписью
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-01-23

Средство устранения неполадок с базами данных Microsoft® Exchange обнаружило в журнале одно или несколько событий MSExchangeIS 9519 с кодом ошибки 0xfffffb3a. Эта ошибка означает, что уже запущена еще одна копия этой же базы данных.

Объяснение

Каждая база данных Exchange имеет уникальную подпись. Если служба банка данных Microsoft Exchange обнаруживает несколько баз данных с одинаковой подписью, эта служба запретит подключение дублирующихся баз данных.

Эта ошибка также может быть обозначена «error -1222, JET_errDatabaseSignInUse».

Действия пользователя

Чтобы убедиться в наличии двух копий одной и той же базы данных в одной группе хранения, выполните следующие действия.

  1. Отключите все прочие базы данных в этой группе хранения и попробуйте подключить базу данных, вызвавшую сообщение об ошибке.

  2. Если эта база данных успешно подключена, затем попытайтесь подключить все остальные базы данных в этой группе хранения.

  3. Если другая база данных в этой группе хранения выдает в журнале такую же ошибку, значит у этих двух баз данных одинаковая подпись, следовательно, они являются копиями одной и той же базы данных.

Для устранения этой проблемы убедитесь, что в данной группе хранения присутствует только одна копия базы данных.


MSExchangeIS 9519 (0xfffffe07): не удается подключить базу данных из-за выполняемой архивации
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-02-27

Средство устранения неполадок с базами данных Microsoft Exchange обнаружило в журнале приложений одно или несколько событий MSExchangeIS 9519 с кодом ошибки 0xfffffe07. Эта ошибка означает, что указанную базу не удалось подключить из-за того, что выполняется процесс архивации.

Объяснение

Эта ошибка может возникнуть, если группа хранения, к которой относится база данных, содержит несколько баз данных (баз данных почтовых ящиков или общих папок), и для одной из них производится резервное копирование в момент, когда пользователь пытается подключить эту базу данных. Такой порядок работы предусмотрен намеренно. Невозможно подключить базу данных из группы хранения, пока выполняется архивация другой базы данных в этой группе.

Эта ошибка также может быть обозначена «error -505, JET_errBackupInProgress».

Действия пользователя

Убедитесь, что архивация других баз данных в этой группе хранения в настоящее время не выполняется, и попытайтесь подключить базу данных. Также можно дождаться завершения архивации другой базы данных в этой группе хранения, затем попытаться подключить базу данных.


MSExchangeIS 9519 (0x3f3): флажок «База данных может быть перезаписана при восстановлении» снят после восстановления
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-01-23

Средство устранения неполадок с базами данных Microsoft® Exchange обнаружило в журнале одно или несколько событий MSExchangeIS 9519 с кодом ошибки 0x3f3. Эта ошибка означает, что восстановление было выполнено для базы данных, для которой не был установлен флажок «База данных может быть перезаписана при восстановлении».

Объяснение

Это событие происходит, когда была выполнено выполнено восстановление базы данных, при этом в свойствах хранилища не был установлен флажок «База данных может быть перезаписана при восстановлении».

Действия пользователя

Для устранения этой проблемы убедитесь, что база данных может быть перезаписана при восстановлении.

В Exchange 2000 Server и Exchange Server 2003 выполните следующие действия.

  1. Запустите диспетчер Exchange.

  2. Раскройте административные группы (если применимо)

  3. Раскройте серверы, <имя сервера>, <группа хранения>, затем выберите базу данных, которая была восстановлена.

  4. Щелкните базу данных правой кнопкой мыши и выберите Свойства.

  5. Перейдите на вкладку База данных.

  6. Установите флажок База данных может быть перезаписана при восстановлении.

  7. Нажмите кнопку ОК.

  8. Для подключения базы данных щелкните ее правой кнопкой мыши и выберите Подключить хранилище.
В Exchange Server 2007 выполните следующие действия.

  1. Запустите консоль управления Exchange.

  2. В поле Конфигурация сервера выберите Почтовый ящик.

  3. В области Управление базой данных щелкните правой кнопкой мыши базу данных, которая была восстановлена.

  4. Выберите Свойства.

  5. Перейдите на вкладку Общие.

  6. Установите флажок База данных может быть перезаписана при восстановлении.

  7. Нажмите кнопку ОК.

  8. Для подключения базы данных щелкните ее правой кнопкой мыши и выберите Подключить базу данных.


MSExchangeIS 9518 (0xfffffc01): неправильный диск или каталог базы данных или журнала транзакций
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-01-23

Средство устранения неполадок с базами данных Microsoft® Exchange обнаружило одно или несколько событий MSExchangeIS 9518 с кодом ошибки 0xfffffc01 в журнале приложений. Это указывает, что для базы данных Exchange или файлов журналов был неправильно установлен путь или буква диска.

Объяснение

Эта ошибка означает, что в пути базы данных или файлов журналов в неисправной группе хранения указана недействительная буква диска или неправильный путь файла. В случае этой ошибки все базы данных в неисправной группе хранения будут недоступны для подключения.

Эта проблема может возникнуть также в том случае, если антивирусная программа блокирует доступ для записи на дисках, которые содержат базу данных Exchange или файлы журналов транзакций.

Это событие может также определяться как ошибка -1023, JET_errInvalidPath.

Действия пользователя

Чтобы решить эту проблему, выполните одно или несколько следующих действий.

  • Чтобы определить, не вызывает ли проблему антивирусная программа, временно отключите ее на консоли Службы. Затем попытайтесь подключить неисправные базы данных. Если базы данных были успешно подключены, обратитесь к поставщику антивирусной программы, чтобы получить последнее обновление ПО.

  • Проверьте и установите правильный путь для системных файлов, базы данных и файлов журналов транзакций для каждой группы хранения и базы данных, вызывающих эту ошибку. Выполните следующие действия.

Проверка и установка правильного пути к файлам в Exchange Server 2003 или Exchange 2000 Server

  1. Запустите Диспетчер Exchange. Щелкните Пуск, укажите Программы, выберите Microsoft Exchange, а затем щелкните Диспетчер.

  2. Если в диспетчере Exchange отображаются административные группы, разверните Административные группы, а затем - административные группы, в которых происходит эта проблема.

  3. Разверните пункт Серверы, а затем - сервер, на котором происходит эта проблема.

  4. Щелкните правой кнопкой группу хранения, содержащую хранилище, которое нужно подключить, а затем щелкните Свойства.

  5. На вкладке Общие проверьте путь, который отображается в поле Местоположение журнала транзакций. Проверьте путь в поле Местоположение системного пути.

    Если эти пути неправильные, обратитесь в службу поддержки Майкрософт для получения справки и разрешения этой проблемы.

  6. Выполните шаги 3-5 для каждой группы хранения, которая может быть представлена для проверки пути базы данных и пути файлов журнала транзакций.

  7. После проверки пути к системным файлам и файлам журнала транзакций для каждой группы хранения, проверьте путь к базе данных для каждого хранилища в каждой группе хранения. Для этого выполните следующие действия.

    1. Разверните группу хранения. Например, разверните основную группу хранения.

    2. Щелкните правой кнопкой StoreName (ServerName) и выберите Свойства.

    3. Перейдите на вкладку Общие и затем проверьте путь, который отображается в поле База данных Exchange. Затем проверьте путь, который отображается в поле Потоковая база данных Exchange.

      Если какой-то путь будет неправильным, обратитесь в службу поддержки Майкрософт для получения справки и разрешения этой проблемы.

    4. Повторите шаги 7b и 7c, чтобы проверить путь для каждого хранилища почтовых ящиков или общих папок, которое будет представлена в каждой группе хранения.

  8. Подключите хранилище почтовых ящиков или хранилище общих папок.

Проверка и установка правильных путей в Exchange Server 2007

  1. Запустите Консоль управления Exchange. Нажмите кнопку Пуск, укажите Программы, выберите Microsoft Exchange, а затем щелкните Консоль управления Exchange.

  2. Разверните пункт Конфигурация сервера и выберите Почтовый ящик.

  3. На панели Управление базой данных выберите группу хранения, содержащую базу данных, которую невозможно подключить.

  4. Щелкните правой кнопкой группу хранения и затем выберите Свойства.

  5. На вкладке Общие проверьте, что путь отображается в местоположениях Путь к журналу и Системный путь.

    Если эти пути неправильные, щелкните правой кнопкой группу хранения и выберите Переместить путь группы хранения. Под элементами Путь к файлам журналов и Путь к системным файлам щелкните Обзор, чтобы перейти к папке, которая содержит файлы журнала транзакций или файлы базы данных. По умолчанию файлы журнала транзакций или файлы базы данных находятся в следующей папке:

    %PROGRAMFILES%\Microsoft\Exchange Server\Mailbox\<имя группы хранения>

  6. Нажмите OK.

  7. Выполните шаги 3-5 для каждой группы хранения, которая может быть представлена для проверки пути к системным файлам и файлам журнала транзакций.

  8. После проверки пути к системным файлам и файлам журнала транзакций для каждой группы хранения проверьте путь к базе данных для каждой базы данных в каждой группе хранения. Для этого выполните следующие действия.

    1. Разверните группу хранения. Например, разверните основную группу хранения.

    2. Проверьте путь, который отображается под элементом Путь к файлам базы данных на панели Управление базой данных

    3. Если какой-то путь неправильный, щелкните правой кнопкой базу данных и выберите Переместить путь базы данных.

    4. Щелкните Обзор, чтобы выбрать правильную папку для файлов базы данных. По умолчанию файлы базы данных Exchange (EDB) находятся в следующей папке:

      %PROGRAMFILES%\Microsoft\Exchange Server\Mailbox\<storage group name>\<имя базы данных.edb>

    5. Нажмите OK.

    6. Повторите шаги 8b и 8e, чтобы проверить путь для каждой базы данных почтовых ящиков или общей папки, которая будет представлена в каждой группе хранения.

  9. Подключите базу данных почтовых ящиков или базу данных общей папки.


MSExchangeIS 9519 (0xfffffbda): отсутствует язык набора двухбайтовых знаков, установленный как язык системы по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-01-23

Средство устранения неполадок базы данных Microsoft® Exchange обнаружило одно или несколько событий MSExchangeIS 9519 с кодом ошибки 0xfffffbda в журнале приложений. Это событие указывает, что по умолчанию установлен язык системы, отличный от английского. После установки Exchange Server язык системы по умолчанию был удален.

Объяснение

Если при перезапуске сервера Exchange Server возникает событие MSExchangeIS 9519 с кодом ошибки 0xfffffbda, база данных Exchange не будет установлена. Кроме того, события ошибки ESE 604 и MSExchangeIS 9519 записываются в журнал событий приложений.

Такое поведение может происходить в том случае, если ранее по умолчанию был установлен язык системы, отличный от английского. При возникновении такого события, если был выбран другой язык системы по умолчанию, удалите не английский язык и затем перезагрузите Exchange 2000 Server или Exchange Server 2003.

Это событие может также определяться как -1062, JET_errInvalidLanguageId. Это событие применимо к следующим версиям сервера Exchange Server:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Действия пользователя

Чтобы разрешить эту проблему, переустановите не английский язык или создайте новую базу данных. Если переустановлен не английский язык, его нельзя назначить в качестве языка системы по умолчанию.


MSExchangeIS 9519 (0xfffff05b): база данных или журналы сжаты на сервере с Exchange Server 2000 с пакетом обновления 3 (SP3) или более поздней версии
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-02-19

Средство устранения неполадок с базами данных Microsoft Exchange обнаружило в журнале приложений одно или несколько событий MSExchangeIS 9519 с кодом ошибки 0xfffff05b. Эта ошибка указывает, что база данных Exchange или журнал транзакций находятся на диске, где включено сжатие файловой системы.

Объяснение

Эта ошибка может возникнуть при установке пакета обновления 3 (SP3) для Exchange 2000 Server на сервер, база данных которого сжата при помощи файловой системы NTFS. Эта проблема также может возникнуть при обновлении сервера Exchange 2000 Server до Exchange Server 2003. Серверы Exchange 2000 Server с пакетом обновления 3, Exchange Server 2003 и Exchange Server 2007 не допускают подключения сжатых баз банка данных.

Эта ошибка также может быть идентифицирована как «-4005, JET_errFileCompressed». Ошибка применяется к следующим версиям сервера Exchange Server:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server с пакетом обновления 3 (SP3)

Действия пользователя

Для устранения проблемы следует отключить сжатие папок, в которых находятся базы данных и журналы, дефрагментировать базу данных, а затем выполнить сетевую архивацию (с учетом работы Exchange) групп хранения банка данных, где хранятся базы данных и журналы. См. статью 327772 базы знаний Майкрософт После установки пакета обновления 3 (SP3) для Exchange 2000 не подключается база данных и выводится сообщение об ошибке 0xfffff05b (на английском языке).


MSExchangeIS 9519 (0xfffffa84): отсутствуют или повреждены индексы баз данных
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-01-22

Средство устранения неполадок базы данных Microsoft® Exchange обнаружило в журнале приложений одно или несколько событий с кодом ошибки 0xfffffa84. Это событие указывает, что индексы для этой базы данных повреждены или отсутствуют.

Объяснение

Ниже указаны возможные причины повреждения или отсутствия индекса базы данных.

  • Это может произойти во время очистки индекса базы данных Exchange после установки нового пакета обновления Microsoft Windows. После установки пакета обновления невозможно подключить базы данных почтовых ящиков или общих папоку на сервере Exchange. Кроме того, в журнале событий приложений регистрируются события ESE 609 и ESE 611.

  • Это может произойти после запуска операции восстановления базы данных (eseutil /p). При этом может быть удален индекс, созданный при первом создании базы данных. Выполнение команды восстановления Eseutil удаляет этот индекс.

Эта ошибка также может определяться как -1404, JET_errIndexNotFound. Эта ошибка применима к следующим версиям сервера Exchange Server:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Действия пользователя

Чтобы устранить эту проблему, следуйте решениям, которые предлагаются в ранее описанных сценариях неполадок.

  • Если индекс был поврежден во время очистки индекса базы данных Exchange после установки нового пакета обновления Microsoft Windows, выполните следующие действия.

    1. Восстановите поврежденную базу данных почтовых ящиков или общих папок из исправной резервной копии.

    2. Выполните в автономном режиме дефрагментацию неисправной базы данных, применив команду eseutil /d. Сведения о порядке дефрагментации неисправной базы данных в автономном режиме см. в следующих разделах:

      Базы данных Exchange 2000 Server и Exchange Server 2003: инструкции по запуску Eseutil /D (дефрагментация)

      Базы данных Exchange Server 2007: инструкции по запуску Eseutil /D (дефрагментация)

  • Если индекс отсутствует после операции по восстановлению базы данных (eseutil /p), установите исправление, описанное в статье 924627 базы знаний Майкрософт Event ID 9519 that includes error 0xfffffa84 is logged when you try to mount a database after you use the Eseutil and Isinteg utilities to recover the database in Exchange 2003 (При попытке установить базу данных после применения служебных программ Eseutil и Isinteg для восстановления базы данных в Exchange 2003 в журнале регистрируется событие 9519, которое включает ошибку 0xfffffa84).


MSExchangeIS 9519 0x972: удален контейнер общих папок или отсутствуют обязательные атрибуты
Анализатор сервера Microsoft Exchange — статьи > Восстановление базы данных >

Дата последнего изменения раздела: 2007-08-30

Средство устранения неполадок с базами данных Microsoft Exchange обнаружило в журнале приложений одно или несколько событий MSExchangeIS 9519 с кодом ошибки 0x972. Это свидетельствует о том, что при подключении баз данных общих папок произошел сбой из-за того, что контейнер общих папок был удален или отсутствуют его необходимые атрибуты.

Объяснение

Данная ошибка может возникнуть, если контейнер общих папок был удален из Active Directory или если соответствующее общее хранилище не настроено для использования контейнера общих папок, то есть значение атрибута msExchOwningPFTreeBL контейнеров общих папок не указывает на общее хранилище. Причина этой ошибки чаще всего заключается в том, что административная группа, содержащая контейнер общих папок, была удалена без предварительного перемещения контейнера общих папок в новую административную группу.

Действия пользователя

Чтобы устранить данную проблему, определите с помощью редактора ADSI Edit или подобного средства, существует ли контейнер общих папок и указывает ли атрибут msExchOwningPFTreeBL на соответствующее общее хранилище.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью редактора ADSI, средства LDP или другого клиента LDAP версии 3 может привести к серьезным неполадкам. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, а также сервера Exchange Server 2003 или Exchange Server 2007 либо обоих продуктов. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Определение причины ошибки

  1. С помощью редактора ADSI или подобного средства найдите каждый объект административной группы в Active Directory.

    Объект административной группы можно найти в следующем месте:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group

  2. Разверните каждую административную группу и проверьте, существует ли контейнер CN=Folder Hierarchies. Если этот контейнер существует, выделите его и убедитесь в том, что на правой панели доступен объект CN=Public Folders. Если ни в какой административной группе нет объекта CN=Public Folders, воспользуйтесь описанным ниже решением 1. Если контейнер CN=Public Folders удалось найти, перейдите к этапу 3.

  3. Щелкните правой кнопкой мыши объект CN=Public Folders и выберите пункт Свойства.

  4. В списке Атрибуты выберите атрибут msExchOwningPFTreeBL и нажмите кнопку Изменить.

  5. Убедитесь в том, что в списке Значения содержится соответствующее хранилище общих папок. Если его там нет, воспользуйтесь описанным ниже решением 2.
Решение 1. Воссоздание иерархий папок и контейнеров общих папок

  1. Используя редактор ADSI или подобное средство, найдите и разверните объект Административная группа Exchange (FYDIBOHF23SPDLT).

    Найти этот объект можно в следующем месте:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups

  2. Щелкните правой кнопкой мыши объект Административная группа Exchange (FYDIBOHF23SPDLT) и выберите пункт Создать, а затем — Объект.

  3. В списке Выберите класс выберите элемент msExchPublicFolderTreeContainer и нажмите кнопку Далее.

  4. В поле Значение введите Folder Hierarchies и нажмите кнопку Далее, а затем — кнопку Готово.

  5. Щелкните правой кнопкой мыши созданный объект Folder Hierarchies и выберите пункт Создать, а затем — пункт Объект.

  6. В списке Выберите класс выберите элемент msExchPFTree и нажмите кнопку Далее.

  7. В поле Значение введите Public Folders и нажмите кнопку Далее.

  8. Нажмите кнопку Другие атрибуты.

  9. В раскрывающемся списке Выберите свойство для просмотра выберите элемент msExchPFTree.

  10. В поле Изменить атрибут введите значение 1 и нажмите последовательно кнопки Задать, ОК и Готово.

  11. Чтобы назначить контейнер общих папок каждому общему хранилищу, щелкните правой кнопкой мыши контейнер Public Folders и выберите пункт Свойства.

  12. В списке Атрибуты выберите атрибут distinguishedName и нажмите кнопку Изменить.

  13. Скопируйте содержимое поля Значение в буфер обмена и нажмите кнопку Отмена.

  14. На каждом сервере, на котором регистрируется событие MSExchangeIS 9519 с кодом ошибки 0x972, найдите объект хранилища общих папок. По умолчанию он находится в следующем месте:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups, CN=Exchange Administrative Group (FYDIBOHF23SPDLT), CN=Servers, CN= имя_сервера , CN= банк_данных , CN=Second Storage Group.

  15. Щелкните правой кнопкой мыши объект хранилища общих папок и выберите пункт Свойства.

  16. В списке Атрибуты выберите атрибут msExchOwningPFTree и нажмите кнопку Изменить.

  17. Вставьте значение, скопированное в буфер обмена при выполнении действия 13, в поле Значение и дважды нажмите кнопку ОК.

  18. Повторите действия 15 — 17 для каждого сервера, на котором было зарегистрировано событие MSExchangeIS 9519 с кодом ошибки 0x972.

  19. Перезапустите службу банка данных Microsoft Exchange на соответствующих серверах.

Решение 2. Повторное задание значения атрибута msExchOwningPFTreeBL для объекта контейнера общих папок

  1. С помощью редактора ADSI или подобного средства найдите в Active Directory объект Public Folders.

    Его можно найти в следующем месте:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Folder Hierarchies,CN=Public Folders

  2. Щелкните правой кнопкой мыши контейнер Public Folders и выберите пункт Свойства.

  3. В списке Атрибуты выберите атрибут distinguishedName и нажмите кнопку Изменить.

  4. Скопируйте содержимое поля Значение в буфер обмена и нажмите кнопку Отмена.

  5. На каждом сервере, на котором регистрируется событие MSExchangeIS 9519 с кодом ошибки 0x972, найдите объект хранилища общих папок. По умолчанию он находится в следующем месте:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups, CN=Exchange Administrative Group (FYDIBOHF23SPDLT), CN=Servers, CN= имя_сервера , CN= банк_данных , CN=Second Storage Group.

  6. Щелкните правой кнопкой мыши объект хранилища общих папок и выберите пункт Свойства.

  7. В списке Атрибуты выберите атрибут msExchOwningPFTree и нажмите кнопку Изменить.

  8. Вставьте значение, скопированное в буфер обмена при выполнении действия 4, в поле Значение и дважды нажмите кнопку ОК.

  9. Повторите действия 6 — 8 для каждого сервера, на котором было зарегистрировано событие MSExchangeIS 9519 с кодом ошибки 0x972.

  10. Перезапустите службу банка данных Microsoft Exchange на соответствующих серверах.


Кластер Exchange
Анализатор сервера Microsoft Exchange — статьи >

Дата последнего изменения раздела: 2005-11-18

Статьи в этой части содержат сведения о параметрах, оцениваемых средством анализатора сервера Microsoft® Exchange для кластеров Exchange. Кроме того, в этих статьях описываются действия, которые можно предпринять, чтобы устранить проблемы, касающиеся кластеров Exchange и обнаруживаемые анализатором сервера Exchange, такие как ошибки, предупреждения и конфигурации, отличные от конфигураций по умолчанию.


Отладка кластера включена
Анализатор сервера Microsoft Exchange — статьи > Кластер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра, чтобы определить, существует ли запись реестра :

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Cluster\Debug

Если средство анализатора сервера Exchange обнаруживает, что значение Debug равно 1, средство анализатора сервера Exchange отображает предупреждение.

Отладка кластера с использованием значения реестра предупреждает возможность сбоя ресурсов кластера между узлами. Следует использовать это значение реестра только при выполнении отладки при возникновении проблемы, требующей обеспечения защиты ресурсов от сбоя.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы отключить раздел реестра отладки кластера

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\Software\Microsoft\Exchange\Cluster.

  3. Измените значение Debug на 0.

  4. Закройте редактор реестра.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Для получения дополнительных сведений о кластерах Exchange см. раздел «Управление кластерами Exchange в Exchange Server 2003» в руководстве по администрированию Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).


Неправильно настроен выделенный сетевой приоритет пульса кластера
Анализатор сервера Microsoft Exchange — статьи > Кластер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить порядок приоритетов каждого сетевого интерфейса в кластере сервера Exchange:

HKEY_LOCAL_MACHINE\Cluster\Networks\<NetworkInterfaceGUID>\Priority

Значение записи «Priority» показывает сетевой приоритет, настроенный для ресурсов сетевого интерфейса. Ресурс сетевого интерфейса с максимальным приоритетом обладает значением 1, следующим по приоритету является интерфейс со значением 2 и т. д.

Анализатор сервера Exchange также считывает следующую запись реестра, чтобы определить роль для каждой сети в кластере сервера Exchange:

HKLM\Cluster\Networks\<NetworkInterfaceGUID>\Role

Значение 1 показывает, что сетевой ресурс был настроен как выделенная частная сеть (пульс). Значение 2 показывает, что сетевой интерфейс был настроен как выделенная общедоступная сеть (клиентский доступ). Значение 3 показывает, что сетевой ресурс был настроен как смешанная сеть, в которой разрешен как трафик пульса, так и трафик клиентского доступа.

Если анализатор сервера Exchange определяет, что ресурс сетевого интерфейса со значением «Role», равным 1, обладает значением «Priority», равным 1, выводится предупреждение. Это предупреждение показывает, что обнаружена выделенная сеть пульса, но ее сетевой приоритет установлен неправильно.

Рекомендуемыми действиями для всех кластеров сервера Exchange является настройка выделенной частной сети для передачи сигналов пульса кластера. Связь между узлами критична для бесперебойной работы кластера. Для правильной настройки сетевого приоритета выделенной сети пульса воспользуйтесь следующими инструкциями.

Устранение причины появления этого предупреждения

  1. Откройте средство «Администратор кластера» и подключитесь к кластеру сервера Exchange.

  2. В левой области щелкните правой кнопкой объект Кластер вверху иерархии и выберете команду Свойства.

  3. Щелкните Приоритет сети.

  4. Выберите ресурс выделенной сети пульса.

  5. Щелкайте Вверх, пока ресурс выделенной сети пульса не окажется вверху списка сетевых ресурсов.

  6. Нажмите кнопку ОК.

Дополнительные сведения о сетях пульса кластеров см. в следующих статьях базы знаний Майкрософт:

  • 258750, посвященная рекомендуемой настройке частной сети пульса для кластерного сервера по адресу, http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750 (возможно, на английском языке)

  • 307962, посвященная поддержке групповой передачи для пульса кластера, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=307962 (возможно, на английском языке)

Дополнительные подробности см. в контрольном списке конфигурации кластера Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?linkid=36083 (возможно, на английском языке).


Версия Windows для узлов кластера не соответствует первому узлу
Анализатор сервера Microsoft Exchange — статьи > Кластер Exchange >

Дата последнего изменения раздела: 2005-11-18

Для определения базовой версии операционной системы Microsoft Windows® в каждом узле кластера средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Cluster\Nodes\ <Номер_узла> \BuildNumber

Если анализатор сервера Exchange обнаруживает, что значение BuildNumber во втором или следующем узле кластера отличается от значения BuildNumber в первом узле кластера Exchange, на экран выводится сообщение об ошибке.

Если в кластере Exchange работают разные версии Windows, переход на другой ресурс может отличаться от ожидаемого или настроенного. В смешанной среде с устаревшими системами Windows переход на другой ресурс возможен только с более ранней операционной системы на более позднюю (например, с Windows 2000 Advanced Server на Windows Server™ 2003 Enterprise Edition). Переход же с более поздней операционной системы на более раннюю (например, с Windows Server 2003 на Windows 2000 Server) невозможен.

Для решения этой проблемы следует обновить все узлы путем установки одних и тех же операционной системы и пакета обновления. Для минимизации простоев можно выполнить чередующееся обновление кластера.

Чтобы устранить эту ошибку

  1. Ознакомьтесь с указаниями по выполнению чередующегося обновления кластера в статье 811272 базы знаний Майкрософт «How to Perform a Rolling Upgrade of Windows Server 2003 Server Clusters» (Выполнение чередующегося обновления кластеров сервера Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=811272).

  2. Ознакомьтесь со статьей «Windows 2000 Clustering: Performing a Rolling Upgrade» (Кластеризация Windows 2000. Выполнение чередующегося обновления) (http://go.microsoft.com/fwlink/?linkid=1718).

  3. Выполните чередующееся обновление каждого узла, значение BuildNumber которого отличается от значения для первого узла в кластере.

Дополнительные сведения об альтернативных процедурах см. в статье «Alternatives to rolling upgrades» (Альтернативы чередующемуся обновлению) (http://go.microsoft.com/fwlink/?LinkId=41363).


Версия пакета обновления Windows для узлов кластера не соответствует первому узлу
Анализатор сервера Microsoft Exchange — статьи > Кластер Exchange >

Дата последнего изменения раздела: 2005-11-18

Для определения, установлена ли данная версия пакета обновления Microsoft Windows® в каждом узле кластера, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Cluster\Nodes\<Node Number>\CSDVersion

Если анализатор сервера Exchange обнаруживает, что значение для CSDVersion во втором или следующем узле кластера отличается от значения для CSDVersion в первом узле кластера Exchange, на экран выводится сообщение об ошибке.

Это сообщение об ошибке показывает, что в узлах данного кластера Exchange пакет обновления Windows работает не на одном и том же уровне. В качестве лучшего решения рекомендуется, чтобы во всех узлах кластера Exchange работали операционная система и пакет обновления одного и того же уровня.

Для решения этой проблемы следует обновить все узлы путем установки одних и тех же операционной системы и пакета обновления. Для минимизации простоев можно выполнить откат обновления кластера.

Чтобы устранить причину появления этого предупреждения

  1. Ознакомьтесь с указаниями по выполнению отката обновления кластера, прочитав в базе знаний Майкрософт статью 811272 "How to Perform a Rolling Upgrade of Windows Server 2003 Server Clusters" (Как выполнять откат обновления кластеров сервера Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=811272).

  2. Ознакомьтесь со статьей "Windows 2000 Clustering: Performing a Rolling Upgrade" (Кластеризация Windows 2000: Выполнение отката обновления) (http://go.microsoft.com/fwlink/?linkid=34288).

  3. Выполнение отката обновления каждого узла, значение которого CSDVersion отличается от значения первого узла в кластере.

Дополнительные сведения об альтернативных процедурах см. в разделе "Alternatives to rolling upgrades" (Альтернативы откатам обновлений) ресурса (http://go.microsoft.com/fwlink/?LinkId=63014).


Путь кластера TEMP/TMP находится на диске с системным разделом
Анализатор сервера Microsoft Exchange — статьи > Кластер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить на компьютере некластерного сервера Exchange значения переменных окружения TEMP и TMP, анализатор сервера Microsoft® Exchange считывает следующие записи реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

HKLM\System\CurrentControlSet\Control\Session Manager\Environment\TMP

Если анализатор сервера Exchange выполняется для анализа виртуального сервера Exchange в кластере серверов Microsoft Windows®, он не считывает ветвь реестра HKLM. Вместо этого он считывает следующие записи реестра:

HKEY_USERS \<Cluster service account SID> \Environment\TEMP

HKEY_USERS \<Cluster service account SID> \Environment\TMP

Если анализатор сервера Exchange обнаруживает, что значение переменной среды TEMP или TMP начинается с %SYSTEMROOT, выводится предупреждение.

Служебный процесс банка данных Microsoft Exchange использует папки TEMP и TMP в качестве временного хранилища при выполнении различных операций, таких как преобразование сообщений и перемещение почтовых ящиков. На некластерном сервере Exchange служба банка данных Microsoft Exchange использует переменную SYSTEM (например, Local System), которая, в свою очередь, использует заданный по умолчанию параметр переменной среды %Systemroot%\Temp как для TEMP, так и для TMP.

Виртуальные серверы Exchange, работающие в кластере серверов Windows, используют параметры переменных среды для учетной записи службы кластеров, которая выполняется в контексте принципа безопасности конкретного пользователя. Для учетных записей пользователей переменная среды для TEMP и TMP по умолчанию устанавливается равной %Userprofile%\temp.

Переменные среды TEMP и TMP применяются, чтобы указать, какие папки в файловой системе (какой путь) должны использоваться приложениями, которым требуется наличие временного рабочего пространства. Переменная TEMP обычно используется приложениями, такими как Microsoft Exchange, а переменная TMP обычно используется средствами разработки, такими как Microsoft Visual C++®. Путь для каждой переменной обычно указывается относительно контекста безопасности приложения или средства.

Для обеспечения оптимальной производительности не рекомендуется размещать папки TEMP и TMP, используемых приложением Exchange, на диске, содержащем операционную систему. Кроме того, следует убедиться, что для этих переменных среды заданы пути к быстрому диску или скоростной дисковой подсистеме, например к массиву дисков RAID 0+1. Также не рекомендуется размещать на диске операционной системы папки TEMP и TMP, используемые Exchange или виртуальными серверами Exchange.

Чтобы устранить причину появления этого предупреждения

  1. Войдите на узел кластера с учетной записью службы кластеров.

  2. Щелкните правой кнопкой мыши Мой компьютер и выберите команду Свойства.

  3. Щелкните Дополнительно.

  4. Щелкните Переменные среды.

  5. В области Пользовательские переменные для <имя учетной записи> выберите TEMP и нажмите кнопку Изменить.

  6. В поле Значение переменной введите новый путь для переменной среды TEMP и нажмите кнопку ОК.

  7. В области Пользовательские переменные для <имя учетной записи> выберите TMP и нажмите кнопку Изменить.

  8. В поле Значение переменной введите новый путь для переменной среды TMP и нажмите кнопку ОК.

  9. Нажмите кнопку ОК, чтобы закрыть диалоговое окно Переменные среды, а затем нажмите кнопку ОК еще раз, чтобы закрыть диалоговое окно Свойства системы.

  10. Перезагрузите узел, чтобы применить изменение.

  11. Повторите шаги с 1 по 10 для каждого узла в кластере.

Сведения об изменении переменных среды на некластерном сервере Exchange см. в разделе По-видимому, переменная TEMP/TMP указывает на недопустимую или неподходящую папку.


Пульс выделенного кластера не найден
Анализатор сервера Microsoft Exchange — статьи > Кластер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить роль для каждого ресурса сетевого интерфейса в кластере сервера Exchange:

HKEY_LOCAL_MACHINE\Cluster\Networks\<NetworkInterfaceGUID>\Role

Если задано значение 1, значит сетевой ресурс был настроен как выделенная частная сеть (пульс). Если задано значение 2, сетевой ресурс был настроен как выделенная общая сеть (клиентский доступ). Если задано значение 3, значит сетевой ресурс был настроен как смешанная сеть, позволяющая трафик пульса и трафик клиентского доступа.

Средство анализатора сервера Exchange запрашивает класс Win32_Service Microsoft Windows® Management Instrumentation (WMI), чтобы определить значение раздела «Started» для службы кластеров (ClusSvc). Если задано значение True, это значит, что служба кластера запущена, а значение «False» указывает на то, что служба кластера не запущена.

Если средство анализатора сервера Exchange не обнаруживает в кластере Exchange сетевой ресурс, настроенный как выделенная частная сеть, отображается предупреждение.

Рекомендуется настраивать выделенную частную сеть для использования для пульса кластера всех кластеров сервера Exchange. Связь между узлами имеет важное значение для успешного выполнения операций кластера. Необходимо настроить сети, которые используются для обеспечения оптимального взаимодействия в кластере, и выполнить все требования, указанные в списке совместимости оборудования. Для создания конфигурации сети необходимо соединить узлы кластера с помощью двух или более независимых сетей, чтобы избежать наличия подверженных сбоям непродублированных элементов. Обычно используются две локальные сети LAN. Службы поддержки продуктов Майкрософт не поддерживают конфигурацию кластера, в которой узлы соединены только одной сетью.

Чтобы устранить причину появления этого предупреждения

  1. Добавьте несколько сетевых плат к каждому узлу в кластере Exchange, если они не были добавлены ранее, и настройте сетевые платы как частные сети в администраторе кластера.

  2. Если дополнительные сетевые платы существуют, но используются для смешанных сетей, необходимо изменить настройку, повторно настроив соответствующие сети для работы в качестве выделенных частных сетей.

Дополнительные сведения о сетях кластерного пульса см. в следующих статьях базы знаний Майкрософт:

  • инструкции из части 258750 по настройке частной сети пульса для кластерного сервера (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)

  • инструкции из части 307962 по включению групповой поддержки для пульса кластера (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307962)

Для получения дополнительных сведений см. документ Контрольный список конфигурации кластера для Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=36083).


По умолчанию размер файла cluster.log должен увеличиваться до 32
Анализатор сервера Microsoft Exchange — статьи > Кластер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, настроен ли параметр ClusterLogSize, средство анализатора приложения Microsoft® Exchange Server считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment\

Если анализатор сервера Exchange обнаруживает, что значение для ClusterLogSize отсутствует или значение ClusterLogSize не больше 8, на экран выводится предупреждение. В занятом кластере файл осуществляет циклический переход так быстро, что могут быть потеряны записи при устранении неполадок в ситуациях перемещения при следующих условиях:

  • Устранение неполадок требует подробного анализа файла журнала кластера.

  • Кластер управляет несколькими ресурсами.

Следовательно, устранение неполадок требует использования файла журнала кластера, создания параметра ClusterLogSize, если он еще отсутствует, и увеличения размера по умолчанию по меньшей мере до размера 32, 64 или 96.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» в Regedit.exe или Regedt32.exe.
Чтобы создать параметр ClusterLogSize и установить его значение

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment.

  3. В левой области щелкните Среда.

  4. В меню Правка укажите пункт Создать, а затем щелкните Значение DWORD.

  5. Введите ClusterLogSize и затем нажмите ENTER, чтобы присвоить имя новой записи реестра.

  6. Щелкните правой кнопкой мыши ClusterLogSize и затем щелкните Изменить.

  7. Измените ClusterLogSize Значение на новый размер файла журнала. Например, измените значение ClusterLogSize на 32, 64 или 96 и затем нажмите ENTER.

  8. Закройте редактор реестра.
Чтобы изменить размер файла cluster.log по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment.

  3. Щелкните правой кнопкой мыши ClusterLogSize и затем щелкните Изменить.

  4. Измените ClusterLogSize Значение на новый размер файла журнала. Например, измените значение ClusterLogSize на 32, 64 или 96 и затем нажмите ENTER.

  5. Закройте редактор реестра.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986 "Description of the Microsoft Windows registry" (Описание реестра Microsoft Windows) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о ведении журнала кластера в Microsoft Cluster Server см. в базе знаний Майкрософт в статье 168801 "How to Turn on Cluster Logging in Microsoft Cluster Server" (Инструкции по включению ведения журнала кластера в Microsoft Cluster Server) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=168801)


Включение для SMTP проверки подлинности по протоколу Kerberos
Анализатор сервера Microsoft Exchange — статьи > Кластер Exchange >

Дата последнего изменения раздела: 2006-05-12

Средство анализатора сервера Microsoft® Exchange запрашивает службу Active Directory®, чтобы определить, имеет ли сервер Microsoft Exchange Server 2003, установленный в службе кластеров Windows™ Server 2003, полное доменное имя сервера в качестве значения ресурса SMTPSVC в атрибуте servicePrincipalName.

Если анализатор сервера Exchange обнаружит, что атрибут servicePrincipalName ресурса SMTPSVC приложения Exchange в службе кластеров не содержит полного доменного имени сервера в качестве значения, анализатор сервера Exchange выведет сообщение с рекомендациями.

Рекомендуется включить проверку подлинности по протоколу Kerberos для служб SMTP (Simple Mail Transfer Protocol) на серверах кластера Windows Server 2003, на которых выполняется Exchange Server 2003. Проверку подлинности по протоколу Kerberos можно включить, установив вручную новое значение имени участника службы (Service Principal Name, SPN) для ресурса SMTPSVC приложения Exchange.

По умолчанию операционная система Windows Server 2003 использует проверку подлинности по протоколу NTLM. Протокол Kerberos отличается большей гибкостью и эффективностью, чем NTLM, и к тому же более защищенный. При использовании протокола Kerberos достигаются следующие преимущества:

  • Более скоростные подключения. При использовании проверки подлинности по протоколу NTLM сервер приложений должен подключиться к контроллеру домена, чтобы проверить подлинность каждого клиента. При использовании проверки подлинности по протоколу Kerberos серверу не надо искать контроллер домена. Сервер может проверить подлинность клиента путем анализа учетных данных, предоставляемых клиентом. Клиенты могут получить учетные данные для конкретного сервера один раз и повторно использовать их в сеансе входа в сеть.

  • Взаимная проверка подлинности. Протокол NTLM предоставляет серверам возможность проверки удостоверений своих клиентов. Протокол NTLM не предоставляет клиентам возможности проверки удостоверения сервера, и не предусматривает проверку одним сервером удостоверения другого сервера. Проверка подлинности по протоколу NTLM была разработана для сетевой среды, в которой предполагалось, что серверы не могут быть поддельными. В протоколе Kerberos отсутствует подобное допущение. Участники на обоих концах сетевого соединения могут убедиться в том, что сторона на другом конце является именно тем субъектом, за которого она себя выдает.

  • Делегированная проверка подлинности. Службы Windows имитируют клиентов, когда получают доступ к ресурсам от имени клиентов. Часто служба может выполнить работу за клиента, обратившись к ресурсам на локальном компьютере. Оба протокола NTLM и Kerberos предоставляют сведения, которые необходимо иметь службе, чтобы играть роль своего клиента в локальном масштабе. Однако некоторые распределенные приложения разработаны таким образом, что интерфейсная служба должна имитировать клиентов при подключении к прикладным службам на других компьютерах. В протоколе Kerberos имеется механизм прокси-сервера, который позволяет службе имитировать своих клиентов при подключении к другим службам. В протоколе NTLM отсутствует эквивалент такого механизма.

Чтобы устранить эту проблему, выполните приводимые шаги, чтобы добавить отсутствующие значений для задействованных атрибутов.

Использование средства SETSPN.exe для добавления имени участника службы (SPN) с отсутствующими значениями

  1. Установите программное средство Setspn.exe. Сведения о получении программного средства Setspn.exe см. в разделе, посвященном средству из набора ресурсов Windows 2000: Setspn.exe (http://go.microsoft.com/fwlink/?LinkId=28103).

    Версия программного средства командной строки, Setspn.exe, для Windows Server 2003 доступна в средствах поддержки Windows Server 2003, поставляемых на компакт-диске Windows Server 2003. Чтобы установить средства поддержки Server 2003, дважды щелкните файл Suptools.msi в папке «Support/Tools».

  2. Следуйте инструкциям, приведенным в фале Setspn_d.txt средства SETSPN.EXE, чтобы добавить отсутствующее значение в объект Active Directory для своего сервера Exchange. В следующем примере показано, как добавить значение полного доменного имени для имени участника службы (SPN) виртуального SMTP-сервера:

    • Откройте окно командной строки, а затем укажите каталог, в котором установлено программное средство Setspn.exe.

    • В командной строке введите следующую команду:

      setspn.exe-a SMTPSVC/ mail.yourdomain.com ИМЯ_ИСПОЛЬЗУЕМОГО_СЕРВЕРА

      Примечание.
      Замените mail.yourdomain.com полным доменным именем виртуального SMTP-сервера, а ИМЯ_ИСПОЛЬЗУЕМОГО_СЕРВЕРА замените именем сервера Exchange.
    • Нажмите клавишу ВВОД.


Нет контакта с узлом кластера Exchange
Анализатор сервера Microsoft Exchange — статьи > Кластер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server запрашивает класс Win32_Service инструментария Microsoft Windows® Management (WMI), чтобы определить значение параметра Started для службы кластера (ClusSvc). Значение True показывает, что служба кластера запущена, значение False — что служба кластера не запущена.

Кроме того, средство анализа Exchange Server считывает следующий параметр реестра, чтобы определить, какая версия Windows установлена на компьютере сервера Exchange:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Если значение CurrentVersion равно 4.0, это означает, что установлена система Microsoft Windows NT® Server 4.0. Значение 5.0 означает, что на компьютере установлена система Windows 2000 Server, значение 5.2 — Windows Server™ 2003.

Если средство анализа Exchange Server не может определить версию Windows, работающую на кластере, или если он не может определить, работает ли кластер, отображается сообщение об ошибке. Это сообщение свидетельствует о том, что средству анализа Exchange Server не удалось связаться с узлом кластера сервера Exchange.

Устранение ошибки

  1. Убедитесь в том, что компьютер сервера Exchange запущен и подключен к сети.

  2. Воспользуйтесь командой PING, чтобы определить, доступен ли компьютер сервера Exchange.

  3. Если используется брандмауэр, проверьте, не заблокированы ли порты удаленного вызова процедур (RPC).

  4. Убедитесь в том, что на компьютере Exchange Server запущена служба удаленного реестра.

  5. Проверьте разрешения учетной записи, под которой работает средство анализа Exchange Server, убедитесь в том, что они достаточны для считывания реестра компьютера Exchange Server.

Для получения дополнительных сведений об устранении неполадок, связанных с сетевыми подключениями, см. статью 325487 базы знаний корпорации Майкрософт «Разрешение проблем, связанных с выполнением сетевого подключения« (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).


Путь к данным Exchange в Active Directory не соответствует реестру кластера
Анализатор сервера Microsoft Exchange — статьи > Кластер Exchange >

Дата последнего изменения раздела: 2006-04-28

Средство анализатора сервера Microsoft® Exchange опрашивает реестр кластера (HKEY_LOCAL_MACHINE\Cluster) и службу каталогов Active Directory®, чтобы определить, одинаковы ли в обоих местах пути к файлам данных Exchange (например, к файлам журнала трассировки сообщений). Exchange Server настраивает эти значения в реестре и службе каталогов Active Directory при установке Exchange на узле кластера серверов Microsoft Windows®.

Значение реестра, которое создается программой установки Exchange и считывается анализатором сервера Exchange:

HKLM\Cluster\Resources\<GUID ресурса банка данных>\Parameters\DestPath

Значение службы каталогов Active Directory, которое создается программой установки Exchange и считывается анализатором сервера Exchange: msExchDataPath. Это значение является атрибутом объекта компьютера сервера Exchange в Active Directory, имеющим следующее расположение:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN= имя_организации =Administrative Groups, CN= имя_административной_группы , CN=Servers, CN= имя_сервера

Если анализатор сервера Exchange обнаруживает, что значения параметров DestPath и msExchDataPath не соответствуют друг другу, отображается сообщение об ошибке.

Обычной причиной различия этих значений является изменение местоположения некоторых или всех файлов Exchange после производственного использования Exchange. Например, если обновлено оборудование, перемещены файлы журналов трассировки сообщений и изменена буква диска, изменения отражаются в реестре кластера, но не в службе каталогов Active Directory. Послы подобных изменений могут возникнуть ошибки запуска службы, неполадки с подключением базы данных и другие проблемы, особенно при применении пакета обновления Exchange или установке набора исправлений.

Примечание.
Следует как можно быстрее устранить эту проблему. Не устанавливайте пакеты обновления для Exchange Server до решения этой проблемы.

Чтобы выполнить следующую процедуру, необходимо использовать редактор службы каталогов Active Directory, например оснастку Edit интерфейса ADSI или средство LDP (ldp.exe).

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью ADSI Edit, средства LDP или другого LDAP-клиента версии 3 может привести к возникновению серьезных неполадок. Для устранения этих неполадок может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы устранить эту ошибку

  1. Измените значение msExchDataPath для необходимого виртуального сервера Exchange, чтобы оно соответствовало значению реестра кластера DestPath. Атрибут msExchDataPath можно найти по следующему пути: CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=имя_организации=Administrative Groups, CN=имя_административной_группы, CN=Servers, CN=имя_сервера

  2. Перезапустите ресурс системного помощника Exchange на виртуальном сервере, чтобы изменения вступили в силу.

Дополнительные сведения об изменении службы каталогов Active Directory с помощью средства LDP см. в статье 260745 базы знаний Майкрософт, посвященной использованию служебной программы LDP для изменения атрибутов объектов Active Directory (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260745).

Дополнительные сведения об использовании ADSI Edit для изменения атрибута msExchDataPath см. в статье 288362 базы знаний Майкрософт, посвященной сообщению с кодом события 5007 «Система не может найти указанный путь», зарегистрированному системным помощником Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=288362).


Включена репликация журнала событий
Анализатор сервера Microsoft Exchange — статьи > Кластер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange считывает следующую запись реестра на каждом из серверов, который является узлом кластера:

HKEY_LOCAL_MACHINE\Cluster\Nodes\X\EnableEventLogReplication

Примечание.
X — номер узла, начиная с 1.

Если анализатор сервера Exchange обнаруживает, что значение записи реестра EnableEventLogReplication равно 1, выводится сообщение о рекомендуемых действиях.

Если для записи реестра EnableEventLogReplication указано значение 1, данный узел кластера выполняет репликацию событий , занесенных в журнал событий, на все другие узлы кластера. При включенной репликации журнала событий средства, выполняющие слежение за несколькими серверами, такие как Microsoft Operations Manager (MOM), выдают ряд сообщений по одному событию, количество которых равно количеству узлов. Если используется автоматическое слежение, рекомендуется отключить репликацию журнала событий на узлах кластера.

Чтобы отключить репликацию журнала событий на всех узлах кластера

  1. Войдите на любой из узлов кластера с учетной записью, которая является учетной записью пользователя домена или членом глобальной группы.

  2. Нажмите кнопку Пуск, щелкните Выполнить и введите

    cluster /prop EnableEventLogReplication=0

Чтобы отключить репликацию журнала событий на одном узле кластера

  1. Войдите на любой из узлов кластера с учетной записью, которая является учетной записью пользователя домена или членом глобальной группы.

  2. Нажмите кнопку Пуск, щелкните Выполнить и введите

    Cluster <имя узла> /prop EnableEventLogReplication=0

Дополнительные сведения о настройке репликации журнала событий см. в статье 224969 базы знаний Майкрософт, «HOW TO: Configure Event Log Replication in Windows 2000 Cluster Servers» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224969) (Инструкции: настройка репликации журнала событий на серверах кластера Windows 2000).

Дополнительные сведения об администрировании кластеров серверов см. в документе Administering Server Clusters (http://go.microsoft.com/fwlink/?LinkId=45971) (Администрирование кластеров серверов).


Для ресурса «Имя сети» Kerberos отключен
Анализатор сервера Microsoft Exchange — статьи > Кластер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа сервера Microsoft® Exchange считывает следующий параметр реестра, чтобы определить версию операционной системы Microsoft Windows®, под которой работает сервер:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Значение 4.0 CurrentVersion означает, что компьютер работает под Windows NT® Server 4.0. Значение 5.0 означает, что копмпьютер работает под операционной системой Windows 2000 Server, а значение 5.2 означает, что компьютер работает под операционной системой Windows Server™ 2003.

Анализатор сервера Exchange также запрашивает службу каталога Active Directory®, чтобы определить значение для атрибута serialNumber для всех объектов объектного класса msExchExchangeServer. Если строковое значение включает в себя «Version 5.5,», компьютер работает под Exchange Server 5.5. Если строковое значение включает в себя «Version 6.0,», компьютер работает под Exchange 2000 Server. Если строковое значение включает в себя «Version 6.5,», компьютер работает под Exchange Server 2003.

И наконец, анализатор сервера Exchange считывает следующие значения параметров реестра, чтобы определить, запущен ли Exchange Server в кластере со включенным Kerberos для кластерного ресурса «Имя сети»:

HKLM\Cluster\Resources\< GUID ресурса для ресурса «Имя сети»>\Parameters\RequireKerberos

Значение 0 для параметра RequireKerberos означает, что ресурс «Имя сети» не включен для Kerberos, а значение 1 означает, что ресурс «Имя сети» включен для Kerberos.

Если анализатор сервера Exchange обнаруживает, что на виртуальном сервере Exchange Server 2003, работающем в серверном кластере Windows Server 2003, значение для параметра RequireKerberos установлено в 0, будет выведено предупреждение.

Это предупреждение означает, что кластерный ресурс «Имя сети» со включенным Kerberos не используется для виртуального сервера Exchange Server 2003. Эта настройка не поддерживается и должна быть изменена как можно скорее.

Чтобы устранить это предупреждение

  1. Откройте программу администрирования кластера.

  2. Переведите ресурс «Имя сети» в автономный режим. Эта операция переведет в автономный режим все ресурсы, зависящие от ресурса «Имя сети», в том числе ресурс «Системный диспетчер Microsoft Exchange».

  3. Правой кнопкой мыши щелкните ресурс «Имя сети», затем выберите Свойства.

  4. На вкладке Параметры выберите пункт Включить проверку подлинности Kerberos и нажмите кнопку OK.

  5. Переведите ресурс «Имя сети в оперативный режим», затем переведите оставшиеся автономные ресурсы в оперативный режим.

Для получения дополнительных сведений о использовании ресурсов «Имя сети» со включенным Kerberos в кластере Windows Server 2003 см. статью 302389 базы знаний корпорации Майкрософт «Описание свойств кластерного ресурса «Имя сети» в Windows Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=302389).

Для получения дополнительных сведений о кластеризации см. следующие разделы:

  • «Развертывание Exchange Server 2003 в кластере» в документе Руководство по развертыванию Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47569)

  • «Планирование для кластеризации Exchange» в документе Руководство по высокой доступности Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47571)


Протокол Kerberos включен для ресурса сетевого имени
Анализатор сервера Microsoft Exchange — статьи > Кластер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить версию операционной системы Microsoft Windows®, под управлением которой работает сервер, средство анализатора сервера Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Значение CurrentVersion равное 4.0 означает, что компьютер работает под управлением операционной системы Microsoft Windows NT® Server 4.0. Значение равное 5.0 указывает, что компьютер работает под управлением операционной системы Microsoft Windows 2000 Server, а значение 5.2 означает, что компьютер работает под управлением операционной системы Microsoft Windows Server™ 2003.

Анализатор сервера Exchange также запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumber для всех объектов, относящихся к классу msExchExchangeServer. Если строковое значение содержит «Version 5.5», на компьютере работает сервер Exchange 5.5. Если строковое значение содержит «Version 6.0», на компьютере работает сервер Exchange 2000. Если строковое значение содержит строку «Version 6.5», на компьютере работает Exchange Server 2003.

Наконец, чтобы определить, работает ли Exchange в кластере с кластерным ресурсом сетевого имени, для которого включен протокол Kerberos, анализатор сервера Exchange считывает следующий раздел реестра:

HKLM\Cluster\Resources\<Идентификатор GUID для ресурса сетевого имени>\RequireKerberos

Значение параметра RequireKerberos равное 0 указывает, что ресурс сетевого имени не активизирован для протокола Kerberos, а значение 1 указывает, что ресурс сетевого имени включен для протокола Kerberos.

Если анализатор сервера Exchange обнаружит, что значение параметра RequireKerberos установлено равным 1 на виртуальном сервере Exchange 2000 Server, работающем в кластере под управлением серверной операционной системы Windows 2000 Server, на экран будет выведено предупреждение.

Это предупреждение указывает, что для виртуального сервера Exchange 2000 Server используется кластерный ресурс сетевого имени с включенным протоколом Kerberos. Эта конфигурация не поддерживается и должна быть исправлена как можно быстрее. Как утверждается в базе знаний Майкрософт в статье 235529, описывающей поддержку протокола Kerberos в кластерах серверов под управлением Windows 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=235529), проверка подлинности по протоколу Kerberos для ресурса сетевого имени Exchange 2000 Server не поддерживается. Приложение Exchange 2000 Server не тестировалось, поэтому нельзя гарантировать поддержку виртуальным сервером Exchange 2000 Server проверки подлинности по протоколу Kerberos.

Чтобы устранить причину появления этого предупреждения

  1. Откройте окно командной строки на каком-либо узле кластера.

  2. Выполните следующую команду: cluster res "Имя ресурса сетевого имени" /priv requirekerberos=0:dword

    Примечание.
    Имя ресурса должно быть заключено в кавычки.

  3. Переведите ресурс сетевого имени в автономный режим и удалите его.

  4. Откройте оснастку «Active Directory — пользователи и компьютеры».

  5. Найдите объект учетной записи компьютера для удаленного ресурса сетевого имени и удалите этот объект из службы Active Directory.

  6. Создайте новый ресурс сетевого имени для этого виртуального сервера Exchange и не включайте для него поддержку протокола Kerberos. Можно использовать то же имя и ту же конфигурацию, как у ресурса сетевого имени, который был удален на шаге 3.

  7. Переведите новый ресурс сетевого имени в оперативный режим, а затем переведите в оперативный режим остальные ресурсы на виртуальном сервере Exchange.

Дополнительные сведения об использовании ресурсов сетевого имени с включенным протоколом Kerberos в кластере Windows 2000 Server см. в базе знаний Майкрософт в статье 235529, описывающей поддержку протокола Kerberos в кластерах серверов под управлением Windows 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=235529).


По-видимому, в кластере отсутствует ресурс MSDTC
Анализатор сервера Microsoft Exchange — статьи > Кластер Exchange >

Дата последнего изменения раздела: 2006-04-20

Чтобы определить, существует ли в кластере ресурс координатора распределенных транзакций (Microsoft Distributed Transaction Coordinator, MSDTC), средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Cluster\Resources\

Если значение параметра ClusterMSDTCInstance равно 0, анализатор сервера Exchange выводит на экран предупреждение.

Ресурс MSDTC должен присутствовать в кластере серверов Exchange для поддержки исходной установки и дополнений для пакетов обновлений. Однако этот компонент не является критически важным компонентом, и его наличие не требуется для работы Exchange.

Любой администратор в организации может удалить ресурс MSDTC, так как известно, что этот ресурс не нужен для работы Exchange.

Однако рекомендуется не удалять ресурс MSDTC после первоначальной установки Exchange Server 2003. Если сохранить ресурс MSDTC в кластере, можно будет устанавливать пакеты обновлений и другие исправления.

Чтобы устранить причины появления этого предупреждения, создайте новый ресурс MSDTC. Описание шагов по созданию ресурса MSDTC см. в инструкциях по установке координатора распределенных транзакций в кластере серверов Windows Server 2003 в разделе, посвященном развертыванию Exchange Server 2003, в руководстве по развертыванию Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47569).

Дополнительные сведения

Дополнительные сведения о ресурсе MSDTC и приложении Exchange см. в описании групп кластеров в разделе, содержащем общие сведения о кластеризации Exchange Server 2003, в руководстве по обеспечению высокой доступности Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47571).

Дополнительные сведения о добавлении ресурса MSDTC в Microsoft Windows Server™ 2003 см. в базе знаний Майкрософт в статье 301600, содержащей инструкции по настройке координатора распределенных транзакций для кластера Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301600).

Примечание.
Статья 301600 базы знаний Майкрософт содержит ссылку на статью 817064, описывающую включение сетевого доступа к DTC в Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=817064). Для обеспечения безопасности сервера Exchange рекомендуется не включать сетевой доступ к координатору распределенных транзакций (DTC) для кластера Exchange. При настройке ресурса координатора распределенных транзакций для кластера Exchange, не включайте сетевой доступ к координатору распределенных транзакций.


Простои ресурса MSDTC влияют на группу кластера
Анализатор сервера Microsoft Exchange — статьи > Кластер Exchange >

Дата последнего изменения раздела: 2006-03-16

Чтобы определить, была ли выполнена настройка, при которой отказ ресурса MSDTC (Microsoft Distributed Transaction Coordinator) влияет на группу, средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\Cluster\Resources\

Если значение параметра ClusterMSDTCInstance равно 2, анализатор сервера Exchange выведет на экран предупреждение.

Ресурс MSDTC должен присутствовать в кластере Exchange для поддержки исходной установки и устанавливаемых пакетов обновлений. Однако этот ресурс не нужен для работы Exchange.

По умолчанию отказ ресурса MSDTC влияет на группу. Ниже приводятся два примера отказа ресурса:

  • Размер файла журнала превышает емкость диска.

  • Отказ физического диска ресурса MSDTC.

В частности отказ ресурса MSDTC вызовет переход на другой узел в кластере всех служб Exchange, которые выполняются на этом узле кластера. Однако поскольку ресурс MSDTC не является обязательным ресурсом, его не надо настраивать так, чтобы он воздействовал на группу.

Чтобы устранить причины появления этого предупреждения, настройте кластер Exchange таким образом, чтобы отказ ресурса MSDTC не влиял на группу.

Для настройки Exchange таким образом, чтобы отказ ресурса MSDTC не влиял на группу

  1. Войдите на любой узел кластера.

  2. Нажмите кнопку Пуск, последовательно наведите указатель на Программы, Администрирование, а затем щелкните Администратор кластера.

  3. В разделе Группы щелкните правой кнопкой мыши группу кластера, которая содержит ресурс MSDTC.

  4. Щелкните правой кнопкой мыши ресурс MSDTC и в контекстном меню выберите Свойства.

  5. На вкладке Дополнительно снимите флажок Затрагивает эту группу и нажмите кнопку OK.

Дополнительные сведения

Описание шагов по созданию ресурса MSDTC см. в инструкциях по установке координатора распределенных транзакций в кластере серверов Windows Server 2003, которые содержатся в разделе, посвященном развертыванию Exchange Server 2003 в кластере, в руководстве по развертыванию Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47569).

Дополнительные сведения о ресурсе MSDTC и приложении Exchange см. в подразделе по группам кластеров в разделе, описывающем общие сведения о кластеризации Exchange Server 2003, в руководстве по обеспечению высокой доступности Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47571).

Дополнительные сведения о добавлении ресурса MSDTC в Microsoft Windows Server™ 2003 см. в базе знаний Майкрософт в статье 301600, содержащей инструкции по настройке координатора распределенных транзакций в кластере Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301600).

Примечание.
Статья 301600 в базе знаний Майкрософт содержит ссылку на статью 817064, описывающую порядок включения сетевого доступа к координатору распределенных транзакций в Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=817064). Для обеспечения безопасности сервера Exchange рекомендуется не включать сетевой доступ к координатору распределенных транзакций для кластера Exchange. Если для кластера Exchange настраивается ресурс координатора распределенных транзакций, не включайте сетевой доступ к координатору распределенных транзакций.


Отключения агента передачи сообщений затронут кластерную группу
Анализатор сервера Microsoft Exchange — статьи > Кластер Exchange >

Дата последнего изменения раздела: 2006-03-16

Анализатор сервера Microsoft® Exchange проверяет настройки раздела реестра Cluster\Resources для системы сервера Exchange.

HKEY_LOCAL_MACHINE\Cluster\Resources

Если анализатор сервера Exchange обнаружит, что ресурсы службы стеков агента передачи сообщений запущены в кластере Exchange Server 2003 для организации, находящейся в основном режиме, выдается сообщение с практическими рекомендациями.

В нем администратору Exchange рекомендуется настроить ресурс агента передачи сообщений так, чтобы при сбое или остановке агента не происходил переход виртуального сервера Exchange.

Примечание.
Служба стеков агента передачи сообщений в Microsoft Exchange 2000 Server и в Microsoft Exchange Server 2003 часто используется для передачи сообщений между серверами Exchange 2000 Server или Exchange Server 2003 и серверами Microsoft Exchange Server 5.5 в среде со смешанным режимом. После перехода на чистую среду Exchange 2000 Server или Exchange Server 2003 с основным режимом агент передачи сообщений перестает быть ключевым ресурсом для работы служб Exchange.

В случае остановки или сбоя службы стеков агента передачи сообщений может быть инициирован переход виртуального сервера Exchange на другой ресурс. Во избежание этого рекомендуется настроить службу стеков агента передачи сообщений на предотвращение такого перехода, выполнив следующие действия.

Чтобы настроить службу стеков агента передачи сообщений в защищенном состоянии в кластере серверов Exchange

  1. Откройте Cluster Administrator

  2. Снимите флажок Affect this Group для ресурса службы стеков агента передачи сообщений.

Дополнительные сведения

Дополнительные сведения о поддержке службы стеков агента передачи сообщений в Exchange Server 2003 см. в статье 810489 базы знаний Майкрософт, в которой приводятся инструкции по поддержке этой службы для Exchange 2000 Server и Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810489).

Дополнительные сведения об агенте передачи сообщений в архитектуре Exchange Server 2003 см. в документе «Exchange MTA in Exchange Server 2003 Architecture» (Агент передачи сообщений Exchange в архитектуре Exchange Server 2003, http://go.microsoft.com/fwlink/?LinkId=63496).

Дополнительные сведения о развертывании Exchange Server 2003 в кластере см. в документе «Deploying Exchange Server 2003 in a Cluster» (Развертывание Exchange Server 2003 в кластере, http://go.microsoft.com/fwlink/?LinkId=63495).

Сведения об использовании администратора кластера см. в документе «Using Cluster Administrator to Manage Exchange Clusters» (Использование администратора кластера для управления кластерами Exchange, http://go.microsoft.com/fwlink/?LinkId=63493).


Это 2-узловой кластер «активный/активный»
Анализатор сервера Microsoft Exchange — статьи > Кластер Exchange >

Дата последнего изменения раздела: 2006-04-28

Чтобы определить значение параметра Started службы кластеров ClusSvc, анализатор сервера Microsoft® Exchange запрашивает класс инструментария Microsoft Windows® Management Instrumentation (WMI) Win32_Service. Значение True указывает, что служба кластеров работает, а значение False означает, что она не работает.

Для определения числа узлов в кластере анализатор Exchange Server также читает следующий параметр реестра:

HKEY_LOCAL_MACHINE\Cluster\Nodes\ <Номер_узла> \NodeName

Количество экземпляров NodeName представляет число узлов в кластере. Кроме того, чтобы определить число ресурсов Exchange Server в кластере, анализатор Exchange Server читает следующий параметр реестра:

HKLM\Cluster\Resources\ <GUID_ресурса_кластера> \Parameters\DestPath

Значение DestPath будут иметь следующие ресурсы в кластере Exchange Server:

  • Агент передачи сообщений Microsoft Exchange

  • Банк сообщений Microsoft Exchange

Число экземпляров DestPath указывает число серверов в кластере, на которых работает виртуальный сервер Exchange (EVS).

Если анализатор Exchange Server определяет, что в кластере, в котором работает 2 экземпляра NodeName, есть 3 экземпляра DestPath, выводится предупреждение. Это предупреждение означает, что данный кластер — двухузловой с двумя серверами EVS, известный как кластер «активный/активный».

  • В модели кластера «активный/активный» число виртуальных серверов Exchange в кластере равно или больше числа физических узлов в кластере.

Примечание.
Кластеры Exchange «активный/активный» могут создаваться только в кластерах, состоящих из двух узлов. Если в кластере три или больше узлов, следует использовать модель «активный/пассивный».
  • В модели кластера «активный/пассивный» число виртуальных серверов Exchange в кластере меньше числа физических узлов.

Хотя сервер Microsoft Exchange Server поддерживает объединение в кластеры «активный/активный», для кластеров Exchange настоятельно рекомендуется использовать реализации «активный/пассивный». Корпорация Майкрософт поддерживает только кластеры Exchange «активный/активный», которые отвечают следующим ограничениям масштабирования:

  • Число параллельных пользовательских подключений на виртуальный сервер Exchange и на физический узел не должно превышать 1900. Если один узел кластера недоступен и если все виртуальные серверы Exchange на одном узле находятся в оперативном режиме, действует предел масштабирования в 3800 подключений для двух виртуальных серверов Exchange. Поскольку каждый пользователь может установить несколько подключений, число почтовых ящиков не может служить точным критерием оценки количества подключений.

  • Среднее потребление ресурсов процессора на процесс хранилища Exchange не должно быть больше 40%. Если общее использование ресурсов процессора процессом STORE.EXE на узле превышает 40% в течение 10 и более минут, следует переместить пользователей на другой виртуальный сервер Exchange или сервер Exchange. К тому же следует учитывать, что эта нагрузка не включает потребление ресурсов процессора на выполнение административных задач.

Переход от конфигурации кластера «активный/активный» на конфигурацию «активный/пассивный» предполагает перемещение ресурсов со второго сервера EVS с последующим его списанием.

Чтобы перейти от кластера «активный/активный» на кластер «активный/пассивный»

  1. Переместите почтовые ящики, поддерживаемые на втором EVS, на первый EVS в кластере. Первый EVS в кластере всегда содержит единственный ресурс агента передачи сообщений Microsoft Exchange в кластере.

  2. После того, как все почтовые ящики перемещены на первый EVS, переведите второй EVS в автономный режим.

  3. Удалите второй EVS, выполнив одно из следующих действий:

    • В кластере Exchange Server 2003 щелкните правой кнопкой мыши ресурс системного помощника Microsoft Exchange и выберите команду Удалить виртуальный сервер Exchange.

    • В кластере Exchange 2000 Server щелкните правой кнопкой мыши ресурс системного помощника Microsoft Exchange и выберите команду Удалить.

  4. Убедитесь, что объект EVS удален из службы каталогов Active Directory®. Так как разрешения учетной записи службы кластеров в Exchange Server 2003 изменены, учетная запись должна иметь разрешение на удаление объектов Active Directory.

  5. Переведите в автономный режим остальные ресурсы во втором EVS (например, физический диск, сетевое имя и IP-адрес) и затем удалите их.

  6. Удалите группу ресурсов, которая содержала второй EVS.

Дополнительные сведения об удалении EVS см. в разделе «Removing an Exchange virtual server from a Cluster» (Удаление виртуального сервера Exchange из кластера) интерактивной книги Развертывание кластеров Microsoft Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=9393).

Практические рекомендации по работе с кластерами Exchange см. в Руководстве по развертыванию Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).

Дополнительные сведения о развертывании Exchange в кластере серверов Windows см. в статье базы знаний Майкрософт 815180 «Considerations when deploying Exchange on an Active/Active cluster» (Особенности развертывания Exchange в кластере «активный/активный») (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815180).


Слишком маленький файл журнала кворума
Анализатор сервера Microsoft Exchange — статьи > Кластер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server считывает следующий параметр реестра для определения размера журнала кворума, настроенного для кластера:

HKEY_LOCAL_MACHINE\Cluster\Quorum\MaxQuorumLogSize

Если средство анализа Exchange Server обнаружит, что значение MaxQuorumLogSize меньше 4194304 в десятичной системе (0x400000 в шестнадцатеричной), появится предупреждение.

Значение параметра реестра MaxQuorumLogSize — это настроенное на данный момент значение параметра кворума кластера Сбрасывать журнал кворума при достижении. Данное предупреждение выдается, если значение MaxQuorumLogSize менее 4096 кбайт (кБ).

Кластер регистрирует все изменения базы данных кластера в файле журнала кворума. Когда журнал кворума достигает заданного размера, кластер сохраняет базу данных и сбрасывает файл журнала. Для кластеров, построенных на основе Microsoft Windows® 2000 Server, ограничение размера кворума по умолчанию составляет 64 кБ. Для кластеров, построенных на основе Windows Server™ 2003, ограничение размера кворума по умолчанию 4096 кБ. Для кластеров сервера Exchange рекомендуется установить для параметра Сбрасывать журнал кворума при достижении значение 4096 кбайт. Этим обеспечивается достаточное количество места для хранения информации о настройке кластера, например сведений о том, какие серверы входят в кластер, какие ресурсы установлены в кластере, и сведения о состоянии ресурсов (к примеру, в сети/не в сети).

Для устранения этого предупреждения

  1. Откройте администратор кластера.

  2. В левой панели щелкните правой кнопкой мыши объект, представляющий кластер, и щелкните Свойства.

  3. На вкладке Кворум установите для параметра Сбрасывать журнал кворума при достижении значения 4096.

  4. Нажмите кнопку ОК, чтобы сохранить изменения.

Для получения дополнительных сведений о предельном размере журнала кворума по умолчанию см. статью 225081 базы знаний корпорации Майкрософт «Как изменить значение в 64 кбайт, установленное по умолчанию для журнала кворума ресурсов кластера» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=225081).


Сервер Exchange
Анализатор сервера Microsoft Exchange — статьи >

Дата последнего изменения раздела: 2005-11-18

Статьи в этой части предоставляют сведения об оценках, выполняемых средством анализатора сервера Microsoft® Exchange в отношении компьютеров серверов Exchange. Помимо этого, в данных статьях описываются действия, которые можно предпринять по устранению относящихся к Exchange ошибок, предупреждений и нестандартных конфигураций, обнаруживаемых анализатором сервера Exchange.


Установлена блокировка учетной записи
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-08-28

Чтобы определить, присутствует ли в папке System32 на сервере Exchange файл с именем ALockout.dll, средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile. Файл ALockout.dll является частью средств управления учетными записями и их блокировки (ALTools.exe). С помощью этих средств администраторы осуществляют управление учетными записями и устраняют проблемы блокировки учетных записей.

Если анализатор сервера Exchange обнаруживает, что на сервере Exchange существует файл ALockout.dll, этот анализатор сервера Exchange выводит сообщение об ошибке.

Средства управления учетными записями и их блокировки не следует использовать для серверов, размещающих сетевые приложения или службы, в том числе серверы Exchange. Если на сервере Exchange установлены средства управления учетными записями и их блокировки, эти средства могут вызвать сбой при запуске служб Exchange. Поэтому настоятельно рекомендуется удалить средства управления учетными записями и их блокировки с такого сервера Exchange.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.
Чтобы устранить эту ошибку

  1. В командной строке введите regsvr32 /u alockout.dll.

  2. Удалите значение ALockout.dll, расположенное в следующем разделе реестра: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Windows\AppInit_DLLs
Примечание.
После удаления значения ALockout.dll раздел реестра AppInit_DLLs будет пуст. Перезапустите компьютер.
  1. Удалите файл ALockout.dll из папки System32.

Перед началом редактирования реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт "Description of the Microsoft Windows registry" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения о средствах управления учетными записями и их блокировки см. в разделе «Средства блокировки учетных записей» в материале Account Passwords and Policies (http://go.microsoft.com/fwlink/?LinkId=52465) (Пароли и политики учетных записей).


Несоответствие сайтов Active Directory
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-03-16

Анализатор сервера Microsoft® Exchange, используя функцию DsGetSiteName API-интерфейса Win32, запрашивает имя сайта службы каталогов Active Directory® для контроллера домена и имя сайта Active Directory для локального сервера Exchange.

Если анализатор сервера Exchange определит, что имя сайта Active Directory, содержащего контроллер домена, не совпадает с именем сайта Active Directory, содержащего локальный сервер Exchange, выводится предупреждение.

Это предупреждение означает, что процесс доступа к службе каталогов (DSAccess), выполняя запросы LDAP, выходит за рамки локального сайта Active Directory, что может привести к заметному снижению быстродействия сервера Exchange.

Такая ситуация может быть вызвана статической конфигурацией внешнего контроллера домена, отключением сети или компьютера контроллера домена, в результате которого размещенный в сайте контроллер домена становится недоступным, или неправильной топологией Active Directory, в которой контроллер домена Active Directory и сервер Exchange располагаются в разных сайтах.

DSAccess — общий компонент сервера Exchange, запрашивающий данные каталога и сохраняющий их в кэше. DSAccess динамически обнаруживает серверы каталога, к которым должны будут обращаться другие компоненты Exchange, на основе таких критериев, как конфигурация сайтов Active Directory и доступность серверов Active Directory. Серверы Exchange переднего плана используют процесс DSAccess для поиска сервера, содержащего почтовый ящик того или иного пользователя, адресов SMTP, определенных для объекта пользователя, и серверов с хранилищами общих папок.

Когда процесс DSAccess инициализируется, он ищет в реестре контроллеры доменов со статической конфигурацией и глобальные каталоги, и если их не находит, то использует процесс обнаружения, чтобы определить топологию сети и оценить доступность и допустимость серверов каталога. В частности, при определении допустимости контроллера домена проверяется, находится ли он в том же сайте Active Directory, что и сервер Exchange.

Для сокращения задержки, вызываемой запросами LDAP между сайтами, серверы Exchange следует располагать в том же сайте Active Directory, что и резидентный контроллер домена.

Чтобы решить этот вопрос:

  • Проверьте определения сайтов в топологии Active Directory и убедитесь, что каждый сервер Exchange имеет доступ к контроллеру домена того же сайта Active Directory.

  • Убедитесь, что каждый контроллер домена со статической конфигурацией находится в том же сайте Active Directory, что и сервер Exchange.

Дополнительные сведения

Дополнительные сведения о настройке процесса DSAccess и устранении связанных с ним неполадок см. в следующих материалах по Exchange:

  • Directory Integration and Exchange Server (Интеграция каталога и сервер Exchange, http://go.microsoft.com/fwlink/?LinkId=63447)

  • Understanding and Troubleshooting Directory Access (Общие сведения о доступе к каталогу и устранение возможных неполадок, http://go.microsoft.com/fwlink/?LinkId=39012)

  • Статья 250570 базы знаний Майкрософт, посвященная обнаружению серверов службы каталогов и использованию процесса DSAccess (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)


Отключены общие файлы администрирования
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, изменены ли заданные по умолчанию параметры общих ресурсов администрирования, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters\AutoShareServer

Если анализатор сервера Exchange обнаруживает, что для параметра AutoShareServer установлено значение 0, выводится сообщение об ошибке.

Эта ошибка указывает, что на сервере отключены созданные сервером по умолчанию общие ресурсы администрирования. Если общие ресурсы администрирования отключены, оперативное резервное копирование или восстановление сервера Exchange может быть недоступно. В некоторых программах резервного копирования при попытке восстановить данные будут выводиться сообщения об ошибке. Кроме того, сообщения об ошибке могут заноситься в журнал резервного копирования на ленточный носитель.

Если общие ресурсы администрирования удалены, в процессе оперативного резервного копирования сервера Exchange возможно появление следующего сообщения: Непредусмотренная ошибка 0xc0040000. Сервер Microsoft Exchange недоступен. Чтобы устранить эту проблему, рекомендуется включить заданные по умолчанию общие ресурсы администрирования, настроив параметры реестра и перезапустив службу сервера.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.
Чтобы устранить эту ошибку

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

  3. В правой области дважды щелкните AutoShareServer.

  4. Измените значение с 0 на 1.

  5. Закройте редактор реестра и перезапустите службу сервера, чтобы изменения вступили в силу.

Перед редактированием реестра изучите инструкции по редактированию реестра в статье 256986 базы знаний Майкрософт 256986 «Description of the Microsoft Windows registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения о восстановлении заданных по умолчанию общих ресурсов администрирования в Microsoft Windows Server™ 2003 см. в статье 816113 базы знаний «HOW TO: Use Registry Editor to Restore Administrative Shares in Windows Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816113) (Инструкции: использование редактора реестра для восстановления общих ресурсов администрирования в Windows Server 2003).


Взаимодействие между драйвером AFD.SYS и соединителем X.400
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить версию операционной системы Microsoft Windows®, под управлением которой работает компьютер сервера Exchange, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Значение CurrentVersion, равное 4.0, указывает, что компьютер сервера Exchange работает под управлением Microsoft Windows NT® Server 4.0. Значение, равное 5.0, указывает, что компьютер сервера Exchange работает под управлением Windows 2000 Server, а значение, равное 5.2, указывает, что на компьютере сервера Exchange установлена операционная система Windows Server™ 2003.

Анализатор сервера Exchange также запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_ComputerSystem, чтобы определить значение, установленное для ключа NumberOfProcessors. Это значение представляет собой количество процессоров, установленных на компьютере. Эти процессоры включают как физические процессоры, так и логические процессоры. С помощью технологии многопоточности (hyper-threading) компании Intel физический процессор может быть разделен на два логических процессора.

Чтобы определить, является ли сервер Exchange сервером-плацдармом для соединителя X.400, анализатор сервера Exchange также считывает следующую запись реестра:

HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeMTA

Наконец, анализатор сервера Exchange запрашивает WMI-класс (Windows Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version для файла Afd.sys.

Анализатор сервера Exchange выводит на экран предупреждение, если выполняются следующие условия:

  • Компьютер сервера Exchange работает под управлением Windows Server 2000.

  • Значение параметра NumberOfProcessors больше 1.

  • Сервер Exchange является сервером-плацдармом для соединителя X.400.

  • Значение ключа Version для WINDOWSPATH%\\system32\\drivers\\afd.sys находится в диапазоне между 5.0.2195.7036 и 5.0.2195.7060.

Это предупреждение указывает, что версия файла Afd.sys, установленного на сервере, может быть причиной проблем почтового потока с соединителями X.400, размещенными на этом сервере.

Для устранения этой проблемы получите обновление, упоминаемое в базе знаний Майкрософт в статье 904712, описывающей ситуацию, когда в Exchange Server 5.5 доставка почты на удаленный узел замедляется или останавливается на соединителе X.400 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=904712).


Нестандартное значение срока хранения баз данных
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-08

Средство анализа Microsoft Exchange Server запрашивает службу каталога Active Directory для определения, установлен ли атрибут msExchAgingKeepTime. Атрибут представляет собой значение времени, используемое для определения времени удаления индексов, видов и классификаций. Если Exchange Server Analyzer обнаруживает, что атрибут установлен, появляется сообщение о нестандартной настройке.

Индексы для видов, созданные клиентом Exchange в таблицах в базе данных Exchange и не использовавшиеся в течение указанного времени, в данный момент очищаются. Атрибут msExchAgingKeepTime обозначает минимальный срок хранения индексов. В первой версии Exchange 2000 Server значение по умолчанию было 8 дней. В пакете обновления 1 (SP1) для Exchange 2000 Server и всех следующих версиях Exchange Server, в т.ч. Exchange Server 2003 и Exchange Server 2007, значение по умолчанию составляет 40 дней.

Внимание!
В случае неверного изменения атрибутов объектов Active Directory при работе с редактором интерфейсов службы Active Directory (ADSI), средством LDP (ldp.exe) или другим клиентом протокола LDAP версии 3 могут возникнуть серьезные проблемы. Для устранения этих проблем может потребоваться переустановка системы Microsoft Windows Server™ 2003, сервера Exchange Server 2003 или сервера Exchange Server 2007 или обоих продуктов. Майкрософт не несет ответственности за последствия изменения атрибутов объектов Active Directory.
Просмотр или изменение значения срока хранения

  1. Запустите редактор ADSI.

  2. Дважды щелкните контейнер Настройки, разверните CN=Services, затем CN=Microsoft Exchange, затем CN=<ExchangeOrganizationName>.

  3. Разверните CN=Administrative Groups, затем CN=<AdministrativeGroupName>, затем CN=Servers.

  4. Разверните CN=<ServerName>, затем CN=InformationStore и выберите CN=<StorageGroupName>.

  5. В области сведений щелкните правой кнопкой мыши параметр CN=<MailboxStoreName>, затем щелкните Свойства.

  6. В Редакторе атрибутов щелкните атрибут msExchAgingKeepTime, затем Правка.

  7. В поле Правка атрибута щелкните Очистить, чтобы удалить значение.

  8. Нажмите Применить, затем ОК.

  9. Закройте редактор ADSI. Чтобы изменения вступили в силу, необходимо перезапустить службу хранилища информации Microsoft Exchange.

Для получения дополнительных сведений о средстве LDP см. статью 260745 базы знаний Майкрософт «XADM: Using the LDP Utility to Modify Active Directory Object Attributes» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745) (Использование служебной программы LDP для изменения свойств объектов Active Directory).

Дополнительные сведения о возможных проблемах с доступом к папкам банка данных см. статью 216076 базы знаний Майкрософт «Accessing information store folders may become slow in Exchange» (Замедление доступа к папкам банка данных в Exchange» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=216076).


Доступно обновление для службы Antigen
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-06-20

Анализатор Microsoft Exchange Server запрашивает класс CIM_Datafile инструментария управления Microsoft® Windows® (WMI), чтобы определить значение раздела Version для библиотеки MimeNavigator.dll. Этот модуль входит в Microsoft Antigen версий 8 и 9.

Если анализатор Exchange определяет, что значение раздела Version для библиотеки MimeNavigator.dll меньше 8.00.1517.0 для версии 8 или меньше 9.00.1055.0 для версии 9, выводится предупреждение.

Это предупреждение указывает на то, что на сервере Exchange Server установлена версия 8 или 9 Microsoft Antigen и для данной версии доступно обновление программного обеспечения. Настоятельно рекомендуется установить это обновление, так как оно позволяет повысить общую производительность и надежность сервера.

Чтобы устранить данную проблему, изучите и примените рекомендации, изложенные в статье 928082 базы знаний Майкрософт В процессе проверки службой Antigen размер SMTP-сообщений может увеличиваться (на английском языке).


Размер журнала приложений
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-11-09

Средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить максимальный размер файла журнала приложений:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Eventlog\Application\MaxSize

Если средство анализатора сервера Exchange обнаруживает, что значение MaxSize меньше 41,943,040 байт (40 мегабайт), средство анализатора сервера Exchange отображает сообщение с рекомендацией.

По умолчанию максимальный размер журнала для файла журнала приложений составляет 16 777 216 байтов (16384 КБ) для Windows Server 2003 и 524288 байтов (512 КБ) для Windows 2000 Server. Для компьютеров, на которых установлен сервер Exchange, рекомендуется, чтобы максимальный размер журнала приложений равнялся не менее 40 МБ (размер вводится как 40960). Увеличив размер журнала приложений, можно сохранить больше событий приложения. Дополнительные сведения о событиях помогают при устранении неполадок.

Чтобы увеличить максимальный размер журнала приложений

  1. Откройте оснастку «Просмотр событий» консоли управления.

  2. Щелкните правой кнопкой мыши Журнал приложения и щелкните Свойства.

  3. На вкладке General в группе Log size введите 40960 или более в поле Maximum log size, а затем нажмите кнопку ОК.


Rootver ASP.NET поврежден
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-08

Средство анализа Microsoft® Exchange Server считывает следующий параметр реестра для определения значения Rootver для ASP.NET:

HKEY_LOCAL_MACHINE\Software\Microsoft\ASP.NET

Средство анализа Exchange Server отображает сообщение об ошибке, если выполняются следующие условия:

  • Средство анализа Exchange Server обнаруживает, что значение Rootver установлено как 0.0.0.0.

  • Запущена служба кластеров.

Иногда ASP.NET завершает работу, не отображая сообщения об ошибке. В таких случаях параметр Rootver установлен как 0.0.0.0. Установка для параметра Rootver значения 0.0.0.0 приводит к тому, что системный помощник Microsoft Exchange или другие службы Exchange Server не могут запуститья на кластерах Exchange Server 2003 и Exchange Server 2007. Необходимо исправить эту ошибку, изменив значение Rootver на одно из следующих:

  • Раздел Rootver для Exchange Server 2003 = 1.1.4322.0.

  • Раздел Rootver для Exchange Server 2007 = 2.0.50727.0

Важно!
В этой статье содержатся сведения о редактировании реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Для получения сведений о восстановлении реестра см. разделе «Восстановление реестра» справочной системы файла Regedit.exe или Regedt32.exe.
Для установки Rootver как 1.1.4322.0

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел: HKLM\Software\Microsoft\ASP.NET\

  3. На панели свдений дважды щелкните параметр RootVer.

  4. В диалоговом окне Edit String установите для Value data значение, соответствующее указанному в этой статье выше, и нажмите OK.

  5. Закройте редактор реестра.

Перед редактированием реестра для получения сведений по редактированию реестра см. статью 256986 базы знаний Майкрософт, содержащую описание реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Автоматическая отладка операционной системы отключена
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft Exchange Server определяет отключение отладки операционной системы по следующему параметру реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AeDebug\Auto

Если Exchange Server Analyzer обнаруживает, что значение Auto установлено в 0, отображается предупреждение.

По умолчанию в операционных системах Microsoft Windows® 2000 Server и Windows Server™ 2003 System устанавливается отладчик уровня приложений под названием «Доктор Ватсон». Отладчик является программой, помогающей обнаружить, найти и исправить ошибки в другой программе, позволяя программисту исследовать программу по шагам, проверять данные и отслеживать условия, например значения переменных.

Параметры по умолчанию устанавливаются при первом запуске программы «Доктор Ватсон», т.е. при возникновении ошибки программы или при намеренном запуске программы «Доктор Ватсон».

При возникновении ошибки в работе приложения Windows ищет обработчик ошибок программы. Обработчик ошибок программы обрабатывает ошибки по мере их возникновения в ходе работы программы. Если Windows не обнаруживает обработчик ошибок программы, происходит проверка выполнения отладки программы в данный момент, и ошибка считается необработанной. Затем Windows обрабатывает необработанные ошибки, осуществляя поиск отладчика ошибок программы в реестре.

Поведение Windows зависит от значений двух параметров реестра: HKLM\Software\Microsoft\Windows NT\CurrentVersion\AeDebug

Параметры называются Debugger и Auto. Значение строки Debugger указывает команду, используемую отладчиком при анализе ошибок программы. Если найдено значение параметра Debugger, Windows проверяет, равно ли значение параметра Auto 0 или 1:

  • Если для параметра Auto установлено значение 0, появляется окно сообщения, сообщающее об ошибке программы. Если значение параметра Debugger указывает команду для запуска допустимого отладчика, в окне сообщения отображаются две кнопки: OK и Отмена. Нажатие OK приводит к остановке программы. Нажатие кнопки Отмена приводит к запуску указанного отладчика. Если значение для параметра Debugger не установлено, в окне сообщения отобразится только OK, и отладчик не будет запущен.

  • Если для параметра Auto установлено значение 1, а значение параметра Debugger указывает команду запуска допустимого отладчика, система автоматически запустит отладчик, и окно сообщения не появится.

При установке Windows для параметра Auto по умолчанию устанавливается значение 1, а значение параметра Debugger указывает команду запуска программы «Доктор Ватсон» (drwtsn32 -p %ld -e %ld -g). Таким образом, при возникновении ошибки программы «Доктор Ватсон» автоматически диагностирует ошибку и вносит в журнал соответствующую диагностическую информацию.

На серверах Exchange рекомендуется использовать отладчик ошибок программ. Если раньше по умолчанию использовались другие отладчики, а теперь необходимо установить «Доктор Ватсон», в командной строке введите drwtsn32 -i, чтобы запустить «Доктор Ватсон». Благодаря вводу -i происходят необходимые изменения в реестре.

Регистрация программы «Доктор Ватсон» в качестве отладчика по умолчанию с помощью командной строки

  1. Откройте окно командной строки.

  2. Выполните следующую команду: drwtsn32 -i

  3. Появится сообщение «Доктор Ватсон» установлен в качестве отладчика по умолчанию.» Нажмите OK для подтверждения.

Регистрация программы «Доктор Ватсон» в качестве отладчика по умолчанию с помощью пользовательского интерфейса

  1. Нажмите Пуск, затем Выполнить, введите drwtsn32 и нажмите клавишу ВВОД. Появится пользовательский интерфейс программы «Доктор Ватсон» для Windows.

  2. Установите флажок Создание файла аварийной копии памяти.

  3. Нажмите OK, чтобы сохранить изменения, и закройте пользовательский интерфейс программы «Доктор Ватсон» для Windows.

Для получения дополнительных сведений о программе «Доктор Ватсон» для Windows см. справочную систему программы «Доктор Ватсон» (открывается при нажатии F1 в пользовательском интерфейсе программы «Доктор Ватсон»).

Для использования другого отладчика ошибок отключите программу «Доктор Ватсон», выполняя процедуру из статьи 188296 базы знаний Майкрософт «Отключение программы Доктор Ватсон в Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=188296).


Средняя задержка чтения LDAP превысила 50 миллисекунд
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-03-14

Анализатор Microsoft Exchange содержит подсистему сбора данных о производительности, используемую для запроса объектов счетчиков производительности на компьютерах с Exchange 2000 Server или Exchange Server 2003. Эта подсистема собирает данные счетчика производительности LDAP Read Time объекта производительности MSExchangeDSAccess Process для анализа.

Счетчик производительности LDAP Read Time показывает время в миллисекундах, которое занимает выполнение запроса на чтение LDAP (Lightweight Directory Access Protocol). Анализатор Exchange получает выборочные данные каждые 5 секунд на протяжении 5 минут. Затем анализатор Exchange сообщает максимальное значение счетчика производительности за время сбора данных. Если среднее значение превышает 50 миллисекунд, анализатор сервера Exchange выводит предупреждение.

Причинами больших задержек чтения LDAP могут быть большие задержки удаленных вызовов процедур и большие очереди. Большие задержки чтения LDAP обычно указывают на одну из следующих проблем:

  • Проблема производительности сетевого подключения к контроллеру домена.

  • Проблемы производительности самого контроллера домена.

Примечание.
Задержки LDAP обычно больше, когда пользователи подключаются к контроллерам доменов, которые находятся на других физических узлах. Однако рекомендуемые максимальные задержки, указываемые в этой статье, как правило, не должны превышаться.

Когда контроллер домена, зарегистрировавший это предупреждение в журнале, находится на другом физическом узле, можно, ничем не рискуя, проигнорировать это предупреждение, если есть возможность определить, что контроллер домена, сообщающий об этой ошибке, не используется сервером Exchange. Один из способов определить, используется ли контроллер домена сервером Exchange Server, заключается в повышении уровня ведения журнала диагностики для компонента Топология службы MSExchangeDSAccess до значения Минимум. Если в журнале не наблюдается событие MSExchangeDSAccess с идентификатором 2080, можно спокойно игнорировать это предупреждение.

Чтобы устранить это предупреждение, выполните указанные ниже действия.

  • Убедитесь, что все сетевые подключения к контроллеру домена работоспособны и поддерживают трафик ICMP.

  • Изучите рекомендации, изложенные в указанных ниже статьях.

    • Дополнительные сведения о счетчиках производительности LDAP Read Time и других счетчиках, которые можно использовать для устранения неполадок с Active Directory, см. в разделе «Решение проблем, связанных с Active Directory» Руководства по устранению неполадок с сервером Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588) (на английском языке). Эта статья также содержит сведения о том, как повысить производительность работы службы Active Directory.

    • Дополнительные сведения о достижении максимальной производительности службы Active Directory см. в разделе, описывающем настройку интеграции со службой Active Directory, в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

    • Дополнительные сведения о способах обеспечения высокого уровня доступности серверов Active Directory см. в подразделах «Обеспечение надежного доступа к Active Directory и службе доменных имен (DNS)» раздела «Меры обеспечения отказоустойчивости на уровне системы» Руководства по обеспечению высокого уровня доступности Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47571) (на английском языке).

    • Сведения по вопросам пропускной способности сети см. в части, касающейся производительности сети из раздела, описывающего общие сведения о производительности сервера Exchange, в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).


Максимальная задержка чтения LDAP превысила 100 миллисекунд
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-03-14

Анализатор Microsoft Exchange содержит подсистему сбора данных о производительности, используемую для запроса объектов счетчиков производительности на компьютерах с Exchange 2000 Server или Exchange Server 2003. Эта подсистема собирает данные счетчика производительности LDAP Read Time объекта производительности MSExchangeDSAccess Process для анализа.

Счетчик производительности LDAP Read Time показывает время в миллисекундах, которое занимает выполнение запроса на чтения LDAP (Lightweight Directory Access Protocol). Анализатор Exchange получает выборочные данные каждые 5 секунд на протяжении 5 минут. Затем анализатор Exchange сообщает максимальное значение счетчика производительности за время сбора данных. Если максимальное значение превышает 100, анализатор Exchange выводит сообщение об ошибке.

Причинами больших задержек чтения LDAP могут быть большие задержки удаленных вызовов процедур и большие очереди. Большие задержки чтения LDAP обычно указывают на одну из следующих проблем:

  • Проблема производительности сетевого подключения к контроллеру домена.

  • Проблемы производительности самого контроллера домена.

Примечание.
Задержки LDAP обычно больше, когда пользователи подключаются к контроллерам доменов, которые находятся на других физических узлах. Однако рекомендуемые максимальные задержки, указываемые в этой статье, как правило, не должны превышаться.

Серверы Exchange Server опрашивают серверы глобального каталога, не входящие в домен, каждые 15 минут для обновления списка серверов глобального каталога и контроллеров домена. Поскольку некоторые из этих серверов каталогов могут быть удаленными, при выполнении таких запросов могут возникать длительные задержки. Это приемлемо, если такие запросы выполняются нечасто (их количество в секунду не превышает 0,5).

Если контроллер домена, зарегистрировавший такую ошибку, физически расположен на другом сайте, можно пропустить ошибку, если известно, что этот контроллер домена не используется сервером Exchange Server. Один из способов определить, используется ли контроллер домена сервером Exchange Server, заключается в повышении уровня ведения журнала диагностики для компонента Топология службы MSExchangeDSAccess до значения Минимум. Если в журнале не наблюдается событие MSExchangeDSAccess с идентификатором 2080, можно с уверенностью игнорировать эту ошибку.

Важно!
Подобное поведение наблюдалось только в средах со смешанным режимом во время использования Exchange 2000 Server с пакетом обновления 2 (SP2) для определенных пользовательских атрибутов, связанных с безопасностью, таких как tokenGroups и tokengroupsGlobalandUniversal. Эти атрибуты использовались для определения групп безопасности, членом которых является пользователь, и, соответственно, разрешений, которыми обладает пользователь для доступа к ресурсам безопасности, таким как общие папки, требующим выполнения сервером Exchange Server запроса к контроллеру домена, полномочному для домашнего домена пользователя. Полномочный контроллер домена может находиться на удаленном сайте, а запросы от большого количества пользователей удаленных доменов, получающих доступ к локальным общим папкам, могут привести к длительным задержкам RPC.

Дополнительные сведения о подобном поведении см. в следующем разделе блога разработчиков сервера Exchange Server:

  • Сервер Exchange не всегда использует локальные глобальные каталоги

    Примечание.
    Ссылки на блоги предоставляются, чтобы облегчить поиск необходимых технических сведений. Содержимое и URL-адрес каждого блога могут изменяться без предварительного уведомления.

Чтобы устранить эту ошибку, выполните указанные ниже действия.

  • Убедитесь, что все сетевые подключения к контроллеру домена работоспособны и поддерживают трафик ICMP.

  • Изучите рекомендации, изложенные в указанных ниже статьях.

    • Дополнительные сведения о счетчиках производительности LDAP Read Time и других счетчиках, которые можно использовать для устранения неполадок с Active Directory, см. в разделе «Решение проблем, связанных с Active Directory» Руководства по устранению неполадок с сервером Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588) (на английском языке). Эта статья также содержит сведения о том, как повысить производительность работы службы Active Directory.

    • Дополнительные сведения о достижении максимальной производительности службы Active Directory см. в разделе, описывающем настройку интеграции со службой Active Directory, в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

    • Дополнительные сведения о способах обеспечения высокого уровня доступности серверов Active Directory см. в подразделах «Обеспечение надежного доступа к Active Directory и службе доменных имен (DNS)» раздела «Меры обеспечения отказоустойчивости на уровне системы» Руководства по обеспечению высокого уровня доступности Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47571) (на английском языке).

    • Сведения по вопросам пропускной способности сети см. в части, касающейся производительности сети из раздела, описывающего общие сведения о производительности сервера Exchange, в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).


Среднее время задержки поиска LDAP превысило 50 миллисекунд
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-03-14

Анализатор Microsoft Exchange содержит подсистему сбора данных о производительности, используемую для запроса объектов счетчиков производительности на компьютерах с Exchange 2000 Server или Exchange Server 2003. Эта подсистема собирает данные счетчика производительности LDAP Search Time объекта производительности MSExchangeDSAccess Process для анализа.

Счетчик производительности LDAP Search Time показывает время в миллисекундах, которое требуется для выполнения поисковых запросов протокола Lightweight Directory Access Protocol (LDAP). Анализатор Exchange получает выборочные данные каждые 5 секунд на протяжении 5 минут. Затем анализатор Exchange сообщает максимальное значение счетчика производительности за время сбора данных. Если среднее значение превышает 50 миллисекунд, анализатор сервера Exchange выводит предупреждение.

Высокая задержка поиска LDAP может быть вызвана запаздыванием удаленного вызова процедур (RPC) и увеличением очередей. Высокие задержки поиска LDAP обычно указывают на одну из следующих проблем:

  • Проблемы производительности, связанные с сетевыми подключениями к контроллеру домена.

  • Проблемы производительности самого контроллера домена.

Примечание.
Задержки LDAP обычно выше при подключении пользователя к контроллерам домена, расположенным на физически других сайтах. В то же время рекомендованные максимальные задержки, указанные в этой статье, должны в целом выполняться.

Если контроллер домена, зарегистрировавший такое предупреждение, физически расположен на другом сайте, можно пропустить ошибку, если известно, что этот контроллер домена не используется сервером Exchange Server. Один из способов определить, используется ли контроллер домена сервером Exchange Server, заключается в повышении уровня ведения журнала диагностики для компонента Топология службы MSExchangeDSAccess до значения Минимум. Если вы не видите события MSExchangeDSAccess с идентификатором 2080, можно безопасно игнорировать это предупреждение.

Чтобы устранить это предупреждение, выполните указанные ниже действия.

  • Убедитесь, что все сетевые подключения к контроллеру домена работоспособны и поддерживают трафик ICMP.

  • Изучите рекомендации, изложенные в указанных ниже статьях.

    • Дополнительные сведения о счетчиках производительности LDAP Read Time и других счетчиках, которые можно использовать для устранения неполадок с Active Directory, см. в разделе «Решение проблем, связанных с Active Directory» Руководства по устранению неполадок с сервером Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588) (на английском языке). Эта статья также включает в себя сведения об улучшении производительности Active Directory.

    • Для получения дополнительных сведений о достижении максимальной производительности Active Directory, см. раздел «Настройка интеграции Active Directory» в Руководство по производительности и масштабируемости Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

    • Дополнительные сведения о способах обеспечения высокого уровня доступности серверов Active Directory см. в подразделах «Обеспечение надежного доступа к Active Directory и службе доменных имен (DNS)» раздела «Меры обеспечения отказоустойчивости на уровне системы» Руководства по обеспечению высокого уровня доступности Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47571) (на английском языке).

    • Для получения сведений о пропускной способности сети см. подраздел Network Performance раздела «Понимание производительности Exchange» Руководство по производительности и масштабируемости Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).


Максимальная задержка поиска LDAP превысила 100 миллисекунд
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-03-14

Анализатор Microsoft Exchange содержит подсистему сбора данных о производительности, используемую для запроса объектов счетчиков производительности на компьютерах с Exchange 2000 Server или Exchange Server 2003. Эта подсистема собирает данные счетчика производительности LDAP Search Time объекта производительности MSExchangeDSAccess Process для анализа.

Счетчик производительности LDAP Search Time показывает время в миллисекундах, которое занимает выполнение запроса на LDAP-поиск (Lightweight Directory Access Protocol). Анализатор Exchange получает выборочные данные каждые 5 секунд на протяжении 5 минут. Затем анализатор Exchange сообщает максимальное значение счетчика производительности за время сбора данных. Если максимальное значение превышает 100, анализатор Exchange выводит сообщение об ошибке.

Причинами больших задержек LDAP-поиска могут быть большие задержки удаленных вызовов процедур и большие очереди. Большие задержки LDAP-поиска обычно указывают на одну из следующих проблем:

  • Проблема производительности сетевого подключения к контроллеру домена.

  • Проблемы производительности самого контроллера домена.

Примечание.
Задержки LDAP обычно больше, когда пользователи подключаются к контроллерам доменов, которые находятся на других физических узлах. Однако рекомендуемые максимальные задержки, указываемые в этой статье, как правило, не должны превышаться.

Серверы Exchange Server опрашивают серверы глобального каталога, не входящие в домен, каждые 15 минут для обновления списка серверов глобального каталога и контроллеров домена. Поскольку некоторые из этих серверов каталогов могут быть удаленными, при выполнении таких запросов могут возникать длительные задержки. Это приемлемо, если такие запросы выполняются нечасто (их количество в секунду не превышает 0,5).

Когда контроллер домена, зарегистрировавший эту ошибку в журнале, находится на другом физическом узле, можно, ничем не рискуя, проигнорировать эту ошибку, если есть возможность определить, что контроллер домена, сообщающий об этой ошибке, не используется сервером Exchange. Один из способов определить, используется ли контроллер домена сервером Exchange Server, заключается в повышении уровня ведения журнала диагностики для компонента Топология службы MSExchangeDSAccess до значения Минимум. Если в журнале не наблюдается событие MSExchangeDSAccess с идентификатором 2080, можно с уверенностью игнорировать эту ошибку.

Важно!
Подобное поведение наблюдалось только в средах со смешанным режимом во время использования Exchange 2000 Server с пакетом обновления 2 (SP2) для определенных пользовательских атрибутов, связанных с безопасностью, таких как tokenGroups и tokengroupsGlobalandUniversal. Эти атрибуты применялись для определения групп безопасности, членом которых является пользователь, и, соответственно, разрешений, которыми обладает пользователь для доступа к ресурсам безопасности, таким как общие папки, требующим выполнения сервером Exchange Server запроса к контроллеру домена, полномочному для домашнего домена пользователя. Полномочный контроллер домена может находиться на удаленном сайте, а запросы от большого количества пользователей удаленных доменов, получающих доступ к локальным общим папкам, могут привести к длительным задержкам RPC.

Дополнительные сведения об этом алгоритме поведения см. в следующих статьях электронных журналов по серверу Exchange:

  • Сервер Exchange не всегда использует локальные глобальные каталоги

    Примечание.
    Ссылки на блоги предоставляются, чтобы облегчить поиск необходимых технических сведений. Содержимое и URL-адрес каждого блога могут изменяться без предварительного уведомления.

Чтобы устранить эту ошибку, выполните указанные ниже действия.

  • Убедитесь, что все сетевые подключения к контроллеру домена работоспособны и поддерживают трафик ICMP.

  • Изучите рекомендации, изложенные в указанных ниже статьях.

    • Дополнительные сведения о счетчиках производительности LDAP Read Time и других счетчиках, которые можно использовать для устранения неполадок с Active Directory, см. в разделе «Решение проблем, связанных с Active Directory» Руководства по устранению неполадок с сервером Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588) (на английском языке). Эта статья также содержит сведения о том, как повысить производительность работы службы Active Directory.

    • Дополнительные сведения о достижении максимальной производительности службы Active Directory см. в разделе, описывающем настройку интеграции со службой Active Directory, в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

    • Дополнительные сведения о способах обеспечения высокого уровня доступности серверов Active Directory см. в подразделах «Обеспечение надежного доступа к Active Directory и службе доменных имен (DNS)» раздела «Меры обеспечения отказоустойчивости на уровне системы» Руководства по обеспечению высокого уровня доступности Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47571) (на английском языке).

    • Сведения по вопросам пропускной способности сети см. в части, касающейся производительности сети из раздела, описывающего общие сведения о производительности сервера Exchange, в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).


Не удается идентифицировать указанный шлюз Exchange
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-08-08

Средство анализатора сервера Microsoft® Exchange запрашивает в службе каталогов Active Directory® имя (cn) каждого объекта каталога, относящегося к классу msExchExchangeServer, чтобы определить, существует ли соответствие для указанного пользователем сервера шлюза Exchange.

Значение cn — это строка, которая содержит краткое имя компьютера сервера Exchange.

Если анализатору сервера Exchange не удается найти соответствие значению cn для указанного пользователем сервера шлюза Exchange в службе Active Directory, на экран выводится сообщение об ошибке.

Эта ошибка указывает, что справедливо одно из следующих условий:

  • Указанный пользователем сервер шлюза Exchange не существует в организации локального сервера Exchange.

  • Указанный пользователем сервер шлюза Exchange неправильно введен.

Чтобы устранить эту ошибку, убедитесь, что указанный сервер шлюза Exchange был введен правильно, а затем повторите операцию.

Внимание!
Если при использовании оснастки ADSI Edit (ADSI — Active Directory Service Interfaces), средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3 неправильно изменить атрибуты объектов Active Directory, могут возникнуть серьезные неполадки. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих продуктов. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Чтобы проверить значение (cn) имени сервера

  1. С помощью оснастки ADSI Edit или подобного средства найдите объект-сервер в Active Directory.

    Атрибут CN может быть найден по адресу:

    Копировать код
    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Servers,CN=Server.


Длина очереди классификатора превышает пороговое значение
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-02-13

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов о показаниях счетчиков производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности получает данные со счетчика производительности Categorizer Queue Length объекта с оцениваемой производительностью SMTP Server для анализа данных о производительности.

Если анализатор сервера Exchange определяет, что в течение временного интервала снятия отсчета значение счетчика Categorizer Queue Length превысило максимальное значение, равное 10, анализатор сервера Exchange выводит на экран сообщение об ошибке.

Счетчик SMTP Server\Categorizer Queue Length показывает количество сообщений в очереди классификатора SMTP (Simple Mail Transfer Protocol), ожидающих поиска атрибутов службы каталогов с использованием серверов глобального каталога.

Классификатор выполняет следующие основные операции:

  • Разрешает и проверяет достоверность всех получателей.

  • Определяет пределы и ограничения для всех получателей.

  • При необходимости расширяет списки рассылки.

  • Определяет, предназначено ли сообщение для локальной или удаленной доставки

Эта ошибка указывает на возможность проблем с производительностью сервера или сети, с DSAccess (Directory Service Access), со службой каталогов Active Directory® или свидетельствует о простоях основных серверов в организации сервера Exchange. Увеличение показаний счетчика Categorizer Queue Length может указывать на медленную реакцию или отсутствие ответа при обращении к службе Active Directory либо при передаче сообщений для локальной доставки или в очередь SMTP. Это может привести к задержкам доставки почты.

Чтобы устранить эту ошибку:

  • Убедитесь, что для сервера Exchange доступны в достаточном объеме ресурсы Active Directory. К необходимым ресурсам относятся контроллеры домена и серверы глобального каталога. Рекомендуемое соотношение между числом процессоров сервера Exchange и числом процессоров со сходным быстродействием на сервере глобального каталога равно 4:1.

  • Находясь в диспетчере Exchange, убедитесь, что все контроллеры домена, перечисленные на вкладке DSAccess сервера Exchange, функционируют правильно. К ним относятся серверы, перечисленные в списке ConfigDC, контроллер домена и роли сервера глобального каталога.

  • Ведите наблюдение за производительностью сети между сервером Exchange и выбранными для него контроллерами домена и серверами глобального каталога, чтобы определить наличие узких мест в работе сети.

  • Наблюдайте за использованием ресурсов процессора на сервере Exchange, а также за использованием ресурсов процессора процессом Inetinfo.exe. Сюда входит компонент классификатора.

  • Убедитесь в работоспособности относящихся к Exchange объектов пользователей и групп, используя для этого объект конфигурации e2kdsinteg из службной программы ConfigDSInteg, входящей в состав средств развертывания Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=21231). Объекты, имеющие адреса неправильного формата, или неполные сведения могут быть причиной задержек в определении получателей и задержки классификации.

Дополнительные сведения

Дополнительные сведения об устранении проблем производительности сервера Exchange см. в разделе, посвященном устранению неполадок, связанных с производительностью сервера Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).


Отсутствует файл CDO.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить наличие нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange определяет, что отсутствует один или несколько файлов, отображается сообщение об ошибке. Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если это не устранит ошибку, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <диск>:\setup\i386\setup, где <диск> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-значный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Доступно обновление CimWin32.dll
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-09-19

Чтобы определить версию операционной системы Microsoft Windows®, под управлением которой работает компьютер сервера Exchange, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Значение CurrentVersion, равное4.0, указывает, что компьютер сервера Exchange работает под управлением Microsoft Windows NT® Server 4.0. Значение, равное 5.0, указывает, что компьютер сервера Exchange работает под управлением Windows 2000 Server, а значение, равное 5.2, указывает, что на компьютере сервера Exchange установлена операционная система Windows Server™ 2003.

Анализатор сервера Exchange также запрашивает WMI-класс (Microsoft Windows Management Instrumentation) CIM_Datafile, чтобы определить значение, установленное для ключа Version файла Cimwin32.dll.

Анализатор сервера Exchange выводит на экран сообщение, содержащее рекомендации, если выполняются следующие условия:

  • Компьютер сервера Exchange работает под управлением Windows 2000 Server.

  • Значение ключа Version соответствует конкретной версии файла Cimwin32.dll.

Для файла Cimwin32.dll существует обновление, которое позволяет повысить эффективность работы анализатора сервера Exchange.

Чтобы устранить эту проблему, прочитайте и примените рекомендации, содержащиеся в базе знаний Майкрософт, в статье 820608, сообщающей, что класс CIM_DataFile возвращает некорректное или нулевое значение для файлов, размер которых превышает 2 ГБ в Windows 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=820608).


На производительность сервера влияют клиентские приложения
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange обнаружил наличие клиентских компьютеров особого типа или приложений клиентской части, которые могут увеличивать загрузку сервера в организации Exchange.

Загрузка сервера может повышаться в результате работы многих видов приложений. Если загрузка выросла, следует выявить, какие приложения выполняют пользователи, а затем принять решение, нужно ли вводить ограничения для пользователей на выполнение определенных приложений. Работа некоторых приложения, связанная с электронной почтой (как приложений независимых разработчиков, так и встраиваемых модулей Microsoft Office Outlook®), может привести к увеличению загрузки сервера. Если на сервере выросли задержки удаленных вызовов процедур или повысилась загрузка, рекомендуется определить причину возникновения таких проблем.

Чтобы выявить пользователей, у которых велико время задержек или работа которых ведет к повышению загрузки сервера, можно воспользоваться средством наблюдения за пользователями сервера Exchange (ExMon). Чтобы загрузить программу ExMon, посетите центр загрузки Майкрософт (http://go.microsoft.com/fwlink/?LinkId=54983).

Процедура

Чтобы устранить причину появления этого предупреждения

  • С помощью ExMon определите, какие пользователи вызывают повышение загрузки сервера. Затем обратитесь к этим пользователям и определите, вызвана ли дополнительная загрузка работой следующих приложений:

    • Клиентские встраиваемые модули независимых разработчиков

    • Устройства синхронизации рабочего стола, такие как Exchange ActiveSync® или Blackberry

    • Другие MAPI-приложения, такие как модуле поиска на рабочем столе

    Если эти приложения не требуются для работы или для них опубликованы исправления, отключите или обновите данные приложения, чтобы снизить загрузку до приемлемого уровня.

  • Установите для клиентских компьютеров, работа которых сильно загружает сервер (особенно компьютеры с длительными задержками по операциям Restrict, SetColumns или FindRow), использование Exchange в режиме кэширования. Режим кэширования Exchange защищает сервер от большей части избыточного трафика удаленных вызовов процедур.

    Кроме того, попросите пользователей, в папках которых много элементов, заархивировать старые данные в PST-файл. Если же эти пользователи хотят оставить свои данные на сервере, попросите их переместить старые элементы в новые папки.

    Рекомендуется оставить в папках «Входящие», «Календарь», «Отправленные», «Контакты» и «Удаленные» не более 5 000 элементов.
Примечание.
Некоторые приложения способны существенно повысить загрузку сервера без большого количества MAPI-операций. Это объясняется тем, что для выполнения ряда операций требуется больше ресурсов, чем для других. Небольшое количество ресурсоемких операций заметно замедляет производительность сервера. В средстве ExMon для таких пользователей сообщается об относительно высокой загрузке процессора без наличия большого числа MAPI-операций.

Дополнительные сведения

  • Дополнительные сведения о производительности сервера Exchange см. в руководстве Exchange Server 2003 Performance and Scalability Guide (http://go.microsoft.com/fwlink/?LinkId=47576) (Руководство по производительности и масштабируемости Exchange Server 2003).

  • Дополнительные сведения об устранении проблем в производительности сервера Exchange см. в документе Troubleshooting Microsoft Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588) (Устранение неполадок, связанных с производительностью Microsoft Exchange Server 2003).

  • Дополнительные сведения об устранении неполадок, связанных с производительностью клиентов Outlook, см. в документе «Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803) (Пользователи Outlook испытывают снижение производительности компьютера при работе с папкой, содержащей много элементов, на сервере с Exchange Server 2003 или Exchange 2000 Server).

  • Дополнительные сведения о программном обеспечении поиска на рабочем столе см. в статье 905184 базы знаний Майкрософт «Exchange 2000 Server and Exchange Server 2003 performance may be affected when desktop search engine software is running on Outlook or other MAPI client computers» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184) (На производительность Exchange 2000 Server и Exchange Server 2003 может влиять выполнение программного обеспечения поиска на рабочем столе на клиетских компьютерах с Outlook или другими MAPI-клиентами).


Путь к переменной TEMP кластера указан неверно или отличается от заданного по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить значение переменной среды на некластерном сервере Exchange, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

Если анализатор сервера Exchange выполняется на виртуальном сервере Exchange в кластере серверов Microsoft Windows®, он не считывает куст реестра HKLM. Вместо этого считывается следующая запись реестра:

HKEY_USERS\< Идентификатор SID учетной записи службы кластеров >\Environment\TEMP

Если анализатор сервера Exchange обнаруживает, что переменная среды TEMP содержит путь, недоступный в текущей системе, выводится предупреждение. Если данный путь недопустим, это может привести к сбою доставки почты в организации. Если анализатор сервера Exchange имеет конфигурацию по умолчанию, он ожидает, что будет указан путь «%USERPROFILE%\Local Settings\Temp». Хотя этот путь можно изменить, указав другие местоположения, после применения исправления или обновления и перезапуска узла кластера система в некоторых случаях предполагает, что снова установлен путь по умолчанию.

С помощью переменной среды TEMP указывается папка в файловой системе, используемая приложениями, которым требуется временное рабочее пространство. Переменная TEMP обычно используется приложениями, например сервером Exchange. Путь для каждой переменной, как правило, указывается относительно контекста приложения. Например, в процессах службы банка данных Microsoft Exchange папка TEMP используется в качестве временного хранилища при выполнении различных операций, таких как преобразование сообщений и перемещение почтовых ящиков.

Чтобы устранить причину появления этого предупреждения

  1. Войдите на узел кластера с учетной записью службы кластеров.

  2. Щелкните правой кнопкой мыши Мой компьютер и выберите команду Свойства.

  3. Щелкните Дополнительно.

  4. Щелкните Переменные среды.

  5. В разделе Пользовательские переменные для <имя учетной записи> выберите TEMP, а затем нажмите кнопку Изменить.

  6. В поле значения Переменная введите путь по умолчанию для переменной среды TEMP и нажмите кнопку ОК.

  7. Нажмите кнопку ОК еще раз, чтобы закрыть диалоговое окно «Переменные среды», а затем снова нажмите кнопку ОК, чтобы закрыть диалоговое окно «Свойства системы».

  8. Перезапустите узел, чтобы применить изменения.

  9. Повторите шаги 1 — 8 для каждого узла кластера, где данный параметр отличается от заданного по умолчанию.


Необходимо создать несколько реплик автономной адресной книги
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-08-14

Средство анализатора сервера Microsoft® Server запрашивает WMI-класс Exchange_PublicFolder в пространстве имен root\MicrosoftExchangeV2, чтобы определить количество записей в ключе ReplicaList. Количество записей представляет количество реплик автономной адресной книги, имеющих в каждой административной группе.

Анализатор сервера Exchange Server также запрашивает службу каталогов Active Directory®, чтобы определить количество объектов базы данных общих папок, имеющих набор атрибутов legacyExchangeDN. Количество объектов, имеющих этот набор атрибутов, представляет количество хранилищ общих папок, имеющихся в организации.

Если анализатор сервера Exchange Server определит, что только одна реплика автономной адресной книги существует в организации Exchange, имеющей несколько хранилищ общих папок, то отображается сообщение с рекомендациями.

В целях обеспечения доступности и повышения производительности рекомендуется развернуть несколько реплик каждой автономной адресной книги. В некоторых случаях наличие нескольких реплик автономной адресной книги может повысить производительность и гибкость системы. В крупных организациях Exchange использование единственной реплики автономной адресной книги может привести к существенному повышению загрузки системы. Во всех организациях Exchange использование единственной реплики автономной адресной книги является основным источником ошибок.

Хотя наличие нескольких реплик означает дополнительный сетевой трафик репликации, рекомендуется все же использовать несколько реплик. Следует использовать по крайней мере две реплики для каждой автономной адресной книги.

Чтобы добавить реплики автономной адресной книги к организации Exchange

  1. Откройте системный диспетчер Exchange

  2. Разверните узел Папки, щелкните правой кнопкой мыши Общие папки и выберите Просмотреть системные папки. Примечание. Если узел Папки не отображается, разверните узел Административные группы, а затем — административную группу, содержащую системные папки, которые требуется просмотреть. Щелкните правой кнопкой мыши Общие папки и выберите Просмотреть системные папки.

  3. Разверните контейнер Автономная адресная книга и щелкните правой кнопкой мыши автономную адресную книгу, для которой требуется добавить реплику, выбрав в появившемся раскрывающемся списке пункт Свойства.

  4. Выберите вкладку Репликация, а затем щелкните Добавить, чтобы выбрать хранилище общих папок, в которое требуется добавить реплику. Нажмите кнопку ОК, чтобы завершить процедуру.

  5. Повторите шаги 3 и 4 для всех дочерних объектов контейнера автономных адресных книг, для которых требуется добавить реплику. Благодаря этому будет обеспечено, что все поддерживаемые форматы будут включены в реплику, а именно при выборе Добавить будут добавляться дочерние объекты форматов OAB Version 2, OAB Version 3a и т. д.

Дополнительные сведения о способах управления и настройки автономных адресных книг см. в следующих статьях по Microsoft Exchange Server, находящихся на веб-узле Microsoft TechCenter:

  • Статья, посвященная важным вопросам работы с автономной адресной книгой (http://go.microsoft.com/fwlink/?LinkId=57581)

  • Статья, посвященная работе с хранилищами Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).

  • Руководство с рекомендациями по работе автономной адресной книгой (http://go.microsoft.com/fwlink/?LinkId=47583).

  • Статья, посвященная формату OAB Version 4 автономной адресной книги в пакете обновления 2 (SP2) для Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=53097).

  • Статья, посвященная совместному использованию пакета обновления 2 (SP2) для Outlook 2003 и формата OAB Version 4 из пакета обновления 2 (SP2) для Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=53099).


Подключение к контроллеру домена службы обновления получателей
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-05-18

Средство анализатора сервера Microsoft® Exchange открывает TCP-сокет для порта 389 на каждом контроллере домена. Это подключение выполняется с помощью процессора пользовательских объектов, который возвращает определенную строку, если подключение установлено успешно.

Если анализатор сервера Exchange не получит 389 Available в качестве части возвращенной строки, на экран будет выведено предупреждение.

Это предупреждение указывает, что контроллер домена не ответил на попытку подключения к TCP-порту 389. TCP-порт 389 — это порт по умолчанию для LDAP-взаимодействий (Lightweight Directory Access Protocol). Если выводится данное предупреждение, может иметь место любое из следующих условий:

  • Возможны проблемы с соединением между анализатором сервера Exchange и контроллером домена.

  • Может быть выключен сервер.

  • Сервер может быть списан.

Существует множество причин, по которым LDAP-запросы могут некорректно обрабатываться контроллером домена, когда анализатор сервера Exchange запрашивает контроллер домена.

Чтобы устранить причину появления этого предупреждения

  1. Убедитесь, что учетная запись, под которой выполняется анализатор сервера Exchange, имеет разрешения на запрос контроллера домена. Необходимо иметь разрешения уровня пользователя в домене, в котором функционирует контроллер домена. Дополнительные сведения о разрешениях, необходимых для работы анализатора сервера Exchange, см. в файле справки, поставляемом с анализатором сервера Exchange. Чтобы открыть файл справки анализатора сервера Exchange, в анализаторе сервера Exchange щелкните Справка, а затем — Справка средства анализатора сервера Microsoft Exchange.

  2. Убедитесь в отсутствии сетевых экранов и ограничений портов между компьютером, на котором выполняется анализатор сервера Exchange, и неотвечающим контроллером домена.

  3. Проверьте подключение контроллера домена к сети и правильность его работы.

  4. Убедитесь, что сервер не был списан и по-прежнему указан в списке как контроллер домена, доступный для сервера Exchange.

Дополнительные сведения см. в следующих статьях базы знаний Майкрософт:

  • Статья 319065, содержащая инструкции по работе со службой обновления получателей Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319065).

  • Статья 816103, содержащая инструкции по использованию команды Portqry для устранения неполадок подключений к Active Directory (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103).


Доступно обновление содержимого
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-06-21

Дополнительные сведения см. на веб-странице, посвященной загрузке документации по Exchange Server 2007 (может быть на английском языке).


Для хранилища общих папкок включена индексация содержимого, но не запланированы обновления
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server запрашивает службу каталога Active Directory, чтобы определить значение атрибута msExchCIAvailable для каждого хранилища общих папок. Его значение показывает, включена ли индексация содержимого для хранилища общих папок. Значение True показывает, что для хранилища общих папок существует индекс содержимого и выбран параметр Exchange System Manager This index is currently available for searching by clients (Этот индекс доступен для поиска клиентами). Значение False показывает, что для хранилища общих папок существует индекс содержимого, но не выбран параметр Exchange System Manager This index is currently available for searching by clients (Этот индекс доступен для поиска клиентами). Значение <Not Set> означает, что для хранилища общих папок не существует индекса содержимого.

Кроме того, средство анализа Exchange Server также запрашивает Active Directory, чтобы выяснить значение атрибутов msExchCIRebuildSchedule для каждого хранилища общих папок. Значение этого атрибута показывает параметр расписания пересоздания индекса содержимого. Этот атрибут хранится в виде строки восьмизначных чисел с 82 парами шестнадцатеричных значений.

Если средство анализа Exchange Server определяет, что значение атрибута msExchCIAvailable установлено как True, но значение строки восьмизначных чисел msExchCIRebuildSchedule установлено как Never run, появляется предупреждение.

Рекомендуется установить интервал запланированных добавочных обновлений не реже одного раза в день. Можно запланировать и более частые обновления, поскольку индекс актуален только на момент заполнения. Нерегулярно обновляемые индексы могут привести к неточным и устаревшим результатам.

Также следует учесть время, которое требуется для заполнения с приращением. Например, обычно обновления с приращением включаются в начале каждого часа. В то же время если обновление длится более часа, следующее обновление начнется в начале следующего часа.

Как правило, если хранилище общих папок занимает 6 ГБ или менее, можно ежечасно выполнять обновления с приращением. Если хранилище превышает 6 ГБ или активно используется память сервера, обновления индекса можно выполнять реже.

Настройка полнотекстового обновления индекса данного хранилища общих папок

  1. Откройте системный диспетчер Exchange.

  2. Разверните Административные группы, вашу административную группу, Серверы, ваш сервер, группу хранения, щелкните правой кнопкой папку хранилища и выберите Свойства. Если узел Административные группы не показывается программой Exchange System Manager, откройте Серверы, щелкните правой кнопкой свой сервер и щелкните Свойства.

  3. На вкладке Полнотекстовая индексация выберите вариант, отличный от Никогда не запускать.

  4. Если выбрано Использовать особое расписание, нажмите кнопку Настройка, настройте свое расписание и нажмите кнопку OK.

  5. Нажмите кнопку Применить.

Для получения дополнительных сведений о полнотекстовой индексации сервера Exchange см. раздел Рекомендации по развертывания полнотекстовой индексации (http://go.microsoft.com/fwlink/?linkid=5223).


Для данного хранилища почтовых ящиков индексация содержимого включена, но обновления не запланированы
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchCIAvailable для каждого хранилища почтовых ящиков. Значение этого атрибута указывает, включена ли индексация содержимого для данного хранилища почтовых ящиков. Значение "Истина" указывает на то, индекс содержимого для хранилища почтовых ящиков существует и что выбран параметр диспетчера Exchange " Разрешить клиентам выполнять поиск по этому индексу". Значение "Ложь" указывает на то, индекс содержимого для хранилища почтовых ящиков существует, но параметр диспетчера Exchange "Разрешить клиентам выполнять поиск по этому индексу" удален. Значение <Не установлено> указывает на то, что для данного хранилища почтовых ящиков индекс содержимого не существует.

Анализатор сервера Exchange Server также запрашивает службу Active Directory, чтобы определить значение атрибута msExchCIRebuildSchedule каждого хранилища почтовых ящиков. Значение данного атрибута указывает на перестройку параметров расписания для индекса содержимого. Данный атрибут хранится в виде строки октета с 82 парами шестнадцатиричных значений.

Если анализатор сервера Exchange обнаруживает, что для атрибута msExchCIAvailable установлено значение "Истина", но значение строки октета для атрибута msExchCIRebuildSchedule преобразуется в "Никогда не выполнять", на экран выводится предупреждение.

Интервал обновления рекомендуется настроить так, чтобы было запланировано выполнение добавочных обновлений, по меньшей мере, раз в день. Может понадобиться запланировать более частое выполнение обновлений, т.к. текущий индекс после последнего заполнения не изменяется. Если индексы регулярно не обновлять, это может привести к неточным и устаревшим результатам.

Следует также учитывать время, которое занимает операция добавочного заполнения. Например, типовое расписание предусматривает добавочные обновления в начале каждого часа. Однако, если обновление длится более одного часа, следующее заполнение начинается в начале следующего часа.

В общем случае, если хранилище почтовых ящиков имеет объем не менее 6 ГБ, добавочные обновления можно выполнять ежечасно. Если хранилище почтовых ящиков имеет объем более 6 ГБ или сервер использует больший объем памяти, может понадобиться обновлять индекс реже.

Чтобы настроить интервал обновления полнотекстовой индексации для конкретного хранилища почтовых ящиков

  1. Откройте диспетчер Exchange.

  2. Разверните узел Административные группы, последовательно разверните административную группу, узел Серверы, ваш сервер, вашу группу хранения, щелкните правой кнопкой мыши ваше хранилище почтовых ящиков и в контекстном меню выберите пункт Свойства. Если узел "Административные группы" не отображается в окне диспетчера Exchange, разверните узел Серверы, щелкните правой кнопкой мыши ваш сервер и затем выберите пункт Свойства.

  3. На вкладке Полнотекстовая индексация выберите параметр, отличный от параметра Никогда не выполнять.

  4. Если выбран параметр Использовать настраиваемое расписание, щелкните пункт Настройка, настройте свое собственное расписание и затем нажмите кнопку ОК.

  5. Нажмите кнопку Применить.

Дополнительные сведения о конфигурации и устранении неполадок полнотекстовой индексации в Exchange см. в базе знаний Майкрософт в статье, 822932, "HOW TO: Configure Full-Text Indexing on Mailbox Stores in Exchange 2003" (Инструкции по настройке полнотекстовой индексации хранилищ почтовых ящиков в Exchange 2003) (http://go.microsoft.com/fwlink/?LinkID=3052&kbid=822932) и 319436, "How to configure full-text indexing on mailbox stores in Exchange 2000" (Инструкции по настройке полнотекстовой индексации хранилищ почтовых ящиков в Exchange 2003) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319436).

Для получения дополнительных сведений о полнотекстовой индексации для сервера Exchange см. раздел Рекомендации по развертыванию полнотекстовой индексации (http://go.microsoft.com/fwlink/?LinkId=5223).


Доступно обновление драйвера CQPCIDRV.SYS
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-08-14

Чтобы определить версию операционной системы Microsoft Windows®, под управлением которой работает компьютер сервера Exchange, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Значение CurrentVersion, равное 4.0, означает, что сервер Exchange работает под управлением операционной системы Microsoft Windows NT® Server 4.0. Значение, равное 5.0, означает, что сервер Exchange работает под управлением операционной системы Windows 2000 Server. Значение, равное 5.2, означает, что компьютер сервера Exchange работает под управлением операционной системы Windows Server™ 2003.

Анализатор сервера Exchange также проверяет WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Processor, чтобы определить значение ключа DataWidth.

Значение ключа DataWidth, равное 32, указывает, что сервер работает под управлением 32-разрядной версии операционной системы Windows, тогда как значение ключа DataWidth, равное 64, указывает, что сервер работает под управлением 64-разрядной версии операционной системы Windows.

Наконец, анализатор сервера Exchange запрашивает WMI-класс CIM_Datafile, чтобы определить значение ключа Version для файла CpqCiDrv.sys.

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Сервер Exchange работает под управлением Windows Server 2003.

  • Сервер Exchange работает в среде 64-разрядной версии операционной системы Windows.

  • Версия драйвера интерфейса управления HP Integrated Lights-Out, CPQCIDRV.sys, предшествует версии 1.8.

Эта ошибка указывает, что версия драйвера CpqCiDrv.sys, установленного на сервере, может быть причиной появления ошибок распределения памяти ядра.

Чтобы устранить эту проблему, следуйте рекомендациям поставщика, содержащимся в документе с идентификатором: c00688313 (http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c00688313).

Примечание.
Сведения о веб-узлах сторонних производителей в этом разделе предоставлены для оказания помощи в нахождении необходимой технической информации. URL-адреса могут быть изменены без предварительного уведомления.


Действие параметра CrashOnAuditFail
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, настроен ли параметр CrashOnAuditFail, средство анализатора приложения Microsoft® Exchange Server считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\LSA\CrashOnAuditFail

Если анализатор сервера Exchange обнаруживает, что значение параметра CrashOnAuditFail равно 2, на экран выводится сообщение об ошибке.

Назначением раздела CrashonAuditFail реестра является настройка сервера таким образом, чтобы конечным пользователям не был разрешен доступ к компьютеру в случае, когда журналы безопасности достигают заданного предельного размера. Запрет доступа в компьютер гарантирует, что данные аудита, которые в других обстоятельствах должны быть занесены в журнал, не будут потеряны.

При включении разделу CrashonAuditFail реестра присваивается значение, равное 1. Однако когда достигнут предельный размер журнала безопасности, сервер присваивает разделу реестра значение, равное 2, что, в свою очередь, останавливает обработку на сервере. Иногда этот процесс вызывает полный отказ или STOP 0xC0000244, также известный как ошибка останова. Как минимум, пользователи не смогут получить доступ к ресурсам сервера, и работа будет в значительной степени заторможена. Кроме того, когда сервер находится в этом состоянии, доступ к компьютеру возможен лишь для пользователей с разрешениями администратора.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» в Regedit.exe или Regedt32.exe.

Чтобы устранить эту ошибку

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\SYSTEM\currentcontrolset\Services

  3. Удалите вызванное значение CrashOnAuditFail (следует удалить значение полностью, а не только данные).

  4. Скопируйте журналы событий безопасности в отдельную папку. По умолчанию журналы событий безопасности (SecEvent.Evt) расположены в %SystemRoot%\System32\Config, где %SystemRoot% представляет собой путь для папки, где установлена операционная система Microsoft Windows®.

  5. Откройте средство просмотра событий, щелкните правой кнопкой мыши Безопасность и затем щелкните Свойства.

  6. На странице Безопасность — свойства щелкните Очистить журнал. После получения приглашения сохранить журнал щелкните Да и затем укажите папку, в которой следует сохранить файл журнала.

    Примечание На странице Безопасность — свойства можно также увеличить размер журнала, изменив поле Наибольший размер журнала и затем щелкнув Применить.

  7. Перезапустите сервер.

  8. Войдя в почтовый ящик Exchange, проверьте, чтобы пользователи могли получить доступ к ресурсам сервера.

  9. Повторно создайте раздел CrashonAuditFail реестра и установите для него значение, равное 1.

  10. Перезапустите сервер, чтобы параметры CrashonAuditFail вступили в действие.

  11. Периодически очищайте и сохраняйте журналы безопасности сервера, следя за тем, чтобы наибольший размер журнала не был превышен. Дополнительные сведения см. в базе знаний Майкрософт, в статье 312571 "The event log stops logging events before reaching the maximum log size" (Журнал событий прекращает регистрацию событий в журнале перед достижением максимального размера журнала) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=312571).

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986 "Description of the Microsoft Windows Registry" (Описание реестра Microsoft Windows) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о восстановлении после неисправности CrashOnAuditFail см. в следующих статьях базы знаний:

  • 232564 "STOP 0xC0000244 when security log full" (STOP 0xC0000244 — когда журнал безопасности полон) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232564)

  • 829082, "You receive a "Stop error 0xC0000244 {Audit Failed}" error message when the crashonauditfail registry key is set to 1 on a Windows Server 2003-based computer" (Сообщение об ошибке "Stop error 0xC0000244 {Audit Failed}" выдается, когда разделу реестра crashonauditfail присвоено значение 1 на компьютере, работающем на основе Windows Server 2003) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=829082)


Список настраиваемых ссылок на общие папки
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-09

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, содержит ли атрибут msExchFolderAffinityCustom какие-либо имена серверов Exchange. Если анализатор сервера Exchange обнаруживает, что атрибут msExchFolderAffinityCustom содержит список имен серверов, то он выводит на экран сообщение о конфигурации не по умолчанию.

По умолчанию в Exchange Server 2003 для определения ссылок общих папок используются группы маршрутизации.

В Exchange Server 2007 для определения маршрутизации ссылок общих папок по умолчанию используются параметры стоимости маршрутизации службы каталогов Active Directory.

Если атрибут msExchFolderAffinityCustom содержит список имен серверов, на сервере Exchange настроены настраиваемые ссылки. The Атрибут msExchFolderAffinityCustom указывается для каждого сервера.

Рекомендуется использовать для ссылок общих папок конфигурацию по умолчанию. Однако может понадобиться создать список настраиваемых ссылок. Сообщение о конфигурации не по умолчанию является информационным сообщением. Никаких специальных действий выполнять не требуется.

Для возвращения к конфигурации по умолчанию в Exchange Server 2003 выполните следующие действия.

  1. Откройте диспетчер Exchange

  2. Найдите объект сервера, где настраиваются настраиваемые ссылки на общие папки. Имя сервера Exchange, на котором настраиваются настраиваемые ссылки на общие папки, указывается в сообщении анализатора сервера Exchange.

  3. Щелкните правой кнопкой мыши Server_Name и затем щелкните Свойства.

  4. На вкладке Ссылки на общие папки выберите Использовать маршрутизацию групп в раскрывающемся окне Параметры ссылок на общие папки.

  5. Нажмите Применить, затем ОК.
Для возвращения к конфигурации по умолчанию в Exchange Server 2007 выполните следующие действия.

  1. Следующий код является примером команды оболочки управления Exchange Set-PublicFolderDatabase, отключающей использование PublicFolderRefferalServerList для базы данных общих папок «MyServer\First Storage Group\Public Folder Database».
Копировать код
Set-PublicFolderDatabase -Identity "MyServer\First Storage Group\Public Folder Database" -UseCustomReferralServerList $false

Параметр UseCustomReferralServerList указывает, использовать ли значения стоимости серверов, указанные параметром PublicFolderReferralServerList. Если этому параметру установлено значение «$true», сервер использует стоимости параметра PublicFolderReferralServerList для ссылок общих папок. Если установлено значение «$false», сервер использует стоимости Active Directory.

Примечание.
При установке значения «$false» также очищается параметр PublicFolderReferralServerList.

Дополнительные сведения о команде оболочки управления Exchange Set-PublicFolderDatabase см. в документации Exchange Server 2007 в статье «Set-PublicFolderDatabase» (http://go.microsoft.com/fwlink/?LinkId=80813).

Для получения дополнительных сведений о репликации общих папках см. раздел Рекомендации по общим папкам сервера Exchange (http://go.microsoft.com/fwlink/?LinkId=46437).


Объект счетчика производительности баз данных недоступен
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Log Record Stalls/sec объекта производительности Database для анализа данных о производительности. Если данный счетчик не возвращает допустимые данные, выводится базовое сообщение.

Если допустимые данные не возвращаются модулем сбора данных о производительности, имеет место одно из сочетаний следующих условий:

  • Объект производительности Database отключен.

  • Объект счетчика производительности Database отсутствует или поврежден.

  • Для анализатора сервера Exchange не назначены разрешения, необходимые для получения доступа к объектам производительности.

Первые два условия могут иметь место в том случае, если реестр поврежден определенными расширяемыми счетчиками или изменен программами, основанными на инструментарии управления Windows® (WMI).

С помощью следующей процедуры можно исправить неполадки, связанные с первыми двумя условиями. Перед выполнением данной процедуры убедитесь, что анализатору сервера Exchange назначены соответствующие разрешения. Дополнительные сведения о разрешениях, требуемых для выполнения анализатора сервера Exchange, см. в справочной документации, включенной в анализатор сервера Exchange. Чтобы открыть справку, откройте анализатор сервера Exchange и нажмите клавишу F1.

Чтобы устранить эту ошибку

  1. Убедитесь, что включен объект производительности Database.

    1. Загрузите и установите средство списка расширяемых счетчиков производительности (Exctrlst.exe). Средство Exctrlst.exe можно загрузить на странице Exctrlst.exe: Extensible Performance Counter List (http://go.microsoft.com/fwlink/?LinkId=34436) (Exctrlst.exe: список расширяемых счетчиков производительности).

    2. Откройте окно средства Exctrlst.exe, щелкните Sort Order, а затем — Service.

    3. Найдите службу, сведения о которой поставляет данный объект производительности, и проверьте, что установлен флажок Performance Counters Enabled.

      Если флажок Performance Counters Enabled не установлен, установите его, а затем перезапустите связанную с нужными счетчиками производительности службу, чтобы проверить, что эти счетчики производительности работоспособны. Если счетчики производительности не работоспособны или флажок Performance Counters Enabled уже установлен, перейдите к выполнению шага 2.

  2. Повторно создайте отсутствующие или поврежденные счетчики производительности в соответствии с инструкциями статьи 300965 базы знаний Майкрософт по перестройке параметров библиотеки счетчиков производительности (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) .

  3. Если после выполнения процедуры, указанной в этой статье базы знаний, проблема не будет устранена, придется переустановить сервер Exchange в режиме Восстановление, а затем применить последние пакеты обновления для сервера Exchange.


Отсутствует файл DAVEX.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы проверить наличие нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange обнаруживает, что один или более файлов отсутствуют, на экран выводится сообщение об ошибке. Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если эта ошибка остается, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Не выполняется служба DHCP-клиента
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Service, чтобы определить значение ключа Started для службы DHCP-клиента. Если анализатор сервера Exchange обнаруживает, что ключ Started для службы DHCP-клиента на сервере Exchange имеет значение False, выводится предупреждение.

Это предупреждение указывает, что служба DHCP-клиента не выполняется. Служба DHCP-клиента выполняется динамические обновления доменной системы имен (DNS). Если служба DHCP-клиента не выполняется, возникнут сбои динамического обновления. Если на сервере Exchange не выполняется эта служба, чаще всего возникают неполадки потока почты.

Чтобы устранить эту неполадку, задайте для службы DHCP-клиента автоматическое обновление, а затем запустите эту службу.

Примечание.
Служба DHCP-клиента должна выполняться даже в том случае, если сервер настроен на использование статических IP-адресов, а не DHCP.
Чтобы включить службу DHCP-клиента

  1. Откройте оснастку Службы.

  2. В области сведений щелкните правой кнопкой мыши Служба DHCP-клиента и выберите команду «Свойства».

  3. На вкладке Общие в разделе Тип запуска выберите Авто.

  4. Нажмите кнопку Пуск, а затем — кнопку ОК.

Дополнительные сведения о службе DHCP-клиента см. в статье 264539 базы знаний Майкрософт «Dynamic DNS updates do not work if the DHCP client service stops» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264539) (Динамические обновления DNS не действуют, если остановлена служба DHCP-клиента).

Дополнительные сведения о протоколе динамического обновления DNS см. в статье 816592 базы знаний Майкрософт «How to configure DNS dynamic updates in Windows Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592) (Инструкции по настройке динамических обновлений в Windows Server 2003).


Доктор Ватсон не включен
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа сервера MicrosoftВ® Exchange считывает значение следующего параметра реестра, чтобы определить, установлена ли служебная программа «Доктор Ватсон» в операционной системе Microsoft Windows® как отладчик уровня приложений по умолчанию:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger

Если анализатор сервера Exchange обнаруживает, что значение для Debugger не начинается с drwtsn32, будет выведено сообщение о настройке не по умолчанию.

Это сообщение показывает, что Доктор Ватсон не включен. Отладчик уровня приложений, называемый «Доктор Ватсон», включен в состав Windows начиная с Windows NT®. Когда приложение завершается аварийно, ошибка может быть перехвачена программой «Доктор Ватсон», которая заносит в журнал различные данные, такие как данные платформы, список запущенных процессов, определение ошибочных процессов, дамп памяти ошибочных процессов, один или более стеков вызовов и указатель на саму ошибку. Большинство собранной информации является низкоуровневой отладочной информацией, которая предназначена для разработчика процесса, закончившегося аварийно.

Рекомендуется запускать Windows в режиме со включенным отладчиком уровня приложений. Если приложение «Доктор Ватсон» не включено и не используется альтернативный отладчик уровня приложений, рекомендуется включить приложение «Доктор Ватсон» с помощью следующей процедуры.

Как включить приложение «Доктор Ватсон»

  1. Откройте окно командной строки.

  2. В командной строке введите drwtsn32 -i.

Для получения дополнительных сведений о включении и отключении приложения «Доктор Ватсон» см. статью 188296 базы знаний корпорации Майкрософт «Как отключить приложение Доктор Ватсон для Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=188296).


Несоответствие имени компьютера DSA
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить значение параметра DSA Computer, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить значение атрибута name для каждого объекта сервера Exchange.

В последнюю очередь анализатор сервера Exchange Server запрашивает WMI-класс Win32_Service, чтобы определить значение ключа Started для службы кластеров (ClusSvc). Значение True означает, что служба кластеров запущена. Значение False указывает, что служба не запущена.

Если анализатор сервера Exchange обнаружит, что значение раздела реестра DSA Computer не соответствует значению атрибута объекта сервера name в службе каталогов Active Directory для любого компьютера сервера Exchange, который не работает в кластере серверов Windows, отображается сообщение об ошибке.

Чтобы устранить эту ошибку, необходимо изменить раздел реестра DSA Computer, чтобы он соответствовал значению атрибута name в службе каталогов Active Directory.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о редактировании реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить эту ошибку

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. В правой области дважды щелкните DSA Computer, введите правильное имя этого компьютера и нажмите кнопку ОК.

  4. Закройте редактор реестра и перезапустите компьютер сервера Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Отсутствует файл DSACCESS.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы проверить наличие нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»),

  • Mapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange обнаружит отсутствие одного или нескольких из перечисленных выше файлов, на экран будет выведено сообщение об ошибке. Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если эта ошибка продолжает оставаться, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Кэш конфигурации DSAccess заполнен
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-05-24

Средство анализатора сервера Microsoft® Exchange опрашивает WMI-класс Win32_PerfRawData_MSExchangeDSAccess_MSExchangeDSAccessCaches, чтобы определить текущее значение раздела TotalEntriesMemoryConfigurationData. Если анализатор обнаружит, что значение раздела TotalEntriesMemoryConfigurationData равняется общему размеру кэша конфигурации DSAccess (MaxMemoryConfig), отображается предупреждение.

DSAccess является внутренним компонентом серверов Exchange 2000 и Exchange Server 2003, который управляет доступом всех компонентов Exchange к службе каталогов Active Directory®. Основной функцией DSAccess является поддержка сведений о различных событиях и операциях, связанных с каталогом. Например, DSAccess обнаруживает топологию Active Directory и определяет доступность контроллеров домена и серверов глобальных каталогов, а также возможность их ответа на запросы. Кроме того, все запросы каталога, выполняемые внутренними компонентами Exchange, например, хранилищем Microsoft Exchange, маршрутизируются посредством DSAccess, например, разрешение получателей, поиск параметров конфигурации и прочее. Частью функционирования DSAccess является поддержка кэша в оперативной памяти, в котором хранятся некоторые из этих запросов на тот случай, если одни и те же сведения будут запрошены дважды, их можно будет получить из кэша DSAccess, а не посредством LDAP-запроса службы каталогов Active Directory.

Так как параметр по умолчанию максимального размера кэша конфигурации DSAccess был уменьшен с 25 мегабайтов (МБ) в Exchange 2000 Server до 5 мегабайтов в Exchange Server 2003, это предупреждение может появиться в любой из этих двух версий Exchange. Независимо от версии Exchange, которая отобразит это сообщение, неполадка должна быть устранена в кратчайшие сроки.

Значение MaxMemoryConfig часто используется вместе со значением MaxMemoryUser, с помощью которого можно управлять максимальным количеством памяти, которое могут использовать объекты данных пользователей в кэше DSAccess. При изменении или удалении значения MaxMemoryConfig как показано в следующей процедуре, необходимо соответственно изменить или удалить значение MaxMemoryUser, как описано в разделе Значение кэша пользователя DSAccess не является значением по умолчанию.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Увеличьте значение MaxMemoryConfig. Если раздел Instance0 или значение DWORD параметра MaxMemoryConfig не существуют, можно создать их вручную. Значение параметра реестра MaxMemoryConfig выражается в килобайтах (КБ); поэтому десятичное значение 15000 равняется 15 МБ. Если это значение существует, увеличьте его на 10 процентов. Если этого значения не существует, рекомендуется установить начальное значение равным 10 МБ.

  4. Закройте редактор реестра и перезапустите службу системного помощника Microsoft Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Значение кэша конфигурации DSAccess отличается от значения по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-17

Чтобы определить, изменен ли размер кэша объекта конфигурации DSAccess (Directory Service Access) относительно значения по умолчанию, средство анализатора сервера Microsoft® Exchange считывает следующие записи реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0\MaxMemoryConfig

Если анализатор сервера Exchange обнаружит, что параметр MaxMemoryConfig существует и настроен, на экран будет выведено сообщение о конфигурации, отличной от конфигурации по умолчанию.

MaxMemoryConfig — это параметр реестра Exchange 2000 Server, который больше не нужен в Exchange Server 2003. Параметр MaxMemoryConfig управляет максимальным объемом памяти, которую разрешено использовать объектам данных конфигурации в кэше конфигурации DSAccess. DSAccess — это внутренний компонент в приложениях Exchange 2000 Server и Exchange Server 2003, который управляет доступом всех компонентов Exchange к службе каталогов Active Directory®. Основная функция компонента DSAccess состоит в обслуживании сведений о различных событиях и операциях, относящихся к каталогам. Например, компонент DSAccess узнает топологию Active Directory и определяет, доступны ли контроллеры доменов и серверы глобального каталога и отвечают ли они на запросы. Кроме того, все запросы службы каталогов, посылаемые внутренними компонентами Exchange, такими как хранилище Microsoft Exchange, направляются через DSAccess, например, определение получателя, просмотры настроек конфигурации и другие. В качестве части этой работы компонент DSAccess обслуживает находящийся в памяти кэш результатов некоторых из этих запросов, чтобы в случае повторного запроса одних и тех же сведений, их можно было извлечь из кэша DSAccess вместо отправки еще одного LDAP-запроса (Lightweight Directory Access Protocol) в службу Active Directory.

В приложении Exchange 2000 Server размер кэша конфигурации первоначально установлен равным 25 мегабайтам (МБ). На большинстве серверов Exchange эта настройка была гораздо больше, чем требовалось. Настройка MaxMemoryConfig применялась для возврата и повторного выделения некоторой памяти, используемой кэшем конфигурации DSAccess. Обычно эта настройка устанавливалась равной 5 МБ. На основе внутреннего тестирования и отзывов клиентов в корпорации Майкрософт определили, что 3 МБ будет оптимальным размером в качестве готовой настройки для Exchange Server 2003. При обновлении Exchange 2000 Server до Exchange Server 2003 все ручные настройки сохраняются. Если данный сервер Exchange получен в результате обновления Exchange 2000 Server до Exchange Server 2003, следует убедиться, что значение MaxMemoryConfig не превышает 5 МБ.

Значение MaxMemoryConfig часто используется совместно со значением MaxMemoryUser, которое управляет максимальным объемом памяти, предоставляемой объектам данных пользователей в кэше DSAccess. Если изменяется или удаляется значение MaxMemoryConfig, как описано в приводимой ниже процедуре, следует подобным образом изменить или удалить значение MaxMemoryUser, как описано в статьеЗначение кэша пользователя DSAccess не является значением по умолчанию.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы использовать параметр MaxMemoryConfig реестра

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Проанализируйте и при необходимости измените значение MaxMemoryConfig.
Примечание.
Значение для этой записи реестра выражено в килобайтах (КБ). Если значение установлено равным 3000 или менее, следует удалить MaxMemoryConfig и перезапустить службу Системный помощник Microsoft Exchange, чтобы установить для Exchange Server 2003 настройку по умолчанию.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о компоненте DSAccess см. в базе знаний Майкросфот в статье 250570, описывающей процедуру обнаружения сервера службы каталогов и использование компонента DSAccess (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).


Значение параметра реестра DisableNetLogonCheck для DSAccess не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, настроено ли для средства DSAccess использование протокола ping, не являющегося протоколом по умолчанию, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\DisableNetLogonCheck

Если анализатор сервера Exchange обнаруживает, что для записи DisableNetLogonCheck установлено значение больше 0, выводится сообщение о нестандартной конфигурации.

После того, как средство DSAccess выявляет топологию службы каталогов Active Directory®, оно определяет, можно ли использовать найденные контроллеры домена и серверы глобального каталога. В ходе начальной проверки топологии и последующих проверок средство DSAccess определяет пригодность сервера, выполняя последовательность тестов. При одной проверке серверу каталога посылается удаленный вызов процедур, чтобы проверить его общую пригодность. В сценарии периметра сети, где трафик удаленных вызовов процедур обычно не разрешен, запросы удаленных вызовов процедур, выполняемые средством DSAccess, завершаются с ошибкой. Однако средство DSAccess продолжает выполнять удаленные вызовы процедур до сбоя, что может происходить длительное время. Такая повторяющаяся проверка может повлиять на производительность компьютеров, на которых работает Exchange Server. По этой причине администраторы часто добавляют раздел реестра DisableNetLogonCheck со значением 1 на серверы Exchange, расположенные на периметре сети.

Если сервер Exchange, создавший сообщение о нестандартной конфигурации, находится на периметре сети, где отключены удаленные вызовы процедур, или если отсутствует необходимость выполнения теста DSAccess на пригодность, необходимо задать значение 1 для параметра DisableNetLogonCheck. В противном случае следует удалить раздел DisableNetLogonCheck.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы использовать раздел DisableNetLogonCheck key

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Дважды щелкните раздел DisableNetLogonCheck и задайте значение DWORD, равное 1.

  4. Закройте редактор реестра. Чтобы это изменение вступило в силу, не требуется перезапускать службы.

Чтобы удалить раздел DisableNetLogonCheck

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Удалите значение реестра DisableNetLogonCheck.

  4. Закройте редактор реестра. Чтобы это изменение вступило в силу, не требуется перезапускать службы.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения о редактировании реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о разделе реестра DisableNetLogonCheck см. в статье 320228 базы знаний Майкрософт, посвященной значению раздела реестра DisableNetLogonCheck Registry и инструкциям по его использованию (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320228).


Компонент DSAccess жестко закодирован
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Exchange_DSAccessDC в пространстве имен ROOT\MicrosoftExchangeV2, чтобы определить значение ключа ConfigurationType. Если значение этого ключа равно 0, на экран выводится сообщение о нестандартной конфигурации.

Свойство ConfigurationType показывает, какой контроллер домена описывает этот экземпляр — обнаруженный автоматически или заданный вручную. Компонент DSAccess (Directory Service Access) в сервере Exchange динамически обнаруживает топологию службы каталогов Active Directory® и автоматически находит контроллеры доменов и серверы глобальных каталогов. На компьютерах, работающих под управлением Exchange Server 2000 с пакетом обновления 2 или более поздних версий или Exchange Server 2003, диспетчер Exchange предоставляет возможность ввести жестко закодированный список серверов Active Directory для использования компонентом DSAccess.

Если по какой-то особой причине было выполнено жесткое кодирование серверов каталогов для DSAccess, следует удалить список серверов и вернуться к стандартной настройке, при которой используется автоматическое обнаружение. Рекомендуется использовать автоматическое обнаружение топологии, чтобы воспользоваться преимуществом перехода на другой ресурс для глобального каталога.

Чтобы восстановить настройку по умолчанию

  1. Нажмите кнопку Пуск, выберите пункт Программы, щелкните Microsoft Exchange, а затем выберите Диспетчер.

  2. Разверните узлы Административные группы, <имя_административной_группы>, Серверы, <имя_сервера> (где «имя_административной_группы» — имя административной группы, содержащей сервер Exchange, а «имя_сервера» — имя сервера Exchange, который требуется настроить).

  3. Щелкните правой кнопкой сервер Exchange и выберите команду Свойства.

  4. Перейдите на вкладку Доступ к каталогам.

  5. В поле со списком Показать выберите Контроллер домена конфигурации.

  6. Установите флажок Обнаруживать серверы автоматически.

  7. Нажмите кнопку Да, когда появится следующий запрос диспетчера Exchange: «Указанные выбранные вручную серверы будет очищены. Продолжить?»

  8. В поле со списком Показать выберите Контроллеры доменов.

  9. Установите флажок Обнаруживать серверы автоматически.

  10. Нажмите кнопку Да, когда появится следующий запрос диспетчера Exchange: «Указанные выбранные вручную серверы будет очищены. Продолжить?»

  11. В поле со списком Показать выберите Серверы глобальных каталогов.

  12. Установите флажок Обнаруживать серверы автоматически.

  13. Нажмите кнопку Да, когда появится следующий запрос диспетчера Exchange: «Указанные выбранные вручную серверы будет очищены. Продолжить?»

  14. Нажмите кнопку ОК, чтобы сохранить изменения.

Дополнительные сведения о компоненте DSAccess и обнаружении служб каталогов см. в статье 250570 базы знаний Майкрософт, в которой описывается обнаружение серверов службы каталогов и использование DSAccess (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).


DSAccess не использует порт 389 для LDAP-запросов контроллера домена
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс Exchange_DSAccessDC в пространстве имен ROOT\MicrosoftExchangeV2, чтобы определить значение раздела LDAPPort. Если значение LDAPPort не равняется 389, отображается сообщение о нестандартной конфигурации.

Раздел LDAPPort представляет номер TCP-порта, который прослушивается контроллером домена в ожидании LDAP-запросов. Администраторы могут использовать LDAP через SSL по TCP-порту 636 (контроллер домена) или TCP-порту 3269 (глобальный каталог) в качестве меры по обеспечению безопасности.

По умолчанию сервер глобального каталога прослушивает порт 3268 в ожидании связи по протоколу LDAP. Однако если установлен центр сертификации предприятия, все контроллеры домена автоматически требуют сертификат и могут поддерживать связь по протоколу LDAP через SSL, используя TCP-порт 636. Если контроллер домена настроен как глобальный каталог, он также может поддерживать связь по протоколу LDAP через SSL по TCP-порту 3269.

Чтобы устранить эту ошибку

  • Никаких специальных действий выполнять не требуется. Анализатор сервера Exchange обнаруживает нестандартную конфигурацию.

Дополнительные сведения о DSAccess и портах LDAP см. в следующих статьях базы знаний Майкрософт:

  • статья 247078, посвященная описывающая инструкциям по включению связи SSL по LDAP для контроллеров домена Windows 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=247078);

  • статья 246228, посвященная профилям DSAccess (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246228).


DSAccess не использует порт 3268 для запросов LDAP глобального каталога
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс Exchange_DSAccessDC в пространстве имен ROOT\MicrosoftExchangeV2, чтобы определить значение для ключа LDAPPort. Если для ключа LDAPPort не установлено значение 3268, отображается сообщение о о нестандартной настройке.

Ключ LDAPPort представляет номер TCP-порта, который прослушивается контроллером домена на запрос LDAP. Администраторы могут использовать LDAP через протокол SSL на TCP-порте 636 (контроллер домена) или на TCP-порте 3269 (глобальный каталог) в качестве одной из мер безопасности.

По умолчанию сервер глобального каталога прослушивает порт 3268 на связь по протоколу LDAP. Однако если установлен корпоративный центр сертификации, все контроллеры домена автоматически запрашивают сертификат и могут поддерживать связь по протоколу LDAP через SSL на TCP-порте 636. Если контроллер домена также настроен, как глобальный каталог, он может также поддерживать связь по протоколу LDAP через SSL на TCP-порте 3269.

Дополнительные сведения о DSAccess и LDAP-портах см. в следующих статьях базы знаний Майкрософт:

  • 247078 — приводятся инструкции по включению связь по протоколу LDAP через SSL для контроллеров доменов Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=247078)

  • 246228 — описываются профили DSAccess для XGEN (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246228)


Параметр реестра «DSAccess LdapKeepAliveSecs» отличается от заданного по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, настроено ли для средства DSAccess использование LDAP-протокола в реализации, предназначенной для операционной системы Microsoft Windows® (wLDAP-протокола), анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\ LdapKeepAliveSecs

Если анализатор сервера Exchange обнаруживает, что для записи LdapKeepAliveSecs установлено значение 0, выводится сообщение о том, что конфигурация отличается от заданной по умолчанию.

После того, как средство DSAccess выявляет топологию службы каталогов Active Directory®, оно определяет, можно ли использовать найденный список работающих контроллеров домена и серверов глобального каталога. В ходе начальной проверки топологии и последующих проверок средство DSAccess определяет пригодность сервера, выполняя последовательность тестов. По умолчанию в одном из тестов на пригодность используется ICMP-протокол для ping-запросов контроллерам домена для проверки доступности этих серверов.

ICMP-протокол может не поддерживаться некоторыми подключениями сети. Конкретный пример — граничная сеть, где использование ICMP-протокола между серверами Exchange и контроллерами домена не разрешается. В таких случаях можно указать для параметра реестра LdapKeepAliveSecs значение 0, в результате чего для проведения тестов DSAccess будет принудительно использовать Windows-реализацию LDAP-протокола (wLDAP).

Если сервер Exchange, который создал сообщение об отличии конфигурации от заданной по умолчанию, находится в граничной сети, где отключен удаленный вызов процедур или в сети, где использование ICMP не разрешено, следует оставить раздел LdapKeepAliveSecs без изменений. В обратном случае следует удалить этот раздел.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы удалить раздел «LdapKeepAliveSecs»

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Удалите значение реестра с названием LdapKeepAliveSecs.

  4. Закройте редактор реестра. Чтобы это изменение вступило в силу, не требуется перезапускать службы.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Для получения дополнительных сведений об использовании раздела реестра LdapKeepAliveSecs см. статью 320529 базы знаний Майкрософт «XADM: Using DSAccess in a Perimeter Network Firewall Scenario Requires a Registry Key Setting» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320529) (XADM: для использования DSAccess в сценарии межсетевого экрана граничной сети требуется настройка разделов реестра).


Параметр LdapKeepAliveSecs реестра для DSAccess установлен равным неподдерживаемому значению
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, настроено ли для средства DSAccess использование LDAP-протокола в реализации, предназначенной для операционной системы Microsoft Windows® (wLDAP-протокола), анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\ LdapKeepAliveSecs

Если анализатор сервера Exchange обнаружит, что параметр LdapKeepAliveSecs присутствует и настроен равным значению, отличному от 0, на экран будет выведено предупреждение.

После того, как средство DSAccess выявляет топологию службы каталогов Active Directory®, оно определяет, можно ли использовать найденный список работающих контроллеров домена и серверов глобального каталога. В ходе начальной проверки топологии и последующих проверок средство DSAccess определяет пригодность сервера, выполняя последовательность тестов. По умолчанию в одном из тестов на пригодность используется ICMP-протокол для отправки ping-запросов контроллерам домена с целью проверки доступности этих серверов.

ICMP-протокол может не поддерживаться некоторыми подключениями сети. Конкретный пример — граничная сеть, где использование ICMP-протокола между серверами Exchange и контроллерами домена не разрешается. Для этих случаев с помощью установки параметра LdapKeepAliveSecs реестра в 0 средство DSAccess принудительно устанавливается на использование протокола wLDAP в тестах на пригодность.

Если сервер Exchange, выводящий это предупреждение, находится в граничной сети, где удаленные вызовы процедур (RPC) отключены, или в сети, где протокол ICMP не разрешен, установите параметр LdapKeepAliveSecs равным 0. В противном случае следует удалить этот раздел. Все значения, отличные от нуля, являются неподдерживаемыми значениями для этого параметра реестра.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы изменить раздел «LdapKeepAliveSecs»

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Дважды щелкните параметр LdapKeepAliveSecs и установите значение DWORD равным 0 (нулю).

  4. Закройте редактор реестра. Чтобы это изменение вступило в силу, не требуется перезапускать службы.

Чтобы удалить раздел «LdapKeepAliveSecs»

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Удалите параметр реестра LdapKeepAliveSecs.

  4. Закройте редактор реестра. Чтобы это изменение вступило в силу, не требуется перезапускать службы.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о параметре LdapKeepAliveSecs реестра см. в базе знаний Майкрософт в статье 320529, описывающей необходимость установки параметра реестра при использовании DSAccess в сценарии с сетевым экраном в граничной сети (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320529).


Параметр реестра DSAccess PreloadBaseDNs отличается от настройки по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange Server считывает следующий параметр реестра, чтобы определить, отличается ли предварительно загружаемая функция поиска DSAccess от настройки по умолчанию:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\PreloadBaseDNs

Данными значения по умолчанию для PreloadBaseDNs являются:

'"'

'"'

'"'

'"'

'"'

Если анализатор сервера Exchange Server обнаружит, что значение для PreloadBaseDNs было изменено по сравнению с этими значениями по умолчанию, на экран будет выведено соответствующее предупреждение. Анализатор сервера Exchange Server представляет отчет по этой настройке, поскольку она может быть изменена только после консультации со службой поддержки продуктов Майкрософт.

Кэш DSAccess находится на сервере Exchange, он служит для сбора записей о пользователях и настройке, которые загружаются из службы каталогов Active Directory®. Доступ к записям в кэше DSAccess осуществляется с использованием различающегося имени объекта, идентификатора GUID или ключа, созданного на основе области поиска, BaseDN и фильтра поиска, использованного для поиска объекта в Active Directory. При последующем доступе, в котором используется то же самое различающееся имя, идентификатор GUID или ключ, находится нужная запись в кэше. Поэтому отпадает необходимость загрузки Active Directory для выполнения идентичных процедур поиска. Однако DSAccess не препятствует загрузке Active Directory, когда фильтр поиска отличается от фильтра, содержащегося в кэше, даже в случае, если DSAccess запрашивает тот же набор атрибутов для объекта пользователя.

Предварительно загружаемая функция поиска является средством, устраняющим многие проблемы поиска в Active Directory, возникающие в случаях, когда различные фильтры поиска используются для одного и того же объекта пользователя. Предварительно загружаемая функция поиска обрабатывается с помощью упоминавшейся выше конструкции ключа, в которой запись в поле поиска создается на основе области поиска, BaseDN и фильтра поиска.

Дополнительные сведения о настройке предварительно загружаемой функции поиска DSAccess см. в статье базы знаний Майкрософт 250572, посвященной этой функции и кэшу DSAccess (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250572).


Значение параметра реестра DSAccess PreloadFilters отлично от значения по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server считывает следующий параметр реестра, чтобы определить, соответствует ли настройка функций предварительной загрузки поиска DSAccess настройке по умолчанию:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\PreloadFilters

Значение PreloadFilters по умолчанию:

(&(|(msExchMasterAccountSID=%)(objectSid=%))(!(objectClass=foreignSecurityPrincipal)))(|(msExchMailboxGUID=%)(objectGUID=%))(legacyExchangeDN=%)(msExchMailboxGUID=%)(&(proxyAddresses=%)(|(objectClass=user)(objectClass=contact)))

Если средство анализа Exchange Server обнаружит, что значение PreloadFilters отличается от значения по умолчанию, появится предупреждение. Средство анализа Exchange Server проверяет данную настройку, поскольку параметр реестра PreloadFilters следует изменять, только проконсультировавшись в службе поддержки продуктов корпорации Майкрософт.

Кэш DSAccess размещается на сервере Exchange; в нем собираются записи о настройке и о пользователях, полученные из службы каталога Active Directory®. Доступ к записям в кэше осуществляется при помощи различающегося имени объекта, глобального уникального идентификатора (GUID) или ключа, составленного из области, BaseDN и фильтра поиска, используемого для обнаружения данного объекта в Active Directory. Последовательные попытки получить доступ при помощи одного и того же различающегося имени, GUID или ключа приводят к обнаружению записи в кэше. Таким образом, предотвращается ненужная нагрузка на Active Directory при повторении одинаковых поисков. Однако DSAccess не сокращает нагрузку на Active Directory, если фильтр поиска отличается от фильтра, содержащегося в кэше, даже если DSAccess запрашивает тот же набор атрибутов объекта пользователя.

Предварительная загрузка поиска — это способ избежать многих проблем, связанных с поиском в Active Directory, которые могут возникать из-за того, что для одного и того же объекта пользователя создаются различные фильтры поиска. Предварительная загрузка поиска работает с вышеописанной конструкцией ключа, в котором элемент поиска состоит из области, BaseDN и фильтра поиска.

Для получения дополнительных сведений о настройке предварительной загрузки поиска DSAccess см. статью 250572 базы данных корпорации Майкрософт «XCON: предварительная загрузка и кэш DSAccess» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250572).


DSAccess сообщает, что данный сервер Active Directory не работает
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Exchange_DSAccessDC в пространстве имен ROOT\MicrosoftExchangeV2, чтобы определить значение ключа IsUp. Если для ключа IsUp задано значение False, выводится сообщение об ошибке.

Если для ключа IsUp задано значение True, значит, контроллер домена ответил при последней попытке Exchange пытался установить подключение. Если для ключа IsUp задано значение False, значит, контроллер домена не ответил при попытке подключения.

Отсутствие ответа не всегда означает, что контроллер домена или глобальный каталог отключен или работает неправильно. Ошибка может быть вызвана проблемами связи между сервером Exchange и контроллером домена. Причиной ошибки также может быть наличие межсетевого экрана между сервером Exchange и контроллером домена, в котором не были открыты соответствующие порты.

Чтобы устранить эту ошибку

  1. Проверьте, работает ли контроллер домена, отправив ему ping-запрос.

  2. Если установлен межсетевой экран, убедитесь, что в нем открыты соответствующие порты. Следует также учесть, что межсетевой экран может быть настроен на сброс PING-пакетов. Сведения о том, как открыть или закрыть конкретные порты, см. в документации межсетевого экрана.

  3. Проверьте, нет ли других проблем в работе сети, таких как неисправные коммутаторы, маршрутизаторы и кабели.

Дополнительные сведения о DSAccess и обнаружении служб каталогов см. в статье 250570 базы знаний Майкрософт, описывающей обнаружение службы каталогов и применение DSAccess (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).

Дополнительные сведения об устранении проблем в работе сети см. в статье 325487 базы знаний Майкрософт, описывающей устранение неполадок в сетевых подключениях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).


DSAccess указывает, что этот сервер Active Directory не синхронизирован с остальной частью топологии
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-04-21

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс Exchange_DSAccessDC в пространстве имен ROOT\MicrosoftExchangeV2, чтобы определить значения ключа IsInSync. Если для ключа IsInSync задано значение False, выводится сообщение об ошибке.

Ключ IsInSync указывает, синхронизирован ли контроллер домена с сервером глобального каталога и контроллером конфигурации домена. Значение True означает, что сервер синхронизирован. Значение False означает, что контроллер домена не синхронизирован.

Чтобы устранить эту ошибку

  1. Посмотрите время на контроллере домена или глобальном контроллере. Убедитесь, что служба времени запущена, или вручную синхронизируйте время на сервере Exchange с сервером глобального каталога или контроллером конфигурации домена.

  2. Воспользуйтесь средством наблюдения за репликацией (Replmon), чтобы просмотреть, проверить и исправить неполадки, связанные с репликацией контроллера домена. Replmon является частью средств поддержки Microsoft Windows 2000 Server и Microsoft Windows Server™ 2003, которые находятся в папке Support\Tools на компакт-диске Windows Server.

Дополнительные сведения о DSAccess и обнаружении служб каталогов см. в следующих статьях базы знаний Майкрософт:

  • статья 316300, посвященная коду события 2080 и MSExchangeDSAccess (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316300);

  • статья 250570, посвященная обнаружению сервера службы каталогов и использованию DSAccess (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).


DSAccess сообщает, что данному серверу Active Directory требуется более 2 секунд для ответа на запрос LDAP
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server запрашивает классExchange_DSAccessDC инструментария Microsoft Windows® Management Instrumentation (WMI) в пространстве имен ROOT\MicrosoftExchangeV2, чтобы определить значения параметров IsFast и IsUp. Если значение параметра IsUp равно True, это означает, что сервер каталога, используемый компонентом Directory Service Access (DSAccess), подключен к сети и отвечает на запросы. Значение False говорит о том, что сервер каталога не отвечает на запросы. Если значение IsFast равно True, это означает, что время ответа сервера каталога составляет менее двух секунд. Значение False свидетельствует о том, что время ответа превышает две секунды. Если значение IsUp равно True, а значение IsFast равно False, появляется сообщение об ошибке.

Устранение ошибки

  1. Проверьте нагрузку контроллера домена и глобального каталога. Перегрузка контроллера домена и глобального каталога может привести к замедлению ответа на запросы LDAP.

  2. Для оптимальной работы обеспечьте по крайней мере один глобальный каталог в локальной службе каталогов сайта Active Directory®.

Для получения дополнительных сведений о DSAccess и обнаружении служб каталогов см. статью 250570 базы знаний корпорации Майкрософт «Обнаружение сервера служб каталогов и использованию DSAccess» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).


Значение параметра реестра TopoCreateTimeoutSecs для DSAccess не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, изменено ли значение по умолчанию для таймаута инициализации DSAccess, анализатор сервера Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess\TopoCreateTimeoutSecs

Если анализатор обнаружит, что раздел TopoCreateTimeoutSecs существует и его значение превышает 0, отображается сообщение о нестандартной конфигурации.

Во время запуска DSAccess использует процесс обнаружения, чтобы определить топологию службы каталогов Active Directory® и доступность контроллеров домена и серверов глобального каталога. Сразу после запуска и затем через каждые 15 минут DSAccess пользуется почти тем же процессом, чтобы снова определить топологию и проверить доступность серверов. По умолчанию инициализация DSAccess во время запуска должна завершиться в течение одной минуты. В противном случае DSAccess останавливается. Одной минуты обычно бывает достаточно, чтобы произошла инициализация DSAccess.

Примечание.
Если серверы каталога, используемые DSAccess, жестко закодированы, DSAccess пропускает процесс обнаружения и проверяет только исправность серверов.
Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы восстановить конфигурацию по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess

  3. Удалите значение реестра TopoCreateTimeoutSecs.

  4. Закройте редактор реестра.

Если этот раздел реестра существует, необходимо оценить топологию сети. Если в организации требуется дополнительное время инициализации DSAccess, это может означать неполадку в сети и проблему с разработкой сети. Быстрый и надежный доступ к контроллерам домена, особенно к серверам глобальных каталогов, являются необходимым условием оптимального быстродействия Exchange.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о доступе к каталогам см. на веб-странице, посвященной общим понятиям о доступе к каталогам и устранении соответствующих неполадок(может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=39012).


Кэш пользователя DSAccess заполнен
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-04-20

Средство анализатора сервера Microsoft® Exchange опрашивает WMI-класс Win32_PerfRawData_MSExchangeDSAccess_MSExchangeDSAccessCaches, чтобы определить текущее значение параметра TotalEntriesMemoryUserData. Если анализатор сервера Exchange обнаружит, что значение параметра TotalEntriesMemoryUserData равняется общему размеру кэша DSAccess (Directory Service Access) (MaxMemoryUser), на экран выводится предупреждение.

DSAccess является внутренним компонентом серверов Exchange 2000 и Exchange Server 2003, который управляет доступом всех компонентов Exchange к службе каталогов Active Directory®. Основной функцией DSAccess является поддержка сведений о различных событиях и операциях, связанных с каталогом. Например, DSAccess обнаруживает топологию Active Directory и определяет доступность контроллеров домена и серверов глобальных каталогов, а также возможность их ответа на запросы. Кроме того, все запросы каталога, выполняемые внутренними компонентами Exchange, например хранилищем Exchange, маршрутизируются посредством DSAccess, например запросы разрешения получателей, поиска параметров конфигурации и т. д. DSAccess в частности обеспечивает поддержку кэша в оперативной памяти, в котором хранятся некоторые из этих запросов. Если одни и те же сведения будут запрошены дважды, их можно будет получить из кэша DSAccess, а не посредством LDAP-запроса службы каталогов Active Directory.

На сервере Exchange 2000 размер кэша пользователя изначально равен 25 мегабайтам (МБ). На компьютерах под управлением Exchange 2000 Server, которые обслуживают большое количество клиентов Microsoft Office Outlook® 2003, размер кэша пользователя DSAccess по умолчанию не является достаточным. В целях повышения производительности значение по умолчанию для кэша пользователя было оптимизирован до 140 МБ в Exchange Server 2003.

Так как максимальный размер кэша DSAccess, заданный по умолчанию, был увеличен с 25 МБ в Exchange 2000 Server до 140 МБ в Exchange Server 2003, это предупреждение может появиться на компьютере под управлением Exchange 2000 Server. Независимо от версии Exchange, которая отобразит это сообщение, неполадка должна быть устранена в кратчайшие сроки. В системах с заниженным размером кэша DSAccess локальная доставка сообщений и разрешение имен адресной книги может происходить дольше, чем следует.

Максимальный размер кэша пользователя можно настроить вручную с помощью записи реестра на сервере Exchange. MaxMemoryUser — это параметр реестра Exchange 2000 Server, с помощью которого администратор Exchange может управлять максимальным количеством памяти, которое будет доступно объектам данных пользователей в кэше DSAccess.

Значение MaxMemoryUser часто используется вместе со значением MaxMemoryConfig, с помощью которого можно управлять максимальным количеством памяти, доступного объектам данных конфигурации в кэше DSAccess. При изменении или удалении параметра MaxMemoryUser, как показано в следующей процедуре, необходимо соответственно изменить или удалить параметр MaxMemoryConfig, как описано в разделе Значение кэша конфигурации DSAccess отличается от значения по умолчанию.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить эту проблему на компьютере под управлением Exchange 2000 Server

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Увеличьте значение MaxMemoryUser. Если данного значения DWORD не существует, можно создать его вручную. Значение данной записи реестра выражается в килобайтах (КБ), поэтому десятичное значение 140000 равняется 140 МБ.

  4. Уменьшите значение MaxMemoryConfig. Если данного значения DWORD не существует, можно создать его вручную. Значение этой записи реестра также выражено в килобайтах (КБ). Рекомендуется использовать значение 5000 (десятичное), соответствующее 5 МБ.

  5. Закройте редактор реестра и перезапустите службу системного помощника Microsoft Exchange, чтобы изменения вступили в силу.

Чтобы устранить эту проблему на компьютере под управлением Exchange Server 2003

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Если параметр MaxMemoryUser существует и имеет значение меньше 140 МБ, удалите параметр MaxMemoryUser. Если параметр MaxMemoryUser существует и имеет значение 140 МБ, увеличьте это значение на 10%.

  4. Если параметр MaxMemoryConfig существует, удалите его.

  5. Закройте редактор реестра и перезапустите службу системного помощника Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в статье 256986 базы знаний Майкрософт, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о DSAccess см. в статье 250570 базы знаний Майкрософт, описывающей процедуру обнаружения сервера в службе каталогов и использование DSAccess (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570).


Значение кэша пользователя DSAccess не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, был ли изменен размер кэша пользовательского объекта доступа к службе каталогов (DSAccess) относительно значения по умолчанию, средство анализатора Microsoft® Exchange считывает следующие разделы реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0\MaxMemoryUser

Если анализатор находит, что параметр MaxMemoryUser существует и настроен, отображается сообщение о нестандартной конфигурации.

MaxMemoryUser — это параметр реестра сервера Exchange, с помощью которого администратор Exchange может управлять максимальным количеством памяти, которое будет доступно объектам данных пользователей в кэше DSAccess.

DSAccess является внутренним компонентом серверов Exchange 2000 и Exchange Server 2003, который управляет доступом всех компонентов Exchange к службе каталогов Active Directory®. Основной функцией DSAccess является поддержка сведений о различных событиях и операциях, связанных с каталогом. Например, DSAccess обнаруживает топологию Active Directory и определяет доступность контроллеров домена и серверов глобальных каталогов, а также возможность их ответа на запросы. Кроме того, все запросы каталога, выполняемые внутренними компонентами Exchange, например хранилищем Exchange, маршрутизируются посредством DSAccess, например разрешение получателей, поиск параметров конфигурации и прочее. Частью функционирования DSAccess является поддержка кэша в оперативной памяти, в котором хранятся некоторые из этих запросов на тот случай, если одни и те же сведения будут запрошены дважды, их можно будет получить из кэша DSAccess, а не посредством LDAP-запроса службы каталогов Active Directory.

На сервере Exchange 2000 размер кэша пользователя изначально равен 25 мегабайтам (МБ). На компьютерах серверов Exchange 2000, которые обслуживают большое количество клиентов Microsoft Office Outlook® 2003, размер кэша пользователя DSAccess по умолчанию не является достаточным. В системах с заниженным размером кэша DSAccess локальная доставка сообщений и разрешение имен адресной книги может происходить дольше, чем следует.

Чтобы улучшить производительность, в Exchange Server 2003 значение кэша пользователя было увеличено до 140 МБ. При обновлении Exchange 2000 Server до Exchange Server 2003 любые настройки, сделанные вручную, будут сохранены. Если этот сервер Exchange был обновлен с Exchange 2000 Server до Exchange Server 2003, необходимо убедиться, что значение MaxMemoryUser равно, по меньшей мере, 140 МБ.

Значение MaxMemoryUser часто используется вместе со значением MaxMemoryConfig, что управляет максимальным количеством памяти, которое могут использовать объекты данных конфигурации в кэше DSAccess. При изменении или удалении значения MaxMemoryUser, как показано в следующей процедуре, необходимо соответственно изменить или удалить значение MaxMemoryConfig, как описано в разделе Значение кэша конфигурации DSAccess отличается от значения по умолчанию.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы использовать раздел реестра MaxMemoryUser

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Просмотрите или измените значение параметра MaxMemoryUser.

    Значение для этой записи реестра выражено в килобайтах (КБ). Если значение равно 140000 или меньше, необходимо удалить MaxMemoryUser и повторно запустить системного помощника Microsoft Exchange, чтобы вернуться к значению по умолчанию для Exchange Server 2003.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о DSAccess см. в статье 250570 базы знаний Майкрософт, описывающей процедуру обнаружения сервера в службе каталогов и использование DSAccess (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).


Служба DSProxy RFR отключена
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Server считывает следующие параметры реестра, чтобы определить, отключена ли служба прокси-ссылок службы каталогов (DSProxy RFR):

HKEY_LOCAL_MACHINE\ System\CurrentControlSet\Services\MSExchangeSA\Parameters\ No RFR Service

Если анализатор сервера Exchange Server обнаружит, что параметр No RFR Service имеется и имеет значение 1, отображается сообщение о нестандартной настройке.

Компонент DSProxy в Exchange 2000 Server и Exchange Server 2003 обеспечивает доступ каталога к контроллеру домена или глобальному каталогу для клиентов Microsoft Outlook® 98 и Outlook 97. Outlook 2000 Service Release 2 (SR-2) и более поздние версии могут запрашивать сервер глобального каталога напрямую.

Когда Outlook 2000 SR-2 или клиенты более поздних версий подключаются к серверу Exchange 2000 или компьютеру с более поздней версией, осуществляется поиск службы каталогов на почтовом сервере Exchange. Outlook сначала проходит через процесс DSProxy для своего первого сеанса. После того как клиент установит контакт со службой DSProxy (при этом предпринимаются попытки использовать все доступные транспортные протоколы), ссылка передается обратно клиенту, информируя его о том, что все будущие запросы каталога будут передаваться серверу глобального каталога. Outlook задает ссылку в профиле MAPI в реестре. Механизм ссылок DSProxy снижает загрузку сервера Exchange, а также задержку для поисков в адресной книге. Если в профиль будет введено явное имя сервера, программа Outlook должна осуществить перезапуск, если в работе сервера службы каталогов Active Directory® возникнет ошибка. Если это произойдет, сервер Exchange отправит программе Outlook новую ссылку.

В некоторых сценариях может потребоваться определить, чтобы клиенты Outlook (даже имеющие последние версии) всегда проходили через процесс DSProxy без указания их ссылок. Например, может потребоваться сделать это, если между Outlook и сервером Exchange имеется брандмауэр.

При добавлении параметр реестра No RFR Service и задании для него значения 1, сервер Exchange будет работать, как прокси-сервер для клиентов Outlook, а не предоставлять ссылки для клиентов на соответствующий сервер глобального каталога для установления связи напрямую. Задание параметра реестра No RFR Service равным 1 приводит к снижению производительности сервера Exchange, поскольку он будет действовать в качестве прокси-сервера для клиентов Outlook, включая Outlook 2000 SR-2 и более новые версии клиентов, которые могут устанавливать связь с Active Directory напрямую.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неполадок. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы включать службу DSProxy RFR

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Создайте новое значение DWORD с именем No RFR Service.

  4. Настройте параметр No RFR Service, задав для него значение 1.

Чтобы отключить службу DSProxy RFR, либо удалите значение реестра No RFR Service, либо установите его равным 0.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о том, как Outlook 2000 SR-2 и клиенты более новых версий взаимодействуют с Active Directory, см. в базе знаний Майкрософт в статье 256976, в которой описывается, как Outlook 2000 осуществляет доступ к Active Directory (http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914).

Дополнительные сведения о том, как клиенты MAPI осуществляют доступ к Active Directory см. в базе знаний Майкрософт в статье 256976, посвященную этой теме (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976).


Файл EMSMTA.EXE не найден
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы проверить наличие нескольких основных двоичных файлов Exchange:

  • Exres.dll

  • Gapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»),

  • Mapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»),

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если средство анализатора сервера Exchange обнаруживает, что отсутствует один или несколько из этих файлов, выводится сообщение об ошибке. Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если ошибку не удалось устранить, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в привод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если вы согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Раздел EnableAuthEpResolution реестра включен
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра, чтобы определить, включен ли раздел ограничений интерфейса удаленного вызова процедур (RPC):

HKEY_LOCAL_MACHINE\ Software\Policies\Microsoft\Windows NT\RPC

Если анализатор сервера Exchange обнаруживает, что значение EnableAuthEpResolution реестра существует, анализатор сервера Exchange выводит на экран сообщение о конфигурации не по умолчанию.

Ограничения интерфейса RPC обеспечивают улучшенную сетевую защиту, которая делает системы менее уязвимой к атакам через сеть.

Интерфейс RPC, доступный удаленно и анонимно и по умолчанию регистрируемый в Microsoft Windows® XP, представляет собой значительную поверхность для атаки. Сам удаленный вызов процедур (RPC) должен регистрироваться как такой интерфейс, который обеспечивает разрешение конечной точки для вызовов, использующих динамические конечные точки. Раздел RestrictRemoteClients реестра изменяет поведение всех интерфейсов RPC в системе. По умолчанию раздел RestrictRemoteClients реестра предотвращает удаленный анонимный доступ к интерфейсам RPC в системе, с некоторыми исключениями. Следовательно, интерфейс служба отображения конечных точек RPC анонимно больше недоступна.

Клиент RPC, пытающийся сделать вызов, используя динамическую конечную точку, сначала должен запросить службу отображения конечных точек на сервере, чтобы определить, к какой динамической точке клиент RPC должен подключиться. Этот запрос выполняется анонимно даже в случае, когда клиент RPC сам выполняется с использованием защиты RPC. По умолчанию анонимные вызовы на интерфейс службы отображения конечных точек RPC не проходят при использовании пакета обновления 2 для Microsoft Windows XP, т.к. функция RestrictRemoteClients по умолчанию предотвращает удаленный анонимный доступ к интерфейсам RPC системы. Из-за ограничения интерфейса RPC время цикла клиента RPC изменяется так, чтобы выполнить запрос в службу отображения конечных точек с проверкой подлинности. Указанное ограничение интерфейса RPC представляет собой поведение по умолчанию в пакете обновления 2 для Windows XP. В этом случае во время выполнения цикла клиент RPC использует встроенную проверку подлинности Windows, прежде называвшуюся NTLM, чтобы проверить подлинность перед обращением в службу отображения конечных точек. Встроенная проверка подлинности Windows производится, если в реальном вызове клиента RPC используется проверка подлинности данного вида. Конфигурация не по умолчанию существует, если выполняются следующие условия:

  • Созданы описанные раздел и значение EnableAuthEpResolution реестра.

  • Значение параметра EnableAuthEpResolution реестра установлено равным нулю.

Дополнительные сведения об изменениях в службе RPC при использовании пакета обновления 2 для Windows XP см. в разделе "Ограничения интерфейса RPC" (http://go.microsoft.com/fwlink/?LinkId=47371).


Значение счетчика «Epoxy Client Out Queue Length (DSAccess)» (для IMAP) ниже порогового
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-02-13

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Client Out Queue Length (IMAP) объекта производительности Epoxy для анализа данных о производительности.

Счетчик производительности Client Out Queue Length (IMAP) показывает количество сообщений в очереди, содержащей сообщения IMAP4, отправленные процессом Inetinfo.exe процессу Store.exe. Длина этих очередей никогда не должна превышать 50. Если анализатор сервера Exchange определяет, что в течение временного интервала снятия отсчета значение счетчика Client Out Queue Length (IMAP) превысило максимальное значение, равное 50, анализатор сервера Exchange выводит на экран сообщение об ошибке.

Epoxy (ExIPC) — это механизм общей памяти, позволяющий быстро обмениваться данными процессам служб IIS (Microsoft Internet Information Services, Inetinfo.exe) и банка данных Microsoft Exchange (Store.exe). Он обеспечивает двунаправленную связь между процессами Inetinfo.exe и Store.exe.

Примечание.
Inetinfo.exe принимает запросы от таких Интернет-протоколов, как WebDAV, IMAP4, NNTP, POP3 и SMTP.

Эту память также использует DSAccess, компонент Exchange, кэширующий данные Active Directory®.

Эта ошибка сообщает о проблемах производительности процесса Store.exe или ресурсов, от которых зависит этот процесс, которые приводят к росту очереди. В результате увеличивается время ответа сервера.

Для решения этой проблемы используйте ресурсы, приведенные в разделе «Дополнительные сведения», чтобы определить узкое место производительности процесса Store.exe или связанных процессов. Это узкое место может быть вызвано плохой производительностью диска или высоким использованием процессора.

Дополнительные сведения

  • Дополнительные сведения об обнаружении очередей в Epoxy см. в статье «Выявление растущих очередей в Epoxy» раздела Устранение неполадок приложения Microsoft Exchange Server, связанных с производительностью (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Дополнительные сведения об узких местах работы процессора см. в разделе Узкое место в работе процессора.

  • Дополнительные сведения об узких местах работы дисков см. в разделе Обнаружено узкое место на диске.

  • Дополнительные сведения об устранении неполадок производительности хранилища см. в статье 257725 базы знаний Майкрософт, посвященную XADM и сбору диагностических данных для устранения неполадок банка данных по адресу http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725 (возможно, на английском языке).

  • Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=47576 (возможно, на английском языке).

  • Дополнительные сведения об устранении проблем производительности сервера Exchange см. в разделе Устранение неполадок приложения Microsoft Exchange Server, связанных с производительностью по адресу http://go.microsoft.com/fwlink/?LinkId=47588 (возможно, на английском языке).


Значение счетчика «Epoxy Client Out Queue Length (DSAccess)» (для POP) ниже порогового
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-02-13

Анализатор сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Client Out Queue Length (POP) объекта производительности Epoxy для анализа данных о производительности.

Счетчик производительности Client Out Queue Length (POP) показывает количество сообщений в очереди, содержащей сообщения POP3, отправленные процессом Inetinfo.exe процессу Store.exe. Длина этих очередей никогда не должна превышать 50. Анализатор сервера Exchange получает от этого счетчика замер каждые 5 секунд в течение 5 минут. Если анализатор сервера Exchange определяет, что в течение временного интервала снятия отсчета значение счетчика Client Out Queue Length (POP) превысило максимальное значение, равное 50, анализатор сервера Exchange выводит на экран сообщение об ошибке.

Epoxy (ExIPC) — это механизм общей памяти, позволяющий быстро обмениваться данными процессам служб IIS (Inetinfo.exe) и банка данных Microsoft Exchange (Store.exe). Он обеспечивает двунаправленную связь между процессами Inetinfo.exe и Store.exe.

Примечание.
Inetinfo.exe принимает запросы от таких Интернет-протоколов, как WebDAV, IMAP4, NNTP, POP3 и SMTP.

Эту память также использует DSAccess, компонент Exchange, кэширующий данные Active Directory®.

Эта ошибка сообщает о проблемах производительности процесса Store.exe или ресурсов, от которых зависит этот процесс, которые приводят к росту очереди. В результате увеличивается время ответа сервера.

Для решения этой проблемы используйте ресурсы, приведенные в разделе «Дополнительные сведения», чтобы определить узкое место производительности процесса Store.exe или связанных процессов. Это узкое место может быть вызвано плохой производительностью диска или высоким использованием процессора.

Дополнительные сведения

  • Дополнительные сведения об обнаружении очередей в Epoxy см. в статье, посвященной выявлению растущих очередей в Epoxy, на веб-узле, описывающем устранение неполадок приложения Microsoft Exchange Server, связанных с производительностью (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Дополнительные сведения об узких местах работы процессора см. в разделе Узкое место в работе процессора.

  • Дополнительные сведения об узких местах работы дисков см. в разделе Обнаружено узкое место на диске.

  • Дополнительные сведения об устранении неполадок производительности хранилища см. в статье 257725 базы знаний Майкрософт, посвященную инструкции по сбору диагностических данных для устранения неполадок банка данных (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

  • Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Дополнительные сведения об устранении проблем производительности сервера Exchange см. на веб-узле, посвященном устранению неполадок приложения Microsoft Exchange Server, связанных с производительностью (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).


Отсутствует файл EPOXY.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server запрашивает класс CIM_Datafile инструментария Microsoft Windows® Management Instrumentation (WMI), чтобы проверить наличие некоторых основных двоичных файлов Exchange:

  • Exres.dll

  • Gapi32.dll (проверяется в папке System32 и в папке \Exchsrvr\bin)

  • Mapi32.dll (проверяется в папке System32 и в папке \Exchsrvr\bin folder)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если средство анализа Exchange Server обнаруживает отсутствие одного или нескольких этих файлов, появляется сообщение об ошибке. Для устранения этой ошибки установите новейший пакет обновления или накопительный пакет обновлений для своей версии Exchange. Если ошибка останется, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Пользовательские данные и настройки при этом не удаляются и не сбрасываются. При переустановке сервера Exchange также необходимо переустанавливать любые установленные пакеты обновлений и обновления Exchange.

Переустановка Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором нужно переустановить Exchange. Вставьте компакт-диск с Exchange 2000 Server или Exchange Server 2003 в дисковод CD-ROM.

  2. В меню Пуск выберите пункт Выполнить, введите <диск>:\setup\i386\setup, где <диск> — буква дисковода CD-ROM.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите Далее.

  4. На странице с лицензионным соглашением прочтите лицензионное соглашение. Если вы согласны с его условиями, нажмите кнопки Я согласен и Далее.

  5. На странице Идентификация продукта введите 25-значный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь стрелкой раскрывающегося списка рядом с узлом Microsoft Exchange и выберите Переустановить, затем нажмите кнопку Далее.

Для получения дополнительных сведений о последних пакетах обновлений Exchange Server 2003, накопительных пакетах обновлений и надстройках см. раздел загрузок для Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Для получения дополнительных сведений о последних пакетах обновлений Exchange Server 2000, накопительных пакетах обновлений и надстройках см. раздел загрузок для Exchange Server 2000 (http://go.microsoft.com/fwlink/?LinkId=25097).


Объект Epoxy системного монитора недоступен
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Client Out Queue Length объекта производительности Epoxy для анализа данных о производительности. Если счетчиком не возвращаются допустимые данные, анализатор сервера Exchange выводит на экран сообщение об отклонении от основного поведения.

Если модулем сбора данных о производительности не возвращаются допустимые данные, имеет место любая комбинация из следующих условий:

  • Объект Epoxy системного монитора отключен.

  • Объект Epoxy системного монитора отсутствует или поврежден.

  • У анализатора сервера Exchange отсутствуют соответствующие разрешения на доступ к объектам производительности.

Первые два условия могут возникать при повреждении реестра некоторыми расширяемыми счетчиками или если реестр изменяют программы, основанные на инструментарии управления Windows (Microsoft Windows® Management Instrumentation, WMI). Приводимая ниже процедура позволяет устранить первые два условия. Прежде чем выполнить процедуру, убедитесь, что у анализатора сервера Exchange имеются соответствующие разрешения. Дополнительные сведения о разрешениях, которые необходимы для запуска анализатора сервера Exchange, см. в документации «Справки», которая поставляется с анализатором сервера Exchange. Для доступа к «Справке» откройте анализатор сервера Exchange и нажмите клавишу F1.

Чтобы устранить эту ошибку

  1. Убедитесь, что объект производительности Epoxy включен:

    1. Загрузите и установите средство (Exctrlst.exe) расширяемого списка счетчиков производительности. Программу Exctrlst.exe можно загрузить на веб-узле, «Exctrlst.exe: расширяемый список счетчиков производительности» (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Запустите программу Exctrlst.exe, щелкните Порядок сортировки, а затем щелкните Служба.

    3. Найдите службу, для которой выводит значения счетчик производительности, и убедитесь, что установлен флажок Счетчики производительности включены.

      Если флажок Счетчики производительности включены не установлен, установите этот флажок, а затем перезапустите службу, которая связана со счетчиками производительности, чтобы убедиться в работоспособности счетчиков производительности. Если счетчики производительности не функционируют или если флажок Счетчики производительности включены уже установлен, перейдите к шагу 2.

  2. Перестройте отсутствующие или поврежденные счетчики производительности, воспользовавшись сведениями, приводимыми в базе знаний Майкрософт в статье 300956, содержащей инструкции по перестройке вручную значений библиотеки счетчиков производительности (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Если сведения из данной статьи базы знаний Майкрософт не помогли устранить проблему, следует переустановить сервер Exchange в режиме Восстановление, а затем применить последние пакеты обновлений для сервера Exchange.


Длина сохраненной очереди Epoxy (IMAP) превышает пороговое значение
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-02-13

Средство анализа сервера Microsoft® Exchange включает механизм сбора данных о производительности, который используется, чтобы опрашивать объекты счетчиков производительности на компьютерах, работающих с Exchange 2000 Server или Exchange Server 2003. Механизм сбора данных о производительности собирает данные счетчика производительности Store Out Queue Length (IMAP) объектов производительности Epoxy для анализа данных производительности.

Счетчик производительности Store Out Queue Length (IMAP) указывает количество сообщений в очереди, которые содержат сообщения IMAP4, отправленные при помощи процесса Store.exe процессу Inetinfo.exe. Длина очереди всегда должна быть меньше 50. Средство анализа сервера Exchange получает от счетчика отсчет каждые 5 секунд в течение пятиминутного периода. Если средство анализа сервера Exchange определяет, что значение счетчика Store Out Queue Length (IMAP) превосходит максимальное значение (50) во время взятия отсчета, отображается сообщение об ошибке.

Epoxy (ExIPC) - это механизм общей памяти, позволяющий службам IIS (Inetinfo.exe) и Microsoft Exchange Information Store (Store.exe) быстро пересылать данные. Он позволяет организовать двустороннее межпроцессное взаимодействие между процессом Inetinfo.exe и процессом Store.exe.

Примечание.
Inetinfo.exe принимает запросы от таких протоколов Интернета, как WebDAV, IMAP4, NNTP, POP3 и SMTP.

Эта память также используется DSAccess, компонентом Exchange, кэширующим информацию Active Directory®.

Данная ошибка указывает, что в процессе Inetinfo.exe или в ресурсах, от которых он зависит, возникли проблемы с производительностью, из-за чего растет очередь. Из-за этого время ответа сервера может увеличиваться. Поэтому пользователи столкнутся с тем, что сервер отвечает медленно.

Для решения этой проблемы обратитесь к источникам, упомянутым в разделе «Дополнительные сведения», или связанных с ними источникам для определения узкого места производительности Inetinfo.exe. Узкое место может быть связано с недостаточной производительностью диска или высокой загруженностью ЦП.

Дополнительные сведения

  • Для получения дополнительных сведений об определении роста очередей в Epoxy см. «Определение роста очередей в Epoxy» в Устранение неполадок в связи с быстродействием сервера Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Для получения дополнительных сведений об узких местах, связанных с процессором, см. Узкое место в работе процессора.

  • Для получения дополнительных сведений об узких местах, связанных с диском, см. Обнаружено узкое место на диске.

  • Подробнее об устранении неполадок с производительностью хранилища см. статью 257725 базы знаний Майкрософт «XADM: Как собирать данные диагностики для устранения неполадок хранения информации» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

  • Для получения дополнительных сведений о производительности сервера Exchange см. Руководство по производительности и масштабированию для сервера Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Для получения дополнительных сведений о проблемах с производительностью сервера Exchange см. Устранение неполадок с производительностью сервера Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Значение счетчика Store Out Queue Length (POP) Epoxy превышает пороговое значение
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-02-13

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов о показаниях счетчиков производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности получает данные со счетчика производительности Store Out Queue Length (POP) объекта с оцениваемой производительностью Epoxy для анализа данных о производительности.

Счетчик производительности Store Out Queue Length (POP) показывает число сообщений в очереди, содержащих сообщения POP3, отправленных процессом Store.exe в процесс Inetinfo.exe. Длина очереди всегда должна быть меньше 50 Анализатор сервера Exchange получает замер каждые 5 секунд в течение пятиминутного периода. Если анализатор сервера Exchange определяет, что в течение временного интервала снятия отсчета значение счетчика Store Out Queue Length (POP) превысило максимальное значение, равное 50, он выводит на экран сообщение об ошибке.

Механизм Epoxy (ExIPC) представляет собой механизм общей памяти, обеспечивающий процессам служб IIS (Inetinfo.exe) и служб банка данных Microsoft Exchange (Store.exe) возможность быстрого перемещения данных назад и вперед. Это обеспечивает возможность двунаправленного межпроцессного взаимодействия между процессами Inetinfo.exe и Store.exe.

Примечание.
Процесс Inetinfo.exe принимает запросы из протоколов IP, например WebDAV, IMAP4, NNTP, POP3 и SMTP.

Эта память используется также DSAccess, компонентом Exchange, который кэширует данные Active Directory®.

Это сообщение об ошибке показывает, что в процессе Inetinfo.exe имеются проблемы с производительностью или с ресурсами, от которых зависит процесс Inetinfo.exe, которые вызывают рост очереди. Это может привести к увеличению времени ответа. Следовательно, пользователи столкнутся с задержкой получения ответов с сервера.

Чтобы решить эту проблему, следует использовать ресурсы, указанные в разделе "Дополнительные сведения", с целью определения узкого места в отношении производительности с помощью Inetinfo.exe или других ресурсов. Это узкое место может быть связано с низкой производительностью диска или высокой загрузкой процессора.

Дополнительные сведения

  • Дополнительные сведения об определении причины увеличения очередей в Epoxy см. в статье, посвященной определению причины увеличения очередей в Epoxy, в разделе Устранение неполадок приложения Microsoft Exchange Server, связанных с производительностью (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Дополнительные сведения об узких местах процессора см. в разделе Узкое место в работе процессора.

  • Дополнительные сведения об узких местах диска см. в разделе Обнаружено узкое место на диске.

  • Для получения дополнительных сведений об устранении неполадок, связанных с производительностью банка данных, см. в базе знаний Майкрософт в статье 257725 в которой даются инструкции по сбору диагностических данных для устранения неполадок банка данных (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

  • Дополнительные сведения о производительности сервера Exchange см. в Руководстве по управлению производительностью и масштабируемостью приложения Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Дополнительные сведения об устранении проблем с производительностью сервера Exchange см. в разделе Устранение неполадок, связанных с производительностью приложения Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).


Ошибка доступа к серверу Exchange
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора доступа Microsoft® Exchange не может получить доступ к серверу Exchange. Эта ошибка указывает на то, что заданные вами данные конфигурации сервера Exchange в службе каталогов Active Directory® не обнаружены.

Чтобы устранить эту ошибку

  • Проверьте, чтобы имя сервера было введено правильно.

  • Введите для сервера только имя компьютера или имя NetBIOS (например, Server1) вместо полного доменного имени (например, Server1.example.com).

  • Проверьте, чтобы у вас были разрешения, необходимые для доступа к данным конфигурации Active Directory для данного сервера.


Ошибка доступа к информации о сервере Exchange Server
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Произошла ошибка при попытке средства анализа сервера Microsoft® Exchange обратиться к службе каталогов Active Directory®, чтобы получить конфигурационную информацию о сервере Exchange.

Чтобы устранить эту ошибку:

  • Проверьте, что учетная запись, с которой вы выполнили вход, имеет соответствующие разрешения на чтение конфигурационной информации о сервере Exchange в службе каталогов Active Directory.

  • Убедитесь в наличии сетевого доступа к контроллеру домена Active Directory.

  • Введите явным образом учетные данные для доступа к Active Directory в средство анализа сервера Exchange.

  • Укажите контроллер домена Active Directory в анализаторе сервера Exchange.

  • Убедитесь, что указанный вами сервер Exchange существует и имя сервера введено корректно.


Ошибка доступа к журналу отслеживания сообщений
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-06

Средство анализатора сервера Microsoft® Exchange запрашивает свойство MessageID по каждому экземпляру WMI-класса (Microsoft Windows® Management Instrumentation) Exchange_MessageTrackingEntry.

Если анализатор сервера Exchange не получает ответ на запрос, анализатор сервера Exchange выдает на экран сообщение об ошибке.

Наиболее вероятной причиной этой ошибки является то, что центр отслеживания сообщений отключен.

Центр отслеживания сообщений, если он включен, регистрирует в журнале информацию об отправителе, сообщении электронной почты и получателях сообщения. В частности, можно просмотреть статистику, например время отправки или получения сообщения, размер и приоритет сообщения, а также список получателей сообщения. Можно также заносить в журнал строки тем сообщений электронной почты. Центр отслеживания сообщений осуществляет поиск сообщений, например системных сообщений, сообщений об общих папках и сообщений электронной почты.

Следует включить центр отслеживания сообщений на каждом сервере, для которого предполагается отслеживать сообщения. Когда эта функция включена, все сообщения, направляемые через сервер, заносятся в журналы отслеживания сообщений.

Для запуска сканирования анализатора сервера Exchange необходимо, чтобы отслеживание сообщений было включено.

Примечание.
Для выполнения этой процедуры необходимы следующие разрешения: члена локальной группы администраторов и члена группы, содержащей роль администраторов Exchange, применяемой на уровне административной группы
Чтобы включить на сервере центр отслеживания сообщений

  1. В диспетчере Exchange разверните узел Серверы, щелкните правой кнопкой мыши сервер, на котором предполагается включить отслеживание сообщений, и затем щелкните Свойства.

  2. На вкладке Общие установите флажок Включить отслеживание сообщений.

  3. Для записи темы сообщения, посылаемого на сервер, с сервера или через сервер, установите флажок Включить занесение в журнал и отображение темы.

    Примечание.
    Включение занесения в журнал темы может привести к снижению производительности.

  4. В группе Обслуживание файлов журнала можно предотвратить удаление файлов журнала или изменить длительность хранения файлов журнала. По умолчанию период хранения журналов отслеживания составляет семь дней.

    Примечание.
    На серверах, обрабатывающих большие объемы почты, объем журналов отслеживания растет очень быстро. Проверьте, чтобы на диске было достаточно места для файлов журналов и для других служб или приложений, использующих данный диск.

  5. Нажмите кнопку ОК или Применить. Для вступления данного изменения в действие нет необходимости перезапускать службы.

Дополнительные сведения о порядке использования центра отслеживания сообщений см. в базе знаний Майкрософт в статье 262162 "XADM: Using the Message Tracking Center to Track a Message" (XADM: использование центра отслеживания сообщений для отслеживания сообщений) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

Дополнительные сведения о решении проблем транспорта сервера Exchange см. в базе знаний Майкрософт в статье 821910 "How to troubleshoot for Exchange Server 2003 transport issues" (Как устранить неполадки с транспортом в приложении Exchange Server 2003) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).


Ошибка при обновлении списков управления доступом
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-02-15

Средство анализа Microsoft Exchange запрашивает класс WMI Win32_NTLogEvent для определения того, была ли в течение последнего часа зарегистрирована ошибка 9551 для объекта MSExchangeIS.

Если ошибка 9551 была зарегистрирована в течение последнего часа, средство анализа Exchange подсчитывает общее количество ошибок 9551, зарегистрированных за это время.

Если ошибка 9551 была зарегистрирована в течение последнего часа 20 или более раз, средство анализа Exchange отображает предупреждение.

Эта ошибка свидетельствует о том, что в списке управления доступом для ресурса почтового ящика или общей папки могут присутствовать учетные записи пользователей, не сопоставленные с действительными объектами службы каталогов Active Directory.

Чтобы почтовый ящик на сервере с Microsoft Exchange Server 2003 или Exchange 2000 Server был доступен, он должен быть представлен в Active Directory действительной учетной записью пользователя службы каталогов Active Directory.

Учетная запись, не имеющая действительного представления в Active Directory, может быть создана, если после удаления почтового ящика на компьютере с Exchange Server 5.5 не выполнялось обновление ресурса почтового ящика или общей папки Exchange 2000 Server или Exchange Server 2003.

Если учетная запись удаленного почтового ящика остается в списке управления доступом ресурса почтового ящика или общей папки, каждый раз, когда осуществляется доступ к ресурсу почтового ящика или общей папке и сервер Exchange пытается выполнить разрешение указанных учетных записей, сделать это для учетной записи без действительного представления в Active Directory ему не удается. Это может приводить к снижению производительности.

Для устранения этой проблемы выполните следующие действия.

  • Убедитесь в том, что на компьютере установлен пакет обновления 3 (SP3) или более поздний пакет обновления для Exchange 2000 Server. Сведения о получении последнего пакета обновлений для Exchange 2000 Server см. в статье 301378 базы знаний Майкрософт, «Как получить последний пакет обновления для Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378).

  • С помощью диспетчера Exchange удалите вручную неверные учетные записи почтовых ящиков из списка управления доступом.

  • Если среда Exchange работает в смешанном режиме Exchange, запустите для банка данных проверку согласованности службы каталогов с банком данных.

  • Если среда Exchange работает в основном режиме Exchange, см. инструкции, приведенные в статье 324323 базы знаний Майкрософт «XADM: Пропуск учетных записей пользователей, не представленных в Active Directory, в ходе преобразования списка управления доступом» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324323, на английском языке).

Удаление неверных учетных записей почтовых ящиков из списка управления доступом вручную с помощью диспетчера Exchange

  1. Запустите диспетчер Exchange и найдите папку, указанную в сообщении об ошибке 9551.

  2. Щелкните папку правой кнопкой мыши и выберите пункт Свойства.

  3. Откройте вкладку Разрешения и щелкните пункт Разрешения клиента.

  4. В области Имя выделите учетную запись, указанную в сообщении об ошибке 9551, и нажмите кнопку «Удалить», чтобы удалить учетную запись из списка управления доступом.
Запуск средства проверки согласованности службы каталогов с банком данных для банка данных в смешанном режиме Exchange

  1. В программе «Администратор сервера Exchange Server 5.5» щелкните компьютер с сервером Exchange 5.5, на котором находится банк данных.

  2. В меню File выберите пункт Properties, после чего откройте вкладку Advanced.

  3. Щелкните элемент Consistency Adjustment.

  4. Установите флажки Remove unknown user accounts from public folder permissions и Remove unknown user accounts from mailbox permissions, после чего щелкните пункт All Inconsistencies.

  5. Снимите все остальные флажки и нажмите кнопку ОК.

Дополнительные сведения

Дополнительные сведения об этой проблеме см. в следующих статьях базы знаний Майкрософт и материалах по Exchange Server:

  • «Центр событий и сообщений об ошибках. Сведения о событии 9551 хранилища почтовых ящиков MSExchangeIS» (http://go.microsoft.com/fwlink/?LinkId=83189, на английском языке).

  • Статья 301378 базы знаний Майкрософт «Как получить последний пакет обновления для Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378).

  • Статья 324323 базы знаний Майкрософт «XADM: Пропуск учетных записей пользователей, не представленных в Active Directory, в ходе преобразования списка управления доступом» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324323, на английском языке).


Отсутствует файл ESE.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-04-21

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы проверить наличие нескольких основных двоичных файлов Exchange:

  • Exres.dll

  • Gapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»),

  • Mapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»),

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если средство анализатора сервера Exchange обнаруживает, что отсутствует один или несколько из этих файлов, выводится сообщение об ошибке. Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если ошибку не удалось устранить, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в привод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если вы согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2000 см. на веб-узле загружаемых ресурсов Exchange Server 2000 (http://go.microsoft.com/fwlink/?LinkId=25097).


Отсутствует файл ESEUTIL.EXE
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить наличие нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange определяет, что отсутствует один или несколько файлов, отображается сообщение об ошибке. Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если это не устранит ошибку, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-значный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=33457).


Файл EXCDO.DLL отсутствует
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы проверить наличие нескольких основных двоичных файлов Exchange:

  • Exres.dll

  • Gapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»),

  • Mapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»),

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если средство анализатора сервера Exchange обнаруживает, что отсутствует один или несколько из этих файлов, выводится сообщение об ошибке. Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если ошибку не удалось устранить, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа установки не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. После переустановки сервера Exchange необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Переустановка Exchange 2000 Server или Exchange Server 2003

  1. Войдите в систему сервера, на котором необходимо переустановить Exchange. Вставьте компакт-диск Exchange 2000 Server или Exchange Server 2003 в привод компакт-дисков.

  2. В меню Пуск выберите команду Выполнить, а затем введите <диск>:\setup\i386\setup, где <диск> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. В случае согласия с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=25097 (возможно, на английском языке).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server по адресу http://go.microsoft.com/fwlink/?LinkId=33457 (возможно, на английском языке).


Отсутствует файл EXCHMEM.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы проверить несколько основных двоичных файлов:

  • Exres.dll,

  • Gapi32.dll (проверяется в папке System32 и в папке \Exchsrvr\bin),

  • Mapi32.dll (проверяется в папке System32 и в папке \Exchsrvr\bin),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange определяет, что отсутствует один или несколько файлов, отображается сообщение об ошибке. Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если это не устранит ошибку, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-значный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Файл EXMIME.DLL отсутствует
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы проверить несколько основных двоичных файлов:

  • Exres.dll

  • Gapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»)

  • Mapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если средство анализатора сервера Exchange обнаруживает, что отсутствует один или несколько из этих файлов, выводится сообщение об ошибке. Чтобы устранить эту ошибку, установите последний пакет обновления или сборку обновления для своей версии Exchange. Если ошибку не удалось устранить, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в устройство чтения компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие нажмите кнопку с указывающей вниз стрелкой рядом с узлом Microsoft Exchange, выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Отсутствует файл EXOLEDB.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы проверить наличие нескольких основных двоичных файлов Exchange:

  • Exres.dll

  • Gapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin)

  • Mapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если анализатор сервера Exchange обнаруживает, что отсутствует один или несколько из этих файлов, выводится сообщение об ошибке. Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если ошибку не удалось устранить, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. После переустановки сервера Exchange необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Переустановка Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте компакт-диск Exchange 2000 Server или Exchange Server 2003 в дисковод компакт-дисков.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-значный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Файл EXPOP3.DLL отсутствует
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы проверить несколько основных двоичных файлов Exchange:

  • Exres.dll

  • Gapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»)

  • Mapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если анализатор сервера Exchange определяет, что отсутствует один или несколько файлов, выводится сообщение об ошибке. Чтобы устранить эту ошибку, установите последний пакет обновления или сборку обновления для своей версии Exchange. Если ошибку не удалось устранить, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в устройство чтения компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие нажмите кнопку с указывающей вниз стрелкой рядом с узлом Microsoft Exchange, выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2000 см. на веб-узле загружаемых ресурсов Exchange Server 2000 (http://go.microsoft.com/fwlink/?LinkId=33457).


Файл EXPROX.DLL отсутствует
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы проверить несколько основных двоичных файлов:

  • Exres.dll,

  • Gapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange обнаруживает, что один или более файлов отсутствуют, на экран выводится сообщение об ошибке. Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если эта ошибка остается, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Отсутствует файл EXRES.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить наличие нескольких основных двоичных файлов Exchange:

  • Exres.dll

  • Gapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin)

  • Mapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если анализатор сервера Exchange определяет, что отсутствует один или несколько файлов, отображается сообщение об ошибке. Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если это не устранит ошибку, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-значный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Отсутствует файл EXSMTP.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server запрашивает класс CIM_Datafile инструментария Microsoft Windows® Management Instrumentation (WMI), чтобы проверить наличие некоторых основных двоичных файлов Exchange:

  • Exres.dll

  • Gapi32.dll (проверяется в папке System32 и в папке \Exchsrvr\bin)

  • Mapi32.dll (проверяется в папке System32 и в папке \Exchsrvr\bin folder)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если средство анализа Exchange Server обнаружит, что одного или нескольких файлов недостает, появится сообщение об ошибке. Чтобы исправить ошибку, установите последний пакет обновлений или накопительный пакет обновлений для своей версии Exchange. Если ошибка останется, запустите установку Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Данные пользователей и данные настройки не удаляются и не сбрасываются. При переустановке сервера Exchange необходимо также переустановить все установленные пакеты обновлений и исправления.

Переустановка Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором нужно переустановить Exchange. Вставьте компакт-диск Exchange 2000 Server или Exchange Server 2003 в дисковод CD-ROM.

  2. В меню Пуск выберите пункт Выполнить, введите <диск>:\setup\i386\setup, где <диск> — буква дисковода CD-ROM.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение прочтите лицензионное соглашение. Если вы согласны с его условиями, нажмите кнопки Я согласен и Далее.

  5. На странице Идентификация продукта введите 25-значный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь стрелкой раскрывающегося списка рядом с узлом Microsoft Exchange и выберите Переустановить, затем нажмите кнопку Далее.

Для получения дополнительных сведений о последних пакетах обновлений для Exchange Server 2003, накопительных пакетах обновлений и надстройках см. раздел загрузок для Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Для получения дополнительных сведений о последних пакетах обновлений для Exchange 2000 Server, накопительных пакетах обновлений и надстройках см. раздел загрузок для Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=25097).


Версия файла EXSMTP.DLL устарела
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Сообщение об ошибке

Введение

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version для файла EXSMTP.DLL. Если анализатор сервера Exchange обнаруживает, что значение ключа Version для файла EXSMTP.DLL отличается от 6556.0, на экран выводится предупреждение.

Это предупреждение указывает на то, что на компьютере под управлением Exchange Server установлен файл EXSMTP.DLL из набора исправлений версии 1 (май 2004 г.), выпущенных после пакета обновления 3 для Exchange 2000. Для загрузки доступен набор исправлений более поздней версии.

Чтобы устранить причину появления этого предупреждения

  1. Загрузите новейшее обновление (август 2004 г.) на веб-узле файлов загрузки для Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).

  2. Прочитайте сведения о новейшем обновлении в статье 870540 базы знаний корпорации Майкрософт, описывающей набор исправлений за август 2004 г., выпущенных после пакета обновления 3 для Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540).

  3. Выполните полное резервное копирование компьютера с Exchange Server.

  4. Примените обновление за август 2004 г.

Дополнительные сведения об установке этого и других обновлений для Exchange Server см. в статье 328839 базы знаний Майкрософт, описывающей применение пакетов обновления и исправлений для Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Трассировка Exchange ActiveSync в настоящее время включена
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, включена ли трассировка для Exchange ActiveSync®, средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Tracing\Microsoft Server ActiveSync\MasSync\Enabled

Если анализатор сервера Exchange обнаружит, что значение Enabled существует и установлено равным любому числовому значению больше 0, на экран выводится предупреждение.

Exchange ActiveSync используется в качестве расширения ISAPI в службах IIS. IIS, Exchange ActiveSync и множество клиентских устройств, использующих Exchange ActiveSync, содержат собственные возможности трассировки, что указывает на необходимость использовать в Microsoft Windows Server™ 2003 собственные возможности трассировки.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\Software\Microsoft\Windows NT\CurrentVersion\Tracing\Microsoft Server ActiveSync\MasSync

  3. Удалите раздел Enabled.

  4. Закройте редактор реестра и перезапустите компьютер сервера Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о трассировке и ведению журналов для Exchange ActiveSync и клиентов Exchange ActiveSync см. в следующих статьях базы знаний Майкрософт:

  • статья 330463, посвященная инструкциям по устранению неполадок, связанных с кодами ошибок HTTP ActiveSync на сервере (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=330463);

  • статья 330461, описывающая устранение неполадок с ActiveSync на сервере (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=330461);

  • статья 822176, описывающая устранение неполадок с уведомлением о постоянном обновлении на серверах Exchange 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822176);


Версия двоичного файла Exchange является более новой, чем установленная версия сервера Exchange
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение раздела Version для нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (проверяется в папке System32 и в папке \Exchsrvr\bin),

  • Mapi32.dll (проверяется в папке System32 и в папке \Exchsrvr\bin),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange обнаружит, что значение Version для какого-либо из файлов меньше значения Version сервера Exchange, будет выведено предупреждение. Более поздний номер версии указывает, что файл новее, чем был ожидаем. Это может произойти при установке исправления.

Чтобы устранить причину появления этого предупреждения

  1. Нет необходимости предпринимать что-либо. Это предупреждение означает только то, что существуют более новые файлы, причиной чему могла послужить установка исправления или другого обновления.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Этот узел кластера Exchange также является контроллером домена
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-объект (Microsoft Windows® Management Instrumentation) (класс Win32_ComputerSystem), чтобы определить для сервера значение DomainRole. Значение DomainRole представляет роль компьютера в домене. В приведенной ниже таблице перечислены допустимые значения DomainRole.

Значение | Описание
0 | Изолированная рабочая станция
1 | Рядовая рабочая станция
2 | Изолированный сервер
3 | Рядовой сервер
4 | Резервный контроллер домена
5 | Основной контроллер домена

Кроме того, анализатор сервера Exchange запрашивает WMI-объект ClusSvc (объект Windows Cluster Service, класс Win32_Service), чтобы определить значение Started. Значение True указывает, что служба кластеров запущена, а значение False означает, что она не запущена.

Если анализатор сервера Exchange определяет, что значение DomainRole превышает 3 на компьютере с Exchange Server, на котором запущена служба кластеров, отображается сообщение об ошибке. Эта ошибка указывает, что сервер Exchange запущен на кластере серверов Windows, узлы которого являются контроллерами домена.

Работа узла кластера с сервером Exchange Server в качестве контроллера домена не является поддерживаемой конфигурацией.

Чтобы устранить эту ошибку

  1. Выберите некластерный сервер в качестве контроллера домена и запустите мастер установки Active Directory (dcpromo), чтобы удалить север.

  2. После настройки службы каталогов Active Directory® на новом контроллере домена подождите, пока содержимое существующей службы каталогов Active Directory реплицируется на новый сервер.

    В зависимости от размера службы каталогов Active Directory, выполнение этой операции может потребовать несколько часов.

  3. Запустите мастер установки Active Directory (dcpromo) на кластерном сервере, чтобы понизить роль сервера и удалить Active Directory.

Дополнительные сведения о повышении и понижении роли контроллеров домена см. в статье 238369 базы знаний Майкрософт, содержащей инструкции по повышению и понижению роли контроллеров домена в Windows 2000 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320053).


Отчетность об ошибках Exchange отключена
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-04-21

Чтобы определить включен или нет вывод сообщений об ошибках Exchange, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\DisableErrorReporting

Если анализатор сервера Exchange обнаружит, что значение DisableErrorReporting равно 1, на экран будет выведено предупреждение. Значение 1 указывает, что отчетность об ошибках выключена.

Поддержка функции отчетности об ошибках для Майкрософт, которая также упоминается как отчетность об ошибках Windows (Windows Error Reporting), отчетность о событиях для Майкрософт (Microsoft Event Reporting) и автоматическая отчетность об ошибках (Automatic Error Reporting), была первоначально добавлена в пакет обновления 2 (SP2) для Exchange 2000 Server. Приложение Exchange Server 2003 содержит расширенную версию функции отчетности об ошибках для Майкрософт, называемую отчетностью об ошибках Exchange, которая упрощает подготовку отчетов об ошибках для администраторов, объединяет эту функцию с корпоративными отчетами об ошибках и предоставляет расширенную функцию отчетности для службы обновления получателей Exchange Server 2003.

Функция отчетности об ошибках Exchange предоставляет администраторам серверов Exchange возможность передачи сведений об аварийных отказах и других неисправимых ошибках по протоколу HTTPS через Интернет в корпорацию Майкрософт на сервер отчетов об ошибках. Рекомендуется отправлять отчеты об ошибках в корпорацию Майкрософт в интерактивную службу анализа аварийных отказов. Собираемые данные о неисправимых ошибках с серверов Exchange помогают группе поддержки Exchange находить и устранять ошибки в используемом программном обеспечении.

Если неисправимая ошибка возникает при использовании системного диспетчера Exchange или во время выполнения задачи, относящейся к Exchange, с помощью оснастки «Active Directory — пользователи и компьютеры» на компьютере с установленным системным диспетчером Exchange, функция отчетности об ошибках Exchange уведомляет администратора об ошибке и выводит подсказки по отправке отчета об ошибке в корпорацию Майкрософт. Дополнительно, функция отчетности об ошибках Exchange также отлавливает ошибки, возникающие при работе системного помощника Microsoft Exchange, банка данных Microsoft Exchange и других служб Exchange, а также выводит отчеты об этих ошибках. Кроме того, поскольку ошибки службы обновления получателей могут оставить компонент системного помощника в плохом состоянии, функция отчетности об ошибках Exchange также сообщает о нарушениях прав доступа и других внутренних ошибках, которые возникают в службе обновления получателей.

Каждый сервер Exchange можно настроить на отправку сведений о неисправимых ошибках, установив флажок на странице свойств сервера в системном диспетчере Exchange.

Чтобы настроить приложение Exchange 2000 Server или Exchange Server 2003 на отправку сведений о неисправимых ошибках сервера в корпорацию Майкрософт

  1. Откройте системный диспетчер Exchange

  2. Разверните узел Административные группы, разверните административную группу, разверните узел Серверы, щелкните правой кнопкой мыши сервер и в контекстном меню выберите пункт Свойства. Если узел Административные группы не отображается в системном диспетчере Exchange, разверните узел Серверы, щелкните правой кнопкой мыши свой сервер и в контекстном меню выберите пункт Свойства.

  3. На вкладке Общие страницы <Имя сервера> — свойства установите флажок Автоматически отправлять сведения о неустранимых ошибках служб в корпорацию Майкрософт, а затем щелкните Применить.

  4. Щелкните Да, чтобы подтвердить включение функции отчетности об ошибках Exchange.

  5. Нажмите кнопку ОК.

Когда возникает неисправимая ошибка, создается сжатый файл отчета об ошибке (обычно 10-50 килобайтов). Среди прочих сведений этот отчет содержит файл дампа. Файл дампа — это файл, содержащий сведения о процессе, в котором возникла ошибка. Хотя ошибки могут возникать на различных уровнях программирования (например, на уровне потока, на уровне интерфейса, а также на уровне метода или функции), все они возникают в контексте одного процесса. Обычно файл дампа содержит сведения о процессе, подвергшемся ошибке, например сведения о том, какой поток выполнялся, о различных областях памяти, используемых процессом, системные сведения и другую важную отладочную информацию. Для сервера Exchange отчеты об ошибках также включают сведения о состоянии сервера Exchange, информацию о версии операционной системы, сведения об оборудовании компьютера, IP-адресе компьютера и цифровой код продукта, используемый для идентификации лицензии на продукт.

Хотя корпорация Майкрософт не собирает намеренно личные сведения, ею подтверждается тот факт, что некоторые из собираемых сведений могут содержать информацию, которая позволяет уникально идентифицировать систему пользователя. Однако корпорация Майкрософт не использует собираемые данные для идентификации системы, эти данные служат лишь основой для подготовки отчетов об аварийных отказах и для устранения ошибок в программном коде. Дополнительные сведения см. в описании политики составления отчетов об ошибках, «Политика сбора данных» (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=33818).


В файле Boot.ini этого сервера Exchange переднего плана содержится переключатель загрузки /3GB
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает WMI-класс Win32_OperatingSystem, чтобы определить количество виртуального адресного пространства, выделенного для процессов пользовательского режима (MaxProcessMemorySize) на компьютере сервера Exchange. Анализатор Exchange Server также исследует WMI-класс Exchange_Server в пространстве имен root\MicrosoftExchangeV2, чтобы определить значение раздела IsFrontEndServer. Значение False означает, что компьютер сервера Exchange не является внешним сервером. Значение True означает, что компьютер сервера Exchange является сервером переднего плана.

Если анализатор сервера Exchange определяет, что значение раздела MaxProcessMemorySize не равняется 2097024, а значение ключа IsFrontEndServer равняется True, отображается предупреждение.

Это предупреждение указывает, что сервер каталогов неправильно настроен для оптимального использования памяти, поскольку в файле Boot.ini установлен переключатель загрузки /3GB. Этот переключатель следует использовать только на серверах Exchange, имеющих память объемом 1 гигабайт (ГБ) или более и работающих под управлением любой из следующих операционных систем:

  • Microsoft Windows Server™ 2003 Standard Edition,

  • Microsoft Windows Server 2003 Enterprise Edition,

  • Microsoft Windows Server 2003 Datacenter Edition,

  • Microsoft Windows 2000 Advanced Server,

  • Microsoft Windows 2000 Datacenter Server.

Важно!
Переключатель /3GB не должен использоваться в Windows 2000 Server, так как он не поддерживается и может быть причиной отказов приложений или операционной системы. Более того, переключатель /3GB поддерживается указанными выше операционными системами только в том случае, если на компьютере установлена физическая память объемом 1 ГБ и более.

Если параметр /3GB содержится в файле Boot.ini на сервере, работающем под управлением Microsoft Windows 2000 Server или Windows Server 2003, Windows выделяет 3 ГБ из общих 4 ГБ виртуального адресного пространства для пользовательских процессов и 1 ГБ для процессов ядра. Обычно (если не используется параметр /3GB), Windows выделяет 2 ГБ для пользовательских процессов и 2 ГБ для процессов ядра. Поэтому при установленном переключателе /3GB приложения, усиленно использующие память, имеют большее виртуальное адресное пространство для работы, что приводит к увеличению производительности.

Использование переключателя /3GB в основном способствует приложениям, усиленно использующим память, например, Store.exe, на сервере Exchange, на котором размещены почтовые ящики. Сервер переднего плана не содержит почтовых ящиков пользователей, поэтому нет необходимости использовать на нем /3GB.

Чтобы устранить причину появления этого предупреждения

  1. В проводнике Windows перейдите к системному разделу.

  2. Если файл Boot.ini не виден, возможно, в свойствах папки установлен флажок Скрывать защищенные системные файлы. Если это так, в окне проводника Windows последовательно щелкните Сервис, Свойства папки, а затем откройте вкладку Вид. Снимите флажок Скрывать защищенные системные файлы (рекомендуется). Когда появится окно предупреждения, щелкните Да.

  3. Если файл Boot.ini виден в проводнике Windows, щелкните правой кнопкой мыши этот файл, выберите в контекстном меню команду Открыть с помощью и щелкните Блокнот, чтобы открыть файл.

  4. В разделе [Operating Systems] удалите из всех строк загрузки следующий переключатель: /3GB

  5. Сохраните изменения и закройте «Блокнот».

  6. Перезагрузите компьютер, чтобы изменение вступило в силу.

Дополнительные сведения об использовании переключателей загрузки /3GB и /USERVA см. в следующих статьях базы знаний Майкрософт:

  • 297812, описывающая функцию настройки ОЗУ, 4GT (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812);

  • 311901, описывающая влияние настройки 4GT на системные элементы таблицы страниц (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901);

  • 31679, описывающая использование переключателя /USERVA в файле Boot.ini для настройки конфигураций с переключателем /3GB (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739);

  • 325044, описывающая инструкции по устранению проблем, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044);

  • 815372, описывающая оптимизацию использования памяти в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372).


IFS-диск Exchange не был явно исключен из резервного копирования Windows
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра, чтобы определить файлы и папки, которые были исключены из резервных копий с помощью средства резервного копирования:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

Анализатор сервера Exchange отдельно ищет строковое значение Exchange IFS.

Анализатор сервера Exchange также считывает следующее значение реестра, чтобы получить букву диска, представляющую IFS-диск Exchange:

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

В Exchange 2000 Server буквой диска по умолчанию является M. IFS-диск в Exchange Server 2003 по умолчанию отключен.

Если анализатор сервера Exchange обнаружит отсутствие строкового значения Exchange IFS в разделе реестра FilesNotToBackup или если это значение будет указано, но данные Exchange IFS не будут равняться M:\* /s (где M — это буква диска, представляющая IFS), будет отображено предупреждение.

По умолчанию, если разрешено сопоставление букве диска IFS, Exchange IFS добавляется в раздел реестра FilesNotToBackup. Диск M:\ drive — это логическое представление хранилища Exhange, а не действительный диск, поэтому создание его резервной копии может вызвать серьезные неполадки, например потерю вложений. Кроме того, программное обеспечение, предназначенное для создания резервных копий, может не выполнять правильное усечение журналов, что может привести к непредвиденному сокращению дискового пространства.

Если резервное копирование не используется, не обращайте внимание на это сообщение. Если используется резервное копирование, рекомендуется исключить IFS-диск из всех заданий по созданию резервных копий. Если создается резервная копия IFS-диска с помощью любой программы для создания резервных копий, базы данных банка данных могут быть повреждены, данные могут быть потеряны и восстановление данных из резервной копии IFS-диска может оказаться невозможным.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

  3. Правой кнопкой мыши щелкните FilesNotToBackup и щелкните Раздел| Мультистроковый параметр. Введите Exchange IFS в качестве имени и нажмите кнопку ENTER.

  4. В правой области дважды щелкните Exchange IFS и введите значение M:\* /s. Убедитесь, что введена правильная буква диска в том случае, если в системе не используется буква диска M по умолчанию.

  5. Закройте редактор реестра.

Дополнительные сведения о реестре Microsoft Windows® см. в статье 256986 базы знаний Майкрософт, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Дополнительные сведения о резервном копировании и восстановлении Exchange см. на странице, посвященной руководству по аварийному восстановлению Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47570). Дополнительные сведения см. в следующих статьях базы знаний Майкрософт:

  • 258243, посвященной резервному копированию и восстановлению компьютера Exchange с помощью программы резервного копирования Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=258243)

  • 233427, посвященная файлам и папкам, которые не включены в резервное копирование при использовании средства Ntbackup.exe в операционных системах Windows Server 2003, Windows XP и Windows 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=233427)

Дополнительные сведения о неполадках, которые могут произойти при сканировании IFS-диска, см. в следующих статьях базы данных:

  • 298924, посвященная необходимости не выполнять архивирования и антивирусного сканирования диска M сервера Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, посвященная сообщению об ошибке C1041737, отображаемому при подключении базы данных (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, посвященная исчезновению элементов календаря из пользовательских папок (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


Объем памяти почтового сервера Exchange равен 1 ГБ или более, однако для него не установлен переключатель /3GB в файле Boot.ini
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает два WMI-класса (Microsoft Windows® Management Instrumentation), чтобы определить объем физической памяти на сервере Exchange и объем виртуального адресного пространства, выделенного для процессов пользовательского режима. В следующей таблице описываются классы и ключи, оцениваемые анализатором сервера Exchange.

Запрашиваемый класс | Запрашиваемые ключи | Описание
Win32_OperatingSystem | MaxProcessMemorySize | Максимальное количество килобайтов памяти, которая может быть выделена для процесса.
Win32_OperatingSystem | OSProductSuite | Установленные и лицензированные дополнения системных продуктов для операционной системы.
Win32_ComputerSystem | TotalPhysicalMemory | Количество байтов памяти с произвольной выборкой (ОЗУ), установленной на компьютере.

Если анализатор сервера Exchange определит, что компьютер сервера Exchange работает под управлением операционной системы, отличной от Windows 2000 Server, на компьютере установлено физической памяти объемом 1 ГБ или более и значение MaxProcessMemorySize больше 2097024, но меньше 3104640, на экран будет выведено предупреждение.

Это предупреждение указывает, что сервер Exchange не соответствует требованиям, изложенным в базе знаний Майкрософт в статье 266096, описывающей необходимость установки для Exchange 2000 переключателя /3GB на компьютере с ОЗУ равным 1 гигабайту и более (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096). Такая конфигурация не является рекомендуемой производственной конфигурацией.

Операционная система Microsoft Windows Server™ 2003 поддерживает два переключателя загрузки — /3GB и /USERVA — которые позволяют настроить выделение памяти и адресного пространства памяти. Независимо от объема физической памяти в системе операционная система Windows использует виртуальное адресное пространство 4 ГБ, из которых 2 ГБ выделены для процессов в пользовательском режиме (например, приложений) и 2 ГБ выделены для процессов в режиме ядра (например, операционная система и драйверы, работающие в защищенном режиме). Для систем с объемом физической памяти 1 ГБ и более эти два переключателя загрузки могут использоваться для выделения большей памяти приложениям (3 ГБ) и меньшей памяти операционной системе (1 ГБ). Это дополнительное виртуальное адресное пространство помогает уменьшить степень фрагментации памяти в виртуальном адресном пространстве процесса банка данных Exchange.

Переключатель /3GB используется для реализации этого изменения выделяемой памяти. Переключатель задается в системном файле Boot.ini и вступает в силу после перезапуска. Этот переключатель следует использовать только на серверах Exchange, имеющих память объемом 1 ГБ или более и работающих под управлением любой из следующих операционных систем:

  • Microsoft Windows Server 2003 Standard Edition,

  • Microsoft Windows Server 2003 Enterprise Edition,

  • Microsoft Windows Server 2003 Datacenter Edition,

  • Microsoft Windows 2000 Advanced Server,

  • Microsoft Windows 2000 Datacenter Server.

Важно!
Переключатель /3GB не должен использоваться в Windows 2000 Server, так как он не поддерживается и может быть причиной отказов приложений или операционной системы. Более того, переключатель /3GB поддерживается указанными выше операционными системами только в том случае, если на компьютере установлена физическая память объемом 1 ГБ и более.

Переключатель /USERVA появился впервые в Windows Server 2003. Его назначение — предоставление более точного управления разделением виртуального адресного пространства между процессами, выполняющимися в пользовательском режиме, и процессами в режиме ядра. Данный переключатель должен использоваться только для приложений, таких как Exchange 2000 Server и Exchange Server 2003, которые поддерживают его, и со специальными значениями, поддерживаемыми данными приложениями.

Примечание.
Служба поддержки продуктов Майкрософт не поддерживает произвольные настройки переключателя /USERVA. Клиенты должны добавить эту настройку в файл Boot.ini только на основе рекомендаций производителя.

При использовании в системах Exchange Server 2003 единственное поддерживаемое значение переключателя /USERVA равно 3030 (например, /USERVA=3030). Когда установлено это значение, операционной системе выделяется дополнительные 40 мегабайтов (МБ), что позволяет добавить пользователей без расходования всех доступных ресурсов.

Чтобы устранить причину появления этого предупреждения

  1. Щелкните правой кнопкой мыши Мой компьютер и в контекстном меню выберите Свойства. Появится диалоговое окно Свойства системы.

  2. Откройте вкладку Дополнительно.

  3. В области «Загрузка и восстановление» щелкните Параметры. Появится диалоговое окно Загрузка и восстановление.

  4. В области «Загрузка операционной системы» щелкните Изменить. В результате этих действий в «Блокноте» откроется файл Boot.ini операционной системы Windows.

  5. В части [Operating Systems] (Операционные системы) добавьте в конец строки загрузки, которая содержит переключатель /fastdetect, следующие переключатели: /3GB /USERVA=3030

  6. Сохраните изменения и закройте «Блокнот».

  7. Нажмите два раза кнопку OK, чтобы закрыть открытые диалоговые окна, и затем перезапустите компьютер сервера Exchange, чтобы изменение вступило в силу.

Дополнительные сведения об оптимизации использования памяти для сервера Exchange см. в следующих статьях базы знаний Майкрософт:

  • Статья 266096, описывающая необходимость установки для Exchange 2000 переключателя /3GB на компьютере с ОЗУ 1 гигабайт и более (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096).

  • Статья 325044, описывающая инструкции по устранению проблем, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044).

  • Статья 815372, описывающая оптимизацию использования памяти в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372).

  • Статья 810371, описывающая использование переключателя /Userva на сервере Exchange, выполняемом на компьютере под управлением Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371).

  • Статья 823440, описывающая необходимость использования переключателя /3GB при установке Exchange Server 2003 на компьютере под управлением Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440).

  • Статья 822178, содержащая обзор зависимостей и требований для поддержки функций Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822178).


Включена трассировка поставщика Exchange
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-06-20

Анализатор сервера Microsoft Exchange Server опрашивает службу каталогов Active Directory для определения значения атрибута serialNumber для всех объектов с классом объектов msExchExchangeServer. Если строковое значение содержит выражение «Version 5.5», на компьютере установлен сервер Microsoft Exchange Server 5.5. Если строковое значение содержит выражение «Version 6.0», на компьютере установлен сервер Microsoft Exchange 2000 Server. Если строковое значение содержит выражение «Version 6.5», на компьютере установлен сервер Microsoft Exchange Server 2003. Если строковое значение содержит выражение «Version 8.0», на компьютере установлен сервер Microsoft Exchange Server 2007.

Анализатор Exchange также запрашивает класс CIM_Datafile инструментария управления Microsoft® Windows® (WMI), чтобы определить значение раздела Version для библиотеки Emsmdb32.dll, поставщика транспорта Exchange. Раздел WMI Version указывает на номер сборки для этого файла.

Наконец, анализатор Exchange запрашивает следующий параметр реестра, чтобы определить, была ли настроена и включена трассировка поставщика Exchange:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Enable Tracing

Если выполняются следующие условия, анализатор Exchange выводит сообщение об ошибке:

  • на сервере не установлен Exchange Server 2007;

  • раздел Version для библиотеки Emsmdb32.dll имеет значение 6.5.7233.47 или больше (более поздние версии);

  • параметр HKML\Software\Microsoft\Exchange\Exchange Provider\Enable Tracing существует и имеет значение, отличное от 0.

Эта ошибка показывает, что на компьютере включена трассировка поставщика Exchange.

Поставщик транспорта Exchange версии 6.5.7233.47 и более поздних версий имеет встроенные возможности трассировки. TTD-файл позволяет выполнять трассировку следующих программ:

  • всех программ, использующих протокол MAPI на сервере с Exchange Server 2003;

  • всех программ, установленных с помощью средств управления системой Microsoft Exchange.

Трассировку поставщика транспорта Exchange следует включать только для активного устранения неполадок, поскольку она может негативно влиять на обычную производительность сервера.

Важно!
Эта статья содержит сведения об изменении реестра. Перед изменением реестра убедитесь, что знаете, как восстановить его в случае возникновения проблем. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Отключение трассировки поставщика Exchange в Exchange Server 2003

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу: HKML\Software\Microsoft\Exchange\Exchange Provider\

  3. В правой области переходов выполните указанные ниже действия.

    1. Щелкните правой кнопкой мыши подраздел Enable Tracing и выберите пункт Удалить либо

    2. дважды щелкните подраздел Enable Tracing.

  4. Присвойте подразделу Enable Tracing значение 0.

  5. Закройте редактор реестра.

  6. Чтобы изменения вступили в силу, перезапустите службу банка данных Exchange.

Сведения о внесении изменений в реестр см. в статье 256986 базы знаний МайкрософтОписание реестра Microsoft Windows. Изучите эту статью перед началом изменения реестра.


Служба управления Exchange выполняется не с использованием учетной записи локальной системы
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (WMI — Windows® Management Instrumentation) Win32_Service, чтобы определить значение свойства StartName для службы управления Microsoft Exchange (MSExchangeMGMT). Если анализатор сервера Exchange обнаруживает, что служба управления Exchange работает с использованием учетной записи, отличной от учетной записи локальной системы (SYSTEM), анализатор сервера Exchange выводит на экран сообщение об ошибке.

В этом сообщении об ошибке указано, что служба управления Exchange работает в конфигурации, которая не поддерживается. Запуск службы управления Exchange с использованием любой другой учетной записи приведет к появлению ошибок, связанных с разрешениями и доступом.

Чтобы устранить эту ошибку, необходимо настроить службу управления Exchange так, чтобы она запускалась с использованием учетной записи локальной системы (SYSTEM).

Чтобы настроить учетную запись службы управления Exchange

  1. Откройте оснастку «Службы» консоли управления (MMC).

  2. Найдите и остановите службу Управление Microsoft Exchange.

  3. Дважды щелкните службу Управление Microsoft Exchange.

  4. На вкладке Вход страницы Управление Microsoft Exchange: свойства в группе Вход в систему как выберите вариант учетная запись «Локальная система» и нажмите кнопку Применить.

  5. В разделе Состояние службы щелкните Запустить, а затем нажмите кнопку OK.

  6. Закройте оснастку «Службы».

Дополнительные сведения о запуске служб Exchange с учетной записью локальной системы см. в статье 239762 базы знаний Майкрософт (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762).


Служба управления Exchange остановлена
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation, WMI) Win32_Process, чтобы определить значение ключа Started для экземпляра MSExchangeMGMT, который представляет собой службу управления Microsoft Exchange. Если анализатор сервера Exchange обнаружит, что ключ «Started» экземпляра MSExchangeMGMT не равен «True», на экран будет выведено предупреждение.

Служба управления Exchange была введена в пакете обновления 2 (SP2) Exchange 2000 Server. Среди других обновлений следует отметить зависимость от этой службы функции центра отслеживания сообщений сервера Exchange и некоторых функций системного диспетчера Exchange.

Служба управления Exchange позволяет с помощью пользовательского интерфейса указывать, какой контроллер домена или сервер глобального каталога используется приложением Exchange Server 2003 или Exchange 2000 Server для доступа к службе каталогов Active Directory®. Эта служба также необходима для отслеживания сообщений. Эту службу можно отключить, не оказывая воздействия на основные функции Exchange. Однако при аудите функциональных возможностей сервера Exchange могут потребоваться функции отслеживания сообщений на всех компьютерах сервера Exchange, которые участвуют в маршрутизации почты.

Примечание.
Так как серверы переднего плана наиболее часто используются для доступа к почте, а не для маршрутизации почты, возможно, будет решено, что службу управления Exchange не надо запускать на серверах переднего плана.

Чтобы настроить службу управления Exchange на автоматический запуск

  1. Откройте оснастку «Службы» консоли MMC (Microsoft Management Console).

  2. Дважды щелкните службу Управление Microsoft Exchange.

  3. На вкладке «Общие» страницы Свойства управления Microsoft Exchange выберите Авто в диалоговом окне Тип запуска, а затем щелкните Применить.

  4. В разделе Состояние сервера щелкните Запустить, а затем нажмите кнопку OK.

Дополнительные сведения о службе управления Exchange см. в базе знаний Майкрософт в статье 307413, описывающей общие сведения о службе управления Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307413).

Дополнительные сведения об управлении Exchange см. в руководстве по администрированию Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).


На сервере Exchange 2000 Server не установлен последний пакет обновления
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута versionNumber для каждого объекта Exchange Server. Атрибут versionNumber представляет версию Exchange Server, установленную на компьютере.

Анализатор сервера Exchange также запрашивает класс инструментария управления Windows (WMI) CIM_Datafile, чтобы определить значение параметра Version для процесса STORE.EXE. Если анализатор сервера Exchange обнаруживает, что значение параметра Version для процесса STORE.EXE больше 4416 и меньше или равно 6249, выводится предупреждение.

Это предупреждение указывает на то, что на компьютере под управлением Exchange Server не выполняется новейший программный код, доступный для данной версии Exchange.

Чтобы устранить причину появления этого предупреждения

  1. Загрузите пакет обновления 3 (SP3) для сервера Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=17058).

  2. Изучите Руководство по развертыванию пакета обновления 3 (SP3) для сервера Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=12337).

  3. Загрузите последнее обновление (август 2004 г.) (http://go.microsoft.com/fwlink/?LinkId=33457).

  4. Сведения о последнем обновлении см. в статье 870540 базы знаний Майкрософт, описывающей доступность сборки обновлений для Exchange 2000 Server, следующей после пакета обновлений 3, которая выпущена в августе 2004 г. (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540).

  5. Выполните полное резервное копирование компьютера сервера Exchange.

  6. Примените пакет обновления 3 (SP3) для Exchange 2000 Server

  7. Примените обновление за август 2004 г.

Дополнительные сведения о получении последнего пакета обновления для Exchange 2000 Server см. в статье 301378 базы знаний Майкрософт, описывающей получение последнего пакета обновления Exchange 2000 Server) (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378).

Дополнительные сведения об установке этого и других обновлений для Exchange Server см. в статье 328839 базы знаний Майкрософт, описывающей применение пакетов обновления и исправлений для Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Exchange 2000 Server не поддерживается системой Windows Server 2003
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Для определения версии операционной системы Microsoft Windows®, установленной на компьютере, использующем Exchange Server, средство анализа Microsoft® Exchange Server считывает следующий параметр реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Если значение параметра CurrentVersion равно 4.0, на компьютере установлена система Microsoft Windows NT® Server 4.0. Если значение равно 5.0 или 5.2, на компьютере установлена Windows 2000 Server или Windows Server™ 2003 соответственно.

Для определения значения атрибута serialNumber всех объектов класса msExchExchangeServer Exchange Server Analyzer направляет запрос службе каталогов Active Directory®. Если строка значения содержит запись «Version 5.5», на компьютере установлен Microsoft Exchange Server версии 5.5. Если строка значения содержит запись «Version 6.0», на компьютере установлен Exchange 2000 Server. Если строка значения содержит запись «Version 6.5», на компьютере установлен Exchange Server 2003.

Если Exchange Server Analyzer определяет, что значение CurrentVersion равно 5.2, а в значении параметра serialNumber содержится запись «Version 6.0», отображается сообщение об ошибке. Эта конфигурация не поддерживается, ошибка должна быть исправлена немедленно.

Для исправления этой ошибки

  1. Выполните одно из следующих указаний:

    • Установите Exchange 2000 Server на сервер, использующий поддерживаемую операционную систему, и перенесите почтовые ящики на этот сервер.

    • Обновите Exchange 2000 Server до Exchange Server 2003.

Для получения дополнительных сведений о поддерживаемых конфигурациях см. Руководство по использованию Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).

Для получения дополнительных сведений о Exchange Server и Windows Server 2003 обратитесь к статье 810591 базы знаний Microsoft «Совместимость Exchange Server и Windows Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810591).


На компьютере установлена предварительная версия сервера Exchange Server 2007
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-02-20

Средство анализа Microsoft Exchange Server опрашивает службу каталогов Active Directory, чтобы определить значение атрибута serialNumber для всех объектов Exchange Server в каталоге. Атрибут serialNumber является строковым значением, содержащим как версию сервера Exchange Server, так и версию пакета обновления, если он установлен. Например, на компьютере с сервером Exchange Server 2007 без пакета обновления атрибут serialNumber имеет значение Version 8.0 (Build 0685).

Если средство анализа Exchange Server обнаружит, что атрибут serialNumber содержит значение 8.0 и номер сборки, меньший, чем 0685, будет отображено сообщение ошибке.

Эта ошибка свидетельствует о том, что на компьютере используется предварительная версия сервера Exchange Server 2007.

Использование предварительных версий сервера Exchange Server 2007 в рабочей среде не поддерживается.

Чтобы устранить эту ошибку, установите итоговую версию сервера Exchange Server 2007.


Объект сервера Exchange 2007 перемещен в другую административную группу
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-08-11

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumber для всех объектов в каталоге.

Анализатор сервера Exchange также запрашивает значение атрибута cn административной группы, которой принадлежит компьютер сервера Exchange, чтобы можно было определить, является ли она выделенной административной группой Exchange 2007, Административная группа Exchange (FYDIBOHF23SPDLT).

Если анализатор сервера Exchange определит, что сервер, на котором выполняется Microsoft Exchange Server 2007, находится в административной группе, отличной от Административной группы Exchange (FYDIBOHF23SPDLT), на экран будет выведено сообщение об ошибке.

Эта ошибка указывает, что сервер, возможно, вручную перемещен из выделенной административной группы Exchange 2007 и, вероятно, является причиной неполадок потока почты.

Атрибут serialNumber является строковым значением, содержащим как версию сервера Exchange, так и версию пакета обновления, если он установлен. Значение атрибута serialNumber, равное «Version 8.0», указывает, что на сервере выполняется Exchange 2007.

Приложения Microsoft Exchange Server 2003 и Microsoft Exchange 2000 Server используют административные группы, чтобы группировать объекты Exchange с целью делегирования разрешения на управление этими объектами. Приложение Exchange 2007 не использует административные группы в качестве логического блока управления. Для поддержки совместной работы Exchange Server 2003 или Exchange 2000 Server и Exchange 2007, все серверы Exchange 2007 автоматически добавляются в одну административную группу при установке Exchange 2007. Эта административная группа опознается диспетчером Exchange в приложении Exchange Server 2003 как Административная группа Exchange (FYDIBOHF23SPDLT).

Чтобы устранить эту проблему, удалите и повторно установите сервер.


Exchange работает резидентно на контроллере домена, который не является сервером глобального каталога
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-09

Анализатора сервера Microsoft® Exchange запрашивает класс инструментария управления Windows (WMI) Win32_ComputerSystem, чтобы определить значение параметра DomainRole. Допустимые значения для этого параметра приведены в следующей таблице.

Значение | Применение
0 | Автономная рабочая станция
1 | Рабочая станция-член
2 | Автономный сервер
3 | Сервер-член
4 | Резервный контроллер домена
5 | Основной контроллер домена

Анализатор сервера Exchange также запрашивает WMI-класс Win32_Service, чтобы определить значение параметра Started для службы кластеров ClusSvc. Затем анализатор сервера Exchange запрашивает WMI-класс Win32_OperatingSystem, чтобы определить значение ключа OSProductSuite. Значение параметра OSProductSuite указывает версию операционной системы Windows, работающей на компьютере.

Анализатор сервера Exchange также запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumber каждого из объектов каталога, относящихся к объектной категории msExchExchangeServer. Значение атрибута serialNumber указывает версию используемого сервера Exchange.

Наконец, анализатор сервера Exchange запрашивает Active Directory, чтобы определить значение атрибута isGlobalCatalogReady этого сервера. Значение True этого атрибута указывает, что сервер каталогов также является функционирующим сервером глобального каталога, а значение False означает, что сервер каталогов не является сервером глобального каталога.

Если анализатор сервера Exchange определяет, что значение параметра DomainRole больше 3 на компьютере сервера Exchange; что на компьютере сервера Exchange не работает сервер Windows Small Business Server, сервер Exchange Server версии 5.5 или он работает в кластере Windows; и что для атрибута isGlobalCatalogReady установлено значение False, выводится предупреждение.

Это предупреждение означает, что сервер Exchange работает на сервере каталогов, который не является также функционирующим сервером глобального каталога. Эта конфигурация не поддерживается и может привести к сбоям служб Exchange.

Если сервер Exchange работает на контроллере домена без Small Business Server, проверьте следующие факторы:

  • Как сервер Exchange, так и Active Directory являются ресурсоёмкими приложениями. Когда оба приложении работают на одном компьютере, возможны проблемы производительности.

  • Если сервер Exchange работает на контроллере домена, необходимо сделать этот контроллер домена также сервером глобального каталога.

  • Несколько компонентов каталога сервера Exchange, такие как DSAccess (Directory Service Access), DSProxy (Directory Service Proxy) и классификатор сообщений не будут перемещаться после отказа на другой контроллер домена или сервер глобального каталога.

  • Воспользоваться преимуществами ключа запуска /3GB в Windows нельзя, поскольку при этом сервер Exchange может израсходовать всю память, в том числе выделенную для Active Directory.

  • Завершение работы системы займет намного больше времени, если службы Exchange Server не остановлены перед выключением или перезагрузкой сервера.

  • Такая конфигурация менее безопасна, поскольку администраторы Exchange получат локальный доступ с правами администратора к Active Directory. Это позволит им расширить свои собственные права. Кроме того, любая уязвимость безопасности, обнаруженная либо в сервере Exchange, либо в Active Directory, делает уязвимым также второй из этих компонентов.

  • При запуске сервера Exchange Server 2003 или Exchange Server 2007 на контроллере домена использование средства DCPromo для изменения роли компьютера не поддерживается, поскольку это средство нарушает работу компонентов, таких как Microsoft Outlook® Mobile Access.

  • Запуск сервера Exchange Server 2003 или Exchange Server 2007 на кластерном узле, являющимся контроллером домена Active Directory, не поддерживается и не должен производиться. Иными словами, если Exchange 2000 Server работает на узле в кластере, который является также контроллером домена, то перед обновлением с Exchange 2000 Server до Exchange Server 2003 необходимо понизить роль сервера до рядового сервера.

Если на компьютере работает сервер Exchange 2000 Server, рекомендуется при первой возможности понизить роль сервера до рядового сервера при помощи средства DCPromo. Если на компьютере используется Exchange Server 2003 или Exchange Server 2007, примените одну из следующих процедур для устранения данного предупреждения.

Чтобы исправить проблему путем перемещения Exchange на другой компьютер

  1. Установите сервер Exchange на другом компьютере.

  2. С помощью команды Переместить почтовый ящик мастера задач Exchange переместите любые существующие почтовые ящики с контроллера домена на новый сервер Exchange.

  3. Переместите любые общие папки и роли, поддерживаемые старым компьютером сервера Exchange, на новый компьютер сервера Exchange.

  4. Отмените установку сервер Exchange на контроллере домена.
Чтобы исправить проблему путем преобразования сервера Exchange в сервер глобального каталога

  1. Откройте узлы и службы Active Directory.

  2. Разверните Узлы, разверните Узел и разверните Серверы.

  3. Выберите контроллер домена, который предполагается определить в качестве сервера глобального каталога.

  4. В правой области щелкните правой кнопкой мыши Параметры NTDS и выберите Свойства.

  5. На вкладке Общие установите флажок Глобальный каталог. Если на сервере каталогов работает Windows 2000 Server с пакетом обновления 2 (SP2) или более ранней версии, перезагрузите сервер, чтобы изменение вступило в силу. Если на сервере каталогов работает Windows 2000 Server с пакетом обновления 2 (SP2) или более поздней версии или Windows Server™ 2003, изменение применяется динамически без перезагрузки сервера.

Дополнительные сведения об установке сервера Exchange на контроллере домена см. в статье 250989 базы знаний Майкрософт «Установка ADC на контроллер домена Microsoft Windows 2000 с работающим сервером Microsoft Exchange» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250989).


Обнаружен сервер Exchange Server 5.5
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-10-06

Средство анализа Microsoft® Exchange Server запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumber для всех объектов, относящихся к классу объектов msExchExchangeServer. Если строковое значение содержит выражение Version 5.5, на компьютере используется Microsoft Exchange Server версии 5.5. Если строковое значение содержит выражение Version 6.0, на компьютере используется Exchange 2000 Server. Если строковое значение содержит выражение Version 6.5, на компьютере используется Exchange Server 2003.

При нахождении анализатором Exchange Server других значений атрибута serialNumber, содержащих выражение Version 5.5, выведется ошибка.

Эта ошибка указывает, что обнаруженная версия сервера Exchange Server не может больше анализироваться данной версией средства анализа Exchange Server.

Работа средства анализа Exchange Server зависит от различных интерфейсов программ, которые недоступны в обнаруженной версии сервера Exchange Server.

Чтобы устранить данную ошибку, укажите сервер Exchange Server под управлением Exchange 2000 или более поздней версии.

Если правило было запущено по ошибке, проверьте, чтобы значение атрибута serialNumber объекта сервера Exchange Server в службе Active Directory было задано правильно.

Внимание!
Если при использовании оснастки ADSI Edit, средства LDP (ldp.exe) или другого клиента LDAP версии 3 неправильно изменить атрибуты объектов Active Directory, могут возникнуть серьезные неполадки. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих продуктов. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на пользователе, внесшем эти изменения.
Просмотр значений атрибута serialNumber

  1. Запустите ADSI Edit.

  2. Дважды щелкните контейнер Configuration, разверните последовательно CN=Services, CN=Microsoft Exchange и CN=<имя_организации_Exchange>.

  3. Разверните CN=Administrative Groups, затем CN=<имя_административной_ группы>, затем CN=Servers.

  4. Щелкните объект сервера правой кнопкой мыши и выберите пункт Свойства.

  5. Дважды щелкните атрибут serialNumber для вывода его текущего значения.

Дополнительные сведения о развертывании сервера Exchange Server 2003 см. в руководстве по развертыванию сервера Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=47569 (на английском языке).

Дополнительные сведения о переходе с версии Exchange Server 5.5 на версию Exchange Server 2003 см. в статье 259912 базы знаний Майкрософт «Предварительные условия для обновления Exchange Server 5.5 до Exchange 2000 Server или Exchange Server 2003» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=259912 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

Сведения о миграции и обновлении до Exchange Server 2003 см. на странице обновления до Exchange Server 2003 http://go.microsoft.com/fwlink/?LinkId=34186 (на английском языке).


Последняя версия пакета обновления не выполняется для Exchange Server 5.5
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута versionNumber для всех объектов сервера Exchange. Атрибут versionNumber представляет версию сервера Exchange, которая выполняется на компьютере.

Анализатор сервера Exchange также запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version для процесса STORE.EXE. Если анализатор сервера Exchange находит, что значение этого атрибута больше 1959, но меньше 2653, отображается предупреждение. Это свидетельствует о том, что на компьютере выполняется Exchange Server 5.5, на котором не установлен пакет обновления версии 4.

Это предупреждение указывает, что на компьютере, на котором выполняется сервер Exchange, не используется последняя доступная версия кода для версии Exchange, которая работает на этом компьютере.

Чтобы устранить причину появления этого предупреждения

  1. Загрузите пакет обновления 4 для Exchange Server 5.5 (http://go.microsoft.com/fwlink/?LinkId=33456).

  2. Загрузите последнее обновление (май 2004 года) для Exchange Server 5.5 в центре загрузки Microsoft (http://go.microsoft.com/fwlink/?LinkId=33456).

  3. Дополнительные сведения об этом обновлении см. в базе знаний Майкрософт в статье 841765, описывающей сводку обновлений для Exchange Server 2003 за май 2004 года (http://go.microsoft.com/fwlink/?linkid=3052&kbid=841765).

  4. Выполните полную архивацию компьютера с сервером Exchange.

  5. Примените пакет обновления 4 для Exchange Server 5.5

  6. Примените обновление за май 2004 года

Дополнительные сведения о выполнении установки этого и других обновлений сервера Exchange см. в базе знаний Майкрософт в статье 328839, описывающей применение пакетов обновления и исправлений Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Приложение Exchange Server 5.5 не поддерживается в Windows 2003
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить версию операционной системы Microsoft Windows®, под управлением которой работает компьютер сервера Exchange, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Значение CurrentVersion, равное 4.0, указывает, что компьютер работает под управлением операционной системы Microsoft Windows NT® Server 4.0. Значение, равное 5.0, указывает, что компьютер работает под управлением операционной системы Windows 2000 Server, а значение, равное 5.2, указывает, что на компьютере установлена операционная система Windows Server™ 2003.

Анализатор сервера Exchange также запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumber для всех объектов, относящихся к классу msExchExchangeServer. Если строковое значение содержит выражение «Version 5.5», на компьютере выполняется приложение Microsoft Exchange Server версии 5.5. Если строковое значение содержит выражение «Version 6.0», на компьютере выполняется Exchange 2000 Server. Если строковое значение содержит выражение «Version 6.5», на компьютере выполняется Exchange Server 2003.

Если анализатор сервера Exchange обнаружит, что значение CurrentVersion равно 5.2, и значение serialNumber содержит выражение «Version 5.5», на экран будет выведено сообщение об ошибке. Эта конфигурация не поддерживается и данную ошибку следует устранить как можно быстрее.

Чтобы устранить эту ошибку

  • Выполните одно из следующих действий:

    • Установите приложение Exchange Server 5.5 на сервере, работающем под управлением поддерживаемой операционной системы, а затем переместите почтовые ящики на этот сервер.

    • Осуществите миграцию с Exchange Server 5.5 на Exchange Server 2003.

Дополнительные сведения о развертывании Exchange Server 2003 см. в руководстве по развертыванию Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).

Дополнительные сведения о сервере Exchange и операционной системе Windows Server 2003 см. в базе знаний Майкрософт в статье 810591, описывающей совместимость сервера Exchange с операционной системой Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810591).

Дополнительные сведения о миграции из Exchange Server 5.5 в Exchange Server 2003 см. в базе знаний Майкрософт в статье 259912, описывающей предварительные условия для обновления приложения Exchange Server 5.5 до Exchange 2000 Server или до Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=259912).

Сведения о миграции и обновлении, конечным результатом которых является Exchange Server 2003, см. на странице миграции и обновления, описывающей переход на Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=34186).


Для Exchange Server 5.0 не установлена последняя версия пакета обновления или сборки обновлений
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить значение атрибута versionNumber для всех объектов сервера Exchange. Атрибут versionNumber указывает версию сервера Exchange, которая выполняется на данном компьютере.

Анализатор сервера Exchange также запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version для процесса STORE.EXE. Если анализатор сервера Exchange обнаружит, что значение ключа Version для процесса STORE.EXE больше 1456 и меньше 1460, на экран будет выведено предупреждение.

Данное предупреждение указывает, что на данном компьютере сервера Exchange отсутствует последняя версия программного кода, доступного для установленной на нем версии Exchange.

Чтобы устранить причину появления этого предупреждения

  1. Загрузите пакет обновления 2 для Exchange Server 5.0 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168858).

  2. Прочитайте файл README.TXT пакета обновления 2 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168735).

  3. Посетите центр загрузки Майкрософт (http://go.microsoft.com/fwlink/?LinkId=41361), чтобы загрузить новейшее обновление (апрель 2004 г.) для Exchange Server 5.0.

  4. Дополнительные сведения о данном обновлении см. в статье 834130 базы знаний Майкрософт, посвященной набору исправлений для Microsoft Exchange Server 5.0 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834130).

  5. Создайте полную резервную копию сервера Exchange.

  6. Примените пакет обновления 2 для Exchange Server 5.0.

  7. Примените обновление за апрель 2004 г.

Дополнительные сведения об установке этого и других обновлений сервера Exchange см. в базе знаний Майкрософт в статье 328839, содержащей инструкции по применению пакетов обновлений и отдельных исправлений Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Резидент Exchange Server 5.5 на контроллере домена Active Directory
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_ComputerSystem, чтобы определить значение ключа DomainRole. Допустимые значения этого ключа приведены в следующей таблице.

Значение | Значение
0 | Автономная рабочая станция
1 | Рабочая станция-член
2 | Автономный сервер
3 | Сервер-член
4 | Резервный контроллер домена
5 | Основной контроллер домена

Анализатор сервера Exchange также запрашивает WMI-класс Win32_Service, чтобы определить значение ключа Started для службы кластера ClusSvc.

Анализатор сервера Exchange также запрашивает службу каталога Active Directory®, чтобы определить значение атрибута serialNumber всех объектов каталога с категорией объекта msExchExchangeServer. Значение атрибута serialNumber показывает используемую версию сервера Exchange.

Если анализатор сервера Exchange определяет, что значение ключа DomainRole на компьютере сервера Exchange больше 3, что компьютер сервера Exchange не работает в кластере Windows, и что работающая версия сервера Exchange — это Exchange Server 5.5, появляется предупреждение.

Это предупреждение показывает, что Exchange Server 5.5 работает на сервере Active Directory. Эта ситуация может привести к проблемам с соединителем Active Directory Connector (ADC) из-за возможного конфликта портов. Если соединитель ADC использует этот сервер в качестве назначения, следует убедиться, что используется правильный номер порта протокола LDAP Exchange. По умолчанию сервер каталога слушает запросы LDAP, используя TCP-порт 389. Если порт Exchange не изменен и соединитель ADC настроен на использование порта, соединитель ADC не сможет связываться с Exchange.

Служба Active Directory использует для LDAP-доступа стандартный LDAP-порт 389. Но использование стандартного номера порта мешает серверу Exchange, находящемуся на том же сервере и тоже пытающемуся слушать LDAP-порт 389. Необходимо переназначить LDAP-порт Exchange, чтобы предоставить серверу Exchange LDAP-доступ к своему каталогу.

Устранение причины появления этого предупреждения

  1. Откройте окно «Администратор Exchange».

  2. Разверните Название узла, разверните Конфигурация, разверните Протоколы, а затем разверните LDAP (каталог) Параметры узла по умолчанию.

  3. Измените назначение порта с 389 на порт, которые на данный момент не используется.

  4. Нажмите кнопку ОК, чтобы сохранить изменения.

  5. Перезагрузите службу каталогов Microsoft Exchange, чтобы изменение вступило в силу.

  6. При необходимости, чтобы использовать новый порт, измените настройки соединителя ADC, использующего этот сервер в качестве назначения.

Дополнительные сведения об изменении назначения порта LDAP в Exchange Server 5.5 см. в статье 224447 базы знаний Майкрософт, посвященной XADM и изменению назначений портов LDAP в сервере Exchange по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856 (возможно, на английском языке).


Ошибка при разрешении DNS-имени сервера Exchange
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange пытается выполнить запрос в системе доменных имен (DNS) относительно DNS-серверов, настроенных для каждого компьютера с сервером Exchange. Это подключение устанавливается с помощью обработчика пользовательских объектов, который выполняет запрос на разрешение имени и анализирует его результаты. Если в результатах запроса, полученных анализатором сервера Exchange, отсутствует IP-адрес, выдается сообщение об ошибке.

Данная ошибка указывает, что компьютер с сервером Exchange не найден в DNS. Для нормальной работы сервера Exchange и службы каталогов Active Directory необходимо правильно настроить систему DNS и обеспечить ее работоспособность. Проблемы регистрации в DNS и разрешения доменных имен могут существенно повлиять на возможности отправки, получения и доставки сообщений.

Для нормального функционирования Active Directory и сервера Exchange необходимо правильно настроить DNS. Более подробные сведения о настройке DNS для Active Directory см. в статье 237675 базы знаний Майкрософт, посвященной настройке системы доменных имен для Active Directory (http://go.microsoft.com/fwlink/?linkid=3052&kbid=237675).

Чтобы устранить эту ошибку

  1. Просмотрите следующие элементы конфигурации, чтобы убедиться в нормальном состоянии DNS и обеспечить правильную регистрацию записей DNS для сервера Exchange:

    • Конфигурация IP-адресов в DNS

    • Динамическое обновление зон

    • Перенаправление запросов DNS

  2. Проверьте наличие записи корневой зоны. Просмотрите зоны прямого просмотра на консоли управления DNS. Там должна присутствовать запись для текущего домена. Могут существовать записи и других зон. В списке не должно быть корневой зоны («.»). Если такая зона имеется, удалите ее. Корневая зона («.») идентифицирует DNS-сервер как корневой сервер. Обычно в качестве корневого DNS-сервера настраивается домен Active Directory, для которого требуется внешний доступ (через Интернет). Перерегистрируйте IP-адрес сервера Exchange вручную, воспользовавшись командой Ipconfig /registerdns на сервере каталога после удаления корневой зоны («.»). Возможно, также потребуется перезапустить службу Netlogon.

  3. Заново заполните вручную записи DNS сервера Exchange, используя команду netdiag /fix на компьютере с сервером Exchange.

Дополнительные сведения об использовании DNS вместе с Active Directory см. в статье 323418 базы знаний Майкрософт, содержащей инструкции по интеграции DNS в существующую инфраструктуру DNS при включенной поддержке Active Directory в Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=323418).

Дополнительные сведения об устранении неполадок, связанных с DNS и Active Directory, см. в статье 260371 базы знаний, посвященной устранению типичных неполадок настройки Active Directory в Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260371).


Сервер Exchange был назначен сервером переднего плана и содержит почтовые ящики
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает WMI-объект (класс Exchange_Server), чтобы определить значение IsFrontEndServer для сервера. Если значением является True, сервер Exchange выступает в качестве сервера переднего плана. Если сервер содержит хранилища почтовых ящиков, анализатор сервера Exchange опрашивает службу каталогов Active Directory® , чтобы определить, сколько почтовых ящиков содержится на сервере. Каждый объект хранилища почтовых ящиков (класс msExchPrivateMDB) содержит многозначный атрибут homeMDBBL, в котором хранится список всех почтовых ящиков хранилища. Подсчитывая эти значения, анализатор сервера Exchange получает общее количество почтовых ящиков на сервере.

Если сервер Exchange назначен в качестве сервера переднего плана и содержит более 20 настроенных почтовых ящиков, отображается предупреждение.

В зависимости от конфигурации, для Exchange может понадобиться поместить служебные почтовые ящики на сервер переднего плана. Например, если сервер переднего плана принимает SMTP-почту из Интернета, для работы службы SMTP сервера Exchange может понадобиться назначенный почтовый ящик на этом сервере. Анализатор сервера Exchange учитывает эти служебные почтовые ящики, только отображая предупреждения, если более 20 почтовых ящиков настроено на сервере Exchange.

Не следует размещать пользовательские почтовые ящики на сервере переднего плана. Такая конфигурация не поддерживается.

Если пользовательские почтовые ящики размещены на сервере переднего плана, воспользуйтесь диспетчером Exchange (только в Exchange Server 2003) или оснасткой «Active Directory — пользователи и компьютеры», чтобы переместить эти почтовые ящики на внутренний сервер.

Чтобы переместить почтовые ящики (Exchange 2000 Server or Exchange Server 2003)

  1. В оснастке «Active Directory — пользователи и компьютеры» выберите пользователя или пользователей, почтовые ящики которых хотите переместить.

  2. Щелкните правой кнопкой мыши список пользователей, выбранный на предыдущем шаге, и в контекстном меню выберите Задачи Exchange.

  3. В окне Мастер задач Exchange на странице Доступные задачи щелкните Переместить почтовый ящик и нажмите кнопку Далее.

  4. Внимательно ознакомьтесь с оставшимися шагами в мастере.

Чтобы переместить почтовые ящики (только Exchange Server 2003)

  1. В окне Диспетчер системы Exchange разверните узел Серверы, разверните сервер, с которого хотите переместить почтовые ящики, разверните узел Группа хранения, из которой хотите переместить почтовые ящики, разверните узел Хранилище почтовых ящиков, содержащее почтовые ящики, которые хотите переместить, а затем щелкните Почтовые ящики.

  2. В области сведений щелкните правой кнопкой мыши пользователя или пользователей, почтовые ящики которых хотите переместить, и в контекстном меню выберите Задачи Exchange.

  3. В окне Мастер задач Exchange на странице Доступные задачи щелкните Переместить почтовый ящик и нажмите кнопку Далее.

  4. Внимательно ознакомьтесь с оставшимися шагами в мастере.

Дополнительные сведения о корректных конфигурациях серверов переднего плана Exchange см. в статье 822443 базы знаний Майкрософт, посвященной вопросам, связанным с серверами переднего плана в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822443).

Общие рекомендации по развертыванию и настройке серверов переднего плана Exchange front-end servers см. в руководстве по развертыванию Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47569).

Дополнительные сведения об ошибках, которые могут произойти при работе почтовых ящиков пользователей на сервере переднего плана Exchange, см. в статье 273296 базы знаний Майкрософт, посвященной невозможности получить почту пользователями на сервере переднего плана (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=273296).

Дополнительные сведения о перемещении почтовых ящиков в Exchange Server 2003 см. в следующих статьях базы знаний Майкрософт:

  • статья 821829, описывающая перемещение почтовых ящиков в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829);

  • статья 822892, описывающая улучшения, касающиеся перемещения почтовых ящиков в Exchange 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892).


Данный сервер Exchange также является контроллером домена — данная конфигурация нежелательна
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-03-28

Анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32, чтобы определить значение ключа DomainRole. Допустимые значения этого ключа приведены в следующей таблице.

Значение | Описание
0 | Автономная рабочая станция
1 | Рабочая станция-член
2 | Автономный сервер
3 | Рядовой сервер
4 | Резервный контроллер домена
5 | Основной контроллер домена

Кроме того, анализатор сервера Exchange запрашивает WMI-класс (Microsoft Windows Management Instrumentation) Win32_Service, чтобы получить значение ключа Started для ClusSvc, службы кластеров Microsoft Windows.

Анализатор сервера Exchange также запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumber всех объектов каталога с категорией объекта msExchExchangeServer. Значение атрибута serialNumber указывает используемую версию сервера Exchange.

Если анализатор сервера Exchange обнаруживает, что значение ключа DomainRole на сервере Exchange больше 3, на компьютере сервера Exchange не выполняется Exchange Server 5.5 или этот компьютер работает не в кластере Windows, выводится предупреждение.

При выполнении сервера Exchange в составе Microsoft Small Business Server 2000 или Windows Small Business Server 2003 допускается установка Exchange Server на контроллер домена. Однако если сервер Exchange выполняется не в составе Small Business Server, не рекомендуется устанавливать сервер Exchange на контроллере домена.

При выполнении сервера Exchange на контроллере домена без Small Business Server необходимо учесть следующие факторы:

  • Как сервер Exchange, так и Active Directory представляют собой ресурсоемкие приложения. Если оба этих приложения выполняются на одном компьютере, это может отразиться на их производительности.

  • Если сервер Exchange выполняется на контроллере домена, необходимо сделать этот контроллер домена сервером глобального каталога. Дополнительные сведения о создании сервера глобального каталога см. в статье 313994 базы знаний Майкрософт «Создание и перемещение глобального каталога в Windows Server 2003, Windows 2000 и Small Business Server 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid= 313994) (на английском языке).

  • Некоторые компоненты работы с каталогами сервера Exchange, такие как DSAccess, DSProxy и классификатор сообщений, не смогут выполнить переключение при сбое на другой контроллер домена или сервер глобального каталога.

  • В такой конфигурации нецелесообразно использовать преимущества переключателя загрузки «/3GB» в Windows, поскольку при этом для сервера Exchange будет выделена вся память и объем памяти, доступный для Active Directory, снизится.

  • Завершение работы системы будет занимать значительно больше времени, если не остановить службы сервера Exchange перед завершением работы или перезапуском сервера.

  • Такая конфигурация менее безопасна, так как администраторы Exchange будут иметь локальный доступ для администрирования Active Directory, что позволяет им поднять уровень своих прав. Кроме того, уязвимость системы безопасности, обнаруженная в сервере Exchange или в службе Active Directory, будет представлять опасность для другого приложения.

  • При запуске сервера Exchange Server 2003 или Exchange Server 2007 на контроллере домена использование средства DCPromo для изменения роли компьютера не поддерживается, поскольку это средство нарушает работу компонентов, таких как Microsoft Outlook® Mobile Access.

  • Запуск сервера Exchange Server 2003 или Exchange Server 2007 на кластерном узле, являющимся контроллером домена Active Directory, не поддерживается и не должен производиться. Это означает, что в том случае, если сервер Exchange 2000 Server установлен на узле кластера, одновременно выступающего в качестве контроллера домена, необходимо понизить роль данного сервера до рядового сервера перед выполнением обновления с Exchange 2000 Server до Exchange Server 2003.

Если на компьютере выполняется Exchange 2000 Server, рекомендуется при первой возможности понизить роль данного сервера до рядового сервера с помощью средства DCPromo. Если на компьютере используется Exchange Server 2003, для устранения предупреждения выполните следующие действия.

Чтобы устранить причину появления этого предупреждения

  1. Установите сервер Exchange на другом компьютере.

  2. С помощью задачи Перемещение почтовых ящиков в мастере задач Exchange переместите нужные существующие почтовые ящики с контроллера домена на новый сервер Exchange.

  3. Переместите на новый компьютер сервера Exchange нужные общие папки и роли со старого компьютера сервера Exchange.

  4. Удалите сервер Exchange с контроллера домена.

Дополнительные сведения об установке сервера Exchange на контроллере домена см. в статье 250989 базы знаний Майкрософт «XADM: Installing the ADC on a Windows 2000 Domain Controller That Also Runs Exchange Server» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250989) (XADM: установка ADC на контроллере домена Windows 2000, где также выполняется сервер Exchange).


Этот сервер Exchange не работает или недоступен
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-04-20

Средство анализатора сервера Microsoft® Exchange использует удаленные вызовы процедур (RPC), чтобы прочитать строковое значение CurrentVersion из следующего раздела реестра на компьютере с сервером Exchange:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Если анализатору сервера Exchange по какой-то причине не удается прочитать это значение реестра, отображается сообщение об ошибке.

Чтобы устранить эту ошибку

  1. Убедитесь, что компьютер с сервером Exchange включен и подключен к сети.

  2. С помощью команды Ping проверьте доступность компьютера с сервером Exchange.

  3. Если используется межсетевой экран, проверьте, не закрыты ли порты RPC.

  4. Проверьте, что на компьютере с сервером Exchange запущена служба Remote Registry.

  5. Проверьте разрешения для учетной записи, используемой для запуска средства анализатора сервера Exchange, и убедитесь, что она имеет достаточные разрешения для чтения реестра на компьютере с сервером Exchange.

Для получения дополнительных сведений об устранении неполадок, связанных с подключениями к сети, см. статью базы знаний Майкрософт 325487, содержащую инструкции по устранению неполадок сетевых подключений (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Для получения дополнительных сведений об устранении проблем подключения средства анализатора рекомендаций для сервера Exchange см. статью, посвященную устранению неполадок, связанных с подключениями средства анализатора рекомендаций для сервера Microsoft Exchange (http://go.microsoft.com/fwlink/?linkid=56285).


Этот сервер Exchange работает в операционной системе Windows NT4.0; доступны ограниченные диагностические сведения
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить версию операционной системы Microsoft Windows®, под управлением которой работает компьютер сервера Exchange, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Значение CurrentVersion, равное 4.0, указывает, что компьютер работает под управлением операционной системы Microsoft Windows NT® Server 4.0. Значение, равное 5.0, указывает, что компьютер работает под управлением операционной системы Windows 2000 Server, а значение, равное 5.2, указывает, что на компьютере установлена операционная система Windows Server™ 2003.

Если анализатор сервера Exchange обнаруживает, что для ключа CurrentVersion установлено значение 4.0, выводится предупреждение.

Это предупреждение указывает, что этот компьютер сервера Exchange работает под управлением операционной системы Windows NT Server 4.0. Windows NT Server 4.0 не предоставляет такого количества диагностических сведений, как в более поздних версиях Windows Server. В результате, анализатор сервера Exchange будет способен собирать и анализировать только ограниченный объем данных.

Чтобы устранить причину появления этого предупреждения

  1. Нет необходимости немедленно предпринимать что-либо. Это предупреждения является информационным.

  2. Так как Windows NT Server 4.0 и Exchange Server версии 5.5 подходят к концу своего жизненного цикла, необходимо рассмотреть возможность обновления до Windows Server 2003 и Exchange Server 2003.

Дополнительные сведения о жизненном цикле для Windows NT Server 4.0 и Exchange Server 5.5 см. на веб-узле, посвященном жизненному циклу, поддерживаемому корпорацией Майкрософт (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=21759).

Дополнительные сведения о Windows Server 2003 см. на веб-узле, посвященном Microsoft Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=26095).

Дополнительные сведения об Exchange Server 2003 см. на веб-узле, посвященном Microsoft Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=21573).


Окончательная версия сборки пакета обновления 2 не выполняется для Exchange Server 2003
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumber для всех объектов в каталоге. Атрибут serialNumber является значением строки, включающим как версию сервера Exchange, так и версию пакета обновления, если он установлен. Например, на компьютере, где установлено приложение Exchange Server 2003 с пакетом обновления 1, значение атрибута serialNumber равно Version 6.5 (Build 7638: Service Pack 2).

Если анализатор сервера Exchange обнаруживает, что значение для атрибута serialNumber содержит в строке значения 6.5 и Service Pack 2, но не содержит в строке значение 7638, анализатор сервера Exchange отображает предупреждение.

Это свидетельствует о том, что на компьютере выполняется предварительная версия пакета обновления 2 для Exchange Server 2003.

Примечание.
Так как пакеты обновления сервера Exchange не могут быть удалены, рекомендуется, чтобы было выполнено полное архивирование компьютера, на котором выполняется сервер Exchange, перед использованием пакетов обновления.
Чтобы устранить причину появления этого предупреждения

  1. Приобретите последнюю версию пакета обновления 2 (SP2) для Exchange Server 2003 см. на веб-узле пакета обновления 2 (SP2) для Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=52073).

  2. Просмотрите заметки о выпуске пакета обновления 2 для Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=52072).

  3. Выполните полное архивирование компьютера с установленным сервером Exchange.

  4. Примените пакет обновления 2 для Exchange Server 2003

  5. Выполните повторное полное архивирование компьютера, на котором установлен сервер Exchange.

Дополнительные сведения о выполнении установки пакета обновления для сервера Exchange см. в базе знаний Майкрософт в статье 328839, описывающей применение пакетов обновления и исправлений Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


На сервере Exchange работает сервер SharePoint Portal
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Service, чтобы определить значение ключа Started для сервера портала Microsoft Windows SharePoint® Portal (MSDMSERV). Значение True показывает, что на этом Exchange работает сервер SharePoint Portal.

Если анализатор сервера Exchange обнаруживает, что на компьютере сервера Exchange работает сервер SharePoint Portal Server, выводится предупреждение.

Сервер SharePoint Portal несовместим с сервером Exchange и должен быть удален. Сервер SharePoint Portal и сервер Exchange предназначены для совместной работы и обеспечивают для организации среду сотрудничества. Однако сервер SharePoint Portal и сервер Exchange предназначены для работы отдельно друг от друга и не должны сосуществовать на одном и том же оборудовании.

Чтобы устранить причину появления этого предупреждения

  • Переместите на другой компьютер либо сервер Exchange, либо сервер SharePoint Portal. Рекомендуется удалить с компьютера одно из этих приложений.

Дополнительные сведения о перемещении почтовых ящиков сервера Exchange см. в статье 821829 базы знаний Майкрософт, описывающей перемещение почтовых ящиков в Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=).

Дополнительные сведения о совместимости сервера Exchange и сервера SharePoint Portal см. в статье 277567 базы знаний Майкрософт, посвященной невозможности установки сервера SharePoint Portal на компьютере сервера Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=277567).


На сервере Exchange запущен Virtual Server 2005 при другом сервере Exchange, установленным в качестве гостя
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, является ли сервер виртуальным, средство анализатора сервера Exchange считывает значения в следующем разделе реестра:

HKEY_LOCAL_MACHINE\Software\Classes\Installer\Products\354F2D7F395B57846953B997DF778AC1

Анализатор сервера Exchange также проверяет следующее значение реестра:

HKLM\Software\Microsoft\Virtual Machine\Guest\Parameters

Кроме того, анализатор сервера Exchange опрашивает WMI-класс Win32_Service, чтобы определить, запущена ли служба банка данных Microsoft Exchange (MSExchangeIS) на физическом компьютере, на котором работает Microsoft Virtual Server 2005.

Если анализатор сервера Exchange обнаружит, что сервер является виртуальным, что ветка реестра, описанная выше, существует и на физическом компьютере запущена служба MSExchangeIS, то анализатор отобразит сообщение об ошибке.

Наличие раздела HKLM\Software\Classes\Installer\Products\354F2D7F395B57846953B997DF778AC1 указывает на то, что на компьютере сервере Exchange установлены добавления виртуальной машины. Этот фактор наряду с наличием раздела HKLM\Software\Microsoft\Virtual Machine\Guest\Parameters означает, что компьютер сервера Exchange работает в качестве гостевого виртуального компьютера в Virtual Server 2005.

Майкрософт не поддерживает выполнение сервера Exchange на виртуальном компьютере или в эмуляторе. Это справедливо для серверов Exchange, работающих в Virtual Server 2005, Microsoft Virtual PC 2004 или любом стороннем программном обеспечении, создающем виртуальные компьютеры. Платформы сервера Exchange созданы и проверены только на физическом оборудовании, особенно это касается тех платформ оборудования, которые приведены в каталоге серверов Windows (http://go.microsoft.com/fwlink/?linkid=17219).

Кроме того, не рекомендуется выполнять Exchange в качестве гостевого виртуального сервера на компьютере с работающим сервером Exchange, так как в таком случае не поддерживается адекватная избыточность между службами.

Чтобы устранить эту ошибку

  1. Переместите почтовые ящики с сервера Exchange работающего в Virtual Server 2005 на невиртуальном компьютере сервера Exchange.

  2. Переместите любые общие папки и роли, установленные на виртуальном сервере Exchange.

  3. Удалите Exchange с виртуального компьютера, чтобы списать его и удалить из инфраструктуры Exchange в службе каталогов Active Directory®.

Дополнительные сведения о перемещении почтовых ящиков см. в следующих статьях базы знаний Майкрософт:

  • 822892, описывающая улучшения, касающиеся перемещения почтовых ящиков в Exchange 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892);

  • 224975, посвященная различиям между методами перемещения почтовых ящиков быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975).

Дополнительные сведения о поддержке компьютеров сервера Exchange, работающих в виртуальных средах, см. в статье 320220 базы знаний, посвященной ограничениям сервера Exchange на виртуальных машинах и эмуляторах (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).

Дополнительные сведения о Virtual Server 2005 см. на веб-узле, посвященном Microsoft Virtual Server 2005 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=34938).

Дополнительные сведения о Virtual PC 2004 см. на веб-узле, посвященном Microsoft Virtual PC 2004 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=34663).


На сервере Exchange выполняются службы DNS
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Service, чтобы определить значение ключа Started для службы DNS Server (DNS). Значение True указывает, что на данном сервере Exchange выполняется служба DNS Server.

Анализатор сервера Exchange также запрашивает WMI-класс Win32_OperatingSystem, чтобы определить значение ключа OSProductSuite. Возвращаемое для данного ключа значение указывает версию операционной системы Windows, которая выполняется на данном компьютере сервера Exchange.

Помимо этого, анализатор сервера Exchange запрашивает службу каталогов Active Directory®, чтобы определить количество записей, содержащихся в атрибуте homeMDBBL для каждого из хранилищ почтовых ящиков. Значение этого атрибута указывает количество почтовых ящиков в хранилище почтовых ящиков.

Если анализатор сервера Exchange обнаруживает, что на компьютере сервера Exchange запущена служба DNS Server и выполняются следующие условия, выводится предупреждение:

  • На сервере Exchange размещено более 100 почтовых ящиков.

  • Сервер Exchange работает не под управлением операционной системы Windows Small Business Server 2003 или Small Business Server 2000.

Не рекомендуется выполнять службу DNS Server на компьютере, который является производственным сервером почтовых ящиков Exchange. При параллельном размещении сервера DNS Server и сервера Exchange на одном компьютере в производственной среде производительность одного или обоих серверов скорее всего будет невысокой.

Чтобы устранить причину появления этого предупреждения

  1. Устранить причину появления этого предупреждения можно несколькими путями:

    • Переместите с компьютера службу Exchange Server или DNS Server. Рекомендуется полностью удалить с компьютера одно из этих серверных приложений.

    • Переместите с данного сервера почтовые ящики Exchange. Следует по меньшей мере удалить почтовые ящики и преобразовать данный сервер Exchange в сервер протокола или инфраструктуры. Это существенно снизит нагрузку на диск и несколько сократит загрузку процессора (уровень загрузки зависит от роли в инфраструктуре Exchange).

    • Продумайте возможность установки ОС Small Business Server. При выполнении Exchange в малой среде, включающей менее 75 пользователей, где не требуется наличие более одного сервера Exchange, установка ОС Small Business Server может принести положительные результаты. Операционная система Small Business Server содержит как сервер Microsoft SQL Server™, так и сервер Exchange Server, а также другие ключевые серверные приложения Microsoft; эта система была разработана, проверена и оптимизирована специально для установки на одном компьютере.

Дополнительные сведения о перемещении почтовых ящиков см. в следующих статьях базы знаний Майкрософт:

  • Статья 822892 об улучшенных возможностях перемещения почтовых ящиков в Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892).

  • Статья 224975 о различиях между способами перемещения почтовых ящиков (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975).

  • Статья 297289, в которой представлены инструкции по переносу Exchange Server на новое оборудование с сохранением имени сервера (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=155216).

Дополнительные сведения о Small Business Server см. в документе Microsoft Windows Small Business Server 2003 (http://go.microsoft.com/fwlink/?linkid=23456).


На сервере Exchange выполняется сервер SQL Server
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Service, чтобы определить значение ключа Started для службы Microsoft SQL Server™ (MSSQLSERVER). Значение True указывает, что на данном сервере Exchange выполняется служба SQL Server.

Анализатор сервера Exchange также запрашивает WMI-класс Win32_OperatingSystem, чтобы определить значение ключа OSProductSuite. Возвращаемое для данного ключа значение указывает версию операционной системы Windows, которая выполняется на данном компьютере сервера Exchange.

Помимо этого, анализатор сервера Exchange запрашивает службу каталогов Active Directory®, чтобы определить количество записей, содержащихся в атрибуте homeMDBBL для каждого из хранилищ почтовых ящиков. Значение этого атрибута указывает количество почтовых ящиков в хранилище почтовых ящиков.

Если анализатор сервера Exchange обнаруживает, что на компьютере сервера Exchange запущена служба SQL Server и выполняются все следующие условия, выводится предупреждение:

  • На сервере Exchange размещено более 100 почтовых ящиков.

  • Сервер Exchange работает не под управлением операционной системы Windows Small Business Server 2003 или Small Business Server 2000.

Не рекомендуется выполнять службу SQL Server на компьютере, который является производственным сервером почтовых ящиков Exchange. Для оптимальной работы как сервера SQL Server, так и серверов почтовых ящиков Exchange требуется большой объем памяти и дисковых ресурсов. При параллельном размещении сервера SQL Server и сервера Exchange на одном компьютере в производственной среде, скорее всего, производительность одного или обоих серверов будет невысокой. Кроме того, при такой установке неясно, как обеспечить безопасность работы и выполнять устранение неполадок.

Наконец, известно несколько проблем с работоспособностью, которые могут возникнуть при выполнении серверов SQL Server и Exchange на одном компьютере. Большая часть этих проблем возникает по причине несовместимости версий файлов или программ, используемых обоими серверами, таких как координатор распределенных транзакций Microsoft (MS DTC), Microsoft ActiveX® Data Objects (ADO), и OLE Database (OLE DB).

Чтобы устранить причину появления этого предупреждения

  • Устранить причину появления этого предупреждения можно несколькими путями:

    • Переместите с компьютера сервер Exchange Server или сервер SQL Server. Рекомендуется полностью удалить с компьютера одну из этих программ.

    • Переместите с данного сервера почтовые ящики Exchange. Следует по меньшей мере удалить почтовые ящики и преобразовать данный сервер Exchange в сервер протокола или инфраструктуры. Это существенно снизит нагрузку на диск и несколько сократит загрузку процессора (уровень загрузки зависит от роли в инфраструктуре Exchange).

    • Продумайте возможность установки ОС Small Business Server. При выполнении Exchange в малой среде, где не требуется наличие более одного сервера Exchange установка ОС Small Business Server может принести положительные результаты. Операционная система Small Business Server содержит как сервер SQL Server, так и сервер Exchange Server, а также другие ключевые серверные приложения Microsoft, эта система была разработана, проверена и оптимизирована специально для установки на одном компьютере.

Дополнительные сведения о перемещении почтовых ящиков см. в следующих статьях базы знаний Майкрософт:

  • 822892, «Move Mailbox improvements in Exchange 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)) (Улучшенные возможности перемещения почтовых ящиков в Exchange Server 2003)

  • 224975, «XADM: Differences Between Move Mailbox Methods» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975) (XADM: различия между способами перемещения почтовых ящиков)

  • 297289, «How to move Exchange 2000 to new hardware and keep the same server name» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=155216) (Инструкции по переносу Exchange Server на новое оборудование с сохранением имени сервера).

Дополнительные сведения о Small Business Server см. в документе «Microsoft Windows Small Business Server 2003» (http://go.microsoft.com/fwlink/?linkid=23456),


Сервер Exchange работает под управлением VMware
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-10-26

Дополнительные сведения о поддержке компьютеров Exchange Server, работающих в виртуальных средах, см. в статье базы знаний 897615 «Support policy for Microsoft software running in non-Microsoft hardware virtualization software» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=897615) (Ограничения поддержки работы Exchange Server на программном обеспечении виртуальных машин, поставляемом не корпорацией Майкрософт).


На данном Exchange server менее 1 ГБ памяти, но в файле boot.ini есть ключи /3GB и /USERVA=3030
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server запрашивает два класса инструментария Microsoft Windows® Management Instrumentation (WMI) для определения объема физической памяти Exchange Server и виртуального адресного пространства, распределенных для процессов режима пользователя. В следующей таблице приведены классы и ключи, оцениваемые средством анализа Exchange Server.

Класс | Ключ | Описание
Win32_OperatingSystem | MaxProcessMemorySize | Максимальное количество килобайт памяти, которые могут быть распределены для процесса.
Win32_OperatingSystem | OSProductSuite | Установленные и лицензированные добавления системных продуктов к операционной системе.
Win32_ComputerSystem | TotalPhysicalMemory | Количество байт установленной на компьютере оперативной памяти (ОЗУ).

Если средство Exchange Server Analyzer определяет, что на компьютере Exchange Server менее 950 мегабайт (МБ) ОЗУ, и значение MaxProcessMemorySize превышает 2097024, но менее 3104640, отображается предупреждение.

Это предупреждение означает, что компьютер Exchange Server неправильно настроен на оптимальное использование памяти в двух отношениях.

  • Установлен ключ запуска /USERVA=3030. Этот ключ необходим только для компьютеров Exchange Server с объемом памяти 1 гигабайт (ГБ) или больше, работающих под управлением операционной системы Microsoft Windows Server™ 2003.

  • Установлен ключ запуска /3GB. Этот ключ следует использовать только на Exchange Server с объемом памяти 1 ГБ или более, работающих под управлением следующих операционных систем.

    • Microsoft Windows Server 2003 Standard Edition

    • Microsoft Windows Server 2003 Enterprise Edition

    • Microsoft Windows Server 2003 Datacenter Edition

    • Microsoft Windows 2000 Advanced Server

    • Microsoft Windows 2000 Datacenter Server

Важно!
Ключ /3GB не должен использоваться в операционной системе Windows 2000 Server, так как он не поддерживается и может привести к сбою приложения или операционной системы. Более того, ключ /3GB поддерживается только в перечисленных выше операционных системах с объемом установленной физической памяти 1 ГБ или более.

Появление данного сообщения в системах с установленной физической памятью объемом 1 ГБ может означать, что другой компонент, например видеокарта, распределил некоторое количество памяти на аппаратном уровне, таким образом сделав распределенную физическую память недоступной для операционной системы. В этом случае количество физической установленной памяти в соответствии с Windows будет меньше фактического размера установленной на компьютере физической памяти. В этом случае следует следует сравнить сведения BIOS и Windows об объеме установленной памяти.

Для устранения этой неполадки в Windows Server 2003

  1. Правой кнопкой мыши щелкните значок Мой компьютер, затем щелкните Свойства. Появится диалоговое окно Свойства системы.

  2. Щелкните Дополнительно.

  3. В области Загрузка и восстановление щелкните Параметры. Появится диалоговое окно Загрузка и восстановление.

  4. В области Загрузка операционной системы щелкните Правка. Файл Windows Boot.ini откроется в программе Блокнот.

  5. В разделе [Операционные системы] удалите следующие ключи из всех строк загрузки: /3GB /USERVA=3030

  6. Сохраните изменения и закройте программу Блокнот.

  7. Два раза щелкните OK, чтобы закрыть открытые диалоговые окна, затем перезагрузите компьютер, чтобы изменения вступили в силу.

Для устранения этой неполадки в Windows 2000 Server

  1. В Проводнике Windows перейдите к следующему разделу системы.

  2. Если файл Boot.ini не виден, для параметра Свойства папки установлено значение Скрывать защищенные системные файлы. В этом случае в Проводнике Windows щелкните Сервис, затем Свойства папки, затем Вид. Отключите флажок Скрывать защищенные системные файлы (рекомендуется). При появлении окна с предупреждением щелкните Да.

  3. Если файл Boot.ini виден в Проводнике Windows, щелкните файл правой кнопкой мыши и выберите Открыть с помощью, затем щелкните Блокнот, чтобы открыть файл.

  4. Удалите ключ /3GB и, если присутствует, /USERVA=3030.

  5. Сохраните изменения и закройте программу Блокнот.

  6. Перезагрузите компьютер, чтобы изменения вступили в силу.

Дополнительные сведения об использовании ключей загрузки /3GB и /USERVA см. в следующих статьях базы знаний корпорации Майкрософт:

  • 308356, «Использование памяти процессом Lsass.exe на контроллерах домена, работающих под управлением операционной системы Windows Server 2003 или Windows 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)

  • 297812, «Использование функции настройки ОЗУ 4GT» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, «Результаты настройки 4GT на элементы системной таблицы страниц» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739, «Использование ключа /USERVA Switch в файле Boot.ini для настройки конфигураций Tune /3GB» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044, «ИНСТРУКЦИИ: Устранение фрагментации виртуальной памяти в Exchange 2003 и Exchange 2000»" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, «Оптимизация использования памяти в Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Объем памяти сервера Exchange меньше 1 ГБ, однако для него установлен переключатель /3GB в файле Boot.ini
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает два WMI-класса (Microsoft Windows® Management Instrumentation), чтобы определить объем физической памяти на компьютере сервера Exchange и объем виртуального адресного пространства, выделенного для процессов пользовательского режима на компьютере сервера Exchange. В следующей таблице описываются классы и ключи, оцениваемые анализатором сервера Exchange.

Запрашиваемый класс | Запрашиваемые ключи | Описание
Win32_OperatingSystem | MaxProcessMemorySize | Максимальное количество килобайтов памяти, которая может быть выделена для процесса.
Win32_ComputerSystem | TotalPhysicalMemory | Количество байтов памяти с произвольной выборкой (ОЗУ), установленной на компьютере.

Если анализатор сервера Exchange определит, что значение TotalPhysicalMemory меньше 1073741824, и что значение MaxProcessMemorySize равно 3145600, на экран будет выведено предупреждение.

Это предупреждение указывает, что объем физической памяти системы меньше 950 мегабайтов (МБ), но система настроена с переключателем загрузки /3GB в файле Boot.ini. Этот переключатель следует использовать только на серверах Exchange, имеющих память объемом 1 гигабайт (ГБ) или более и работающих под управлением любой из следующих операционных систем:

  • Microsoft Windows Server™ 2003 Standard Edition,

  • Microsoft Windows Server 2003 Enterprise Edition,

  • Microsoft Windows Server 2003 Datacenter Edition,

  • Microsoft Windows 2000 Advanced Server,

  • Microsoft Windows 2000 Datacenter Server.

Важно!
Переключатель /3GB не должен использоваться в Windows 2000 Server, так как он не поддерживается и может быть причиной отказов приложений или операционной системы. Более того, переключатель /3GB поддерживается указанными выше операционными системами только в том случае, если на компьютере установлена физическая память объемом 1 ГБ и более.

Если данное предупреждение выводится для системы, в которой установлена физическая память объемом 1 ГБ, это может указывать на то, что другому компоненту, например, видеоадаптеру, выделена часть этой физической памяти на аппаратном уровне, в связи с этим выделенная физическая память становится недоступной для операционной системы. В таких случаях объем установленной физически памяти согласно данным Windows будет меньше фактического объема физической памяти, установленной на компьютере. Если возникнет данная ситуация, следует сравнить объем установленной памяти, сообщаемой средствами BIOS, с объемом установленной памяти, сообщаемой системой Windows.

Чтобы устранить причины появления этого предупреждения в Windows Server 2003

  1. Щелкните правой кнопкой мыши Мой компьютер и в контекстном меню выберите Свойства. Появится диалоговое окно Свойства системы.

  2. Щелкните Дополнительно.

  3. В области «Загрузка и восстановление» щелкните Параметры. Появится диалоговое окно Загрузка и восстановление.

  4. В области «Загрузка операционной системы» щелкните Изменить. В результате этих действий в «Блокноте» откроется файл Boot.ini операционной системы Windows.

  5. В части [Operating Systems] (операционные системы) удалите из всех строк загрузки следующий переключатель: /3GB

  6. Сохраните изменения и закройте «Блокнот».

  7. Нажмите два раза кнопку OK, чтобы закрыть открытые диалоговые окна, и затем перезапустите компьютер, чтобы изменение вступило в силу.

Чтобы устранить причины появления этого предупреждения в Windows 2000 Server

  1. В проводнике Windows перейдите к системному разделу. Это раздел, в котором хранятся файлы поддержки оборудования, такие как Boot.ini и NTLDR.

  2. Если файл Boot.ini не виден, возможно, в окне Свойства папки установлен флажок Скрывать защищенные системные файлы. Если это так, в окне проводника Windows последовательно щелкните Сервис, Свойства папки, а затем щелкните Вид. Снимите флажок Скрывать защищенные системные файлы (рекомендуется). При появлении запроса нажмите кнопку Да.

  3. Если файл Boot.ini виден в проводнике Windows, щелкните правой кнопкой мыши этот файл, выберите в контекстном меню команду Открыть с помощью и щелкните Блокнот, чтобы открыть файл.

  4. В части [Operating Systems] (операционные системы) удалите из всех строк загрузки следующий переключатель: /3GB

  5. Сохраните изменения и закройте «Блокнот».

  6. Перезагрузите компьютер, чтобы изменение вступило в силу.

Дополнительные сведения об оптимизации использования памяти для сервера Exchange см. в следующих статьях базы знаний Майкрософт:

  • 325044, описывающая инструкции по устранению проблем, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044).

  • 815372, описывающая оптимизацию использования памяти в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Для этого сервера Exchange в файле Boot.ini задан переключатель запуска /3GB
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_OperatingSystem, чтобы определить объем виртуального адресного пространства, выделенного для процессов, которые выполняются в пользовательском режиме (MaxProcessMemorySize) на компьютере сервера Exchange.

Анализатор сервера Exchange также анализирует WMI-класс Exchange_Server в пространстве имен root\MicrosoftExchangeV2, чтобы определить значение ключа IsFrontEndServer. Значение False указывает, что компьютер сервера Exchange не является сервером переднего плана. Значение True указывает, что компьютер сервера Exchange является сервером переднего плана.

Анализатор сервера Exchange также запрашивает WMI-класс Win32_Service, чтобы определить, верно ли, что служба кластеров (ClusSvc) присутствует и запущена.

Наконец, анализатор сервера Exchange запрашивает службу каталогов Active Directory®, чтобы определить счетчик для атрибута homeMDBBL объекта хранения почтового ящика (msExchPrivateMDB). Итоговое показание счетчика — это число почтовых ящиков, обнаруженных на компьютере сервера Exchange.

Если анализатор сервера Exchange определит, что значение ключа MaxProcessMemorySize не равно 2097024, что ключ IsFrontEndServer установлен в значение False, что служба кластеров не выполняется, что хранилище почтовых ящиков сервера Exchange содержит менее 20 почтовых ящиков, и что приложение Exchange не выполняется в среде Microsoft Windows Small Business Server 2003, на экран будет выведено предупреждение.

Это предупреждение указывает, что сервер каталогов неправильно настроен для оптимального использования памяти, поскольку в файле Boot.ini установлен переключатель загрузки /3GB. Этот переключатель следует использовать только на серверах Exchange, имеющих память объемом 1 гигабайт (ГБ) или более и работающих под управлением любой из следующих операционных систем:

  • Microsoft Windows Server™ 2003 Standard Edition,

  • Microsoft Windows Server 2003 Enterprise Edition,

  • Microsoft Windows Server 2003 Datacenter Edition,

  • Microsoft Windows 2000 Advanced Server,

  • Microsoft Windows 2000 Datacenter Server.

Важно!
Переключатель /3GB не должен использоваться в Windows 2000 Server, так как он не поддерживается и может быть причиной отказов приложений или операционной системы. Более того, переключатель /3GB поддерживается указанными выше операционными системами только в том случае, если на компьютере установлена физическая память объемом 1 ГБ и более.

Если переключатель /3GB задан в файле Boot.ini поддерживаемой операционной системы, Windows выделяет 3 ГБ из максимально допустимых 4 ГБ виртуального адресного пространства для пользовательских процессов и 1 ГБ для ядра операционной системы. Обычно (когда переключатель /3GB не используется) операционная система Windows выделяет 2 ГБ для пользовательских процессов и 2 ГБ для ядра. Следовательно если задан переключатель /3GB, приложения, интенсивно потребляющие ресурсы памяти, имеют большее виртуальное адресное пространство для своей работы, и производительность системы повышается.

При использовании переключателя /3GB в первую очередь улучшается работа приложений, активно потребляющих ресурсы памяти, таких как процесс Store.exe на сервере Exchange, на котором размещаются почтовые ящики пользователей. На серверах переднего плана не размещаются почтовые ящики пользователей, и поэтому производительность серверов переднего плана не повышается, если задать переключатель /3GB.

Чтобы устранить причину появления этого предупреждения

  1. В проводнике Windows перейдите к системному разделу.

  2. Если файл Boot.ini не виден, возможно, в свойствах папки установлен флажок Скрывать защищенные системные файлы. Если это так, в окне проводника Windows последовательно щелкните Сервис, Свойства папки, а затем откройте вкладку Вид. Снимите флажок Скрывать защищенные системные файлы (рекомендуется). Когда появится окно предупреждения, щелкните Да.

  3. Если файл Boot.ini виден в проводнике Windows, щелкните правой кнопкой мыши этот файл, выберите в контекстном меню команду Открыть с помощью и щелкните Блокнот, чтобы открыть файл.

  4. В части [Operating Systems] (операционные системы) удалите из всех строк загрузки следующий переключатель: /3GB

  5. Сохраните изменения и закройте «Блокнот».

  6. Перезагрузите компьютер, чтобы изменение вступило в силу.

Дополнительные сведения об использовании переключателя /3GB см. в следующих статьях базы знаний Майкрософт:

  • Статья 325044, описывающая инструкции по устранению проблем, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000 (может быть на английском языке)

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044).

  • Статья 815372, описывающая оптимизацию использования памяти в Exchange Server 2003 (может быть на английском языке)

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372).


На сервере Exchange 2003 не установлена окончательная сборка пакета обновления 1 (7226.6)
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-04-21

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumber для каждого объекта Exchange Server в каталоге. Атрибут serialNumber представляет собой строковое значение, включающее версию сервера Exchange и версию пакета обновления (если он установлен). Например на компьютере под управлением Exchange Server 2003 с установленным пакетом обновления 1 атрибут serialNumber имеет значение Version 6.5 (Build 7226.6: Service Pack 1).

Если анализатор сервера Exchange обнаруживает, что значение атрибута serialNumber содержит 6.5 и Service Pack 1, но не содержит 7226.6, на экран выводится предупреждение.

Это предупреждение означает, что на компьютере под управлением Exchange Server 2003 выполняется предварительная версия пакета обновления 1 для Exchange Server 2003.

Примечание.
Поскольку удаление пакетов обновления для Exchange не предусмотрено, настоятельно рекомендуется перед установкой пакетов обновления выполнить полное резервное копирование компьютера с Exchange Server.

Чтобы устранить причину появления этого предупреждения

  1. Получите конечную версию пакета обновления 1 для Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=29090).

  2. Прочитайте заметки о выпуске Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=23235).

  3. Проверьте, какие обновления включены в пакет обновления 1 (http://go.microsoft.com/fwlink/?linkid=34272).

  4. Выполните полное резервное копирование компьютера под управлением Exchange Server.

  5. Примените пакет обновления 1 для Exchange Server 2003.

  6. Вновь выполните полное резервное копирование компьютера с Exchange Server.

Дополнительные сведения об установке пакета обновления для Exchange Server см. в статье 328839 базы знаний Майкрософт, содержащей инструкции по применению пакетов обновления и исправлений Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Этот сервер Exchange работает под управлением Windows 2000 Server, однако для него установлен переключатель «/3GB» в файле boot.ini
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает два WMI-класса (Microsoft Windows® Management Instrumentation), чтобы определить объем физической памяти на сервере Exchange и объем виртуального адресного пространства, выделенного для процессов пользовательского режима. В следующей таблице описываются классы и ключи, оцениваемые анализатором сервера Exchange.

Класс | Ключ | Описание
Win32_OperatingSystem | MaxProcessMemorySize | Максимальное количество килобайтов памяти, которая может быть выделена для процесса.
Win32_OperatingSystem | OSProductSuite | Установленные и лицензированные дополнения системных продуктов для операционной системы.
Win32_ComputerSystem | TotalPhysicalMemory | Количество байтов памяти с произвольной выборкой (ОЗУ), установленной на компьютере.

Если анализатор сервера Exchange обнаружит, что значение ключа MaxProcessMemorySize не равно 2097024 и что по значению ключа OSProductSuite определяется Windows 2000 Server, на экран будет выведено сообщение об ошибке.

Это сообщение об ошибке указывает, что сервер каталогов неправильно настроен для оптимального использования памяти, поскольку в файле Boot.ini установлен переключатель загрузки /3GB. Этот переключатель следует использовать только на серверах Exchange, имеющих память объемом 1 гигабайт (ГБ) или более и работающих под управлением любой из следующих операционных систем:

  • Microsoft Windows Server™ 2003 Standard Edition,

  • Microsoft Windows Server 2003 Enterprise Edition,

  • Microsoft Windows Server 2003 Datacenter Edition,

  • Microsoft Windows 2000 Advanced Server,

  • Microsoft Windows 2000 Datacenter Server.

Важно!
Переключатель /3GB не должен использоваться в Windows 2000 Server, так как он не поддерживается и может быть причиной отказов приложений или операционной системы. Более того, переключатель /3GB поддерживается указанными выше операционными системами только в том случае, если на компьютере установлена физическая память объемом 1 ГБ и более.

Чтобы устранить эту ошибку в Windows Server 2003

  1. Щелкните правой кнопкой мыши Мой компьютер и в контекстном меню выберите Свойства. Появится диалоговое окно Свойства системы.

  2. Откройте вкладку Дополнительно.

  3. В области «Загрузка и восстановление» нажмите кнопку Параметры. Появится диалоговое окно Загрузка и восстановление.

  4. В области «Загрузка операционной системы» нажмите кнопку Изменить. В результате этих действий в «Блокноте» откроется файл Boot.ini операционной системы Windows.

  5. В части [Operating Systems] (операционные системы) удалите из всех строк загрузки следующий переключатель: /3GB.

  6. Сохраните изменения и закройте «Блокнот».

  7. Нажмите два раза кнопку OK, чтобы закрыть открытые диалоговые окна, и затем перезапустите сервер каталогов, чтобы изменения вступили в силу.

Чтобы устранить эту ошибку в Windows 2000 Server

  1. В проводнике Windows перейдите к системному разделу.

  2. Если файл Boot.ini не виден, возможно, в свойствах папки установлен флажок Скрывать защищенные системные файлы. Если это так, в окне проводника Windows последовательно щелкните Сервис, Свойства папки, а затем откройте вкладку Вид. Снимите флажок Скрывать защищенные системные файлы (рекомендуется). Когда появится окно предупреждения, щелкните Да.

  3. Если файл Boot.ini виден в проводнике Windows, щелкните правой кнопкой мыши этот файл, выберите в контекстном меню команду Открыть с помощью и щелкните Блокнот, чтобы открыть файл.

  4. Удалите переключатель /3GB и сохраните файл.

  5. Перезагрузите сервер каталогов, чтобы изменение вступило в силу.

Дополнительные сведения об использовании параметров загрузки /3GB и /USERVA см. в следующих статьях базы знаний Майкрософт:

  • 297812, описывающая функцию настройки ОЗУ, 4GT (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, описывающая влияние настройки 4GT на системные элементы таблицы страниц (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739, описывающая использование переключателя /USERVA в файле Boot.ini для настройки конфигураций с переключателем /3GB (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044, описывающая инструкции по устранению проблем, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, описывающая оптимизацию использования памяти в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Отказано в доступе к WMI Exchange Server
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-08-24

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс Win32_ComputerSystem, чтобы определить, установлено ли значение ключа Name. Если запрос WMI-класса завершается сбоем, и сервер Exchange не работает на платформе Microsoft Windows NT® Server°4.0, анализатор сервера Exchange выводит сообщение об ошибке.

Существует две вероятные причины этой ошибки:

  • Учетная запись, от имени которой запущено средство анализа Exchange Server, не имеет достаточных разрешений на запрос классов WMI.

  • Неполадка в сети делает невозможным подключение средства анализа Exchange Server к компьютеру.

Исправление ошибки

  1. Убедитесь, что компьютер Exchange Server включен и подсоединен к сети.

  2. С помощью команды PING проверьте доступность компьютера сервера Exchange.

  3. Если в системе установлен брандмауэр, проверьте, не заблокированы ли порты удаленного вызова процедур (RPC).

  4. Проверьте разрешения учетной записи, от имени которой выполняется анализатор сервера Exchange. Учетная запись, от имени которой запущено средство анализа Exchange Server, должна иметь локальные права Администратора для каждого проверяемого сервера Exchange.

    Можно также предоставить особое разрешение WMI учетной записи, от имени которой запущено средство анализа Exchange Server:

    1. На компьютере Exchange откройте дерево консоли MMC (Microsoft Management Console) Управление компьютером.

    2. В ветви Службы и приложения щелкните правой кнопкой мыши Управляющий элемент WMI и выберите команду Свойства.

    3. На странице Свойства: Управляющий элемент WMI щелкните вкладку Безопасность и разверните дерево Root.

    4. Выберите папку CIMV2 и нажмите кнопку Безопасность.

    5. На странице Безопасность для ROOT\CIMV2 добавьте учетную запись, от имени которой выполняется анализатор сервера Exchange.

  5. Выберите учетную запись, которая была добавлена выше, на шаге 5. В разделе Разрешения для Выбранная_учетная_запись, в столбце Разрешить установите флажки Включить удаленно и Прочесть безопасность, а затем нажмите кнопку OK.

Для получения дополнительных сведений об устранении неполадок, связанных с сетевыми подключениями, см. статью 325487 базы знаний корпорации Майкрософт «Разрешение проблем, связанных с выполнением сетевого подключения» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Для получения дополнительных сведений об устранении проблем подключения средства анализатора рекомендаций для сервера Exchange см. в базе знаний Майкрософт статью, посвященную устранению неполадок, связанных с подключениями средства анализатора рекомендаций для сервера Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=56285).

Для получения дополнительных сведений о требованиях к портам см. статью 832017 базы знаний «Службы и сетевые порты в серверных системах Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


На клиентском сервере не выполняется служба системного помощника Exchange
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Server запрашивает WMI-класс Win32_Service, чтобы определить значение ключа Started для службы служба системного помощника Microsoft Exchange. Значение False указывает, что эта служба не запущена. Значение True указывает, что данная служба запущена.

Анализатор сервера Exchange также проверяет WMI-класс Exchange_Server в пространстве имен root\MicrosoftExchangeV2 для определения значения ключа IsFrontEndServer. Значение False означает, что компьютер сервера Exchange не является клиентским сервером. Значение True означает, что компьютер сервера Exchange Server является клиентским сервером.

Если анализатор сервера Exchange обнаруживает, что для ключа Started на клиентском сервере Exchange задано значение False, отображается соответствующее предупреждение.

Вообще говоря, на серверах Exchange служба системного помощника Exchange работает в непрерывном режиме. Однако иногда выполнение этой службы не требуется. Например, на клиентском сервере служба системного помощника требуется только для изменения настройки сервера.

Exchange Server хранит все свои сведения о настройке в службе каталогов Active Directory®, включая сведения о политиках получателей, настройке виртуального SMTP-сервера, параметрах удаленного вызова процедур (RPC) через HTTP и почтовых ящиков пользователей. Однако протокол SMTP считывает свои параметры из метабазы IIS. Чтобы заполнить метабазу сведениями, которые требуются Exchange для поддержки функции SMTP и RPC через HTTP, компонент DS2MB системного помощника реплицирует сведения о настройке из Active Directory в метабазу IIS. Если системный помощник не выполняется, изменения, внесенные в параметры настройки Exchange Server, которые хранятся в Active Directory, е будут копироваться в метабазу IIS сервера Exchange Server. Если изменение настроек не проводилось и SMTP-сообщения не обрабатывались, служба системного помощника может не запускаться.

Если требуется внести изменения в настройку, запустите службу системного помощника, внесите необходимые изменения в настройку, а затем подождите, пока эти изменения не будут реплицированы в метабазу IIS. Чтобы определить, выполнена ли репликация изменений из Active Directory в метабазу IIS, проверьте наличие трех записей в журнале событий приложений сервера Exchange, для которых имеется источник событий MSExchangeMU и код события, равный 1005. Эти события будут занесены в журнал после успешного выполнения репликации компонентом DS2MB. Если эти события занесены в журнал, можно остановить службу системного помощника.

За исключением случая, когда протокол SMTP используется на клиентском сервере, рекомендованной настройкой является останов службы системного помощника, после чего задается ее отключение. На клиентских серверах, на которых используется SMTP, а также на всех других компьютерах Exchange Server, служба системного помощника Exchange должна выполняться для обеспечения доставки сообщений, поддержки службы SMTP, транзакций хранилища почтовых ящиков и выполнения репликации компонентом DS2MB.

Служба системного помощника Exchange должна всегда выполняться на клиентских серверах и любых других серверах Exchange, на которых имеются почтовые ящики или общие папки.

Чтобы устранить причину появления этого предупреждения

  1. Откройте оснастку «Службы» консоли управления (MMC).

  2. В правой области выполните прокрутку до службы служба системного помощника Microsoft Exchange и дважды щелкните этот элемент. Будет выведено диалоговое окно Свойства службы системного помощника.

  3. В раскрывающемся списке Тип запуска выберите значение Авто.

  4. Нажмите кнопку Пуск для запуска службы системного помощника.

  5. Нажмите кнопку ОК, чтобы сохранить изменения и закрыть диалоговое окно Свойства службы системного помощника.

  6. Закройте оснастку «Службы».

Для получения дополнительных сведений об отключении службы системного помощника и обеспечении безопасности серверов Exchange, см. следующие документы по Exchange Server:

  • Статья, посвященная обеспечению безопасности серверов Exchange 2000 Server на основе использования ролей (http://go.microsoft.com/fwlink/?LinkId=18177)

  • Руководство по усилению безопасности Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576)


Системный помощник Exchange отключен
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-09

Для определения значения раздела Started службы системного помощника Microsoft Exchange анализатор рекомендаций сервера Exchange Server делает запрос к классу Win32_Service инструментария управления Microsoft Windows® (WMI). Значение False указывает, что служба Exchange System Attendant не работает. Значение True указывает, что служба системного помощника Exchange работает.

Анализатор сервера Exchange Server также анализирует класс WMI Exchange_Server в пространстве имен root\MicrosoftExchangeV2, чтобы определить значение раздела IsFrontEndServer. Значение Ложь указывает, что компьютер, использующий Exchange Server, не является сервером переднего плана. Значение True указывает, что компьютер Exchange Server является сервером переднего плана.

Если анализатор Exchange Server определяет, что на компьютере Exchange Server, который не является сервером переднего плана, значение раздела Started равно False, отображается предупреждение.

Как правило, на большинстве серверов Exchange служба системного помощника работает постоянно. Однако в некоторых случаях запуск службы System Attendant не требуется. Например, на сервере переднего плана Exchange 2000 Server или Exchange Server 2003 служба системного помощника необходима только для изменения настройки сервера.

Exchange Server сохраняет все сведения о настройке, включая данные о политиках получателей, настройке виртуального сервера SMTP, параметрах удаленного вызова процедур (RPC) по протоколу HTTP, в службе каталогов Active Directory®. Однако SMTP считывает свои параметры из метабазы служб IIS. Для занесения в метабазу IIS данных, необходимых Exchange для работы с SMTP и RPC через HTTP, компонент Системного помощника, предназначенный для переноса службы каталогов в метабазу (DS2MB), копирует данные о настройке из службы Active Directory в метабазу IIS. Если Системный помощник не работает, изменения параметров настройки Exchange Server, хранящиеся в Active Directory, не будут скопированы в метабазу IIS Exchange Server. Если изменения настройки отсутствуют и сообщения SMTP не обрабатываются, системный помощник может находиться в состоянии останова.

При необходимости внесения изменений в настройку запустите службу системного помощника, внесите изменения и подождите, пока они не будут скопированы в метабазу IIS. Чтобы определить, скопированы ли изменения из Active Directory в метабазу IIS, проверьте наличие в журнале событий сервера Exchange трех записей, источник события для которых -- MSExchangeMU, а идентификатор события равен 1005. Эти события записываются после успешного копирования DS2MB. После записи событий системный помощник может быть остановлен.

Если на сервере переднего плана Exchange 2000 Server или Exchange Server 2003 не используется SMTP, рекомендуется остановить службу системного помощника и отключить его работу. На серверах переднего плана Exchange 2000 Server или Exchange Server 2003, использующих SMTP, а также на всех компьютерах, использующих Exchange Server, для доставки сообщений, обслуживания транзакций SMTP и хранилищ почтовых ящиков и репликации DS2MB должна быть запущена служба системного помощника Exchange.

Служба Exchange System Attendant должна работать на всех серверах-хранилищах и всех серверах Exchange, содержащих почтовые ящики или общедоступные папки.

Для устранения этого предупреждения

  1. Откройте оснастку Microsoft Management Console (MMC) Службы.

  2. На правой панели с помощью прокрутки найдите службу Системный помощник Exchange Microsoft и дважды щелкните ее. Отобразится диалоговое окно Свойства системного помощника.

  3. В раскрывающемся меню для параметра Тип загрузки укажите Автоматически.

  4. Нажмите кнопку Пуск для запуска системного помощника.

  5. Нажмите кнопку OK для сохранения изменений и закройте диалоговое окно Свойства системного помощника.

  6. Закройте оснастку Службы.

Дополнительные сведения об отключении службы системного помощника и обеспечении безопасности серверов Exchange Server см. в статье, посвященной обеспечению безопасности серверов Exchange 2000 Server на основе ролей (http://go.microsoft.com/fwlink/?linkid=35585).


Кучи Exchmem указывают на проблемы производительности
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange проанализировал счетчики производительности Exchmem Heap объекта системного монитора MSExchangeIS для определения снижения производительности на сервере Exchange. Анализатор сервера Exchange создает отчетность по счетчикам Exchmem следующим образом:

  • Если значение Exchmem: число куч с ошибками памяти больше нуля, анализатор сервера Exchange регистрирует предупреждение. Если это значение больше пяти, анализатор сервера Exchange регистрирует ошибку.

  • Если значение Exchmem: число ошибок памяти больше 500, анализатор сервера Exchange регистрирует ошибку.

  • Если значение Exchmem: число дополнительных куч больше трех, анализатор сервера Exchange регистрирует ошибку.

Процесс Store.exe использует свои собственные механизм и структуры распределения куч. Они называются Exchmem. При запуске процесс Store.exe создает несколько куч Exchmem. Store.exe не увеличивает число куч, если только существующее количество полностью не используется или кучи не фрагментированы до такой степени, что процесс распределения не может найти достаточный блок непрерывной памяти.

Если возникает проблема использования ресурсов памяти или внутренней фрагментации (то есть, фрагментация в кучах Exchmem, которые распределяются в пространстве виртуальной памяти хранилища Exchange), процесс Store.exe создает новые кучи Exchmem.

Обычно если процессу Store.exe приходится многократно создавать дополнительные кучи, общая виртуальная память хранилища Exchange становится фрагментированной или исчерпывается. Отслеживая упомянуты выше счетчики, можно определить, являются ли кучи Exchmem источником проблемы и уменьшается ли производительность куч по мере их фрагментации.

Чтобы устранить причину предупреждения или ошибки:

  • Загрузите и установите самые последние обновления хранилища Exchange.

    • Самые последние загружаемые файлы для Exchange Server 2003 можно получить на веб-узле загрузки Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

    • Самые последние загружаемые файлы для Exchange Server 2000 можно получить на веб-узле загрузки Exchange Server 2000 (http://go.microsoft.com/fwlink/?LinkId=33457).

  • Загрузите и установите последние обновления для всех приложений, которые запускаются в процессе Store.exe. Иногда фрагментацию куч могут вызвать приложения независимых разработчиков, работающие в процессе Store.exe.

  • Рассмотрите целесообразность перемещения почтовых ящиков пользователей с проблемного сервера на другой сервер, чтобы уменьшить нагрузку не сервер. Дополнительные сведения см. в разделе Перенос почтовых ящиков пользователей на другой сервер.

  • Пока причина проблемы еще не выявлена, в качестве временной меры можно перезапустить систему, чтобы сбросить память.

Дополнительные сведения

  • Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Дополнительные сведения об устранении проблем, связанных с производительностью сервера Exchange, см. в документе, посвященном устранению неполадок, связанных с производительностью сервера Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).


В папке System32 операционной системы Windows имеется файл EXCHMEM.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-12-15

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс CIM_Datafile (WMI — Microsoft Windows® Management Instrumentation), чтобы определить, удается ли прочитать значение ключа Version для \Windows\System32\Exchmem.dll. Если анализатор сервера Exchange может прочитать ключ «Version», значит в папке System32 имеется файл Exchmem.dll.

Кроме того, анализатор сервера Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumber для всех объектов, имеющих класс объекта msExchExchangeServer. Если строковое значение содержит «Version 6», на компьютере работает Exchange 2000 Server или Exchange Server 2003.

Анализатор сервера Exchange выводит на экран сообщение с рекомендациями, если выполняются следующие условия:

  • Exchmem.dll имеется в папке System32.

  • Компьютер работает под управлением Exchange 2000 Server или Exchange Server 2003.

На одном сервере Exchange обычно не бывает двух копий Exchmem.dll. Однако иногда второй файл Exchmem.dll добавляется при выполнении обновления предыдущих выпусков данного продукта на месте. Наличие двух версий этого файла может привести к сбою в работе программы установки при установке пакетов обновления. Чтобы избежать проблем, рекомендуется переименовать или удалить файл Exchmem.dll в папке \Windows\System32.

Чтобы переименовать или удалить вторую версию файла Exchmem.dll

  1. Остановите все службы Exchange.

  2. Переименуйте или удалите файл Exchmem.dll в папке \Windows\System32.

  3. Повторно запустите все службы Exchange.


Обнаружена неустранимая ошибка
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-10-06

Средство анализа Microsoft® Exchange Server пытается получить доступ к различным специальным ресурсам для выполнения анализа:

  • Служба каталогов Microsoft Active Directory®;

  • Центр отслеживания сообщений Exchange Server;

  • Системный реестр Microsoft Windows®;

  • Инструментарий WMI;

  • Метабаза служб Internet Information Services (IIS).

Если средство анализа Exchange Server не может получить доступ к одному или нескольким требуемым ресурсам, выдается сообщение об ошибке.

Это сообщение указывает на то, что дополнительный анализ невозможен, так как один или несколько основных ресурсов недоступны.

Для устранения причин появления этого сообщения об ошибке просмотрите руководство по действиям в случае ошибок для конкретного ресурса и ссылки, указанные средством анализа Exchange Server.


Для сервера не включена регистрация в журнале вызовов функций
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-20

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumber для всех объектов, принадлежащих классу msExchExchangeServer. Если строковое значение содержит выражение Version 5.5, на компьютере выполняется Microsoft Exchange Server версии 5.5. Если строковое значение содержит выражение Version 6.0, на компьютере выполняется Exchange 2000 Server. Если строковое значение содержит выражение Version 6.5, на компьютере выполняется Exchange Server 2003.

Чтобы определить, включена ли для сервера Exchange возможность регистрации вызовов функций (Function Call Logging, FCL) Microsoft Exchange, анализатор сервера Exchange также запрашивает наличие подраздела Отключить отслеживание вызовов из следующей записи реестра:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Сервер Exchange может отслеживать функционирование внутренних вызовов, выполняемых службой «Банк данных Microsoft Exchange» (Store.exe). Журнал вызовов функций можно использовать для выявления вызова функции и компонента, которые могут быть основной причиной возникновения проблемы с производительностью.

Журнал вызовов функций в службе «Банк данных Microsoft Exchange» отслеживает соответствующие вызовы для следующих компонентов:

  • сервер проверки подлинности локальной системы безопасности (Lsass.exe),

  • DSAccess,

  • модуль расширяемого хранилища ESE (Extensible Storage Engine),

  • IMAIL,

  • Virusscan.

Журнал вызовов функций характеризуется низкой нагрузкой на систему при регистрации собираемых данных о проблемных сценариях, таких как проблемы ненамеренных завершений работы сервера Exchange и ситуации, когда служба «Банк данных Exchange» (Store.exe) демонстрирует падение производительности или перестает отвечать на внешние воздействия.

Сразу после включения журнал вызовов функций автоматически регистрирует данные вызовов функций. Вмешательство пользователя или специальная настройка, например, получение пользовательского файла дампа производственного сервера или использование отладчика не требуются.

По умолчанию журнал вызовов функций включен в приложении Exchange Server 2003, но должен специально включаться в Exchange 2000 Server.

Анализатор сервера Exchange выводит на экран сообщение, содержащее рекомендации, если выполняются следующие условия:

  • На сервере выполняется Exchange 2000 Server и подраздел Отключить отслеживание вызовов отсутствует, или подраздел Отключить отслеживание вызовов присутствует, но содержит значение, отличное от 0.

  • На сервере выполняется Exchange Server 2003, подраздел Отключить отслеживание вызовов присутствует и содержит значение, отличное от 0.

Это сообщение, содержащее рекомендации, указывает, что журнал вызовов функций отключен.

Рекомендуется включить журнал вызовов функций на всех серверах Exchange.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы включить регистрацию вызовов функций в приложении Exchange 2000 Server

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Disable Call Tracing

  3. В правой области дважды щелкните Отключить отслеживание вызовов. Если подраздел Отключить отслеживание вызовов отсутствует, создайте его как новое значение DWORD.

  4. Установите для подраздела Отключить отслеживание вызовов значение равное 0.
Примечание.
По умолчанию журнал вызовов функций выключен в Exchange 2000 Server, и это значение установлено равным 1.
  1. Закройте редактор реестра.

  2. Перезапустите службу «Банк данных Exchange», чтобы изменения вступили в силу.

 Чтобы включить регистрацию вызовов функций в Exchange Server 2003

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Отключить отслеживание вызовов.

  3. В правой области дважды щелкните Отключить отслеживание вызовов.

  4. Установите для подраздела Отключить отслеживание вызовов значение равное 0.
Примечание.
По умолчанию журнал вызовов функций включен в Exchange Server 2003, подраздел Отключить отслеживание вызовов создан, а его значение установлено и отличается от 0, чтобы отключить эту возможность.
  1. Закройте редактор реестра.

  2. Перезапустите службу «Банк данных Exchange», чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Количество свободных элементов таблицы страниц достигло критического порога
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_PerfRawData_PerfOS_Memory, чтобы определить текущее значение объекта FreeSystemPageTableEntries. Если значение объекта FreeSystemPageTableEntries меньше или равно 5000, отображается ошибка.

Операционные системы Microsoft Windows Server™ 2003 и Windows 2000 Server могут напрямую адресовать до 4 гигабайтов (ГБ) адресного пространства памяти, независимо от объема установленного ОЗУ. С точки зрения процесса каждый элемент виртуального адреса в принципе указывает на байт физической памяти. Диспетчер виртуальной памяти (Virtual Memory Manager, VMM) совместно с блоком диспетчера памяти процессора (memory manager unit, MMU) отвечает за преобразование (сопоставление) каждого виртуального адреса в соответствующий физический адрес. Диспетчер виртуальной памяти выполняет сопоставление посредством разбиения ОЗУ на блоки страниц фиксированного размера и создания системных элементов таблицы страниц (page table entries, PTE) для хранения сведений об этих блоках страниц и их сопоставления. Системные элементы таблицы страниц — это небольшие буферы памяти в защищенном режиме операционной системы, которые используются для взаимодействия с дисковой подсистемой ввода-вывода и сетью. Каждый элемент таблицы страниц представляет собой страничный блок и содержит сведения, необходимые диспетчеру виртуальной памяти для определения местоположения страницы.

В системах на основе процессора x86, в которых используются страницы размером 4 килобайта (КБ), максимальное количество элементов таблицы страниц, необходимых для сопоставления 2 ГБ адресного пространства, составляет 524 288 (2 ГБ/4 КБ). В аналогичных системах, в которых используется переключатель /3GB, количество элементов таблицы страниц, необходимых для сопоставления 3 ГБ адресного пространства, составляет 786 432 (3 ГБ/4 КБ). В типовой системе указанное пространство используется следующим образом:

  • Не более 50 000 элементов таблицы страниц (приблизительно 195 МБ адресного пространства) резервируется для общего использования.

  • Остальная память используется для сопоставления системного кэша, гиперпространства, выгружаемого пула, невыгружаемого пула, области аварийной копии памяти и так далее.

Размер этого пула элементов таблицы страниц автоматически определяется при запуске системы на основе объема физической памяти в системе. Этот пул вмещается между выгружаемым пулом и невыгружаемым пулом, которые также увеличиваются с объемом физической памяти в системе.

Пул системных элементов таблицы страниц может быть большей частью использован и сильно фрагментирован. Это может привести к ситуациям, когда невозможно загрузить драйвер. К тому же, если пул системных элементов таблицы страниц полностью занят, ухудшится работа других частей системы, что может даже привести к невозможности создания потоков, системным остановам и потенциальным отказам системы.

На исправном компьютере сервера Exchange в любое время должно быть доступно, по крайней мере, 8000 системных элементов таблицы страниц. Если количество свободных системных элементов таблицы страниц становится меньше 8000, но остается больше 5000, отображается предупреждение, описанное в разделе Количество свободных элементов таблицы страниц достигло критического порога. Когда количество свободных системных элементов таблицы страниц становится меньше 5000, отображается данная ошибка.

Для устранения этой проблемы можно выполнить описываемую ниже процедуру, чтобы настроить в реестре значение SystemPages, подходящее для операционной системы компьютера, на котором функционирует сервер Exchange. При выполнении пакета обновления 1 (SP1) Exchange Server 2003 в операционной системе Windows Server 200 с ОЗУ 1 ГБ и более рекомендуется установить в реестре параметр SystemPages равным нулю. Эта рекомендация противоположна рекомендации для Windows 2000 Server, в которой советуют установить параметр SystemPages равным десятичному числу 31000.

После выполнения описываемой ниже процедуры следует проконтролировать количество свободных системных элементов таблицы страниц. Это можно сделать путем наблюдения за счетчиком производительности «Память | Свободные системные элементы таблицы страниц» с помощью системного монитора Windows. Если после внесения изменений в реестр количество свободных системных элементов таблицы страниц остается малым, следует выполнить следующие проверки, чтобы убедиться в оптимальной настройке компьютера сервера Exchange:

  • Драйверы. Неправильно функционирующий драйвер — одна из наиболее распространенных причин малого количества системных элементов таблицы страниц. Обратившись к производителю оборудования, проверьте, чтобы использовались последние версии драйверов для всех компонентов оборудования. К тому же, существует возможность возврата на более общий драйвер с меньшим номером версии. Например, компьютеры, на которых выполняются серверные приложения, такие как сервер Exchange, обычно не нуждаются в самых последних драйверах видеоадаптеров со всеми их возможностями. Вместо них в большинстве случаев подойдет более общий драйвер. При переходе от усовершенствованного драйвера видеоадаптера к более общему драйверу должно увеличиться количество свободных системных элементов таблицы страниц.

  • Конфигурация системы. Если на компьютере с операционной системой Windows Server 2003 установлено физической памяти 1 ГБ и более, следует убедиться в правильной настройке файла Boot.ini с переключателями /3GB и /USERVA=3030 согласно сведениям, изложенным в базе знаний Майкрософт в статье 823440, описывающей необходимость использования переключателя /3GB при установке Exchange Server 2003 на компьютере под управлением Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440) и статье базы знаний Майкрософт, 810371, описывающей использование переключателя /Userva в сервере Exchange, выполняемом на компьютере под управлением Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371).

  • Журналы событий. Проверьте на сервере Exchange журнал событий приложений на наличие ошибок и предупреждений, особенно событий MSExchangeIS 9582 (ошибки и предупреждения), 9665 (предупреждение) и 12880 (ошибка). Присутствие в журнале события 9665 может также указывать на то, что параметр SystemPages не настроен для достижения оптимальной производительности. Дополнительные сведения об этих событиях см. в базе знаний Майкрософт в статье 325044, описывающей инструкции по устранению проблем, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044).

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить эту ошибку на компьютере под управлением Windows 2000 Server

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. В правой области дважды щелкните SystemPages.

  4. В поле Значение введите десятичное значение 31000 (31000 — это десятичное представление шестнадцатеричного числа 7918 hex. Программа Regedit.exe использует по умолчанию шестнадцатеричные значения), а затем нажмите кнопку OK.

  5. Закройте редактор реестра и перезапустите компьютер, чтобы изменения вступили в силу.

Чтобы устранить эту ошибку на компьютере под управлением начальной версии Windows 2003 Server

  • Ознакомьтесь со сведениями, изложенными в базе знаний Майкрософт в статье 894067, описывающей почему средство повышения производительности неточно показывает доступное количество свободных системных элементов таблицы страниц в Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067), чтобы определить фактическое количество свободных системных элементов таблицы страниц.

Чтобы устранить эту ошибку на компьютере под управлением Windows Server 2003 с пакетом обновления 1 (SP1)

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. В правой области дважды щелкните SystemPages.

  4. В поле Значение введите 0 и нажмите кнопку OK.

  5. Закройте редактор реестра.

  6. Щелкните правой кнопкой мыши Мой компьютер и в контекстном меню выберите Свойства. Появится диалоговое окно Свойства системы.

  7. Щелкните Дополнительно.

  8. В области Загрузка и восстановление щелкните Параметры. Появится диалоговое окно Загрузка и восстановление.

  9. В области Загрузка операционной системы щелкните Изменить. В результате этих действий в «Блокноте» откроется файл Boot.ini операционной системы Windows.

  10. Ознакомьтесь с частью [Operating Systems] (Операционные системы).

    1. Если присутствует переключатель /3GB и нет переключателя /USERVA=3030, добавьте переключатель /USERVA=3030 в строку загрузки, чтобы она была настроена как /3GB /USERVA=3030.

    2. Если переключатели /3GB /USERVA=3030 уже настроены, измените значение переключателя /USERVA на /USERVA=2970.

  11. Сохраните изменения и закройте «Блокнот».

  12. Нажмите два раза кнопку OK, чтобы закрыть открытые диалоговые окна, и затем перезапустите компьютер, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в статье 256986 (может быть на английском языке) базы знаний Майкрософт, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об оптимизации памяти для сервера Exchange см. в следующих статьях базы знаний Майкрософт:

  • 894067, описывающая почему средство повышения производительности неточно показывает доступное количество свободных системных элементов таблицы страниц в Windows Server 2003 (может быть на английском языке) http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067

  • 325044, описывающая инструкции по устранению проблем, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 823150, описывающая порядок сбора данных для устранение проблем виртуальной памяти в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823150)

  • 815372, описывающая оптимизацию использования памяти в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 311901, описывающая влияние настройки 4GT на системные элементы таблицы страниц (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


Количество свободных элементов таблицы страниц достигло критического порога
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_PerfRawData_PerfOS_Memory, чтобы определить текущее значение объекта FreeSystemPageTableEntries. Если значение FreeSystemPageTableEntries больше 5000, однако меньше или равно 8000, выводится предупреждение.

Операционные системы Microsoft Windows Server™ 2003 и Windows 2000 Server могут напрямую адресовать до 4 гигабайтов (ГБ) адресного пространства памяти, независимо от объема установленного ОЗУ. С точки зрения процесса каждый элемент виртуального адреса в принципе указывает на байт физической памяти. Диспетчер виртуальной памяти (Virtual Memory Manager, VMM) совместно с блоком диспетчера памяти процессора (memory manager unit, MMU) отвечает за преобразование (сопоставление) каждого виртуального адреса в соответствующий физический адрес. Диспетчер виртуальной памяти выполняет сопоставление посредством разбиения ОЗУ на блоки страниц фиксированного размера и создания системных элементов таблицы страниц (page table entries, PTE) для хранения сведений об этих блоках страниц и их сопоставления. Системные элементы таблицы страниц — это небольшие буферы памяти в защищенном режиме операционной системы, которые используются для взаимодействия с дисковой подсистемой ввода-вывода и сетью. Каждый элемент таблицы страниц представляет собой страничный блок и содержит сведения, необходимые диспетчеру виртуальной памяти для определения местоположения страницы.

В системах на основе процессора x86, в которых используются страницы размером 4 килобайта (КБ), максимальное количество элементов таблицы страниц, необходимых для сопоставления 2 ГБ адресного пространства, составляет 524 288 (2 ГБ/4 КБ). В аналогичных системах, в которых используется переключатель /3GB, количество элементов таблицы страниц, необходимых для сопоставления 3 ГБ адресного пространства, составляет 786 432 (3 ГБ/4 КБ). В типовой системе указанное пространство используется следующим образом:

  • Не более 50 000 элементов таблицы страниц (приблизительно 195 МБ адресного пространства) резервируется для общего использования.

  • Остальная память используется для сопоставления системного кэша, гиперпространства, выгружаемого пула, невыгружаемого пула, области аварийной копии памяти и так далее.

Размер этого пула элементов таблицы страниц автоматически определяется при запуске системы на основе объема физической памяти в системе. Этот пул вмещается между выгружаемым пулом и невыгружаемым пулом, которые также увеличиваются с объемом физической памяти в системе.

Пул системных элементов таблицы страниц может быть большей частью использован и сильно фрагментирован. Это может привести к ситуациям, когда невозможно загрузить драйвер. К тому же, если пул системных элементов таблицы страниц полностью занят, ухудшится работа других частей системы, что может даже привести к невозможности создания потоков, системным остановам и потенциальным отказам системы.

На исправном компьютере сервера Exchange в любое время должно быть доступно, по крайней мере, 8000 системных элементов таблицы страниц. Если количество свободных системных элементов таблицы страниц становится меньше 8000, но остается больше 5000, отображается ошибка, описанная в разделе Количество свободных элементов таблицы страниц достигло критического порога. Когда количество свободных системных элементов таблицы страниц становится меньше 8 000, однако остается более 5 000, отображается данное предупреждение.

Для устранения этой проблемы можно выполнить описываемую ниже процедуру, чтобы настроить в реестре значение SystemPages, подходящее для операционной системы компьютера, на котором функционирует сервер Exchange. При выполнении пакета обновления 1 (SP1) Exchange Server 2003 в операционной системе Windows Server 200 с ОЗУ 1 ГБ и более рекомендуется установить в реестре параметр SystemPages равным нулю. Эта рекомендация противоположна рекомендации для Windows 2000 Server, в которой предпочтительно установить параметр SystemPages равным десятичному числу 31 000.

После выполнения описываемой ниже процедуры следует проконтролировать количество свободных системных элементов таблицы страниц. Это можно сделать путем наблюдения за счетчиком производительности «Память | Свободные системные элементы таблицы страниц» с помощью системного монитора Windows. Если после внесения изменений в реестр количество свободных системных элементов таблицы страниц остается малым, следует выполнить следующие проверки, чтобы убедиться в оптимальной настройке компьютера сервера Exchange:

  • Драйверы. Неправильно функционирующий драйвер — одна из наиболее распространенных причин малого количества системных элементов таблицы страниц. Обратесь к производителю оборудования, чтобы гарантировать, что используются последние версии драйверов для всех компонентов оборудования. К тому же, существует возможность возврата на более общий драйвер с меньшим номером версии. Например, компьютеры, на которых выполняются серверные приложения, такие как сервер Exchange, обычно не нуждаются в самых последних драйверах видеоадаптеров со всеми их возможностями. Вместо них в большинстве случаев подойдет более общий драйвер. При переходе от усовершенствованного драйвера видеоадаптера к более общему драйверу должно увеличиться количество свободных системных элементов таблицы страниц.

  • Конфигурация системы. Если на компьютере с операционной системой Windows Server 2003 установлено физической памяти 1 ГБ и более, следует убедиться в правильной настройке файла Boot.ini с переключателями /3GB и /USERVA=3030 согласно сведениям, изложенным в базе знаний Майкрософт в статье 823440, описывающей необходимость использования переключателя /3GB при установке Exchange Server 2003 на компьютере под управлением Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440) и статье базы знаний Майкрософт, 810371, описывающей использование переключателя /Userva в сервере Exchange, выполняемом на компьютере под управлением Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371).

  • Журналы событий. Проверьте на сервере Exchange журнал событий приложений на наличие ошибок и предупреждений, особенно событий MSExchangeIS 9582 (ошибки и предупреждения), 9665 (предупреждение) и 12880 (ошибка). Присутствие в журнале события 9665 может также указывать на то, что параметр SystemPages не настроен для достижения оптимальной производительности. Дополнительные сведения об этих событиях см. в базе знаний Майкрософт в статье 324044, описывающей инструкции по устранению проблем, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044).

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы устранить эту ошибку на компьютере под управлением Windows 2000 Server

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. В правой области дважды щелкните SystemPages.

  4. В поле Значение введите десятичное значение 31000 (31000 — это десятичное представление шестнадцатеричного числа 7918, программа Regedit.exe использует по умолчанию шестнадцатеричные значения), а затем нажмите кнопку ОК.

  5. Закройте редактор реестра и перезапустите компьютер, чтобы изменения вступили в силу.

Чтобы устранить это предупреждение на компьютере под управлением начальной версии Windows 2003 Server

  • Ознакомьтесь со сведениями, изложенными в базе знаний Майкрософт в статье 894067, описывающей почему средство повышения производительности неточно показывает доступное количество свободных системных элементов таблицы страниц в Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067), чтобы определить фактическое количество свободных системных элементов таблицы страниц.

Чтобы устранить эту ошибку на компьютере под управлением Windows Server 2003 с пакетом обновления 1 (SP1)

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. В правой области дважды щелкните SystemPages.

  4. В поле Значение введите 0 и нажмите кнопку ОК.

  5. Закройте редактор реестра.

  6. Щелкните правой кнопкой мыши Мой компьютер и в контекстном меню выберите Свойства. Появится диалоговое окно Свойства системы.

  7. Щелкните Дополнительно.

  8. В области Загрузка и восстановление щелкните Параметры. Появится диалоговое окно Загрузка и восстановление.

  9. В области Загрузка операционной системы щелкните Изменить. В результате этих действий в «Блокноте» откроется файл Boot.ini операционной системы Windows.

  10. Ознакомьтесь с частью [Operating Systems] (Операционные системы).

    1. Если присутствует переключатель /3GB и нет переключателя /USERVA=3030, добавьте переключатель /USERVA=3030 в строку загрузки, чтобы она была настроена как /3GB /USERVA=3030.

    2. Если переключатели /3GB /USERVA=3030 уже настроены, измените значение переключателя /USERVA на /USERVA=2970.

  11. Сохраните изменения и закройте Блокнот.

  12. Нажмите два раза кнопку OK, чтобы закрыть открытые диалоговые окна, и затем перезапустите компьютер, чтобы изменения вступили в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт "Description of the Microsoft Windows Registry" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения об оптимизации памяти для сервера Exchange см. в следующих статьях базы знаний Майкрософт:

  • 894067, "The Performance tool does not accurately show the available Free System Page Table entries in Windows Server 2003" http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067 (Средство повышения производительности неточно показывает доступное количество свободных системных элементов таблицы страниц в Windows Server 2003)

  • 325044, "HOW TO: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044) (Инструкции по устранению проблем, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000)

  • 823150, "How to gather data to troubleshoot Exchange Server 2003 virtual memory issues" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823150) (Инструкции по сбору данных для устранения проблем виртуальной памяти в Exchange Server 2003)

  • 815372, "How to optimize memory usage in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372) (Инструкции по оптимизации использования памяти в Exchange Server 2003)

  • 311901, "The effects of 4GT tuning on System Page Table Entries" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901) (Влияние настройки 4GT на системные элементы таблицы страниц)


На сервере переднего плана выполняется служба репликации сайта
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-объект (Microsoft Windows® Management Instrumentation) (класс Exchange_Server), чтобы определить для сервера текущее значение объекта IsFrontEndServer. Если это значение равно «истина», сервер Exchange играет роль сервера переднего плана. Анализатор сервера Exchange также запрашивает WMI-объект MSExchangeSRS (класс Win32_Service), чтобы определить значение свойства Started (Запущено) этого объекта. Если это значение равно «истина», на данном сервере работает служба репликации сайта.

Если сервер Exchange предназначен для использования в качестве сервера переднего плана, и при этом на нем работает экземпляр службы репликации сайта, выводится предупреждение.

Exchange использует службу репликации сайта, если топология системы включает серверы Exchange Server 5.5 наряду с серверами Exchange 2000 Server или Exchange Server 2003. Эта служба позволяет более новым версиям Exchange реплицировать данные конфигурации сервера на серверы Exchange Server 5.5 в форме, совместимой с каталогом Exchange Server 5.5, а также правильно обрабатывать данные конфигурации, реплицированные из каталога Exchange Server 5.5, чтобы их можно было сохранить в службе каталогов Active Directory®. Если топология системы настроена так, чтобы использовать серверы переднего плана и фоновые серверы, служба репликации сайта должна работать только на фоновых серверах. Служба репликации сайта, входящая в пакет обновлений Exchange 2000 Server SP2, на серверах переднего плана работает неправильно и может вызывать проблемы.

Чтобы исправить эту проблему, преобразуйте внешний сервер в фоновый и настройте новый сервер переднего плана. Не рекомендуется пытаться удалить с сервера службу репликации сайта.

Устранение ошибки

  1. Настройте новый внешний сервер.

  2. На проблемном сервере переднего плана в системном диспетчере Exchange, в ветви Серверы щелкните правой кнопкой мыши проблемный сервер и выберите Свойства в контекстном меню.

  3. Снимите флажок Сервер переднего плана.

Дополнительные сведения о сервере переднего плана и службе репликации сайта см. в статье 313646 базы знаний Майкрософт, посвященной отключенным службам на серверах переднего плана после установки пакета обновлений Exchange 2000 Server SP2, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=313646 (возможно, на английском языке).


В папке «bin» отсутствует файл GAPI32.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить наличие нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (проверяется в папке System32 и в папке \Exchsrvr\bin),

  • Mapi32.dll (проверяется в папке System32 и в папке \Exchsrvr\bin),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange определяет, что отсутствует один или несколько файлов, отображается сообщение об ошибке. Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если это не устранит ошибку, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-значный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Файл GAPI32.DLL отсутствует в папке system32
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange Server запрашивает WMI-класс CIM_Datafile, чтобы определить наличие нескольких двоичных файлов ядра Exchange:

  • Exres.dll

  • Gapi32.dll (проверяется в папке System32 и в папке \Exchsrvr\bin)

  • Mapi32.dll (проверяется в папке System32 и в папке \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если анализатор сервера Exchange обнаружит, что отсутствует один или несколько файлов, отображается сообщение об ошибке. Чтобы устранить эту ошибку, установите последний пакет обновлений или накопительный пакет обновления для своей версии Exchange. Если это не приведет к устранению ошибки, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные настройки. Если сервер Exchange Server переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Осуществите вход на сервер, на котором требуется переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если вы согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификатор продукта введите свой 25-значный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, накопительных пакетах обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, накопительных пакетах обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Установлено значение параметра GlobalFlag
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующие разделы реестра, чтобы определить значение параметра GlobalFlag:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\MAD.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\INETINFO.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\EMSMTA.EXE

Если анализатор сервера Exchange обнаруживает значение GlobalFlag, не равное 0 или null, отображается предупреждение.

Значение параметра реестра GlobalFlag представляет собой битовую маску, определяющую, какие параметры отладки были включены для определенного процесса. В этом случае анализатор сервера Exchange проверяет, включены ли параметры отладки для некоторых компонентов Exchange:

  • STORE.EXE (процесс банка данных);

  • MAD.EXE (процесс системного помощника);

  • INETINFO.EXE (родительский и административный процесс IIS);

  • EMSMTA.EXE (процесс агента передачи сообщений).

Если администратор не занимается постоянно отладкой и отслеживанием проблемы с помощью служб поддержки продуктов Майкрософт, рекомендуется задать для параметра GlobalFlag постоянное значение 0 или вообще удалить этот параметр.

По умолчанию значение параметра реестра GlobalFlag не существует и должно быть добавлено вручную, если требуется отладка процесса STORE.EXE (или любого другого процесса). Можно использовать средство Gflags, входящее в состав средств поддержки Microsoft Windows Server™ 2003 (на диске Windows в папке \Support). Также можно вручную установить значение 0 или полностью удалить параметр GlobalFlag с помощью редактора реестра. Обе процедуры описаны в этой статье.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программы Regedit.exe или Regedt32.exe.

Чтобы устранить эту неисправность с помощью средства Gflags

  1. Нажмите кнопку Пуск, выберите команду Выполнить и в поле Открыть введите GFlags. Появится пользовательский интерфейс средства Global Flags.

  2. В поле Имя файла образа введите STORE.EXE.

  3. Выберите Параметры файла образа.

  4. Снимите все флажки и нажмите кнопку Применить.

  5. Повторите шаги 2-4 для каждого процесса Exchange, перечисленного в этой статье.

  6. Нажмите кнопку ОК, чтобы закрыть средство GFlags, и перезапустите соответствующие службы, чтобы изменения вступили в силу.

Чтобы исправить эту ошибку с помощью редактора реестра

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

  3. Удалите значение реестра GlobalFlag.

  4. Повторите шаги 2 и 3 для каждого процесса Exchange, перечисленного в этой статье.

  5. Закройте редактор реестра и перезапустите компьютер, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Происходит большое число сбоев при обновлении списка ACL.
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_PerfRawData_MSExchangeIS_MSExchangeIS, чтобы определить значение ключа ACLUpgradefailures. Ключ ACLUpgradefailures представляет счетчик производительности ACL Upgrade: failures объекта производительности MSExchangeIS.

Если анализатор сервера Exchange обнаруживает, что значение ключа ACLUpgradefailures больше 500, на экран выводится предупреждение.

Это предупреждение указывает, что север Exchange сообщил о многочисленных сбоях при обновлении списка ACL. Большое число сбоев при обновлении списка ACL может вызвать серьезные проблемы производительности, в частности, происходящие случайным образом остановки процесса банка данных (store.exe).

Сбои при обновлении списка ACL могут происходить по разным причинам, в частности, когда выполняются следующие условия:

  • При использовании организаций Exchange в смешанном режиме корректор согласованности на сервере Exchange Server 5.5 не был запущен перед реализацией сервера Active Directory Connector (ADC). Корректор согласованности на сервере Exchange Server 5.5 удаляет потерянные списки ACL.

  • Репликация службы каталогов Active Directory не работает должным образом.

  • Репликация службы каталогов Active Directory некорректно реплицирует учетные записи с сервера Exchange Server 5.5 в службу каталогов Active Directory.

  • Была некорректно выполнена миграция учетных записей.

Чтобы устранить причину появления этого предупреждения

  1. Посмотрите статью 812963 базы знаний Майкрософт об использовании раздела реестра «Ignore Zombie Users» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812963).

  2. После изучения последствий применения раздела реестра Ignore Zombie Users воспользуйтесь им по своему усмотрению.

  3. Запустите анализатор сервера Exchange или проследите за показаниями счетчика производительности ACL Upgrade: failures, чтобы обнаружить наличие частых сбоев при обновлении списка ACL.


Пользователь Exmon, проявляющий повышенную активность
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-04-21

Средство анализатора сервера Microsoft® Exchange использует средство наблюдения за пользователями Exchange Server (ExMon), чтобы определить, приходится ли на того или иного пользователя или процесс (или группу пользователей или процессов) непропорционально высокий процент текущей загрузки сервера.

Имеется несколько сценариев оценки ExMon:

  • Клиентские ограничения

  • Массовые операции удаленного вызова процедур (RPC)

  • Массовые операции синхронизации RPC

  • Большое количество клиентских интерактивных операций

  • Пользовательские операции по созданию представлений

В следующих разделах приводятся подробные сведения о действиях, которые рекомендуется выполнять для каждого из этих сценариев.

Клиентские ограничения

В этом сценарии данные ExMon по операциям RPC свидетельствуют, что ограничения, накладываемые на клиентские компьютеры, являются причиной высокой нагрузки на данный сервер. В контексте MAPI ограничение относится к операции MAPI, называемой Restrict. Эта операция используется для выбора элементов, отвечающих определенному критерию. Операция Restrict является частью процесса по запросу Exchange создать представление папки или набора папок (фактически, таблицы базы данных со связанным критерием). Если представление папки или набора папок уже имеет совпадающее ограничение, Exchange использует существующее представление для удовлетворения запроса пользователя. Если же представление не имеет совпадающего ограничения, Exchange создает новое представление. Создание представления является более дорогим, чем использование существующего представления.

После перемещения почтовых ящиков клиентские ограничения на короткое время становятся более дорогими. При выполнении операции move-mailbox сервер перестраивает индексы папок. Таким образом, когда клиенты впервые просматривают папки на новом сервере, все ограничения должны быть созданы заново. Поэтому производительность может значительно снизиться. Если же почтовые ящики в последнее время не перемещались, следует и исследовать следующие возможности:

  • Другое приложение MAPI установлено на клиентских компьютерах. Довольно часто надстройки Microsoft Office Outlook® или другие приложения MAPI могут привести к созданию слишком большого количества ограничений.

  • На почтовые ящики наложены соответствующие ограничения по размеру во всей организации.

Дополнительные сведения о размере почтового ящика и количестве элементов см. в блоге группы по Microsoft Exchange, посвященном этой теме (http://go.microsoft.com/fwlink/?linkid=55097).

Массовые операции RPC

Примерами массовых операций RPC являются свойства перемещения, удаления или настройки (то есть флаг чтения), применяемые к сотням или тысячам элементов в одной операции. Эти типы операций могут привести к существенному снижению производительности сервера в короткие интервалы времени. Если массовые операции RPC выполняются часто, и на сервере возникают узкие места на уровне диска или процессора, производительность Outlook, относящаяся к другим пользователям того же сервера, уменьшится.

Чтобы устранить эту ошибку

  1. Проверьте, что заданы предельные размеры почтового ящика.

  2. Рекомендуется, чтобы пользователи архивировали элементы в PST-файлы.

    Примечание.
    Общая рекомендация может состоять в том, чтобы в папках, которые часто используются, содержалось менее 5000 элементов.

Массовые операции синхронизации RPC

Массовые операции синхронизации RPC свидетельствую о том, многие пользователи в данный момент выполняют синхронизацию элементов. В результате этого возрастает загрузка сервера.

Чтобы устранить эту ошибку

  • Убедитесь, что серверы Exchange были масштабированы в соответствии с количеством клиентских компьютеров, на которых выполняется Outlook в режиме кэширования Exchange. Дополнительные сведения см. в документе, посвященном удаленному вызову процедур Exchange Server 2003 в сценариях развертывания HTTP (http://go.microsoft.com/fwlink/?LinkId=47577).

  • Замедление обработки клиентских запросов в режиме кэширования Exchange может помочь в устранении проблемы снижения производительности в связи с массовыми операциями синхронизации RPC. Дополнительные сведения см. в статье 818484 базы знаний Майкрософт, посвященной значений реестра и счетчиков производительности, которые можно использовать для настройки и отслеживания синхронизации клиентов Outlook (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=818484).

Большое количество клиентских интерактивных операций

Иногда в работе Exchange может возникнуть неожиданное значительное снижение производительности, вызванное высокой загрузкой, которая более или мене равномерно распределяется между пользователями. Это может быть обусловлено плохим планированием, при котором недостаточно учитывался фактор роста организации. Если при планировании учитывались рекомендации корпорации Майкрософт по масштабированию организации, однако производительность по-прежнему остается низкой в результате выполнения большого количества клиентских операций, это может свидетельствовать о том, что пользователи выполняют приложения MAPI или надстройки Outlook сторонних разработчиков.

Пользовательские операции по созданию представлений

Данные ExMon по операциям RPC свидетельствуют, что пользователь создает новые представления, который приводят к значительному возрастанию загрузки сервера. В этом сценарии на одного пользователя приходится значительный процент использования процессора для операций удаленного вызова процедур.

При исследовании этой проблемы рассмотрите следующие сценарии:

  • Пользователь может выполнять операции с папкой, содержащей много элементов. Чтобы устранить эту проблему, обяжите пользователей уменьшить количество элементов в каждой отдельной папке. Общая рекомендация может состоять в том, чтобы в папках содержалось менее 2000 элементов.

  • Пользователь может работать с плохо написанным приложением, что приводит к повышению загрузки сервера. Чтобы устранить эту проблему, удалите данное приложение.

Дополнительные сведения

  • Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Дополнительные сведения об устранении проблем, связанных с производительностью сервера Exchange, см. на веб-узле, посвященном устранению неполадок, связанных с производительностью сервера Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Дополнительные сведения о размере почтового ящика и количестве элементов см. в блоге группы по Microsoft Exchange, посвященном этой теме (http://go.microsoft.com/fwlink/?linkid=55097).

  • Дополнительные сведения об ограничениях на размер почтового ящика см. в блоге группы по Microsoft Exchange, посвященном этой теме (http://go.microsoft.com/fwlink/?LinkId=55098).

  • Дополнительные сведения об ExMon см. на веб-узле загрузки ExMon (http://go.microsoft.com/fwlink/?LinkId=54983).


Службы IIS создают 32-разрядные процессы на 64-разрядном компьютере
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-05-03

Анализатор Microsoft Exchange Server опрашивает метабазу IIS для получения значения свойства метабазы w3svc/AppPools/Enable32BitAppOnWin64 на всех серверах с 64-разрядной операционной системой Windows Server 2003 с пакетом обновления 1 (SP1), на которых установлен Exchange Server 2007, чтобы определить, настроены ли службы IIS на создание 32-разрядных рабочих процессов.

Значение 1 (истина) указывает на то, что службы IIS настроены на создание 32-разрядных рабочих процессов. Значение 0 (ложь) означает, что службы IIS настроены на создание 64-разрядных рабочих процессов.

Если анализатор Exchange определяет, что для свойства метабазы w3svc/AppPools/Enable32BitAppOnWin64 установлено значение 1 (истина), выводится сообщение об ошибке. Эта ошибка указывает на то, что службы IIS настроены на создание 32-разрядных рабочих процессов на сервере с 64-разрядной операционной системой Windows, на котором установлен Exchange Server 2007. Подобная конфигурация может привести к сбою работы виртуальных каталогов Exchange Server 2007.

Чтобы устранить эту ошибку, настройте службы IIS на создание 64-разрядных рабочих процессов на сервере с 64-разрядной операционной системой Windows Server 2003 с пакетом обновления 1 (SP1), на котором установлен Exchange Server 2007.

Переключение служб IIS в 64-разрядный режим

  1. Откройте окно командной строки.

  2. Введите следующую команду:

    cscript c:\inetpub\adminscripts\adsutil.vbs SET /w3svc/AppPools/Enable32BitAppOnWin64 False

  3. Нажмите клавишу ВВОД.

Дополнительные сведения о запуске 32-разрядных рабочих процессов служб IIS 6.0 на сервере с 64-разрядной операционной системой Windows Server 2003 с пакетом обновления 1 (SP1) см. в статье 895976 базы знаний Майкрософт «Windows Server 2003 с пакетом обновления 1 (SP1) обеспечивает совместимость WOW64 для 32-разрядных веб-приложений служб IIS 6.0» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=895976) (на английском языке).


Оптимизация памяти ядра
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server тестирует уровни памяти системы, чтобы проверить, не выходят ли они за рамки допустимых диапазонов. Если средство анализа Exchange Server обнаружит, что показания какого-либо из счетчиков памяти ядра в системном мониторе находятся ниже приемлемого уровня, он выдаст сообщение о необходимости устранения неполадки.

В памяти ядра Microsoft Windows® имеется несколько структур памяти, в том числе выгружаемые и невыгружаемые пулы памяти и элементы таблицы страниц. Эти структуры, которые также считаются памятью ядра, используются операционной системой для предоставления среды для таких приложений, как Exchange. Для корректного развертывания Exchange необходим контроль памяти ядра.

Оптимизация памяти ядра может быть сложной задачей. Для получения подробных сведений об использовании памяти ядра, в том числе и сведений об устранении неполадок, см. статью «Устранение неполадок в работе Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=47588). Одна из возможностей высвободить ресурсы сервера заключается в нагрузке на почтовые ящики пользователей на сервере. Попробуйте перенести почтовые ящики пользователей на другой сервер, чтобы снизить нагрузку на сервер, и, возможно, проблема будет решена. Для получения дополнительных сведений см. раздел Перенос почтовых ящиков пользователей на другой сервер.

Дополнительные сведения

Для получения дополнительных сведений о производительности сервера Exchange см. Руководство по производительности и масштабируемости Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

Для получения дополнительных сведений о переносе почтовых ящиков пользователей для сокращения нагрузки на сервер см. раздел Перенос почтовых ящиков пользователей на другой сервер


Улучшение пользовательской памяти
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-04-28

Средство анализатора сервера Microsoft® Exchange определило, что счетчики производительности памяти пользователя превысили порог работоспособности сервера Exchange. Анализатор сервера Exchange опрашивает счетчик производительности Доступно МБ, затем счетчик ??Страницы памяти/сек?? в объекте производительности Память. Если на сервере недостаточно памяти или размер страницы подкачки слишком высокий, это указывает на узкое место в работе памяти.

Счетчик производительности Доступно МБ показывает количество физической памяти в мегабайтах (МБ), доступное в настоящий момент для выделения процессам или системе. Количество доступной памяти равно общему количеству памяти, выделенной для кэша, свободной памяти и обнуленных страниц памяти.

Счетчик производительности Страницы памяти/cек указывает скорость чтения и записи страниц на диск для разрешения серьезных сбоев страниц. В то время как сервер использует память и начинает недоставать свободной памяти, операционная система начинает сокращать работающий набор процессов и более активно использовать файл подкачки. Использование файла подкачки влияет на общую производительность, так как операции с диском занимают больше времени, чем операции с памятью. Этот счетчик является основным указателем типов сбоев, которые приводят к задержкам во всей системе. Он показывает количество полученных страниц для компенсации сбоев страниц в кэше файловой системы. Эти страницы обычно требуются приложениями. Значение этого счетчика не должно превышать 1000 в любое время.

Если анализатор сервера Exchange обнаружит, что счетчик производительности Доступно МБ указывает, что доступно менее 50 МБ памяти при количестве страниц памяти, считываемых с диска или записываемых на диск, превышающем 1000 страниц в секунду, анализатор сервера Exchange отображает сообщение об ошибке.

В следующем списке описано, как улучшить производительность пользовательской памяти.

Чтобы устранить эту проблему

  1. Воспользуйтесь рекомендациями по работе с анализатором сервера Microsoft Exchange, чтобы проверить правильность настройки параметров памяти на сервере (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=34705).

  2. Удалите ненужное программное обеспечение. Чтобы предоставить Exchange больше ресурсов памяти, удалите сторонние программные средства, которые выполняют функции наблюдения, или любые типы необязательных служб. Оснастка «Производительность» (Perfmon.msc) поможет узнать, сколько памяти используется приложениями.

  3. Выполняйте задачи обслуживания сервера в часы внепиковой нагрузки. Для выполнения средств обслуживания (например, Eseutil) или задач (например, управление почтовыми ящиками) во время пиковой нагрузки может потребоваться память, которая могла бы использоваться процессами Exchange. Рекомендуется работать с этими средствами и задачами в часы внепиковой нагрузки или в периоды наименьшего использования сервера.

  4. Рассмотрите возможность перемещения почтовых ящиков пользователей с этого сервера на другой сервер, чтобы уменьшить нагрузку на сервер. Дополнительные сведения см. в разделе Перенос почтовых ящиков пользователей на другой сервер.

Дополнительные сведения

Дополнительные сведения см. на следующих ресурсах корпорации Майкрософт:

  • Перенос почтовых ящиков пользователей на другой сервер

  • веб-страница, посвященная устранению неполадок, связанных с производительностью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588);

  • статья, посвященная оптимизации использования памяти в Exchange Server 2003, в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576);

  • рекомендации по использованию средства анализатора сервера Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=34705);

  • статья 815372 базы знаний Майкрософт, описывающая оптимизацию использования памяти в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372);

  • статья, посвященная изменению конфигурации памяти Exchange 2003 для Windows 2003 (поддержка PAE) (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=54979).

    Примечание.
    Содержимое и URL-адрес каждого блога могут изменяться без предварительного уведомления.


Улучшение виртуальной памяти
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange определило, что на сервере имеются проблемы фрагментации виртуальной памяти.

В 32-разрядных системах Microsoft Windows® существует два вида памяти:

  • Физическая память — объем фактической памяти, установленной в системе.

  • Адресное пространство виртуальной памяти — пространство виртуальной памяти объемом 4 ГБ.

Независимо от объема физической памяти, установленной в системе, общий размер виртуального адресного пространства всегда один и тот же: 4 ГБ. В случае сервера Exchange виртуальное адресное пространство равно виртуальной памяти, хотя это положение не выполняется для всех 32-разрядных приложений. Эти термины взаимозаменяют друг друга.

Во время обычного хода выполнения операций хранилище Exchange многократно выделяет, использует и освобождает виртуальную память. При выделении, использовании и освобождении виртуальной памяти может происходить фрагментация виртуальной памяти. Фрагментация виртуальной памяти сходна с фрагментацией файловой системы, которая может происходить со временем. По истечении некоторого времени выделяемые сегменты виртуальной памяти больше не являются непрерывными, и производительность начинает ухудшаться. В случае файловой системы можно запустить приложение, которое выполнит дефрагментацию файловой системы. В большинстве случаев дефрагментация может выполняться в то время, когда система находится в оперативном режиме и к ней осуществляется доступ. В случае фрагментации виртуальной памяти не существует средства дефрагментации. Вместо этого для устранения проблемы необходимо остановить и запустить службу «Банк данных Microsoft Exchange» или перезапустить систему.

Причиной фрагментации виртуальной памяти может быть программное обеспечение сторонней компании, которое запускается в процессах store/inetinfo. Проверьте, чтобы использовались последние версии драйверов для всех приложений сторонних компаний. Если проблема остается после перезапуска, рассмотрите возможность отключения программного обеспечения сторонних компаний или перемещения почтовых ящиков пользователей на другой сервер для уменьшения нагрузки на сервер, и проверьте, будет ли устранена проблема в результате этих действий. Дополнительные сведения см. по ссылке Перенос почтовых ящиков пользователей на другой сервер.

Дополнительные сведения

  • Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Дополнительные сведения об устранении проблем производительности сервера Exchange см. в описании процедур устранения неполадок, связанных с производительностью Microsoft Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Дополнительные сведения об устранении проблем, связанных с фрагментацией виртуальной памяти в Microsoft Exchange Server 2003 и Exchange 2000 Server, см. в базе знаний Майкрософт в статье 325044, содержащей инструкции по устранению неполадок, вызванных фрагментацией виртуальной памяти в Exchange Server 2003 и Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044).

  • Дополнительные сведения об оптимизации использования виртуальной памяти см. в базе знаний Майкрософт в статье 815372, описывающей оптимизацию использования памяти в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372).

  • Дополнительные сведения о переносе почтовых ящиков пользователей для снижения нагрузки на сервер см. по ссылке Перенос почтовых ящиков пользователей на другой сервер.


Интеллектуальный фильтр сообщений не установлен на одном или нескольких серверах, на которых работает Exchange Server 2003
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchExchangeServer для каждого объекта Exchange Server в организации. Анализатор сервера Exchange использует результаты этого запроса, чтобы определить общее количество серверов в организации, на которых работает Exchange Server 2003. Анализатор также опрашивает WMI-класс CIM_Datafile , чтобы определить, установлен ли интеллектуальный фильтр сообщений на всех серверах Exchange Server 2003 в организации. Если анализатор сервера Exchange обнаружит, что интеллектуальный фильтр сообщений не установлен на одном или нескольких серверах, на которых работает Exchange Server 2003, анализатор сервера Exchange выведет на экран сообщение с рекомендацией.

Интеллектуальный фильтр сообщений определяет сообщения, которые, скорее всего, являются нежелательными. В обычной топологии Exchange Server 2003, интеллектуальный фильтр сообщений установлен на серверах-шлюзах, которые фильтруют входящие сообщения электронной почты из Интернета. Если в качестве сервера-шлюза используется система электронной почты, не принадлежащая корпорации Майкрософт, необходимо установить интеллектуальный фильтр сообщений на сервер-плацдарм Exchange, который будет принимать внешние входящие сообщения электронной почты от серверов-шлюзов.

Чтобы установить интеллектуальный фильтр сообщений, используйте учетную запись, которая обладает правами локального администратора и является членом группы, которая обладает ролью администраторов Exchange.

Дополнительные сведения см. на веб-узле, посвященном интеллектуальному фильтру сообщений Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=21607).


Доступно обновление ISA Server 2000
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить версию файла smtpfltr.dll, который используется возможностью блокировки сообщений SMTP в ISA Server 2000. Если анализатор сервера Exchange обнаруживает, что версия датируется ранее 2004 года, выводится предупреждение.

Это предупреждение означает, что доступна более новая версия ISA Server 2000. Рекомендуется установить ISA Server 2000 с пакетом обновления 2. Обновление с помощью пакета обновления 2 особенно важно, если выполняется возможность блокировки сообщений SMTP. Более ранние версии блокировки сообщений SMTP образуют узкое место и соответственно снижают общую производительность обработки сообщений.

Чтобы устранить причину появления этого предупреждения

  1. Загрузитье ISA Server 2000 с пакетом обновления 2 с центра загрузки корпорации Майкрософт (http://go.microsoft.com/fwlink/?linkid=37592).

  2. Изучите заметки о выпуске для пакета обносления 2 (http://go.microsoft.com/fwlink/?linkid=37584).

  3. Установите пакет обновления 2 с помощью инструкций, приведенных в этих заметках о выпуске.

Дополнительные сведения о загрузке ISA Server, в том числе ISA Server 2000 с пакетом обновления 2, смю в документе «ISA Server 2000 Downloads» (http://go.microsoft.com/fwlink/?LinkId=18919) (Загрузка ISA Server 2000).


Получатель журнала недействителен
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-03-27

Анализатор рекомендаций Microsoft® Exchange Server запрашивает службу каталогов Active Directory®, чтобы определить, что значение для свойства mailNickname на объекте получателя журнала действительно. Чтобы свойство mailNickname было действительно, должен быть установлен псевдоним. Если свойство mailNickname для назначенного объекта получателя журнала недействительно, запись сообщений в журнал будет ставиться в очередь. Кроме того, недействительный mailNickname может означать, что ведение журнала было настроено таким образом, чтобы копировать запись сообщений в журнал в объект получателя, который является отключенным почтовым ящиком. Если анализатор рекомендаций Exchange Server обнаруживает, что значение свойства mailNickname для объекта получателя журнала недействительно, анализатор Exchange Server выводит сообщение об ошибке.

Для устранения этой ошибки в Exchange Server 2003 используйте оснастку «Пользователи и компьютеры Active Directory» и диспетчер Exchange, чтобы при необходимости выполнить следующие действия.

  • Включить почтовый ящик для объекта получателя журнала.

  • Указать почтовый ящик нового пользователя как получателя журнала.

Для устранения этой ошибки в Exchange Server 2003 используйте оснастку «Пользователи и компьютеры Active Directory» и диспетчер Exchange, чтобы при необходимости выполнить следующие действия.

Включение почтового ящика объекта получателя журнала для Exchange Server 2003

  1. Откройте оснастку «Active Directory — пользователи и компьютеры»

  2. Разверните домен в дереве консоли.

  3. Перейдите к родительскому контейнеру того получателя, который требуется изменить.

  4. В области сведений щелкните правой кнопкой получателя, которого необходимо изменить, и выберите Задачи Exchange.

  5. В Мастере задач Exchange в диалоговом окне Доступные задачи выберите Создать почтовый ящик и нажмите кнопку Далее.

  6. В диалоговом окне Создать почтовый ящик подтвердите информацию для полей Псевдоним, Хранилище и Сервер почтового ящика и нажмите кнопку Далее.

  7. Щелкните Готово, чтобы закрыть Мастер задач Exchange.
Определение нового почтового ящика пользователя как получателя журнала в Exchange Server 2003

  1. Запустите Диспетчер Exchange.

  2. Последовательно разверните Серверы, <ваш сервер Exchange>, <группа хранения>, затем щелкните правой кнопкой хранилище почтового ящика и выберите Свойства.

  3. Щелкните Обзор справа от текста Архивировать все сообщения, отправленные или полученные почтовыми ящиками в этом хранилище, чтобы указать почтовый ящик в качестве почтового ящика службы ведения журнала.

    Примечание.
    Все записанные в журнал сообщения отправителям в этом хранилище почтового ящика отправляются в почтовый ящик, который был указан.

Для устранения этой ошибки в Exchange Server 2007 используйте консоль управления Exchange или командную консоль Exchange, чтобы при необходимости выполнить следующие действия.

  • Создайте почтовый ящик для объекта получателя журнала.

  • Назначьте почтовый ящик нового пользователя в качестве получателя журнала.

Включение почтового ящика объекта получателя журнала для Exchange Server 2007 с помощью консоли управления Exchange

  1. В консоли управления Exchange разверните Конфигурация получателя, щелкните правой кнопкой объект «Почтовый ящик», а затем выберите Создать почтовый ящик, чтобы запустить Мастер создания почтового ящика.

  2. В окне Введение выберите «Почтовый ящик пользователя» и нажмите кнопку Далее.

  3. В окне Тип пользователя выберите Существующий пользователь и с помощью кнопки «Обзор» выберите объект получателя журнала, чтобы создать для него почтовый ящик.

  4. В окне Параметры почтового ящика подтвердите сведения Псевдоним, Сервер, Группа хранения и База данных почтового ящика и затем щелкните Далее.

  5. В окне Создать почтовый ящик щелкните Создать, чтобы создать почтовый ящик для объекта получателя журнала.

  6. Щелкните Готово, чтобы завершить работу мастера создания почтового ящика
Включение почтового ящика объекта получателя журнала для Exchange Server 2007 с помощью командной консоли Exchange

  1. Следуйте указаниям в статье «Enable-Mailbox» (http://go.microsoft.com/fwlink/?LinkId=80827) документации на сервер Exchange Server 2007 (на английском языке).

Определение нового почтового ящика пользователя в качестве получателя журнала в Exchange Server 2007

  1. На консоли управления Exchange разверните Конфигурация сервера, <сервер Exchange>, <группа хранения>, щелкните правой кнопкой базу данных почтового ящика и затем выберите Свойства.

  2. На вкладке Общие в разделе Получатель журнала щелкните Обзор и укажите почтовый ящик в качестве получателя журнала.

Дополнительные сведения о развертывании решения по ведению журналов для Exchange Server 2003 см. в статье Journaling with Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47581) (Ведение журналов на сервере Exchange Server).

Дополнительные сведения о развертывании решения по ведению журналов для Exchange Server 2007 см. в статье Overview of Journaling (http://go.microsoft.com/fwlink/?LinkId=80820) (Обзор ведения журналов).


Получатель службы ведения журнала указывает на удаленный объект
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-02-01

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить содержит ли значение атрибута msExchMessageJournalRecipient строку DEL:. Этот атрибут указывает, что ведение журнала настроено для копирования сообщений в почтовый ящик, который был удален. Чтобы ведение журнала функционировало правильно, должен существовать допустимый почтовый ящик получателя службы ведения журнала, в который отправляются скопированные сообщения. Атрибут msExchMessageJournalRecipient устанавливается, когда ведение журнала включено для базы данных почтовых ящиков. Этот атрибут является атрибутом базы данных почтовых ящиков и содержит различающееся имя почтового ящика службы ведения журнала.

Если почтовый ящик получателя службы ведения журнала удален, сообщения службы ведения журнала будут отправляться в очередь. Если анализатор сервера Exchange обнаружит, что значение атрибута msExchMessageJournalRecipient содержит строку DEL:, анализатор сервера Exchange выведет на экран сообщение об ошибке.

Для исправления этой ошибки используйте диспетчер Exchange или консоль управления Exchange, чтобы определить в качестве получателя журнала новый почтовый ящик.

Определение нового почтового ящика пользователя как получателя журнала в Exchange Server 2003

  1. Откройте Системный диспетчер Exchange.

  2. Разверните узел Серверы, разверните <свой сервер Exchange>, разверните <группу хранения>, а затем щелкните правой кнопкой хранилище почтовых ящиков и выберите в контекстном меню пункт Свойства.

  3. Щелкните Обзор справа от текста Архивировать все сообщения, отправленные или полученные почтовыми ящиками в этом хранилище, чтобы указать почтовый ящик в качестве почтового ящика службы ведения журнала.

    Примечание.
    Все регистрируемые в журнале сообщения для отправителей в этом хранилище почтовых ящиков отправляются в указанный почтовый ящик.
Определение нового почтового ящика пользователя как получателя журнала в Exchange Server 2007

  1. На консоли управления Exchange последовательно разверните пункты Конфигуркция сервера, <сервер Exchange>, <группа хранения>, щелкните правой кнопкой базу данных почтового ящика и выберите Свойства.

  2. На вкладке Общие в разделе Получатель журнала, щелкните Обзор и укажите почтовый ящик в качестве получателя журнала.

Дополнительные сведения о развертывании решения по ведению журналов для Exchange Server 2003 см. в статье Journaling with Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47581) (Ведение журналов на сервере Exchange Server).

Дополнительные сведения о развертывании решения по ведению журналов для Exchange Server 2007 см. в статье Overview of Journaling (http://go.microsoft.com/fwlink/?LinkId=80820) (Обзор ведения журналов).


Получатель журнала указывает на отключенную учетную запись
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-09

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, не установлено ли значение атрибута msExchUserAccountControl объекта получателя журнала так, чтобы указывать на отключенную учетную запись пользователя. Значение атрибута msExchUserAccountControl объекта получателя журнала, равное 2, указывает, что журнал был настроен так, чтобы копировать сообщения журнала в отключенную учетную запись пользователя. Эта конфигурация может вызвать постановку сообщений журнала в очередь или их отправку в папку нежелательных сообщений. Если анализатор сервера Exchange обнаруживает, что значение атрибута msExchUserAccountControl получателя журнала указывает на отключенную пользовательскую учетную запись получателя журнала, анализатор сервера Exchange выводит сообщение об ошибке.

Для устранения этой ошибки в Exchange Server 2003 используйте оснастку «Пользователи и компьютеры Active Directory» и диспетчер Exchange, чтобы при необходимости выполнить следующие действия.

  • Включите пользовательскую учетную запись текущего получателя журнала.

  • Назначьте в качестве получателя журнала новый почтовый ящик пользователя.

Для включения учетной записи получения журнала в Exchange Server 2003 выполните следующие действия.

  1. Откройте оснастку «Active Directory — пользователи и компьютеры».

  2. В дереве консоли разверните узел домена.

  3. Перейдите в родительский контейнер получателя журнала, настройки которого нужно изменить.

  4. В области сведений щелкните правой кнопкой и в контекстном меню выберите Включить учетную запись.
Чтобы указать новый почтовый ящик в качестве получателя журнала в Exchange Server 2003, выполните следующие действия.

  1. Откройте Системный диспетчер Exchange.

  2. Разверните узел Серверы, разверните <нужный_сервер_Exchange>, разверните <группу_хранения>, щелкните правой кнопкой мыши хранилище почтовых ящиков и выберите Свойства.

  3. Нажмите кнопку Обзор справа от текста Архивировать все сообщения, отправленные или полученные почтовыми ящиками в этом хранилище, чтобы указать почтовый ящик в качестве почтового ящика ведения журнала.

    Примечание.
    Все сообщения ведения журналов для отправителей в этом хранилище почтовых ящиков будут отправляться на этот почтовый ящик.

Для устранения этой ошибки в Exchange Server 2007 используйте консоль управления Exchange или командную консоль Exchange, чтобы при необходимости выполнить следующие действия.

  • Создайте почтовый ящик для объекта получателя журнала.

  • Укажите новый почтовый ящик в качестве получателя журнала.

Для включения почтового ящика получателя журнала в Exchange Server 2007 c помощью консоли управления Exchange выполните следующие действия.

  1. В консоли управления Exchange разверните Конфигурация получателя, щелкните правой кнопкой объект почтового ящика, затем выберите Создать почтовый ящик, чтобы запустить мастер создания почтового ящика.

  2. На странице Введение выберите «Почтовый ящик пользователя» и нажмите кнопку Далее.

  3. В окне Тип пользователя выберите Существующий пользователь и нажмите кнопку «Обзор», чтобы выбрать получателя журнала для создания почтового ящика.

  4. В окне Параметры почтового ящика проверьте данные в полях Псевдоним, Сервер, Группа хранения и База данных почтовых ящиков, затем нажмите кнопку Далее.

  5. В окне Создать почтовый ящик нажмите кнопку Создать, чтобы создать почтовый ящик для получателя журнала.

  6. Нажмите кнопку Готово, чтобы закрыть мастер создания почтового ящика.
Для включения почтового ящика получателя журнала в Exchange Server 2007 с помощью командной консоли Exchange выполните следующие действия.

  1. Следуйте указаниям в документации Exchange Server 2007 в статье «Enable-Mailbox» (http://go.microsoft.com/fwlink/?LinkId=80827).

Чтобы указать новый почтовый ящик в качестве получателя журнала в Exchange Server 2007, выполните следующие действия.

  1. В консоли управления Exchange разверните Конфигурация сервера, <нужный сервер Exchange>, <группа хранения>, щелкните правой кнопкой мыши базу данных почтового ящика и выберите Свойства.

  2. На вкладке Общие в разделе Получатель журнала нажмите кнопку Обзор, чтобы выбрать почтовый ящик для использования в качестве получателя журнала.

Дополнительные сведения о развертывании решения по ведению журналов для Exchange Server 2003 см. в статье Journaling with Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47581) (Ведение журналов на сервере Exchange Server).

Дополнительные сведения о развертывании решения по ведению журналов для Exchange Server 2007 см. в статье Overview of Journaling (http://go.microsoft.com/fwlink/?LinkID=80820) (Обзор ведения журналов).


Ведение журнала по точкам получателя на локальном сервере
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-09

Средство анализатора сервера Microsoft® Exchange Server запрашивает службу каталогов Active Directory®, чтобы определить, совпадает ли значение атрибутаmsExchHomeServerName на объекте получателя, по которому ведется журнал, для хранилища почтовых ящиков со значением атрибута legacyExchangeDN для локального сервера. Если значения этих атрибутов совпадают, это указывает на то, что регистрируемые в журнале сообщения скопированы в почтовый ящик на сервере, который активизирован и выполняет операции по ведению журнала. Из-за большого возможного объема трафика ведения журнала рекомендуется, чтобы почтовый ящик получателя журнала располагался на специальном сервере для ведения журнала.

Если анализатор сервера Exchange обнаруживает, что значения атрибута msExchHomeServerName для ведения журнала по объекту получателя совпадают со значением legacyExchangeDN локального сервера, анализатор сервера Exchange выводит на экран сообщение с рекомендациями.

Дополнительные сведения о развертывании решения по ведению журналов для Exchange Server 2003 см. в статье Journaling with Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47581) (Ведение журналов на сервере Exchange Server).

Дополнительные сведения о развертывании решения по ведению журналов для Exchange Server 2007 см. в статье Overview of Journaling (http://go.microsoft.com/fwlink/?LinkId=80820) (Обзор ведения журналов).


Получатель ведения журналов должен быть скрытым
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-09

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, установлено ли значение True для атрибута msExchHideFromAddressLists объекта получателей ведения журналов. Значение этого атрибута, отличающееся от True, указывает, что получатель ведения журналов для хранилища почтовых ящиков не является скрытым в списках адресов Exchange Server и может стать получателем сообщений, не относящихся к ведению журналов. Если анализатор сервера Exchange обнаруживает, что значения атрибута msExchHideFromAddressLists для ведения журналов не установлено как True, анализатор сервера Exchange выводит на экран сообщение с рекомендациями.

Для устранения этой проблемы в Exchange Server 2003 используйте оснастку пользователей и компьютеров Active Directory, чтобы скрыть почтовый ящик получателя журнала из списков адресов Exchange Server.

Для устранения этой проблемы в Exchange Server 2007 используйте консоль управления Exchange, чтобы скрыть почтовый ящик получателя журнала из списков адресов Exchange Server.

Чтобы скрыть почтовый ящик получателя журнала из списков адресов Exchange Server 2003, выполните следующие действия.

  1. Откройте оснастку «Active Directory — пользователи и компьютеры»

  2. В дереве консоли разверните домен.

  3. Перейдите в родительский контейнер получателя, которого следует изменить.

  4. В области результатов дважды щелкните необходимого получателя.

  5. На вкладке «Exchange: дополнительно» установите флажок Скрыть из списков адресов Exchange.

  6. Нажмите кнопку ОК.
Чтобы скрыть почтовый ящик получателя журнала из списков адресов Exchange Server 2007, выполните следующие действия.

  1. Откройте консоль управления Exchange

  2. В дереве консоли перейдите к родительскому контейнеру получателя, которого требуется изменить.

  3. В области сведений дважды щелкните почтовый ящик нужного получателя журнала для отображения его свойств.

  4. На вкладке Общие установите флажок Скрыть из списков адресов Exchange.

  5. Нажмите кнопку ОК.

Дополнительные сведения о развертывании решения по ведению журналов для Exchange Server 2003 см. в статье Journaling with Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47581) (Ведение журналов на сервере Exchange Server).

Дополнительные сведения о развертывании решения по ведению журналов для Exchange Server 2007 см. в статье Overview of Journaling (http://go.microsoft.com/fwlink/?LinkId=80820) (Обзор ведения журналов).


Junk store threshold not configured
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-07-30

Анализатор Microsoft Exchange запрашивает у среды Exchange сведения о наличии в ней ролей транспортного сервера-концентратора или сервера почтовых ящиков Exchange Server 2007.

При обнаружении одной из этих ролей анализатор Exchange выполняет следующий командлет командной консоли Exchange, запрашивая значение параметра SCLJunkThreshold для организации Exchange:

Get-OrganizationConfig

Параметр SCLJunkThreshold определяет для организации вероятность нежелательной почты, при которой сообщение перемещается в папку нежелательной почты.

Если анализатор Exchange выясняет, что параметр SCLJunkThreshold для оpганизации имеет значение по умолчанию 8, он выводит предупреждение.

Оно свидетельствует о том, что пороговое значение вероятности нежелательной почты, при котором сообщения перемещаются в папку нежелательной почты, настроено так, что в папку нежелательной почты могут быть помещены сообщения, полученные от легальных пользователей. Параметру SCLJunkThreshold рекомендуется присвоить значение 4.

Чтобы устранить причину появления данного предупреждения, присвойте параметру SCLJunkThreshold значение 4 с помощью командлета Set-OrganizationConfig в командной консоли Exchange.

Присвоение значения 4 параметру SCLJunkThreshold с помощью командлета Set-OrganizationConfig

  1. Ниже приведен пример команды Set-OrganizationConfig, присваивающей параметру SCLJunkThreshold значение 4.

  2. Set-OrganizationConfig -SCLJunkThreshold 4


Истощение памяти ядра
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-02-15

Средство анализа Microsoft Exchange запрашивает класс WMI Win32_NTLogEvent для определения того, была ли в течение последних 24 часов зарегистрирована ошибка 2000, 2019 или 2020 для источника SRV (сервер) или сервера NCP.

  • Событие SRV (сервер) с идентификатором 2000 свидетельствует о том, что при вызове сервером системной службы произошел непредвиденный сбой из-за истощения общей системной памяти ядра.

  • Событие SRV с идентификатором 2019 свидетельствует об истощении системной памяти в невыгружаемом пуле.

  • Событие SRV с идентификатором 2020 свидетельствует об истощении системной памяти в выгружаемом пуле.

Если анализатор Exchange обнаружит, что хотя бы одно из этих событий было зарегистрировано в течение последних 24 часов, он отобразит сообщение об ошибке.

Данное сообщение свидетельствует об истощении памяти ядра на сервере и возможном снижении производительности сервера.

В памяти ядра Microsoft Windows имеется несколько структур памяти, в том числе выгружаемые и невыгружаемые пулы памяти и элементы таблицы системных страниц. Эти структуры, которые также считаются памятью ядра, используются операционной системой для предоставления среды для таких приложений, как Exchange.

Для устранения указанной проблемы воспользуйтесь рекомендациями, приведенными в указанных ниже статьях о средстве анализа Exchange.

  • Оптимизация памяти ядра

  • Размер выгружаемого пула превысил порог предупреждения

  • Невыгружаемый пул превысил пороговое значение для вывода предупреждения

  • Размер невыгружаемого пула превышает порог ошибки

Обычно для обеспечения корректной работы сервера Exchange Server необходимо регулярно проверять использование памяти его ядра.

Дополнительные сведения

Дополнительные сведения о событиях SRV 2000, 2019 и 2020 см. на странице «Центр сообщений о событиях и ошибках: сведения о событиях».

  • Событие SRV с идентификатором 2000: http://go.microsoft.com/fwlink/?LinkId=83250 (на английском языке).

  • Событие SRV с идентификатором 2019: http://go.microsoft.com/fwlink/?LinkId=83251 (на английском языке).

  • Событие SRV с идентификатором 2020: http://go.microsoft.com/fwlink/?LinkId=83252 (на английском языке).

Дополнительные сведения об оптимизации использования памяти для Exchange Server см. в следующих статьях базы знаний Майкрософт:

  • 912376, «Наблюдение за использованием памяти из выгружаемого пула и устранение связанных с этим неполадок в Exchange Server 2003 и Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=912376, на английском языке).

  • 815372, «Оптимизация использования памяти в Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372).

  • 894067, «Средство контроля производительности выводит неверные сведения о свободных элементах системной таблицы страниц в Windows Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067, на английском языке).

  • 311901, «Воздействие настройки 4GT на элементы системной таблицы страниц» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901, на английском языке).

  • 912376, «Наблюдение за использованием памяти из выгружаемого пула и устранение связанных с этим неполадок в Exchange Server 2003 и Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=912376, на английском языке).


Исчерпание ресурсов ядра: обновление службы теневого копирования томов
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-02-13

Средство анализатора сервера Microsoft® Exchange опрашивает WMI-класс CIM_Datafile, чтобы проверить, существует ли файл Vssvc.exe.

Анализатор сервера Exchange запрашивает реестр, чтобы определить, работает ли на сервере Windows служба теневого копирования томов (VSS) или служба виртуальных дисков (VDS):

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VSS

Кроме того, анализатор сервера Exchange считывает следующее значение реестра, чтобы определить, какая версия операционной системы Microsoft Windows® работает на сервере Exchange:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Если значение параметра CurrentVersion равно 5.0, на сервере Exchange используется операционная система Microsoft Windows 2000 Server. Если значение CurrentVersion равно 5.2, на сервере Exchange используется операционная система Microsoft Windows Server™ 2003.

В последнюю очередь анализатор сервера Exchange Server запрашивает WMI-класс Win32_OperatingSystem, чтобы определить значение ключа ServicePackMajorVersion. Значение ключа ServicePackMajorVersion показывает, какой пакет обновлений Windows установлен на компьютере.

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Сервер Exchange установлен на сервере с операционной системой Windows Server 2003 и пакетом обновлений SP1.

  • На сервере с операционной системой Windows Server 2003 и пакетом обновлений SP1 работает служба теневого копирования томов или служба виртуальных дисков.

  • В этой конфигурации сервера Exchange не установлено обновление службы теневого копирования томов.

Если установить обновление службы теневого копирования томов, проблемы, подобные исчерпанию ресурсов ядра, будут решены.

Исправление ошибки

  • Установите обновление службы теневого копирования томов, которое можно загрузить с веб-страницы статьи 891957 базы знаний Майкрософт, описывающей доступное обновление, исправляющее проблемы службы теневого копирования томов Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=891957).

Сведения о рекомендациях по использованию службы теневого копирования томов с приложением Exchange Server 2003 см. в рекомендациях по использованию службы теневого копирования томов с приложением Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=56571).


Установлен LeakDiag
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server считывает следующий параметр реестра, чтобы определить, установлен ли на компьютере LeakDiag.exe:

HKEY_LOCAL_MACHINE\Software\Microsoft\LeakDiag

Если средство анализа Exchange Server обнаружит, что данная ветвь реестра существует, появится сообщение о том, что настройка отлична от настройки по умолчанию.

LeakDiag — это набор средств, помогающих разработчикам, специалистам группы поддержки и работникам информационных отделов диагностировать утечки памяти, фрагментацию и прочие связанные с памятью проблемы в приложениях и службах на компьютерах, работающих под управлением Microsoft Windows NT® Server 4.0, Windows® 2000 Server, Windows XP или Windows Server™ 2003.

Средства LeakDiag можно использовать для того, чтобы проследить утечки памяти вплоть до уровня строки кода. Используя технологию Detours от Майкрософт, LeakDiag перехватывает обращения к указанным ячейкам памяти и отслеживает различные стеки вызовов. Он сообщает о тех участках памяти, которые были выделены, но еще не освобождены. Эта информация позволяет устранять утечки памяти и точно обнаруживать, какие компоненты выполняли выделение памяти. При правильных отладочных символах можно отследить даже строку кода, в которой запрашивается выделение памяти.

Не рекомендуется запускать LeakDiag на серверах Exchange, работающих в производственной среде. Если LeakDiag включен, он будет отслеживать все выделения памяти для всех процессов при каждом запуске сервера Exchange. На это потребуется значительное количество ресурсов процессора и памяти, поэтому это рекомендуется только в случаях, когда идет активное решение проблем, связанных с памятью. Во всех остальных случаях следует отключить LeakDiag. Запуск LeakDiag на сервере Exchange в производственной среде может привести к фрагментации и исчерпанию ресурсов памяти — и в конечном итоге к сбою в работе Exchange.

Примечание.
Устранять неполадки при помощи LeakDiag следует в часы, когда загрузка минимальна. Использование LeakDiag во время высокой или максимальной загрузки может привести к значительному снижению производительности компьютера Exchange Server.

Информация о сообщении

  1. Данное сообщение выдается только для сведения. Если LeakDiag не включен и не запущен, простой факт его установки не влияет на производительность сервера Exchange. Однако LeakDiag занимает 4 Мбайт дискового пространства (не включая файлы журналов).

  2. Чтобы освободить место на жестком диске, можно удалить LeakDiag.exe следующим образом: открыть Панель управления, щелкнуть Установка и удаление программ, щелкнуть LeakDiag и нажать кнопку Удалить.

Последнюю версию LeakDiag можно найти на общедоступном узле FTP корпорации Майкрософт (http://go.microsoft.com/fwlink/?LinkId=41401).


Программа LeakDiag включена
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, активизирована ли на компьютере программа LeakDiag.exe, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\LeakDiag\EnableAutoStart

Если анализатор сервера Exchange обнаружит, что значение параметра EnableAutoStart установлено равным 1, на экран будет выведено предупреждение. Параметр «EnableAutoStart» настраивается с помощью пользовательского интерфейса LeakDiag. Значение по умолчанию равно 0. Значение равное 1 указывает, что программа LeakDiag включена и находится в активном состоянии.

LeakDiag — это набор средств, которые помогают разработчикам, специалистам службы поддержки и отделов информационных технологий диагностировать утечки памяти, фрагментацию и другие проблемы, относящиеся к памяти, в приложениях и службах на компьютерах, работающих под управлением Microsoft Windows NT® Server 4.0, Windows® 2000 Server, Windows XP и Windows Server™ 2003.

Средства LeakDiag позволяют выявить причины утечек памяти с точностью до строки программного кода. Используя технологию Detours от Майкрософт, программа LeakDiag перехватывает вызовы в указанные области памяти и отслеживает стеки различных вызовов. Программа сообщает сведения по памяти, которая выделена, но еще не освобождена. Эти сведения помогают лицу, занимающемуся устранением проблемы утечек памяти, точно знать, какие компоненты вызывали выделение памяти. С помощью правильных символов отладки, можно увидеть даже строку кода, которая выдала запрос на выделение памяти.

Рекомендуется не запускать LeakDiag на серверах Exchange, которые находятся в производственной среде. После включения LeakDiag отслеживает все выделения памяти для всех процессов при каждом запуске сервера Exchange. На это расходуется большой объем ресурсов процессора и памяти и поэтому не рекомендуется включать это средство, если не выполняется устранение проблемы, связанной с памятью. Если не выполняется устранение проблем, связанных с памятью, следует отключить LeakDiag. Работа LeakDiag в производственной среде сервера Exchange может приводить к фрагментации, расходованию памяти и, в конечном итоге, к сбою приложения Exchange.

Примечание.
Устранять неполадки с помощью LeakDiag всегда следует во внепиковые часы. Использование LeakDiag в периоды больших и пиковых нагрузок может привести к значительному уменьшению производительности компьютера, на котором работает сервер Exchange.

Чтобы выключить автозапуск в программе LeakDiag.exe

  1. Нажмите кнопку Пуск, а затем щелкните LeakDiag.

  2. В меню Сервис выберите команду Параметры.

  3. На странице Параметры снимите флажок Разрешить автозапуск и нажмите кнопку OK.

Последнюю версию LeakDiag см. на общедоступном FTP-узле корпорации Майкрософт (http://go.microsoft.com/fwlink/?LinkId=41401).


Менее семи дней осталось до заполнения пространства для журналов
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-04-13

Средство анализатора сервера Microsoft Exchange оценивает время, оставшееся до заполнения пространства для журналов транзакций в группе хранения сервера Exchange. Анализатор сервера Exchange оценивает это время, проверяя штампы времени файлов журнала транзакций на диске. Если анализатор обнаружит, что осталось менее семи дней до заполнения диска журналов, анализатор отобразит сообщение об ошибке.

Пространство на диске, содержащем файлы журнала для баз данных сервера Exchange, заканчивается.

Если свободное пространство на диске журналов заканчивается, могут возникнуть следующие неполадки:

  • База данных не сможет запуститься или прекратит работу.

  • Работа базы данных завершится некорректно и база данных станет несогласованной.

  • Пользователи не смогут получить доступ к электронной почте или общим папкам.

Пространство диска журналов может заполниться из-за отключенного циклического ведения журналов. Поэтому файлы журнала транзакций остаются на диске до выполнения полного или добавочного резервного копирования средством резервного копирования, поддерживающего работу с Exchange Server.

В версиях Exchange Server, выпущенных до версии 2003, базы данных могут не завершить работу правильно перед полной остановкой. Два зарезервированных файла журнала транзакций, Res1.log и Res2.log, преобразуются в обычные файлы журнала транзакций в экстренных случаях нехватки дискового пространства.

В Exchange Server 2003 появились улучшения, касающиеся возможности правильного завершения работы баз данных до того, как резервные файлы журнала будут исчерпаны. Если работа базы данных не была правильно завершена, очень важно, чтобы несколько последних журналов транзакций, связанных с базой данных, не были удалены. Эти журналы транзакций содержат данные, которые необходимо применить к базе данных, чтобы восстановить ее согласованность. Если удалить эти файлы журналов, база данных невозможно будет запустить до тех пор, пока не она не будет исправлена или восстановлена.

Если все базы данных в группе хранения находятся в состоянии правильного завершения работы, удаление всех журналов транзакций не будет препятствовать запуску баз данных. Однако удаление журналов транзакций сделает предыдущие резервные копии недопустимыми. Это удаление не означает, что невозможно будет восстановить предыдущие резервные копии. Это означает, что невозможно будет сделать накат восстановленной базы данных, минуя время удаления файлов журнала.

Мастер пространства журналов в анализаторе сервера Exchange проанализирует существующие файлы журнала транзакций и поможет переместить те из них, в которых база данных больше не нуждается. Также этот мастер проверит, находятся ли все базы данных в состоянии правильного завершения работы, и в этом случае не удалит текущий файл журнала. Если текущий файл журнала не удален, предыдущие резервные копии остаются допустимыми.

Чтобы освободить пространство на диске журналов, необходимо удалить ненужные файлы журналов. Рекомендуются следующие действия.

Чтобы полностью или почти полностью освободить пространство на диске журналов

  • Выполните оперативное потоковое резервное копирование базы данных, поддерживающее Exchange или резервное копирование с помощью службы теневого копирования томов. Дополнительные сведения о резервном копировании с помощью службы теневого копирования томов см. на веб-узле, посвященном советам и рекомендациям по использованию службы теневого копирования томов в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=56571).

    Примечание.
    Предпочитаемым методом очистки ненужных файлов журналов является выполнение оперативного потокового резервного копирования или резервного копирования с помощью службы теневого копирования томов.

  • Если база данных завершает работу из-за нехватки пространства диска журналов, можно использовать мастер управления пространством журналов анализатора сервера Exchange. С помощью этого мастера можно переместить избыточные файлы журналов. Кроме того, можно вручную переместить избыточные файлы журналов перед повторным подключением базы данных.

    Чтобы удалить файлы журналов вручную, выполните процедуры и рекомендации, приведенные в статье 240145 базы знаний Майкрософт, посвященной инструкциям по удалению файлов журнала транзакций в Exchange Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240145).


Значение LegacyExchangeDN для этого сервера Exchange не соответствует родительской административной группе
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-09

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы проверить значение legacyExchangeDN сервера, сравнивая атрибуты объекта-сервера в контейнере «Серверы» в Active Directory с фактическим именем организации и административной группы, в которой располагается сервер. Если значение legacyExchangeDN сервера отличается от значения для организации или административной группы, возвращается ошибка.

Exchange использует значение legacyExchangeDN для идентификации объектов Exchange в Active Directory. Значение legacyExchangeDN — это различающееся имя, которое указывает место объекта в организации Exchange:

/o= организация /ou= административная группа /ou= сервер

Такие объекты, как хранилища почтовых ящиков и хранилища общих папок, наследуют часть своих значений legacyExchangeDN от сервера. Это означает, что если есть проблема со значением для сервера, остальные объекты могут унаследовать ту же проблему.

Обычно проблемы с legacyExchangeDN возникают, когда администратор пытается изменить значение вручную. Это значение следует изменять с помощью таких средств, как Active Directory Service Interfaces (ADSI) Edit, LDP (ldp.exe) или другого клиента LDAP версии 3.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью оснастки «Редактирование» интерфейса ADSI, средства LDP или другого клиента, использующего протокол LDAP версии 3, может привести к серьезным неполадкам. Для устранения этих проблем может потребоваться переустановка системы Microsoft Windows Server™ 2003, сервера Exchange Server 2003 или сервера Exchange Server 2007 или обоих продуктов. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы устранить эту ошибку

  1. С помощью ADSI Edit или подобного средства найдите объект административной группы в Active Directory.

    Атрибут legacyExchangeDN может описываться следующим образом:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=организация,CN=Administrative Groups,CN=административная_группа,CN=Servers,CN=сервер

  2. Введите новое строковое значение в виде:

    /o= организация /ou= административная группа /ou= сервер

Дополнительные сведения об использовании средства LDP см. в статье 260745 базы знаний корпорации Майкрософт "XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (Использование служебной программы LDP для изменения атрибутов объектов Active Directory) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Дополнительные сведения о работе с оснасткой Edit интерфейса ADSI см. в разделе «Adsiedit.msc: ADSI Edit» в справке Windows Server 2003.


LegacyExchangeDN для данного сервера Exchange недопустимо
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-09

Средство анализа сервера Microsoft® Exchange запрашивает службу каталога Active Directory® для подтверждения значения параметра legacyExchangeDN сервера Exchange. Если структура или группа администрирования, указанная в значении параметра legacyExchangeDN, не соответствует действительному имени структуры или группы администрирования, или если часть значения параметра полностью отсутствует, отображается ошибка.

Exchange использует значение параметра legacyExchangeDN для определения объектов Exchange в Active Directory. Значение legacyExchangeDN - это определенное имя, указывающее, где объект встраивается в структуру Exchange, например:

/o= структура /ou= группа администрирования

Такие объекты, как серверы и иерархическая структура папок, наследуют часть значения параметра legacyExchangeDN из группы администрирования. Это значит, что если возникает проблема со значением группы администрирования, многие другие объекты могут ее унаследовать.

Обычно проблемы с legacyExchangeDN возникают, когда администратор пытается непосредственно изменить значение. Значение необходимо исправить при помощи такого средства, как редактор интерфейсов служб Active Directory (ADSI), средство LDP (ldp.exe) или любого другого клиента LDAP версии 3.

Внимание!
Если неверно изменить атрибуты объектов Active Directory при помощи редактора ADSI, средства LDP или любого другого клиента LDAP версии 3, могут возникнуть серьезные проблемы. Для устранения этих проблем может потребоваться переустановка системы Microsoft Windows Server™ 2003, сервера Exchange Server 2003 или сервера Exchange Server 2007 или обоих продуктов. Изменять атрибуты объектов Active Directory можно на свой страх и риск.

Чтобы исправить эту ошибку

  1. При помощи редактора ADSI или подобного средства найдите объект группы администрирования в Active Directory.

    Атрибут legacyExchangeDN находится в:

    CN=Конфигурация,CN=Службы,CN=Microsoft Exchange,CN=Структура,CN=Группы администрирования,CN=Группа администрирования

  2. Введите значение строки формы:

    /o= структура /ou= группа администрирования

Для получения дополнительных сведений об использовании средства LDP см. статью 260745, «XADM: использование служебной программы LDP для изменения свойств объектов Active Directory» по адресу http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.

Для получения дополнительных сведений о работе с редактором ADSI см. тему «Adsiedit.msc: Редактор ADSI» в справке Windows Server 2003.


Установлено значение «Авто» службы учета лицензий
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft Exchange Server запрашивает класс Win32_Service инструментария Microsoft Windows Management Instrumentation (WMI) для определения значения параметра Started для службы учета лицензий (LicenseService). Значение Ложь указывает, что служба учета лицензий не работает на данном сервере Exchange. Значение Истина указывает, что служба учета лицензий работает.

Кроме того, Exchange Server Analyzer запрашивает класс Exchange_Server инструментария WMI в пространстве имен root\MicrosoftExchangeV2 для определения значения параметра IsFrontEndServer. Значение Ложь указывает, что сервер Exchange не является сервером переднего плана. Значение Истина указывает, что сервер Exchange является сервером переднего плана.

Кроме того, Exchange Server Analyzer запрашивает класс Win32_OperatingSystem инструментария WMI для определения значения параметра OSProductSuite. Значение данного параметра указывает версию операционной системы Windows, используемую сервером Exchange.

Кроме того, Exchange Server Analyzer запрашивает службу каталога Active Directory для определения счетчика записей атрибута homeMDBBL каждого хранилища почтового ящика. Счетчик данного атрибута представляет собой количество почтовых ящиков в хранилище почтовых ящиков.

Если Exchange Server Analyzer обнаруживает, что служба учета лицензий запущена на сервере Exchange, соответствующем всем следующим критериям, появляется предупреждение:

  • Сервер Exchange не является сервером переднего плана.

  • На сервере Exchange размещено более 20 почтовых ящиков.

  • Сервер Exchange работает не с Microsoft Windows Small Business Server 2003 или Small Business Server 2000.

Служба учета лицензией разработана, чтобы помогать клиентам управлять лицензиями на серверные продукты Майкрософт, лицензированные по модели Server Client Access License (CAL).

По умолчанию Microsoft Windows Server 2003 отключает службу учета лицензий. Ввиду заложенных при разработке ограничений и изменения лицензионных соглашений служба учета лицензий не может предоставить точные сведения об общем количестве приобретаемых лицензий CAL по отношению к общему количеству лицензий CAL, используемых на одном сервере или про всему предприятию. Лицензии CAL, регистрируемые службой учета лицензий, могут вступать в конфликт с интерпретациями лицензионных соглашений и с правами на использование продукта. Служба учета лицензий не будет входить в следующие версии операционной системы Windows.

У Майкрософт есть особые требования и рекомендации по использованию службы учета лицензий на серверах Exchange:

  • На серверах Exchange переднего плана, использующих протокол SSL, необходимо включить и запустить службу учета лицензий. Если служба учета лицензий не работает, службы IIS ограничат число одновременно действующих подключений SSL, прошедших проверку подлинности, до 10.

  • На фоновых серверах Exchange рекомендуется остановить и отключить службу учета лицензий.

  • На кластерных серверах Exchange рекомендуется остановить и отключить службу учета лицензий.

  • На серверах Exchange, работающих с Microsoft Windows Small Business Server 2003 или Small Business Server 2000, служба учета лицензий необходима только при работе с более чем 10 подключениями SSL, прошедшими проверку подлинности.

Установка состояния службы учета лицензий

  1. Запустите оснастку «Службы» в меню «Администрирование».

  2. Найдите и дважды щелкните Служба учета лицензий.

  3. В раскрывающемся списке Тип запуска выберите соответствующий вариант:

    • Установите Авто для серверов Exchange переднего плана, использующих SSL.

    • Установите Отключено для фоновых и кластерных серверов Exchange.

  4. При отключении службы учета лицензий необходимо также остановить службу нажатием Стоп.

  5. Нажмите OK, чтобы сохранить изменения, и закройте оснастку «Службы».

Для получения дополнительных сведений о службе учета лицензий см. следующие статьи базы знаний Майкрософт:

  • 824196, «Описание службы учета лицензий для операционных систем Windows Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=824196)

  • 316631, «Отключение службы учета лицензий» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316631)


Имя файла журнала не соответствует номеру поколения журнала
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-07

Средство анализа Microsoft® Exchange Server сравнивает значение внутреннего номера поколения lGeneration из заголовка файла журнала транзакций и имя файла журнала транзакций.

Если внутренний номер поколения из файла журнала транзакций не соответствует представлению внутреннего номера поколения в имени файла журнала транзакций, средство анализа Exchange Server сообщает об ошибке.

Кроме случая, когда файл журнала является текущим журналом, самый новый доступный файл журнала должен иметь имя файла, совпадающее с его номером поколения. Если файл журнала является текущим журналом, его имя не должно содержать номера создания, а только префикс журнала для группы хранения. Например, предыдущие журналы транзакций серии могут называться E0154321.LOG, E0154322.LOG, E0154323.LOG, и так далее, а текущий журнал - E01.LOG.

Можно использовать команду Eseutil /ML LOGFILE для просмотра внутреннего значения lGeneration файла журнала.

Для получения дополнительных сведений о журналировании транзакций сервера Exchange см. разделе «Журналирование транзакций Exchange в Exchange Server 2003» на странице Using Recovery Storage Groups in Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589).


Несоответствие подписей последовательности журналов
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-07

Средство анализатора сервера Microsoft® Exchange сравнивает значение Signature файла журнала со следующим значением Signature файла журнала, чтобы определить, совпадают ли они.

Если значение Signature файла журнала не соответствует значению Signature следующего файла журнала, отображается сообщение об ошибке.

В Exchange используется ряд файлов журнала, размер каждого из которых составляет ровно пять мегабайт, вместо того, чтобы осуществлять запись в один большой файл. Когда файл журнала заполнен, Exchange закрывает его и присваивает ему в качестве имени последовательный номер.

При инициализации новой последовательности файлов журнала транзакций для групп хранения Exchange Signature записывается в первый файл журнала и копируется в каждый последующий файл Значение Signature является уникальным идентификатором определенного файла журнала как члена определенной последовательности файлов журнала.

В одной папке не должны находиться файлы журнала с различными подписями. Если это происходит, значит файл другого журнала был скопирован в группу хранения или файлы этого журнала были сброшены без предварительного удаления всех предыдущих файлов журнала.

Команда Eseutil /ML LOGFILE может использоваться для отображения значения Signature для файла журнала.

Дополнительные сведения о ведении журналов транзакций в Exchange Server см. на веб-странице, посвященной ведению журналов транзакций Exchange в Exchange Server 2003 в разделе, описывающем использование групп аварийного хранения в Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589).


Вопрос, связанный с подписью журнала
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-07

Средство анализатора сервера Microsoft® Exchange сравнивает подпись в заголовке текущего файла журнала транзакций Exchange на сервере с подписью журнала в файле базы данных группы хранения.

Если подпись файла журнала транзакций не соответствует подписи журнала в любом файле базы данных, анализатор сервера Exchange отображает сообщение об ошибке.

Эта ошибка указывает, что справедливо одно из следующих условий:

  • Текущего файла журнала транзакций не существует.

  • Текущий файл журнала транзакций не соответствует одной из базы данных в группе хранения.

Такое поведение может возникнуть по следующим причинам:

  • Журналы транзакций для группы хранения были удалены вручную.

  • База данных другой группы хранения была восстановлена в этой группе хранения или скопировано в нее.

  • В эту группу хранения были скопированы файлы журнала транзакций из другой группы хранения или из другой последовательности.

Будет ли это условие препятствовать подключению базы данных, зависит от того, находится ли файл базы данных в состоянии правильного завершения работы или же в состоянии неправильного завершения работы.

Примечание.
База данных может находиться в состоянии правильного завершения работы, но не сможет быть подключенной, так как другие базы данных в группе хранения не могут быть подключены. Используйте средство анализа аварийного восстановления сервера Exchange для проверки и получения рекомендаций о том, как подключить базы данных в подобных случаях.

Если база данных Exchange правильно завершает работу, все ожидающие данные записываются в файлы базы данных. После обычного завершения работы файлы базы данных (расширения EDB и STM) считаются согласованными. Затем Exchange отсоединяет набор файлов базы данных от соответствующего потока журнала. Это означает, что файлы базы данных теперь автономны, то есть пребывают в текущем состоянии. Предыдущие журналы транзакций не требуются для запуска файлов базы данных.

Базы данных, находящиеся в состоянии правильного завершения работы, были отсоединены от своих файлов журналов и могут быть присоединены к другому потоку журнала. Поэтому несоответствие между файлами журналов и базой данных не всегда является проблемой.

Базы данных, находящиеся в состоянии неправильного завершения работы, были неправильно отсоединены от своих файлов журналов. Эти базы данных должны быть восстановлены с помощью своих присоединенных файлов журналов. Если невозможно обнаружить присоединенные файлы журналов, базу данных подключить невозможно. Необходимо восстановить резервную копию или восстановить базу данных перед ее подключением.

Можно определить, правильно ли завершилась работа базы данных, если ввести команду Eseutil /mh и изучить заголовки файлов. В Microsoft Exchange 2000 с пакетом обновления 1 и более поздних версиях в заголовке отображается строка «State: Clean Shutdown» или «State: Dirty Shutdown». В более ранних версиях Exchange те же состояния отображались как «State: Consistent» или «State: Inconsistent».

Дополнительные сведения о ведении журналов транзакций в Exchange Server см. на веб-странице, посвященной ведению журналов транзакций Exchange в Exchange Server 2003 (может быть на английском языке) (Using Recovery Storage Groups in Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589).


Запись байт/с в журнале превышает порог ошибки
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-23

Анализатор рекомендаций Microsoft® Exchange Server использует монитор пользователей сервера Exchange Server (ExMon), чтобы определить, занимают ли операции MAPI больше времени, чем это должно быть на исправном сервере Exchange.

В частности, анализатор Exchange Server проверяет журнал транзакций, чтобы установить, какие операции MAPI приводят к тому, что в журналы транзакций Exchange записывается более 5 МБ данных в минуту.

Излишнее увеличение длины файла транзакций из-за операций MAPI может привести к проблемам с нехваткой ресурсов сервера, таким как превышение глубины контрольных точек, задержки дисковых операций ввода-вывода и недостаток места на дисках.

Если анализатор Exchange Server обнаружит, что одна или несколько операций MAPI приводят к записи в журналы транзакций Exchange более 5 МБ данных в минуту, отображается сообщение об ошибке.

Если операции MAPI записывают в журналы транзакций Exchange более 5 МБ данных в минуту, это не обязательно является ошибкой. Высокая скорость записи допустима для некоторых действий, таких как перемещение почтовых ящиков и для других операций с большим количеством сообщений одновременно, при которых создается большой объем данных для журнала транзакций. В этом случае высокая скорость записи в журнал сохраняется в течение не более нескольких минут.

Если сервер испытывает другие проблемы, такие как длительные задержки RPC, опросите пользователя, для которого создается большой объем данных в журнале транзакций, чтобы установить, какие действия пользователя вызывают эту проблему.

Дополнительные сведения

Дополнительные сведения см. в следующих ресурсах сервера Exchange Server:

  • Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576) (Руководство по производительности и масштабируемости для Exchange Server 2003)

  • Troubleshooting Microsoft Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588) (Устранение неполадок, связанных с производительностью сервера Microsoft Exchange Server 2003)

  • Exchange Server 2003 Performance: 10 Things to Think About (http://go.microsoft.com/fwlink/?LinkId=56460) (Производительность Exchange Server 2003 — 10 вопросов к размышлению)

  • Статья 905803 базы знаний Майкрософт «Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803) (Низкая производительность Outlook при работе с папкой, содержащей множество элементов, на сервере Exchange Server 2003 или Exchange 2000 Server)


Объект LogicalDisk системного монитора недоступен
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Avg. Disk sec/Read объекта производительности LogicalDisk для анализа данных о производительности. Если данный счетчик не возвращает допустимые данные, выводится базовое сообщение.

Если допустимые данные не возвращаются модулем сбора данных о производительности, имеет место одно из сочетаний следующих условий:

  • Объект производительности LogicalDisk отключен. По умолчанию в Microsoft Windows Server™ 2003 объект производительности LogicalDisk включен. Однако в Microsoft Windows® 2000 Server объект LogicalDisk по умолчанию отключен.

  • Объект системного монитора LogicalDisk отсутствует или поврежден.

  • Для анализатора сервера Exchange не назначены разрешения, необходимые для получения доступа к объектам производительности.

Первые два условия могут возникнуть в том случае, если реестр поврежден определенными расширяемыми счетчиками или изменен программами, основанными на WMI-классах.

Приводимая ниже процедура позволяет устранить первые два условия. Перед выполнением этой процедуры убедитесь, что анализатору сервера Exchange назначены соответствующие разрешения. Дополнительные сведения о разрешениях, требуемых для выполнения анализатора сервера Exchange, см. в справочной документации, включенной в анализатор сервера Exchange. Чтобы открыть справку, откройте анализатор сервера Exchange и нажмите клавишу F1.

Чтобы устранить эту ошибку

  1. Убедитесь, что включен объект производительности LogicalDisk:

    1. Загрузите и установите средство списка расширяемых счетчиков производительности (Exctrlst.exe). Средство Exctrlst.exe можно загрузить на странице Exctrlst.exe: Список расширяемых счетчиков производительности (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Откройте окно средства Exctrlst.exe, щелкните Sort Order, а затем — Service.

    3. Найдите службу, сведения о которой поставляет данный объект производительности и проверьте, что установлен флажок Performance Counters Enabled.

      Если флажок Performance Counters Enabled не установлен, установите его, а затем перезапустите связанную с нужными счетчиками производительности службу, чтобы проверить, что эти счетчики производительности работоспособны. Если счетчики производительности неработоспособны или флажок Performance Counters Enabled уже установлен, перейдите к выполнению шага 2.

  2. Повторно создайте отсутствующие или поврежденные счетчики производительности в соответствии с инструкциями в статье 300956 базы знаний Майкрософт, посвященной инструкциям по ручному созданию значений библиотеки счетчиков производительности (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Если после выполнения процедуры, указанной в этой статье базы знаний, проблема не будет устранена, придется переустановить операционную систему Windows в режиме Восстановление, а затем применить последние пакеты обновления Windows.


Обнаружены операции MAPI с длинной задержкой
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-11-22

Анализатор рекомендаций Microsoft® Exchange Server использует монитор пользователей сервера Exchange Server (ExMon) для сбора данных в пятиминутных интервалах, чтобы определить, занимают ли операции MAPI больше времени, чем это должно быть на исправном сервере Exchange.

Если анализатор рекомендаций Exchange Server определит, что в течение интервала времени, за который выполнялся сбор данных, одна или несколько операций MAPI занимали более 30 секунд, отображается сообщение об ошибке и выполняется дополнительный анализ действий пользователей, для которых возникла эта ошибка.

Операция MAPI, длящаяся более 30 секунд, не обязательно является ошибкой. При сохранении больших сообщений или вложенных файлов операции MAPI могут длиться дольше, чем обычно.

Если один или несколько пользователей сталкиваются с частыми задержками или задержки приводят к снижению удобства работы с электронной почтой, эти задержки операций MAPI должны быть исследованы более подробно: следует убедиться, что эти задержки не являются симптомами более серьезных проблем, таких как нехватка ресурсов или вложенные зависимости.

Чтобы устранить эту ошибку, выполните следующие действия.

  • Попробуйте с помощью монитора ExMon записать более крупный фрагмент для изучения в анализаторе рекомендаций Exchange Server. Поскольку монитор ExMon создает значительный объем данных, рекомендуется, чтобы временной интервал сбора данных не превышал 30 минут.

  • Просмотрите все ошибки, связанные с задержками, и соответствующие статьи, описывающие данные операции и действия по устранению проблем. Если анализатор рекомендаций Exchange Server не выдает ошибки, связанные с задержками, дополнительный анализ действий пользователей не требуется.


Длительная глобальная операция MAPI
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-23

Анализатор рекомендаций сервера Microsoft® Exchange использует монитор пользователей сервера Exchange Server (ExMon), чтобы определить ситуацию, когда пользовательские операции MAPI превышают разумную длительность, которая отводится для нормальной работы сервера Exchange.

Частью этого анализа является обзор анализатором данных монитора ExMon о длительных глобальных пользовательских операциях MAPI, длительность которых превышает 30 секунд.

Глобальные операции MAPI - это операции, при которых обрабатывается больше одного объекта и которые обычно являются затратными (повышенная нагрузка на процессы ввода-вывода).

Если анализатор сервера Exchange Server определяет, что одна или несколько пользовательских глобальных операций MAPI превышают 30 секунд, на экран выводится сообщение об ошибке.

Глобальные операции MAPI, которые выполняются более 30 секунд, не всегда могут быть проблемой. Если пользователь работает одновременно более чем с тысячей сообщений (копирование, удаление, установка флажков свойств и т. п.), это может стать причиной того, что глобальные операции займут больше времени, чем обычно.

Если пользователи сталкиваются с частыми задержками или такими задержками, которые отрицательно влияют на процесс обмена сообщениями, следует изучить эти глобальные операции MAPI, чтобы убедиться, что они не являются симптомом более серьезных проблем с задержкой, таких как «узкие места» в ресурсах или вложенные зависимости.

Чтобы устранить эту ошибку, выполните следующие действия.

  • Используйте ExMon, чтобы получить более объемный образец данных для обзора в анализаторе сервера Exchange Server. Поскольку Exchange создает большой объем данных, рекомендуется сохранить образец набора данных не более чем за 30 минут.

Дополнительные сведения

Дополнительные сведения см. в следующих ресурсах Exchange Server:

  • Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576) (Руководство по производительности и масштабируемости для Exchange Server 2003)

  • Troubleshooting Microsoft Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588) (Устранение неполадок, связанных с производительностью сервера Microsoft Exchange Server 2003)

  • «Exchange Server 2003 Performance: 10 Things to Think About» (http://go.microsoft.com/fwlink/?LinkId=56460) (Производительность Exchange Server 2003 — 10 вопросов к размышлению)

  • Статья 905803 базы знаний Майкрософт «Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803) (Низкая производительность Outlook при работе с папкой, содержащей множество элементов, на сервере Exchange Server 2003 или Exchange 2000 Server)


Длительная операция MAPI «FindRow»
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-11-22

Анализатор рекомендаций Microsoft® Exchange Server использует монитор пользователей сервера Exchange Server (ExMon), чтобы определить, занимают ли операции MAPI больше времени, чем это должно быть на исправном сервере Exchange.

В частности, анализатор рекомендаций Exchange Server просматривает данные ExMon на наличие запрошенных пользователями операций MAPI FindRow, выполнение которых заняло более 30 секунд.

Увеличение числа представлений для каждой из папок может увеличить длительность выполнения многих операций MAPI. Клиентские приложения используют операции MAPI SeekRow или FindRow для перемещения указателя между строками представления. Операция SeekRow указывает, на сколько строк должен быть перемещен указатель, и требует совсем немного ресурсов ЦП. Операции FindRow требуется значительный объем вычислительных ресурсов, поскольку она перемещает указатель к первому элементу нематериализованного представления (оно не будет кэшироваться), которое отвечает условиям ограничения, а затем удаляет данное представление после того, как клиентское приложение завершило выполняемое действие. Общие затраты времени ЦП на операцию FindRow зависит от сложности ограничения, а также от того, сколько строк нужно просмотреть до того, как будет найден первый элемент, отвечающий заданным условиям, поэтому затраты времени ЦП растут по мере увеличения числа элементов в папке.

Вследствие высокой нагрузки на ЦП при выполнении операции FindRow можно рекомендовать выполнять эту операцию в режиме кэширования, чтобы снизить нагрузку на сервер. Обратите внимание, что иногда высокая нагрузка на ЦП вызвана совместным использованием календарей, и в этом случае применение режима кэширования не приведет к снижению нагрузки. Высокая нагрузка операции FindRow на процессор может указывать на создание большого числа представлений, создание ресурсоемких представлений или наличие папок с большим количеством элементов.

Если анализатор рекомендаций Exchange Server определит, что запущенная пользователем операция MAPI FindRow заняла более 30 секунд, отображается сообщение об ошибке.

Операция MAPI FindRow, длящаяся более 30 секунд, не обязательно является ошибкой. Если один или несколько пользователей сталкиваются с частыми задержками, или задержки приводят к снижению удобства работы с электронной почтой, следует установить причину задержек. Следует опросить пользователя, сталкивающегося с задержками, и выяснить следующее:

  • Насколько велико количество элементов в папках.

  • Какие приложения применяет пользователь.

Для устранения этой проблемы выполните следующие действия.

  • Предложите пользователям, у которых в папках хранится много элементов, уменьшить число элементов в каждой папке. Рекомендуется, чтобы число элементов в папках «Входящие», «Календарь», «Отправленные», «Контакты» и «Удаленные» не превышало 5000.

  • Настройте клиентские компьютеры, вызвывающие наибольшую нагрузку (особенно компьютеры с длительными задержками операций Restrict, SetColumns и FindRow) на использование режима кэширования Exchange. Режим кэширования Exchange позволяет избавить сервер от большей части избыточного трафика RPC.

  • Попробуйте закрыть все приложения, затем запускайте их по одному, чтобы установить, какое из них вызывает проблему. Если эти приложения не требуются дли бизнеса или для них выпущено обновления, следует навсегда закрыть все приложения, вызывающие проблемы, или обновить эти приложения для снижения нагрузки до приемлемого уровня.

Примечание.
Некоторые приложения могут значительно увеличить загрузку на сервер и без запуска множества операций MAPI. Причина заключается в том, что для некоторых операций требуется больше ресурсов системы, чем для других. Даже небольшое увеличение количества ресурсоемких операций может привести к значительному повышению нагрузки на сервер. В отчетах ExMon пользователи могут вызывать значительную загрузку ЦП без запуска большого числа операций MAPI.

При наличии ограничения производительности (обычно причиной ограничения является недостаточная скорость работы дисков или ЦП) увеличиваются задержки операций FindRow.

Дополнительные сведения

Дополнительные сведения см. в следующих ресурсах сервера Exchange Server:

  • Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576) (Руководство по производительности и масштабируемости для Exchange Server 2003)

  • Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588) (Устранение неполадок, связанных с производительностью сервера Microsoft Exchange Server)

  • Exchange Server 2003 Performance: 10 Things to Think About (http://go.microsoft.com/fwlink/?LinkId=56460) (Производительность Exchange Server 2003 — 10 вопросов к размышлению)

  • Статья 905803 базы знаний Майкрософт «Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803) (Низкая производительность Outlook при работе с папкой, содержащей множество элементов, на сервере Exchange Server 2003 или Exchange 2000 Server)


Длительные оперативные операции MAPI
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-23

Анализатор рекомендаций Microsoft® Exchange Server использует монитор пользователей сервера Exchange Server (ExMon), чтобы определить, занимают ли оперативные операции MAPI больше времени, чем это должно быть на исправном сервере Exchange.

Примером оперативной операции MAPI является операция QueryRows.

Операция QueryRows возвращает строки в текущем представлении. При этом операция QueryRows использует данные в таблице для ответа на запрос пользователя. Операция SetColumns определяет данные, доступные для QueryRows. Ресурсоемкость операции QueryRows повышается по мере увеличения размера запрошенных свойств, числа запрошенных свойств, а также числа запрошенных строк данных. Операция QueryRows также может занимать много ресурсов при запросе большого числа столбцов и строк.

По мере увеличения числа элементов в основных папках сервера Exchange Server 2003 возрастают и затраты дисковых ресурсов, требуемые для выполнения некоторых операций для пользователей Outlook. Например, команда упорядочения папки «Входящие» по размеру сообщений в первый раз может использовать значительный объем ресурсов (скорость ввода-вывода дисков). В дальнейшем упорядочение папки «Входящие» по размеру сообщений не будет занимать много ресурсов.

Если анализатор рекомендаций Exchange Server определит, что запущенная пользователем оперативная операция MAPI заняла более 30 секунд, отображается сообщение об ошибке.

Длинные задержки оперативных операций MAPI могут указывать на нехватку ресурсов сервера. Для операции QueryRows это также может означать большое число объектов в папке или множество свойств, установленных на внутренние таблицы.

Если длительная задержка оперативных операций связана с обработкой большого объекта данных, то в этом случае может не быть проблем производительности сервера. Пример такой операции — когда пользователь выделяет все элементы в папке и единой операцией помечает все элементы как прочтенные. Следует опросить пользователя, сталкивающегося с задержками, и выяснить следующее:

  • Насколько велико количество элементов в папках.

  • Какие приложения применяет пользователь.

Для устранения этой проблемы выполните следующие действия.

  • Предложите пользователям, у которых в папках хранится много элементов, уменьшить число элементов в каждой папке. Рекомендуется, чтобы число элементов в папках «Входящие», «Календарь», «Отправленные», «Контакты» и «Удаленные» не превышало 5000.

  • Попробуйте закрыть все приложения, затем запускайте их по одному, чтобы установить, какое из них вызывает проблему. Если эти приложения не требуются дли бизнеса или для них выпущено обновление, следует навсегда закрыть все приложения, вызывающие проблемы, или обновить эти приложения для снижения нагрузки до приемлемого уровня.

Примечание.
Некоторые приложения могут значительно увеличить загрузку на сервер и без запуска множества оперативных операций MAPI. Причина заключается в том, что для некоторых операций требуется больше ресурсов системы, чем для других. Даже небольшое увеличение количества ресурсоемких операций может привести к значительному повышению нагрузки на сервер. В отчетах ExMon пользователи, запускающие такие операции, могут вызывать значительную загрузку ЦП без запуска большого числа операций MAPI.

При наличии ограничения производительности (обычно причиной ограничения является недостаточная скорость работы дисков или ЦП) увеличиваются задержки оперативных операций MAPI. Следует определить наличие ограничений серверных ресурсов и либо увеличить мощность сервера, либо перенести пользователей сервер с меньшей загрузкой.

Дополнительные сведения

Дополнительные сведения см. в следующих ресурсах сервера Exchange Server:

  • Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576) (Руководство по производительности и масштабируемости для Exchange Server 2003)

  • Troubleshooting Microsoft Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588) (Устранение неполадок, связанных с производительностью сервера Microsoft Exchange Server 2003)

  • Exchange Server 2003 Performance: 10 Things to Think About (http://go.microsoft.com/fwlink/?LinkId=56460) (Производительность Exchange Server 2003 — 10 вопросов к размышлению)

  • Статья 905803 базы знаний Майкрософт «Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803) (Низкая производительность Outlook при работе с папкой, содержащей множество элементов, на сервере Exchange Server 2003 или Exchange 2000 Server)


Длительные операции MAPI
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-11-22

Анализатор рекомендаций сервера Microsoft® Exchange использует монитор пользователей сервера Exchange Server (ExMon), чтобы определить ситуацию, когда пользовательские операции MAPI превышают разумную длительность, которая отводится для нормальной работы сервера Exchange.

Если анализатор рекомендаций Exchange Server определяет, что одна или две пользовательские операции MAPI превышают 30 секунд, на экран выводится сообщение об ошибке.

Увеличение числа представлений для каждой из папок может увеличить длительность выполнения многих операций MAPI. В этом разделе обсуждаются две наиболее распространенные операции, SeekRow и FindRow. Другие операции MAPI, определяемые анализатором сервера Exchange Server как "длительные", обычно могут быть разрешены тем же способом, как и операции MAPI SeekRow и FindRow.

Клиентские приложения используют операции MAPI SeekRow или FindRow для перемещения указателя между строками представления. Операция SeekRow указывает, на сколько строк должен быть перемещен указатель, и требует совсем немного ресурсов ЦП. Операции FindRow требуется значительный объем вычислительных ресурсов, поскольку она перемещает указатель к первому элементу нематериализованного представления (оно не будет кэшироваться), которое отвечает условиям ограничения, а затем удаляет данное представление после того, как клиентское приложение завершило выполняемое действие. Предельная стоимость процессорного ресурса операции FindRow зависит от сложности данного ограничения, числа свойств сообщения, допустимого для каждого сообщения, и от количества строк, которые должно просмотреть хранилище до того, как будет найден первый элемент, отвечающий заданным условиям. Поэтому эта стоимость растет по мере увеличения числа элементов в папке.

Операции MAPI, которые занимают более 30 секунд, не всегда могут быть связаны с неполадками. Если определенный пользователь или группа пользователей сталкивается с частыми задержками или такими задержками, которые отрицательно влияют на процесс обмена сообщениями, следует разобраться в причине этого. Проанализируйте совместно с пользователем, испытывающим большие задержки, следующие вопросы:

  • Не велико ли число элементов в папках?

  • Какие приложения запущены пользователем?

Устранение этой проблемы

  • Предложите пользователю уменьшить число элементов в каждой папке, если оно велико. Рекомендуется, чтобы число элементов в папках "Входящие", "Календарь", "Отправленные", "Контакты" и "Удаленные" не превышало 5 000

  • Настройте клиентские компьютеры, на которых выполняется наибольшее количество операций (особенно те компьютеры, на которых наблюдаются длинные задержки, связанные с операциями Restrict, SetColumns или FindRow) для использования режима кэширования Exchange. Режим кэширования Exchange изолирует сервер от большинства избыточного RPC-трафика.

  • Попробуйте отключить все приложения и затем включите их одно за другим, чтобы определить приложение, которое, возможно, вызывает проблему. Если эти приложения не используются в работе или для них имеются опубликованные исправления, полностью их отключите или обновите, чтобы снизить нагрузку до соответствующего уровня.

Примечание.
Некоторые приложения могут значительно повышать нагрузку на сервер без увеличения количества операций MAPI. Это связано с тем, что одни операции являются более затратными, чем другие. Небольшое увеличение числа затратных операций может значительно повлиять на производительность сервера. В отчетах о таких пользователях на мониторе ExMon сообщается, что они создают высокую нагрузку на ЦП не обязательно по причине большого числа операций MAPI.

Также следует иметь в виду, что, при возникновении "узкого места" в ресурсах (как правило, связанных с диском или ЦП), задержки операций MAPI увеличиваются. Определите "узкие места" ресурсов сервера и либо увеличьте производительность серверных ресурсов, либо переместите пользователей на менее загруженный сервер.

Дополнительные сведения

Дополнительные сведения см. на следующих ресурсах сервера Exchange:

  • Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576) (Руководство по производительности и масштабируемости для Exchange Server 2003)

  • Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588) (Устранение неполадок, связанных с производительностью сервера Microsoft Exchange Server)

  • Exchange Server 2003 Performance: 10 Things to Think About (http://go.microsoft.com/fwlink/?LinkId=56460) (Производительность Exchange Server 2003 — 10 вопросов к размышлению)

  • Статья 905803 базы знаний Майкрософт "Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803) (Низкая производительность Outlook при работе с папкой, содержащей множество элементов, на сервере Exchange Server 2003 или Exchange 2000 Server)


Длительная операция MAPI «SaveChangesMessage»
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-11-22

Анализатор рекомендаций Microsoft® Exchange Server использует монитор пользователей сервера Exchange Server (ExMon), чтобы определить, занимают ли операции MAPI больше времени, чем это должно быть на исправном сервере Exchange.

В частности, анализатор рекомендаций Exchange Server просматривает данные ExMon на наличие запрошенных пользователями операций MAPI SaveChangesMessage, выполнение которых заняло более 30 секунд.

Операция MAPI SaveChangesMessage запускается, когда приложение сохраняет содержание и свойства сообщения на сервер. Время, требуемое для этой операции, зависит от объема записываемых данных, скорости работы дисков, на которых находятся база данных и журналы транзакций, а также от возможной нехватки ресурсов.

Если анализатор рекомендаций Exchange Server определит, что запущенная пользователем операция MAPI SaveChangesMessage заняла более 30 секунд, отображается сообщение об ошибке.

Операция MAPI SaveChangesMessage, длящаяся более 30 секунд, не обязательно является ошибкой. При сохранении больших сообщений или вложенных файлов операция MAPI SaveChangesMessage может длиться дольше, чем обычно. Если один или несколько пользователей сталкиваются с частыми задержками или задержки приводят к снижению удобства работы с электронной почтой, наиболее вероятной причиной этого является недостаточная производительность дисковой системы.

Дополнительные сведения

  • Дополнительные сведения об узких местах работы дисков см. в разделе Обнаружено узкое место на диске.

  • Дополнительные сведения о быстродействии сервера Exchange см. в руководстве Exchange Server 2003 Performance and Scalability Guide (http://go.microsoft.com/fwlink/?LinkId=47576) (Руководство по производительности и масштабируемости Exchange Server 2003).

  • Дополнительные сведения об устранении проблем производительности сервера Exchange см. в материале Troubleshooting Microsoft Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588) (Устранение неполадок, связанных с производительностью Microsoft Exchange Server 2003).

  • Дополнительные сведения о рекомендациях по разработке архитектуры хранилищ см. в документе Best Practices Common to Multiple Architectures (http://go.microsoft.com/fwlink/?LinkId=72988) (Общие рекомендации для нескольких архитектур).

  • Дополнительные сведения о перемещении почтовых ящиков пользователей для сокращения нагрузки на сервер см. в разделеПеренос почтовых ящиков пользователей на другой сервер.

  • Дополнительные сведения об изменении емкости дисков, задержках и скорости операций ввода-вывода см. в следующих блогах на веб-узле блогов группы Microsoft Exchange (на английском языке):

    • «A few basic concepts in disk sizing» (http://go.microsoft.com/fwlink/?linkid=39538)

    • «Some more thoughts on disk IO and calculations….» (http://go.microsoft.com/fwlink/?linkid=39539).

    • How to Calculate Your Disk I/O Requirements (http://go.microsoft.com/fwlink/?linkid=69747)


Длительная операция MAPI «SetColumns»
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-23

Анализатор рекомендаций Microsoft® Exchange Server использует монитор пользователей сервера Exchange Server (ExMon), чтобы определить, занимают ли операции MAPI больше времени, чем это должно быть на исправном сервере Exchange Server.

В частности, анализатор рекомендаций Exchange Server просматривает данные ExMon на наличие запрошенных пользователями операций MAPI SetColumns, выполнение которых заняло более 30 секунд.

C помощью операции MAPI SetColumns создается базовое представление. Вызов операции SetColumns определяет свойства, которые будут отображены в столбцах таблицы в представлении.

При первом запросе отображения какого-либо свойства сервер должен затратить значительный объем вычислительных ресурсов для создания представления. После первого запроса свойства оно будет всегда доступно для последующих представлений. Это означает, что при первом запросе новых свойств вызов операции SetColumns может занять гораздо больше времени. Требуемое количество времени пропорционально числу новых свойств и количеству элементов в папке. Например, при первом просмотре папки «Входящие» после перемещения почтового ящика создание представления займет больше времени. Причина заключается в том, что представления не перемещаются при перемещении почтового ящика. Они создаются заново.

Также длительное время занимает добавление свойств к представлению. Затраты времени на добавление свойств пропорциональны числу добавляемых свойств и количеству элементов в папке. При обычном использовании Microsoft Office® Outlook® к таблице папки сообщений добавляется немного свойств, но можно добавить новые свойства вручную. Обычно это не вызывает проблем. Однако проблемы могут возникнуть, если приложение постоянно добавляет столбцы, добавляет много столбцов или клиент добавляет несколько столбцов при наличии в папке большого количества элементов. Чем больше столбцов отображается в таблице папки сообщений, тем больше времени занимает выполнение всех действий с элементами в этой папке. После добавления столбца его невозможно удалить. Каждое свойство в таблице папки сообщений увеличивает время, необходимое для вставки элементов в эту папку.

Если анализатор рекомендаций Exchange Server определит, что запущенная пользователем операция MAPI SetColumns заняла более 30 секунд, отображается сообщение об ошибке.

При первом доступе пользователя к своему почтовому ящику после перемещения этого ящика в новую базу данных или на новый сервер будут созданы новые представления. В этом случае можно ожидать длительных задержек операций SetColumns и Restrict. В течение нескольких дней после перемещения почтового ящика на эти ошибки можно не обращать внимания, поскольку они еще не свидетельствуют о неполадках.

Некоторые приложения будут создавать новые представления и переносить свойства во внутренние структуры хранения данных. Это может повлиять на производительность сервера в долгосрочной перспективе при каждом обращении сервера к данным пользователя. Если один или несколько пользователей сталкиваются с частыми задержками или задержки приводят к снижению удобства работы с электронной почтой, следует установить причину задержек. Следует опросить пользователя, сталкивающегося с задержками, и выяснить следующее:

  • Насколько велико количество элементов в папках.

  • Какие приложения применяет пользователь.

Для устранения проблемы выполните следующие действия.

  • Предложите пользователям, у которых в папках хранится много элементов, уменьшить число элементов в каждой папке. Рекомендуется, чтобы число элементов в папках «Входящие», «Календарь», «Отправленные» и «Удаленные» не превышало 5000.

  • Настройте клиентские компьютеры, испытывающие наибольшие задержки, на использование режима кэширования Exchange. Обратите особое внимание на клиентские компьютеры с задержками операций Restrict, SetColumns и FindRow. Режим кэширования Exchange позволяет избавить сервер от большей части избыточного трафика RPC.

  • Попробуйте закрыть все приложения. Затем запускайте их по одному, чтобы установить, какое из них вызывает проблему. Следует навсегда закрыть все приложения, вызывающие проблемы, или обновить эти приложения для снижения нагрузки до приемлемого уровня, если верно любое из следующих двух условий:

    • Приложение не требуется для бизнеса.

    • Для приложения выпущено обновление.

Примечание.
Некоторые приложения могут значительно увеличить загрузку на сервер и без запуска множества операций MAPI. Причина заключается в том, что для некоторых операций требуется больше ресурсов системы, чем для других. Даже небольшое увеличение количества ресурсоемких операций может привести к значительному повышению нагрузки на сервер. В отчетах ExMon пользователи могут вызывать значительную загрузку ЦП без запуска большого числа операций MAPI.

Также следует учесть, что при наличии ограничения производительности (обычно причиной ограничения является недостаточная скорость работы дисков или ЦП) увеличиваются задержки операций SetColumns.

Дополнительные сведения

Дополнительные сведения см. в следующих ресурсах сервера Exchange Server:

  • «Performance and Scalability Guide for Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=47576) (Руководство по управлению производительностью и масштабируемостью Exchange Server 2003)

  • «Troubleshooting Microsoft Exchange Server Performance» (http://go.microsoft.com/fwlink/?LinkId=47588) (Устранение неполадок, связанных с производительностью сервера Microsoft Exchange Server)

  • Exchange Server 2003 Performance: 10 Things to Think About (http://go.microsoft.com/fwlink/?LinkId=56460) (Производительность Exchange Server 2003 — 10 вопросов к размышлению)

  • Статья 905803 базы знаний Майкрософт «Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803) (Низкая производительность Outlook при работе с папкой, содержащей множество элементов, на сервере Exchange Server 2003 или Exchange 2000 Server)


Длительная операция синхронизации MAPI
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-23

Анализатор рекомендаций Microsoft® Exchange Server использует монитор пользователей сервера Exchange Server (ExMon), чтобы определить, занимают ли операции MAPI больше времени, чем это должно быть на исправном сервере Exchange.

В частности, анализатор рекомендаций Exchange Server просматривает данные ExMon на наличие запрошенных пользователями операций синхронизации MAPI, выполнение которых заняло более 30 секунд.

Операции синхронизации MAPI выполняются для синхронизации файла автономных папок Microsoft Office® Outlook® (OST) или локальной копии почтового ящика пользователя с данными пользовательского почтового ящика на сервере.

Операция синхронизации MAPI, длящаяся более 30 секунд, не обязательно является ошибкой. По умолчанию все электронные сообщения, хранящиеся на сервере Exchange Server и являющиеся полными копиями глобального списка адресов, загружаются на компьютер пользователя при первом включении режима кэширования Exchange в Outlook 2003.

При первоначальной синхронизации с сервером Exchange Server пользователи Outlook 2003 могут столкнуться с длительными задержками.

Если один или несколько пользователей сталкиваются с частыми задержками, или задержки приводят к снижению удобства работы с электронной почтой, эти задержки операций синхронизации MAPI должны быть исследованы более подробно: следует убедиться, что эти задержки не являются симптомами более серьезных проблем, таких как нехватка ресурсов или вложенные зависимости.

При наличии ограничения производительности (обычно причиной ограничения является недостаточная скорость работы дисков или ЦП) увеличиваются задержки операций синхронизации MAPI. Следует определить наличие ограничений серверных ресурсов и либо увеличить мощность сервера, либо перенести пользователей сервер с меньшей загрузкой.

Дополнительные сведения

Дополнительные сведения см. в следующих ресурсах сервера Exchange Server:

  • Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576) (Руководство по производительности и масштабируемости для Exchange Server 2003)

  • Troubleshooting Microsoft Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588) (Устранение неполадок, связанных с производительностью сервера Microsoft Exchange Server 2003)

  • «Exchange Server 2003 Performance: 10 Things to Think About» (http://go.microsoft.com/fwlink/?LinkId=56460) (Производительность Exchange Server 2003 — 10 вопросов к размышлению)

  • Статья 905803 базы знаний Майкрософт «Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803) (Низкая производительность Outlook при работе с папкой, содержащей множество элементов, на сервере Exchange Server 2003 или Exchange 2000 Server)


Длительная операция MAPI «TaskQ»
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-02-20

Средство анализа Microsoft Exchange использует монитор пользователей сервера Exchange Server (ExMon) для определения того, занимают ли операции MAPI больше времени, чем это должно быть на исправном сервере Exchange.

Частью этого анализа является проверка средством анализа Exchange данных ExMon о пользовательских операциях MAPI TaskQ, длительность которых превышает 30 секунд.

Операции TaskQ представляют собой асинхронные задачи, выполняемые вне контекста удаленного вызова процедуры. Операции TaskQ и TaskQ User Unknown — это задачи, выполняемые по запросу сервера Exchange и включающие обслуживание хранилища. Операции TaskQ User Known — это асинхронные задачи, которые инициируются непосредственным запросом пользователя и включают заполнение папки поиска, сортировку и глобальные операции над сообщениями, такие как перемещение сообщений, их копирование, удаление и обозначение прочитанных сообщений.

Если средство анализа Exchange определяет, что запущенные пользователем операции MAPI TaskQ выполняются более 30 секунд, отображается предупреждение.

Это не всегда свидетельствует о проблемах с производительностью, так как выполнение операций TaskQ обычно занимает длительное время.

Для устранения проблемы выполните указанные ниже действия.

  • Попробуйте с помощью монитора ExMon записать более крупный фрагмент данных для изучения в средстве анализа Exchange. Поскольку сервер Exchange Server создает большой объем данных, рекомендуется ограничить временные рамки образца данных не более чем 30 минутами.

Дополнительные сведения

Дополнительные сведения см. в следующих материалах по серверу Exchange Server:

  • Руководство по производительности и масштабируемости для Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576, на английском языке).

  • Устранение неполадок, связанных с производительностью сервера Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588, на английском языке).

  • Производительность Exchange Server 2003: 10 вопросов для обдумывания (http://go.microsoft.com/fwlink/?LinkId=56460, на английском языке).


Повышение длительности операций из-за операции MAPI «Restrict»
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-23

Анализатор рекомендаций Microsoft® Exchange Server использует монитор пользователей сервера Exchange Server (ExMon), чтобы определить, занимают ли операции MAPI больше времени, чем это должно быть на исправном сервере Exchange Server.

В частности, анализатор рекомендаций Exchange Server просматривает данные ExMon на наличие запрошенных пользователями операций MAPI Restrict, выполнение которых заняло более 30 секунд.

Операция MAPI Restrict используется клиентскими приложениями для выбора элементов, отвечающих определенным условиям. Сервер создает представление в виде таблицы со связанными условиями, которые называется ограничением. Если представление с таким ограничением уже существует, сервер использует при обработке запроса пользователя существующее представление. При использовании существующего представления сервер тратит меньше времени, чем при создании нового представления. По умолчанию в хранилище кэшируется только 11 представлений для каждой папки. Если сервер получает запрос на создание двенадцатого представления, он удаляет самое старое кэшированное представление и создает новое. Использование предоставлений требует дополнительных вычислительных ресурсов для всех действий с элементами.

Если анализатор рекомендаций Exchange Server определит, что запущенная пользователем операция MAPI Restrict заняла более 30 секунд, отображается сообщение об ошибке.

Операция MAPI Restrict, длящаяся более 30 секунд, не обязательно является ошибкой. Если один или несколько пользователей сталкиваются с частыми задержками, или задержки приводят к снижению удобства работы с электронной почтой, это может означать, что пользовательское приложение вызывает создание новых представлений.

Для устранения этой ошибки следует опросить пользователя, сталкивающегося с задержками, и выяснить следующее:

  • Насколько велико количество элементов в папках.

  • Какие приложения применяет пользователь.

Для устранения проблемы выполните следующие действия.

  • Предложите пользователям, у которых в папках хранится много элементов, уменьшить число элементов в каждой папке. Рекомендуется, чтобы число элементов в папках «Входящие», «Календарь», «Отправленные» и «Удаленные» не превышало 5000.

  • Настройте клиентские компьютеры, испытывающие наибольшие задержки, на использование режима кэширования Exchange. Обратите особое внимание на клиентские компьютеры с задержками операций Restrict, SetColumns и FindRow. Режим кэширования Exchange позволяет избавить сервер от большей части избыточного трафика RPC.

  • Следуйте инструкциям блога группы Exchange, указанного в следующем разделе, для включения трассировки журнала событий. Затем запускайте пользовательские приложения по одному, чтобы установить, какое из приложений вызывает задержку.

  • Попробуйте закрыть все приложения. Затем запускайте их по одному, чтобы установить, какое из них вызывает проблему. Следует навсегда закрыть все приложения, вызывающие проблемы, или обновить эти приложения для снижения нагрузки до приемлемого уровня, если верно любое из следующих двух условий:

    • Приложение не требуется для бизнеса.

    • Для приложения выпущено обновление.

Примечание.
Некоторые приложения могут значительно увеличить загрузку на сервер и без запуска множества операций MAPI. Причина заключается в том, что для некоторых операций требуется больше ресурсов системы, чем для других. Даже небольшое увеличение количества ресурсоемких операций может привести к значительному повышению нагрузки на сервер. В отчетах ExMon пользователи могут вызывать значительную загрузку ЦП без запуска большого числа операций MAPI.

Также следует учесть, что при наличии ограничения производительности (обычно причиной ограничения является недостаточная скорость работы дисков или ЦП) увеличиваются задержки операций Restrict.

Дополнительные сведения

Дополнительные сведения об операции MAPI Restrict см. в блоге группы Microsoft Exchange «Putting the Restrictions on Restrictions» (http://go.microsoft.com/fwlink/?linkid=55098).

Примечание.
Содержимое и URL-адрес каждого блога могут изменяться без предварительного уведомления.

Дополнительные сведения см. в следующих ресурсах сервера Exchange Server:

  • «Performance and Scalability Guide for Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=47576) (Руководство по управлению производительностью и масштабируемостью Exchange Server 2003)

  • «Troubleshooting Microsoft Exchange Server Performance» (http://go.microsoft.com/fwlink/?LinkId=47588) (Устранение неполадок, связанных с производительностью сервера Microsoft Exchange Server)

  • «Exchange Server 2003 Performance: 10 Things to Think About» (http://go.microsoft.com/fwlink/?LinkId=56460) (Производительность Exchange Server 2003 — 10 вопросов к размышлению)

  • Статья 905803 базы знаний Майкрософт «Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803) (Низкая производительность Outlook при работе с папкой, содержащей множество элементов, на сервере Exchange Server 2003 или Exchange 2000 Server)


Отсутствует файл MAD.EXE
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы проверить наличие нескольких основных двоичных файлов Exchange:

  • Exres.dll

  • Gapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»)

  • Mapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если средство анализатора сервера Exchange обнаруживает, что отсутствует один или несколько из этих файлов, выводится сообщение об ошибке. Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если ошибку не удалось устранить, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в привод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие нажмите кнопку с указывающей вниз стрелкой рядом с узлом Microsoft Exchange, выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2000 см. на веб-узле загружаемых ресурсов Exchange Server 2000 (http://go.microsoft.com/fwlink/?LinkId=33457).


Номер порта MAD NSPI ниже 5000
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра, чтобы определить значение параметра TCP/IP NSPI Port для службы системного помощника Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

Если анализатор сервера Exchange обнаруживает, что значение TCP/IP NSPI Port меньше 5000 (десятичное), на экран выводится предупреждение.

В случае, если необходимо установить статическое значение параметра TCP/IP NSPI Port, рекомендуется установить значение, чуть превышающее 5000. Назначение статических номеров портов ниже 5000 может привести к конфликту с портами других процессов и завершиться сбоем процесса службы системного помощника Microsoft Exchange.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы установить значение параметра реестра для порта TCP/IP NSPI

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Дважды щелкните раздел TCP/IP NSPI Port и установите в поле Значение целое значение, чуть превышающее 5000 (десятичное).

  4. Закройте редактор реестра.

  5. Перезапустите службу системного помощника Microsoft Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об ограничениях портов см. в статье 194952 базы знаний, посвященной ограничениям статически сопоставляемых портов, используемых для сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952)


Порт MAD RFR был переопределен вручную
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы выявить, было ли вручную переопределено значение порта для порт ссылки на каталог системного помощника Microsoft Exchange, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

Если анализатор сервера Exchange обнаруживает, что присутствует запись TCP/IP Port , выводится сообщение о том, что конфигурация отличается от заданной по умолчанию.

Наиболее распространенная причина настройки этого значения — включение клиентов MAPI для подключения к серверу Exchange, который находится по другую сторону межсетевого экрана. Этот сценарий содержит процедуру открытия нескольких портов на межсетевом экране для предоставления клиентам Microsoft Office Outlook® 2003 возможности подключения с помощью MAPI к серверу Exchange, как правило, через Интернет. Такая конфигурация поддерживается. Дополнительные сведения о настройке клиентов MAPI для подключения к Exchange через межсетевой экран см. в статье 270836 базы знаний Майкрософт «Exchange 2000 and Exchange 2003 Static Port Mappings» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836) (Сопоставление статических портов Exchange 2000 и Exchange 2003). Если этот сценарий не используется, данный раздел реестра следует удалить.

Рекомендуемое развертывание для использования Outlook в режиме MAPI с целью подключения к серверу Exchange через Интернет — это использование удаленных вызовов процедур через HTTP-функции, доступные в Windows Server™ 2003, Exchange Server 2003, Outlook 2003 и Windows® XP Professional. Режим MAPI ранее назывался «Корпоративным» режимом или режимом «Рабочей группы».

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы удалить значение реестра для порта TCP/IP

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Удалите значение реестра с названием TCP/IP Port.

  4. Закройте редактор реестра и повторно запустите службу системного помощника Microsoft Exchange.

Чтобы развернуть удаленные вызовы процедур через HTTP

  1. Изучите документ Exchange Server 2003 RPC over HTTP Deployment Scenarios (http://go.microsoft.com/fwlink/?linkid=47577) (Cценарии развертывания удаленных вызовов процедур Exchange Server 2003 через HTTP).

  2. Изучите статью 833401 базы знаний Майкрософт «How to configure RPC over HTTP on a single server in Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401) (Инструкции по настройке удаленных вызовов процедур через HTTP на одиночном сервере в Exchange Server 2003).

  3. Изучите статью 827330 базы знаний Майкрософт «How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330) (Инструкции по устранению в Office Outlook 2003 проблем подключения при передаче удаленных вызовов процедур клиента через HTTP).

  4. Изучите веб-презентацию службы поддержки Майкрософт «Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134) (Использование Microsoft Exchange через Интернет (RPC/HTTP) с помощью средств Microsoft Office Outlook 2003).

Перед редактированием реестра, а также для получения инструкций по изменению реестра изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).


Для порта MAD RFR установлено значение менее 5000
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server читает следующий параметр реестра для определения параметра TCP/IP Port для службы Microsoft Exchange System Attendant:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

Если средством анализа Exchange Server будет обнаружено, что значение параметра TCP/IP Port меньше 5000 (десятичное число), появится предупреждение.

Если для параметра TCP/IP Port необходимо установить статическое значение, рекомендуется установить значение немного больше 5000. Назначение статических номеров порта менее 5000 может вызвать конфликт порта с другим процессом и привести к сбою процесса службы Microsoft Exchange System Attendant.

Важно!
В этой статье содержатся сведения о редактировании реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Для получения сведений о восстановлении реестра см. разделе «Восстановление реестра» справочной системы файла Regedit.exe или Regedt32.exe.

Для установки раздела порта TCP/IP в реестре

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Дважды щелкните раздел TCP/IP Port и установите для поля Value data целое число немного больше 5000 (десятичное число).

  4. Закройте редактор реестра.

  5. Перезагрузите службу Microsoft Exchange System Attendant, чтобы изменения вступили в силу.

Перед началом редактирования реестра, а также для получения сведений о редактировании реестра см. статью 256986 базы знаний корпорации Майкрософт, посвященную описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о параметрах порта см. в статье 194952 базы знаний «XADM: Статически сопоставленные ограничения порта для Exchange Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952).


Файл MAPI32.DLL отсутствует в папке «bin»
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы проверить наличие нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»),

  • Mapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange обнаружит отсутствие одного или нескольких из перечисленных выше файлов, на экран будет выведено сообщение об ошибке. Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если эта ошибка продолжает оставаться, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


В папке system32 отсутствует файл MAPI32.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server запрашивает класс CIM_Datafile инструментария Microsoft Windows® Management Instrumentation (WMI), чтобы проверить наличие некоторых основных двоичных файлов Exchange:

  • Exres.dll

  • Gapi32.dll (проверяется в папке System32 и в папке \Exchsrvr\bin)

  • Mapi32.dll (проверяется в папке System32 и в папке \Exchsrvr\bin folder)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если средство анализа Exchange Server обнаружит, что одного или нескольких файлов недостает, появится сообщение об ошибке. Чтобы исправить ошибку, установите последний пакет обновлений или накопительный пакет обновлений Exchange. Если ошибка останется, запустите установку Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Данные пользователей и данные настройки не удаляются и не сбрасываются. При переустановке сервера Exchange необходимо также переустановить все установленные пакеты обновлений и исправления.

Переустановка Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором нужно переустановить Exchange. Вставьте компакт-диск Exchange 2000 Server или Exchange Server 2003 в дисковод CD-ROM.

  2. В меню Пуск выберите пункт Выполнить, введите <диск>:\setup\i386\setup, где <диск> — буква дисковода CD-ROM.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите Далее.

  4. На странице Лицензионное соглашение прочтите лицензионное соглашение. Если вы согласны с его условиями, нажмите кнопки Я согласен и Далее.

  5. На странице Идентификация продукта введите 25-значный ключ продукта и нажмите Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь стрелкой раскрывающегося списка рядом с узлом Microsoft Exchange и выберите Переустановить, затем нажмите кнопку Далее.

Для получения дополнительных сведений о последних пакетах обновлений Exchange Server 2003, накопительных пакетах обновлений и надстройках см. раздел загрузок для Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Для получения дополнительных сведений о последних пакетах обновлений Exchange 2000 Server, накопительных пакетах обновлений и надстройках см. раздел загрузок для Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=25097).


Отсутствует файл EXPROX.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает класс инструментария управления Windows (WMI) CIM_Datafile, чтобы проверить наличие нескольких основных двоичных файлов Exchange:

  • Exres.dll

  • Gapi32.dll (проверяется в папке System32 и в папке \Exchsrvr\bin)

  • Mapi32.dll (проверяется в папке System32 и в папке \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если средство анализатора сервера Exchange обнаруживает, что отсутствует один или несколько из этих файлов, выводится сообщение об ошибке. Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если ошибку не удалось устранить, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в привод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если вы согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Отсутствует файл MAPISP32.EXE
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить наличие нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange определяет, что отсутствует один или несколько файлов, отображается сообщение об ошибке. Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если это не устранит ошибку, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте компакт-диск Exchange 2000 Server или Exchange Server 2003 в устройство чтения компакт-дисков.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — устройство чтения компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если вы согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-значный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=33457).


Наибольший размер кэша ESE больше 1,2 ГБ
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-02-13

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов о показаниях счетчиков производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности получает данные со счетчика производительности DataBase Cache Size (DBCacheSize) объекта с оцениваемой производительностью DataBase для анализа данных о производительности.

Счетчик производительности DataBase Cache Size (DBCacheSize) отражает текущий объем кэша, используемый хранилищем. Если анализатор сервера Exchange определяет, что значение счетчика производительности DataBase Cache Size (DBCacheSize) должно быть больше, чем 307200 (1,2 ГБ), анализатор сервера Exchange выводит на экран сообщение об ошибке.

Эта ошибка указывает на то, что значение атрибута msExchESEParamCacheSizeMax для объекта банка данных Microsoft Exchange (MSExchangeIS) вышло за пределы наибольшего рекомендуемого значения, равного 307200 (1,2 ГБ).

Кэш базы данных хранилища также называется буфером ESE (модуля расширяемого хранилища). Он кэширует транзакции базы данных перед их фиксацией в базе данных.

В Exchange 2000 Server большая область виртуальной памяти, используемой программой Store.exe, выделяется для буфера ESE. В Exchange 2000 Server для этого буфера используется жестко закодированная память объемом по умолчанию 858 МБ. В Exchange Server 2003 объем памяти, выделяемой для буфера ESE, зависит от наличия переключателя /3GB в файле Boot.ini. Если переключатель /3GB присутствует, буфер ESE настраивается на значение, равное 896 МБ. Если переключатель /3GB отсутствует, буфер ESE настраивается значение, равное 576 МБ. Хотя автонастройка всегда удобна, может возникнуть необходимость в отмене автонастройки и задании вручную значения, более подходящего для конкретной среды.

Хотя можно настроить это значение на любое число таким способом, что фактически выделенная память кратна 8192 байтам, рекомендуется использовать лишь значение из следующей таблицы.

Рекомендуемое значение | Выделенная память | Комментарии
147456 | 576 МБ | Это рекомендуемый минимум памяти. Не устанавливайте меньшее значение. Это значение подходит для серверов с ограниченной виртуальной памятью и для компьютеров Exchange Server 2003 под управлением Microsoft Windows® 2000 Server. Здесь переключатель /3GB не поддерживается. Это значение является также значением по умолчанию для систем, в которых не используется переключатель /3GB.
196608 | 768 МБ | Это значение рекомендуется для серверов с большими объемами виртуальной памяти, которые часто регистрируют в журнале событие 9582.
219726 | 858 МБ | Это значение по умолчанию в Exchange 2000 Server. Это хорошее значение для использования в системах, обновляемых на месте и имеющих большой объем виртуальной памяти.
229376 | 896 МБ | Это значение является значением по умолчанию в Exchange Server 2003 и хорошо подходит для использования в новых системах, если присутствие событий 9582 в журнале событий приложений не указывает на иное.
307200 | 1,2 ГБ | Это наибольшее значение, которое можно установить. Это значение должно использоваться только на системах с физической памятью объемом 2 ГБ и более.

Прежде чем изменить это значение, необходимо проконтролировать объем виртуальной памяти, потребляемой процессом Store.exe. Это можно сделать путем наблюдения за рабочим объектом процесса в Microsoft Windows. В системах с переключателем /3GB счетчик Virtual Bytes для экземпляра Store.exe объектаProcess должен быть меньше 2,8 ГБ. В системах без переключателя /3GB счетчик Virtual Bytes для экземпляра Store.exe объектаProcess должен быть меньше 1,8 ГБ. Если указанные значения превышают указанные объемы , возможно, потребуется уменьшить значение msExchESEParamCacheSizeMax. Если значения меньше указанных объемов, может возникнуть желание увеличить значение msExchESEParamCacheSizeMax.

Внимание!
Могут возникнуть серьезные проблемы, если некорректно изменить атрибуты объектов Active Directory при использовании интерфейса ADSI , средства LDP (ldp.exe) или другого клиента протокола LDAP версии 3. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Чтобы настроить атрибут msExchESEParamCacheSizeMax

  1. Откройте редактор Active Directory, например, ADSI Edit.

  2. Дважды щелкните контейнер Конфигурация.

  3. Разверните узел CN=Службы.

  4. Разверните узел CN=Microsoft Exchange.

  5. Разверните узел CN=<Имя организации Exchange>.

  6. Разверните узел CN=Административные группы.

  7. Разверните узел CN=<Имя административной группы>.

  8. Разверните узел CN=Серверы.

  9. Разверните узел CN=<Имя сервера Exchange>.

  10. Щелкните правой кнопкой мыши CN=InformationStore и затем щелкните Свойства.

  11. Сделайте прокрутку в поле атрибутов и затем дважды щелкните msExchESEParamCacheSizeMax.

  12. В поле значений введите значение, которое предполагается установить. Воспользуйтесь таблицей, чтобы определить оптимальное значение для своей системы.

  13. Нажмите кнопку OK, а затем еще раз нажмите кнопку OK.

  14. Закройте редактор Active Directory, а затем перезапустите службу «Банк данных Microsoft Exchange», чтобы изменения вступили в силу.

Дополнительные сведения об оптимизации использования памяти см. в статье "Optimizing Memory Usage for Exchange Server 2003" (Оптимизация использования памяти для Exchange Server 2003) раздела Планирование системы сообщений приложения Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

Дополнительные сведения об атрибуте msExchESEParamCacheSizeMax см. в базе знаний Майкрософт в статье 266768 "How to modify the Store Database maximum cache size in Exchange 2000 Server" (Как изменить наибольший размер кэша базы данных хранилища) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768).


Ограничение максимального количество получателей было изменено
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить, был ли изменен атрибут msExchRecipLimit относительно своего значения по умолчанию. В атрибуте msExchRecipLimit хранится значение глобального максимального количества получателей для каждого сообщения электронной почты. По умолчанию значение атрибута msExchRecipLimit равно 5000. Если анализатор сервера Exchange обнаружит, что значение атрибута msExchRecipLimit равно 5000, анализатор сервера Exchange отобразит сообщение о нестандартной конфигурации.

Глобальное ограничение максимального количества получателей применимо ко всей организации Exchange. Значение атрибута msExchRecipLimit ограничивает значение получателей одного сообщения электронной почты. Глобальное ограничение максимального количества получателей влияет на системные и несистемные сообщения. Системные сообщения включают сообщения о репликации общих папок.

Примечание.
Также можно установить ограничения количества получателей для отдельных пользователей с помощью оснастки «Active Directory — пользователи и компьютеры». Параметры, настроенные для каждого пользователя, имеют приоритет над глобальными параметрами. По умолчанию ограничение количества получателей для каждого пользователя настраивается на использование глобального ограничения количества получателей.
Примечание.
На виртуальном SMTP-сервере можно установить ограничения количества получателей каждого сообщения для сообщений, которые получены от пользователей Интернета. Это ограничение отличается от глобального ограничения максимального количества получателей и от ограничения количества получателей для каждого пользователя. Глобальное ограничение максимального количества получателей и ограничение количества получателей для каждого пользователя ограничивают количество получателей, которым пользователь Exchange может отправить сообщение.
Чтобы вернуть значение по умолчанию для глобального ограничения максимального количества получателей

  1. Откройте системный диспетчер Exchange.

  2. В левой области разверните Глобальные параметры.

  3. Щелкните правой кнопкой мыши Доставка сообщения и в контекстном меню выберите Свойства.

  4. На вкладке По умолчанию под разделом Ограничения получателей щелкните Максимальное количество получателей и введите 5000.

  5. Перезапустите службу банка данных Microsoft Exchange.

Дополнительные сведения об установке ограничений получателей и настройке клиентов веб-клиента Microsoft Office Outlook® см. на веб-странице, посвященной параметрам веб-клиента Outlook, относящимся к управлению S/MIME, в руководстве по безопасности сообщений Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47574).

Дополнительные сведения об истории ограничения максимального количества получателей см. в блоге Exchange «Me Too!» (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=41848).


Слишком высокое ограничение максимального количества получателей
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить, превышает ли значение разделаmsExchRecipLimit для сообщений 7500. Если анализатор обнаружит, что значение атрибута msExchRecipLimit выше 7500, он отобразит предупреждение.

В атрибуте msExchRecipLimit хранится значение глобального максимального количества получателей для каждого сообщения электронной почты. Это значение ограничивает количество получателей для отдельного сообщения электронной почты. Это значение также влияет на системные и несистемные сообщения. Системные сообщения включают сообщения о репликации общих папок. По умолчанию значение атрибута msExchRecipLimit равно 5000.

Если значение атрибута msExchRecipLimit превышает 7500, существует риск возникновения неполадок, вызванных сообщениями с увеличенным количеством получателей.

Примечание.
Также можно установить ограничения количества получателей для отдельных пользователей с помощью оснастки «Active Directory — пользователи и компьютеры». Параметры, настроенные для каждого пользователя, имеют приоритет над глобальными параметрами. По умолчанию ограничение количества получателей для каждого пользователя настраивается на использование глобального ограничения количества получателей.
Примечание.
На виртуальном SMTP-сервере можно установить ограничения количества получателей каждого сообщения для сообщений, которые получены от пользователей Интернета. Это ограничение отличается от глобального ограничения максимального количества получателей и от ограничения количества получателей для каждого пользователя. Глобальное ограничение максимального количества получателей и ограничение количества получателей для каждого пользователя ограничивают количество получателей, которым пользователь Exchange может отправить сообщение.
Чтобы вернуть значение по умолчанию для глобального ограничения максимального количества получателей

  1. Откройте системный диспетчер Exchange.

  2. В левой области разверните Глобальные параметры.

  3. Щелкните правой кнопкой мыши Доставка сообщения и в контекстном меню выберите Свойства.

  4. На вкладке По умолчанию под разделом Ограничения получателей щелкните Максимальное количество получателей и введите 5000.

  5. Перезапустите службу банка данных Microsoft Exchange.

Дополнительные сведения об установке ограничений получателей и настройке клиентов веб-клиента Microsoft Office Outlook® см. на веб-странице, посвященной параметрам веб-клиента Outlook, относящимся к управлению S/MIME, в руководстве по безопасности сообщений Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47574).

Дополнительные сведения об истории глобального ограничения максимального количества получателей см. в блоге Exchange «Me Too!» (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=41848).


Слишком низкое ограничение максимального количества получателей
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить, меньше ли значение msExchRecipLimit для сообщений, чем количество хранилищ общих папок в организации Exchange. Если анализатор сервера Exchange обнаруживает, что значение атрибута msExchRecipLimit меньше, чем количество хранилищ общих папок, анализатор сервера Exchange выводит на экран сообщение об ошибке.

В атрибуте msExchRecipLimit хранится значение глобального максимального количества получателей для каждого сообщения электронной почты. Это значение ограничивает количество получателей для отдельного сообщения электронной почты. Это значение также влияет на системные и несистемные сообщения. Системные сообщения включают сообщения о репликации общих папок. По умолчанию значение атрибута msExchRecipLimit равно 5000. Если значение атрибута msExchRecipLimit меньше, чем количество хранилищ общих папок в организации Exchange, возникнут неполадки с репликацией иерархии общих папок.

Примечание.
Также можно установить ограничения количества получателей для отдельных пользователей с помощью оснастки «Active Directory — пользователи и компьютеры». Параметры, настроенные для каждого пользователя, имеют приоритет над глобальными параметрами. По умолчанию ограничение количества получателей для каждого пользователя настраивается на использование глобального ограничения количества получателей.
Примечание.
На виртуальном SMTP-сервере можно установить ограничения количества получателей каждого сообщения для сообщений, которые получены от пользователей Интернета. Это ограничение отличается от глобального ограничения максимального количества получателей и от ограничения количества получателей для каждого пользователя. Глобальное ограничение максимального количества получателей и ограничение количества получателей для каждого пользователя ограничивают количество получателей, которым пользователь Exchange может отправить сообщение.
Чтобы вернуть значение по умолчанию для глобального ограничения максимального количества получателей

  1. Откройте системный диспетчер Exchange.

  2. В левой области разверните Глобальные параметры.

  3. Щелкните правой кнопкой мыши Доставка сообщения и в контекстном меню выберите Свойства.

  4. На вкладке По умолчанию в разделе Ограничения получателей щелкните Максимальное количество получателей и убедитесь, что установленное значение не меньше, чем количество хранилищ общих папок в организации Exchange.

  5. Перезапустите службу банка данных Microsoft Exchange.

Дополнительные сведения об установке ограничений получателей и настройке клиентов веб-клиента Microsoft Office Outlook® см. на веб-странице, посвященной параметрам веб-клиента Outlook, относящимся к управлению S/MIME, в руководстве по безопасности сообщений Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47574).

Дополнительные сведения об истории глобального ограничения максимального количества получателей см. в блоге Exchange «Me Too!» (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=41848).


Раздел MaxUserPort отсутствует, или его значение отличается от значения по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-03-23

Анализатор Microsoft Exchange опрашивает службу каталогов Active Directory для определения значения атрибута serialNumber для всех объектов с классом объектов msExchExchangeServer. Если строковое значение содержит выражение «Version 5.5», на компьютере выполняется Exchange Server 5.5. Если строковое значение содержит выражение «Version 6.0», на компьютере выполняется Exchange 2000 Server. Если строковое значение содержит выражение «Version 6.5», на компьютере установлен сервер Exchange Server 2003. Если строковое значение содержит выражение «Version 8.0», на компьютере установлен сервер Exchange Server 2007.

Анализатор Exchange считывает следующий раздел реестра для каждого обнаруженного сервера Exchange Server 2007, чтобы определить, присвоено ли разделу MaxUserPort значение по умолчанию (60000):

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Раздел MaxUserPort задает максимальный номер порта, доступный для протокола TCP, когда приложение запрашивает у системы доступный пользовательский порт.

По умолчанию операционная система Microsoft Windows Server 2003 устанавливает для раздела MaxUserPort значение 5000. Microsoft Windows 2000 не добавляет значение MaxUserPort в реестр. Однако это значение можно добавить вручную. В Windows Server 2003 и Windows 2000 Server серверы Exchange Server 2003 и Exchange Server 2007 устанавливают значение по умолчанию 60000. Exchange 2000 Server не устанавливает это значение.

Рекомендуется устанавливать для раздела MaxUserPort значение 60000. Если установить для раздела MaxUserPort значение меньше 60000, это может привести к появлению предупреждения прокси-интерфейса NSPI, такого как событие 9040. Событие 9040 документировано в приведенной ниже таблице.

Код события | 9040
Категория события | Прокси-интерфейс NSPI
Источник события | MSExchangeSA
Тип события | Предупреждение
Описание события | При получении пакета произошла ошибка прокси-интерфейса NSPI. Не работает либо контроллер домена назначения, либо сеть, либо клиент. Подсистема Winsock возвратила ошибку: [0x2746]. Получивший эту ошибку канал закрыт.
Важно!
Этот раздел содержит сведения об изменении реестра. Перед изменением реестра убедитесь, что знаете, как восстановить его в случае возникновения проблем. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы устранить это предупреждение, выполните указанные ниже действия.

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

  3. Дважды щелкните раздел MaxUserPort, введите в поле Значение значение 60000 (десятичное) и нажмите кнопку ОК.

  4. Чтобы изменения вступили в силу, закройте редактор реестра и перезагрузите компьютер.

Сведения о внесении изменений в реестр см. в статье 256986 базы знаний Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986). Изучите эту статью перед началом изменения реестра.

Данная проблема связана с проблемой анализатора Раздел TcpTimedWaitDelay отсутствует, или его значение отличается от значения по умолчанию.

Дополнительные сведения о влиянии разделов реестра MaxUserPort и TcpTimedWaitDelay см. в разделе «Протокол TCP» комплекта ресурсов для Windows 2000 (http://go.microsoft.com/fwlink/?LinkId=85654) (на английском языке).


Значение MaxUserPort слишком мало
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server считывает следующий параметр реестра для определения максимального номера временного порта TCP:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\MaxUserPort

Временный порт - порт, который используется короткое время.

Если средство анализа Exchange Server находит, что значение параметра реестра MaxUserPort менее 50000, отображается предупреждение.

Значение MaxUserPort указывает максимальный номер порта, доступного для протокола TCP, когда приложение запрашивает у системы доступный пользовательский порт. Обычно временные порты получают номера от 1024 до 5000.

По умолчанию Microsoft Windows Server 2003 устанавливает значение MaxUserPort равным 5000. Microsoft Windows 2000 не добавляет в реестр значение MaxUserPort. Можно вручную добавить в реестр значение MaxUserPort. Однако в Windows Server 2003 и Windows 2000 Server программа Exchange Server 2003 устанавливает значение по умолчанию равным 60000. Exchange 2000 Server не устанавливает это значение.

Рекомендуется устанавливать значение MaxUserPort равным 60000. Если вы установили значение параметра MaxUserPort меньше 60000, может появится предупреждение интерфейса прокси Name Service Provider Interface (NSPI), такое как Event 9040. Событие Event 9040 документировано в следующей таблице.

Идентификатор события | 9040
Категория события | NSPI Proxy
Источник события | MSExchangeSA
Тип события | Предупреждение
Описание события | NSPI Proxy обнаружена ошибка при получении пакета. Контроллер домена назначения, сеть или клиент, возможно, не функционируют. Подсистема Winsock возвратила ошибку: [0x2746]. Канал, получивший эту ошибку, будет закрыт.

Для устранения этого предупреждения установите значение параметра реестра MaxUserPort равным 60000.

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неполадки. Для получения сведений о восстановлении реестра см. раздел «Восстановление реестра» справочной системы файла Regedit.exe или Regedt32.exe.
Устранение этого предупреждения

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел: HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

  3. Дважды щелкните MaxUserPort, установите значения поля Значение как ea60 (шестнадцатеричное число), затем нажмите кнопку OK.

  4. Выйдите из редактора реестра и перезагрузите компьютер для вступления изменений в силу.

Перед правкой реестра, а также для получения сведений о правке реестра см. статью 256986 базы знаний корпорации Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Отсутствует файл MDBSZ.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server запрашивает класс CIM_Datafile инструментария Microsoft WindowsManagement Instrumentation (WMI) для проверки наличия некоторых двоичных файлов ядра Exchange:

  • Exres.dll

  • Gapi32.dll (проверяется в папках System32 и \Exchsrvr\bin)

  • Mapi32.dll (проверяется в папках System32 и \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если средство анализа Exchange Server обнаруживает отсутствие одного или нескольких этих файлов, появляется сообщение об ошибке. Для устранения этой ошибки установите последний пакет обновлений или обновление вашей версии Exchange. Если ошибка сохраняется, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске установки в режиме переустановки устанавливаются только двоичные файлы. Пользовательские данные и настройки при этом не удаляются и не сбрасываются. При переустановке Exchange Server также необходимо переустанавливать любые установленные пакеты обновлений и обновления Exchange.

Переустановка Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором нужно переустановить Exchange. Вставьте диск Exchange 2000 Server или Exchange Server 2003 в привод компакт-дисков.

  2. В меню Пуск выберите Выполнить, затем наберите <диск>:\setup\i386\setup, где <диск> - буква дисковода CD-ROM.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение прочтите соглашение. Если вы согласны с условиями, нажмите кнопку Согласен, затем Далее.

  5. На странице Идентификация продукта введите 25-значный код продукта, затем нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие с помощью стрелки раскрывающегося списка справа от узла Microsoft Exchange выберите Переустановить, затем нажмите кнопку Далее.

Для получения дополнительных сведений о последних пакетах обновлений Exchange Server 2003, обновлениях и дополнениях см. раздел «Загрузки для Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=25097).

Для получения дополнительных сведений о последних пакетах обновлений Exchange 2000 Server см. раздел «Загрузки для Exchange 2000 Server» (http://go.microsoft.com/fwlink/?LinkId=33457).


Объект системного монитора Memory недоступен
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Available Mbytes объекта системного монитора Memory для анализа данных о производительности. Если данный счетчик не возвращает допустимые данные, выводится базовое сообщение.

Если допустимые данные не возвращаются модулем сбора данных о производительности, действует одно из сочетаний следующих условий:

  • Объект системного монитора Memory отключен.

  • Объект системного монитора Memory отсутствует или поврежден.

  • Для анализатора сервера Exchange не назначены разрешения, необходимые для получения доступа к объектам системного монитора.

Первые два условия могут возникнуть в том случае, если реестр поврежден определенными расширяемыми счетчиками или изменен программами, основанными на классах инструментария управления Windows (WMI).

Перед выполнением данной процедуры убедитесь, что анализатору сервера Exchange назначены соответствующие разрешения. Дополнительные сведения о разрешениях, требуемых для выполнения анализатора сервера Exchange, см. в справочной документации анализатора сервера Exchange. Чтобы открыть справку, откройте анализатор сервера Exchange и нажмите клавишу F1.

Чтобы устранить эту ошибку

  1. Убедитесь, что включен объект системного монитора Memory:

    1. Загрузите и установите средство списка расширяемых счетчиков производительности (Exctrlst.exe). Средство Exctrlst.exe можно загрузить на странице Exctrlst.exe: Extensible Performance Counter List (http://go.microsoft.com/fwlink/?LinkId=34436) (Exctrlst.exe: список расширяемых счетчиков производительности).

    2. Откройте окно средства Exctrlst.exe, щелкните Sort Order, а затем — Service.

    3. Найдите службу, сведения о которой поставляет данный объект системного монитора и проверьте, установлен ли флажок Performance Counters Enabled.

      Если флажок Performance Counters Enabled не установлен, установите его, а затем перезапустите связанную с нужными счетчиками производительности службу, чтобы проверить, что эти счетчики производительности работоспособны. Если счетчики производительности не работоспособны или флажок Performance Counters Enabled уже установлен, перейдите к выполнению шага 2.

  2. Повторно создайте отсутствующие или поврежденные счетчики производительности в соответствии с инструкциями статьи 300956 базы знаний Майкрософт «How to manually rebuild Performance Counter Library values» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) (Инструкции по ручному созданию значений библиотеки счетчиков производительности).

  3. Если после выполнения процедуры, указанной в этой статье базы знаний, проблема не будет устранена, следует переустановить операционную систему Windows в режиме Восстановление, а затем применить последние пакеты обновления Windows.


Объект MSExchangeDSAccess наблюдения за производительностью процессов недоступен
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов о показаниях счетчиков производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности получает данные со счетчика производительности LDAP Read Time объекта с оцениваемой производительностью MSExchangeDSAccess для анализа данных о производительности. Если счетчик не возвращает достоверных данных, анализатор сервера Exchange выводит на экран сообщение с базовыми показателями.

Если модуль сбора данных о производительности не возвращает достоверных данных, будет верна любая комбинация следующих причин:

  • Объект MSExchangeDSAccess наблюдения за производительностью отключен.

  • Объект MSExchangeDSAccess наблюдения за производительностью отсутствует или поврежден.

  • Анализатор сервера Exchange не имеет соответствующих разрешений на доступ к объектам наблюдения за производительностью.

Первые два условия могут возникнуть, если определенные расширяемые счетчики повредили реестр, или если программы на основе инструментария управления Microsoft Windows® Management Instrumentation (WMI) изменили реестр. В следующих процедурах объясняется как устранить первые две причины. Перед выполнением данной процедуры проверьте, чтобы анализатор сервера Exchange имел соответствующие разрешения.

Дополнительные сведения о разрешениях, необходимых для работы анализатора сервера Exchange, см. в документации справки, входящей в состав анализатора сервера Exchange. Для вызова справки откройте анализатор сервера Exchange и нажмите клавишу F1.

Чтобы устранить эту ошибку

  1. Проверьте, чтобы объект MSExchangeDSAccess наблюдения за производительностью был включен:

    1. Загрузите и установите средство расширяемого списка счетчиков производительности (Exctrlst.exe). Можно загрузить Exctrlst.exe на Exctrlst.exe: Расширяемый список счетчиков производительности (http://go.microsoft.com/fwlink/?LinkId=46440).

    2. Откройте Exctrlst.exe, щелкните Порядок сортировки и затем щелкните Служба.

    3. Найдите службу, для которой объект наблюдения за производительностью служит источником данных, и проверьте, чтобы был установлен флажок Счетчики производительности включены.

      Если флажок Счетчики производительности включены не установлен, установите этот флажок и перезапустите службу, связанную с данными счетчиками производительности, чтобы проверить их исправность. Если счетчики производительности неисправны, или если флажок Счетчики производительности включены уже установлен, переходите к шагу 2.

  2. Перестройте отсутствующие или поврежденные счетчики производительности, как указано в базе знаний Microsoft в статье 300956, "How to manually rebuild Performance Counter Library values" (Инструкции по перестройке вручную значений библиотеки счетчиков производительности) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Если с помощью следующей статьи базы знаний не удается решить проблему, можно переустановить сервер Exchange в режим Восстановление и затем применить последние пакеты обновления сервера Exchange.


Объект системного монитора «MSExchangeIS Mailbox» недоступен
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчиков производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Send Queue Size объекта производительности MSExchangeIS Mailbox для анализа данных о производительности. Если от счетчика не удается получить правильные данные, анализатор сервера Exchange выводит базовое сообщение.

Если модулю сбора данных о производительности не удается получить правильные данные, истинна любая комбинация следующих условий:

  • Объект производительности MSExchangeIS Mailbox отключен.

  • Объект системного монитора MSExchangeIS Mailbox отсутствует или поврежден.

  • У анализатора сервера Exchange отсутствуют соответствующие разрешения для доступа к объектам производительности.

Первые два условия могут возникнуть, если реестр поврежден определенными расширяемыми счетчиками, или если реестр изменен программами, использующими WMI (Microsoft Windows® Management Instrumentation).

Перед выполнением процедуры убедитесь, что анализатор сервера Exchange обладает соответствующими разрешениями. Дополнительные сведения о разрешениях, необходимых для выполнения анализатора сервера Exchange, см. в справке анализатора сервера Exchange. Для доступа к справке откройте анализатор сервера Exchange и нажмите клавишу F1.

Устранение ошибки

  1. Убедитесь, что объект производительности MSExchangeIS Mailbox включен.

    1. Загрузите и установите список расширяемых счетчиков производительности (Exctrlst.exe). Можно загрузить Exctrlst.exe с веб-страницы Exctrlst.exe: Список расширяемых счетчиков производительности по адресу http://go.microsoft.com/fwlink/?LinkId=34436 (возможно, на английском языке).

    2. Откройте Exctrlst.exe, щелкните Порядок сортировки, а затем щелкните служба.

    3. Найдите службу, о которой сообщает данный объект производительности, и убедитесь, что флажок Счетчики производительности включены установлен.

      Если флажок Счетчики производительности включены не установлен, установите флажок, а затем перезапустите службу, связанную со счетчиками производительности, чтобы убедиться, что счетчики производительности работают. Если счетчики производительности не работают, или если флажок Счетчики производительности включены уже был установлен, перейдите к шагу 2.

  2. Перестройте отсутствующие или поврежденные счетчики производительности в соответствии со статьей 300956 базы знаний Майкрософт, посвященной перестройке значений библиотеки счетчиков производительности вручную, по адресу http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956 (возможно, на английском языке).

  3. Если действия, описанные в этой статье базы знаний, не решают проблему, понадобится переустановить сервер Exchange в режиме Восстановить, а затем установить новейшие пакеты обновлений сервера Exchange.


Объект монитора производительности MSExchangeIS недоступен
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-04-03

Средство анализа Microsoft® Exchange Server включает в средство сбора данных о производительности, используемое для опроса счетчиков производительности компьютеров, работающих с Exchange 2000 Server или Exchange Server 2003. Для анализа сведений о производительности средство сбора данных о производительности собирает показания счетчика производительности RPC Operations/sec объекта MSExchangeIS. Если счетчик не возвращает допустимые сведения, Exchange Server Analyzer отображает стандартное сообщение.

Если средство сбора данных о производительности не возвращает допустимые значения, выполняются любые из следующих условий:

  • Объект MSExchangeIS отключен.

  • Объект монитора производительности MSExchangeIS отсутствует или поврежден.

  • Средство анализа Exchange Server не имеет соответствующих разрешений на доступ к объектам производительности.

Первые два условия могут выполняться, если реестр поврежден несколькими расширяемыми счетчиками или программы, основанные на инструментарии Microsoft Windows® Management Instrumentation (WMI), изменили реестр. Перед запуском процедуры убедитесь, что у средства анализа Exchange Server есть соответствующие разрешения. Для получения дополнительных сведений о разрешениях, требуемых для запуска средства анализа Exchange Server Analyzer, обратитесь к справочной документации, поставляемой со средством анализа Exchange Server. Для просмотра справки откройте средство анализа Exchange Server Analyzer и нажмите клавишу F1.

Для исправления этой ошибки

  1. Убедитесь, что объект MSExchangeIS включен:

    1. Загрузите и установите средство Extensible Performance Counter List (Exctrlst.exe). Файл Exctrlst.exe может быть загружен по адресу Exctrlst.exe: Extensible Performance Counter List (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Откройте файл Exctrlst.exe, выберите Упорядочить, затем выберите Служба.

    3. Найдите службу, отчет для которой создает объект производительности, и убедитесь, что флажок Performance Counters Enabled установлен.

      Если флажок Performance Counters Enabled не установлен, установите флажок, затем перезапустите службу, связанную со счетчиками производительности, чтобы убедиться, что счетчики производительности работают. Если счетчики производительности не работают или флажок Performance Counters Enabled уже установлен, перейдите к шагу 2.

  2. Восстановите отсутствующие или поврежденные счетчики производительности в соответствии со статьей 300956 базы знаний Microsoft «Восстановление значений библиотеки счетчиков производительности вручную» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Если следование указаниям статьи базы знаний не решает проблему, следует переустановить Exchange Server в режиме Восстановление и установить последние пакеты обновлений Exchange Server.

Для получения дополнительных сведений об устранении неполадок при подключении Exchange Server Best Practices Analyzer Tool обратитесь к статье «Устранение неполадок при подключении Microsoft Exchange Server Best Practices Analyzer Tool» (http://go.microsoft.com/fwlink/?LinkId=56285).


Недоступен объект отслеживания производительности MSExchangeIS Public
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Send Queue Size объекта производительности MSExchangeIS Public для анализа данных о производительности. Если данный счетчик не возвращает допустимые данные, выводится базовое сообщение.

Если допустимые данные не возвращаются модулем сбора данных о производительности, действует одно из сочетаний следующих условий:

  • Объект производительности MSExchangeIS Public отключен.

  • Объект отслеживания производительности MSExchangeIS Public отсутствует или поврежден.

  • Для анализатора сервера Exchange не назначены разрешения, необходимые для получения доступа к объектам производительности.

Первые два условия могут возникнуть в том случае, если реестр поврежден определенными расширяемыми счетчиками или изменен программами, основанными на WMI-классах (Microsoft Windows® Management Instrumentation). Перед выполнением данной процедуры убедитесь, что анализатору сервера Exchange назначены соответствующие разрешения. Дополнительные сведения о разрешениях, требуемых для выполнения анализатора сервера Exchange, см. в справочной документации, включенной в анализатор сервера Exchange. Чтобы открыть справку, откройте анализатор сервера Exchange и нажмите клавишу F1.

Чтобы устранить эту ошибку

  1. Убедитесь, что включен объект производительности MSExchangeIS Public:

    1. Загрузите и установите средство списка расширяемых счетчиков производительности (Exctrlst.exe). Средство Exctrlst.exe можно загрузить на странице Exctrlst.exe: Extensible Performance Counter List (http://go.microsoft.com/fwlink/?LinkId=34436) (Exctrlst.exe: список расширяемых счетчиков производительности).

    2. Откройте окно средства Exctrlst.exe, щелкните Sort Order, а затем — Service.

    3. Найдите службу, сведения о которой поставляет данный объект производительности и проверьте, что установлен флажок Performance Counters Enabled.

      Если флажок Performance Counters Enabled не установлен, установите его, а затем перезапустите связанную с нужными счетчиками производительности службу, чтобы проверить, что эти счетчики производительности работоспособны. Если счетчики производительности не работоспособны или флажок Performance Counters Enabled уже установлен, перейдите к выполнению шага 2.

  2. Повторно создайте отсутствующие или поврежденные счетчики производительности в соответствии с инструкциями статьи 300956 базы знаний Майкрософт «How to manually rebuild Performance Counter Library values» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) (Инструкции по ручному созданию значений библиотеки счетчиков производительности).

  3. Если после выполнения процедуры, указанной в этой статье базы знаний, проблема не будет устранена, придется переустановить сервер Exchange в режиме Восстановление, а затем применить последние пакеты обновления для сервера Exchange.


Доступно обновление драйвера MSGINA.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-08-21

Чтобы определить версию операционной системы Microsoft Windows®, под управлением которой работает компьютер сервера Exchange, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Значение CurrentVersion, равное 4.0, означает, что сервер Exchange работает под управлением операционной системы Microsoft Windows NT® Server 4.0. Значение, равное 5.0, означает, что сервер Exchange работает под управлением операционной системы Windows 2000 Server. Значение, равное 5.2, означает, что сервер Exchange работает под управлением операционной системы Windows Server™ 2003.

Анализатор сервера Exchange также проверяет WMI-класс (Microsoft Windows® Management Instrumentation) Win32_OperatingSystem, чтобы определить значение ключа ServicePackMajorVersion.

Значение ключа ServicePackMajorVersion, равное 1, означает, что на сервере установлен пакет обновления 1 (SP1).

Наконец, анализатор сервера Exchange запрашивает WMI-класс CIM_Datafile, чтобы определить значение ключа Version для файла Msgina.dll.

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Сервер работает под управлением операционной системы Windows Server™ 2003 с пакетом обновления 1 (SP1).

  • Номер сборки файла Msgina.dll меньше, чем 5.2.3790.2525.

Эта ошибка указывает, что версия файла Msgina.dll, установленного на сервере, может быть причиной избыточного использования файла подкачки и снижения производительности.

Чтобы устранить эту проблему, получите обновление, указанное в базе знаний Майкрософт, в статье 905865, которая сообщает, что размеры работающих наборов всех процессов в сеансе консоли могут быть сокращены при использовании службы терминалов для входа или выхода на компьютере, функционирующем под управлением операционной системы Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905865).


Для параметра «APDU logging required» агента передачи сообщений (MTA) задано значение, отличное от значения по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить ее значение:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\APDU logging required

Если анализатор сервера Exchange обнаружит, что параметр APDU logging required существует и для него задано значение, отличное от 0, на экран выводится предупреждение о значении, отличном от значения по умолчанию.

Текстовые журналы APDU (Application Protocol Data Unit) содержат двоичные представления данных, которыми обмениваются агенты передачи сообщений (MTA) Exchange в различных сайтах, а также агенты передачи сообщений и клиентские приложения в пределах одного сайта. Журналы APDU помогают диагностировать проблемы в работе MTA. Однако они могут представлять интерес только в том случае, если вы знакомы с ASCII-преобразованиями протокола X.400.

Если параметр APDU logging required существует и имеет значение 0, все элементы APDU, отправляемые или получаемые агентом передачи сообщений, протоколируются как двоичные данные в файле MTADATA\BF*.LOG.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о редактировании реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы восстановить конфигурацию протоколирования APDU для MTA, заданную по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. В правой области найдите и дважды щелкните значение APDU logging required.

  4. В поле «Значение» введите 0 и нажмите кнопку ОК.

  5. Закройте редактор реестра и перезапустите службу Стеки агента передачи сообщений Microsoft Exchange, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в статье 256986 базы знаний Майкрософт, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о журналах APDU см. в статье 163324 базы знаний Майкрософт, описывающей журналы APDU (BF0.LOG) (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=163324).


Значение параметра Call-stack diagnostics required для агента передачи сообщений не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить ее значение:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Call-stack diagnostics required

Если анализатор сервера Exchange обнаруживает, что значение Call-stack diagnostics required существует и не равняется 1, на экран выводится сообщение о нестандартной конфигурации.

Раздел реестра Call-stack diagnostics required используется только для расширенной отладки и считывается только версией агента передачи сообщений для отладки. Его значением всегда должно быть равным 1. Если используется версия агента передачи сообщений для отладки, с помощью этого значения предоставляется стек вызовов для каждого потока агента передачи сообщений во время прерывания.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить эту ошибку

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. В правой области найдите и дважды щелкните значение Call-stack diagnostics required.

  4. В поле «Значение» введите 1 и нажмите кнопку ОК.

  5. Закройте редактор реестра и перезапустите службу Стеки агента передачи сообщений Microsoft Exchange, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Несоответствие имени компьютера агента передачи сообщений
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра, чтобы определить параметр компьютера агента передачи сообщений (MTA): HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Средство анализатора сервера Exchange опрашивает службу каталогов Active Directory®, чтобы определить значение атрибута name для каждого объекта сервера Exchange.

В последнюю очередь анализатор сервера Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Service, чтобы определить значение ключа Started для службы кластеров (ClusSvc). Значение True означает, что служба кластеров запущена, а значение False — что служба кластеров не запущена.

Если анализатор сервера Exchange обнаруживает, что значение ключа MTA Computer не соответствует значению атрибута name объекта сервера в службе каталогов Active Directory для какого-либо компьютера Exchange Server, не работающего в кластере Windows Server, на экран выводится сообщение об ошибке.

Чтобы устранить эту неполадку, необходимо изменить раздел реестра MTA Computer, чтобы его значение соответствовало значению атрибутаname в Active Directory.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения об изменении реестра см. в разделе справки «Восстановление реестра» программы Regedit.exe или Regedt32.exe.

Чтобы устранить эту ошибку

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. В правой области дважды щелкните MTA Computer, введите правильное имя компьютера и нажмите кнопку ОК.

  4. Закройте редактор реестра и перезапустите компьютер сервера Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Значение параметра Concurrent connections to LAN-MTAs отличается от значения по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server считывает следующий параметр реестра для определения его текущего значения:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent connections to LAN-MTAs

Если средство анализа Exchange Server находит, что параметр Concurrent connections to LAN-MTAs существует и отличается от значения 0x28 (шестнадцатеричное) или 40 (десятичное), появляется сообщение о нестандартной настройке.

Параметр реестра Concurrent connections to LAN-MTAs определяет максимальное число одновременных подключений к агентам передачи сообщений (MTA) по локальной сети (LAN). Агенты MTA, которые обмениваются данными по сети, носят название LAN-MTA. Местный MTA может иметь несколько подключений к удаленному MTA в зависимости от его настройки и нагрузки на сервер. Максимальное количество одновременных подключений LAN-MTA равно 240.

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неполадки. Для получения сведений о восстановлении реестра см. раздел «Восстановление реестра» справочной системы файла Regedit.exe или Regedt32.exe.

Восстановление стандартного числа одновременных подключений MTA

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. На правой панели найдите и дважды щелкните пункт Concurrent connections to LAN-MTAs.

  4. Проверьте, что система счисления установлена как шестнадцатичеричная, и в поле Значение введите 28, затем щелкните OK.

  5. Закройте редактор реестра и перезапустите службу Microsoft Exchange MTA Stacks, чтобы изменения вступили в силу.

Перед правкой реестра, а также для получения сведений о правке реестра см. статью 256986 базы знаний Microsoft «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Для получения дополнительных сведений о максимальном числе одновременных подключений LAN-MTA см. статью 243402 базы знаний «XCON: Событие с кодом 9280 MTA Exchange Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=243402).


Нестандартный параметр одновременных подключений MTA к шлюзам X.400
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить текущее значение данного параметра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent connections to X.400 gateways

Если анализатор сервера Exchange Server обнаружит, что значение для параметра Concurrent connections to X.400 gateways имеется и отличается от 6, отображается сообщение о нестандартной настройке.

Значение реестра Concurrent connections to X.400 gateways определяет максимальное количество одновременных подключений к удаленным агентам передачи сообщений (MTA) через шлюзы X.400. Значение по умолчанию, равное 6, является достаточным для большинства организаций. В настоящее время известна проблема, состоящая в том, что при использовании более четырех соединителей EDK на сервере с Exchange Server версии 5.5 требуется, чтобы значение для Concurrent connections to X.400 gateways было увеличено до 0x12 (в шестнадцатеричном выражении) или до 18 (в десятичном выражении). Дополнительные сведения об этой ошибке см. в базе знаний Майкрософт в статье 282115, посвященной данной теме (http://go.microsoft.com/fwlink/?linkid=3052&kbid=282115). Если ошибка, описанная в этой статье, не возникает, следует оставить значение реестра Concurrent connections to X.400 gateways равным 6.

Чтобы устранить данную проблему, вернитесь к стандартной настройке

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. В правой области найдите и дважды щелкните значение Concurrent connections to X.400 gateways.

  4. В поле значения введите 6 и нажмите кнопку OK.

  5. Закройте редактор реестра и перезапустите службу Microsoft Exchange MTA Stacks, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Значение параметра «Concurrent MDB/delivery queue clients» для агента передачи сообщений отличается от заданного по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить ее текущее значение:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent MDB/delivery queue clients

Если анализатор сервера Exchange обнаруживает, что для параметра Concurrent MDB/delivery queue clients установлено значение, отличное от 3, выводится сообщение о том, что конфигурация отличается от заданной по умолчанию.

Значение Concurrent MDB/delivery queue clients указывает максимальное число клиентских компьютеров очереди доставки доступа к базе данных сообщений (MDB) и сообщениям Exchange API, которое поддерживается данным агентом передачи сообщений. Для каждого из клиентских компьютеров может быть назначено несколько сеансов работы. Это значение должно равняться по меньшей мере двум, чтобы была доступна поддержка общей и частной баз данных сообщений.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы устранить эту ошибку

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. В правой области дважды щелкните значение Concurrent MDB/delivery queue clients.

  4. В поле данных «Значение» введите 3 и нажмите кнопку ОК.

  5. Выйдите из редактора реестра и перезапустите службу MTA-стеки Microsoft Exchange, чтобы изменения вступили в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).


Файлы данных MTA записываются в сжатую папку
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Directory, чтобы определить значение раздела Compressed для пути данных агента передачи сообщений (MTA). Если анализатор сервера Exchange обнаруживает, что значение раздела Compressed равно Истина, на экран выводится сообщение об ошибке.

Корпорация Майкрософт не поддерживает хранение файлов данных Exchange на сжатом томе файловой системы NTFS. При хранении файлов данных Exchange на сжатом томе дополнительные накладные расходы значительно влияют на производительность Exchange. Кроме того, после того, как база данных хранилища Exchange достигнет определенного размера — приблизительно 4 ГБ, ее не всегда можно подключить или она может быть повреждена.

В число файлов Exchange входят следующие файлы:

  • EDB-файлы

  • STM-файлы

  • LOG-файлы

  • DAT-файлы

  • EML-файлы

  • CHK-файлы

Файлы управляемые модулем расширяемого хранилища (ESE), не предназначены для хранения на сжатом диске. В отношении восстановления на основе журнала модуль ESE зависит от независимости секторов, а сжатие файлов ухудшает независимость секторов. Сжатие не следует включать на томах, содержащих базы данных ESE, и для любой базы данных, в которой используется ведение журнала с опережающей записью.

Сжатые базы данных хранилища Exchange можно подключать в приложении Exchange 2000 Server версии до пакета обновления 3. Однако в базах данных хранилища Exchange 2000 Exchange или журналах могут возникнуть повреждения, если они сжаты с использованием сжатия NTFS.

При установленном пакете обновления 3 для Exchange 2000 Server сжатые файлы базы данных банка данных размером не более 128 МБ распаковываются автоматически. Когда размер файла превышает 128 Мб, базу данных нельзя подключить и в журнале приложения генерируются сообщения об ошибках. Пакет обновления 3 для Exchange 2000 Server не допускает подключения сжатых баз данных размером более 128 МБ.

Чтобы выключить сжатие для заданной папки

  1. Щелкните правой кнопкой мыши на папке, для которой предполагается выключение сжатия, и затем щелкните Свойства.

  2. На вкладке Общие щелкните Дополнительно.

  3. В диалоговом окне Дополнительные атрибуты снимите флажок Сжатие содержимого для экономии дискового пространства и затем нажмите кнопку ОК.

Чтобы изменить местоположение файлов базы данных MTA

  1. На сервере Exchange версии 5.5 можно переместить файлы базы данных MTA, используя средство оптимизатора производительности. Дополнительные сведения о том, как это сделать на приложении Exchange 2000 Server и Exchange Server 2003, см. в базе знаний Майкрософт в статье 259896, в которой приведены инструкции по изменению местоположения базы данных MTA и рабочего каталога (http://go.microsoft.com/fwlink/?linkid=3052&kbid=259896).

Дополнительные сведения о файлах базы данных Exchange и сжатии NTFS см. в следующих статьях базы знаний Майкрософт:

  • Статья 170009, посвященная тому, что сжатый том в файловой системе NTFS вызывает сбои в работе хранилища данных (http://go.microsoft.com/fwlink/?linkid=3052&kbid=170009)

  • Статья 327772, посвященная случаю, когда при применении пакета обновления 3 (SP3) базу данных нельзя подклеить и на экран выводится сообщение об ошибке 0xfffff05b (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327772)


Файлы данных агента передачи сообщений записываются в зашифрованную папку
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-17

Анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Directory, чтобы определить значение ключа Encrypted для пути к данным в агенте передачи сообщений. Если анализатор сервера Exchange обнаруживает, что этот ключ имеет значение True, выводится сообщение об ошибке.

На компьютере с Exchange 2000 Server или Exchange Server 2003 файлы агента передачи сообщений по умолчанию записываются в следующее расположение:

<диск> :\Program Files\Exchsrvr\MTAdata

Microsoft не поддерживает хранение файлов данных Exchange на томе с шифрованной файловой системой (EFS). При хранении файлов данных Exchange на зашифрованном томе дополнительные накладные расходы существенно замедляют производительность сервера Exchange. К файлам данных Exchange относятся все следующие файлы:

  • EDB-файлы

  • STM-файлы

  • LOG-файлы

  • DAT-файлы

  • EML-файлы

  • CHK-файлы

В целях обеспечения безопасности файлов данных Exchange рекомендуется запретить неавторизаванный доступ к компьютеру Exchange и использовать для шифрования данных сообщения формат S/MIME.

Чтобы отключить шифрование файлов для указанной папки

  1. Щелкните правой кнопкой мыши папку, для которой нужно отключить сжатие файлов, и выберите команду Свойства.

  2. На вкладке Общие щелкните Дополнительно.

  3. В диалоговом окне Дополнительные атрибуты снимите флажок Шифровать содержимое для обеспечения безопасности данных, а затем нажмите кнопку ОК.

Для получения дополнительных сведений о файлах данных сервера Exchange Server и EFS см. статью 834638 базы знаний Майкрософт, содержащую сведения о хранении файлов данных сервера Exchange Server в зашифрованном томе (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638).

Сведения о том, как защитить сообщения в Exchange Server 2003, см. в документе Exchange Server 2003 Message Security Guide (http://go.microsoft.com/fwlink/?linkid=47574) (Руководство по обеспечению безопасности сообщений в Exchange Server 2003).


Файлы с данными MTA записываются в раздел в формате, отличном от NTFS
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-17

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Directory, чтобы определить значение раздела FSName для папки, содержащей данные агента передачи сообщений (MTA) Exchange: Если анализатор сервера Exchange обнаруживает, что значение раздела FSName не равно NTFS, выводится сообщение об ошибке.

Корпорация Майкрософт не поддерживает хранение файлов данных Exchange на томах формата, отличного от формата NTFS. К файлам данных Exchange относятся все следующие файлы:

  • EDB-файлы

  • STM-файлы

  • LOG-файлы

  • DAT-файлы

  • EML-файлы

  • CHK-файлы

Если произошла такая ошибка, необходимо переместить папку с данными MTA на диск NTFS Если диск, на котором находится папка с данными MTA, форматируется как диск в формате FAT, можно использовать средство командной строки convert.exe для преобразования диска в формат NTFS.

Чтобы переместить папку данных MTA Exchange

  1. Откройте диспетчер Exchange.

  2. Последовательно раскройте элемент Группы администрирования, нужную группу администрирования, элемент Серверы, щелкните правой кнопкой мыши нужную группу хранилищ и выберите команду Свойства.

  3. На странице свойств группы хранилищ рядом с полем Местоположение системного пути щелкните Обзор.

  4. Введите новый путь для папки данных MTA, а затем щелкните ОК.

  5. Нажмите кнопку ОК.

Существует альтернативный способ: если диск, на котором находятся файлы с данными, форматируется как диск в формате FAT, можно использовать средство командной строки convert.exe для преобразования диска в формат NTFS. Дополнительные сведения об использовании средства командной строки convert.exe для преобразования раздела FAT в раздел NTFS см. в статье 214579 базы знаний Майкрософт «How to Use Convert.exe to Convert a Partition to the NTFS File System» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579).


Значение параметра числа буферов на объект в базе данных агента передачи сообщений (MTA DB) отличается от значения по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа сервера Microsoft® Exchange считывает следующий параметр из реестра, чтобы определить его текущее значение:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\DB data buffers per object

Если средство анализа сервера Exchange определяет, что значение DB data buffers per object имеется и больше нуля, но не равно 3 или 6, отображается сообщение об изменении настройки по умолчанию.

Значение параметра DB data buffers per object - это количество 4-килобайтных (кБ) буферов на сервере базы данных, настроенных для каждого объекта базы данных. Чем больше буферов, тем больше нужно памяти, но тем меньше риска, что объект базы данных будет выгружен на диск из-за недостатка места под буфер. Одной из причин, по которой может быть рекоменовано изменить это значение, является случай, когда агент передачи сообщений (MTA) взаимодействует с несколькими серверами Exchange версии 5.5 либо на одном сайте, либо между сайтами. В этом случае рекомендуется изменить значение на 6. Если агент передачи сообщений (MTA) не соответствует этому критерию, снова измените значение на 3, которое является значением по умолчанию.

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неполадки. Для получения сведений о восстановлении реестра см. разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы восстановить параметры по умолчанию, выполните следующие действия

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Найдите и дважды щелкните значение DB data buffers per object в правой части окна.

  4. В поле «Значение» введите 3, затем нажмите кнопку ОК.

  5. Закройте редактор реестра, затем перезапустите службу Microsoft Exchange MTA Stacks, чтобы изменения вступили в силу.

Перед правкой реестра, а также для получения сведений о правке реестра см. статью 256986 базы знаний Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Параметр числа файловых манипуляторов на объект базы данных агента передачи сообщений (MTA DB) отличается от значения по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа сервера Microsoft® Exchange считывает следующий параметр реестра, чтобы определить его текущее значение:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\DB file handles

Если анализатор сервера Exchange обнаруживает, что значение для DB file handles существует и его значение не равно 192, будет отображено сообщение о настройке не по умолчанию.

Значение DB file handles отображает количество настроенных манипуляторов файлов сервера базы данных. Этот параметр определяет наибольшее количество файлов баз данных, которые можно открыть одновременно. Если требуется открыть файлов больше, чем настроено, объекты базы данных копируются на диск.

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неполадки. Для получения сведений о восстановлении реестра см. раздел справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы исправить эту ошибку

  1. Откройте редактор реестра, такой как Regedit.exe или Regedt32.exe.

  2. Пройдите по адресу: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. В правой области экрана двойным щелчком мыши откройте значение параметра DB file handles.

  4. В поле данных Значение введите 192 и нажмите кнопку OK.

  5. Закройте редактор реестра и перезапустите службу Microsoft Exchange MTA Stacks, чтобы изменения вступили в силу.

Перед правкой реестра и для получения сведений о правке реестра см. статью 256986 базы знаний корпорации Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Уровень ведения журнала диагностики агента передачи сообщений имеет значение больше 5 (агент передачи сообщений работает в режиме отладки)
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange получает серию разделов реестра для определения уровня ведения журнала диагностики агента передачи сообщений, установленного на сервере Exchange. Указанные разделы реестра расположены в следующей папке:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Diagnostics

По умолчанию значение для данных разделов равно 0. Если анализатор сервера Exchange находит, что значение любого из этих разделов должно быть больше 5, на экран выводится сообщение об ошибке.

Эти разделы реестра устанавливаются диспетчером Exchange при настройке уровней ведения журнала на вкладке Ведение журнала диагностики конкретной страницы свойств сервера. Диспетчер Exchange позволяет администратору устанавливать для заданного уровня ведения журнала значения Нет, Минимум, Среднее и Максимум. Соответствующие значения данных разделов реестра равны 0, 1, 3 и 5

Следовательно, значение больше 5 можно установить, лишь вручную редактируя реестр, и его следует устанавливать на таком уровне лишь в часы внепиковой нагрузки на очень короткое время во всех режимах отладки и устранения неполадок. Настройка для этих разделов значений больше 5 интенсифицирует ведение журнала до уровней отладки, требующих чрезвычайно интенсивного расходования ресурсов. В дополнение к ведению журнала уровня отладки установка для указанных разделов значений больше 5 приводит к выдаче каждые несколько секунд файла трассировки отладки call.out, имеющего размер 40 МБ. При этом журнал событий компьютера может заполниться меньше чем за минуту.

В следующей таблице приведены категории ведения журнала агента передачи сообщений в том порядке, в котором они перечислены на вкладке Ведение журнала диагностики в диспетчере Exchange, и соответствующие им имена разделов реестра.

Категория, отображаемая в диспетчере Exchange | Имя соответствующего раздела реестра
Служба X.400 | 1 X.400 Service
Ресурс | 2 Resource
Безопасность | 3 Security
Интерфейс | 4 Interface
Эксплуатация | 5 Field Engineering
Администрирование агента передачи сообщений | 6 MTA Administration
Конфигурация | 7 Configuration
Доступ к каталогу | 8 Directory Access
Операционная система | 9 Operating System
Внутренняя обработка | 10 Internal Processing
Возможность взаимодействия | 11 Interoperability
APDU (Блок данных протокола приложения) | 12 APDU

Справка в конце данной статьи представляет дополнительные сведения о том, что регистрирует в журнале каждая категория агента передачи сообщений..

Рекомендуется установить для каждой категории агента передачи сообщений значение Нет (0), если только активно не выполняется устранение неполадок. Эта рекомендация направлена на сохранение управляемого числа событий, регистрируемых в журнале. Даже уровень, имеющий значение Минимум (1) скорее всего создаст сотни журналов событий в течение нескольких дней в зависимости от категории, в которой этот уровень установлен.

Если в данный момент не производится устранение неполадок, очень похоже, что эти значения были установлены на высокое значение во время устранения неполадок и случайно остались в таком состоянии. Следует установить эти значения по меньшей мере на Максимум (5), однако следует рассматривать возможность установки для уровня ведения журнала значения Нет (0) по каждому агенту передачи сообщений, если только активно не выполняется устранение неполадок.

Чтобы установить для категорий ведения диагностики агента передачи сообщений значение "Нет"

  1. Запустите диспетчер Exchange Щелкните Пуск, укажите Все программы, укажите Microsoft Exchange, а затем щелкните Диспетчер.

  2. В дереве консоли разверните узел Серверы, разверните нужный сервер и затем щелкните Свойства.

  3. В окне <Сервер> Свойства откройте вкладку Ведение журнала диагностики.

  4. В меню Службы щелкнитеMSExchangeMTA.

  5. Для каждой записи в группе Категории установите для уровня ведения журнала значение "Нет" путем выбора категории и затем выбора Нет в группе Уровень ведения журнала.

  6. После установки для всех категорий значения Нет щелкните Применить и затем нажмите ОК.

Дополнительные сведения о ведении журнала диагностики агента передачи сообщений в Exchange 2000 Server и Exchange Server 2003 см. в базе знаний Майкрософт, в статье 163033, "XCON: Description of Diagnostics Categories for MTA" (XCON: описание категорий диагностики для агента передачи сообщений) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163033).

Дополнительные сведения о ведении журнала диагностики агента передачи сообщений в Exchange Server, версия 5.5, см. в базе знаний Майкрософт, в статье 163032, "XCON: Description of Diagnostics Categories for MTA" (XCON: описание категорий диагностики для агента передачи сообщений) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163033).


Уровень ведения журнала диагностики агента передачи сообщений является ненулевым
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает последовательность разделов реестра, чтобы определить уровень ведения журнала диагностики агента передачи сообщений, настроенный на сервере Exchange. Разделы находятся по следующему пути:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Diagnostics

Значение этих разделов по умолчанию равно 0. Если анализатор сервера Exchange обнаружит, что значение любого из этих разделов превышает 1, но меньше 6, отображается сообщение о нестандартной конфигурации.

Эти разделы реестра устанавливаются диспетчером Exchange при настройке уровней ведения журналов на вкладке Ведение журнала диагностики на странице свойств определенного сервера. Диспетчер Exchange позволяет администраторам задавать определенный уровень ведения журнала: Отсутствует, Минимальный, Средний и Максимальный. Соответственные разделы реестра: 0, 1, 3 или 5.

В следующей таблице показаны категории ведения журналов агента передачи сообщений, как они отображены на вкладке Ведение журнала диагностики в диспетчере Exchange, и имена соответствующих разделов реестра.

Категория в диспетчере Exchange | Имя соответствующего раздела реестра
Служба X.400 | 1 X.400 Service
Ресурс | 2 Resource
Безопасность | 3 Security
Интерфейс | 4 Interface
Наладка | 5 Field Engineering
Администрирование агента передачи сообщений | 6 MTA Administration
Конфигурация | 7 Configuration
Доступ к каталогам | 8 Directory Access
Операционная система | 9 Operating System
Внутренняя обработка | 10 Internal Processing
Взаимодействие | 11 Interoperability
APDU | 12 APDU

По ссылкам в конце этой статьи можно найти дополнительные сведения о каждой категории журналов агента передачи сообщений.

Рекомендуется настраивать ведение журнала диагностики для каждой категории агента передачи сообщений как Отсутствует (0), если только не происходит устранение неполадок. Причиной этой рекомендации является необходимость поддержки управляемого количества регистрируемых событий. Даже при уровне ведения журнала, заданном как Максимальный (1), будут записываться сотни событий на протяжении нескольких дней, в зависимости от категории, где был установлен уровень ведения журнала.

Если в данный момент не происходит отладка, эти значения, скорее всего, эти значения были выставлены столь высокими во время устранения неполадок и не были снижены в дальнейшем. Рассмотрите возможность установки уровня ведения журнала, равного Отсутствует (0) для каждой категории ведения журнала диагностики агента передачи сообщений.

Чтобы устранить эту ошибку в Exchange Server 2003 или Exchange 2000 Server

  1. Откройте диспетчер Exchange.

  2. В дереве консоли разверните узел Серверы, разверните нужный сервер и щелкните Свойства.

  3. В меню <Сервер> Свойства щелкните вкладку Ведение журнала диагностики.

  4. В меню Службы выберите MSExchangeMTA.

  5. Для каждой записи в разделе Категории уберите уровень ведения журналов, выбирая категорию и устанавливая Отсутствует в разделе Уровень ведения журнала.

  6. При установке значений всех категорий, равными Отсутствует, нажмите кнопку Применить, затем кнопку ОК.

Чтобы устранить эту ошибку в Exchange Server 5.5

  1. Запустите администратор Microsoft Exchange.

  2. Откройте объект, который представляет сервер, на котором имеются неполадки с агентом передачи сообщений.

  3. В правой области дважды щелкните Объект агента передачи сообщений.

  4. На вкладке Ведение журнала диагностики выберите Служба X.400 и щелкните Максимальный.

  5. Выберите Ресурсы.

  6. Удерживайте клавишу CTRL, затем щелчком выбирайте каждый ресурс, который следует отладить.

  7. Щелкните ??Параметр??, чтобы установить уровень ведения журнала равным Отсутствует.

  8. Нажмите кнопку ОК.

Дополнительные сведения о ведении журналов агента передачи сообщений в Exchange 2000 Server см. в статье 163033 базы знаний корпорации Майкрософт, посвященной категориям диагностики для агента передачи сообщений (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163033).

Дополнительные сведения об откате дополнительного ведения журналов в Exchange 5,5 Server см. в статье 168906 базы знаний корпорации Майкрософт, посвященной дополнительному ведению журналов в Exchange 5.0 и агентах передачи сообщений 5.5 MTAs (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168906).

Дополнительные сведения о ведении журналов агента передачи сообщений в Exchange Server 5.5 см. в статье 163032 базы знаний корпорации Майкрософт, посвященной описаниям категорий диагностики для агента передачи сообщений (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163032).


Значение параметра «Dispatcher threads» агента передачи сообщений не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Сообщение об ошибке

Введение

Средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить ее значение:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Dispatcher threads

Если анализатор сервера Exchange обнаруживает, что значение параметра Dispatcher threads существует и превышает 0, но не равняется 1 или 2, на экран выводится сообщение о нестандартной конфигурации.

Значение параметра Dispatcher threads определяет количество потоков диспетчера агента передачи сообщений. Это значение умножается на три для трех подтипов потока диспетчера (Router — маршрутизатор, Fanout — ветвление, Result — результат). Данное значение рекомендуется изменить, например, в случае, когда агент передачи сообщений взаимодействует с более чем пятью компьютерами под управлением Exchange Server 5.5 в пределах сайта или между сайтами, а также при интенсивном использовании списков рассылки. В этом случае рекомендуется изменить значение на 3. Если агент передачи сообщений не соответствует этому критерию, необходимо восстановить значение 1, заданное по умолчанию.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы восстановить конфигурацию по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. В правой области найдите и дважды щелкните параметр Dispatcher threads.

  4. В поле "Значение" введите 1 и затем нажмите кнопку ОК.

  5. Закройте редактор реестра и перезапустите службу Стеки агента передачи сообщений Microsoft Exchange, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Агент передачи сообщений не выполняется под учетной записью LocalSystem
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange опрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Service, чтобы определить установленное значение ключа StartName для службы стеков агента передачи сообщений Microsoft Exchange. Анализатор сервера Exchange также опрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumber для объекта сервера Exchange в каталоге. Атрибут serialNumber объекта сервера Exchange идентифицирует версию сервера Exchange, работающего на компьютере, представленном этим объектом. Если значение ключа StartName не равно LocalSystem на сервере Exchange, на котором выполняется Exchange 2000 Server или Exchange Server 2003, на экран будет выведено сообщение об ошибке.

Выполнение службы стеков агента передачи сообщений Exchange под любой другой учетной записью приводит к возникновению ошибок разрешений и доступа, к тому же данная конфигурация не поддерживается.

Чтобы устранить данную ошибку, необходимо настроить службу стеков агента передачи сообщений Exchange на запуск под учетной записью LocalSystem (aks SYSTEM).

Примечание.
Эта ошибка не возникает для Exchange Server версии 5.5. Только для приложений Exchange 2000 Server и Exchange Server 2003 требуется, чтобы служба стеков агента передачи сообщений Exchange выполнялась под учетной записью LocalSystem.

Чтобы настроить учетную запись службы стеков агента передачи сообщений Exchange

  1. Откройте оснастку «Службы» консоли управления (MMC).

  2. Найдите и остановите службу Стеки агента передачи сообщений Microsoft Exchange.

  3. Дважды щелкните службу Стеки агента передачи сообщений Microsoft Exchange.

  4. На вкладке Вход в систему страницы Стеки агента передачи сообщений Microsoft Exchange выберите Учетная запись LocalSytem в группе Вход в систему как, а затем нажмите кнопку Применить.

  5. В разделе Состояние службы щелкните Запустить, а затем нажмите кнопку OK.

  6. Закройте оснастку «Службы».

Дополнительные сведения о выполнении служб Exchange под учетной записью LocalSystem см. в базе знаний Майкрософт в статье 239762, описывающей выполнение служб Exchange под учетной записью LocalSystem (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762).


Значение параметра Kernel threads агента передачи сообщений не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра, чтобы определить его текущее значение:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Kernel threads

Если анализатор сервера Exchange обнаруживает, что значение параметра Kernel threads превышает 0, но не равняется 1 или 3, на экран выводится сообщение о нестандартной конфигурации.

Значение Kernel threads — это количество потоков платформы, которые обрабатывают уровень презентаций и сеансов стека OSI. Эти потоки являются ключевым аспектом обработки сообщений агентом передачи сообщений. Если этот агент передачи сообщений связывается с несколькими серверами Exchange Server версии 5.5 с помощью вызова удаленных процедур по медленным сетевым подключениям или по сетевым подключениям с длительными задержками, рекомендуется использовать значения, приведенные в следующей таблице:

Значение | Описание
0x3 (hex) | Стандартная рекомендация. Используйте это значение для любых агентов передачи сообщений, которые связываются с другими серверами Exchange Server 5.5 с помощью удаленного вызова процедур на медленных сетевых подключениях или сетевых подключениях с длительными задержками.
0x8 (hex) | Используйте это значения для агентов передачи сообщений в Exchange 2000 Server или Exchange Server 2003, которые принадлежат сайту, содержащему более 15 компьютеров Exchange Server 5.5.
0xC (hex) | Используйте это значения для агентов передачи сообщений в Exchange 2000 Server или Exchange Server 2003, которые принадлежат сайту, содержащему более 30 компьютеров Exchange Server 5.5.
Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения об изменении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы настроить значение параметра «Kernel threads»

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. В правой области найдите и дважды щелкните параметр Kernel threads.

  4. В поле «Значение» введите необходимое значение и нажмите кнопку ОК.

  5. Закройте редактор реестра и перезапустите службу стеков агента передачи сообщений Microsoft Exchange, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Значения параметра LAN-MTAs агента передачи сообщений не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра, чтобы определить его текущее значение:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\LAN-MTAs

Если анализатор сервера Exchange обнаружит, что значение параметра LAN-MTAs существует и не равняется 20, на экран выводится сообщение о нестандартной конфигурации.

Значение LAN-MTAs является количеством сетевым агентом передачи сообщений, которые поддерживаются агентом передачи сообщений. Рекомендуется использовать значение 20 для этого раздела реестра.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы восстановить конфигурацию по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. В правой области найдите и дважды щелкните параметр LAN-MTAs.

  4. В поле значения введите 20 и нажмите кнопку OK.

  5. Закройте редактор реестра и перезапустите службу стеков агента передачи сообщений Microsoft Exchange, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Параметр "MDB users" агента MTA не является параметром по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Для определения его текущего значения средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\MDB users

Если анализатор сервера Exchange обнаруживает, что значение для параметра MDB users имеется и установлено отличным от значения 500, на экран выводится сообщение о конфигурации не по умолчанию.

Значение MDB users представляет собой наибольшее число пользователей базы данных сообщений (MDB), поддерживаемых агентом передачи сообщений (агентом MTA). Все пользователи сервера Exchange являются пользователями MDB по умолчанию, если только явным образом не установлено иное.

Значение параметра MDB users реестра определяет число отличающихся имен из каталога, запоминаемых в кэше. Если в организации имеется более 1500 пользователей, следует изменить значение до одной третьей от размера глобального списка, но не больше, чем до 5000.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» в Regedit.exe или Regedt32.exe.

Чтобы устранить эту ошибку

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. В правой области найдите и дважды щелкните значение MDB users.

  4. В поле "Значение" введите 500 и затем нажмите кнопку ОК.

  5. Закройте редактор реестра и перезапустите службу Microsoft Exchange MTA Stacks, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986 "Description of the Microsoft Windows Registry" (Описание реестра Microsoft Windows) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Значение параметра «Max RPC calls outstanding» агента передачи сообщений не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить ее текущее значение:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Max RPC Calls Outstanding

Если анализатор сервера Exchange обнаруживает, что значение параметра Max RPC Calls Outstanding существует и отлично от 50, на экран выдается сообщение о конфигурации не по умолчанию.

Значение Max RPC Calls Outstanding — это максимальное количество потоков удаленных вызовов процедур. Это ограничивает максимальное количество удаленных вызовов процедур, которое гарантировано будет обработано за один раз. Это значение используется функциями RpcServerUseAllProtSeqs() и RpcServerListen().

В сценариях, где современные решения смешаны с унаследованными, когда компьютеры Exchange 2000 Server и/или Exchange Server 2003 сосуществуют с компьютерами Exchange Server версии 5.5, и количество потоков входящих/исходящих шлюзов в процессе Store.exe было увеличено, рекомендуется увеличить значение до 0x80 (шестнадцатеричное) или 128 (десятичное).

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Возвращение к конфигурации по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. В правой области найдите и дважды щелкните значение Max RPC Calls Outstanding.

  4. В поле «Значение» введите 50 и нажмите кнопку ОК.

  5. Закройте редактор реестра и перезапустите службу Microsoft Exchange MTA Stacks, чтобы изменение вступило в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт, посвященную описанию реестра Microsoft Windows, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986 (возможно, на английском языке).


Значение параметра MTA Min RPC Threads отличается от заданного по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Сообщение об ошибке

Введение

Для определения текущего значения параметра средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Min RPC Threads

Если анализатор сервера Exchange обнаруживает, что задано значение для параметра Min RPC Threads и оно отличается от 4, на экран выводится сообщение о том, что конфигурация отличается от заданной по умолчанию.

Значение Min RPC Threads — это минимальное количество потоков удаленных вызовов процедур. Оно определяет минимальное число потоков вызовов. Это значение используется функцией RpcServerListen(). Обычно изменять это заданное по умолчанию значение реестра не следует.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить эту ошибку

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. В правой области найдите и дважды щелкните параметр Min RPC Threads.

  4. В поле «Значение» введите 4 и затем нажмите кнопку ОК.

  5. Закройте редактор реестра и перезапустите службу Microsoft Exchange MTA Stacks, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Значение параметра RTS threads агента передачи сообщений не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра, чтобы определить его текущее значение:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\RTS threads

Если анализатор сервера Exchange обнаруживает, что значение параметра RTS threads существует и превышает 0, но не равняется 1 или 3, на экран выводится сообщение о нестандартной конфигурации.

Значение RTS threads — это количество потоков платформы, которые обрабатывают уровень RTSE стека OSI. Потоки RTS ответственны за помещение данных в очереди. Необходимо изменить значение раздела реестра RTS threads со значения по умолчанию, равного 1, на значение 3, если этот агент передачи сообщений связывается с несколькими компьютерами Exchange Server версии 5.5 внутри сайта или между сайтами.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы оптимизировать значение реестра RTS threads

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. В правой области найдите и дважды щелкните параметр RTS threads.

  4. В поле значения введите необходимое значение (1 или 3) и нажмите кнопку ОК.

  5. Закройте редактор реестра и перезапустите службу стеков агента передачи сообщений Microsoft Exchange, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Не выполняется служба агента передачи сообщений
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-02-19

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Windows® Management Instrumentation) Win32_Service, чтобы определить, установлены ли ключи Started следующих служб в значение True или False:

  • служба стеков агента передачи сообщений Microsoft Exchange,

  • служба кластеров.

Значение False указывает, что служба не выполняется на компьютере сервера Exchange. Значение True указывает, что служба запущена.

Анализатор сервера Exchange также исследует WMI-класс Exchange_Server в пространстве имен root\MicrosoftExchangeV2, чтобы определить значение раздела IsFrontEndServer. Значение False означает, что компьютер сервера Exchange не является сервером переднего плана. Значение True означает, что компьютер сервера Exchange является сервером переднего плана.

Если значения всех трех оцениваемых параметров равны False, на экран выводится предупреждение.

Рекомендуется, чтобы на всех компьютерах серверов Exchange, которые маршрутизируют почту, была запущена служба стеков агента передачи сообщений Exchange. Это особенно важно в среде со смешанным режимом, где сообщения передаются между Exchange Server версии 5.5 и Exchange Server 2003 и/или Exchange 2000 Server. Кроме того, служба стеков агента передачи сообщений Exchange требуется для всех соединителей X.400, поэтому при отключении службы будут возникать ошибки и, возможно, сбои в выполнении функций. Для перемещения почтовых ящиков также требуется запустить службу стеков агента передачи сообщений Exchange.

Чтобы устранить причины появления данного предупреждения, запустите службу стеков агента передачи сообщений Exchange.

Чтобы запустить службу стеков агента передачи Exchange

  1. Выберите в меню Пуск пункт Программы, затем Администрирование, а после этого оснастку Службы консоли управления (MMC).

  2. Щелкните правой кнопкой мыши службу Стеки агента передачи сообщений Microsoft Exchange и выберите в контекстном меню команду Свойства.

  3. Убедитесь, что на вкладке Общие страницы свойств Стеки агента передачи сообщений Microsoft Exchange Тип запуска выставлен как Авто. Если нет, нажмите кнопку Применить, затем ОК.

  4. Щелкните правой кнопкой мыши службу Стеки агента передачи сообщений Microsoft Exchange и выберите в контекстном меню команду Запустить.

  5. Закройте оснастку «Службы».

Дополнительные сведения о поддержании работающей службы стеков агента передачи сообщений Exchange в среде Exchange со смешанным режимом см. в базе знаний Майкрософт в статье 810489, описывающей необходимость включения службы стеков агента передачи сообщений для Exchange 2000 и 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810489).


Служба агента передачи сообщений отключена
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Service, чтобы определить значение, установленное для ключа StartMode службы стеков агента передачи сообщений Microsoft Exchange. Значение Отключено указывает, что служба стеков агента передачи сообщений Exchange отключена и ее невозможно запустить до тех пор, пока для ключа StartMode не будет установлено значение Вручную или Авто.

Анализатор сервера Exchange также запрашивает WMI-класс Win32_Service, чтобы определить значение ключа Started для службы SMTP (Simple Mail Transfer Protocol). Значение False указывает, что служба не выполняется. Значение True указывает, что служба выполняется.

Наконец, анализатор сервера Exchange запрашивает WMI-класс Win32_OperatingSystem, чтобы определить значение ключа OSProductSuite. Значение этого ключа соответствует определенной версии операционной системы Microsoft Windows Server™ 2003.

Если анализатор сервера Exchange обнаружит, что на компьютере сервера Exchange, на котором запущена служба SMTP, значение ключа StartMode установлено равным Отключено и что компьютер сервера Exchange не является частью установки Microsoft Windows Small Business Server 2003, на экран будет выведено предупреждение.

Если сервер не является частью установки Microsoft Windows Small Business Server 2003 или если он не находится в чистой среде основного режима Exchange Server 2003, на всех компьютерах сервера Exchange, участвующих в маршрутизации почты, служба стеков агента передачи сообщений Exchange должна быть установлена в режим Авто. При маршрутизации почты на сервере, на котором отключена служба стеков агента передачи сообщений Exchange, могут выводиться различные сообщения об ошибках. В некоторых случаях ошибки регистрируются в журнале, если функционирует среда Exchange 2000 Server или Exchange Server 2003, в которой все еще выполняется сервер Exchange версии 5.5. Кроме того, для любых соединителей X.400 требуется служба стеков агента передачи сообщений Exchange, поэтому при отключении службы возникнут ошибки, и станут возможны сбои в работе функций.

Примечание.
За исключением прямых подключений к внешним почтовым системам X.400 и работы соединителей из пакета разработки Exchange (Exchange Development Kit, EDK), таких как соединители Novell GroupWise Connector, Lotus Notes Connector и соединитель факса сторонних разработчиков, зависимости от службы стеков агента передачи сообщений удалены в Exchange Server 2003. Поэтому корпорация Майкрософт теперь поддерживает чистые развертывания Exchange Server 2003 в основном режиме, в которых служба стеков агента передачи сообщений отключена.

Чтобы устранить эту ошибку, необходимо настроить службу стеков агента передачи сообщений Exchange на автоматический запуск на серверах, которые участвуют в маршрутизации почты.

Чтобы настроить службу стеков агента передачи сообщений Exchange на автоматический запуск

  1. Откройте оснастку «Службы» консоли MMC (Microsoft Management Console).

  2. Дважды щелкните службу Стеки агента передачи сообщений Microsoft Exchange.

  3. На вкладке Общие страницы Свойства стеков агента передачи сообщений Microsoft Exchange выберите Авто из раскрывающегося диалогового окна Тип запуска, а затем щелкните Применить.

  4. В разделе Состояние сервера щелкните Запустить, а затем нажмите кнопку OK.

  5. Закройте оснастку «Службы».

Дополнительные сведения о поддержке в приложении Exchange работающей службы стеков агента передачи сообщений Exchange см. в базе знаний Майкрософт в статье 810489, содержащей инструкции по поддержке службы стеков агента передачи сообщений для приложений Exchange 2000 Server и Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810489).


Параметр «MTA Submit/deliver threads» отличается от заданного по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить ее текущее значение:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\ Submit/deliver threads

Если анализатор сервера Exchange обнаруживает, что для параметра Submit/deliver threads установлено значение, отличное от 2, выводится сообщение о том, что конфигурация отличается от заданной по умолчанию.

Значение Submit/deliver threads представляет собой число потоков отправки и доставки в агента передачи сообщений (message transfer agent, MTA). Агент MTA использует эти потоки для передачи сообщений в банк данных. На некоторых компьютерах Exchange Server версии 5.5 это значение может быть автоматически изменено средством оптимизации производительности Exchange с заданного по умолчанию значения 2 на более подходящее для сервера Exchange.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы вернуться к конфигурации по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. В правой области дважды щелкните значение Submit/deliver threads.

  4. Проверьте, что в поле «Значение» указано значение 2, а затем нажмите кнопку ОК.

  5. Выйдите из редактора реестра и перезапустите службу MTA-стеки Microsoft Exchange, чтобы изменения вступили в силу.

На компьютерах Exchange 2000 Server и Exchange Server 2003 значение данной записи не должно превышать 3. На компьютерах Exchange Server 5.5 вместо указанной выше процедуры можно выполнить средство оптимизации производительности Exchange в развернутом режиме (perfwiz.exe -v) и установить значение с помощью этого средства.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения о ситуациях, в которых следует изменить значение реестра «MTA Submit/deliver threads» с указанного по умолчанию см. в следующих статьях базы знаний:

  • 234280, «XCON: How to Increase the Ability of the MTA to Pass Mail over Slow Network Connections» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=234280) (XCON: инструкции по расширению возможностей агента передачи сообщений передавать почту по медленным сетям)

  • 265186, «XCON: MTA Fanout Slows on Multiprocessor Servers and Messages Back Up in Information Store» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=265186) (XCON: распространение сообщений агентом передачи сообщений замедляется на многопроцессорных серверах, сообщения помещаются в банк данных)

  • 234702, «XGEN: MTA Queue to Information Store Processing Slowly» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=234702) (XGEN: очередь агента сообщений в банк данных обрабатывается медленно)

  • 327260, «MTA slows down or stalls in Exchange Server 5.5 and messages back up in the private information store» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327260) (Работа агента сообщений замедляется или останавливается в Exchange Server 5.5, сообщения помещаются в частный банк данных)

  • Дополнительные сведения об использовании средства оптимизации производительности Exchange в развернутом режиме см. в статье 246125 базы знаний «XADM: Exchange Server 5.5 Performance Optimizer Verbose Mode» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246125) (Развернутый режим работы средства оптимизации производительности Exchange Server 5.5).


Параметр MTA TCP/IP control blocks отличается от установленного по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Сообщение об ошибке

Введение

Средство анализа Microsoft® Exchange Server считывает следующий параметр реестра для определения его значения:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\TCP/IP control blocks

Если средство анализа Exchange Server обнаруживает, что параметр TCP/IP control blocks имеет значение, отличное от 20, отображается сообщение о нестандартной настройке.

Значение TCP/IP control blocks представляет собой максимальное число поддерживаемых одновременных подключений RFC1006 (TCP/IP). Этот параметр контролирует число буферов, доступных для подключений X.400. Если агент передачи сообщений (MTA) обслуживает более одного соединителя X.400, значение TCP/IP control blocks должно быть исправлено соответствующим образом. Для каждого обслуживаемого соединителя X.400 должно быть создано 10 контрольных блоков, и еще один контрольный блок должен обслуживать входящие соединения. Таким образом, значение параметра для системы с тремя подключениями X.400 должно быть 33.

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что знаете, как восстановить реестр в случае возникновения проблем. Сведения о восстановлении реестра находятся в разделе справки «Восстановление реестра» файла Regedit.exe или Regedit32.exe.

Для настройки параметра TCP/IP control blocks

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. На правой панели дважды щелкните параметр TCP/IP control blocks.

  4. В поле Значение введите значение, соответствующее этому MTA, затем нажмите кнопку OK.

  5. Закройте редактор реестра и перезагрузите службу Microsoft Exchange MTA Stacks для того, чтобы изменения вступили в силу.

Перед правкой реестра для получения дополнительных сведений обратитесь к статье 256986 Базы знаний Microsoft «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Параметр MTA «TCP/IP threads» установлен не по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Сообщение об ошибке

Введение

Средство анализа сервера Microsoft® Exchange считывает следующий параметр реестра, чтобы определить его текущее значение:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\TCP/IP threads

Если анализатор сервера Exchange обнаруживает, что значение для TCP/IP threads присутствует и не равно 2, будет выведено сообщение о настройке не по умолчанию.

Значение TCP/IP threads равно наибольшему количеству потоков агентов передачи сообщений (MTA) динамических адресных модулей (DMOD), которые обрабатывают подключения RFC1006. Это количество умножено на два для двух подтипов (Драйвер и Уведомление Async) потоков RFC1006. При репликации каталогов X.400 на серверах-плацдармах и выделенных серверах общих папок, которые поддерживают большое количество подключений, рекомендуется, чтобы значение было изменено со значения по умолчанию, равного 2, на значение, равное 10.

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неполадки. Для получения сведений о правке реестра см. раздел справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Как настроить значение параметра «TCP/IP threads»

  1. Откройте редактор реестра, такой как Regedit.exe или Regedt32.exe.

  2. Перейдите по адресу: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. В правой области двойным щелчком мыши откройте значение параметра TCP/IP threads.

  4. В поле данных Значение введите соответствующее значение и нажмите кнопку OK.

  5. Закройте редактор реестра и перезапустите службу Microsoft Exchange MTA Stacks, чтобы изменения вступили в силу.

Перед правкой реестра и для получения сведений о правке реестра см. статью 256986 базы знаний корпорации Майкрософт, «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Значение параметра Transfer threads агента передачи сообщений не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Сообщение об ошибке

Введение

Средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра, чтобы определить его текущее значение:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Transfer threads

Если анализатор сервера Exchange обнаруживает, что значение параметра Transfer threads превышает 0, но не равняется 1 или 2, на экран выводится сообщение о нестандартной конфигурации.

Значение Transfer threads — это количество транспортных потоков сообщений агента передачи сообщений. Это значение удвоено для двух подтипов (Transfer In и Transfer Out) каждого транспортного потока. Это значение эквивалентно значению Submit/deliver threads (которое относится к агенту передачи сообщений и передаче сообщений банка данных), но применимо к шлюзам и агентам передачи сообщений. Дополнительные сведения о значении Submit/deliver threads см. в разделе Параметр «MTA Submit/deliver threads» отличается от заданного по умолчанию.

Если используется сервер Exchange 2000 или агент передачи сообщений сервера Exchange Server 2003, который связывается с несколькими серверами Exchange версии 5.5 внутри сайта или между сайтами, рекомендуется изменить значение параметра Transfer threads на 3.

Возможно, что на некоторых компьютерах серверов Exchange Server 5.5 это значение было автоматически изменено средством Exchange Performance Optimizer со значение по умолчанию 2 до более подходящего значения для этого компьютера сервера Exchange.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы установить значение параметра «Transfer threads»

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. В правой области найдите и дважды щелкните параметр SystemPages.

  4. В поле значение введите необходимое значение и нажмите ОК.

  5. Закройте редактор реестра и перезапустите службу стеков агента передачи сообщений Microsoft Exchange, чтобы изменение вступило в силу.

На компьютерах серверов Exchange 2000 и Exchange Server 2003 значение этого раздела не должно превышать 3. В качестве альтернативы предыдущей процедуре можно выполнить средство оптимизации производительности Exchange в режиме подробного протоколирования (perfwiz.exe -v) и установить значение этого параметра с помощью этого средства.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о случаях, при которых следует менять значение по умолчанию параметра агента передачи сообщений Transfer threads см. в следующих статьях базы знаний:

  • 234280, описывающая инструкции по увеличению возможностей агента передачи сообщений по отправке сообщений на медленных сетевых подключениях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=318230);

  • 265186, описывающая причины замедления агента передачи сообщений на многопроцессорных серверах и резервное копирование сообщений в банке данных (может быть на английском языке) http://go.microsoft.com/fwlink/?linkid=3052&kbid=265186);

  • 327260, посвященная замедлению или остановке агента передачи сообщений на сервере Exchange 5.5 и резервному копированию сообщений в частном банке данных (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=265186).


Значение параметра «Transfer threads» агента передачи сообщений не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Сообщение об ошибке

Введение

Анализатор сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить ее текущее значение:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Transport threads

Если анализатор сервера Exchange обнаруживает, что для параметра Transport threads установлено значение и оно отличается от 1, выводится сообщение о том, что конфигурация отличается от заданной по умолчанию.

Значение Transfer threads определяет количество транспортных потоков сообщений агента передачи сообщений. Установленное по умолчанию значение 1, как правило, подходит для всех организаций. Без соответствующих рекомендаций служб поддержки продуктов Майкрософт следует оставить для данного параметра значение 1.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы установить значение параметра «Transfer threads»

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. В правой области найдите и дважды щелкните параметр Transport threads.

  4. В поле «Значение» введите 1 и нажмите кнопку ОК.

  5. Закройте редактор реестра и перезапустите службу Стеки агента передачи сообщений Microsoft Exchange, чтобы изменение вступило в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).


Отслеживание сообщений отключено
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-06

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить установлено ли свойство messageTrackingEnabled объекта сервера равным значению TRUE (включено) или FALSE (выключено).

Если анализатор сервера Exchange определит, что свойство messageTrackingEnabled объекта сервера установлено равным False, анализатор сервера Exchange выведет на экран сообщение об ошибке.

Свойство messageTrackingEnabled объекта сервера определяет для сервера состояние центра отслеживания сообщений.

Когда центр отслеживания сообщений включен, в журнале регистрируются сведения об отправителе, сообщении электронной почты и получателях сообщения. В частности, можно просмотреть статистические данные, например, время отправки или получения сообщения, размер и приоритет сообщения, а также список получателей сообщения. Можно также записывать в журнал строку темы сообщений электронной почты. Центр отслеживания сообщений выполняет поиск сообщений, таких как системные сообщения, сообщения в общих папках и сообщения электронной почты.

Центр отслеживания сообщений необходимо включить на каждом сервере, для которого требуется отслеживать сообщения. Когда центр отслеживания сообщений включен, все сообщения, направляемые через сервер, добавляются в журналы отслеживания сообщений.

Чтобы анализатор сервера Exchange начал выполнять сканирования, для него необходимо включить отслеживание сообщений.

Примечание.
Для выполнения данной процедуры требуются следующие разрешения: необходимо быть членом локальной группы администраторов и членом группы, обладающей ролью администраторов Exchange, применяемой на уровне административной группы.
Чтобы включить на сервере центр отслеживания сообщений

  1. В системном диспетчере Exchange разверните узел Серверы, щелкните правой кнопкой мыши сервер, для которого хотите включить отслеживание сообщений, и в контекстном меню выберите пункт Свойства.

  2. На вкладке Общие установите флажок Включить отслеживание сообщений.

  3. Чтобы записать тему любого сообщения, отправленного на сервер, через сервер или с сервера, установите флажок Включить отображение темы и ее запись в журнал.

    Примечание.
    Если включена запись темы в журнал, производительность работы может несколько упасть.

  4. В разделе Обслуживание файла журнала можно запретить удаление файлов журнала или изменить время, в течение которого хранятся файлы журнала. Период хранения по умолчанию для журналов отслеживания равен семи дням.

    Примечание.
    На серверах, обрабатывающих большие количества почты, объем журналов отслеживания быстро увеличивается. Убедитесь, что на диске имеется достаточно свободного места для файлов журналов, а также для других служб или приложений, которые используют этот диск.

  5. Нажмите кнопку OK или кнопку Применить. Чтобы изменение вступило в силу, не требуется перезапускать службы.

Дополнительные сведения об использовании центра отслеживания сообщений см. в базе знаний Майкрософт в статье 262162, описывающей использование центра отслеживания сообщений для отслеживания сообщений (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162).

Дополнительные сведения об устранении неполадок транспорта сервера Exchange см. в базе знаний Майкрософт в статье 821910, содержащей инструкции по устранению неполадок транспорта в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821910).


Журналы трассировки сообщений записываются в сжатую папку
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-17

Анализатор Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Directory, чтобы определить значение ключа Compressed для пути к файлу журнала трассировки сообщений. Если анализатор сервера Exchange обнаруживает, что ключ Compressed имеет значение True, выводится сообщение об ошибке.

При включенной трассировке сообщений на сервере Exchange 2000 Server или Exchange Server 2003 журналы трассировки по умолчанию записываются в следующее местоположение:

<диск> :\Program Files\Exchsrvr\ имя_сервера .log

где <диск> указывает диск, содержащий путь «\Program Files\Exchsrvr», а имя_сервера — имя сервера для компьютера сервера Exchange.

Корпорация Майкрософт не поддерживает хранение файлов данных Exchange в сжатых томах с форматом NTFS. При хранении файлов данных Exchange на сжатом томе дополнительные накладные расходы существенно замедляют производительность сервера Exchange. Кроме того, при достижении базой данных банка данных определенного размера, приблизительно 4 гигабайта (ГБ), она может стать поврежденной или недоступной для подключения.

К файлам данных Exchange относятся все следующие файлы:

  • EDB-файлы

  • STM-файлы

  • LOG-файлы

  • DAT-файлы

  • EML-файлы

  • CHK-файлы

Файлы, управляемые расширяемым модулем хранилищ (ESE), не предназначены для хранения на сжатом диске. В основе работы расширяемого модуля хранилищ лежит независимость сектора аварийного восстановления на базе журнала, а при сжатии файлов эта независимость утрачивается. Не следует включать сжатие на томах, размещающих базы данных расширяемого модуля хранилищ или любую базу данных, в которой используется ведение журнала с добавлением записей в начало.

До Exchange 2000 Server с пакетом обновления 3 можно было подключать сжатые базы данных банка данных. Однако сжатие баз данных банка данных или журналов банка данных Exchange 2000 Server с использованием NTFS может привести к их повреждению.

В Exchange 2000 с пакетом обновления 3 сжатые файлы базы данных банка данных размером не более 128 мегабайт (МБ) автоматически возвращаются в исходное состояние. Если размер файлов базы данных превышает 128 МБ, эта база данных становится недоступной для подключения, а в журнал приложения заносятся сообщения об ошибке. В Exchange 2000 с пакетом обновления 3 подключение сжатых баз данных размером более 128 МБ недоступно.

Чтобы отключить сжатие файлов для указанной папки

  1. Щелкните правой кнопкой мыши папку, для которой нужно отключить сжатие файлов, и выберите команду Свойства.

  2. На вкладке Общие щелкните Дополнительно.

  3. В диалоговом окне Дополнительные атрибуты снимите флажок Сжимать содержимое для экономии места на диске, а затем нажмите кнопку ОК.

Помимо выполнения указанной выше процедуры, можно переместить файлы журнала трассировки сообщений в другую, несжатую папку. Дополнительные сведения о перемещении файлов журнала трассировки сообщений см. в следующих статьях базы знаний Майкрософт:

  • 841089, «How to change the location of the message tracking logs in Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=841089) (Как изменить расположение журналов отслеживания сообщений в Exchange Server 2003)

  • 317700, «How to change the location of the message tracking logs in Exchange 2000 Server» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700) (Как изменить расположение журналов отслеживания сообщений в Exchange 2000 Server)

Дополнительные сведения о файлах данных Exchange и NTFS-сжатии см. в следующих статьях базы знаний:

  • 170009, «XADM: NTFS Compressed Volume Causes Store to Fail» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=170009) (NTFS-сжатие тома приводит к сбою хранилища)

  • 327772, «XADM: Database Does Not Mount and You Receive Error 0xfffff05b After You Apply SP3» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327772) (После установки пакета обновления SP3 не подключается база данных и выводится сообщение об ошибке 0xfffff05b)


Файлы журнала отслеживания сообщений Exchange записываются в раздел, который имеет формат, отличный от NTFS
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-17

Анализатор Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Directory, чтобы определить значение ключа FSName для пути к файлам журнала отслеживания сообщений Exchange. Если анализатор сервера Exchange обнаруживает, что значение ключа FSName не равно NTFS, выводится сообщение об ошибке.

Корпорация Майкрософт не поддерживает хранение файлов данных Exchange в томах, которые отформатированы в файловой системе, отличной от NTFS. К файлам данных Exchange относятся все следующие файлы:

  • EDB-файлы,

  • STM-файлы,

  • LOG-файлы,

  • DAT-файлы,

  • EML-файлы,

  • CHK-файлы.

При возникновении этой ошибки необходимо переместить файлы журнала отслеживания сообщений в папку на диске с форматом NTFS. Если же диск, на котором хранятся файлы журналов отслеживания сообщений, имеет формат FAT, можно преобразовать этот диск в формат NTFS с помощью средства командной строки convert.exe.

Чтобы переместить файлы журнала отслеживания сообщений в Exchange Server 2003

  1. Откройте диспетчер Exchange.

  2. Разверните узел Административные группы, разверните административную группу, разверните узел Серверы, щелкните правой кнопкой мыши сервер и в контекстном меню выберите пункт Свойства.

  3. На вкладке Общие щелкните Изменить.

  4. Введите новый путь для файлов журнала отслеживания сообщений и нажмите кнопку ОК.

  5. Нажмите кнопку ОК.
Примечание.
По умолчанию изменение расположения файлов журнала отслеживания сообщений вступает в силу в полночь по универсальному времени (UTC). После этого компонент отслеживания сообщений Exchange создает новые файлы журнала в новой папке, которая была указана. Однако предыдущие файлы журнала не перемещаются в новую папку. Поэтому следует дождаться, когда изменение расположения файлов журнала вступит в силу, а затем вручную переместить файлы журнала из старого расположения в новое. Если выполняется перезапуск службы системного помощника Microsoft Exchange, путь к файлам журналов немедленно изменяется на новый. В этом сценарии компонент отслеживания сообщений Exchange создает новый файл журнала в новой папке, когда пользователь отправляет сообщение. В этом сценарии может оказаться, что два файла журнала имеют одинаковое имя: один файл журнала находится в исходном расположении, а другой — в новом расположении, которое было указано. В этом случае следует переименовать файл журнала, хранящийся в исходном расположении, перед перемещением его в новое расположение. Следует использовать такое же соглашение об именах, которое используется компонентом отслеживания сообщений Exchange (ггггммдд). Однако в этом случае следует использовать более раннюю дату, чем имеет любой из существующих файлов журнала, чтобы переименованный файл журнала не помешал при создании будущих файлов журнала.

Дополнительные сведения о перемещении журналов отслеживания сообщений на сервере Exchange 2000 Server см. в статье 317700 базы знаний Майкрософт «How to change the location of the message tracking logs in Exchange 2000 Server» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700).

Если диск, на котором хранятся файлы журнала, имеет формат FAT, вместо выполнения вышеизложенной процедуры можно преобразовать этот диск в формат NTFS с помощью средства командной строки convert.exe. Дополнительные сведения об использовании средства командной строки convert.exe для преобразования раздела FAT в раздел NTFS см. в статье 214579 базы знаний Майкрософт «How to Use Convert.exe to Convert a Partition to the NTFS File System» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579).


Журналы отслеживания сообщений записываются в зашифрованную папку
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-17

Средство анализа Microsoft® Exchange Server запрашивает класс Win32_Directory инструментария Microsoft Windows Management Instrumentation (WMI), чтобы определить значение параметра Encrypted файлов журнала отслеживания сообщений. Если значение параметра Истина, появляется сообщение об ошибке.

Если отслеживание сообщений включено на компьютере с Exchange 2000 Server или Exchange Server 2003, журналы отслеживания по умолчанию записываются в следующую папку:

<диск>:\Program Files\Exchsrvr\ ServerName .log

где <диск> - диск, на котором присутствует путь \Program Files\Exchsrvr и ServerName - имя узла компьютера сервера Exchange.

Microsoft не поддерживает сохранение файлов данных Exchange на томе, содержащем файловую систему с шифрованием (EFS). При сохранении данных Exchange на зашифрованном томе дополнительные накладные затраты заметно снижают производительность Exchange. Файлы данных Exchange включают следующие типы файлов:

  • файлы EDB

  • файлы STM

  • файлы LOG

  • файлы DAT

  • файлы EML

  • файлы CHK

Чтобы обезопасить файлы данных Exchange, рекомендуется предотвращать несанкционированный доступ к компьютеру, на котором установлен Exchange, и использовать формат S/MIME для шифрования сообщений.

Отключение шифрование указанной папки

  1. Щелкните правой кнопкой мыши папку, шифрование которой нужно отключить, и выберите Свойства.

  2. На вкладке Общие нажмите кнопку Дополнительно.

  3. В диалоговом окне Дополнительные атрибуты снимите флажок Шифровать содержимое для безопасности, затем нажмите кнопку OK.

В качестве другого способа можно переместить файлы журнала отслеживания сообщений в другую, незашифрованную папку. Для получения дополнительных сведений о перемещении файлов журнала отслеживания сообщений см. следующие статьи базы знаний Microsoft:

  • 841089, «How to change the location of the message tracking logs in Exchange Server 2003» (Как изменить расположение журналов отслеживания сообщений в Exchange Server 2003) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=841089)

  • 317700, «How to change the location of the message tracking logs in Exchange 2000 Server» (Как изменить расположение журналов отслеживания сообщений в Exchange 2000 Server) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700)


Не удается получить доступ к метабазе
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-02-13

Средство анализа Microsoft® Exchange Server пытается прочитать свойства экземпляра виртуального сервера протокола SMTP по следующему пути метабазы служб Microsoft IIS:

/LM/SmtpSvc/<экземпляр_виртуального_сервера_SMTP>

Средство анализа Exchange Server выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Запрос к метабазе выполнен неудачно.

  • Сервер Exchange Server запущен не на платформе Microsoft Windows NT® Server 4.0.

Эта ошибка означает, что средство анализа сервера Exchange Server не может подключиться к метабазе служб IIS.

Метабаза служб IIS содержит такие данные, оказывающие влияние на работу сервера Exchange Server, как параметры протокола HTTP, виртуальные каталоги для доступа к почтовым ящикам и мобильным устройствам, а также параметры безопасности HTTP.

Для разрешения данной проблемы проверьте целостность метабазы и убедитесь, что службы IIS установлены правильно.

Для того чтобы убедиться в том, что метабаза не повреждена, а службы IIS установлена правильно, см. следующие ресурсы:

  • Статья 240225 базы знаний Майкрософт «Описание средств Adsutil и MetaEdit, предназначенных для изменения метабазы» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=240225 (на английском языке).

  • Статья 317678 базы знаний Майкрософт «Инструкции по перезапуску служб IIS на сервере Exchange 2000 Server» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=317678 (на английском языке).

Если инструкции, имеющиеся в этих ресурсах, не помогают в решении проблемы, то может потребоваться удаление и повторная установка служб IIS.

Удаление служб IIS с помощью средства «Установка компонентов Windows» в панели управления

  1. Нажмите кнопку Пуск и выберите пункт Панель управления.

  2. Дважды щелкните значок Установка и удаление программ.

  3. Выберите пункт Установка компонентов Windows.

  4. В списке Компоненты установите флажок Сервер приложений.

  5. Нажмите кнопку Состав.

  6. Щелкните Диспетчер служб IIS.

  7. Нажмите кнопку Далее.

  8. После завершения удаления IIS нажмите кнопку Готово.
Установка IIS с помощью панели управления

  1. Нажмите кнопку Пуск и выберите пункт Панель управления.

  2. Дважды щелкните значок Установка и удаление программ.

  3. Выберите пункт Установка компонентов Windows.

  4. В списке Компоненты установите флажок Сервер приложений.

  5. Нажмите кнопку Состав.

  6. Установите флажок Диспетчер служб IIS.

  7. Нажимайте кнопку ОК, пока не вернетесь в мастер компонентов Windows.

  8. Нажмите кнопку Далее и завершите работу мастера компонентов Windows.


Значение MinUserDC отлично от значения по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-02-08

Средство анализа Microsoft® Exchange Server считывает следующие параметры реестра, чтобы определить, не был ли контроллер домена службы каталога Active Directory®, работающий как эмулятор первичного контроллера домена (PDC), вручную удален из списка контроллеров домена, доступных для использования Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default

Если анализатор обнаружит, что параметр MinUserDC существует и настроен, появится сообщение о том, что настройка отличается от настройки по умолчанию.

Эмулятор PDC — это компьютер, выполняющий роль хозяина операций Active Directory, обрабатывающий запросы на репликацию резервных контроллеров домена Microsoft Windows NT® Server 4.0 и все обновления паролей клиентов, которые используют клиентское программное обеспечение, не поддерживающее Active Directory. Эмуляторы PDC также являются контроллерами доменов и поэтому могут использоваться такими приложениями, как Exchange.

DSAccess — это внутренний компонент Exchange 2000 Server и Exchange Server 2003, контролирующий доступ всех компонентов Exchange к Active Directory. Первичная функция DSAccess — сохранять информацию о различных событиях и операциях, связанных с каталогом. Например, DSAccess определяет топологию Active Directory и обнаруживает контроллеры домена и серверы глобального каталога, доступные для ответа на запросы.

По умолчанию DSAccess включает компьютер эмулятора PDC в список контроллеров домена, доступных для использования. Если программы, не связанные с Exchange, вызывают высокую загрузку эмулятора PDC, использование его компонентом DSAccess может привести к снижению производительности компьютера эмулятора PDC, а кроме того, сервера Exchange и компьютера, на котором работают программы, не связанные с Exchange.

Чтобы предотвратить такое снижение производительности, можно добавить в реестр сервера Exchange значение MinUserDC, чтобы компонент DSAccess запрашивал все прочие доступные контроллеры домена, прежде чем запрашивать контроллер домена, выполняющий роль эмулятора PDC.

Примечание.
Сервер Exchange, для которого настроено значение реестра MiniUserDC, попытается сначала использовать другие серверы в этом же домене, поэтому рекомендуется выполнять эту настройку, только если на узле есть по крайней мере два контроллера домена для домена, содержащего серверы Exchange.
Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Для получения сведений о восстановлении реестра см. разделе «Восстановление реестра» справочной системы файла Regedit.exe или Regedt32.exe.

Проверка и изменение значения реестра MinUserDC

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default

  3. Найдите параметр MinUserDC и внесите нужные изменения. Если этот параметр типа DWORD не существует, его можно создать вручную.

  4. Значение, установленное для параметра реестра MinUserDC, определяет максимальное число контроллеров домена, которые будут запрашиваться перед обращением к эмулятору PDC. Например, если установить для MinUserDC значение 4, DSAccess исключит эмулятор PDC из списка, только когда имеется 4 контроллера доменов. Если это условие выполнено, эмулятор PDC исключается из списка используемых контроллеров, и DSAccess обращается только к оставшимся 3 контроллерам доменов.

Перед правкой реестра, а также для получения дополнительных сведений о правке реестра просмотрите статью 256986 базы знаний корпорации Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Для получения дополнительных сведений об использовании параметра реестра MinUserDC см. статью 298879 базы знаний корпорации Майкрософт «XADM: Возможны проблемы с производительностью Exchange 2000 при использовании эмулятора PDC компонентом DSAccess» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298879).


Существует более 1000 хранилищ почтовых ящиков
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-12-13

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory® и подсчитывает количество объектов банка данных Microsoft Exchange с помощью класса объекта msExchPrivateMDB. Если анализатор сервера Exchange определяет, что в организации существует более 1000 хранилищ почтовых ящиков, отображается предупреждение.

Предупреждение отображается из-за известного вопроса, связанного с невозможностью входа пользователей в почтовые ящики из веб-клиента Microsoft Office Outlook® 2003 через серверы переднего плана в организациях, имеющих более 1000 хранилищ почтовых ящиков. Этот вопрос вызван методом пересылки запроса проверки подлинности сервером переднего плана Exchange на внутренний сервер Exchange.

Если пользователи пытаются получить доступ к хранилищам почтовых ящиков с серверов переднего плана и получают подобное предупреждение, необходимо выполнить следующее:

  • Загрузить и установить исправление сервера Exchange, описанное в статье 899902 базы знаний Майкрософт, посвященной сообщению об ошибке 401 при попытке доступа к почтовому ящику, находящемуся на сервере переднего плана Exchange Server 2003, с помощью веб-клиента Outlook (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=899902).

  • Если возможно, объедините почтовые ящики в меньшее количество хранилищ почтовых ящиков.

  • Настройте обычную проверку подлинности серверов переднего плана на внутренних серверах. Этому посвящена оставшаяся часть статьи.

По умолчанию серверы переднего плана Exchange Server 2003 используют проверку подлинности Kerberos, чтобы защитить учетные данные пользователей на серверах переднего плана и внутренних серверах. Если проверка подлинности Kerberos заканчивается неудачно, будет зарегистрировано событие и сервер переднего плана попробует проверку подлинности NTLM. Если и NTLM завершится неудачно, ошибка будет зарегистрирована. Проверка подлинности Kerberos повторится через 30 минут. При проверке подлинности компьютеров переднего плана Exchange 2000 Server или Exchange Server 2003 на внутренних компьютерах Exchange 2000 Server используется NTLM. В службах IIS и системном менеджере Exchange нет пользовательских интерфейсов для выбора механизмов проверки подлинности.

При настройке сервера Exchange переднего плана на использование обычной проверки подлинности требуется установить значение раздела реестра на всех серверах переднего плана в организации. В следующей процедуре объясняется, как установить значение этого раздела вручную.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы настроить серверы переднего плана Exchange на использование обычной проверки подлинности на внутренних серверах Exchange

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

    Перейдите к разделу = HKEY_LOCAL_MACHINE\System\CurrentControlSet\Service\MSExchangeWeb

  2. Щелкните правой кнопкой мыши MSExchangeWeb, затем щелкните Создать и Раздел. Назовите новый раздел Dav.

  3. Щелкните правой кнопкой мыши раздел Dav, наведите курсор на пункт Создать, затем щелкните Значение DWORD.

  4. Назовите новый раздел UseBasicAuthToBE и установите для него значение 1.

  5. Откройте оснастку служб, правой кнопкой мыши щелкните IIS Admin Service, затем щелкните Перезапустить.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Большинство действующих вызовов store.exe ожидают ответа ESE
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-13

Средство анализатора сервера Microsoft® Exchange Server просматривает файл Store.fcl журнала вызовов функций Exchange на наличие событий, которые указывают на действующие межкомпонентные вызовы модуля расширяемого хранилища Exchange (ESE) из службы банка данных Microsoft Exchange (Store.exe).

Действующий вызов — это запрос, исходящий из службы банка данных Microsoft Exchange (Store.exe), к другим компонентам, на который не получен ответ на момент записи данных журнала вызовов функций в файл Store.fcl.

Служба банка данных Microsoft Exchange расположена поверх базы данных ESE. ESE является сложным модулем на основе транзакций. Транзакция представляет собой серию операций, определяемых в качестве элементарных (невидимых) единиц. Все операции в транзакции являются либо выполненными и окончательно сохраненными, либо ни одна из операций не является выполненной.

Сервер Exchange Server использует ESE в качестве встроенного модуля базы данных, определяющего структуру базы данных и управляющего распределением памяти. Модуль базы данных кэширует базу данных в памяти, передавая четырехкилобайтные (КБ) блоки данных (страницы) в память и из нее. Он обновляет страницы в памяти и записывает новые или обновленные страницы обратно на диск. Когда система получает запрос, модуль базы данных может буферизировать данные в памяти. Таким образом, ему не требуется постоянно осуществлять доступ к диску.

Хотя кэширование данных в памяти является самым быстрым и эффективным способом обработки данных, его использование означает, что когда выполняется Exchange, сведения на диске никогда полностью не соответствуют самым последним данным. Последняя версия базы данных находится в памяти. Однако поскольку многие изменения, представленные в памяти, пока еще отсутствуют на диске, база данных и память не синхронизированы между собой. Диск журнала транзакций всегда соответствует текущим сведениям о каждой транзакции.

Если анализатор сервера Exchange Server обнаружит, что события в файле ведения журнала Store.fcl отражают преобладание вызовов, поступающих от службы банка данных Exchange (Store.exe) в базу данных ESE, анализатор сервера Exchange Server отобразит ошибку.

Когда межкомпонентные вызовы от службы базы данных Microsoft Exchange(Store.exe) ожидают ответа, потоки удаленных вызовов процедур могут архивироваться на фоне этих запросов, что может привести к понижению производительности сервера Exchange Server, например из-за задержек в ответах сервера на запросы клиентов.

Причиной действующих вызовов, поступающих от службы база данных Microsoft Exchange в ESE, может служить наличие следующих условий:

  • Выполнение оперативной дефрагментации Exchange.

  • Выполнение архивирования данных.

    Примечание.
    Если архивирование данных или оперативная дефрагментация выполнялись во время сбора сведений для журнала трассировки вызовов Exchange, можно спокойно игнорировать сообщение об ошибке, информирующее о снижении производительности сервера Exchange Server.
  • Наличие критических ограничений для дисков баз данных, таких как недостаточная емкость диска для данного количества пользователей на сервере.

  • Наличие критических ограничений для дисков TEMP и TMP.

Чтобы устранить эту ошибку, выполните следующие шаги:

  • Рекомендуется не перекрывать окна архивирования или оперативной поддержки с интервалами наибольшего спроса со стороны пользователей.

  • Убедитесь, что дисководы базы данных исправны и имеют достаточную пропускную способность для ввода-вывода данных.

  • Запустите анализатор сервера Exchange Server для выполнения дополнительного анализа сервера. Анализатор сервера Exchange можно загрузить с веб-страницы Microsoft Exchange Server Best Practices Analyzer Tool v2.7 (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Ознакомьтесь со статьями в разделе «Дополнительные сведения» данного документа.

Дополнительные сведения

Дополнительные сведения о настройке окон времени оперативной дефрагментации см. в базе знаний Майкрософт в статье 244524, описывающей способы настройки окон времени оперативной дефрагментации Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524).

Дополнительные сведения о критических дисковых ограничениях Exchange Server см. в статье, описывающей Обнаружено узкое место на диске.

Дополнительные сведения об определении размеров дисков и оптимизации их использования для сервера Exchange Server см. в разделах, описывающих расчет требований к системе ввода-вывода диска и общие рекомендации для нескольких архитектур, которые содержатся в статье, посвященной оптимизации хранилища для Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=49324).

Дополнительные сведения о ESE см. в статье, посвященной архитектуре модуля ESE (http://go.microsoft.com/fwlink/?linkid=67009).


Большинство действующих вызовов store.exe ожидают ответа от IMAIL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-13

Средство анализатора сервера Microsoft® Exchange просматривает файл Store.fcl журнала вызовов функций сервера Exchange (Function Call Log, FCL) на наличие событий, которые указывают на доминирование действующих межкомпонентных вызовов из службы «Банк данных Microsoft Exchange» (Store.exe) компонента IMAIL, принадлежащего клиенту MAPI.

Действующий вызов — это запрос, исходящий из службы «Банк данных Microsoft Exchange» (Store.exe), к другим компонентам, на который не получен ответ на момент записи данных журнала вызовов функций в файл Store.fcl.

Компонент IMAIL сервера Exchange Server — это гибкая служба преобразования, которая используется службой «Банк данных Microsoft Exchange» между сообщениями из Интернета и MAPI-сообщениями. Этот компонент обеспечивает взаимодействие между клиентами, использующим RFC-822 или формат Интернета, и клиентами, использующим формат внутреннего хранилища сервера Exchange, такими как клиенты MAPI или внутренние задачи STORE.

Приложение Exchange использует механизм IMAIL для применения форматов сообщений к содержимому в соответствии с тем, как это определено для доменов Интернета в системном диспетчере Exchange или как указано пользователем для каждого получателя в Microsoft Office Outlook®. Если в IMAIL не передано никаких параметров форматирования, механизм IMAIL форматирует MAPI-сообщения в формате S/TNEF (Summary TNEF) для передачи между серверами.

Если анализатор сервера Exchange обнаруживает в файле (Store.fcl) журнала события, которые отражают преобладание действующих вызовов от службы «Банк данных Microsoft Exchange» (Store.exe) к компоненту IMAIL, принадлежащему MAPI, анализатор сервера Exchange выведет на экран сообщение об ошибке.

Когда межкомпонентные вызовы от службы «Банк данных Microsoft Exchange» (Store.exe) ожидают ответа, потоки удаленных вызовов процедур могут архивироваться на фоне этих запросов, что может быть причиной проблем производительности сервера Exchange.

Действующие вызовы от службы «Банк данных Microsoft Exchange» к компоненту IMAIL клиента MAPI могут происходить при соблюдении одного или нескольких из следующих условий:

  • Механизм IMAIL пытается обработать много данных в сообщении или вложении.

  • Многие клиенты запрашивают преобразование данных.

  • Ответы на запросы DSAccess приходят с задержкой.

  • Не хватает ресурсов на дисках TEMP и TMP.

  • Существуют выполняющиеся перемещения почтовых ящиков.

Чтобы устранить эту ошибку, выполните следующие шаги:

  • Планируйте любые перемещения почтовых ящиков на часы внепиковой нагрузки.

  • Запустите анализатор сервера Exchange для дополнительного анализа проблем сервера, таких как предельные размеры сообщений и вложений. Анализатор сервера Exchange можно загрузить на веб-узле средства версии 2.7 анализа рекомендаций Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Ознакомьтесь со статьями в разделе «Дополнительные сведения» данного документа.

Дополнительные сведения

Дополнительные сведения о проблемах отсутствия достаточных ресурсов на диске для сервера Exchange см. по ссылке Обнаружено узкое место на диске.

Дополнительные сведения об определении размеров дисков и оптимизации их использования для сервера Exchange см. в разделах, описывающих расчет требований к системе ввода-вывода диска и общие рекомендации для нескольких архитектур, которые содержатся в статье, посвященной оптимизации хранилища для Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=49324).

Дополнительные сведения о рекомендациях по предельным размерам сообщений на сервере Exchange см. по ссылке Максимальный размер исходящего сообщения не задан.

Дополнительные сведения о производительности DSAccess и сервера Exchange см. разделе, содержащем инструкции по настройке пользовательского кэша DSAccess, в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

Дополнительные сведения об устранении проблем производительности сервера Exchange см. в описании процедур устранения неполадок, связанных с производительностью сервера Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=47588).

Дополнительные сведения об устранении проблем производительности банка данных см. в базе знаний Майкрософт в статье 257725, содержащей инструкции по сбору диагностических данных для устранения неполадок банка данных (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


Большинство действующих вызовов store.exe ожидают ответа от LSASS
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-11

Анализатор сервера Microsoft® Exchange просматривает файл Store.fcl журнала вызовов функций Exchange (FCL) в поиске событий, которые указывают на преобладание действующих межкомпонентных вызовов из службы «Банк сообщений Microsoft Exchange» (Store.exe) процесса сервера проверки подлинности локальной системы безопасности (Lsass.exe).

Действующий вызов — это запрос, исходящий из службы «Банк данных Microsoft Exchange» (Store.exe), к другим компонентам, на который не получен ответ на момент записи данных журнала вызовов функций в файл Store.fcl.

Процесс сервера проверки подлинности локальной системы безопасности (Lsass.exe) — это подсистема безопасности, вызываемая другими процессами для проверки сведений учетной записи и правильности входа в систему.

При каждом входе в систему клиента Exchange сервер, на котором выполняется сервер Exchange, посылает запрос на просмотр идентификатора безопасности учетной записи клиента и создает вызов внутри процесса Lsass.exe.

Если анализатор сервера Exchange обнаруживает события в файле журнала (Store.fcl), которые отражают преобладание действующих вызовов от службы Store.exe к процессу Lsass.exe, анализатор сервера Exchange выводит сообщение об ошибке.

Когда межкомпонентные вызовы от службы «Банк данных Microsoft Exchange» (Store.exe) ожидают ответа, потоки удаленных вызовов процедур могут архивироваться на фоне этих запросов, что может быть причиной проблем производительности сервера Exchange.

Действующие вызовы от службы «Банк сообщений Microsoft Exchange» к процессу LSASS могут быть обусловлены следующими причинами:

  • Проблемы ресурсов сервера, касающиеся ряда пользователей, одновременно проходящих проверку подлинности.

  • Задержки сети между сервером Exchange и контроллером домена или сервером глобального каталога.

  • Проблемы узких мест в ресурсах сервера.

Чтобы устранить эту ошибку, выполните следующие шаги:

  • Рассмотрите возможность применения параметра NeverPing, как описано в статье Рекомендуется параметр NeverPing.

  • Ознакомьтесь со статьями в разделе «Дополнительные сведения» данного документа.

Дополнительные сведения

Дополнительные сведения о процессе Lsass.exe и использовании памяти см. в базе знаний Майкрософт в статье 308356, описывающей использование памяти процессом Lsass.exe на контроллерах доменов, работающих под управлением Windows Server 2003 или Windows 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356).

Дополнительные сведения о проблемах входов в систему клиентов Exchange и процесса LSASS см. в базе знаний Майкрософт в статье 161938, описывающей замедление процессов входа в систему клиентов Exchange из-за блокировки ресурсов (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938).

Дополнительные сведения о задержках сети между сервером Exchange и контроллером домена или сервером глобального каталога см. в статье блога группы поддержки сервера Exchange, описывающей причины, почему приложением Exchange не всегда используются серверы глобального каталога (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=69166).

Примечание.
Содержимое и URL-адрес каждого блога могут изменяться без предварительного уведомления.

Дополнительные сведения о проблемах узких мест в ресурсах сервера см. по ссылке Узкое место в работе процессора.

Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

Дополнительные сведения об устранении проблем производительности сервера Exchange см. в описании процедур устранения неполадок, связанных с производительностью сервера Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).

Дополнительные сведения об устранении проблем производительности банка данных см. в базе знаний Майкрософт в статье 257725, содержащей инструкции по сбору диагностических данных для устранения неполадок банка сообщений (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


Большинство действующих вызовов store.exe ожидают ответа от каталога
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-14

Средство анализатора сервера Microsoft® Exchange просматривает файл Store.fcl журнала вызовов функций сервера Exchange (Function Call Log, FCL) на наличие событий, которые указывают на доминирование действующих межкомпонентных вызовов из службы банка данных Microsoft Exchange (Store.exe) службы каталогов Active Directory®.

Действующий вызов — это запрос, исходящий из службы банка данных Microsoft Exchange (Store.exe), к другим компонентам, на который не получен ответ на момент записи данных журнала вызовов функций в файл Store.fcl.

Служба каталогов Active Directory предоставляет все сведения по почтовым ящикам, службы списков адресов и другие сведения, относящиеся к получателям. Большинство сведений о конфигурации Exchange Server 2003 хранятся в службе каталогов Active Directory.

Службы сервера Exchange получают доступ к сведениям, хранящимся в службе каталогов Active Directory, и записывает сведения в службу каталогов Active Directory.

Если анализатор сервера Exchange обнаруживает в файле (Store.fcl) журнала события, которые отражают преобладание действующих вызовов от службы банка данных Microsoft Exchange (Store.exe) в службу каталогов Active Directory, анализатор сервера Exchange выведет на экран сообщение об ошибке.

Когда межкомпонентные вызовы от службы банка данных Microsoft Exchange (Store.exe) ожидают ответа, потоки удаленных вызовов процедур могут архивироваться на фоне этих запросов, что может быть причиной проблем производительности сервера Exchange, например задержек ответов сервера на запросы клиентов.

Действующие вызовы от службы банка данных Microsoft Exchange к службе каталогов Active Directory могут быть обусловлены следующими причинами:

  • задержки сети между сервером Exchange и контроллером домена;

  • статическая или, в противном случая, некорректная конфигурация DSAccess;

  • перегруженный контроллер домена и глобальный каталог;

  • некорректно разработанная топология Active Directory.

Чтобы устранить эту ошибку, выполните следующие шаги:

  • Запустите анализатор сервера Exchange для дополнительного анализа проблем сервера, таких как предельные размеры сообщений и вложений. Анализатор сервера Exchange можно загрузить на веб-узле средства версии 2.7 анализа рекомендаций Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Проверьте производительность серверов контроллера домена Active Directory.

  • Ознакомьтесь со статьями в разделе «Дополнительные сведения» данного документа.

Дополнительные сведения

Дополнительные сведения о производительности Exchange и DSAccess см. в статье 250570 базы знаний Майкрософт, описывающей процедуру обнаружения сервера в службе каталогов и использование DSAccess (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570).

Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

Дополнительные сведения об устранении проблем производительности сервера Exchange см. в описании процедур устранения неполадок, связанных с производительностью сервера Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).

Дополнительные сведения об устранении проблем производительности банка данных см. в базе знаний Майкрософт в статье 257725, содержащей инструкции по сбору диагностических данных для устранения неполадок банка данных (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

Дополнительные сведения о производительности контроллера домена см. на следующих ресурсах, посвященных серверам Windows:

  • статья, посвященная планированию вместительности контроллера домена (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=70191);

  • статья, посвященная наблюдению за контроллерами домена Active Directory, в руководствах по планированию и развертыванию службы каталогов Active Directory в Windows 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=70193).


Большинство действующих вызовов store.exe ожидают ответа от антивирусного программного обеспечения
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-13

Средство анализатора сервера Microsoft® Exchange просматривает файл Store.fcl журнала вызовов функций сервера Exchange (Function Call Log, FCL) на наличие событий, которые указывают на доминирование действующих межкомпонентных вызовов из службы «Банк данных Microsoft Exchange» (Store.exe) компонента Virusscan VAPI.

Действующий вызов — это запрос, исходящий из службы «Банк данных Microsoft Exchange» (Store.exe), к другим компонентам, на который не получен ответ на момент записи данных журнала вызовов функций в файл Store.fcl.

Если анализатор сервера Exchange обнаруживает в файле (Store.fcl) журнала события, которые отражают преобладание действующих вызовов от службы «Банк данных Microsoft Exchange» (Store.exe) к компоненту Virusscan VAPI, анализатор сервера Exchange выведет на экран сообщение об ошибке.

Когда межкомпонентные вызовы от службы «Банк данных Microsoft Exchange» (Store.exe) ожидают ответа, потоки удаленных вызовов процедур могут архивироваться на фоне этих запросов, что может быть причиной проблем производительности сервера Exchange, например задержек ответов сервера на запросы клиентов.

Действующие вызовы от службы «Банк данных Microsoft Exchange» к компоненту Virusscan VAPI могут быть обусловлены следующими причинами:

  • обновления антивирусного программного обеспечения привели к повторной проверке элементов банка данных;

  • антивирусное программное обеспечение настроено неверно;

  • антивирусное программное обеспечение обрабатывает большое сообщение или вложение.

Чтобы устранить эту ошибку, выполните следующие шаги:

  • Настройте расписание обновлений в антивирусном модуле на время, когда потребление ресурсов является низким, то есть на часы внепиковой нагрузки.

  • Рассмотрите возможность повторной установки антивирусного программного обеспечения, но только во время внепиковой нагрузки.

  • Просмотрите конфигурацию модуля антивирусного сканера, чтобы изменить конфигурацию потоков, исключения на уровне файлов и другие параметры. Прочитайте статью 823166 базы знаний Майкрософт, в которой содержится обзор Exchange и антивирусного программного обеспечения (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Ознакомьтесь со статьями в разделе «Дополнительные сведения» данного документа.

Дополнительные сведения

Дополнительные сведения о разных видах антивирусных программ, обычно используемых с Microsoft Exchange Server 2003 см. в статье 823166 базы знаний Майкрософт, описывающей антивирусное программное обеспечение для Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Дополнительные сведения о разных видах антивирусных программ, обычно используемых на серверах Microsoft Exchange 2000 см. в статье 328841 базы знаний Майкрософт, описывающей антивирусное программное обеспечение для Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

Дополнительные сведения об устранении проблем производительности сервера Exchange см. в описании процедур устранения неполадок, связанных с производительностью сервера Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).

Дополнительные сведения об устранении проблем производительности банка данных см. в базе знаний Майкрософт в статье 257725, содержащей инструкции по сбору диагностических данных для устранения неполадок банка данных (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


Большинство действующих вызовов store.exe ожидают ответа от снимка службы VSS
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-13

Средство анализатора сервера Microsoft® Exchange просматривает файл Store.fcl журнала вызовов функций Exchange (Function Call Log, FCL) на наличие событий, которые указывают на действующие межкомпонентные вызовы из службы «Банк данных Microsoft Exchange» (Store.exe) к компоненту снимка службы теневого копирования томов (Volume Shadow Copy Service — VSS)

Действующий вызов — это запрос, исходящий из службы «Банк данных Microsoft Exchange» (Store.exe), к другим компонентам, на который не получен ответ на момент записи данных журнала вызовов функций Exchange в файл Store.fcl.

VSS — это набор COM-интерфейсов API, которые составляют структуру, позволяющую выполнять архивирование томов в процессе записи приложениями системы данных в эти тома.

Microsoft Exchange Server 2003 использует службу VSS, включенную в комплект поставки операционной системы Microsoft Windows Server™ 2003 для выполнения теневого копирования баз данных Exchange Server 2003 и файлов журналов транзакций.

Снимок VSS не является полностью независимым от исходных данных. Обычно снимки создаются при определении метки времени и позвляют выполнить откат данных к соответствущему моменту времени.

Если анализатор сервера Exchange обнаружит события в файле журнала Store.fcl, которые отражают действующие вызовы от службы «Банк данных Microsoft Exchange» (Store.exe) к компоненту снимка VSS, анализатор сервера Exchange выведет на экран сообщение с рекомендацией.

Когда межкомпонентные вызовы от службы «Банк данных Microsoft Exchange» (Store.exe) ожидают ответа, потоки удаленных вызовов процедур могут архивироваться на фоне этих запросов, что может быть причиной проблем производительности сервера Exchange.

Примечание.
Если снимок VSS был намеренно инициализирован в течение 20 секунд с начала всбора данных для ведения журналов Exchange Call Trace, можно не рассматривать это сообщение как признак возникновения проблем с производительностью сервера Exchange.

В таком случае не рекомендуется, чтобы обслуживание в интерактивном режиме или интервалы наивысшей активности пользователей перекрывали работу окон, в которых выполняется архивация.

Дополнительные сведения

Дополнительные сведения о службе VSS см. в статье, посвященной использованиию службы теневого копирования томов с Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=56571).


Файл MOUNTMGR.SYS имеет неправильную версию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-02-13

Средство анализатора сервера Microsoft® Server считывает следующий раздел реестра, чтобы определить, установлена ли операционная система Microsoft Windows® Server 2003: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\

Анализатор сервера Exchange Server также запрашивает:

  • WMI-класс Win32_OperatingSystem, чтобы определить, установлена ли операционная система Windows Server 2003 с пакетом обновления 1 (SP1).

  • WMI-класс Win32_Service, чтобы определить, выполняется ли служба кластеров.

  • WMI-класс Win32_Volume, чтобы определить, имеются ли точки подключения томов.

  • WMI-класс CIM_Datafile, чтобы определить, что значение ключаVersion для Mountmgr.sys меньше 2443.

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Ключ Version для Mountmgr.sys меньше 2443.

  • Сервер является узлом кластера, в котором выполняется Windows Server 2003 с пакетом обновления 1 (SP1).

  • Сервер имеет точки подключения томов.

Версия Mountmgr.sys установленная в узле кластера может привести к ошибкам точек подключения томов. Эта проблема возникает в связи с ошибкой в драйвере Mountmgr.sys. Эта ошибка является ошибкой временной недоступности точек подключения томов.

Примечание.
Вообще говоря, эта ошибка не возникает в некластеризованной среде. В некластеризованной среде настройка во времени процесса подключения тома может быть различной.

Дополнительные сведения по этой проблеме см. в базе знаний Майкрософт в статье 898790 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790).


Перемещение каталогов Temp и TMP
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-09-01

Средство анализатора Microsoft® Exchange Server определило, что папки TEMP и TMP для сервера не могут быть размещены так, чтобы обеспечить оптимальную производительность диска. Для получения наилучших результатов рекомендуется хранить папки TEMP и TMP в дисковой подсистеме, ресурсы которой не используются совместно системной папкой или файлами данных Exchange.

Служба банка данных Microsoft Exchange использует папки TEMP и TMP в качестве временного хранилища во время разнообразных операций, например при преобразовании сообщений, работе с большими вложениями и при операциях перемещения почтовых ящиков. Переменные среды папок TEMP и TMP используются для определения, какие папки в файловой системе (например, какой путь) будут использоваться приложениями, требующими наличия временной рабочей области. Папка TEMP обычно используется приложениями, например Microsoft Exchange, а папка TMP обычно используется средствами разработки, например Microsoft Visual C++®. Путь для каждой переменной обычно соотносится с контекстом безопасности приложения или средства.

На некластерном сервере Exchange хранилище Exchange использует папку SYSTEM (например, Local System), применяющей параметр переменной среды, равный %Systemroot%\Temp, и для папки TEMP, и для папки TMP. Виртуальные серверы Exchange, работающие в кластере сервера Microsoft Windows®, применяют параметры переменных среды для учетной записи службы кластеров, которая работает в контексте определенного принципа безопасности пользователя. Для учетных записей пользователя переменной среды по умолчанию для папок TEMP и TMP присваивается значение %Userprofile%\Temp.

В данном разделе объясняется порядок перемещения каталогов TEMP и TMP в кластерной и некластерной средах. Прежде чем начать выполнение процедур, описанных в этом разделе, учтите следующие рекомендации:

  • Для достижения оптимальной производительности для папок TEMP и TMP, используемых сервером Exchange, рекомендуется не использовать диск, содержащий операционную систему. Кроме того, следует убедиться, что переменные среды настроены на пути, включающие в себя быстрый диск или дисковую подсистему, например с комплектом шпинделей RAID-0+1.

  • Рекомендуется не применять дисковые журналы транзакций Exchange для используемых папок TEMP и TMP.

Чтобы переместить папки TEMP или TMP в некластерной среде

  1. Войдите в компьютер, на котором работает сервер Exchange, под учетной записью с правами администратора.

  2. Щелкните правой кнопкой мыши Мой компьютер и в контекстном меню выберите Свойства.

  3. Выберите вкладку Дополнительно.

  4. Щелкните Переменные среды.

  5. В области Системные переменные выберите TEMP и затем щелкните Изменить.

  6. В поле Значение переменной введите новый путь для переменной среды для папки TEMP и затем нажмите кнопку ОК.

  7. В области Системные переменные выберите TMP и затем щелкните Изменить.

  8. В поле Значение переменной введите новый путь для переменной среды папки TMP и затем нажмите кнопку ОК.

  9. Нажмите кнопку ОК, чтобы закрыть диалоговое окно Переменные среды и затем нажмите кнопку ОК, чтобы закрыть диалоговое окно Свойства системы.

  10. Перезагрузите сервер, чтобы все изменения вступили в силу.
Чтобы переместить папки TEMP или TMP в кластерной среде

  1. Войдите в узел в кластере под учетной записью службы кластеров.

  2. Щелкните правой кнопкой мыши Мой компьютер и в контекстном меню выберите Свойства.

  3. Щелкните Дополнительно.

  4. Щелкните Переменные среды.

  5. В области Пользовательские переменные для <имени учетной записи> выберите TEMP и затем щелкните Изменить.

  6. В поле Значение переменной введите новый путь для переменной среды папки TEMP и затем нажмите кнопку ОК.

  7. В области Пользовательские переменные для <имени учетной записи> выберите TMP и затем щелкните Изменить.

  8. В поле Значение переменной введите новый путь для переменной среды папки TMP и затем нажмите кнопку ОК.

  9. Нажмите кнопку ОК, чтобы закрыть диалоговое окно Переменные среды, и затем нажмите кнопку ОК, чтобы закрыть диалоговое окно Свойства системы.

  10. Перезапустите узел, чтобы изменение вступило в силу.

  11. Повторите шаги с 1 по 10 для каждого узла кластера.
Важно!
Необходимо предоставить учетной записи пользователя, прошедшего проверку подлинности, разрешения на работу с папками TMP и TEMP, расположенными по новому пути.
Чтобы назначить группе пользователей, прошедших проверку подлинности, разрешения на работу с папками TMP или TEMP

  1. Запустите проводник Windows, найдите и затем щелкните правой кнопкой мыши папку, на которую указывает переменная TEMP или переменная TMP, а затем в контекстном меню выберите пункт Свойства.

  2. В диалоговом окне «Свойства Temp» откройте вкладку Безопасность, а затем щелкните Добавить.

  3. В диалоговом окне «Выбор: Пользователи, Компьютеры или Группы» добавьте группу пользователей, прошедших проверку подлинности, в список имен объектов и нажмите кнопку OK.

  4. Щелкните Дополнительно, чтобы получить доступ к расширенным параметрам безопасности.

  5. Выберите Пользователи, прошедшие проверку подлинности в списке Имя, а затем нажмите кнопку Изменить, чтобы открыть диалоговое окно «Ввод разрешения».

  6. Используйте поля в области «Разрешения», чтобы предоставить следующие специальные разрешения:

    Обзор папок / Выполнение файлов

    Создание файлов / Запись данных

    Создание папок / Дозапись данных

  7. Нажмите кнопку OK три раза, чтобы применить разрешения и закрыть диалоговое окно.

Дополнительные сведения

  • Дополнительные сведения о производительности сервера Exchange см. в Руководстве по управлению производительностью и масштабируемостью приложения Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Дополнительные сведения об устранении проблем с производительностью сервера Exchange см. в разделе Устранение неполадок, связанных с производительностью приложения Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Перенос почтовых ящиков пользователей на другой сервер
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-09-06

Средство анализатора сервера Microsoft® Exchange определило, что пользовательская нагрузка, существующая в настоящий момент на сервере, больше нагрузки, которую он может эффективно поддерживать. Такая пользовательская нагрузка является причиной уменьшения производительности. Рекомендуется переместить пользователей в другое место: каждую ночь перемещайте небольшое количество пользователей (как правило, пять процентов от общего количества), пока сбои производительности не исчезнут.

Этот подход рекомендуется, так как причиной является возникновение следующих неполадок:

  • Некоторые файлы базы данных Exchange находятся на дисках, свободного места на которых почти не осталось.

  • Другие ресурсы сервера (например память или центральный процессор) исчерпали свою емкость.

  • Нагрузка на диск превышает его возможности — это означает, что дисковая подсистема, поддерживающая в настоящее время одно или несколько хранилищ Exchange, имеет среднюю задержку дисковых операций ввода-вывода, которая превышает текущие рекомендованные уровни. Перемещайте по пять процентов от общего числа пользователей в базу данных, находящуюся на другой дисковой подсистеме, до исчезновения неполадки. Если причиной уменьшения производительности являются диски, хранящие базу данных, переместите пользователей в базу, находящуюся на другом диске. Если диск, на котором находится группа хранилищ, является причиной уменьшения производительности, переместите пользователей в базу данных, расположенную в группе хранилищ, находящуюся на другом диске. Если диски используются еще одним ресурсом, другим возможным решением является снижение нагрузки других приложений на эти диски.

  • Физический сервер используется сверх его возможностей. Недостаточно производительности процессора или памяти для обслуживания нагрузки на сервер, создаваемой пользователями. Следует переместить пять процентов пользователей на другой сервер, пока проблемы с производительностью не будут разрешены.

Примечание.
Хотя во время операции перемещения почтовых ящиков не требуется отключать клиентов Exchange от их почтовых ящиков, рекомендуется выполнять перемещение при низкой активности клиентов Exchange, например в часы внепиковой нагрузки, чтобы избежать возможных перебоев в работе службы.
Перемещение почтовых ящиков на Exchange Server 2003

  1. Запустите диспетчер Exchange на компьютере Exchange Server 2003, на котором требуется выполнить процесс.

  2. Дважды щелкните Серверы, а затем найдите контейнер серверов, в котором находятся почтовые ящики пользователей.

    Например, если требуется переместить почтовые ящики из группы хранения по умолчанию и из хранилища почтовых ящиков, дважды щелкните Первая группа хранения, дважды щелкните Хранилище почтовых ящиков, а затем щелкните Почтовые ящики.

  3. В области результатов выберите почтовые ящики, которые необходимо перенести.

  4. Щелкните правой кнопкой выбранных пользователей и в контекстном меню выберите пункт Задачи Exchange.

  5. В окне мастера задач Exchange нажмите кнопку Далее.

  6. На странице Доступные задачи щелкните Перемещение почтового ящика в разделе Выберите задачу для выполнения, а затем нажмите кнопку Далее.

  7. На странице Перемещение почтового ящика в списке Сервер щелкните требуемый сервер, а затем в списке Хранилище почтовых ящиков выберите требуемое хранилище почтовых ящиков.

  8. Нажмите кнопку Далее.

  9. Настройте требуемым образом обработку, выполняющуюся в отношении любых поврежденных сообщений, которые могут быть найдены во время перемещения, а затем нажмите кнопку Далее.

  10. Нажмите кнопку Далее.

Дополнительные сведения

  • Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению быстродействием и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Дополнительные сведения об устранении проблем, связанных с быстродействием сервера Exchange, см. на веб-узле, посвященном устранению неполадок, связанных с быстродействием сервера Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Дополнительные сведения о перемещении почтовых ящиков в Exchange Server 2003 см. в базе знаний Майкрософт, в статье 821829, описывающей перемещение почтовых ящиков в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

  • Дополнительные сведения о перемещении почтовых ящиков между серверами Exchange 2000 Server и Exchange Server 5.5 см. в базе знаний Майкрософт, в статье 328810, описывающей перемещение почтовых ящиков между серверами (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810).


Проблема в конфигурации NAS
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchESEParamLogFilePath для каждого объекта группы хранения. Этот атрибут задает размещение файлов журнала транзакций, используемых базами данных а группе хранения.

Помимо этого, анализатор сервера Exchange запрашивает службу Active Directory, чтобы определить значение счетчика записей, перечисленных в атрибуте homeMDBBL каждого хранилища почтовых ящиков. Счетчик этого атрибута представляет количество почтовых ящиков в хранилище почтовых ящиков.

Средство анализатора Microsoft® Exchange также запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Service, чтобы определить значение ключа Started для службы пакета Microsoft Windows Storage Server 2003 (wssexchmap). Значение False указывает, что служба пакета Windows Storage Server 2003 не выполняется на сервере Exchange. Значение True указывает, что служба пакета Windows Storage Server 2003 выполняется.

Если анализатор сервера Exchange обнаруживает, что значение любого атрибута msExchESEParamLogFilePath начинается с S:\{ и что служба пакета Windows Storage Server 2003 запущена на компьютере с Exchange Server, где установлено более 1500 почтовых ящиков, на экран выводится предупреждение.

Windows Storage Server 2003 представляет собой платформу Майкрософт для устройств NAS. Структура хранилища Windows Storage Server 2003 рекомендована для использования с Exchange Server 2003. Она несколько отличается от стандартной структуры Exchange Server. Рекомендуется использовать конфигурацию, в которой базы данных Exchange Server размещаются на сервере Windows Storage Server 2003, а файлы журнала транзакций хранятся на локальном диске компьютера под управлением Exchange Server.

Корпорация Майкрософт разработала пакет Windows Storage Server 2003 для трех видов нагрузки:

  • Небольшая нагрузка: до 250 почтовых ящиков на сервере Exchange Server, подключенном к одному компьютеру с Windows Storage Server. Для данного сценария рекомендуется использовать следующую конфигурацию Windows Storage Server: процессор 1 ГГц или более быстрый; 512 МБ ОЗУ; четыре диска SCSI или IDE/SATA, сконфигурированные как том RAID-5; две сетевые интерфейсные платы: одна для подключения к локальной сети и адаптер частной сети Gigabit Ethernet для прямого подключения к серверу Exchange. Базы данных Exchange хранятся на томе RAID-5; журналы транзакций остаются в локальном массиве RAID-1 сервера Exchange.

  • Средняя нагрузка: до 750 почтовых ящиков в одной группе хранения на сервере Exchange Server и один компьютер с Windows Storage Server. В этой конфигурации на компьютере с Windows Storage Server должны быть установлены два процессора 1 ГГц (или более быстрых), 1 ГБ ОЗУ, шесть дисков SCSI и две сетевые интерфейсные платы. Диски должны быть сконфигурированы как массив RAID-5 на основе четырех дисков для баз данных и отдельный массив на основе двух зеркальных дисков для журналов транзакций.

  • Высокая нагрузка: один или два сервера Exchange Server 2003, на которых размещено до 1500 почтовых ящиков в двух группах хранения. В этой конфигурации на компьютере с Windows Storage Server должны быть установлены два процессора 1 ГГц (или более быстрых), 2 ГБ ОЗУ и 14 дисков: 10 для массива RAID 0+1, применяемого для хранения баз данных, и два набора зеркальных дисков для журналов транзакций.

Это предупреждение указывает на то, что компьютер под управлением Exchange Server сконфигурирован для использования Windows Storage Server 2003 в качестве хранилища. При использовании Windows Storage Server для хранения данных Exchange Server рекомендуется, чтобы к Exchange Server одновременно подключалось менее 1500 пользователей.

Чтобы устранить причину появления этого предупреждения

  • Выполните одно из следующих действий:

    • Переместите журналы транзакций на локальный диск компьютера Exchange Server

    • Переместите часть почтовых ящиков на другой компьютер под управлением Exchange Server, чтобы на компьютере с Exchange Server, использующем Windows Storage Server, было не более 1500 почтовых ящиков.

Дополнительные сведения об использовании пакета Windows Storage Server 2003 с Exchange Server 2003 см в документе, посвященном управлению системой хранения Exchange с помощью пакета Windows Storage Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=34942).

Для получения дополнительных сведений см. следующие ресурсы:

  • Архитектура и развертывание Windows Storage Server 2003 — введение (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=34943)

  • Создание более защищенных хранилищ с помощью Windows Storage Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=34944)

  • Консолидация серверов с помощью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=47586)


Атрибут networkAddress установлен неправильно
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, содержит ли атрибут networkAddress строку ncacn_ip_tcp. Анализатор сервера Exchange выводит сообщение об ошибке при возникновении любого из следующих условий:

  • Строка ncacn_ip_tcp отсутствует.

  • Строка ncacn_ip_tcp повреждена.

В веб-клиенте Microsoft Office Outlook® для Exchange Server 2003 внешний сервер при попытке подключиться к фоновому серверу Exchange проверяет значение атрибута networkaddress.

Примечание.
Приложение Exchange 2000 Server при работе с веб-клиентом Outlook не выполняет этих действий.

Для внешнего сервера требуется указать значение полного доменного имени (FQDN). Внешний сервер проверяет наличие точки в значении, возвращаемом для networkaddress ncacn_ip_tcp. Запрос подключения для почтового ящика конкретного фонового сервера заканчивается неудачей и фоновый сервер возвращает пользователю сообщение об ошибке «HTTP 500 Внутренняя ошибка сервера» при возникновении следующих условий:

  • Значение networkaddress ncacn_ip_tcp представляет собой лишь имя узла или имя сетевой базовой системы ввода-вывода (NetBIOS).

  • Значение networkaddress ncacn_ip_tcp не является полным доменным именем.

Чтобы обеспечить поддержку соответствующих функций веб-клиента Outlook 2003, необходимо изменить значение networkaddress ncacn_ip_tcp для объекта сервера в службе Active Directory. Имя соответствующего сервера приведено в сообщении об ошибке анализатора сервера Exchange.

Внимание!
Если некорректно изменить атрибуты объектов Active Directory с помощью средства ADSI Edit (Active Directory Service Interfaces, ADSI), средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3, могут возникнуть серьезные проблемы. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Примечание.
Перед изменением значения ncacn_ip_tcp ознакомьтесь с оставшейся частью данной статьи. Чтобы минимизировать время простоя, вызываемое перезапуском служб сервера Exchange, до перезапуска служб сервера Exchange следует выполнить дополнительную процедуру.
Изменение значения ncacn_ip_tcp атрибута networkAddress

  1. Запустите средство ADSI Edit из средств поддержки Windows 2000 Server или из средств поддержки Windows Server 2003.

  2. Разверните следующие узлы:

    • Контейнер конфигурации,

    • Конфигурация,

    • Службы,

    • Microsoft Exchange

    • Имя_организации,

    • Административные группы,

    • Имя_административной_группы,

    • Серверы.

  3. Щелкните правой кнопкой мыши Имя_сервера_Exchange и в контекстном меню выберите команду Свойства.

  4. Щелкните сетевой_адрес в списке Атрибуты, а затем нажмите кнопку Изменить.

  5. Добавьте новое значение ncacn_ip_tcp. Используйте полное доменное имя сервера вместо имени NetBIOS или имени компьютера.

    Для этого значения используется синтаксис ncacn_ip_tcp:FQDN. Например, если имя компьютера фонового сервера Exchange EXCHANGE1, а его полное доменное имя EXCHANGE1.contoso.com, используйте для ncacn_ip_tcp следующее значение: ncacn_ip_tcp:EXCHANGE1.contoso.com

  6. Нажмите два раза кнопку OK, чтобы принять изменения.

  7. Перезапустите на компьютере все службы сервера Exchange.

  8. При наличии нескольких контроллеров домена дождитесь репликации, прежде чем пытаться подключиться с внешнего сервера. Если проблема сохраняется после завершения репликации, перезапустите на внешнем сервере службу IIS Admin Service.

Если на фоновых серверах ведутся файлы Hosts, ставящие в соответствие IP-адрес сервера и краткое имя узла, необходимо также изменить значение UpdateProtocols registry. Если используется файл Hosts, при перезапуске системного помощника Microsoft Exchange сервер Exchange должен восстановить первоначальное значение ncacn_ip_tcp. Если используется кластерная конфигурация фонового сервера, после смены узла сервер Exchange должен восстановить первоначальное значение ncacn_ip_tcp.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Изменение значение реестра «UpdateProtocols» для фоновых серверов, использующих файлы Hosts

  1. С помощью редактора реестра измените на фоновом сервере или серверах следующее значение реестра: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\UpdateProtocols

    Примечание.
    Если значение UpdateProtocols отсутствует, его необходимо создать. Для этого выполните следующие действия:

  2. Откройте редактор реестра и найдите следующий подраздел реестра: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\

    1. Щелкните правой кнопкой мыши Parameters, наведите указатель на пункт Создать и выберите Значение DWORD.

    2. Введите UpdateProtocols и затем клавишу ВВОД.

  3. Щелкните правой кнопкой мыши UpdateProtocols, выберите команду Изменить, введите 0 в поле Значение, а затем нажмите кнопку OK.

  4. Если на узле фонового кластера сети используется файл Hosts, измените порядок записей UpdateProtocols следующим образом:

    IPAddress to FQDN

    IPAddress to NetBIOS

    вместо:

    IPAddress to NetBIOS

    IPAddress to FQDN

  5. Перезапустите на компьютере все службы сервера Exchange.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в статье 256986 базы знаний Майкрософт, содержащей описание реестра Microsoft Windows, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986 (возможно, на английском языке).


Объект Network Interface системного монитора недоступен
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Bytes Total/sec объекта Network Interface системного монитора для анализа данных о производительности. Если данный счетчик не возвращает допустимые данные, выводится базовое сообщение.

Если допустимые данные не возвращаются модулем сбора данных о производительности, действует какое-либо из сочетаний следующих условий:

  • Объект системного монитора Network Interface отключен.

  • Объект системного монитора Network Interface отсутствует или поврежден.

  • Для анализатора сервера Exchange не назначены разрешения, необходимые для получения доступа к объектам системного монитора.

Первые два условия могут возникнуть в том случае, если реестр поврежден определенными расширяемыми счетчиками или изменен программами, основанными на классах инструментария управления Windows (WMI). Перед выполнением данной процедуры убедитесь, что анализатору сервера Exchange назначены соответствующие разрешения. Дополнительные сведения о разрешениях, требуемых для выполнения анализатора сервера Exchange, см. в справочной документации анализатора сервера Exchange. Чтобы открыть справку, откройте анализатор сервера Exchange и нажмите клавишу F1.

Чтобы устранить эту ошибку

  1. Убедитесь, что объект Network Interface системного монитора включен:

    1. Загрузите и установите средство списка расширяемых счетчиков производительности (Exctrlst.exe). Средство Exctrlst.exe можно загрузить на странице «Exctrlst.exe: расширяемый список счетчиков производительности» (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Откройте окно средства Exctrlst.exe, щелкните Sort Order, а затем — Service.

    3. Найдите службу, сведения о которой поставляет данный объект системного монитора и проверьте, установлен ли флажок Performance Counters Enabled.

      Если флажок Performance Counters Enabled не установлен, установите его, а затем перезапустите связанную с нужными счетчиками производительности службу, чтобы проверить, что эти счетчики производительности работоспособны. Если счетчики производительности не работоспособны или флажок Performance Counters Enabled уже установлен, перейдите к выполнению шага 2.

  2. Перестройте отсутствующие или поврежденные счетчики производительности в соответствии с инструкциями статьи 300956 базы знаний Майкрософт «How to manually rebuild Performance Counter Library values» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) (Инструкции по ручному созданию значений библиотеки счетчиков производительности).

  3. Если после выполнения процедуры, указанной в этой статье базы знаний, проблема не будет устранена, следует переустановить операционную систему Windows в режиме Восстановление, а затем применить последние пакеты обновления для сервера Windows.


Доступна более поздняя версия файла MSGTRACK.dll
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-10-05

Средство анализа Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах с сервером Exchange 2000 Server или Exchange Server 2003. Для анализа данных о производительности модуль сбора данных о производительности собирает данные из нескольких счетчиков производительности объекта производительности Processor.

Средство анализа Exchange также запрашивает класс инструментария WMI CIM_Datafile, чтобы определить значение, установленное для ключа Version файла Msgtrak.dll.

Средство анализа сервера Exchange выводит на экран предупреждение, если выполняются следующие условия:

  • На сервере наблюдается высокий уровень загрузки процессора.

  • Ключ Version файла Msgtrak.dll имеет значение меньше 6.0.6373.0.

Это предупреждение указывает на то, что версия обнаруженного файла Msgtrack.dll может вызывать высокую загрузку центрального процессора. Это предупреждение также означает, что обнаруженная версия файла Msgtrack.dll может быть причиной отображения процессом Inetinfo.exe очень высокой занятости памяти.

Для решения указанной проблемы получите обновление, указанное в статье 811409 базы знаний корпорации Майкрософт («XADM: отслеживание сообщений может привести к отображению процессом Inetinfo.exe очень высокой занятости памяти» по адресу http://go.microsoft.com/fwlink/?LinkId=3052&kbid=811409 (эта ссылка может указывать на содержимое частично или полностью на английском языке).


Доступна более новая версия файла WLDAP32.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-10-06

Средство анализа Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах с сервером Exchange 2000 Server или Exchange Server 2003. Для анализа данных о производительности модуль сбора данных о производительности собирает данные из нескольких счетчиков производительности объекта производительности Processor.

Средство Exchange Server Analyzer также считывает следующий раздел реестра, чтобы определить версию системы Microsoft Windows, под управлением которой работает компьютер с сервером Exchange:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Значение параметра CurrentVersion, равное4.0, указывает, что компьютер сервера Exchange работает под управлением Microsoft Windows NT® Server 4.0. Значение 5.0, указывает, что компьютер сервера Exchange работает под управлением Windows 2000 Server, а значение 5.2, указывает, что на компьютере сервера Exchange установлена операционная система Windows Server™ 2003.

Средство анализа Exchange Server также запрашивает класс инструментария WMI CIM_Datafile, чтобы определить значение, установленное для ключа Version в файле Wldap32.dll.

Средство анализа сервера Exchange выводит на экран предупреждение, если выполняются следующие условия:

  • Средство анализа Exchange Server обнаружило высокий уровень загрузки процессора на анализируемом сервере.

  • Компьютер с сервером Exchange Server работает под управлением системы Windows 2000 Server.

  • Значение ключа версии файла Wldap32.dll указывает, что файл имеет более раннюю версию, чем версия 5.0.2195.7044.

Это предупреждение означает, что обнаруженная версия файла Wldap32.dll может привести к тому, что процесс Inetinfo.exe будет потреблять 100 % ресурсов процессора на компьютерах под управлением системы Windows 2000 Server.

Решение этой проблемы см. в статье 899019 базы знаний Майкрософт «Процесс Inetinfo.exe может потреблять 100 % ресурсов процессора на компьютере под управлением системы Windows 2000 Server, на котором выполняется сервер Exchange 2000 Server» по адресу http://go.microsoft.com/fwlink/?LinkId=3052&kbid=899019 (эта ссылка может указывать на содержимое полностью или частично на английском языке).


Включена служба NNTP
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Windows® Management Instrumentation) Win32_Service, чтобы определить значение ключа Started для службы NNTP (NntpSvc). Значение True указывает, что служба NNTP выполняется на сервере Exchange.

Чтобы определить, настроен ли канал NNTP для сервера Exchange, анализатор сервера Exchange также считывает следующее свойство в базе данных IIS:

/LM/NNTPSVC/1/Feeds

Если анализатор сервера Exchange обнаруживает, что служба NNTP запущена, но для сервера не были настроены никакие каналы, на экран выводится предупреждение.

В целях экономии ресурсов и для обеспечения общей безопасности не следует запускать службы для неиспользуемых компонентов. Каждая запущенная служба открывает функциональные возможности, которые могут быть использованы злонамеренным пользователем. Рекомендуется отключить все неиспользуемые службы.

Чтобы отключить службу NNTP

  1. Нажмите кнопку Пуск, а затем последовательно выберите Программы, Администрирование, Службы.

  2. Щелкните правой кнопкой мыши службу NNTP и выберите команду Свойства.

  3. На вкладке Общие нажмите кнопку Стоп.

  4. В списке Тип запуска выберите Отключено, а затем нажмите кнопку ОК.

Дополнительные сведения по защите Exchange Server 2003 см. в руководстве по укреплению безопасности Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=47578).


Отсутствуют доступные для тестирования DNS-серверы.
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-12-05

Средство анализа сервера Microsoft® Exchange запрашивает класс Win32_NetworkAdapterConfiguration инструментария WMI, чтобы определить значение атрибута DNSServerSearchOrder для удаленных серверов, которым сервер Exchange Server пытается отправлять сообщения. Этот атрибут является массивом IP-адресов серверов, использующихся для запроса DNS-серверов.

Кроме того, средство анализа Exchange Server посылает службе каталога Active Directory® запрос на определение значения атрибута msExchSMTPExternalDNSServers класса protocolCfgSMTPServer для объектов серверов Exchange 2000 Server и Exchange Server 2003. Класс protocolCfgSMTPServer содержит параметры для виртуального SMTP-сервера. Если установлен атрибут msExchSMTPExternalDNSServers, то виртуальный SMTP-сервер использует внешний DNS-сервер.

Затем средство анализа Exchange Server использует следующий командлет среды управления Exchange с целью запроса значений свойств ExternalDNSServers и InternalDNSServers ролей любого целевого сервера Exchange 2007 Transport. Свойство ExternalDNSServers указывает список внешних DNS-серверов, которые опрашиваются сервером при определении удаленного домена. Свойство InternalDNSServers указывает список DNS-серверов, которые будут использоваться при определении локального имени домена для целевого сервера.

Копировать код
get-TransportServer -Identity %ExchangeServerName% -DomainController %DomainControllerName%

Средство анализа Exchange Server выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Средству анализа Exchange Server не удается успешно получить значение атрибута DNSServerSearchOrder. Также атрибут может не содержать данных.

  • Не задан атрибут msExchSMTPExternalDNSServers объектов серверов Exchange 2000 Server и Exchange Server 2003.

  • Значения свойств ExternalDNSServers и InternalDNSServers для ролей целевого сервера Exchange 2007 Transport не содержат данных.

Эта ошибка означает, что средству анализа Exchange Server не удается определить DNS-серверы, которые используются целевым сервером Exchange. К тому же это условие может негативно влиять на поток электронной почты.

Среди возможных причин этого состояния следующие:

  • На целевом сервере неправильно настроен DNS-сервер.

  • Сбой или отсутствие доступа к инструментарию WMI.

Чтобы устранить эту проблему, выполните следующие действия:

  • Проверьте конфигурацию DNS на целевом сервере.

  • Убедитесь в наличии доступа к инструментарию WMI сервера Exchange.

Проверка наличия доступа к инструментарию WMI сервера Exchange

  1. Убедитесь, что сервер Exchange включен и подсоединен к сети.

  2. Определите, доступен ли компьютер с сервером Exchange, с помощью команды PING.

  3. При наличии брандмауэра проверьте, не блокированы ли порты удаленного вызова процедур.

  4. Проверьте разрешения учетной записи, от имени которой выполняется средство анализа Exchange Server. Учетная запись, с которой выполняется средство анализа Exchange Server, должна обладать разрешениями локального администратора на каждом сканируемом сервере Exchange Server.

    Можно также предоставить особое разрешение WMI учетной записи, от имени которой запущено средство анализа Exchange Server. Для этого выполните следующие действия:

    1. На сервере Exchange Server откройте дерево Computer Management консоли MMC.

    2. В ветви Services and Applications щелкните правой кнопкой мыши WMI Control и выберите команду Properties.

    3. На странице WMI Controls Property щелкните вкладку Security и разверните дерево Root.

    4. Выберите папку CIMV2 и щелкните Security.

    5. На странице Security for ROOT\CIMV2 добавьте учетную запись, от имени которой выполняется средство анализа сервера Exchange.

  5. Выберите учетную запись, добавленную в шаге 4. В поле Permissions for выбранная_запись в столбце Allow выберите Remote Enable и Read Security, а затем нажмите кнопку ОК.

Дополнительные сведения о настройке DNS-сервера для совместной работы с сервером Exchange Server см. в статье 322856 базы знаний Майкрософт «Настройка DNS для использования с сервером Exchange Server» по адресу http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322856 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

Дополнительные сведения о проблемах с сетевыми подключениями см. в статье 325487 базы знаний Майкрософт «Разрешение проблем, связанных с сетевыми подключениями» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Дополнительные сведения об устранении неполадок в подключениях средства анализа Exchange Server см. в статье «Рекомендации по устранению неполадок, связанных с подключениями средства анализатора рекомендаций для сервера Microsoft Exchange Server» по адресу http://go.microsoft.com/fwlink/?LinkId=56285 (на английском языке).

Дополнительные сведения о требованиях к портам см. в статье 832017 базы знаний Майкрософт «Службы и сетевые порты в серверных системах Microsoft Windows» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017.


Отсутствует идентификатор безопасности главной учетной записи
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-02-14

Средство анализа Microsoft Exchange запрашивает класс WMI Win32_NTLogEvent для определения того, было ли в течение последнего часа зарегистрировано предупреждение 9548 для объекта MSExchangeIS.

Если предупреждение 9548 было зарегистрировано в течение последнего часа, средство анализа Exchange подсчитывает общее количество предупреждений 9548, зарегистрированных за это время.

Если предупреждение 9548 было зарегистрировано в течение последнего часа 20 или более раз, средство анализа Exchange отображает предупреждение.

Данное предупреждение свидетельствует о том, что на компьютере могут присутствовать отключенные учетные записи пользователей службы каталогов Active Directory, сопоставленные с почтовыми ящиками Exchange Server и не имеющие действительных атрибутов msExchMasterAccountSID.

Чтобы почтовый ящик на сервере с Microsoft Exchange Server 2003 или Exchange 2000 Server был доступен, он должен быть сопоставлен с действительной учетной записью пользователя службы каталогов Active Directory. Это сопоставление частично основано на задании для почтового ящика атрибута msExchMasterAccountSid службы Active Directory. Учетная запись Active Directory, с которой сопоставлен почтовый ящик Exchange, может находиться во включенном или в отключенном состоянии. Только отключенные учетные записи должны быть связаны с пользователем, для которого задан атрибут msExchMasterAccountSid.

Если значение атрибута msExchMasterAccountSid отключенной учетной записи пользователя является пустым или повреждено и создается список управления доступом, включающий эту учетную запись, при использовании данного списка управления доступом для доступа к ресурсам почтового ящика или общей папки возможно снижение производительности.

Устранение причин появления этого предупреждения

  • Убедитесь в том, что на сервере установлен пакет обновления 2 (SP2) для Exchange Server 2003 с исправлением, упомянутым в статье 916783 базы знаний Майкрософт «Исправление, изменяющее способ обработки отключенных учетных записей Active Directory, сопоставленных с почтовыми ящиками Exchange Server 2003, в Exchange Server 2003 с пакетом обновления 2» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=916783, на английском языке).

  • Проверьте список управления доступом и учетную запись пользователя, упомянутую в предупреждении 9548, чтобы определить, является ли значение атрибута msExchMasterAccountSid пустым или поврежденным, и в случае надобности назначьте правильное значение атрибуту msExchMasterAccountSID для учетной записи в соответствии с указаниями, приведенными в статье 328880 базы знаний Майкрософт «Устранение неполадок с быстродействием общих папок, связанных с преобразованием списков управления доступом в Exchange 2000 и Exchange 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328880, на английском языке).

  • Удалите отключенную учетную запись пользователя из списка управления доступом в соответствии с указаниями, приведенными в статье 278966 базы знаний Майкрософт «Невозможно подключиться к почтовому ящику Exchange или перенести его» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=278966).

Дополнительные сведения

Дополнительные сведения об этой проблеме см. в следующих статьях базы знаний Майкрософт и материалах по Exchange Server:

  • Центр событий и сообщений об ошибках: сведения о событии 9548 хранилища почтовых ящиков MSExchangeIS (http://go.microsoft.com/fwlink/?LinkId=83135, на английском языке).

  • Статья 916783 базы знаний Майкрософт «Исправление, изменяющее способ обработки отключенных учетных записей Active Directory, сопоставленных с почтовыми ящиками Exchange Server 2003, в Exchange Server 2003 с пакетом обновления 2» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=916783, на английском языке).

  • Статья 328880 базы знаний Майкрософт «Устранение неполадок с быстродействием общих папок, связанных с преобразованием списков управления доступом в Exchange 2000 и Exchange 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328880, на английском языке).

  • Статья 278966 базы знаний Майкрософт «Невозможно подключиться к почтовому ящику Exchange или перенести его» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=278966).


Не обнаружено экземпляра SMTP
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-08-08

Средство анализатора сервера Microsoft® Exchange запрашивает атрибут distingushedName класса объекта protocolCfgSMTPServer службы каталогов Active Directory®, чтобы определить, работает ли экземпляр виртуального SMTP-сервера для указанного пользователем имени сервера шлюза Exchange.

Если анализатору сервера Exchange не удается найти экземпляр виртуальной SMTP-службы для указанного пользователем сервера шлюза Exchange, на экран выводится сообщение об ошибке.

Эта ошибка может быть вызвана временными проблемами в работе сети, а может также указывать на неправильные сведения в Active Directory.

Чтобы устранить эту проблему, проанализируйте конфигурацию виртуального SMTP-сервера для указанного пользователем сервера шлюза Exchange.

Чтобы просмотреть конфигурацию экземпляра виртуального SMTP-сервера

  1. Запустите диспетчер Exchange:

    Щелкните Пуск, укажите Программы, выберите Microsoft Exchange, а затем щелкните Диспетчер.

  2. Перейдите к следующему контейнеру:

    \Administrative Groups\GroupName\Servers\ServerName\Protocols\SMTP\SMTP Virtual Server Instance\

  3. Щелкните правой кнопкой мыши требуемый экземпляр виртуального SMTP-сервера и в контекстном меню выберите пункт Свойства.

  4. Убедитесь в правильности настройки экземпляра виртуального SMTP-сервера.

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • Статья 266686, описывающая инструкции из части 1 по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • Статья 268163, описывающая инструкции из части 2 по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

Дополнительные сведения о структуре SMTP-службы см. в разделе, описывающем структуру SMTP-службы, в техническом руководстве по Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=58876).

Дополнительные сведения о проблемах в сетевых подключениях см. в базе знаний Майкрософт, в статье 325487, содержащей инструкции по устранению неполадок в сетевых подключениях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).


Целевой NSPI-сервер переопределен вручную
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange обнаруживает факт переопределения вручную службы целевого сервера интерфейса поставщика службы поддержки имен (целевого NSPI-сервера ) на основании данных в следующем разделе реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\NSPI Target Server

Если анализатор сервера Exchange обнаруживает, что параметр NSPI Target Server существует и настроен, на экран выводится сообщение о конфигурации, отличной от конфигурации по умолчанию.

Различные типы клиентов по-разному используют контроллеры доменов и серверы глобального каталога для получения доступа к глобальному списку адресов. Клиенты Exchange, более ранние, чем Microsoft Outlook® 2000 с набором исправлений 2 (SR-2), предполагают наличие службы каталогов на сервере Exchange. Exchange 2000 Server и Exchange Server 2003 используют механизм, называемый Directory Service Proxy (DSProxy), для установления подключения к ближайшему серверу глобального каталога от имени клиента и прокси-связи между Outlook и сервером глобального каталога. В зависимости от требований, предъявляемых к развертыванию, можно явно указать конкретный сервер глобального каталога, который следует использовать для обработки DSProxy-запросов. Это можно сделать вручную, непосредственно указав запись реестра NSPI Target Server на сервере Exchange.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы вручную указать NSPI-сервер

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Создайте новый мультистроковый параметр с именем NSPI Target Server.

  4. В качестве значения параметра NSPI Target Server введите полное доменное имя нужного сервера.

Чтобы отключить статические параметры для NSPI-сервера, удалите запись с полным доменным именем сервера, который требуется удалить. Если введено только одно значение целевого NSPI-сервера, удалите параметр реестра NSPI Target Server.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о том, как Outlook 2000 с набором исправлений 2 и более новые клиенты взаимодействуют со службой каталогов Active Directory® см. в следующих статьях базы знаний Майкрософт:

  • Статья 302914, посвященная взаимодействию Outlook 2000 со службой каталогов Active Directory(http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914).

  • Статья 256976, посвященная взаимодействию MAPI-клиентов со службой каталогов Active Directory (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976).


Установлена подсистема MAPI, не являющаяся компонентом Exchange Server
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить версию файла MAPI32.dll, хранящегося в двух следующих папках:

<диск>:\Program Files\Exchsrvr\Bin

%Systemroot%\System32

Если в обеих папках не обнаружены одинаковые копии MAPI32.dll, выводится сообщение об ошибке.

Чтобы гарантировать использование одной версии MAPI, программа установки Exchange Server копирует файл MAPI32.dll в каталоги <диск>:\Program Files\Exchsrvr\Bin и %Systemroot%\system32. Приложение MAPI, например Microsoft Office Outlook® 2003 или программа стороннего разработчика, устанавливаемая на компьютер с Exchange Server, может скопировать другую версии файла MAPI32.dll в папку System32 и таким образом нарушить работу Exchange. Данное нарушение происходит, поскольку версии двух продуктов создают конфликт в подсистеме MAPI, который не всегда может быть устранен без нарушения работы Exchange Server или другого приложения MAPI.

Настоятельно рекомендуется не устанавливать Outlook 2000 (или более поздней версии) и Exchange Server 2003, Exchange 2000 Server или Exchange Server 5.5 на один компьютер.

Часто Outlook устанавливается на один компьютер с Exchange Server для реализации некоторых компонентов Outlook в серверных программах. Для большинства задач, связанных с разработкой программ, наличие Outlook на компьютере с Exchange не требуется. Exchange Server включает объекты совместной работы (CDO), обеспечивающие функциональные возможности, аналогичные возможностям объектной модели Outlook. Объекты CDO предназначены для использования на сервере и не вызывают сложностей, характерных для новейших версий Outlook. Для получения дополнительных сведений см. статью 290500 базы знаний Майкрософт, содержащую сведения о функциях безопасности электронной почты для разработчиков (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=290500).

Другой распространенной причиной установки является необходимость создания профилей MAPI. Exchange Server включает все функциональные возможности, необходимые для создания профилей MAPI, и не требует наличия Outlook. Дополнительные сведения о создании профилей MAPI без установки Outlook см. в статье 306962 базы знаний Майкрософт (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306962).

Если Outlook и Exchange Server необходимо установить на один компьютер в демонстрационных целях, то рекомендуется использовать одну из следующих конфигураций, которые были протестированы на использование в демонстрационных целях:

  • Exchange 2000 Server с Outlook 2000

  • Exchange 2000 Server с Outlook 2002

Чтобы устранить эту ошибку

  1. Удалите Microsoft Outlook или приложение MAPI стороннего разработчика с сервера Exchange.

  2. Повторно запустите программу установки Exchange Server и нажмите кнопку Переустановить.

Дополнительные сведения об использовании Microsoft Office Outlook 2003 и Microsoft Exchange Server на одном компьютере см. в статье 266418 базы знаний Майкрософт, где объясняется, почему корпорация Майкрософт не рекомендует устанавливать Exchange 2000 Server и Outlook 2000 (или более поздней версии) на одной компьютере (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266418).

Дополнительные сведения о конфликтах MAPI см. в статье 229700 базы знаний Майкрософт, описывающей определение правильного пути для файла MAPISVC.INF в Outlook 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=229700).

Дополнительные сведения о библиотеке-заглушке MAPI32 см. в разделе, посвященном интерфейсу MAPI (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=34395).


Обнаружен расширяемый модуль хранилища, отличный от модуля Майкрософт
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version для файла Ese.dll, модуля хранилища базы данных Exchange, также известного как модуль расширяемого хранилища (Extensible Storage Engine, ESE).

Анализатор сервера Exchange также запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumber для всех объектов, относящихся к классу msExchExchangeServer. Если строковое значение содержит выражение «Version 5.5», на компьютере выполняется приложение Microsoft Exchange Server 5.5. Если строковое значение содержит выражение «Version 6.0», на компьютере выполняется приложение Microsoft Exchange 2000 Server. Если строковое значение содержит выражение «Version 6.5», на компьютере выполняется приложение Microsoft Exchange Server 2003.

Если анализатор сервера Exchange обнаружит, что значение Version не содержит подстроки 6 в качестве части сведений о версии, а значение serialNumber указывает, что установлено приложение Exchange 2000 Server или Exchange Server 2003, на экран будет выведено предупреждение. Это предупреждение указывает, что на компьютере сервера Exchange установлена и используется версия файла Ese.dll, отличная от файла корпорации Майкрософт. Эту проблему необходимо устранить как можно быстрее.

Одной из возможных причин такой ситуации может быть использование антивирусного программного обеспечения на основе модуля ESE. Некоторые антивирусные программы на основе модуля ESE используют неподдерживаемый интерфейс между банком данных Exchange и модулем ESE. При использовании такого вида программного обеспечения возникает риск повреждения базы данных и утери данных, если в реализации программного обеспечения существуют ошибки.

Во время установки средство поиска вирусов на основе модуля ESE изменяет службу «Банк данных Microsoft Exchange» так, что она становится зависимой от службы антивирусной программы, основанной на модуле ESE. В результате этого служба антивирусной программы, основанной на модуле ESE, запускается до службы «Банк данных Microsoft Exchange». Когда антивирусная программа, основанная на модуле ESE, запускается, версия файла Ese.dll, поставляемая с сервером Exchange, временно переименовывается как Xese.dll, и версия файла Ese.dll антивирусной программы, основанной на модуле ESE, заменяет исходный файл. После того как версия файла Ese.dll антивирусной программы, основанной на модуле ESE, загрузится, версия файла, поставляемого с сервером Exchange, переименовывается обратно в Ese.dll, и служба «Банк данных Microsoft Exchange» завершает процесс загрузки.

Настоятельно рекомендуется не использовать на компьютере сервера Exchange реализации модуля ESE, отличные от модуля ESE корпорации Майкрософт. Клиентов, обращающихся в службу поддержки продуктов Майкрософт, могут попросить отключить антивирусную программу, основанную на модуле ESE, чтобы облегчить идентификацию существующих проблем, однако клиенты вольны включить программное обеспечение снова, после того как будет правильно определена основная причина возникшей проблемы.

Наиболее широко используемой антивирусной программой, основанной на модуле ESE, является Antigen для Microsoft Exchange от компании Sybari Software. Корпорация Майкрософт и компания Sybari пришли к выводу, что отключение программы Antigen компании Sybari является необходимым шагом при определении причин возникших проблем в процессе устранения неполадок. Чтобы связаться с компанией Sybari Software посетите ее веб-узел ( http://www.sybari.com).

Примечание.
Сведения о веб-узлах сторонних компаний предоставлены для оказания помощи в нахождении необходимой технической информации. URL-адреса могут быть изменены без предварительного уведомления.

Кроме того, рекомендуется использовать антивирусные программы, которые поддерживают интерфейс VSAPI (Virus Scanning Application Programming Interface), также известный как интерфейс AVAPI (Antivirus API).

Чтобы устранить причину появления этого предупреждения

  1. Выполните полное резервное копирование содержимого компьютера сервера Exchange.

  2. Удалите сервер Exchange с компьютера.

  3. Повторно установите сервер Exchange на компьютер.

  4. Примените последний пакет обновлений и все последние обновления для сервера Exchange.

Дополнительные сведения о запуске антивирусного программного обеспечения на сервере Exchange см. в следующих статьях базы знаний Майкрософт:

  • Статья 823166, содержащая обзор Exchange Server 2003 и антивирусного программного обеспечения (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

  • Статья 328841, описывающая приложение Exchange и антивирусное программное обеспечение (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).


Обнаружен расширяемый модуль хранилищ, не являющийся продуктом корпорации Майкрософт
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа «Version» для файла Ese.dll, — модуля хранилища баз данных Exchange, также называемого расширяемым модулем хранилищ (ESE).

Средство анализатора сервера Microsoft® Exchange также запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumber для всех объектов с классом объекта msExchExchangeServer. Если строковое значение содержит «Version 5.5», значит, на компьютере выполняется Microsoft Exchange Server 5.5. Если строковое значение содержит «Version 6.0», значит, на компьютере выполняется Microsoft Exchange Server 2000. Если строковое значение содержит «Version 6.5», значит, на компьютере выполняется Microsoft Exchange Server 2003.

Если анализатор сервера Exchange обнаруживает, что значение атрибута Version не содержит подстроку 5.5 в данных о версии, однако значение serialNumber указывает на то, что на компьютере установлен сервер Exchange Server 5.5, на экран выводится предупреждение. Это предупреждение указывает на то, что на компьютере с Exchange Server установлена и используется версия Ese.dll стороннего производителя (не корпорации Майкрософт). Следует как можно быстрее устранить эту проблему.

Одной из возможных причин ее возникновения может быть применение антивирусного программного обеспечения на основе расширяемого модуля хранилищ (ESE). Некоторые антивирусные программы на базе ESE являются неподдерживаемым интерфейсом между банком данных Exchange и ESE. При использовании такого программного обеспечения существует риск повреждения базы данных и потери данных в случае наличия ошибок в реализации ПО.

В время установи сканер на базе ESE модифицирует службу «Банк данных Microsoft Exchange» таким образом, чтобы она зависела от службы антивирусной программы на базе ESE. Это гарантирует запуск антивирусной программы на базе ESE раньше службы «Банк данных Microsoft Exchange». При запуске антивирусной программы на базе ESE версия файла Ese.dll, входящая в состав Exchange Server, временно переименовывается в Xese.dll, а версия файла Ese.dll антивирусной программы на базе ESE заменяет исходный файл. После загрузки версии Ese.dll антивирусной программы на базе ESE версия, входящая в состав Exchange Server, вновь переименовывается в Ese.dll, после чего процедура загрузки службы «Банк данных Microsoft Exchange» завершается.

Настоятельно рекомендуется избегать использования на компьютерах с Exchange Server реализаций расширяемого модуля хранилищ (ESE) сторонних производителей (не корпорации Майкрософт). Заказчикам, обращающимся в службу поддержки продуктов корпорации Майкрософт, может потребоваться отключить антивирусную программу на базе ESE для диагностирования неполадки, однако после выявления основной причины неполадки заказчики могут вновь включить эту программу.

Чтобы устранить причину появления этого предупреждения

  1. Выполните полное резервное копирование компьютера Exchange Server.

  2. Переустановите Exchange Server на компьютере.

  3. Установите новейший пакет обновления и отдельные обновления для Exchange Server, доступные на веб-узле продукта Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=21573).
  • Дополнительные сведения об использовании антивирусного программного обеспечения в среде Exchange Server см. в статье 328841 базы знаний корпорации Майкрософт, посвященной Exchange и антивирусному программному обеспечению (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

  • Дополнительные сведения о перестройке компьютера на базе Exchange Server 5.5 с использованием того же имени компьютера см. в статье 155216 базы знаний корпорации Майкрософт, посвященной переносу Exchange Server на новый компьютер с тем же именем (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=155216).


Невыгружаемый пул превысил пороговое значение для вывода предупреждения
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_PerfRawData_PerfOS_Memory, чтобы определить текущее значение объекта PoolNonpagedBytes. Действия анализатора сервера Exchange зависят от установленной операционной системы, наличия или отсутствия переключателя «/3GB» в файле Boot.ini ОС Windows, а также выявленного значения этого ключа.

В следующей ниже таблице представлена матрица опорных показателей, с помощью которых анализатор сервера Exchange Server определяет, выходит ли найденное значение за допустимые границы для указанного сервера Exchange. При наличии приведенных в таблице условий выводится предупреждение.

Операционная система | Параметр файла Boot.ini | Текущий невыгружаемый пул
Microsoft Windows 2000 Server или Advanced Server | /3GB | 100 МБ или более
Microsoft Windows 2000 Server или Advanced Server | Отсутствует | 200 МБ или более
Microsoft Windows Server™ 2003 | /3GB | 100 МБ или более
Microsoft Windows Server 2003 | Отсутствует | 200 МБ или более

Значение PoolNonpagedBytes отражает размер невыгружаемого пула памяти ядра в байтах. Это область физической системной памяти, выделяемой для объектов, которые не могут быть записаны на диск даже в том случае, если они не используются. В качестве значения данного ключа используется последнее выявленное значение. На работоспособном сервере Exchange должно использоваться не более 85 МБ памяти невыгружаемого пула, если не выполняется резервное копирование или восстановление.

В операционных системах Windows 2000 Server и Windows 2000 Advanced Server максимальное значение невыгружаемого пула составляет 256 МБ. Так как предельный размер невыгружаемого пула памяти не может больше указанных выше значений, следует устранить эту проблему при первой возможности. Это максимальный размер невыгружаемого пула памяти, который доступен для Windows, независимо от используемой операционной системы или наличия переключателя «/3GB». Если для Windows недостаточно памяти, выводятся сообщения об ошибке и может произойти сбой системы. Память ядра необходима для нормальной работы системы, поэтому за ее наличием следует внимательно следить.

Если после перезапуска сервера Exchange эта проблема возникнет повторно, необходимо убедиться, что система настроена верно и в системе не используется устаревшее программное обеспечение или оборудование. Установите последние версии следующего программного обеспечения:

  • Пакеты обновлений операционной системы Windows

  • Пакеты обновления сервера Exchange

  • Оборудование, микропрограммное обеспечение и драйверы

  • Обновления системного BIOS

  • Обновления для установленных и выполняемых приложений сторонних разработчиков

Если после обновления оборудования и программного обеспечения данная проблема не будет устранена, следует отключить все программное обеспечение сторонних разработчиков, перезапустить компьютер сервера Exchange и включить слежение за памятью ядра.

Чтобы устранить эту ошибку

  1. При первой возможности перезапустите компьютер сервера Exchange.

  2. Включите слежение за счетчиком производительности Memory | Pool Nonpaged Bytes, чтобы убедиться, что его показатели не превышают указанные выше пороговые значения для данной системы.

Дополнительные сведения о верной настройке сервера Exchange см. в следующих статьях базы знаний Майкрософт и технических руководствах:

  • 815372, «How to optimize memory usage in Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372) (Инструкции по оптимизации использования памяти в Exchange Server 2003)

  • 266096, «XGEN: Exchange 2000 Requires /3GB Switch with More Than 1 Gigabyte of Physical RAM» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096) (XGEN: для Exchange 2000 требуется переключатель «/3GB» и наличие более 1 гигабайта физической ОЗУ)

  • «Troubleshooting Exchange Server 2003 Performance» (http://go.microsoft.com/fwlink/?LinkId=47588) (Устранение неполадок в производительности Exchange Server 2003)

  • «Troubleshooting Exchange Server 2000 Performance» (http://go.microsoft.com/fwlink/?LinkId=18177) (Устранение неполадок в производительности Exchange Server 2000)

  • «Performance and Scalability Guide for Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=47576) (Руководство по производительности и масштабируемости для Exchange Server 2003)

Дополнительные сведения о памяти невыгружаемого пула и связанные с этой темой разделы см. в следующих статьях базы знаний:

  • 294418, «Comparison of 32-Bit and 64-Bit Architecture» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836) (Сравнение 32-разрядной и 64-разрядной архитектур)

  • 177415, «How to Use Memory Pool Monitor (Poolmon.exe) to Troubleshoot Kernel Mode Memory Leaks» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=177415) (Инструкции по устранению утечек памяти в защищенном режиме с помощью средства слежения за пулом памяти (Poolmon.exe)).

  • 268343, «Umdhtools.exe: How to Use Umdh.exe to Find Memory Leaks» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268343) (Umdhtools.exe: инструкции по выявлению утечек памяти с помощью средства Umdh.exe)


Число свободных элементов таблицы страниц слишком мало, что может привести к нестабильности системы
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server считывает следующий раздел реестра, чтобы определить значение параметра реестра SystemPages:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

Если средство анализа Exchange Server обнаружит, что значение SystemPages равно 0, а число свободных элементов системной таблицы страниц (PTE) меньше 3001, появится предупреждение.

Microsoft Windows Server™ 2003 и Windows® 2000 Server могут напрямую обращаться к 4 Гбайт адресного пространства памяти, независимо от объема установленной физической оперативной памяти. С точки зрения процесса, каждый элемент виртуального адресного пространства ссылается на участок физической памяти. Диспетчер виртуальной памяти (VMM) вместе с блоком управления памятью процессора (MMU) должен перевести или сопоставить каждый виртуальный адрес с соответствующим физическим адресом. VMM выполняет сопоставление, разделяя ОЗУ на страницы памяти фиксированного размера, создавая таблицы страниц, в которых будет храниться информация о страницах памяти, и сопоставляя их. Системная таблица страниц — это небольшой буфер памяти, работающий в режиме ядра, который используется для обмена данными с подсистемой ввода/вывода диска и с сетью. Каждая таблица страниц представляет страницу памяти и содержит информацию, которая необходима VMM для обнаружения страницы.

На системах типа x86, использующих страницы по 4 кБ, максимальное число элементов таблиц страниц, необходимое для сопоставления 2 ГБ адресного пространства, составляет 524288 (2 ГБ/4 кБ). На такой же системе, но с ключом /3GB, число элементов таблиц страниц, необходимое для сопоставления 3 Гбайт адресного пространства, составляет 786432 (3 ГБ/4 кБ). На стандартной системе это пространство используется следующим образом:

  • Не более 50000 элементов таблиц страниц (приблизительно 195 МБ адресного пространства) отведено под общее использование.

  • Остальные элементы используются для сопоставления системного кэша, гиперпространства, выгружаемых и невыгружаемых пулов, области аварийной копии и т. д.

Размер пула элементов таблиц страниц определяется автоматически при запуске системы на основании количества физической памяти в системе. Этот пул размещается между выгружаемым и невыгружаемым пулом, размер которых также увеличивается с увеличением физической памяти системы.

Пул элементов таблиц страниц может оказаться перегруженным и излишне фрагментированным. Это может привести к тому, что какие-то драйверы не будут загружаться. Кроме того, если пул элементов таблиц страниц полностью исчерпан, ухудшится работа других компонентов системы. Это может даже привести к тому, что потоки не будут создаваться, система будет зависать, появятся сбои в работе системы.

Для нормальной работы компьютера Exchange Server должно быть постоянно доступно не менее 5000 элементов системных таблиц страниц. Если число элементов таблиц страниц меньше 5000, но больше 3001, появится предупреждение, описанное в в разделе Количество свободных элементов таблицы страниц достигло критического порога. Когда число свободных элементов системных таблиц страниц меньше 3001, появляется данное сообщение об ошибке. Чтобы решить эту проблему, можно воспользоваться описанной ниже процедурой и настроить значение реестра SystemPages в соответствии с операционной системой компьютера Exchange Server. Если используется Exchange Server 2003 с пакетом обновления 1 (SP1) на Windows Server 2003 с 1 ГБ ОЗУ или более, рекомендуется установить для раздела реестра SystemPages значение 0. Эта рекомендация отличается от рекомендации для Windows 2000 Server, согласно которой нужно установить для SystemPages значение от 24000 до 31000.

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Для получения сведений о восстановлении реестра см. разделе «Восстановление реестра» справочной системы файла Regedit.exe или Regedt32.exe.

После выполнения описанной ниже процедуры следует проверить число свободных элементов таблиц страниц. Сделать это можно при помощи счетчика свободных элементов таблиц страниц в группе счетчиков памяти в системном мониторе Windows. Если и после после внесения описанных изменений в реестр число свободных элементов таблиц страниц остается небольшим, просмотрите следующие источники, чтобы убедиться, что компьютер сервера Exchange имеет оптимальную конфигурацию:

  • Драйверы Некорректно работающий драйвер — одна из наиболее частых причин уменьшения числа элементов системных таблиц страниц. Обратитесь к изготовителю оборудования, чтобы убедиться в том, что для всего оборудования используются последние версии драйверов. Можно также попробовать вернуться к более простой версии драйвера. Например, компьютеру, на котором установлены серверные приложения, такие как сервер Exchange, обычно не нужны усовершенствованные видеодрайверы, поддерживающие все функции. Обычно можно обойтись более простым драйвером. Переход с усовершенствованной на простую версию драйвера должен увеличить число свободных элементов таблиц страниц.

  • Конфигурация системы Если в системе установлена физическая память объемом 1 ГБ или более, следует убедиться в том, что файл Boot.ini содержит верные ключи /3GB и /USERVA=3030, как описано в следующих статьях базы знаний корпорации Майкрософт:

    • 823440, «Использование параметра /3GB в Exchange Server 2003 на компьютере под управлением Windows Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440)

    • 810371, «XADM: Использование ключа /Userva на компьютерах с Exchange Server под управлением Windows Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371)

  • Журналы событий Просмотрите журнал событий приложения на сервере Exchange на предмет наличия в нем ошибок и предупреждений, в частности события MSExchangeIS 9582 (ошибки и предупреждения), 9665 (предупреждение) и 12880 (ошибка). Наличие события 9665 может, кроме всего прочего, говорит о том, что раздел SystemPages не настроен на оптимальную производительность. Для получения дополнительных сведений об этих событиях см. статью 325044 базы знаний «ИНСТРУКЦИИ: Устранение неполадок, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044).

Устранение данного предупреждения в Windows 2000 Server

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. В правой панели дважды щелкните SystemPages.

  4. В поле Значение введите значение от 24000 до 31000 (в десятичной системе) и нажмите кнопку OK.

  5. Закройте программу и перезагрузите компьютер, чтобы изменения вступили в силу.

Устранение ошибки в Windows Server 2003

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. В правой панели дважды щелкните SystemPages.

  4. В поле Значение введите 0 и нажмите кнопку OK.

  5. Закройте программу и перезагрузите компьютер, чтобы изменения вступили в силу.

Перед правкой реестра, а также для получения дополнительных сведений о правке реестра просмотрите статью 256986 базы знаний корпорации Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Для получения дополнительных сведений об оптимизации использования памяти для Exchange Server см. следующие статьи базы знаний корпорации Майкрософт:

  • 325044, «ИНСТРУКЦИИ: Устранение неполадок, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372, «Оптимизация использования памяти в Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 311901, «Воздействие настройки 4GT на элементы системной таблицы страниц» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


Число действующих вызовов, ожидающих проверки на наличие вирусов, приближается к максимально допустимой границе.
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-13

Анализатор сервера Microsoft® Exchange просматривает файл журнала вызовов функций сервера Exchange Store.fcl на наличие событий, которые определяют число текущих вызовов между компонентами из службы банка данных Microsoft Exchange (Store.exe) в компонент VAPI.

Анализатор сервера Exchange также запрашивает параметр ScanningThreads в следующем разделе реестра, чтобы определить максимальное число потоков, разрешенных для вызовов в компонент VAPI:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Действующий вызов — это запрос, исходящий из службы банка данных Microsoft Exchange (Store.exe) к другим компонентам, на который не получен ответ на момент записи данных журнала вызовов функций в файл Store.fcl.

Если анализатор сервера Exchange обнаруживает, что число действующих вызовов из службы банка данных Exchange (Store.exe) в компонент VAPI приближается к максимально допустимому, выводится сообщение об ошибке.

Когда вызовы между компонентами от службы банка данных Microsoft Exchange (Store.exe) ожидают ответа, в фоновом режиме может выполняться резервное копирование потоков удаленных вызовов процедур, что иногда приводит к падению производительности сервера Exchange.

Причиной наличия действующих вызовов от службы банка данных Microsoft Exchange к компоненту VAPI могут быть следующие условия:

  • Обновления антивирусного программного обеспечения сканирования, в результате которых выполняется повторная проверка элементов банка данных

  • Антивирусное программное обеспечение настроено неверно

  • Антивирусное программное обеспечение обрабатывает большое сообщение или вложение

Чтобы устранить эту ошибку, выполните следующие шаги:

  • Настройте расписание обновлений в антивирусном модуле на время, когда потребление ресурсов является низким, то есть на часы пониженной нагрузки.

  • Рассмотрите возможность повторной установки антивирусного программного обеспечения, но только не во время пиковой нагрузки.

  • Изучите конфигурацию модуля антивирусного сканера, чтобы изменить конфигурацию потоков, исключения на уровне файлов и другие параметры. Изучите статью 823166 базы знаний Майкрософт, «Overview of Exchange Server 2003 and antivirus software» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166) (Общие сведения о Exchange Server 2003 и антивирусном программном обеспечении).

  • Увеличьте число потоков для API антивирусного сканирования:

    Оптимальное значение параметра ScanningThreads рассчитывается по формуле (2 * NumberOfProcessors) + 1. Например, на сервере Exchange Server с двумя процессорами оптимальное значение параметра ScanningThreads составляет 5.

    Примечание.
    Если многопоточность включена, значение параметра NumberOfProcessors будет равно удвоенному количеству физических процессоров. Рекомендуется уточнить у разработчика своего антивирусного программного обеспечения, какие процессоры — физические или логические — должны использоваться в данной формуле.
Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.
Чтобы увеличить число потоков

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

  3. В правой области дважды щелкните ScanningThreads.

  4. Введите значение, полученное в предыдущей формуле.

  5. Закройте редактор реестра и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

  • Ознакомьтесь со статьями в разделе «Дополнительные сведения» данного документа.

Дополнительные сведения

Дополнительные сведения о разных видах антивирусных программ, обычно используемых с Microsoft Exchange Server 2003 см. в статье 823166 базы знаний Майкрософт «Overview of Exchange Server 2003 and antivirus software» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166) (Общие сведения о Exchange Server 2003 и антивирусном программном обеспечении).

Дополнительные сведения о разных видах антивирусных программ, обычно используемых с Microsoft Exchange Server 2000 см. в статье 328841 базы знаний Майкрософт «Overview of Exchange Server 2000 and antivirus software» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841) (Общие сведения о Exchange Server 2000 и антивирусном программном обеспечении).

Дополнительные сведения о производительности сервера Exchange см. в документе «Performance and Scalability Guide for Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=47576) (Руководство по управлению производительностью и масштабируемостью Exchange Server 2003).

Дополнительные сведения об устранении проблем производительности сервера Exchange см. в документе «Troubleshooting Microsoft Exchange Server Performance» (http://go.microsoft.com/fwlink/?LinkId=47588) (Устранение неполадок производительности сервера Microsoft Exchange).

Дополнительные сведения об устранении проблем производительности банка данных см. в статье 257725 базы знаний Майкрософт «XADM: How to Collect Diagnostic Data for Information Store Troubleshooting» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725) (XADM: инструкции по сбору данных диагностики для устранения неполадок в работе банка данных).

Дополнительные сведения о технологии многопоточности см. на веб-узле компании Intel (http://www.intel.com/technology/hyperthread).

Примечание.
Сведения о веб-узлах сторонних компаний в этом разделе предоставлены для оказания помощи в нахождении необходимой технической информации. URL-адреса могут быть изменены без предварительного уведомления.


Отсутствует файл OABGEN.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server Analyzer Tool направляет запрос классу CIM_Datafile инструментария управления Microsoft Windows® (WMI) для проверки наличия нескольких основных двоичных файлов Exchange:

  • Exres.dll

  • Gapi32.dll (поиск в папке System32 и в папке \Exchsrvr\bin)

  • Gapi32.dll (поиск в папке System32 и в папке \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если средство анализа Exchange Server Analyzer обнаруживает, что один или несколько из перечисленных файлов отсутствуют, отображается ошибка. Для устранения этой ошибки установите новейший пакет обновления или накопительный пакет обновлений для установленной версии Exchange. Если ошибка не устраняется, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберитеПереустановить. Запуск программы установки в режиме переустановки позволяет установить только двоичные файлы. Пользовательские данные и данные настройки не удаляются и не сбрасываются. При переустановке сервера Exchange можно также переустановить любые установленные пакеты обновления или исправления.

Как переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором нужно переустановить Exchange. Вставьте компакт-диск сервера Exchange 2000 или Exchange 2003 в дисковод CD-ROM.

  2. В меню Пуск выберите Выполнить, затем введите <диск>:\setup\i386\setup, где <диск> - это буква привода компакт-дисков.

  3. На странице Добро пожаловать в Мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение прочитайте соглашение. Если вы согласны с условиями, нажмите кнопку Принимаю, затем нажмите кнопку Далее.

  5. На странице Регистрационный номер введите состоящий из 25 цифр ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие, используя стрелку раскрывающегося списка, расположенную рядом с узломMicrosoft Exchange, выберите Переустановить и нажмите кнопку Далее.

Для получения дополнительных сведений о новейших пакетах обновления, накопительных пакетах обновлений и расширениях для Exchange Server 2003 см. веб-узел «Загружаемые файлы для Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=25097).

Для получения дополнительных сведений о новейших пакетах обновления, накопительных пакетах обновлений и расширениях для Exchange Server 2000 см. веб-узел «Загружаемые файлы для Exchange Server 2000» (http://go.microsoft.com/fwlink/?LinkId=33457).


Получение новейшего пакета обновления или набора исправлений для Exchange Server 5.0
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута versionNumber для каждого объекта Exchange Server. Атрибут versionNumber представляет версию Exchange Server, установленную на компьютере.

Анализатор сервера Exchange также запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version для процесса STORE.EXE. Если анализатор сервера Exchange обнаруживает, что значение ключа Version для процесса STORE.EXE больше или равно 1460 и меньше 1462, на экран выводится предупреждение.

Это предупреждение указывает на то, что на компьютере под управлением Exchange Server не выполняется новейший программный код, доступный для данной версии Exchange.

Чтобы устранить причину появления этого предупреждения

  1. Посетите центр загрузки Майкрософт (http://go.microsoft.com/fwlink/?LinkId=41361), чтобы загрузить новейшее обновление (апрель 2004 г.) для Exchange Server 5.0.

  2. Дополнительные сведения о данном обновлении см. в статье 834130 базы знаний Майкрософт, посвященной набору исправлений для Microsoft Exchange Server 5.0 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834130).

  3. Выполните полное резервное копирование компьютера с Exchange Server.

  4. Примените обновление за апрель 2004 г.

Чтобы получить новейший набор исправлений для Exchange Server 5.0 с пакетом обновления 2 прочитайте статью 168858 базы знаний Майкрософт (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168858).

Дополнительные сведения об установке этого и других обновлений для Exchange Server см. в статье 328839 базы знаний Майкрософт, описывающей применение пакетов обновления и исправлений для Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Получение последнего пакета обновления или сборки обновления для Exchange Server 5.5
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута versionNumber для всех объектов сервера Exchange. Атрибут versionNumber указывает версию сервера Exchange, которая выполняется на данном компьютере.

Анализатор сервера Exchange также запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version для процесса STORE.EXE. Если анализатор сервера Exchange обнаруживает, что раздел «Version» для параметра STORE.EXE имеет значение от 2653 (включительно) до 2658, выводится предупреждение. Это означает, что на данном компьютере выполняется Exchange Server 5.5 с пакетом обновления 4 или Exchange Server 5.5 с пакетом обновления 4 и исправлениями.

Данное предупреждение указывает, кто на данном компьютере сервера Exchange отсутствует последняя версия программы, доступная для установленной на нем версии Exchange.

Чтобы устранить причину появления этого предупреждения

  1. Загрузите последнее обновление (май 2004 года) для сервера Exchange Server 5.5 с центра загрузки Майкрософт (http://go.microsoft.com/fwlink/?LinkId=33456).

  2. Изучите сведения об этом обновлении в статье 841765 базы знаний Майкрософт «May 2004 Update Rollup for Exchange Server 5.5» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=841765) (Сборка обновления для Exchange Server 5.5, вышедшая в мае 2004 года).

  3. Создайте полную резервную копию сервера Exchange.

  4. Примените обновление от мая 2004 года.

Дополнительные сведения об установке этого и других обновлений сервера Exchange см. в статье 328839 базы знаний Майкрософт «How to apply Exchange service packs and hotfixes» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839) (Инструкции по применению пакетов обновления и исправлений для Exchange).


Получение последнего пакета обновления или накопительного пакета обновлений для Exchange Server 2003
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server запрашивает службу каталога Active Directory®, чтобы определить значение атрибута versionNumber для каждого объекта Exchange Server. Атрибут versionNumber отражает версию Exchange Server, работающего на данном компьютере.

Кроме того, средство анализа Exchange Server запрашивает класс CIM_Datafile инструментария Microsoft Windows® Management Instrumentation (WMI), чтобы определить значение раздела Version для процесса STORE.EXE.

  • Значение 7638 раздела Version означает Exchange Server 2003 с пакетом обновления 2

  • Значение 7226 раздела Version означает Exchange Server 2003 с пакетом обновления 1

  • Значение 6944 раздела Version означает первоначальную версию Exchange Server 2003

  • Значение, расположенное между указанными выше версиями, говорит о том, что на сервере установлены исправления для процесса Store.exe.

Если анализатор сервера Exchange обнаружит, что значение раздела Version для Store.exe меньше 7638, появится предупреждение.

Это предупреждение говорит о том, что на компьютере сервера Exchange установлена не последняя версия сервера Exchange Server.

Для устранения этого предупреждения

  1. Загрузите или закажите пакет обновления 2 для Exchange Server 2003 на посвященном ему веб-узле (http://go.microsoft.com/fwlink/?LinkId=54751).

  2. Просмотрите информацию о выпуске пакета обновления 2 на специальном веб-узле (http://go.microsoft.com/fwlink/?LinkId=52072).

  3. Сделайте полную резервную копию компьютера Exchange Server.

  4. Примените пакет обновления 2 для Exchange Server 2003.

Для получения дополнительных сведений об установке этого и других обновлений для Exchange Server см. статью 328839 базы знаний корпорации Майкрософт «Установка пакетов обновлений и исправлений для Exchange» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Получение последней версии пакета обновлений или сборки обновлений для Exchange 2000 Server
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута versionNumber для каждого объекта сервера Exchange. Атрибут versionNumber представляет собой версию сервера Exchange, которая выполняется на компьютере.

Анализатор сервера Exchange также запрашивает WMI-класс (Microsoft Windows Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version для процесса STORE.EXE. Если анализатор сервера Exchange определит, что ключ Version для STORE.EXE имеет значение, находящееся в одном из следующих диапазонов, на экран будет выведено предупреждение:

  • больше 6249 и меньше или равно 6396;

  • больше 6396 и меньше или равно 6487;

  • больше 6487 и меньше или равно 6556;

  • больше 6556 и меньше или равно 6603;

  • больше 6603 и меньше или равно 6700.

Это предупреждение указывает, что на компьютере сервера Exchange функционирует не самая последняя версия доступного программного кода для версии Echange, выполняющейся на компьютере.

Чтобы устранить причину появления этого предупреждения

  1. Загрузите последнее обновление (август 2004) с веб-узла загружаемых ресурсов для Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).

  2. Сведения о последнем обновлении см. в базе знаний Майкрософт в статье 870540, описывающей доступность сборки обновлений, следующей после пакета обновлений 3, для Exchange 2000 Server, которая выпущена в августе 2004 г. (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540).

  3. Выполните полное резервное копирование содержимого компьютера сервера Exchange.

  4. Примените обновление, выпущенное в августе 2004 г.

Дополнительные сведения об установке этого и других обновлений сервера Exchange см. в базе знаний Майкрософт в статье 328839, содержащей инструкции по применению пакетов обновлений и оперативных исправлений Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Сервер автономной адресной книги удален
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-12-03

Чтобы определить значение атрибута offLineABServer объекта конфигурации автономной адресной книги, средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®. Если анализатор сервера Exchange обнаруживает, что значение атрибута offLineABServer содержит строку «DEL:», выводится сообщение об ошибке.

Атрибут offLineABServer — однозначный отличительный атрибут имени, в котором хранится отличительное имя компьютера сервера Exchange, ответственного за создание автономной адресной книги. Для каждой автономной адресной книги Exchange создает и хранит файлы автономной адресной книги в ряде общих папок на заданном сервере. Это сообщение об ошибке показывает, что сервер, заданный атрибутом offLineABServer объекта конфигурации автономной адресной книги, не существует. Эта ситуация возникает, если старый сервер автономной адресной книги был списан или неправильно удален из топологии. Exchange не будет создавать автономной адресной книги, пока не задан новый сервер.

Исправление этой ошибки на серверах Exchange 2000 Server и Exchange Server 2003

  1. В диспетчере Exchange в группе Получатели щелкните Автономные списки адресов. В правой панели щелкните правой клавишей мыши список Автономный список адресов по умолчанию (или любой автономный список адресов по умолчанию, который выводит это сообщение), затем в появившемся меню выберите пункт Свойства.

  2. На вкладке Общие группы Сервер автономного списка адресов щелкните Обзор и выберите сервер, который необходимо использовать.

Устранение причин появления этого предупреждения на сервере Windows Server 2007

  1. Откройте консоль управления Exchange.

  2. Разверните узлы Microsoft Exchange и Конфигурация организации, а затем выберите элемент Почтовый ящик.

  3. В области результатов перейдите на вкладку Автономная адресная книга.

  4. На вкладке Автономная адресная книга выберите параметр «Автономная адресная книга по умолчанию». В области действий нажмите Переместить для запуска мастера перемещения автономной адресной книги. Этот мастер позволяет переназначить формирование автономной адресной книги на другой сервер. Кроме того, он скопирует на указанный сервер уже существующие файлы адресных книг.

Использование среды управления Exchange для указания сервера, на котором будет выполняться формирование автономной адресной книги

  • Выполните следующую команду:

    Копировать код
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    где: <OAB> — это различающееся имя, имя в формате «домен\имя учетной записи» или идентификатор GUID автономной адресной книги, а <Server> указывает сервер Exchange Server, на котором будет выполняться выбранная операция.

    Например, для переназначения формирования автономной адресной книги на сервер SERVER01 необходимо ввести следующую команду:
Копировать код
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Дополнительные сведения о работе с автономными адресными книгами в Exchange Server 2003 см. в руководстве по настройке автономной адресной книги Exchange Server 2003 в статье Работа с хранилищем Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=47595 (на английском языке).

Дополнительные сведения о работе с автономными адресными книгами в Exchange Server 2007 см. в статье «Настройка организации > Почтовый ящик > Автономные адресные книги» по адресуhttp://go.microsoft.com/fwlink/?LinkId=79247 (на английском языке).


Сервер автономной адресной книге работает на сервере переднего плана
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить значение атрибута offLineABServer для каждого объекта конфигурации автономной адресной книги. Атрибут offLineABServer является однозначным различающимся атрибутом имени, в котором хранится различающееся имя компьютера сервера Exchange, ответственного за создание автономной адресной книги.

Анализатор сервера Exchange также опрашивает WMI-класс Exchange_Server Microsoft, чтобы определить значение раздела IsFrontEndServer сервера Exchange. Если значением раздела IsFrontEndServer является True, сервер Exchange выступает в качестве сервера переднего плана.

Если анализатор сервера Exchange определяет, что назначенный сервер автономной адресной книги также является сервером переднего плана, анализатор отображает сообщение об ошибке.

Эта ошибка указывает, что сервер Exchange, ответственный за создание автономных адресных книг, является сервером переднего плана. Если назначенный сервер автономной адресной книги также является сервером переднего плана, создание автономной адресной книги завершится со сбоем. Для выполнения этой задачи должен быть назначен новый сервер. Если сервер, на котором работает Microsoft Exchange 2000 Server с пакетом обновления 2 или более поздняя версия, назначен в качестве сервера переднего плана, следующие службы не будут работать:

  • DSProxy;

  • создание автономной адресной книги;

  • служба Recipient Update Service;

  • задачи доступности и занятости;

  • агент очистки почтового ящика;

  • служба событий Exchange;

  • служба репликации сайта.

Серверы переднего плана предназначены для обработки входящих клиентских запросов от веб-клиента Microsoft Office Outlook® , POP3, IMAP4, Exchange ActiveSync, Outlook Mobile Access и клиентов Outlook, которые используют удаленные вызовы процедур через HTTP. Также серверы переднего плана иногда используются для ретрансляции SMTP-сообщений на внутренние серверы Exchange.

Чтобы устранить эту неполадку, рекомендуется назначить внутренний сервер Exchange в качестве сервера автономной адресной книги.

Чтобы устранить эту ошибку

  1. Откройте системный диспетчер Exchange

  2. Под пунктом Получатели щелкните ??Автономные списки адресов??.

  3. В правой области щелкните правой кнопкой мыши ??Автономный список адресов по умолчанию??, затем щелкните Свойства.

    Примечание.
    Используйте эту процедуру для других автономных списков адресов, которые приводят к отображению этого сообщения.

  4. На вкладке Общие под разделом ??Сервер автономного списка адресов?? нажмите кнопку Обзор, затем щелкните внутренний сервер Exchange, который следует использовать.

Дополнительные сведения о работе с автономными адресными книгами см. на веб-странице, посвященной настройке автономных адресных книг в Exchange Server 2003, которая содержится в материалах, описывающих работу с хранилищем Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47595).


Общая папка узла автономной адресной книги удалена
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-12-03

Чтобы определить значение атрибута siteFolderServer для каждого объекта хранилища общих папок, средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®. Если анализатор сервера Exchange обнаруживает, что значение атрибута siteFolderServer содержит строку «DEL:», выводится сообщение об ошибке.

Атрибут siteFolderServer представляет хранилище общих папок, используемое для сервера автономной адресной книги. По умолчанию сервер Exchange создает файлы автономной адресной книги на сервере папок узла (первый сервер, установленный в административной группе). Если в качестве сервера автономной адресной книги выбран другой сервер, хранилище общих папок, указанное в этом атрибуте, будет хранилищем на новом сервере автономной адресной книги и не будет хранилищем на действительном сервере папок узла административной группы.

Когда приложение Exchange Server 2003 создает файлы автономной адресной книги, эти файлы связываются с почтовыми сообщениями, а сами сообщения помещаются в специальные общие папки. Microsoft Office Outlook® 2003 извлекает сообщения из папки и загружает вложенные файлы.

Сообщения автономной адресной книги хранятся во вложенных папках папки автономной адресной книги, являющейся одной из системных папок в дереве общих папок по умолчанию. Эта папка содержит вложенную папку для каждой административной группы или узла топологии организации. По умолчанию реплика сожержимого папки административной группы находится на первом сервере, установленном в административной группе (называющемся сервером папок узла).

Если используется организация Exchange Server 2007 без клиентов нижнего уровня (Outlook 2003 или более ранние версии), то это предупреждение или ошибку можно пропустить. Если в организации Exchange Server 2007 размещены клиенты с Outlook 2003 или более ранней версии, выполните указанные ниже действия, чтобы включить распространение через общие папки для автономных файлов адресной книги. Распространение через общие папки - это метод распространения, посредством которого клиенты, на которых выполняется Outlook 2003 (или более ранней версии) и которые работают автономно либо с помощью подключения удаленного доступа, получают доступ к автономной адресной книге (OAB).

Устранение ошибки

  1. Если известно, что сервер существует, в системном диспетчере Exchange, в узле Серверы разверните сервер, разверните группу хранилищ, а затем щелкните Хранилище общих папок. Проверьте в правой области, работает ли хранилище Exchange.

  2. Чтобы назначить новый сервер автономной адресной книги, в узле Получатели щелкните Автономные списки адресов. Затем в правой области щелкните Автономный список адресов по умолчанию (или любой другой автономный список адресов, вызывающий это сообщение).

    Если использование автономной адресной книги не планируется, щелкните правой кнопкой мыши Автономный список адресов по умолчанию, а затем нажмите кнопку Удалить. В противном случае воспользуйтесь оставшейся частью описываемой процедуры для создания расписания.

  3. Щелкните правой кнопкой мыши Автономный список адресов по умолчанию и выберите в контекстном меню команду Свойства.

  4. На вкладке Общие, в разделе сервер автономной адресной книги для выбора сервера нажмите кнопку Обзор.

Устранение причин появления этого предупреждения на сервере Windows Server 2007

  1. Откройте консоль управления Exchange.

  2. Разверните узлы Microsoft Exchange и Конфигурация организации, а затем выберите элемент Почтовый ящик.

  3. В области результатов перейдите на вкладку Автономная адресная книга.

  4. На вкладке Автономная адресная книга выберите параметр «Автономная адресная книга по умолчанию».

    1. Для того чтобы включить распространение через общие папки, на вкладке Рассылка выберите Включить распространение через общие папки.

    2. Нажмите кнопку ОК, чтобы сохранить изменения.

  5. Для назначения нового сервера автономной адресной книги в области действий щелкните Переместить, чтобы запустить мастер перемещения автономной книги. Этот мастер позволяет переназначить формирование автономной адресной книги на другой сервер. Кроме того, он скопирует на указанный сервер уже существующие файлы адресной книги.

Включение распространения общих папок для автономных файлов адресной книги с помощью среды управления Exchange.

  • Выполните следующую команду:

    Копировать код
    Set-OfflineAddressBook -Identity <OAB> -PublicFolderDistributionEnabled $true

    где: <OAB> указывает различающееся имя, имя в формате «домен\имя_учетной_записи» или идентификатор GUID автономной адресной книги.

    Например, чтобы включить распространение общих папок автономной адресной книги по умолчанию, необходимо ввести следующую команду:
Копировать код
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -PublicFolderDistributionEnabled $true

Использование среды управления Exchange для указания сервера, на котором будет выполняться формирование автономной адресной книги

  • Выполните следующую команду:

    Копировать код
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    где: <OAB> — это различающееся имя, имя в формате «домен\имя учетной записи» или идентификатор GUID автономной адресной книги, а <Server> указывает сервер Exchange Server, на котором будет выполняться выбранная операция.

    Например, для переназначения формирования автономной адресной книги на сервер SERVER01 необходимо ввести следующую команду:
Копировать код
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Дополнительные сведения о работе с автономными адресными книгами в Exchange Server 2003 см. в руководстве по настройке автономной адресной книги Exchange Server 2003 в статье Работа с хранилищем Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=47595 (на английском языке).

Дополнительные сведения о работе с автономными адресными книгами в Exchange Server 2007 см. в статье «Настройка организации > Почтовый ящик > Автономные адресные книги» по адресуhttp://go.microsoft.com/fwlink/?LinkId=79247 (на английском языке).


Обнаружена более старая версия файла CDO.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение раздела Version для нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange обнаружит, что значение Version для какого-либо из указанных выше файлов меньше значения Version сервера Exchange, будет выведено предупреждение. Номер более ранней версии указывает на возможность использования устаревших файлов.

Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если это не устранит ошибку, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-значный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Обнаружена более старая версия файла DAVEX.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение раздела Version для нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange обнаружит, что значение Version для какого-либо из указанных выше файлов меньше значения Version сервера Exchange, будет выведено предупреждение. Номер более ранней версии указывает на возможность использования устаревших файлов.

Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если это не устранит ошибку, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте компакт-диск Exchange 2000 Server или Exchange Server 2003 в устройство чтения компакт-дисков.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — устройство чтения компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если вы согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-значный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=33457).


Обнаружена более старая версия файла DRVIIS.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-10-06

Средство Microsoft® Exchange Server Analyzer запрашивает класс CIM_Datafile инструментария WMI, чтобы определить значение ключа Version для нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • DrvIis.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если средство Exchange Server Analyzer обнаруживает, что значение параметра Version для любого из перечисленных выше файлов меньше, чем значение параметра Version для сервера Exchange, отображается предупреждение. Более ранний номер версии указывает на то, что могут использоваться устаревшие файлы.

Чтобы исправить ошибку, установите последний пакет обновления или накопительный пакет обновления для сервера Exchange Server. Если эта ошибка не устраняется, запустите программу установки сервера Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. После переустановки сервера Exchange Server необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Переустановка сервера Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте диск Exchange 2000 Server или Exchange Server 2003 в привод для компакт-дисков.

  2. В меню «Пуск» выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — это дисковод для компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если вы согласны с условиями лицензионного соглашения, нажмите кнопку Принимаю, а затем кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие щелкните стрелку вниз рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=25097 (на английском языке).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server по адресу http://go.microsoft.com/fwlink/?LinkId=33457 (на английском языке).


Обнаружена более ранняя версия файла DSACCESS.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа сервера Microsoft® Exchange запрашивает класс CIM_Datafile инструментария WMI, чтобы определить значение параметра Версия для нескольких основных двоичных файлов Exchange:

  • Exres.dll

  • Gapi32.dll (отмеченный в папках System32 и \Exchsrvr\bin)

  • Mapi32.dll (отмеченный в папках System32 и \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если средство анализа сервера Exchange обнаруживает, что значение параметра Версия для любого из перечисленных выше файлов меньше, чем значение параметра Версия для сервера Exchange, отображается предупреждение. Более ранний номер версии указывает на то, что могут использоваться устаревшие файлы.

Для устранения этой ошибки установите новейший пакет обновления или обновление для своей версии Exchange. Если ошибка не будет устранена, запустите программу установки сервера Exchange 2000 или Exchange Server 2003 и выберите Переустановить. Запуск программы установки в режиме переустановки позволяет установить только двоичные файлы. Данные пользователя или настройки не удаляются и не сбрасываются. При переустановке сервера Exchange можно также переустановить любые установленные пакеты обновления или исправления.

Чтобы переустановить сервер Exchange 2000 или Exchange 2003, выполните следующие действия:

  1. Войдите на сервер, на котором нужно установить Exchange. Вставьте компакт-диск сервера Exchange 2000 или Exchange 2003 в устройство чтения компакт-диска.

  2. В меню Пуск выберите Выполнить и введите <буква диска>:\setup\i386\setup, где <буква диска> соответствует дисководу CD-ROM.

  3. В окне Добро пожаловать в мастер установки Microsoft Exchange выберите Далее.

  4. Прочитайте Лицензионное соглашение в соответствующем окне. Если вы принимаете его, нажмите кнопку Принимаю, затем Далее.

  5. В окне Регистрационный номер введите 25-значный код продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие щелкните стрелку раскрывающегося меню рядом с узлом Microsoft Exchange и выберите Переустановить, затем нажмите кнопку Далее.

Для получения дополнительных сведений о новейших пакетах обновления, накопительных пакетах обновления и расширениях для Exchange 2003 см. веб-узел «Загрузка для Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=25097).

Для получения дополнительных сведений о новейших пакетах обновления, накопительных пакетах обновления и расширениях для Exchange 2000 см. веб-узел «Загрузка для Exchange Server 2000» (http://go.microsoft.com/fwlink/?LinkId=33457).


Обнаружена более старая версия файла EMSMTA.EXE
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс CIM_Datafile, чтобы определить значение раздела Version для нескольких двоичных файлов ядра Exchange:

  • Exres.dll

  • Gapi32.dll (проверяется в папке System32 и в папке \Exchsrvr\bin)

  • Mapi32.dll (проверяется в папке System32 и в папке \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если анализатор сервера Exchange обнаружит, что значение Version для какого-либо из указанных выше файлов меньше значения Version сервера Exchange, будет выведено предупреждение. Номер более ранней версии свидетельствует о том, что, возможно, используются устаревшие файлы.

Чтобы устранить эту ошибку, установите последний пакет обновлений или накопительный пакет обновления для своей версии Exchange. Если это не приведет к устранению ошибки, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные настройки. Если сервер Exchange Server переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Осуществите вход на сервер, на котором требуется переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если вы согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификатор продукта введите свой 25-значный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, накопительных пакетах обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Обнаружена более старая версия файла EPOXY.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение раздела Version для нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange обнаружит, что значение Version для какого-либо из указанных выше файлов меньше значения Version сервера Exchange, будет выведено предупреждение. Номер более ранней версии указывает на возможность использования устаревших файлов.

Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если это не устранит ошибку, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте компакт-диск Exchange 2000 Server или Exchange Server 2003 в устройство чтения компакт-дисков.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — устройство чтения компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-значный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Обнаружена более старая версия файла ESE.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-06-20

Средство анализа сервера Microsoft® Exchange запрашивает класс CIM_Datafile инструментария WMI, чтобы определить значение параметра Версия для нескольких основных двоичных файлов Exchange:

  • Exres.dll

  • Gapi32.dll (поиск в папке System32 и в папке \Exchsrvr\bin)

  • Gapi32.dll (поиск в папке System32 и в папке \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если средство анализа сервера Exchange обнаруживает, что значение параметра Версия для любого из перечисленных выше файлов меньше, чем значение параметра Версия для сервера Exchange, отображается предупреждение. Более ранний номер версии указывает на то, что могут использоваться устаревшие файлы.

Чтобы исправить ошибку, установите последний пакет обновлений или накопительный пакет обновлений Exchange. Если ошибка не устраняется, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберитеПереустановить. Запуск программы установки в режиме переустановки позволяет установить только двоичные файлы. Пользовательские данные и данные настройки не удаляются и не сбрасываются. При переустановке сервера Exchange можно также переустановить любые установленные пакеты обновления или исправления.

Как переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором нужно переустановить Exchange. Вставьте компакт-диск сервера Exchange 2000 или Exchange 2003 в дисковод CD-ROM.

  2. В меню Пуск выберите Выполнить, затем введите <диск>:\setup\i386\setup, где <диск> - это буква привода компакт-дисков.

  3. На странице Добро пожаловать в Мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение прочитайте соглашение. Если вы согласны с условиями, нажмите кнопку Принимаю, затем нажмите кнопку Далее.

  5. На странице Регистрационный номер введите состоящий из 25 цифр ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие, используя стрелку раскрывающегося списка, расположенную рядом с узлом Microsoft Exchange, выберите Переустановить и нажмите кнопку Далее.

Для получения дополнительных сведений о новейших пакетах обновления, накопительных пакетах обновлений и расширениях для Exchange Server 2003 см. веб-узел «Загружаемые файлы для Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=25097).

Для получения дополнительных сведений о новейших пакетах обновления, накопительных пакетах обновлений и расширениях для Exchange Server 2000 см. веб-узел «Загружаемые файлы для Exchange Server 2000» (http://go.microsoft.com/fwlink/?LinkId=33457).


Обнаружена более старая версия файла ESEUTIL.EXE
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение раздела Version для нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange обнаружит, что значение Version для какого-либо из указанных выше файлов меньше значения Version сервера Exchange, будет выведено предупреждение. Номер более ранней версии указывает на возможность использования устаревших файлов.

Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если это не устранит ошибку, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте компакт-диск Exchange 2000 Server или Exchange Server 2003 в устройство чтения компакт-дисков.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — устройство чтения компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-значный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Найден старый файл EXCDO.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version (версия) для нескольких основных двоичных файлов Exchange:

  • Exres.dll

  • Gapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»)

  • Mapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если анализатор сервера Exchange обнаруживает, что значение Version для какого-либо из указанных выше файлов меньше значения Version сервера Exchange, выводится предупреждение. Номер более ранней версии указывает на возможность использования устаревших файлов.

Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если ошибку не удалось устранить, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в привод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие нажмите кнопку с указывающей вниз стрелкой рядом с узлом Microsoft Exchange, выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Обнаружен более старый файл EXSMTP.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version (версия) для нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»),

  • Mapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange обнаружит, что значение Version для какого-либо из указанных выше файлов меньше значения Version сервера Exchange, на экран будет выведено предупреждение. Номер более ранней версии указывает на возможность использования устаревших файлов.

Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если эта ошибка продолжает оставаться, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Присутствует более старый файл EXCHMEM.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version для нескольких основных двоичных файлов сервера Exchange. Эти файлы включают файл Exchmem.dll. Если анализатор сервера Exchange обнаружит, что файл Exchmem.dll в папке \%systemroot%\system32 старше файла Exchmem.dll в папке \%exchangeroot%\bin, анализатор сервера Exchange выведет на экран предупреждение.

Обычно на сервере не существует двух копий файла Exchmem.dll. Однако иногда второй файл Exchmem.dll добавляется вместе с выполняемым на месте обновлением из предыдущих выпусков продукта. Наличие двух версий файла может привести к ошибкам во время установки выпусков обновлений. Чтобы предотвратить появление проблем, рекомендуется переименовать файл Exchmem.dll в папке \%systemroot%\system32.

Чтобы устранить причину появления этого предупреждения

  1. Остановите все службы Exchange.

  2. Переименуйте файл Exchmem.dll в папке \%systemroot%\system32, присвоив ему название «Exchmem.dll.old».

  3. Снова запустите все службы Exchange.


Обнаружена более старая версия файла EXMIME.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение раздела Version для нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange обнаружит, что значение Version для какого-либо из указанных выше файлов меньше значения Version сервера Exchange, будет выведено предупреждение. Номер более ранней версии указывает на возможность использования устаревших файлов.

Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если это не устранит ошибку, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-значный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Найдена устаревшая версия файла EXOLEDB.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Для определения значения параметра Version следующих двоичных файлов ядра средство анализа Exchange Microsoft® Exchange направляет запрос классу CIM_Datafile инструментария Microsoft Windows® Management Instrumentation (WMI):

  • Exres.dll

  • Gapi32.dll (отмеченный в папках System32 и \Exchsrvr\bin)

  • Mapi32.dll (отмеченный в папках System32 и \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если средство анализа Exchange Server обнаруживает, что параметр Version любого из этих файлов меньше параметра Version Exchange Server, отображается предупреждение. Более ранняя версия указывает на вероятность использования устаревших файлов.

Для исправления этой ошибки установите последний пакет обновлений или накопительный пакет обновления для установленной версии Exchange. Если ошибка не устранена, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. В режиме переустановки будут установлены только двоичные файлы. Пользовательские данные и данные о настройке не будут удалены или перезаписаны. При переустановке Exchange Server необходимо переустановить все пакеты обновлений или исправления Exchange, устанавливавшиеся ранее.

Для переустановки Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором нужно переустановить Exchange. Вставьте компакт-диск Exchange 2000 Server или Exchange Server 2003 в дисковод CD-ROM.

  2. В меню Пуск выберите Выполнить.. и введите <диск>:\setup\i386\setup, где <диск> - буква дисковода CD-ROM

  3. На странице Добро пожаловать в Мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение прочтите соглашение. Если вы принимаете условия соглашения, выберите Согласен, затем нажмите кнопку Далее.

  5. На странице Регистрационный номер введите ключ продукта из 25 цифр, затем нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действия нажмите на стрелку рядом с узлом Microsoft Exchange и выберите Переустановить, затем нажмите кнопку Далее.

Для получения дополнительных сведений о последних пакетах обновлений, обновлениях и надстройках Exchange Server 2003 см. страницу «Файлы для Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=25097).

Для получения дополнительных сведений о последних пакетах обновлений, обновлениях и надстройках Exchange 2000 Server см. страницу «Файлы для Exchange Server 2000» (http://go.microsoft.com/fwlink/?LinkId=33457).


Обнаружен более старый файл EXPOP3.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version для нескольких основных двоичных файлов Exchange:

  • Exres.dll

  • Gapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»),

  • Mapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»),

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если анализатор сервера Exchange обнаружит, что значение Version для какого-либо из указанных выше файлов меньше значения Version сервера Exchange, на экран будет выведено предупреждение. Номер более ранней версии указывает на возможность использования устаревших файлов.

Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если ошибку не удалось устранить, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На первой странице мастера установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие нажмите кнопку с указывающей вниз стрелкой рядом с узлом Microsoft Exchange, выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Обнаружен более старый файл EXPROX.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version (версия) для нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange обнаружит, что значение Version для какого-либо из указанных выше файлов меньше значения Version сервера Exchange, на экран будет выведено предупреждение. Номер более ранней версии указывает на возможное использование устаревших файлов.

Чтобы устранить эту ошибку, установите новейший пакет обновлений или сборку обновлений для своей версии Exchange. Если эта ошибка остается, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Обнаружен более старый файл EXRES.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version (версия) для нескольких основных двоичных файлов Exchange:

  • Exres.dll

  • Gapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»)

  • Mapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если анализатор сервера Exchange обнаруживает, что значение Version для какого-либо из указанных выше файлов меньше значения Version сервера Exchange, на экран будет выведено предупреждение. Номер более ранней версии указывает на возможность использования устаревших файлов.

Чтобы устранить эту ошибку, установите последний пакет обновления или сборку обновления для своей версии Exchange. Если ошибку не удалось устранить, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в устройство чтения компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие нажмите кнопку с указывающей вниз стрелкой рядом с узлом Microsoft Exchange, выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Найден старый файл MAD.EXE
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение раздела Version для нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange обнаружит, что значение Version для какого-либо из указанных выше файлов меньше значения Version сервера Exchange, будет выведено предупреждение. Номер более ранней версии указывает на возможность использования устаревших файлов.

Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если это не устранит ошибку, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-значный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Обнаружен более старый файл MAPI32.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version (версия) для нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange обнаружит, что значение Version для какого-либо из указанных выше файлов меньше значения Version сервера Exchange, на экран будет выведено предупреждение. Номер более ранней версии указывает на возможность использования устаревших файлов.

Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если эта ошибка остается, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


В папке system32 обнаружена более старая версия файла MAPI32.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение раздела Version для нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange обнаружит, что значение Version для какого-либо из указанных выше файлов меньше значения Version сервера Exchange, будет выведено предупреждение. Номер более ранней версии указывает на возможность использования устаревших файлов.

Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если это не устранит ошибку, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте компакт-диск Exchange 2000 Server или Exchange Server 2003 в устройство чтения компакт-дисков.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — устройство чтения компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-значный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Обнаружен более старый файл MDBSZ.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version (версия) для нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»),

  • Mapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange обнаружит, что значение Version для какого-либо из указанных выше файлов меньше значения Version сервера Exchange, на экран будет выведено предупреждение. Номер более ранней версии указывает на возможность использования устаревших файлов.

Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если эта ошибка продолжает оставаться, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Обнаружен более старый файл OABGEN.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version (версия) для нескольких основных двоичных файлов Exchange:

  • Exres.dll

  • Gapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»)

  • Mapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если анализатор сервера Exchange обнаруживает, что значение Version для какого-либо из указанных выше файлов меньше значения Version сервера Exchange, на экран будет выведено предупреждение. Номер более ранней версии указывает, что могут использоваться устаревшие файлы.

Чтобы устранить эту ошибку, установите последний пакет обновления или сборку обновления для своей версии Exchange. Если ошибку не удалось устранить, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в устройство чтения компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие нажмите кнопку с указывающей вниз стрелкой рядом с узлом Microsoft Exchange, выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Обнаружен более старый файл PHATCAT.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version (версия) для нескольких основных двоичных файлов Exchange:

  • Exres.dll

  • Gapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»),

  • Mapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»),

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если анализатор сервера Exchange обнаружит, что значение Version для какого-либо из указанных выше файлов меньше значения Version сервера Exchange, на экран будет выведено предупреждение. Номер более ранней версии указывает на возможное использование устаревших файлов.

Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если ошибку не удалось устранить, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Переустановка Exchange 2000 Server или Exchange Server 2003

  1. Войдите в систему сервера, на котором необходимо переустановить Exchange. Вставьте компакт-диск Exchange 2000 Server или Exchange Server 2003 в привод компакт-дисков.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — это дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. В случае согласия с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=25097 (возможно, на английском языке).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server по адресу http://go.microsoft.com/fwlink/?LinkId=33457 (возможно, на английском языке).


Обнаружена более старая версия файла PHATQ.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение раздела Version для нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange обнаружит, что значение Version для какого-либо из указанных выше файлов меньше значения Version сервера Exchange, будет выведено предупреждение. Номер более ранней версии указывает на возможность использования устаревших файлов.

Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если это не устранит ошибку, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-значный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Обнаружена более старая версия файла REAPI.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение раздела Version для нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange обнаружит, что значение Version для какого-либо из указанных выше файлов меньше значения Version сервера Exchange, будет выведено предупреждение. Номер более ранней версии указывает на возможность использования устаревших файлов.

Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если это не устранит ошибку, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-значный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Обнаружен устаревший файл RESVC.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version (версия) для нескольких основных двоичных файлов Exchange:

  • Exres.dll

  • Gapi32.dll (проверяется и в папке «System32», и в папке «\Exchsrvr\bin»),

  • Mapi32.dll (проверяется и в папке «System32», и в папке «\Exchsrvr\bin»),

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если анализатор сервера Exchange обнаружит, что значение Version для какого-либо из указанных выше файлов меньше значения Version сервера Exchange, на экран будет выведено предупреждение. Номер более ранней версии указывает на возможное использование устаревших файлов.

Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если ошибку не удалось устранить, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа установки не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. После переустановки сервера Exchange необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Переустановка Exchange 2000 Server или Exchange Server 2003

  1. Войдите в систему сервера, на котором необходимо переустановить Exchange. Вставьте компакт-диск Exchange 2000 Server или Exchange Server 2003 в привод компакт-дисков.

  2. В меню Пуск выберите команду Выполнить, а затем введите <диск>:\setup\i386\setup, где <диск> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. В случае согласия с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=25097 (возможно, на английском языке).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server по адресу http://go.microsoft.com/fwlink/?LinkId=33457 (возможно, на английском языке).


Обнаружена более старая версия файла STORE.EXE
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-10-06

Средство Microsoft® Exchange Server Analyzer запрашивает класс CIM_Datafile инструментария WMI, чтобы определить значение ключа Version для нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если средство Exchange Server Analyzer обнаруживает, что значение параметра Version для любого из перечисленных выше файлов меньше, чем значение параметра Version для сервера Exchange, отображается предупреждение. Более ранний номер версии указывает на то, что могут использоваться устаревшие файлы.

Чтобы исправить ошибку, установите последний пакет обновления или накопительный пакет обновления для сервера Exchange Server. Если эта ошибка не устраняется, запустите программу установки сервера Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. После переустановки сервера Exchange Server необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Переустановка сервера Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте диск Exchange 2000 Server или Exchange Server 2003 в привод для компакт-дисков.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод для компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если вы согласны с условиями лицензионного соглашения, нажмите кнопку Принимаю, а затем кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие щелкните стрелку вниз рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=25097 (на английском языке).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server по адресу http://go.microsoft.com/fwlink/?LinkId=33457 (на английском языке).


Обнаружены действующие вызовы Active Directory
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-14

Средство анализатора сервера Microsoft® Exchange просматривает файл Store.fcl журнала вызовов функций Exchange (Function Call Log — FCL) на наличие событий, которые указывают на действующие межкомпонентные вызовы службы каталогов Active Directory® из службы «Банк данных Microsoft Exchange» (Store.exe).

Действующий вызов — это запрос из службы «Банк данных Microsoft Exchange» (Store.exe) к другим компонентам, на который не получен ответ на момент записи данных журнала вызовов функций в файл Store.fcl.

Active Directory предоставляет все данные почтовых ящиков, службы списка адресов и другие сведения, связанные с получателями. Большая часть сведений о настройке Exchange Server 2003 также хранится в службе каталогов Active Directory.

Службы сервера Exchange обращаются к данным, которые хранятся в Active Directory, и записывают информацию в Active Directory.

Если анализатор сервера Exchange обнаруживает в файле журнала (Store.fcl) события, которые отражают действующие вызовы Active Directory из службы «Банк данных Microsoft Exchange» (Store.exe), анализатор сервера Exchange выводит на экран предупреждение.

Это предупреждение указывает на возможные проблемы с производительностью на данном сервере. Случайные действующие вызовы не обязательно свидетельствуют о наличии проблемы, однако повторяющиеся действующие вызовы в одной и той же области могут служить индикатором проблемы.

Когда ожидается ответ на межкомпонентные вызовы от службы банка данных Microsoft Exchange (Store.exe), потоки удаленных вызовов процедур могут архивироваться на фоне этих запросов, что может быть причиной проблем быстродействия сервера Exchange, таких как задержки отклика сервера на запросы клиентов.

Действующие вызовы Active Directory из службы «Банк данных Microsoft Exchange» могут быть обусловлены следующими причинами:

  • Задержки в сети между сервером Exchange и контроллером домена.

  • Статическая или другая неправильная настройка DSAccess.

  • Перегруженный контроллер домена и глобальный каталог.

  • Неправильно спроектированная топология Active Directory.

Для устранения причин появления этого предупреждения, выполните следующие шаги:

  • Запустите анализатор сервера Exchange для дополнительного анализа неполадок в работе сервера. Анализатор сервера Exchange можно загрузить на веб-узле версии 2.7 средства анализа рекомендаций Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Проверьте рабочие характеристики серверов контроллеров доменов Active Directory.

  • Ознакомьтесь со статьями в разделе «Дополнительные сведения» данного документа.

Дополнительные сведения

Дополнительные сведения о быстродействии сервера Exchange и о DSAccess см. в базе знаний Майкрософт в статье 250570, в которой описывается процедура обнаружения сервера в службе каталогов и использование DSAccess (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570).

Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению быстродействием и масштабируемостью Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

Дополнительные сведения об устранении проблем производительности сервера Exchange см. в описании процедур устранения неполадок, связанных с производительностью сервера Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=47588).

Дополнительные сведения об устранении проблем производительности банка данных см. в базе знаний Майкрософт в статье 257725, посвященной сбору диагностических данных для устранения неполадок в работе банка данных (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

Дополнительные сведения о быстродействии контроллера домена см. в следующих источниках информации о Windows Server:

  • «Planning Domain Controller Capacity» (Планирование емкости контроллера домена) (http://go.microsoft.com/fwlink/?LinkId=70191).

  • «Active Directory Monitoring of Domain Controllers» (Отслеживание работы контроллеров домена в службе каталогов Active Directory) в руководствах по планированию развертывания и развертыванию службы каталогов Active Directory в среде Windows 2000 Server (http://go.microsoft.com/fwlink/?LinkId=70193).


Обнаружены текущие вызовы к ESE
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-13

Средство анализа Microsoft® Exchange Server ищет в журнале вызова функций Exchange (FCL), файле Store.fcl, события, показывающие текущие межкомпонентные вызовы от службы Microsoft Exchange Information Store (Store.exe) к модулю расширяемого хранилища (ESE).

Текущие обращения - это запросы службы Microsoft Exchange Information Store (Store.exe) к другим компонентам, которые не получают отклика во время записи данных Exchange FCL в файл Store.fcl file.

Microsoft Exchange Information Store размещается поверх базы данных модуля расширяемого хранилища (ESE). ESE - сложное ядро базы данных, основанное на транзакциях. Транзакция - серия операций, рассматриваемая как первичная (невидимая) единица. Все операции в транзакции либо завершаются и постоянно сохраняются, либо никаких операций не происходит.

Сервер Exchange использует ESE как встроенное ядро базы данных, которое определяет структуру базы данных и управляет памятью. Ядро базы данных кэширует базу данных в памяти, передавая участки данных (страницы) в память и из нее. Оно обновляет страницы в памяти и записывает новые или обновленные страницы обратно на диск. При поступлении в систему запроса ядро базы данных может буферизовать данные в памяти. Таким образом, не требуется постоянное обращение к диску.

Хотя кэширование данных в памяти — самый быстрый и эффективный путь обработки данных, оно приводит к тому, что во время работы Exchange данные на диске никогда не бывают актуальными полностью. Последняя версия базы данных находится в памяти. В то же время многие изменения в памяти еще отсутствуют на диске, и память не синхронизирована. Диск с записью журнала транзакций всегда содержит сведения о каждой транзакции.

Если средство анализа Exchange Server определяет, что событие в файле журнала Store.fcl отражает текущие запросы службы Microsoft Exchange Information Store (Store.exe) к базе данных модуля расширяемого хранилища (ESE), выводится предупреждение.

Это предупреждение показывает, что на сервере возможны проблемы с производительностью. Случайные текущие обращения не обязательно указывают на проблему, но постоянные текущие обращения к одной области могут означать именно это.

Когда межкомпонентные запросы службы Microsoft Exchange Information Store (Store.exe) ожидают ответа, потоки удаленного вызова процедур (RPC) могут сохраняться после этих запросов и приводить к снижению производительности сервера Exchange, например, к задержкам реакции на обращения клиентов.

Текущие запросы службы Microsoft Exchange Information Store к модулю расширяемого хранилища (ESE) могут происходить по следующим причинам:

  • Оперативная дефрагментация Exchange.

  • Резервное копирование данных.

    Примечание.
    Если резервное копирование данных или оперативная дефрагментация происходит во время записи журналов отслеживания вызовов Exchange, сообщение о проблемах производительности сервера Exchange можно игнорировать.
  • Узкие места, связанные с дисками, на которых хранится база данных, например недостаточная емкость для числа пользователей сервера.

  • Узкие места, связанные с дисками TEMP и TMP.

Для устранения этих проблем выполните следующие действия:

  • Для получения оптимального результата рекомендуем не проводить резервное копирование или обслуживание в периоды максимального числа обращений пользователей.

  • Убедитесь, что диски, на которых хранятся базы данных, исправны и в достаточной степени поддерживают нагрузку потока ввода-вывода.

  • Запустите средство анализа Exchange Server для дополнительного анализа таких неполадок сервера, как ограничение размера сообщений и вложений. Средство анализа Exchange Server можно загрузить со страницы «Средство анализа Microsoft® Exchange Server v2.7» (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Просмотрите статьи в разделе Дополнительные сведения данного документа.

Дополнительные сведения

Для получения дополнительных сведений о настройке времени оперативной дефрагментации см. статью 244524 базы знаний Microsoft «XADM: Как настроить временной интервал оперативной дефрагментации в сервере Exchange» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524).

Для получения дополнительных сведений о проблемах производительности сервера Exchange, связанных с дисками, см. в разделеОбнаружено узкое место на диске.

Для получения дополнительных сведений о выборе размера и оптимизации работы дисков для сервера Exchange см. разделы «Как определить требования к обмену с диском» и «Общие рекомендации для нескольких архитектур» в статье Оптимизация хранилища для Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=49324).

Для получения дополнительных сведений о ESE см. статью «Архитектура модуля расширяемого хранилища» (http://go.microsoft.com/fwlink/?linkid=67009).


Обнаружены действующие вызовы IMail
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-13

Средство анализатора сервера Microsoft® Exchange просматривает файл Store.fcl журнала вызовов функций сервера Exchange (Function Call Log, FCL) на предмет наличия событий, указывающих на действующие межкомпонентные вызовы из службы «Банк данных Microsoft Exchange» (Store.exe), обращенные к компоненту IMAIL, принадлежащему клиенту MAPI.

Действующий вызов — это запрос, исходящий из службы «Банк данных Microsoft Exchange» (Store.exe), к другим компонентам, ответ на который на момент записи данных журнала вызовов функций в файл Store.fcl не получен.

Компонент IMAIL сервера Exchange Server — это гибкая служба преобразования, которая используется службой «Банк данных Microsoft Exchange» между сообщениями из Интернета и MAPI-сообщениями. Этот компонент обеспечивает взаимодействие между клиентами, использующими формат RFC-822 или формат Интернета, и клиентами, использующими формат внутреннего хранилища сервера Exchange, такими как клиенты MAPI или внутренние задачи хранилища.

Приложение Exchange использует механизм IMAIL для применения форматов сообщений к содержимому в соответствии с тем, как это определено для доменов Интернета в системном диспетчере Exchange или как указано пользователем для каждого получателя в Microsoft Office Outlook®. Если в IMAIL не передано никаких параметров форматирования, для передачи между серверами механизм IMAIL форматирует MAPI-сообщения в формате S/TNEF (Summary TNEF).

Если анализатор сервера Exchange обнаруживает в файле журнала Store.fcl события, которые отражают преобладание действующих вызовов от службы «Банк данных Microsoft Exchange» (Store.exe), адресованных компоненту IMAIL, принадлежащему MAPI, анализатор сервера Exchange выводит на экран предупреждение.

Это предупреждение указывает на возможные проблемы с производительностью на этом сервере. Случайные действующие вызовы не обязательно свидетельствуют о наличии проблемы, однако повторяющиеся действующие вызовы в одной и той же области могут служить индикатором проблемы.

Когда межкомпонентные вызовы от службы «Банк данных Microsoft Exchange» (Store.exe) ожидают ответа, потоки удаленных вызовов процедур могут архивироваться на фоне этих запросов, что может привести к появлению проблем производительности сервера Exchange, например к задержкам ответов сервера клиентам.

Действующие вызовы от службы «Банк данных Microsoft Exchange», адресованные компоненту IMAIL клиента MAPI, могут происходить при соблюдении одного или нескольких из следующих условий:

  • Механизм IMAIL пытается обработать слишком много данных в сообщении или вложении.

  • Многие клиенты посылают запросы на преобразование данных.

  • Ответы на запросы DSAccess приходят с задержкой.

  • Не хватает ресурсов на дисках TEMP и TMP.

  • Существуют выполняющиеся перемещения почтовых ящиков.

Для устранения причин появления этого предупреждения, выполните следующие действия:

  • Планируйте любые перемещения почтовых ящиков на часы внепиковой нагрузки.

  • Запустите анализатор сервера Exchange для дополнительного анализа проблем сервера, таких как предельные размеры сообщений и вложений. Анализатор сервера Exchange можно загрузить на веб-узле версии 2.7 анализатора рекомендаций Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Ознакомьтесь со статьями в разделе «Дополнительные сведения» данного документа.

Дополнительные сведения

Дополнительные сведения о проблемах отсутствия достаточных ресурсов на диске для сервера Exchange см. в разделе Обнаружено узкое место на диске.

Дополнительные сведения об определении размеров дисков и оптимизации их использования для сервера Exchange см. в разделах, описывающих расчет требований к системе ввода-вывода диска и общие рекомендации для нескольких архитектур, которые содержатся в статье, посвященной оптимизации хранилища для Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=49324).

Дополнительные сведения о рекомендациях по предельным размерам сообщений на сервере Exchange см. по ссылке Максимальный размер исходящего сообщения не задан.

Дополнительные сведения о производительности DSAccess и сервера Exchange см. в разделе, содержащем инструкции по настройке пользовательского кэша DSAccess, в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

Дополнительные сведения об устранении проблем производительности сервера Exchange см. в описании процедур устранения неполадок, связанных с производительностью сервера Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).

Дополнительные сведения об устранении проблем производительности банка данных см. в базе знаний Майкрософт в статье 257725, содержащей инструкции по сбору диагностических данных для устранения неполадок банка данных (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


Обнаружены действующие вызовы LSASS
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-13

Средство анализатора сервера Microsoft® Exchange просматривает файл Store.fcl журнала вызовов функций Exchange (Function Call Log, FCL) на наличие событий, которые указывают на действующие межкомпонентные вызовы из службы «Банк данных Microsoft Exchange» (Store.exe) процесса (Lsass.exe) сервера проверки подлинности локальной системы безопасности (Local Security Authentication Server).

Действующий вызов — это запрос, исходящий из службы «Банк данных Microsoft Exchange» (Store.exe), к другим компонентам, на который не получен ответ на момент записи данных журнала вызовов функций в файл Store.fcl.

Процесс (Lsass.exe) сервера проверки подлинности локальной системы безопасности — это подсистема безопасности, вызываемая другими процессами для проверки сведений учетной записи и правильности входа в систему.

При каждом входе в систему клиента Exchange сервер, на котором выполняется сервер Exchange, посылает запрос на просмотр идентификатора безопасности учетной записи клиента и создает вызов внутри процесса (Lsass.exe) сервера проверки подлинности локальной системы безопасности.

Если анализатор сервера Exchange обнаружит события в файле журнала (Store.fcl), которые отражают действующие вызовы от службы «Банк данных Microsoft Exchange» (Store.exe) к процессу (Lsass.exe) сервера проверки подлинности локальной системы безопасности, анализатор сервера Exchange выведет на экран предупреждение.

Это предупреждение указывает на возможность проблем с производительностью на этом сервере. Случайные действующие вызовы не обязательно свидетельствуют о наличии проблемы, однако повторяющиеся действующие вызовы в одной и той же области могут служить индикатором проблемы.

Когда межкомпонентные вызовы от службы «Банк данных Microsoft Exchange» (Store.exe) ожидают ответа, потоки удаленных вызовов процедур могут архивироваться на фоне этих запросов, что может быть причиной проблем производительности сервера Exchange.

Действующие вызовы от службы «Банк данных Microsoft Exchange» к процессу LSASS могут быть обусловлены следующими причинами:

  • Проблемы ресурсов сервера, касающиеся ряда пользователей, одновременно проходящих проверку подлинности.

  • Задержки сети между сервером Exchange и контроллером домена или сервером глобального каталога.

  • Проблемы узких мест в ресурсах сервера.

Для устранения причин появления этого предупреждения, выполните следующие шаги:

  • Рассмотрите возможность реализации параметра NeverPing, как описано в статье Рекомендуется параметр NeverPing

  • Ознакомьтесь со статьями в разделе «Дополнительные сведения» данного документа.

Дополнительные сведения

Дополнительные сведения о процессе Lsass.exe и использовании памяти см. в базе знаний Майкрософт в статье 308356, описывающей использование памяти процессом Lsass.exe на контроллерах доменов, работающих под управлением Windows Server 2003 или Windows 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356).

Дополнительные сведения о проблемах входов в систему клиентов Exchange и процесса LSASS см. в базе знаний Майкрософт в статье 161938, описывающей замедление процессов входа в систему клиентов Exchange из-за блокировки ресурсов (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938).

Дополнительные сведения о задержках сети между сервером Exchange и контроллером домена или сервером глобального каталога см. в статье блога группы поддержки сервера Exchange, описывающей причины, почему приложением Exchange не всегда используются серверы глобального каталога (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=69166).

Примечание.
Содержимое и URL-адрес каждого блога могут изменяться без предварительного уведомления.

Дополнительные сведения о проблемах узких мест в ресурсах сервера см. по ссылке Узкое место в работе процессора.

Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

Дополнительные сведения об устранении проблем производительности сервера Exchange см. в описании процедур устранения неполадок, связанных с производительностью сервера Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).

Дополнительные сведения об устранении проблем производительности банка данных см. в базе знаний Майкрософт в статье 257725, содержащей инструкции по сбору диагностических данных для устранения неполадок банка данных (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


Найдены текущие вызовы к поиску вирусов
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-13

Средство анализа Microsoft® Exchange Server просматривает журнал вызова функций Exchange (FCL), файл Store.fcl, на предмет наличия в нем событий, указывающих на текущие межкомпонентные обращения вызовы из службы Microsoft Exchange Information Store (Store.exe) к компоненту VAPI Virusscan.

Текущие вызовы представляют собой запросы службы Microsoft Exchange Information Store (Store.exe) к другим компонентам, которые не получили ответа при записи данных FCL Exchange в файл Store.fcl.

Если средство анализа Exchange Server обнаружит в файле журнала Store.fcl события, указывающие на текущие вызовы службы Microsoft Exchange Information Store (Store.exe) к компоненту VAPI, оно выдаст предупреждение.

Предупреждение свидетельствует о том, что могут возникнуть проблемы, связанные с производительностью сервера. Текущие вызовы, возникающие время от времени, не обязательно ведут к возникновению проблемы, однако повторяющиеся вызовы могут вызвать проблемы.

Когда служба Microsoft Exchange Information Store (Store.exe) ожидает ответа на межкомпонентные обращения, работа потоков удаленного вызова процедур (RPC) может замедляться, что приведет к снижению производительности Exchange Server, например к задержке ответа сервера на запросы клиентов.

Текущие обращения службы Exchange Information Store к компоненту VAPI могут быть вызваны следующими условиями:

  • Обновления средства поиска вирусов вызывают повторную проверку объектов в хранилище информации.

  • Средство поиска вирусов неправильно настроено.

  • Программа поиска вирусов обрабатывает длинное сообщение или вложение.

Чтобы устранить это предупреждение, выполните следующие шаги:

  • Запланируйте обновление средства поиска вирусов на то время, когда потребление ресурсов невелико, то есть на промежутки времени с минимальной загрузкой.

  • Попробуйте переустановить программу поиска вирусов. Это лучше сделать во время минимальной загрузки.

  • Просмотрите настройку средства поиска вирусов, проверьте правильность настройки потоков, исключений на уровне файлов и т. д. См. статью 823166 базы знаний корпорации Майкрософт «Использование антивирусных программ на сервере Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Просмотрите статьи, указанные в этом документе, в разделе Дополнительные сведения.

Дополнительные сведения

Для получения дополнительных сведений о программах поиска вирусов, обычно используемых с Microsoft Exchange Server 2003, см. статью 823166 базы знаний корпорации Майкрософт «Использование антивирусных программ на сервере Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Для получения дополнительных сведений о программах поиска вирусов, обычно используемых с Microsoft Exchange 2000 Server, см. статью 328841 базы знаний корпорации Майкрософт «Антивирусное программное обеспечение для Exchange» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Для получения дополнительных сведений о производительности сервера Exchange см. «Руководство по производительности и масштабируемости Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=47576).

Для получения дополнительных сведений об устранении неполадок, связанных с производительностью сервера Exchange, см. «Устранение неполадок в работе Microsoft Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=47588).

Для получения дополнительных сведений об устранении неполадок, связанных с производительностью банка сообщений, см. статью 257725 базы знаний корпорации Майкрософт «XADM: Сбор диагностических данных для решения проблем, связанных с хранилищем информации» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


Установлен параметр операционной системы GlobalFlag
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить значение записи GlobalFlag, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager

Если анализатор сервера Exchange обнаруживает, что параметра GlobalFlag имеет значение и это значение больше 0, выводится предупреждение.

  • Значение параметра реестра GlobalFlag представляет собой битовую маску, которая определяет, какие параметры отладки включены для операционной системы. Если не ведется отладка или трассировка неполадки с помощью служб поддержки продуктов Майкрософт, рекомендуется задать для параметра GlobalFlag значение 0.

Параметр GlobalFlag имеет значение 0 по умолчанию. Если это значение было изменено, можно использовать средство Gflags, включенное в средства поддержки Microsoft Windows Server™ 2003, которые находятся на компакт-диске Windows Server 2003 в папке «\Support». Кроме того, можно задать значение 0 вручную в редакторе реестра. Обе процедуры приводятся ниже.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы устранить эту ошибку с помощью средства GFlags

  1. Нажмите кнопку Пуск, щелкните Выполнить и введите в поле Открыть команду GFlags. Откроется окно программы «Global Flags».

  2. Снимите все флажки и нажмите кнопку Применить.

  3. Нажмите кнопку ОК, чтобы закрыть средство GFlags и перезапустите компьютера, чтобы данное изменение вступило в силу.

Чтобы устранить эту ошибку с использованием редактора реестра

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\ System\CurrentControlSet\Control\Session Manager

  3. Дважды щелкните параметр GlobalFlag и введите 0 в поле «Значение».

  4. Закройте редактор реестра и перезапустите компьютер, чтобы изменения вступили в силу.

Перед редактированием реестра для получения инструкций о том, как следует выполнить эту процедуру, изучите статью базы знаний Майкрософт 256986 «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).


Операционная система находится в режиме отладки
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_OperatingSystem, чтобы определить, установлено ли значение для свойства Debug. Если значение этого ключа на компьютере сервера Exchange установлено равным True, на экран выводится сообщение об ошибке.

Режим отладки Windows переключается путем добавления параметра /debug в файл Boot.ini. Если параметр /debug задан в файле Boot.ini компьютера Windows-сервера, отладчик ядра загружается во время запуска и сохраняется в памяти все время. Это позволяет специалисту службы поддержки устанавливать удаленное подключение к отлаживаемой системе и обращаться к отладчику, даже когда система не приостановлена в экранном режиме «ОСТАНОВ ядра». В отличие от переключателя /crashdebug переключатель /debug использует порт COM независимо от того, выполняется отладка или нет. Этот переключатель применяется при отладке неполадок, которые воспроизводятся регулярно. Скорее всего, параметр /debug был установлен в качестве средства устранения неполадок и затем его ненамеренно оставили установленным.

Функционирование дополнительных процессов оказывает значительное негативное воздействие на производительность. Поэтому не рекомендуется запускать сервер Exchange на компьютере, на котором операционная система Windows работает в режиме отладки.

Чтобы исключить появление этой ошибки, измените файл Boot.ini и удалите параметр /debug.

Чтобы устранить эту ошибку

  1. В проводнике Windows перейдите к системному разделу. Это раздел, в котором хранятся файлы поддержки оборудования, такие как Boot.ini и NTLDR.

  2. Если файл Boot.ini не виден, возможно, в окне Свойства папки установлен флажок Скрывать защищенные системные файлы. Если это так, в окне проводника Windows последовательно щелкните Сервис, Свойства папки, а затем щелкните Вид. Снимите флажок Скрывать защищенные системные файлы (рекомендуется). При появлении запроса нажмите кнопку Да.

  3. Если файл Boot.ini виден в проводнике Windows, щелкните правой кнопкой мыши этот файл, выберите в контекстном меню команду Открыть с помощью и выберите Блокнот, чтобы открыть файл.

  4. В разделе [Операционные системы] удалите параметр /debug.

  5. Сохраните и закройте файл, а затем перезапустите сервер Exchange, чтобы изменения вступили в силу.

Дополнительные сведения о параметрах, которые могут использоваться в файле Boot.ini, см. в базе знаний Майкрософт в статье 833721, описывающей доступные параметры в файлах Boot.ini для Windows XP и Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833721).


Для работы веб-клиента Outlook требуется установка исправления для Windows Server 2003 с пакетом обновления 1
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-08-28

Средство анализатора сервера Microsoft® Exchange запрашивает различные WMI-классы, чтобы определить следующие сведения:

  • В какой версии операционной системы Microsoft Windows Server работает сервер Exchange?

  • Работает ли сервер Exchange в кластере?

Если анализатор сервера Exchange обнаруживает, что выполнены приведенные ниже условия, на экран выводится предупреждение:

  • Установлен Exchange Server 2003 с пакетом обновления 1.

  • Не установлена операционная система Microsoft Windows Server™ 2003 с пакетом обновления 1.

  • Выполняется служба кластеров.

  • Значение Version файла Davex.dll меньше 6.5.7232.

Если выполняется эта конфигурация, необходимо загрузить и установить исправление для Exchange Server перед установкой Windows Server 2003 с пакетом обновления 1. Если это исправление не будет установлено, пользователи веб-клиента Microsoft Office Outlook® для Exchange Server 2003 не смогут подключаться к своим почтовым ящикам. Пользователи, чьи почтовые ящики расположены в кластерах, получат следующее сообщение об ошибке при попытке подключения с помощью веб-клиента Outlook:

  • «500 - Внутренние ошибки сервера»

Эта ошибка вызвана некоторыми улучшениями в безопасности, которые содержатся в Windows Server 2003 с пакетом обновления 1.

Если пользователь пытается подключиться к почтовому ящику с помощью веб-клиента Outlook, протокол HTTP отправляет запросы кластерному интерфейсу API, имитируя подключенного пользователя. Однако в операционной системе Windows Server 2003 с пакетом обновления 1 содержатся некоторые изменения, касающиеся безопасности. Были изменены ограничения безопасности для интерфейсов API, с помощью которых можно было получить доступ к удаленному реестру. Поэтому попытка подключения завершится неудачно.

Чтобы устранить эту ошибку, необходимо загрузить и установить исправление для сервера Exchange, описанное в статье 841561 базы знаний корпорации Майкрософт «При попытке доступа к кластерному внутреннему серверу Exchange Server 2003 через Outlook Web Access появляется сообщение «500 — Внутренняя ошибка сервера» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841561).


Несовпадение файлов шаблона веб-клиента Outlook
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить номер версии файла Wmtemplates.dll file. Затем анализатор сервера Exchange сравнивает номер версии файла Wmtemplates.dll на всех серверах административной группы. Если анализатор сервера обнаруживает, что номер версии файла Wmtemplates.dll не совпадает у сервера Exchange переднего плана и фонового сервера Exchange, анализатор сервера Exchange выдает на экран сообщение с рекомендациями.

Файл Wmtemplates.dll используется средствами управления веб-клиента Microsoft Office Outlook®. Несовпадающие версии файла Wmtemplates.dll на сервере переднего плана Exchange и на фоновом сервере Exchange могут вызвать ошибки уровня 400, если пользователи попытаются войти в веб-клиент Outlook путем доступа к серверу Exchange переднего плана.

Недавно корпорация Майкрософт выпустила два обновления файла Wmtemplates.dll:

  • "Microsoft Exchange Information Store service crashes periodically after you install Exchange Server 2003 SP1" (После установки пакета обновления 1 для Exchange Server 2003 периодически возникают сбои в работе службы банка данных Microsoft Exchange) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=872963)

  • "The S/MIME control does not load in OWA when you are running the Exchange Server 2003 OWA client on a Windows XP Service Pack 2-based computer" (Управление S/MIME не загружает веб-клиент Outlook, если веб-клиент Outlook приложения Exchange Server 2003 работает на компьютере на основе пакета обновления 2 для Windows XP) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=883543)

Если недавно было установлено любое из этих двух обновлений, верными могут оказаться следующие причины:

  • Обновления были установлены в неправильном порядке

  • Обновления были установлены не на обоих серверах: переднего плана и фоновом.

При установке обновлений для веб-клиента Outlook, следует установить обновление на сервер переднего плана, перезапустить сервер и затем установить обновление на фоновый сервер.

Если не установлено любое из этих обновлений, проверьте, чтобы на всех серверах работали последние пакеты и программы обновления сервера Exchange.

Сведения о последних пакетах и программах обновления сервера Exchange можно получить, посетив следующие веб-узлы:

  • Программы для загрузки для приложения Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=21236).

  • Программы для загрузки для приложения Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Число ожидающих запросов RPC достигло максимального порогового значения.
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-02-13

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов о показаниях счетчиков производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности получает данные со счетчика производительности RPC Requests объекта с оцениваемой производительностью MSExchangeIS для анализа данных о производительности.

Если анализатор сервера Exchange определяет, что число запросов RPC достигло пикового значения, равного 100, в течение временного интервала снятия отсчета, он выводит на экран сообщение об ошибке.

Счетчик производительности RPC Requests показывает число запросов удаленного вызова процедуры (RPC) MAPI или клиента, обрабатываемых в данный момент службой банка данных Microsoft Exchange. Среднее значение счетчика производительности RPC Requests должно быть всегда ниже 30. По умолчанию максимальное значение для запросов RPC равно 100. Следовательно, если настройка не выполнена по другому, служба банка данных Microsoft Exchange может обслужить только 100 запросов RPC одновременно, после чего все новые операции RPC будут отклонены, и пользователи не смогут связаться с сервером до тех пор, пока число запросов RPC не упадет ниже 100. Сервер перестанет отвечать, поток почты остановится. Пользователи Outlook будут получать диалоговое окно Отмена запросов RPC.

Эта ошибка указывает на то, что в сервере возникло "узкое место" по производительности, или что процесс перестал отвечать.

Узким местом по производительности могут быть соответствующие процессор, диск, сеть или память, такой эффект может также возникнуть из-за увеличения нагрузки на сервер или из-за недостатка ресурсов сервера. Используйте средство системного монитора (Perfmon.msc) для определения, вызвано ли узкое место возрастанием нагрузки на сервер, или сервер имеет недостаточно ресурсов. Если нагрузка на сервер возросла, определите источник нагрузки и уменьшите ее. Если сервер имеет недостаточно ресурсов, увеличьте ресурсы или удалите пользователей с сервера.

Процесс может перестать отвечать из-за того, что хранилище ожидает ресурсы, которые никогда не освобождаются. Например, причиной может быть кластер, теряющий диск, на котором хранятся данные по отслеживанию сообщений, или проблемы с поиском вирусов. Когда процесс перестает отвечать, запросы RPC никогда не отступают, и хранилище следует перезапустить.

Дополнительные сведения

  • Дополнительные сведения об узких местах процессора см. в разделе Узкое место в работе процессора

  • Дополнительные сведения об узких местах диска см. в разделе Обнаружено узкое место на диске

  • Дополнительные сведения о производительности сервера Exchange см. в Руководстве по управлению производительностью и масштабируемостью приложения Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Дополнительные сведения об устранении проблем производительности сервера Exchange см. в разделе Устранение неполадок, связанных с производительностью приложения Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Дополнительные сведения о порядке планирования производительности сервера Exchange см. в разделе Производительность приложения Exchange Server 2003: 10 моментов, о которых следует задуматься (http://go.microsoft.com/fwlink/?LinkID=56460).

  • Дополнительные сведения о порядке перемещения почтовых ящиков пользователей в целях уменьшения нагрузки на сервер см. в разделе Перенос почтовых ящиков пользователей на другой сервер.


Файл PHATCAT.DLL отсутствует
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы проверить несколько основных двоичных файлов:

  • Exres.dll

  • Gapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»)

  • Mapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если анализатор сервера Exchange обнаруживает, что отсутствует один или несколько из указанных выше файлов, выводится сообщение об ошибке. Чтобы устранить эту ошибку, установите последний пакет обновления или накопительный пакет обновления для вашей версии Exchange. Если ошибку не удалось устранить, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновления и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие нажмите кнопку с указывающей вниз стрелкой рядом с узлом Microsoft Exchange, выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновления, накопительных пакетах обновления и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновления, накопительных пакетах обновления и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Файл PHATQ.DLL отсутствует
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа сервера Microsoft® Exchange запрашивает класс CIM_Datafile инструментария управления Microsoft Windows® (WMI) для посика нескольких основных двоичных файлов Exchange:

  • Exres.dll

  • Gapi32.dll (поиск в папке System32 и в папке \Exchsrvr\bin)

  • Gapi32.dll (поиск в папке System32 и в папке \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если средство анализа сервера Exchange обнаруживает, что один или несколько файлов отсутствуют, отображается ошибка. Для устранения этой ошибки установите новейший пакет обновления или накопительный пакет обновлений для своей версии Exchange. Если ошибка не устраняется, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберитеПереустановить. Запуск программы установки в режиме переустановки приводит к переустановке только двоичных файлов. Данные пользователя или данные настройки не удаляются и не сбрасываются. Переустанавливая Exchange Server, необходимо переустановить все пакеты обновления или исправления для Exchange, установленные ранее.

Как переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором нужно переустановить Exchange. Вставьте компакт-диск с Exchange 2000 Server или Exchange Server 2003 в дисковод CD-ROM.

  2. В меню Пуск выберите Выполнить, затем введите <диск>:\setup\i386\setup, где <диск> - это буква привода компакт-дисков.

  3. На странице Добро пожаловать в Мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение прочитайте соглашение. Если вы согласны с условиями, нажмите кнопку Принимаю, затем нажмите кнопку Далее.

  5. На странице Регистрационный номер введите состоящий из 25 цифр ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие, используя стрелку раскрывающегося списка, расположенную рядом с узломMicrosoft Exchange, выберите Переустановить и нажмите кнопку Далее.

Для получения дополнительных сведений о новейших пакетах обновления, накопительных пакетах обновлений и расширениях для Exchange Server 2003 см. веб-узел «Загружаемые файлы для Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=25097).

Для получения дополнительных сведений о новейших пакетах обновления, накопительных пакетах обновлений и расширениях для Exchange Server 2000 см. веб-узел «Загружаемые файлы для Exchange Server 2000» (http://go.microsoft.com/fwlink/?LinkId=33457).


Проблема производительности файла подкачки
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-09-06

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчиков производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Для анализа данных о производительности модуль сбора данных о производительности собирает данные из счетчиков Avg Disk sec/Read и Avg Disk sec/Write экземпляра PAGEDISK объекта быстродействия LogicalDisk.

Если анализатор сервера Exchange определяет, что в течение временного интервала снятия отсчета значения счетчиков Avg Disk sec/Read и Avg Disk sec/Write превысили 10 миллисекунд, анализатор сервера Exchange выводит на экран сообщение об ошибке.

Объект производительности LogicalDisk содержит счетчики, такие как Avg Disk sec/Read и Avg Disk sec/Write, обеспечивающие мониторинг логических разделов жестких дисков. Счетчик производительности Avg Disk sec/Read показывает среднее время считывания данных с диска в секундах. Счетчик производительности Avg Disk sec/Write показывает среднее время записи данных на диск в секундах. Среднее значение счетчиков производительности Avg Disk sec/Read и Avg Disk sec/Write не должно превышать 10 миллисекунд.

Экземпляр PAGEDISK объекта производительности LogicalDisk на сервере представляет файл подкачки (Pagefile.sys). Pagefile.sys — это скрытый системный файл на жестком диске, используемый в Microsoft Windows® для хранения временных данных, когда системе не хватает оперативной памяти. Файл подкачки также называется свопинг-файлом или файлом виртуальной памяти.

Данная ошибка показывает, что существует проблема производительности диска, на котором расположен файл подкачки.

Чтобы устранить эту ошибку, выполните следующие шаги:

  • Определите причину задержки. Если проблема вызвана чрезмерно интенсивной работой со страницами оперативной памяти, она может быть вызвана проблемами памяти сервера.

  • Подумайте о размещении файла подкачки на выделенном разделе или высокоскоростном диске.

  • Проанализируйте возможность создания второго файла подкачки на другом диске, как описано в статье 197379 базы знаний Майкрософт, посвященной настройке файлов подкачки для оптимизации и восстановления в Windows Server 2003, Windows 2000 и Windows NT (http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379).

  • Выполняйте задачи обслуживания сервера во время внепиковых нагрузок. При использовании средств обслуживания, таких как служебные программы базы данных сервера Exchange (Eseutil.exe), или задач обслуживания, таких как управление почтовыми ящиками, в часы пиковых нагрузок может быть задействована дополнительная память, которую в противном случае приложение Exchange не использовало бы. Рекомендуется запускать эти средства и задачи в часы внепиковой нагрузки или в течение периодов низкого использования.

Дополнительные сведения

  • Дополнительные сведения об узких местах работы дисков см. в разделе Обнаружено узкое место на диске.

  • Дополнительные сведения об оптимизации производительности файла подкачки см. в статье 197379 базы знаний Майкрософт, описывающей настройку файлов подкачки для целей оптимизации и восстановления в Windows Server 2003, Windows 2000 и Windows NT (http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379).

  • Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Дополнительные сведения об устранении проблем производительности сервера Exchange см. в описании процедур устранения неполадок, связанных с производительностью сервера Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Дополнительные сведения о рекомендациях по разработке архитектур хранилищ см. в описании общих рекомендаций для нескольких архитектур (http://go.microsoft.com/fwlink/?LinkId=72988).

  • Дополнительные сведения об изменении емкости дисков, задержках и интенсивностях операций ввода-вывода см. в следующих блогах на веб-узле блогов группы Microsoft Exchange:

    • Основные принципы определения емкости диска (http://go.microsoft.com/fwlink/?linkid=39538)

    • Размышления о вводе-выводе диска и расчеты... (http://go.microsoft.com/fwlink/?linkid=39539)

    • Инструкции по расчету требований к системе ввода-вывода диска (http://go.microsoft.com/fwlink/?linkid=69747).


Счетчик использования файла подкачки равен более 50%
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-09-18

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности % Usage объекта производительности Paging File для анализа данных о производительности.

Если анализатор сервера Exchange Server, определит, что счетчик % Usage превышает 50% для определенного отрезка времени, анализатор сервера Exchange выведет сообщение об ошибке.

Файл подкачки (pagefile.sys) является скрытым системным файлом на жестком диске, используемым системой Windows для хранения временных данных в случаях, когда системе не хватает объема ОЗУ. Файл подкачки также называется свопинг-файлом или файлом виртуальной памяти. Использование файла подкачки оказывает влияние на производительность в целом, так как операции с диском требуют больше времени, чем операции с памятью. Кроме того, когда уровень подкачки на диск и с диска достаточно высок, может возникнуть нехватка места на диске и снизиться производительность. В этом случае проблемой является нехватка памяти, а узкие места на диске — это только ее признак.

Проблема конкуренции за память не является критичной до тех пор, пока не будет достигнут уровень, при котором на управление ограниченной памятью система тратит значительное количество времени по сравнению с количеством времени, необходимым для фактического выполнения работы. Если построить график конкуренции за память относительно среднего времени отклика, получится довольно прямая линия от нулевого уровня конкуренции и до точки, в которой время отклика значительно повышается. Эта точка называется точкой переполнения. Когда конкуренция за память доходит до этой точки, время отклика начинает экспоненциально увеличиваться. Временное переполнение в некоторых средах может не быть критичным, однако следует стараться избежать этого.

Эта ошибка указывает, что существует проблема производительности диска, на котором расположен файл подкачки. В конечном счете эта проблема может быть связана с проблемой памяти на сервере.

Чтобы устранить эту ошибку, выполните следующие шаги:

  • Рассмотрите возможность создания дополнительного файла подкачки на альтернативном диске, как описано в статье 197379 о настройке файлов подкачки для целей оптимизации и восстановления в Windows Server 2003, в Windows 2000 и в Windows NT (http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379).

  • Подумайте о размещении файла подкачки на выделенном разделе или диске с высокой скоростью.

  • Удаление лишнего программного обеспечения. Чтобы сделать ресурсы памяти доступными для Exchange, удалите все программные средства сторонних производителей, осуществляющие отслеживание или другое необязательное обслуживание. Оснастка «Производительность» (http://go.microsoft.com/fwlink/?LinkId=56118) может помочь понять, какой объем памяти используется различными приложениями.

  • Запускайте задачи обслуживания сервера в моменты минимальной загруженности системы. Если средства обслуживания, например служебные программы базы данных сервера Exchange (Eseutil.exe), или задачи, например управление почтовыми ящиками, запускаются в моменты наибольшей загруженности системы, при этом может использоваться память, которая в противном случае могла бы быть использована Exchange. Рекомендуется запускать эти средства и задачи в моменты наименьшей загруженности системы, когда система не используется активно.

  • Подумайте о возможности перемещения почтовых ящиков с задействованного сервера на другой сервер с целью снижения загруженности. Для получения дополнительных сведений см. раздел Перенос почтовых ящиков пользователей на другой сервер.

Дополнительные сведения

  • Дополнительные сведения о проблемах отсутствия места на диске см. в разделе Обнаружено узкое место на диске.

  • Для получения дополнительных сведений об оптимизации производительности файла подкачки см. статью 197379 базы знаний Майкрософт о настройке файлов подкачки для целей оптимизации и восстановления в Windows Server 2003, в Windows 2000 и в Windows NT (http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379).

  • Дополнительные сведения об улучшении производительности памяти см. в разделе Улучшение пользовательской памяти.

  • Дополнительные сведения о быстродействии сервера Exchange см. в Руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Дополнительные сведения об устранении проблем производительности сервера Exchange см. в разделе Устранение неполадок, связанных с производительностью сервера Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Дополнительные сведения о рекомендациях по разработке архитектур хранилищ см. в описании общих рекомендаций для нескольких архитектур (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=72988).

  • Для получения дополнительных сведений об определении объема памяти на диске, задержке и оценках ввода-вывода см. следующие журналы на веб-узле журналов команды Microsoft Exchange:

    • Основные принципы определения емкости диска (http://go.microsoft.com/fwlink/?linkid=39538).

    • Размышления о вводе-выводе диска и расчеты... (http://go.microsoft.com/fwlink/?linkid=39539).

    • Инструкции по расчету требований к системе ввода-вывода диска (могут быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=69747).


Установлен параметр PageHeapFlags
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующие разделы реестра, чтобы определить значение параметра PageHeapFlags:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\MAD.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\INETINFO.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\EMSMTA.EXE

Если анализатор сервера Exchange обнаруживает значение PageHeapFlags не равное 0 или null, отображается предупреждение.

Параметр PageHeapFlags используется вместе со значением реестра GlobalFlag, описанном в разделе Установлено значение параметра GlobalFlag. С помощью параметра PageHeapFlags можно выбрать стандартную проверку кучи, которая записывает определенную последовательность заполнения в конце выделения памяти для каждой кучи и изучает эти последовательности при снятии выделения. Также это называется полностраничной проверкой кучи. Эта процедура помещает страницу, к которой нет доступа, в конце каждого выделения памяти, чтобы программа немедленно останавливалась при попытке доступа к памяти за пределами выделения. Так как полностраничная проверка кучи использует целую страницу памяти для каждого выделения, частое применение этой проверки может вызвать нехватку памяти.

В этом случае анализатор сервера Exchange проверяет, включено ли значение PageHeapFlags для некоторых компонентов Exchange:

  • STORE.EXE — процесс банка данных;

  • MAD.EXE — процесс системного помощника;

  • INETINFO.EXE — родительский и административный процесс IIS;

  • EMSMTA.EXE — процесс агента передачи сообщений.

Если администратор не использует постоянно отладку и трассировку проблемы с помощью служб поддержки продуктов Майкрософт, рекомендуется задать параметру PageHeapFlags постоянное значение 0 или вообще удалить этот параметр.

Значение реестра PageHeapFlags по умолчанию не существует и должно быть добавлено вручную, если требуется отладка процесса STORE.EXE (или любого другого процесса). Можно воспользоваться средством Gflags, которое входит в состав средств поддержки Microsoft Windows Server™ 2003, находящихся на компакт-диске Windows Server 2003 в папке \Support. Также можно вручную установить значение 0 или полностью удалить параметр PageHeapFlags с помощью редактора реестра. Обе процедуры описаны в этой статье.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить эту неисправность с помощью средства GFlags

  1. Щелкните Пуск | Выполнить, в поле Открыть запустите GFlags. Появится пользовательский интерфейс средства Global Flags.

  2. В поле Имя файла образа введите STORE.EXE.

  3. Щелкните Параметры файла образа.

  4. Снимите все флажки и нажмите кнопку Применить.

  5. Повторите шаги со 2 по 4 для каждого процесса Exchange, указанного выше.

  6. Нажмите кнопку ОК, чтобы закрыть средство GFlags и перезагрузить необходимые службы для вступления изменений в силу.

  7. При использовании средства GFlags для сброса этого значения, значение PageHeapFlags не меняется и не удаляется. Вместо этого значение параметра GlobalFlag становится равным 0, что имеет больший приоритет и запрещает поведение, заданное параметром PageHeapFlags.

Чтобы исправить эту ошибку с помощью редактора реестра

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

  3. Удалите раздел с названием PageHeapFlags.

  4. Повторите шаги 2 и 3 для каждого приведенного процесса Exchange.

  5. Закройте редактор реестра и перезапустите компьютер, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Размер невыгружаемого пула превышает порог ошибки
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_PerfRawData_PerfOS_Memory, чтобы определить текущее значение для ключа PoolNonpagedBytes. Действие, предпринимаемое анализатором сервера Exchange, зависит от используемой операционной системы, наличия или отсутствия параметра /3GB в файле Boot.ini операционной системы Windows и найденного значения для данного ключа.

Далее представлена матрица оценок, которая используется анализатором сервера Exchange, чтобы определить, выходит ли данное значение за пределы, заданные для сервера Exchange. Если удовлетворяются указанные в матрице условия, отображается сообщение об ошибке.

Операционная система | Параметры Boot.ini | Текущее значение размера невыгружаемого пула
Windows 2000 Server или Advanced Server | /3GB | 110 МБ или более
Windows 2000 Server или Advanced Server | Отсутствует | 220 МБ или более
Windows Server™ 2003 | /3GB | 110 МБ или более
Windows Server 2003 | Отсутствует | 220 МБ или более

Значение ключа PoolNonpagedBytes — это выраженный в байтах размер невыгружаемого пула памяти ядра. Невыгружаемый пул — это область физической системной памяти для объектов, которые не могут записываться на диск и должны оставаться в физической памяти, пока она им выделена. В качестве значения данного ключа используется последнее наблюдаемое значение. На исправно работающем сервере Exchange это значение должно оставаться на определенном уровне. Если значение соответствующего счетчика постоянно растет, это может указывать на утечку памяти.

Поскольку нельзя увеличить предельный размер памяти, отведенной для невыгружаемого пула, сверх указанной выше границы, нарушение данного условия должно быть ликвидировано как можно быстрее. Независимо от используемой операционной системы или наличия параметра /3GB, операционной системой Windows может получить доступ только к указанному выше количеству памяти для невыгружаемого пула. Если Windows обращается к памяти, лежащей за пределами ядра, могут появиться сообщения об ошибках и сбой системы. Память ядра необходима для правильной работы системы, и, следовательно, необходимо тщательно следить за размером памяти ядра.

Если после перезапуска сервера Exchange ошибка повторяется, в качестве следующего шага убедитесь, что система правильно настроена и используются самые поздние версии программного и аппаратного обеспечения компьютера. В частности, должны быть установлены последние версии следующего программного обеспечения:

  • Пакет обновления операционной системы Windows

  • Пакет обновления сервера Exchange Server

  • Микропрограммы и драйверы оборудования

  • Обновления BIOS компьютера

  • Обновления для всех установленных и запущенных приложений сторонних разработчиков

Если обновление программного и аппаратного обеспечения не устраняет неполадку, отключите программное обеспечение сторонних разработчиков, перезагрузите компьютер, на котором установлен Exchange Server, и проследите за размером памяти ядра.

Чтобы устранить эту ошибку

  1. При первом удобном случае перезагрузите компьютер, на котором работает Exchange Server.

  2. Проследите за показаниями счетчика производительности Память | Байт в невыгружаемом страничном пуле, чтобы убедиться в том, что они не выходят за порог, указанный выше для вашей системы.

Дополнительные сведения о правильной настройке Exchange Server см. в следующих статьях и разделах базы знаний Майкрософт:

  • Статья 815372, описывающая оптимизацию использования памяти в Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • Статья 266096, в которой сообщается, что для Exchange 2000 требуется параметр /3GB при наличии более одного гигабайта ОЗУ (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096)

  • Статья, посвященная исправлению неполадок, связанных с производительностью сервера Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588)

  • Статья, посвященная исправлению неполадок, связанных с производительностью сервера Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=18177)

  • Руководство по производительности и масштабируемости для Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576)


Размер выгружаемого пула превысил порог предупреждения
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-03-16

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_PerfRawData_PerfOS_Memory, чтобы определить текущее значение ключа PoolPagedBytes. Действия, предпринимаемые анализатором сервера Exchange, зависят от используемой операционной системы, наличия или отсутствия параметра /3GB в файле Boot.ini операционной системы Windows и найденного значения данного ключа.

В таблице представлена матрица оценок, которая используется анализатором сервера Exchange, чтобы определить, выходит ли данное значение за пределы, заданные для сервера Exchange. Если удовлетворяются указанные в таблице условия, отображается предупреждение.

Операционная система | Параметры Boot.ini | Текущее значение размера выгружаемого пула
Windows 2000 Server или Advanced Server | /3GB | 180 МБ или более
Windows 2000 Server или Advanced Server | Отсутствует | 180 МБ или более
Windows Server™ 2003 | /3GB | 200 МБ или более
Windows Server 2003 | Отсутствует | 300 МБ или более

Значение ключа PoolPagedBytes — это выраженный в байтах размер выгружаемого пула памяти ядра. Выгружаемый пул — это область физической системной памяти для объектов, которые могут записываться на диск, когда они не используются. В качестве значения данного ключа используется последнее наблюдаемое значение. На исправно работающем сервере Exchange, когда не происходит архивирование или восстановление, для выгружаемого пула не должно использоваться более 180 МБ памяти.

В Windows 2000 Server и Windows 2000 Advanced Server наибольшим значением для размера памяти выгружаемого пула является 470 МБ. Когда используется параметр /3GB, на компьютерах, работающих под управлением Windows 2000 Advanced Server, наибольшим значением для размера памяти выгружаемого пула является 192 МБ. Когда параметр /3GB не используется, на компьютерах, работающих под управлением Windows Server 2003, наибольшим значением для размера памяти выгружаемого пула является 491 МБ. Когда используется параметр /3GB, на компьютерах, работающих под управлением Windows Server 2003, наибольшим значением для размера памяти выгружаемого пула является 256 МБ.

Поскольку нельзя увеличить предельный размер памяти, отведенной для выгружаемого пула, сверх указанной выше границы, нарушение данного условия должно быть ликвидировано как можно быстрее. Независимо от используемой операционной системы или наличия параметра /3GB, операционной системой Windows может получить доступ только к указанному количеству памяти для выгружаемого пула. Если Windows обращается к памяти, лежащей за пределами ядра, могут появиться сообщения об ошибках и сбой системы. Память ядра необходима для правильной работы системы, и, следовательно, необходимо тщательно следить за размером памяти ядра.

Если после перезапуска сервера Exchange ошибка повторяется, в качестве следующего шага убедитесь, что система правильно настроена и используются самые последние версии программного и аппаратного обеспечения компьютера. В частности, должны быть установлены последние версии следующего программного обеспечения:

  • Пакет обновления операционной системы Windows

  • Пакет обновления сервера Exchange Server

  • Микропрограммы и драйверы оборудования

  • Обновления BIOS компьютера

  • Обновления для всех установленных и запущенных приложений сторонних разработчиков

Если обновление программного и аппаратного обеспечения не устраняет неполадку, отключите программное обеспечение сторонних разработчиков, перезагрузите компьютер, на котором установлен Exchange Server, и проследите за размером памяти ядра.

Чтобы устранить причину появления этого предупреждения

  1. При первом удобном случае перезагрузите компьютер, на котором работает Exchange Server.

  2. Проследите за показаниями счетчика производительности Память | Байт в выгружаемом страничном пуле, чтобы убедиться в том, что они не выходят за порог, указанный выше для вашей системы.

Дополнительные сведения о правильной настройке Exchange Server см. в следующих статьях базы знаний Майкрософт и разделах справочной системы Exchange:

  • Статья 815372, описывающая оптимизацию использования памяти в Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • Статья 266096, в которой сообщается, что для Exchange 2000 требуется параметр /3GB при наличии более одного гигабайта ОЗУ (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096)

  • Статья, посвященная исправлению неполадок, связанных с производительностью сервера Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588)

  • Статья, посвященная исправлению неполадок, связанных с производительностью сервера Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=18177)

  • Руководство по производительности и масштабируемости для Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576)

Дополнительные сведения см. в следующих статьях блога по Exchange:

  • Статья, посвященная управлению памятью ядра Microsoft Windows и серверу Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=63477)

  • Статья, посвященная применению для Exchange 2003 большой памяти и памяти, добавляемой без выключения компьютера (http://go.microsoft.com/fwlink/?LinkId=63478)

  • Статья, посвященная большим маркерам безопасности и нехватке памяти ядра (http://go.microsoft.com/fwlink/?LinkId=63479)

    Примечание.
    Ссылки на эти блоги приводятся только с информационной целью. Их содержимое может изменяться без уведомления.


Неверно указан путь к расширению прокси-сервера RPC
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange считывает следующее свойство метабазы служб IIS, чтобы определить, правильно ли указано его значение:

LM/W3SVC/Filters/RpcProxy

Свойство метабазы представляет собой свойство расширения прокси-сервера удаленных вызовов процедур (RPC) в расширениях веб-служб для IIS. Верным значением для этого свойства является следующее:

<Windows Directory>\system32\rpcproxy\rpcproxy.dll

Если анализатор сервера Exchange обнаруживает, что данное свойство имеет неверное значение, выводится предупреждение.

Свойство расширения прокси-сервера RPC указывается при установке подкомпонента «Прокси RPC по HTTP» компонента «Сетевые службы Microsoft Windows®». Если для данного свойства задано неверное значение или оно было изменено вручную, нужно выполнить следующие действия:

  1. Удалите неверное свойство расширения прокси-сервера RPC.

  2. Удалите подкомпонент «Прокси RPC по HTTP».

  3. Переустановите подкомпонент «Прокси RPC по HTTP».

Чтобы удалить неверно настроенное свойство расширения прокси-сервера RPC

  1. Откройте Диспетчер IIS.

  2. В левой области окна диспетчера IIS разверните имя сервера и щелкните Веб-расширения.

  3. В правой области окна диспетчера IIS щелкните правой кнопкой мыши Расширение прокси-сервера RPC и выберите команду Свойства.

  4. На вкладке Требуемые файлы выберите в списке файлов неправильный файл, нажмите кнопку Удалить, а затем — кнопку ОК.

    Примечание.
    Чтобы просмотреть полный путь, измените ширину столбца Имя файла в списке файлов.
Чтобы удалить подкомпонент «Прокси RPC по HTTP»

  1. Щелкните Пуск, затем щелкните Панель управления и выберите Установка и удаление программ.

  2. В левой области щелкните Установка компонентов Windows.

  3. Выберите Сетевые службы и нажмите кнопку Состав.

  4. Снимите флажок для элемента Прокси RPC по HTTP, нажмите кнопку ОК, а затем — кнопку Далее.

  5. По завершению работы мастера установки компонентов Windows нажмите кнопку Готово, чтобы закрыть окно мастера.
Чтобы повторно установить подкомпонент «Прокси RPC через HTTP»

  1. Щелкните Пуск, затем щелкните Панель управления и выберите Установка и удаление программ.

  2. В левой области щелкните Установка компонентов Windows.

  3. Выберите Сетевые службы и нажмите кнопку Состав.

  4. Установите флажок для элемента Прокси RPC по HTTP, нажмите кнопку ОК, а затем — кнопку Далее.

  5. По завершению работы мастера установки компонентов Windows нажмите кнопку Готово, чтобы закрыть окно мастера.

Дополнительные сведения о неполадках, связанных с неверной загрузкой расширения прокси-сервера RPC см. в части «Удаление неполадок» статьи 833401 базы знаний Майкрософт «How to configure RPC over HTTP on a single server in Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=833401) (Инструкции по настройке «RPC по HTTP» на отдельном сервере в Exchange Server 2003).

Дополнительные сведения о развертывании RPC по HTTP в Exchange Server 2003 см. в документе Exchange Server 2003 RPC over HTTP Deployment Scenarios (http://go.microsoft.com/fwlink/?LinkId=24823) (Сценарии развертывания RPC по HTTP в Exchange Server 2003).


Эмулятор PDC не исключен из топологии DSAccess
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средства анализатора сервера Microsoft® Exchange считывает следующие записи реестра, чтобы определить, был ли контроллер домена Active Directory®, играющий роль эмулятора основного контроллера домена(PDC), вручную исключен из списка контроллеров домена, доступных для использования сервером Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default\MinUserDC

Если анализатор сервера Exchange обнаруживает, что контроллер домена, выполняющий роль эмулятора PDC, не был вручную исключен из списка контроллеров домена, доступных для использования сервером Exchange, на экране выводится рекомендация.

Эмулятор PDC — это компьютер с ролью хозяина операций Active Directory, обрабатывающий запросы репликации от резервных контроллеров домена Microsoft Windows NT® Server 4.0, а также запросы обновления паролей для клиентов, не использующих программное обеспечение с поддержкой Active Directory. Эмуляторы PDC также являются контроллерами домена и поэтому доступны для использования Exchange Server и другими приложениями.

DSAccess (Directory Service Access) является внутренним компонентом Exchange 2000 Server и Exchange Server 2003, который управляет доступом всех компонентов сервера Exchange к службе каталогов Active Directory. Основной функцией DSAccess является поддержка сведений о различных событиях и операциях, связанных с каталогом. Например, DSAccess обнаруживает топологию Active Directory и определяет доступность контроллеров домена и серверов глобальных каталогов, а также возможность их ответа на запросы.

Компьютер эмулятора PDC по умолчанию включен в список доступных и пригодных к использованию контроллеров домена DSAccess. Если другие программы (помимо Exchange Server) активно используют эмулятор PDC, то использование эмулятора PDC компонентом DSAccess может привести к снижению производительности на компьютере эмулятора PDC, а также на сервере Exchange и на компьютере с другим приложением (не Exchange Server).

Снижения производительности можно избежать, добавив параметр MinUserDC в реестр на сервере Exchange. Это заставит DSAccess опросить все прочие доступные контроллеры домена перед обращением к контроллеру домена с ролью хозяина операций эмулятора PDC.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы проверить и изменить значение параметра реестра MinUserDC

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default

  3. Найдите параметр MinUserDC и произведите необходимые изменения. Если данного значения DWORD не существует, можно создать его вручную.

    Примечание.
    Значение, задаваемое для записи реестра MinUserDC, представляет максимальное количество контроллеров домена, которые необходимо опросить перед обращением к эмулятору PDC. Например, когда для параметра MinUserDC задано значение 4, DSAccess исключает эмулятор PDC только если доступно 4 контроллера домена.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные инструкции по использованию записи реестра MinUserDC см. в статье 298879 базы знаний Майкрософт, в которой описывается возможное снижение производительности Exchange 2000 при использовании эмулятора PDC для DSAccess (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298879).


Данные производительности для счетчика Available MBytes
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Available MBytes объекта производительности Memory для анализа данных о производительности. Если анализатор сервера Exchange собирает данные счетчика производительности Available MBytes, анализатор отобразит сведения о собранных данных в качестве базовых сведений.

Счетчик производительности Available MBytes показывает количество физической памяти в мегабайтах (МБ), доступное в настоящий момент для выделения процессам или системе. Количество доступной памяти равно общему количеству памяти, выделенной для кэша, свободной памяти и обнуленных страниц памяти.

По умолчанию анализатор сервера Exchange получает сведения каждые 30 секунд в течение двух часов. Анализатор сервера Exchange сообщает максимальное значение счетчика производительности, достигаемое в течение интервала сбора данных. Кроме того, анализатор сервера Exchange сообщает значение, находящееся на позиции девяносто процентов в списке всех собранных значений.

Примечание.
Если расположить в возрастающем порядке все значения, собранные анализатором сервера Exchange, таким показателем будет значение, находящееся на позиции девяноста процентов в данном списке. Это значение отражает высокие показания счетчика в течение интервала сбора данных.

В некоторых случаях максимальное значение является пиковым в данном интервале. Поэтому максимальное значение не является репрезентативным для всего интервала. Значение медианы не всегда верно отражает загрузку, поскольку это значение включает время бездействия в течение интервала сбора данных. Таким образом, анализатор сервера Exchange сообщает максимальное значение и значение, расположенное на позиции девяноста процентов.

Данные в этом базовом сообщении предназначены только для чтения. Никаких специальных действий выполнять не требуется.

Дополнительные сведения о предложенных порогах счетчиков производительности см. на веб-узле, посвященном устранению неполадок, связанных с производительностью сервера Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).


Данные о производительности от счетчика «Average Disk sec/Read» объекта производительности «LogicalDisk»
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Avg. Disk sec/Read объекта производительности LogicalDisk для анализа данных о производительности. Если анализатор сервера Exchange собирает данные от счетчика производительности Avg. Disk sec/Read, анализатор сервера Exchange отображает сведения о собранных данных в качестве базовых сведений.

Объект производительности Logical Disk состоит из таких счетчиков, как Avg. Disk sec/Read, которые ведут наблюдение за логическими разделами жестких дисков. Счетчик производительности Avg. Disk sec/Read показывает среднее время считывания данных с диска в секундах. Среднее значение счетчика производительности Avg. Disk sec/Read не должно превышать 10 миллисекунд. Максимальное значение счетчика производительности Avg. Disk sec/Read не должно превышать 50 миллисекунд.

По умолчанию анализатор сервера Exchange извлекает выборку каждые 30 секунд в течение двух часов. Анализатор сервера Exchange сообщает максимальное значение счетчика производительности, достигаемое в течение интервала сбора данных. Кроме того, анализатор сервера Exchange сообщает значение, находящееся на позиции девяносто процентов в списке всех собранных значений.

Примечание.
Если расположить в возрастающем порядке все значения, собранные анализатором сервера Exchange, таким показателем будет значение, находящееся на позиции девяноста процентов в данном списке. Это значение отражает высокие показания счетчика в течение интервала сбора данных.

В некоторых случаях максимальное значение является пиковым в данном интервале. Поэтому максимальное не является репрезентативным для всего интервала. Значение медианы не всегда верно отражает загрузку, поскольку это значение включает время бездействия в течение интервала сбора данных. Таким образом, анализатор сервера Exchange сообщает максимальное значение и значение, расположенное на позиции девяноста процентов.

Данные в этом базовом сообщении предназначены только для чтения. В отношении них не требуется выполнять никаких действий.

Дополнительные сведения об оптимизации системы хранения для Exchange Server 2003 см. в материале Optimizing Storage for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=49324) (Оптимизация хранилищ для Exchange Server 2003).

Дополнительные сведения о рекомендуемых пороговых значениях счетчиков производительности см. в материале Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588)(Устранение неполадок в производительности Exchange Server 2003).


Данные о производительности от счетчика «Average Disk sec/Read» объекта производительности «PhysicalDisk»
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Avg. Disk sec/Read объекта производительности PhysicalDisk для анализа данных о производительности. Если анализатор сервера Exchange собирает данные от счетчика производительности Avg. Disk sec/Read, анализатор сервера Exchange отображает сведения о собранных данных в качестве базовых сведений.

Счетчик производительности Avg. Disk sec/Read указывает среднее время считывания данных с диска в секундах. Среднее значение счетчика производительности Avg. Disk sec/Read не должно превышать 10 миллисекунд. Максимальное значение счетчика производительности Avg. Disk sec/Read не должно превышать 50 миллисекунд.

Если ведется сбор результатов от счетчиков Disk Reads/sec и Disk Writes/sec, это позволяет выявить, увеличивается ли или уменьшается со временем объем данных ввода-вывода, генерируемых сервером Exchange. Если ведется сбор результатов от счетчиков Avg. Disk sec/Read и Avg. Disk sec/Write, это позволяет выявить, изменился ли период задержки хранилища. Например, следующие шаги помогут выявить, что пропускная способность хранилища является узким местом или станет таковым:

  1. Проводите измерения ежемесячно, рекомендуется выполнять их в один и тот же день и в одно и то же время.

  2. Анализируйте собранные данные.

По умолчанию анализатор сервера Exchange извлекает выборку каждые 30 секунд в течение двух часов. Анализатор сервера Exchange сообщает максимальное значение счетчика производительности, достигаемое в течение интервала сбора данных. Кроме того, анализатор сервера Exchange сообщает значение, находящееся на позиции девяносто процентов в списке всех собранных значений.

Примечание.
Если расположить в возрастающем порядке все значения, собранные анализатором сервера Exchange, девяностопроцентным будет значение, находящееся на позиции девяноста процентов в данном списке. Это значение отражает высокие показания счетчика в течение интервала сбора данных.

В некоторых случаях максимальное значение является пиковым в данном интервале. Поэтому максимальное не является репрезентативным для всего интервала. Значение медианы не всегда верно отражает загрузку, поскольку это значение включает время бездействия в течение интервала сбора данных. Таким образом, анализатор сервера Exchange сообщает максимальное значение и значение, расположенное на позиции девяноста процентов.

Данные в этом базовом сообщении предназначены только для чтения. В отношении них не требуется выполнять никаких действий.

Дополнительные сведения о рекомендуемых пороговых значениях счетчиков производительности см. в материале Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588)(Устранение неполадок в производительности Exchange Server 2003).


Данные о производительности от счетчика Average Disk sec/Write объекта производительности LogicalDisk
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Avg. Disk sec/Write объекта производительности LogicalDisk для анализа данных о производительности. Если анализатор сервера Exchange собирает данные счетчика производительности Avg. Disk sec/Write, анализатор отобразит сведения о собранных данных в качестве базовых сведений.

Объект производительности Logical Disk состоит из таких счетчиков, как Avg. Disk sec/Write, которые ведут наблюдение за логическими разделами жестких дисков. Счетчик производительности Avg. Disk sec/Write показывает выраженное в секундах среднее время записи данных на диск. Среднее значение счетчика производительности Avg. Disk sec/Write не должно превышать 10 миллисекунд. Максимальное значение счетчика производительности Avg. Disk sec/Write не должно превышать 50 миллисекунд.

По умолчанию анализатор сервера Exchange получает сведения каждые 30 секунд в течение двух часов. Анализатор сервера Exchange сообщает максимальное значение счетчика производительности, достигаемое в течение интервала сбора данных. Кроме того, анализатор сервера Exchange сообщает значение, находящееся на позиции девяносто процентов в списке всех собранных значений.

Примечание.
Если расположить в возрастающем порядке все значения, собранные анализатором сервера Exchange, девяностопроцентным будет значение, находящееся на позиции девяноста процентов в данном списке. Это значение отражает высокие показания счетчика в течение интервала сбора данных.

В некоторых случаях максимальное значение является пиковым в данном интервале. Поэтому максимальное значение не является репрезентативным для всего интервала. Значение медианы не всегда верно отражает загрузку, поскольку это значение включает время бездействия в течение интервала сбора данных. Таким образом, анализатор сервера Exchange сообщает максимальное значение и значение, расположенное на позиции девяноста процентов.

Данные в этом базовом сообщении предназначены только для сведений. Никаких специальных действий выполнять не требуется.

Дополнительные сведения об оптимизации системы хранения для Exchange Server 2003 см. на веб-узле, посвященном оптимизации хранилища для Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=34649).

Дополнительные сведения о рекомендуемых пороговых значениях счетчиков производительности см. в материале, посвященном устранению неполадок, связанных с производительностью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).


Данные о производительности для счетчика среднего времени записи на диск
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные со счетчика производительности Avg. Disk sec/Write объекта производительности Physical Disk для анализа данных о производительности. Если анализатор сервера Exchange собирает данные со счетчика производительности Avg. Disk sec/Write, анализатор сервера Exchange отображает сведения о собранных данных в качестве базовых сведений.

Счетчик производительности Avg. Disk sec/Write показывает выраженное в секундах среднее время записи данных на диск. Среднее значение счетчика производительности Avg. Disk sec/Write не должно превышать 10 миллисекунд. Максимальное значение счетчика производительности Avg. Disk sec/Write не должно превышать 50 миллисекунд.

По умолчанию анализатор сервера Exchange извлекает выборку каждые 30 секунд в течение двух часов. Анализатор сервера Exchange сообщает максимальное значение счетчика производительности, достигаемое в течение интервала сбора данных. Кроме того, анализатор сервера Exchange сообщает значение девяностого персентиля, вычисленного по всем собранным значениям.

Примечание.
Если расположить в возрастающем порядке все значения, собранные анализатором сервера Exchange, таким показателем будет значение, находящееся на позиции, соответствующей девяноста процентов элементов в данном списке. Это значение отражает наиболее высокие показания счетчика в течение интервала сбора данных.

В некоторых случаях максимальное значение является пиковым в данном интервале. Поэтому максимальное значение не является репрезентативным для всего интервала. Значение медианы не всегда верно отражает загрузку, поскольку это значение включает время бездействия в течение интервала сбора данных. Поэтому анализатор сервера Exchange сообщает максимальное значение и значение, расположенное на позиции девяноста процентов.

Данные в этом базовом сообщении носят исключительно информационный характер. Никаких действий предпринимать не требуется.

Дополнительные сведения о рекомендуемых пороговых значениях счетчиков производительности см. в статье об устранении неполадок, связанных с производительностью сервера Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Данные производительности от счетчика «Epoxy Client Out Queue Length (DSAccess)»
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Client Out Queue Length (DSAccess) объекта производительности Epoxy для анализа данных о производительности. Если анализатор сервера Exchange собирает данные от счетчика производительности Client Out Queue Length (DSAccess) , анализатор сервера Exchange отображает сведения о собранных данных в качестве базовых сведений.

Счетчик производительности Client Out Queue Length (DSAccess) указывает число сообщений в очереди, которая содержит сообщения DSAccess (Directory Service Access), отправленные процессом Inetinfo.exe. Длина этих очередей в любом случае не должна превышать 10.

По умолчанию анализатор сервера Exchange извлекает выборку каждые 30 секунд в течение двух часов. Затем анализатор сервера Exchange сообщает максимальное значение счетчика производительности, достигаемое в течение интервала сбора данных. Кроме того, анализатор сервера Exchange сообщает значение, находящееся на позиции девяносто процентов в списке всех собранных значений.

Примечание.
Если расположить в возрастающем порядке все значения, собранные анализатором сервера Exchange, девяностопроцентным будет значение, находящееся на позиции девяноста процентов в данном списке. Это значение отражает высокие показания счетчика в течение интервала сбора данных.

В некоторых случаях максимальное значение является пиковым в данном интервале. Поэтому максимальное не является репрезентативным для всего интервала. Значение медианы не всегда верно отражает загрузку, поскольку это значение включает время бездействия в течение интервала сбора данных. Таким образом, анализатор сервера Exchange сообщает максимальное значение и значение, расположенное на позиции девяноста процентов.

Данные в этом базовом сообщении предназначены только для чтения. В отношении них не требуется выполнять никаких действий.

Дополнительные сведения о рекомендуемых пороговых значениях счетчиков производительности см. в материале Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588)(Устранение неполадок в производительности Exchange Server 2003).


Данные производительности от счетчика «Epoxy Client Out Queue Length (SMTP)»
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Client Out Queue Length (SMTP) объекта производительности Epoxy для анализа данных о производительности. Если анализатор сервера Exchange собирает данные от счетчика производительности Client Out Queue Length (SMTP), анализатор сервера Exchange отображает сведения о собранных данных в качестве базовых сведений.

Счетчик производительности Client Out Queue Length (SMTP) указывает число сообщений в очереди, содержащей сообщения SMTP, отправленные процессом Inetinfo.exe. The queues should be under 50 at all times unless there is a mail queue.

По умолчанию анализатор сервера Exchange извлекает выборку каждые 30 секунд в течение двух часов. Анализатор сервера Exchange сообщает максимальное значение счетчика производительности, достигаемое в течение интервала сбора данных. Кроме того, анализатор сервера Exchange сообщает значение, находящееся на позиции девяносто процентов в списке всех собранных значений.

Примечание.
Если расположить в возрастающем порядке все значения, собранные анализатором сервера Exchange, девяностопроцентным будет значение, находящееся на позиции девяноста процентов в данном списке. Это значение отражает высокие показания счетчика в течение интервала сбора данных.

В некоторых случаях максимальное значение является пиковым в данном интервале. Поэтому максимальное не является репрезентативным для всего интервала. Значение медианы не всегда верно отражает загрузку, поскольку это значение включает время бездействия в течение интервала сбора данных. Таким образом, анализатор сервера Exchange сообщает максимальное значение и значение, расположенное на позиции девяноста процентов.

Данные в этом базовом сообщении предназначены только для чтения. В отношении них не требуется выполнять никаких действий.

Дополнительные сведения о рекомендуемых пороговых значениях счетчиков производительности см. в материале Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588)(Устранение неполадок в производительности Exchange Server 2003).


Данные производительности от счетчика «Epoxy Store Out Queue Length» (DSAccess)
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности ведет сбор данных от счетчика производительности Store Out Queue Length объекта производительности Epoxy для анализа данных о производительности. Если анализатор сервера Exchange собирает данные от счетчика производительности Store Out Queue Length (DSAccess), сведения о собранных данных отображаются в виде базовых сведений.

Счетчик производительности Store Out Queue Length (DSAccess) указывает число сообщений в очереди, которая содержит сообщения DSAccess (Directory Service Access), отправленные процессом Store.exe. Длина этих очередей в любом случае не должна превышать 10.

По умолчанию анализатор сервера Exchange извлекает выборку каждые 30 секунд в течение двух часов. Анализатор сервера Exchange сообщает максимальное значение счетчика производительности, достигаемое в течение интервала сбора данных. Кроме того, анализатор сервера Exchange сообщает значение, находящееся на позиции девяносто процентов в списке всех собранных значений.

Примечание.
Если расположить в возрастающем порядке все значения, собранные анализатором сервера Exchange, таким показателем будет значение, находящееся на позиции девяноста процентов в данном списке. Это значение отражает высокие показания счетчика в течение интервала сбора данных.

В некоторых случаях максимальное значение является пиковым в данном интервале. Поэтому максимальное значение не является репрезентативным для всего интервала. Значение медианы не всегда верно отражает загрузку, поскольку это значение включает время бездействия в течение интервала сбора данных. Таким образом, анализатор сервера Exchange сообщает максимальное значение и значение, расположенное на позиции девяноста процентов.

Данные в этом базовом сообщении предназначены только для чтения. В отношении них не требуется выполнять никаких действий.

Дополнительные сведения о рекомендуемых пороговых значениях счетчиков производительности см. в документе Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588)(Устранение неполадок в производительности Exchange Server 2003).


Данные о быстродействии от счетчика «Epoxy Store Out Queue Length (SMTP)»
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о быстродействии, используемый для опроса объектов счетчиков производительности на компьютерах, работающих под управлением Exchange 2000 Server или Exchange Server 2003. Этот модуль собирает данные от счетчика производительности Store Out Queue Length объекта производительности Epoxy для анализа данных о быстродействии. Если анализатор сервера Exchange собирает данные от счетчика производительности Store Out Queue Length (SMTP), анализатор сервера Exchange отображает сведения о собранных данных в качестве базовых сведений.

Счетчик производительности Store Out Queue Length (SMTP) показывает число сообщений в очереди, содержащей SMTP-сообщения, отправленные процессом Store.exe. Число сообщений в очереди не должно превышать 50, если это не очередь почтовых сообщений.

По умолчанию анализатор сервера Exchange извлекает выборку каждые 30 секунд в течение двух часов. Анализатор сервера Exchange сообщает максимальное значение счетчика производительности, достигаемое в течение интервала сбора данных. Кроме того, анализатор сервера Exchange сообщает значение, представляющее собой девяностую процентиль всех собранных значений.

Примечание.
Если расположить в возрастающем порядке все значения, собранные анализатором сервера Exchange, таким показателем будет значение, находящееся на позиции девяноста процентов в данном списке. Это значение отражает высокие показания счетчика в течение интервала сбора данных.

В некоторых случаях максимальное значение является пиковым в данном интервале. Поэтому максимальное значение не является показательным для всего интервала. Медианное значение не всегда верно отражает загрузку, поскольку это значение включает время бездействия в течение интервала сбора данных. Таким образом, анализатор сервера Exchange сообщает максимальное значение и значение, расположенное на позиции девяноста процентов.

Сведения в этом базовом сообщении носят исключительно информативный характер. Никаких действий выполнять не требуется.

Для получения дополнительных сведений о рекомендуемых пороговых значениях счетчиков производительности см. руководство по устранению неполадок, связанных с быстродействием Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Данные счетчика производительности средней задержки удаленного вызова процедур (RPC)
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство Microsoft® Exchange Server Analyzer Tool включает механизм сбора данных о производительности, который используется для опроса объектов счетчика производительности на компьютерах под управлением Exchange 2000 Server или Exchange Server 2003. Механизм сбора данных производительности собирает данные счетчика производительности RPC Averaged Latency объекта MSExchangeIS для анализа этих данных. Если средство анализа Exchange Server собирает какие-либо данные счетчика производительности RPC Averaged Latency, средство анализа Exchange Server отображает сведения о собранных данных в качестве базовой информации.

Счетчик производительности RPC Averaged Latency показывает среднюю задержку удаленного вызова процедур (RPC) в миллисекундах для последних 1024 пакетов. Максимальное значение счетчика быстродействия RPC Averaged Latency должно всегда быть меньше 50 миллисекунд.

По умолчанию сроедство анализа сервера Exchange получает отсчет каждые 30 секунд в течение двухчасового периода. Средство анализа Exchange Server сообщает максимальное значение счетчика производительности в течение периода сбора данных. Средство анализа Exchange Server также сообщает значение девяностого перцентиля всех собранных значений.

Примечание.
Если расположить все собранные средством Exchange Server Analyzer значения в возрастающем порядке, девяностым перцентилем будет значение, номер которого равен 90% от длины списка. Значение девяностого перцентиля означает высокие значения счетчика в течение периода сбора данных.

В некоторых случаях максимальным значением будет являться значение, находящееся в самой верхней точке интервала. Поэтому максимальное значение не является типичным для всего интервала. Значение медианы не всегда точно отражает загрузку, так как в значение медианы входит время ожидания в течение периода сбора данных. Поэтому средство анализа Exchange Server сообщает максимальное значение и значение девяностого перцентиля.

Информация в этом базовом сообщении предназначена только для справочных целей. Никаких действий выполнять не требуется.

Для получения дополнительных сведений о рекомендуемых пороговых значениях счетчиков производительности см. веб-узел Устранение неполадок производительности Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Данные о производительности, предоставляемые счетчиком количества RPC операций в секунду
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

В составе средства анализа Microsoft® Exchange Server имеется механизм сбора данных о производительности, который опрашивает счетчики производительности компьютеров, где установлен Exchange 2000 Server или Exchange Server 2003. Механизм собирает данные со счетчика RPC Operations/sec объекта производительности MSExchangeIS для анализа данных производительности. Если средство анализа Exchange Server получает какие-либо данные со счетчика производительности RPC Operations/sec, оно отображает информацию о собранных данных в качестве базовой.

Счетчик производительности RPC Operations/sec показывает скорость совершения операций удаленного вызова процедур (RPC). Счетчик производительности RPC Operations/sec — неплохой счетчик скорости, позволяющий измерить нагрузку на сервер Exchange, поскольку все операции MAPI используют протокол RPC.

По умолчанию средство анализа Exchange Server получает отсчет каждые 30 секунд в течение двух часов. Средство анализа Exchange Server сообщает максимальные показания счетчика производительности, полученные в период сбора данных. Кроме того, средство анализа Exchange Server сообщает значение, являющееся девяностой перцентилью всех собранных значений.

Примечание.
Если разместить в порядке возрастания все значения, собранные средством анализа Exchange Server, то девяностая перцентиль — это значение, номер которого в списке равен девяноста процентам длины списка. Девяностая перцентиль показывает высокие показания счетчика в период сбора данных.

В некоторых случаях максимальное значение оказывается точкой максимума интервала. В таком случае максимальное значение не репрезентативно. Значение медианы не всегда точно отображает нагрузку, поскольку при вычислении медианы учитывается время простоя, вошедшее в период сбора данных. Поэтому средство анализа Exchange Server показывает максимальное значение и девяностую перцентиль.

Информация в данном базовом сообщении приводится только для сведения. Никаких специальных действий выполнять не требуется.

Для получения дополнительных сведений о пороговых значениях счетчиков производительности см. статью Устранение неполадок в работе Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Данные производительности из счетчика RPC-запросов
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности RPC Requests объекта производительности MSExchangeIS для анализа данных о производительности. Если анализатор сервера Exchange собирает данные счетчика производительности RPC Requests, анализатор отобразит сведения о собранных данных в качестве базовых сведений.

Счетчик производительности RPC Requests отображает количество запросов удаленного вызова процедур (RPC) MAPI или клиентских запросов, обрабатываемых службой «Банк данных Microsoft Exchange». Среднее значение счетчика производительности RPC Requests всегда должно быть ниже 30. По умолчанию для RPC-запросов задано максимальное значение 100. Таким образом, если данная настройка не изменена, служба «Банк данных Microsoft Exchange» может одновременно обрабатывать не более 100 RPC-запросов. Если это значение превышено, дополнительные запросы отклоняются.

По умолчанию анализатор сервера Exchange получает сведения каждые 30 секунд в течение двух часов. Анализатор сервера Exchange сообщает максимальное значение счетчика производительности, достигаемое в течение интервала сбора данных. Анализатор также сообщает значение девяностого процентиля всех собранных данных.

Примечание.
Если отобразить все собранные анализатором значения в восходящем порядке, девяностый процентиль будет находиться на месте девяностого процента в списке. Значение девяностого процентиля указывает высокие значения этого счетчика во время периода сбора данных.

В некоторых случаях максимальное значение будет пиковым значением во время периода сбора данных. Поэтому максимальное значение не может служить образцом всего периода сбора данных. Значение медианы не всегда точно определяет нагрузку, так как в него включено и время простоя в период сбора данных. Поэтому анализатор сервера Exchange сообщает максимальное значение и значение девяностого процентиля.

Сведения в этом базовом сообщении предоставляются только в информационных целях. Никаких специальных действий выполнять не требуется.

Дополнительные сведения о рекомендуемых порогах счетчиков производительности см. на веб-узле, посвященном устранению неполадок, связанных с производительностью сервера Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).


Данные о производительности из счетчика длины очереди классификатора SMTP
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Categorizer Queue Length объекта производительности SMTP Server для анализа данных о производительности. Анализатор сервера Exchange сообщает об общем количестве сообщений, найденных в очереди классификатора.

Счетчик SMTP Server\Categorizer Queue Length показывает количество сообщений в очереди классификатора SMTP (Simple Mail Transfer Protocol), ожидающих поиска атрибутов службы каталогов с использованием серверов глобального каталога. Согласно общей рекомендации максимальное значение должно быть меньше 10.

По умолчанию анализатор сервера Exchange извлекает выборку каждые 30 секунд в течение двух часов. Анализатор сервера Exchange сообщает максимальное значение счетчика производительности, достигаемое в течение интервала сбора данных. Кроме того, анализатор сервера Exchange сообщает значение, находящееся на позиции девяносто процентов в списке всех собранных значений.

Примечание.
Если расположить в возрастающем порядке все значения, собранные анализатором сервера Exchange, таким показателем будет значение, находящееся на позиции девяноста процентов в данном списке. Это значение отражает высокие показания счетчика в течение интервала сбора данных.

В некоторых случаях максимальное значение является пиковым в данном интервале. Поэтому максимальное значение не является репрезентативным для всего интервала. Значение медианы не всегда верно отражает загрузку, поскольку это значение включает время бездействия в течение интервала сбора данных. Таким образом, анализатор сервера Exchange сообщает максимальное значение и значение, расположенное на позиции девяноста процентов.

Счетчик Categorizer Queue Length показывает количество сообщений в очереди классификатора сообщений. Классификатор выполняет следующие основные операции:

  • Он разрешает и проверяет достоверность всех получателей.

  • Он определяет пределы и ограничения для всех получателей.

  • При необходимости он расширяет списки рассылки.

  • Он определяет, предназначено ли сообщение для локальной или удаленной доставки

Увеличение показаний счетчика Categorizer Queue Length указывает на возможность проблем с производительностью сервера, DSAccess (Directory Service Access), службой каталогов Active Directory® или на простои основных серверов в организации сервера Exchange. Увеличение показаний счетчика Categorizer Queue Length будет указывать на медленную реакцию или отсутствие ответа при обращении к службе Active Directory либо при передаче сообщений для локальной доставки или в очередь SMTP.

Данные в этом базовом сообщении предназначены только для чтения. В отношении них не требуется выполнять никаких действий.

Дополнительные сведения о рекомендуемых пороговых значениях счетчиков производительности см. в материале Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588)(Устранение неполадок в производительности Exchange Server 2003).


Данные производительности из счетчика «Длина локальной очереди SMTP»
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Local Queue Length объекта производительности SMTP Server для анализа данных о производительности. Средство анализатора сервера Exchange сообщает об общем количестве сообщений в локальной очереди SMTP.

Счетчик SMTP Server\Local Queue Length указывает количество сообщений в очереди SMTP для локальной доставки. Общая рекомендация такова: максимальное значение должно быть меньше 1,000. Изменения размера очереди должны быть незначительными, а размер не должен сильно отличаться от среднего значения.

По умолчанию анализатор сервера Exchange извлекает образец каждые 30 секунд в течение 2 часов. Затем анализатор сервера Exchange сообщает максимальное значение счетчика производительности, достигаемое в течение интервала сбора данных. Средство анализатора сервера Exchange также сообщает значение, которое находится в девяностом процентиле от всех собранных значений.

Примечание.
Если все значения, собранные анализатором сервера Exchange, указываются в списке в исходящем порядке, девяностый процентиль — это значение, которое находится в позиции, отделяющей 90% списка Значения девяностого процентиля указывает на высокие значения счетчика во время интервала сбора.

В некоторых экземплярах максимальное значение будет находиться в точке наивысшей загрузки интервала. Поэтому максимальное значение не дает представления об интервале в целом. Значение медианы не всегда точно указывает уровень загрузки, так как значение медианы включает время ожидания во время интервала сбора. Поэтому анализатор сервера Exchange сообщает о максимальном значении и значении девяностого процентиля.

Увеличение количества сообщений в очереди локальной доставки указывает на проблемы с производительностью или перебои на сервере, так как сервер больше не может доставлять входящую почту вовремя. Эта задержка может объясняться следующими причинами:

  • Служба каталогов Active Directory® не получает запросы немедленно.

  • Сообщения не передаются немедленно для локальной доставки или SMTP.

  • Базы данных отключены.

Сведения в этом основном сообщении предназначены только для информационных целей. Никаких действий выполнять не требуется.

Дополнительные сведения о рекомеднуемых пороговых значениях счетчиков производительности см. в разделе Устранение неполадок, связанных с производительностью Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Данные счетчика производительности длины удаленной очереди SMTP
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа сервера Microsoft® Exchange включает механизм сбора данных о производительности, который используется, чтобы опрашивать объекты счетчиков производительности на компьютерах, работающих с Exchange 2000 Server или Exchange Server 2003. Механизм сбора данных о быстродействии собирает данные счетчиков производительности Remote Queue Length объектов производительности SMTP Server для анализа данных о производительности. Средство анализа сервера Exchange сообщает общее количество сообщений в удаленной очереди SMTP.

Счетчик SMTP Server\Remote Queue Length указывает количество сообщений в очереди SMTP для удаленной доставки. В общем случае рекомендуется, чтобы максимальное значение не превышало 1000. Среднее значение очереди должно изменяться незначительно.

По умолчанию сроедство анализа сервера Exchange получает отсчет каждые 30 секунд в течение двухчасового периода. Средство Exchange Server Analyzer сообщает максимальное значение счетчика производительности в течение периода сбора данных. Средство Exchange Server Analyzer также сообщает значение, являющееся девяностым перцентилем для всех собранных значений.

Примечание.
Если расположить все собранные средством Exchange Server Analyzer значения в возрастающем порядке, девяностым перцентилем будет значение, имеющее номер в 90% от длины списка. Значение девяностого перцентиля означает высокие значения счетчика в течение периода сбора данных.

В некоторых случаях максимальным значением будет являться значение, находящееся в самой верхней точке интервала. Поэтому максимальное значение не является типичным для всего интервала. Значение медианы не всегда точно отражает загрузку, так как в это значение медианы входит время ожидания в течение периода сбора данных. Поэтому средство Exchange Server Analyzer сообщает максимальное значение и значение девяностого перцентиля.

Рост длины удаленной очереди означает, что почта не отправляется на другие серверы. Невозможность отправить сообщения может объясняться перебоями или проблемами с производительностью сети или удаленных серверов. Перебои или проблемы с производительностью мешают сети или удаленным серверам эффективно получать почту.

Информация в этом основном сообщении предназначена только для справочных целей. Никаких действий выполнять не требуется.

Для получения дополнительных сведения о рекомендуемых пороговых значениях счетчиков производительности см. веб-узел Устранение неполадок производительности Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Сведения о быстродействии из счетчика «Длина очереди средства поиска вирусов»
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о быстродействии, используемый для опроса объектов счетчиков производительности на компьютерах, работающих под управлением Exchange 2000 Server или Exchange Server 2003. Этот модуль собирает данные от счетчика производительности Virus Scan Queue Length объекта производительности MSExchangeIS для анализа данных о быстродействии. Если анализатор сервера Exchange получает какие-либо данные от счетчика производительности Virus Scan Queue Length, сведения о собранных данных отображаются в анализаторе сервера Exchange как базовая информация.

Счетчик производительности Virus Scan Queue Length показывает текущее число подозрительных запросов, поставленных в очередь с целью проверки на вирусы. Рекомендованное значение этого счетчика зависит от конкретной организации.

По умолчанию анализатор сервера Exchange извлекает образец каждые 30 секунд в течение двухчасового периода. Анализатор сервера Exchange сообщает максимальное значение счетчика производительности за интервал сбора данных. Кроме того, анализатор сервера Exchange сообщает значение, являющееся девяностой процентилью всех собранных значений.

Примечание.
Если расположить по возрастанию все значения, собранные анализатором сервера Exchange, девяностая процентиль — значение, положение которого в списке соответствует 90 процентам. Значение девяностой процентили указывает высокие значения счетчика в интервале сбора данных.

В некоторых случаях максимальное значение является пиковым в данном интервале. Поэтому максимальное значение не является показательным для всего интервала. Медианное значение не всегда верно отражает загрузку, поскольку это значение включает время бездействия в течение интервала сбора данных. Таким образом, анализатор сервера Exchange сообщает максимальное значение и значение, расположенное на позиции девяноста процентов.

Сведения в этом базовом сообщении носят исключительно информативный характер. Никаких действий выполнять не требуется.

Для получения дополнительных сведений о рекомендуемых пороговых значениях счетчиков производительности см. руководство по устранению неполадок, связанных с быстродействием Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Данные производительности для счетчика Log Record Stalls/sec
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Log Record Stalls/sec объекта производительности Database для анализа данных о производительности. Если анализатор сервера Exchange собирает данные счетчика производительности Log Record Stalls/sec, анализатор отобразит сведения о собранных данных в качестве базовых сведений.

Счетчик производительности Log Record Stalls/sec отображает число записей журнала, которые не удалось добавить в буферы журнала за одну секунду из-за того, что буферы заполнены. Среднее значение счетчика производительности Log Record Stalls/sec должно быть ниже 10 в секунду. Максимальное значение не должно превышать 100 в секунду.

По умолчанию анализатор сервера Exchange получает сведения каждые 30 секунд в течение двух часов. Анализатор сервера Exchange сообщает максимальное значение счетчика производительности, достигаемое в течение интервала сбора данных. Анализатор также сообщает значение девяностого процентиля всех собранных данных.

Примечание.
Если отобразить все собранные анализатором значения в восходящем порядке, девяностый процентиль будет находиться на месте девяностого процента в списке. Значение девяностого процентиля указывает высокие значения этого счетчика во время периода сбора данных.

В некоторых случаях максимальное значение будет пиковым значением во время периода сбора данных. Поэтому максимальное значение не может служить образцом всего периода сбора данных. Значение медианы не всегда точно определяет нагрузку, так как в него включено и время простоя в период сбора данных. Поэтому анализатор сервера Exchange сообщает максимальное значение и значение девяностого процентиля.

Сведения в этом базовом сообщении предоставляются только для сведений. Никаких специальных действий выполнять не требуется.

Дополнительные сведения о предложенных порогах счетчиков производительности см. на веб-узле, посвященном устранению неполадок, связанных с производительностью сервера Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).


Данные производительности для счетчика «Log Threads Waiting»
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Log Threads Waiting объекта производительности Database для анализа данных о производительности. Если анализатор сервера Exchange собирает данные от счетчика производительности Log Threads Waiting, анализатор сервера Exchange отображает сведения о собранных данных в качестве базовых сведений.

Счетчик производительности Log Threads Waiting показывает количество потоков, ожидающих выполнения обновления базы данных путем записи их данных в журнал. Если значение счетчика производительности Log Threads Waiting слишком высоко, журнал может стать узким местом для других операций.

По умолчанию анализатор сервера Exchange извлекает выборку каждые 30 секунд в течение двух часов. Анализатор сервера Exchange сообщает максимальное значение счетчика производительности, достигаемое в течение интервала сбора данных. Кроме того, анализатор сервера Exchange сообщает значение, находящееся на позиции девяносто процентов в списке всех собранных значений.

Примечание.
Если расположить в возрастающем порядке все значения, собранные анализатором сервера Exchange, девяностопроцентным будет значение, находящееся на позиции девяноста процентов в данном списке. Это значение отражает высокие показания счетчика в течение интервала сбора данных.

В некоторых случаях максимальное значение является пиковым в данном интервале. Поэтому максимальное значение не является репрезентативным для всего интервала. Значение медианы не всегда верно отражает загрузку, поскольку это значение включает время бездействия в течение интервала сбора данных. Таким образом, анализатор сервера Exchange сообщает максимальное значение и значение, расположенное на позиции девяноста процентов.

Данные в этом базовом сообщении предназначены только для сведения. В отношении них не требуется выполнять никаких действий.

Дополнительные сведения о рекомендуемых пороговых значениях счетчиков производительности см. в материале Устранение неполадок производительности Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=47588 (возможно, на английском языке).


Данные производительности для счетчика Pages/sec
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Pages/sec объекта производительности Memory для анализа данных о производительности. Если анализатор сервера Exchange собирает данные счетчика производительности Pages/sec, анализатор отобразит сведения о собранных данных в качестве базовых сведений.

Счетчик производительности Pages/sec указывает скорость чтения и записи страниц на диск для разрешения серьезных сбоев страниц. Этот счетчик является основным указателем типов сбоев, которые приводят к задержкам во всей системе. Он показывает количество полученных страниц для компенсации сбоев страниц в кэше файловой системы. Эти страницы обычно требуются приложениями. Значение этого счетчика не должно превышать 1000 в любое время.

По умолчанию анализатор сервера Exchange получает сведения каждые 30 секунд в течение двух часов. Анализатор сервера Exchange сообщает максимальное значение счетчика производительности, достигаемое в течение интервала сбора данных. Кроме того, анализатор сервера Exchange сообщает значение, находящееся на позиции девяносто процентов в списке всех собранных значений.

Примечание.
Если расположить в возрастающем порядке все значения, собранные анализатором сервера Exchange, таким показателем будет значение, находящееся на позиции девяноста процентов в данном списке. Это значение отражает высокие показания счетчика в течение интервала сбора данных.

В некоторых случаях максимальное значение является пиковым в данном интервале. Поэтому максимальное значение не является репрезентативным для всего интервала. Значение медианы не всегда верно отражает загрузку, поскольку это значение включает время бездействия в течение интервала сбора данных. Таким образом, анализатор сервера Exchange сообщает максимальное значение и значение, расположенное на позиции девяноста процентов.

Данные в этом базовом сообщении предназначены только для чтения. Никаких специальных действий выполнять не требуется.

Дополнительные сведения о предложенных порогах счетчиков производительности см. на веб-узле, посвященном устранению неполадок, связанных с производительностью сервера Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).


Данные производительности для счетчика «% процессорного времени»
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Для анализа данных о производительности модуль сбора данных о производительности собирает данные из счетчика производительности % Processor Time объекта производительности Processor. Если анализатор сервера Exchange собирает данные счетчика производительности % Processor Time, анализатор отобразит сведения о собранных данных в качестве базовых сведений.

Счетчик производительности % Processor Time показывает процент времени, в течение которого процессор выполняет активные потоки. Этот счетчик можно использовать для мониторинга суммарного использования процессоров либо для мониторинга использования каждого из процессоров. Среднее использование процессора должно быть все время не выше 90 процентов.

Примечание.
Значение % Processor Time, выводимое анализатором сервера Exchange, является общим значением, основанным на суммарном количестве обнаруженных процессоров, физических и логических, и разделенным на сумму количества процессоров.

По умолчанию анализатор сервера Exchange получает сведения каждые 30 секунд в течение двух часов. Анализатор сервера Exchange сообщает максимальное значение счетчика производительности, достигаемое в течение интервала сбора данных. Анализатор сервера Exchange также сообщает значение девяностого процентиля всех собранных данных.

Примечание.
Если отобразить все собранные анализатором значения в восходящем порядке, девяностый процентиль будет находиться на месте девяностого процента в списке. Значение девяностого процентиля указывает высокие значения этого счетчика во время периода сбора данных.

В некоторых случаях максимальное значение будет пиковым значением во время периода сбора данных. Поэтому максимальное значение не является репрезентативным для всего интервала. Значение медианы не всегда точно определяет нагрузку, так как в него включено и время простоя в течение интервала сбора данных. Поэтому анализатор сервера Exchange сообщает максимальное значение и значение девяностого процентиля.

Данные в этом базовом сообщении носят исключительно информационный характер. Никаких действий выполнять не требуется.

Дополнительные сведения о предложенных порогах счетчиков производительности см. на веб-странице, посвященной устранению неполадок, связанных с производительностью сервера Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=47588).


Данные производительности для счетчика Bytes Total/sec
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Bytes Total/sec объекта производительности Network Interface для анализа данных о производительности. Если анализатор сервера Exchange собирает данные счетчика производительности Bytes Total/sec, анализатор отобразит сведения о собранных данных в качестве базовых сведений.

Счетчик производительности Bytes Total/sec показывает уровень обработки данных сетевым адаптером. Этот счетчик содержит данные всех приложений и файлов и сведения о протоколах, например, заголовки пакетов. Для сетевых адаптеров, работающих со скоростью 100 мегабитов в секунду (Мбит/с), значение счетчика производительности Bytes Total/sec будет меньше 7 мегабайтов/с. Для сетевых адаптеров, работающих со скоростью 1000 Мбит/с, значение счетчика производительности Bytes Total/sec будет менее 70 мегабайтов/c.

По умолчанию анализатор сервера Exchange получает сведения каждые 30 секунд в течение двух часов. Анализатор сервера Exchange сообщает максимальное значение счетчика производительности, достигаемое в течение интервала сбора данных. Анализатор также сообщает значение девяностого процентиля всех собранных данных.

Примечание.
Если отобразить все собранные анализатором значения в восходящем порядке, девяностый процентиль будет находиться на месте девяностого процента в списке. Значение девяностого процентиля указывает высокие значения этого счетчика во время периода сбора данных.

В некоторых случаях максимальное значение будет пиковым значением во время периода сбора данных. Поэтому максимальное значение не может служить образцом всего периода сбора данных. Значение медианы не всегда точно определяет нагрузку, так как в него включено и время простоя в период сбора данных. Поэтому анализатор сервера Exchange сообщает максимальное значение и значение девяностого процентиля.

Сведения в этом базовом сообщении предоставляются только для сведений. Никаких специальных действий выполнять не требуется.

Дополнительные сведения о предложенных порогах счетчиков производительности см. на веб-узле, посвященном устранению неполадок, связанных с производительностью сервера Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).


Данные о производительности со счетчика производительности LDAP Read Time
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-02-06

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчиков производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности получает данные со счетчика производительности LDAP Read Time объекта производительности MSExchangeDSAccess Process для анализа данных о производительности. Если анализатор сервера Exchange собирает данные со счетчика производительности LDAP Read Time, анализатор сервера Exchange отображает сведения о собранных данных в качестве базовых сведений.

Счетчик производительности LDAP Read Time показывает время в миллисекундах, которое занимает выполнение LDAP-запроса на чтение. Среднее значение не должно превышать 50 мс. Максимальное значение на должно превышать 100 мс.

По умолчанию анализатор сервера Exchange извлекает выборку каждые 30 секунд в течение двух часов. Анализатор сервера Exchange сообщает максимальное значение счетчика производительности, достигаемое в течение интервала сбора данных. Кроме того, анализатор сервера Exchange сообщает значение девяностого персентиля, вычисленного по всем собранным значениям.

Примечание.
Если расположить в возрастающем порядке все значения, собранные анализатором сервера Exchange, таким показателем будет значение, находящееся на позиции, соответствующей девяноста процентов элементов в данном списке. Это значение отражает высокие показания счетчика в течение интервала сбора данных.

В некоторых случаях максимальное значение является пиковым в данном интервале. Поэтому максимальное значение не является репрезентативным для всего интервала. Значение медианы не всегда верно отражает загрузку, поскольку это значение включает время бездействия в течение интервала сбора данных. Поэтому анализатор сервера Exchange сообщает максимальное значение и значение девяностого персентиля.

Данные в этом базовом сообщении носят исключительно информационный характер. Никаких действий предпринимать не требуется.

Дополнительные сведения о рекомендуемых пороговых значениях счетчиков производительности см. в статье об устранении неполадок, связанных с производительностью сервера Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Данные производительности счетчика LDAP Search Time
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности LDAP Search Time объекта производительности MSExchangeDSAccess Processes для анализа данных о производительности. Если анализатор сервера Exchange собирает данные счетчика производительности LDAP Search Time, анализатор отобразит сведения о собранных данных в качестве базовых сведений.

Счетчик производительности LDAP Search Time показывает время в миллисекундах, которое занимает выполнение запроса на поиск LDAP. Среднее значение не должно быть ниже 50 миллисекунд. Максимальное значение не должно превышать 100 миллисекунд.

По умолчанию анализатор сервера Exchange получает сведения каждые 30 секунд в течение двух часов. Анализатор сервера Exchange сообщает максимальное значение счетчика производительности, достигаемое в течение интервала сбора данных. Кроме того, анализатор сервера Exchange сообщает значение, находящееся на позиции девяносто процентов в списке всех собранных значений.

Примечание.
Если расположить в возрастающем порядке все значения, собранные анализатором сервера Exchange, таким показателем будет значение, находящееся на позиции девяноста процентов в данном списке. Это значение отражает высокие показания счетчика в течение интервала сбора данных.

В некоторых случаях максимальное значение является пиковым в данном интервале. Поэтому максимальное значение не является репрезентативным для всего интервала. Значение медианы не всегда верно отражает загрузку, поскольку это значение включает время бездействия в течение интервала сбора данных. Таким образом, анализатор сервера Exchange сообщает максимальное значение и значение, расположенное на позиции девяноста процентов.

Данные в этом базовом сообщении предназначены только для чтения. Никаких специальных действий выполнять не требуется.

Дополнительные сведения о предложенных порогах счетчиков производительности см. на веб-узле, посвященном устранению неполадок, связанных с производительностью сервера Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).


Объект системного монитора PhysicalDisk недоступен
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов о показаниях счетчиков производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности получает данные со счетчика производительности Avg. Disk sec/Read объекта с оцениваемой производительностью PhysicalDisk для анализа данных о производительности. Если со счетчика не удается получить правильные данные, анализатор сервера Exchange выводит базовое сообщение.

Если модулю сбора данных о производительности не удается получить правильные данные, истинна любая комбинация следующих условий:

  • Объект производительности PhysicalDisk отключен.

  • Объект системного монитора PhysicalDisk отсутствует или поврежден.

  • У анализатора сервера Exchange отсутствуют соответствующие разрешения для доступа к объектам производительности.

Первые два условия могут возникнуть, если реестр поврежден определенными расширяемыми счетчиками, или если реестр изменен программами, использующими WMI (Microsoft Windows® Management Instrumentation). В следующих процедурах объясняется, как устранить первые две причины. Перед выполнением процедуры убедитесь, что анализатор сервера Exchange обладает соответствующими разрешениями. Дополнительные сведения о разрешениях, необходимых для выполнения анализатора сервера Exchange, см. в справке анализатора сервера Exchange. Для доступа к справке откройте анализатор сервера Exchange и нажмите клавишу F1.

Чтобы устранить эту ошибку

  1. Убедитесь, что включен объект производительности PhysicalDisk.

    1. Загрузите и установите список расширяемых счетчиков производительности (Exctrlst.exe). Программу Exctrlst.exe можно загрузить с веб-узла Microsoft «Exctrlst.exe: расширяемый список счетчиков производительности» (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Откройте Exctrlst.exe, щелкните Порядок сортировки, а затем щелкните Служба.

    3. Найдите службу, о которой сообщает данный объект производительности, и убедитесь, что флажок Счетчики производительности включены установлен.

      Если флажок Счетчики производительности включены не установлен, установите флажок, а затем перезапустите службу, связанную со счетчиками производительности, чтобы убедиться, что счетчики производительности работают. Если счетчики производительности не работают, или если флажок Счетчики производительности включены уже был установлен, перейдите к шагу 2.

  2. Перестройте отсутствующие или поврежденные счетчики производительности в соответствии с инструкциями в статье 300956 базы знаний Майкрософт, посвященной перестройке значений библиотеки счетчиков производительности вручную, по адресу http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956.

  3. Если после выполнения процедуры, указанной в этой статье базы знаний, проблема не будет устранена, следует переустановить операционную систему Windows в режиме Восстановление, а затем применить последние пакеты обновления Windows.


Конфликт портов:Служба репликации сайта
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server считывает следующие параметры реестра, чтобы установить, нет ли конфликтов портов:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Если средство анализа Exchange Server обнаруживает, что значение HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP совпадает со значением для одного из перечисленных выше шести портов, взятых из реестра, появится сообщение об ошибке. Кроме того, средство анализа Exchange Server также выдаст ошибку для порта, конфликтующего с HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP.

Чтобы исправить эту ошибку, необходимо изменить значение данного параметра реестра или конфликтующего параметра реестра согласно выходным данным средства анализа Exchange Server, так чтобы значения были уникальны.

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Для получения сведений о восстановлении реестра см. разделе «Восстановление реестра» справочной системы файла Regedit.exe или Regedt32.exe.

Установка параметра реестра TCP/IP

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел: HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters

  3. Дважды щелкните раздел TCP/IP и установите в поле Value data уникальное значение, незначительно превышающее 5000 (в десятичной системе).

  4. Закройте редактор реестра.

  5. Перезагрузите компьютер, чтобы этот параметр вступил в силу.

Развертывание удаленного вызова процедур через HTTP

  1. Просмотрите «Руководство по ситуациям использования RPC через HTTP в Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=47577 ).

  2. Прочтите статью 833401 базы знаний корпорации Майкрософт «Настройка удаленного вызова процедур (RPC) для работы по протоколу HTTP при использовании одного сервера в Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  3. Прочтите статью 827330 базы знаний «Устранение неполадок, возникающих в Office Outlook 2003 при использовании подключений RPC по протоколу HTTP» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  4. Прочтите материалы веб-конференции службы поддержки корпорации Майкрософт «Использование Microsoft Exchange через Интернет (RPC/HTTP) в Microsoft Office Outlook 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Перед правкой реестра, а также для получения дополнительных сведений о правке реестра просмотрите статью 256986 базы знаний корпорации Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Для получения дополнительных сведений о статическом сопоставлении портов, используемых Exchange, см. следующие статьи базы знаний:

  • 194952, «XADM: Ограничения статического сопоставления портов для сервера Exchange» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952)

  • 270836, «Статическое сопоставление портов в Exchange 2000 и Exchange 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836).


Конфликт доступа к порту: HTTP-порт хранилища
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-03-21

Чтобы определить существование каких-либо конфликтов доступа к портам, средство анализатора сервера Microsoft® Exchange считывает следующие записи реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Раздел реестра Rpc/HTTP Port используется Exchange для поддержки функций RPC через HTTP в Microsoft Office Outlook® 2003 и мобильного Outlook в Exchange Server 2007. Если анализатор сервера Exchange обнаружит, что значение HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters\Rpc/HTTP Port совпадает с каким-либо из значений параметров реестра для других шести портов, перечисленных выше в этой статье, на экран выводится сообщение об ошибке. Анализатор сервера Exchange выводит на экран также сообщение об ошибке для порта, который конфликтует с HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters\Rpc/HTTP Port.

Чтобы устранить эту ошибку, необходимо изменить значение данного ключа или конфликтующего ключа, указываемого в выходных данных анализатора сервера Exchange, установив для соответствующего ключа уникальное значение.

При поддержке RPC/HTTP в клиентах Outlook 2003 или Outlook 2007 следует установить параметру Rpc/HTTP Port числовое значение 6001. Также следует ознакомиться с применяемой конфигурацией RPC/HTTP.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Установка значения раздела реестра для порта Rpc/HTTP

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters

  3. Дважды щелкните ключ Rpc/HTTP Port и установите в поле Значение уникальное значение, превышающее 5000 (десятичное).

  4. Закройте редактор реестра.

  5. Перезагрузите компьютер, чтобы эта настройка вступила в силу.

Просмотр конфигураций удаленных вызовов процедур через HTTP

  1. Изучите документ о сценариях развертывания удаленных вызовов процедур Exchange Server 2003 через HTTP (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Ознакомьтесь с документом, посвященным развертыванию мобильного Outlook (http://go.microsoft.com/fwlink/?LinkId=80831).

  3. Изучите статью 833401 базы знаний Майкрософт о настройке удаленных вызовов процедур через HTTP на одиночном сервере в Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  4. Изучите статью 827330 базы знаний Майкрософт об устранении в Office Outlook 2003 проблем подключения при передаче удаленных вызовов процедур клиента через HTTP (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  5. Изучите веб-презентацию службы поддержки Майкрософт, посвященную использованию Microsoft Exchange через Интернет (RPC/HTTP) с помощью средств Microsoft Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Конфликт портов:Сохранение TCP
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-30

Средство анализа Microsoft® Exchange Server Analyzer Tool считывает следующие записи реестра, чтобы определить наличие конфликта портов:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Если средство анализа Exchange Server Analyzer обнаруживает, что значение для HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port совпадает с одним из значений, указанных в параметрах реестра других шести портов, перечисленных выше, отображается сообщение об ошибке. Средство анализа Exchange Server Analyzer также отображает сообщение об ошибке для порта, конфликтующего с HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port.

Самая распространенная причина в настройке этого значения - возможность клиентов MAPI подключаться к серверу Exchange, который находится с другой стороны брандмауэра. Этот сценарий включает открытие нескольких портов в брандмауэре, чтобы дать возможность клиентам Microsoft Office Outlook® 2003 или Outlook 2007 подключаться к серверу Exchange, используя MAPI, обычно через Интернет.

Рекомендованное развертывание для использования Outlook в режиме MAPI для подключения к серверу Exchange через Интернет - это использование RPC по протоколу HTTP. Эта возможность существует в Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003, Exchange Server 2007, Outlook 2007 и Microsoft Windows® XP Professional. Режим MAPI ранее назывался «Корпоративным» или режимом «Рабочей группы».

Для решения этой проблемы необходимо изменить это значение или конфликтующее значение, как указано в выводе средства анализа Exchange, на уникальное значение.

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неполадки. Для получения сведений о восстановлении реестра см. раздел справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы задать значение реестра TCP/IP Port

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Пройдите по адресу: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Дважды щелкните раздел TCP/IP Port и введите в поле Значение уникальное значение, превышающее 5000 (десятичное).

  4. Закройте редактор реестра.

  5. Чтобы изменения вступили в силу, перезагрузите компьютер.

Чтобы развернуть RPC поверх HTTP

  1. Ознакомьтесь с материалом «Сценарии развертывания RPC поверх HTTP в Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Ознакомьтесь с документом, посвященным развертыванию мобильного Outlook (http://go.microsoft.com/fwlink/?LinkId=80831).

  3. Ознакомьтесь со статьей 833401 в базе знаний корпорации Майкрософт «Как настроить RPC поверх HTTP на одиночном сервере под управлением Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  4. Ознакомьтесь со статьей 827330 базы знаний Майкрософт "Устранение неполадок, возникающих в Office Outlook 2003 при использовании подключений RPC по протоколу HTTP" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  5. Ознакомьтесь с записью веб-конференции службы поддержки корпорации Майкрософт «Использование Microsoft Exchange через Интернет (RPC/HTTP) с Microsoft Office Outlook 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Перед правкой реестра, а также для получения сведений о правке реестра см. статью 256986 базы знаний Майкрософт, «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о статическом сопоставлении портов, используемых Exchange, см. в статье 270836 базы знаний Майкрософт «Сопоставление статических портов для сервера Exchange Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)


Конфликт доступа к порту: системный помощник HTTP
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-03-21

Чтобы определить существование каких-либо конфликтов доступа к портам, средство анализатора сервера Microsoft® Exchange считывает следующие записи реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Раздел реестра HTTP Port используется Exchange для поддержки функций RPC через HTTP в Microsoft Office Outlook® 2003 и мобильного Outlook в Exchange Server 2007. Если анализатор сервера Exchange обнаружит, что значение HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port совпадает с каким-либо из значений параметров реестра для других шести портов, перечисленных выше в этой статье, на экран выводится сообщение об ошибке. Анализатор сервера Exchange также выводит на экран сообщение об ошибке для порта, который конфликтует с HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port.

Чтобы устранить эту ошибку, необходимо изменить значение данного раздела или конфликтующего раздела, указываемого в выходных данных анализатора сервера Exchange, установив для соответствующего раздела уникальное значение.

При поддержке RPC/HTTP в клиентах Outlook 2003 или Outlook 2007 следует установить параметру HTTP Port числовое значение 6002. Также следует ознакомиться с применяемой конфигурацией RPC/HTTP.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы установить значение раздела реестра для порта HTTP

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Дважды щелкните раздел реестра HTTP Port и установите в поле Значение уникальное значение, превышающее 5000 (десятичное).

  4. Закройте редактор реестра.

  5. Перезагрузите компьютер, чтобы этот параметр вступил в силу.

Чтобы просмотреть конфигурацию удаленного вызова процедур через HTTP

  1. Ознакомьтесь с описанием сценариев развертывания удаленных вызовов процедур Exchange Server 2003 через HTTP (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Ознакомьтесь с документом, посвященным развертыванию мобильного Outlook (http://www.microsoft.com/technet/prodtechnol/exchange/e2k7help/7b2d1ce2-b6df-4604-80fd-2f6cafc47e82.mspx).

  3. Ознакомьтесь в базе знаний Майкрософт со статьей 833401, содержащей инструкции по настройке удаленных вызовов процедур через HTTP на одиночном сервере в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  4. Ознакомьтесь в базе знаний Майкрософт со статьей 827330, содержащей инструкции по устранению в Office Outlook 2003 проблем подключения при передаче удаленных вызовов процедур клиента через HTTP (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  5. Ознакомьтесь с веб-презентацией службы поддержки Майкрософт, посвященной использованию Microsoft Exchange через Интернет (RPC/HTTP) с помощью средств Microsoft Office Outlook 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Конфликт доступа к порту:системный помощник HTTP NSPI
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-30

Чтобы определить существование каких-либо конфликтов доступа к портам, средство анализатора сервера Microsoft® Exchange считывает следующие записи реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Раздел реестра Rpc/HTTP NSPI Port используется Exchange для поддержки функций RPC через HTTP в Microsoft Office Outlook® 2003 и мобильного Outlook в Exchange Server 2007. Если анализатор сервера Exchange обнаружит, что значение HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port совпадает с каким-либо из значений параметров реестра для других шести портов, перечисленных выше в этой статье, на экран выводится сообщение об ошибке. Анализатор сервера Exchange также выводит на экран сообщение об ошибке для порта, который конфликтует с HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\ Rpc/HTTP NSPI Port.

Чтобы устранить эту ошибку, необходимо изменить значение данного раздела или конфликтующего раздела, указываемого в выходных данных анализатора сервера Exchange, установив для соответствующего раздела уникальное значение.

Если имеется поддержка клиентов RPC через HTTP в Outlook 2003 или Outlook 2007, необходимо установить для раздела Rpc/HTTP NSPI Port десятичное значение 6004. Кроме того, следует просмотреть настройки RPC через HTTP в вашей среде.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы установить значение раздела реестра для порта NSPI Rpc/HTTP

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Дважды щелкните раздела Rpc/HTTP NSPI Port и установите в поле Значение уникальное значение, превышающее 5000 (десятичное).

  4. Закройте редактор реестра.

  5. Перезагрузите компьютер, чтобы эта настройка вступила в силу.

Чтобы просмотреть конфигурацию удаленного вызова процедур через HTTP

  1. Ознакомьтесь с описанием сценариев развертывания удаленных вызовов процедур Exchange Server 2003 через HTTP (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Ознакомьтесь с документом, посвященным развертыванию мобильного Outlook (http://go.microsoft.com/fwlink/?LinkId=80831).

  3. Ознакомьтесь в базе знаний Майкрософт со статьей 833401, содержащей инструкции по настройке удаленных вызовов процедур через HTTP на одиночном сервере в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  4. Ознакомьтесь в базе знаний Майкрософт со статьей 827330, содержащей инструкции по устранению в Office Outlook 2003 проблем подключения при передаче удаленных вызовов процедур клиента через HTTP (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  5. Ознакомьтесь с веб-презентацией службы поддержки Майкрософт, посвященной использованию Microsoft Exchange через Интернет (RPC/HTTP) с помощью средств Microsoft Office Outlook 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Конфликт доступа к порту: системный помощник NSPI
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-03-21

Чтобы определить существование каких-либо конфликтов доступа к портам, анализатор сервера Microsoft® Exchange считывает следующие записи реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Если анализатор сервера Exchange обнаруживает, что значение HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port совпадает с каким-либо из значений параметров реестра для других шести портов, перечисленных выше в этой статье, выводится сообщение об ошибке. Анализатор сервера Exchange также выводит сообщение об ошибке для порта, который конфликтует с HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port.

Наиболее распространенная причина настройки этого значения — включение клиентов MAPI для подключения к серверу Exchange, который находится по другую сторону межсетевого экрана. Этот сценарий включает открытие нескольких портов в брандмауэре, чтобы дать возможность клиентам Microsoft Office Outlook® 2003 и Outlook 2007 подключаться к серверу Exchange, используя MAPI, обычно через Интернет.

Рекомендованное развертывание для использования Outlook в режиме MAPI для подключения к серверу Exchange через Интернет - это использование RPC по протоколу HTTP. Эта возможность существует в Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003, Exchange Server 2007, Outlook 2007 и Microsoft Windows® XP Professional. Режим MAPI ранее назывался «Корпоративным» режимом или режимом «Рабочей группы».

Чтобы устранить эту ошибку, необходимо изменить значение данного ключа или конфликтующего ключа, указанного в выходных данных анализатора сервера Exchange, установив для соответствующего ключа уникальное значение.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы установить значение параметра реестра для порта TCP/IP NSPI

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Дважды щелкните раздел TCP/IP NSPI Port и установите в поле Значение уникальное значение, превышающее 5000 (десятичное).

  4. Закройте редактор реестра.

  5. Перезагрузите компьютер, чтобы данное изменение вступило в силу.

Чтобы развернуть удаленные вызовы процедур через HTTP

  1. Изучите документ «Exchange Server 2003 RPC over HTTP Deployment Scenarios» (http://go.microsoft.com/fwlink/?linkid=47577) (Cценарии развертывания удаленных вызовов процедур Exchange Server 2003 через HTTP).

  2. Ознакомьтесь с документом, посвященным развертыванию мобильного Outlook (http://go.microsoft.com/fwlink/?LinkId=80831).

  3. Изучите статью 833401 базы знаний Майкрософт «How to configure RPC over HTTP on a single server in Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401) (Инструкции по настройке удаленных вызовов процедур через HTTP на одиночном сервере в Exchange Server 2003).

  4. Изучите статью 827330 базы знаний Майкрософт «How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330) (Инструкции по устранению в Office Outlook 2003 проблем подключения при передаче удаленных вызовов процедур клиента через HTTP).

  5. Изучите веб-презентацию службы поддержки Майкрософт «Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134) (Использование Microsoft Exchange через Интернет (RPC/HTTP) с помощью средств Microsoft Office Outlook 2003).

Перед редактированием реестра, а также для получения инструкций по изменению реестра изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения о статически сопоставляемых портах, используемых Exchange Server, см. в следующей статье базы знаний Майкрософт:

  • 270836, «Статическое сопоставление портов в Exchange 2000 и Exchange 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836).


Конфликт доступа к порту:системный помощник RFR
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-30

Чтобы определить существование каких-либо конфликтов доступа к портам, средство анализатора сервера Microsoft® Exchange считывает следующие записи реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Если анализатор сервера Exchange обнаружит, что значение HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port совпадает с каким-либо из значений параметров реестра для других шести портов, перечисленных выше в этой статье, на экран выводится сообщение об ошибке. Анализатор сервера Exchange также выводит на экран сообщение об ошибке для порта, который конфликтует с HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port.

Наиболее распространенная причина настройки этого значения — включение клиентов MAPI для подключения к серверу Exchange, который находится по другую сторону сетевого экрана. Эта ситуация включает открытие нескольких портов в брандмауэре, чтобы дать возможность клиентам Microsoft Office Outlook® 2003 или Outlook 2007 подключаться к серверу Exchange с помощью MAPI, обычно через Интернет.

Рекомендованное развертывание для использования Outlook в режиме MAPI для подключения к серверу Exchange через Интернет — это использование RPC по протоколу HTTP. Эта функция поддерживается в Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003 и Microsoft Windows® XP Professional. Режим MAPI ранее назывался «Корпоративным» режимом или режимом «Рабочей группы».

Чтобы устранить эту ошибку, необходимо изменить значение данного ключа или конфликтующего ключа, указываемого в выходных данных анализатора сервера Exchange, установив для соответствующего ключа уникальное значение.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы установить значение параметра реестра для порта TCP/IP

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Дважды щелкните ключ TCP/IP Port и установите в поле Значение уникальное значение, превышающее 5000 (десятичное).

  4. Закройте редактор реестра.

  5. Перезагрузите компьютер, чтобы эта настройка вступила в силу.

Чтобы развернуть удаленные вызовы процедур через HTTP

  1. Ознакомьтесь с описанием сценариев развертывания удаленных вызовов процедур Exchange Server 2003 через HTTP (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Ознакомьтесь с документом, посвященным развертыванию мобильного Outlook (http://go.microsoft.com/fwlink/?LinkId=80831).

  3. Ознакомьтесь в базе знаний Майкрософт со статьей 833401, содержащей инструкции по настройке удаленных вызовов процедур через HTTP на одиночном сервере в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  4. Ознакомьтесь в базе знаний Майкрософт со статьей 827330, содержащей инструкции по устранению в Office Outlook 2003 проблем подключения при передаче удаленных вызовов процедур клиента через HTTP (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  5. Ознакомьтесь с веб-презентацией службы поддержки Майкрософт, посвященной использованию Microsoft Exchange через Интернет (RPC/HTTP) с помощью средств Microsoft Office Outlook 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о статическом сопоставлении портов, используемых сервером Exchange, см. в статье 270836 базы знаний Майкрософт «Сопоставление статических портов для сервера Exchange Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836).


Обнаружено обновление с помощью пакета обновления для бета-версии
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута versionNumber для каждого объекта Exchange Server. Атрибут versionNumber представляет версию Exchange Server, установленную на компьютере.

Средство анализатора сервера Microsoft® Exchange запрашивает класс инструментария управления Windows (WMI) CIM_Datafile, чтобы определить значение параметра Version для файла ExCDO.DLL библиотеки объектов совместной работы для Exchange (ExCDO). Если анализатор сервера Exchange обнаруживает, что значение параметра Version для файла ExCDO.DLL не равно 6603.0, на экран выводится предупреждение.

Если на компьютере Exchange 2000 Server обнаружена версия ExCDO.dll 6603.0, это значит, что на сервере работает Exchange 2000 Server версии 1 за август 2004 г. со сборкой обновлений, следующей после пакета обновлений 3 (SP3). В настоящее время имеется версия 2 этой сборки обновлений. Рекомендуется установить сборку обновлений за август 2004 г.

Чтобы устранить причину появления этого предупреждения

  1. Cведения о новейшем обновлении см. в статье 870540 базы знаний корпорации Майкрософт, описывающей сборку обновлений за август 2004 г., выпущенных после пакета обновления 3 (SP3) для Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540).

  2. Загрузите новейшее обновление (август 2004 г.) на веб-узле файлов загрузки для Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).

  3. Выполните резервное копирование на компьютере сервера Exchange.

  4. Примените сборку обновлений за август 2004 г.

Дополнительные сведения о получении последнего пакета обновления для Exchange 2000 Server см. в статье 301378 базы знаний корпорации Майкрософт, описывающей получение последнего пакета обновления Exchange 2000 Server) (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378).

Дополнительные сведения об установке этого и других обновлений для Exchange Server см. в статье 328839 базы знаний Майкрософт, описывающей применение пакетов обновления и исправлений для Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Проблема, связанная с расположением файла подкачки
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange определил, что расположение файла подкачки может отрицательно сказаться на работе сервера. Файл подкачки не должен располагаться на том же диске, что и базы данных Exchange или файлы журнала Exchange. Рекомендуется также изолировать файл подкачки от системных файлов.

Рекомендуется размещать файл подкачки на выделенном разделе или на высокоскоростном диске.

Чтобы устранить причину появления этого предупреждения

  • Переместите файл подкачки в расположение, в котором не содержатся файлы журналов или баз данных Exchange, и, желательно, не содержится системный раздел.

Дополнительные сведения

  • Дополнительные сведения о настройке файла подкачки см. в базе знаний Майкрософт в статье 197379, посвященной настройке файлов подкачки для целей оптимизации и восстановления в Windows Server 2003, Windows 2000 и Windows NT (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=197379).

  • Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению быстродействием и масштабируемостью Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Дополнительные сведения об устранении проблем, связанных с быстродействием сервера Exchange, см. на веб-узле, посвященном устранению неполадок, связанных с быстродействием сервера Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Узкое место в работе процессора
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-02-24

Средство анализатора сервера Microsoft® Exchange определило, что на сервере существует узкое место в работе процессора. Нагрузка на процессор сервера превысила рекомендуемое пороговое значение. Для идентификации узких мест в работе процессора и проблем использования процессора применяются следующие счетчики:

  • Счетчик производительности Переключения контекста/сек для объекта быстродействия Система.

  • Счетчик производительности % процессорного времени (_Всего) для объекта быстродействия Процессор.

  • Счетчик производительности Длина очереди процессора для объекта быстродействия Система.

Обнаружение узких мест в работе процессора

Анализатор сервера Exchange обнаружит узкое место, если будет соблюдаться одно из следующих условий:

  • Среднее значение счетчика производительности % процессорного времени (_Всего) для объекта быстродействия Процесс превышает 70 процентов.

  • Максимальное значение счетчика производительности % процессорного времени (_Всего) для объекта быстродействия Процесс превышает 90 процентов.

  • Среднее значение счетчика производительности Переключения контекста/сек для объекта быстродействия Система превышает 20 000.

  • Значение счетчика производительности Длина очереди процессора для объекта быстродействия Система больше двух.

  • Данный счетчик производительности % процессорного времени (_Всего) для объекта быстродействия Процесс предоставляет общий показатель использования процессоров. Среднее значение использования ресурсов процессора должно всегда быть меньше 80 процентов. Более высокие средние значения указывают на существование узкого места в работе процессора. Если среднее значение использования ресурсов процессора превышает 70 процентов, на экран выводится предупреждение. Наличие частых пиков, превышающих 90 процентов, на диаграмме потребления процессорного времени также указывают на узкое место в работе процессора.

  • Счетчик производительности Длина очереди процессора для объекта быстродействия Система показывает число потоков в очереди процессора. Существует одна очередь за ресурсами процессорного времени даже на компьютерах с несколькими процессорами. Значение больше двух указывает, что потоки ожидают выделения процессорного времени и что существует узкое место в работе процессора.

Определение источников нагрузки на процессор

Если обнаружено узкое место в работе процессора, необходимо определить, на что уходит большая часть процессорного времени. На прикладном сервере Exchange большая часть процессорного времени должна расходоваться на процесс Store.exe. Если более 20 процентов загрузки процессора приходится на процесс, отличный от Store.exe, важно определить, какие другие процессы занимают ресурсы процессора.

Если использование процессорного времени процессами, перечисляемыми в приводимой ниже таблице, больше пороговых значений, анализатор сервера Exchange выведет на экран сообщение об ошибке.

Процесс | Пороговое значение счетчика производительности % процессорного времени для объекта быстродействия Процесс
Store | 90%
Inetinfo | 20%
Emsmts | 40%
Lsass | 40%
System | 40%
Mad | 40%
ExMGMT | 20%
W3WP | 40%

Анализатор сервера Exchange также измеряет разницу между временем простоя процессора, которое измеряется счетчиком производительности % процессорного времени (экземпляр Ожидание) и счетчиком производительности % процессорного времени (экземпляр _Всего) для объекта производительности Процесс. На исправном прикладном сервере Exchange по крайней мере 70 процентов используемого процессорного времени должно приходиться на процесс Store.exe.

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Если объем затраченного процессорного времени, не приходящийся на процессы, связанные с сервером Exchange (процессы Store.exe, inetinfo.exe, emsmta.exe, lsass.exe, w3wp.exe, exmgmt.exe и mad.exe), превышает 35 процентов.

  • Если используемое процессорное время, не связанное с Exchange, превышает 20 процентов.

  • Если существует узкое место в работе процессора и на процесс Store.exe приходится менее 70 процентов процессорного времени.

Во всех этих случаях рекомендуется найти, какие другие процессы потребляют процессорные ресурсы сервера.

Распространенные причины возникновения узких мест в работе процессора на прикладных серверах

Существует несколько возможных причин возникновения узких мест в работе процессора, включая следующие:

  • другие приложения на сервере, потребляющие процессорные ресурсы;

  • высокая интенсивность удаленных вызовов процедур;

  • расширение списка рассылки;

  • резервное копирование и обслуживание выполняются во время рабочих часов пиковой нагрузки;

  • преобразование содержимого в сообщениях, вызванное следующими причинами:

    • работа нескольких протоколов (например, HTTP, POP3, IMAP4, Microsoft Office Outlook®);

    • Outlook 2000 или более ранние версии, использующие автономные папки (файлы с расширением OST).

Устранение узких мест в работе процессора

Существует несколько способов устранения узких мест в работе процессора на сервере Exchange.

Чтобы устранить узкие места в работе процессора

  • Если можно, добавьте на сервер дополнительные или более быстрые процессоры. К тому же, включите многопоточность, если она поддерживается процессорами. Многопоточность можно включить путем настройки BIOS системы. Дополнительные сведения см. в справочной документации, предоставляемой производителем компьютера.

  • Если отсутствует возможность увеличения процессорной мощности, необходимо уменьшить нагрузку на процессоры. Чтобы уменьшить общую нагрузку на сервер, важно убедиться, что задачи, активно потребляющие ресурсы системы ввода-вывода, процессоров или памяти, выполняются вне пределов обычного рабочего времени.

    Сначала идентифицируйте приложения или задачи, которые создают нагрузку на сервер. Если приложение, отличное от Exchange, не важно для сервера, запустите это приложение на другом сервере. Если есть возможность, переместите также роли сервера на другие компьютеры. Например, если процесс Inetinfo потребляет значительные процессорные ресурсы, рассмотрите возможность добавления серверов переднего плана для переноса на них работы протокола, выполняемой процессом Inetinfo. Можно также переместить средства доступа к общим папкам на выделенный сервер общих папок. Наконец, если сервер выполняет множество расширений списка рассылки, можно уменьшить нагрузку на процессоры путем перемещения расширения списка рассылки на выделенный сервер расширений списка рассылки.

  • Убедитесь, что задачи, активно потребляющие ресурсы процессора (например, резервное копирование и обслуживание) выполняются в часы внепиковой нагрузки. Также проверьте, чтобы эти задачи выполнялись в несколько этапов. Поэтапное выполнение задач предполагает установку разных времен запуска и, желательно, разных времен окончания для каждой задачи. Поэтапное выполнение обслуживания и резервного копирования баз данных или групп хранения также снижает нагрузку, оказываемую этими ресурсоемкими задачами.

  • Если удалены все дополнительные источники нагрузки, а использование процессорных ресурсов все еще остается слишком большим, необходимо переместить пользователей на другой сервер, чтобы уменьшить нагрузку. Дополнительные сведения см. по ссылке Перенос почтовых ящиков пользователей на другой сервер.

Дополнительные сведения

  • Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Дополнительные сведения об устранении проблем производительности сервера Exchange см. в описании процедур устранения неполадок, связанных с производительностью Microsoft Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Дополнительные сведения о переносе почтовых ящиков пользователей для снижения нагрузки на сервер см. по ссылке Перенос почтовых ящиков пользователей на другой сервер.


Недоступен объект наблюдения за производительностью процессора
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа сервера Microsoft® Exchange включает механизм сбора данных о производительности, который используется, чтобы опрашивать объекты счетчиков производительности на компьютерах, работающих с Exchange 2000 Server или Exchange Server 2003. Механизм сбора данных о быстродействии собирает данные счетчиков производительности % Processor Time объектов производительности Processor для анализа данных о производительности. Если счетчик не возвращает допустимое значение данных, средство анализа сервера Exchange отображает сведения о средней производительности.

Если средство сбора данных о быстродействии не возвращает допустимое значение данных, верно любое сочетание следующих условий:

  • Объект производительности Processor отключен.

  • Объект наблюдения за производительностью Processor отсутствует или поврежден.

  • Средство анализа сервера Exchange не имеет необходимых разрешений для доступа к объектам производительности.

Два первых условия могут иметь место, если определенные расширяемые счетчики внесли повреждения в реестр или если программы, работающие на основе инструментария WMI, изменили реестр. В следующей процедуре приведено объяснение, как исправить два первых условия. Перед выполнением процедуры убедитесь, что средство анализа сервера Exchange имеет соответствующие разрешения. Для получения дополнительных сведений о разрешениях, необходимых для запуска средства анализа сервера Exchange, см. документацию справки, входящую в комплект поставки средства анализа сервера Exchange. Для просмотра справки откройте средство анализа сервера Exchange и нажмите клавишу F1.

Чтобы исправить эту ошибку

  1. Убедитесь, что объект производительности Processor доступен.

    1. Загрузите и установите средство составления списка расширяемого счетчика производительности (Exctrlst.exe). Exctrlst.exe можно загрузить по адресу «Exctrlst.exe: Средство составления списка расширяемого счетчика производительности» (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Откройте Exctrlst.exe, выберите Порядок сортировки, затем выберите Служба.

    3. Найдите службу, соответствующую отчетам объектов производительности, и убедитесь, что установлен флажок Счетчики производительности включены.

      Если флажок Счетчики производительности включены не установлен, установите его и перезапустите связанную со счетчиками производительности службу, чтобы убедиться, что счетчики производительности находятся в рабочем состоянии. Если счетчики производительности не находятся в рабочем состоянии или флажок Счетчики производительности включены уже установлен, перейдите к шагу 2.

  2. Воссоздайте отсутствующие или поврежденные счетчики производительности, как описано в статье 300956 базы знаний Майкрософт «Как вручную повторно создать значения библиотеки счетчиков производительности» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Если следующая статья базы знаний не решит проблему, понадобится повторно установить операционную систему Windows в режиме Восстановление, затем применить последние пакеты обновления Windows.


Репликация содержимого общей папки приостановлена
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, установлен ли для данной организации Exchange Server атрибут heuristics. Если анализатор сервера Exchange обнаруживает, что в атрибуте heuristics установлен бит 1024, выводится предупреждение.

В Exchange Server 2003 с пакетом обновления 2 внедрена возможность для администратора остановить репликацию содержимого общей папки в организации. Чтобы остановить репликацию общей папки, следует щелкнуть правой кнопкой мыши имя нужной организации в системном диспетчере Exchange и выбрать команду Остановить репликацию содержимого общей папки. При выборе команды Остановить репликацию содержимого общей папки в атрибуте heuristics устанавливается бит 1024. Репликацию содержимого общей папки следует останавливать только в исключительных случаях, например при устранении неполадок в работе общей папки уровня целой организации или устранении проблем потока почты.

Необходимо возобновить репликацию содержимого общей папки, если выполнены следующие условия:

  • Не ведется устранение неполадок.

  • Нет необходимости в остановке репликации содержимого общей папки по иным причинам.

Чтобы возобновить репликацию содержимого общей папки на уровне организации

  1. Откройте системный диспетчер Exchange.

  2. Щелкните правой кнопкой мыши элемент имя_организации и выберите команду Возобновить репликацию содержимого общей папки.

Дополнительные сведения о репликации общих папок см. в документе Best Practices for Exchange Server Public Folders (http://go.microsoft.com/fwlink/?LinkId=46437) (Рекомендации для общих папок в Exchange Server).


На сервере переднего плана присутствует хранилище общих папок
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-09-07

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, присутствует ли хранилище общих папок на каждом сервере Exchange. Если анализатор сервера Exchange обнаружит, что объект InformationStore является классом объекта, msExchPublicMDB, значит, на сервере размещается хранилище общих папок.

Анализатор сервера Exchange также запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) MicrosoftExchangeV2, чтобы определить, установлено ли значение для ключа IsFrontEndServer. Значение «True» указывает, что сервер Exchange настроен как сервер переднего плана, а значение «False» указывает, что сервер Exchange не настроен в качестве сервера переднего плана. Если анализатор сервера Exchange обнаружит, что сервер Exchange настроен как сервер переднего плана, на котором размещается общий банк данных, на экран будет выведено предупреждение.

Рекомендуется не размещать хранилища общих папок на серверах переднего плана. Хранилища общих папок не нужны на серверах переднего плана, так как на серверах переднего плана не размещаются почтовые ящики. Кроме того, при размещении хранилищ общих папок на серверах переднего плана, на которых выполняется приложение Exchange 2000 Server, возникают известные проблемы с репликацией общих папок, ссылками на общие папки, а также утечки памяти. Поэтому следует отключить все хранилища общих папок на серверах переднего плана.

После отключения хранилищ общих папок можно отключить службу «Банк данных Microsoft Exchange», так как она больше не выполняет никаких функций на серверах переднего плана. Путем удаления ненужных служб снижается нагрузка, повышается уровень безопасности и производительность.

Примечание.
Если сервер переднего плана также получает SMTP-сообщения (Simple Mail Transfer Protocol) из Интернета, служба «Банк данных Microsoft Exchange» должна продолжать функционировать, а хранилище почтовых ящиков должно оставаться подключенным. Тем не менее, никогда не следует располагать хранилище общих папок на сервере переднего плана.

Чтобы остановить и отключить базы данных почтовых ящиков и общих папок

  1. В системном диспетчере Exchange разверните узел Серверы, разверните узел сервера, а затем разверните узел Первая группа хранения.

    Щелкните правой кнопкой мыши Хранилище почтовых ящиков (Имя_сервера), в контекстном меню выберите Отключить хранилище, а затем щелкните Да, чтобы отключить хранилище.

    Важно!
    Если сервер переднего плана используется как SMTP-сервер-плацдарм, на сервере должно существовать подключенное хранилище почтовых ящиков. В этом случае не отключайте и не удаляйте это хранилище, однако убедитесь, что на этом сервере не хранятся какие-либо почтовые ящики.

  2. Щелкните правой кнопкой мыши Хранилище почтовых ящиков (Имя_сервера) и в контекстном меню выберите пункт Свойства.

  3. Откройте вкладку База данных, установите флажок Не подключать это хранилище при загрузке и нажмите кнопку OK.

    Щелкните правой кнопкой мыши Хранилище общих папок (Имя_сервера) и в контекстном меню выберите команду Отключить хранилище.

    Внимание!
    Прежде чем отключить хранилище общих папок, убедитесь, что общие папки имеют свои реплики в другом хранилище общих папок. В противном случае будет возможна потеря сведений.

  4. Щелкните Да, чтобы отключить хранилище общих папок.

Чтобы отключить службу «Банк данных Microsoft Exchange»

  1. В оснастке «Службы» консоли MMC (Microsoft Management Console) щелкните правой кнопкой мыши Банк данных Microsoft Exchange в списке Имя, а затем в контекстном меню выберите пункт Свойства.

  2. В списке Тип запуска выберите Выключено, а затем щелкните Стоп.

Чтобы безвозвратно удалить базу данных почтовых ящиков и общих папок

  • Следуйте инструкциям, содержащимся в руководстве по усилению безопасности сервера Exchange, в котором описывается отключение и удаление хранилищ почтовых ящиков и общих папок (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=25210).

Дополнительные сведения о проблемах, связанных с работой служб хранилищ на серверах переднего плана, см. в следующих статьях базы знаний Майкрософт:

  • Статья 286822, описывающая явление установки серверами переднего плана большого количества подключений между собой (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=286822).

  • Статья 320298, описывающая случай большого количества подключений, установленных на серверах переднего плана, на которых выполняется приложение Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320298).

Дополнительные сведения о серверах переднего плана и фоновых серверах см. в руководстве по внешней и внутренней топологии приложений Exchange Server 2003 и Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=34216).


Отсутствует файл REAPI.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы проверить наличие нескольких основных двоичных файлов Exchange:

  • Exres.dll

  • Gapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»),

  • Mapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»),

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Если средство анализатора сервера Exchange обнаруживает, что отсутствует один или несколько из указанных выше файлов, выводится сообщение об ошибке. Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если ошибку не удалось устранить, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в привод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Recipient Update Service is missing or is not configured
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-07-11

Анализатор сервера Microsoft Exchange Server запрашивает службу каталогов Active Directory, чтобы определить значение атрибута msExchAddressListServiceLink для каждого имеющегося в каталоге объекта службы обновления получателей. Атрибут msExchAddressListServiceLink является ссылкой из службы списков адресов на компьютер с сервером Exchange Server, на котором эта служба должна работать. Если анализатор Exchange обнаруживает, что для объекта службы обновления получателей отсутствует атрибут msExchAddressListServiceLink или для этого объекта не задано значение атрибута msExchAddressListServiceLink, выводится сообщение об ошибке.

Каждый экземпляр службы обновления получателей обычно связан с одним компьютером с сервером Exchange Server, на котором запущена служба обновления получателей. Это сообщение об ошибке означает, что экземпляр службы обновления получателей не связан с компьютером с сервером Exchange Server. Это может привести к тому, что списки адресов Exchange и получатели не будут обновляться.

Чтобы запустить данный экземпляр службы обновления получателей, необходимо связать его с существующим сервером Exchange.

Устранение ошибки

  1. Откройте диспетчер Exchange.

  2. В разделе Получатели выберите пункт Службы обновления получателей. В правой панели щелкните правой кнопкой мыши соответствующий экземпляр службы обновления получателей и выберите пункт Свойства.

  3. На вкладке Общие в разделе Сервер Exchange Server нажмите кнопку Обзор и укажите сервер для запуска данного экземпляра службы.

  4. Чтобы изменения вступили в силу, дважды нажмите кнопку ОК.

  5. Закройте диспетчер Exchange.

Дополнительные сведения о службе обновления получателей см. в следующих разделах и статьях базы знаний Майкрософт:

  • Раздел «Управление получателями и политиками получателей в сервере Exchange Server 2003» руководства по администрированию сервера Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47617) (на английском языке)

  • Статья 328738, «Применение политики получателей службой обновления получателей» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738) (эта ссылка может указывать на содержимое полностью или частично на английском языке)

  • Статья 253828, «Заполнение списков адресов службой Recipient Update» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • Статья 246127, «Проверка работы службы обновления получателей Exchange» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127) (эта ссылка может указывать на содержимое полностью или частично на английском языке)

  • Статья 253770, «Задачи, выполняемые службой обновления получателей Exchange» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770) (эта ссылка может указывать на содержимое полностью или частично на английском языке)


Рекомендуемые обновления для Windows 2000 Server с пакетом обновления 4 в кластере
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Exchange считывает следующий раздел реестра, чтобы определить версию Microsoft Windows®, под управлением которой работает сервер Exchange:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion

Примечание.
Значение CurrentVersion равное 4,0 означает, что компьютер работает под управлением операционной системы Microsoft Windows NT® Server 4.0. Значение 5.0 означает, что компьютер работает под управлением операционной системы Microsoft Windows Server 2000. Значение 5.2 означает, что компьютер работает под управлением операционной системы Microsoft Windows Server 2003.

Анализатор сервера Exchange также опрашивает WMI-класс Win32_OperatingSystem, чтобы определить значение раздела ServicePackMajorVersion.

Наконец, анализатор опрашивает WMI-класс Win32_Service, чтобы определить, запущена ли служба ClusSvc.

Если выполняются следующие условия, анализатор сервера Exchange отобразит рекомендацию:

  • ??Сервер Exchange находится на компьютере, работающем под управлением Windows 2000 Server с пакетом обновления 4.??

  • Служба ClusSvc запущена.

Рекомендуется изучить доступные обновления и исправления и определить, смогут ли они решить проблемы в определенной среде.

Дополнительные сведения об обновлениях серверов, работающих под управлением Windows 2000 Server и список этих обновлений см. в статье 895090 базы данных Майкрософт, посвященной рекомендованным исправлениям для кластерных серверов на основе Windows 2000 с пакетом обновления 4 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895090).


Длина удаленной очереди превышает пороговое значение
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-04-09

Анализатор Microsoft Exchange содержит подсистему сбора данных о производительности, используемую для запроса объектов счетчиков производительности на компьютерах с Exchange 2000 Server или Exchange Server 2003. Эта подсистема собирает данные счетчика производительности Remote Queue Length объекта производительности SMTP Server для анализа.

Если анализатор Exchange определяет, что значение счетчика Remote Queue Length превысило максимально допустимое значение (1000) в течение интервала, для которого выполняется выборка, выводится сообщение об ошибке.

Счетчик SMTP Server\Remote Queue Length указывает число сообщений в очереди SMTP, ожидающих удаленной доставки. Увеличение значения Remote Queue Length означает, что почта не отправляется другим службам.

Причиной сбоя отправки почты могут быть отключения или нарушения производительности сети и удаленных серверов. Эти отключения и нарушения производительности делают невозможным нормальный прием почты сетью или удаленными серверами.

Чтобы устранить эту ошибку, воспользуйтесь следующими ресурсами для выявления проблемного сервера или сетевого компонента и устранения нарушения производительности.

Дополнительные сведения

  • Для получения дополнительных сведений см. инструкции по выявлению увеличивающихся почтовых очередей в разделе, посвященном обнаружению симптомов снижения производительности, руководства по устранению проблем производительности Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Дополнительные сведения о производительности сервера Exchange Server см. в Руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576) (на английском языке).

  • Дополнительные сведения о производительности Exchange Server см. в разделе, описывающем 10 вопросов, связанных с производительностью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkID=56460).


Длина очереди удаленных попыток превышает пороговое значение
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-02-13

Средство анализа сервера Microsoft® Exchange включает в себя механизм сбора данных о производительности, который используется для опроса объектов счетчиков производительности на компьютерах, работающих под Exchange 2000 Server или Exchange Server 2003. Механизм сбора данных о производительности собирает данные со счетчика производительности Remote Retry Queue Length объектов SMTP Server для анализа данных о производительности.

SMTP Server\Remote Retry Queue Length Счетчик показывает количество сообщений в очереди удаленных попыток SMTP, которые не могут быть отправлены на сервер назначения. Если средство анализа сервера Exchange определяет, что счетчик Remote Retry Queue Length превысил допустимое значение, равное 1000 в течение временного интервала снятия отсчета, анализатор сервера Exchange отображает сообщение об ошибке.

Эта ошибка в доставке почты может быть объяснена сбоями или проблемами производительности сети или удаленных серверов. Эти сбои или проблемы производительности препятствуют эффективному получению почты сетью или удаленными серверами.

Чтобы устранить эту ошибку, используйте источники, доступные по следующей ссылке, для определения проблемного сервера или компонента сети и определения местоположения проблем с производительностью.

Дополнительные сведения

  • Для получения дополнительных сведений об устранении проблем с быстродействием в Exchange Server см. главу «Определение признаков нарастания почтовых очередей» в разделе «Определение признаков недостаточной производительности» статьи Устранение проблем с производительностью в Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Для получения дополнительных сведений о производительности Exchange Server см. Руководство по производительности и масштабируемости для Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Для получения дополнительных сведений о быстродействии Exchange Server см. Производительность Exchange Server 2003: 10 вещей, над которыми необходимо задуматься (http://go.microsoft.com/fwlink/?LinkID=56460).


Реплика автономной адресной книги версии 4 не найдена
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-02-13

Средство анализатора сервера Microsoft® Exchange опрашивает WMI-класс Exchange_Public_Folder, чтобы определить значение раздела HasLocalReplica. Если анализатор сервера Exchange находит, что значение раздела HasLocalReplica для экземпляра автономной адресной книги версии 4 автономного списка адресов равно False, отображается сообщение об ошибке.

Если значение раздела HasLocalReplica равно False для экземпляра автономной адресной книги версии 4 автономного списка адресов, автономные списки адресов не были созданы правильно. В результате пользователи Microsoft Office Outlook® 2003 не смогут загрузить автономные списки адресов.

Это может произойти в том случае, если хранилища общих папок не были настроены на содержание реплик автономных адресных книг версии 4. По умолчанию содержимое автономной адресной книги реплицируется в хранилище общих папок на том же сервере, где она установлена. Если хранилище общих папок удаляется из конфигурации репликации адресной книги, возникает ошибка, описанная выше.

Чтобы устранить эту ошибку

  1. Откройте системный диспетчер Exchange.

  2. Разверните узел Административные группы и щелкните Папки.

  3. Щелкните правой кнопкой мыши Общие папки, затем щелкните Просмотреть системные папки.

  4. Щелкните, чтобы развернуть объект АВТОНОМНАЯ АДРЕСНАЯ КНИГА.

  5. В узле АВТОНОМНАЯ АДРЕСНАЯ КНИГА, щелкните правой кнопкой мыши o=org/cn=addrlists/cn=oabs/cn=автономный список адресов по умолчанию, затем щелкните Свойства.

  6. На вкладке Репликация убедитесь, что в поле Реплицировать содержимое в эти общие хранилища указано хранилище общих папок. Если хранилище общих папок не указано, нажмите кнопку Добавить и введите необходимое общее хранилище для автономной адресной книги.

  7. Нажмите Применить, затем ОК.

  8. Щелкните, чтобы развернуть узел o=org/cn=addrlists/cn=oabs/cn=автономный список адресов по умолчанию.

  9. В узле o=org/cn=addrlists/cn=oabs/cn=автономный список адресов по умолчанию щелкните правой кнопкой мыши пункт автономная адресная книга версии 4 и щелкните Свойства.

  10. На вкладке Репликация убедитесь, что в поле Реплицировать содержимое в эти общие хранилища указано хранилище общих папок. Если хранилище общих папок не указано, нажмите кнопку Добавить и введите необходимое общее хранилище для автономной адресной книги.

  11. Нажмите Применить, затем ОК.

Дополнительные сведения об этом вопросе см. в статье 286328 базы знаний Майкрософт, посвященной отсутствию и невозможности создания автономной адресной книги в Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328).

Дополнительные сведения о правильном удалении первого компьютера с Exchange Server 2003 из административной группы см. в статье 822931 базы знаний Майкрософт, посвященной удалению первого компьютера с Exchange Server 2003 из административной группы (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822931).

Дополнительные сведения о вопросах, связанных с автономной адресной книгой, см. на следующих ресурсах, посвященных Exchange Server:

  • страница, посвященная вопросам, которые следует учесть при использовании автономной адресной книги (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=57581);

  • страница, посвященная совместной работе Outlook 2003 SP2 и автономной адресной книги версии 4 в Exchange Server 2003 SP2 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=53099)

  • страница, посвященная автономной адресной книги версии 4 в Exchange Server 2003 с пакетом обновления 2 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=53097)


Длина очереди на получение репликации превышает пороговое значение
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-02-13

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов о показаниях счетчиков производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности получает данные со счетчика производительности Replication Receive Queue Size объекта с оцениваемой производительностью MSExchangeIS Public для анализа данных о производительности.

Если анализатор сервера Exchange определяет, что в течение временного интервала снятия отсчета значение счетчика Replication Receive Queue Size превысило максимальное значение, равное 1000, анализатор сервера Exchange выводит на экран сообщение об ошибке.

Сообщения о репликации общих папок принимаются протоколом SMTP, классифицируется и передается в локальную SMTP-очередь. Затем эти сообщения передаются в хранилище общих папок. После их поступления в хранилище общих папок, сообщения ставятся в очередь на получение репликации. Затем сообщения в очереди на получение репликации обрабатываются, и производятся изменения в соответствующей общей папке. Счетчик производительности Replication Receive Queue Size показывает число сообщений о репликации общих папок, ожидающих обработки.

Чем больше становится очередь на репликацию, тем больше становится рассинхронизация содержимого в папках. С ростом очереди на репликацию возрастает нагрузка на ресурсы, т.к. в очереди на репликацию производится обработка сообщений. Кроме того рост очереди на репликацию указывает, что содержимое общей папки на сервере устарело.

В двух случаях, когда ожидается и может планироваться рост очереди на получение репликации, нет необходимости предпринимать какие-либо действия:

  • На вновь введенном сервере общих папок рост очереди на получение репликации может быть вызван ожидаемой первоначальной репликацией введенных данных.

  • Если происходит консолидация или другие значительные изменения топологии Exchange, ожидается, что в связи с изменением содержимого будет большой объем репликации.

Для существующих серверов, находящихся в стабильном состоянии, где реплики общих папок не изменяются в массовом порядке, это сообщение об ошибке может указывать на следующее:

  • Узкие места с точки зрения производительности ресурсов сервера, например, диск, процессор, сеть или память. Если узкое место находится на сервере, то процесс Store.exe не сможет обрабатывать сообщения о репликации достаточно быстро и очередь будет расти.

  • Интервал репликации общих папок слишком мал, чтобы репликация была завершена до начала следующего цикла репликации.

Чтобы устранить эту ошибку, выполните следующие шаги:

  • Увеличьте временной интервал репликации и наблюдайте MSExchangeIS Public\Replication Receive Queue Size до тех пор, пока он не покажет, что репликация завершена до начала следующего цикла репликации.

  • Используйте ресурсы, указанные следующими ссылками, чтобы определить, вызывает ли узкое место с точки зрения производительности рост очереди, и решить проблему узкого места.

  • Рассмотрите возможность уменьшения общего числа реплик в организации Exchange с целью уменьшения необходимого трафика репликации.

Дополнительные сведения

  • Дополнительные сведения об устранении проблем производительности сервера Exchange см. в статье "Handling Special Exchange Roles and Performance" (Обработка специальных ролей Exchange и производительность) раздела Устранение неполадок приложения Microsoft Exchange Server, связанных с производительностью (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Дополнительные сведения о репликации общих папок сервера Exchange см. в статье "Controlling Exchange Server 2003 Public Folder Replication" (Управление репликацией общих папок приложения Exchange Server" в разделе Работа с хранилищем приложения Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).

  • Дополнительные сведения о рекомендациях по общим папкам Exchange см. в разделе Рекомендации по общим папками Exchange: Выполнение репликации (http://go.microsoft.com/fwlink/?LinkId=46440).

  • Дополнительные сведения об улучшениях в управлении общими папками, введенных пакетом обновления 2 приложения Exchange Server 2003, см в разделе Заметки о выпуске пакета обновления 2 для приложения Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=52072).


Отсутствует файл RESVC.DLL
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить наличие нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapi32.dll (записывается в папку System32 и в папку \Exchsrvr\bin),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если средство анализатора сервера Exchange обнаруживает, что отсутствует один или несколько из указанных выше файлов, выводится сообщение об ошибке. Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если это не устранит ошибку, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-значный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Включен параметр реестра RestrictRemoteClients
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server Analyzer Tool считывает следующий параметр реестра, чтобы определить, включена ли функция ограничения интерфейсов удаленного вызова процедур (RPC).

HKEY_LOCAL_MACHINE\ Software\Policies\Microsoft\Windows NT\RPC

Если Exchange Server Analyzer обнаруживает, что настроен раздел реестра RestrictRemoteClients, появляется сообщение о нестандартной настройке.

Функция ограничения интерфейсов удаленного вызова процедур (RPC) обеспечивает повышенную защиту сети, делающую системы менее уязвимыми к атакам в сети. Значение раздела реестра RestrictRemoteClients изменяет поведение все интерфейсов удаленного вызова процедур в системе. По умолчанию значение реестра RestrictRemoteClients предотвращает удаленный анонимный доступ к интерфейсам удаленного вызова процедур - за рядом исключений.

При регистрации интерфейса с помощью RpcServerRegisterIf RPC позволяет приложению сервера ограничить доступ к интерфейсу, как правило путем ответного вызова безопасности. Значение реестра RestrictRemoteClients дает возможность RPC выполнить дополнительную проверку безопасности для всех интерфейсов, даже если интерфейс не имеет ответного вызова безопасности.

Примечание.
Клиенты RPC, использующие указанную последовательность каналов протоколов, являются исключением для всех ограничений. Последовательность каналов протоколов не может быть ограничена по причине существенных проблем обратной совместимости.
Примечание.
Также можно настроить раздел реестра the RestrictRemoteClients с помощью редактора объектов групповой политики.

Раздел реестра RestrictRemoteClients настраивается с использованием значений DWORD. Если значения реестра нет, отсутствующее значение равняется значению RPC_Restrict_Remote_Client_Default.

В таблице ниже приведена информация о параметрах настройки RestrictRemoteClients.

Значение раздела реестра (DWORD) Описание

0 (по умолчанию)

RPC_RESTRICT_REMOTE_CLIENT_NONE (0) представляет значение по умолчанию Microsoft Windows Server™ 2003 с пакетом обновления 1. Параметры значения по умолчанию приводят к тому, что система обходит ограничение интерфейса RPC.

Значение по умолчанию соответствует значению RPC_RESTRICT_REMOTE_CLIENT_NONE. Приложение сервера отвечает за применение соответствующих ограничений RPC. Значение по умолчанию равняется значению RestrictRemoteClients в более ранних версиях Windows.

1

Значение 1 в разделе реестра RestrictRemoteClients является значением по умолчанию в Microsoft Windows® XP с пакетом обновлений 2. Значение 1 ограничивает доступ ко всем интерфейсам RPC. Все удаленные анонимные вызовы отклоняются подсистемой RPC.

Данное значение соответствует значению RPC_RESTRICT_REMOTE_CLIENT_DEFAULT. Если интерфейс регистрирует обратный вызов безопасности и обеспечивает флаг RPC_IF_ALLOW_CALLBACKS_WITH_NO_AUTH, к нему не применимо данное ограничение.

2

Значение 2 раздела реестра RestrictRemoteClients означает, что все без исключения удаленные анонимные вызовы отклоняются подсистемой RPC.

Данное значение соответствует значению RPC_RESTRICT_REMOTE_CLIENT_HIGH. Если в качестве значения RestrictRemoteClientsустановлено 2, система не принимает удаленные анонимные вызовы с использованием RPC.

Для получения дополнительных сведений об изменения в службе RPC в пакете обновление 2 Windows XP Service см. статью MSDN® «Ограничения интерфейса RPC» (http://go.microsoft.com/fwlink/?LinkId=47371).


Сервер RFR назначения переопределен вручную
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, была ли служба Directory Services Proxy Referral (DSProxy referral) переопределена вручную, средство анализа Microsoft® Exchange Server считывает следующий параметр реестра на сервере Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\RFR Target Server

Если средство анализа Exchange Server обнаруживает, что параметр RFR Target Server существует и настроен, отображается сообщение о нестандартной настройке.

При первом подключении к компьютеру, использующему Exchange 2000 Server или Exchange Server 2003, клиент Microsoft Outlook® 2000 Service Release 2 (SR-2) или более поздней версии ищет службу каталога на своем сервере Exchange. Во время первой сессии Outlook проходит обработку DSProxy. После соединения клиента со службой DSProxy клиенту передается ссылка DSProxy, оповещающая о том, что все последующие запросы к каталогам должны передаваться к серверу глобального каталога. Outlook записывает ссылку на данные DSProxy в профиль MAPI в реестре.

Механизм ссылок DSProxy уменьшает нагрузку на сервер Exchange и задержку при поиске в адресной книге. Если в профиль явно введено имя сервера, при сбое этого сервера глобального каталога Outlook должен перезапуститься. При этом сервер Exchange отправляет Outlook новую ссылку.

В некоторых ситуациях может быть полезно жестко закодировать запись RFR Target Server для указания серверов, которые должны использоваться службой ссылок клиентов MAPI. Например, за неделю до понижения статуса сервера глобальных каталогов до рядового сервера жестко закодируйте запись RFR Target Server, чтобы определить группу серверов глобального каталога. При этом гарантируется, что ссылок на сервер глобального каталога, статус которого понижается, не будет в профилях MAPI клиентов Outlook. Для получения дополнительных сведений об использовании параметра реестра RFR Target Server см. статью 305065 базы знаний Microsoft «XADM: Советы по понижению статуса сервера глобальных каталогов до контроллера доменов в Exchange Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=305065).

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Для получения сведений о восстановлении реестра см. раздел справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Использование параметра реестра RFR Target Server

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите по адресу: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Создайте новый параметр типа REG_MULTISZ и назовите его RFR Target Server.

  4. Запишите значение RFR Target Server, равное полному доменному имени сервера или серверов, которые вы хотите указать.

  5. Закройте редактор реестра и перезапустите службу Microsoft Exchange System Attendant для того, чтобы изменения вступили в силу.

Для отмены статического параметра для сервера RFR удалите полное доменное имя сервера, который нужно удалить. Если введено имя только одного сервера RFR, удалите параметр реестра RFR Target Server.

Перед правкой реестра, а также для получения дополнительных сведений обратитесь к статье 256986 базы знаний Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Для получения дополнительных сведений о взаимодействии клиентов Outlook 2000 SR-2 и более поздних версий со службой каталогов Active Directory® см. следующие статьи базы знаний Майкрософт:

  • 302914, «XCCC: Доступ Outlook 2000 к Active Directory» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914)

  • 256976, "XCLN: Доступ клиентов MAPI к Active Directory» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976)


В текущий момент включена трассировка RegTrace
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, включена ли на компьютере Exchange Server расширенная диагностическая трассировка, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\MosTrace\CurrentVersion\DebugAsyncTrace\EnabledTraces

Если анализатор сервера Exchange обнаруживает наличие записи реестра EnabledTraces, которая имеет значение, отличное от 0, выводится сообщение об ошибке.

Расширенная диагностическая трассировка компонентов транспортировки и маршрутизации сервера Exchange выполняется с использованием служебной программы Regtrace (Regtrace.exe). Программа Regtrace особенно полезна для выполнения диагностики и устранения неполадок в отношении отчетов о недоставке. Служебная программа Regtrace находится на компакт-диске Exchange Server в папке \Support\Utils\I386.

Файл трассировки доступен в местоположении, указанном на вкладке Output окна служебной программы Regtrace. Местоположение данного файла по умолчанию — C:\Trace.atf. Файл трассировки является двоичным файлом, который одержит сведения отладке о трассируемых компонентах транспортировки и маршрутизации. В связи с этим службы поддержки продуктов Майкрософт просят своих клиентов направлять файлы трассировки для внутреннего анализа.

Корпорация Майкрософт предупреждает, что включение трассировки Regtrace приводит к существенному падению производительности сервера. Эта трассировка должна использоваться только для устранения неполадок в течение непродолжительного времени под пристальным руководством служб поддержки продуктов Майкрософт. Помимо воздействия на производительность, в ходе трассировки файла трассировки каждую минуту увеличивается более чем на 10 мегабайт (МБ). Чтобы решить эту проблему, следует отключить трассировку с помощью программы Regtrace, если не выполняется устранение неполадки.

Чтобы отключить расширенную диагностическую трассировку с помощью программы Regtrace

  1. Скопируйте файл Regtrace.exe с компакт-диска Exchange Server на компьютер Exchange Server.

  2. Выполните программу Regtrace.exe на компьютере Exchange Server. Появится интерфейс пользователя программы Regtrace.

  3. Снимите все флажки на вкладке Трассировка.

  4. Перейдите на вкладку Выходные данные и выберите параметр Без трассировки.

  5. Нажмите кнопку ОК, чтобы сохранить внесенные изменения и закрыть служебную программу Regtrace.
  • Дополнительные сведения о средстве Regtrace см. в статье 238614 базы знаний Майкрософт, в которой приведены инструкции по настройке Regtrace для Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=238614).

  • Дополнительные сведения об устранении неполадок обмена сообщениями см. в статье 281800 базы знаний Майкрософт об устранении сбоев доставки сообщений в Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=281800).


Rejection threshold not configured
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-07-30

Анализатор Microsoft Exchange запрашивает у службы каталогов Active Directory значения указанных ниже атрибутов всех объектов класса ContentFilterConfig.

msExchAgentsFlags Значение атрибута msExchAgentsFlag определяет состояние агента фильтра содержимого Microsoft Exchange Server 2007 и действие отклонения вероятных нежелательных сообщений электронной почты. Когда на компьютере включен агент фильтра содержимого, он фильтрует все сообщения, поступающие через все соединители приема на этом компьютере. Если включено действие отклонения вероятных нежелательных сообщений электронной почты, в ходе сеанса SMTP в ответ на все сообщения, для которых вероятность нежелательной почты превышает пороговое значение, отправляется ответ, отклоняющий сообщение.

msExchMessageHygieneSCLRejectThreshold Значение атрибута msExchMessageHygieneSCLRejectThreshold определяет уровень действия отклонения вероятных нежелательных сообщений электронной почты. Это значение соответствует рейтингу вероятности нежелательной почты, который конкретное сообщение должно превысить, чтобы агент фильтра содержимого отклонил сообщение и послал отправителю отчет о недоставке.

Кроме того, с помощью следующего командлета командной консоли Exchange анализатор Exchange запрашивает сведения обо всех ролях транспортного сервера-концентратора с установленными агентами защиты от нежелательной почты:

Get-TransportServer | where { $_.AntispamAgentsEnabled -eq $True}

Если анализатор сервера Exchange выясняет, что на сервере выполняются все указанные ниже условия, он выводит предупреждение.

  • Включена фильтрация содержимого.

  • Включено действие отклонения вероятных нежелательных сообщений электронной почты.

  • Пороговое значение отклонения вероятных нежелательных сообщений электронной почты равняется 9.

  • На сервере включены агенты защиты от нежелательной почты.

Данное предупреждение свидетельствует о том, что, хотя фильтрация содержимого и действие отклонения вероятных нежелательных сообщений электронной почты включены, порог отклонения вероятных нежелательных сообщений имеет значение по умолчанию, равное 9. При этом значении могут отклоняться сообщения, отправленные легальными пользователями. Порогу отклонения вероятных нежелательных сообщений электронной почты рекомендуется присвоить значение 7.

Чтобы устранить причины появления данного предупреждения, присвойте порогу отклонения вероятных нежелательных сообщений электронной почты значение 7 на вкладке «Защита от нежелательной почты» в консоли управления Exchange или с помощью командлета Set-ContentFilterConfig в командной консоли Exchange.

Чтобы настроить порог отклонения вероятных нежелательных сообщений электронной почты, следуйте инструкциям, приведенным в документации по Exchange Server 2007 в разделе «Включение и настройка пороговых значений вероятности нежелательной почты» (http://go.microsoft.com/fwlink/?LinkId=96099).

Дополнительные сведения

Дополнительные сведения об управлении реализованными в Exchange Server 2007 средствами защиты от нежелательной почты и вирусов см. в документации по Exchange Server 2007 в разделе «Управление средствами защиты от нежелательной почты и вирусов» (http://go.microsoft.com/fwlink/?LinkId=96103).


Служба Recipient Update удалена
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-04-20

Средство анализа Microsoft® Exchange Server запрашивает службу каталога Active Directory®, чтобы определить значение атрибута msExchAddressListServiceLink для каждого объекта службы Recipient Update в каталоге. Атрибут msExchAddressListServiceLink является ссылкой из службы списка адресов на компьютер Exchange Server, на котором она должна работать. Если средство анализа Exchange Server обнаружит, что для атрибута msExchAddressListServiceLink установлено значение DEL:, появится сообщение об ошибке.

Каждый экземпляр службы Recipient Update связан с одним компьютером Exchange Server, на котором работает служба Recipient Update. Если появляется такое сообщение, это означает, что экземпляр службы Recipient Update связан с компьютером Exchange Server, который в организации Exchange не существует. Возможно, сервер был списан или каким-либо другим образом удален из топологии.

Чтобы запустить данный экземпляр службы Recipient Update, необходимо связать его с существующим сервером Exchange.

Устранение ошибки

  1. Запустите системный диспетчер Exchange.

  2. В разделе Получатели щелкните Службы Recipient Update. В правой панели щелкните правой кнопкой мыши соответствующий экземпляр службы Recipient Update и выберите Свойства.

  3. На вкладке Общие, в разделе Exchange Server, нажмите кнопку Обзор и укажите новый компьютер для запуска данного экземпляра службы.

  4. Нажмите кнопку OK, а затем нажмите кнопку OK еще раз, чтобы изменения вступили в силу.

  5. Закройте системный диспетчер Exchange.

Для получения дополнительных сведений о службе Recipient Update см. следующие разделы, посвященные Exchange, и статьи базы знаний корпорации Майкрософт:

  • Раздел об управлении получателями и политиками получателей в документе Руководство по администрированию Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47617)

  • 328738, «XADM: применение политики получателей службой Recipient Update» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828, «Заполнение списков адресов службой Recipient Update» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127, «XADM: Проверка работы службы Recipient Update» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770, «XADM: Задачи, выполняемые службой Recipient Update» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


Привязка удаленных вызовов процедур не содержит полного имени домена
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, содержит ли значение ncacn_ip_tcp атрибута networkAddress полное имя домена (FQDN). Если анализатор сервера Exchange обнаруживает, что значение ncacn_ip_tcp не содердит точку (.), анализатор сервера Exchange выводит ошибку.

В веб-клиенте Microsoft Office Outlook® для Exchange Server 2003 сервер переднего плана при попытке подключения к фоновому серверу Exchange проверяет значение атрибута networkaddress.

Примечание.
Веб-клиент Outlook для Exchange 2000 Server такими возможностями не обладает. Серверу переднего плана требуется полное доменное имя.

Сервер переднего плана проверяет наличие точки в значении, возвращаемом для networkaddress ncacn_ip_tcp. Запрос подключения к почтовому ящику на конкретном фоновом сервере заканчивается неудачей, а сервер переднего плана возвращает пользователю сообщение об ошибке «HTTP 500 Внутренняя ошибка сервера» при возникновении следующих условий:

  • Значение ncacn_ip_tcp представляет собой только имя узла или имя сетевой базовой системы ввода-вывода (NetBIOS).

  • Значение ncacn_ip_tcp не является полным именем домена.

Чтобы гарантировать правильную работу веб-клиента Outlook для Exchange Server 2003, необходимо изменить значение ncacn_ip_tcp для объекта сервера в службе Active Directory. Результат работы анализатора Exchange содержит имя затрагиваемого сервера.

Внимание!
Если некорректно изменить атрибуты объектов Active Directory с помощью средства ADSI Edit (Active Directory Service Interfaces, ADSI), средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3, то могут возникнуть серьезные проблемы. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Примечание.
Перед изменением значения ncacn_ip_tcp ознакомьтесь с оставшейся частью этой статьи. Перед перезапуском служб сервера Exchange может понадобиться выполнить дополнительные процедуры.
Изменение значения ncacn_ip_tcp атрибута networkAddress

  1. Запустите средство ADSI Edit из средств поддержки Windows 2000 Server или из средств поддержки Windows Server 2003.

  2. Разверните следующие узлы:

    • Контейнер конфигурации

    • Конфигурация

    • Службы

    • Microsoft Exchange

    • Имя_организации

    • Административные группы

    • Имя_административной_группы

    • Серверы

  3. Щелкните правой кнопкой мыши имя_сервера_Exchange и в контекстном меню выберите команду Свойства.

  4. Щелкните networkaddress в списке Атрибуты, а затем нажмите кнопку Изменить.

  5. Добавьте новое значение ncacn_ip_tcp. Используйте для сервера полное имя домена (FQDN) вместо имени компьютера или имени NetBIOS.

    Для этого значения используется следующий синтаксис: ncacn_ip_tcp:FQDN. Например, если компьютер фонового сервера Exchange имеет имя EXCHANGE1, а полное имя домена — EXCHANGE1.contoso.com, используйте для ncacn_ip_tcp следующее значение: ncacn_ip_tcp:EXCHANGE1.contoso.com.

  6. Удалите исходное значение ncacn_ip_tcp, содержащее имя NetBIOS или имя компьютера для фонового сервера, выбрав исходное значение и нажав кнопку Удалить. Нажмите два раза кнопку OK, чтобы принять изменения.

  7. Перезапустите на компьютере все службы сервера Exchange.

  8. При наличии нескольких контроллеров домена дождитесь репликации, прежде чем пытаться подключиться с сервера переднего плана. Если проблема сохраняется после завершения репликации, перезапустите на сервере переднего плана службу IIS Admin Service.

Если на фоновых серверах, чтобы связать IP-адрес сервера и короткое имя компьютера, используется файл Hosts, необходимо также изменить значение реестра UpdateProtocols. Если используется файл узлов, сервер Exchange при перезапуске системного помощника Microsoft Exchange может вернуть значение ncacn_ip_tcp. Если для фонового сервера используется кластер, сервер Exchange может вернуть значение ncacn_ip_tcp после перехода на другой узел кластера.

Чтобы минимизировать простой, который может быть вызван перезапуском служб сервера Exchange, перед перезапуском служб сервера Exchange выполните следующую процедуру, изменяя значение ncacn_ip_tcp атрибута networkaddress, как описано в предыдущей процедуре.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Изменение значение реестра UpdateProtocols для фоновых серверов, использующих файлы узлов Hosts

  1. С помощью редактора реестра настройте на фоновых серверах следующее значение реестра: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\UpdateProtocols

    Примечание.
    Если значение UpdateProtocols отсутствует, его необходимо создать. Для этого выполните следующие действия:
    1. Откройте редактор реестра и найдите следующий подраздел реестра: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\

    2. Щелкните правой кнопкой мыши Параметры, наведите указатель на пункт Создать и выберите Значение DWORD.

    3. Введите UpdateProtocols и затем нажмите клавишу ВВОД.

  2. Щелкните правой кнопкой мыши UpdateProtocols, выберите в контекстном меню Изменить, введите 0 в поле Значение и нажмите кнопку OK.

  3. Если на узле фонового кластера в сети используется файл узлов, измените порядок UpdateProtocols записи следующим образом:

    IPAddress to FQDN

    IPAddress to NetBIOS

    вместо:

    IPAddress to NetBIOS

    IPAddress to FQDN

  4. Перезапустите на сервере все службы сервера Exchange.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт, посвященную описанию реестра Microsoft Windows, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Привязка удаленного вызова процедуры не соответствует разрешенному DNS-имени
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-03-21

Анализатор сервера Microsoft® Exchange пытается выполнить запрос в системе доменных имен (DNS) относительно DNS-серверов, настроенных для каждого компьютера с сервером Exchange. Это подключение устанавливается с помощью обработчика пользовательских объектов, который выполняет запрос на разрешение имени и анализирует его результаты. Анализатор сервера Exchange также опрашивает службу каталогов Active Directory®, чтобы определить, отличается ли значение ncacn_ip_tcp данного сервера в атрибуте networkAddress от полного доменного имени, возвращенного в результате разрешения DNS. Атрибут networkAddress имеется у каждого объекта сервера Exchange в Active Directory. Если анализатор сервера Exchange обнаружит, что значение ncacn_ip_tcp данного сервера в Active Directory не совпадает с полным доменным именем после разрешения DNS, выдается предупреждение.

Подобная ситуация возникает, если полное доменное имя сервера изменяется после установки Exchange. Для нормальной работы сервера Exchange и службы Active Directory необходимо правильно настроить систему DNS и обеспечить ее работоспособность. Проблемы регистрации в DNS и разрешения доменных имен могут существенно повлиять на возможности отправки, получения и доставки сообщений на компьютере с сервером Exchange. Проблем можно избежать, сделав два адреса одинаковыми; для этого следует вручную изменить атрибут networkAddress объекта сервера Exchange в Active Directory.

Необходимо обновить значение ncacn_ip_tcp для объекта сервера в Active Directory так, чтобы значение ncacn_ip_tcp совпало с полным доменным именем сервера. В выходных данных анализатора сервера Exchange указывается имя затрагиваемого сервера.

Внимание!
Некорректное изменение атрибутов объектов Active Directory при использовании оснастки Edit интерфейса ADSI (Active Directory Service Interfaces), программы LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3 может вызвать серьезные проблемы. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, а также сервера Exchange Server 2003, сервера Exchange Server 2007 или обоих продуктов. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Чтобы обновить значение ncacn_ip_tcp в атрибуте networkAddress

  1. Запустите ADSI Edit из средств поддержки Windows® 2000 или из средств поддержки Windows Server 2003.

  2. Разверните следующие узлы:

    • Контейнер конфигурации

    • Конфигурация

    • Службы

    • Microsoft Exchange

    • Имя_организации

    • Административные группы

    • Имя_административной_группы

    • Серверы

  3. Щелкните правой кнопкой мыши узел Имя_сервера_Exchange и выберите команду Свойства.

  4. Щелкните networkaddress в списке Атрибуты и нажмите кнопку Изменить.

  5. Добавьте новое значение для ncacn_ip_tcp. Укажите полное доменное имя сервера вместо текущего значения.

    Для этого значения используется следующий синтаксис: ncacn_ip_tcp:полное_доменное_имя. Например, если серверу Exchange назначено имя узла EXCHANGE1 и полное доменное имя EXCHANGE1.contoso.com, используйте для ncacn_ip_tcp следующее значение: ncacn_ip_tcp:EXCHANGE1.contoso.com.

  6. Удалите первоначальное значение ncacn_ip_tcp, содержащее неправильное имя сервера: выделите это значение и нажмите кнопку Удалить. Нажмите кнопку ОК два раза, чтобы сохранить изменения.

  7. Перезапустите все службы сервера Exchange на данном сервере.

Дополнительные сведения об использовании DNS вместе с Active Directory см. в статье 323418 базы знаний Майкрософт, содержащей инструкции по интеграции DNS в существующую инфраструктуру DNS при включенной поддержке Active Directory в Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=323418).


Неверный порядок привязки удаленных вызовов процедур
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить порядок привязки удаленных вызовов процедур, который используется сервером Exchange, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Svr_Binding_Order

Если анализатор сервера Exchange обнаруживает, что значение записи Rpc_Svr_Binding_Order не начинается со строки ncacn_ip_tcp, выводится сообщение об ошибке.

Запись реестра Rpc_Svr_Binding_Order создается в процессе установки сервера Exchange на компьютере. Эта запись определяет последовательность протоколов, которые используются при обмене данными между серверами в ходе удаленных вызовов процедур.

По умолчанию запись Rpc_Svr_Binding_Order содержит следующие данные:

ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp

Примечание.
Строка может содержать дополнительные значения, если на сервере Exchange установлены и другие протоколы.

Эта запись определяет порядок, в котором сервер Exchange использует сетевые протоколы связи для обмена данными с другими серверами при удаленных вызовах процедур. Например, если первым указан протокол TCP/IP, сервер Exchange будет пытаться установить связь с другими серверами при удаленном вызове процедуры в первую очередь с использованием протокола TCP/IP, а затем уже по другим протоколам.

Не рекомендуется менять для порядка привязки удаленных вызовов процедур заданное по умолчанию значение. Если значение по умолчанию изменено, это может вызвать проблемы при запуске сервера или службы, а также в процессе обмена данными между серверами.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы устранить эту ошибку

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\Software\Microsoft\Exchange\Exchange Provider

  3. В правой области дважды щелкните Rpc_Svr_Binding_Order.

  4. В диалоговом окне Значение введите ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp.

  5. Нажмите кнопку ОК и закройте редактор реестра.

  6. Перезапустите все службы сервера Exchange или перезапустите компьютер сервера Exchange, чтобы изменения вступили в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения о порядке привязки удаленных вызовов процедур см. в статье 325930 базы знаний «How to troubleshoot connectivity issues that are caused by RPC client protocol registry entries» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325930) (Инструкции по устранению неполадок при подключении, вызванных записями реестра протокола клиента удаленных вызовов процедур).


Раздел реестра Rpc_Binding_Order не существует
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра, чтобы проверить существование раздела реестра, предназначенного для порядка привязки удаленного вызова процедур для клиента, на компьютере сервера Exchange:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Binding_Order

Если анализатор сервера Exchange обнаружит раздел Rpc_Binding_Order, будет отображено предупреждение.

Если существует значение Rpc_Binding_Order, это обозначает, что одна или несколько из следующих программ установлена на компьютере:

  • Exchange Server версии 5.5;

  • Microsoft Office Outlook® 2003;

  • Служба кластеров Windows.

  • С помощью раздела RPC_Binding_Order определяется последовательность протоколов, используемая при запуске удаленного вызова процедур в Outlook. Этот раздел не создается на серверах Exchange Server 2003 или Exchange 2000. Запись эта создается только на серверах Exchange Server 5.5 и более ранних версий Exchange. Если Exchange Server 5.5 или Microsoft Outlook уже были установлены на компьютере, но были удалены, этот раздел можно удалить вручную. Кроме того, необходимо удалить Outlook с любого компьютера, на котором работает сервер Exchange, так как такая конфигурация не поддерживается. Дополнительные сведения о работе Exchange и Outlook на одном компьютере см. в статье 266418 базы данных Майкрософт, посвященной рекомендации Майкрософт не устанавливать сервер Exchange и Outlook на одном компьютере (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266418).

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы удалить раздел реестра Rpc_Binding_Order

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\Software\Microsoft\Exchange\Exchange Provider

  3. Удалите значение Rpc_Binding_Order.

  4. Закройте редактор реестра и перезапустите все службы сервера Exchange или перезагрузите компьютер сервера Exchange, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о разделе реестра RPC_Binding_Order см. в следующих статьях базы знаний:

  • 325930, описывающая устранение неполадок с подключениями, вызванные разделами реестра, посвященными клиентскими протоколами удаленного вызова процедур (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325930);

  • 326036, посвященная невозможности войти в систему на компьютере сервера Exchange 2000, используя верные учетные данные (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326036).


Значение параметра реестра «Rpc_Svr_Binding_Order» отличается от заданного по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить порядок привязки удаленных вызовов процедур, который используется сервером Exchange, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Svr_Binding_Order

Если анализатор сервера Exchange обнаруживает, что параметр Rpc_Svr_Binding_Order имеет значение, отличное от значения ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp, выводится сообщение об ошибке.

Запись реестра Rpc_Svr_Binding_Order создается при установке сервера Exchange на компьютер. Эта запись определяет последовательность протокола, которая используется при обмене данными между серверами в ходе удаленных вызовов процедур.

По умолчанию запись Rpc_Svr_Binding_Order содержит следующие данные:

ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp

Примечание.
Строка может содержать дополнительные значения, если на компьютере Exchange Server установлены и другие протоколы.

Эта запись определяет порядок, в котором сервер Exchange использует сетевые протоколы связи для обмена данными с другими серверами при удаленных вызовах процедур. Например, если первым указан протокол TCP/IP, сервер Exchange будет пытаться установить связь с другими серверами при удаленном вызове процедуры в первую очередь с использованием протокола TCP/IP, а затем уже по другим протоколам.

Корпорация Майкрософт не рекомендует менять заданное по умолчанию значение для порядка привязки удаленных вызовов процедур. Если значение по умолчанию изменено, это может привести к возникновению проблем при запуске сервера или службы, а также в процессе обмена данными между серверами.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы устранить эту ошибку

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\Software\Microsoft\Exchange\Exchange Provider

  3. В правой области дважды щелкните Rpc_Svr_Binding_Order.

  4. В диалоговом окне Значение введите ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp.

  5. Нажмите кнопку ОК и закройте редактор реестра.

  6. Перезапустите все службы сервера Exchange или перезапустите компьютер сервера Exchange, чтобы изменения вступили в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения о порядке привязки удаленных вызовов процедур см. в статье 325930 базы знаний «How to troubleshoot connectivity issues that are caused by RPC client protocol registry entries» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325930) (Инструкции по устранению неполадок при подключении, вызванных записями реестра протокола клиента удаленных вызовов процедур).


Общая задержка при обращении к серверу Active Directory составляет более 100 мс
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-03-16

Анализатор сервера Exchange опрашивает WMI-класс (Microsoft Windows® Management Instrumentation) WIN32_PingStatus в пространстве имен root\cimv2, чтобы определить значение ключа ResponseTime. Если анализатор сервера Exchange обнаружит, что значение ключа ResponseTime превышает 100 миллисекунд (мс), на экран будет выведено сообщение об ошибке.

Ключ ResponseTime представляет время (в миллисекундах) с момента ICMP-запроса (Internet Control Message Protocol) отклика до получения ответа. Контроллеры доменов, используемые компьютером сервера Exchange, всегда должны иметь время отклика не более 10 мс. Если время отклика превышает 100 мс, это может указывать на проблемы с производительностью или связью.

Чтобы устранить эту ошибку

  1. Убедитесь, что рассматриваемый контроллер домена не подвержен избыточной нагрузке. С помощью средства ADTest.exe протестируйте контроллер домена и определите, может ли его оборудование обрабатывать ожидаемую нагрузку.

  2. Проверьте журналы событий на сервере Exchange и контроллере домена на наличие сетевых событий, отражающих появление одной или нескольких проблем.

  3. Выполните на контроллере домена команды DCDiag.exe и NetDiag.exe, чтобы проверить его работоспособность и правильность конфигурации.

  4. Проверьте структуру узла службы каталогов Active Directory®. Сайт Active Directory считается частью сети с высокой пропускной способностью и низкими задержками. Если сеть не разделена в соответствии с такой спецификацией, изучите возможность разделения сети на несколько дополнительных узлов Active Directory.
Примечание.
Когда анализатор выполняет WMI-запрос для проверки отклика, переопределяются заданные по умолчанию значения размера пакета и времени ожидания. В анализаторе используются ICMP-пакеты размером 4096 байт (вместо стандартного размера 32 байта) и время ожидания 2000 мс (вместо указанных по умолчанию 1000 мс).

Выполните следующие шаги, чтобы вручную воссоздать поведение анализатора при проверке отклика.

Чтобы вручную выполнить проверку отклика

  • Запустите в окне командной строки сервера Exchange следующую команду:ping -L 4096 -N 6 <Active Server server name>Примечание. Команда выдает шесть ping-запросов, каждый запрос длиной 4096 байтов.

Дополнительные сведения о средстве ADTest.exe см. на веб-узле средства (ADTest.exe) тестирования производительности службы Active Directory (http://go.microsoft.com/fwlink/?LinkId=33758).

Дополнительные сведения о WMI-классе Win32_PingStatus см. в статье MSDN®, посвященной WMI-классу «Win32_PingStatus» (http://go.microsoft.com/fwlink/?LinkId=33549).

Дополнительные сведения о структуре узла Active Directory см. в описании разработки топологии узла (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=33551).


Время приема-передачи сервера Active Directory превышает 10 мс
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-03-16

Средство анализа Microsoft® Exchange Server запрашивает класс инструментария Microsoft Windows® Management Instrumentation (WMI) WIN32_PingStatus пространства имен root\cimv2, чтобы определить значение параметра ResponseTime. Если средство анализа Exchange Server обнаруживает, что значение параметра ResponseTime больше 10 миллисекунд (мс), но меньше 100 мс, отображается предупреждение.

Параметр ResponseTime соответствует времени (в миллисекундах), затраченному на ответ на пакеты эхо запросов (проверки связи) протокола ICMP, отправленные с сервера Exchange контроллеру домена. Время ответа контроллера домена, используемого сервером Exchange Server, всегда меньше или равен 10 мс. Если время ответа превышает 10 мс, это может быть связано с проблемами быстродействия или подключения.

Для устранения этого предупреждения

  1. Убедитесь, что данный контроллер домена не перегружен. Чтобы выяснить, справится ли оборудование с ожидаемыми нагрузками, воспользуйтесь средством ADTest.exe для проверки контроллера домена.

  2. Проверьте, были ли в журнале событий Exchange server или контроллера домена зарегистрированы сетевые события, указывающие на одну или более неполадок.

  3. Чтобы настроить нужную конфигурацию и работоспособность, примените к контороллеру домена команды DCDiag.exe и NetDiag.exe.

  4. Наконец, проверьте оформление сайта службы каталогов Active Directory®. Сайт Active Directory считается сетевым разделом с высокой пропускной способностью и малой задержкой. Если сеть не разделена в соответствии с этими спецификациями, попробуйте разделить сеть еще на несколько сайтов Active Directory.
Примечание.
При запуске запроса WMI на проверку связи средством анализа размер пакета по умолчанию и значения таймаутов переопределяются. Вместо этого средство анализа подставляет значение размера пакета 4096 ICMP (вместо указанных по умолчанию 32 байт) и значение таймаута, равное 2000 мс (вместо указанных по умолчанию 1000 мс).

Чтобы вручную повторить действия средства анализа при проверки связи, выполните следующие шаги:

Чтобы вручную выполнить проверку связи

  • Запустите следующую команду в командной строке Exchange server:ping -L 4096 -N 6 <Active Server server name>Примечание Команда выполняет шесть запросов проверки связи по 4096 байт каждый.

Дополнительные сведения о средстве ADTest.exe см. на веб-узле Active Directory Performance Testing Tool (ADTest.exe) (http://go.microsoft.com/fwlink/?LinkId=33758).

Дополнительные сведения о Win32_PingStatus класса WMI, см. в статье MSDN® «Win32_PingStatus» (http://go.microsoft.com/fwlink/?LinkId=33549).

Дополнительные сведения об оформлении сайта Active Directory см. в статье «Топология оформления сайта» (http://go.microsoft.com/fwlink/?LinkId=33551).


Двусторонние задержки до сервера глобального каталога составляют более 100 миллисекунд
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-03-16

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) WIN32_PingStatus в пространстве имен root\cimv2, чтобы определить значение ключа ResponseTime. Если анализатор сервера Exchange обнаружит, что значение ключа ResponseTime больше 100 миллисекунд (мс), на экран будет выведено сообщение об ошибке.

Ключ ResponseTime представляет собой время (в миллисекундах) между откликом и эхо-запросом ICMP (Internet Control Message Protocol), посланным с сервера Exchange на сервер глобального каталога. Время отклика серверов глобального каталога, используемых компьютером сервера Exchange, всегда не должно превышать 10 мс. Если время отклика больше 10 мс, возможно наличие проблем с производительностью или соединениями.

Чтобы устранить эту ошибку

  1. Проверьте, чтобы нагрузка на используемый сервер глобального каталога не была чрезмерной. Используйте средство ADTest.exe, чтобы выполнить проверки сервера глобального каталога и убедиться, что оборудование может обрабатывать ожидаемую нагрузку.

  2. Проанализируйте журналы событий на сервере Exchange и сервере глобального каталога, чтобы проверить в журналах наличие событий, связанных с работой сети, которые указывают на одну или более проблем.

  3. Используйте команды DCDiag.exe и NetDiag.exe на сервере глобального каталога, чтобы убедиться в исправности оборудования и правильности настройки.

  4. Наконец, проанализируйте структуру узла службы каталогов Active Directory®. Считается, что узел Active Directory является частью сети, которая обладает большой пропускной способностью и малыми задержками. Если сеть не разделена в соответствии с этой спецификацией, рассмотрите возможность разделения сети на большее число узлов Active Directory.
Примечание.
Когда средство анализатора выполняет WMI-запрос для проверки прохождения ping-запроса, значения по умолчанию для размера пакета и тайм-аута переопределяются. Вместо них анализатор использует ICMP-пакет размером 4096 (вместо 32 байтов по умолчанию) и значение тайм-аута 2000 мс (вместо 100 мс по умолчанию).

Выполните эти шаги, чтобы эмулировать вручную поведение ping-запроса анализатора.

Чтобы выполнить проверку ping-запроса вручную

  • Выполните следующую команду в окне командной строки на сервере Exchange:ping -L 4096 -N 6 <Active Server server name>Примечание. Команда запускает шесть ping-запросов, каждый длиной 4096 байтов.

Дополнительные сведения о средстве ADTest.exe см. на веб-узле, посвященном средству (ADTest.exe) проверки производительности службы Active Directory (http://go.microsoft.com/fwlink/?LinkId=33758).

Дополнительные сведения о WMI-классе Win32_PingStatus см. в статье MSDN®, «Win32_PingStatus» (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=33549).

Дополнительные сведения о структуре узлов Active Directory см. в описании принципов разработки топологии узлов (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=33551).

Сведения об установке средств поддержки Windows 2000 Server см. в базе знаний Майкрософт в статье 301423, описывающей инструкции по установке средств поддержки Windows 2000 на компьютер под управлением Windows 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301423).

Сведения об установке средств поддержки Windows Server 2003 см. в статье, описывающей установку средств поддержки Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=41362).


Общая задержка при обращении к серверу глобального каталога составляет более 10 мс
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-03-16

Анализатор сервера Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) WIN32_PingStatus в пространстве имен root\cimv2, чтобы определить значение ключа ResponseTime. Если анализатор сервера Exchange обнаруживает, что значение ключа ResponseTime превышает 10 миллисекунд (мс), но меньше 100 мс, выводится предупреждение.

Ключ ResponseTime указывает время (в миллисекундах) до отклика на ICMP-пакеты запроса отзыва, направленные сервером Exchange серверу глобального каталога. Время отклика для серверов глобального каталога, используемых на компьютере Exchange Server, не должно превышать 10 миллисекунд. Если время отклика превышает 10 миллисекунд, могут возникнуть проблемы производительности или доступности.

Чтобы устранить причину появления этого предупреждения

  1. Убедитесь, что соответствующий сервер глобального каталога не перегружен. С помощью средства ADTest.exe протестируйте сервер глобального каталога и определите, может ли его оборудование справиться с ожидаемой нагрузкой.

  2. Проверьте журналы событий на сервере Exchange и сервере глобального каталога на наличие сетевых событий, отражающих появление одной или нескольких проблем.

  3. Выполните на сервере глобального каталога средства командной строки DCDiag.exe и NetDiag.exe, чтобы проверить его работоспособность и правильность конфигурации.

  4. Проверьте структуру сайта службы каталогов Active Directory®. Сайт Active Directory считается частью сети с высокой пропускной способностью и низкими задержками. Если сеть не разделена в соответствии с такой спецификацией, изучите возможность разделения сети на несколько дополнительных сайтов Active Directory.
Примечание.
Когда анализатор выполняет WMI-запрос для проверки отклика, переопределяются заданные по умолчанию значения размера пакета и времени ожидания. В анализаторе используются ICMP-пакеты размером 4096 байт (вместо стандартного размера 32 байта) и время ожидания 2000 мс (вместо указанных по умолчанию 1000 мс).

Выполните следующие шаги, чтобы вручную воссоздать поведение анализатора при проверке отклика.

Чтобы вручную выполнить проверку отклика

  • Выполните в окне командной строки сервера Exchange следующую команду:

    ping -L 4096 -N 6 <Active Server server name>

    Примечание.
    При выполнении этой команды направляются шесть запросов на отклик размером 4096 байт каждый.

Дополнительные сведения о средстве ADTest.exe см. на веб-узле «Active Directory Performance Testing Tool (ADTest.exe)» (http://go.microsoft.com/fwlink/?LinkId=33758) (Средство тестирования производительности Active Directory — ADTest.exe).

Дополнительные сведения о WMI-классе Win32_PingStatus см. в статье MSDN® «Win32_PingStatus» (http://go.microsoft.com/fwlink/?linkid=33549) (Класс Win32_PingStatus).

Дополнительные сведения о структуре сайта Active Directory см. в документе «Designing the Site Topology» (http://go.microsoft.com/fwlink/?linkid=33551) (Определение топологии сайта).


Требуется изменить фильтр поиска для политики получателей
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-02-21

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута purportedSearch для всех объектов получателей политики Exchange. Атрибут purportedSearch указывает аргумент поиска, который используется при применении данной политики.

Анализатор сервера Exchange также запрашивает Active Directory, чтобы определить значение атрибута msDS-Behavior-Version объекта леса в параметрах NTDS Active Directory. Это значение отражает функциональный уровень леса Active Directory. Допустимые значения атрибута msDS-Behavior-Version показаны в следующей ниже таблице.

Значение | Функциональный уровень леса
0 | Смешанный сервер Microsoft Windows® 2000 Server
1 | Промежуточный сервер Microsoft Windows Server™ 2003
2 | Основной сервер Windows Server 2003

Анализатор сервера Exchange также запрашивает Active Directory, чтобы определить значение атрибута revision контейнера Windows2003Update. Значение этого атрибута указывает, было ли выполнено средство подготовки Active Directory (ADPrep.exe).

В последнюю очередь анализатор сервера Exchange Server запрашивает WMI-класс Win32_OperatingSystem , чтобы определить значение ключа OSProductSuite. Значение ключа OSProductSuite указывает версию ОС Windows, под управлением которой работает компьютер.

Если анализатор сервера Exchange обнаруживает, что выполнены приведенные ниже условия, на экран выводится следующее предупреждение:

  • Значение атрибута purportedSearch политики получателей содержит homeMdb.

  • Функциональный уровень леса Active Directory — промежуточный сервер Windows Server 2003 или основной сервер Windows Server 2003.

  • Компьютер сервера Exchange работает не под управлением Microsoft Windows Small Business Server 2003.

Это предупреждение указывает, что данный лес Active Directory подготовлен для Windows Server 2003. Чтобы избежать проблем с маркировкой адресов электронной почты при обновлении леса до уровня полнофункционального сервера Windows Server 2003, необходимо внести изменения в политики получателей. Соответствующая политика получателей указывается в данных, выводимых анализатором сервера Exchange.

Если в качестве контроллера домена используется Windows Server 2003 и политика получателей не обновлена, репликация связанных значений в Windows Server 2003 приводит к некорректной записи адресов электронной почты новых пользователей в службе обновления получателей. Первое появление пользователя в службе обновления получателей может попасть в промежуток времени между репликацией mailnickname и репликацией homeMDB по причине репликации связанных значений. Таким образом, в отношении этого пользователя будет действовать политика по умолчанию, а не политика на основе homeMDB. Через несколько минут при репликации homeMDB в отношении пользователя начнет действовать политика homeMDB. Однако к этому моменту пользователь уже получит адреса в соответствии с политикой по умолчанию.

Чтобы устранить причину появления этого предупреждения

  1. Откройте системный диспетчер Exchange.

  2. Раскройте узел Получатели, выберите элемент Политики получателей, щелкните правой кнопкой мыши RecipientPolicyName и выберите команду Свойства.

  3. На странице Свойства RecipientPolicyName на вкладке Общие в разделе Правила фильтра щелкните Изменить.

  4. В меню Поиск получателей Exchange выберите Пользовательский поиск. Если политика получателей первоначально была создана в результате пользовательского поиска, после выбора в шаге 3 команды Изменить отроется страница Поиск пользовательского поиска.

  5. Изменить LDAP-запрос таким образом, чтобы атрибут homeMdb не использовался как часть условия фильтра. Такие атрибуты, как extensionAttribute, msExchHomeServerName или UPN, являются допустимыми аргументами, с помощью которых можно достичь того же результата.

  6. Нажмите кнопку ОК, чтобы сохранить внесенные изменения, а затем закройте окно системного диспетчера Exchange.


Требуется изменить фильтр поиска для политики получателей
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить значение атрибута purportedSearch для всех объектов политики получателей Exchange. Атрибут purportedSearch указывает аргумент поиска, который используется при применении данной политики.

Анализатор сервера Exchange также опрашивает Active Directory, чтобы определить значение атрибута msDS-Behavior-Version объекта леса в параметрах NTDS Active Directory. Это значение отражает функциональный уровень леса Active Directory. Допустимые значения атрибута msDS-Behavior-Version показаны в следующей ниже таблице.

Значение | Функциональный уровень леса
0 | Смешанный сервер Microsoft Windows® 2000 Server
1 | Промежуточный сервер Microsoft Windows Server™ 2003
2 | Основной сервер Windows Server 2003

Анализатор сервера Exchange также опрашивает Active Directory, чтобы определить значение атрибута revision контейнера Windows2003Update. Значение этого атрибута указывает, было ли выполнено средство подготовки Active Directory (ADPrep.exe).

В последнюю очередь анализатор сервера Exchange запрашивает WMI-класс Win32_OperatingSystem, чтобы определить значение ключа OSProductSuite. Значение ключа OSProductSuite указывает версию операционной системы Windows, под управлением которой работает компьютер.

Если анализатор сервера Exchange обнаружит, что выполнены все условия, приведенные ниже, будет выведено предупреждение.

  • Значение атрибута purportedSearch политики получателей содержит (homeMdb=).

  • Функциональный уровень леса Active Directory — смешанный сервер Windows 2000 Server.

  • Лес Active Directory был подготовлен для контроллеров домена Windows Server 2003.

  • Компьютер сервера Exchange работает не под управлением Microsoft Windows Small Business Server 2003.

Это предупреждение указывает, что данный лес Active Directory подготовлен для Windows Server 2003. Чтобы избежать проблем с маркировкой адресов электронной почты при обновлении леса Active Directory до уровня полнофункционального сервера Windows Server 2003, необходимо внести изменения в политики получателей. Соответствующая политика получателей указывается в данных, выводимых анализатором сервера Exchange.

Если в качестве контроллера домена используется Windows Server 2003 и политика получателей не обновлена, репликация связанных значений в Windows Server 2003 приводит к неправильной записи адресов электронной почты новых пользователей в службе обновления получателей.

Из-за репликации связанных значений служба обновления получателей может обнаружить нового пользователя в первый раз между репликацией mailnickname (почтовый псевдоним) и репликацией homeMdb. Следовательно, в отношении этого пользователя будет действовать политика по умолчанию, а не политика homeMdb. Несколько минут спустя, когда реплицируется homeMdb, в отношении пользователя будет действовать политика homeMdb. Однако к этому моменту пользователь уже получит адреса в соответствии с политикой по умолчанию.

Чтобы устранить причину появления этого предупреждения

  1. Откройте диспетчер Exchange.

  2. Раскройте узел Получатели, выберите элемент Политики получателей, щелкните правой кнопкой мыши RecipientPolicyName и выберите команду Свойства.

  3. На странице Свойства RecipientPolicyName на вкладке Общие в разделе Правила фильтра щелкните Изменить.

  4. В меню Поиск получателей Exchange выберите Пользовательский поиск. Если политика получателей первоначально была создана в результате пользовательского поиска, после выбора на шаге 3 команды Изменить отроется страница Поиск пользовательского поиска.

  5. Измените LDAP-запрос таким образом, чтобы атрибут homeMdb не использовался как часть условия фильтра. Такие атрибуты, как extensionAttribute, msExchHomeServerName или UPN, являются допустимыми аргументами, с помощью которых можно достичь того же результата.

  6. Нажмите кнопку ОК два раза, чтобы сохранить внесенные изменения, а затем закройте окно диспетчера Exchange.


Не настроен код отправителя
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-05-10

Анализатор соответствия рекомендациям для Microsoft Exchange использует указанный ниже командлет командной консоли Exchange для запроса значений свойств Enabled и ExternalMailEnabled объекта SenderIdConfig для целевых ролей пограничного транспортного сервера и транспортного сервера-концентратора Exchange Server 2007.

Копировать код
- get-SenderIdConfig

Значение свойства Enabled показывает, включен ли агент кода отправителя. Допустимыми значениями параметра Enabled являются $true и $false. Значение по умолчанию — $true. Если параметру Enabled присвоено значение $true, агент кода отправителя включен.

Значение свойства ExternalMailEnabled определяет, будут ли все сообщения от подключений, не прошедших проверку подлинности, передаваться агенту кода отправителя для обработки. Допустимыми значениями параметра ExternalMailEnabled являются $true и $false. Значение по умолчанию — $true. Если параметру ExternalMailEnabled присвоено значение $true, все сообщения от подключений, не прошедших проверку подлинности, передаются для обработки агенту кода отправителя.

Если анализатор соответствия рекомендациям для Exchange определяет, что для свойства Enabled или ExternalMailEnabled объекта SenderIdConfig не установлено значение $true, он выводит сообщение с рекомендацией.

В этом сообщении указано, что для целевых ролей пограничного транспортного сервера или транспортного сервера-концентратора Exchange Server 2007 не включен код отправителя.

Код отправителя служит для проверки того, что сообщение действительно получено из домена Интернета, из которого оно якобы было отправлено.

Когда на компьютере включен код отправителя, выполняется фильтрация всех сообщений, поступающих через все соединители приема. Фильтруются только сообщения, полученные из внешних источников. Внешние источники — это источники, не прошедшие проверку подлинности. Такими источниками считаются анонимные интернет-источники.

Чтобы устранить данную проблему, включите код отправителя для ролей пограничного транспортного сервера и транспортного сервера-концентратора Exchange Server 2007.

Включение кода отправителя с помощью командной консоли Exchange

  • Чтобы включить фильтрацию отправителей, выполните следующую команду:

    Копировать код
    Set-SenderIdConfig -Enabled $true -ExternalMailEnabled $true

Дополнительные сведения о коде отправителя см. в следующих разделах:

  • Начальная страница, посвященная коду отправителя (http://go.microsoft.com/fwlink/?linkid=50977) (на английском языке)

  • Код отправителя в Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkId=89719) (на английском языке)

  • Настройка кода отправителя (http://go.microsoft.com/fwlink/?LinkId=89720) (на английском языке)


Несоответствие регистра символов имени сервера
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить значение, хранящееся в Active Directory в качестве имени сервера Exchange (CN=<ExchangeServerName>). Получив это имя, анализатор сервера Exchange подсчитывает число содержащихся в нем символов.

Анализатор сервера Exchange также считывает следующую запись реестра, чтобы определить значение, хранящееся в реестре компьютера с сервером Exchange в качестве имени узла для сервера Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

Анализатор сервера Exchange также запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Service, чтобы определить значение ключа Started для ClusSvc — службы кластеров Windows®.

Если все следующие условия выполнены, анализатор сервера Exchange выводит сообщение о том, что текущая конфигурация отличается от используемой по умолчанию.

  • Регистр символов в значении CN=<ExchangeServerName> отличается от регистра в значении Hostname. Например, CN=ComputerName, а Hostname=COMPUTERNAME.

    Примечание.
    Хотя в реестре разрешается изменять регистр символов имени сервера, делать это не рекомендуется.
  • Имя сервера Exchange содержит не более 15 символов.

  • Сервер Exchange не запущен в кластере Windows.

Наиболее распространенной причиной этой ошибки является изменение имени сервера Exchange в реестре вручную.


Несоответствие имени сервера
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить значение параметра This Server, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Анализатор сервера Exchange также запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута name для каждого объекта сервера Exchange.

В последнюю очередь анализатор сервера Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Service, чтобы определить значение ключа Started для службы кластеров (ClusSvc). Значение TRUE указывает, что служба кластеров запущена, а значение False — что служба кластеров не запущена.

Если анализатор сервера Exchange обнаруживает, что значение ключа This Server не соответствует значению атрибута name объекта сервера в службе каталогов Active Directory для какого-либо компьютера Exchange Server, не работающего в кластере серверов, выводится сообщение об ошибке.

Чтобы устранить эту ошибку, необходимо изменить раздел реестра This Server, чтобы его значение соответствовало значению атрибута name в Active Directory.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы устранить эту ошибку

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в следующий раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem.

  3. В правой области дважды щелкните This Server, введите правильное имя компьютера и нажмите кнопку ОК.

  4. Закройте редактор реестра и перезапустите компьютер Exchange Server, чтобы изменения вступили в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).


Слишком длинное имя сервера
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-02-22

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить имя (cn) для каждого объекта каталога с классом объекта msExchExchangeServer. Значением cn является строка, содержащая краткое имя компьютера сервера Exchange. Анализатор сервера Exchange получает значение cn и определяет длину строки. Длиной строки является количество символов в имени сервера Exchange. Если анализатор сервера Exchange определяет, что длина имени сервера превышает 15 символов, отображается сообщение об ошибке.

Серверы Exchange Server 2007, Exchange Server 2003 и Exchange Server 2000 имеют несколько зависимостей NetBIOS, которые могут потребовать использования разрешений имен NetBIOS в различных подсетях, чтобы обеспечить успешную работу всех компонентов Exchange в зависимости от топологии сети. Соглашение об именах NetBIOS позволяет имени NetBIOS состоять из 16 символов. Однако корпорация Майкрософт ограничивает имена NetBIOS 15-ю символами и использует 16-ый символ в качестве суффикса NetBIOS.

Так как Exchange Server зависит от NetBIOS и длина имен NetBIOS не может превышать 15 символов, имена серверов, длина которых превышает 15 символов, не поддерживаются в организации Exchange. Кроме того, так как переименование компьютера сервера Exchange может произвести обширные изменения в службе каталогов Active Directory и организации Exchange, переименование компьютера сервера Exchange не поддерживается.

Чтобы устранить эту ошибку

  1. Удалите компьютер сервера Exchange с неправильным именем с помощью параметра Удалить.

  2. Переименуйте компьютер, задав имя, содержащее 15 символов или меньше.

  3. Переустановите сервер Exchange на этом компьютере.

Дополнительные сведения об удалении сервера Exchange Server 2007 см. в статье «Полное удаление Exchange 2007 с сервера» (http://go.microsoft.com/fwlink/?LinkId=79246) документации по развертыванию Microsoft Exchange Server 2007 (на английском языке).

Сведения об удалении Exchange Server 2003 см. на странице, посвященной инструкциям по удалению Exchange Server 2003, находящейся в руководстве по развертыванию Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47569).

Дополнительные сведения см. в следующих статьях базы знаний Майкрософт:

  • статья 833396, посвященная инструкциям по ручному удалению Exchange 2003 с компьютера (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=833396);

  • статья 260378, посвященная инструкциям по ручному удалению Exchange 2000 с компьютера (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260378);

  • статья 328810, описывающая перемещение почтовых ящиков между серверами (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328810);

  • статья 821829, описывающая перемещение почтовых ящиков в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829);


Сетевой адрес удаленного вызова процедур сервера не соответствует имени сервера Exchange
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута networkAddress для каждого объекта сервера Exchange в каталоге. Для этого многострокового атрибута обычно перечисляется несколько записей, как показано в следующих примерах:

ncacn_ip_tcp :<полное доменное имя сервера Exchange>

ncacn_np: <имя узла сервера Exchange>

ncacn_spx: <имя узла сервера Exchange>

ncacn_vns_spp: <имя узла сервера Exchange>

ncalrpc: <имя узла сервера Exchange>

netbios: <имя узла сервера Exchange>

Средство анализатора сервера Exchange также запрашивает в службе каталогов Active Directory значение атрибута name для каждого объекта сервера Exchange.

Если анализатор сервера Exchange обнаруживает, что значение атрибута name не соответствует содержащему имя фрагменту ни одной из строк, найденных в атрибуте networkAddress, отображается сообщение об ошибке.

Эта ошибка может возникать в том случае, если администратор вручную изменил значение cn объекта сервера. Атрибут networkAddress создается и поддерживается сервером Exchange, в этом атрибуте содержится несколько строковых значений для поддержки разных протоколов сетевой связи, поддерживаемых сервером Exchange. Каждое значение связывает протокол с соответствующей формой имени сервера, которая требуется для этого протокола.

Чтобы исправить эту ошибку, проверьте, было ли изменено имя сервера и является ли значение допустимым, а затем выполните соответствующие действия:

  • Если имя сервера было изменено, используйте процедуру, описанную ниже в этой статье, для исправления значений.

  • Если значения являются недопустимыми по какой-либо другой причине, повторно запустите программу установки Exchange на сервере.

Внимание!
Если при использовании оснастки ADSI Edit (ADSI — Active Directory Service Interfaces), средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3 неправильно изменить атрибуты объектов Active Directory, могут возникнуть серьезные неполадки. Для их устранения может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих продуктов. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы устранить эту ошибку

  1. С помощью ADSI Edit или похожего средства найдите в службе каталогов Active Directory объект административной группы.

    Атрибут networkAddress можно найти по следующему пути:

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN= имя_организации , CN=Administrative Groups, CN= имя административной группы , CN=Servers, CN= имя сервера

  2. Обратите внимание на формат каждого значения в списке. При необходимости обновите значения, изменив только содержащий имя фрагмент каждого значения.

    Примечание.
    Убедитесь, что для значения ncacn_ip_tcp имя сервера указывается в виде полного доменного имени, а не имени NetBIOS или IP-адреса.

  3. Закройте редактор Active Directory, а затем перезапустите службу модуля маршрутизации Exchange.

Дополнительные сведения об использовании средства LDP см. в статье 260745 базы знаний Майкрософт, посвященной использованию служебной программы LDP для изменения атрибутов объектов Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Дополнительные сведения о проблемах маршрутизации в Exchange см. в разделе, посвященном устранению неполадок при маршрутизации, руководства по транспорту и маршрутизации в Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


Отсутствует имя участника службы
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-08-14

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значения, возвращенные для атрибута servicePrincipalName учетных записей на компьютере сервера Exchange для ресурсов Exchange, перечисленных в следующей таблице.

Значение servicePrincipalName ресурса Exchange | Ожидаемое возвращаемое значение
exchangeMDB | Полное доменное имя (FQDN)
exchangeMDB | Имя NetBIOS
exchangeRFR | Полное доменное имя (FQDN)
exchangeRFR | Имя NetBIOS
SMTP | Полное доменное имя
SMTP | NetBIOS-имя
SMTPSVC | Полное доменное имя (FQDN)
SMTPSVC | Имя NetBIOS
HOST | Полное доменное имя (FQDN)
HOST | Имя NetBIOS

Если анализатор сервера Exchange обнаруживает, что в атрибуте servicePrincipalName учетной записи компьютера для ресурса Exchange отсутствует одно из перечисленных здесь ожидаемых значений, анализатор сервера Exchange возвращает ошибку.

Имя участника службы (SPN) — уникальное имя, которое определяет экземпляр службы и связано с учетной записью для входа, под которой работает экземпляр службы. Без правильной настройки SPN проверка подлинности Kerberos для служб Exchange невозможна.

  • Проблемы проверки подлинности между клиентами Microsoft Office Outlook® 2003 или более поздней версии и банком сообщений Exchange (данные почтового ящика) могут указывать на отсутствие допустимого SPN для ресурса exchangeMDB.

  • Проблемы проверки подлинности Active Directory у клиентов Outlook 2003 или более поздней версии могут указывать на отсутствие допустимого SPN для ресурса exchangeRFR.

  • Ошибки проверки подлинности между виртуальными SMTP-серверами могут указывать на отсутствие допустимого SPN для ресурса SMTPSVC или HOST.

Чтобы разрешить эти проблемы, проделайте следующие шаги добавления недостающих значений для соответствующих атрибутов.

Использование средства SETSPN.exe для добавления SPN с недостающими значениями

  1. Установите средство Setspn.exe. Чтобы получить средство Setspn.exe, см. "Средство из пакета ресурсов Windows 2000: Setspn.exe" (http://go.microsoft.com/fwlink/?LinkId=28103).

    Версия для Windows Server 2003 программы Setspn.exe, работающей в режиме командной строки, доступна в пакете средств поддержки Windows Server 2003, имеющемся на компакт-диске Windows Server 2003. Чтобы установить средства поддержки Windows Server 2003, дважды щелкните файл Suptools.msi в папке Support/Tools.

  2. Следуйте инструкциям в файле Setspn_d.txt программы SETSPN.EXE по добавлению недостающего значения к объекту Active Directory для сервера Exchange. В следующем примере демонстрируется добавление значения FQDN для SPN виртуального SMTP-сервера:

    • Запустите режим командной строки и перейдите в каталог установки программы Setspn.exe.

    • В командной строке введите следующую команду:

      setspn.exe -a SMTPSVC/ mail.домен.com имя_сервера

      Примечание.
      Замените mail.домен.com на FQDN своего виртуального SMTP-сервера, а имя_сервера — на имя сервера Exchange.
      Затем нажмите клавишу ВВОД.


Непредвиденное завершение работы службы в предыдущие 24 часа
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-02-14

Средство анализа Microsoft Exchange запрашивает класс WMI Win32_NTLogEvent для определения того, было ли в течение последних 24 часов зарегистрировано предупреждение 7031 для источника диспетчера управления службами.

Предупреждение 7031 означает, что работа указанной службы не могла быть продолжена. После того как служба сообщит о сбое указанное количество раз, диспетчер управления службами выполнит восстановительные действия, заданные для этой службы.

Если средство анализа Exchange обнаружит, что хотя бы одно это событие было зарегистрировано в течение последних 24 часов, он отобразит информационное сообщение.

Данная проблема может быть вызвана различными причинами, наиболее распространенные из которых перечислены ниже.

  • Обработка поврежденного сообщения.

  • Неправильная настройка антивирусного программного обеспечения.

Для устранения этой проблемы выполните следующие действия.

  • Выясните причину отсутствия реакции на действия пользователя (зависания) или непредвиденного завершение работы (сбоя) процесса, выполнив рекомендации, приведенные в статье 286350 базы знаний Майкрософт «Использование средства ADPlus для устранения неполадок, приводящих к зависаниям и сбоям» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286350, на английском языке).

  • Установите последний пакет обновления для Microsoft Windows 2000.

  • Установите последний пакет обновления для Microsoft Exchange Server.

  • Свяжитесь с изготовителем антивирусного программного обеспечения для получения последних обновлений и сведений по настройке системы.

Дополнительные сведения

Дополнительные сведения о предупреждении 7031 см. на странице «Центр сообщений о событиях и ошибках: сведения о событиях» (http://go.microsoft.com/fwlink/?LinkId=83114, на английском языке).

Дополнительные сведения о получении последнего пакета обновлений для Windows 2000 Server см. в статье 260910 базы знаний Майкрософт «Как получить последний пакет обновления для Windows 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260910).

Дополнительные сведения о получении последнего пакета обновлений для Exchange 2000 Server см. в статье 301378 базы знаний Майкрософт «Как получить последний пакет обновления для Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378).

Дополнительные сведения о получении последнего пакета обновлений для Exchange Server 2003 см. в статье «Почему следует установить пакет обновления 2 для Exchange Server 2003?» (http://go.microsoft.com/fwlink/?LinkId=52073, на английском языке).

Дополнительные сведения об использовании антивирусных программ с сервером Exchange Server см. в следующих статьях базы знаний Майкрософт:

  • 328841, «Антивирусное программное обеспечение для Exchange» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841).

  • 823166, «Использование антивирусных программ на сервере Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • 306105, «XGEN: Отношение Майкрософт к антивирусным решениям для Exchange 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105, на английском языке).

  • 245822, «Рекомендации по устранению неполадок на компьютере с сервером Exchange Server, использующем антивирусные программы» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Список антивирусного программного обеспечения сторонних производителей для сервера Exchange Server см. на веб-узле, который посвящен партнерам Майкрософт, производящим антивирусные программы для Exchange Server, по адресу http://go.microsoft.com/fwlink/?linkid=16226 (на английском языке).


Services Value is Missing or Inaccessible
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-07-24

Анализатор Microsoft Exchange проверяет следующий параметр реестра на наличие строкового значения Services:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Setup

Если анализатор Exchange обнаруживает, что строковое значение Services отсутствует или недоступно, он выводит сообщение об ошибке.

Эта ошибка указывает на то, что строковое значение Services, используемое для хранения пути к папке установки Exchange, отсутствует или недоступно. Отсутствие пути к папке установки Exchange может привести к сбою инициализации критически важных драйверов и протоколов, что, в свою очередь, может привести к сбою запуска банка данных Exchange и зависящих от нее служб.

Чтобы устранить эту ошибку, следуйте рекомендациям, приведенным в статье 285116 базы знаний Майкрософт «Банк данных Exchange не запускается: ошибки 7024, 1026, 9542, 5000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285116) (эта ссылка может указывать на содержимое полностью или частично на английском языке).


Обнаружена только одна реплика сведений о занятости
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-12-15

Анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Exchange_PublicFolder в пространстве имен root\MicrosoftExchangeV2, чтобы определить число реплик сведений о занятости, существующих в каждой из групп администрирования.

Если анализатор сервера Exchange обнаруживает, что в группе администрирования есть только одна реплика данных о занятости, выводится сообщение с рекомендациями.

В целом рекомендуется иметь несколько реплик папки сведений о занятости в каждой административной группе. Иногда наличие нескольких реплик сведений о занятости позволяет повысить производительность и отказоустойчивость. В крупных организациях Exchange может возникнуть перегрузка единственной реплики сведений о занятости. Во всех организациях Exchange единственная реплика сведений о занятости всегда представляет собой точку возможного сбоя.

Рекомендуется использовать несколько реплик несмотря на следующие отрицательные стороны:

  • Наличие нескольких реплик создает добавочный трафик репликации в сети.

  • С ростом числа реплик увеличивается риск возникновения конфликтов планирования.

Должна существовать по меньшей мере одна реплика для 10 000 почтовых ящиков.

Дополнительные сведения о папках сведений о занятости и публикации сведений о занятости см. в документе «Working with Exchange Server 2003 Stores» (http://go.microsoft.com/fwlink/?LinkId=47595) (Работа с хранилищами Exchange Server 2003).


Обнаружена одна реплика сведений о занятости для большого количества почтовых ящиков
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-12-15

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Exchange_PublicFolder в пространстве имен root\MicrosoftExchangeV2, чтобы определить количество записей в параметре ReplicaList. Количество записей представляет число реплик сведений о занятости в каждой группе администрирования.

Помимо этого, анализатор сервера Exchange опрашивает службу Active Directory®, чтобы определить значение счетчика записей, перечисленных в атрибуте homeMDBBL каждого хранилища почтовых ящиков. Счетчик этого атрибута представляет количество почтовых ящиков в хранилище почтовых ящиков.

Если анализатор сервера Exchange обнаруживает, что в административной группе, насчитывающей более 10 000 почтовых ящиков, существует только одна реплика сведений о занятости, на экран выводится сообщение об ошибке.

Как правило рекомендуется обеспечить наличие в каждой административной группе нескольких реплик сведений о занятости. Иногда использование нескольких реплик сведений о занятости позволяет повысить производительность и устойчивость. В крупных организациях Exchange одна реплика сведений о занятости может оказаться перегруженной. Использование только одной реплики сведений о занятости в любой организации Exchange означает наличие непродублированного критического элемента.

Рекомендуется использовать несколько реплик несмотря на следующие недостатки:

  • Использование нескольких реплик приводит к увеличению трафика репликации в сети.

  • Использование нескольких реплик повышает риск конфликтов расписаний.

На каждые 10 000 почтовых ящиков должна приходиться по крайней мере одна реплика.

Дополнительные сведения о папках занятости и публикации сведений о занятости см. в разделе, посвященном работе с хранилищами Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47595).


В топологии доступен только один глобальный каталог
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-09

Анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Exchange_DSAccess в пространстве имен root\MicrosoftExchangeV2, чтобы определить число серверов глобального каталога, доступных в топологии. Число серверов глобального каталога определяется путем подсчета количества записей для WMI-ключа DSAccessNameGC. Если анализатор сервера Exchange обнаруживает, что в топологии присутствует только один сервер глобального каталога, выводится сообщение с рекомендациями.

Для повышения отказоустойчивости рекомендуется, чтобы серверам и пользователям Exchange было доступно по меньшей мере два сервера глобального каталога. Один сервер глобального каталога образует подверженный сбоям непродублированный элемент. Различные функции Exchange 2000 Server, Exchange Server 2003 и Exchange Server 2007 зависят от серверов глобального каталога. Если сервер глобального каталога недоступен, доставка почты может замедлиться или остановиться. Кроме того, в такой ситуации не будут запускаться службы Exchange Server. Если не удается выполнить запуск служб Exchange Server, пользователи не смогут получить доступ к своим почтовым ящикам.

Для улучшения масштабируемости и повышения отказоустойчивости рекомендуется настроить по меньшей мере два сервера глобального каталога на каждом сайте службы каталогов Active Directory®. Если сайт включает несколько доменов, рекомендуется настроить глобальный каталог для каждого домена, содержащего серверы Exchange 2000 Server, Exchange Server 2003 или Exchange Server 2007 и клиентские компьютеры. Кроме того, рекомендуется развернуть один сервер глобального каталога для каждых четырех процессоров компьютеров Exchange Server.

Дополнительные сведения о том, как создавать серверы глобального каталога, см. в базе знаний Майкрософт в статье 313994 «How to create or move a Global Catalog in Windows 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372) (Инструкции по созданию и перемещению глобального каталога в Windows 2000).

Дополнительные сведения о расположении и доступности сервера глобального каталога для Exchange Server см. в следующих статьях базы знаний:

  • 875427, «Global catalog server placement and ratios in an Exchange 2000 Server organization or in an Exchange Server 2003 organization» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=875427) (Расположение и нормы для сервера глобального каталога в организации Exchange 2000 Server или Exchange Server 2003)

  • 322801, «Exchange System Attendant Does Not Start, and You Receive a 'Global Catalog Servers Not Responding' Error Message» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322801) (Системный помощник Exchange не запускается, выводится сообщение об ошибке «Серверы глобального каталога не отвечают)

  • 829361, «Exchange Server 2003 Computer Takes Longer Than You Expect to Shut Down» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829361) (Для завершения работы компьютера Exchange Server 2003 требуется больше времени, чем ожидалось)

  • 304403, «Exchange Considerations for Promoting a Domain Controller to a Global Catalog Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=304403) (Рекомендации для Exchange по повышению уровня контроллера домена до сервера глобального каталога)

  • 305065, «Exchange Server-Related Considerations for Demoting a Global Catalog Server to a Domain Controller» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=305065) (Рекомендации для сервера Exchange по понижению уровня сервера глобального каталога до контроллера домена)


Сервер папок сайта удален
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-03-01

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить значение атрибута siteFolderServer для каждого объекта административной группы. Если анализатор сервера Exchange определит, что значение атрибута siteFolderServer содержит строку DEL:, отобразится сообщение об ошибке.

Атрибут siteFolderServer представляет различающееся имя хранилища общих папок, ответственное за размещение папок сайта (обычно первый сервер в сайте или административной группе).

По умолчанию сервером папок сайта является первый сервер, установленный в административной группе. Хранилище общих папок на этом сервере является расположением по умолчанию для папок занятости и папок автономной адресной книги для административной группы. Если этот сервер удаляется или списывается без репликации этих папок на другой сервер и назначения его в роли сервера автономной адресной книги, пользователи Microsoft Office Outlook® 2003 столкнуться с неполадками в работе автономной адресной книги и в данных занятости.

Внимание!
Могут возникнуть серьезные проблемы, если некорректно изменить атрибуты объектов Active Directory при использовании средства ADSI Edit (Active Directory Service Interfaces, ADSI), средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3. Для устранения этих неполадок может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы устранить эту ошибку

  1. Откройте редактор Active Directory, например, ADSI Edit.

  2. Найдите банк данных общих папок, который следует назначить сервером папок сайта, разворачивая следующие узлы в контейнере конфигурации:

    CN=Configuration,DC=<имя_домена>,DC=com, CN=Services, CN=Microsoft Exchange, CN=<имя_организации>, CN=Administrative Groups, CN=<имя_административной группы> CN=Servers, CN=<имя_сервера>, CN=InformationStore, CN=<имя_группы_хранения>

  3. В правой области щелкните правой кнопкой мыши CN=<имя_хранилища_общих_папок>,, а затем щелкните Свойства.

  4. В поле атрибутов перейдите в конец списка и выберите атрибут distinguishedName.

  5. Щелкните Изменить и скопируйте весь атрибут в буфер обмена.

  6. Разверните контейнер конфигурации, затем разверните CN=Configuration,CN=<имя_домена>,CN=com, CN=Services, CN=Microsoft Exchange, CN=<имя_организации>, CN=Administrative Groups

  7. Щелкните правой кнопкой мыши административную группу, которую следует изменить, и в контекстном меню выберите Свойства.

  8. В поле атрибутов перейдите в конец список и выберите атрибут siteFolderServer.

  9. Щелкните Изменить и вставьте значение атрибута distinguishedName в поле Значение.

  10. Щелкните дважды содержимое поля Значение, чтобы убедиться, что вставка прошла успешно, затем щелкните ОК для сохранения изменений.

  11. Нажмите кнопку ОК, чтобы закрыть свойства административной группы.

  12. Закройте редактор Active Directory и перезапустите службу банка данных сервера Microsoft Exchange на всех компьютерах серверов Exchange в сайте, чтобы изменения вступили в силу.

Дополнительные сведения о повторном создании системных папок и повторной настройке сервера папок сайта см. в следующих статьях базы знаний Майкрософт:

  • 822444, описывающая сброс папки сайта в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822444);

  • 275171, описывающая сброс системных папок в Exchange Server 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=275171);

  • 284200, описывающая отсутствие системной папки занятости и расписания (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=284200).

Дополнительные сведения об использовании средства LDP см. в статье 260745 базы знаний корпорации Майкрософт, посвященной использованию служебной программы LDP для изменения атрибутов объектов Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Дополнительные сведения о работе с оснасткой Edit интерфейса ADSI см. в разделе, посвященном Adsiedit.msc: ADSI Edit, в справке сервера Windows.


Медленные обращения к службе каталога Active Directory
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-14

Средство анализа Microsoft® Exchange Server проверяет журнал вызова функций Exchange (FCL), файл Store.fcl, на предмет наличия в нем событий компонента службы каталогов Active Directory®, время ответа на которые превысило 2,5 секунды.

События компонента Active Directory в журнале FCL Exchange отражают обращения функции Microsoft Exchange Information Store service (Store.exe) к компоненту Active Directory.

Active Directory предоставляет всю информацию о почтовых ящиках, службы списков адресов и прочую информацию, связанную с получателями. Большая часть информации о конфигурации Exchange Server 2003 также хранится в Active Directory.

Службы сервера Exchange получают доступ к информации, хранящейся в Active Directory, и записывают информацию в Active Directory.

Если средство анализа Exchange Server обнаружит, что события в файле FCL имеют время ответа, превышающее 2,5 секунды для вызова функций Active Directory службой Microsoft Exchange Information Store service (Store.exe), оно выдаст сообщение об ошибке.

Когда служба Microsoft Exchange Information Store service (Store.exe) ожидает ответа на межкомпонентные вызовы, работа потоков удаленного вызова процедур (RPC) может замедляться, что приведет к снижению производительности сервера Exchange, например к задержке ответа сервера на запросы клиентов.

Обращения службы Microsoft Exchange Information Store service к Active Directory, требующие более 2,5 секунд, могут быть вызваны следующими условиями:

  • Задержки в сети между сервером Exchange и контроллером домена.

  • Статическая настройка DSAccess или другие ошибки настройки.

  • Перегружен контроллер домена и глобальный каталог.

  • Неправильно построенная топология Active Directory.

Чтобы решить эту проблему, сделайте следующее:

  • Запустите средство анализа Exchange Server для дополнительного анализа сервера. Средство анализа Exchange Server можно загрузить на веб-узле «Средство анализа Microsoft® Exchange Server версии 2.7» (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Проверьте производительность серверов контроллеров домена Active Directory.

  • Просмотрите статьи, указанные в этом документе, в разделе Дополнительные сведения.

Дополнительные сведения

Для получения дополнительных сведений о производительности Exchange и DSAccess см. статью 250570 базы знаний корпорации Майкрософт «Обнаружение сервера службы каталога и использование DSAccess» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570).

Для получения дополнительных сведений о производительности сервера Exchange см. «Руководство по производительности и масштабируемости Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=47576).

Для получения дополнительных сведений об устранении неполадок, связанных с производительностью сервера Exchange, см. «Устранение неполадок в работе Microsoft Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=47588).

Для получения дополнительных сведений об устранении неполадок, связанных с производительностью банка сообщений, см. статью 257725 базы знаний корпорации Майкрософт «XADM: сбор диагностических данных для решения проблем, связанных с хранилищем информации» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

Для получения дополнительных сведений о производительности контроллера домена см. следующие материалы по Windows Server:

  • «Планирование производительности контроллера домена» (http://go.microsoft.com/fwlink/?LinkId=70191).

  • Раздел «Наблюдение за контроллерами доменов, выполняемое Active Directory», в документе Руководства по планированию и развертыванию Active Directory на основе Windows 2000 Server (http://go.microsoft.com/fwlink/?LinkId=70193).


Медленная реакция на вызовы ESE
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-13

Средство анализа сервера Microsoft® Exchange ищет в журнале вызовов Exchange (FCL) и файле Store.fcl события компонента модуля расширяемого хранилища Exchange (ESE), в которых превышено время ответа в 2,5 секунды.

События компонента ESE FCL Exchange являются представлениями функциональных вызовов службы информационного хранилища Microsoft Exchange (Store.exe) к компоненту ESE.

Информационное хранилище Exchange построено на основе базы данных ESE. ESE - это сложный, основанный на транзакциях механизм базы данных. Транзакция - это серия операций, которые обрабатываются как неделимый блок. Все операции в транзакции либо завершены и постоянно сохранены, либо никакие операции не выполняются.

Сервер Exchange использует ESE как встроенный механизм базы данных, который определяет структуру баз данных и управляет памятью. Механизм базы данных кэширует базы данных в памяти, переводя части данных (страниц) по четыре килобайта в память и из нее. Этот механизм обновляет страницы в памяти и записывает новые или обновленные страницы на диск. Когда в систему приходит запрос, база данных может буферизовать данные в памяти. Таким образом, ей не требуется постоянный доступ к жесткому диску.

Хотя кэширование данных в памяти является самым быстрым и эффективным способом обработки данных, это означает, что во время работы Exchange информация на диске никогда полностью не актуальна, однако диск журнала транзакций всегда поддерживает текущее состояние информации о каждой транзакции. Тем не менее, вследствие того, что многие изменения в памяти не попадают на диск немедленно, база данных и память не синхронизированы.

Если анализатор сервера Exchange обнаруживает, что события в файле Store.fcl показывают время отклика более 2,5 секунд на функциональные вызовы компонента ESE из службы информационного хранилища Microsoft Exchange (Store.exe), анализатор сервера Exchange выводит сообщение об ошибке.

Когда межкомпонентные вызовы из службы информационного хранилища Microsoft Exchange (Store.exe) дожидаются ответа, потоки удаленного вызова процедур (RPC) могут выполняться одновоременно с этими запросами и вести к таким проблемам с производительностью Exchange Server, как задержка ответов сервера клиентам.

Текущие вызовы из ESE могут быть обусловлены следующим:

  • Оперативная дефрагментация Exchange.

  • Резервное копирование данных.

    Примечание.
    Если резервное копирование данных или оперативная дефрагментация преднамеренно проводились во время сборки журнала отслеживания вызовов Exchange, можно не обращать внимания на это сообщение, это просто сообщение о проблеме с производительностью сервера Exchange
  • Узкие места, связанные с диском базы данных.

Чтобы устранить эту ошибку, выполните следующие действия:

  • Рекомендуется не перекрывать интервалы резервного копирования или оперативное обслуживание с требуемыми интервалами наиболее высокой пользовательской нагрузки.

  • Запустите анализатор сервера Exchange для дополнительного анализа сервера. Загрузить анализатор сервера Exchange можно на «Microsoft Exchange Server Best Practices Analyzer Tool v2.7» (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Ознакомьтесь со статьями в разделе «Дополнительные сведения» данного документа.

Дополнительные сведения

Для получения дополнительных сведений о настройке интервалов оперативной дефрагментации см. статью 244524 базы знаний корпорации Майкрософт «XADM: Как настроить временной интервал оперативной дефрагментации в сервере Exchange» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524).

Для получения дополнительных сведений о проблеме узких мест сервера Exchange, связанных с диском, см. Обнаружено узкое место на диске.

Для получения дополнительных сведений о том, как определять и распределять объем дисков для работы сервера Exchange Server, см. «Как определить требования к обмену с диском» и «Общие рекомендации для нескольких архитектур» в статье Оптимизация хранилища для Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=49324).

Для получения дополнительных сведений о ESE см. «Архитектура модуля расширяемого хранилища» (http://go.microsoft.com/fwlink/?linkid=67009).


Медленные IMAIL-вызовы
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-12

Анализатора сервера Microsoft® Exchange просматривает файл Store.fcl журнала вызовов функций сервера Exchange (FCL) на наличие событий, которые указывают на превышение времени ответа 2,5 сек от компонента IMAIL MAPI-клиента.

События компонента Exchange FCL IMAIL MAPI представляют вызовы функций службы «Банк сообщений Microsoft Exchange» (Store.exe), преобразующие сообщения в формат Интернета и из формата Интернета в формат MAPI.

Компонент IMAIL сервера Exchange Server — это гибкая служба преобразования, которая используется службой «Банк сообщений Microsoft Exchange» между сообщениями из Интернета и MAPI-сообщениями. Этот компонент обеспечивает взаимодействие между клиентами, использующими RFC-822 или формат Интернета, и клиентами, использующими формат внутреннего хранилища сервера Exchange, такими как клиенты MAPI или внутренние задачи STORE.

Приложение Exchange использует механизм IMAIL для применения форматов сообщений к содержимому в соответствии с тем, как это определено для доменов Интернета в системном диспетчере Exchange или как указано пользователем для каждого получателя в Microsoft Office Outlook®. Если в IMAIL не передано никаких параметров форматирования, механизм IMAIL форматирует MAPI-сообщения в формате S/TNEF (Summary TNEF) для передачи между серверами.

Если анализатор сервера Exchange обнаруживает, что события в журнале Store.fcl показывают, что время ответа для вызовов функций компонента IMAIL MAPI-клиента из службы банка сообщений Microsoft Exchange превышает 2,5 сек, анализатор отображает сообщение об ошибке.

Когда межкомпонентные вызовы от службы «Банк сообщений Microsoft Exchange» (Store.exe) ожидают ответа, потоки удаленных вызовов процедур могут архивироваться на фоне этих запросов, что может быть причиной проблем производительности сервера Exchange.

Медленные ответы на запросы функций службы «Банк сообщений Microsoft Exchange» (Store.exe) к компоненту IMAIL могут быть обусловлены следующими причинами:

  • Механизм IMAIL пытается обработать много данных в сообщении или вложении.

  • Многие клиенты запрашивают преобразование данных.

  • Ответы на запросы DSAccess приходят с задержкой.

  • Не хватает ресурсов на дисках TEMP и TMP.

  • Существуют выполняющиеся перемещения почтовых ящиков.

  • Чтобы устранить эту ошибку, выполните следующие шаги:

  • Планируйте любые перемещения почтовых ящиков на время непиковой нагрузки.

  • Запустите анализатор сервера Exchange для дополнительного анализа проблем сервера, таких как предельные размеры сообщений и вложений. Анализатор сервера Exchange можно загрузить на веб-узле средства версии 2.7 анализа рекомендаций Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Ознакомьтесь со статьями в разделе «Дополнительные сведения» данного документа.

Дополнительные сведения

Дополнительные сведения о проблемах отсутствия достаточных ресурсов на диске для сервера Exchange см. по ссылке Обнаружено узкое место на диске.

Дополнительные сведения об определении размеров дисков и оптимизации их использования для сервера Exchange см. в разделах, описывающих расчет требований к системе ввода-вывода диска и общие рекомендации для нескольких архитектур, которые содержатся в статье, посвященной оптимизации хранилища для Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=49324).

Дополнительные сведения о рекомендациях по предельным размерам сообщений на сервере Exchange см. по ссылке Максимальный размер исходящего сообщения не задан.


Медленные вызовы LSASS
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-12-04

Средство анализа Microsoft® Exchange Server проверяет журнал вызова функций Exchange (FCL) в файле Store.fcl на предмет наличия в нем событий компонента процесса Lsass.exe, время ответа на которые превысило 25 миллисекунд.

События компонентов процесса Exchange FCL LSASS представляют вызовы функций компонента процесса сервера проверки подлинности локальной системы безопасности (Lsass.exe) от службы банка данных Microsoft Exchange (Store.exe).

Процесс сервера проверки подлинности локальной системы безопасности (Lsass.exe) — это подсистема безопасности, вызываемая другими процессами для проверки данных учетной записи и правильности входа в систему.

При каждом входе в систему клиента Exchange сервер, на котором выполняется сервер Exchange, посылает запрос на поиск идентификатора безопасности учетной записи клиента и создает вызов внутри процесса сервера проверки подлинности локальной системы безопасности (Lsass.exe).

Если средство анализа Exchange Server обнаруживает события в файле Store.fcl, имеющие время ответа на вызов функций компонента Lsass.exe, превышающее 25 миллисекунд, оно выведет сообщение об ошибке.

Когда ожидается ответ на межкомпонентные вызовы от службы банка данных Microsoft Exchange (Store.exe), потоки удаленных вызовов процедур могут архивироваться на фоне этих запросов, что может быть причиной проблем быстродействия сервера Exchange, таких как задержки отклика сервера на запросы клиентов.

Причинами большого времени отклика для вызовов функций LSASS от службы банка данных Microsoft Exchange (Store.exe) могут служить следующие обстоятельства:

  • Проблемы ресурсов сервера, связанные с одновременным прохождением проверки подлинности множеством пользователей.

  • Задержки в сети между сервером Exchange и контроллером домена или сервером глобального каталога.

  • Проблемы узких мест в использовании ресурсов сервера.

Чтобы устранить эту ошибку, выполните следующие действия:

  • Рассмотрите возможность реализации параметра NeverPing, как описано в статье, Рекомендуется параметр NeverPing.

  • Запустите анализатор сервера Exchange для дополнительного анализа проблем сервера, таких как предельные размеры сообщений и вложений. Анализатор сервера Exchange можно загрузить на веб-узле версии 2.7 средства анализа рекомендаций Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Ознакомьтесь со статьями в разделе «Дополнительные сведения» данного документа.

Дополнительные сведения

Дополнительные сведения о процессе Lsass.exe и использовании памяти см. в базе знаний Майкрософт в статье 308356, описывающей использование памяти процессом Lsass.exe на контроллерах доменов, работающих под управлением Windows Server 2003 или Windows 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356).

Дополнительные сведения о проблемах входов в систему клиентов Exchange и процесса LSASS см. в базе знаний Майкрософт в статье 161938, описывающей замедление процессов входа в систему клиентов Exchange из-за блокировки ресурсов (http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938).

Дополнительные сведения о задержках в сети между сервером Exchange и контроллером домена или глобальным сервером каталогов см. в следующей статье блога коллектива разработчиков Exchange Server «Exchange не всегда использует локальные каталоги» по адресу http://go.microsoft.com/fwlink/?LinkId=69166 (на английском языке).

Примечание.
Содержимое и URL-адрес каждого блога могут изменяться без предварительного уведомления.

Дополнительные сведения о проблемах узких мест в использовании ресурсов сервера см. по ссылке Узкое место в работе процессора.

Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению быстродействием и масштабируемостью Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

Дополнительные сведения об устранении проблем производительности сервера Exchange см. в описании процедур устранения неполадок, связанных с производительностью сервера Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=47588).

Дополнительные сведения об устранении проблем производительности банка данных см. в базе знаний Майкрософт в статье 257725, посвященной сбору диагностических данных для устранения неполадок в работе банка данных (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


Медленные вызовы к средству поиска вирусов
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-11

Средство анализа Microsoft® Exchange Server проверяет журнал вызова функций Exchange (FCL), файл Store.fcl, на предмет наличия в нем событий Virusscan компонента VAPI, время ответа на которые превысило 2,5 секунды.

События Virusscan компонента VAPI в журнале FCL Exchange отражают обращения функции Microsoft Exchange Information Store service (Store.exe) к внешнему антивирусному программному обеспечению.

Чтобы повысить эффективность устранения неполадок VAPI, Exchange Server использует журнал событий, при помощи которого можно отслеживать производительность антивирусного API.

Записываемые в журнал события:

  • загрузка и выгрузка файлов DLL поставщика;

  • успешная проверка объектов;

  • вирусы, обнаруженные в хранилище информации;

  • нестандартное поведение VAPI.

Если средство анализа Exchange Server обнаруживает, что события в файле Store.fcl имеют время ответа на вызов функций внешнего антивирусного программного обеспечения службой Microsoft Exchange Information Store service (Store.exe), превышающее 2,5 секунды, оно выдаст сообщение об ошибке.

Когда служба Microsoft Exchange Information Store service (Store.exe) ожидает ответа на межкомпонентные вызовы, работа потоков удаленного вызова процедур (RPC) может замедляться, что приведет к снижению производительности сервера Exchange, например к задержке ответа сервера на запросы клиентов.

Большое время ответа на обращение службы Microsoft Exchange Information Store (Store.exe) к функциям внешнего антивирусного программного обеспечения может быть вызвано следующими условиями:

  • Обновления средства поиска вирусов вызывают повторную проверку объектов в хранилище информации.

  • Средство поиска вирусов неправильно настроено.

  • Программа поиска вирусов обрабатывает длинное сообщение или вложение.

Чтобы решить эту проблему, сделайте следующее:

  • Запланируйте обновление средства поиска вирусов на то время, когда потребление ресурсов невелико, то есть на промежутки времени с минимальной загрузкой.

  • Попробуйте переустановить программу поиска вирусов. Это лучше сделать во время минимальной загрузки.

  • Просмотрите настройки средства поиска вирусов, проверьте правильность настройки потоков, исключений на уровне файлов и т. п. См. статью 823166 базы знаний корпорации Майкрософт «Использование антивирусных программ на сервере Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Просмотрите статьи, указанные в этом документе, в разделе Дополнительные сведения.

Дополнительные сведения

Для получения дополнительных сведений о программах поиска вирусов, обычно используемых с Microsoft Exchange Server 2003, см. статью 823166 базы знаний корпорации Майкрософт «Использование антивирусных программ на сервере Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Для получения дополнительных сведений о программах поиска вирусов, обычно используемых с Microsoft Exchange 2000 Server, см. статью 328841 базы знаний корпорации Майкрософт «Антивирусное программное обеспечение для Exchange» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Для получения дополнительных сведений о производительности сервера Exchange см. «Руководство по производительности и масштабируемости Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=47576).

Для получения дополнительных сведений об устранении неполадок, связанных с производительностью сервера Exchange, см. «Устранение неполадок в работе Microsoft Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=47588).

Для получения дополнительных сведений об устранении неполадок, связанных с производительностью банка сообщений, см. статью 257725 базы знаний корпорации Майкрософт «XADM: "Сбор диагностических данных для решения проблем, связанных с хранилищем информации» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


Медленные вызовы снимков службы теневого копирования
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-13

Средство анализатора сервера Microsoft® Exchange просматривает журнал вызовов функций Exchange (файл Store.fcl) для поиска событий компонента снимков службы теневого копирования, время ответа которых превышает 20 секунд.

События компонента журнала вызовов функций Exchange для служб теневого копирования представляет вызовы функций службы банка данных Microsoft Exchange (Store.exe) компонента снимков службы теневого копирования томов.

Служба теневого копирования томов — это набор COM API, который внедряет систему, разрешающую резервное копирование томов, выполняемое во время записи приложениями системы данных на эти тома.

Microsoft Exchange Server 2003 использует службу теневого копирования томов, которая включена в операционную систему Microsoft Windows Server™ 2003 для выполнения теневого копирования томов баз данных Exchange Server 2003 и файлов журнала транзакций.

Снимок службы теневого копирования томов не является полностью независимым от исходных данных. Вообще, снимки создаются при определении маркера времени с гарантией отката данных до этой временной точки.

Если анализатор сервера Exchange обнаруживает, что события в файле Store.fcl отражают время ответа, превышающее 20 секунд, для вызовов функций компонента снимков службы теневого копирования томов службой банка данных Microsoft Exchange, анализатор отображает сообщение об ошибке.

Когда межкомпонентные вызовы от службы «Банк данных Microsoft Exchange» (Store.exe) ожидают ответа, потоки удаленных вызовов процедур могут архивироваться на фоне этих запросов, что может быть причиной проблем производительности сервера Exchange, например задержек ответов сервера на запросы клиентов.

Примечание.
Если снимок службы теневого копирования томов был специально сделан в течение 20 секунд во время сбора данных журнала вызова трассировки Exchange, можно не обращать внимания на это сообщение как на индикатор неполадки с производительностью сервера Exchange.

Рекомендуется не занимать промежутки между выполнением резервных копий оперативным обслуживанием или периодами пиковых пользовательских запросов.

Дополнительные сведения

Дополнительные сведения о службах теневого копирования томов см. на веб-узле, посвященном советам и рекомендациям по использованию службы теневого копирования томов в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=56571).


За последние 24 часа зарегистрировано событие состояния «ошибка» SMTPSVC (код: 429)
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-03-16

Анализатор Microsoft Exchange опрашивает метабазу IIS для определения значения свойства LM/SmtpSvc/%SMTPInstance%/ServerState для каждого экземпляра виртуального SMTP-сервера.

Свойство ServerState представляет текущее состояние экземпляра сервера. Возможны следующие состояния и соответствующие им коды: 1 (запуск), 2 (запущен), 3 (остановка), 4 (остановлен), 5 (приостановка), 6 (приостановлен) и 7 (работает).

Если анализатор Exchange определяет, что значение свойства ServerState для экземпляра виртуального SMTP-сервера не равно 2 (запущен), он запрашивает класс Win32_NTLogEvent инструментария управления Microsoft Windows (WMI), чтобы проверить, было ли за последние 24 часа зарегистрировано событие 429 об ошибке службы SMTP (SMTPSVC).

Если анализатор Exchange обнаруживает, что экземпляр виртуального SMTP-сервера не запущен, а в журнале за последние 24 часа зарегистрировано по крайней мере одно событие 429 об ошибке службы SMTPSVC, выводится предупреждение.

Это предупреждение указывает на возможные проблемы с назначенными каталогами для экземпляра виртуального сервера SMTP.

SMTP является основным почтовым протоколом для отправки и транспорта почты в Exchange Server. Это означает, что протокол SMTP используется клиентами для отправки сообщений, а серверами Exchange Server — для доставки сообщений и данных сообщений.

Когда сообщения поступают на сервер Exchange Server через службу SMTP, данные записываются на жесткий диск в виде EML-файла. По умолчанию эти файлы хранятся в папке <диск>:\Program Files\Exchsrvr\Mailroot в том же разделе, в котором установлен Exchange.

Ниже приведены возможные причины данной проблемы.

  • Каталог <диск>:\Program Files\Exchsrvr\Mailroot или папки внутри него перемещены, повреждены или отсутствуют.

  • Неправильно установлены разрешения на каталог <диск>:\Program Files\Exchsrvr\Mailroot или папки внутри него.

  • Антивирусная программа проверяет каталог <диск>:\Program Files\Exchsrvr\Mailroot или папки внутри него.

Чтобы устранить это предупреждение, выполните одно или несколько из указанных ниже действий.

  • Проверьте местоположение и целостность каталога <диск>:\Program Files\Exchsrvr\Mailroot и папок внутри него.

  • Проверьте разрешения на каталог <диск>:\Program Files\Exchsrvr\Mailroot и папки внутри него.

  • Убедитесь, что антивирусные программы не проверяют папки внутри каталога <диск>:\Program Files\Exchsrvr\Mailroot.

Проверка пути к каталогу Mailroot в Exchange Server 2003

  1. Откройте диспетчер Exchange.

  2. Последовательно разверните узел Servers (Серверы), сервер Exchange Server, пункты Protocols (Протоколы) и SMTP.

  3. Щелкните правой кнопкой мыши виртуальный SMTP-сервер (например виртуальный SMTP-сервер по умолчанию) и выберите пункт Stop (Остановить).

  4. Щелкните правой кнопкой мыши виртуальный SMTP-сервер еще раз и выберите пункт Properties (Свойства).

  5. Откройте вкладку Messages (Сообщения).

  6. В поле Queue directory (Каталог очереди) проверьте полный путь к соответствующей папке Mailroot. Для поиска пути на локальном компьютере можно нажать кнопку Browse (Обзор).

  7. Нажмите кнопку OK, чтобы сохранить изменения.

  8. Щелкните правой кнопкой мыши виртуальный SMTP-сервер и выберите пункт Start (Запустить).
Проверка пути к каталогу Mailroot в Exchange 2000 Server

  1. Остановите все службы Exchange Server и IIS на компьютере с Exchange 2000 Server, на котором требуется проверить папку Mailroot виртуального SMTP-сервера.

  2. Убедитесь, что значение параметра msExchSmtpQueueDirectory соответствующего виртуального SMTP-сервера содержит правильный путь.

  3. Подождите, пока Active Directory реплицирует это изменение на серверы глобального каталога, используемые сервером Exchange Server.

  4. Запустите службу системного помощника Microsoft Exchange.

  5. На компьютере с сервером Exchange Server проверьте наличие в журнале событий приложений трех экземпляров события с кодом 1005, в качестве источника события для которых указан MSExchangeMU, а в качестве категории — General (Общие).

  6. Чтобы изменения вступили в силу, перезапустите компьютер с сервером Exchange Server.
Проверка разрешений по умолчанию на каталог Mailroot в Exchange 2000 Server и Exchange Server 2003

  1. Запустите проводник, перейдите к папке Exchsvr и откройте ее.

  2. Щелкните правой кнопкой мыши папку Mailroot и выберите команду Свойства.

  3. Откройте вкладку Безопасность и проверьте указанные ниже разрешения по умолчанию.

Учетная запись | Разрешения
Администраторы | «Полный доступ»
Прошедшие проверку | «Чтение и выполнение», «Список содержимого папки», «Чтение»
Создатель-владелец | Нет
Операторы сервера | «Изменение», «Чтение и выполнение», «Список содержимого папки», «Чтение», «Запись»
Система | «Полный доступ»
  1. Убедитесь, что данные разрешения по умолчанию установлены для всех папок каждого экземпляра виртуального сервера.

Дополнительные сведения об описанных выше процедурах см. в следующих статьях базы знаний Майкрософт:

  • 822933, «Изменение местоположения папки SMTP Mailroot в Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822933) (на английском языке)

  • 318230, «XCON. Изменение местоположения каталога SMTP Mailroot в Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=318230) (на английском языке)

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • 266686, «XCON. Настройка виртуального SMTP-сервера, часть 1» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) (на английском языке)

  • 268163, «XCON. Настройка виртуального SMTP-сервера, часть 2» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (на английском языке)

Дополнительные сведения о настройке антивирусных программ для использования с Exchange Server см. в статье Не настроены исключения для папок, проверяемых на вирусы.

Дополнительные сведения о настройке исключений для проверки в режиме реального времени в антивирусной программе Symantec AntiVirus Corporate Edition см. на веб-узле компании Symantec (http://www.symantec.com) (на английском языке).

Примечание.
Веб-адреса могут измениться, поэтому существует вероятность того, что не удастся подключиться к упомянутым здесь веб-узлам.

Дополнительные сведения об улучшении защиты среды Exchange Server от вирусов и вирусов-червей, распространяемых по электронной почте, см. в статье «Замедление и остановка передачи вирусов по электронной почте в среде Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=47587) (на английском языке).

Дополнительные сведения об использовании антивирусных программ с сервером Exchange Server см. в следующих статьях базы знаний Майкрософт:

  • 328841, «Антивирусное программное обеспечение для Exchange» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, «Использование антивирусных программ на сервере Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, «XGEN. Отношение корпорации Майкрософт к антивирусным решениям для Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105) (на английском языке)

  • 245822, «Рекомендации по устранению неполадок на компьютере с сервером Exchange Server, использующем антивирусные программы» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Список антивирусных программ сторонних производителей для Exchange Server см. на веб-узле «Партнеры по Exchange Server 2007: антивирусные решения и средства защиты от нежелательной почты» (http://go.microsoft.com/fwlink/?linkid=16226) (на английском языке).


Полное доменное имя SMTP-экземпляра не совпадает с именем сервера
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-07

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить совпадает ли значение строки ncacn_ip_tcp: атрибута networkAddress объекта сервера с полным доменным именем (FQDN) в атрибуте msExchSmtpFullyQualifiedDomainName объекта виртуального SMTP-сервера.

Если анализатор сервера Exchange обнаруживает, что значения этих атрибутов не совпадают, выводится предупреждение.

Данное предупреждение указывает, что значения указанных атрибутов могли изменены вручную и это может привести к возникновению проблем на сервере.

Значение атрибута msExchSmtpFullyQualifiedDomainName указывает полное доменное имя виртуального SMTP-сервера, оно должно быть разрешимо с использованием сетевого протокола DNS.

Для значения этого атрибута должна существовать допустимая запись DNS HOST (A), чтобы серверы обмена сообщениями, которые предпринимают попытку разрешить полное доменное имя виртуального SMTP-сервера, могли извлечь верный IP-адрес и соответствующим образом направить почту.

Дополнительные сведения о возможности обратного DNS-поиска в Exchange см. в материале «Add a resource record to a DNS zone» (http://go.microsoft.com/fwlink/?LinkId=63002) (Добавление записи ресурса в DNS-зону).

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • 266686, «XCON: How to Configure a SMTP Virtual Server Part 1» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) (Инструкции по настройке виртуального SMTP-сервера, часть 1).

  • 268163, «XCON: How to Configure a SMTP Virtual Server Part 2» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (Инструкции по настройке виртуального SMTP-сервера, часть 2).

Дополнительные сведения о структуре SMTP-службы см. в материале «SMTP Service Design» (Структура SMTP-службы) в руководстве Technical Reference Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=58876) (Техническое руководство по Exchange Server 2003).


Длина локальной очереди SMTP превышает пороговое значение
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-04-20

Анализатор сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Local Queue Length объекта производительности SMTP Server для анализа данных о производительности.

Если анализатор сервера Exchange обнаруживает, что счетчик Local Queue Length превысил пороговое значение 1000 за выборочный квант времени, то выдается сообщение об ошибке.

Счетчик SMTP Server\Local Queue Length указывает число сообщений в очереди SMTP, ожидающих локальной доставки в службу банка данных Microsoft Exchange. Данные (каталог «Mailroot») локальной очереди SMTP временно хранятся в устройстве хранения во время их обработки сервером Exchange. Такое решение предотвращает потерю данных в случае отказа сервера. Например, когда сервер-получатель недостижим, сообщения, которые должны направляться на этот сервер, будут храниться в каталоге очереди локального сервера до тех пор, пока они не смогут быть доставлены.

Данная ошибка указывает на проблемы с производительностью или простои сервера, так как сервер не может доставить своевременно входящую почту. Эта задержка может быть обусловлена следующими причинами:

  • Не выполняется своевременное обращение в службу каталогов Active Directory®.

  • Сообщения не передаются своевременно для локальной доставки или очереди SMTP.

  • Отключены базы данных (хранилища почтовых ящиков и хранилища общих папок).

  • Чтобы устранить эту проблему, выполните следующие шаги:

  • Убедитесь, что все базы данных (хранилища почтовых ящиков и хранилища общих папок) подключены.

  • Идентифицируйте источник узких мест по производительности. Узкое место по производительности может относиться к процессору, диску, сети или памяти и может быть вызвано увеличением нагрузки на сервер или отсутствием достаточных ресурсов сервера. Используйте средство системного монитора (Perfmon.msc), чтобы определить, является ли причиной узкого места повышенная нагрузка на сервер или не достаточны ресурсы сервера. Если возросла нагрузка на сервер, идентифицируйте источник нагрузки и уменьшите нагрузку. Если не хватает ресурсов сервера, увеличьте необходимые ресурсы или переместите пользователей с сервера.

  • Ведите наблюдение за внешними зависимостями, например, за службой каталогов Active Directory, по проблемам, связанным с производительностью и при необходимости определяйте и устраняйте обнаруженные неполадки.

Дополнительные сведения

  • Дополнительные сведения о настройке транспорта SMTP см. в описании настройки транспорта SMTP в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Дополнительные сведения об устранении проблем с потоком почты см. в базе знаний Майкрософт в статье 823489, содержащей инструкции по использованию средства просмотра очереди для устранения неполадок потока почты в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Дополнительные сведения об устранении проблем транспорта см. в базе знаний Майкрософт в статье 257265, содержащей общие сведения об устранении проблем транспорта в Exchange 2000 Server и в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265).

  • Дополнительные сведения об узких местах работы процессора см. в разделе Узкое место в работе процессора.

  • Дополнительные сведения об узких местах работы дисков см. в разделе Обнаружено узкое место на диске.

  • Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Дополнительные сведения об устранении проблем производительности сервера Exchange см. в разделе Устранение неполадок приложения Microsoft Exchange Server, связанных с производительностью по адресу http://go.microsoft.com/fwlink/?LinkId=47588 (возможно, на английском языке).

  • Дополнительные сведения о перемещении почтовых ящиков пользователей и уменьшении нагрузки на сервер см. по ссылке Перенос почтовых ящиков пользователей на другой сервер.


Объект системного монитора SMTP Server недоступен
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Local Queue Length объекта производительности SMTP Server для анализа данных о производительности. Если этот счетчик не возвращает допустимые данные, выводится базовое сообщение.

Если допустимые данные не возвращаются модулем сбора данных о производительности, возможно любое сочетание следующих условий:

  • Объект производительности SMTP Server отключен.

  • Объект системного монитора SMTP Server отсутствует или поврежден.

  • Для анализатора сервера Exchange не назначены разрешения, необходимые для получения доступа к объектам производительности.

Первые два условия могут возникнуть в том случае, если реестр поврежден определенными расширяемыми счетчиками или изменен программами, основанными на WMI-классах (Microsoft Windows® Management Instrumentation). Приводимая ниже процедура позволяет устранить первые два условия. Перед выполнением данной процедуры убедитесь, что анализатору сервера Exchange назначены соответствующие разрешения. Дополнительные сведения о разрешениях, требуемых для выполнения анализатора сервера Exchange, см. в справочной документации, включенной в анализатор сервера Exchange. Чтобы открыть справку, откройте анализатор сервера Exchange и нажмите клавишу F1.

Чтобы устранить эту ошибку

  1. Убедитесь, что объект производительности SMTP Server включен.

    1. Загрузите и установите средство списка расширяемых счетчиков производительности (Exctrlst.exe). Средство Exctrlst.exe можно загрузить с веб-узла Exctrlst.exe: расширяемый список счетчиков производительности (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Откройте окно средства Exctrlst.exe, щелкните Порядок сортировки, а затем — Служба.

    3. Найдите службу, сведения о которой поставляет данный объект производительности, и проверьте, что установлен флажок Счетчики производительности включены.

      Если флажок Счетчики производительности включены не установлен, установите его, а затем перезапустите связанную с нужными счетчиками производительности службу, чтобы проверить, что эти счетчики производительности работоспособны. Если счетчики производительности не работоспособны или флажок Счетчики производительности включены уже установлен, перейдите к выполнению шага 2.

  2. Повторно создайте отсутствующие или поврежденные счетчики производительности в соответствии с инструкциями статьи 300956 базы знаний Майкрософт, описывающей перестройку значений библиотеки счетчиков производительности вручную (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Если после выполнения процедуры, указанной в этой статье базы знаний, проблема не будет устранена, понадобится переустановить операционную систему Windows в режиме Восстановление, а затем применить последние пакеты обновления Windows.


На сервере SQL Server выполняется виртуальный сервер Virtual Server 2005, на котором установлен сервер Exchange с правами гостя
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_ComputerSystem, чтобы определить, установлено ли для ключа Model значение Virtual Machine.

Кроме того, анализатор сервера Exchange поверяет наличие следующего значения реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

Анализатор сервера Exchange также запрашивает queries WMI-класс Win32_Services, чтобы определить выполняется ли служба Microsoft SQL Server™ (MSSQLSERVER) на физическом компьютере с сервером Microsoft Virtual Server 2005.

Если анализатор сервера Exchange обнаруживает, что ключ Model содержит строку Virtual Machine, существует указанный выше раздел реестра и выполняется служба MSSQLSERVER , выводится сообщение об ошибке.

Значение Virtual Machine в ключе Model указывает, что данный компьютер с сервером Exchange Server работает как виртуальная машина с правами гостя под управлением Virtual Server 2005 или Microsoft Virtual PC 2004. Поскольку вышеуказанный раздел реестра создается только сервером Virtual Server 2005, его наличие означает, что данный компьютер сервера Exchange работает в качестве виртуальной машины с правами гостя на сервере Virtual Server 2005.

Корпорация Майкрософт не поддерживает работу ни одной версии Microsoft Exchange на виртуальной машине или под управлением эмулятора. Это правило распространяется на работу сервера Exchange Server под управлением Microsoft Virtual Server 2005, Microsoft Virtual PC 2004 или любой другой программы виртуальной машины сторонней разработки. Платформы Microsoft Exchange Server предназначены для работы только на физическом оборудовании (и протестированы исходя из этого принципа), в частности, для работы с аппаратными платформами, включенными в каталог серверов Windows (http://go.microsoft.com/fwlink/?linkid=17219).

Более того, выполнение Exchange с правами гостя на виртуальном сервере, установленном на компьютере с SQL Server, не рекомендуется, поскольку не обеспечивает нужного уровня избыточности между серверами.

Чтобы устранить эту ошибку

  1. Переместите почтовые ящики с сервера Exchange, работающего под управлением Virtual Server 2005, на компьютер Exchange Server, не являющийся виртуальным.

  2. При необходимости измените связи публичных папок и переключите роли, присвоенные данному виртуальному серверу Exchange.

  3. Удалите Exchange с виртуальной машины, чтобы списать его, а также удалите его из инфораструктуры Exchange и службы каталогов Active Directory®.

Дополнительные сведения о перемещении почтовых ящиков см. в следующих статьях базы знаний Майкрософт:

  • 822892, «Move Mailbox improvements in Exchange 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)) (Улучшенные возможности перемещения почтовых ящиков в Exchange Server 2003)

  • 224975, «XADM: Differences Between Move Mailbox Methods» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975) (XADM: различия между способами перемещения почтовых ящиков)

Дополнительные сведения о поддержке компьютеров Exchange Server, работающих в виртуальных средах, см. в статье 320220 базы знаний «Support Boundaries for Exchange Server on a Virtual Machine or an Emulation Machine» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220) (Ограничения поддержки работы Exchange Server на виртуальных машинах и эмуляторах).

Дополнительные сведения о Microsoft Virtual Server 2005 см. на веб-узле Microsoft Virtual Server 2005 (http://go.microsoft.com/fwlink/?linkid=34938).

Дополнительные сведения о Microsoft Virtual PC 2004 см. на веб-узле Microsoft Virtual PC 2004 (http://go.microsoft.com/fwlink/?linkid=34663).


Номер порта SRS ниже 5000
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра, чтобы определить значение параметра TCP/IP для службы репликации сайта Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

Если анализатор сервера Exchange находит, что значение TCP/IP меньше 5 000 (десятичное), отображается предупреждение.

В случае, если необходимо установить статическое значение параметра TCP/IP, рекомендуется установить значение, чуть превышающее 5000. Назначение статических номеров портов ниже 5000 может привести к конфликту с портами других процессов и завершится сбоем процессов службы репликации сайта Microsoft Exchange.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы установить значение раздела реестра для порта TCP/IP

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters

  3. Дважды щелкните раздел TCP/IP и установите в поле Значение целочисленное значение, превышающее 5000 (десятичное).

  4. Закройте редактор реестра.

  5. Перезапустите службу репликации сайта Microsoft Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об ограничениях портов см. в статье 194952 базы знаний, посвященной ограничениям статически сопоставляемых портов, используемых для сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952)


SRS-порт был переопределен вручную
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange определяет, что значение порта для службы репликации сайтов Microsoft Exchange было переопределено вручную, на основании данных в следующем разделе реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

Если анализатор сервера Exchange обнаружит, что раздел TCP/IP существует, выводится сообщение о наличии конфигурации, не являющейся заданной по умолчанию.

Наиболее распространенная причина настройки этого значения — включение клиентов MAPI для подключения к серверу Exchange, который находится по другую сторону межсетевого экрана. Этот сценарий содержит процедуру открытия нескольких портов на межсетевом экране для предоставления клиентам Microsoft Office Outlook® 2003 возможности подключения с помощью MAPI к серверу Exchange, как правило, через Интернет. Это поддерживаемая конфигурация. Дополнительные сведения о настройке клиентов MAPI для подключения к Exchange через межсетевой экран см. в статье 270836 базы знаний Майкрософт "Exchange 2000 and Exchange 2003 Static Port Mappings" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836) (Сопоставление статических портов Exchange 2000 и Exchange 2003). Если этот сценарий не используется, данный раздел реестра следует удалить.

Рекомендуемое развертывания для использования Outlook в режиме MAPI с целью подключения к серверу Exchange через Интернет — это использование удаленных вызовов процедур через HTTP-функции, доступные в Windows Server™ 2003, Exchange Server 2003, Outlook 2003 и Microsoft Windows® XP Professional. Режим MAPI ранее назывался «Корпоративным» режимом или режимом «Рабочей группы».

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы удалить раздел реестра TCP/IP

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters

  3. Удалите значение реестра с названием TCP/IP.

  4. Закройте редактор реестра и повторно запустите службу репликации сайтов Microsoft Exchange.

Чтобы развернуть удаленные вызовы процедур через HTTP

  1. Изучите документ, "Exchange Server 2003 RPC over HTTP Deployment Scenarios" (http://go.microsoft.com/fwlink/?linkid=47577) (Сценарии развертывания удаленных вызовов процедур Exchange Server 2003 через HTTP).

  2. Изучите статью 833401 базы знаний Майкрософт "How to configure RPC over HTTP on a single server in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401) (Инструкции по настройке удаленных вызовов процедур через HTTP на одиночном сервере в Exchange Server 2003).

  3. Изучите статью 827330 базы знаний Майкрософт "How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330) (Инструкции по устранению в Office Outlook 2003 проблем подключения при передаче удаленных вызовов процедур клиента через HTTP).

  4. Изучите веб-презентацию службы поддержки Майкрософт, "Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134) (Использование Microsoft Exchange через Интернет (RPC/HTTP) с помощью средств Microsoft Office Outlook 2003).

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт "Description of the Microsoft Windows Registry" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).


Учетная запись запуска, указанная для системного помощника, не поддерживается
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Services чтобы определить, используется ли учетная запись LocalSystem для учетной записи запуска, указанной в свойстве StartName службы системного помощника Microsoft Exchange (MSExchangeSA) . Если анализатор сервера Exchange обнаруживает, что в свойстве StartName на компьютере Exchange 2000 Server или Exchange Server 2003 указана учетная запись, отличная от учетной записи LocalSystem, выводится сообщение об ошибке. Учетная запись LocalSystem также называется учетной записью SYSTEM.

Системный помощник MSExchangeSA в Exchange 2000 Server или Exchange Server 2003 необходимо запустить в контексте безопасности LocalSystem. Нельзя запускать помощник MSExchangeSA путем его привязки к учетной записи отдельного пользователя. Когда служба Exchange, выполняемая с учетной записью LocalSystem, получает доступ к удаленному серверу, выполняется проверка подлинности этой службы Exchange с использованием учетных данных учетной записи компьютера.

В стандартном механизме смены паролей пароль учетной записи компьютера меняется раз в семь дней. Это позволяет повысить уровень безопасности учетной записи компьютера. Учетная запись компьютера более безопасна, чем учетная запись обычного пользователя, по следующим причинам:

  • Пароль учетной записи обычного пользователя меняется реже.

  • Пароль учетной записи обычного пользователя формируется не с такой степенью случайности, как пароль учетной записи компьютера.

В Exchange Server 5.5 учетные записи пользователей используются для служб. Некоторые администраторы, имеющие опыт работы с Exchange Server 5.5, изменяют учетную запись запуска для служб Exchange 2000 Server и Exchange Server 2003 с учетной записи LocalSystem на учетную запись пользователя.

В Exchange 2000 Server и Exchange Server 2003 корпорация Майкрософт поддерживает выполнение MSExchangeSA только с учетной записью по умолчанию LocalSystem.

Чтобы устранить эту ошибку

  1. Щелкните Пуск, укажите Программы, укажите Администрирование, а затем щелкните Службы.

  2. В области сведений щелкните правой кнопкой мыши Системный помощник Microsoft Exchange и выберите команду Свойства.

  3. На вкладке Вход в разделе Вход от имени щелкните Локальная системная учетная запись, а затем нажмите кнопку ОК.

  4. Щелкните правой кнопкой мыши Системный помощник Microsoft Exchange и выберите команду Перезапустить.

Дополнительные сведения о службах Exchange см. в статье 239762 базы знаний Майкрософт «Exchange Services Run Under LocalSystem» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762) (Службы Exchange выполняются с учетной записью LocalSystem).


Отсутствует файл STORE.EXE
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы проверить наличие нескольких основных двоичных файлов Exchange:

  • Exres.dll,

  • Gapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»),

  • Mapi32.dll (записывается в папку «System32» и в папку «\Exchsrvr\bin»),

  • Mapisp32.dll,

  • Mapistub.dll,

  • Cdo.dll,

  • DavEx.dll,

  • DSAccess.dll,

  • EmsMta.exe,

  • Epoxy.dll,

  • Ese.dll,

  • Eseutil.exe,

  • ExCdo.dll,

  • ExchMem.dll,

  • ExMime.dll,

  • ExOleDb.dll,

  • ExPop3.dll,

  • ExSmtp.dll,

  • Mad.exe,

  • Mbdsz.dll,

  • OabGen.dll,

  • PhatCat.dll,

  • Phatq.dll,

  • Reapi.dll,

  • ReSvc.dll,

  • Store.exe.

Если анализатор сервера Exchange обнаружит отсутствие одного или нескольких из перечисленных выше файлов, на экран будет выведено сообщение об ошибке. Чтобы устранить эту ошибку, установите последний пакет обновлений или сборку обновлений для своей версии Exchange. Если эта ошибка продолжает оставаться, запустите программу установки Exchange 2000 Server или Exchange Server 2003 и выберите Переустановить. При запуске программы установки в режиме переустановки устанавливаются только двоичные файлы. Программа не удаляет и не переустанавливает какие-либо пользовательские данные или данные конфигурации. Если сервер Exchange переустановлен, необходимо также переустановить все пакеты обновлений и исправления Exchange, которые устанавливались ранее.

Чтобы переустановить Exchange 2000 Server или Exchange Server 2003

  1. Войдите на сервер, на котором необходимо переустановить Exchange. Вставьте в дисковод компакт-дисков компакт-диск Exchange 2000 Server или Exchange Server 2003.

  2. В меню Пуск выберите команду Выполнить, а затем введите <дисковод>:\setup\i386\setup, где <дисковод> — дисковод компакт-дисков.

  3. На странице Добро пожаловать в мастер установки Microsoft Exchange нажмите кнопку Далее.

  4. На странице Лицензионное соглашение ознакомьтесь с лицензионным соглашением. Если согласны с условиями лицензионного соглашения, щелкните Принимаю и нажмите кнопку Далее.

  5. На странице Идентификация продукта введите свой 25-разрядный ключ продукта и нажмите кнопку Далее.

  6. На странице Выбор компонентов в столбце Действие воспользуйтесь указывающей вниз стрелкой рядом с узлом Microsoft Exchange и выберите Переустановить, а затем нажмите кнопку Далее.

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange Server 2003 см. на веб-узле загружаемых ресурсов Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Дополнительные сведения о последних пакетах обновлений, сборках обновлений и надстройках Exchange 2000 Server см. на веб-узле загружаемых ресурсов Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Значение HTTP-порта хранилища — меньше 5000
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-03-21

Средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить значение параметра Rpc/HTTP Port для службы банка данных Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

Если средство анализатора сервера Exchange обнаруживает, что для Rpc/HTTP Port задано значение меньше 5000 (десятичное число), отображается предупреждение.

Значение раздела реестра Rpc/HTTP Port задается равным 6001 во время установки Exchange Server 2003. Раздел реестра Rpc/HTTP Port используется для поддержки удаленного вызова по протоколу HTTP для Microsoft Office Outlook® 2003 и Microsoft Office Outlook 2007.

Если развертывание RPC через HTTP не настроено с помощью служб консультации корпорации Майкрософт или по рекомендации служб поддержки продукции компании Майкрософт, рекомендуется выполнять развертывание RPC через HTTP, используя значения порта по умолчанию.

Если для параметра Rpc/HTTP Port необходимо задать значение, отличное от 6001, рекомендуется задавать значение, которое будет больше 5000. Назначение статических номеров порта до 5000 может стать причиной конфликта порта с другим процессом и привести к сбою процесса службы банка данных Microsoft Exchange.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы установить значение по умолчанию раздела реестра для порта RPC по HTTP, выполните следующие действия.

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

  3. Дважды щелкните ключ Rpc/HTTP Port и установите в поле Значение значение 6001 или целое число, превышающее 5000 (десятичное).

  4. Закройте редактор реестра.

  5. Перезагрузите компьютер, чтобы эта настройка вступила в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о настройке RPC через HTTP см. в следующих статьях базы знаний Майкрософт:

  • Статья 833401, содержащая инструкции по настройке удаленных вызовов процедур через HTTP на одиночном сервере в Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • Статья 827330, содержащая инструкции по устранению в Office Outlook 2003 проблемы подключения при передаче удаленных вызовов процедур клиента через HTTP (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


Хранилище:порт HTTP не является портом по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-09

Средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра, чтобы определить, является ли значение раздела HTTP Port значением по умолчанию:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

Если анализатор сервера Exchange обнаружит, что значение параметра Rpc/HTTP Port не равно 6001 (десятичное), будет отображено сообщение о нестандартной конфигурации.

Во время установки Exchange Server 2003 и Exchange Server 2007 значение раздела реестра Rpc/HTTP Port задается равным 6001. Раздел реестра Rpc/HTTP Port используется для поддержки функциональных возможностей RPC по протоколу HTTP для Microsoft Office Outlook® 2003 и Microsoft Office Outlook 2007.

Если развертывание удаленного вызова процедур через HTTP не было настроено с помощью служб консультации корпорации Майкрософт или по рекомендациям служб поддержки продуктов Майкрософт, рекомендуется развертывать удаленный вызов процедур через HTTP по стандартным портам.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы установить значение по умолчанию раздела реестра для порта Rpc/HTTP

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Дважды щелкните значение Rpc/HTTP Port и установите в поле Значение 6001 (десятичное).

  4. Закройте редактор реестра.

  5. Перезагрузите компьютер, чтобы эта настройка вступила в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о настройке удаленного вызова процедур через HTTP см. в следующих статьях базы знаний:

  • статья 833401, посвященная инструкциям по настройке удаленных вызовов процедур через HTTP на одиночном сервере Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401);

  • статья 827330, посвященная устранению неполадок в клиенте удаленных вызовов процедур через подключения HTTP в Office Outlook 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).


Неоптимальная конфигурация параметров памяти
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-02-15

Средство анализа Microsoft Exchange запрашивает класс WMI Win32_NTLogEvent для определения того, была ли в течение последних 24 часов зарегистрирована ошибка 9665 для объекта MSExchangeIS.

При запуске процесса хранилища сервер Microsoft Exchange Server 2003 проверяет, оптимально ли настроены параметры памяти. Если нет, в средстве просмотра событий будет зарегистрировано событие 9665.

Если средство анализа Exchange обнаруживает, что в последние 24 часа было зарегистрировано событие 9665, оно читает поле данных события, чтобы определить, какие в нем установлены флаги из указанных в приведенной ниже таблице.

Флаг поля данных события | Предупреждение, отображаемое анализатором Exchange Server | Проблема с Exchange Server 2003
0x00000001 | Параметр /3GB не задан | Сервер работает под управлением Microsoft Windows 2000 Advanced Server или Microsoft Windows 2000 Datacenter Server, имеет не менее 1 ГБ физической памяти, но в файле boot.ini для него не задан параметр /3GB.
0x00000002 | Параметр /Userva задан неверно | Сервер работает под управлением Microsoft Windows Server 2003 Standard Edition, Microsoft Windows Server 2003 Enterprise Edition или Microsoft Windows Server 2003 Datacenter Edition и имеет не менее 1 ГБ физической памяти; параметр /3GB задан, но параметр /USERVA отсутствует в файле boot.ini.
0x00000004 | Необходимо задать параметр SystemPages | Сервер работает под управлением Microsoft Windows 2000 Server, а значение реестра SystemPages не попадает в диапазон от 24 000 до 31 000.
0x00000008 | Необходимо сбросить параметр SystemPages | Сервер работает под управлением Microsoft Windows Server 2003 Standard Edition, Microsoft Windows Server 2003 Enterprise Edition или Microsoft Windows Server 2003 Datacenter Edition, а параметр реестра SystemPages имеет значение, отличное от нуля.
0x00000010 | Параметр HeapDecommitFreeBlockThreshold задан неверно | Сервер работает под управлением Microsoft Windows 2000 Server или Microsoft Windows Server 2003, а параметр реестра HeapDeCommitFreeBlockThreshold имеет значение, отличное от 0x00040000.

В зависимости от флага, присутствующего в поле данных события 9665, анализатор Exchange отображает соответствующее предупреждение из приведенной выше таблицы.

Эти предупреждения свидетельствуют о том, что память Exchange Server находится в неоптимальном состоянии.

Для устранения причин этих предупреждений воспользуйтесь рекомендациями, приведенными в указанных ниже статьях о средстве анализа Exchange.

  • Объем памяти почтового сервера Exchange равен 1 ГБ или более, однако для него не установлен переключатель /3GB в файле Boot.ini

  • Переключатель USERVA установлен неправильно

  • Слишком большое значение параметра «SystemPages»

  • Этот сервер работает под управлением Windows Server 2003, а значение SystemPages не равно 0

  • На сервере установлено не менее 1 ГБ физической памяти, а для параметра HeapDeCommitFreeBlockThreshold не указано значение 262144

Дополнительные сведения

Дополнительные сведения об этих проблемах см. в статье 325044 базы знаний Майкрософт, «Устранение неполадок, связанных с фрагментацией виртуальной памяти, в Exchange Server 2003 и Exchange 2000 Server» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044 (на английском языке).

Дополнительные сведения о событии MSExchangeIS 9665 см. на странице «Центр сообщений о событиях и ошибках: сведения о событиях».

  • Сведения о событии 9665 хранилища почтовых ящиков см. по адресу http://go.microsoft.com/fwlink/?LinkId=83210 (на английском языке).

  • Сведения о событии 9665 общего хранилища см. по адресу http://go.microsoft.com/fwlink/?LinkId=83213 (на английском языке).


На клиенстких компьютерах предположительно установлена возможность поиска на рабочем столе
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-09-05

Анализатор сервера Microsoft® Exchange выявил, что у многих пользователей установлен модуль поиска на рабочем столе. Модули поиска на рабочем столе могут направлять в подключенные почтовые ящики пользователей многочисленные удаленные вызовы процедур, а также создавать значительный трафик обмена данными с общими папками, поскольку эти модули ведут поиск в структуре файлов хранилища общих папок. Многие модули поиска просматривают публичные папки только в том случае, если эти папки находятся в списке избранных общих папок пользователя. Таким образом, загрузка серверов общих папок в связи с выполнением поиска на рабочем столе возможна, но не обязательна.

Чтобы снизить остроту этой проблемы, можно выполнить следующие действия:

  • Попросите пользователей отключить возможности сканирования в Microsoft Office Outlook® или ограничить область сканирования своим личным почтовым ящиком.

  • Обеспечьте выполнение Outlook в режиме кэширования Exchange, чтобы при сканирование велось только в отношении локальных рабочих станций, а не сервера.

  • Следуйте инструкциям, содержащимся в базе знаний Майкрософт, в статье 889086, описывающей возможность непредвиденного поведения компьютера под управлением Windows XP при попытке доступа к общим папкам на сервере Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=889086), чтобы получить оперативное исправление и установить параметр MaxObjsPerMapiSession реестра на компьютерах с функционирующим сервером Exchange, к которым имеют доступ пользователи, обладающие возможностью поиска на рабочем столе.

Чтобы проверить, что причиной высокой нагрузки, создаваемой отдельным пользователем, является именно приложение поиска на рабочем столе, проверьте операции удаленного вызова процедур модуля поиска с помощью средства наблюдения за пользователями сервера Microsoft Exchange (ExMon). Сбор данных должен вестись в течение достаточно длительного времени (не менее пяти минут). Затем удалите данный модуль поиска и повторно выполните средство ExMon. Если наблюдается существенное сокращение объема удаленных вызовов процедур, это свидетельствует, что увеличение нагрузки связано с работой модуля поиска на рабочем столе. Если снизилась средняя задержка удаленных вызовов процедур, это подтверждает, что именно высокая нагрузка приводила к повышению задержек удаленных вызовов процедур.

Примечание.
Размер задержек существенно меняется в течение суток. Поэтому пятиминутной проверки может быть недостаточно. Возможно, потребуется проводить измерения в течение более длительного промежутка времени.

Чтобы загрузить средство ExMon, посетите центр загрузки Майкрософт (http://go.microsoft.com/fwlink/?linkid=54983).

Дополнительные сведения

  • Дополнительные сведения о программном обеспечении поиска на рабочем столе см. в следующих материалах:

    • Статья 905184 базы знаний Майкрософт «Влияние работы программы поиска на компьютера на компьютерах с Outlook или другим клиентом MAPI на производительность Exchange 2000 Server и Exchange Server 2003» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184 (на английском языке).

    • Электронный журнал группы разработчиков Microsoft Exchange «Are your clients using desktop search engines that index Exchange mailboxes or public folders?» (http://go.microsoft.com/fwlink/?LinkId=52073)(Используются ли на ваших клиентских компьютерах модули поиска на рабочем столе, которые индексируют почтовые ящики Exchange или общие папки?).

  • Дополнительные сведения о быстродействии сервера Exchange см. в руководстве Exchange Server 2003 Performance and Scalability Guide (http://go.microsoft.com/fwlink/?LinkId=47576) (Руководство по производительности и масштабируемости Exchange Server 2003).

  • Дополнительные сведения об устранении проблем производительности сервера Exchange см. в материале Troubleshooting Microsoft Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588) (Устранение неполадок, связанных с производительностью Microsoft Exchange Server 2003).


Слишком большое значение параметра «SystemPages»
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-03-13

Чтобы определить значение параметр SystemPages, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

Если анализатор сервера Exchange обнаруживает, что значение атрибута SystemPages больше 50000, на экран выводится предупреждение.

Операционные системы Microsoft Windows Server™ 2003 и Microsoft Windows® 2000 Server могут напрямую адресовать до 4 гигабайтов (ГБ) адресного пространства памяти, независимо от объема установленного ОЗУ. С точки зрения процесса каждый элемент виртуального адреса указывает на байт физической памяти. Диспетчер виртуальной памяти (Virtual Memory Manager, VMM) совместно с блоком диспетчера памяти процессора (Memory Manager Unit, MMU) отвечает за преобразование (сопоставление) каждого виртуального адреса в соответствующий физический адрес. Диспетчер виртуальной памяти выполняет сопоставление посредством разбиения ОЗУ на блоки страниц фиксированного размера и создания системных элементов таблицы страниц (Page Table Entries, PTE) для хранения сведений об этих блоках страниц и их сопоставления. Системные элементы таблицы страниц — это небольшие буферы памяти в защищенном режиме операционной системы, которые используются для взаимодействия с дисковой подсистемой ввода-вывода и сетью. Каждый элемент таблицы страниц представляет собой страничный блок и содержит сведения, необходимые диспетчеру виртуальной памяти для определения местоположения страницы.

В системах на основе процессора x86, где используются страницы размером 4 килобайта (КБ), максимальное количество элементов таблицы страниц, необходимых для сопоставления 2 ГБ адресного пространства, составляет 524 288 (2 ГБ/4 КБ). В аналогичных системах, где используется переключатель /3GB, количество элементов таблицы страниц, необходимых для сопоставления 3 ГБ адресного пространства, составляет 786 432 (3 ГБ/4 КБ). В типовой системе указанное пространство используется следующим образом:

  • Не более 50 000 элементов таблицы страниц (приблизительно 195 МБ адресного пространства) резервируется для общего использования.

  • Остальная память используется для сопоставления системного кэша, гиперпространства, выгружаемого пула, невыгружаемого пула, области аварийной копии памяти и так далее.

Размер этого пула элементов таблицы страниц автоматически определяется при запуске системы на основе объема физической памяти в системе. Этот пул вмещается между выгружаемым пулом и невыгружаемым пулом, которые также увеличиваются с объемом физической памяти в системе.

Пул системных элементов таблицы страниц может быть большей частью использован и сильно фрагментирован. Это может привести к ситуациям, когда невозможно загрузить драйвер, а также вызвать другие проблемы. Кроме того, если пул системных элементов таблицы страниц полностью занят, ухудшится работа других частей системы, что может вызвать сбой при создании потоков, системным остановам и потенциальным отказам системы.

Чтобы предотвратить чрезмерную фрагментацию пула системных элементов таблицы страниц, следует всегда правильно настраивать параметр реестраSystemPages для операционной системы, установленной на компьютере с Exchange Server. При использовании Exchange Server в среде Windows Server 2003 рекомендуется задать для параметра SystemPages значение 0. Для Windows 2000 Server, наоборот, рекомендуется установить параметр SystemPages равным значению в диапазоне от 24000 до 31000.

После выполнения описанной ниже процедуры следует проконтролировать количество свободных системных элементов таблицы страниц. Это можно сделать путем наблюдения за счетчиком производительности «Память | Свободные системные элементы таблицы страниц» (также называемого системным монитором). Если после внесения изменений в реестр количество свободных системных элементов таблицы страниц остается малым, следует выполнить следующие проверки, чтобы убедиться в оптимальной настройке компьютера сервера Exchange:

  • Драйверы. Неправильно функционирующий драйвер — одна из наиболее распространенных причин малого количества системных элементов таблицы страниц. Кроме того, некоторые версии драйверов видеоадаптера S3 Savage 4 задают для параметра SystemPages значение 208896. Такой драйвер часто привязан к серверам IBM E-Series. Обратитесь к производителю оборудования и убедитесь, что используются новейшие версии драйверов для всех компонентов оборудования. Кроме того, существует возможность отката к более простому драйверу с меньшим номером версии. Например, компьютеры, на которых выполняются серверные приложения, такие как сервер Exchange, обычно не нуждаются в самых последних драйверах видеоадаптеров со всеми их возможностями. Вместо них в большинстве случаев подойдет более простой драйвер. При переходе от усовершенствованного драйвера видеоадаптера к более простому драйверу должно увеличиться количество свободных системных элементов таблицы страниц.

  • Конфигурация системы. Если на компьютере с Windows Server 2003 установлен 1 ГБ ОЗУ или более, необходимо проверить, правильно ли заданы переключатели /3GB и /USERVA=3030 в файле Boot.ini, как описано в следующих статьях базы знаний Майкрософт:

    • Статья 823440, в которой обсуждается необходимость использования переключателя /3GB при установке Exchange Server 2003 на компьютере с Windows Server 2003 ( может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440)

    • Статья 810371, описывающая использование переключателя /Userva на сервере Exchange, выполняемом на компьютере под управлением Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371).

  • Журналы событий. На сервере Exchange проверьте журнал событий приложений на наличие ошибок и предупреждений, особенно событий MSExchangeIS 9582 (ошибки и предупреждения), 9665 (предупреждение) и 12880 (ошибка). Присутствие в журнале события 9665 может также указывать на то, что параметр SystemPages не настроен для достижения оптимальной производительности. Дополнительные сведения об этих событиях см. в статье 325044 базы знаний Майкрософт, содержащей инструкции по устранению проблем, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044).

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить причины появления этого предупреждения в Windows 2000 Server путем изменения значения параметра «SystemPages»

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. В правой области дважды щелкните параметр SystemPages.

  4. В поле Значение введите значение от 24000 до 31000 (десятичное) и нажмите кнопку ОК. Если вы не уверены, какое значение использовать, рекомендуется ввести 31000 (десятичное).

  5. Закройте редактор реестра и перезапустите компьютер, чтобы изменения вступили в силу.

Чтобы устранить причины появления этого предупреждения в Windows Server 2003 путем изменения значения параметра «SystemPages»

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. В правой области дважды щелкните параметр SystemPages.

  4. В поле Значение введите 0 и нажмите кнопку OK.

  5. Закройте редактор реестра и перезапустите компьютер, чтобы изменения вступили в силу.

Чтобы устранить причины появления этого предупреждения путем установки более поздней или более ранней версии драйвера видеоадаптера

  • Выполните одно из следующих действий:

    • Обратитесь к изготовителю оборудования для получения обновленного драйвера видеоадаптера, не изменяющего параметр SystemPages.

    • Установите стандартный драйвер VGA, а затем исправьте значение SystemPages, как описано выше.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в статье 256986 базы знаний Майкрософт, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об оптимизации памяти для сервера Exchange см. в следующих статьях базы знаний Майкрософт:

  • Статья 325044, содержащая инструкции по устранению проблем, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • Статья 815372, описывающая оптимизацию использования памяти в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • Статья 311901, описывающая влияние настройки 4GT на системные элементы таблицы страниц (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


Значение HTTP-порта системного помощника меньше 5000
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-03-21

Средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра, чтобы определить значение параметра HTTP Port для системного помощника Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

Если анализатор сервера Exchange обнаруживает, что значение HTTP Port меньше 5000 (десятичное), отображается предупреждение.

Значение раздела реестра HTTP Port задается равным 6002 во время установки Exchange Server 2003. Раздел реестра HTTP Port используется для поддержки удаленного вызова по протоколу HTTP для Microsoft Office Outlook® 2003 и Microsoft Office Outlook 2007.

Если развертывание удаленного вызова процедур через HTTP не было настроено с помощью служб консультации корпорации Майкрософт или по рекомендациям служб поддержки продуктов Майкрософт, рекомендуется развертывать удаленный вызов процедур через HTTP с использованием стандартных портов.

Если необходимо задать для HTTP Port значение, отличное от 6002, рекомендуется задать значение, превышающее 5000. Назначение статических номеров портов меньше 5000 может привести к конфликту портов с другим процессом и сбою процесса системного помощника Microsoft Exchange.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» средства Regedit.exe или Regedt32.exe.

Чтобы установить значение по умолчанию раздела реестра для порта HTTP, выполните следующие действия.

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Дважды щелкните раздел HTTP Port и задайте в поле Значение значение 6002 (десятичное) или целочисленное значение, превышающее 5000 (десятичное).

  4. Закройте редактор реестра.

  5. Перезагрузите компьютер, чтобы эта настройка вступила в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о настройке удаленного вызова процедур через HTTP см. в следующих статьях базы знаний:

  • Статья 833401, посвященная инструкциям по настройке удаленных вызовов процедур через HTTP на одиночном сервере Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401);

  • Статья 827330, посвященная устранению неполадок в клиенте удаленных вызовов процедур через подключения HTTP в Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).


Значение HTTP NSPI-порта системного помощника — меньше 5000
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-03-21

Средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить значение параметра Rpc/HTTP NSPI Port для системного помощника Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

Если средство анализатора сервера Exchange обнаруживает, что для Rpc/HTTP NSPI Port задано значение меньше 5000 (десятичное число), отображается предупреждение.

Значение раздела реестра Rpc/HTTP NSPI Port задается равным 6004 во время установки Exchange Server 2003. Раздел реестра Rpc/HTTP NSPI Port используется для поддержки удаленного вызова по протоколу HTTP для Microsoft Office Outlook® 2003 и Microsoft Office Outlook 2007.

Если развертывание RPC по HTTP не было настроено с помощью служб Microsoft Consulting Services или по рекомендациям служб поддержки продуктов Майкрософт, рекомендуется развертывать RPC по HTTP с использованием стандартных портов.

Если для параметра Rpc/HTTP NSPI Port необходимо задать значение, отличное от 6004, рекомендуется задавать значение, которое будет больше 5000. Назначение статических номеров порта, значение которых ниже 5000, может стать причиной конфликта порта с другим процессом и привести к сбою процесса службы системного помощника Microsoft Exchange.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы установить для раздела реестра порта Rpc/HTTP NSPI его значение по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Дважды щелкните ключ Rpc/HTTP NSPI Port и установите в поле Значение значение 6004 (десятичное число) или целое число, превышающее 5000 (десятичное число).

  4. Закройте редактор реестра.

  5. Перезагрузите компьютер, чтобы эта настройка вступила в силу.

Перед редактированием реестра, а также для получения сведений о редактировании реестра см. статью 256986 базы знаний Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о настройке RPC через HTTP см. в следующих статьях базы знаний Майкрософт:

  • Статья 833401, содержащая инструкции по настройке удаленных вызовов процедур через HTTP на изолированном сервере в Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • Статья 827330, содержащая инструкции по устранению в Office Outlook 2003 проблемы подключения при передаче удаленных вызовов процедур клиента через HTTP (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


Системный помощник:HTTP-порт NSPI не является портом по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, является ли значение HTTP Port значением по умолчанию, средство анализатора приложения Microsoft® Exchange Server считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

Если анализатор сервера Exchange обнаруживает, что значение Rpc/HTTP NSPI Port не равно 6004 (десятичное), выводится сообщение о том, что конфигурация не является конфигурацией по умолчанию.

Для раздела реестра Rpc/HTTP NSPI Port программа установки Exchange Server 2003 устанавливает значение 6004. Раздел реестра Rpc/HTTP NSPI Port используется для поддержки функций RPC через HTTP для Microsoft Office Outlook® 2003.

Если настройка развертывания RPC через HTTP не выполняется с помощью службы консультаций Майкрософт или по рекомендациям службы поддержки продуктов Майкрософт, рекомендуется развертывать RPC через HTTP, используя значения портов по умолчанию.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Установка значения реестра «Rpc/HTTP NSPI Port»

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Дважды щелкните раздел Rpc/HTTP NSPI Port и установите значение поля Value data равным 6004 (десятичное).

  4. Закройте редактор реестра.

  5. Перезагрузите компьютер, чтобы эта настройка вступила в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт, посвященную описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (возможно, на английском языке).

Дополнительные сведения о настройке RPC через HTTP см. в следующих статьях базы знаний Майкрософт:

  • 833401, посвященная настройке удаленных вызовов процедур через HTTP на одиночном сервере в Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401) (возможно, на английском языке).

  • 827330, посвященная устранению в Office Outlook 2003 проблем подключения при передаче удаленных вызовов процедур клиента через HTTP (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330) (возможно, на английском языке).


Системный помощник:значение HTTP-порта отличается от заданного по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-09

Чтобы определить, имеет ли параметр HTTP Port значение по умолчанию, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

Если анализатор сервера Exchange обнаруживает, что для параметра HTTP Port установлено значение, отличное от 6002 (десятичное), выводится сообщение о том, что текущая конфигурация отличается от заданной по умолчанию.

Значение раздела реестра HTTP Port задается равным 6002 во время установки Exchange Server 2003. Раздел реестра HTTP Port используется для поддержки удаленного вызова по протоколу HTTP для Microsoft Office Outlook® 2003 и Microsoft Office Outlook 2007.

Если текущее развертывание удаленных вызовов процедур через HTTP было настроено не по рекомендациям консультационных служб Майкрософт или служб поддержки продуктов Майкрософт, рекомендуется развернуть удаленные вызовы процедур через HTTP со значениями портов, заданными по умолчанию.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы задать значение по умолчанию для раздела реестра, определяющего использование HTTP-порта

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Дважды щелкните раздел HTTP Port и задайте в поле Значение значение 6002 (десятичное).

  4. Закройте редактор реестра.

  5. Перезагрузите компьютер, чтобы данное изменение вступило в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения о настройке удаленных вызовов процедур через HTTP см. в следующих статьях базы знаний Майкрософт:

  • 833401, «How to configure RPC over HTTP on a single server in Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401) (Инструкции по настройке удаленных вызовов процедур через HTTP на одиночном сервере в Exchange Server 2003).

  • 827330, «How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330) (Инструкции по устранению в Office Outlook 2003 проблем подключения при передаче удаленных вызовов процедур клиента через HTTP).


Отсутствует значение системного помощника legacyExchangeDN
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-09

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута legacyExchangeDN объекта системного помощника для каждого из компьютеров Exchange Server. Если анализатор сервера Exchange не находит значение атрибута legacyExchangeDN объекта системного помощника, выводится сообщение об ошибке.

Отсутствие атрибута legacyExchangeDN может привести к сбою при аварийном восстановлении, если администратор изменяет Active Directory в процессе аварийного восстановления базы данных. Чтобы устранить эту ошибку, необходимо изменить атрибут legacyExchangeDN с помощью редактора Active Directory, например средства LDP (ldp.exe) или оснастки «Редактирование» интерфейса ADSI.

Чтобы убедиться, что атрибут legacyExchangeDN настроен правильно, следует также изучить другие объекты системного помощника на данном или другом сервере Exchange, работа которых не приводит к возникновению этой ошибки, так как они должны иметь схожее значение атрибута legacyExchangeDN.

Если атрибут legacyExchangeDN отсутствует в базе данных, он также может отсутствовать в нескольких других системных объектах. Таким образом, если добавлено новое значение атрибута legacyExchangeDN с помощью средства LDP или оснастки «Редактирование» интерфейса ADSI, потребуется также добавить новое значение атрибута legacyExchangeDN для всех остальных системных объектов.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью оснастки «Редактирование» интерфейса ADSI, средства LDP или другого LDAP-клиента версии 3 может привести к возникновению серьезных неполадок. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, а также сервера Exchange Server 2003, сервера Exchange Server 2007 или обоих продуктов. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Чтобы устранить эту ошибку

  1. Откройте редактор Active Directory, например оснастку «Редактирование» интерфейса ADSI.

  2. Разверните узел Конфигурация [имя_домена], а затем разверните узел CN=Configuration, DC=DomainName, DC=DomainSuffix.

  3. Разверните узел CN=Services, а затем разверните узел CN=Microsoft Exchange.

  4. Последовательно разверните CN=OrganizationName, CN=Administrative Groups и CN=AdminGroupName.

  5. Последовательно разверните CN=Servers и CN=ServerName.

  6. Щелкните правой кнопкой мыши CN=Microsoft System Attendant и выберите команду Свойства.

  7. Выполните прокрутку вниз, выберите legacyExchangeDN и нажмите кнопку Изменить.

  8. В поле «Значение» введите правильное значение атрибута legacyExchangeDN.

  9. Закройте редактор Active Directory и перезапустите компьютер сервера Exchange, чтобы изменения вступили в силу.

Дополнительные сведения о создании нового атрибута legacyExchangeDN с помощью оснастки «Редактирование» интерфейса ADSI см. в статье 273863 базы знаний Майкрософт «How to Change the LegacyExchangeDN Attribute in Native Mode with ADSI Edit» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863) (Инструкции по изменению атрибута LegacyExchangeDN в основном режиме с помощью оснастки «Редактирование» интерфейса ADSI).


Порт NSPI системного помощника переопределен вручную
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-17

Средство анализатора сервера Microsoft® Exchange определяет факт переопределения вручную службы целевого сервера интерфейса поставщика службы поддержки имен (целевого сервера NSPI) на основании данных в следующем разделе реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

Если анализатор сервера Exchange обнаруживает, что раздел TCP/IP NSPI Port существует и настроен, выводится сообщение о наличии конфигурации, не являющейся заданной по умолчанию.

Наиболее распространенная причина для настройки этого значения — включение клиентов MAPI для подключения к серверу Exchange, который находится по другую сторону межсетевого экрана. Этот сценарий содержит процедуру открытия нескольких портов на межсетевом экране для предоставления клиентам Microsoft Office Outlook® 2003 возможности подключения с помощью MAPI к серверу Exchange, как правило, через Интернет.

При развертывании для использования Outlook в корпоративном режиме или режиме рабочей группы с целью подключения к серверу Exchange через Интернет рекомендуется использовать удаленные вызовы процедур (RPC) с помощью HTTP-функций, реализованных в Windows Server™ 2003, Exchange Server 2003, Outlook 2003 и Microsoft Windows® XP Professional.

При использовании RPC через HTTP отпадает необходимость в использовании подключения через виртуальную частную сеть (VPN) и открытии нескольких портов в межсетевом экране для получения MAPI-доступа из Outlook 2003 к серверу Exchange Server 2003. Пользователь, работающий в Outlook 2003, может подключиться к серверу Exchange через Интернет. RPC-клиент устанавливает подключение Интернета с помощью туннелирования трафика RPC через протокол HTTP. Если RPC-клиент может установить подключение HTTP/HTTPS к удаленному компьютеру, на котором работает служба IIS, данный RPC-клиент сможет подключиться к любому серверу в удаленной сети. Для сервера в удаленной сети должна быть настроена доступность из Интернета с помощью RPC через HTTP. Программы RPC-клиента и RPC-сервера могут подключаться через Интернет даже если обе эти программы находятся внутри межсетевых экранов, расположенных в разных сетях.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы удалить раздел реестра TCP/IP NSPI Port

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите в следующий раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Удалите значение реестра TCP/IP NSPI Port.

  4. Выйдите из редактора реестра и перезагрузите службу системного помощника Exchange.

Чтобы развернуть удаленные вызовы процедур через HTTP

  1. Ознакомьтесь с материалом «Exchange Server 2003 RPC over HTTP Deployment Scenarios» (http://go.microsoft.com/fwlink/?linkid=47577) (Сценарии развертывания RPC по протоколу HTTP в Exchange Server 2003).

  2. Изучите статью 833401 базы знаний Майкрософт «How to configure RPC over HTTP on a single server in Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401) (Инструкции по настройке удаленных вызовов процедур через HTTP на одиночном сервере в Exchange Server 2003).

  3. Изучите статью 827330 базы знаний Майкрософт «How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330) (Инструкции по устранению в Office Outlook 2003 проблем подключения при передаче удаленных вызовов процедур клиента через HTTP).

  4. Изучите веб-презентацию службы поддержки Майкрософт «Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134) (Использование Microsoft Exchange через Интернет (RPC/HTTP) с помощью Microsoft Office Outlook 2003).

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения об использовании значения реестра TCP/IP NSPI Port в среде межсетевого экрана см. в статье 270836 базы знаний Майкрософт «Exchange 2000 and Exchange 2003 Static Port Mappings» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836) (Сопоставление статических портов Exchange 2000 и Exchange 2003).


Служба системного помощника настроена на взаимодействие с рабочим столом
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Service, чтобы определить значение свойства DesktopInteract для службы системного помощника Microsoft Exchange (MSExchangeSA). Если анализатор сервера Exchange обнаружит, что служба системного помощника Exchange настроена на взаимодействие с рабочим столом, он выводит на экран сообщение об ошибке.

Данную конфигурацию следует использовать только под руководством службы поддержки продуктов Майкрософт. Если служба поддержки продуктов Майкрософт дает указание вам работать со службой системного помощника в данной конфигурации, рекомендуется перенастроить свойства службы системного помощника так, чтобы она не взаимодействовала с рабочим столом.

Чтобы настроить учетную запись службы системного помощника Exchange

  1. Откройте оснастку консоли управления (MMC) службами

  2. Найдите и остановите службу Системный помощник Microsoft Exchange . Заметьте, что при остановке службы системного помощника также останавливаются все службы, зависящие от службы системного помощника. В их число входит служба банка данных Microsoft Exchange.

  3. Дважды щелкните службу Системный помощник Microsoft Exchange .

  4. На вкладке Вход страницы Свойства системного помощника Microsoft Exchange выберите пункт Локальная системная учетная запись в группе Вход в качестве.

  5. Снимите флажок Разрешить службе взаимодействие с рабочим столом и затем нажмите кнопку Применить.

  6. В разделе Состояние службы щелкните Запустить, а затем нажмите кнопку OK.

  7. Закройте оснастку «Службы».

Дополнительные сведения о правильной конфигурации службы Exchange см. в базе знаний Майкрософт в статье 239762, посвященной работе служб Exchange под LocalSystem (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762).


Служба системного помощника не работает в качестве локальной системы
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-01-09

Средство Microsoft® Exchange Server Analyzer отправляет классу Microsoft Windows® Management Instrumentation (WMI) службы Win32_Service запрос на определение значения свойства StartName службы системного помощника Microsoft Exchange System Attendant (MSExchangeSA). Кроме того, средство анализа Exchange Server посылает службе каталога Active Directory® запрос на определение значения атрибута serialNumber объекта Exchange Server в каталоге. Атрибут serialNumber объекта Exchange Server определяет версию Exchange Server, установленную на компьютере, который представляет объект. Если анализатор Exchange Server обнаруживает, что служба системного помощника Exchange на сервере Exchange под управлением Exchange 2000 Server, Exchange Server 2003 или Exchange Server 2007 работает под любой учетной записью, кроме учетной записи локальной системы LocalSystem (SYSTEM), анализатор Exchange Server отображает сообщение об ошибке.

Данная ошибка указывает на то, что такая настройка службы системного помощника не поддерживается. При запуске службы системного помощника под любой другой учетной записью возникнут ошибки, связанные с разрешениями и доступом.

Для устранения данной ошибки необходимо настроить службу системного помощника Exchange таким образом, чтобы она запускалась под учетной записью локальной системы LocalSystem (SYSTEM).

Примечание.
Эта ошибка не относится к Exchange Server версии 5.5. Запуск службы системного помощника Exchange под учетной записью LocalSystem требуется только для Exchange 2000 Server, Exchange Server 2003 и Exchange Server 2007.
Для настройки учетной записи службы системного помощника Exchange выполните следующее:

  1. Откройте оснастку Microsoft Management Console (MMC) Службы.

  2. Найдите и остановите работу службы системного помощника Microsoft Exchange System Attendant. Обратите внимание на то, что остановка работы службы системного помощника также остановит работу всех служб, зависящих от работы службы системного помощника. В частности, к таким службам относится служба информационного хранилища Microsoft Exchange Information Store.

  3. Дважды щелкните службу системного помощника Microsoft Exchange System Attendant.

  4. На вкладке Вход страницы свойств системного помощника Microsoft Exchange System Attendant Properties выберите для параметра Войти как значение С системной учетной записью и щелкните Применить.

  5. В разделе Состояние службы выберите Запустить, а затем нажмите кнопку OK.

  6. Закройте оснастку Службы.

Дополнительные сведений о запуске служб Exchange под учетной записью LocalSystem см. в статье 239762 базы знаний Майкрософт, посвященной запуску служб Exchange под учетной записью локальной системы LocalSystem (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762).


Раздел TcpTimedWaitDelay отсутствует, или его значение отличается от значения по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-03-13

Анализатор Microsoft Exchange опрашивает службу каталогов Active Directory для определения значения атрибута serialNumber для всех объектов с классом объектов msExchExchangeServer. Если строковое значение содержит выражение «Version 5.5», на компьютере выполняется Exchange Server 5,5. Если строковое значение содержит выражение «Version 6.0», на компьютере выполняется Exchange 2000 Server. Если строковое значение содержит выражение «Version 6.5», на компьютере установлен сервер Exchange Server 2003. Если строковое значение содержит выражение «Version 8.0», на компьютере установлен сервер Exchange Server 2007.

Анализатор Exchange считывает следующий раздел реестра для каждого обнаруженного сервера Exchange Server 2007, чтобы определить, присвоено ли разделу TcpTimedWaitDelay значение по умолчанию (60):

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Раздел TcpTimedWaitDelay определяет время, которое должно пройти, прежде чем TCP сможет освободить закрытое подключение и повторно использовать его ресурсы. Этот интервал между закрытием и освобождением называется состоянием TIME_WAIT или 2MSL. В течение этого времени можно повторно открыть подключение с намного меньшими затратами для клиента и сервера, чем при установке нового подключения.

Уменьшение значения этого раздела позволяет протоколу TCP быстрее освобождать закрытые подключения и предоставлять больше ресурсов новым подключениям. Однако если это значение слишком мало, протокол TCP может освобождать ресурсы подключения до его завершения, что потребует от сервера использования дополнительных ресурсов для повторной установки подключения.

Если анализатор Exchange обнаруживает, что значение раздела TcpTimedWaitDelay отсутствует или не равно значению по умолчанию (60), выводится предупреждение.

Для обеспечения оптимальной производительности на серверах Exchange Server 2007 рекомендуется назначить для раздела TcpTimedWaitDelay значение по умолчанию 60.

Важно!
Этот раздел содержит сведения об изменении реестра. Перед изменением реестра убедитесь, что знаете, как восстановить его в случае возникновения проблем. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Задание значения по умолчанию для раздела реестра TcpTimedWaitDelay

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\Tcpip\Parameters

  3. Дважды щелкните раздел реестра TcpTimedWaitDelay и укажите в поле Значение значение 60 (десятичное).

  4. Закройте редактор реестра и перезапустите компьютер.

Сведения о внесении изменений в реестр см. в статье 256986 базы знаний Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986). Изучите эту статью перед началом изменения реестра.

Данная проблема связана с проблемой анализатора Раздел MaxUserPort отсутствует, или его значение отличается от значения по умолчанию.

Дополнительные сведения о влиянии разделов реестра MaxUserPort и TcpTimedWaitDelay см. в разделе «Протокол TCP» комплекта ресурсов для Windows 2000 (http://go.microsoft.com/fwlink/?LinkId=85654) (на английском языке).


По-видимому, переменная TEMP/TMP указывает на недопустимую или неподходящую папку
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить на компьютере некластерного сервера Exchange значения переменных окружения TEMP и TMP, средство анализатора сервера Microsoft® Exchange считывает следующие записи реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

HKLM\System\CurrentControlSet\Control\Session Manager\Environment\TMP

Служба «Банк данных Microsoft Exchange» использует папки TEMP и TMP в качестве временного хранилища во время различных операций, таких как преобразование сообщений и перемещение почтовых ящиков. На некластерном сервере Exchange служба «Банк данных Microsoft Exchange» использует переменную SYSTEM (например, Local System), которая в свою очередь использует настройку %Systemroot%\Temp переменной среды по умолчанию как для TEMP, так и для TMP. Если одна либо обе переменные среды, TEMP или TMP, сервера Exchange начинаются со строки %SYSTEMROOT, на экран будет выведено предупреждение.

Переменные среды TEMP и TMP применяются, чтобы указать, какие папки в файловой системе (какой путь) должны использоваться приложениями, для которых необходимо временное рабочее пространство. Переменная TEMP обычно используется приложениями, такими как Microsoft Exchange, а переменная TMP обычно используется средствами разработки, такими как Microsoft Visual C++®. Путь для каждой переменной обычно указывается относительно контекста безопасности приложения или средства.

Когда анализатор сервера Exchange запускается для анализа виртуального сервера Exchange в кластере Microsoft Windows Server™ 2003, он не читает ветвь реестра HKLM. Вместо этого он читает следующие записи реестра:

HKEY_USERS\<Идентификатор безопасности учетной записи службы кластеров>\Environment\TEMP

HKEY_USERS\<Идентификатор безопасности учетной записи службы кластеров>\Environment\TMP

Виртуальные серверы Exchange, работающие в кластере Windows Server 2003, используют настройки переменных среды для учетной записи службы кластеров, которая выполняется в контексте принципа безопасности конкретного пользователя. Для учетных записей пользователей переменная среды по умолчанию для TEMP и TMP устанавливается равной %Userprofile%\temp. Если одна либо обе переменные среды, TEMP или TMP, виртуального сервера Exchange начинаются со строки %SYSTEMROOT, на экран будет выведено предупреждение.

Для обеспечения оптимальной производительности рекомендуется не указывать диск, содержащий операционную систему, для размещения папок TEMP и TMP, используемых приложением Exchange. Кроме того, следует убедиться, что для этих переменных среды заданы пути к быстрому диску или скоростной дисковой подсистеме, таким как массив дисков RAID 0+1. Также рекомендуется не указывать диск, содержащий операционную систему, для папок TEMP и TMP, используемых приложением Exchange или виртуальными серверами Exchange.

Чтобы устранить причину появления этого предупреждения

  1. Войдите в систему компьютера сервера Exchange с помощью учетной записи, обладающей правами администратора.

  2. Щелкните правой кнопкой мыши Мой компьютер и в контекстном меню выберите Свойства.

  3. Выберите вкладку Дополнительно.

  4. Нажмите кнопку Переменные среды.

  5. В области Переменные среды выберите TEMP и нажмите кнопку Изменить.

  6. В поле Значение переменной введите новый путь для переменной среды TEMP и нажмите кнопку OK.

  7. В области Переменные среды выберите TMP и нажмите кнопку Изменить.

  8. В поле Значение переменной введите новый путь для переменной среды TMP и нажмите кнопку OK.

  9. Нажмите кнопку OK, чтобы закрыть диалоговое окно «Переменные среды» и нажмите кнопку OK еще раз, чтобы закрыть диалоговое окно «Свойства системы».

  10. Перезагрузите узел, чтобы применить изменение.

Дополнительные сведения об изменении переменных среды TEMP и TMP на кластерном сервере Exchange см. по ссылке Путь кластера TEMP/TMP находится на диске с системным разделом.


На сервере установлено не менее 1 ГБ физической памяти, а для параметра HeapDeCommitFreeBlockThreshold не указано значение 262144
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-08-14

Сообщение об ошибке

Введение

Анализатор сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить, оптимальна ли настройка Exchange с учетом доступной в системе физической памяти:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\HeapDeCommitFreeBlockThreshold

Если анализатор сервера Exchange обнаруживает, что на компьютере Exchange Server с установленной физической памятью объемом не менее 1 гигабайта (ГБ) не задан параметр HeapDeCommitFreeBlockThreshold, выводится предупреждение.

Когда освобождается память по конкретному адресу, диспетчер неорганизованной памяти операционной системы проверяет, сколько смежных байт было высвобождено рядом с этим адресом. После завершения проверки диспетчер неорганизованной памяти выполняет одно из двух следующих действий:

  • Сохраняет блок смежной памяти выделенным.

  • Высвобождает блок смежной памяти и помечает его только как зарезервированный.

В разделе реестра HeapDecommitFreeBlockThreshold указывается число смежных байт, при превышении которого память будет высвобождена. По умолчанию диспетчер нераспределенной памяти не всегда объединяет все свободные блоки памяти или выделяет новую память. В результате высвобождаемые блоки могут стать бесполезными областями виртуального адресного пространства. Это может вызвать фрагментацию виртуальной памяти, замедление производительности и в конечном итоге нестабильность работы системы.

В системах, где установлено не менее 1 ГБ физической памяти, можно оптимизировать производительность путем управления размерами блоков высвобождаемой памяти. Раздел реестра HeapDecommitFreeBlockThreshold обеспечивает управление обработкой и высвобождением памяти. При добавлении этого параметра в реестр необходимо указать для него шестнадцатеричное значение 0x00040000 (десятичное значение 262144).

Корпорация Майкрософт не поддерживает использование других значений в качестве параметра реестра HeapDecommitFreeBlockThreshold.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Control\Session Manager

  3. Создайте новое значение DWORD с именем HeapDecommitFreeBlockThreshold.

  4. Дважды щелкните значение HeapDecommitFreeBlockThreshold и введите шестнадцатеричное значение 0x00040000 (десятичное значение 262144).

  5. Закройте редактор реестра и перезапустите компьютер Exchange Server, чтобы изменения вступили в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения о разделе реестра HeapDecommitFreeBlockThreshold см. в следующих статьях базы знаний Майкрософт:

  • 315407, «XADM: Раздел реестра "HeapDecommitFreeBlockThreshold"» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=315407)

  • 815372, «How to optimize memory usage in Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372) (Инструкции по оптимизации использования памяти в Exchange Server 2003)

  • 325044, «HOW TO: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044) (Инструкции по устранению проблем, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000)


Этот сервер работает под управлением Windows Server 2003, а значение SystemPages не равно 0
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server считывает следующий параметр реестра для определения значения SystemPages:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

Кроме того, средство анализа Exchange Server запрашивает класс Win32_OperatingSystem инструментария Microsoft Windows Management Instrumentation (WMI) для определения значения параметра OSProductSuite. Значение этого параметра отражает версию операционной системы Microsoft Windows.

Если средство анализа Exchange Server обнаруживает, что значение SystemPages на компьютере с Exchange Server, работающим под управлением Microsoft Windows Server 2003, которая не является частью Microsoft Windows Small Business Server 2003, не равно 0, то появляется предупреждение.

При запуске Exchange Server 2003 с пакектом обновления 1 (SP1) на Microsoft Windows Server 2003 с 1 ГБ ОЗУ или более рекомендуется устанавливать значение параметра реестра SystemPages равным 0. Эта рекомендация противоречит рекомендации для Microsoft Windows 2000 Server, где значение SystemPages лежит между 24000 и 31000.

На компьютере Windows Server 2003, который не является частью установки Microsoft Windows Small Business Server 2003, не следует устанавливать для параметра реестра SystemPages значение, отличное от 0. В случае изменения система не сможет расчитать оптимальное значение и настраивать его при изменениях.

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неполадки. Для получения сведений о восстановлении реестра см. раздел «Восстановление реестра» справочной системы файла Regedit.exe или Regedt32.exe.
Внимание!
В результате настройки параметра реестра SystemPages на компьютере с запущенным Windows Server 2003 может снижаться максимальный размер выгружаемого пула памяти. Это может привести к истощению выгружаемого пула и нестабильности работы сервера.

Для устранения этого предупреждения

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. На правой панели дважды щелкните SystemPages.

  4. В поле Value data наберите 0, затем щелкните OK.

  5. Выйдите из редактора реестра и перезагрузите компьютер для вступления изменений в силу.

Перед правкой реестра, а также для получения сведений о правке реестра см. статью 256986 базы знаний Microsoft «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Для получения дополнительных сведений об организации памяти сервера Exchange см. статьи базы знаний:

  • 325044, «ИНСТРУКЦИЯ: Устранение фрагментации виртуальной памяти в Exchange 2003 и Exchange 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372, «Оптимизация использования памяти в Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 311901, «Результаты настроки 4GTна элементы таблицы страниц» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


Сервер Exchange содержит переключатель загрузки PAE в файле Boot.ini
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_ComputerSystem, чтобы определить, какие параметры заданы в свойстве SystemStartupOptions. Средство анализатора сервера Exchange делает запрос в службу каталогов Active Directory® на подсчет значения атрибута homeMDBBL объекта (msExchPrivateMDB) хранилища почтовых ящиков. Результатом подсчета является число почтовых ящиков обнаруженных на сервере Exchange.

Если анализатор сервера обнаруживает, что переключатель загрузки /PAE в файле boot.ini установлен на сервер Exchange, содержащий менее 500 почтовых ящиков, и работает на сервере Windows 2000 Server, на экран выводится предупреждение.

Расширения физической адресации (PAE) обеспечивают компьютеру доступ к более чем 4 ГБ физической памяти (ОЗУ). Сервер Exchange не поддерживает PAE. PAE обеспечивает доступ Windows к более чем 4 ГБ физической памяти. Сервер Exchange не может использовать более 4 ГБ физической памяти, и нет смысла устанавливать на компьютер, предназначенный для работы на нем сервера Exchange, ОЗУ емкостью более 4 ГБ. Расширение PAE включено, если переключатель загрузки /PAE присутствует в файле Boot.ini.

Чтобы устранить причину появления этого предупреждения только для Windows 2000, рекомендуется удалить переключатель /PAE из файла Boot.ini.

Чтобы устранить причину появления этого предупреждения

  1. В проводнике Windows перейдите к системному разделу. Это раздел, в котором хранятся файлы поддержки оборудования, такие как Boot.ini и NTLDR.

  2. Если файл Boot.ini не виден, возможно, в окне Свойства папки установлен флажок Скрывать защищенные системные файлы. Если это так, в окне проводника последовательно щелкните Сервис, Свойства папки, а затем щелкните Вид. Щелкните Показать скрытые файлы и папки. Снимите флажок Скрывать защищенные системные файлы (рекомендуется). При появлении запроса нажмите кнопку Да.

  3. Если файл Boot.ini виден в проводнике Windows, щелкните правой кнопкой мыши этот файл, выберите в контекстном меню команду Открыть с помощью и щелкните Блокнот, чтобы открыть файл.

  4. В разделе [Операционные системы] удалите переключатель /PAE.

  5. Сохраните и закройте файл и перезапустите сервер Exchange, чтобы изменения вступили в силу.

Дополнительные сведения о переключателе в файле Boot.ini /PAE см. в следующих статьях базы знаний Майкрософт:

  • 268363: "Intel Physical Addressing Extensions (PAE) in Windows 2000" (Расширения физической адресации (PAE) в Windows 2000)

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882: "Exchange Memory Use and the /3GB Switch" (Использование памяти Exchange и переключатель /3GB"

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882)


Этот сервер Exchange выполняется с включенными расширениями физических адресов
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-05-08

Средство анализатора сервера Microsoft® Exchange Server запрашивает WMI-класс Win32_OperatingSystem, чтобы определить значения для следующих ключей:

  • PAEEnabled Значение этого ключа указывает, включено ли расширение физических адресов. Значение True указывает, что расширение физических адресов включено, а значение False — что расширение физических адресов не включено.

  • Version Значение этого ключа указывает версию операционной системы Microsoft Windows, которая выполняется на данном компьютере. Значение 5.0.2195 указывает, что выполняется операционная система Microsoft Windows 2000 Server, а значение 5.2.3790 — что выполняется операционная система Microsoft Windows Server™ 2003.

  • ServicePackMajorVersion Значение этого ключа указывает основной номер версии установленного пакета обновлений Windows.

Анализатор сервера Exchange Server также запрашивает WMI-класс CIM_Datafile для дополнительного номера версии программы ntoskrnl.exe, выполняющейся в системе, чтобы определить, установлено ли на компьютере обновление системы безопасности MS04-032. Если дополнительный номер версии ntoskrnl.exe равен 174 или меньшему значению, это свидетельствует о том, что обновление MS04-032 не установлено. Если дополнительный номер версии ntoskrnl.exe превышает 174, это свидетельствует о том, что обновление MS04-032 установлено.

Если анализатор сервера Exchange Server обнаружит, что для PAEEnabled указано значение True для сервера Exchange Server, выполняющегося в среде Windows Server 2003, в которой не установлено обновление системы безопасности MS04-032, будет выведено сообщение об ошибке. Эта ошибка указывает, что данный компьютер уязвим по отношению к известной проблеме, которая может привести к сбою в работе банка данных Microsoft Exchange (Store.exe).

Exchange Server не использует расширение физических адресов. Расширение физических адресов обеспечивает доступ Windows к более чем 4 ГБ физической памяти. Сервер Exchange Server не может использовать более 4 ГБ физической памяти, поэтому нет смысла устанавливать на компьютер, предназначенный для выполнения сервера Exchange Server, ОЗУ емкостью более 4 ГБ. Расширение физических адресов включается, когда переключатель загрузки /PAE указывается в файле Boot.ini при загрузке или когда операционная система Windows Server 2003 обнаруживает устройства, поддерживающие «горячее» добавление памяти. Операционные системы Windows Server 2003 Enterprise Edition и Windows Server 2003 Datacenter Edition автоматически включают расширение физических адресов только в случае, если сервер использует устройства, поддерживающие «горячее» добавление памяти.

Чтобы устранить эту ошибку посредством установки обновления MS04-032

  1. Чтобы получить обновление MS04-032, ознакомьтесь со статьей базы знаний Майкрософт 840987, в которой описывается данное обновление системы безопасности для Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=840987).

  2. Выполните полное архивирование системы.

  3. Примените данное обновление, а затем перезапустите компьютер, чтобы это обновление вступило в силу.

Дополнительные сведения о расширении физических адресов см. следующие статьи базы знаний Майкрософт:

  • 268363: описывается расширение физических адресов в Windows 2000

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882: описывается использование памяти Exchange и переключателя /3GB

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882)

Дополнительные сведения о переключателе /NOPAE в Boot.ini см. статью MSDN, в которой описывается использование этого переключателя (http://go.microsoft.com/fwlink/?LinkId=51490).


Сервер Exchange выполняется с включенными расширениями физических адресов и переключателем загрузки /3GB
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_OperatingSystem, чтобы определить значение ключа PAEEnabled. Значение данного ключа определяет, включены ли расширения физических адресов (PAE). Если установлено значение «True», то расширения PAE включены, а если «False» — то отключены. Анализатор сервера Exchange также запрашивает WMI-класс Win32_OperatingSystem, чтобы определить значение ключа MaxProcessMemorySize.

Если анализатор сервера Exchange обнаружит, что значение PAEEnabled равно «True», а значение MaxProcessMemorySize больше 2097024, на экран выводится предупреждение. Предупреждение указывает на то, что указанные значения отличаются от значений по умолчанию. Анализатор сервера Exchange отображает эту конфигурацию только в информационных целях. Никаких действий выполнять не требуется.

Дополнительные сведения о PAE см. в следующих статьях базы знаний Майкрософт:

  • 268363: о расширениях физических адресов (PAE) Intel в Windows 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882: об использовании памяти в Exchange и переключателе /3GB (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882)


Этот сервер Exchange работает с ключами запуска /PAE и /3GB
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа сервера Microsoft® Exchange запрашивает класс Win32_ComputerSystem инструментария Microsoft Windows® Management Instrumentation (WMI), чтобы определить, какие параметры установлены в разделе SystemStartupOptions. Кроме того, анализатор сервера Exchange запрашивает класс Win32_OperatingSystem инструментария WMI, чтобы определить значение параметра MaxProcessMemorySize.

Если анализатор сервера Exchange обнаруживает, что значение параметра SystemStartupOptions включает в себя /PAE, значение Win32_OperatingSystem показывает Microsoft Windows 2000 Server, и значение для MaxProcessMemorySize больше, чем 2097024, отображается сообщение об ошибке.

Эта ошибка означает, что оба ключа запуска /PAE и /3GB установлены в файле Boot.ini. Расширение физического адреса (PAE) позволяет компьютеру получить доступ к более чем 4 гигабайтам (ГБ) физической памяти (ОЗУ). Сервер Exchange не поддерживает PAE. Сервер Exchange не может использовать более 4 ГБ физической памяти, так что нет смысла ставить больше 4 ГБ физической памяти на компьютер, который выделен под сервер Exchange. PAE включен, если ключ запуска /PAE имеется в файле Boot.ini при запуске.

Чтобы исправить эту ошибку только для Windows 2000 Server, рекомендуется удалить ключ /PAE из файла Boot.ini.

Чтобы исправить эту ошибку

  1. В проводнике Windows перейдите в системный раздел. Это раздел, который содержит зависящие от оборудования файлы, такие как Boot.ini и NTLDR.

  2. Файл Boot.ini может не быть виден, так как в Свойствах Папки установлен параметр Скрывать защищенные системные файлы. В этом случае в окне проводника Windows нажмите кнопку Сервис, выберите Свойства Папки и выберите Вид. Установите флажок Показывать скрытые файлы и папки. Снимите флажок Скрывать защищенные системные файлы (Рекомендуется). Когда будет предложено, нажмите Да.

  3. Когда файл Boot.ini в Windows Explorer станет видимым, щелкните его правой кнопкой мыши, нажмите Открыть с помощью и выберите Блокнот, чтобы открыть файл.

  4. В разделе [Operating Systems] удалите ключ /PAE.

  5. Сохраните и закройте файл, затем перезапустите компьютер, чтобы изменения вступили в силу.

Для получения дополнительных сведений о ключе /PAE в файле Boot.ini,см. следующие статьи в базе знаний корпорации Майкрософт:

  • 268363, «Расширение физического адреса Intel (PAE) в Windows 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882, «Использование памяти сервером Exchange и ключ /3GB» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882)


Данный сервер переднего плана настроен со службой обновления получателей
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchAddressListServiceLink для каждого объекта Recipient Update Service в каталоге. Атрибут msExchAddressListServiceLink — это ссылка из службы списков адресов на компьютер сервера Exchange, на котором выполняется служба обновления получателей. Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Сервер Exchange настроен как сервер переднего плана.

  • На компьютере сервера Exchange выполняется служба обновления получателей.

Служба обновления получателей — это компонент в службе системного помощника Exchange. Служба обновления получателей создает и обслуживает относящиеся к Exchange значения атрибутов в службе Active Directory. Если для пользователя создается почтовый ящик, служба обновления получателей отвечает за автоматическое создание SMTP-адреса (Simple Mail Transfer Protocol) и любых других прокси-адресов, которые определены в применяемых политиках получателей.

Если сервер Exchange, настроенный на использование службы обновления получателей, настроен также в качестве сервера переднего плана, вновь создаваемые объекты пользователей не обрабатываются службой обновления получателей. В результате объекты пользователей могут не получать адреса электронной почты, и получатели не отображаются в списке адресов. К тому же, обновления автономной адресной книги не обрабатываются.

Если получено это сообщение, служба обновления получателей выполняется на сервере Exchange, настроенном в качестве сервера переднего плана.

Чтобы устранить эту ошибку

  1. Откройте диспетчер Exchange.

  2. В разделе Получатели щелкните Службы обновления получателей. В правой области щелкните правой кнопкой мыши соответствующий экземпляр службы обновления получателей и выберите в контекстном меню пункт Свойства.

  3. На вкладке Общие в разделе Сервер Exchange щелкните Обзор, а затем укажите новый сервер, на котором будет выполняться данный экземпляр служб обновления получателей.

  4. Нажмите кнопку OK, а затем еще раз нажмите кнопку OK, чтобы изменение вступило в силу.

Дополнительные сведения о службе обновления получателей см. в следующих статьях базы знаний Майкрософт:

  • статья 328738, описывающая применение службой обновления получателей политик получателей (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738);

  • статья 253828, посвященная заполнению службой обновления получателей списков адресов (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828);

  • статья 246127, посвященная проверке хода выполнения службы обновления получателей Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127);

  • статья 253770, описывающая задачи, выполняемые службой обновления получателей (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770).


Расхождение в имени сервера Exchange в реестре и Active Directory
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-12-03

Средство анализа Microsoft® Exchange Server запрашивает службу каталога Active Directory®, чтобы определить значение имени сервера Exchange, хранящееся в Active Directory (CN=<ExchangeServerName>). Получив имя, средство анализа Exchange Server считает количество символов в имени.

Кроме того, средство анализа Exchange Server считывает следующий параметр реестра, чтобы определить имя сервера Exchange, хранящееся в реестре компьютера сервера Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

В дополнение к этому средство анализа Exchange Server запрашивает класс Win32_Service инструментария Microsoft Windows® Management Instrumentation (WMI), чтобы определить значение параметра Started для ClusSvc, службы кластеров.

Если средство анализа сервера Exchange обнаруживает, что следующие критерии верны, появляется сообщение об ошибке:

  • Значение CN=<ExchangeServerName> не совпадает со значением Hostname.

  • Имя сервера Exchange содержит 15 символов или меньше.

  • Сервер Exchange работает не в кластере Windows.

Чаще всего эта ошибка возникает из-за того, что имя сервера Exchange было изменено. При таком изменении меняется имя в реестре компьютера, меняется имя учетной записи компьютера в Active Directory, а многочисленные ссылки на имя сервера Exchange в атрибутах Exchange и объектах Active Directory не изменяются.

Примечание.
Кроме того, некоторые программы сторонних производителей меняют имя компьютера для обеспечения функциональности кластеризации. Если используются такие программы, возможно, это сообщение об ошибке можно пропустить.

Переименование компьютера Exchange Server не поддерживается. Оно приводит к таким ошибкам, как невозможность запустить службу Microsoft Exchange System Attendant после изменения имени компьютера. Если переименованный компьютер Exchange Server работает в каком-то отношении некорректно, можно удалить Exchange Server вручную, воспользовавшись процедурой, описанной в данной статье. Если переименованный компьютер Exchange Server работает корректно со всех точек зрения, нужно восстановить сервер Exchange, воспользовавшись процедурой восстановления, описанной ниже, поскольку существующая настройка не поддерживается и может вызвать проблемы в будущем.

Исправление ошибки путем удаления Exchange Server вручную

  1. Остановите все службы Exchange Server и сделайте резервную копию всех данных, хранящихся на компьютере.

  2. В зависимости от того, какая версия Exchange Server установлена, прочтите следующие статьи базы знаний корпорации Майкрософт:

    • Если установлен Exchange 2007 Server, выполните процедуру, описанную в документации для сервера Exchange Server 2007 в разделе, посвященном полному удалению Exchange 2007 с сервера, по адресу http://go.microsoft.com/fwlink/?LinkId=79246 (на английском языке).

    • Если установлен сервер Exchange Server 2003, выполните процедуру, описанную в статье 833396 базы знаний Майкрософт «Как удалить Exchange Server 2003 из системы» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=833396.

    • Если установлен Exchange 2000 Server, выполните процедуру, описанную в статье 260378 базы знаний Майкрософт «Удаление Exchange 2000 вручную» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=260378.

  3. Если используется сервер Exchange 2000 Server или Exchange Server 2003 и это единственный сервер Exchange в организации, выполните процедуру, описанную в статье 273478 базы знаний Майкрософт «Полное удаление Exchange 2000 или Exchange 2003 из Active Directory» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=273478).

Исправление ошибки путем восстановления компьютера Exchange Server

  1. Перенесите почтовые ящики, общие папки, соединители и роли на другой компьютер Exchange Server организации.

  2. Удалите Exchange Server с компьютера.

  3. Чтобы очистить реестр компьютера, на котором установлен сервер Exchange Server 2003 или Exchange Server 2000, выполните связанную с очисткой реестра часть процедуры, описанной в следующих статьях базы знаний Майкрософт:

    • 833396 «Как удалить Exchange Server 2003 из системы» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=833396

    • 260378 «Удаление Exchange 2000 вручную» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=260378

    Другой способ — восстановить операционную систему.

  4. Установите Exchange Server на компьютер.

  5. Перенесите почтовые ящики, общие папки, соединители и роли на восстановленный компьютер Exchange Server.

Для получения дополнительных сведений о развертывании Exchange Server 2003 в кластерах см. статью 810986 базы знаний корпорации Майкрософт «Политика Майкрософт в области поддержки серверов Exchange, работающих со службой кластеров стороннего производителя» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=810986 (эта ссылка может указывать на содержимое полностью или частично на английском языке).


Несоответствие имени сервера Exchange в Active Directory
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-12-03

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить, совпадают ли атрибуты Name и cn сервера (объекта класса msExchExchangeServer). Если анализатор сервера Exchange обнаруживает, что эти атрибуты отличаются, выводится сообщение об ошибке.

Exchange использует значение cn объекта-сервера для внутренней идентификации сервера. Значение Name используется для идентификации сервер в интерфейсе пользователя диспетчера Microsoft Exchange.

Эта ошибка может возникнуть, если администратор изменил значение Name с помощью оснастки Edit интерфейса ADSI или средства LDP (ldp.exe). Так как это действие изменяет имя сервера в интерфейсе пользователя, оно создает несоответствие, которое генерирует события системного помощника и хранилища. Это значение следует исправить с помощью, например, оснастки Edit интерфейса ADSI, средство LDP (ldp.exe) или любого другого клиента, использующего протокол LDAP версии 3.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью оснастки Edit интерфейса ADSI, средства LDP или другого клиента, использующего протокол LDAP версии 3, может привести к серьезным неполадкам. Для устранения этих проблем может потребоваться переустановка сервера Microsoft Windows Server™ 2003, Exchange Server 2003 или Exchange Server 2007 либо обоих продуктов. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы устранить эту ошибку

  1. С помощью оснастки ADSI Edit или подобного средства найдите объект-сервер в Active Directory.

    Атрибуты CN иName могут описываться следующим образом:

    Копировать код
    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Servers,CN=Server

  2. Для атрибута Name введите новое строковое значение, которое соответствует значению атрибута CN.

Дополнительные сведения об использовании средства LDP см. в статье 260745 базы знаний корпорации Майкрософт "XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (Использование служебной программы LDP для изменения атрибутов объектов Active Directory) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Дополнительные сведения о работе с оснасткой Edit интерфейса ADSI см. в разделе «Adsiedit.msc: ADSI Edit» в справке Windows Server.


Между сервером Active Directory и данным сервером Exchange более одной сети
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) WIN32_PingStatus в пространстве имен root\cimv2, чтобы определить значение ключа RouteRecord. Ключ RouteRecord содержит запись сведений о промежуточных прыжках (например, число маршрутизаторов) между сервером Exchange и контроллером домена. Анализатор сервера Exchange проверяет число маршрутизаторов, указанное в ключе RouteRecord. Если анализатор сервера Exchange обнаружит в этом списке более одного маршрутизатора, выдается сообщение об ошибке.

Для службы каталогов Active Directory® оптимальной является структура, в которой обеспечивается взаимодействие компьютера сервера Exchange с контроллером домена или сервером глобального каталога в своей подсети. Данная ошибка говорит о том, что компьютер с сервером Exchange взаимодействует с контроллерами доменов в сетях, достижимых для него более чем за один прыжок.

Чтобы устранить эту ошибку

  1. Проверьте топологию сети и пересмотрите расположение серверов Active Directory.

  2. Просмотрите журналы событий сервера Exchange и контроллера домена и выясните, не были ли зарегистрированы какие-либо сетевые события, свидетельствующие о потенциальных проблемах.

  3. Проанализируйте структуру сайтов Active Directory. Если сеть не разделена в соответствии с этой спецификацией, рассмотрите возможность разделения сети на большее число сайтов Active Directory.

Дополнительные сведения о WMI-классе Win32_PingStatus см. в статье MSDN® «Win32_PingStatus» (http://go.microsoft.com/fwlink/?linkid=33549).

Дополнительные сведения о структуре сайтов Active Directory см. в документе «Designing the Site Topology» (http://go.microsoft.com/fwlink/?linkid=33551) (Определение топологии сайтов).


Слишком много прыжков
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-07-06

Средство анализатора сервера Microsoft® Exchange отправляет тестовое сообщение от сервера Exchange учетной записи администратора почтовой системы или пользовательской записи домена SMTP, а затем проверяет на сервере журналы трассировки сообщений, чтобы определить, не возникли ли проблемы при доставке тестового сообщения.

В ходе проверки анализатор сервера Exchange запрашивает свойство MessageID WMI-класса (Microsoft Windows® Management Instrumentation) Exchange_MessageTrackingEntry в пространстве имен root\MicrosoftExchangeV2 для каждого сервера, через который проходит сообщение.

Прежде чем сообщение достигнет окончательного адресата, оно может быть маршрутизировано через множество различных SMTP-серверов. Каждый сервер на этом маршруте называется прыжок.

Если количество экземпляров Exchange_MessageTrackingEntry для конкретного MessageID увеличивается до 30, анализатор сервера Exchange выводит ошибку.

Эта ошибка показывает, что тестовое сообщение, возможно, передается по кругу. Поэтому анализатор сервера Exchange прекратил запрос дополнительных экземпляров Exchange_MessageTrackingEntry в качестве меры предосторожности от возможного бесконечного цикла.

Помочь определить, не возникло ли зацикливание, может дополнительный анализ раздела «Журнал отслеживания событий» результатов работы анализатора сервера Exchange.


Неподдерживаемая конфигурация виртуального компьютера — обнаружен кластерный сервер Exchange
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-12-15

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс Win32_ComputerSystem, чтобы определить, установлено ли значение «Virtual Machine» для раздела Model.

Анализатор сервера Exchange также опрашивает WMI-класс Win32_Service, чтобы определить значение раздела Started для службы кластеров Windows (ClusSvc). Значение True раздела Started означает, что служба кластеров запущена. Значение False — служба кластеров не запущена.

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Значение раздела Model установлено как «Virtual Machine».

  • Значение раздела Started для службы кластеров установлено как True.

Эта ошибка указывает, что сервер Exchange является кластерным сервером, который работает в среде виртуального компьютера. Такая конфигурация не поддерживается.

Чтобы устранить эту ошибку

  1. Создайте физический кластер и переместите почтовые ящики в этот кластер с кластерного сервера Exchange, работающего в виртуальной среде.

  2. Если невозможно создать физический кластер, можно исправить эту ошибку следующим образом:

    1. Переместите почтовые ящики с сервера Exchange, который работает в виртуальной среде, на изолированный физический компьютер сервера Exchange.

    2. Переместите любые общие папки и роли, установленные на кластерном сервере Exchange.

    3. Удалите сервер Exchange с виртуального компьютера, чтобы списать его и удалить из инфраструктуры Exchange в службе каталогов Active Directory.

Дополнительные сведения о политике корпорации Майкрософт по работе Exchange Server 2003 в виртуальных средах, см. в статье 320220 базы знаний, посвященной политике поддержки для Exchange Server 2003, работающем на виртуальном оборудовании (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).


Неподдерживаемая конфигурация виртуальной машины — не найден пакет обновления 2 (или более поздней версии) для Exchange Server 2003
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-12-15

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс Win32_ComputerSystem, чтобы определить, установлено ли значение «Virtual Machine» для раздела Model.

Анализатор сервера Exchange также запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumberдля всех объектов, относящихся к классу msExchExchangeServer. Если строковое значение содержит «Version 5.5», значит, на компьютере выполняется Exchange Server 5.5. Если строковое значение содержит «Version 6.0», значит, на компьютере выполняется Exchange 2000 Server. Если строковое значение содержит «Version 6.5», значит, на компьютере выполняется Exchange Server 2003. Если строковое значение содержит «Version 6.5» и «Service Pack 2», значит, на компьютере выполняется Exchange Server 2003 с пакетом обновления 2 (SP2).

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Значение раздела Model установлено как «Virtual Machine».

  • На компьютере не выполняется Exchange Server 2003 с пакетом обновления 2 (или более поздней версии).

Эта ошибка указывает на то, что сервер Exchange является виртуальной машиной, однако пакет обновления Exchange Server 2003 SP2 или более поздней версии не установлен. Такая конфигурация не поддерживается.

Чтобы устранить эту ошибку

  1. Установите пакет обновления 2 или более поздней версии для Exchange Server 2003.

  2. Прочитайте статью 320220 базы знаний Майкрософт, в которой описывается политика поддержки для Exchange Server 2003, работающем на виртуальном оборудовании (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).

  3. Если применение пакета обновления 2 или более поздней версии невозможно, ошибку можно устранить следующим образом:

    1. Переместите почтовые ящики с сервера Exchange, работающего под управлением Virtual Server 2005, на компьютер Exchange Server, не являющийся виртуальным.

    2. Переместите любые общие папки и роли, установленные на виртуальном сервере Exchange.

    3. Удалите сервер Exchange с виртуального компьютера, чтобы списать его и удалить из инфраструктуры Exchange в службе каталогов Active Directory.


Неподдерживаемая конфигурация виртуального компьютера — дополнения виртуального компьютера не обнаружены
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-12-15

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_ComputerSystem, чтобы определить, равно ли значение ключа Model строке «Virtual Machine».

Чтобы определить, установлены ли дополнения виртуального компьютера, анализатор сервера Exchange считывает также следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

Наличие этого раздела реестра показывает, что добавления виртуального компьютера установлены. Отсутствие этого раздела реестра свидетельствует о том, что добавления виртуального компьютера не установлены.

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Значение ключа Model установлено равным «Virtual Machine».

  • Указанный раздел реестра отсутствует.

Эта ошибка показывает, что сервер Exchange является виртуальным компьютером, но дополнения виртуального компьютера не установлены. Такая конфигурация не поддерживается.

Установка дополнений виртуального компьютера

  1. Выполните резервное копирование сервера Exchange, работающего в виртуальной среде.

  2. Установите дополнения виртуального компьютера, используя административную консоль или веб-узел Virtual Server 2005.

Дополнительные сведения об использовании приложения Exchange Server 2003 в виртуальной среде см. в статье 320220 базы знаний Майкрософт, описывающей политику поддержки приложения Exchange Server 2003, работающего в среде программной виртуализации оборудования, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220.


Доступно обновление для перехода на летнее время
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-07-30

Анализатор Microsoft Exchange запрашивает службу каталогов Active Directory, чтобы определить значение атрибута versionNumber для каждого объекта сервера Exchange Server. Атрибут versionNumber представляет версию сервера Exchange Server, которая выполняется на компьютере.

Анализатор Exchange также запрашивает класс инструментария управления Windows (WMI) CIM_Datafile, чтобы определить значение параметра Version для процесса Store.exe.

  • Значение 7638 параметра Version соответствует серверу Exchange Server 2003 с пакетом обновления 2.

  • Значение 7226 параметра Version соответствует серверу Exchange Server 2003 с пакетом обновления 1.

  • Значение 6944 параметра Version соответствует первоначальной версии сервера Exchange Server 2003.

  • Значение, находящееся в диапазоне между указанными выше, свидетельствует о том, что на сервере установлены исправления для процесса Store.exe.

Если анализатор Exchange выясняет, что параметр Version процесса Store.exe на компьютере с сервером Exchange Server 2003 с пакетом обновления 2 или пакетом обновления 1 имеет значение меньше 7561 или 7234 соответственно, выводится предупреждение.

Это предупреждение свидетельствует о том, что на компьютере выполняется сервер Exchange Server 2003 с пакетом обновления 1 или 2 без обновления для перехода на летнее время в 2007 году.

Без этого обновления элементы календаря в программах, основанных на объектах CDO, и в Outlook Web Access будут работать так, как если бы вместо летнего времени действовало стандартное время.

Устранение проблемы в Exchange Server 2003 с пакетом обновления 2 (SP2)

  1. Следуйте инструкциям, приведенным в статье 926666 базы знаний Майкрософт «Изменение обновления для перехода на летнее время в 2007 г. для Exchange Server 2003 с пакетом обновления 2» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=926666 (на английском языке).
Устранение проблемы в Exchange Server 2003 с пакетом обновления 1 (SP1)

  1. Следуйте инструкциям, приведенным в статье 931978 базы знаний Майкрософт «Изменение обновления для перехода на летнее время в 2007 г. для Exchange Server 2003 с пакетом обновления 1» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=931978 (на английском языке).


Не установлен набор исправлений для Windows 2000 SP4
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation), чтобы определить значение ключа ServicePackMajorVersion. Анализатор сервера Exchange также проверяет следующий раздел реестра, чтобы определить версию Windows, под управлением которой работает целевой компьютер:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Если анализатор сервера Exchange определит, что целевая система работает под управлением операционной системы Windows 2000 Server, но в ней не установлен набор исправлений для Windows 2000 Server с пакетом обновлений 4, выдается предупреждение.

Рекомендуется установить последние пакеты обновлений и наборы исправлений для всех программных компонентов развернутой системы Exchange.

Чтобы устранить причину появления этого предупреждения

  1. Обновите все контроллеры доменов и серверы глобального каталога, работающие под управлением Windows 2000 Server, установив набор исправлений для пакета обновлений 4, а также последние исправления и обновления с веб-узла Windows Update.

  2. Обновите все компьютеры с сервером Exchange, установив последние исправления и обновления.

Дополнительные сведения о наборе исправлений для Windows 2000 SP4 см. в статье 891861 базы знаний Майкрософт, описывающей набор исправлений 1 для Windows 2000 SP4 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=891861).

Дополнительные сведения о получении и установке пакетов обновлений и наборов исправлений сервера Exchange см. на веб-узле Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=21573).


Средство URLScan установлено
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-04-20

Средство анализатора сервера Microsoft® Exchange опрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить, существует ли следующий файл в следующей папке на сервере Exchange:

%WINDOWSPATH%\\SYSTEM32\\INETSRV\URLSCAN\URLSCAN.DLL

Наличие Urlscan.dll указывает, что средство URLScan установлено на сервере Exchange. Если анализатор сервера Exchange обнаружит, что средство URLScan установлено на сервере Exchange, на экран будут выведены рекомендации.

URLScan — это фильтр ISAPI (Internet Server Application Programming Interface), который предоставляет администраторам веб-узлов возможности по ограничению типов HTTP-запросов, обрабатываемых сервером. Блокируя определенные HTTP-запросы, фильтр URLScan не пропускает потенциально вредные запросы на сервер и, тем самым, предотвращает возможные вредоносные действия.

При запуске URLScan на сервере Exchange следует убедиться, что файл Urlscan.ini настроен для роли сервера Exchange. Для повышения безопасности сервера Exchange необходимо отредактировать конфигурационный файл Urlscan.ini, чтобы удалить ненужные функции. Чтобы настроить файл Urlscan.ini для определенной роли компьютера Exchange Server 2003, необходимо удалить команды в части [AllowVerbs] файла Urlscan.ini. Однако убедитесь, что рекомендуемые команды, соответствующие роли компьютера, включены для поддержки соответствующих функциональных возможностей. Если на одиночном компьютере требуется иметь несколько веб-функций, следует объединить соответствующие требования части [AllowVerbs].

Файл Urlscan.ini можно изменить на основе роли компьютера Exchange Server 2003, используя сведения из шаблона Urlscan для Exchange Server 2003, который содержится в базе знаний Майкрософт в статье 823175, описывающей точную настройку и известные проблемы использования служебной программы Urlscan в среде Exchange 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823175).

Дополнительные сведения о служебной программе URLScan см. в описании средства безопасности UrlScan (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=24490).

Дополнительные сведения об использовании URLScan в среде сервера Exchange см. в следующих статьях базы знаний Майкрософт:

  • статья 309677, посвященная известным проблемам и точной настройке использования мастера блокировки IIS в среде Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=309677);

  • статья 309508, описывающая блокировку IIS и конфигурации URLscan в среде Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=309508);

  • статья 325965, сообщающая о том, что средство URLScan может быть причиной проблем с веб-клиентом Outlook (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325965);

  • статья 326444, содержащая инструкции по настройке средства URLScan (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326444).


Переключатель USERVA установлен неправильно
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-09-19

Средство анализатора сервера Microsoft® Exchange запрашивает три WMI-класса (Microsoft Windows® Management Instrumentation), чтобы определить объем физической памяти на компьютере сервера Exchange и объем виртуального адресного пространства, выделенного для процессов пользовательского режима на компьютере сервера Exchange. В следующей таблице описываются классы и ключи, оцениваемые анализатором сервера Exchange.

Запрашиваемый класс | Запрашиваемые ключи | Описание
Win32_OperatingSystem | MaxProcessMemorySize | Максимальное количество килобайтов памяти, которые могут быть выделены для процесса.
Win32_ComputerSystem | TotalPhysicalMemory | Количество байтов ОЗУ, установленных на компьютере.
Win32_Service | Started | Состояние службы. Значение True означает, что служба запущена. Значение False — служба не запущена.

Анализатор сервера Exchange также считывает следующий раздел реестра, чтобы определить версию Microsoft Windows, под управлением которой работает компьютер сервера Exchange:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Значение CurrentVersion равное 4.0 означает, что компьютер сервера Exchange работает под управлением операционной системы Microsoft Windows NT® Server 4.0. Значение 5.0 означает, что этот компьютер работает под управлением Windows 2000 Server, а значение 5.2 означает Windows Server™ 2003.

В завершении анализатор сервера Exchange опрашивает службу каталогов Directory®, чтобы определить количественное значение атрибута homeMDBBL объекта хранилища почтовых ящиков (msExchPrivateMDB). Это значение равняется количеству почтовых ящиков, найденных на компьютере сервера Exchange.

Если анализатор сервера Exchange обнаружит, что все условия, перечисляемые ниже, соблюдаются, на экран выводится предупреждение:

  • Компьютер сервера Exchange работает под управлением Windows Server 2003.

  • Значение TotalPhysicalMemory превышает 1073741824.

  • Значение MaxProcessMemorySize равно 3145600.

  • Значение Win32_Service\Started в службе кластеров (ClusSvc) равно True или компьютер сервера Exchange содержит более 20 почтовых ящиков.

Это предупреждение указывает на то, что компьютер сервера Exchange не настроен оптимально для использования виртуальной памяти. В частности, в файле Boot.ini компьютера сервера Exchange не содержится переключателя загрузки /USERVA=3030. Добавление этого переключателя может увеличить масштабируемость и улучшить производительность.

Windows Server 2003 включает поддержку для двух переключателей загрузки в файле Boot.ini — /3GB и /USERVA — которые позволяют настроить выделение и использование памяти, а также адресное пространство памяти. Независимо от количества физической памяти системы Windows использует виртуальное адресное пространство, равное 4 гигабайтам (ГБ), где 2 ГБ отводятся пользовательским процессами (например, приложениям), а другие 2 ГБ — процессам режима ядра (например, операционной системе и драйверам режима ядра). На системе с 1 ГБ физической памяти или более эти переключатели загрузки можно использовать для выделения большего количества памяти приложениям (3 ГБ) и меньшего количества памяти операционной системе (1 ГБ). На компьютере сервера Exchange это дополнительное виртуальное адресное пространство помогает уменьшить фрагментацию памяти в виртуальном адресном пространстве банка данных. Переключатель /3GB используется для изменения выделения памяти. Переключатель устанавливается в системном файле Boot.ini и вступает в действие после перезагрузки. Этот переключатель следует использовать только на серверах Exchange, имеющих память объемом 1 гигабайт (ГБ) или более и работающих под управлением любой из следующих операционных систем:

  • Microsoft Windows Server™ 2003 Standard Edition,

  • Microsoft Windows Server 2003 Enterprise Edition,

  • Microsoft Windows Server 2003 Datacenter Edition.

Важно!
Переключатель /3GB не должен использоваться в Windows 2000 Server, так как он не поддерживается и может быть причиной отказов приложений или операционной системы. Более того, переключатель /3GB поддерживается указанными выше операционными системами только в том случае, если на компьютере установлена физическая память объемом 1 ГБ и более. Кроме того, переключатель /3GB нельзя использовать на серверах Active Directory (контроллеры домена и серверы глобальных каталогов), работающих под управлением Windows Server 2003 Standard Edition.

Переключатель /USERVA является нововведением в Windows Server 2003. Его назначение — обеспечение лучшего уровня управления распределения виртуального адресного пространства между процессами пользовательского режима и процессами режима ядра. Переключатель должен использоваться только с теми приложениями, которые его поддерживают, например с Exchange Server 2003, а также с определенными значениями, поддерживаемыми этими приложениями. При использовании на системах Exchange Server 2003 переключатель /USERVA всегда должен равняться 3030 (то есть /USERVA=3030). Это значение означает, что для операционной системы будут выделены дополнительные 40 МБ и можно будет добавлять пользователей без использования всех доступных ресурсов системы.

Чтобы устранить причины появления этого предупреждения в Windows Server 2003

  1. Щелкните правой кнопкой мыши Мой компьютер и в контекстном меню выберите Свойства. Появится диалоговое окно Свойства системы.

  2. Откройте вкладку Дополнительно.

  3. В области Загрузка и восстановление щелкните Параметры. Появится диалоговое окно Загрузка и восстановление.

  4. В области Загрузка операционной системы щелкните Изменить. В результате этих действий в «Блокноте» откроется файл Boot.ini операционной системы Windows.

  5. В разделе [Operating Systems] добавьте следующие переключатели в строку загрузки: /3GB /USERVA=3030

  6. Сохраните изменения и закройте «Блокнот».

  7. Нажмите два раза кнопку OK, чтобы закрыть открытые диалоговые окна, и затем перезапустите компьютер сервера Exchange, чтобы изменение вступило в силу.

Дополнительные сведения об использовании переключателей загрузки /3GB и /USERVA см. в следующих статьях базы знаний Майкрософт:

  • Статья 297812, описывающая функцию настройки ОЗУ, 4GT (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812).

  • Статья 311901, описывающая влияние настройки 4GT на системные элементы таблицы страниц (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901).

  • Статья 316739, содержащая инструкции по использованию переключателя /userva с переключателем /3GB для настройки адресного пространства в пользовательском режиме в диапазоне от 2 ГБ до 3 ГБ (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739).

  • Статья 325044, описывающая инструкции по устранению проблем, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044).

  • Статья 815372, описывающая оптимизацию использования памяти в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372).


Установленная на этом компьютере версия файла Tcpip.sys может требовать обновления
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version для файла Tcpip.sys. Если анализатор сервера Exchange обнаруживает, что значение ключа Version соответствует конкретной версии файла Tcpip.sys, анализатор сервера Exchange выводит предупреждение.

Для получения дополнительных сведений об этом предупреждении следуйте рекомендациям статьи 898060 базы знаний Майкрософт, посвященной возможным сбоям работы сети между клиентами и серверами при установке обновления MS05-019 или пакета обновлений SP1 для Windows Server 2003, по адресу http://go.microsoft.com/fwlink/?LinkId=3052&kbid=898060 (возможно, на английском языке).


Обнаружена конфигурация виртуального компьютера
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-12-15

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс Win32_ComputerSystem, чтобы определить, установлено ли значение «Virtual Machine» для раздела Model.

Анализатор сервера Exchange также опрашивает WMI-класс Win32_Service, чтобы определить значение раздела Started для службы кластеров Windows (ClusSvc). Значение «True» раздела Started означает, что служба кластеров запущена. Значение «False» означает, что служба кластеров не запущена.

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumber для всех объектов, класс объекта которых равен msExchExchangeServer. Если строковое значение содержит «Version 6.5» и «Service Pack 2», на компьютере работает сервер Exchange 2003 с пакетом обновления 2.

Наконец, чтобы определить, установлены ли дополнения виртуального компьютера, анализатор сервера Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

Наличие этого раздела указывает, что дополнения виртуального компьютера были установлены. Отсутствие этого раздела указывает, что дополнения виртуального компьютера не были установлены.

Анализатор сервера Exchange выводит на экран рекомендацию, если выполняются следующие условия:

  • В Microsoft Virtual Server 2005 сервер Exchange работает в качестве гостя.

  • На сервере Exchange выполняется Exchange Server 2003 с пакетом обновления 2 или более поздняя версия.

  • Сервер Exchange не является кластерным сервером.

  • На сервере Exchange установлены дополнения виртуального компьютера для Virtual Server 2005.

Существуют некоторые требования для работы в этой конфигурации, которую анализатор сервера Exchange не способен определить. Поэтому рекомендуется просмотреть следующую статью, чтобы получить последние сведения о поддержке и настройке производительности для такой конфигурации, прежде чем использовать Exchange Server 2003 в среде Virtual Server 2005:

статья 320220 базы знаний Майкрософт, посвященная политики поддержки для Exchange Server 2003, работающем на виртуальном оборудовании (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).


Виртуальная память фрагментирована
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2007-02-15

Средство анализа Microsoft Exchange запрашивает класс WMI Win32_NTLogEvent для определения того, была ли в течение последних 24 часов зарегистрирована ошибка 9582 для объекта MSExchangeIS.

Если средство анализа Exchange обнаружит, что событие 9582 было зарегистрировано в течение последних 24 часов, будет выведено сообщение об ошибке.

Эта ошибка свидетельствует о том, что виртуальная память, необходимая для работы сервера Exchange, фрагментирована.

В 32-разрядных системах Microsoft Windows существует два вида памяти:

  • Физическая память — фактическая память, установленная в системе.

  • Адресное пространство виртуальной памяти — пространство виртуальной памяти объемом 4 ГБ.

Независимо от объема физической памяти, установленной в системе, общий размер виртуального адресного пространства всегда один и тот же: 4 ГБ. Хотя это не характерно для всех 32-разрядных приложений, в сервере Exchange виртуальное адресное пространство эквивалентно виртуальной памяти. Эти термины взаимозаменяемы.

При нормальной работе хранилище Exchange постоянно выделяет, использует и освобождает виртуальную память. При частом выделении, использовании и освобождении виртуальной памяти она может фрагментироваться. Фрагментация виртуальной памяти сходна с фрагментацией файловой системы, которая может происходить со временем. По истечении некоторого времени выделяемые сегменты виртуальной памяти больше не являются непрерывными, и производительность начинает ухудшаться. Для дефрагментации файловой системы можно использовать специальные приложения. В большинстве случаев дефрагментировать файловую систему можно в то время, когда система находится в оперативном режиме и к ней осуществляется доступ. Средств дефрагментации виртуальной памяти не существует. Вместо этого для устранения проблемы необходимо остановить и запустить службу банка данных Microsoft Exchange или перезапустить систему.

Для устранения этой проблемы выполните следующие действия.

  • Причиной фрагментации виртуальной памяти может быть программное обеспечение сторонней компании, которое запускается в процессах store/inetinfo. Убедитесь в том, что все приложения сторонних компаний используют новейшие драйверы.

  • Используя средство «Журналы и оповещения производительности», проследите за изменениями показаний счетчика Всего байтов в больших свободных блоках виртуальной памяти для объекта производительности MSExchangeIS. Опираясь на собранные данные, определите оптимальное время для выключения и перезапуска сервера в интервале от 36 до 72 часов.

Примечание.
Если сервер входит в кластер, остановите и перезапустите пассивный узел перед перемещением ресурсов кластера, чтобы гарантировать, что целевое адресное пространство виртуальной памяти будет очищено.
  • Если после перезапуска системы проблема не исчезнет, подумайте об отключении программного обеспечения сторонней компании.

  • Попробуйте переместить почтовые ящики пользователей на другой сервер, чтобы снизить нагрузку на сервер, и посмотрите, решит ли это проблему. Дополнительные сведения см. в разделе Перенос почтовых ящиков пользователей на другой сервер.

Дополнительные сведения

  • Дополнительные сведения о событии MSExchangeIS 9852 см. на странице «Центр сообщений о событиях и ошибках: сведения о событиях» по адресу http://go.microsoft.com/fwlink/?LinkId=83209 (на английском языке).

  • Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по производительности и масштабируемости сервера Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=47576 (на английском языке).

  • Дополнительные сведения об устранении проблем с производительностью сервера Exchange см. в статье Устранение неполадок, связанных с производительностью Microsoft Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=47588 (на английском языке).

  • Дополнительные сведения об устранении проблем, связанных с фрагментацией виртуальной памяти, в Microsoft Exchange Server 2003 и Exchange 2000 Server, см. в статье 325044 базы знаний Майкрософт «Устранение неполадок, связанных с фрагментацией виртуальной памяти, в Exchange Server 2003 и Exchange 2000 Server» по адресу http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044 (на английском языке).

  • Дополнительные сведения об оптимизации использования виртуальной памяти см. в статье 815372 базы знаний Майкрософт «Оптимизация использования памяти в Exchange Server 2003» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372 (на английском языке).

  • Дополнительные сведения о перемещении почтовых ящиков пользователей для сокращения нагрузки на сервер см. в разделе Перенос почтовых ящиков пользователей на другой сервер.


Не обнаружена версия виртуального сервера Virtual Server 2005 R2 или более поздняя
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-12-15

Анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version для Vssrvc.exe, процесса, представленного службой виртуального сервера, включенной в Microsoft Virtual Server 2005. Если анализатор сервера Exchange обнаруживает, что значение ключа Version для программы Vssrvc.exe равно 1.1.465.0, выводится сообщение об ошибке.

Эта ошибка указывает, что данный сервер Exchange выполняется с учетной записью гостя в среде Microsoft Virtual Server 2005, где не установлена версия Virtual Server 2005 R2 или более поздняя. Такая конфигурация не поддерживается. В отношении работы с учетной записью гостя в виртуальной среде под управлением версии Microsoft Virtual Server 2005 R2 или более поздней поддерживается только Exchange Server 2003 с пакетом обновления 2.

Чтобы устранить эту ошибку

  1. См. статью 320220 базы знаний Майкрософт «Support policy for Exchange Server 2003 running on hardware virtualization software» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220) (Политика поддержки работы Exchange Server 2003 с программным обеспечением, имитирующим оборудование).

  2. Установите Microsoft Virtual Server 2005 R2 или более позднюю версию. Сведения о Microsoft Virtual Server 2005 R2 см. на веб-узле Microsoft Virtual Server 2005 R2 (http://go.microsoft.com/fwlink/?linkid=34938).

  3. Если не удается установить Virtual Server 2005 R2 или более позднюю версию, данную ошибку можно исправить следующим образом:

    1. Переместите почтовые ящики с сервера Exchange, который выполняется под управлением Virtual Server 2005, на компьютер сервера Exchange, работающий не в виртуальной среде, или на виртуальный компьютер сервера Exchange, работающий под управлением Virtual Server 2005 R2.

    2. При необходимости переместите общие папки и переключите роли, присвоенные не поддерживаемому виртуальному серверу Exchange.

    3. Удалите сервер Exchange с неподдерживаемого виртуального компьютера, чтобы списать и удалить его из инфраструктуры сервера Exchange и Active Directory.


Длина очереди поиска вирусов превышает пороговое значение
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-02-27

Средство Microsoft® Exchange Server Analyzer Tool включает механизм сбора данных о производительности, который используется для опроса объектов счетчика производительности на компьютерах под управлением Exchange 2000 Server или Exchange Server 2003. Механизм сбора данных производительности собирает данные Virus Scan Queue Length счетчика производительности объекта MSExchangeIS для анализа данных производительности.

Если средство анализа сервера Exchange определяет, что значение 90-й перцентили счетчика Virus Scan Queue Length превосходит 10 во время взятия образца, отображается сообщение об ошибке.

Счетчик производительности Virus Scan Queue Length указывает текущее количество ожидающих запросов, помещенных в очередь для поиска вирусов.

Ошибка может означать проблему с производительностью, связанную со следующим:

  • Снижение производительности сервера, обычно вызванное узким местом, связанным с ЦП.

  • Загрузка сервера, превышающая обычную.

  • Устаревший механизм поиска вирусов.

  • Неверно настроенный механизм поиска вирусов.

Для решения этой проблемы выполните следующие шаги:

  • Проверьте обновление своего механизма поиска вирусов.

  • Подумайте, не нужно ли переустановить программное обеспечение для поиска вирусов.

  • Проверьте настройку цепочек, уровня исключения файлов и т.д. средства поиска вирусов. См. статью 823166 базы знаний корпорации Майкрософт «Обзор сервера Exchange 2003 и антивирусных программ» (http://go.microsoft.com/fwlink/?linkid=3052&k b id=823166).

  • При помощи монитора призводительности (Perfmon.msc) определите, возникает ли узкое место из-за увеличившейся загрузки сервера или сервер имеет недостаточную пропускную способность. Если возросла загрузка сервера, определите ее источник и уменьшите загрузку. Если ресурсов сервера недостаточно, увеличьте нужные ресурсы или переместите пользователей с сервера.

Устранение узких мест, связанных с процессором

Существуем много способов устранения узких мест сервера Exchange, связанных с процессором.

  • Прежде всего проверьте приложения или задания, создающие загрузку сервера. Определите, должно ли приложение использовать столько времени процессора, или же имеются проблемы с процессом.

  • Если не связанное с Exchange приложение не важно для сервера, запустите его на другом сервере. При запуске этого приложения на другом сервере переместите роли сервера на другие компьютеры. Например, если процессор Inetinfo создает большую загруженность ЦП, подумайте, не стоит ли добавить серверы переднего края, чтобы принять ответственность за работу протокола, осуществляемую Inetinfo. Можно также переместить папки с общим доступом на специальный сервер папок общего доступа. Наконец, если сервер выполняет большое количество расширений списка рассылки, можно сократить использование ЦП, переместив список на специальный сервер списков рассылки.

  • Если это возможно, добавьте дополнительные или более быстрые процессоры. Также включите функцию Hyper-Threading, если процессоры ее поддерживают. Для этого нужно настроить BIOS системы. Для получения дополнительных сведений см. справочную документацию изготовителя компьютера.

  • Если невозможно повысить мощность процессора, уменьшите загрузку процессоров. Чтобы уменьшить общее воздействие на сервер, убедитесь, что задания, значительно использующие ввод-вывод, ЦП или память, не выполняются в обычные рабочие часы.

  • Убедитесь, что задания, значительно использующие ЦП, например создание резервных копий и обслуживание, происходят в часы наименьшей загруженности. Также убедитесь, что эти задания выполняются поэтапно. Поэтапное выполнение предполагает установку различного времени начала и, желательно, окончания выполнения каждого задания. Поэтапное выполнение обслуживания и создания резервных копий баз данных и групп хранения также сокращает использование ресурсов этими заданиями.

Дополнительные сведения

  • Общие сведения о свервере Exchange и поиске вирусов см. статью 823166 базы знаний Майкрософт «Общие сведения о сервере Exchange 2003 и антивирусном программном обеспечении» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Подробнее о поиске вирусов и сервере Exchange см. статью 285667 базы знаний Майкрософт «XADM: Общее представление о поиске вирусов API 2.0 для сервера Exchange 2000 SP1» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285667).

  • Подробнее об узких местах, связанных с процессором см. Узкое место в работе процессора.

  • Для получения дополнительной информации о производительности сервера Exchange см. Руководство по производительности и масштабированию для сервера Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Для получения дополнительной информации о проблемах с производительностью сервера Exchange см. Устранение неполадок производительности сервера Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Подробнее о перемещении почтовых ящиков пользователей для сокращения нагрузки на сервер см. Перенос почтовых ящиков пользователей на другой сервер.


Длина очереди средства поиска вирусов выходит за пределы порога предупреждения
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-04-20

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Virus Scan Queue Length объекта производительности MSExchangeIS для анализа данных о производительности.

Если анализатор сервера Exchange определит, что значение 90-го процентиля для счетчика Virus Scan Queue Length больше 5 во временном интервале выборки, анализатор сервера Exchange выведет на экран предупреждение.

Счетчик производительности Virus Scan Queue Length указывает текущее количество ожидающих запросов, находящихся в очереди поиска вирусов.

Это предупреждение указывает на возможность проблем с производительностью на этом сервере. Проблемы производительности могут быть обусловлены следующими причинами:

  • Пониженная производительность сервера, причиной которой обычно является возникновение узких мест в работе процессора.

  • Более высокая нагрузка на сервер по сравнению с обычной нагрузкой.

  • Устаревший модуль сканирования на вирусы.

  • Неправильно настроенный модуль сканирования на вирусы.

Для устранения причин появления этого предупреждения, выполните следующие шаги:

  • Проверьте наличие обновлений для модуля сканирования на вирусы.

  • Рассмотрите необходимость переустановки антивирусного программного обеспечения.

  • Проанализируйте конфигурацию модуля сканирования на вирусы, чтобы убедиться в правильности настройки потоков, исключений на уровне файлов и так далее. См. в базе знаний Майкрософт статью 823166, содержащую общие сведения о приложении Exchange Server 2003 и антивирусном программном обеспечении (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Используйте средство системного монитора (Perfmon.msc), чтобы определить, вызвано ли появление узкого места увеличением нагрузки на сервер или обусловлено недостаточным размером сервера. Если нагрузка на сервер возросла, определите источник нагрузки и уменьшите нагрузку. Если на сервере недостаточно ресурсов, увеличьте необходимые ресурсы или переместите пользователей с сервера.

Устранение узких мест в работе процессора

Существует множество способов устранения узких мест в работе процессора на сервере Exchange:

  • Сначала проанализируйте приложения или задачи, которые создают нагрузку на сервер. Определите, должно ли приложение потреблять ресурсы процессора или, возможно, существуют проблемы с рабочим процессом.

  • Если приложение, отличное от Exchange не важно для сервера, запустите это приложение на другом сервере. Если есть возможность, переместите также роли сервера на другие компьютеры. Например, если процесс Inetinfo потребляет значительные ресурсы процессора, рассмотрите возможность добавления серверов переднего плана для переноса на них работы протокола, выполняемой процессом Inetinfo. Можно также переместить средства доступа к общим папкам на выделенный сервер общих папок. Наконец, если сервер выполняет множество расширений списка рассылки, можно уменьшить нагрузку на процессор путем перемещения расширения списка рассылки на выделенный сервер расширений списка рассылки.

  • Если есть возможность, добавьте на сервер дополнительные или более быстродействующие процессоры. К тому же, включите многопоточность, если она поддерживается процессорами. Многопоточность можно включить путем настройки BIOS в системе. Дополнительные сведения см. в справочной документации, предоставляемой поставщиком компьютера.

  • Если отсутствует возможность увеличения вычислительных мощностей, следует уменьшить нагрузку на процессоры. Чтобы уменьшить общую нагрузку на сервер, убедитесь, что задачи, активно потребляющие ресурсы системы ввода-вывода, процессора или памяти, выполняются вне интервала обычного рабочего времени.

  • Убедитесь, что задачи, активно потребляющие ресурсы процессора, такие как резервное копирование и обслуживание, приходятся на часы внепиковой нагрузки. Также проверьте, чтобы эти задачи выполнялись в несколько этапов. Поэтапное выполнение задач предполагает установку разных времен запуска и, желательно, разных времен окончания для каждой задачи. Поэтапное выполнение обслуживания и резервного копирования баз данных или групп хранения также снижает нагрузку, оказываемую этими ресурсоемкими задачами.

Дополнительные сведения

  • Обзор по серверу Exchange и сканированию на вирусы см. в базе знаний Майкрософт в статье 823166, содержащей общие сведения о приложении Exchange Server 2003 и антивирусном программном обеспечении (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Дополнительные сведения о сканировании на вирусы и сервере Exchange см. в базе знаний Майкрософт в статье 285667, содержащей общие сведения об интерфейсе API 2.0 поиска вирусов, включенном в пакет обновления 1 (SP1) Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285667).

  • Дополнительные сведения об узких местах в работе процессора см. по ссылке Узкое место в работе процессора.

  • Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Дополнительные сведения об устранении проблем производительности сервера Exchange см. в описании процедур устранения неполадок, связанных с производительностью сервера Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Дополнительные сведения о переносе почтовых ящиков пользователей для снижения нагрузки на сервер см. по ссылке Перенос почтовых ящиков пользователей на другой сервер.


Сбой точки подключения тома: не установлен пакет обновления 1 для Windows Server 2003
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2006-02-13

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы проверить наличие драйвера Mountmgr.sys.

Анализатор сервера Exchange считывает следующий раздел реестра, чтобы определить версию Microsoft Windows®, под управлением которой работает сервер Exchange. HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Если параметр CurrentVersion имеет значение 5.0, значит, сервер Exchange работает под управлением Microsoft Windows 2000 Server. Если параметр «CurrentVersion» имеет значение 5.2, значит, сервер Exchange работает под управлением Microsoft Windows Server™ 2003.

Анализатор сервера Exchange также опрашивает WMI-класс Win32_Service, чтобы определить значение ключа Started службы кластеров (ClusSvc). Значение «TRUE» указывает на то, что служба кластеров запущена, а значение «FALSE» означает, что служба остановлена.

Анализатор сервера Exchange выводит на экран предупреждение, если выполняются следующие условия:

  • Компьютер сервера Exchange работает под управлением Windows Server 2003.

  • Пакет обновления 1 для Windows Server 2003 не установлен.

  • Exchange Server выполняется в среде кластера.

  • Имеются точки подключения тома.

В предупреждении указано, что при обновлении узла кластера Exchange до Windows Server 2003 с пакетом обновления (SP1) необходимо установить обновление, описанное в следующем разделе. В противном случае после обновления могут наблюдаться сбои точки подключения тома.

Чтобы устранить причину появления этого предупреждения

  • Примените обновление, указанное в статье 898790 базы знаний Майкрософт, в которой описываются периодические отказы точек подключения томов на дисках в кластере серверов после установки пакета обновления 1 для Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790).


На сервере Exchange включена служба брандмауэра Windows
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server запрашивает класс Win32_Service инструментария Microsoft Windows Management Instrumentation (WMI), чтобы выяснить значение параметра Started службы брандмауэра Windows (SharedAccess). Значение Истина показывает, что на этом сервере Exchange включена служба брандмауэра Windows.

Если средство анализа Exchange Server определяет, что на компьютере с Exchange Server включена служба брандмауэра Windows, отображается предупреждение. Если служба брандмауэра Windows включена, могут возникнуть следующие проблемы:

  • Некоторые компоненты Exchange Server, такие как служба отслеживания сообщений или удаленного вызова процедур (RPC), могут перестать отвечать.

  • Может возникнуть сообщение об ошибке, что не хватает свободной памяти.

По умолчанию служба брандмауэра Windows останавливается, когда устанавливается пакет обновления 1 (SP1) для Microsoft Windows Server 2003. В то же время служба автоматически настраивается на запуск, если выполняется любое из следующих условий:

  • Администратор вручную запустил службу брандмауэра Windows.

  • Служба брандмауэра Windows включена после запуска мастера настройки безопасности.

Устранение этого предупреждения

  • Проверьте программы-исключения.

  • Проверьте порты-исключения.

  • Проверьте исключения брандмауэра, если клиенты не могут подключиться к серверу Exchange.

  • Вручную откройте порты в брандмауэре, чтобы могли запуститься Exchange System Manager и Microsoft Exchange Administrator. При открытии портов в службе брандмауэра Windows вы повышаете вероятность того, что другие программы могут получить доступ к вашему компьютеру через эти порты. Перед открытием портов в службе брандмауэра Windows тщательно рассмотрите требования безопасности вашей сети.

  • Остановите службу брандмауэра Windows.


Служба WMI (Windows Management Instrumentation) не испольузет учетную запись локальной системы
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, значение параметра ObjectName, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winmgmt

Параметр ObjectName в этой ветви реестра определяет параметры учетной записи службы WMI (Microsoft Windows® Management Instrumentation), называемой службой Winmgmt. Если анализатор сервера Exchange обнаруживает, что для ключа ObjectName задано значение, отличное от «LocalSystem», на экран выводится сообщение об ошибке.

Это сообщение указывает на то, что служба WMI не выполняется в поддерживаемой конфигурации. Выполнение службы WMI с любой учетной записью, кроме LocalSystem, может привести к ошибкам разрешений и доступа.

Чтобы устранить данную проблему, настройте службу WMI для запуска с учетной записью «Локальная система» (SYSTEM).

Чтобы настроить учетную запись службы WMI

  1. Откройте оснастку MMC «Службы».

  2. Найдите службу WMI и остановите ее.

  3. Дважды щелкните службу WMI.

  4. На вкладке Вход в систему страницы Свойства WMI выберите С системной учетной записью в группе Вход в систему как, а затем нажмите кнопку Применить.

  5. В разделе Состояние службы щелкните Запустить, а затем нажмите кнопку OK.

  6. Закройте оснастку «Службы».


Windows Server 2003 с пакетом обновления 1: требуется исправление для веб-клиента Outlook
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает различные WMI-классы, чтобы определить следующие сведения:

  • В какой версии операционной системы Microsoft Windows Server работает сервер Exchange?

  • Работает ли сервер Exchange в кластере?

Если анализатор сервера Exchange обнаруживает, что выполнены приведенные ниже условия, на экран выводится сообщение об ошибке:

  • Установлен Exchange Server 2003 с пакетом обновления 1.

  • Установлен Exchange Server™ 2003 с пакетом обновления 1.

  • Выполняется служба кластеров.

  • Значение Version файла Davex.dll меньше 6.5.7232.

Если выполняется эта конфигурация, необходимо загрузить и установить исправление для Exchange Server перед установкой Windows Server 2003 с пакетом обновления 1. Если это исправление не будет установлено, пользователи веб-клиента Microsoft Office Outlook® для Exchange Server 2003 не смогут подключаться к своим почтовым ящикам. Пользователи, чьи почтовые ящики расположены в кластерах, получат следующее сообщение об ошибке при попытке подключения с помощью веб-клиента Outlook:

  • «500 - Внутренние ошибки сервера»

Эта ошибка вызвана некоторыми улучшениями в безопасности, которые содержатся в Windows Server 2003 с пакетом обновления 1.

Если пользователь пытается подключиться к почтовому ящику с помощью веб-клиента Outlook, протокол HTTP отправляет запросы кластерному интерфейсу API, имитируя подключенного пользователя. Однако в операционной системе Windows Server 2003 с пакетом обновления 1 содержатся некоторые изменения, касающиеся безопасности. Были изменены ограничения безопасности для интерфейсов API, с помощью которых можно было получить доступ к удаленному реестру. Поэтому попытка подключения завершится неудачно.

Чтобы устранить эту ошибку, необходимо загрузить и установить исправление для сервера Exchange, описанное в статье 841561 базы знаний Майкрософт, посвященной сообщению об ошибке 500 при попытке доступа к почтовому ящику, находящемуся на внутреннем сервере Exchange Server 2003, с помощью веб-клиента Outlook (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841561).


Обнаружен мастер настройки безопасности Windows Server 2003 с пакетом обновления 1 (SP1)
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить версию Microsoft Windows®, под управлением которой работает сервер Exchange, анализатор сервера Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Если значение CurrentVersion равно 5.0, сервер Exchange работает под управлением Microsoft Windows 2000 Server. Если значение CurrentVersion равно 5.2, сервер Exchange работает под управлением Microsoft Windows Server™ 2003.

Кроме того, чтобы определить путь к каталогу «Program Files» Windows, анализатор сервера Exchange считывает следующую запись реестра:

HKLM\Software\Microsoft\Windows\CurrentVersion\ProgramFilesDir

Затем анализатор сервера Exchange проверяет каталог «Program Files» Windows, чтобы определить, содержится ли в каталоге «Program Files» Windows папка «\Exchsrvr» для сервера Exchange.

В последнюю очередь анализатор сервера Exchange Server запрашивает WMI-класс Win32_OperatingSystem, чтобы определить значение ключа ServicePackMajorVersion. Значение ключа ServicePackMajorVersion указывает, какой пакет обновления Windows установлен на компьютере.

Анализатор сервера Exchange выводит на экран предупреждение, если выполняются следующие условия:

  • Анализатор сервера Exchange определяет, что сервер Exchange работает под управлением Windows Server 2003 с пакетом обновления 1 (SP1).

  • Анализатор сервера Exchange определяет, что приложение Exchange Server 2003 не установлено в папку по умолчанию, «\Program Files\Exchsrvr».

Данное предупреждение указывает, что приложение Exchange Server 2003 не установлено на сервере в папке по умолчанию в каталоге «Program Files» и что мастер настройки безопасности установлен на сервере Exchange. Мастер настройки безопасности — это средство, содержащееся в качестве дополнительного компонента в пакете обновления 1 (SP1) для Windows Server 2003. Если на сервере Exchange установлен мастер настройки безопасности, требуется вручную настроить раздел «Безопасность сети».

Примечание.
Чтобы установить мастер настройки безопасности, необходимо сначала установить пакет обновления 1 (SP1) для Windows Server 2003. После установки пакета обновления 1 (SP1) откройте в панели управления компонент «Установка и удаление программ», чтобы установить мастер настройки безопасности.

Мастер настройки безопасности помогает уменьшить зону Windows-серверов, уязвимую к атакам, посредством запроса у пользователя ответов на ряд вопросов, которые позволяют определить функциональные требования, предъявляемые к серверу. В частности, мастер настройки безопасности помогает выполнить следующие задачи:

  • Он автоматически отключает ненужные службы.

  • Он автоматически блокирует неиспользуемые порты.

  • Он помогает применить дополнительные ограничения по адресам или по безопасности для портов, которые остаются открытыми.

  • Он предотвращает ненужные веб-расширения IIS (Internet Information Services), если это возможно.

  • Он уменьшает подверженность внешним воздействиям протоколов SMB (server message block), LanMan и LDAP (Lightweight Directory Access Protocol).

  • Он определяет политику аудита с высоким отношением сигнала к шуму.

Мастер настройки безопасности управляет действиями пользователя в процессе создания, изменения, применения и отката политики безопасности, которая основывается на выбранных ролях сервера. Политики безопасности, создаваемые с помощью мастера настройки безопасности, являются XML-файлами, которые при их применении настраивают службы, безопасность сети, определенные параметры реестра и политику аудита. Если это применимо, службы IIS также могут настраиваться.

Помимо выполнения других функций мастер настройки безопасности реализует функцию сетевой безопасности, с помощью которой настраиваются и добавляются исключения в сетевой экран Windows. Сетевой экран Windows — это новая версия переменного фильтра пакетов в пакете обновления 1 (SP1) для Windows Server 2003. Сетевой экран впервые был введен в пакете обновления 2 (SP2) для Windows XP. В пакете обновления 2 (SP) для Windows XP он назывался брандмауэром подключения к Интернету.

Существует известная проблема, возникающая в случае, когда функция сетевой безопасности в мастере настройки безопасности выполняется на сервере Exchange, который не установлен в папку по умолчанию. В этой конфигурации применение результирующей политики может сделать сервер Exchange недоступным для клиентов. Если функция сетевой безопасности используется на сервере Exchange, который не установлен в папке по умолчанию, мастер настройки безопасности может настроить сетевой экран Windows на блокирование доступа к порту TCP/IP процессов сервера Exchange, таких как системный помощник (Mad.exe), банк данных Microsoft Exchange (Store.exe) и агент передачи сообщений (Emsmta.exe). В этой конфигурации мастер настройки безопасности отображает рядом с каждым процессом отметку Не найден!. Если мастер настройки безопасности выполняется до тех пор, пока не завершится с процессом, рядом с которым имеется отметка Не найден!, мастер настройки безопасности применяет политику безопасности к сетевому экрану Windows, который блокирует сетевой доступ для этого процесса.

Если блокированные процессы содержат один или более процессов сервера Echange, сервер Exchange может стать недоступен для клиентов и других серверов. Если это условие выполняется, следует выполнить одну из следующих процедур, чтобы устранить проблему.

Чтобы устранить проблему

  • Для устранения проблемы выполните одну из следующих процедур:

    • Используйте в мастере настройки безопасности функцию отката, чтобы вернуться к предыдущему состоянию после применения политики безопасности. Дополнительные сведения о том, как это сделать, см. в файле справки мастера настройки безопасности, который входит в пакет обновления 1 (SP1) для Windows Server 2003. Дополнительные сведения о пакете обновления 1 (SP1) для Windows Server 2003 и мастере настройки безопасности см. на веб-узле Windows Server 2003 TechCenter (http://go.microsoft.com/fwlink/?LinkId=45315).

    • В мастере настройки безопасности вручную заполните поле пути к приложению, чтобы указать местоположение исполняемых файлов процессов сервера Exchange. Чтобы сделать это, выберите процесс, рядом с которым имеется отметка Не найден!, и щелкните «Изменить». Рекомендуется запустить мастер настройки безопасности на сервере Exchange, чтобы убедиться в правильности пути к каждому исполняемому файлу процесса сервера Exchange. После успешной проверки путей ко всем исполняемым файлам процессов можно применить политику безопасности в мастере настройки безопасности, кроме того, чтобы сервер Exchange функционировал, для него должен иметься сетевой доступ.

Дополнительные сведения о пакете обновления 1 (SP1) для Windows Server 2003 и о мастере настройки безопасности см. на веб-узле Windows Server 2003 TechCenter (http://go.microsoft.com/fwlink/?LinkId=45315).


Файл XESE.DLL существует
Анализатор сервера Microsoft Exchange — статьи > Сервер Exchange >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс CIM_Datafile, чтобы определить значение раздела Version для файла Xese.dll:

Если анализатор может получить значение Version для этого файла, это означает, что файл существует, поэтому выводится сообщение об ошибке.

Некоторые антивирусные программы на базе ESE являются неподдерживаемым интерфейсом между банком данных Exchange и ESE. При использовании такого программного обеспечения существует риск повреждения базы данных и потери данных в случае наличия ошибок в реализации программного обеспечения.

Во время установки сканер на базе ESE изменяет службу банка данных Microsoft Exchange таким образом, чтобы она зависела от службы антивирусной программы на базе ESE. Это гарантирует запуск антивирусной программы на базе ESE раньше службы банка данных Microsoft Exchange. При запуске антивирусной программы на базе ESE версия файла Ese.dll, входящая в состав Exchange Server, временно переименовывается в Xese.dll, а версия файла Ese.dll антивирусной программы на базе ESE заменяет исходный файл. После того как версия файла Ese.dll антивирусной программы, основанной на модуле ESE, загрузится, версия файла, поставляемого с сервером Exchange, переименовывается обратно в Ese.dll, и служба банка данных Microsoft Exchange завершает процесс загрузки.

Чтобы устранить причину появления этого предупреждения

  1. Настоятельно рекомендуется избегать использования на компьютерах с Exchange Server реализаций ESE сторонних производителей (не корпорации Майкрософт). Заказчикам, обращающимся в службу поддержки продуктов корпорации Майкрософт, может потребоваться отключить антивирусную программу на базе ESE для диагностирования неполадки, однако после выявления основной причины неполадки заказчики могут вновь включить эту программу.

  2. Наиболее широко используемой антивирусной программой, основанной на модуле ESE, является Antigen для Microsoft Exchange от компании Sybari Software. Корпорация Майкрософт и компания Sybari пришли к выводу, что отключение программы Antigen компании Sybari является необходимым шагом при определении причин возникновения проблем в процессе устранения неполадок. Чтобы связаться с компанией Sybari Software, посетите ее веб-узел (http://www.sybari.com).

    Примечание.
    Сведения о веб-узлах сторонних компаний предоставлены для оказания помощи в поиске необходимой технической информации. URL-адреса могут быть изменены без предварительного уведомления.

  3. Рекомендуется использовать антивирусные программы, которые поддерживают интерфейс VSAPI (Virus Scanning Application Programming Interface), известный еще как интерфейс AVAPI.

Дополнительные сведения о запуске антивирусного программного обеспечения на сервере Exchange см. в следующих статьях базы знаний Майкрософт:

  • Статья 823166, содержащая обзор Exchange Server 2003 и антивирусного программного обеспечения (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=).

  • Статья 328841, посвященная Exchange и антивирусному программному обеспечению (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=).


Оборудование
Анализатор сервера Microsoft Exchange — статьи >

Дата последнего изменения раздела: 2005-11-18

В статьях этого раздела приводятся подробные сведения о том, какую относящуюся к оборудованию информацию предоставляет средство анализатора сервера Microsoft® Exchange. Кроме того, в этих статьях указывается, какие следует предпринять действия в связи с полученной от анализатора сервера Exchange информацией об относящихся к работе оборудования ошибках, предупреждениях и конфигурациях, отличающихся от заданных по умолчанию.


BIOS устарел
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_BIOS, чтобы определить значение разделов SMBIOSBIOSVersion и ReleaseDate. Возвращаемое значение отражает, соответственно, номер версии и дату выпуска BIOS, установленного на компьютере. Анализатор сервера Exchange также проверяет WMI-класс Win32_ComputerSystem, чтобы определить значение раздела Model.

Если анализатор сервера обнаруживает, что значение ReleaseDate показывает, что обновления не было более года, и что раздел Model содержит любую из следующих строк, на экран выводится предупреждение:

  • ProLiant DL320

  • ProLiant DL320 G2

  • ProLiant DL320 G3

  • ProLiant DL360

  • ProLiant DL360 G2

  • ProLiant DL360 G3

  • ProLiant DL360 G4

  • ProLiant DL380

  • ProLiant DL380 G2

  • ProLiant DL380 G3

  • ProLiant DL380 G4

  • ProLiant DL560

  • ProLiant DL570 G3

  • ProLiant DL580

  • ProLiant DL580 G2

  • ProLiant DL580 G3

  • ProLiant DL585 G1

  • ProLiant ML350

  • ProLiant ML350 G2

  • ProLiant ML350 G3

  • ProLiant ML350 G4

  • ProLiant ML370

  • ProLiant ML370 G2

  • ProLiant ML370 G3

  • ProLiant ML370 G4

  • ProLiant ML530

  • ProLiant ML530 G2

  • ProLiant ML570

  • ProLiant ML570 G2

  • ProLiant ML750

Чтобы устранить причины появления этого предупреждения, и для получения дополнительных сведений о получении и обновлении более новой версии BIOS см. веб-узел компании Hewlett-Packard "ROM-BIOS/Firmware Updates" (ОЗУ-BIOS: обновление встроенного программного обеспечения) (http://h18023.www1.hp.com/support/files/server/us/romtabl.html).

Дополнительные сведения о серверах Hewlett-Packard ProLiant см. на веб-узле Hewlett-Packard Web (http://www.hp.com).

Примечание.
Веб-адреса могут измениться, поэтому существует вероятность, что вам не удастся подключиться к упомянутым здесь веб-узлам.


BIOS на сервере Dell PowerEdge устарел
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server запрашивает класс Win32_BIOS инструментария Microsoft Windows® Management Instrumentation (WMI), чтобы определить значение параметра SMBIOSBIOSVersion. Возвращаемое значение — номер версии BIOS, установленной на компьютере. Кроме того, средство анализа Exchange Server проверяет класс Win32_ComputerSystem WMI, чтобы определить значение параметра Model.

Если средство анализа Exchange Server обнаружит, что раздел Model содержит хотя бы одну из следующих строк, а значение SMBIOSBIOSVersion не соответствует последней версии для данной модели, появится предупреждение:

  • PowerEdge 2400

  • PowerEdge 2450

  • PowerEdge 2500

  • PowerEdge 2550

  • PowerEdge 2600

  • PowerEdge 2650

  • PowerEdge 2800

  • PowerEdge 2850

  • PowerEdge 3250

  • PowerEdge 4300

  • PowerEdge 4350

  • PowerEdge 4400

  • PowerEdge 4600

  • PowerEdge 6300

  • PowerEdge 6350

  • PowerEdge 6400

  • PowerEdge 6450

  • PowerEdge 6600

  • PowerEdge 6650

  • PowerEdge 6800

  • PowerEdge 6850

  • PowerEdge 7150

  • PowerEdge 7250

  • PowerEdge 8450

Для получения сведений об исправлении этого предупреждения, а также о том, как получить и установить новую версию BIOS, см. веб-узел Dell, раздел загрузок (http://support.dell.com/support/downloads).

Для получения дополнительных сведений о серверах Dell PowerEdge см. веб-узел Dell (http://www.dell.com).

Примечание.
Веб-адреса могут измениться, и поэтому, возможно, не удастся подключиться к веб-узлам, упомянутым здесь.


Доступно обновление BIOS
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс Win32_BIOS, чтобы определить значение ключа SMBIOSBIOSVersion. Возвращаемое значение отражает номер версии и дату выпуска BIOS, установленного на компьютере. Анализатор сервера Exchange также просматривает WMI-класс Win32_ComputerSystem, чтобы определить значение ключа Model. Если анализатор сервера Exchange обнаружит, что компьютер является системой IBM X445 с версией BIOS более ранней, чем REJT48A, анализатор выведет на экран сообщение об ошибке.

Сведения об исправлении этой ошибки, а также о получении и обновлении версии BIOS см. на веб-узле IBM, посвященном обновлению Flash BIOS (пакет обновления для DOS) с поддержкой RSA I и RSA II EXA для IBM eServer xSeries 445 (может быть на английском языке) (http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-54089).

Примечание.
Веб-адреса могут измениться, поэтому существует вероятность, что указанные веб-узлы будут недоступны.


Для кластерного сетевого адаптера включена поддержка DHCP
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс Win32_NetworkAdapterConfiguration, чтобы определить значение ключа DHCPEnabled для всех сетевых интерфейсов в кластере. Если анализатор сервера Exchange обнаруживает, что для параметра DHCPEnabled любого частного сетевого интерфейса кластера задано значение True, выводится сообщение об ошибке.

Значение «True» WMI-ключа DHCPEnabled указывает, что сетевой интерфейс настроен на использование DHCP. Корпорация Майкрософт не поддерживает использование DHCP для узлов частной сети в кластере серверов Windows. Для узлов общих сетей кластера серверов Windows рекомендуется использовать статические IP-адреса. Использование динамической конфигурации для общих сетей с поддержкой DHCP нежелательно, так как сбой при обновлении DHCP-аренды может вызвать нарушение операций кластера. Кроме того, не поддерживается использование динамической конфигурации для частных сетей с поддержкой DHCP. Не следует реализовывать такую конфигурацию.

Чтобы устранить эту неполадку, необходимо выполнить перенастройку сетевых интерфейсов для частных сетей с использованием статических IP-адресов. Рекомендуется выбирать адреса из следующего диапазона:

  • 10.0.0.0 — 10.255.255.255 (сеть класса A)

  • 172.16.0.0 - 172.31.255.255 (сеть класса B)

  • 192.168.0.0 - 192.168.255.255 (сеть класса C)

Чтобы устранить эту ошибку

  1. В разделе «Сетевые подключения» щелкните правой кнопкой мыши сетевое подключение для своего сетевого адаптера и выберите команду Свойства.

  2. Щелкните Протокол Интернета (TCP/IP), а затем нажмите кнопку Свойства.

  3. На вкладке Общие введите статический IP-адрес, не входящий в подсеть или в сеть, содержащую другой из сетевых адаптеров данной общей сети. Пример IP-адресов, которые рекомендуется для частных адаптеров — 10.10.10.10 в узле 1 и 10.10.10.11 в узле 2 с маской подсети 255.0.0.0. Если в общей сети используется сеть 10.x.x.x и маска подсети 255.0.0.0, следует воспользоваться другими IP-адресом и подсетью частной сети.

  4. Убедитесь, что в поле Шлюз по умолчанию не указано значение.

  5. Проверьте отсутствие значений в поле Использовать следующие адреса DNS-серверов.

  6. Щелкните Дополнительно.

  7. Убедитесь, что на вкладке DNS не указано ни одно значение. Также убедитесь, что сняты флажки Зарегистрировать адреса этого подключения в DNS и Использовать DNS-суффикс подключения при регистрации DNS.

  8. Убедитесь, что на вкладке WINS не указано ни одно значение. Щелкните Отключить NetBIOS через TCP/IP.

  9. При попытке закрыть это диалоговое окно может быть выведено следующее сообщение. В этом случае нажмите кнопку Да: Для данного подключения указан пустой основной WINS-адрес. Продолжить?

  10. Нажмите кнопку ОК, чтобы сохранить изменения.

  11. Выполните предыдущие шаги для всех других узлов кластера.

Дополнительные сведения об оптимальной конфигурации сети для кластеров серверов Windows см. в документе «Server Clusters: Network Configuration Best Practices for Windows 2000 and Windows Server 2003» (http://go.microsoft.com/fwlink/?linkid=34304) (Кластеры серверов: рекомендации по настройке конфигурации сети в Windows 2000 и Windows Server 2003).

Дополнительные сведения о правильной настройке конфигурации пульса кластера см. в статье 258750 базы знаний «Recommended Private Heartbeat Configuration on a Cluster Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750) (Рекомендуемая настройка пульса частной сети на сервере кластера).


Основной DNS-суффикс компьютера не совпадает с полным доменным именем FQDN домена, в котором он находится
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2006-05-18

Средство анализатора сервера Microsoft® Exchange считывает следующие записи реестра, чтобы определить основной суффикс службы доменных имен (DNS) для данного сервера Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\NV Domain

HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Domain

Если анализатор сервера Exchange обнаруживает, что значения для NV Domain и Domain не совпадают, на экран выводится предупреждение.

Параметр NV Domain реестра содержит основной DNS-суффикс компьютера. Параметр Domain реестра содержит основной DNS-домен компьютера. По умолчанию основная часть DNS-суффикса полного доменного имени (FQDN) компьютера должна совпадать с именем домена службы каталогов Active Directory®, в котором находится компьютер. Несовпадающие имена могут воспрепятствовать правильному выполнению DNS-регистрации. Если DNS-имя компьютера не совпадает с именем домена Active Directory, можно будет наблюдать сообщения об ошибках в системном журнале ошибок компьютера каждые 22 минуты. Такая ситуация известна как раздельное пространство имен. Чтобы разрешить существование различных основных DNS-суффиксов, можно создать ограниченный список допустимых суффиксов путем создания атрибута Active Directory, называемого msDS-AllowedDNSSuffixes, в контейнере объектов домена.

Процедура, обеспечивающая наличие правильно настроенного раздельного пространства имен, зависит от операционной системы, используемой для ваших контроллеров домена Active Directory.

  • В случае использования для контроллеров домена операционной системы Microsoft Windows® 2000 Server можно использовать процедуру, описанную в базе данных Майкрософт в статье 258503, в которой описываются ошибки DNS-регистрации 5788 и 5789, когда имена DNS-домена и домена Active Directory различны (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258503), чтобы правильно настроить пространство имен. В данной статье описаны процедуры корректировки непредусмотренного раздельного пространства имен и правильной настройки раздельного пространства имен, если оно предусмотрено.

  • В случае использования для контроллеров домена операционной системы Microsoft Windows Server™ 2003 и непредусмотренного раздельного пространства имен можно использовать первую процедуру для корректировки непредусмотренного раздельного пространства имен и устранения причины появления данного предупреждения. В случае использования для контроллеров домена операционной системы Microsoft Windows Server 2003 и предусмотренного раздельного пространства имен можно использовать вторую процедуру для правильной его настройки.

Чтобы выполнить описанную ниже вторую процедуру, необходимо использовать редактор Active Directory, например ADSI Edit или средство LDP (Ldp.exe). Дополнительные сведения об изменении службы Active Directory с помощью средства LDP см. в базе знаний Майкрософт в статье 260745, описывающей: использование служебной программы LDP для изменения атрибутов объектов Active Directory (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260745).

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью ADSI Edit, средства LDP или другого LDAP-клиента версии 3 может привести к возникновению серьезных неполадок. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Если раздельное пространство имен является непредусмотренным

  1. Щелкните правой кнопкой мыши Мой компьютер и в контекстном меню выберите Свойства. Появится диалоговое окно «Свойства системы».

  2. Щелкните вкладку Имя компьютера.

  3. Щелкните Изменить. Появится диалоговое окно Изменение имени компьютера.

  4. Нажмите кнопку Дополнительно. Появится диалоговое окно DNS-суффикс и NetBIOS-имя компьютера.

  5. Установите флажок Сменить основной DNS-суффикс при смене членства в домене.

  6. Два раза нажмите кнопку ОК, чтобы сохранить изменения, а затем нажмите кнопку ОК, чтобы выйти из диалогового окна Изменение имени компьютера.

  7. Нажмите кнопку OK, чтобы закрыть диалоговое окно Свойства системы, а затем перезапустите компьютер, чтобы изменение вступило в силу.

Если раздельное пространство имен является предусмотренным

  1. Используйте процедуру, приведенную выше, для обеспечения снятия флажка Сменить основной DNS-суффикс при смене членства в домене.

  2. Измените атрибут Active Directory msDS-AllowedDNSSuffixes в контейнере объектов домена. Можно сделать это с помощью ADSI Edit, выполнив следующие шаги:

    1. Дважды щелкните в разделе каталога доменов домен, который предполагается изменить

    2. Щелкните правой кнопкой объект контейнера домена и в контекстном меню выберите Свойства.

    3. На вкладке Редактор атрибутов в окне Атрибуты дважды щелкните кнопкой мыши атрибут msDS-AllowedDNSSuffixes.

    4. В диалоговом окне Редактор многострочных параметров в поле добавления Значение введите DNS-суффикс и затем нажмите кнопку Добавить.

    5. После добавления DNS-суффиксов для домена нажмите кнопку OK.

    6. Нажмите кнопку ОК, чтобы закрыть диалоговое окно Свойства для данного домена.

    7. Повторите эти шаги, если предполагается аналогичным образом настроить несколько доменов.

Дополнительные сведения об атрибуте msDS-AllowedDNSSuffixes см. в справке Windows Server 2003 и в центре поддержки. Дополнительные сведения о данной процедуре, используемой для редактирования этого атрибута, см. в разделе "Пошаговое руководство по выполнению переименования домена" (http://go.microsoft.com/fwlink/?LinkId=41359).


Доступно критическое обновление BIOS
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2006-04-20

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_BIOS, чтобы определить значение параметра SMBIOSBIOSVersion. Значение параметра SMBIOSBIOSVersion представляет версию BIOS, установленную на сервере. Анализатор сервера Exchange также запрашивает WMI-класс Win32_ComputerSystem, чтобы определить значение параметра Model. Параметр «Model» представляет сведения о модели оборудования, предоставленные производителем.

Если анализатор сервера Exchange обнаруживает, что параметр Version имеет значение 42B на сервере, чей параметр Model начинается с eserver xSeries 445, выводится сообщение об ошибке. Эта ошибка указывает на необходимость обновления BIOS данного сервера IBM xSeries 445.

В версии 42B присутствует известная ошибка микропрограммы BIOS, которая может привести к повреждению данных. Данная проблема относится только к системам X445 с установленной системой BIOS 42B (версия 1.15). Установка BIOS 45A устраняет эту проблему. Необходимо как можно скорее обновить BIOS на данном сервере до версии 45A.

Чтобы устранить эту ошибку

  1. Дополнительные сведения о данной проблеме см. на веб-узле компании IBM в разделе, посвященном обновлению Flash BIOS (набор обновления DOS) для IBM eServer xSeries 445 (может быть на английском языке) (http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-54089#BIOSVersion).

  2. Дополнительные сведения см. в файле Readme обновления BIOS (может быть на английском языке) (ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers/39y4888.txt).

  3. Загрузите обновление BIOS с веб-узла компании IBM (http://www-307.ibm.com/pc/support/site.wss/license.do?filename=pc_servers/26r0663.exe).

  4. Обновите BIOS на сервере.

Дополнительные сведения о применении этого критического обновления BIOS см. на веб-узле компании IBM (может быть на английском языке) (http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=DSHY-3TEPF6).

Примечание.
Веб-адреса могут измениться, поэтому существует вероятность, что вам не удастся подключиться к упомянутым здесь веб-узлам.


Текущая тактовая частота процессора меньше максимально возможной
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Processor, чтобы определить текущие значения MaxClockSpeed и CurrentClockSpeed. Если анализатор сервера Exchange обнаруживает, что значение CurrentClockSpeed меньше значения MaxClockSpeed, выводится предупреждение.

Значение CurrentClockSpeed представляет собой текущую тактовую частоту каждого процессора в мегагерцах (МГц). MaxClockSpeed — максимальная тактовая частота каждого процессора в мегагерцах. Появление этого предупреждающего сообщения свидетельствует о том, что один или несколько процессоров сервера Exchange работают не с максимальной скоростью. Такая ситуация может быть вызвана несколькими причинами.

  1. Сервер Exchange установлен на компьютере, работающем под управлением операционной системы Microsoft Windows® 2000 Server или Windows 2000 Advanced Server, для которой не установлен Windows 2000 Server с необходимым пакетом обновлений не ниже SP3. Windows 2000 Server с пакетом обновлений SP3 исправил проблему возвращения WMI неправильных значений для MaxClockSpeed и CurrentClockSpeed.

  2. Неправильная настройка параметров энергосбережения в BIOS сервера Exchange может заставить процессор работать с уменьшенной тактовой частотой в режиме экономии электроэнергии.

Чтобы устранить причину появления этого предупреждения

  1. Если сервер Exchange установлен на компьютере с операционной системой Windows 2000 Server или Windows 2000 Advanced Server, для которой не установлен Windows 2000 Server с пакетом обновлений не ниже SP3, следует установить новейший пакет обновлений. Дополнительные сведения о новейших пакетах обновлений Windows 2000 см. на веб-узле Microsoft Windows 2000 (http://go.microsoft.com/fwlink/?LinkId=18353).

  2. Если сервер Exchange установлен на компьютере с операционной системой Windows 2000 Server или Windows 2000 Advanced Server, для которой установлен пакет обновлений Windows 2000 Server SP3 или более поздний, проверьте настройки BIOS сервера Exchange. Следует также проверить настройки электропитания в BIOS и в Панели управления или в Диспетчере устройств.

Сведения о просмотре и настройке параметров BIOS компьютера, процессора и электропитания см. в документации производителя оборудования.

Дополнительные сведения о функциях управления электропитанием в Windows 2000 Server см. в статье 244806 базы знаний Майкрософт, содержащей обзор управления электропитанием в Windows 2000, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=244806 (возможно, на английском языке).

Дополнительные сведения о функциях управления электропитанием в Microsoft Windows Server™ 2003 можно найти в разделах «Управление питанием» и «Общие сведения о параметрах электропитания» Центра справки и поддержки Windows Server 2003, который запускается из меню «Пуск» компьютера с операционной системой Windows Server 2003.

Дополнительные сведения о функциях управления питанием в операционной системе Windows 2000 Server см. в разделах «Управление питанием» и «Общие сведения о параметрах электропитания» справки Windows 2000 Server, которая запускается из меню «Пуск» компьютера с операционной системой Windows 2000 Server.


Непрвильно настроен раздел реестра DisableDHCPMediaSense в Windows Server 2003
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2006-10-02

Анализатор сервера Microsoft® Exchange считывает следующий раздел реестра, чтобы определить, правильно ли настроена возможность обнаружения носителей:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\DisableDHCPMediaSense

Кроме того, анализатор сервера Exchange проверяет следующий раздел реестра, чтобы определить версию Windows, под управлением которой работает компьютер назначения:

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Если параметр CurrentVersion имеет значение 4.0, это указывает, что данный компьютер работает под управлением ОС Microsoft Windows NT® Server 4.0. Значение 5.0 указывает, что компьютер работает под управлением операционной системы Windows® 2000 Server, а значение 5.2 — что компьютер работает под управлением ОС Windows Server™ 2003.

Кроме того, анализатор сервера Exchange запрашивает WMI-класс (Microsoft Windows Management Instrumentation) Win32_Service, чтобы получить значение раздела Started для ClusSvc, службы кластеров Microsoft Windows. Значение True указывает, что служба кластеров Windows выполняется, and значение False — что она не выполняется.

Если анализатор сервера Exchange обнаруживает, что служба кластеров Windows выполняется на компьютере под управлением Windows Server 2003, Enterprise Edition или Windows Server 2003, Datacenter Edition и при этом значение раздела реестра DisableDHCPMediaSense равно 1, отображается предупреждение.

При использовании службы кластеров Windows Server 2003 в случае утраты подключения к сети TCP/IP-стек по умолчанию не выгружается, в отличие от Windows 2000 Server. В результате нет необходимости настраивать раздел реестра DisableDHCPMediaSense. В Windows 2000 Server при утрате подключения к сети TCP/IP-стек выгружался. Эт означало, что все ресурсы кластера, включая ресурсы виртуального сервера Exchange, в которых использоваличь IP-адреса, переводились в автономный режим. При восстановлении сетей их роли переключались на заданные по умолчанию (клиентская или частная). Если возможность обнаружения носителей по умолчанию отключена, сетевые роли будут сохранены, а ресурсы, в которых используются IP-адреса, останутся подключенными к сети.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра:

    HKLM\System\CurrentControlSet\Services\Tcpip\Parameters

  3. В правой панели дважды щелкните правой кнопкой мыши значение реестра DisableDHCPMediaSense, чтобы изменить (установите значение 0, чтобы отключить это значение) либо удалить его.

  4. Закройте редактор реестра.

  5. Переместите все кластерные ресурсы на другой узел или переключите их в автономный режим. Затем повторно запустите узел кластера, чтобы изменения вступили в силу.

  6. Повторите эту процедуру на всех остальных узлах кластера, где было создано данное предупреждение.

Дополнительные сведения о реестре Microsoft Windows см. в статье 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения о возможности обнаружения носителей и кластерах Windows см. в следующих статьях базы знаний:

  • 254651, «Cluster network role changes automatically» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=254651) (Сетевая роль кластера изменяется автоматически)

  • 239924, «How to disable Media Sense for TCP/IP in Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=239924) (Инструкции по отключению обнаружения носителей для протокола TCP/IP в Windows)

  • 242430, «Network Adapter Not Available During Cluster Configuration with a Crossover Cable» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=242430) (Сетевой адаптер недоступен в процессе настройки кластера с использованием кабеля переключения)

  • 278007, «Available Features in Windows Server 2003 Clusters» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=278007) (Возможности, доступные в кластерах Windows Server 2003)


Раздел DisableDHCPMediaSense реестра в Windows 2000 Server настроен неправильно
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2005-11-18

Для определения, правильно ли настроена функция обнаружения датчика наличия сетевого соединения, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\DisableDHCPMediaSense

Чтобы определить версию операционной системы Windows, установленной на целевом компьютере, анализатор сервера Exchange проверяет также следующую запись реестра:

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Значение CurrentVersion, равное 4.0, означает, что компьютер работает под управлением операционной системы Microsoft Windows NT® Server 4.0. Значение 5.0 означает, что компьютер работает под управлением операционной системы Microsoft Windows® 2000, а значение 5.2 означает, что компьютер работает под управлением операционной системы Microsoft Windows Server™ 2003.

Кроме того, средство анализатора сервера Exchange запрашивает класс инструментария WMI Win32_Service, чтобы определить значение раздела Started для ClusSvc — службы кластеров Microsoft Windows. Значение Истина указывает на то, что служба кластеров Windows работает, а значение Ложь указывает, что она не работает.

Если анализатор сервера Exchange обнаруживает, что служба кластеров Windows работает в Windows 2000 Advanced Server или в Windows 2000 Datacenter Server, и если раздел DisableDHCPMediaSense реестра присутствует, причем его значение не установлено равным 1, на экран выводится предупреждение.

При использовании службы кластеров Windows 2000 Server, если подключение к сети потеряно, стек TCP/IP выгружается. Это означает, что все ресурсы кластеров, включая ресурсы виртуального сервера Exchange, зависящие от IP-адресов, переведены в автономный режим. Когда сети возвращаются в интерактивный режим, их сетевые роли возвращаются к значениям параметров по умолчанию (клиентов и частной сети). Чтобы этого не случилось, рекомендуется отключить функцию обнаружения датчика наличия сетевого соединения во всех кластерах на основе Windows 2000 Server. Функция обнаружения датчика наличия сетевого соединения автоматически отключается в кластерах на основе Windows Server 2003.

Важно!
Этот раздел содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра:

    HKLM\System\CurrentControlSet\Services\Tcpip\Parameters

  3. Щелкните правой кнопкой мыши Параметры и затем щелкните Создать значение | DWORD. Введите в качестве имени DisableDHCPMediaSense и нажмите кнопку Enter.

  4. В правой области дважды щелкните DisableDHCPMediaSense и введите значение, равное 1.

  5. Закройте редактор реестра.

  6. Переместите все ресурсы кластера в другой узел или переведите их в автономный режим. Перезагрузите каждый узел, чтобы изменения вступили в силу.

  7. Повторите эту процедуру для всех узлов в кластере, выдавших предупреждение.

Дополнительные сведения о реестре Microsoft Windows см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о функции обнаружении датчика наличия сетевого соединения и кластерах Windows см. в следующих статьях базы знаний:

  • 254651, в которой описывается автоматическое изменение сетевых ролей в кластере (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328810)

  • 239924, в которой описывается порядок отключения датчика сетевой среды в Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=239924)

  • 242430, в которой описывается случай, когда сетевой адаптер отсутствует во время настройки кластеров с помощью перекрестного кабеля (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328810)

  • 278007, в которой описываются доступные функции в кластерах Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821829)


Время ожидания для диска отличается от умолчания
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, отличается ли от применяемого по умолчанию время ожидания ответа диска, анализатор сервера Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Disk\TimeOutValue

Если анализатор сервера Exchange определяет, что параметр TimeOutValue присутствует, его значение не равно 10 и сервер не является кластерным, выводится сообщение о наличии нестандартной конфигурации. Если анализатор сервера Exchange определяет, что параметр TimeOutValue присутствует, его значение не равно 20, а сервер является кластерным, также выводится сообщение о нестандартной конфигурации.

Время ожидания для диска — параметр реестра, определяющий время, в течение которого Microsoft Windows® будет ожидать ответа жесткого диска на команду. На некластерных системах этот параметр не задается и для всех дисков используется значение по умолчанию 10 секунд. В кластерах Windows этот параметр присутствует, а по умолчанию используется значение 20 секунд. Если время ожидания больше значения этого параметра реестра, Windows возвращает ошибку и блокирует доступ к диску. Иногда, если используется программное обеспечение (ПО) для группового дискового доступа, может потребоваться большее значение. ПО группового доступа позволяет для организации избыточности подсоединить к одному диску несколько физических путей (например, волоконно-оптический кабель). ПО группового доступа управляет несколькими физическими соединениями, в то время как Windows продолжает работать только с одним дескриптором диска.

Необходимость в добавлении и настройке этого параметра может возникнуть при установке адаптеров шины (HBA) или других контроллеров хранилища. При установке или переустановке этих драйверов значение реестра TimeOutValue перезаписывается значением, необходимым для этих драйверов. Правильное значение параметра реестра TimeOutValue для определенной конфигурации можно выяснить у поставщика соответствующего оборудования.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неполадок. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы восстановить конфигурацию по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра:

    HKLM\System\CurrentControlSet\Services\Disk\TimeOutValue

  3. В правой области удалите параметр реестра TimeOutValue. Либо дважды щелкните параметр TimeOutValue и установите для него одно из следующих значений:

    • На некластерном сервере введите значение 10.

    • На кластерном сервере введите значение 20.

    • Если изготовитель оборудования рекомендует другое значение для кластерной или некластерной системы, используйте значение, рекомендуемое изготовителем оборудования.

  4. Закройте редактор реестра и перезагрузите компьютер, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в статье 256986 базы знаний Майкрософт, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о параметрах TimeOutValue для кластерных систем см. в статье 818877 базы знаний «Cluster Servers May Experience Connection Timeouts to Drives After You Install or Upgrade to the Windows Clustering Feature in Windows Server 2003» (После установки или обновления функции кластеров Windows на кластерных серверах Windows Server 2003 могут возникать проблемы ожидания доступа к дискам) (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818877).


Порядок поиска DNS является пустым
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_NetworkAdapterConfiguration, чтобы определить, установлено ли значение раздела DNSServerSearchOrder. Если значение этого ключа на сервере Exchange пустое, на экран выводится предупреждение.

Это предупреждение указывает, что один или несколько сетевых адаптеров на этом компьютере, не содержит сопоставленных им IP-адресов DNS. Поэтому, если этот компьютер пытается подключиться к другому компьютеру, он посылает широковещательные пакеты по всей локальной сети, пытаясь найти IP-адреса. Следовательно, разрешение имен будет происходить медленно, что, в свою очередь, замедлит быстродействие Exchange.

Рекомендуется ввести IP-адрес хотя бы одного DNS-сервера. Если на компьютере установлено несколько сетевых адаптеров, убедитесь, что для каждого адаптера имеется IP-адрес хотя бы одного допустимого DNS-сервера.

Чтобы настроить IP-адрес DNS на сетевом адаптере

  1. В компоненте Сетевые подключения щелкните правой кнопкой мыши необходимый адаптер подключения по локальной сети и выберите Свойства.

  2. На вкладке Общие дважды щелкните Протокол Интернета (TCP/IP).

  3. На вкладке Общие страницы Протокол Интернета (TCP/IP) введите хотя бы один IP-адрес допустимого DNS-сервера и нажмите кнопку ОК.

Дополнительные сведения о работоспособной настройке DNS в Exchange см. в статье 322856 базы знаний Майкрософт, посвященной инструкциям по настройке DNS для сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322856).


В подключении подтверждения соединения используется шлюз по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_NetworkAdapter, чтобы определить значение ключа NetConnectionID. Если значение ключа NetConnectionID содержит строку Internal или HEART, это указывает, что данный интерфейс является частной кластерной сетью (сетью подтверждения соединения).

Анализатор сервера Exchange также запрашивает WMI-класс Win32_NetworkAdapterConfiguration, чтобы определить, установлено ли значение ключа DefaultIPGateway. Наличие этого значения указывает, что для данного сетевого интерфейса настроен шлюз по умолчанию.

Если анализатор сервера Exchange обнаруживает, что значение, установленное для ключа DefaultIPGateway в данном сетевом интерфейсе, используется для сети подтверждения соединения кластера, выводится предупреждение.

Так как частные кластерные сети используются для внутреннего обмена данными в кластерах, нет необходимости создавать для них шлюз по умолчанию. Чтобы предотвратить появление возможных неполадок обмена данными, рекомендуется удалить весь ненужный сетевой трафик с сетевого адаптера, который используется в качестве адаптера частной кластерной сети.

Чтобы устранить причину появления этого предупреждения

  1. Откройте окно «Сетевые подключения». Щелкните правой кнопкой мыши значок Мои сетевые подключения и выберите команду Свойства либо (если значок «Мои сетевые подключения» не отображается на рабочем столе) нажмите кнопку Пуск и последовательно щелкните Программы, Стандартные, Связь и Сетевые подключения.

  2. В окне «Сетевые подключения» щелкните правой кнопкой мыши сетевой адаптер, используемый для частной сети, и выберите команду Свойства.

  3. Выберите Интернет-протокол (TCP/IP), а затем нажмите кнопку Свойства.

  4. В области «Использовать следующий IP-адрес» удалите IP-адрес шлюза по умолчанию.

  5. Два раза нажмите кнопку ОК, чтобы сохранить изменения.

  6. Повторите шаги 1-5 для каждого узла в кластере.

Дополнительные сведения о рекомендуемых параметрах частной сети на кластере серверов Windows см. в статье 258750 базы знаний Майкрософт «Recommended Private 'Heartbeat' Configuration on a Cluster Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750) (Рекомендуемая конфигурация частной сети подтверждения соединения для сервера кластера).


Пульс подключения содержит адрес поиска DNS
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс Win32_NetworkAdapter, чтобы определить значение раздела NetConnectionID. Если значение раздела NetConnectionID содержит строку Internal или HEART, это означает, что интерфейс является кластерной частной сетью (сетью пульса).

Анализатор сервера Microsoft® Exchange также запрашивает WMI-класс Win32_NetworkAdapterConfiguration, чтобы определить, установлено ли значение раздела DNSServerSearchOrder. Если значение установлено, это означает, что адрес поиска DNS был настроен на этом сетевом интерфейсе.

Если анализатор сервера Exchange обнаружит установленное значение параметра DNSServerSearchOrder на сетевом интерфейсе, используемом для сети пульса кластера, анализатор отобразит предупреждение.

Так как частные кластерные сети используются для внутренней связи кластеров, нет необходимости настраивать серверы DNS. Чтобы устранить возможные проблемы со связью, рекомендуется избегать ненужного сетевого трафика на сетевом адаптере, который используется в качестве частного кластерного сетевого адаптера.

Чтобы устранить причину появления этого предупреждения

  1. Откройте компонент Сетевые подключения. Щелкните правой кнопкой мыши Сетевое окружение, затем щелкните Свойства или, если на рабочем столе не отображается элемент «Сетевое окружение», нажмите кнопку Пуск, щелкните Программы, затем Стандартные, Связь и выберите Сетевые подключения.

  2. В окне Сетевые подключения щелкните правой кнопкой мыши сетевой адаптер, который используется для частной сети, и щелкните Свойства.

  3. Выберите Протокол Интернета (TCP/IP), а затем нажмите кнопку Свойства.

  4. Щелкните Дополнительно.

  5. На вкладке «DNS» выберите адрес сервера DNS и нажмите кнопку Удалить. Повторите этот шаг для каждого адреса DNS-сервера в списке.

  6. Снимите флажки Зарегистрировать адреса этого подключения в DNS и Использовать DNS-суффикс подключения при регистрации DNS.

  7. Нажмите кнопку ОК три раза, чтобы сохранить изменения.

  8. Повторите шаги с 1 по 7 для каждого узла в кластере.

Дополнительные сведения о рекомендованных настройках для частной сети в кластере серверов Windows см. в статье 258750 базы знаний Майкрософт, посвященной рекомендованным настройкам частной конфигурации пульса на кластерном сервере (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750).


Пульс подключения содержит адрес WINS
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс Win32_NetworkAdapter, чтобы определить значение раздела NetConnectionID. Если значение раздела NetConnectionID содержит строку Internal или HEART, это означает, что интерфейс является кластерной частной сетью (сетью пульса).

Анализатор сервера Microsoft® Exchange также запрашивает WMI-класс Win32_NetworkAdapterConfiguration, чтобы определить, установлено ли значение раздела WINSPrimaryServer. Если значение установлено, это означает, что основной адрес WINS был настроен на этом сетевом интерфейсе.

Если анализатор сервера Exchange обнаружит установленное значение параметра WINSPrimaryServer на сетевом интерфейсе, используемом для сети пульса кластера, анализатор отобразит предупреждение.

Так как частные кластерные сети используются для внутренней связи кластеров, нет необходимости настраивать серверы WINS или использовать NetBIOS. Чтобы устранить возможные проблемы со связью, рекомендуется избегать ненужного сетевого трафика на сетевом адаптере, который используется в качестве частного кластерного сетевого адаптера.

Чтобы устранить причину появления этого предупреждения

  1. Откройте компонент «Сетевые подключения». Щелкните правой кнопкой мыши Сетевое окружение, затем щелкните Свойства или, если на рабочем столе не отображается элемент «Сетевое окружение», нажмите кнопку Пуск, щелкните Программы, затем Стандартные, Связь и выберите Сетевые подключения.

  2. В окне «Сетевые подключения» щелкните правой кнопкой мыши сетевой адаптер, который используется для частной сети, и щелкните Свойства.

  3. Выберите Протокол Интернета (TCP/IP), а затем нажмите кнопку Свойства.

  4. Щелкните Дополнительно.

  5. На вкладке «WINS» выберите адрес WINS и нажмите кнопку Удалить. Повторите этот шаг для каждого адреса WINS в списке.

  6. В области настройке NetBIOS установите флажок Отключить NetBIOS через TCP/IP.

  7. Нажмите кнопку ОК три раза, чтобы сохранить изменения. После первого нажатия кнопки ОК может появиться следующий запрос. Если этот запрос получен, нажмите кнопку Да: "Это подключение содержит пустой основной адрес WINS Продолжить?"

  8. Повторите шаги с 1 по 7 для каждого узла в кластере.

Дополнительные сведения о рекомендованных настройках для частной сети в кластере серверов Windows см. в статье 258750 базы знаний Майкрософт, посвященной рекомендованным настройкам частной конфигурации пульса на кластерном сервере (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750).


Первым в порядке привязки протокола TCP/IP является подключение синхронизации, а не общее подключение
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft Exchange Server запрашивает два класса инструментария Microsoft Windows Management Instrumentation (WMI) сделать следующее:

  • Класс WMI Win32_NetworkConfiguration опрашивается для определения значения параметра SettingID для всех сетевых интерфейсов кластера. Значением параметра SettingsID является идентификатор GUID, представляющий собой уникальный сетевой адаптер.

  • Класс WMI Win32_NetworkAdapter опрашивается для определения сетевых адаптеров, используемых для сообщений частной сети кластера Exchange. Эта частная сеть используется для внутрикластерных взаимодействий, в том числе для синхронизации кластера.

  • Кроме того, Exchange Server Analyzer проверяет значение следующего параметра реестра с целью определения порядка привязки сетевых адаптеров:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Linkage\Bind

Параметр реестра Bind является многостроковым параметром, содержащим список сетевых адаптеров в порядке привязки. Первый по списку сетевой адаптер привязан первым, второй по списку является вторым в порядке привязки, и т.д.

Если Exchange Server Analyzer обнаруживает, что сетевой адаптер синхронизации кластера является первым в порядке привязки, появляется предупреждение.

Чтобы решить проблему, убедитесь, что общий сетевой адаптер является первым в порядке привязки. При наличии нескольких общих сетевых адаптеров убедитесь, что частный сетевой адаптер синхронизации является последним в списке. Если сетевой адаптер синхронизации стоит первым в списке, могут возникнуть проблемы при установке пакетов обновления.

Исправление предупреждения

  1. В окне «Сетевые подключения» нажмите кнопку Дополнительно, затем Дополнительные параметры.

  2. Выберите вкладку Адаптеры и привязки.

  3. В поле Подключения выберите частный сетевой адаптер и используйте стрелку вниз, чтобы переместить частный сетевой адаптер в конец списка.

  4. Повторите данные действия для каждого узла кластера.

Для получения дополнительных сведений об оптимальной настройке сети для кластеров серверов Windows см. статью «Кластеры серверов: рекомендации по настройке сети для Windows 2000 и Windows Server 2003» (http://go.microsoft.com/fwlink/?linkid=34304)

Для получения дополнительных сведений о правильной настройке синхронизации кластера см. статью 258750 базы знаний Майкрософт «Рекомендуемая настройка частной сети синхронизации на сервере кластера» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750).


Пульс скорости сети был установлен на автообнаружение
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс Win32_NetworkAdapter, чтобы определить значение раздела NetConnectionID. Если значение раздела NetConnectionID содержит строку Internal или HEART, это означает, что интерфейс является кластерной частной сетью (сетью пульса).

Анализатор также считывает следующее значение реестра, чтобы определить скорость и параметры дуплекса сетевого адаптера, используемого для сети пульса кластера.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\ <Идентификатор_сетевого_адаптера> \SpeedDuplex

Кроме того, включено ли автоматическое определение скорости, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKLM\System\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\%NICDEVICEID%\Ndi\Params\SpeedDuplex\enum\0

Если в значении раздела 0 содержится строка AUTO, это означает, что включено автоматическое определение скорости.

Если анализатор обнаружит, что значение раздела SpeedDuplex равно 0 и автоматическое определение скорости включено для сети пульса кластера, на экран выводится сообщение об ошибке.

Связь между узлами кластера серверов критична для бесперебойной работы кластера. Если в кластерной связи используется сетевой адаптер с разными скоростями и этот адаптер настроен на автоматическое определение скорости сети, адаптер может вызвать неполадки в кластере. Во время процесса обнаружения пакеты не могут быть обработаны адаптером и накапливаются в очереди. Некоторые адаптеры могут непроизвольно вызвать частое повторение процесса автоматического обнаружения. Поэтому пакеты накапливаются в очереди и происходят задержки связи. Задержки этого вида могут привести к тому, что узлы кластера не получат критические пакеты по требованию, что, в свою очередь, приведет к раннему переходу на другой ресурс при сбое. Рекомендуется, чтобы сеть пульса в кластере была установлена вручную на 10 мегабит и полудуплекс. Эти настройки обеспечат достаточную пропускную способность и надежную связь.

Чтобы устранить причину появления этого предупреждения

  • Настройте сетевой адаптер пульса сети на скорость 10 мегабит и режим полудуплекса. Так как способы настройки каждого сетевого адаптера различаются, следуйте инструкциям поставщика оборудования, чтобы правильно настроить сеть пульса. Для настройки этих параметров может потребоваться обновленный драйвер.

Дополнительные сведения о рекомендованных настройках для частной сети в кластере серверов Windows см. в статье 258750 базы знаний Майкрософт, посвященной рекомендованным настройкам частной конфигурации пульса на кластерном сервере (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750).


Глубина очереди адаптера шины равна 32
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2006-10-11

Чтобы определить глубину очереди адаптеров шины, установленных на компьютере сервера Exchange, средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\elxstor\Parameters\Device\DriverParameter

Если анализатор сервера Exchange обнаруживает, что для раздела DriverParameter установлено значение 32, отображается предупреждение.

Адаптер шины — это контроллер диска для сетей SAN. Размер очереди хост-адаптера определяет максимальное количество ожидающих запросов в очереди. Как правило, рекомендуется значение раздела DriverParameter, равное 128. Однако это может и не быть оптимальным значением для глубины очереди адаптера шины для каждого адаптера шины на каждом компьютере сервера Exchange. Поэтому необходимо проконсультироваться с производителем адаптера шины, чтобы получить оптимальное значение для определенного оборудования.

Чтобы устранить причину появления этого предупреждения

  1. Свяжитесь с производителем оборудования, чтобы определить оптимальное значения для адаптеров шины.

  2. Наблюдайте за производительностью диска с помощью системного монитора Microsoft Windows®.

  3. Обновите микропрограммы и драйверы для адаптеров шины.

Дополнительные сведения о структуре и оптимизации хранилищ Exchange Server см. статье, посвященной оптимизации хранилища для Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=49324).


Конфигурация памяти, добавляемой без выключения системы
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2006-02-22

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Computer System, чтобы определить поддерживает ли сервер возможности добавления памяти без отключения системы. Анализатор сервера Exchange также запрашивает WMI-класс Win32_OperatingSystem, чтобы определить следующие сведения:

  • Указан ли переключатель /3GB в файле Boot.ini.

  • Загружено ли ядро расширений физических адресов.

  • Какой выпуск операционной системы установлен на сервере.

Наконец, чтобы определить, существует ли параметр конфигурации DynamicMemory и правильно ли он настроен, анализатор сервера Exchange запрашивает следующую запись реестра:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Если анализатор сервера Exchange определяет, что все перечисляемые ниже условия выполняются, анализатор сервера Exchange выводит на экран сообщение об ошибке:

  • Компьютер поддерживает добавление памяти без выключения системы, и по умолчанию эта возможность включена.

  • Компьютер работает под управлением Microsoft Windows Server™ 2003 Enterprise Edition или Windows Server 2003 Datacenter Edition.

  • Загружено ядро расширений физической памяти.

  • Переключатель /3GB задан в файле Boot.ini.

  • Параметр DynamicMemory конфигурации в реестре не установлен, установлен равным 0 или установлен равным значению, превышающему 3.

Примечание.
Если компьютер поддерживает добавление памяти без выключения системы, а производитель оборудования отключает эту возможность по умолчанию, анализатор сервера Exchange выводит на экран предупреждение вместо сообщения об ошибке.

Возможность добавления памяти без выключения системы была введена в Windows Server 2003 Enterprise Edition и Windows Server 2003 Datacenter Edition, чтобы предоставить системным администраторам возможность добавления физической памяти в компьютер без его перезапуска. Эта функция удобна на серверах, поддерживающих приложения реляционных баз данных, такие как Microsoft SQL Server, которые активно потребляют ресурсы памяти. Однако поскольку сервер Exchange не может использовать больше 4 ГБ физической памяти, эта возможность не востребована для сервера Exchange.

Не все компьютеры поддерживают добавление памяти без выключения системы. Для компьютеров, которые поддерживают эту возможность, некоторые производители оборудования включают данную функцию по умолчанию, а другие предоставляют элементы управления этой возможностью в BIOS (Basic Input Output System). Если в процессе загрузки функция добавления памяти без выключения системы включена, ядро операционной системы должно предварительно выделить пространство для обработки любой памяти, которая может быть добавлена впоследствии в компьютер. Поэтому ресурсы ядра выделяются на основе возможностей компьютера без учета фактически установленного оборудования. Память ядра — драгоценный ресурс на компьютерах, на которых выполняется приложение Microsoft Exchange Server. Так как ядром выделяются значительные объемы ресурсов под память, которая часто не устанавливается, а также из-за природы физической памяти, используемой сервером Exchange, дополнительный выигрыш в производительности и масштабируемости может достигаться путем отключения функции добавления памяти без выключения системы. Если оставить эту функцию включенной, максимальный размер выгружаемого пула будет намного меньше ожидаемого значения. Это может быть причиной значительного падения производительности, зависаний системы и, в конечном счете, простоев в работе службы.

Примеры ожидаемых максимальных размеров выгружаемого пула (чем больше, тем лучше):

  • 240 MB — компьютер с 4 ГБ физической памяти, который не поддерживает функцию добавления памяти без выключения системы или на котором отключена эта функция;

  • 210 MB — компьютер с 4 ГБ физической памяти, который поддерживает до 32 ГБ памяти, добавляемой без выключения системы;

  • 160 MB — компьютер с 4 ГБ физической памяти, который поддерживает до 64 ГБ памяти, добавляемой без выключения системы.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы устранить эту проблему на компьютерах, на которых выполняется пакет обновления 1 (SP1) Windows Server 2003 или более поздняя версия

  1. Чтобы отключить функцию добавления памяти без выключения системы, установите следующий параметр реестра:

    Путь

    HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

    Значение

    DynamicMemory

    Тип

    REG_DWORD

    Значение

    0x1
    Примечание.
    Значение для этого параметра конфигурации выражается в виде количества, в гигабайтах, максимальной адресуемой физической памяти, включая память, добавляемую без выключения системы, если физическая память, установленная во время загрузки, не превышает это количество. При установке значения равного 1 ядро резервирует пространство для большего из двух значений: системной памяти объемом 1 ГБ или общего объема физической памяти, установленной во время загрузки.

  2. Перезапустите компьютер
Чтобы устранить эту проблему на компьютерах, на которых выполняется Windows Server 2003 без установленного пакета обновления 1 (SP1)

  • Свяжитесь с поставщиком оборудования, чтобы узнать, может ли функция добавления памяти без выключения системы отключаться в BIOS.

  • Если функция добавления памяти без выключения системы не может управляться аппаратными средствами, рекомендуется установить пакет обновления 1 (SP1) Windows Server 2003 и выполнить шаги, описываемые в этой статье, по установке параметра DynamicMemory. Если отсутствует возможность установки пакета обновления 1 (SP1), в альтернативном варианте действий можно установить параметр /NOPAE в файле Boot.ini. Если установить этот параметр, в компьютере принудительно отключается опознавание любой памяти, превышающей 4 ГБ. Используйте этот параметр на компьютерах под управлением Windows Server 2003 до установки пакета обновления 1 (SP1), однако этот параметр не следует использовать на компьютерах, на которых установлен пакет обновления 1 (SP1), так как он может ненамеренно отключать функции, включая поддержку функции предотвращения выполнения данных (Data Execution Prevention, DEP).

Дополнительные сведения

Дополнительные сведения о поддержке памяти, добавляемой без выключения системы, в Windows Server 2003 см. в ресурсах Windows Server 2003, посвященных поддержке памяти, добавляемой без выключения системы (http://go.microsoft.com/fwlink/?linkid=57183).


Программа Internet SCSI Initiator Software устарела
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2006-04-03

Средство анализатора сервера Microsoft® Exchange Server запрашивает WMI-класс Win32_SCSIController, чтобы определить ключ DriverName для драйвера iScsciPrt. Анализатор сервера Exchange Server также запрашивает WMI-класс CIM_Datafile чтобы определить значение ключа Version, указанного в файле драйвера iScsciPrt. Если анализатор сервера Exchange Server обнаружит, что значение подстроки в ключе Version драйвера iScsciPrt меньше 1748, отобразится соответствующее предупреждение

iSCSI представляет собой метод, основанный на протоколе IP, который разработан для пересылки команд SCSI, инкапсулированных в IP-пакеты, по сетям TCP/IP. Поскольку технология iSCSI основана на протоколе IP, данные могут передаваться по локальным сетям, глобальным сетям и по Интернету в удаленные хранилища. Операционные системы семейства Microsoft Windows отображают жесткие диски iSCSI программам, таким как Exchange Server 2003 или Exchange 2000 Server, в качестве жестких дисков, которые подключены напрямую к компьютеру Exchange Server.

Корпорация Майкрософт настоятельно рекомендует проявлять осторожность при развертывании Exchange Server 2003 или Exchange 2000 Server со iSCSI. В iSCSI применяется транспортный протокол SCSI для передачи данных по сетям TCP/IP, в таких сетях могут присутствовать компоненты, которые в обычных условиях не обеспечивают высокоскоростного ввода-вывода данных. Чтобы максимизировать пропускную способность, необходимо при настройке Exchange Server максимизировать кэширование операций, а также убедиться, что величина задержек в трафике iSCSI минимизирована. Также настоятельно рекомендуется (если только поставщик хранилища не указывает обратное) использовать последнюю доступную сборку Microsoft iSCSI Software Initiator.

Чтобы устранить причину появления этого предупреждения

  1. Загрузите последнюю версию Microsoft iSCSI Software Initiator с веб-узла центра загрузки Microsoft (http://go.microsoft.com/fwlink/?LinkId=33817).

  2. Ознакомьтесь с заметками о выпуске на веб-узле корпорации Майкрософт (http://go.microsoft.com/fwlink/?LinkId=40951).

  3. Ознакомьтесь с руководством пользователя на веб-узле корпорации Майкрософт (http://go.microsoft.com/fwlink/?LinkId=40963).

  4. Выполните полное архивирование компьютера.

  5. Примените последнее обновление версии.

Дополнительные сведения о поддержке iSCSI в Exchange 2000 Server и Exchange Server 2003 см. в статье базы знаний Майкрософт 839686, в которой описывается поддержка компонентов технологии iSCSI technology в Exchange Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839686).

Дополнительные сведения о технологии iSCSI и поддержке iSCSI в продуктах корпорации Майкрософт см. документ на веб-узле корпорации Майкрософт, посвященной данной теме (http://go.microsoft.com/fwlink/?LinkId=27514).


Счетчики производительности логических и физических дисков отключены
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить, отключены ли счетчики производительности логических и физических дисков:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Perfdisk\Performance\Disable Performance Counters

Если анализатор сервера Exchange обнаружит, что значение параметра Disable Performance Counters существует и ему присвоено значение 1, выводится предупреждение.

На сервере, работающем под управлением операционной системы Microsoft Windows®, публикуются счетчики производительности дисков двух типов:

  • используемые подсистемой контроля производительности Microsoft Win32® и инструментарием управления Windows (WMI);

  • используемые старыми приложениями, вызывающими API-интерфейс IOCTL_DISK_PERFORMANCE для получения показаний необработанных счетчиков.

  • Счетчики производительности, используемые в Win32 и WMI, включаются по умолчанию в системах Microsoft Windows Server™ 2003 и Windows 2000 Server. Необработанные счетчики в обеих операционных системах по умолчанию отключаются. Если параметр реестра Disable Performance Counters, по умолчанию отсутствующий в обеих операционных системах, добавлен и ему присвоено значение 1, счетчики производительности Win32/WMI отключаются, и сбор данных о производительности по этим счетчикам невозможен.

Проще всего отключить счетчики Win32/WMI с помощью программы «Список расширяемых счетчиков» (ExCtrLst.exe). Эта программа с графическим интерфейсом, включенная в наборы ресурсов для Windows 2000 Server и для Windows Server 2003, позволяет администратору выборочно включать и отключать публикацию счетчиков производительности. Когда программа ExCtrLst.exe используется для отключения объекта производительности, она добавляет в реестр элемент Disable Performance Counters и присваивает ему значение 1. Если затем ExCtrLst.exe используется для включения отключенного счетчика, она изменяет значение параметра Disable Performance Counters на 0. (Следует иметь в виду, что при этом элемент Disable Performance Counters не удаляется.)

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\SYSTEM\CurrentControlSet\Services\Perfdisk\Performance

  3. В правой области щелкните правой кнопкой мыши параметр Disable Performance Counters и присвойте ему значение 0. Можно также удалить элемент Disable Performance Counters, чтобы вновь включить счетчики.

  4. Закройте редактор реестра и перезапустите все приложения, собирающие данные о производительности, чтобы изменение вступило в силу.

Дополнительные сведения о программе ExCtrLst.exe см. в документе «Exctrlst.exe: Extensible Performance Counter List» (Exctrlst.exe: список расширяемых счетчиков производительности, http://go.microsoft.com/fwlink/?linkid=34436).


Обнаружено несколько шлюзов по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает класс инструментария Microsoft Windows® Management Instrumentation (WMI) Win32_NetworkAdapterConfiguration, чтобы определить количество экземпляров раздела DefaultIPGateway. С помощью этого раздела каждый сетевой адаптер публикует настроенный по умолчанию адрес шлюза в инструментарии WMI. Если анализатор сервера Exchange Server определяет, что имеется более одного настроенного экземпляра раздела DefaultIPGateway, на экран выводится предупреждение.

Это предупреждение указывает на то, чтоб обнаружено несколько сетевых адаптеров и что один из этих адаптеров содержит настроенный по умолчанию шлюз. Когда используется несколько адаптеров, которые настроены с отдельными шлюзами по умолчанию, может быть нарушено соединение с компьютерами или удаленными сетями. Кроме того, известно, что при использовании нескольких шлюзов по умолчанию, связанных с различными подсетями сети, возникают проблемы с разрешением службы доменных имен (DNS), доставкой сообщений SMTP, очередями протокола LDAP и отправкой новых почтовых уведомлений клиентам Microsoft Office Outlook® 2003. Многие из этих проблем могут воспрепятствовать запуску сервера Exchange или отправке и получению сообщений.

Рекомендуется удалить все, за исключением одного шлюза по умолчанию одного из сетевых адаптеров сервера Exchange. Серверы Exchange часто оснащают несколькими сетевыми адаптерами, когда на тот же компьютер устанавливают Microsoft Internet Security and Acceleration (ISA) Server. Даже в случае, когда на том же компьютере работает Exchange Server and ISA Server, не рекомендуется использовать несколько шлюзов по умолчанию. Если сервер Exchange и ISA Server не установлены на одном и том же компьютере, не рекомендуется использовать сервер Exchange с несколькими сетевыми платами.

Чтобы устранить причину появления этого предупреждения

  1. Откройте окно «Сетевые подключения». Щелкните правой кнопкой мыши значок Сетевое окружение и затем щелкните Свойства, или если значок "Сетевое окружение" не отображается на рабочем столе, нажмите кнопку Пуск, последовательно выберите Программы, Стандартные, Связь и затем Сетевые подключения.

  2. В окне "Сетевые подключения" щелкните правой кнопкой мыши сетевое подключение, содержащее запись о шлюзе по умолчанию, которую предполагается удалить, и щелкните пункт Свойства.

  3. Выберите Интернет-протокол (TCP/IP), а затем нажмите кнопку Свойства.

  4. Удалите IP-адрес из поля Шлюз по умолчанию.

  5. Дважды нажмите кнопку ОК, чтобы сохранить изменения.

  6. Повторите эту процедуру для всех сетевых подключений, содержащих записи о шлюзе по умолчанию, за исключением одной записи, которую предполагается оставить.

Дополнительные сведения о проблемах, возникающих на компьютерах, оснащенных несколькими шлюзами по умолчанию, см. в базе знаний Майкрософт в статье 159168, "Multiple Default Gateways Can Cause Connectivity Problems" (Несколько шлюзов по умолчанию могут вызвать неполадки в подключениях) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159168).

Дополнительные сведения о настройке шлюзов по умолчанию на компьютерах с несколькими сетевыми платами см. в базе знаний Майкрософт в статье 157025, "Default Gateway Configuration for Multihomed Computers" (Конфигурация шлюзов по умолчанию для компьютеров с несколькими сетевыми платами) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=157025).


Размер файла подкачки превышает объем физической памяти
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2007-07-30

Анализатор Microsoft Exchange запрашивает класс инструментария управления Windows (WMI) Win32_PageFile, чтобы определить значение параметра MaximumSize, который представляет заданный в текущий момент максимальный размер файла подкачки.

Кроме того, анализатор Exchange запрашивает класс WMI Win32_ComputerSystem, чтобы определить значение параметра TotalPhysicalMemory, который представляет объем установленной на компьютере оперативной памяти.

Если анализатор Exchange выясняет, что значение параметра Win32_PageFile MaximumSize более чем в полтора раза превышает значение Win32_ComputerSystem TotalPhysicalMemory, выводится сообщение об ошибке.

Файл подкачки (pagefile.sys) — это скрытый файл на жестком диске, используемый системой Windows для хранения временных данных при недостатке оперативной памяти. Файл подкачки также называют файлом виртуальной памяти. Виртуальная память состоит из файла подкачки и оперативной памяти.

Размер файла подкачки рекомендуется настраивать так, чтобы он в 1,05 раза превышал объем оперативной памяти, при этом максимальный размер файла подкачки для конкретного тома диска может составлять 4095 МБ.

Примечание.
Для предотвращения фрагментации файла подкачки рекомендуется задавать в качестве его исходного и максимального размеров одинаковые значения. При уменьшении исходного или максимального размера файла подкачки изменения вступают в силу только после перезапуска компьютера. При увеличении какого-либо из этих параметров перезапускать компьютер обычно не требуется.
Изменение параметров файла подкачки

  1. Нажмите кнопку Пуск, выберите пункт Панель управления и щелкните значок Система.

  2. Откройте вкладку Дополнительно и в разделе Быстродействие нажмите кнопку Параметры.

  3. В диалоговом окне Параметры быстродействия откройте вкладку Дополнительно и в разделе Виртуальная память нажмите кнопку Изменить.

  4. В списке Диск [метка тома] щелкните диск, содержащий файл подкачки, параметры которого требуется изменить.

  5. В разделе Размер файла подкачки для выбранного диска выберите пункт Особый размер, укажите рекомендованные размеры файла подкачки в мегабайтах в полях Исходный размер (МБ) и Максимальный размер (МБ) и нажмите кнопку Задать.

Дополнительные сведения о файлах подкачки см. в следующих статьях базы знаний Майкрософт:

  • 197379, «Настройка файлов подкачки для оптимизации и восстановления в Windows Server 2003, Windows 2000 и Windows NT» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379)

  • 307973, «Настройка параметров обработки сбоев и восстановления системы в Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307973)

  • 254649, «Описание параметров создания дампа памяти для Windows 2000, Windows XP и Windows Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=254649)

  • 241046, «Файл Memory.dmp невозможно создать на компьютерах, имеющих более 4 ГБ оперативной памяти» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=241046) (на английском языке)


Пустой адрес вторичного сервера WINS
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_NetworkAdapterConfiguration, чтобы определить, установлено ли значение для ключа WINSSecondaryServer. Если значение этого ключа на сервере Exchange пустое, на экран выводится предупреждение.

Приложения Exchange Server 2003 и Exchange 2000 Server имеют несколько зависимостей от NetBIOS. Кроме того, для клиентов, на которых выполняются версии Microsoft Outlook®, предшествующие Microsoft Office Outlook 2003, также требуется разрешение имен NetBIOS. Например, от разрешения имен NetBIOS зависят следующие функциональные возможности Exchange:

  • Программы установки Exchange Server 2003 и Exchange 2000 Server, особенно на кластерных серверах.

  • Мастер слияния почтовых ящиков (ExMerge) на компьютерах Exchange Server 2003 и Exchange 2000 Server.

  • Изменение пароля для почтового ящика Exchange Server 2003 или Exchange 2000 Server с помощью веб-клиента Outlook.

  • Системный диспетчер Exchange на компьютерах Exchange Server 2003 и Exchange 2000 Server.

В зависимости от топологии сети организации можно благополучно игнорировать это предупреждение. В сетях, состоящих из единственной подсети NetBIOS, широковещательные рассылки обычно способны выполнять требования по разрешению имен NetBIOS для развертывания Exchange.

В больших организациях разрешение имен NetBIOS через широковещательные рассылки может функционировать некорректно. Так как широковещательные рассылки NetBIOS обычно не пересекают подсети, для сетей с маршрутизацией требуется альтернативный метод разрешения имен NetBIOS. Предпочтительный метод для выполнения этой задачи — служба WINS (Windows Internet Name Service). Служба WINS предоставляет распределенную базу данных для регистрации и запроса динамических сопоставлений имен NetBIOS компьютеров и групп, используемых в конкретной сети. Служба WINS сопоставляет имена NetBIOS с IP-адресами и предназначена для устранения проблем, возникающих из-за разрешения имен NetBIOS в средах с маршрутизацией. Служба WINS является наилучшим выбором для разрешения имен NetBIOS в сетях с маршрутизацией, которые используют NetBIOS через TCP/IP.

Операции и функции Exchange Server 2003 и Exchange 2000 Server не протестированы в полном объеме для больших организаций и организаций с подсетями, которые не используют службу WINS. Согласно требованиям корпорации Майкрософт в компаниях, работающих с Exchange в сетях с маршрутизацией и сегментированных сетях, необходимо использовать службу WINS для разрешения имен NetBIOS. Работа Exchange в среде с маршрутизацией или подсетями без применения службы WINS не поддерживается.

Рекомендуется развертывать отказоустойчивую среду WINS, содержащую, по крайней мере, два сервера WINS. Серверы WINS могут действовать в отношении клиента как основной сервер WINS или как вторичный сервер WINS. Различие между основным и вторичным серверами WINS состоит в приоритете, согласно которому клиенты обращаются к ним. Основной сервер WINS является первым сервером, к которому обращается клиент для выполнения своих операций службы имен NetBIOS. Клиент обращается к вторичному серверу WINS только тогда, когда основной сервер WINS не может выполнить запрос, например, если он недоступен, когда клиент делает запрос, или если он не может разрешить имя для клиента.

Если основной сервер WINS не выполнил запрос, клиент посылает тот же самый запрос на вторичный сервер WINS. Если для клиента настроено более двух серверов WINS, клиент предпринимает попытку запроса дополнительных вторичных серверов WINS до тех пор, пока не будет исчерпан список или пока один из серверов WINS не ответит успешно на запрос. После использования клиентом вторичного сервера WINS он периодически пытается переключиться обратно на основной сервер WINS для получения ответов на последующие запросы службы имен.

Рекомендуется настроить хотя бы один вторичный сервер WINS на компьютерах серверов Exchange в сети с маршрутизацией или подсетями.

Чтобы устранить причину появления этого предупреждения

  1. Откройте компонент «Сетевые подключения».

  2. Щелкните правой кнопкой мыши настраиваемое подключение и в контекстном меню выберите Свойства.

  3. На вкладке Общие (для подключения к локальной сети) или на вкладке Сеть (для всех остальных подключений) щелкните Протокол Интернета (TCP/IP), а затем щелкните Свойства.

  4. Щелкните Дополнительно, откройте вкладку WINS, а затем щелкните Добавить.

  5. В поле WINS-сервер TCP/IP введите IP-адрес вторичного сервера WINS и щелкните Добавить.

  6. Повторите шаги 4 и 5 для IP-адреса каждого дополнительного сервера WINS, а затем нажмите кнопку OK. Порядок предпочтения серверов WINS можно изменить, используя клавиши со стрелками.

  7. Проверьте, чтобы был установлен флажок Включить NetBIOS через TCP/IP.

  8. Нажмите кнопку ОК, чтобы сохранить изменения.

Дополнительные сведения о требованиях по разрешению имен NetBIOS для приложения Exchange см. в базе знаний Майкрософт в статье 837391, описывающей необходимость разрешения имен NetBIOS для поддержки всех функций Exchange Server 2003 и Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=837391).


Сервер является виртуальным ПК
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2007-03-28

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_ComputerSystem, чтобы определить значение ключа Model для компьютера сервера Exchange. Если значение этого ключа содержит строку «Virtual Machine», выводится сообщение об ошибке.

Наличие строки Virtual Machine показывает, что компьютер сервера Exchange работает на виртуальном компьютере Microsoft Virtual PC 200x. Virtual PC 200x — это программное обеспечение для виртуализации, позволяющее выполнять на одной рабочей станции одновременно несколько операционных систем для ПК. Корпорация Майкрософт не поддерживает выполнение никаких версий сервера Microsoft Exchange на виртуальном компьютере или эмуляторе. Это относится к серверам Exchange Server, работающим под управлением Microsoft Virtual Server 200x, Microsoft Virtual PC 200x или любых программ для виртуальных машин сторонних производителей. Платформы Microsoft Exchange Server разработаны и протестированы для запуска только на физическом оборудовании, в частности, на платформах, перечисленных в каталоге Windows Server (http://go.microsoft.com/fwlink/?linkid=17219).

Устранение ошибки

  1. Переместите почтовые ящики с сервера Exchange Server, работающего под управлением Virtual PC 200x, на невиртуальный компьютер с сервером Exchange Server.

  2. При необходимости переместите на физический компьютер все общедоступные папки и перенесите все роли, размещенные на виртуальном сервере Exchange .

  3. Для списания удалите Exchange с виртуального компьютера, из своей инфраструктуры Exchange и из службы каталогов Active Directory®.

Дополнительные сведения о поддержке компьютеров с сервером Exchange Server, работающих в виртуальных средах, см. в статье 320220 базы знаний Майкрософт «Политика поддержки Exchange Server 2003 под управлением программного обеспечения виртуализации» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320220) (на английском языке).

Дополнительные сведения о Microsoft Virtual PC см. на начальной странице Microsoft Virtual PC (http://go.microsoft.com/fwlink/?linkid=34663) (на английском языке).


Ошибка на диске
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_DiskDrive, чтобы определить значение ключа Status для каждого диска. Если анализатор сервера Exchange обнаруживает, что значение ключа Status какого-либо диска отлично от OK, выводится сообщение об ошибке.

Ключ Status определяет текущее состояние объекта диска. Можно определять различные операционные и неоперационные состояния. К операционным состояниям относятся:

  • OK

  • Degraded

  • Pred Fail (элемент, такой как жесткий диск с поддержкой SMART, может функционировать нормально, но при этом прогнозировать отказ в ближайшем будущем).

  • К неоперационным состояниям относятся:

  • Error

  • Starting

  • Stopping

  • Service (может иметь место при создании/восстановлении зеркальной копии диска, перезагрузке списка разрешений пользователя или выполнении других административных задач).

Ключ Status наследуется из WMI-класса CIM_ManagedSystemElement, который содержит следующие значения:

  • OK

  • Error

  • Degraded

  • Unknown

  • Pred Fail

  • Starting

  • Stopping

  • Service

  • Stressed

  • NonRecover

  • No Contact

  • Lost Comm

Обычно Майкрософт не предоставляет документацию по устранению неисправностей дисков конкретных производителей.

Чтобы устранить эту ошибку

  1. Проверьте все соединения диска с кабелями, подождите 10 минут и затем проверьте значение ключа Status.

  2. Если возвращается значение, не соответствующее режиму обслуживания (например значение, отличное от Service), следуйте инструкциям по устранению неисправностей жесткого диска, рекомендованным его изготовителем. В некоторых случаях изготовитель диска предоставляет программное обеспечение устранения неисправностей, которое можно установить и использовать для анализа проблемы.

Общие сведения о средствах хранения данных в Exchange см. в статье «Storage Solutions for Microsoft Exchange 2000 Server» (Решения хранения данных для сервера Microsoft Exchange 2000) в центре загрузки Майкрософт (http://go.microsoft.com/fwlink/?LinkId=1715).

Общие сведения о средствах хранения данных в Microsoft Windows Server™ 2003 см. в статье «Windows Server 2003 Storage Services» (Службы хранения данных Windows Server 2003) в техническом центре Microsoft Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=33811).

Общие сведения о средствах хранения данных в Windows 2000 Server см. в статье «Windows 2000 Storage Services» (Службы хранения данных Windows 2000) на веб-узле Windows 2000 (http://go.microsoft.com/fwlink/?LinkId=33812).


Данный сервер Exchange имеет более 8 процессоров
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_ComputerSystem, чтобы определить текущее значение раздела NumberOfProcessors. Если анализатор сервера Exchange обнаружит, что значение NumberOfProcessors больше 8, на экран будет выведено предупреждение. Однако если данный сервер настроен на использование технологии многопоточности, это предупреждение можно без всякого риска проигнорировать. Технология многопоточности предоставляет приложениям с поддержкой многопоточности возможность параллельного запуска нескольких потоков. Для использования технологии многопоточности требуется компьютерная система с процессором Intel Pentium 4, поддерживающим технологию многопоточности, а также набор микросхем, BIOS и операционная система, которые поддерживают технологию многопоточности.

Приложения Exchange 2000 Server и Exchange Server 2003 могут эффективно использовать на компьютере только восемь процессоров. В частности, служба банка данных Microsoft Exchange оптимизирована максимум для восьми процессоров.

На компьютерах, имеющих больше восьми процессоров, рекомендуется использовать разделение оборудования для разделения компьютера на несколько восьмипроцессорных компьютеров или на несколько четырехпроцессорных компьютеров. Или можно настроить родство процессоров для процесса (Store.exe) «Банк данных Microsoft Exchange», ограничившись только восемью процессорами.

После того как процесс «Банк данных Microsoft Exchange» ограничен восемью процессорами с помощью родства процессоров или путем разделения оборудования, рекомендуется установить последнюю доступную версию пакета обновления и сборки обновлений Exchange. Это особенно важно, если на компьютере выполняется Exchange Server 2003.

Ранее производительность сервера Exchange достигала предельных значений, когда число процессоров на фоновых серверах увеличивалось и превышало четыре. При количестве процессоров более восьми производительность в лучшем случае достигала предельного значения и иногда производительность могла уменьшиться. Падение производительности с добавлением процессоров стало более заметным для типов процессоров, используемых на современных компьютерах. Для Exchange Server 2003 с пакетом обновления 1 (SP1) масштабируемость путем добавления процессоров намного улучшилась. Теперь если многопоточность включена, восьмипроцессорные серверы обладают на 50 процентов большей производительностью, чем четырехпроцессорные серверы. Сейчас использование восьмипроцессорных компьютеров в качестве фоновых серверов целесообразно во многих сценариях. Для серверов переднего плана по-прежнему рекомендуется использовать двухпроцессорные компьютеры.

Как упоминалось ранее, если данный компьютер сервера Exchange использует технологию многопоточности, данное предупреждение можно без всякого риска проигнорировать.

Чтобы устранить причины появления этого предупреждения на системах, не использующих технологию многопоточности

  1. Установите новейший пакет обновления и сборки обновлений для Exchange, доступные на веб-узле загружаемых ресурсов для Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=25097).

  2. Установите родство процессоров для службы (Store.exe) «Банк данных Microsoft Exchange» равным восьми процессорам или используйте разделение аппаратного обеспечения для создания четырехпроцессорного сервера Exchange. Свяжитесь с изготовителем оборудования, чтобы узнать, как это сделать.

Дополнительные сведения о масштабируемости ресурсов сервера Exchange см. в базе знаний Майкросфот в статье 827281, описывающей масштабируемость процессоров и памяти для приложений Exchange 2000 и Exchange 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827281).

Дополнительные сведения см. также в базе знаний в статье 271088, описывающей оптимизацию шести- или восьмипроцессорных серверов Active Directory под управлением Windows 2000 для работы с Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=271088).

Дополнительные сведения о технологии многопоточности см. на веб-узле компании Intel (http://www.intel.com/info/hyperthreading).

Примечание.
Веб-адреса могут измениться, поэтому существует вероятность, что указанные веб-узлы будут недоступны.


На данный сервер Exchange установлена память объемом более 4 ГБ
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2006-06-20

Средство анализатора сервера Microsoft® Exchange запрашивает класс инструментария WMI Win32_ComputerSystem, чтобы определить значение раздела TotalPhysicalMemory для каждого сервера Exchange.

Если анализатор сервера Exchange находит, что значение раздела TotalPhysicalMemory6 больше 4294967296, но меньше 6442450944, на экран выводится предупреждение.

Если анализатор сервера Exchange обнаруживает, что значение раздела TotalPhysicalMemory больше 6442450944, на экран выводится сообщение об ошибке.

Если значение раздела TotalPhysicalMemory больше 4294967296, это указывает на то, что на сервер Exchange установлена память объемом более 4 ГБ, а если значение раздела TotalPhysicalMemory больше 6442450944, это указывает на то, что на сервер Exchange установлена память объемом более 6 ГБ. На компьютере с физической памятью объемом больше 4 ГБ сервер Server использует не более 3 ГБ. Следовательно, если компьютер предназначен для работы на нем только сервера Exchange, нецелесообразно устанавливать на него память объемом более 4 ГБ.

Более важно то, что чем больше объем установленного ОЗУ, тем больше требуется адресов для ядра операционной системы, чтобы выполнять необходимое отображение виртуальных параметров в физические. При этом уменьшаются и объем свободных системных элементов таблицы страниц (PTE), и память выгружаемого пула, доступные для системы, что может привести к нестабильности.

Для примера: на компьютере с физическим ОЗУ объемом 8 ГБ свободных системных элементов таблицы страниц будет меньше на 3000 и на 30 МБ будет уменьшен наибольший размер выгружаемого пула, чем на компьютере, на котором установлено физическое ОЗУ объемом только в 4 ГБ.

Рекомендуется следовать одному из следующих двух решений:

  • Уменьшить объем памяти в системе до 4 ГБ

  • Настроить параметр BurnMemory в файле Boot.ini так, чтобы уменьшить объем физической памяти до 4 ГБ, как это описано далее в данной статье.

Кроме того, если выполняется несколько приложений, требующих дополнительной памяти, можно запустить исправление Windows, предотвращающее сбои банка данных Exchange, которые могут возникнуть при наличии ОЗУ объемом более 4 GB. Заметьте, что рекомендуется, чтобы на компьютере работал только сервер Exchange. Подробнее об исправлении см. в базе знаний Майкрософт статью 834628 "Data is corrupted when PAE is enabled on a Windows Server 2003-based computer" (Данные повреждаются, если на компьютере, работающем под управлением Windows Server 2003, включено расширение PAE) (http://go.microsoft.com/fwlink/?linkid=3052).

Чтобы устранить причину появления этого предупреждения

  1. В проводнике Windows перейдите к системному разделу.

  2. Если файл boot.ini не виден, возможно, в свойствах папки установлен флажок Скрывать защищенные системные файлы. Если это так, в проводнике Windows последовательно щелкните Сервис, Свойства папки, а затем откройте вкладкуВид. Снимите флажок Скрывать защищенные системные файлы (рекомендуется). Когда появится окно предупреждения, нажмите Да.

  3. Если файл boot.ini виден в проводнике Windows, щелкните правой кнопкой мыши этот файл, выберите в контекстном меню команду Открыть с помощью и щелкните Блокнот, чтобы открыть файл.

  4. В части [Operating Systems] (операционные системы) добавьте в строку загрузки следующий переключатель: /BURNMEMORY=<Значение в мегабайтах>

    Например:

    Если установлено 6 ГБ физической памяти, используйте /BURNMEMORY=2048, чтобы уменьшить доступную память до 4 ГБ. Если установлено 8 ГБ физической памяти, используйте /BURNMEMORY=4096.

  5. Сохраните изменения и закройте блокнот.

  6. Перезагрузите сервер Exchange, чтобы изменение вступило в силу.

Дополнительные сведения о параметрах, которые могут использоваться в файле Boot.ini см. в следующих статьях базы знаний Майкрософт:

  • 833721: "Available switch options for the Windows XP and Windows Server 2003 Boot.ini files" (Доступные опции переключателя для файлов Boot.ini операционных систем Windows XP и Windows Server 2003) (http://go.microsoft.com/fwlink/?linkid=3052)

  • 102873: "BOOT.INI and ARC Path Naming Conventions and Usage" (BOOT.INI и соглашения об именовании путей в формате ARC и их использование) (http://go.microsoft.com/fwlink/?linkid=3052)


Доступное пространство на логическом диске меньше 3 ГБ
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2007-03-14

Анализатор сервера Exchange также опрашивает WMI-класс Win32_LogicalDisk, чтобы определить значение раздела FreeSpace для дисков, раздел реестра Win32_LogicalDisk DriveType для которых равен 3 (указывает на то, что диск является логическим). Если значение раздела FreeSpace для локального диска на компьютере сервера Exchange меньше 3 ГБ, будет отображено предупреждение. Рекомендуется постоянно оставлять хотя бы 50 процентов свободного пространства для всех дисков на компьютерах серверов Exchange, которые содержат почтовые ящики.

Наличие достаточного места на диске критически важно. Когда на диске с базой данных заканчивается свободное место, база данных переходит в автономный режим. Когда свободное место заканчивается на диске с журналами транзакций, все базы данных в группе хранения переходят в автономный режим. Быстро предоставить дополнительное свободное место зачастую трудно, а автономное сжатие данных для высвобождения места на диске может занять продолжительное время. В большинстве случаев недостаток свободного места на диске приводит к недоступности одной или нескольких баз данных на время, которое, как правило, превышает запланированное время восстановления.

Чтобы устранить причину появления этого предупреждения

  1. Удалите ненужные файлы с этого диска, чтобы освободить дисковое пространство.

  2. Если на диске, где осталось менее 50 процентов свободного пространства, содержатся данные, которые можно безопасно переместить на другой диск (например, почтовые ящики или файл подкачки Windows), выполните шаги, требуемые для перемещения данных.

  3. Установите дополнительные диски на компьютер сервера Exchange.

Дополнительные сведения о перемещении почтовых ящиков в Exchange Server 2003 см. в статье 821829 базы знаний Майкрософт «Перемещение почтовых ящиков в системе Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

Дополнительные сведения о перемещении почтовых ящиков между серверами Exchange 2000 Server и Exchange Server 5.5 см. в статье 328810 базы знаний Майкрософт, описывающей перемещение почтовых ящиков между серверами (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810).

Дополнительные сведения о настройке ограничений для хранения почтовых ящиков см. в статье 822938 базы знаний Майкрософт в статье, посвященной инструкциям по настройке ограничений для хранения почтовых ящиков в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822938);

Дополнительные сведения о настройке ограничений для почтовых ящиков с помощью системной политики см. в статье 319130 базы знаний, посвященной использованию системных политик для настройки ограничений для хранения почтовых ящиков в Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319130).

Дополнительные сведения


В точке подключения доступно менее 3 ГБ свободного места
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Volume, чтобы определить значение ключа FreeSpace для точек подключения тома, используемых компьютером на базе Exchange Server. Если значение FreeSpace, разделенное на 1 000 000 000 и округленное до ближайшего целого числа, оказывается меньше 4, на экран выводится предупреждение.

Это предупреждение указывает, что в точке подключения тома менее 3 ГБ свободного места. В среде Exchange Server 2003 точки подключения тома (также называемые точками соединения файловой системы NTFS) поддерживаются для размещения хранилищ данных в кластерной конфигурации, когда Exchange Server 2003 установлен на компьютере под управлением Microsoft Windows Server™ 2003 Enterprise Edition или Windows Server 2003 Datacenter Edition. Точки подключения тома NTFS позволяют обходить ограничение на 26-знаковое имя диска. С помощью точек подключения томов можно присоединять или подключать конечный раздел к папке на другом физическом диске. Точки подключения томов прозрачны для программ, включая Exchange Server 2003.

Точки подключения не поддерживаются в следующих сценариях:

  • Когда они используются для размещения хранилища двоичных файлов Exchange Server 2003.

  • Когда они используются с кластерами Exchange, работающими под управлением Microsoft Exchange 2000 Server или более ранней версии.

  • Когда они используются с кластерами Windows, работающими под управлением Microsoft Exchange 2000 Server или более ранней версии.

Независимо от того, является ли том, используемый Exchange Server, локальным физическим диском, логическим томом или точкой подключения тома, в среде Exchange Server рекомендуется оставлять свободным не мене 50% места на всех дисках. В общем случае корпорация Майкрософт рекомендует оставлять свободным не менее 25-30% дискового пространства для проведения операций обслуживания Exchange, выполняемых, например, с помощью таких служебных программ баз данных, как Eseutil и Isinteg. Кроме того, для проведения таких операций обслуживания, как автономная дефрагментация, корпорация Майкрософт рекомендует оставлять свободным на 100% больше места, чем требуется дефрагментировать. Например, при дефрагментации базы данных объемом 1 ГБ желательно, чтобы на диске было не менее 1 ГБ свободного места.

Наличие большого объема свободного дискового пространства также целесообразно с точки зрения безопасности и доступности. Атака с отказом в обслуживании, замкнутый цикл обработки сообщения или распространение вируса может привести к повышенному использованию дискового пространства из-за увеличения трафика сообщений, активности журнала транзакций и т. д.

Чтобы устранить причину появления этого предупреждения

  1. Оцените возможности очистки диска и увеличьте объем свободного места.

  2. Если места на диске очень мало, рассмотрите возможность переноса данных на другой компьютер с Exchange Server или на виртуальный сервер Exchange с достаточным объемом свободного места. Установка пределов на объем почтового ящика также помогает управлять использованием дискового пространства.

Дополнительные сведения об использовании точек подключения томов в кластере Exchange Server 2003 см. в статье 318458 базы знаний Майкрософт, посвященной поддержке точек подключения томом для кластера Exchange Server 2003 в системах на базе Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=318458).

Дополнительные сведения о использовании точек подключения томов в кластере Windows Server 2003 см. в статье 280297 базы знаний Майкрософт, посвященной настройке точек подключения томов на сервере кластера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=280297).


Для сетевого адаптера включена поддержка DHCP
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_NetworkAdapterConfiguration, чтобы определить, установлено ли значение для свойства DHCPEnabled. Если на сервере Exchange для этого свойства задано значение 1, выводится сообщение об ошибке.

Выполнение Exchange на сетевом адаптере с включенной поддержкой DHCP является поддерживаемой конфигурацией. Однако использовать такую конфигурацию не рекомендуется. Выполнение Exchange на компьютерах с включенной поддержкой DHCP нежелательно, поскольку сбой или прерывание службы DHCP может привести к прекращению доставки почты или вызвать другую неполадку в Exchange.

Рекомендуется настроить все компьютеры с Exchange для использования статических IP-адресов.

Дополнительные сведения о проектировании сетей Windows TCP/IP см. на веб-узле Microsoft TechNet, посвященным сетям (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=33819).


Пустой адрес основного сервера WINS
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_NetworkAdapterConfiguration, чтобы определить, установлено ли значение для ключа WINSPrimaryServer. Если анализатор сервера Exchange обнаруживает, что этот ключ на сервере Exchange не имеет значения, выводится предупреждение.

Приложения Exchange Server 2003 и Exchange 2000 Server имеют несколько зависимостей от NetBIOS. Кроме того, для клиентов, на которых выполняются более ранние версии Microsoft Outlook®, чем Microsoft Office Outlook 2003, также требуется разрешение имен NetBIOS. Например, от разрешения имен NetBIOS зависят следующие функциональные возможности Exchange:

  • Программы установки Exchange Server 2003 и Exchange 2000 Server, особенно на кластерных серверах.

  • Мастер слияния почтовых ящиков (ExMerge) на компьютерах Exchange Server 2003 и Exchange 2000 Server.

  • Изменение пароля для почтового ящика Exchange Server 2003 или Exchange 2000 Server с помощью веб-доступа Outlook.

  • Диспетчер Exchange на компьютерах Exchange Server 2003 и Exchange 2000 Server.

В зависимости от топологии сети организации можно благополучно игнорировать это предупреждение. В сетях, состоящих из единственной подсети, широковещательные рассылки NetBIOS обычно способны обрабатывать требования по разрешению имен NetBIOS для развертывания Exchange.

В больших организациях разрешение имен NetBIOS через широковещательные рассылки может функционировать некорректно. Так как широковещательные рассылки NetBIOS обычно обычно выполняются в рамках одной подсети, для сетей с маршрутизацией требуется альтернативный метод разрешения имен NetBIOS. Рекомендуемый способ выполнения этой задачи — служба WINS (Windows Internet Name Service). Служба WINS предоставляет распределенную базу данных для регистрации и запроса динамических сопоставлений имен NetBIOS компьютеров и групп, используемых в конкретной сети. Служба WINS сопоставляет имена NetBIOS с IP-адресами и предназначена для устранения проблем, связанных с разрешением имен NetBIOS в средах с маршрутизацией. Служба WINS является наилучшим выбором для разрешения имен NetBIOS в сетях с маршрутизацией, которые используют NetBIOS через TCP/IP.

Операции и функции Exchange Server 2003 и Exchange 2000 Server не протестированы в полном объеме для больших организаций и организаций с разделением на подсети, где не используется служба WINS. Согласно требованиям корпорации Майкрософт в компаниях, работающих с Exchange в сетях с маршрутизацией и сегментированных сетях, необходимо использовать службу WINS для разрешения имен NetBIOS. Работа Exchange в среде с маршрутизацией или подсетями без применения службы WINS не поддерживается.

Рекомендуется развертывать отказоустойчивую среду WINS, содержащую, по крайней мере, два сервера WINS. Серверы WINS могут действовать в отношении клиента как основной сервер WINS или как вторичный сервер WINS. Различие между основным и вторичным серверами WINS состоит в приоритете, согласно которому клиенты обращаются к ним. Основной сервер WINS является первым сервером, к которому обращается клиент для выполнения своих операций службы имен NetBIOS. Клиент обращается к вторичному серверу WINS только тогда, когда основной сервер WINS не может выполнить запрос, например если он недоступен, когда клиент направляет запрос, или если он не может разрешить имя для данного клиента.

Если основной сервер WINS не выполнил запрос, клиент посылает тот же самый запрос на вторичный сервер WINS. Если для клиента настроено более двух серверов WINS, клиент предпринимает попытку запроса дополнительных вторичных серверов WINS до тех пор, пока не будет исчерпан список или пока один из серверов WINS не даст ответ на запрос. После использования клиентом вторичного сервера WINS он периодически пытается переключиться обратно на основной сервер WINS для получения ответов на последующие запросы службы имен.

Рекомендуется настроить хотя бы один вторичный сервер WINS на компьютерах серверов Exchange в сети с маршрутизацией или подсетями.

Чтобы устранить причину появления этого предупреждения

  1. Откройте компонент «Сетевые подключения».

  2. Щелкните правой кнопкой мыши настраиваемое подключение и в контекстном меню выберите Свойства.

  3. На вкладке Общие (для подключения к локальной сети) или на вкладке Сеть (для всех остальных подключений) щелкните Протокол Интернета (TCP/IP), а затем щелкните Свойства.

  4. Щелкните Дополнительно, откройте вкладку WINS, а затем щелкните Добавить.

  5. В поле WINS-сервер TCP/IP введите IP-адрес вторичного сервера WINS и нажмите кнопку Добавить.

  6. Повторите шаги 4 и 5 для IP-адреса каждого дополнительного сервера WINS, а затем нажмите кнопку ОК. Порядок выбора серверов WINS можно изменить, используя клавиши со стрелками.

  7. Убедитесь, что установлен флажок Включить NetBIOS через TCP/IP.

  8. Нажмите кнопку ОК, чтобы сохранить изменения.

Дополнительные сведения о требованиях по разрешению имен NetBIOS для приложения Exchange см. в статье 837391 базы знаний Майкрософт «Exchange Server 2003 and Exchange 2000 Server require NetBIOS name resolution for full functionality» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=837391) (Для полнофункциональной работы Exchange Server 2003 и Exchange 2000 Server требуется разрешение имен NetBIOS).


Обнаружен виртуальный сервер
Анализатор сервера Microsoft Exchange — статьи > Оборудование >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_ComputerSystem, чтобы определить, установлено ли для ключа Model значение Virtual Machine.

Кроме того, анализатор сервера Exchange поверяет наличие следующей записи реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

Если анализатор сервера Exchange обнаружит, что ключ Model содержит строковое значение Virtual Machine, и указанная выше запись реестра существует, на экран будет выведено сообщение об ошибке.

Значение Virtual Machine в ключе Model указывает, что данный компьютер сервера Exchange работает как виртуальная машина с правами гостя под управлением Microsoft Virtual Server 2005 или Microsoft Virtual PC 2004. Поскольку вышеуказанный раздел реестра создается только сервером Virtual Server 2005, его наличие означает, что данный компьютер сервера Exchange работает в качестве виртуальной машины с правами гостя на сервере Virtual Server 2005.

Корпорация Майкрософт не поддерживает работу ни одной версии Microsoft Exchange Server на виртуальной машине или под управлением эмулятора. Это правило распространяется на работу сервера Exchange Server под управлением Microsoft Virtual Server 2005, Microsoft Virtual PC 2004 или любой другой программы виртуальной машины сторонней разработки. Платформы Microsoft Exchange Server предназначены для работы только на физическом оборудовании (и протестированы исходя из этого принципа), в частности, для работы с аппаратными платформами, включенными в каталог серверов Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=17219).

Чтобы устранить эту ошибку

  1. Переместите почтовые ящики с сервера Exchange, работающего в Virtual Server 2005, на невиртуальный компьютер сервера Exchange.

  2. При необходимости переместите общие папки и перенесите роли, выполняемые данным виртуальным сервером Exchange.

  3. Удалите Exchange с виртуального компьютера, чтобы списать и удалить его из инфраструктуры Exchange и из службы каталогов Active Directory®.

Дополнительные сведения о перемещении почтовых ящиков см. в следующих статьях базы знаний Майкрософт:

  • статья 822892, описывающая улучшения, касающиеся перемещения почтовых ящиков в Exchange 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892);

  • статья 224975, посвященная различиям между методами перемещения почтовых ящиков (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975).

Дополнительные сведения о Microsoft Virtual Server 2005 см. на веб-узле Microsoft Virtual Server 2005 (http://go.microsoft.com/fwlink/?LinkId=34938).

Дополнительные сведения о Microsoft Virtual PC 2004 см. на веб-узле Microsoft Virtual PC 2004 (http://go.microsoft.com/fwlink/?linkid=34663).


Сеть
Анализатор сервера Microsoft Exchange — статьи >

Дата последнего изменения раздела: 2005-11-18

В статьях этого раздела приводятся подробные сведения о том, какую относящуюся к сети информацию предоставляет средство анализатора сервера Microsoft® Exchange. Кроме того, в этих статьях указывается, какие следует предпринять действия в связи с полученной от анализатора сервера Exchange информацией об относящихся к работе сети ошибках, предупреждениях и отличающихся от заданных по умолчанию конфигураций.


Запись DNS узла, возможно, отсутствует
Анализатор сервера Microsoft Exchange — статьи > Сеть >

Дата последнего изменения раздела: 2006-04-13

Анализатор сервера Microsoft® Exchange выполняет просмотр службы имен доменов (DNS) для извлечения записи (A) узла сервера Exchange. Если операция запроса DNS не возвращает IP-адрес, анализатор сервера Exchange выводит предупреждение, что запись (A) узла, возможно, отсутствует.

Запрос в DNS записи (A) узла с компьютера Exchange Server 2003 может быть неудачным по следующим причинам:

  • DNS-сервер выключен или не отвечает из-за отказа сети или по другим причинам.

  • Запись (A) узла для Exchange Server 2003 может отсутствовать на DNS-сервере, так как запись, возможно, не доступна, неправильна или на DNS-сервер может быть не настроено разрешение динамических обновлений записей узлов.

Когда DNS-сервер остановлен, возможны задержки маршрутизации почты и другие сбои служб.

Примечание.
Сервер Exchange 2003 использует разрешение имен узлов для локальных и внешних SMTP-систем управления сообщениями в сети. Разрешение имен узлов базируется прежде всего на DNS; DNS — критически важная сетевая служба. Отказ DNS-сервера может сделать невозможной нахождение пользователями системы управления сообщениями. Служба каталогов Active Directory и организация Exchange Server 2003 не могут функционировать без DNS. Клиенты управления сообщениями запрашивают DNS для нахождения таких внутренних ресурсов, как контроллеры доменов и серверы почтовых ящиков. Exchange Server 2003, с другой стороны, полагается на DNS при отборе IP-адресов контроллеров доменов для запроса каталогов и адресов внешних SMTP-узлов, когда Exchange Server 2003 отправляет сообщения в Интернет.

Чтобы устранить причину проблемы, убедитесь, что DNS-сервер работает и что запись (A) узла зарегистрирована.

Чтобы убедиться, что DNS-сервер находится в оперативном режиме и запись узла существует

  1. Проверьте, работает ли DNS-сервер, выполнив один или несколько следующих шагов:

    • Определите состояние DNS-сервера, воспользовавшись программой администрирования службы DNS на DNS-сервере.

    • Перезапустите DNS-сервер. Дополнительные сведения см. в материале "Start, stop, pause, or restart a DNS server" (http://go.microsoft.com/fwlink/?LinkId=62999) (Запуск, останов, временный останов и перезапуск DNS-сервера).

    • Определите реакцию DNS-сервера на внешние воздействия с помощью команды nslookup. Дополнительные сведения см. в описании проверки реакции DNS-сервера на внешние воздействия с помощью команды nslookup (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=63001).

  2. С помощью команды nslookup проверьте, что запись (А) узла существует на DNS-сервере. Дополнительные сведения см. в описании проверки существования записей ресурса «А» в службе DNS (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=63001).

  3. Если запись ресурса (А) узла не существует, добавьте или измените вручную запись ресурса «А» или настройте на DNS-сервере динамические обновления записей:

    • Добавьте вручную запись ресурса «А». Дополнительные сведения см. в описании процедуры добавления записи ресурса в зону DNS (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=63002).

    • Измените вручную запись ресурса «А». Дополнительные сведения см. в описании процедуры изменения существующей записи ресурса (http://go.microsoft.com/fwlink/?LinkId=63014).

    • Настройте на DNS-сервере динамические обновления записей узлов. Дополнительные сведения см. в базе знаний Майкрософт в статье 816592, описывающей настройку динамических обновлений DNS в Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592).
  • Сведения об использовании в Exchange Server 2003 службы DNS для разрешения внешних IP-адресов см. в разделе «Transport Dependencies for Exchange Server 2003» (Зависимости транспорта для Exchange Server 2003) в Руководстве по транспорту и маршрутизации сервера Exchange (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Сведения о разрешении DNS-имен см. в статье 322856 базы знаний Майкрософт "How to configure DNS to use with Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856) (Настройка DNS для использования с сервером Exchange).

  • Сведения об устранении проблем DNS см. в материале «Troubleshooting DNS» (Устранение неполадок DNS) (http://go.microsoft.com/fwlink/?LinkId=63003).

Сведения о наблюдении за системой Exchange Server 2003 см. в разделе «System Monitoring with Exchange Server 2003 Management Pack» (Наблюдение за системой с помощью пакета управления Exchange Server 2003) Руководства по пакету управления Exchange Server 2003 для MOM 2000 SP1 (http://go.microsoft.com/fwlink/?LinkId=47573).

  • Сведения о записях ресурсов (А) узлов см. в описании управления записями ресурсов (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=63004).


Отклики DNS различаются для UDP и TCP
Анализатор сервера Microsoft Exchange — статьи > Сеть >

Дата последнего изменения раздела: 2007-03-16

Анализатор Microsoft Exchange запрашивает класс инструментария управления Windows (WMI) Win32_NetworkAdapterConfiguration для получения атрибута DNSServerSearchOrder. Этот атрибут является массивом IP-адресов серверов, использующихся для запроса DNS-серверов.

После получения адреса основного DNS-сервера анализатор Exchange отправляет запрос DNS на настроенные DNS-серверы для каждого сервера службы каталогов Active Directory. Это подключение устанавливается с помощью настраиваемого обработчика объектов, который выполняет запросы на разрешение имен для TCP и UDP.

Если выполнены запросы на разрешение имен как для TCP, так и для UDP, анализатор Exchange сравнивает возвращенные отклики запросов. Если отклики, возвращенные для TCP- и UDP-запросов, различаются, анализатор Exchange выводит предупреждение.

Это предупреждение указывает на возможные проблемы с конфигурацией DNS-сервера, которые негативно влияют на производительность потока почты.

SMTP является основным почтовым протоколом для отправки и транспорта почты в Exchange Server. Это означает, что протокол SMTP используется клиентами для отправки сообщений, а серверами Exchange Server — для доставки сообщений и данных сообщений.

Для доставки сервером Exchange Server исходящего интернет-сообщения через службу SMTP применяется служба DNS, как описано ниже.

  1. Внутренний пользователь отправляет сообщение получателю в удаленном домене.

  2. Чтобы определить, является получатель локальным или удаленным, виртуальный SMTP-сервер на сервере Exchange Server отправителя использует внутренние функции транспорта для запроса адреса получателя на сервере глобального каталога. Если адрес получателя в сообщении не входит в политику получателей, он не хранится в Active Directory. Таким образом, Exchange определяет, что сообщение предназначено для удаленного домена.

  3. При необходимости сервер Exchange Server доставляет сообщение на соответствующий виртуальный SMTP-сервер.

  4. Для определения способа доставки сообщения в удаленный домен виртуальный SMTP-сервер использует собственные данные метабазы IIS.

  5. Затем виртуальный SMTP-сервер на сервере Exchange Server выполняет одно из следующих действий:

    • использует DNS для поиска IP-адреса для конечного домена, а затем пытается доставить сообщение;

    • перенаправляет сообщение на промежуточный узел, который становится ответственным за разрешение DNS и доставку сообщения.

Дополнительные сведения об устранении этого предупреждения см. в статье 820284 базы знаний Майкрософт «Доставка почты в определенные домены может не осуществляться, если в качестве серверной операционной системы используется Windows Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=820284) (на английском языке).

Дополнительные сведения о DNS и сервере Exchange Server см. в следующих статьях базы знаний Майкрософт и веб-трансляции:

  • 322856, «Настройка DNS для использования с Exchange Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856) (на английском языке)

  • 263237, «XCON. Протокол SMTP в Windows 2000 Server и Exchange 2000 Server использует TCP-запросы к DNS» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237) (на английском языке)

  • 324759, «Веб-трансляция службы технической поддержки: Microsoft Exchange 2000 Server: устранение неполадок DNS, связанных с транспортом» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759) (на английском языке)


На DNS-сервере запущен Virtual Server 2005, где Exchange Server установлен как ведущий сервер
Анализатор сервера Microsoft Exchange — статьи > Сеть >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_ComputerSystem, чтобы определить задано ли значение ключа Model для Виртуальной машины.

Анализатор сервера Exchange также проверяет наличие следующего значения реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

Кроме того, анализатор сервера Exchange запрашивает WMI-класс Win32_Services, чтобы определить, запущена ли служба доменных имен (DNS) на физическом компьютере, где запущено приложение Microsoft Virtual Server 2005.

Если анализатор сервера Exchange обнаруживает, что ключ Model содержит строку Виртуальная машина, указанный выше раздел реестра существует, а служба DNS запущена, на экран выводится сообщение об ошибке.

Значение Virtual Machine для ключа Model указывает, что компьютер сервера Exchange Server запущен как ведущая виртуальная машина в Virtual Server 2005 или Microsoft Virtual PC 2004. Так как указанный выше раздел реестра создается только с помощью Virtual Server 2005, его существование указывает на том, что компьютер сервера Exchange запущен как ведущая виртуальная машина в Virtual Server 2005.

Майкрософт не поддерживает запуск какой-либо из версий Microsoft Exchange Server на виртуальной машине или на эмуляторе. Это относится к серверу Exchange, запущенному на Virtual Server 2005, Virtual PC 2004 или любой программе виртуальной машины стороннего производителя. Платформы Microsoft Exchange Server разработаны и испытаны только для работы на физическом оборудовании, в частности те платформы, которые перечислены на веб-узле каталога Windows Server (http://go.microsoft.com/fwlink/?linkid=17219).

Кроме того, запуск Exchange в виде ведущей виртуальной машины на Virtual Server 2005 на компьютере, где запущена система DNS, не рекомендуется в связи с тем, что не обеспечивает необходимого уровня избыточности для служб.

Чтобы устранить эту ошибку

  1. Переместите почтовые ящики с сервера Exchange, работающего под управлением Virtual Server 2005 на физический компьютер сервера Exchange.

  2. Повторно разместите все общие папки и переместите роли, размещенные на виртуальном сервере Exchange при необходимости.

  3. Удалите Exchange с виртуальной машины, чтобы списать и удалить его из инфраструктуры Exchange и службы каталогов Active Directory®.

Дополнительные сведения о перемещении почтовых ящиков см. в следующих статьях базы знаний Майкрософт:

  • Статья 822892, описывающая усовершенствования, связанные с почтовыми ящиками в Exchange Server2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • Статья 224975, описывающая разницу между способами перемещения почтовых ящиков (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

Дополнительные сведения о поддержке компьютеров сервера Exchange в виртуальных средах см. в базе знаний Майкрософт в статье 320220, описывающей поддержку границ для сервера Exchange на виртуальной машине или эмуляторе (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).

Дополнительные сведения о Microsoft Virtual Server 2005, см. на веб-узле Microsoft Virtual Server 2005 (http://go.microsoft.com/fwlink/?linkid=34938).

Дополнительные сведения о Microsoft Virtual PC 2004, см. на веб-узле Microsoft Virtual PC 2004 (http://go.microsoft.com/fwlink/?linkid=34938).


Отклики внешнего DNS-сервера отличаются для UDP и TCP
Анализатор сервера Microsoft Exchange — статьи > Сеть >

Дата последнего изменения раздела: 2007-03-16

Анализатор Microsoft Exchange опрашивает службу каталогов Active Directory для определения значения атрибута msExchSmtpExternalDNSServers класса protocolCfgSMTPServer для каждого объекта Exchange Server. Значение атрибута msExchSmtpExternalDNSServers (если оно задано) указывает адрес внешнего DNS-сервера, который использует экземпляр виртуального SMTP-сервера.

После получения адреса основного внешнего DNS-сервера анализатор Exchange отправляет DNS-запрос на настроенные DNS-серверы для каждого сервера службы каталогов Active Directory. Это подключение устанавливается с помощью настраиваемого обработчика объектов, который выполняет запросы на разрешение имен для TCP и UDP.

Если выполнены запросы на разрешение имен как для TCP, так и для UDP, анализатор Exchange сравнивает возвращенные отклики запросов. Если отклики, возвращенные для TCP- и UDP-запросов, различаются, анализатор Exchange выводит предупреждение.

Это предупреждение указывает на возможные проблемы с конфигурацией внешнего DNS-сервера, которые негативно влияют на производительность потока почты.

SMTP является основным почтовым протоколом для отправки и транспорта почты в Exchange Server. Это означает, что протокол SMTP используется клиентами для отправки сообщений, а серверами Exchange Server — для доставки сообщений и данных сообщений.

Для доставки сервером Exchange Server исходящего интернет-сообщения через службу SMTP применяется служба DNS, как описано ниже.

  1. Внутренний пользователь отправляет сообщение получателю в удаленном домене.

  2. Чтобы определить, является получатель локальным или удаленным, виртуальный SMTP-сервер на сервере Exchange Server отправителя использует внутренние функции транспорта для запроса адреса получателя на сервере глобального каталога. Если адрес получателя в сообщении не входит в политику получателей, он не хранится в Active Directory. Таким образом, Exchange определяет, что сообщение предназначено для удаленного домена.

  3. При необходимости сервер Exchange Server доставляет сообщение на соответствующий виртуальный SMTP-сервер.

  4. Для определения способа доставки сообщения в удаленный домен виртуальный SMTP-сервер использует собственные данные метабазы IIS.

  5. Затем виртуальный SMTP-сервер на сервере Exchange Server выполняет одно из следующих действий:

    • использует DNS для поиска IP-адреса для конечного домена, а затем пытается доставить сообщение;

    • перенаправляет сообщение на промежуточный узел, который становится ответственным за разрешение DNS и доставку сообщения.

Дополнительные сведения об устранении этого предупреждения см. в статье 820284 базы знаний Майкрософт «Доставка почты в определенные домены может не осуществляться, если в качестве серверной операционной системы используется Windows Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=820284) (на английском языке).

Дополнительные сведения о DNS и сервере Exchange Server см. в следующих статьях базы знаний Майкрософт и веб-трансляции:

  • 322856, «Настройка DNS для использования с Exchange Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856) (на английском языке)

  • 263237, «XCON. Протокол SMTP в Windows 2000 Server и Exchange 2000 Server использует TCP-запросы к DNS» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237) (на английском языке)

  • 324759, «Веб-трансляция службы технической поддержки: Microsoft Exchange 2000 Server: устранение неполадок DNS, связанных с транспортом» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759) (на английском языке)


Значения счетчика «Network Bytes Total per second» выше порогового значения
Анализатор сервера Microsoft Exchange — статьи > Сеть >

Дата последнего изменения раздела: 2006-02-13

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Bytes Total/sec объекта производительности Network Interface для анализа данных о производительности.

Счетчик Bytes Total/sec показывает скорость обработки сетевым адаптером байт данных. В этом счетчике учитываются данные всех приложений и файлов, а также сведения по протоколу, например заголовки пакетов. Счетчик производительности Bytes Total/sec объединяет счетчики Network Interface\Bytes Received/sec и Network Interface/Bytes Sent/sec.

Анализатор сервера Exchange сообщает максимальное значение счетчика производительности, достигаемое в течение интервала сбора данных. Для сетевого адаптера со скоростью работы 100 мегабит в секунду (Мб/с) значение счетчика производительности Bytes Total/sec не должно превышать 7 мегабайт в секунду. Для сетевого адаптера со скоростью работы 1000 Мб/с значение счетчика производительности Bytes Total/sec не должно превышать 70 мегабайт в секунду. Если значение Bytes Total/sec превышает 7 процентов пропускной способности сети, анализатор сервера Exchange выводит на экран сообщение об ошибке.

Такая ошибка, как правило, означает, что данный сервер время от времени перестает отвечать на запросы, что приводит замедлению или полному останову потока почты. Кроме того, клиенты Microsoft Outlook®, подключенные к данному серверу, могут получать сообщение Запрос на отмену удаленного вызова процедуры.

Ниже приводится ряд возможных причин возникновения этой ошибки:

  • Карта сетевого интерфейса на данном компьютере не поддерживает пропускную способность, которую поддерживает инфраструктура сети.

  • Данный сервер слишком сильно загружен.

  • Внезапный рост загрузки сети вызван вирусами или нежелательными сообщениями электронной почты.

Чтобы устранить эту ошибку:

  • Если карта сетевого интерфейса не поддерживает максимальную пропускную способность сети, обновите карту до более быстрой.

  • Сократите нагрузку на сервер. Для этого можно переместить почтовые ящики на сервер, на котором их меньше. При необходимости добавьте дополнительный сервер Exchange в среду.

  • Если есть подозрения, что необычно высокая загрузка не связана с тем, что на сервере расположено слишком много почтовых ящиков, попытайтесь выяснить источник этой загрузки и устранить ее.

  • Изучите рекомендации, изложенные в следующих статьях:

    • Сведения о пропускной способности сети см. в разделе, посвященном производительности сети, части "Understanding Exchange Performance" (Общее представление о производительности сети) руководства Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576) (Руководство по управлению производительностью и масштабируемостью Exchange Server 2003).

    • Сведения об устранении проблем сети см.в разделе "Ruling Out Network-Bound Problems" (Устранение проблем сети) статьи Troubleshooting Microsoft Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588) (Устранение проблем производительности Microsoft Exchange Server 2003).


Группировка сетевых интерфейсных плат (NIC) включена
Анализатор сервера Microsoft Exchange — статьи > Сеть >

Дата последнего изменения раздела: 2006-10-16

Средство анализа Microsoft Exchange Server запрашивает класс Win32_NetworkAdapter инструментария WMI для определения всех сетевых интерфейсных плат, связанных с протоколом TCP/IP.

Средство анализа Microsoft® Exchange Server запрашивает следующую запись из реестра, чтобы определить наличие параметра реестра TeamAdapters для этих плат:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\%NICDEVICEID%\

Если средство анализа Exchange Server определяет, что ключ TeamAdapters существует для одной или более сетевых плат, установленных на анализируемом сервере, то отображается предупреждение.

Предупреждение указывает, что на анализируемом сервере Exchange включена группировка сетевых интерфейсных плат. Несмотря на то, что группировка сетевых интерфейсных плат не относится к потоку почтовых сообщений, необходимо убедиться, что группировка правильно настроена с наиболее поздними версиями драйверов этих плат.

Устранение этой проблемы

  • Если проблемы с потоком электронной почты происходят на сервере с включенной группировкой сетевых интерфейсных плат, отключите группировку и посмотрите, решилась ли после этого проблема.

  • Обновите драйверы сетевых интерфейсных плат до наиболее поздних версий, поставляемых изготовителем плат.

  • Строго следуйте рекомендациям изготовителя сетевых интерфейсных плат по настройке группировки.

Дополнительные сведения о группировке сетевых интерфейсных плат см. в следующих статьях базы знаний Майкрософт:

  • Статья 278431 «Проблемы в работе сети при использовании группировки адаптеров с балансировкой нагрузки сети» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=278431 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 814607 «Поддержка корпорацией Майкрософт кластеров серверов с компонентами сторонних производителей» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=814607 (эта ссылка может указывать на содержимое полностью или частично на английском языке).


Исходящие сетевые пакеты превышают пороговое значение
Анализатор сервера Microsoft Exchange — статьи > Сеть >

Дата последнего изменения раздела: 2006-02-13

Анализатор сервера Microsoft® Exchange содержит модуль сбора данных о производительности, который используется для запроса объектов счетчиков производительности. Для анализа данных о производительности модуль сбора данных о производительности ведет сбор данных от счетчика производительности Packet Outbound errors объекта производительности Network Interface.

Счетчик производительности Packet Outbound errors указывает число исходящих пакетов, которые не могут быть переданы в связи с возникновением ошибки. Значение счетчика производительности Packet Outbound errors должно быть равным нулю. Если анализатор сервера Exchange обнаруживает, что счетчик производительности Packet Outbound errors имеет значение больше нуля, выводится сообщение об ошибке.

Такая ошибка, как правило, означает, что данный сервер время от времени перестает отвечать на запросы, что приводит к замедлению или полному останову потока почты. Кроме того, клиенты Microsoft Outlook®, подключенные к данному серверу, могут получать сообщение Запрос на отмену удаленного вызова процедуры.

Эта ошибка, скорее всего, вызвана поврежденной или неисправной картой сетевого интерфейса.

Чтобы устранить данную ошибку, необходимо выявить причину ошибок в исходящих пакетах, а затем исправить проблему. Если ошибки в исходящих пакетах вызваны неисправной картой сетевого интерфейса, следует незамедлительно заменить эту карту.

Изучите рекомендации, изложенные в следующих статьях:

  • Сведения о пропускной способности сети см. в разделе, посвященном производительности сети, части «Understanding Exchange Performance» (Общее представление о производительности сети) руководства Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576) (Руководство по управлению производительностью и масштабируемостью Exchange Server 2003).

  • Сведения об устранении проблем сети см.в разделе «Ruling Out Network-Bound Problems» (Устранение проблем сети) статьи Troubleshooting Microsoft Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588) (Устранение проблем производительности Microsoft Exchange Server 2003).


Длина исходящей очереди сети превысила пороговое значение
Анализатор сервера Microsoft Exchange — статьи > Сеть >

Дата последнего изменения раздела: 2007-02-13

Анализатор сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика производительности Output Queue Length объекта производительности Network Interface для анализа данных о производительности.

Счетчик производительности Output Queue Length показывает длину очереди исходящих пакетов в пакетах. Анализатор сервера Exchange сообщает максимальное значение счетчика производительности, достигаемое в течение интервала сбора данных. Если среднее значение превышает 10, анализатор сервера Exchange выводит сообщение об ошибке.

Такая ошибка, как правило, означает, что данный сервер время от времени перестает отвечать на запросы, что приводит к замедлению или полному останову потока почты. Кроме того, клиенты Outlook, подключенные к данному серверу, могут получать сообщение Запрос на отмену удаленного вызова процедуры.

Ниже приводится ряд возможных причин возникновения этой ошибки:

Примечание.
При некоторых условиях на компьютере, работающем под управлением операционной системы Microsoft Windows 2000 Server, счетчик производительности Output Queue Length может постоянно показывать случайное значение, превышающее ноль. Дополнительные сведения об условиях, в которых счетчик производительности Output Queue Length может показывать случайное значение, и инструкции по исправлению такой ситуации см. в статье 834940 базы знаний Майкрософт «Системный монитор может показывать высокие значения для счетчика производительности длины очереди вывода в системе Windows 2000», по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=834940 (эта ссылка может указывать на содержимое полностью или частично на английском языке).
  • Карта сетевого интерфейса на данном компьютере не поддерживает пропускную способность, которую поддерживает инфраструктура сети.

  • Данный сервер слишком сильно загружен.

  • Внезапный рост загрузки сети вызван вирусами или нежелательными сообщениями электронной почты.

Чтобы устранить эту ошибку, выполните следующие шаги:

  • Если карта сетевого интерфейса не поддерживает максимальную пропускную способность сети, замените карту на более быструю.

  • Сократите загрузку сервера. Для этого можно переместить почтовые ящики на сервер, на котором их меньше. При необходимости добавьте дополнительный сервер Exchange в среду.

  • Если есть подозрения, что необычно высокая загрузка не связана с тем, что на сервере расположено слишком много почтовых ящиков, попытайтесь выяснить источник этой загрузки и устранить ее.

Изучите рекомендации, изложенные в следующих статьях:

  • Сведения о пропускной способности сети см. в разделе, посвященном производительности сети, части «Understanding Exchange Performance» (Общее представление о производительности сети) руководства Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576) (Руководство по управлению производительностью и масштабируемостью Exchange Server 2003).

  • Сведения об устранении проблем сети см.в разделе «Ruling Out Network-Bound Problems» (Устранение проблем сети) документа Troubleshooting Microsoft Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588) (Устранение проблем производительности Microsoft Exchange Server 2003).


Основной DNS-сервер не ответил на UDP-соединение
Анализатор сервера Microsoft Exchange — статьи > Сеть >

Дата последнего изменения раздела: 2007-03-16

Анализатор Microsoft Exchange запрашивает класс инструментария управления Windows (WMI) Win32_NetworkAdapterConfiguration для получения атрибута DNSServerSearchOrder. Этот атрибут является массивом IP-адресов серверов, использующихся для запроса DNS-серверов.

После получения адреса основного DNS-сервера анализатор Exchange отправляет запрос DNS на настроенные DNS-серверы для каждого сервера службы каталогов Active Directory. Это подключение устанавливается с помощью обработчика пользовательских объектов, который выполняет UDP-запрос на разрешение имени и анализирует его результаты.

В случае сбоя UDP-запроса на разрешение имени анализатор Exchange выводит предупреждение.

Это предупреждение указывает на то, что основной DNS-сервер, возможно, настроен на прием только TCP-запросов.

SMTP является основным почтовым протоколом для отправки и транспорта почты в Exchange Server. Это означает, что протокол SMTP используется клиентами для отправки сообщений, а серверами Exchange Server — для доставки сообщений и данных сообщений.

Для доставки сервером Exchange Server исходящего интернет-сообщения через службу SMTP применяется служба DNS, как описано ниже.

  1. Внутренний пользователь отправляет сообщение получателю в удаленном домене.

  2. Чтобы определить, является получатель локальным или удаленным, виртуальный SMTP-сервер на сервере Exchange Server отправителя использует внутренние функции транспорта для запроса адреса получателя на сервере глобального каталога. Если адрес получателя в сообщении не входит в политику получателей, он не хранится в Active Directory. Таким образом, Exchange определяет, что сообщение предназначено для удаленного домена.

  3. При необходимости сервер Exchange Server доставляет сообщение на соответствующий виртуальный SMTP-сервер.

  4. Для определения способа доставки сообщения в удаленный домен виртуальный SMTP-сервер использует собственные данные метабазы IIS.

  5. Затем виртуальный SMTP-сервер на сервере Exchange Server выполняет одно из следующих действий:

    • использует DNS для поиска IP-адреса для конечного домена, а затем пытается доставить сообщение;

    • перенаправляет сообщение на промежуточный узел, который становится ответственным за разрешение DNS и доставку сообщения.

По умолчанию DNS-серверы выполняют прослушивание на UDP-сокете 53 на наличие таких операций связи, как запросы на разрешение имен.

Если службы SMTP на сервере Exchange Server настроены на отправку только UDP-запросов, а основной DNS-сервер настроен на прием только TCP-запросов, могут возникать сбои маршрутизации, негативно влияющие на производительность потока почты.

Чтобы устранить это предупреждение, выполните указанные ниже действия.

  1. Убедитесь, что DNS-сервер запущен и подключен к сети.

  2. Убедитесь, что сетевой брандмауэр или фильтр пакетов не блокирует принудительно известные DNS-порты, такие как UDP-порт 53.

  3. Убедитесь, что основной DNS-сервер поддерживает UDP-запросы на разрешение имен.

Дополнительные сведения о DNS и сервере Exchange Server см. в следующих статьях базы знаний Майкрософт и веб-трансляции:

  • 322856, «Настройка DNS для использования с Exchange Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856) (на английском языке)

  • 263237, «XCON. Протокол SMTP в Windows 2000 Server и Exchange 2000 Server использует TCP-запросы к DNS» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237) (на английском языке)

  • 324759, «Веб-трансляция службы технической поддержки: Microsoft Exchange 2000 Server: устранение неполадок DNS, связанных с транспортом» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759) (на английском языке)


Основной DNS-сервер недоступен
Анализатор сервера Microsoft Exchange — статьи > Сеть >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_NetworkAdapterConfiguration для получения атрибута DNSServerSearchOrder. Этот атрибут является массивом IP-адресов сервера, которые должны использоваться в запросах для DNS-серверов. После извлечения адреса основного DNS-сервера анализатор сервера Exchange открывает подключение TCP-сокета к порту 53 сервера. Это подключение создается с помощью пользовательского обработчика объектов, который в случае успешного подключения возвращает соответствующую строку. Если анализатор сервера Exchange не получит 53 Available в качестве части возвращенной строки, на экран будет выведено предупреждение.

Это предупреждение указывает на то, что сервер не ответил на попытку подключения через TCP-порт 53. По умолчанию DNS-серверы прослушивают TCP-сокет 53 для получения таких запросов, как запросы разрешения имен.

Если основной DNS-сервер недоступен, а вы используете Exchange 2000 Server, доставка почты будет осуществляться медленно. Корпорация Майкрософт предоставляет поддерживаемое исправление для устранения проблемы медленной доставки сообщений внешним получателям в случае недоступности основного DNS-сервера. Обратитесь в службу поддержки продуктов компании Майкрософт для получения этого исправления.

Кроме того, вам потребуется выяснить, почему DNS-сервер недоступен, или изменить параметры DNS сервера Exchange для использования другого DNS-сервера для разрешения имен.

Чтобы устранить причину появления этого предупреждения

  1. Убедитесь, что DNS-сервер запущен и подключен к сети.

  2. Используйте команду PING, чтобы определить, доступен ли DNS-сервер.

Для получения дополнительных сведений о проблеме медленной доставки почты в случае, если DNS-сервер недоступен, а также о способах получения исправлений для устранения этой проблемы см. статью 829722 в базе данных Майкрософт, посвященную проблеме медленной доставки почты в Exchange 2000 в случае, если DNS-сервер недоступен (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829722).

Дополнительные сведения о DNS-сервере и сервера Exchange см. в следующих статьях базы знаний и веб-презентации:

  • Статья 322856, посвященная настройке использования DNS с сервером Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • Статья 263237, посвященная использованию протокола SMTP в Windows 2000 и Exchange 2000 для TCP-запросов DNS-сервера (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • Статья 324759 с веб-презентацией службы поддержки, посвященной устранению неполадок транспорта DNS-сервера в Microsoft Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


Основной внешний DNS-сервер не ответил на TCP-соединение
Анализатор сервера Microsoft Exchange — статьи > Сеть >

Дата последнего изменения раздела: 2007-03-16

Анализатор Microsoft Exchange опрашивает службу каталогов Active Directory для определения значения атрибута msExchSmtpExternalDNSServers класса protocolCfgSMTPServer для каждого объекта Exchange Server. Значение атрибута msExchSmtpExternalDNSServers (если оно задано) указывает адрес внешнего DNS-сервера, который использует экземпляр виртуального SMTP-сервера.

После получения адреса основного внешнего DNS-сервера анализатор Exchange Server открывает TCP-соединение через сокет к порту 53 на сервере. Это соединение выполняется с помощью обработчика пользовательских объектов, который возвращает определенную строку, если соединение установлено успешно. Если анализатор сервера Exchange Server не получит 53 Available в возвращенной строке, будет выведено предупреждение.

Это предупреждение указывает на то, что сервер не ответил на попытку установить TCP-соединение для порта 53. По умолчанию DNS-серверы выполняют прослушивание на TCP-сокете 53 на наличие таких операций связи, как запросы на разрешение имен.

SMTP является основным почтовым протоколом для отправки и транспорта почты в Exchange Server. Это означает, что протокол SMTP используется клиентами для отправки сообщений, а серверами Exchange Server — для доставки сообщений и данных сообщений.

Для доставки сервером Exchange Server исходящего интернет-сообщения через службу SMTP применяется служба DNS, как описано ниже.

  1. Внутренний пользователь отправляет сообщение получателю в удаленном домене.

  2. Чтобы определить, является получатель локальным или удаленным, виртуальный SMTP-сервер на сервере Exchange Server отправителя использует внутренние функции транспорта для запроса адреса получателя на сервере глобального каталога. Если адрес получателя в сообщении не входит в политику получателей, он не хранится в Active Directory. Таким образом, Exchange определяет, что сообщение предназначено для удаленного домена.

  3. При необходимости сервер Exchange Server доставляет сообщение на соответствующий виртуальный SMTP-сервер.

  4. Для определения способа доставки сообщения в удаленный домен виртуальный SMTP-сервер использует собственные данные метабазы IIS.

  5. Затем виртуальный SMTP-сервер на сервере Exchange Server выполняет одно из следующих действий:

    • использует DNS для поиска IP-адреса для конечного домена, а затем пытается доставить сообщение;

    • перенаправляет сообщение на промежуточный узел, который становится ответственным за разрешение DNS и доставку сообщения.

Если основной внешний DNS-сервер недоступен и при этом используется сервер Exchange 2000 Server, доставка почты будет выполняться медленно. Корпорация Майкрософт выпустила поддерживаемое исправление, устраняющее проблему с медленной доставкой сообщений внешним получателям в случае недоступности основного внешнего DNS-сервера. Для получения данного исправления обратитесь в службу технической поддержки корпорации Майкрософт.

Кроме того, необходимо выяснить причину, по которой основной внешний DNS-сервер недоступен, или изменить параметры DNS в сервере Exchange Server, чтобы использовать для разрешения имен другой DNS-сервер.

Чтобы устранить это предупреждение, выполните указанные ниже действия.

  1. Убедитесь, что внешний DNS-сервер запущен и к нему можно подключиться из сети Exchange.

  2. Воспользуйтесь командой PING, чтобы определить, доступен ли внешний DNS-сервер.

Дополнительные сведения о медленной доставке почты в случае недоступности основного DNS-сервера, а также о получении исправления, устраняющего данную проблему, см. в статье 829722 базы знаний Майкрософт «Доставка почты в Exchange 2000 Server выполняется медленно, если основной DNS-сервер недоступен» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829722) (на английском языке).

Дополнительные сведения о DNS и сервере Exchange Server см. в следующих статьях базы знаний и веб-трансляции:

  • 322856, «Настройка DNS для использования с Exchange Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856) (на английском языке)

  • 263237, «XCON. Протокол SMTP в Windows 2000 Server и Exchange 2000 Server использует TCP-запросы к DNS» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237) (на английском языке)

  • 324759, «Веб-трансляция службы технической поддержки: Microsoft Exchange 2000 Server: устранение неполадок DNS, связанных с транспортом» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759) (на английском языке)


Основной внешний DNS-сервер не ответил на UDP-соединение
Анализатор сервера Microsoft Exchange — статьи > Сеть >

Дата последнего изменения раздела: 2007-03-16

Анализатор Microsoft Exchange опрашивает службу каталогов Active Directory для определения значения атрибута msExchSmtpExternalDNSServers класса protocolCfgSMTPServer для каждого объекта Exchange Server. Значение атрибута msExchSmtpExternalDNSServers (если оно задано) указывает адрес внешнего DNS-сервера, который использует экземпляр виртуального SMTP-сервера.

После получения адреса основного внешнего DNS-сервера анализатор Exchange отправляет запрос DNS на настроенные внешние DNS-серверы для каждого сервера службы каталогов Active Directory. Это подключение устанавливается с помощью обработчика пользовательских объектов, который выполняет UDP-запрос на разрешение имени и анализирует его результаты.

В случае сбоя UDP-запроса на разрешение имени анализатор Exchange выводит предупреждение.

Это предупреждение указывает на то, что основной внешний DNS-сервер, возможно, настроен на прием только TCP-запросов.

SMTP является основным почтовым протоколом для отправки и транспорта почты в Exchange Server. Это означает, что протокол SMTP используется клиентами для отправки сообщений, а серверами Exchange Server — для доставки сообщений и данных сообщений.

Для доставки сервером Exchange Server исходящего интернет-сообщения через службу SMTP применяется служба DNS, как описано ниже.

  1. Внутренний пользователь отправляет сообщение получателю в удаленном домене.

  2. Чтобы определить, является получатель локальным или удаленным, виртуальный SMTP-сервер на сервере Exchange Server отправителя использует внутренние функции транспорта для запроса адреса получателя на сервере глобального каталога. Если адрес получателя в сообщении не входит в политику получателей, он не хранится в Active Directory. Таким образом, Exchange определяет, что сообщение предназначено для удаленного домена.

  3. При необходимости сервер Exchange Server доставляет сообщение на соответствующий виртуальный SMTP-сервер.

  4. Для определения способа доставки сообщения в удаленный домен виртуальный SMTP-сервер использует собственные данные метабазы IIS.

  5. Затем виртуальный SMTP-сервер на сервере Exchange Server выполняет одно из следующих действий:

    • использует DNS для поиска IP-адреса для конечного домена, а затем пытается доставить сообщение;

    • перенаправляет сообщение на промежуточный узел, который становится ответственным за разрешение DNS и доставку сообщения.

По умолчанию DNS-серверы выполняют прослушивание на UDP-сокете 53 на наличие таких операций связи, как запросы на разрешение имен.

Если службы SMTP на сервере Exchange Server настроены на отправку только UDP-запросов, а основной внешний DNS-сервер настроен на прием только TCP-запросов, могут возникать сбои маршрутизации, негативно влияющие на производительность потока почты.

Чтобы устранить это предупреждение, выполните указанные ниже действия.

  1. Убедитесь, что внешний DNS-сервер запущен и к нему можно подключиться из сети.

  2. Убедитесь, что сетевой брандмауэр или фильтр пакетов не блокирует принудительно известные DNS-порты, такие как UDP-порт 53.

  3. Убедитесь, что основной внешний DNS-сервер поддерживает UDP-запросы на разрешение имен.

Дополнительные сведения о DNS и сервере Exchange Server см. в следующих статьях базы знаний Майкрософт и веб-трансляции:

  • 322856, «Настройка DNS для использования с Exchange Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856) (на английском языке)

  • 263237, «XCON. Протокол SMTP в Windows 2000 Server и Exchange 2000 Server использует TCP-запросы к DNS» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237) (на английском языке)

  • 324759, «Веб-трансляция службы технической поддержки: Microsoft Exchange 2000 Server: устранение неполадок DNS, связанных с транспортом» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759) (на английском языке)


Основной сервер WINS не ответил на запрос
Анализатор сервера Microsoft Exchange — статьи > Сеть >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_NetworkAdapterConfiguration для получения атрибута WINSPrimaryServer. Данный атрибут представляет IP-адрес основного сервера WINS (Windows Internet Name Service) для компьютера с Exchange Server. Получив адрес основного сервера WINS, анализатор сервера Exchange открывает подключение через сокет TCP к порту 137 сервера. Это подключение устанавливается с помощью обработчика пользовательских объектов, возвращающего определенную строку в случае удачного подключения. Если анализатор сервера Exchange не обнаруживает 137 Available в возвращенной строке, на экран выводится предупреждение.

Это предупреждение указывает на то, что сервер не ответил на попытку подключения через TCP-порт 137. По умолчанию серверы WINS прослушивают TCP-сокет 137 для получения таких запросов, как запросы разрешения имен.

Если основной сервер WINS недоступен в среде Exchange Server, то доставка почты замедляется, особенно в крупных организациях. Следует выяснить, почему основной сервер WINS недоступен или изменить параметры WINS на сервере Exchange, чтобы использовать для разрешения имен другой сервер WINS.

Чтобы устранить причину появления этого предупреждения

  1. Убедитесь, что сервер WINS запущен и подключен к сети.

  2. Используйте команду PING, чтобы определить, доступен ли сервер WINS.

Дополнительные сведения о требованиях по использованию WINS в среде Exchange 2000 Server и Exchange Server 2003 см. в статье 837391 базы знаний Майкрософт, где объясняется, почему для полноценного функционирования серверу Exchange Server 2003 и Exchange 2000 Server требуется разрешение имен NetBIOS (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=837391).


Порт 389 не отвечает
Анализатор сервера Microsoft Exchange — статьи > Сеть >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута dNSHostName для всех контроллеров домена в Active Directory. Получив имена контроллеров домена, анализатор сервера Exchange открывает сокет TCP-подключения к порту 389 на каждом из контроллеров домена. Это подключение создается с помощью пользовательского обработчика объектов, который в случае успешного подключения возвращает соответствующую строку. Если в получаемой анализатором сервера строке отсутствует строка 389 Available, выводится предупреждение.

Это предупреждение указывает, что контроллер домена не ответил на попытку подключения к TCP-порту 389. TCP-порт 389 — это порт по умолчанию для LDAP-взаимодействий (Lightweight Directory Access Protocol).

Появление этого предупреждения может быть вызвано проблемами связи между анализатором сервера Exchange и контроллером домена. Существует множество причин, по которым LDAP-запросы могут некорректно обрабатываться контроллером домена, когда анализатор сервера Exchange запрашивает контроллер домена.

Чтобы устранить причину появления этого предупреждения

  1. Убедитесь, что учетная запись, от имени которой запущено этот средство, авторизована на запросы к контроллеру домена. Если контроллер домена работает, понадобятся разрешения уровня «Пользователь». Дополнительные сведения о разрешениях, необходимых для запуска анализатора сервера Exchange, можно найти в файле справки к этому средству. Чтобы открыть файл справки, запустите анализатор сервера Exchange, выберите команду Справка, а затем — команду Справка анализатора сервера Microsoft Exchange.

  2. Убедитесь, что между компьютером, на котором выполняется анализатор сервера Exchange, и не дающим отклика контроллером домена отсутствуют межсетевые экраны или ограничения на использование соответствующих портов.

  3. Убедитесь, что контроллер домена подключен к сети и правильно работает.

Дополнительные сведения об устранении проблем подключения к службе Active Directory см. в статье 816103 базы знаний Майкрософт, «HOW TO: Use Portqry to Troubleshoot Active Directory Connectivity Issues» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103) (Инструкции по использованию команды Portqry для устранения неполадок подключения к Active Directory).

Дополнительные сведения о настройке Microsoft Windows® Time на контроллерах домена см. в статье 816042 базы знаний «How to configure an authoritative time server in Windows Server 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816042) (Инструкции по настройке авторизованного сервера времени в Windows Server 2003).


Порт 636 не отвечает
Анализатор сервера Microsoft Exchange — статьи > Сеть >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута dNSHostName для всех контроллеров домена в Active Directory. Получив имена контроллеров домена, анализатор сервера Exchange открывает сокет TCP-подключения к порту 636 на каждом контроллере домена. Это подключение создается настраиваемым обработчиком объектов, который в случае успешного подключения возвращает соответствующую строку. Если в строке, получаемой анализатором сервера отсутствует строка 636 Available, выводится предупреждение.

Это предупреждение показывает, что контроллер домена не отвечает на попытку подключения, использующего TCP-порт 636. TCP-порт 636 — это порт по умолчанию для связи по протоколу for Secure Lightweight Directory Access Protocol (защищенный облегченный протокол доступа к каталогам, LDAP через SSL).

С введением пакета обновлений SP3 для сервера Exchange 2000 сервер сможет связываться, используя протокол LDAP через SSL, если в локальном хранилище сертификатов компьютера, на котором работает сервер Exchange, имеется действительный сертификат. Если подобный сертификат отсутствует, или если возвращается связанная с сертификатом ошибка (например, контроллер домена не доверяет сертификату Exchange, или используемый сертификат требует защиты с помощью надежного ключа), сервер Exchange автоматически вернется к протоколу LDAP без SSL. Появление этого предупреждения может быть вызвано проблемами связи между анализатором сервера Exchange и контроллером домена. Это предупреждение не указывает на проблемы инфраструктуры открытых ключей (PKI) или другие проблемы, связанные с сертификатом.

Существует множество причин неправильной обработки контроллером домена запросов протокола LDAP через SSL, инициированных анализатором сервера Exchange.

Устранение причины появления этого предупреждения

  1. Убедитесь, что учетной записи, от имени которой запущено этот средство, разрешено обращаться с запросами к контроллеру домена. Если контроллер домена работает, понадобятся разрешения уровня «Пользователь». Дополнительные сведения о разрешениях, необходимых для запуска анализатора сервера Exchange, можно найти в файле справки к этому средству. Чтобы открыть файл справки, запустите анализатор сервера Exchange, щелкните Help (Справка), а затем щелкните Microsoft Exchange Server Analyzer Tool Help (Справка средства анализатора сервера Microsoft Exchange).

  2. Убедитесь, что между компьютером, на котором работает анализатор сервера Exchange, и неотвечающим контроллером домена, брандмауэры либо отсутствуют, либо на них нет ограничений для соответствующих портов.

  3. Убедитесь, что контроллер домена подключен к сети и правильно работает.

  4. Убедитесь в синхронизации времени на компьютере анализатора сервера Exchange и на неотвечающем контроллере домена. Если служба времени Microsoft Windows® Time Service на контроллере домена остановлена или отключена, локальное время контроллера домена может оказаться несинхронизированным. В этом случае контроллер домена не будет отвечать на запросы протокола LDAP через SSL, пока его часы не будут синхронизированы.

Дополнительные сведения об использовании LDAP через SSL см. в статье 321051 базы знаний Майкрософт, посвященной использованию протокола LDAP через SSL со сторонними центрами сертификации, по адресу http://go.microsoft.com/fwlink/?LinkId=3052&kbid=321051 (возможно, на английском языке).

Дополнительные сведения об устранении проблем подключения к службе Active Directory см. в статье 816103 базы знаний Майкрософт, посвященной использованию Portqry для устранения проблем подключения к службе Active Directory по адресу http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103 (возможно, на английском языке).

Дополнительные сведения о службе времени Windows Time см. в статье 816042 базы знаний Майкрософт, посвященной настройке службы Windows Time на главном компьютере корневого основного контроллера домена леса на базе Windows Server 2003 http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816042 (возможно, на английском языке).


SMTP-сервер не поддерживает команду X-LINK2STATE
Анализатор сервера Microsoft Exchange — статьи > Сеть >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запускает SMTP-сеанс связи с сервером Exchange для проверки, что перечислены правильные SMTP-команды Exchange. Если команда X-LINK2STATE отсутствует в списке, отображается предупреждение.

Команда X-LINK2STATE используется сервером Exchange для обновления таблиц состояния ссылок на хозяевах маршрутизации. В таблицах состояния ссылок записывается актуальная информация о состоянии SMTP-ссылок в организации Exchange. Эти сведения используются в Exchange для выбора наиболее надежных и экономичных маршрутов при маршрутизации сообщений. Эту функцию также называют «Интеллектуальной маршрутизацией».

Команда X-LINK2STATE требуется Exchange для эффективной маршрутизации и не используется другими SMTP-поставщиками. Эти функциональные возможности предоставляются в файле (xlsasink.dll), который устанавливается и регистрируется программой установки Exchange.

Существует две известные причины появления этого предупреждения. Первая заключается в том, что некоторые администраторы могли отключить библиотеку xlsasink.dll, чтобы не использовать функции интеллектуальной маршрутизации, предоставляемые этой библиотекой. Это делать не рекомендуется, поскольку это может стать причиной проблем быстродействия и надежности. В таком случае рекомендуется переустановить Exchange на соответствующем компьютере, чтобы установить и зарегистрировать библиотеку xlsasink.dll.

Вторая причина появления этого предупреждения может заключаться в использовании антивирусного продукта, который устанавливает и использует свой стек протокола SMTP для проверки сообщений. В этом случае антивирусное программное обеспечения может запускать свой стек SMTP для перехвата и проверки сообщений перед тем, как они достигают стека SMTP сервера Exchange. При этом стек SMTP антивирусной программы не использует команду X-LINK2STATE. Рекомендуется запускать антивирусную программу в режиме, не требующем установки собственного стека SMTP на сервере Exchange.

Дополнительные сведения о команде X-LINK2STATE и других командах, используемых сервером Exchange, см. в базе знаний Майкрософт в статье 812455, посвященной определениям команд, используемых между двумя серверами Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=812455).

Дополнительные сведения о просмотре команд Exchange и переустановке Exchange 2000 Server см. в базе знаний Майкрософт в статье 319885, посвященной проблемам доставки сообщений, отправленных в организации Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319885)

Дополнительные сведения о просмотре команд Exchange и переустановке Exchange Server 2003 см. в базе знаний Майкрософт в статье 822939, посвященной проблемам доставки сообщений, отправленных в организации Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822939).


SMTP-сервер не прошел тест на прием почты
Анализатор сервера Microsoft Exchange — статьи > Сеть >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange пытается отправить сообщение учетной записи администратора почтовой системы для домена SMTP. При этом выполняются следующие задачи:

  • Открытие подключения к серверу SMTP через сокет. Если анализатор сервера Exchange получает код ответа 220, данный этап считается выполненным успешно.

  • Передача SMTP-команды EHLO. Если анализатор сервера Exchange получает ряд кодов ответа 250, включая ответ, содержащий 250-X-LINK2STATE и 250-XEXCH50, данный этап считается выполненным успешно.

  • Передача SMTP-команды MAIL FROM: ExBPA-MailAcceptTest@Fabrikam.com. Если анализатор сервера Exchange получает код ответа 250, данный этап считается выполненным успешно.

  • Передача SMTP-команды RCPT TO: Postmaster@<имя_домена>.com. Если анализатор сервера Exchange получает код ответа 250, данный этап считается выполненным успешно.

Если анализатору сервера Exchange не удается выполнить эти этапы, на экран выводится сообщение об ошибке. Данная ошибка может указывать на наличие общей проблемы с потоком почты. Далее приведены ссылки в порядке, в котором должна выполняться процедура устранения неполадок, от уровня сервера к сетевому уровню.

Чтобы устранить эту ошибку

  1. См. раздел по устранению неполадок маршрутизации руководства по транспорту и маршрутизации Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=47579).

  2. См. статью 324867 базы знаний Майкрософт по веб-презентации службы поддержки Майкрософт, посвященной устранению неполадок с потоком почты в Microsoft Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324867).

  3. См. статью 823489 базы знаний Майкрософт, описывающую использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489).

  4. См. статью 324759 базы знаний Майкрософт по веб-презентации службы поддержки Майкрософт, посвященной устранению неполадок DNS для транспорта в Microsoft Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324759).

Дополнительные сведения об учетной записи администратора почтовой системы в Exchange Server см. в следующих статьях базы знаний Майкрософт:

  • Статья 223860, описывающая необходимость ручной настройки почтового ящика SMTP администратора почтовой системы (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=223860)

  • Статья 313832, содержащая инструкции по настройке учетной записи SMTP администратора почтовой системы в Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313832)


SMTP-сервер не прошел тест открытой ретрансляции
Анализатор сервера Microsoft Exchange — статьи > Сеть >

Дата последнего изменения раздела: 2007-03-14

Анализатор сервера Microsoft® Exchange пытается передать сообщение через SMTP-сервер, выполняя следующие задачи:

  • Открытие сокет-подключения к серверу SMTP. Если анализатор сервера Exchange получает код отклика 220, считается, что этот шаг завершен успешно.

  • Передача команды SMTP EHLO. Если анализатор сервера Exchange получает ряд кодов отклика 250, в том числе отклик, который содержит код 250-X-LINK2STATE и 250-XEXCH50, считается, что этот шаг завершен успешно.

  • Передача команды SMTP MAIL FROM: ExBPA-OpenRelayTest@Fabrikam.com. Если анализатор сервера Exchange получает код отклика 250, считается, что этот шаг завершен успешно.

  • Передача команды SMTP RCPT TO: ExBPA-OpenRelayTest@Fabrikam.com. Если анализатор сервера Exchange получает код отклика 250, считается, что этот шаг завершен успешно.

Анализатор сервера Exchange также запрашивает класс инструментария управления Microsoft Windows (WMI) Win32_OperatingSystem, чтобы определить значение ключа OSProductSuite. Значение этого ключа соответствует определенной версии операционной системы сервера Windows.

Если анализатор сервера Exchange может успешно выполнить все шаги на компьютере сервера Exchange, который входит в состав установки Microsoft Small Business Server 2000 или Microsoft Windows Small Business Server 2003, возвращается ошибка.

Эта ошибка означает, что данный сервер настроен как открытый ретранслятор.

Включать открытую ретрансляцию не рекомендуется.

Открытая ретрансляция имеет место, когда почтовый сервер разрешает передавать почтовые сообщения через систему без каких-либо ограничений или какой-либо обработки транзитной электронной почты.

Примечание.
Данная ошибка может возникнуть, если по некоторым причинам в организации Exchange используется SMTP-домен по имени Fabrikam.com. В этом случае можно безопасно игнорировать эту ошибку. Домен Fabrikam.com принадлежит корпорации Майкрософт и используется для обучения, распространения документации и подобных целей.

Сама по себе ретрансляция как технология не имеет каких-либо отрицательных аспектов, поскольку протокол SMTP был разработан именно с этой целью (дополнительные сведения см. в документе RFC 2821, разделы 2.1 и 3.7 (http://ietf.org)). Однако если ретрансляцией не управлять (неконтролируемые серверы называются открытыми серверами ретрансляции), ее потенциально могут использовать для массовой рассылки нежелательных почтовых сообщений (спама или навязчивой рекламы). Перебрасывая эти нежелательные сообщения между промежуточными серверами, недобросовестные пользователи пытаются скрыть данные их идентификации. При этом также расходуются ресурсы на сервере ретрансляции, что может мешать ему обрабатывать допустимые сообщения. В большинстве случаев пользователи, которые занимаются рассылкой таких нежелательных сообщений, отправляют одно сообщение огромному числу получателей, не используя при этом свою собственную пропускную способность.

Анонимная ретрансляция на виртуальных SMTP-серверах, доступных из Интернета, должна быть запрещена. В стандартной конфигурации Exchange ретрансляция почты разрешается только пользователям, прошедшим проверку подлинности. Только пользователи, прошедшие проверку подлинности, могут использовать Exchange для отправки почты на внешние домены. Если изменить применяемые по умолчанию настройки ретрансляции, чтобы разрешить ретрансляцию не прошедшим проверку подлинности пользователям, или если разрешить открытую ретрансляцию на домен через соединитель, неавторизованные пользователи и опасные сетевые черви могут использовать сервер Exchange для рассылки спама. Сервер может быть занесен в список блокируемых доменов, что приведет к невозможности отправлять почту доверенным удаленным серверам. Чтобы воспрепятствовать неавторизованными пользователям использовать сервер Exchange для ретрансляции почты, нужно как минимум использовать применяемые по умолчанию ограничения ретрансляции.

При наличии законных оснований для ретрансляции следуйте стандартным инструкциям, чтобы обеспечить безопасность своей среды. Обычно для этого нужно оставить все установленные по умолчанию запреты и добавить только IP-адреса, переданная с которых почта должна приниматься, и отключить доступ для пользователей, прошедших проверку подлинности.

Проверьте, как встроенные учетные записи (локальный администратор) и другие пользователи используются на шлюзовых серверах. Маловероятно, что встроенные учетные записи используются для какого-либо вида ретрансляции. Если используется ретрансляция, она, вероятно, осуществляется известным набором пользователей или компьютеров. Рекомендуется ограничить права ретрансляции для явных пользователей и компьютеры или на определенный IP-адрес.

Дополнительно обезопасить сервер поможет установка явного разрешения на ретрансляцию. Опасные пользователи могут использовать атаки с перебором, пытаясь получить пароли встроенных учетных записей или учетных записей пользователей, найденных в Интернете, для использования соответствующих серверов как прокси-серверов для рассылки нежелательной почты. Поэтому настройка по умолчанию, которая разрешает ретрансляцию любому компьютеру, прошедшему проверку подлинности, для компьютеров, доступных из Интернета, не рекомендуется. Этот параметр рекомендуется отключить.

В следующих процедурах показано, как отключить анонимную ретрансляцию в зависимости от того, доступен ли виртуальный SMTP-сервер из Интернета. Как уже упоминалось ранее в этой статье, включение любого вида анонимной ретрансляции допустимо только в случаях, когда риск безопасности понятен и приемлем для организации. Ссылки в конце этой статьи содержат подробные сведения об использовании ретрансляции.

Если виртуальный SMTP-сервер недоступен из Интернета, рекомендуется восстановить конфигурацию ретрансляции к значениям по умолчанию. При этом виртуальные SMTP-серверы будет разрешать только внутреннюю ретрансляцию от компьютеров, прошедших проверку подлинности.

Для виртуальных SMTP-серверов, доступных из Интернета, рекомендуется дополнительно обезопасить применяемые по умолчанию конфигурации ретрансляции таким образом, чтобы позволить ретрансляцию только пользователям и компьютерам с явным разрешением.

Если на сервере Exchange настроена блокировка ретрансляции, но в анализаторе сервера Exchange все еще возникает эта ошибка, проверьте, не разрешает ли анонимную ретрансляции какой-либо прокси-сервер или процесс, такой как межсетевой экран, антивирус или программное обеспечение противодействия нежелательной почте.

Чтобы восстановить настройки по умолчанию для конфигураций анонимной ретрансляции на внутренних виртуальных SMTP-серверах

  1. Откройте диспетчер Exchange.

  2. В дереве консоли разверните узел Серверы, разверните нужный сервер, разверните узел Протоколы, а затем разверните узел SMTP.

  3. Щелкните правой кнопкой мыши виртуальный сервер SMTP, на котором нужно применить ограничения ретрансляции, и в контекстном меню выберите Свойства.

  4. В окне <Виртуальный сервер SMTP:> Свойства, откройте вкладку Доступ и выберите Ретрансляция.

  5. В разделе Ограничения ретрансляции в поле Выберите компьютер для ретрансляции через этот виртуальный сервер выберите Только указанные в списке, установите флажок Разрешить ретрансляцию всем компьютерам, которые успешно прошли проверку подлинности, независимо от указанных в списке и нажмите кнопку ОК.

Чтобы настроить явное разрешение на ретрансляцию для виртуальных SMTP- серверов, доступных из Интернета, на сервере Exchange 2003

  1. Откройте диспетчер Exchange.

  2. В дереве консоли разверните узел Серверы, разверните нужный сервер, разверните узел Протоколы, а затем разверните узел SMTP.

  3. Щелкните правой кнопкой мыши виртуальный сервер SMTP, на котором нужно применить ограничения ретрансляции, и в контекстном меню выберите Свойства.

  4. В окне <Виртуальный сервер SMTP:> Свойства, откройте вкладку Доступ и выберите Ретрансляция.

  5. В разделе Ограничения ретрансляции снимите флажок Разрешить ретрансляцию всем компьютерам, которые успешно прошли проверку подлинности, независимо от указанных в списке и затем нажмите кнопку Пользователи, чтобы указать подмножество пользователей, которым будут предоставлены разрешения на ретрансляцию на этом виртуальном SMTP-сервере.

  6. Чтобы удалить пользователя или группу, в списке Разрешения на отправку и ретрансляцию выберите группу или пользователя и нажмите кнопку Удалить.

  7. Чтобы добавить группу или пользователя, нажмите кнопку Добавить и затем выберите пользователей или группу, для которых нужно задать разрешения. Выполните одну из следующих процедур:

    • В Microsoft Windows Server™ 2003 в окне Выбор: Пользователи, Компьютеры или Группы в поле Введите имена выбираемых объектов введите имя пользователя или группы. Чтобы найти пользователя или группу, нажмите кнопку Дополнительно, найдите имя пользователя или группы и нажмите кнопку Проверка имен, чтобы проверить правильность ввода.

      Совет.
      Щелкните ссылку примеры, чтобы просмотреть допустимые форматы для ввода.
    • В Windows 2000 Server в окне Выбор: Пользователи, Компьютеры или Группы выберите группу или пользователей, которым нужно предоставить разрешения на отправку, и нажмите кнопку Добавить.

  8. Нажмите кнопку ОК, чтобы вернуться к диалоговому окну Разрешения на отправку и ретрансляцию.

  9. В списке Имена групп или пользователей выберите только что добавленную группу.

  10. В разделе Разрешения для <выбранная группа>, рядом с полем Разрешение на отправку при необходимости установите флажок Разрешить , чтобы разрешить выбранному пользователю или группе отправлять почту через данный виртуальный SMTP-сервер.

  11. Рядом с полем Разрешения на ретрансляцию установите флажок Разрешить, чтобы разрешить выбранному объекту ретрансляцию через данный виртуальный SMTP-сервер, или установите флажок Запретить, чтобы воспрепятствовать ретрансляции выбранным объектом через этот виртуальный сервер.

    Примечание.
    Если требуется разрешить ретрансляцию, необходимо предоставить также разрешения на отправку.

  12. Нажмите кнопку ОК.

Чтобы настроить разрешение на ретрансляцию для виртуальных SMTP- серверов, доступных из Интернета, на сервере Exchange 2000

  1. Откройте диспетчер Exchange.

  2. В дереве консоли разверните узел Серверы, разверните сервер, который нужно настроить, разверните узел Протоколы, а затем разверните узел SMTP.

  3. Щелкните правой кнопкой мыши виртуальный сервер SMTP, на котором нужно применить ограничения ретрансляции, и в контекстном меню выберите Свойства.

  4. В окне <Виртуальный сервер SMTP:> Свойства, откройте вкладку Доступ и выберите Ретрансляция.

  5. В разделе «Выберите компьютер для ретрансляции через этот виртуальный сервер» выберите вариант Только указанные в списке.

  6. Нажмите кнопку Добавить, чтобы добавить отдельный компьютер, группу компьютеров или имя домена SMTP, и нажмите кнопку ОК. Повторите этот шаг для каждого дополнительного объекта, который нужно добавить.

  7. Установите флажок Разрешить ретрансляцию всем компьютерам, которые успешно прошли проверку подлинности, независимо от указанных в списке и затем дважды нажмите кнопку ОК.

Дополнительные сведения о ретрансляции сообщений и безопасности см. в следующих руководствах из технической библиотеки сервера Exchange 2003:

  • Руководство по транспорту и маршрутизации сервера Exchange 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Противодействие вирусам, распространяемым через электронную почту, в среде Exchange 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=47587)

Дополнительные сведения о тестировании и защите открытой ретрансляции в среде Exchange и Microsoft Windows см. в статье 304897 базы знаний корпорации Майкрософт «SMTP relay behavior in Windows 2000, Windows XP, and Exchange Server» (Особенности SMTP-ретрансляции в Windows 2000, Windows XP и Exchange Server) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=304897).


Выполняемая версия SMTP не поддерживает команду XEXCH50
Анализатор сервера Microsoft Exchange — статьи > Сеть >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запускает сеанс SMTP с сервером Exchange, чтобы проверить, что отображены допустимые команды Exchange SMTP. Если команда XEXCH50 отсутствует, отображается предупреждение.

Помимо других функций, команда XEXCH50 используется для репликации общих папок. Выполнение версии SMTP на сервере Exchange, не поддерживающей команду XEXCH50, приведет к остановке репликации общих папок.

Команда XEXCH50 не используется другими поставщиками SMTP; поэтому функции обеспечены в файле peexch50.dll, который устанавливается и регистрируется программой установки Exchange.

Анализатор сервера Exchange может отобразить это предупреждение, если выполняется антивирусное программное обеспечение, установившее и использующее собственный стек протокола SMTP для проверки сообщений. В этом случае антивирусное приложение использует собственный стек SMTP для перехвата и проверки сообщений, прежде чем они достигнут стека SMTP Exchange. В этом случае стек SMTP антивирусного программного обеспечения не использует команду XEXCH50.

Рекомендуется выполнять антивирусное программное обеспечение в режиме, при котором не требуется установка собственного стека SMTP на сервере Exchange, или выполнять это программное обеспечение на входящем периметре сети SMTP. Если стек SMTP антивирусного программного обеспечения отключен, но предупреждение все еще появляется, переустановите Exchange и правильно зарегистрируйте библиотеку peexch50.dll.

Дополнительные сведения о команде XEXCH50 и других внутренних командах, используемых Exchange, см. в статье 812455 базы знаний Майкрософт, посвященной определениям команд, которые используются между двумя серверами Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=812455).

Дополнительные сведения о просмотре команд Exchange и переустановке Exchange 2000 Server см. в статье 319885 базы знаний Майкрософт, посвященной недоставленым сообщениям в организации Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319885).

Дополнительные сведения о просмотре команд Exchange и переустановке Exchange Server 2003 см. в статье 822939 базы знаний Майкрософт, посвященной недоставленным сообщениям в организации в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822939).


Протоколы
Анализатор сервера Microsoft Exchange — статьи >

Дата последнего изменения раздела: 2005-11-18

Статьи в этой части содержат сведения о параметрах, оцениваемых средством анализатора сервера Microsoft® Exchange для протоколов Интернета. Кроме того, в этих статьях описываются действия, которые можно предпринять, чтобы устранить проблемы, касающиеся протоколов Интернета и обнаруживаемые анализатором сервера Exchange, такие как ошибки, предупреждения и конфигурации, отличные от конфигураций по умолчанию.


Ошибка ответа при циклическом обмене со службой Active Directory
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_PingStatus, чтобы определить значение (раздела StatusCode), возвращаемое сервером службы каталогов Active Directory®. Win32_PingStatus возвращает объект, имеющий 24 свойства, которые предоставляют обширные сведения о пакетах для проверки связи, отправляемых классом.

Если анализатор сервера Exchange обнаруживает, что значение для этого раздела совпадает с одним из значений в следующей таблице, на экран выводится сообщение об ошибке.

Анализатор сервера Exchange отображает имя сервера службы Active Directory и соответствующее значение StatusCode, возвращаемое с этой ошибкой.

Значение StatusCode Значение Описание

11001

Слишком малый буфер

Выдача этого сообщения об ошибке маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11002

Сеть назначения недоступна

Сбой запроса, т.к. сеть, содержащая конечный компьютер, недоступна, к конечному компьютеру не существует действующего маршрута.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487 "How to troubleshoot network connectivity problems" (Устранение неполадок сетевых подключений) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11003

Узел назначения недоступен

Запрос не прошел, так как конечный компьютер недоступен.

Дополнительные сведения см. в разделе Сервер Active Directory остановлен или недоступен.

В альтернативном случае, эта ошибка может быть вызвана наличием сетевого экрана между компьютером, на котором выполняется анализатор сервера Exchange, и целевым контроллером домена или даже DNS-ошибкой

Дополнительные сведения см. в базе знаний в статье 325487 "How to troubleshoot network connectivity problems" (Устранение неполадок сетевых подключений) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11004

Целевой протокол недоступен

Запрос не прошел, так как конечный компьютер не отвечает на протокол пакета.

Эта ошибка может быть вызвана наличием сетевого экрана между компьютером, на котором выполняется анализатор сервера Exchange, и целевым контроллером домена.

11005

Порт назначения недоступен

Запрос не прошел, так как порт на конечном компьютере недоступен.

Дополнительные сведения см. в базе знаний в статье 325487 "How to troubleshoot network connectivity problems" (Устранение неполадок сетевых подключений) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11006

Отсутствуют ресурсы

Запрос не прошел из-за нехватки сетевых ресурсов.

Дополнительные сведения см. в базе знаний в статье 325487 "How to troubleshoot network connectivity problems" (Устранение неполадок сетевых подключений) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11007

Неправильный параметр

Запрос не прошел, так как содержит недопустимый параметр.

Выдача этого сообщения об ошибке маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11008

Ошибка оборудования

Запрос не прошел из-за ошибки оборудования.

Проверьте правильность работы контроллера домена, запустив средство проверки исправности оборудования поставщика компьютера.

11009

Слишком большой пакет

Запрос не прошел, так как пакет, содержащий запрос, больше наибольшего размера передаваемых данных узла (маршрутизатора или шлюза), расположенного между исходным и конечным пунктами. Наибольший размер передаваемых данных определяет наибольший размер передаваемого пакета.

Объем запроса, отправляемого анализатором сервера Exchange, не превышает 10 КБ. Убедитесь, что маршрутизаторы и шлюзы в организации правильно настроены.

Дополнительные сведения см. в базе знаний в статье 159211 "Diagnoses and Treatment of Black Hole Routers" (Диагностика и устранение неполадок маршрутизаторов, действующих как черные дыры) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211).

11010

Блокировка запроса по времени

Ответ не получен в отведенное время. Время по умолчанию, отведенное для получения ответов, равно 5 секундам.

Дополнительные сведения см. в базе знаний в статье 325487 "How to troubleshoot network connectivity problems" (Устранение неполадок сетевых подключений) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11011

Неправильный запрос

Запрос не прошел из-за неправильного кода запроса.

Выдача этого сообщения об ошибке маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11012

Неправильный маршрут

Запрос не прошел, так как отсутствует действующий маршрут между исходным и конечным компьютерами.

Дополнительные сведения см. в базе знаний в статье 325487 "How to troubleshoot network connectivity problems" (Устранение неполадок сетевых подключений) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11013

Истек срок жизни во время передачи пакета

Запрос не прошел, т.к. значение срока жизни достигло нуля, что заставляет пересылающий узел (мршрутизатор или шлюз) сбросить пакет.

Дополнительные сведения см. в базе знаний в статье 325487 "How to troubleshoot network connectivity problems" (Устранение неполадок сетевых подключений) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11014

Истек срок жизни во время повторной сборки пакета

Запрос не прошел, так как пакет был поделен на фрагменты для передачи и все фрагменты не были получены в период времени, отведенный для повторной сборки пакета. Документ RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) определяет 60 секунд в качестве предельного времени, в течение которого все фрагменты пакета должны быть получены.

Дополнительные сведения см. в базе знаний в статье 325487 "How to troubleshoot network connectivity problems" (Устранение неполадок сетевых подключений) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11015

Проблема параметров

Запрос не прошел из-за проблем узла (маршрутизатора или шлюза), возникших при обработке заголовка пакета. Например, такая ситуация может возникнуть, если заголовок содержит недопустимые данные в поле или нераспознанный параметр.

Выдача этого сообщения об ошибке маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11016

Снизить скорость

Запрос не прошел из-за сброса пакета. Это происходит, когда выходная очередь исходного компьютера не имеет достаточного места для хранения запросов, или когда пакеты прибывают в пункт назначения слишком быстро, чтобы быть обработанными.

Выдача этого сообщения об ошибке маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11017

Слишком большой параметр

Запрос не прошел, так как содержит недопустимый параметр.

Выдача этого сообщения об ошибке маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11018

Неправильный пункт назначения

Запрос не прошел, т.к. по IP-адресу назначения невозможно получить запросы проверки связи или IP-адрес никогда не должен отображаться в поле адреса назначения какой-либо диаграммы IP.

Эта ошибка может быть вызвана наличием сетевого экрана между компьютером, на котором выполняется анализатор сервера Exchange, и целевым контроллером домена.

11032

Согласование с протоколом IPSEC

Запрос не прошел, так как не удалось согласовать подключение IPsec.

11050

Общая ошибка

Запрос не прошел по неизвестной причине.

Дополнительные сведения см. в базе знаний в статье 325487 "How to troubleshoot network connectivity problems" (Устранение неполадок сетевых подключений) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).


Ошибка ответа при циклическом обмене данными между службой Active Directory и сервером Exchange
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2006-05-15

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс Win32_PingStatus (Microsoft Windows® Management Instrumentation), чтобы определить значение ключа StatusCode, возвращаемое с сервера службы каталогов Active Directory®. Win32_PingStatus возвращает объект, имеющий 24 свойства, которые предоставляют обширные сведения о ping-пакетах, отправляемых классом.

Если анализатор сервера Exchange обнаруживает, что значение этого ключа совпадает с одним из значений в следующей таблице, анализатор сервера Exchange выводит на экран сообщение об ошибке.

Анализатор сервера Exchange отображает имя сервера службы Active Directory, имя сервера Exchange и соответствующее значение StatusCode, возвращаемое с этой ошибкой.

Значение StatusCode Значение Описание

11001

Слишком малый буфер

Эта ошибка маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11002

Конечная сеть недостижима

Запрос не прошел, так как сеть, содержащая целевой компьютер, является недостижимой. Не существует действующего маршрута к целевому компьютеру.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11003

Целевой узел недостижим

Запрос не прошел, так как целевой компьютер недостижим.

Дополнительные сведения см. по ссылке Сервер Active Directory остановлен или недоступен.

Или эта ошибка может быть вызвана одной из следующих причин:

  • Между компьютером, на котором выполняется анализатор сервера Exchange, и целевым контроллером домена существует сетевой экран.

  • Ошибка службы DNS.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11004

Целевой протокол недостижим

Запрос не прошел, так как целевой компьютер не отвечает на протокол пакета.

Эта ошибка может быть вызвана наличием сетевого экрана между компьютером, на котором выполняется анализатор сервера Exchange, и целевым контроллером домена.

11005

Конечный порт недостижим

Запрос не прошел, так как порт на целевом компьютере недоступен.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11006

Отсутствуют ресурсы

Запрос не прошел из-за нехватки сетевых ресурсов.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11007

Неправильный параметр

Запрос не прошел, так как содержит недопустимый параметр.

Эта ошибка маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11008

Ошибка оборудования

Запрос не прошел из-за ошибки оборудования.

Убедитесь в работоспособности контроллера домена, запустив средство проверки оборудования, поставляемое производителем компьютера.

11009

Слишком большой пакет

Запрос не прошел, так как пакет, содержащий запрос, больше максимального блока передачи (MTU) узла маршрутизатора или шлюза, который находится между исходным и конечным пунктами. Максимальный блок передачи (MTU) определяет максимальный размер передаваемого пакета.

Запрос, отправляемый анализатором сервера Exchange, не превышает 10 КБ. Убедитесь, что маршрутизаторы и шлюзы в организации правильно настроены.

Дополнительные сведения см. в базе знаний Майкрософт в статье 159211, описывающей обнаружение и устранение маршрутизаторов, действующих как черные дыры (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211).

11010

Блокировка запроса по времени

Ответ не получен в отведенное время. Время по умолчанию, отведенное для получения ответов, равно 5 секундам.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11011

Неправильный запрос

Запрос не прошел из-за неправильного кода запроса.

Эта ошибка маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11012

Неправильный маршрут

Запрос не прошел, так как отсутствует действующий маршрут между исходным и конечным компьютерами.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11013

Истек срок жизни во время передачи пакета

Запрос не прошел, так как значение его срока жизни достигло нуля. Это привело к сбросу пакета запроса пересылающим маршрутизатором или шлюзом.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11014

Истек срок жизни во время повторной сборки пакета

Запрос не прошел, так как пакет был поделен на фрагменты для передачи, и все фрагменты не были получены в отведенное время для повторной сборки пакета. Документ RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) определяет 60 секунд в качестве предельного времени, в течение которого все фрагменты пакета должны быть получены.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11015

Проблема параметров

Запрос не прошел из-за проблем узла маршрутизатора или шлюза, возникших при обработке заголовка пакета. Такая ситуация может возникнуть, если заголовок содержит недопустимые данные в поле или нераспознанный параметр.

Эта ошибка маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11016

Обрыв источника

Запрос не прошел из-за сброса пакета. Это происходит, когда выходная очередь исходного компьютера не имеет достаточного места для хранения запросов. Или такая ситуация может возникнуть, когда пакеты поступают в конечный пункт слишком быстро и не успевают обрабатываться.

Эта ошибка маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11017

Слишком большой параметр

Запрос не прошел, так как содержит недопустимый параметр.

Эта ошибка маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11018

Неправильный конечный пункт

Запрос не прошел по одной из следующих причин:

  • На конечный IP-адрес не могут приниматься запросы PING.

  • Конечный IP-адрес никогда не должен появляться в поле конечного адреса какой-либо IP-датаграммы.

Эта ошибка может быть вызвана наличием сетевого экрана между компьютером, на котором выполняется анализатор сервера Exchange, и целевым контроллером домена.

11032

Согласование с протоколом IPSEC

Запрос не прошел, так как не удалось согласовать подключение IPsec.

11050

Общая ошибка

Запрос не прошел по неизвестной причине.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).


Для клиентов IMAP и POP разрешен анонимный доступ на внутренних виртуальных SMTP-серверах и выделенных виртуальных SMTP-серверах
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchAuthenticationFlags в классе protocolCfgSMTPServer для объекта Exchange Server. Класс protocolCfgSMTPServer содержит параметры виртуального SMTP-сервера. Атрибут msExchAuthenticationFlags представляет тип проверки подлинности, допустимый на SMTP-сервере. Анализатор сервера Exchange выводит на экран предупреждающее сообщение, если выполняются следующие условия:

  • Для атрибута msExchAuthenticationFlags настроена проверка подлинности, разрешающая анонимный доступ к SMTP-серверу.

  • Сервер Exchange работает не под управлением Microsoft Small Business Server 2000 или Microsoft Windows® Small Business Server 2003.

  • Сервер Exchange поддерживает более 20 почтовых ящиков.

Для усиления безопасности следует отключить анонимный доступ на внутренних виртуальных SMTP-серверах, которые не принимают входящую почту из Интернета. Для усиления безопасности можно также отключить анонимный доступ на выделенных виртуальных SMTP-серверах для удаленных пользователей IMAP и POP.

Важно!
Не отключайте анонимный доступ на виртуальных SMTP-серверах, которые являются узловыми транспортными серверами Интернета. На виртуальных SMTP-серверах, которые принимают почту из Интернета, анонимный доступ должен быть разрешен.

При отправке внутренней почты серверы Exchange в организации проверяют подлинность друг друга. Поэтому включать анонимный доступ на внутренних виртуальных SMTP-серверах не требуется. При запрещенном анонимном доступе на внутренних серверах поток почты не нарушается, и на внутреннем виртуальном SMTP-сервере обеспечивается дополнительный слой безопасности.

Точно так же клиенты IMAP и POP перед отправкой почты на виртуальные SMTP-сервера проверяют их подлинность. Поэтому если для клиентов IMAP и POP используются выделенные виртуальные SMTP-серверы, эти серверы можно настроить таким образом, чтобы разрешить только доверенный доступ. Отключение анонимного доступа на этих серверах закроет доступ к ним неавторизованных пользователей.

Если на виртуальном SMTP-сервере нельзя отключить доступ с проверкой подлинности (например, требуется проверка подлинности для партнерской компании), для повышения безопасности сервера шлюза выполните следующие действия:

  • Примените политику надежного пароля для всех учетных записей пользователя, особенно для учетной записи администратора.

  • Отключите учетную запись «Гость». Дополнительные сведения об отключении учетной записи «Гость» см. в статье 320053 базы знаний Майкрософт, описывающей переименование учетной записи гостя и администратора в системе Windows 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320053). Хотя эта статья относится к Windows 2000 Server, аналогичные принципы применимы и в Windows Server 2003.

Чтобы отключить проверку подлинности для анонимного доступа к виртуальному SMTP-серверу

  1. В диспетчере Exchange разверните узел Серверы, затем <your inbound Exchange server>, затем Протоколы и SMTP.

  2. Щелкните правой кнопкой мыши входящий виртуальный SMTP-сервер и выберите команду Свойства.

  3. Откройте вкладку Доступ и щелкните Проверка подлинности.

  4. В диалоговом окне Проверка подлинности снимите флажок Анонимный доступ.

Дополнительные инструкции по настройке организации Exchange Server 2003 для более безопасной отправки и получения почты через Интернет см. в руководстве по транспорту и маршрутизации Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).


Включена фоновая антивирусная проверка
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, включена ли фоновая антивирусная проверка, анализатор сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Если анализатор сервера Exchange определяет, что для параметра BackgroundScanning задано значение 1, на экран выводится предупреждение.

Если параметр реестра BackgroundScanning и равен 1, все сообщения повторно просматриваются в фоновом режиме при каждом обновлении файла описаний вирусов антивирусной программы. Это действие существенно сказывается на производительности при каждом обновлении файла описаний вирусов антивирусной программы и поэтому корпорацией Майкрософт не рекомендуется.

Если при использовании антивирусной программы, которая поддерживает интерфейс VSAPI (Virus Scanning Application Programming Interface) 2.0 клиент пытается открыть сообщение, выполняется сравнение с целью подтверждения, что тело и вложение сообщения были проверены с применением текущего файла описаний вирусов. Если текущий файл описаний вирусов еще не использовался для проверки содержимого, то прежде чем это сообщение будет доставлено клиенту, антивирусная программа получит соответствующее сообщение.

Если установленная антивирусная программа не содержит интерфейса пользователя, который позволяет отключить фоновую проверку, можно использовать следующую процедуру ниже для управления этим поведением путем изменения реестра на компьютере сервера Exchange.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

  3. В правой области дважды щелкните параметр BackgroundScanning.

  4. В поле «Значение» измените значение на 0.

  5. Закройте редактор реестра, а затем перезапустите службу банка сообщений Microsoft Exchange и службы антивирусной программы, чтобы изменения вступили в силу.
  • Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

  • Дополнительные сведения о разных видах антивирусных программ, используемых на серверах Exchange, см. в статье 328841 базы знаний Майкрософт, описывающей взаимодействие антивирусного программного обеспечения с Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).


Значение раздела реестра CheckPop3Tail было изменено
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, существует ли следующее значение реестра, средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\CheckPop3Tail

Если анализатор обнаружит, что значение CheckPop3Tail существует и его значение превышает 1, отображается сообщение о нестандартной конфигурации.

В документе RFC 1939 группы IETF (Internet Engineering Task Force) (http://www.ietf.org/rfc/rfc1939.txt) определена последовательность прерывания CRLF для сообщений POP3. В терминологии Exchange последовательность CRLF называется POP3Tail. Если клиент POP3, например, Microsoft Office Outlook® 2003 или Microsoft Outlook Express встречает сообщение неправильного формата с неверным POP3Tail (например, отсутствует CRLF), он способен перестать отвечать на запросы и не сможет загрузить все входящие сообщения. Значение реестра CheckPop3Tail представляет администраторам возможность настроить службу Microsoft Exchange POP3 на проверку POP3Tail каждого сообщения POP3 и добавить правильную последовательность прерывания, если она отсутствует.

Примечание.
С помощью этого параметра сообщения с неправильным форматом будут исправляться, а клиент POP3 сможет загружать все сообщения в почтовый ящик пользователя; однако это также приведет к уменьшению производительности, так как каждое сообщение будет проверяться на наличие правильного POP3Tail.

При необходимости можно использовать следующую процедуру для удаления значения реестра CheckPop3Tail.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы удалить значение реестра CheckPop3Tail

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Удалите значение реестра CheckPop3Tail.

  4. Выйдите из редактора реестра и перезапустите службу Microsoft Exchange POP3, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об использовании раздела реестра CheckPop3Tail, см. в статье 816896 базы знаний Майкрософт, посвященной не отвечающему клиенту POP3 при попытке загрузить сообщения (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816896).


Включена система Defense Message System
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить, был ли настроен атрибут heuristics для включения системы защиты сообщений. По умолчанию атрибут heuristics не включен. Если анализатор сервера Exchange обнаруживает, что значение атрибута heuristics равно 256, будет отображено сообщение о нестандартной конфигурации.

Анализатор сервера Exchange отображает эту конфигурацию только для сведений. Никаких действий выполнять не требуется.

Программа Defense Message System (DMS) была утверждена заместителем министра обороны США, чтобы упростить и скоординировать разработку интегрированной системы пользовательских сообщений, удовлетворяющей требованиям переписки, уменьшающей стоимость и уровень кадрового обеспечения и улучшающей функциональность, безопасность, надежность и доступность.

Дополнительные сведения о Defense Message System см. на веб-узле Lockheed Martin (http://www.lockheedmartin.com).

Примечание.
Веб-адреса могут измениться, поэтому существует вероятность, что указанные веб-узлы будут недоступны.


Предупреждение об отключении клиентов MAPI
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2007-05-01

Чтобы определить, установлена ли блокировка клиента MAPI, анализатор сервера Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable MAPI Clients

Если анализатор рекомендаций сервера Exchange обнаруживает, что значение для Disabled MAPI Clients начинается с -10, -11 или -12, отображается предупреждение.

По умолчанию раздел Disable MAPI Clients не включен. Поэтому администратор может заблокировать соединение отдельных версий Outlook с компьютером, который работает под управлением Exchange 2000 Server, Exchange Server 2003 или Exchange Server 2007.

Если для раздела Disabled MAPI Clients установлено значение, которое начинается с -10, -11 или -12, все диапазоны версий MAPI блокируются. Эти диапазоны соответствуют версиям Outlook 2000, Outlook 2003 и Outlook 2007 и системному помощнику Exchange в Exchange Server 2003. Блокировка системного помощника Exchange, вероятно, приведет к неработоспособности Exchange Server.

Чтобы исправить причину появления этого предупреждения, следуйте рекомендациям и процедурам, приведенным в разделе Разрешен доступ на сервер всем версиям Outlook.

Дополнительные сведения о блокировании подключения отдельных клиентов MAPI к компьютеру, который работает под управлением Exchange 2000 Server или Exchange Server 2003, см. в следующих статьях базы знаний Майкрософт:

  • статья 328240, посвященная ограничениям на стороне сервера для клиентов, которые используются для доступа к почтовым ящиками Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328240);

  • статья 288894, посвященная отключению доступа клиента MAPI к компьютеру, работающему под управлением Exchange Server 2003 или Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=288894).

Дополнительные сведения о блокировании подключения отдельных клиентов MAPI к компьютеру, работающему под управлением Exchange Server 2007, см в разделе о командлете «Set-CasMailbox» командной консоли Exchange в документации Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkId=80698).

Дополнительные сведения о загрузке обновлений системы безопасности для более старых версий Outlook и блокировании других версий Outlook см. в статье Slowing and Stopping E-mail Transmitted Viruses in an Exchange Server 2003 Environment (Замедление и остановка передачи вирусов по электронной почте в среде Exchange Server 2003) (http://go.microsoft.com/fwlink/?LinkId=30732).


Установлено значение DisableSMTPMailboxAddressing
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2006-08-11

Чтобы определить, установлено ли значение для отключения SMTP-адресации (Simple Mail Transfer Protocol) почтового ящика, средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра:

HKeyLocalMachine\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\DisableSMTPMailboxAddressing

Значение параметра DisableSMTPMailboxAddressing, равное 1, указывает, что SMTP-адресация почтовых ящиков отключена (true), тогда как значение, равное 0, указывает, что SMTP-адресация почтовых ящиков не отключена (false).

Если анализатор сервера Exchange определит, что значение параметра DisableSMTPMailboxAddressing установлено в 1 для отключения SMTP-адресации почтовых ящиков, на экран будет выведено предупреждение.

Данная ошибка указывает, что SMTP-адресация почтовых ящиков отключена. Это может быть причиной ошибок синхронизации клиентов Microsoft Exchange ActiveSync, которые подключаются к этому серверу.

Чтобы устранить причины появления данного предупреждения, установите значение параметра DisableSMTPMailboxAddressing равным 0.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы изменить значение параметра «DisableSMTPMailboxAddressing»

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра:

HKeyLocalMachine\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA

  1. В правой области найдите и дважды щелкните параметр DisableSMTPMailboxAddressing

  2. Измените значение с 1 на 0.

  3. Закройте редактор реестра и перезапустите службу сервера, чтобы изменения вступили в силу.

Перед редактированием реестра для получения сведений по редактированию реестра см. статью 256986 базы знаний Майкрософт, содержащую описание реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об ошибке синхронизации, связанной с данным предупреждением, см. в базе знаний Майкрософт, в статье 886346, описывающей ситуацию, когда при синхронизации мобильного устройства с Microsoft Exchange Server 2003 выводится сообщение об ошибке HTTP_500 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=886346).


Распределение пользовательской нагрузки
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2006-09-06

Средство анализатора сервера Microsoft® Exchange определило, что количество операций в секунду для удаленных вызовов процедур высокое на этом сервере.

Если количество операций в секунду для удаленных вызовов процедур высокое на этом сервере, можно указать с помощью средства наблюдения за пользователями сервера Exchange (ExMon), как эта нагрузка будет распределяться. Важно определить, вызвана ли нагрузка одним из следующих обстоятельств:

  • Существует относительно небольшое количество активных пользователей.

  • Нагрузка распределяется между множеством пользователей.

Если определяется, что отдельный пользователь вызывает высокий процентный уровень нагрузки, анализатор сервера Exchange отображает предупреждение, в котором говорится, что высокая нагрузка вызвана отдельным пользователем. Если это не так, анализатор сервера Exchange отображает сообщение, в котором говорится, что нагрузка распределена между многими пользователями.

Примечание.
Трафик удаленных вызовов процедур со временем изменяется. Поэтому может понадобиться осуществить сбор данных несколько раз, чтобы собрать соответственные статистические данные о пользователях, работающих с Exchange.

Кроме того, некоторые обычные пользовательские операции могут вызвать увеличение использования процессора на небольшие промежутки времени. Эту активность не стоит воспринимать всерьез, если только один и тот же пользователь не увеличивает нагрузку на процессор постоянно в течение долгого времени.

Примечание.
Можно без всякого риска проигнорировать данное предупреждение, если источником высокой нагрузки является известная служба или известный процесс, которые, как можно ожидать, будут оказывать большую нагрузку и которые обрабатывают запросы для многих пользователей и создают более высокую нагрузку, чем отдельные пользователи. Примеры служб и процессов, которые могут создавать более высокие нагрузки по сравнению с отдельными пользователями: некоторые службы, синхронизирующие мобильные устройства; серверные процессы, управляющие сведениями о занятости; службы, относящиеся к голосовой почте или к единой системе обмена сообщениями; а также серверные процессы, перемещающие пользователей.
Чтобы устранить эту неполадку

  • Если уровень удаленных вызовов процедур слишком высок (для отдельного пользователя или для всех пользователей), определите, используют ли пользователи службы поиска, сторонние клиентские дополнительные модули или мобильные устройства, синхронизирующие электронную почту с почтовым ящиком пользователя. Дополнительные сведения об устранении неполадок, связанных со сторонними приложениями, см. в разделе Отключение расширений клиента сторонних производителей.

  • Пользователи должны хранить менее 5000 элементов в папках по умолчанию и часто используемых папках.

  • Рекомендуется, чтобы размер почтовых ящиков не превышал 1 ГБ. Пользователям, вызывающим высокую нагрузку, рекомендуется архивировать элементы почтовых ящиков в PST-файл. Затем можно повторно выполнить средство производительности Exchange (Perfmon), чтобы просмотреть, продолжает ли пользователь вызывать высокую нагрузку.

  • Обратитесь к пользователю, чтобы выяснить, какие клиентские приложения могут получать доступ к программе электронной почты. Удалите эти приложения и переустановите их последовательно, чтобы изучить их влияние на сервер.

  • При устранении неполадок, связанных с пользовательской нагрузкой, обычны ошибочно положительные оценки. Поэтому рекомендуется выполнять средство ExMon периодически во время высоких нагрузок, чтобы убедиться в согласованности анализа.

Дополнительные сведения

  • Средство ExMon можно загрузить из центра загрузки Майкрософт (http://go.microsoft.com/fwlink/?LinkId=54983).

  • Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Дополнительные сведения об устранении проблем, связанных с производительностью сервера Exchange, см. на веб-узле, посвященном устранению неполадок, связанных с производительностью сервера Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Дополнительные сведения об устранении неполадок, связанных с вопросами производительности клиента Outlook, см. в статье 905803 базы знаний Майкрософт, посвященной низкой производительности Outlook при работе с папкой, содержащей множество элементов, на сервере Exchange Server 2003 или Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803).

  • Дополнительные сведения о программном обеспечении для поиска см. в статье 905184 базы знаний Майкрософт, посвященной понижению производительности Exchange Server 2003 при работе с программным обеспечением модулей поиска на компьютерах с клиентами Outlook или другими клиентами MAPI (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184).


Виртуальный каталог Exchange для OMA и EAS переопределен
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, был ли изменен адрес прокси-сервера SMTP для Exchange ActiveSync®, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MasSync\Parameters\ExchangeVDir

Если анализатор обнаружит, что значение раздела ExchangeVDir существует и настроено, отображается сообщение о нестандартной конфигурации.

Запись реестра ExchangeVDir используется приложениями Microsoft Outlook® Mobile Access и Exchange ActiveSync. Она определяет виртуальный каталог, который приложения Outlook Mobile Access и Exchange ActiveSync используют для доступа к шаблонам Microsoft Office Outlook для Exchange Server 2003 и WebDAV на фоновых серверах Exchange Server 2003, где хранятся почтовые ящики пользователей.

Если запись ExchangeVDir не существует или для нее не установлено значение, используется значение по умолчанию /Exchange. В противном случае эта запись содержит имя виртуального каталога (включая знак косой черты «/»). Это значение можно изменить, если нужно указать виртуальный каталог для приложения Outlook Mobile Access или Exchange ActiveSync.

Известной проблемой Exchange Server 2003 является невозможность работы мобильных служб Exchange при использовании проверки подлинности на основе форм в топологии с одним компьютером Exchange Server 2003. Если виртуальный каталог /Exchange на фоновом сервере Exchange Server 2003 настроен так, чтобы требовать использования SSL, или когда включена проверка подлинности на основе форм, приложение Outlook Mobile Access не сможет получить доступ к этому виртуальному каталогу. Данная проблема не возникает, если эти настройки включены в виртуальном каталоге /Exchange на сервере переднего плана.

Для решения этой проблемы можно воспользоваться возможностью настройки, предусматривающей создание значения реестра ExchangeVDir.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы вернуть конфигурацию по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра:

    HKLM\System\CurrentControlSet\Services\MasSync\Parameters

  3. Просмотрите и, если необходимо, измените значение ExchangeVDir.

  4. Закройте редактор реестра. После внесения изменения, чтобы изменение вступило в силу, перезагрузите компьютер сервера Exchange.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в статье 256986 базы знаний Майкрософт, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об этом вопросе см. в статье 817317 базы знаний Майкрософт, посвященной тому факту, что сопоставление нескольких прокси-адресов с несколькими фоновыми виртуальными корневыми каталогами на одном и том же сервере не поддерживается (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328).


Обнаружен продукт, совместимый с Exchange VSAPI, но в настоящее время не включенный
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра, чтобы определить, включено ли программное обеспечение, совместимое с VSAPI (Virus Scanning Application Programming Interface), на компьютере сервера Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Анализатор сервера Exchange также опрашивает WMI-класс CIM_Datafile, чтобы определить значение раздела Version для Ese.dll — модуля хранилища базы данных Exchange, также известного как модуль ESE (Extensible Storage Engine).

Наконец, средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumber для всех объектов, класс объекта которых равен msExchExchangeServer. Если строковое значение содержит «Version 5,5», на компьютере работает сервер Exchange 5.5. Если строковое значение содержит «Version 6,0», на компьютере работает сервер Exchange 2000. Если строковое значение содержит «Version 6.5», на компьютере работает сервер Exchange 2003.

Если анализатор сервера Exchange обнаружит, что значение Version не содержит подстроку 6 в качестве части сведений о версии, но значение serialNumber будет указывать, что установлен Exchange 2000 Server или Exchange Server 2003, это значит, что на сервере Exchange работает версия ESE, не предназначенная для Exchange.

Если анализатор сервера Exchange определит, что не предназначенная для Exchange версия ESE не работает и значение раздела реестра VirusScan \Enabled равняется 0, отображается предупреждение. Если анализатор определит, что не предназначенная для Exchange версия ESE работает на сервере Exchange, будет отображено отдельное предупреждение.

Как правило, рекомендуется развертывать антивирусное программное обеспечение, которое предназначено для систем обмена сообщениями на шлюзе SMTP или на компьютерах серверов Exchange, которые содержат почтовые ящики. Чтобы обеспечить наибольшую безопасность, запускайте антивирусное программное обеспечение на шлюзе, который будет обрабатывать все входящие сообщения MIME, и антивирусный сканер на сервере Exchange, использующем VSAPI (Virus Scanning API) версии 2.0.

Кроме того, следует использовать антивирусное программное обеспечение на клиентских компьютерах. Если антивирусное программное обеспечение, предназначенное для систем обмена сообщениями (может анализировать и сканировать MIME), работает на шлюзе или на сервере Exchange, сканирование файлов на рабочих станциях пользователей будет достаточным.

Чтобы устранить причину появления этого предупреждения

  1. В пользовательском интерфейсе антивирусного программного обеспечения включите сканирование VSAPI.

  2. Если проблема не устранена после включения сканирования VSAPI, обратитесь за помощью к поставщику антивирусного программного обеспечения.

Дополнительные сведения о разных видах антивирусных программ, обычно используемых с Microsoft Exchange Server 2003 см. в статье 823166 базы знаний Майкрософт, описывающей антивирусное программное обеспечение для Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Дополнительные сведения о разных видах антивирусных программ, обычно используемых на серверах Microsoft Exchange 2000 см. в статье 328841 базы знаний Майкрософт, описывающей антивирусное программное обеспечение для Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Дополнительные сведения о защите среды Exchange от вирусов, передаваемых по электронной почте, см. на странице, посвященной борьбе с вирусами, распространяемыми по электронной почте, в среде Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47587).


Средство, совместимое с интерфейсом API для поиска вирусов в Exchange, найдено, но установлено неверно
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server Analyzer Tool считывает следующую запись реестра, чтобы определить, установлено ли на компьютере программное обеспечение, поддерживающее интерфейс API для поиска вирусов (VSAPI), и связан ли с ним действительный файл библиотеки:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Если средство анализа Exchange Server Analyzer обнаружит, что в значении Library нет действительного пути, указывающего на файл библиотеки (DLL) антивирусной защиты VSAPI, появится предупреждение.

Обычно рекомендуется использовать антивирусное программное обеспечение, разработанное для систем передачи сообщений, на шлюзе SMTP или на компьютерах Exchange Server, на которых размещаются почтовые ящики. Для максимальной защиты следует установить антивирусное программное обеспечение на шлюзе, которое будет сканировать входящие сообщения MIME, и средство проверки на Exchange Server, использующее VSAPI 2.0 (Exchange 2000 Server) или VSAPI 2.5 (Exchange Server 2003).

Кроме того, следует использовать антивирусное программное обеспечение на клиентских компьютерах. Если используется антивирусное программное обеспечение, предназначенное для систем передачи сообщений (то есть способное анализировать и сканировать MIME) на шлюзе или на Exchange Server, на клиентских компьютерах достаточно использовать средство проверки на уровне файлов.

Устранение ошибки

  1. Удалите, а затем заново установите антивирусное программное обеспечение.

  2. Если и после переустановки программного обеспечения проблема сохраняется, обратитесь за помощью к поставщику антивирусного программного обеспечения.

Для получения дополнительных сведений об антивирусных программах, обычно используемых с Microsoft Exchange Server 2003, см. статью 823166 базы знаний корпорации Майкрософт «Использование антивирусных программ на сервере Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Для получения дополнительных сведений об антивирусных программах, обычно используемых с Microsoft Exchange 2000 Server, см. статью 328841 базы знаний корпорации Майкрософт «Антивирусное программное обеспечение для Exchange» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Для получения дополнительных сведений о том, как усилить защиту среды Exchange против вирусов и червей, распространяемых по электронной почте, см. статью «Пресечение деятельности вирусов, распространяемых по электронной почте, в среде Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=47587).


Малое число потоков VSAPI Exchange
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Для определения значения параметра ScanningThreads анализатор сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Значение реестра ScanningThreads представляет максимальное число потоков интерфейса антивирусного сканирования (VSAPI), создаваемых для сканирования.

Анализатор сервера Exchange также считывает следующий раздел реестра, чтобы определить, включено ли сканирование сообщений VSAPI:

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Значение 1 означает, что сканирование VSAPI Включено. Значение 0 означает, что сканирование VSAPI не включено.

Анализатор сервера Exchange также запрашивает класс инструментария управления Windows (WMI) Win32_ComputerSystem, чтобы определить значение параметра NumberOfProcessors. Это значение представляет число процессоров, установленных на компьютере, включая физические и логические процессоры. Технология Hyper-Threading компании Intel позволяет разделять физический процессор на два логических процессора.

Если анализатор сервера Exchange определяет, что значение ScanningThreads на компьютере сервера Exchange с включенным сканированием VSAPI меньше, чем (2 ? NumberOfProcessors) + 1, выводится предупреждение. Оптимальное значение ScanningThreads равно (2 ? NumberOfProcessors) + 1. Например, на компьютере сервера Exchange с двумя процессорами оптимальное значение для ScanningThreads равно 5.

Примечание.
Если режим Hyper-Threading включен, значением NumberOfProcessors будет удвоенное число физических процессоров. Рекомендуется уточнить у изготовителя антивирусного программного обеспечения, какие процессоры должны использоваться в вышеупомянутой формуле: физические или логические.
Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неполадок. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

  3. В правой области дважды щелкните параметр ScanningThreads.

  4. Введите значение, рассчитанное по вышеупомянутой формуле.

  5. Закройте редактор реестра и перезапустите службу Банк сообщений Microsoft Exchange, чтобы изменение вступило в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт "Description of the Microsoft Windows Registry" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения о технологии Hyper-Threading см. на веб-узле Intel (http://www.intel.com/technology/hyperthread).

Примечание.
Веб-адреса могут измениться, поэтому существует вероятность, что вам не удастся подключиться к упомянутым здесь веб-узлам.


Для SMTP используется внешний DNS-сервер
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchSMTPExternalDNSServers в классе protocolCfgSMTPServer для объекта Exchange Server. Класс protocolCfgSMTPServer содержит параметры виртуального сервера SMTP. Если значение атрибута msExchSMTPExternalDNSServers задано, виртуальный сервер SMTP использует внешний DNS-сервер. Если анализатор сервера Exchange обнаруживает, что для атрибута msExchSMTPExternalDNSServers задано значение, на экран выводится предупреждение.

Если для виртуального сервера SMTP задано использование внешнего DNS-сервера, производительность может снизиться. Поэтому использовать такую конфигурацию не рекомендуется.

Чтобы изменить настройку внешнего DNS-сервера для виртуального сервера SMTP

  1. В системном диспетчере Exchange разверните узел Серверы, затем узел <входящего сервера Exchange>, узел Протоколы и узел SMTP.

  2. Щелкните правой кнопкой мыши виртуальный сервер SMTP и выберите команду Свойства.

  3. Откройте вкладку Доступ и нажмите кнопку Дополнительно.

  4. Нажмите кнопку Настройка для настройки внешних DNS-серверов.

  5. Чтобы добавить внешний DNS-сервер, нажмите кнопку Добавить, введите IP-адрес внешнего DNS-сервера в диалоговом окне Добавление, а затем нажмите кнопку ОК.

  6. Чтобы удалить внешний DNS-сервер, выделите IP-адрес и нажмите кнопку Удалить.

  7. Нажмите кнопку ОК.

Дополнительные сведения по настройке службы SMTP в организации Exchange Server 2003 см. в разделе, посвященном настройке DNS, руководства по транспорту и маршрутизации Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).

Дополнительные сведения по настройке DNS-соединителей для связи с доменами Интернета в Exchange см. в статье 319426 базы знаний Майкрософт (может быть на английском языке) (http://go.microsoft.com/fwlink/?Linkid=3052&kbid=319426).


Клиентский сервер использует бычную проверку подлинности
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующий параметр реестра, чтобы определить, настроена ли обычная проверка подлинности между клиентским и фоновым серверами:

HKEY_LOCAL_MACHINE\CurrentControlSet\Services\MSExchangeWeb\DAV\UseBasicAuthToBE

Если анализатор сервера Exchange Server обнаружит, что указан раздел UseBasicAuthToBE реестра, отображается сообщение о нестандартной настройке.

По умолчанию клиентские серверы Exchange Server 2003 используют проверку подлинности Kerberos, чтобы защитить учетные данные пользователей при взаимодействии клиентских и фоновых серверов. Если при проверке подлинности Kerberos возникнет ошибка, в журнал будет записано предупреждающее событие, и клиентский сервер попытается применить проверку подлинности NTLM. Если при проверке подлинности NTLM возникнет ошибка, в журнал будет записана ошибка. Через 30 минут будет предпринята новая попытка выполнения проверки подлинности Kerberos. Когда клиентские компьютеры Exchange 2000 Server или Exchange Server 2003 выполняют проверку подлинности при взаимодействии с клиентскими компьютерами Exchange 2000 Server, используется проверка подлинности NTLM.

Параметр UseBasicAuthToBE раздела реестра заменяет эту логику по умолчанию и предписывает клиентским серверам Exchange использовать обычную проверку подлинности для всех сеансов связи с клиентскими серверами. Если в организации Exchange имеется более 1000 хранилищ почтовых ящиков, следует указать этот раздел реестра. В настоящее время известна проблема, состоящая в том, что пользователи, пытающиеся получить доступ к почтовым ящикам из Microsoft Office Outlook® Web Access for Exchange Server 2003 через клиентские серверы в организациях, в которых имеется более 1000 хранилищ почтовых ящиков, не могут получить доступ к своим почтовым ящикам.

Если в организации имеется менее 1000 хранилищ почтовых ящиков, а также отсутствуют какие-либо особые причины для применения проверки подлинности, раздел реестра UseBasicAuthToBE можно удалить.

При обычной проверке подлинности учетные данные отправляются в виде обычного текста. Если клиентский сервер Exchange выполняется с заданным разделом реестра UseBasicAuthToBE, настоятельно рекомендуется использовать шифрование IPSec.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неполадок. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы удалить раздел реестра UseBasicAuthToBE

  1. На клиентском сервере Exchange откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Service\MSExchangeWeb\Dav\ UseBasicAuthToBE.

  3. Щелкните правой кнопкой мыши элемент UseBasicAuthToBE, щелкните Удалить, а затем щелкните Да.

  4. Откройте оснастку «Службы» консоли управления MMC, щелкните правой кнопкой мыши Служба Admin Service, а затем щелкните Перезапустить.

Перед изменением реестра ознакомьтесь с тем, как следует выполнять эту процедуру. Описание соответствующих инструкций содержится в статье базы знаний Майкрософт 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Неуспешный PING-запрос сервера шлюза
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2006-05-17

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс Win32_PingStatus (Microsoft Windows® Management Instrumentation), чтобы определить значение ключа StatusCode, возвращаемое с сервера шлюза, не относящегося к Exchange. Win32_PingStatus возвращает объект, имеющий 24 свойства, которые предоставляют обширные сведения о ping-пакетах, отправляемых классом.

Если анализатор сервера Exchange обнаруживает, что значение этого ключа совпадает с одним из значений в следующей таблице, анализатор сервера Exchange выводит на экран сообщение об ошибке.

Анализатор сервера Exchange отображает имя удаленного узла, имя сервера Exchange и соответствующее значение StatusCode, возвращаемое с этой ошибкой.

Значение StatusCode Значение Описание

11001

Слишком малый буфер

Эта ошибка маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11002

Конечная сеть недостижима

Запрос не прошел, так как сеть, содержащая целевой компьютер, является недостижимой. Не существует действующего маршрута к целевому компьютеру.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11003

Целевой узел недостижим

Запрос не прошел, так как целевой компьютер недостижим.

Дополнительные сведения см. по ссылке Сервер Active Directory остановлен или недоступен.

Или эта ошибка может быть вызвана одной из следующих причин:

  • Между компьютером, на котором выполняется анализатор сервера Exchange, и целевым контроллером домена существует сетевой экран.

  • Ошибка службы DNS.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11004

Целевой протокол недостижим

Запрос не прошел, так как целевой компьютер не отвечает на протокол пакета.

Эта ошибка может быть вызвана наличием сетевого экрана между компьютером, на котором выполняется анализатор сервера Exchange, и целевым контроллером домена.

11005

Конечный порт недостижим

Запрос не прошел, так как порт на целевом компьютере недоступен.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11006

Отсутствуют ресурсы

Запрос не прошел из-за нехватки сетевых ресурсов.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11007

Неправильный параметр

Запрос не прошел, так как содержит недопустимый параметр.

Эта ошибка маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11008

Ошибка оборудования

Запрос не прошел из-за ошибки оборудования.

Убедитесь в работоспособности контроллера домена, запустив средство проверки оборудования, поставляемое производителем компьютера.

11009

Слишком большой пакет

Запрос не прошел, так как пакет, содержащий запрос, больше максимального блока передачи (MTU) узла маршрутизатора или шлюза, который находится между исходным и конечным пунктами. Максимальный блок передачи (MTU) определяет максимальный размер передаваемого пакета.

Запрос, отправляемый анализатором сервера Exchange, не превышает 10 КБ. Убедитесь, что маршрутизаторы и шлюзы в организации правильно настроены.

Дополнительные сведения см. в базе знаний Майкрософт в статье 159211, описывающей обнаружение и устранение маршрутизаторов, действующих как черные дыры (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211).

11010

Блокировка запроса по времени

Ответ не получен в отведенное время. Время по умолчанию, отведенное для получения ответов, равно 5 секундам.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11011

Неправильный запрос

Запрос не прошел из-за неправильного кода запроса.

Эта ошибка маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11012

Неправильный маршрут

Запрос не прошел, так как отсутствует действующий маршрут между исходным и конечным компьютерами.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11013

Истек срок жизни во время передачи пакета

Запрос не прошел, так как значение его срока жизни достигло нуля. Это привело к сбросу пакета запроса пересылающим маршрутизатором или шлюзом.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11014

Истек срок жизни во время повторной сборки пакета

Запрос не прошел, так как пакет был поделен на фрагменты для передачи, и все фрагменты не были получены в отведенное время для повторной сборки пакета. Документ RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) определяет 60 секунд в качестве предельного времени, в течение которого все фрагменты пакета должны быть получены.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11015

Проблема параметров

Запрос не прошел из-за проблем узла маршрутизатора или шлюза, возникших при обработке заголовка пакета. Такая ситуация может возникнуть, если заголовок содержит недопустимые данные в поле или нераспознанный параметр.

Эта ошибка маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11016

Обрыв источника

Запрос не прошел из-за сброса пакета. Это происходит, когда выходная очередь исходного компьютера не содержит достаточного объема места для хранения запросов. Или такая ситуация может возникнуть, когда пакеты поступают в конечный пункт слишком быстро и не успевают обрабатываться.

Эта ошибка маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11017

Слишком большой параметр

Запрос не прошел, так как содержит недопустимый параметр.

Эта ошибка маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11018

Неправильный конечный пункт

Запрос не прошел по одной из следующих причин:

  • На конечный IP-адрес не могут приниматься запросы PING.

  • Конечный IP-адрес никогда не должен появляться в поле конечного адреса какой-либо IP-датаграммы.

Эта ошибка может быть вызвана наличием сетевого экрана между компьютером, на котором выполняется анализатор сервера Exchange, и целевым контроллером домена.

11032

Согласование с протоколом IPSEC

Запрос не прошел, так как не удалось согласовать подключение IPsec.

11050

Общая ошибка

Запрос не прошел по неизвестной причине.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).


Параметр IIS 6.0 MaxFieldLength установлен неверно
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2007-01-08

Анализатор рекомендаций Exchange Server считывает следующий раздел реестра, чтобы определить, была ли в разделе жестко задана максимальная длина поля для запросов HTTP.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters\MaxFieldLength

Анализатор Exchange Server также проверяет следующий раздел реестра, чтобы определить версию операционной системы Microsoft Windows®, под управлением которой работает компьютер назначения.

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Значение CurrentVersion равное 4,0 означает, что компьютер работает под управлением операционной системы Microsoft Windows NT® Server 4.0. Значение равное 5,0 указывает, что компьютер работает под управлением операционной системы Microsoft Windows 2000 Server, а значение 5,2 означает, что компьютер работает под управлением операционной системы Microsoft Windows Server™ 2003.

Наконец, средство анализатора сервера Microsoft® Exchange изучает WMI-класс Exchange_Server, находящейся в пространстве имен root\MicrosoftExchangeV2, чтобы определить значение раздела IsFrontEndServer. Значение False означает, что компьютер сервера Exchange не является сервером переднего плана. Значение True означает, что компьютер сервера Exchange является сервером переднего плана.

Анализатор сервера Exchange отобразит предупреждение, если обнаружит, что значение параметра MaxFieldLength не равняется 32768 на внутреннем сервере Exchange, на котором выполняются следующие условия:

  • Внутренний сервер Exchange работает под управлением операционной системы Windows Server 2003.

  • Внутренний сервер Exchange не настроен как сервер переднего плана.

  • На фоновом сервере Exchange размещено больше 500 почтовых ящиков.

Параметр реестра IIS MaxFieldLength, отсутствующий по умолчанию, указывает максимальный размер любого отдельного клиентского HTTP-запроса. Это значение обычно задается вместе с сопутствующим значением параметра MaxRequestBytes. В более крупных средах, если для этого значения не установлено 32768, пользователи веб-клиента Microsoft Office Outlook® для Exchange Server могут столкнуться с ошибками входа в систему. Отсутствие этих значений может привести к ошибкам HTTP «400 Ошибочный запрос». При настройке раздела реестра MaxFieldLength также необходимо установить значение параметра MaxRequestBytes равным 32768, чтобы пользователи, являющиеся членами более чем 75 групп, могли входить в веб-клиент Outlook. Значение реестра MaxRequestBytes определяет верхнюю границу общего размера строки запроса и заголовков. Если это значение меньше, чем MaxFieldLength, значение параметра MaxFieldLength автоматически исправляется.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы задать параметры MaxRequestBytes и MaxFieldLength

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра

    HKLM\System\CurrentControlSet\Services\HTTP\Parameters

  3. Щелкните правой кнопкой мыши Параметры, затем Создать | параметр DWORD и назовите новый параметр MaxFieldLength.

  4. Щелкните правой кнопкой мыши Параметры, затем Создать | параметр DWORD и назовите новый параметр MaxRequestBytes.

  5. В правой области дважды щелкните MaxFieldLength и установите значение 32768 (десятичное).

  6. В правой области дважды щелкните MaxRequestBytes и установите значение 32768 (десятичное).

  7. Закройте редактор реестра и перезапустите службу администрирования IIS, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о параметрах HTTP в реестре для служб IIS см. в статье 820129 базы знаний Майкрософт, посвященной параметрам реестра в файле http.sys для служб IIS (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=820129).


Параметр IIS 6.0 «MaxRequestBytes» установлен неверно
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2007-01-05

Анализатор сервера Microsoft® Exchange Server считывает следующий раздел реестра, чтобы определить, установлен ли в реестре максимальный размер HTTP-запросов.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters\MaxRequestBytes

Анализатор сервера Exchange также считывает следующий раздел реестра, чтобы определить версию Microsoft Windows®, под управлением которой работает конечный компьютер:

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Значение параметра «CurrentVersion», равное 4.0, указывает, что компьютер работает под управлением операционной системы Microsoft Windows NT® Server 4.0. Значение 5.0 указывает, что компьютер работает под управлением операционной системы Microsoft Windows 2000 Server, а значение 5.2 — что компьютер работает под управлением операционной системы Microsoft Windows Server™ 2003.

В последнюю очередь анализатор сервера Microsoft® Exchange изучает WMI-класс «Exchange_Server» в пространстве имен root\MicrosoftExchangeV2, чтобы определить значение ключа «IsFrontEndServer». Значение False означает, что компьютер Exchange Server не является сервером переднего плана. Значение «True» указывает, что компьютер Exchange Server является сервером переднего плана.

Анализатор сервера Exchange выводит предупреждение, если обнаруживает, что значение параметра «MaxRequestBytes» не равно 32 768 на фоновом сервере Exchange, на котором выполняются следующие условия:

  • Этот фоновый сервер Exchange работает под управлением операционной системы Windows Server 2003.

  • Этот фоновый сервер Exchange не настроен как сервер переднего плана.

  • На фоновом сервере Exchange находится свыше 500 почтовых ящиков.

Параметр реестра «MaxRequestBytes», который по умолчанию не установлен, определяет верхний предел общего размера строки запроса и заголовков. Это значение обычно задается вместе с сопутствующим значением параметра «MaxFieldLength». Параметр реестра IIS «MaxFieldLength» указывает максимальный размер любого отдельного клиентского HTTP-запроса. В более крупной среде, если эти значения не равны 32768, пользователи веб-клиента Microsoft Office Outlook® могут сталкиваться с ошибками входа. Отсутствие этих значений может привести к ошибкам HTTP «400 Ошибочный запрос». При настройке раздела реестра «MaxFieldLength» также необходимо установить значение параметра равным 32768, чтобы пользователи, являющиеся членами более чем 75 групп, могли входить в веб-клиент Outlook. Если это значение меньше значения параметра «MaxFieldLength», значение этого параметра автоматически настраивается.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы задать параметры «MaxRequestBytes» и «MaxFieldLength»

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в следующий раздел реестра:

    HKLM\System\CurrentControlSet\Services\HTTP\Parameters

  3. Щелкните правой кнопкой мыши Параметры, выберите команды Создать и параметр DWORD, а затем присвойте новому параметру имя MaxFieldLength.

  4. Щелкните правой кнопкой мыши Параметры, выберите команды Создать и параметр DWORD, а затем присвойте новому параметру имя «MaxRequestBytes».

  5. В правой области дважды щелкните MaxFieldLength и установите значение 32768 (десятичное).

  6. В правой области дважды щелкните MaxRequestBytes и установите значение 32768 (десятичное).

  7. Закройте редактор реестра и перезапустите службу администрирования IIS, чтобы изменения вступили в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения о параметрах HTTP в реестре для служб IIS см. в статье 820129 базы знаний Майкрософт, «INF: Http.sys Registry Settings for IIS» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=820129) (INF: параметры реестра в файле http.sys для служб IIS).


В реестре установлен флаг совместимости с IMAP4
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, существует ли следующий параметр реестра, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\Compatibility

Если анализатор сервера Exchange обнаруживает, что параметр Compatibility существует и его значение задано равным 0xfffffffe (в шестнадцатиричном формате), на экран выводится сообщение о конфигурации не по умолчанию.

Клиентские компьютеры, работающие с протоколом Интернета (IP), сервера Exchange, а также с протоколами IMAP4 и POP3, полностью используют файл хранения потоковых данных (STM-файл) для считывания и записи данных. Когда IP-клиент запрашивает загрузку сообщений с использованием протокола POP3 или IMAP4, банк данных Exchange, содержащий почтовый ящик пользователя, вычисляет точные размеры сообщений в папке "Входящие", чтобы отправить их клиенту до передачи этих сообщений. В обширных средах, особенно содержащих среды Exchange, для вычислений может потребоваться много времени. Параметр Compatibility предоставляет возможности конфигурации для администраторов, чтобы они могли выдать команду в хранилище Exchange на использование приблизительных размеров сообщений вместо расчета их точных размеров.

Параметр Compatibility реестра доступен для службы MAP4 сервера Exchange, как описано в данном разделе, и для службы POP3 сервера Exchange, как описано в разделе В реестре установлен флаг совместимости для POP3.

Параметр Compatibility реестра также используется в процессе перемещения нескольких почтовых ящиков или почтовых ящиков с несколькими MIME-сообщениями. При перемещении данных они перемещаются из хранилища потоковых данных в MAPI-хранилище (EDB-файл). У клиентов, использующих протоколы POP3 и IMAP4 для доступа к своим почтовым ящикам, после перемещения своих почтовых ящиков между базами данных или серверами, могут возникнуть проблемы с производительностью. После входа пользователя в систему должен быть вычислен размер сообщений и происходит их преобразование из формата MAP в формат MIME в памяти и на диске сервера. В экстремальных вариантах при возникновении таких ситуаций на сервере Exchange могут быть созданы очень большие временные файлы.

Не все клиенты почты POP3 и IMAP4 могут корректно работать с заданным значением параметра Compatibility реестра. Изменение значения этого параметра приводит к нарушению работы некоторых более старых клиентов почты, например Fetchmail. Настройка данного раздела реестра также нарушает соответствие RFC для протокола IMAP4. Если существуют проблемы с загрузкой сообщений с помощью протоколов POP3 и IMAP4 и используется параметр Compatibility реестра, можно удалить его с использованием следующей процедуры как шага процедуры устранения неполадок, связанных с загрузкой сообщений.

Важно!
Этот раздел содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы удалить параметр "Compatibility" реестра

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. Удалите параметр с названием Compatibility.

  4. Выйдите из редактора реестра и перезапустите службу банка сообщений в Microsoft Exchange и службу администратора IIS, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об использовании параметра Compatibility реестра см. в базе знаний Майкрософт в статьях:

  • Статья 317722, рассказывающая о том, что в случае преобразования почты Exchange 2000 из формата MAPI в формат MIME происходят задержки в работе клиента (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317722)

  • Статья 329067, рассказывающая о том, что при перемещение функций почтовых ящиков перемещается и содержимое STM-файлов (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329067)


Изменено значение MaxBufferSize протокола IMAP4
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2007-08-07

Чтобы определить, существует ли следующее значение параметра реестра, анализатор сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

Если анализатор сервера Exchange обнаруживает значение реестра MaxBufferSize, не равное 0, выводится сообщение о том, что конфигурация отличается от заданной по умолчанию.

Значение параметра MaxBufferSize реестра используется во внешней/внутренней топологии Exchange. Это значение определяет размер буфера TCP/IP между внешними серверами и внутренними серверами. Размер буфера по умолчанию равен 1 килобайту (КБ). В сетях с большой задержкой настройка значения MaxBufferSize может обеспечить увеличение производительности клиентов IMAP4.

При установке размера буфера TCP/IP с помощью значения параметра MaxBufferSize реестра, следует всегда устанавливать размер буфера кратным 1024. Рекомендуется протестировать производительность конфигурации внешних/внутренних серверов со следующими размерами буфера, чтобы определить оптимальное значение для своей организации:

  • 8192 байта.

  • 16 384 байта.

  • 32 768 байт.

Параметру реестра MaxBufferSize не рекомендуется присваивать значение, превышающее 32 768. Тем не менее, задание размера буфера в 65 536 байт может повысить производительность — это зависит от условий работы сети. Буфер большего размера использует больше памяти на компьютере сервера Exchange и может быть причиной уменьшения количества пользователей, имеющих доступ к серверу переднего плана. Хотя не существует предела на максимальное значение, которое можно использовать для параметра MaxBufferSize реестра, однако, если присвоить слишком большое значение этой записи реестра, возможны нестабильность в работе и проблемы с памятью.

Примечание.
Чтобы использовать значение параметра MaxBufferSize реестра, на компьютере должно выполняться приложение Exchange 2000 Server с пакетом обновления 2 (SP2) или более поздняя версия.

Если присвоить параметру реестра MaxBufferSize слишком маленькое значение, производительность не повысится, а анализатор сервера Exchange отобразит сообщение об ошибке, описанное в документе Слишком малое значение MaxBufferSize протокола IMAP4. Если присвоить параметру реестра MaxBufferSize слишком большое значение, система может начать работать нестабильно, а анализатор сервера Exchange отобразит сообщение об ошибке, описанное в документе Слишком большое значение MaxBufferSize протокола IMAP4.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы настроить значение MaxBufferSize

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. Создайте новое значение DWORD под именем MaxBufferSize.

  4. Дважды щелкните значение MaxBufferSize и установите его равным новому размеру буфера (в байтах). Например, можно ввести 8192, чтобы установить значение равным 8192 байтам.

  5. Закройте редактор реестра и перезапустите службу Microsoft Exchange IMAP4, чтобы изменение вступило в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт "Description of the Microsoft Windows Registry" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения о том, в каких случаях и как используется параметр MaxBufferSize реестра, см. в базе знаний Майкрософт в статье 823857, описывающей причины уменьшения производительности служб IMAP4 и POP3 между серверами переднего плана и внутренними серверами (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


Слишком большое значение MaxBufferSize протокола IMAP4
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2007-08-07

Средство анализатора сервера Microsoft® Exchange считывает реестр на компьютере сервера Exchange, чтобы определить, существует ли следующий раздел:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

Если анализатор сервера Exchange обнаружит, что значение параметра MaxBufferSize существует и установлено равным любому числовому значению больше 32768, на экран выводится предупреждение.

Значение параметра MaxBufferSize реестра используется во внешней и внутренней топологии Exchange. Это значение определяет размер буфера TCP/IP между внешними серверами и внутренними серверами. Размер буфера по умолчанию равен 1 килобайту (КБ). В сетях с большой задержкой настройка значения MaxBufferSize может обеспечить увеличение производительности клиентов IMAP4.

При установке размера буфера TCP/IP с помощью значения параметра MaxBufferSize реестра, следует всегда устанавливать размер буфера кратным 1024. Рекомендуется протестировать производительность конфигурации внешних/внутренних серверов со следующими размерами буфера:

  • 8 192 байтов;

  • 16 384 байтов;

  • 32 768 байтов.

При использовании этого параметра реестра он должен иметь значение не менее 1024. Присваивать параметру MaxBufferSize значение, превышающее 32 768, не рекомендуется. Тем не менее, задание размера буфера в 65536 байт может повысить производительность — это зависит от условий работы сети. Буфер большего размера использует больше памяти на компьютере сервера Exchange и может быть причиной уменьшения количества пользователей, имеющих доступ к серверу переднего плана. Хотя не существует предела на максимальное значение, которое можно использовать для параметра MaxBufferSize реестра, однако, если присвоить слишком большое значение этой записи реестра, возможны нестабильность в работе и проблемы с памятью.

Примечание.
Чтобы использовать значение параметра MaxBufferSize реестра, на компьютере должно выполняться Exchange 2000 Server с пакетом обновления 2 (SP2) или более поздняя версия.

Если значение параметра MaxBufferSize реестра установлено слишком малым, производительность не повысится, и анализатор сервера Exchange выведет на экран сообщение об ошибке, рассматриваемой в разделе Слишком малое значение MaxBufferSize протокола IMAP4. Если значение параметра MaxBufferSize реестра установлено слишком большим, это приведет к нестабильности системы, и анализатор сервера Exchange выведет на экран сообщение об ошибке, описываемой в этой статье.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. Создайте новое значение DWORD под именем MaxBufferSize.

  4. Дважды щелкните значение MaxBufferSize и установите его равным новому размеру буфера (в байтах). Например, можно ввести 8192, чтобы установить значение равным 8192 байтам.

  5. Закройте редактор реестра и перезапустите службу Microsoft Exchange IMAP4, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о том, в каких случаях и как используется параметр MaxBufferSize реестра, см. в базе знаний Майкрософт в статье 823857, описывающей причины уменьшения производительности служб IMAP4 и POP3 между серверами переднего плана и внутренними серверами (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


Слишком малое значение MaxBufferSize протокола IMAP4
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2007-08-07

Чтобы определить, существует ли следующее значение параметра реестра, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

Если анализатор сервера Exchange обнаружит, что значение параметра MaxBufferSize существует и установлено равным какому-либо числовому значению, которое больше 0, но меньше 1024, на экран будет выведено сообщение об ошибке.

Значение параметра MaxBufferSize реестра используется во внешней и внутренней топологии Exchange. Это значение определяет размер буфера TCP/IP между внешними серверами и внутренними серверами. Размер буфера по умолчанию равен 1 килобайту (КБ). В сетях с большой задержкой настройка значения MaxBufferSize может обеспечить увеличение производительности клиентов IMAP4.

При установке размера буфера TCP/IP с помощью значения параметра MaxBufferSize реестра, следует всегда устанавливать размер буфера кратным 1024. Рекомендуется протестировать производительность конфигурации внешних/внутренних серверов со следующими размерами буфера, чтобы определить оптимальное значение для своей организации:

  • 8 192 байтов;

  • 16 384 байтов;

  • 32 768 байтов.

При использовании этого параметра реестра он должен иметь значение не менее 1024. Присваивать параметру MaxBufferSize значение, превышающее 32 768, не рекомендуется. Тем не менее, задание размера буфера в 65 536 байт может повысить производительность — это зависит от условий работы сети. Буфер большего размера использует больше памяти на компьютере сервера Exchange и может быть причиной уменьшения количества пользователей, имеющих доступ к серверу переднего плана. Хотя не существует предела на максимальное значение, которое можно использовать для параметра MaxBufferSize реестра, однако, если присвоить слишком большое значение этой записи реестра, возможны нестабильность в работе и проблемы с памятью.

Примечание.
Чтобы использовать значение параметра MaxBufferSize реестра, на компьютере должно выполняться Exchange 2000 Server с пакетом обновления 2 (SP2) или более поздняя версия.

Если значение параметра MaxBufferSize установлено слишком малым, производительность не повысится, и анализатор сервера Exchange выведет на экран сообщение об ошибке, рассматриваемой в этой статье. Если значение параметра MaxBufferSize реестра установлено слишком большим, это приведет к нестабильности системы, и анализатор сервера Exchange выведет на экран сообщение об ошибке, описываемой в статье Слишком большое значение MaxBufferSize протокола IMAP4.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить эту ошибку

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. Создайте новое значение DWORD под именем MaxBufferSize.

  4. Дважды щелкните значение MaxBufferSize и установите его равным новому размеру буфера (в байтах). Например, можно ввести 8192, чтобы установить значение равным 8192 байтам.

  5. Закройте редактор реестра и перезапустите службу Microsoft Exchange IMAP4, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о том, в каких случаях и как используется параметр MaxBufferSize реестра, см. в базе знаний Майкрософт в статье 823857, описывающей причины уменьшения производительности служб IMAP4 и POP3 между серверами переднего плана и внутренними серверами (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


Сбой операции MAPI
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange определило, что сервер зарегистрировал множество сбоев MAPI. Некоторые операции MAPI иногда возвращают ошибки. Однако иногда приложение клиента может не обрабатывать ошибку правильным образом. В результате приложение может повторить запрос удаленного вызова процедур, который привел к ошибке, тем самым увеличивая нагрузку на сервер.

Пример часто повторяющейся ошибки клиента: клиент MAPI запрашивает список элементов в пакетах и продолжает запрашивать эти элементы после возвращения сервером Exchange этого запроса. Например, клиентский компьютер может запросить все элементы в определенной папке, которые содержат вложения. Далее клиент может запросить возвращение всех элементов в пакетах, состоящих из 30 элементов. В некоторых случаях после того, как сервер Exchange возвратит последний элемент для запроса, клиент продолжит запрашивать новый пакет из 30 элементов. В таких случаях Exchange отображает ошибку «Не найдено». Если клиентский компьютер продолжит запрашивать элементы после возвращенной ошибки «Не найдено», это означает, что клиентский компьютер не смог правильно обработать ошибку. В подобном сценарии средство наблюдения за пользователями Exchange Server (ExMon) зарегистрирует многочисленные сбои MAPI. В таком случае, несмотря на то, что отношение количества сбоев к количеству операций является высоким, ожидается высокий уровень сбоев. Операции MAPI с высокими уровнями сбоев: GetPerUserGuid, ImportMsgMove и Logon.

Чтобы устранить эту ошибку

  1. Используйте средство ExMon, чтобы определить, какие пользователи или группы пользователей привели к появлению большого количества сбоев MAPI.

  2. Определите, какое приложение на клиентском компьютере приводит к возникновению этой неполадки.

  3. Исправьте или удалите это приложение.

Дополнительные сведения

  • Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Дополнительные сведения об устранении проблем, связанных с производительностью сервера Exchange, см. на веб-узле, посвященном устранению неполадок, связанных с производительностью сервера Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).


Значение MaxClientRequestBuffer отлично от значения по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server считывает следующий раздел реестра, чтобы установить, существует ли раздел:

HKEY_LOCAL_MACHINE System\CurrentControlSet\w3svc\Parameters\MaxClientRequestBuffer

Если анализатор сервера Exchange обнаружит, что раздел MaxClientRequestBuffer был создан, он выдаст сообщение о настойке, отличной от настройки по умолчанию.

По умолчанию данное значение реестра отсутствует.

Средство анализа Exchange Server сообщает об этой настройке только для информации. Никаких специальных действий выполнять не требуется.

Для получения дополнительных сведений о разделе реестра MaxClientRequestBuffer см. статью 260694 базы знаний корпорации Майкрософт «Описание параметра системного реестра MaxClientRequestBuffer» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260694)


Задано слишком низкое значение MaxClientRequestBuffer
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Server считывает следующий раздел реестра, чтобы определить значение для MaxClientRequestBuffer:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer

Если анализатор сервера Exchange Server обнаружит, что значение для MaxClientRequestBuffer меньше 16384, отображается предупреждение.

Если значение для MaxClientRequestBuffer является слишком низким, могут возникнуть ошибки в работе пользователей Microsoft Office Outlook® Web Access. В частности, это может привести к тому, что в обозреватель будет возвращаться предупреждение HTTP 400 - Bad Request. Чтобы устранить появление данного предупреждения, рекомендуется увеличить это значение до величины, превышающей 16384, или удалить соответствующее значение реестра, чтобы вернуться к параметрам по умолчанию. Значение MaxClientRequestBuffers по умолчанию отсутствует.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неполадок. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы устранить появление этого предупреждения посредством увеличения величины данного значения

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer

  3. Дважды щелкните значение MaxClientRequestBuffer и измените его величину. Установите величину этого значения равной или превышающей 16384 в десятичном выражении.

  4. Закройте редактор реестра и перезапустите сервер Exchange.
Чтобы устранить появление этого предупреждения посредством удаления данного значения

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer

  3. Щелкните правой кнопкой мыши значение MaxClientRequestBuffer, а затем выберите Удалить.

  4. Закройте редактор реестра и перезапустите сервер Exchange.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения о редактировании реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о значении реестра MaxClientRequestBuffer см. в базе знаний Майкрософт в статье 260694, посвященной этой теме (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260694).


Настроено несколько привязок SMTP-портов
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, настроено ли значение для атрибута msExchServerBindings с несколькими привязками портов. По умолчанию атрибут msExchServerBindings настраивается для TCP-порта 25. Если анализатор сервера Exchange обнаруживает, что атрибут msExchServerBindings настроен с несколькими привязками портов, он выводит на экран сообщение о конфигурации не по умолчанию.

Атрибут msExchServerBindings представляет TCP-порт, на котором SMTP-сервер прослушивает входящие подключения. Можно настроить виртуальные SMTP-серверы на прослушивание одного или более TCP-портов. По умолчанию все виртуальные SMTP-серверы настроены для прослушивания TCP-порта 25. Можно изменить прослушиваемый SMTP-порт, если соответственно изменить остальную внутреннюю инфраструктуру обмена сообщениями. Однако, для виртуальных SMTP-серверов, принимающих сообщения прямо из Интернета, обычно следует использовать порт 25, т.к. SMTP-серверы в Интернете посылают сообщения через порт 25.

Заметьте, что анализатор сервера Exchange проверяет значение виртуального сервера Exchange протокола SMTP. Виртуальный сервер Exchange протокола SMTP может быть или может не быть SMTP-сервером, принимающим сообщения прямо из Интернета. Некоторые антивирусные продукты и продукты для защиты от нежелательной почты предназначены для приема SMTP-сообщений из Интернета на порт 25 и перенаправление их на виртуальный SMTP-сервер Exchange или другой порт.

Чтобы просмотреть или изменить порт прослушивания виртуального SMTP-сервера

  1. В диспетчере Exchange разверните узел Серверы, разверните сервер Exchange, разверните узел Протоколы и затем разверните узел SMTP.

  2. Щелкните правой кнопкой мыши виртуальный SMTP-сервер, например виртуальный SMTP-сервер по умолчанию и затем щелкните Свойства.

  3. Выберите вкладку Общие и щелкните Дополнительно.

  4. На экран будет выведен список IP-адресов и портов.

    • Чтобы изменить существующий порт, выберите IP-адрес и щелкните Изменить.

    • Чтобы удалить существующий порт, выберите IP-адрес и щелкните Удалить.

  5. Чтобы сохранить изменения, нажмите кнопку ОК, затем нажмите кнопку ОК, чтобы выйти из диалогового окна Дополнительно.

  6. Нажмите кнопку ОК, чтобы закрыть диалоговое окно Свойства для виртуального SMTP-сервера.

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • 266686, "XCON: How to Configure a SMTP Virtual Server Part 1" (XCON: инструкции по настройке виртуального SMTP-сервера, часть 1) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: How to Configure a SMTP Virtual Server Part 2" (XCON: инструкции по настройке виртуального SMTP-сервера, часть 2) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


PING-отклик имеет неверный размер
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2006-05-17

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation)Win32_PingStatus с использованием конкретных значений параметраBufferSize, сравнивает их с возвращенными значениями BufferSizeи определяет, отличаются ли они друг от друга.

Если возвращенное значение BufferSize отличается от отправленного значения, анализатор сервера Exchange выводит предупреждение.

Это предупреждение указывает, что при передаче пакет был усечен. Это может означать общий сбой сети или или наличие в сети маршрутизатора, выступающего в роли «черной дыры».

В глобальных сетях TCP/IP (WAN), подключение по определенным маршрутам может быть невозможно, если в промежуточных сегментах сети используются пакеты меньшего размера, чем на взаимодействующих серверах, а маршрутизаторы не отправляют соответствующие ICMP-ответы при наступлении этого условия. Кроме того, эти ответы могут отсекаться расположенным на пути их следования межсетевым экраном. Маршрутизатор, являющийся причиной подобной неполадки, иногда называется маршрутизатором — черной дырой.

Наличие «черной дыры» может привести к возникновению ряда ошибок, невозможных в том случае, если программа подключается к компьютеру по локальной подсети. Может показаться, что такое поведение проявляется нерегулярно, однако при более тщательном анализе обстоятельств можно обнаружить, что оно возникает в определенных условиях, например, при чтении клиентом большого файла, отправленного с удаленного хоста.

Дополнительные сведения см. в статье 314825 базы знаний Майкрософт "How to Troubleshoot Black Hole Router Issues" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825) (Инструкции по устранению проблем, связанных с маршрутизаторами, действующими как черные дыры).

Дополнительные сведения

Дополнительные сведения о выявлении и устранении маршрутизаторов — черных дыр см. в следующих ресурсах:

  • Статья 159211 базы знаний Майкрософт "Diagnoses and treatment of black hole routers" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211) (Выявление и устранение маршрутизаторов, действующих как черные дыры).

  • "Path Maximum Transmission Unit (PMTU) Black Hole Routers" (http://go.microsoft.com/fwlink/?LinkId=66963) (Маршрутизаторы — черные дыры, связанные с максимальными пакетами передачи данных).


Проверка отклика не выполнена
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2006-08-09

Средство анализатора сервера Microsoft® Exchange пытается запросить WMI-класс (Microsoft Windows® Management Instrumentation) Win32_PingStatus, чтобы проанализировать объект ответа для различных параметров конфигурации, относящихся к потоку почты.

WMI-класс Win32_PingStatus обычно возвращает объект, имеющий 24 свойства, которые предоставляют обширные сведения о пакетах ping-запросов, отправляемых классом.

Если анализатор сервера Exchange не получает ожидаемый объект в ответ на свой запрос после шести последовательных попыток, на экран выводится предупреждение.

Это предупреждение означает, что команду Win32_PingStatus не удалось выполнить.

Наиболее вероятная причина данной ошибки состоит в том, что компьютер, который пытается выполнить команду Win32_PingStatus, работает под управлением операционной системы Microsoft Windows® 2000 Server. Операционная система Windows 2000 Server не поддерживает WMI-класс Win32_PingStatus.

Если компьютер, пытающийся выполнить команду Win32_PingStatus, работает под управлением операционной системы, отличной от Windows 2000 Server, ошибка может возникать в результате общих неполадок в работе сети или из-за проблем с разрешениями.

Чтобы устранить эту ошибку

  1. Убедитесь, что компьютер сервера Exchange включен и подсоединен к сети.

  2. Запустите команду PING с компьютера, на котором выполняется анализатор сервера Exchange, чтобы увидеть, достижим ли целевой компьютер сервера Exchange.

  3. Запустите команду PING с сервера, который находится в одной подсети с целевым сервером Exchange, чтобы увидеть, достижим ли целевой компьютер сервера Exchange.

  4. При наличии межсетевого экрана проверьте, не блокированы ли порты удаленного вызова процедур.

  5. Проверьте разрешения учетной записи, от имени которой выполняется анализатор сервера Exchange. Учетная запись, с которой выполняется анализатор сервера Exchange, на каждом сканируемом сервере Exchange должна обладать разрешениями локального администратора.

Дополнительные сведения о проблемах в сетевых подключениях см. в базе знаний Майкрософт, в статье 325487, содержащей инструкции по устранению неполадок в сетевых подключениях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Дополнительные сведения об устранении неполадок в подключениях анализатора рекомендаций для сервера Exchange см. статью, посвященную устранению неполадок, связанных с подключениями средства анализатора рекомендаций для сервера Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=56285).

Дополнительные сведения о WMI-классе «Win32_PingStatus» см. в статье MSDN® «Win32_PingStatus» (http://go.microsoft.com/fwlink/?linkid=33549).


Антивирусное сканирование обычного текста отключено
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить значение параметра антивирусного сканирования сообщений в формате RTF (Rich Text Format), средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Если анализатор сервера Exchange определяет, что для параметра ScanPlainText задано значение 0, на экран выводится предупреждение.

Параметр реестра ScanPlainText задается антивирусными программами сторонних поставщиков, использующими интерфейс VSAPI (Exchange Virus Scanning API). Рекомендуется проверять сообщения всех типов, включая сообщения в формате обычного текста, на наличие вирусов. Следует включить сканирование всех сообщений, проходящих через компьютер под управлением Exchange Server.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить эту ошибку

  • Включите сканирование всех сообщений в антивирусной программе с поддержкой Exchange.

    -или-

  • Вручную измените запись реестра, выполнив следующие действия:

    1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

    2. Перейдите к разделу реестра:

      HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

    3. Дважды щелкните запись реестра ScanPlainText и введите 1 в поле «Значение».

    4. Закройте редактор реестра и перезапустите службу «Банк данных Microsoft Exchange», а также службы, представляющие антивирусное программное обеспечение с поддержкой Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в статье 256986 базы знаний Майкрософт, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о борьбе с вирусами см. на веб-узле, посвященном обезвреживанию вирусов, передаваемых по электронной почте, в среде Exchange 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47587).


В реестре установлен флаг совместимости для POP3
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, существует ли следующее значение параметра реестра, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\Compatibility

Если анализатор сервера Exchange обнаруживает, что параметр Compatibility присутствует и для него указано значение 0xfffffffe (шестнадцатеричное), выводится сообщение о том, что конфигурация отличается от заданной по умолчанию.

IP-клиенты сервера Exchange, на которых используются IMAP4 и POP3, полноценно используют файл потокового хранилища (STM-файл) для чтения и записи данных. Когда IP-клиент запрашивает загрузку сообщений с использованием POP3 или IMAP4, хранилище Exchange, содержащее почтовый ящик этого пользователя, рассчитывает точный размер сообщений в папке «Входящие», предназначенных для отправки данному клиенту перед тем, как передать эти сообщения. В сложных средах, особенно в средах размещаемых приложений Exchange, выполнение данного вычисления может занять длительное время. Значение Compatibility позволяет администраторам указать для хранилища Exchange, что должен использоваться приблизительный расчет размера сообщений вместо точного.

Значение реестра Compatibility доступно для службы POP3 в Exchange, что рассматривается в данной статье, а также для службы IMAP4 в Exchange, что рассматривается в разделе В реестре установлен флаг совместимости с IMAP4.

Параметр реестра Compatibility также полезен при перемещении большого числа почтовых ящиков или почтовых ящиков с большим количеством MIME-сообщений. При перемещении данных эти данные переносятся из потокового хранилища в MAPI-хранилище (EDB-файл). У клиентов, использующих для доступа к своим почтовым ящикам протоколы POP3 и IMAP4, после перемещения их почтовых ящиков в другую базу данных или сервер, может снизиться производительность. После входа пользователя должен быть вычислен размер сообщений и выполнено преобразование из формата MAPI в формат MIME как в памяти, так и на диске сервера. В особых случаях при возникновении такого поведения, на сервере Exchange могут создаваться очень большие временные файлы.

Если установлен параметр реестра Compatibility, некоторые почтовые клиенты POP3 и IMAP4 могут работать некорректно. Изменение данного параметра вызывает сбой ряда старых почтовых клиентов (таких как Fetchmail). Кроме того, при создании данного параметра реестра нарушается совместимость протокола POP3 с требованиями RFC. Если возникают неполадки при загрузке сообщений с использованием POP3 и IMAP4 и используется параметр реестра Compatibility, в процессе устранения таких неполадок этот параметр можно удалить с помощью приведенной ниже процедуры.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы удалить параметр реестра «Compatibility»

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Удалите значение реестра с названием Compatibility.

  4. Закройте редактор реестра, а затем перезапустите службу банка данных Microsoft Exchange и службу администрирования IIS, чтобы изменения вступили в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения о параметре реестра Compatibility см. в следующих статьях базы знаний Майкрософт:

  • 317722, «XADM: Client Latencies Occur When Exchange 2000 Converts Mail from MAPI to MIME Format» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317722) (XADM: возникают задержки в работе клиентских компьютеров в том случае, если почта в Exchange 2000 преобразуется из формата MAPI в формат MIME)

  • 329067, «XADM: Move Mailbox Functionality Promotes Contents of .stm Files» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329067) (XADM: функциональность перемещений почтовых ящиков предполагает перенос содержимого STM-файлов)


Изменено значение MaxBufferSize протокола POP3
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, существует ли следующее значение параметра реестра, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

Если анализатор сервера Exchange обнаружит, что значение параметра MaxBufferSize существует и установлено равным любому числовому значению больше 0, на экран выводится сообщение о конфигурации, отличной от конфигурации по умолчанию.

Значение параметра MaxBufferSize реестра используется во внешней/внутренней топологии Exchange. Это значение определяет размер буфера TCP/IP между внешними серверами и внутренними серверами. Размер буфера по умолчанию равен 1 килобайту (КБ). В сетях с большой задержкой настройка значения MaxBufferSize может обеспечить увеличение производительности клиентов POP3.

При установке размера буфера TCP/IP с помощью значения параметра MaxBufferSize реестра, следует всегда устанавливать размер буфера кратным 1024. Рекомендуется протестировать производительность конфигурации внешних/внутренних серверов со следующими размерами буфера:

  • 8 192 байтов.

  • 16 384 байтов.

  • 32 768 байтов.

При использовании этой записи реестра она должна быть установлена равной, по крайней мере, 1024. Не рекомендуется устанавливать значение записи MaxBufferSize реестра, которое превышает 32 768. Однако в зависимости от сетевых условий производительность может возрасти при значении буфера равном 65 536. Буфер большего размера использует больше памяти на компьютере сервера Exchange и может быть причиной уменьшения количества пользователей, имеющих доступ к серверу переднего плана. Хотя не существует предела на максимальное значение, которое можно использовать для параметра MaxBufferSize реестра, однако, если присвоить слишком большое значение этой записи реестра, возможны нестабильность в работе и проблемы с памятью.

Примечание.
Чтобы использовать значение параметра MaxBufferSize реестра, на компьютере должно выполняться приложение Exchange 2000 Server с пакетом обновления 2 (SP2) или более поздняя версия.

Если значение параметра MaxBufferSize реестра установлено слишком малым, производительность не повысится, и анализатор сервера Exchange выведет на экран сообщение об ошибке, рассматриваемой в статье Слишком малое значение MaxBufferSize протокола POP3. Если значение параметра MaxBufferSize реестра установлено слишком большим, это приведет к нестабильности системы, и анализатор сервера Exchange выведет на экран сообщение об ошибке, описываемой в статье Слишком большое значение MaxBufferSize протокола POP3.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить эту ошибку

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Создайте новое значение DWORD под именем MaxBufferSize.

  4. Дважды щелкните значение MaxBufferSize и установите его равным новому размеру буфера (в байтах). Например, можно ввести 8192, чтобы установить значение равным 8192 байтам.

  5. Выйдите из редактора реестра и перезапустите службу POP3 в Microsoft Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о том, в каких случаях и как используется параметр MaxBufferSize реестра, см. в базе знаний Майкрософт в статье 823857, описывающей причины уменьшения производительности служб IMAP4 и POP3 между серверами переднего плана и внутренними серверами (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


Слишком большое значение MaxBufferSize протокола POP3
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, существует ли следующее значение параметра реестра, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

Если анализатор сервера Exchange обнаружит, что значение параметра MaxBufferSize существует и установлено равным любому числовому значению больше 32768, на экран выводится предупреждение.

Значение параметра MaxBufferSize реестра используется во внешней/внутренней топологии Exchange. Это значение определяет размер буфера TCP/IP между внешними серверами и внутренними серверами. Размер буфера по умолчанию равен 1 килобайту (КБ). В сетях с большой задержкой настройка значения MaxBufferSize может обеспечить увеличение производительности клиентов POP3.

При установке размера буфера TCP/IP с помощью значения параметра MaxBufferSize реестра, следует всегда устанавливать размер буфера кратным 1024. Рекомендуется протестировать производительность конфигурации внешних/внутренних серверов со следующими размерами буфера:

  • 8192 байта,

  • 16 384 байта,

  • 32 768 байтов.

При использовании этой записи реестра она должна быть установлена равной, по крайней мере, 1024. Не рекомендуется устанавливать значение записи MaxBufferSize реестра, которое превышает 32 768. Однако в зависимости от сетевых условий производительность может возрасти при значении буфера равном 65 535. Буфер большего размера использует больше памяти на компьютере сервера Exchange и может быть причиной уменьшения количества пользователей, имеющих доступ к серверу переднего плана. Хотя не существует предела на максимальное значение, которое можно использовать для параметра MaxBufferSize реестра, однако, если присвоить слишком большое значение этой записи реестра, возможны нестабильность в работе и проблемы с памятью.

Примечание.
Чтобы использовать значение параметра MaxBufferSize реестра, на компьютере должно выполняться приложение Exchange 2000 Server с пакетом обновления 2 (SP2) или более поздняя версия.

Если значение параметра MaxBufferSize реестра установлено слишком малым, производительность не повысится, и анализатор сервера Exchange выведет на экран сообщение об ошибке, рассматриваемой в статье Слишком малое значение MaxBufferSize протокола POP3. Если значение параметра MaxBufferSize реестра установлено слишком большим, это приведет к нестабильности системы, и анализатор сервера Exchange выведет на экран сообщение об ошибке, описываемой в этой статье.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить эту ошибку

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Создайте новое значение DWORD под именем MaxBufferSize.

  4. Дважды щелкните значение MaxBufferSize и установите его равным новому размеру буфера (в байтах). Например, можно ввести 8192, чтобы установить значение равным 8192 байтам.

  5. Выйдите из редактора реестра и перезапустите службу POP3 в Microsoft Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о том, в каких случаях и как используется параметр MaxBufferSize реестра, см. в базе знаний Майкрософт в статье 823857, описывающей причины уменьшения производительности служб IMAP4 и POP3 между серверами переднего плана и внутренними серверами (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


Слишком малое значение MaxBufferSize протокола POP3
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, существует ли следующее значение параметра реестра, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

Если анализатор сервера Exchange обнаружит, что значение параметра MaxBufferSize существует и установлено равным какому-либо числовому значению, которое больше 0, но меньше 1024, на экран будет выведено сообщение об ошибке.

Значение параметра MaxBufferSize реестра используется во внешней/внутренней топологии Exchange. Это значение определяет размер буфера TCP/IP между внешними серверами и внутренними серверами. Размер буфера по умолчанию равен 1 килобайту (КБ). В сетях с большой задержкой настройка значения MaxBufferSize может обеспечить увеличение производительности клиентов POP3.

При установке размера буфера TCP/IP с помощью значения параметра MaxBufferSize реестра, следует всегда устанавливать размер буфера кратным 1024. Рекомендуется протестировать производительность конфигурации внешних/внутренних серверов со следующими размерами буфера, чтобы определить оптимальное значение для своей организации:

  • 8192 байта,

  • 16 384 байта,

  • 32 768 байтов.

При использовании этой записи реестра она должна быть установлена равной, по крайней мере, 1024. Не рекомендуется устанавливать значение записи MaxBufferSize реестра, которое превышает 32 768. Однако в зависимости от сетевых условий производительность может возрасти при значении буфера равном 65 535. Буфер большего размера использует больше памяти на компьютере сервера Exchange и может быть причиной уменьшения количества пользователей, имеющих доступ к серверу переднего плана. Хотя не существует предела на максимальное значение, которое можно использовать для параметра MaxBufferSize реестра, однако, если присвоить слишком большое значение этой записи реестра, возможны нестабильность в работе и проблемы с памятью.

Примечание.
Чтобы использовать значение параметра MaxBufferSize реестра, на компьютере должно выполняться приложение Exchange 2000 Server с пакетом обновления 2 (SP2) или более поздняя версия.

Если значение параметра MaxBufferSize установлено слишком малым, производительность не повысится, и анализатор сервера Exchange выведет на экран сообщение об ошибке, рассматриваемой в этой статье. Если значение параметра MaxBufferSize реестра установлено слишком большим, это приведет к нестабильности системы, и анализатор сервера Exchange выведет на экран сообщение об ошибке, описываемой в статье Слишком большое значение MaxBufferSize протокола POP3.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить эту ошибку

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Создайте новое значение DWORD под именем MaxBufferSize.

  4. Дважды щелкните значение MaxBufferSize и установите его равным новому размеру буфера (в байтах). Например, можно ввести 8192, чтобы установить значение равным 8192 байтам.

  5. Закройте редактор реестра и перезапустите службу Microsoft Exchange POP3, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о том, в каких случаях и как используется параметр MaxBufferSize реестра, см. в базе знаний Майкрософт в статье 823857, описывающей причины уменьшения производительности служб IMAP4 и POP3 между серверами переднего плана и внутренними серверами (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


Порт не отвечает
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2006-05-16

Средство анализатора сервера Microsoft® Exchange запрашивает пользовательский сервер и пытается открыть сокет подключения к указанному серверу, используя TCP-порт 25 конфигурации по умолчанию или определенный пользователем порт. Если анализатор сервера Exchange не получает ожидаемого настраиваемого ответа xx Available, где xx — порт по умолчанию (25) или другой порт, определенный пользователем, анализатор сервера Exchange выводит сообщение об ошибке.

Это сообщение об ошибке показывает, что сервер недоступен по нужному TCP-порту и что мог произойти тот или иной сбой. Чтобы исправить эту ошибку, можно проверить связь с сервером и устранить возникшие неполадки.

Устранение проблем связи с сервером

  1. Можно ли, используя программу telnet, связаться с нужным портом нужного сервера с самого сервера? Если нет, то проблема не в сети.

  2. Все ли подключено? Все ли оборудование правильно работает?

  3. Работает ли и правильно ли настроен DNS?

  4. Правильно ли работает маршрутизатор?

  5. Не мешает ли установлению связи работа брандмауэров?

Дополнительные сведения об устранении проблем связи с сервером см. в материале, посвященном проблемам устранения неполадок сетевых подключений средства Best Practices Analyzer сервера Microsoft Exchange, по адресу http://go.microsoft.com/fwlink/?LinkId=56285.


Возможно возникновение маршрутизатора «черная дыра»
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2006-05-17

Анализатор сервера Microsoft® Exchange запрашивает класс инструментария управления Windows (WMI) Win32_PingStatus с использованием различных значений параметров BufferSize и NoFragmentation, чтобы определить наличие маршрутизаторов «черная дыра» в среде глобальной сети.

Параметр BufferSize | Параметр NoFragmentation
548 | True
1472 | True
1472 | False
4096 | True
4096 | False

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • PING-запрос с меньшими BufferSize и NoFragmentation = True проходит успешно;

  • PING-запрос с большими BufferSize и NoFragmentation = True завершается по времени;

  • PING-запрос с большими BufferSize и NoFragmentation = False проходит успешно, но размер BufferSize в ответе отличается от отправленного BufferSize.

Эта ошибка указывает на возможное присутствие в глобальной сети одного или нескольких маршрутизаторов «черная дыра».

Если выполняются следующие условия, в глобальной сети TCP/IP в трафике по некоторым маршрутам могут возникать сбои:

  • В промежуточных сегментах сети используются пакеты меньшего размера, чем на взаимодействующих серверах.

  • Маршрутизаторы не отправляют соответствующие ICMP-ответы на это условие.

Кроме того, эти ответы могут отсекаться расположенным на пути их следования межсетевым экраном. Маршрутизатор, являющийся причиной подобной неполадки, иногда называют маршрутизатором черная дыра.

Наличие «черной дыры» может привести к возникновению ряда ошибок, невозможных в том случае, если программа подключается к компьютеру по локальной подсети. На первый взгляд, такое поведение проявляется нерегулярно, однако можно обнаружить, что оно возникает в определенных условиях, например, при чтении клиентом большого файла, отправленного с удаленного сервера.

Дополнительные сведения см. в статье 314825 базы знаний Майкрософт "How to Troubleshoot Black Hole Router Issues" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825) (Инструкции по устранению проблем, связанных с маршрутизаторами, действующими как черные дыры).

Дополнительные сведения

Для получения дополнительных сведений о выявлении и устранении маршрутизаторов «черная дыра» см. следующие ресурсы:

  • Статья 159211 базы знаний Майкрософт "Diagnoses and treatment of black hole routers" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211) (Выявление и устранение маршрутизаторов, действующих как черные дыры).

  • Статья «PMTU-маршрутизаторы «черная дыра»» в колонке The Cable Guy - July 2004 (http://go.microsoft.com/fwlink/?LinkId=66963) (может быть на английском языке).


Неуспешный PING-запрос удаленного узла
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2006-05-03

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_PingStatus, используя различные настройки BufferSize и NoFragmentation, чтобы определить размер максимального блока передачи (Maximum Transmission Unit, MTU) для сети и чтобы обнаружить возможные маршрутизаторы, действующие как черные дыры. Анализатор сервера Exchange определяет это, анализируя значение ключа StatusCode, возвращаемого удаленным узлом для каждой комбинации параметров.

Параметр BufferSize | Параметр NoFragmentation
548 | True
1472 | True
1472 | False
4096 | True
4096 | False

Win32_PingStatus возвращает объект, имеющий 24 свойства, которые предоставляют обширные сведения о пакетах ping-запросов, отправляемых классом.

Если анализатор сервера Exchange обнаруживает, что значение этого ключа совпадает с одним из значений в следующей таблице, анализатор сервера Exchange выводит на экран сообщение об ошибке.

Анализатор сервера Exchange отображает имя удаленного узла, имя сервера Exchange и соответствующее значение StatusCode, возвращаемое с этой ошибкой.

Значение StatusCode Значение Описание

11001

Слишком малый буфер

Эта ошибка маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11002

Конечная сеть недостижима

Запрос не прошел, так как сеть, содержащая целевой компьютер, является недостижимой. Не существует действующего маршрута к целевому компьютеру.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11003

Целевой узел недостижим

Запрос не прошел, так как целевой компьютер недостижим.

Дополнительные сведения см. по ссылке Сервер Active Directory остановлен или недоступен.

Или эта ошибка может быть вызвана одной из следующих причин:

  • Между компьютером, на котором выполняется анализатор сервера Exchange, и целевым контроллером домена существует сетевой экран.

  • Ошибка службы DNS.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11004

Целевой протокол недостижим

Запрос не прошел, так как целевой компьютер не отвечает на протокол пакета.

Эта ошибка может быть вызвана наличием сетевого экрана между компьютером, на котором выполняется анализатор сервера Exchange, и целевым контроллером домена.

11005

Конечный порт недостижим

Запрос не прошел, так как порт на целевом компьютере недоступен.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11006

Отсутствуют ресурсы

Запрос не прошел из-за нехватки сетевых ресурсов.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11007

Неправильный параметр

Запрос не прошел, так как содержит недопустимый параметр.

Эта ошибка маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11008

Ошибка оборудования

Запрос не прошел из-за ошибки оборудования.

Убедитесь в работоспособности контроллера домена, запустив средство проверки оборудования, поставляемое производителем компьютера.

11009

Слишком большой пакет

Запрос не прошел, так как пакет, содержащий запрос, больше максимального блока передачи (MTU) узла маршрутизатора или шлюза, который находится между исходным и конечным пунктами. Максимальный блок передачи (MTU) определяет максимальный размер передаваемого пакета.

Запрос, отправляемый анализатором сервера Exchange, не превышает 10 КБ. Убедитесь, что маршрутизаторы и шлюзы в организации правильно настроены.

Дополнительные сведения см. в базе знаний Майкрософт в статье 159211, описывающей обнаружение и устранение маршрутизаторов, действующих как черные дыры (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211).

11010

Блокировка запроса по времени

Ответ не получен в отведенное время. Время по умолчанию, отведенное для получения ответов, равно 5 секундам.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11011

Неправильный запрос

Запрос не прошел из-за неправильного кода запроса.

Эта ошибка маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11012

Неправильный маршрут

Запрос не прошел, так как отсутствует действующий маршрут между исходным и конечным компьютерами.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11013

Истек срок жизни во время передачи пакета

Запрос не прошел, так как значение его срока жизни достигло нуля. Это привело к сбросу пакета запроса пересылающим маршрутизатором или шлюзом.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11014

Истек срок жизни во время повторной сборки пакета

Запрос не прошел, так как пакет был поделен на фрагменты для передачи, и все фрагменты не были получены в отведенное время для повторной сборки пакета. Документ RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) определяет 60 секунд в качестве предельного времени, в течение которого все фрагменты пакета должны быть получены.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11015

Проблема параметров

Запрос не прошел из-за проблем узла маршрутизатора или шлюза, возникших при обработке заголовка пакета. Такая ситуация может возникнуть, если заголовок содержит недопустимые данные в поле или нераспознанный параметр.

Эта ошибка маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11016

Обрыв источника

Запрос не прошел из-за сброса пакета. Это происходит, когда выходная очередь исходного компьютера не имеет достаточного места для хранения запросов. Или такая ситуация может возникнуть, когда пакеты поступают в конечный пункт слишком быстро и не успевают обрабатываться.

Эта ошибка маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11017

Слишком большой параметр

Запрос не прошел, так как содержит недопустимый параметр.

Эта ошибка маловероятна, так как анализатор сервера Exchange формирует стандартный запрос.

11018

Неправильный конечный пункт

Запрос не прошел по одной из следующих причин:

  • На конечный IP-адрес не могут приниматься запросы PING.

  • Конечный IP-адрес никогда не должен появляться в поле конечного адреса какой-либо IP-датаграммы.

Эта ошибка может быть вызвана наличием сетевого экрана между компьютером, на котором выполняется анализатор сервера Exchange, и целевым контроллером домена.

11032

Согласование с протоколом IPSEC

Запрос не прошел, так как не удалось согласовать подключение IPsec.

11050

Общая ошибка

Запрос не прошел по неизвестной причине.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, описывающей устранение неполадок в сетевых подключениях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Дополнительные сведения об эти проверках см. в базе знаний Майкрософт в статье 314825, описывающей устранение проблем, связанных с маршрутизаторами, действующими как черные дыры (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825).


Механизм маршрутизации остановлен
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Для ответа на вопрос, работают ли службы Microsoft Exchange Routing Engine (RESvc) и SMTPSVC (Simple Mail Transfer Protocol (SMTP)) Microsoft® Exchange Server Analyzer Tool направляет запрос классу Microsoft Windows® Management Instrumentation (WMI) Win32_Service. Средство анализа Exchange Server Analyzer отображает сообщение об ошибке, если обнаруживает выполнение хотя бы одного из следующих условий:

  • Запущена служба SMTPSVC.

  • Служба RESvc не запущена.

Ошибки при маршрутизации могут возникнуть, если служба RESvc запущена не на всех серверах Exchange, которые могут передавать сообщения. Конфигурация Exchange Server, позволяющая передавать сообщения без запуска RESvc, не поддерживается.

Как и Exchange 2000 Server, Exchange Server 2003 использует алгоритм маршрутизации состояния канала и протокол маршрутизации для распространения информации о состоянии канала в форме таблицы состояния каналов. Таблица состояния каналов хранится в памяти всех серверов Exchange 2000 Server и Exchange Server 2003 организации.

Использование алгоритма состояния канала имеет следующие преимущества:

  • Вместо рассылки сообщений по маршрутам с неработающими каналами сервер Exchange выбирает оптимальный маршрут передачи сообщения на компьютере-источнике.

  • Не требуется отправлять сообщения между серверами ни в одном из направлений, так как каждый сервер Exchange содержит информацию о существовании альтернативных или избыточных маршрутов.

  • Не происходит зацикливание сообщений. Зацикливание сообщений иногда появлялось в ранних версиях Exchange Server.

Из таблицы состояния каналов Exchange Server получает следующие сведения:

  • Таблица состояния каналов содержит топологию маршрутизации для всей организации Exchange.

  • Таблица состояния каналов содержит сведения о доступности всех соединителей в топологии сети. Доступность топологии отмечается как «up». Недоступность топологии отмечается как «down».

  • Таблица состояния каналов содержит сведения о стоимости и адресном пространстве, ассоциируемом с доступными соединителями.

Exchange Server использует эти данные для поиска маршрута с наименьшей стоимостью, ведущего к адресу назначения. Если в маршруте с минимальной стоимостью недоступен соединитель, то Exchange Server находит лучший альтернативный маршрут, основываясь на сведениях о стоимости и доступности соединителей. Для маршрутизации с использованием состояний каналов требуется служба RESvc.

Для исправления этой ошибки настройте автоматический запуск службы RESVc. Убедитесь, что служба RESvc работает в часы нагрузки.

Для исправления этой ошибки

  1. Нажмите кнопку Пуск, выберите пункт меню Программы, Администрирование и выберите Службы.

  2. В списке служб щелкните правой кнопкой мыши Microsoft Exchange Routing Engine, затем выберите пункт меню Свойства.

  3. На вкладке Общие в меню Загрузка выберите Автоматическая и нажмите кнопку OK.

  4. Правой кнопкой мыши щелкните Microsoft Exchange Routing Engine и выберите Запуск.

Для получения дополнительных сведений о сообщениях маршрутизации Exchange Server 2003 см. Руководство по пересылке и маршрутизации Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


Счетчики производительности RPC демонстрируют низкую производительность сервера
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2006-08-24

Средство анализатора сервера Microsoft® Exchange определило, что сервер не обеспечивает оптимальную производительность. Анализатор сервера Exchange проверяет множество счетчиков производительности уделенного вызова процедур (RPC). Если показания счетчиков производительности RPC ниже значений в приведенной далее таблице, на экран выводится предупреждение.

Число пользователей на сервере Exchange | Средний порог задержки RPC
Меньше 500 | Среднее значение больше 15
Больше или равно 500, но меньше 3000 | Среднее значение больше 30
Больше 3000 | Average greater than 50

Следующие счетчики производительности, обсуждаемые в данной статье, управляются объектом производительности MSExchangeIS:

  • Средняя задержка RPC

  • Запросы RPC

Средняя задержка RPC

Счетчик производительности Средняя задержка RPC регистрирует среднее время (в миллисекундах) обработки последних 1024 пакетов. Задержка представляет период времени от получения пакета процессом Store.exe до возвращения пакета. Счетчик производительности Средняя задержка RPC не учитывает задержки сети и прочие задержки, вызванные любыми компонентами, кроме процесса Store.exe. Хотя показания счетчика производительности Средняя задержка RPC не включают время передачи по сети, они предоставляют данные о наименьшем интервале времени ожидания ответа сервера клиентскими компьютерами. Если счетчик производительности Средняя задержка RPC показывает время меньше 50 мс., значит, сервер обеспечивает приемлемую скорость обработки запросов. Если в течение нескольких секунд счетчик показывает время больше 50 мс., это свидетельствует о том, что серверу тяжело справляться с нагрузкой. В результате возможны задержки во время доступа пользователей к электронной почте. Если среднее время задержки превышает 100 мс., то на клиентских компьютерах с Microsoft Office Outlook® отображается всплывающее окно со следующим текстом: «Получение данных из Exchange Server».

Анализ показаний счетчика производительности «Средняя задержка RPC»

Показания счетчика производительности Средняя задержка RPC могут быть неправильно интерпретированы в следующих ситуациях:

  • Некоторые операции MAPI занимают много времени. Например, если клиентский компьютер проверяет папку, содержащую тысячи элементов, в поисках элементов, соответствующих сложному набору критериев, такая операция может занять несколько секунд. При небольшом количестве пользователей на сервере выполнение такой операции может вызвать скачек в показаниях счетчика Средняя задержка RPC. При низкой нагрузке RPC на сервер среднее значение для этих показаний следует рассчитывать на основе более продолжительного периода времени (не менее нескольких минут) вместо анализа менее постоянного поведения за короткий срок.

  • Вторая ситуация возможна в условиях очень низкой нагрузки RPC на сервер. Иногда, в зависимости от действий наиболее активного пользователя, время задержки может сильно колебаться. В условиях повышенной загруженности сервера активная работа одного пользователя может значительно исказить показания средней задержки RPC.

Запросы RPC

Счетчик производительности Запросы RPC регистрирует число запросов клиентских компьютеров, обрабатываемых Exchange в настоящий момент. Для этого счетчика предусмотрено максимальное значение 100. Когда число обрабатываемых операций RPC достигает 100, хранилище Exchange обычно отклоняет последующие подключения. На исправном сервере число запросов в очереди должно быть меньше 50. Если в течение долгого времени сохраняется значение больше 50, значит, обработка запросов RPC откладывается и клиентские компьютеры наверняка испытывают задержки.

Интерпретация запросов RPC

Значение 50 запросов не является жестким порогом. Слабо загруженный сервер может начать испытывать проблемы произодительности до того, как значение счетчика достигнет 30. В то же время сильно загруженный сервер может работать нормально даже при достижении порога 50. В идеальном случае базовое значение данного счетчика должно рассчитываться для каждого сервера. Анализатор устранения неполадок сервера Exchange использует пороговое значение 50, подходящее для большинства крупных серверов.

По сравнению с сильно загруженным сервером для сервера со слабой загрузкой предусмотрено сниженное количество запросов RPC. Это объясняется тем, что слабо загруженному серверу требуется меньшее число потоков для обработки имеющейся нагрузки. Чтобы избежать задержек и обеспечить обработку большего числа запросов RPC, более загруженный сервер должен выполнять больший объем работы за единицу времени. Таким образом, на сильно загруженном сервере большее количество запросов RPC не свидетельствуют само по себе о проблеме производительности. Чтобы правильно оценить быстродействие сервера, необходимо также учесть показания счетчика производительности Средняя задержка RPC.

Причины задержки

Далее перечислены возможные причины увеличения задержки:

  • Повышение нагрузки RPC

  • «Узкое место» в одном или нескольких серверных ресурсах

Кроме того, возможны следующие причины появления «узкого места»:

  • Высокая нагрузка RPC (или любая другая нагрузка на сервер)

  • Неисправность оборудования или ошибка конфигурации

Чтобы устранить эту ошибку

  • Следуйте рекомендациям, содержащимся в следующих руководствах по Exchange Server 2003:

    • Руководство по управлению производительностью и масштабируемостью в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576)

    • Устранение неполадок, связанных с производительностью Exchange Server 2003 Performance (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588)


Диапазон RPC-портов задан на некластерном сервере
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить значение для портов, анализатор сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\Internet\Ports

Если анализатор сервера Exchange находит, что истинны следующие условия, он отображает ошибку:

  • Задан параметр HKLM\Software\Microsoft\Rpc\Internet\Ports.

  • Сервер не является кластерным сервером Exchange.

  • На сервере имеют место другие ошибки.

Если параметр реестра задан, для звонков RPC сервер Exchange ограничен определенным диапазоном портов. Если сервер Exchange находится под нагрузкой и нуждается в большем количестве портов, чем доступно в данный момент, могут происходить ошибки.

Чтобы устранить причину этой проблемы, следует к HKLM\Software\Microsoft\Rpc\Internet\Ports добавлять по 100 портов, пока проблемы не исчезнут.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неполадок. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра Regedt32.exe.

    Примечание.
    Чтобы изменить значение REG_MULTI_SZ, необходимо вместо Regedt32.exe использовать Regedit.exe.

  2. Перейдите в раздел реестра: HKLM\Software\Microsoft\Rpc\Internet.

  3. В правой области дважды щелкните параметр Ports. В окне значения увеличьте диапазон портов.

  4. Закройте редактор реестра и перезапустите сервер Exchange.

Перед началом редактирования реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт "Description of the Microsoft Windows registry" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения о параметрах раздела реестра HKLM\Software\Microsoft\Rpc\Internet см. в статье 154596 базы знаний Майкрософт, описывающей настройку динамического выделения портов RPC для работы с межсетевыми экранами (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=154596).


Диапазон портов RPC установлен на кластерном сервере
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Для определения значений, установленных для портов, средство анализа Microsoft® Exchange Server Analyzer Tool считывает следующий раздел реестра: HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\Internet\Ports

Exchange Server Analyzer отображает сообщение об ошибке, если обнаруживает выполнение следующих условий:

  • Раздел HKLM\Software\Microsoft\Rpc\Internet\Ports существует.

  • Сервер является кластерным сервером Exchange.

  • На сервере имеются другие ошибки.

Если параметр реестра существует, Exchange Server ограничивается определенным диапазоном портов для вызовов RPC. При нагрузке на сервер Exchange необходимости в большем числе портов, чем доступно в данный момент, может возникнуть ошибка.

Для исправления этой ошибки необходимо добавлять по 100 портов в раздел HKLM\Software\Microsoft\Rpc\Internet\Ports до исчезновения неполадки.

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что знаете, как восстановить реестр в случае возникновения проблем. Сведения о восстановлении реестра находятся в разделе справки «Восстановление реестра» файла Regedit.exe или Regedit32.exe.
Для устранения этого предупреждения

  1. Откройте редактор реестра Regedit32.exe.

    Примечание.
    Для изменения параметра типа REG_MULTI_SZ вместо редактора Regedit.exe необходимо использовать редактор Regedit32.exe.

  2. Перейдите к разделу HKLM\Software\Microsoft\Rpc\Internet.

  3. На правой панели щелкните раздел Ports. В поле ввода значения увеличьте Port Range.

  4. Закройте редактор реестра и перезапустите сервер Exchange.

Перед правкой реестра для получения дополнительных сведений обратитесь к статье 256986 Базы Знаний Microsoft «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Для получения дополнительных сведений о разделах реестра HKLM\Software\Microsoft\Rpc\Internet см. статью 154596 Базы знаний Microsoft «Настройка динамического назначения портов удаленного вызова процедур для взаимодействия с брандмауэром» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=154596).


Активность применения пользователями удаленных вызовов процедур, определяемая по счетчикам производительности
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2007-02-14

Средство анализатора сервера Microsoft® Exchange определило, что в текущий момент удаленные вызовы процедур (remote procedure call, RPC) создают высокую нагрузку на сервер.

Интенсивность удаленных вызовов процедур в виде количества операций за секунду служит индикатором нагрузки, которую создают на сервере удаленные вызовы процедур. Иногда неожиданное увеличение рабочей нагрузки, создаваемой удаленными вызовами процедур, может приводить к падению производительности сервера. Если на сервере возникают проблемы с производительностью, следует сначала определить, превышает ли нагрузка на сервер ее ожидаемое значение. Существует несколько счетчиков производительности, которые предоставляют сведения об интенсивности удаленных вызовов процедур на сервере. Все следующие счетчики производительности, рассматриваемые в данной статье, находятся в объектах производительности MSExchangeIS, MSExchangeIS Public или MSExchangeIS Mailbox:

  • Операций RPC/сек,

  • Счетчик активных пользователей,

  • Входы в систему активных клиентов (MSExchangeIS Public)

  • Входы в систему активных клиентов (MSExchangeIS Mailbox)

Идентификация нагрузки, создаваемой клиентскими удаленными вызовами процедур

Существует два счетчика, которые можно использовать для определения текущей активности клиентских компьютеров.

  • Операций RPC/сек — этот счетчик предоставляет количество операций, выполняемых в секунду, которые связаны с запросами на сервере удаленных вызовов процедур клиентскими компьютерами. Пользователей можно посчитать следующими способами:

    • Можно посчитать общее количество почтовых ящиков на сервере.

    • Общее количество входов в систему можно определить, сложив значения Входы в систему активных клиентов для объекта MSExchangeIS Public и Входы в систему активных клиентов для объекта MSExchangeIS Mailbox.

    • Можно посчитать общее количество входов в систему из Счетчика активных пользователей.

    Анализатор сервера Exchange использует последний метод. Чтобы рассчитать интенсивность операций, приходящихся на одного активного пользователя, разделите среднее значение счетчика Операций RPC/сек на значение Счетчик активных пользователей.

  • Операций RPC/сек на пользователя — этот счетчик предоставляет показание активности пользователей на сервере. Обычно активность работников умственного труда, использующих Microsoft Office Outlook®, составляет приблизительно 0,1 операций/сек в расчете на пользователя на почтовом сервере. Если пользователи на сервере запускают дополнительные приложения, этот показатель активности может возрасти.

Если анализатор сервера Exchange определит, что число операций RPC в секунду, приходящихся на одного пользователя, превышает 0,15, но меньше 0,25, активность пользователей считается умеренной и анализатор сервера Exchange выведет на экран предупреждение.

Если анализатор сервера Exchange определит, что число операций RPC в секунду, приходящихся на одного пользователя, превышает 0,25, в этом случае считается что активность пользователей больше обычной, и анализатор сервера Exchange выведет на экран сообщение об ошибке.

Действия, предпринимаемые при высокой нагрузке RPC

Если количество операций в секунду превышает ожидаемое значение, следует сначала попробовать идентифицировать причину высокой нагрузки, а затем уменьшить нагрузку. Можно использовать средство наблюдения за пользователями сервера Exchange (ExMon), чтобы определить, является ли источником высокой интенсивности операций RPC какой-либо конкретный пользователь.

Если невозможно уменьшить нагрузку на сервер, следует идентифицировать узкие места в работе сервера и увеличить производительность сервера.

Идентификация большого количества входов в систему

Необходимо, чтобы сервер сохранял некоторые сведения о входах в систему в памяти (как в пользовательской памяти, так и в памяти ядра операционной системы). Выделяется ограниченный объем памяти. Если эта память используется, на сервере может возникнуть дефицит памяти. По этой причине если на сервере Exchange возникает проблема с производительностью, следует убедиться, что общее количество входов в систему в расчете на пользователя не является чрезмерно большим.

Обычно на одного работника умственного труда приходится два или три входа в систему. Если пользователи запускают другие приложения, количество входов в систему может возрасти. Анализатор сервера Exchange рассчитывает количество входов в систему, приходящихся на одного пользователя, путем деления общего количества входов в систему сервера на количество почтовых ящиков на сервере. Общее количество входов на сервер можно определить посредством сложения значений счетчиков производительности Входы в систему активных клиентов для рабочих объектов MSExchangeIS Mailbox и MSExchangeIS Public. Для почтовых серверов и смешанных серверов почтовых ящиков и общих папок анализатор сервера Exchange просматривает только этот показатель.

Примечание.
Если большое число пользователей просматривают общие папки других пользователей (например, общие календари), количество входов в систему может также быть большим.

Если среднее количество входов в систему в расчете на пользователя больше пяти и на сервере возникает дефицит памяти, это может указывать на то, что пользователи запускают приложения, которые создают большое количество входов в систему. Если пользователи запускают приложения, которые не нужны непосредственно для работы, попросите, чтобы они не запускали приложения, приводящие к избыточным входам в систему сервера Exchange.

Если невозможно уменьшить количество приложений, запускаемых пользователями, следует уменьшить количество пользователей в расчете на сервер, переместив пользователей на другой сервер. Чтобы определить, обусловлено ли чрезмерное количество входов в систему большим количеством пользователей или непропорционально большое количество входов в систему связано с каким-либо одним пользователем, можно воспользоваться системным диспетчером Exchange для просмотра активных входов в систему по каждому пользователю.

Дополнительные сведения

  • Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Дополнительные сведения об устранении проблем производительности сервера Exchange см. в описании процедур устранения неполадок, связанных с производительностью Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Антивирусное сканирование RTF отключено
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить значение параметра антивирусного сканирования сообщений в формате RTF (Rich Text Format), средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Если анализатор сервера Exchange определяет, что для параметра ScanRTF задано значение 0, на экран выводится предупреждение.

Параметр реестра ScanRTF задается антивирусными программами сторонних поставщиков, использующими интерфейс VSAPI (Exchange Virus Scanning API). Сообщения в формате RTF позволяют использовать цвета, шрифты и форматирование, но формат RTF читается только клиентом Microsoft Office Outlook® 2003. Формат RTF сервера Exchange отличается от формата RTF текстового процессора, такого как Microsoft Office Word 2003.

Рекомендуется проверять на наличие вирусов сообщения всех типов, включая сообщения в формате RTF. Следует включить сканирование всех сообщений, проходящих через компьютер сервера Exchange.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить эту ошибку

  1. Включите сканирование всех сообщений в антивирусной программе с поддержкой Exchange.

    или

  2. Вручную измените запись реестра, выполнив следующие действия:

    • Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

    • Перейдите к разделу реестра:

      HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

    • Дважды щелкните запись реестра ScanRTF и введите 1 в поле «Значение».

    • Чтобы изменения вступили в силу, закройте редактор реестра и перезапустите службу «Банк данных Microsoft Exchange», а также службы, представляющие антивирусное программное обеспечение с поддержкой Exchange.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в статье 256986 базы знаний Майкрософт, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о борьбе с вирусами см. на веб-узле, посвященном обезвреживанию вирусов, передаваемых по электронной почте, в среде Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=30732).


Заголовок SMTP был изменен
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2006-05-17

Средство анализатора сервера Microsoft® Exchange пытается отправить сообщение учетной записи администратора или пользовательской учетной записи в домен SMTP. Анализатор сервера Exchange выводит предупреждение, получив от этой учетной записи ответ, отличающийся от следующего ответа по умолчанию:

"220 Имя компьютера . Имя домена .com Служба Microsoft ESMTP MAIL, Версия: Номер версии готовый, на Дату Время +0000"

Это предупреждение показывает, что ответ по умолчанию, который появляется при подключении программы к виртуальному SMTP-серверу Exchange, был изменен.

Измененный заголовок SMTP может и не быть проблемой, если администратор сервера Exchange Server специально изменил заголовок, выполнив действия, описанные в статье 281224 базы знаний Майкрософт, посвященной изменению заголовка SMTP (http://go.microsoft.com/fwlink/?linkid=3052&kbid=281224).

Если заголовок SMTP по умолчанию не был специально изменен администратором сервера Exchange, это предупреждение может показывать, что сервер Exchange расположен за брандмауэром или прокси-сервером SMTP, фильтрующим расширенные команды сервера Exchange (ESMTP).

Фильтрация ESMTP-команд сервера Exchange может заметно повлиять на производительность Exchange и привести к поведению, описанному в статье 320027 базы знаний Майкрософт, посвященной невозможности отправки или получения сообщений электронной почты за брандмауэром Cisco PIX (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027).

Дополнительные сведения об измененных заголовках SMTP см. в следующих статьях базы знаний Майкрософт:

  • Статья 281224, посвященная изменению заголовков SMTP (http://go.microsoft.com/fwlink/?linkid=3052&kbid=281224).

  • Статья 320027, посвященная невозможности отправки или получения сообщений электронной почты за брандмауэром Cisco PIX (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027).


Экземпляр SMTP приостановлен
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2006-05-16

Анализатор сервера Microsoft® Exchange запрашивает метабазу IIS, чтобы определить значение свойства ServerState для каждого из экземпляров виртуального сервера SMTP.

Свойство ServerState отображает текущее состояние экземпляра сервера. Ниже приводятся возможные состояния и соответствующие им коды состояний: 1 (запуск), 2 (запущен), 3 (останов), 4 (остановлен), 5 (пауза), 6 (приостановлен) и 7 (работает).

Если анализатор сервера Exchange обнаруживает, что значение свойства ServerState экземпляра виртуального сервера SMTP равно 6 (приостановлен), выводится сообщение об ошибке.

Протокол SMTP представляет собой естественный протокол электронной почты для отправки и транспортировки почты сервером Exchange. Это означает, что протокол SMTP используется клиентскими компьютерами для отправки сообщений, а серверами Exchange — для доставки сообщений и данных этих сообщений.

Виртуальные серверы выполняются в серверном процессе, который можно запустить, остановить или приостановить, аналогично другим серверным процессам. Например, при изменении конфигурации виртуального сервера или выполнении других задач по обслуживанию может возникнуть необходимость остановить виртуальный сервер, внести нужные изменения, а затем перезапустить сервер. Если виртуальный сервер остановлен, он не принимает пользовательские подключения и его нельзя использовать для доставки или извлечения почты.

Альтернатива останову виртуального сервера — его приостанов. Если виртуальный сервер приостановлен, новые клиентские подключения будут недоступны, однако существующие подключения не разрываются. Если приостановлен виртуальный сервер SMTP, активные клиенты могут продолжать отправлять сообщения, а виртуальный сервер может доставлять сообщения, включенные в очередь доставки. Однако новые подключения не принимаются.

Для обычных операций обмена сообщениями экземпляры виртуального SMTP-сервера Exchange Server должны быть запущены.

Чтобы устранить эту ошибку, запустите нужный экземпляр виртуального SMTP-сервера, выполнив следующие ниже шаги.

Чтобы запустить экземпляр виртуального SMTP-сервера

  1. В диспетчере Exchange щелкните правой кнопкой мыши экземпляр виртуального сервера, который нужно запустить.

  2. В меню «Действие» выберите команду Запустить.

Дополнительные сведения о запуске, останове и приостановке виртуальных SMTP-серверов см. в следующих статьях базы знаний Microsoft:

  • «XCON: How to Configure a SMTP Virtual Server Part 1» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) (XCON: инструкции по настройке виртуального SMTP-сервера, часть 1).

  • «XCON: How to Configure a SMTP Virtual Server Part 2» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (XCON: инструкции по настройке виртуального SMTP-сервера, часть 2).

  • «XIMS: How to Flush the SMTP Mail Queue in Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=251087) (XIMS: инструкции по очистке очереди SMTP-сообщений в Exchange 2000 Server).

  • «XGEN: Disabling Protocols in Exchange 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=291330) (XGEN: отключение протоколов в Exchange 2000).


Экземпляр SMTP остановлен
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2006-05-16

Средство анализатора сервера Microsoft® Exchange запрашивает метабазу IIS, чтобы определить значение свойства ServerState для каждого из экземпляров виртуального SMTP-сервера.

Свойство ServerState отображает текущее состояние экземпляра сервера. Ниже приводятся возможные состояния и соответствующие им коды состояний: 1 (запуск), 2 (запущен), 3 (останов), 4 (остановлен), 5 (пауза), 6 (приостановлен) и 7 (работает).

Если анализатор сервера Exchange обнаруживает, что значение свойства ServerState экземпляра виртуального SMTP-сервера равно 4 (остановлен), анализатор сервера Exchange выводит сообщение об ошибке.

Протокол SMTP представляет собой естественный протокол электронной почты для отправки и транспортировки почты сервером Exchange. Это означает, что протокол SMTP используется клиентскими компьютерами для отправки сообщений, а серверами Exchange — для доставки сообщений и данных этих сообщений.

Виртуальные серверы выполняются в серверном процессе, который можно запустить, остановить или приостановить, аналогично другим серверным процессам. Например, при изменении конфигурации виртуального сервера или выполнении других задач по обслуживанию может возникнуть необходимость остановить виртуальный сервер, внести нужные изменения, а затем перезапустить сервер. Если виртуальный сервер остановлен, он не принимает пользовательские подключения и его нельзя использовать для доставки или извлечения почты.

Для обычных операций обмена сообщениями экземпляры виртуального SMTP-сервера Exchange Server должны быть запущены.

Чтобы устранить эту ошибку, запустите нужный экземпляр виртуального SMTP-сервера, выполнив следующие ниже шаги.

Чтобы запустить экземпляр виртуального SMTP-сервера

  1. В системном диспетчере Exchange щелкните правой кнопкой мыши экземпляр виртуального сервера, который нужно запустить.

  2. В меню «Действие» выберите команду Запустить.

Дополнительные сведения о запуске, останове и приостановке виртуальных SMTP-серверов см. в следующих статьях базы знаний Microsoft:

  • "XCON: How to Configure an SMTP Virtual Server Part 1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) (XCON: инструкции по настройке виртуального SMTP-сервера - часть 1).

  • "XCON: How to Configure an SMTP Virtual Server Part 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (XCON: инструкции по настройке виртуального SMTP-сервера - часть 2).

  • "XIMS: How to Flush the SMTP Mail Queue in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=251087) (XIMS: инструкции по очистке очереди SMTP-сообщений в Exchange 2000 Server).

  • "XGEN: Disabling Protocols in Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=291330) (XGEN: отключение протоколов в Exchange 2000).


Возможно, установлено слишком малое значение для максимального числа получателей в SMTP
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить, меньше ли настроенное значение атрибута msExchSmtpMaxRecipients чем 250. По умолчанию атрибут msExchSmtpMaxRecipients настроен для 64 000 получателей. Если анализатор сервера Exchange обнаружит, что установленное значение атрибута msExchSmtpMaxRecipients меньше 250, на экран будет выведено предупреждение.

С точки зрения безопасности рекомендуется ограничить максимальное количество получателей для всех сообщений. Рекомендуется оставить атрибут msExchSmtpMaxRecipients установленным в значение по умолчанию, равное 64000.

В каждой организации должны определить приемлемое максимальное число получателей на основе требований собственной сферы деятельности. Однако рекомендуется не устанавливать максимальное количество получателей менее 250. Скорее всего, сообщения, адресуемые в несколько списков рассылки, будут иметь более 250 получателей. Если установить максимальное число получателей менее 250, приложение Exchange должно будет обрабатывать остальных получателей, используя дополнительные копии сообщения. Эти дополнительные копии приведут к увеличению сетевого трафика.

Чтобы просмотреть и настроить максимальное число получателей

  1. Откройте диспетчер Exchange.

  2. Разверните узео Серверы, затем разверните сервер Exchange, Протоколы и SMTP.

  3. Щелкните правой кнопкой мыши виртуальный SMTP-сервер, например виртуальный SMTP-сервер по умолчанию, а затем выберите команду Свойства.

  4. Откройте вкладку Сообщения.

  5. Чтобы вернуться к настройке по умолчанию, равной 64000, убедитесь, что флажок Предельное число получателей сообщения установлен, и введите значение 64000. В альтернативном варианте можно задать в этом поле любое требуемое значение или снять флажок, чтобы разрешить получение сообщения неограниченному числу получателей.

  6. Нажмите кнопку ОК, чтобы сохранить изменения и закрыть диалоговое окно Свойства виртуального SMTP-сервера.

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • статья 266686, описывающая первую часть инструкций по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686);

  • статья 268163, описывающая вторую часть инструкций по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).


Адрес прокси-сервера SMTP для EAS был изменен
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Сообщение об ошибке

Введение

Чтобы определить, был ли изменен адрес прокси-сервера SMTP для Exchange ActiveSync®, средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MasSync\Parameters\SMTPProxy

Если анализатор обнаружит, что значение раздела SMTPProxy существует и настроено, отображается сообщение о нестандартной конфигурации.

SMTP-адреса используются для идентификации пути к почтовому ящику в Exchange Server и должны быть уникальными. Каждый адрес состоит из левой и правой частей, разделенных символом @. Ниже приведен правильный формат SMTP-адреса:

имя_пользователя@домен.ru = левая_часть@правая_часть

Exchange ActiveSync использует запрос WebDAV для получения доступа к сведениям сервера Exchange о почтовом ящике. Затем Exchange ActiveSync выбирает соответствующее значение правой части адреса, чтобы использовать его в запросе WebDAV. В средах, где правая часть адреса установлена по умолчанию, но отличается от основного SMTP-адреса пользователя, значение реестра SMTPProxy предоставляет возможность такой конфигурации, чтобы Exchange ActiveSync использовал альтернативный адрес прокси-сервера SMTP.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы просмотреть или изменить значение реестра SMTPProxy

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра

    HKLM\System\CurrentControlSet\Services\MasSync\Parameters

  3. Просмотрите и, если необходимо, измените значение SMTPProxy.

  4. Если изменение внесено, закройте редактор реестра и перезагрузите компьютер сервера Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о Exchange ActiveSync см. на веб-узле, посвященном архитектуре ActiveSync в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=34203).

Дополнительные сведения о мобильном доступе и Exchange Server 2003 см. на веб-узле, посвященном мобильному доступу с помощью Exchange 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=20098).


SMTP-сервер допускает обычную проверку подлинности
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchAuthenticationFlags в классе protocolCfgSMTPServer для объекта Exchange Server. Класс protocolCfgSMTPServer содержит параметры виртуального сервера SMTP. Атрибут msExchAuthenticationFlags представляет тип проверки подлинности, допустимый на сервере SMTP. Если анализатор сервера Exchange обнаруживает, что на сервере SMTP была настроена обычная проверка подлинности и при этом сервер не является Microsoft Small Business Server 2000 или Microsoft Windows® Small Business Server 2003, на экран выводится предупреждение.

Если на сервере SMTP включена обычная проверка подлинности, то увеличивается вероятность нарушения безопасности. Обычная проверка подлинности допускает отправку имен пользователей и паролей по сети открытым текстом. Без использования шифрования имена пользователей и пароли могут быть легко перехвачены в Интернете.

При использовании обычной проверки подлинности настоятельно рекомендуется применять TLS-шифрование (Transport Layer Security) для обеспечения большей защиты. TLS шифрует имена пользователей, пароли и данные сообщений. Можно задать обязательное TLS-шифрование для клиентов, подключающихся к виртуальному SMTP-серверу. Технология TLS помогает защитить исходящие сообщения, однако не защищает трафик, идущий от клиентов к серверу.

Технология TLS поддерживается программой Microsoft Outlook Express. Чтобы использовать TLS-шифрование для виртуального сервера SMTP, необходимо создать пары ключей и настроить сертификаты ключа. После этого клиенты смогут использовать TLS для шифрования сеанса со службой SMTP. Таким образом, это относится только к исходящим сообщениям. Служба SMTP также может использовать технологию TLS для шифрования сеансов с удаленными серверами.

Примечание.
Клиенты, не поддерживающие TLS, не могут выполнять ретрансляцию сообщений электронной почты через виртуальный сервер.

Если на виртуальном SMTP-сервере нельзя отключить доступ с проверкой подлинности (например, требуется проверка подлинности для партнерской компании), выполните следующие действия для повышения безопасности сервера шлюза:

  • Примените политику надежного пароля для всех учетных записей пользователя, особенно для учетной записи администратора.

  • Отключите учетную запись «Гость». Дополнительные сведения об отключении учетной записи «Гость» см. в статье 320053 базы знаний Майкрософт, описывающей переименование учетной записи гостя и администратора в системе Windows 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320053). Хотя эта статья относится к Microsoft Windows 2000 Server, аналогичные принципы используются и в Windows Server™ 2003.

Чтобы отключить обычную проверку подлинности

  1. В системном диспетчере Exchange разверните узел Серверы, затем узел <входящего сервера Exchange>, узел Протоколы и узел SMTP.

  2. Щелкните правой кнопкой мыши входящий виртуальный SMTP-сервер и выберите команду Свойства.

  3. Откройте вкладку Доступ и щелкните Проверка подлинности.

    Диалоговое окно «Проверка подлинности»

  4. В диалоговом окне Проверка подлинности снимите флажок Обычная проверка подлинности.

    Важно!
    Если применяется обычная проверка подлинности, рассмотрите возможность реализации TLS-шифрования для повышения уровня безопасности. При наличии цифрового сертификата установите флажок Требуется TLS-шифрование. Использование цифровых сертификатов распространено в средах с высоким уровнем защиты. При установке этого флажка в связанном поле Домен по умолчанию необходимо ввести имя домена Windows 2000 Server или Windows Server 2003, с помощью которого пользователь должен будет выполнять проверку подлинности в тех случаях, когда он не указывает домен самостоятельно. Дополнительные сведения о TLS-шифровании см. в интерактивной документации по Exchange.

Дополнительные инструкции по настройке организации Exchange Server 2003 для более безопасной отправки и получения почты через Интернет см. в руководстве по транспорту и маршрутизации Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=26041).


Служба SMTP отключена
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2006-05-16

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Service, чтобы определить значение ключа StartMode службы SMTP. Значение Disabled показывает, что служба SMTP была отключена и не может быть запущена, пока значение StartMode не будет изменено либо на Manual, либо на Automatic.

Анализатор сервера Exchange запрашивает WMI-класс Win32_Service, чтобы определить значение ключа Started для службы SMTP. Значение False показывает, что служба не запущена. Значение True показывает, что служба запущена.

Если анализатор сервера Exchange обнаруживает, что значение ключа StartMode на компьютере сервера Exchange, где запущена служба SMTP, равно Disabled, анализатор сервера Exchange выводит сообщение об ошибке.

Служба SMTP Windows является компонентом службы IIS и выполняется как часть Inetinfo.exe. Сервер Exchange использует службу SMTP как собственный протокол передачи. Следовательно, Exchange использует SMTP для маршрутизации внутренних и внешних сообщений.

На всех компьютерах серверов Exchange Server для службы SMTP должен быть выбран вариант Automatic.

Чтобы исправить эту ошибку, необходимо настроить службу SMTP так, чтобы на серверах маршрутизации почты она запускалась автоматически.

Настройка автоматического запуска службы SMTP

  1. Откройте оснастку «Службы» консоли MMC.

  2. Дважды щелкните службу SMTP.

  3. На вкладке Общие страницы SMTP: Свойства, выберите значение Автоматически в раскрывающемся списке Тип запуска, а затем нажмите кнопку Применить.

  4. В разделе Состояние щелкните Пуск, а затем нажмите кнопку OK.

  5. Закройте оснастку «Службы».

Дополнительные сведения о службе SMTP и серверах Exchange см. в разделе «Архитектура передачи SMTP» в руководства по транспорту и маршрутизации сервера Exchange (http://go.microsoft.com/fwlink/?LinkId=47579, возможно, на английском языке).

Дополнительные сведения о настройке службы SMTP для Exchange см. в разделе «Настройка SMTP в Microsoft Exchange 2000 Server» по адресу http://go.microsoft.com/fwlink/?LinkId=24866 (возможно, на английском языке).


Служба SMTP не запущена
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2007-03-13

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Windows® Management Instrumentation) Win32_Service, чтобы определить значение ключа Started для службы SMTP. Значение False указывает, что служба SMTP не выполняется. Значение True указывает, что служба SMTP выполняется.

Если анализатор сервера Exchange обнаруживает, что для ключа Started задано значение False, на экран выводится сообщение об ошибке.

Служба SMTP в системе Windows является компонентом службы IIS (Internet Information Services) и выполняется в составе программы Inetinfo.exe. Exchange Server использует службу SMTP в качестве встроенного транспортного протокола. Таким образом, Exchange использует SMTP для маршрутизации всех внутренних и внешних сообщений.

Служба SMTP должна всегда выполняться на серверах Exchange.

Чтобы устранить эту ошибку

  1. Откройте оснастку MMC «Службы».

  2. В правой области выполните прокрутку до службы SMTP (Simple Mail Transfer Protocol) и дважды щелкните ее. Откроется диалоговое окно Свойства SMTP (Simple Mail Transfer Protocol).

  3. В раскрывающемся меню Тип запуска выберите значение Авто.

  4. Нажмите кнопку Пуск для запуска службы системного помощника.

  5. Нажмите кнопку ОК, чтобы сохранить изменения и закрыть диалоговое окно Свойства SMTP (Simple Mail Transfer Protocol).

  6. Закройте оснастку «Службы».

Дополнительные сведения о службе SMTP и серверах Exchange см. в разделе, описывающем архитектуру транспорта SMTP технического руководства по Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47891).

Дополнительные сведения о настройке службы SMTP для Exchange см. в разделе, посвященном настройке службы SMTP в Microsoft Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=24866).


Для службы SMTP установлен ручной режим
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2006-05-16

Анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Service, чтобы определить значение ключа StartMode службы SMTP. Значение Manual указывает, что для службы SMTP установлен вывод запроса на ручной запуск и эта служба не будет запускаться автоматически.

Анализатор сервера Exchange также запрашивает WMI-класс Win32_Service, чтобы определить значение ключа Started службы SMTP. Значение False указывает, что служба не выполняется. Значение True указывает, что служба выполняется.

Если анализатор сервера Exchange обнаруживает, что для ключа StartMode задано значение Manual на компьютере сервера Exchange с запущенной службой SMTP, выводится предупреждение.

SMTP-служба Windows является компонентом служб IIS и выполняется при выполнении программы Inetinfo.exe. Сервер Exchange использует данную службу SMTP как свой основной транспортный протокол. Таким образом Exchange использует службу SMTP для маршрутизации всех внутренних и внешних сообщений.

Если служба SMTP не запускается автоматически при запуске компьютера, она может быть не замечена. Это может привести к серьезным проблемам почты.

На всех компьютерах сервера Exchange следует установить для службы SMTP значение Automatic.

Чтобы устранить эту ошибку, необходимо настроить автоматический запуск службы SMTP на серверах, отвечающих за маршрутизацию сообщений.

Чтобы задать автоматический запуск службы SMTP

  1. Откройте оснастку «Службы» консоли управления (MMC).

  2. Дважды щелкните службу Simple Mail Transfer Protocol (SMTP).

  3. На вкладке Общие страницы Свойства Simple Mail Transfer Protocol (SMTP) выберите в раскрывающемся диалоговом окне Тип запуска параметр Автоматически, а затем нажмите кнопку Применить.

  4. В разделе Состояние службы щелкните Запустить, а затем нажмите кнопку ОК.

  5. Закройте оснастку «Службы».

Дополнительные сведения о службе SMTP и серверах Exchange см. в разделе «SMTP Transport Architecture» (Транспортная архитектура SMTP» руководства Exchange Server Transport and Routing Guide (http://go.microsoft.com/fwlink/?LinkId=47579) (Руководство по транспорту и маршрутизации сервера Exchange).

Дополнительные сведения о настройке службы SMTP для Exchange см. в документе «Configuring SMTP in Microsoft Exchange 2000 Server» (http://go.microsoft.com/fwlink/?LinkId=24866) (Настройка SMTP в Microsoft Exchange 2000 Server).


Состояние службы SMTP неизвестно
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2006-10-06

Средство анализа Microsoft® Exchange Server запрашивает класс WMI (Microsoft Windows® Management Instrumentation) Win32_Service, чтобы определить значение ключа Started для службы SMTP. Значение False указывает на то, что служба SMTP не запущена. Значение True указывает на то, что служба SMTP запущена.

Если средство анализа Exchange Server не может определить значение параметра Started, то выдается сообщение об ошибке.

Эта ошибка указывает, что по запросу WMI не удалось получить требуемые данные.

Ниже перечислены возможные причины данной ошибки:

  • Учетная запись, от имени которой запущено средство анализа Exchange Server, не имеет достаточных разрешений на запрос классов WMI.

  • Подключение средства анализа Exchange Server к компьютеру невозможно из-за неполадок в сети.

  • Переходное состояние неизвестного происхождения вызвало истечение времени запроса.

Устранение этой ошибки

  1. Убедитесь, что компьютер с сервером Exchange Server включен и подсоединен к сети.

  2. Определите, доступен ли компьютер с сервером Exchange, с помощью команды PING.

  3. При наличии брандмауэра проверьте, не блокированы ли порты удаленного вызова процедур.

  4. Проверьте разрешения учетной записи, от имени которой выполняется средство анализа Exchange Server. Учетная запись, с которой выполняется средство анализа Exchange Server, должна обладать разрешениями локального администратора на каждом сканируемом сервере Exchange Server.

    Можно также предоставить учетной записи, от имени которой запущено средство анализа Exchange Server, особые разрешения WMI:

    1. На сервере Exchange Server откройте дерево Computer Management консоли MMC.

    2. В ветви Services and Applications щелкните правой кнопкой мыши WMI Control и выберите команду Properties.

    3. В диалоговом окне WMI Controls Property перейдите на вкладку Security и разверните пункт Root.

    4. Выберите папку CIMV2 и щелкните Security.

    5. На странице Security for ROOT\CIMV2 добавьте учетную запись, от имени которой выполняется анализатор сервера Exchange.

  5. Выберите учетную запись, добавленную в шаге 5. В поле Permissions for выбранная_запись в столбце Allow выберите Remote Enable и Read Security, а затем нажмите кнопку ОК.

Дополнительные сведения о службе SMTP и серверах Exchange Server см. в разделе «Архитектура передачи данных SMTP» в техническом руководстве по Exchange Server 2003 по адресу: http://go.microsoft.com/fwlink/?LinkId=47891 (на английском языке).

Дополнительные сведения о настройке службы SMTP для сервера Exchange Server см. в разделе «Настройка протокола SMTP на сервере Microsoft Exchange 2000» по адресу http://go.microsoft.com/fwlink/?LinkId=24866 (на английском языке).

Дополнительные сведения об устранении проблем в сетевых подключениях см. в статье 325487 базы знаний Майкрософт «Разрешение проблем, связанных с выполнением сетевого подключения» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Дополнительные сведения об устранении неполадок в подключениях средства анализа Exchange Server см. в статье «Устранение неполадок, связанных с подключениями средства анализатора рекомендаций Microsoft Exchange Server» по адресу http://go.microsoft.com/fwlink/?LinkId=56285 (на английском языке).


Одновременно включены параметры реестра UseAltRegionalCharset и UseRegionalCharset
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-12-15

Чтобы определить языковые настройки, используемые веб-клиентами Microsoft Outlook®, средство анализатора сервера Microsoft® Exchange считывает следующие записи реестра:

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

    Если этот параметр имеет значение 1, текст сообщений UTF-8 хранится в хранилище в региональном наборе символов или в региональной кодовой странице, а не в формате UTF-8. Это значение по умолчанию для параметра реестра UseRegionalCharset в Exchange Server 2003.

  • HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseAltRegionalCharset

Обозреватель определяет кодировку сообщений, если выполняются следующие условия:

  • Раздел UseAltRegionalCharset не установлен или равен 0.

  • Соответствующий раздел UseRegionalCharset также не установлен или равен 0.

Современные обозреватели, например Internet Explorer версии 5 или более поздней, отправляют сообщения в формате UTF-8. Обозреватели более ранней версии или обозреватели, отличные от Internet Explorer 5, отправляют сообщения в кодировке, соответствующей допустимому языку этого обозревателя.

Раздел UseAltRegionalCharset меняет только поведение обозревателя, настроенного для следующих кодировок:

  • корейская: KS_C_5601-1987

  • японская: shift_jis

  • западноевропейская: windows-1252

  • русская: windows-1251

  • центральноевропейская: windows-1250

Если значение UseAltRegionalCharset равно 1, то и современные, и более старые обозреватели будут отправлять сообщения в следующих кодировках:

  • корейская: euc_kr

  • японская: iso-2022-jp (JIS)

  • западноевропейская: iso-8859-1

  • русская: koi8-r

  • центральноевропейская: iso-8859-2

Анализатор сервера Exchange также запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumber для всех объектов, относящихся к классу msExchExchangeServer.

  • Если строковое значение содержит «Version 6.0», на компьютере выполняется Exchange 2000 Server.

  • Если строковое значение содержит выражение «Version 6.5», на компьютере выполняется Exchange Server 2003.

Анализатор сервера Exchange выводит предупреждение, если выполняются следующие условия:

  • Установлены как параметр UseAltRegionalCharset, так и параметр UseRegionalCharset

  • Как для параметра UseAltRegionalCharset, так и для параметра UseRegionalCharset указано значение 1 на сервере Exchange 2000 или на сервере Exchange 2003.

В Exchange 2000 Server и Exchange Server 2003 используется альтернативный набор знаков, если выполнены следующие условия:

  • Включено использование региональной кодировки — для параметра реестра UseRegionalCharset установлено значение -1 с типом REG_DWORD.

  • Включено использование региональной кодировки — для параметра реестра UseAltRegionalCharset установлено значение 0x1 с типом REG_DWORD.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.
Чтобы устранить эту проблему

  1. На компьютере Exchange откройте редактор реестра, например Regedit.exe или RegEdt32.exe.

  2. Определите, какие языковые параметры веб-клиента Outlook соответствуют среде сервера Exchange и удалите ненужный раздел.

    1. Перейдите в раздел реестра: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

    2. Выберите раздел, который нужно удалить, щелкните его правой кнопкой мыши и выберите в контекстном меню команду Удалить.

  3. Закройте редактор реестра.

Перед началом редактирования реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт "Description of the Microsoft Windows registry" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения о языковых параметрах веб-клиента Outlook см. в следующих ресурсах сервера Exchange:

Документ «Exchange Server Client Access Guide» (http://go.microsoft.com/fwlink/?LinkId=47568) (Руководство по клиентскому доступу для Exchange Server).

Статья 311342 базы знаний Майкрософт «XCCC: Exchange 2000 Server SP2 Server-Side OWA Registry Keys» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311342) (XCCC: разделы реестра серверной части веб-клиента Outlook в Exchange 2000 Server с пакетом обновления 2).


Значение реестра UseAltRegionalCharset включено на сервере Exchange 2000
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-12-15

Средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра, чтобы определить, используется ли параметр UseAltRegionalCharset для настройки клиентского языка веб-клиента Microsoft Outlook®:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseAltRegionalCharset

Обозреватель определяет кодировку сообщений, если выполняются следующие условия:

  • Раздел UseAltRegionalCharset не установлен или равен 0.

  • Относящийся к предыдущему раздел UseRegionalCharset также не установлен или равен 0.

Раздел UseAltRegionalCharset меняет только поведение обозревателя, настроенного для следующих кодировок:

  • корейская: KS_C_5601-1987

  • японская: shift_jis

  • западноевропейская: windows-1252

  • русская: windows-1251

  • центральноевропейская: windows-1250

Если значение UseAltRegionalCharset равно 1, то и современные, и более старые обозреватели будут отправлять сообщения в следующих кодировках:

  • корейская: euc_kr

  • японская: iso-2022-jp (JIS)

  • западноевропейская: iso-8859-1

  • русская: koi8-r

  • центральноевропейская: iso-8859-2

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumber для всех объектов, класс объекта которых равен msExchExchangeServer. Если строковое значение содержит «Version 6.0», на компьютере работает сервер Exchange 2000.

Если анализатор Exchange обнаружит, что значение параметра UseAltRegionalCharset больше 0 на компьютере сервера Exchange 2000, анализатор отобразит сообщение о нестандартной конфигурации.

В этом сообщении будет указано, что параметр реестра UseAltRegionalCharset включен на этом сервере Exchange 2000. Если пользователи веб-клиента Outlook в организации часто отправляют почтовые сообщения получателям, которые применяют различные кодировки, можно изменить параметры реестра, чтобы пользователи, использующие обозреватель Internet Explorer 5 или более поздние версии, могли использовать символы Юникод, закодированные в UTF-8, для отправки сообщений. Если нет необходимости использовать несколько кодировок, можно восстановить конфигурацию по умолчанию с помощью следующей процедуры.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы восстановить языковые настройки по умолчанию для веб-клиента Outlook

  1. На компьютере с Exchange, откройте редактор реестра, например Regedit.exe или RegEdt32.exe.

  2. Перейдите к разделу реестра HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. В правой области удалите значение реестра UseAltRegionalCharSet.

  4. Закройте редактор реестра.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о языковых настройках веб-клиента Outlook см. в статье 311342 базы знаний Майкрософт, посвященной разделам реестра веб-клиента Outlook на стороне сервера для Exchange 2000 с пакетом обновления 2 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311342).


Параметр UseAltRegionalCharset реестра включен для Exchange Server 2003
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-12-15

Чтобы определить наличие параметра UseAltRegionalCharset реестра, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\

Параметр UseAltRegionalCharset реестра предоставляет пользователям веб-клиента Microsoft Outlook® возможность кодирования электронной почты с помощью альтернативного набора символов.

Анализатор сервера Exchange также запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumberдля всех объектов, относящихся к классу msExchExchangeServer. Если строковое значение содержит выражение «Version 6.5», на компьютере выполняется Exchange Server 2003.

Если анализатор сервера Exchange обнаружит, что на сервере Exchange 2003 задано значение параметра UseAltRegionalCharset реестра больше 0, анализатор сервера Exchange выведет на экран сообщение о конфигурации, отличной от конфигурации по умолчанию.

Это сообщение указывает, что на данном сервере Exchange 2003 параметр UseAltRegionalCharset настроен. Эта настройка может привести к кодированию сообщений веб-клиента Outlook с помощью непредусмотренного набора символов, что сделает невозможным чтение некоторыми клиентами ряда сообщений. Рекомендуется проверить правильность настройки параметров языка клиента.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы восстановить настройку языка по умолчанию для веб-клиента Outlook в приложении Exchange Server 2003

  1. На компьютере, на котором выполняется приложение Exchange, откройте редактор реестра, например, Regedit.exe или RegEdt32.exe.

  2. Перейдите к разделу реестра: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. В правой области удалите параметр UseAltRegionalCharSet реестра.

  4. Если параметр UseRegionalCharset реестра не существует, выполните приводимые ниже шаги, чтобы создать его.

    1. В меню Правка щелкните Создать, а затем щелкните Параметр DWORD.

    2. Введите UseRegionalCharset в качестве имени параметра DWORD и нажмите клавишу «ВВОД».

  5. Если параметр UseRegionalCharset существует, дважды щелкните его, чтобы внести необходимые изменения.

  6. В поле Значение введите 1 и нажмите кнопку OK.

  7. Закройте редактор реестра.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о параметрах реестра UseAltRegionalCharSet и UseRegionalCharset см. в базе знаний Майкрософт в статье 283214, описывающей ситуацию, когда веб-клиент Outlook может посылать сообщение на японском языке в формате SJIS (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=283214).


Значение реестра UseRegionalCharset доступно для Exchange 2000 Server
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-12-15

Средство анализа сервера Microsoft® Exchange считывает следующую запись из реестра, чтобы определить языковые параметры, которые используют веб-клиенты Microsoft Outlook®:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

Параметр реестра UseRegionalCharset приводит к тому, что кодировка UTF-8 в теле сообщения в хранилище перекодируется в региональный набор символов или кодовую страницу вместо формата UTF-8.

Средство анализа сервера Microsoft® Exchange также запрашивает службу каталогов Active Directory® для определения значения атрибута serialNumberдля всех объектов класса msExchExchangeServer. Если в значение строки входит «Version 6.0» (Версия 6.0), значит, на компьютере запущен сервер Exchange 2000.

Если средство анализа средства Exchange обнаруживает, что параметр UseRegionalCharset имеет значение 1 или больше на компьютере, на котором запущен сервер Exchange 2000, отображается сообщение о том, что настройка по умолчанию изменена.

Это сообщение означает, что включен параметр реестра UseRegionalCharset на сервере Exchange 2000. Если вы предоплагаете, что пользователи веб-доступа к Outlook в вашей организации будут часто посылать почту получателям, использующим разнообразные наборы символов, можно изменить параметры реестра, чтобы пользователи, работающие с Internet Explorer 5 или более поздними версиями, могли использовать символы Юникода в кодировке UTF-8 при отправке почты. Если различные наборы символов не нужны, восстановить конфигурацию по умолчанию можно следующим способом.

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неполадки. Для получения сведения о восстановлении реестра см. раздел справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Восстановление языкового параметра по умолчанию для веб-доступа к Outlook

  1. На компьютере с сервером Exchange откройте редактор реестра, например Regedit.exe или RegEdt32.exe.

  2. Перейдите к: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. В правой части окна удалите значение параметра UseRegionalCharSet.

  4. Закройте редактор реестра.

Перед правкой реестра, а также для получения сведений о правке реестра см. статью 256986 базы знаний Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Отключено значение реестра UseRegionalCharset
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-12-15

Чтобы определить языковые настройки, используемые веб-клиентами Microsoft Outlook®, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

Значение реестра UseRegionalCharset инициирует хранение текста сообщений UTF-8 в хранилище в региональном наборе символов или в региональной кодовой странице, а не в формате UTF-8.

Анализатор сервера Exchange также запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumber для всех объектов, обладающих классом объекта msExchExchangeServer. Если строковое значение содержит строку «Version 6.5», на компьютере работает Exchange Server 2003.

Если анализатор сервера Exchange обнаруживает, что на компьютере, на котором выполняется приложение Exchange Server 2003, для UseRegionalCharset задано значение 0, анализатор сервера Exchange выводит сообщение о конфигурации не по умолчанию.

Это сообщение показывает, что параметр реестра UseRegionalCharset для этого сервера Exchange 2003 отключен. Эта настройка может привести к неожиданной кодировке набора символов в сообщениях веб-клиента Outlook, при этом определенные сообщения могут оказаться нечитаемыми некоторыми клиентами.

При использовании для веб-клиента Outlook обозревателя Microsoft Internet Explorer 5 или более поздних версий сервер Exchange Server 2003 использует языковые настройки обозревателя, чтобы определить, какой набор символов использовать для кодировки данных, таких как сообщения электронной почты и приглашения на встречу.

Если ожидается, что пользователи веб-клиентов Outlook в организации будут часто посылать почту получателям, использующим различные наборы символов, можно изменить настройки реестра так, чтобы пользователи, применяющие Internet Explorer 5 или более поздние версии, могли использовать для отправки почты символы UNICODE в кодировке UTF-8.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Восстановление для веб-клиента Outlook языковых настроек по умолчанию

  1. На компьютере Exchange откройте редактор реестра, например Regedit.exe или RegEdt32.exe.

  2. Перейдите в раздел реестра: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. Если запись UseRegionalCharset отсутствует, создайте ее, выполнив следующие действия:

    1. В меню Правка укажите пункт Создать, а затем щелкните Параметр DWORD.

    2. Введите UseRegionalCharset в качестве имени DWORD, и нажмите клавишу Enter.

  4. Если запись UseRegionalCharset существует, дважды щелкните ее, чтобы изменить.

  5. В поле Значение введите 1 и нажмите кнопку ОК.

  6. Закройте редактор реестра.

Перед началом редактирования реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт, содержащую описание реестра Microsoft Windows, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986 (возможно, на английском языке).

Дополнительные сведения о языковых настройках веб-клиента Outlook см. в статье «Руководство по клиентскому доступу сервера Exchange» по адресу http://go.microsoft.com/fwlink/?LinkId=47568 (возможно, на английском языке).


Значение UseRegionalCharset реестра в приложении Exchange Server 2003 отключено или отсутствует.
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2005-12-15

Средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра для определения языковых параметров, используемых веб-клиентами Microsoft Outlook®:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

Значение UseRegionalCharset реестра заставляет тексты сообщений формата UTF-8 храниться в хранилище с использованием региональных набора символов или кодовой страницы вместо формата UTF-8.

Анализатор сервера Microsoft® Exchange также запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumber для всех объектов, имеющих класс объекта msExchExchangeServer. Если строковое значение содержит фрагмент "Version 6.5", компьютер выполняет приложение Exchange Server 2003.

Анализатор сервера Exchange выводит на экран предупреждающее сообщение, если выполняется хотя одно из следующих условий:

  • Запись UseRegionalCharset для приложения Exchange 2003 server отсутствует.

  • Запись UseRegionalCharset имеет значение, отличное от 1.

Данное сообщение показывает, что параметр UseRegionalCharset реестра данного приложения Exchange 2003 отключен или отсутствует. Данный параметр может привести к кодированию сообщений веб-клиента Outlook с использованием непредусмотренного набора символов, при этом некоторые сообщения некоторые клиенты не смогут прочесть.

При использовании приложения Microsoft Internet Explorer 5 или более поздних версий для доступа к веб-клиенту Outlook, приложение Exchange Server 2003 использует языковые параметры обозревателя для определения, какой набор символов должен использоваться для кодирования данных, таких как сообщения электронной почты и приглашения на собрание.

Если предполагается, что пользователи веб-клиента Outlook в вашей организации будут часто посылать почтовые сообщения получателям, использующим несколько наборов символов, можно изменить параметры реестра так, чтобы пользователи, использующие приложение Internet Explorer 5 или более поздние версии, для отправки почтовых сообщений могли использовать символы Юникода с кодированием в формате UTF-8.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» в Regedit.exe или Regedt32.exe.
Чтобы восстановить языковые параметры по умолчанию для веб-клиента Outlook

  1. На компьютере с сервером Exchange откройте редактор реестра, например Regedit.exe или RegEdt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. Если запись UseRegionalCharset не существует, перейдите к следующим шагам, чтобы создать ее:

    1. В меню Правка щелкните Создать, а затем щелкните Значение DWORD.

    2. Введите запись UseRegionalCharset для имени DWORD и нажмите Enter.

  4. Если запись UseRegionalCharset существует, щелкните дважды, чтобы изменить ее.

  5. Вполе Значение введите 1, а затем нажмите кнопку ОК.

  6. Закройте редактор реестра.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986 "Description of the Microsoft Windows registry" (Описание реестра Microsoft Windows) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об языковых параметрах веб-клиента Outlook см. в статье "Exchange Server Client Access Guide" (Руководство по клиентскому доступу для сервера Exchange) (http://go.microsoft.com/fwlink/?LinkId=47568).


Пользовательская загрузка и операции MAPI
Анализатор сервера Microsoft Exchange — статьи > Протоколы >

Дата последнего изменения раздела: 2006-10-17

Средство анализатора сервера Microsoft® Exchange определило, что на несколько операций MAPI на данном сервере приходится существенный процент пользовательской загрузки сервера. Такой вывод сделан на основе запроса на наличие операций, на долю которых приходится более 4 процентов процессорного времени по отношению к общему процессорному времени, используемому для обработки всех RPC-запросов.

Распространенные причины высокой загрузки процессора при выполнении операций MAPI

Администратор, изучающий причины низкой производительности сервера Exchange, должен определить, велик ли средний размер почтовых ящиков на серверах с низкой производительностью. Следует выявить, не слишком ли велики отдельные папки (более 5 000 элементов в папках «Входящие», «Отправленные», «Удаленные» или «Календарь»). Наличие больших папок и рост почтового ящика могут привести к повышению загрузки процессора и ввода-вывода. Увеличение числа представлений для каждой из папок также может повысить накладные расходы многих операций MAPI.

Представления

Многие из стандартных длительных операций MAPI связаны с представлениями. В качестве яркого примера можно упомянуть операции Restrict и FindRow. Эти операции не всегда занимают длительное время, и, если их выполнение затруднено, необходимо выяснить причину. Кроме того, обратите внимание, что в дополнение к следующим причинам каждый раз при возникновении узкого места в использовании ресурсов (как правило, связанных с диском или процессором), время выполнения операций увеличивается.

Примечание.
Иногда высокая стоимость связана с выполнением операции TaskQ User Known в сочетании с операцией Restrict или FindRow. Это связано с тем, что некоторые действия в этих операциях выполняются в TaskQ и данная стоимость относится к TaskQ User Known.

Ограничения

Операция MAPI Restrict используется для выбора элементов, отвечающих определенным условиям. Сервер создает представление, которое в результате выражается в виде таблицы со связанными критериями и носит название ограничения. Если представление с таким ограничением уже существует, сервер использует при обработке запроса пользователя существующее представление. Использование этого представления относительно малозатратно. Напротив, создание нового представления относительно затратно. По умолчанию в хранилище кэшируется только 11 представлений для каждой из папок. Если сервер получает запрос на создание двенадцатого представления, он удаляет наиболее старое кэшированное представление и создает новое. Представления добавляют накладные расходы для всех действий в отношении элементов, которые отвечают условиям ограничений представлений.

Findrow

Клиентские приложения используют операции MAPI SeekRow или FindRow для перемещения курсора между строками представления. Операция SeekRow указывает, на сколько строк должен быть перемещен курсор, и является очень низкозатратной с точки зрения процессорного времени. Операция FindRow довольно затратна, поскольку она перемещает курсор на первый элемент нематериализованного представления (не включаемого в кэш), которое отвечает условиям ограничения, а затем удаляет данное представление после того, как клиентское приложение завершило данное действие. Предельная процессорная стоимость операции FindRow зависит от сложности данного ограничения, а также от того, сколько строк должно просмотреть хранилище до того как будет найден первый элемент, отвечающий заданным условиям, и поэтому она растет по мере роста числа элементов в папке.

Высокая стоимость выполнения операций Restrict и FindRow делает их хорошими кандидатами на выполнение в кэшированном режиме, что снизит загрузку сервера. Следует помнить, что иногда высокая загрузка процессора в процессе выполнения этих операций обусловлена совместной работой с календарями, и в этом случае использование кэшированного режима не принесет результата. Высокое потребление ресурсов процессора этими операциями может указывать на трудоемкость создания представления, высокозатратные представления или объемные счетчики элементов папок.

Дополнительные сведения

Дополнительные сведения см. в следующих ресурсах сервера Exchange:

  • Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576) (Руководство по производительности и масштабируемости для Exchange Server 2003)

  • Exchange Server 2003 Performance: 10 Things to Think About (http://go.microsoft.com/fwlink/?LinkId=56460) (Производительность Exchange Server 2003 — 10 вопросов к размышлению)


Хранилища
Анализатор сервера Microsoft Exchange — статьи >

Дата последнего изменения раздела: 2005-11-18

Статьи в этом разделе содержат подробное описание оценок средства анализа сервера Microsoft® Exchange в отношении хранилищ. Кроме того, в этих статьях описаны действия, которые можно выполнить для решения проблем, устранения предупреждений и восстановления настроек по умолчанию, связанных с хранилищами и обнаруженных средством анализа сервера Exchange.


Значение реестра Aging Clean Interval для хранилища почтовых ящиков не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-05

Чтобы определить, был ли изменен интервал удаления неиспользуемых индексов базы данных относительно значения по умолчанию, средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Aging Clean Interval

Если анализатор обнаружит, что раздел Aging Clean Interval существует и настроен, отображается сообщение о нестандартной конфигурации.

Одной из функций модуля ESE является динамическое создание индексов при повторной сортировке данных или при запросе этих данных в другом порядке. В результате база данных хранилища Exchange может содержать тысячи индексов для одной таблицы. Чтобы справиться с подобной ситуацией, хранилище Exchange ограничивает срок действия индексов. Сведения об индексе добавляются во внутреннюю таблицу, которая называется таблицей очистки индексов. Во время оперативного обслуживания эта таблица просматривается, и значение времени удаления каждой записи сравнивается с текущим временем. Если срок действия индекса закончился, индекс удаляется. По умолчанию этот процесс запускается каждые 24 часа во время цикла обслуживания хранилища Exchange, удаляются записи старше 8 дней в Exchange Server 5.5 и старше 40 дней в Exchange 2000 Server, Exchange Server 2003 и Exchange Server 2007. Раздел Aging Clean Interval — это интервал в миллисекундах, по прошествии которого хранилище Exchange пытается удалить индексы. Этот раздел реестра может быть использован для изменения этого значения по умолчанию и выполнения вышеуказанной функции в течение заданного интервала.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы восстановить конфигурацию по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Удалите раздел Aging Clean Interval.

  4. Закройте редактор реестра.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о разделе Aging Clean Interval см. в следующих статьях базы знаний Майкрософт:

  • статья 159197, посвященная управлению сроком очистки папки индексов (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=159197);

  • статья 216076, посвященная замедленному доступу к папкам банка данных в Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=216076).


Значение Aging Clean Interval для хранилища общих папок отличается от значения по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server считывает следующий параметр реестра, чтобы определить, совпадает ли интервал удаления неиспользуемых индексов баз данных со значением по умолчанию:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\Aging Clean Interval

Если средство анализа Exchange Server обнаружит, что раздел Aging Clean Interval существует и настроен, появится сообщение о том, что настройка отличается от настройки по умолчанию.

Одна из функций механизма расширяемого хранилища — динамическое создание индексов, когда информация сортируется повторно или запрашивается с другим порядком сортировки. В результате база данных хранилища Exchange может иметь тысячи индексов для одной таблицы. Хранилище Exchange решает эту проблему, назначая индексам срок действия. Информация об индексе добавляется во внутреннюю таблицу — так называемую таблицу устаревания индексов. Во время оперативного обслуживания таблица устаревания индексов проверяется, и время удаления для каждой записи сравнивается с текущим временем. Если срок действия индекса истек, индекс удаляется. По умолчанию этот процесс запускается каждые 24 часа во время цикла обслуживания хранилища Exchange, удаляются записи старше 8 дней в Exchange Server 5.5 и старше 40 дней в Exchange 2000 Server и Exchange Server 2003. Раздел Aging Clean Interval — это интервал в миллисекундах, по прошествии которого хранилище Exchange пытается удалить индексы. Раздел реестра можно использовать для изменения значения по умолчанию и выполнения функции через интервалы, указанные пользователем.

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Для получения сведений о восстановлении реестра см. разделе «Восстановление реестра» справочной системы файла Regedit.exe или Regedt32.exe.

Восстановление настройки по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. Удалите раздел Aging Clean Interval.

  4. Закройте редактор реестра.

Перед правкой реестра, а также для получения дополнительных сведений о правке реестра просмотрите статью 256986 базы знаний корпорации Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Для получения дополнительных сведений о разделе Aging Clean Interval см. следующие статьи базы знаний корпорации Майкрософт:

  • 159197, «XADM: Управление устареванием индексов папок» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=159197)

  • 216076, «Возможно замедление работы Exchange из-за доступа к папкам хранилища информации» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=216076)


Разрешен доступ на сервер всем версиям Outlook
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-05

Анализатор рекомендаций Microsoft® Exchange Server считывает следующую запись реестра, чтобы определить, блокировано ли подключение к серверу Exchange Server любых версий Microsoft Office Outlook®:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Если анализатор сервера Exchange обнаруживает, что раздел Disable MAPI Clients не существует, на экран выводится предупреждение.

Раздел реестра Disable MAPI Clients, который не включается по умолчанию, позволяет администратору блокировать подключение отдельных версий Outlook к компьютеру, работающему под управлением Exchange 2000 Server, Exchange Server 2003 или Exchange Server 2007.

Последние выпуски и пакеты обновления Outlook содержат много дополнительных возможностей, связанных с обеспечением безопасности и антивирусной защитой. Начиная с Outlook 2002, блокирование вложений и механизм защиты модели объектов (Object Model Guard) входит в состав приложения и активирован по умолчанию. Эти функции являются критическим компонентом всей системы антивирусной защиты. Самой старой версией Outlook, поддерживаемой службой поддержки продуктов Майкрософт, является пакет обновления 3 для Outlook 2000 Service (SP3). Если в вашей организации используются более ранние версии Outlook, обновите их до Outlook 2003 или, по крайней мере, обновите клиент Outlook путем установки в него самых последних выпусков программ защиты.

После обновления Outlook можно заблокировать доступ к Exchange из более ранних, не обновленных, версий Outlook. Блокировка более ранних версий Outlook, не поддерживающих блокировку вложений и механизм защиты модели объектов, помогает обеспечить известный уровень безопасности для подключений MAPI-клиентов.

Для защиты от всех более ранних версий Outlook (Outlook 97, Outlook 98, Outlook 2000 до пакета обновления SP3 и более ранних версий) настоятельно рекомендуется отменить разрешение на подключение к серверу Exchange всех версий Outlook с номерами сборки, не меньше, чем 5.3164.0.0.

Сам клиент определяет строку версии клиента. Эта строка похожа на номер версии, выводимый для клиента в диалоговом окне Сведения о. Однако не следует полагаться на этот номер версии. Вместо этого используйте диспетчер Exchange, чтобы просмотреть свойство Версия клиента на странице данных для входа почтового хранилища.

Важно!
Перед выполнением этих изменений заметьте, что выпуски исправлений и пакетов обновлений могут влиять на строку версии клиента. Будьте осторожны при ограничении доступа клиента, т.к. компоненты на стороне сервера Exchange для входа также должны использовать интерфейс MAPI. Некоторые компоненты сообщают свои версии клиентов, например SMTP или OLEDB, тогда как другие выдают в Exchange номер сборки, например 6.0.4712.0. По этой причине избегайте ограничения клиентов, имеющих номера версий, начинающиеся с 6.<x.x>. Например, для того, что полностью предотвратить MAPI-доступ, вместо задания значения 0.0.0-65535.65535.65535", чтобы компоненты сервера могли войти, задайте два диапазона следующим образом: 0.0.0-5.9.9; 7.0.0-65535.65535.65535.
Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» в Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Создайте новую запись строкового значения с названием Disable MAPI Clients.

  4. Дважды щелкните запись Disable MAPI Clients реестра и установите значение на нужном вам уровне. Список значений в строке "Значение" дает возможность использовать различные способы отключения диапазонов версий MAPI-клиента. Версии (vX) обычно имеют следующие форматы:

    • Для Microsoft Outlook 2003 and Outlook 2007: Maj.Min.Build

    • Для Microsoft Outlook 2000: Maj.Build.Dot

    • Для более ранних версий Microsoft Outlook: Maj.Min.Build

    В этой строке можно указать все конкретные версии или диапазоны версий, которые требуется отключить. Используйте диспетчер Exchange, чтобы определить версию клиентов MAPI, которые подключаются к хранилищу почтовых ящиков для Exchange Server 2003. В диспетчере Exchange перейдите к контейнеру «Входы в систему» хранилища почтовых ящиков. В столбце «Версия клиента» отображается версия клиентов MAPI, которые подключены к хранилищу почтовых ящиков.

    В Exchange Server 2007 используйте командлет Get-LogonStatistics в командной консоли Exchange, чтобы получить клиентскую версию клиентов MAPI, которые подключены к базе данных почтовых ящиков.
Важно!
Версия клиента MAPI приводится в диспетчере Exchange и командной консоли Exchange как X.0.Y.Z. В параметре реестра эта версия должна вводиться как X.Y.Z. Например, если в диспетчере Exchange версия клиента MAPI указана как 5.0.2819.0, введите 5.2819.0 в параметр «Disable MAPI Clients» реестра.
  1. Выйдите из редактора реестра и перезагрузите банк данных Microsoft Exchange, чтобы изменения вступили в силу.

Перед началом редактирования реестра, а также для получения дополнительных сведений о редактировании реестра см. статью 256986 базы знаний Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Дополнительные сведения о блокировании подключения конкретных MAPI-клиентов к компьютеру, с установленным на нем приложением Exchange 2000 Server или Exchange Server 2003 , см. в следующих статьях:

  • Статья 328240 «How to put server-side restrictions on clients that are used to access Exchange 2000 mailboxes» (Применение ограничений к клиентам, которые используются для доступа к почтовым ящикам Exchange 2000) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328240)

  • Статья 288894, "XADM: функция для отключения доступа клиентов MAPI" по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=288894 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

Дополнительные сведения о загрузке обновлений системы защиты для более старых версий Outlook и блокировании других версий Outlook см. в статье "Slowing and Stopping E-mail Transmitted Viruses in an Exchange Server 2003 Environment" (Замедление и пресечение передачи вирусов по электронной почте в среде Exchange Server 2003) (http://go.microsoft.com/fwlink/?LinkId=47587).

Дополнительные сведения о командлете Get-LogonStatistics см. в разделе «Get-LogonStatistics» (http://go.microsoft.com/fwlink/?LinkId=80699) в документации Exchange Server 2007.


Установлен параметр AssertOnEvent
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, включена ли отладка банка данных Microsoft Exchange, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\AssertOnEvent

Если анализатор сервера Exchange обнаруживает, что для атрибута AssertOnEvent задано значение, на экран выводится предупреждение.

Параметр реестра AssertOnEvent содержит десятичные значения, которые указывают, какие события хранилища должны инициировать режим отладки банка данных Microsoft Exchange. Параметр реестра AssertOnEvent действует только в том случае, если выполняется отладочная версия программы store.exe. Служба «Банк данных Microsoft Exchange» использует большое количество ресурсов при работе в режиме отладки. Не рекомендуется проводить отладку хранилища в производственной среде.

Если в данный момент не требуется устранять неполадку хранилища с помощью службы поддержки продуктов Майкрософт, следует удалить параметр реестра AssertOnEvent.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.
Чтобы удалить раздел реестра AssertOnEvent

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. В правой области найдите и удалите параметр AssertOnEvent.

  4. Закройте редактор реестра и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Перед редактированием реестра для получения сведений по редактированию реестра см. статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).


Обнаружено по меньшей мере одно поврежденное сообщение
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-05

Анализатор сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить число записей в значении PoisonIDs:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<ExchangeServerName> \Private- <PrivateInformationStoreGUID>

Если анализатор сервера Exchange обнаруживает, что число записей в значении параметра PoisonIDs больше 0, выводится предупреждение.

Версии Exchange Server, более поздние чем Exchange Server 2003 с пакетом обновления 1 (SP1), обрабатывают сообщения таким образом, чтобы поврежденные и неверные сообщения не вызывали неожиданной остановки службы банка данных Exchange и не мешали успешному запуску этой службы.

В серверах Exchange Server 2003 с пакетом обновления 1 или более поздних версиях отслеживаются сообщения, вызывающие неожиданную остановку службы банка данных Exchange при преобразовании из формата MAPI в формат MIME. В случае возникновения сбоя код поврежденного сообщения сохраняется в реестре. Если поврежденное сообщение вызывает неожиданный останов службы три раза, эти сведения используются для предотвращения обработки сообщения после четвертого запуска службы банка данных Exchange.

Если служба банка данных Exchange неожиданно остановлена из-за поврежденного сообщения, создается параметр реестра PoisonIDs в следующем разделе:

HKLM\System\CurrentControlSet\Services\MSExchangeIS \<ExchangeServerName> \Private- <PrivateInformationStoreGUID>

Кроме того, администратор может создать запись реестра PoisonThreshold. Параметр PoisonThreshold определяет наибольшее количество прохождений сообщения через банк данных Exchange перед тем, как это сообщение добавляется в раздел PoisonIDs. По умолчанию это пороговое значение равно 2. Чтобы включить такое поведение, данное пороговое значение должно быть превышено. Таким образом, служба банка данных Exchange может быть остановлена 3 раза в связи с наличием поврежденного сообщения до того, как это сообщение будет блокировано. Например, если сообщение стало причиной сбоя 3 раза, оно блокируется, поскольку число три превышает пороговое значение 2.

Когда в реестр записывается событие поврежденного сообщения, в журнал событий приложения заносятся сообщения событий ошибки 9680 и 9681. После успешного запуска службы банка данных Exchange сообщение блокируется, сервер Exchange пытается отправить отчет о том, что это сообщение не доставлено. В некоторых случаях такой отчет отправить невозможно. В таких случаях заблокированное сообщение может оставаться в очереди до времени своего истечения. Раздел реестра PoisonIDs может содержать до десяти идентификаторов сообщений. Если число сообщений превышает десять, добавляется новое событие поврежденного сообщения. Событие поврежденного сообщения с самой старой датой удаляется.

Чтобы устранить причину появления этого предупреждения

  1. Если в хранилище почтовых ящиков возникли неполадки с поврежденным сообщением, требуется дополнительно изучить эту проблему. Сведения о том, как ведется восстановление ИТ Microsoft при повреждении баз данных Exchange см. по адресу http://go.microsoft.com/fwlink/?LinkId=56372.

  2. Если возникают неполадки с выключением Exchange Server 2003 из-за поврежденных сообщений, целесообразно включить автоматические отчеты об ошибках на компьютере с Exchange Server. Данные отчетов об ошибках используются для поиска и исправления проблем в используемом программном обеспечении. Дополнительные сведения о включении отправки отчетов об ошибках в Exchange см. в разделе Отчетность об ошибках Exchange отключена.

Дополнительные сведения о сервере Exchange Server 2003 с пакетом обновления 1 см. в документе «Service Pack 1 for Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=29090) (Пакет обновления 1 для Exchange Server 2003).


Фоновая очистка хранилища почтовых ящиков не выполняется по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Средство анализатора приложения Microsoft® Exchange Server считывает следующую запись реестра, чтобы определить текущее значение для параметра Background Cleanup реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Background Cleanup

Если анализатор сервера Exchange обнаруживает, что значение параметра Background Cleanup установлено отличным от 60 000 (десятичное число) или 0xEA60 (шестнадцатиричное число), на экран выводится сообщение о конфигурации не по умолчанию. Рекомендуется установить значение Background Cleanup, которое используется по умолчанию.

Если будет установлено слишком высокое значение Background Cleanup, процесс очистки в фоновом режиме будет запускаться менее часто и это может привести к появлению нескольких ошибок. Ниже перечислены возможные неполадки.

  • Перемещение почтового ящика может закончиться неудачей, и в журнал будет занесено событие 1205 с кодом ошибки 0x4e3.

  • Размеры папок и число элементов, отображаемые в диспетчере Exchange или консоли управления Exchange, могут значительно отличаться от значений, отображаемых в Microsoft Outlook®. Кроме того, место в базе данных, занятое этими элементами, может не восстановиться.

  • При определенных условиях для элементов, которые были удалены, могут не выдаваться уведомления о непрочитанных сообщениях, хотя сообщения не прочитаны.

  • Не будет производиться очистка старых записей в таблице DeliveredTo. Таблица DeliveredTo используется хранилищем Exchange для предотвращения доставки дублирующих сообщений.

Если значение Background Cleanup слишком мало, процедура фоновой очистки может привести к ненужной нагрузке на сервер.

Внимание!
Описанная ниже в этом разделе процедура, предусмотренная для изменения слишком высоких значений к значению по умолчанию, может привести к увеличению нагрузки на сервер, пока не завершится очистка в фоновом режиме для всех элементов, которые в обычном порядке были бы удалены с периодичностью, заданной по умолчанию. Поэтому для внесения этих изменений рекомендуется выбирать время, когда это в наименьшей степени влияет на работу пользователей. Кроме того, если сообщения с запросом уведомления о прочтении были удалены без прочтения и не были очищены из-за этой проблемы, то после того, как вы исправите эту проблему, будут созданы уведомления о непрочтении для каждого из этих сообщений.
Важно!
Эта статья содержит сведения о порядке редактирования реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неполадок. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» в Regedit.exe или Regedt32.exe.
Чтобы возвратиться к конфигурации по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Измените значение параметра Background Cleanup на 60 000 (десятичное число) или 0xEA60 (шестнадцатиричное число).

  4. Выйдите из редактора реестра и перезапустите банк сообщений в Microsoft Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986 "Description of the Microsoft Windows registry" (Описание реестра Microsoft Windows) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Не указан интервал фоновой очистки для хранилища почтовых ящиков
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Чтобы определить, существует ли значение параметра реестра Background Cleanup, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Background Cleanup

Если анализатор сервера Exchange обнаруживает, что значение Background Cleanup отсутствует, на экран выводится предупреждение.

Если значение Background Cleanup отсутствует, процесс фоновой очистки не выполняется и могут возникнуть многочисленные неполадки, в том числе:

  • Перемещение почтового ящика может закончиться неудачей, и в журнал будет занесено событие 1205 с кодом ошибки 0x4e3.

  • Размер почтовых ящиков и количество элементов, отображаемые в диспетчере Exchange или в консоли управления Exchange, могут значительно отличаться от аналогичных данных, отображаемых в Microsoft Outlook®. Кроме того, недоступно повторное использование места в базе данных, занятого этими элементами.

  • При определенных обстоятельствах могут создаваться уведомления о непрочтении для элементов, удаленных без прочтения.

  • Не будет выполняться очистка таблицы DeliveredTo. Таблица DeliveredTo используется хранилищем Exchange для предотвращения дублирования доставки сообщений. Значение Track Duplicates определяет промежуток времени, в течение которого записи хранятся в таблице DeliveredTo. Если есть значение Background Cleanup и при этом отсутствует значение Track Duplicates, в процессе фоновой очистки удаляются записи, которые существуют более 24 часов. Для параметра Track Duplicates рекомендуется установить значение 1 (в десятичном или шестнадцатеричном формате).

Для параметра Background Cleanup рекомендуется задать значение по умолчанию — 60 000 (десятичное) или 0xEA60 (шестнадцатеричное).

Внимание!
Выполнение следующей ниже процедуры для устранения причины появления данного предупреждения может вызвать повышенную загрузку сервера в течение выполнения фоновой очистки для элементов, которые в обычном режиме работы были бы удалены частями. В связи с этим рекомендуется выполнить указанные изменения в такое время, когда воздействие на пользователей будет минимальным. Кроме того, если сообщения с запросом на подтверждение прочтения были удалены без прочтения, а их очистку выполнить не удалось из-за возникновения данной проблемы, после внесения исправлений для каждого из таких сообщений будет создано уведомление о непрочтении.
Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.
Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Создайте параметр с типом DWORD, названием Background Cleanup и значением 60000 (десятичное) или 0xEA60 (шестнадцатеричное).

  4. Закройте редактор реестра. Чтобы изменения вступили в силу, выполните одно из следующих действий:

    • Отключите и затем подключите затронутые банки данных.

    • Перезапустите службу банков данных Microsoft Exchange.

Перед редактированием реестра для получения сведений по редактированию реестра см. статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).


Интервал фоновой очистки хранилища общих папок не задается по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора приложения Microsoft® Exchange Server считывает следующую запись реестра, чтобы определить текущее значение для параметра Background Cleanup реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<PublicStoreGUID>\Background Cleanup

Если анализатор сервера Exchange обнаруживает, что значение параметра Background Cleanup установлено отличным от 60 000 (десятичное число) или 0xEA60 (шестнадцатиричное число), на экран выводится сообщение о конфигурации не по умолчанию. Рекомендуется установить для параметра Background Cleanup значение по умолчанию.

Если значение Background Cleanup установлено слишком большим, процедура фоновой очистки может выполняться недостаточно часто, и могут возникнуть многочисленные проблемы, в том числе следующие:

  • Размеры папок и результаты подсчета элементов в диспетчере Exchange могут значительно отличаться от тех, что показывает приложение Microsoft Outlook®. Кроме того, место в базе данных, занятое этими элементами, может не восстановиться.

  • При определенных условиях для элементов, которые были удалены, могут не выдаваться уведомления о непрочитанных сообщениях, хотя сообщения не прочитаны.

  • Не будет производиться очистка старых записей в таблице DeliveredTo. Таблица DeliveredTo используется хранилищем Exchange для предотвращения доставки дублирующих сообщений.

Если значение Background Cleanup слишком мало, процедура фоновой очистки может привести к ненужной нагрузке на сервер.

Внимание!
Приведенные ниже процедуры следует выполнить для того, чтобы вернуться к конфигурации по умолчанию от слишком высокого значения, которое может вызвать повышение нагрузки на сервер, сохраняющееся до тех пор, пока не будет выполнена фоновая очистка для всех элементов, которые должны были бы в нормальных условиях очищаться с периодичностью, заданной по умолчанию. Поэтому рекомендуется выполнять эти изменения в такое время, когда пользователи задействованы меньше всего. Кроме того, если сообщения, для которых запрашивается уведомление о прочтении, удалены непрочитанными и по этой причине не были подвергнуты очистке, уведомления о непрочитанных сообщениях буду создаваться для каждого из этих сообщений после того, как пользователь устранит причину появления этого предупреждения.
Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» в Regedit.exe или Regedt32.exe.
Чтобы возвратиться к конфигурации по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<PublicStoreGUID>

  3. Измените значение Background Cleanup на 60 000 (десятичное число) или 0xEA60 (шестнадцатиричное число).

  4. Выйдите из редактора реестра и перезагрузите банк данных Microsoft Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986 "Description of the Microsoft Windows registry" (Описание реестра Microsoft Windows) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Не указан интервал фоновой очистки для хранилища общих папок
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-05

Чтобы определить, существует ли значение параметра реестра Background Cleanup, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicStoreGUID>\Background Cleanup

Если анализатор сервера Exchange обнаруживает, что значение Background Cleanup отсутствует, выводится предупреждение.

Если значение Background Cleanup отсутствует, процесс фоновой очистки не выполняется и могут возникнуть многочисленные проблемы, в том числе:

  • Размеры папок и число элементов, отображаемые в диспетчере Exchange или консоли управления Exchange, могут значительно отличаться от значений, отображаемых в Microsoft Outlook®. Кроме того, недоступно повторное использование места в базе данных, занятого этими элементами.

  • При определенных обстоятельствах могут создаваться уведомления о непрочтении для элементов, удаленных без прочтения.

  • Не будет выполняться очистка таблицы DeliveredTo. Таблица DeliveredTo используется хранилищем Exchange для предотвращения дублирования доставки сообщений. Значение Track Duplicates определяет промежуток времени, в течение которого записи хранятся в таблице DeliveredTo. Если есть значение Background Cleanup и при этом отсутствует значение Track Duplicates, в процессе фоновой очистки удаляются записи, которые существуют более 24 часов. Для параметра Track Duplicates рекомендуется установить значение 1 (в десятичном или шестнадцатеричном формате).

Для параметра Background Cleanup рекомендуется задать значение по умолчанию — 60 000 (десятичное) или 0xEA60 (шестнадцатеричное).

Внимание!
Выполнение следующей ниже процедуры для устранения причины появления данного предупреждения может вызвать повышенную загрузку сервера в течение выполнения фоновой очистки для элементов, которые в обычном режиме работы были бы удалены частями. В связи с этим рекомендуется выполнить указанные изменения в такое время, когда воздействие на пользователей будет минимальным. Кроме того, если сообщения с запросом на подтверждение прочтения были удалены без прочтения, а их очистку выполнить не удалось из-за возникновения данной проблемы, после внесения исправлений для каждого из таких сообщений будет создано уведомление о непрочтении.
Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.
Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicStoreGUID>

  3. Создайте параметр с типом DWORD, названием Background Cleanup и значением 60000 (десятичное) или 0xEA60 (шестнадцатеричное).

  4. Закройте редактор реестра. Чтобы изменения вступили в силу, выполните одно из следующих действий:

    • Отключите и затем подключите затронутые банки данных.

    • Перезапустите службу банков данных Microsoft Exchange.

Перед редактированием реестра для получения сведений по редактированию реестра см. статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).


Значение реестра BreakOnEvent установлено
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, включена ли отладка в банке данных Microsoft Exchange, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\BreakOnEvent

Если анализатор сервера Exchange обнаружит, что значение раздела реестра BreakOnEvent задано, на экран выводится предупреждение.

Значением реестра BreakOnEvent являются десятичные значения, которые указывают, какие события хранилища включают режим отладки банка данных Microsoft Exchange. Банк данных Microsoft Exchange использует большое количество ресурсов при работе в режиме отладки. Не рекомендуется проводить отладку хранилища в производственной среде.

Если в данный момент не требуется устранять неполадку, связанную с хранилищем, с помощью службы поддержки продуктов Майкрософт, то следует удалить параметр BreakOnEvent.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы удалить раздел реестра BreakOnEvent

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. В правой области найдите и удалите параметр BreakOnEvent.

  4. Закройте редактор реестра и перезапустите службу Банк данных Microsoft Exchange, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Трассировка вызовов отключена
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, включено ли ведение журнала трассировки вызовов, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable Call Tracing

Если анализатор сервера Exchange обнаруживает, что значение регистра для Disable Call Tracing существует и настроено на использование значения 1, а на компьютере выполняется приложение Exchange Server 2003, анализатор сервера Exchange отображает сообщение о конфигурации не по умолчанию.

Если ведение журнала трассировки вызовов включено, данные вызовов функций регистрируются в журнале. По умолчанию трассировка вызовов включена на компьютерах, на которых выполняется приложение Exchange Server 2003. Заметьте, что данная функция по умолчанию отключена на сервере Exchange 2000. Однако если выполняется приложение Exchange Server 2003, необходимо включить трассировку вызовов, если только от служб поддержки продуктов Майкрософт не было других указаний. Если трассировка вызовов включена, происходит сбор важных сведений, которые можно использовать для устранения любых неполадок, которые происходят в процессе сохранения данных.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» в Regedit.exe или Regedt32.exe.
Чтобы возвратиться к конфигурации по умолчанию

  1. Откройте редактор реестра (Regedit.exe или Regedt32.exe).

  2. Перейдите к следующему разделу реестра:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Установите значение Disable Call Tracing реестра равным 0.

  4. Закройте редактор реестра и перезапустите службу банка сообщений Microsoft Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986 "Description of the Microsoft Windows registry" (Описание реестра Microsoft Windows) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Трассировка вызовов включена
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, включено ли ведение журнала трассировки вызовов, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable Call Tracing

Если анализатор сервера Exchange обнаруживает, что параметр реестра Disable Call Tracing имеет значение 0, выводится сообщение о том, что текущая конфигурация отличается от заданной по умолчанию.

Если ведение журнала трассировки вызовов включено, данные вызовов функций регистрируются в журнале. Ведение журнала трассировки вызовов может привести к падению производительности на величину до 4 процентов. Такое ведение журнала следует включать только в том случае, если оно нужно для устранения неполадок медленных или не возвращающих отклик процессов Store.exe.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.
Чтобы вернуться к конфигурации по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Установите значение Disable Call Tracing реестра равным 1. Если трассировка вызовов отключена, параметры Flush Call Traces , RPC Requests Threshold и Call Tracing Logging Interval не используются.

  4. Закройте редактор реестра и перезапустите сервер Exchange, чтобы изменения вступили в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).


Неправильно установлена глубина контрольной точки для этого кластера
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить значение атрибута msExchESEParamCheckpointDepthMax для каждой группы хранения, анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®. Если анализатор сервера Exchange обнаруживает, что значение msExchESEParamCheckpointDepthMax для кластера Exchange 2000 Server не равно 5242880, выводится предупреждение.

Значение атрибута msExchESEParamCheckpointDepthMax задается в байтах и определяет максимальную глубину контрольной точки. Глубина контрольной точки — это объем данных, которые ожидают переноса в хранилище Exchange. Максимальная глубина контрольной точки — максимальный объем данных, который в любой момент времени может оставаться не сохраненным в хранилище. Таким образом, если для максимальной глубины контрольной точки установлено значение 20 МБ, это — максимальный объем данных, который в любое время может быть незавершенным (не перенесенным в хранилище Exchange). В кластерной среде чем меньше значение этого параметра, тем быстрее выполняется переход на другой ресурс. Тестирование Exchange Server 2003 показало, что значение 5 МБ (5242880 байт) этого параметра (вместо 20 МБ, которое задавалось по умолчанию в Exchange 2000 Server) обеспечивает значительное ускорение перехода на другой ресурс без заметного ущерба для производительности ввода/вывода на сервере.

Для кластеров серверов Exchange 2000 это значение всегда должно быть равно 5242880.

Внимание!
Серьезные проблемы могут возникнуть в случае некорректного изменения атрибутов объектов службы каталогов Active Directory® при использовании средства Active Directory Service Interfaces (ADSI) Edit, LDP (ldp.exe) или другого клиента LDAP версии 3. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы задать значение атрибута msExchESEParamCheckpointDepthMax с помощью ADSI Edit

  1. Запустите средство ADSI Edit. ADSI Edit поставляется в составе пакета средств поддержки Microsoft Windows® 2000 Server и Microsoft Windows Server™ 2003 Server Support Tools.

  2. В дереве консоли щелкните правой кнопкой мыши ADSIEdit, выберите команду Подключиться и затем выберите для подключения Контекст именования конфигурации.

  3. Разверните узел Configuration Container, CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<имя_организации>, CN=Administrative Groups, CN=<имя_административной_группы>, CN=Servers, CN=<имя_сервера>, CN=Information Store.

  4. Щелкните правой кнопкой мыши CN=<StorageGroupName> и выберите Свойства.

  5. В списке свойств выберите msExchESEParamCheckpointDepthMax.

  6. Нажмите кнопку Изменить и введите нужный размер с приращением 5 МБ. Значение должно быть задано в байтах. Например, чтобы задать глубину контрольной точки 5 МБ, нужно ввести 5242880 байт, а для глубины 10 МБ нужно ввести 10485760 байт. Минимальный размер, который можно ввести — 5 МБ. Значение, большее 20 МБ, увеличит время перехода на другой ресурс службы банка сообщений Microsoft Exchange.

  7. Закройте средство ADSIEdit и затем перезапустите службу банка сообщений Microsoft Exchange.

Дополнительные сведения о развертывании кластеров серверов Exchange 2000 Server см. на веб-странице «Deploying Microsoft Exchange 2000 Server Clusters» (Развертывание кластеров Exchange 2000 Server) (http://go.microsoft.com/fwlink/?LinkID=14578).


Размещение файла контрольных точек
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-05

Средство анализатора Microsoft® Exchange запрашивает службу Active Directory®, чтобы определить, совпадает ли путь (msExchESEParamSystemPath) файла контрольных точек для каждой группы хранения на сервере Exchange с путем (msExchESEParamLogFilePath) журнала транзакций для данной группы хранения. Если анализатор сервера Exchange определяет, что путь файла контрольных точек не совпадет с путем журнала транзакций для данной группы хранения, анализатор сервера выводит на экран сообщение с рекомендациями.

Если местоположение файла контрольных точек не совпадает с расположением журнала транзакций, может возникнуть длительный простой, если произойдет сбой диска.

Чтобы изменить расположение файла контрольных точек группы хранения в Exchange 2000 Server и Exchange Server 2003, выполните следующие действия.

  1. В диспетчере Exchange щелкните правой кнопкой мыши группу хранения и затем в контекстном меню выберите пункт Свойства.

  2. На вкладке Общие в меню Местоположение системного пути щелкните пункт Обзор и затем выберите местоположение файла контрольных точек.
Чтобы изменить расположение файлов журнала транзакций группы хранения в Exchange 2000 Server и Exchange Server 2003, выполните следующие действия.

  1. В диспетчере Exchange щелкните правой кнопкой мыши группу хранения и затем в контекстном меню выберите пункт Свойства.

  2. На вкладке Общие в меню Местоположение журнала транзакций щелкните пункт Обзор и затем выберите местоположение файла транзакций.
Чтобы изменить расположение файлов журнала транзакций в Exchange Server 2007, выполните следующие действия.

  1. Следуйте инструкциям в документации Exchange Server 2007 на странице «How to Set or Change the Location of Storage Group Log Files» (http://go.microsoft.com/fwlink/?LinkId=80702) (Как установить или изменить расположение файлов журнала транзакций группы хранения).

Дополнительные сведения о файла журнала транзакций см. в статье "Managing Mailbox Stores and Public Folder Stores" (Управление хранилищами почтовых ящиков и хранилищами общих папок) раздела Руководство по администрированию приложения Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).

Дополнительные сведения о файле контрольных точек см. в статье "Transaction Log File Replay: Soft Recovery and Hard Recovery in Exchange Server 2003" (Воспроизведения файлов журнала транзакций: Восстановление программ и восстановление аппаратных средств в приложении Exchange Server 2003) в разделе Использование групп хранения для восстановления приложения Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589).


Циклическое ведение журналов на этом сервере переднего плана отключено
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2006-03-27

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить установленное значение атрибута циклического ведения журналов (msExchESEParamCircularLog). Если анализатор сервера Exchange обнаружит, что значение этого атрибута равно 0, отображается предупреждение.

Значение 1 атрибута msExchESEParamCircularLog означает, что циклическое ведение журналов включено. Значение 0 атрибута msExchESEParamCircularLog означает, что циклическое ведение журналов отключено.

В стандартном ведении журналов транзакций, используемом сервером Exchange, каждая транзакция базы данных в группе хранения записывается в файл журнала, а затем в базу данных. При достижении файлом журнала определенного размера он переименовывается и создается новый файл журнала. Со временем это приведет к появлению набора файлов журнала. При сбое можно восстановить транзакции с помощью воспроизведения данных из этих файлов журнала в базе данных.

Циклическое ведение журналов перезаписывает и повторно использует первый файл журнала после записи данных, содержащихся в нем, в базу данных. В Exchange Server циклическое ведение журналов по умолчанию отключено. Включив его, можно уменьшить количество требуемого дискового пространства, но не завершив файлы журналов транзакций, невозможно восстановить данные, записанные после последнего резервного копирования. Поэтому на производственных серверах, содержащих данные почтовых ящиков или общих папок, не рекомендуется выполнять циклическое ведение журналов. Однако на серверах Exchange переднего плана, на которых нет почтовых ящиков или общих папок, фиксируются только сообщения, которые являются отчетами о недоставке, поэтому нет необходимости сохранять файлы транзакций на этих серверах, а также создавать резервные копии этих серверов. Включение циклического ведения журналов на серверах переднего плана позволяет перезаписывать файлы журнала транзакций и не превышать 20 МБ.

Чтобы включить циклическое ведение журналов

  1. В системном диспетчере Exchange разверните узел Серверы, затем сервер Exchange.

  2. Щелкните правой кнопкой мыши группу хранения, для которой следует включить циклическое ведение журналов, и выберите Свойства. Появится диалоговое окно свойств группы хранения.

  3. Установите флажок Включить циклическое ведение журналов и нажмите кнопку ОК, чтобы сохранить изменения.

  4. Закройте системный диспетчер Exchange и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Дополнительные сведения о циклическом ведении журналов см. в следующих статьях базы знаний Майкрософт:

  • статья 258470, посвященная изменению параметров циклического ведения журналов (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=258470);

  • статья 147524, посвященная влиянию циклического ведения журналов и использованию журналов транзакций (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524);

  • статья 296788, посвященная автономным процедурам резервного копирования и восстановления в Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296788);

  • статья 314605, описывающая включение и отключение циклического ведения журналов в Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314605).


Включено циклическое ведение журнала
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-05

Чтобы определить значение атрибута msExchESEParamCircularLog для каждой группы хранения сервера Exchange, средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®. Значение 1 указывает, что для данной группы хранения включено циклическое ведение журнала. Значение 2 указывает, что для данной группы хранения не включено циклическое ведение журнала. Помимо этого, анализатор сервера Exchange запрашивает службу Active Directory, чтобы определить значение счетчика записей, перечисленных в атрибуте homeMDBBL каждого хранилища почтовых ящиков. Счетчик этого атрибута отражает количество почтовых ящиков в хранилище почтовых ящиков.

Анализатор сервера Exchange также запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Exchange_Server в пространстве имен root\MicrosoftExchangeV2, чтобы определить значение ключа VMLargestBlockSize. Значение True указывает, что данный компьютер сервера Exchange является внешним сервером. Значение False указывает, что данный компьютер сервера Exchange не является внешним сервером.

Если анализатор сервера Exchange обнаруживает, что значение атрибута msExchESEParamCircularLog равно 1, для ключа IsFrontEndServer установлено значение «False» и значение атрибута homeMDBBL превышает 20, выводится предупреждение.

Такое сочетание значений указывает, что циклическое ведение журнала включено на сервере, содержащем более 20 почтовых ящиков. При обычном ведении журнала транзакций, применяемом в Exchange 2000 Server, Exchange Server 2003 и Exchange Server 2007, каждая операция базы данных в группе хранения записывается в файл журнала и затем - в эту базу данных. Когда файл журнала достигает определенного размера, он переименовывается и создается новый файл журнала. Со временем образуется набор файлов журнала. При сбое транзакции можно восстановить, перенеся данные из этих журналов в базу данных.

При циклическом ведении журнала первый файл журнала перезаписывается и повторно используется после того, как содержащиеся в нем данные были занесены в базу данных. На серверах Exchange 2000 Server, Exchange Server 2003 и Exchange Server 2007 циклическое ведение журналов отключено по умолчанию. При его включении снижаются требования к свободному месту на диске, однако не отсутствие полного набора файлов журнала транзакций не позволяет восстановить данные со времени последнего создания полной резервной копии. Таким образом, не рекомендуется использовать циклическое ведение журнала в обычной производственной среде.

Устранение причин этого предупреждения для серверов Exchange 2000 Server и Exchange Server 2003

  1. Откройте системный диспетчер Exchange.

  2. Раскройте узел Серверы, а затем раскройте узел сервера, который нужно изменить.

  3. Щелкните правой кнопкой мыши группу хранения, которую нужно изменить, и выберите команду «Свойства».

  4. В диалоговом окне «Свойства» снимите флажок Включить циклическое ведение журнала.

  5. Нажмите кнопку ОК, чтобы сохранить изменения.

  6. Закройте системный диспетчер Exchange и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Устранение причин этого предупреждения для сервера Exchange 2007 Server с помощью консоли управления Exchange

  1. Откройте консоль управления Exchange.

  2. Разверните узел Конфигурация сервера, а затем разверните сервер, который нужно исправить.

  3. Щелкните правой кнопкой группу хранения, которую нужно изменить, и затем щелкните Свойства.

  4. В диалоговом окне Свойства снимите флажок Включить циклическое ведение журналов.

  5. Нажмите кнопку ОК, чтобы сохранить настройки.

  6. Закройте консоль управления Exchange и перезапустите службу банка данных Microsoft Exchange, чтобы изменение вступило в силу.

Устранение причин этого предупреждения для сервера Exchange 2007 Server с помощью командной консоли Exchange

  1. Следующий код является примером команды Set-StorageGroup, которая отключает циклическое ведение журналов в группе хранения «MyStorageGroup».
Копировать код
Set-StorageGroup -Identity MyStorageGroup -CircularLoggingEnabled $false
  • Дополнительные сведения о циклическом ведении журнала см. в следующих статьях базы знаний Майкрософт:

  • 147524, «How Circular Logging affects the Use of Transaction Logs» (Влияние циклического ведения журналов на использование журнала транзакций) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524)

  • 240145, "How to Tell Which Transaction Log Files Can Be Safely Removed" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=240145) (Определение файлов журнала, которые могут быть безопасно удалены)


Циклическое ведение журнала отключено
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-03-23

Анализатор Microsoft Exchange опрашивает службу каталогов Active Directory, чтобы определить значение атрибута msExchESEParamCircularLog.

Значение 1 для атрибута msExchESEParamCircularLog указывает, что циклическое ведение журнала включено. Значение 0 для атрибута msExchESEParamCircularLog указывает, что циклическое ведение журнала отключено.

Анализатор Exchange также проверяет, выполняются ли указанные ниже условия.

  • Сервер Exchange настроен как клиентский сервер.

  • Служба SMTP запущена; определяется также количество настроенных почтовых ящиков.

Если анализатор сервера Exchange обнаружит, что выполняются указанные ниже условия, он выведет предупреждение.

  • Атрибут msExchESEParamCircularLog настроен со значением 0.

  • Сервер не настроен как клиентский сервер.

  • Настроено менее 20 почтовых ящиков.

При стандартном ведении журнала транзакций, которое используется в сервере Exchange Server, каждая из транзакций базы данных в группе хранилищ заносится в файл журнала, а затем — в базу данных. Когда файл журнала достигает определенного размера, он переименовывается и создается новый файл журнала. Со временем при таком стандартном ведении журнала транзакций образуется набор файлов журнала. В случае сбоя системы транзакции можно восстановить, перенеся данные из этих журналов в базу данных.

При циклическом ведении журнала первый файл журнала после того, как содержащиеся в нем данные записываются в базу данных, заменяется и повторно используется. В сервере Exchange Server циклическое ведение журнала по умолчанию отключено.

Важно!
Включение циклического ведения журнала позволяет уменьшить требования, предъявляемые к наличию свободного места на диске. Однако если отсутствует полный набор файлов журналов транзакций, невозможно будет восстановить новые данные, которые не вошли в архивную копию при выполнении последней полной архивации. Поэтому не рекомендуется включать циклическое ведение журнала на серверах приложений, содержащих данные почтовых ящиков или общих папок.

На серверах Exchange Server переднего плана, серверах маршрутизации сообщений (также называемых серверами инфраструктуры) и серверах-плацдармах, на которых отсутствуют почтовые ящики пользователей и общие папки, единственным отправляемым типом сообщений являются отчеты о недоставке. Поэтому не требуется хранить файлы транзакций для этих серверов. Кроме того, не требуется выполнять резервное копирование для этих серверов. Если включить циклическое ведение журнала на серверах, на которых отсутствуют почтовые ящики пользователей, то можно перезаписывать файлы журналов транзакций. Величина файлов журналов транзакций в этом случае не может превышать 20 МБ данных.

Для включения циклического ведения журнала в Exchange 2000 Server и Exchange Server 2003 выполните следующие действия.

  1. Откройте диспетчер Exchange.

  2. Разверните Серверы, а затем разверните сервер Exchange.

  3. Щелкните правой кнопкой мыши группу хранилищ, в которой требуется включить циклическое ведение журнала, и выберите Свойства. Появится диалоговое окно свойств группы хранилищ.

  4. Установите флажок Включить циклическое ведение журнала, а затем нажмите кнопку ОК, чтобы сохранить изменения.

  5. Закройте диспетчер Exchange и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.
Для включения циклического ведения журнала в Exchange 2007 Server при помощи консоли управления Exchange выполните следующие действия.

  1. Откройте консоль управления Exchange.

  2. Разверните узел Конфигурация сервера, затем разверните сервер, который нужно изменить.

  3. Щелкните правой кнопкой мыши группу хранения, которую нужно изменить, и выберите команду Свойства.

  4. В окне Свойства установите флажок Включить циклическое ведение журнала.

  5. Нажмите кнопку ОК для сохранения изменений.

  6. Закройте консоль управления Exchange и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.
Для включения циклического ведения журнала в Exchange 2007 Server при помощи среды управления Exchange выполните следующие действия.

  1. Приведенный ниже код является примером команды Set-StorageGroup, включающей циклическое ведение журнала для группы хранения MyStorageGroup.
Копировать код
Set-StorageGroup -Identity MyStorageGroup -CircularLoggingEnabled $true

Дополнительные сведения о циклическом ведении журнала см. в следующих статьях базы знаний Майкрософт:

  • 258470 — описываются изменения в настройке параметров циклическое ведение журнала (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=258470)

  • 147524 — описывается влияние циклического ведения журнала на использование журналов транзакций (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524)

  • 296788 — описываются процедуры автономного архивирования и восстановления для Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296788)

  • 314605, «Включение и отключение циклического ведения журнала в Exchange 2000 Server и Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314605) (на английском языке)


Сжатие удаленных вызовов процедур между клиентом и сервером отключено
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-05

Чтобы определить, отключено ли сжатие удаленных вызовов процедур, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Rpc Compression Enabled

Если анализатор сервера Exchange обнаружит, что значение параметра Rpc Compression Minimum Size существует и настроено равным 0, на экран будет выведено сообщение о конфигурации, отличной от конфигурации по умолчанию.

По умолчанию все данные RPC, которые перемещаются между Microsoft Office Outlook® 2003 или Outlook 2007 и Exchange Server 2003 или Exchange Server 2007, сжимаются, независимо от их размера. В некоторых сценариях может потребоваться управлять сжатием удаленных вызовов процедур. Например, при устранении неполадок соединений путем просмотра пакетов, отправляемых по сети, сжатие удаленных вызовов процедур может затруднить анализ, поскольку при отслеживании будут видны только сжатые данные.

Чтобы настроить параметры сжатия удаленных вызовов процедур, можно добавить в параметры системы три значения разделов реестра:

  • Минимальный размер сжатия удаленных вызовов процедур

  • Сжатие удаленных вызовов процедур включено

  • Упаковка удаленных вызовов процедур включена

Значение параметра Rpc Compression Enabled реестра определяет, используются ли алгоритмы сжатия удаленных вызовов процедур. Если этот раздел реестра отсутствует, сжатие удаленных вызовов процедур включено и используется.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы вернуться к конфигурации по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Удалите раздел Rpc Compression Enabled. Если разделы Rpc Compression Minimum Size и Rpc Packing Enabled присутствуют, удалите также и эти разделы.

  4. Закройте редактор реестра и перезапустите сервер Exchange, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об управлении сжатием удаленных вызовов процедур см. в базе знаний Майкрософт в статье 825371, описывающей изменение сжатия удаленных вызовов процедур в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=825371).


Значение параметра ClientMonitoringReportLevel отличается от значения по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, как приложение Exchange Server 2003 контролирует данные о производительности для Microsoft Office Outlook® 2003, средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Если анализатор сервера Exchange обнаружит, что значение параметра ClientMonitoringReportLevel реестра не равно 1, на экран будет выведено сообщение о том, что конфигурация отличается от конфигурации по умолчанию.

Сервер Exchange Server использует значение параметра ClientMonitoringReportLevel реестра для идентификации ошибок сети и проблем с задержками, касающихся клиентов Outlook 2003. Значение параметра ClientMonitoringReportLevel реестра имеет три возможных настройки.

Значение | Функция
0 | Данные о производительности от клиентов Outlook 2003 не собираются.
1 | Собираются данные о производительности только от клиентов Outlook 2003, имеющих высокоскоростное сетевое подключение.
2 | Собираются данные о производительности от всех клиентов Outlook 2003.

При включении в реестре параметра ClientMonitoringReportLevel со значением 1 или 2, клиенты Outlook 2003 отправляют данные на сервер. Отправляемые на сервер данные указывают статус и состояние сетевого подключения. Отправляемые на сервер данные содержат сведения о неудавшихся запросах удаленного вызова процедур и условиях возникновения ошибок. Сервер накапливает сведения и представляет данные в виде записей журнала событий.

Программа установки Exchange не создает раздел ClientMonitoringReportLevel реестра. Однако в соответствии с алгоритмом поведения по умолчанию, существующим в Exchange Server 2003, данные о производительности собираются только от клиентов Outlook 2003, имеющих высокоскоростные сетевые подключения. Это поведение по умолчанию приложения Exchange Server 2003 совпадает по функциям с поведением приложения, когда значение параметра ClientMonitoringReportLevel реестра установлено равным 1.

Анализатор сервера Exchange отображает эту конфигурацию только для сведений. Никаких действий выполнять не требуется. Тем не менее, можно изменить значение параметра ClientMonitoringReportLevel реестра, если необходимо восстановить значение по умолчанию.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.
Чтобы восстановить конфигурацию по умолчанию.

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Дважды щелкните ClientMonitoringReportLevel.

  4. В поле Значение введите 1 и нажмите кнопку OK.

  5. Закройте редактор реестра.

Служба банка данных Microsoft Exchange обнаруживает изменение в течение нескольких минут. Нет необходимости перезагружать компьютер.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Рассмотрите использование квот хранилища
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-03-21

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить, установлены ли квоты почтовых ящиков для каждого объекта частных баз данных сообщений (MDB). Если анализатор сервера Exchange обнаружит, что частная база данных сообщений содержит более 20 почтовых ящиков и квоты для этой базы данных не установлены, анализатор отобразит рекомендацию.

Рекомендуется использовать квоты для всех баз данных на компьютерах серверов Exchange, на которых хранятся почтовые ящики пользователей. Существуют три ограничения, которые следует установить на уровне базы данных. Эти ограничения устанавливаются на вкладке Ограничения на странице свойств хранилища почтовых ящиков. Каждое ограничение выражено в килобайтах (КБ)

  • Предупреждение. Ограничение Issue warning определяет размер почтового ящика, которое приведет к отправке пользователю предупреждающего сообщения электронной почты. Это сообщение электронной почты предупреждает пользователя о скором достижении размера почтового ящика ограничения Prohibit send.

  • Запретить отправку Ограничение Prohibit send определяет размер почтового ящика, превышение которого приводит к запрету на отправку сообщений электронной почты пользователем. Пользователь получит сообщение от сервера Exchange, в котором будет написано, что было превышено ограничение размера почтового ящика.

  • Запретить отправку и получение Ограничение Prohibit send and receive определяет размер почтового ящика, превышение которого приводит к запрету на отправку и получение сообщений электронной почты пользователем. Вся почта, присланная этому пользователю, возвращается отправителю с отчетом о недоставке.

При установке этих правил убедитесь, что предоставлен достаточный диапазон между ограничением запрещения отправки и ограничением запрещения отправки и получения. Если дельта между двумя значениями ограничений слишком мала, это может привести к блокированию обмена сообщениями, пока пользователь не очистит свой почтовый ящик. Поэтому рекомендуется использовать буфер, равный, по меньшей мере, 20 процентам между ограничением запрещения отправки и ограничением запрещения отправки и получения. Например, если пользователям запрещено отправлять новые сообщения при достижении размера почтового ящика равного 100 МБ, ограничение запрещения отправки и получения должно быть, по меньшей мере, 120 МБ.

Установка ограничений размера почтового ящика для Exchange 2000 Server и Exchange Server 2003

  1. Откройте системный диспетчер Exchange.

  2. Найдите хранилище почтовых ящиков, которое отображается в анализаторе сервера Exchange при упоминании этого вопроса.

  3. Щелкните правой кнопкой мыши имя_хранилища_почтовых_ящиков и выберите Свойства.

  4. Откройте вкладку Ограничения.

  5. Измените ограничения Предупреждать о проблеме при (КБ), Запретить отправку при (КБ) и Запретить отправку и получение при (КБ).

  6. Нажмите Применить, затем ОК.
Установка ограничений размера почтового ящика для Exchange 2007 Server с помощью консоли управления Exchange

  1. Откройте консоль управления Exchange

  2. Перейдите к отображаемому в анализаторе Exchange Server хранилищу почтовых ящиков, для которых нужно установить ограничение.

  3. Щелкните правой кнопкой MailboxStore_Name и выберите Свойства.

  4. Откройте вкладку Ограничения.

  5. Измените ограничения Предупреждение о проблеме в (КБ), Запретить отправку при (КБ) и Запретить отправку и получение при (КБ)

  6. Щелкните Применить, а затем нажмите кнопку ОК.
Установка ограничений размера почтового ящика для Exchange 2007 Server с помощью командной консоли Exchange

  1. В следующем примере показано, как установить размер почтового ящика, при котором пользователю будет отправлено предупреждающее сообщение. Эти свойства применимы ко всем почтовым ящикам в данной базе данных почтовых ящиков, для которых не установлены свойства собственных предупреждающих квот. Можно указать целое число или значение «не ограничено». Значение по умолчанию равно 1,9 гигабайт (ГБ).

    Копировать код
    Set-MailboxDatabase "Mailbox Database Name" -IssueWarningQuota 1991680

  2. В следующем примере показано, как установить размер почтового ящика, при котором пользователь, связанный с этим почтовым ящиком, больше не может отправлять сообщения. Эти свойства применимы ко всем почтовым ящикам в данной базе данных почтовых ящиков, для которых не установлены свойства собственных запретных квот. Можно указать целое число или значение «не ограничено».

    Копировать код
    Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendQuota 2097152

  3. В следующем примере показано, как установить размер почтового ящика, при котором пользователь, связанный с этим почтовым ящиком, больше не может отправлять или получать сообщения. Эти свойства применимы ко всем почтовым ящикам в данной базе данных почтовых ящиков, для которых не установлены свойства собственных запретных квот на отправку и получение. Можно указать целое число или значение «не ограничено».

    Копировать код
    Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendReceiveQuota 2411520

Дополнительные сведения об управлении почтовыми ящиками в Exchange Server 2003 см. в статье Working with Exchange Server 2003 Stores (http://go.microsoft.com/fwlink/?LinkId=47595) (Работа с хранилищами Exchange Server 2003).

Дополнительные сведения об управлении ограничениями почтовых ящиков в Exchange Server 2007 см. в статье «How to Configure Database Limits and Properties» (http://go.microsoft.com/fwlink/?LinkId=80746) (Как настроить ограничения и запрещения для базы данных)


Для этого хранилища почтовых ящиков включена индексация содержимого
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, задано ли для атрибута расписания перестроения индексов содержимого (msExchCIRebuildSchedule) какое-либо значение, не равное NULL, и задан ли атрибут стиля перестроения индексов содержимого (msExchCIRebuildStyle). Это атрибуты каждой частной базы данных почтовых ящиков. Если анализатор сервера Exchange находит, что оба эти атрибута настроены для индексации, выводится предупреждение.

Выполнять индексацию содержимого, известную также как «полнотекстовая индексация», для хранилища почтовых ящиков не рекомендуется, поскольку полнотекстовая индексация потребляет много ресурсов, а данные почтового ящика часто изменяются. Поэтому поддержание актуального состояния индекса базы данных — очень ресурсоемкий процесс. Полнотекстовая индексация больше подходит для общих папок.

Для выполнения полнотекстовой индексации хранилища почтовых ящиков рекомендуется настроить в расписании индексации частое обновление хранилища с отслеживанием производительности компьютера. Это позволит исключить ситуации перегрузки компьютера и его неспособности доставлять почту и отвечать на запросы клиентов во время индексации содержимого.

Иначе придется вообще отключить полнотекстовую индексацию, удалив полнотекстовый индекс из хранилища почтовых ящиков.

Чтобы отключить полнотекстовую индексацию данного хранилища почтовых ящиков

  1. Откройте диспетчер Exchange.

  2. Разверните узел Административные группы, разверните нужную административную группу, разверните узел Серверы, разверните узел своего сервера, разверните нужную группу хранения, щелкните правой кнопкой мыши Хранилище почтовых ящиков и в контекстном меню выберите пункт Удалить полнотекстовый индекс.

Дополнительные сведения о настройке и устранении неполадок полнотекстовой индексации в Exchange см. в статье базы знаний Майкрософт, посвященной настройке полнотекстовой индексации хранилищ почтовых ящиков в Exchange 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkID=3052&kbid=822932).


Для этого хранилища общих папок включено индексирование содержимого
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, заданы ли атрибуты расписания перестройки индексирования содержимого (msExchCIRebuildSchedule) и стиля перестройки индексирования содержимого (msExchCIRebuildStyle), а также отличается ли их значение от 0. Эти атрибуты являются атрибутами каждой базы данных общего банка данных.

Если анализатор сервера Exchange обнаруживает, что оба эти атрибута присутствуют и их значение отличается от 0, выводится предупреждение о нестандартной конфигурации.

Если для обоих атрибутов установлено значение 1,то для базы данных банка данных включено полнотекстовое индексирование. Полнотекстовое индексирование обеспечивает мощный и быстрый поиск путем индексирования каждого слова в указанной базе данных. При реализации полнотекстового индексирования выберите отдельное хранилище общих папок или почтовых ящиков, которое будет индексироваться. Пользователи затем смогут выполнять полнотекстовый поиск в сообщениях и вложениях, содержащихся в хранилище общих папок или почтовых ящиков.

По умолчанию индекс содержит тему и текст сообщения, а также имена отправителя и получателя и все имена, содержащиеся в полях «Копия» и «Скрытая копия». Индекс также включает текст вложений следующего типа: файлы DOC, XLS, PPT, HTML, HTM, ASP, TXT и EML (вложенные MIME-сообщения). Двоичные вложения, такие как файлы изображений и аудио, не индексируются.

Точность результатов поиска определяется временем последнего обновления индекса. При изменении содержимого общих папок или хранилищ почтовых ящиков индекс необходимо обновить, чтобы отразить появление новых данных. Обновления индекса могут выполняться вручную или автоматически по расписанию.

Существует четыре основных категории файлов полнотекстового индексирования. Производительность полнотекстового индексирования можно оптимизировать, упорядочив размещение этих файлов на диске следующим образом:

  • Каталоги. Каталоги являются основными индексами. У каждого хранилища Exchange может быть один каталог. Поместите свой каталог на дисковый массив RAID-0+1. При создании каталога его местонахождение можно указать в диспетчере Exchange.

  • Хранилище свойств. Это база данных, содержащая различные свойства элементов, индексированных в каталоге. У сервера может быть только одно хранилище свойств. Поместите хранилище свойств полнотекстового индексирования на RAID-массив. По умолчанию файлы устанавливаются на тот же диск, что и сервер Exchange.

  • Временные файлы. Эти файлы содержат временные данные, используемые службой Microsoft Search. Поместите каталог временных файлов полнотекстового индексирования на RAID-массив. По умолчанию эти файлы устанавливаются на системный диск, который обычно не обеспечивает такую производительность ввода-вывода, как RAID-массив.

  • Журналы сборщиков. Эти файлы содержат данные журналов службы индексирования. Для каждого каталога существует один набор журналов. Журналы сборщиков могут оставаться в папке по умолчанию, либо при желании их можно переместить.

Включение или отключение полнотекстового индексирования

  1. Откройте диспетчер Exchange.

  2. Разверните узел Серверы, разверните узел сервера Exchange, а затем разверните группу хранилища, содержащую хранилище общих папок, с которым ведется работа.

  3. Щелкните правой кнопкой мыши хранилище общих папок и выберите в контекстном меню команду Свойства.

  4. Откройте вкладку Полнотекстовое индексирование.

  5. Измените нужным образом значение поля Интервал обновления.

  6. Нажмите кнопку OK, чтобы сохранить изменения и выйти из окна свойств хранилища общих папок.

Дополнительные сведения о настройке полнотекстового индексирования для общих папок см. в статье 319433 базы знаний Майкрософт, описывающей настройку полнотекстового индексирования для общих папок (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319433).

Дополнительные сведения о настройке и устранении неполадок полнотекстового индексирования для хранилищ почтовых ящиков см. в следующих статьях базы знаний Майкрософт:

  • Статья 822932, описывающая настройку полнотекстового индексирования для хранилищ почтовых ящиков в Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822932)

  • Статья 319436, описывающая настройку полнотекстового индексирования для хранилищ почтовых ящиков в Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823144).

Сведения о полнотекстовом индексировании в многоязыковой среде см. в статье 325624 базы знаний Майкрософт, посвященной полнотекстовому индексированию для нескольких языков (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325624).

Дополнительные сведения о рекомендациях по полнотекстовому индексированию см. в статье 326186 базы знаний Майкрософт, посвященной рекомендациям по развертыванию полнотекстового индексирования (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326186).


Уведомления о состоянии доставки отображаются как сообщения
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-03-21

Средство анализатора сервера Microsoft® Server считывает параметр реестра, чтобы определить, отображаются ли уведомления о состоянии доставки (DSN) на компьютере с Exchange Server как стандартные сообщения:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent\RenderDSNsAsMessages

Если анализатор сервера Exchange Server обнаружит, что параметр реестра RenderDSNsAsMessages имеется и значение его настройки больше нуля, отображается сообщение о нестандартной настройке.

Параметр реестра RenderDSNsAsMessages представляет собой возможность настройки, позволяющую администраторам управлять отображением уведомлений о доставке в Exchange 2000 Server, Exchange Server 2003 и Exchange Server 2007.

  • Если значение для RenderDSNsAsMessages установлено равным 0, уведомления о состоянии доставки (включающие как отчеты о доставке, так и отчеты об ошибках доставки) отображаются в виде стандартных сообщений MAPI.

  • Если значение для RenderDSNsAsMessages больше 0, уведомления о состоянии доставки отображаются как смешанные или многокомпонентные сообщения MIME.

Это значение реестра не имеет значения по умолчанию и должно добавляться вручную. Кроме того, чтобы данный параметр оказал соответствующий эффект на Exchange 2000 Server, на соответствующем компьютере должен выполняться Exchange 2000 Server с накопительным пакетом обновлений (сентябрьской 2003 г. или более поздней версии), вышедших после пакета обновления 3 (SP3).

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неполадок. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы вернуться к настройкам по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к параметру реестра

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

  3. Удалите параметр реестра RenderDSNsAsMessages .

  4. Закройте редактор реестра и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.
  • Сведения о внесении изменений в реестр см. в статье 256986 базы знаний Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986). Изучите эту статью перед началом изменения реестра.

  • Дополнительные сведения о проблемах с форматом уведомления о доставке см. в статье 812806 базы знаний Майкрософт «Пользователь Exchange неожиданно получает стандартный отчет о недоставке вместо настраиваемого отчета о недоставке» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=812806) (на английском языке).

  • Дополнительные сведения о накопительном пакете обновления, выпущенном после пакета обновления 3 (SP3) для Exchange 2000 Server, см. в статье 824282 базы знаний Майкрософт «Комплект исправлений (сентябрь 2003 г.), вышедших после пакета обновления 3 (SP3) для Exchange 2000» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=824282).


Интервал Database Aging Keep Time изменен по сравнению со стандартным значением
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Средство анализа Microsoft® Exchange Server считывает следующий параметр реестра, чтобы определить, изменено ли стандартное время устаревания для просмотра индексов базы данных клиента Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Private-<Private Information Store GUID>\Aging Keep Time

Если средство анализа Exchange Server обнаруживает, что элемент реестра Aging Keep Time существует и настроен, появляется сообщение о нестандартной настройке.

Индексы, предназначенные для просмотров таблиц базы данных Exchange клиентом Exchange и не используемые в течение указанного времени, удаляются. Для управления устареванием индексов используются следующие параметры реестра:

  • Aging Keep Time Минимальный возраст индекса перед его удалением. По умолчанию это 8 дней для Exchange Server 5.5 и 40 дней для Exchange 2000 Server, Exchange Server 2003 и Exchange Server 2007..

  • Aging Clean Interval Минимальный интервал времени (миллисекунд) между запусками задания определения возраста индекса. Значение по умолчанию равняется 24 часам.

  • Reset Views Если этот параметр существует и не равен нулю, он приводит к удалению всех кэшированных индексов при следующем запуске задания. После завершения устаревания индексов значение Reset Views устанавливается равным 0.

Не рекомендуется устанавливать значение элемента реестра Aging Keep Time, если это не указание службы поддержки корпорации Майкрософт.

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неполадки. Для получения сведений о восстановлении реестра см. раздел «Восстановление реестра» справочной системы файла Regedit.exe или Regedt32.exe.

Просмотр или изменение параметра реестра Aging Keep Time

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Private-<Private Information Store GUID>

  3. Проверьте и при необходимости измените параметр Aging Keep Time.

  4. Закройте редактор реестра. Если проводились изменения, перезапустите компьютер с Exchange Server, чтобы они вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


База данных и журналы хранятся на одном дисковом томе
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-05

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, находятся ли файлы базы данных для данного хранилища почтовых ящиков на том же физическом диске, что и файлы журнала транзакций для данной группы хранения. А именно, анализатор сервера Exchange запрашивает Active Directory, чтобы определить следующее:

  • Имеется ли в хранилище почтовых ящиков более 100 почтовых ящиков, определяемых подсчетом значений атрибута homeMDBBL объекта хранилища почтовых ящиков (класс msExchPrivateMDB). Если в хранилище почтовых ящиков меньше 100 почтовых ящиков, влияние местоположения файлов на производительность будет минимальным.

  • Путь файлов базы данных для хранилища почтовых ящиков, определяемое чтением значения msExchEDBFile объекта хранилища почтовых ящиков.

  • Путь файлов журнала транзакций для группы хранения, определяемый чтением значения msExchESEParamLogFilePath объекта группы хранения (класс msExchStorageGroup).

  • Указывает ли путь в msExchESEParamLogFilePath на тот же диск, что и путь в msExchEDBFile.

Кроме того, анализатор сервера Exchange определяет следующее:

  • Работают ли серверные расширения Exchange для подключаемого сетевого хранилища (NAS) под управлением Windows на сервере, определяемом запросом класса Win32_Service инструментария Microsoft Windows® Management Instrumentation (WMI) для значения атрибута Started для серверных NAS-расширений Exchange (wssexchmap). Если серверные расширения Exchange для NAS под управлением Windows работают, это означает, что требуемые файлы, возможно, находятся не на локальном приводе и аспекты производительности, возможно, не играют роли.

  • Находятся ли файлы на дисковом томе, имя которого содержит больше трех символов, определяемых запросом WMI-класса Win32_Volume. Опять же, это может означать, что файлы находятся не на локальном приводе и аспекты производительности, возможно, не применимы.

Для обеспечения отказоустойчивости в случае сбоя жесткого диска файлы журнала транзакций и файлы базы данных Exchange следует хранить на отдельных физических жестких дисках. Размещая журналы и файлы базы данных на отдельных жестких дисках, можно значительно повысить производительность ввода/вывода жесткого диска.

Примечание.
Для обеспечения отказоустойчивости в случае необходимости восстановления базы данных каждая группа хранения имеет свой собственный набор журналов транзакций. В файлы журнала транзакций записывается каждое изменение в каждой базе данных данной группы хранения. Журналы транзакций не удаляются до выполнения полной архивации всех баз данных группы хранения.

В следующих примерах иллюстрируется восстановление данных даже в критических обстоятельствах (например, при полном выходе из строя жесткого диска, содержащего файлы базы данных или файлы журнала транзакций), если имеется архивная копия и файлы журнала транзакций находятся на отдельном диске.

  • Если происходит отказ жесткого диска, содержащего файлы базы данных, можно заменить этот жесткий диск, восстановить файлы базы данных из последней архивной копии и затем с помощью текущих журналов, которые были расположены на отдельном жестком диске, восстановить данные на сервере Exchange и привести их к состоянию на момент отказа жесткого диска.

  • Если на жестком диске, который содержит журналы транзакций, происходит отказ, но жесткий диск с файлами базы данных работает нормально и файл хранилища базы данных правильно закрыт, можно попытаться отремонтировать отказавший диск журнала транзакций и повторно подключить хранилище базы данных. Если файл хранилища базы данных правильно не закрывается, он останется в несогласованном состоянии и может быть подключен только после принудительного восстановления с помощью программы eseutil.exe, что может привести к некоторым потерям данных. Другой вариант — восстановить файл хранилища базы данных из архивной копии, которая не будет содержать данные о новых почтовых ящиках, созданных после архивации.

Важно!
Если файлы базы данных Exchange и журнала транзакций хранятся на одном физическом жестком диске и происходит отказ этого диска, теряются все данные, созданные после последней архивации.

Кроме того, размещение файлов базы данных и файлов журнала транзакций на отдельных физических дисках повышает общую производительность системы. Exchange записывает каждую операцию сначала в файл журнала транзакций, а затем — в файл базы данных. При этом файлы журнала транзакций используются всеми хранилищами почтовых ящиков в группе хранения. Если эти файлы находятся на одном физическом диске, для выполнения операции записи головка привода должна многократно перемещаться между местоположением текущего файла журнала транзакций и местоположениями файлов базы данных. Если же файлы находятся на отдельных дисках, одна из головок привода находится в позиции записи в файл журнала транзакций. Таким образом, операции могут выполняться быстрее, чем когда файлы находятся на одном диске. Разница в производительности для одной операции невелика, но при высокой системной нагрузке может стать значительной.

Чтобы оптимизировать конфигурацию, можно переместить файлы журнала транзакций или файлы базы данных.

Перемещение файлов журнала транзакций на другой диск на сервере Exchange 2000 Server или Exchange Server 2003

  1. В системном диспетчере Exchange разверните нужный объект-сервер Exchange, щелкните правой кнопкой мыши нужную группу хранения и в контекстном меню выберите Свойства.

  2. На вкладке Общие укажите новое местоположение для файлов.

    Например, если диск E:\ будет содержать только журналы для этой группы хранения, в разделе Местоположение журнала транзакций нажмите кнопку Обзор и выберите диск E:\.

Изменение расположения файлов журнала транзакций группы хранения Exchange на сервере Exchange Server 2007

  1. Следуйте указаниям раздела «How to Set or Change the Location of Storage Group Log Files» (Как установить или изменить расположение файлов журнала транзакций группы хранения) (http://go.microsoft.com/fwlink/?LinkId=80702) в основной документации Exchange Server 2007.

Перемещение файлов базы данных на другой диск на сервере Exchange 2000 Server или Exchange Server 2003

  1. В системном диспетчере Exchange разверните объект-сервер Exchange, на котором находится хранилище, разверните соответствующий контейнер группы хранения, щелкните правой кнопкой мыши нужный объект хранилища почтовых ящиков и в контекстном меню выберите Свойства.

  2. На вкладке База данных диалогового окна Свойства укажите новые местоположения файлов.
Внимание!
Чтобы переместить файл базы данных, необходимо временно отключить базу данных, затем снова ее подключить. Мастер автоматически выполняет эту процедуру, но во время этого процесса база данных недоступна для всех пользователей.

Перемещение файлов базы данных на другой диск на сервере Exchange Server 2007 с помощью мастера перемещения пути базы данных

  1. Запустите консоль управления Exchange на сервере с размещенной группой хранения.

  2. В дереве консоли разверните узел Конфигурация сервера и щелкните значок Почтовый ящик.

  3. На панели результатов разверните соответствующий контейнер группы хранения, щелкните правой кнопкой нужный объект базы данных почтового ящика и затем щелкните Переместить путь базы данных. Откроется окно мастера перемещения пути базы данных.

  4. На вводной странице в окне пути файлов базы данных отображается расположение файлов базы данных. Щелкните «Обзор», чтобы указать местоположение, куда следует переместить эти файлы.

  5. Щелкните «Переместить».

  6. На странице «Завершение» подтвердите успешное изменение пути файла базы данных. Состояние «Завершено» указывает, что мастер успешно завершил выполнение задачи. Состояние «Завершить не удалось» указывает, что задача не завершена. Если задача не завершена, просмотрите сводные данные, чтобы выяснить причину, а затем нажмите кнопку «Назад», чтобы внести изменения конфигурации. Нажмите «Готово», чтобы завершить работу мастера перемещения пути базы данных.
Примечание.
Для перемещения файлов базы данных также можно использовать командную консоль Exchange. Дополнительные сведения см. в разделе Move- DatabasePath.

Дополнительные сведения о файлах базы данных сервера Exchange см. в следующих разделах:

  • «Управление хранилищами почтовых ящиков и хранилищами общих папок» в Руководстве администратора сервера Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617)

  • «Общие сведения о хранилищах Exchange Server 2003» в руководстве Работа с хранилищами Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595)

Дополнительные сведения об управлении файлами базы данных сервера Exchange см. в статье 328794 базы знаний корпорации Майкрософт «How to Protect Exchange Data from Hard Disk Failure» (Как защитить данные Exchange при отказе жесткого диска) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328794)

Дополнительные сведения о принудительном исправлении хранилищ базы данных Exchange см. в статье 296788 базы знаний «Offline Backup and Restoration Procedures for Exchange» (Процедуры архивации и восстановления Exchange в автономном режиме) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296788).

Дополнительные сведения о выполнении принудительного исправления для файла хранилища базы данных Exchange см. в статье 810190 базы знаний «XADM: «the information store terminated abnormally» error message and event ID 447 is logged» (XADM: сообщение об ошибке «аварийное закрытие банка сообщений» и регистрация кода события 447) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810190).


В базе данных имеются все файлы журнала
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange определило, что все файлы журнала, необходимые для восстановления данной базы данных, существуют и находятся в правильном расположении для восстановления. Следовательно, сбой восстановления не вызван отсутствием или несоответствием файла журнала транзакций.

Возможно базы данных или файлы журнала транзакций повреждены или другие файлы мешают процессу восстановления.

Чтобы устранить эту ошибку

  • С помощью диспетчера Exchange поместите одну из баз данных в группу хранения и затем просмотрите журнал приложения на предмет наличия ошибок, которые могут указать на причину сбоя.

  • Автономное восстановление базы данных. После анализа базы данных анализатор сервера Exchange выведет на экран инструкции по автономному восстановлению базы данных.

  • Запустите Run Eseutil.exe /ML, чтобы проверить целостность нужных файлов журнала. Дополнительные сведения об использовании Eseutil см. в базе знаний Майкрософт в статье 248122, "How to use Eseutil to test transaction log files for damage in Exchange 2000 Server and in Exchange Server 2003" (Инструкции по использованию Eseutil для проверки файлов журнала транзакций в Exchange 2000 Server и в Exchange Server 2003) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=248122).


База данных находится в состоянии чистого отключения
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange обнаружил, что база данных Exchange находится в состоянии нормального завершения работы.

Работа базы данных, находящейся в состоянии нормального завершения работы, была завершена правильно, эта база была отключена от потока файла журнала. Таким образом, чтобы снова подключить эту базу данных, не нужно выполнять операции аварийного восстановления.

Если не удается подключить базу данных, находящуюся в состоянии нормального завершения работы, это не связано с требованием дополнительно повторить файл журнала транзакций. Тем не менее, причиной неудачи подключения базы данных, которая находится в состоянии нормального завершения работы, может быть необходимость повторить журнал транзакций для других баз данных в той же группе хранения. Для подключения любой из баз данных группы хранения Exchange необходимо восстановить и перевести в подключаемое состояние все базы данных в данной группе хранения.

База данных в состоянии нормального завершения работы может быть подключена с предыдущими журналами транзакций или с другим набором журналов транзакций. Если при подключении базы данных в состоянии нормального завершения работы отсутствуют журналы транзакций, создается новый набор таких журналов.

Примечание.
Как правило, не следует удалять существующие файлы журнала транзакций, даже если все базы данных в группе хранения находятся в состоянии нормального завершения работы. Если существующие файлы журнала транзакций удалены,будет недоступен накат с предыдущих резервных копий. Однако удаление файлов журналов транзакций в случае, если все базы данных в группе хранения находятся в состоянии нормального завершения работы, не воздействует на текущие базы данных. Рекомендуется при удалении всех файлов журнала транзакций для группы хранения незамедлительно создать полные резервные копии для всех баз данных в этой группе хранения.


База данных находится в состоянии неправильного завершения работы и никаких журналов не требуется
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2006-08-10

Средство анализатора сервера Microsoft® Exchange обнаружило, что база данных находится в состоянии неправильного завершения работы.

По определению, для базы данных в состоянии неправильного завершения работы требуется хотя бы один файл журнала транзакций. Неправильное завершение работы препятствует подключению базы данных и не должно происходить во время обычной работы.

Чтобы устранить эту ошибку

  • Подробный анализ файлов базы данных и журнала можно получить на веб-узле службы справки и поддержки Microsoft http://go.microsoft.com/fwlink/?linkid=3052&kbid=31845.


База данных находится в неизвестном состоянии
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange определило, что база данных находится в неизвестном состоянии. Первоначально база данных должна быть или в состоянии нормального завершения работы, или в состоянии некорректного завершения работы. (В Exchange 2000 Server и более ранних версиях эти состояния назывались согласованными и несогласованными, соответственно.)

Чтобы устранить эту ошибку

  • Для расширенного анализа состояния базы данных обратитесь в службу справки и поддержки корпорации Майкрософт (http://go.microsoft.com/fwlink/?LinkId=31845).


В базе данных отсутствуют необязательные и обязательные файлы журнала
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange не обнаружил в соответствующей папке файлы журнала, обязательные для восстановления базы данных. Если отсутствует обязательный файл журнала, восстановление базы данных невозможно.

При некорректном завершении работы базы данных Exchange всегда остаются файлы журнала, которые необходимо повторить для этой базы данных перед ее подключением. Необходимо повторить по меньшей мере один файл журнала. Как правило, таких файлов журнала несколько.

Кроме обязательных файлов журнала, могут присутствовать дополнительные файлы журнала, которые можно повторить для базы данных. Хотя повтор таких файлов журнала перед подключением базы данных не является обязательным, с их можно восстановить дополнительные данные. Без повтора этих необязательных файлов журнала все содержащиеся в них данные будут утрачены.

Чтобы устранить эту ошибку

  • Найдите отсутствующие файлы журнала транзакций и добавьте их в соответствующую папку.

  • Если не удается обнаружить все необязательные файлы журнала, можно восстановить базу данных изолированно с использованием только обязательных файлов журнала. Чтобы восстановить базу данных без необязательных файлов журнала, следуйте инструкциям анализатора сервера Exchange. Помните, что при восстановлении базы данных без необязательных файлов журнала будут утрачены содержащиеся в этих файлах данные.

    Однако при отсутствии ряда файлов журнала некоторые необязательные файлы журнала можно повторить для базы данных. В качестве примера рассмотрим следующий сценарий. Существуют файлы журнала с номерами от одного до десяти. Десятый файл журнала является обязательным (остальные файлы необязательны), шестой файл журнала отсутствует. В этом случае можно повторить файлы журнала с номерами от семи до десяти, поскольку последовательность до обязательного файла непрерывна.

  • Восстановите текущую базу данных.

    Примечание.
    Хотя восстановление базы данных, скорее всего, будет выполнено успешно, такой результат не является гарантированным. Даже при успешном восстановлении может быть утрачено небольшой или значительный объем данных. Дополнительные сведения о восстановлении базы данных Exchange см. в статье 812357 базы данных Майкрософт «How to maintain your Exchange database after you repair by using the Eseutil /p tool in Exchange Server 5.5, in Exchange 2000 Server, and in Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812357) (Инструкции по обслуживанию базы данных Exchange после ее восстановления с помощью средства «Eseutil /p» в Exchange Server 5.5, Exchange 2000 Server и Exchange Server 2003).

  • Внедрите гибридную стратегию, которая включает полное восстановление базы данных. Иногда доступно полное восстановление базы данных даже в том случае, если ее невозможно откатить вперед с использованием дополнительных файлов журнала. В такой ситуации можно попробовать восстановить предыдущую копию базы данных, одновременно выполняя восстановление текущей копии, которую не удается подключить. Затем можно слить содержимое баз данных, чтобы добиться восстановления максимального объема данных. Эта стратегия не относится к числу стандартных, перед ее внедрением рекомендуется обратиться в службу справки и поддержки Майкрософт (http://go.microsoft.com/fwlink/?LinkId=31845). Дополнительные сведения об этой стратегии см. в разделе Using Recovery Storage Groups in Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589) (Использование групп хранения аварийного восстановления в Exchange Server 2003).


В базе данных отсутствуют дополнительные, но не обязательные файлы журнала
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange обнаружило, что работа одной из баз данных была завершена неправильно.

При неправильном завершении работы базы данных Exchange всегда остаются файлы журнала, которые необходимо повторить для этой базы данных перед ее подключением. Необходимо повторить по меньшей мере один файл журнала. Как правило, таких файлов журнала несколько.

Кроме обязательных файлов журнала, могут присутствовать дополнительные файлы журнала, которые можно повторить для базы данных. Хотя повтор таких файлов журнала перед подключением базы данных не является обязательным, с их помощью можно восстановить дополнительные данные. Без повтора этих необязательных файлов журнала все содержащиеся в них данные будут утрачены.

Чтобы устранить эту ошибку

  • Найдите отсутствующие дополнительные файлы журнала и добавьте их в папку журнала транзакций.

  • Если не удается обнаружить все дополнительные файлы журнала, можно восстановить базу данных изолированно с использованием только обязательных файлов журнала. Чтобы восстановить базу данных без дополнительных файлов журнала, следуйте инструкциям анализатора сервера Exchange. Помните, что при восстановлении базы данных без дополнительных файлов журнала будут утрачены содержащиеся в этих файлах данные.

    Однако при отсутствии ряда файлов журнала некоторые дополнительные файлы журнала можно повторить для базы данных. В качестве примера рассмотрим следующий сценарий. Существуют файлы журнала с номерами от одного до десяти. Десятый файл журнала является обязательным (остальные файлы необязательны), шестой файл журнала отсутствует. В этом случае можно повторить файлы журнала с номерами от семи до десяти, поскольку последовательность до обязательного файла непрерывна.


В базе данных отсутствуют обязательные файлы журнала
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средством анализатора сервера Microsoft® Exchange не обнаружены в соответствующей папке файлы журнала, обязательные для восстановления базы данных. Если отсутствует обязательный файл журнала, восстановление базы данных невозможно.

Чтобы устранить эту ошибку

  • Найдите отсутствующие файлы журнала транзакций и добавьте их в соответствующую папку.

  • Восстановите базу данных из резервной копии. Затем внесите в базу данных недостающие обновления, воспроизведя остальные файлы журнала транзакций в базе данных.

    Важно!
    Данные в отсутствующем файле журнала и в последующих файлах журнала будут утеряны. Прежде чем восстановить базу данных из резервной копии, следует сохранить копию текущей базы данных. Если восстановление не завершится успешно, возможно удастся исправить текущую базу данных.

  • Восстановите текущую базу данных.

    Примечание.
    Хотя восстановление базы данных, скорее всего, будет выполнено успешно, такой результат не является гарантированным. Даже при успешном восстановлении может быть утрачен небольшой или значительный объем данных. Дополнительные сведения о восстановлении базы данных Exchange см. в базе знаний Майкрософт в статье 812357, содержащей инструкции по обслуживанию базы данных Exchange после восстановления с помощью средства Eseutil /p в Exchange Server 5.5, в Exchange 2000 Server и в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812357).

  • Реализуйте гибридную стратегию, которая включает исправление и восстановление базы данных. Иногда доступно полное восстановление базы данных даже в том случае, если ее невозможно обновить вперед с использованием дополнительных файлов журнала. В такой ситуации можно попробовать восстановить предыдущую копию базы данных, одновременно исправляя текущую копию, которую не удается подключить. Затем можно слить содержимое баз данных, чтобы добиться восстановления максимального объема данных. Эта стратегия не относится к числу стандартных, перед ее реализацией рекомендуется обратиться в службу справки и поддержки Майкрософт (http://go.microsoft.com/fwlink/?LinkId=31845). Дополнительные сведения об этой стратегии см. по ссылке Использование групп хранения для восстановления в Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589).


Для баз данных в этой группе хранения установлены во время архивирования нулевые страницы
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-05

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchESEParamZeroDatabaseDuringBackup каждой группы хранения на сервере. Если анализатор сервера Exchange обнаружит, что атрибут msExchESEParamZeroDatabaseDuringBackup установлен равным 1, средство анализатора сервера Exchange выведет сообщение о конфигурации, отличной от конфигурации по умолчанию.

Атрибут msExchESEParamZeroDatabaseDuringBackup представляет собой параметр конфигурации, который включает перезапись удаленных записей/длинных значений нулями во время архивирования. Этот процесс называется обнулением. Обнулением страниц баз данных можно управлять на уровне групп хранения. Каждая группа хранения имеет свою, отличную от других, политику обнуления удаленных страниц базы данных.

По умолчанию обнуление отключено и значение атрибута msExchESEParamZeroDatabaseDuringBackup установлено равным 0. Когда атрибут установлен равным 1, удаленные страницы базы данных перезаписываются другими знаками в конце оперативных резервных копирований любой из баз данных в этой группе хранения.

Включить и отключить обнуление базы данных для Exchange 2000 Server и Exchange Server 2003 можно с помощью диспетчера Exchange, как описано в этой статье. Включить и отключить обнуление базы данных для Exchange 2007 Server можно с помощью командной консоли Exchange - эта процедура также описана в данной статье. Хотя эта возможность предоставляет более высокий уровень безопасности, она влияет на производительность работы сервера.

Примечание. Если на компьютере с Exchange 2000 Server включается обнуление, рекомендуется установить пакет обновления 3 (SP3) Exchange 2000 Server или более позднюю версию. Пакет обновления 3 (SP3) устраняет известную проблему, которая может быть причиной прекращения ответов со стороны банка данных Exchange. Дополнительные сведения об этой проблеме см. в базе знаний Майкрософт в статье 320883, описывающей причины прекращения ответов со стороны банка данных во время оперативного резервного копирования, когда включено обнуление базы данных (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320883).

Включение или отключение обнуления базы данных Exchange 2000 Server и Exchange Server 2003

  1. Откройте диспетчер Exchange

  2. Разверните узел Серверы, а затем разверните узел сервера, который хотите изменить.

  3. Щелкните правой кнопкой мыши группу хранения, которую хотите изменить, и выберите в контекстном меню пункт «Свойства».

  4. В диалоговом окне «Свойства» установите или снимите флажок Обнулить удаленные страницы базы данных в зависимости от того, что необходимо. При установке флажка обнуление включается, а если флажок снять, обнуление отключается.

  5. Нажмите кнопку ОК, чтобы сохранить настройку.

  6. Закройте системный диспетчер Exchange и перезапустите службу банка данных Microsoft Exchange, чтобы изменение вступило в силу.

Включение или отключение обнуления базы данных удаленных страниц Exchange Server 2007

  1. Следующий код является примером команды Set-StorageGroup, которая включает или отключает обнуление баз данных в группе хранения "MyStorageGroup".
Копировать код
Set-StorageGroup -Identity MyStorageGroup -ZeroDatabasePages
 $false
Set-StorageGroup -Identity MyStorageGroup -ZeroDatabasePages
 $true

Дополнительные сведения о влиянии перезаписи удаленных страниц баз данных на производительность см. в базе знаний Майкрософт в статье 815068, описывающей причины уменьшения со временем производительности оперативного резервного копирования (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815068).


Включен параметр «Debug Break At Startup» (точка останова при запуске)
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, включена ли отладка в службе «Банк данных Microsoft Exchange», анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Debug Break At Startup

Если анализатор сервера Exchange обнаружит, что для атрибута Debug Break At Startup задано значение, на экран выводится предупреждение.

Параметр реестра Debug Break At Startup включает режим отладки при следующем запуске службы «Банк данных Microsoft Exchange». Служба «Банк данных Microsoft Exchange» использует большое количество ресурсов при работе в режиме отладки. Не рекомендуется проводить отладку хранилища в производственной среде.

Если в данный момент не требуется устранять неполадку хранилища с помощью службы поддержки продуктов Майкрософт, то следует удалить параметр Debug Break At Startup.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы удалить ключ реестра «Debug Break At Startup»

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. В правой области найдите и удалите параметр Debug Break At Startup.

  4. Закройте редактор реестра и перезапустите службу Банк данных Microsoft Exchange, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Изменены буферы журнала ESE по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить значение атрибута msExchESEParamLogBuffers для каждой группы хранения сервера Exchange, средство анализатора сервера Microsoft® Exchange выполняет поиск в службе каталогов Active Directory®. Если анализатор сервера Exchange обнаружит, что значение атрибута msExchESEParamLogBuffers равно 512, на экран будет выведено сообщение о конфигурации, отличной от конфигурации по умолчанию.

Атрибут группы хранения msExchESEParamLogBuffers определят количество буферов журнала ESE, которые используются банком данных Exchange. Модуль ESE использует набор буферов журналов для хранения данных в ОЗУ перед их записью в журналы транзакций. Применение этих буферов повышает быстродействие при ведении журнала транзакций. Для больших серверов используемое по умолчанию значение 84 слишком мало. Из-за этого может чрезвычайно возрасти объем дисковых операций ввода-вывода при обращении к диску с журналом транзакций и, следовательно, может значительно снизиться быстродействие при загрузке сервера или при отправке пользователями больших сообщений. Увеличение числа буферов журналов ESE повышает быстродействие, но при этом использование виртуальной памяти растет.

Чтобы правильно задать это значение, воспользуйтесь следующей информацией:

  • Для сервера Exchange 2000 Server, пакета обновления 1 (SP1) для сервера Exchange 2000 Server и пакета обновления 2 (SP2) для сервера Exchange 2000 Server установите в качестве этого значения 9000.

  • Для пакета обновления 3 (SP3) для сервера Exchange 2000 Server задайте значение 512.

  • Для севера Exchange Server 2003 по умолчанию в качестве этого значения используется 500, и следует для атрибута msExchESEParamLogBuffers установить значение 9000.

Примечание.
Если ранее для числа буферов журнала было задано значение 9000, необходимо обязательно вручную уменьшить это значение после установки пакета обновления 3 для сервера Exchange 2000 Server. Это изменение не выполняется автоматически при установке пакета обновления 3 для сервера Exchange 2000 Server.

При зависании журнала причиной этого может быть слишком низкое число буферов, и тогда следует увеличить его до 9000. Наблюдение за счетчиком производительности Database\Log Record Stalls/sec позволяет определить, произошло ли зависание журнала. Не используйте значения, которые превышают 9000, так как это может повредить файлы журнала транзакций.

Примечание.
Значение Log Record Stalls/sec — это число записей журнала, которые не удалось добавить в буферы журнала за одну секунду из-за того, что буферы были заполнены. Если большую часть времени значение этого счетчика отлично от нуля, размер буфера журнала является узким местом.

Это значение следует исправить, применяя, например, оснастку Edit интерфейса ADSI, средство LDP (ldp.exe) или любой другой клиент, использующий протокол LDAP версии 3.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью оснастки «Редактирование» интерфейса ADSI, средства LDP или другого клиента, использующего протокол LDAP версии 3, может привести к серьезным неполадкам. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Возврат к конфигурации по умолчанию

  1. Запустите оснастку Edit интерфейса ADSI.

  2. Дважды щелкните контейнер Configuration, разверните последовательно CN=Services, CN=Microsoft Exchange и CN=<ExchangeOrganizationName>.

  3. Разверните последовательно CN=Administrative Groups, CN=<AdministrativeGroupName> и CN=Servers.

  4. Разверните последовательно CN=<ServerName> и CN=InformationStore, щелкните правой кнопкой мыши CN=<StorageGroupName>, а затем выберите Свойства.

  5. В окне Редактора атрибутов щелкните атрибут msExchESEParamLogBuffers, а затем нажмите кнопку Изменить.

  6. В поле Изменить атрибут задайте значение 512 для Exchange 2000 Server или 9000 для Exchange Server 2003.

  7. Нажмите кнопку Применить, затем кнопку ОК.

  8. Закройте оснастку Edit интерфейса ADSI и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Для получения дополнительных сведений о буферах журналов ESE см. статью 328466 базы знаний корпорации Майкрософт о том, что слишком малое значение, установленное для буферов журналов ESE, может быть причиной прекращения отклика банка данных (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466).

Для получения дополнительных сведений об использовании средства LDP см. статью 260745 базы знаний корпорации Майкрософт об использовании служебной программы LDP для изменения атрибутов объектов Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Дополнительные сведения о работе с оснасткой Edit интерфейса ADSI см. в разделе «Adsiedit.msc: ADSI Edit» в справке Windows Server.


Хранилище общих папок по умолчанию является удаленным
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-03

Средство анализатора приложения Microsoft® Exchange Server запрашивает службу каталогов Active Directory®, чтобы определить, содержит ли атрибут msExchHomePublicMDB каждого хранилища почтовых ящиков локальный сервер Exchange. По умолчанию хранилище общих папок для хранилища почтовых ящиков размещено на локальном сервере Exchange. Если атрибут msExchHomePublicMDB не содержит локальный сервер Exchange, хранилище почтовых ящиков содержит удаленное хранилище общих папок. Если анализатор сервера Exchange обнаруживает, что хранилище почтовых ящиков содержит удаленное хранилище общих папок, он выводит на экран сообщение о конфигурации не по умолчанию.

Чтобы изменить хранилище почтовых ящиков по умолчанию

  1. В диспетчере Exchange разверните узел Серверы, разверните <ваш сервер Exchange>, разверните <группу хранения>, щелкните правой кнопкой мыши почтовый ящик и затем выберите параметр Свойства.

  2. На вкладке Общие в группе Общее хранилище по умолчанию щелкните параметр Обзор, чтобы выбрать хранилище общих папок.

Дополнительные сведения о хранилищах почтовых ящиков и хранилищах общих папок см. в статье "Managing Mailbox Stores and Public Folder Stores" (Управление хранилищами почтовых ящиков и хранилищами общих папок) раздела Руководство по администрированию приложения Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).


Значение параметра Deletion Thread Period для хранилища почтовых ящиков отличается от используемого по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Анализатор рекомендаций Microsoft® Exchange Server считывает следующий параметр реестра, чтобы определить, совпадает ли интервал окончательного удаления элементов со значением по умолчанию:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Deletion Thread Period

Если анализатор сервера Exchange обнаруживает, что параметр Deletion Thread Period существует и настроен, выводится сообщение о наличии конфигурации, не являющейся заданной по умолчанию.

Когда сообщение удаляется, Exchange помечает его для удаления. Exchange также помечает это сообщение как скрытое до тех пор, пока оно не будет окончательно удалено из хранилища Exchange. Когда хранилище Exchange получает запрос на удаление сообщения с указанным идентификатором сообщения в определенной папке, хранилище Exchange определяет, должно ли сообщения быть удалено с возможностью восстановления или без возможности восстановления. Сообщение окончательно удаляется по истечении срока хранения удаленных элементов. Удаление с возможностью восстановления также называется логическим удалением. Удаление без возможности восстановления называется физическим удалением.

По умолчанию процесс очистки мусорного контейнера выполняется каждые 24 часа, при этом элемент удаляется без возможности восстановления. Процесс очистки мусорного контейнера является частью процесса сетевого обслуживания хранилища Exchange. Если срок хранения удаленных элементов истек, элемент будет удален без возможности восстановления. Параметр реестра Deletion Thread Period используется для отмены заданного по умолчанию 24-часового интервала и указания нового интервала для процесса очистки мусорного контейнера.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» средства Regedit.exe или Regedt32.exe.

Чтобы вернуть настройку по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Удалите раздел Deletion Thread Period.

  4. Закройте редактор реестра.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Для получения дополнительных сведений о хранении и восстановлении удаленных элементов см. следующие статьи базы знаний:

  • Статья 249680, в которой описывается хранение удаленных элементов и процесс удаления сообщений (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=249680).

  • Статья 287544, в которой описывается существенное увеличение объема общего банка данных при включении функции хранения удаленных элементов (http://go.microsoft.com/fwlink/?linkid=3052&kbid=287544).

  • Статья 822938, в которой описывается использование системных политик для настройки размера хранилищ почтовых ящиков в Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822938).


Значение параметра Deletion Thread Period для хранилища общих папок отличается от заданного по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, был ли изменен интервал очистки удаленных элементов так, что он отличается от заданного по умолчанию, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\Deletion Thread Period

Если анализатор сервера Exchange обнаруживает, что параметр Deletion Thread Period существует и настроен, выводится сообщение о наличии конфигурации, не являющейся заданной по умолчанию.

Когда сообщение удаляется, Exchange помечает его для удаления. Exchange также помечает это сообщение как скрытое до тех пор, пока оно не будет окончательно удалено из хранилища Exchange. Когда банк данных получает запрос на удаление сообщения с указанным идентификатором сообщения в определенной папке, хранилище Exchange определяет, должно ли сообщения быть удалено с возможностью восстановления или без возможности восстановления. Удаление с возможностью восстановления также называется логическим удалением, а удаление без возможности восстановления — физическим удалением. Сообщение окончательно удаляется по истечении срока хранения удаленных элементов.

По умолчанию процесс очистки мусорной корзины выполняется каждые 24 часа, при этом элемент удаляется без возможности восстановления. Процесс очистки мусорной корзины является частью процесса сетевого обслуживания хранилища Exchange. Если срок хранения удаленных элементов истек, элемент будет удален без возможности восстановления. Значение реестра Deletion Thread Period используется для отмены заданного по умолчанию 24-часового интервала и указания нового интервала для процесса очистки мусорного контейнера.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» средства Regedit.exe или Regedt32.exe.

Чтобы восстановить конфигурацию по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. Удалите параметр реестра Deletion Thread Period.

  4. Закройте редактор реестра.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Для получения дополнительных сведений о хранении и восстановлении удаленных элементов см. следующие статьи базы знаний:

  • Статья 249680, в которой описывается хранение удаленных элементов и процесс удаления сообщений (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=249680).

  • Статья 287544, в которой описывается существенный рост общего банка данных при включении функции хранения удаленных элементов (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=287544).

  • Статья 319098, в которой описывается использование системных политик для настройки ограничений хранилища общих папок в Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319098).


Обнаружено узкое место на диске
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2006-11-14

Средством анализатора сервера Microsoft® Exchange определено, что дисковая система в текущий момент работает в пределах 20 процентов от ожидаемой максимально доступной производительности. Этот вывод сделан на основании одного из следующих расчетов:

  • Измерение задержек в работе диска. Счетчики производительности, которые показывают задержку: LogicalDisk\Avg., Disk sec/Read и LogicalDisk\Avg. Disk sec/Write.

  • Сравните максимально возможное количество дисковых операций ввода-вывода за секунду для конфигурации текущего диска и показание счетчика диска по сравнению с текущим значением количества дисковых операций ввода вывода за секунду, зафиксированным системным монитором (Perfmon).

Допустимые задержки

В зависимости от типа данных, к которым происходит обращение, сервер Exchange имеет разные допуски на задержки. По этой причине максимально допустимое пороговое значение на среднюю задержку приводится на основе типа ресурса, находящегося на диске. Для всех случаев за исключением тех, что указаны в следующем списке, максимально допустимое значение задержек чтения или записи составляет 50 миллисекунд (мс).

  • Диски журналов транзакций. Диск, на котором размещается журнал транзакций, должен иметь средние значения задержек записи менее 10 мс. Пиковые значения задержек записи не должны превышать 50 мс. Записи в журнал транзакций выполняются согласованно. Это означает, что прежде чем поток в процессе Store.exe сможет выполнить другую задачу, поток должен дождаться завершения записи. Задержки записи для журналов транзакций влияют в сильной мере на производительность сервера. Средняя задержка операции чтения для дисков журнала транзакций должна быть меньше 20 мс. Пиковые значения задержки чтения должны быть меньше 50 мс. Число остановов записей журнала базы данных должно быть меньше 10. Число ожидающих потоков журнала базы данных должно быть меньше 10.

    Обычно серверы Exchange не выполняют чтение из журналов транзакций. Поэтому задержки чтения для этого диска не имеют значения. Однако, поскольку задержки записи в журнал транзакций сильно влияют на производительность приложения Exchange, рекомендуется, чтобы на больших серверах диски, на которых размещаются журналы транзакций, не использовались для каких-либо других целей. В этом случае интенсивность операций чтения (измеряемая счетчиком LogicalDisk\Disk Reads/sec) должна быть минимальной по сравнению с интенсивностью операций записи (измеряемой счетчиком LogicalDisk\Disk Writes/sec). Анализатор сервера Exchange определит, когда отношение количества операций чтения к числу операций записи на диске журнала транзакций будет больше 0,10 (более одной операции чтения на каждые десять операций записи).

    Если на каждую операцию записи приходится более 0,10 операций чтения, следует идентифицировать, какое приложение выполняет чтение с диска журнала транзакций, а затем прекратить выполнение этих действий.

  • Диски баз данных. Допустимые задержки для дисков, содержащих файлы баз данных Exchange (файлы с расширениями EDB и STM), перечисляются ниже (более высокие значения указывают на наличие узких мест на диске):

    • Максимальное значение показателя «Логический диск\среднее число дисковых операций в секунду/чтение» на диске базы данных должно быть меньше 50 мс. (0,050 секунды).

    • Среднее значение показателя «Логический диск\среднее число дисковых операций в секунду/чтение» на диске базы данных должно быть меньше 20 мс. (0,020 секунды).

  • Диски каталогов TEMP и TMP. Задержки операций чтения и записи для дисков, содержащих каталоги TEMP и TMP, должны быть меньше 10 мс. Максимальное значение задержки операции чтения или записи должно быть меньше 50 мс.

  • Диск файла подкачки и системы. Задержки чтения и записи для дисков, содержащих файлы подкачки и системные файлы Windows, должны быть меньше 10 мс.

  • SMTP-диск. Задержки чтения и записи для дисков, содержащих файлы SMTP-сервера, должны быть меньше 10 мс.

Причины задержки

Интенсивность обращений к дискам выше частоты доступа, которая поддерживается дисковой подсистемой — это одна из самых распространенных причин задержки дисковых операций. В этом случае считается, что диск является узким местом системы. Это также означает, что нагрузка на дисковую подсистему достигла или превысила предельную производительность подсистемы.

Если интенсивность дисковых операций ввода-вывода в секунду (счетчик LogicalDisk\Disk Transfers/sec) около или больше оцениваемой производительности, тогда считается, что диск находится за пределами пропускной способности или за пределами производительности. В этих случаях для повышения производительности сервера необходимо уменьшить нагрузку на дисковую подсистему (переместив пользователей на другой сервер) или увеличить производительность диска (добавив дополнительные или более быстрые диски).

В случаях, когда оборудование не работает так, как ожидается, задержки могут возникать даже тогда, когда интенсивность операций ввода-вывода значительно меньше предполагаемой производительности.

Уменьшение задержек дисковых операций

Чтобы снизить нагрузку на дисковую подсистему, можно уменьшить некоторые задачи, которые выполняются сервером. В частности, следует удалить любые дополнительные приложения, которые вносят вклад в нагрузку на диск. Процесс Store.exe является единственным приложением, которое должно обращаться к дискам баз данных и журналов транзакций.

В зависимости от текущей конфигурации дисковой системы можно предпринять некоторые действия по снижению остроты этой проблемы.

Чтобы уменьшить задержки дисковых операций

  • Если диск базы данных или журнала транзакций является узким местом, можно уменьшить нагрузку на этот диск, переместив пользователей в базу данных или группу хранения, размещаемую на диске, ресурсы которого далеки от полного использования. Если все диски баз данных или журнала транзакций практически полностью заняты, возможно, потребуется переместить пользователей на другой сервер. Дополнительные сведения см. по ссылке Перенос почтовых ящиков пользователей на другой сервер.

  • Иногда продолжительность высокой интенсивности операций ввода-вывода невелика, поскольку вызвана дорогостоящей MAPI-операцией. В этом случае чтобы определить, какой пользователь или какое действие является причиной высокой интенсивности операций ввода-вывода, можно использовать средство наблюдения за пользователями сервера Exchange (ExMon) совместно со счетчиками производительности логических дисков. Если изолировать пользователя, можно будет определить, какое клиентское приложение создает более высокую нагрузку. Средство ExMon можно загрузить из центра загрузки Майкрософт (http://go.microsoft.com/fwlink/?LinkId=54983).

  • Если работает дисковый массив RAID-5, может возникнуть желание перейти на дисковый массив RAID-10, чтобы увеличить интенсивность операций ввода-вывода в секунду, поддерживаемую дисковой подсистемой.

  • Чтобы увеличить поддерживаемую интенсивность операций ввода-вывода в секунду, рассмотрите возможность добавления в дисковую систему дополнительных дисков.

Дополнительные сведения

  • Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Дополнительные сведения об устранении проблем производительности сервера Exchange см. в описании процедур устранения неполадок, связанных с производительностью Microsoft Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Дополнительные сведения о рекомендациях по разработке архитектур хранилищ см. в описании общих рекомендаций для нескольких архитектур (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=72988).

  • Дополнительные сведения о переносе почтовых ящиков пользователей для снижения нагрузки на сервер см. по ссылке Перенос почтовых ящиков пользователей на другой сервер.

  • Дополнительные сведения об изменении емкости дисков, задержках и интенсивностях операций ввода-вывода см. в следующих блогах на веб-узле блогов группы Microsoft Exchange:

    • Описание основных концепций по изменению емкости дисков (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=39538).

    • Дополнительные соображения по дисковым операциям ввода-вывода, расчетам и другим вопросам (могут быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=39539).

    • Инструкции по расчету требований к системе ввода-вывода диска (могут быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=69747).


Найдено узкое место, связанное с диском, содержащим файлы журнала транзакций
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server обнаружило, что дисковая система, содержащая файлы журнала Exchange Server, перегружена, и это является причиной уменьшения производительности. Этот факт фиксируется при проверке одного или нескольких из следующих счетчиков производительности:

  • Среднее значение Database\Log Record Stalls/sec больше 10.

  • Максимальное значение Database\Log Record Stalls/sec больше 100.

  • Среднее значение Database\Log Threads Waiting больше 10.

  • Максимальное значение Database\Log Threads Waiting больше 20.

Если один из этих порогов превышается, отображается сообщение об ошибке, указывающее на наличие узкого места, связанного с диском, содержащим журнал. Задержка записи в файлы журнала должна быть низкой. Резервное копирование или остановка при записи в файл журнала может вызвать уменьшение производительности сервера. Остановки при записи в журнал могут быть вызваны низким значением параметра буфера журнала msExchESEParamLogBuffers или слишком большим количеством подключений пользователей к серверу.

Для уменьшения задержки записи в журнал

  • Можно увеличить значение параметра буферов ESE msExchESEParamLogBuffers до 9000. Не используйте значение больше 9000, это может повредить файлы журнала транзакций. Для получения дополнительных сведений см. раздел Изменены буферы журнала ESE по умолчанию.

  • Если имеетсяузкое место, связанное с диском, содержащим журнал транзакций или базу данных, можно уменьшить загрузку диска переносом пользователей в базу данных или группу хранилищ, хранящуюся на диске, имеющем достаточно свободного места. Если свободного места на всех дисках, содержащих журналы транзакций или базы данных, мало, может потребоваться перенести пользователей на другой сервер. Для получения дополнительных сведений см. раздел Перенос почтовых ящиков пользователей на другой сервер.


Значение EnableChangeNotification отличается от заданного по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, были ли включены уведомления об изменении файлов для устанавливаемой файловой системы Exchange (ExIFS), анализатор сервера Microsoft® Exchange читает значение следующего параметра реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIFS\Parameters\ EnableChangeNotification

Если анализатор сервера Exchange обнаруживает параметр EnableChangeNotification, значение которого превышает 0, отображается сообщение о том, что конфигурация отличается от заданной по умолчанию.

По умолчанию уведомления об изменении файлов для ExIFS отключены. Когда файловая система ExIFS отправляет уведомления об изменении файла или каталога, он не очищает кэшированную версию файла или каталога. В результате, когда такое приложение, как сервер Exchange или сервер Microsoft SharePoint® Portal Server получает уведомление об изменении и перезагружает файл или каталог, оно получает кэшированную версию, а не вновь измененный файл или каталог.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы восстановить конфигурацию по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\EXIFS\Parameters

  3. Удалите раздел EnableChangeNotification.

  4. Закройте редактор реестра и перезапустите сервер Exchange, чтобы изменение вступило в силу.

Перед редактированием реестра изучите инструкции о том, как следует выполнить эту процедуру, в статье базы знаний Майкрософт 256986 «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Для получения дополнительных сведений об устанавливаемой файловой системе Exchange см. следующие материалы:

  • Глава 26 «Архитектура Exchange 2000» сборника руководств Exchange 2000 Server Resource Kit (http://go.microsoft.com/fwlink/?LinkId=51224) (может быть на английском языке);

  • Техническое руководство по Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=47586).


Ошибка при доступе к каталогу журналов
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange обнаружило, что к пути, определенному на сервере Exchange для журналов транзакции этой группы хранения, нет доступа.

Чтобы устранить эту ошибку

  • Проверьте, что местоположение, указанное в пути, действительно существует на сервере.

  • Проверьте, что имеются права на чтение файлов, которые размещены по пути журналов транзакций.


Ошибка доступа к файлу потоковой базы данных
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Server обнаружило, что файл потоковой базы данных (STM-файл) недоступен.

Каждая база данных Exchange 2000 Server и Exchange Server 2003 состоит из двух файлов: EDB-файл базы данных Exchange и STM-файл потоковой базы данных. Доступ к этим файлам и их обработка должны осуществляться совместно.

Чтобы устранить эту ошибку:

  • Определите путь к STM-файлу. В диспетчере Exchange этот путь определен на странице свойств базы данных для каждого объекта базы данных.

  • Проверьте, что STM-файл для этой базы данных существует.

  • Убедитесь, что имеете разрешения на доступ к папке, в которой находится STM-файл.

  • Проверьте, что этот файл не был монопольно заблокирован другим процессом. Один из способов такой проверки состоит в том, чтобы попытаться переименовать данный файл. Если это удастся сделать, это означает, что данный файл не был монопольно заблокирован. (Не забудьте вернуть этому файлу его исходное имя.)


Файлы журнала проверки ошибок
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server не смогло прочитать файлы журналов операций.

Исправление ошибки

  • Убедитесь, что у вас есть необходимое разрешение для доступа к папке файла журнала операций.

  • Убедитесь, что файл не заблокирован другим процессом. Одним из способов проверки является попытка переименования файла. Если переименование файла возможно, это означает, что файл не заблокирован. (Помните, что необходимо переименовать файл обратно.)


Для данной группы хранения буферы журналов ESE находятся на максимуме
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchESEParamLogBuffers для каждой группы хранения. Если анализатор сервера Exchange обнаружит, что значение атрибута msExchESEParamLogBuffers равно 9000, на экран будет выведено сообщение о конфигурации, отличной от конфигурации по умолчанию.

Модуль расширяемого хранилища (Extensible Storage Engine, ESE) использует набор буферов журналов для хранения данных в ОЗУ перед их записью в журналы транзакций. Применение этих буферов повышает быстродействие при ведении журнала транзакций. Для больших серверов используемое по умолчанию значение 84 слишком мало. Из-за этого может чрезмерно возрасти объем дисковых операций ввода-вывода, когда происходит обращение к диску с журналом транзакций и, следовательно, может значительно снизиться быстродействие при загрузке сервера или при отправке пользователями больших сообщений. Увеличение числа буферов журналов ESE повышает быстродействие, но при этом использование виртуальной памяти растет.

Чтобы правильно задать это значение, воспользуйтесь следующей информацией:

  • Для сервера Exchange 2000 Server, пакета обновления 1 (SP1) для сервера Exchange 2000 Server и пакета обновления 2 (SP2) для сервера Exchange 2000 Server установите в качестве этого значения 9000.

  • Для пакета обновления 3 (SP3) для сервера Exchange 2000 Server установите в качестве этого значения 512.

  • Для севера Exchange Server 2003 по умолчанию в качестве этого значения используется 500, а для атрибута msExchESEParamLogBuffers следует установить значение 9000.

Примечание.
Если ранее для числа буферов журнала было задано значение 9000, проверьте, что вы вручную уменьшили это значение после установки пакета обновления 3 для сервера Exchange 2000 Server. Это изменение не выполняется автоматически при установке пакета обновления 3 для сервера Exchange 2000 Server.

При зависании журнала причиной этого может быть слишком низкое число буферов, и тогда следует увеличить его до 9000. Наблюдение за счетчиком производительности Database\Log Record Stalls/sec позволяет определить, произошло ли зависание журнала. Не используйте значений, которые больше 9000, так как это может повредить файлы журнала транзакций.

Примечание.
Значение Log Record Stalls/sec — это число записей журнала, которые не удалось добавить в буферы журнала за одну секунду из-за того, что буферы были заполнены. Если большую часть времени значение этого счетчика отлично от нуля, размер буфера журнала является узким местом.

Это значение следует исправить, применяя, например, оснастку Edit интерфейса ADSI, средство LDP (ldp.exe) или любой другой клиент, использующий протокол LDAP версии 3.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью оснастки Edit интерфейса ADSI, средства LDP или другого клиента, использующего протокол LDAP версии 3, может привести к серьезным неполадкам. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы вернуться к конфигурации по умолчанию

  1. Запустите оснастку Edit интерфейса ADSI.

  2. Дважды щелкните контейнер Конфигурация, разверните последовательно CN=Службы, CN=Microsoft Exchange и CN=<имя_организации_Exchange>.

  3. Разверните последовательно CN=Административные группы, CN=<имя_группы_администраторов> и CN=Серверы.

  4. Разверните последовательно CN=<имя_сервера> и CN=InformationStore, щелкните правой кнопкой мыши CN=<имя_группы_хранения>, а затем выберите Свойства.

  5. В окне Редактор атрибутов выберите атрибут msExchESEParamLogBuffers, а затем щелкните Изменить.

  6. В поле Изменить атрибут задайте значение 512 для Exchange 2000 Server или 9000 для Exchange Server 2003.

  7. Нажмите Применить, затем — ОК.

  8. Закройте оснастку Edit интерфейса ADSI и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Дополнительные сведения о настройке буферов журналов ESE см. в базе знаний Майкрософт в статье 328466, описывающей ситуацию, когда слишком малое значение, установленное для буферов журналов ESE, может привести к прекращению отклика банка данных (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466).


Размер буферов журналов ESE задан слишком малым для этой группы хранения
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство Microsoft® Exchange Server Analyzer запрашивает службу каталогов Active Directory®, чтобы определить значение msExchESEParamLogBuffers для каждого объекта группы хранения (классmsExchStorageGroup) в контейнере InformationStore. Если Exchange Server Analyzer находит, что значение этого атрибута меньше, чем 500, отображается предупреждение.

Модуль Extensible Storage Engine (ESE) использует набор буферов журналов для хранения данных в ОЗУ перед их записью в журналы транзакций. Применение этих буферов повышает быстродействие при ведении журнала транзакций. Для больших серверов используемое по умолчанию значение 84 слишком мало. Из-за этого может чрезвычайно возрасти объем дисковых операций ввода-вывода при обращении к диску с журналом транзакций и, следовательно, может значительно снизиться быстродействие при загрузке сервера или при отправке пользователями больших сообщений. Увеличение числа буферов журналов ESE повышает быстродействие, но при этом использование виртуальной памяти растет.

Чтобы правильно задать это значение, воспользуйтесь следующей информацией:

  • Для сервера Exchange 2000 Server, пакета обновления 1 (SP1) для сервера Exchange 2000 Server Service и пакета обновления 2 (SP2) для сервера Exchange 2000 Server установите в качестве этого значения 9000.

  • Для пакета обновления 3 (SP3) для сервера Exchange 2000 Server Service Pack 3 (SP3) установите в качестве этого значения 512.

  • Для севера Exchange Server 2003 по умолчанию в качестве этого значения используется 500, и следует для атрибута msExchESEParamLogBuffers установить значение 9000.

Примечание.
Если ранее для числа буферов журнала было задано значение 9000, проверьте, что вы вручную уменьшили это значение после установки пакета обновления 3 для сервера Exchange 2000 Server. Это изменение не выполняется автоматически при установке пакета обновления 3 для сервера Exchange 2000 Server.

При зависании журнала причиной этого может быть слишком низкое число буферов, и тогда следует увеличить его до 9000. Наблюдение за счетчиком производительности Database\Log Record Stalls/sec позволяет определить, произошло ли зависание журнала. Не используйте значения, которые превышают 9000, так как это может повредить файлы журнала транзакций.

Примечание.
Значение Log Record Stalls/sec — это число записей журнала, которые не удалось добавить в буферы журнала за одну секунду из-за того, что буферы были заполнены. Если большую часть времени значение этого счетчика отлично от нуля, размер буфера журнала является узким местом.

Это значение следует исправить, применяя, например, оснастку «Изменение ADSI», средство LDP (ldp.exe) или любой другой клиент, использующий протокол LDAP версии 3.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью оснастки «Изменение ADSI», средства LDP или другого клиента с LDAP версии 3, может привести к серьезным неполадкам. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы устранить причину появления этого предупреждения

  1. Запустите оснастку Edit интерфейса ADSI.

  2. Дважды щелкните контейнер Configuration, разверните последовательно CN=Services, CN=Microsoft Exchange и CN=<ExchangeOrganizationName>.

  3. Разверните последовательно CN=Administrative Groups, CN=<AdministrativeGroupName> и CN=Servers.

  4. Разверните последовательно CN=<ServerName> и CN=InformationStore, щелкните правой кнопкой мыши CN=<StorageGroupName>, а затем выберите Свойства.

  5. В окне Редактора атрибутов щелкните атрибут msExchESEParamLogBuffers, а затем нажмите кнопку Изменить.

  6. В поле Edit Attribute задайте значение 512 для Exchange 2000 Server или 9000 для Exchange Server 2003.

  7. Нажмите кнопку Применить, затем кнопку ОК.

  8. Закройте оснастку Edit интерфейса ADSI и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Для получения дополнительных сведений о буферах журналов ESE см. статью 328466 базы знаний корпорации Майкрософт о том, что слишком малое значение, установленное для буферов журналов ESE, может быть причиной прекращения отклика банка данных (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466).

Для получения дополнительных сведений об использовании средства LDP см. статью 260745 базы знаний корпорации Майкрософт об Using the LDP Utility to Modify Active Directory Object Attributes» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745) (Использование служебной программы LDP для изменения атрибутов объектов Active Directory).

Для получения дополнительных сведений о настройке буферов журналов ESE см. статью 328466 базы знаний корпорации Майкрософт о том, что слишком малое значение, установленное для буферов журналов ESE, может быть причиной прекращения отклика банка данных (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466).

Дополнительные сведения о работе с оснасткой Edit интерфейса ADSI см. в разделе «Adsiedit.msc: ADSI Edit» в справке Windows Server.


Для этой группы хранения указан слишком большой размер буферов журналов ESE
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить значение атрибута msExchESEParamLogBuffers для каждой группы хранения, средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®. Если анализатор сервера Exchange обнаруживает, что значение атрибута msExchESEParamLogBuffers любой из групп хранения превышает 9 000, отображается сообщение об ошибке.

Модуль Extensible Storage Engine (ESE) использует набор буферов журналов для хранения данных в ОЗУ перед их записью в журналы транзакций. Применение этих буферов повышает быстродействие при ведении журнала транзакций. Для больших серверов используемое по умолчанию значение 84 слишком мало. Из-за этого может чрезвычайно возрасти объем дисковых операций ввода-вывода при обращении к диску с журналом транзакций и, следовательно, может значительно снизиться быстродействие при загрузке сервера или при отправке пользователями больших сообщений. Увеличение числа буферов журналов ESE повышает быстродействие, но при этом использование виртуальной памяти растет.

Чтобы правильно задать это значение, воспользуйтесь следующей информацией:

  • Для сервера Exchange 2000 Server, пакета обновления 1 (SP1) для сервера Exchange 2000 Server Service и пакета обновления 2 (SP2) для сервера Exchange 2000 Server установите в качестве этого значения 9000.

  • Для пакета обновления 3 (SP3) для сервера Exchange 2000 Server Service Pack 3 (SP3) установите в качестве этого значения 512.

  • Для севера Exchange Server 2003 по умолчанию в качестве этого значения используется 500, и следует для атрибута msExchESEParamLogBuffers установить значение 9000.

Примечание.
Если ранее для числа буферов журнала было задано значение 9000, вручную уменьшите это значение после установки пакета обновления 3 для сервера Exchange 2000 Server. Это изменение не выполняется автоматически при установке пакета обновления 3 для сервера Exchange 2000 Server.

При зависании журнала причиной этого может быть слишком низкое число буферов, и тогда следует увеличить его до 9000. Наблюдение за счетчиком производительности Database\Log Record Stalls/sec позволяет определить, произошло ли зависание журнала. Не используйте значений, больших чем 9000, так как это может повредить файлы журнала транзакций.

Примечание.
Значение Log Record Stalls/sec — это число записей журнала, которые не удалось добавить в буферы журнала за одну секунду из-за того, что буферы были заполнены. Если большую часть времени значение этого счетчика отлично от нуля, размер буфера журнала является узким местом.

Это значение следует исправить, применяя, например, оснастку «Изменение» интерфейса ADSI, средство LDP (ldp.exe) или любой другой клиент, использующий протокол LDAP версии 3.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью оснастки «Редактирование» интерфейса ADSI, средства LDP или другого клиента, использующего протокол LDAP версии 3, может привести к серьезным неполадкам. Для устранения этих проблем может потребоваться переустановить Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих этих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы устранить эту ошибку

  1. Запустите оснастку «Редактирование» интерфейса ADSI.

  2. Дважды щелкните контейнер Configuration, разверните последовательно CN=Services, CN=Microsoft Exchange и CN=<имя_организации_Exchange>.

  3. Разверните последовательно CN=Administrative Groups, CN=<имя_группы_администраторов> и CN=Servers.

  4. Разверните последовательно CN=<имя_сервера> и CN=InformationStore, щелкните правой кнопкой мыши CN=<имя_группы_хранения>, а затем выберите команду Свойства.

  5. В окне Редактора атрибутов щелкните атрибут msExchESEParamLogBuffers, а затем нажмите кнопку Изменить.

  6. В поле Изменение атрибута задайте значение 512 для Exchange 2000 Server или 9000 для Exchange Server 2003.

  7. Нажмите кнопку Применить, а затем — кнопку ОК.

  8. Закройте оснастку «Редактирование» интерфейса ADSI и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Дополнительные сведения об использовании средства LDP см. в статье 260745 базы знаний корпорации Майкрософт "XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (Использование служебной программы LDP для изменения атрибутов объектов Active Directory) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Дополнительные сведения о настройке буферов журналов ESE см. в статье 328466 базы знаний корпорации Майкрософт "XADM: ESE Log Buffers That Are Set Too Low Can Cause the Store to Stop Responding" (Отсутствие отклика хранилища в связи с установкой для буферов журналов слишком малого значения ESE) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466).


Размер файла журнала ESE изменен вручную
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchESEParamLogFileSize контейнера InformationStore. Если анализатор сервера Exchange обнаружит, что значение атрибута msExchESEParamLogFileSize не равно 5120, на экран будет выведено сообщение об ошибке.

Это значение применяется на сервере ко всем группам хранения. Данная конкретная ошибка возникает, если значение этого атрибута изменено и не равно значению по умолчанию (5120 КБ или 5 МБ). Это единственное поддерживаемое значение, которое никогда не следует изменять.

Это значение следует исправить, применяя, например, оснастку Edit интерфейса ADSI, средство LDP (ldp.exe) или любой другой клиент, использующий протокол LDAP версии 3.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью оснастки Edit интерфейса ADSI, средства LDP или другого клиента, использующего протокол LDAP версии 3, может привести к серьезным неполадкам. Для устранения этих неполадок может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы устранить эту ошибку

  1. Откройте редактор службы Active Directory, например оснастку Edit интерфейса ADSI и найдите объект InformationStore для данного компьютера сервера Exchange в службе Active Directory.

    Атрибут msExchESEParamLogFileSize можно найти по следующему пути:

    CN=Configuration, DC=Domain, CN=Services, CN=Microsoft Exchange, CN= имя_организации , CN=Administrative Groups, CN= имя_административной_группы , CN=Servers, CN= имя_сервера , CN=InformationStore

  2. Дважды щелкните атрибут msExchESEParamLogFileSize и установите его значение равным 5120.

  3. Закройте редактор Active Directory, а затем перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Дополнительные сведения об использовании средства LDP.exe для изменения атрибутов объектов Active Directory см. в базе знаний Майкрософт в статье 260745, посвященной использованию служебной программы LDP для изменения атрибутов объектов Active Directory (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Дополнительные сведения о работе с оснасткой Edit интерфейса ADSI см. в разделе, посвященном Adsiedit.msc: ADSI Edit, в справке сервера Windows.


Максимальное количество открытых таблиц ESE жестко закодировано
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-17

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить, существует ли атрибут msExchESEParamMaxOpenTables для любых объектов группы хранения в объекте InformationStore объекта сервера Exchange. Если анализатор находит, что атрибут msExchESEParamMaxOpenTables существует и настроен, отображается сообщение о нестандартной конфигурации.

По умолчанию в Exchange 2000 Server и Exchange Server 2003 этот атрибут существует, но не имеет какого-либо значения. Сервер Exchange кэширует данные о папках, к которым в настоящий момент нет обращений. В некоторых случаях это может привести к фрагментации виртуальной памяти. Чтобы избежать этого, уменьшите максимальное количество таблиц баз данных, которое можно открыть одновременно. Предлагаемое значение этого параметра зависит от версии сервера Exchange и установленного пакета обновления. Для сервера Exchange 2000 с пакетом обновления 2 значением по умолчанию для 8-процессорных серверов будет 85 000 таблиц для одной группы хранения. Это значение уменьшено до 27 600 в сервере Exchange 2000 с пакетом обновления 3 для 8-процессорных серверов. Для 4-процессорных серверов значение будет равняться 13 800. Это значение может быть еще ниже, если следует избежать фрагментации виртуальной памяти. Однако снижение этого значения может привести к таким ситуациям, когда операции могут завершиться со сбоем из-за большого количества открытых таблиц. Ошибка возникает из-за того, что максимальное количество таблиц, которое может быть открыто одновременно, было занижено, следовательно, это максимальное количество достигается быстрее.

Exchange Server 2003 использует другой метод кэширования данных о папках, к которым в настоящий момент нет обращений. Поэтому уменьшение максимального количества открытых таблиц не является необходимым или эффективным для решения вопросов, связанных с фрагментацией виртуальной памяти. Этот атрибут не следует устанавливать на сервере Exchange Server 2003.

Если не поступало указаний от службы поддержки продуктов Майкрософт ввести это значение, используйте средство ADSI Edit для сброса значения, установленного для этого атрибута.

Внимание!
Могут возникнуть серьезные неполадки, если некорректно изменить атрибуты объектов Active Directory при использовании средства ADSI Edit, средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3. Для устранения этих неполадок может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы сбросить значение атрибута msExchESEParamMaxOpenTables

  1. Откройте редактор Active Directory, например, ADSI Edit.

  2. Дважды щелкните контейнер Configuration, разверните последовательно CN=Services, CN=Microsoft Exchange и CN=имя_организации_Exchange.

  3. Разверните последовательно CN=Administrative Groups, CN=имя_группы_администраторов и CN=Servers.

  4. Разверните последовательно CN=имя_сервера_Exchange и CN=InformationStore, щелкните правой кнопкой мыши CN=имя_группы_хранения, а затем выберите Properties.

  5. В поле Select a property to view, щелкните msExchESEParamMaxOpenTables.

  6. В поле Edit Attribute щелкните Clear, чтобы изменить значение на <not set>.

  7. Нажмите кнопку OK, а затем еще раз нажмите кнопку OK.

  8. Закройте редактор Active Directory, а затем перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Дополнительные сведения об этом атрибуте см. в базе знаний Майкрософт в статье 325044, описывающей инструкции по устранению неполадок, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044).

Дополнительные сведения об использовании средства LDP см. в статье 260745 базы знаний корпорации Майкрософт, посвященной использованию служебной программы LDP для изменения свойств объектов Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).


Размер базы данных Exchange превышает 100 ГБ
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-17

Средство анализа Microsoft Exchange Server запрашивает класс CIM_DataFile инструментария Microsoft Windows Management Instrumentation (WMI) для определения значения параметра FileSize для каждой базы данных банка сообщений Exchange. Если суммарный размер файла edb и файла stm превышает 100 гигабайтов (ГБ), появляется предупреждение.

Рекомендуемый размер базы данных хранилища информации не должен превышать 50 ГБ. При правильном обслуживании не возникает проблем в эксплуатации хранилищ почтовых ящиков размером более 50 ГБ. Тем не менее, большое время архивации и восстановления может привести к тому, что почтовый ящик утратит соответствие некоторым соглашениям об уровне обслуживания (SLA).

При использовании хранилищ почтовых ящиков размером более 50 ГБ необходимо проверить соответствие оборудования соглашениям об уровне обслуживания, например, что восстановление больших баз данных находится в пределах SLA. В противном случае рекомендуется распределить почтовые ящики между различными хранилищами, чтобы размер каждого хранилища почтовых ящиков не превышал 50 ГБ.

Исправление предупреждения

  1. Можно переместить некоторые почтовые ящики из большого хранилища информации в новые хранилища информации этого или другого сервера Exchange.

  2. Если почтовые ящики данного хранилища информации недавно были перемещены в другой или удалены, можно уменьшить размер файлов при помощи автономной дефрагментации.

  3. Возможна установка ограничений размера сообщений или почтовых ящиков, чтобы предотвратить чрезмерное увеличение размеров базы данных хранилища информации.

Дополнительные сведения о STM- и EDB-файлах см. в статье 232323 базы знаний Майкрософт, описывающей собственное хранилище содержимого в Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323).

Дополнительные сведения о перемещении почтовых ящиков в Exchange Server 2003 см. в базе знаний Майкрософт в статье 821829, описывающей перемещение почтовых ящиков в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

Дополнительные сведения о перемещении почтовых ящиков в Exchange 2000 Server см. в базе знаний Майкрософт в статье 328810, описывающей перемещение почтовых ящиков между серверами (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810).

Дополнительные сведения о выполнении автономной дефрагментации базы данных сервера Exchange см. в базе знаний Майкрософт в статье 328804, описывающей порядок дефрагментации баз данных Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804).

Для получения дополнительных сведений об установке ограничений размеров сообщений см. статью 322679 базы знаний Майкрософт «Установка ограничений размера сообщений» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679).


Файлы базы данных Exchange записываются в сжатую папку
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Directory, чтобы определить значение ключа Compressed для папки, содержащей файлы базы данных банка данных Exchange. Если значение Compressed установлено равным True для этой папки, на экран будет выведено сообщение об ошибке.

На компьютере с Exchange 2000 Server или Exchange Server 2003 базы данных банка данных записываются в следующее местоположение по умолчанию:

<диск> :\Program Files\Exchsrvr\mdbdata

По умолчанию на компьютере с Exchange Server 2007 файлы базы данных записываются по следующему пути:

<диск> :\Program Files\Microsoft\Exchange Server\Mailbox\<Storage Group Name>

Корпорация Майкрософт не поддерживает хранение файлов данных Exchange на сжатых NTFS-томах. При хранении файлов данных Exchange на сжатом томе дополнительные служебные операции существенно сказываются на производительности Exchange. Кроме того, когда база данных банка данных достигает определенного размера (приблизительно 4 ГБ), становятся возможными отказы при подключении или повреждение базы данных.

К файлам данных Exchange относятся следующие файлы:

  • EDB-файлы,

  • STM-файлы,

  • LOG-файлы,

  • DAT-файлы,

  • EML-файлы,

  • CHK-файлы.

Файлы, управляемые модулем расширяемого хранилища (Extensible Storage Engine, ESE), не предназначены для хранения на сжатом диске. Работа модуля расширяемого хранилища определяется независимостью секторов для восстановления на основе журнала, а сжатие файлов нарушает независимость секторов. Сжатие не должно включаться для томов, на которых размещаются базы данных модуля расширяемого хранилища или любые базы, использующие упреждающую регистрацию в журнале.

До появления пакета обновления 3 (SP3) Exchange 2000 Server разрешалось подключение сжатых баз данных банка данных. Однако в любых журналах банка данных и базах данных банка данных Exchange 2000 Server, сжатых с помощью NTFS-сжатия, могут возникать повреждения.

Если установлен пакет обновления 3 (SP3) Exchange 2000 Server, сжатые файлы базы данных банка данных размером 128 МБ или меньше автоматически разворачиваются. Когда размер файлов базы данных становится больше 128 МБ, база данных не подключается, и в журнал приложений записываются сообщения об ошибках. Пакет обновления 3 (SP3) Exchange 2000 Server предотвращает подключение сжатых баз данных, размер которых превышает 128 МБ.

Чтобы выключить сжатие файлов для заданной папки

  1. Щелкните правой кнопкой мыши папку, для которой хотите выключить сжатие файлов, и в контекстном меню выберите пункт Свойства.

  2. На вкладке Общие щелкните Дополнительно.

  3. В диалоговом окне Дополнительные атрибуты снимите флажок Сжимать содержимое для экономии места на диске и нажмите кнопку OK.

Чтобы переместить файлы базы данных в Exchange 2000 Server или Exchange Server 2003

  1. Откройте системный диспетчер Exchange.

  2. Разверните узел Административные группы, разверните административную группу, разверните узел Серверы, разверните узел сервера, разверните группу хранения, щелкните правой кнопкой мыши Хранилище почтовых ящиков и выберите в контекстном меню пункт Свойства.

  3. На вкладке База данных в разделе База данных Exchange или Потоковая база данных Exchange щелкните Обзор, введите путь к папке, где сжатие не включено, и нажмите кнопку OK.

  4. Нажмите кнопку OK или Применить, чтобы применить изменения, а затем щелкните Да в окне предупреждения.

    После нажатия кнопки Да хранилища (базы данных) отключаются, перемещаются и снова подключаются. После успешного завершения этих процедур выводится следующее информационное сообщение:

    Файлы базы данных успешно перемещены

Изменение расположения файлов базы данных группы хранения Exchange на сервере Exchange Server 2007

  1. Следуйте указаниям раздела «How to Move a Storage Group Path» (Как изменить путь группы хранения) основной документации Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkID=80747).

Дополнительные сведения о STM- и EDB-файлах см. в базе знаний Майкрософт в статье 232323 «Native Content Storage in Microsoft Exchange» (Собственное хранилище содержимого в Microsoft Exchange) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323).


Файлы базы данных Exchange записываются в раздел, который имеет формат, отличный от NTFS
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Анализатор Microsoft® Exchange запрашивает класс инструментария управления Windows (WMI) Win32_Directory, чтобы определить значение ключа FSName для пути к файлу базы данных Exchange. Если анализатор сервера Exchange обнаруживает, что значение параметра FSName не равно NTFS File System, выводится сообщение об ошибке.

Корпорация Майкрософт не поддерживает хранение файлов данных Exchange в томах, которые отформатированы в файловой системе, отличной от NTFS. К файлам данных Exchange относятся все следующие файлы:

  • EDB-файлы

  • STM-файлы

  • LOG-файлы

  • DAT-файлы

  • CHK-файлы

  • EML-файлы

При возникновении этой ошибки необходимо переместить файлы базы данных в папку на диске с форматом NTFS. Если же диск, на котором хранятся файлы базы данных, имеет формат FAT, можно преобразовать этот диск в формат NTFS с помощью средства командной строки convert.exe.

Для перемещения файлов баз данных Exchange 2000 Server или Exchange Server 2003 выполните следующие действия.

  1. Откройте диспетчер Exchange.

  2. Разверните узел Административные группы, разверните административную группу, разверните узел Серверы, разверните узел сервера, разверните группу хранения, щелкните правой кнопкой мыши Хранилище почтовых ящиков и в контекстном меню выберите пункт Свойства.

  3. На вкладке База данных в разделе База данных Exchange или Потоковая база данных Exchange нажмите кнопку Обзор, введите путь к папке на томе NTFS и нажмите кнопку ОК.

  4. Нажмите кнопку ОК или Применить, чтобы применить изменения, или нажмите Отмена, если не хотите применять изменения.

  5. При нажатии кнопки ОК или Применить выводится следующее предупреждающее сообщение:

    Примечание. Будут выполнены следующие операции:

    • изменение местоположения базы данных Exchange;

    • изменение местоположения потоковой базы данных Exchange.

    Для выполнения запрошенных операций хранилище должно быть временно отключено, что сделает его недоступным для пользователей.

    Продолжить?

    Примечание.
    В предупреждающем сообщении перечисляются только выбранные операции. В окне предупреждающего сообщения имеются кнопки «Да» и «Нет».

  6. Нажмите кнопку Да, если готовы продолжить, в противном случае нажмите Нет.

  7. После нажатия кнопки Да хранилища (базы данных) отключаются, перемещаются и снова подключаются. После успешного завершения этих процедур выводится следующее информационное сообщение:

    Файлы базы данных успешно перемещены

Для перемещения расположения группы хранения баз данных Exchange Server 2007 выполните следующие действия.

  1. Следуйте указаниям раздела «How to Move a Storage Group Path» (Как изменить путь группы хранения) документации Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkID=80747).

Если диск, на котором хранится каталог файлов журнала транзакций, имеет формат FAT, помимо выполнения вышеизложенной процедуры можно преобразовать этот диск в формат NTFS с помощью средства командной строки convert.exe. Сведения о преобразовании раздела FAT в раздел NTFS с помощью средства командной строки convert.exe см. в статье 214579 базы знаний Майкрософт «How to Use Convert.exe to Convert a Partition to the NTFS File System» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=214579) (Инструкции преобразованию раздела в файловую систему NTFS с помощью средства Convert.exe).


Файлы базы данных Exchange записываются в зашифрованную папку
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Directory, чтобы определить значение ключа Encrypted для папки, которая содержит файлы базы данных банка данных Microsoft Exchange. Если анализатор сервера Exchange обнаруживает, что для ключа Encrypted установлено значение True, выводится сообщение об ошибке.

На компьютере с Exchange 2000 Server или Exchange Server 2003 файлы базы данных по умолчанию записываются в следующее местоположение:

<диск> :\Program Files\Exchsrvr\mdbdata

На сервере Exchange Server 2007 файлы базы данных по умолчанию сохраняются в следующей папке:

<диск> :\Program Files\Microsoft\Exchange Server\Mailbox\<имя_группы_хранения>

Microsoft не поддерживает хранение файлов данных Exchange на томе с шифрованной файловой системой (EFS). При хранении файлов данных Exchange на зашифрованном томе дополнительные накладные расходы существенно замедляют производительность сервера Exchange. К файлам данных Exchange относятся все следующие файлы:

  • EDB-файлы

  • STM-файлы

  • LOG-файлы

  • DAT-файлы

  • EML-файлы

  • CHK-файлы

В целях обеспечения безопасности файлов данных Exchange рекомендуется запретить неавторизованный доступ к компьютеру Exchange и использовать для шифрования данных сообщения формат S/MIME.

Чтобы устранить данную ошибку, необходимо отключить шифрование для папки, в которую записываются файлы базы данных, или переместить эти файлы базы данных в папку, для которой шифрование отключено.

Чтобы отключить шифрование файлов для указанной папки

  1. Щелкните правой кнопкой мыши папку, для которой нужно отключить шифрование файлов, и выберите команду Свойства.

  2. На вкладке Общие щелкните Дополнительно.

  3. В диалоговом окне Дополнительные атрибуты снимите флажок Шифровать содержимое для обеспечения безопасности данных, а затем нажмите кнопку ОК.

Чтобы переместить файлы базы данных в Exchange 2000 Server или Exchange Server 2003

  1. Откройте диспетчер Exchange

  2. Разверните узел Административные группы, разверните административную группу, разверните узел Серверы, разверните узел сервера, разверните группу хранения, щелкните правой кнопкой мыши Хранилище почтовых ящиков и выберите в контекстном меню пункт Свойства.

  3. На вкладке База данных в разделе База данных Exchange или Потоковая база данных Exchange нажмите кнопку Обзор введите путь к папке, где сжатие не включено, а затем нажмите кнопку ОК.

  4. Нажмите кнопку ОК или Применить, чтобы применить изменения, а затем щелкните Да в окне предупреждения.

  5. После нажатия кнопки Да хранилища (базы данных) будут отключены, перемещены и снова подключены. После завершения этих процедур выводится следующее сообщение:

    Файлы базы данных успешно перемещены

Чтобы переместить расположение группы хранения баз данных Exchange Server 2007, выполните следующие действия.

  1. Следуйте указаниям в документации Exchange Server 2007 в статье «How to Move a Storage Group Path» (http://go.microsoft.com/fwlink/?LinkID=80747)

Дополнительные сведения о перемещении файлов базы данных см. в статье 821915 базы знаний Майкрософт «How to Move Exchange Databases and Logs in Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915) (Инструкции по перемещению баз данных и журналов в Exchange Server 2003).

Дополнительные сведения о файлах данных сервера Exchange и шифрованной файловой системе см. в статье 834638 базы знаний «Information about the storage of data files on an encrypted volume in Exchange Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638) (Сведения о хранении файлов данных на зашифрованном томе в Exchange Server).

Сведения об обеспечении безопасности сообщений в Microsoft Exchange Server 2003 см. в руководстве Exchange Server 2003 Message Security Guide (http://go.microsoft.com/fwlink/?linkid=47574) (Руководство по безопасности сообщений в Exchange Server 2003).


База данных Exchange находится в состоянии некорректного завершения
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2006-10-30

Средство анализатора сервера Microsoft® Exchange обнаружило, что работа одной из баз данных не была завершена корректно. Таким образом, файлы базы данных все еще присоединены к файлам журнала.

Состояние некорректного завершения не означает, что база данных повреждена. Это состояние указывает только на то, что файлы базы данных не были корректно отсоединены от потока журнала. Таким образом, необходимо восстановить файлы базы данных прежде, чем можно будет вновь ее запустить.

При следующем подключении базы данных процедура восстановления запускается автоматически. В случае сбоя процедуры автоматического восстановления можно воспользоваться средством анализа аварийного восстановления сервера Microsoft Exchange для выяснения причин сбоя. После выполнения анализа средство анализа аварийного восстановления сервера Exchange предоставит рекомендации по восстановлению файлов базы данных вручную.

Чтобы устранить эту ошибку

  • Переведите базу данных в состояние чистого отключения путем воспроизведения требуемых файлов журналов транзакций в базу данных. Для воспроизведения файлов журналов выполните подключение базы данных. В случае сбоя данной процедуры воспользуйтесь средством анализа аварийного восстановления сервера Exchange для выяснения причин сбоя.

Дополнительные сведения об анализаторе аварийного восстановления сервера Exchange Server см. в статье 922247, «Описание анализатора аварийного восстановления серверов Microsoft Exchange Server применительно к серверу Exchange Server 2003», базы знаний Майкрософт по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=922247 (эта ссылка может указывать на содержимое полностью или частично на английском языке).


Для времени оперативного обслуживания базы данных Exchange установлено значение «Никогда»
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-05

Анализатор рекомендаций Microsoft® Exchange Server запрашивает службу каталога Active Directory®, чтобы определить значение для атрибута activationSchedule хранилищ почтовых ящиков и общих хранилищ. Если анализатор Exchange Server обнаруживает, что для параметра activationSchedule установлено значение «Никогда», отображается предупреждение.

Свойство activationSchedule представляет параметры расписания обслуживания базы данных в интерактивном режиме. Оперативное обслуживание в Exchange Server очень важно. В течение этого интервала выполняются такие задания, как очистка мусорной корзины (удаление сообщений, срок хранения которых подошел к концу), истечение срока общих папок (сообщения в общих папках, которые старше определенной даты), очистка удаленных почтовых ящиков и оперативная дефрагментация (объекты базы данных, которые больше не используются, определяются и удаляются, таким образом освобождается дополнительное место, которое используется базой данных). Эти операции поддерживают исправность и работоспособность компьютера под управлением Exchange Server стабильными. Обслуживание в интерактивном режиме должно проводиться не менее четырех часов в день; в противном случае, с течением времени возникнет снижение производительности.

Рекомендуется установить проведение оперативного обслуживания для каждой базы данных (хранилища почтовых ящиков и хранилища общих папок) в течение четырех часов каждый день. Сочетайте в расписании интервалы оперативного обслуживания с резервным копированием. Например, если резервное копирование выполняется с полуночи до 2.00, запустите обслуживание в интерактивном режиме с 3.00 до 7.00.

Это важно, поскольку обслуживание в интерактивном режиме не начнется, если будет выполняться сеанс резервного копирования. В случае перекрывания времени проведения этих процедур резервное копирование имеет приоритет перед оперативным обслуживанием. В этом случае каждые 15 минут Exchange проверяет, не завершилось ли резервное копирование. После завершения резервного копирования будет запущена процедура оперативного обслуживания.

В хранилище в ходе обслуживания выполняются 18 задач. Когда задача запущена, она выполняется до конца независимо от временного окна обслуживания. Однако обслуживание не начнет выполнять новую задачу, если время, отведенное на это, истекло. Таким образом, в некоторых случаях не все задачи завершаются в установленный для обслуживания интервал времени. Если обслуживание прервано, оно продолжается с этого же момента в следующий цикл обслуживания.

Включение обслуживания базы данных в интерактивном режиме для Exchange 2000 Server и Exchange Server 2003

  1. Откройте системный диспетчер Exchange.

  2. Разверните пункт Серверы, затем разверните сервер, с которым хотите работать.

  3. Разверните группу хранилищ, с которой хотите работать.

  4. В области сведений в списке доступных хранилищ данных откройте щелчком правой кнопки мыши то хранилище, с которым предполагается работать, и нажмите кнопку Свойства.

  5. В диалоговом окне Свойства хранилища откройте вкладку База данных.

  6. Выполните одно из следующих действий:

    • Выберите интервал в списке интервалов Обслуживание.

    • Нажмите кнопку Настроить, чтобы получить доступ к диалоговому окну Расписание, и создайте пользовательский интервал.

  7. Нажмите OK.

Устранение причин появления этого предупреждения на сервере Windows Server 2007

  1. Откройте консоль управления Exchange

  2. Разверните пункт Конфигурация сервера и затем выберите сервер, с которым хотите работать.

  3. Разверните группу хранилищ, с которой хотите работать.

  4. Щелкните правой кнопкой нужное хранилище и в контекстном меню выберите Свойства.

  5. На вкладке Общие щелкните раскрывающийся список Расписание обслуживания и выберите интервал или щелкните Настроить, чтобы создать пользовательское расписание.

Для получения дополнительных сведений о задачах, выполняемых оперативным обслуживанием, см. статью 159196 базы знаний корпорации Майкрософт, «XADM: Tasks Controlled by the IS Maintenance Schedule» (Задачи, управляемые расписанием обслуживания банка данных) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159196).


Служба Exchange Information Store не настроена на работу как LocalSystem
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-02-27

Средство анализа Microsoft® Exchange Server запрашивает класс Win32_Services инструментария Microsoft Windows Management Instrumentation (WMI), чтобы определить, использует ли учетная запись запуска, указанная в свойстве StartName службы Microsoft Exchange Information Store (MSExchangeIS), учетную запись LocalSystem. Если анализатор Exchange Server обнаруживает значение этого параметра для компьютера с Exchange 2000 Server, Exchange Server 2003 или Exchange Server 2007 отличное от LocalSystem (также известное как учетная запись SYSTEM), отображается предупреждение. Предупреждение не включается для компьютеров с Exchange Server 5.5, когда служба Microsoft Exchange Information Store ожидается и запускается под учетной записью пользователя.

Exchange 2000 Server, Exchange Server 2003 и Exchange Server 2007 должны запускаться под контекстом безопасности LocalSystem вместо конкретной учетной записи пользователя (и пароля) для запуска этих служб. Это гарантирует, что смена пароля или удаление учетной записи пользователя не повлияет на функциональность Exchange. Когда служба Exchange, запущенная как LocalSystem, подключается к удаленному серверу, Microsoft Windows 2000 Server или Windows Server 2003 проверяют ее подлинность по учетной записи компьютера.

Пароль учетной записи компьютера меняется каждые семь дней, используя стандартный механизм смены пароля. Это помогает делать учетную запись компьютера более безопасной, чем обычная учетная запись пользователя, где пароль меняется не так часто и менее случаен, чем создаваемый пароль учетной записи компьютера.

Некоторые администраторы, работавшие с Exchange Server 5.5, где для этой службы использовалась учетная запись пользователя, меняют стартовую учетную запись служб сервера Exchange 2000 Server, Exchange Server 2003 и Exchange Server 2007 с учетной записи по умолчанию LocalSystem на пользовательскую.

Для Exchange 2000 Server, Exchange Server 2003 и Exchange Server 2007 Майкрософт не поддерживает запуск службы банка данных Microsoft Exchange под любой учетной записью, отличной от LocalSystem.

Устранение этой ошибки

  1. Нажмите «Пуск», «Программы», «Администрирование» и выберите «Службы».

  2. В списке служб щелкните правой кнопкой мыши Microsoft Exchange Information Store, а затем выберите Свойства.

  3. На вкладке Вход в систему под заголовком Вход в систему выберите С системной учетной записью и затем нажмите кнопку OK.

  4. Щелкните правой кнопкой мыши Microsoft Exchange Information Store, затем выберите Перезапуск.

Дополнительные сведения о службах Exchange см. в статье 239762 базы знаний Майкрософт «Службы Exchange выполняются в контексте учетной записи локальной системы» по адресу http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762 (на английском языке).


Служба банка данных Exchange не работает
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-05

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Service, чтобы определить, установлено ли значение для разделаStarted в службе банка данных Microsoft Exchange равным True (Истина) или False (Ложь).

Значение False показывает, что служба банка данных Microsoft Exchange на сервере Exchange не работает. Значение True показывает, что служба банка данных Microsoft Exchange работает.

Анализатор сервера Exchange также проверяет WMI-класс Exchange_Server в пространстве имен root\MicrosoftExchangeV2, чтобы определить значение раздела IsFrontEndServer. Значение False показывает, что сервер Exchange не является сервером переднего плана. Значение True указывает, что компьютер сервера Exchange является сервером переднего плана Exchange Server 2003 или Exchange 2000 Server.

Если значения обоих проверяемых параметров равны False в Exchange 2000 Server и Exchange Server 2003, отображается предупреждение.

Если значение «False» возвращается для параметра Win32_Service Started, а на сервере Exchange Server используется Exchange Server 2007, отображается предупреждение.

Если попытка запустить службу банка данных Microsoft Exchange оканчивается неудачей, это может указывать на более серьезную проблему на данном сервере Exchange. В этом случае следует посмотреть в журналах событий подробные данные о сбое. Необходимо также убедиться, что в вашей версии сервера Exchange используется последний пакет обновления.

Последнюю версию пакета обновления для Exchange Server 2003 можно загрузить на странице «Downloads for Exchange Server 2003» по адресу http://go.microsoft.com/fwlink/?LinkId=25097.

Дополнительные сведения об известных причинах сбоев в работе службы банка данных Microsoft Exchange см. в следующих статьях базы знаний Майкрософт:

  • 827915, «The Information Store service may stop unexpectedly while converting a message that does not contain the PR_MESSAGE_CLASS property in Exchange 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827915) (При преобразовании сообщения, которое не содержит свойства PR_MESSAGE_CLASS в Exchange 2003, может произойти неожиданная остановка службы банка данных)

  • 830602, «Exchange Server 2003 Information Store service stops responding» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=830602) (Служба банка данных Exchange Server 2003 не отвечает на запросы)

  • 839115, «The Information Store service does not start after you upgrade to Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839115) (После обновления до Exchange Server 2003 не запускается служба банка данных)

  • 330197, «The Information Store service stops unexpectedly when a message with a null Internet message ID is delivered locally» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=330197) (При локальной доставке сообщения из Интернета с нулевым заголовком происходит неожиданная остановка службы банка данных)

  • 831130, «The Folders pane does not appear or the Information Store service quits unexpectedly when you use OWA to access your mailbox on your Exchange Server 2003 computer» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=831130) (При использовании OWA для доступа к почтовому ящику на компьютере Exchange Server 2003 не появляется панель «Папки» или происходит неожиданная остановка службы банка данных)

  • 823163, «Setup Cannot Locate a Qualifying Global Catalog Server' Error Message When You Try to Start the Information Store Service» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823163) (При попытке запуска службы банка данных выводится сообщение об ошибке «Setup Cannot Locate a Qualifying Global Catalog Server»)

  • 822579, «Event ID 7024 After You Install Exchange Server 2003, and Exchange Information Store Service Does Not Start» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822579) (После установки Exchange Server 2003 возникает событие 7024 и служба банка данных Exchange не запускается)

  • 833841, «The Microsoft Exchange Information Store service unexpectedly stops responding» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833841) (Служба банка данных Microsoft Exchange неожиданно перестает отвечать на запросы)

Дополнительные сведения об использовании серверов переднего плана Exchange Server 2003 и Exchange 2000 Server см. на следующих веб-узлах (на английском языке):

  • Using Microsoft Exchange 2000 Front-End Servers (http://go.microsoft.com/fwlink/?linkid=12055)

  • Exchange Server 2003 and Exchange 2000 Server Front-End and Back-End Topology (http://go.microsoft.com/fwlink/?linkid=47567)


На сервере переднего плана не выполняется служба «Банк данных Microsoft Exchange»
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Service, чтобы определить значения, заданные для ключа Started служб «Банк данных Microsoft Exchange» и SMTP (Simple Message Transfer Protocol). Значение False указывает, что служба не выполняется. Значение True указывает, что служба выполняется.

Анализатор сервера Exchange также проверяет WMI-класс Exchange_Server в пространстве имен root\MicrosoftExchangeV2 для определения значения ключа IsFrontEndServer. Значение False указывает, что компьютер с Exchange Server не является сервером переднего плана. Значение True указывает, что компьютер с Exchange Server является сервером переднего плана.

Если анализатор сервера Exchange определяет, что параметр Started службы SMTP имеет значение «True», параметр Started службы «Банк данных Microsoft Exchange» имеет значение False, а параметр IsFrontEndServer имеет значение True, то отображается данное предупреждение.

Exchange 2000 Server и Exchange Server 2003 используют серверы переднего плана в качестве прокси-серверов для обработки запросов клиентов POP3, IMAP4 и веб-клиента Microsoft Office Outlook®. Кроме того, они могут использоваться в качестве SMTP-серверов с выходом в Интернет. Если сервер переднего плана принимает и переправляет SMTP-сообщения, обеспечивает поддержку IMAP-клиентов (использующих протокол SMTP для отправки сообщений) или если на нем выполняется VSAPI-совместимое (Virus Scan API) программное обеспечение, то должна выполняться служба «Банк данных Microsoft Exchange». В противном случае сервер переднего плана не сможет обрабатывать SMTP-сообщения или сканировать сообщения с помощью VSAPI.

Если на сервере переднего плана не выполняется SMTP- или VSAPI-совместимое антивирусное программное обеспечение, то рекомендуется отключить и удалить все хранилища общих папок, остановить службу «Банк данных Microsoft Exchange», а затем отключить ее. Кроме того, следует остановить службу SMTP, если она не используется. На компьютерах под управлением Exchange Server с установленным SMTP- или VSAPI-совместимым программным обеспечением должна выполняться служба «Банк данных Microsoft Exchange» для доставки сообщений и обслуживания клиентов системы обмена сообщениями.

Чтобы устранить причину появления этого предупреждения

  1. Откройте оснастку «Службы» консоли MMC.

  2. Щелкните правой кнопкой мыши службу Банк данных Microsoft Exchange и выберите в контекстном меню команду Свойства.

  3. Убедитесь, что на вкладке Общие страницы свойств Банк данных Microsoft Exchange для параметра Тип запуска задано значение «Авто». Если установлено другое значение, выберите значение «Авто», нажмите кнопку Применить, а затем кнопку ОК.

  4. Щелкните правой кнопкой мыши службу Банк данных Microsoft Exchange и выберите в контекстном меню команду Запустить.

  5. Закройте оснастку «Службы».

Если запустить службу «Банк данных Microsoft Exchange» не удается, возможно, на компьютере под управлением Exchange Server присутствует более серьезная проблема. В этом случае следует изучить журнал событий для получения сведений о данном сбое. Также следуют убедиться, что для данной версии Exchange Server установлена новейшая версия пакета обновления. Новейший пакет обновления для Exchange Server доступен на домашней странице Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=21573).

Дополнительные сведения о возможных причинах сбоя службы «Банк данных Microsoft Exchange» см. в следующих статьях базы знаний Майкрософт:

  • 827915, описывающей неожиданную остановку службы «Банк данных Microsoft Exchange» при преобразовании сообщения, не содержащего свойства PR_MESSAGE_CLASS в Exchange 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827915)

  • 830602, описывающей зависание службы банка данных Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=830602)

  • 839115, описывающей сбой запуска службы банка данных после обновления до Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839115)

  • 330197, описывающей неожиданную остановку службы банка данных при локальной доставке сообщения с нулевым идентификатором сообщения Интернета (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=330197)

  • 831130, описывающей ситуацию, при которой область папок не отображается или служба банка данных неожиданно завершает свою работу в случае использования OWA для доступа к почтовому ящику на компьютере с Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=831130)

  • 823163, описывающей ошибку, когда программе установки не удается найти необходимый сервер глобального каталога при попытке запуска службы банка данных (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823163)

  • 822579, описывающей событие 7024: после установки Exchange Server 2003 служба банка данных Exchange не запускается (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822579)

  • 833841, описывающей неожиданное зависание службы «Банк данных Microsoft Exchange» (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833841)

Дополнительные сведения об использовании серверов переднего плана см. в руководстве по топологии серверов переднего плана и фоновых серверов на базе Exchange Server 2003 и Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=47567).


Подключен диск с устанавливаемой файловой системой Exchange
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2006-02-28

Анализатор сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить, включено ли сопоставление буквы диска с устанавливаемой файловой системой Exchange (ExIFS или IFS):

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

Если анализатор сервера Exchange обнаруживает, что параметр реестра DriveLetter содержит букву диска (например M), выводится сообщение об ошибке.

В Exchange 2000 Server внедрена возможность с названием IFS. IFS представляет собой драйвер уровня ядра, который помещает некоторые данные банков данных Exchange в файловой системе Microsoft Windows®. На новых установках Exchange 2000 Server и при обновлении до Exchange 2000 Server с Exchange Server 5.5 автоматически устанавливается система IFS, а также присваивается буква диска (по умолчанию это диск M), которая сопоставляется с банком данных. Эти действия выполняются с использованием пространства имен \\.\BackOfficeStorage\.

В Exchange Server 2003 реализована поддержка системы IFS, однако сопоставление буквы диска по умолчанию отключено. Параметр DriveLetter отсутствует в новых установках Exchange Server 2003, а при обновлении с Exchange 2000 Server до Exchange Server 2003 данные этого параметра реестра удаляются, что отменяет сопоставление буквы диска.

Рекомендуется не включать сопоставление буквы диска IFS в Exchange Server 2003 и отключить это сопоставление в Exchange 2000 Server. Существует ряд неполадок, которые могут возникнуть при получении доступа к диску с буквой, сопоставленной IFS, или сканировании этого диска антивирусными или файловыми приложениями. Поэтому рекомендуется удалить сопоставление буквы диска, если возможность IFS не используется в текущий момент.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы устранить эту ошибку

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра:

    HKLM\System\CurrentControlSet\Services\EXIFS\Parameters

  3. В правой области дважды щелкните параметр DriveLetter.

  4. В поле Значение удалите букву, чтобы это поле осталось пустым.

  5. Закройте редактор реестра, а затем перезапустите службу системного помощника Microsoft Exchange и службу публикации в Интернете, чтобы изменения вступили в силу. При перезапуске службы системного помощника будет также выполнен перезапуск всех служб, которые основаны на службе системного помощника, в том числе службы стеков агента передачи сообщений Microsoft Exchange и службы банка данных Microsoft Exchange.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения об удалении сопоставления диска M в Exchange 2000 Server см. в статье 305145 базы знаний «How to remove the IFS mapping for Drive M in Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=305145) (Инструкции по удалению сопоставления IFS для диска M в Exchange 2000 Server).

Дополнительные сведения об добавлении сопоставления диска M в Exchange 2003 Server см. в статье 821836 базы знаний «Drive M Mapping to IFS Is Not Present by Default in Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=305145) (Сопоставление диска M с IFS в Exchange Server 2003 по умолчанию отключено).


Настройка сервера Exchange Server и его производительность
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2006-09-06

Средство анализатора Microsoft® Exchange определило, что сервер Exchange не настроен на оптимальную производительность.

В процессе обычной работы сервер Exchange обращается к различным файлам. Расположение файлов может стать фактором, лимитирующим производительность. Группы взаимозависимых файлов, например диски журналов транзакций, также называются ресурсами.

Если расположение ресурсов приводит к тому, что дисковые операции лимитируют производительность, анализатор сервера Exchange может вывести предупреждение или сообщение об ошибке, связанной с расположением ресурсов на сервере Exchange. Чтобы гарантированно изолировать ресурсы от других файлов, которые требуют загрузки, поместите ресурсы на выделенное устройство хранения. Далее для каждого ресурса приводятся сведения по его использованию и рекомендации по его настройке.

  • Диски журналов транзакций. Файлы журналов транзакций служат для поддержания должного состояния и целостности EDB- и STM-файлов. Это означает, что файлы журналов по существу представляют данные. Для каждой группы хранения предусмотрен файл журнала транзакций. Поскольку журналы транзакций являются критическим компонентом резервного копирования для данных, хранящихся в файлах баз данных сервера Exchange, все данные должны фиксироваться в файле журнала, до того как будут завершено большинство транзакций. Любые задержки в записи на диск журналов транзакций могут сильно повлиять на производительность сервера. Поэтому важно изолировать диски журналов транзакций, чтобы у этих дисков была своя дисковая подсистема, отдельная от любых других серверов, приложений или ресурсов. Для обеспечения наивысшей производительности для каждого журнала транзакций выделите отдельный диск.

  • Расположение диска TEMP. При первой установке операционная система задает расположение временных файлов на том же самом диске, который используется операционной системой. Это означает, что при выполнении любых операций ввода-вывода на диск TEMP они конкурируют с операциями ввода-вывода программ и файла подкачки, которые выполняются на том же диске. Эта конкуренция при выполнении ввода-вывода влияет на производительность. Диск TEMP используется для доставки почты и для преобразования содержимого больших сообщений. Если диск TEMP становится лимитирующим фактором, это влияет на поток почты и некоторые клиентские приложения. Чтобы исключить конкуренцию операционной системы с диском TEMP при выполнении операций ввода-вывода и снизить риск неполадок в работе сервера Exchange, связанных со снижением производительности, рекомендуется выполнить следующие действия:

    • Измените значение глобального параметра среды TEMP, указав другой диск.

    • Переместите диск TEMP на его собственный диск.

  • Расположение EDB- и STM-файлов. База данных Exchange состоит из двух файлов:

    • EDB-файл (MAPI-содержимое). В этом файле хранятся все MAPI-сообщения и таблицы, используемые процессом Store.exe для поиска всех сообщений и контрольных сумм как EDB- и STM-файлов, так и MAPI-сообщений.

    • STM-файл (содержимое, не относящееся к MAPI). Этот файл содержит сообщения, которые передаются со своим собственным Интернет-содержимым.

    Поскольку для файлов обоих этих типов обычно используется произвольный доступ, все они могут быть помещены на один и тот же дисковый том. Однако важно не помещать EDB- и STM-файлы на тот диск, на котором находятся журналы транзакций. Кроме того, чтобы производительность операций с дисками, на которых содержатся файлы баз данных, не стала лимитирующим фактором, рекомендуется поместить эти файлы на отдельные диски, выделенные для каждой группы хранения.

  • Расположение каталога SMTP. SMTP-очередь хранит SMTP-сообщения до тех пор, пока Exchange не запишет их в базу данных (хранилище почтовых ящиков или хранилище общих папок) или отправит сообщения на другой сервер или соединитель. Обычно SMTP-очереди используют небольшие операции ввода-вывода с произвольным доступом. Анализатор севера Exchange отображает предупреждение, если каталог SMTP находится на диске, который используется также для хранения следующей информации:

    • любых других файлов данных Exchange;

    • каталогов TEMP или TMP;

    • файла подкачки;

    • системного диска.

    Если дисковые операции с каталогом SMTP не являются лимитирующим фактором, это предупреждение можно игнорировать. Однако если интенсивность операций этим диском высока и их выполнение является фактором, лимитирующим производительность, рекомендуется переместить каталог SMTP на отдельный диск или увеличить емкость диска, содержащего каталог SMTP.

  • Расположение файла подкачки. Файл подкачки служит для расширения физической памяти. Точнее, файл подкачки — это место, где система хранит неиспользуемые страницы или страницы, которые потребуются системе позже. Файл подкачки используется всегда, даже если на сервере достаточное количество свободной памяти. Это происходит, потому что операционная система пытается хранить только необходимые страницы и обеспечить достаточно свободного места для выполнения операций. Например, средство печати, которое используется только на начальном этапе, может занять несколько страниц памяти на диске, которые никогда не вернуться обратно, если это средство больше не будет применяться.

    Убедитесь, что на серверах, где интенсивно используется физическая память, все обращения к файлу подкачки выполняются с максимально возможной скоростью. Рекомендуется создать второй файл подкачки на специально выделенном для него диске.

Дополнительные сведения

  • Дополнительные сведения о производительности сервера Exchange см. в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Дополнительные сведения об устранении проблем, связанных с производительностью сервера Exchange, см. на веб-узле, посвященном устранению неполадок, связанных с производительностью сервера Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Дополнительные сведения о рекомендациях по разработке архитектур хранилищ см. в описании общих рекомендаций для нескольких архитектур (http://go.microsoft.com/fwlink/?LinkId=72988).

  • Дополнительные сведения об определении свободного места на диске, задержки и скоростей ввода-вывода см. в разделе Инструкции по расчету требований к системе ввода-вывода диска (http://go.microsoft.com/fwlink/?linkid=69747).


Порт хранилищаTCP/IP Exchange был изменен вручную
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-03-21

Средство анализа сервера Microsoft® Exchange считывает следующий параметр реестра, чтобы определить, было ли значение порта для интерфейса хранилища Exchange переопределено вручную:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Если анализатор рекомендаций Exchange Server обнаружит, что TCP/IP Port существует и настроен, последует сообщение, что настройка отличается от настройки по умолчанию.

Самая распространенная причина настройки этого значения - возможность клиентов MAPI подключаться к серверу Exchange Server, который находится с другой стороны брандмауэра. Этот сценарий включает в себя открытие нескольких портов в брандмауэре, чтобы дать возможность клиентам Microsoft Office Outlook® 2003 или Outlook 2007 подключаться к серверу Exchange Server, используя MAPI, как правило через Интернет. Это поддерживаемая конфигурация. Дополнительные сведения о настройке клиентов MAPI для подключения к Exchange через брандмауэр см. в статье 270836 базы знаний Майкрософт "Exchange 2000 and Exchange 2003 Static Port Mappings" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836) (Сопоставление статических портов в Exchange 2000 и Exchange 2003). Однако если такой сценарий не используется, необходимо удалить этот раздел реестра.

Чтобы использовать Outlook в режиме MAPI для подключения к серверу Exchange Server через Интернет, рекомендуется настроить удаленный вызов процедур (RPC) для работы по протоколу HTTP. Эта возможность поддерживается в Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003, Exchange Server 2007, Outlook 2007 и Microsoft Windows® XP Professional. Режим MAPI ранее назывался "Корпоративным" или режимом "Рабочей группы".

Важно!
Эта статья содержит сведения о редактировании реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неполадки. Для получения сведений о восстановлении реестра см. раздел справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы удалить раздел реестра порта TCP/IP

  1. Откройте редактор реестра, такой как Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Удалите значение реестра TCP/IP Port.

  4. Закройте редактор реестра и перезапустите службу информационного хранилища Microsoft Exchange.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986 "Описание реестра Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Чтобы развернуть RPC поверх HTTPS

  1. Ознакомьтесь с документом «Сценарии развертывания RPC через HTTP для Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=47577) (на английском языке).

  2. Ознакомьтесь со статьей 833401 базы знаний Майкрософт "Настройка удаленного вызова процедур (RPC) для работы по протоколу HTTP при использовании одного сервера Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  3. Ознакомьтесь со статьей 827330 базы знаний Майкрософт "Устранение неполадок, возникающих в Office Outlook 2003 при использовании подключений RPC по протоколу HTTP" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  4. Ознакомьтесь с записью веб-трансляции службы поддержки корпорации Майкрософт "Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134) (Использование Microsoft Exchange через Интернет (RPC/HTTP) с Microsoft Office Outlook 2003).


Значение порта TCP/IP хранилища Exchange ниже 5000
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2006-01-11

Чтобы определить значение параметра TCP/IP Port для хранилища Exchange, средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Если анализатор сервера Exchange находит, что значение TCP/IP Port меньше 5000 (десятичное), отображается предупреждение.

Если необходимо задать постоянное значение для параметра TCP/IP Port, рекомендуется установить значение, равное или превышающее 5000. Если установлено значение ниже 5000, это может привести к прекращению прослушивания этого порта сервером Exchange. Сервер Exchange будет пребывать в таком состоянии до перезапуска службы (перезапускаемая служба зависит от жестко закодированного компонента Exchange).

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы установить значение раздела реестра для порта TCP/IP

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Дважды щелкните раздел TCP/IP Port и установите в поле Значение целочисленное значение, превышающее 5000 (десятичное).

  4. Закройте редактор реестра.

  5. Перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о настройке портов см. в статье 270836 базы знаний Майкрософт, посвященной статическим сопоставлениям портов в сервере Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836).


Файлы журнала транзакций Exchange записываются в раздел, который имеет формат, отличный от NTFS
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-02-27

Сообщение об ошибке

Введение

Средство анализа Microsoft Exchange запрашивает класс инструментария управления Windows (WMI) Win32_Directory, чтобы определить значение ключа FSName для пути к файлу журнала транзакций Exchange. Если анализатор сервера Exchange обнаруживает, что значение ключа FSName не равно NTFS, выводится сообщение об ошибке.

Корпорация Майкрософт не поддерживает хранение файлов данных Exchange в томах, которые отформатированы в файловой системе, отличной от NTFS. К файлам данных Exchange относятся все следующие файлы:

  • EDB-файлы

  • STM-файлы

  • LOG-файлы

  • DAT-файлы

  • EML-файлы

При возникновении этой ошибки необходимо переместить файлы журналов в папку на диске с форматом NTFS. Кроме того, если диск, на котором хранится каталог файлов журнала транзакций, имеет формат FAT, можно преобразовать этот диск в формат NTFS с помощью средства командной строки convert.exe.

Перемещение журналов транзакций на серверах Exchange 2000 Server и Exchange Server 2003

  1. Откройте системный диспетчер Exchange.

  2. Последовательно раскройте узел Группы администрирования, нужную группу администрирования и узел Серверы, щелкните правой кнопкой мыши группу хранения и выберите команду Свойства.

  3. На вкладке Общие в разделе Расположение журнала транзакций нажмите кнопку Обзор.

  4. Введите путь к новому расположению файлов журнала и нажмите кнопку ОК.

  5. Нажмите кнопку ОК.

Изменение расположения журналов транзакций группы хранения Exchange Server 2007

  1. Следуйте инструкциям в документации Exchange Server 2007, раздел «Задание или изменение местоположения файлов журнала группы хранения» по адресу http://go.microsoft.com/fwlink/?LinkID=80702 (на английском языке).

Если диск, на котором хранится каталог файлов журнала транзакций, имеет формат FAT, помимо выполнения вышеизложенной процедуры можно преобразовать этот диск в формат NTFS с помощью средства командной строки convert.exe. Сведения о преобразовании раздела FAT в раздел NTFS с помощью средства командной строки convert.exe см. в статье 214579 базы знаний Майкрософт «How to Use Convert.exe to Convert a Partition to the NTFS File System» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=214579) (Инструкции преобразованию раздела в файловую систему NTFS с помощью средства Convert.exe).


Журналы транзакций Exchange записываются в сжатую папку
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-05

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Directory, чтобы определить значение раздела Compressed для папки, содержащей журналы транзакций банка данных Exchange: Если для раздела Compressed задано значение True для этой папки, отобразится сообщение об ошибке.

После доставки сообщения в Exchange, оно записывается в журнал транзакций до того, как будет сохранено в хранилище и доставлено. На компьютере, работающем под управлением Exchange 2000 Server или Exchange Server 2003, журналы транзакций записываются в следующее расположение по умолчанию:

<диск> :\Program Files\Exchsrvr\mdbdata

На сервере Exchange Server 2007 журналы транзакций по умолчанию сохраняются в следующей папке:

<диск> :\Program Files\Microsoft\Exchange Server\Mailbox\<имя_группы_хранения>

Корпорация Майкрософт не поддерживает хранение данных Exchange в сжатых томах NTFS . При сохранении файлов с данными Exchange в сжатый том дополнительная загрузка системы в значительной мере влияет на производительность Exchange. Кроме того, после того как база данных банка данных достигает определенного размера (около 4 ГБ), могут возникнуть проблемы с подключением, также может быть повреждена база.

Файлы данных Exchange включают следующие файлы:

  • файлы с расширением EDB

  • файлы с расширением STM

  • файлы с расширением LOG

  • файлы с расширением DAT

  • файлы с расширением EML

  • файлы с расширением CHK

Файлы, управляемые модулем расширяемого хранилища (ESE), не предназначены для хранения на сжатом диске. Модуль ESE зависит от независимости сектора для восстановления на основе журнала, а сжатие файлов делает недействительной независимость сектора. Не следует использовать сжатие для томов, в которых размещены базы данных ESE или другие базы данных, использующие опережающее ведение журнала.

До появления пакета обновления 3 (SP3) для сервера Exchange 2000 Server было разрешено подключать сжатые базы данных банков данных. Однако в результате этого могут быть повреждены базы данных банков данных Exchange 2000 или журналы банков данных, которые были сжаты с помощью NTFS-сжатия.

С помощью пакета обновления 3 (SP3) для сервера Exchange 2000 Server сжатые файлы баз данных банков данных, размер которых равен 128 МБ или меньше, автоматически распаковываются. Если размер файла базы данных превышает 128 МБ, база данных не подключается, а в журнале приложений создаются сообщения об ошибках. Пакет обновления 3 для Exchange 2000 Server предупреждает возможность подключения сжатых баз данных, размер которых превышает 128 МБ.

Чтобы отключить сжатие для указанной папки

  1. Щелкните правой кнопкой мыши папку, для которой необходимо отключить сжатие файлов, а затем щелкните Свойства.

  2. На вкладке Общие щелкните Дополнительно.

  3. В диалоговом окне Дополнительные атрибуты снимите флажок Сжимать содержимое для экономии места на диске, а затем нажмите кнопку ОК.

Чтобы переместить журналы транзакций на серверы Exchange 2000 Server и Exchange Server 2003

  1. Откройте диспетчер Exchange

  2. Разверните узел Административные группы, откройте административную группу, выберите Серверы, правой кнопкой мыши щелкните группу хранилищ, а затем щелкните Свойства.

  3. На вкладке Общие в группе Местоположение журнала транзакций щелкните Обзор.

  4. Введите путь к новому расположению файла журнала и нажмите кнопку OK.

  5. Нажмите кнопку ОК.

Чтобы изменить расположение журналов транзакций группы хранения Exchange Server 2007, выполните следующие действия.

  1. Следуйте инструкциям в документации Exchange Server 2007 на странице «How to Set or Change the Location of Storage Group Log Files» (http://go.microsoft.com/fwlink/?LinkId=80702).

Дополнительные сведения о перемещении файлов журнала в Exchange Server 2003 см. в базе знаний Майкрософт в статье 821915, описывающей перемещение баз данных и журналов Exchange в Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915).

Дополнительные сведения о перемещении файлов журнала в Exchange Server 2000 см. в базе знаний Майкрософт в статье 239944, описывающей перемещение журналов транзакций или системных журналов в другое расположение (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239944).


Файлы транзакций Exchange записаны в зашифрованную папку
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-02-27

Средство анализа Microsoft Exchange запрашивает WMI-класс (Microsoft Windows Management Instrumentation) Win32_Directory, чтобы определить значение ключа Encrypted для папки, содержащей журналы транзакций банка данных. Если средство анализа Exchange обнаруживает, что для ключа Encrypted установлено значение True, выводится сообщение об ошибке.

Когда в Exchange доставляется сообщение, в первую очередь оно записывается в журналы транзакций, а затем сообщение помещается в хранилище и выполняется его доставка. На компьютерах Exchange 2000 Server и Exchange Server 2003 журналы транзакций по умолчанию записываются в следующее расположение по умолчанию:

<диск> :\Program Files\Exchsrvr\mdbdata

На сервере Exchange Server 2007 журналы транзакций по умолчанию сохраняются в следующей папке:

<диск> :\Program Files\Microsoft\Exchange Server\Mailbox\<имя_группы_хранения>

Microsoft не поддерживает хранение файлов данных Exchange на томе с шифрованной файловой системой (EFS). При хранении файлов данных Exchange на зашифрованном томе дополнительные накладные расходы существенно замедляют производительность сервера Exchange. К файлам данных Exchange относятся все следующие файлы:

  • EDB-файлы

  • STM-файлы

  • LOG-файлы

  • DAT-файлы

  • EML-файлы

  • CHK-файлы

В целях обеспечения безопасности файлов данных Exchange рекомендуется запретить неавторизованный доступ к компьютеру Exchange и использовать для шифрования данных сообщения формат S/MIME.

Чтобы устранить данную ошибку, необходимо отключить шифрование для папки, в которую записываются журналы транзакций, или переместить журналы транзакций в папку, для которой шифрование отключено.

Чтобы отключить шифрование файлов для указанной папки

  1. Щелкните правой кнопкой мыши папку, для которой нужно отключить шифрование файлов, и выберите команду Свойства.

  2. На вкладке Общие щелкните Дополнительно.

  3. В диалоговом окне Дополнительные атрибуты снимите флажок Шифровать содержимое для обеспечения безопасности данных, а затем нажмите кнопку ОК.

Чтобы переместить файлы журнала в Exchange 2000 Server или Exchange Server 2003

  1. Откройте системный диспетчер Exchange.

  2. Последовательно раскройте элемент Группы администрирования, нужную группу администрирования, элемент Серверы, щелкните правой кнопкой мыши нужную группу хранения и выберите команду Свойства.

  3. На вкладке Общие в разделе Местоположение журнала транзакций нажмите кнопку Обзор.

  4. Введите путь к новому местоположению файлов журнала и нажмите кнопку ОК.

  5. Нажмите кнопку ОК.

Изменение расположения журналов транзакций группы хранения Exchange Server 2007

  1. Следуйте инструкциям в документации Exchange Server 2007, раздел «Задание или изменение местоположения файлов журнала группы хранения» по адресу http://go.microsoft.com/fwlink/?LinkID=80702 (на английском языке).

Дополнительные сведения о перемещении файлов журнала см. в статье 821915 базы знаний Майкрософт «How to Move Exchange Databases and Logs in Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915) (Инструкции по перемещению баз данных и журналов в Exchange Server 2003).

Дополнительные сведения о файлах данных сервера Exchange и файловой системе EFS см. в статье 834638 базы знаний Майкрософт «Сведения о хранении файлов данных в зашифрованном томе в Exchange Server» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638 (на английском языке).

Сведения об обеспечении безопасности сообщений в Microsoft Exchange Server 2003 см. в руководстве Exchange Server 2003 Message Security Guide (http://go.microsoft.com/fwlink/?linkid=47574) (Руководство по безопасности сообщений в Exchange Server 2003).


Включены расширенные счетчики производительности ESE
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, содержит ли данный сервер Exchange в своей библиотеке счетчиков расширенные счетчики ESE, анализатор сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ESE\Performance\Show Advanced Counters

Если анализатор сервера Exchange обнаруживает, что параметр реестра Show Advanced Counters имеет значение 1, анализатор сервера Exchange выводит на экран сообщение о том, что текущая конфигурация отличается от заданной по умолчанию.

Анализатор сервера Exchange выводит эти сведения о конфигурации исключительно для сведения. Никаких специальных действий выполнять не требуется.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.
Чтобы отключить расширяемые счетчики производительности ESE

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Удалите значение Показывать расширенные счетчики в разделе реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ESE\Performance.

  3. Закройте редактор реестра.

  4. Перезапустите системный монитор, чтобы применить изменения.

Перед редактированием реестра для получения инструкций о том, как следует выполнить эту процедуру, изучите статью базы знаний Майкрософт 256986 "Description of the Microsoft Windows Registry" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).


Включены расширенные счетчики производительности хранилища
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, существует ли Mdbperfx.dll в библиотеке счетчиков производительности сервера Exchange, средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\Performance

Если анализатор сервера Exchange обнаруживает, что значение «Library» включает строку «mdbperfx.dll», анализатор сервера Exchange выводит на экран сообщение о конфигурации не по умолчанию.

Анализатор сервера Exchange выводит отчет об этой конфигурации только для сведения. Никаких специальных действий выполнять не требуется.

DLL-библиотека Mdbperf.dll содержит набор стандартных счетчиков производительности хранилища. DLL-библиотека Mdbperfx.dll содержит тот же самый стандартный набор счетчиков производительности хранилища, а также расширенный набор счетчиков производительности хранилища.

По умолчанию данные значения «Library» содержат DLL-библиотеку Mdbperf.dll. По умолчанию данные значения «Library» не содержат DLL-библиотеку Mdbperfx.dll. В следующей таблице перечислены расширенные счетчики производительности хранилища, содержащиеся в DLL-библиотеке Mdbperfx.dll.

Счетчик | Назначение
FXGetBufferRopsCalled | Общее количество операций удаленных вызовов процедуры FXGetBuffer
FXGetBufferRopsCalledPerSec | Количество операций удаленных вызовов процедуры FXGetBuffer в секунду
FXGetBufferRopsAcceptedPerSec | Количество принятых операций удаленных вызовов процедуры FXGetBuffer в секунду
FXGetBufferRopsDenied | Общее количество отклоненных операций удаленных вызовов процедуры FXGetBuffer
FXGetBufferRopsDeniedPerSec | Количество отклоненных операций удаленных вызовов процедуры FXGetBuffer в секунду
FXGetBufferCurrentCallerCount | Количество одновременных операций удаленных вызовов процедуры FXGetBuffer
FXGetBufferCurrentUsersExecuting | Количество одновременно выполняемых операций удаленных вызовов процедуры FXGetBuffer
Messages Scanned as MIME | Общее количество сообщений верхнего уровня, обрабатываемых средством поиска вирусов как MIME
Messages Scanned as MIME/sec | Скорость, с которой сообщения верхнего уровня обрабатываются средством поиска вирусов как MIME
Messages Scanned as MAPI | Общее количество сообщений верхнего уровня, обрабатываемых средством поиска вирусов как MAPI
Messages Scanned as MAPI/sec | Скорость, с которой сообщения верхнего уровня обрабатываются средством поиска вирусов как MAPI
Bytes Read | Общее количество байтов, считываемых средством поиска вирусов
Bytes Written | Общее количество байтов, записываемых средством поиска вирусов
Queue Length (Low Priority) | Текущее количество ожидающих низкоприоритетных запросов в очереди поиска вирусов
Threads | Текущее число потоков в пуле, используемых для поиска вирусов. Сюда не входят потоки, используемые для фоновой проверки.
Checks Satisfied by MFT Stamp | Количество проверок на вирусы, подтвержденных штампом в таблице папок с сообщениями
Checks Satisfied by MFT Stamp/sec | Скорость выполнения проверок на вирусы, подтвержденных штампом в таблице папок с сообщениями
Checks Satisfied by Instance Stamp | Количество проверок на вирусы, подтвержденных штампом копии
Checks Satisfied by Instance Stamp/sec | Скорость выполнения проверок на вирусы, подтвержденных штампом копии
Checks Satisfied by Master Instance Stamp/sec | Скорость выполнения проверок на вирусы, подтвержденных штампом главной копии
Checks Not Satisfied | Количество проверок на вирусы, не подтвержденных никаким штампом
Checks Not Satisfied/sec | Скорость выполнения проверок на вирусы, не подтвержденных никаким штампом
Checks Blocked | Количество блокировок обработки в состоянии ожидания завершения поиска вирусов
Checks Blocked/sec | Частота блокировок обработки в состоянии ожидания завершения поиска вирусов
Check Timeouts | Количество случаев истечения времени операций в состоянии ожидания завершения поиска вирусов
Check Timeouts/sec | Частота случаев истечения времени операций в состоянии ожидания завершения поиска вирусов
Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Включение только стандартных счетчиков производительности хранилища

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Найдите значение «Library» в следующем разделе реестра:

    HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\Performance

  3. В меню Правка выберите Изменить.

  4. В поле Значение измените значение с c:\Program Files\Exchsrvr\bin\mdbperfx.dll на c:\Program Files\exchsrvr\bin\mdbperf.dll.

  5. Нажмите кнопку OK и закройте редактор реестра.

  6. Перезапустите Системный монитор, чтобы применить изменения.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт, посвященную описанию реестра Microsoft Windows, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986 (возможно, на английском языке).

Дополнительные сведения о сборе показателей производительности хранилища Exchange см. в статье 821912 базы знаний Майкрософт, посвященной сбору диагностических данных, помогающих устранению проблем банка данных, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=821912 (возможно, на английском языке).


Параметр «FXGetBuffer Backoff Constant» отличается от заданного по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, установлено ли значение FXGetBuffer Backoff Constant, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE \SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Если анализатор сервера Exchange обнаруживает, что для раздела реестра ParametersSystem установлено значение FXGetBuffer Backoff Constant, выводится сообщение о том, что конфигурация отличается от заданной по умолчанию.

С помощью значения FXGetBuffer Backoff Constant можно управлять числом клиентских компьютеров с Microsoft Office Outlook® 2003, которые могут одновременно синхронизироваться с сервером Exchange Server 2003. Значение FXGetBuffer Backoff Constant позволяет указать время ожидания для клиента Outlook, по истечении которого данный клиент предпримет следующую попытку выполнить синхронизацию. Значение по умолчанию параметра FXGetBuffer Backoff Constant — 500 миллисекунд.

Анализатор сервера Exchange выводит эти сведения о конфигурации исключительно для сведения. Никаких специальных действий выполнять не требуется. Однако можно удалить раздел реестра FXGetBuffer Backoff Constant, если нужно восстановить конфигурацию по умолчанию.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.
Чтобы вернуться к конфигурации по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Удалите значение FXGetBuffer Backoff Constant.

  4. Закройте редактор реестра.

Служба банка Microsoft Exchange обнаружит внесенные изменения в течение нескольких минут. Нет необходимость выполнять перезагрузку компьютера.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения о настройке разделов реестра для управления количеством клиентов Outlook, которые могут выполнять синхронизацию с Exchange Server 2003, см. в статье 818484 базы знаний «Registry Values and Counters That You Can Use to Configure and Monitor Outlook Client Synchronization» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484) (Значения реестра и счетчики, с помощью которых можно настраивать синхронизацию клиентов Outlook и отслеживать ее).


Параметр «FXGetBuffer Retry Count» отличается от заданного по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, установлено ли значение FXGetBuffer Retry Count, анализатор сервера Microsoft® Exchange также считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Если анализатор сервера Exchange обнаруживает, что для раздела реестра ParametersSystem создано значение FXGetBuffer Retry Count, выводится сообщение о том, что конфигурация отличается от заданной по умолчанию.

С помощью значения FXGetBuffer Retry Count можно управлять числом клиентских компьютеров с Microsoft Office Outlook® 2003, которые могут одновременно синхронизироваться с сервером Exchange Server 2003. Значение FXGetBuffer Retry Count определяет, сколько попыток выполнить синхронизацию может предпринять клиент Outlook перед тем, как ему будет предоставлен доступ. Значение по умолчанию: 10.

Анализатор сервера Exchange сообщает об изменении в конфигурации только для сведения. Никаких специальных действий выполнять не требуется. Однако можно удалить раздел реестра FXGetBuffer Retry Count, если нужно восстановить конфигурацию по умолчанию.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.
Чтобы вернуться к конфигурации по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Удалите значение FXGetBuffer Retry Count.

  4. Закройте редактор реестра.

Служба информационного хранилища Microsoft Exchange обнаружит внесенные изменения в течение нескольких минут. Нет необходимость выполнять перезагрузку компьютера.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения о настройке разделов реестра для управления количеством клиентов Outlook, которые могут выполнять синхронизацию с Exchange Server 2003, см. в статье 818484 базы знаний «Registry Values and Counters That You Can Use to Configure and Monitor Outlook Client Synchronization» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484) (Значения реестра и счетчики, с помощью которых можно настраивать синхронизацию клиентов Outlook и отслеживать ее).


Установлен параметр реестра «Ignore Bad Oof Rule»
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Средство анализатора сервера Microsoft® Exchange считывает реестр компьютера сервера Exchange, чтобы проверить наличие в реестре записи Ignore Bad Oof Rule. Эта запись размещается в следующем разделе реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

Если анализатор сервера Exchange обнаруживает, что запись Ignore Bad Oof Rule присутствует в реестре, и ее значение равно 1 или меньше, выводится сообщение о конфигурации не по умолчанию.

Параметр реестра Ignore Bad Oof Rule является параметром конфигурации Exchange Server 2000, Exchange Server 2003 и Exchange Server 2007 и предназначен для работы с исправлением, описанным в статье 828875 базы знаний Майкрософт «You cannot move an Exchange mailbox after you use the Exmerge.exe utility» (http://go.microsoft.com/fwlink/?LinkID=3052&kbid=828875).

При использовании программы объединения почтовых ящиков Microsoft Exchange (Exmerge.exe) для перемещения сообщений и других элементов из почтового ящика одного хранилища почтовых ящиков в почтовый ящик другого хранилища почтовых ящиков, последующая попытка перемещения другого почтового ящика может закончиться неудачей. Это может происходить из-за неверного правила для сообщений об отсутствии на работе для этого почтового ящика. При необходимости можно вернуться к конфигурации по умолчанию, используя описанную здесь процедуру.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неполадок. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Возвращение к конфигурации по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. В правой области найдите и удалите значение Ignore Bad Oof Rule.

  4. Чтобы изменения вступили в силу, закройте редактор реестра и перезапустите службу банка данных Microsoft Exchange.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт, посвященную описанию реестра Microsoft Windows, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986 (возможно, на английском языке).


Установлен параметр реестра «Ignore Zombie Users»
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает реестр компьютера сервера Exchange, чтобы проверить наличие в реестре записи Ignore Zombie users. Эта запись размещается в следующем разделе реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Если анализатор сервера Exchange обнаруживает, что запись Ignore Zombie users присутствует в реестре, и ее значение равно 1 или больше, выводится сообщение о нестандартной конфигурации.

В организации Exchange Server, работающей в смешанном режиме, в которой содержится и Exchange Server 5.5, и Exchange 2000 Server, или в среде, которая была смешанной, могут возникнуть проблемы при выполнении следующих условий:

  • Список управляемого доступа почтовых ящиков и общих папок был обновлен с Exchange Server 5.5 до Exchange 2000 Server.

  • Список управляемого доступа содержит учетные записи пользователей в службе каталогов Active Directory®.

Эти неиспользуемые записи управления доступом известны как пользователи-зомби. В наборе исправлений, выпущенном после пакета обновления 3 в марте 2003 года, для Exchange 2000 Server изменилось поведение по умолчанию при обработке пользователей-зомби. Можно управлять этим поведением с помощью раздела реестра Ignore Zombie users.

Значение реестра Ignore Zombie users может быть использовано на серверах, на которых установлен Exchange 2000 Server с пакетом обновления 3 или более поздние версии. Следует использовать этот раздел реестра с осторожностью и только в том случае, когда есть уверенность, что пользователи-зомби появились не вследствие проблем с репликацией соединителя Active Directory, например вследствие задержек. Этот раздел реестра приводит к тому, что сервер Exchange будет игнорировать пользователей-зомби и удалять их из списка управляемого доступа почтовых ящиков или общих папок. Если пользователь является допустимым, но не находится в службе каталогов Active Directory во время обновления списка управляемого доступа, пользователь удаляется и необходимо будет впоследствии добавить этого пользователя в каждый список управляемого доступа.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы восстановить конфигурацию по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. В правой области найдите и удалите значение Ignore Zombie users.

  4. Чтобы изменения вступили в силу, закройте редактор реестра и перезапустите службу банка данных Microsoft Exchange.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об использовании раздела реестра Ignore Zombie Users реестра см. в следующих статьях базы знаний Майкрософт:

  • статья 812963, посвященная использованию раздела реестра «Ignore Zombie Users» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812963);

  • статья 324323, посвященная игнорированию учетных записей пользователей, не присутствующих в службе каталогов Active Directory, во время преобразования списка управления доступом (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324323).


Обработка исключений IMAIL была отключена вручную
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-17

Средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить значение параметра ExceptionHandling раздела реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Если анализатор сервера Exchange обнаруживает, что значение реестра ExceptionHandling установлено равным 0, выводится предупреждение.

В сервере Exchange обработка исключений IMAIL по умолчанию включена и не может быть отключена из пользовательского интерфейса. Но обработку исключений IMAIL можно отключить с помощью реестра.

Корпорация Майкрософт рекомендует отключать обработку исключений IMAIL только при ведении активных действий по устранению проблем. Например, можно отключить обработку исключений IMAIL, если используются специализированные приложения, инициирующие события в зависимости от ошибок содержания MIME или MAPI. Корпорация Майкрософт рекомендует отключать обработку исключений IMAIL только по совету и указанию специалистов службы поддержки продуктов Майкрософт.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Устранение причины появления этого предупреждения

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent.

  3. Дважды щелкните ExceptionHandling:

Перед редактированием реестра для получения сведений о его редактировании см. статью 256986 базы знаний Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о значени параметра реестра ExceptionHandling см. в статье 832174 базы знаний Майкрософт «There is no option to turn off IMAIL exception handling in Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832174) (Невозможно отключить обработку исключения IMAIL в Exchange 2000 Server).


Настройка службы хранилища информации на взаимодействие с рабочим столом
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft Exchange Server запрашивает класс Win32_Service Microsoft Windows Management Instrumentation (WMI) для определения значения свойства DesktopInteract службы хранилища информации Microsoft Exchange (MSExchangeIS). Если Exchange Server Analyzer обнаруживает, что служба хранилища информации Microsoft Exchange настроена на взаимодействие с рабочим столом, появляется сообщение об ошибке.

Данная настройка используется только под руководством служб поддержки корпорации Майкрософт. Рекомендуется использовать данную настройку только при получении соответствующих указаний от служб поддержки корпорации Майкрософт. В противном случае следует изменить настройку таким образом, чтобы служба хранилища информации Microsoft Exchange не взаимодействовала с рабочим столом.

Настройка учетной записи службы хранилища информации Microsoft Exchange

  1. Откройте оснастку «Службы» консоли MMC.

  2. Найдите и остановите службу Хранилище информации Microsoft Exchange.

  3. Дважды щелкните службу Хранилище информации Microsoft Exchange.

  4. На вкладке Вход в систему на странице Свойства хранилища информации Microsoft Exchange выберите Локальная системная учетную запись в узле Вход под именем.

  5. Снимите флажок Разрешить взаимодействие службы с рабочим столом и нажмите Применить.

  6. В разделе Состояние службы выберите Запустить, а затем нажмите кнопку OK.

  7. Закройте оснастку «Службы».

Для получения дополнительных сведений о правильной настройке службы Exchange см. статью 239762 базы знаний Майкрософт «Службы Exchange, работающие на локальном компьютере» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762).


Увеличение максимального размера базы данных для хранилища почтовых ящиков
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-12-15

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс CIM_DataFile, чтобы определить следующие сведения:

  • полный путь к файлам базы данных Exchange;

  • текущий размер хранилища почтовых ящиков.

Анализатор сервера Exchange также запрашивает WMI-класс Win32_OperatingSystem, чтобы определить дополнительные сведения:

  • версию операционной системы Windows, управляющей сервером Exchange;

  • версию установленного сервера Exchange;

  • выпуск установленного сервера Exchange;

  • версию уровня пакета обновления для сервера Exchange.

Наконец, чтобы определить, установлено ли значение Database Size in Gb, анализатор сервера Exchange также считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Имя_сервера>\Private-<Идентификатор_GUID_хранилища_почтовых_ящиков>

Анализатор рекомендаций по серверу Exchange выводит сообщение об ошибке, если выполняются следующие условия:

  • На сервере выполняется приложение Exchange Server 2003.

  • Службой установлен пакет обновления 2 для Exchange Server 2003.

  • Размер базы данных сервера Exchange больше 16 гигабайтов (ГБ).

  • В реестре не установлено значение параметра Database Size in Gb.

Эта ошибка указывает, что идентифицированная база данных Exchange близка по объему к своему предельному размеру. С установкой пакета обновления 2 для Exchange Server 2003 предельный размер базы данных повышается с 16 ГБ до 75 ГБ. Однако для использования новых предельных размеров необходимо добавить вручную значение параметра Database Size in Gb в реестре на сервере Exchange.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы устранить эту ошибку путем добавления в реестр значения параметра «Database Size in Gb»

  1. На компьютере, на котором выполняется сервер Exchange, откройте редактор реестра, например, Regedit.exe или RegEdt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Имя_сервера>\Private-<Идентификатор_GUID_хранилища_почтовых_ящиков>

  3. Щелкните правой кнопкой мыши Идентификатор_GUID_общего_хранилища, наведите указатель на пункт Создать и выберите Значение DWORD.

  4. В качестве имени нового значения введите Database Size Limit in Gb.

  5. Дважды щелкните Database Size Limit in Gb. В поле Значение введите соответствующее значение максимального размера базы данных, выраженное в ГБ. Нажмите кнопку ОК.

  6. Щелкните правой кнопкой мыши Идентификатор_GUID_общего_хранилища, наведите указатель на пункт Создать и выберите Значение DWORD.

  7. В качестве имени нового значения введите Database Size Buffer in Percentage.

  8. Дважды щелкните Database Size Buffer in Percentage. В поле Значение введите значение в диапазоне между 1 и 100, чтобы указать, когда в журнал должны заноситься события, предупреждающие о приближении к максимальному размеру базы данных. Нажмите кнопку ОК.

    Примечание.
    Значение по умолчанию, равное 10, приведет к записи в журнал предупреждающих сообщений, когда до достижения максимального размера этой базы данных останется 10 процентов её предельного объема.

  9. Щелкните правой кнопкой мыши Идентификатор_GUID_общего_хранилища, наведите указатель на пункт Создать и выберите Значение DWORD.

  10. В качестве имени нового значения введите Database Size Check Start Time in Hours From Midnight.

  11. Дважды щелкните Database Size Check Start Time in Hours From Midnight. В поле Значение введите значение в диапазоне между 0 и 23, чтобы указать, когда размер базы данных должен контролироваться приложением Exchange. Нажмите кнопку ОК.

    Примечание.
    Значение по умолчанию, равное 5, приведет к контролю сервером Exchange размера базы данных спустя 5 часов после полуночи (05:00:00).

  12. Закройте редактор реестра.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о процедуре настройки предельного размера базы данных сервера Exchange и управлении этими размерами см. в описании настройки предельного размера базы данных и управления этим размером (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=57029).

Сведения о максимальном размере базы данных для приложения Exchange Server 2003 Standard Edition и Exchange 2000 Server Standard Edition см. в базе знаний Майкрософт в статье 828070, описывающей причины, почему хранилище почтовых ящиков сервера Exchange не подключается, когда база данных хранилища почтовых ящиков достигает предела в 16 ГБ (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070).

Дополнительные сведения о пакете обновления 2 (SP2) для Exchange Server 2003 см. на веб-узле пакета обновления 2 (SP2) Exchange Server 2003 в материалах, описывающих, почему следует устанавливать пакет обновления 2 для Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=52073).


Увеличение максимального размера базы данных для хранилища общих папок
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-12-15

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_DataFile, чтобы определить следующие сведения:

  • Полный путь к файлам базы данных сервера Exchange.

  • Текущий размер хранилища общих папок.

Анализатор сервера Exchange также запрашивает WMI-класс Win32_OperatingSystem, чтобы определить дополнительные сведения:

  • Версия операционной системы Windows, управляющей сервером Exchange.

  • Версия установленного сервера Exchange.

  • Выпуск установленного сервера Exchange.

  • Версия уровня пакета обновления для сервера Exchange.

Наконец, чтобы определить, установлено ли значение Database Size in Gb, анализатор сервера Exchange также считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Имя_сервера>\Public-<Идентификатор_GUID_общего_хранилища>

Анализатор рекомендаций по серверу Exchange выводит сообщение об ошибке, если выполняются следующие условия:

  • На сервере выполняется приложение Exchange Server 2003.

  • Службой установлен пакет обновления 2 для Exchange Server 2003.

  • Размер базы данных Exchange больше 16 гигабайтов (ГБ).

  • В реестре значение параметра Database Size in Gb не установлено.

Эта ошибка указывает, что идентифицированная база данных сервера Exchange близка по объему к своему предельному размеру. С установкой пакета обновления 2 для Exchange Server 2003 предельный размер базы данных повышается с 16 ГБ до 75 ГБ. Однако для использования новых предельных размеров необходимо добавить вручную значение параметра Database Size in Gb в реестре на сервере Exchange.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы устранить эту ошибку путем добавления в реестр значения параметра «Размер базы данных в ГБ»

  1. На компьютере, на котором выполняется сервер Exchange, откройте редактор реестра, например, Regedit.exe или RegEdt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Имя_сервера>\Public-<Идентификатор_GUID_общего_хранилища>

  3. Щелкните правой кнопкой мыши Идентификатор_GUID_общего_хранилища, наведите указатель на пункт Создать и выберите Значение DWORD.

  4. В качестве имени нового значения введите Предельный размер базы данных в ГБ.

  5. Дважды щелкните Предельный размер базы данных в ГБ. В поле Значение введите соответствующее значение максимального размера базы данных, выраженное в ГБ. Нажмите кнопку ОК.

  6. Щелкните правой кнопкой мыши Идентификатор_GUID_общего_хранилища, наведите указатель на пункт Создать и выберите Значение DWORD.

  7. В качестве имени нового значения введите Ограничитель размера базы данных в процентах.

  8. Дважды щелкните Ограничитель размера базы данных в процентах. В поле Значение введите значение в диапазоне между 1 и 100, чтобы указать, когда в журнал должны заноситься события, предупреждающие о приближении к максимальному размеру базы данных. Нажмите кнопку ОК.

    Примечание.
    Значение по умолчанию, равное 10, приведет к записи в журнал предупреждающих сообщений, когда до достижения максимального размера этой базы данных останется 10 процентов её предельного объема.

  9. Щелкните правой кнопкой мыши Идентификатор_GUID_общего_хранилища, наведите указатель на пункт Создать и выберите Значение DWORD.

  10. В качестве имени нового значения введите Время начала проверки размера базы данных, выраженное в часах после полуночи.

  11. Дважды щелкните Время начала проверки размера базы данных, выраженное в часах после полуночи. В поле Значение введите значение в диапазоне между 0 и 23, чтобы указать, когда размер базы данных должен контролироваться приложением Exchange. Нажмите кнопку ОК.

    Примечание.
    Значение по умолчанию, равное 5, приведет к контролю сервером Exchange размера базы данных спустя 5 часов после полуночи (05:00:00).

  12. Закройте редактор реестра.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о процедуре настройки предельного размера базы данных Exchange и управлении этими размерами см. в описании настройки предельного размера базы данных и управления этим размером (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=57029).

Сведения о максимальном размере базы данных для приложения Exchange Server 2003 Standard Edition и Exchange 2000 Server Standard Edition см. в базе знаний Майкрософт в статье 828070, описывающей причины, почему хранилище почтовых ящиков сервера Exchange не подключается, когда база данных хранилища почтовых ящиков достигает предела в 16 ГБ (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070).

Дополнительные сведения о пакете обновления 2 (SP2) для Exchange Server 2003 см. на веб-узле пакета обновления 2 (SP2) Exchange Server 2003 в материалах, описывающих, почему следует устанавливать пакет обновления 2 для Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=52073).


Увеличение значения настройки буферов журнала транзакций
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средством анализатора сервера Microsoft® Exchange определено, что количество буферов журнала на сервере слишком мало. Средством обнаружено, что значение «База данных (экземпляр банка данных)\остановы записи в журнал/сек» для сервера больше 10 остановов в секунду. Значение больше 10 указывает, что в журнал транзакций ведется запись резервной копии. Данная ситуация может возникать, когда на диске журнала транзакций не остается свободного места или когда количество буферов журнала слишком мало.

Операции ввода-вывода при записи в журнал являются последовательными и однопоточными, поэтому задержка операций ввода-вывода в журнал часто является узким местом системы. Операции ввода-вывода в журнал записываются сначала в буферы журнала, а затем буфер очищается путем мгновенной фиксации или полной фиксации. Мгновенная фиксация означает, что буфер журнала записывается на диск немедленно. Полная фиксация означает, что буфер журнала записывается на диск, когда буфер полностью заполнен.

При увеличении размера буфера журнала уменьшается частота сбрасывания данных на диск, увеличивается размер данных, записываемых в журнал за раз и, соответственно, уменьшается общая задержка записи в журнал. Уменьшение задержки записи операций ввода-вывода в журнал является важным способом повышения производительности и масштабируемости развертывания Exchange.

Общая рекомендация заключается в увеличении размера буфера до максимума, равного 9000 для Exchange Server 2003 и 512 для Exchange 2000 Server.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью оснастки Edit интерфейса ADSI, средства LDP или другого клиента, использующего протокол LDAP версии 3, может привести к серьезным неполадкам. Для устранения этих неполадок может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Чтобы устранить причину появления этого предупреждения

  1. Запустите ADSI Edit.

  2. Дважды щелкните контейнер Конфигурация, последовательно разверните узлы CN=службы, CN=Microsoft Exchange, а затем разверните CN=имя_организации_Exchange.

  3. Последовательно разверните CN=административные группы, CN=имя_административной_группы, а затем разверните CN=серверы.

  4. Последовательно разверните CN=имя_сервера_Exchange, CN=банк_данных, щелкните правой кнопкой мыши узел CN=имя группы хранения и в контекстном меню выберите пункт Свойства.

  5. В поле Выберите свойство для просмотра щелкните msExchESEParamLogBuffers.

  6. В поле Изменение атрибута введите соответствующее значение своей версии Exchange для msExchESEParamLogBuffers, а затем щелкните Установить.

    Примечание.
    Для компьютеров, на которых выполняется Exchange 2000 Server, Exchange 2000 Server с пакетом обновления 1 (SP1), Exchange 2000 Server с пакетом обновления 2 (SP2) или Exchange 2000 с пакетом обновления 3 (SP3), установите значение равное 512. Для компьютеров, на которых выполняется исходная версия Exchange Server 2003 или Exchange Server 2003 с пакетом обновления 1 (SP1), установите значение равное 9000.

  7. Нажмите Применить, затем — ОК.

Дополнительные сведения

  • Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Дополнительные сведения об устранении проблем, связанных с производительностью сервера Exchange, см. на веб-узле, посвященном устранению неполадок, связанных с производительностью сервера Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Дополнительные сведения о работе с буферизацией журнала см. в базе знаний Майкрософт в статье, описывающей ситуацию, когда из-за установки слишком малых буферов журнала ESE прекращает отвечать служба банка данных Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328466).


Определено значение «Initial memory percentage»
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-05

Чтобы определить, определено ли значение параметра Initial Memory Percentage, средство анализатора приложения Microsoft® Exchange Server считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Если анализатор сервера Exchange обнаруживает наличие значения Initial Memory Percentage, большего 0, выводится сообщение о том, что конфигурация отличается от заданной по умолчанию.

Параметр реестра Initial Memory Percentage был введен в качестве механизма тонкой настройки первоначального количества памяти, выделенного банку данных, и равного 10 процентам всей физической памяти сервера Exchange. Выбор такого начального распределения памяти позволяет снизить вероятность фрагментации виртуальной памяти. Это значение реестра нельзя устанавливать произвольным образом, оно должно использоваться только по совету и указанию службы поддержки продуктов Майкрософт.

Версии сервера Exchange Server, начиная с Exchange Server 2003 и включая более поздние версии, включают поддержку особых параметров запуска в Microsoft Windows® 2000 Advanced Server и Windows Server™ 2003, помогающих снизить фрагментацию виртуальной памяти; были внесены дополнительные изменения для предотвращения фрагментации виртуальной памяти в кластерах серверов Exchange Server. Поэтому значение реестра Initial Memory Percentage не нужно для серверов Exchange Server начиная с Exchange Server 2003.

Значение реестра Initial Memory Percentage работает только на компьютерах, на которых работает приложение Exchange 2000 Server. Серверы Exchange Server 2003 и Exchange Server 2007 не будут обрабатывать это значение, если оно указано, поэтому оно не окажет никакого влияния на работу. Следовательно, перед модернизацией сервера Exchange с Exchange 2000 Server до Exchange Server 2003 эту запись реестра рекомендуется удалить.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Удаление параметра реестра «Initial Memory Percentage»

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. В правой области удалите значение Initial Memory Percentage.

  4. Чтобы изменения вступили в силу, закройте редактор реестра и перезапустите службу банка данных Microsoft Exchange.
  • Дополнительные сведения о проблеме использования этого значения реестра см. в статье 810883 базы знаний Майкрософт, посвященной отсутствию влияния значения реестра «Initial memory percentage», по адресу http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810883 (возможно, на английском языке).

  • Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в статье 256986 базы знаний Майкрософт, содержащей описание реестра Microsoft Windows, по адресу http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986 (возможно, на английском языке).


Установлена запись реестра Initial Reserve Size KB
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2006-04-27

Средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра, чтобы определить, существует ли запись реестра Initial Reserve Size KB:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Если анализатор сервера Exchange обнаруживает, что значение реестра "Initial Reserve Size KB" присутствует и оно больше 0, на экран выводится сообщение о конфигурации не по умолчанию.

Значение Initial Reserve Size KB реестра используется с целью резервирования дополнительного пространства для области динамической памяти. Это значение задается в килобайтах. По умолчанию это значение для большинства серверов Exchange составляет 655360 КБ, что равно 640 МБ. Можно уменьшить это значение, чтобы увеличить объем доступной свободной памяти и уменьшить фрагментацию виртуальной памяти. Это значение должно устанавливаться в соответствии с рекомендациями профессионалов службы поддержки продуктов Майкрософт. Данное сообщение является информационным, и никаких корректирующих действий не требуется, если это значение реестра было добавлено в соответствии с рекомендациями профессионалов службы поддержки продуктов Майкрософт.

Если вы уверены, что эта запись установлена неправильно, можно удалить ее и вернуться к конфигурации по умолчанию.

Важно!
Этот раздел содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» в Regedit.exe или Regedt32.exe.

Чтобы возвратиться к конфигурации по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

  3. Удалите значение с названием Initial Reserve Size KB.

  4. Закройте редактор реестра и перезапустите службу Microsoft Exchange Information Store, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об устранении неполадок, связанных с фрагментацией виртуальной памяти, см. в базе знаний Майкрософт в статье, описывающей инструкции по устранению неполадок, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044).


Атрибут legacyExchangeDN для этой базы данных Exchange не соответствует серверу Exchange
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута legacyExchangeDN для всех баз данных хранилища почтовых ящиков. Если анализатор сервера Exchange обнаруживает, что значение атрибута legacyExchangeDN для какого-либо хранилища почтовых ящиков не соответствует компьютеру с сервером Exchange, на котором размещено это хранилище почтовых ящиков, отображается сообщение об ошибке.

Причиной несоответствия атрибута legacyExchangeDN может быть внесение администратором изменений в службу каталогов Active Directory для восстановления базы данных в ситуации аварийного восстановления. Чтобы исправить эту ошибку, необходимо изменить атрибут legacyExchangeDN с помощью редактора Active Directory, например с помощью средства LDP (ldp.exe) или ADSI Edit.

Чтобы обеспечить правильное значение атрибута legacyExchangeDN, следует проверить атрибут legacyExchangeDN сервера, на котором размещена база данных, поскольку, являясь дочерним объектом этого сервера, эта база данных будет иметь то же значение атрибута legacyExchangeDN.

Следует также проверить другие базы данных на этом сервере Exchange, для которых данная ошибка не возникает, поскольку для них значение атрибута legacyExchangeDN должно быть таким же. Имейте в виду, что существует еще несколько системных объектов, имеющих этот атрибут. В случае несоответствия атрибута legacyExchangeDN базы данных, существует вероятность, что этот атрибут также не соответствует на некоторых других системных объектах. Поэтому, если для исправления значения legacyExchangeDN используется средство LDP или ADSI Edit, потребуется внести это исправление на всех таких системных объектах.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью ADSI Edit, средства LDP или другого LDAP-клиента версии 3 может привести к возникновению серьезных неполадок. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, а также сервера Exchange Server 2003, сервера Exchange Server 2007 или обоих продуктов. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы устранить эту ошибку

  1. Откройте редактор Active Directory, например ADSI Edit.

  2. Разверните узел Конфигурация [имя_домена], затем — CN=Configuration,DC=имя_домена,DC=суффикс_домена.

  3. Разверните CN=Services, а затем — CN=Microsoft Exchange.

  4. Разверните CN=имя_организации, CN=Administrative Groups, а затем — CN=имя_административной_группы.

  5. Разверните узел CN=Servers, CN=имя_сервера, а затем — CN=InformationStore.

  6. Выберите CN=имя_группы_хранения, а затем в правой области щелкните правой кнопкой мыши хранилище почтовых ящиков с несоответствующим атрибутом legacyExchangeDN и выберите команду Свойства.

  7. Прокрутите до атрибута legacyExchangeDN, выделите его и нажмите кнопку Изменить.

  8. В поле «Значение» введите правильное значение legacyExchangeDN.

  9. Закройте редактор Active Directory и перезапустите компьютер с сервером Exchange, чтобы изменения вступили в силу.

Дополнительные сведения об использовании средства ADSI Edit для создания нового атрибута legacyExchangeDN см. в базе знаний Майкрософт в статье 273863, содержащей инструкции по изменению атрибута LegacyExchangeDN в основном режиме с помощью ADSI Edit (http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863).


Значение legacyExchangeDN отсутствует в этой базе данных Exchange
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута legacyExchangeDN для всех баз данных хранилища почтовых ящиков на компьютере сервера Exchange. Если анализатор сервера Exchange не обнаруживает значение атрибута legacyExchangeDN для любого из хранилищ почтовых ящиков, выводится сообщение об ошибке.

Отсутствие legacyExchangeDN может быть вызвано действиями администратора, изменившего Active Directory для восстановления базы данных при аварийном восстановлении. Для исправления этой ошибки необходимо изменить атрибут legacyExchangeDN, используя редактор Active Directory, например средство LDP (ldp.exe) или оснастку «Редактирование» интерфейса ADSI (Active Directory Service Interfaces).

Чтобы убедиться в правильности атрибута legacyExchangeDN, проверьте атрибут legacyExchangeDN сервера, на котором находится эта база данных, так как, будучи дочерним объектом этого сервера, эта база данных будет использовать то же значение legacyExchangeDN.

Необходимо также проверить на этом сервере Exchange другие базы данных, не вызывающие этой ошибки, для них должно использоваться это же значение legacyExchangeDN. Учтите, что этот атрибут используется также некоторыми другими системными объектами. В этой ситуации, если атрибут legacyExchangeDN отсутствует для одной базы данных, вероятно, что он отсутствует и для некоторых других системных объектов. Следовательно, при использовании LDP или оснастки «Редактирование» интерфейса ADSI для добавления нового значения legacyExchangeDN понадобится проделать это и для всех остальных системных объектов.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью оснастки «Редактирование» интерфейса ADSI, средства LDP или другого клиента, использующего протокол LDAP версии 3, может привести к серьезным проблемам. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, а также сервера Exchange Server 2003, сервера Exchange Server 2007 или обоих продуктов. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Устранение ошибки

  1. Откройте редактор Active Directory, например оснастку «Редактирование» интерфейса ADSI.

  2. Разверните узел Конфигурация имя_домена, разверните CN=Конфигурация,DC=имя_домена,DC=суффикс_домена.

  3. Разверните узел CN=Services, а затем разверните узел CN=Microsoft Exchange.

  4. Разверните узел CN=имя_организации, разверните узел CN=Administrative Groups, а затем разверните узел CN=имя_административной_группы.

  5. Разверните узе CN=Servers, разверните узел CN=имя_сервера, а затем разверните узел CN=InformationStore.

  6. Выберите CN=имя_группы_хранилища и в правой области щелкните правой кнопкой мыши хранилище почтовых ящиков, у которого отсутствует атрибут legacyExchangeDN, и выберите в контекстном меню команду Свойства.

  7. Выполните прокрутку вниз, чтобы поместить legacyExchangeDN, выберите этот атрибут и нажмите кнопку Изменить.

  8. В поле «Значение» введите правильное значение legacyExchangeDN.

  9. Закройте редактор Active Directory и перезапустите сервер Exchange, чтобы изменения вступили в силу.

Дополнительные сведения об использовании оснастки «Редактирование» интерфейса ADSI для создания нового атрибута legacyExchangeDN см. в статье 273863 базы знаний Майкрософт, посвященной изменению атрибута LegacyExchangeDN в основном режиме с помощью оснастки «Редактирование» интерфейса ADSI, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863.


Параметр LimitBodyParts установлен вручную
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, не было ли изменено установленное по умолчанию ограничение на вложения в сообщение, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent\LimitBodyParts

Если анализатор сервера Exchange обнаруживает, что запись реестра LimitBodyParts существует и настроена, отображается сообщение о нестандартной конфигурации.

По соображениям структуры и безопасности сервер Exchange ограничивает количество вложений (называемых разделами) значением 250. Если сообщение содержит свыше 250 вложений, возникает ошибка MAPI_E_TOO_BIG. Кроме того, службе банка данных Microsoft Exchange при обработке сообщений с большим количеством вложений могут потребоваться избыточные объемы памяти и ресурсы процессоров.

Существует возможность настройки, позволяющая администраторам добавить запись реестра LimitBodyParts и определить для него значение, большее 250. Если эта запись отсутствует, используется значение по умолчанию, равное 250.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Просмотр или изменение значения реестра LimitBodyParts

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

  3. Проверьте и при необходимости измените значение LimitBodyParts. Допустимым значением для этой записи реестра является любое целое число между 250 и 4294967295.

  4. Чтобы изменения вступили в силу, после внесения изменений перезапустите компьютер сервера Exchange.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт, содержащую описание реестра Microsoft Windows, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Параметр LimitEmbeddingDepth был задан вручную
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-30

Для выявления факта изменения применяемых по умолчанию пределов для заголовков MIME в Exchange анализатор сервера Microsoft® Exchange читает следующий раздел системного реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Если анализатор сервера Exchange обнаружит, что задано какое-либо значение LimitEmbeddingDepth, выводится сообщение о наличии конфигурации, не являющейся заданной по умолчанию.

Exchange 2000 Server с пакетом обновления 3, Exchange Server 2003 и Exchange Server 2007 включают функциональные обновления процесса банка данных (store.exe), который определяет, какой объем или какие нестандартно сформированные операции MIME обрабатываются. Эти функциональные возможности были добавлены с целью дальнейшего повышения устойчивости Exchange Server против злонамеренных и неумышленных атак типа «отказ в обслуживании» с применением больших и сложных MIME-сообщений. В числе ограничений, накладываемых на MIME-сообщения, передаваемые в хранилище, — ограничение числа получателей, числа внедренных сообщений и размеров отдельных MIME-заголовков.

Значения по умолчанию для этих различных ограничений MIME-заголовков задаются процессом обработки банка сообщений. Однако, если любой из этих пределов задан при помощи ключа реестра, значение реестра переопределит значение по умолчанию, заданное процессом store.exe. В случае превышения в MIME-сообщении любого из пределов отправителю посылается отчет о недоставке.

Ограничение глубины внедрения MIME определяет число сообщений MIME, которые могут быть внедрены друг в друга. Например, пусть получено сообщение (m1) с вложенным сообщением (m2). При открытии вложенного сообщения (m2) обнаружилось сообщение (m3), вложенное в сообщение (m2). Таким образом, исходное сообщение (m1) содержит сообщения, внедренные на глубину в 3 уровня. По умолчанию Exchange допускает 100-уровневую глубину внедрения сообщений. Сообщения, глубина внедрения сообщений в которых превышает 100 уровней, могут потреблять всю память на сервере Exchange в течение времени, требуемого серверу для развертывания уровней сообщений, их анализа и преобразования в формат MAPI. Весьма маловероятно, однако, что какой-либо почтовый клиент или сервер будет генерировать сообщения с такой глубиной внедренных сообщений. Наиболее вероятно, что такое сообщение появится в результате злонамеренных действий в попытке провести на систему управления сообщениями атаку типа «отказ в обслуживании».

Чтобы вернуться к конфигурации по умолчанию

  • Никаких действий выполнять не требуется. Эта запись в реестре появляется только после установки исправления, описанного в статье 833607 базы знаний Майкрософт «The Microsoft Exchange Information Store service uses 100 percent of the CPU resources on an Exchange 2000 Server or an Exchange Server 2003» (Служба банка данных Microsoft Exchange использует 100 процентов ресурсов ЦП на сервере Exchange 2000 Server или Exchange Server 2003) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833607). Это исправление создает параметр реестра LimitEmbeddingDepth и задает для него значение 10.

Дополнительные сведения о пакетах обновления и исправлениях сервера Exchange см. в статье базы знаний 328839 «How to apply Exchange service packs and hotfixes» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839) (Инструкции по применению пакетов обновления и исправлений Exchange).


Значение параметра «LimitNestingLevels» задано вручную
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Для выявления факта изменения применяемых по умолчанию ограничений для заголовков MIME в Exchange средство анализатора сервера Microsoft® Exchange считывает следующий раздел системного реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Если анализатор сервера Exchange обнаружит, что задано какое-либо значение LimitNestingLevels, выводится сообщение о наличии конфигурации, не являющейся заданной по умолчанию.

Части сообщения MIME могут быть вложенными. Чем выше уровень вложенности, тем больше ресурсов необходимо для процесса преобразования, чтобы расшифровать все сообщения. Обработка отдельного сообщения, у которого может быть до 700 уровней вложенности частей MIME, занимает до 10 минут. Когда из Интернета доставляются сообщений с вложенными частями MIME, процесс преобразования этих частей может стать причиной медленной доставки этих сообщений. При доставке таких сообщений серверу понадобится большое количество системных ресурсов, особенно памяти. Если получено большое количество таких сообщений одновременно, система может сообщить, что заканчивается виртуальная память.

Ограничение глубины вложенности MIME определяет число типов содержимого MIME (например, многокомпонентные и смешанные или многокомпонентные и альтернативные), которые могут быть вложены друг в друга. Сообщения создаются большинством почтовых клиентов (в том числе Microsoft Outlook® и Outlook Express), почтовые сервера содержат мало вложенных типов содержимого MIME. Например, обычное сообщение (даже с несколькими ответами) будет представлено в сообщении MIME только как один тип содержимого. Наличие нескольких уровней вложенности обычно является результатом работы автоматизированного процесса, при котором сообщения MIME создаются для определенных целей (например, приложения для автоматизации документооборота), или результатом действия вредоносных сообщений, созданных с целью потребления ресурсов на почтовом сервере.

Кроме назначения уровням вложенности типов содержимого сервер Exchange использует значение LimitNestingLevels (определенное как значение параметра реестра или как значение по умолчанию в процессе сохранения), чтобы определить ограничения для вложенных сообщений. Если значение параметра реестра LimitNestingLevels не определено, используется значение по умолчанию, указывающее наличие 30 уровней вложенности. Ограничение количества вложенных сообщений определяется умножением значения LimitNestingLevels на 16. Таким образом, значение по умолчанию для количества вложенных сообщений составляет 480. Например, если для параметра LimitNestingLevels задано значения 5, будет приниматься не более 80 вложений.

Возврат к конфигурации по умолчанию

  • Никаких действий выполнять не требуется. Анализатор сервера Exchange выводит сообщение о несоответствии заданной по умолчанию конфигурации в информационных целях.

Дополнительные сведения об исправлении Exchange 2000 Server, связанном с параметром реестра LimitNestingLevels, см. в базе знаний Майкрософт в статье 289775, описывающей ситуацию, когда в Exchange 2000 Server происходят утечки памяти из-за большого количества вложенных сообщений (http://go.microsoft.com/fwlink/?linkid=3052&kbid=289775).


Значение параметра LimitRecipients установлено вручную
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Чтобы определить, изменены ли пределы MIME-заголовка в Exchange, анализатор сервера Microsoft® Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Если анализатор сервера Exchange обнаруживает, что параметр LimitRecipients имеет любое значение, выводится сообщение о том, что текущая конфигурация отличается от заданной по умолчанию.

В Exchange 2000 Server с пакетом обновления 2 (SP2) и более поздних версиях Exchange Server используется обновленный процесс хранения (store.exe), определяющий, как обрабатываются крупные и неправильно сформированные MIME-сообщения. Эта функциональность призвана повысить защиту Exchange от атак типа «отказ в обслуживании», организованных с использованием вредоносных и неординарных (непреднамеренно больших и сложных) MIME-сообщений. К ограничениям для MIME-сообщений, предоставляемых в хранилище, относятся ограничение числа получателей, ограничение количества вложенных сообщений и ограничение размера отдельных MIME-заголовков. В предыдущих версиях Exchange, где можно было предоставлять в хранилище на обработку MIME-заголовки без ограничений, излишне большие или сложные MIME-сообщения могли поглощать практически все ресурсы (в основном процессорные) в ходе разбора, индексации и обработки данного MIME-заголовка.

Значения по умолчанию для данных ограничений в отношении MIME-заголовка устанавливаются в рамках процесса хранилища. Однако, если для определения любого из этих ограничений используется раздел реестра, этот параметр переопределяет значение по умолчанию, заданное программой store.exe. Если для MIME-сообщений превышено одно или несколько ограничений, отправителю сообщения направляется отчет о недоставке.

Если установлен раздел реестра LimitRecipients, скорее всего, это было рекомендовано службами поддержки продуктов Майкрософт, так как сведения о данном разделе реестра не публиковались. В связи с этим корпорация Майкрософт не рекомендует менять значение данного параметра.

Значение по умолчанию для параметра LimitRecipients (если отсутствует соответствующий раздел реестра) в процессе хранилища составляет 65 535 получателей для одного MIME-сообщения.


Буферы журналов не оптимизированы для серверов с реплицированным дисковым хранилищем, на которых работает Exchange Server 2003
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить, выполняются ли следующие условия:

  • На компьютере выполняется приложение Exchange Server 2003.

  • Значение msExchESEParamLogBuffers находится между 0 и 8 960.

Анализатор сервера Exchange запрашивает WMI-класс Win32_PerfRawData_MSExchangeIS_MSExchangeIS, чтобы определить, выполняется ли следующее условие:

  • Значение VMLargestBlockSize больше 150 000 000.

Анализатор сервера Exchange определяет, выполняется ли какая-либо из эти служб:

  • GeoSpanService

  • SRDFService

Если все вышеприведенные условия выполняются, отображается сообщение об ошибке.

Модуль ESE использует буферы журналов, чтобы хранить транзакции в памяти, прежде чем зафиксировать их в журналах транзакций. Если существует недостаточное количество буферов журналов, может возникнуть чрезмерное количество операций записи и чтения на диск журналов транзакций, что приведет к уменьшению производительности.

Внимание!
Могут возникнуть серьезные проблемы, если некорректно изменить атрибуты объектов Active Directory при использовании оснастки «Edit» интерфейса ADSI (Active Directory Service Interfaces), средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Чтобы устранить эту ошибку

  1. В оснастке «Edit» интерфейса ADSI щелкните дважды контейнер Configuration, разверните узел CN=Services, затем CN=Microsoft Exchange, затем разверните CN=ExchangeOrganizationName.

  2. Разверните последовательно CN=Administrative Groups, CN=имя_группы_администраторов и CN=Servers.

  3. Разверните последовательно CN=имя_сервера_Exchange и CN=InformationStore, щелкните правой кнопкой мыши CN=имя_группы_хранения, а затем выберите Properties.

  4. В поле Select a property to view, щелкните msExchESEParamLogBuffers.

  5. В поле Edit Attribute введите 9000 для msExchESEParamLogBuffers и щелкните Set.

  6. Нажмите Apply, затем ОК.

  7. Чтобы изменения вступили в силу, необходимо перезапустить службу банка данных Microsoft Exchange.

Дополнительные сведения см. в статье 328466 базы знаний Майкрософт, посвященную возможности буферов журналов ESE привести к прекращению ответов на запросы службой банка данных Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466).


Возможно, недостаточно буферов журнала для сервера с большим количеством почтовых ящиков, работающего под Exchange Server 2003
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-03-27

Средство анализа Microsoft® Exchange Server запрашивает службу каталогов Active Directory®, чтобы определить, выполняются ли следующие условия:

  • На компьютере установлен Exchange Server 2003.

  • Значение msExchESEParamLogBuffers лежит в промежутке от 0 до 8960.

  • Число почтовых ящиков в группе хранения превышает 500.

Средство анализа Exchange Server запрашивает класс Win32_PerfRawData_MSExchangeIS_MSExchangeIS инструментария Microsoft Windows® Management Instrumentation (WMI), чтобы определить, выполняется ли следующее условие:

  • Значение VMLargestBlockSize превышает 150 миллионов.

Если все условия выполнены, появится предупреждение.

Модуль расширяемого хранилища ESE использует буферы журналов для хранения транзакций до того, как они будут переданы в журнал транзакций. Если буферов журнала недостаточно, это может привести к слишком большому числу операций ввода/вывода диска, на котором размещен журнал транзакций, и к снижению производительности.

Устранение предупреждения

  1. В редакторе интерфейсов служб Active Directory (ADSI) дважды щелкните контейнер Настройка, раскройте CN=Services, раскройте CN=Microsoft Exchange, а затем раскройте CN=ExchangeOrganizationName.

  2. Раскройте CN=Administrative Groups, раскройте CN=AdministrativeGroupName, затем раскройте CN=Servers.

  3. Раскройте CN=ExchangeServerName, раскройте CN=InformationStore, щелкните правой кнопкой мыши CN=Storage Group Name и выберите Свойства.

  4. В окне выбора свойств для просмотра щелкните msExchESEParamLogBuffers.

  5. В окне Правка атрибута введите 9000 для msExchESEParamLogBuffers и нажмите кнопку Установить.

  6. Нажмите Применить, затем ОК.

  7. Чтобы изменения вступили в силу, нужно перезапустить службу Microsoft Exchange Information Store.
Внимание!
Неправильное изменение атрибутов объектов Active Directory в редакторе ADSI, средстве LDP (ldp.exe) или другом клиенте LDAP версии 3 может привести к серьезным ошибкам. В результате может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или и того, и другого. Будьте предельно осторожны, изменяя атрибуты объектов Active Directory.

Дополнительные сведения см. в статье 328466 базы знаний Майкрософт «Недостаточный размер буферов журнала ESE может привести к тому, что служба банка данных Microsoft Exchange перестанет отвечать на запросы» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466) (на английском языке).


Файлы журналов хранятся на сетевом диске
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchESEParamLogFilePath для каждого объекта группы хранения. Этот атрибут задает размещение файлов журналав транзакций, используемых базами данных в группе хранения.

Помимо этого, анализатор сервера Exchange запрашивает службу Active Directory, чтобы определить значение счетчика записей, перечисленных в атрибуте homeMDBBL каждого хранилища почтовых ящиков. Счетчик этого атрибута представляет количество почтовых ящиков в хранилище почтовых ящиков.

Если анализатор сервера Exchange обнаруживает, что значение атрибута msExchESEParamLogFilePath начинается с \\ на сервере Exchange Server с более чем 50 почтовыми ящиками, отображается сообщение об ошибке.

Данная ошибка указывает, что файлы журналов транзакций для группы хранения находятся на общем сетевом ресурсе. Если значение атрибута msExchESEParamLogFilePath, начинается с \\, это свидетельствует о том, что при записи пути к файлу журнала использован UNC-путь. Размещать файлы журналов в сети не рекомендуется, поскольку неполадки сетевого подключения могут вызвать ошибки в работе журналов транзакций и баз данных, что может привести к потере данных и повреждению баз данных. Рекомендуется как можно быстрее исправить эту неполадку.

Чтобы устранить эту ошибку

  • Переместите журналы транзакций с общего сетевого ресурса на локальный диск. Для повышения быстродействия разместите все журналы транзакций на разных дисках.

Сведения о том, как переместить журналы транзакций в другое расположение, см. в статье 239944 базы знаний Майкрософт (http://go.microsoft.com/fwlink/?linkid=3052&kbid=239944).


Расхождение в именовании журналов
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange обнаружил расхождение в именовании файлов журналов. Эта ошибка означает, что файл журнала транзакций был переименован с использованием неправильного порядкового номера.

Для именования файлов журнала транзакций Exchange используется следующий формат: EnnXXXXX.log

  • XXXXX — пятизначный шестнадцатеричный порядковый номер. При генерировании набора файлов журнала транзакций первому журналу набора присваивается имя 000001, второму — 00002 и т. д. Поскольку в заголовок журнала транзакций записывается его собственный порядковый номер, то можно определить, было ли изменено имя журнала.

  • Enn — префикс журнала, представляющий собой трехзначную последовательность, общую для всех журналов транзакций в пределах группы хранения. Обычно используется префикс E00, E01, E02, E03 или R00 (для группы аварийного хранения).

Для текущего журнала, в который производится запись, в качестве имени используется только префикс журнала. Журнал не получает порядкового номера до тех пор, пока он не будет закрыт и пока вместо него не будет сгенерирован новый текущий журнал. Поэтому текущий журнал может иметь имя E00.log. При заполнении этого журнала он может быть переименован в E0012345.log. Затем будет сгенерирован новый журнал E00.log с внутренним порядковым номером 12346.

Чтобы устранить эту ошибку

  • Переименуйте файл журнала, задав для него соответствующий порядковый номер.
Чтобы просмотреть внутренний порядковый номер

  • Выполните следующую команду:

    C:\Program Files\Exchsrvr\Bin\Eseutil.exe /ML [имя файла журнала]

    Значение «lGeneration» в результатах выполнения данной команды указывает фактический порядковый номер файла журнала.


Пары журналов не согласованы
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange обнаружил, что некоторые из обязательных файлов журнала не согласованы. Это сообщение об ошибке означает, что файлы журнала могут быть повреждены, вручную перемещены, скопированы, переименованы или удалены.

Чтобы устранить эту ошибку

  • Для развернутого анализа файлов журнала обратитесь в службу справки и поддержки корпорации Майкрософт (http://go.microsoft.com/fwlink/?LinkId=31845).


Несоответсвие подписи журнала
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange Server определило, что подпись журнала в одном или нескольких файлах журналов не соответствует другим файлам журналов в той же самой папке.

Такая неполадка происходит только тогда, когда файлы журналов вручную перемещались, удалялись или переупорядочивались.

Примечание.
Исправление этой неполадки не относится к числу стандартных, предварительно рекомендуется обратиться в службу справки и поддержки Майкрософт (http://go.microsoft.com/fwlink/?LinkId=31845).

Каждый файл журнала Exchange скреплен подписью, называемой подписью журнала. Эта подпись идентифицирует отдельные файлы журналов, принадлежащие к одной и той же серии журналов. В каждой базе данных Exchange записана подпись журнала, относящаяся к серии журналов транзакций к которой последний раз была присоединена база данных.

У баз Exchange также имеется подпись, называемая подписью БД. Подпись БД формируется при первоначальном создании базы данных. При применении программы Eseutil для дефрагментации или восстановления базы данных эта подпись изменяется, поскольку в ходе процессов восстановления и дефрагментации в файлы базы данных вносятся изменения, которые не регистрируются в журналах транзакций. Из соображений удобства ведения журналов база данных, которая получается в результате восстановления или дефрагментации, считается новой или другой базой данных.

В отличие от подписей БД подписи журнала никогда не изменяются в течение жизненного цикла серии файлов журнала.

При создании файлов журналов в них записываются подписи БД для всех присоединенных баз данных. В базы данных записываются подписи журнала для самых последних серий журналов, к которым была присоединена база данных. Следовательно, подписи БД и подписи журнала могут быть использованы для проверки соответствия баз данных файлам журналов транзакций.

Можно отсоединить базу данных Exchange от одного набора журналов и присоединить ее к другому набору. Это можно сделать, переместив базу данных в другую группу хранения или удалив все журналы транзакций группы хранения и начав новую серию журналов.

Если база данных находится в состоянии некорректного завершения, только те файлы журналов транзакций, подписи которых соответствуют подписям журнала в заголовке базы данных, могут быть успешно повторены в базе данных. База данных, даже находящаяся в состоянии некорректного завершения, может быть подсоединена к определенному потоку журналов, и восстановление может быть выполнено только с использованием этого потока журналов.

Если база данных находится в состоянии нормального завершения, иногда можно повторить файлы журналов транзакций, у которых нет подписей, соответствующих текущей подписи журнала в заголовке базы данных. Эта операция будет успешной только в следующих случаях:

  1. Работа с базой данных была корректно завершена в конце предыдущей последовательности файлов журналов.

  2. База данных была присоединена к новой последовательности файлов журналов, и есть доступ к журналу транзакций, в котором база данных была впервые присоединена к новой последовательности журналов.

Чтобы устранить эту ошибку

  • Необходимо знать историю базы данных и учитывать, при каких обстоятельствах были созданы журналы транзакций по отношению к базе данных.

  • В данной ситуации перед попыткой восстановления всегда делайте копии и файлов журналов транзакций, и файлов базы данных. При неудачных попытках восстановления файлы журналов транзакций и базы данных могут так измениться, что последующие попытки восстановления станут невозможными.

  • За один раз с одной базой данных повторяйте только один набор журналов транзакций. Переместите другие журналы транзакций из папки восстановления.

  • Если база данных находится в состоянии некорректного завершения, сначала надо успешно повторить журналы транзакций, к которым подсоединена база данных, и привести базу данных в состояние нормального завершения. После этого можно повторить в базе данных второй набор файлов журналов.

  • Если база данных находится в состоянии нормального завершения, анализ журналов и базы данных не позволяет однозначно решить, какой набор данных является правильным, чтобы повторить его первым.


Некоторым пользователям запрещен вход в систему
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange считывает следующую запись реестра на компьютере сервера Exchange, чтобы определить, был ли ограничен список пользователей, которым разрешается входить в банк данных Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Logon Only As

Если анализатор сервера Exchange обнаруживает значение реестра Logon Only As, выводится предупреждение.

Значение реестра Logon Only As представляет собой многострочное значение (REG_MULTI_SZ), которое содержит список атрибутов legacyExchangeDN для учетных записей, авторизованных для входа в банк данных Exchange. Данное значение реестра, которое отсутствует по умолчанию, как правило, добавляется в процессе выполнения операций устранения неполадок, обслуживания и перемещения почтовых ящиков.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. В правой области удалите значение реестра Logon Only As.

  4. Закройте редактор реестра и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения о значении реестра Logon Only As см. в статье 146764 базы знаний «Limiting Logons to the Information Store» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=146764) (Ограничение входа в банк данных).

Инструкции по ограничению входа при выполнении операций перещения ящиков, см. статью 218920 базы знаний «XADM: How to Prevent Logons During Move Mailbox» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=218920) (XADM: инструкции по предотвращению входа в систему в процессе перемещения почтовых ящиков).


Поиск наличия значения реестра «SID Cache Expire»
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает последующий раздел реестра, чтобы определить, существует ли следующая запись реестра Lookup Sid Cache Expire:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Анализатор сервера Exchange отображает сообщение о конфигурации не по умолчанию, если существуют следующие условия:

  • Существует запись Lookup Sid Cache Expire реестра.

  • Запись Lookup Sid Cache Expire реестра имеет значение, отличное от 3600.

На серверах Exchange, на которых работает пакет обновления 3 сервера Exchange 2000 Server Service Pack 3 или более поздней версии, банк сообщений создает кэш, содержащий идентификаторы безопасности, и указывает, является ли индикатор безопасности объектом пользователя или объектом группы. Этот кэш создается и заполняется при первом открытии общей папки. После заполнения кэша все запросы на просмотр индикаторов безопасности учетных записей сначала направляются в кэш банка сообщений. Если индикатор безопасности в кэше банка сообщений отсутствует, запрос делается в контроллер домена и затем данные для этого индикатора безопасности добавляются в кэш.

По умолчанию данные в кэше сохраняются в течение одного часа. Если объем записей в кэше превышает 8 КБ, более старые записи из кэша удаляются, чтобы освободить место для новых записей. Можно использовать два раздела реестра для регулировки и времени хранения данных в кэше (Lookup Sid Cache Expire), и размера кэша по умолчанию (Lookup Sid Cache Size). Рекомендуется не изменять параметры по умолчанию, если не является очевидным, что такие изменения приведут к повышению производительности.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» в Regedit.exe или Regedt32.exe.
Чтобы возвратиться к конфигурации по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. В правой области переходов найдите и удалите значение Lookup Sid Cache Expire. Если установлено также значение Lookup SID Cache Size, удалите его также.

  4. Выйдите из редактора реестра и перезапустите банк сообщений в Microsoft Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986 "Description of the Microsoft Windows registry" (Описание реестра Microsoft Windows) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Для получения дополнительных сведений о значении Lookup Sid Cache Expire реестра см. статью 328907 "XADM: Access Control List Upgrades Cause Slow Public Folder Performance; Fix Requires Exchange 2000 SP2" (XADM: обновления списков управления доступом вызывают снижение производительности общих папок, для недопущения этой ситуации требуется пакет обновления 2 Exchange 2000) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328907).


Значение параметра реестра Lookup SID Cache Size не было установлено
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, существует ли раздел реестра Lookup Sid Cache Size, средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Если выполняются следующие условия, анализатор сервера Exchange отобразит сообщение о нестандартной конфигурации:

  • Существует раздел реестра Lookup Sid Cache Size.

  • Значение раздела реестра Lookup Sid Cache Size не равно 1 024.

На серверах Exchange, работающих под управлением Exchange 2000 Server с пакетом обновления 3 или более поздних версий, банк данных создает кэш, в котором содержатся идентификаторы SID, и указывает, является ли SID объектом пользователя или объектом группы. Этот кэш создается и заполняется при первом обращении к общей папке. После заполнения кэша, все вызовы на просмотр SID учетной записи сначала направляются в кэш банка данных. Если в кэше банка данных не содержится идентификатора SID, запрос поступает контроллеру домена, а затем эти сведения добавляются в кэш.

По умолчанию кэш поддерживается один час. Если размер кэша превысит 8 килобайтов (КБ) по умолчанию, старые записи кэша удаляются и предоставляется место для новых записей. Можно использовать два раздела реестра, чтобы настроить время кэша по умолчанию (Lookup Sid Cache Expire) и размер кэша по умолчанию (Lookup Sid Cache Size). Рекомендуется не изменять эти два параметра, если нет уверенности, что эти изменения приведут к увеличению производительности.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы восстановить конфигурацию по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. В правой области найдите и удалите значение Lookup Sid Cache Size. Если также настроено значение параметра Lookup SID Cache Expire, удалите и его.

  4. Выйдите из редактора реестра и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о значении реестра Lookup Sid Cache Size см. в статье 328907 базы знаний Майкрософт, посвященной низкой производительности общих папок, вызванной обновлениями списка управления доступа папки, для устранения которой требуется Exchange 2000 с пакетом обновления 2 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328907).


Ошибка недостаточности виртуальной памяти была изменена
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server читает следующую строку реестра для определения того, был ли порог регистрации в журнале события фрагментации виртуальной памяти изменен вручную:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\VM Error Level

Если средство анализа Exchange Server обнаруживает, что параметр реестра VM Error Level существует и настроен, появляется сообщение о нестандартной конфигурации.

В 32-разрядных версиях операционных систем Microsoft Windows® существует два вида памяти: адресное пространство физической (фактическое количество установленной в системе памяти) и виртуальной (виртуализированное адресной пространство объемом 4 Гб) памяти. Независимо от объема установленной в системе физической памяти, общий размер виртуального адресного пространства всегда одинаковый: 4 ГБ. Хотя это не обязательно для 32-разрядных приложений, в случае Exchange Server размер виртуального адресного пространства равен размеру виртуальной памяти; другими словами, термины используются равнозначно.

При обычной работе банк сообщений Exchange многократно распределяет, использует и отменяет распределение виртуальной памяти. Частое распределение, использование и отмена распределения виртуальной памяти может привести к фрагментации виртуальной памяти. Фрагментация виртуальной памяти аналогична фрагментации файловой системы, которая может со временем происходить. Через некоторое время распределенные сегменты виртуальной памяти перестанут распологаться непрерывно, это повлияет на производительность. В случае файловой системы можно запустить приложение дефрагментации, и в большинстве случаев это можно сделать, когда система работает и доступна. Для дефрагментации виртуальной памяти подобное приложение отсутствует; вместо этого для устранения неполадки необходимо остановить, а потом запустить службу Microsoft Exchange Information Store или перезагрузить систему.

Если на компьютере с установленным Exchange Server менее 16 МБ непрерывного виртуального адресного пространства, в журнале событий приложения регистрируется следующее сообщение об ошибке:

Источник: | MSExchangeIS
Категория: | Производительность
Идентификатор: | 9582
Тип: | Ошибка
Описание: | Виртуальная память, необходимая для запуска Exchange server, фрагментирована настолько, что нормальная работа может быть невозможна. Для устранения этой неполадки рекомендуется перезапустить все службы Exchange.

Параметр реестра VM Error Level соответствует возможности конфигурации, позволяющей администратору изменять предупреждение уровня в 16 МБ по умолчанию и устанавливать другое значение.

Важно!
В этой статье содержатся сведения о редактировании реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Для получения сведений о восстановлении реестра см. разделе «Восстановление реестра» справочной системы файла Regedit.exe или Regedt32.exe.

Восстановление настройки по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. В правой области удалите значение параметра VM Error Level.

  4. Закройте редактор реестра и перезагрузите службу Microsoft Exchange Information Store, чтобы изменения вступили в силу.

Дополнительные сведения об устранении фрагментации виртуальной памяти в Exchange Server 2003 и Exchange 2000 Server см. в статье 325044 базы знаний корпорации Майкрософт «ИНСТРУКЦИИ: Устранение фрагментации виртуальной памяти в Exchange 2003 и Exchange 2000» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044).


Перезаписано событие предупреждения, в котором сообщается о нехватке виртуальной памяти
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Server считывает следующий параметр реестра, чтобы определить, был ли вручную перезаписан порош для записи в журнал события, касающегося фрагментации виртуальной памяти:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\VM Warning Level

Если анализатор сервера Exchange Server обнаружит, что значение реестра VM Warning Level имеется и является настроенным, отображается сообщение о нестандартной настройке.

В 32-разрядных системах Microsoft Windows® имеется два типа памяти: физическая память (объем памяти, фактически установленной на компьютере) и адресное пространство виртуальной памяти (пространство виртуальной памяти объемом 4 ГБ). Независимо от объема физической памяти, установленной на компьютере, общий объем адресного пространства виртуальной памяти, всегда остается одним и тем же: 4 ГБ. В случае Exchange Server виртуальное адресное пространство равняется виртуальной памяти; иными словами, эти термины являются взаимозаменяемыми. Сказанное, однако, не является справедливым для всех 32-разрядных приложений.

В обычном режиме работы база данных Exchange неоднократно осуществляет распределение, использование и перераспределение виртуальной памяти. Когда циклы распределения, использования и перераспределения виртуальной памяти осуществляются часто, это может привести к фрагментации виртуальной памяти. Фрагментации виртуальной памяти аналогична фрагментации файловой системы, которая может происходить с течением времени. По прошествии некоторого времени распределенные сегменты виртуальной памяти перестают быть непрерывными, что отрицательно сказывается на производительности системы. В случае файловой системы можно запустить приложение, выполняющее дефрагментацию файлов. Вообще говоря, это можно делать, когда система работает в интерактивном режиме и является доступной. Средство, с помощью которого можно выполнить дефрагментацию виртуальной памяти, отсутствует. Чтобы устранить эту неполадку, следует остановить и снова запустить службу банка данных Microsoft Exchange или перезагрузить систему.

По умолчанию, если на компьютере Exchange Server имеется менее 32 МБ свободного непрерывного виртуального адресного пространства, в журнал событий приложения записывается следующее предупреждение:

Источник: | MSExchangeIS
Категория: | Производительность
Идентификатор | 9582
Тип: | Предупреждение
Описание: | Фрагментация виртуальной памяти, необходимой для запуска сервера Exchange, может повлиять на его производительность. Для решения этой проблемы настоятельно рекомендуется перезапустить все службы Exchange.

Значение реестра VM Warning Level предоставляет возможности для настройки, позволяющие администратору заменить 32-мегабайтный уровень предупреждения и задать для него новое значение.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неполадок. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы вернуться к настройкам по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. В правой области удалите значение для VM Warning Level.

  4. Закройте редактор реестра и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Дополнительные сведения об устранении неполадок, связанных с фрагментацией виртуальной памяти в Exchange Server 2003 и Exchange 2000 Server см. в базе знаний Майкрософт в статье в статье 325044, посвященной этой теме (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044).


Установлен предел времени хранения в кэше почтового ящика
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-15

Анализатор рекомендаций Microsoft® Exchange Server проверяет реестр сервера Exchange Server на наличие в нем параметра Mailbox Cache Age Limit. Эта запись размещается в следующем разделе реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Если в реестре есть параметр Mailbox Cache Age Limit со значением 1 или более высоким, то отображается сообщение о нестандартной конфигурации.

Сервер Exchange позволяет устанавливать для почтовых ящиков ограничения размеров (квоты). Параметры квот хранятся в службе каталогов Active Directory®, сервер Exchange периодически считывает данные в Active Directory, чтобы определить, изменены ли эти ограничения. По умолчанию эти данные помещаются в кэш Exchange Server на срок два часа (120 минут), после чего эти данные повторно считываются из Active Directory.

Параметр реестра Mailbox Cache Age Limit, выраженный в минутах, позволяет переопределить установленный по умолчанию период времени. Это особенно полезно в ситуации, когда пользователи не могут получить доступ к своим почтовым ящикам в связи с тем, что достигнуты ограничения для этих почтовых ящиков. Если действует заданное по умолчанию ограничение срока хранения в кэше, пользователь не сможет получить доступ к своему почтовому ящику до истечения двух часов. Рекомендованное значение составляет 20 минут. Не следует устанавливать слишком маленькое значение, так как это может привести к падению производительности.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы вернуться к конфигурации по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в следующий раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. На панели справа найдите и удалите значение Mailbox Cache Age Limit.

  4. Чтобы изменения вступили в силу, закройте редактор реестра и перезапустите службу Банк данных Microsoft Exchange.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения об использовании параметра реестра Mailbox Cache Age Limit см. статью 327378 базы знаний Майкрософт «XADM: Exchange 2000 and Exchange Server 2003 Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time; Fix Requires Exchange 2000 SP3» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378).


Установлен предел времени хранения в кэше почтового ящика
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, установлен ли предел времени хранения в кэше почтового ящика, анализатор сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Если анализатор сервера Exchange обнаруживает, что параметр Mailbox Cache Idle Limit существует, выводится сообщение о наличии конфигурации, не являющейся заданной по умолчанию.

Сервер Exchange позволяет устанавливать для почтовых ящиков ограничения размеров (квоты). Настройки квоты хранятся в службе каталогов Active Directory®, и сервер Exchange периодически считывает информацию в Active Directory, чтобы выявить изменения, внесенные в эти пределы. Сервер Exchange кэширует эти данные в течение определенного времени, после чего вновь считывает информацию в Active Directory.

Параметры Mailbox Cache Age Limit и Mailbox Cache Idle Limit управляют длительностью хранения записей в кэше данных почтового ящика. Элемент удаляется из кэша после пребывания в нем в течение времени (в секундах), заданного параметром Mailbox Cache Age Limit. Если элемент не используется в течение времени (в секундах), заданного параметром Mailbox Cache Idle Limit, он также будет удален из кэша. Значения по умолчанию для этих параметров — 7200 секунд (120 минут) для Mailbox Cache Age Limit и 900 секунд (15 минут) для Mailbox Cache Idle Limit. Значение параметра Mailbox Cache Idle Limit не должно превышать значение Mailbox Cache Age Limit.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы восстановить конфигурацию по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem.

  3. В правой области найдите и удалите значение Mailbox Cache Idle Limit.

  4. Закройте редактор реестра и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт "Description of the Microsoft Windows Registry" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Для получения дополнительных сведений о параметре реестра Mailbox Cache Age Limit см. статью базы знаний 327378 «XADM: Exchange 2000 Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time; Fix Requires Exchange 2000 SP3» (Предел размера почтового ящика для Exchange 2000 не действует в течение допустимого промежутка времени; для обновления требуется Exchange 2000 SP3) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378).


Установлен размер кэша почтового ящика
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server считывает следующий раздел реестра, чтобы установить, существует ли параметр Mailbox Cache Size:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Если анализатор обнаружит, что в реестре существует параметр Mailbox Cache Size, появится сообщение о том, что настройка отлична от настройки по умолчанию.

Параметр Mailbox Cache Size управляет размером кэша данного почтового ящика. Значение по умолчанию — 256 Мбайт (МБ). Exchange Server позволяет устанавливать ограничения (квоты) для почтовых ящиков. Параметры квот хранятся в службе каталога Active Directory®, и Exchange Server периодически считывает информацию из Active Directory, чтобы определить, не были ли изменены ограничения. По умолчанию Exchange Server кэширует эту информацию за двухчасовой период (7200 секунд), после чего он считывает информацию из Active Directory заново.

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Для получения сведений о восстановлении реестра см. разделе «Восстановление реестра» справочной системы файла Regedit.exe или Regedt32.exe.

Восстановление настройки по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. В правой панели найдите и удалите значение Mailbox Cache Size.

  4. Закройте программу и перезапустите службу Microsoft Exchange Information Store, чтобы изменения вступили в силу.

Перед правкой реестра, а также для получения сведений о правке реестра просмотрите статью 256986 базы знаний корпорации Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Для получения дополнительных сведений о параметре реестра Mailbox Cache Age Limit см. статью 327378 базы знаний корпорации Майкрософт «XADM: Ограничения размера почтового ящика в Exchange 2000 не применяются своевременно; для исправления требуется пакет обновления 3 (SP3) для Exchange 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378).


Установлен размер кэша почтового ящика, равный нулю
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить значение размера кэша почтового ящика, анализатор сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Если анализатор сервера Exchange обнаруживает, что для параметра реестра «Mailbox Cache Size» установлено значение 0, выводится сообщение об ошибке.

В Exchange Server можно устанавливать ограничения размера (квоты) почтовых ящиков. Параметры квот хранятся в службе каталогов Active Directory®, сервер Exchange периодически считывает данные в Active Directory, чтобы определить, изменены ли эти ограничения. Значение «Mailbox Cache Size» управляет размером кэша почтового ящика. Значение по умолчанию — 256 МБ. Если установлено значение 0, кэш почтового ящика отключен. Не рекомендуется устанавливать значение 0, так как при этом компонент DSAccess будет чаще выполнять запросы Active Directory. Кроме того, если это значение равняется 0, могут возникнуть сбои в работе хранилища Exchange или в ходе перемещения почтовых ящиков.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы устранить эту ошибку

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. В правой области найдите и удалите значение «Mailbox Cache Size».

  4. Закройте редактор реестра и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Для получения дополнительных сведений об использовании значения реестра «Mailbox Cache Age Limit» см. статью 327378 базы знаний Майкрософт «XADM: Exchange 2000 Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time; Fix Requires Exchange 2000 SP3» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378) (XADM: ограничения на размер почтового ящика Exchange 2000 не применяются в течение длительного времени; для устранения этой неполадки требуется наличие Exchange 2000 с пакетом обновления 3).


Хранилище почтовых ящиков управляется с использованием политики
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2006-06-06

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchPolicyList для каждого объекта хранилища почтовых ящиков. Атрибут msExchPolicyList определяет, назначена ли для хранилища почтовых ящиков политика почтовых ящиков Exchange Server. Если анализатор сервера Exchange обнаруживает, что установлен атрибут msExchPolicyList , выводится сообщение о том, что текущая конфигурация отличается от заданной по умолчанию.

По умолчанию при создании хранилищ почтовых ящиков для них не назначаются политики почтовых ящиков. Однако в большинстве случаев администраторы самостоятельно создают политики почтовых ящиков и назначают их для нескольких хранилищ. Эти политики позволяют применять такие параметры администрирования, как максимальный размер хранилища, обновления индексации, интервалы обслуживания, сопоставление с общими хранилищами и автономными списками адресов. Если для хранилища почтовых ящиков назначена одна из созданных политик почтовых ящиков, анализатор сервера Exchange выводит сообщение о том, что в данное хранилище почтовых ящиков в настоящий момент управляется с использованием политики почтовых ящиков. Не нужно выполнять никаких действий.

Чтобы удалить политику почтовых ящиков из хранилища почтовых ящиков

  1. Откройте системный диспетчер Exchange и раскройте в дереве консоли узел Группы администрирования.

  2. Раскройте узел Первая группа администрирования и выберите параметр Системные политики.

  3. В области результатов щелкните правой кнопкой мыши нужное хранилище почтовых ящиков и выберите команду Удалить из политики.

  4. В окне системного диспетчера Exchange нажмите кнопку Да, чтобы подтвердить удаление данного хранилища почтовых ящиков.
Примечание.
Если узел «Системные политики» не отображается в дереве консоли в системном диспетчере Exchange, настройте системный диспетчер Exchange таким образом, чтобы отображались группы администрирования.

Дополнительные сведения о политиках почтовых ящиков см. в следующих статьях базы знаний Майкрософт:

  • 822938, «How To: Use System Policies to Configure Mailbox Storage Limits in Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822938) (Инструкции по настройке размера хранилищ почтовых ящиков в Exchange Server 2003 с использованием системных политик).

  • 256141, «How to Create System Policies in Exchange» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256141) (Инструкции по созданию системных политик в Exchange)

Дополнительные сведения о файлах базы данных сервера Exchange см. в следующих разделах справки Exchange Server 2003:

  • «Managing Mailbox Stores and Public Folder Stores» (Управление хранилищами почтовых ящиков и хранилищами общих папок) в руководстве Administration Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617) (Руководство по администрированию Exchange Server 2003).

  • «Understanding the Exchange Server 2003 Store» (Общее представление о хранилищах Exchange Server 2003) в материале Working with Exchange Server 2003 Stores (http://go.microsoft.com/fwlink/?LinkId=47595) (Работа с хранилищами Exchange Server 2003).


Файл базы данных хранилища почтовых ящиков находится на сетевом диске
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить значение атрибута msExchEDBFile для каждого объекта хранилища почтовых ящиков, анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®. Этот атрибут задает местоположение файлов базы данных, используемых этим хранилищем почтовых ящиков.

Помимо этого, анализатор сервера Exchange запрашивает службу Active Directory, чтобы определить значение счетчика записей, перечисленных в атрибуте homeMDBBL каждого хранилища почтовых ящиков на данном сервере. Счетчик этого атрибута отражает количество почтовых ящиков в хранилище почтовых ящиков. После этого анализатор сервера Exchange сможет рассчитать общее количество почтовых ящиков, управляемых сервером.

Если анализатор сервера Exchange обнаруживает, что атрибут msExchEDBFile на сервере Exchange с более чем 50 почтовых ящиков начинается с \\, возвращается ошибка.

Эта ошибка означает, что файлы базы данных для хранилища почтовых ящиков хранятся на общем сетевом ресурсе. Если атрибут msExchEDBFile начинается с \\, это означает, что путь журнала указан с использованием универсального соглашения об именах (UNC). Это не рекомендуется, поскольку прерывания сетевой доступности могут вызвать ошибки в базе данных, что приведет к потерям данных или разрушению базы данных. Эту проблему следует исправить как можно скорее.

Чтобы переместить файлы базы данных на другой диск

  1. В системном диспетчере Exchange разверните объект-сервер Exchange, на котором находится хранилище, разверните соответствующий контейнер группы хранения, щелкните правой кнопкой мыши нужный объект хранилища почтовых ящиков и в контекстном меню выберите Свойства.

  2. На вкладке База данных диалогового окна Свойства укажите новые местоположения файлов.

Дополнительные сведения о файлах базы данных сервера Exchange см. в следующих разделах:

  • «Управление хранилищами почтовых ящиков и хранилищами общих папок» в Руководстве администратора сервера Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617) (может быть на английском языке);

  • «Общие сведения о хранилищах Exchange Server 2003» в руководстве Работа с хранилищами Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595) (может быть на английском языке).

Для получения дополнительных сведений об использовании сервера Exchange Server с сетевыми дисками см. следующие статьи базы знаний корпорации Майкрософт:

  • 328879 — описывается использование сервера Exchange с сетями областей хранения и подключаемыми сетевыми хранилищами (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328879) (может быть на английском языке);

  • 839687 — описывается политика поддержки корпорацией Майкрософт использования подключаемых сетевых хранилищ с Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839687) (может быть на английском языке);

  • 317173 — описывается взаимодействие сервера Exchange с подключаемым сетевым хранилищем (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317173) (может быть на английском языке);

  • 317172 — описывается взаимодействие сервера Exchange 5.5 с подключаемым сетевым хранилищем (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317172) (может быть на английском языке.


Установлен предельный размер базы данных хранилища почтовых ящиков
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Средство анализатора сервера The Microsoft® Exchange считывает следующий параметр реестра, чтобы определить, имеется ли значение Database Size Limit in Gb реестра и настроено ли оно для базы данных хранилища почтовых ящиков:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

Если анализатор сервера Exchange Server обнаружит, что значение Database Size Limit in Gb имеется и настроено соответствующим образом, то отобразит сообщение о нестандартной настройке.

Когда пакет обновления 2 (SP2) для Exchange Server 2003 применяется к Exchange Server 2003 Standard Edition, жестко закодированный предельный размер лицензируемой базы данных увеличивается с 16 ГБ до 75 ГБ. Можно задать предельный размер базы данных в качестве предупредительной меры, чтобы не допустить неконтролируемого роста размера базы данных. Значение по умолчанию предельного размера в пакете обновления 2 (SP2) составляет 18 ГБ, и это значение по умолчанию может быть заменено посредством создания значения Database Size Limit in Gb реестра.

Жестко заданное в Exchange Server 2007 Standard Edition ограничение предельного размера лицензируемой базы данных в 50 ГБ также можно увеличить, создав параметр реестра Database Size Limit in Gb.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неполадок. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы вернуться к настройкам по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Удалите значение Database Size Limit in Gb.

  4. Закройте редактор реестра.

Перед изменением реестра ознакомьтесь с тем, как следует выполнять эту процедуру. Описание соответствующих инструкций содержится в статье базы знаний Майкрософт 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о пакете обновления 2 (SP2) для Exchange Server 2003 см. на веб-узле пакета обновления 2 (SP2) для Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=52073).


Хранилище почтовых ящиков не имеет связанного с ним хранилища общих папок по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Server запрашивает службу каталогов Active Directory®, чтобы определить, имеет ли атрибут msExchPrivateMDB хранилище общих папок по умолчанию, назначенное хранилищу почтовых ящиков.

Атрибут msExchPrivateMDB является конфигурации частной базы данных для объекта хранилищ почтовых ящиков. По умолчанию атрибут msExchHomePublicMDB связан с хранилищем почтовых ящиков. Атрибут msExchPrivateMDB является домашней общей базой данных сообщений (MDB).

Если анализатор сервера Exchange Server обнаружит, что атрибут msExchHomePublicMDB удален или настроен неправильно, то отобразит сообщение об ошибке.

Каждое хранилище почтовых ящиков должно быть связано с хранилищем общих папок по умолчанию либо на локальном сервере, либо на другом сервере. Для каждого пользователя с включенным почтовым ящиком, поддерживаемого конкретным хранилищем почтовых ящиков, связанное хранилище общих папок является для этого пользователя домашним хранилищем общих папок. Если возможно, используйте хранилище общих папок по умолчанию на том же сервере, на котором находится хранилище почтовых ящиков.

Примечание.
Использование хранилища общих папок по умолчанию на том же сервере, на котором находится хранилище почтовых ящиков, позволяет увеличить производительность при доступе пользователей к общим папкам, а также упрощает устранение неполадок доступа к общим папкам.
Чтобы назначить хранилище общих папок по умолчанию хранилищу папок

  1. В окне Диспетчер Exchange щелкните правой кнопкой мыши группу хранилищ, в которой находится Хранилище папок.

  2. Щелкните правой кнопкой мыши это хранилище папок, а затем выберите Свойства.

  3. На вкладке «Общие» в разделе Хранилище общих папок по умолчанию щелкните Обзор и выберите хранилище общих папок, которое требуется связать с данным хранилищем почтовых ящиков.

    Примечание.
    Если выполняется создание нового хранилища почтовых ящиков, Exchange Server автоматически выбирает хранилище общих папок по умолчанию, связанное с деревом общих папок, и автономную адресную книгу, которую пользователи будут загружать для автономного использования.

Дополнительные сведения об управлении хранилищами почтовых ящиков и хранилищами общих папок см. в руководстве по администрированию Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47617).


Объем хранилища почтовых ящиков превышает 12 ГБ
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2006-02-28

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_DataFile, чтобы определить значение ключа FileSize для каждого файла потокового формата (с расширением STM) и файла (с расширением EDB) базы данных хранилища почтовых ящиков. Чтобы определить версию установленного сервера Exchange, анализатор сервера Exchange также считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<Exchange Product GUID>

Если анализатор сервера Exchange обнаруживает, что суммарный размер базы данных хранилища почтовых ящиков и файлов потокового формата превышает 12 ГБ на компьютере, на котором выполняется Microsoft Exchange Server 2003 Standard Edition или Microsoft Exchange 2000 Server Standard Edition, на экран выводится предупреждение.

Базы данных хранилища Exchange в приложениях Exchange Server 2003 Standard Edition и Exchange 2000 Server Standard Edition не могут увеличиваться свыше 16 ГБ. После того как достигнут этот предел, хранилище почтовых ящиков перестает быть подключенным, и приложение Exchange становится недоступным. Базы данных хранилища Exchange в приложениях Exchange Server 2003 Enterprise Edition и Exchange 2000 Server Enterprise Edition не ограничены размером 16 ГБ; они ограничены только возможностями оборудования, причем теоретический максимальный размер равен 16 терабайтам.

Чтобы устранить причину появления этого предупреждения

  1. Рассмотрите возможность перемещения некоторых почтовых ящиков из большого хранилища почтовых ящиков в новое хранилище почтовых ящиков на этом или другом компьютере сервера Exchange.

  2. Если недавно выполнялось перемещение почтовых ящиков из этого банка данных в другое хранилище, или если недавно удалялись почтовые ящики из этого хранилища почтовых ящиков, выполнение автономной дефрагментации может привести к уменьшению общего размера файлов.

  3. Рассмотрите возможность установки пределов на объем почтового ящика и размер сообщений, чтобы предотвратить неограниченное увеличение хранилища почтовых ящиков.
Примечание.
С выпуском пакета обновления 2 (SP2) Exchange Server 2003 жестко закодированный предельный размер лицензируемой базы данных в Exchange Server 2003 Standard Edition увеличился с 16 ГБ до 75 ГБ. Администратор имеет возможность установить предохранительный предел на размер базы данных (предотвращающий ненамеренное увеличение размера базы данных). Значение по умолчанию равно 18 ГБ в пакете обновления SP2 для выпуска Standard Edition, причем значение по умолчанию, равное 18 ГБ, можно переопределить путем изменения в реестре параметра Предельный размер базы данных в ГБ.
Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы установить предельный размер базы данных с пакетом обновления 2 (SP2) Exchange Server 2003

  1. На компьютере, на котором выполняется сервер Exchange, запустите редактор реестра, Regedit.exe.

  2. Откройте следующий раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\Имя сервера\Идентификатор GUID частного хранилища почтовых ящиков

  3. Щелкните правой кнопкой мыши Идентификатор GUID частного хранилища, наведите указатель на пункт Создать и выберите Значение DWORD.

  4. В качестве имени нового значения введите Предельный размер базы данных в ГБ.

  5. Дважды щелкните Предельный размер базы данных в ГБ. В поле Значение введите соответствующее значение максимального размера базы данных, выраженное в ГБ. Для приложения Exchange Server 2003 Standard Edition введите десятичное значение в диапазоне от 1 до 75 (значение по умолчанию — 18 ГБ). Для приложения Exchange Server 2003 Enterprise Edition введите десятичное значение в диапазоне от 1 до 8000 (значение по умолчанию — 8000 ГБ). Нажмите кнопку ОК.

  6. Щелкните правой кнопкой мыши Идентификатор GUID частного хранилища, наведите указатель на пункт Создать и выберите Значение DWORD.

  7. В качестве имени нового значения введите Ограничитель размера базы данных в процентах.

  8. Дважды щелкните Ограничитель размера базы данных в процентах. В поле Значение введите десятичное значение в диапазоне между 1 и 100, чтобы указать, когда в журнал должны заноситься события, предупреждающие о приближении к максимальному размеру базы данных. Значение по умолчанию, равное 10, приведет к записи в журнал предупреждающих сообщений, когда до достижения максимального размера этой базы данных останется 10 процентов её предельного объема. Нажмите кнопку ОК.

  9. Щелкните правой кнопкой мыши Идентификатор GUID частного хранилища, наведите указатель на пункт Создать и выберите Значение DWORD.

  10. В качестве имени нового значения введите Время начала проверки размера базы данных, выраженное в часах после полуночи.

  11. Дважды щелкните Время начала проверки размера базы данных, выраженное в часах после полуночи. В поле Значение введите значение в диапазоне между 0 и 23, чтобы указать, когда размер базы данных должен контролироваться приложением Exchange. Значение по умолчанию, равное 5, приведет к контролю сервером Exchange размера базы данных спустя 5 часов после полуночи (5:00). Нажмите кнопку ОК.

  12. Закройте редактор реестра.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о файлах с расширениями STM и EDB см. в базе знаний Майкрософт в статье 232323, описывающей собственное хранилище содержимого в Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323).

Дополнительные сведения о перемещении почтовых ящиков в Exchange Server 2003 см. в базе знаний Майкрософт в статье 821829, описывающей перемещение почтовых ящиков в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

Дополнительные сведения о перемещении почтовых ящиков в Exchange 2000 Server см. в базе знаний Майкрософт в статье 328810, описывающей перемещение почтовых ящиков между серверами (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810).

Дополнительные сведения о выполнении автономной дефрагментации базы данных сервера Exchange см. в базе знаний Майкрософт в статье 328804, описывающей порядок дефрагментации баз данных Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804).

Дополнительные сведения об установке пределов на размер сообщений см. в базе знаний Майкрософт в статье 322679, описывающей порядок установки пределов на размеры сообщений (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679).

Сведения о достижении максимального размера базы данных в приложениях Exchange Server 2003 Standard Edition и Exchange 2000 Server Standard Edition см. в базе знаний Майкрософт в статье 828070, описывающей причины, почему хранилище почтовых ящиков сервера Exchange не подключается, когда база данных хранилища почтовых ящиков достигает предела в 16 ГБ (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070).

Дополнительные сведения о пакете обновления 2 (SP2) для Exchange Server 2003 см. на веб-узле пакета обновления 2 (SP2) Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=52073).


Объем хранилища почтовых ящиков превышает 15 ГБ
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2006-02-28

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_DataFile, чтобы определить значение ключа FileSize для каждого файла потокового формата (с расширением STM) и файла (с расширением EDB) базы данных хранилища почтовых ящиков. Чтобы определить версию установленного сервера Exchange, анализатор сервера Exchange также считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<идентификатор GUID продукта Exchange>

Если анализатор сервера Exchange обнаруживает, что суммарный размер базы данных хранилища почтовых ящиков и файлов потокового формата превышает 15 ГБ на компьютере, на котором выполняется Microsoft Exchange Server 2003 Standard Edition или Microsoft Exchange 2000 Server Standard Edition, на экран выводится сообщение об ошибке.

Базы данных хранилища Exchange в приложениях Exchange Server 2003 Standard Edition и Exchange 2000 Server Standard Edition не могут увеличиваться свыше 16 ГБ. После того как достигнут этот предел, хранилище почтовых ящиков перестает быть подключенным, и приложение Exchange становится недоступным. Базы данных хранилища Exchange в приложениях Exchange Server 2003 Enterprise Edition и Exchange 2000 Server Enterprise Edition не ограничены размером 16 ГБ; они ограничены только возможностями оборудования, причем теоретический максимальный размер равен 16 терабайтам.

Чтобы устранить эту ошибку

  1. Рассмотрите возможность перемещения некоторых почтовых ящиков из большого хранилища почтовых ящиков в новое хранилище почтовых ящиков на этом или другом компьютере сервера Exchange.

  2. Если недавно выполнялось перемещение почтовых ящиков из этого банка данных в другое хранилище, или если недавно удалялись почтовые ящики из этого хранилища почтовых ящиков, выполнение автономной дефрагментации может привести к уменьшению общего размера файлов.

  3. Рассмотрите возможность установки пределов на объем почтового ящика и размер сообщений, чтобы предотвратить неограниченное увеличение хранилища почтовых ящиков.
Примечание.
С выпуском пакета обновления 2 (SP2) Exchange Server 2003 жестко закодированный предельный размер лицензируемой базы данных в Exchange Server 2003 Standard Edition увеличился с 16 ГБ до 75 ГБ. Администратор имеет возможность установить предохранительный предел на размер базы данных (предотвращающий ненамеренное увеличение размера базы данных). Значение по умолчанию равно 18 ГБ в пакете обновления SP2 для выпуска Standard Edition, причем значение по умолчанию, равное 18 ГБ, можно переопределить путем изменения в реестре параметра Предельный размер базы данных в ГБ.
Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы установить предельный размер базы данных с пакетом обновления 2 (SP2) Exchange Server 2003

  1. На компьютере, на котором выполняется сервер Exchange, запустите редактор реестра, Regedit.exe.

  2. Откройте следующий раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\Имя сервера\Идентификатор GUID частного хранилища почтовых ящиков

  3. Щелкните правой кнопкой мыши Идентификатор GUID частного хранилища, наведите указатель на пункт Создать и выберите Значение DWORD.

  4. В качестве имени нового значения введите Предельный размер базы данных в ГБ.

  5. Дважды щелкните Предельный размер базы данных в ГБ. В поле Значение введите соответствующее значение максимального размера базы данных, выраженное в ГБ. Для приложения Exchange Server 2003 Standard Edition введите десятичное значение в диапазоне от 1 до 75 (значение по умолчанию — 18 ГБ). Для приложения Exchange Server 2003 Enterprise Edition введите десятичное значение в диапазоне от 1 до 8000 (значение по умолчанию — 8000 ГБ). Нажмите кнопку ОК.

  6. Щелкните правой кнопкой мыши Идентификатор GUID частного хранилища, наведите указатель на пункт Создать и выберите Значение DWORD.

  7. В качестве имени нового значения введите Ограничитель размера базы данных в процентах.

  8. Дважды щелкните Ограничитель размера базы данных в процентах. В поле Значение введите десятичное значение в диапазоне между 1 и 100, чтобы указать, когда в журнал должны заноситься события, предупреждающие о приближении к максимальному размеру базы данных. Значение по умолчанию, равное 10, приведет к записи в журнал предупреждающих сообщений, когда до достижения максимального размера этой базы данных останется 10 процентов её предельного объема. Нажмите кнопку ОК.

  9. Щелкните правой кнопкой мыши Идентификатор GUID частного хранилища, наведите указатель на пункт Создать и выберите Значение DWORD.

  10. В качестве имени нового значения введите Время начала проверки размера базы данных, выраженное в часах после полуночи.

  11. Дважды щелкните Время начала проверки размера базы данных, выраженное в часах после полуночи. В поле Значение введите значение в диапазоне между 0 и 23, чтобы указать, когда размер базы данных должен контролироваться приложением Exchange. Значение по умолчанию, равное 5, приведет к контролю сервером Exchange размера базы данных спустя 5 часов после полуночи (5:00). Нажмите кнопку ОК.

  12. Закройте редактор реестра.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о файлах с расширениями STM и EDB см. в базе знаний Майкрософт в статье 232323, описывающей собственное хранилище содержимого в Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323).

Дополнительные сведения о перемещении почтовых ящиков в Exchange Server 2003 см. в базе знаний Майкрософт в статье 821829, описывающей перемещение почтовых ящиков в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

Дополнительные сведения о перемещении почтовых ящиков в Exchange 2000 Server см. в базе знаний Майкрософт в статье 328810, описывающей перемещение почтовых ящиков между серверами (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810).

Дополнительные сведения о выполнении автономной дефрагментации базы данных сервера Exchange см. в базе знаний Майкрософт в статье 328804, описывающей порядок дефрагментации баз данных Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804).

Дополнительные сведения об установке пределов на размер сообщений см. в базе знаний Майкрософт в статье 322679, описывающей порядок установки пределов на размеры сообщений (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679).

Сведения о достижении максимального размера базы данных в приложениях Exchange Server 2003 Standard Edition и Exchange 2000 Server Standard Edition см. в базе знаний Майкрософт в статье 828070, описывающей причины, почему хранилище почтовых ящиков сервера Exchange не подключается, когда база данных хранилища почтовых ящиков достигает предела в 16 ГБ (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070).

Дополнительные сведения о пакете обновления 2 (SP2) для Exchange Server 2003 см. на веб-узле пакета обновления 2 (SP2) Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=52073).


Последнее полное резервное копирование хранилища почтовых ящиков проводилось более чем 8 дней назад
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Для определения даты и времени последнего полного резервного копирования анализатор рекомендаций сервера Exchange Server направляет запрос в каждое хранилище почтовых ящиков. Для определения числа пользователей с почтовыми ящиками в каждом хранилище почтовых ящиков Exchange Server Analyzer также направляет запрос службе каталогов Active Directory®. Анализатор рекомендаций Exchange Server отображает предупреждение, если выполняются оба следующие условия:

  • Число дней со времени проведения последнего полного резервного копирования больше восьми.

  • В хранилище почтовых ящиков более 10 почтовых ящиков.

Хранилище почтовых ящиков является базой данных для хранения почтовых ящиков в Microsoft Exchange Server 2003 и Exchange Server 2007. Хранилище почтовых ящиков состоит из файла форматированного текста (EDB-файла) и файла потокового содержимого Интернета (STM-файла). EDB- и STM-файлы представляют части одной, а не отдельных баз данных.

Резервное копирование данных хранилища почтовых ящиков и общих папок баз данных Exchange Server и файлов журналов транзакций должно быть выполнено в организации Exchange Server в первую очередь. Можно использовать резервную копию базы данных Exchange Server для восстановления поврежденного почтового ящика на работающем сервере, использующем Exchange Server. Резервные копии баз данных Exchange Server могут быть использованы также для восстановления баз данных Exchange Server на других серверах.

Рекомендуется выполнять полное резервное копирование файлов базы данных и журналов транзакций каждый день. После завершения резервного копирования группы хранилищ переданные файлы журнала транзакций базы данных Exchange Server удаляются с сервера. Полное резервное копирование дает преимущество в скорости при восстановлении, так как для восстановления данных требуется только одна лента.

Примечание.
Рекомендуется хранить файлы журналов транзакций на специальном диске отдельно от файлов базы данных. Это повышает отказоустойчивость в случае разрушения диска базы данных и в некоторых случаях повышает производительность базы данных.
Важно!
Учетной записи пользователя должны быть предоставлены необходимые разрешения или права, чтобы пользователь мог создавать резервные копии файлов и папок, а также восстанавливать данные из этих резервных копий. Для создания резервных копий Exchange Server необходимо иметь права оператора архива на уровне домена. Чтобы создать резервные копии операционной системы Microsoft Windows Server™ 2003, необходимо как минимум обладать правами локального оператора архива.

Выбор стратегии резервного копирования данных Exchange Server зависит от размеров хранилищ, быстродействия программного обеспечения и оборудования для резервного копирования, производительности оборудования и требуемого времени.

Дополнительные сведения о стратегиях резервного копирования и операциях аварийного восстановления см. в документах

  • Exchange Server 2003 Disaster Recovery Operations Guide (http://go.microsoft.com/fwlink/?LinkId=47570) (Руководство по операциям аварийного восстановления Exchange Server 2003).

  • Database Backup and Restore (http://go.microsoft.com/fwlink/?LinkId=80766) (Резервное копирование и восстановление баз данных).


Для хранилища почтовых ящиков не была проведена полная архивация в течение более чем 60 дней
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Средство анализатора сервера Microsoft® Server запрашивает хранилище почтовых ящиков, чтобы определить дату и время последнего выполнения полной архивации. Анализатор сервера Exchange Server также запрашивает службу каталогов Active Directory®, чтобы определить количество пользователей, имеющих почтовые ящики в каждом хранилище почтовых ящиков. Анализатор сервера Exchange Server отображает сообщение об ошибке, если одновременно выполняются следующие два условия:

  • Прошло более 60 дней после последнего выполнения полной архивации.

  • В хранилище почтовых ящиков имеется более 10 почтовых ящиков.

Хранилище почтовых ящиков является базой данных для хранения почтовых ящиков в Microsoft Exchange Server 2003 и Microsoft Exchange Server 2007. Хранилище почтовых ящиков состоит из файла с форматированным текстом (EDB-файл) и потокового файла содержимого Интернета (STM-файл). Хотя в нем имеется два файла, EDB-файл и STM-файл, они представляет собой две половины единой базы данных, а не две отдельных базы данных.

Данные хранилища почтовых ящиков и хранилища общих папок в базах данных сервера Exchange и файлах журнала транзакций — самые важные данные, которые нужно архивировать в организации сервера Exchange Server. Архивную копию базы данных Exchange может использоваться для восстановления поврежденного почтового ящика на работающем сервере с сервером Exchange. Архивные копии базы данных сервера Exchange можно также использовать для восстановления баз данных сервера Exchange на другом сервере.

Рекомендуется выполнять полную архивацию файлов базы данных и журналов транзакций каждый день. После полной архивации группы хранилищ журналы зафиксированных транзакций баз данных сервера Exchange удаляются с сервера. Полная архивация обеспечивает быстрое восстановление, поскольку для восстановления всех данных нужен только один набор магнитных носителей.

Примечание.
Рекомендуется хранить файлы журналов транзакций на выделенном диске отдельно от файлов базы данных. Это обеспечивает отказоустойчивость при повреждении диска базы данных и в некоторых случаях повышает производительность базы данных.
Важно!
Учетной записи пользователя должны быть предоставлены необходимые разрешения или права, чтобы пользователь, осуществивший вход с этой учетной записью, мог создавать и восстанавливать архивные копии файлов и папок. Для создания архивных копий сервера Exchange необходимо иметь права оператора архива на уровне домена. Чтобы создать архивные копии операционной системы Microsoft Windows Server™ 2003, необходимо иметь по крайней мере права локального оператора архива.

Стратегия архивации, выбранной для данных сервера Exchange, зависит от размера хранилищ, скорости программного обеспечения и оборудования архивации, мощности оборудования и потребностей во времени.

Дополнительные сведения о стратегиях архивации и об операциях по восстановлению после сбоя см. в следующих ресурсах:

  • Exchange Server 2003 Disaster Recovery Operations Guide (http://go.microsoft.com/fwlink/?LinkId=47570) (Руководство по операциям аварийного восстановления Exchange Server 2003).

  • Database Backup and Restore (http://go.microsoft.com/fwlink/?LinkID=80766) (Резервное копирование и восстановление баз данных).


Расписания интерактивного обслуживания хранилища почтовых ящиков перекрываются
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Чтобы определить, все ли хранилища почтовых ящиков из группы хранилищ имеют одинаковое расписание обслуживания, анализатор рекомендаций Exchange Server направляет запрос службе каталогов Active Directory®. Если групповой контейнер хранилища (класс msExchStorageGroup) содержит два или более хранилища почтовых ящиков (класс msExchPrivMDB), Exchange Server Analyzer проверяет параметр activationSchedule каждого хранилища почтовых ящиков. Если Exchange Server Analyzer обнаруживает, что эти значения (хранящиеся в виде строк октетов) одинаковы для всех хранилищ почтовых ящиков или перекрываются, отображается предупреждение.

По умолчанию процессы обслуживания почтовых ящиков запускаются в ночное время с 1.00 до 5.00. Из-за необходимости использования ресурсов сервера для процессов обслуживания рекомендуется изменить расписания обслуживания таким образом, чтобы расписания почтовых ящиков отличались как минимум на 15 минут.

Устранение причин этого предупреждения для серверов Exchange 2000 Server и Exchange Server 2003

  1. Откройте системный диспетчер Exchange.

  2. Разверните пункт Серверы, затем разверните сервер, с которым хотите работать.

  3. Разверните группу хранилищ, с которой хотите работать.

  4. Щелкните правой кнопкой нужное хранилище и в контекстном меню выберите Свойства.

  5. На вкладке База данных выберите Сеанс обслуживания и выберите новый сеанс или нажмите кнопку Настроить для создания пользовательского расписания.

Устранение причин появления этого предупреждения на сервере Windows Server 2007

  1. Откройте консоль управления Exchange

  2. Разверните пункт Конфигурация сервера и затем выберите сервер, с которым хотите работать.

  3. Разверните группу хранилищ, с которой хотите работать.

  4. Щелкните правой кнопкой нужное хранилище и в контекстном меню выберите Свойства.

  5. На вкладке Общие щелкните в раскрывающемся списке Расписание обслуживания и выберите новый сеанс или щелкните Настроить, чтобы создать пользовательское расписание.

Дополнительные сведения о порядке обслуживания хранилищ сервера Exchange Server 2003 см. в разделе "Configuring Store Maintenance and Backup Options" (Настройка параметров обслуживания и архивации хранилищ) руководства Exchange Server 2003 Administration Guide (http://go.microsoft.com/fwlink/?LinkId=47617) (Руководство по администрированию Exchange Server 2003).


Максимальные размеры хранилища почтовых ящиков, при которых запрещаются отправка и получение, слишком похожи
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтоб определить установленные для почтового ящика максимальные значения размеров. Если анализатор сервера Exchange обнаруживает, что разница между ограничениями размеров почтовых ящиков Prohibit send и Prohibit send and receive меньше 20 процентов, анализатор сервера Exchange выводит сообщение о рекомендуемой конфигурации.

Рекомендуется, чтобы максимальные значения Prohibit send и Prohibit send and receive отличались не менее чем на 20 процентов. Если разница между максимальными значениями оказывается меньше 20 процентов, пользователю почтового ящика может не хватить времени для очистки своего почтового ящика, прежде чем почтовый ящик начнет отклонять сообщения. Например, если пользователю запрещается отправлять новые сообщения, когда размер его почтового ящика достигает 100 МБ, максимальное значение Prohibit send and receive должно быть не менее 120 МБ.

Примечание.
Кроме того, важно определить для почтовых ящиков ограничение предупреждения. Когда размер почтового ящика достигает ограничения предупреждения, пользователю отправляется сообщение электронной почты, предупреждающее о приближении размера почтового ящика к максимальному значению, определенному параметром Prohibit send.

Для исправления этой проблемы следует увеличить разницу между максимальными значениями почтового ящика Prohibit send и Prohibit send and receive так, чтобы она превышала 20 процентов.

Установка ограничений для почтовых ящиков

  1. Откройте системный диспетчер Exchange.

  2. Найдите хранилище почтовых ящиков, указанное в сообщении анализатора сервера Exchange.

  3. Щелкните правой кнопкой мыши Имя_хранилища_почтового_ящика и выберите команду Свойства.

  4. Откройте вкладку Ограничения.

  5. Измените ограничение Запретить отправку при (КБ) limit, или ограничение Запретить отправку и получение при (КБ), или оба ограничения.

  6. Нажмите кнопку Применить, а затем кнопку ОК.
Чтобы установить ограничения почтового ящика Exchange Server 2007 с помощью консоли управления Exchange, выполните следующие действия.

  1. Откройте консоль управления Exchange

  2. Найдите почтовый ящик, отображаемый в анализаторе рекомендаций Exchange Server.

  3. Щелкните правой кнопкой мыши имя_почтового_ящика и выберите Свойства.

  4. Откройте вкладку Ограничения.

  5. Измените значения параметров Предупреждение о проблеме в (КБ), Запретить отправку при (КБ) и Запретить отправку и получение при (КБ).

  6. Нажмите кнопку Применить, затем нажмите кнопку ОК.
Чтобы установить ограничения почтового ящика Exchange Server 2007 с помощью оболочки управления Exchange, выполните следующие действия.

  1. В следующем примере показано, как установить размер почтового ящика, при достижении которого пользователю отправляется предупреждение. Этот атрибут применяется ко всем ящикам в текущей базе данных почтовых ящиков, для которых не установлены собственные параметры предупреждения. Можно указать целое число или значение «Не ограничено». Значение по умолчанию — 1,9 ГБ.
Копировать код
Set-MailboxDatabase "Mailbox Database Name" -IssueWarningQuota 1991680
  1. В следующем примере показано, как установить размер почтового ящика, при достижении которого этот почтовый ящик больше не отправляет сообщения. Этот атрибут применяется ко всем ящикам в текущей базе данных почтовых ящиков, для которых не установлены собственные параметры прекращения отправки. Можно указать целое число или значение «Не ограничено».

Копировать код
Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendQuota 2097152
  1. В следующем примере показано, как установить размер почтового ящика, при достижении которого этот почтовый ящик больше не отправляет и не получает сообщения. Этот атрибут применяется ко всем ящикам в текущей базе данных почтовых ящиков, для которых не установлены собственные параметры прекращения отправки и получения. Можно указать целое число или значение «Не ограничено».

Копировать код
Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendReceiveQuota 2411520

Дополнительные сведения об управления почтовыми ящиками Exchange см. в статье Работа с хранилищами Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=47595 (возможно, на английском языке).

Дополнительные сведения об управлении ограничениями почтовых ящиков в Exchange Server 2007 см. в статье «How to Configure Database Limits and Properties» (http://go.microsoft.com/fwlink/?LinkID=80746) (Как настроить ограничения и запрещения для базы данных)


Хранилище почтовых ящиков не подключается при запуске
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Средство анализа Microsoft® Exchange Server Analyzer Tool направляет запрос службе каталогов Active Directory® для определения значения атрибута msExchEDBOffline для каждого объекта класса msExchPrivateMDB. Объекты, принадлежащие к этому классу, являются хранилищами почтовых ящиков.

Значение True для атрибута msExchEDBOffline указывает, что хранилище почтовых ящиков не подключается автоматически при запуске службы Microsoft Exchange Information Store. Значение False указывает, что хранилище почтовых ящиков будет подключено при запуске. Если средство анализа Exchange Server Analyzer обнаруживает, что значение атрибута True, отображается предупреждение.

Данное предупреждение означает, что установлен флажок Do not mount this store at start-up. Данный флажок находится на вкладке Database диалогового окна Properties хранилища почтовых ящиков. Если флажок установлен, хранилище почтовых ящиков не подключается автоматически при запуске службы Microsoft Exchange Information Store. При следующем запуске службы Microsoft Exchange Information Store, например после перезагрузки сервера, хранилище почтовых ящиков с данным атрибутом, установленным как True, не будет подключено. Рекомендуется автоматическое подключение хранилищ почтовых ящиков при запуске службы Microsoft Exchange Information Store.

Устранение причин этого предупреждения для серверов Exchange 2000 Server или Exchange Server 2003

  1. Откройте системный диспетчер Exchange.

  2. Разверните Servers, затем разверните сервер, содержащий хранилище почтовых ящиков, которое необходимо изменить.

  3. Разверните группу хранения, содержащую хранилище почтовых ящиков, которое необходимо изменить.

  4. Щелкните хранилище почтовых ящиков правой кнопкой мыши и выберите Properties.

  5. На вкладке Database снимите флажок Do not mount this store at start-up .

  6. Нажмите кнопку OK для сохранения изменений.

  7. Запустите системный диспетчер Exchange System Manager.

Устранение причин появления этого предупреждения на сервере Windows Server 2007

  1. Откройте консоль управления Exchange

  2. Разверните пункт Конфигурация сервера и затем выберите сервер, с которым хотите работать.

  3. Разверните группу хранилищ, с которой хотите работать.

  4. Щелкните правой кнопкой нужную базу данных и в контекстном меню выберите Свойства.

  5. На вкладке Общие снимите флажок Не подключать эту базу данных при запуске.

  6. Нажмите кнопку ОК, чтобы сохранить параметры.

  7. Закройте консоль управления Exchange

Дополнительные сведения см. в следующих статьях базы знаний Майкрософт:

  • 314218, «ИНСТРУКЦИИ: автоматическое подключение и отключение хранилищ данных для Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314218)

  • 285169, «XADM: Хранилища данных не подключаются автоматически после использования параметра "/disasterrecovery"» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285169)


Параметр «Max FXGetBuffer Users» отличается от заданного по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, настроен ли параметр Max FXGetBuffer Users, анализатор приложения Microsoft® Exchange Server считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Если анализатор сервера Exchange обнаруживает, что в разделе реестра ParametersSystem создан параметр Max FXGetBuffer Users, выводится сообщение о том, что конфигурация отличается от заданной по умолчанию.

С помощью значения Max FXGetBuffer Users можно управлять числом клиентских компьютеров с Microsoft Office Outlook® 2003, которые могут одновременно синхронизироваться с сервером Exchange Server 2003. Значение раздела реестра Max FXGetBuffer Users позволяет переопределить максимальное число синхронных подключений удаленных вызовов процедур, устанавливаемых клиентами Outlook. Иногда такие подключения называются ropFXSrcGetBuffers. Чтобы рассчитать значение по умолчанию для параметра реестра Max FXGetBuffer Users, следует умножить количество доступных на сервере процессоров на 2, а затем добавить к итоговому числу 3. Например, для сервера Exchange Server 2003 с двумя процессорами значение по умолчанию составит 7 ([2*2] + 3=7).

Анализатор сервера Exchange отображает эту конфигурацию только для сведения. Никаких действий выполнять не требуется.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.
Чтобы вернуться к конфигурации по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Удалите значение Max FXGetBuffer Users.

  4. Закройте редактор реестра.

Служба банка данных Microsoft Exchange обнаруживает изменение в течение нескольких минут. Нет необходимости перезагружать компьютер.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения о настройке разделов реестра для управления количеством клиентов Outlook, которые могут выполнять синхронизацию с Exchange Server 2003, см. в статье 818484 базы знаний «Registry Values and Counters That You Can Use to Configure and Monitor Outlook Client Synchronization» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484) (Значения реестра и счетчики, с помощью которых можно настраивать синхронизацию клиентов Outlook и отслеживать ее).


Изменено значение максимального количества вложений на одно сообщение
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Чтобы определить, не было ли изменено установленное по умолчанию ограничение на количество вложений в сообщение, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtAttachment

Если анализатор рекомендаций Exchange обнаруживает в реестре значение параметра objtAttachment с любым значением, отличном от приведенных в таблице ниже, отображается сообщение о том, что используется нестандартная конфигурация.

Вхождение | Значение по умолчанию в Exchange Server 2003 | Значение по умолчанию в Exchange Server 2003 с пакетом обновления 1 и более поздних версиях | Значение по умолчанию в Exchange Server 2007
objtAttachment | 100 | 500 | 500

Вручную добавленный и настроенный параметр реестра objtAttachment определяет максимальное число вложений для одного сообщения, отправляемого одним клиентом MAPI. Когда MAPI-клиент пытается отправить сообщение, количество вложений которого превышает предельное, следующее событие записывается в журнал событий на сервере Exchange Server, содержащем почтовый ящик клиента:

Тип события: | Ошибка
Код события: | 9646
Источник события: | MSExchangeIS
Категория события: | Общие
Описание: | Закрытие сеанса Mapi «/o=OrganizationName/ou=AdministrativeGroupName/cn=Recipients/cn=UserName» из-за превышения максимального количества объектов xxx типа «objtAttachment».

Параметр реестра objtAttachment предлагает возможность настройки, с помощью которой администратор может более тесно управлять ресурсами сервера Exchange, используемыми MAPI-клиентами.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы вернуться к конфигурации по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в следующий раздел реестра:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. Удалите параметр реестра objtAttachment.

  4. Чтобы изменения вступили в силу, закройте редактор реестра и перезапустите службу Банк данных Microsoft Exchange.

Если планируется использовать параметр реестра objtAttachment, вместо его удаления сохраните или измените это значение.

Перед редактированием реестра для получения инструкций о том, как следует выполнить эту процедуру, изучите статью базы знаний Майкрософт 256986 «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения см. в статье 830829 базы знаний "Your Exchange Server 2003 computer may stop responding after a MAPI client opens more than the default value of certain server objects" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829) (Компьютер с Exchange Server 2003 может перестать реагировать на действия пользователей, если MAPI-клиентами открыто больше объектов сервера, чем это допустимо).


Изменено максимальное количество кэшированных представлений
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, было ли изменено максимальное количество кэшированных представлений, приходящихся на одну базу данных. Если анализатор сервера Exchange обнаружит, что атрибут msExchMaxCachedViews изменился относительно значения по умолчанию, равного 11, анализатор сервера Exchange отображает сообщение о конфигурации, отличной от конфигурации по умолчанию. Число кэшированных представлений, настроенных для каждой базы данных, включается в выходные данные анализатора сервера Exchange. Рекомендуется иметь от 5 до 20 кэшированных представлений.

msExchMaxCachedViews — это атрибут класса объекта msExchangePrivateMDB. Поэтому в службе Active Directory каждый объект хранилища базы данных почтовых ящиков имеет значение атрибута msExchMaxCachedViews. Значение атрибута msExchMaxCachedViews задает максимальное количество представлений, которые кэшируются для определенной папки в почтовом ящике. В этом контексте «представлением» называются папки, которые отображаются, когда пользователь, получает доступ к почтовому ящику Microsoft Office Outlook® 2003 другого пользователя. Когда пользователи открывают доступ к папке Outlook другим пользователям, сервер Exchange создает представление, которое скрывает личные элементы.

Когда пользователь Outlook в первый раз просматривает календарь, контактную папку или другие данные какого-либо пользователя, могут возникать задержки при выводе на экран. После того как пользователь просмотрел папку, при последующих просмотрах вывод на экран может выполняться быстрее, однако спустя некоторый период времени пользователь опять может столкнуться с задержками при просмотре, когда попытается снова получить доступ к этой папке. Такая задержка обычно наиболее заметна, если в папке содержится большое количество элементов. Большое количество — это 5000 элементов и более.

В процессе применения представления к папке создаются папки поиска в хранилище Exchange для каждого уникального пользователя, обращающегося к папке Outlook. Когда создается папка поиска, она кэшируется для последующего использования. Прежде чем создать новую папку поиска, сервер Exchange определяет, не существует ли уже эта папка поиска. Если папка поиска существует, сервер Exchange кэширует папку поиска для ускорения последующих просмотров.

Атрибут msExchMaxCachedViews определяет, сколько папок поиска кэшируется в определенной папке. Например, атрибут msExchMaxCachedViews определяет, сколько папок поиска кэшируется в папке «Календарь».

Если папки Outlook совместно используются многими пользователями, необходимо решить, как сбалансировать ресурсы сервера и приемлемую производительность просмотра для клиента. Когда папка поиска кэширована, она поддерживается актуальной при изменении данных в папке поиска. Для таких обновлений используются ресурсы центрального процессора и диска. Если поддерживается несколько кэшей папки поиска, это создает дополнительную нагрузку на процессор и диск.

С другой стороны, когда сервер Exchange создает папку поиска в первый раз, пользователь, обращающийся к папке Outlook, может сталкиваться с задержками, связанными с созданием папки поиска.

Например, рассмотрим сервер Exchange, настроенный с 11 папками поиска. Одиннадцать — это количество папок поиска по умолчанию. Пользователь «А» совместно использует свою папку «Календарь» с 15 другими пользователями. Пользователь «Б» обращается к этой папке и вынужден ожидать, пока его папка поиска не будет создана. После того как папка поиска создана для пользователя «Б», доступ к папке «Календарь» пользователя «А» будет быстрым. Предположим, что оставшуюся часть дня пользователь «Б» не обращается к папке. Между тем, если 11 других пользователей обращаются к папке, для них создаются уникальные папки поиска. Так как кэшируются только 11 папок поиска, то при следующем обращении пользователя «Б» к папке «Календарь» пользователя «А» пользователь «Б» опять будет вынужден ждать, пока для него не будет создана папка поиска.

Рекомендуется ограничить максимальное число кэшей папок поиска 20 или меньшим числом. При превышении этого числа, особенно для папок содержащих более 5000 элементов, может возникнуть перегрузка сервера, так как сервер будет пытаться обслужить кэшированные папки.

Кроме того, рекомендуется иметь менее пяти кэшей. Если пользователи предоставляют доступ к своим папкам Outlook многим пользователям, кэширование только четырех папок поиска негативно скажется на удобстве работы клиентов и приведет к необходимости использования сервером дополнительных ресурсов для более частого создания новых кэшей.

Атрибут msExchMaxCachedViews также может устанавливаться для баз данных общих папок. Папки поиска также создаются для общих папок. По умолчанию общие папки — это совместно используемые ресурсы, к которым могут получать доступ многие пользователи. Если общие папки получают много запросов, следует минимизировать количество папок поиска, так как сервер Exchange может интенсивно потреблять ресурсы процессора и диска при обновлениях папок поиска. Кроме того, не рекомендуется пытаться оптимизировать удобство работы клиентов за счет предоставления множества кэшей папок поиска, если к общей папке обращается много разных пользователей. С большой вероятностью эти кэши будут сбрасываться по мере создания новых папок поиска для новых пользователей.

Внимание!
Могут возникнуть серьезные проблемы, если некорректно изменить атрибуты объектов Active Directory при использовании средства ADSI Edit (Active Directory Service Interfaces, ADSI), средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Чтобы изменить атрибут msExchMaxCachedViews

  1. Запустите средство ADSI Edit из средств поддержки Microsoft Windows® 2000 или из средств поддержки Windows Server 2003.

  2. Разверните следующие узлы:

    • Контейнер конфигурации,

    • Конфигурация,

    • Службы,

    • Microsoft Exchange,

    • Имя_организации,

    • Административные группы,

    • Имя_административной_группы,

    • Серверы,

    • Информационное_хранилище,

    • Имя_группы_хранения.

  3. В области сведений щелкните правой кнопкой мыши Имя_базы_данных, а затем щелкните Свойства.

  4. В поле Атрибуты дважды щелкните msExchMaxCachedViews.

  5. В диалоговом окне Редактор целочисленных атрибутов введите число между 5 и 20 в поле Значение, а затем нажмите кнопку OK.

  6. Щелкните Применить и закройте средство ADSI Edit.

  7. Дождитесь репликации в течение хотя бы 15 минут, а затем перезапустите службу «Банк данных Microsoft Exchange» на сервере Exchange, на котором вносились изменения.


Установлено слишком большое значение для максимального количества кэшированных представлений
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, было ли изменено максимальное количество кэшированных представлений, приходящихся на одну базу данных. Если анализатор сервера Exchange обнаружит, что атрибут msExchMaxCachedViews установлен в значение, превышающее 20, анализатор сервера Exchange выводит на экран предупреждение. Число кэшированных представлений, настроенных для каждой базы данных, включается в выходные данные анализатора сервера Exchange. Рекомендуется иметь от 5 до 20 кэшированных представлений.

msExchMaxCachedViews — это атрибут класса объекта msExchangePrivateMDB. Поэтому в службе Active Directory каждый объект хранилища базы данных почтовых ящиков имеет значение атрибута msExchMaxCachedViews. Значение атрибута msExchMaxCachedViews задает максимальное количество представлений, которые кэшируются для определенной папки в почтовом ящике. В этом контексте «представлением» называются папки, которые отображаются, когда пользователь, получает доступ к почтовому ящику Microsoft Office Outlook® 2003 другого пользователя. Когда пользователи открывают доступ к папке Outlook другим пользователям, сервер Exchange создает представление, которое скрывает личные элементы.

Когда пользователь Outlook в первый раз просматривает календарь, контактную папку или другие данные какого-либо пользователя, могут возникать задержки при выводе на экран. После того как пользователь просмотрел папку, при последующих просмотрах вывод на экран может выполняться быстрее, однако спустя некоторый период времени пользователь опять может столкнуться с задержками при просмотре, когда попытается снова получить доступ к этой папке. Такая задержка обычно наиболее заметна, если в папке содержится большое количество элементов. Большое количество — это 5000 элементов и более.

В процессе применения представления к папке создаются папки поиска в хранилище Exchange для каждого уникального пользователя, обращающегося к папке Outlook. Когда создается папка поиска, она кэшируется для последующего использования. Прежде чем создать новую папку поиска, сервер Exchange определяет, не существует ли уже эта папка поиска. Если папка поиска существует, сервер Exchange кэширует папку поиска для ускорения последующих просмотров.

Атрибут msExchMaxCachedViews определяет, сколько папок поиска кэшируется в определенной папке. Например, атрибут msExchMaxCachedViews определяет, сколько папок поиска кэшируется в папке «Календарь».

Если папки Outlook совместно используются многими пользователями, необходимо решить, как сбалансировать ресурсы сервера и приемлемую производительность просмотра для клиента. Когда папка поиска кэширована, она поддерживается актуальной при изменении данных в папке поиска. Для таких обновлений используются ресурсы центрального процессора и диска. Если поддерживается несколько кэшей папки поиска, это создает дополнительную нагрузку на процессор и диск.

С другой стороны, когда сервер Exchange создает папку поиска в первый раз, пользователь, обращающийся к папке Outlook, может сталкиваться с задержками, связанными с созданием папки поиска.

Например, рассмотрим сервер Exchange, настроенный с 11 папками поиска. Одиннадцать — это количество папок поиска по умолчанию. Пользователь «А» совместно использует свою папку «Календарь» с 15 другими пользователями. Пользователь «Б» обращается к этой папке и вынужден ожидать, пока его папка поиска не будет создана. После того как папка поиска создана для пользователя «Б», доступ к папке «Календарь» пользователя «А» будет быстрым. Предположим, что оставшуюся часть дня пользователь «Б» не обращается к папке. Между тем, если 11 других пользователей обращаются к папке, для них создаются уникальные папки поиска. Так как кэшируются только 11 папок поиска, то при следующем обращении пользователя «Б» к папке «Календарь» пользователя «А» пользователь «Б» опять будет вынужден ждать, пока для него не будет создана папка поиска.

Рекомендуется ограничить максимальное число кэшей папок поиска 20 или меньшим числом. При превышении этого числа, особенно для папок содержащих более 5000 элементов, может возникнуть перегрузка сервера, так как сервер будет пытаться обслужить кэшированные папки.

Кроме того, рекомендуется иметь менее пяти кэшей. Если пользователи предоставляют доступ к своим папкам Outlook многим пользователям, кэширование только четырех папок поиска негативно скажется на удобстве работы клиентов и приведет к необходимости использования сервером дополнительных ресурсов для более частого создания новых кэшей.

Атрибут msExchMaxCachedViews также может устанавливаться для баз данных общих папок. Папки поиска также создаются для общих папок. По умолчанию общие папки — это совместно используемые ресурсы, к которым могут получать доступ многие пользователи. Если общие папки получают много запросов, следует минимизировать количество папок поиска, так как сервер Exchange может интенсивно потреблять ресурсы процессора и диска при обновлениях папок поиска. Кроме того, не рекомендуется пытаться оптимизировать удобство работы клиентов за счет предоставления множества кэшей папок поиска, если к общей папке обращается много разных пользователей. С большой вероятностью эти кэши будут сбрасываться по мере создания новых папок поиска для новых пользователей.

Внимание!
Могут возникнуть серьезные проблемы, если некорректно изменить атрибуты объектов Active Directory при использовании средства ADSI Edit (Active Directory Service Interfaces, ADSI), средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Чтобы изменить атрибут msExchMaxCachedViews

  1. Запустите средство ADSI Edit из средств поддержки Microsoft Windows® 2000 или из средств поддержки Windows Server 2003.

  2. Разверните следующие узлы:

    • Контейнер конфигурации,

    • Конфигурация,

    • Службы,

    • Microsoft Exchange,

    • Имя_организации,

    • Административные группы,

    • Имя_административной_группы,

    • Серверы,

    • Банк_данных,

    • Имя_группы_хранения.

  3. В области сведений щелкните правой кнопкой мыши Имя_базы_данных, а затем щелкните Свойства.

  4. В поле Атрибуты дважды щелкните msExchMaxCachedViews.

  5. В диалоговом окне Редактор целочисленных атрибутов введите число между 5 и 20 в поле Значение, а затем нажмите кнопку OK.

  6. Щелкните Применить и закройте средство ADSI Edit.

  7. Дождитесь репликации в течение хотя бы 15 минут, а затем перезапустите службу «Банк данных Microsoft Exchange» на сервере Exchange, на котором вносились изменения.


Установлено слишком малое значение для максимального количества кэшированных представлений
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, было ли изменено максимальное количество кэшированных представлений, приходящихся на одну базу данных. Если анализатор сервера Exchange обнаружит, что атрибут msExchMaxCachedViews установлен в значение, меньше 5, анализатор сервера Exchange выведет на экран предупреждение. Число кэшированных представлений, настроенных для каждой базы данных, включается в выходные данные анализатора сервера Exchange. Рекомендуется иметь от 5 до 20 кэшированных представлений.

msExchMaxCachedViews — это атрибут класса объекта msExchangePrivateMDB. Поэтому в службе Active Directory каждый объект хранилища базы данных почтовых ящиков имеет значение атрибута msExchMaxCachedViews. Значение атрибута msExchMaxCachedViews задает максимальное количество представлений, которые кэшируются для определенной папки в почтовом ящике.

В этом контексте «представлением» называются папки, которые отображаются, когда пользователь, получает доступ к почтовому ящику Microsoft Office Outlook® 2003 другого пользователя. Когда пользователи открывают доступ к папке Outlook другим пользователям, сервер Exchange создает представление, которое скрывает личные элементы.

Когда пользователь Outlook в первый раз просматривает календарь, контактную папку или другие данные какого-либо пользователя, могут возникать задержки при выводе на экран. После того как пользователь просмотрел папку, при последующих просмотрах вывод на экран может выполняться быстрее, однако спустя некоторый период времени пользователь опять может столкнуться с задержками при просмотре, когда попытается снова получить доступ к этой папке. Такая задержка обычно наиболее заметна, если в папке содержится большое количество элементов. Большое количество — это 5000 элементов и более.

В процессе применения представления к папке создаются папки поиска в хранилище Exchange для каждого уникального пользователя, обращающегося к папке Outlook. Когда создается папка поиска, она кэшируется для последующего использования. Прежде чем создать новую папку поиска, сервер Exchange определяет, не существует ли уже эта папка поиска. Если папка поиска существует, сервер Exchange кэширует папку поиска для ускорения последующих просмотров.

Атрибут msExchMaxCachedViews определяет, сколько папок поиска кэшируется в определенной папке. Например, атрибут msExchMaxCachedViews определяет, сколько папок поиска кэшируется в папке «Календарь».

Если папки Outlook совместно используются многими пользователями, необходимо решить, как сбалансировать ресурсы сервера и приемлемую производительность просмотра для клиента. Когда папка поиска кэширована, она поддерживается актуальной при изменении данных в папке поиска. Для таких обновлений используются ресурсы центрального процессора и диска. Если поддерживается несколько кэшей папки поиска, это создает дополнительную нагрузку на процессор и диск.

С другой стороны, когда сервер Exchange создает папку поиска в первый раз, пользователь, обращающийся к папке Outlook, может сталкиваться с задержками, связанными с созданием папки поиска.

Например, рассмотрим сервер Exchange, настроенный с 11 папками поиска. Одиннадцать — это количество папок поиска по умолчанию. Пользователь «А» совместно использует свою папку «Календарь» с 15 другими пользователями. Пользователь «Б» обращается к этой папке и вынужден ожидать, пока его папка поиска не будет создана. После того как папка поиска создана для пользователя «Б», доступ к папке «Календарь» пользователя «А» будет быстрым. Предположим, что оставшуюся часть дня пользователь «Б» не обращается к папке. Между тем, если 11 других пользователей обращаются к папке, для них создаются уникальные папки поиска. Так как кэшируются только 11 папок поиска, то при следующем обращении пользователя «Б» к папке «Календарь» пользователя «А» пользователь «Б» опять будет вынужден ждать, пока для него не будет создана папка поиска.

Рекомендуется ограничить максимальное число кэшей папок поиска 20 или меньшим числом. При превышении этого числа, особенно для папок содержащих более 5000 элементов, может возникнуть перегрузка сервера, так как сервер будет пытаться обслужить кэшированные папки.

Кроме того, рекомендуется иметь менее пяти кэшей. Если пользователи предоставляют доступ к своим папкам Outlook многим пользователям, кэширование только четырех папок поиска негативно скажется на удобстве работы клиентов и приведет к необходимости использования сервером дополнительных ресурсов для более частого создания новых кэшей.

Атрибут msExchMaxCachedViews также может устанавливаться для баз данных общих папок. Папки поиска также создаются для общих папок. По умолчанию общие папки — это совместно используемые ресурсы, к которым могут получать доступ многие пользователи. Если общие папки получают много запросов, следует минимизировать количество папок поиска, так как сервер Exchange может интенсивно потреблять ресурсы процессора и диска при обновлениях папок поиска. Кроме того, не рекомендуется пытаться оптимизировать удобство работы клиентов за счет предоставления множества кэшей папок поиска, если к общей папке обращается много разных пользователей. С большой вероятностью эти кэши будут сбрасываться по мере создания новых папок поиска для новых пользователей.

Внимание!
Могут возникнуть серьезные проблемы, если некорректно изменить атрибуты объектов Active Directory при использовании средства ADSI Edit (Active Directory Service Interfaces, ADSI), средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Чтобы изменить атрибут msExchMaxCachedViews

  1. Запустите средство ADSI Edit из средств поддержки Microsoft Windows® 2000 или из средств поддержки Windows Server 2003.

  2. Разверните следующие узлы:

    • Контейнер конфигурации,

    • Конфигурация,

    • Службы,

    • Microsoft Exchange,

    • Имя_организации,

    • Административные группы,

    • Имя_административной_группы,

    • Серверы,

    • Банк_данных,

    • Имя_группы_хранения.

  3. В области сведений щелкните правой кнопкой мыши Имя_базы_данных, а затем щелкните Свойства.

  4. В поле Атрибуты дважды щелкните msExchMaxCachedViews.

  5. В диалоговом окне Редактор целочисленных атрибутов введите число между 5 и 20 в поле Значение, а затем нажмите кнопку OK.

  6. Щелкните Применить и закройте средство ADSI Edit.

  7. Дождитесь репликации в течение хотя бы 15 минут, а затем перезапустите службу «Банк данных Microsoft Exchange» на сервере Exchange, на котором вносились изменения.


Максимальный кэш ESE изменен вручную
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2006-02-21

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchESEParamCacheSizeMax для всех объектов хранилища почтовых ящиков. Если анализатор сервера Exchange обнаруживает, что значение атрибута msExchESEParamCacheSizeMax для какого-либо хранилища почтовых ящиков больше 0, но меньше 219727, на экран выводится сообщение о конфигурации, отличной от конфигурации по умолчанию.

В Exchange 2000 Server большая область виртуальной памяти, используемой программой STORE.EXE, выделяется для буфера ESE. В Exchange 2000 Server для этого буфера жестко закодирована память по умолчанию объемом 858 мегабайтов (МБ). В Exchange Server 2003 объем памяти, выделяемой для буфера ESE, зависит от наличия переключателя /3GB в файле Boot.ini. Если переключатель /3GB присутствует, буфер ESE настраивается равным 896 МБ. Если переключатель /3GB отсутствует, буфер ESE настраивается равным 576 МБ. Хотя автонастройка удобна во всех случаях, может возникнуть необходимость в переопределении автонастройки и задании вручную значения, более подходящего для конкретной среды. Наряду с тем, что это значение должно быть кратно 8192, рекомендуется использовать только значения из следующей таблицы.

Рекомендуемое значение | Выделенная память | Комментарии
147456 | 576 МБ | Это рекомендуемый минимум памяти. Не устанавливайте меньший объем памяти. Это значение подходит для серверов с ограниченной виртуальной памятью и для компьютеров Exchange Server 2003 под управлением Microsoft Windows® 2000 Server, которые не поддерживают переключатель /3GB. Это значение является также значением по умолчанию для систем, в которых не используется переключатель /3GB.
196608 | 768 МБ | Это значение рекомендуется для серверов с большими объемами виртуальной памяти, которые часто регистрируют в журнале событие 9582.
219726 | 858 МБ | Это значение является значением по умолчанию в Exchange 2000 Server и хорошо подходит для использования в системах, которые обновляются на месте и имеют большие объемы виртуальной памяти.
229376 | 896 МБ | Это значение является значением по умолчанию в Exchange Server 2003 и хорошо подходит для использования в новых системах, если присутствие событий 9582 в журнале событий приложений не указывает на иное.
311296 | 1,2 ГБ | Это максимальное значение, которое можно установить. Это значение должно использоваться только на системах с физической памятью объемом 2 ГБ и более.

Прежде чем изменить это значение, необходимо проконтролировать объем виртуальной памяти, потребляемой процессом STORE.EXE. Это можно сделать путем наблюдения за рабочим объектом процесса в Windows. В системах с переключателем /3GB счетчик Virtual Bytes для экземпляра STORE.EXE объекта Process должен быть меньше 2,8 ГБ. В системах без переключателя /3GB этот счетчик должен быть меньше 1,8 ГБ. Если значения превышают указанные объемы памяти, возможно, потребуется уменьшить значение msExchESEParamCacheSizeMax. Если значения меньше указанных объемов памяти, возможно, потребуется увеличить значение msExchESEParamCacheSizeMax.

Внимание!
Могут возникнуть серьезные проблемы, если некорректно изменить атрибуты объектов Active Directory при использовании средства ADSI Edit (Active Directory Service Interfaces, ADSI), средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы установить атрибут msExchMaxCachedViews

  1. Откройте редактор Active Directory, например, ADSI Edit.

  2. Дважды щелкните контейнер Конфигурация.

  3. Разверните узел CN=Службы.

  4. Разверните узел CN=Microsoft Exchange.

  5. Разверните узел CN=<Имя организации Exchange>.

  6. Разверните узел CN=Административные группы.

  7. Разверните узел CN=<Имя административной группы>.

  8. Разверните узел CN=Серверы.

  9. Разверните узел CN=<Имя сервера Exchange>.

  10. Щелкните правой кнопкой мыши CN=Банк_данных, а затем щелкните Свойства.

  11. Прокрутите поле атрибутов и затем дважды щелкните msExchESEParamCacheSizeMax.

  12. В поле значений введите значение, которое хотите установить. Воспользуйтесь таблицей, приводимой в этой статье, чтобы определить оптимальное значение для своей системы. Обратите внимание, что используемое значение должно быть кратно 8192.

  13. Нажмите кнопку OK, а затем еще раз нажмите кнопку OK.

  14. Закройте редактор Active Directory, а затем перезапустите службу «Банк данных Microsoft Exchange», чтобы изменения вступили в силу.

Дополнительные сведения об оптимизации использования памяти см. в базе знаний Майкрософт в статье 815372, описывающей оптимизацию использования памяти в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372).

Дополнительные сведения об атрибуте msExchESEParamCacheSizeMax см. в базе знаний Майкрософт в статье 266768, описывающей инструкции по изменению максимального размера кэша базы данных хранилища (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768).


Слишком большой максимальный кэш ESE
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2006-02-21

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchESEParamCacheSizeMax для всех объектов хранилища почтовых ящиков. Анализатор сервера Exchange также запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_PerfRawData_MSExchangeIS_MSExchangeIS, чтобы определить значение ключа VMLargestBlockSize. Ключ VMLargestBlockSize представляет размер (в байтах) наибольшего доступного блока виртуальной памяти.

Помимо этого, анализатор сервера Exchange запрашивает службу Active Directory, чтобы определить значение счетчика записей, перечисленных в атрибуте homeMDBBL каждого хранилища почтовых ящиков. Счетчик этого атрибута представляет количество почтовых ящиков в хранилище почтовых ящиков.

Если анализатор сервера Exchange обнаруживает, что значение msExchESEParamCacheSizeMax больше чем 219726, и значение VMLargestBlockSize больше чем 50000000, но меньше чем 150000000 на компьютере сервера Exchange с более чем 20 почтовыми ящиками, выводится сообщение об ошибке. Эта ошибка указывает, что на этом компьютере сервера Exchange для атрибута msExchESEParamCacheSizeMax установлено слишком большое значение.

В Exchange 2000 Server большая область виртуальной памяти, используемой программой STORE.EXE, выделяется для буфера ESE. В Exchange 2000 Server для этого буфера жестко закодирована память по умолчанию объемом 858 мегабайтов (МБ). В Exchange Server 2003 объем памяти, выделяемой для буфера ESE, зависит от наличия переключателя /3GB в файле Boot.ini. Если переключатель /3GB присутствует, буфер ESE настраивается равным 896 МБ. Если переключатель /3GB отсутствует, буфер ESE настраивается равным 576 МБ. Хотя автонастройка удобна для управления, может возникнуть необходимость в переопределении автонастройки и задании вручную значения, более подходящего для конкретной среды. Наряду с тем, что это значение должно быть кратно 8192, рекомендуется использовать только значения из следующей таблицы.

Рекомендуемое значение | Выделенная память | Комментарии
147456 | 576 МБ | Это рекомендуемый минимум памяти. Не устанавливайте меньший объем памяти. Это значение подходит для серверов с ограниченной виртуальной памятью и для компьютеров Exchange Server 2003 под управлением Microsoft Windows 2000 Server, которые не поддерживают переключатель /3GB. Это значение является также значением по умолчанию для систем, в которых не используется переключатель /3GB.
196608 | 768 МБ | Это значение рекомендуется для серверов с большими объемами виртуальной памяти, которые часто регистрируют в журнале событие 9582.
219726 | 858 МБ | Это значение является значением по умолчанию в Exchange 2000 Server и хорошо подходит для использования в системах, которые обновляются на месте и имеют большие объемы виртуальной памяти.
229376 | 896 МБ | Это значение является значением по умолчанию в Exchange Server 2003 и хорошо подходит для использования в новых системах, если присутствие событий 9582 в журнале событий приложений не указывает на иное.
311296 | 1,2 ГБ | Это максимальное значение, которое можно установить. Это значение должно использоваться только на системах с физической памятью объемом 2 ГБ и более.

Прежде чем изменить это значение, необходимо проконтролировать объем виртуальной памяти, потребляемой процессом STORE.EXE. Это можно сделать путем наблюдения за рабочим объектом процесса в Windows. В системах с переключателем /3GB счетчик Virtual Bytes для экземпляра STORE.EXE объекта Process должен быть меньше 2,8 ГБ. В системах без переключателя /3GB этот счетчик должен быть меньше 1,8 ГБ. Если значения превышают указанные объемы памяти, возможно, потребуется уменьшить значение msExchESEParamCacheSizeMax. Если значения меньше указанных объемов памяти, может возникнуть желание увеличить значение msExchESEParamCacheSizeMax.

Внимание!
Могут возникнуть серьезные проблемы, если некорректно изменить атрибуты объектов Active Directory при использовании средства ADSI Edit (Active Directory Service Interfaces, ADSI), средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы настроить атрибут msExchESEParamCacheSizeMax

  1. Откройте редактор Active Directory, например, ADSI Edit.

  2. Дважды щелкните контейнер Конфигурация.

  3. Разверните узел CN=Службы.

  4. Разверните узел CN=Microsoft Exchange.

  5. Разверните узел CN=<Имя организации Exchange>.

  6. Разверните узел CN=Административные группы.

  7. Разверните узел CN=<Имя административной группы>.

  8. Разверните узел CN=Серверы.

  9. Разверните узел CN=<Имя сервера Exchange>.

  10. Щелкните правой кнопкой мыши CN=Информационное_хранилище, а затем щелкните Свойства.

  11. Прокрутите поле атрибутов и затем дважды щелкните msExchESEParamCacheSizeMax.

  12. В поле значений введите значение, которое хотите установить. Воспользуйтесь таблицей, чтобы определить оптимальное значение для своей системы. Обратите внимание, что используемое значение должно быть кратно 8192.

  13. Нажмите кнопку OK, а затем еще раз нажмите кнопку OK.

  14. Закройте редактор Active Directory, а затем перезапустите службу «Банк данных Microsoft Exchange», чтобы изменения вступили в силу.

Дополнительные сведения об оптимизации использования памяти см. в базе знаний Майкрософт в статье 815372, описывающей оптимизацию использования памяти в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372).

Дополнительные сведения об атрибуте msExchESEParamCacheSizeMax см. в базе знаний Майкрософт в статье 266768, описывающей инструкции по изменению максимального размера кэша базы данных хранилища (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768).


Увеличен максимальный размер кэша ESE
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2006-02-21

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchESEParamCacheSizeMax для всех объектов хранилища почтовых ящиков.

Анализатор сервера Exchange также запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_PerfRawData_MSExchangeIS_MSExchangeIS, чтобы определить значение раздела VMLargestBlockSize. Ключ VMLargestBlockSize представляет собой размер (в байтах) наибольшего доступного блока виртуальной памяти.

Помимо этого, анализатор сервера Exchange запрашивает службу Active Directory, чтобы определить значение счетчика записей, перечисленных в атрибуте homeMDBBL каждого хранилища почтовых ящиков. Счетчик этого атрибута представляет количество почтовых ящиков в хранилище почтовых ящиков.

Если анализатор сервера Exchange обнаруживает, что значение msExchESEParamCacheSizeMax превышает 219726, а значение VMLargestBlockSize не входит в следующие диапазоны значений на компьютере сервера Exchange, на котором размещено более 20 почтовых ящиков, отображается предупреждение:

  • более 50000000 и менее 150000000;

  • более 0 и менее 50000001.

Это предупреждение указывает, что атрибут msExchESEParamCacheSizeMax был увеличен на этом компьютере сервера Exchange и может вызвать условия, связанные с малым количеством виртуальной памяти.

В Exchange 2000 Server большая область виртуальной памяти, используемой программой STORE.EXE, выделяется для буфера ESE. В Exchange 2000 Server для этого буфера жестко закодирована память по умолчанию объемом 858 мегабайтов (МБ). В Exchange Server 2003 объем памяти, выделяемой для буфера ESE, зависит от наличия переключателя /3GB в файле Boot.ini. Если переключатель /3GB присутствует, буфер ESE настраивается равным 896 МБ. Если переключатель /3GB отсутствует, буфер ESE настраивается равным 576 МБ. Хотя автонастройка удобна во всех случаях, может возникнуть необходимость в переопределении автонастройки и задании вручную значения, более подходящего для конкретной среды. Наряду с тем, что это значение должно быть кратно 8192, рекомендуется использовать только значения из следующей таблицы.

Рекомендуемое значение | Выделенная память | Комментарии
147456 | 576 МБ | Это рекомендуемый минимум памяти. Не устанавливайте меньший объем памяти. Это значение подходит для серверов с ограниченной виртуальной памятью и для компьютеров Exchange Server 2003 под управлением Microsoft Windows 2000 Server, которые не поддерживают переключатель /3GB. Это значение является также значением по умолчанию для систем, в которых не используется переключатель /3GB.
196608 | 768 МБ | Это значение рекомендуется для серверов с большими объемами виртуальной памяти, которые часто регистрируют в журнале событие 9582.
219726 | 858 МБ | Это значение является значением по умолчанию в Exchange 2000 Server и хорошо подходит для использования в системах, которые обновляются на месте и имеют большие объемы виртуальной памяти.
229376 | 896 МБ | Это значение является значением по умолчанию в Exchange Server 2003 и хорошо подходит для использования в новых системах, если присутствие событий 9582 в журнале событий приложений не указывает на иное.
311296 | 1,2 ГБ | Это максимальное значение, которое можно установить. Это значение должно использоваться только на системах с физической памятью объемом 2 ГБ и более.

Прежде чем изменить это значение, необходимо проконтролировать объем виртуальной памяти, потребляемой процессом STORE.EXE. Это можно сделать путем наблюдения за рабочим объектом процесса в Windows. В системах с переключателем /3GB счетчик Virtual Bytes для экземпляра STORE.EXE объекта Process должен быть меньше 2,8 ГБ. В системах без переключателя /3GB этот счетчик должен быть меньше 1,8 ГБ. Если значения превышают указанные объемы памяти, возможно, потребуется уменьшить значение msExchESEParamCacheSizeMax. Если значения меньше указанных объемов памяти, возможно, потребуется увеличить значение msExchESEParamCacheSizeMax.

Внимание!
Могут возникнуть серьезные проблемы, если некорректно изменить атрибуты объектов Active Directory при использовании средства ADSI Edit (Active Directory Service Interfaces, ADSI), средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы установить атрибут msExchMaxCachedViews

  1. Откройте редактор Active Directory, например, ADSI Edit.

  2. Дважды щелкните контейнер Конфигурация.

  3. Разверните узел CN=Службы.

  4. Разверните узел CN=Microsoft Exchange.

  5. Разверните узел CN=<Имя организации Exchange>.

  6. Разверните узел CN=Административные группы.

  7. Разверните узел CN=<Имя административной группы>.

  8. Разверните узел CN=Серверы.

  9. Разверните узел CN=<Имя сервера Exchange>.

  10. Щелкните правой кнопкой мыши CN=InformationStore, а затем щелкните Свойства.

  11. Прокрутите поле атрибутов и затем дважды щелкните msExchESEParamCacheSizeMax.

  12. В поле значений введите значение, которое хотите установить. Воспользуйтесь таблицей, приводимой в этой статье, чтобы определить оптимальное значение для своей системы. Обратите внимание, что используемое значение должно быть кратно 8192.

  13. Нажмите кнопку OK, а затем еще раз нажмите кнопку OK.

  14. Закройте редактор Active Directory, а затем перезапустите службу «Банк данных Microsoft Exchange», чтобы изменения вступили в силу.

Дополнительные сведения об оптимизации использования памяти см. в статье 815372 базы знаний Майкрософт, описывающей оптимизацию использования памяти в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372).

Дополнительные сведения об атрибуте msExchESEParamCacheSizeMax см. в статье 266768 базы знаний Майкрософт, описывающей инструкции по изменению максимального размера кэша базы данных хранилища (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768).


Задано значение MaxOpenMessagesPerLogon
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-05-14

Чтобы определить, существует ли значение реестра MaxOpenMessagesPerLogon и настроено ли оно, средство анализа Microsoft Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Если средство анализа Exchange определяет, что значение MaxOpenMessagesPerLogon существует и превышает 0, на экран выводится сообщение о нестандартной конфигурации.

Каждый раз, когда клиент MAPI или приложение открывает сообщение на компьютере с Exchange Server, службе банка данных Microsoft Exchange (store.exe) выделяется небольшой объем физической памяти. Когда клиент Microsoft Office Outlook 2003 или Outlook 2007 закрывает сообщение, память освобождается. Чтобы предотвратить ситуацию, когда действия одного или нескольких клиентов MAPI заставляют службу банка данных Microsoft Exchange непрерывно перераспределять память, в пакет обновления 1 (SP1) для Exchange 2000 Server была добавлена новая функция настройки, которая позволяет администратору ограничивать количество сообщений, которые могут быть одновременно открыты в течение сеанс входа в систему каждого клиента MAPI. Такое ограничение может оказаться полезным, если некоторые клиентские приложения непреднамеренно открывают большое число сообщений, снижая общую производительность сервера.

Эта функция основана на использовании значения реестра MaxOpenMessagesPerLogon на компьютере с Exchange Server. Корпорация Майкрософт рекомендует ограничить это значение числом, не превышающим 1000. Значение 1000 позволяет каждому клиенту использовать приблизительно от 4 до 6 МБ памяти. Для некоторых сред более подходящим может оказаться значение 500.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неполадок. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Задание максимального числа одновременно открытых сообщений

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Откройте следующий раздел реестра:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Щелкните правой кнопкой мыши ParametersSystem, выберите Создать | DWORD Value и задайте новое значение параметру с именем MaxOpenMessagesPerLogon.

  4. В правой области дважды щелкните значение MaxOpenMessagesPerLogon, а затем введите в десятичном выражении максимальное количество одновременно открываемых сообщений.

  5. Закройте редактор реестра и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Перед изменением реестра ознакомьтесь с тем, как следует выполнять эту процедуру. Описание соответствующих инструкций содержится в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о значении реестра MaxOpenMessagesPerLogon см. в статье 289109 базы знаний Майкрософт «XADM. Ограничение числа сообщений, которые могут быть открыты для каждого входа в систему MAPI (http://go.microsoft.com/fwlink/?linkid=3052&kbid=289109, на английском языке).


Максимальное количество баз данных на группу хранения было изменено вручную
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить значение атрибута msExchMaxStoresPerGroup для каждой группы хранения, средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®. Если анализатор сервера Exchange обнаруживает, что значение атрибута msExchMaxStoresPerGroup любой из групп хранения отличается от 5, отображается сообщение об ошибке.

Данное значение применяется ко всем группам хранения на сервере. Ошибка возникает в том случае, если было изменено заданное по умолчанию значение 5. Это единственное поддерживаемое значение, и оно никогда не должно меняться. При изменении этого значения Exchange Server не может работать правильно.

Это значение следует исправить, применяя, например, оснастку Edit интерфейса ADSI, средство LDP (ldp.exe) или любой другой клиент, использующий протокол LDAP версии 3.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью оснастки Edit интерфейса ADSI, средства LDP или другого клиента, использующего протокол LDAP версии 3, может привести к серьезным неполадкам. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы устранить эту ошибку

  1. Запустите оснастку Edit интерфейса ADSI.

  2. Дважды щелкните контейнер Configuration, разверните последовательно CN=Services, CN=Microsoft Exchange и CN=<имя_организации_Exchange>.

  3. Разверните последовательно CN=Administrative Groups, CN=<имя_группы_администраторов> и CN=Servers.

  4. Разверните последовательно CN=<имя_сервера>, щелкните правой кнопкой мыши CN=InformationStore, а затем выберите Свойства.

  5. В окне Редактор атрибутов выдерите атрибут msExchMaxStoresPerGroup, а затем нажмите кнопку Изменить.

  6. В поле Изменить атрибут задайте значение 5.

  7. Нажмите кнопку Применить, а затем кнопку ОК.

  8. Закройте оснастку Edit интерфейса ADSI и перезапустите службу Банк данных Microsoft Exchange, чтобы изменения вступили в силу.

Дополнительные сведения об использовании средства LDP см. в статье 260745 базы знаний Майкрософт, посвященной использованию служебной программы LDP для изменения атрибутов объектов Active Directory (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Дополнительные сведения о максимальном допустимом количестве групп хранения см. в статье 251123 базы знаний Майкрософт, описывающей максимальное число групп хранения в Exchange 2000 при планировании вместимости базы данных (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=251123).

Дополнительные сведения о работе с оснасткой Edit интерфейса ADSI см. в разделе «Adsiedit.msc: ADSI Edit» в справке Windows Server.


Максимальное количество групп хранения было изменено вручную
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchMaxStorageGroups для каждого контейнера InformationStore. Если анализатор сервера Exchange определит, что значение любого атрибута msExchMaxStorageGroups не равняется 4, отобразится сообщение об ошибке.

Единственное значение, которое поддерживается для атрибута msExchMaxStorageGroups — это 4. Это значение не должно меняться. Если это значение изменено, Exchange не будет правильно работать.

Это значение следует исправить, используя, например, оснастку Edit интерфейса ADSI, средство LDP (ldp.exe) или любой другой клиент, использующий протокол LDAP версии 3.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью оснастки Edit интерфейса ADSI, средства LDP или другого клиента, использующего протокол LDAP версии 3, может привести к серьезным неполадкам. Для устранения этих неполадок может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы устранить эту ошибку

  1. С помощью ADSI Edit или похожего средства найдите в службе каталогов Active Directory объект InformationStore для этого сервера.

    Атрибут msExchMaxStorageGroups можно найти по следующему пути:

    CN=Configuration,DC=Domain,CN=com, CN=Services, CN=Microsoft Exchange, CN= имя_организации , CN=Administrative Groups, CN= имя_административной_группы , CN=Servers, CN= имя_сервера , CN=InformationStore

  2. Измените значение атрибута msExchMaxStorageGroups на 4.

  3. Закройте редактор Active Directory и перезапустите компьютер сервера Exchange, чтобы изменения вступили в силу.

Дополнительные сведения об использовании средства LDP см. в статье 260745 базы знаний Майкрософт, посвященной использованию служебной программы LDP для изменения атрибутов объектов Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).


Изменено максимальное число объектов папок для одного сеанса работы
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Средство анализатора сервера Microsoft® Exchange определяет, изменено ли максимальное число папок, которые можно открыть в течение одного сеанса MAPI, на основании данных следующего раздела реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtFolder

Если анализатор сервера Exchange обнаружит значение реестра objtFolder, отличающееся от 500, будет выведено сообщение о том, что конфигурация отличается от заданной по умолчанию.

При ручном добавлении значения реестра objtFolder и его настройке это значение определяет максимальное число папок, которое может быть открыто одним MAPI-клиентом. По умолчанию в Exchange Server 2003 и Exchange Server 2007 количество открытых папок ограничено числом 500. Когда клиент MAPI пытается открыть больше 500 папок, на компьютере с сервером Exchange Server, содержащем клиентский почтовый ящик, в журнале событий приложения регистрируется следующее событие:

Тип события: | Ошибка
Код события: | 9646
Источник события: | MSExchangeIS
Категория события: | Общие
Описание: | Сеанс MAPI "/o=OrganizationName/ou=AdministrativeGroupName/cn=Recipients/cn=UserName" будет закрыт, поскольку количество объектов с типом "objtFolder" превысило 500.

Значение реестра objtFolder представляет собой возможность настройки, с помощью которой администратор может более тесно управлять ресурсами сервера Exchange, используемыми MAPI-клиентами.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы вернуться к конфигурации по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите в следующий раздел реестра:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. Удалите значение реестра objtFolder.

  4. Закройте редактор реестра и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

  5. Если же планируется использовать значение реестра objtFolder, вместо его удаления сохраните или измените это значение.

Перед редактированием реестра для получения инструкций о том, как следует выполнить эту процедуру, изучите статью базы знаний Майкрософт 256986 "Description of the Microsoft Windows Registry" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения см. в статье 830829 базы знаний "Your Exchange Server 2003 computer may stop responding after a MAPI client opens more than the default value of certain server objects" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829) (Компьютер с Exchange Server 2003 может перестать реагировать на действия пользователей, если MAPI-клиентами открыто больше объектов сервера, чем это допустимо).


Изменено максимальное число представлений открытых папок на один вход в систему
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Средство анализатора сервера Microsoft® Exchange Server считывает следующий параметр реестра, чтобы определить, изменено ли максимальное число представлений папок по умолчанию, которые можно открыть на один сеанс MAPI:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtFolderView

Если анализатор сервера Exchange Server обнаружит, что значение objtFolderView реестра здесь представлено и его настройка отличается от 500, отображается сообщение о нестандартной настройке.

Добавляемое и настраиваемое вручную значение objtFolderView реестра определяет максимальное количество представлений папок, которое может быть открыто на один клиент MAPI. По умолчанию количество представлений папок в Exchange Server 2003 и Exchange Server 2007 ограничено 500. Когда MAPI-клиент пытается открыть боле 500 представлений, следующее событие записывается в журнал событий на компьютере Exchange Server, где находится почтовый ящик клиента:

Тип события: Ошибка

Источник ошибки: MSExchangeIS

Категория события: Общие

Описание: Закрытие сеанса Mapi "/o= OrganizationName /ou= AdministrativeGroupName /cn=Recipients/cn= UserName " поскольку превышено максимальное значение в 500 объектов типа "objtFolderView".

Значение objtFolderView реестра предоставляет администратору более широкий спектр возможностей для управления ресурсами сервера Exchange Server, которые используются клиентами MAPI.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неполадок. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы вернуться к настройкам по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. Удалите значение objtFolderView реестра.

  4. Закройте редактор реестра и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

  5. Если же по каким-то причинам требуется не удалять, а использовать значение objtFolderView реестра, сохраните его, установив равным текущему значению или скорректировав соответствующим образом.

Перед изменением реестра ознакомьтесь с тем, как следует выполнять эту процедуру. Описание соответствующих инструкций содержится в статье базы знаний Майкрософт 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения см. в статье 830829 базы знаний Майкрософт «Компьютер под управлением Exchange Server 2003 может перестать отвечать на запросы, если MAPI-клиент открывает больше серверных объектов, чем задано по умолчанию» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829).


Изменено максимальное количество объектов открытого сообщения, разрешенное для одного сеанса
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить, было ли изменено максимальное количество открытых сообщений, разрешенное для сеанса MAPI:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtMessage

Если анализатор сервера Exchange обнаружит, что значение реестра objtMessage существует, а также, что для него настроено любое значение, кроме 250, на экран выводится сообщение о нестандартной конфигурации.

Если значение реестра objtMessage добавлено и настроено вручную, оно определяет максимальное количество открытых сообщений для клиента MAPI. По умолчанию в Exchange Server 2003 и Exchange Server 2007 может быть открыто не более 250 сообщений. Когда клиент MAPI пытается открыть более 250 сообщений, следующее событие заносится в журнал событий на сервере Exchange Server, содержащем почтовый ящик пользователя:

Тип события: Ошибка

Код события: 9646

Источник события: MSExchangeIS.

Категория события: Общие

Описание Закрытие сеанса MAPI «/o= OrganizationName /ou= AdministrativeGroupName /cn=Recipients/cn= UserName » так как превышено максимальное количество объектов (250) типа «objtMessage».

Значение реестра objtMessage дает возможность выполнения настройки, при которой администратор наделен полномочиями более высокого уровня для управления ресурсами Exchange Server, используемыми клиентами MAPI.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы вернуть настройку по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. Удалите значение реестра objtMessage .

  4. Закройте редактор реестра и повторно запустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

  5. Если необходимо использовать значение реестра objtMessage , а не удалить его, установите для него существующее значение или настройте его при необходимости.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Дополнительные сведения см. в базе знаний Майкрософт в статье 830829, описывающей ситуацию, когда компьютер с установленным Exchange Server 2003 перестает отвечать на запросы, если клиент MAPI открыл больше объектов сервера, чем установлено по умолчанию (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829).


Значение раздела реестра Maximum Polling Frequency не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Анализатор рекомендаций сервера Exchange Server считывает следующее значение реестра, чтобы определить, было ли изменено значение по умолчанию интервала опроса для клиентов Microsoft Office Outlook® 2003 и Outlook 2007, которые обращаются к серверу Exchange Server 2003 или Exchange Server 2007 с помощью RPC по протоколу HTTP:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Maximum Polling Frequency

Если анализатор находит, что раздел Maximum Polling Frequency существует и его значение превышает 0, отображается сообщение о нестандартной конфигурации.

При своем первом подключении к серверу Exchange Outlook регистрируется для получения уведомлений о новых сообщениях. Когда в почтовый ящик пользователя Outlook приходит новое сообщение, Exchange посылает уведомление для Outlook, используя протокол UDP. Outlook получает это уведомление, а затем получает сообщение с сервера Exchange и отображает его в соответствующей папке. Если Outlook не получает уведомлений о новой почте, опрос сервера Exchange повторяется. Несмотря на то, что опрос производится приложением Outlook, частота опроса задается сервером Exchange.

По умолчанию Outlook 2003 опрашивает сервер каждые 60 секунд. Можно изменить эту частоту, добавив раздел реестра Maximum Polling Frequency на сервере Exchange, содержащий почтовый ящик пользователя. Введенное значение будет являться наименьшим количеством миллисекунд между интервалами опроса. Если раздел Maximum Polling Frequency не существует, по умолчанию используется значение 60 секунд (60 000 миллисекунд). Это значение по умолчанию не означает, что опрос будет производиться каждые 60 секунд. Это означает, что опрос будет производиться в любое время диапазона, который начинается со значения этого интервала и заканчивается значением этого интервала умноженным на два. Например, значение параметра Maximum Polling Frequency равно 90 секундам. В этом примере следующий опрос будет произведен между 90 и 180 секундами со времени последнего опроса.

Не следует задавать значение ниже 60 секунд по умолчанию, так как это снизит производительность Exchange, Outlook и всей сети. Может и не потребоваться изменение этого значения, так как проверку на наличие новых сообщений могут вызвать различные действия пользователей. Например, если пользователь переходит из папки в папку или открывает сообщения, будут отображаться новые элементы на сервере. Когда Outlook посылает необходимые запросы удаленных вызовов процедур для Exchange, чтобы применить действие пользователя, проверяется флажок наличия новых сообщений и, если таковой существует, уведомление о новом сообщении включается в ответ вызовов удаленных процедур, которые посылается обратно для Outlook.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы восстановить конфигурацию по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Удалите раздел с названием Maximum Polling Frequency.

  4. Перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о вызове удаленных процедур через HTTP см. в руководстве, посвященном сценариям развертывания вызовов удаленных процедур через HTTP в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47577).


Минимальный кэш ESE изменен вручную
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2006-01-16

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchESEParamCacheSizeMin для всех объектов хранилища почтовых ящиков. Если анализатор сервера Exchange обнаруживает, что значение атрибута msExchESEParamCacheSizeMin для какого-либо хранилища почтовых ящиков больше 0, выводится сообщение о наличии нестандартной конфигурации.

Служба «Банк сообщений Microsoft Exchange» использует кэш подсистемы расширяемых хранилищ (ESE) как буфер при записи данных хранилища на диск. Для Exchange 2000 Server используется максимальный размер кэша 858 МБ. Exchange Server 2003 определяет значение по умолчанию для свойства msExchESEParamCacheSizeMin динамически, исходя из объема оперативной памяти (ОЗУ), установленной на сервере.

Например, максимальный размер кэша для компьютера Exchange Server 2003, для которого в файле boot.ini указан ключ /3GB, — 896 МБ. Если ключ /3GB для компьютера не указан, максимальный размер кэша — 576 МБ.

Для восстановления исходного значения свойства msExchESEParamCacheSizeMin можно использовать следующую информацию:

  • Если Exchange Server 2003 работает под управлением Microsoft Windows Server™ 2003 и объем оперативной памяти на сервере 2 ГБ или больше, msExchESEParamCacheSizeMin будет равно 131072 (512 МБ).

  • Если Exchange Server 2003 работает под управлением Microsoft Windows Server™ 2003 и на сервере имеется от 768 МБ до 2 ГБ оперативной памяти, msExchESEParamCacheSizeMin будет равно ОЗУ/4*(4*1024).

  • Если Exchange Server 2003 работает под управлением Microsoft Windows Server™ 2003 и объем оперативной памяти на сервере меньше 768 МБ, msExchESEParamCacheSizeMin будет равно ОЗУ/8*(4*1024).

Например:

  • Windows Server 2003 с ОЗУ 512 МБ будет иметь значение по умолчанию для msExchESEParamCacheSizeMin, равное 16384 (страницы по 4 КБ).

  • Windows Server 2003 с ОЗУ 1 ГБ будет иметь значение по умолчанию для msExchESEParamCacheSizeMin, равное 65536 (страницы по 4 КБ).

  • Windows Server 2003 с ОЗУ 4 ГБ будет иметь значение по умолчанию для msExchESEParamCacheSizeMin, равное 131072 (страницы по 4 КБ).

  • Если Exchange Server 2003 работает под управлением Microsoft Windows® 2000 Server, значение по умолчанию для msExchESEParamCacheSizeMin не устанавливается.

Внимание!
Могут возникнуть серьезные проблемы, если некорректно изменить атрибуты объектов Active Directory при использовании средства ADSI Edit (Active Directory Service Interfaces, ADSI), средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор Active Directory, например, ADSI Edit.

  2. Дважды щелкните контейнер Конфигурация.

  3. Разверните узел CN=Службы.

  4. Разверните узел CN=Microsoft Exchange.

  5. Разверните узел CN=<Имя организации Exchange>.

  6. Разверните узел CN=Административные группы.

  7. Разверните узел CN=<Имя административной группы>.

  8. Разверните узел CN=Серверы.

  9. Разверните узел CN=<Имя сервера Exchange>.

  10. Щелкните правой кнопкой мыши CN=Банк_сообщений, а затем щелкните Свойства.

  11. Прокрутите поле атрибутов и затем дважды щелкните msExchESEParamCacheSizeMin.

  12. В поле значений введите значение, которое хотите установить. Можно использовать применяемую по умолчанию формулу и при необходимости отредактировать ее. Используемое значение должно быть кратным 32 МБ.

  13. Нажмите кнопку OK, а затем еще раз нажмите кнопку OK.

  14. Закройте редактор Active Directory, а затем перезапустите службу «Банк данных Microsoft Exchange», чтобы изменения вступили в силу.

Дополнительные сведения о настройке атрибута msExchESEParamCacheSizeMin см. в статье 822894 базы знаний Майкрософт «Jet Database Does Not Work Correctly During a Backup or During a Content Indexing Operation» (База данных Jet неправильно работает во время архивации или индексации содержимого) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822894).


Число потоков для процесса банка данных слишком велико
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Анализатор Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Process, чтобы определить значение параметра ThreadCount для процесса банка данных Exchange. Это значение показывает число активных потоков банка данных на сервере. Если число активных потоков банка данных превысит 400, выдается предупреждение.

Наиболее распространенной причиной данной проблемы является несовместимость антивирусной программы, запущенной на том же компьютере.

Чтобы устранить причину появления этого предупреждения

  1. Обратитесь к поставщику антивирусной программы и убедитесь, что используется самая свежая и совместимая с Exchange версия программы.

  2. Обновите антивирусное программное обеспечение.

Дополнительные сведения об антивирусном программном обеспечении и сервере Exchange Server 2003 см. в статье 823166 базы знаний Майкрософт, содержащей общий обзор Exchange Server 2003 и антивирусного программного обеспечения (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).


Значение раздела реестра OAB Bandwidth Threshold (KBps) не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, был ли создан раздел реестра OAB Bandwidth Threshold (KBps), средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Если анализатор сервера Exchange обнаружит, что раздел реестра OAB Bandwidth Threshold (KBps) был создан в разделе ParametersSystem, анализатор сервера Exchange отобразит сообщение о нестандартной конфигурации.

В Microsoft Exchange Server 2003 с пакетом обновления 1 администратор может указать и настроить раздел реестра OAB Bandwidth Threshold (KBps) для переопределения функциональных возможностей по умолчанию и для ограничения пропускной способности, используемой для загрузки автономной адресной книги с определенного общего хранилища.

По умолчанию каждый клиентский запрос на полную загрузку автономной адресной книги немедленно обслуживается. Также общее хранилище не ограничивает количество одновременных полных загрузок автономных адресных книг. Анализатор сервера Exchange отображает эту конфигурацию только для сведений. Никаких действий выполнять не требуется. Однако можно удалить раздел OAB Bandwidth Threshold (KBps), если следует восстановить конфигурацию по умолчанию.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы восстановить конфигурацию по умолчанию.

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Удалите раздел OAB Bandwidth Threshold (KBps).

  4. Закройте редактор реестра.

Служба банка данных Microsoft Exchange обнаруживает изменение в течение нескольких минут. Нет необходимости перезагружать компьютер.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о регулировании пропускной способности при загрузках автономной адресной книги см. в статье 867623 базы знаний Майкрософт, посвященной регулированию полных загрузок автономной адресной книги для ограничения нагрузки сети в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=867623).


Автономная адресная книга не связана с определенным хранилищем почтовых ящиков
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить, настроен ли атрибут msExchUseOAB в классе msExchPrivateMDB на использование определенной автономной адресной книги для конкретного хранилища почтовых ящиков. Класс msExchPrivateMDB определяет конфигурацию для частной базы данных. Атрибут msExchUseOAB определяет конкретную автономную адресную книгу, которая используется определенным хранилищем почтовых ящиков. Если анализатор сервера Exchange обнаружит отсутствие автономной адресной книги для хранилища почтовых ящиков, на экран будет выведено сообщение об ошибке.

В Exchange 2000 Server и более поздних версиях автономный список адресов сопоставлен со всеми пользователями, содержащимися в банке данных. Невозможно автоматически сопоставить автономный список адресов с определенным почтовым ящиком или заменить глобальные параметры автономного списка адресов для банка данных или группы хранения.

Чтобы связать автономный список адресов с определенным почтовым ящиком, необходимо сначала создать автономный список адресов, который содержит фильтрованную копию глобального списка адресов. Затем необходимо связать автономный список адресов с определенным почтовым ящиком, используя оснастку Edit интерфейса ADSI (Active Directory Service Interfaces) или другой LDAP-клиент версии 3, чтобы установить атрибут msExchUseOAB равным полному различающемуся имени автономного списка адресов.

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью оснастки Edit интерфейса ADSI, средства LDP (ldp.exe) или другого клиента, использующего протокол LDAP версии 3, может привести к серьезным неполадкам. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, а также сервера Exchange Server 2003, сервера Exchange Server 2007 или обоих продуктов. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Подробные инструкции по связыванию автономной адресной книги с определенным почтовым ящиком см. в базе знаний Майкрософт в статье 275203, описывающей ситуацию, когда не удается связать автономную адресную книгу с определенным почтовым ящиком (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=275203).

Дополнительные сведения об автономных адресных книгах см. в руководстве по оптимальному использованию автономной адресной книги (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47583).


Значение раздела реестра OLD Completion Time для хранилища общих папок не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, была ли изменена начальная задержка для оперативной дефрагментации относительно значения по умолчанию, средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\OLD Completion Time

Если анализатор обнаружит, что раздел реестра OLD Completion Time существует, отображается сообщение о нестандартной конфигурации. Раздел OLD Completion Time указывает временной интервал в секундах для запуска оперативной дефрагментации после промежутка обслуживания банка данных. Значение по умолчанию равно 1 часу (3600 секундам).

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы восстановить конфигурацию по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. Удалите раздел OLD Completion Time.

  4. Закройте редактор реестра и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Значение раздела реестра OLD Minimum RunTime для общей папки не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, было ли изменено минимальное время работы оперативной дефрагментации относительно значения по умолчанию, средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\OLD Minimum RunTime

Если анализатор обнаружит, что раздел реестра OLD Minimum RunTime существует, отображается сообщение о нестандартной конфигурации. Раздел OLD Minimum RunTime указывает минимальный период выполнения оперативной дефрагментации в секундах.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы восстановить конфигурацию по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. Удалите раздел OLD Minimum RunTime.

  4. Закройте редактор реестра и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Отключена дефрагментация в сетевом режиме
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchESEParamEnableOnlineDefrag для каждого объекта группы хранения. Значение True указывает на то, что обслуживание базы данных в сетевом режиме будет выполняться в соответствии с настроенным расписанием. Значение False показывает, что обслуживание в сетевом режиме выполняться не будет. Если анализатор сервера Exchange обнаруживает, что для атрибута msExchESEParamEnableOnlineDefrag установлено значение False, выводится сообщение об ошибке.

Обслуживание базы данных в сетевом режиме, включая дефрагментацию, играет важную роль в работе сервера Exchange. В течение этого периода выполняются такие задачи, как очистка мусорного контейнера (удаление сообщений, для которых истек срок хранения после удаления), обработка общей папки по истечении срока хранения (истекает срок хранения сообщений, находящихся в общих папках, созданных до определенной даты), очистка удаленных ящиков, дефрагментация в сетевом режиме (выполняется обнаружение и удаление неиспользуемых объектов базы данных, при этом освобождается место для базы данных) и т. д. Эти процессы помогают поддерживать стабильную и надежную работу сервера Exchange. Для обслуживания базы данных в сетевом режиме не следует устанавливать значение «Никогда не запускать», поскольку это может привести к снижению быстродействия через некоторое время.

Внимание!
Если при использовании оснастки ADSI Edit (ADSI — Active Directory Service Interfaces), средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3 неправильно изменить атрибуты объектов Active Directory, могут возникнуть серьезные неполадки. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, а также сервера Exchange Server 2003, сервера Exchange Server 2007 или обоих продуктов. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы устранить эту ошибку

  1. Нажмите кнопку Пуск, выберите команду Выполнить, введите MMC и нажмите кнопку ОК.

  2. В консоли управления (MMC) щелкните Файл и выберите команду Добавить/удалить оснастку.

  3. В списке «Доступные изолированные оснастки» выберите ADSI Edit и нажмите кнопку Добавить, а затем нажмите кнопку Закрыть. Нажмите кнопку ОК в окне «Добавить/удалить оснастку».

  4. Щелкните правой кнопкой мыши ADSI Edit и выберите Подключение к. В диалоговом окне Выберите хорошо известный контекст именования выберите Конфигурация и нажмите кнопку ОК.

  5. Разверните узел «Контейнер конфигурации», CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<имя_организации>, CN=Administrative Groups, CN=<имя_группы_администраторов>, CN=Servers, CN=<имя_сервера>, CN=Information Store.

  6. Щелкните правой кнопкой мыши CN=<имя_ группы_хранения>, а затем щелкните Свойства.

  7. В диалоговом окне «Свойства группы хранения» в списке атрибутов выберите msExchESEParamEnableOnlineDefrag и нажмите кнопку Изменить, а затем измените значение на True.

  8. Закройте оснастку ADSI Edit и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Дополнительные сведения о поддержке сетевой базы данных см. в следующих ресурсах Exchange.

  • Статья 314214 базы знаний Майкрософт «How to set maintenance intervals in data stores in Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314214).

  • Статья для специалистов по Exchange Server 2007 «Exchange Store Maintenance» (http://go.microsoft.com/fwlink/?LinkId=80787).


В реестр включен раздел «Preferred backfill source»
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, был ли изменен раздел Preferred Backfill Source относительно значения по умолчанию, средство анализатора сервера Microsoft® Exchange считывает следующие записи реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Preferred Backfill Source

По умолчанию раздел Preferred Backfill Source не существует. Если анализатор сервера Exchange обнаружит, что раздел Preferred Backfill Source должен присутствовать, на экран будет выведено сообщение о конфигурации, отличной от конфигурации по умолчанию.

Обратная засыпка происходит, когда хранилищем общих папок определяется, что не все обновления были получены для реплицированной папки (или для иерархии), и необходимо извлечь отсутствующие обновления из другого хранилища.

Чтобы упорядочить процесс обратной засыпки, сервер Exchange хранит сведения об отсутствующих обновлениях в массиве обратной засыпки.

В массиве обратной засыпки эти сведения хранятся в течение указанного периода времени (называемого тайм-аутом обратной засыпки). Если отсутствующие обновления поступают в последующих сообщениях репликации в течение этого времени, они удаляются из массива обратной засыпки. В таблице перечисляются значения тайм-аута обратной засыпки по умолчанию, которые зависят от того, где существуют отсутствующие обновления и запрашивались ли они прежде.

Тип запроса | Содержимое существует в хранилище на локальном узле | Содержимое существует в хранилище на удаленном узле
Исходная обратная засыпка | 6 часов | 12 часов
Первая попытка обратной засыпки | 12 часов | 24 часов
Последующие попытки обратной засыпки | 24 часов | 48 часов

Если тайм-аут обратной засыпки истекает и обновления по-прежнему отсутствуют, приложение Exchange Server 2003 создает один или более запросов обратной засыпки и определяет, какие серверы должны использоваться в качестве источников обратной засыпки.

Чтобы выбрать сервер (или серверы) для использования в качестве источника обратной засыпки, приложение Exchange Server 2003 сначала создает список всех серверов, имеющих реплики папки, а затем сортирует список согласно следующей последовательности критериев:

  • Сортировка по состоянию сервера. Выключенные или недоступные серверы переносятся в конец списка.

  • Сортировка по предпочтительному серверу обратной засыпки. (если она применима, эта функция доступна только в приложении Exchange Server 2003 или в более полной версии). Приложение Exchange Server 2003 проверяет объект хранилища общих папок и службу каталогов Active Directory® на наличие предпочтительного сервера обратной засыпки. Этот параметр используется редко. В большинстве случаев процесс обратной засыпки выполняется наиболее эффективно, если приложение Exchange Server 2003 выбирает сервер обратной засыпки автоматически. Для большинства развертываний Exchange Server 2003 предпочтительный сервер обратной засыпки не нужен. Служба поддержки продуктов Майкрософт может предоставить сценарий, который устанавливает предпочтительный сервер засыпки, если это необходимо для конкретного развертывания.

  • Сортировка по стоимости транспортировки (от наименьшей к наибольшей). Серверы на одном и том же узле имеют приоритет перед серверами на удаленных узлах. Стоимость транспортировки для сервера вычисляется модулем маршрутизации Exchange Server 2003 и обычно используется для расчета наиболее эффективного способа доставки сообщения. Обратите внимание, что в версиях Exchange, предшествующих Exchange Server 2003, стоимость транспортировки имеет более низкий приоритет и учитывается только после версии Exchange и количества доступных изменений.

  • Сортировка по версии Exchange (от новейшей к самой старой)

  • Сортировка по количеству необходимых изменений, которые доступны на сервере (от наибольшего к наименьшему). Серверы, не содержащие какие-либо из отсутствующих изменений, переносятся в конец списка.

Если на сервере нет всех необходимых изменений, приложение Exchange Server 2003 выбирает следующий сервер в отсортированном списке и отправляет запрос на обратную засыпку и на этот сервер. Этот процесс повторяется до тех пор, пока все изменения не будут запрошены. Данная функция доступна только в приложении Exchange Server 2003 и более поздних версиях; версии Exchange отправляют запросы обратной засыпки на один сервер за раз, если никакой из серверов не содержит все отсутствующие обновления для определенной папки. После каждого запроса предыдущие версии Exchange ожидают в течение тайм-аута попытки (от 24 до 48 часов), прежде чем отправляют следующий запрос.

Если выбранный сервер не отвечает на запрос обратной засыпки, хранилище помечает этот сервер как выключенный и повторяет процесс выбора. Серверы, помеченные как выключенные, переносятся в конец списка.

Большую часть времени ваша топология будет работать эффективно, если позволить серверу Exchange Server автоматически выбирать серверы обратной засыпки. Для целей устранения неполадок служба поддержки продуктов Майкрософт может рекомендовать установить раздел Preferred Backfill Source. Однако можно использовать его только в случае необходимости решения конкретной проблемы.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неполадки. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы сбросить раздел реестра «Preferred Backfill Source»

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>

  3. Проанализируйте или измените значение раздела Preferred Backfill Source.

    Значение для этой записи реестра выражено в килобайтах (КБ). Чтобы вернуться к значению по умолчанию, следует удалить раздел Preferred Backfill Source и перезапустить службу Банк данных Microsoft Exchange.

Перед изменением реестра ознакомьтесь с тем, как следует выполнять эту процедуру. Описание соответствующих инструкций содержится в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о репликации общей папки см. в разделе по управлению репликацией общей папки Exchange Server 2003, который содержится в материалах, описывающих работу с хранилищем Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).


Включен предпочитаемый источник обратной засыпки общих папок
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, настроен ли в Exchange предпочитаемый источник засыпки для иерархии общих папок, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<имя сервера>\Public-<идентификатор GUID общего банка данных>\Preferred Backfill Source

Если анализатор сервера Exchange обнаруживает, что параметр реестра Preferred Backfill Source существует и настроен, отображается сообщение о нестандартной конфигурации.

В Exchange Server 2003 добавлен новый атрибут службы каталогов Active Directory® msexchPreferredBackfillSource, который можно использовать для назначения сервера Exchange, который должен получать сообщения с запросами об обратной засыпке.

Когда необходимо выполнить репликацию содержимого общей папки, организации Exchange отправляется запрос на запрос об обратной засыпке. Для обратной засыпки данных используется первый ответивший сервер общих папок. В этой логике подразумевается, что первым откликается ближайший сервер общих папок, однако это не всегда так. В Exchange Server 2003 реализована возможность настройки — администратор может указать предпочитаемый сервер для обратной засыпки.

В Exchange Server 2003 можно задать предпочитаемый сервер, который должен использоваться для обратной засыпки иерархии и содержимого общих папок. Для этого используется атрибут Active Directory или параметр реестра Preferred Backfill Source на сервере общих папок. Сначала проверяется параметр Active Directory. Если его значение null, проверяется параметр реестра. Если он тоже отсутствует, используется заданный по умолчанию алгоритм обратной засыпки общих папок.

Чтобы использовать атрибут Active Directory, следует задать различающееся имя (DN) соответствующего хранилища общих папок, для которых требуется обратная засыпка, в атрибуте msExchPreferredBackfillSource на объектах хранилища общих папок.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» средства Regedit.exe или Regedt32.exe.

Если принято решение изменить атрибут msExchPreferredBackfillSource в Active Directory, потребуется использовать редактор Active Directory, например средство Edit интерфейса ADSI (Active Directory Service Interfaces) или средство LDP (ldp.exe).

Внимание!
Неправильное изменение атрибутов объектов Active Directory с помощью ADSI Edit, средства LDP или другого LDAP-клиента версии 3 может привести к возникновению серьезных неполадок. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих продуктов. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы указать предпочитаемый источник обратной засыпки общих папок в реестре

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<имя сервера>\Public-<идентификатор GUID общих банков данных>

  3. Просмотрите и, если необходимо, измените значение параметра Preferred Backfill Source. Следует ввести различающееся имя (DN) хранилища общих папок Exchange, из которого следует брать данные.

  4. Чтобы внесенные изменения вступили в силу, отключите и повторно подключите хранилище общих папок.

Чтобы указать предпочитаемый источник обратной засыпки общих папок в Active Directory

  1. Укажите необходимый источник обратной засыпки, изменив значение параметра msExchPreferredBackfillSource соответствующего объекта хранилища общих папок. Атрибут msExchPreferredBackfillSource можно найти по следующему пути: CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=имя_организации, CN=Administrative Groups, CN=имя_административной_группы, CN=Servers, CN=имя_сервера, CN=InformationStore, CN=имя_ группы_хранения, CN=Public Folder Store

  2. Необходимо ввести различающееся имя (DN) хранилища общих папок Exchange, из которого следует брать данные.

  3. Чтобы внесенные изменения вступили в силу, отключите и повторно подключите хранилище общих папок.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об изменении параметров настройки службы каталогов Active Directory с помощью средства LDP см. в базе знаний Майкрософт в статье 260745, посвященной использованию служебной программы LDP для изменения атрибутов объектов Active Directory (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260745).


Увеличьте объем свободного места на диске
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2006-09-06

Анализатор сервера Microsoft® Exchange обнаружил, что объем свободного места на диске компьютера, где выполняется сервер Exchange, ниже допустимого уровня. Анализатор сервера Exchange измеряет объем свободного места на диске, чтобы проверить, что этот объем находится в допустимых пределах. Если анализатор обнаруживает, что объем свободного места на диске ниже допустимого уровня, выводится сообщение об ошибке. Рекомендуется постоянно оставлять хотя бы 10 процентов свободного места для всех дисков на компьютерах серверов Exchange, которые содержат почтовые ящики.

Анализатор сервера Exchange проверяет следующие диски:

  • Диск базы данных

  • Диск временных данных

  • Диск MailRoot

  • Диск STM

  • Системный диск

  • Диск журнала

    Примечание.
    В таблице состояний выводится запрос увеличить размер диска журнала и выполнить архивацию журналов.
  • Диск подкачки

Чтобы устранить эту ошибку

  1. Чтобы освободить место на диске, удалите расположенные на нем ненужные файлы.

  2. Если на диске, где осталось менее 10 процентов свободного пространства, содержатся данные, которые можно безопасно переместить на другой диск (например, почтовые ящики или файл подкачки Microsoft Windows®), выполните шаги, требуемые для перемещения этих данных.

  3. Добавьте в компьютер сервера Exchange дополнительные диски.

  4. Сократите размер почтовых ящиков или переместите пользователей на другой сервер.

Дополнительные сведения

  • Дополнительные сведения о перемещении почтовых ящиков в Exchange Server 2003 см. в базе знаний Майкрософт, в статье 821829, описывающей перемещение почтовых ящиков в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

  • Дополнительные сведения о перемещении почтовых ящиков между серверами Exchange 2000 Server и Exchange Server 5.5 см. в статье 328810 базы знаний Майкрософт «Moving mailboxes between servers» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810) (Перемещение почтовых ящиков между серверами).

  • Дополнительные сведения о настройке ограничений для почтовых ящиков с помощью системных политик см. в статье 822938 базы знаний Майкрософт «HOW TO: Use System Policies to Configure Mailbox Storage Limits in Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822938) (Инструкции по настройке ограничений для хранения почтовых ящиков с помощью системных политик в Exchange Server 2003)

  • Дополнительные сведения о настройке ограничений для почтовых ящиков с помощью системных политик в Exchange 2000 Server см. в статье 319130 базы знаний Майкрософт «HOW TO: Use System Policies to Configure Mailbox Storage Limits in Exchange Server 2000» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319130) (Инструкции по настройке ограничений для хранения почтовых ящиков с помощью системных политик в Exchange Server 2000)

  • Дополнительные сведения о быстродействии сервера Exchange см. в руководстве Exchange Server 2003 Performance and Scalability Guide (http://go.microsoft.com/fwlink/?LinkId=47576) (Руководство по производительности и масштабируемости Exchange Server 2003).

  • Дополнительные сведения об устранении проблем производительности сервера Exchange см. в материале Troubleshooting Microsoft Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588) (Устранение неполадок, связанных с производительностью Microsoft Exchange Server 2003).

  • Дополнительные сведения о рекомендациях по разработке архитектур хранилищ см. в описании общих рекомендаций для нескольких архитектур (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=72988).

  • Дополнительные сведения об определении свободного места на диске, задержки и скоростей ввода-вывода см. в разделе Инструкции по расчету требований к системе ввода-вывода диска (http://go.microsoft.com/fwlink/?linkid=69747).


На сетевом диске содержится файл базы данных хранилища общих папок
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchEDBFile для каждого объекта хранилища общих папок. Этот атрибут указывает местоположение файлов базы данных, используемых соответствующим хранилищем общих папок.

Помимо этого, анализатор сервера Exchange опрашивает службу Active Directory, чтобы определить число значений, перечисленных в атрибуте homeMDBBL каждого хранилища почтовых ящиков на данном сервере. Число значений этого атрибута соответствует количеству почтовых ящиков в хранилище почтовых ящиков. Затем анализатор сервера Exchange может рассчитать общее число почтовых ящиков, управляемых сервером.

Если анализатор сервера Exchange обнаружит, что атрибут msExchEDBFile начинается с символов \\ на каком-либо сервере Exchange, содержащем более 50 почтовых ящиков, выдается сообщение об ошибке.

Эта ошибка указывает, что на сетевом диске имеются файлы базы данных хранилища общих папок. Если атрибут msExchEDBFile начинается с \\, это означает, что путь к файлу журнала задан в формате UNC (Universal Naming Convention). Такой способ использовать не рекомендуется, поскольку разрывы сетевых подключений могут вызывать ошибки баз данных, что приведет к потере данных или повреждению баз данных. Эту проблему следует устранить как можно скорее.

Чтобы переместить файлы базы данных на новый диск

  1. В системном диспетчере Exchange разверните объект сервера Exchange, на котором расположено хранилище, разверните соответствующий контейнер группы хранения, щелкните правой кнопкой мыши объект требуемого хранилища общих папок и выберите команду Свойства.

  2. Укажите новое расположение файлов на вкладке База данных диалогового окна Свойства.

Дополнительные сведения о файлах баз данных сервера Exchange см. в следующих разделах:

  • «Managing Mailbox Stores and Public Folder Stores» (Управление хранилищами почтовых ящиков и хранилищами общих папок) в документе Exchange Server 2003 Administration Guide (Руководство администратора Exchange Server 2003, http://go.microsoft.com/fwlink/?LinkId=47617)

  • «Understanding the Exchange Server 2003 Store» (Общее представление о хранилище Exchange Server 2003) в документе Working with Exchange Server 2003 Stores (Работа с хранилищами Exchange Server 2003, http://go.microsoft.com/fwlink/?LinkId=47595)

Дополнительные сведения об использовании сервера Exchange с сетевыми дисками см. в следующих статьях базы знаний Майкрософт:

  • Статья 328879 об использовании сервера Exchange совместно с сетью систем хранения данных и запоминающими устройствами, подключаемыми к сети (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328879)

  • Статья 839687 о политике Майкрософт в отношении использования устройств хранения данных, подключаемых к сети, совместно с Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839687)

  • Статья 317173 об использовании сервера Exchange вместе с системой хранения данных, подключаемой к сети (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317173)

  • Статья 317172 об использовании Exchange Server 5.5 вместе с системой хранения данных, подключаемой к сети (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317172)


Установлен предельный размер для базы данных хранилища общих папок
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, существует ли параметр Database Size Limit in Gb реестра и настроен ли этот параметр для хранилища общих папок, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Server_Name>\Public-<MailboxStoreGUID>

Если анализатор сервера Exchange обнаружит, что параметр Database Size Limit in Gb существует и настроен, анализатор сервера Exchange выводит на экран сообщение о конфигурации, отличной от конфигурации по умолчанию.

Если пакет обновления 2 (SP2) для Exchange Server 2003 применен к Exchange Server 2003 Standard Edition, жестко закодированный предельный размер лицензируемой базы данных увеличивается с 16 гигабайтов (ГБ) до 75 ГБ. Для предотвращения ненамеренного роста базы данных можно установить предохранительный предел на размер базы данных. Значение предельного размера по умолчанию в SP2 равно 18 ГБ, причем это значение по умолчанию можно переопределить, создав в реестре параметр Database Size Limit in Gb.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы вернуться к конфигурации по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<MailboxStoreGUID>

  3. Удалите параметр Database Size Limit in Gb.

  4. Закройте редактор реестра.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о пакете обновления 2 (SP2) для Exchange Server 2003 см. на веб-узле пакета обновления 2 (SP2) Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=52073).


Полная архивация хранилища общих папок не производилась более 8 дней
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Анализатор сервера Microsoft® Exchange выполняет запрос в хранилище общих папок для определения даты и времени последней полной архивации. Если анализатор сервера Exchange обнаруживает, что число дней со времени последней полной архивация хранилища общих папок — больше восьми, он выводит предупреждение.

Хранилище общих папок содержит сведения, связанные с определенным деревом общих папок, например, как дерево структурировано и какие папки оно содержит. В нем также хранится содержимое общих папок. Хранилище общих папок состоит из EDB-файла форматированного текста и STM-файла с исходным потоковым содержимым из Интернета.

Данные хранилища почтовых ящиков и хранилища общих папок в базах данных сервера Exchange и файлах журнала транзакций — самые важные данные, которые нужно архивировать в организации сервера Exchange. Архивную копию базы данных сервера Exchange можно использовать для восстановления поврежденного хранилища общих папок на функционирующем сервере Exchange. Архивную копию базы данных сервера Exchange можно использовать для восстановления баз данных сервера Exchange на другой сервер.

Рекомендуется выполнять полную архивацию файлов базы данных и журналов транзакций каждый день. После полной архивации группы хранения журналы зафиксированных транзакций баз данных сервера Exchange удаляются с сервера. Полная архивация обеспечивает быстрое восстановление, поскольку для восстановления всех данных нужен только один набор лент.

Примечание.
Рекомендуется хранить файлы журналов транзакций на специальном диске отдельно от файлов базы данных. Это обеспечивает отказоустойчивость при повреждении диска базы данных и в некоторых случаях повышает производительность базы данных.
Важно!
Учетной записи пользователя должны быть предоставлены необходимые разрешения или права, чтобы он мог создавать резервные копии файлов и папок, а также восстанавливать данные из этих резервных копий. Для создания резервных копий сервера Exchange необходимо иметь права оператора архива на уровне домена. Для создания резервных копий операционной системы Microsoft Windows Server™ 2003 необходимо иметь, по крайней мере, права локального оператора архива.

Выбор стратегии архивации данных сервера Exchange зависит от размера хранилищ, производительности программного обеспечения и оборудования архивации, мощности оборудования и выделенного времени.

Дополнительные сведения о стратегиях архивации и об операциях по восстановлению после сбоя см. в следующих ресурсах:

  • Exchange Server 2003 Disaster Recovery Operations Guide (http://go.microsoft.com/fwlink/?linkid=47570) (Руководство по операциям аварийного восстановления Exchange Server 2003).

  • Database Backup and Restore (http://go.microsoft.com/fwlink/?LinkID=80766) (Резервное копирование и восстановление баз данных).


Полная архивация хранилища общих папок не производилась более 60 дней
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Анализатор сервера Microsoft® Exchange выполняет запрос в хранилище общих папок для определения даты и времени последней полной архивации. Если анализатор сервера Exchange обнаруживает, что число дней со времени последней полной архивация хранилища общих папок больше 60, он выводит сообщение об ошибке.

Хранилище общих папок содержит сведения, связанные с определенным деревом общих папок, например как дерево структурировано и какие папки оно содержит. Хранилище общих папок содержит также содержимое общих папок. Хранилище общих папок состоит из EDB-файла форматированного текста и STM-файла с исходным потоковым содержимым из Интернета.

Данные хранилища почтовых ящиков и хранилища общих папок в базах данных сервера Exchange и файлах журнала транзакций — самые важные данные, которые нужно архивировать в организации сервера Exchange. Архивную копию базы данных сервера Exchange можно использовать для восстановления поврежденного хранилища общих папок на функционирующем сервере Exchange. Архивную копию базы данных сервера Exchange можно использовать для восстановления баз данных сервера Exchange на другой сервер.

Рекомендуется выполнять полную архивацию файлов базы данных и журналов транзакций каждый день. После полной архивации группы хранения журналы зафиксированных транзакций баз данных сервера Exchange удаляются с сервера. Полная архивация обеспечивает быстрое восстановление, поскольку для восстановления всех данных нужен только один набор лент.

Примечание.
Рекомендуется хранить файлы журналов транзакций на специальном диске отдельно от файлов базы данных. Выполнение этой рекомендации не только повышает производительность базы данных, но также обеспечивает защиту от сбоев в случае повреждения диска базы данных.
Важно!
У вас должны быть необходимые разрешения или права, назначенные пользовательской учетной записи, с которой вы выполняете вход, чтобы создавать архивные копии файлов и папок, а также восстанавливать данные из этих архивных копий. Для создания архивных копий Exchange Server необходимо иметь права оператора архива на уровне домена. Для создания архивных копий операционной системы Microsoft Windows Server™ 2003 необходимо иметь, по крайней мере права локального оператора архива.

Выбор стратегии архивации данных сервера Exchange зависит от размера хранилищ, производительности программного обеспечения и оборудования архивации, мощности оборудования и выделенного времени.

Дополнительные сведения о стратегиях архивации и об операциях по восстановлению после сбоя см. в следующих ресурсах:

  • Exchange Server 2003 Disaster Recovery Operations Guide (http://go.microsoft.com/fwlink/?linkid=47570) (Руководство по операциям аварийного восстановления Exchange Server 2003).

  • Database Backup and Restore (http://go.microsoft.com/fwlink/?LinkId=80766) (Резервное копирование и восстановление баз данных).


Объем хранилища общих папок превышает 12 ГБ
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_DataFile, чтобы определить значение ключа FileSize для каждого файла потокового формата (с расширением STM) и файла (с расширением EDB) базы данных хранилища общих папок Exchange. Чтобы определить версию установленного сервера Exchange, анализатор сервера Exchange также считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<идентификатор GUID продукта Exchange>

Если анализатор сервера Exchange обнаруживает, что суммарный размер базы данных хранилища общих папок и файлов потокового формата превышает 12 ГБ на компьютере, на котором выполняется Microsoft Exchange Server 2003 Standard Edition или Exchange 2000 Server Standard Edition, на экран выводится предупреждение.

Базы данных хранилища Exchange в приложениях Exchange Server 2003 Standard Edition и Exchange 2000 Server Standard Edition не могут увеличиваться свыше 16 ГБ. После того как достигнут этот предел, хранилище почтовых ящиков перестает быть подключенным, и приложение Exchange становится недоступным. Базы данных хранилища Exchange в приложениях Exchange Server 2003 Enterprise Edition и Exchange 2000 Server Enterprise Edition не ограничены размером 16 ГБ; они ограничены только возможностями оборудования, причем теоретический максимальный размер равен 16 терабайтам.

Чтобы устранить причину появления этого предупреждения

  1. Рассмотрите возможность установки политик управления сроком жизни общих папок, чтобы удалять сообщения, время существования которых превышает определенный срок.

  2. Рассмотрите возможность установки пределов хранения как для хранилищ общих папок, так и для отдельных общих папок, чтобы предотвратить неограниченный рост хранилища общих папок.

  3. Если из этого хранилища общих папок недавно были удалены многочисленные сообщения или реплики общих папок, выполнение автономной дефрагментации может привести к уменьшению общего размера файлов.
Примечание.
С выпуском пакета обновления 2 (SP2) Exchange Server 2003 жестко закодированный предельный размер лицензируемой базы данных в Exchange Server 2003 Standard Edition увеличился с 16 ГБ до 75 ГБ. Администратор имеет возможность установить предохранительный предел на размер базы данных (предотвращающий ненамеренное увеличение размера базы данных). Значение по умолчанию равно 18 ГБ в пакете обновления SP2 для выпуска Standard Edition, причем значение по умолчанию, равное 18 ГБ, можно переопределить путем изменения в реестре параметра Предельный размер базы данных в ГБ.
Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы установить предельный размер базы данных с пакетом обновления 2 (SP2) Exchange Server 2003

  1. На компьютере, на котором выполняется сервер Exchange, запустите редактор реестра, Regedit.exe.

  2. Откройте следующий раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\Имя_сервера\идентификатор общего хранилища

  3. Щелкните правой кнопкой мыши Идентификатор GUID общего хранилища, наведите указатель на пункт Создать и выберите Значение DWORD.

  4. В качестве имени нового значения введите Предельный размер базы данных в ГБ.

  5. Дважды щелкните Предельный размер базы данных в ГБ. В поле Значение введите соответствующее значение максимального размера базы данных, выраженное в ГБ. Для приложения Exchange Server 2003 Standard Edition введите значение в диапазоне от 1 до 75 (значение по умолчанию — 18 ГБ). Для приложения Exchange Server 2003 Enterprise Edition введите значение в диапазоне от 1 до 8000 (значение по умолчанию — 8000 ГБ). Нажмите кнопку ОК.

  6. Щелкните правой кнопкой мыши Идентификатор GUID общего хранилища, наведите указатель на пункт Создать и выберите Значение DWORD.

  7. В качестве имени нового значения введите Ограничитель размера базы данных в процентах.

  8. Дважды щелкните Ограничитель размера базы данных в процентах. В поле Значение введите значение в диапазоне между 1 и 100, чтобы указать, когда в журнал должны заноситься события, предупреждающие о приближении к максимальному размеру базы данных. Значение по умолчанию, равное 10, приведет к записи в журнал предупреждающих сообщений, когда до достижения максимального размера этой базы данных останется 10 процентов её предельного объема. Нажмите кнопку ОК.

  9. Щелкните правой кнопкой мыши Идентификатор GUID общего хранилища, наведите указатель на пункт Создать и выберите Значение DWORD.

  10. В качестве имени нового значения введите Время начала проверки размера базы данных, выраженное в часах после полуночи.

  11. Дважды щелкните Время начала проверки размера базы данных, выраженное в часах после полуночи. В поле Значение введите значение в диапазоне между 0 и 23, чтобы указать, когда размер базы данных должен контролироваться приложением Exchange. Значение по умолчанию, равное 5, приведет к контролю сервером Exchange размера базы данных спустя 5 часов после полуночи (5:00). Нажмите кнопку ОК.

  12. Закройте редактор реестра.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в статье 256986 (может быть на английском языке) базы знаний Майкрософт, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о файлах с расширениями STM и EDB см. в базе знаний Майкрософт в статье 232323, описывающей собственное хранилище содержимого в Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323).

Дополнительные сведения о перемещении почтовых ящиков в Exchange Server 2003 см. в базе знаний Майкрософт в статье 821829, описывающей перемещение почтовых ящиков в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

Дополнительные сведения о перемещении почтовых ящиков в Exchange 2000 Server см. в базе знаний Майкрософт в статье 328810, описывающей перемещение почтовых ящиков между серверами (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810).

Дополнительные сведения о выполнении автономной дефрагментации базы данных сервера Exchange см. в базе знаний Майкрософт в статье 328804, описывающей порядок дефрагментации баз данных Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804).

Дополнительные сведения о настройке пределов хранения для общих папок см. в базе знаний Майкрософт в статье 823144, описывающей инструкции по настройке пределов хранения для общих папок в Exchange 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823144).

Сведения о достижении максимального размера базы данных в приложениях Exchange Server 2003 Standard Edition и Exchange 2000 Server Standard Edition см. в базе знаний Майкрософт в статье 828070, описывающей причины, почему хранилище почтовых ящиков сервера Exchange не подключается, когда база данных хранилища почтовых ящиков достигает предела в 16 ГБ (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070).

Дополнительные сведения о пакете обновления 2 (SP2) для Exchange Server 2003 см. на веб-узле пакета обновления 2 (SP2) Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=52073).


Объем хранилища общих папок превышает 15 ГБ
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_DataFile, чтобы определить значение ключа FileSize для каждого файла потокового формата (с расширением STM) и файла (с расширением EDB) базы данных хранилища общих папок Exchange. Чтобы определить версию установленного сервера Exchange, анализатор сервера Exchange также считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<идентификатор GUID продукта Exchange>

Если анализатор сервера Exchange обнаружит, что суммарный размер базы данных хранилища общих папок и файлов потокового формата превышает 15 ГБ на компьютере, на котором выполняется Microsoft Exchange Server 2003 Standard Edition или Exchange 2000 Server Standard Edition, на экран выводится сообщение об ошибке.

Базы данных хранилища Exchange в приложениях Exchange Server 2003 Standard Edition и Exchange 2000 Server Standard Edition не могут увеличиваться свыше 16 ГБ. После того как достигнут этот предел, хранилище почтовых ящиков перестает быть подключенным, и приложение Exchange становится недоступным. Базы данных хранилища Exchange в приложениях Exchange Server 2003 Enterprise Edition и Exchange 2000 Server Enterprise Edition не ограничены размером 16 ГБ; они ограничены только возможностями оборудования, причем теоретический максимальный размер равен 16 терабайтам.

Чтобы устранить эту ошибку

  1. Рассмотрите возможность установки политик управления сроком жизни общих папок, чтобы удалять сообщения, время существования которых превышает определенный срок.

  2. Рассмотрите возможность установки пределов хранения как для хранилищ общих папок, так и для отдельных общих папок, чтобы предотвратить неограниченный рост хранилища общих папок.

  3. Если из этого хранилища общих папок недавно были удалены многочисленные сообщения или реплики общих папок, выполнение автономной дефрагментации может привести к уменьшению общего размера файлов.
Примечание.
С выпуском пакета обновления 2 (SP2) для Exchange Server 2003 Standard Edition жестко закодированный предельный размер лицензируемой базы данных увеличился с 16 ГБ до 75 ГБ. Администратор имеет возможность установить предохранительный предел на размер базы данных (предотвращающий ненамеренное увеличение размера базы данных). Значение по умолчанию равно 18 ГБ в пакете обновления SP2 для выпуска Standard Edition, причем значение по умолчанию, равное 18 ГБ, можно переопределить путем изменения в реестре параметра Предельный размер базы данных в ГБ.
Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы установить предельный размер базы данных с пакетом обновления 2 (SP2) Exchange Server 2003

  1. На компьютере, на котором выполняется сервер Exchange, запустите редактор реестра, Regedit.exe.

  2. Откройте следующий раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\Имя_сервера\идентификатор общего хранилища

  3. Щелкните правой кнопкой мыши Идентификатор GUID общего хранилища, наведите указатель на пункт Создать и выберите Значение DWORD.

  4. В качестве имени нового значения введите Предельный размер базы данных в ГБ.

  5. Дважды щелкните Предельный размер базы данных в ГБ. В поле Значение введите соответствующее значение максимального размера базы данных, выраженное в ГБ. Для приложения Exchange Server 2003 Standard Edition введите значение в диапазоне от 1 до 75 (значение по умолчанию — 18 ГБ). Для приложения Exchange Server 2003 Enterprise Edition введите значение в диапазоне от 1 до 8000 (значение по умолчанию — 8000 ГБ). Нажмите кнопку ОК.

  6. Щелкните правой кнопкой мыши Идентификатор GUID общего хранилища, наведите указатель на пункт Создать и выберите Значение DWORD.

  7. В качестве имени нового значения введите Ограничитель размера базы данных в процентах.

  8. Дважды щелкните Ограничитель размера базы данных в процентах. В поле Значение введите значение в диапазоне между 1 и 100, чтобы указать, когда в журнал должны заноситься события, предупреждающие о приближении к максимальному размеру базы данных. Значение по умолчанию, равное 10, приведет к записи в журнал предупреждающих сообщений, когда до достижения максимального размера этой базы данных останется 10 процентов её предельного объема. Нажмите кнопку ОК.

  9. Щелкните правой кнопкой мыши Идентификатор GUID общего хранилища, наведите указатель на пункт Создать и выберите Значение DWORD.

  10. В качестве имени нового значения введите Время начала проверки размера базы данных, выраженное в часах после полуночи.

  11. Дважды щелкните Время начала проверки размера базы данных, выраженное в часах после полуночи. В поле Значение введите значение в диапазоне между 0 и 23, чтобы указать, когда размер базы данных должен контролироваться приложением Exchange. Значение по умолчанию, равное 5, приведет к контролю сервером Exchange размера базы данных спустя 5 часов после полуночи (5:00). Нажмите кнопку ОК.

  12. Закройте редактор реестра.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о файлах с расширениями STM и EDB см. в базе знаний Майкрософт в статье 232323, описывающей собственное хранилище содержимого в Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323).

Дополнительные сведения о перемещении почтовых ящиков в Exchange Server 2003 см. в базе знаний Майкрософт в статье 821829, описывающей перемещение почтовых ящиков в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

Дополнительные сведения о перемещении почтовых ящиков в Exchange 2000 Server см. в базе знаний Майкрософт в статье 328810, описывающей перемещение почтовых ящиков между серверами (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810).

Дополнительные сведения о выполнении автономной дефрагментации базы данных сервера Exchange см. в базе знаний Майкрософт в статье 328804, описывающей порядок дефрагментации баз данных Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804).

Дополнительные сведения о настройке пределов хранения для общих папок см. в базе знаний Майкрософт в статье 823144, описывающей инструкции по настройке пределов хранения для общих папок в Exchange 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823144).

Сведения о достижении максимального размера базы данных в приложениях Exchange Server 2003 Standard Edition и Exchange 2000 Server Standard Edition см. в базе знаний Майкрософт в статье 828070, описывающей причины, почему хранилище почтовых ящиков сервера Exchange не подключается, когда база данных хранилища почтовых ящиков достигает предела в 16 ГБ (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070).

Дополнительные сведения о пакете обновления 2 (SP2) для Exchange Server 2003 см. на веб-узле пакета обновления 2 (SP2) Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=52073).


Хранилище общих папок не имеет адреса электронной почты
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2006-03-28

Анализатор сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить значение атрибута mail для каждого хранилища общих папок. Если анализатор сервера Exchange обнаруживает, что значение параметра mail не настроено для любого хранилища общих папок, на экран выводится сообщение об ошибке.

Если в хранилище общих папок не настроен SMTP-адрес, репликации иерархии общих папок не будет корректно работать с этим хранилищем.

Технически, хранилище общих папок является особым типом почтового ящика Exchange. Как и все объекты, работающие с почтовыми ящиками, хранилище общих папок должно содержать корректно настроенные следующие атрибуты, чтобы отправлять и принимать почту:

  • legacyExchangeDN. Это различающееся имя объекта в стиле Exchange.

  • proxyAddresses. Этот атрибут содержит все адреса электронной почты, которые могут быть использованы для отправки почтовых сообщений этому получателю.

  • textEncodedORAddress. Этот атрибут содержит основной адрес X.400.

  • Mail. Этот атрибут содержит основной SMTP-адрес объекта без префикса адреса.

  • mailNickname. Этот атрибут используется для создания URL-адреса доступа к почтовому ящику.

  • displayName. Этот атрибут содержит краткое имя объекта, которое используется для этого объекта в глобальном списке адресов и любых других списках адресов, членом которых может являться этот объект.

Если атрибут почты не установлен на хранилище общих папок, часто это означает, что служба обновления получателей не настроена или работает некорректно. Существует два вида служб обновления получателей. Одна обрабатывает системные объекты Exchange в контейнере конфигурации (служба обновления получателей предприятия), а другая обрабатывает получателей в каждом домене (служба обновления получателей домена).

Во всем лесе Active Directory существует только одна служба обновления получателей предприятия, так как существует только один контейнер конфигурации. Именно эта служба обновления получателей ответственна за настройку многих атрибутов для хранилищ общих папок, в том числе и атрибута mail. Если служба обновления получателей отключена, некорректно настроена или завершилась с ошибкой, атрибуты могут быть настроены неверно и репликация общих папок не будет работать правильно. Эту неполадку следует устранить путем проверки конфигурации службы обновления получателей предприятия.

Чтобы устранить эту ошибку

  1. Откройте диспетчер Exchange.

  2. Разверните узел Получатели, затем выберите узел Службы обновления получателей.

  3. В правой области щелкните правой кнопкой мыши службу обновления получателей, в части имени которой содержится ??(конфигурация предприятия)??, затем щелкните Свойства.

  4. Убедитесь, что в поле Домен отображается правильное имя домена.

  5. Убедитесь, что компьютеры, отображенные в списках полей сервер Exchange и Контроллер домена Windows, работают корректно и доступны в сети. Если эти системы выключены, недоступны или не являются требуемыми системами для выполнения задач службы обновления получателей, можно использовать кнопку Обзор для указания других компьютеров.

  6. Убедитесь, что значение поля Интервал обновления выставлено как Всегда выполнять.

  7. Нажмите кнопку ОК, чтобы сохранить изменения.

  8. В правой области щелкните правой кнопкой мыши службу обновления получателей, в части имени которой содержится ??(конфигурация предприятия)??, затем щелкните Перестроить. Будет отображено следующее сообщение:

    «Эта операция произведет пересчет членства списка адресов и параметров политики получателей для всех получателей в 'contoso.com' при следующем запланированном обновлении. В зависимости от количества получателей в домене операция может занять несколько часов. Продолжить?»

  9. Нажмите кнопку Да, чтобы перестроить службу обновления получателей.

  10. После 15 минут начните наблюдение за выполнением службы обновления получателей, следуя процедуре, описанной в статье 246127 базы знаний Майкрософт, посвященной проверке работы службы обновления получателей (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127).

Дополнительные сведения о службе обновления получателей см. в следующих статьях базы знаний Майкрософт:

  • статья 296479, посвященная требованиям для отключения службы обновления получателей (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=296479);

  • статья 328738, посвященная применению политик получателя службой обновления получателей (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • статья 253770, посвященная задачам, выполняемым службой обновления получателей (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770);

  • Статья 288807, описывающая задачи, выполняемые службой обновления получателей (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770);

  • статья 319065, описывающая инструкции по работе со службой обновления получателей Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319065).


Хранилище общих папок не подключается при загрузке
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchEDBOffline для всех объектов класса msExchPublicMDB. Объекты этого класса являются хранилищами общих папок.

Значение True для атрибута msExchEDBOffline указывает, что хранилище общих папок не будет автоматически подключаться при запуске службы банка данных Microsoft Exchange. Значение False указывает, что хранилище общих папок будет подключаться при запуске. Если анализатор сервера Exchange обнаруживает, что для этого атрибута задано значение True, отображается предупреждение.

Это предупреждение указывает, что установлен флажок Не подключать это хранилище при загрузке. Этот флажок находится на вкладке База данных диалогового окна Свойства хранилища общих папок. Если установлено этот флажок, то хранилище общих папок не будет автоматически подключаться при запуске службы банка данных Microsoft Exchange. При следующем запуске службы банка данных Microsoft Exchange, например после перезагрузки сервера, хранилище общих папок, для атрибута которого задано значение True, не будет запускаться. Рекомендуется настроить автоматический запуск хранилища общих папок при запуске службы банка данных Microsoft Exchange.

Для устранения этого предупреждения в Exchange 2000 Server и Exchange Server 2003 выполните следующие действия.

  1. Откройте диспетчер Exchange

  2. Разверните список Серверы, а затем откройте сервер, где находится хранилище общих папок, которое необходимо изменить.

  3. Разверните группу хранилищ, содержащую хранилище общих папок, которое необходимо изменить.

  4. Щелкните правой кнопкой мыши хранилище общих папок, а затем щелкните Свойства.

  5. На вкладке База данных снимите флажок Не подключать это хранилище при загрузке.

  6. Нажмите кнопку ОК, чтобы сохранить настройку.

  7. Закройте диспетчер Exchange.

Для устранения этого предупреждения в Exchange Server 2007 выполните следующие действия.

  1. Откройте консоль управления Exchange

  2. Раскройте узел Конфигурация сервера и выберите нужный сервер.

  3. Раскройте нужную группу хранилищ.

  4. Щелкните правой кнопкой мыши требуемую базу данных общих папок и выберите Свойства.

  5. На вкладке Общие снимите флажок Не подключать эту базу данных при загрузке.

  6. Нажмите кнопку ОК для сохранения изменений.

  7. Закройте консоль управления Exchange

Дополнительные сведения об этом параметре см. в следующих статьях базы знаний Майкрософт:

  • 314218, описывающая включение или выключение автоматического подключения хранилищ данных при запуске в Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314218)

  • 285169, описывающая случай, когда банки данных не подключаются после использования параметра «/disasterrecovery» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=285169)


Назначение базы данных для дерева общих папок
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchOwningPFTreeBL для каждого класса объекта msExchPFTree . Атрибут msExchOwningPFTreeBL хранит список различающихся имен хранилищ общих папок, содержащих реплику дерева общих папок. Если анализатор сервера Exchange определяет, что для атрибута msExchOwningPFTreeBL объекта дерева общих папок не задано значение, на экран выводится предупреждение. В этом предупреждении указано, что дерево общих папок не принадлежит никакому хранилищу общих папок.

Каждое дерево общих папок (также называемое «иерархией общих папок») связано с хранилищем общих папок. Сначала необходимо создать дерево, а потом хранилище. Если привязка дерева к базе данных еще не была выполнена, то выводится данное предупреждение. Для каждого дерева общих папок может быть задано только одно хранилище на конкретном сервере. Для дерева может быть задано несколько хранилищ, находящихся на разных серверах. При использовании такой конфигурации Exchange реплицирует данные между хранилищами для поддержания согласованной иерархии.

При попытке подключения веб-клиента Microsoft Office Outlook® к любой общей папке в дереве, для которой не заданы хранилища общих папок, выдается ошибка «служба недоступна» (HTTP 503).

Чтобы устранить причины появления этого предупреждения, необходимо выполнить одно из следующих действий:

  • Свяжите дерево общих папок с базой данных общих папок. Чтобы связать дерево общих папок с базой данных общих папок, необходимо сначала создать новую базу данных общих папок, а затем найти дерево общих папок и связать их между собой.

  • Удалите дерево общих папок. Если дерево общих папок не было связано с базой данных общих папок, то при удалении дерева никакие пользовательские данные утеряны не будут.

Чтобы связать дерево общих папок с базой данных общих папок

  1. В системном диспетчере Exchange разверните сервер, в который требуется добавить хранилище общих папок.

  2. Щелкните правой кнопкой мыши группу хранения, выберите Создать, а затем выберите Общее хранилище.

  3. В поле Имя введите имя новой базы данных.

  4. Чтобы связать дерево общих папок с базой данных, нажмите кнопку Обзор и выберите дерево общих папок, указанное в предупреждении анализатора сервера Exchange.

  5. Чтобы сохранить изменения, нажмите кнопку ОК.

  6. Чтобы подключить новое хранилище, нажмите кнопку Да.

Чтобы удалить дерево общих папок

  1. В системном диспетчере Exchange разверните узел Папки, содержащий дерево общих папок.

  2. Щелкните правой кнопкой мыши дерево общих папок, которое требуется удалить, нажмите кнопку Удалить, а затем нажмите кнопку Да.

Дополнительные сведения об администрировании общих папок см. в разделе руководства по администрированию Exchange Server 2003, посвященном управлению хранилищами почтовых ящиков и хранилищами общих папок (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=47617).

Для получения дополнительных сведений см. интерактивную справку по Exchange Server 2003 с пакетом обновления 1 (SP1) (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=29847).


Группа хранения для восстановления включена
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchESEParamBaseName для всех объектов, относящихся к классу msExchStorageGroup. Объекты этого класса являются объектами групп хранения. Значение R00 атрибута msExchESEParamBaseName указывает, что объект группы хранения является группой хранения для восстановления. Если анализатор сервера Exchange обнаружит, что значение этого атрибута равно R00, на экран будет выведено предупреждение.

Это предупреждение указывает, что группа хранения для восстановления существует. Рекомендуется удалить группу хранения для восстановления после завершения процесса восстановления. Если группу хранения для восстановления не удалить, администратор, не знакомый с группами хранения для восстановления, может запутаться, когда впоследствии будет выполнять стандартное восстановление.

Устранение причин этого предупреждения для серверов Exchange 2000 Server и Exchange Server 2003

  1. Откройте системный диспетчер Exchange.

  2. Разверните узел Серверы, а затем разверните узел сервера, содержащего группу хранения для восстановления, которую требуется удалить.

  3. Щелкните правой кнопкой мыши группу хранения для восстановления и в контекстном меню выберите команду Удалить.

  4. Закройте системный диспетчер Exchange.

Устранение причин появления этого предупреждения на сервере Windows Server 2007

  1. Следуйте указаниям раздела «How to Remove a Recovery Storage Group» (Как удалить группу хранения для восстановления) основной документации Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkId=80783).

Дополнительные сведения о группах хранения для восстановления и сервере Exchange Server 2003 см. в статье Using Exchange Server 2003 Recovery Storage Groups (Использование групп хранения для восстановления сервера Exchange Server 2003) (http://go.microsoft.com/fwlink/?LinkId=23233) и в статье 824126 базы знаний Майкрософт «How to use Recovery Storage Groups in Exchange Server 2003» (Применение групп хранения для восстановления в Exchange Server 2003) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=824126).

Дополнительные сведения о группах хранения для восстановления и сервере Exchange Server 2007 см. в документе, посвященном общим сведениям о группах хранения для восстановления (http://go.microsoft.com/fwlink/?LinkId=80784).


Функции групп аварийного хранения отключены
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Анализатор сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить, был ли изменен атрибут msExchMaxRestoreStorageGroups. Если анализатор сервера Exchange обнаружит, что атрибуту msExchMaxRestoreStorageGroups было присвоено значение 0, анализатор сервера Exchange выводит сообщение об ошибке.

msExchMaxRestoreStorageGroups — двоичный атрибут объекта банка данных, назначаемого каждому компьютеру Exchange. Если атрибут msExchMaxRestoreStorageGroups имеет значение 0, это не позволит создать группы аварийного хранения для данного компьютера Exchange.

Данная ошибка может возникнуть после выполнения обновления на месте с переходом от Exchange 2000 Server SP3 к Exchange Server 2003 SP1 в кластере Windows, в котором виртуальный сервер Exchange не был заменен версией Exchange Server 2003. Следует иметь в виду, что иногда такой сценарий обновления на месте может также вызвать сбой клиента Outlook® Mobile Access.

Ошибку, связанную с группами аварийного хранения, необходимо исправить, присвоив атрибуту msExchMaxRestoreStorageGroups значение 1 для каждого объекта банка данных, являющегося компьютером Exchange. Объекты банка данных, которых это касается, показаны в выходных данных анализатора сервера Exchange. По вопросам, связанным с Outlook Mobile Access, обращайтесь за помощью в службу поддержки Майкрософт.

Внимание!
Некорректное изменение атрибутов объектов Active Directory при использовании оснастки Edit интерфейса ADSI (Active Directory Service Interfaces), программы LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3 может вызвать серьезные проблемы. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, а также сервера Exchange Server 2003, сервера Exchange Server 2007 или обоих продуктов. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Чтобы исправить ошибку, связанную с группами аварийного хранения

  1. Запустите оснастку Edit интерфейса ADSI.

  2. Дважды щелкните контейнер Configuration, разверните последовательно CN=Services, CN=Microsoft Exchange и CN=<имя_организации_Exchange>.

  3. Разверните последовательно CN=Administrative Groups, CN=<имя_группы_администраторов> и CN=Servers.

  4. В области сведений щелкните правой кнопкой мыши CN=InformationStore и выберите команду Свойства.

  5. В окне Редактор атрибутов щелкните атрибут msExchMaxRestoreStorageGroups и нажмите кнопку Изменить.

  6. В поле Изменить атрибут введите 1.

  7. Нажмите кнопку Применить и затем кнопку ОК.

  8. Закройте оснастку Edit интерфейса ADSI. Перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Дополнительные сведения об использовании программы LDP см. в статье 260745 базы знаний Майкрософт об использовании служебной программы LDP для изменения атрибутов объектов Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Дополнительные сведения о восстановлении групп хранения Exchange см. в следующих ресурсах сервера Exchange:

  • Using Exchange Server 2003 Recovery Storage Groups (http://go.microsoft.com/fwlink/?LinkId=47589).

  • Understanding Recovery Storage Groups (http://go.microsoft.com/fwlink/?LinkID=80784)


Срок действия репликации для сервера общих папок является нестандартным
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2006-05-25

Средство анализа Microsoft® Exchange Server читает следующий параметр реестра для определения изменения значения по умолчанию для интервала удаления хранилищем Exchange элементов с закончившимся сроком хранения:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>\Replication Expiry

Если средство Exchange Server Analyzer обнаруживает, что Replication Expiry параметр реестра существует и настроен, появляется сообщение о нестандартной конфигурации.

Истечение срока сообщения - это процесс окончания срока действия сообщений в общих папках с превышенным установленным значением времени. Срок действия сообщения по умолчанию - 24 часа.

Важно!
В этой статье содержатся сведения о редактировании реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Для получения сведений о восстановлении реестра см. разделе «Восстановление реестра» справочной системы файла Regedit.exe или Regedt32.exe.

Восстановление настройки по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>

  3. Удалите параметр реестраReplication Expiry.

  4. Перезагрузите службу Microsoft Exchange Information Store, чтобы изменения вступили в силу.

Перед началом редактирования реестра, а также для получения сведений о редактировании реестра см. статью 256986 базы знаний корпорации Майкрософт, посвященную описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о репликации общих папок см. на веб-узле Работа с Exchange Server 2003 Store (http://go.microsoft.com/fwlink/?LinkId=47595) и в статье базы знаний 273479, посвященной описанию функций ссылок общих папок в Exchange 2000 Server и Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=273479).


Ограничение срока давности конфликта папки репликации для хранилища общих папок не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить, было ли изменено значение по умолчанию для срока давности конфликтов папок:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>\Replication Folder Conflict Age Limit

Если анализатор сервера Exchange обнаружит, что параметр реестра Replication Folder Conflict Age Limit существует и настроен, на экран выводится сообщение о нестандартной конфигурации.

Если два пользователя редактируют и изменяют одно и то же сообщение в общей папке, итоговые сохраненные сообщения определяются как конфликтующие. Это может произойти, если выполняется одновременное сохранение на один сервер общих папок, а также, когда сообщение редактируется на двух серверах, содержащих реплики папки. Если владельцы общей папки не предпринимают никаких действий в течение времени, указанного как ограничение срока давности конфликта, конфликт разрешается с помощью хранилища общих папок по истечении срока давности конфликта. Параметр реестра предела срока давности конфликта папок репликации определят предело срока давности. Его значением является количество дней, в течение которых могут существовать конфликтующие элементы.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Возврат к конфигурации по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>

  3. Удалите параметр реестра Replication Folder Conflict Age Limit.

  4. Перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о репликации общих папок см. в базе знаний Майкрософт в статье 273479, содержащей общие сведения о репликации общих папок и ссылках (http://go.microsoft.com/fwlink/?linkid=3052&kbid=273479).


Изменилось значение раздела реестра Replication Folder Count Limit
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, было ли изменено значение раздела Replication Folder Count Limit относительно значения по умолчанию, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ <\имя_сервера> \Public -<идентификатор GUID общего хранилища> \Replication Folder Count Limit

Если анализатор сервера Exchange обнаружит, что параметр Replication Folder Count Limit существует, будет отображено сообщение о нестандартной конфигурации.

По умолчанию раздел Replication Folder Count Limit не существует. Значение раздела Replication Folder Count Limit представляет максимальное количество папок, которое следует поместить в сообщение иерархии репликации (используется для репликации иерархии дерева и свойств общих папок). Значение должно находится в диапазоне между 1 и 1000; значением по умолчанию является 20. Раздел реестра недопустим в Exchange Server 2003 и более поздних версиях; он используется только в предыдущих версиях серверов Exchange.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы сбросить раздел реестра Replication Folder Count Limit

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeIS\<имя_сервера>\Public-<идентификатор GUID общего хранилища>

  3. Проанализируйте или измените значение параметра Replication Folder Count Limit.

    Значение для этой записи реестра выражено в килобайтах (КБ). Чтобы вернуться к значению по умолчанию, следует удалить параметр Replication Folder Count Limit и перезапустить службу Банк данных Microsoft Exchange.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о репликации общей папки см. в разделе по управлению репликацией общей папки Exchange Server 2003, который содержится в материалах, описывающих работу с хранилищем Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47595).


Изменено значение параметра Replication Folder Tree RMQ Timeout
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Для отслеживания изменений, вносимых в параметр Replication Folder Tree RMQ Timeout, средство анализа Microsoft® Exchange Server считывает следующий параметр реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ <servername> \Public -<GUID of Public Store> \Replication Folder Tree RMQ Timeout

Если средство анализа Exchange Server определяет, что параметр Replication Folder Tree RMQ Timeout существует, отображается сообщение о нестандартной настройке.

По умолчанию параметр Replication Folder Tree RMQ Timeout не существует. Для репликации иерархии дерева общих папок и их свойств Exchange использует иерархию сообщений. После получения реплицированных изменений хранилище общедоступных папок загружает изменения в память (очереди сообщений о репликации) для обработки. Параметр Replication Folder Tree RMQ Timeout представляет максимальное время, в течение которого реплицированные изменения иерархии могут оставаться в памяти. Значение в секундах должно находиться между 3600 (один час) и 2592000 (30 дней). Значением по умолчанию является 604800 (7 дней). Успешно обработанные изменения сразу удаляются из памяти. Изменения остаются в памяти, пока не будут обработаны или пока не истечет тайм-аут, по завершении которого изменения удаляются.

Допустим, одно изменение реплицируется для папки, а другое изменение реплицируется для подпапки этой папки. В зависимости от топологии и времени, прошедшего между изменениями, изменения могут быть получены хранилищем общедоступных папок в любом порядке. Если изменение подпапки получено первым, но не может быть обработано верно до вступления в силу изменения родительской папки, хранилище общедоступных папок оставит это изменение в памяти до получения и обработки изменения родительской папки. Если тайм-аут истекает до обработки изменения родительской папки, изменение подпапки будет удалено из памяти. После обработки изменения родительской папки хранилище общих папок может получить копию изменения подпапки, которая может быть успешно обработана. Если хранилище не получает копию изменения подпапки, во время проверки своего состояния по сравнению с другими хранилищами в топологии хранилище общих папок не обнаруживает изменение подпапки в своей копии дерева общих папок и начинает отмену этого изменения.

В большинстве случаев изменение стандартного значения параметра Replication Folder Tree RMQ Timeout не рекомендуется. Если это значение изменилось, возможно, оно было временно увеличено в период интенсивного трафика репликации (например, после добавления нового хранилища общих папок).

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что знаете, как восстановить реестр в случае возникновения проблем. Сведения о восстановлении реестра находятся в разделе справки «Восстановление реестра» файла Regedit.exe или Regedit32.exe.

Для восстановления параметра реестра Replication Folder Tree RMQ Timeout

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>

  3. Просмотрите или измените значение Replication Folder Tree RMQ Timeout.

    Значение этого параметра реестра вводится в секундах. Для восстановления значения по умолчанию удалите параметр Replication Folder Tree RMQ Timeout и перезапустите службу Microsoft Exchange Information Store.

Перед правкой реестра для получения дополнительных сведений см. статью 256986 Базы Знаний Microsoft "Описание реестра Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о репликации общих папок находятся в разделе «Controlling Exchange Server 2003 Public Folder Replication» в статьеWorking with the Exchange Server 2003 Store (http://go.microsoft.com/fwlink/?LinkId=47595).


Предел возраста захоронений папок репликации для хранилища общих папок отличается от заданного по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализа сервера Microsoft® Exchange, чтобы определить, отличается ли интервал удаления записей о захоронении общих папок от значения, заданного по умолчанию, считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder Store GUID>\Replication Folder Tombstone Age Limit

Если анализатор сервера Exchange обнаруживает, что в реестре есть запись Replication Folder Tombstone Age Limit, выводится сообщение о том, что конфигурация отличается от заданной по умолчанию.

Сведения о захоронении папок используется при репликации общих папок. Ограничение возраста необходимо для предотвращения неограниченного роста списка захоронений папок. Заданное по умолчанию значение, равное 180 дням, может быть переопределено с помощью параметра реестра Replication Folder Tombstone Age Limit.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы вернуться к конфигурации, заданной по умолчанию,

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder Store GUID>

  3. Удалите параметр реестра Replication Folder Tombstone Age Limit.

  4. Перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о параметре реестра Replication Folder Tombstone Age Limit см. в статье 159196 базы знаний Майкрософт, описывающей задачи, контролируемые расписанием обслуживания банка данных (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159196).


Изменено значение задержки длинного запроса обратной засыпки репликации
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, был ли изменен ключ Задержка длинного запроса обратной засыпки репликации относительно значения по умолчанию, средство анализатора Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<имя_сервера> \Public- <идентификатор GUID общего хранилища> \Задержка длинного запроса обратной засыпки репликации

Если анализатор сервера Exchange обнаружит, что параметр Задержка длинного запроса обратной засыпки репликации должен присутствовать, на экран выводится сообщение о конфигурации, отличной от конфигурации по умолчанию.

По умолчанию параметр Задержка длинного запроса обратной засыпки репликации не существует. Обратная засыпка происходит, когда хранилищем общих папок определяется, что не все обновления были получены для реплицированной папки (или для иерархии), и необходимо извлечь отсутствующие обновления из другого хранилища.

Чтобы упростить процесс обратной засыпки, сервер Exchange хранит сведения об отсутствующих обновлениях в массиве обратной засыпки. В массиве обратной засыпки эти сведения хранятся в течение указанного периода времени (называемого тайм-аутом обратной засыпки). Если отсутствующие обновления поступают в последующих сообщениях репликации в течение этого времени, они удаляются из массива обратной засыпки. В приводимой ниже таблице перечисляются значения тайм-аута обратной засыпки по умолчанию, которые зависят от того, где существуют отсутствующие обновления и запрашивались ли они прежде.

Тип запроса | Содержимое существует в хранилище на локальном узле | Содержимое существует в хранилище на удаленном узле
Исходная обратная засыпка | 6 часов | 12 часов
Первая попытка обратной засыпки | 12 часов | 24 часа
Последующие попытки обратной засыпки | 24 часа | 48 часов

Если тайм-аут обратной засыпки истекает, и обновления по-прежнему отсутствуют, Exchange Server 2003 создает один или более запросов обратной засыпки и определяет, какие серверы должны использоваться в качестве источников обратной засыпки.

Чтобы выбрать сервер (или серверы) для использования в качестве источника обратной засыпки, Exchange Server 2003 сначала создает список всех серверов, имеющих копии папки, а затем сортирует список согласно следующей последовательности условий:

  • Сортировка по состоянию серверов. Серверы, которые выключены или недоступны, переносятся в конец списка.

  • Сортировка согласно предпочтительному серверу обратной засыпки, если такой имеется; эта возможность доступна только в Exchange Server 2003 и более поздних версиях. Exchange Server 2003 проверяет объект хранилища общих папок и службу каталогов Active Directory® на наличие предпочтительного сервера обратной засыпки. Эта настройка используется редко. В большинстве случаев процесс обратной засыпки действует наиболее эффективно, если Exchange Server 2003 выбирает сервер обратной засыпки автоматически. Для большинства развертываний Exchange Server 2003 предпочтительный сервер обратной засыпки не нужен. Служба поддержки продуктов Майкрософт может предоставить сценарий, который устанавливает предпочтительный сервер засыпки, если это необходимо для конкретного развертывания.

  • Сортировка по стоимости транспортировки (от наименьшей к наибольшей). Серверы на одном и том же узле имеют приоритет над серверами в удаленных узлах. Стоимость транспортировки для сервера вычисляется модулем маршрутизации Exchange Server 2003 и обычно используется для расчета наиболее эффективного способа доставки сообщения. Обратите внимание, что в версиях Exchange, предшествующих Exchange Server 2003, стоимость транспортировки имеет более низкий приоритет и учитывается только после версии Exchange и количества доступных изменений.

  • Сортировка по версии Exchange (от новейшей к самой старой)

  • Сортировка по количеству необходимых изменений, которые доступны на сервере (от максимальных к минимальным). Серверы, на которых нет каких-либо отсутствующих изменений, удаляются из списка.

Если на сервере нет всех необходимых изменений, Exchange Server 2003 выбирает следующий сервер в отсортированном списке и отправляет запрос на обратную засыпку и на этот сервер. Этот процесс повторяется до тех пор, пока все изменения не будут запрошены. Данная функция доступна только в Exchange Server 2003 и более поздних версиях; предыдущие версии Exchange отправляют запросы обратной засыпки на один сервер за раз, если никакой из серверов не содержит все отсутствующие обновления для определенной папки. После каждого запроса предыдущие версии Exchange ожидают в течение тайм-аута попытки (от 24 до 48 часов), прежде чем отправляют следующий запрос.

Если выбранный сервер не отвечает на запрос обратной засыпки, хранилище помечает этот сервер как выключенный и повторяет процесс выбора. Серверы, помеченные как выключенные, переносятся в конец списка.

Значение параметра Задержка длинного запроса обратной засыпки репликации представляет собой период времени, в течение которого хранилище выжидает, прежде чем отправить запрос обратной засыпки для данных, которые недоступны на том же узле Exchange. Значение, выраженное в секундах, должно находиться в диапазоне от 900 до 2592000 секунд (30 дней); значение по умолчанию: 43200 секунд (12 часов).

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы сбросить в исходное состояние параметр реестра «Задержка длинного запроса обратной засыпки репликации»

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<имя_сервера>\Public-<идентификатор GUID общего хранилища>

  3. Проанализируйте или измените значение параметра Задержка длинного запроса обратной засыпки репликации.

    Значение для этой записи реестра выражено в секундах. Чтобы вернуться к значению по умолчанию, следует удалить параметр Задержка длинного запроса обратной засыпки репликации и перезапустить службу Банк данных Microsoft Exchange.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о репликации общей папки см. в разделе по управлению репликацией общей папки Exchange Server 2003, который содержится в материалах, описывающих работу с хранилищем Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47595).


Изменение значения тайм-аута длинного запроса обратной засыпки репликации
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, был ли изменен ключ Тайм-аут длинного запроса обратной засыпки репликации относительно значения по умолчанию, средство анализатора Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<имя_сервера> \Public -<идентификатор GUID общего хранилища> \Тайм-аут длинного запроса обратной засыпки репликации

Если анализатор сервера Exchange обнаружит, что параметр Тайм-аут длинного запроса обратной засыпки репликации должен присутствовать, на экран выводится сообщение о конфигурации, отличной от конфигурации по умолчанию.

По умолчанию параметр Тайм-аут длинного запроса обратной засыпки репликации не существует. Обратная засыпка происходит, когда хранилищем общих папок определяется, что не все обновления были получены для реплицированной папки (или для иерархии), и необходимо извлечь отсутствующие обновления из другого хранилища.

Чтобы упростить процесс обратной засыпки, сервер Exchange хранит сведения об отсутствующих обновлениях в массиве обратной засыпки. В массиве обратной засыпки эти сведения хранятся в течение указанного периода времени (называемого тайм-аутом обратной засыпки). Если отсутствующие обновления поступают в последующих сообщениях репликации в течение этого времени, они удаляются из массива обратной засыпки. В приводимой ниже таблице перечисляются значения тайм-аута обратной засыпки по умолчанию, которые зависят от того, где существуют отсутствующие обновления и запрашивались ли они прежде.

Тип запроса | Содержимое существует в хранилище на локальном узле | Содержимое существует в хранилище на удаленном узле
Исходная обратная засыпка | 6 часов | 12 часов
Первая попытка обратной засыпки | 12 часов | 24 часа
Последующие попытки обратной засыпки | 24 часа | 48 часов

Если тайм-аут обратной засыпки истекает, и обновления по-прежнему отсутствуют, Exchange Server 2003 создает один или более запросов обратной засыпки и определяет, какие серверы должны использоваться в качестве источников обратной засыпки.

Чтобы выбрать сервер (или серверы) для использования в качестве источника обратной засыпки, Exchange Server 2003 сначала создает список всех серверов, имеющих копии папки, а затем сортирует список согласно следующей последовательности условий:

  • Сортировка по состоянию серверов. Серверы, которые выключены или недоступны, переносятся в конец списка.

  • Сортировка согласно предпочтительному серверу обратной засыпки, если такой имеется; эта возможность доступна только в Exchange Server 2003 и более поздних версиях. Exchange Server 2003 проверяет объект хранилища общих папок и службу каталогов Active Directory® на наличие предпочтительного сервера обратной засыпки. Эта настройка используется редко. В большинстве случаев процесс обратной засыпки действует наиболее эффективно, если Exchange Server 2003 выбирает сервер обратной засыпки автоматически. Для большинства развертываний Exchange Server 2003 предпочтительный сервер обратной засыпки не нужен. Служба поддержки продуктов Майкрософт может предоставить сценарий, который устанавливает предпочтительный сервер засыпки, если это необходимо для конкретного развертывания.

  • Сортировка по стоимости транспортировки (от наименьшей к наибольшей). Серверы на одном и том же узле имеют приоритет над серверами в удаленных узлах. Стоимость транспортировки для сервера вычисляется модулем маршрутизации Exchange Server 2003 и обычно используется для расчета наиболее эффективного способа доставки сообщения. Обратите внимание, что в версиях Exchange, предшествующих Exchange Server 2003, стоимость транспортировки имеет более низкий приоритет и учитывается только после версии Exchange и количества доступных изменений.

  • Сортировка по версии Exchange (от новейшей к самой старой)

  • Сортировка по количеству необходимых изменений, которые доступны на сервере (от максимальных к минимальным). Серверы, на которых нет каких-либо отсутствующих изменений, удаляются из списка.

Если на сервере нет всех необходимых изменений, Exchange Server 2003 выбирает следующий сервер в отсортированном списке и отправляет запрос на обратную засыпку и на этот сервер. Этот процесс повторяется до тех пор, пока все изменения не будут запрошены. Данная функция доступна только в Exchange Server 2003 и более поздних версиях; предыдущие версии Exchange отправляют запросы обратной засыпки на один сервер за раз, если никакой из серверов не содержит все отсутствующие обновления для определенной папки. После каждого запроса предыдущие версии Exchange ожидают в течение тайм-аута попытки (от 24 до 48 часов), прежде чем отправляют следующий запрос.

Если выбранный сервер не отвечает на запрос обратной засыпки, хранилище помечает этот сервер как выключенный и повторяет процесс выбора. Серверы, помеченные как выключенные, переносятся в конец списка.

Значение параметра Тайм-аут длинного запроса обратной засыпки репликации представляет значение тайм-аута, используемое хранилищем общих папок при попытке отправки запроса обратной засыпки для данных, которые недоступны на том же узле Exchange. Значение, выраженное в секундах, должно находиться в диапазоне от 900 до 2592000 секунд (30 дней); значение по умолчанию: 86400 секунд (24 часов).

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы сбросить в исходное состояние параметр реестра «Тайм-аут длинного запроса обратной засыпки репликации»

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<имя_сервера>\Public-<идентификатор GUID общего хранилища>

  3. Проанализируйте или измените значение параметра Тайм-аут длинного запроса обратной засыпки репликации.

    Значение для этой записи реестра выражено в секундах. Чтобы вернуться к значению по умолчанию, следует удалить параметр Тайм-аут длинного запроса обратной засыпки репликации и перезапустить службу Банк данных Microsoft Exchange.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о репликации общей папки см. в разделе по управлению репликацией общей папки Exchange Server 2003, который содержится в материалах, описывающих работу с хранилищем Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47595).


Изменилось значение повторов тайм-аута длинного запроса обратной засыпки репликации
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, был ли изменен параметр Повтор тайм-аута длинного запроса обратной засыпки репликации относительно значения по умолчанию, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<имя_сервера> \Public- <идентификатор GUID общего хранилища> \Повтор тайм-аута длинного запроса обратной засыпки репликации

Если анализатор сервера Exchange обнаружит, что параметр Повтор тайм-аута длинного запроса обратной засыпки репликации присутствует, на экран выводится сообщение о конфигурации, отличной от конфигурации по умолчанию.

По умолчанию параметр Повтор тайм-аута длинного запроса обратной засыпки репликации не существует. Обратная засыпка происходит, когда хранилищем общих папок определяется, что не все обновления были получены для реплицированной папки (или для иерархии), и необходимо извлечь отсутствующие обновления из другого хранилища.

Чтобы упростить процесс обратной засыпки, сервер Exchange хранит сведения об отсутствующих обновлениях в массиве обратной засыпки. В массиве обратной засыпки эти сведения хранятся в течение указанного периода времени (называемого тайм-аутом обратной засыпки). Если отсутствующие обновления поступают в последующих сообщениях репликации в течение этого времени, они удаляются из массива обратной засыпки. В таблице перечисляются значения тайм-аута обратной засыпки по умолчанию, которые зависят от того, где существуют отсутствующие обновления и запрашивались ли они прежде.

Тип запроса | Содержимое существует в хранилище на локальном узле | Содержимое существует в хранилище на удаленном узле
Исходная обратная засыпка | 6 часов | 12 часов
Первая попытка обратной засыпки | 12 часов | 24 часа
Последующие попытки обратной засыпки | 24 часа | 48 часов

Если тайм-аут обратной засыпки истекает, и обновления по-прежнему отсутствуют, Exchange Server 2003 создает один или более запросов обратной засыпки и определяет, какие серверы должны использоваться в качестве источников обратной засыпки.

Чтобы выбрать сервер (или серверы) для использования в качестве источника обратной засыпки, Exchange Server 2003 сначала создает список всех серверов, имеющих копии папки, а затем сортирует список согласно следующей последовательности условий:

  • Сортировка по состоянию серверов. Серверы, которые выключены или недоступны, переносятся в конец списка.

  • Сортировка согласно предпочтительному серверу обратной засыпки, если такой имеется; эта возможность доступна только в Exchange Server 2003 и более поздних версиях. Exchange Server 2003 проверяет объект хранилища общих папок и службу каталогов Active Directory® на наличие предпочтительного сервера обратной засыпки. Эта настройка используется редко. В большинстве случаев процесс обратной засыпки действует наиболее эффективно, если Exchange Server 2003 выбирает сервер обратной засыпки автоматически. Для большинства развертываний Exchange Server 2003 предпочтительный сервер обратной засыпки не нужен. Служба поддержки продуктов Майкрософт может предоставить сценарий, который устанавливает предпочтительный сервер засыпки, если это необходимо для конкретного развертывания.

  • Сортировка по стоимости транспортировки (от наименьшей к наибольшей). Серверы на том же узле имеют приоритет над серверами в удаленных узлах. Стоимость транспортировки для сервера вычисляется модулем маршрутизации Exchange Server 2003 и обычно используется для расчета наиболее эффективного способа доставки сообщения. Обратите внимание, что в версиях Exchange, предшествующих Exchange Server 2003, стоимость транспортировки имеет более низкий приоритет и учитывается только после версии Exchange и количества доступных изменений.

  • Сортировка по версии Exchange (от новейшей к самой старой)

  • Сортировка по количеству необходимых изменений, которые доступны на сервере (от максимальных к минимальным). Серверы, на которых нет каких-либо отсутствующих изменений, удаляются из списка.

Если на сервере нет всех требуемых изменений, Exchange Server 2003 выбирает следующий сервер в отсортированном списке и отправляет запрос на обратную засыпку и на этот сервер. Этот процесс повторяется до тех пор, пока все изменения не будут запрошены. Данная функция доступна только в Exchange Server 2003 и более поздних версиях; предыдущие версии Exchange отправляют запросы на обратную засыпку на один сервер за раз, если никакой из серверов не содержит все отсутствующие обновления для определенной папки. После каждого запроса предыдущие версии Exchange ожидают в течение тайм-аута попытки (от 24 до 48 часов), прежде чем отправляют следующий запрос.

Если выбранный сервер не отвечает на запрос обратной засыпки, хранилище помечает этот сервер как выключенный и повторяет процесс выбора. Серверы, помеченные как выключенные, переносятся в конец списка.

Значение параметра Повтор тайм-аута длинного запроса обратной засыпки репликации представляет значение тайм-аута, используемое хранилищем общих папок при отправке запроса обратной засыпки для данных, которые недоступны на том же узле Exchange, и когда этот запрос является повторением предыдущего запроса обратной засыпки. Значение, выраженное в секундах, должно находиться в диапазоне от 900 до 2592000 секунд (30 дней); значение по умолчанию: 172800 секунд (48 часов).

Важно!
Этот раздел содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы сбросить в исходное состояние параметр реестра «Повтор тайм-аута длинного запроса обратной засыпки репликации»

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<имя_сервера>\Public-<идентификатор GUID общего хранилища>

  3. Проанализируйте или измените значение параметра Повтор тайм-аута длинного запроса обратной засыпки репликации.

    Значение для этой записи реестра выражено в секундах. Чтобы вернуться к значению по умолчанию, следует удалить параметр Повтор тайм-аута длинного запроса обратной засыпки репликации и перезапустить службу Банк данных Microsoft Exchange.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о репликации общей папки см. в разделе по управлению репликацией общей папки Exchange Server 2003, который содержится в материалах, описывающих работу с хранилищем Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47595).


Включено создание сообщений репликации при загрузке
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, настроено ли в Exchange создание сообщений о запросе состояния для иерархии общих папок, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Public-<Public Information Store GUID>\Enable Replication Messages At Startup

Если анализатор сервера Exchange обнаруживает, что запись реестра Enable Replication Messages At Startup существует и настроена, отображается сообщение о нестандартной конфигурации.

В Exchange Server 5.5 каждый компьютер с хранилищем общих папок каждую ночь отправляет сообщение с запросом о состоянии сообщения, чтобы определить состояние иерархии общих папок. В Exchange 2000 Server и Exchange Server 2003 это не происходит. Обычно в Exchange 2000 Server и Exchange Server 2003 сообщение запроса о состоянии отправляется только один раз в течение срока жизни хранилища общей папки, оно отправляется при создании хранилища.

Однако в определенных обстоятельствах может понадобиться создать сообщение запроса о состоянии. Например, если создается впечатление, что иерархия общих папок на компьютерах, где выполняются Exchange 2000 Server или Exchange Server 2003, не реплицируется или реплицируется очень медленно, сообщение запроса о состоянии позволит продолжить выполнять репликацию иерархии общих папок. Проблемы, связанные с репликацией иерархии общих папок могут произойти, если исходное сообщение запроса о состоянии, отправленное при создании хранилища общих папок, было отброшено и не подтверждено, а также в случае, если сообщение было отправлено на сервер с неполной иерархией.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы просмотреть или изменить значение реестра Aging Keep Time

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Public-<Public Information Store GUID>

  3. Просмотрите или, если необходимо, измените значение Enable Replication Messages At Startup. Для вступления изменения в силу для REG_DWORD должно быть задано значение 1. Если задано значение 0 (по умолчанию), сообщение с запросом о состоянии не будет отправляться при запуске хранилища общих папок.

  4. После выполнения изменения закройте редактор реестра, а затем отключите и повторно подключите хранилище общих папок, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о сообщениях запроса о состоянии репликации общих папок и значении параметра реестра Enable Replication Messages At Startup см. в базе знаний Майкрософт в статьях:

  • Статья 321082, описывающая способы очистки очереди почтовых сообщений SMTP в Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=321082)

  • Статья 842273, описывающая устранение неполадок, связанных с репликацией общих папок в Exchange 2000 Server и Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=842273)


Значение Replication Short Backfill Request Delay изменено
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализа сервера Microsoft® Exchange считывает следующий параметр реестра, чтобы определить, было ли изменено значение по умолчанию параметра Replication Short Backfill Request Delay:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<servername> \Public -<GUID of Public Store> \Replication Short Backfill Request Delay

Если анализатор сервера Exchange обнаруживает, что параметр Replication Short Backfill Request Delay имеется в наличии, будет выведено сообщение настройке не по умолчанию.

По умолчанию раздела Replication Short Backfill Request Delay не существует. Заполнение задним числом возникает, когда хранилище общих папок определяет, что получены не все обновления для реплицированной папки (или для иерархии папок), и вынуждено получать недостающие обновления из другого хранилища.

Чтобы упростить процесс заполнения задним числом, сервер Exchange Server сохраняет данные о недостающих обновлениях в массиве заполнения задним числом. Масив заполнения задним числом хранит эти данные в течение указанного интервала времени (он называется интервалом ожидания заполнения задним числом). Если недостающие обновления поступают последющими репликационными сообщениями в течение этого времени, они удаляются из массива заполнения задним числом. В таблице перечислены значения по умолчанию интервалов ожидания заполнения задним числом, которые зависят от того, где находятся недостающие обновления и запрашивались ли они ранее.

Тип запроса | Содержимое находится в хранилище на сервере на локальном сайте | Содержимое находится в хранилище на сервере на удаленном сайте
Начальное заполнение задним числом | 6 часов | 12 часов
Первая попытка повторного заполнения задним числом | 12 часов | 24 часа
Последующие попытки повторного заполнения задним числом | 24 часа | 48 часов

Если интервал заполнения задним числом истек, а обновлений так и не поступило, Exchange Server 2003 создает один или больше запросов на заполнение задним числом и определяет, который из серверов использовать в качестве источника заполнения задним числом.

Чтобы выбрать сервер (или серверы) для использования в качестве источника заполнения задним числом, Exchange Server 2003 сначала создает список всех серверов, обладающих репликами папок, а затем сортирует список последовательно согласно следующим критериям:

  • Сортировка соответственно состоянию сервера Остановленные или недоступные серверы опускаются в конец списка.

  • Сортировка согласно предпочитаемому серверу заполнения задним числом При наличии таковых; эта функция доступна только при использовании версии Exchange Server 2003 или более поздней. Exchange Server 2003 проверяет объект хранилища общих папок в службе каталогов Active Directory®, чтобы обнаружить предпочитаемый сервер заполнения задним числом. Этот параметр используется редко. В большинстве случаев процесс заполнения задним числом эффективней всего работает в том случае, если Exchange Server 2003 выбирает сервер заполнения задним числом автоматически. В большинстве установок Exchange Server 2003 предпочтительный сервер заполнения задним числом не требуется. Служба поддержки продукта корпорации Майкрософт может предоставить сценарий, который устанавливает предпочитаемый сервер заполнения задним числом, если необходимо его развертывание.

  • Сортировка согласно транспортным затратам (от наименьших к наиболее высоким) Серверы, расположенные на том же узле, имеют приоритет перед серверами, расположеннми на удаленных узлах. Транспортные затраты сервера рссчитываются модулем маршрутизации Exchange Server 2003, и обычно используется тот путь доставки сообщений, который рассчитан как самый эффективный. Обратите внимание, что в версиях Exchange, предшествующих Exchange Server 2003, транспортные затраты имеют более низкий приоритет, и учитываются только после версии Exchange и числа доступных изменений.

  • Сортировка по версии Exchange (от новейшей к старейшей)

  • Сортировка согласно числу необходимых изменений, доступных на сервере (от наибольшего количества до наименьшего) Серверы, не имеющие никаких из недостающих изменений, удаляются из списка.

Если сервер не имеет всех необходимых изменений, Exchange Server 2003 выбирает следующий сервер из списка сортировки и также посылает запрос на заполнение задним числом этому серверу. Эта процедура повторяется до тех пор, пока все изменения не будут запрошены. Эта функция доступна только в версии Exchange Server 2003 и более поздних; предыдущие версии Exchange посылают запрос на заполнение задним числом только одному серверу единовременно, если никакой единственный сервер не содержит все недостающие обновления для конкретной папки. После каждого запроса предыдущие версии Exchange выжидают определенный интервал времени до повторной попытки (от 24 до 48 часов), прежде чем отсылают следующий запрос.

Если выбранный сервер не отвечает на запрос на заполнение задним числом, хранилище помечает этот сервер как остановленный и повторяет процедуру выбора. Серверы, помеченные как остановленные, перемещаются в конец списка.

Значение раздела Replication Short Backfill Request Delay соответствует интервалу времени, в течение которого хранилище общих папок задерживается перед тем, как послать запрос на заполнение заждним числом для тех данных, что доступны в том же сайте Exchange. Это значение должно быть равно от 900 до 2592000 секунд (30 дней); по умолчанию это значение равно 21600 секундам (6 часам).

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неполадки. Для получения сведений о восстановлении реестра см. раздел справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Как сбросить значение раздела реестра Replication Short Backfill Request Delay

  1. Откройте редактор реестра, такой как Regedit.exe или Regedt32.exe.

  2. Перейдите по адресу: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>

  3. Проверьте или измените значение параметра Replication Short Backfill Request Delay.

    Значение этого параметра реестра устанавливается в секундах. Чтобы вернуться к значению по умолчанию, нужно удалить Replication Short Backfill Request Delay и перезапустить службу информационного хранилища Microsoft Exchange.

Перед правкой реестра и для получения сведений о правке реестра см. статью 256986 базы знаний корпорации Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Для получения дополнительных сведений о репликации общих папок см. «Управление репликациями общих папок в Exchange Server 2003» в статье Работа с хранилищем Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).


Изменение значения тайм-аута короткого запроса обратной засыпки репликации
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, был ли изменен ключ Тайм-аут короткого запроса обратной засыпки репликации относительно значения по умолчанию, средство анализатора Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ <имя_сервера> \Public -<идентификатор GUID общего хранилища> \Тайм-аут короткого запроса обратной засыпки репликации

Если анализатор сервера Exchange обнаружит, что параметр Тайм-аут короткого запроса обратной засыпки репликации должен присутствовать, на экран будет выведено сообщение о конфигурации, отличной от конфигурации по умолчанию.

По умолчанию параметр Тайм-аут короткого запроса обратной засыпки репликации не существует. Обратная засыпка происходит, когда хранилищем общих папок определяется, что не все обновления были получены для реплицированной папки (или для иерархии), и необходимо извлечь отсутствующие обновления из другого хранилища.

Чтобы упростить процесс обратной засыпки, сервер Exchange хранит сведения об отсутствующих обновлениях в массиве обратной засыпки. В массиве обратной засыпки эти сведения хранятся в течение указанного периода времени (называемого тайм-аутом обратной засыпки). Если отсутствующие обновления поступают в последующих сообщениях репликации в течение этого времени, они удаляются из массива обратной засыпки. В приводимой ниже таблице перечисляются значения тайм-аута обратной засыпки по умолчанию, которые зависят от того, где существуют отсутствующие обновления и запрашивались ли они прежде.

Тип запроса | Содержимое существует в хранилище на локальном узле | Содержимое существует в хранилище на удаленном узле
Исходная обратная засыпка | 6 часов | 12 часов
Первая попытка обратной засыпки | 12 часов | 24 часв
Последующие попытки обратной засыпки | 24 часа | 48 часов

Если тайм-аут обратной засыпки истекает, и обновления по-прежнему отсутствуют, Exchange Server 2003 создает один или более запросов обратной засыпки и определяет, какие серверы должны использоваться в качестве источников обратной засыпки.

Чтобы выбрать сервер (или серверы) для использования в качестве источника обратной засыпки, Exchange Server 2003 сначала создает список всех серверов, имеющих копии папки, а затем сортирует список согласно следующей последовательности условий:

  • Сортировка по состоянию серверов. Серверы, которые выключены или недоступны, переносятся в конец списка.

  • Сортировка согласно предпочтительному серверу обратной засыпки, если такой имеется; эта возможность доступна только в Exchange Server 2003 и более поздних версиях. Exchange Server 2003 проверяет объект хранилища общих папок и службу каталогов Active Directory® на наличие предпочтительного сервера обратной засыпки. Эта настройка используется редко. В большинстве случаев процесс обратной засыпки действует наиболее эффективно, если Exchange Server 2003 выбирает сервер обратной засыпки автоматически. Для большинства развертываний Exchange Server 2003 предпочтительный сервер обратной засыпки не нужен. Служба поддержки продуктов Майкрософт может предоставить сценарий, который устанавливает предпочтительный сервер засыпки, если это необходимо для конкретного развертывания.

  • Сортировка по стоимости транспортировки (от наименьшей к наибольшей). Серверы на одном и том же узле имеют приоритет над серверами в удаленных узлах. Стоимость транспортировки для сервера вычисляется модулем маршрутизации Exchange Server 2003 и обычно используется для расчета наиболее эффективного способа доставки сообщения. Обратите внимание, что в версиях Exchange, предшествующих Exchange Server 2003, стоимость транспортировки имеет более низкий приоритет и учитывается только после версии Exchange и количества доступных изменений.

  • Сортировка по версии Exchange (от новейшей к самой старой)

  • Сортировка по количеству необходимых изменений, которые доступны на сервере (от максимальных к минимальным). Серверы, на которых нет каких-либо отсутствующих изменений, удаляются из списка.

Если на сервере нет всех необходимых изменений, Exchange Server 2003 выбирает следующий сервер в отсортированном списке и отправляет запрос на обратную засыпку и на этот сервер. Этот процесс повторяется до тех пор, пока все изменения не будут запрошены. Данная функция доступна только в Exchange Server 2003 и более поздних версиях; предыдущие версии Exchange отправляют запросы обратной засыпки на один сервер за раз, если никакой из серверов не содержит все отсутствующие обновления для определенной папки. После каждого запроса предыдущие версии Exchange ожидают в течение тайм-аута попытки (от 24 до 48 часов), прежде чем отправляют следующий запрос.

Если выбранный сервер не отвечает на запрос обратной засыпки, хранилище помечает этот сервер как выключенный и повторяет процесс выбора. Серверы, помеченные как выключенные, переносятся в конец списка.

Значение параметра Тайм-аут короткого запроса обратной засыпки репликации представляет значение тайм-аута, используемое хранилищем общих папок при попытке отправки запроса обратной засыпки для данных, которые недоступны на том же узле Exchange. Значение, выраженное в секундах, должно находиться в диапазоне от 900 до 2592000 секунд (30 дней); значение по умолчанию: 43200 секунд (12 часов).

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы сбросить в исходное состояние параметр реестра «Тайм-аут короткого запроса обратной засыпки репликации»

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<имя_сервера>\Public-<идентификатор GUID общего хранилища>

  3. Проанализируйте или измените значение параметра Тайм-аут короткого запроса обратной засыпки репликации.

    Значение для этой записи реестра выражено в секундах. Чтобы вернуться к значению по умолчанию, следует удалить параметр Тайм-аут короткого запроса обратной засыпки репликации и перезапустить службу Банк данных Microsoft Exchange.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о репликации общей папки см. в разделе по управлению репликацией общей папки Exchange Server 2003, который содержится в материалах, описывающих работу с хранилищем Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47595).


Изменено значения повторов тайм-аута короткого запроса обратной засыпки репликации
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, был ли изменен параметр Повтор тайм-аута короткого запроса обратной засыпки репликации относительно значения по умолчанию, средство анализатора Microsoft® Exchange Server считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<имя_сервера> \Public -<идентификатор GUID общего хранилища> \Повтор тайм-аута короткого запроса обратной засыпки репликации

Если анализатор сервера Exchange обнаружит, что параметр Повтор тайм-аута короткого запроса обратной засыпки репликации должен присутствовать, на экран выводится сообщение о конфигурации, отличной от конфигурации по умолчанию.

По умолчанию Повтор тайм-аута короткого запроса обратной засыпки репликации не существует. Обратная засыпка происходит, когда хранилищем общих папок определяется, что не все обновления были получены для реплицированной папки (или для иерархии), и необходимо извлечь отсутствующие обновления из другого хранилища.

Чтобы упростить процесс обратной засыпки, сервер Exchange хранит сведения об отсутствующих обновлениях в массиве обратной засыпки. В массиве обратной засыпки эти сведения хранятся в течение указанного периода времени (называемого тайм-аутом обратной засыпки). Если отсутствующие обновления поступают в последующих сообщениях репликации в течение этого времени, они удаляются из массива обратной засыпки. В приводимой ниже таблице перечисляются значения тайм-аута обратной засыпки по умолчанию, которые зависят от того, где существуют отсутствующие обновления и запрашивались ли они прежде.

Тип запроса | Содержимое существует в хранилище на локальном узле | Содержимое существует в хранилище на удаленном узле
Исходная обратная засыпка | 6 часов | 12 часов
Первая попытка обратной засыпки | 12 часов | 24 часа
Последующие попытки обратной засыпки | 24 часа | 48 часов

Если тайм-аут обратной засыпки истекает, и обновления по-прежнему отсутствуют, Exchange Server 2003 создает один или более запросов обратной засыпки и определяет, какие серверы должны использоваться в качестве источников обратной засыпки.

Чтобы выбрать сервер (или серверы) для использования в качестве источника обратной засыпки, Exchange Server 2003 сначала создает список всех серверов, имеющих копии папки, а затем сортирует список согласно следующей последовательности условий:

  • Сортировка по состоянию серверов. Серверы, которые выключены или недоступны, переносятся в конец списка.

  • Сортировка согласно предпочтительному серверу обратной засыпки, если такой имеется; эта возможность доступна только в Exchange Server 2003 и более поздних версиях. Exchange Server 2003 проверяет объект хранилища общих папок и службу каталогов Active Directory® на наличие предпочтительного сервера обратной засыпки. Эта настройка используется редко. В большинстве случаев процесс обратной засыпки действует наиболее эффективно, если Exchange Server 2003 выбирает сервер обратной засыпки автоматически. Для большинства развертываний Exchange Server 2003 предпочтительный сервер обратной засыпки не нужен. Служба поддержки продуктов Майкрософт может предоставить сценарий, который устанавливает предпочтительный сервер засыпки, если это необходимо для конкретного развертывания.

  • Сортировка по стоимости транспортировки (от наименьшей к наибольшей). Серверы на одном и том же узле имеют приоритет над серверами в удаленных узлах. Стоимость транспортировки для сервера вычисляется модулем маршрутизации Exchange Server 2003 и обычно используется для расчета наиболее эффективного способа доставки сообщения. Обратите внимание, что в версиях Exchange, предшествующих Exchange Server 2003, стоимость транспортировки имеет более низкий приоритет и учитывается только после версии Exchange и количества доступных изменений.

  • Сортировка по версии Exchange (от новейшей к самой старой)

  • Сортировка по количеству необходимых изменений, которые доступны на сервере (от максимальных к минимальным). Серверы, на которых нет каких-либо отсутствующих изменений, удаляются из списка.

Если на сервере нет всех требуемых изменений, Exchange Server 2003 выбирает следующий сервер в отсортированном списке и отправляет запрос на обратную засыпку и на этот сервер. Этот процесс повторяется до тех пор, пока все изменения не будут запрошены. Данная функция доступна только в Exchange Server 2003 и более поздних версиях; предыдущие версии Exchange отправляют запросы обратной засыпки на один сервер за раз, если никакой из серверов не содержит все отсутствующие обновления для определенной папки. После каждого запроса предыдущие версии Exchange ожидают в течение тайм-аута попытки (от 24 до 48 часов), прежде чем отправляют следующий запрос.

Если выбранный сервер не отвечает на запрос обратной засыпки, хранилище помечает этот сервер как выключенный и повторяет процесс выбора. Серверы, помеченные как выключенные, переносятся в конец списка.

Значение параметра Повтор тайм-аута короткого запроса обратной засыпки репликации представляет значение тайм-аута, используемое хранилищем общих папок при отправке запроса обратной засыпки для данных, которые доступны на том же узле Exchange, и когда этот запрос является повторением предыдущего запроса обратной засыпки. Значение, выраженное в секундах, должно находиться в диапазоне от 900 до 2592000 секунд (30 дней); значение по умолчанию: 86400 секунд (24 часов).

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы сбросить в исходное состояние параметр реестра «Повтор тайм-аута короткого запроса обратной засыпки репликации»

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<имя_сервера>\Public-<идентификатор GUID общего хранилища>

  3. Проанализируйте или измените значение параметра Повтор тайм-аута короткого запроса обратной засыпки репликации.

    Значение для этой записи реестра выражено в секундах. Чтобы вернуться к значению по умолчанию, следует удалить параметр Повтор тайм-аута короткого запроса обратной засыпки репликации и перезапустить службу Банк данных Microsoft Exchange.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о репликации общей папки см. в разделе по управлению репликацией общей папки Exchange Server 2003, который содержится в материалах, описывающих работу с хранилищем Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47595).


Установлен размер приращения зарезервированной памяти
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-30

Чтобы определить, установлено ли значение параметра Reserve Increment KB реестра, анализатор сервера Microsoft® Exchange считывает следующую запись реестра: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Анализатор рекомендаций Exchange Server также опрашивает службу каталогов Active Directory® для определения значения атрибута serialNumber для всех объектов, имеющих класс объекта msExchExchangeServer. Если строковое значение содержит «Version 5.5», на компьютере работает сервер Exchange 5.5. Если строковое значение содержит «Version 6.0», на компьютере работает сервер Microsoft Exchange 2000 Server. Если строковое значение содержит «Version 6.5», на компьютере работает сервер Microsoft Exchange Server 2003. Если строковое значение содержит «Version 8.0», на компьютере работает сервер Microsoft Exchange Server 2007.

Если анализатор сервера Exchange находит, что на компьютере, на котором запущен Exchange Server 2003, существует параметр реестра Reserve Increment KB, отображается сообщение о конфигурации, отличной от установленной по умолчанию.

Значение параметра Reserve Increment KB реестра обладает большим приоритетом, чем значение размера памяти, выделяемой для кучи, заданное в Microsoft Windows®. В Windows предусмотрен диспетчер куч на уровне процессов, который управляет операциями с памятью для всех процессов. При каждом создании экземпляра процесса для него создается куча по умолчанию (называемая кучей процесса). Программы и модули, загружаемые в процесс, при необходимости также могут создавать дополнительные кучи. Служба банка данных Microsoft Exchange, Store.exe, является примером процесса, который при необходимости создает дополнительные кучи. По умолчанию Store.exe задает начальную память, в которой для кучи резервируется 20 % емкости физического ОЗУ. Значение параметра Reserve Increment KB изменяет начальный размер резервируемой для кучи памяти до 10 % емкости физического ОЗУ.

Применение параметра Reserve Increment KB реестра полезно лишь в редких случаях. Кроме того, это значение следует задавать только по совету или указанию службы технической поддержки корпорации Майкрософт. Неверная установка или неверное использование этого значения может повлечь снижение производительности и повышенную фрагментацию виртуальной памяти. Если этот параметр установлен без консультации со службой технической поддержки корпорации Майкрософт, рекомендуется удалить его с помощью следующей процедуры.

Чтобы восстановить конфигурацию по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem.

  3. В правой области удалите параметр реестра Reserve Increment KB.

  4. Чтобы изменения вступили в силу, закройте редактор реестра и перезапустите службу Банк данных Microsoft Exchange.

Дополнительные сведения о настройке Exchange Server 2003 см. в следующих статьях базы знаний Майкрософт:

  • Статья 325044, описывающая способы устранения неполадок, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • Статья 815372, описывающая оптимизацию использования памяти в Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)


Сжатие буфера RPC отключено
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, отключено ли сжатие буфера вызова удаленных процедур, анализатор сервера Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc Packing Enabled

Если анализатор сервера Exchange обнаружит, что раздел реестра Rpc Packing Enabled равен 0, анализатор сервера Exchange отобразит сообщение о нестандартной конфигурации. Раздел реестра Rpc Packing Enabled отключен, если значение этого параметра равно 0.

Значение раздела реестра Rpc Packing Enabled является одной из трех разделов, которые могут добавить администраторы, чтобы настроить сжатие вызовов удаленных процедур между Microsoft Office Outlook® 2003 и Exchange Server 2003.

Для Outlook 2003 может потребоваться буфер данных равный 96 КБ. Однако после того как Exchange Server 2003 сожмет данные, буфер данных может стать значительно меньше, чем требовалось Outlook 2003.

Exchange Server 2003 поддерживает сжатие буфера для поддержки различных видов сжатия и заполнения буферов в целях увеличения эффективности.

Если раздел реестра Rpc Packing Enabled включен, Exchange Server 2003 продолжает добавлять сжатые данные в буфер до тех пор, пока буфер не будет заполнен. Для каждого запроса данных Outlook 2003 может загрузить значительно больше данных, чем более ранние версии Outlook по следующим причинам:

  • В Outlook 2003 требуются увеличенные размеры буферов.

  • Exchange Server 2003 поддерживает сжатие буферов.

Анализатор сервера Exchange отображает эту конфигурацию только для сведений. Никаких действий выполнять не требуется. Однако можно удалить раздел Rpc Packing Enabled, если следует восстановить конфигурацию по умолчанию. Также можно задать значение раздела реестра Rpc Packing Enabled равным 1, чтобы включить сжатие буфера вызова удаленных процедур.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы восстановить конфигурацию по умолчанию.

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

    • Чтобы удалить запись, удалите значение Rpc Packing Enabled.

    • Чтобы сохранить запись и включить сжатие буферов, дважды щелкните Rpc Packing Enabled, установите значение равное 1 и нажмите кнопку ОК.

  3. Закройте редактор реестра.

Служба банка данных Microsoft Exchange обнаруживает изменение в течение нескольких минут. Нет необходимости перезагружать компьютер.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об установке значений реестра для настройки сжатия удаленного вызова процедур между клиентами Outlooл и Exchange Server 2003 см. в статье 825371 базы знаний Майкрософт, описывающей изменения сжатия вызова удаленных процедур в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=825371).


Минимумальный размер сжатия RPC отличается от заданного по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Чтобы определить минимальный размер пакета для сжатия при удаленном вызове процедур (RPC), анализатор сервера Microsoft® Exchange Server читает следующий параметр системного реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc Compression Minimum Size

Если анализатор сервера Exchange обнаруживает, что значение Rpc Compression Minimum Size больше 0, выводится сообщение о наличии конфигурации, не являющейся заданной по умолчанию.

По умолчанию все данные RPC, которые перемещаются между Microsoft Office Outlook® 2003 или Outlook 2007 и Exchange Server 2003 или Exchange Server 2007, сжимаются, независимо от их размера. В некоторых случаях необходимо управлять сжатием RPC. Например, при диагностике проблем доступа сжатие RPC может затруднить анализ пакетов, отправляемых по сети, поскольку при просмотре трассировки будут видны только сжатые данные.

Чтобы настроить параметры сжатия RPC, можно добавить к системным настройкам три значения реестра:

  • Rpc Compression Minimum Size

  • Rpc Compression Enabled

  • Rpc Packing Enabled

Значение реестра Rpc Compression Minimum Size определяет минимальное число байт, которое должен содержать пакет RPC, чтобы началось сжатие. Если этот параметр не задан, по умолчанию используется значение 1024 байта.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы вернуться к конфигурации по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в следующий раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Удалите параметр Rpc Compression Minimum Size. Если заданы параметры Rpc Compression Enabled и Rpc Packing Enabled, удалите их также.

  4. Закройте редактор реестра и перезапустите сервер Exchange, чтобы изменения вступили в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт "Description of the Microsoft Windows Registry" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения об управлении сжатием RPC см. в статье 825371 базы знаний «Modify Remote Procedure Call Compression in Exchange Server 2003» (Изменение сжатия при удаленном вызове процедур в Exchange Server 2003) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372).


Параметр RpcEtwTracing не является параметром, используемым по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить значение, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\RpcEtwTracing

Если анализатор сервера Exchange обнаружит, что значение параметра RpcEtwTracing реестра установлено в 1, анализатор сервера Exchange выведет на экран сообщение о конфигурации, отличной от конфигурации по умолчанию.

Значение параметра RpcEtwTracing реестра используется только для устранения неполадок сетевых подключений между Microsoft Office Outlook® 2003 и сервером Exchange. Рекомендуется отключить параметр RpcEtwTracing реестра, если в текущий момент не выполняется устранение возникшей проблемы.

Анализатор сервера Exchange сообщает об этой конфигурации исключительно в информационных целях. Никаких действий выполнять не требуется. Однако можно удалить параметр RpcEtwTracing реестра, если требуется восстановить конфигурацию по умолчанию.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы восстановить конфигурацию по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Удалите параметр RpcEtwTracing.

  4. Закройте редактор реестра.

Служба «Банк данных Microsoft Exchange» обнаружит изменения в течение нескольких минут. Перезапускать компьютер не требуется.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


На сервере имеется менее четырех групп хранения, а определено более четырех хранилищ почтовых ящиков
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы посчитать число объектов StorageGroup и объектов MailboxGroup на сервере, на котором выполняется приложение Exchange Server 2003. Если анализатор сервера Exchange определит, что общее число объектов StorageGroup меньше четырех, а общее число объектов MailboxStore больше четырех, на экран будет выведено сообщение об ошибке.

Если используется приложение Exchange Server 2003 Standard Edition, на каждом компьютере сервера Exchange может быть одна группа хранения, которая поддерживает одно хранилище почтовых ящиков и одно хранилище общих папок. Если используется приложение Exchange Server 2003 Enterprise Edition, на каждом сервере может быть до четырех групп хранения, каждая из которых поддерживает до пяти баз данных (или хранилищ почтовых ящиков, или хранилищ общих папок).

Рекомендуется при настройке групп хранения для компьютеров, на которых выполняется приложение Exchange Server 2003 Enterprise Edition, добавлять дополнительную группу хранения для каждой новой базы данных, пока не будет создано максимальное количество групп хранения. Нагрузку в виде почтовых ящиков можно распределять в топологии хранения сервера Exchange по максимально возможному количеству групп хранения. Такая топология обладает следующими преимуществами:

  • Повышенная надежность топологии хранения.

  • Повышенная восстанавливаемость топологии хранения.

  • Улучшенная управляемость операциями ввода-вывода диска.

Если на сервере, на котором выполняется приложение Exchange Server 2003 Enterprise Edition, имеется менее четырех групп хранения и более четырех хранилищ почтовых ящиков, выполните следующие шаги, чтобы распределить почтовые ящики по максимально возможному количеству групп хранения.

Чтобы устранить эту ошибку

  1. В системном диспетчере Exchange выберите сервер, который выводит сообщение об ошибке. Отметьте для себя количество групп хранения и хранилищ почтовых ящиков на этом сервере. Отметьте для себя группы хранения, которые содержат более одного хранилища почтовых ящиков.

  2. Создайте дополнительные группы хранения, чтобы на компьютере, на котором выполняется приложение Exchange Server 2003 Enterprise Edition, было четыре группы хранения. Сведения о создании новой группы хранения см. в разделе, описывающем добавление группы хранения, в руководстве по администрированию Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47617).

  3. Создайте новое хранилище почтовых ящиков в каждой созданной группе хранения. Сведения о создании нового хранилища почтовых ящиков см. в разделе, описывающем добавление хранилища почтовых ящиков, в руководстве по администрированию Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).

  4. Переместите почтовые ящики из одного из хранилищ почтовых ящиков в группе хранения, которая содержит несколько хранилищ почтовых ящиков, в хранилище почтовых ящиков, расположенное во вновь созданной группе хранения. Для перемещения почтовых ящиков используйте мастер перемещения почтовых ящиков. Подробные сведения об использовании мастера перемещения почтовых ящиков см. в разделе, описывающем использование мастера задач Exchange для перемещения почтовых ящиков, в главе, посвященной миграции из Exchange Server 5.5 в Exchange Server 2003, в руководстве по развертыванию Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47569).

Дополнительные сведения о настройке групп хранения в Exchange Server 2003 см. в базе знаний Майкрософт в статье 890699, содержащей инструкции по настройке групп хранения в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=890699).

Сведения о настройке групп хранения см. в части, описывающей настройку групп хранения, в разделе, посвященном планированию надежного решения фонового хранения, в руководстве по высокой доступности Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47571).

Общие рекомендации, помогающие максимизировать доступность, отказоустойчивость и производительность, см. в описании оптимизации хранилища для Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=49324).


Несоответствие подписей базы данных и файла потокового формата
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange Server обнаружил несоответствие подписей файла базы данных Exchange (.edb) и соответствующего файла потокового формата Exchange (.stm).

Каждая база данных Exchange 2000 Server и Exchange Server 2003 состоит из двух файлов: MAPI-файл базы данных (.edb) и файл базы данных в потоковом формате (.stm). Согласованные пары этих файлов используют общую подпись базы данных. Если подписи базы данных не совпадают, — файлы не согласованы.

Файлы .edb и .stm следует рассматривать как две части одного файла. Они всегда должны перемещаться и копироваться вместе.

Чтобы устранить эту ошибку

  • Исследуйте историю файлов базы данных. Вполне вероятно, что файлы были вручную скопированы, перемещены или удалены. Прежде чем база данных может быть восстановлена, эту проблему необходимо исправить.

  • Если не удается найти соответствующие файлы .edb и .stm, можно попытаться использовать программу Eseutil.exe, чтобы восстановить только файл .edb, а с помощью Eseutil с ключом /createstm сбросить файл .stm. В результате этого действия теряется вся информация в потоковом файле базы данных.

    Примечание.
    Если все пользователи базы данных подключаются к базе данных с помощью MAPI-клиента, такого как Microsoft Office Outlook®, в потоковом файле базы данных хранится минимальный объем данных. Если же пользователи подключаются к базе данных с помощью клиентов POP3, IMAP или веб-клиента Outlook, потоковый файл базы данных содержит часть или все содержимое почтовых ящиков пользователей.

Дополнительные сведения о восстановлении базы данных Exchange см. в статье 812357 базы знаний Майкрософт «How to maintain your Exchange database after you repair by using the Eseutil /p tool in Exchange Server 5.5, in Exchange 2000 Server, and in Exchange Server 2003» (Сопровождение базы данных Exchange после восстановления с помощью команды Eseutil /p в среде Exchange Server 5.5, Exchange 2000 Server, и Exchange Server 2003) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812357).


SMTP-адрес не определен в политике получателей по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2006-12-03

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить, задан ли SMTP-адрес в атрибуте gatewayProxy политики получателей по умолчанию в организации сервера Exchange. Если анализатор сервера Exchange обнаружит, что атрибут gatewayProxy не содержит SMTP-адрес, на экран будет выведено сообщение об ошибке.

Эта ошибка является критической ошибкой. Необходимо добавить SMTP-адрес, например, «SMTP:@contoso.com» в атрибут gatewayProxy политики получателей по умолчанию в своей организации сервера Exchange. Политика получателей по умолчанию должна содержать SMTP-адрес. Если политика получателей по умолчанию не содержит SMTP-адрес, служба «Банк данных Microsoft Exchange» не будет инициализирована после перезапуска. При последующем перезапуске службы «Банк данных Microsoft Exchange» этот сбой произойдет на всех серверах Exchange в организации сервера Exchange.

Внимание!
Могут возникнуть серьезные проблемы, если некорректно изменить атрибуты объектов Active Directory при использовании средства ADSI Edit (Active Directory Service Interfaces, ADSI), средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3. Для устранения этих проблем может потребоваться переустановка системы Microsoft Windows Server™ 2003, а также сервера Exchange Server 2003, сервера Exchange Server 2007 или обоих продуктов. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Чтобы добавить SMTP-адрес в атрибут «gatewayProxy» политики получателей по умолчанию

  1. Запустите средство ADSI Edit из средств поддержки Microsoft Windows® 2000 или из средств поддержки Windows Server 2003.

  2. Разверните следующие узлы:

    • контейнер конфигурации,

    • конфигурация,

    • службы,

    • Microsoft Exchange

    • имя_организации,

    • политики получателей.

  3. В области сведений щелкните правой кнопкой мыши CN=политика по умолчанию и в контекстном меню выберите пункт Свойства.

  4. В поле Атрибуты дважды щелкните gatewayProxy.

  5. В диалоговом окне Редактор многозначных строк введите SMTP:@имя_домена.com в поле Добавляемое значение и щелкните Добавить.

    Примечание.
    Важно соблюдать синтаксис вводимых данных. Необходимо набрать SMTP:@ до ввода имени домена организации сервера Exchange. В этом строковом значении нет пробелов.

  6. Нажмите кнопку ОК, затем — Применить и закройте средство ADSI Edit.

  7. Подождите, по меньшей мере, 15 минут до завершения репликации.


Для параметров реестра для распределения RPC Store установлены неверные значения
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server читает три раздела реестра для определения изменения значений по умолчанию. Все три раздела являются значениями DWORD, которые находятся в реестре:

HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Image File Execution Options\STORE.EXE\RpcThreadPoolThrottle

Разделы имеют соответствующие названия и значения по умолчанию:

Значение DWORD Десятичное значение по умолчанию
  • ProrateStart

  • 40
  • ProrateMax

  • 10,000
  • ProrateFactor

  • 100

Если средство Exchange Server Analyzer обнаруживает, что какие-либо из указанных ваше значений по умолчанию были изменены, появляется сообщение о нестандартной конфигурации.

Важно!
В этой статье содержатся сведения о редактировании реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Для получения сведений о восстановлении реестра см. разделе «Восстановление реестра» справочной системы файла Regedit.exe или Regedt32.exe.

Для возврата значений по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел: HKLM\Software\Microsoft\WindowsNT\CurrentVersion\Image File Execution Options\STORE.EXE\RpcThreadPoolThrottle

  3. В правой области дважды щелкните строку, значение которой было изменено, и установите для нее значение по умолчанию.

  4. Повторите шаг 3, если было изменено несколько значений.

  5. Закройте программу и перезапустите службу Microsoft Exchange Information Store, чтобы изменения вступили в силу.

Перед началом редактирования реестра, а также для получения сведений о редактировании реестра см. статью 256986 базы знаний корпорации Майкрософт, посвященную описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о потоках процесса см. в статье 267255 базы знаний «Потоки Store.exe используют почти всю доступную память» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=267255).


Рабочий каталог хранилища отсутствует или неправильный
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-30

Чтобы проверить рабочий каталог службы «Банк данных Microsoft Exchange», средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Working Directory

Анализатор сервера Exchange выводит предупреждение, если выполняются следующие условия:

  • Каталог, указанный в качестве рабочего каталога, не существует.

  • Выполняется Exchange 2000 Server, Exchange Server 2003 или Exchange Server 2007.

Сервер Exchange использует рабочий каталог для временного хранилища. Например, сервер Exchange использует рабочий каталог в процессе преобразования сообщений. Сервер Exchange также использует рабочий каталог для хранения временной базы данных во время дефрагментации. Если рабочий каталог не указан правильно, могут возникнуть следующие проблемы:

  • Сообщения с вложениями могут попасть в локальную очередь SMTP-доставки.

  • Сообщения могут быть получены без вложений.

  • Сообщения могут быть не доставлены успешно.

По умолчанию Exchange 2000 Server и Exchange Server 2003 устанавливают в качестве каталога mdbdata рабочую папку в каталоге, в котором установлен Exchange Server. Например, если сервер Exchange установлен в каталоге «C:\Program Files\Exchsrvr», сервер Exchange устанавливает рабочий каталог как «C:\Program Files\Exchsrvr\mdbdata».

По умолчанию Exchange 2007 Server устанавливает в качестве каталога базы данных почтовых ящиков рабочую папку в каталоге, в котором установлен Exchange Server. Например, если сервер Exchange Server установлен в каталоге C:\Program Files\Exchange Server, сервер Exchange Server 2007 установит рабочий каталог как C:\ Program Files\Exchange Server\Mailbox\MDBTemp

Чтобы устранить причины появления этого предупреждения, укажите в качестве рабочего каталога каталог, который существует на сервере Exchange.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы указать рабочий каталог с помощью редактора реестра (regedit)

  1. Запустите редактор реестра (regedit).

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Обновите значение параметра Working Directory реестра, установив правильный рабочий каталог для службы «Банк данных Microsoft Exchange», например, «C:\Program Files\Exchsrvr\mdbdata».

    Примечание.
    Для этого изменения не требуется перезапускать службу «Банк данных Microsoft Exchange».

  4. Закройте редактор реестра.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о значении раздела реестра Working Directory см. в статье 298415 базы знаний Майкрософт «Messages that have attachments are not delivered as expected, and Event ID 12003 and 327 messages are logged in Exchange 2000 Server and in Exchange Server 2003» (http://go.microsoft.com/fwlink/?Linkid=3052&kbid=298415) (Сообщения с вложениями не доставляются, как ожидалось, и в журналах Exchange 2000 Server и Exchange Server 2003 регистрируются события с кодами 12003 и 327).


Параметр запрета сообщений об отсутствии на рабочем месте для списков рассылок был установлен
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-02-27

Средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра, чтобы определить, запрещены ли сообщения об отсутствии на рабочем месте для списков рассылки:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\SuppressOOFsToDistributionLists

Если анализатор сервера Exchange обнаруживает, что значение параметра SuppressOOFsToDistributionLists больше 0, на экране отображается сообщение о нестандартной конфигурации.

Если сообщение отправляется в почтовый ящик, в котором включен заместитель, отправитель получит сообщение без адреса в поле Кому или Копия, но со списком рассылки в поле Скрытая копия, сообщение об отсутствии на рабочем месте посылается по списку рассылки в поле Скрытая копия.

Если сообщение отправляется получателю, адрес которого содержится только в поле Скрытая копия, но не включен в список рассылки, а получатель включил заместителя, хранилище почтовых ящиков получателя так же будет отправлять сообщение об отсутствии на рабочем месте, даже если установлено значение реестра SuppressOOFsToDistributionLists. Это ограничение применимо только в том случае, если адрес получателя содержится в поле Скрытая копия, а поля Кому и Копия пусты. Если в поле «Кому» или «Копия» есть хотя бы один пользователь, то параметр реестра сервера Exchange Server предотвратит создание сообщения об отсутствии на работе для получателей, перечисленных в поле СК.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы изменить поведение при создании сообщения об отсутствии на рабочем месте

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Щелкните правой кнопкой мыши ParametersSystem, наведите указатель на пункт Создать и выберите Значение DWORD.

  4. Назовите новый раздел SuppressOOFsToDistributionLists.

  5. Щелкните правой кнопкой мыши SuppressOOFsToDistributionLists и в контекстном меню выберите Изменить.

  6. В поле Значение введите 1 и нажмите кнопку OK.

  7. Закройте редактор реестра и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Сведения о замещении параметра реестра SuppressOOFsToDistributionLists см. в статье 825370 базы знаний Майкрософт «Out-of-Office Messages Are Sent to Distribution Lists That Are in the BCC Field» (http://go.microsoft.com/fwlink/?linkid=3052 & kbid=825370).


Изменено значение параметра, контролирующего предельное разрешенное число прохождений поврежденного сообщения через хранилище
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-08

Анализатор рекомендаций сервера Exchange Server считывает следующий ключ реестра, чтобы определить значение для PoisonThreshold:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<ExchangeServerName> \Private- <PrivateInformationStoreGUID>

Если анализатор обнаруживает, что значение PoisonThreshold не равно 2, последует сообщение, что настройка отличается от настройки по умолчанию.

В версиях сервера Exchange Server более поздних, чем Exchange Server 2003 с пакетом обновления 1, реализовано поведение, помогающее предотвратить внезапную остановку службы банка данных Microsoft Exchange или неполадки при её запуске из-за поврежденных или ошибочных сообщений.

В Exchange Server 2003 с пакетом обновления 1 или более поздних версиях сервера отслеживаются сообщения, приводящие к внезапной остановке службы банка данных Microsoft Exchange во время выполнения преобразования из формата MAPI в формат MIME. При возникновении сбоя идентификатор поврежденного сообщения сохраняется в реестре. Если поврежденное сообщение трижды вызывает внезапную остановку работы хранилища, эти данные используются для предотвращения обработки сообщения при четвертом перезапуске службы банка данных Microsoft Exchange.

При внезапной остановке службы банка данных Microsoft Exchange из-за поврежденного сообщения создается значение реестра PoisonIDs в разделе:

HKLM\System\CurrentControlSet\Services\MSExchangeIS \<ExchangeServerName> \Private- <PrivateInformationStoreGUID>

Кроме того, администратор может создать запись реестра PoisonThreshold. Раздел PoisonThreshold контролирует максимальное число прохождений поврежденного сообщения через хранилище данных Exchange до добавления этого сообщения в раздел PoisonIDs. По умолчанию пороговым значением является 2. Для изменения поведения этот порог должен быть превышен. Таким образом, до блокировки поврежденного сообщения работа службы хранилища сообщений Microsoft Exchange может быть остановлена из-за него 3 раза. Например, если сообщение привело к 3 сбоям, оно блокируется, так как превышается пороговое значение 2.

После записи в реестре события поврежденного сообщения в журнале событий приложений отобразятся сообщения об ошибках (коды событий 9680 и 9681). Exchange блокирует сообщение и пытается отправить отчет о его потере после успешного запуска службы хранилища информации Microsoft Exchange. В некоторых случаях Exchange может не отправить отчет о потере сообщения. В таких случаях заблокированное сообщение может оставаться в очереди до истечения срока доставки. Раздел реестра PoisonIDs может содержать до десяти идентификаторов сообщений. При превышении этого предела после добавления нового поврежденного сообщения: Поврежденное сообщение с самой ранней датой сбоя удаляется.

Примечание.
Анализатор Exchange Server не предоставляет средств устранения неполадок в поврежденных сообщениях. В некоторых случаях помощь в устранении неполадок в поврежденных сообщениях может быть оказана службой поддержки Майкрософт. Проблемы, возникающие по причине завершения работы сервера Exchange Server 2003 или более поздних версий из-за поврежденных сообщений, может решить запуск автоматического сообщения сведений об ошибках на компьютере Exchange Server. Данные из отчета об ошибках используются при поиске и устранении неполадок в используемом программном обеспечении. Для получения дополнительных сведений о запуске Exchange Error Reporting см. статью Отчетность об ошибках Exchange отключена

Рекомендуется снова установить для параметра PoisonThreshold значение по умолчанию - 2.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед правкой реестра убедитесь, что знаете, как восстановить реестр в случае возникновения проблем. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Для исправления этой ошибки

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ExchangeServerName>\Private-<PrivateInformationStoreGUID>

  3. В правой области дважды щелкните PoisonThreshold.

  4. В поле "Значение" введите 2 (в десятичной системе счисления) и нажмите кнопку OK.

  5. Закройте редактор реестра и перезапузите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986 "Описание реестра Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Для процесса доступа к хранилищу включена трассировка
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange проверяет наличие записи реестра Enable Tracing и значения реестра Trace User LegacyDN: Оба эти значения реестра находятся в следующей записи реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

Если анализатор сервера Exchange обнаружит, что оба значения существуют и настроены, на экран выводится предупреждение.

Значение реестра Enable Tracing DWORD включает трассировку для службы банка данных Microsoft Exchange. Трассировка используется при устранении неполадок с запуском хранилища Exchange и может серьезно повлиять на производительность. Если нет необходимости устранить неполадку, не следует использовать этот параметр реестра. Можно включить трассировку для определенных пользователей (фильтрованная трассировка), добавив значение строки реестра Trace User LegacyDN. Если значение Trace User LegacyDN не существует, трассировка включена для всех пользователей. Если значение Trace User LegacyDN существует, трассировка выполняется для определенных пользователей, указанных в этом реестре.

Если на компьютере сервера Exchange не выполняется устранение неполадок, эти значения реестра не должны существовать.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Удалите значения реестра Enable Tracing и Trace User LegacyDN.

  4. Закройте редактор реестра и перезапустите компьютер, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о трассировки для определенных пользователей см. в базе знаний Майкрософт в статье 296624, описывающей функцию трассировки, включенную в обновление 2 для Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296624).


Трассировка включена в службе Microsoft Exchange Information Store для всех пользователей
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2007-01-17

Средство анализа Microsoft® Exchange Server считывает раздел реестра, чтобы установить, существует ли параметр Enable Tracing в

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

Если средство анализа Exchange Server обнаруживает наличие и конфигурацию параметра реестра Enable Tracing, отображается предупреждение.

Параметр реестра DWORD Enable Tracing обеспечивает трассировку для службы Microsoft Exchange Information Store. Трассировка используется для устранения неисправностей и может серьезно повлиять на быстродействие. Если не выполняется устранение неисправностей, данный параметр реестра не следует использовать. Трассирока может быть включена для конкретных пользователей путем добавления значения строки реестра Trace User LegacyDN. Если это значение не задано, это означает, что трассировка включена для всех пользователей.

Если устранение неисправностей выполняется не на сервере Exchange Server, задавать это значение не следует.

Примечание.
В этой статье содержатся сведения о редактировании реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Для получения сведений о восстановлении реестра см. в разделе «Восстановление реестра» справочной системы файла Regedit.exe или Regedt32.exe.

Для устранения этого предупреждения

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Удалите значение реестра Enable Tracing.

  4. Закройте программу и перезапустите службу Microsoft Exchange Information Store, чтобы изменения вступили в силу.

Перед началом редактирования реестра, а также для получения сведений о редактировании реестра см. статью 256986 базы знаний Майкрософт, посвященную описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Для получения дополнительной информации о трассировке для конкретных пользователей на сервере Exchange Server см. статью базы знаний Майкрософт 296624, посвященную добавленной к пакету обновлений 2 для Exchange 2000 Server функции трассировки для конкретных пользователей (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296624).


Закончились имена файлов журнала транзакций
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange проверяет работоспособность файлов журнала транзакций для каждой группы хранения, для чего проверяет файлы журнала на диске сервера. Чтобы найти местоположение файлов журнала, анализатор сервера Exchange запрашивает службу каталогов Active Directory®. Для каждого объекта группы хранения (класс msExchStorageGroup) путь к файлам журнала хранится в атрибуте msExchESEParamLogFilePath.

Имена файлов журнала транзакций содержат последовательные шестнадцатеричные числа, определяющие последовательность файлов журнала. Например, первый файл журнала для группы хранения, используемой по умолчанию, называется E0000001.log, второй — E0000002.log и т. д. Последовательность может продолжаться до E00FFFFF.log. Exchange может создать до 1 030 000 файлов журнала. Однако когда Exchange достигает конца этой последовательности, хранилища в соответствующей группе хранения, отключенные после достижения предельного значения, больше не будут подключаться. Если хранилище остается подключенным, базы данных не будут отключены, даже если никакие операции Jet больше не могут выполняться. Обычно Exchange может работать несколько лет до того, как этот предел будет достигнут.

Вы увидите это сообщение как предупреждение, если указанный сервер использовал больше 950 000 файлов журнала транзакций.

Вы увидите это сообщение как ошибку, если указанный сервер использовал больше 1 020 000 файлов журнала транзакций.

Чтобы после достижения этого предельного значения разрешить хранилищу должным образом отключать базы данных, в Exchange Server 2003 с пакетом обновления 1 было включено исправление. Для Exchange 2000 Server доступно экстренное исправление, устанавливаемое после установки пакета обновления 3, как описывается в базе знаний Майкрософт в статье 830408, посвященной описанию ситуации, когда хранилища баз данных Exchange остаются подключенными, хотя все журналы транзакций, доступные для группы хранения, уже использованы (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830408).

Если в Exchange достигнуто предельное значение в 1 030 000 журналов транзакций, следует как можно скорее выполнить полное резервное копирование данных сервера в сетевом режиме. Дополнительные сведения о выполнении полного резервного копирования хранилищ Exchange в сетевом режиме см. в руководстве по аварийному восстановлению Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47570).

Если в Exchange достигнуто это предельное значение, необходимо переместить все имеющиеся журналы транзакций в другое местоположение. После этого будет формироваться новая последовательность файлов журнала, начинающаяся с 0x00001. Чтобы обеспечить правильное отключение баз данных хранилищем Exchange, необходимо также установить соответствующее исправление для своей версии Exchange.

Примечание.
Перед перемещением журналов транзакций необходимо проверить, что все базы данных в группе хранения находятся в состоянии правильного завершения работы.
Важно!
После выполнения процедуры, описанной ниже, все предыдущие резервные копии будут недействительными. Это не означает, что невозможно будет восстановить эти резервные копии. Однако для них невозможно будет выполнить накат с использованием дополнительных файлов журнала. Если после удаления журналов транзакций требуется восстановить предыдущую резервную копию, можно будет восстановить данные только до момента начала формирования новой последовательности файлов журнала транзакций.

Чтобы устранить эту неполадку

  1. Для Exchange Server 2003 установите пакет обновления 1, доступный на веб-узле загружаемых файлов для сервера Exchange (http://go.microsoft.com/fwlink/?LinkId=29090).

    -или-

    Для Exchange 2000 Server получите и установите экстренное исправление, которое описывается в базе знаний Майкрософт в статье 830408, посвященной описанию ситуации, когда хранилища баз данных Exchange остаются подключенными, хотя все журналы транзакций, доступные для группы хранения, уже использованы (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830408).

  2. В группе хранения, для которой закончились файлы журнала транзакций, отключите все базы данных. Для этого выполните следующие действия:

    1. Откройте диспетчер Exchange.

    2. Последовательно разверните узлы Административные группы, <имя_административной_группы>, Серверы, <имя_сервера>, <имя_группы_хранения>.

    3. Щелкните правой кнопкой мыши первое хранилище в этой группе хранения и выберите команду Отключить хранилище. Повторите это действие для каждого хранилища из этой группы хранения.

  3. Проверьте, что каждая база данных в группе хранения находится в состоянии правильного завершения работы. Для этого выполните следующие действия:

    1. В диспетчере Exchange щелкните правой кнопкой мыши первое хранилище в группе хранения, для которой закончились файлы журнала транзакций, и выберите команду Свойства.

    2. Перейдите на вкладку База данных и запишите пути и имена файлов баз данных, указанные в поле «База данных Exchange» и в поле «Потоковая база данных Exchange». Каждая база данных Exchange состоит из набора пар файлов с расширением имени файла EDB и STM. Повторите это действие для каждого хранилища из этой группы хранения.

    3. В командной строке смените каталог на папку «bin» сервера Exchange. Например, смените каталог на C:\Program Files\Exchsrvr\bin.

    4. Введите «Eseutil /mh имя_файла_базы_данных» и нажмите клавишу ВВОД. Повторите это действие для каждой базы данных из этой группы хранения. Эта команда используется для отображения заголовка файла базы данных. Заголовок будет содержать одну из двух строк: State: Clean Shutdown или State: Dirty Shutdown.

  4. Если заголовок содержит строку State: Dirty Shutdown, перед удалением файлов журнала необходимо вручную восстановить базу данных. Для этого выполните следующие действия:

    1. В диспетчере Exchange щелкните правой кнопкой мыши группу хранения, для которой закончились файлы журнала транзакций, и выберите команду Свойства.

    2. Перейдите на вкладку Общие и запишите пути к журналам транзакций, указанные в поле «Местоположение журнала транзакций».

    3. Обратите внимание на путь к файлу контрольных точек в поле «Местоположение системного пути».

    4. В командной строке смените каталог на папку «bin» сервера Exchange.

    5. Введите следующую команду и нажмите клавишу ВВОД: Eseutil /r базовое_имя_файлов_журнала_из_трех_символов /lDirectory:\путь_к_файлам_журнала /sDirectory:\путь_к_файлу_контрольных_точек.

      Примечание.
      Не следует вводить пробел между переключателем параметра и путями к каталогам. В случае опечатки при вводе путей, входящих в команду, восстановление может быть не выполнено. Чтобы этого избежать, можно скопировать файл контрольных точек в папку, содержащую файлы журнала транзакций. В командной строке, для которой по умолчанию настроена папка, содержащая файлы журнала, выполните команду Eseutil /r 3-CharacterLogfileBaseName. Поскольку переключатели /l и /s по умолчанию настроены на текущий каталог, вводить пути для файлов журнала и файлов контрольных точек не потребуется.
    6. После завершения восстановления и перед перемещением файлов журнала транзакций и файлов контрольных точек проверьте, что все файлы баз данных находятся в состоянии правильного завершения работы. Если перемещать файлы журнала, когда база данных находится в состоянии неправильного завершения работы, перезапустить базу данных не удастся. Если не удается восстановить все базы данных в состояние правильного завершения работы, обратитесь за дополнительными сведениями в службу технической поддержки продуктов корпорации Майкрософт.

  5. В диспетчере Exchange щелкните правой кнопкой мыши группу хранения, для которой закончились файлы журнала транзакций, и выберите команду Свойства.

  6. Перейдите на вкладку Общие и запишите пути к журналам транзакций, указанные в поле Местоположение журнала транзакций.

  7. Запишите путь к файлу контрольных точек, указанный в поле Местоположение системного пути.

  8. Переместите файлы журнала транзакций и файл контрольных точек в другое место. Файлы журнала имеют расширение имени файла LOG, а файлы контрольных точек — CHK.

  9. В диспетчере Exchange щелкните правой кнопкой мыши первое отключенное хранилище в группе хранения и выберите команду Подключить хранилище.

  10. Повторите это действие для каждого хранилища из этой группы хранения. Теперь последовательность файлов журнала для группы хранения перенастроена.

  11. Выполните полное резервное копирование всех баз данных в группе хранения.

Дополнительные сведения о пакетах обновления для сервера Exchange см. на веб-узле Exchange (http://go.microsoft.com/fwlink/?LinkId=21573).


Недостаточный размер наибольшего блока виртуальной памяти
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает класс инструментария управления Windows (WMI) Win32_PerfRawData_MSExchangeIS_MSExchangeIS, чтобы определить значение ключа VMLargestBlockSize. Ключ VMLargestBlockSize представляет собой размер (в байтах) наибольшего доступного блока виртуальной памяти.

Помимо этого, анализатор сервера Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение счетчика записей, перечисленных в атрибуте homeMDBBL каждого хранилища почтовых ящиков. Счетчик этого атрибута отражает количество почтовых ящиков в хранилище почтовых ящиков.

Если анализатор сервера Exchange обнаруживает, что значение VMLargestBlockSize больше 50 000 000, но меньше 150 000 000 на компьютере сервера Exchange с более чем 20 почтовыми ящикам, отображается предупреждающее сообщение.

Среди прочего сервер Exchange использует виртуальную память для хранения сообщений при их преобразовании между форматами MIME и MAPI и как буфер при извлечении сообщений из журнала операций и передаче в хранилище. Часто для быстрого и эффективного выполнения этих операций требуются большие непрерывные блоки виртуальной памяти. Если отображается это предупреждение, для работы виртуальной памяти на компьютере Exchange осталось менее 150 МБ непрерывного пространства. Такое состояние виртуальной памяти называется фрагментацией виртуальной памяти.

Если виртуальной памяти остается слишком мало, в журнале событий могут начать появляться сообщения об ошибке с кодом события 9582, которые представляют ошибки виртуальной памяти. Если объем виртуальной памяти недостаточен, появится сообщение с кодом события 12800, которое означает, что сообщения не доставляются из-за отсутствия достаточных объемов памяти для обработки сообщений.

Для устранения причин этого предупреждения выполните следующие рекомендации в указанном порядке.

Просмотрите выходные данные анализатора сервера Exchange на наличие ошибки «Достигнут максимальный размер кэша ESE».

Если ошибка, Достигнут максимальный размер кэша ESE, возвращается на том же компьютере Exchange, на котором возвращается данное предупреждение о фрагментации виртуальной памяти, следуйте рекомендациям, описанным в статье Слишком большой максимальный кэш ESE.

С большой долей вероятности сочетание этих двух предупреждений указывает на то, что проблемы фрагментации виртуальной памяти являются результатом увеличения вручную кэша ESE.

Перезапустите службу «Банк данных Exchange»

В описании этого сообщения об ошибке анализатор сервера Exchange указывает количество дней работы службы «Банк сообщений Microsoft Exchange». Если указанное количество дней больше 30, перезапустите службу.

Чтобы перезапустить банк сообщений Exchange

  1. Откройте оснастку «Службы» консоли MMC.

  2. Щелкните правой кнопкой мыши службу Банк данных Microsoft Exchange и выберите в контекстном меню команду Перезапустить.

Оцените пределы размеров сообщений

Если многие пользователи отправляют большие сообщения (более 30 МБ), фрагментация виртуальной памяти наступит быстрее, чем когда большинство пользователей не отправляет больших сообщений. Как упоминалось ранее, виртуальная память используется как буфер в процессе сохранения данных, когда они перемещаются из файлов журнала в хранилище. При частом перемещении больших объемов данных быстро расходуются крупные непрерывные блоки виртуальной памяти.

Если в организации с помощью электронной почты регулярно пересылаются большие объемы данных, следует рассмотреть возможность установки общих каталогов на файловых серверах, на которых пользователи смогут размещать большие массивы данных.

Рекомендуется задать наибольший предельный размер сообщения не выше 30 МБ. Однако если необходим больший предел на размер сообщений с большими вложениями, отправляемыми в организации Exchange, возможно, потребуется увеличить предел на максимальный размер исходящих сообщений свыше 30 МБ. Помимо фрагментации виртуальной памяти, увеличение предела на размер сообщений свыше 30 МБ может сделать систему более уязвимой к атакам злоумышленников. Поэтому устанавливать для сообщений предельный размер свыше 30 МБ не рекомендуется.

Чтобы задать предельные размеры сообщений

  1. В диспетчере Exchange разверните узел Глобальные параметры, щелкните правой кнопкой мыши Доставка сообщения и выберите в контекстном меню Свойства.

  2. В диалоговом окне Доставка сообщения — свойства на вкладке Параметры по умолчанию выберите параметр Предел на размер отправляемых сообщений и введите требуемый предельный размер.

Проверьте актуальность антивирусного программного обеспечения

В некоторых случаях устаревшее антивирусное программное обеспечение, которое выполняется в режиме VSAPI (Exchange Virus Scanning API), может быть причиной фрагментации виртуальной памяти. Если антивирусное программное обеспечение выполняется в режиме VSAPI, свяжитесь с поставщиком антивирусного программного обеспечения и убедитесь, что выполняются последние версии их программного обеспечения и драйверов.

Переместите почтовые ящики на другой сервер Exchange

Если все процедуры выполнены, а анализатор сервера Exchange продолжает отображать это предупреждение, следует переместить почтовые ящики с сервера, о котором идет речь в сообщении, чтобы уменьшить его нагрузку. На данном сервере размещено слишком много почтовых ящиков.

Чтобы переместить почтовые ящики на серверы Exchange 2000 Server и Exchange Server 2003

  1. В оснастке «Active Directory — компьютеры и пользователи» выберите пользователя или пользователей, почтовые ящики которых хотите переместить.

  2. Щелкните правой кнопкой мыши список пользователей, выбранный на предыдущем шаге, и в контекстном меню выберите Задачи Exchange.

  3. В окне Мастер задач Exchange на странице Доступные задачи щелкните Переместить почтовый ящик и нажмите кнопку Далее.

  4. Внимательно ознакомьтесь с оставшимися шагами в мастере.

Чтобы переместить почтовые ящики на сервер Exchange Server 2003

  1. В окне Диспетчер системы Exchange разверните узел Серверы, разверните сервер, с которого хотите переместить почтовые ящики, разверните узел Группа хранения, из которой хотите переместить почтовые ящики, разверните узел Хранилище почтовых ящиков, содержащее почтовые ящики, которые хотите переместить, а затем щелкните Почтовые ящики.

  2. В области сведений щелкните правой кнопкой мыши пользователя или пользователей, почтовые ящики которых хотите переместить, и в контекстном меню выберите Задачи Exchange.

  3. В окне Мастер задач Exchange на странице Доступные задачи щелкните Переместить почтовый ящик и нажмите кнопку Далее.

  4. Внимательно ознакомьтесь с оставшимися шагами в мастере.

Дополнительные сведения об устранении проблем фрагментации виртуальной памяти см. в следующих статьях базы знаний Майкрософт:

  • 325044, "HOW TO: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044) (Инструкции по устранению проблем, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000)

  • 838233, описывающей причины замедления или остановки ответов и повторяющегося вывода в журнал событий с кодами 9582 и 1160 в Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=838233)

Дополнительные сведения об установке пределов на размер сообщений см. в базе знаний Майкрософт в статье 322679, описывающей порядок установки пределов на размеры сообщений (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

Дополнительные сведения о перемещении почтовых ящиков см. в следующих статьях базы знаний Майкрософт:

  • 328810, описывающей перемещение почтовых ящиков между серверами (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328810)

  • 821829, описывающей перемещение почтовых ящиков в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821829)


Размер наибольшего блока виртуальной памяти приближается к критическому уровню
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_PerfRawData_MSExchangeIS_MSExchangeIS, чтобы определить значение ключа VMLargestBlockSize. Ключ VMLargestBlockSize представляет собой размер (в байтах) наибольшего доступного блока виртуальной памяти.

Помимо этого, анализатор сервера Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение счетчика записей, перечисленных в атрибуте homeMDBBL каждого хранилища почтовых ящиков. Счетчик этого атрибута представляет количество почтовых ящиков в хранилище почтовых ящиков.

Если анализатор сервера Exchange обнаруживает, что значение VMLargestBlockSize больше 0, но меньше 50000001 на компьютере сервера Exchange с более чем 20 почтовыми ящикам, отображается сообщение об ошибке.

Среди прочего сервер Exchange использует виртуальную память для хранения сообщений при их преобразовании между форматами MIME и MAPI и как буфер при извлечении сообщений из журнала операций и передаче в хранилище. Часто для быстрого и эффективного выполнения этих операций требуются большие непрерывные блоки виртуальной памяти. Если отображается эта ошибка, виртуальная память на компьютере Exchange практически исчерпана и осталось менее 50 МБ объема непрерывной памяти. Такое состояние виртуальной памяти называется фрагментацией виртуальной памяти. При работе сервера почтовых ящиков Exchange с объемом непрерывной виртуальной памяти менее 50 МБ возникает критическая ошибка.

Если виртуальной памяти остается слишком мало, в журнале событий могут начать появляться предупреждения об ошибке (с идентификатором события 9582), которые представляют собой ошибки виртуальной памяти. Если объем виртуальной памяти достаточно мал, появится сообщение с идентификатором события 12800, которое означает, что сообщения не доставляются из-за отсутствия достаточных объемов памяти для обработки сообщений.

Чтобы устранить эту ошибку, выполните следующие рекомендации в том порядке, в котором они приводятся.

Просмотрите выходные данные анализатора сервера Exchange на наличие ошибки «Достигнут максимальный размер кэша ESE».

Если ошибка, Достигнут максимальный размер кэша ESE, возвращается на том же компьютере Exchange, на котором возвращается данное предупреждение о фрагментации виртуальной памяти, следуйте рекомендациям, описанным в статье Слишком большой максимальный кэш ESE.

С большой долей вероятности сочетание этих двух предупреждений указывает на то, что проблемы фрагментации виртуальной памяти являются результатом увеличения вручную кэша ESE.

Перезапустите службу «Банк данных Exchange»

В описании этого предупреждения анализатор сервера Exchange указывает количество дней работы службы «Банк данных Microsoft Exchange». Если указанное количество дней больше 30, перезапустите службу.

Чтобы перезапустить банк данных Exchange

  1. Откройте оснастку «Службы» консоли MMC.

  2. Щелкните правой кнопкой мыши службу Банк данных Microsoft Exchange и выберите в контекстном меню команду Перезапустить.

Оцените пределы размеров сообщений

Если многие пользователи посылают большие сообщения (более 30 МБ), фрагментация виртуальной памяти наступит быстрее, чем в том случае, когда большинство пользователей не посылают большие сообщения. Как упоминалось выше, виртуальная память используется как буфер в процессе сохранения данных, когда они перемещаются из файлов журнала в хранилище. При частом перемещении больших объемов данных быстро расходуются крупные непрерывные блоки виртуальной памяти.

Если большие объемы данных регулярно посылаются с помощью электронной почты и эти данные отправляются внутри организации, рассмотрите возможность установки общих каталогов на файловых серверах, на которых пользователи могут размещать большие части данных.

Рекомендуется установить предел на максимальный размер сообщения не превышающий 30 МБ. Однако если необходим больший предел на размер сообщений с большими вложениями, отправляемыми в организации Exchange, возможно, потребуется увеличить предел на максимальный размер исходящих сообщений свыше 30 МБ. Помимо фрагментации виртуальной памяти, увеличение предела на размер сообщений свыше 30 МБ может сделать систему более уязвимой к атакам злоумышленников. Поэтому не рекомендуется устанавливать для сообщений предельный размер свыше 30 МБ.

Чтобы установить пределы на размер сообщений

  1. В диспетчере системы Exchange разверните узел Глобальные параметры, щелкните правой кнопкой мыши Доставка сообщения и выберите в контекстном меню Свойства.

  2. В диалоговом окне Доставка сообщения — свойства на вкладке Параметры по умолчанию выберите параметр Предел на размер отправляемых сообщений и введите требуемый предельный размер.

Проверьте актуальность антивирусного программного обеспечения

В некоторых случаях устаревшее антивирусное программное обеспечение, которое выполняется в режиме VSAPI (Exchange Virus Scanning API), может быть причиной фрагментации виртуальной памяти. Если антивирусное программное обеспечение выполняется в режиме VSAPI, свяжитесь с поставщиком антивирусного программного обеспечения и убедитесь, что выполняются последние версии их программного обеспечения и драйверов.

Переместите почтовые ящики на другой сервер Exchange

Если выполнены все указанные выше процедуры и анализатор сервера Exchange по-прежнему отображает данную ошибку или предупредительную версию этого оповещения (когда остается меньше 150 МБ непрерывного объема виртуальной памяти), необходимо переместить почтовые ящики с сервера с недостаточной виртуальной памятью, чтобы уменьшить нагрузку на этот сервер. На данном сервере размещено слишком много почтовых ящиков.

Чтобы переместить почтовые ящики на серверы Exchange 2000 Server и Exchange Server 2003

  1. В оснастке «Active Directory — компьютеры и пользователи» выберите пользователя или пользователей, почтовые ящики которых хотите переместить.

  2. Щелкните правой кнопкой мыши список пользователей, выбранный на предыдущем шаге, и в контекстном меню выберите Задачи Exchange.

  3. В окне Мастер задач Exchange на странице Доступные задачи щелкните Переместить почтовый ящик и нажмите кнопку Далее.

  4. Внимательно ознакомьтесь с оставшимися шагами в мастере.

Чтобы переместить почтовые ящики на сервер Exchange Server 2003

  1. В окне Диспетчер системы Exchange разверните узел Серверы, разверните сервер, с которого хотите переместить почтовые ящики, разверните узел Группа хранения, из которой хотите переместить почтовые ящики, разверните узел Хранилище почтовых ящиков, содержащее почтовые ящики, которые хотите переместить, а затем щелкните Почтовые ящики.

  2. В области сведений щелкните правой кнопкой мыши пользователя или пользователей, почтовые ящики которых хотите переместить, и в контекстном меню выберите Задачи Exchange.

  3. В окне Мастер задач Exchange на странице Доступные задачи щелкните Переместить почтовый ящик и нажмите кнопку Далее.

  4. Внимательно ознакомьтесь с оставшимися шагами в мастере.

Дополнительные сведения об устранении проблем фрагментации виртуальной памяти см. в следующих статьях базы знаний Майкрософт:

  • 325044, описывающая инструкции по устранению проблем, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 838233, описывающая причины замедления или остановки ответов и повторяющегося вывода в журнал событий с идентификаторами 9582 и 1160 в Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=838233)

Дополнительные сведения об установке пределов на размер сообщений см. в базе знаний Майкрософт в статье 322679, описывающей порядок установки пределов на размеры сообщений (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

Дополнительные сведения о перемещении почтовых ящиков см. в следующих статьях базы знаний Майкрософт:

  • 328810, описывающая перемещение почтовых ящиков между серверами (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328810)

  • 821829, описывающая перемещение почтовых ящиков в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821829)


Значение VirtualReserveSize отличается от заданного по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, изменилось ли заданное по умолчанию значение распределения памяти для компонента связи процессов в Exchange (Exchange Interprocess Communication, ExIPC), анализатор сервера Microsoft® Exchange считывает следующее значение реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIPC\Parameters\VirtualReserveSize

Если анализатор сервера Exchange обнаруживает, что присутствует раздел VirtualReserveSize, для которого указано значение, превышающее 0, отображается сообщение о том, что конфигурация отличается от заданной по умолчанию.

ExIPC представляет собой компонент организации очереди, с помощью которого программы Inetinfo.exe (службы IIS) и Store.exe (служба информационного хранилища Microsoft Exchange) могут быстро перемещать данные по очереди. В целом выделенной по умолчанию памяти достаточно для работы ExIPC. По умолчанию раздел VirtualReserveSize отсутствует. Его следует добавить и настроить только для служб консультации Microsoft или служб поддержки продуктов Microsoft.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы вернуться к конфигурации по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\EXIPC\Parameters

  3. Удалите раздел VirtualReserveSize.

  4. Закройте редактор реестра, а затем перезапустите службу информационного хранилища Microsoft Exchange и службу администрирования IIS, чтобы изменения вступили в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения о ExIPC см. в следующих статьях базы знаний Майкрософт:

  • 821879, «Definitions of key transport components in Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821879) (Определения ключевых компонентов системы транспорта в Exchange Server 2003)

  • 260995, «XCON: Definitions of key transport components in Exchange Server 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260995) (XCON: Определения ключевых компонентов системы транспорта в Exchange Server 2000)


Интервал событий виртуальной памяти был перезаписан
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра, чтобы определить был ли вручную перезаписан порог ведения журнала событий фрагментации виртуальной памяти:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ VM Info Update Interval

Если анализатор обнаружит, что значение реестра VM Info Update Interval существует, но не равняется 3600, отображается сообщение о нестандартной конфигурации.

В 32-разрядных системах Microsoft Windows® systems существует два вида памяти: физическая память (объем памяти, установленной в системе) и адресное пространство виртуальной памяти (виртуальное 4-гигабайтное пространство памяти). Не зависимо от объема физической памяти, установленной в системе, общий объем виртуального адресного пространства всегда один и тот же: 4 ГБ. Хоть это и не применимо ко всем 32-разрядным приложениям, в Exchange Server виртуальное адресное пространство равно виртуальной памяти, то есть эти термины взаимозаменяемы.

Во время обычного хода выполнения операций служба банка данных Exchange многократно выделяет, использует и освобождает виртуальную память. При выделении, использовании и освобождении виртуальной памяти может происходить фрагментация виртуальной памяти. Фрагментация виртуальной памяти сходна с фрагментацией файловой системы, которая может происходить со временем. По истечении некоторого времени выделяемые сегменты виртуальной памяти больше не являются непрерывными, и производительность начинает ухудшаться. Для файловой системы можно выполнить приложение, которое выполнит дефрагментацию файловой системы, и в большинстве случаев, это можно сделать в оперативном режиме при работе с системой. Что касается виртуальной памяти, то не существует средства для ее фрагментации; вместо этого для устранения проблемы необходимо остановить и запустить службу банка данных Microsoft Exchange или перезапустить систему.

По умолчанию служба банка данных Microsoft Exchange проверяет на наличие свободной виртуальной памяти каждый час (например, каждые 3600 секунд). Значение реестра VM Info Update Interval представляет возможность настройки, с помощью которой можно перезаписать интервал по умолчанию, равный 3600 секундам. При изменении уровня по умолчанию рекомендуется не устанавливать значение ниже 5 минут (300 секунд).

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы восстановить конфигурацию по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. В правой области удалите значение VM Info Update Interval.

  4. Закройте редактор реестра и перезапустите службу банка данных Microsoft Exchange, чтобы изменения вступили в силу.

Дополнительные сведения об устранении неполадок, связанных с фрагментацией виртуальной памяти в Exchange Server 2003 и Exchange 2000 Server, см. в статье 325044 базы знаний, посвященной устранению неполадок, связанных с фрагментацией виртуальной памяти в Exchange 2003 и Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044).


Обратное кэширование записи отключено
Анализатор сервера Microsoft Exchange — статьи > Хранилища >

Дата последнего изменения раздела: 2006-08-18

Анализатор рекомендаций Microsoft® Exchange Server определил, что на используемом контроллере дискового массива обратное кэширование записи неверно настроено для дисков, на которых размещены журналы транзакций.

Рекомендуется включить на контроллере дискового массива обратное кэширование записи на 100% для всех дисков, на которых размещены журналы транзакций. Чтение журналов транзакций, как правило, выполняется крайне редко. Чем выше скорость записи на диске с журналом транзакций, тем выше производительность сервера Exchange Server.

Чтобы устранить это предупреждение, выполните следующие действия.

  • Включите обратное кэширование записи.

Дополнительные сведения о настройке жестких дисков сервера Exchange Server см. в статье 188589 базы знаний Майкрософт «Exchange DB and caching hard disks and controllers» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=188589).


Программное обеспечение сторонних производителей
Анализатор сервера Microsoft Exchange — статьи >

Дата последнего изменения раздела: 2005-11-18

В статьях в данном разделе содержатся сведения об оценке средством анализа Microsoft® Exchange Server программного обеспечения сторонних производителей. К тому же, в этих статьях описываются действия, которые можно предпринять для устранения относящихся к программному обеспечению сторонних производителей ошибок, предупреждений и нестандартных конфигураций, найденных средством анализа Exchange Server.


Не настроены исключения для папок, проверяемых на вирусы
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить установлено ли на сервере Exchange антивирусное программное обеспечение Symantec AntiVirus Corporate Edition (Symantec AV) и включен ли режим RealTime Protection (RTP), средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Storages\Filesystem\RealTimeScan

Если анализатор сервера Exchange обнаружит, что значение параметра HaveExceptionDirs реестра установлено равным 0, на экран будет выведено сообщение об ошибке. Значение параметра HaveExceptionDirs реестра равное 0 указывает, что исключения папок отключены.

Исключения папок предотвращают проверку определенных папок во время сканирования на вирусы в реальном времени. Если на сервере Exchange не включены исключения папок, могут возникнуть следующие проблемы:

  • Антивирусное программное обеспечение AV RTP компании Symantec может предоставлять неверные положительные отчеты по определенным незараженным файлам, к которым выполняется обращение во время обычной активности программы.

  • Антивирусное программное обеспечение AV RTP компании Symantec может неправильно сообщать об инфицированных файлах в программном обеспечении, которому в соответствии с корпоративной политикой безопасности уже разрешено выполняться на сервере Exchange.

  • Антивирусное программное обеспечение AV RTP компании Symantec может сканировать структуру каталогов сервера Exchange и быть причиной неправильного определения вирусов, непредусмотренного поведения на сервере Exchange или повреждения базы данных сервера Exchange.

Важно!
Никогда не следует запускать программы сканирования, основанные на проверке файлов, в отношении баз данных, журналов, временных файлов, системных файлов служб IIS (Internet Information Services) и диска (диск М) установочной файловой системы сервера Exchange. Настройте антивирусное программное обеспечение на исключение из сканирования папок, которые содержат эти файлы.

Антивирусное программное обеспечение, основанное на проверке файлов, можно запускать в отношении операционной системы на компьютере сервера Exchange и в отношении программных файлов (папка «Exchsrvr\Bin») сервера Exchange. Однако не запускайте антивирусные программы, основанные на проверке файлов, в отношении следующих файлов и папок:

  • Базы данных (файлы с расширениями MDB и STM) сервера Exchange и файлы (с расширением LOG) журнала транзакций (местоположение по умолчанию: \Exchsrvr\MDBData).

  • MTA-файлы сервера Exchange (местоположение по умолчанию: \Exchsrvr\Mtadata).

  • Файлы журнала отслеживания сообщений сервера Exchange (местоположение по умолчанию: \Exchsrvr\Server_Name.log).

  • Папки виртуального сервера (местоположение по умолчанию: \Exchsrvr\Mailroot).

  • Файлы службы репликации узла (местоположение по умолчанию: \Exchsrvr\Srsdata).

  • Системные файлы службы IIS (местоположение по умолчанию: \%SystemRoot%\System32\Inetsrv).

  • Файлы почтового соединителя Интернета (местоположение по умолчанию: \Exchsrvr\IMCData).

  • Рабочая папка, используемая для хранения временных потоковых файлов, с помощью которых выполняется преобразование сообщений. По умолчанию эта рабочая папка находится по адресу: \Exchsrvr\MDBData.

  • Временная папка, которая используется совместно с автономными служебными программами обслуживания, такими как Eseutil.exe. По умолчанию эта папка является местом, откуда запускаются EXE-файлы, но местоположение запуска исполняемых файлов можно настраивать при запуске служебной программы.

Сканирование, основанное на проверке файлов, может запускаться в отношении следущих папок:

  • Exchsrvr\Address,

  • Exchsrvr\Bin,

  • Exchsrvr\Exchweb,

  • Exchsrvr\Res,

  • Exchsrvr\Schema.

Подробные сведения о настройке исключений для сканирования RealTime в программном обеспечении Symantec AntiVirus Corporate Edition см. на веб-узле антивирусного программного обеспечения компании Symantec (http://www.symantec.com).

Примечание.
Веб-адреса могут измениться, поэтому существует вероятность, что указанные веб-узлы будут недоступны.

Сведения о защите среды Exchange от вирусов и червей, передаваемых по электронной почте, см. на странице, посвященной борьбе с вирусами, распространяемыми по электронной почте, в среде Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47587).

Дополнительные сведения об использовании антивирусного программного обеспечения совместно с сервером Exchange Server см. в статьях базы знаний корпорации Майкрософт:

  • статья 328841, посвященная Exchange и антивирусному программному обеспечению (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841);

  • статья 823166, содержащая обзор Exchange и антивирусного программного обеспечения (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166);

  • статья 306105, посвященная отношению корпорации Майкрософт к антивирусному программному обеспечению для Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105);

  • статья 245822, содержащая рекомендации по исправлению неполадок при использовании Exchange на компьютерах с установленной антивирусной защитой (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Список стороннего антивирусного программного обеспечения, доступного для сервера Exchange, см. на веб-узле, посвященном партнерам по антивирусному программному обеспечению для сервера Exchange (http://go.microsoft.com/fwlink/?linkid=16226).


Программа Antigen сканирует сообщения о репликации общих папок
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2006-03-13

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, присутствует ли хранилище общих папок на каждом сервере Exchange. Если анализатор сервера Exchange обнаружит, что объект InformationStore принадлежит классу msExchPublicMDB, значит, на сервере размещается хранилище общих папок.

Анализатор Microsoft® Exchange также запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение параметра Version для файла ANTIGENVSAPI.DLL. Если для файла ANTIGENVSAPI.DLL задано значение параметра Version 1517 или больше, значит, на сервере Exchange Server установлена программа Sybari Antigen для Microsoft Exchange версии 8.0 SR3 или выше.

Наконец, анализатор сервера Exchange считывает следующую ветвь реестра, чтобы определить, существует ли параметр DoNotScanIPMReplicationMessages и не превышает ли его знанечие 0:

HKEY_LOCAL_MACHINE\Software\Sybari Software\Antigen for Exchange\DoNotScanIPMReplicationMessages

Значение параметра DoNotScanIPMReplicationMessages определяет, будет ли установленная программа Sybari Antigen сканировать (и, возможно, удалять) сообщения о репликации общих папок сервера Exchange. Если для параметра DoNotScanIPMReplicationMessages установлено значение меньше 1, значит, программа Antigen будет сканировать файл winmail.dat на наличие вирусов. Exchange Server использует файлы Winmail.dat для нескольких целей, включая оптимизацию репликации общих папок между серверами. Если программа Antigen изменяет любые из файлов Winmail.dat, происходит сбой процедуры репликации общих папок.

Если анализатор сервера Exchange определяет, что перечисляемые ниже условия выполняются, на экран выводится сообщение об ошибке:

  • На сервере Exchange размещено одна или несколько хранилищ общих папок

  • На сервере установлена программа Sybari Antigen сборки 1517 (или более поздней версии)

  • Параметр DoNotScanIPMReplicationMessages отсутствует или его значение не превышает 0.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы устранить эту ошибку

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\Software\Sybari Software\Antigen for Exchange

  3. Если в правой области уже присутствует подраздел DoNotScanIPMReplicationMessages, щелкните его дважды и задайте значение 1.

  4. Если подраздел DoNotScanIPMReplicationMessages не существует, щелкните правой кнопкой мыши в правой области и создайте его как новое значение DWORD.

  5. Установите для раздела DoNotScanIPMReplicationMessages значение 1.

    Примечание.
    Если в ходе репликации общих папок произойдет копирование вируса, программа Antigen обнаружит его при сканировании в режиме реального времени, даже если указанный выше параметр реестра задан.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об использовании антивирусного программного обеспечения совместно с сервером Exchange Server см. в статьях базы знаний корпорации Майкрософт:

  • Статья 328841, посвященная Exchange и антивирусному программному обеспечению (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841).

  • Статья 823166, содержащая обзор Exchange Server 2003 и антивирусного программного обеспечения (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Статья 306105 об отношении корпорации Майкрософт к антивирусному программному обеспечению для Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105).

  • Статья 245822, содержащая рекомендации по исправлению неполадок при использовании Exchange Server на компьютерах с установленной антивирусной защитой (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).


Антивирусная программа eTrust компании Computer Associates: Файлы EML/LOG/EDB/STM/DAT в настоящее время не находятся в списке исключений
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server Analyzer Tool считывает следующие записи реестра, чтобы получить список расширений файлов, которые были исключены из поиска вирусов вручную в режиме реального времени на уровне файлов для антивирусной программы eTrust от Computer Associates:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeExtList

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeExtList

Если средство анализа Exchange Server Analyzer обнаруживает, что значение для szExcludeExtList не содержит расширения файлов, соответствующих типу файла данных Exchange (eml, log, edb, stm или dat), отображается предупреждение.

eTrust Antivirus - это программа поиска вирусов на уровне файлов. Чтобы определить установленную на сервере Exchange версию eTrust Antivirus, выполните следующие действия:

  1. Перейдите в Пуск | Программы | eTrust Antivirus, затем выберите eTrust Antivirus для запуска приложения.

  2. В меню приложения eTrust Antivirus щелкните Справка, затем О программе eTrust Antivirus.

  3. В поле Версия продукта приведен номер версии eTrust Antivirus.

При использовании программ поиска вирусов на уровне файлов на сервере Exchange могут возникать следующие проблемы:

  • Программы поиска вирусов на уровне файлов проверяют файл при его использовании или с запланированным интервалом и могут закрыть для доступа или поместить в карантин журнал Exchange или файл базы данных, когда Exchange пытается к ним обратиться. Это может вызвать ошибку в работе сервера Exchange, а также ошибки базы данных.

  • Дополнительные проблемы могут возникать при проверке диска, представленного IFS — обычно это диск M — при помощи программ поиска вирусов на уровне файлов.

Вне зависимости от того, какой антивирусной программой файлового уровня вы пользуетесь, следующие файлы и папки всегда нужно исключать:

  • файлы eml, edb, stm, log, dat и chk.

  • Диск сервера Exchange, представленный IFS. По умолчанию это диск M.

  • Базы данных и файлы журнала Exchange. По умолчанию они находятся в папке Exchsrvr\Mdbdata.

  • Файлы MTA Exchange находятся в папке Exchsrvr\Mtadata.

  • Дополнительные файлы журнала, например файл Exchsrvr\server_name.log.

  • Папка виртуального сервера Exchsrvr\Mailroot.

  • Рабочая папка, которая используется для хранения потоковых временных файлов, используемых для преобразования сообщений. По умолчанию адрес этой папки - \Exchsrvr\MDBData, но его можно изменить.

  • Временная папка, которая используется автономными средствами обслуживания, например Eseutil.exe. По умолчанию папка находится там же, откуда запущен файл exe, но при запуске средства это место можно перенастроить.

  • Файлы службы репликации сайтов (SRS) в папке Exchsrvr\Srsdata.

  • Системные файлы Microsoft Internet Information Service (IIS) в папке %SystemRoot%\System32\Inetsrv.

  • Рабочие файлы IIS в папке %SystemRoot%\IIS Temporary Compressed Files.

Исправление предупреждения

  1. При помощи интерфейса пользователя eTrust Antivirus исключите перечисленные выше папки и файлы из поиска вирусов на файловом уровне.

  2. Посетите веб-узел Computer Associates eTrust (http://www3.ca.com/Solutions/Product.asp?ID=156) для получения новейшей информации об использовании eTrust Antivirus на сервере Exchange.

    Примечание.
    Веб-адреса могут меняться, поэтому попасть на упомянутый здесь веб-узел или узлы может быть невозможно.

Для получения дополнительных сведений об использовании антивирусного программного обеспечения с сервером Exchange см. следующие статьи базы знаний Майкософт:

  • 328841, «XADM: Exchange и антивирусное программное обеспечение» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, «Обзор сервера Exchange 2003 и антивирусного программного обеспечения» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, «XGEN: Отношение Майкрософт к антивирусным решениям для Exchange 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, «Рекомендации по устранению неполадок компьютера с сервером Exchange, на котором установлено антивирусное программное обеспечение» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Для получения списка антивирусного программного обеспечения сторонних производителей для сервера Exchange см. перечень партнеров продукта Exchange Server: Веб-узел антивирусного программного обеспечения (http://go.microsoft.com/fwlink/?LinkId=16226).

Для получения дополнительных сведений о проблемах, которые могут возникать при проверке диска IFS, см. следующие статьи базы знаний Майкософт:

  • 298924, «XADM: Запрет на резервное копирование или проверку диска M сервера Exchange 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, «XADM: C1041737 Сообщение об ошибке отображается при подключении базы данных» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, «XADM: Из папок пользователя пропадают элементы календаря» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: диск данных Exchange не был исключен из созданного вручную задания на антивирусное сканирование
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующие записи реестра, чтобы получить список каталогов, которые исключены из созданного вручную задания на антивирусное сканирование, выполняемого на уровне файлов программой eTrust Antivirus, разработанной компанией Computer Associates:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

Анализатор сервера Exchange также считывает значение атрибута MsExchESEParamSystemPath в службе каталогов Active Directory®, который является атрибутом группы хранения, соответствующим местоположению файла системного журнала Exchange.

Если анализатор сервера Exchange обнаруживает, что значение szExcludeDirs не содержит пути, соответствующего местоположению системного журнала Exchange, выводится предупреждение.

eTrust Antivirus является программой антивирусного сканирования на уровне файлов. Чтобы определить версию программы eTrust Antivirus, установленной на компьютере сервера Exchange, выполните следующие действия:

  1. Последовательно выберите Пуск | Программы | eTrust Antivirus, а затем щелкните eTrust Antivirus, чтобы запустить приложение.

  2. В меню eTrust Antivirus последовательно выберите Справка и About eTrust Antivirus (О программе eTrust Antivirus).

  3. В поле Product Version (Версия продукта) указана версия программы eTrust Antivirus.

При выполнении антивирусного сканирования на уровне файлов на компьютере сервера Exchange могут встретиться следующие затруднения:

  • В процессе антивирусного сканирования на уровне файлов обработка файла происходит в то время, когда он используется или когда его использование попадает в запланированный интервал. В результате файл журнала Exchange или базы данных может быть заблокирован или помещен в карантин, в то время как Exchange пытается использовать этот файл. Это может вызвать серьезный сбой сервера Exchange, а также привести к ошибкам в работе базы данных.

  • Проблемы могут также возникнуть при сканировании диска, представленного системой IFS (Exchange Installable File System), — обычно это диск M — с программным обеспечением антивирусного сканирования на уровне файлов.

Независимо от того, какая программа используется для антивирусного сканирования на уровне файлов, следует всегда исключать сканирование следующих файлов и папок:

  • Файлы с расширениями EML, EDB, STM, LOG, DAT и CHK.

  • Диск сервера Exchange, представленного системой IFS. По умолчанию это диск M.

  • Файлы баз данных Exchange и журналов. По умолчанию они расположены в папке Exchsrvr\Mdbdata.

  • MTA-файлы Exchange в папке Exchsrvr\Mtadata.

  • Дополнительные файлы журналов, такие как файл Exchsrvr\server_name.log.

  • Папка виртуального сервера Exchsrvr\Mailroot.

  • Рабочая папка, используемая для хранения временных потоковых файлов, используемых для преобразования сообщений. По умолчанию эта папка расположена в папке \Exchsrvr\MDBData, но ее местоположение можно изменять.

  • Временная папка, используемая средствами автономного обслуживания, такими как Eseutil.exe. По умолчанию эта папка находится в той же папке, что и вызываемый EXE-файл, но при запуске средства местоположение временной папки можно изменить.

  • Файлы службы репликации сайта (SRS), находящиеся в папке Exchsrvr\Srsdata.

  • Системные файлы службы Microsoft Internet Information Service (IIS), находящиеся в папке %SystemRoot%\System32\Inetsrv.

  • Рабочие файлы службы IIS, находящиеся в папке %SystemRoot%\IIS Temporary Compressed Files.

Устранение причины появления этого предупреждения

  1. С помощью пользовательского интерфейса программы eTrust Antivirus исключите перечисленные ранее папки и файлы из антивирусного сканирования на уровне файлов.

  2. Новейшие сведения об использовании программы eTrust Antivirus на компьютере сервера Exchange см. на веб-узле Computer Associates eTrust Antivirus по адресу http://www3.ca.com/Solutions/Product.asp?ID=156 (возможно, на английском языке).

    Примечание.
    Веб-адреса могут измениться, поэтому существует вероятность, что подключиться к упомянутым здесь веб-узлам не удастся.

Для получения дополнительных сведений об использовании антивирусного программного обеспечения совместно с сервером Exchange см. статьи базы знаний корпорации Майкрософт:

  • 328841, посвященная XADM, а также Exchange и антивирусном программном обеспечении, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841 (возможно, на английском языке)

  • 823166, содержащая обзор Exchange и антивирусного программного обеспечения, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166 (возможно, на английском языке)

  • 306105, посвященная XGEN и отношению корпорации Майкрософт к антивирусному программному обеспечению для Exchange 2000, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105 (возможно, на английском языке)

  • 245822, содержащая рекомендации по исправлению неполадок при использовании Exchange на компьютерах с установленной антивирусной защитой, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822 (возможно, на английском языке)

Перечень стороннего антивирусного программного обеспечения для сервера Exchange см. на веб-узле Exchange Partners, посвященный антивирусному программному обеспечению (http://go.microsoft.com/fwlink/?LinkId=16226).

Для получения дополнительных сведений о неполадках, которые могут произойти при сканировании IFS-диска, см. следующие статьи базы данных:

  • 298924, в которой описывается XADM и рекомендуется не выполнять ни архивирования, ни антивирусного сканирования диска M сервера Exchange 2000, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924 (возможно, на английском языке)

  • 300608, описывающая XADM и сообщение об ошибке C1041737 при подключении базы данных, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608 (возможно, на английском языке)

  • 299046, описывающая XADM и исчезновение элементов календаря из пользовательских папок, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046 (возможно, на английском языке)


CA eTrust: Диск с данными Exchange не был исключен из поиска в режиме реального времени.
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server считывает следующие параметры реестра, чтобы получить список каталогов, исключенных из поиска вирусов на файловом уровне в режиме реального времени в антивирусной программе eTrust от Computer Associates:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

Средство анализа Exchange Server также запрашивает данные службы каталогов Active Directory®, чтобы определить значение атрибутаMsExchESEParamSystemPath для каждой группы хранения. Этот атрибут представляет собой путь файлов данных Exchange.

Если средство анализа Exchange Server обнаруживает, что значение szExcludeDirs не включает в себя путь файла системных данных Exchange, отображается предупреждение.

eTrust Antivirus - это программа поиска вирусов на уровне файлов. Чтобы определить версию eTrust Antivirus, установленную на компьютере с Exchange Server:

  1. Перейдите в Пуск | Программы | eTrust Antivirus, затем выберите eTrust Antivirus для запуска приложения.

  2. В меню приложения eTrust Antivirus щелкните Справка, затем О программе eTrust Antivirus.

  3. В поле Версия продукта приведен номер версии eTrust Antivirus.

При использовании программ поиска вирусов на уровне файлов на сервере Exchange могут возникать следующие проблемы:

  • Программы поиска вирусов на уровне файлов проверяют файл при его использовании или с запланированным интервалом и могут закрыть для доступа или поместить в карантин журнал Exchange или файл базы данных, когда Exchange пытается к ним обратиться. Это может вызвать ошибку в работе сервера Exchange, а также ошибки базы данных.

  • Дополнительные проблемы могут возникать при проверке диска, представленного IFS — обычно это диск M — при помощи программ поиска вирусов на уровне файлов.

Вне зависимости от того, какой антивирусной программой файлового уровня вы пользуетесь, следующие файлы и папки всегда нужно исключать:

  • Файлы eml, edb, stm, log, dat и chk.

  • Диск сервера Exchange, представленный IFS. По умолчанию это диск M.

  • Базы данных и файлы журнала Exchange. По умолчанию они находятся в папке Exchsrvr\Mdbdata.

  • Файлы MTA Exchange находятся в папке Exchsrvr\Mtadata.

  • Дополнительные файлы журнала, например файл Exchsrvr\server_name.log.

  • Папка виртуального сервера Exchsrvr\Mailroot.

  • Рабочая папка, которая используется для хранения потоковых временных файлов, используемых для преобразования сообщений. По умолчанию адрес этой папки - \Exchsrvr\MDBData, но его можно изменить.

  • Временная папка, которая используется автономными средствами обслуживания, например Eseutil.exe. По умолчанию папка находится там же, откуда запущен файл exe, но при запуске средства это место можно перенастроить.

  • Файлы службы репликации сайтов (SRS) в папке Exchsrvr\Srsdata.

  • Системные файлы Microsoft Internet Information Service (IIS) в папке %SystemRoot%\System32\Inetsrv.

  • Рабочие файлы IIS в папке %SystemRoot%\IIS Temporary Compressed Files.

Для устранения этого предупреждения

  1. При помощи интерфейса пользователя eTrust Antivirus исключите перечисленные выше папки и файлы из поиска вирусов на файловом уровне.

  2. Посетите веб-узел Computer Associates eTrust (http://www3.ca.com/Solutions/Product.asp?ID=156) для получения новейшей информации об использовании eTrust Antivirus на сервере Exchange.

    Примечание.
    Веб-адреса могут меняться, поэтому попасть на упомянутый здесь веб-узел или узлы может быть невозможно.

Для получения дополнительных сведений об использовании антивирусного программного обеспечения с сервером Exchange см. следующие статьи базы знаний Майкософт:

  • 328841, «XADM: Exchange и антивирусное программное обеспечение» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, «Обзор сервера Exchange 2003 и антивирусного программного обеспечения» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, «XGEN: Отношение Майкрософт к антивирусным решениям для Exchange 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, «Рекомендации по устранению неполадок компьютера с сервером Exchange, на котором установлено антивирусное программное обеспечение» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Для получения списка антивирусного программного обеспечения сторонних производителей для сервера Exchange см. перечень партнеров продукта Exchange Server: Веб-узел антивирусного программного обеспечения (http://go.microsoft.com/fwlink/?LinkId=16226).

Для получения дополнительных сведений о проблемах, которые могут возникать при проверке диска IFS, см. следующие статьи базы знаний Майкософт:

  • 298924, «XADM: Запрет на резервное копирование или проверку диска M сервера Exchange 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, «XADM:C1041737 Сообщение об ошибке отображается при подключении базы данных» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, «XADM: Из папок пользователя пропадают элементы календаря» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


Антивирусная программа eTrust компании Computer Associates: Путь устанавливаемой файловой системы (IFS) Exchange не был исключен из списка для поиска вирусов в заданиях вручную
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Средство анализа сервера Microsoft® Exchange считывает следующие параметры реестра, чтобы получить список папок, которые были исключены поиска вирусов вручную на уровне файлов для антивирусной программы eTrust от Computer Associates:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

Средство анализа сервера Exchange также считывает букву диска, соответствующую диску устанавливаемой файловой системы (IFS):

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

Буква диска по умолчанию для сервера Exchange 2000 - M. Диск IFS для сервера Exchange 2003 по умолчанию отключен.

Если средство анализа сервера Exchange обнаружит, что значение szExcludeDirs не включает в себя соответствующее диску IFS значение, отображается предупреждение.

eTrust Antivirus - это программа поиска вирусов на уровне файлов. Чтобы определить установленную на сервере Exchange версию eTrust Antivirus, выполните следующие действия:

  1. Перейдите в Пуск | Программы | eTrust Antivirus, затем выберите eTrust Antivirus для запуска приложения.

  2. В меню приложения eTrust Antivirus щелкните Справка, затем О программе eTrust Antivirus.

  3. В поле Версия продукта приведен номер версии eTrust Antivirus.

При использовании программ поиска вирусов на уровне файлов на сервере Exchange могут возникать следующие проблемы:

  • Программы поиска вирусов на уровне файлов проверяют файл при его использовании или с запланированным интервалом и могут закрыть для доступа или поместить в карантин журнал Exchange или файл базы данных, когда Exchange пытается к ним обратиться. Это может вызвать ошибку в работе сервера Exchange, а также ошибки базы данных.

  • Дополнительные проблемы могут возникать при проверке диска, представленного IFS — обычно это диск M — при помощи программ поиска вирусов на уровне файлов.

Вне зависимости от того, какой антивирусной программой файлового уровня вы пользуетесь, следующие файлы и папки всегда нужно исключать:

  • файлы eml, edb, stm, log, dat и chk.

  • Диск сервера Exchange, представленный IFS. По умолчанию это диск M.

  • Базы данных и файлы журнала Exchange. По умолчанию они находятся в папке Exchsrvr\Mdbdata.

  • Файлы MTA Exchange находятся в папке Exchsrvr\Mtadata.

  • Дополнительные файлы журнала, например файл Exchsrvr\server_name.log.

  • Папка виртуального сервера Exchsrvr\Mailroot.

  • Рабочая папка, которая используется для хранения потоковых временных файлов, используемых для преобразования сообщений. По умолчанию адрес этой папки - \Exchsrvr\MDBData, но его можно изменить.

  • Временная папка, которая используется автономными средствами обслуживания, например Eseutil.exe. По умолчанию папка находится там же, откуда запущен файл exe, но при запуске средства это место можно перенастроить.

  • Файлы службы репликации сайтов (SRS) в папке Exchsrvr\Srsdata.

  • Системные файлы Microsoft Internet Information Service (IIS) в папке %SystemRoot%\System32\Inetsrv.

  • Рабочие файлы IIS в папке %SystemRoot%\IIS Temporary Compressed Files.

Чтобы исправить эту предупреждение

  1. При помощи интерфейса пользователя eTrust Antivirus исключите перечисленные выше папки и файлы из поиска вирусов на файловом уровне.

  2. Посетите веб-узел Computer Associates eTrust (http://www3.ca.com/Solutions/Product.asp?ID=156) для получения новейшей информации об использовании eTrust Antivirus на сервере Exchange.

    Примечание.
    Веб-адреса могут меняться, поэтому попасть на упомянутый здесь веб-узел или узлы может быть невозможно.

Для получения дополнительных сведений об использовании антивирусного программного обеспечения с сервером Exchange см. следующие статьи базы знаний Майкософт:

  • 328841, «XADM: Exchange и антивирусное программное обеспечение» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, «Обзор сервера Exchange 2003 и антивирусного программного обеспечения» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, «XGEN: Отношение Майкрософт к антивирусным решениям для Exchange 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, «Рекомендации по устранению неполадок компьютера с сервером Exchange, на котором установлено антивирусное программное обеспечение» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Для получения списка антивирусного программного обсепечения сторонних производителей для сервера Exchange см. перечень партнеров продукта Exchange Server: Веб-узел антивирусного программного обеспечения (http://go.microsoft.com/fwlink/?LinkId=16226)

Для получения дополнительных сведений о проблемах, которые могут возникать при проверке диска IFS, см. следующие статьи базы знаний Майкософт:

  • 298924, «XADM: Запрет на резервное копирование или проверку диска M сервера Exchange 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, «XADM: C1041737 Сообщение об ошибке отображается при подключении базы данных» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, «XADM: Из папок пользователя пропадают элементы календаря» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


Программа eTrust компании CA: путь IFS в Exchange не был исключен из поиска в режиме реального времени
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server считывает следующие параметры реестра, чтобы получить список каталогов, исключенных из поиска вирусов на файловом уровне в режиме реального времени в антивирусной программе eTrust от Computer Associates:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7,0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

Кроме того, средство анализа Exchange Server считывает следующие параметры реестра, чтобы узнать букву диска устанавливаемой файловой системы (IFS):

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

В Exchange 2000 Server буква диска по умолчанию M. По умолчанию диск IFS в Exchange Server 2003 отключен.

Если анализатор обнаружит, что в значении szExcludeDirs не содержится путь, соответствующий диску IFS, появится предупреждение.

eTrust Antivirus — это программа для поиска вирусов на файловом уровне. Чтобы определить, какая версия eTrust Antivirus установлена на компьютере сервера Exchange, сделайте следующее:

  1. Нажмите кнопку Пуск, выберите Программы | eTrust Antivirus и щелкните eTrust Antivirus, чтобы запустить приложение.

  2. В меню приложения eTrust Antivirus щелкните Help и выберите пункт About eTrust Antivirus.

  3. В поле Product Version указана версия eTrust Antivirus.

При использовании программ поиска вирусов файлового уровня на компьютере сервера Exchange могут возникать следующие проблемы:

  • Программы поиска вирусов файлового уровня проверяют файл при его использовании или через определенные интервалы времени и могут заблокировать или поместить на карантин файл журнала или базы данных Exchange, тогда как Exchange будет пытаться их использовать. Это может привести к серьезному сбою в работе сервера Exchange или к ошибкам баз данных.

  • Другие проблемы могут возникнуть при проверке программами файлового уровня диска IFS — обычно это диск M.

Независимо от того, какая антивирусная программа файлового уровня используется, следующие файлы и папки должны быть обязательно исключены из перечня проверяемых объектов:

  • Файлы eml, edb, stm, log, dat и chk.

  • Диск IFS сервера Exchange. По умолчанию это диск M.

  • Файлы журнала и баз данных Exchange. По умолчанию они расположены в папке Exchsrvr\Mdbdata.

  • Файлы MTA сервера Exchange в папке Exchsrvr\Mtadata.

  • Дополнительные файлы журналов, например Exchsrvr\server_name.log.

  • Папка виртуального сервера Exchsrvr\Mailroot.

  • Рабочая папка, используемая для хранения потоковых временных файлов, задействованных при преобразовании сообщений. По умолчанию это папка \Exchsrvr\MDBData, но ее расположение может быть настроено.

  • Временная папка, используемая средствами обслуживания в автономном режиме, такими как Eseutil.exe. По умолчанию эта папка расположена там же, где и файл exe, но ее расположение можно настроить при запуске средства.

  • Файлы службы репликации сайта (SRS) в папке Exchsrvr\Srsdata.

  • Системные файлы IIS в папке %SystemRoot%\System32\Inetsrv.

  • Рабочие файлы IIS в папке %SystemRoot%\IIS Temporary Compressed Files.

Устранение предупреждения

  1. В интерфейсе программы eTrust Antivirus исключите вышеперечисленные файлы и папки из списка файлов, проверяемых программой поиска вирусов файлового уровня.

  2. Посетите веб-узел CA eTrust Antivirus (http://www3.ca.com/Solutions/Product.asp?ID=156), чтобы узнать последние сведения об использовании eTrust Antivirus на компьютерах Exchange Server.

    Примечание.
    Веб-адреса могут измениться, и поэтому, возможно, не удастся подключиться к веб-узлам, упомянутым здесь.

Для получения дополнительных сведений об использовании антивирусного программного обеспечения для Exchange Server см. следующие статьи базы знаний корпорации Майкрософт:

  • 328841, «XADM: „Антивирусное программное обеспечение для Exchange» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, Использование антивирусных программ на сервере Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, «XGEN: Мнение Майкрософт об антивирусных программах для Exchange 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, «Рекомендации по устранению неполадок на компьютере с Exchange Server, использующем антивирусные программы» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Список антивирусного программного обеспечения сторонних производителей, используемого для сервера Exchange, можно найти на веб-узле, посвященном партнерам сервера Exchange в области антивирусных программ (http://go.microsoft.com/fwlink/?linkid=16226).

Для получения дополнительных сведений о проблемах, которые могут возникнуть при проверке диска IFS, см. следующие статьи базы знаний:

  • 298924, «XADM: Не следует выполнять резервное копирование и проверку на вирусы диска M (Exchange 2000)» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, «XADM: Сообщение об ошибке C1041737, появляющееся при подключении баз данных» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, «XADM: Из папок пользователя пропадают объекты календаря» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: задано сканирование в режиме реального времени всех файлов независимо от расширения
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2006-04-21

Средство анализатора сервера Microsoft® Exchange считывает следующие записи реестра, чтобы получить список расширений имен файлов, которые были исключены из антивирусного сканирования в режиме реального времени, выполняемого на уровне файлов программой eTrust Antivirus, разработанной компанией Computer Associates:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\dwFileFilterType

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\dwFileFilterType

Если анализатор сервера Exchange определяет, что значение параметра dwFileFilterType задает сканирование всех файлов независимо от расширения имени файла, выводится предупреждение.

Программа eTrust Antivirus является программой антивирусного сканирования на уровне файлов. Чтобы определить версию программы eTrust Antivirus, установленной на компьютере с сервером Exchange Server, выполните следующие действия:

  1. Последовательно выберите Пуск, Программы, eTrust Antivirus, а затем щелкните eTrust Antivirus, чтобы запустить приложение.

  2. В меню eTrust Antivirus последовательно выберите Справка и About eTrust Antivirus.

  3. В поле Product Version указана версия программы eTrust Antivirus.

При выполнении антивирусного сканирования на уровне файлов на компьютере с Exchange могут возникнуть следующие неполадки:

  • В процессе антивирусного сканирования на уровне файлов обработка файла выполняется при его использовании или с запланированным интервалом. В результате файл журнала или базы данных Exchange может быть заблокирован или находиться в карантине в то время, когда Exchange пытается использовать этот файл. Это может вызвать серьезный сбой сервера Exchange, а также привести к возникновению ошибок в базе данных.

  • Неполадки могут также произойти при антивирусном сканировании на уровне файлов диска, представленного системой IFS (Exchange Installable File System), — обычно это диск M.

Независимо от того, какая программа используется для антивирусного сканирования на уровне файлов, следует всегда исключать сканирование следующих файлов и папок:

  • Файлов с расширениями EML, EDB, STM, LOG, DAT и CHK.

  • Диска Exchange Server, представленного системой IFS. По умолчанию это диск M .

  • Файлов баз данных и журналов Exchange. По умолчанию они расположены в папке Exchsrvr\Mdbdata.

  • MTA-файлов Exchange в папке Exchsrvr\Mtadata.

  • Дополнительных файлов журналов, таких как файл Exchsrvr\имя_сервера.log.

  • Папки виртуального сервера Exchsrvr\Mailroot.

  • Рабочей папки, используемой для хранения временных потоковых файлов, с помощью которых выполняется преобразование сообщений. По умолчанию эта папка расположена в папке \Exchsrvr\MDBData, но ее расположение можно изменять.

  • Временной папки, используемой средствами автономного обслуживания, такими как Eseutil.exe. По умолчанию эта папка находится в папке, из которой запускаются EXE-файлы, но при запуске этих средств расположение временной папки можно изменять.

  • Файлов службы репликации сайта (SRS), находящихся в папке Exchsrvr\Srsdata.

  • Системных файлов служб IIS, находящихся в папке %SystemRoot%\System32\Inetsrv.

  • Рабочих файлов служб IIS, находящихся в папке %SystemRoot%\IIS Temporary Compressed Files.

Чтобы устранить причину появления этого предупреждения

  1. С помощью интерфейса пользователя программы eTrust Antivirus исключите антивирусное сканирование на уровне файлов перечисленных папок и файлов.

  2. Самые новые сведения об использовании программы eTrust Antivirus на компьютерах с сервером Exchange Server можно получить на веб-узле Computer Associates eTrust Antivirus (http://www3.ca.com/Solutions/Product.asp?ID=156).

    Примечание.
    Веб-адреса могут измениться, поэтому указанные веб-узлы могут быть недоступны.

Дополнительные сведения об использовании антивирусного программного обеспечения совместно с сервером Exchange Server см. в статьях базы знаний корпорации Майкрософт:

  • Статья 328841, посвященная Exchange и антивирусному программному обеспечению (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • Статья 823166, содержащая обзор Exchange и антивирусного программного обеспечения (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • Статья 306105, посвященная отношению корпорации Майкрософт к антивирусному программному обеспечению для Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • Статья 245822, содержащая рекомендации по исправлению неполадок при использовании Exchange на компьютерах с установленной антивирусной защитой (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Список антивирусного программного обеспечения сторонних разработчиков для сервера Exchange см. на веб-узле «Exchange Partners: Antivirus» (http://go.microsoft.com/fwlink/?LinkId=16226).

Дополнительные сведения о неполадках, которые могут возникнуть при сканировании IFS-диска, см. в следующих статьях базы знаний:

  • Статья 298924, посвященная необходимости исключить архивирование и антивирусное сканирование диска M сервера Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • Статья 300608, посвященная сообщению об ошибке C1041737, отображаемому при подключении баз данных (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • Статья 299046, посвященная исчезновению элементов календаря из пользовательских папок (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: диск групп хранения не был исключен из созданного вручную задания на сканирование
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Средство Microsoft® Exchange Server Analyzer считывает следующие записи реестра, чтобы получить список каталогов, которые исключены из созданного вручную задания на антивирусное сканирование, выполняемого на уровне файлов программой eTrust Antivirus, разработанной компанией Computer Associates:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7,0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

Exchange Server Analyzer также считывает значение атрибута MsExchESEParamSystemPath в службе каталогов Active Directory®, который является атрибутом группы хранения соответствующим местоположению файла системного журнала Exchange.

Если Exchange Server Analyzer что значение szExcludeDirs не содержит пути, соответствующего местоположению системного журнала Exchange, отображается предупреждение.

eTrust Antivirus является программой антивирусного сканирования на уровне файлов. Чтобы определить версию программы eTrust Antivirus, установленной на компьютере с сервером Exchange Server, выполните следующие действия:

  1. Последовательно выберите Пуск | Программы | eTrust Antivirus, а затем щелкните eTrust Antivirus, чтобы запустить приложение.

  2. В меню eTrust Antivirus последовательно выберите Справка и About eTrust Antivirus (О программе eTrust Antivirus).

  3. В поле Product Version (Версия продукта) указана версия программы eTrust Antivirus.

При выполнении антивирусного сканирования на уровне файлов на компьютере с Exchange Server могут встретиться следующие затруднения:

  • В процессе антивирусного сканирования на уровне файлов обработка файла происходит в то время, когда он используется или когда его использование попадает в запланированный интервал. В результате файл журнала Exchange или базы данных может быть заблокирован или помещен в карантин, в то время как Exchange пытается использовать этот файл. Это может вызвать серьезный сбой сервера Exchange Server, а также привести к ошибкам в работе базы данных.

  • Неполадки могут также произойти при сканировании диска, представленного системой IFS (Exchange Installable File System), — обычно это диск M — с программным обеспечением антивирусного сканирования на уровне файлов.

Независимо от того, какая программа используется для антивирусного сканирования на уровне файлов, следует всегда исключать сканирование следующих файлов и папок:

  • Файлов с расширениями EML, EDB, STM, LOG, DAT и CHK.

  • Диска Exchange Server, представленного системой IFS. По умолчанию это диск M.

  • Файлов баз данных Exchange и журналов. По умолчанию они расположены в папке Exchsrvr\Mdbdata.

  • MTA-файлов Exchange в папке Exchsrvr\Mtadata.

  • Дополнительных файлов журналов, таких как файл Exchsrvr\server_name.log.

  • Папки виртуального сервера Exchsrvr\Mailroot.

  • Рабочей папки, используемой для хранения временных потоковых файлов, используемых для преобразования сообщений. По умолчанию эта папка расположена в папке \Exchsrvr\MDBData, но ее местоположение можно изменять.

  • Временной папки, используемой средствами автономного обслуживания, такими как Eseutil.exe. По умолчанию эта папка находится в той же папке, из которой вызываются EXE-файлы, но при запуске этого средства местоположение временной папки можно изменять.

  • Файлов службы репликации сайта (SRS), находящихся в папке Exchsrvr\Srsdata.

  • Системных файлов службы Microsoft Internet Information Service (IIS), находящихся в папке %SystemRoot%\System32\Inetsrv.

  • Рабочих файлов службы IIS, находящихся в папке %SystemRoot%\IIS Temporary Compressed Files.

Чтобы исправить неполадки, вызвавшие предупреждение, выполните следующие действия:

  1. С помощью пользовательского интерфейса программы eTrust Antivirus исключите перечисленные ранее папки и файлы из области антивирусного сканирования на уровне файлов.

  2. Новейшие сведения об использовании программы eTrust Antivirus на компьютерах с сервером Exchange Server можно получить на веб-узле Computer Associates eTrust Antivirus (http://www3.ca.com/Solutions/Product.asp?ID=156).

    Примечание.
    Веб-адреса могут измениться, поэтому существует вероятность, что вам не удастся подключиться к упомянутым здесь веб-узлам.

Для получения дополнительных сведений об использовании антивирусного программного обеспечения совместно с сервером Exchange Server см. статьи базы знаний корпорации Майкрософт:

  • Статья 328841 об Exchange и антивирусном программном обеспечении (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • Статья 823166, содержащая обзор Exchange и антивирусного программного обеспечения (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • Статья 306105 об отношении корпорации Майкрософт к антивирусному программному обеспечению для Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • Статья 245822, содержащая рекомендации по исправлению неполадок при использовании Exchange на компьютерах с установленной антивирусной защитой (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

  • Для получения перечня стороннего антивирусного программного обеспечения для Exchange Server см. веб-узел Exchange Partners, посвященный антивирусному программному обеспечению (http://go.microsoft.com/fwlink/?LinkId=16226).

Для получения дополнительных сведений о неполадках, которые могут произойти при сканировании IFS-диска, см. следующие статьи базы данных:

  • Статья 298924, в которой рекомендуется не выполнять ни архивирования, ни антивирусного сканирования диска M сервера Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • Статья 300608, в которой обсуждается сообщение об ошибке C1041737 при подключении базы данных (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • Статья 299046, в которой обсуждаются причины того, что из пользовательских папок исчезают элементы календаря (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: диск групп хранения не был исключен из процесса сканирования в режиме реального времени
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange считывает следующие записи реестра, чтобы получить список каталогов, которые были исключены из антивирусного сканирования в режиме реального времени, выполняемого на уровне файлов программой eTrust Antivirus, разработанной компанией Computer Associates:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

Анализатор сервера Exchange также считывает значение атрибута MsExchESEParamSystemPath в службе каталогов Active Directory®, который является атрибутом группы хранения, соответствующим местоположению системного файла данных Exchange.

Если анализатор сервера Exchange обнаруживает, что значение szExcludeDirs не содержит пути, соответствующего расположению системного файла данных Exchange, выводится предупреждение.

Программа eTrust Antivirus является программой антивирусного сканирования на уровне файлов. Чтобы определить версию программы eTrust Antivirus, установленную на компьютере сервера Exchange, выполните следующие действия:

  1. Последовательно выберите Пуск, Программы, eTrust Antivirus, а затем щелкните eTrust Antivirus, чтобы запустить приложение.

  2. В меню eTrust Antivirus последовательно выберите Справка и About eTrust Antivirus.

  3. В поле Product Version указана версия программы eTrust Antivirus.

При выполнении антивирусного сканирования на уровне файлов на компьютере с Exchange могут возникнуть следующие проблемы:

  • В процессе антивирусного сканирования на уровне файлов обработка файла выполняется при его использовании или с запланированным интервалом. В результате файл журнала или базы данных Exchange может быть заблокирован или помещен в карантин в то время, как Exchange пытается использовать этот файл. Это может вызвать серьезный сбой сервера Exchange, а также привести к возникновению ошибок в работе базы данных.

  • Неполадки могут также возникнуть при сканировании диска, представленного устанавливаемой файловой системой Exchange (IFS) с использованием программного обеспечения сканирования на уровне файлов. Как правило, такой диск имеет букву M.

Независимо от того, какая программа используется для антивирусного сканирования на уровне файлов, следует всегда исключать сканирование следующих файлов и папок:

  • Файлов с расширениями EML, EDB, STM, LOG, DAT и CHK.

  • Диска Exchange, представленного системой IFS. По умолчанию это диск M.

  • Файлов баз данных и журналов Exchange. По умолчанию они расположены в папке Exchsrvr\Mdbdata.

  • MTA-файлов Exchange в папке Exchsrvr\Mtadata.

  • Дополнительных файлов журналов, таких как файл Exchsrvr\имя_сервера.log.

  • Папки виртуального сервера Exchsrvr\Mailroot.

  • Рабочей папки, используемой для хранения временных потоковых файлов, с помощью которых выполняется преобразование сообщений. По умолчанию эта папка расположена в папке \Exchsrvr\MDBData, но ее расположение можно изменять.

  • Временной папки, используемой средствами автономного обслуживания, такими как Eseutil.exe. По умолчанию эта папка находится в папке, где выполняются EXE-файлы, но при запуске этого средства расположение временной папки можно изменять.

  • Файлов службы репликации сайта (SRS), находящихся в папке Exchsrvr\Srsdata.

  • Системных файлов служб IIS, находящихся в папке %SystemRoot%\System32\Inetsrv.

  • Рабочих файлов служб IIS, находящихся в папке %SystemRoot%\IIS Temporary Compressed Files.

Чтобы устранить причину появления этого предупреждения

  1. С помощью интерфейса пользователя программы eTrust Antivirus исключите перечисленные ранее папки и файлы из области антивирусного сканирования на уровне файлов.

  2. Самые новые сведения об использовании программы eTrust Antivirus на компьютерах с сервером Exchange Server можно получить на веб-узле Computer Associates eTrust Antivirus (http://www3.ca.com/Solutions/Product.asp?ID=156).

    Примечание.
    Веб-адреса могут измениться, поэтому существует вероятность, что указанные веб-узлы будут недоступны.

Дополнительные сведения об использовании антивирусного программного обеспечения совместно с сервером Exchange см. в следующих статьях базы знаний Майкрософт:

  • 328841, «XADM: Exchange and Antivirus Software» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841) (XADM: Exchange и антивирусное программное обеспечение)

  • 823166, «Overview of Exchange Server 2003 and antivirus software» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166) (Общие сведения об Exchange и антивирусном программном обеспечении)

  • 306105, «XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105) (Позиция корпорации Майкрософт в отношении антивирусного программного обеспечения для Exchange 2000)

  • 245822, «Recommendations for troubleshooting an Exchange computer with antivirus software installed» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822) (Рекомендации по исправлению неполадок в работе Exchange на компьютерах с установленной защитой от вирусов)

Список антивирусного программного обеспечения сторонних разработчиков для сервера Exchange см. на веб-узле «Exchange Partners: Antivirus» (http://go.microsoft.com/fwlink/?LinkId=16226) (Партнеры Exchange: антивирусное ПО).

Дополнительные сведения о неполадках, которые могут возникнуть при сканировании IFS-диска, см. в следующих статьях базы знаний:

  • 298924, «XADM: Do Not Back Up or Scan Exchange 2000 Drive M» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924) (XADM: не выполняйте резервное копирование и сканирование диска M в Exchange 2000)

  • 300608, «XADM: C1041737 Err Msg Displayed When You Mount Databases» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608) (XADM: сообщение об ошибке C1041737 при подключении базы данных)

  • 299046, «XADM: Calendar Items Disappear from User's Folders» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046) (XADM: из пользовательских папок исчезают элементы календаря)


CA eTrust: процесс Exchange не был исключен из диск групп хранения не был исключен из процесса сканирования в режиме реального времени
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange считывает следующие записи реестра, чтобы получить список процессов, которые были исключены из антивирусного сканирования в режиме реального времени, выполняемого на уровне файлов программой eTrust Antivirus, разработанной компанией Computer Associates:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\RealTime\szExcludeProcessNames

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeProcessNames

Если анализатор сервера Exchange обнаруживает, что значение szExcludeProcessNames не содержит STORE.EXE, EMSMTA.EXE и MAD.EXE, отображается предупреждение.

Рекомендуется не сканировать процесс банка данных Microsoft Exchange (Store.exe), процесс агента передачи сообщений Exchange (Emsmta.exe) и процесс системного помощника (Mad.exe) антивирусным сканнером файлов во время выполнения этих процессов.

Программа eTrust Antivirus является программой антивирусного сканирования на уровне файлов. Чтобы определить версию программы eTrust Antivirus, установленной на компьютере с сервером Exchange Server, выполните следующие действия:

  1. Последовательно выберите Пуск | Программы | eTrust Antivirus, а затем щелкните eTrust Antivirus, чтобы запустить приложение.

  2. В меню eTrust Antivirus последовательно выберите Справка и About eTrust Antivirus (О программе eTrust Antivirus).

  3. В поле Product Version (Версия продукта) указана версия программы eTrust Antivirus.

При выполнении антивирусного сканирования на уровне файлов на компьютере с Exchange Server могут встретиться следующие затруднения:

  • В процессе антивирусного сканирования на уровне файлов обработка файла происходит в то время, когда он используется или когда его использование попадает в запланированный интервал. В результате файл журнала Exchange или базы данных может быть заблокирован или помещен в карантин, в то время как Exchange пытается использовать этот файл. Это может вызвать серьезный сбой сервера Exchange Server, а также привести к ошибкам в работе базы данных.

  • Неполадки могут также возникнуть при сканировании диска, представленного файловой системой IFS (обычно диск M), с использованием программного обеспечения сканирования на уровне файлов.

Независимо от того, какая программа используется для антивирусного сканирования на уровне файлов, следует всегда исключать сканирование следующих файлов и папок:

  • Файлов с расширениями EML, EDB, STM, LOG, DAT и CHK.

  • Диска Exchange Server, представленного системой IFS. По умолчанию это диск M.

  • Файлов баз данных Exchange и журналов. По умолчанию они расположены в папке Exchsrvr\Mdbdata.

  • Файлов агента передачи сообщений Exchange в папке Exchsrvr\Mtadata.

  • Дополнительных файлов журналов, таких как файл Exchsrvr\имя_сервера.log.

  • Папки виртуального сервера Exchsrvr\Mailroot.

  • Рабочей папки, используемой для хранения временных потоковых файлов, используемых для преобразования сообщений. По умолчанию эта папка расположена в папке \Exchsrvr\MDBData, но ее местоположение можно изменить.

  • Временной папки, используемой средствами автономного обслуживания, такими как Eseutil.exe. По умолчанию эта папка находится в той же папке, из которой вызываются EXE-файлы, но при запуске этого средства местоположение временной папки можно изменить.

  • Файлов службы репликации сайта, находящихся в папке Exchsrvr\Srsdata.

  • Системных файлов служб IIS, находящихся в папке %SystemRoot%\System32\Inetsrv.

  • Рабочих файлов службы IIS, находящихся в папке %SystemRoot%\IIS Temporary Compressed Files.

Чтобы устранить причину появления этого предупреждения

  1. С помощью пользовательского интерфейса программы eTrust Antivirus исключите перечисленные выше папки и файлы из области антивирусного сканирования на уровне файлов.

  2. Самые последние сведения об использовании программы eTrust Antivirus на компьютерах Exchange Server можно получить на веб-узле Computer Associates eTrust Antivirus (http://www3.ca.com/Solutions/Product.asp?ID=156).

    Примечание.
    Веб-адреса могут измениться, поэтому существует вероятность, что вам не удастся подключиться к упомянутым здесь веб-узлам.

Дополнительные сведения об использовании антивирусного программного обеспечения совместно с сервером Exchange Server см. в следующих статьях базы знаний корпорации Майкрософт:

  • 328841, посвященная Exchange и антивирусном программном обеспечении (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841);

  • статья 823166, содержащая обзор Exchange и антивирусного программного обеспечения (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166);

  • статья 306105, посвященная отношению корпорации Майкрософт к антивирусному программному обеспечению для Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105);

  • статья 245822, содержащая рекомендации по исправлению неполадок при использовании Exchange на компьютерах с установленной антивирусной защитой (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Список антивирусного программного обеспечения сторонних разработчиков для сервера Exchange см. на веб-узле, посвященном партнерам Exchange по антивирусному программному обеспечению (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=16226).

Дополнительные сведения о неполадках, которые могут возникнуть при сканировании IFS-диска, см. в следующих статьях базы знаний:

  • статья 298924, посвященная рекомендации не выполнять ни архивирования, ни антивирусного сканирования диска M сервера Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924);

  • статья 300608, посвященная сообщению об ошибке C1041737 при подключении базы данных (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608);

  • статья 299046, посвященная исчезновению элементов календаря из пользовательских папок (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


Доступно обновление службы Client Service Messaging Security для SMB версии 2.0
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2006-02-13

Средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\SOFTWARE\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Значение Version равное 6.2100 указывает, что установлена служба Trend Micro ScanMail Client Service Messaging Security для SMB версии 2.0.

Средство анализатора сервера Microsoft® Exchange также опрашивает WMI-класс CIM_Datafile, чтобы определить установленную версию службы Client Service Messaging Security для SMB версии 2.0. Если номер основной сборки меньше 1145, анализатор сервера Exchange отобразит предупреждение.

Это предупреждение указывает, что служба Client Server Messaging Security для SMB версии 2.0 установлена на сервере Exchange и доступно рекомендуемое обновление программного обеспечения. Рекомендуемое обновление — это исправление 2 службы Client Server Messaging Security для SMB v2.0 для компонента обмена сообщениями. Это обновление настоятельно рекомендуется и может улучшить общую производительность и надежность сервера.

Чтобы устранить причину появления этого предупреждения

  1. Посетите центр загрузки Trend Micro для службы Client Server Messaging Security для SMB (может быть на английском языке) (http://www.trendmicro.com/download/product.asp?productid=39).

  2. Загрузите и установите исправление 2.
Примечание.
Сведения о веб-узлах сторонних компаний в этом разделе предоставлены для оказания помощи в нахождении необходимой технической информации. URL-адреса могут быть изменены без предварительного уведомления.

Дополнительные сведения об обновлениях продуктов Trend Micro см. на веб-узле центра обновлений Trend Micro (может быть на английском языке) (http://www.trendmicro.com/download/).

Дополнительные сведения об использовании антивирусного программного обеспечения совместно с сервером Exchange Server см. в статьях базы знаний корпорации Майкрософт:

  • статья 328841, посвященная Exchange и антивирусному программному обеспечению (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841);

  • статья 823166, содержащая обзор Exchange Server 2003 и антивирусного программного обеспечения (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166);

  • статья 306105, посвященная отношению корпорации Майкрософт к антивирусному программному обеспечению для Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105);

  • статья 245822, содержащая рекомендации по исправлению неполадок при использовании Exchange на компьютерах с установленной антивирусной защитой (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Список стороннего антивирусного программного обеспечения см. на веб-узле, посвященном партнерам Exchange по антивирусному программному обеспечению (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=16226).


Рекомендуется установить HP Command View EVAPerf
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-12-09

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_SCSIController, чтобы определить значение ключа Name. Если значением ключа Name является Compaq HSV110CCL, то по крайней мере один дисковый том на сервере представлен сетью областей хранения HP EVA.

Анализатор сервера Exchange также запрашивает WMI-класс Win32_Service, чтобы определить значение ключа Started службы HP StorageWorks Command View EVAPerf (EVSPDCS). Значение False указывает, что служба не выполняется. Значение True указывает, что служба выполняется.

Анализатор сервера Exchange выводит на экран рекомендацию, если выполняются следующие два условия:

  • По крайней мере один дисковый том на сервере представлен сетью областей хранения HP EVA.

  • Служба HP StorageWorks Command View EVAPerf (EVSPDCS) отсутствует или не запущена.

Компания HP бесплатно предоставляет программное приложение управления, которое публикует дополнительные счетчики производительности для служб областей хранения HP StorageWorks. Администраторы могут применять это программное приложение управления для отслеживания производительности отдельных контроллеров и физических дисков в сетях областей хранения.

Чтобы выполнить приведенную рекомендацию

  1. Перейдите на веб-узел HP StorageWorks Command View EVAPerf Software, чтобы загрузить приложение HP Command View EVAPerf (http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?pnameOID=471498&locale=en_US&taskId=135&prodSeriesId=471497&prodTypeId=12169&swEnvOID=1005).

    Примечание.
    Сведения о веб-узлах сторонних компаний предоставлены для оказания помощи в поиске необходимой технической информации. URL-адреса могут быть изменены без предварительного уведомления.

  2. Запустите загруженный самораскрывающийся EXE-файл и следуйте инструкциям по установке приложения.


Служба EMC PowerPath Service остановлена
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Exchange также опрашивает WMI-класс Win32_Service, чтобы определить значение раздела Started для службы EMC PowerPath Service. Значение True означает, что служба EMC PowerPath Service запущена. Значение False означает, что служба не запущена. Если анализатор сервера Exchange обнаружит, что значением раздела реестра Started является False, отображается предупреждение.

EMC PowerPath является программным обеспечением многопутевого ввода и вывода. Многопутевой ввод и вывод обеспечивает высокодоступный доступ к данным, разрешая узлу иметь до 32 путей доступа к внешнему устройству хранения, что упрощает переход на другой ресурс при сбое и балансировку нагрузки. Многопутевой ввод и вывод не является функцией операционной системы, он поддерживается в пакете разработки драйверов многопутевого ввода и вывода, который обеспечивает производителям устройств хранения средства для создания взаимодействующих решений многопутевого ввода и вывода.

При работе программного обеспечения многопутевого ввода и вывода, Microsoft Windows® обнаруживает только один драйвер, в то время как программное обеспечение многопутевого ввода и вывода управляет несколькими подключениями к различным устройствам хранения. Если программное обеспечение многопутевого ввода и вывода не выполняется, Windows обнаружит все подключенные устройства хранения в виде независимых дисков. Это может привести к ошибкам в хранилищах и сбоям.

Чтобы запустить службу EMC PowerPath Service

  1. Откройте оснастку «Службы» консоли MMC.

  2. Щелкните правой кнопкой мыши службу EMC PowerPath Service и в контекстном меню выберите Свойства.

  3. Убедитесь, что на вкладке Общие страницы свойств EMC PowerPath Service Тип запуска выставлен как Авто. Если нет, нажмите кнопку Применить, затем ОК.

  4. Щелкните правой кнопкой мыши службу EMC PowerPath Service и в контекстном меню выберите Пуск.

  5. Закройте оснастку «Службы».

Общие сведения о развертывании различных технологий хранения в Windows см. на веб-странице, посвященной использованию функций хранения в Windows с помощью сетей SAN (может быть на английском языке (http://go.microsoft.com/fwlink/?LinkId=33626).


EMC PowerPath Version Mismatch Between Cluster Nodes
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2007-07-25

Для определения версии EMC PowerPath, установленной на каждом узле кластера, анализатор Microsoft Exchange считывает следующий параметр реестра:

HKEY_LOCAL_MACHINE\SOFTWARE\EMC\PowerPath\Version

Если анализатор Exchange обнаруживает, что значение параметра Version для второго или последующего узла кластера Exchange отличается от значения параметра Version для первого узла кластера, выводится сообщение об ошибке.

Эта ошибка указывает на то, что на узлах данного кластера Exchange запущены разные версии драйвера EMC PowerPath. Рекомендуется использовать на всех узлах кластера Exchange одну версию драйвера EMC PowerPath.

EMC PowerPath представляет собой программу многопутевого ввода-вывода (MPIO). Использование многопутевого ввода-вывода обеспечивает высокий уровень доступности данных, предоставляя узлу до 32 путей для доступа к внешнему устройству хранения, что упрощает переход на другой ресурс при сбое и балансировку нагрузки. Многопутевой ввод-вывод не является возможностью операционной системы, его поддержка обеспечивается пакетом разработки драйверов (DDK) MPIO, который предоставляет производителям устройств хранения средства создания решений для многопутевого ввода-вывода.

Если в Microsoft Windows работает программное обеспечение многопутевого ввода-вывода, операционная система обнаруживает только один диск, в то время как это программное обеспечение использует несколько подключений к различным устройствам хранения. Если на узлах кластера установлены разные версии драйвера MPIO, это может привести к проблемам с переходом на другой ресурс при сбое.

Чтобы устранить эту проблему, необходимо установить на всех узлах одинаковые версии драйвера EMC PowerPath.

Дополнительные сведения

Дополнительные сведения о развертывании в операционной системе Windows различных технологий хранения данных см. в статье «Планирование использования функций хранения Windows с сетями хранения данных» (http://go.microsoft.com/fwlink/?LinkId=33626) (на английском языке).


Драйвер FC-порта Emulex не обновлялся более двух лет
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2006-04-19

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_SCSIController, чтобы определить, установлено ли значение для ключа DriverName. Средство анализатора сервера Exchange определяет, выполняются ли следующие условия:

  • На сервере Exchange установлен драйвер FC-порта Emulex.

  • На сервере Exchange установлена текущая версия драйвера FC-порта Emulex.

  • Драйвер FC-порта Emulex обновлялся в течение последних двух лет.

Если анализатор сервера Exchange обнаруживает, что значение ключа DriverName не обновлялось свыше двух лет, анализатор сервера Exchange выводит предупреждение.

Драйвер FC-порта Emulex предоставляет только функции SCSI или одновременно функции SCSI и IP для одного или нескольких адаптеров шины. Драйвер FC-порта поддерживает топологии FC-AL (Fibre Channel arbitrated loop), топологии точка-точка и топологии фабрики. Драйвер FC-порта предназначен для специализированных приложений, которым требуется сопоставление или постоянное связывание номеров логических устройств (LUN) на основе компьютера.

Чтобы обновить драйвер FC-порта Emulex, см. раздел Загружаемые файлы и руководства для Windows по адресу http://www.emulex.com/ts/docfc/winframe.htm (возможно, на английском языке). Если нужны специальные драйверы ПВТ, см. веб-узел программного обеспечения и документации Emulex по адресу http://www.emulex.com/ts/index.html (возможно, на английском языке).

Примечание.
Сведения о веб-узлах сторонних компаний в этом разделе предоставлены для оказания помощи в нахождении необходимой технической информации. URL-адреса могут быть изменены без предварительного уведомления.


Драйвер мини-порта Emulex SCSIport не обновлялся более двух лет
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2006-06-14

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс Win32_SCSIController, чтобы определить, установлено ли значение ключа DriverName. Средство анализатора сервера Exchange определяет, выполняются ли следующие условия:

  • На сервере Exchange установлен драйвер мини-порта Emulex SCSIport.

  • На сервере Exchange установлена текущая версия драйвера мини-порта Emulex SCSIport.

  • Драйвер мини-порта Emulex SCSIport обновлялся в течение последних двух лет.

Если анализатор сервера Exchange обнаруживает, что значение ключа DriverName не обновлялось свыше двух лет, анализатор сервера Exchange выводит предупреждение.

Драйвер мини-порта Emulex SCSIport обеспечивает функциональность SCSI поверх топологии Fibre Channel Arbitrated Loop (FC-AL), топологии «точка-точка» и топологии Fabric.

Получить сведения о том, как обновить драйвер мини-порта Emulex SCSIport, см. веб-страницу, посвященную загрузке файлов и руководствам для Windows по адресу http://www.emulex.com/ts/docfc/winframe.htm. Если нужны специальные ПВТ-драйверы, см. веб-узел программного обеспечения и документации для ПВТ по адресу http://www.emulex.com/ts/index.html.

Примечание.
Веб-адреса могут измениться, поэтому существует вероятность, что не удастся подключиться к упомянутым здесь веб-узлам.


Драйвер мини-порта Emulex Storport не обновлялся более двух лет
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2006-06-14

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_SCSIController, чтобы определить, установлено ли значение для ключа DriverName. Средство анализатора сервера Exchange определяет, выполняются ли следующие условия:

  • На сервере Exchange установлен драйвер мини-порта Emulex Storport.

  • На сервере Exchange установлена текущая версия драйвера мини-порта Emulex Storport.

  • Драйвер мини-порта Emulex Storport обновлялся в течение последних двух лет.

Если анализатор сервера Exchange обнаруживает, что значение ключа DriverName не обновлялось свыше двух лет, анализатор сервера Exchange выводит предупреждение.

Драйвер мини-порта Emulex Storport оптимизирует производительность и управляемость сетей областей хранения (SAN) и аппаратных дисковых массивов. Драйвер мини-порта Emulex Storport поддерживает топологии управляемой петли волоконно-оптического канала (FC-AL), двухточечные топологии и топологии фабрики.

Чтобы обновить драйвер мини-порта Emulex Storport, см. раздел Загружаемые файлы и руководства для Windows по адресу http://www.emulex.com/ts/docfc/winframe.htm (возможно, на английском языке). Если нужны специальные драйверы для ПВТ, см. веб-узел программного обеспечения и документации для ПВТ по адресу http://www.emulex.com/ts/index.html (возможно, на английском языке).

Примечание.
Веб-адреса могут измениться, поэтому существует вероятность, что вам не удастся подключиться к упомянутым здесь веб-узлам.


Высокая загрузка процессора процессом, который не относится к Exchange
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

  • Средством анализатора сервера Microsoft® Exchange обнаружен не относящийся к Exchange Server процесс, использующий более 20 процентов доступных ресурсов процессора сервера. Если не относящийся к серверу Exchange процесс использует больше 20 процентов доступных ресурсов процессора, отображается сообщение об ошибке.

  • Рекомендуется, чтобы серверы, на которых выполняется Exchange Server, были выделены исключительно для работы сервера Exchange и чтобы на этих серверах запускалось как можно меньше приложений и служб, не относящихся к Exchange.

Чтобы устранить эту ошибку

  • Если другой процесс использует большую часть ресурсов процессора, воспользуйтесь одним из следующих способов:

    • Отключите процесс и посмотрите, приведет ли это к устранению неполадки.

    • Если есть возможность, перенесите процесс на другой сервер.

    • Убедитесь, что процесс правильно настроен, и выполните поиск обновлений от корпорации Майкрософт и поставщика процесса, помогающих устранить эту неполадку.

    • Удалите процесс, если он не нужен.

  • Если не удается переместить или исправить процесс, необходимо выполнить повторное масштабирование сервера, чтобы учесть дополнительную нагрузку, создаваемую процессом, не относящимся к серверу Exchange. В рамках такого повторного масштабирования следует рассмотреть возможность перемещения пользователей на другой сервер Exchange.


Служба HP/Compaq Secure Path остановлена
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс Win32_Service, чтобы определить, выполняется ли служба HP/Compaq Secure Path. Если анализатор сервера Exchange обнаружит, что служба HP/Compaq Secure Path, на экран будет выведено предупреждение.

Служба HP/Compaq Secure Path является программным обеспечением многопутевого ввода и вывода. Многопутевой ввод и вывод обеспечивает высокодоступный доступ к данным, разрешая узлу иметь до 32 путей доступа к внешнему устройству хранения, что упрощает переход на другой ресурс при сбое и балансировку нагрузки. Многопутевой ввод и вывод не является функцией операционной системы, он поддерживается в пакете разработки драйверов многопутевого ввода и вывода, который обеспечивает производителям устройств хранения средства для создания взаимодействующих решений многопутевого ввода и вывода.

При работе программного обеспечения многопутевого ввода и вывода, операционная система Windows обнаруживает только один драйвер, в то время как программное обеспечение многопутевого ввода и вывода управляет несколькими подключениями к различным устройствам хранения. Если программное обеспечение многопутевого ввода и вывода не выполняется, Windows обнаружит все подключенные устройства хранения в виде независимых дисков. Это может привести к ошибкам в хранилищах и сбоям.

Чтобы устранить причину появления этого предупреждения

  1. Откройте оснастку «Службы» консоли MMC.

  2. Щелкните правой кнопкой мыши службу HP/Compaq Secure Path и в контекстном меню выберите Свойства.

  3. Убедитесь, что на вкладке Общие страницы свойств службы HP/Compaq Secure Path Тип запуска выставлен как Авто. Если нет, нажмите кнопку Применить, затем ОК.

  4. Щелкните правой кнопкой мыши службу HP/Compaq Secure Path и в контекстном меню выберите Пуск.

  5. Закройте оснастку «Службы».

Общие сведения о развертывании различных технологий хранения в Windows см. на веб-странице, посвященной использованию функций хранения в Windows с помощью сетей SAN (может быть на английском языке (http://go.microsoft.com/fwlink/?linkid=33626).


Влияние программного обеспечения сторонних разработчиков
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange обнаружило, что на сервере Exchange выполняется программное обеспечение сторонних разработчиков. Использование этого программного обеспечения может быть причиной снижения производительности сервера. Программное обеспечение сторонних разработчиков может включать среди прочего следующие продукты:

  • Антивирусные программы уровня файлов

  • Антивирусные программы для электронной почты с поддержкой Exchange

  • Программы для борьбы с нежелательной почтой

  • Программное обеспечение факс-сервера

  • Внешний соединитель для почтовой системы или системы совместной работы

  • Службы файлов и печати

  • Соединители для мобильных устройств

Чтобы устранить эту ошибку

  • Если у вас есть подозрение, что программное обеспечение сторонних разработчиков снижает производительность Exchange Server, удалите или отключите это программное обеспечение и проверьте производительность Exchange Server.

  • Если программное обеспечение сторонних разработчиков необходимо на сервере, но при этом снижает его производительность, рассмотрите возможность выделения дополнительного сервера для распределения нагрузки.

Дополнительные сведения

  • Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Дополнительные сведения об устранении проблем, связанных с производительностью сервера Exchange, см. на веб-узле, посвященном устранению неполадок, связанных с производительностью сервера Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).


Доступно обновление версии INO_FLPY.SYS
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить версию драйвера Ino_flpy.sys антивирусного фильтра компании Computer Associates.

Анализатор сервера Exchange опрашивает WMI-класс CIM_Datafile, чтобы определить значение ключа «Version» для Ino_flpy.sys и на основании номера версии сборки узнать, необходимо ли обновление программного обеспечения. Если значение ключа «Version» указывает, что для файла Ino_flpy.sys номер версии меньше 5.00.6100.109, на экран будет выведено предупреждение.

Номер версии меньше 5.00.6100.109 указывает, что на компьютере сервера Exchange не установлена последняя версия файла Ino_flpy.sys, и требуется установить более свежую версию драйвера фильтра. Обновление антивирусного программного обеспечения для файла Ino_flpy.sys можно найти на веб-узле компании Computer Associates. Настоятельно рекомендуется установить это обновление антивирусного программного обеспечения, поскольку оно может улучшить общую производительность и надежность компьютера сервера Exchange.

Когда на компьютере с работающим приложением Exchange 2000 Server или Exchange Server 2003 устанавливаются антивирусные программы Inoculan Computer Associates eTrust Antivirus версии 6.x или 7.x и InoculateIT версии 6.x, программа установки копирует файлы драйверов Ino_flpy.sys и Ino_fltr.sys антивирусного фильтра в папку «%systemroot%\system32\drivers». Файлы драйверов антивирусного фильтра — это драйверы, работающие в режиме ядра Windows NT®, которые используются для запуска требуемых антивирусных служб. Старые версии драйверов фильтра могут быть причиной получения неожиданных результатов на компьютере сервера Exchange.

Чтобы устранить причину появления этого предупреждения

  1. Последние обновления антивирусного программного обеспечения для файла ino_flpy.sys, можно получить на веб-узле компании Computer Associates (http://supportconnectw.ca.com/premium/antivirus/downloads/nt/4.5/ildrvupdate.asp).

  2. Загрузите соответствующую обновленную версию программы eTrust или InoculateIT.

  3. Создайте полную резервную копию содержимого компьютера сервера Exchange, включая резервную копию файла Ino_flpy.sys.

  4. Установите последнее обновление для eTrust или InoculateIT.
Примечание.
Веб-адреса могут измениться, поэтому существует вероятность, что указанные веб-узлы будут недоступны.

Дополнительные сведения об использовании антивирусного программного обеспечения совместно с сервером Exchange см. в следующих статьях базы знаний Майкрософт:

  • статья 240309, содержащая инструкции по полному отключению фильтрации файлов антивирусным программным обеспечением (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240309);

  • статья 328841, посвященная Exchange и антивирусному программному обеспечению (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841);

  • статья 823166, содержащая обзор Exchange и антивирусного программного обеспечения (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166);

  • статья 306105, посвященная отношению корпорации Майкрософт к антивирусному программному обеспечению для Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105);

  • статья 245822, содержащая рекомендации по исправлению неполадок при использовании Exchange на компьютерах с установленной антивирусной защитой (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Список стороннего антивирусного программного обеспечения, доступного для сервера Exchange, см. на веб-узле, посвященном партнерам по антивирусному программному обеспечению для сервера Exchange (http://go.microsoft.com/fwlink/?linkid=16226).


Доступно обновление версии для INO_FLTR.SYS
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс CIM_Datafile, чтобы определить номер версию драйвера фильтра Computer Associates Ino_fltr.sys.

Анализатор сервера Exchange опрашивает WMI-класс CIM_Datafile, чтобы определить значения ключа версии для Ino_fltr.sys и, основываясь на номере версии сборки, может потребоваться обновление программного обеспечения. Если значение ключа версии указывает, что номер версии ниже 5.00.6100.142 для файла Ino_fltr.sys file, отображается в предупреждение.

Номер версии менее 5.00.6100.142 указывает, что самая последняя версия файла Ino_fltr.sys не установлена на компьютере сервера Exchange и необходимо установить более новую версию драйвера фильтра. Обновление антивирусного программного обеспечения для файла Ino_fltr.sys можно найти на веб-узле Computer Associates. Это обновление антивирусного программного обеспечения настоятельно рекомендуется и может улучшить общую производительность и надежность сервера Exchange.

Если антивирусные программы Inoculan Computer Associates eTrust Antivirus версии 6.x или 7.x и InoculateIT версии 6.x установлены на компьютерах Exchange 2000 Server или Exchange Server 2003, программа установки копирует файлы антивирусного драйвера фильтра Ino_flpy.sys и Ino_fltr.sys в папку %systemroot%\system32\drivers. Файлы антивирусного драйвера фильтра являются драйверами режима ядра Windows NT®, которые используются для запуска требуемых антивирусных служб. Старые версии драйверов фильтра может привести к неожиданным результатам на компьютере сервера Exchange.

Чтобы устранить причину появления этого предупреждения

  1. Чтобы получить самые последние обновления антивирусного программного обеспечения для файла Ino_fltr.sys file, посетите веб-узел Computer Associates: (http://supportconnectw.ca.com/premium/antivirus/downloads/nt/4.5/ildrvupdate.asp).

  2. Загрузите необходимую обновленную версию eTrust или InoculateIT.

  3. Создайте полную резервную копию компьютера сервера Exchange, включая резервную копию файла Ino_fltr.sys.

  4. Установите самое последнее обновление программного обеспечения eTrust или InoculateIT.
Примечание.
Веб-адреса могут измениться, поэтому существует вероятность, что не удастся подключиться к упомянутым здесь веб-узлам.

Дополнительные сведения об использовании антивирусного программного обеспечения совместно с сервером Exchange Server см. в статьях базы знаний корпорации Майкрософт:

  • статья 240309, посвященная инструкциям по полному отключению антивирусного программного обеспечения от файлов фильтрации (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240309);

  • статья 328841, посвященная Exchange и антивирусному программному обеспечению (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841);

  • статья 823166, содержащая обзор Exchange и антивирусного программного обеспечения (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166);

  • статья 306105, посвященная отношению корпорации Майкрософт к антивирусному программному обеспечению для Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105);

  • статья 245822, содержащая рекомендации по исправлению неполадок при использовании Exchange на компьютерах с установленной антивирусной защитой (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Список стороннего антивирусного программного обеспечения см. на веб-узле, посвященном партнерам Exchange по антивирусному программному обеспечению (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=16226).


Доступны обновления для программы Exchange McAfee GroupShield 5.2 для Microsoft Exchange
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2006-04-19

Средство анализа сервера Microsoft® Exchange считывает следующее значение реестра, чтобы определить, зарегистрирован ли файл библиотеки VSAPI службой хранения информации Microsoft Exchange Information Store:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Если на сервере Exchange 2000 или Exchange 2003 установлен McAfee GroupShield 5.2 для Microsoft Exchange, запись реестра библиотеки имеет значение GSEVS2.DLL. Файл библиотеки выполняет ряд функций, связанных с VSAPI, в GroupShield 5.2 для Microsoft Exchange.

Средство анализа сервера Exchange также запрашивает класс CIM_Datafile инструментария Microsoft Windows® Management Instrumentation (WMI) для определения значения раздела Version для GSEVS2.DLL. Если значение параметра Version указывает, что для данного файла номер сборки меньше 682, отображается сообщение об ошибке.

Номер версии менее 682 для GSEVS2.DLL означает, что не установлена новейшая версия GroupShield 5.2 для Microsoft Exchange. Обновление программного обеспечения доступно для GroupShield 5.2 для Microsoft Exchange на веб-узле McAfee. Настоятельно рекомендуется установить это обновление. Оно может повысить общую производительность и надежность. Кроме того, обновление GroupShield для Microsoft Exchange 5.2.682 позволяет гарантировать, что используются новейшие версии важных файлов DLL. Использование новейшей версии gsevs2.dll значительно повысило производительность и надежность развернутых систем обмена сообщениями Exchange Server.

Чтобы исправить это предупреждение, выполните следующие действия

  1. Чтобы определить, какая версия GroupShield 5.2 для сервера Microsoft Exchange является новейшей, посетите страницу Guided Knowledge Search (Направляемый поиск сведений) на веб-узле McAfee (http://knowledgemap.nai.com/). Перечисленные ниже и другие статьи McAfee Solutions KnowledgeBase (базы знаний о решениях McAfee) на этой странице помогут определить новейшую версию:

    • Код решения KB40567, «Как получить новейшую версию GroupShield и/или SpamKiller»

    • Код решения ID KB nai18117, «Информация о версии продукта GroupShield для Exchange 2000»

  2. Посетите веб-узел McAfee (https://secure.nai.com/us/forms/downloads/upgrades/login.asp).

  3. Загрузите новейшее обновление для вашей версии GroupShield 5.2 для сервера Microsoft Exchange.

  4. Сделайте полную резервную копию всех данных компьютера с сервером Exchange.

  5. Установите новейшее обновление для GroupShield 5.2 для сервера Microsoft Exchange.
Примечание.
Сведения о веб-узлах сторонних производителей в этом разделе предоставлены для справки при поиске необходимых технических сведений. URL-адреса могут быть изменены без предварительного уведомления.

Для получения дополнительных сведений об использовании антивирусного программного обеспечения с сервером Exchange см. следующие статьи базы знаний Майкософт:

  • 328841, «Exchange и антивирусное программное обеспечение» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, «Обзор сервера Exchange 2003 и антивирусного программного обеспечения» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, «XGEN: Отношение Майкрософт к антивирусным решениям для Exchange 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, «Рекомендации по устранению неполадок компьютера с сервером Exchange, на котором установлено антивирусное программное обеспечение» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Для получения списка антивирусного программного обсепечения других производителей для сервера Exchange см. перечень партнеров по продукту Exchange Server: Веб-узел антивирусного программного обеспечения (http://go.microsoft.com/fwlink/?linkid=16226)


Доступно обновление для McAfee GroupShield 6.0 for Microsoft Exchange
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange считывает следующий параметр реестра, чтобы определить, зарегистрирован ли в службе банков данных Microsoft Exchange файл библиотеки интерфейса программирования приложений антивирусного сканирования (VSAPI):

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Если в Exchange 2000 Server или Exchange Server 2003 установлено приложение McAfee GroupShield 6.0 for Microsoft Exchange, запись реестра «Library» будет содержать значение VSAPISCANSOURCE.DLL. Этот файл библиотеки позволяет выполнять ряд относящихся к VSAPI функций в GroupShield 6.0 for Microsoft Exchange.

Анализатор сервера Exchange также запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение, установленное для ключа Version для VSAPISCANSOURCE.DLL. Если значение ключа Version указывает, что номер сборки для этого файла менее 6.0.1148.0, выводится предупреждение.

Номер версии менее 6.0.1148.0 для VSAPISCANSOURCE.DLL указывает, что последняя версия GroupShield 6.0 for Microsoft Exchange не установлена. На веб-узле компании McAfee доступно обновление для GroupShield 6.0 for Microsoft Exchange. Насоятельно рекомендуется выполнить установку этого обновления — это улучшит общую производительность и надежность работы.

Чтобы устранить причину появления этого предупреждения

  1. Чтобы определить последнюю версию GroupShield 6.0 for Microsoft Exchange, посетите страницу поиска по базе знаний веб-узла McAfee (http://knowledgemap.nai.com/). Определите последнии версию с помощью следующих статей по решениям McAfee, а также других таких статей:

    • 0Решение ID nai18117 «Product Version Information for GroupShield for Exchange 2000» (Сведения о версии продукта для GroupShield for Exchange 2000)

    • Решение ID KB37636, «Version numbers for McAfee GroupShield 6.x for Microsoft Exchange» (Номера версий для McAfee GroupShield 6.x for Microsoft Exchange)

    • Solution ID KB40567, «Getting the latest version of GroupShield and/or SpamKiller» (Получение последней версии GroupShield и SpamKiller)

  2. Посетите страницу загрузки продуктов на веб-узле McAfee (https://secure.nai.com/us/forms/downloads/upgrades/login.asp).

  3. Загрузите последнюю версию GroupShield 6.0 for Microsoft Exchange.

  4. Выполните полное резервное копирование компьютера Exchange Server.

  5. Установите последнее обновление для GroupShield 6.0 for Microsoft Exchange.
Примечание.
Сведения о веб-узлах сторонних компаний в этом разделе предоставлены для оказания помощи в нахождении необходимой технической информации. URL-адреса могут быть изменены без предварительного уведомления.

Дополнительные сведения об использовании антивирусного программного обеспечения совместно с сервером Exchange Server см. в статьях базы знаний корпорации Майкрософт:

  • 328841, «Exchange and antivirus software» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841) (Exchange и антивирусное программное обеспечение)

  • 823166, «Overview of Exchange Server 2003 and antivirus software» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166) (Общие сведения об Exchange и антивирусном программном обеспечении)

  • 306105, «XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105) (Позиция корпорации Майкрософт в отношении антивирусного программного обеспечения для Exchange 2000)

  • 245822, «Recommendations for troubleshooting an Exchange computer with antivirus software installed» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822) (Рекомендации по устранению неполадок в работе Exchange на компьютерах с установленной защитой от вирусов)

Список антивирусного программного обеспечения независимых производителей см. на веб-узле, посвященном партнерам Exchange — разработчикам антивирусного программного обеспечения (http://go.microsoft.com/fwlink/?LinkId=16226).


Служба McAfee GroupShield установлена на этом сервере Exchange, ее работа остановлена
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Service, чтобы определить, установлена ли служба McAfee GroupShield и выполняется ли она на компьютере, работающем под управлением Exchange.

Анализатор сервера Exchange также запрашивает WMI-класс Win32_Service, чтобы определить, какое значение задано для параметра Started в службе «Банк данных Microsoft Exchange»: True или False.

Значение False указывает, что служба банка данных не выполняется на компьютере, работающим под управлением сервера Exchange. Значение True показывает, что служба банка данных Microsoft Exchange работает.

Если анализатор сервера Exchange обнаруживает, что служба банка данных Microsoft Exchange выполняется, а служба McAfee GroupShield установлена, но не запущена, отображается предупреждение.

Служба McAfee GroupShield обеспечивает защиту от вирусов для Exchange. Ниже перечислены некоторые причины, по которым могла быть остановлена служба McAfee GroupShield, а также решения для их устранения.

  • На сервере Exchange может выполняться пробная версия программного обеспечения, срок действия которой истек. В этом случае может понадобиться переустановить службу McAfee GroupShield. Чтобы можно было продолжить использование программного обеспечения, необходимо по крайней мере активизировать его.

  • Администратор мог ненамеренно остановить службу McAfee GroupShield Убедитесь, что служба настроена для автоматического запуска, а затем запустите ее.

  • Червь, вирус или другая программа могла остановить службу. Убедитесь, что служба настроена для автоматического запуска, а затем запустите ее. Если служба продолжает неожиданно останавливаться без выдачи сообщений об ошибке, убедитесь, что компьютер не заражен, и при необходимости выполните дезинфекцию системы.

Корпорация Майкрософт обычно рекомендует развертывать антивирусное программное обеспечение, разработанное для систем обмена сообщениями либо на SMTP-шлюзе, либо на серверах Exchange, где расположены почтовые ящики. Чтобы обеспечить наибольшую безопасность, запускайте антивирусное программное обеспечение на шлюзе, который будет обрабатывать все входящие сообщения MIME, и антивирусный сканер на сервере Exchange, использующем VSAPI 2.5.

Чтобы запустить службу McAfee GroupShield

  1. Откройте оснастку «Службы» консоли MMC.

  2. Щелкните правой кнопкой мыши службу McAfee GroupShield, а затем выберите Свойства.

  3. На вкладке Общие страницы свойств службы McAfee GroupShield убедитесь, что на вкладке Тип запуска выбрано Авто. Если нет, нажмите кнопку Применить, затем кнопку ОК.

  4. Щелкните правой кнопкой мыши службу McAfee GroupShield, а затем выберите Пуск.

  5. Закройте оснастку «Службы».

Кроме того, следует установить клиентское антивирусное программное обеспечение на настольных компьютерах. Если на уровне шлюза или сервера Exchange установлено антивирусное программное обеспечение, предназначенное для систем обмена сообщениями (такое программное обеспечение способно анализировать и сканировать содержимое MIME), то в настольной системе достаточно использовать сканер уровня файлов.

  • Дополнительные сведения о разных видах антивирусных программ, обычно используемых с Microsoft Exchange Server 2003, см. в статье 823166 базы знаний Майкрософт, описывающей антивирусное программное обеспечение для Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

  • Дополнительные сведения о разных видах антивирусных программ, обычно используемых с Microsoft Exchange 2000 Server, см. в статье 328841 базы знаний Майкрософт, описывающей антивирусное программное обеспечение для Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

  • Дополнительные сведения об укреплении защиты среды Exchange от вирусов и червей, передающихся с помощью сообщений электронной почты, см. в разделе, посвященном замедлению и прекращений действия вирусов в электронной почте в среде Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=30732).


Установлен пакет Messageware Plus
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, установлен ли пакет Messageware Plus, анализатор сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\Software\Messageware Incorporated\Core Services\PlusPack\Load

Если анализатор сервера Exchange обнаруживает, что значение Load равно 1, анализатор сервера Exchange выводит на экран сообщение о нестандартной конфигурации.

Анализатор сервера Exchange сообщает об этой конфигурации только для сведения. Никаких действий выполнять не требуется.

Пакет Messageware Plus — это надстройка веб-клиента Microsoft Office Outlook® для сервера Exchange Server 2003, поставляемая компанией Messageware Incorporated. Пакет Messageware Plus расширяет и улучшает возможности веб-клиента Outlook Web Access для пользователей Outlook Web Access категорий Basic и Premium.

Дополнительные сведения о пакете Messageware Plus см. на веб-узле, посвященном комплекту Messageware OWA (http://www.messageware.com).

Примечание.
Веб-адреса могут измениться, поэтому существует вероятность, что вам не удастся подключиться к упомянутым здесь веб-узлам.


Совместимость предотвращения выполнения данных Microsoft Antigen
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2007-02-19

Для определения значения раздела Started службы Microsoft Antigen средство анализа Microsoft Exchange запрашивает класс WMI Win32_Service. Значение False указывает на то, что эта служба не запущена. Значение True указывает на то, что эта служба запущена.

Кроме того, средство анализа Exchange читает следующую запись реестра для определения того, установлен ли на сервере Exchange антивирусный сканер Касперского для Microsoft Antigen. Эта запись присутствует в реестре только в том случае, если антивирусный сканер Касперского установлен на сервере Exchange Server.

HKEY_LOCAL_MACHINE\Software\Sybari Software\Antigen for Exchange\Scan Engines\Kaspersky

Наконец, если сервер Exchange Server работает на компьютере с Microsoft Windows Server 2003 с пакетом обновления 1 (SP1) или более поздней версии, средство анализа Exchange запрашивает класс WMI Win32_ComputerSystem для определения того, содержит ли значение параметра SystemStartupOptions строку «/NOEXECUTE=OPTOUT» или «/NOEXECUTE=ALWAYSON». Это означает, что на сервере включен механизм предотвращения выполнения данных. Он представляет собой совокупность аппаратных и программных технологий, которые выполняют дополнительные виды проверки памяти, предотвращая выполнение вредоносного кода.

Если средство анализа Exchange обнаруживает, что выполнены приведенные ниже условия, на экран выводится предупреждение.

  • На сервере включена служба Microsoft Antigen.

  • Установлен антивирусный сканер Касперского для службы Antigen.

  • Сервер Exchange Server работает на компьютере с Microsoft Windows Server 2003 с пакетом обновления 1 (SP1) или более поздней версии.

  • На сервере включено предотвращение выполнения данных.

Это предупреждение свидетельствует о том, что при текущей конфигурации сервера возможно возникновение проблем с эффективностью обмена сообщениями и поиска вирусов.

Чтобы устранить причины данного предупреждения, выборочно отключите функцию предотвращения выполнения данных для отдельных программ, выполнив действия, указанные в статье 905952 базы знаний Майкрософт «Система обмена сообщениями в Antigen работает медленнее, чем ожидалось, а клиент Antigen прекращает реагировать на команды» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905952, на английском языке).

Дополнительные сведения

Дополнительные сведения о функции предотвращения выполнения данных см. в статье 875352 базы знаний Майкрософт «Подробное описание функции предотвращения выполнения данных, входящей в состав Windows XP с пакетом обновления 2 (SP2), Windows XP Tablet PC Edition 2005 и Windows Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=875352).


Установлена программа Double-Take корпорации NIS Software
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Service, чтобы определить значение ключа Started для службы Double-Take. Значение «True» указывает, что служба Double-Take выполняется на этом сервере Exchange. Если служба Double-Take обнаружена на сервере Exchange, анализатор сервера Exchange выводит на экран сообщение о конфигурации, отличной от конфигурации по умолчанию.

Анализатор сервера Exchange сообщает об этой конфигурации, отличной от конфигурации по умолчанию, исключительно в информационных целях. Никаких действий выполнять не требуется.

Программа Double-Take корпорации NSI Software копирует выбираемые пользователем файлы или полные тома с одного или нескольких серверов-источников на один или несколько серверов-получателей через стандартные сетевые подключения. Эти копии позволяют компаниям быстро восстанавливаться после аварии или остановов системы, при этом восстановление выполняется под руководством пользователя или автоматически.

Дополнительные сведения о программе Double-Take см. на веб-узле «Double-Take» (http://www.nsisoftware.com/pro/doubletake).

Примечание.
Веб-адреса могут измениться, поэтому существует вероятность, что вам не удастся подключиться к упомянутым здесь веб-узлам.

Double-Take — это программное обеспечение, предназначенное для репликации данных. Подробные сведения о репликации данных на нескольких узлах для приложений Exchange 2000 Server и Exchange Server 2003 см. в базе знаний Майкрософт в статье 895847, описывающей поддержку репликации данных на нескольких узлах для Exchange 2003 и Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895847).


Процесс, отличный от Exchange, потребляет более 20% процессорного времени
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2006-02-13

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные из счетчика %Processor Time (_Total) объекта быстродействия Processor для анализа данных о производительности.

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Существует узкое место в работе процессора.

  • Один или несколько процессов, отличных от Exchange, используют более 20 процентов общего усредненного процессорного времени сервера.

Анализатор сервера Exchange выводит на экран предупреждение, если выполняются следующие условия:

  • Существует узкое место в работе процессора.

  • Один или несколько процессов, отличных от Exchange, используют более 10 процентов общего усредненного процессорного времени сервера.

Счетчик производительности % Processor Time (_Total) объекта быстродействия Process предоставляет сведения об общем использовании ресурсов процессоров. Среднее значение использования ресурсов процессора должно всегда быть меньше 80 процентов. Более высокие средние значения указывают на существование узкого места в работе процессора. Наличие частых пиков, превышающих 90 процентов, на диаграмме потребления процессорного времени также указывает на существование узкого места в работе процессора.

Устранение узких мест в работе процессора

Существует несколько способов устранения узких мест в работе процессора на сервере Exchange.

  • Сначала проанализируйте приложения или задачи, которые создают нагрузку на сервер. Определите, должно ли приложение потреблять ресурсы процессора или, возможно, существуют проблемы с рабочим процессом.

  • Если приложение, отличное от Exchange, не важно для сервера, запустите это приложение на другом сервере. Если есть возможность, переместите также роли сервера на другие компьютеры. Например, если процесс Inetinfo потребляет значительные ресурсы процессора, рассмотрите возможность добавления серверов переднего плана для переноса на них работы протокола, выполняемой процессом Inetinfo. Можно также переместить средства доступа к общим папкам на выделенный сервер общих папок. Наконец, если сервер выполняет множество расширений списка рассылки, можно уменьшить нагрузку на процессор путем перемещения расширения списка рассылки на выделенный сервер расширений списка рассылки.

  • Если есть возможность, добавьте на сервер дополнительные или более быстрые процессоры. К тому же, включите многопоточность, если она поддерживается процессорами. Многопоточность можно включить путем настройки BIOS системы. Дополнительные сведения см. в справочной документации, предоставляемой поставщиком компьютера.

  • Если отсутствует возможность увеличения процессорной мощности, необходимо уменьшить нагрузку на процессоры. Чтобы уменьшить общую нагрузку на сервер, убедитесь, что задачи, активно потребляющие ресурсы системы ввода-вывода, процессора или памяти, выполняются вне интервала обычного рабочего времени.

  • Убедитесь, что задачи, активно потребляющие ресурсы процессора, такие как резервное копирование и обслуживание, приходятся на часы внепиковой нагрузки. Также проверьте, чтобы эти задачи выполнялись в несколько этапов. Поэтапное выполнение задач предполагает установку разных времен запуска и, желательно, разных времен окончания для каждой задачи. Поэтапное выполнение обслуживания и резервного копирования баз данных или групп хранения также снижает нагрузку, оказываемую этими ресурсоемкими задачами.

Дополнительные сведения

  • Дополнительные сведения об узких местах в работе процессора см. по ссылке Узкое место в работе процессора.

  • Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Дополнительные сведения об устранении проблем производительности сервера Exchange см. в описании процедур устранения неполадок, связанных с производительностью Microsoft Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Дополнительные сведения о переносе почтовых ящиков пользователей для снижения нагрузки на сервер см. по ссылке Перенос почтовых ящиков пользователей на другой сервер.


Потребление ресурсов процессора процессами, не относящимися к Exchange, составляет более 50%
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2006-02-13

В состав средства анализа Microsoft® Exchange Server включен механизм сбора данных о производительности, который опрашивает счетчики производительности компьютеров, где установлен Exchange 2000 Server или Exchange Server 2003. Механизм собирает данные со счетчика %Processor Time (_Total) объекта производительности Processor для анализа данных производительности.

Данный счетчик производительности % Processor Time (_Total) объекта производительности Process дает общие сведения о загрузке процессоров. В среднем загрузка ЦП должна быть меньше 80 процентов. Более высокие показатели говорят о наличии узкого места, связанного с процессором. Частые взлеты загруженности процессора выше 90 процентов также свидетельствуют об узком месте, связанном с процессором.

Если средство анализа Exchange Server обнаружит, что процесс, не относящийся к Exchange, использует более 50% общего среднего количества ресурсов ЦП сервера, даже если связанное с процессором узкое место фактически не обнаружено, будет выдано предупреждение.

Устранение потенциальных узких мест, связанных с процессором

Существует несколько способов устранения потенциальных узких мест, связанных с процессором, на сервере Exchange.

  • Во-первых, проверьте приложения и задания, вызывающие нагрузку на сервер. Определите, на самом ли деле приложение должно использовать ресурсы процессора, или, возможно, существует какая-то проблема, связанная с процессом.

  • Если приложение, не связанное с Exchange, не важно для этого сервера, запустите его на другом сервере. Если возможно, также перенесите на другие компьютеры роли сервера. Например, если процесс Inetinfo использует большое количество ресурсов ЦП, попробуйте добавить серверы переднего плана, которые возьмут на себя работу протокола, которую выполняет Inetinfo. Также можно перенести доступ к общим папкам на выделенный сервер общих папок. Наконец, если на сервере часто выполняются расширения списка рассылки, загрузку ЦП можно уменьшить, перенеся расширение списка рассылки на выделенный сервер.

  • Если возможно, установите на сервер дополнительные или более быстрые процессоры. Также можно включить технологию hyper-threading, если она поддерживается процессорами. Технологию hyper-threading можно включить в параметрах BIOS системы. Для получения дополнительных сведений см. справочную документацию производителя.

  • Если увеличение мощности процессора не подходит, нужно уменьшить нагрузку на процессоры. Чтобы сократить общее воздействие на сервер, обеспечьте выполнение заданий, требующих большого числа операций ввода/вывода, большого количества ресурсов ЦП или памяти, в нерабочее время.

  • Обеспечьте выполнение заданий, требующих больших затрат ресурсов ЦП, таких как резервное копирование и обслуживание, в часы минимальной загрузки. Кроме того, убедитесь, что эти задания выполняются поэтапно. Имеется в виду, что задания должны начинаться, а лучше и заканчиваться в разное время. Поэтапное выполнение обслуживания и резервного копирования баз данных или групп хранилищ также уменьшает воздействие ресурсоемких заданий.

Дополнительные сведения

  • Для получения дополнительных сведений об узких местах см. разделе Узкое место в работе процессора.

  • Для получения дополнительных сведений о производительности Exchange Server см. Руководство по производительности и масштабируемости Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Для получения дополнительных сведений об устранении неполадок, связанных с производительностью сервера Exchange, см. статью Устранение неполадок в работе Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Установлена старая версия HP/Compaq Secure Path
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-12-13

Средство анализатора сервера Microsoft® Exchange опрашивает WMI-класс Win32_Service, чтобы определить, установлена ли версия программного обеспечения HP/Compaq Secure Path на сервере Exchange. Если версия Secure Path не равна 3.7.2.540, отображается предупреждение.

Чтобы избежать появления этого предупреждения, установите программное обеспечение Secure Path. Обратитесь к поставщику программного обеспечения HP/Compaq за обновлениями этого программного обеспечения.

Дополнительные сведения об обновлениях программного обеспечения HP/Compaq Secure Path см. на веб-узле HP, посвященном HP StorageWorks Secure Path (может быть на английском языке) (http://h18006.www1.hp.com/products/sanworks/softwaredrivers/securepath/index.html).

Примечание.
Сведения о веб-узлах сторонних компаний в этом разделе предоставлены для оказания помощи в нахождении необходимой технической информации. URL-адреса могут быть изменены без предварительного уведомления.


Порт 25 заблокирован
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2006-10-06

Чтобы определить, установлено ли на компьютере с сервером Exchange средство McAfee VirusScan, средство анализа Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\Network Associates\TVD\VirusScan Enterprise\CurrentVersion

Чтобы определить конфигурацию блокировки портов продуктом VirusScan, анализатор сервера Exchange также запрашивает следующий раздел реестра:

HKLM\Software\Network Associates\TVD\Shared Components\On Access Scanner\BehaviourBlocking

Ключи в этом разделе используются для указания того, какие процессы и порты блокируются или разрешаются функцией On Access продукта VirusScan.

Затем средство анализа Microsoft® Exchange запрашивает у WMI-класса Win32_Service значение ключа Started для службы McAfee VirusScan, чтобы определить, запущена ли она на сервере Exchange.

Значение Ложь указывает, что служба McAfee VirusScan не работает на данном сервере Exchange. Значение Истина указывает, что служба McAfee VirusScan работает.

Средство анализа Exchange выводит на экран предупреждение, если выполняются следующие условия:

  • Служба McAfee VirusScan установлена и работает на сервере Exchange Server.

  • Для порта 25 применяется правило Prevent mass mailing worms from sending mail (Предотвращать массовую рассылку вирусами-червями сообщений электронной почты).

  • Служба протокола SMTP на сервере Exchange не исключена из блокирующего правила.

Это предупреждение означает, что приложение McAfee VirusScan настроено таким образом, что возможно блокирование передачи законного содержимого сервера Exchange Server через порт 25. Из-за этого могут возникнуть проблемы с передачей почты.

Устранение этой проблемы

  • Рассмотрите возможность отключения правила Prevent mass mailing worms from sending mail (Предотвращать массовую рассылку вирусами-червями сообщений электронной почты).

  • ?Добавьте службу протокола SMTP на сервере Exchange Server в список исключений для правила Prevent mass mailing worms from sending mail (Предотвращать массовую рассылку вирусами-червями сообщений электронной почты).

Дополнительные сведения

  • Дополнительные сведения о настройке приложения McAfee VirusScan для работы с сервером Microsoft Exchange см. на веб-портале обслуживания McAfee по адресу http://knowledge.mcafee.com/ (на английском языке).

    Примечание.
    Сведения о веб-узлах сторонних компаний предоставлены для оказания помощи в нахождении необходимой технической информации. URL-адреса могут быть изменены без предварительного уведомления.
  • Для получения дополнительных сведений об антивирусных программах, обычно используемых с сервером Microsoft Exchange Server 2003 см. статью 823166 базы знаний Майкрософт «Использование антивирусных программ на сервере Exchange Server 2003» по адресу http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166.

  • Для получения дополнительных сведений об антивирусных программах, обычно используемых с сервером Microsoft Exchange 2000 Server, см. статью 328841 базы знаний Майкрософт «Антивирусное программное обеспечение для Exchange» по адресу http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841.

  • Для получения дополнительных сведений о том, как укрепить защиту среды Exchange против вирусов и червей, распространяемых по электронной почте, см. статью «Пресечение деятельности вирусов, распространяемых по электронной почте, в среде Exchange Server 2003» по адресу http://go.microsoft.com/fwlink/?LinkId=30732 (на английском языке).


Red Earth Software Policy Patrol for Exchange Server Needs Update
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2007-07-24

Анализатор Microsoft Exchange проверяет реестр на наличие следующих подразделов:

HKEY_LOCAL_MACHINE\Software\Red Earth Software\Policy Patrol\3.0

HKEY_LOCAL_MACHINE\Software\Wow6432Node\Red Earth Software\Policy Patrol\3.0

Наличие любого из данных подразделов указывает на то, что на локальном компьютере установлено программное обеспечение Red Earth Software Policy Patrol версии 3.0 для Exchange Server.

Если анализатор Exchange обнаруживает, что на локальном компьютере установлено программное обеспечение Policy Patrol версии 3 для Exchange Server, он выводит предупреждение.

Это предупреждение указывает на то, что для программного обеспечения Policy Patrol для Exchange Server имеется рекомендуемое обновление.

Устранение причины появления этого предупреждения

  1. Посетите веб-узел загрузки Red Earth Software Policy Patrol для Exchange Server по адресу http://www.policypatrol.com/download.htm (на английском языке).

  2. Загрузите и установите все необходимые и рекомендуемые обновления программного обеспечения Policy Patrol для Exchange Server.
Примечание.
Сведения о веб-узлах сторонних компаний предоставлены для оказания помощи в поиске необходимой технической информации. URL-адреса могут быть изменены без предварительного уведомления.


ScanMail для Microsoft Exchange и CA eTrust запущены одновременно
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-12-15

Чтобы определить версию Trend Micro ScanMail для Microsoft Exchange, установленную на сервере Exchange, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Если значение для параметра Version начинается с цифры 7, значит установлена версия 7 программы ScanMail для Microsoft Exchange.

Чтобы определить, установлена ли на сервере Exchange программа eTrust компании Computer Associates, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\

Если существует параметр реестра CurrentVersion, значит на сервере Exchange установлена версия 7 программы eTrust Antivirus компании Computer Associates.

Наконец, анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Service, чтобы определить значение ключа Started для службы InoRT, также называемой eTrust Antivirus Realtime Server, в программе eTrust Antivirus.

Анализатор сервера Exchange выводит на экран рекомендацию, если выполняются следующие условия:

  • И ScanMail для Microsoft Exchange, и eTrust Antivirus установлены на сервере Exchange.

  • Запущена служба eTrust Antivirus Realtime Server.

Специалисты Trend Micro рекомендуют исключить сканирование папок программы ScanMail для Microsoft Exchange при применении любого основанного на файловой системе антивирусного программного обеспечения, такого как eTrust Antivirus. ScanMail для Microsoft Exchange при сканировании использует временные папки, находящиеся в своих папках. Если основанная на файловой системе антивирусная программа сканирует эти временные папки, это может помешать выполнению обычных операций, выполняемых программой ScanMail для Microsoft Exchange.

Рекомендуется исключить сканирование в режиме реального времени папок ScanMail для Microsoft Exchange основанными на файловой системе антивирусными программами, такими как eTrust Antivirus компании Computer Associates. Дополнительные сведения об использовании программы ScanMail для Microsoft Exchange на компьютерах, на которых установлено основанное на файловой системе антивирусное программное обеспечение, см. в статье базы знаний Trend Micro статью, посвященную установке другого антивирусного приложения на том же сервере, на котором установлена программа ScanMail для Exchange (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=8540).

Примечание.
Сведения о веб-узлах сторонних компаний предоставлены для оказания помощи в поиске необходимой технической информации. URL-адреса могут быть изменены без предварительного уведомления.


Каталог архива ScanMail для Microsoft Exchange содержит слишком много файлов
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-12-15

Чтобы определить, установлена ли версия 7.0 средства Trend Micro ScanMail для Microsoft Exchange, анализатор сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Затем анализатор сервера Exchange считывает число файлов в каталоге архива, используемом средством ScanMail для Microsoft Exchange. По умолчанию задан следующий путь к каталогу архива:

C:\Program Files\Trend Micro\Smex\Storage\Archive

Анализатор сервера Exchange выводит на экран предупреждение, если выполняются следующие условия:

  • Установлена версия 7.0 средства ScanMail для Microsoft Exchange.

  • В каталоге архива, который используется средством ScanMail для Microsoft Exchange, находится более 1 000 файлов.

Это предупреждение указывает на то, что каталог архива, используемый средством ScanMail для Microsoft Exchange, содержит слишком много файлов. Компания Trend Micro рекомендует периодически просматривать и очищать папку архива, используемую средством ScanMail для Microsoft Exchange.


Каталог резервного копирования ScanMail для Microsoft Exchange содержит слишком много файлов
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-12-15

Чтобы определить, установлена ли версия 7.0 средства Trend Micro ScanMail для Microsoft Exchange, анализатор сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Затем анализатор сервера Exchange считывает число файлов в каталоге резервного копирования, используемом средством ScanMail для Microsoft Exchange. По умолчанию задан следующий путь к каталогу резервного копирования:

C:\Program Files\Trend Micro\Smex\Storage\Backup

Анализатор сервера Exchange выводит на экран предупреждение, если выполнены следующие условия:

  • Установлена версия 7.0 средства ScanMail для Microsoft Exchange.

  • В каталоге резервного копирования, который используется средством ScanMail для Microsoft Exchange, находится более 1 000 файлов.

Это предупреждение указывает на то, что каталог резервного копирования, используемый средством ScanMail для Microsoft Exchange, содержит слишком много файлов. Компания Trend Micro рекомендует периодически просматривать и очищать папку резервного копирования, используемую средством ScanMail для Microsoft Exchange.


Исключения ScanMail для резервного копирования Microsoft Exchange
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-12-15

Средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра, чтобы определить файлы и папки, которые были исключены из резервных копий с помощью средства резервного копирования Windows:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

Анализатор сервера Exchange отдельно ищет строку, содержащую «SMEX\DATA».

Если анализатор сервера Exchange обнаружит, что раздел FilesNotToBackup содержит значение, которое, в свою очередь, содержит строку «SMEX\DATA», анализатор сервера Exchange выводит на экран предупреждение.

Если не резервное копирование Windows не используется, не обращайте внимания на это сообщение. Если используется средство резервного копирования Windows, рекомендуется удалить исключение для каталога SMEX\DATA. Trend Micro рекомендует пользователям создавать резервные копии всех файлов в этой папке, имеющие расширение MDB. Файлы резервных копий могут использоваться, если производственные MDB-файлы в папке SMEX\DATA повреждаются или удаляются.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

  3. В левой области выберите FilesNotToBackup.

  4. В правой области щелкните правой кнопкой мыши значение, содержащее строку «SMEX\DATA» и выберите Удалить.

  5. Закройте редактор реестра.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Включен режим отладки программы «ScanMail для Microsoft Exchange»
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-12-15

Чтобы определить включен или нет режим отладки в программе «ScanMail для Microsoft Exchange» компании Trend Micro, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\DebugModule

Анализатор сервера Exchange выводит на экран предупреждение, если значение параметра DebugModule содержит одну или несколько следующих цепочек символов:

  • HOST:1

  • CONFIG:1

  • MASTER:1

  • WATCHER:1

  • STORE:1

  • INETINFO:1

  • TCHER:1

  • MON:1

  • MONITOR:1

Это предупреждение указывает, что режим отладки в текущий момент включен для одного или нескольких модулей «ScanMail для Microsoft Exchange». Компания Trend Micro рекомендует, чтобы режим отладки был включен только в случаях, когда он необходим, например, для устранения неполадок. Компания Trend Micro рекомендует во всех остальных случаях отключать режим отладки для обычных операций.

Чтобы устранить причину появления этого предупреждения

  1. Ознакомьтесь в базе знаний компании Trend Micro со следующей статьей, описывающей включение режима отладки программы «ScanMail для Exchange (SMEX) 7.0» с помощью редактора реестра (может быть на английском языке) (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=25532).

  2. Отключите режим отладки для всех модулей, выполнив инструкции, описываемые в статье базы знаний компании Trend Micro.
Примечание.
Сведения о веб-узлах сторонних компаний в этом разделе предоставлены для оказания помощи в нахождении необходимой технической информации. URL-адреса могут быть изменены без предварительного уведомления.


Каталог карантина ScanMail для Microsoft Exchange содержит слишком много файлов
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-12-15

Чтобы определить, установлена ли версия 7.0 средства Trend Micro ScanMail для Microsoft Exchange, анализатор сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Затем анализатор сервера Exchange считывает число файлов в каталоге карантина, используемом средством ScanMail для Microsoft Exchange. По умолчанию задан следующий путь к каталогу карантина:

C:\Program Files\Trend Micro\Smex\Storage\Quarantine

Анализатор сервера Exchange выводит на экран предупреждение, если выполнены следующие условия:

  • Установлена версия 7.0 средства ScanMail для Microsoft Exchange.

  • В каталоге карантина, который используется средством ScanMail для Microsoft Exchange, находится более 1 000 файлов.

Это предупреждение указывает на то, что каталог карантина, используемый средством ScanMail для Microsoft Exchange, содержит слишком много файлов. Компания Trend Micro рекомендует периодически просматривать и очищать папку карантина, используемую средством ScanMail для Microsoft Exchange.


Путь по умолчанию для каталога SharedResPool программы ScanMail для Microsoft Exchange
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2007-06-05

Чтобы определить установленную версию Trend Micro ScanMail для Microsoft Exchange, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Чтобы определить размещение папки SharedResPool, анализатор сервера Exchange также считывает следующую запись реестра:

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\SharedResPool

Наконец, чтобы определить папку установки ScanMail для Microsoft Exchange, анализатор сервера Exchange также считывает следующую запись реестра:

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\HomeDir

Анализатор сервера Exchange выводит на экран сообщение с рекомендациями, если выполняются следующие условия:

  • Установлена версия ScanMail для Microsoft Exchange.

  • Папка SharedResPool находится в пути корневого каталога ScanMail.

Рекомендуется переместить каталог SharedResPool на диск, обеспечивающий более высокое быстродействие, чем тот, на котором размещен корневой каталог ScanMail для Microsoft Exchange. Компания Trend Micro рекомендует переместить папку SharedResPool на более быстрый диск для повышения уровня производительности. В каталоге SharedResPool содержатся файлы отображения памяти для общих ресурсов, используемых процессами ScanMail для Microsoft Exchange версии 7.0. Не следует удалять содержимое данного каталога.

Дополнительные сведения о папке SharedResPool см. в разделе, посвященном описанию каталогов SharedResPool и Engine программы ScanMail для Exchange (SMEX) 7.0 (может быть на английском языке). (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=26898) (на английском языке).

Дополнительные сведения о перемещении папки SharedResPool см. в разделе «Перемещение каталога SharedResPool программы ScanMail для Exchange (SMEX) 7.0 в другое место» по адресу http://esupport.trendmicro.com/support/viewxml.do?ContentID=EN-127549&id=EN-127549 (на английском языке).

Примечание.
Сведения о веб-узлах сторонних компаний предоставлены для оказания помощи в поиске необходимой технической информации. URL-адреса могут быть изменены без предварительного уведомления.


Для сервера почтовых ящиков включено SMTP-сканирование ScanMail для Microsoft Exchange
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-12-15

Чтобы определить текущие параметры конфигурации Trend Micro ScanMail для Microsoft Exchange, средство анализатора сервера Microsoft® Exchange считывает следующее свойство в метабазе:

LM/SmtpSvc/%SMTPINSTANCE%/EventManager/EventTypes/{76719654-05A6-11d2-9dfd-00C04FA322BA}/Bindings/{6BA0CE4C-AC34-411E-B58A-EB715D04019D}/Enabled

Анализатор сервера Exchange делает запрос в службу каталогов Active Directory®, чтобы определить значение атрибута serverRole объекта сервера Exchange. Значение 1 атрибута serverRole указывает на то, что сервер Exchange был настроен в качестве сервера переднего плана. Значение 0 указывает на то, что сервер Exchange не был настроен в качестве сервера переднего плана.

Анализатор сервера Exchange также опрашивает WMI-класс Win32_OperatingSystem, чтобы определить значение параметра OSProductSuite сервера Exchange. Данный запрос позволяет определить операционную систему на сервере Exchange.

Анализатор сервера Exchange также считывает следующий раздел реестра, чтобы определить версию ScanMail для Exchange, под управлением которой работает сервер Exchange:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Если значение параметра Version начинается цифрой 7, значит, установлена программа ScanMail для Microsoft Exchange версии 7.

Наконец, анализатор сервера Exchange опрашивает службу Active Directory, чтобы определить количество объектов с настроенным атрибутом homeMDBBL. Объекты с настроенным атрибутом homeMDBBL поддерживают электронную почту. Таким образом, количество объектов с настроенным атрибутом homeMDBBL соответствует количеству существующих почтовых ящиков.

Анализатор сервера Exchange выводит на экран сообщение с рекомендациями, если выполняются следующие условия:

  • Установлена версия 7 ScanMail для Microsoft Exchange.

  • Программа ScanMail для Microsoft Exchange настроена для выполнения SMTP-сканирования на сервере Exchange, который не сконфигурирован в качестве сервера переднего плана.

  • На сервере Exchange содержится более 20 почтовых ящиков.

  • Сервер Exchange работает не под управлением Microsoft Windows Small Business Server 2003 или Microsoft Small Business Server 2000.

Компания Trend Micro рекомендует пользователям ScanMail для Microsoft Exchange версии 7 отключить SMTP-сканирование, использующее консоль управления ScanMail на серверах почтовых ящиков при наличии выделенных серверов-шлюзов или серверов-плацдармов. Для обеспечения максимальной безопасности и производительности компания Trend Micro рекомендует включить SMTP-сканирование на серверах-шлюзах или серверах-плацдармах, а не на серверах почтовых ящиков.


Каталог TEMP программы «ScanMail для Microsoft Exchange» содержит слишком много файлов
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-12-15

Чтобы определить, установлена ли версия 7.0 средства «Trend Micro ScanMail для Microsoft Exchange», анализатор сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Затем средство анализатора сервера Exchange подсчитывает число файлов в каталоге TEMP, используемом средством «ScanMail для Microsoft Exchange». По умолчанию средство «ScanMail для Microsoft Exchange» использует следующий путь к каталогу TEMP:

C:\Program Files\Trend Micro\Smex\Temp

Анализатор сервера Exchange выводит на экран предупреждение, если выполняются следующие условия:

  • Установлена версия 7.0 средства «ScanMail для Microsoft Exchange».

  • В каталоге TEMP, который используется средством «ScanMail для Microsoft Exchange», находится более 100 файлов.

Это предупреждение указывает на то, что каталог TEMP, используемый средством «ScanMail для Microsoft Exchange», содержит слишком много файлов. Файлы в этой папке являются временными файлами, используемыми средством «ScanMail для Microsoft Exchange». Предполагается, что средство «ScanMail для Microsoft Exchange» автоматически удаляет эти файлы.

Компания Trend Micro рекомендует удалять старые файлы, если существует много файлов с датой, предшествующей текущей дате.


В каталоге TEMP приложения ScanMail для Microsoft Exchange слишком много файлов
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-12-15

Чтобы определить, установлена ли версия 7.0 программы Trend Micro ScanMail для Microsoft Exchange, анализатор сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Если программа ScanMail 7.0 для Microsoft Exchange установлена, анализатор сервера Exchange читает следующий раздел реестра, чтобы определить местоположение каталога TEMP, используемого ScanMail для Microsoft Exchange:

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\TempFolderPath

Затем анализатор сервера Exchange считает количество файлов в каталоге TEMP, используемом ScanMail для Microsoft Exchange.

Если выполняются следующие условия, анализатор сервера Exchange выводит на экран предупреждение:

  • Установлена версия 7.0 программы ScanMail для Microsoft Exchange .

  • В каталоге TEMP, используемом ScanMail для Microsoft Exchange, имеется более 100 файлов.

Это предупреждение указывает на наличие слишком большого числа файлов в каталоге TEMP, используемом ScanMail для Microsoft Exchange. В этой папке хранятся временные файлы, используемые ScanMail для Microsoft Exchange. Программа ScanMail для Microsoft Exchange должна удалять эти файлы автоматически.

Если накопилось много файлов, созданных ранее текущей даты, Trend Micro рекомендует удалить эти старые файлы.


Изменился путь к временной папке программы ScanMail для Microsoft Exchange
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-12-15

Чтобы определить, установлена ли версия 7.0 средства Trend Micro ScanMail для Microsoft Exchange, анализатор сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Анализатор сервера Exchange также считывается следующую запись, чтобы определить местоположение временной папки, которая используется программой ScanMail для Microsoft Exchange:

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\TempFolderPath

Если в реестре существует и задано значение TempFolderPath, значит временная папка, используемая программой ScanMail для Microsoft Exchange была перемещена из стандартного расположения.

Наконец анализатор сервера Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version для библиотеки AdapterSMTP.dll. Этот модуль поставляется вместе с программой ScanMail для Microsoft Exchange, разработанной в компании Trend Micro. Если значение ключа Version для AdapterSMTP.dll меньше 7.0.1366, значит необходимо установить обновленную версию ScanMail для Microsoft Exchange.

Анализатор сервера Exchange выводит на экран предупреждение, если выполняются следующие условия:

  • Установлена версия ScanMail для Microsoft Exchange.

  • Временная папка, используемая программой ScanMail для Microsoft Exchange, была перемещена из исходного расположения.

  • Версия файла adapterSMTP.dll — 7.0.1366 или более старая.

В новых сборках ScanMail для Microsoft Exchange компания Trend Micro реализовала возможность перемещать временную папку. Эта функция работает только в сборках, выпущенных позднее 7.0.1366. Это предупреждение показывает, что временная папка была перемещена, но это изменение расположения не вступит в силу, поскольку на сервере выполняется более ранняя сборка ScanMail для Microsoft Exchange, в которой не поддерживается перемещение временной папки.

Чтобы устранить причину появления этого предупреждения

  1. Посетите веб-узел центра обновления Trend Micro (http://www.trendmicro.com/download).

  2. Загрузите и установите все необходимые или рекомендованные обновления для программы ScanMail для Microsoft Exchange.
Примечание.
Сведения о веб-узлах сторонних компаний предоставлены для оказания помощи в поиске необходимой технической информации. URL-адреса могут быть изменены без предварительного уведомления.


Оптимизация пути к временной папке ScanMail для Microsoft Exchange
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-12-15

Чтобы определить, установлена ли версия 7.0 средства Trend Micro ScanMail для Microsoft Exchange, анализатор сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Кроме того, анализатор сервера Exchange считывает следующий параметр, чтобы определить расположение временной папки, используемой ScanMail для Microsoft Exchange:

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\TempFolderPath

Если реестр содержит параметр TempFolderPath, это указывает, что временная папка, используемая ScanMail для Microsoft Exchange, была перемещена из местоположения по умолчанию.

В последнюю очередь анализатор сервера Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version для модуля AdapterSMTP.dll. Этот модуль включен в программу ScanMail для Microsoft Exchange, поставляемую компанией Trend Micro.

Анализатор сервера Exchange выводит на экран сообщение с рекомендациями, если выполняются следующие условия:

  • Установлена программа ScanMail для Microsoft Exchange версии 7.

  • Временная папка, используемая ScanMail для Microsoft Exchange, остается в исходном местоположении.

  • Установлена версия модуля AdapterSMTP.dll, в которой поддерживается перенаправление временной папки, используемой ScanMail для Microsoft Exchange.

Компания Trend Micro внедрила возможность перемещения временной папки в последних сборках ScanMail для Microsoft Exchange. Эта возможность доступна только начиная со сборки 7.0.1366. При использовании более поздней сборки ScanMail для Microsoft Exchange, чем версия 7.0.1366, Trend Micro рекомендует переместить временную папку на более быстрый диск.

Чтобы переместить временную папку

  1. Изучите статью базы знаний Trend Micro «Can users change the location of the ScanMail for Exchange (SMEX) 7.0 temporary folder?» (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=26343) (Могут ли пользователи изменить местоположение временной папки в ScanMail для Exchange версии 7.0).

  2. Выполните приведенные в этой статье процедуры, чтобы переместить временную папку на более быстрый диск.
Примечание.
Сведения о веб-узлах сторонних компаний предоставлены для оказания помощи в поиске необходимой технической информации. Эти URL-адреса могут быть изменены без предварительного уведомления.


Доступно обновление программы ScanMail ScanMail for Microsoft Exchange
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-12-15

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение раздела Version для adapterSMTP.dll. Этот модуль включен вместе с программой ScanMail for Microsoft Exchange компании Trend Micro.

Если анализатор сервера Exchange обнаружит, что значение раздела Version для adapterSMTP.dll должно быть меньше 7.0.1366, анализатор сервера Exchange выводит на экран предупреждение.

Это предупреждение показывает, что на сервере Exchange установлена версия 7 программы ScanMail for Microsoft Exchange и что доступно рекомендуемое обновление программы. Данное обновление настоятельно рекомендуется установить, чтобы улучшить общую производительность и надежность сервера.

Чтобы устранить причину появления этого предупреждения

  1. Посетите веб-узел центра обновления компании Trend Micro (http://www.trendmicro.com/download/).

  2. Загрузите и установите требуемые или рекомендуемые обновления для программы ScanMail for Microsoft Exchange.
Примечание.
Сведения о веб-узлах сторонних компаний предоставлены для оказания помощи в нахождении необходимой технической информации. URL-адреса могут быть изменены без предварительного уведомления.


Не включено антивирусное сканирование транспорта SMTP
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс Win32_Service, чтобы определить, установлено ли значение для ключа Started в службе SMSMSE. Класс Win32_Service определяет, установлена ли служба SMSMSE на компьютере с Exchange Server 2003. Значение True указывает, что служба SMSMSE выполняется. Значение False указывает, что служба SMSMSE не выполняется. Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Служба SMSMSE установлена на компьютере с Exchange Server 2003.

  • Не включено антивирусное сканирование транспорта SMTP.

В Exchange Server 2003 усовершенствованный модуль очередей использует интерфейс Exchange Transport AntiVirus API в качестве одного из шести приемников событий для доставки сообщений по назначению. Приемник событий Exchange Transport AntiVirus API реализован в файле OnSubmit.dll и позволяет поставщикам, отличным от корпорации Майкрософт, таким как Symantec, реализовать свое антивирусное программное обеспечениеs, проверяющее каждое сообщение на наличие злонамеренных вложений и структур данных до того, как они будут поставлены по назначению. Это событие регистрируется для события OnSubmission.

По умолчанию антивирусное сканирование транспорта не включено, поскольку это приводит к двойному сканированию сообщений — один раз в слое SMTP и один раз в хранилище Exchange. Однако при использовании клиентских серверов для подключения организации Exchange к Интернету, можно включить антивирусное сканирование транспорта на этих серверах.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неполадки. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы включить антивирусное сканирование транспорта

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к параметру реестра HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\TransportAVAPI

  3. Создайте новое значение DWORD с именем значения Enabled. Назначьте значение 1 для имени значения Enabled.

  4. Закройте редактор реестра.

Перед редактированием реестра для получения сведений по редактированию реестра см. статью 256986 базы знаний Майкрософт, содержащую описание реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Примечание.
Функция антивирусного сканирования транспорта доступна только с антивирусным программным обеспечением Exchange, основанном на интерфейсе Virus Scanning Application Programming Interface (VSAPI) 2.5.

Дополнительные сведения об архитектуре транспорта SMTP см. в техническом справочном руководстве для Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

Дополнительные сведения об использовании антивирусного программного обеспечения совместно с сервером Exchange Server см. в следующих статьях базы знаний Майкрософт:

  • 328841 — описывается использование антивирусное сканирование в Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841);

  • 823166 — содержит обзор антивирусного программного обеспечения Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 — описывается отношение корпорации Майкрософт к антивирусному программному обеспечению для Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 — содержит рекомендации по исправлению неполадок при использовании Exchange на компьютерах с установленной антивирусной защитой (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Список стороннего антивирусного программного обеспечения см. на веб-страницу с информацией о партнерах Exchange Server, поставляющих антивирусное программное обеспечение (http://go.microsoft.com/fwlink/?LinkId=16226).

Примечание.
Веб-адреса могут измениться, поэтому указанные веб-узлы могут быть недоступны.


Доступно обновление диспетчера ресурсов Simpler-Webb Exchange
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2006-04-14

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс CIM_Datafile, чтобы определить значение ключа Version для ERME2KAsyncSink.dll. Если анализатор сервера Exchange находит, что значение ключа Version для ERME2KAsyncSink.dll меньше 1015, на экран выводится предупреждение.

Файл ERME2KAsyncSink.dll является двоичным файлом ядра менеджера ресурсов Simpler-Webb Exchange (ERM). Если версия ERME2KAsyncSink.dll меньше чем 1015, то на сервере установлена версия ERM 1.2 или более ранняя. Известна неполадка версии ERM 1.2, которая может вызвать остановку доставки сообщений локальной очередью доставки сообщений Exchange, поскольку Exchange OLE DB ожидает возвратного вызова от приемника событий ERM. Во время завершения работы хранилища Exchange компонент Microsoft Exchange OLEDB ожидает, пока приемник событий ERME2KAsyncSink.dll вернется из вызова OnSyncSave.

Сбой при возврате из этого вызова может препятствовать полному завершению работы хранилища Exchange. Эта неполадка исправлена в версии ERM 1.35

Чтобы устранить причину появления этого предупреждения

  1. С помощью компонента Установка и удаление программ вручную удалите ERM 1.2.

  2. Установите версию ERM 1.35, доступную на веб-узле Simpler-Webb (http://www.swinc.com/products/ERM/upgrade/).

    Примечание.
    Сведения о веб-узлах сторонних компаний в этом разделе предоставлены для оказания помощи в нахождении необходимой технической информации. URL-адреса могут быть изменены без предварительного уведомления.


Доступно обновление Sybari Antigen 7.5 for Microsoft Exchange для Exchange
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, зарегистрирован ли файл библиотеки VSAPI (Virus Scanning Application Programming Interface) в службе банка данных Microsoft Exchange, средство анализатора сервера Microsoft® Exchange считывает значение следующего параметра реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Antigen 7.5 for Microsoft Exchange — продукт компании Sybari. Когда на компьютере с Exchange 2000 Server или Exchange Server 2003 установлен продукт Antigen 7.5 for Microsoft Exchange, запись реестра «Library» имеет значение ANTIGENVSAPI.DLL. Этот файл библиотеки используется в Antigen 7.5 for Microsoft Exchange для выполнения нескольких функций, связанных с VSAPI.

Кроме того, анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение ключа Version для ANTIGENVSAPI.DLL. Если значение ключа Version указывает, что номер сборки для этого файла меньше 1316, отображается предупреждение.

Если номер версии для ANTIGENVSAPI.DLL меньше 1316, значит на компьютере не установлена новейшая версия Antigen 7.5 for Microsoft Exchange. Обновление для Antigen 7.5 for Microsoft Exchange доступно на веб-узле Sybari. Настоятельно рекомендуется установить это обновление, оно позволяет повысить общее быстродействие и надежность.

Чтобы устранить причину появления этого предупреждения

  1. Посетите веб-узел Sybari «Licensed Download Center», где можно загрузить лицензионные продукты (http://www.sybari.com/portal/alias__Rainbow/lang__en-US/tabID__3359/DesktopDefault.aspx).

    Примечание.
    Веб-адреса могут измениться, поэтому существует вероятность, что вам не удастся подключиться к упомянутому веб-узлу.

  2. Загрузите новейшее обновление для своей версии продукта Antigen 7.5 for Microsoft Exchange.

  3. Выполните полное резервное копирование всех данных компьютера с сервером Exchange.

  4. Установите новейшее обновление Antigen 7.5 for Microsoft Exchange.

Для получения дополнительных сведений об использовании антивирусного программного обеспечения совместно с сервером Exchange см. статьи базы знаний корпорации Майкрософт:

  • Статья 328841, посвященная использованию Exchange и антивирусного программного обеспечения (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • Статья 823166, содержащая обзор Exchange Server 2003 и антивирусного программного обеспечения (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • Статья 306105 об отношении корпорации Майкрософт к антивирусному программному обеспечению для Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • Статья 245822, содержащая рекомендации по устранению неполадок при использовании Exchange на компьютерах с установленной антивирусной защитой (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Для получения перечня стороннего антивирусного программного обеспечения для сервера Exchange см. веб-узел Exchange Server Partners: Antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Доступен Sybari Antigen 8.0 for Microsoft Exchange Update для Exchange
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2006-01-09

Средство анализа Microsoft® Exchange Server считывает данные следующего параметра реестра, чтобы проверить, зарегистрирован ли файл библиотеки API поиска вирусов (VSAPI) службой Microsoft Exchange Information Store:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Antigen 8.0 для Microsoft Exchange - продукт компании Sybari. При установке Antigen 8.0 для Microsoft Exchange на сервер Exchange 2000 Server или Exchange Server 2003 элемент реестра Library принимает значение ANTIGENVSAPIEx.DLL. Файл библиотеки выполняет ряд связанных с VSAPI функций в программе Antigen 8.0 для Microsoft Exchange.

Кроме того, средство анализа Exchange Server запрашивает класс CIM_Datafile инструментария Microsoft Windows Management Instrumentation (WMI) для определения значения параметра Version для ANTIGENVSAPI.DLL. Если значение параметра Version показывает, что номер сборки для этого файла менее 1517, появляется предупреждение.

Номер версии менее 1517 для ANTIGENVSAPI.DLL означает, что не установлена последняя версия Antigen 8.0 для Microsoft Exchange. На веб-узле Sybari доступно обновление для Antigen 8.0 для Microsoft Exchange. Настоятельно рекомендуется провести обновление, которое может повысить общую производительность и надежность.

Для устранения этого предупреждения

  1. Посетите веб-узел компании Sybari, «Licensed Download Center» (http://www.sybari.com/portal/alias__Rainbow/lang__en-US/tabID__3359/DesktopDefault.aspx).

    Примечание.
    Веб-адрес может меняться, поэтому указанный здесь веб-узел может оказаться недоступен.

  2. Загрузите последнее обновление для вашей версии Antigen 8.0 для Microsoft Exchange.

  3. Сделайте полную резервную копию компьютера с Exchange Server.

  4. Установите последнее обновление для Antigen 8.0 для Microsoft Exchange.

Для получения дополнительных сведений об использовании антивирусных программ с сервером Exchange см. статьи базы знаний:

  • 328841, «Exchange и антивирусное программное обеспечение» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, «Обзор Exchange Server 2003 и антивирусного программного обеспечения» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, «XGEN: Мнение Microsoft об антивирусных решениях для Exchange 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, «Рекомендации по поиску и устранению неполадок на компьютере Exchange Server с установленным антивирусным программным обеспечением» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Для ознакомления со списком антивирусных программ сторонних разработчиков, доступных для сервера Exchange Server, см. веб-узел Exchange Server Partners: Antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


На этом сервере Exchange установлено приложение Sybari Antigen, но служба AntigenStore не запущена
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Service, чтобы определить, установлено ли на компьютере Exchange приложение Sybari Antigen и запущена ли на нем служба AntigenStore.

Анализатор сервера Exchange также запрашивает WMI-класс Win32_Service, чтобы определить, равно ли значение ключа Started, заданное для службы банка данных Microsoft Exchange, True или False.

Значение False показывает, что служба банка данных Microsoft Exchange не запущена на этом компьютере сервера Exchange. Значение True означает, что служба «Банк сообщений Microsoft Exchange» работает.

Если анализатор сервера Exchange обнаруживает, что служба банка данных Microsoft Exchange работает и приложение Sybari Antigen установлено, но служба AntigenStore не запущена, на экран выводится предупреждение.

Приложение Sybari Antigen обеспечивает защиту сервера Exchange от вирусов. В этом разделе перечислены некоторые причины остановки службы Sybari AntigenStore и возможные решения.

  • Возможно, на сервере Exchange выполняется пробная или оценочная версия программного обеспечения, срок действия которой уже истек. В этом случае может понадобиться переустановить приложение Sybari Antigen. Для продолжения использования программного обеспечения понадобится как минимум его активировать.

  • Администратор мог случайно остановить службу Sybari Antigen. Убедитесь, что для службы настроен автоматический запуск, и запустите службу.

  • Червь, вирус или другая программа могла остановить службу. Убедитесь, что служба настроена для автоматического запуска, а затем запустите ее. Если служба продолжает неожиданно останавливаться без выдачи сообщений об ошибке, убедитесь, что компьютер не заражен, и при необходимости устраните вирусную опасность.

Обычно рекомендуется развертывать антивирусное программное обеспечение, предназначенное для систем обмена сообщениями либо на шлюзе SMTP, либо на серверах Exchange, содержащих почтовые ящики. Для большей защиты используйте программное обеспечение на шлюзе, сканирующем входящие сообщения MIME, и сканер на сервере Exchange, использующем VSAPI 2.5. Кроме того, следует использовать клиентское антивирусное программное обеспечение на рабочих местах пользователей. При использовании антивирусного программного обеспечения, предназначенного для систем обмена сообщениями (оно может разбирать и сканировать MIME), на шлюзе или сервере Exchange на настольных компьютерах достаточно использовать сканер уровня файлов.

Запуск службы AntigenStore

  1. Откройте оснастку MMC Службы.

  2. Щелкните правой кнопкой мыши службу AntigenStore и в контекстном меню выберите Свойства.

  3. На вкладке Общие страницы свойств AntigenStore убедитесь, что для поля Тип запуска установлено значение Автоматически. В противном случае установите значение Автоматически, нажмите кнопку Применить, а затем нажмите кнопку OK.

  4. Щелкните правой кнопкой мыши службу AntigenStore и в контекстном меню выберите Пуск.

  5. Закройте оснастку Службы.

Сведения о защите среды Exchange от вирусов, передаваемых по электронной почте, см. на странице, посвященной борьбе с вирусами, распространяемыми по электронной почте, в среде Exchange Server 2003, по адресу http://go.microsoft.com/fwlink/?LinkId=47587.

Для получения дополнительных сведений об использовании антивирусного программного обеспечения совместно с сервером Exchange Server см. следующие статьи базы знаний корпорации Майкрософт:

  • 328841, описывающая совместное использование Exchange и антивирусного программного обеспечения, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841

  • 823166, содержащая обзор Exchange Server 2003 и антивирусного программного обеспечения, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166

  • 306105, посвященная отношению корпорации Майкрософт к антивирусному программному обеспечению для Exchange 2000, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105

  • 245822, содержащая рекомендации по исправлению неполадок компьютеров Exchange с установленным антивирусным программным обеспечением, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822

Перечень антивирусного программного обеспечения сторонних производителей для Exchange Server см. на веб-узле парнеров Exchange Server, посвященном антивирусному программному обеспечению, по адресу http://go.microsoft.com/fwlink/?linkid=16226.


На этом сервере Exchange установлено приложение Sybari Antigen, но служба остановлена
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает класс инструментария управления Windows (WMI) Win32_Service, чтобы определить, установлено ли на компьютере сервера Exchange приложение Sybari Antigen и работает ли служба AntigenService.

Анализатор сервера Exchange запрашивает WMI-класс Win32_Service также, чтобы определить, какое значение установлено для параметра Started в службе «Банк сообщений Microsoft Exchange»: True или False.

Значение False указывает на то, что служба «Банк сообщений Microsoft Exchange» на данном компьютере сервера Exchange не работает. Значение True означает, что служба «Банк сообщений Microsoft Exchange» работает.

Если анализатор сервера Exchange определяет, что служба «Банк сообщений Microsoft Exchange» работает, приложение Sybari Antigen установлено, но служба AntigenService не запущена, выводится предупреждение.

Sybari Antigen обеспечивает антивирусную защиту сервера Exchange. Далее приводятся некоторые причины, по которым служба Sybari Antigen, возможно, была остановлена, а также решения проблемы:

  • Программное обеспечение, работающее на сервере Exchange, может быть ознакомительной версией, срок эксплуатации которой истек. В этом случае, возможно, придется переустановить Sybari Antigen. Как минимум, чтобы продолжить использовать программное обеспечение, его необходимо активировать.

  • Администратор мог неумышленно остановить службу Sybari Antigen. Убедитесь, что для службы настроен автоматический запуск, и затем запустите службу.

  • Службу могли остановить опасные сетевые черви, вирусы или другая программа. Убедитесь, что для службы настроен автоматический запуск, и запустите службу. Если служба продолжает неожиданно останавливаться без регистрации соответствующих событий ошибок, убедитесь, что компьютер не заражен сетевым червем, и при необходимости произведите очистку системы от инфекции.

Обычно антивирусное программное обеспечение, предназначенное для системы управления сообщениями рекомендуется разворачивать на SMTP-шлюзе или на серверах Exchange, на которых расположены почтовые ящики. Для усиления защиты запустите антивирусное программное обеспечение на шлюзе, просматривающем входящие MIME-сообщения, а на сервере Exchange запустите сканер, использующий VSAPI 2.5. Кроме того, следует запустить антивирусное программное обеспечение на компьютер-клиентах. Если на шлюзе или сервере Exchange работает антивирусное программное обеспечение, разработанное для систем управления сообщениями (которое может анализировать и сканировать MIME-данные), на рабочем столе будет достаточно запустить сканер файлового уровня.

Чтобы запустить службу AntigenService

  1. Откройте оснастку Службы консоли MMC.

  2. Щелкните правой кнопкой мыши службу AntigenService и в контекстном меню выберите Свойства.

  3. Убедитесь, что на вкладке Общие страницы свойств AntigenService для параметра Тип запуска задано значение Авто. Если установлено другое значение, выберите значение авто, нажмите кнопку Применить, а затем кнопку ОК.

  4. Щелкните службу AntigenService правой кнопкой мыши и в контекстном меню выберите Пуск.

  5. Закройте оснастку Службы.
  • Дополнительные сведения о защите среды Exchange от вирусов, передаваемых по электронной почте, см. на странице, посвященной борьбе с вирусами, распространяемыми по электронной почте, в среде Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47587).

Для получения дополнительных сведений об использовании антивирусного программного обеспечения совместно с сервером Exchange Server см. следующие статьи базы знаний корпорации Майкрософт:

  • 328841, описывающая взаимодействие Exchange с антивирусным программным обеспечением (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • Статья 823166, содержащая обзор Exchange и антивирусного программного обеспечения (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • Статья 306105 об отношении корпорации Майкрософт к антивирусному программному обеспечению для Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • Статья 245822, содержащая рекомендации по исправлению неполадок при использовании Exchange на компьютерах с установленной антивирусной защитой (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Для получения перечня антивирусного программного обеспечения для сервера Exchange независимых разработчиков см. веб-узел Exchange Server Partners: Antivirus, посвященный антивирусному программному обеспечению (http://go.microsoft.com/fwlink/?linkid=16226).


Определения антивирусного пакета Symantec не обновлялись более 30 дней
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, выполнены ли следующие условия, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

  • На сервере установлен антивирусный пакет Symantec.

  • Обновлены следующие файлы определений:

    HKEY_LOCAL_MACHINE\Software\Symantec\SharedDefs\MicroDefs

Если анализатор сервера Exchange обнаруживает, что значение раздела реестра BinHubStamp не обновлялось более 30 дней, выводится предупреждение.

Антивирусный пакет Symantec для Microsoft Exchange Server обеспечивает защиту от вирусов для Exchange Server. Рекомендуется загружать последние обновления антивирусного пакета Symantec сразу после их выпуска. Убедитесь, что обновления антивирусных определений развернуты для следующих слоев организации:

  • Серверы шлюзов сообщений

  • Серверы Exchange

  • Клиентские рабочие станции

Чтобы загрузить последние определения вирусов, посетите веб-узел антивирусного пакета Symantec, «Symantec home page» (http://www.symantec.com) (Главная страница Symantec).

Дополнительные сведения о защите среды Exchange от вирусов и червей, передаваемых по электронной почте, см. в документе «Slowing and Stopping E-Mail Viruses in an Exchange Server 2003 Environment» (http://go.microsoft.com/fwlink/?LinkId=47587) (Замедление и останов передаваемых по электронной почте вирусов в среде Exchange Server 2003).

Дополнительные сведения об использовании антивирусного программного обеспечения с Exchange Server см. в следующих статьях базы знаний Майкрософт:

  • 328841, «Exchange and antivirus software» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841) (Exchange и антивирусное программное обеспечени)

  • 823166, «Overview of Exchange Server 2003 and antivirus software» http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166 (Общие сведения о Exchange и антивирусном программном обеспечении)

  • 306105, «XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105) (Позиция корпорации Майкрософт в отношении антивирусного программного обеспечения для Exchange 2000)

  • 245822, «Recommendations for troubleshooting an Exchange computer with antivirus software installed» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822) (Рекомендации по устранению неполадок в работе Exchange на компьютерах с установленной защитой от вирусов)

Перечень антивирусного программного обеспечения независимых разработчиков для Exchange Server см. на веб-узле Exchange Server Partners Antivirus (http://go.microsoft.com/fwlink/?linkid=16226) (Антивирусное программное обеспечение партнеров Exchange Server).

Примечание.
Возможно изменение веб-адресов, поэтому указанные веб-узлы могут быть недоступны.


На этом сервере Exchange установлен Symantec Antivirus, но служба остановлена
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс Win32_Service, чтобы определить, установлено ли значение раздела Started. Класс Win32_Service определяет, установлено ли приложение Symantec Antivirus на этом сервере Exchange. Значение «True» раздела Started означает, что служба Symantec Antivirus работает на этом компьютере сервера Exchange. Значение «False» раздела Started означает, что служба Symantec Antivirus не работает на этом компьютере сервера Exchange.

Если анализатор сервера Exchange обнаружит, что приложение Symantec Antivirus установлено на этом компьютере сервера Exchange, но служба Symantec Antivirus не запущена, анализатор отобразит предупреждение.

Приложение Symantec Antivirus обеспечивает антивирусную защиту сервера Exchange. Некоторые причины, по которым служба Symantec Antivirus может быть остановлена, а также способы устранения этих причин приведены ниже.

  • Программное обеспечение, работающее на сервере Exchange, может быть пробной, и срок его действия истек. В этом случае можно попытаться переустановить Symantec Antivirus. Чтобы продолжить использование программного обеспечения, необходимо хотя бы его активировать.

  • Администратор мог случайно остановить службу Symantec Antivirus. Проверьте, что служба запускается автоматически, затем запустите службу.

  • Вредоносный вирус-червь, другой вирус или программа остановила службу. Убедитесь, что служба запускается автоматически, затем запустите службу. Если служба продолжает неожиданно останавливаться без соответственных событий ошибок, убедитесь, что компьютер не заражен вирусом и при необходимости устраните вирусную опасность.

Рекомендуется развертывать антивирусное программное обеспечение, предназначенное для систем обмена сообщениями, на шлюз SMTP или на серверы Exchange, которые содержат почтовые ящики. Чтобы обеспечить наибольшую безопасность, запускайте антивирусное программное обеспечение на шлюзе, который будет обрабатывать все входящие сообщения MIME, и антивирусный сканер на сервере Exchange, использующем VSAPI 2.5.

Чтобы запустить службу Symantec Antivirus

  1. Откройте оснастку Службы консоли MMC.

  2. Щелкните правой кнопкой мыши Symantec Antivirus и в контекстном меню выберите Свойства.

  3. Убедитесь, что на вкладке Общие страницы свойств Symantec Antivirus Тип запуска выставлен как Авто. Если нет, нажмите кнопку Применить, затем ОК.

  4. Щелкните правой кнопкой мыши Symantec Antivirus и в контекстном меню выберите Пуск.

  5. Закройте оснастку Службы.

Кроме того, следует использовать антивирусное программное обеспечение на компьютерах пользователей. Сканирование файлов на компьютерах обеспечивает достаточную защиту, если выполняется одно из следующих условий:

  • Выполняется антивирусное программное обеспечение, которое предназначено для систем обмена сообщениями и может анализировать и сканировать MIME на шлюзах.

  • Выполняется антивирусное программное обеспечение, которое предназначено для систем обмена сообщениями и может анализировать и сканировать MIME на сервере Exchange.

Дополнительные сведения о разных видах антивирусных программ, обычно используемых с Microsoft Exchange Server 2003 см. в статье 823166 базы знаний Майкрософт, описывающей антивирусное программное обеспечение для Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Дополнительные сведения о разных видах антивирусных программ, обычно используемых на серверах Microsoft Exchange 2000 см. в статье 328841 базы знаний Майкрософт, описывающей антивирусное программное обеспечение для Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Сведения о защите среды Exchange от вирусов, передаваемых по электронной почте, см. на странице, посвященной борьбе с вирусами, распространяемыми по электронной почте, в среде Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47587).


Предупреждения, относящиеся к конфигурации антивирусного программного обеспечения Symantec Mail Security for Exchange
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает WMI-класс Win32_Process, чтобы определить значение параметра Started для службы SMSMSE (Symantec Mail Security for Microsoft Exchange).

Значение True означает, что Symantec Mail Security for Microsoft Exchange Server установлено на компьютере сервера Exchange и служба SMSMSE выполняется. Значение False указывает, что служба SMSMSE не выполняется.

Анализатор сервера Exchange также опрашивает WMI-класс Win32_Service, чтобы определить, какое значение задано для параметра Started в службе банка данных Microsoft Exchange: True или False.

Значение False указывает, что служба банка данных Microsoft Exchange не выполняется на компьютере сервера Exchange. Значение True указывает, что служба банка данных Microsoft Exchange выполняется.

Если анализатор сервера Exchange обнаруживает, что служба банка данных Microsoft Exchange выполняется и программное обеспечение Symantec Mail Security for Microsoft Exchange установлено, но служба SMSMSE не запущена, то на экран выводится предупреждение.

Одну из основных угроз компьютерной среде несут вирусы, передающиеся через сообщения электронной почты. Вирусы, передаваемые по электронной почте, могут атаковать компьютерные системы или среду обмена электронными сообщениями, перегружая систему сообщениями. Необходимо убедиться, что среда достаточно защищена от вирусов. Рассмотрите возможность защиты от вирусов на уровне брандмауэра на шлюзе SMTP или вне его, а также на каждом сервере Exchange и на каждом клиенте.

Чтобы устранить причину появления этого предупреждения

  1. Запустите оснастку Windows Службы на компьютере сервера Exchange.

  2. В правой области перейдите к службе Symantec Mail Security for Microsoft Exchange и дважды щелкните ее.

  3. Убедитесь, что в раскрывающемся меню Тип запуска выбрано значение Авто.

  4. Щелкните Пуск, чтобы запустить службу Symantec Mail Security for Microsoft Exchange.

  5. Нажмите кнопку OK, чтобы сохранить изменения и закрыть диалоговое окно Свойства, затем закройте оснастку.

Сведения о защите среды Exchange см. в разделе, посвященном обезвреживанию вирусов, передаваемых по электронной почте, в Exchange 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47587).

Дополнительные сведения об использовании антивирусного программного обеспечения совместно с сервером Exchange Server см. в следующих статьях базы знаний корпорации Майкрософт:

  • статья 328841, посвященная Exchange и антивирусному программному обеспечению (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841);

  • статья 823166, содержащая обзор Exchange и антивирусного программного обеспечения (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166);

  • статья 306105, посвященная отношению корпорации Майкрософт к антивирусному программному обеспечению для Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105);

  • статья 245822, содержащая рекомендации по исправлению неполадок при использовании Exchange на компьютерах с установленной антивирусной защитой (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Список стороннего антивирусного программного обеспечения см. на веб-узле, посвященном партнерам Exchange по антивирусному программному обеспечению (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=16226).


Доступно обновление для Symantec Mail Security for Microsoft Exchange 4.5
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2006-02-14

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить значение раздела Version для файла Savfmsevsapi.dll. Если значение раздела Version показывает, что номер сборки для этого файла равен 4.5, на экран выводится предупреждение.

Номер версии для файла Savfmsevsapi.dll, равный 4.5, показывает, что у вас работает не самая последняя версия приложения Symantec Mail Security for Microsoft Exchange 4.6x. Программу обновления для Symantec Mail Security for Microsoft Exchange 4.6x можно загрузить с веб-узла компании Symantec. Обновление до версии 4.63 или более поздних версий настоятельно рекомендуется, т.к. оно может улучшить общую производительность и надежность.

Ниже приведены некоторые известные проблемы, возникающие при работе версии 4.5 файла Savfmsevsapi.dll.

  • Обработка потоков почты сервером Exchange может замедляться во время обычных операций.

  • Очереди SMTP, например очередь на поиск в каталоге и очередь на локальную доставку, архивируются.

  • Нельзя остановить службу банка данных Microsoft Exchange.

  • Клиенты Microsoft Outlook® не могут подключиться к серверу Exchange.

  • Доставка сообщений, отправленных клиентами Outlook, на сервер Exchange длится гораздо дольше обычного. Задержка с ответом клиентам Outlook может достигать 30 секунд.

Чтобы устранить причину появления этого предупреждения

  1. Посетите страницу корпоративной поддержки веб-узла компании Symantec (http://www.symantec.com/techsupp/enterprise/).

  2. Выполните обновление до версии 4.63 или более поздней версии.
Примечание.
Сведения о веб-узлах сторонних компаний в этом разделе предоставлены для оказания помощи в нахождении необходимой технической информации. URL-адреса могут быть изменены без предварительного уведомления.

Для получения дополнительных сведений об использовании антивирусного программного обеспечения совместно с сервером Exchange см. статьи базы знаний корпорации Майкрософт:

  • 328841, посвященная Exchange и антивирусному программному обеспечению (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, посвященная обзору Exchange Server 2003 и антивирусного программного обеспечения http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, посвященная отношению корпорации Майкрософт к антивирусному программному обеспечению для Exchange 2000 http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, посвященная рекомендациям по устранению неполадок при использовании сервера Exchange с установленным программным обеспечением антивирусной защиты (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Для получения перечня стороннего антивирусного программного обеспечения для сервера Exchange см. Exchange Server Partners: антивирусный веб-узел (http://go.microsoft.com/fwlink/?linkid=16226).


Доступно обновление программы Trend Micro ScanMail for Microsoft Exchange
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2006-01-09

Средство анализатора приложения Microsoft® Exchange Server считывает следующее значение реестра, чтобы определить, зарегистрирован ли файл библиотеки API-интерфейса для сканирования вирусов (VSAPI) в банке данных Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Если ScanMail for Microsoft Exchange, являющийся продуктом компании Trend Micro, установлен в Exchange 2000 Server или в Exchange Server 2003, запись для библиотеки в реестре будет иметь следующее значение: SMXS3DLL.DLL. Данный библиотечный файл выполняет в ScanMail for Microsoft Exchange несколько функций, связанных с VSAPI.

Анализатор сервера Exchange также запрашивает класс инструментария WMI CIM_Datafile, чтобы определить значение раздела Version для SMXS3DLL.DLL. Если значение раздела Version показывает, что номер сборки для данного файла меньше 1174, на экран выводится предупреждение.

Номер версии меньше 1174 для SMXS3DLL.DLL показывает, что самая последняя версия программы ScanMail for Microsoft Exchange не установлена. Программу обновления для ScanMail for Microsoft Exchange можно загрузить с веб-узла компании Trend Micro. Данное обновление настоятельно рекомендуется установить, чтобы улучшить общую производительность и надежность.

Чтобы устранить причину появления этого предупреждения

  1. Посетите веб-узел компании Trend Micro "Update Center, ScanMail for Microsoft Exchange" (Центр обновления, ScanMail for Microsoft Exchange) (http://www.trendmicro.com/download/product.asp?productid=8).

  2. Загрузите самое последнее обновление для вашей версии программы ScanMail for Microsoft Exchange.

  3. Сделайте полную архивацию сервера Exchange.

  4. Установите последнее обновление для ScanMail for Microsoft Exchange.

Для получения дополнительных сведений об использовании антивирусного программного обеспечения совместно с сервером Exchange см. статьи базы знаний корпорации Майкрософт:

  • Статья 328841 "XADM: Exchange and Antivirus Software" (XADM: Exchange и антивирусное программное обеспечение) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • Статья 823166 "Overview of Exchange Server 2003 and antivirus software" (Обзор Exchange Server 2003 и антивирусного программного обеспечения) http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • Статья 306105 "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (XGEN: (Отношение корпорации Майкрософт к антивирусному программному обеспечению для Exchange 2000) http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • Статья 245822 "Recommendations for troubleshooting an Exchange computer with antivirus software installed" (Рекомендации по устранению неполадок при использовании Exchange на компьютерах с установленной антивирусной защитой) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Для получения перечня стороннего антивирусного программного обеспечения для сервера Exchange см. Exchange Server Partners: антивирусный веб-узел (http://go.microsoft.com/fwlink/?linkid=16226).


Trend Micro ServerProtect для Microsoft Windows остановлен
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server запрашивает класс Win32_Service инструментария Microsoft Windows® Management Instrumentation (WMI), чтобы определить значение параметра реестра Started для службы SpntSvc. Служба SpntSvc устанавливается программой ServerProtect для Microsoft Windows, разработанной Trend Micro. Значение True параметра Started говорит о том, что служба запущена, а значение False — о том, что служба остановлена. Если средство анализа Exchange Server обнаруживает, что служба SpntSvc остановлена, появляется предупреждение.

ServerProtect для Microsoft Windows выполняет поиск вирусов на уровне файловой системы сервера, в том числе и обнаружение и удаление вирусов в режиме реального времени.

Запуск службы SpntSvc

  1. Откройте оснастку Службы консоли управления Microsoft.

  2. Щелкните правой кнопкой мыши службу ServerProtect Server и выберите Свойства.

  3. На вкладке Общие окна свойств ServerProtect Server проверьте, установлено ли для параметра Тип запуска значение Автоматически. Если это не так, установите значение Автоматически, нажмите кнопку Применить и нажмите кнопку OK.

  4. Щелкните правой кнопкой мыши службу ServerProtect Server и выберите Запустить.

  5. Закройте оснастку Службы.

Для получения дополнительных сведений об использовании антивирусного программного обеспечения для Exchange Server см. следующие статьи базы знаний корпорации Майкрософт:

  • 328841, «XADM: Антивирусное программное обеспечение для Exchange» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, «Использование антивирусных программ на сервере Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, «XGEN: мнение Майкрософт об антивирусных программах для Exchange 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, «Рекомендации по устранению неполадок на компьютере с сервером Exchange Server, использующем антивирусные программы» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Список антивирусного программного обеспечения сторонних производителей, используемого для сервера Exchange, можно найти на веб-узле, посвященном партнерам сервера Exchange в области антивирусных программ (http://go.microsoft.com/fwlink/?linkid=16226).


Конфигурация Trend ScanMail: производительность может быть улучшена
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2006-09-05

Чтобы определить значение параметра TempFileThreshold, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

Параметр реестра TempFileThreshold применяется при сканировании текста сообщений, а также вложений. Если размер текста сообщения или вложения превышает значение, установленное для раздела TempFileThreshold, временный файл создается на диске. В обратном он будет создан в памяти. По умолчанию для параметра TempFileThreshold установлено значение 3 072 килобайта (3 МБ).

Анализатор сервера Exchange также запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_ComputerSystem, чтобы определить значение, заданное для ключа TotalPhysicalMemory. Это значение указывает объем установленной на компьютере памяти с произвольной выборкой (ОЗУ).

Анализатора сервера Microsoft® Exchange также запрашивает службу каталогов Active Directory®, чтобы определить значение для атрибута delivContLength глобальных параметров, находящегося в следующих группах:

CN=Configuration,DC=Domain,CN=com, CN=Services, CN=Microsoft Exchange, CN= имя_организации , CN=Global Settings, CN=Message Delivery

Этот атрибут отражает максимальный размер входящих SMTP-сообщений.

Если анализатор сервера Exchange обнаруживает, что значение параметра TempFileThreshold составляет менее 70 процентов максимального размера сообщения на компьютере Exchange Server с ОЗУ объемом более 1 ГБ, выводится предупреждение.

Это предупреждение указывает, что значение параметра реестра TempFileThreshold, возможно, не оптимизировано для используемой среды. Данное значение должно задаваться таким образом, чтобы оно было по меньшей мере равно предельному размеру вложений, установленному для используемых серверов Exchange.

Примечание.
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

  3. В правой области дважды щелкните TempFileThreshold.

  4. Введите значение, выраженное в килобайтах, которое равно среднему размеру сообщений в организации. Например, если средний размер сообщений равен 10 МБ, следует ввести значение 10240.
Примечание.
Если увеличить это значение, может потребоваться дополнительная системная память. Например, если значение «ScanningThreads» установлено равным 8, а значение «TempFileThreshold» установлено равным 10240, минимальный объем памяти, необходимой для проверки на вирусы, будет равен 80 МБ (ScanningThreads * TempFileThreshold).
  1. Закройте редактор реестра и перезапустите службу ScanMail_RealTimeScan и службу Банк данных Microsoft Exchange, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт, в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Конфигурация Trend ScanMail: в реестре включен параметр QuerySender
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2006-04-20

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation, WMI) Win32_Service, чтобы определить значение ключа «Started» службы ScanMail_Action, работающей с «Trend Micro ScanMail для Microsoft Exchange». Значение True указывает, что служба ScanMail_Action работает, а значение False указывает, что служба не работает.

Чтобы определить, выполнена ли настройка «ScanMail для Microsoft Exchange», позволяющая использовать подстановочный знак при поиске в службе каталогов Active Directory®, анализатор сервера Exchange также считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\QuerySender

Значение 0 для записи QuerySender в реестре указывает, что поиски с использованием подстановочных знаков отключены. Значение 1 для записи QuerySender в реестре указывает, что поиски с использованием подстановочных знаков включены.

Помимо этого, анализатор сервера Exchange запрашивает службу Active Directory, чтобы определить значение счетчика записей, перечисленных в атрибуте homeMDBBL каждого хранилища почтовых ящиков. Счетчик этого атрибута представляет количество почтовых ящиков в хранилище почтовых ящиков.

Если анализатор сервера Exchange определит, что служба ScanMail_Action выполняется, что сервер Exchange содержит более 100 почтовых ящиков, и что запись QuerySender в реестре не установлена равной 0, на экран выводится предупреждение.

Программа «Trend Micro ScanMail для Microsoft Exchange» предоставляет антивирусную защиту серверу Exchange. Когда «ScanMail для Exchange» сканирует сообщение, отправленное в список рассылки, то в соответствии с алгоритмом поведения по умолчанию в глобальном каталоге Active Directory запрашиваются все получатели сообщения. Если в списке рассылки существует большое число получателей, такой алгоритм поведения программы может быть причиной возникновения проблем с производительностью. Кроме того, если рекомендации, приводимые в этой статье, не выполнены, будут высокими значения следующих счетчиков производительности:

  • MSExchangeIS/Длина очереди средства поиска вирусов,

  • MSExchangeIS/запросы RPC,

  • MSExchangeIS/средняя задержка RPC.

Если для параметра QuerySender установлено значение, равное 0, при сканировании сообщений, отправляемых в списки рассылки, запрещается запрос всех получателей в глобальном каталоге, выполняемый «ScanMail для Microsoft Exchange».

Чтобы устранить причину появления этого предупреждения

  1. Свяжитесь с компанией Trend Micro для получения сведений об использовании параметра QuerySender реестра (http://www.trendmicro.com/en/about/overview.htm).

  2. Дополнительные сведения о параметре QuerySender реестра см. в решении Trend Micro с идентификатором 120393 (http://esupport.trendmicro.com/support/viewxml.do?ContentID=en-120393).

    Примечание.
    Веб-адреса могут измениться, поэтому существует вероятность, что вам не удастся подключиться к упомянутым здесь веб-узлам.

Дополнительные сведения о защите среды Exchange от вирусов и червей, распространяемых по электронной почте, см. в описании мер по защите от вирусов, распространяемых по электронной почте, в среде Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47587).

Дополнительные сведения об использовании антивирусного программного обеспечения совместно с сервером Exchange Server см. в следующих статьях базы знаний Майкрософт:

  • Статья 328841, описывающая приложение Exchange и антивирусное программное обеспечение (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841).

  • Статья 823166, содержащая обзор Exchange и антивирусного программного обеспечения (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Статья 306105 об отношении корпорации Майкрософт к антивирусному программному обеспечению для Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105).

  • Статья 245822, содержащая рекомендации по исправлению неполадок при использовании Exchange на компьютерах с установленной антивирусной защитой (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Для получения перечня стороннего антивирусного программного обеспечения для Exchange Server см. веб-узел Exchange Server Partners, посвященный антивирусному программному обеспечению (http://go.microsoft.com/fwlink/?LinkId=16226).


Конфигурация Trend ScanMail: служба ScanMail_Monitor не зависит от службы кластеров
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2006-02-13

Анализатор сервера Microsoft® Exchange считывает следующую запись реестра на каждом из серверов, который является узлом кластера:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Если параметр Version имеет значение 6.2.000, значит, установлена версия 6.2 программы ScanMail для Microsoft Exchange.

Анализатор сервера Exchange также опрашивает WMI-класс Win32_Service, чтобы определить значение ключа Started службы кластеров (ClusSvc). Значение True указывает, что служба кластеров запущена, а значение False означает, что служба остановлена.

Анализатор сервера Exchange также считывает следующую запись реестра на каждом из серверов, который является узлом кластера:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ScanMail_Monitor

Если анализатор сервера Exchange обнаруживает, что параметр ScanMail_Monitor не включает многозначную запись реестра DependOnService со значением ClusSvc, значит, служба ScanMail_Monitor не зависит от службы кластеров.

Анализатор сервера Exchange выводит на экран предупреждение, если выполняются следующие условия:

  • На сервере выполняется версия 6.2. программы TrendMicro ScanMail для Microsoft Exchange

  • На сервере выполняется служба кластеров (ClusSvc).

  • Служба ScanMail_Monitor не настроена таким образом, чтобы она зависела от службы кластеров.

После установки сборок ScanMail для Microsoft Exchange 6.2 необходимо настроить службу ScanMail_Monitor таким образом, чтобы она зависела от службы кластеров. Если не сконфигурировать такую зависимость, то служба кластеров будет зависать при каждом перезапуске узла.

Чтобы устранить причину появления этого предупреждения

  1. См. статью, в которой описывается неожиданная остановка службы кластеров Microsoft Exchange после применения исправления 1 для ScanMail для Exchange (SMEX) 6.2 [Идентификатор решения: 21441] на веб-узле компании Trend Micro (может быть на английском языке) (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionId=21441&id=21441).

    Примечание.
    Хотя в статье решения 21441 описывается необходимость настроить эту зависимость именно после установки исправления 1, сведения, содержащиеся в статье, применимы к серверам с любой сборкой ScanMail для Microsoft Exchange 6.2.

  2. Добавьте в реестр мультистроковой параметр DependOnService, как описано в разделе статьи 21441, в котором описываются способы решения проблемы.
Примечание.
Сведения о веб-узлах сторонних компаний в этом разделе предоставлены для оказания помощи в нахождении необходимой технической информации. URL-адреса могут быть изменены без предварительного уведомления.

Дополнительные сведения об обновлениях продуктов Trend Micro см. на веб-узле центра обновлений Trend Micro (может быть на английском языке) (http://www.trendmicro.com/download/).

Дополнительные сведения об использовании антивирусного программного обеспечения совместно с сервером Exchange Server см. в статьях базы знаний корпорации Майкрософт:

  • Статья 328841, посвященная Exchange и антивирусному программному обеспечению (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841).

  • Статья 823166, содержащая обзор Exchange Server 2003 и антивирусного программного обеспечения (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Статья 306105, посвященная отношению корпорации Майкрософт к антивирусному программному обеспечению для Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105).

  • Статья 245822, содержащая рекомендации по исправлению неполадок при использовании Exchange на компьютерах с установленной антивирусной защитой (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Список стороннего антивирусного программного обеспечения см. на веб-узле, посвященном партнерам Exchange по антивирусному программному обеспечению (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=16226).


Настройка Trend ScanMail: для параметра реестра SkipWildcardSearchInGC установлено значение 0
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation, WMI) Win32_Service, чтобы определить значение ключа Started службы ScanMail_Action (Trend Micro ScanMail для Microsoft Exchange). Значение True указывает, что служба ScanMail_Action работает, а значение False указывает, что служба не работает.

Чтобы определить, выполнена ли настройка ScanMail для Microsoft Exchange, позволяющая использовать подстановочный знак при поиске в службе каталогов Active Directory®, анализатор сервера Exchange также считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\SkipWildcardSearchInGC

Значение 1 для параметра реестра SkipWildcardSearchInGC указывает, что функции поиска с использованием подстановочных знаков отключены. Значение 0 параметра SkipWildcardSearchInGC указывает, что функции поиска с использованием подстановочных знаков включены.

Помимо этого, анализатор сервера Exchange запрашивает службу Active Directory, чтобы определить значение счетчика записей, перечисленных в атрибуте homeMDBBL каждого хранилища почтовых ящиков. Счетчик этого атрибута представляет количество почтовых ящиков в хранилище почтовых ящиков.

Если анализатор сервера Exchange определит, что служба ScanMail_Action выполняется, что сервер Exchange содержит более 100 почтовых ящиков, и что для параметра реестра SkipWildcardSearchInGC установлено значение 0, на экран выводится предупреждение.

Программа Trend Micro ScanMail для Microsoft Exchange обеспечивает защиту от вирусов для сервера Exchange. Если задать для параметра SkipWildcardSearchInGC значение 1, программа ScanMail для Microsoft Exchange не будет распознавать имена, содержащие подстановочный знак (*). Запрос имени с подстановочным знаком может существенно замедлить работу компьютера с сервером Exchange, поскольку ScanMail для Exchange может проверять весь каталог. Кроме того, если рекомендации, приводимые в этой статье, не выполнены, будут высокими значения следующих счетчиков производительности:

  • MSExchangeIS/длина очереди средства поиска вирусов,

  • MSExchangeIS/запросы RPC,

  • MSExchangeIS/средняя задержка RPC.

Чтобы устранить причину появления этого предупреждения

  1. Для получения сведений об использовании параметра реестра SkipWildcardSearchInGC обратитесь в компанию Trend Micro (http://www.trendmicro.com/en/about/overview.htm).

  2. Для получения дополнительных сведений о параметре реестра SkipWildcardSearchInGC см. решение Trend Micro с идентификатором 20393 (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=13176).

    Примечание.
    Веб-адреса могут измениться, поэтому существует вероятность, что не удастся подключиться к упомянутым здесь веб-узлам.

Дополнительные сведения об укреплении защиты среды Exchange от вирусов и червей см. в разделе, посвященном замедлению и прекращению действия вирусов в электронной почте в среде Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47587).

Для получения дополнительных сведений об использовании антивирусного программного обеспечения совместно с сервером Exchange Server см. статьи базы знаний корпорации Майкрософт:

  • Статья 328841, в которой описывается Exchange и антивирусное программное обеспечение (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841).

  • Статья 823166, содержащая обзор Exchange Server 2003 и антивирусного программного обеспечения (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Статья 306105, в которой описывается отношение корпорации Майкрософт к антивирусному программному обеспечению для Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105).

  • Статья 245822, содержащая рекомендации по исправлению неполадок при использовании Exchange на компьютерах с установленной антивирусной защитой (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Для получения перечня стороннего антивирусного программного обеспечения для Exchange Server см. веб-узел партнеров Exchange Server, посвященный антивирусному программному обеспечению (http://go.microsoft.com/fwlink/?LinkId=16226).


Настройка Trend ScanMail: значение реестра MaxMessageCount — меньше 500
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить значение для MaxMessageCount:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion

Помимо этого, анализатор сервера Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение счетчика записей, перечисленных в атрибуте homeMDBBL каждого хранилища почтовых ящиков. Счетчик этого атрибута представляет количество почтовых ящиков в хранилище почтовых ящиков.

Если анализатор сервера Exchange определит, что сервер Exchange содержит больше 100 почтовых ящиков, а значение MaxMessageCount меньше 500, на экран будет выведено предупреждение.

Trend Micro ScanMail для Microsoft Exchange обеспечивает защиту от вирусов для сервера Exchange. После завершения задачи потоком сканирования ScanMail для Exchange, результаты сканирования записываются в очередь. Если в очереди слишком много элементов, поток сканирования должен ожидать до тех пор, пока не сможет выполнить запись в очередь и освободить поток. Пороговое значение для размера очереди результатов сканирования управляется значением реестра MaxMessageCount. Задавая для MaxMessageCount значение 500, можно оптимизировать производительность приложения ScanMail для Exchange.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion

  3. В правой области дважды щелкните MaxMessageCount.

  4. Введите значение 500 (десятичное).

  5. Закройте редактор реестра и перезапустите службу ScanMail_RealTimeScan и службу Банк данных Microsoft Exchange, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об использовании значения реестра MaxMessageCount см. на веб-узле приложения Trend Micro (http://www.trendmicro.com/en/about/overview.htm)..

Примечание.
Веб-адреса могут измениться, поэтому существует вероятность, что вам не удастся подключиться к упомянутым здесь веб-узлам.

Дополнительные сведения об укреплении защиты среды Exchange от вирусов и червей см. в разделе, посвященном замедлению и прекращений действия вирусов в электронной почте в среде Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47587).

Для получения дополнительных сведений об использовании антивирусного программного обеспечения совместно с сервером Exchange Server см. статьи базы знаний корпорации Майкрософт:

  • 328841, описывающая Exchange и антивирусное программное обеспечение (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • Статья 823166, содержащая обзор Exchange и антивирусного программного обеспечения (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • Статья 306105 об отношении корпорации Майкрософт к антивирусному программному обеспечению для Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • Статья 245822, содержащая рекомендации по исправлению неполадок при использовании Exchange на компьютерах с установленной антивирусной защитой (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Для получения перечня стороннего антивирусного программного обеспечения для Exchange Server см. веб-узел Exchange Server Partners: , посвященный антивирусному программному обеспечению (http://go.microsoft.com/fwlink/?LinkId=16226).


Программа Trend ScanMail настроена на удаление всех файловых вложений
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server считывает несколько параметров реестра, чтобы выяснить, настроен ли ScanMail для Microsoft Exchange на удаление вложений. Считываемые параметры реестра:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption\Advance

Параметр | Описание
Действие | Показывает, какие вложения должны блокироваться, если включена блокировка вложений. Значение 0 показывает, что блокируются все вложения. Значение 3 означает, что администратор указал список расширений, имен файлов или типов файлов. Этот параметр настраивается выбором нужного варианта в диалоговом окне Attachment Blocking Settings в ScanMail Management Console.
EnableAlert | Показывет, включена ли блокировка вложений. Значение 1 показывает, что включена блокировка вложений. Значение 0 показывает, что блокировка вложений отключена. Параметр можно настраивать путем установки флажка (включено) или его снятия (отключено) Enable attachment blocking на странице Virus Scan | Options консоли ScanMail Management.

HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

Значение | Описание
EnableEManager | Показывает, включен ли ScanMail eManager. Значение 1 показывает, что eManager включен. Значение 0 показывает, что отключен. Параметр можно настраивать путем установки флажка (включено) или его снятия (отключено) Enable eManager консоли ScanMail Management . Этот параметр доступен, только если установлено отдельное служебное приложение ScanMail eManager.
EnableWebStoreDelMail | Показывает, что для входящих сообщений включен фильтр ScanMail Active Message Filter. Значение 1 показывает, что Active Message Filter для входящих сообщений включен. Значение 0 показывает, что Active Message Filter для входящих сообщений выключен. Параметр можно настраивать путем установки флажка (включено) или его снятия (отключено) Inbound Messages в диалоговом окне Active Message Filter консоли ScanMail Management Console.

Кроме того, средство анализа Exchange Server считывает следующий параметр реестра, чтобы выяснить, включена ли проверка сообщений с помощью Virus Scanning API (VSAPI):

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Значение 1 для Enabled показывает, что включена проверка VSAPI. Значение 0 показывает, что проверка VSAPI выключена. Параметр можно настраивать путем установки флажка (включено) или снятия (отключено) Enable VS API virus scanning на странице Virus Scan | Options консоли ScanMail Management Console.

Если средство анализа Exchange Server находит, что все эти параметры включены, появляется предупреждение:

  • Проверка VSAPI в ScanMail для Exchange включена

  • EnableAlert имеет значение 1

  • ActionType имеет значение 0

  • EnableEManager имеет значение 1

  • EnableWebStoreDelMail имеет значение 1

Это предупреждение показывает, что приложение ScanMail настроено на удаление всех вложений при следующей запланированной или ручной проверке.

Для устранения этого предупреждения

  1. Проверьте, хотите ли вы удалять вложения.

  2. При необходимости отключите блокировку вложений или измените действие с Delete (удалить) на Quarantine (Поместить в карантин). Это позволит администратору проверить файлы в карантине и сохранить необходимые вложения.

Для получения дополнительных сведений о ScanMail для Microsoft Exchange и ScanMail eManager посетите веб-узел Trend Micro (http://www.trend.com).

Примечание.
Веб-адрес может меняться, поэтому указанный здесь веб-узел может оказаться недоступен.


Служба Trend ScanMail настроена для удаления вложений с определенными именами файлов
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает несколько записей реестра, чтобы определить, настроена ли программа ScanMail для Microsoft Exchange для удаления вложений. Считываются параметры в следующей ветви реестра:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption\Advance

Значение | Описание
ActionType | Определяет, какие вложения блокируются, если включена блокировка вложений. Значение 0 указывает, что блокируются все вложения. Значение 3 указывает, что администратор задал список расширений имен файлов, имен файлов или действительных типов файлов. Данный параметр можно настроить, выбрав соответствующее значение в диалоговом окне Параметры блокирования вложений консоли управления ScanMail.
EnableAlert | Указывает, включена ли блокировка вложений. Значение 1 указывает, что блокировка вложений включена. Значение 0 указывает, что блокировка вложений отключена. Этот параметр можно настроить, установив или сняв флажок Включить блокировку вложений в области Поиск вирусов | Параметры консоли управления ScanMail.
FileName | Строковое значение, разделенное точкой с запятой, содержащее список файлов, подлежащих удалению. При блокировке конкретных файлов данный параметр можно настроить, введя соответствующие имена файлов в диалоговом окне Параметры блокирования вложений консоли управления ScanMail.

HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

Значение | Описание
EnableEManager | Определяет, включен ли диспетчер ScanMail eManager. Значение 1 указывает, что диспетчер eManager включен. Значение 0 указывает, что диспетчер отключен. Данный параметр можно настроить, установив или сняв флажок Включить eManager консоли управления ScanMail. Данный параметр доступен только в том случае, если установлен ScanMail eManager, являющийся отдельным сопутствующим продуктом.
EnableWebStoreDelMail | Определяет, включен ли фильтр ScanMail Active Message Filter для входящих сообщений. Значение 1 указывает, что фильтр Active Message Filter для входящих сообщений включен. Значение 0 указывает, что фильтр Active Message Filter для входящих сообщений отключен. Этот параметр можно настроить, установив или сняв флажокВходящие сообщения в диалоговом окне Active Message Filter консоли управления ScanMail.

Анализатор сервера Exchange также считывает следующую запись реестра, чтобы определить, включено ли VSAPI-сканирование сообщений (Virus Scanning API — интерфейс антивирусного сканирования):

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Значение 1, которое соответствует значению Включено, указывает, что VSAPI-сканирование включено. Значение 0 указывает, что VSAPI-сканирование не включено. Этот параметр можно настроить, установив или сняв флажок Включить поиск вирусов VS API на странице Поиск вирусов | Options консоли управления ScanMail.

Если анализатор сервера Exchange обнаружит, что все условия, перечисляемые ниже, соблюдаются, на экран выводится предупреждение:

  • В ScanMail для Exchange включено VSAPI-сканирование

  • Для параметра EnableAlert задано значение 1

  • Для параметра ActionType задано значение 3

  • Для параметра EnableEManager задано значение 1

  • Для параметра EnableWebStoreDelMail задано значение 1

  • Параметр FileName имеет непустое и ненулевое значение

Это предупреждение указывает, что программа ScanMail настроена для удаления всех вложений с именами файлов, перечисленными в разделе FileName, в ходе следующей запланированной или запускаемой вручную процедуры сканирования.

Чтобы устранить причину появления этого предупреждения

  1. Проверьте, требуется ли удалять вложения с именами файлов, перечисленными в разделе FileName.

  2. При необходимости отключите блокировку вложений или измените выполняемое действие с Удалить на Поместить в карантин. Это позволит администратору проверять помещенные в карантин файлы для поиска вложений, которые требуется сохранить.

Дополнительные сведения о приложении ScanMail для Microsoft Exchange и диспетчере ScanMail eManager см. на веб-узле компании Trend Micro (может быть на английском языке) (http://www.trend.com).

Примечание.
Веб-адреса могут измениться, поэтому существует вероятность, что вам не удастся подключиться к упомянутым здесь веб-узлам.


Служба Trend ScanMail настроена для удаления вложений с определенными расширениями имен файлов
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange считывает несколько записей реестра, чтобы определить, настроена ли служба ScanMail сервера Microsoft Exchange для удаления вложений. Требуемые значения находятся в следующем разделе реестра:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption\Advance

Значение | Описание
ActionType | Определяет, какие вложения должны блокироваться, если блокировка вложений включена. Значение 0 указывает, что блокируются все вложения. Значение 3 указывает, что администратор определил список имен файлов, расширений имен файлов или истинных типов файлов. Эту настройку можно задать, выбрав нужный вариант в диалоговом окне Параметры блокировки вложений на консоли управления ScanMail.
EnableAlert | Определяет, включена ли блокировка вложений. Значение 1 указывает, что блокировка вложений включена. Значение 0 указывает, что она отключена. Эту настройку можно задать, установив (для включения) или сняв (для отключения) флажок Включить блокировку вложений на странице Поиск вирусов | Параметры консоли управления ScanMail.
Extension | Строковое значение в виде списка разделенных точкой с запятой расширений имен файлов для вложений, подлежащих удалению. Эту настройку можно задать, введя расширения для блокируемых вложений в диалоговом окне Параметры блокировки вложений на консоли управления ScanMail.

HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

Значение | Описание
EnableEManager | Определяет, включен ли диспетчер ScanMail eManager. Значение 1 указывает, что eManager включен. Значение 0 указывает, что он отключен. Эту настройку можно задать, установив (для включения) или сняв (для отключения) флажок Включить eManager на консоли управления ScanMail. Данная настройка доступна только в том случае, если диспетчер ScanMail eManager установлен как отдельный сопутствующий продукт.
EnableWebStoreDelMail | Определяет, включен ли фильтр активных сообщений ScanMail для входящих сообщений. Значение 1 указывает, что фильтр активных сообщений включен для входящих сообщений. Значение 0 указывает, что этот фильтр не включен для входящих сообщений. Эту настройку можно задать, установив (для включения) или сняв (для отключения) флажок Входящие сообщения в диалоговом окне Фильтр активных сообщений на консоли управления ScanMail.

Анализатор сервера Exchange также считывает следующую запись реестра, чтобы определить, включено ли VSAPI-сканирование сообщений (Virus Scanning API — интерфейс антивирусного сканирования):

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Значение 1, которое соответствует значению Включено, указывает, что VSAPI-сканирование включено. Значение 0 указывает, что VSAPI-сканирование не включено. Эту настройку можно задать, установив (для включения) или сняв (для отключения) флажок Включить VSAPI-сканирование вирусов на странице Поиск вирусов | Параметры консоли управления ScanMail.

Если анализатор сервера Exchange обнаружит, что все перечисленные ниже условия выполнены, выводится предупреждение:

  • VSAPI-сканирование Включено в ScanMail для Exchange

  • EnableAlert имеет значение 1

  • ActionType имеет значение 3

  • EnableEManager имеет значение 1

  • EnableWebStoreDelMail имеет значение 1

  • Extension не определено

Это предупреждение указывает, что служба ScanMail настроена для удаления всех вложений с расширениями имен, перечисленными в разделе Extension, в ходе следующей процедуры поиска вирусов, запускаемой по расписанию или вручную.

Чтобы устранить причину появления этого предупреждения

  1. Проверьте, действительно ли следует удалять вложения с расширениями имен, перечисленными в разделе Extension.

  2. Если это так, отключите блокировку вложений или замените действие «Удаление» действием «Карантин». Это позволит администратору просматривать файлы, помещенные в карантин, в поисках вложений, которые целесообразно сохранить.

Дополнительные сведения о службе ScanMail для сервера Microsoft Exchange и о диспетчере ScanMail eManager см. на веб-узле Trend Micro (http://www.trend.com).

Примечание.
Веб-адреса могут измениться, поэтому существует вероятность, что вам не удастся подключиться к упомянутым здесь веб-узлам.


Служба Trend ScanMail настроена для двукратной обработки сообщений
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Exchange опрашивает WMI-класс Win32_Service, чтобы определить значение ключа Started для службы ScanMail_RealTimeScan. Значение True указывает, что служба ScanMail_RealTimeScan запущена, а значение False указывает, что служба ScanMail_RealTimeScan не запущена. Служба ScanMail_RealTimeScan является компонентом приложения Trend Micro ScanMail для Microsoft Exchange. Trend Micro ScanMail для Microsoft Exchange обеспечивает антивирусную защиту Exchange.

Средство анализатора сервера Exchange также считывает следующую запись реестра, чтобы определить значение параметра Enabled:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\TransportAVAPI

Значение 1 параметра Enabled указывает, что сканирование вирусов на уровне транспорта (иногда называемое сканирование SMTP) включено, а значение 0 указывает, что сканирование SMTP отключено.

Если анализатор сервера Exchange обнаружит, что ключ Enabled имеет значение 1, а ключ «Started» для службы ScanMail_RealTimeScan имеет значение True, на экран будет выведено предупреждение.

Это предупреждение означает, что сообщения, проходящие через данный компьютер с Exchange Server, дважды сканируются одним приложением и модулем антивирусного сканирования. Двукратное сканирование сообщения, передаваемого через компоненты транспорта и хранилища Exchange Server, приводит к неоправданному расходу ресурсов и не обеспечивает никакой дополнительной защиты или иных преимуществ. Рекомендуется оставить антивирусное сканирование VSAPI (Virus Scanning API) включенным, отключив сканирование почты SMTP с помощью консоли управления ScanMail.

Рекомендуется разворачивать антивирусное программное обеспечение, предназначенное для систем обмена сообщениями, на уровне SMTP-шлюза или серверов Exchange, где размещаются почтовые ящики. Чтобы обеспечить наибольшую безопасность, запускайте антивирусное программное обеспечение на шлюзе, который будет обрабатывать все входящие сообщения MIME, и антивирусный сканер на сервере Exchange, использующем VSAPI 2.5. Кроме того, следует установить клиентское антивирусное программное обеспечение на настольных компьютерах. Если на уровне шлюза или сервера Exchange установлено антивирусное программное обеспечение, предназначенное для систем обмена сообщениями (такое программное обеспечение способно анализировать и сканировать содержимое MIME), то в настольной системе достаточно использовать сканер уровня файлов.

Чтобы устранить причину появления этого предупреждения

  1. Откройте консоль управления ScanMail и введите учетные данные.

  2. Убедитесь, что на странице Поиск вирусов | Параметры установлен флажок Включить поиск вирусов VS API.

  3. На той же странице снимите флажок Включить сканирование почты SMTP.

  4. Нажмите кнопку Применить, чтобы сохранить изменения.

  5. Откройте консоль управления ScanMail.

Дополнительные сведения о приложении Trend Micro ScanMail для Microsoft Exchange см. на веб-узле компании Trend (может быть на английском языке) (http://kb.trendmicro.com/solutions/search).

Примечание.
Веб-адреса могут измениться, поэтому существует вероятность, что вам не удастся подключиться к упомянутым здесь веб-узлам.

Для получения дополнительных сведений об использовании антивирусного программного обеспечения совместно с сервером Exchange Server см. статьи базы знаний корпорации Майкрософт:

  • Статья 328841, описывающая приложение Exchange и антивирусное программное обеспечение (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

  • Статья 823166, содержащая обзор Exchange Server 2003 и антивирусного программного обеспечения (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

  • Статья 306105 об отношении корпорации Майкрософт к антивирусному программному обеспечению для Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=306105)

  • Статья 245822, содержащая рекомендации по исправлению неполадок при использовании Exchange на компьютерах с установленным антивирусным программным обеспечением (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=245822)


Trend ScanMail уменьшает счетчик потоков
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить значение MaxScanningThreadCount, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

Значение параметра MaxScanningThreadCount реестра представляет собой максимальное количество потоков, которые ScanMail приложения Exchange может создать для сканирования. Значение по умолчанию равно 12.

Чтобы определить, включен ли режим VSAPI (Virus Scanning API) сканирования сообщений, анализатор сервера Exchange также считывает следующую запись реестра:

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Значение 1 параметра Enabled указывает, что режим VSAPI сканирования включен. Значение 0 указывает, что VSAPI-сканирование не включено.

Анализатор сервера Exchange также запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_ComputerSystem, чтобы определить значение, заданное для ключа NumberOfProcessors. Это значение представляет собой число процессоров, установленных на компьютере, и включает как физические процессоры, так и логические процессоры. С помощью технологии многопоточности компании Intel физический процессор может быть разделен на два логических процессора.

Анализатор сервера Exchange также запрашивает службу каталогов Active Directory®, чтобы определить количество объектов, принадлежащих классу msExchPrivateMDB. Счетчик этих объектов представляет собой количество хранилищ почтовых ящиков на данном компьютере сервера Exchange.

Если анализатор сервера Exchange обнаружит, что значение MaxScanningThreadCount меньше (2 ? NumberOfProcessors + 1) + 3 + число хранилищ почтовых ящиков) на компьютере сервера Exchange, на котором включено VSAPI-сканирование, на экран будет выведено предупреждение.

Примечание.
Если многопоточность включена, значение параметра NumberOfProcessors будет равно удвоенному количеству физических процессоров. Рекомендуется использовать указанную выше формулу для систем, которые имеют физические процессоры, а также для систем, имеющих как физические, так и логические процессоры.

Это предупреждение указывает, что значение параметра MaxScanningThreadCount реестра, возможно, не оптимизировано для используемой среды. Данное значение должно задаваться так, чтобы, по крайней мере, быть равным предельному размеру вложений, установленному для используемых серверов Exchange. Сведения о соответствующем параметре реестра см. в статье Trend ScanMail уменьшает счетчик пула потоков.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

  3. В правой области дважды щелкните MaxScanningThreadCount.

  4. Введите значение, рекомендуемое анализатором сервера Exchange.

  5. Закройте редактор реестра и перезапустите службу ScanMail_RealTimeScan и службу Банк данных Microsoft Exchange, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о параметре MaxScanningThreadCount реестра см. в решении Trend Micro с идентификатором 13176 (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=13176).

Дополнительные сведения о технологии многопоточности см. на веб-узле компании Intel (http://www.intel.com/technology/hyperthread).

Примечание.
Веб-адреса могут измениться, поэтому существует вероятность, что вам не удастся подключиться к упомянутым здесь веб-узлам.


Trend ScanMail уменьшает счетчик пула потоков
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2006-04-21

Чтобы определить значение ScanningThreadPoolCount, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

Значение параметра ScanningThreadPoolCount реестра представляет собой количество потоков сканирования, которые будут инициализированы и считаны для использования, когда запускается служба «ScanMail для Exchange». Значение по умолчанию равно 12. Когда все потоки, созданные при запуске, использованы, служба «ScanMail для Exchange» создает для использования дополнительные потоки до тех пор, пока не будет достигнуто число потоков, управляемое параметром MaxScanningThreadCount реестра, описанным в статье Trend ScanMail уменьшает счетчик потоков.

Чтобы определить, включен ли режим VSAPI (Virus Scanning API) сканирования сообщений, анализатор сервера Exchange также считывает следующую запись реестра:

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Значение 1 параметра Enabled указывает, что режим VSAPI сканирования включен. Значение 0 указывает, что VSAPI-сканирование не включено.

Анализатор сервера Exchange также запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_ComputerSystem, чтобы определить значение, заданное для ключа NumberOfProcessors. Это значение представляет собой число процессоров, установленных на компьютере, и включает как физические процессоры, так и логические процессоры. С помощью технологии многопоточности компании Intel физический процессор может быть разделен на два логических процессора.

Анализатор сервера Exchange также запрашивает службу каталогов Active Directory®, чтобы определить количество объектов, принадлежащих классу msExchPrivateMDB. Счетчик этих объектов представляет количество хранилищ почтовых ящиков на данном компьютере сервера Exchange.

Если анализатор сервера Exchange обнаружит, что значение ScanningThreadPoolCount меньше (2 ? NumberOfProcessors + 1) + 3 + число хранилищ почтовых ящиков) на компьютере сервера Exchange, на котором включено VSAPI-сканирование, на экран будет выведено предупреждение.

Примечание.
Если многопоточность включена, значение параметра NumberOfProcessors будет равно удвоенному количеству физических процессоров. Рекомендуется использовать указанную выше формулу для систем, которые имеют физических процессоры, а также для систем, имеющих как физические, так и логические процессоры.

Это предупреждение указывает, что значение параметра ScanningThreadPoolCount реестра, возможно, не оптимизировано для используемой среды. Данное значение должно задаваться так, чтобы, по крайней мере, быть равным предельному размеру вложений, установленному для используемых серверов Exchange.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption.

  3. В правой области дважды щелкните ScanningThreadPoolCount.

  4. Введите значение, рекомендуемое анализатором сервера Exchange.

  5. Закройте редактор реестра и перезапустите службу ScanMail_RealTimeScan и службу Банк данных Microsoft Exchange, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о технологии многопоточности см. на веб-узле компании Intel (http://www.intel.com/technology/hyperthread).

Примечание.
Веб-адреса могут измениться, поэтому существует вероятность, что вам не удастся подключиться к упомянутым здесь веб-узлам.


Средство Trend ScanMail выполняется в режиме отладки
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2006-06-22

Чтобы определить значение раздела реестра ModuleName, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\Tools\Debug

Значение реестра ModuleName указывает имя используемого файла модуля отладки.

Анализатор сервера Exchange также считывает следующую запись реестра, чтобы определить, включено ли VSAPI-сканирование сообщений (Virus Scanning API — интерфейс антивирусного сканирования):

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Значение 1, которое соответствует значению Включено, указывает, что VSAPI-сканирование включено. Значение 0 указывает, что VSAPI-сканирование не включено.

Если анализатор сервера Exchange обнаруживает, что включено VSAPI-сканирование и при этом присутствует значение ModuleName, отличное от нуля, выводится предупреждение.

Выполнение в режиме отладки влечет существенное снижение производительности, так как предполагает ведение фоновой диагностической трассировки. Если не стоит задача устранить неполадку, для решения которой требуется выполнить средство ScanMail для Exchange в режиме отладки, данный режим следует отключить.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\Software\TrendMicro\ScanMail for Exchange\Tools\Debug.

  3. В правой области дважды щелкните ModuleName.

  4. Удалите значение этой записи, оставив строку пустой. Не удаляйте сам раздел ModuleName.

  5. Закройте редактор реестра и перезапустите службу ScanMail_RealTimeScan и службу Информационное хранилище Microsoft Exchange, чтобы изменения вступили в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052) (Описание реестра Microsoft Windows).

Дополнительные сведения о проверке отключения режима отладки см. в материале Trend Micro Solution ID 119149 (http://esupport.trendmicro.com/support/viewxml.do?ContentID=en-119149).

Примечание.
Сведения о веб-узлах сторонних компаний в этом разделе предоставлены для оказания помощи в нахождении необходимой технической информации. Эти URL-адреса могут быть изменены без предварительного уведомления.


Служба Trend ScanMail Mail Action установлена на сервере Exchange, но не запущена
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Service, чтобы определить, установлено ли программное обеспечение Trend Micro ScanMail для Exchange и выполняется ли служба ScanMail_MailAction на компьютере с Exchange.

Анализатор сервера Exchange также запрашивает WMI-класс Win32_Service, чтобы определить, какое значение задано для параметра Started в службе «Банк данных Microsoft Exchange»: True или False.

Значение False указывает, что служба «Банк данных Microsoft Exchange» не выполняется на компьютере с Exchange Server. Значение True указывает, что служба «Банк данных Microsoft Exchange» выполняется.

Если анализатор сервера Exchange обнаруживает, что служба «Банк данных Microsoft Exchange» выполняется и программное обеспечение Trend Micro ScanMail для Exchange установлено, но служба ScanMail_MailAction не запущена, то на экран выводится предупреждение.

Trend Micro ScanMail для Exchange обеспечивает защиту от вирусов для Exchange Server. Ниже перечислены возможные причины остановки службы Trend ScanMail, а также способы устранения этой проблемы.

  • Возможно, на сервере Exchange выполняется пробная или оценочная версия программного обеспечения, срок действия которого уже истек. В этом случае может быть необходимо переустановить Trend ScanMail. Чтобы можно было продолжить использование программного обеспечения, необходимо по крайней мере активизировать его.

  • Возможно, администратор случайно остановил службу ScanMail_MailAction . Убедитесь, что служба настроена для автоматического запуска, а затем запустите ее.

  • Червь, вирус или другая программа могула остановить службу. Убедитесь, что служба настроена для автоматического запуска, а затем запустите ее. Если служба продолжает неожиданно останавливаться без выдачи сообщений об ошибке, убедитесь, что компьютер не заражен и при необходимости выполните дезинфекцию системы.

Рекомендуется разворачивать антивирусное программное обеспечение, предназначенное для систем обмена сообщениями, на уровне SMTP-шлюза или серверов Exchange, где размещаются почтовые ящики. Для обеспечения максимальной защиты рекомендуется устанавливать антивирусное программное обеспечение на уровне шлюза, сканирующего входящие MIME-сообщения, а также сканер на сервере Exchange с VSAPI 2.5. Кроме того, следует установить клиентское антивирусное программное обеспечение на настольных компьютерах. Если на уровне шлюза или сервера Exchange установлено антивирусное программное обеспечение, предназначенное для систем обмена сообщениями (такое программное обеспечение способно анализировать и сканировать содержимое MIME), то в настольной системе достаточно использовать сканер уровня файлов.

Чтобы запустить службу ScanMail_MailAction

  1. Откройте оснастку «Службы» консоли MMC.

  2. Щелкните правой кнопкой мыши службу ScanMail_MailAction и в контекстном меню выберите команду Свойства.

  3. Убедитесь, что на вкладке Общие страницы свойств ScanMail_MailAction для параметра Тип запуска задано значение Авто. Если установлено другое значение, выберите значение «Авто», нажмите кнопку Применить, а затем кнопку ОК.

  4. Щелкните правой кнопкой мыши службу ScanMail_MailAction и в контекстном меню выберите команду Запустить.

  5. Закройте оснастку «Службы».
  • Дополнительные сведения о защите среды Exchange см. в разделе, посвященном обезвреживанию вирусов, передаваемых по электронной почте, в Exchange 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47587).

Для получения дополнительных сведений об использовании антивирусного программного обеспечения совместно с сервером Exchange Server см. статьи базы знаний корпорации Майкрософт:

  • Статья 328841, описывающая Exchange и антивирусное программное обеспечение (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • Статья 823166, содержащая обзор Exchange и антивирусного программного обеспечения (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • Статья 306105 об отношении корпорации Майкрософт к антивирусному программному обеспечению для Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • Статья 245822, содержащая рекомендации по исправлению неполадок при использовании Exchange на компьютерах с установленной антивирусной защитой (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Для получения перечня стороннего антивирусного программного обеспечения для Exchange Server см. веб-узел Exchange Server Partners Antivirus (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=16226).


Служба реального времени Trend ScanMail установлена на этом сервере Exchange, но была остановлена
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange опрашивает WMI-класс Win32_Service, чтобы определить, установлено ли приложение Trend Micro ScanMail для Microsoft Exchange и работает ли служба ScanMail_RealTimeScan на компьютере сервера Exchange. Если анализатор сервера Exchange обнаружит установленное приложение Trend Micro ScanMail для Microsoft Exchange, но служба ScanMail_RealTimeScan запущена не будет, будет отображено предупреждение.

Trend Micro ScanMail для Microsoft Exchange обеспечивает антивирусную защиту Exchange. Некоторые причины, по которым служба ScanMail_RealTimeScan может быть остановлена, и устранение этих причин приведены ниже:

  • Версия программного обеспечения, работающего на сервере Exchange, может быть пробной, и срок ее действия истек. В этом случае следует переустановить Trend Micro ScanMail для Microsoft Exchange. Чтобы продолжить использование программного обеспечения, необходимо хотя бы его активировать.

  • Администратор мог случайно остановить службу ScanMail_RealTimeScan. Проверьте, что служба запускается автоматически, затем запустите службу.

  • Вредоносный вирус-червь, другой вирус или программа остановила службу. Убедитесь, что служба запускается автоматически, затем запустите службу. Если служба продолжает неожиданно останавливаться без соответственных событий ошибок, убедитесь, что компьютер не заражен вирусом и при необходимости устраните вирусную опасность.

Обычно рекомендуется развертывать антивирусное программное обеспечение, предназначенное для систем обмена сообщениями, на шлюз SMTP или на серверы Exchange, которые содержат почтовые ящики. Чтобы обеспечить наибольшую безопасность, запускайте антивирусное программное обеспечение на шлюзе, который будет обрабатывать все входящие сообщения MIME, и антивирусный сканер на сервере Exchange, использующем VSAPI (Virus Scanning API) версии 2.5. Кроме того, следует установить антивирусное программное обеспечения на компьютерах пользователей. Если антивирусное программное обеспечение, предназначенное для систем обмена сообщениями (может анализировать и сканировать MIME), работает на шлюзе или на сервере Exchange, сканирование файлов на рабочих станциях пользователей будет достаточным.

Чтобы запустить службу ScanMail_RealTimeScan

  1. Откройте оснастку Службы консоли MMC.

  2. Щелкните правой кнопкой мыши ScanMail_RealTimeScan и в контекстном меню выберите Свойства.

  3. Убедитесь, что на вкладке Общие страницы свойств ScanMail_RealTimeScan Тип запуска выставлен как Авто. Если нет, выберите автоматический тип запуска, нажмите кнопку Применить, затем ОК.

  4. Щелкните правой кнопкой мыши службу ScanMail_RealTimeScan, затем щелкните Пуск.

  5. Закройте оснастку Службы.
  • Сведения о защите среды Exchange от вирусов, передаваемых по электронной почте, см. на странице, посвященной борьбе с вирусами, распространяемыми по электронной почте, в среде Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47587).

Дополнительные сведения об использовании антивирусного программного обеспечения совместно с сервером Exchange Server см. в статьях базы знаний корпорации Майкрософт:

  • 328841, посвященная Exchange и антивирусному программному обеспечению (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • Статья 823166, содержащая обзор Exchange и антивирусного программного обеспечения (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166);

  • Статья 306105, посвященная отношению корпорации Майкрософт к антивирусному программному обеспечению для Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105);

  • 245822, содержащая рекомендации по исправлению неполадок при использовании Exchange на компьютерах с установленной антивирусной защитой (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Список стороннего антивирусного программного обеспечения см. на веб-узле, посвященном партнерам Exchange по антивирусному программному обеспечению (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=16226).


Отключение расширений клиента сторонних производителей
Анализатор сервера Microsoft Exchange — статьи > Программное обеспечение сторонних производителей >

Дата последнего изменения раздела: 2006-04-21

Средство анализа Microsoft Exchange Server определило, что используется один из видов программного обеспечения сторонних производителей:

  • Расширение Microsoft Office Outlook сторонних производителей, например антивирусное программное обеспечение или программное обеспечение факсов.

  • Приложение сторонних производителей с доступом к серверу Exchange

  • Программное обеспечение сторонних производителей для синхронизации мобильных устройств

Рекомендуется уточнить, какие виды приложений сторонних производителей используются пользователями, а затем принять решение об ограничении или удалении данных приложений. Необходимо помнить, что программное обеспечение сторонних производителей зачастую вызывает перегрузку серверов.

Отключение расширений сторонних производителей в Outlook

  1. В программе Outlook в меню Сервис выберите команду Параметры.

  2. В Параметрах выберите вкладку Другое и выберите Дополнительные параметры.

  3. В разделе Дополнительные параметры выберите Управление расширениями.

  4. Снимите флажки всех расширений сторонних производителей.

  5. Нажмите кнопку OK.

  6. Перезапустите Outlook.

Дополнительные сведения

  • Для получения дополнительных сведений о работе Exchange Server см. Руководство по производительности и масштабируемости Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Для получения дополнительных сведений по устранению неполадок в работе Exchange Server см. Руководство по устранению неполадок Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Транспорт
Анализатор сервера Microsoft Exchange — статьи >

Дата последнего изменения раздела: 2005-11-18

Статьи в этой части содержат сведения о параметрах, оцениваемых средством анализатора сервера Microsoft® Exchange для компонентов транспорта Exchange. Кроме того, в этих статьях указывается, какие следует предпринять действия в связи с полученной от анализатора сервера Exchange информацией об относящихся к транспорту ошибках, предупреждениях и отличающихся от заданных по умолчанию конфигураций.


Не зарегистрирована команда 8BITMIME
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-08-18

Средство анализатора Microsoft® Exchange передает ESMTP-команду (Extended Simple Mail Transfer Protocol) EHLO в порт 25 удаленного сервера и анализирует ответ, чтобы определить, поддерживает ли удаленный сервер ESMTP-команду 8BITMIME.

Если ответ, полученный от удаленного сервера, не содержит строки «250-8BITMIME», на экран выводится предупреждение.

Приложение Exchange Server 2003 использует характерные для Exchange расширенные SMTP-команды для взаимодействия с другими серверами, на которых в организации выполняется сервер Exchange. По сравнению со стандартным протоколом SMTP расширенные SMTP-команды, характерные для Exchange, обеспечивают большую эффективность взаимодействия. Если поддержка для множества ESMTP-команд отключена, это может негативно сказаться на быстродействии сервера Exchange.

Эта ошибка показывает, что удаленный сервер не поддерживает ESMTP-команду 8BITMIME. Эта ошибка не указывает, является или нет удаленный сервер сервером Exchange. В любом случае сообщения, для которых требуется расширение 8BITMIME, не маршрутизируются.

Чтобы устранить эту ошибку, проверьте содержимое SMTP-очередей на наличие сообщений, для которых требуется расширение 8BITMIME.

Дополнительные сведения об удалении и восстановлении поддержки по умолчанию для этих команд см. в базе знаний Майкрософт, в статье 257569, содержащей инструкции по отключению ESMTP-команд в Exchange 2000 Server и Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569).

Дополнительные сведения об использовании ESMTP-команд сервером Exchange см. в разделе, описывающем правильную загрузку протокола SMTP для Exchange, в руководстве по транспорту и маршрутизации сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=71800).


ADAM LDAP Port Identified
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-07-23

Для выявления портов, используемых службой каталогов ADAM на пограничном транспортном сервере, анализатор Microsoft Exchange считывает следующие параметры реестра:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\EdgeTransportRole\AdamSettings\MsExchangeAdam\LdapPort

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\EdgeTransportRole\AdamSettings\MsExchangeAdam\SslPort

ADAM — это служба каталогов LDAP, специально разработанная для работы с приложениями, поддерживающими службу каталогов. ADAM хранит и реплицирует только сведения, связанные с определенным приложением, не требует развертывания на контроллере домена и не зависит от службы каталогов Active Directory. ADAM не обеспечивает проверку подлинности или авторизацию сетевых операционных систем.

В сервере Microsoft Exchange Server 2007 роль пограничного транспортного сервера использует ADAM для хранения сведений о конфигурации и данных получателей для фильтрации содержимого. Если ADAM синхронизирован с Active Directory, его также можно использовать для поиска получателей с целью обеспечения безопасности сообщений.

Данные из Active Directory в ADAM отправляются через подключение LDAP с использованием указанных ниже портов, отличных от используемых по умолчанию.

  • LDAP: порт 50389/TCP

  • Secure LDAP: порт 50636/UDP

Когда анализатор Exchange определяет, какие порты используются ADAM, он выводит сообщение с рекомендациями.

Рекомендуется заблокировать для внешнего доступа все порты, без которых можно обойтись.

Чтобы устранить эту проблему, проверьте, что порты, идентифицированные анализатором Exchange в качестве используемых ADAM, закрыты для внешнего доступа.

Внимание!
Порт 50636/UDP используется службой Exchange EdgeSync и должен быть открыт, если необходимо использовать возможности EdgeSync.
Блокировка внешнего доступа для выявленных портов ADAM с помощью брандмауэра Windows

  1. Нажмите кнопку Пуск, выберите пункт Выполнить, введите команду firewall.cpl и нажмите кнопку ОК.

  2. Откройте вкладку Исключения.

  3. Выберите каждую программу и службу, указанную в поле Имя, и нажмите кнопку Изменить, чтобы просмотреть открытые порты.

  4. Проверьте, чтобы в списке не было портов, указанных анализатором Exchange в качестве используемых ADAM.

  5. Если указаны идентифицированные порты, убедитесь в том, что они не используются для других необходимых взаимодействий, и закройте их, сняв соответствующий флажок в окне Изменение службы.

  6. Чтобы закрыть окно настройки брандмауэра Windows, дважды нажмите кнопку ОК.

Дополнительные сведения

Дополнительные сведения о портах, проверке подлинности и шифровании всех путей данных, используемых сервером Exchange Server 2007, см. в статье «Пути к данным: справка по безопасности» (http://go.microsoft.com/fwlink/?LinkId=95630) (эта ссылка может указывать на содержимое полностью или частично на английском языке).


Установлен подключаемый модуль защиты от вирусов
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-08-18

Чтобы определить, установлен ли подключаемый модуль автоматической защиты электронной почты из Интернета Symantec Antivirus Corporate Edition 9.x, средство анализатора сервера Microsoft® Exchange сканирует следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail

Наличие этой ветви реестра указывает, что подключаемый модуль автоматической защиты электронной почты из Интернета Symantec Antivirus Corporate Edition 9.x установлен на сервере, на котором выполняется сервер Exchange.

Чтобы определить, включен ли подключаемый модуль автоматической защиты электронной почты из Интернета Symantec Antivirus Corporate Edition 9.x, анализатор сервера Microsoft® Exchange также считывает следующую запись реестра:

HKLM\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail\RealTimeScan\OnOff

Значение, равное 1 для OnOff, указывает, что подключаемый модуль автоматической защиты включен. Значение, равное 0, указывает, что модуль автоматической защиты не включен.

Анализатор сервера Exchange выводит на экран предупреждение, если выполняются следующие условия:

  • Подключаемый модуль автоматической защиты электронной почты из Интернета Symantec Antivirus Corporate Edition 9.x установлен.

  • Подключаемый модуль автоматической защиты электронной почты из Интернета Symantec Antivirus Corporate Edition 9.x не включен.

Это предупреждение указывает, что необходимо проверить установку и настройку подключаемого модуля на соответствие рекомендациям поставщика.

Дополнительные сведения о рекомендациях поставщика для данного подключаемого модуля см. в описании оптимального использования модуля автоматической защиты Symantec AntiVirus Corporate Edition 9.x на сервере Microsoft Exchange (может быть на английском языке) (http://service1.symantec.com/SUPPORT/ent-security.nsf/c9b1ac1936fbf63488256e77006521df/3d1bcbc855fce10288256e9e007e01f0?OpenDocument&src=bar_sch_nam).

Примечание.
Сведения о веб-узлах сторонних компаний в этом разделе предоставлены для оказания помощи в нахождении необходимой технической информации. URL-адреса могут быть изменены без предварительного уведомления.


Подключаемый модуль защиты от вирусов включен
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-08-18

Чтобы определить, установлен ли подключаемый модуль автоматической защиты электронной почты из Интернета Symantec Antivirus Corporate Edition 9.x, средство анализатора сервера Microsoft® Exchange сканирует следующую запись реестра:

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail

Наличие этой записи реестра указывает, что подключаемый модуль автоматической защиты электронной почты из Интернета Symantec Antivirus Corporate Edition 9.x установлен на сервере, на котором выполняется сервер Exchange.

Чтобы определить, включен ли подключаемый модуль автоматической защиты электронной почты из Интернета Symantec Antivirus Corporate Edition 9.x, анализатор сервера Microsoft® Exchange также считывает следующую запись реестра:

HKLM\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail\RealTimeScan\OnOff

Значение, равное 1 для OnOff, указывает, что подключаемый модуль автоматической защиты включен. Значение, равное 0, указывает, что модуль автоматической защиты не включен.

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Подключаемый модуль автоматической защиты электронной почты из Интернета Symantec Antivirus Corporate Edition 9.x установлен.

  • Подключаемый модуль автоматической защиты электронной почты из Интернета Symantec Antivirus Corporate Edition 9.x включен.

Эта ошибка указывает, что необходимо проверить установку и настройку подключаемого модуля на соответствие рекомендациям поставщика.

Дополнительные сведения о рекомендациях поставщика для данного подключаемого модуля см. в описании оптимального использования модуля автоматической защиты Symantec AntiVirus Corporate Edition 9.x на сервере Microsoft Exchange (может быть на английском языке) (http://service1.symantec.com/SUPPORT/ent-security.nsf/c9b1ac1936fbf63488256e77006521df/3d1bcbc855fce10288256e9e007e01f0?OpenDocument&src=bar_sch_nam).

Примечание.
Сведения о веб-узлах сторонних компаний в этом разделе предоставлены для оказания помощи в нахождении необходимой технической информации. URL-адреса могут быть изменены без предварительного уведомления.


Включено ведение журналов СК
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, включено ли ведение журнала скрытых копий (СК), средство анализатора сервера Microsoft® Exchange считывает следующий параметр реестра:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\JournalBCC

Если анализатор сервера Exchange обнаруживает, что значение для JournalBCC установлено равным 1, выводится сообщение о нестандартной конфигурации.

Ведение журнала СК представляет собой ведение журнала только сообщений с добавленной возможностью записывать получателей СК. Когда ведение журналов СК включено, Exchange Server записывает всех получателей, включая получателей СК, которые известны на исходном сервере. Если этот список получателей включает списки скрытого распространения, списки распространения на основе очередей или списки распространения, которые распространяются на другой сервер, получатели для этих списков не включаются в электронную почту, записываемую в журнал.

Функция ведения журналов СК включается посредством настройки раздела реестра. Дополнительные сведения о настройке этого раздела реестра см. в базе знаний Майкрософт в статье 810999, посвященной потере информации СК при ведении журнала сообщений в Exchange 2000" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810999).

Чтобы включить ведение журналов СК на конкретном сервере, необходимо сначала настроить ведение журнала только для сообщений. Параметр JournalBCC является неактивным, когда выполняются следующие условия:

  • Значение параметра JournalBCC реестра установлено равным единице.

  • Ведение журнала только для сообщений не включено для любой базы данных на одном и том же сервере.

Для ведения журнала сообщений может потребоваться большой объем ресурсов дискового пространства, процессора, а также сетевых ресурсов. Поэтому ведение журнала требует всестороннего планирования процесса развертывания. Ведение журнала следует включать только в контексте структуры всеобъемлющего решения данной задачи.

Данное сообщение о нестандартной конфигурации можно не принимать во внимание, если выполняются следующие условия:

  • Специфика деятельности организации предусматривает необходимость ведения журнала.

  • В организации развернута структура решения ведения журнала.

В противном случае следует отключить функцию ведения журнала. Отключение ведения журнала осуществляется при отключении ведения журнала в базе данных.

Чтобы отключить ведение журнала только сообщений в базе данных

  1. В программе диспетчер Exchange, последовательно разверните Серверы, <сервер Exchange>, <группа хранилищ>, а затем щелкните правой кнопкой мыши хранилище почтовых ящиков.

  2. На вкладке Общие снимите флажок Архивировать все сообщения, отправленные или полученные почтовыми ящиками в этом хранилище.

  3. Подождите 15 минут, чтобы указанные изменения были внесены в хранилище Exchange. Не следует перезапускать службу базы данных Microsoft Exchange.

Если требуется, чтобы анализатор сервера Exchange Server больше не отображал это сообщение, следует удалить раздел реестра JournalBCC. Удаление раздела реестра JournalBCC не требуется для отключения функции ведения журналов.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неполадки. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы удалить раздел реестра JournalBCC

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к параметру реестра HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\

  3. В правой области найдите и удалите значение JournalBCC.

  4. Закройте редактор реестра.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о порядке развертывания решений по ведению журнала см. в разделе Ведение журнала с помощью сервера Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).


Команда BDAT не зарегистрирована
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-08-18

Средство анализатора Microsoft® Exchange передает ESMTP-команду (Extended Simple Mail Transfer Protocol) EHLO в порт 25 удаленного сервера и анализирует ответ, чтобы определить, поддерживает ли удаленный сервер ESMTP-команду BDAT.

Если анализатор сервера Exchange получает от удаленного сервера ответ со строчным значением, которое указывает на неисправимую ошибку, на экран выводится сообщение об ошибке.

Приложение Exchange Server 2003 использует характерные для Exchange расширенные SMTP-команды для взаимодействия с другими серверами, на которых в организации выполняется сервер Exchange. По сравнению со стандартным протоколом SMTP расширенные SMTP-команды, характерные для Exchange, обеспечивают большую эффективность взаимодействия. Если поддержка для множества ESMTP-команд отключена, это может негативно сказаться на быстродействии сервера Exchange.

Эта ошибка показывает, что удаленный сервер не поддерживает ESMTP-команду BDAT. Ошибка не указывает, является или нет удаленный сервер сервером Exchange. В любом случае сообщения, для которых требуется расширение BDAT, не маршрутизируются.

Чтобы устранить эту ошибку, проверьте содержимое SMTP-очередей на наличие сообщений, для которых требуется расширение BDAT.

Дополнительные сведения об удалении и восстановлении поддержки по умолчанию для этих команд см. в базе знаний Майкрософт, в статье 257569, содержащей инструкции по отключению ESMTP-команд в Exchange 2000 Server и Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569).

Дополнительные сведения об использовании ESMTP-команд сервером Exchange см. в разделе, описывающем правильную загрузку протокола SMTP для Exchange, в руководстве по транспорту и маршрутизации сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkID=71800).


Сервер-плацдарм должен проверить ограничения по доставке, устанавливаемые группой рассылки для RGC
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-09-18

Чтобы определить, установлены ли ограничения по доставке на основе членства в группе рассылки для каждого объекта соединителя группы маршрутизации (msExchRoutingGroupConnector), обнаруженного в службе Active Directory®, средство анализатора сервера Microsoft® Exchange запрашивает следующие атрибуты.

dLMemRejectPerms | Содержит имена доменов списка рассылки, члены которого не могут посылать почту через соединитель данной группы маршрутизации.
dLMemSubmitPerms | Содержит имена доменов списка рассылки, члены которого могут посылать почту через соединитель данной группы маршрутизации.

Если анализатор сервера Exchange обнаружит соединители групп маршрутизации, имеющие ограничения по доставке на основе членства в группе рассылки, анализатор сервера Exchange запросит атрибут msExchSourceBridgeheadServersDN найденных соединителей групп маршрутизации, чтобы определить, установлен ли анализируемый сервер как сервер-плацдарм для каких-либо из этих соединителей.

Наконец, чтобы определить, присутствует ли в реестре параметр CheckConnectorRestrictions и настроен ли он, анализатор сервера Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

Анализатор сервера Exchange выводит на экран предупреждение, если выполняются следующие условия:

  • Соединитель группы маршрутизации используется для ограничения доставки на основе членства в группе рассылки.

  • Анализируемый сервер Exchange назначается в качестве сервера-плацдарма для соединителя этой группы маршрутизации и выполняет задачу расширения группы рассылки.

  • Параметр CheckConnectorRestrictions присутствует, установлен равным 1 и, следовательно, включен.

Поведения классификатора по умолчанию состоят в рекурсивном развертывании групп рассылки и проверке ограничений для каждого сообщения, проходящего через систему.

При создании группы маршрутизации указывается группа серверов, которая может взаимодействовать напрямую друг с другом. Чтобы серверы в разных группах маршрутизации могли взаимодействовать друг с другом, необходимо соединить группы маршрутизации.

Предпочтительным методом соединения является соединитель группы маршрутизации, так как этот соединитель разработан и предназначен специально для соединения групп маршрутизации.

Серверы, которые могут отправлять почту через соединитель группы маршрутизации, являются серверами-плацдармами. Сервер-плацдарм — это комбинация виртуального SMTP-сервера (Simple Mail Transfer Protocol) и сервера Exchange, отвечающего за доставку всех сообщений через соединитель.

При создании соединителя группы маршрутизации можно задать использование всех серверов как серверов-плацдармов для соединителя или можно указать, что только серверы выбранного множества должны действовать как серверы-плацдармы для этого соединителя. Назначенные плацдармы являются серверами, которые выполняют задачу расширения членства в группе рассылки.

Когда почта отправляется с помощью соединителей групп маршрутизации, имеющих ограничения по доставке на основе членства в группах рассылки, классификатор сообщений должен развернуть структуру членства в группе рассылки, получить полный список различающихся имен членов, а затем сравнить список различающихся имен с различающимися именами отправителей в списке. Когда различающиеся имена в обоих списках совпадают, выполняется операция разрешения доступа или операция запрета доступа. Если группа рассылки вложена в другую группу рассылки, вложенная группа рассылки также разворачивается.

Это предупреждение указывает, что ограничения по доставке на основе членства в группе рассылки могут привести к попаданию сообщений, предназначенных для плацдарма, в очередь при проверке классификатором ограничений.

Чтобы устранить причины появления этого предупреждения, выполните следующие действия:

  • Настройте соединитель группы маршрутизации на локальную группу маршрутизации согласно сведениям, содержащимся в базе знаний Майкрософт, в статье 329171, описывающей ситуацию, когда доставка почты задерживается, если получатели настроены с ограничениями по доставке на основе членства в группе (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • Используйте выделенный и более надежный сервер глобального каталога в качестве назначенного сервера-плацдарма для соединителя.

  • Настройте отдельные почтовые ящики, а не группы рассылки для ограничений по доставке согласно сведениям, содержащимся в базе знаний Майкрософт, в статье 812298, описывающей ситуацию, когда доставка почты замедляется после настройки ограничений по доставке на основе списка рассылки (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Рассмотрите возможность реализации фильтрации SMTP-отправителей.

  • Для серверов, на которых выполняется Microsoft Exchange Server 2003 с пакетом обновления 2 (SP2) или более поздняя версия, рассмотрите возможность реализации неиерархической проверки ограничений. Для серверов, на которых выполняются версии Exchange, предшествующие Exchange 2003 с пакетом обновления 2 (SP2), рассмотрите возможность обновления до Exchange 2003 с пакетом обновления 2 (SP2).

Дополнительные сведения

Дополнительные сведения о неиерархической проверке ограничений см. в разделе Рассмотрите возможность неиерархической проверки ограничений.

Дополнительные сведения о фильтрации SMTP-отправителей см. в разделе, описывающем включение фильтрации отправителей, в руководстве по администрированию Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=71832).

Дополнительные сведения о воздействии ограничения групп рассылок на поток почты Exchange см. в следующих статьях базы знаний Майкрософт:

  • Статья 329171, описывающая ситуацию, когда доставка почты задерживается, если получатели настроены с ограничениями по доставке на основе членства в группе (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • Статья 895407, описывающая ситуацию в Exchange Server 2003, когда доставка сообщений в локальные и во внешние почтовые ящики вопреки ожиданиям замедляется после настройки ограничений по доставке на основе групп рассылок (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • Статья 839949, описывающая устранение неполадок почтового транспорта и групп рассылок в Exchange 2000 Server и в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).


Сервер-плацдарм должен проверить ограничения по доставке, устанавливаемые группой рассылки для SMTP-соединителя
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-08-21

Средство анализатора сервера Microsoft® Exchange запрашивает следующие атрибуты для каждого объекта SMTP-соединителя (Simple Mail Transfer Protocol) (msExchRoutingSMTPConnector), обнаруженного в службе Active Directory®, чтобы определить, установлены ли ограничения по доставке на основе членства в группе рассылки.

dLMemRejectPerms | Содержит имена доменов списка рассылки, членам которого не разрешается посылать почту через данный SMTP-соединитель.
dLMemSubmitPerms | Содержит имена доменов списка рассылки, членам которого разрешается посылать почту через данный SMTP-соединитель.

Если анализатор сервера Exchange обнаружит SMTP-соединители, имеющие ограничения по доставке на основе членства в группе рассылки, анализатор сервера Exchange запросит атрибут msExchSourceBridgeheadServersDN обнаруженных SMTP-соединителей, чтобы определить, установлен ли анализируемый сервер как сервер-плацдарм для каких-либо из этих соединителей.

Наконец, чтобы определить, присутствует ли в реестре параметр CheckConnectorRestrictions и настроен ли он, анализатор сервера Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

Анализатор сервера Exchange выводит на экран предупреждение, если выполняются следующие условия:

  • SMTP-соединитель используется для ограничения доставки на основе членства в группе рассылки.

  • Анализируемый сервер Exchange назначается в качестве сервера-плацдарма для SMTP-соединителя и выполняет задачу расширения группы рассылки.

  • Параметр CheckConnectorRestrictions присутствует, установлен равным 1 и, следовательно, включен.

Поведения классификатора по умолчанию состоят в рекурсивном развертывании групп рассылки и проверке ограничений для каждого сообщения, проходящего через систему.

Когда почта отправляется с помощью соединителя, принимающего или блокирующего сообщения из группы рассылки, классификатор сообщений должен развернуть структуру членства в группе рассылки, получить полный список различающихся имен членов, а затем сравнить список различающихся имен с различающимися именами отправителей в списке. Когда различающиеся имена в обоих списках совпадают, выполняется операция разрешения доступа или операция запрета доступа. Если группа рассылки вложена в другую группу рассылки, вложенная группа рассылки также разворачивается.

Назначенный плацдарм является сервером, который выполняет задачу расширения членства в группе рассылки.

Проверка ограничений управляется параметром CheckConnectorRestrictions реестра, который должен быть установлен на сервере-плацдарме Exchange, являющемся источником для проверяемого соединителя. Если указать ограничение, но не создать параметр CheckConnectorRestrictions реестра, ограничение не проверяется.

По умолчанию проверка ограничений соединителя выключена. Быстродействие системы значительно уменьшается, когда группы рассылки развертываются, и выполняется проверка ограничений для каждого сообщения, проходящего через систему.

Это предупреждение указывает, что ограничения по доставке на основе членства в группе рассылки могут привести к попаданию сообщений, предназначенных для плацдарма, в очередь при проверке классификатором ограничений.

Чтобы устранить причины появления этого предупреждения, выполните следующие действия:

  • Назначьте выделенную группу маршрутизации для ограничений соединителя и настройте ее на локальную группу маршрутизации согласно сведениям, содержащимся в базе знаний Майкрософт, в статье 329171, описывающей ситуацию, когда доставка почты замедляется, если получатели настроены с ограничениями по доставке на основе членства в группе (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • Используйте выделенный и более надежный сервер глобального каталога в качестве назначенного сервера-плацдарма для соединителя.

  • Настройте отдельные почтовые ящики, а не группы рассылки для ограничений по доставке согласно сведениям, содержащимся в базе знаний Майкрософт, в статье 812298, описывающей ситуацию, когда доставка почты замедляется после настройки ограничений по доставке на основе списка рассылки (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Рассмотрите возможность реализации фильтрации SMTP-отправителей.

  • Для серверов, на которых выполняется Microsoft Exchange Server 2003 с пакетом обновления 2 (SP2) или более поздняя версия, рассмотрите возможность реализации неиерархической проверки ограничений. Для серверов, на которых выполняются версии Exchange, предшествующие Exchange 2003 с пакетом обновления 2 (SP2), рассмотрите возможность обновления до Exchange 2003 с пакетом обновления 2 (SP2).

Дополнительные сведения

Дополнительные сведения о неиерархической проверке ограничений см. в разделе Рассмотрите возможность неиерархической проверки ограничений.

Дополнительные сведения о фильтрации SMTP-отправителей см. в разделе, описывающем включение фильтрации отправителей, в руководстве по администрированию Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=71832).

Дополнительные сведения о воздействии ограничения групп рассылок на поток почты Exchange см. в следующих статьях базы знаний Майкрософт:

  • Статья 329171, описывающая ситуацию, когда доставка почты задерживается, если получатели настроены с ограничениями по доставке на основе членства в группе (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • Статья 895407, описывающая ситуацию в Exchange Server 2003, когда доставка сообщений в локальные и во внешние почтовые ящики вопреки ожиданиям замедляется после настройки ограничений по доставке на основе групп рассылок (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • Статья 839949, описывающая устранение неполадок почтового транспорта и групп рассылок в Exchange 2000 Server и в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).


Не удается подключиться к порту 25 основного маршрутизатора
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-08-24

Чтобы определить значение атрибута msExchRoutingMasterDN для каждой группы маршрутизации в текущей административной группе, анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®. Затем анализатор сервера Exchange пытается открыть сокет-подключение к основному маршрутизатору через TCP-порт 25. Если анализатор сервера Exchange не получает ожидаемый настраиваемый отклик 25 доступен, возвращается ошибка.

Эта ошибка означает, что основной маршрутизатор на TCP-порту 25 недоступен и что в результате могут происходить ошибки маршрутизации. Чтобы исправить эту ошибку, можно устранить проблему доступа к основному маршрутизатору или назначить новый основной маршрутизатор.

Диагностика проблемы доступа к основному маршрутизатору

  1. Можно ли с помощью программы telnet обратиться к порту 25 с самого основного маршрутизатора? Если нет, проблема не связана с сетью.

  2. Все ли подсоединено? Правильно ли работает все оборудование?

  3. Правильно ли работает и настроена служба DNS?

  4. Правильно ли работает маршрутизатор?

  5. Существуют ли сетевые экраны или приложения препятствующие подключению?
Чтобы назначить новый основной маршрутизатор

  1. Откройте диспетчер Exchange.

  2. Щелкните правой кнопкой мыши значок Имя организации (Exchange) в верхней части дерева в левой области (где имя организации — имя, выбранное вами для своей организации Exchange 2000) и в контекстном меню выберите пункт Свойства.

  3. Щелкните Отображать административные группы, щелкните Отображать группы маршрутизации, а затем нажмите кнопку OK.

  4. Разверните узел Административные группы, разверните нужную <административную_группу> и затем разверните Группы маршрутизации.

  5. Разверните группу маршрутизации и щелкните Члены.

  6. В правой области щелкните правой кнопкой мыши компьютер Exchange, который следует настроить в качестве хозяина группы маршрутизации, и щелкните Сделать хозяином.

Дополнительные сведения об устранении неполадок маршрутизации, настройке топологий маршрутизацию и концепциях расширенной маршрутизации см. в разделе «Устранение неполадок маршрутизации» руководства по транспорту и маршрутизации в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=47579).


Невозможно подключиться к хозяину маршрутизации по порту 691
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-08-24

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchRoutingMasterDN для каждой группы маршрутизации в текущей административной группе. Затем анализатор сервера Exchange пытается открыть подключение через сокет к хозяину маршрутизации по TCP-порту 691. Если анализатор сервера Analyzer не получит ожидаемый ответ 691 доступен, на экран будет выведено сообщение об ошибке.

Эта ошибка указывает, что к хозяину маршрутизации нет доступа по порту 691, а это может привести к неполадкам с маршрутизацией. Чтобы исправить эту ошибку, можно попытаться устранить неисправность, связанную с подключением к хозяину маршрутизации, или назначить нового хозяина маршрутизации.

Чтобы устранить неисправность, связанную с хозяином маршрутизации

  1. Можно ли подключиться с помощью telnet к порту 691 на самом хозяине маршрутизации? Если нет, то эта неисправность не связана с сетью.

  2. Все ли подключено? Правильно ли работает все оборудование?

  3. Правильно ли настроена и работает DNS?

  4. Правильно ли работает маршрутизатор?

  5. Могут ли брандмауэры препятствовать подключению?
Чтобы назначить нового хозяина маршрутизации

  1. Откройте диспетчер Exchange

  2. Щелкните правой кнопкой мыши значок Имя организации (Exchange) в верхней части дерева в левой области (где имя организации — имя, выбранное вами для своей организации Exchange 2000) и в контекстном меню выберите пункт Свойства.

  3. Щелкните Отображать административные группы, щелкните Отображать группы маршрутизации, а затем нажмите кнопку OK.

  4. Последовательно разверните узлы Административные группы, <административная_группа> и Группы маршрутизации.

  5. Разверните группу маршрутизации, затем щелкните Члены.

  6. В правой области щелкните правой кнопкой мыши компьютер Exchange, который следует настроить в качестве хозяина группы маршрутизации, и щелкните ??Сделать хозяином??.

Дополнительные сведения об устранении неполадок, связанных с маршрутизацией, настройке топологий, а также о дополнительных концепциях маршрутизации см. в руководстве по транспорту и маршрутизации в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).


Не удается найти ни записей узлов, ни записей почтового обменника
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-05-10

Средство анализа Microsoft Exchange выполняет поиск в DNS с целью получения записей почтового обменника (MX) для домена. Если средство анализа Exchange не может получить от DNS-сервера записи почтового обменника для домена, оно пытается выполнить поиск в DNS для получения записей узлов (A) доменов, которым сервер Exchange пытается отправить сообщения.

Средство анализа Exchange Server выводит сообщение об ошибке, если выполняются указанные ниже условия.

  • Средство анализа Exchange не может получить записи почтового обменника для домена.

  • Операции просмотра DNS не удается вернуть IP-адрес для какой-либо из записей (А) узлов.

Эта ошибка указывает на то, что записи почтового обменника и записи (А) узлов в DNS, по-видимому, отсутствуют для домена и серверов. Помимо других задержек маршрутизации и служб, эта ошибка может приводить к архивации сообщений, предназначенных для удаленных доменов, в очереди Удаленная доставка сервера Exchange.

Чтобы определить почтовые узлы, отправляющий сервер Exchange проверяет запись почтового обменника. Далее отправляющий сервер извлекает из записи почтового обменника IP-адрес, определяя запись адреса (запись «А»).

Просмотр DNS на наличие записей почтового обменника и записей (А) узлов может завершиться сбоем по следующим причинам:

  • DNS-сервер выключен или недостижим из-за отказа сети или по другим причинам.

  • Запись (А) узла для удаленного сервера отсутствует на DNS-сервере, так как эта запись недоступна или неправильна.

  • DNS-сервер не настроен на поддержку динамических обновлений записей узлов.

  • В ответ на нежелательные сообщения электронной почты, которые могут компрометировать исходные домены, система пытается отправить отчеты о недоставке. Если это происходит, такие сообщения следует удалить (см. ссылку на средство удаления и архивации почтовых сообщений с ошибками для сервера Exchange Server в разделе «Дополнительные сведения»).

Чтобы убедиться, что DNS-сервер находится в оперативном режиме, и записи почтового обменника и узлов существуют

  1. Убедитесь, что DNS-сервер работает, выполнив одну или несколько следующих проверок:

    • Узнайте состояние DNS-сервера, воспользовавшись программой администрирования службы DNS на DNS-сервере.

    • Перезапустите DNS-сервер. Дополнительные сведения см. в описании процедур запуска, останова, временного останова и перезапуска DNS-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Убедитесь в возможности DNS-сервера реагировать на внешние воздействия, выполнив команду nslookup. Дополнительные сведения см. в описании инструкций по проверке реакции DNS-сервера на внешние воздействия с помощью команды nslookup (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=63000).

  2. Используйте команду nslookup, чтобы убедиться, что записи почтового обменника настроены правильно. Дополнительные сведения см. в разделе, описывающем инструкции по использованию команды «Nslookup» для проверки настройки записи почтового обменника, который содержится в части, посвященной проверке структуры и настройки DNS, из руководства по транспорту и маршрутизации сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).

  3. Используйте команду nslookup, чтобы проверить, что запись (А) узла существует на DNS-сервере. Дополнительные сведения см. в описании проверки существования записей ресурса «А» в службе DNS (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=63001).

  4. Если запись ресурса (А) узла не существует, добавьте или измените вручную запись ресурса «А» или настройте DNS-сервер для включения динамических обновлений записей:

    • Добавьте вручную запись ресурса «А». Дополнительные сведения см. в описании процедуры добавления записи ресурса в зону DNS (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=63002).

    • Измените вручную запись ресурса «А». Инструкции см. в описании процедуры изменения существующей записи ресурса (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=63014).

    • Настройте DNS-сервер на активизацию динамических обновлений записей узлов. Дополнительные сведения см. в базе знаний Майкрософт в статье 816592, описывающей настройку динамических обновлений DNS в Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592).

Дополнительные сведения

  • Сведения об использовании в Exchange Server 2003 службы DNS для разрешения внешних IP-адресов см. разделе, описывающем зависимости транспорта для Exchange Server 2003, из руководства по транспорту и маршрутизации сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Сведения о разрешении имен DNS см. в базе знаний Майкрософт в статье 322856, описывающей настройку службы DNS для использования с сервером Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

  • Сведения об устранении проблем службы DNS см. в описании неполадок службы DNS (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=63003).

  • Дополнительные сведения о наблюдении за системой в Exchange Server 2003 см. в разделе «Наблюдение за системой с помощью пакета управления Exchange» статьи Пакет управления Exchange Server 2003 для MOM 2005 (http://go.microsoft.com/fwlink/?LinkId=47573) (на английском языке).

  • Сведения о записях ресурсов (А) узлов см. в описании управления записями ресурсов (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=63004).

  • Сведения об удалении и архивации почтовых сообщений с ошибками в Exchange Server см. в статье «Удаление и архивация почтовых сообщений с ошибками в Exchange Server» (http://go.microsoft.com/fwlink/?LinkId=84239 (на английском языке).


Не удается идентифицировать отправителя
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-08-08

Чтобы определить, существует ли соответствие для указываемого пользователем адреса SMTP (Simple Mail Transfer Protocol), средство анализатора сервера Microsoft® Exchange запрашивает значение атрибута proxyAddress службы каталогов Active Directory® для всех объектов пользователя.

Если анализатору сервера Exchange не удается найти соответствие proxyAddress для указываемого пользователем SMTP-адреса локального отправителя, на экран выводится сообщение об ошибке.

Эта ошибка указывает, что справедливо одно из следующих условий:

  • Локальный отправитель не существует в локальной организации сервера Exchange.

  • Указываемый пользователем SMTP-адрес локального отправителя был неправильно введен.

Чтобы устранить эту ошибку, проверьте указываемый пользователем SMTP-адрес локального отправителя и повторите операцию.

Чтобы проверить адрес локального отправителя

  1. Запустите диспетчер Exchange.

  2. Разверните параметр Получатели, а затем — Все глобальные списки адресов.

  3. Щелкните правой кнопкой мыши Глобальный список адресов по умолчанию и в контекстном меню выберите пункт Свойства.

  4. Щелкните Просмотр, чтобы вывести на экран SMTP-адреса получателей, включенные в глобальный список адресов по умолчанию.

  5. Убедитесь, что указанный локальный отправитель отображается, и отметьте для себя его SMTP-адрес.


Установлен приемник событий CatDbgSink
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange Server считывает данные в свойстве LM/SmtpSvc/%SMTPINSTANCE%/EventManager/EventTypes в метабазе IIS, чтобы определить, установлено ли приложение CatDbgSink для диагностики потока почты на компьютере, на котором работает сервер Exchange 2000 Server или Exchange Server 2003.

Приложение CatDbgSink представляет собой приемник событий, который может использоваться для устранения проблем потока почты на компьютерах сервера Exchange 2000 Server или Exchange Server 2003. Если приложение CatDbgSink установлено на сервере Exchange, анализатор сервера Exchange отображает предупреждение о том, что приложение CatDbgSink установлено и должно использоваться только при диагностике проблем потока почты.

Приложение CatDbgSink обычно предоставляется клиентам для устранения проблем потока почты на компьютерах Exchange 2000 Server или Exchange Server 2003. Обычно приложение CatDbgSink устанавливается под руководством службы поддержки продуктов Майкрософт (PSS). После того, как приложение CatDbgSink установлено и успешно зарегистрировано, клиенты могут использовать приложение CatDbgSink для создания журналов для сбора диагностической информации о проблемах потока почты на сервере Exchange.

Иногда приложение CatDbgSink не удается удалить с производственного сервера Exchange после того, как были локализованы и устранены проблемы. Если приложение CatDbgSink не удалено с компьютера Exchange, приложение CatDbgSink создает значительную нагрузку, которая может вызвать на сервере Exchange нежелательные проблемы производительности. После устранения проблем потока почты на производственном сервере Exchange необходимо удалить приложение CatDbgSink.

Чтобы устранить причину появления этого предупреждения

  1. Перейдите в локальную папку установки приложения CatDbgSink. Эта папка содержит следующие файлы установки: Setup.vbs, CatDbgSink.dll, CatDbgSink.pdb и MustReadMe.txt.

  2. В окне командной строки измените каталог на местоположение файлов установки на локальном диске, например: C:\CatDbgSink.

  3. В командной строке введите cscript setup.vbs uninstall 1

Примечание.
Число 1 в командной строке определяет экземпляр виртуального SMTP-сервера, начиная с 1.

Дополнительные сведения о приложении CatDbgSink можно получить в службах поддержки продуктов Майкрософт (http://support.microsoft.com/default.aspx?pr=cntactms).


Классификатор отключен для экземпляра SMTP
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange Server считывает данные, обнаруженные в свойстве LM/SmtpSvc/%SMTPInstance%/RoutingSources в метабазе IIS, чтобы определить состояние классификатора сообщений для каждого экземпляра виртуального сервера SMTP на компьютерах, на которых работает сервер Exchange 2000 Server или Exchange Server 2003.

Анализатор сервера Exchange определяет, существует ли раздел SMTPDSUseCat в метабазе IIS и затем сообщает о результатах. Если анализатор сервера Exchange обнаружит, что атрибут SMTPDSUseCat существует и установлен в положение отключения 0X000000, анализатор сервера Exchange выводит на экран сообщение об ошибке. Если классификатор сообщений отключен, на сервере Exchange возникают серьезные проблемы с потоком почты.

По умолчанию, когда служба SMTP установлена на компьютере, на котором работает сервер Microsoft Windows®°2000 Server или Microsoft Windows Server™ 2003, в метабазе IIS создается раздел SMTPDSUseCat. По умолчанию раздел SMTPDSUseCat отключен (0). После установки сервера Exchange раздел SMTPDSUseCat метабазы IIS удаляется. При этом включается классификатор сообщений. При установке службы SMTP или сервера Exchange Server на компьютер, на котором работает сервер Windows 2000 Server или Windows Server 2003, по умолчанию создается экземпляр (1) виртуального сервера STMP. Классификатор сообщений может отключиться в ситуации, когда установлен сервер Exchange, а служба SMTP удалена и затем повторно установлена на компьютер. Классификатор сообщений может также отключиться в ситуации, когда установлено программное обеспечение стороннего поставщика или возникла ошибка конфигурации средств администрирования.

Примечание.
Каждый экземпляр виртуального сервера SMTP на сервере Exchange управляет состоянием классификатора сообщений независимо.

Классификатор сообщений проверяет каждое сообщение, приходящее в каждый экземпляр виртуального сервера SMTP, и задает параметры. Сообщения могут быть отправлены в локальное хранилище, на удаленный узел с помощью агента передачи сообщений, или на удаленный узел с помощью протокола SMTP. Классификатор сообщений также обрабатывает расширение списка рассылки. Классификатор сообщений анализирует сообщения, которые поступают на SMTP-сервер, и определяет, что необходимо делать с сообщениями. Классификатор — это дополнительный модуль для расширенного механизма очередей, который выполняет LDAP-запросы (Lightweight Directory Access Protocol) на серверах глобального каталога по TCP-порту 3268. По существу, классификатор — это набор приемников событий, которые выполняют расширенное разрешение адресов по каждому сообщению, проходящему через расширенный механизм очередей.

Примечание.
Средство переустановки SMTP (Smtpreinstall.exe) расположено на компакт диске с пакетом обновления 2 сервера Exchange 2000 Server в папке \SUPPORT\UTILS\I386.
Чтобы включить классификатор сообщений с помощью средства переустановки SMTP

  1. Скопируйте файл Smtpreinstall.exe в папку \Exchsrvr\Bin.

  2. Дважды щелкните файл Smtpreinstall.exe из папки \Exchsrvr\Bin Folder.

  3. Для запуска сервера Exchange нажмите кнопку ОК в диалоговом окне переустановки SMTP сервера Microsoft Exchange.

Если необходимо посмотреть свойства в метабазе, это можно сделать, установив служебную программу Metaedit 2.2 для служб IIS 4.0/5.0 или служебную программу IIS Metabase Explorer для служб IIS 6.0.

Внимание!
Непосредственно изменять метабазу не рекомендуется.

Дополнительные сведения о классификаторе сообщений и доступных служебных программах метабазы IIS см. в следующих статьях базы знаний Майкрософт:

  • 290290, "XIMS: Cannot Send Mail After Re-Installing the IIS SMTP Service" (XIMS: невозможно послать сообщение электронной почты после переустановки службы IIS SMTP)http://go.microsoft.com/fwlink/?linkid=3052&kbid=821829)

  • 319885, "XCON: Messages Sent in the Exchange 2000 Server Organization Are Not Delivered" (XCON: сообщение, посланное в организацию сервера Exchange 2000 Server, не доставлено)http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

  • 231729, "XCON: DSUseCat Key and the Message Categorizer" (XCON: раздел DSUseCat и классификатор сообщений) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).

  • 232068, "How To: Download, Install, and Remove the IIS MetaEdit 2.2 Utility" (Инструкции по загрузке, установке и удалению служебной программы IIS MetaEdit 2.2) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232068)

Чтобы загрузить приложение IIS 6.0 Resource Kit Tools, см. IIS 6.0 Resource Kit Tools (http://go.microsoft.com/fwlink/?LinkId=33134)


За последние 24 часа было зарегистрировано предупреждение классификатора (идентификатор: 6004)
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-10-05

Средство анализа Microsoft® Exchange Server запрашивает класс инструментария WMI Win32_NTLogEvent для определения того, было ли в течение последних 24 часов зарегистрировано предупреждение о событии 6004 для MSExchangeTransport.

Если средство анализа Exchange Server обнаружит, что предупреждение о событии 6004 было зарегистрировано для MSExchangeTransport в течение последних 24 часов, появится предупреждение.

Предупреждение указывает, что классификатором обнаружена ошибка при попытке обработать сообщение.

Классификатор сообщений проверяет сообщения, поступающие на SMTP-сервер, и определяет, что делать с ними дальше. Сообщения могут направляться в локальное хранилище информации, на удаленный компьютер через агент передачи сообщений (MTA) или на удаленный компьютер по протоколу SMTP. Классификатор также обрабатывает расширение списка рассылки. Классификатор — это дополнительный модуль для системы организации очереди, выполняющий запросы LDAP по серверам глобального каталога через TCP-порт 3268. Классификатор это, по сути, набор приемников событий, выполняющих усовершенствованное преобразование адресов для каждого сообщения, проходящего через систему организации очереди. Классификатор выполняет преобразование адресов и пересылку сообщений электронной почты, устанавливает метки преобразования содержимого, расширяет списки рассылки, применяет глобальные параметры и создает уведомления о состоянии доставки. Классификатор также выполняет поиск альтернативного маршрута к получателю, ветвление, ведение журналов и многие другие функции.

Как только сообщение попадает в классификатор, он определяет отправителя путем поиска адреса в атрибутах адреса прокси-сервера в службе каталогов Active Directory®. Классификатор также определяет получателя, просматривая все адреса в атрибуте адресов прокси-серверов в Active Directory. Например, если в списке есть список рассылки, он раскрывает список и добавляет в него эти контакты, если на сервере разрешено расширение списка рассылки.

Possible causes of MSExchangeTransport Предупреждение 6004 может быть вызвано следующими событиями:

  • Неисправности Directory Service Access (DSAccess).

  • Задержка или сбои при репликации директорий.

  • Перегрузка серверов глобального каталога.

  • Неисправности DNS-сервера.

Устранение причин появления этого предупреждения

  • Проверьте, имеет ли сервер Exchange Server связь с одним или несколькими серверами глобального каталога. Для этого можно использовать сетевой монитор Windows.

  • Проверьте создаваемые уведомления о состоянии доставки (DSN). Уведомления о доставке могут включать в себя отчеты о недоставке (NDR). Уведомления о доставке описывают сообщения о непроходящих сбоях в доставке сообщений и проходящих сбоях, которые зачастую могут становиться непроходящими.

  • Воспользуйтесь средством отслеживания сообщений, чтобы устранить неполадки, связанные с сообщениями, которые классификатор долго не может обработать.

  • Воспользуйтесь средством Archive Sink для архивации и анализа сообщений, поступающих на сервер Exchange Server и исходящих с него.

  • Проверьте счетчики производительности классификатора с помощью системного монитора.

Для получения информации о событиях и ошибках Exchange Server 2003 см. веб-узел центра сообщений о событиях и ошибках по адресу http://go.microsoft.com/fwlink/?LinkId=34258 (на английском языке).

Для ознакомления со списком уведомлений о доставке и сообщений о недоставке, создаваемых Exchange серверами Server и Microsoft Windows Small Business Server, см. статью 284204 базы знаний корпорации Майкрософт «Уведомления о состоянии доставки в Exchange Server и Small Business Server» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204.

Для получения дополнительных сведений об использовании центра отслеживания сообщений сервера Exchange Server см. следующие статьи базы знаний Майкрософт:

  • Статья 262162 «XADM: отслеживание сообщения с помощью центра отслеживания сообщений» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 246856 «XADM: Включение отслеживания сообщений в Exchange 2000 Server» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • 821905, «Идентификаторы событий отслеживания сообщений в Exchange Server 2003» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905 (эта ссылка может указывать содержимое полностью или частично на английском языке).

  • 823864, «Усовершенствованные функции отслеживания сообщений в Exchange Server 2003» по адресуhttp://go.microsoft.com/fwlink/?linkid=3052&kbid=823864 (эта ссылка может указывать на содержимое полностью или частично на английском языке)

Для получения дополнительных сведений об устранении неполадок, связанных с классификатором сообщений, см. веб-трансляцию службы поддержки Майкрософт «Exchange 2000 Server: классификатор сообщений и устранение неполадок с недоставкой сообщений» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137 (на английском языке).

Для получения дополнительных сведений о средстве Archive Sink см. статью 307798 базы знаний Майкрософт «Средство Archive Sink из пакета обновления 2» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

Для получения общих сведений об устранении неполадок, связанных с передачей сообщений, см. следующие ресурсы и статьи базы знаний Майкрософт:

  • 821910, «Устранение неполадок, связанных с передачей сообщений, в Exchange Server 2003» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 257265 «Общие сведения об устранении неполадок транспорта в Exchange 2000 Server и Exchange Server 2003» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • 895853, «Устранение неисправностей, связанных с ретрансляцией почты в Exchange Server 2003 и Exchange 2000 Server» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853.

  • Раздел «Устранение проблем, связанных с потоком почты и протоколом SMTP» в руководстве по транспортировке и маршрутизации сервера Exchange (http://go.microsoft.com/fwlink/?LinkID=67875) (на английском языке).

Счетчики производительности классификатора сообщений публикуются отдельно для каждого экземпляра виртуального SMTP-сервера. Список доступных счетчиков производительности, связанных с классификатором сообщений, см. в статье 231734 базы знаний Майкрософт «XCON: счетчики системного монитора для классификатора сообщений» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734 (эта ссылка может указывать на содержимое полностью или частично на английском языке).


За последние 24 часа было зарегистрировано предупреждение классификатора (идентификатор: 6006)
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-10-06

Средство анализа Microsoft® Exchange Server запрашивает класс инструментария WMI Win32_NTLogEvent для определения того, было ли в течение последних 24 часов зарегистрировано предупреждение о событии 6006 для MSExchangeTransport.

Если средство анализа Exchange Server обнаружит, что предупреждение о событии 6006 было зарегистрировано для MSExchangeTransport в течение последних 24 часов, появится предупреждение.

Это предупреждение обозначают, что сообщения задерживаются в классификаторе сообщений.

Классификатор сообщений проверяет сообщения, поступающие на SMTP-сервер, и определяет, что делать с ними дальше. Сообщения могут направляться в локальное хранилище информации, на удаленный компьютер через агент передачи сообщений (MTA) или на удаленный компьютер по протоколу SMTP. Классификатор также обрабатывает расширение списка рассылки. Классификатор — это дополнительный модуль для системы организации очереди, выполняющий запросы LDAP по серверам глобального каталога через TCP-порт 3268. Классификатор это, по сути, набор приемников событий, выполняющих усовершенствованное преобразование адресов для каждого сообщения, проходящего через систему организации очереди. Классификатор выполняет преобразование адресов и пересылку сообщений электронной почты, устанавливает метки преобразования содержимого, расширяет списки рассылки, применяет глобальные параметры и создает уведомления о состоянии доставки. Классификатор также выполняет поиск альтернативного маршрута к получателю, ветвление, ведение журналов и многие другие функции.

Как только сообщение попадает в классификатор, он определяет отправителя путем поиска адреса в атрибутах адреса прокси-сервера в службе каталогов Active Directory®. Классификатор также определяет получателя, просматривая все адреса в атрибуте адресов прокси-серверов в Active Directory. Например, если в списке есть список рассылки, он раскрывает список и добавляет в него эти контакты, если на сервере разрешено расширение списка рассылки.

Possible causes of MSExchangeTransport Предупреждение 6006 может быть вызвано следующими событиями:

  • Антивирусное программное обеспечение неправильно настроено или устарело.

  • Группа рассылки чрезмерно расширена.

  • Получатели журнала настроены неправильно.

  • Для объектов Exchange в службе Active Directory неправильно настроены разрешения.

Устранение причин появления этого предупреждения

  • Убедитесь, что антивирусное приложение уровня файлов настроено так, чтобы исключать определенные директории сервера Exchange Server. Описание папок, которые не следует включать в сканирование компьютеров, на которых выполняется сервер Microsoft Exchange Server, см. в статье 823166 базы знаний корпорации Майкрософт «Использование антивирусных программ на сервере Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Убедитесь, что используется новейшая версия антивирусного программного обеспечения.

  • Проанализируйте ограничения по доставке для группы рассылки и удалите ненужные ограничения.

  • Проверьте конфигурацию ведения журналов на наличие неправильно настроенных параметров.

  • Проверьте объекты Exchange в службе Active Directory на предмет неправильно настроенных разрешений.

Дополнительные сведения

Дополнительные сведения о неиерархической проверке ограничений см. в разделе Рассмотрите возможность неиерархической проверки ограничений.

Дополнительные сведения о влиянии ограничения групп рассылок на поток почты сервера Exchange см. в следующих статьях базы знаний Майкрософт:

  • Статья 895407 «В Exchange Server 2003 доставка сообщений в локальные и внешние почтовые ящики неожиданно замедляется после настройки ограничений по доставке на основе групп рассылок» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 839949 «Устранение неполадок почтового транспорта и групп рассылок в Exchange 2000 Server и Exchange Server 2003» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 812298 «Доставка почты замедляется после настройки ограничений по доставке на основе списка рассылки» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

Дополнительные сведения о развертывании решения по ведению журналов см. в статье «Ведение журналов в сервере Exchange Server» по адресу http://go.microsoft.com/fwlink/?LinkId=47581 (на английском языке).

Дополнительные сведения о возможных причинах предупреждения классификатора с идентификатором 6006 см. в статье 922256 базы знаний Майкрософт «Сообщения электронной почты блокируются в очереди ожидания поиска директории в организации сервера Exchange Server 2003» по адресуhttp://go.microsoft.com/fwlink/?linkid=3052&kbid=922256 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

Для получения информации о событиях и ошибках Exchange Server 2003 см. веб-узел центра сообщений о событиях и ошибках по адресу http://go.microsoft.com/fwlink/?LinkId=34258 (на английском языке).

Для ознакомления со списком уведомлений о доставке и сообщений о недоставке, создаваемых Exchange серверами Server и Microsoft Windows Small Business Server, см. статью 284204 базы знаний корпорации Майкрософт «Уведомления о состоянии доставки в Exchange Server и Small Business Server» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204.

Для получения дополнительных сведений об устранении неполадок, связанных с классификатором сообщений, см. веб-трансляцию службы поддержки Майкрософт «Exchange 2000 Server: классификатор сообщений и устранение неполадок с недоставкой сообщений» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137 (на английском языке).

Для получения общих сведений об устранении неполадок, связанных с передачей сообщений, см. следующие ресурсы и статьи базы знаний Майкрософт:

  • 821910, «Устранение неполадок, связанных с передачей сообщений, в Exchange Server 2003» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 257265 «Общие сведения об устранении неполадок транспорта в Exchange 2000 Server и Exchange Server 2003» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • 895853, «Устранение неисправностей, связанных с ретрансляцией почты в Exchange Server 2003 и Exchange 2000 Server» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853.

  • Раздел «Устранение проблем, связанных с потоком почты и протоколом SMTP» в руководстве по транспортировке и маршрутизации сервера Exchange (http://go.microsoft.com/fwlink/?LinkID=67875) (на английском языке).

Счетчики производительности классификатора сообщений публикуются отдельно для каждого экземпляра виртуального SMTP-сервера. Список доступных счетчиков производительности, связанных с классификатором сообщений, см. в статье 231734 базы знаний Майкрософт «XCON: счетчики системного монитора для классификатора сообщений» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734 (эта ссылка может указывать на содержимое полностью или частично на английском языке).


За последние 24 часа было зарегистрировано предупреждение классификатора (идентификатор: 6008)
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-10-06

Средство анализа Microsoft® Exchange Server запрашивает класс инструментария WMI Win32_NTLogEvent для определения того, было ли в течение последних 24 часов зарегистрировано предупреждение о событии 6008 для MSExchangeTransport.

Если средство анализа Exchange Server обнаружит, что предупреждение о событии 6008 было зарегистрировано для MSExchangeTransport в течение последних 24 часов, появится предупреждение.

Предупреждение указывает, что классификатором обнаружена ошибка при попытке обработать сообщение.

Классификатор сообщений проверяет сообщения, поступающие на SMTP-сервер, и определяет, что делать с ними дальше. Сообщения могут направляться в локальное хранилище информации, на удаленный компьютер через агент передачи сообщений (MTA) или на удаленный компьютер по протоколу SMTP. Классификатор также обрабатывает расширение списка рассылки. Классификатор — это дополнительный модуль для системы организации очереди, выполняющий запросы LDAP по серверам глобального каталога через TCP-порт 3268. Классификатор это, по сути, набор приемников событий, выполняющих усовершенствованное преобразование адресов для каждого сообщения, проходящего через систему организации очереди. Классификатор выполняет преобразование адресов и пересылку сообщений электронной почты, устанавливает метки преобразования содержимого, расширяет списки рассылки, применяет глобальные параметры и создает уведомления о состоянии доставки. Классификатор также выполняет поиск альтернативного маршрута к получателю, ветвление, ведение журналов и многие другие функции.

Как только сообщение попадает в классификатор, он определяет отправителя путем поиска адреса в атрибутах адреса прокси-сервера в службе каталогов Active Directory®. Классификатор также определяет получателя, просматривая все адреса в атрибуте адресов прокси-серверов в Active Directory. Например, если в списке есть список рассылки, он раскрывает список и добавляет в него эти контакты, если на сервере разрешено расширение списка рассылки.

Possible causes of MSExchangeTransport Предупреждение 6008 может быть вызвано следующими событиями:

  • Неисправности Directory Service Access (DSAccess).

  • Задержка или сбои при репликации директорий.

  • Перегрузка серверов глобального каталога.

  • Неисправности DNS-сервера.

  • Чрезмерное расширение группы рассылки.

Устранение причин появления этого предупреждения

  • Проверьте, установлена ли связь сервера Exchange Server с одним или несколькими серверами глобального каталога. Для этого можно использовать сетевой монитор Windows.

  • Проверьте создаваемые сообщения о состоянии доставки (DSN). Уведомления о доставке могут включать в себя отчеты о недоставке (NDR). Уведомления о доставке описывают сообщения о непроходящих сбоях в доставке сообщений и проходящих сбоях, которые зачастую могут становиться непроходящими.

  • Воспользуйтесь средством отслеживания сообщений, чтобы устранить неполадки, связанные с сообщениями, которые классификатор долго не может обработать.

  • Воспользуйтесь средством Archive Sink для архивации и анализа сообщений, поступающих на сервер Exchange Server и исходящих с него.

  • Проверьте счетчики производительности классификатора с помощью системного монитора.

  • Проанализируйте ограничения по доставке для группы рассылки и удалите ненужные ограничения.

Для получения информации о событиях и ошибках Exchange Server 2003 см. веб-узел центра сообщений о событиях и ошибках по адресу http://go.microsoft.com/fwlink/?LinkId=34258 (на английском языке).

Для ознакомления со списком уведомлений о доставке и сообщений о недоставке, создаваемых Exchange серверами Server и Microsoft Windows Small Business Server, см. статью 284204 базы знаний корпорации Майкрософт «Уведомления о состоянии доставки в Exchange Server и Small Business Server» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204.

Для получения дополнительных сведений об использовании центра отслеживания сообщений сервера Exchange Server см. следующие статьи базы знаний Майкрософт:

  • Статья 262162 «XADM: отслеживание сообщения с помощью центра отслеживания сообщений» по адресу http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 246856 «XADM: Включение отслеживания сообщений в Exchange 2000 Server» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • 821905, «Идентификаторы событий отслеживания сообщений в Exchange Server 2003» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905 (эта ссылка может указывать содержимое полностью или частично на английском языке).

  • 823864, «Усовершенствованные функции отслеживания сообщений в Exchange Server 2003» по адресуhttp://go.microsoft.com/fwlink/?linkid=3052&kbid=823864 (эта ссылка может указывать на содержимое полностью или частично на английском языке)

Для получения дополнительных сведений об устранении неполадок, связанных с классификатором сообщений, см. веб-трансляцию службы поддержки Майкрософт «Exchange 2000 Server: классификатор сообщений и устранение неполадок с недоставкой сообщений» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137 (на английском языке).

Для получения дополнительных сведений о средстве Archive Sink см. статью 307798 базы знаний Майкрософт «Средство Archive Sink из пакета обновления 2» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

Дополнительные сведения о неиерархической проверке ограничений см. в разделе Рассмотрите возможность неиерархической проверки ограничений.

Дополнительные сведения о влиянии ограничения групп рассылок на поток почты сервера Exchange см. в следующих статьях базы знаний Майкрософт:

  • Статья 895407 «В Exchange Server 2003 доставка сообщений в локальные и внешние почтовые ящики неожиданно замедляется после настройки ограничений по доставке на основе групп рассылок» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 839949 «Устранение неполадок почтового транспорта и групп рассылок в Exchange 2000 Server и Exchange Server 2003» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 812298 «Доставка почты замедляется после настройки ограничений по доставке на основе списка рассылки» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

Для получения общих сведений об устранении неполадок, связанных с передачей сообщений, см. следующие ресурсы и статьи базы знаний Майкрософт:

  • 821910, «Устранение неполадок, связанных с передачей сообщений, в Exchange Server 2003» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 257265 «Общие сведения об устранении неполадок транспорта в Exchange 2000 Server и Exchange Server 2003» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • 895853, «Устранение неисправностей, связанных с ретрансляцией почты в Exchange Server 2003 и Exchange 2000 Server» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853.

  • Раздел «Устранение проблем, связанных с потоком почты и протоколом SMTP» в руководстве по транспортировке и маршрутизации сервера Exchange (http://go.microsoft.com/fwlink/?LinkID=67875) (на английском языке).

Счетчики производительности классификатора сообщений публикуются отдельно для каждого экземпляра виртуального SMTP-сервера. Список доступных счетчиков производительности, связанных с классификатором сообщений, см. в статье 231734 базы знаний Майкрософт «XCON: счетчики системного монитора для классификатора сообщений» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734 (эта ссылка может указывать на содержимое полностью или частично на английском языке).


Включена фильтрация подключений
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, указано ли в свойстве msExchServerBindingsFiltering объекта виртуального сервера SMTP, что для экземпляра виртуального сервера SMTP включена фильтрация подключений.

Анализатор сервера Exchange также запрашивает службу Active Directory, чтобы определить, указано ли в свойствах msExchSmtpConnectionRulesPriority, msExchSMTPGlobalIPAcceptList или msExchSMTPGlobalIPDenyList, что фильтрация подключений также включена на уровне глобальных параметров.

Анализатор сервера Exchange выводит на экран предупреждение, если выполняются следующие условия:

  • Для данного экземпляра виртуального сервера SMTP включена фильтрация подключений.

  • Фильтрация подключений включена на уровне глобальных параметров.

Это предупреждение указывает, что фильтрация подключений включена. В целом фильтрация подключений не является причиной неполадок. Однако в том случае, если ведется устранение неполадок потока почты на данном конкретном сервере, может возникнуть необходимость проверить конфигурацию фильтра или временно отключить фильтрацию подключений, чтобы выявить неверную блокировку доставки почты допустимым получателям.

Чтобы отключить фильтр отправителей на виртуальном сервере SMTP

  1. Запустите диспетчер Exchange: Нажмите кнопку Пуск и последовательно выберите Все программы, Microsoft Exchange, Диспетчер системы.

  2. В дереве консоли разверните узел Серверы, разверните нужный сервер, разверните узел Протоколы, а затем разверните узел SMTP.

  3. Щелкните правой кнопкой мыши виртуальный сервер SMTP, на котором нужно отключить фильтр, а затем выберите команду Свойства.

  4. В окне <Виртуальный сервер SMTP> Свойства, на вкладке Общие, щелкните Дополнительно.

  5. В окне Дополнительно выберите IP-адрес, для которого нужно отключить фильтр, а затем щелкните Изменить.

  6. В окне Идентификация снимите флажок Применить фильтр получений, чтобы отключить данный фильтр.

  7. Если используется несколько виртуальных серверов, повторите шаги 3-6 для каждого виртуального сервера, на котором нужно отключить фильтр.

Дополнительные сведения о настройке фильтров подключений см. в статье 823866 базы знаний Майкрософт «How to configure connection filtering to use Realtime Block Lists (RBLs) and how to configure recipient filtering in Exchange 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823866) (Инструкции по настройке фильтрации подключений с использованием списков блокировки в режиме реального времени, а также по настройке фильтрации получателей в Exchange 2003).

Дополнительные сведения об интеллектуальном фильтре сообщений см. на веб-узле интеллектуального фильтра сообщений Exchange (http://go.microsoft.com/fwlink/?LinkId=21607).


Соединитель принял набор запретов
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server запрашивает службу каталогов Active Directory, чтобы определить значение атрибута dLMemDefault для каждого соединителя SMTP в группе маршрутизации. Кроме того, средство анализа Exchange Server запрашивает Active Directory, чтобы выяснить значение атрибутов authOrig и unauthOrig каждого соединителя. Атрибуты unauthOrig и authOrig содержат списки различающихся имен (DNs) учетных записей.

По умолчанию все соединители SMTP позволяют всем пользователям отправлять сообщения через соединитель. Если значение параметра dLMemDefault установлено по умолчанию 1, принимаются сообщения ото всех, за исключением учетных записей, перечисленных в атрибуте unauthOrig. Если значение параметра dLMemDefault равно 0, отвергаются сообщения ото всех, за исключением учетных записей, перечисленных в атрибуте authOrig.

Средство анализа Exchange Server сообщает о нестандартной настройке при следующих условиях:

  • Значение атрибута dLMemDefault равно 0.

  • Атрибут authOrig содержит значения.

Соединитель, указанный средством анализа Exchange Server, настроен на прием только некоторых сообщений. Только учетные записи, имеющие явные разрешения на вкладке Delivery Restrictions соединителя, имеют право передавать сообщения через соединитель.

Средство анализа Exchange Server сообщает о нестандартной настройке только с ознакомительной целью.

Для получения дополнительных сведений о соединителях см. Руководство по транспорту и маршрутизации Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


Соединитель отклонил набор ограничений
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута dLMemDefault для каждого SMTP-соединителя группы маршрутизации. Анализатор сервера Exchange также запрашивает Active Directory, чтобы определить значение атрибутов authOrig и unauthOrig каждого соединителя. Атрибуты unauthOrig и authOrig содержит списки различающихся имен учетных записей.

По умолчанию все SMTP-соединители позволяют всем пользователям отправлять сообщения через соединитель. Когда значением dLMemDefault является заданное по умолчанию число 1, сообщения принимаются от всех пользователей, за исключением тех, чьи учетные записи перечислены в атрибуте unauthOrig. Когда значением dLMemDefault является 0, сообщения от всех пользователей отклоняются, за исключением тех, чьи учетные записи перечислены в атрибуте authOrig.

Если выполняются следующие условия, анализатор сервера Exchange отобразит сообщение о нестандартной конфигурации:

  • Значением атрибута dLMemDefault является 1.

  • Атрибут unauthOrig содержит значения.

Соединитель, указанный анализатором сервера Exchange, настроен таким образом, что отклоняет некоторые сообщения. Учетным записям, которым явным отказано в разрешении на вкладке «Ограничения доставки» этого соединителя, не смогут отправлять сообщения через соединитель.

Анализатор сервера Exchange выводит сообщение о несоответствии заданной по умолчанию конфигурации исключительно в информационных целях.

Дополнительные сведения о соединителях см. в руководстве по транспорту и маршрутизации в Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=47579.


Соединитель по умолчанию отклоняет все сообщения
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута dLMemDefault для каждого из соединителей. Атрибут dLMemDefault определяет, будут ли сообщения по умолчанию приниматься или отклоняться.

Значение 0 атрибута dLMemDefault указывает, что сообщения по умолчанию отклоняются. Значение 1 атрибута dLMemDefault указывает, что сообщения по умолчанию принимаются. Если анализатор сервера Exchange обнаруживает, что атрибут dLMemDefault имеет значение 0, выводится сообщение о том, что конфигурация отличается от заданной по умолчанию.

Соединитель, указанный анализатором сервера Exchange, настроен таким образом, что по умолчанию отклоняет все сообщения. Отправлять сообщения через этот соединитель могут только учетные записи, которым явным образом предоставлены разрешения на вкладке «Ограничения доставки» этого соединителя.

Анализатор сервера Exchange выводит сообщение о несоответствии конфигурации заданной по умолчанию исключительно в информационных целях.

Дополнительные сведения о соединителях см. в Руководстве по транспорту и маршрутизации в Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=47579.


Включена проверка ограничений соединителя
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализа сервера MicrosoftВ(r) Exchange считывает следующую ветвь реестра, чтобы определить, является ли значение реестра CheckConnectorRestrictions существующим и определенным:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

Если анализатор сервера Exchange обнаруживает, что значение для CheckConnectorRestrictions существует и равно 1, отображается предупреждение.

В случае необходимости применить ограничение на основе списка рассылки для соединителя, нужно вручную включить процесс проверки для этих ограничений. Проверка ограничений управляется значением реестра CheckConnectorRestrictions, которое должно быть установлено на сервере-плацдарме Exchange, так как он является источником для проверяемого соединителя. Если ограничение указано, но не создано значение реестра CheckConnectorRestrictions, ограничение не будет проверено.

Проверка ограничений соединителя выключена по умолчанию, потому что разворачивание групп подписки и проверка ограничений для каждого сообщения, которое проходит через систему, может существенно повлиять на ее производительность. Если есть возможность, включайте этот параметр только по необходимости (например на сервере-плацдарме для ограниченного соединителя).

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неполадки. Для получения сведений о восстановлении реестра см. разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы отключить проверку ограничений соединителя

  1. Откройте редактор реестра, такой как Regedit.exe или Regedt32.exe.

  2. Перейдите по адресу: HKLM\System\CurrentControlSet\Services\Resvc\Parameters

  3. Найдите параметр CheckConnectorRestrictions в правой области экрана и удалите его.

  4. Закройте редактор реестра и перезапустите службы Модуль маршрутизации Microsoft Exchange и Simple Mail Transfer Protocol (SMTP), чтобы изменения вступили в силу.

Для получения дополнительный сведений о правке реестра см. статью 256986 базы знаний корпорации Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Для получения дополнительных сведений о значении реестра для проверки ограничений соединителя см. статью 277872 базы знаний корпорации Майкрософт, «XCON: Возможно, ограничения соединителя доставки работают неправильно» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872).


Область действия соединителя ограничена локальной маршрутизацией
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-04-21

Средство анализа Microsoft® Exchange Server отправляет службе каталога Active Directory® запрос на определение значения атрибута msExchRoutingSMTPConnector для каждого соединителя SMTP. Если средство анализа Exchange Server обнаружит, что значение атрибута msExchRoutingSMTPConnector содержит строку "Local:", он выдаст сообщение о том, что настройка отличается от настройки по умолчанию. Наличие строки "Local:" указывает на то, что область действия соединителя ограничена локальной маршрутизацией.

Соединитель SMTP выделен под изолированный маршрут для передачи почты. Соединители SMTP можно использовать для создания шлюза для обмена почтой с Интернетом или для подключения к определенному домену или почтовой системе. Соединители позволяют определить конкретные параметры выделенного маршрута доставки почты.

Хотя почту можно отправлять и получать через Интернет, используя виртуальный сервер SMTP, многие организации настраивают выделенный соединитель SMTP для маршрутизации почтовых сообщений. Соединитель SMTP предпочтительнее, поскольку он предоставляет изолированный маршрут для передачи почты в Интернет. Кроме того, соединитель SMTP предоставляет более широкие возможности настройки, нежели виртуальный сервер SMTP.

Средство анализа Exchange Server выдает сообщение о том, что настройка отличается от настройки по умолчанию, только для информации.

Для получения дополнительных сведений о соединителях SMTP см. Руководство по транспортировке и маршрутизации в Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


Рассмотрите возможность неиерархической проверки ограничений
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumber для каждого объекта сервера Exchange в каталоге. Если анализатор сервера Exchange обнаруживает, что значение атрибута serialNumber для объекта сервера Exchange Server 2003 содержит Service Pack 2 в строке, анализатор сервера Exchange считывает следующий раздел реестра, чтобы определить, существует ли и задано ли значение параметра реестра CheckConnectorRestrictions:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

Это условие показывает, что перед обработкой сообщения сервер проверяет ограничения на отправку и получение.

Если анализатор сервера Exchange обнаруживает, что параметр CheckConnectorRestrictions существует и для него задано значение 1, что соответствует включению, анализатор сервера Exchange также читает раздел реестраHKLM\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod , чтобы определить, имеется ли параметр RestrictionMethod и как он настроен.

Если анализатор сервера Exchange обнаруживает, что параметр реестра RestrictionMethod отсутствует или для него задано значение, отличное от 2, выводится сообщение с рекомендациями.

Таким образом, анализатор сервера Exchange выводит на экран сообщение с рекомендациями, если выполняются следующие условия:

  • Для сервера Exchange Server 2003 установлен пакет обновления 2 (SP2).

  • Параметр реестра CheckConnectorRestrictions из раздела HKLM\System\CurrentControlSet\Services\Resvc\Parameters настроен для использования ограничения на основе списков рассылки для соединителя на локальном компьютере.

  • Параметр реестра RestrictionMethod из раздела HKLM\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod отсутствует, или для него задано значение, отличное от 2.

Параметр RestrictionMethod определяет способ обработки ограничений классификатором. По умолчанию классификатор рекурсивно разворачивает группы рассылки и проверяет ограничения для каждого сообщения, проходящего через систему. Такой режим работы классификатора может существенно повлиять на быстродействие и не рекомендуется.

Если задать для параметра RestrictionMethod значение 2, компоненты передачи на этом сервере Exchange не будут разворачивать структуру членства групп рассылки при проверке ограничений. Такая настройка обеспечивает максимальное быстродействие при проверке ограничений. Кроме того, чтобы значение параметра RestrictionMethod вступило в силу, все группы рассылки, содержащие пользователей, для которых настроены ограничения доставки сообщений, должны быть одноуровневыми. То есть группы рассылки, для которых заданы ограничения, не должны содержать вложенные группы рассылки. Логика развертывания не будет работать для групп с ограничениями, содержащих вложенные группы.

Для групп рассылки, используемых в ограничениях соединителя, рекомендуется задать значение параметра реестра RestrictionMethod на сервере-плацдарме соединителя, на котором нет почтовых ящиков. Для ограничений для пользователей Active Directory, если в группах рассылки с ограничениями имеются серверы расширения, рекомендуется создать запись реестра RestrictionMethod на серверах расширения.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» средства Regedit.exe или Regedt32.exe.
Чтобы создать параметр реестра RestrictionMethod и задать для него значение 2

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

  3. В левой области щелкните Параметры.

  4. В меню «Правка» укажите пункт Создать, а затем щелкните Параметр DWORD.

  5. Введите RestrictionMethod, а затем нажмите клавишу ВВОД, чтобы присвоить имя новой записи реестра.

  6. Щелкните правой кнопкой мыши RestrictionMethod и выберите команду Изменить.

  7. Введите 2, а затем нажмите клавишу ВВОД.

  8. Закройте редактор реестра.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения о редактировании реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о параметре реестра RestrictionMethod см. в базе знаний Майкрософт в статье 895407, посвященной более медленной, чем ожидалось, доставке сообщений в локальные и внешние почтовые ящики при использовании Exchange Server 2003 после настройки ограничений доставки на основе групп рассылки (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

Дополнительные сведения о значении параметра реестра см. в базе знаний Майкрософт в статье 277872, описывающей неправильную работу ограничений доставки соединителя (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872).


Раздел реестра ConvertDSNInternetContent настроен на выполнение преобразования содержимого всех сообщений
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующие записи реестра, чтобы определить, настроено ли значение параметра ConvertDSNInternetContent реестра на выполнение преобразования содержимого всех сообщений, получаемых банком данных Exchange на компьютере с сервером Exchange Server 2003:

HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Параметр ConvertDSNInternetContent реестра создан вручную.

  • Значение параметра ConvertDSNInternetContent реестра установлено равным единицы.

Значение 0 или отсутствие значения параметра ConvertDSNInternetContent реестра отключает преобразование содержимого SMTP-сообщений банком данных Exchange. Значение 1 включает преобразование всех сообщений, в том числе SMTP-сообщений, на всех экземплярах виртуальных SMTP-серверов или на отдельных экземплярах виртуальных серверов.

По умолчанию параметр ConvertDSNInternetContent реестра не создается во время установки сервера Exchange Server 2003. Параметр ConvertDSNInternetContent реестра может быть вручную создан после установки сервера Exchange Server Server для изменения настройки преобразования содержимого на компьютере с сервером Exchange Server 2003. Обычно отправляемые SMTP-сообщения не подвергаются преобразованию содержимого. Если включить преобразование всех сообщений, включая SMTP-сообщения, увеличатся накладные расходы обработки на сервере Exchange. Дополнительные накладные расходы обработки могут вызвать неполадки, связанные с быстродействием и работой хранилища файла журнала.

Анализатор сервера Exchange отображает эту конфигурацию только для сведений. Чтобы вернуть настройку преобразования содержимого на компьютере с сервером Exchange Server 2003 в состояние, обеспечивающий наиболее эффективный способ преобразования содержимого, следует внести изменения в реестр.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

  3. В области сведений щелкните правой кнопкой мыши параметр ConvertDSNInternetContent реестра, выберите команду Изменить, а затем измените Значение на 80. Нажмите кнопку OK.

    Примечание.
    Чтобы удалить параметр ConvertDSNInternetContent реестра, в области сведений щелкните правой кнопкой мыши параметр ConvertDSNInternetContent реестра и выберите команду Удалить. Подтвердите удаление параметра реестра, нажав в диалоговом окне кнопку Да.

  4. Закройте редактор реестра.

  5. Перезапустите сервер Exchange.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об изменении реестра Microsoft Windows см. в следующих статьях базы знаний Майкрософт:

  • Статья 322755, описывающая инструкции по резервному копированию, изменению и восстановлению реестра в Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • Статья 322756, описывающая инструкции по резервному копированию, изменению и восстановлению реестра в Windows XP и Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756).


Группа рассылки, указанная в качестве общего получателя
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-10-04

Средство анализа Microsoft® Exchange Server запрашивает класс WMI Exchange_Queue, чтобы определить значение следующих атрибутов очереди SMTP на виртуальном SMTP-сервере.

LinkId | Указывает на код ссылки, содержащей очередь.
QueueId | Указывает на код очереди.
QueueName | Указывает на имя очереди.
VirtualMachine | Указывает на имя виртуальной машины, содержащей очередь.
VirtualServerName | Указывает на имя виртуального сервера, на котором находится очередь.
MessageCount | Указывает на количество сообщений в очереди.

Средство анализа сервера Exchange Server использует полученные данные для запроса у класса WMI Exchange_QueuedSMTPMessage значений следующих атрибутов сообщений из очереди:

Recipients | Указывает на получателей сообщения.
Received | Указывает на полученную метку времени сообщения.
MessageId | Указывает на код сообщения, находящегося в очереди.
StateRetry | Указывает на повторную передачу сообщения, которое не было доставлено.

Затем средство анализа сервера Exchange Server использует полученные данные для отправки запроса в службу каталогов Active Directory® с целью получения значения distinguishedName для каждого объекта Recipient. Затем средство анализа Exchange Server определяет, является ли получателем пользователь, группа рассылки, общая папка или хранилище общих папок.

Если средство анализа Exchange Server определяет, что как минимум у 25 процентов сообщений, скопившихся в очереди, в полях To: или Cc: указана одна и та же группа рассылки, то отображается предупреждение.

Если средство анализа Exchange Server определяет, что как минимум у 50 процентов сообщений, скопившихся в очереди, в полях To: или Cc: указана одна и та же группа рассылки, то отображается сообщение об ошибке.

Такое предупреждение или сообщение об ошибке означает, что указанная группа рассылки является общим получателем сообщений, скопившихся в очереди SMTP.

Для решения данной проблемы следует проверить группу рассылки на наличие проблем конфигурации и другие неполадки, которые могли вызвать скопление сообщений в очереди:

  • Убедитесь, что атрибуты объекта группы рассылки правильно установлены и содержат правильные значения в службе Active Directory.

  • Убедитесь в правильности параметров разрешений объекта группы рассылки в службе Active Directory.

  • Если группа рассылки содержит объект пользователя специального применения, т. е. назначенный получатель журнала, проверьте конфигурации службы или компонентов, к которым относится объект пользователя, на правильность конфигурации.

  • Проверьте наличие нежелательной почты или вирусных атак, направленных против компьютера пользователя.

  • Убедитесь в правильности установки ограничений доставки для группы рассылки.

Дополнительные сведения об устранении проблем, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел «Устранение проблем, связанных с потоком почты и протоколом SMTP» в руководстве по транспортировке и маршрутизации сервера Exchange по адресу http://go.microsoft.com/fwlink/?LinkID=67875 (на английском языке).

  • Статья 823489 базы знаний Майкрософт «Использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003» по адресуhttp://go.microsoft.com/fwlink/?linkid=3052&kbid=823489 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

Дополнительные сведения о влиянии ограничения групп рассылок на поток почты сервера Exchange см. в следующих статьях базы знаний Майкрософт:

  • 895407 «На сервере Exchange Server 2003 доставка сообщений в локальные и внешние почтовые ящики происходит медленнее, чем ожидается, после настройки ограничений доставки на основе групп рассылки» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 329171 «XADM: доставка почты задерживается, если получатели настроены с ограничениями по доставке на основе членства в группе» по адресу: http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 839949 «Устранение неполадок почтового транспорта и групп рассылок на сервере Exchange 2000 Server и Exchange Server 2003» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 812298 «Доставка почты замедляется после настройки ограничений доставки на основе списка рассылки» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298 (эта ссылка может указывать на содержимое полностью или частично на английском языке).


Более ранние классификации завершились сбоем с повторяющейся ошибкой
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-09-06

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные категории: счетчики производительности «выполняющиеся классификации» и «длина очереди классификатора», относящиеся к объекту быстродействия SMTP Server, для анализа данных производительности.

Категория: счетчик производительности «Выполняющиеся классификации» показывает число выполняющихся классификаций, тогда как счетчик производительности «Длина очереди классификатора» показывает количество сообщений в очереди классификатора.

Для данного запроса анализатор сервера Exchange получает сведения каждые 6 секунд в течение двух минут. Затем анализатор сервера Exchange сообщает среднее значение счетчика производительности, достигаемое в течение интервала сбора данных.

Анализатор сервера Exchange проверяет среднее количество выполняющихся классификаций и сравнивает это число с количеством классификаций, все еще находящихся в очереди.

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если в течение периода выборки выполняются следующие условия:

  • Среднее число выполняющихся классификаций равно нулю.

  • Средняя длина очереди классификатора больше нуля.

Классификатор выполняет следующие основные операции:

  • Разрешает и проверяет достоверность всех получателей.

  • Определяет пределы и ограничения для всех получателей.

  • При необходимости расширяет списки рассылки.

  • Определяет, предназначено ли сообщение для локальной или удаленной доставки.

Эта ошибка указывает, что в очереди классификатора существуют сообщения, для которых классификация завершилась сбоем с повторяющейся ошибкой.

В общем случае сообщения накапливаются в очередях из-за того, что расширенный механизм очередей не может классифицировать сообщения. Возможно, расширенный механизм очередей не может получить доступ к серверам глобального каталога и к сведениям получателей. Либо серверы глобального каталога могут быть недостижимы или медленно работать. Кроме того, сообщения могут накапливаться по следующим причинам:

  • Недоступна служба каталогов Active Directory®.

    Примечание.
    Классификатор использует службу Active Directory для классификации сообщений.
  • Служба Active Directory может быть слишком перегружена, если в очереди перед классификацией находится много сообщений.

  • Существует ошибка в преобразовании. Классификатор также обрабатывает преобразование содержимого.

  • Классификатор сообщений не может найти хранилища почтовых ящиков.

  • Если протокол SMTP (Simple Mail Transfer Protocol) переустановлен или удален, это может сделать недействительными следующие ключи метабазы IIS: /smtpsvc/DsUseCat и /smtpsvc/vsi#/DsUseCat.

    Примечание.
    Определите, был ли переустановлен или удален протокол SMTP.

Чтобы определить причину сбоя, можно проанализировать свойства очереди. Например, если в свойствах очереди отображается сообщение, такое как «Произошла ошибка SMTP», следует просмотреть на сервере журналы ошибок, чтобы найти все ошибки SMTP. Если в журнале нет событий, необходимо увеличить уровень регистрации в журнале событий протокола SMTP.

Дополнительные сведения об устранении неполадок Exchange и очередей SMTP см. в следующих ресурсах Exchange:

  • Раздел по устранению проблем, связанных с потоком почты и протоколом SMTP в Руководстве по транспортировке и маршрутизации сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkID=67875).

  • База знаний Майкрософт, статья 823489, описывающая использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • База знаний Майкрософт, статья 821877, содержащая описание полей на вкладках свойств очередей SMTP и X.400 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • База знаний Майкрософт, статья 264054, содержащая общие сведения о состояниях очередей в Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).

  • Статья, посвященная исправлению неполадок, связанных с производительностью Microsoft Exchange Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Руководство по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

Счетчики производительности классификатора сообщений публикуются отдельно для каждого экземпляра виртуального сервера SMTP. Список доступных счетчиков производительности, связанных с классификатором сообщений, см. в базе знаний Майкрософт, в статье 231734, описывающей счетчики системного монитора для классификатора сообщений (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).


Включение автоматического обновления интеллектуального фильтра сообщений
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-02-13

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumber для всех объектов сервера Exchange в каталоге. Атрибут serialNumber представляет собой строковое значение, которое указывает как версию сервера Exchange, так и версию пакета обновления, если такой пакет установлен. Если атрибут serialNumber имеет значение Version 6.5 (Build 7638: Service Pack 2), это означает, что на данном сервере выполняется Exchange Sever 2003 с пакетом обновления 2.

Анализатор сервера Exchange также запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Service, чтобы определить значение ключа Started для службы кластеров ClusSvc. Значение True указывает, что служба кластеров выполняется, а значение False — что она не выполняется.

Анализатор сервера Exchange также считывает следующую запись реестра, чтобы определить, был ли установлен и включен интеллектуальный фильтр сообщений Microsoft Exchange на данном сервере:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

Если анализатор сервера Exchange Server обнаруживает, что в разделе реестра ContentFilter присутствует запись ContentFilterBindings, однако значение ContentFilterBindings не установлено, это указывает, что на данном сервере не включен интеллектуальный фильтр сообщений.

В последнюю очередь анализатор сервера Exchange считывает следующую запись реестра, чтобы определить, присутствует ли подраздел ContentFilterState и включено ли автоматическое обновление интеллектуального фильтра обновлений на данном сервере:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\

Если подраздел ContentFilterState имеет значение, отличное от 1, это указывает, что автоматическое обновление для интеллектуального фильтра сообщений не включено.

Анализатор сервера Exchange выводит на экран сообщение с рекомендациями, если выполняются следующие условия:

  • На сервере выполняется приложение Exchange Server 2003 с пакетом обновления 2.

  • Данный сервер Exchange не является кластерным

  • Включен интеллектуальный фильтр сообщений

  • Автоматические обновления для интеллектуального фильтра сообщений не включены.

По умолчанию возможность интеллектуального фильтра сообщений устанавливается вместе с Exchange Server 2003 с пакетом обновления 2. Чтобы воспользоваться преимуществами этой новой технологии фильтрации сообщений, необходимо включить эту возможность вручную. После включения возможности интеллектуального фильтра сообщений необходимо обновлять DAT-файл и DLL-файл, чтобы поддерживать фильтр в актуальном состоянии и обеспечить эффективность его действия. В статье, упомянутой в следующем разделе, приводится процесс обновления, который позволяет поддерживать актуальность интеллектуального фильтра сообщений.

Сведения о включении автоматического обновления для интеллектуального фильтра сообщений см. в статье 907747 базы знаний Майкрософт «How to update the Intelligent Message Filter version 2 in Exchange Server 2003 SP2» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=907747) (Инструкции по обновлению интеллектуального фильтра сообщений версии 2 в Exchange Server 2003 с пакетом обновления 2).


Ведение журнала конвертов включено
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-03-30

Анализатор сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить, был ли настроен атрибут heuristics на включение ведение журнала конвертов. По умолчанию атрибут heuristics не настроен. Если анализатор сервера Exchange обнаруживает, что значение атрибута heuristics равно 512, будет отображено сообщение о нестандартной конфигурации.

Ведение журнала конвертов позволяет архивировать заголовки P1 сообщений. Заголовок P1 сообщения является адресными данными, используемыми агентами передачи сообщений для маршрутизации почты. Эти адресные данные содержат сведения о получателях, которые должны получить сообщения, включая получателей скрытых копий и получателей из групп рассылок. Ведение журнала конвертов доставляет сообщения, которые помечены для архивирования, с помощью сообщения конверта, которое содержит отчет журнала и исходное сообщение. Исходное сообщение доставляется в виде вложения. В тексте отчета журнала содержится данные транспортные данные конверта архивного сообщения.

Чтобы включить ведение журнала для скрытых копий на определенном сервере, необходимо сначала настроить ведение журнала, относящееся только к сообщениям, на уровне базы данных. Атрибут heuristics является неактивным, когда выполняются следующие условия:

  • Значение параметра heuristics реестра установлено равным 512.

  • Ведение журнала, относящееся только к сообщениям, не включено для любого из хранилищ баз данных.

Сообщения по ведению журнала могут потреблять много ресурсов диска, сети и процессора. Следовательно, ведение журнала требует тщательного планирования развертывания. Ведение журнала следует включать только в контексте общей структуры решения по ведению журнала.

Данное сообщение о конфигурации не по умолчанию следует игнорировать, если выполняются следующие условия:

  • В организации требуется ведение журнала.

  • Развернута структура решения по ведению журнала.

В противном случае функциональные возможности по ведению журнала следует отключить.

Чтобы отключить ведение журнала только для сообщений в базе данных

  1. В диспетчере Exchange разверните узел Серверы, разверните узел <сервер Exchange>, разверните <группу хранения> и затем щелкните правой кнопкой мыши хранилище почтовых ящиков.

  2. На вкладке Общие снимите флажок Архивировать все сообщения, отправленные или полученные почтовыми ящиками в этом хранилище.

  3. Чтобы изменения вступили в действие в хранилище Exchange, подождите 15 минут. Нет необходимости перезапускать службу банка данных Microsoft Exchange.

Если требуется, чтобы анализатор сервера Exchange больше не отображал это сообщение, следует отключить раздел реестра heuristics. Для отключения функции ведения журнала не требуется отключения атрибута heuristics.

Можно отключить ведение журнала конвертов с помощью средства дополнительной конфигурации ведения журнала электронной почты (Exejcfg.exe). Можно запустить это средство с любого сервера, имеющего доступ к службе каталогов Active Directory, но рекомендуется использовать это средство на контроллере домена.

Чтобы получить средство дополнительной конфигурации ведения журнала электронной почты и документацию по нему, загрузите пакет средств с веб-узла http://go.microsoft.com/fwlink/?LinkId=33122. Средство дополнительной конфигурации ведения журнала электронной почты можно использовать в средах Exchange 2000 Server и Exchange Server 2003.

Чтобы отключить атрибут «heuristics»

  1. Загрузите и извлеките средство дополнительной конфигурации ведения журнала электронной почты в каталог по выбору.

  2. Откройте окно командной строки.

  3. Перейдите в каталог, в котором установлено средство дополнительной конфигурации ведения журнала электронной почты.

  4. Введите следующую команду, чтобы отключить ведение журнала конвертов:

    Копировать код
    exejcfg -d

Дополнительные сведения о порядке развертывания решений по ведению журнала см. в разделе, посвященном ведению журнала с помощью сервера Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47581).


Команда ESMTP не поддерживается
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить, является ли значение атрибута msExchSmtpInboundCommandSupportOptions для каждого экземпляра виртуального SMTP-сервера настроенным для поддержки используемых по умолчанию расширенных SMTP-команд для входящих подключений.

Эти расширенные SMTP-команды перечислены в приведенной ниже таблице. Если анализатор сервера Exchange находит, что какая-либо из перечисленных используемых по умолчания расширенных SMTP-команд для входящих подключений не поддерживается, выводится предупреждение.

Exchange Server 2003 использует эти специфичные для Exchange расширенные SMTP-команды для связи с другими серверами Exchange в организации более эффективно, чем другие стандартные SMTP-средства. Эти команды контролируются в метабазе и в приемнике событий сервера Exchange Server. Процесс DS2MB ответственен в Exchange Server 2003 за обновление значений в метабазе посредством копирования значений из Active Directory. Отключение приемников событий может снизить производительность сервера Exchange Server.

Расширенная SMTP-команда Комментарии

8BITMIME

Указывает, что локальный виртуальный SMTP-север поддерживает 8-разрядные MIME-сообщения.

BDAT, CHUNKING

Альтернатива команде DATA. Принимает два аргумента. Когда виртуальный SMTP-сервер отвечает на ключевое слово EHLO с командой CHUNKING, SMTP-сервер указывает, что он поддерживает команду BDAT и будет принимать сообщения блоками.

  • Первый аргумент указывает длину пакета двоичных данных. Поэтому SMTP-узел не должен непрерывно проверять окончание участка данных. Получающий север считает количество байтов в сообщении. Когда размер сообщения равен значению, отправленному командой BDAT, сервер предполагает, что им получены все данные сообщения.

  • Второй аргумент указывает, является ли пакет данных последним пакетом в текущей передаче. Второй аргумент необязательный.

BINARYMIME

Указывает, что виртуальный SMTP-сервер принимает сообщения, которые содержат двоичный материал без кодирования транспорта при помощи параметра BODY со значением BINARYMIME и с командой MAIL. Когда SMTP-сервер принимает команду MAIL, имеющую параметр BODY команды BINARYMIME, сервер сохраняет все разряды каждого октета, передаваемого с помощью команды BDAT. Расширение BINARYMIME SMTP можно использовать только с командой CHUNKING.

DSN

Команда ESMTP, которая включает уведомления состояния распространения в соответствии с документом RFC 1891.

ENHANCEDSTATUSCODES

Указывает, что SMTP-сервер предоставляет расширенные коды состояния ошибки. Текстовая часть всех ответов SMTP-состояния, отличных от начального приветствия и всех ответов на HELO или EHLO, предваряется кодом состояния в соответствии с документом RFC 1893.

ETRN

Отправляется SMTP-сервером, чтобы выяснить, отправил ли локальный виртуальный сервер какое-либо сообщение электронной почты, находящееся в очереди для доменов, указанных в команде ETRN.

TURN

Позволяет удаленному и локальному узлам меняться ролями и отправлять почту в обратном направлении без установки нового подключения.

Дополнительные сведения о том, как восстановить используемую по умолчанию поддержку этих команд, см. в базе знаний Майкрософт в статье 257569, посвященной отключению команд ESMTP в Exchange 2000 Server и Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569).


Расширенные команды не объявляются сервером Exchange
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, настроен ли сервер Exchange на поддержку расширенных команд, средство анализатора сервера Microsoft® Exchange считывает свойство SmtpInboundCommandSupportOptions в метабазе IIS (Internet Information Services). Если анализатор сервера Exchange обнаружит, что параметр SmtpInboundCommandSupportOptions не установлен равным 7697601, на экран будет выведено предупреждение.

Расширенные SMTP-команды необходимы как для Exchange 2000 Server, так и для Exchange Server 2003. Значение в метабазе IIS должно совпадать со значением, установленным в службе каталогов Active Directory®. Если сервер Exchange выполняется в среде смешанного режима, это значение должно быть установлено равным 7697601.

Внимание!
Могут возникнуть серьезные проблемы, если некорректно изменить атрибуты объектов Active Directory при использовании средства ADSI Edit (Active Directory Service Interfaces, ADSI), средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3. Для устранения этих неполадок может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Чтобы восстановить значение по умолчанию для параметра SmtpInboundCommandSupportOptions

  1. Откройте оснастку Edit интерфейса ADSI и подключитесь к контроллеру домена.

  2. Откройте Контейнер конфигурации.

  3. Перейдите в следующее местоположение:

    Configuration/Services/Microsoft Exchange/<используемая организация>/Administrative Groups/<используемая административная группа>/Servers/<используемый сервер Exchange>/Protocols/SMTP/<используемый виртуальный сервер>.

  4. Щелкните правой кнопкой мыши объект виртуального сервера и в контекстном меню выберите пункт «Свойства».

  5. В поле Выберите свойство для просмотра выберите «msExchSmtpInboundCommandsSupportOptions».

  6. В поле Изменение атрибута введите 7697601.

  7. Щелкните Установить, щелкните Применить и нажмите кнопку OK.

  8. Закройте оснастку Edit интерфейса ADSI.


Обнаружены застывшие очереди
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-03

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Windows® Management Instrumentation) ExchangeLink, чтобы определить значение ключа StateFrozen для SMTP-очередей (Simple Mail Transfer Protocol) на сервере.

Если анализатор сервера Exchange обнаружит, что значение ключа StateFrozen для какой-либо из SMTP-очередей на сервере Exchange установлено равным True, анализатор сервера Exchange выведет на экран сообщение об ошибке.

Застывшая очередь означает, что сеансы транспортировки для данной очереди остановлены. Застывшая очередь препятствует передаче исходящих сообщений, хотя новые сообщения могут добавляться. Состояние подключения можно изменить вручную с помощью контекстного меню для каждой очереди ссылок. Когда для переключения состояния очереди в «Active» используется команда Установить подключение, сразу включается подключение, которое отправляет сообщения из этой очереди.

Сведения об определенных SMTP-очередях, подвергаемых воздействию, и возможных причинах см. в следующих статьях о средстве анализатора сервера Exchange:

  • Очередь «Сообщения, ожидающие просмотра каталога» заблокирована

  • Очередь сообщений, ожидающих маршрутизации, остановлена

  • Очередь «Сообщения, ожидающие отправки» заморожена

  • Очередь «Локальная доставка» заморожена

  • Очередь «Удаленная доставка» заблокирована

Дополнительные сведения об устранении проблем, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел по устранению проблем потока почты и SMTP в руководстве по транспорту и маршрутизации сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).

  • База знаний Майкрософт, статья 823489, описывающая использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • База знаний Майкрософт, статья 821877, содержащая описание полей на вкладках свойств очередей SMTP и X.400 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • База знаний Майкрософт, статья 264054, описывающая общие сведения о состояниях очередей в Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Доступно обновление интеллектуального фильтра сообщений
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает WMI-класс CIM_Datafile, чтобы определить, существует ли библиотека MSExchange.UceContentFilter.dll по следующему пути на сервере Exchange:

<путь к двоичным файлам сервера Exchange>\MSCFv2\MSExchange.UceContentFilter.dll

Примечание.
В этом пути <путь к двоичным файлам сервера Exchange> означает местоположение папки bin.

Если MSExchange.UceContentFilter.dll не существует в этом местоположении, анализатор отобразит сообщение с рекомендацией.

Рекомендуется установить обновление для интеллектуального фильтра сообщений Microsoft Exchange на всех серверах Exchange, где существует этот фильтр. Обновление для интеллектуального фильтра сообщений обеспечивает обновление фильтра SmartScreen™ для интеллектуального фильтра сообщений. Обновление фильтра SmartScreen содержит обновленную характеристику нежелательной почты, которая улучшает способность интеллектуального фильтра сообщений блокировать нежелательные коммерческие сообщения электронной почты.

Примечание.
Прежде чем установить обновление, необходимо установить интеллектуальный фильтр сообщений. Чтобы установить интеллектуальный фильтр сообщений, используйте учетную запись, которая обладает правами локального администратора и является членом группы, которая обладает ролью администраторов Exchange.

После установки интеллектуального фильтра сообщений выполните следующую процедуру, чтобы установить обновления.

Чтобы получить и установить обновление интеллектуального фильтра сообщений

  1. Получите последнее обновление интеллектуального фильтра сообщений Exchange на веб-узле http://go.microsoft.com/fwlink/?LinkId=41026.

  2. Просмотрите заметки о выпуске для интеллектуального фильтра сообщений Exchange на веб-узле http://go.microsoft.com/fwlink/?LinkId=41027.

  3. Запустите пакет обновления и следуйте инструкциям в мастере установки пакета обновления.

Дополнительные сведения об интеллектуальном фильтре сообщений Exchange см. на веб-узле (http://go.microsoft.com/fwlink/?LinkId=21607).


Включена сплошная проверка ограничений
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumber для всех объектов сервера Exchange в каталоге. Если значение строки для атрибута serialNumber объекта сервера Exchange Server 2003 содержит Service Pack 2, это свидетельствует о том, что на сервере Exchange выполняется предварительная версия пакета обновления 2 для Exchange Server 2003.

Анализатор сервера Microsoft® Exchange также считывает следующую запись реестра, чтобы определить, существует ли параметр реестра RestrictionMethod:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

Анализатор сервера Exchange отображает сообщение о нестандартной конфигурации, если выполняются следующие условия:

  • Установлен пакет обновления 2 для Exchange Server 2003.

  • Параметр реестра RestrictionMethod существует, для него задано значение 2.

Такая конфигурация указывает, что компоненты транспорта на этом сервере Exchange не расширяют членство в группах распространения, когда сервер выполняет проверку ограничений. Такая конфигурация обеспечивает наилучшую производительность для выполнения проверок ограничений.

Если вы считаете, что настройка значения реестра RestrictionMethod ошибочна, существование этого значения является ошибкой, можно использовать следующую процедуру, чтобы вернуться в исходную конфигурацию. Однако с помощью этого раздела в комбинации с пакетом обновления 2 для Exchange Server 2003 можно обеспечить наилучшую производительность при выполнении проверки ограничений, рекомендуется оставить текущие настройки для параметра реестра RestrictionMethod.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Возврат к конфигурации по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\

  3. В правой области правой кнопкой мыши щелкните RestrictionMethod и выберите Удалить.

  4. Закройте редактор реестра и перезапустите службы IIS Admin и модуль маршрутизации Microsoft Exchange, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения о редактировании реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Для получения дополнительных сведений о значении параметра реестра RestrictionMethod см. базу знаний Майкрософт, статью 895407, в которой описываются причины замедления процесса доставки сообщений в локальные и внешние почтовые ящики после настройки ограничений на основе групп распространения (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).


Обнаружены записи «Host», однако не найдены записи «MX»
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Анализатор сервера Microsoft® Exchange запрашивает DNS-серверы, используемые ей для записей почтового обменника удаленных доменов, в которые Exchange выполняет отправку данных. Затем анализатор сервера Exchange выполняет DNS-поиск, чтобы извлечь записи удаленных доменов «Host (A)».

Если при выполнении операции DNS-поиска анализатора сервера Exchange не будут возвращены записи «MX» для удаленных доменов, а вместо этого будут последовательно извлечены записи «Host (A)» тех же удаленных доменов, выводится предупреждение.

В ситуации сбоя при попытке извлечь записи «MX» сервер Exchange может предпринять попытку отправить почту на сервера, на которые указывают записи «Host (A)». Очень важно, чтобы эти записи «Host (A)» указывали на корректные почтовые сервера.

В некоторых доменах записи «Host (A)» могут быть настроены таким образом, чтобы они указывали на поставщика услуг Интернета. Этот поставщик, несмотря на наличие допустимых почтовых серверов, не обязательно является авторизованным почтовым сервером для получателя. В этом случае почта будет отклонена.

DNS-поиск записей почтового обменника может завершиться неудачно, если данный DNS-сервер отключен или недоступен в связи со сбоем сети или по другой причине.

Чтобы убедиться, что DNS-сервер подключен к сети и существуют записи почтового обменника

  1. Убедитесь, что DNS-сервер работает, выполнив одну или несколько следующих проверок:

    • Узнайте состояние DNS-сервера, воспользовавшись программой администрирования службы DNS на DNS-сервере.

    • Перезапустите DNS-сервер. Дополнительные сведения см. в документе «Start, stop, pause, or restart a DNS server» (http://go.microsoft.com/fwlink/?LinkId=62999) (Запуск, останов, временный останов и перезапуск DNS-сервера).

    • Убедитесь в возможности DNS-сервера реагировать на внешние воздействия, выполнив команду nslookup. Дополнительные сведения см. в документе «Verify DNS server responsiveness using the nslookup command» (http://go.microsoft.com/fwlink/?LinkId=63000) (Проверка реакции DNS-сервера на внешние воздействия с помощью команды «nslookup»).

  2. С помощью команды nslookup убедитесь, что записи почтового обменника настроены правильно. Дополнительные сведения см. в разделе «How to Use Nslookup to Verify MX record configuration» (Инструкции по использованию команды «Nslookup» для проверки настройки записи почтового обменника) части «Verifying DNS Design and Configuration» (Проверка структуры и настройки DNS) документа Exchange Server Transport and Routing Guide (http://go.microsoft.com/fwlink/?LinkId=47579) (Руководство по транспорту и маршрутизации сервера Exchange).

Дополнительные сведения

  • Сведения об использовании в Exchange Server 2003 службы DNS для разрешения внешних IP-адресов см. разделе «Transport Dependencies for Exchange Server 2003» (Зависимости транспорта для Exchange Server 2003) в документе Exchange Server Transport and Routing Guide (http://go.microsoft.com/fwlink/?LinkId=47579) (Руководство по транспорту и маршрутизации сервера Exchange).

  • Сведения о разрешении DNS-имен см. в статье 322856 базы знаний Майкрософт «How to configure DNS to use with Exchange Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856) (Настройка DNS для использования с сервером Exchange).

  • Сведения об устранении неполадок в работе DNS см. в документе «Troubleshooting DNS» (http://go.microsoft.com/fwlink/?LinkId=63003) (Устранение неполадок в DNS).


Параметр реестра IIS PoolThreadLimit был добавлен и настроен вручную
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server считывает следующие параметры реестра, чтобы определить, совпадает ли максимальное число потоков пула IIS со значением по умолчанию:

HKEY_LOCAL_MACHINE\ System\CurrentControlSet\Services\Inetinfo\Parameters\PoolThreadLimit

Если средство анализа Exchange Server обнаружит, что параметр PoolThreadLimit существует и его значение не совпадает со значением по умолчанию, появится сообщение о том, что настройка отличается от настройки по умолчанию.

Параметр реестра PoolThreadLimit указывает максимальное число рабочих потоков ввода/вывода, что, в свою очередь, определяет максимальное допустимое число подключений к IIS. Каждый поток пула отслеживает один сетевой запрос и обрабатывает его: либо отправляет обратно файл статистики, либо направляет запрос к DLL расширения ISAPI (например, ASP.DLL) или в приложение интерфейса CGI. Если расширение ISAPI обрабатывает запрос синхронно, и для обработки запросов требуется много времени, рабочий поток будет тормозиться, и у IIS останется меньше рабочих потоков для обработки других запросов. По этой причине хорошо продуманные расширения ISAPI, к примеру, ASP, применяют собственные пулы потоков, ставят запросы в очередь и обрабатывают запросы асинхронно, используя собственные потоки, чтобы не тормозить рабочие потоки IIS.

По умолчанию IIS устанавливает для параметра PoolThreadLimit значение

2 * число мегабайт оперативной памяти машины

Если это значение больше 256, оно уменьшается до 256. По умолчанию это значение реестра отсутствует. Если это значение есть в реестре, оно перекрывает расчет IIS по умолчанию.

Обычно если ограничение в 256 потоков, установленное по умолчанию, оказывается недостаточным, это говорит о том, что используется неграмотно написанное расширение ISAPI, тормозящее рабочие потоки IIS. 256 активных потоков одновременно вполне достаточно, чтобы покрыть значительные затраты при синхронизации и переключении контекста.

Значение реестра PoolThreadLimit — это жесткое ограничение, охватывающее все рабочие потоки IIS, включая службы HTTP, FTP, NNTP и SMTP.

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Для получения сведений о восстановлении реестра см. разделе «Восстановление реестра» справочной системы файла Regedit.exe или Regedt32.exe.

Восстановление настройки по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

  3. Проверьте, удалите или измените значение PoolThreadLimit.

  4. Закройте программу и перезапустите службу IIS Admin, чтобы изменения вступили в силу.

До изменения реестра, а также для получения сведений о правке реестра просмотрите в базе знаний корпорации Майкрософт статью «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).


Ограничение размера входящих и исходящих сообщений
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-12-01

Средство анализа Microsoft® Exchange Server запрашивает службу каталога Active Directory®, чтобы определить, соответствует ли атрибут ограничения размера исходящих сообщений submissionContLength атрибуту ограничения размера входящих сообщений delivContLength. Если средство анализа Exchange Server обнаружит, что ограничения размера входящих и исходящих сообщений различны, он выдаст сообщение с рекомендациями касательно оптимальной настрйки.

Рекомендуется настроить одинаковые ограничения размера входящих и исходящих сообщений, чтобы ограничения сообщений соответствовали друг другу.

Для того чтобы изменить ограничения размера сообщения для серверов Exchange 2000 Server и Exchange Server 2003, выполните следующие действия:

  1. Запустите системный диспетчер Exchange.

  2. В левой панели раскройте Глобальные параметры.

  3. Щелкните правой кнопкой мыши пункт Доставка сообщений и выберите Свойства.

  4. На вкладке По умолчанию в разделе Размер отправляемых сообщений щелкните Максимум (КБ) и введите число.
Для того чтобы установить ограничения размера исходящего сообщения для серверов Exchange 2007 Server, выполните следующие действия:

  1. В среде управления Exchange выполните следующую команду, где в качестве <размера> указывается значение «не ограничен» либо размер в байтах (B), килобайтах (KB) или мегабайтах (MB) в диапазоне от 0 до 2 147 483 647 байт:
Копировать код
Set-TransportConfig -MaxSendSize <size>

Например, чтобы установить максимальный размер сообщений, отправляемых пользователями организации Exchange, равный 10 мегабайтам, необходимо ввести следующее значение:

Копировать код
Set-TransportConfig -MaxSendSize 10MB

Для того чтобы установить неограниченный максимальный размер сообщений, отправляемых пользователями организации Exchange (значение по умолчанию), необходимо ввести следующее значение:

Копировать код
Set-TransportConfig -MaxSendSize unlimited
 Изменение ограничения размера входящих сообщений

  1. Запустите системный диспетчер Exchange.

  2. В левой панели раскройте Глобальные параметры.

  3. Щелкните правой кнопкой мыши пункт Доставка сообщений и выберите Свойства.

  4. На вкладке По умолчанию в разделе Размер получаемых сообщений щелкните Максимум (кБ) и введите число.
Для того чтобы установить ограничения размера входящего сообщения для серверов Exchange 2007 Server, выполните следующие действия:

  1. В среде управления Exchange выполните следующую команду, где в качестве <размера> указывается значение «не ограничен» либо размер в байтах (B), килобайтах (KB) или мегабайтах (MB) в диапазоне от 0 до 2 147 483 647 байт:
Копировать код
Set-TransportConfig -MaxReceiveSize <size>

Например, чтобы установить для сообщений, получаемых пользователями организации Exchange, максимальный размер, равный 10 МБ, необходимо ввести следующее значение:

Копировать код
Set-TransportConfig -MaxReceiveSize 10MB

Для того чтобы снять ограничение максимального размера сообщений, отправляемых пользователями организации Exchange (это значение по умолчанию), необходимо ввести следующее значение:

Копировать код
Set-TransportConfig -MaxReceiveSize unlimited

Для получения дополнительных сведений об установке предела размера сообщений в Exchange 2000 Server и Exchange Server 2003 см. статью 322679 базы знаний корпорации Майкрософт «Установка ограничения размера сообщений в Exchange Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679).

Дополнительные сведения о командлете TransportConfig для сервера Exchange Server 2007 см. раздел Set-TransportConfig в техническом справочнике по Exchange Server 2007 по адресу http://go.microsoft.com/fwlink/?LinkId=79237 (на английском языке).


Присутствует пользовательский отклик интеллектуального фильтра сообщений
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализа сервера Microsoft® Exchange считывает следующую запись из реестра, чтобы определить наличие параметра реестра CustomRejectResponse:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

Средство анализа сервера Exchange отображает сообщение о том, что настройка по умолчанию изменена, если существуют следующие условия:

  • Присутствует параметр реестра CustomRejectResponse.

  • Этот параметр выражен строкой с допустимым значением.

    Примечание.
    Чтобы значение строки отклика было признано допустимым, оно должно начинаться с 550 5.7.1.

Никаких действий для устранения проблемы выполнять не требуется.

В Exchange Server 2003 с пакетом обновления 2 (SP2) интеллектуальный фильтр сообщений установлен и готов к работе после установки пакета обновления 2 (SP2). Exchange Server 2003 SP2 позволяет настроить строку отклика сервера, которая создается и добавляется к отчету о недоставке, отправляемому отправителю. Отклик по умолчанию (550 5.7.1 Запрошенное действие не выполнено: сообщение отклонено ) можно изменить, чтобы заблокированные легальные пользователи получали осмысленное объяснение о том, почему сообщение было заблокировано. Это объяснение может помочь сократить исследование ложных распознавателей и снизить стоимость технической поддержки, связанную с защитой от нежелательной почты.

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неполадки. Для получения сведения о восстановлении реестра см. раздел справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы изменить пользовательскую строку отклика

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к: HKLM\Software\Microsoft\Exchange\ContentFilter

  3. На правой панели задач щелкните правой кнопкой мыши параметр CustomRejectResponse и выберите Изменить.

  4. Введите значение параметра, который нужно использовать для ответа. Он должен начинаться с 550 5.7.1. Например, можно ввести 550 5.7.1 Домен не является допустимым отправителем, чтобы данное допустимое значение параметра было добавлено к отчету о недоставке.

  5. Сохраните изменения, выйдите из редактора реестра и перезапустите службу SMTP, чтобы изменения вступили в силу.

Перед правкой реестра, а также для получения сведений о правке реестра см. статью 256986 базы знаний Майкрософт, «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Для получения дополнительных сведений об интеллектуальном фильтре сообщений см. веб-сайт «Интеллектуальный фильтр сообщений Exchange» (http://go.microsoft.com/fwlink/?LinkId=21607).

Для получения дополнительных сведений о применении интеллектуального фильтра сообщений см. главу «Настройка интелектуального фильтра сообщений» интерактивной справки сервера Exchange 2003 SP2.

Для получения дополнительных сведений о пакете обновления SP2 для Exchange Server 2003 см. веб-узел пакета обновления 2 для Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=52073).


В интеллектуальном фильтре сообщений присутствует список пользовательских слов
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить наличие файла MSExchange.UCEContentFilter.xml на сервере Exchange. Если анализатор сервера Exchange обнаруживает файл MSExchange.UCEContentFilter.xml на сервере Exchange, выводится сообщение о конфигурации, отличной от конфигурации по умолчанию. Никаких действий по восстановлению выполнять не требуется.

Файл MSExchange.UCEContentFilter.xml является компонентом функции специального взвешивания в интеллектуальном фильтре сообщений для Exchange Server 2003 с пакетом обновления 2 (SP2).

Функция специального взвешивания в интеллектуальном фильтре сообщений для Exchange Server 2003 SP2 дает возможность администраторам настраивать поведение интеллектуального фильтра сообщений на основе фраз в тексте сообщения электронной почты, в поле «Тема» сообщения или в обеих областях. Для функции специального взвешивания не предусмотрен пользовательский интерфейс. Специальное взвешивание реализуется с помощью конфигурационного XML-файла MSExchange.UCEContentFilter.xml, который считывается интеллектуальным фильтром сообщений при инициализации, а затем перезагружается при любом изменении файла. Если файл MSExchange.UCEContentFilter.xml отсутствует при запуске интеллектуального фильтра сообщений, необходимо перезапустить службу SMTP. Файл специального взвешивания MSExchange.UceContentFilter.xml должен находиться в том же каталоге, что и файлы MSExchange.UceContentFilter.dll и MSExchange.UceContentFilter.dat.

Дополнительные сведения о файле специального взвешивания см. в заметках о выпуске Exchange Server 2003 SP2. Заметки о выпуске Exchange Server 2003 SP2 доступны на компакт-диске SP2 и на веб-узле заметок о выпуске Exchange Server 2003 SP2 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=52072).

Дополнительные сведения о пакете обновления 2 (SP2) для Exchange Server 2003 см. на веб-узле пакета обновления 2 (SP2) Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=52073).


Недопустимый настроенный ответ интеллектуального фильтра сообщений
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, существует ли раздел реестра CustomRejectResponse, средство анализатора сервера Microsoft® Exchange считывает следующее значение реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Существует раздел реестра CustomRejectResponse.

  • Это строковое значение не начинается с 550 5.7.1.

    Примечание.
    Строковое значение ответа должно начинаться с 550 5.7.1, чтобы быть допустимым.

Exchange Server 2003 с пакетом обновления 2 (SP2) позволяет настраивать строку ответа сервера, которая создается и присоединяется к отчету о недоставке, посылаемому обратно отправителю. Ответ по умолчанию — 550 5.7.1 Requested action not taken: message refused — можно изменить, чтобы предоставить заблокированным пользователям более понятное объяснение блокировки их сообщений. Это объяснение может сократить время изучения неверных причин блокировки и уменьшить стоимость поддержки, связанной с обработкой нежелательной почты.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\Software\Microsoft\Exchange\ContentFilter

  3. В правой области щелкните правой кнопкой мыши значение CustomRejectResponse и выберите Изменить.

  4. Введите необходимое строковое значение, которое будет использоваться в качестве настроенного ответа, начав эту строку с 550 5.7.1. Например, можно ввести 550 5.7.1 Домен не является разрешенным отправителем, и эта допустимая строка будет прикрепляться к отчету о недоставке.

  5. Сохраните изменения, закройте редактор реестра и перезапустите компьютер, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об интеллектуальном фильтре сообщений см. на веб-узле, посвященном интеллектуальному фильтру сообщений Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=21607).

Подробные сведения о выполнении задач интеллектуального фильтра сообщений см. в разделе интерактивной справки по Exchange Server 2003 с пакетом обновления 2, посвященном настройке интеллектуального фильтра сообщений.


На сервере почтовых ящиков включен интеллектуальный фильтр сообщений
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, установлен ли и включен ли на сервере интеллектуальный фильтр сообщений Microsoft Exchange, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

Анализатор сервера Exchange считывает значение ContentFilterBindings в разделе реестра ContentFilter, чтобы определить, включен ли и установлен ли на сервере интеллектуальный фильтр сообщений.

Затем анализатор сервера Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchAuthenticationFlags объекта сервера Exchange. Атрибут msExchAuthenticationFlags представляет тип проверки подлинности, разрешенный на сервере. Анализатор сервера Exchange выводит на экран сообщение об ошибке при следующих условиях:

  • Проверка подлинности была настроена атрибутом msExchAuthenticationFlags так, чтобы разрешать анонимный доступ к серверу.

  • На сервере также размещены почтовые ящики.

Интеллектуальный фильтр сообщений обнаруживает сообщения, которые, возможно, являются нежелательными почтовыми сообщениями. Для эффективной фильтрации нежелательных почтовых сообщений необходимо установить интеллектуальный фильтр сообщений на серверах шлюзов Exchange или серверах-плацдармах Exchange, если в качестве шлюзов используются решения других производителей, а не серверы электронной почты Майкрософт. Эти серверы шлюзов получают сообщения электронной почты из Интернета и пересылают их соответствующему серверу почтовых ящиков. Обычно почтовые ящики размещаются вне серверов шлюзов.

Кроме того, необходимо включить интеллектуальный фильтр сообщений на каждом виртуальном сервере SMTP, который получает сообщения электронной почты из Интернета на серверах шлюзов Exchange.

Важно!
Не отключайте анонимный доступ на виртуальных серверах SMTP интернет-шлюзов. На виртуальных серверах SMTP, получающих почту из Интернета, должен быть разрешен анонимный доступ.

Для фильтрации нежелательных почтовых сообщений можно настроить интеллектуальный фильтр сообщений, определив пороги для оценки вероятности нежелательной почты, назначенные входящим сообщениям и на шлюзе, и в хранилищах почтовых ящиков Exchange. Интеллектуальный фильтр сообщений оценивает каждое входящее сообщение и присваивает сообщению оценку вероятности нежелательной почты, основываясь на вероятности того, что это сообщение относится к нежелательной почте. Чтобы определить, передавать ли сообщение в пользовательскую папку «Входящие» или в папку нежелательной почты, серверы почтовых ящиков Exchange используют порог и настройки вероятности нежелательной почты, заданные для хранилища почтовых ящиков.

Важно!
Интеллектуальный фильтр сообщений не нужно устанавливать на серверах почтовых ящиков Exchange. Если интеллектуальный фильтр сообщений установлен и включен на виртуальных SMTP-серверах шлюзов, серверы почтовых ящиков Exchange получают оценку вероятности нежелательной почты с каждым входящим сообшением и выполняют соответствующее действие.

Сведения по этим вопросам см. на веб-узле интеллектуального фильтра сообщений Exchange по адресу http://go.microsoft.com/fwlink/?LinkId=21607. Дополнительные сведения о настройке организации Microsoft Exchange Server 2003 для отправки и получения почты через Интернет см. в Руководстве по транспорту и маршрутизации сервера Exchange по адресу http://go.microsoft.com/fwlink/?LinkId=47579.


На сервере не включен интеллектуальный фильтр сообщений
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить, установлен ли и включен на сервере интеллектуальный фильтр сообщений Microsoft Exchange:

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

Если анализатор сервера Exchange обнаружит, что запись значения ContentFilterBindings присутствует в разделе реестра ContentFilter, однако значение ContentFilterBindings не настроено, анализатор выдает предупреждение.

Примечание.
Наличие записи значения ContentFilterBindings в разделе реестра ContentFilter при том, что значение ContentFilterBindings не настроено, указывает на то, что интеллектуальный фильтр сообщений не включен на сервере.
Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Интеллектуальный фильтр сообщений Microsoft Exchange выявляет сообщения, которые следует отнести к нежелательной коммерческой электронной почте. После развертывания интеллектуального фильтра сообщений на серверах-шлюзах Exchange или сервера-плацдармах Exchange, принимающих входящую почту, необходимо включить интеллектуальный фильтр сообщений на каждом виртуальном сервере SMTP, на который поступают сообщения электронной почты Интернета.

Чтобы просмотреть раздел реестра ContentFilter

  1. В редакторе реестра (regedit) в области сведений щелкните правой кнопкой мыши папку ContentFilter, чтобы посмотреть значение для ContentFilterBindings.

    Примечание.
    Если интеллектуальный фильтр сообщений Exchange не настроен на виртуальном сервере SMTP, значение ContentFilterBindings будет не определено.

    Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Интеллектуальный фильтр сообщений Exchange рекомендуется включить на всех серверах Exchange, на которых он установлен. Чтобы включить интеллектуальный фильтр сообщений на виртуальном сервере SMTP, выполните описанную ниже процедуру. После включения интеллектуального фильтра сообщений можно проверить в реестре значение раздела ContentFilter.

Чтобы включить интеллектуальный фильтр сообщений

  1. Нажмите кнопку Пуск и последовательно выберите Все программы, Microsoft Exchange, Диспетчер системы.

  2. В системном диспетчере Exchange последовательно разверните узлы Серверы, имя_сервера, Протоколы, SMTP, щелкните правой кнопкой мыши узел Интеллектуальная фильтрация сообщений и выберите команду Свойства.

  3. На вкладке Общие в списке Применить интеллектуальную фильтрацию сообщений к следующим IP-адресам виртуальных серверов установите флажок рядом с каждым виртуальным сервером SMTP, на котором требуется включить интеллектуальный фильтр сообщений.

    Диалоговое окно «Свойства интеллектуальной фильтрации сообщений»

Дополнительные сведения см. на веб-узле, посвященном интеллектуальному фильтру сообщений Exchange (http://go.microsoft.com/fwlink/?LinkId=21607).


Назначен неверный сервер службы обновления получателей
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-07-30

Анализатор Microsoft Exchange запрашивает службу каталогов Active Directory, чтобы определить значение атрибута msExchAddressListServiceLink для каждого имеющегося в каталоге объекта службы обновления получателей. Атрибут msExchAddressListServiceLink — это ссылка из службы списка адресов на компьютер с сервером Exchange Server, на котором выполняется служба обновления получателей.

После этого анализатор Exchange запрашивает WMI-класс CIM_Datafile, чтобы определить значение параметра Version для службы представления адресной книги и динамических групп (abv_dg.dll) на найденных компьютерах с сервером Exchange Server. Параметр WMI Version определяет номер сборки этого файла.

Если анализатор Exchange выясняет, что номер сборки файла abv_dg.dll на каком-либо из найденных компьютеров начинается с 08, выводится сообщение об ошибке.

Эта ошибка свидетельствует о том, что на компьютере, назначенном в качестве сервера службы обновления получателей, работает сервер Microsoft Exchange Server 2007.

Служба обновления получателей — это компонент службы системного помощника Exchange, входящей в Exchange 2000 Server и Exchange Server 2003. Служба обновления получателей для Exchange 2000 Server и Exchange Server 2003 создает и обслуживает в Active Directory значения атрибутов, специфичных для сервера Exchange Server. Эти функции в Exchange Server 2007 выполняет процесс создания получателей, и прежняя служба обновления получателей не может обрабатывать обновления, если она выполняется на сервере Exchange Server 2007.

Чтобы устранить данную ошибку, поручите выполнение службы обновления получателей серверу Exchange 2000 Server или Exchange Server 2003.

Устранение ошибки

  1. Откройте диспетчер Exchange.

  2. В разделе Получатели щелкните пункт Службы обновления получателей. В правой панели навигации щелкните правой кнопкой мыши соответствующий экземпляр службы обновления получателей и выберите пункт Свойства.

  3. На вкладке Общие в разделе Exchange Server нажмите кнопку Обзор и укажите новый сервер Exchange 2000 Server или Exchange Server 2003 для запуска данного экземпляра службы обновления получателей.

  4. Нажмите кнопку ОК, а затем нажмите кнопку ОК еще раз, чтобы изменения вступили в силу.


Выполняется большое количество классификаций
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-08-21

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные категории: счетчик производительности «выполняющиеся классификации» объекта быстродействия SMTP Server для анализа данных производительности.

Категория: счетчик «выполняющиеся классификации» показывает количество классификаций, находящихся в стадии выполнения.

Для данного запроса анализатор сервера Exchange получает сведения каждые 6 секунд в течение двух минут. Затем анализатор сервера Exchange сообщает среднее значение счетчика производительности, достигаемое в течение интервала сбора данных.

Если анализатор сервера Exchange определит, что среднее количество выполняющихся классификаций в течение периода выборки значений превышает 800, на экран будет выведено сообщение об ошибке.

Классификатор выполняет следующие основные операции:

  • Разрешает и проверяет достоверность всех получателей.

  • Определяет пределы и ограничения для всех получателей.

  • При необходимости расширяет списки рассылки.

  • Определяет, предназначено ли сообщение для локальной или удаленной доставки.

Эта ошибка может указывать на наличие чрезмерной нагрузки на сервер или на проблему, связанную с производительностью.

Чтобы устранить эту ошибку, выполните следующие действия:

  • Определите, является ли нагрузка на классификатор ожидаемой или типовой. Если напряжение в работе классификатора создает ожидаемая нагрузка, ознакомьтесь с рекомендациями по управлению производительностью Exchange в следующих статьях Microsoft TechNet.

    • Статья, посвященная исправлению неполадок, связанных с производительностью сервера Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).

    • Руководство по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Если источником напряжения в работе классификатора не является ожидаемая нагрузка, проверьте систему на наличие вирусов и нежелательной почты, которые могут создать дополнительную нагрузку.

Счетчики производительности классификатора сообщений публикуются отдельно для каждого экземпляра виртуального сервера SMTP (Simple Mail Transfer Protocol). Список доступных счетчиков производительности, связанных с классификатором сообщений, см. в базе знаний Майкрософт в статье 231734, описывающей счетчики системного монитора для классификатора сообщений (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).


Большое количество почтовых ящиков с ограничениями по доставке, установленными группой рассылки
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-08-21

Чтобы определить, существуют ли для каких-либо почтовых ящиков в доменах ограничения по доставке, установленные на основе членства в группе рассылки, средство анализатора сервера Microsoft® Exchange запрашивает для каждого объекта пользователя во всех доменах, обнаруженных в службе каталогов Active Directory®, следующие атрибуты:

dLMemDefault | Указывает, будут ли сообщения приниматься или отклоняться по умолчанию. Когда атрибут установлен в значение по умолчанию, равное 1, принимаются сообщения от всех отправителей.
dLMemRejectPerms | Содержит различающиеся имена списков рассылки, членам которых не разрешено отправлять сообщения этому получателю.
dLMemSubmitPerms | Содержит различающиеся имена списков рассылки, членам которых разрешено отправлять сообщения этому получателю.

Если анализатор сервера Exchange определит, что в домене существует более 500 почтовых ящиков, для которых имеются ограничения по доставке, установленные на основе членства в группе рассылки, на экран будет выведено сообщение об ошибке.

Это сообщение об ошибке указывает, что ограничения по доставке на основе членства в группе рассылки для многих почтовых ящиков могут влиять на интенсивность потока почты сервера Exchange.

По умолчанию классификатор рекурсивно разворачивает группы рассылки и проверяет ограничения для каждого сообщения, проходящего через систему.

Когда классификатор сообщений отправляет почту пользователю, принимающему или блокирующему сообщения из группы доставки, классификатор сообщений должен развернуть структуру членства в группе рассылки, получить полный список различающихся имен членов и затем сравнить список различающихся имен с различающимися именами отправителей в списке. Когда различающееся имя присутствует в обоих списках, выполняется операция разрешения доступа или операция запрета доступа. Если группа рассылки вложена в другую группу рассылки, вложенная группа рассылки также разворачивается.

Чтобы устранить эту ошибку, выполните следующие действия:

  • Проанализируйте тех пользователей, чьи ограничения по доставке установлены группой рассылки, и удалите ненужные ограничения.

  • Настройте отдельные почтовые ящики, а не группы рассылки для ограничений по доставке согласно сведениям, содержащимся в базе знаний Майкрософт, в статье 812298, описывающей ситуацию, когда доставка почты замедляется после настройки ограничений по доставке на основе списка рассылки (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Для серверов, на которых выполняется Microsoft Exchange Server 2003 с пакетом обновления 2 (SP2) или более поздняя версия, рассмотрите возможность реализации неиерархической проверки ограничений. Для серверов, на которых выполняются версии Exchange, предшествующие Exchange Server 2003 с пакетом обновления 2 (SP2), рассмотрите возможность обновления до Exchange Server 2003 с пакетом обновления 2 (SP2).

Дополнительные сведения

Дополнительные сведения о неиерархической проверке ограничений см. в разделе Рассмотрите возможность неиерархической проверки ограничений.

Дополнительные сведения о влиянии ограничения групп рассылок на поток почты сервера Exchange см. в следующих статьях базы знаний Майкрософт:

  • Статья 895407, описывающая ситуацию в Exchange Server 2003, когда доставка сообщений в локальные и во внешние почтовые ящики вопреки ожиданиям замедляется после настройки ограничений по доставке на основе групп рассылок (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • Статья 839949, описывающая устранение неполадок почтового транспорта и групп рассылок в Exchange 2000 Server и в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • Статья 812298, описывающая ситуацию, когда доставка почты замедляется после настройки ограничений по доставке на основе списка рассылки (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).


Маршрутизация по пути с наименьшей стоимостью включена в организации смешанного режима
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, включена ли маршрутизация по пути с наименьшей стоимостью на сервере Exchange Server 5.5 в среде смешанного режима. Анализатор сервера Exchange выводит предупреждение, если справедливы следующие условия:

  • Маршрутизация с наименьшей стоимостью включена.

  • В организации работает Exchange Server 2003 в среде смешанного режима с Exchange Server 5.5.

Если маршрутизация с наименьшей стоимостью в среде смешанного режима включена, могут возникать циклы сообщений. Exchange Server 2003 использует маршрутизацию состояния ссылок. Поэтому когда Exchange Server 2003 обнаруживает, что ссылка отключена, он изменяет маршрут сообщения на другой сервер. Если сервер Exchange Server 5.5 использует параметр Only use least cost routes в окне свойств Message Transfer Agent, в качестве наилучшего маршрута часто определяется возврат к серверу Exchange Server 2003, от которого сообщение было только что отправлено. Когда сообщение отправляется обратно серверу Exchange Server 2003, маршрут зацикливается.

В любой организации смешанного режима, в которой работают как Exchange Server 5.5, так и Exchange Server 2003, рекомендуется отключить маршрутизацию с наименьшей стоимостью на всех серверах Exchange Server 5.5.

Чтобы отключить маршрутизацию с наименьшей стоимостью на сервере Exchange Server 5.5

  1. В программе администратора сервера Microsoft Exchange разверните контейнер Организация, разверните контейнер Узел, разверните контейнер Конфигурация, разверните контейнер Серверы и щелкните объект-сервер.

  2. В правой области щелкните объект Агент передачи сообщений.

  3. В меню Файл выберите команду Свойства.

  4. В диалоговом окне Свойства агента передачи сообщений на вкладке Общие снимите флажок Использовать только маршрутизацию с наименьшей стоимостью.

  5. Нажмите кнопку ОК.


Прослушиваемый порт SMTP мог измениться со своего значения по умолчанию 25
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить, было ли изменено значение по умолчанию 25 параметра msExchServerBindings. По умолчанию атрибут msExchServerBindings настроен на TCP-порт 25. Если анализатор сервера Exchange обнаружит, что значение этого атрибута не равно 25, на экране отобразится сообщение о нестандартной конфигурации.

Атрибут msExchServerBindings представляет TCP-порт, по которому SMTP-сервер ожидает входящие подключения. Виртуальные SMTP-серверы можно настроить на прослушивание одного или нескольких портов TCP. По умолчанию все виртуальные SMTP-серверы прослушивают TCP-порт 25 — порт SMTP по умолчанию. Если прослушиваемый порт SMTP был изменен со своего значения по умолчанию и больше не содержит TCP-порт 25 в своем списке, поток электронной почты может быть нарушен.

Разрешается изменить прослушиваемый порт SMTP, если изменить соответствующим образом и всю инфраструктуру внутреннего обмена сообщениями. Но, как правило, нельзя использовать другие порты для виртуальных SMTP-серверов, которые получают сообщения напрямую из Интернета, так как SMTP-серверы в Интернете посылают сообщения через порт 25.

Заметьте, что анализатор сервера Exchange ищет значение для виртуального SMTP-сервера Exchange. Виртуальный SMTP-сервер может являться SMTP-сервером, который получает сообщения напрямую из Интернета, а может и не являться таковым. Существует несколько продуктов, предназначенных для борьбы с вирусами и нежелательной почтой, которые получают SMTP-сообщения из Интернета по порту 25 и перенаправляют их на виртуальный SMTP-сервер Exchange или на другой порт. В этом сценарии виртуальный SMTP-сервер Exchange, который прослушивает порт, отличный от 25, является приемлемой конфигурацией.

Чтобы просмотреть или изменить прослушиваемый виртуальным SMTP-сервером порт

  1. В системном диспетчере Exchange разверните узел Серверы, затем сервер Exchange, затем Протоколы и SMTP.

  2. Правой кнопкой мыши щелкните виртуальный SMTP-сервер (например, виртуальный SMTP-сервер по умолчанию) и нажмите Свойства.

  3. Выберите вкладку Общие и щелкните Дополнительно.

  4. Появится список IP-адресов и портов.

    • Чтобы изменить существующий порт, выберите IP-адрес и щелкните Изменить. Измените TCP-порт в соответствующем поле на 25.

    • Чтобы добавить порт 25 в качестве дополнительного прослушиваемого порта, нажмите кнопку Добавить и добавьте новую комбинацию, состоящую из IP-адреса и порта. Если используется фильтрация подключения, отправителя или получателя, убедитесь, что установлены соответствующие флажки.

  5. Нажмите кнопку ОК, чтобы сохранить изменения, а затем снова нажмите кнопку ОК, чтобы закрыть диалоговое окно Дополнительно. Нажмите кнопку ОК, чтобы закрыть диалоговое окно Свойства виртуального SMTP-сервера.

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • 266686, описывающая первую часть инструкций по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686);

  • 268163, описывающая вторую часть инструкций по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).


Очередь «Локальная доставка» заморожена
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-03

Средство анализатора сервера Microsoft® Server запрашивает WMI-класс ExchangeLink, чтобы определить значение ключа StateFrozen для очереди SMTP Локальная доставка.

Если анализатор сервера Exchange Server обнаружит, что для ключа StateFrozen очереди Локальная доставка на сервере Exchange установлено значение True, он отображает сообщение об ошибке.

Заморозка очереди означает, что транспортные сеансы для данной очереди остановлены. Заморозка очереди запрещает отправку исходящих сообщений, хотя новые сообщения могут в нее добавляться. Состояние подключения можно изменить вручную с помощью контекстного меню для каждой очереди связей. При использовании команды Установить подключение для изменения состояния очереди на «Активное» сразу же включается подключение и происходит отправка сообщений из данной очереди.

Очередь Локальная доставка содержит сообщения, включенные в очередь на сервере Exchange для локальной доставки в почтовый ящик Exchange Server хранилище общих папок.

Сообщения могут накапливаться в этой очереди, если сервер Exchange yt принимает сообщения для локальной доставки. Медленная или прерывистая доставка сообщений может свидетельствовать о зацикливании процесса доставки сообщений или о низкой производительности системы.

Чтобы устранить эту ошибку, увеличьте объем заносимой в журнал диагностической информации для службы MSExchangeTransport, чтобы собрать необходимые сведения о компонентах классификатора.

Дополнительные сведения о способах изменения параметров ведения журнала см. в подразделе, содержащем инструкции по изменению параметров ведения журнала для службы MSExchangeTransport, который находится в разделе, посвященном вопросам устранения неполадок потока почты и SMTP руководства по транспорту и маршрутизации сервера Exchange (http://go.microsoft.com/fwlink/?LinkId=47579).

Дополнительные сведения об устранении проблем, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел по устранению проблем потока почты и SMTP в руководстве по транспорту и маршрутизации сервера Exchange (http://go.microsoft.com/fwlink/?LinkId=47579).

  • База знаний Майкрософт, статья 823489, описывающая использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • База знаний Майкрософт, статья 821877, содержащая описание полей на вкладках свойств очередей SMTP и X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • База знаний Майкрософт, статья 264054, в которой приводятся общие сведения о состояниях очередей в Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Очередь «Локальная доставка» находится в состоянии повторения
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-03

Средство анализатора сервера Microsoft® Exchange запрашивает класс инструментария управления Windows (WMI) ExchangeLink, чтобы определить значение параметра StateRetry для SMTP-очереди Локальная доставка.

Если анализатор сервера Exchange обнаружит, что значение параметра StateRetry для очереди Локальная доставка на сервере Exchange равно True , анализатор сервера Exchange выводит сообщение об ошибке.

Если очередь находится в состоянии повторения, это состояние указывает, что произошла по крайней мере одна ошибка в предыдущих попытках обработки сообщений в этой очереди. С помощью команды Установить подключение очереди, находящиеся в состоянии Retry или Scheduled, можно перевести в состояние Active. Это заставит очередь функционировать, как если бы интервал повторения закончился или было достигнуто запланированное время. Однако этот метод действует не всегда. Свойства очереди могут указывать на конкретную причину, по которой очередь находится в состоянии Retry.

Очередь Локальная доставка содержит сообщения, занесенные в очередь на сервере Exchange для локальной доставки в почтовый ящик сервера Exchange или хранилище общих папок.

Сообщения могут накапливаться в этой очереди, если сервер Exchange не принимает сообщения для локальной доставки. Медленная или неустойчивая доставка сообщений может указывать на зацикливание сообщения или проблему производительности.

Чтобы устранить эту ошибку, повысьте уровень диагностики в журнале для службы MSExchangeTransport, чтобы собрать сведения о компонентах классификатора.

Дополнительные сведения об изменении настройки ведения журнала см. в разделе «How to Modify Logging Settings for MSExchangeTransport» (Изменение параметров ведения журнала для службы MSExchangeTransport) части «Troubleshooting Mail Flow and SMTP» (Устранение неполадок потока почты и SMTP) руководства Exchange Server Transport and Routing Guide (Руководство по транспорту и маршрутизации сервера Exchange) (http://go.microsoft.com/fwlink/?LinkId=47579).

Дополнительные сведения об устранении проблем, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел по устранению проблем потока почты и SMTP в руководстве по транспорту и маршрутизации сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).

  • База знаний Майкрософт, статья 823489, описывающая использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • База знаний Майкрософт, статья 821877, содержащая описание полей на вкладках свойств очередей SMTP и X.400 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Статья 264054 базы знаний Майкрософт, содержащая общие сведения о состояниях очередей в Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Ошибка принятия почты
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Средство анализатора сервера Microsoft® Exchange пытается отправить сообщение на учетную запись администратора почтовой системы или на учетную запись, определяемую пользователем, для SMTP-домена (Simple Mail Transfer Protocol) следующим образом:

  • Анализатор сервера Exchange открывает подключение через сокет к SMTP-серверу. Если анализатор сервера Exchange получает код ответа, равный 220, этот шаг считается выполненным успешно.

  • Анализатор сервера Exchange передает SMTP-команду EHLO. Этот шаг считается успешно выполненным, если соблюдаются следующие условия:

    • Анализатор сервера Exchange получает серию кодов ответов, равных 250.

    • Один из этих ответов содержит выражения 250-X-LINK2STATE и 250-XEXCH50.

  • Анализатор сервера Exchange передает SMTP-команду MAIL FROM: ExMFA-MailAcceptTest@Fabrikam.com. Если анализатор сервера Exchange получает код ответа, равный 250, этот шаг считается выполненным успешно.

  • Анализатор сервера Exchange передает SMTP-команду RCPT TO: Postmaster (или учетная запись, определяемая пользователем)@<имя_домена>.com. Если анализатор сервера Exchange получает код ответа, равный 250, этот шаг считается выполненным успешно.

  • Анализатор сервера Exchange передает SMTP-команду DATA с примером тела сообщения, оканчивающегося точкой. Если анализатор сервера Exchange получает код ответа, равный 250, этот шаг считается выполненным успешно.

Если анализатору сервера Exchange не удается выполнить все шаги, на экран выводится сообщение об ошибке. Сообщение об ошибке указывает на возможность существования общей проблемы с потоком почты. Ниже перечисляются ссылки, порядок расположения которых соответствует шагам алгоритма устранения неполадок, начиная с уровня сервера и заканчивая уровнем сети.

Чтобы устранить эту ошибку

  1. См. описание устранения неполадок в маршрутизации в руководстве по транспорту и маршрутизации Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=47579).

  2. См. в базе знаний Майкрософт статью 324867, посвященную веб-презентации службы поддержки по устранению проблем с потоком почты в Microsoft Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324867).

  3. См. в базе знаний Майкрософт статью 823489, содержащую инструкции по использованию средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489).

  4. См. в базе знаний Майкрософт статью 324759, посвященную веб-презентации службы поддержки по устранению неполадок DNS в средствах транспорта Microsoft Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324759).

Дополнительные сведения об учетной записи администратора почтовой системы на сервере Exchange см. в следующих статьях базы знаний Майкрософт:

  • статья 223860, описывающая необходимость установки вручную почтового ящика SMTP администратора почтовой системы (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=223860);

  • статья 313832, содержащая инструкции по установке учетной записи администратора почтовой системы в Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313832).


Ошибка принятия почты, команда BDAT
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-08-21

Средство анализатора сервера Microsoft® Exchange передает ESMTP-команду (Extended Simple Mail Transfer Protocol) EHLO в порт 25 удаленного сервера и анализирует ответ, чтобы определить, поддерживает ли удаленный сервер ESMTP-команду BDAT.

Если отклик, полученный от удаленного сервера в ответ на команду BDAT, не указывает на неисправимую ошибку, анализатор сервера Exchange передает затем тестовое сообщение на удаленный сервер и анализирует ответ, чтобы определить, была ли передача сообщения успешной.

Если анализатор сервера Exchange не получает ожидаемую строку ответа «250», на экран выводится сообщение об ошибке.

Приложение Exchange Server 2003 использует характерные для Exchange расширенные SMTP-команды для взаимодействия с другими серверами, на которых в организации выполняется сервер Exchange. По сравнению со стандартным протоколом SMTP расширенные SMTP-команды, характерные для Exchange, обеспечивают большую эффективность взаимодействия. Если поддержка для множества ESMTP-команд отключена, это может негативно сказаться на быстродействии сервера Exchange.

ESMTP-команда BDAT может использоваться вместо команды DATA. Когда виртуальный SMTP-сервер отвечает на ключевое слово EHLO с помощью строки «CHUNKING», SMTP-сервер указывает, что он поддерживает команду BDAT и принимает сообщения отдельными порциями. Данная команда принимает два аргумента:

  • Первый аргумент указывает длину пакета двоичных данных. Поэтому SMTP-узел не должен непрерывно проверять, закончен ли фрагмент данных. Получающий север считает количество байтов в сообщении. Когда размер сообщения равен значению, отправленному командой BDAT, сервер предполагает, что им получены все данные сообщения.

  • Второй аргумент указывает, является ли пакет данных последним пакетом в текущей передаче. Второй аргумент необязательный.

Данная ошибка указывает, что хотя ESMTP-команда BDAT поддерживается удаленным сервером, последующая проверка принятия почты BDAT завершилась ошибкой.

Чтобы устранить эту ошибку, проверьте среду обмена сообщениями на наличие проблем или настроек, которые могут блокировать команду BDAT, например:

  • временные перебои в работе сети,

  • прокси-серверы SMTP,

  • сетевые экраны,

  • приложения.

Дополнительные сведения об удалении и восстановлении поддержки по умолчанию для этих команд см. в базе знаний Майкрософт, в статье 257569, содержащей инструкции по отключению ESMTP-команд в Exchange 2000 Server и Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569).

Дополнительные сведения об использовании ESMTP-команд сервером Exchange см. в разделе, описывающем правильную загрузку протокола SMTP для Exchange в руководстве по транспорту и маршрутизации сервера Exchange (http://go.microsoft.com/fwlink/?LinkID=71800).


Хранилище почтовых ящиков, указанное в качестве общего назначения
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-10-04

Средство анализа Microsoft® Exchange Server запрашивает класс WMI Exchange_Queue, чтобы определить значение следующих атрибутов очереди SMTP на виртуальном SMTP-сервере.

LinkId | Указывает на код ссылки, содержащей очередь.
QueueId | Указывает на код очереди.
QueueName | Указывает на имя очереди.
VirtualMachine | Указывает на имя виртуальной машины, содержащей очередь.
VirtualServerName | Указывает на имя виртуального сервера, на котором находится очередь.
MessageCount | Указывает на количество сообщений в очереди.

Средство анализа сервера Exchange Server использует полученные данные для запроса у класса WMI Exchange_QueuedSMTPMessage значений следующих атрибутов сообщений из очереди:

Recipients | Указывает на получателей сообщения.
Received | Указывает на полученную метку времени сообщения.
MessageId | Указывает на код сообщения, находящегося в очереди.
StateRetry | Указывает на повторную передачу сообщения, которое не было доставлено.

Кроме того, средство Exchange Server Analyzer использует полученные данные для запроса службы директорий Active Directory® с целью получения следующих значений объекта Recipient. Затем средство анализа Exchange Server определяет, является ли получателем пользователь, группа рассылки, общая папка или хранилище общих папок.

distinguishedName | Указывает на отличительное имя объекта.
msExchHomeServerName | Указывает на сервер, к которому подключен получатель.
homeMDB | Указывает на хранилище почтовых ящиков получателя.

Если средство Exchange Server Analyzer определяет, что как минимум у 25 процентов сообщений, скопившихся в очереди, в полях To: (Кому) или Cc: (Копия) указаны получатели, чьи почтовые ящики находятся в одном и том же хранилище почтовых ящиков, то отображается предупреждение.

Если средство Exchange Server Analyzer определяет, что как минимум у 50 процентов сообщений, скопившихся в очереди, в полях To: (Кому) или Cc: (Копия) указаны получатели, чьи почтовые ящики находятся в одном и том же хранилище почтовых ящиков, то отображается сообщение об ошибке.

Такое предупреждение или сообщение об ошибке означает, что указанное хранилище почтовых ящиков является общим назначением сообщений, скопившихся в очереди SMTP.

Для решения данной проблемы следует проверить хранилище почтовых ящиков на наличие ошибок в конфигурации и других неполадок, которые могли вызвать скопление сообщений в очереди:

  • Убедитесь, что атрибуты объекта хранилища почтовых ящиков в службе Active Directory правильно установлены и содержат правильные значения.

  • Убедитесь в правильности параметров разрешений объекта хранилища в службе Active Directory .

  • Если хранилище почтовых ящиков содержит объект пользователя специального применения, т. е. назначенного получателя журнала, проверьте конфигурации службы или компонентов, к которым относится объект пользователя, на правильность конфигурации.

  • Проверьте наличие нежелательной почты или вирусных атак, направленных против хранилища.

Дополнительные сведения об устранении неполадок, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел «Устранение проблем, связанных с потоком почты и протоколом SMTP» в руководстве по транспортировке и маршрутизации сервера Exchange по адресу http://go.microsoft.com/fwlink/?LinkID=67875 (на английском языке).

  • Статья 823489 базы знаний Майкрософт «Использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003» по адресуhttp://go.microsoft.com/fwlink/?linkid=3052&kbid=823489 (эта ссылка может указывать на содержимое полностью или частично на английском языке).


Очередь "Сообщения с недостижимым местом назначения" задерживает сообщения
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-10-04

Средство анализа Microsoft® Exchange запрашивает класс WMI ExchangeLink, чтобы определить значение свойств TypeCurrentlyUnreachableLinkName и NumberofMessages для очередей протокола SMTP на сервере.

Если свойство TypeCurrentlyUnreachable имеет значение True, то канал связи (очередь сервера Exchange) задерживает сообщения для назначений, недоступных в настоящее время.

Свойство LinkName указывает на имя канала связи.

Свойство NumberOfMessages указывает на количество сообщений, ожидающих передачи по каналу связи.

Если средство анализа Exchange Server определяет, что очередь службы SMTP для Сообщения с недостижимым местом назначения содержит сообщения, то на экран выводится сообщение об ошибке.

Эта ошибка означает наличие в очереди сообщений, которые не могут достичь требуемого сервера назначения. Например, сервер Exchange не может определить маршрут или соединитель до конечного назначения. Кроме того, все доступные маршруты или соединители могут быть обозначены как остановленные.

Устранение этой ошибки

  • Определите достоверность отправителя сообщений в очереди Сообщения с недостижимым местом назначения.

  • Ознакомьтесь с руководством по действиям в случае ошибок и ссылками, указанными средством анализа сервера Exchange Server.

  • Следуйте указаниям в разделе «Дополнительные сведения» ниже в этой же теме.

Дополнительные сведения

Дополнительные сведения об устранении проблем, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел «Устранение проблем, связанных с потоком почты и протоколом SMTP» в Руководстве по транспортировке и маршрутизации сервера Exchange по адресу: http://go.microsoft.com/fwlink/?LinkId=47579 (на английском языке).

  • Статья 823489 базы знаний Майкрософт «Использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003» по адресуhttp://go.microsoft.com/fwlink/?linkid=3052&kbid=823489 (эта ссылка может указывать на содержимое полностью или частично на английском языке).


Очередь «Сообщения с недостижимым местом назначения» заморожена
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-10-06

Средство Microsoft® Exchange Server Analyzer Tool запрашивает класс ExchangeLink инструментария WMI с целью определить значение ключа StateFrozen для очереди Сообщения с недостижимым местом назначения протокола SMTP.

Если средство анализа Exchange Server обнаруживает, что ключ StateFrozen очереди Сообщения с недостижимым местом назначения сервера Exchange имеет значение True, то отображается сообщение об ошибке.

При фиксации очереди все сеансы передачи для этой очереди прекращаются. Фиксация очереди препятствует отправке исходящих сообщений, при этом можно добавлять новые сообщения.

В очереди Сообщения с недостижимым местом назначения находятся сообщения, которые не могут достичь требуемого сервера назначения. Например, сервер Exchange не может определить маршрут или соединитель до конечного назначения. Кроме того, все доступные маршруты или соединители могут быть обозначены как остановленные. Сообщения накапливаются в этой очереди при выполнении следующих условий.

  • Отсутствует маршрут для доставки сообщения.

  • Соединитель или удаленная очередь доставки Exchange недоступны.

  • Новые сообщения перемещаются в эту очередь в том случае, если соединитель или удаленная очередь доставки Exchange находятся в состоянии повторной попытки, а альтернативные маршруты до соединителя или удаленной очереди доставки отсутствуют.

Для устранения этой ошибки вручную измените состояние соединения с помощью контекстного меню на каждой очереди канала связи. При использовании команды Force Connection для включения активного состояния очереди происходит немедленная установка соединения, через которое начинается отправка сообщений из этой очереди. Если ошибка не устраняется, поднимите уровень ведения журнала диагностики для механизма постановки в очередь, как описано ниже в разделе дополнительных сведений этой статьи.

Дополнительные сведения

Для получения дополнительных сведений об изменении параметров ведения журнала см. описание изменения параметров ведения журнала для MSExchangeTransport в разделе, посвященном устранению неполадок почтового потока и протокола SMTP, в руководстве по маршрутизации и транспортировке сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).

Дополнительные сведения об устранении неполадок, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел «Устранение проблем, связанных с потоком почты и протоколом SMTP» в руководстве по транспортировке и маршрутизации сервера Exchange по адресу: http://go.microsoft.com/fwlink/?LinkId=47579 (на английском языке).

  • Статья 823489 базы знаний Майкрософт «Использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003» по адресуhttp://go.microsoft.com/fwlink/?linkid=3052&kbid=823489 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 821877 базы знаний Майкрософт «Описание полей на вкладках свойств очередей SMTP и X.400» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 264054 базы знаний Майкрософт «XCON: сведения о состояниях очередей в Exchange 2000 Server» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054 (эта ссылка может указывать на содержимое полностью или частично на английском языке).


Повторная попытка очереди «Сообщения с недостижимым местом назначения»
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-10-06

Средство анализа Microsoft® Exchange Server запрашивает класс WMI ExchangeLink, чтобы определить значение ключа StateRetry для очереди Сообщения с недостижимым местом назначения службы SMTP.

Если средство анализа Exchange Server обнаруживает, что значение ключа StateRetry для очереди Сообщения с недостижимым местом назначения на сервере Exchange Server — True, оно выводит ошибку.

Если очередь находится в состоянии повторной попытки, средство указывает, что во время предыдущих попыток обнаружена как минимум одна ошибка обработки сообщений в очереди.

Примечание.
В свойствах очереди указана точная причина ее нахождения в состоянии повторной попытки.

В очереди Сообщения с недостижимым местом назначения находятся сообщения, которые не могут достичь требуемого сервера назначения. Например, сервер Exchange не может определить маршрут или соединитель до конечного назначения. Кроме того, все доступные маршруты или соединители могут быть обозначены как остановленные. Сообщения накапливаются в этой очереди при выполнении следующих условий.

  • Отсутствует маршрут для доставки сообщения.

  • Соединитель или удаленная очередь доставки Exchange недоступны.

  • Новые сообщения перемещаются в эту очередь в том случае, если соединитель или удаленная очередь доставки Exchange находятся в состоянии повторной попытки, а альтернативные маршруты до соединителя или удаленной очереди доставки отсутствуют.

Чтобы устранить проблему, измените состояние Retry на Active с помощью команды Force Connection. Это заставит очередь работать так, как будто время повторной попытки истекло. Однако этот метод может работать не всегда. Если ошибка не устраняется, поднимите уровень ведения журнала диагностики для механизма постановки в очередь, как описано ниже в разделе дополнительных сведений этой статьи.

Дополнительные сведения

Для получения дополнительных сведений об изменении параметров ведения журнала см. описание изменения параметров ведения журнала для MSExchangeTransport в разделе, посвященном устранению неполадок почтового потока и протокола SMTP, в руководстве по маршрутизации и транспортировке сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).

Дополнительные сведения об устранении неполадок, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел «Устранение проблем, связанных с потоком почты и протоколом SMTP» в руководстве по транспортировке и маршрутизации сервера Exchange по адресу: http://go.microsoft.com/fwlink/?LinkId=47579 (на английском языке).

  • Статья 823489 базы знаний Майкрософт «Использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003» по адресуhttp://go.microsoft.com/fwlink/?linkid=3052&kbid=823489 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 821877 базы знаний Майкрософт «Описание полей на вкладках свойств очередей SMTP и X.400» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 264054 базы знаний Майкрософт «XCON: сведения о состояниях очередей в Exchange 2000 Server» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054 (эта ссылка может указывать на содержимое полностью или частично на английском языке).


Почтовые ящики с ограничениями по доставке, установленными группой рассылки
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-08-21

Чтобы определить, существуют ли для каких-либо почтовых ящиков в доменах ограничения по доставке, установленные на основе членства в группе рассылки, средство анализатора сервера Microsoft® Exchange запрашивает для каждого объекта пользователя во всех доменах, обнаруженных в службе каталогов Active Directory®, следующие атрибуты:

dLMemDefault | Указывает, будут ли сообщения приниматься или отклоняться по умолчанию. Когда атрибут установлен в значение по умолчанию, равное 1, принимаются сообщения от всех отправителей.
dLMemRejectPerms | Содержит различающиеся имена списков рассылки, членам которых не разрешено отправлять сообщения этому получателю.
dLMemSubmitPerms | Содержит различающиеся имена списков рассылки, членам которых разрешено отправлять сообщения этому получателю.

Если анализатор сервера Exchange определит, что в домене существуют почтовые ящики, для которых имеются ограничения по доставке, установленные на основе членства в группе рассылки, на экран будет выведено предупреждение.

Это предупреждение означает, что ограничения по доставке на основе членства в группе рассылки могут влиять на интенсивность потока почты сервера Exchange.

По умолчанию классификатор рекурсивно разворачивает группы рассылки и проверяет ограничения для каждого сообщения, проходящего через систему.

Когда классификатор сообщений отправляет почту пользователю, принимающему или блокирующему сообщения из группы доставки, классификатор сообщений должен развернуть структуру членства в группе рассылки, получить полный список различающихся имен членов и затем сравнить список различающихся имен с различающимися именами отправителей в списке. Когда различающееся имя присутствует в обоих списках, выполняется операция разрешения доступа или операция запрета доступа. Если группа рассылки вложена в другую группу рассылки, вложенная группа рассылки также разворачивается.

Чтобы устранить причины появления этого предупреждения, выполните следующие действия:

  • Проанализируйте тех пользователей, чьи ограничения по доставке установлены группой рассылки, и удалите ненужные ограничения.

  • Настройте отдельные почтовые ящики, а не группы рассылки для ограничений по доставке согласно сведениям, содержащимся в базе знаний Майкрософт, в статье 812298, описывающей ситуацию, когда доставка почты замедляется после настройки ограничений по доставке на основе списка рассылки (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Для серверов, на которых выполняется Microsoft Exchange Server 2003 с пакетом обновления 2 (SP2) или более поздняя версия, рассмотрите возможность реализации неиерархической проверки ограничений. Для серверов, на которых выполняются версии Exchange, предшествующие Exchange Server 2003 с пакетом обновления 2 (SP2), рассмотрите возможность обновления до Exchange Server 2003 с пакетом обновления 2 (SP2).

Дополнительные сведения

Дополнительные сведения о неиерархической проверке ограничений см. по ссылке Рассмотрите возможность неиерархической проверки ограничений.

Дополнительные сведения о влиянии ограничения групп рассылок на поток почты сервера Exchange см. в следующих статьях базы знаний Майкрософт:

  • Статья 895407, описывающая ситуацию в Exchange Server 2003, когда доставка сообщений в локальные и во внешние почтовые ящики вопреки ожиданиям замедляется после настройки ограничений по доставке на основе групп рассылок (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • Статья 839949, описывающая устранение неполадок почтового транспорта и групп рассылок в Exchange 2000 Server и в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • Статья 812298, описывающая ситуацию, когда доставка почты замедляется после настройки ограничений по доставке на основе списка рассылки (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).


Максимальный размер входящего сообщения не задан
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-01-05

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение для атрибута delivContLength глобальных параметров, находящегося в следующих группах:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Если анализатор сервера Exchange определяет, что значение атрибута delivContLength меньше 1, на экран выводится предупреждение.

Эта ошибка указывает, что максимальный размер всходящего сообщения не задан. Исходя из пропускной способности сети и пользовательских требований в данной организации, может понадобиться ограничить размер с сообщения. В серверах Exchange 2000 Server и Exchange Server 2007 отсутствует ограничение размера сообщения по умолчанию. В сервере Exchange Server 2003 предельный размер исходящих и входящих сообщений по умолчанию составляет 10 240 КБ. Ограничение размера по умолчанию для сервера Exchange Server 2003 применяется к недавно установленным серверам и к серверам, обновленным с сервера Exchange 2000 Server, для которых не было установлено ограничение размера сообщения.

Можно сберечь системные ресурсы путем задания ограничений на размер сообщений, что предотвращает отправку и прием пользователями больших сообщений электронной почты. Это поможет ограничить сетевой трафик, сберечь место на диске и улучшить пропускную способность сети. При работе с сервером Exchange 2000 Server или Exchange Server 2003 можно использовать вкладку Defaults окна Message Delivery Properties узла Global Settings для указания ограничений по доставке входящих и исходящих сообщений. Для того чтобы затем установить максимальный размер одного сообщения, выберите параметр Максимум (КБ) и введите в текстовое поле максимальный размер в килобайтах (КБ). Если ограничивать размер сообщений не требуется, выберите Без ограничений. Отправители в организации получат отчет о недоставке, если попытаются послать сообщение пользователю, для которого превышено заданное ограничение на размер. В зависимости от параметров отчета о недоставке, настроенных на странице «Форматы сообщений Интернета», внешние отправители могут получать или не получать отчеты о недоставке.

При работе с сервером Exchange Server 2007 можно с помощью командной консоли Exchange настроить параметр TransportConfig MaxSendSize для организации Exchange.

Рекомендуется установить ограничение предельного размера сообщения не более 10 МБ. Однако если необходимо отправлять сообщения с большими вложениями через организацию Exchange, может потребоваться увеличить предельный размер входящих сообщений до 30 МБ. Увеличение предельного размера сообщений свыше 30 МБ может привести к снижению производительности сети и сделать систему более уязвимой к атакам.

Установка ограничений размера сообщения для серверов Exchange 2000 Server и Exchange Server 2003

  1. В диспетчере системы Exchange разверните узел Глобальные параметры, щелкните правой кнопкой мыши Доставка сообщения и выберите в контекстном меню Свойства.

  2. В диалоговом окне Доставка сообщений — свойства на вкладке Параметры по умолчанию выберите параметр Предельный размер получаемых сообщений и введите требуемый предельный размер.

Установка ограничений размера сообщения для сервера Exchange Server 2007

  1. В среде управления Exchange выполните следующую команду, где в качестве <размера> указывается значение «не ограничен» либо размер в байтах (B), килобайтах (KB) или мегабайтах (MB) в диапазоне от 0 до 2 147 483 647 байт:
Копировать код
Set-TransportConfig -MaxReceiveSize <size>

Например, чтобы установить для сообщений, получаемых пользователями организации Exchange, максимальный размер, равный 10 МБ, необходимо ввести следующее значение:

Копировать код
Set-TransportConfig -MaxReceiveSize 10MB

Для того чтобы снять ограничение максимального размера сообщений, отправляемых пользователями организации Exchange (это значение по умолчанию), необходимо ввести следующее значение:

Копировать код
Set-TransportConfig -MaxReceiveSize unlimited
  • Дополнительные сведения об ограничении размера сообщений в Exchange 2000 Server и Exchange Server 2003 см. в статье 322679 базы знаний Майкрософт «Установка ограничения размера сообщений в Exchange Server» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

  • Дополнительные сведения о командлете TransportConfig для сервера Exchange Server 2007 см. в разделе Set-TransportConfig технического справочника по Exchange Server 2007 по адресу http://go.microsoft.com/fwlink/?LinkID=79237 (на английском языке).

  • Дополнительные сведения о форматах сообщений Интернета см. в разделе, посвященном настройке политик SMTP для управления форматированием исходящей почты и автоматическими ответами, руководства по администрированию Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47617).


Установлен слишком большой размер входящих сообщений (>30МБ)
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-02-27

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение для атрибута delivContLength глобальных параметров, находящегося в следующем месте:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Если анализатор сервера Exchange находит, что значение атрибута delivContLength превышает 30720, на экран выводится сообщение об ошибке.

Эта ошибка указывает, что ограничение максимального размера входящих сообщений было установлено выше 30 мегабайт (МБ). В серверах Exchange 2000 Server и Exchange Server 2007 отсутствует ограничение размера сообщения по умолчанию. В сервере Exchange Server 2003 предельный размер исходящих и входящих сообщений по умолчанию составляет 10 240 КБ. Данный предельный размер по умолчанию применяется к новым установкам и к обновлениям с сервера Exchange 2000 Server, в котором не задан предельный размер сообщения.

Можно сберечь системные ресурсы путем задания ограничений на размер сообщений, что предотвращает отправку и прием пользователями больших сообщений электронной почты. Это поможет ограничить сетевой трафик, сберечь место на диске и улучшить пропускную способность сети. При работе с сервером Exchange 2000 Server или Exchange Server 2003 можно использовать вкладку Defaults окна Message Delivery Properties узла Global Settings для указания ограничений по доставке входящих и исходящих сообщений. Чтобы задать наибольший размер отдельного сообщения, выберите Максимум (КБ) и затем в текстовом поле введите наибольший размер в килобайтах (КБ). Если ограничивать размер сообщений не требуется, выберите Без ограничений. Отправители в организации получат отчет о недоставке, если попытаются послать сообщение пользователю, для которого превышено заданное ограничение на размер. В зависимости от параметров отчета о недоставке, настроенных на странице «Форматы сообщений Интернета», внешние отправители могут получать или не получать отчеты о недоставке.

При работе с сервером Exchange Server 2007 можно с помощью оболочки управления Exchange настроить параметр TransportConfig MaxSendSize для организации Exchange.

Рекомендуется установить ограничение предельного размера сообщения не более 30 МБ. Однако если необходимо отправлять сообщения с большими вложениями через организацию Exchange, может потребоваться увеличить предельный размер входящих сообщений свыше 30 МБ. Увеличение предельного размера сообщений свыше 30 МБ может привести к снижению производительности сети и сделать систему более уязвимой к атакам.

Важно!
Хотя результаты настройки следующих параметров в средах, включающих только серверы Exchange 2000 Server/Exchange Server 2003, и средах, включающих только Exchange Server 2007, могут показаться похожими, на самом деле они существенно различаются.

Присвоение предельному размеру исходящих и входящих сообщений значения 0 в узле глобальных параметров почтового ящика в среде, содержащей только серверы Exchange 2000 Server и Exchange Server 2003, полностью устраняет ограничения на размер сообщений.

Присвоение значения 0 параметрам TransportConfig -MaxSendSize и TransportConfig -MaxreceiveSize в среде, содержащей только серверы Exchange 2007, блокирует отправку сообщений любого размера.

Установка ограничений размера сообщения для серверов Exchange 2000 Server и Exchange Server 2003

  1. В диспетчере системы Exchange разверните узел Глобальные параметры, щелкните правой кнопкой мыши Доставка сообщения и выберите в контекстном меню Свойства.

  2. В диалоговом окне Доставка сообщений — свойства на вкладке Параметры по умолчанию выберите параметр ??Предельный размер принимаемых сообщений?? и введите требуемый предельный размер.

Установка ограничений размера сообщения для сервера Exchange Server 2007

  1. В среде управления Exchange выполните следующую команду, где в качестве <размера> указывается значение «не ограничен» либо размер в байтах (B), килобайтах (KB) или мегабайтах (MB) в диапазоне от 0 до 2 147 483 647 байт:
Копировать код
Set-TransportConfig -MaxReceiveSize <size>

Например, чтобы установить для сообщений, получаемых пользователями организации Exchange, максимальный размер, равный 10 МБ, необходимо ввести следующее значение:

Копировать код
Set-TransportConfig -MaxReceiveSize 10MB

Для того чтобы снять ограничение максимального размера сообщений, отправляемых пользователями организации Exchange (это значение по умолчанию), необходимо ввести следующее значение:

Копировать код
Set-TransportConfig -MaxReceiveSize unlimited
  • Дополнительные сведения об ограничении размера сообщений в Exchange 2000 Server и Exchange Server 2003 см. в статье 322679 базы знаний Майкрософт «Установка ограничения размера сообщений в Exchange Server» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

Дополнительные сведения о командлете TransportConfig для сервера Exchange Server 2007 см. в разделе Set-TransportConfig технического справочника по Exchange Server 2007 по адресу http://go.microsoft.com/fwlink/?LinkID=79237 (на английском языке).

  • Дополнительные сведения о форматах сообщений в Интернете см. в разделе «Configuring SMTP Policies to Control Outbound Mail Formatting and Automatic Responses» руководства Exchange Server 2003 Administration Guide (http://go.microsoft.com/fwlink/?LinkId=47617).


Параметр максимального размера входящего сообщения может иметь слишком низкое значение (<1МБ)
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-01-05

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута delivContLength глобальных параметров, расположенного по следующему адресу:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Если средство анализа Exchange Server обнаруживает, что значение атрибута delivContLength меньше 1024 и больше 0, то отображается сообщение об ошибке.

Эта ошибка указывает, что для максимального размера входящего сообщения указано значение менее 1 мегабайта (МБ). При таком низком значении в Exchange Server будет отклонен ряд сообщений, отправленных в данную организацию. В серверах Exchange 2000 Server и Exchange Server 2007 отсутствует ограничение размера сообщения по умолчанию. В Exchange Server 2003 предельный размер исходящих и входящих сообщений по умолчанию составляет 10 240 КБ. Данный предельный размер по умолчанию применяется к новым установкам и к обновлениям с сервера Exchange 2000 Server, в котором не задан предельный размер сообщения.

Можно сберечь системные ресурсы, задав ограничения на размер сообщений, что предотвращает отправку и прием пользователями больших сообщений электронной почты. Это поможет снизить сетевой трафик, сберечь место на диске и улучшить пропускную способность сети. При работе с сервером Exchange 2000 Server или Exchange Server 2003 можно использовать вкладку Defaults окна Message Delivery Properties узла Global Settings для указания ограничений по доставке входящих и исходящих сообщений. Чтобы задать наибольший размер отдельного сообщения, выберите Максимум (КБ) и затем в текстовом поле введите наибольший размер в килобайтах (КБ). Если ограничивать размер сообщений не требуется, выберите Без ограничений. Отправители в организации получат отчет о недоставке, если попытаются послать сообщение определенному пользователю с превышением заданного для него ограничения по размеру. В зависимости от параметров отчета о недоставке, настроенных на странице «Форматы сообщений Интернета», внешние отправители могут получать или не получать отчеты о недоставке.

При работе с сервером Exchange Server 2007 можно с помощью командной консоли Exchange настроить параметр TransportConfig MaxSendSize для организации Exchange.

Рекомендуется установить ограничение предельного размера сообщения не более 10 МБ. Однако если необходимо отправлять сообщения с большими вложениями через организацию Exchange, может потребоваться увеличить предельный размер входящих сообщений до 30 МБ. Увеличение предельного размера сообщений свыше 30 МБ может привести к снижению производительности сети и сделать систему более уязвимой к атакам.

Установка ограничений размера сообщения для серверов Exchange 2000 Server и Exchange Server 2003

  1. В диспетчере Exchange разверните узел Глобальные параметры, щелкните правой кнопкой мыши Доставка сообщения и выберите в контекстном меню команду Свойства.

  2. В диалоговом окне Доставка сообщений — свойства на вкладке Параметры по умолчанию выберите параметр Предельный размер получаемых сообщений и введите нужный предельный размер.

Установка ограничений размера сообщения для сервера Exchange Server 2007

  1. В среде управления Exchange выполните следующую команду, где в качестве <размера> указывается значение «не ограничен» либо размер в байтах (B), килобайтах (KB) или мегабайтах (MB) в диапазоне от 0 до 2 147 483 647 байт:
Копировать код
Set-TransportConfig -MaxReceiveSize <size>

Например, чтобы установить для сообщений, получаемых пользователями организации Exchange, максимальный размер, равный 10 МБ, необходимо ввести следующее значение:

Копировать код
Set-TransportConfig -MaxReceiveSize 10MB

Для того чтобы снять ограничение максимального размера сообщений, отправляемых пользователями организации Exchange (это значение по умолчанию), необходимо ввести следующее значение:

Копировать код
Set-TransportConfig -MaxReceiveSize unlimited
  • Дополнительные сведения об ограничении размера сообщений в Exchange 2000 Server и Exchange Server 2003 см. в статье 322679 базы знаний Майкрософт «Установка ограничения размера сообщений в Exchange Server» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

Дополнительные сведения о командлете TransportConfig для сервера Exchange Server 2007 см. в разделе Set-TransportConfig технического справочника по Exchange Server 2007 по адресу http://go.microsoft.com/fwlink/?LinkID=79237 (на английском языке).

  • Дополнительные сведения о форматах Internet Message Format см. в разделе «Настройка политик SMTP для управления форматированием исходящей почты и автоматическими ответами» руководства администратора Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=47617 (на английском языке).


Не задан параметр MaxDSNSize
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, задан ли максимальный размер уведомлений о состоянии доставки, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MaxDSNSize

Анализатор сервера Exchange также запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута serialNumber для всех объектов, относящихся к классу msExchExchangeServer. Если строковое значение содержит выражение «Version 5.5», на компьютере выполняется приложение Microsoft Exchange Server 5.5. Если строковое значение содержит выражение «Version 6.0», на компьютере выполняется приложение Microsoft Exchange 2000 Server. Если строковое значение содержит выражение «Version 6.5», на компьютере выполняется приложение Microsoft Exchange Server 2003.

Если анализатор сервера Exchange обнаружит, что значение параметра MaxDSNSize реестра не существует на компьютере, на котором выполняется Exchange 2000 Server или Exchange Server 2003, на экран будет выведено предупреждение.

Значение параметра MaxDSNSize реестра является дополнительным значением в сервере Exchange, которое ограничивает размер уведомлений о состоянии доставки. Этот параметр настраивает Exchange на удаление вложений, если сообщение не удается доставить. При добавлении в реестр этого параметра рекомендуется, чтобы его значение было равно 10240000 байтам (10 мегабайтам).

Примечание.
Параметр MaxDSNSize реестра был введен в пакете обновления 2 (SP2) для Exchange 2000 Server, и поэтому для его работы требуется Exchange 2000 Server с пакетом обновления 2 (SP2) или более поздние версии приложения. Кроме того, в пакете обновления 1 (SP1) для Exchange Server 2003 и в более поздних версиях в отсутствие значения параметра MaxDSNSize реестра используется значение, равное 10 мегабайтам. При желании можно добавить значение параметра MaxDSNSize реестра, чтобы переопределить этот алгоритм поведения по умолчанию.

Если включить этот параметр, можно сберечь ресурсы сервера и сети. Однако в этой реализации удаления SMTP-вложений (Simple Mail Transfer Protocol) существуют недостатки. Если включить эту функцию удаления вложений из отчета о недоставке, сведения, которые необходимы для отображения уведомления в области предварительного просмотра, также удаляются, и автор сообщения не может воспользоваться функцией Отправить заново. Если автор сообщения попытается воспользоваться функцией «Отправить заново» из отчета о недоставке, он получит следующее сообщение об ошибке: Не удается повторно отправить сообщение. Отчет о недоставке не содержит достаточной информации об исходном сообщении. Чтобы повторно послать сообщение, откройте его в своей папке «Отправленные», щелкните меню «Действия» и выберите команду «Отправить заново».

Однако автору сообщения не удастся повторно отправить сообщение, даже если он воспользуется методом, описанным в сообщении об ошибке.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\SMTPSvc

  3. Щелкните правой кнопкой мыши SMTPSvc и в контекстном меню выберите Создать | Ключ. Присвойте новому ключу имя Организация очереди и оставьте класс пустым.

  4. Щелкните правой кнопкой мыши Организация очереди и в контекстном меню выберите Создать | Значение DWORD. Присвойте новому значению имя MaxDSNSize.

  5. В правой области дважды щелкните параметр MaxDSNSize реестра и введите требуемый предельный размер (в байтах) в поле «Значение». Сообщения с размером больше данного значения, при достижении которого создается отчет о недоставке, не возвращают вложения или все свойства сообщения.

  6. Закройте редактор реестра и перезапустите службу Протокол SMTP (Simple Mail Transfer Protocol), чтобы изменение вступило в силу.

Дополнительные сведения о настройке параметра MaxDSNSize реестра см. в следующих статьях базы знаний Майкрософт:

  • Статья 308303, описывающая возможность удаления вложений из сообщений, которые создают отчет о недоставке (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308303).

  • Статья 323484, содержащая описание формата многоэлементного сообщения-отчета из Интернета (Multipart/Report Internet Message) в Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=323484).


Максимальный размер исходящего сообщения не задан
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-12-04

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение для атрибута msExchESEParamCacheSizeMax глобальных параметров, находящегося в следующих группах:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Если анализатор сервера Exchange находит, что значение для атрибута submissionContLength должно быть меньше 1, на экран выводится сообщение об ошибке.

Эта ошибка показывает, что наибольший предельный размер исходящего сообщения не задан. Исходя из пропускной способности сети и пользовательских требований в данной организации, может понадобиться ограничить размер с сообщения В серверах Exchange 2000 Server и Exchange Server 2007 отсутствует ограничение размера сообщения по умолчанию. В сервере Exchange Server 2003 предельный размер исходящих и входящих сообщений по умолчанию составляет 10 240 КБ. Данный предельный размер по умолчанию применяется к новым установкам и к обновлениям с сервера Exchange 2000 Server, в котором не задан предельный размер сообщения.

Можно сберечь системные ресурсы путем задания ограничений на размер сообщений, что предотвращает отправку и прием пользователями больших сообщений электронной почты. Это поможет ограничить сетевой трафик, сберечь место на диске и улучшить пропускную способность сети. При работе с сервером Exchange 2000 Server или Exchange Server 2003 можно использовать вкладку Defaults окна Message Delivery Properties узла Global Settings для указания ограничений по доставке входящих и исходящих сообщений. Чтобы задать наибольший размер отдельного сообщения, выберите Максимум (КБ) и затем в текстовом поле введите наибольший размер в килобайтах (КБ). Если ограничивать размер сообщений не требуется, выберите Без ограничений. Отправители в организации получат отчет о недоставке, если попытаются послать сообщение пользователю, для которого превышено заданное ограничение на размер. В зависимости от параметров отчета о недоставке, заданных в узле Форматы сообщений Интернета, внешние отправители могут получить или не получить отчет о недоставке.

При работе с сервером Exchange Server 2007 можно с помощью командной консоли Exchange настроить параметр TransportConfig MaxSendSize для организации Exchange.

Рекомендуется задать наибольший предельный размер сообщения не выше 10 МБ. Однако если необходим больший предельный размер для сообщений с большими вложениями, отправляемыми через организацию Exchange, возможно, потребуется увеличить наибольший предельный размер исходящих сообщений до 30 МБ. Увеличение предельного размера сообщения до величины свыше 30 МБ может снизить пропускную способность сети и даже сделать ее более уязвимой при атаках системы защиты.

Установка ограничений размера сообщения для серверов Exchange 2000 Server и Exchange Server 2003

  1. В диспетчере Exchange разверните узел Глобальные параметры, щелкните правой кнопкой мыши Доставка сообщения и выберите в контекстном меню Свойства.

  2. В диалоговом окне Доставка сообщений — свойства на вкладке Параметры по умолчанию выберите параметр Предельный размер отправляемых сообщений и введите требуемый предельный размер.

Установка ограничений размера сообщения для сервера Exchange Server 2007

  1. В среде управления Exchange выполните следующую команду, где в качестве <размера> указывается значение «не ограничен» либо размер в байтах (B), килобайтах (KB) или мегабайтах (MB) в диапазоне от 0 до 2 147 483 647 байт:
Копировать код
Set-TransportConfig -MaxSendSize <size>

Например, чтобы установить максимальный размер сообщений, отправляемых пользователями организации Exchange, равный 10 мегабайтам, необходимо ввести следующее значение:

Копировать код
Set-TransportConfig -MaxSendSize 10MB

Для того чтобы установить неограниченный максимальный размер сообщений, отправляемых пользователями организации Exchange (значение по умолчанию), необходимо ввести следующее значение:

Копировать код
Set-TransportConfig -MaxSendSize unlimited
  • Дополнительные сведения об установке ограничения размера сообщений для серверов Exchange 2000 Server и Exchange Server 2003 см. в статье 322679 базы знаний Майкрософт «Установка ограничения размера сообщений в Exchange Server» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

  • Дополнительные сведения о командлете TransportConfig для сервера Exchange Server 2007 см. в разделе Set-TransportConfig технического справочника по Exchange Server 2007 по адресу http://go.microsoft.com/fwlink/?LinkID=79237 (на английском языке).

  • Дополнительные сведения о форматах сообщений Интернета см. в разделе "Настройка политик SMTP для управления форматированием исходящей почты и автоматические ответы" в Руководстве по администрированию Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).


Задан слишком большой максимальный размер исходящих сообщений (>30 МБ)
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-12-04

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута глобальных параметров submissionContLength, размещенного на:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Если анализатор сервера Exchange обнаруживает, что для атрибута submissionContLengthзадано значение, превышающее 30720, отображается сообщение об ошибке.

Эта ошибка указывает, что для ограничения максимального размера исходящего сообщения задано значение, превышающее 30 мегабайт (МБ). В зависимости от пропускной способности сети и потребностей пользователя, может понадобиться установить меньший допустимый размер сообщений. В серверах Exchange 2000 Server и Exchange Server 2007 отсутствует ограничение размера сообщения по умолчанию. В Exchange Server 2003 ограничением размера по умолчанию для отправки и получения сообщений является 10,240 КБ. Ограничение размера по умолчанию применяется для новых установок и обновлений с Exchange 2000 Server, в котором было задано ограничение по размеру.

Можно экономить системные ресурсы, задавая ограничения размера сообщений, которые не позволяют пользователям отправлять и получать большие сообщения электронной почты. Это позволяет ограничить объем сетевого трафика, сохранить пространство на диске и улучшить общую производительности сети. При работе с сервером Exchange 2000 Server или Exchange Server 2003 можно использовать вкладку Defaults окна Message Delivery Properties узла Global Settings для указания ограничений по доставке входящих и исходящих сообщений. Чтобы задать максимальный размер отдельного сообщения, выберите Максимум (КБ), а затем в текстовом поле введите максимальный размер в килобайтах (КБ). Если нет необходимости задавать ограничения размера сообщений, укажите Без ограничений. Отправители в организации получают отчет о недоставке при попытке отправить сообщение пользователю, для которого превышено указанное ограничение по размеру. В зависимости от параметров отчета о недоставке, настроенных на странице Форматы сообщений Интернета, внешние отправители могут получать или не получать отчеты о недоставке.

При работе с сервером Exchange Server 2007 можно с помощью командной консоли Exchange настроить параметр TransportConfig MaxSendSize для организации Exchange.

Рекомендуется установить ограничение на максимальный размер сообщения, не превышающее 10 МБ. Однако если необходимо большее ограничение размера сообщений с большими вложениями, отправляемыми в организации Exchange, может потребоваться указать ограничение максимального размера исходящих сообщений, превышающее 30 МБ. Указав ограничение размера сообщения, превышающее 30 МБ, можно замедлить производительность сети и даже сделать систему более уязвимой для атак против системы безопасности.

Установка ограничений размера сообщения для серверов Exchange 2000 Server и Exchange Server 2003

  1. В диспетчере системы Exchange разверните узел Глобальные параметры, щелкните правой кнопкой мыши Доставка сообщения и выберите в контекстном меню Свойства.

  2. В диалоговом окне Доставка сообщения — свойства на вкладке По умолчанию выберите параметр Предел на размер отправляемых сообщений и введите требуемое ограничение размера.

Установка ограничений размера сообщения для сервера Exchange Server 2007

  1. В среде управления Exchange выполните следующую команду, где в качестве <размера> указывается значение «не ограничен» либо размер в байтах (B), килобайтах (KB) или мегабайтах (MB) в диапазоне от 0 до 2 147 483 647 байт:
Копировать код
Set-TransportConfig -MaxSendSize <size>

Например, чтобы установить максимальный размер сообщений, отправляемых пользователями организации Exchange, равный 10 мегабайтам, необходимо ввести следующее значение:

Копировать код
Set-TransportConfig -MaxSendSize 10MB

Для того чтобы установить неограниченный максимальный размер сообщений, отправляемых пользователями организации Exchange (значение по умолчанию), необходимо ввести следующее значение:

Копировать код
Set-TransportConfig -MaxSendSize unlimited
  • Дополнительные сведения об установке ограничения размера сообщений для серверов Exchange 2000 Server и Exchange Server 2003 см. в статье 322679 базы знаний Майкрософт «Установка ограничения размера сообщений в Exchange Server» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

Дополнительные сведения о командлете TransportConfig для сервера Exchange Server 2007 см. в разделе Set-TransportConfig технического справочника по Exchange Server 2007 по адресу http://go.microsoft.com/fwlink/?LinkID=79237 (на английском языке).

  • Для получения дополнительных сведений о форматах сообщений Интернета см. раздел «Настройка SMTP-политик для управления форматированием исходящих сообщений и автоматическими ответами в руководстве по администрированию Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=21769).


Возможно, задан слишком низкий максимальный размер исходящего сообщения
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-12-04

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение для атрибута msExchESEParamCacheSizeMax глобальных параметров, находящегося в следующих группах:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN= имя_организации , CN=Global Settings, CN=Message Delivery

Если анализатор сервера Exchange находит, что значение для атрибута submissionContLength меньше 1024, но больше 0, на экран выводится предупреждение.

Это предупреждение означает, что максимальный предел для размера исходящего сообщения задан на уровне меньше 1 МБ. Исходя из пропускной способности сети и пользовательских требований в данной организации, может потребоваться увеличить размер сообщения, чтобы разрешить сообщения большего размера. На серверах Exchange 2000 Server и Exchange Server 2007 отсутствует ограничение размера сообщения по умолчанию. В сервере Exchange Server 2003 предельный размер исходящих и входящих сообщений по умолчанию составляет 10 240 КБ. Данный предельный размер по умолчанию применяется к новым установкам и к обновлениям с сервера Exchange 2000 Server, в котором не задан предельный размер сообщения.

Можно сберечь системные ресурсы путем задания ограничений на размер сообщений, что предотвращает отправку и прием пользователями больших сообщений электронной почты. Это поможет ограничить сетевой трафик, сберечь место на диске и улучшить пропускную способность сети. При работе с сервером Exchange 2000 Server или Exchange Server 2003 можно использовать вкладку Defaults окна Message Delivery Properties узла Global Settings для указания ограничений по доставке входящих и исходящих сообщений. Чтобы задать наибольший размер отдельного сообщения, выберите Максимум (КБ) и затем в текстовом поле введите наибольший размер в килобайтах (КБ). Если ограничивать размер сообщений не требуется, выберите Без ограничений. Отправители в организации получат отчет о недоставке, если попытаются отправить сообщение пользователю, для которого превышено заданное ограничение размера. В зависимости от параметров отчета о недоставке, заданных в узле Форматы сообщений Интернета, внешние отправители могут получить или не получить отчет о недоставке.

При работе с сервером Exchange Server 2007 можно с помощью командной консоли Exchange настроить параметр TransportConfig MaxSendSize для организации Exchange.

Рекомендуется задать наибольший предельный размер сообщения не выше 30 МБ. Однако если через организацию Exchange необходимо отправлять сообщения с большими вложениями, возможно, потребуется увеличить предельный размер исходящих сообщений свыше 30 МБ. Увеличение предельного размера сообщения до величины свыше 30 МБ может снизить пропускную способность сети и даже сделать ее более уязвимой при атаках на систему защиты.

Установка ограничений размера сообщения для серверов Exchange 2000 Server и Exchange Server 2003

  1. В диспетчере Exchange разверните узел Глобальные параметры, щелкните правой кнопкой мыши Доставка сообщения и выберите в контекстном меню Свойства.

  2. В диалоговом окне Доставка сообщений — свойства на вкладке Параметры по умолчанию выберите параметр Предельный размер отправляемых сообщений и введите требуемый предельный размер.

Установка ограничений размера сообщения для сервера Exchange Server 2007

  1. В среде управления Exchange выполните следующую команду, где в качестве <размера> указывается значение «не ограничен» либо размер в байтах (B), килобайтах (KB) или мегабайтах (MB) в диапазоне от 0 до 2 147 483 647 байт:
Копировать код
Set-TransportConfig -MaxSendSize <size>

Например, чтобы установить максимальный размер сообщений, отправляемых пользователями организации Exchange, равный 10 мегабайтам, необходимо ввести следующее значение:

Копировать код
Set-TransportConfig -MaxSendSize 10MB

Для того чтобы установить неограниченный максимальный размер сообщений, отправляемых пользователями организации Exchange (значение по умолчанию), необходимо ввести следующее значение:

Копировать код
Set-TransportConfig -MaxSendSize unlimited
  • Дополнительные сведения об установке ограничения размера сообщений для серверов Exchange 2000 Server и Exchange Server 2003 см. в статье 322679 базы знаний Майкрософт «Установка ограничения размера сообщений в Exchange Server» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

Дополнительные сведения о командлете TransportConfig для сервера Exchange Server 2007 см. в разделе Set-TransportConfig технического справочника по Exchange Server 2007 по адресу http://go.microsoft.com/fwlink/?LinkID=79237 (на английском языке).

  • Дополнительные сведения о форматах сообщений Интернета см. в разделе "Настройка политик SMTP для управления форматированием исходящей почты и автоматические ответы" в Руководстве по администрированию Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).


Включено ведение журнала только для сообщений
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-01-10

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, настроен ли атрибутmsExchMessageJournalRecipient для копирования почтового сообщения в почтовый ящик получателя. Атрибут msExchMessageJournalRecipient является атрибутом объектов хранилища почтовых ящиков в Active Directory. По умолчанию атрибут msExchMessageJournalRecipient не настроен. Если анализатор сервера Exchange обнаруживает, что атрибут msExchMessageJournalRecipient настроен, то он выводит на экран сообщение о конфигурации не по умолчанию. Анализатор сервера также отображает имя базы данных и имя сервера, где включено ведение журнала только для сообщений.

Функция ведения журнала сообщений в Exchange Server 2003 и функция стандартного ведения журнала Exchange Server 2007 создает копию данных всех сообщений с соответствующим заголовком P2, отправляемых и получаемых всеми пользователями в почтовой базе данных, и отправляет копию сообщения в указанный почтовый ящик. Заголовок P2 сообщения содержит только данные получателя сообщения, которые отправитель показывает получателям. Если внешнее сообщение принято из Интернета, сервер Exchange заносит в журнал заголовки P1 сообщений. Заголовок P1 сообщения является адресными данными, используемыми агентами передачи сообщений (MTA) для маршрутизации почты. По умолчанию, когда включено ведение журнала только для сообщений, сервер Exchange Server не отвечает за получателей скрытых копий (СК) сообщений, получателей из транспортных правил пересылки или получателей из расширения группы рассылки. Кроме того, сервер Exchange не архивирует сообщения MAPI-отчетов, например уведомления о прочтении сообщений и уведомления об отсутствии на рабочем месте.

Сообщения по ведению журнала могут потреблять много ресурсов диска, сети и процессора. Следовательно, ведение журнала требует полного планирования развертывания. Ведение журнала следует включать только в контексте общей структуры решения по ведению журнала.

Не обращайте внимание на это сообщение о нестандартной конфигурации в следующих случаях:

  • Ваше предприятие требует ведения журнала.

  • Развернута структура решения по ведению журнала.

В противном случае функциональные возможности по ведению журнала следует отключить.

Чтобы отключить журнал сообщений базы данных в Exchange 2000 Server и Exchange Server 2003, выполните следующие действия.

  1. В приложении Exchange System Manager, разверните узел Серверы, разверните узел <сервер Exchange>, разверните <группу хранения> и затем щелкните правой кнопкой мыши хранилище почтовых ящиков.

  2. На вкладке Общие снимите флажок Архивировать все сообщения, отправленные из почтовых ящиков или принятые в почтовые ящики в данном хранилище.

  3. Чтобы изменения вступили в действие в хранилище Exchange, подождите 15 минут. Нет необходимости перезапускать службу банка данных Microsoft Exchange.
Чтобы отключить стандартное ведение журнала базы данных Exchange Server 2007, выполните следующие действия.

  1. Следуйте инструкциям, указанным в документации Exchange Server 2007 на странице How to Disable Per-Mailbox Database Journaling (http://go.microsoft.com/fwlink/?LinkId=80889).

Дополнительные сведения о развертывании решения по ведению журналов для Exchange Server 2003 см. в статье Journaling with Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47581) (Ведение журналов на сервере Exchange Server).

Дополнительные сведения о развертывании решения по ведению журналов для Exchange Server 2007 см. в статье Overview of Journaling (http://go.microsoft.com/fwlink/?LinkId=80820) (Обзор ведения журналов).


Возможно зацикливание маршрутизации сообщений
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchAlternateServer для каждого виртуально сервера SMTP. Анализатор Best Practice Analyzer сервера Exchange также проверяет, задан ли атрибут msExchNonAuthoritativeDomains для любой из политик получателя в организации. Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Был задан любой экземпляр атрибута msExchAlternateServer.

  • Был задан атрибут msExchNonAuthoritativeDomains для любой политики получателя.

Анализатор сервера Exchange выводит предупреждение, поскольку указанные конфигурации могут привести к зацикливанию маршрутизации сообщений. Зацикливание маршрутизации сообщений возможно в тех случаях, когда разные системы обмена сообщениями настроены для совместной работы в одной организации. В данном сценарии политики получателя Exchange Server и конфигурации SMTP используются для маршрутизации и доставки сообщений между группами пользователей в неоднородных системах обмена сообщениями.

Атрибут msExchAlternateServer задается при указании адреса в поле Пересылать всю почту с не определенными получателями узлу на странице свойств виртуального сервера SMTP.

Атрибут msExchNonAuthoritativeDomains задается при снятии флажка Эта организация Exchange осуществляет доставку всей почты на этот адрес на странице свойств адреса SMTP конкретной политики получателя.

Таким образом, если задать домен SMTP как неавторизованный, сняв флажок Эта организация Exchange осуществляет доставку всей почты на этот адрес, когда на любом виртуальном сервере SMTP задан адрес для не определенных получателей, то анализатор сервера Exchange выдает предупреждение. Однако необходимо заметить, что данное предупреждение не всегда означает наличие замкнутого цикла обработки сообщений в организации.

Если имеется неавторизованный доверия домен и хотя бы для одного сервера в организации задан атрибут msExchAlternateServer, то существует потенциальная опасность зацикливания маршрутизации сообщений. Убедитесь в том, что выполнены следующие условия:

  • Для всех доменов в организации существуют авторизованные домены.

  • Виртуальные серверы SMTP настроены таким образом, чтобы авторизованные домены обрабатывали все не определенные сообщения.

В частности, при совместном использовании доменного имени с другой организацией, рекомендуется использовать только один путь входящих сообщений к пространству имен домена. Чтобы избежать зацикливания, для домена должен быть задан один авторизованный почтовый сервер или почтовая система. Авторизованный сервер должен быть последней системой в пути входящих сообщений.

Неважно, какая система является исходным получателем. Также не имеет значения наличие более двух исходных получателей. Однако важно, чтобы в качестве пункта назначения была задана только одна система.

Чтобы изменить атрибут msExchAlternateServer

  1. В диспетчере Exchange разверните узел Серверы, затем <имя сервера>, затем Протоколы и SMTP.

  2. Щелкните правой кнопкой мыши виртуальный сервер SMTP и выберите команду Свойства.

  3. В окне свойств виртуального сервера SMTP откройте вкладку Сообщения.

  4. В поле Пересылать всю почту с не определенными получателями узлу введите полное имя домена для сервера, который будет получать не определенную почту. Также можно ввести IP-адрес сервера в квадратных скобках ([ ]).

  5. Нажмите кнопку ОК.
Чтобы изменить атрибут msExchNonAuthoritativeDomains

  1. В диспетчере Exchange разверните узел Получатели и дважды щелкните <имя политики получателя>.

  2. На вкладке Адреса электронной почты (политика) дважды щелкните адрес SMTP.

  3. На странице «Свойства адреса SMTP» установка флажка Эта организация Exchange осуществляет доставку всей почты на этот адрес отключает атрибут msExchNonAuthoritativeDomains. При снятии этого флажка задается атрибут msExchNonAuthoritativeDomains с адресом SMTP, указанным в поле Адрес.

Дополнительные сведения о совместном использовании пространств адресов SMTP см. в статье 321721 базы знаний Майкрософт, посвященной совместному использованию пространств адресов SMTP в Exchange 2000 Server и Exchange Server 2003 (может быть на английском языке) http://go.microsoft.com/fwlink/?LinkId=3052&kbid=321721).

Дополнительные сведения о сценариях развертывания для подключения к Интернету см. в соответствующем разделе руководства по транспорту и маршрутизации Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).


Очередь «Сообщения, ожидающие просмотра каталога» заблокирована
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс ExchangeLink, чтобы определить значение раздела StateFrozen для SMTP-очереди Сообщения, ожидающие просмотра каталога.

Если анализатор сервера Exchange обнаружит, что значение раздела StateFrozen для очереди Сообщения, ожидающие просмотра каталога на сервере Exchange установлено равным True, анализатор сервера Exchange выведет на экран сообщение об ошибке.

Заблокированная очередь означает, что транспортные сеансы для этой очереди остановлены. Заблокированная очередь препятствует отправке исходящих сообщений, хотя новые сообщения могут быть добавлены в очередь. Можно вручную изменить состояние подключения с помощью контекстного меню каждой очереди. При использовании команды Установить подключение для изменения состояния очереди на «Активная» немедленно разрешается подключение, которое используется для отправки сообщений в этой очереди.

Очередь Сообщения, ожидающие просмотра каталога содержит сообщения для получателей, адреса которых еще не определены для службы каталогов Active Directory®. Сообщения также хранятся в очереди, пока расширяются списки рассылки.

Обычно сообщения накапливаются в этой очереди из-за того, что расширенный механизм очередей не может классифицировать сообщение. Расширенный механизм очередей может не иметь доступа к серверам глобального каталога и доступа к сведениям о получателе, либо серверы глобального каталога недостижимы или работают медленно. Кроме того, сообщения могут накапливаться по следующим причинам:

  • Служба Active Directory недоступна.

    Примечание.
    Классификатор использует службу каталогов Active Directory для классификации сообщений.
  • Служба каталогов Active Directory может быть слишком перегружена, если в очереди перед классификацией находится много сообщений.

  • Существует ошибка в преобразовании. Классификатор также обрабатывает преобразование содержимого.

  • Классификатор сообщений не может найти хранилища почтовых ящиков.

  • Если протокол SMTP переустановлен или удален, это может сделать недействительными следующие ключи метабазы IIS: /smtpsvc/DsUseCat и /smtpsvc/vsi#/DsUseCat.

    Примечание.
    Определите, был ли переустановлен или удален протокол SMTP.

Чтобы устранить эту ошибку, увеличьте уровень ведения журнала диагностики для служб MSExchangeDSAccess и MSExchangeTransport, чтобы собрать сведения о компонентах классификатора.

Дополнительные сведения об устранении проблем, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел по устранению проблем потока почты и SMTP в руководстве по транспорту и маршрутизации сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).

  • База знаний Майкрософт, статья 823489, описывающая использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • База знаний Майкрософт, статья 821877, содержащая описание полей на вкладках свойств очередей SMTP и X.400 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • База знаний Майкрософт, статья 264054, описывающая общие сведения о состояниях очередей в Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Повторная попытка для очереди «Сообщения, ожидающие просмотра каталога»
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Windows® Management Instrumentation) ExchangeLink, чтобы определить значение ключа StateRetry для SMTP-очереди (Simple Mail Transfer Protocol) Сообщения, ожидающие просмотра каталога.

Если анализатор сервера Exchange обнаружит, что значение ключа StateRetry для очереди Сообщения, ожидающие просмотра каталога на сервере Exchange установлено равным True, анализатор сервера Exchange выведет на экран сообщение об ошибке.

Если очередь находится в состоянии повторения, это состояние указывает, что произошла хотя бы одна ошибка в предыдущих попытках обработки сообщений в этой очереди. С помощью команды Установить подключение очереди в состоянии «Retry» или «Scheduled» можно перевести в состоянии «Active». Это заставит очередь функционировать, как если бы интервал повторения закончился или было достигнуто запланированное время. Однако этот метод действует не всегда.

Примечание.
Свойства очереди могут указывать на конкретную причину, по которой очередь находится в состоянии «Retry».

Очередь Сообщения, ожидающие просмотра каталога содержит сообщения для получателей, адреса которых еще не определены для службы каталогов Active Directory®. Сообщения также хранятся в очереди, пока расширяются списки рассылки.

В общем случае сообщения накапливаются в этой очереди из-за того, что расширенный механизм очередей не может классифицировать сообщение. Расширенный механизм очередей может не иметь доступа к серверам глобального каталога и доступа к сведениям о получателе, либо серверы глобального каталога недостижимы или работают медленно. Кроме того, сообщения могут накапливаться по следующим причинам:

  • Служба Active Directory недоступна.

    Примечание.
    Классификатор использует службу Active Directory для классификации сообщений.
  • Служба Active Directory может быть слишком перегружена, если в очереди перед классификацией находится много сообщений.

  • Существует ошибка в преобразовании. Классификатор также обрабатывает преобразование содержимого.

  • Классификатор сообщений не может найти хранилища почтовых ящиков.

  • Если протокол SMTP переустановлен или удален, это может сделать недействительными следующие ключи метабазы IIS: /smtpsvc/DsUseCat и /smtpsvc/vsi#/DsUseCat.

    Примечание.
    Определите, был ли переустановлен или удален протокол SMTP.

Для разрешения этой ошибки проанализируйте свойства очереди, чтобы определить, почему очередь находится в состоянии повторения. Например, если в свойствах очереди отображается сообщение, такое как «Произошла ошибка SMTP», следует просмотреть на сервере журналы ошибок, чтобы найти все ошибки SMTP. Если в журнале нет событий, необходимо увеличить уровень регистрации в журнале событий протокола SMTP.

Дополнительные сведения об устранении проблем, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел по устранению проблем потока почты и SMTP в руководстве по транспорту и маршрутизации сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).

  • База знаний Майкрософт, статья 823489, описывающая использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • База знаний Майкрософт, статья 821877, содержащая описание полей на вкладках свойств очередей SMTP и X.400 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • База знаний Майкрософт, статья 264054, описывающая общие сведения о состояниях очередей в Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Очередь «Сообщения, ожидающие отправки» заморожена
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-16

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Windows® Management Instrumentation) ExchangeLink, чтобы определить значение ключа StateFrozen для SMTP-очереди Сообщения, ожидающие отправки.

Если анализатор сервера Exchange обнаруживает, что значение раздела StateFrozen для очереди Сообщения, ожидающие отправки на сервере Exchange установлено равным True, выводится сообщение об ошибке.

Заблокированная очередь означает, что транспортные сеансы для этой очереди остановлены. Заблокированная очередь препятствует отправке исходящих сообщений, хотя новые сообщения могут быть добавлены в очередь. Можно вручную изменить состояние подключения с помощью контекстного меню каждой очереди. При использовании команды Установить подключение для изменения состояния очереди на «Активная» будет незамедлительно установлено подключение, которое используется для отправки сообщений из этой очереди.

Очередь Сообщения, ожидающие отправки содержит сообщения, подтвержденные и принятые данной SMTP-службой.

Сообщения, находящиеся в этой очереди, не прошли обработку. Если сообщения постоянно накапливаются, производительность может снизиться. Нерегулярные всплеск роста производительности процессора могут к промежуточному включению сообщений в данную очередь. Часто к накоплению сообщений в этой очереди приводят неполадки приемников событий, например, например в пользовательских программах SMTP-обработки для защиты от вирусов и отказов от ответственности.

Дополнительные сведения об изменении параметров ведения журнала см. в подразделе «How to Modify Logging Settings for MSExchangeTransport» (Инструкции по изменению параметров ведения журнала для MSExchangeTransport) раздела «Устранение неполадок потока почты и SMTP» руководства Exchange Server Transport and Routing Guide (http://go.microsoft.com/fwlink/?LinkId=47579) (Руководство по транспорту и маршрутизации сервера Exchange).

Дополнительные сведения об устранении проблем, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел «Troubleshooting Mail Flow and SMTP» (Устранение проблем потока почты и SMTP) в руководстве Exchange Server Transport and Routing Guide (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579) (Руководство по транспорту и маршрутизации сервера Exchange).

  • Статья 823489 базы знаний Майкрософт «How to use Queue Viewer to troubleshoot mail flow issues in Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489) (Инструкции по использованию средства просмотра очереди для устранения неполадок потока почты в Exchange Server 2003).

  • Статья 821877 базы знаний Майкрософт «Description of Fields on the SMTP and X.400 Queue Properties Tabs» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877) (Описание полей на вкладках свойств очередей SMTP и X.400).

  • Статья 264054 база знаний Майкрософт «XCON: Understanding Queue States in Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054) (XCON: общие сведения о состояниях очередей в Exchange 2000 Server).


Очередь «Сообщения, ожидающие отправки» находится в состоянии «Повтор»
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Windows® Management Instrumentation) ExchangeLink, чтобы определить значение ключа StateRetry для SMTP-очереди Сообщения, ожидающие отправки.

Если анализатор сервера Exchange обнаруживает, что значение раздела StateRetry для очереди Сообщения, ожидающие отправки на сервере Exchange установлено равным True, выводится сообщение об ошибке.

Если очередь находится в состоянии повтора, это состояние указывает, что произошла хотя бы одна ошибка в предыдущих попытках обработки сообщений в этой очереди. Состояние очереди «Retry» или «Scheduled» можно изменить на состояние «Active» с помощью команды Принудительное подключение. В результате этого очередь будет функционировать как если бы интервал повтора уже прошел или назначенное время уже достигнуто. Однако этот метод может срабатывать не всегда.

Примечание.
В свойствах очереди может быть указана конкретная причина, по которой она находится в состоянии «Retry».

Очередь Сообщения, ожидающие отправки содержит сообщения, подтвержденные и принятые данной SMTP-службой.

Сообщения в этой очереди не прошли обработку. Если сообщения постоянно накапливаются, производительность может снизиться. Всплески производительности процессора могут приводить к нерегулярному включению сообщений в данную очередь. Часто к накоплению сообщений в этой очереди приводят неполадки приемников событий, например в пользовательских программах SMTP-обработки для защиты от вирусов и отказов от ответственности.

Дополнительные сведения об изменении параметров ведения журнала см. в разделе «How to Modify Logging Settings for MSExchangeTransport» (Инструкции по изменению параметров ведения журнала для MSExchangeTransport) части «Устранение неполадок потока почты и SMTP» документа Exchange Server Transport and Routing Guide (http://go.microsoft.com/fwlink/?LinkId=47579) (Руководство по транспорту и маршрутизации сервера Exchange).

Дополнительные сведения об устранении проблем, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел «Troubleshooting Mail Flow and SMTP» (Устранение проблем потока почты и SMTP) в документе Exchange Server Transport and Routing Guide (http://go.microsoft.com/fwlink/?LinkId=47579) (Руководство по транспорту и маршрутизации сервера Exchange).

  • Статья 823489 базы знаний Майкрософт «How to use Queue Viewer to troubleshoot mail flow issues in Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489) (Инструкции по использованию средства просмотра очереди для устранения неполадок потока почты в Exchange Server 2003).

  • Статья 821877 базы знаний Майкрософт «Description of Fields on the SMTP and X.400 Queue Properties Tabs» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877) (Описание полей на вкладках свойств очередей SMTP и X.400).

  • Статья 264054 база знаний Майкрософт «XCON: Understanding Queue States in Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054) (XCON: общие сведения о состояниях очередей в Exchange 2000 Server).


Очередь сообщений, ожидающих маршрутизации, остановлена
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Средство анализатора сервера Microsoft® Exchange запрашивает класс инструментария Windows® Management Instrumentation (WMI) ExchangeLink, чтобы определить значение ключа StateFrozen для SMTP-очереди Сообщения, ожидающие маршрутизации.

Если анализатор сервера Exchange обнаружит, что для ключа StateFrozen очереди Сообщения, ожидающие маршрутизации на сервере Exchange установлено значение True, на экран выводится сообщение об ошибке.

Остановка очереди означает, что транспортные сеансы для данной очереди остановлены. Остановка очереди запрещает отправку исходящих сообщений, хотя новые сообщения могут добавляться. Состояние подключения можно изменить вручную с помощью контекстного меню для каждой очереди связей. При изменении с помощью команды Установить подключение состояния очереди на «Активное» подключение сразу же включается и отправляет сообщения из данной очереди.

Очередь Сообщения, ожидающие маршрутизации хранит сообщения до тех пор, пока не будет определен следующий сервер-адресат, и затем перемещает их в соответствующие очереди связей.

Сообщения накапливаются в этой очереди, если на сервера Exchange возникают проблемы маршрутизации. Маршруты сообщений можно заархивировать.

Чтобы разрешить эту ошибку, повысьте уровень ведение журнала диагностики для службы MSExchangeDSAccess и службы MSExchangeTransport, чтобы собрать сведения о компонентах классификатора.

Дополнительные сведения об изменении настройки ведения журнала см. в разделе «How to Modify Logging Settings for MSExchangeTransport» (Изменение параметров ведения журнала для службы MSExchangeTransport) части «Troubleshooting Mail Flow and SMTP» (Устранение неполадок потока почты и SMTP) руководства Exchange Server Transport and Routing Guide (Руководство по транспорту и маршрутизации сервера Exchange) (http://go.microsoft.com/fwlink/?LinkId=47579).

Дополнительные сведения об устранении проблем, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел по устранению проблем потока почты и SMTP в руководстве по транспорту и маршрутизации сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).

  • База знаний Майкрософт, статья 823489, описывающая использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • База знаний Майкрософт, статья 821877, содержащая описание полей на вкладках свойств очередей SMTP и X.400 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • База знаний Майкрософт, статья 264054, описывающая общие сведения о состояниях очередей в Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Очередь «Сообщения, ожидающие переадресации» в состоянии «Retry»
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Средство анализатора сервера Microsoft® Exchange Server запрашивает ExchangeLink WMI-класс (Microsoft Windows® Management Instrumentation), чтобы определить значение ключа StateRetry для SMTP-очереди Сообщения, ожидающие переадресации.

Если анализатор сервера Exchange Server обнаружит, что значение ключа StateRetry очереди Сообщения, ожидающие просмотра каталогов на сервере Exchange установлено в True, анализатор сервера Exchange Server отобразит ошибку.

Если очередь находится в состоянии «Retry», это состояние свидетельствует о том, что по крайней мере одна ошибка произошла при предыдущих попытках обработать сообщения в очереди. Очереди с состоянием «Retry» или «Scheduled» можно изменить на состояние «Active» с помощью команды Принудительное подключение. В результате этого очередь будет функционировать как если бы интервал повтора уже прошел или назначенное время уже достигнуто. Однако этот метод может срабатывать не всегда.

Примечание.
В свойствах очереди может быть указана конкретная причина, по которой она находится в состоянии «Retry».

Очередь Сообщения, ожидающие переадресации содержит сообщения до тех пор, пока не будет определен их следующий конечный сервер, после чего они перемещаются в соответствующие очереди ссылок.

Сообщения накапливаются в этой очереди, если существуют какие-либо неполадки маршрутизации сервера Exchange Server. Маршрутизация сообщения может архивироваться.

Чтобы устранить эту ошибку, увеличьте объем записи данных диагностики для службы MSExchangeTransport, чтобы собрать сведения о компонентах классификатора. Отключите все ненужные ограничения на соединители, поскольку эти ограничения могут привести к значительному снижению производительности сервера. Для некоторых ограничений может потребоваться включить раздел реестра CheckConnectorRestrictions.

Дополнительные сведения об изменении параметров ведение журнала см. в инструкциях по изменению параметров ведение журнала для MSExchangeTransport в разделе по устранению проблем потока почты и SMTP руководства по транспорту и маршрутизации сервера Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Дополнительные сведения об устранении проблем, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел по устранению проблем потока почты и SMTP руководства по транспорту и маршрутизации сервера Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • База знаний Майкрософт, статья 823489, описывающая использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • База знаний Майкрософт, статья 821877, содержащая описание полей на вкладках свойств очередей SMTP и X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • База знаний Майкрософт, статья 264054, описывающая общие сведения о состояниях очередей в Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Отсутствует привязка приемника события передачи
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-01-11

Средство анализатора сервера Microsoft® Exchange запрашивает метабазу Microsoft IIS, чтобы пронумеровать список привязок приемников событий передачи SMTP. Анализатор сервера Exchange пытается обнаружить несколько стандартных привязок событий в зависимости от следующего списка, ранее заполненного в анализаторе сервера Exchange:

  • Настраиваемый приемник DSN Exchange

  • Приемник обработчика входящих команд EHLO для XLSA

  • Приемник обработчика ответов EHLO для X-LSA

  • Приемник обработчика входящих команд EOD

  • Классификатор Exchange

  • Балансировщик нагрузки Exchange

  • Драйвер NTFS-хранилища Exchange

  • Маршрутизатор Exchange

  • Приемник журнала протокола SMTP Exchange

  • Приемник EHLO безопасности протокола SMTP Exchange

  • Приемник EXPS безопасности протокола SMTP Exchange

  • Приемник EXPS-Aux безопасности протокола SMTP Exchange

  • Приемник EXPS-EOD безопасности протокола SMTP Exchange

  • Приемник почты безопасности протокола SMTP Exchange

  • Приемник предварительных данных расширения XEXCH50 протокола SMTP Exchange

  • Приемник ответов EHLO расширения XEXCH50 протокола SMTP Exchange

  • Приемник EOD расширения XEXCH50 протокола SMTP Exchange

  • Приемник входящих EHLO расширения XEXCH50 протокола SMTP Exchange

  • Приемник входящих MAIL расширения XEXCH50 протокола SMTP Exchange

  • Приемник входящих RCPT расширения XEXCH50 протокола SMTP Exchange

  • Приемник входящих XEXCH50 расширения XEXCH50 протокола SMTP Exchange

  • Приемник событий получателей расширения XEXCH50 протокола SMTP Exchange

  • Приемник ответов RCPT расширения XEXCH50 протокола SMTP Exchange

  • Приемник ответов расширения XEXCH50 протокола SMTP Exchange

  • Драйвер хранилища Exchange

  • Антивирусный API передачи Exchange

  • Приемник отправки расширения XEXCH50 передачи Exchange

  • Приемник обработчика входящих команд MAIL для TURF

  • Классификатор мобильных устройств

  • Приемник EOD фильтра содержания MSExchange

  • Приемник MsgTrackLog

  • Приемник обработчика входящих команд RCPT

  • Приемник журнала событий SMTP

  • UmConvSink

  • Приемник обработчика входящих команд X-LSA

  • Приемник обработчика ответов X-LSA

  • Приемник X-LSA

Если анализатор сервера Exchange обнаруживает отсутствие одной или нескольких стандартных привязок событий, анализатор сервера Exchange генерирует предупреждение.

Событие передачи SMTP возникает, когда данные сообщения передаются в службу SMTP или из нее. Все сообщения проходят через события, в том числе входящие и исходящие сообщения X.400 и RPC. Типичным примером входящего события передачи является получение сообщения службой SMTP по сети или в каталог раскладки SMTP. В случае события передачи источник этого события уведомляет приемники событий передачи, каждый из которых может предпринять действие некоторого типа в зависимости содержания сообщения. Передав данные сообщения приемнику, система не выполняет с данными сообщения никаких других действий, пока приемник не завершит свои действия и не возвратит сообщение. Выполняя свои действия, приемник получает исключительные права управления данными и состоянием сообщения.

Отсутствующие привязки приемников событий передачи может вызвать проблемы управления почтой. Если сервер Exchange проявляет симптомы проблем потока почты, например очереди сообщений, выполните регистрацию приемников событий передачи заново.

Повторная регистрация приемников событий передачи

  1. Из сервера Microsoft Exchange откройте окно командной строки и перейдите в папку \Program Files\Exchsrvr\Bin.

  2. Введите следующие команды, чтобы повторно выполнить регистрацию приемников событий передачи:

    regsvr32 /i exps.dll

    regsvr32 /i miscat.dll

    regsvr32 /i onsubmit.dll

    regsvr32 /i peexch50.dll

    regsvr32 /i phatcat.dll

    regsvr32 /i protolog.dll

    regsvr32 /i reapi.dll

    regsvr32 /i regsinks.dll

    regsvr32 /i tranmsg.dll

    regsvr32 /i turflist.dll

    regsvr32 /i xlsasink.dll

    regsvr32 /i msgfilter.dll

  3. Запустите повторно анализатор сервера Exchange, чтобы убедиться в отсутствии предупреждений. Если предупреждения приемников событий продолжат появляться и в случае возникновения проблем потока почты, обратитесь в службу поддержки продуктов Майкрософт.

Дополнительные сведения о привязках приемников событий передачи см. в следующих ресурсах Exchange:

  • Статья 258224 базы знаний Майкрософт, описывающая XCON и перечисление зарегистрированных приемников событий передачи, по адресу http://go.microsoft.com/fwlink/?linkID=3052&kbid=258224 (возможно, на английском языке)

  • «Структура службы SMTP» в техническом справочном руководстве для Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=58876 (возможно, на английском языке)


Атрибут msExchAlternateServer установлен
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchAlternateServer для каждого виртуального сервера SMTP (Simple Mail Transfer Protocol). По умолчанию значение атрибута msExchAlternateServer не устанавливается. Если анализатор сервера Exchange обнаруживает, что атрибут msExchAlternateServer установлен, выводится сообщение о том, что текущая конфигурация отличается от используемой по умолчанию.

Атрибут msExchAlternateServer может устанавливаться в следующей ситуации. Предположим, что адресное пространство SMTP (например домен SMTP) используется совместно сервером Exchange Server 2003 и другой системой электронной почты. В рассматриваемом примере Exchange Server 2003 принимает входящую почту из Интернета. Exchange Server 2003 ищет нужного получателя в организации сервера Exchange. Если никаких соответствий не найдено, сервер Exchange направляет почту во внешнюю почтовую систему. В принимающей системе также может быть выполнен поиск получателя. Если соответствие не найдено, почта может быть передана в третью почтовую систему. Конечная система в этой цепочке должна быть авторизована для домена. В этой конечной системе также должен быть выполнен поиск соответствующего получателя. Если получатель не найден, генерируется отчет о недоставке сообщения. Если принимающая система после поиска соответствия, заканчивающегося неудачей, возвращает сообщение в исходную систему, образуется цикл обработки сообщения.

Чтобы изменить атрибут msExchAlternateServer

  1. В системном диспетчере Exchange последовательно разверните узлы Серверы, <имя_сервера>, Протоколы и SMTP.

  2. Щелкните правой кнопкой мыши виртуальный сервер SMTP и выберите команду Свойства.

  3. В окне Свойства виртуального сервера SMTP откройте вкладку Сообщения.

  4. В поле Пересылать все сообщения с неразрешенными получателями в узел введите полное доменное имя сервера, который будет получать почту с неразрешенными адресами. Можно также ввести IP-адрес сервера в квадратных скобках ([ ]).

  5. Нажмите кнопку ОК.

Дополнительные сведения о совместном использовании адресных пространств SMTP см. в статье 321721 базы знаний Майкрософт, посвященной совместному использованию адресных пространств SMTP в Exchange 2000 Server и Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=321721).

Дополнительные сведения о сценариях развертывания подключений к Интернету см. в соответствующем разделе документа Exchange Server 2003 Transport and Routing Guide (Руководство по транспорту и маршрутизации в Exchange Server 2003, http://go.microsoft.com/fwlink/?LinkId=47579).


Значение msExchMaxIncomingConnections было изменено относительно своего значения по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить настроенное значение атрибута msExchSmtpMaxIncomingConnections для каждого виртуального сервера SMTP, анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®.

По умолчанию на компьютере Exchange Server, который не является частью установки Microsoft Windows® Small Business Server 2003, атрибут msExchSmtpMaxIncomingConnections настроен на неограниченное число подключений, которое по умолчанию представлено значением этого атрибута 2 000 000 000. На компьютере Exchange Server, который является частью установки Microsoft Windows Small Business Server 2003, по умолчанию применяется максимальное число входящих подключений 500.

Анализатор сервера Exchange также запрашивает класс инструментария управления Windows (WMI) Win32_OperatingSystem, чтобы определить значение ключа OSProductSuite. Значение этого ключа соответствует определенной версии операционной системы сервера Windows.

Если анализатор сервера Exchange обнаруживает, что атрибут msExchSmtpMaxIncomingConnections на компьютере сервера Exchange, который не входит в состав установки Microsoft Windows Small Business Server 2003, не имеет значения 2 000 000 000, выводится сообщение о наличии конфигурации, не являющейся заданной по умолчанию. Значение 2 000 000 000, используемое для этого атрибута, является как теоретическим пределом, так и ограничением, накладываемым на элементы интерфейса пользователя, которые позволяют настраивать это значение.

С другой стороны, если анализатор сервера Exchange обнаруживает, что атрибут msExchSmtpMaxIncomingConnections на компьютере сервера Exchange, который входит в состав установки Microsoft Windows Small Business Server 2003, не имеет значения 500, выводится сообщение о наличии конфигурации, не являющейся заданной по умолчанию.

Ограничение числа входящих подключений может иметь смысл с точки зрения безопасности. Возможность принимать неограниченное число входящих SMTP-подключений может привести к ситуации отказа в обслуживании. Слишком большое количество одновременных подключений к виртуальному серверу может вызвать перегрузку сети и снижение производительности системы. Для каждой организации оптимальное значение для этого атрибута следует подбирать индивидуально.

Чтобы просмотреть или настроить максимальное число входящих подключений

  1. Откройте системный диспетчер Exchange.

  2. Разверните узел Серверы, разверните «Сервер Exchange», разверните узел Протоколы и затем разверните «SMTP».

  3. Щелкните правой кнопкой мыши виртуальный сервер SMTP (например, «Виртуальный сервер SMTP по умолчанию») и нажмите кнопку Свойства.

  4. Откройте вкладку Общие:

    • Чтобы ограничить число входящих подключений, установите флажок Ограничить число подключений до и введите нужное значение.

    • Чтобы восстановить применяемое по умолчанию неограниченное число входящих подключений, снимите флажок Ограничить число подключений до.

  5. Нажмите кнопку ОК, чтобы сохранить изменения.

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • 266686, "XCON: инструкции из части 1 по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: инструкции из части 2 по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


Изменено значение msExchSmtpMaxHopCount, заданное по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, было ли изменено заданное по умолчанию значение атрибута msExchSmtpMaxHopCount.

В Exchange 2000 Server для атрибута msExchSmtpMaxHopCount по умолчанию задано значение 15. В Exchange Server 2003 для этого атрибута по умолчанию задано значение 30. Если анализатор сервера Exchange обнаруживает, что заданное по умолчанию значение атрибута было изменено, на экран выводится сообщение о конфигурации, отличной от конфигурации по умолчанию.

Сообщение может быть передано через множество SMTP-серверов (каждый такой сервер называется прыжком) прежде, чем достигнет пункта своего назначения. Чтобы предотвратить многократную неправильную маршрутизацию сообщения (явление, называемое замкнутым циклом обработки сообщения), администратор может настроить максимальное допустимое число прыжков. Атрибут mxExchSmtpMaxHopCount определяет число SMTP-серверов, через которое может пройти сообщение прежде, чем оно будет возвращено к отправителю с пометкой о невозможности доставки.

Рекомендуется использовать значение 30 для виртуальных SMTP-серверов Exchange 2000 Server и Exchange Server 2003.

Чтобы устранить эту ошибку

  1. В системном диспетчере Exchange разверните узел Серверы, затем узел сервера Exchange, узел Протоколы и узел SMTP.

  2. Щелкните правой кнопкой мыши виртуальный SMTP-сервер (например, виртуальный SMTP-сервер по умолчанию) и выберите Свойства.

  3. Откройте вкладку Доставка и нажмите кнопку Дополнительно.

  4. Введите значение в поле Максимальное количество прыжков и нажмите кнопку ОК, чтобы сохранить изменения.

  5. Нажмите кнопку ОК, чтобы закрыть диалоговое окно Свойства виртуального SMTP-сервера.

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • 266686, описывающая инструкции по настройке виртуального SMTP-сервера (часть 1) (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, описывающая инструкции по настройке виртуального SMTP-сервера (часть 2) (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


Значение msExchSmtpMaxMessageSize изменено и отличается от значения по умолчанию, равного 0
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, изменено ли значение атрибута msExchSmtpMaxMessageSize относительно значения по умолчанию, равного 0. По умолчанию атрибут msExchSmtpMaxMessageSize настроен для неограниченного размера сообщений. Если анализатор сервера Exchange обнаружит, что значение этого атрибута отличается от 0, и что приложение Exchange не выполняется в среде Microsoft Windows® Small Business Server 2003, на экран будет выведено предупреждение.

Значение атрибута msExchSmtpMaxMessageSize представляет собой максимальный размер отправляемых и получаемых SMTP-сообщений. С точки зрения безопасности рекомендуется ограничить максимальный размер SMTP-сообщений, которые могут отправляться или приниматься через Интернет. Однако для внутренних SMTP-сообщений, например, тех, что передаются между серверами Exchange в одной и той же организации, рекомендуется оставить значение атрибута msExchSmtpMaxMessageSize равным 0.

Внутри приложения Exchange SMTP-сообщения используются для обработки задач, таких как репликация общих папок. Если атрибут msExchSmtpMaxMessageSize настроен с очень малым пределом, это может привести к проблемам репликации общих папок и к другим отказам доставки сообщений внутри организации.

Если сервер Exchange является сервером-плацдармом, передающим и принимающим SMTP-сообщения через Интернет, можно без каких-либо последствий проигнорировать это сообщение. Если этот сервер Exchange обрабатывает внутренние SMTP-сообщения, следует обратно установить для атрибута msExchSmtpMaxMessageSize значение по умолчанию, равное 0.

Примечание.
Если установить предельный размер сообщений слишком малым, это может сделать невозможным репликацию автономной адресной книги между компьютерами сервера Exchange. Дополнительные сведения по данному вопросу см. в базе знаний Майкрософт в статье 326154, описывающей невозможность репликации автономной адресной книги, когда на транспортном уровне установлено ограничение по размеру сообщений (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326154).

Чтобы просмотреть и настроить максимальный размер SMTP-сообщений

  1. В системном диспетчере Exchange последовательно разверните узел Серверы, узел сервера Exchange, узел Протоколы, а затем разверните узел протокола SMTP.

  2. Щелкните правой кнопкой мыши виртуальный SMTP-сервер (например, виртуальный SMTP-сервер по умолчанию) и в контекстном меню выберите Свойства.

  3. Откройте вкладку Сообщения.

  4. Чтобы вернуться к настройке по умолчанию, равной 0, снимите флажок Ограничить размер сообщений до… (КБ). Или оставьте этот флажок установленным, и задайте любое требуемое значение.

  5. Нажмите кнопку OK, чтобы сохранить изменения и закрыть диалоговое окно Свойства виртуального SMTP-сервера.

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • Статья 266686, описывающая инструкции из части 1 по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • Статья 268163, описывающая инструкции из части 2 по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


Значение msExchSmtpMaxOutboundMsgPerDomain отличается от значения по умолчанию 20
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-07-07

Средство анализа Microsoft® Exchange Server запрашивает службу каталогов Active Directory®, чтобы определить, совпадает ли настроенное значение атрибута msExchSmtpMaxOutboundMsgPerDomain со значением по умолчанию 20. По умолчанию для атрибута msExchSmtpMaxOutboundMsgPerDomain установлено максимальное количество в 20 исходящих сообщений SMTP на каждое подключение. Если анализатор обнаруживает, что значение атрибута не равно 20, он выдает сообщение о том, что настройка отличается от настройки по умолчанию.

Атрибут msExchSmtpMaxOutboundMsgPerDomain представляет максимальное число сообщений для каждого подключения, которые могут быть отправлены виртуальным сервером SMTP на сервере Exchange. Например, если серверу SMTP необходимо отправить 35 сообщений на microsoft.com, а для атрибута msExchSmtpMaxOutboundMsgPerDomain установлено значение 20, будут созданы два подключения к почтовым серверам, отвечающим за сообщения для microsoft.com. Через первое подключение будет отправлено максимальное допустимое число сообщений — 20 — и будет создано второе подключение для отправки оставшихся 15 сообщений.

Обычно не дается никаких рекомендаций относительно верного значения данного атрибута. Каждая организация должна сама для себя определить подходящее значение.

Установка максимального числа сообщений для каждого подключения

  1. Запустите диспетчер Exchange.

  2. Раскройте Серверы, раскройте сервер Exchange, раскройте Протоколы, а затем раскройте SMTP.

  3. Щелкните правой кнопкой мыши виртуальный сервер SMTP (например, Виртуальный сервер SMTP по умолчанию) и выберите Свойства.

  4. Выберите Сообщения.

  5. Текущее значение атрибута msExchSmtpMaxOutboundMsgPerDomain указано в поле Ограничить количество подключений до. Измените число в этом поле, если необходимо, и нажмите кнопку OK, чтобы сохранить изменения. Допустимым значением для данного поля является целое число от 1 до 1999999999..

  6. Нажмите кнопку OK, чтобы закрыть диалоговое окно Свойства виртуального сервера SMTP.

Для получения дополнительных сведений о настройках виртуального сервера SMTP см. следующие статьи базы знаний Майкрософт:

  • 266686, «XCON: инструкции из части 1 по настройке виртуального SMTP-сервера» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686 (эта ссылка может указывать на содержимое полностью или частично на английском языке);

  • 268163, «XCON: инструкции из части 2 по настройке виртуального SMTP-сервера» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163 (эта ссылка может указывать на содержимое полностью или частично на английском языке).


Значение msExchSmtpMaxOutgoingConnections не равно своему значению по умолчанию 1000
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange Server выполняет запрос в службе каталогов Active Directory®, чтобы определить, было ли изменено настроенное значение атрибута msExchSmtpMaxOutgoingConnections относительно своего значения по умолчанию 1000. По умолчанию атрибут msExchSmtpMaxOutgoingConnections разрешает максимум 1000 исходящих SMTP-подключений. Если анализатор сервера Exchange обнаружит, что значение атрибута не равно 1000, отображается сообщение о нестандартной конфигурации.

Атрибут msExchSmtpMaxOutgoingConnections представляет максимальное число исходящих подключений, которое может быть установлено виртуальным SMTP-сервером на сервере Microsoft Exchange.

Надежных практических рекомендаций по определению правильного значения для этого атрибута не существует. В каждой организации следует определить свое оптимальное значение. Для некоторых организаций значение по умолчанию может оказаться слишком высоким. Определить фактическое число исходящие SMTP-подключений, установленных виртуальным SMTP-сервером Exchange, можно, собирая данные следующих счетчиков производительности на сервере Exchange:

Объект | Счетчик | Описание
SMTP-сервер | Текущих исходящих подключений | Число установленных в данный момент исходящих подключений.
SMTP-сервер | Всего исходящих подключений | Общее количество предпринятых попыток исходящих подключений.

Если на сервере Exchange в организации исходящие SMTP-подключения широко не используются, можно уменьшить значение этого атрибута. Снижение максимального числа одновременных исходящих SMTP-подключений, которое может быть установлено в любой данный момент времени, потенциально может уменьшить влияние пиковых ситуаций в работе SMTP-сервера, причиной которых могут стать неправильная настройка, неумышленная ошибка, злонамеренная деятельность, зацикливание сообщений и другие сбои, а также вирусная активность или нарушение безопасности.

Чтобы просмотреть и настроить предел исходящий подключений

  1. Откройте диспетчер Exchange.

  2. Разверните узел Серверы, разверните «Сервер Exchange», разверните узел Протоколы и затем разверните SMTP.

  3. Правой кнопкой мыши щелкните виртуальный SMTP-сервер (например, виртуальный SMTP-сервер по умолчанию) и в контекстном меню выберите Свойства.

  4. Щелкните Доставка и затем выберите Исходящие подключения.

  5. Текущее значение атрибута msExchSmtpMaxOutgoingConnections указано в поле Ограничить число подключений до. Введите в это поле нужное значение и нажмите кнопку ОК, чтобы сохранить изменения. Допустимым значением этого поля может быть любое целое число от 1 до 1 999 999 999.

  6. Чтобы закрыть диалоговое окно Свойства виртуального SMTP-сервера, нажмите кнопку ОК.

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • 266686, "XCON: инструкции из части 1 по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686);

  • 268163, "XCON: инструкции из части 2 по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).


Значение msExchSmtpMaxOutgoingConnectionsPerDomain было изменено относительно своего значения по умолчанию — 100
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange Server выполняет запрос в службе каталогов Active Directory®, чтобы определить, было ли изменено настроенное значение атрибута msExchSmtpMaxOutgoingConnectionsPerDomain относительно своего значения по умолчанию. Атрибут msExchSmtpMaxOutgoingConnectionsPerDomain представляет максимальное число исходящих подключений на домен, которое может быть установлено виртуальным SMTP-сервером на сервере Microsoft Exchange. По умолчанию на компьютере сервера Exchange, который не входит в состав установки Microsoft Windows® Small Business Server 2003, для атрибута msExchSmtpMaxOutgoingConnectionsPerDomain задается значение по умолчанию 100. На компьютере сервера Exchange, который является частью установки Windows Small Business Server 2003, по умолчанию применяется максимальное число исходящих подключений на домен 10.

Анализатор сервера Exchange также запрашивает класс инструментария Microsoft Windows® Management Instrumentation (WMI) Win32_OperatingSystem, чтобы определить значение ключа OSProductSuite. Значение этого ключа соответствует определенной версии операционной системы сервера Windows.

Если анализатор сервера Exchange находит, что значение атрибута msExchSmtpMaxOutgoingConnectionsPerDomain на компьютере сервера Exchange, который не входит в установку Windows Small Business Server 2003, не равно 500, выводится сообщение о наличии конфигурации, не являющейся заданной по умолчанию.

Точно так же, если анализатор сервера Exchange обнаруживает, что значение атрибута msExchSmtpMaxOutgoingConnectionsPerDomain на компьютере сервера Exchange, который входит в состав установки Microsoft Windows Small Business Server 2003, не равно 10, выводится сообщение о наличии конфигурации, не являющейся заданной по умолчанию.

Надежных практических рекомендаций по определению правильного значения для этого атрибута не существует. В каждой организации следует определить свое оптимальное значение. Для некоторых организаций значение по умолчанию может оказаться слишком высоким. Определить фактическое число исходящие SMTP-подключений, установленных виртуальным SMTP-сервером Exchange, можно, собирая данные следующих счетчиков производительности на сервере Exchange:

Объект | Счетчик | Описание
SMTP-сервер | Текущих исходящих подключений | Число установленных в данный момент исходящих подключений.
SMTP-сервер | Всего исходящих подключений | Общее количество предпринятых попыток исходящих подключений.

Если на сервере Exchange в организации исходящие SMTP-подключения широко не используются, можно уменьшить значение этого атрибута. Снижение максимального числа одновременных исходящих SMTP-подключений, которое может быть установлено в любой данный момент времени, потенциально может уменьшить влияние пиковых ситуаций в работе SMTP-сервера, причиной которых могут стать неправильная настройка, неумышленная ошибка, злонамеренная деятельность, зацикливание сообщений и другие сбои, а также вирусная активность или нарушение безопасности.

Чтобы просмотреть и настроить предел исходящий подключений на домен

  1. Откройте системный диспетчер Exchange.

  2. Разверните узел Серверы, разверните «Сервер Exchange», разверните узел Протоколы и затем разверните SMTP.

  3. Щелкните правой кнопкой мыши виртуальный сервер SMTP (например, «Виртуальный сервер SMTP по умолчанию») и нажмите кнопку Свойства.

  4. Щелкните Доставка и затем выберите Исходящие подключения.

  5. Текущее значение атрибута msExchSmtpMaxOutgoingConnectionsPerDomain указано в поле Ограничить число подключений на домен до. Введите в это поле нужное значение и нажмите кнопку ОК, чтобы сохранить изменения. Допустимым значением этого поля может быть любое целое число от 1 до 1999999999.

  6. Чтобы закрыть диалоговое окно Свойства виртуального SMTP-сервера, нажмите кнопку ОК.

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • 266686, "XCON: инструкции из части 1 по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: инструкции из части 2 по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


Значение msExchSmtpMaxRecipients отличается от значения по умолчанию 64000
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server запрашивает службу каталогов Active Directory®, чтобы определить, совпадает ли настроенное значение атрибута msExchSmtpMaxRecipients со значением по умолчанию 64000. По умолчанию для атрибута msExchSmtpMaxRecipients установлено значение 64000 получателей. Если средство анализа Exchange Server обнаружит, что значение атрибута не равно 64000, он выдаст сообщение о том, что настройка отличается от настройки по умолчанию.

С точки зрения безопасности, ограничение максимального числа получателей для каждого сообщения весьма полезно. Каждая организация должна сама для себя определить допустимое значение. Если нет причин менять это число, рекомендуется оставить для атрибута msExchSmtpMaxRecipients значение 64000, установленное по умолчанию.

Просмотр и настройка максимального числа получателей

  1. В системном диспетчере Exchange раскройтеСерверы, раскройте Сервер Exchange, раскройте Протоколы, а затем раскройте SMTP.

  2. Щелкните правой кнопкой мыши виртуальный сервер SMTP (например Виртуальный сервер SMTP по умолчанию) и выберите Свойства.

  3. Выберите вкладку Сообщения.

  4. Чтобы восстановить значение по умолчанию 64000, убедитесь, что установлен флажок Ограничение числа получателей сообщения, и введите значение 64000. Или же в этом поле можно ввести любое нужное значение или снять флажок, чтобы разрешить неограниченное число получателей.

  5. Нажмите кнопку OK, чтобы сохранить изменения и закрыть диалоговое окно Свойства виртуального сервера SMTP.

Для получения дополнительных сведений о параметрах виртуального сервера SMTP см. следующие статьи базы знаний Майкрософт:

  • 266686, «XCON: Настройка виртуального сервера SMTP (часть 1)» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, «XCON: Настройка виртуального сервера SMTP (часть 2)» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


Значение msExchSmtpMaxSessionSize изменилось по отношению к значению по умолчанию, равному 0
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, изменилось ли настроенное значение атрибута msExchSmtpMaxSessionSize по отношению к значению по умолчанию, равному 0. По умолчанию атрибут msExchSmtpMaxSessionSize настроен на неограниченный размер сообщения. Если анализатор сервера Exchange обнаружит, что значение атрибута не равно 0, на экран выводится предупреждение.

Атрибут msExchSmtpMaxSessionSize отражает максимальный объем данных в килобайтах (КБ), который должен приниматься во время каждого SMTP-сеанса. С точки зрения безопасности ограничение объема SMTP-сеансов для сообщений, отправляемых в Интернет и принимаемых из Интернета, является лучшим практическим решением. Однако для внутренних SMTP-сеансов, например между серверами Exchange в одной организации рекомендуется оставлять для атрибута msExchSmtpMaxSessionSize значение, равное 0.

Внутри приложения Exchange SMTP-сообщения используются для работы с такими задачами, как например репликация общих папок. Если атрибут msExchSmtpMaxSessionSize настроен с слишком низким предельным значением, это может привести к проблемам с репликацией общих папок и другим неполадкам при доставке сообщений внутри организации.

Если сервер Exchange является сервером-плацдармом, передающим SMTP-сообщения в Интернет и из Интернета, можно без всяких последствий игнорировать это предупреждение. Если сервер Exchange обрабатывает внутренние SMTP-сообщения, необходимо изменить значение атрибута msExchSmtpMaxSessionSize обратно на значение параметра по умолчанию, равное 0.

Чтобы просмотреть и настроить наибольший размер SMTP-сеанса

  1. Откройте диспетчер Exchange

  2. Разверните узел Серверы, затем разверните сервер Exchange, разверните узел Протоколы и затем разверните узел SMTP.

  3. Щелкните правой кнопкой мыши виртуальный SMTP-сервер (например виртуальный SMTP-сервер по умолчанию) и затем щелкните Свойства.

  4. Щелкните Сообщения.

  5. Для возврата к значению параметра по умолчанию, равному 0, снимите флажок Предельный размер сеанса в килобайтах. В противном случае оставьте данный флажок установленным и задайте любое желаемое значение.

  6. Нажмите кнопку ОК, чтобы сохранить изменения и закрыть диалоговое окно Свойства виртуального SMTP-сервера.

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • 266686, "XCON: How to Configure a SMTP Virtual Server Part 1" (XCON: инструкции по настройке виртуального SMTP-сервера, часть 1) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: How to Configure a SMTP Virtual Server Part 2" (XCON: инструкции по настройке виртуального SMTP-сервера, часть 2) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


Значение msExchSmtpOutgoingPort не равно своему значению по умолчанию 25
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange Server выполняет запрос в службе каталогов Active Directory®, чтобы определить, было ли изменено настроенное значение атрибута msExchSmtpOutgoingPort относительно своего значения по умолчанию 25. По умолчанию в качестве значения атрибута msExchSmtpOutgoingPort указан TCP-порт 25. Если анализатор сервера Exchange обнаруживает, что в этом атрибуте указан другой порт, выводится предупреждение.

По умолчанию SMTP-серверы принимают входящие подключения через TCP-порт 25. Параметр msExchSmtpOutgoingPort представляет TCP-порт, через который данный сервер Exchange будет пытаться подключаться ко всем удаленным SMTP-серверам. Если в настройке удаленных SMTP-серверов не предусмотрено прослушивание этого порта, подключение будет невозможно.

Если некоторая часть или вся внутренняя инфраструктура управления сообщениями не была настроена для использования нестандартных портов, рекомендуется для всех SMTP-связей использовать TCP-порт 25.

Чтобы просмотреть или изменить применяемый по умолчанию исходящий SMTP-порт

  1. В системном диспетчере Exchange разверните узел Серверы, затем сервер Exchange, затем Протоколы и SMTP.

  2. Щелкните правой кнопкой мыши виртуальный SMTP-сервер (например, виртуальный SMTP-сервер по умолчанию) и в контекстном меню выберите Свойства.

  3. Щелкните Доставка и затем выберите Исходящие подключения.

  4. В поле «TCP-порт» введите порт, который должен использоваться для исходящих подключений. На каждом удаленном SMTP-сервере, с которым будет устанавливаться связь, должен быть настроен прием подключений через этот заданный порт. В большинстве случаев изменять это значение не требуется.

  5. Введите в это поле нужное значение и нажмите кнопку ОК, чтобы сохранить изменения.

  6. Чтобы закрыть диалоговое окно Свойства виртуального SMTP-сервера, нажмите кнопку ОК.

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • 266686, "XCON: инструкции из части 1 по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: инструкции из части 2 по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


Для параметра msExchSmtpRelayForAuth изменено значение по умолчанию «True»
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, было ли изменено заданное по умолчанию значение атрибута msExchSmtpRelayForAuth. По умолчанию для атрибута msExchSmtpRelayForAuth установлено значение True. Если анализатор сервера Exchange обнаруживает, что для атрибута msExchSmtpRelayForAuth установлено не значение True, выводится сообщение о том, что текущая конфигурация отличается от заданной по умолчанию.

Если для этого атрибута задано значение «True», только подключения SMTP, прошедшие проверку подлинности, могут ретранслировать сообщения SMTP через данный виртуальный сервер SMTP. Если значение параметра изменено на «False», это указывает, что снят флажок «Разрешить всем компьютерам, которые успешно прошли проверку подлинности, выполнять ретрансляцию независимо от верхнего списка» в разделе «Параметры ретрансляции» в диалоговом окне Свойства виртуального сервера SMTP.

Ретранслирование является действием входящего подключения к серверу SMTP, используемому для отправки сообщений электронной почты во внешние домены. Отправка одного сообщения электронной почты на сервер SMTP с несколькими получателями, находящимися в доменах, которые являются внешними по отношению к организации, считается рассылкой нежелательной коммерческой почты. Так как по умолчанию на серверах SMTP используется анонимная проверка подлинности, система, в которой ведется распространение сообщений нежелательной коммерческой электронной почты, принимает это входящее сообщение как типичное.

После того, как сообщение принято, сервер SMTP определяет, что получатели сообщения относятся к внешним доменам, а затем данный сервер SMTP выполняет доставку сообщений. Таким образом, неавторизованные пользователи, которые отправляют сообщения нежелательной коммерческой электронной почты, могут направить только одно входящее сообщение на сервер SMTP, чтобы разослать его тысячам получателей, что замедляет время отклика сервера Exchange, увеличивает очереди, а также ведет к недовольству получателей сообщения при его доставке.

Основные средства управления ретранслированием — отказ в предоставлении разрешений на ретранслирование на любые другие серверы. Однако в ряде случаев ретранслирование является обязательным. Например, при наличии клиентских компьютеров POP3 и IMAP4, которые используют для доставки сообщений протокол SMTP и выполняют отправку сообщений электронной почты во внешние домены на законных основаниях. Это противоречие можно обойти, создав второй виртуальный сервер SMTP, предназначенный для получения сообщений электронной почты от клиентских компьютеров POP3 и IMAP4. На этом дополнительном виртуальном сервере SMTP может использоваться проверка подлинности в сочетании с SSL-шифрованием. Помимо этого, на нем можно включить выполнение ретрансляции для прошедших проверку пользователей. Дополнительные сведения о внедрении этой конфигурации см. в в статье 319267 базы знаний Майкрософт «HOW TO: Secure Simple Message Transfer Protocol Client Message Delivery in Exchange 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319267) (Инструкции: доставка сообщений по защищенному протоколу SMTP в Exchange 2000).

Чтобы просмотреть или изменить значение «msExchSmtpRelayForAuth» в диспетчере

  1. Откройте диспетчер Exchange.

  2. Раскройте узел Серверы, раскройте нужный сервер Exchange, раскройте узел Протоколы, а затем — «SMTP».

  3. Щелкните правой кнопкой мыши виртуальный сервер SMTP (например, установленный по умолчанию) и выберите Свойства.

  4. Откройте вкладку Доступ и щелкните Ретранслирование.

  5. Снимите или установите флажок Разрешить всем компьютерам, которые успешно прошли проверку подлинности, выполнять ретрансляцию независимо от верхнего списка.

  6. Нажмите кнопку ОК, чтобы сохранить изменения.

Если данный флажок установлен, для атрибута msExchSmtpRelayForAuth следует установить значение True. Если флажок снят, для атрибута msExchSmtpRelayForAuth следует установить значение False.

Дополнительные сведения об управлении учетными записями, для которых доступна ретрансляция сообщений, см. в следующих статьях базы знаний Майкрософт:

  • 818778, «Users Without Permissions to Relay Messages Can Still Send Messages Through the SMTP Virtual Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818778) (Пользователи, не обладающие разрешениями на ретрансляцию сообщений, могут отправлять сообщения через виртуальный сервер SMTP)

  • 310380, "HOW TO: Prevent Exchange 2000 from Being Used as a Mail Relay in Windows 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=310380) (Инструкции по предотвращению использования Exchange 2000 в качестве ретранслятора почты в Windows 2000)


Значение msExchSmtpSmartHostType не равно своему значению по умолчанию 0
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить, было ли изменено значение по умолчанию 0 параметра msExchSmtpSmartHostType. По умолчанию атрибут msExchSmtpSmartHostType равен 0. Если анализатор сервера Exchange обнаружит, что этот атрибут не равен 0, на экране отобразится сообщение о нестандартной конфигурации.

Атрибут msExchSmtpSmartHostType указывает, настроен ли виртуальный SMTP-сервер на использование промежуточного узла для доставки сообщений. Можно маршрутизировать все исходящие сообщения для удаленных доменов через промежуточный узел, вместо того чтобы отправлять эти сообщения напрямую в домены получателей. Если Exchange использует промежуточный узел, значение атрибута msExchSmtpSmartHostType меняется, как описывается в следующей таблице.

Настройка промежуточного узла | Значение атрибута msExchSmtpSmartHostType
Нет промежуточного узла | 0
Промежуточный узел | 2
Промежуточный узел с первоочередной попыткой прямой доставки | 1

На компьютерах Exchange Server 2003 это значение будет равняться 0 или 2. На компьютерах серверов Exchange 2000 это значение может равняться 0, 1 или 2. Значение 1 устанавливается в том случае, если установлен флажок ??Попытаться использовать прямую доставку, прежде чем отправить на промежуточный узел??. Этот флажок присутствует только в Exchange 2000 Server. В Exchange Server 2003 такого флажка не существует.

Если нет особой причины, рекомендуется не менять атрибут msExchSmtpSmartHostType и оставить значение по умолчанию 0.

Если в среде необходим промежуточный узел и существует (или планируется) более одного сервера Exchange, рекомендуется использовать соединитель SMTP для любых записей промежуточного узла. Таким образом, вся внутренняя почта будет маршрутизироваться сервером Exchange и только внешняя почта будет маршрутизироваться через промежуточный узел.

Чтобы просмотреть и изменить параметры промежуточного узла

  1. Откройте системный диспетчер Exchange.

  2. Откройте Серверы, затем разверните сервер Exchange, Протоколы и SMTP.

  3. Щелкните правой кнопкой мыши виртуальный SMTP-сервер (например, виртуальный SMTP-сервер по умолчанию) и выберите Свойства.

  4. Выберите вкладку Доставка и щелкните Дополнительно.

  5. Введите промежуточный узел, который необходимо использовать. Можно определить промежуточный узел, используя полное доменное имя или IP-адрес. Если используется IP-адрес, необходимо заключить его в квадратные скобки ([ ]). Сначала Exchange проверяет имя сервера, затем IP-адрес. Квадратные скобки указывают, что значение является IP-адресом, поэтому разрешение DNS опускается.

  6. Если этот компьютер является сервером Exchange 2000, можно дополнительно установить флажок ??Попытаться использовать прямую доставку, прежде чем отправить на промежуточный узел??.

  7. Нажмите кнопку ОК, чтобы сохранить изменения, затем щелкните ОК, чтобы закрыть диалоговое окно Свойства виртуального SMTP-сервера.

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • 266686, описывающая первую часть инструкций по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, описывающая вторую часть инструкций по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).


Служба стеков агента передачи сообщений настроена на взаимодействие с рабочим столом
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс Win32_Service, чтобы определить значение ключа DesktopInteract для службы стеков агента передачи сообщений (MSExchangeMTA). Если анализатор сервера Exchange обнаруживает, что для служба агента передачи сообщений настроена на взаимодействие с рабочим столом, на экран выводится сообщение об ошибке.

Эта конфигурация может использоваться под руководством служб поддержки продуктов Майкрософт. Если служба поддержки не давала инструкций по выполнению службы агента передачи сообщений в подобной конфигурации, рекомендуется повторно настроить свойства службы стеков агента передачи сообщений, чтобы служба не могла взаимодействовать с рабочим столом.

Чтобы настроить учетную запись службы стеков агента передачи сообщений

  1. Откройте оснастку «Службы» консоли MMC.

  2. Найдите и остановите службу Стеки агента передачи сообщений Microsoft Exchange.

  3. Дважды щелкните службу Стеки агента передачи сообщений Microsoft Exchange.

  4. На вкладке Вход в систему страницы Свойства стеков агента передачи сообщений Microsoft Exchange выберите С системной учетной записью в группе Вход в систему как.

  5. Снимите флажок Разрешить взаимодействие с рабочим столом и нажмите кнопку Применить.

  6. В разделе Состояние службы щелкните Запустить, а затем нажмите кнопку OK.

  7. Закройте оснастку «Службы».

Дополнительные сведения об исправлении конфигурации службы Exchange см. в статье 239762 базы знаний Майкрософт, посвященной выполнению служб Exchange с системной учетной записью (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762).


Для записей почтового обменника не найдено записей узлов
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-03

Средство анализатора сервера Microsoft® Exchange выполняет просмотр службы имен доменов (Domain Name System, DNS) для извлечения записей почтового обменника (Mail Exchanger, MX). Если записи почтового обменника успешно получены, тогда анализатор сервера Exchange выполняет просмотр службы DNS для извлечения записей (А) узлов серверов, на которые указывают записи почтового обменника. Если операция просмотра службы DNS не возвращает IP-адрес для какой-нибудь одной из этих записей (A) узлов, анализатор сервера Exchange выводит на экран сообщение об ошибке.

Эта ошибка указывает, что запись (А) узла службы DNS, по-видимому, отсутствует для сервера. Из-за этой ошибки сообщения, предназначенные для удаленных доменов, могут архивироваться в очереди Удаленная доставка сервера Exchange. Данная ошибка может также быть причиной задержек маршрутизации или работы службы.

Поиски в службе DNS записей (А) узлов для записей почтового обменника могут завершаться ошибками по следующим причинам:

  • DNS-сервер выключен или не отвечает из-за отказа сети или по другим причинам.

  • Запись (А) узла для удаленного сервера отсутствует на DNS-сервере, так как эта запись недоступна или неправильна.

  • DNS-сервер не настроен на поддержку динамических обновлений записей узлов.

Чтобы убедиться, что DNS-сервер находится в оперативном режиме и запись узла существует

  1. Убедитесь, что DNS-сервер работает, выполнив одну или несколько следующих проверок:

    • Узнайте состояние DNS-сервера, воспользовавшись программой администрирования службы DNS на DNS-сервере.

    • Перезапустите DNS-сервер. Дополнительные сведения см. в описании процедур запуска, останова, временного останова и перезапуска DNS-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Убедитесь в возможности DNS-сервера реагировать на внешние воздействия, выполнив команду nslookup. Дополнительные сведения см. в описании процедуры проверки реакции DNS-сервера на внешние воздействия с помощью команды nslookup (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=63000).

  2. Используйте команду nslookup, чтобы проверить, что запись (А) узла существует на DNS-сервере. Дополнительные сведения см. в описании проверки существования записей ресурса «А» в службе DNS (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=63001).

  3. Если запись ресурса (А) узла не существует, добавьте или измените вручную запись ресурса «А» или настройте DNS-сервер для включения динамических обновлений записей:

    • Добавьте вручную запись ресурса «А». Дополнительные сведения см. в описании процедуры добавления записи ресурса в зону DNS (http://go.microsoft.com/fwlink/?LinkId=63002).

    • Измените вручную запись ресурса «А». Дополнительные сведения см. в описании процедуры изменения существующей записи ресурса (http://go.microsoft.com/fwlink/?LinkId=63014).

    • Настройте DNS-сервер на активизацию динамических обновлений записей узлов. Дополнительные сведения см. в базе знаний Майкрософт в статье 816592, описывающей настройку динамических обновлений DNS в Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592).

Дополнительные сведения

  • Сведения об использовании в Exchange Server 2003 службы DNS для разрешения внешних IP-адресов см. разделе, описывающем зависимости транспорта для Exchange Server 2003, из руководства по транспорту и маршрутизации сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Сведения о разрешении имен DNS см. в базе знаний Майкрософт в статье 322856, описывающей настройку службы DNS для использования с сервером Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

  • Сведения об устранении проблем службы DNS см. в описании неполадок службы DNS (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=63003).

  • Сведения о наблюдении за системой в Exchange Server 2003 см. в главе 3, описывающей наблюдение за системой с помощью пакета управления Exchange Server 2003, из руководства по пакету управления Exchange Server 2003 для MOM 2000 SP1 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47573).

  • Сведения о записях ресурсов (А) узлов см. в описании управления записями ресурсов (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=63004).


Не найдены записи узлов
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-04

Средство анализатора сервера Microsoft® Exchange выполняет поиск DNS для записей (А) узлов удаленных серверов, на которые сервер Exchange пытается отправить сообщения. Если не будет получен IP-адрес, анализатор сервера Exchange отобразит ошибку.

Эта ошибка указывает, что запись (А) узла службы DNS для удаленного сервера, по-видимому, отсутствует. Из-за этой ошибки сообщения, предназначенные для удаленных доменов, могут архивироваться в очереди Удаленная доставка сервера Exchange.

Поиски в службе DNS записей (А) узлов для записей удаленного сервера могут завершаться ошибками по следующим причинам:

  • DNS-сервер выключен или не отвечает из-за отказа сети или по другим причинам.

  • Запись (А) узла для удаленного сервера отсутствует на DNS-сервере, так как эта запись недоступна или неправильна.

  • DNS-сервер не настроен на поддержку динамических обновлений записей узлов.

Чтобы убедиться, что DNS-сервер находится в оперативном режиме и запись узла существует

  1. Убедитесь, что DNS-сервер работает, выполнив одну или несколько следующих проверок:

    • Узнайте состояние DNS-сервера, воспользовавшись программой администрирования службы DNS на DNS-сервере.

    • Перезапустите DNS-сервер. Дополнительные сведения см. в описании процедур запуска, остановки, временной остановки и перезапуска DNS-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Убедитесь в возможности DNS-сервера реагировать на внешние воздействия, выполнив команду nslookup. Дополнительные сведения см. в описании процедуры проверки реакции DNS-сервера на внешние воздействия с помощью команды nslookup (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=63000).

  2. Используйте команду nslookup, чтобы проверить, что запись (А) узла существует на DNS-сервере. Дополнительные сведения см. в описании проверки существования записей ресурса «А» в службе DNS (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=63001).

  3. Если запись ресурса (А) узла не существует, добавьте или измените вручную запись ресурса «А» или настройте DNS-сервер для включения динамических обновлений записей:

    • Добавьте вручную запись ресурса «А». Дополнительные сведения см. в описании процедуры добавления записи ресурса в зону DNS (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=63002).

    • Измените вручную запись ресурса «А». Дополнительные сведения см. в описании процедуры изменения существующей записи ресурса (http://go.microsoft.com/fwlink/?LinkId=63014).

    • Настройте DNS-сервер на активизацию динамических обновлений записей узлов. Дополнительные сведения см. в базе знаний Майкрософт в статье 816592, описывающей настройку динамических обновлений DNS в Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592).
  • Сведения об использовании в Exchange Server 2003 службы DNS для разрешения внешних IP-адресов см. разделе, описывающем зависимости транспорта для Exchange Server 2003, из руководства по транспорту и маршрутизации сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Сведения о разрешении имен DNS см. статье 322856 базы знаний Майкрософт, описывающей настройку службы DNS для использования с сервером Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

  • Сведения об устранении проблем службы DNS см. в описании неполадок службы DNS (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=63003).

  • Сведения о наблюдении за системой в Exchange Server 2003 см. в главе 3, описывающей наблюдение за системой с помощью пакета управления Exchange Server 2003, из руководства по пакету управления Exchange Server 2003 для MOM 2000 SP1 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47573).

  • Сведения о записях ресурсов (А) узлов см. в описании управления записями ресурсов (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=63004).


Не найдены записи почтового обменника
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Средство анализатора сервера Microsoft® Exchange запрашивает DNS-серверы, используемые ей для записей почтового обменника удаленных доменов, в которые Exchange выполняет отправку данных.

Если анализатор сервера Exchange не может извлечь записи почтового обменника для удаленного домена из используемых DNS-серверов, анализатор сервера Exchange выводит предупреждение.

В этом предупреждении указывается, что для данного удаленного домена отсутствуют DNS-записи почтового обменника.

Чтобы определить почтовые узлы, отправляющий сервер Exchange проверяет запись почтового обменника. Далее отправляющий сервер извлекает из записи почтового обменника IP-адрес, определяя запись адреса (запись «А»).

Если записи почтового обменника для удаленных доменов отсутствуют, это может привести к созданию резервных копий сообщений, предназначенных для удаленных доменов, в очереди Удаленная доставка сервера Exchange, а также к иным задержкам маршрутизации и обработки.

DNS-поиск записей почтового обменника может завершиться неудачно, если данный DNS-сервер отключен или недоступен в связи со сбоем сети или по другой причине.

Чтобы убедиться, что DNS-сервер подключен к сети и существуют записи почтового обменника

  1. Убедитесь, что DNS-сервер работает, выполнив одну или несколько следующих проверок:

    • Узнайте состояние DNS-сервера, воспользовавшись программой администрирования службы DNS на DNS-сервере.

    • Перезапустите DNS-сервер. Дополнительные сведения см. в материале "Start, stop, pause, or restart a DNS server" (http://go.microsoft.com/fwlink/?LinkId=62999) (Запуск, останов, временный останов и перезапуск DNS-сервера).

    • Убедитесь в возможности DNS-сервера реагировать на внешние воздействия, выполнив команду nslookup. Дополнительные сведения см. в материале "Verify DNS server responsiveness using the nslookup command" (http://go.microsoft.com/fwlink/?LinkId=63000) (Проверка реакции DNS-сервера на внешние воздействия с помощью команды «nslookup»).

  2. С помощью команды nslookup убедитесь, что записи почтового обменника настроены правильно. Дополнительные сведения см. в разделе "How to Use Nslookup to Verify MX record configuration" (Инструкции по использованию команды «Nslookup» для проверки настройки записи почтового обменника) в части "Verifying DNS Design and Configuration" (Проверка структуры и настройки DNS) в Exchange Server Transport and Routing Guide (http://go.microsoft.com/fwlink/?LinkId=47579) (Руководство по транспорту и маршрутизации сервера Exchange).

Дополнительные сведения

  • Сведения об использовании в Exchange Server 2003 службы DNS для разрешения внешних IP-адресов см. разделе "Transport Dependencies for Exchange Server 2003" (Зависимости транспорта для Exchange Server 2003) в материале Exchange Server Transport and Routing Guide (http://go.microsoft.com/fwlink/?LinkId=47579) (Руководство по транспорту и маршрутизации сервера Exchange).

  • Сведения о разрешении DNS-имен см. в статье 322856 базы знаний Майкрософт "How to configure DNS to use with Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856) (Настройка DNS для использования с сервером Exchange).

  • Сведения об устранении проблем DNS см. в материале "Troubleshooting DNS" (http://go.microsoft.com/fwlink/?LinkId=63003) (Устранение неполадок DNS).

  • Сведения о наблюдении за системой в Exchange Server 2003 см. в главе 3, "System Monitoring with Exchange Server 2003 Management Pack" (Наблюдение за системой с помощью пакета управления Exchange Server 2003) руководства System Monitoring with Exchange Server 2003 Management Pack(http://go.microsoft.com/fwlink/?LinkId=47573) (Руководство по пакету управления Exchange Server 2003 для MOM 2000 SP1).


В ограничениях по доставке обнаружена вложенная группа рассылки
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-08-21

Чтобы определить, используются ли какие-либо группы для установки ограничений по доставке на основе членства в группе, средство анализатора сервера Microsoft® Exchange запрашивает для каждого объекта группы рассылки во всех доменах, обнаруженных в службе каталогов Active Directory®, следующие атрибуты:

dLMemRejectPermsBL | Содержит различающиеся имена получателей или соединителей, которые не принимают сообщения из этой группы.
dLMemSubmitPermsBL | Содержит различающиеся имена получателей или соединителей, которые принимают сообщения из этой группы.

Если анализатор сервера Exchange обнаружит, что существуют объекты групп, которые используются для установки ограничений по доставке, тогда анализатор сервера Exchange анализирует эти группы, чтобы определить, содержат ли они какие-либо вложенные группы.

Чтобы определить, существует ли в реестре параметр RestrictionMethod и, если существует, то как он настроен, анализатор сервера Exchange также считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

Анализатор сервера Exchange выводит на экран предупреждение, если выполняются следующие условия:

  • Членство в группе рассылки используется для установки ограничений по доставке.

  • В группах рассылки, которые задают ограничения по доставке, существуют вложенные группы рассылки.

  • Параметр RestrictionMethod реестра существует и не установлен на принудительную сплошную проверку ограничений.

Это сообщение об ошибке означает, что ограничения по доставке на основе членства в группе рассылки могут оказывать значительное влияние на интенсивность потока почты Exchange.

Поведения классификатора по умолчанию состоят в рекурсивном развертывании групп рассылки и проверке ограничений для каждого сообщения, проходящего через систему.

Когда почта посылается пользователю, принимающему или отклоняющему сообщения из группы рассылки, или когда посылается почта, которая проходит через соединитель, принимающий или отклоняющий сообщения из группы рассылки, классификатор сообщений должен развернуть иерархию членства в группе рассылки, получить полный список различающихся имен членов и затем сравнить список различающихся имен с различающимися именами отправителей в списке. Когда различающиеся имена в обоих списках совпадают, выполняется операция разрешения доступа или операция запрета доступа. Если группа рассылки вложена в другую группу рассылки, вложенная группа рассылки также разворачивается.

Значение параметра RestrictionMethod реестра определяет, каким образом классификатор обрабатывает ограничения. Если значение параметра RestrictionMethod установлено равным 2, компоненты передачи на этом сервере Exchange не будут разворачивать структуру членства групп рассылки при проверке ограничений. Такая конфигурация обеспечивает максимальную производительность выполнения проверок ограничений. Кроме того, чтобы параметр реестра RestrictionMethod смог оказать свое влияние, необходимо, чтобы все группы рассылки, включающие пользователей, которые имеют ограничения по доставке, были плоскими. Это означает, что группы рассылки, на которые наложены ограничения, не должны иметь вложенных групп рассылки. Логика расширения не будет работать, если группы рассылки, на которые наложены ограничения, будут иметь вложенные группы рассылки.

Для групп рассылки, используемых в ограничениях соединителя, рекомендуется задать значение параметра реестра RestrictionMethod на сервере-плацдарме соединителя, не имеющем почтовых ящиков. Для ограничений для пользователей Active Directory, если в группах рассылки с ограничениями имеются серверы расширения, рекомендуется создать запись RestrictionMethod реестра на серверах расширения.

Чтобы устранить эту ошибку, выполните следующие действия:

  • Проанализируйте тех пользователей, которые имеют ограничения по доставке, установленные группой рассылки, и удалите ненужные ограничения.

  • Настройте отдельные почтовые ящики, а не группы рассылки для ограничений по доставке согласно сведениям, содержащимся в базе знаний Майкрософт, в статье 812298, описывающей ситуацию, когда доставка почты замедляется после настройки ограничений по доставке на основе списка рассылки (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Для серверов, на которых выполняется Microsoft Exchange Server 2003 с пакетом обновления 2 (SP2) или более поздняя версия, рассмотрите возможность реализации неиерархической проверки ограничений. Для серверов, на которых выполняются версии Exchange, предшествующие Exchange 2003 с пакетом обновления 2 (SP2), рассмотрите возможность обновления до Exchange 2003 с пакетом обновления 2 (SP2).

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы создать параметр реестра RestrictionMethod и задать для него значение 2

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

  3. В левой области щелкните Параметры.

  4. В меню «Правка» укажите пункт Создать, а затем щелкните Параметр DWORD.

  5. Введите RestrictionMethod, а затем нажмите клавишу ВВОД, чтобы присвоить имя новой записи реестра.

  6. Щелкните правой кнопкой мыши RestrictionMethod и выберите команду Изменить.

  7. Введите 2, а затем нажмите клавишу ВВОД.

  8. Закройте редактор реестра.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения о редактировании реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения

Дополнительные сведения о неиерархической проверке ограничений см. в разделе Рассмотрите возможность неиерархической проверки ограничений.

Дополнительные сведения о влиянии ограничения групп рассылок на поток почты Exchange см. в следующих статьях базы знаний Майкрософт:

  • Статья 895407, описывающая ситуацию в Exchange Server 2003, когда доставка сообщений в локальные и во внешние почтовые ящики вопреки ожиданиям замедляется после настройки ограничений по доставке на основе групп рассылок (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • Статья 839949, описывающая устранение неполадок почтового транспорта и групп рассылок в Exchange 2000 Server и в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • Статья 812298, описывающая ситуацию, когда доставка почты замедляется после настройки ограничений по доставке на основе списка рассылки (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

Дополнительные сведения о параметре RestrictionMethod реестра см. в базе знаний Майкрософт в статье 895407, описывающей ситуацию в Exchange Server 2003, когда доставка сообщений в локальные и во внешние почтовые ящики вопреки ожиданиям замедляется после настройки ограничений по доставке на основе групп рассылок (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

Дополнительные сведения о значении параметра реестра см. в базе знаний Майкрософт, в статье 277872, описывающей проблемы в работе ограничений по доставке, настроенных для соединителя (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872).


Обнаружена вложенная группа рассылки, но включена сплошная проверка ограничений
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-08-21

Чтобы определить, используются ли какие-либо группы для установки ограничений по доставке на основе членства в группе, средство анализатора сервера Microsoft® Exchange запрашивает для каждого объекта группы рассылки во всех доменах, обнаруженных в службе каталогов Active Directory®, следующие атрибуты:

dLMemRejectPermsBL | Содержит различающиеся имена получателей или соединителей, которые не принимают сообщения из этой группы.
dLMemSubmitPermsBL | Содержит различающиеся имена получателей или соединителей, которые принимают сообщения из этой группы.

Если анализатор сервера Exchange обнаружит, что существуют объекты групп, которые используются для установки ограничений по доставке, тогда анализатор сервера Exchange анализирует эти группы, чтобы определить, содержат ли они какие-либо вложенные группы

Чтобы определить, существует ли в реестре параметр RestrictionMethod и, если существует, то как он настроен, анализатор сервера Exchange также считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

Анализатор сервера Exchange выводит на экран предупреждение, если выполняются следующие условия:

  • Установка ограничений по доставке выполняется на основе членства в группе рассылки.

  • В группах рассылки, которые задают ограничения по доставке, существуют вложенные группы рассылки.

  • Параметр RestrictionMethod реестра существует и установлен на принудительную сплошную проверку ограничений.

Это предупреждение указывает, что хотя параметр RestrictionMethod реестра и установлен на принудительную сплошную (неиерархическую) проверку ограничений, группы рассылки, установившие ограничения по доставке, имеют другие, встроенные в них (вложенные) группы рассылки. Сплошная проверка ограничений не идентифицирует правильно разрешенных или заблокированных отправителей, если группы рассылки содержат вложенные группы рассылки. При сплошной проверке ограничений вложенные группы рассылки не раскрываются.

Поведения классификатора по умолчанию состоят в рекурсивном развертывании групп рассылки и проверке ограничений для каждого сообщения, проходящего через систему.

Когда почта посылается пользователю, принимающему или отклоняющему сообщения из группы рассылки, или когда посылается почта, которая проходит через соединитель, принимающий или отклоняющий сообщения из группы рассылки, классификатор сообщений должен развернуть иерархию членства в группе рассылки, получить полный список различающихся имен членов и затем сравнить список различающихся имен с различающимися именами отправителей в списке. Когда различающиеся имена в обоих списках совпадают, выполняется операция разрешения доступа или операция запрета доступа. Если группа рассылки вложена в другую группу рассылки, вложенная группа рассылки также разворачивается.

Значение параметра RestrictionMethod реестра определяет, каким образом классификатор обрабатывает ограничения. Если значение параметра RestrictionMethod установлено равным 2, компоненты передачи на этом сервере Exchange не будут разворачивать структуру членства групп рассылки при проверке ограничений. Такая конфигурация обеспечивает максимальную производительность выполнения проверок ограничений. Кроме того, чтобы параметр реестра RestrictionMethod смог оказать свое воздействие, необходимо, чтобы все группы рассылки, включающие пользователей, которые имеют ограничения по доставке, были плоскими. Это означает, что группы рассылки, на которые наложены ограничения, не должны иметь вложенных групп рассылки.

Чтобы не допустить появления этого предупреждения в случае, когда включена сплошная проверка ограничений, не вкладывайте группы рассылки в другие группы рассылки, которые используются для ограничений по доставке.

Дополнительные сведения

Дополнительные сведения о неиерархической проверке ограничений см. в разделе Рассмотрите возможность неиерархической проверки ограничений.

Дополнительные сведения о воздействии ограничения групп рассылок на поток почты Exchange см. в следующих статьях базы знаний Майкрософт:

  • Статья 895407, описывающая ситуацию в Exchange Server 2003, когда доставка сообщений в локальные и во внешние почтовые ящики вопреки ожиданиям замедляется после настройки ограничений по доставке на основе групп рассылок (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • Статья 839949, описывающая устранение неполадок почтового транспорта и групп рассылок в Exchange 2000 Server и в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • Статья 812298, описывающая ситуацию, когда доставка почты замедляется после настройки ограничений по доставке на основе списка рассылки (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

Дополнительные сведения о параметре RestrictionMethod реестра см. в базе знаний Майкрософт в статье 895407, описывающей ситуацию в Exchange Server 2003, когда доставка сообщений в локальные и во внешние почтовые ящики вопреки ожиданиям замедляется после настройки ограничений по доставке на основе групп рассылок (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

Дополнительные сведения о значениях параметра реестра см. в базе знаний Майкрософт в статье 277872, описывающей проблемы в работе ограничений по доставке, настроенных для соединителя (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872).


Нет сообщения от указанного отправителя
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-03-07

Чтобы определить, существует ли соответствие для указанного пользователем SMTP-адреса, анализатор Microsoft Exchange Server запрашивает в службе каталогов Active Directory значение атрибута proxyAddress для всех объектов пользователя.

Если соответствие для атрибута proxyAddress объекта пользователя найдено, тогда анализатор сервера Exchange запрашивает значение атрибута msExchHomeServerName объекта пользователя службы каталогов Active Directory, чтобы определить, совпадает ли это значение с заданным пользователем именем сервера Exchange.

Наконец, анализатор Exchange Server запрашивает свойство SenderAddress класса инструментария управления Microsoft Windows (WMI) Exchange_MessageTrackingEntry в пространстве имен root\MicrosoftExchangeV2, чтобы определить все сообщения, отслеживаемые журналами отслеживания сообщений как сообщения от указанного пользователем отправителя.

Если анализатору сервера Exchange не удается найти запись в журнале отслеживания сообщений со значением свойства senderAddress, которое совпадает с legacyDN или SMTP-адресом указанного пользователем отправителя, на экран выводится сообщение об ошибке.

  • Эта ошибка указывает, что выполняется не менее одного из следующих условий:

  • Указанный пользователем отправитель не посылал никаких сообщений.

  • Время хранения в журнале отслеживания сообщений истекло, и записи нужного журнала уже удалены.

  • Отслеживание сообщений не включено для сервера.

Чтобы устранить эту проблему, выполните следующие действия:

  • Попросите указанного отправителя отправить еще одно сообщение заданному получателю.

  • Включите центр отслеживания сообщений.

  • Увеличьте период хранения в журнале отслеживания сообщений или отследите более свежее сообщение.

Дополнительные сведения о включении центра отслеживания сообщений см. в статье «Включение центра отслеживания сообщений на сервере» (http://go.microsoft.com/fwlink/?LinkId=71257) (на английском языке) и в разделе «Устранение проблем, связанных с потоком почты и протоколом SMTP» Руководства по транспорту и маршрутизации в Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875) (на английском языке).

Дополнительные сведения об использовании отслеживания сообщений см. в базе знаний Майкрософт, в статье 262162, описывающей применение центра отслеживания сообщений для наблюдения за сообщениями (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162).


Отсутствует сообщение для указанного получателя
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-12-07

Чтобы определить, существует ли соответствие для указанного пользователем SMTP-адреса (Simple Mail Transfer Protocol), средство анализатора сервера Microsoft® Exchange запрашивает значение атрибута proxyAddress службы каталогов Active Directory® для всех объектов пользователя.

Если соответствие для атрибута proxyAddress объекта пользователя найдено, тогда анализатор сервера Exchange запрашивает значение атрибута msExchHomeServerName объекта пользователя службы каталогов Active Directory, чтобы определить, совпадает ли это значение с заданным пользователем именем сервера Exchange.

Затем анализатор сервера Exchange запрашивает свойство SenderAddress WMI-класса (Microsoft Windows® Management Instrumentation) Exchange_MessageTrackingEntry в пространстве имен root\MicrosoftExchangeV2, чтобы идентифицировать все сообщения, отслеживаемые журналами отслеживания сообщений, от указанного пользователем отправителя.

Наконец, анализатор сервера Exchange запрашивает свойство RecipientAddress WMI-класса Exchange_MessageTrackingEntry, чтобы идентифицировать все сообщения, отслеживаемые в журналах отслеживания сообщений, для указанного пользователем получателя.

Если анализатору сервера Exchange не удается найти запись в журнале отслеживания сообщений со значением свойства RecipientAddress, которое совпадает с SMTP-адресом указанного пользователем получателя, на экран выводится сообщение об ошибке.

Эта ошибка указывает, что выполняется не менее одного из следующих условий:

  • Указанный пользователем отправитель не послал никаких сообщений для заданного пользователем получателя.

  • Время хранения в журнале отслеживания сообщений истекло, и записи нужного журнала уже удалены.

Чтобы устранить эту проблему, выполните следующие действия:

  • Убедитесь в правильности указанного адреса получателя.

  • Попросите указанного отправителя отправить еще одно сообщение заданному получателю.

  • Увеличьте период хранения в журнале отслеживания сообщений или отследите более свежее сообщение.

Дополнительные сведения об увеличении периода хранения журналов в центре отслеживания сообщений см. в статье «Включение центра отслеживания сообщений на сервере» по адресу http://go.microsoft.com/fwlink/?LinkID=71257 (на английском языке).

Дополнительные сведения об использовании отслеживания сообщений см. в базе знаний Майкрософт, в статье 262162, описывающей применение центра отслеживания сообщений для наблюдения за сообщениями (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162).


Состояние очереди недоступно. Анализ очереди SMTP прерван
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-03-15

Анализатор Microsoft Exchange запрашивает класс ExchangeLink инструментария управления Microsoft Windows (WMI) для проверки состояния очередей SMTP для сервера Exchange Server.

SMTP является основным почтовым протоколом для отправки и транспорта почты в Exchange Server. Это означает, что протокол SMTP используется клиентами для отправки сообщений, а серверами Exchange Server — для доставки сообщений и данных сообщений.

Свойства класса WMI ExchangeLink возвращают сведения о связях (очередях) обработки сообщений между почтовыми серверами. Связь может содержать ноль или более объектов ExchangeQueue. Это количество зависит от текущего трафика сообщений.

Протокол SMTP использует очереди SMTP для внутренней и внешней доставки почты. В процессе классификации и доставки сообщений расширенный механизм постановки в очередь отправляет всю почту через очереди SMTP виртуального SMTP-сервера. Если на каком-либо этапе этого процесса возникнет проблема с доставкой сообщения, оно останется в очереди, в которой возникла проблема.

Описание очередей SMTP

Очередь SMTP Описание

[имя_локального_домена] (локальная доставка)

Содержит сообщения, поставленные в очередь на сервере Exchange Server для локальной доставки в почтовый ящик Exchange или хранилище общих папок.

Сообщения, ожидающие поиска в каталоге

Содержит сообщения для получателей, которые еще не были разрешены в службе каталогов Microsoft Active Directory. В эту очередь также помещаются сообщения во время развертывании списков рассылки.

Сообщения, ожидающие маршрутизации

Содержит сообщения, ожидающие определения следующего сервера назначения, а затем перемещает их в соответствующие очереди.

Удаленная доставка

[имя_соединителя|

имя_сервера| удаленный_домен]

Содержит сообщения, предназначенные для удаленной доставки. Имя очереди соответствует месту назначения удаленной доставки , которое может быть соединителем, сервером или доменом.

Конечное назначение в настоящий момент недоступно

Конечный сервер назначения для этих сообщений недоступен. Например, серверу Exchange Server не удается определить сетевой путь к конечному назначению.

Подготовка к отправке

Содержит сообщения, подтвержденные и принятые службой SMTP. Обработка этих сообщений еще не началась.

Уведомления о доставке, ожидающие отправки

Содержит уведомления о доставке (которые также называются отчетами о недоставке), готовые к доставке сервером Exchange Server.

Примечание. Для этой очереди недоступны следующие операции:

  • Удалить все сообщения (без отчета о недоставке)

  • Удалить все сообщения (с отчетом о недоставке)

Очередь повторной доставки сбойных сообщений

Содержит сообщения, которые по какой-либо причине не удалось отправить в очередь (зачастую до выполнения любой другой обработки). По умолчанию сообщения в этой очереди повторно обрабатываются через 60 минут.

Сообщения, поставленные в очередь для отложенной доставки

Содержит сообщения, поставленные в очередь для доставки в более позднее время, в том числе сообщения, отправленные предыдущими версиями Outlook. (Этот параметр можно установить на клиентских компьютерах Outlook.)

Для доставки сообщений в предыдущих версиях Outlook используется агент передачи сообщений (MTA). В современных версиях доставка сообщений выполняется с помощью протокола SMTP, а не агента MTA. Поэтому отложенная доставка сообщений, отправленных предыдущими версиями Outlook, выполняется по-другому.

Эти сообщения остаются в данной очереди до запланированного времени доставки.

Если анализатору Exchange не удается успешно запросить класс WMI ExchangeLink для сервера, выводится сообщение об ошибке.

Эта ошибка указывает на то, что запросу WMI не удалось получить требуемые данные.

Ниже перечислены возможные причины такой ошибки.

  • Учетная запись, от имени которой запущен анализатор Exchange, не имеет достаточных разрешений на запрос классов WMI.

  • Подключение анализатора Exchange к компьютеру невозможно из-за неполадок в сети.

  • Временное состояние, причина которого неизвестна, привело к истечению времени ожидания запроса.

Чтобы устранить эту ошибку, выполните указанные ниже действия.

  1. Убедитесь, что компьютер Exchange Server включен и подключен к сети.

  2. С помощью команды PING проверьте доступность компьютера с сервером Exchange Server.

  3. Если в системе установлен брандмауэр, проверьте, не заблокированы ли порты удаленного вызова процедур (RPC).

  4. Проверьте разрешения учетной записи, с которой запущен анализатор Exchange. Учетная запись, с которой запущен анализатор Exchange, должна иметь разрешения локального администратора для каждого проверяемого сервера Exchange Server.

    Можно также предоставить особое разрешение WMI учетной записи, с которой запущен анализатор Exchange.

    1. На компьютере с Exchange Server откройте дерево консоли управления (MMC) Управление компьютером.

    2. В разделе Службы и приложения щелкните правой кнопкой мыши пункт Управляющий элемент WMI и выберите команду Свойства.

    3. На странице Свойства: Управляющий элемент WMI откройте вкладку Безопасность и разверните узел Корень.

    4. Выберите папку CIMV2 и нажмите кнопку Безопасность.

    5. На странице Безопасность для ROOT\CIMV2 добавьте учетную запись, с которой выполняется анализатор Exchange.

  5. Выберите учетную запись, которая была добавлена в действии 5. В разделе Разрешения для выбранная_учетная_запись в столбце Разрешить установите флажки Включить удаленно и Читать безопасность, а затем нажмите кнопку ОК.

Дополнительные сведения об устранении неполадок с сетевыми подключениями см. в статье 325487 базы знаний Майкрософт «Разрешение проблем, связанных с выполнением сетевого подключения » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Дополнительные сведения об устранении неполадок с подключениями анализатора соответствия рекомендациям для Exchange см. в статье «Устранение неполадок, связанных с подключениями анализатора соответствия рекомендациям для Microsoft Exchange» (http://go.microsoft.com/fwlink/?LinkId=56285) (на английском языке).

Дополнительные сведения о требованиях к портам см. в статье 832017 базы знаний Майкрософт «Службы и сетевые порты в серверных системах Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Для проверки DNS-записи нет доступных удаленных серверов или доменов
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-07-06

Анализатор сервера Microsoft® Exchange предпринимает попытку выявить полные доменные имена, IP-адреса и доменные имена удаленных серверов, для которых предназначена почта в очереди удаленной доставки, и включить эти данные в список.

Список полных доменных имен, IP-адресов и доменных имен удаленных серверов составляется следующим образом:

  • Запрашивается свойство msExchSmtpFullyQualifiedDomainName объекта службы каталогов Active Directory® виртуального SMTP-сервера.

    Примечание.
    Затем в свойстве msExchTargetBridgeheadServersDN объекта каталога соединителя группы маршрутизации при направлении в этот объект запроса по конечным целевым серверам-плацдармам считывается свойство msExchSmtpFullyQualifiedDomainName
  • В свойстве msExchSmtpSmartHost объекта SMTP-соединителя в Active Directory запрашивается конечный промежуточный узел SMTP-соединителя.

  • В свойстве LinkName WMI-класса ExchangeLink запрашиваются прямые подключения удаленного сервера.

Если анализатор сервера Exchange обнаруживает, что построенный список не содержит записей, выводится сообщение об ошибке.

Эта ошибка может быть вызвана следующими причинами:

  • Нерегулярно возникающие проблемы подключения к сети или к Active Directory, которые вызывают проблемы в потоке почты.

  • Учетная запись, от имени которой выполняется анализатор сервера Exchange, не обладает достаточными разрешениями на запрос таких данных.

Чтобы устранить эту ошибку

  1. Убедитесь, что компьютер сервера Exchange включен и подключен к сети.

  2. Проверьте наличия сетевого подключения к контроллеру домена Active Directory.

  3. Укажите контроллер домена Active Directory в анализаторе сервера Exchange.

  4. С помощью команды PING проверьте доступность компьютера сервера Exchange.

  5. При наличии межсетевого экрана проверьте, не блокированы ли порты удаленного вызова процедур.

  6. Проверьте разрешения учетной записи, от имени которой выполняется анализатор сервера Exchange. Учетная запись, с которой выполняется анализатор сервера Exchange, на каждом сканируемом компьютере сервера Exchange должна обладать разрешениями локального администратора.

Дополнительные сведения см. в статье 325487 базы знаний Майкрософт, посвященной инструкциям по устранению неполадок в сетевых подключениях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Дополнительные сведения о неполадках в сетевых подключениях анализатора сервера Exchange см. в на веб-узле, посвященном рекомендациям по устранению неполадок в сетевых подключениях средства анализатора сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=56285).

Дополнительные сведения о требованиях к портам см. в статье базы знаний Майкрософт 832017, содержащей обзор служб и требования к сетевым портам для системы Windows Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Отсутствуют доступные серверы для проверки SMTP-команд
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-10-16

Средство анализа Microsoft® Exchange Server пытается определить и сформировать список полных доменных имен (FQDN), IP-адресов и доменных имен удаленных серверов, для которых предназначены сообщения электронной почты в очереди удаленной доставки.

Список полных доменных имен, IP-адресов и доменных имен удаленных серверов строится следующим образом:

  • Запрашивается свойство msExchSmtpFullyQualifiedDomainName объекта службы каталогов Active Directory® виртуального SMTP-сервера.

    Примечание.
    Свойство msExchSmtpFullyQualifiedDomainName, свою очередь, считывается из свойстваmsExchTargetBridgeheadServersDN объекта каталога соединителя группы маршрутизации, когда ему отправляется запрос назначенных целевых серверов-плацдармов.
  • Происходит запрос свойства msExchSmtpSmartHost объекта службы Active Directory SMTP-соединителя на предмет указанного промежуточного узла для SMTP-соединителя.

  • Свойство LinkName классаExchangeLink инструментария WMI запрашивается на наличие прямых соединений с удаленными серверами.

Если средство анализа Exchange Server определило, что при попытке построения списка не получено ни одной записи, то на экран выводится сообщение об ошибке.

Это сообщение свидетельствует о следующем:

  • Проблемы промежуточной сети или соединения службы Active Directory могут вызывать проблемы потока почты.

  • Учетная запись, от имени которой запущено средство Exchange Server Analyzer, не имеет достаточных разрешений на запрос сведений.

Устранение этой ошибки

  1. Убедитесь, что компьютер с сервером Exchange Server включен и подсоединен к сети.

  2. Убедитесь, что контроллер доменов службы Active Directory доступен через сеть.

  3. В средстве анализа Exchange Server укажите контроллер домена службы Active Directory.

  4. Определите, доступен ли компьютер с сервером Exchange, с помощью команды PING.

  5. При наличии брандмауэра проверьте, не блокированы ли порты удаленного вызова процедур.

  6. Проверьте разрешения учетной записи, от имени которой выполняется средство анализа Exchange Server. Учетная запись, с которой выполняется средство анализа Exchange, должна обладать разрешениями локального администратора на каждом сканируемом сервере Exchange Server.

Дополнительные сведения о проблемах с сетевыми подключениями см. в статье 325487 базы знаний Майкрософт «Разрешение проблем, связанных с сетевыми подключениями» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Дополнительные сведения об устранении неполадок в подключениях средства анализа Exchange Server см. в статье «Рекомендации по устранению неполадок, связанных с подключениями средства анализатора рекомендаций для сервера Microsoft Exchange Server» по адресу http://go.microsoft.com/fwlink/?LinkId=56285 (на английском языке).

Дополнительные сведения о требованиях к портам см. в статье 832017 базы знаний Майкрософт «Службы и сетевые порты в серверных системах Microsoft Windows» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017.


Отсутствовали доступные серверы для проверок подключений
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-07-07

Средство анализатора сервера Microsoft® Exchange пытается определить и создать список полных доменных имен (FQDN — Fully Qualified Domain Name), IP-адресов и доменных имен удаленных серверов, для которых предназначена почта в очереди удаленной доставки.

  • Список полных доменных имен, IP-адресов и доменных имен удаленных серверов создается следующим образом:

  • Запрашивается свойство msExchSmtpFullyQualifiedDomainName объекта службы каталогов Active Directory® виртуального SMTP-сервера.

    Примечание.
    В свою очередь свойство msExchSmtpFullyQualifiedDomainName читается из свойства msExchTargetBridgeheadServersDN объекта каталога соединителя групп маршрутизации, когда он запрашивается для назначенных целевых серверов-плацдармов.
  • Запрашивается свойство msExchSmtpSmartHost SMTP-соединителя (объекта Active Directory) для назначенного промежуточного узла для SMTP-соединителя.

  • Запрашивается свойство LinkName WMI-класса ExchangeLink для любых непосредственных подключений к удаленному серверу.

Если анализатор сервера Exchange определяет, что при попытке создания этого списка не создано ни одной записи, отображается сообщение об ошибке.

Эта ошибка указывает на следующее:

  • Периодически могут возникать неполадки с сетью или подключением к службе каталогов Active Directory, приводящие к проблемам с потоком почты.

  • Учетная запись, от имени которой выполняется анализатор сервера Exchange, возможно, не обладает достаточными разрешениями на запрос данных.

Чтобы устранить эту ошибку

  1. Убедитесь, что компьютер сервера Exchange включен и подключен к сети.

  2. Проверьте наличие подключения к контроллеру домена Active Directory.

  3. Укажите контроллер домена Active Directory в анализаторе сервера Exchange.

  4. С помощью команды PING проверьте доступность компьютера сервера Exchange.

  5. Если используется межсетевой экран, проверьте, не закрыты ли порты RPC.

  6. Проверьте разрешения учетной записи, от имени которой выполняется анализатор сервера Exchange. Учетная запись, от имени которой выполняется анализатор сервера Exchange, на каждом сканируемом компьютере сервера Exchange должна обладать разрешениями локального администратора.

Для получения дополнительных сведений о проблемах, связанных с подключениями к сети, см. статью базы знаний Майкрософт 325487, содержащую инструкции по устранению неполадок сетевых подключений (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Для получения дополнительных сведений о неполадках, связанных с подключениями анализатора сервера Exchange, см. статью, посвященную устранению неполадок, связанных с подключениями средства анализатора рекомендаций для сервера Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=56285).

Для получения дополнительных сведений о требованиях к портам см. статью базы знаний Майкрософт 832017, содержащую обзор служб и требования к сетевым портам для системы Windows Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Отсутствовали доступные серверы для проверки имен экземпляров SMTP
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-07-07

Анализатор сервера Microsoft® Exchange предпринимает попытку выявить полные доменные имена, IP-адреса и доменные имена удаленных серверов, для которых предназначена почта в очереди удаленной доставки, и включить эти данные в список.

Список полных доменных имен, IP-адресов и доменных имен удаленных серверов составляется следующим образом:

  • Запрашивается свойство msExchSmtpFullyQualifiedDomainName объекта службы каталогов Active Directory® виртуального SMTP-сервера.

    Примечание.
    Затем в свойстве msExchTargetBridgeheadServersDN объекта каталога соединителя группы маршрутизации при направлении в этот объект запроса о конечных целевых серверах-плацдармах считывается свойство msExchSmtpFullyQualifiedDomainName
  • В свойстве msExchSmtpSmartHost объекта Active Directory SMTP-соединителя запрашивается конечный промежуточный узел SMTP-соединителя.

  • В свойстве LinkName WMI-класса (Microsoft Windows® Management Instrumentation) ExchangeLink запрашиваются прямые подключения удаленного сервера.

Если анализатор сервера Exchange обнаруживает, что созданный список не содержит записей, выводится сообщение об ошибке.

Эта ошибка может быть вызвана следующими причинами:

  • Нерегулярно возникающие проблемы подключения к сети или к Active Directory, которые вызывают проблемы в потоке почты.

  • Учетная запись, от имени которой выполняется анализатор сервера Exchange, не обладает достаточными разрешениями на запрос таких данных.

Чтобы устранить эту ошибку

  1. Убедитесь, что компьютер сервера Exchange включен и подключен к сети.

  2. Проверьте наличие сетевого подключения к контроллеру домена Active Directory.

  3. Укажите контроллер домена Active Directory в анализаторе сервера Exchange.

  4. С помощью команды PING проверьте доступность компьютера сервера Exchange.

  5. При наличии межсетевого экрана проверьте, не блокированы ли порты удаленного вызова процедур.

  6. Проверьте разрешения учетной записи, от имени которой выполняется анализатор сервера Exchange. Учетная запись, с которой выполняется анализатор сервера Exchange, на каждом сканируемом компьютере сервера Exchange должна обладать разрешениями локального администратора.

Дополнительные сведения см. в базе знаний Майкрософт в статье 325487, содержащей инструкции по устранению неполадок в сетевых подключениях (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Дополнительные сведения о неполадках в сетевых подключениях анализатора сервера Exchange см. в статье, посвященной устранению неполадок в сетевых подключениях анализатора рекомендаций сервера Exchange (http://go.microsoft.com/fwlink/?LinkId=56285).

Дополнительные сведения о требованиях к портам см. в статье базы знаний Майкрософт 832017, содержащей обзор служб и требования к сетевым портам для системы Windows Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Параметр кэша службы маршрутизации не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, изменен ли параметр по умолчанию кэша службы маршрутизации, анализатор сервера Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\

Если анализатор сервера Exchange обнаружит, что значение реестра ServerCacheRefreshInterval было создано вручную с помощью изменения двоичного параметра 900 сервера Exchange по умолчанию, анализатор сервера Exchange отображает предупреждение. По умолчанию значение параметра реестра ServerCacheRefreshInterval не создается во время установки сервера Exchange. Однако значение реестра ServerCacheRefreshInterval можно создать вручную после установки сервера Exchange для изменения параметра по умолчанию кэша службы маршрутизации. Если значение реестра создано вручную и этот параметр настроен неверно, на сервере Exchange могут возникнуть неполадки с почтовым потоком.

Рекомендуется создавать и изменять значение параметра ServerCacheRefreshInterval реестра только после проведения серьезного анализа сложившихся условий. Значения по умолчанию двоичных параметров сервера Exchange были тщательно выбраны для оптимальной производительности в большинстве сред серверов Exchange. Рекомендуется искать основную причину неполадок, а не изменять поведение по умолчанию сервера Exchange с помощью настройки реестра. Чтобы следовать этим рекомендациям, может понадобиться удалить раздел реестра ServerCacheRefreshInterval, если он существует, чтобы вернуть сервер Exchange к двоичным параметрам по умолчанию для кэша службы маршрутизации. Однако это решение зависит от настроенных параметров конфигурации сервера Exchange или от среды Exchange.

Анализатор сервера Exchange отображает эту конфигурацию только для сведений. Однако можно изменить раздел реестра на значение по умолчанию.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы устранить причину появления этого предупреждения

  1. Нажмите кнопку Пуск, выберите команду Выполнить, введите Regedit и нажмите кнопку ОК.

  2. В дереве консоли найдите и щелкните следующий раздел реестра: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\RESvc\Parameters\

  3. В области сведений щелкните правой кнопкой мыши значение реестра ServerCacheRefreshInterval. Измените значение на 900.

  4. Также в области сведений можно щелкнуть правой кнопкой мыши значение реестра ServerCacheRefreshInterval, затем щелкнуть Удалить. Подтвердите удаление значения реестра, нажав кнопку Да в диалоговом окне.

  5. Перезапустите сервер Exchange.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об изменении реестра Microsoft Windows см. в следующих статьях базы знаний Майкрософт:

  • статья 322755, описывающая инструкции по резервному копированию, изменению и восстановлению реестра в Windows 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755);

  • статья 322756, описывающая инструкции по резервному копированию, изменению и восстановлению реестра в Windows XP и Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756).


Значение реестра SMTP LdapRequestTimeLimit отличается от значения по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server считывает следующий параметр реестра, чтобы определить, было ли изменено значение LdapRequestTimeLimit, установленное по умолчанию:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Если средство анализа Exchange Server обнаружит, что параметр реестра LdapRequestTimeLimit был создано вручную, чтобы изменить двоичный параметр сервера Exchange, установленный по умолчанию (600 секунд), оно выдаст сообщение о том, что настройка отличается от настройки по умолчанию. По умолчанию параметр реестра LdapRequestTimeLimit при установке сервера Exchange не создается. Однако параметр LdapRequestTimeLimit можно создать вручную после установки сервера Exchange, чтобы изменить максимальное время ожидания каждого отдельного запроса LDAP в очереди (указывается в секундах). Если параметр реестра создан вручную и настроен неверно, это может вызвать проблемы передачи сообщений на сервере Exchange.

Рекомендуется создавать и изменять параметр реестра LdapRequestTimeLimit только в самом крайнем случае. Значения в двоичных файлах сервера Exchange, установленные по умолчанию, тщательно отбирались для обеспечения оптимальной производительности в большинстве сред серверов Exchange. Обычно лучше устранить основную причину возникшей проблемы, а не изменять стандартное поведение Exchange Server, настраивая реестр вручную. Следуя этому совету, лучше удалить параметр реестра LdapRequestTimeLimit, если он существует, чтобы вернуть настройку сервера Exchange к двоичному параметру, установленному по умолчанию.

Средство анализа Exchange Server сообщает об этой настройке только для информации. Однако может понадобиться изменить параметр реестра путем правки реестра, чтобы вернуться к параметру по умолчанию.

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Для получения сведений о восстановлении реестра см. раздел «Восстановление реестра» справочной системы файла Regedit.exe или Regedt32.exe.
Устранение предупреждения

  1. Нажмите кнопку Пуск, выберите Выполнить, введите Regedit и нажмите кнопку ОК.

  2. В дереве консоли найдите и щелкните следующий раздел реестра: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. В панели сведений щелкните правой кнопкой мыши параметр реестра LdapRequestTimeLimit. Установите значение 600.

  4. Другой вариант: в панели сведений щелкните правой кнопкой мыши значение реестра LdapRequestTimeLimit и выберите Удалить. Подтвердите удаление значения реестра, нажав кнопку Да в диалоговом окне.

  5. Перезапустите сервер Exchange.

Перед правкой реестра, а также для получения дополнительных сведений о правке реестра просмотрите статью 256986 базы знаний корпорации Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Для получения дополнительных сведений о правке реестра Microsoft Windows см. следующие статьи базы знаний корпорации Майкрософт:

  • 322755, «Создание резервной копии, изменение и восстановление реестра Windows 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, «Создание резервной копии, изменение и восстановление реестра Windows XP и Windows Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Значение SMTP-параметра LdapResultTimeout реестра, отличное от значения по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, изменено ли значение LdapResultTimeout по умолчанию, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Если анализатор сервера Exchange обнаружит, что параметр LdapResultTimeout реестра создан вручную и изменена двоичная настройка сервера Exchange по умолчанию, равна 121 секунде, анализатор сервера Exchange выведет на экран предупреждение об изменении значения по умолчанию. По умолчанию параметр LdapResultTimeout реестра не создается при установке сервера Exchange. Однако параметр LdapResultTimeout реестра может быть создан вручную после установки сервера Exchange для изменения значения тайм-аута. LdapResultTimeout — это максимальное время в секундах, в течение которого потоки завершения LDAP для LDAP-подключений классификатора ожидают обработки. Если тайм-аут истекает и с сервера глобального каталога не получены новые результаты, ожидающие операции поиска для подключения завершаются ошибкой с LDAP_SERVER_DOWN. Затем данный процесс запускает повтор этих операций поиска, находящихся в состоянии ожидания, для новых подключений. Если параметр реестра создан вручную, и настройка значения параметра реестра выполнена неправильно, для сервера Exchange могут возникать неполадки транспорта сообщений.

Рекомендуется создавать и изменять значение параметра LdapResultTimeout реестра только после проведения серьезного анализа сложившихся условий. Значения по умолчанию в двоичных файлах для сервера Exchnage были тщательно выбраны, чтобы обеспечить оптимальную производительность в большинстве рабочих сред сервера Exchange. Общая рекомендация — устранять основную причину проблемы вместо изменения поведения по умолчанию приложения Exchange путем настройки реестра вручную. Если параметр LdapResultTimeout реестра существует, то для выполнения рекомендаций, возможно, потребуется удалить этот параметр реестра, чтобы вернуть сервер Exchange к двоичным настройкам по умолчанию.

Анализатор сервера Exchange сообщает об этой конфигурации исключительно в информационных целях. Однако может возникнуть желание изменить параметр реестра, чтобы вернуть настройку по умолчанию путем изменения реестра.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы устранить причину появления этого предупреждения

  1. Нажмите кнопку Пуск, выберите команду Выполнить, введите Regedit и нажмите кнопку ОК.

  2. В дереве консоли найдите и затем щелкните следующий раздел реестра: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. В области сведений щелкните правой кнопкой мыши параметр LdapResultTimeout реестра. Измените значение, установив его равным 121.

  4. Дополнительно в области сведений можно щелкнуть правой кнопкой мыши параметр LdapResultTimeout реестра и выбрать в контекстном меню команду Удалить. Подтвердите удаление параметра реестра, щелкнув Да в диалоговом окне.

  5. Перезапустите сервер Exchange.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об изменении реестра Microsoft Windows см. в следующих статьях базы знаний Майкрософт:

  • Статья 322755, содержащая инструкции по резервному копированию, изменению и восстановлению реестра в Windows 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755).

  • Статья 322756, содержащая инструкции по резервному копированию, изменению и восстановлению реестра в Windows XP и Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756).


Значение реестра MaxConnectionRetries для SMTP не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, изменено ли значение MaxConnectionRetries, анализатор сервера Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Если анализатор сервера Exchange обнаружит, что значение реестра MaxConnectionRetries было создано вручную с помощью изменения двоичного параметра 20 сервера Exchange по умолчанию, анализатор сервера Exchange отображает сообщение о нестандартной конфигурации. По умолчанию значение параметра реестра MaxConnectionRetries не создается во время установки сервера Exchange. Однако значение реестра MaxConnectionRetries можно создать вручную после установки сервера Exchange для необходимого изменения значения. С помощью значения MaxConnectionRetries можно установить максимальное количество сбоев подключений LDAP и установки новых подключений для отдельной классификации. После сбоев подключения классификации, равном количеству MaxConnectionRetries, оно помещается в очередь повтора. Если значение реестра создано вручную и этот параметр настроен неверно, на сервере Exchange могут возникнуть неполадки с транспортировкой сообщений.

Рекомендуется создавать и изменять значение реестра MaxConnectionRetries только после учета всех последствий. Значения по умолчанию двоичных параметров сервера Exchange были тщательно выбраны для оптимальной производительности в большинстве сред серверов Exchange. Рекомендуется искать основную причину неполадок, а не изменять поведение по умолчанию сервера Exchange с помощью настройки реестра. Чтобы следовать этим рекомендациям, может понадобиться удалить раздел реестра MaxConnectionRetries, если он существует, чтобы вернуть сервер Exchange к двоичным параметрам по умолчанию.

Анализатор сервера Exchange отображает эту конфигурацию только для сведений. Однако можно изменить раздел реестра на значение по умолчанию.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы устранить причину появления этого предупреждения

  1. Нажмите кнопку Пуск, выберите команду Выполнить, введите Regedit и нажмите кнопку ОК.

  2. В дереве консоли найдите и щелкните следующий раздел реестра: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. В области сведений щелкните правой кнопкой мыши значение реестра MaxConnectionRetries. Измените значение на 20.

  4. Также в области сведений можно щелкнуть правой кнопкой мыши значение реестра MaxConnectionRetries, затем щелкнуть Удалить. Подтвердите удаление значения реестра, нажав кнопку Да в диалоговом окне.

  5. Перезапустите сервер Exchange.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке). (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)

Дополнительные сведения об изменении реестра Microsoft Windows см. в следующих статьях базы знаний Майкрософт:

  • статья 322755, описывающая инструкции по резервному копированию, изменению и восстановлению реестра в Windows 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755);

  • статья 322756, описывающая инструкции по резервному копированию, изменению и восстановлению реестра в Windows XP и Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756).


Значение реестра «SMTP MaxLdapConnections» отличается от заданного по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, был ли изменен параметр MaxLdapConnections, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Если анализатор сервера Exchange обнаруживает, что значение реестра MaxLdapConnections было создано вручную, изменив двоичное значение 8, определенное для сервера Exchange по умолчанию, анализатор сервера Exchange выводит предупреждение о том, что конфигурация не является конфигурацией по умолчанию. По умолчанию значение реестра MaxLdapConnections в процессе установки Exchange не создается. Но после установки Exchange значение реестра MaxLdapConnections может быть создано вручную, чтобы изменить значение по умолчанию. Значение MaxLdapConnections определяет максимальное количество подключений LDAP, открытых классификатором к одному глобальному серверу каталога. Если значение реестра создано вручную и определено неправильно, у сервера Exchange могут возникнуть проблемы с передачей сообщений.

Внимание!
Значение параметра реестра MaxLdapConnections всегда должно соответствовать значению параметра реестра HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters\MaxPoolThreads.

Рекомендуется создавать или изменять значение реестра MaxLdapConnections только после тщательного анализа. Значения по умолчанию в двоичных файлах сервера Exchange тщательно подобраны для оптимальной производительности в большинстве сред серверов Exchange. Общая рекомендация состоит в том, чтобы устранять корневые причины проблемы, а не менять стандартное поведение сервера Exchange путем ручной настройки реестра. Если значение реестра MaxLdapConnections существует, может понадобиться удалить это значение реестра, чтобы возвратить настройки реестра Exchange к стандартным настройкам двоичных файлов и выполнить рекомендации.

Анализатор сервера Exchange выводит отчет об этой конфигурации только для сведения. Но можно также изменить это значение реестра на значение по умолчанию, редактируя реестр.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.
Устранение причины появления этого предупреждения

  1. Нажмите кнопку Пуск, выберите команду Выполнить, введите Regedit и нажмите кнопку ОК.

  2. В дереве консоли найдите и щелкните следующий раздел реестра: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. В области сведений щелкните правой кнопкой мыши значение реестра MaxLdapConnections. Измените значение на 8.

  4. Дополнительно в области сведений можно щелкнуть правой кнопкой мыши значение реестра MaxLdapConnections, а затем щелкнуть Удалить. Подтвердите удаление значения реестра, нажав кнопку Да диалогового окна.

  5. Перезапустите сервер Exchange.

Перед началом редактирования реестра для получения сведений о выполнении этой процедуры изучите статью 256986 базы знаний Майкрософт, содержащую описание реестра Microsoft Windows (возможно, на английском языке). (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

Дополнительные сведения о редактировании реестра Microsoft Windows см. в следующих статьях базы знаний Майкрософт:

  • 322755, посвященная резервному копированию, редактированию и восстановлению реестра Windows 2000, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755 (возможно, на английском языке)

  • 322756, посвященная резервному копированию, редактированию и восстановлению реестра Windows XP и Windows Server 2003, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756 (возможно, на английском языке)


Значение реестра SMTP MaxPendingSearches отличается от заданного по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, изменялся ли параметр MaxPendingSearches, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Если анализатор сервер Exchange обнаруживает, что значение реестра MaxPendingSearches было создано вручную, и установленное по умолчанию для двоичного файла Exchange значение 60 изменено, анализатор сервера выводит предупреждение о том, что конфигурация не является конфигурацией по умолчанию. По умолчанию значение реестра MaxPendingSearches при установке сервера Exchange не создается. Но значение реестра MaxPendingSearches можно создать вручную после установки сервера Exchange, чтобы изменить значение по умолчанию. Значение MaxPendingSearches определяет количество LDAP-поисков на конкретном сервере глобального каталога, одновременно поддерживаемое классификатором. Максимальное количество ожидающих поисков на подключение для Exchange 2000 Server с пакетом обновления до SP3 равнялось 1024. Значение по умолчанию для Exchange 2000 Server SP3 и Exchange Server 2003 равно 60. Например, изменение этого значения с 60 до 30 уменьшает общее количество LDAP-поисков на сервере глобального каталога, поддерживаемое классификатором.

Если значение реестра создано вручную и неправильно определено, сервер Exchange может столкнуться с проблемами передачи сообщений.

Рекомендуется создавать или изменять значение реестра MaxPendingSearches только после тщательного анализа. Значения по умолчанию в двоичных файлах сервера Exchange тщательно подобраны для оптимальной производительности в большинстве сред серверов Exchange. Общая рекомендация состоит в том, чтобы устранять корневые причины проблемы, а не менять стандартное поведение сервера Exchange путем ручной настройки реестра. В соответствии с рекомендациями, если значение реестра MaxPendingSearches существует, может понадобиться удалить это значение реестра, возвратить сервер Exchange к использованию стандартных настроек двоичных файлов.

Анализатор сервера Exchange выводит отчет об этой конфигурации только для сведения. Но можно также изменить это значение реестра на значение по умолчанию, редактируя реестр.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.
Устранение причины появления этого предупреждения

  1. Нажмите кнопку Пуск, выберите команду Выполнить, введите Regedit и нажмите кнопку ОК.

  2. В дереве консоли найдите и щелкните следующий раздел реестра: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. В области сведений щелкните правой кнопкой мыши значение реестра MaxPendingSearches. Измените значение на 60.

  4. Либо в области сведений можно щелкнуть правой кнопкой мыши значение реестра MaxPendingSearches, а затем выбрать команду Удалить. Подтвердите удаление значения реестра, нажав кнопку Да диалогового окна.

  5. Перезапустите сервер Exchange.

Перед началом редактирования реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт, содержащую описание реестра Microsoft Windows, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986 (возможно, на английском языке).

Дополнительные сведения о редактировании реестра Microsoft Windows см. в следующих статьях базы знаний Майкрософт:

•322755, посвященная резервному копированию, изменению и восстановлению реестра в Windows 2000, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755 (возможно, на английском языке);

•322756, посвященная резервному копированию, изменению и восстановлению реестра в Windows XP и Windows Server 2003, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756 (возможно, на английском языке).


Значение реестра MaxSearchBlockSize для SMTP не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, изменено ли значение MaxSearchBlockSize, анализатор сервера Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Если анализатор сервера Exchange обнаружит, что значение реестра MaxSearchBlockSize было создано вручную, изменив двоичный параметр 20 сервера Exchange по умолчанию, анализатор сервера Exchange отображает сообщение о нестандартной конфигурации. По умолчанию значение параметра реестра MaxSearchBlockSize не создается во время установки сервера Exchange. Однако значение реестра MaxSearchBlockSize можно создать вручную после установки сервера Exchange для необходимого изменения значения. С помощью значения MhelpsBlockSize можно установить максимальное количество сеансов поиска классификатора, которые могут быть начаты или одновременно, или в качестве одного поиска LDAP. Установив максимальное количество сеансов поиска классификатора, можно упростить фильтры поиска в классификаторе.

С помощью этого процесса можно использовать ожидающие сеансы поиска на новых подключениях. Если значение реестра создано вручную и этот параметр настроен неверно, на сервере Exchange могут возникнуть неполадки с транспортировкой сообщений.

Рекомендуется создавать и изменять значение реестра MaxSearchBlockSize только после учета всех последствий. Значения по умолчанию двоичных параметров сервера Exchange были тщательно выбраны для оптимальной производительности в большинстве сред серверов Exchange. Рекомендуется искать основную причину неполадок, а не изменять поведение по умолчанию сервера Exchange с помощью настройки реестра. Чтобы следовать этим рекомендациям, может понадобиться удалить раздел реестра MaxSearchBlockSize, если он существует, чтобы вернуть сервер Exchange к двоичным параметрам по умолчанию.

Анализатор сервера Exchange отображает эту конфигурацию только для сведений. Однако можно изменить раздел реестра на значение по умолчанию.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы устранить причину появления этого предупреждения

  1. Нажмите кнопку Пуск, выберите команду Выполнить, введите Regedit и нажмите кнопку ОК.

  2. В дереве консоли найдите и щелкните следующий раздел реестра: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. В области сведений щелкните правой кнопкой мыши значение реестра MaxSearchBlockSize. Измените значение на 20.

  4. Также в области сведений можно щелкнуть правой кнопкой мыши значение реестра MaxSearchBlockSize, затем щелкнуть Удалить. Подтвердите удаление значения реестра, нажав кнопку Да в диалоговом окне.

  5. Перезапустите сервер Exchange.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об изменении реестра Microsoft Windows см. в следующих статьях базы знаний Майкрософт:

  • 322755, описывающая инструкции по резервному копированию, изменению и восстановлению реестра в Windows 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755);

  • 322756, описывающая инструкции по резервному копированию, изменению и восстановлению реестра в Windows XP и Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756).


Значение реестра SMTP TopoRecheckSecs отличается от заданного по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange проверяет изменение заданного по умолчанию значения в следующем разделе реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\TopoRecheckSecs.

Если анализатор сервера Exchange обнаруживает, значение раздела TopoRecheckSecs не соответствует значению по умолчанию, которое равно 900 секундам, выводится сообщение о том, что конфигурация отличается заданной по умолчанию. Анализатор сервера Exchange выводит отчет об этой конфигурации только для сведения. Не требуется выполнять каких-либо действий. Поскольку значение реестра TopoRecheckSecs используется в DSAccess для определения интервала времени, с которым перестраивается список глобального каталога, неверная настройка этого параметра может привести к снижению быстродействия. Рекомендуется использовать для сервера Exchange параметры конфигурации по умолчанию. Однако при наличии этого значения реестра его можно добавить и настроить в соответствии с рекомендациями службы поддержки продуктов Майкрософт, чтобы устранить возникшую ранее проблему. Рекомендуется обдумать возможность удаления данного значения реестра, если только оно не добавлено и настроено в соответствии с рекомендациями службы поддержки продуктов Microsoft или другой экспертной организации.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.
Чтобы удалить раздел реестра TopoRecheckSecs

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess

  3. В правой области найдите и удалите значение TopoRecheckSecs.

  4. Закройте редактор реестра.

  5. Чтобы сохранить внесенное изменение, перезапустите системный помощник.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт "Description of the Microsoft Windows Registry" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения об оптимизации размещения глобального каталога для сервера Exchange см. в материале Understanding and Troubleshooting Directory Access (http://go.microsoft.com/fwlink/?LinkId=39012) (Общее представление о доступе к каталогам и устранение возможных неполадок).


Сервер шлюза, отличный от Exchange, не установлен в качестве промежуточного узла
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-08-09

Средство анализатора сервера Microsoft® Exchange запрашивает в службе каталогов Active Directory® значение атрибута distingushedName класса объекта protocolCfgSMTPServer, чтобы вывести список всех экземпляров виртуального SMTP-сервера (Simple Mail Transfer Protocol) на указанном пользователем шлюзе Exchange.

Затем анализатор сервера Exchange запрашивает в службе Active Directory значения атрибутов msExchSourceBridgeheadServersDN и routingList для каждого найденного объекта msExchRoutingSMTPConnector, чтобы определить, правильно ли установлен для SMTP-соединителя один из обнаруженных экземпляров виртуального SMTP-сервера в качестве его локального плацдарма для пространства внешних SMTP-адресов.

Наконец, анализатор сервера Exchange запрашивает в службе Active Directory значение атрибута msExchSmtpSmartHost для всех обнаруженных SMTP-соединителей (объект msExchRoutingSMTPConnector), чтобы определить, не назначен ли один из них в качестве промежуточного узла для указанного пользователем сервера шлюза, отличного от Exchange.

Если анализатор сервера Exchange определит, что указанный пользователем сервер шлюза, отличного от Exchange, не установлен в качестве промежуточного узла для одного из SMTP-соединителей, на экран будет выведено предупреждение.

Это предупреждение означает, что не существует установленного явного маршрута от указанного пользователем сервера шлюза Exchange до заданного пользователем сервера шлюза, отличного от Exchange, и что серверы, отличные от шлюза, не относящегося к Exchange, могут ненамеренно направлять сообщения за пределы организации.

Чтобы устранить эту проблему, назначьте сервер шлюза, отличного от Exchange, в качестве промежуточного узла для SMTP-соединителя.

Чтобы просмотреть и изменить параметры промежуточного узла

  1. Откройте диспетчер Exchange.

  2. Разверните узел Серверы, затем разверните сервер Exchange, Протоколы и SMTP.

  3. Щелкните правой кнопкой мыши виртуальный сервер SMTP, например Виртуальный сервер SMTP по умолчанию, и выберите команду Свойства.

  4. Выберите вкладку Доставка, а затем щелкните Дополнительно.

  5. Введите промежуточный узел, который необходимо использовать. Можно определить промежуточный узел, используя полное доменное имя или IP-адрес. Если используется IP-адрес, необходимо заключить его в квадратные скобки ([ ]). Сначала Exchange проверяет имя сервера, затем IP-адрес. Квадратные скобки идентифицируют значение как IP-адрес. Поэтому поиск в службе DNS пропускается.

  6. Если это сервер, на котором выполняется приложение Exchange 2000 Server, можно дополнительно установить флажок Попытка прямой доставки до отправки на промежуточный узел.

  7. Нажмите кнопку ОК, чтобы сохранить изменения, затем щелкните ОК, чтобы закрыть диалоговое окно Свойства виртуального SMTP-сервера.

Дополнительные сведения о настройке соединителя промежуточных узлов см. в базе знаний Майкрософт, в статье 821911, содержащей инструкции по настройке Exchange Server 2003 для использования IP-адресов промежуточных узлов (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821911).

Дополнительные сведения об использовании SMTP-соединителей см. в базе знаний Майкрософт, в статье 294736, описывающей, в каких случаях создаются SMTP-соединители в Exchange 2000 и более поздних версиях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=294736).

Дополнительные сведения о SMTP-соединителях см. в руководстве по транспорту и маршрутизации в Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=47579.


Возможна перегрузка классификатора
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-09-06

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные категории: «переданные сообщения/сек» и категории: счетчики производительности «завершенные классификации/сек» объекта быстродействия SMTP Server для анализа данных производительности.

Категория: счетчик производительности «переданные сообщения/сек» показывает количество сообщений, передаваемых за секунду в классификатор, тогда как категория: «завершенные классификации/сек» показывает частоту классификаций, выполняемых за секунду.

Анализатор сервера Exchange сравнивает общие средние значения двух счетчиков, чтобы определить, отправляется ли сообщений больше, чем обрабатывается.

Если анализатор сервера Exchange определит, что общее среднее количество сообщений, передаваемых за секунду в классификатор, устойчиво больше на два сообщения, чем общее среднее количество сообщений, обрабатываемых за секунду, на экран выводится предупреждение.

Классификатор выполняет следующие основные операции:

  • Разрешает и проверяет достоверность всех получателей.

  • Определяет пределы и ограничения для всех получателей.

  • При необходимости расширяет списки рассылки.

  • Определяет, предназначено ли сообщение для локальной или удаленной доставки.

Это предупреждение указывает, что классификатор может находиться под повышенной нагрузкой. Там, где такая ситуация может возникать, возможные причины должны быть проанализированы и устранены.

Повышенная нагрузка на классификатор может быть вызвана необходимостью обработки многих сообщений по следующим причинам:

  • Нежелательная коммерческая электронная почта или ненужные сообщения.

  • Распространение вирусов.

  • Проблемы с быстродействием сервера.

Чтобы устранить причины появления этого предупреждения, выполните следующие действия:

  • Определите, является ли нагрузка на классификатор ожидаемой или типовой. Если напряжение в работе классификатора создает ожидаемая нагрузка, ознакомьтесь с рекомендациями по управлению производительностью Exchange в следующих статьях Microsoft TechNet.

    • Статья, посвященная исправлению неполадок, связанных с производительностью сервера Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).

    • Руководство по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Если источником напряжения в работе классификатора не является ожидаемая нагрузка, проверьте систему на наличие вирусов и нежелательной почты, которые могут создать дополнительную нагрузку.


Возможна проблема со шлюзом
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-08-09

Средство анализатора сервера Microsoft® Exchange посылает тестовое сообщение на внешнюю учетную запись, определяемую пользователем, с сервера, на котором выполняется сервер Exchange. Затем анализатор сервера Exchange сканирует на сервере журналы отслеживания сообщений, чтобы определить, были ли обнаружены какие-либо проблемы с доставкой тестового сообщения.

В качестве части процесса сканирования анализатор сервера Exchange запрашивает свойство EntryType WMI-класса (Microsoft Windows® Management Instrumentation) Exchange_MessageTrackingEntry в пространстве имен root\MicrosoftExchangeV2, чтобы определить причины появления записей в журнале отслеживания сообщений.

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Журнал отслеживания сообщений может успешно сканироваться.

  • Тестовое сообщение не было успешно передано из очереди.

  • Не был создан отчет о недоставке (NDR).

  • Для свойства EntryType существует значение 1034.

  • Сообщение достигло указанного сервера шлюза Exchange исходящих сообщений.

Эта ошибка может указывать на наличие проблемы соединения между заданным пользователем локальным сервером шлюза Exchange исходящих сообщений и удаленным сервером.

Чтобы устранить эту ошибку, используйте служебную программу NSlookup для просмотра возможных проблем разрешения имен службой DNS (Domain Name System). Для устранения проблем, связанных с подключением и протоколом, например ошибки типа «Узел недостижим», используйте Telnet.exe, чтобы подключиться к целевому компьютеру. Чтобы устранить ошибки протоколов, повысьте уровень диагностики службы MSExchangeTransport для компонента SMTP (Simple Mail Transfer Protocol), а затем просмотрите журналы на наличие ошибок. Также можно использовать средство «Сетевой монитор» (Netmon.exe) для получения сведений об ошибках сетевых подключений.

Дополнительные сведения об изменении параметров ведения журнала см. в описании изменения параметров ведения журнала для MSExchangeTransport в разделе, посвященном устранению неполадок почтового потока и протокола SMTP, в Руководстве по маршрутизации и транспортировке сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).

Дополнительные сведения об устранении проблем, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел по устранению проблем, связанных с потоком почты и протоколом SMTP в Руководстве по транспортировке и маршрутизации сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).

  • База знаний Майкрософт, статья 823489, описывающая использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • База знаний Майкрософт, статья 821877, содержащая описание полей на вкладках свойств очередей SMTP и X.400 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • База знаний Майкрософт, статья 264054, содержащая общие сведения о состояниях очередей в Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Возможна проблема с Inetinfo
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-09-06

Средство анализатора сервера Microsoft® Exchange содержит модуль сбора данных о производительности, используемый для запроса объектов счетчика производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003. Модуль сбора данных о производительности собирает данные категории: счетчик производительности «выполняющиеся классификации» объекта быстродействия SMTP Server для анализа данных производительности.

Категория: счетчик «выполняющиеся классификации» показывает количество классификаций, находящихся в стадии выполнения.

Для данного запроса анализатор сервера Exchange получает сведения каждые 6 секунд в течение двух минут. Затем анализатор сервера Exchange сообщает среднее значение счетчика производительности, достигаемое в течение интервала сбора данных.

Если анализатор сервера Exchange определит, что минимальное количество выполняющихся классификаций в течение интервала выборки данных никогда не равно нулю, на экран будет выведено предупреждение.

Классификатор выполняет следующие основные операции:

  • Разрешает и проверяет достоверность всех получателей.

  • Определяет пределы и ограничения для всех получателей.

  • При необходимости расширяет списки рассылки.

  • Определяет, предназначено ли сообщение для локальной или удаленной доставки.

Если сервер не подвергается большой нагрузке, это предупреждение может указывать на блокировку процесса Inetinfo.exe или ресурсов, от которых зависит процесс Inetinfo.exe.

Служба SMTP (Simple Mail Transfer Protocol) выполняется в процессе Inetinfo.exe и когда сообщения проходят через транспортную подсистему, SMTP интенсивно использует ресурсы IIS (Internet Information Services).

Блокировка возникает, когда каждый из двух или более процессов (или потоков) ожидает завершения другого процесса, прежде чем он сможет продолжить работу. В результате все процессы (или потоки) прекращают отвечать (зависают). Во время блокировки процессы никогда не завершают свое выполнение, и системные ресурсы остаются занятыми. Это препятствует запуску других заданий.

Чтобы устранить причины появления этого предупреждения, выполните следующие действия:

  • Определите, оказывается ли воздействие на классификатор со стороны ожидаемой или типовой нагрузки. Если классификатор не находится под большой нагрузкой, используйте ресурсы, упоминаемые в разделе «Дополнительные сведения», для идентификации возможных проблем производительности, связанных с процессом Inetinfo.exe или соответствующими ресурсами.

  • Проверьте, выполняется ли процесс Inetinfo.exe.

  • Проверьте наличие блокировки процесса Inetinfo.exe, выполнив инструкции по отладке, содержащиеся в базе знаний Майкрософт, в статье 919791, описывающей использование диагностического средства отладки для устранения причин активного использования процессора процессом службы IIS (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=919791).

Дополнительные сведения

Дополнительные сведения о процессе Inetinfo.exe см. в разделе, посвященном службам IIS, в техническом справочнике по Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=72966).

Дополнительные сведения об устранении взаимоблокировки см. в базе знаний Майкрософт, в статье 919791, описывающей использование диагностического средства отладки для устранения причин активного использования процессора процессом службы IIS (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=919791).

Дополнительные сведения о быстродействии сервера Exchange см. в руководстве по управлению производительностью и масштабируемостью Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

Дополнительные сведения об устранении проблем производительности сервера Exchange см. в описании процедур устранения неполадок, связанных с производительностью сервера Microsoft Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).


Возможна проблема, не связанная со шлюзом
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-08-09

Средство анализатора сервера Microsoft® Exchange посылает тестовое сообщение на определяемый пользователем SMTP-адрес внешнего получателя с сервера, на котором выполняется сервер Exchange. Затем анализатор сервера Exchange сканирует на сервере журналы отслеживания сообщений, чтобы определить, были ли обнаружены какие-либо проблемы с доставкой тестового сообщения.

В качестве части процесса сканирования анализатор сервера Exchange запрашивает свойство EntryType WMI-класса (Microsoft Windows® Management Instrumentation) Exchange_MessageTrackingEntry в пространстве имен root\MicrosoftExchangeV2, чтобы определить причины появления записей в журнале отслеживания сообщений.

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Журнал отслеживания сообщений может успешно сканироваться.

  • Тестовое сообщение не было успешно передано из очереди.

  • Не был создан отчет о недоставке.

  • Для свойства EntryType существует значение 1034.

  • Сообщение не достигло указанного локального сервера шлюза исходящих сообщений Exchange.

Эта ошибка может указывать, что тестовое сообщение все еще находится в одной из SMTP-очередей удаленной доставки отправляющего сервера, и в работе этой очереди возникла ошибка.

Очередь удаленной доставки содержит сообщения, предназначенные для удаленной доставки. Имя очереди соответствует месту назначения удаленной доставки. Таким местом назначения может быть соединитель, сервер или домен.

Чтобы устранить ошибки протоколов, повысьте уровень диагностики службы MSExchangeTransport для компонента SMTP, а затем просмотрите журналы на наличие ошибок. Также можно использовать средство «Сетевой монитор» (Netmon.exe) для получения сведений об ошибках сетевых подключений. Для воспроизведения проблемы, возможно, понадобится снова запустить очередь. Необходимо проверить наличие в журнале событий возможных ошибок, связанных со службой банка данных Microsoft Exchange.

Для получения дополнительных сведений об изменении параметров ведения журнала см. описание изменения параметров ведения журнала для MSExchangeTransport в разделе, посвященном устранению неполадок почтового потока и протокола SMTP, в Руководстве по маршрутизации и транспортировке сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).

Дополнительные сведения об устранении проблем, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел по устранению проблем, связанных с потоком почты и протоколом SMTP в Руководстве по транспортировке и маршрутизации сервера Exchange (http://go.microsoft.com/fwlink/?LinkId=47579).

  • База знаний Майкрософт, статья 823489, описывающая использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • База знаний Майкрософт, статья 821877, содержащая описание полей на вкладках свойств очередей SMTP и X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • База знаний Майкрософт, статья 264054, содержащая общие сведения о состояниях очередей в Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Возможно, обнаружен прокси-сервер SMTP
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-12-06

Средство анализатора сервера Microsoft® Exchange пытается отправить сообщение учетной записи администратора или пользовательской учетной записи в домен SMTP.

Когда анализатор сервера Exchange открывает подключение через сокет к SMTP-серверу, ожидается по умолчанию получение следующего ответа:

«220 Имя компьютера. Имя домена .com Служба Microsoft ESMTP MAIL, Версия: Номер версии готовый, на Дату Время +0000».

Если анализатор сервера Exchange получает ответ, отличный от ответа по умолчанию, который содержит строку, относящуюся к третьей стороне, на экран выводится сообщение об ошибке.

Эта ошибка указывает, что возможно существование прокси-сервера SMTP третьей стороны, который работает под защитой удаленного сервера.

Если заголовок SMTP по умолчанию не был специально изменен администратором сервера Exchange, это предупреждение может означать, что сервер Exchange расположен за прокси-сервером SMTP, фильтрующим ESMTP-команды (Extended Simple Mail Transfer Protocol) сервера Exchange.

Фильтрация ESMTP-команд сервера Exchange может заметно влиять на производительность Exchange и привести к поведению, описанному в статье 320027 базы знаний Майкрософт, посвященной невозможности отправки или получения сообщений электронной почты за брандмауэром Cisco PIX (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027).

Дополнительные сведения о настраиваемых заголовках SMTP см. в следующей статье базы знаний Майкрософт:

  • 281224: «XCON: изменение заголовков SMTP» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=281224 (эта ссылка может указывать на содержимое полностью или частично на английском языке).


Потенциальная проблема с производительностью классификатора
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-09-06

Средство анализатора сервера Microsoft® Exchange запрашивает в WMI-классе ExchangeLink значение атрибута TypePendingCategorization экземпляра ProtocolName протокола SMTP (Simple Mail Transfer Protocol), чтобы определить количество сообщений в SMTP-очереди «Сообщения, ожидающие просмотра каталога» (Messages Awaiting Directory Lookup, MADL).

Свойства WMI-класса ExchangeLink возвращают сведения о связях (очередях) обработки сообщений между почтовыми серверами. Связь может содержать ноль или более объектов ExchangeQueue. Это количество зависит от текущего трафика сообщений по текущему каналу связи.

Анализатор сервера Exchange также содержит модуль сбора данных о производительности, который используется для запроса объектов счетчиков производительности на компьютерах, на которых выполняется приложение Exchange 2000 Server или Exchange Server 2003.

Если анализатор сервера Exchange определит, что в текущий момент существует более пятидесяти сообщений в очереди «Сообщения, ожидающие просмотра каталога» (MADL), анализатор сервера Exchange использует модуль сбора данных о производительности, чтобы собрать данные следующей категории: классифицированные сообщения и категории: счетчики производительности «завершенные классификации» объекта быстродействия SMTP Server для анализа данных производительности.

Категория: счетчик производительности «классифицированные сообщения» показывает количество сообщений, переданных классификатором в очередь, тогда как категория: счетчик производительности «завершенные классификации» показывает общее количество переданных в классификатор сообщений, классификация которых завершена.

Классификатор выполняет следующие основные операции:

  • Разрешает и проверяет достоверность всех получателей.

  • Определяет пределы и ограничения для всех получателей.

  • При необходимости расширяет списки рассылки.

  • Определяет, предназначено ли сообщение для локальной или удаленной доставки.

Анализатор сервера Exchange проверяет общие средние значения двух счетчиков, чтобы определить, увеличиваются ли их показания в течение периода выборки значений.

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • В очереди «Сообщения, ожидающие просмотра каталога» (MADL) находится пятьдесят или более сообщений.

  • Категория: счетчик производительности «классифицированные сообщения» показывает рост значений в течение периода выборки, что указывает на успех передачи отправленных сообщений в следующий процесс.

  • Категория: счетчик производительности «завершенные классификации» показывает рост показаний в течение периода выборки значений, что указывает на продвижение в успешном завершении классификации переданных сообщений.

Данная ошибка означает, что, хотя классификатор успешно обрабатывает сообщения, длина его очереди остается большой и, возможно, производительность работы ухудшилась.

Повышенная нагрузка на классификатор может быть вызвана необходимостью обработки многих сообщений по следующим причинам:

  • Нежелательная коммерческая электронная почта или ненужные сообщения.

  • Распространение вирусов.

  • Проблемы с быстродействием сервера.

Чтобы устранить причины появления этого предупреждения, выполните следующие действия:

  • Определите, является ли нагрузка на классификатор ожидаемой или типовой. Если напряжение в работе классификатора создает ожидаемая нагрузка, ознакомьтесь с рекомендациями по управлению производительностью Exchange в следующих ресурсах по Exchange:

    • Статья, посвященная устранению проблем с производительностью сервера Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47588).

    • Руководство по производительности и масштабируемости Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Если источником напряжения в работе классификатора не является ожидаемая нагрузка, проверьте систему на наличие вирусов и нежелательной почты, которые могут создать дополнительную нагрузку.


Обнаружены потенциальные проблемы расширения группы рассылки
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Средство анализатора сервера Microsoft® Server считывает параметр реестра, чтобы определить, установлен ли на сервере Exchange пакет обновления 2 (SP2) для Exchange Server 2003 и настроен ли он для расширения групп рассылки при проверке ограничений доставки:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

  • Значение 1 для этого параметра означает, что сервер настроен для расширения групп рассылки при проверке ограничений доставки.

  • Значение 2 для этого параметра указывает, что настройка сервера не предусматривает расширение групп рассылки при проверке ограничений доставки.

Если анализатор сервера Exchange Server обнаружит, что сервер настроен для расширения групп рассылки при проверке ограничений доставки, то проверяет журналы событий сервера, чтобы выявить, не происходили ли события ошибок (всех включительно) 6004, 6006 и 6008 за последние 24 часа.

Эти события свидетельствуют о том, что сообщения захватываются классификатором сообщений. Классификатор сообщений является компонентом усовершенствованного модуля очередей, который отправляет LDAP-запросы серверу глобального каталога для выполнения просмотров каталога.

Наконец, анализатор сервера Exchange Server запрашивает службу каталогов Active Directory®, чтобы определить следующие моменты:

  • Имеется ли более 500 почтовых ящиков в лесу, для которого имеются ограничения доставки, определенные таким образом, что по крайней мере одна группа рассылки используется для разрешения либо для запрещения отправителей.

  • Имеются ли для соединителя групп маршрутизации ограничения доставки, основанные на членстве в группе рассылки, и включена ли для сервера-плацдарма проверка ограничений соединителя.

  • Имеются ли для соединителя SMTP ограничения доставки, основанные на членстве в группах рассылки, и включена ли для сервера-плацдарма проверка ограничений соединителя.

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Сервер с пакетом обновления 2 (SP2) для Exchange Server 2003 настроен для расширения групп рассылки при проверке ограничений доставки.

  • Сервер Exchange занес события ошибок 6004, 6006 и 6008 за последние 24 часа.

  • Имеется более 500 почтовых ящиков в лесу, для которого имеются ограничения доставки, определенные таким образом, что по крайней мере одна группа рассылки используется для разрешения либо для запрещения отправителей, либо для соединителя групп маршрутизации имеются ограничения доставки, основанные на членстве в группе рассылки, и для сервера-плацдарма включена проверка ограничений соединителя, либо для соединителя SMTP имеются ограничения доставки, основанные на членстве в группах рассылки, и для сервера-плацдарма включена проверка ограничений соединителя.

Значение RestrictionMethod определяет, каким образом классификатор будет обрабатывать ограничения. Поведение классификатора по умолчанию состоит в рекурсивном расширении групп рассылки и проверке ограничений для каждого сообщения, проходящего через систему. Когда сообщение электронной почты отправляется получателю, который имеет ограничение, блокирующее сообщения для членов конкретной группы рассылки или группы безопасности, сервер Exchange Server должен расширить эту группу, чтобы гарантировать, что отправитель не является членом группы, на которую наложено указанное ограничение. Результаты расширения этой группы не кэшируются сервером Exchange Server и должны выполняться заново каждый раз. Это может привести к задержке в очередях классификатора, в результате чего их обработка задерживается.

Если установить для RestrictionMethod значение 2, компоненты транспорта сервера Exchange не будут расширять группы рассылки, когда сервер выполнят проверку ограничений. Данная настройка обеспечивает наилучшую производительность при выполнении проверок ограничений. Кроме того, чтобы параметр реестра RestrictionMethod смог оказать свое воздействие, необходимо, чтобы все группы рассылки, включающие пользователей, которые имеют ограничения доставки, были плоскими. Это означает, что группы рассылки, на которые наложены ограничения, не должны иметь вложенных групп рассылки. Логика расширения не будет работать, если группы рассылки, на которые наложены ограничения, будут иметь вложенные группы рассылки.

Для групп рассылки, используемых в ограничениях соединителя, рекомендуется задать значение параметра реестра RestrictionMethod на сервере-плацдарме соединителя, не имеющем почтовых ящиков. Если группы рассылки, на которые наложены ограничения, имеют серверы расширения, то для ограничений пользователей Active Directory рекомендуется создать параметр реестра RestrictionMethod на серверах расширения.

Дополнительные сведения о последствиях настройки ограничений доставки см. в базе знаний Майкрософт в статье 812298 о замедлении доставки при настройке ограничений, основанных на списке рассылки (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

Дополнительные сведения о значении реестра RestrictionMethod см. в базе знаний Майкрософт в статье 895407 о замедлении доставки сообщений в локальные и внешние почтовые ящики при использовании Exchange Server 2003 после настройки ограничений доставки, основанных на группах рассылки (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

Дополнительные сведения о событиях и ошибках Exchange Server 2003 см. на странице, посвященной центру событий и сообщений об ошибках (http://go.microsoft.com/fwlink/?LinkId=34258).

Дополнительные сведения об ограничениях соединителя см. в базе знаний Майкрософт в статье 277872, в которой описываются проблемы в работе ограничений доставки соединителя (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872).

Дополнительные сведения об очередях SMTP см. в базе знаний Майкрософт в статье 884996, посвященной проблеме задержки сообщений, ожидающих просмотра очереди SMTP, в Exchange Server 2003 или в Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=884996).


Возможные проблемы, связанные с получателем журнала сообщения
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

The Microsoft® Exchange Server Analyzer Tool направляет запрос о классе Win32_NTLogEvent Microsoft Windows® Management Instrumentation (WMI), чтобы определить, имели ли место сочетания Предупреждения классификатора/Ошибка за прошедшие 24 часа:

  • Событие 9004 и Событие 9003

  • Событие 9035 и Событие 6004

Данные события обозначают, что сообщения задерживаются в классификаторе сообщений. Классификатор сообщений является компонентом механизма постановки в очередь, отправляющим запросы атрибута LDAP на сервер глобального каталога для выполнения поиска в каталоге.

  • Средство анализа сервера Exchange также запрашивает службу каталога Active Directory®, чтобы определить, выполняется ли какое-либо из следующих условий:

  • Получатель журнала, назначенный для его хранения, указывает на удаленный объект.

  • Получатель журнала, назначенный для его хранения, указывает на объект, не имеющий mailNickname.

  • Получатель журнала, назначенный для его хранения, указывает на отключенную учетную запись.

Средство анализа Exchange Server Analyzer отображает сообщение об ошибке, если выполняются следующие условия:

  • Имеет место сочетание Предупреждение/Ошибка, описанное ранее.

  • Выполняется любое из указанных условий получателя журнала.

Данная ошибка указывает на существование возможной проблемы с журналом в среде Exchange, которая может приводить к очереди сообщений.

Для получения дополнительной информации об исправлении этой ошибки см. соответствующую статью о средстве анализа Exchange Server Analyzer, связанную с этой ошибкой:

  • Получатель службы ведения журнала указывает на удаленный объект

  • Получатель журнала недействителен

  • Получатель журнала указывает на отключенную учетную запись

  • Для получения информации о событиях и ошибках Exchange Server 2003 см. «Центр сообщений о событиях и ошибках» (http://go.microsoft.com/fwlink/?LinkId=34258).


Найдена возможная проблема с ведением журнала сообщений и службой банка данных
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Средство анализатора сервера Microsoft® Exchange опрашивает WMI-класс Win32_NTLogEvent, чтобы определить, произошло ли событие предупреждения классификатора 9004 в течение последних 24 часов.

Также анализатор сервера Exchange опрашивает WMI-класс Win32_Service, чтобы определить, запущена или остановлена служба банка данных Microsoft Exchange (MSExchangeIS). Значение, отличающееся от Работает означает, что служба MSExchangeIS остановлена.

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • На сервере зарегистрировано событие предупреждения классификатора 9003 в течение последних 24 часов.

  • Служба MSExchangeIS остановлена.

Эта ошибка указывает, что существует неполадка с ведением журнала сообщений или со службой банка данных Microsoft Exchange (Store.exe), которая могла привести к образованию очереди сообщений.

Такое может возникнуть, если выполняется одно из следующих условий:

  • Объект The объект получателя журнала был удален из службы каталогов Active Directory®.

  • Служба банка данных не запущена или была отключена на компьютере сервера Exchange, являющимся сервером-плацдармом SMTP.

  • Одно или несколько хранилищ почтовых ящиков на сервере-плацдарме SMTP были отключены.

Чтобы решить этот вопрос:

  • Убедитесь, что на сервере-плацдарме SMTP запущена и функционирует служба банка данных. Убедитесь, что хранилища почтовых ящиков на сервере-плацдарме SMTP подключены.

  • Убедитесь, что объект получателя журнала для хранилищ почтовых ящиков не был удален из службы каталогов Active Directory.

Чтобы определить получателя журнала для хранилища почтовых ящиков

  1. Откройте Системный диспетчер Exchange.

  2. Разверните узел Серверы, затем <необходимый_сервер_Exchange>, затем <группа_хранения>, щелкните правой кнопкой мыши хранилище почтовых ящиков и выберите Свойства.

  3. На вкладке Общие просмотрите учетную запись, которая появится сразу под флажком Архивировать все сообщения, отправленные или полученные почтовыми ящиками в этом хранилище. Эта учетная запись, используемая в качестве получателя журнала.

    Примечание.
    Убедитесь, что проверены получатели журналов для каждого объекта хранилища почтовых ящиков.
Чтобы назначить новый почтовый ящик пользователя в качестве получателя журнала

  1. Откройте Системный диспетчер Exchange.

  2. Разверните узел Серверы, затем <необходимый_сервер_Exchange>, затем <группа_хранения>, щелкните правой кнопкой мыши хранилище почтовых ящиков и выберите Свойства.

  3. На вкладке Общие щелкните Обзор справа от строки Архивировать все сообщения, отправленные или полученные почтовыми ящиками в этом хранилище, чтобы указать почтовый ящик в качестве почтового ящика ведения журнала.

    Примечание.
    Все сообщения ведения журналов для отправителей в этом хранилище почтовых ящиков будут отправляться на указанный почтовый ящик.

Сведения об этом вопросе см. в разделе Получатель службы ведения журнала указывает на удаленный объект.

Дополнительные сведения о событиях и ошибках Exchange Server 2003 см. на странице, посвященной центру событий и сообщений об ошибках (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=34258).

Дополнительные сведения о развертывании решения ведения журнала см. на странице, посвященной ведению журнала с помощью сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47581).


Обнаружены потенциальные проблемы с разрешениями
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Средство анализатора сервера Microsoft® Exchange опрашивает WMI-класс Win32_NTLogEvent, чтобы определить, произошли ли в течение прошедших 24 часов следующие события, связанные с ошибками сервера Exchange:

  • Событие 929.

  • Событие 9035.

  • Комбинация событий 9003, 9004 и 6004.

Событие ошибки сервера Exchange 929 может возникать из-за неправильных разрешений доступа для объектов сервера Exchange в службе каталогов Active Directory®.

События ошибок сервера Exchange 9003, 9004 и 6004 указывают, что сообщения задерживаются в классификаторе сообщений. Классификатор сообщений является компонентом расширенного механизма очередей, который отправляет LDAP-запросы (Lightweight Directory Access Protocol) на сервер глобального каталога для выполнения просмотров каталога.

Анализатор сервера Exchange также опрашивает службу каталогов Active Directory, чтобы определить, указывают ли атрибуты объектов, связанных с Exchange, на наличие проблем с разрешениями для этих объектов.

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Регистрация одного из следующих событий или комбинации событий за последние 24 часа в журнале на сервере, имеющем сообщения в очереди Сообщения, ожидающие просмотра каталога:

    • Событие 929.

    • Событие 9035.

    • Комбинация событий 9003, 9004 и 6004.

  • У объектов, связанных с Exchange, отсутствуют разрешения или имеющиеся разрешения являются неправильными.

Эта ошибка означает, что в среде Exchange существуют проблемы с разрешениями, которые могут быть причиной попадания почты в очередь.

Чтобы устранить эту проблему, выполните шаги, описываемые в базе знаний Майкрософт в статье 907969, рассматривающей ситуацию, когда в журнале зарегистрировано событие с идентификатором 929, и почта не доставляется с одного почтового сервера на другой почтовый сервер в организации Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=907969).

Дополнительные сведения о событиях и ошибках Exchange Server 2003 см. на странице, посвященной центру событий и сообщений об ошибках (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=34258).


Общая папка, указанная в качестве общего назначения
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-10-04

Средство анализа Microsoft® Exchange Server запрашивает класс WMI Exchange_Queue, чтобы определить значение следующих атрибутов очереди SMTP на виртуальном SMTP-сервере.

LinkId | Указывает на код ссылки, содержащей очередь.
QueueId | Указывает на код очереди.
QueueName | Указывает на имя очереди.
VirtualMachine | Указывает на имя виртуальной машины, содержащей очередь.
VirtualServerName | Указывает на имя виртуального сервера, на котором находится очередь.
MessageCount | Указывает на количество сообщений в очереди.

Средство анализа сервера Exchange Server использует полученные данные для запроса у класса WMI Exchange_QueuedSMTPMessage значений следующих атрибутов сообщений из очереди:

Recipients | Указывает на получателей сообщения.
Received | Указывает на полученную метку времени сообщения.
MessageId | Указывает на код сообщения, находящегося в очереди.
StateRetry | Указывает на повторную передачу сообщения, которое не было доставлено.

Затем средство анализа сервера Exchange Server использует полученные данные для отправки запроса в службу каталогов Active Directory® с целью получения значения distinguishedName для каждого объекта Recipient. Затем средство анализа Exchange Server определяет, является ли получателем пользователь, группа рассылки, общая папка или хранилище общих папок.

Если анализатор сервера Exchange Server определяет, что как минимум у 25 процентов сообщений, скопившихся в очереди, в полях To: (Кому) или Cc: (Копия) указана одна и та же общая папка, то отображается предупреждение.

Если анализатор сервера Exchange Server определяет, что как минимум у 50 процентов сообщений, скопившихся в очереди, в полях To: (Кому) или Cc: (Копия) указана одна и та же общая папка, то отображается сообщение об ошибке.

Такое предупреждение или сообщение об ошибке означает, что указанная общая папка является общим назначением сообщений, скопившихся в очереди SMTP.

Для решения данной проблемы следует проверить общую папку на наличие ошибок конфигурации и других неполадок, которые могли вызвать скопление сообщений в очереди:

  • Убедитесь, что атрибуты объекта общей папки в службе Active Directory установлены правильно и содержат правильные значения.

  • Убедитесь в правильности параметров разрешений объекта общей папки в службе Active Directory .

  • Проверьте наличие нежелательной почты или вирусных атак, направленных против общей папки.

Дополнительные сведения об устранении неполадок, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел «Устранение проблем, связанных с потоком почты и протоколом SMTP» в руководстве по транспортировке и маршрутизации сервера Exchange по адресу http://go.microsoft.com/fwlink/?LinkID=67875 (на английском языке).

  • Статья 823489 базы знаний Майкрософт «Использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003» по адресуhttp://go.microsoft.com/fwlink/?linkid=3052&kbid=823489 (эта ссылка может указывать на содержимое полностью или частично на английском языке).


Хранилище общих папок, указанное в качестве общего назначения
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-10-04

Средство анализа Microsoft® Exchange Server запрашивает класс WMI Exchange_Queue, чтобы определить значение следующих атрибутов очереди SMTP на виртуальном SMTP-сервере.

LinkId | Указывает на код ссылки, содержащей очередь.
QueueId | Указывает на код очереди.
QueueName | Указывает на имя очереди.
VirtualMachine | Указывает на имя виртуальной машины, содержащей очередь.
VirtualServerName | Указывает на имя виртуального сервера, на котором находится очередь.
MessageCount | Указывает на количество сообщений в очереди.

Средство анализа сервера Exchange Server использует полученные данные для запроса у класса WMI Exchange_QueuedSMTPMessage значений следующих атрибутов сообщений из очереди:

Recipients | Указывает на получателей сообщения.
Received | Указывает на полученную метку времени сообщения.
MessageId | Указывает на код сообщения, находящегося в очереди.
StateRetry | Указывает, что происходит повторная передача сообщения, которое не было удачно доставлено.

Кроме того, средство анализа Exchange server использует полученные данные для запроса службы каталогов Active Directory® с целью получения значения distinguishedName для каждого объекта Recipient. Затем средство анализа Exchange Server определяет, является ли получателем пользователь, группа рассылки, общая папка или хранилище общих папок.

Если средство Exchange Server Analyzer определяет, что как минимум у 25 процентов сообщений, скопившихся в очереди, в полях To: (Кому) или Cc: (Копия) указаны получатели, чьи почтовые ящики находятся в одном и том же хранилище общих папок, то отображается предупреждение.

Если средство Exchange Server Analyzer определяет, что как минимум у 50 процентов сообщений, скопившихся в очереди, в полях To: (Кому) или Cc: (Копия) указаны получатели, чьи почтовые ящики находятся в одном и том же хранилище общих папок, то отображается сообщение об ошибке.

Такое предупреждение или сообщение об ошибке означает, что указанное хранилище общих папок является общим назначением сообщений, скопившихся в очереди SMTP.

Для решения данной проблемы следует проверить хранилище общих папок на наличие ошибок в конфигурации, множественных репликаций и других неполадок, которые могли вызвать скопление сообщений в очереди:

  • Убедитесь, что атрибуты объекта хранилища в службе Active Directory установлены правильно и содержат правильные значения.

  • Убедитесь в правильности параметров разрешений объекта хранилища в службе Active Directory .

  • Проверьте наличие нежелательной почты или вирусных атак, направленных против общей папки.

  • Проверьте иерархию и содержимое общих папок на наличие изменений, которые могли вызвать множественные репликации между общими хранилищами папок.

Дополнительные сведения об устранении неполадок, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел «Устранение проблем, связанных с потоком почты и протоколом SMTP» в руководстве по транспортировке и маршрутизации сервера Exchange по адресу http://go.microsoft.com/fwlink/?LinkID=67875 (на английском языке).

  • Статья 823489 базы знаний Майкрософт «Использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003» по адресуhttp://go.microsoft.com/fwlink/?linkid=3052&kbid=823489 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 842273 базы знаний корпорации Майкрософт «Устранение неполадок репликации папок в Exchange 2000 Server и Exchange Server 2003» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=842273 (эта ссылка может указывать на содержимое полностью или частично на английском языке).


Включен фильтр получателей
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, указывает ли свойство msExchServerBindingsFiltering объекта виртуального SMTP-сервера на то, что включен фильтр олучателей для экземпляра виртуального SMTP-сервера.

Средство анализатора сервера Exchange также запрашивает службу Active Directory, чтобы определить, указывают ли свойства msExchRecipTurfListNames или msExchRecipTurfListOptions на то, что фильтр получателей также включен на уровне глобальных параметров.

Если средство анализатора сервера Exchange обнаруживает, что фильтр получателей включен как на экземпляре виртуального SMTP-сервера, так и на уровне глобальных параметров, средство анализатора сервера Exchange выводит на экран предупреждение.

Это предупреждение указывает на то, что фильтр получателей включен и действует. Обычно фильтр получателей не является проблемой. Однако при решении проблем с почтовыми потоками именно на этом сервере может возникнуть необходимость изменить настройку или временно отключить фильтр получателей, чтобы определить, не блокирует ли он допустимых получателей по ошибке.

Чтобы отключить фильтр получателей на виртуальном SMTP-сервере

  1. Запустите диспетчер Exchange Щелкните Пуск, укажите Программы, выберите Microsoft Exchange, а затем щелкните Диспетчер.

  2. В дереве консоли разверните узел Серверы, затем выберите нужный сервер, откройте Протоколы и SMTP.

  3. Правой кнопкой мыши щелкните виртуальный SMTP-сервер, для которого необходимо отключить фильтр, а затем нажмите Свойства.

  4. В окне <SMTP Virtual Server> Свойства на вкладке Общие щелкните Дополнительно.

  5. В окне Дополнительно выберитеe IP-адрес, для которого необходимо отключить фильтр, а затем нажмите кнопку Изменить.

В окне Идентификация снимите флажок Применить фильтр получателей, чтобы отключить фильтр.

  1. Если существует несколько виртуальных серверов, повторите шаги с 3 по 6 для каждого виртуального сервера, на котором необходимо отключить фильтр.

Дополнительные сведения о настройке фильтров получателей см. в статье 823866 базы знаний Майкрософт, описывающей настройку фильтра подключения для использования списков запрещенных адресов реального времени (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823866).

Дополнительные сведения об интеллектуальном фильтре сообщений см. на веб-узле интеллектуального фильтра сообщений Exchange (http://go.microsoft.com/fwlink/?LinkId=21607).


Очередь «Удаленная доставка» заблокирована
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс ExchangeLink, чтобы определить значение раздела StateFrozen для SMTP-очереди Удаленная доставка.

Если анализатор сервера Exchange обнаружит, что значение раздела StateFrozen для очереди Удаленная доставка на сервере Exchange установлено равным True, анализатор сервера Exchange выведет на экран сообщение об ошибке.

Заблокированная очередь означает, что транспортные сеансы для этой очереди остановлены. Заблокированная очередь препятствует отправке исходящих сообщений, хотя новые сообщения могут быть добавлены в очередь. Можно вручную изменить состояние подключения с помощью контекстного меню каждой очереди. При использовании команды Установить подключение для изменения состояния очереди на «Активное» немедленно разрешается подключение, которое используется для отправки сообщений из этой очереди.

В очереди Удаленная доставка хранятся сообщения, которые предназначены для удаленной доставки. Имя очереди соответствует назначению удаленной доставки. Назначением может служить соединитель, сервер или домен.

Чтобы решить эту проблему, используйте средство NSlookup для просмотра возможных неполадок с разрешением имен DNS. Если неполадки связаны с подключениями или протоколами (например, ошибки невозможности достижения узла), воспользуйтесь программой Telnet.exe, чтобы попытаться подключиться к целевому компьютеру. Чтобы устранить неполадки, связанные с ошибками протоколов, увеличьте ведение журналов диагностики для службы MSExchangeTransport компонента SMTP-протокола и просмотрите эти журналы на наличие ошибок. Кроме того, можно использовать сетевой монитор (Netmon.exe), чтобы получить сведения об ошибках, связанных с сетевыми подключениями. Чтобы снова вызвать появление ошибки, может понадобиться повторно начать принудительное выполнение очереди. Просмотрите журнал событий на наличие возможных ошибок, связанных со службой банка данных Microsoft Exchange.

Дополнительные сведения об изменения параметров ведения журналов см. в статье, посвященной инструкциям по изменению параметров ведения журналов для MMSExchangeTransport в разделе, посвященном устранению неполадок с почтовым потоком и SMTP, в руководстве по транспорту и маршрутизации в Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Дополнительные сведения об устранении проблем, связанных с очередями SMTP, см. на следующих ресурсах Exchange:

  • раздел по устранению проблем потока почты и SMTP в руководстве по транспорту и маршрутизации сервера Exchange (http://go.microsoft.com/fwlink/?LinkId=47579);

  • статья 823489 базы знаний Майкрософт, описывающая использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489);

  • статья 821877 базы знаний Майкрософт, содержащая описание полей на вкладках свойств очередей SMTP и X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877);

  • статья 264054 базы знаний Майкрософт, описывающая общие сведения о состояниях очередей в Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Повторная попытка для очереди «Удаленная доставка»
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Windows® Management Instrumentation) ExchangeLink, чтобы определить значение раздела StateRetry для SMTP-очереди Удаленная доставка.

Если анализатор сервера Exchange обнаружит, что для раздела StateRetry для очереди Удаленная доставка на сервере Exchange задано значение True, анализатор сервера Exchange выведет на экран сообщение об ошибке.

Если очередь находится в состоянии повторения, это состояние указывает, что произошла хотя бы одна ошибка в предыдущих попытках обработки сообщений в этой очереди. С помощью команды Установить подключение очереди в состоянии «Retry» или «Scheduled» можно перевести в состоянии «Active». Это заставит очередь функционировать, как если бы интервал повторения закончился или было достигнуто запланированное время. Однако этот метод действует не всегда.

Примечание.
Свойства очереди могут указывать на конкретную причину, по которой очередь находится в состоянии «Retry».

В очереди Удаленная доставка содержатся сообщения, предназначенные для удаленной доставки. Имя очереди соответствует назначению удаленной доставки. Таким назначением может быть соединитель, сервер или домен.

Чтобы исправить эту ошибку, используйте служебную программу NSlookup для просмотра возможных неполадок, связанных с разрешением DNS. Для решения проблем, связанных с подключением и протоколом, например ошибки типа «Узел недостижим», используйте Telnet.exe, чтобы подключиться к целевому компьютеру. Для устранения неполадок, связанных с протоколом, необходимо увеличить частоту регистрации событий в журнале диагностики для службы MSExchangeTransport компонента SMTP-протокола и просмотреть ошибки в журнале. Также можно использовать средство «Сетевой монитор» (Netmon.exe) для получений сведений об ошибках сетевых подключений. Для воспроизведения проблемы может понадобиться снова запустить очередь. Необходимо проверить наличие в журнале событий возможных ошибок, связанных со службой банка данных Microsoft Exchange.

Для получения дополнительных сведений об изменении параметров ведения журнала см. описание изменения параметров ведения журнала для MSExchangeTransport в разделе, посвященном устранению неполадок почтового потока и протокола SMTP в Руководстве по маршрутизации и транспортировке сервера Exchange (http://go.microsoft.com/fwlink/?LinkId=47579).

Дополнительные сведения об устранении проблем, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел по устранению проблем, связанных с потоком почты и протоколом SMTP в Руководстве по транспортировке и маршрутизации сервера Exchange (http://go.microsoft.com/fwlink/?LinkId=47579).

  • База знаний Майкрософт, статья 823489, описывающая использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • База знаний Майкрософт, статья 821877, содержащая описание полей на вкладках свойств очередей SMTP и X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • База знаний Майкрософт, статья 264054, содержащая общие сведения о состояниях очередей в Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Ошибка очереди «Удаленная доставка»
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Средство анализатора сервера Microsoft® Server отправляет тестовое сообщение с сервера Exchange для учетной записи администратора почты или учетной записи пользователя для SMTP-домена, а затем сканирует журналы отслеживания сообщений сервера, чтобы определить, не возникли ли какие-либо проблемы с доставкой тестового сообщения.

При проведении сканирования анализатор сервера Exchange Server запрашивает свойство EntryType для WMI-класса Exchange_MessageTrackingEntry в пространстве имен root\MicrosoftExchangeV2, чтобы определить причины создания записей журнала отслеживания.

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Журнал отслеживания сообщений может успешно сканироваться.

  • Тестовому сообщению не удалось пройти очередь.

  • Был создан отчет NDR.

  • Для свойства EntryType существует значение 1034.

Эта ошибка указывает, что тестовое сообщение все еще находится в одной из очередей SMTP Удаленная доставка отправляющего сервера и в работе этой очереди возникла ошибка.

Очередь Удаленная доставка содержит сообщения, предназначенные для удаленной доставки. Имя очереди соответствует пункту назначения удаленной доставки. Этим пунктом назначения может быть соединитель, сервер или домен.

Чтобы устранить эту ошибку, воспользуйтесь служебной программой NSlookup, чтобы выявить возможные проблемы с разрешением DNS. В случае ошибок подключения или использования протокола, например ошибок, связанных с недоступностью узла, используйте Telnet.exe, чтобы попытаться подключиться к конечному компьютеру. Чтобы устранить ошибки, связанные с использованием протокола, следует увеличить объем заносимой в журнал диагностической информации для службы MSExchangeTransport для SMTP-компонента и просмотреть журналы на наличие ошибок. Можно также использовать сетевой монитор (Netmon.exe), чтобы получить сведения об ошибках сетевых подключений. Для воспроизведения возникшей проблемы можно еще раз проанализировать работу очереди. Изучите журнал событий на наличие возможных ошибок, связанных со службой базы данных Microsoft Exchange.

Дополнительные сведения об изменении настройки ведения журнала см. в подразделе, содержащем инструкции по изменению параметров ведения журнала для службы MSExchangeTransport, который находится в разделе, посвященном вопросам устранения неполадок потока почты и SMTP, руководства по транспорту и маршрутизации сервера Exchange (http://go.microsoft.com/fwlink/?LinkId=47579).

Дополнительные сведения об устранении проблем, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел по устранению проблем потока почты и SMTP в руководстве по транспорту и маршрутизации сервера Exchange (http://go.microsoft.com/fwlink/?LinkId=47579).

  • База знаний Майкрософт, статья 823489, описывающая использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • База знаний Майкрософт, статья 821877, содержащая описание полей на вкладках свойств очередей SMTP и X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • База знаний Майкрософт, статья 264054, описывающая общие сведения о состояниях очередей в Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Повторная классификация
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Средство анализатора сервера Microsoft® Exchange посылает тестовое сообщение с сервера Exchange на учетную запись администратора почтовой системы или на определяемую пользователем учетную запись для SMTP-домена (Simple Mail Transfer Protocol), а затем сканирует на сервере журналы отслеживания сообщений, чтобы определить, были ли обнаружены проблемы, связанные с доставкой тестового сообщения.

В качестве части процесса сканирования анализатор сервера Exchange запрашивает свойство EntryType для WMI-класса (Microsoft Windows® Management Instrumentation) Exchange_MessageTrackingEntry в пространстве имен root\MicrosoftExchangeV2, чтобы определить причину появления записи в журнале отслеживания сообщений.

Если анализатор сервера Exchange обнаружит, что значение свойства EntryType равно 1032, анализатор сервера Exchange выведет на экран предупреждение.

Это предупреждение указывает, что тестовое сообщение находится в очереди, которая запланирована для повторной классификации. Если очередь находится в состоянии повторения, это состояние указывает, что произошла хотя бы одна ошибка в предыдущих попытках обработки сообщений в этой очереди. С помощью команды Установить подключение очереди в состоянии «Retry» или «Scheduled» можно перевести в состоянии «Active». Это заставит очередь функционировать, как если бы интервал повторения закончился или было достигнуто запланированное время. Однако этот метод действует не всегда.

Примечание.
Свойства очереди могут указывать на конкретную причину, по которой очередь находится в состоянии «Retry».

В общем случае сообщения накапливаются в очереди, ожидающей повторения, из-за того, что расширенный механизм очередей не может классифицировать сообщение. Расширенный механизм очередей может не иметь доступа к серверам глобального каталога и доступа к сведениям о получателе, либо серверы глобального каталога недостижимы или работают медленно. Кроме того, сообщения могут накапливаться по следующим причинам:

  • Служба Active Directory недоступна.

    Примечание.
    Классификатор использует службу Active Directory для классификации сообщений.
  • Служба Active Directory может быть слишком перегружена, если в очереди перед классификацией находится много сообщений.

  • Существует ошибка в преобразовании. Классификатор также обрабатывает преобразование содержимого.

  • Классификатор сообщений не может найти хранилища почтовых ящиков.

  • Если протокол SMTP переустановлен или удален, это может сделать недействительными следующие ключи метабазы IIS: /smtpsvc/DsUseCat и /smtpsvc/vsi#/DsUseCat.

    Примечание.
    Определите, был ли переустановлен или удален протокол SMTP.

Если очередь находится в состоянии «Retry», проанализируйте свойства очереди, чтобы определить причину. Например, если в свойствах очереди отображается сообщение, такое как «Произошла ошибка SMTP», следует просмотреть на сервере журналы ошибок, чтобы найти все ошибки SMTP. Если в журнале нет событий, необходимо увеличить уровень регистрации в журнале событий протокола SMTP.

Дополнительные сведения об устранении проблем, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел по устранению проблем потока почты и SMTP в руководстве по транспорту и маршрутизации сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).

  • База знаний Майкрософт, статья 823489, описывающая использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • База знаний Майкрософт, статья 821877, содержащая описание полей на вкладках свойств очередей SMTP и X.400 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • База знаний Майкрософт, статья 264054, описывающая общие сведения о состояниях очередей в Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Повторить Локальную Доставку
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-04

Средство анализа Microsoft® Exchange Server отправляет тестовое сообщение с сервера Exchange для учетной записи Postmaster или учетной записи, указанной пользователем, в домене Simple Mail Transfer Protocol (SMTP) и затем выполняет поиск проблем, возникших при доставке тестового сообщения, в журнале отслеживания сообщений.

Для определения причин появления записи в журнале сообщений в процессе поиска средство анализа Exchange Server Analyzer запрашивает свойство EntryType Exchange_MessageTrackingEntry класса Microsoft Windows® Management Instrumentation (WMI) в пространстве имен root\MicrosoftExchangeV2.

Если средство анализа Exchange Server Analyzer определяет, что значение свойства EntryType равно 1037, Exchange Server Analyzer отображает предупреждение.

Это предупреждение указывает, что во время предыдущих попыток обработки сообщения в очереди Local Delivery произошло не менее одной ошибки.

Очередь Local Delivery содержит сообщения, включаемые в очередь на сервере Exchange для локальной доставки в общедоступную папку или на почтовый ящик Exchange Server.

Сообщения могут накапливаться в этой очереди, если сервер Exchange не принимает сообщения для локальной доставки. Замедленная или пульсирующая доставка сообщений может указывать на зацикливание сообщения или проблемы с производительностью.

Очереди, находящиеся в состоянии «Повтор» или «По Расписанию», могут быть переведены в состояние «Активно» с помощью команды Force Connection. В этом состоянии очередь функционирует так, как будто интервал между повторами завершен или было достигнуто запланированное время. Однако этот метод может работать не всегда.

Примечание.
Очередь, обладающая определенными свойствами, может остаться в состоянии «Повтор».

Для исправления этой ошибки усильте диагностическое протоколирование компонентов драйверов хранилища служб MSExchangeIS и MSExchangeTransport.

Для получения дополнительных сведений об изменении параметров протоколирования см. статью «How to Modify Logging Settings for MSExchangeTransport» раздела «Troubleshooting Mailflow and SMTP» в документе Руководство по пересылке и маршрутизации Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Для получения дополнительных сведений об исправлении ошибок в очередях SMTP см. следующие источники по Exchange:

  • «Troubleshooting Mail Flow and SMTP» в документе Руководство по пересылке и маршрутизации Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Статья 823489 базы знаний Microsoft «Использование Просмотра очередей для устранения неполадок почтового потока Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Статья 821877 базы знаний Microsoft «Описание полей таблиц свойств очередей SMTP и X.400» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Статья 264054 базы знаний Microsoft , «XCON: Состояния очередей в Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Повторная попытка маршрутизации
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Средство анализатора сервера Microsoft® Exchange посылает тестовое сообщение с сервера Exchange на учетную запись администратора почтовой системы или на определяемую пользователем учетную запись для SMTP-домена (Simple Mail Transfer Protocol), а затем сканирует на сервере журналы отслеживания сообщений, чтобы выявить проблемы, связанные с доставкой тестового сообщения.

В рамках процесса сканирования средство анализатора сервера Exchange запрашивает свойство EntryType WMI-класса (Microsoft Windows® Management Instrumentation) Exchange_MessageTrackingEntry в пространстве имен root\MicrosoftExchangeV2, чтобы определить причину появления записи в журнале отслеживания сообщений.

Если анализатор обнаружит значение 1035 для свойства EntryType, на экран выводится предупреждение.

Это предупреждение указывает, что тестовое сообщение находится в очереди, которая запланирована для повторной маршрутизации. Если очередь находится в состоянии повторения, это состояние указывает, что произошла хотя бы одна ошибка в предыдущих попытках обработки сообщений в этой очереди. С помощью команды Установить подключение очереди в состоянии «Retry» или «Scheduled» можно перевести в состоянии «Active». Это заставит очередь функционировать, как если бы интервал повторения закончился или наступило назначенное время. Однако этот метод действует не всегда.

Примечание.
Свойства очереди могут указывать на конкретную причину, по которой очередь находится в состоянии «Retry».

Сообщения накапливаются в очередях для повторной обработки при наличии проблем с маршрутизацией в Exchange Server. Маршрутизация сообщений не была выполнена из-за временной ошибки, т. е. инициализация модуля маршрутизации не была выполнена успешно. Сообщения находятся в очереди, ожидания обработки или находясь в процессе повторной маршрутизации.

Чтобы устранить эту ошибку, увеличьте уровень ведения журнала диагностики для службы MSExchangeTransport, чтобы собрать сведения о компоненте категории маршрутизации. Отключите все ненужные ограничения соединителя, поскольку ограничения могут существенно снизить производительность сервера. Может потребоваться включить параметр реестра CheckConnectorRestrictions для некоторых ограничений.

Дополнительные сведения по настойке параметров ведения журнала см. в части раздела по устранению проблем потока почты и SMTP, посвященной изменению параметров ведения журнала для MSExchangeTransport, руководства по транспорту и маршрутизации сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).

Дополнительные сведения об устранении проблем, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел по устранению проблем потока почты и SMTP в руководстве по транспорту и маршрутизации сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Статья 823489 базы знаний Майкрософт, описывающая использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Статья 821877 базы знаний Майкрософт, содержащая описание полей на вкладках свойств очередей SMTP и X.400 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Статья 264054 базы знаний Майкрософт, содержащая общие сведения о состояниях очередей в Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Обратные запросы DNS включены в метабазе, и не включены на связанном SMTP-сервере в службе Active Directory
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-01-17

Средство анализатора сервера Microsoft® Exchange считывает следующее свойство в метабазе IIS (Internet Information Services), чтобы определить, совпадает ли его значение с установленным значением атрибута msExchSmtpPerformReverseDnsLookup в службе каталогов Active Directory®:

/LM/SmtpSvc/<SMTP virtual server instance>/EnableReverseDnsLookup

Если анализатор сервера Exchange обнаружит, что значения не совпадают, на экран будет выведено предупреждение.

Если значение в метабазе IIS не совпадает со значением в службе Active Directory, это может указывать на проблему с репликацией Active Directory или на проблему с присутствующим в Exchange компонентом репликации службы каталогов в метабазу (DS2MB).

Функция процесса DS2MB — передача сведений о конфигурации из службы Active Directory в локальную метабазу. По причинам, связанным с производительностью и масштабируемостью, эта конфигурация хранится в локальной метабазе, а не в реестре. В приложениях Exchange 2000 Server и Exchange Server 2003 все протоколы Интернета (SMTP, NNTP, POP3, IMAP4 и HTTP) запускаются как компоненты службы IIS.

Каждые 15 минут процесс DS2MB копирует из службы Active Directory целые поддеревья без изменения формы поддеревьев. Это однонаправленная запись из службы Active Directory в метабазу; запись из метабазы в службу Active Directory никогда не выполняется.

И свойство EnableReverseDnsLookup, и атрибут msExchSmtpPerformReverseDnsLookup могут иметь значение «TRUE» или «FALSE». Значение «TRUE» означает, что виртуальный SMTP-сервер выполняет обратные запросы DNS по всем входящим сообщениям. Значение «FALSE» означает, что виртуальный SMTP-сервер не выполняет обратные запросы DNS. В виду возможности ухудшения производительности из-за неправильно настроенных записей DNS или из-за неустойчивых подключений к Интернету свойство EnableReverseDnsLookup и атрибут msExchSmtpPerformReverseDnsLookup установлены равными «FALSE» по умолчанию.

Если свойство EnableReverseDnsLookup установлено равным «TRUE» (включено) и атрибут msExchSmtpPerformReverseDnsLookup установлен равным «FALSE» (выключено), это означает что служба Active Directory и метабаза IIS не синхронизированы. Если причиной проблемы является сбой процесса DS2MB, можно устранить эту проблему, выполнив описываемую ниже процедуру для используемой версии сервера Exchange. Если проблема вызвана частичным или полным отказом репликации Active Directory, можно воспользоваться служебной программой наблюдения за репликацией Active Directory (ReplMon.exe), чтобы проверить работоспособность и состояние репликации Active Directory. Служебная программа ReplMon.exe находится в средствах поддержки Microsoft Windows® на компакт-диске Windows Server.

Чтобы устранить эту ошибку в Exchange Server 2003

  1. Проверьте журнал событий приложений на наличие записей с источником MSExchangeMU. Если происходит сбой DS2MB, в журнал заносится событие для Exchange Server 2003.

  2. Если никаких отказов DS2MB не наблюдается, используйте средство ReplMon для диагностики репликации Active Directory. Обратите особое внимание на серверы глобального каталога, используемые виртуальным SMTP-сервером.

  3. Если отказы DS2MB видны либо если устранены или разрешены какие-либо проблемы с репликацией Active Directory, перезапустите службу «Системный помощник Exchange».

Чтобы устранить эту ошибку в Exchange 2000 Server

  1. Используйте средство ReplMon для диагностики репликации Active Directory. Обратите особое внимание на серверы глобального каталога, используемые виртуальным SMTP-сервером.

  2. После устранения или разрешения любых проблем с репликацией Active Directory перезапустите службу «Системный помощник Exchange».

Дополнительные сведения о функции обратного запроса DNS в Exchange см. в статье 297412 базы знаний Майкрософт, описывающей использование параметра «Выполнить обратный запрос DNS для входящих сообщений» с целью разрешения имен узлов (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в базе знаний Майкрософт в статье 266686 «XCON: How to Configure a SMTP Virtual Server Part 1» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) и в статье 268163 «XCON: How to Configure a SMTP Virtual Server Part 2» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

Дополнительные сведения о репликации в Active Directory см. в статье 232072 базы знаний Майкрософт «Initiating Replication Between Active Directory Direct Replication Partners» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072).

Дополнительные сведения о процессе DS2MB см. в базе знаний Майкрософт в статье 240105 «XGEN: General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105).


Модуль маршрутизации:Значение параметра AttachedTimeout не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, была ли изменена логика маршрутизации соединителя SMTP относительно значения по умолчанию, средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\AttachedTimeout

Если анализатор обнаружит, что раздел реестра AttachedTimeout существует и его значение превышает 300, отображается сообщение о нестандартной конфигурации.

Значение реестра AttachedTimeout является настраиваемым параметром конфигурации для сервера Exchange, с помощью которого определяется частота отправки пакета ORG_INFO. Каждый раз, когда клиент маршрутизации не может подключиться к серверу маршрутизации, пользовательская версия топологии будет увеличена, что приведет к отправке широковещательного пакета ORG_INFO по всей организации.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы восстановить конфигурацию по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Удалите раздел реестра AttachedTimeout.

  4. Закройте редактор реестра.

  5. Перезагрузите службу IIS Admin, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о разделе реестра AttachedTimeout см. в статье 832281 базы знаний Майкрософт, посвященной вопросам состояния связи и маршрутизации в Exchange 2000 Server и Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832281).


Модуль маршрутизации:параметр BestAddressMatchOnly не является параметром по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange считывает следующую запись реестра, чтобы определить, было ли изменено значение по умолчанию для логики маршрутизации SMTP-соединителя:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\BestAddressMatchOnly

Если анализатор сервера Exchange обнаружит, что запись реестра BestAddressMatchOnly существует и для нее настроено значение больше 0, на экран выводится сообщение о нестандартной конфигурации.

Запись реестра BestAddressMatchOnly является значением стандартной конфигурации для сервера Exchange, которое способствует тому, что почта, отправленная на определенный домен, направляется на определенный соединитель вне зависимости от существующих ограничений.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы вернуть настройку по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Удалите раздел реестра BestAddressMatchOnly.

  4. Закройте редактор реестра.

  5. Перезапустите службу IIS Admin, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Модуль маршрутизации: для параметра CheckConnectorRestrictions задано значение, отличное от значения по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, было ли изменено значение по умолчанию для логики маршрутизации SMTP-соединителя, средство анализатора Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\CheckConnectorRestrictions

Если анализатор сервера Exchange обнаружит, что параметр CheckConnectorRestrictions существует и для него задано значение больше 0, на экран выводится предупреждение о значении, отличном от значения по умолчанию.

Запись реестра CheckConnectorRestrictions является пользовательским параметром конфигурации Exchange Server, позволяющим выполнять проверку ограничений на сервере-плацдарме Exchange, являющемся источником проверяемого соединителя. По умолчанию проверка ограничений соединителя отключена, поскольку она может серьезно сказаться на производительности, особенно в конфигурациях со множеством групп рассылки. Проверяются ограничения для всех сообщений, отправляемых любому члену любой группы рассылки и проходящих через систему. Если ограничения заданы, но данная запись реестра отсутствует, то проверка ограничений не выполняется.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы восстановить конфигурацию по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Удалите параметр реестра CheckConnectorRestrictions.

  4. Закройте редактор реестра.

  5. Перезапустите службу администрирования IIS.

  6. На вкладке Ограничения доставки включите соответствующий параметр.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о значении параметра реестра CheckConnectorRestrictions см. в статье 277872 базы знаний Майкрософт, описывающей неправильную работу ограничений доставки соединителя (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872).


Модуль маршрутизации: настраиваемый параметр не является параметром по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, был ли изменен интервал чтения службы каталогов Active Directory для модуля маршрутизации Exchange относительно значения по умолчанию, анализатор сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RESvc\Parameters\ReloadOsInterval

Если анализатор сервера Exchange определяет, что значение ReloadOsInterval не равно 3600, выводится сообщение о нестандартной конфигурации.

Параметр ReloadOsInterval используется для указания интервала обновления данных состояния связей маршрута между серверами Exchange. Exchange использует информацию о состоянии связей маршрута с тем, чтобы каждый сервер мог определить самый недорогой маршрут доставки сообщения, и также определить, функционируют ли соединители, которые формируют данный маршрут. По умолчанию серверы Exchange считывают данные состояния связей из Active Directory каждые 3600 секунд, то есть, каждый час.

В определенных ситуациях информация о состоянии маршрута может не быть правильно динамически распространена по серверам в масштабах организации Exchange. Некоторые серверы в организации будут продолжать работать со старыми и, возможно, неправильными данными состояния маршрута. В результате новые соединители могут не отображаться при просмотре удаленной группы маршрутизации с помощью средства WinRoute (Winroute.exe). Средство WinRoute можно использовать для проверки распространения информации о состоянии связей. Чтобы убедиться, что информация распространяется, просмотрите с помощью средства WinRoute информацию о состоянии связей из нескольких разных местоположений в организации Exchange и затем сравните номера версий для каждой группы маршрутизации. Средство WinRoute подключается к порту состояния связей на компьютере сервера Exchange и извлекает данные о состоянии связей в организации Exchange. Хотя информация о состоянии связей — это ряд глобальных уникальных идентификаторов (GUID), WinRoute сопоставляет GUID соединителей и узловых транспортных серверов с объектами в Active Directory и представляет информацию в удобочитаемом формате.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что знаете, как восстановить реестр в случае возникновения неполадок. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы восстановить конфигурацию по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\SYSTEM\CurrentControlSet\Services\RESvc\Parameters

  3. В правой области дважды щелкните ReloadOsInterval.

  4. В поле «Значение» введите 3600 и нажмите кнопку ОК.

  5. Закройте редактор реестра.

Перед началом редактирования реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о маршрутизации и данных состояния связей см. в следующих статьях базы знаний:

  • Статья 842026 «Routing status information is not propagated correctly to all servers in Exchange 2000 Server or in Exchange Server 2003» (Данные состояния маршрутизация не распространяются правильно по всем серверам Exchange 2000 Server или Exchange Server 2003) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=842026) (может быть на английском языке);

  • Статья 285130 «Link State Information» (Данные состояния связей) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285130) (может быть на английском языке).

Загрузить средство WinRoute, которое помогает определять данные состояния связей, известные основному маршрутизатору, можно на веб-узле «Exchange Server WinRoute» (http://go.microsoft.com/fwlink/?LinkId=25049).


Механизм маршрутизации:параметр PollingInterval не является параметром по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализа сервера Microsoft® Exchange считывает следующую запись из реестра, чтобы определить, было ли изменено значение по умолчанию логики маршрутизации соединителя протокола SMTP:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\PollingInterval

Если средство анализа средства Exchange обнаруживает наличие записи PollingInterval в реестре, настроенной со значением более 300, отображается сообщение о том, что настройка по умолчанию изменена.

Запись из реестра PollingInterval - это параметр пользовательской настройки сервера Exchange, которая помогает контролировать частоту трафика обращения к ссылкам среди групп маршрутизации, особенно к владельцу групп маршрутизации и от него. Увеличение значения параметра предотвратит разрыв подключения, но может также помешать вам исправить более серьезную проблему медленного перехода по ссылкам между членами группы маршрутизации.

Важно!
Эта статья содержит сведения об изменении реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неполадки. Для получения сведений о восстановлении реестра см. раздел справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы восстановить параметры по умолчанию, выполните следующие действия

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к: HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Удалите раздел реестра PollingInterval.

  4. Закройте редактор реестра.

  5. Перезапустите Службу IIS Admin, чтобы изменение вступило в силу.

Перед правкой реестра, а также для получения сведений о правке реестра см. статью 256986 базы знаний Майкрософт, «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Модуль маршрутизации:Параметр StateChangeDelay не является параметром по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить, изменилась ли логика маршрутизатора соединителя протокола SMTP по отношению к его параметрам по умолчанию:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\StateChangeDelay

Если анализатор сервера Exchange обнаруживает, что раздел StateChangeDelay реестра присутствует и ему присвоено значение больше, чем 0, на экран выводится сообщение о конфигурации не по умолчанию.

Запись StateChangeDelay реестра является настраиваемым параметром конфигурации для сервера Exchange, помогающим управлять интервалами, с которым размечены соединители как недоступные, и уведомлениями, выдаваемыми в связи с изменением состояния соединителя и сервера. Когда параметр StateChangeDelay установлен в значение, большее, чем 0, сервер может быть помечен только как доступный или недоступный по одному разу в каждый период времени, который установлен этим значением.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» в Regedit.exe или Regedt32.exe.

Чтобы возвратиться к конфигурации по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Удалите раздел StateChangeDelay реестра.

  4. Закройте редактор реестра.

  5. Перезагрузите службу администратора IIS, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986 "Description of the Microsoft Windows registry" (Описание реестра Microsoft Windows) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Модуль маршрутизации: для параметра SuppressStateChanges задано значение, отличное от значения по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, было ли изменено значение по умолчанию для логики маршрутизации SMTP-соединителя, средство анализатора Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\SuppressStateChanges

Если анализатор сервера Exchange обнаружит, что параметр SuppressStateChanges существует и для него задано значение больше 0, на экран выводится предупреждение о значении, отличном от значения по умолчанию.

В Exchange Server 2003 включены функции автоматического обнаружения изменений состояния ссылки. Эти сведения могут использоваться для сообщения другим серверам, работающим под управлением Exchange Server 2003, о том, что вместо наиболее экономичного основного маршрута должен использоваться дополнительный маршрут. Различают значительные и незначительные изменения состояния ссылки. Значительное изменение происходит, когда администратор изменяет топологию маршрутизации, например добавляет новый соединитель или изменяет стоимость. Незначительные изменения происходят, когда система автоматически обнаруживает сбой или восстановление ссылки.

Эта функция хорошо работает в организациях небольшого и среднего размера. Однако в крупномасштабных многоузловых средах массовые отклонения в работе сети могут привести к чрезмерному увеличению числа обновлений ссылок в случае незначительных изменений. Для достижения эффективности необходима широковещательная передача данных о состоянии ссылок на все серверы в организации. Кроме того, при изменении состояния осуществляется повторная широковещательная рассылка всей таблицы состояния ссылок, что связано с передачей большого объема данных через сеть. В этих сценариях может оказаться полезным игнорировать незначительные изменения состояния ссылок. Запись реестра SuppressStateChanges является пользовательским параметром настройки, который применяется для игнорирования незначительных изменений состояния ссылок. Когда для параметра SuppressStateChanges установлено значение больше 0, все изменения состояния ссылок на данном компьютере с сервером Exchange игнорируются.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программы Regedit.exe или Regedt32.exe.

Чтобы восстановить конфигурацию по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Удалите параметр реестра SuppressStateChanges.

  4. Закройте редактор реестра.

  5. Чтобы изменения вступили в силу, следует перезапустить SMTP (Simple Mail Transfer Protocol), модуль маршрутизации Microsoft Exchange и службы Microsoft Exchange MTA Stacks.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Для получения дополнительных сведений о разделе реестра SuppressStateChanges см. следующие руководства корпорации Майкрософт:

  • Руководство по транспорту и маршрутизации в Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579)

  • Руководство по быстродействию и масштабируемости Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576)


Соединитель группы маршрутизации с ограничениями по доставке, установленными группой рассылки
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-09-06

Средство анализатора сервера Microsoft® Exchange запрашивает следующие атрибуты для всех объектов соединителя группы маршрутизации (msExchRoutingGroupConnector), обнаруженных в службе Active Directory®, чтобы определить, имеют ли они ограничения по доставке, установленные на основе членства в группе рассылки.

dLMemRejectPerms | Содержит имена доменов списков рассылки, членам которых не разрешено посылать почту через данный соединитель группы маршрутизации.
dLMemSubmitPerms | Содержит имена доменов списков рассылки, членам которых разрешено посылать почту через данный соединитель группы маршрутизации.

Если анализатор сервера Exchange определит, что существуют соединители групп маршрутизации, для которых установлены ограничения по доставке на основе членства в группе рассылки, на экран будет выведено предупреждение.

Это предупреждение указывает, что ограничения по доставке на основе членства в группе рассылки могут влиять на интенсивность потока почты Exchange.

Когда почта отправляется с помощью соединителей групп маршрутизации, имеющих ограничения по доставке на основе членства в группах рассылки, классификатор сообщений должен развернуть структуру членства в группе рассылки, получить полный список различающихся имен членов, а затем сравнить список различающихся имен с различающимися именами отправителей в списке. Когда различающиеся имена в обоих списках совпадают, выполняется операция разрешения доступа или операция запрета доступа. Если группа рассылки вложена в другую группу рассылки, вложенная группа рассылки также разворачивается.

Чтобы устранить причины появления этого предупреждения, выполните следующие действия:

  • Назначьте выделенную группу маршрутизации для ограничений соединителя и настройте ее на локальную группу маршрутизации согласно сведениям, содержащимся в базе знаний Майкрософт, в статье 329171, описывающей ситуацию, когда доставка почты задерживается, если получатели настроены с ограничениями по доставке на основе членства в группе (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • Используйте выделенный и более надежный сервер глобального каталога в качестве назначенного сервера-плацдарма для соединителя.

  • Настройте отдельные почтовые ящики, а не группы рассылки для ограничений по доставке согласно сведениям, содержащимся в базе знаний Майкрософт в статье 812298, описывающей ситуацию, когда доставка почты замедляется после настройки ограничений по доставке на основе списка рассылки (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Рассмотрите возможность реализации фильтрации SMTP-отправителей (Simple Mail Transfer Protocol ).

  • Для серверов, на которых выполняется Exchange Server 2003 с пакетом обновления 2 (SP2) или более поздняя версия, рассмотрите возможность реализации неиерархической проверки ограничений. Для серверов, на которых выполняются версии Exchange, предшествующие Exchange 2003 с пакетом обновления 2 (SP2), рассмотрите возможность обновления до Exchange 2003 с пакетом обновления 2 (SP2).

Дополнительные сведения

Дополнительные сведения о неиерархической проверке ограничений см. в разделе Рассмотрите возможность неиерархической проверки ограничений.

Дополнительные сведения о фильтрации SMTP-отправителей см. в разделе, описывающем включение фильтрации отправителей, в руководстве по администрированию Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=72967).

Дополнительные сведения о влиянии ограничения групп рассылок на поток почты Exchange см. в следующих статьях базы знаний Майкрософт:

  • Статья 329171, описывающая ситуацию, когда доставка почты задерживается, если получатели настроены с ограничениями по доставке на основе членства в группе (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • Статья 895407, описывающая ситуацию в Exchange Server 2003, когда доставка сообщений в локальные и во внешние почтовые ящики вопреки ожиданиям замедляется после настройки ограничений по доставке на основе групп рассылок (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • Статья 839949, описывающая устранение неполадок почтового транспорта и групп рассылок в Exchange 2000 Server и в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).


Хозяин группы маршрутизации был удален
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить значение атрибута msExchRoutingMasterDN для каждого контейнера группы маршрутизации. Если анализатор сервера Exchange определит, что значение атрибута msExchRoutingMasterDN содержит строку DEL:, отобразится сообщение об ошибке.

Атрибут msExchRoutingMasterDN является однозначным атрибутом, в котором хранится различающееся имя компьютера сервера Exchange, служащего хозяином группы маршрутизации для каждой группы маршрутизации. Присутствие строки DEL: может означать, что предыдущий хозяин группы маршрутизации был удален с помощью оснастки «Active Directory — пользователи и компьютеры». Без хозяина группы репликации Exchange не сможет правильно обновлять или обслуживать топологию маршрутизации.

При создании группы маршрутизации первому серверу в этой группе назначается роль хозяина группы маршрутизации. Хозяин группы маршрутизации поддерживает сведения о текущем состоянии связи в группе и распространяет их на другие серверы внутри группы маршрутизации. Хозяин группы маршрутизации наблюдает за сведениями маршрутизации, которые записываются в службу каталогов Active Directory, относящиеся только к своей группе. Рядовые серверы могут передать сведения о состоянии соединителя или доступности сервера хозяину группы маршрутизации. Например, если рядовой сервер пытается связаться с другим сервером в другой группе маршрутизации через соединитель и эта связь доступна, рядовой сервер немедленно сообщает об этом хозяину группы маршрутизации. Таким же образом, если сервер, не являющийся хозяином, получает новые сведения о состоянии связи, он немедленно передает сведения о состоянии соединителя хозяину группы маршрутизации, чтобы другие серверы могли получить данные об изменении маршрутизации.

Чтобы устранить эту ошибку

  1. В системном диспетчере Exchange, в разделе Административные группы разверните группу_администрирования, затем Группы маршрутизации.

  2. Разверните группу маршрутизации и щелкните Члены.

  3. В правой области щелкните правой кнопкой мыши компьютер Exchange, который следует настроить в качестве хозяина группы маршрутизации, и щелкните ??Сделать хозяином??.

Дополнительные сведения о хозяинах групп маршрутизации см. в статье, посвященной настройке топологии маршрутизации в руководстве по транспорту и маршрутизации в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=47579).


Ошибка членства в группе маршрутизации
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-08-21

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory® по каждому значению атрибута msExchRoutingGroupMembersBL объектов Routing Group, чтобы определить, принадлежит ли сервер с обратной связью к выделенной административной группе Microsoft Exchange Server 2007, Административная группа Exchange (FYDIBOHF23SPDLT).

Анализатор сервера Exchange также запрашивает значение атрибута CN для объекта Routing Group, чтобы определить, равно ли значение группе маршрутизации по умолчанию в Exchange 2007, Группа маршрутизации Exchange (DWBGZMFD01QNBJR).

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Сервер с обратной связью принадлежит выделенной административной группе Exchange 2007, Административная группа Exchange (FYDIBOHF23SPDLT).

  • Группа маршрутизации не является группой маршрутизации по умолчанию в Exchange 2007, Группа маршрутизации Exchange (DWBGZMFD01QNBJR).

Эта ошибка указывает, что сервер мог быть перемещен вручную из группы маршрутизации по умолчанию Exchange 2007. Это может быть причиной проблем с маршрутизацией.

Приложения Microsoft Exchange Server 2003 и Microsoft Exchange 2000 Server используют группы маршрутизации для определения топологии маршрутизации, характерной для Exchange. Приложение Exchange 2007 использует узлы Active Directory для определения своей топологии маршрутизации. Приложения Exchange 2003 и Exchange 2000 используют топологию маршрутизации, которая основана на группах маршрутизации и соединителях. Характерная для Exchange конфигурация маршрутизации больше не требуется в организации, содержащей только Exchange 2007. Для определения своей топологии маршрутизации организация, содержащая только Exchange 2007, использует топологию узлов Active Directory.

Для поддержки совместного существования этих двух топологий маршрутизации все серверы Exchange 2007 автоматически добавляются в одну группу маршрутизации при установке приложения Exchange 2007. Группа маршрутизации Exchange 2007 распознается диспетчером Exchange в Exchange 2003 и Exchange 2000 как Группа маршрутизации Exchange (DWBGZMFD01QNBJR) в Административной группе Exchange (FYDIBOHF23SPDLT).

Чтобы устранить эту проблему, переместите серверы Exchange 2007 в выделенную группу маршрутизации Exchange 2007 либо удалите и повторно установите сервер.


Соединитель отправки отключен
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-07-30

Анализатор Microsoft Exchange использует следующий командлет командной консоли Exchange для запроса сведений обо всех соединителях отправки в среде Exchange, для которых атрибуту Enabled присвоено значение False. Если атрибут Enabled соединителя отправки имеет значение False, соединитель отправки отключен.

Get-SendConnector | where { $_.Enabled -eq $False}

После этого анализатор Exchange запрашивает службу каталогов Active Directory, чтобы определить значение атрибута serialNumber для всех объектов, относящихся к классу msExchExchangeServer.

Если это строковое значение содержит выражение «Version 5.5», на компьютере установлен сервер Microsoft Exchange Server 5.5. Если это строковое значение содержит выражение «Version 6.0», на компьютере используется Exchange 2000 Server. Если данное значение содержит выражение «Version 6.5», на компьютере установлен сервер Exchange Server 2003. Если оно содержит выражение «Version 8», на компьютере установлен сервер Exchange Server 2007.

Если анализатор Exchange выясняет, что в среде Exchange, включающей серверы Exchange 2000 Server или Exchange Server 2003, отключен соединитель отправки, он выводит сообщение об ошибке.

Эта ошибка свидетельствует о том, что в то время как сервер Exchange Server 2007 при маршрутизации будет игнорировать отключенные соединители отправки, серверы Exchange 2000 Server и Exchange Server 2003 не смогут распознать флаг отключения соединителя и, возможно, попытаются отправлять сообщения через этот соединитель, что может привести к зацикливанию маршрутизации.

Чтобы устранить данную ошибку, удалите все отключенные соединители отправки в средах Exchange, основанных на Exchange 2000 Server или Exchange Server 2003.

Чтобы удалить отключенный соединитель отправки, следуйте инструкциям по использованию командлета Remove-SendConnector командной консоли Exchange, приведенным в документации по серверу Exchange Server 2007 в разделе «Remove-SendConnector» (http://go.microsoft.com/fwlink/?LinkId=96007).


Фильтрация отправителей включена
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Средство анализатора сервера Microsoft® Exchange запрашивает службу Active Directory®, чтобы определить, показывает ли свойство msExchServerBindingsTurflist объекта виртуального сервера SMTP, что для экземпляра виртуального сервера SMTP включена фильтрация отправителей.

Анализатор сервера Exchange также запрашивает службу Active Directory, чтобы определить, показывают ли свойства msExchTurfListNames или msExchTurfListOptions, что фильтрация отправителей также включена на уровне глобальных параметров.

Анализатор сервера Exchange выводит на экран предупреждение, если выполняются следующие условия:

  • Фильтрация отправителей включена для экземпляра виртуального сервера SMTP.

  • Фильтрация отправителей включена на уровне глобальных параметров.

Это предупреждение показывает, что фильтрация отправителей действительно включена. Фильтрация отправителей обычно не представляет собой проблемы, пока не понадобится выполнить устранение проблем потока почты для этого конкретного сервера. В подобном случае может понадобиться проверить настройку фильтра или временно отключить фильтрацию отправителей, чтобы определить, не блокируется ли допустимая почта от разрешенных отправителей.

Отключение фильтра отправителей на виртуальном сервере SMTP

  1. Запустите системный диспетчер Exchange: Щелкните Пуск, укажите Программы, укажите Администрирование, укажите Microsoft Exchange, а затем щелкните Системный диспетчер.

  2. В дереве консоли разверните узел Серверы, разверните нужный сервер, разверните узел Протоколы, а затем разверните узел SMTP.

  3. Щелкните правой кнопкой мыши виртуальный сервер SMTP, на котором нужно отключить фильтр, а затем щелкните Свойства.

  4. В окне <Виртуальный сервер SMTP> Свойства, на вкладке Общие, щелкните Дополнительно.

  5. В окне Дополнительно выберите IP-адрес, для которого нужно отключить фильтр, а затем щелкните Изменить.

  6. В окне Идентификация, чтобы отключить фильтр, снимите флажок Применить фильтр отправителей.

  7. Если используется несколько виртуальных серверов, повторите шаги 3-6 для каждого виртуального сервера, на котором нужно отключить фильтр.

Дополнительные сведения об интеллектуальной фильтрации сообщений см. на веб-узле интеллектуального фильтра сообщений Exchange по адресу http://go.microsoft.com/fwlink/?LinkId=21607 (возможно, на английском языке).

Дополнительные сведения о настройке фильтрации и управления нежелательной почтой см. в разделе «Настройка фильтрации и управления нежелательной почтой» в руководстве по транспорту и маршрутизации сервера Exchange по адресу http://go.microsoft.com/fwlink/?LinkId=47579 (возможно, на английском языке).


Включен фильтр идентификатора отправителя
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Средство анализа Microsoft® Exchange Server Analyzer Tool направляет запрос службе каталогов Active Directory®, чтобы определить, действительно ли msExchServerBindingsFiltering проверка подлинности SMTP объекта виртуального сервера указывает на то, что включен фильтр идентификатора отправителя для экземпляра виртуального сервера SMTP.

Средство анализа Exchange Server Analyzer также направляет запрос службе каталогов Active Directory, чтобы определить, действительно ли wWWHomePage атрибут объекта Фильтр содержимого UCE содержит записи для идентификатора отправителя ID и фильтрации подключений.

Средство анализа Exchange Server Analyzer отображает предупреждение, если выполняются следующие условия:

  • Фильтрация отправителя включена на экземпляре виртуального сервера SMTP.

  • Фильтрация отправителя включена на уровне объекта Фильтр содержимого UCE.

Данное предупреждение указывает на то, что фильтрация идентификатора отправителя успешно включена. Как правило, фильтрация идентификатора отправителя не является проблемой, если вы не устраняете проблемы, связанные с обработкой сообщений на данном сервере. В этом случае может понадобиться проверка настройки фильтра или временное отключение фильтрации идентификатора отправителя для определения того, не выполняет ли он неправильную блокировку почты от нужных отправителей.

Для отключения фильтра идентификатора отправителя на виртуальном сервере SMTP

  1. Запустите диспетчер Exchange System Manager: Нажмите кнопку Пуск, выберите в меню Программы пункт Microsoft Exchange, а затем - System Manager.

  2. В дереве консоли разверните узел Серверы, разверните необходимый сервер, затем разверните Протоколы и SMTP.

  3. Щелкните правой кнопкой мыши виртуальный сервер SMTP, где необходимо отключить фильтр, и выберите пункт Свойства.

  4. В <SMTP Virtual Server> Свойства, на вкладке Общие щелкните Дополнительно.

  5. В Дополнительно выберите IP-адрес, для которого необходимо отключить фильтр, и щелкните Изменить.

  6. В разделе Идентификация снимите флажок Применить фильтрацию отправителя для отключения фильтра.

  7. При наличии нескольких виртуальных серверов повторите Шаги 3-6 для каждого виртуального сервера, на котором необходимо отключить фильтр.

Для получения дополнительных сведений об интеллектуальном фильтре сообщений см. веб-узел «Интеллектуальный фильтр сообщений Exchange» (http://go.microsoft.com/fwlink/?LinkId=21607).


Сервер, указанный в качестве общего назначения
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-10-04

Средство анализа Microsoft® Exchange Server запрашивает класс WMI Exchange_Queue, чтобы определить значение следующих атрибутов очереди SMTP на виртуальном SMTP-сервере.

LinkId | Указывает на код ссылки, содержащей очередь.
QueueId | Указывает на код очереди.
QueueName | Указывает на имя очереди.
VirtualMachine | Указывает на имя виртуальной машины, содержащей очередь.
VirtualServerName | Указывает на имя виртуального сервера, на котором находится очередь.
MessageCount | Указывает на количество сообщений в очереди.

Средство анализа сервера Exchange Server использует полученные данные для запроса у класса WMI Exchange_QueuedSMTPMessage значений следующих атрибутов сообщений из очереди:

Recipients | Указывает на получателей сообщения.
Received | Указывает на полученную метку времени сообщения.
MessageId | Указывает на код сообщения, находящегося в очереди.
StateRetry | Указывает, что происходит повторная передача сообщения, которое не было удачно доставлено.

В завершении, средство анализа Exchange Server использует полученные данные для запроса службы каталогов Active Directory® для получения следующих значений объекта Recipient. Затем средство анализа Exchange Server определяет, является ли получателем пользователь, группа рассылки, общая папка или хранилище общих папок.

distinguishedName | Указывает на отличительное имя объекта.
msExchHomeServerName | Указывает на сервер, к которому подключен получатель.
homeMDB | Указывает на хранилище почтовых ящиков получателя.

Если средство анализа Exchange Server определяет, что как минимум у 25 процентов сообщений, скопившихся в очереди, в полях To: (Кому) или Cc: (Копия) указаны получатели, находящиеся на одном и том же сервере, то отображается предупреждение.

Если средство анализа Exchange Server определяет, что как минимум у 50 процентов сообщений, скопившихся в очереди, в полях To: (Кому) или Cc: (Копия) указаны получатели, находящиеся на одном и том же сервере, то отображается сообщение об ошибке.

Такое предупреждение или сообщение об ошибке означает, что указанный сервер является общим назначением сообщений, скопившихся в очереди SMTP.

Для решения данной проблемы следует проверить сервер на наличие ошибок конфигурации и другие неполадки, которые могли вызвать скопление сообщений в очереди:

  • Убедитесь, что атрибуты объекта сервера в службе Active Directory установлены правильно и содержат правильные значения.

  • Убедитесь в правильности параметров разрешений объекта сервера в службе Active Directory.

  • Если сервер содержит объект пользователя специального применения, т. е. назначенного получателя журнала, проверьте конфигурации службы или компонентов, к которым относится объект пользователя, на правильность конфигурации.

  • Проверьте наличие нежелательной почты или вирусных атак, направленных против общей папки.

Дополнительные сведения об устранении неполадок, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел «Устранение проблем, связанных с потоком почты и протоколом SMTP» в руководстве по транспортировке и маршрутизации сервера Exchange по адресу http://go.microsoft.com/fwlink/?LinkID=67875 (на английском языке).

  • Статья 823489 базы знаний Майкрософт «Использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003» по адресуhttp://go.microsoft.com/fwlink/?linkid=3052&kbid=823489 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

Дополнительные сведения о влиянии ограничения групп рассылок на поток почты сервера Exchange см. в следующих статьях базы знаний Майкрософт:

  • Статья 895407 «В Exchange Server 2003 доставка сообщений в локальные и внешние почтовые ящики неожиданно замедляется после настройки ограничений по доставке на основе групп рассылок» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 329171 «XADM: доставка почты задерживается, если получатели настроены с ограничениями по доставке на основе членства в группе» по адресу: http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 839949 «Устранение неполадок почтового транспорта и групп рассылок в Exchange 2000 Server и Exchange Server 2003» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 812298 «Доставка почты замедляется после настройки ограничений по доставке на основе списка рассылки» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298 (эта ссылка может указывать на содержимое полностью или частично на английском языке).


Регистрация получателя не найдена
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-01-11

Средство анализа Microsoft® Exchange Server запрашивает метабазу сервера Microsoft Internet Information Server (IIS) для получения списка привязок получателей событий транспорта протокола SMTP. Средство анализа Exchange Server определяет количество стандартных привязок событий в соответствии со списком, предварительно созданным в средстве анализа Exchange Server. Для каждой привязки средство анализа Exchange Server проверяет сведения о регистрации компонента Component Object Model (COM) в следующей ветке реестра:

HKEY_CLASSES_ROOT\CLSID\

Средство анализа Exchange Server отображает предупреждение при наличии следующих условий.

  • Привязка получателя события транспорта найдена в метабазе.

  • Соответствующая регистрация компонента COM отсутствует в реестре.

Событие транспорта SMTP происходит при передаче данных службе SMTP или от нее. Все сообщения передаются событиями. Включая входящие и исходящие сообщения X.400 и RPC. Общим примером события входящего транспорта является получение сообщения службой SMTP через сеть или каталог раскладки SMTP. При наступлении этого события транспорта источник события уведомляет получателя события транспорта, каждый из который может выполнить какие-либо действия в зависимости от данных сообщения. После передачи данных сообщения получателю система не будет выполнять никакие другие действия до выполнения получателем своих действий и возврата сообщения. Получатель при выполнении этого действия имеет монопольное управление состоянием и данными сообщения.

Отсутствие регистрации компонентов COM для привязок получателей может вызвать проблемы в почтовом потоке. При возникновении признаков проблем в почтовом потоке, например организации очереди сообщений, необходимо повторно зарегистрировать получатей событий транспорта.

Чтобы повторно зарегистрировать получателей событий транспорта

  1. В Microsoft Exchange Server откройте окно командной строки и перейдите к папке \Program Files\Exchsrvr\Bin.

  2. Для повторной регистрации получателей событий транспорта наберите следующие команды:

    regsvr32 /i exps.dll

    regsvr32 /i miscat.dll

    regsvr32 /i onsubmit.dll

    regsvr32 /i peexch50.dll

    regsvr32 /i phatcat.dll

    regsvr32 /i protolog.dll

    regsvr32 /i reapi.dll

    regsvr32 /i regsinks.dll

    regsvr32 /i tranmsg.dll

    regsvr32 /i turflist.dll

    regsvr32 /i xlsasink.dll

    regsvr32 /i msgfilter.dll

  3. Еще раз запустите средство анализа Exchange Server, чтобы убедиться, что предупреждения больше не отображаются. Если предупреждения о регистрации получателя события продолжаются появляться и присутствуют проблемы в почтовом трафике, обратитесь в службу поддержки продуктов корпорации Майкрософт (PSS).

Дополнительные сведения о привязках получателей событий транспорта см. в следующих источниках Exchange.

  • Статья 258224 базы знаний корпорации Майкрософт « XCON: Определение количества зарегистрированных получателей событий транспорта» (http://go.microsoft.com/fwlink/?linkID=3052&kbid=258224).

  • Раздел «Структура службы SMTP» технического руководства для Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=58876)


На виртуальном сервере SMTP установлен промежуточный узел
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, присутствует ли атрибут msExchSmtpSmartHost на конкретном виртуальном сервере SMTP. Если анализатор сервера Exchange обнаруживает атрибут msExchSmtpSmartHost, выводится предупреждение.

Не рекомендуется настраивать промежуточный узел на виртуальном сервере SMTP. Вместо этого следует создать SMTP-соединитель и настроить промежуточный узел в этом соединителе.

В Exchange Server 2003 настройка параметров доставки почты Интернета выполняется с помощью мастера почты Интернета. Дополнительные сведения см. в разделе «How to Use Internet Mail Wizard» (Работа с мастером почты Интернета в руководстве Exchange Server Transport and Routing Guide (http://go.microsoft.com/fwlink/?LinkId=50099) (Руководство по транспорту и маршрутизации в Exchange Server).

Дополнительные сведения о создании SMTP-соединителей см. в разделе «How to Create an SMTP Connector» (Инструкции по созданию SMTP-соединителя) в руководстве Exchange Server Transport and Routing Guide (http://go.microsoft.com/fwlink/?LinkId=50100) (Руководство по транспорту и маршрутизации в Exchange Server).


Параметр реестра AdditionalPoolThreadsPerProc для SMTP был задан вручную
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-01-17

Чтобы определить, были ли вручную заданы дополнительные потоки в пуле, анализатор сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\AdditionalPoolThreadsPerProc

Если анализатор сервера Exchange обнаруживает, что параметр присутствует и ему присвоено значение, выводится сообщение о том, что текущая конфигурация отличается от заданной по умолчанию.

В SMTP доступно пять рабочих очередей, в которых используется пул потоков, известных как потоки ATQ. По умолчанию две из этих очередей используют до 90 процентов доступных потоков. Этот пул потоков находится в совместном использовании процессом, принимающим запросы POP и IMAP. Таким образом, в сценарии средней или высокой загрузки может возникнуть ситуация запрета доступа к ресурсам для служб POP и IMAP со стороны SMTP.

Можно зарезервировать адекватное число потоков для POP и IMAP, ограничив процент потоков, который может использоваться SMTP. Чтобы внести это изменение, следует увеличить общее число потоков, доступное для служб IIS. Единственный минус такого подхода — повышенная загрузка памяти в связи с добавлением новых потоков.

Существует два значения реестра, с помощью которых можно управлять процентом потоков, выделенным для SMTP, а также количеством дополнительных потоков на один процессор:

Расположение: HKLM\System\CurrentControlSet\Services\SMTPSVC\Parameters

Значение: AdditionalPoolThreadsPerProc

Тип: REG_DWORD

Расположение: HKLM\System\CurrentControlSet\Services\SMTPSVC\Parameters

Значение: MaxPercentPoolThreads

Тип: REG_DWORD

Оба эти значения реестра следует настроить на компьютерах серверов Exchange кластера в том случае, если высокая активность по SMTP приводит к сбою POP3, IMAP4 или обоих ресурсов. Чтобы рассчитать оптимальное значение для кластера, можно воспользоваться следующими формулами:

Значение реестра | Формула
AdditionalPoolThreadsPerProc | ((9 / (MaxPercentPoolThreads/100)) - 4) / 2
MaxPercentPoolThreads | 90 / (2 * число виртуальных серверов протокола)

Например, в кластере серверов Exchange с двумя виртуальными серверами протокола формула для параметра MaxPercentPoolThreads будет 90 / (2*2) = 22. Если при расчете значения MaxPercentPoolThreads получилась десятичная дробь, следует округлить это число до ближайшего целочисленного значения. Если при расчете значения AdditionalPoolThreadsPerProc итоговое значение превышает 200, требуется присвоить это итоговое значение дополнительному параметру реестра:

Расположение: HKLM\System\CurrentControlSet\Services\InetInfo\Parameters\

Значение: PoolThreadLimit

Тип: REG_DWORD

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы оптимально настроить параметры кластера Exchange

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Создайте параметр реестра с типом DWORD и названием AdditionalPoolThreadsPerProc и задайте для этого параметра нужное значение, воспользовавшись приведенными выше формулами.

  4. Создайте параметр реестра с типом DWORD и названием MaxPercentPoolThreads и задайте для этого параметра нужное значение, воспользовавшись приведенными выше формулами.

  5. Закройте редактор реестра и перезапустите службу администрирования IIS, чтобы изменения вступили в силу.

Перед редактированием реестра, а также для получения сведений о редактировании реестра см. статью 256986 базы знаний Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об отдельных неполадках кластерного ресурса, описанных в данной статье, см. статью 281868 базы знаний Майкрософт «XADM: POP\IMAP4 Virtual Servers Repeatedly Fail Over Under High Load» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=281868).


Приемник архива SMTP:набор заголовков архива P1
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange Server считывает следующие разделы реестра, чтобы определить, был ли установлен и включен приемник архива SMTP:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Dump P1

Если анализатор сервера Exchange обнаруживает, что значение параметра Dump P1 больше 0, на экране отображается сообщение о нестандартной конфигурации.

Значение 0 означает, что архивация заголовка P1 отключена. Значение 1 означает, что архивация заголовка P1 включена. Значения, отличные от 0 или 1 не поддерживаются.

Средство приемника архива SMTP является настроенным сценарием, позволяющим архивировать все сообщения, приходящие в определенную папку сервера Exchange или исходящие из нее. По умолчанию, если приемник архива SMTP включен, все сообщения и их получатели архивируются в EML-файл, кроме получателей скрытой копии.

Заголовки P1 также называются данными «конверта». Данные конверта — это список действительных получателей, созданный Exchange при пересылке сообщения, который способствует доставке сообщений всем получателям. В отличие от заголовков P2, которые являются списком получателей, в таком виде, в каком они были представлены отправителем в полученном сообщении, данные конверта меняются при отправке в разные местоположения. Эти изменения происходят из-за расширения списка рассылки и поведения скрытого списка рассылки.

По умолчанию заголовки P1 не архивируются при установке и включении приемника архива SMTP. Как правило, архивация заголовка P1 включено только для устранения неисправностей.

Если нет необходимости архивировать заголовки P1 на этом компьютере Exchange, можно задать значение раздела реестра Dump P1 равное 0 или удалить приемник архива SMTP. При удалении приемника архива SMTP удаляются все разделы реестра, используемые приемником архива SMTP.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы отключить архивацию заголовков P1

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Дважды щелкните раздел реестра Dump P1, в поле Значение введите 0 и нажмите кнопку ОК.

  4. Закройте редактор реестра и перезапустите службу администрирования IIS, чтобы изменения вступили в силу.

Чтобы удалить приемник архива SMTP

  1. Нажмите кнопку Пуск, выберите команду Выполнить, введите cmd и нажмите кнопку ОК.

  2. В папке C:\Program Files\Exchsrvr\bin введите cscript archivesink_setup.vbs затем нажмите клавишу ENTER.

  3. Введите cscript archivesink_setup.vbs uninstall Virtual Server ID, где Virtual Server ID — это номер виртуального сервера на виртуальном сервере, где установлен приемник архива SMTP.

  4. Закройте окно командной строки и перезапустите службу администрирования IIS, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Сведения об установке и настройке приемника архива SMTP в Exchange Server 2003 см. в статье 871110 базы знаний Майкрософт, посвященной установке и использованию средства приемника архива в Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110).

Дополнительные сведения о средстве приемника архива SMTP см. в статье 307798 базы знаний Майкрософт, описывающей средство приемника архива, доступное в пакете обновления 2 (SP2) (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Сведения о развертывании полного решения ведения журнала для соответствия требованиям см. на странице, посвященной ведению журнала в Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).


Приемник архива SMTP включен
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, был ли установлен и включен приемник архива SMTP, анализатор сервера Microsoft® Exchange Server проверяет следующую запись реестра:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable Smtp Messages

Если анализатор сервера Exchange обнаружит, что значение Enable Smtp Messages больше 0, выводится сообщение о наличии конфигурации, не являющейся заданной по умолчанию.

Значение 0 указывает, что приемник архива SMTP отключен. Значение 1 указывает, что приемник архива SMTP включен. Значения, отличные от 0 и 1, не поддерживаются.

Средство приемника архива SMTP — это пользовательский сценарий, который включает архивирование всех сообщений, входящих и перемещаемых из определенной папки на сервере Exchange. По умолчанию, когда приемник архива SMTP включен, все сообщения и их получатели, за исключением получателей скрытых копий, архивируются в файле .eml.

По умолчанию при включенном архивировании SMTP с помощью приемника архива SMTP это событие вызывают все сообщения, отправленные для транспортировки по протоколу SMTP хранилищем Exchange или любыми другими приемниками. Теоретически это событие может быть вызвано один раз для каждого сообщения и может быть архивировано только один раз. Событие OnMessageSubmission вызывается перед событиями маршрутизации и классификатора. Поэтому такие сообщения называют сообщениями PreCat («до классификатора»). По умолчанию сообщения архивируются в связи с этим событием, если установлено средство приемника архива SMTP. Сообщения, архивированные при этом событии, содержат префикс в имени файла: ARCH_случайный номер.xml.

Чтобы на данном компьютере Exchange не архивировать сообщения, можно для раздела реестра Enable Smtp Messages задать значение 0 или отменить установку приемника архива SMTP. При отмене установки приемника архива SMTP все используемые им разделы реестра удаляются.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы отключить приемник архива SMTP

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите в следующий раздел реестра: HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Дважды щелкните параметр реестра Enable Smtp Messages, в поле Значение введите 0 и нажмите кнопку ОК.

  4. Выйдите из редактора реестра и перезагрузите службу администратора IIS, чтобы изменения вступили в силу.

Чтобы отменить установку приемника архива SMTP

  1. Нажмите кнопку Пуск, выберите команду Выполнить, введите cmd и нажмите кнопку ОК.

  2. Перейдите в папку C:\Program Files\Exchsrvr\bin, введите cscript archivesink_setup.vbs и нажмите клавишу ВВОД.

  3. Введите cscript archivesink_setup.vbs uninstall Virtual Server ID, где Virtual Server ID представляет номер виртуального сервера, на котором установлен приемник архива SMTP.

  4. Закройте окно командной строки и перезагрузите службу администратора IIS, чтобы изменения вступили в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения об установке и настройке приемника архива SMTP в Exchange Server 2003 см. в статье базы знаний 871110 «How to install and use the Archive Sink utility in Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110) (Инструкции по установке и использованию служебной программы приемника архива в Exchange Server 2003).

Дополнительные сведения об установке и настройке приемника архива SMTP в Exchange Server 2000 см. в статье базы знаний 307798 «The Archive Sink utility is available in Service Pack 2» (Служебная программа приемника архива, доступная в пакете обновления 2 (SP2) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Дополнительные сведения о развертывании комплексного решения по ведению журнала в целях обеспечения соответствия нормативным требованиям см. в статье Journaling with Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581) (Ведение журнала с помощью Exchange Server 2003).


Приемник архива SMTP:набор после классификации
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, установлен ли и включен приемник архива SMTP, анализатор приложения Microsoft® Exchange Server считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable PostCat

Если анализатор сервера Exchange обнаруживает, что значение параметра Enable PostCat больше 0, выводится сообщение о том, что конфигурация отличается от заданной по умолчанию.

Значение, равное 0, указывает, что архивирование сообщений после классификации отключено. Значение, равное 1, указывает, что архивирование сообщений после классификации включено. Значения, отличные от 0 или 1 не поддерживаются.

Средство приемника архива SMTP является настроенным сценарием, позволяющим архивировать все сообщения, приходящие в определенную папку сервера Exchange или исходящие из нее. По умолчанию, если приемник архива SMTP включен, все сообщения и их получатели архивируются в EML-файл, кроме получателей скрытой копии.

Если для параметра Enable PostCat установлено значение 1, после классификации сообщений они архивируются. Сообщения могут запускать это событие неоднократно, однако такое возможно только в том случае, если сообщение классифицировано, поставлено в очередь, а затем повторно пронумеровано. Сообщения, которые архивируются для этого события, содержат имя файла префикса ARCH_POSTCAT_случайное число.xml.

Если на данном компьютере Exchange не нужно архивировать сообщения после классификации, нужно задать для раздела реестра Enable PostCat значение 0. Если архивация на данном компьютере не выполняется, можно удалить приемник архива SMTP. При удалении приемника архива SMTP удаляются все разделы реестра, используемые приемником архива SMTP.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы отключить архивацию сообщений после классификации

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Дважды щелкните раздел реестра Enable PostCat, введите 0 в поле Значение, а затем нажмите кнопку ОК.

  4. Закройте редактор реестра и перезапустите службу администрирования IIS, чтобы изменения вступили в силу.

Чтобы удалить приемник архива SMTP

  1. Нажмите кнопку Пуск, выберите команду Выполнить, введите cmd и нажмите кнопку ОК.

  2. В папке C:\Program Files\Exchsrvr\bin введите cscript archivesink_setup.vbs затем нажмите клавишу ENTER.

  3. Введите cscript archivesink_setup.vbs uninstall Virtual Server ID, где Virtual Server ID — это номер виртуального сервера на виртуальном сервере, где установлен приемник архива SMTP.

  4. Закройте окно командной строки и перезапустите службу администрирования IIS, чтобы изменения вступили в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт «Description of the Microsoft Windows Registry» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения об установке и настройке приемника архива SMTP в Exchange Server 2003 см. в статье 871110 базы знаний Майкрософт «How to install and use the Archive Sink utility in Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829) (Инструкции по установке и использованию служебной программы приемника архива в Exchange Server 2003).

Дополнительные сведения об установке и настройке средства приемника архива см. статье 307798 базы знаний Майкрософт «The Archive Sink utility is available in Service Pack 2» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798) (Служебная программа приемника архива, доступная в пакете обновления 2).

Сведения о развертывании полного решения ведения журнала для обеспечения соответствия требованиям законодательства см. в документе Journaling with Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581) (Ведение журнала в Exchange Server 2003).


SMTP Archive Sink:архивация сообщений до классификации
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, установлено ли и включено ли средство SMTP Archive Sink, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable PreCat

Если анализатор сервера Exchange обнаруживает, что значение Enable PreCat больше 0, выводится сообщение о наличии конфигурации, не являющейся заданной по умолчанию.

Значение 0 показывает, что архивация сообщений до классификации отключена. Значение 1 показывает, что архивация сообщений до классификации включена. Значения, отличные от 0 и 1 не поддерживаются.

Средство SMTP Archive Sink представляет собой пользовательский сценарий, позволяющий выполнять архивацию всех сообщений, поступающих в определенную папку на сервере Exchange или перемещаемых из нее. По умолчанию, когда средство SMTP Archive Sink включено, выполняется архивация всех сообщений и их получателей (за исключением получателей скрытой копии) в файл с расширением EML.

Все сообщения, отправленные для транспортировки по протоколу SMTP (Simple Mail Transfer Protocol), с использованием хранилища Exchange или любых других приемников, запускают это событие. Теоретически это событие может быть сгенерировано один раз для каждого сообщения и заархивировано только один раз. Событие OnMessageSubmission создается до событий маршрутизации и классификации. Поэтому эти сообщения называют сообщениями до классификации (PreCat). Сообщения для этого события архивируются по умолчанию, когда установлена служебная программа SMTP Active Sink. В сообщениях, которые архивируются для этого события, содержится префиксное имя файла ARCH_произвольное число.xml.

Если на этом компьютере Exchange не требуется выполнять архивацию сообщений до классификации, можно установить для раздела реестра Enable PreCat значение 0. Если на данном компьютере вообще не требуется выполнять архивацию, можно удалить служебную программу SMTP Archive Sink. При удалении SMTP Archive Sink удаляются все разделы реестра, используемые служебной программой SMTP Archive Sink.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» средства Regedit.exe или Regedt32.exe.

Чтобы отключить архивацию сообщений до классификации

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Дважды щелкните раздел реестра Enable PreCat, в поле Значение введите 0 и нажмите кнопку ОК.

  4. Закройте редактор реестра и перезапустите службу администрирования IIS, чтобы изменения вступили в силу.

Чтобы удалить SMTP Archive Sink

  1. Нажмите кнопку Пуск, выберите команду Выполнить, введите cmd и нажмите кнопку ОК.

  2. В папке C:\Program Files\Exchsrvr\bin введите cscript archivesink_setup.vbs и нажмите клавишу ВВОД.

  3. Введите cscript archivesink_setup.vbs uninstall Virtual Server ID, где Virtual Server ID — номер виртуального сервера, на котором установлена программа SMTP Archive Sink.

  4. Закройте окно командной строки и перезапустите службу администрирования IIS, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Для получения дополнительных сведений о настройке SMTP Archive Sink в Exchange Server 2003 см. статью базы знаний 871110, посвященную установке и использованию служебной программы Archive Sink в Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110).

Для получения дополнительных сведений о настройке SMTP Archive Sink в Exchange 2000 Server см. статью базы знаний 307798, посвященную описанию служебной программы, доступной в пакете обновления 2 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798).

Для получения дополнительных сведений о развертывании всестороннего решения ведения журналов для обеспечения соответствия требованиям см. статью, посвященную ведению журналов при использовании Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).


Приемник архива SMTP:архивируются системные сообщения
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, был ли установлен и включен приемник архива SMTP, средство анализатора сервера Microsoft® Exchange считывает следующие разделы реестра:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Archive System Messages

Если анализатор сервера Exchange обнаружит, что значение параметра Archive System Messages больше 0, на экран будет выведено сообщение о нестандартной конфигурации.

Значение равное 0 указывает, что системные сообщения не архивируются. Значение равное 1 указывает, что системные сообщения архивируются. Значения, отличные от 0 и 1, не поддерживаются.

Средство приемника архива SMTP является настроенным сценарием, позволяющим архивировать все сообщения, приходящие в определенную папку сервера Exchange или исходящие из нее. По умолчанию, если приемник архива SMTP включен, все сообщения и их получатели архивируются в EML-файл, кроме получателей скрытой копии.

Если нет необходимости архивировать системные сообщения на этом компьютере Exchange, можно установить значение раздела реестра Archive System Messages равное 0. Если на этом компьютере вообще не требуется выполнять архивирование, можно удалить приемник архива SMTP. При удалении приемника архива SMTP удаляются все разделы реестра, используемые приемником архива SMTP.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы отключить архивирование системных сообщений

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Дважды щелкните раздел реестра Archive System Messages, в поле Значение введите 0 и нажмите кнопку ОК.

  4. Закройте редактор реестра и перезапустите службу администрирования IIS, чтобы изменения вступили в силу.

Чтобы удалить приемник архива SMTP

  1. Нажмите кнопку Пуск, выберите команду Выполнить, введите cmd и нажмите кнопку ОК.

  2. В папке C:\Program Files\Exchsrvr\bin введите cscript archivesink_setup.vbs затем нажмите клавишу ВВОД.

  3. Введите cscript archivesink_setup.vbs uninstall Virtual Server ID, где Virtual Server ID — это номер виртуального сервера на виртуальном сервере, где установлен приемник архива SMTP.

  4. Закройте окно командной строки и перезапустите службу администрирования IIS, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Сведения об установке и настройке приемника архива SMTP в Exchange Server 2003 см. в статье 871110 базы знаний Майкрософт, посвященной установке и использованию средства приемника архива в Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110).

Дополнительные сведения о средстве приемника архива SMTP см. в статье 307798 базы знаний Майкрософт, описывающей средство приемника архива, доступное в пакете обновления 2 (SP2) (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Сведения о развертывании полного решения ведения журнала для соответствия требованиям см. на странице, посвященной ведению журнала в Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).


Недопустимые данные SMTP были записаны в сжатую папку
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс Win32_Directory, чтобы определить значение ключа Compressed для папки недопустимых данных SMTP. Если анализатор сервера Exchange обнаруживает, что для ключа Compressed установлено значение True, выводится предупреждение.

Когда сообщения приходят на компьютер Exchange по службе SMTP, данные записываются на жесткий диск в виде EML-файлов. По умолчанию эти файлы хранятся в папке <диск>:\Program Files\Exchsrvr\Mailroot в том же разделе, в котором был установлен Exhange. Если в папке, в которой хранятся недопустимые данные SMTP, включена возможность сжатия, производительность Exchange будет существенно снижена. Поэтому сжатие папки, в которой содержатся недопустимые данные SMTP, не поддерживается.

Если получено это предупреждение, необходимо выключить сжатие папки, в которой содержатся недопустимые данные SMTP, или переместить недопустимые данные SMTP в несжатую папку.

Корпорация Майкрософт не поддерживает хранение файлов данных Exchange в сжатых томах. При хранении файлов данных Exchange на сжатом томе дополнительные служебные операции существенно сказываются на производительности Exchange. К файлам данных Exchange относятся все следующие файлы:

  • EDB-файлы

  • STM-файлы

  • LOG-файлы

  • DAT-файлы

  • EML-файлы

  • CHK-файлы

Чтобы отключить сжатие файлов для заданной папки

  1. Щелкните правой кнопкой мыши папку, для которой нужно отключить сжатие файлов, и выберите команду Свойства.

  2. На вкладке Общие щелкните Дополнительно.

  3. В диалоговом окне Дополнительные атрибуты снимите флажок Сжимать содержимое для экономии места на диске и нажмите кнопку OK.

Чтобы переместить папку с недопустимыми данными в Exchange 2000 Server или Exchange Server 2003

  1. Откройте диспетчер Exchange.

  2. Щелкните узел Административные группы, разверните административную группу, разверните узел Серверы, разверните необходимый сервер, затем узел Протоколы, затем SMTP.

  3. Щелкните правой кнопкой мыши виртуальный SMTP-сервер и щелкните Стоп.

  4. Щелкните правой кнопкой мыши виртуальный SMTP-сервер и щелкните Свойства.

  5. На вкладке Сообщения рядом с окном ??Каталог недопустимой почты?? щелкните Обзор, затем введите новое местоположение папки очереди.

  6. Нажмите кнопку ОК.

  7. Щелкните правой кнопкой мыши виртуальный SMTP-сервер и выберите Пуск.

Дополнительные сведения о перемещении корневой папки почты см. в статье 822933 базы знаний Майкрософт, посвященной изменению местоположения корневой папки почты SMTP в Exchange 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).


SMTP-данные BadMail записываются в раздел, формат которого отличен от NTFS
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Анализатор Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Directory, чтобы определить значение ключа FSName для SMTP-каталога BadMail в Exchange. Если анализатор сервера Exchange обнаружит, что значение ключа FSName не равно NTFS, на экран будет выведено предупреждение.

Корпорация Майкрософт не поддерживает хранение файлов данных Exchange на томах, которые отформатированы в файловой системе, отличной от NTFS. К файлам данных Exchange относятся следующие файлы:

  • EDB-файлы,

  • STM-файлы,

  • LOG-файлы,

  • DAT-файлы,

  • EML-файлы.

Если выводится это предупреждение, необходимо переместить SMTP-каталог BadMail в папку на диске с файловой системой NTFS. Или если диск, на котором хранится каталог BadMail, имеет формат FAT, можно преобразовать этот диск в формат NTFS с помощью средства командной строки convert.exe.

Чтобы переместить SMTP-каталог BadMail в другую папку

  1. Откройте диспетчер Exchange.

  2. Щелкните Административные группы, разверните свою административную группу, разверните узел Серверы, разверните свой сервер, разверните узел Протоколы, а затем разверните узел SMTP.

  3. Щелкните правой кнопкой мыши свой виртуальный SMTP-сервер и выберите в контекстном меню команду Остановить.

  4. Щелкните правой кнопкой мыши свой виртуальный SMTP-сервер и выберите в контекстном меню пункт Свойства.

  5. На вкладке Сообщения, рядом с полем Каталог BadMail щелкните Обзор, а затем введите путь к новому местоположению папки BadMail.

  6. Нажмите кнопку ОК.

  7. Щелкните правой кнопкой мыши свой виртуальный SMTP-сервер и выберите в контекстном меню команду Пуск.

Дополнительные сведения о перемещении папки Mailroot см. в базе знаний Майкрософт в статье 822933, содержащей инструкции по изменению местоположения SMTP-папки Mailroot в Exchange 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).

Если диск, на котором хранятся файлы, имеет формат FAT, то вместо выполнения описанной выше процедуры можно преобразовать этот диск в формат NTFS с помощью средства командной строки convert.exe. Сведения о преобразовании раздела FAT в раздел NTFS с помощью средства командной строки convert.exe см. в базе знаний Майкрософт в статье 214579, содержащей инструкции по преобразованию раздела в файловую систему NTFS с помощью средства Convert.exe (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579).


Недопустимые данные SMTP были записаны в зашифрованную папку
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс Win32_Directory, чтобы определить значение ключа Encrypted для папки недопустимых данных SMTP. Если анализатор сервера Exchange обнаруживает, что для ключа Encrypted установлено значение True, выводится предупреждение.

Когда сообщения приходят на компьютер Exchange по службе SMTP, данные записываются на жесткий диск в виде EML-файлов. По умолчанию эти файлы хранятся в папке <диск>:\Program Files\Exchsrvr\Mailroot в том же разделе, в котором был установлен Exhange. Если папка, в которой хранятся недопустимые данные SMTP, зашифрована, производительность Exchange будет существенно снижена. Поэтому шифрование папки, в которой содержатся недопустимые данные SMTP, не поддерживается.

Если получено это предупреждение, необходимо выключить шифрование папки, в которой содержатся недопустимые данные SMTP, или переместить недопустимые данные SMTP в незашифрованную папку.

Microsoft не поддерживает хранение файлов данных Exchange на томе с шифрованной файловой системой (EFS). При хранении файлов данных Exchange на зашифрованном томе дополнительные накладные расходы существенно замедляют производительность сервера Exchange. К файлам данных Exchange относятся следующие файлы:

  • EDB-файлы

  • STM-файлы

  • LOG-файлы

  • DAT-файлы

  • EML-файлы

  • CHK-файлы

В целях обеспечения безопасности файлов данных Exchange рекомендуется запретить неавторизованный доступ к компьютеру Exchange и использовать для шифрования данных сообщения формат S/MIME.

Чтобы устранить эту ошибку, необходимо отключить шифрование для папки, в которой хранятся недопустимые данные, или переместить эту папку в местоположение, где отключено шифрование.

Чтобы отключить шифрование файлов для указанной папки

  1. Щелкните правой кнопкой мыши папку, для которой нужно отключить шифрование файлов, и выберите команду Свойства.

  2. На вкладке Общие щелкните Дополнительно.

  3. В диалоговом окне Дополнительные атрибуты снимите флажок Шифровать содержимое для обеспечения безопасности данных, а затем нажмите кнопку ОК.

Чтобы переместить папку с недопустимыми данными в Exchange 2000 Server или Exchange Server 2003

  1. Откройте диспетчер Exchange.

  2. Щелкните узел Административные группы, разверните административную группу, разверните узел Серверы, разверните необходимый сервер, затем узел Протоколы, затем SMTP.

  3. Щелкните правой кнопкой мыши виртуальный SMTP-сервер и щелкните Стоп.

  4. Щелкните правой кнопкой мыши виртуальный SMTP-сервер и щелкните Свойства.

  5. На вкладке Сообщения рядом с окном ??Каталог недопустимой почты?? щелкните Обзор, затем введите новое местоположение папки очереди.

  6. Нажмите кнопку ОК.

  7. Щелкните правой кнопкой мыши виртуальный SMTP-сервер и выберите Пуск.

Дополнительные сведения о перемещении корневой папки почты см. в статье 822933 базы знаний Майкрософт, посвященной изменению местоположения корневой папки почты SMTP в Exchange 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).

Дополнительные сведения о файлах данных сервера Exchange и шифрованной файловой системе см. в статье 834638 базы знаний Майкрософт «Information about the storage of data files on an encrypted volume in Exchange Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638) (Сведения о хранении файлов данных на зашифрованном томе в Exchange Server).

Сведения об обеспечении безопасности сообщений в Microsoft Exchange Server 2003 см. в руководстве по безопасности сообщений в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=47574).


Значение реестра CatRetryMinutes для SMTP отличается от заданного по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, была ли изменена применяемая по умолчанию конфигурация управления очередями SMTP, анализатор сервера Microsoft® Exchange Server читает следующий раздел реестра:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Если анализатор сервера Exchange обнаруживает, что параметр CatRetryMinutes реестра существует, он выводит на экран сообщение о наличии нестандартной конфигурации.

Рекомендуется изменять стандартные значения управления очередями только после полного анализа необходимости этих изменений. Значения по умолчанию были тщательно подобраны для оптимальной производительности в большинстве сред. Общая рекомендация — выявить основную причину проблемы, вместо изменения параметров очередей на сервере Exchange.

Анализатор сервера Exchange выводит отчет об этой конфигурации только для сведения. Никаких действий выполнять не требуется.

Дополнительные сведения об очередях SMTP в Exchange см. в разделе блога группы разработчиков Microsoft Exchange «Explaining the Mysterious SMTP Advanced Queuing Engine» (Объяснение таинств подсистемы расширенного управления очередями SMTP) (http://go.microsoft.com/fwlink/?LinkId=48585).


Предупреждение конфигурации SMTP
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-03

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, отличается ли значение атрибута msExchSmtpMaxMessageSize от заданного по умолчанию значения 0. По умолчанию в атрибуте msExchSmtpMaxMessageSize задан неограниченный размер сообщений.

Анализатор сервера Exchange выводит предупреждение, если выполнены следующие условия:

  • Значение атрибута msExchSmtpMaxMessageSize отличается от 0.

  • Exchange выполняется не под управлением ОС Microsoft Windows® Small Business Server 2003.

Атрибут msExchSmtpMaxMessageSize задает максимально допустимый размер одного отправляемого или получаемого SMTP-сообщения. С точки зрения безопасности рекомендуется ограничить максимально допустимый размер SMTP-сообщений, которые могут быть отправлены в Интернет или получены из Интернета. Однако в отношении внутренних SMTP-сообщений, например передаваемых между серверами Exchange в одной организации, рекомендуется оставить для атрибута msExchSmtpMaxMessageSize значение 0.

Внутри организации SMTP-сообщения используются в Exchange для выполнения таких задач, как репликация общих папок. Если в атрибуте msExchSmtpMaxMessageSize установлен слишком малый размер, это может вызвать проблемы репликации общих папок и другие сбои доставки сообщений внутри организации.

Если данный сервер Exchange является сервером-плацдармом, который передает SMTP-сообщения в Интернет или из Интернета, это предупреждение можно проигнорировать. Если сервер Exchange обрабатывает внутренние SMTP-сообщения, следует вернуть для атрибута msExchSmtpMaxMessageSize значение по умолчанию 0.

Примечание.
Если установлен слишком малый предельный размер сообщения, может стать недоступна репликация автономной адресной книги между компьютерами серверами Exchange. Дополнительные сведения см. в статье 326154 базы знаний Майкрософт «You cannot download the offline address book in Microsoft Outlook in Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326154) (Невозможно загрузить автономную адресную книгу в Microsoft Outlook на сервере Exchange 2000 Server).
Чтобы просмотреть и настроить максимальный размер SMTP-сообщения

  1. В системном диспетчере Exchange последовательно раскройте элементы Серверы, сервер Exchange, Протоколы и «SMTP».

  2. Щелкните правой кнопкой мыши виртуальный SMTP-сервер, например виртуальный SMTP-сервер по умолчанию, а затем выберите команду Свойства.

  3. Откройте вкладку Сообщения.

  4. Чтобы вернуться к значению по умолчанию 0, снимите флажок Ограничить размер сообщения следующим (КБ):. Можно также оставить этот флажок установленным и указать нужное значение.

  5. Нажмите кнопку ОК, чтобы сохранить внесенные изменения и закрыть диалоговое окно Свойства виртуального SMTP-сервера.

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • 266686, «XCON: How to Configure a SMTP Virtual Server Part 1» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) (Инструкции по настройке виртуального SMTP-сервера, часть 1).

  • 268163, «XCON: How to Configure a SMTP Virtual Server Part 2» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (Инструкции по настройке виртуального SMTP-сервера, часть 2).


SMTP-соединитель с ограничениями по доставке, установленными группой рассылки
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-09-06

Средство анализатора сервера Microsoft® Exchange запрашивает следующие атрибуты для каждого объекта SMTP-соединителя (Simple Mail Transfer Protocol) (msExchRoutingSMTPConnector), обнаруженного в службе каталогов Active Directory®, чтобы определить, имеют ли они ограничения по доставке, установленные на основе членства в группе рассылки.

dLMemRejectPerms | Содержит имена доменов списков рассылки, членам которых не разрешено посылать почту через данный SMTP-соединитель.
dLMemSubmitPerms | Содержит имена доменов списков рассылки, членам которых разрешено посылать почту через данный SMTP-соединитель.

Если анализатор сервера Exchange определит, что существуют SMTP-соединители, для которых установлены ограничения по доставке на основе членства в группе рассылки, на экран будет выведено предупреждение.

Это предупреждение указывает, что ограничения по доставке на основе членства в группе рассылки могут влиять на интенсивность потока почты сервера Exchange.

Когда почта отправляется с помощью SMTP-соединителей, имеющих ограничения по доставке, установленные на основе членства в группах рассылки, классификатор сообщений должен развернуть структуру членства в группе рассылки, получить полный список различающихся имен членов, а затем сравнить список различающихся имен с различающимися именами отправителей в списке. Когда различающиеся имена в обоих списках совпадают, выполняется операция разрешения доступа или операция запрета доступа. Если группа рассылки вложена в другую группу рассылки, вложенная группа рассылки также разворачивается.

Чтобы устранить причины появления этого предупреждения, выполните следующие действия:

  • Создайте выделенную группу маршрутизации для ограничений соединителя и настройте ее на локальную группу маршрутизации согласно сведениям, содержащимся в базе знаний Майкрософт, в статье 329171, описывающей ситуацию, когда доставка почты задерживается, если получатели настроены с ограничениями по доставке на основе членства в группе (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • Используйте выделенный и более надежный сервер глобального каталога в качестве назначенного сервера-плацдарма для соединителя.

  • Настройте отдельные почтовые ящики, а не группы рассылки для ограничений по доставке согласно сведениям, содержащимся в базе знаний Майкрософт, в статье 812298, описывающей ситуацию, когда доставка почты замедляется после настройки ограничений по доставке на основе списка рассылки (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Рассмотрите возможность реализации фильтрации SMTP-отправителей.

  • Для серверов, на которых выполняется Microsoft Exchange Server 2003 с пакетом обновления 2 (SP2) или более поздняя версия, рассмотрите возможность реализации неиерархической проверки ограничений. Для серверов, на которых выполняются версии Exchange, предшествующие Exchange 2003 с пакетом обновления 2 (SP2), рассмотрите возможность обновления до Exchange 2003 с пакетом обновления 2 (SP2).

Дополнительные сведения

Дополнительные сведения о неиерархической проверке ограничений см. в разделе Рассмотрите возможность неиерархической проверки ограничений.

Дополнительные сведения о фильтрации SMTP-отправителей см. в разделе, описывающем включение фильтрации отправителей, в руководстве по администрированию Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=72967).

Дополнительные сведения о влиянии ограничения групп рассылок на поток почты Exchange см. в следующих статьях базы знаний Майкрософт:

  • Статья 329171, описывающая ситуацию, когда доставка почты замедляется, если получатели настроены с ограничениями по доставке на основе членства в группе (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • Статья 895407, описывающая ситуацию в Exchange Server 2003, когда доставка сообщений в локальные и во внешние почтовые ящики вопреки ожиданиям замедляется после настройки ограничений по доставке на основе групп рассылок (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • Статья 839949, описывающая устранение неполадок почтового транспорта и групп рассылок в Exchange 2000 Server и в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).


Перезапись домена SMTP включена
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить значение атрибута heuristics объекта виртуального сервера SMTP для данного сервера Exchange. Если анализатор сервера Exchange обнаруживает, что значение атрибута heuristics не равно значению по умолчанию, а именно 131072, выводится сообщение об ошибке.

Анализатор сервера Exchange отображает эту конфигурацию только для сведений. Никаких действий выполнять не требуется.

Дополнительные сведения о средстве перезаписи адреса сервера Exchange см. в описании средстве перезаписи адреса сервера Exchange (http://go.microsoft.com/fwlink/?LinkId=25932).


Нестандартное значение параметра реестра FailedMsgQRetryMinutes, относящееся к протоколу SMTP
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить, были ли изменены заданные по умолчанию конфигурации очереди SMTP:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Если анализатор сервера Exchange обнаруживает, что установлен параметр реестра FailedMsgQRetryMinutes, анализатор сервера Exchange выводит сообщение о том, что текущее значение отличается от заданного по умолчанию.

Рекомендуется изменять заданные по умолчанию значения параметров очереди только после всесторонней оценки последствий этого действия. Значения по умолчанию определены по результатам тщательного анализа и обеспечивают оптимальную производительность в большинстве сред. В целом рекомендуется устранять основные причины возникновения проблемы, а не изменять параметры организации очереди сервера Exchange.

Анализатор сервера Exchange сообщает об этой конфигурации только для сведений. Никаких действий выполнять не требуется.

Для получения дополнительных сведений об SMTP-очереди в Exchange см. ветку электронного журнала группы разработчиков Microsoft Exchange, содержащую разъяснения по загадочному расширенному модулю SMTP-очереди (http://go.microsoft.com/fwlink/?LinkId=48585).


Значение реестра SMTP LocalDeliveryMaxBatch является нестандартным
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, изменилось ли заданное по умолчанию значение LocalDeliveryMaxBatch реестра, средство анализатора сервера Microsoft® Exchange считывает следующий параметр реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\StoreDriver\Exchange\%SMTPVirtualServerInstance%.

Если анализатор сервера Exchange Server обнаружит, что значение LocalDeliveryMaxBatch реестра было создано вручную посредством изменения двоичного параметра 80 сервера Exchange, то отобразит предупреждение о нестандартной настройке.

По умолчанию значение LocalDeliveryMaxBatch реестра не создается при установке Exchange Server. Значение LocalDeliveryMaxBatch реестра может быть создано вручную после установки Exchange Server, чтобы изменить способ, каким служба банка данных Exchange осуществляет внутреннюю обработку и доставку сообщений. Сервер Exchange может столкнуться с неполадками, связанными с передачей сообщений и производительностью хранилищ, если выполняются следующие условия:

  • Значение LocalDeliveryMaxBatch реестра было создано вручную.

  • Значение LocalDeliveryMaxBatch реестра было неправильно настроено.

Рекомендуется создавать и изменять значение LocalDeliveryMaxBatch реестра только после учета всех возможных последствий. Значения по умолчанию (двоичных параметров) для сервера Exchange были тщательно подобраны для обеспечения оптимального уровня производительности в большинстве сред, в которых используется сервер Exchange. Рекомендуется искать основную причину неполадок, а не изменять поведение по умолчанию сервера Exchange Server с помощью ручной настройки реестра. Чтобы выполнить эту рекомендацию, если значение LocalDeliveryMaxBatch реестра уже существует, можно его удалить и вернуть исходную настройку двоичного параметра по умолчанию сервера Exchange.

Анализатор сервера Exchange Server отображает эту настройку только в информационных целях. Однако можно вернуть значение реестра по умолчанию, внеся соответствующие изменения в реестр.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неполадок. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы устранить причину появления этого предупреждения

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\StoreDriver\Exchange\%SMTPVirtualServerInstance%

  3. В области подробностей щелкните правой кнопкой мыши значение LocalDeliveryMaxBatch реестра, щелкните Изменить, а затем измените значение на 80. Нажмите кнопку ОК.

    Примечание.
    Чтобы удалить значение LocalDeliveryMaxBatch реестра, в области подробностей щелкните правой кнопкой мыши значение LocalDeliveryMaxBatch реестра, а затем щелкните Удалить. Подтвердите удаление значения реестра, нажав кнопку Да в диалоговом окне.

  4. Закройте редактор реестра.

  5. Перезапустите сервер Exchange.

Перед изменением реестра ознакомьтесь с тем, как следует выполнять эту процедуру. Описание соответствующих инструкций содержится в статье базы знаний Майкрософт 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о редактировании реестра Microsoft Windows см. в следующих статьях базы знаний Майкрософт:

  • 322755 — описываются инструкции по резервному копированию, изменению и восстановлению реестра в Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755);

  • 322756 — описываются инструкции по резервному копированию, изменению и восстановлению реестра в Windows XP и Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756).


Полное доменное имя экземпляра службы SMTP не соответствует имени сервера, преобразованному DNS-сервером
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-10-04

Средство анализа Microsoft® Exchange Server запрашивает метабазу сервера Microsoft IIS для получения значения атрибута msExchSmtpFullyQualifiedDomainName от объекта виртуального сервера SMTP.

Средство анализа Exchange Server также пытается отправить настроенным DNS-серверам запрос полного доменного имени сервера, на котором запущен сервер Exchange Server, от системы доменных имен. Это соединение выполняется с пользовательским обработчиком объектов, который производит разрешение имени и анализирует результаты.

Средство анализа Exchange Server сравнивает результаты двух запросов. Если значение атрибута msExchSmtpFullyQualifiedDomainName объекта виртуального сервера SMTP не соответствует полному доменному имени DNS сервера Exchange, то средство анализа Exchange Server выводит предупреждение.

Это предупреждение указывает, что значения этих атрибутов могли быть изменены вручную. Следовательно, эти измененные значения могут отрицательно влиять на поток почты на этом сервере.

Значение атрибута msExchSmtpFullyQualifiedDomainName указывает полное доменное имя виртуального SMTP-сервера, при этом сетевой протокол системы DNS должен быть в состоянии разрешить это имя.

Для значения этого атрибута должна существовать допустимая запись DNS HOST (A), чтобы серверы обмена сообщениями, пытающиеся разрешить полное доменное имя виртуального сервера SMTP, могли извлечь правильный IP-адрес и должным образом определить маршрут электронной почты.

Чтобы устранить причины этого предупреждения, определите, были ли эти значения намеренно изменены и, если были, то с какой целью. Если значения были изменены по необходимости, выполните одно из перечисленных ниже действий:

  • Измените значение атрибута msExchSmtpFullyQualifiedDomainName так, чтобы оно соответствовало полному доменному имени системы доменных имен.

  • Настройте полное доменное имя сервера Exchange Server так, чтобы оно соответствовало значению атрибута msExchSmtpFullyQualifiedDomainName.

Внимание!
Если при использовании оснастки ADSI Edit, средства LDP (ldp.exe) или другого клиента LDAP версии 3 неправильно изменить атрибуты объектов Active Directory, могут возникнуть серьезные неполадки. Для устранения этих проблем может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих продуктов. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на пользователе, внесшем эти изменения.
Обновление значения атрибута msExchSMTPFullyQualifiedDomainName

  1. Откройте диспетчер Exchange.

  2. Разверните узел Административные группы, затем разверните узел Серверы, разверните сервер Exchange, разверните узел Протоколы, после чего разверните узел SMTP.

  3. Щелкните правой кнопкой мыши виртуальный SMTP-сервер по умолчанию и в контекстном меню выберите пункт Свойства.

  4. Выберите вкладку Доставка, а затем щелкните Дополнительно.

  5. В поле полного доменного имени введите значение атрибута msExchSmtpFullyQualifiedDomainName.

  6. Нажмите кнопку ОК, чтобы сохранить изменения, затем щелкните ОК, чтобы закрыть диалоговое окно Свойства виртуального SMTP-сервера.
Настройка полного доменного имени DNS сервера Exchange Server

  1. Следуйте указаниям руководства по настройке параметров на DNS-сервере .

Дополнительные сведения о функции обратного поиска DNS на сервере Exchange см. в статье «Добавление записи ресурса в зоне DNS» по адресу http://go.microsoft.com/fwlink/?LinkId=63002 (на английском языке).

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • 266686, "XCON: инструкции из части 1 по настройке виртуального SMTP-сервера» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686 (на английском языке).

  • 268163, "XCON: инструкции из части 2 по настройке виртуального SMTP-сервера» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163 (на английском языке).

Дополнительные сведения о структуре службы SMTP см. в разделе, «Структура службы SMTP» в техническом руководстве по Exchange Server 2003 по адресу http://go.microsoft.com/fwlink/?LinkId=58876 (на английском языке).


Экземпляр SMTP без установленного отправляющего SMTP-соединителя
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-08-22

Средство анализатора сервера Microsoft® Exchange запрашивает в службе каталогов Active Directory® значение атрибута distingushedName класса объекта protocolCfgSMTPServer, чтобы вывести список всех экземпляров виртуального SMTP-сервера (Simple Mail Transfer Protocol) на указанном пользователем шлюзе Exchange.

Затем анализатор сервера Exchange запрашивает в службе Active Directory значения атрибутов msExchSourceBridgeheadServersDN и routingList для каждого найденного объекта msExchRoutingSMTPConnector, чтобы определить, установлен ли для SMTP-соединителя один из обнаруженных экземпляров виртуального SMTP-сервера в качестве его локального плацдарма для пространства внешних SMTP-адресов.

SMTP-соединитель назначает для почты изолированный маршрут. SMTP-соединители можно использовать, чтобы установить шлюз для почты из Интернета или чтобы подключиться к конкретному домену или определенной почтовой системе. Соединители позволяют определять особые параметры для назначенного маршрута почты.

Если анализатор сервера Exchange определит, что не существует SMTP-соединителей с экземпляром виртуального SMTP-сервера с заданного сервера шлюза Exchange, установленного в качестве локального сервера-плацдарма, на экран будет выведено предупреждение.

Это предупреждение означает, что серверы, отличные от заданного пользователем сервера шлюза Exchange, могут ненамеренно направить сообщения за пределы организации.

Возможно, потребуется создать SMTP-соединитель, который назначит экземпляр виртуального SMTP-сервера на указанном сервере шлюза Exchange в качестве своего плацдарма, чтобы исключить ситуацию, когда серверы, отличные от заданного пользователем сервера шлюза Exchange, могут ненамеренно направить сообщения за пределы организации.

Хотя посылать и получать почту через Интернет можно, используя лишь виртуальный SMTP-сервер, рекомендуется настроить выделенный SMTP-соединитель для маршрутизации почты через Интернет. Использование SMTP-соединителя рекомендуется, так как он предоставляет изолированный маршрут для почты, предназначенной для прохождения через Интернет. Кроме того, на SMTP-соединителе доступно больше параметров настройки, чем на виртуальном SMTP-сервере.

Дополнительные сведения об использовании SMTP-соединителей см. в базе знаний Майкрософт, в статье 294736, описывающей, в каких случаях создаются SMTP-соединители в Exchange 2000 и более поздних версиях (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=294736).

Дополнительные сведения о SMTP-соединителях см. в руководстве по транспорту и маршрутизации сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).


Значение реестра SMTP LocalRetryMinutes отличается от заданного по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, изменены ли заданные по умолчанию параметры конфигурации SMTP-очереди, анализатор сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Если анализатор сервера Exchange обнаруживает, что установлен параметр реестра LocalRetryMinutes, анализатор сервера Exchange выводит сообщение о том, что текущее значение отличается от заданного по умолчанию.

Рекомендуется изменить заданные по умолчанию значения параметров очереди только после всесторонней оценки последствий этого действия. Значения по умолчанию определены по результатам тщательного анализа и обеспечивают оптимальную производительность в большинстве сред. В целом рекомендуется устранять основные причины возникновения проблемы, а не изменять параметры организации очереди Exchange.

Анализатор сервера Exchange сообщает об изменении в конфигурации только для сведения. Никаких специальных действий выполнять не требуется.

Дополнительные сведения об SMTP-очереди в Exchange см. ветку электронного журнала группы разработчиков Microsoft Exchange "Explaining the Mysterious SMTP Advanced Queuing Engine" (http://go.microsoft.com/fwlink/?LinkId=48585) (Разъяснения по загадочному расширенному модулю организации SMTP-очереди).


Значение реестра SMTP FileCacheLifeTimeSeconds было добавлено вручную, но, возможно, в нем больше нет необходимости
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить, изменено ли значение время хранения помещенных в кэш дескрипторов файлов IIS, которое по умолчанию составляет 1 880 секунд (30 минут):

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Inetinfo\Parameters\FileCacheLifeTimeSeconds

Если анализатор сервера Exchange обнаруживает, что параметр FileCacheLifeTimeSeconds установлен и имеет другое значение, выводится сообщение о том, что конфигурация отличается от заданной по умолчанию.

Значение FileCacheLifeTimeSeconds указывает время хранения помещенных ф кэш дескрипторов файлов IIS. Дескрипторы файлов кэшируются с целью улучшения производительности, так как кэшированные дескрипторы файлов оберегают сервер от выполнения избыточных циклов процессора и ввода-вывода. Каждый раз, когда транспортный стек SMTP на компьютере с Exchange Server получает сообщение, оно направляется в файловую систему, где ожидает, пока его перенаправят в место назначения. Для записи в файловую систему транспортный стек SMTP получает файловый дескриптор, а затем передает сообщение в этот дескриптор. Каждый дескриптор требует примерно 2 КБ памяти выгружаемого пула. По умолчанию количество дескрипторов файлов кэша IIS составляет 800 на каждые 32 МБ.

По умолчанию данный параметр реестра отсутствует, поскольку в Exchange 2000 Server с пакетом 2 и более поздних версиях, а также в Exchange Server 2003 настроено кэширование оптимального количества дескрипторов файлов. Exchange Server 2003 динамически рассчитывает соответствующие параметры для дескрипторов файлов SMTP, поэтому эти параметры больше не нужны. В связи с этим перед обновлением компьютеров Exchange 2000 Server, где установлены эти параметры, до Exchange Server 2003 следует удалить их из реестра.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы вернуться к конфигурации по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите в следующий раздел реестра: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

  3. В правой области удалите значение FileCacheLifeTimeSeconds.

  4. Закройте редактор реестра и перезапустите службу Администрирование IIS, чтобы изменения вступили в силу.

Перед редактированием реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт "Description of the Microsoft Windows Registry" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).


Параметр реестра SMTP FileCacheMaxHandles был добавлен вручную, но больше не требуется
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, было ли изменено максимальное количество дескрипторов файлов IIS (Internet Information Services) для кэша относительно заданного по умолчанию значения 800, средство анализатора сервера Microsoft® Exchange считывает следующий параметр реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Inetinfo\Parameters\FileCacheMaxHandles

Если анализатор сервера Exchange обнаруживает, что параметр FileCacheMaxHandles существует и для него установлено значение, отличное от 800, выводится сообщение о том, что конфигурация отличается от заданной по умолчанию.

Значение FileCacheMaxHandles определяет максимальное количество дескрипторов файлов IIS, используемых Exchange для каждых 32 мегабайтов (МБ) физической памяти. Дескрипторы файлов кэшируются для повышения быстродействия, поскольку это позволяет предотвратить выполнение сервером излишних циклов ввода-вывода и циклов процессора. Каждый раз, когда транспортный стек SMTP на компьютере с сервером Exchange получает сообщение, оно передается в файловую систему, где ожидает маршрутизации по назначению. Для выполнения записи в файловую систему транспортный стек SMTP получает дескриптор файла, а затем передает сообщение этому дескриптору. Каждый дескриптор файла занимает приблизительно 2 килобайта (КБ) выгружаемого пула. Заданное по умолчанию количество дескрипторов файлов кэша IIS равно 800 для каждых 32 МБ.

До появления пакета обновления 2 (SP2) для Exchange 2000 Server существовали ограничения быстродействия для серверов Exchange с большими очередями сообщений, передаваемых по протоколу SMTP (например, в среднем около 1000 сообщений и больше), поскольку по умолчанию для службы SMTP было установлено максимальное значение 1000 дескрипторов файлов. Поскольку по умолчанию в Exchange 2000 Server было установлено максимальное число дескрипторов файлов — 1000, служба SMTP могла одновременно записать в файловую систему только 1000 сообщений.

С целью повышения быстродействия таких больших систем часто выполнялась одновременная корректировка трех параметров реестра, чтобы увеличить максимальное количество дескрипторов файлов, которые могут быть открыты службой SMTP (чтобы можно было обработать больше сообщений), и сократить число открытых дескрипторов файлов для устанавливаемой файловой системы, еще одного компонента Exchange (чтобы избежать недостатка памяти в случае большой очереди). Эти параметры реестра, которые отсутствовали по умолчанию и которые требовалось добавлять вручную, перечислены ниже.

Местоположение: HKLM\System\CurrentControlSet\Services\SMTPSVC\Queuing

Параметр: MsgHandleThreshold

Тип: REG_DWORD

Местоположение: HKLM\System\CurrentControlSet\Services\SMTPSVC\Queuing

Параметр: MsgHandleAsyncThreshold

Тип: REG_DWORD

Местоположение: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

Параметр: FileCacheMaxHandles

Тип: REG_DWORD

Для параметров реестра MsgHandleThreshold и MsgHandleAsyncThreshold обычно задают одинаковые значения (обычно больше 1000), а значение параметра FileCacheMaxHandles обычно уменьшают с 800 до 600.

Этот параметр реестра по умолчанию отсутствует, поскольку в Exchange 2000 Server с пакетом обновления 2 (SP2) и в более поздних версиях оптимальные значения определяются динамически. Если сервер Exchange работает под управлением Exchange 2000 Server с пакетом обновления 1 или под управлением более ранней версии, рекомендуется провести обновление до новейшего пакета обновления и установить новейший пакет исправлений. После обновления кода до новейшего уровня эти разделы реестра можно удалить.

Exchange Server 2003 динамически вычисляет подходящие значения для дескрипторов файлов SMTP, следовательно эти параметры настройки больше не нужны. Поэтому перед обновлением компьютеров, на которых установлен сервер Exchange 2000 Server и настроены эти параметры, до Exchange Server 2003 следует удалить из реестра эти записи.

Важно!
В этой статье содержатся сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» средства Regedit.exe или Regedt32.exe.

Чтобы устранить эту ошибку

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

  3. Удалите значение FileCacheMaxHandles.

  4. Закройте редактор реестра и перезапустите службу администрирования IIS, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Значение параметра реестра GlitchRetrySeconds для SMTP было установлено вручную
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-01-17

Чтобы определить, изменено ли вручную значение времени ожидания повтора при сбое по умолчанию, анализатор сервера Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\GlitchRetrySeconds

Если анализатор находит, что параметр GlitchRetrySeconds существует и настроен, отображается сообщение о нестандартной конфигурации.

Если Exchange 2000 Server или Exchange Server 2003 пытается маршрутизировать сообщение во внешнюю перегруженную систему SMTP, может возникнуть ошибка занятости сервера. Если это происходит, Exchange переходит в состояние, называемое «повтором при сбое». В этом состоянии Exchange ожидает 60 секунд, прежде чем попытаться повторно отправить сообщение, и этот процесс повторяется три раза до перехода к другим действиям. Если внешние SMTP-серверы постоянно заняты, рекомендуется уменьшить время ожидания повтора при сбое, чтобы предотвратить накопление многочисленных сообщений в очереди.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы восстановить конфигурацию по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. В правой области удалите значение GlitchRetrySeconds. Кроме того, можно уменьшить значение раздела GlitchRetrySeconds, если происходит массовое накопление сообщений в очереди.

  4. Закройте редактор реестра и перезапустите службу SMTP, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Параметр реестра IgnorePFTimeLimit для SMTP был задан вручную
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-01-17

Чтобы определить, было ли задано вручную количество дней, в течение которых модуль маршрутизации SMTP пропускает новое хранилище общих папок, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\IgnorePFTimeLimit

Если анализатор сервера Exchange обнаружит, что параметр IgnorePFTimeLimit существует и настроен, на экран выводится сообщение о конфигурации, отличной от конфигурации по умолчанию.

При подключении нового хранилища общих папок средство просмотра очереди может показывать рост очереди локальной доставки. При использовании большой иерархии общих папок число сообщений в локальной очереди продолжает расти и для их доставки может потребоваться дополнительное время. В некоторых случаях сообщения не могут быть доставлены.

При вводе нового сервера его различающееся имя добавляется к атрибуту msExchOwningPFTreeBL объекта общей папки иерархий папок группы администрирования в службе каталогов Active Directory®. Когда классификатор сервера, получающего сообщения, отправленные в общие папки, считывает атрибут msExchOwningPFTreeBL, он должен сначала выбрать локальное хранилище общих папок, если оно существует. Для лучшего распределения нагрузки он затем выбирает хранилища общих папок в том порядке, в котором они перечислены. Поскольку новый сервер указан первым, сообщения направляются ему и добавляются в локальную очередь доставки нового сервера. Если хранилище общих папок не получило копии иерархии, сервер не может направить сообщения в хранилище, которому принадлежит копия папки назначения.

Можно предотвратить эту проблему, добавив параметр IgnorePFTimeLimit в реестр нового сервера общих папок. Это позволит указать количество дней, в течение которых модуль маршрутизации будет пропускать новое хранилище общих папок.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы восстановить конфигурацию по умолчанию

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. В правой области удалите параметр IgnorePFTimeLimit.

  4. Закройте редактор реестра и перезапустите службу администрирования IIS, чтобы изменение вступило в силу.

Дополнительные сведения о данной проблеме и параметре реестра IgnorePFTimeLimit, описанном в данном разделе, см. в статье 328870 базы знаний Майкрософт, посвященной проблеме доступности маршрутизации общей папки до выполнения репликации иерархии (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328870).

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Экземпляр SMTP имеет несколько настроенных привязок портов
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить, было ли изменено настроенное значение атрибута msExchServerBindings по умолчанию 25 или были ли заданы несколько значений. По умолчанию атрибут msExchServerBindings настроен на TCP-порт 25. Если анализатор сервера Exchange обнаружит, что этот атрибут имеет несколько наборов значений, будет отображено сообщение о нестандартной конфигурации вместе с именем виртуального SMTP-сервера, у которого существует несколько наборов значений.

Атрибут msExchServerBindings представляет TCP-порт, по которому SMTP-сервер ожидает входящие подключения. Виртуальные SMTP-серверы можно настроить на прослушивание одного или нескольких портов TCP. По умолчанию все виртуальные SMTP-серверы прослушивают TCP-порт 25 — порт SMTP по умолчанию. Если прослушиваемый порт SMTP был изменен со своего значения по умолчанию и содержит несколько привязок портов, поток электронной почты может быть нарушен.

Разрешается изменить прослушиваемый порт SMTP, если изменить соответствующим образом и всю инфраструктуру внутреннего обмена сообщениями. Но, как правило, нельзя использовать другие порты для виртуальных SMTP-серверов, которые получают сообщения напрямую из Интернета, так как SMTP-серверы в Интернете посылают сообщения через порт 25.

Заметьте, что анализатор сервера Exchange ищет значение для виртуального SMTP-сервера Exchange. Виртуальный SMTP-сервер может являться SMTP-сервером, который получает сообщения напрямую из Интернета, а может и не являться таковым. Существует несколько продуктов, предназначенных для борьбы с вирусами и нежелательной почтой, которые получают SMTP-сообщения из Интернета по порту 25 и перенаправляют их на виртуальный SMTP-сервер Exchange или на другой порт. В этом сценарии виртуальный SMTP-сервер Exchange, который прослушивает несколько портов, является приемлемой конфигурацией.

Чтобы просмотреть или изменить прослушиваемый виртуальным SMTP-сервером порт

  1. Откройте системный диспетчер Exchange.

  2. Откройте Серверы, затем разверните сервер Exchange, Протоколы и SMTP.

  3. Правой кнопкой мыши щелкните виртуальный SMTP-сервер (например, виртуальный SMTP-сервер по умолчанию) и нажмите Свойства.

  4. Выберите вкладку Общие и щелкните Дополнительно.

  5. Появится список IP-адресов и портов.

    • Чтобы изменить существующий порт, выберите IP-адрес и щелкните Изменить. Измените TCP-порт в соответствующем поле на 25.

    • Чтобы добавить порт 25 в качестве дополнительного прослушиваемого порта, нажмите кнопку Добавить и добавьте новую комбинацию, состоящую из IP-адреса и порта. Если используется фильтрация подключения, отправителя или получателя, убедитесь, что установлены соответствующие флажки.

  6. Нажмите кнопку ОК, чтобы сохранить изменения, а затем снова нажмите кнопку ОК, чтобы закрыть диалоговое окно Дополнительно.

  7. Нажмите кнопку ОК, чтобы закрыть диалоговое окно Свойства виртуального SMTP-сервера.

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • 266686, описывающая первую часть инструкций по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, описывающая вторую часть инструкций по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).


Предупреждение об ошибке SMTP-сообщения — общий сбой недопустимых сообщений
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс Win32_PerfRawData_SMTPSVC_SMTPServer, чтобы определить значение ключа BadmailedMessagesGeneralFailure. Значение этого ключа представляет количество сообщений, отправленных в каталог недопустимых сообщений по причинам, не связанным с определенным счетчиком. Каталог недопустимых сообщений используется для хранения недоставленных сообщений. Сведения о некоторых других WMI-счетчиках недопустимых сообщений см. в следующих статьях об анализаторе сервера Exchange:

  • Предупреждение об ошибке SMTP-сообщения — порог количества прыжков сообщений недопустимой почты

  • Предупреждение об ошибке SMTP-сообщения — недоставленные сообщения: отчет о недоставке уведомлений о состоянии доставки

Существуют счетчики, значения которых получают приращение, когда сообщение отправляется в каталог недопустимой почты по другим причинам, включая неправильный файл раскладки, отсутствие получателей и срабатывание через событие.

Анализатор сервера Exchange Server также запрашивает WMI-ключ Win32_PerfRawData_PerfOS_System, чтобы определить значение SystemUpTime.

Если анализатор сервера Exchange определяет, что значение ключа SystemUpTime больше 0 и что результат деления значения BadmailedMessagesGeneralFailure на значение SystemUpTime больше 1000, на экран выводится предупреждение.

Это предупреждение указывает, что в среднем 1000 или более сообщений в день получают отметку невозможности доставки и размещаются в каталоге недопустимых сообщений. Сообщения в этом каталоге должны быть удалены вручную. Рекомендуется в качестве части регулярного обслуживания сервера Exchange систематически просматривать и удалять сообщения в каталоге недопустимой почты. Если допустить неограниченное увеличение каталога недопустимой почты, он может занять все доступное пространство на диске, что приведет к отключению базы данных Exchange.

Чтобы устранить причину появления этого предупреждения

  1. Проанализируйте сообщения в каталоге недопустимой почты, чтобы определить, предназначены ли уведомления о состоянии доставки для внутренних или внешних получателей. Сообщения в каталоге недопустимой почты хранятся в формате ASCII и могут открываться и просматриваться в «Блокноте» или другом текстовом редакторе.

    • Если сообщение было создано внутри организации, можно просмотреть его заголовки, чтобы определить происхождение.

    • Если сообщение было создано вне пределов организации, это может указывать, что сервер Exchange используется в качестве почтового ретранслятора.

Дополнительные сведения об управлении и настройке параметров ретрансляции см. в следующих статьях базы знаний Майкрософт:

  • статья 310380, описывающая инструкции по предотвращению использования Exchange 2000 в качестве почтового ретранслятора в Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=310380);

  • статья 313395, описывающая изучение ограничений ретрансляции для анонимных SMTP-подключений (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313395).

Дополнительные сведения об отключениях базы данных по причине недостатка свободного дискового пространства см. в статье 321825 базы знаний Майкрософт (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=321825).


Предупреждение об ошибке SMTP-сообщения — порог количества прыжков сообщений недопустимой почты
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_PerfRawData_SMTPSVC_SMTPServer, чтобы определить значение ключа BadmailedMessagesHopCountExceeded. Значение этого ключа представляет число сообщений, отправленных в каталог недопустимой почты, так как для них было превышено максимальное число прыжков. Каталог недопустимой почты используется для хранения сообщений, которые не удалось доставить. Сведения о некоторых других счетчиках WMI недопустимой почты см. в статьях о средстве анализатора сервера Exchange, Предупреждение об ошибке SMTP-сообщения — общий сбой недопустимых сообщений и Предупреждение об ошибке SMTP-сообщения — недоставленные сообщения: отчет о недоставке уведомлений о состоянии доставки.

Существуют счетчики, увеличивающиеся, когда сообщение отправляется в каталог недопустимой почты и по другим причинам, например, включая плохой файл раскладки, отсутствие получателей и инициирование событием.

Анализатор сервера Exchange также запрашивает WMI-ключ Win32_PerfRawData_PerfOS_System, чтобы определить значение SystemUpTime.

Если анализатор сервера Exchange определяет, что значение ключа SystemUpTime больше 0, и что результат деления значения BadmailedMessagesHopCountExceeded на значение SystemUpTime больше 100, выводится предупреждение.

Это предупреждение показывает, что в среднем 100 и более сообщений в день помечаются как сообщения, которые невозможно доставить, и сохраняются в каталоге недопустимой почты, так как для них превышено максимальное число прыжков. Максимальное число прыжков - это максимальное число серверов SMTP, через которые может проходить сообщение на пути от отправителя к получателю. Всякий раз, когда сообщение проходит через сервер SMTP, в заголовок сообщения добавляется строка текста, представляющая прыжок.

Оптимальное число прыжков сообщения меняется в зависимости от топологии сети и потребностей системы обмена сообщениями. Чтобы запретить повторную передачу сообщения по неправильному маршруту (условие, известное как петля сообщения), администратор может управлять максимальным разрешенным количеством прыжков. Это может быть сделано с помощью определения максимального числа прыжков для виртуального сервера SMTP. В Exchange 2000 Server число прыжков по умолчанию равно 15. В Exchange Server 2003 значение по умолчанию равно 30. Для обоих виртуальных серверов SMTP, Exchange 2000 Server и Exchange Server 2003, рекомендуется использовать значение 30.

Сообщения в каталоге недопустимой почты должны удаляться вручную. Рекомендуется, чтобы регулярный просмотр каталога недопустимой почты и удаление из него сообщений стали частью регулярного обслуживания сервера Exchange. Неограниченный рост каталога недопустимой почты может привести к исчерпанию доступного дискового пространства и, как следствие, к отключению баз данных Exchange.

Устранение причины появления этого предупреждения

  1. Проверьте сообщения в каталоге недопустимой почты, чтобы определить, является ли источник сообщений внешним или внутренним. Сообщения в каталоге недопустимой почты хранятся в формате ASCII и могут быть открыты и просмотрены в редакторе «Блокнот» или другом текстовом редакторе.

    • Если источник сообщений является внутренним, можно проверить заголовки сообщений, чтобы определить их отправителя.

    • Если источник сообщений является внешним, это может указывать на то, что данный сервер Exchange используется в качестве ретранслятора почты.

  2. Установите значение максимального числа прыжков равным 30.

    1. Откройте системный диспетчер Exchange.

    2. Разверните узел Серверы, затем разверните узел сервера Exchange, затем разверните узел Протоколы, а затем - узел SMTP.

    3. Щелкните правой кнопкой мыши виртуальный сервер SMTP (например, виртуальный сервер SMTP по умолчанию) и выберите команду Свойства.

    4. Выберите вкладку Каталог, а затем щелкните Дополнительно.

    5. Введите нужное значение в поле Максимальное число прыжков и нажмите кнопку OK, чтобы сохранить изменение.

    6. Нажмите кнопку OK, чтобы закрыть диалоговое окно Свойства виртуального сервера SMTP.

Сведения об управлении и настройке параметров ретрансляции см. в следующих статьях базы знаний Майкрософт:

  • 310380, посвященная защите Exchange 2000 от использования в качестве ретранслятора почты в Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=310380, возможно, на английском языке)

  • 313395, посвященная проверке ограничений на ретрансляцию для анонимных подключений SMTP (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313395, возможно, на английском языке)

Дополнительные сведения об отключении базы данных из-за недостаточного свободного дискового пространства см. в статье 321825 базы знаний Майкрософт, посвященной отключению баз данных из-за недостатка дискового пространства (http://go.microsoft.com/fwlink/?linkid=3052&kbid=321825, возможно, на английском языке).


Предупреждение об ошибке SMTP-сообщения — недоставленные сообщения: отчет о недоставке уведомлений о состоянии доставки
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-23

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_PerfRawData_SMTPSVC_SMTPServer, чтобы определить значение ключа BadmailedMessagesNDRofDSN. Значение этого ключа представляет собой количество уведомлений о состоянии доставки, отправленных в каталог «Badmail» из-за того, что они не были доставлены. Каталог «Badmail» используется для хранения недоставленных сообщений. Сведения о некоторых других WMI-счетчиках недоставленных сообщений см. в статьях об анализаторе серверах Exchange: Предупреждение об ошибке SMTP-сообщения — общий сбой недопустимых сообщений и Предупреждение об ошибке SMTP-сообщения — порог количества прыжков сообщений недопустимой почты.

Существуют счетчики, значения которых получают приращение, когда сообщение отправляется в каталог «Badmail» по другим причинам, включая неправильный приемный файл, отсутствие получателей и срабатывание через событие.

Анализатор сервера Exchange Server также запрашивает WMI-ключ Win32_PerfRawData_PerfOS_System, чтобы определить значение SystemUpTime.

Если анализатор сервера Exchange определяет, что значение ключа SystemUpTime больше 0, и что результат деления значения BadmailedMessagesNDRofDSN на значение SystemUpTime больше 1000, на экран будет выведено предупреждение.

Это предупреждение указывает, что ежедневно в среднем 1000 или более уведомлений о состоянии доставки сохраняются в каталоге «Badmail» из-за того, что их не удалось доставить. Сообщения в каталоге «Badmail» должны удаляться вручную. Рекомендуется в качестве части регулярного обслуживания сервера Exchange систематически просматривать и удалять сообщения в каталоге «Badmail». Если допустить неограниченное увеличение каталога «Badmail», он может занять все доступное пространство на диске, что приведет к отключению базы данных Exchange.

Чтобы устранить причину появления этого предупреждения

  • Проанализируйте сообщения в каталоге «Badmail», чтобы определить, предназначены ли уведомления о состоянии доставки для внутренних или внешних получателей. Сообщения в каталоге «Badmail» хранятся в формате ASCII и могут открываться и просматриваться в «Блокноте» или другом текстовом редакторе.

    • Если уведомления о состоянии доставки предназначены для внутренних получателей, это указывает на проблему с потоком сообщений. Устранение причин данной проблемы зависит от конкретного числового кода, возвращаемого с уведомлением о состоянии доставки.

    • Если уведомления о состоянии доставки предназначены для внешних получателей, это может свидетельствовать о том, что сервер Exchange используется как ретранслятор электронной почты. Устранение причин данной проблемы также зависит от возвращаемого числового кода.

Дополнительные сведения о числовых кодах, возвращаемых с уведомлениями о состоянии доставки см. в базе знаний Майкрософт в статье 284204, описывающей уведомления о состоянии доставки на сервере Exchange и в пакете Small Business Server.

Сведения о контроле и настройке параметров ретрансляции см. в базе знаний Майкрософт в статье 313395, содержащей инструкции по анализу ограничений ретрансляции для анонимных SMTP-подключений и по фильтрации нежелательных сообщений электронной почты в Exchange 2000 Server.

Дополнительные сведения об отключеньях баз данных из-за недостатка свободного места на диске см. в базе знаний Майкрософт в статье 321825, описывающей явление отключения баз данных из-за недостатка свободного места на диске.


Предупреждение об ошибке SMTP-сообщения — не найдены просмотры адресов классификатора
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-03-20

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_PerfRawData_SMTPSVC_SMTPServer, чтобы определить значение ключа CatAddresslookupsnotfound. Значение этого ключа представляет собой количество просмотров адресов, выполненных классификатором сообщения, который не нашел объекта службы каталогов. Анализатор сервера Exchange Server также запрашивает WMI-ключ Win32_PerfRawData_PerfOS_System, чтобы определить значение SystemUpTime.

Если анализатор сервера Exchange определяет, что значение ключа SystemUpTime больше 0, и что результат деления значения CatAddresslookupsnotfound на значение SystemUpTime больше 5000, выводится предупреждение.

Классификатор сообщений анализирует сообщения, которые поступают на SMTP-сервер, и определяет, что необходимо делать с сообщениями. Сообщения могут быть отправлены в банк данных, на удаленный узел с помощью агента передачи сообщений, или сообщения могут быть отправлены на удаленный узел с помощью протокола SMTP. Классификатор также обрабатывает расширение списка рассылки. Классификатор — это дополнительный модуль для расширенного механизма очередей, который выполняет LDAP-запросы (Lightweight Directory Access Protocol) на серверах глобального каталога по TCP-порту 3268. По существу, классификатор — это набор приемников событий, которые выполняют расширенное разрешение адресов по каждому сообщению, проходящему через расширенный механизм очередей. Классификатор выполняет разрешение адресов, переадресацию почты, устанавливает флаги преобразований, расширяет списки рассылки, принудительно устанавливает глобальные параметры, создает уведомления о состоянии доставки, а также выполняет определение дополнительных маршрутов приема, ветвление, ведение журнала и многие другие функции.

После того как сообщение попадает в классификатор сообщений, он определяет отправителя конверта путем поиска адреса в атрибутах адреса прокси-сервера в службе каталогов Active Directory®. Классификатор также определяет получателя конверта путем поиска каждого адреса в атрибуте адресов прокси-серверов в службе Active Directory. Например, если список включает список рассылки, он расширяет список для включения этих членов, если расширение списка рассылки разрешено на сервере.

Это предупреждение указывает, что ежедневно в среднем 5000 или более просмотров адресов классификатором завершаются неудачей. Существуют различные причины этого, включая проблемы с доступом к службе каталогов (DSAccess), задержки или сбои репликации каталогов, словарные атаки злоумышленников на каталоги, проблемы со службой DNS и использование неправильных адресов.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Проанализируйте на наличие ошибок журналы событий на компьютере сервера Exchange.

  2. Если не найдено никаких событий, которые позволяют устранить проблему, рассмотрите возможность установки на максимум ведения журнала диагностики для классификатора MSExchangeTransport. После включения ведения журнала диагностики повторно проверьте журнал событий на наличие ошибок. Если настройка на максимальную регистрацию в журнале диагностики не приводит к появлению каких-либо записей в журнале событий, настройте уровень 7 для ведения журнала диагностики, используя для этого возможности реестра. Когда установлен уровень 7, в журнал будет заноситься событие с идентификатором 9000, создаваемое классификатором сообщений и описывающее функцию, причину сбоя, имя и тип получателя, для которого произошел сбой. Чтобы установить для ведения журнала диагностики уровень 7:

    1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

    2. Перейдите к разделу реестра:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. В правой части редактора дважды щелкните 2 Categorizer (2 Классификатор), установите значение равным 7, а затем нажмите кнопку OK.

    4. Закройте редактор реестра.

      Примечание.
      После завершения устранения неполадок верните значение параметра «2 Categorizer» (2 Классификатор) обратно в 0.

  3. Убедитесь, что сервер Exchange может установить подключения к одному или нескольким серверам глобального каталога. Для этого хорошо подойдет существующее в Windows средство наблюдения за сетью.

  4. Проанализируйте все создаваемые уведомления о состоянии доставки. В уведомлениях о состоянии доставки, которые могут включать отчеты о недоставке, описываются сообщения о постоянных ошибках и сообщения о временных ошибках, часто заканчивающихся постоянными ошибками доставки.

  5. Используйте отслеживание сообщений для устранения проблем с сообщениями, которые попадают в классификатор.

  6. Используйте средство приемника архива для архивирования и анализа сообщений, поступающих на сервер Exchange и выходящих из него.

  7. Наблюдайте за счетчиками производительности классификатора с помощью системного монитора.

Список уведомлений о состоянии доставки и отчетов о недоставке, создаваемых серверами Exchange и Microsoft Windows Small Business Server, см. в базе знаний Майкрософт в статье 284204, посвященной уведомлениям о состоянии доставки на серверах Exchange и Small Business Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Сведения об использовании центра отслеживания сообщений на сервере Exchange см. в следующих статьях базы знаний Майкрософт:

  • 262162, описывающая использование центра отслеживания сообщений для отслеживания сообщений (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856, описывающая порядок включения отслеживания сообщений в Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905, описывающая идентификаторы событий при отслеживании сообщений на сервере Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864, описывающая улучшенные функции отслеживания сообщений на сервере Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

Дополнительные сведения об устранении неполадок классификатора сообщений см. в веб-презентации службы поддержки Майкрософт, представляющей: устранение неполадок классификатора сообщений и отчетов о недоставке в Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137).

Дополнительные сведения о средстве приемника архива см. в базе знаний Майкрософт в статье 307798, описывающей служебную программу приемника архива, доступную в пакете обновления 2 (SP2) (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Общие сведения об устранении проблем, связанных с транспортом, см. в следующих статьях базы знаний Майкрософт:

  • 821910, описывающая устранение проблем транспорта в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265, описывающая общие сведения об устранении проблем транспорта в Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

Счетчики производительности классификатора сообщений публикуются отдельно для каждого экземпляра виртуального сервера SMTP. Список доступных счетчиков производительности, связанных с классификатором сообщений, см. в базе знаний Майкрософт в статье 231734, описывающей счетчики системного монитора для классификатора сообщений (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).

Сведения о некоторых других WMI-счетчиках классификатора см. в следующих статьях об анализаторе сервера Exchange:

  • Предупреждение об ошибке SMTP-сообщения — ошибка службы каталогов классификатора

  • Предупреждение об ошибке SMTP-сообщения — ошибка входа в каталог классификатора

  • Предупреждение об ошибке SMTP-сообщения — неповторяющаяся ошибка классификатора

  • Предупреждение о недоставке сообщения SMTP — Недостаточно памяти классификатора

  • Предупреждение об ошибке SMTP-сообщения — повторяющаяся ошибка классификатора


Предупреждение об ошибке SMTP-сообщения — ошибка входа в каталог классификатора
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_PerfRawData_SMTPSVC_SMTPServer, чтобы определить значение ключа CatCategorizationsfailedDSlogonfailure. Значение этого ключа представляет собой количество классификаций, которые завершились сбоем из-за ошибки входа в службу каталогов. Анализатор сервера Exchange Server также запрашивает WMI-ключ Win32_PerfRawData_PerfOS_System, чтобы определить значение SystemUpTime.

Если анализатор сервера Exchange определяет, что значение ключа SystemUpTime больше 0, и что результат деления значения CatCategorizationsfailedDSlogonfailure на значение SystemUpTime больше 50, выводится предупреждение.

Классификатор сообщений анализирует сообщения, которые поступают на SMTP-сервер, и определяет, что необходимо делать с сообщениями. Сообщения могут быть отправлены в банк данных, на удаленный узел с помощью агента передачи сообщений, или сообщения могут быть отправлены на удаленный узел с помощью протокола SMTP. Классификатор также обрабатывает расширение списка рассылки. Классификатор — это дополнительный модуль для расширенного механизма очередей, который выполняет LDAP-запросы (Lightweight Directory Access Protocol) на серверах глобального каталога по TCP-порту 3268. По существу, классификатор — это набор приемников событий, которые выполняют расширенное разрешение адресов по каждому сообщению, проходящему через расширенный механизм очередей. Классификатор выполняет разрешение адресов, переадресацию почты, устанавливает флаги преобразований, расширяет списки рассылки, принудительно устанавливает глобальные параметры, создает уведомления о состоянии доставки, а также выполняет определение дополнительных маршрутов приема, ветвление, ведение журнала и многие другие функции.

После того как сообщение попадает в классификатор сообщений, он определяет отправителя конверта путем поиска адреса в атрибутах адреса прокси-сервера в службе каталогов Active Directory®. Классификатор также определяет получателя конверта путем поиска каждого адреса в атрибуте адресов прокси-серверов в службе Active Directory. Например, если список включает список рассылки, он расширяет список для включения этих членов, если расширение списка рассылки разрешено на сервере.

Это предупреждение указывает, что ежедневно в среднем 50 или более попыток подключения к службе каталогов, предпринимаемые классификатором сообщений, завершаются неудачей из-за ошибок входа. Существуют различные причины этого, включая проблемы с доступом к службе каталогов, задержки или сбои репликации каталогов, перегруженные серверы глобального каталога и проблемы со службой DNS.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Проверьте наличие ошибок в журналах событий на компьютере сервера Exchange.

  2. Если не найдено никаких событий, которые позволяют устранить проблему, рассмотрите возможность установки на максимум ведения журнала диагностики для классификатора MSExchangeTransport. После включения ведения журнала диагностики повторно проверьте журнал событий на наличие ошибок. Если настройка на максимальную регистрацию в журнале диагностики не приводит к появлению каких-либо записей в журнале событий, настройте уровень 7 для ведения журнала диагностики, используя для этого возможности реестра. Если установлен уровень 7, в журнал будет заноситься событие с идентификатором 9000, создаваемое классификатором сообщений и описывающее функцию, причину сбоя, имя и тип получателя, для которого произошел сбой. Чтобы установить для ведения журнала диагностики уровень 7:

    1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

    2. Перейдите в раздел реестра:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. В правой части редактора дважды щелкните параметр 2 Categorizer, установите значение равным 7, а затем нажмите кнопку ОК.

    4. Закройте редактор реестра.

      Примечание.
      После завершения устранения неполадок верните значение параметра «2 Categorizer» (2 Классификатор) обратно в 0.

  3. Убедитесь, что сервер Exchange может установить подключения к одному или нескольким серверам глобального каталога. Для этого хорошо подойдет существующее в Windows средство наблюдения за сетью.

  4. Проанализируйте все создаваемые уведомления о состоянии доставки. В уведомлениях о состоянии доставки, которые могут включать отчеты о недоставке, описываются сообщения о постоянных ошибках и сообщения о временных ошибках, часто заканчивающихся постоянными ошибками доставки.

  5. Используйте отслеживание сообщений для устранения проблем с сообщениями, которые попадают в классификатор.

  6. Используйте средство приемника архива для архивирования и анализа сообщений, поступающих на сервер Exchange и выходящих из него.

  7. Наблюдайте за счетчиками производительности классификатора с помощью системного монитора.

Список уведомлений о состоянии доставки и отчетов о недоставке, создаваемых серверами Exchange и Microsoft Windows Small Business Server, см. в статье 284204 базы знаний Майкрософт «Delivery status notifications in Exchange Server and in Small Business Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204)(Уведомления о состоянии доставки на серверах Exchange и Small Business Server).

Сведения об использовании центра отслеживания сообщений на сервере Exchange см. в следующих статьях базы знаний Майкрософт:

  • 262162, «XADM: Using the Message Tracking Center to Track a Message» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162) (XADM: использование центра отслеживания сообщений для отслеживания сообщений)

  • 246856, «XADM: How to Enable Message Tracking in Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856) (XADM: инструкции по включению отслеживания сообщений в Exchange 2000 Server)

  • 821905, «Message Tracking Event IDs in Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905) (Идентификаторы событий при отслеживании сообщений на сервере Exchange Server 2003)

  • 823864, «Improved Message Tracking Features in Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864) (Усовершенствованные функции отслеживания сообщений на сервере Exchange Server 2003)

Дополнительные сведения об устранении неполадок классификатора сообщений см. в веб-презентации службы поддержки Майкрософт «Exchange 2000 Server: Message Categorizer and NDR Troubleshooting» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137) (Устранение неполадок классификатора сообщений и отчетов о недоставке в Exchange 2000 Server).

Дополнительные сведения о средстве приемника архива см. статье 307798 базы знаний Майкрософт «The Archive Sink utility is available in Service Pack 2» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798) (Служебная программа приемника архива, доступная в пакете обновления 2).

Общие сведения об устранении проблем, связанных с транспортом, см. в следующих статьях базы знаний Майкрософт:

  • 821910, «How To Troubleshoot for Exchange Server 2003 Transport Issues» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910) (Устранение неполадок транспорта в Exchange Server 2003)

  • 257265, «XCON: General Troubleshooting for Exchange 2000 Transport Issues» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265) (XCON: общие сведения об устранении неполадок транспорта в Exchange 2000)

Счетчики производительности классификатора сообщений публикуются отдельно для каждого экземпляра виртуального сервера SMTP. Список доступных счетчиков производительности, связанных с классификатором сообщений, см. в базе знаний Майкрософт в статье 231734 «XCON: Performance Monitor Counters for Message Categorizer» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734) (XCON: счетчики системного монитора для классификатора сообщений).

Сведения о некоторых других WMI-счетчиках классификатора см. в следующих статьях об анализаторе сервера Exchange:

  • Предупреждение об ошибке SMTP-сообщения — ошибка службы каталогов классификатора

  • Предупреждение об ошибке SMTP-сообщения — не найдены просмотры адресов классификатора

  • Предупреждение об ошибке SMTP-сообщения — неповторяющаяся ошибка классификатора

  • Предупреждение о недоставке сообщения SMTP — Недостаточно памяти классификатора

  • Предупреждение об ошибке SMTP-сообщения — повторяющаяся ошибка классификатора


Предупреждение об ошибке SMTP-сообщения — ошибка службы каталогов классификатора
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-03-20

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_PerfRawData_SMTPSVC_SMTPServer, чтобы определить значение ключа CatCategorizationsfailedDSconnectionfailure. Значение этого ключа представляет собой количество классификаций, которые завершились сбоем из-за ошибки службы подключения к службе каталогов. Анализатор сервера Exchange Server также запрашивает WMI-ключ Win32_PerfRawData_PerfOS_System, чтобы определить значение SystemUpTime.

Если анализатор сервера Exchange определяет, что значение ключа SystemUpTime больше 0, и что результат деления значения CatCategorizationsfailedDSconnectionfailure на значение SystemUpTime больше 50, на экране отображается предупреждение.

Классификатор сообщений анализирует сообщения, которые поступают на SMTP-сервер, и определяет, что необходимо делать с сообщениями. Сообщения могут быть отправлены в банк данных, на удаленный узел с помощью агента передачи сообщений, или сообщения могут быть отправлены на удаленный узел с помощью протокола SMTP. Классификатор также обрабатывает расширение списка рассылки. Классификатор — это дополнительный модуль для расширенного механизма очередей, который выполняет LDAP-запросы (Lightweight Directory Access Protocol) на серверах глобального каталога по TCP-порту 3268. По существу, классификатор — это набор приемников событий, которые выполняют расширенное разрешение адресов по каждому сообщению, проходящему через расширенный механизм очередей. Классификатор выполняет разрешение адресов, переадресацию почты, устанавливает флаги преобразований, расширяет списки рассылки, принудительно устанавливает глобальные параметры, создает уведомления о состоянии доставки, а также выполняет определение дополнительных маршрутов приема, ветвление, ведение журнала и многие другие функции.

После того как сообщение попадает в классификатор сообщений, он определяет отправителя конверта путем поиска адреса в атрибутах адреса прокси-сервера в службе каталогов Active Directory®. Классификатор также определяет получателя конверта путем поиска каждого адреса в атрибуте адресов прокси-серверов в службе Active Directory. Например, если список включает список рассылки, он расширяет список для включения этих членов, если расширение списка рассылки разрешено на сервере.

Это предупреждение указывает, что ежедневно в среднем 50 или более попыток подключения к службе каталогов, предпринимаемые классификатором сообщений, завершаются неудачей. Существуют различные причины этого, включая проблемы с доступом к службе каталогов (DSAccess), задержки или сбои репликации каталогов, перегруженные серверы глобального каталога и проблемы со службой DNS.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Проанализируйте на наличие ошибок журналы событий на компьютере сервера Exchange.

  2. Если не найдено никаких событий, которые позволяют устранить проблему, рассмотрите возможность установки на максимум ведения журнала диагностики для классификатора MSExchangeTransport. После включения ведения журнала диагностики повторно проверьте журнал событий на наличие ошибок. Если настройка на максимальную регистрацию в журнале диагностики не приводит к появлению каких-либо записей в журнале событий, настройте уровень 7 для ведения журнала диагностики, используя для этого возможности реестра. Когда установлен уровень 7, в журнал будет заноситься событие с идентификатором 9000, создаваемое классификатором сообщений и описывающее функцию, причину сбоя, имя и тип получателя, для которого произошел сбой. Чтобы установить для ведения журнала диагностики уровень 7:

    1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

    2. Перейдите к разделу реестра:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. В правой части редактора дважды щелкните 2 Categorizer (2 Классификатор), установите значение равным 7, а затем нажмите кнопку OK.

    4. Закройте редактор реестра.

      Примечание.
      После завершения устранения неполадок верните значение параметра «2 Categorizer» (2 Классификатор) обратно в 0.

  3. Убедитесь, что сервер Exchange может установить подключения к одному или нескольким серверам глобального каталога. Для этого хорошо подойдет существующее в Windows средство наблюдения за сетью.

  4. Проанализируйте все создаваемые уведомления о состоянии доставки. В уведомлениях о состоянии доставки, которые могут включать отчеты о недоставке, описываются сообщения о постоянных ошибках и сообщения о временных ошибках, часто заканчивающихся постоянными ошибками доставки.

  5. Используйте отслеживание сообщений для устранения проблем с сообщениями, которые попадают в классификатор.

  6. Используйте средство приемника архива для архивирования и анализа сообщений, поступающих на сервер Exchange и выходящих из него.

  7. Наблюдайте за счетчиками производительности классификатора с помощью системного монитора.

Список уведомлений о состоянии доставки и отчетов о недоставке, создаваемых серверами Exchange и Microsoft Windows Small Business Server, см. в базе знаний Майкрософт в статье 284204, посвященной уведомлениям о состоянии доставки на серверах Exchange и Small Business Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Сведения об использовании центра отслеживания сообщений на сервере Exchange см. в следующих статьях базы знаний Майкрософт:

  • 262162, описывающая использование центра отслеживания сообщений для отслеживания сообщений (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856, описывающая порядок включения отслеживания сообщений в Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905, описывающая идентификаторы событий при отслеживании сообщений на сервере Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864, описывающая улучшенные функции отслеживания сообщений на сервере Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

Дополнительные сведения об устранении неполадок классификатора сообщений см. в веб-презентации службы поддержки Майкрософт, представляющей: устранение неполадок классификатора сообщений и отчетов о недоставке в Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137).

Дополнительные сведения о средстве приемника архива см. в базе знаний Майкрософт в статье 307798, описывающей служебную программу приемника архива, доступную в пакете обновления 2 (SP2) (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Общие сведения об устранении проблем, связанных с транспортом, см. в следующих статьях базы знаний Майкрософт:

  • 821910, описывающая устранение проблем транспорта в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265, описывающая общие сведения об устранении проблем транспорта в Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

Счетчики производительности классификатора сообщений публикуются отдельно для каждого экземпляра виртуального сервера SMTP. Список доступных счетчиков производительности, связанных с классификатором сообщений, см. в базе знаний Майкрософт в статье 231734, описывающей счетчики системного монитора для классификатора сообщений (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).

Сведения о некоторых других WMI-счетчиках классификатора см. в следующих статьях об анализаторе сервера Exchange:

  • Предупреждение об ошибке SMTP-сообщения — не найдены просмотры адресов классификатора

  • Предупреждение об ошибке SMTP-сообщения — ошибка входа в каталог классификатора

  • Предупреждение об ошибке SMTP-сообщения — неповторяющаяся ошибка классификатора

  • Предупреждение о недоставке сообщения SMTP — Недостаточно памяти классификатора

  • Предупреждение об ошибке SMTP-сообщения — повторяющаяся ошибка классификатора


Предупреждение об ошибке SMTP-сообщения — неповторяющаяся ошибка классификатора
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_PerfRawData_SMTPSVC_SMTPServer, чтобы определить значение ключа CatCategorizationsfailednonretryableerror. Значение этого ключа представляет собой количество классификаций, которые завершились сбоем из-за неисправимой (неповторяющейся) ошибки. Анализатор сервера Exchange Server также запрашивает WMI-ключ Win32_PerfRawData_PerfOS_System, чтобы определить значение SystemUpTime.

Если анализатор сервера Exchange определяет, что значение ключа SystemUpTime больше 0, и что результат деления значения CatCategorizationsfailednonretryableerror на значение SystemUpTime больше 50, выводится предупреждение.

Классификатор сообщений анализирует сообщения, которые поступают на SMTP-сервер, и определяет, что необходимо делать с сообщениями. Сообщения могут быть отправлены в банк данных, на удаленный узел с помощью агента передачи сообщений, или сообщения могут быть отправлены на удаленный узел с помощью протокола SMTP. Классификатор также обрабатывает расширение списка рассылки. Классификатор — это дополнительный модуль для расширенного механизма очередей, который выполняет LDAP-запросы (Lightweight Directory Access Protocol) на серверах глобального каталога по TCP-порту 3268. По существу, классификатор — это набор приемников событий, которые выполняют расширенное разрешение адресов по каждому сообщению, проходящему через расширенный механизм очередей. Классификатор выполняет разрешение адресов, переадресацию почты, устанавливает флаги преобразований, расширяет списки рассылки, принудительно устанавливает глобальные параметры, создает уведомления о состоянии доставки, а также выполняет определение дополнительных маршрутов приема, ветвление, ведение журнала и многие другие функции.

После того как сообщение попадает в классификатор сообщений, он определяет отправителя конверта путем поиска адреса в атрибутах адреса прокси-сервера в службе каталогов Active Directory®. Классификатор также определяет получателя конверта путем поиска каждого адреса в атрибуте адресов прокси-серверов в службе Active Directory. Например, если список включает список рассылки, он расширяет список для включения этих членов, если расширение списка рассылки разрешено на сервере.

Это предупреждение указывает, что ежедневно в среднем происходит 50 или более неисправимых ошибок. Существуют различные причины этого, включая проблемы с доступом к службе каталогов (DSAccess), задержки или сбои репликации каталогов, перегруженные серверы глобального каталога и проблемы со службой DNS.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Проверьте наличие ошибок в журналах событий на компьютере сервера Exchange.

  2. Если не найдено никаких событий, которые позволяют устранить проблему, рассмотрите возможность установки на максимум ведения журнала диагностики для классификатора MSExchangeTransport. После включения ведения журнала диагностики повторно проверьте журнал событий на наличие ошибок. Если настройка на максимальную регистрацию в журнале диагностики не приводит к появлению каких-либо записей в журнале событий, настройте уровень 7 для ведения журнала диагностики, используя для этого возможности реестра. Когда установлен уровень 7, в журнал будет заноситься событие с идентификатором 9000, создаваемое классификатором сообщений и описывающее функцию, причину сбоя, имя и тип получателя, для которого произошел сбой. Чтобы установить для ведения журнала диагностики уровень 7:

    1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

    2. Перейдите к разделу реестра:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. В правой части редактора дважды щелкните 2 Categorizer (2 Классификатор), установите значение равным 7, а затем нажмите кнопку OK.

    4. Закройте редактор реестра.

      Примечание.
      После завершения устранения неполадок верните значение параметра «2 Categorizer» (2 Классификатор) обратно в 0.

  3. Убедитесь, что сервер Exchange может установить подключения к одному или нескольким серверам глобального каталога. Для этого хорошо подойдет существующее в Windows средство наблюдения за сетью.

  4. Проанализируйте все создаваемые уведомления о состоянии доставки. В уведомлениях о состоянии доставки, которые могут включать отчеты о недоставке, описываются сообщения о постоянных ошибках и сообщения о временных ошибках, часто заканчивающихся постоянными ошибками доставки.

  5. Используйте отслеживание сообщений для устранения проблем с сообщениями, которые попадают в классификатор.

  6. Используйте средство приемника архива для архивирования и анализа сообщений, поступающих на сервер Exchange и выходящих из него.

  7. Наблюдайте за счетчиками производительности классификатора с помощью системного монитора.

Список уведомлений о состоянии доставки и отчетов о недоставке, создаваемых серверами Exchange и Microsoft Windows Small Business Server, см. в базе знаний Майкрософт в статье 284204, посвященной уведомлениям о состоянии доставки на серверах Exchange и Small Business Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Сведения об использовании центра отслеживания сообщений на сервере Exchange см. в следующих статьях базы знаний Майкрософт:

  • 262162, описывающая использование центра отслеживания сообщений для отслеживания сообщений (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856, описывающая порядок включения отслеживания сообщений в Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905, описывающая идентификаторы событий при отслеживании сообщений на сервере Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864, описывающая улучшенные функции отслеживания сообщений на сервере Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

Дополнительные сведения об устранении неполадок классификатора сообщений см. в веб-презентации службы поддержки Майкрософт, представляющей: устранение неполадок классификатора сообщений и отчетов о недоставке в Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137).

Дополнительные сведения о средстве приемника архива см. в базе знаний Майкрософт в статье 307798, описывающей служебную программу приемника архива, доступную в пакете обновления 2 (SP2) (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Общие сведения об устранении проблем, связанных с транспортом, см. в следующих статьях базы знаний Майкрософт:

  • 821910, описывающая устранение проблем транспорта в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265, описывающая общие сведения об устранении проблем транспорта в Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

Счетчики производительности классификатора сообщений публикуются отдельно для каждого экземпляра виртуального сервера SMTP. Список доступных счетчиков производительности, связанных с классификатором сообщений, см. в базе знаний Майкрософт в статье 231734, описывающей счетчики системного монитора для классификатора сообщений (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).

Сведения о некоторых других WMI-счетчиках классификатора см. в следующих статьях об анализаторе сервера Exchange:

  • Предупреждение об ошибке SMTP-сообщения — не найдены просмотры адресов классификатора

  • Предупреждение об ошибке SMTP-сообщения — ошибка входа в каталог классификатора

  • Предупреждение об ошибке SMTP-сообщения — ошибка службы каталогов классификатора

  • Предупреждение о недоставке сообщения SMTP — Недостаточно памяти классификатора

  • Предупреждение об ошибке SMTP-сообщения — повторяющаяся ошибка классификатора


Предупреждение о недоставке сообщения SMTP — Недостаточно памяти классификатора
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-03-28

Средство анализа Microsoft® Exchange Server Analyzer Tool запрашивает класс инструментария Microsoft Windows® Management Instrumentation (WMI) Win32_PerfRawData_SMTPSVC_SMTPServer, чтобы определить значение параметра CatCategorizationsfailedOutOfMemory. Значение этого параметра показывает число процессов классификации, которые не удалось выполнить из-за отсутствия свободной памяти. Средство анализа Exchange Server Analyzer также запрашивает раздел WMI Win32_PerfRawData_PerfOS_System, чтобы определить значение параметра SystemUpTime.

Если средство анализа Exchange Server Analyzer обнаружит, что значение параметра SystemUpTime больше 0, а частное от деления значения CatCategorizationsfailedOutOfMemory на значение SystemUpTime больше 50, появится сообщение об ошибке.

Классификатор сообщений проверяет сообщения, поступающие на сервер SMTP, и определяет, что делать с ними дальше. Сообщения могут направляться в локальное хранилище информации, на удаленный компьютер через агент передачи сообщений (MTA) или на удаленный компьютер через протокол SMTP. Классификатор также обрабатывает расширение списка рассылки. Классификатор — это дополнительный модуль для системы организации очереди, выполняющей запросы LDAP по серверам глобального каталога через порт 3268 протокола TCP. Классификатор в основе своей — это набор приемников событий, выполняющих усовершенствованное преобразование адресов для каждого сообщения, проходящего через систему организации очереди. Он выполняет преобразование адресов, пересылку сообщений электронной почты, устанавливает метки преобразования содержимого, расширяет списки рассылки, внедряет глобальные параметры, создает сообщения о состоянии доставки, а также выполняет поиск альтернативного маршрута к получателю, ветвление надвое, ведение журналов и многие другие функции.

Как только сообщение попадает в классификатор, он определяет отправителя путем поиска адреса в атрибутах адреса прокси-сервера в службе каталогов Active Directory®. Классификатор также определяет получателя, просматривая все адреса в атрибуте адресов прокси-серверов в Active Directory. Например, если в списке есть список рассылки, он раскрывает список и добавляет в него эти контакты, если на сервере разрешено расширение списка рассылки.

Данное предупреждение свидетельствует о том, что около 50 процедур классификации или больше не удалось выполнить из-за недостатка доступной памяти. Это может быть вызвано разными причинами, в том числе и неполадками в работе DSAccess (доступа к службе каталога), задержками или сбоями репликации каталога, перегрузками на сервере глобального каталога и проблемами, связанными с DNS.

Важно!
Эта статья содержит сведения о правке реестра. Перед правкой реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра находятся в разделе «Восстановление реестра» справочной системы файла Regedit.exe или Regedt32.exe.

Устранение предупреждения

  1. Просмотрите журналы событий на компьютере Exchange Server на предмет наличия в них ошибок.

  2. Если события, которые бы позволили решить проблему, найти не удается, попробуйте включить диагностическое ведение журнала в классификаторе MSExchangeTransport на максимум. После включения диагностического ведения журнала просмотрите журнал событий еще раз. Если установка диагностического ведения журнала на максимум не дала никаких дополнительных записей в журнале событий, установите диагностическое ведение журнала на уровень 7, воспользовавшись реестром. Когда ведение журнала установлено на уровень 7, в журнал записывается событие 9000, порождаемое классификатором сообщений. В этом событии содержатся сведения о функции, причина сбоя, имя получателя, которому не удалось доставить сообщение, и тип получателя. Чтобы установить диагностическое ведение журнала на уровень 7, сделайте следующее:

    1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

    2. Перейдите в раздел

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. На правой панели дважды щелкните параметр 2 Categorizer, установите значение 7 и нажмите кнопку OK.

    4. Закройте редактор реестра.

      Примечание.
      После устранения неполадок снова установите для 2 Categorizer значение 0.

  3. Проверьте, имеет ли Exchange Server связь с одним или несколькими серверами глобального каталога. Для этого можно использовать сетевой монитор Windows.

  4. Проверьте создаваемые сообщения о состоянии доставки (DSN). Сообщения о состоянии доставки, среди которых могут быть и сообщения о недоставке (NDRs), описывают постоянные сбои в доставке сообщений и временные, которые зачастую перерастают в постоянные.

  5. Воспользуйтесь средством отслеживания сообщений, чтобы устранить неполадки, связанные с сообщениями, которые классификатор долго не может обработать.

  6. Воспользуйтесь средством Archive Sink для архивации и анализа сообщений, поступающих на Exchange Server и исходящих с него.

  7. Проверьте счетчики производительности классификатора с помощью системного монитора.

Список уведомлений о доставке и отчетов о недоставке, создаваемых серверами Exchange Server и Microsoft Windows Small Business Server, см. в статье 284204 базы знаний Майкрософт «Уведомления о состоянии доставки в Exchange Server и Small Business Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Для получения дополнительных сведений об использовании центра отслеживания сообщений в Exchange Server см. следующие статьи базы знаний корпорации Майкрософт:

  • 262162, «XADM. Использование центра отслеживания сообщений для отслеживания сообщения» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162) (на английском языке)

  • 246856, «XADM. Включение отслеживания сообщений в Exchange 2000 Server и Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856) (на английском языке)

  • 821905, «Коды событий отслеживания сообщений в Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905) (на английском языке)

  • 823864, «Усовершенствованные возможности отслеживания сообщений в Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864) (на английском языке)

Для получения дополнительных сведений об устранении неполадок, связанных с классификатором сообщений, см.веб-трансляцию службы поддержки Майкрософт «Exchange 2000 Server: классификатор сообщений и устранение неполадок при получении отчетов о недоставке» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137) (на английском языке).

Дополнительные сведения о приемнике архива см. в статье 307798 базы знаний Майкрософт «В пакете обновления 2 (SP2) доступен приемник архива» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798) (на английском языке).

Для получения общих сведений об устранении неполадок, связанных с передачей сообщений, см. следующие статьи базы знаний корпорации Майкрософт:

  • 821910, «Устранение неполадок с транспортом в Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910) (на английском языке).

  • 257265, «Общие сведения об устранении неполадок с транспортом в Exchange 2000 Server и Exchange Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265) (на английском языке).

Счетчики производительности классификатора создаются отдельно для каждого виртуального сервера SMTP. Для ознакомления со списком имеющихся счетчиков производительности, относящихся к классификатору сообщений, см. статью 231734 базы знаний корпорации Майкрософт «XCON. Счетчики системного монитора для классификатора сообщений» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734) (на английском языке).

Для получения сведений о других счетчиках WMI, относящихся к классификатору, см. следующие статьи о средстве анализа Exchange Server Analyzer:

  • Предупреждение об ошибке SMTP-сообщения — не найдены просмотры адресов классификатора

  • Предупреждение об ошибке SMTP-сообщения — ошибка входа в каталог классификатора

  • Предупреждение об ошибке SMTP-сообщения — ошибка службы каталогов классификатора

  • Предупреждение об ошибке SMTP-сообщения — неповторяющаяся ошибка классификатора

  • Предупреждение об ошибке SMTP-сообщения — повторяющаяся ошибка классификатора


Предупреждение об ошибке SMTP-сообщения — повторяющаяся ошибка классификатора
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-03-20

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_PerfRawData_SMTPSVC_SMTPServer, чтобы определить значение ключа CatCategorizationsfailedretryableerror. Значение этого ключа представляет количество классификаций, которые завершились сбоем с повторяющейся ошибкой. Анализатор сервера Exchange Server также запрашивает WMI-ключ Win32_PerfRawData_PerfOS_System, чтобы определить значение SystemUpTime.

Если анализатор сервера Exchange определяет, что значение ключа SystemUpTime больше 0, и что результат деления значения CatCategorizationsfailedretryableerror на значение SystemUpTime больше 500, выводится предупреждение.

Классификатор сообщений анализирует сообщения, которые поступают на SMTP-сервер, и определяет, что необходимо делать с сообщениями. Сообщения могут быть отправлены в информационное хранилище, удаленный узел с помощью агента передачи сообщений, или сообщения могут быть отправлены на удаленный узел с помощью протокола SMTP. Классификатор также обрабатывает расширение списка рассылки. Классификатор — это дополнительный модуль для расширенного механизма очередей, который выполняет LDAP-запросы (Lightweight Directory Access Protocol) на серверах глобального каталога по TCP-порту 3268. По существу, классификатор — это набор приемников событий, которые выполняют расширенное разрешение адресов по каждому сообщению, проходящему через расширенный механизм очередей. Классификатор выполняет разрешение адресов, переадресацию почты, устанавливает флаги преобразований, расширяет списки рассылки, принудительно устанавливает глобальные параметры, создает уведомления о состоянии доставки, а также выполняет определение дополнительных маршрутов приема, ветвление, ведение журнала и многие другие функции.

После того как сообщение попадает в классификатор сообщений, он определяет отправителя конверта путем поиска адреса в атрибутах адреса прокси-сервера в службе каталогов Active Directory®. Классификатор также определяет получателя конверта путем поиска каждого адреса в атрибуте адресов прокси-серверов в службе Active Directory. Например, если список включает список рассылки, он расширяет список для включения этих членов, если расширение списка рассылки разрешено на сервере.

Это предупреждение указывает, что ежедневно в среднем 500 или более классификаций заканчиваются сбоем с повторяющейся ошибкой. Существуют различные причины этого, включая проблемы с доступом к службе каталогов, задержки или сбои репликации каталогов, перегруженные серверы глобального каталога и проблемы со службой DNS.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить причину появления этого предупреждения

  1. Проверьте наличие ошибок в журналах событий на компьютере сервера Exchange.

  2. Если не найдено никаких ошибок, которые позволяют устранить проблему, рассмотрите возможность установки на максимум ведения журнала диагностики для классификатора MSExchangeTransport. После включения ведения журнала диагностики повторно проверьте журнал событий на наличие ошибок. Если настройка на максимальную регистрацию в журнале диагностики не приводит к появлению каких-либо записей в журнале событий, настройте уровень 7 для ведения журнала диагностики, используя для этого возможности реестра. Когда установлен уровень 7, в журнал будет заноситься событие с идентификатором 9000, создаваемое классификатором сообщений и описывающее функцию, причину сбоя, имя и тип получателя, для которого произошел сбой. Чтобы установить для ведения журнала диагностики уровень 7:

    1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

    2. Перейдите к разделу реестра:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. В правой части редактора дважды щелкните 2 Categorizer (2 Классификатор), установите значение равным 7, а затем нажмите кнопку OK.

    4. Закройте редактор реестра.

      Примечание.
      После завершения устранения неполадок верните значение параметра «2 Categorizer» (2 Классификатор) обратно в 0.

  3. Убедитесь, что сервер Exchange может установить подключения к одному или нескольким серверам глобального каталога. Для этого хорошо подойдет существующее в Windows средство наблюдения за сетью.

  4. Проанализируйте все создаваемые уведомления о состоянии доставки. В уведомлениях о состоянии доставки, которые могут включать отчеты о недоставке, описываются сообщения о постоянных ошибках и сообщения о временных ошибках, часто заканчивающиеся постоянными ошибками доставки.

  5. Используйте отслеживание сообщений для устранения проблем с сообщениями, которые попадают в классификатор.

  6. Используйте средство приемника архива для архивирования и анализа сообщений, поступающих на сервер Exchange и выходящих из него.

  7. Наблюдайте за счетчиками производительности классификатора с помощью системного монитора.

Список уведомлений о состоянии доставки и отчетов о недоставке, создаваемых серверами Exchange и Microsoft Windows Small Business Server, см. в базе знаний Майкрософт в статье 284204, посвященной уведомлениям о состоянии доставки на серверах Exchange и Small Business Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Сведения об использовании центра отслеживания сообщений на сервере Exchange см. в следующих статьях базы знаний Майкрософт:

  • 262162, описывающая использование центра отслеживания сообщений для отслеживания сообщений (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856, описывающая порядок включения отслеживания сообщений в Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905, описывающая идентификаторы событий при отслеживании сообщений на сервере Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864, описывающая улучшенные функции отслеживания сообщений на сервере Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

Дополнительные сведения об устранении неполадок классификатора сообщений см. в веб-презентации службы поддержки Майкрософт, представляющей: устранение неполадок классификатора сообщений и отчетов о недоставке в Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137).

Дополнительные сведения о средстве приемника архива см. в базе знаний Майкрософт в статье 307798, описывающей служебную программу приемника архива, доступную в пакете обновления 2 (SP2) (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Общие сведения об устранении проблем, связанных с транспортом, см. в следующих статьях базы знаний Майкрософт:

  • 821910, описывающая устранение проблем транспорта в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265, описывающая общие сведения об устранении проблем транспорта в Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

Счетчики производительности классификатора сообщений публикуются отдельно для каждого экземпляра виртуального сервера SMTP. Список доступных счетчиков производительности, связанных с классификатором сообщений, см. в базе знаний Майкрософт в статье 231734, описывающей счетчики системного монитора для классификатора сообщений (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).

Сведения о некоторых других WMI-счетчиках классификатора см. в следующих статьях о средстве анализатора сервера Exchange:

  • Предупреждение об ошибке SMTP-сообщения — не найдены просмотры адресов классификатора

  • Предупреждение об ошибке SMTP-сообщения — ошибка входа в каталог классификатора

  • Предупреждение об ошибке SMTP-сообщения — ошибка службы каталогов классификатора

  • Предупреждение об ошибке SMTP-сообщения — неповторяющаяся ошибка классификатора

  • Предупреждение о недоставке сообщения SMTP — Недостаточно памяти классификатора


Данные очереди почтовых сообщений SMTP записываются в сжатую папку
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Directory, чтобы определить значение ключа Compressed для папки очереди почтовых сообщений SMTP. Если анализатор сервера Exchange обнаруживает, что для ключа Compressed установлено значение True, выводится предупреждение.

Когда сообщения поступают на сервер Exchange с использованием службы SMTP, данные записываются на жесткий диск в виде EML-файлов. По умолчанию эти файлы хранятся в папке <диск>:\Program Files\Exchsrvr\Mailroot в том же разделе, в котором установлен Exhange. Если для папки, в которой хранится очередь почтовых сообщений SMTP, включено сжатие, производительность Exchange может сильно упасть. Поэтому сжатие для папки хранения очереди почтовых сообщений SMTP не поддерживается.

Корпорация Майкрософт не поддерживает хранение файлов данных Exchange на сжатых томах. При хранении файлов данных Exchange на сжатом томе дополнительные накладные расходы существенно замедляют производительность сервера Exchange. В число файлов Exchange входят следующие файлы:

  • EDB-файлы

  • STM-файлы

  • LOG-файлы

  • DAT-файлы

  • EML-файлы

  • CHK-файлы

Чтобы отключить сжатие файлов для заданной папки

  1. Щелкните правой кнопкой мыши папку, для которой нужно отключить сжатие файлов, и выберите команду Свойства.

  2. На вкладке Общие щелкните Дополнительно.

  3. В диалоговом окне Дополнительные атрибуты снимите флажок Сжимать содержимое для экономии места на диске, а затем нажмите кнопку ОК.

Чтобы переместить папку «Mailroot» в Exchange 2000 Server или Exchange Server 2003

  1. Откройте диспетчер Exchange.

  2. Щелкните узел Административные группы, разверните свою административную группу, разверните узел Серверы, разверните свой сервер, разверните узел Протоколы и затем разверните узел SMTP.

  3. Щелкните правой кнопкой мыши виртуальный сервер SMTP и выберите команду Остановить.

  4. Щелкните правой кнопкой мыши виртуальный сервер SMTP и выберите команду Свойства.

  5. На вкладке Сообщения рядом с полем Каталог очереди щелкните Обзор, а затем введите путь нового расположения папки «Очередь».

  6. Нажмите кнопку ОК.

  7. Щелкните правой кнопкой мыши виртуальный сервер SMTP и выберите команду Запустить.

Дополнительные сведения о перемещении папки «Mailroot» см. в статье 822933 базы знаний Майкрософт «How to change the Exchange 2003 SMTP Mailroot folder location» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915) (Инструкции по изменению местоположения папки SMTP «Mailroot» в Exchange Server 2003).


Данные очереди почтовых сообщений SMTP записываются в зашифрованную папку
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft® Exchange Server запрашивает класс Win32_Directory инструментария Microsoft Windows® Management Instrumentation (WMI), чтобы определить значение раздела Encrypted для папки очереди сообщений SMTP. Если анализатор обнаружит, что для Encrypted установлено значение True, появится предупреждение.

Когда на компьютер Exchange приходят сообщения через службу SMTP, данные записываются на жесткий диск в виде файла eml. По умолчанию эти файлы хранятся в папке <диск>:\Program Files\Exchsrvr\Mailroot на том же разделе диска, на котором установлен Exchange. Если для папки, в которой хранится очередь сообщений SMTP, включено шифрование файлов, производительность Exchange может значительно снизиться. Поэтому шифрование папки, в которой хранится очередь сообщений SMTP, не поддерживается.

Макрософт не поддерживает хранение файлов данных Exchange на зашифрованном томе EFS. При хранении файлов данных Exchange на зашифрованном томе дополнительная нагрузка существенно влияет на быстродействие Exchange. Файлы данных Exchange включают в себя следующие файлы:

  • файлы edb

  • файлы stm

  • файлы log

  • файлы dat

  • файлы eml

  • файлы chk

Для обеспечения безопасности ваших файлов данных Exchange рекомендуется предотвратить несанкционированный доступ к серверу Exchange и использовать формат сообщений S/MIME для шифрования данных сообщений.

Чтобы исправить эту ошибку, нужно либо отключить шифрование файлов в папке очереди сообщений SMTP, либо переместить папку очереди сообщений SMTP в папку, в которой шифрование отключено.

Для отключения шифрования файлов в указанной папке

  1. Щелкните правой кнопкой мыши папку, для которой нужно отключить шифрование, и выберите Свойства.

  2. На вкладке Общие нажмите кнопку Дополнительно.

  3. В диалоговом окне Дополнительные атрибуты снимите флажок Шифровать содержимое для защиты данных и нажмите кнопку OK.

Перемещение папки очереди сообщений SMTP в Exchange 2000 Server или Exchange Server 2003

  1. Запустите системный диспетчер Exchange.

  2. Щелкните Административные группы, раскройте вашу административную группу, раскройте Серверы, раскройте ваш сервер, раскройте Протоколы, а затем раскройте SMTP.

  3. Щелкните правой кнопкой мыши виртуальный сервер SMTP и нажмите кнопку Остановить.

  4. Щелкните правой кнопкой мыши виртуальный сервер SMTP и выберите Свойства.

  5. На вкладке Сообщения нажмите рядом с полем Каталог нежелательной почты кнопку Обзор и введите путь к новому расположению папки очереди.

  6. Нажмите кнопку OK.

  7. Щелкните правой кнопкой мыши виртуальный сервер SMTP и щелкните Запустить.

Для получения дополнительных сведений о перемещении корневой папки почты см. статью 822933 базы знаний корпорации Майкрософт «Как изменить расположение корневой папки почты SMTP в Exchange 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).

Для получения дополнительных сведений о файлах данных сервера Exchange и EFS см. статью 834638 базы знаний корпорации Майкрософт «Сведения о хранении файлов данных сервера Exchange на зашифрованном томе» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638).

Для получения сведений о защите сообщений в Microsoft Exchange Server 2003 см. Руководство по безопасности сообщений в Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47574).


Данные очереди SMTP записаны в раздел формата, отличного от формата NTFS
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_Directory, чтобы определить значение раздела FSName для каталога очереди SMTP в Exchange. Если анализатор сервера Exchange определяет, что значение раздела FSName не равно значению Файловая система NTFS, на экран выдается сообщение об ошибке.

Корпорация Майкрософт не поддерживает хранение файлов данных Exchange на томах формата, отличного от формата NTFS. В число файлов Exchange входят следующие файлы:

  • EDB-файлы

  • STM-файлы

  • LOG-файлы

  • DAT-файлы

  • EML-файлы

При появлении этой ошибки необходимо перейти в каталог очереди SMTP в папку на диске NTFS. В альтернативном варианте, если диск, на котором хранится каталог очереди, отформатирован как диск FAT, для преобразования формата в формат NTFS можно использовать средство командной строки convert.exe.

Чтобы переместить очередь SMTP в другую папку

  1. Откройте диспетчер Exchange

  2. Щелкните узел Административные группы, разверните вашу административную группу, разверните узел Серверы, разверните ваш сервер, разверните узел Протоколы и затем разверните узел SMTP.

  3. Щелкните правой кнопкой мыши виртуальный сервер SMTP и затем щелкните Стоп.

  4. Щелкните правой кнопкой мыши виртуальный сервер SMTP и затем щелкните Свойства.

  5. На вкладке Сообщения рядом с полем Каталог BadMail щелкните Обзор и затем введите путь нового расположения папки "Очередь".

  6. Нажмите кнопку ОК.

  7. Щелкните правой кнопкой мыши виртуальный сервер SMTP и затем щелкните Пуск.

Дополнительные сведения о перемещения папки Mailroot см. в базе знаний Майкрософт в статье 822933, "How to change the Exchange 2003 SMTP Mailroot folder location" (Инструкции по изменению местоположения папки Mailroot SMTP в Exchange 2003) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).

В альтернативном варианте по отношению к процедуре, описанной в данной статье, если диск, на котором хранятся файлы, отформатирован как диск FAT, для преобразования формата в формат NTFS можно использовать средство командной строки convert.exe. Сведения об использовании средства командной строки convert.exe для преобразования раздела формата FAT в раздел формата NTFS см. в базе знаний Майкрософт в статье 214579, "How to Use Convert.exe to Convert a Partition to the NTFS File System" (Инструкции по преобразованию формата раздела в формат файловой системы NTFS) http://go.microsoft.com/fwlink/?linkid=3052&kbid=214579).


Значение SMTP MaxDSNSize было задано вручную
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-01-17

Анализатор сервера Microsoft® Exchange считывает следующий подраздел реестра, чтобы выявить, переопределен ли макисмальный размер сообщений уведомления состояния доставки вручную:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MaxDSNSize

Если анализатор сервера Exchange обнаружит, что указано значение MaxDSNSize, отображается сообщение о том, что конфигурация отличается от заданной по умолчанию.

При наличии значения MaxDSNSize доступно удаление вложений на компьютере сервера Exchange 2000 Server с пакетом обновления 2 (SP2) или более поздней версии, если сообщение не удается доставить. Включение этого параметра позволяет экономить ресурсы сервера и сети. Однако такая реализация механизма удаления SMTP-вложений имеет и отрицательные стороны.

При включении этого параметра для удаления вложений из отчетов о недоставке также будут удаляться сведения, необходимые для вывода уведомления в области предварительного просмотра. В результате источник сообщения не сможет использовать параметр повторной отправки. Если источник сообщения предпримет попытку использовать в отчете о недоставке параметр повторной отправки, он получит следующее сообщений об ошибке:

«Не удается повторно отправить сообщение. Отчет о недоставке содержит недостаточно данных об исходном сообщении. Чтобы повторно отправить сообщение, откройте его в папке «Отправленные», щелкните меню «Действия» и выберите команду «Отправить сообщение повторно."

Однако источник сообщения не сможет отправить его повторно, даже следуя инструкциям, содержащимся в сообщении об ошибке. Таким образом, перед использованием данного параметра рекомендуется тщательно обдумать этот шаг.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.

Чтобы изменить значение реестра MaxDSNSize

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите в раздел реестра: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. Создайте значение реестра с типом DWORD под названием MaxDSNSize и установите в нем нужный объем (в байтах).

  4. Закройте редактор реестра и перезапустите SMTP-службу, чтобы изменения вступили в силу.

Перед редактированием реестра, а также для получения сведений о редактировании реестра см. статью 256986 базы знаний Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения о значении реестра MaxDSNSize см. в следующих статьях базы знаний Майкрософт:

  • 308303, «XCON: Option to Strip Attachments for Messages That Generate an NDR»(http://go.microsoft.com/fwlink/?linkid=3052&kbid=308303) (Параметр удаления вложений для сообщений, которые создают отчет о недоставке)

  • 323484, «XCON: Description of the Multipart/Report Internet Message Format in Exchange 2000» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=323484) (Описание формата сообщений Интернета - составных и отчетов - в Exchange 2000)


Значение раздела реестра MaxPendingCat для SMTP не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, изменена ли конфигурация очереди SMTP по умолчанию, анализатор сервера Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Если анализатор сервера Exchange обнаружит, что раздел реестра MaxPendingCat был установлен, анализатор сервера Exchange отобразит сообщение о нестандартной конфигурации.

Рекомендуется создавать и изменять значения реестра, только после учета всех последствий. Значения по умолчанию были тщательно выбраны для оптимальной работоспособности в большинстве сред. Рекомендуется искать основную причину неполадок, а не изменять поведение очередей в Exchange по умолчанию.

Анализатор сервера Exchange отображает эту конфигурацию только для сведений. Никаких действий выполнять не требуется.

Дополнительные сведения об очередях SMTP в Exchange см. в записях блога группы Microsoft Exchange, посвященных объяснению работы модуля SMTP (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=48585).


Значение параметра MaxMessageObjects по протоколу SMTP установлено слишком малым
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить максимальное число почтовых сообщений, которые система может распределить:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\MailMsg\MaxMessageObjects

Если анализатор сервера Exchange находит, что значение параметра MaxMessageObjects меньше 30001, на экран выводится предупреждение.

Когда в очереди находится максимальное число сообщений, протоколом SMTP никакие дополнительные входящие сообщения не принимаются. Каждый резидент почтового сообщения в очереди SMTP использует по меньшей мере 4 КБ памяти, поэтому есть вероятность попасть в ситуацию малого объема памяти с очень большой очередью.

Значение параметра MaxMessageObjects не задано по умолчанию, и максимальное число сообщений установлено равным 100 000. При установке меньшего значения параметра MaxMessageObjects уменьшается максимальное число сообщений, которые могут находиться в очереди, что приводит к уменьшению максимального пространства памяти для SMTP. После достижения предельного значения каждое SMTP-подключение возвращает сообщение об ошибке в связи с отсутствием свободной памяти.

Важно!
Этот раздел содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы установить предельное значение числа сообщений SMTP, которые можно поставить в очередь

  1. Запустите редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к следующему разделу реестра: HKLM\Software\Microsoft\Exchange

  3. Щелкните правой кнопкой мыши имя компьютера и выберите Создать раздел. Присвойте название новому разделу MailMsg.

  4. Щелкните правой кнопкой мыши раздел MailMsg и затем щелкните Создать значение DWORD.

  5. Щелкните правой кнопкой мыши новое значение, затем щелкните "Переименовать" и затем введите MaxMessageObjects.

  6. Дважды щелкните параметр MaxMessageObjects и затем установите его значение равным максимально возможному, по вашему мнению, в любой данный момент числу сообщений в очередях. Если нет необходимости обрабатывать больше сообщений, рекомендуется установить максимальное значение равным 100 000.

  7. Выйдите из редактора реестра и перезапустите службу SMTP, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об установке предельных значений на сообщения в очередях см. базе знаний Майкрософт в статье 258748, описывающей порядок установки предельного числа сообщений SMTP в очередях (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258748).


Изменено значение параметра реестра MaxMessageObjects для SMTP, принимаемое по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Анализатор сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить максимальное число почтовых сообщений, разрешенное в системе:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\MailMsg\MaxMessageObjects

Если анализатор сервера Exchange обнаруживает, что значение MaxMessageObjects больше 0, выводится сообщение о том, что текущая конфигурация отличается от используемой по умолчанию.

Когда в очереди содержится максимально допустимое число сообщений, никакие другие сообщения в SMTP приниматься не будут. Каждое почтовое сообщение, находящееся в очереди SMTP, использует не менее 4 килобайт (КБ) памяти, поэтому слишком большая очередь может вызвать проблему нехватки памяти.

Значение MaxMessageObjects по умолчанию не определено, и максимальное число сообщений устанавливается равным 100000. Присваивание параметру MaxMessageObjects меньшего значения снижает максимальный предел числа сообщений в очереди и тем самым сокращает максимальный объем памяти, отводимой для SMTP. После достижения этого предела при каждом подключении SMTP к серверу будет возвращаться сообщение об отсутствии свободной памяти.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы установить предельное число сообщений SMTP, включаемых в очередь

  1. Откройте редактор реестра, например Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\Software\Microsoft\Exchange

  3. Щелкните раздел Exchange правой кнопкой мыши и выберите команду Создать раздел. Присвойте новому разделу имя MailMsg.

  4. Щелкните раздел MailMsg правой кнопкой мыши и выберите команду Создать параметр DWORD.

  5. Щелкните новый параметр правой кнопкой мыши, выберите команду «Переименовать» и введите MaxMessageObjects.

  6. Дважды щелкните параметр MaxMessageObjects и присвойте ему значение, равное максимальному числу сообщений, которые смогут находиться в очереди в каждый момент времени. Рекомендуется использовать максимальное значение 100000, если не планируется обрабатывать большее число сообщений.

  7. Закройте редактор реестра и перезапустите службу SMTP, чтобы изменения вступили в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об установке предельного числа сообщений для очередей см. в статье 258748 базы знаний, содержащей инструкции по установке предельного числа сообщений SMTP в очередях (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258748).


Параметр реестра MaxPercentPoolThreads для SMTP был задан вручную
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-01-17

Чтобы определить, были ли вручную настроены дополнительные потоки пула, средство анализатора сервера Microsoft® Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\MaxPercentPoolThreads

Если анализатор находит, что параметр MaxPercentPoolThreads существует и настроен, отображается сообщение о нестандартной конфигурации.

Существует пять рабочих очередей в SMTP, которые используют пул потоков, известных как потоки ATQ. В соответствие с разработкой, две очереди по умолчанию используют 90 процентов доступных потоков. Этот пул потоков совместно используется процессом, принимающим POP, и запросами IMAP. Поэтому в сценариях средних и высоких нагрузок может возникнуть ситуация, при которой SMTP может не давать ресурсов службам POP и IMAP.

Можно зарезервировать адекватные потоки для POP и IMAP, ограничив процентное количество потоков, которые может использовать SMTP. Чтобы внести подобное изменение, необходимо увеличить общее количество потоков, доступных службам IIS. Единственным недостатком является увеличение использования памяти дополнительными потоками.

Существует два раздела реестра, с помощью которых можно управлять процентным количеством потоков SMTP для каждого процессора:

расположение: HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

значение: AdditionalPoolThreadsPerProc

тип: REG_DWORD

расположение: HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

значение: MaxPercentPoolThreads

тип: REG_DWORD

Необходимо изменить оба раздела реестра на компьютерах кластерных серверов Exchange, если высокая активность SMTP приводит к сбоям в работе POP, IMAP или обоих ресурсов одновременно. Можно использовать следующие формулы для расчета оптимального значения для кластера:

Значение реестра | Формула
AdditionalPoolThreadsPerProc | ((9 / (MaxPercentPoolThreads/100)) - 4) / 2
MaxPercentPoolThreads | 90 / (2 * количество виртуальных серверов протоколов)

Например, в кластере Exchange Server с двумя виртуальными серверами протоколов формула для параметра MaxPercentPoolThreads будет выглядеть следующим образом: 90 / (2*2) = 22. Если все расчеты при подсчете значения MaxPercentPoolThreads приведут к значению, содержащему дробную часть, необходимо округлить результат до ближайшего целого числа. Если расчеты при подсчете значения AdditionalPoolThreadsPerProc приведут к значению, превышающему 200, необходимо также задать значение для дополнительного раздела реестра:

расположение: HKLM\System\CurrentControlSet\Services\InetInfo\Parameters\

значение: PoolThreadLimit

тип: REG_DWORD

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы настроить оптимальный параметр в кластере Exchange

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Создайте значение реестра DWORD AdditionalPoolThreadsPerProc и установите значение для необходимо числа, основываясь на вышеприведенных формулах.

  4. Создайте значение реестра DWORD MaxPercentPoolThreads и установите значение для необходимо числа, основываясь на вышеприведенных формулах.

  5. Закройте редактор реестра и перезапустите службу администрирования IIS, чтобы изменения вступили в силу.

Перед редактированием реестра ознакомьтесь со статьей 256986 базы знаний Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Дополнительные сведения об обсуждаемом вопросе, связанным с ресурсом кластера, см. в статье 281868 базы знаний Майкрософт «XADM: POP\IMAP4 Virtual Servers Repeatedly Fail Over Under High Load» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=281868).


Значение реестра SMTP MsgHandleAsyncThreshold было добавлено вручную, но, возможно, в нем больше нет необходимости
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-01-17

Средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить, было ли максимальное число дескрипторов файла асинхронных служб IIS изменено по сравнению со значением по умолчанию, которое равняется 1,000:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MsgHandleAsyncThreshold

Если средство анализатора сервера Exchange обнаруживает, что MsgHandleAsyncThreshold существует и настроено с альтернативным значением, отображается предупреждение.

Значение MsgHandleAsyncThreshold указывает максимальное количество асинхронных дескрипторов файла, которые могут использовать службы IIS. Дескрипторы файлов кэшируются с целью улучшения производительности, так как кэшированные дескрипторы файлов оберегают сервер от выполнения избыточных циклов процессора и ввода-вывода. Каждый раз, когда транспортный стек SMTP на компьютере с Exchange Server получает сообщение, оно направляется в файловую систему, где ожидает, пока его перенаправят в место назначения. Для записи в файловую систему транспортный стек SMTP получает файловый дескриптор, а затем передает сообщение в этот дескриптор. Каждый дескриптор требует примерно 2 КБ памяти выгружаемого пула. По умолчанию количество дескрипторов файлов кэша IIS составляет 800 на каждые 32 МБ.

До появления версии Exchange 2000 Server с пакетом обновления 2 (SP2) серверы Exchange, содержащие большие очереди SMTP-сообщений (например, в среднем 1,000 сообщений или больше) сталкивались с ограничениям производительности из-за параметра по умолчанию для службы SMTP, для которой было разрешено не более 1000 дескрипторов файлов. Так как для Exchange 2000 Server было установлено ограничение в 1000 дескрипторов файлов, служба SMTP могла записать в файловую систему только 1000 сообщений одновременно.

Чтобы улучшить производительность для больших систем часто одновременно настраивались три записи реестра, чтобы увеличить максимальное количество дескрипторов файлов, которые могли быть открыты с помощью службы SMTP (чтобы можно было обработать большее количество сообщений) и уменьшить количество открытых дескрипторов файлов для устанавливаемой файловой системы, другой компонент Exchange (чтобы избежать дефицита памяти в случае большой очереди). Эти значения реестра, которые не существовали по умолчанию и поэтому их пришлось добавлять вручную, перечислены ниже:

Расположение: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

Значение: MsgHandleThreshold

Тип: REG_DWORD

Место: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

Значение: MsgHandleAsyncThreshold

Тип: REG_DWORD

Место: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

Значение: FileCacheMaxHandles

Тип: REG_DWORD

Для записей MsgHandleThreshold и MsgHandleAsyncThreshold обычно устанавливаются одинаковые значения (как правило, больше 1,000), а значение FileCacheMaxHandles обычно снижается с 800 до 600.

Это значение реестра не существует по умолчанию, так как Exchange 2000 Server с пакетом обновления 2 и более поздней версии динамически определяет оптимальные значения, которые следует использовать. Если на сервере Exchange установлен Exchange 2000 Server с пакетом обновления 1 или более ранней версии, рекомендуется обновить его до последней версии пакета обновления и развернуть пакет. После обновления кода до последней версии можно удалить эти записи реестра.

Exchange Server 2003 динамически рассчитывает соответствующие параметры для дескрипторов файлов SMTP, поэтому эти параметры больше не нужны. Таким образом, если другие указания не получены от служб поддержки продуктов Майкрософт, перед обновлением компьютеров с Exchange 2000 Server с этими параметрами до Exchange Server 2003 необходимо удалить эти записи из реестра the registry.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы вернуть настройку по умолчанию

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. В области справа удалите значение MsgHandleAsyncThreshold.

  4. Закройте редактор реестра и перезапустите службу IIS Admin, чтобы изменение вступило в силу.

Перед редактированием реестра ознакомьтесь со статьей 256986 базы знаний Майкрософт «Описание реестра Microsoft Windows» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Параметр «MsgHandleThreshold» в реестре, относящийся к SMTP, добавлен вручную, но, возможно, больше уже не нужен
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-09-06

Чтобы определить, изменено ли значение по умолчанию, равное 1000, для максимального количества дескрипторов файлов IIS, средство анализатора сервера Microsoft® Exchange считывает следующую запись реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MsgHandleThreshold

Если анализатор сервера Exchange обнаружит, что параметр MsgHandleThreshold присутствует и установлен в другое значение, на экран будет выведено сообщение о том, что конфигурация отличается от конфигурации по умолчанию.

Значение параметра MsgHandleThreshold задает максимальное количество дескрипторов файлов, используемых службами IIS. Дескрипторы файлов кэшируются для повышения быстродействия, поскольку кэшированные дескрипторы файлов избавляют сервер от необходимости выполнять избыточные циклы ввода-вывода и процессора. Каждый раз, когда стек транспорта SMTP на компьютере сервера Exchange получает сообщение, оно направляется в файловую систему, где ожидает направления в место назначения. Чтобы записать сообщение в файловую систему, стек транспорта SMTP получает дескриптор файла, а затем передает сообщение в этот дескриптор. Дескриптор каждого файла занимает приблизительно 2 килобайта (КБ) памяти выгружаемого пула. По умолчанию на каждые 32 МБ памяти в кэше IIS приходится 800 дескрипторов файлов.

До появления Exchange 2000 Server с пакетом обновления 2 (SP2) серверы Exchange, поддерживавшие большие очереди SMTP-сообщений (например, в среднем 1000 и более сообщений), постоянно сталкивались с ограничениями по производительности из-за того, что для службы SMTP установка по умолчанию задавала максимум в 1000 дескрипторов файлов. Так как для Exchange 2000 Server по умолчанию максимальное количество дескрипторов файлов равнялось 1000, служба SMTP могла одновременно записать в файловую систему только 1000 сообщений.

Чтобы повысить производительность таких больших систем, одновременно изменялись три записи реестра для увеличения максимального количества дескрипторов файлов, которые могли открываться службой SMTP (чтобы можно было обработать больше сообщений), и для уменьшения количества дескрипторов открытых файлов установочной файловой системы, еще одного компонента Exchange (чтобы избежать полного расходования памяти в случаях, когда очередь большая). Эти параметры реестра, которые по умолчанию не существовали, и, соответственно, должны были добавляться вручную, перечисляются ниже:

Местоположение: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing,

Значение: MsgHandleThreshold,

Тип: REG_DWORD,

Местоположение: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing,

Значение: MsgHandleAsyncThreshold,

Тип: REG_DWORD,

Местоположение: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters,

Значение: FileCacheMaxHandles,

Тип: REG_DWORD.

Параметры MsgHandleThreshold и MsgHandleAsyncThreshold обычно устанавливаются равными одному и тому же значению (обычно значению больше 1000), а параметр FileCacheMaxHandles, как правило, уменьшается с 800 до 600.

Если сервер Exchange работает под управлением Exchange 2000 Server, рекомендуется провести обновление до новейшего пакета обновления и установить новейший пакет исправлений. После проведения обновления до последних версий программного кода рекомендуется установить параметр MsgHandleThreshold в значение по умолчанию, равное 1000.

Значение MsgHandleThreshold по умолчанию для Exchange Server 2003 равно 1000, поэтому эти настройки, переопределяющие параметры реестра, больше не нужны. Поэтому если нет иных указаний со стороны службы поддержки продуктов Майкрософт, прежде чем обновить какие-либо компьютеры Exchange 2000 Server с этими параметрами до уровня Exchange Server 2003, следует удалить из реестра данные разделы.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.

Чтобы устранить эту ошибку

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите к разделу реестра HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. Удалите раздел MsgHandleThreshold.

  4. Закройте редактор реестра и перезапустите службу администрирования IIS, чтобы изменение вступило в силу.

Сведения, с которыми следует ознакомиться до редактирования реестра, а также сведения по редактированию реестра см. в базе знаний Майкрософт в статье 256986, посвященной описанию реестра Microsoft Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Файлы Pickup службы SMTP записываются в сжатую папку
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange запрашивает WMI-класс (Windows® Management Instrumentation) Win32_Directory, чтобы определить значение ключа Compressed для папки PickUp службы SMTP (Simple Mail Transfer Protocol). Если анализатор сервера Exchange обнаруживает, что для ключа Compressed установлено значение True, выводится предупреждение.

Когда сообщения приходят на компьютер Exchange через службу SMTP, данные записываются на жесткий диск в виде EML-файлов. По умолчанию эти файлы хранятся в папке <диск>:\Program Files\Exchsrvr\Mailroot в том же разделе, в котором был установлен Exhange. Если для папки, в которой хранятся данные PickUp службы SMTP, включено сжатие файлов, быстродействие Exchange может быть существенно снижено. Поэтому сжатие для папки, в которой хранятся данные PickUp службы SMTP, не поддерживается.

Если выводится это предупреждение, необходимо отключить сжатие для папки, в которой хранятся данные PickUp службы SMTP или переместить эти данные в папку, для которой не используется сжатие.

Корпорация Майкрософт не поддерживает хранение файлов данных Exchange на сжатых томах. При хранении файлов данных Exchange на сжатом томе дополнительные накладные расходы значительно влияют на производительность Exchange. В число файлов Exchange входят следующие файлы:

  • EDB-файлы,

  • STM-файлы,

  • LOG-файлы,

  • DAT-файлы,

  • EML-файлы,

  • CHK-файлы.

Чтобы выключить сжатие файлов для заданной папки

  1. Щелкните правой кнопкой мыши папку, для которой нужно отключить сжатие файлов, и выберите команду Свойства.

  2. На вкладке Общие щелкните Дополнительно.

  3. В диалоговом окне Дополнительные атрибуты снимите флажок Сжимать содержимое для экономии места на диске, а затем нажмите кнопку ОК.

Дополнительные сведения о перемещения папки PickUp см. в базе знаний Майкрософт в статье, содержащей инструкции по изменению местоположения папки Mailroot службы SMTP в Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).


Файлы раскладки протокола SMTP записываются в зашифрованную папку
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализа сервера Microsoft® Exchange запрашивает класс Win32_Directory инструментария Microsoft Windows® Management Instrumentation (WMI), чтобы определить значение параметра Encrypted для папки раскладки протокола SMTP . Если Exchange Server Analyzer обнаруживает, что значение Encrypted установлено как Истина, отображается предупреждение.

Когда сообщения поступают на сервер Exchange через службу SMTP, данные записываются на жесткий диск как файл eml. По умолчанию эти файлы хранятся в папке <диск>:\Program Files\Exchsrvr\Mailroot в том же разделе, где установлен Exchange. Если в папке, где хранятся данные раскладки протокола SMTP, включено шифрование файлов, быстродействие Exchange может существенно снизиться. Следовательно, шифрование папки, где хранятся данные раскладки протокола SMTP, не поддерживается.

При получении данного предупреждения необходимо отключить шифрование в папке, где хранятся данные раскладки протокола SMTP, или же следует переместить данные раскладки протокола SMTP в незашифрованную папку.

Майкрософт не поддерживает хранение файлов данных Exchange на зашифрованном томе EFS. При хранении файлов данных Exchange на зашифрованном томе дополнительная нагрузка существенно влияет на быстродействие Exchange. Файлы данных Exchange включают в себя следующие файлы:

  • файлы edb

  • файлы stm

  • файлы log

  • файлы dat

  • файлы eml

  • файлы chk

Для обеспечения безопасности ваших файлов данных Exchange рекомендуется предотвратить несанкционированный доступ к серверу Exchange и использовать формат сообщений S/MIME для шифрования данных сообщений.

Для решения этой проблемы необходимо или отключить шифрование файлов в папке раскладки протокола, или переместить папку раскладки протокола в метосположение, где шифрование отключено.

Для отключения шифрования файлов в указанной папке

  1. Щелкните правой кнопкой мыши папку, где необходимо отключить шифрование, а затем щелкните Свойства.

  2. На вкладке Общие нажмите кнопку Дополнительно.

  3. В диалоговом окне Дополнительные атрибуты снимите флажок Шифровать содержимое для защиты данных, затем щелкните OK.

Для получения дополнительных сведений о перемещении папки раскладки см. статью 822933 базы знаний корпорации Майкрософт «Как изменить местоположение корневой папки SMTP в Exchange 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).

Для получения дополнительных сведений о файлах данных сервера Exchange и EFS см. статью 834638 базы знаний корпорации Майкрософт «Информация о хранении файлов данных на зашифрованном томе на сервере Exchange» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638).

Для получения информации о том, как обезопасить сообщения в Exchange Server 2003, см. Руководство по безопасности сообщений Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47574).


Файлы раскладки SMTP записываются в раздел с файловой системой, отличной от NTFS
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализа сервера Microsoft® Exchange запрашивает класс Win32_Directory инструментария Microsoft Windows® Management Instrumentation (WMI), чтобы определить значение параметра FSName для каталога раскладки SMTP Exchange. Если анализатор сервера Exchange определяет, что значение параметра FSName не равно NTFS, отображается предупреждение.

Microsoft не поддерживает хранение файлов данных Exchange на томах с файловой системой, отличной от NTFS. Файлы данных Exchange включают в себя следующие файлы:

  • файлы с расширением edb

  • файлы с расширением stm

  • файлы с расширением log

  • файлы с расширением dat

  • файлы с расширением eml

При появлении этого предупреждения необходимо переместить каталог раскладки SMTP в папку на диске, использующем файловую систему NTFS. Также можно использовать средство командной строки convert.exe, чтобы преобразовать диск в NTFS в том случае, если диск, на котором хранится каталог раскладки, отформатирован под файловую систему FAT.

Для получения дополнительных сведений о перемещении папки раскладки см. статью 822933 базы знаний корпорации Майкрософт «Как изменить местоположение корневой папки SMTP в Exchange 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).

Кроме того, можно использовать средство командной строки convert.exe, чтобы преобразовать диск в NTFS в том случае, если диск, на котором хранятся файлы, отформатирован под файловую систему FAT. Для получения сведений об использовании средства командной строки convert.exe для преобразования раздела FAT в раздел NTFS см. статью 214579 в базе знаний Майкрософт «Как использовать Convert.exe для преобразования раздела в файловую систему NTFS» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579).


Изменение порта SMTP
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-11

Анализатор сервера Exchange считывает следующее свойство метабазы служб IIS, чтобы определить, соответствует ли значение этого свойства значению по умолчанию 25:

/LM/SmtpSvc/<экземпляр виртуального сервера SMTP>/SMTPPORT

Если анализатор сервера Exchange обнаружит, что значение свойства SMTPPORT больше 25, на экран выводится предупреждение.

Свойство SMTPPORT представляет TCP-порт, по которому SMTP-сервер ожидает входящие подключения. Виртуальные SMTP-серверы можно настроить на прослушивание одного или нескольких портов TCP. По умолчанию все виртуальные SMTP-серверы прослушивают TCP-порт 25 — порт SMTP по умолчанию. Если прослушиваемый порт SMTP был изменен со своего значения по умолчанию и больше не содержит TCP-порт 25 в своем списке, поток электронной почты может быть нарушен.

Разрешается изменить прослушиваемый порт SMTP, если изменить соответствующим образом и всю инфраструктуру внутреннего обмена сообщениями. Но, как правило, нельзя использовать другие порты для виртуальных SMTP-серверов, которые получают сообщения напрямую из Интернета, так как SMTP-серверы в Интернете посылают сообщения через порт 25.

Примечание.
Анализатор сервера Exchange исследует значение для виртуального SMTP-сервера Exchange. Виртуальный SMTP-сервер может и не являться SMTP-сервером, который получает сообщения напрямую из Интернета. Существует несколько продуктов, предназначенных для борьбы с вирусами и нежелательной почтой, которые получают SMTP-сообщения из Интернета по порту 25 и перенаправляют их на виртуальный SMTP-сервер Exchange или на другой порт. В этом сценарии виртуальный SMTP-сервер Exchange, который прослушивает порт, отличный от 25, является приемлемой конфигурацией.
Чтобы просмотреть или изменить порт прослушивания виртуального SMTP-сервера

  1. В диспетчере Exchange разверните узел Серверы, разверните сервер Exchange, разверните узел Протоколы и затем разверните узел SMTP.

  2. Правой кнопкой мыши щелкните виртуальный SMTP-сервер (например, виртуальный SMTP-сервер по умолчанию) и в контекстном меню выберите Свойства.

  3. Выберите вкладку Общие и щелкните Дополнительно.

  4. Появится список IP-адресов и портов.

    • Чтобы изменить существующий порт, выберите IP-адрес и щелкните Изменить. Измените TCP-порт в соответствующем поле на 25.

    • Чтобы добавить порт 25 в качестве дополнительного прослушиваемого порта, нажмите кнопку Добавить и добавьте новую комбинацию, состоящую из IP-адреса и порта. Если используется фильтрация подключения, отправителя или получателя, убедитесь, что установлены соответствующие флажки.

  5. Нажмите кнопку ОК, чтобы сохранить изменения, а затем снова нажмите кнопку ОК, чтобы закрыть диалоговое окно Дополнительно. Нажмите кнопку ОК, чтобы закрыть диалоговое окно Свойства для виртуального SMTP-сервера.

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • статья 266686, посвященная первой части инструкции по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686);

  • статья 268163, посвященная второй части инструкции по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).


Папка очереди протокола SMTP содержит большое количество файлов
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-10-06

Средство анализа Microsoft® Exchange Server запрашивает метабазу сервера Microsoft IIS для получения значения атрибута QueueDirectory для каждого экземпляра виртуального сервера протокола SMTP.

Затем средство анализа Exchange Server подсчитывает количество файлов в папке очереди, указанной для каждого виртуального сервера SMTP.

Если средство анализа Exchange Server обнаруживает, что папка очереди виртуального сервера SMTP содержит 50 000 и более файлов, выводится предупреждение.

Если средство анализа Exchange Server обнаруживает, что папка очереди виртуального сервера SMTP содержит 90 000 и более файлов, выводится сообщение об ошибке.

Появление предупреждения или ошибки означает чрезмерное накопление сообщений для обработки экземпляром виртуального сервера SMTP. Такое предупреждение или ошибка означают значительную потерю быстродействия либо связи с сервером, поскольку сервер более не может своевременно доставлять входящую почту. Эта задержка может быть вызвана следующими условиями:

  • Обращения в службу каталогов Active Directory® происходят недостаточно быстро.

  • Сообщения для локальной доставки или передачи по протоколу SMTP отправляются недостаточно быстро.

Чтобы устранить эту проблему, выполните следующие действия:

  • Проверьте сообщения в папке очереди на достоверность отправителя, чтобы убедиться, что сервер на подвержен аномальной нагрузке из-за нежелательной почты или вирусной атаки.

  • Убедитесь, что служба SMTP включена и запущена.

Проверка работы службы SMTP

  1. Откройте оснастку Services консоли Microsoft Management Console (MMC).

  2. На правой панели с помощью полосы прокрутки найдите службу Simple Mail Transfer Protocol (SMTP) и дважды щелкните ее название. На экране появится окно Simple Mail Transfer Protocol (SMTP) Properties.

  3. Убедитесь, что в меню параметра Startup type установлено значение Automatic.

  4. Нажмите кнопку Start для запуска системного помощника.

  5. Нажмите кнопку OK для сохранения изменений и закройте диалоговое окно Simple Mail Transfer Protocol (SMTP) Properties.

  6. Закройте оснастку Службы.

Дополнительные сведения об устранении проблем, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел «Устранение проблем, связанных с потоком почты и протоколом SMTP» в Руководстве по транспортировке и маршрутизации сервера Exchange по адресу: http://go.microsoft.com/fwlink/?LinkId=47579 (на английском языке).

  • Статья 823489 базы знаний Майкрософт «Использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003» о адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 821877 базы знаний Майкрософт «Описание полей на вкладках свойств очередей SMTP и X.400» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 264054 базы знаний Майкрософт «XCON: сведения о состояниях очередей в Exchange 2000 Server» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054 (эта ссылка может указывать на содержимое полностью или частично на английском языке).


Папка очереди SMTP и папка раскладки идентичны
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы проверить, что каталог раскладки сообщений не находится в том же каталоге, в котором размещается очередь сообщений для определенного виртуального SMTP-сервера. Если анализатор сервера Exchange обнаружит, что атрибут каталога очереди msExchSmtpQueueDirectory и атрибут каталога раскладки msExchSmtpPickupDirectory идентичны, анализатор отобразит сообщение об ошибке.

Эта ошибка является критической ошибкой. Если атрибуты msExchSmtpQueueDirectory и msExchSmtpPickupDirectory настроены на один и тот же каталог, будет производиться доставка дублированных сообщений. Обновить эти атрибуты можно с помощью средства ADSI Edit.

Внимание!
Могут возникнуть серьезные неполадки, если некорректно изменить атрибуты объектов Active Directory при использовании средства ADSI Edit, средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3. Для устранения этих неполадок может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.
Чтобы обновить атрибуты msExchSmtpPickupDirectory и msExchSmtpQueueDirectory с помощью ADSI Edit

  1. Запустите средство ADSI Edit из средств поддержки Windows® 2000 или из средств поддержки Windows Server 2003.

  2. Разверните следующие узлы:

    • контейнер конфигурации,

    • конфигурация,

    • службы,

    • Microsoft Exchange,

    • имя_организации,

    • политики получателей,

    • имя_административной_группы,

    • серверы,

    • имя_сервера,

    • протоколы,

    • SMTP.

  3. В области сведений щелкните правой кнопкой мыши CN=1 (где 1 — это виртуальные SMTP-сервер по умолчанию), затем щелкните Свойства.

  4. В поле Select which properties to view, щелкните Both.

  5. Обновите атрибут msExchSmtpPickupDirectory, чтобы он больше не конфликтовал с атрибутом msExchSmtpQueueDirectory, затем щелкните Set.

  6. Нажмите кнопку ОК, затем Применить и закройте средство ADSI Edit.

  7. Подождите, по меньшей мере, 15 минут до завершения репликации.


Очередь SMTP находится на одном диске с системным разделом
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить установленное значение атрибута msExchSmtpQueueDirectory.

Анализатор сервера Exchange также опрашивает WMI-класс Win32_Service, чтобы определить значение раздела Started для службы SMTP. Значение False указывает, что служба не запущена. Значение True указывает, что служба запущена. Кроме того, анализатор сервера Exchange опрашивает WMI-класс Win32_OperatingSystem, чтобы определить значение раздела WindowsDirectory. В значении этого раздела указывается местоположение системного диска Windows.

Если анализатор сервера Exchange обнаружит, что в значении атрибута msExchSmtpQueueDirectory указан путь на системный диск, на котором работает служба SMTP, а Exchange работает на Microsoft Windows Small Business Server, отображается предупреждение.

Атрибут msExchSmtpQueueDirectory означает путь к папке очереди SMTP, также известной как корневая папка почты Mailroot. Когда сообщения приходят на сервер Exchange по службе SMTP, данные записываются на жесткий диск в виде EML-файлов. По умолчанию эти файлы хранятся в папке <диск>:\Program Files\Exchsrvr\Mailroot в том же разделе, в котором был установлен Exhange.

В некоторых сценариях, например, при настройке сервера-плацдарма, можно увеличить производительность сервера Exchange, переместив корневой каталог почты SMTP на другой жесткий диск или раздел. Рекомендуется избегать расположения корневой папки почты SMTP на системной диске Windows. Вместо этого, для улучшения производительности корневая папка почты должна находиться на быстром диске или на подсистеме быстрого диска.

Если корневая папка почты может быть перемещена с помощью системного диспетчера Exchange на виртуальный SMTP-сервер Exchange Server 2003, для ее перемещения на виртуальный SMTP-сервер Exchange 2000 Server требуется низкоуровневый редактор Active Directory, например, Edit ADSI.

Внимание!
Могут возникнуть серьезные неполадки, если некорректно изменить атрибуты объектов Active Directory при использовании средства ADSI Edit, средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3. Для устранения этих неполадок может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Чтобы устранить эту ошибку в Exchange Server 2003

  1. Откройте системный диспетчер Exchange.

  2. Откройте Серверы, затем разверните сервер Exchange, Протоколы и SMTP.

  3. Правой кнопкой мыши щелкните виртуальный SMTP-сервер (например, виртуальный SMTP-сервер по умолчанию) и нажмите Остановить.

  4. Снова щелкните правой кнопкой мыши виртуальный SMTP-сервер, затем щелкните Свойства.

  5. Откройте вкладку Сообщения.

  6. В поле Каталог очереди укажите полный путь к корневой папке почты Mailroot. Можно щелкнуть Обзор, чтобы найти путь на локальном компьютере.

  7. Нажмите кнопку ОК, чтобы сохранить изменения.

  8. Щелкните правой кнопкой мыши виртуальный SMTP-сервер и нажмите Пуск. Новое местоположение будет немедленно использовано.

Чтобы устранить эту ошибку в Exchange 2000 Server

  1. Остановите сервер Exchange Server и службы IIS на компьютере сервера Exchange 2000 Server, на котором необходимо изменить корневую папку почты Mailroot виртуального SMTP-сервера.

  2. Измените значение параметра msExchSmtpQueueDirectory виртуального SMTP-сервера, чтобы задать необходимый путь.

  3. Дождитесь, пока Active Directory не завершит репликацию этого изменения на серверы глобального каталога, используемые этим сервером Exchange.

  4. Запустите службу системного помощника Microsoft Exchange.

  5. На компьютере сервера Exchange, убедитесь в наличии трех экземпляров кода события 1005 в журнале событий приложений, в которых источником события является MSExchangeMU, а категорией — Общие.

  6. Перезагрузите компьютер сервера Exchange, чтобы изменения вступили в силу.

Дополнительные сведения об обеих описанных процедурах см. в следующих статьях базы знаний Майкрософт:

  • 822933, описывающая изменение расположения корневой SMTP-папки почты Mailroot в Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822933);

  • 318230, описывающая инструкции по изменению расположения корневой SMTP-папки Mailroot в Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=318230);

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • 266686, описывающая первую часть инструкций по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, описывающая вторую часть инструкций по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


Значение реестра ResetMessageStatus для SMTP отличается от заданного по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, были ли изменены применяемые по умолчанию конфигурации очередей SMTP, анализатор сервера Microsoft® Exchange читает следующий параметр системного реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если выполняются следующие условия:

  • Значение параметра ResetMessageStatus на равно 0 (нулю).

  • Служба кластеров на сервере Exchange не работает.

Когда для параметра реестра ResetMessageStatus установлено значение 1, при перезапуске сервера Exchange все сообщения, в данный момент находящиеся в очереди, снова проходят все очереди внутренней обработки. Например, при перезапуске сервера Exchange все сообщения, в данный момент находящиеся в очереди, снова пройдут через классификатор. Поэтому значение 1 должно задаваться для параметра ResetMessageStatus только для устранения неполадок установки SMTP, как описано в статье 279616 базы знаний Майкрософт «XCON: Adding a Registry Key to Re-Categorize Messages» (Добавление параметра реестра для переклассификации сообщений) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=279616). Чтобы не диагностировать проблемы установки SMTP, этот параметр реестра следует удалить.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» программ Regedit.exe или Regedt32.exe.
Чтобы удалить параметр реестра ResetMessageStatus

  1. Откройте редактор реестра, например, Regedit.exe или Regedt32.exe.

  2. Перейдите в следующий раздел реестра: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. В правой области найдите и удалите значение ResetMessageStatus.

  4. Закройте редактор реестра.

Перед началом редактирования реестра для получения инструкций по выполнению этой процедуры изучите статью 256986 базы знаний Майкрософт "Description of the Microsoft Windows registry" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (Описание реестра Microsoft Windows).

Дополнительные сведения об организации очереди SMTP Exchange см. в разделе блога группы разработчиков Microsoft Exchange «Explaining the Mysterious SMTP Advanced Queuing Engine» (Объяснение таинств подсистемы расширенного управления очередями SMTP) (http://go.microsoft.com/fwlink/?LinkId=48585).


Значение раздела реестра ResetRoutesRetryMinutes для SMTP не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, изменена ли конфигурация очереди SMTP по умолчанию, анализатор сервера Exchange считывает следующий раздел реестра:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Если анализатор сервера Exchange обнаружит, что раздел реестра ResetRoutesRetryMinutes был установлен, анализатор сервера Exchange отобразит сообщение о нестандартной конфигурации.

Рекомендуется создавать и изменять значения реестра, только после учета всех последствий. Значения по умолчанию были тщательно выбраны для оптимальной работоспособности в большинстве сред. Рекомендуется искать основную причину неполадок, а не изменять поведение очередей в Exchange по умолчанию.

Анализатор сервера Exchange отображает эту конфигурацию только для сведений. Никаких действий выполнять не требуется.

Дополнительные сведения об очередях SMTP в Exchange см. в записях блога группы Microsoft Exchange, посвященных объяснению работы модуля SMTP (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=48585).


Нестандартное значение параметра реестра SMTP RoutingRetryMinutes
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализа Microsoft Exchange Server определяет изменение настроек постановки в очередь SMTP по следующему параметру реестра:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Если Exchange Server Analyzer обнаруживает, что установлен параметр RoutingRetryMinutes, появляется сообщение о нестандартной настройке.

Рекомендуется тщательно обдумать изменение порядка постановки в очередь по умолчанию. Значения по умолчанию были специально подобраны, чтобы обеспечить оптимальную производительность в любой среде. Рекомендуется устранить основную причину проблемы, прежде чем вносить изменения в порядок постановки в очередь Exchange Server.

Exchange Server Analyzer использует эту настройку только в информационных целях. Действий не требуется.

Для получения дополнительных сведений о порядке постановки в очередь SMTP Exchange см. запись в веб-дневнике команды Microsoft Exchange «Загадочный механизм расширенной постановки в очередь SMTP» (http://go.microsoft.com/fwlink/?LinkId=48585).


Значение SMTP SecondsPerDSNPass в реестре отличается от значения по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализа сервера Microsoft® Exchange считывает следующую запись из реестра, чтобы определить значение параметра реестра: SecondsPerDSNPass:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Если средство анализа средства Exchange обнаруживает наличие раздела SecondsPerDSNPass в реестре, и его значение не равно 10, отображается сообщение о том, что настройка по умолчанию изменена.

Этот параметр используется для оптимизации уведомлений о состоянии доставки и указывает количество секунд для обработки этих уведомлений. Когда этот порог превышен, создание уведомлений о состоянии доставки прекращается и возобновляется позже. Изменять значение по умолчанию рекомендуется, только серьезно взвесив ситуацию. Изменить значение определенного параметра можно только после консультации со службами поддержки корпорации Майкрософт. Значения по умолчанию были тщательно выбраны для оптимальной работе в большинстве сред. Обычно рекомендуется обратиться к первопричине проблемы вместо изменения правил составления очереди сервером Exchange.

Средство анализа средства Exchange сообщает эту конфигурацию только в информационных целях. Никаких специальных действий выполнять не требуется.


Для SMTP-сервера отключена проверка подлинности NTLM
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-11-10

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить, задан ли бит протокола проверки подлинности NTLM (встроенной проверки подлинности Windows) в атрибуте msExchAuthenticationFlags. Если анализатор сервера Exchange определяет, что этот бит не задан и Exchange не выполняется на сервере Microsoft Windows® Small Business Server, выводится предупреждение.

Атрибут msExchAuthenticationFlags показывает, какой тип проверки подлинности допускает виртуальный сервер протокола. В этом атрибуте используется трехбитовая маска.

Бит | Метод проверки подлинности
0 | Анонимная
1 | Основная
2 | NTLM (встроенная проверка подлинности Windows)

Если бит, контролирующий проверку подлинности NTLM, не задан, виртуальный SMTP-сервер не разрешит выполнение проверки подлинности NTLM. Это может вызвать проблемы проверки подлинности между компьютерами Exchange Server.

Чтобы устранить причину появления этого предупреждения

  1. Откройте диспетчер Exchange.

  2. Разверните узел Серверы, узел с именем сервера, узел Протоколы, а затем разверните узел SMTP.

  3. Щелкните правой кнопкой мыши виртуальный SMTP-сервер Exchange и выберите команду Свойства.

  4. Перейдите на вкладку Доступ, щелкните Проверка подлинности, а затем установите флажок Встроенная проверка подлинности Windows.

  5. Нажмите кнопку OK, а затем еще раз нажмите кнопку OK.

  6. Закройте диспетчер Exchange.

Дополнительные сведения о способах проверки подлинности для протокола SMTP см. в руководстве по транспорту и маршрутизации в Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579), а также в базе знаний Майкрософт в статье 319267, содержащей инструкции по безопасной доставке сообщений по протоколу SMTP в Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319267).


Значение реестра SMTP SubmissionRetryMinutes не является значением по умолчанию
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Чтобы определить, изменены ли заданные по умолчанию параметры конфигурации SMTP-очереди, анализатор сервера Microsoft® Exchange считывает следующий параметр реестра:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Если анализатор сервера Exchange обнаружит, что задан ключ SubmissionRetryMinutes, то выводит предупреждение о нестандартной настройке.

Рекомендуется, чтобы изменение заданных по умолчанию значений параметров очереди, выполнялось только после всесторонней оценки последствий этого действия. Значения по умолчанию определены по результатам тщательного анализа и обеспечивают оптимальную производительность в большинстве сред. Рекомендуется искать основную причину неполадок, а не изменять поведение очереди в Exchange.

Анализатор сервера Exchange Server подготавливает отчет по этой настройке исключительно в информационных целях. Никаких действий выполнять не требуется.

Дополнительные сведения об SMTP-очереди в Exchange см. в записях блога группы по Microsoft Exchange, посвященных усовершенствованному модулю SMTP-очередей (http://go.microsoft.com/fwlink/?LinkId=48585).


Ограничение размера сообщений на виртуальном SMTP-сервере больше, чем глобальное ограничение размера сообщений
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы сравнить ограничения входящих сообщений виртуального SMTP-сервера с глобальным ограничением входящих сообщений.

Атрибут Active Directory msExchSmtpMaxMessageSize представляет ограничение размера сообщений виртуального SMTP-сервера для входящих и исходящих сообщений. Это значение является атрибутом объекта виртуального SMTP-сервера в Active Directory, имеющим следующее расположение:

CN= <номер виртуального сервера>, CN=SMTP, CN=Protocols, CN= <имя_сервера> , CN=Servers, CN= <имя_административной_группы> , CN=Administrative Groups, CN= <имя_организации>, CN=Microsoft Exchange, CN=Services, CN=Configuration, DC= <имя_домена>, DC=com

Атрибут Active Directory delivContLength представляет глобальное ограничение размера входящих сообщений. Это значение является атрибутом объектом доставки сообщений глобальных параметров организации, имеющим следующее расположение:

CN=Message Delivery, CN=Global Settings, CN= <имя_организации> , CN=Microsoft Exchange, CN=Services, CN=Configuration, DC= <имя_домена>, DC=com

Если анализатор сервера Exchange находит, что значение msExchSmtpMaxMessageSize превышает значение delivContLength, отображается предупреждение.

Если ограничение размера сообщений любого виртуального SMTP-сервера превышает глобальное ограничение размера сообщений, сообщения, превышающие указанные размеры, могут быть приняты внутри организации, но не доставлены впоследствии. Чтобы решить этот вопрос, настройте виртуальный SMTP-сервер таким образом, чтобы наибольший размер сообщений не превышал глобальное ограничение размера входящих сообщений.

Примечание.
Слишком низкое ограничение размера сообщений может препятствовать синхронизации автономной адресной книги между компьютерами серверов Exchange. Дополнительные сведения об этом вопросе см. в статье 326154 базы знаний Майкрософт, посвященной невозможности репликации автономной адресной книги при ограничении размера сообщений на уровне транспорта (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326154).

Чтобы устранить причину появления этого предупреждения

  1. В системном диспетчере Exchange разверните узел Серверы, затем сервер Exchange, затем Протоколы и SMTP.

  2. Щелкните правой кнопкой мыши виртуальный SMTP-сервер (например, виртуальный SMTP-сервер по умолчанию) и выберите Свойства.

  3. Откройте вкладку Сообщения.

  4. Измените значение поля ??Ограничить размер сообщений (КБ)??, чтобы оно не превышало глобальное ограничение размера сообщений.

  5. Нажмите кнопку ОК, чтобы сохранить изменения и закрыть диалоговое окно Свойства виртуального SMTP-сервера.

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • 266686, описывающая первую часть инструкций по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, описывающая вторую часть инструкций по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

Дополнительные сведения о просмотре и изменении параметров организации см. в статье 821881 базы знаний Майкрософт, посвященной изменению глобальных параметров с помощью системного диспетчера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821881).

Дополнительные сведения о глобальном ограничении размера сообщений см. в следующих статьях базы знаний Майкрософт:

  • 298572, посвященной невозможности доставки сообщения электронной почты, превышающего ограничение размера отправляемого сообщения и ограничение размера получаемого сообщения (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298572)

  • 322679, описывающая установку ограничений размера для сообщений (может быть на английском языке) ((http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679)

  • 824111, посвященной изменениям и обновлениям параметров безопасности, появившихся в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=824111)


Для этого виртуального SMTP-сервера настроено выполнение обратных запросов DNS для входящих сообщений
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-08-24

Анализатор сервера Microsoft® Exchange Server выполняет запрос в службе каталогов Active Directory®, чтобы определить, было ли изменено настроенное значение атрибута msExchSmtpPerformReverseDnsLookup относительно своего значения по умолчанию False. По умолчанию атрибут msExchSmtpPerformReverseDnsLookup настроен не выполнять обратные запросы DNS для входящих сообщений. Если анализатор сервера Exchange определяет, что для этого атрибута задано значение True, на экран выводится предупреждение.

Параметр Выполнить обратные запросы DNS для входящих сообщений не предоставляет возможностей по предотвращению получения нежелательных сообщений электронной почты. Когда используется этот параметр, сервер Exchange выполняет запрос DNS с целью сопоставить IP-адрес входящих сообщений с именем компьютера. Затем имя компьютера присоединяется к заголовкам почтовых сообщений.

Если эта функция включена, может наблюдаться снижение производительности из-за неправильно настроенных записей DNS или неустойчивости подключений Интернета. Поэтому если доставка почты Интернета происходит медленнее, чем ожидается, этот параметр лучше отключить.

Чтобы включить или отключить обратные запросы DNS для входящих SMTP-сообщений

  1. Откройте диспетчер Exchange.

  2. Разверните узел Серверы, разверните «Сервер Exchange», разверните узел Протоколы и затем разверните SMTP.

  3. Правой кнопкой мыши щелкните виртуальный SMTP-сервер (например, виртуальный SMTP-сервер по умолчанию) и нажмите Свойства.

  4. На вкладке Доставка нажмите кнопку Дополнительно.

    • Чтобы включить обратные запросы DNS, установите флажок Выполнить обратный запрос DNS для входящих сообщений.

    • Чтобы отключить обратные запросы DNS, снимите флажок Выполнить обратный запрос DNS для входящих сообщений.

  5. Нажмите кнопку ОК, чтобы сохранить изменения, затем нажмите кнопку ОК, чтобы закрыть диалоговое окно Свойства виртуального SMTP-сервера.

Дополнительные сведения о функции обратного запроса DNS в Exchange см. в статье 297412 базы знаний Майкрософт, описывающей использование параметра «Выполнить обратный запрос DNS для входящих сообщений» с целью разрешения имен узлов (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • 266686, "XCON: инструкции из части 1 по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686);

  • 268163, "XCON: инструкции из части 2 по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).


Включена версия пакета обновления 1 интеллектуального фильтра сообщеий
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Анализатор сервера Microsoft® Exchange считывает следующую запись реестра, чтобы определить, был ли установлен и включен на сервере интеллектуальный фильтр сообщений Microsoft Exchange:

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

Анализатор сервера Exchange считывает значение ContentFilterBindings в разделе реестра ContentFilter, чтобы определить, был ли включен и установлен ли на сервере интеллектуальный фильтр сообщений.

Анализатор сервера Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) CIM_Datafile, чтобы определить, существует ли версия пакета обновления 1 для Exchange Server 2003 интеллектуального фильтра сообщений MSExchange.UceContentFilter.dll в следующем расположении на сервере Exchange:

<путь к двоичным файлам сервера Exchange>MSCFv1\MSExchange.UceContentFilter.dll

Примечание.
В этом пути <путь к двоичным файлам сервера Exchange> означает местоположение папки bin.

Если версия пакета обновления 1 для Exchange Server 2003 интеллектуального фильтра сообщений установлена и включена на сервере, анализатор сервера Exchange отображает предупреждения.

Это предупреждение означает, что доступна более новая версия интеллектуального фильтра сообщений. Рекомендуется установить последнюю версию интеллектуального фильтра сообщений. При устранении неполадок с почтовыми потоками именно на этом сервере может возникнуть необходимость временно отключить интеллектуальный фильтр сообщений, чтобы определить, не блокирует ли он допустимых получателей по ошибке.

Чтобы отключить интеллектуальный фильтр сообщений

  1. Нажмите кнопку Пуск и последовательно выберите Все программы, Microsoft Exchange, Диспетчер системы.

  2. В системном диспетчере Exchange последовательно разверните узлы Серверы, Имя_сервера, Протоколы, SMTP, щелкните правой кнопкой мыши узел Интеллектуальная фильтрация сообщений и выберите команду Свойства.

  3. На вкладке Общие в списке Применить интеллектуальную фильтрацию сообщений к следующим IP-адресам виртуальных серверов снимите флажок рядом с каждым виртуальным сервером SMTP, на котором требуется отключить интеллектуальный фильтр сообщений.

    Диалоговое окно «Свойства интеллектуальной фильтрации сообщений»

Дополнительные сведения см. на веб-узле, посвященном интеллектуальному фильтру сообщений Exchange (http://go.microsoft.com/fwlink/?LinkId=21607).


Включена версия интеллектуального фильтра сообщений из пакета обновления 2
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-04

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить, указывает ли свойство msExchServerBindingsFiltering объекта виртуального SMTP-сервера на включение интеллектуального фильтра сообщений для экземпляра виртуального SMTP-сервера.

Анализатор также опрашивает Active Directory, чтобы определить, включено ли значение msExchUceEnabled на уровне глобальных параметров.

Анализатор сервера Exchange выводит на экран предупреждение, если выполняются следующие условия:

  • Интеллектуальный фильтр сообщений включен для экземпляра виртуального SMTP-сервера.

  • Интеллектуальный фильтр сообщений включен на уровне глобальных параметров.

Это предупреждение указывает, что версия интеллектуального фильтра сообщений Exchange Server 2003 с пакетом обновления 2 успешно включена. Включение интеллектуального фильтра сообщений из пакета обновления 2 обычно не является проблемой, если не происходит устранение неполадок, связанных с потоком сообщений на этом сервере. В этом случае, возможно, следует проверить конфигурацию фильтра или временно отключить интеллектуальный фильтр сообщений, чтобы определить, блокирует ли он по ошибке допустимую почту.

Чтобы отключить интеллектуальный фильтр сообщений

  1. Нажмите кнопку Пуск, укажите Все программы, Microsoft Exchange, а затем щелкните Системный диспетчер.

  2. В системном диспетчере Exchange разверните узел Серверы, затем Имя сервера, затем Протоколы и SMTP.

  3. В разделе Свойства виртуального SMTP-сервера на вкладке Общие, щелкните Дополнительно.

  4. Выберите IP-адрес, для которого следует отключить интеллектуальный фильтр сообщений, и нажмите кнопку Изменить.

  5. В пункте Идентификация снимите флажок ??Применить интеллектуальный фильтр сообщений??.

  6. Если существует несколько виртуальных серверов, повторите шаги с 3 по 6 для каждого виртуального сервера, на котором следует отключить интеллектуальный фильтр сообщений.

Дополнительные сведения см. на веб-узле, посвященном интеллектуальному фильтру сообщений Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=21607).


Указанный сервер шлюза не используется
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-08-09

Средство анализатора сервера Microsoft® Exchange посылает тестовое сообщение с сервера Exchange на определяемую пользователем учетную запись, а затем сканирует на сервере журналы отслеживания сообщений, чтобы определить, были ли обнаружены какие-либо проблемы, связанные с доставкой тестового сообщения.

Как часть этого сканирования анализатор сервера Exchange проверяет, совпадает ли сервер шлюза Exchange, используемый для маршрутизации сообщения к внешнему получателю, с сервером, который задан пользователем на странице «Ввод сведений о сервере и пользователе» в процессе указания учетных данных и имени сервера.

Если анализатор сервера Exchange определит, что сообщение было успешно направлено за пределы организации Exchange, но не использовало указанный сервер шлюза, на экран будет выведено предупреждение.

Это предупреждение указывает на возможную проблему с топологией маршрутизации Exchange и на присутствие неизвестных серверов шлюза исходящих сообщений.

Проблемы с маршрутизацией могут возникать, если записи промежуточных узлов установлены на уровне виртуального сервера вместо их установки на уровне соединителя. Рекомендуется устанавливать все записи промежуточных узлов на SMTP-соединителе, а не на виртуальном SMTP-сервере.

Для устранения причин появления этого предупреждения, выполните следующие шаги:

  • Проанализируйте конфигурацию виртуального SMTP-сервера, чтобы убедиться в отсутствии установленных записей промежуточных узлов.

  • Проанализируйте конфигурацию локальных серверов-плацдармов на правильность адресных пространств и затрат памяти на соединителях.

Чтобы просмотреть и изменить параметры промежуточного узла

  1. Откройте диспетчер Exchange.

  2. Разверните узел Серверы, затем разверните сервер Exchange, Протоколы и SMTP.

  3. Щелкните правой кнопкой мыши виртуальный сервер SMTP (например, виртуальный сервер SMTP по умолчанию) и выберите команду Свойства.

  4. Выберите вкладку Доставка, а затем щелкните Дополнительно.

  5. Очистите все записи в разделе Промежуточный узел.

  6. Нажмите кнопку ОК, чтобы сохранить изменения, затем щелкните ОК, чтобы закрыть диалоговое окно Свойства виртуального SMTP-сервера.

Дополнительные сведения о настройке SMTP-соединителей см. в базе знаний Майкрософт, в статье 822941, содержащей инструкции по использованию SMTP-соединителей для подключения групп маршрутизации в Exchange 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822941).

Дополнительные сведения об устранении проблем, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел по устранению проблем, связанных с потоком почты и протоколом SMTP в Руководстве по транспортировке и маршрутизации сервера Exchange (http://go.microsoft.com/fwlink/?LinkID=67875).

  • База знаний Майкрософт, статья 823489, описывающая использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).


Указанный отправитель находится на другом сервере
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-08-10

Чтобы определить, существует ли соответствие для указанного пользователем SMTP-адреса (Simple Mail Transfer Protocol), средство анализатора сервера Microsoft® Exchange запрашивает значение атрибута proxyAddress службы каталогов Active Directory® для всех объектов пользователя.

Если соответствие для атрибута proxyAddress объекта пользователя найдено, тогда анализатор сервера Exchange запрашивает значение атрибута msExchHomeServerName объекта пользователя в службе каталогов Active Directory, чтобы определить, совпадает ли это значение с заданным пользователем именем сервера Exchange.

Если анализатор сервера Exchange определит, то значение атрибута msExchHomeServerName для указанного пользователем отправителя не совпадает с заданным пользователем именем сервера Exchange, на экран будет выведено предупреждение.

Это предупреждение указывает, что было предоставлено неправильное имя сервера Exchange, или что проблема потока почты влияет на сервер, отличный от сервера, заданного пользователем.

Чтобы устранить эту проблему, проверьте правильность введенного имени сервера Exchange.

Чтобы просмотреть почтовые ящики пользователей на указанном сервере

  1. Запустите диспетчер Exchange, выполнив следующие действия:

    Нажмите кнопку Пуск, укажите Программы, выберите Microsoft Exchange, а затем щелкните Диспетчер.

  2. В окне Диспетчер Exchange, используя функцию обзора, найдите и выберите следующий контейнер:

    \Administrative Groups\ GroupName \Servers\ ServerName \ StorageGroupName \Mailbox Store\Mailboxes

  3. Убедитесь, что указанный почтовый ящик пользователя отображается на заданном сервере Exchange.


Не удалось идентифицировать целевые конечные серверы
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-07-06

Анализатор сервера Microsoft® Exchange предпринимает попытку выявить полные доменные имена, IP-адреса и доменные имена удаленных серверов, для которых предназначена почта в очереди удаленной доставки, и включить эти данные в список.

Список полных доменных имен, IP-адресов и доменных имен удаленных серверов составляется следующим образом:

  • Запрашивается свойство msExchSmtpFullyQualifiedDomainName объекта службы каталогов Active Directory® виртуального SMTP-сервера.

    Примечание.
    Затем в свойстве msExchTargetBridgeheadServersDN объекта каталога соединителя группы маршрутизации при направлении в этот объект запроса по конечным целевым серверам-плацдармам считывается свойство msExchSmtpFullyQualifiedDomainName
  • В свойстве msExchSmtpSmartHost объекта Active Directory SMTP-соединителя запрашивается конечный смарт-хост SMTP-соединителя.

  • В свойстве LinkName WMI-класса (Microsoft Windows® Management Instrumentation) ExchangeLink запрашиваются прямые подключения удаленного сервера.

Если анализатор сервера Exchange обнаруживает, что построенный список не содержит записей, выводится сообщение об ошибке.

Эта ошибка может быть вызвана следующими причинами:

  • Нерегулярно возникающие проблемы подключения к сети или к Active Directory, которые вызывают проблемы в потоке почты.

  • Учетная запись, от имени которой выполняется анализатор сервера Exchange, не обладает достаточными разрешениями на запрос таких данных.

Чтобы устранить эту ошибку

  1. Убедитесь, что компьютер сервера Exchange включен и подключен к сети.

  2. Проверьте наличия сетевого подключения к контроллеру домена Active Directory.

  3. Укажите контроллер домена Active Directory в анализаторе сервера Exchange.

  4. С помощью команды PING проверьте доступность компьютера сервера Exchange.

  5. При наличии межсетевого экрана проверьте, не блокированы ли порты удаленного вызова процедур.

  6. Проверьте разрешения учетной записи, с которой выполняется анализатор сервера Exchange. Учетная запись, с которой выполняется анализатор сервера Exchange, на каждом сканируемом компьютере сервера Exchange должна обладать разрешениями локального администратора.

Дополнительные сведения см. в статье 325487 базы знаний Майкрософт «How to troubleshoot network connectivity problems» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487) (Инструкции по устранению неполадок в сетевых подключениях).

Дополнительные сведения о неполадках в сетевых подключениях анализатора сервера Exchange см. в документе «Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems» (http://go.microsoft.com/fwlink/?LinkId=56285) (Рекомендации по устранению неполадок в сетевых подключениях средства Microsoft Exchange Server Best Practices Analyzer).

Дополнительные сведения о требованиях к портам см. в статье 832017 базы знаний Майкрософт «Service overview and network port requirements for the Windows Server system» http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017 (Обзор служб и требований к сетевым портам для операционной системы Windows Server).


Задан параметр TarpitTime
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-02-21

Чтобы определить, настроена ли функция замедления ответов для фильтрования получателей, анализатор приложения Microsoft® Exchange Server считывает следующий параметр реестра:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\TarpitTime

Если анализатор сервера Exchange обнаруживает, что значение параметра TarpitTime больше нуля (0), выводится сообщение о значении, отличном от заданного по умолчанию.

Замедление ответов — это принудительное торможение или откладывание нелегальных подключений с целью уменьшения интенсивности автоматической отправки нежелательной почты или проведения атаки для сбора сведений о словаре.

Функция замедления ответов, реализованная в Microsoft Windows Server™ 2003 с пакетом обновления 1 (SP1), может быть добавлена к фильтрации получателей, как описано в статье базы знаний Майкрософт 842851 «» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=842851). Функция замедления ответов улучшает эффективность фильтрации получателя, если на вкладке Фильтрация получателей в диалоговом окне Глобальные настройки установлен флажок Фильтровать получателей, не входящих в каталог.

Функция замедления ответов включается установкой значения параметра реестра TarpitTime. Для параметра реестра TarpitTime должно быть задано десятичное значение. Десятичное значение преобразуется в число секунд, в течение которого сеанс SMTP ожидает, прежде чем ответить отправителю, если получатель не существует в целевой организации сервера Exchange.

Функция замедления ответов существенно осложняет жизнь злоумышленникам, которые рассылают нежелательную почту при автоматизированной атаке для сбора сведений каталога. Атака для сбора сведений каталога — это попытка получить список известных действительных адресов электронной почты определенной организации.

SMTP-протокол подтверждает допустимых получателей во время сеанса SMTP, возвращая ответ «2.1.5 Recipient OK». Если же почта отправлена неизвестному получателю, SMTP-протокол возвращает ошибку «5.x.x». Поэтому отправитель нежелательной почты может написать программу автоматического создания адресов электронной почты по словарю или с использованием распространенных имен, добавляя к ним конкретный домен. Такая программа может собрать все адреса электронной почты с ответом «2.1.5 Recipient OK» и отбраковать все адреса с ошибкой «5.x.x». Затем этот злоумышленник продает действительные адреса электронной почты или использует их для рассылки собственной нежелательной почты.

Если установлен флажок Фильтровать получателей, не входящих в каталог, но значение параметра реестра TarpitTime не задано, то если получатель не существует в целевой службе каталогов Active Directory®, сервер Exchange сразу возвращает ошибку «5.x.x» во время сеанса SMTP отправителю.

Однако если значение параметра реестра TarpitTime задано и флажок Фильтровать получателей, не входящих в каталог установлен, сеанс SMTP ожидает возврата ошибки «5.x.x». Десятичное значение, заданное для параметра реестра TarpitTime, представляет число секунд, в течение которого сеанс SMTP будет ожидать возврата ошибки. Эта пауза сеанса SMTP значительно затрудняет автоматизацию атаки для сбора сведений каталога.

Как упоминалось ранее, если задан параметр TarpitTime, анализатор сервера Exchange отображает сообщение о значении, отличном от умолчания. Это сообщение носит исключительно информативный характер.

Важно!
Эта статья содержит сведения о редактировании реестра. Перед редактированием реестра убедитесь, что вы знаете, как восстановить реестр в случае возникновения неисправности. Сведения о восстановлении реестра см. в разделе справки «Восстановление реестра» файла Regedit.exe или Regedt32.exe.
Чтобы просмотреть или изменить значение реестра TarpitTime

  1. Нажмите кнопку Пуск, выберите команду Выполнить, в поле Открыть введите regedit и нажмите кнопку ОК.

  2. Найдите и щелкните следующий параметр реестра:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SMTPSVC\Parameters\TarpitTime

  3. Поле «Значение» содержит десятичное число. Это значение представляет требуемое число секунд задержки отклика при проверке SMTP-адреса для каждого адреса, не существующего в Active Directory.

  4. Если изменить значение раздела реестра TarpitTime или удалить его, нужно будет перезапустить службу SMTP (Simple Mail Transport Protocol).

Дополнительные сведения см. в статье базы знаний Майкрософт 842851 «Режим замедления ответов SMTP в Microsoft Windows Server 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=842851).


Тестовая почта создала отчет о недоставке
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Средство анализатора сервера Microsoft® Exchange посылает тестовое сообщение с сервера Exchange на учетную запись администратора почтовой системы или на определяемую пользователем учетную запись для SMTP-домена (Simple Mail Transfer Protocol), а затем сканирует на сервере журналы отслеживания сообщений, чтобы определить, были ли обнаружены проблемы, связанные с доставкой тестового сообщения.

В качестве части данного процесса сканирования анализатор сервера Exchange запрашивает свойство EntryType для WMI-класса (Microsoft Windows® Management Instrumentation) Exchange_MessageTrackingEntry в пространстве имен root\MicrosoftExchangeV2, чтобы определить причину появления записи в журнале отслеживания сообщений.

Если средство анализатора сервера Exchange обнаружит, что свойство EntryType имеет значение 1030, анализатор сервера Exchange выведет на экран предупреждение.

Это предупреждение указывает, что тестовое сообщение создало отчет о недоставке, и для сервера возможно наличие проблемы с конфигурацией SMTP (Simple Mail Transfer Protocol). Получение отчета о недоставке следует ожидать, если целевой получатель не существует, однако этот отчет является проблемой, если тестовое сообщение было послано существующему получателю.

Может возникнуть желание предпринять в качестве шага по устранению неполадки попытку послать другие сообщения тому же получателю и просмотреть отчеты о недоставке для определения причины возникшей проблемы.

Дополнительные сведения об устранении неполадок, связанных с отчетами о недоставке, см. в разделе, описывающем устранение неполадок, касающихся сообщений отчета о недоставке, в руководстве по транспорту и маршрутизации сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).


Тестовое сообщение отправлено в каталог недопустимой почты
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-05-17

Средство анализатора сервера Microsoft® Exchange посылает тестовое сообщения с сервера Exchange для учетной записи администратора или для учетной записи, определенной пользователем, в домен SMTP, а затем сканирует журналы трассировки сообщений на сервере, чтобы определить, были ли неполадки, связанные с доставкой тестового сообщения.

Частью этого сканирования является попытка анализатора опросить свойство EntryType для WMI-класса Exchange_MessageTrackingEntry в пространстве имен root\MicrosoftExchangeV2, чтобы определить, что послужило причиной появления записи в журнале трассировки сообщений.

Если анализатор обнаружит значение 1021 для свойства EntryType, отображается предупреждение.

Это предупреждение означает, что тестовое сообщение было послано в каталог недопустимой почты сервера Exchange и существует неполадка с конфигурацией SMTP этого сервера.

Сообщение попадает в каталог недопустимых сообщений по одной из следующих причин:

  • Сообщение не может быть доставлено.

  • Максимальное количество повторных попыток было превышено.

  • Сообщение невозможно возвратить отправителю как недоставленное.

Дополнительные сведения о тестировании потока исходящих сообщений см. в статье 297700 базы данных Майкрософт, посвященной инструкциям по тестированию потока исходящих сообщений с помощью файла в папке раскладки (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297700).

Дополнительные сведения об устранении неполадок, связанных с почтовым потоком и SMTP см. в статье, посвященной устранению неполадок с почтовым потоком и SMTP, в руководстве по транспорту и маршрутизации в Exchange Server(может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).


Тестовое сообщение находится в очереди SMTP
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-07-06

Средство анализатора сервера Microsoft® Exchange посылает тестовое сообщение с сервера Exchange на учетную запись администратора почтовой системы или на определяемую пользователем учетную запись для SMTP-домена (Simple Mail Transfer Protocol), а затем сканирует на сервере журналы отслеживания сообщений, чтобы определить, были ли обнаружены проблемы, связанные с доставкой тестового сообщения.

В качестве части процесса сканирования анализатор сервера Exchange запрашивает свойство EntryType WMI-класса (Microsoft Windows® Management Instrumentation) Exchange_MessageTrackingEntry в пространстве имен root\MicrosoftExchangeV2, чтобы определить причины появления записей в журнале отслеживания сообщений.

В приводимой ниже таблице перечисляются значения параметра EntryType, которые могут быть возвращены.

Имя значения | Значение
Получено сообщение через соединитель X.400 | 0
Получен отчет | 2
Послано сообщение | 4
Сообщение передано на выход | 7
Отчет передан на выход | 8
Сообщение доставлено | 9
Отчет доставлен | 10
Расширен список рассылки | 26
Сообщение переадресовано | 28
Сообщение перенаправлено | 29
Роль сервера понижена агентом передачи сообщения | 31
Отчет поглощен | 33
Отчет создан | 34
Немаршрутизируемый отчет удален | 43
Сообщение удалено администратором | 50
Тест удален администратором | 51
Отчет удален администратором | 52
Сообщение доставлено локально | 1000
Сообщение передано на вход по магистральной сети | 1001
Сообщение передано на выход по магистральной сети | 1002
Сообщение передано на выход через шлюз | 1003
Сообщение передано на вход через шлюз | 1004
Отчет передан на вход через шлюз | 1005
Отчет передан на выход через шлюз | 1006
Отчет создан | 1007
SMTP: сообщение помещено в очередь исходящих сообщений | 1010
SMTP: сообщение передано на выход | 1011
SMTP: входящее сообщение получено | 1012
SMTP: входящее сообщение передано | 1013
SMTP: сообщение перенаправлено | 1014
SMTP: отчет передан на вход | 1015
SMTP: отчет передан на выход | 1016
SMTP: отчет создан | 1017
SMTP: отчет поглощен | 1018
SMTP: сообщение отправлено в расширенную очередь | 1019
SMTP: запущена передача сообщения на выход | 1020
SMTP: сообщение отправлено в каталог «badmail» | 1021
SMTP: сбой расширенной очереди | 1022
SMTP: сообщение доставлено локально | 1023
SMTP: сообщение передано в классификатор | 1024
SMTP: запущена передача сообщения в расширенную очередь | 1025
SMTP: сбой доставки сообщения из расширенной очереди | 1026
Драйвер SMTP-хранилища: сообщение передано из хранилища | 1027
Драйвер SMTP-хранилища: сообщение доставлено локально в хранилище | 1028
Драйвер SMTP-хранилища: сообщение передано в агент передачи сообщений | 1029
SMTP: создан отчет о недоставке | 1030
SMTP: сообщение передано на выход | 1031

Анализатор сервера Exchange выводит на экран сообщение об ошибке, если возвращаемые значения EntryType указывают на выполнение следующих условий:

  • Журнал отслеживания тестового сообщения может быть успешно просканирован.

  • Тестовое сообщение не было успешно передано из очереди.

  • Для тестового сообщения не был создан отчет о недоставке.

  • Тестовое сообщение не было передано в каталог «Badmail».

  • Тестовое сообщение не поставлено в очередь для удаленной доставки.

  • Тестовое сообщение не было успешно доставлено в локальное хранилище.

  • Тестовое сообщение не запланировано для повторной классификации.

  • Тестовое сообщение не запланировано для повторной маршрутизации.

  • Тестовое сообщение не запланировано для повторной локальной доставки.

Эта ошибка означает, что тестовое сообщение находится в одной из SMTP-очередей и необходим дополнительный анализ для определения причины застревания сообщения в очереди.

Чтобы устранить эту ошибку, используйте служебную программу NSlookup для обзора возможных проблем разрешения имен в службе DNS (Domain Name System). Для устранения проблем подключений и функционирования протоколов, например, ошибок из-за недостижимости узла, используйте программу Telnet.exe, чтобы попытаться установить подключение к целевому компьютеру. Чтобы устранить ошибки протоколов, повысьте уровень диагностики службы MSExchangeTransport для компонента SMTP, а затем просмотрите журналы на наличие ошибок. Или можно воспользоваться сетевым монитором (Netmon.exe), чтобы получить сведения об ошибках подключений к сети. Для воспроизведения проблемы, возможно, потребуется принудительно активизировать действие в очереди для повторения попытки. Проанализируйте журнал событий на наличие возможных ошибок, связанных со службой банка данных Microsoft Exchange.

Дополнительные сведения об изменении настройки ведения журнала см. в разделе «How to Modify Logging Settings for MSExchangeTransport» (Изменение параметров ведения журнала для службы MSExchangeTransport) части «Troubleshooting Mail Flow and SMTP» (Устранение неполадок потока почты и SMTP) руководства Exchange Server Transport and Routing Guide (Руководство по транспорту и маршрутизации сервера Exchange) (http://go.microsoft.com/fwlink/?LinkId=47579).

Дополнительные сведения об устранении проблем, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел по устранению проблем потока почты и SMTP в руководстве по транспорту и маршрутизации сервера Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47579).

  • База знаний Майкрософт, статья 823489, описывающая использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • База знаний Майкрософт, статья 821877, содержащая описание полей на вкладках свойств очередей SMTP и X.400 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • База знаний Майкрософт, статья 264054, содержащая общие сведения о состояниях очередей в Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


В группе маршрутизации более 900 соединителей.
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-01-17

Средство анализа Microsoft® Exchange Server запрашивает службу каталогов Active Directory® для определения количества соединителей в определенной группе маршрутизации, включая соединители SMTP, соединители группы маршрутизации, соединители X.400 и EDK. При обнаружении средством анализа Exchange Server более 900 соединителей в одной группе маршрутизации появится предупреждение.

Рекомендуется использовать не более 900 объектов Exchange определенного типа. По умолчанию максимальный размер страницы, возвращаемой Active Directory при запросе, равен 1 000. Это означает, что при запросе LDAP для объекта, количество экземпляров которого в Active Directory превышает 1 000, результаты не будут возвращены из-за превышения максимального размера страницы.

Что касается Exchange Server, различные процессы запрашивают количество экземпляров определенных типов объектов. Например, Exchange System Manager выполняет запрос LDAP для создания службой Active Directory списка всех соединителей в группе маршрутизации. Если в какой-либо группе маршрутизации более 1 000 соединителей, Active Directory не вернет результаты запроса. В этом случае в Exchange System Manager появится ошибка.

Хотя максимальный размер страницы для Active Directory может быть увеличен, это не рекомендуется или не поддерживается Exchange Server. В средах Exchange с увеличенным значением максимального размера страницы возможны сбои и нечеткое поведение.

Хотя рекомендуется, чтобы количество объектов какого-либо типа в Exchange Server не превышало 900 экземпляров, поддерживается до 1 000 объектов.

Для устранения этого предупреждения

  1. Продумайте консолидацию соединителей или создание большего количества групп маршрутизации и балансировку нагрузки существующих соединителей среди них.

  2. Проверьте в Active Directory наличие соединителей без ссылок и удалите их.

  3. Продумайте консолидацию серверов Exchange в вашей организации.

Дополнительные сведения о структуре группы маршрутизации и соединителях см. в руководстве Руководство по отправке и доставке почты Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Дополнительные сведения о консолидации серверов Exchange см. в документе Server Consolidation Using Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47586) (Консолидация серверов с помощью Exchange Server 2003).


Существует разногласие между настройками полных доменных имен в Active Directory и в метабазе
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2007-01-17

Средство анализатора сервера Microsoft® Exchange считывает следующее свойство в метабазе IIS (Internet Information Services), чтобы определить, совпадает ли его значение с установленным значением атрибута msExchSmtpFullyQualifiedDomainName в службе каталогов Active Directory®:

/LM/SmtpSvc/<SMTP virtual server instance>/FullyQualifiedDomainName

Если анализатор сервера Exchange обнаружит, что значения двух атрибутов не совпадают, на экран выводится предупреждение.

Если значение в метабазе IIS не совпадает со значением в службе Active Directory, это может указывать на проблему с репликацией Active Directory или на проблему с присутствующим в Exchange компонентом репликации службы каталогов в метабазу (DS2MB).

Функция процесса DS2MB — передача сведений о конфигурации из службы Active Directory в локальную метабазу. По причинам, связанным с производительностью и масштабируемостью, эта конфигурация хранится в локальной метабазе, а не в реестре. В приложениях Exchange 2000 Server и Exchange Server 2003 все протоколы Интернета (SMTP, NNTP, POP3, IMAP4 и HTTP) запускаются как компоненты службы IIS.

Каждые 15 минут процесс DS2MB копирует из службы Active Directory целые поддеревья без изменения формы поддеревьев. Это однонаправленная запись из службы Active Directory в метабазу; запись из метабазы в службу Active Directory никогда не выполняется.

Свойством FullyQualifiedDomainName и атрибутом msExchSmtpFullyQualifiedDomainName используется имя сервера по умолчанию, которое соответствует полному доменному имени сервера Exchange (например, сервер.домен.com). Если значения свойства FullyQualifiedDomainName и атрибута msExchSmtpFullyQualifiedDomainName не имеют одинаковых полных имен доменов, это означает, что служба Active Directory и метабаза IIS не синхронизированы. Если причиной проблемы является сбой процесса DS2MB, можно устранить эту проблему, выполнив описываемую ниже процедуру для используемой версии сервера Exchange. Если проблема вызвана частичным или полным отказом репликации Active Directory, можно воспользоваться служебной программой наблюдения за репликацией Active Directory (ReplMon.exe), чтобы проверить работоспособность и состояние репликации Active Directory. Служебная программа ReplMon.exe находится в средствах поддержки Microsoft Windows® на компакт-диске Windows Server™ 2003.

Чтобы устранить причины появления этого предупреждения в Exchange Server 2003

  1. Проверьте журнал событий приложений на наличие записей с источником MSExchangeMU. Если происходит сбой DS2MB, в журнал заносится событие для Exchange Server 2003.

  2. Если никаких отказов DS2MB не наблюдается, используйте средство ReplMon для диагностики репликации Active Directory. Обратите особое внимание на серверы глобального каталога, используемые виртуальным SMTP-сервером.

  3. Если отказы DS2MB видны либо если устранены или разрешены какие-либо проблемы с репликацией Active Directory, перезапустите службу «Системный помощник Exchange».

Чтобы устранить причины появления этого предупреждения в Exchange 2000 Server

  1. Используйте средство ReplMon для диагностики репликации Active Directory. Обратите особое внимание на серверы глобального каталога, используемые виртуальным SMTP-сервером.

  2. После устранения или разрешения любых проблем с репликацией Active Directory перезапустите службу «Системный помощник Exchange».

Дополнительные сведения о функции обратного запроса DNS в Exchange см. в статье 297412 базы знаний Майкрософт «The 'Perform Reverse DNS Lookup for Incoming Messages' Option Is for Host Name Resolution» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в базе знаний Майкрософт в статье 266686, описывающей, как настроить виртуальный сервер SMTP (часть 1) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) и в статье 268163, описывающей как настроить виртуальный сервер SMTP (часть 2) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

Дополнительные сведения о репликации в Active Directory см. в статье 232072 базы знаний Майкрософт «Initiating Replication Between Active Directory Direct Replication Partners» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072).

Дополнительные сведения о процессе DS2MB см. в базе знаний Майкрософт в статье 240105 «XGEN: General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105).


Существует разногласие между настройками максимально допустимых количеств прыжков в Active Directory и в метабазе
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующее свойство в метабазе IIS (Internet Information Services), чтобы определить, совпадает ли его значение с установленным значением атрибута msExchSmtpMaxHopCount в службе каталогов Active Directory®:

/LM/SmtpSvc/<SMTP virtual server instance>/HopCount

Если анализатор сервера Exchange обнаружит, что значения не совпадают, на экран выводится предупреждение.

Если значение в метабазе IIS не совпадает со значением в службе Active Directory, это может указывать на проблему с репликацией Active Directory или на проблему с присутствующим в Exchange компонентом репликации службы каталогов в метабазу (DS2MB).

Функция процесса DS2MB — передача сведений о конфигурации из службы Active Directory в локальную метабазу. По причинам, связанным с производительностью и масштабируемостью, эта конфигурация хранится в локальной метабазе, а не в реестре. В приложениях Exchange 2000 Server и Exchange Server 2003 все протоколы Интернета (SMTP, NNTP, POP3, IMAP4 и HTTP) запускаются как компоненты службы IIS.

Каждые 15 минут процесс DS2MB копирует из службы Active Directory целые поддеревья без изменения формы поддеревьев. Это однонаправленная запись из службы Active Directory в метабазу; запись из метабазы в службу Active Directory никогда не выполняется.

На виртуальном SMTP-сервере допустимое количество прыжков по умолчанию равно 15. На виртуальном SMTP-сервере Exchange Server 2003 допустимое количество прыжков по умолчанию равно 30. Независимо от настроек, если значения свойства HopCount и атрибута msExchSmtpMaxHopCount не совпадают, это означает, что служба Active Directory и метабаза IIS не синхронизированы. Если причиной проблемы является сбой процесса DS2MB, можно устранить эту проблему, выполнив описываемую ниже процедуру для используемой версии сервера Exchange. Если проблема вызвана частичным или полным отказом репликации Active Directory, можно воспользоваться служебной программой наблюдения за репликацией Active Directory (ReplMon.exe), чтобы проверить работоспособность и состояние репликации Active Directory. Служебная программа ReplMon.exe находится в средствах поддержки Microsoft Windows® на компакт-диске Windows Server™ 2003.

Чтобы устранить эту ошибку в Exchange Server 2003

  1. Проверьте журнал событий приложений на наличие записей с источником MSExchangeMU. Если происходит сбой DS2MB, в журнал заносится событие для Exchange Server 2003.

  2. Если никаких отказов DS2MB не наблюдается, используйте средство ReplMon для диагностики репликации Active Directory. Обратите особое внимание на серверы глобального каталога, используемые виртуальным SMTP-сервером.

  3. Если отказы DS2MB видны либо если устранены или разрешены какие-либо проблемы с репликацией Active Directory, перезапустите службу Системный помощник Exchange.

Чтобы устранить эту ошибку в Exchange 2000 Server

  1. Используйте средство ReplMon для диагностики репликации Active Directory. Обратите особое внимание на серверы глобального каталога, используемые виртуальным SMTP-сервером.

  2. После устранения или разрешения каких-либо проблем с репликацией Active Directory перезапустите службу Системный помощник Exchange.

Дополнительные сведения о функции обратного запроса DNS в Exchange см. в базе знаний Майкрософт в статье 297412, описывающей использование параметра «Выполнить обратный запрос DNS для входящих сообщений» с целью разрешения имен узлов (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • 266686, описывающая инструкции из части 1 по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, описывающая инструкции из части 2 по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

Дополнительные сведения о репликации Active Directory см. в базе знаний Майкрософт в статье 232072, описывающей процедуру запуска репликации между партнерами по прямой репликации Active Directory (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072).

Дополнительные сведения о процессе DS2MB см. в базе знаний Майкрософт в статье 240105, описывающей общие сведения о синхронизации службы каталогов и метабазы в Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105).


Существует разногласие между настройками максимального размера сообщений в Active Directory и в метабазе
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает следующее свойство в метабазе IIS (Internet Information Services), чтобы определить, совпадает ли его значение с установленным значением атрибута msExchSmtpMaxMessageSize в службе каталогов Active Directory®:

/LM/SmtpSvc/<экземпляр виртуального сервера SMTP>/MaxMessageSize

Если анализатор сервера Exchange обнаружит, что значения не совпадают, на экран выводится предупреждение.

Если значение в метабазе IIS не совпадает со значением в службе Active Directory, это может указывать на проблему с репликацией Active Directory или на проблему с присутствующим в Exchange компонентом репликации службы каталогов в метабазу (DS2MB).

Функция процесса DS2MB — передача сведений о конфигурации из службы Active Directory в локальную метабазу. По причинам, связанным с производительностью и масштабируемостью, эта конфигурация хранится в локальной метабазе, а не в реестре. В приложениях Exchange 2000 Server и Exchange Server 2003 все протоколы Интернета (SMTP, NNTP, POP3, IMAP4 и HTTP) запускаются как компоненты службы IIS.

Каждые 15 минут процесс DS2MB копирует из службы Active Directory целые поддеревья без изменения формы поддеревьев. Это однонаправленная запись из службы Active Directory в метабазу; запись из метабазы в службу Active Directory никогда не выполняется.

И свойство MaxMessageSize, и атрибут msExchSmtpMaxMessageSize используют настройку по умолчанию, равную 0, которая означает, что не существует заданных пределов на размер сообщений. Если значения свойства MaxMessageSize и атрибута msExchSmtpMaxMessageSize не совпадают, это означает, что служба Active Directory и метабаза IIS не синхронизированы. Если причиной проблемы является сбой процесса DS2MB, можно устранить эту проблему, выполнив описываемую ниже процедуру для используемой версии сервера Exchange. Если проблема вызвана частичным или полным отказом репликации Active Directory, можно воспользоваться служебной программой наблюдения за репликацией Active Directory (ReplMon.exe), чтобы проверить работоспособность и состояние репликации Active Directory. Служебная программа ReplMon.exe находится в средствах поддержки Microsoft Windows® на компакт-диске Windows Server™ 2003.

Чтобы устранить эту ошибку в Exchange Server 2003

  1. Проверьте журнал событий приложений на наличие записей с источником MSExchangeMU. Если происходит сбой DS2MB, в журнал заносится событие для Exchange Server 2003.

  2. Если никаких отказов DS2MB не наблюдается, используйте средство ReplMon для диагностики репликации Active Directory. Обратите особое внимание на серверы глобального каталога, используемые виртуальным SMTP-сервером.

  3. Если отказы DS2MB видны либо если устранены или разрешены какие-либо проблемы с репликацией Active Directory, перезапустите службу Системный помощник Exchange.

Чтобы устранить эту ошибку в Exchange 2000 Server

  1. Используйте средство ReplMon для диагностики репликации Active Directory. Обратите особое внимание на серверы глобального каталога, используемые виртуальным SMTP-сервером.

  2. После устранения или разрешения любых проблем с репликацией Active Directory перезапустите службу Системный помощник Exchange.

Дополнительные сведения о функции обратного запроса DNS в Exchange см. в базе знаний Майкрософт в статье 297412, описывающей использование параметра «Выполнить обратный запрос DNS для входящих сообщений» с целью разрешения имен узлов (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • 266686, описывающая инструкции из части 1 по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, описывающая инструкции из части 2 по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

Дополнительные сведения о репликации Active Directory см. в базе знаний Майкрософт в статье 232072, описывающей процедуру запуска репликации между партнерами по прямой репликации Active Directory (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072).

Дополнительные сведения о процессе DS2MB см. в базе знаний Майкрософт в статье 240105, описывающей общие сведения о синхронизации службы каталогов и метабазы в Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105).


Существует разногласие между настройками максимального размера сеанса в Active Directory и в метабазе
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange считывает свойство /LM/SmtpSvc/<SMTP virtual server instance>/MaxSessionSize в метабазе IIS (Internet Information Services), чтобы определить, совпадает ли его значение с установленным значением атрибута msExchSmtpMaxSessionSize в службе каталогов Active Directory®.

Если анализатор сервера Exchange обнаружит, что значения не совпадают, на экран выводится предупреждение.

Если значение в метабазе IIS не совпадает со значением в службе Active Directory, это может указывать на проблему с репликацией Active Directory или на проблему с присутствующим в Exchange компонентом репликации службы каталогов в метабазу (DS2MB).

Функция процесса DS2MB — передача сведений о конфигурации из службы Active Directory в локальную метабазу. По причинам, связанным с производительностью и масштабируемостью, эта конфигурация хранится в локальной метабазе, а не в реестре. В приложениях Exchange 2000 Server и Exchange Server 2003 все протоколы Интернета (SMTP, NNTP, POP3, IMAP4 и HTTP) запускаются как компоненты службы IIS.

Каждые 15 минут процесс DS2MB копирует из службы Active Directory целые поддеревья без изменения формы поддеревьев. Это однонаправленная запись из службы Active Directory в метабазу; запись из метабазы в службу Active Directory никогда не выполняется.

И свойство MaxSessionSize, и атрибут msExchSmtpMaxSessionSize используют настройку по умолчанию, равную 0, которая означает, что не существует заданных пределов на размер сеанса. Если значения свойства MaxSessionSize и атрибута msExchSmtpMaxSessionSize не совпадают, это означает, что служба Active Directory и метабаза IIS не синхронизированы. Если причиной проблемы является сбой процесса DS2MB, можно устранить эту проблему, выполнив описываемую ниже процедуру для используемой версии сервера Exchange. Если проблема вызвана частичным или полным отказом репликации Active Directory, можно воспользоваться служебной программой наблюдения за репликацией Active Directory (ReplMon.exe), чтобы проверить работоспособность и состояние репликации Active Directory. Служебная программа ReplMon.exe находится в средствах поддержки Microsoft Windows® на компакт-диске Windows Server™ 2003.

Чтобы устранить эту ошибку в Exchange Server 2003

  1. Проверьте журнал событий приложений на наличие записей с источником MSExchangeMU. Если происходит сбой DS2MB, в журнал заносится событие для Exchange Server 2003.

  2. Если никаких отказов DS2MB не наблюдается, используйте средство ReplMon для диагностики репликации Active Directory. Обратите особое внимание на серверы глобального каталога, используемые виртуальным SMTP-сервером.

  3. Если отказы DS2MB видны либо если устранены или разрешены какие-либо проблемы с репликацией Active Directory, перезапустите службу «Системный помощник Exchange».

Чтобы устранить эту ошибку в Exchange 2000 Server

  1. Используйте средство ReplMon для диагностики репликации Active Directory. Обратите особое внимание на серверы глобального каталога, используемые виртуальным SMTP-сервером.

  2. После устранения или разрешения любых проблем с репликацией Active Directory перезапустите службу «Системный помощник Exchange».

Дополнительные сведения о функции обратного запроса DNS в Exchange см. в базе знаний Майкрософт в статье 297412, описывающей использование параметра «Выполнить обратный запрос DNS для входящих сообщений» с целью разрешения имен узлов (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Дополнительные сведения о параметрах виртуального SMTP-сервера см. в следующих статьях базы знаний Майкрософт:

  • Статья 266686, описывающая первую часть инструкций по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • Статья 268163, описывающая вторую часть инструкций по настройке виртуального SMTP-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

Дополнительные сведения о репликации Active Directory см. в базе знаний Майкрософт в статье 232072, описывающей процедуру запуска репликации между партнерами по прямой репликации Active Directory (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072).

Дополнительные сведения о процессе DS2MB см. в базе знаний Майкрософт в статье 240105, описывающей общие сведения о синхронизации службы каталогов и метабазы в Exchange 2000 Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105).


За последние 24 часа в журнал было занесено событие предупреждения диспетчера транспортного подключения
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-07-07

Анализатор сервера Microsoft® Exchange запрашивает WMI-класс (Microsoft Windows® Management Instrumentation) Win32_NTLogEvent, чтобы определить, было ли занесено в журнал MSExchangeTransport событие предупреждения 4006 за прошедшие 24 часа.

Если анализатор сервера Exchange обнаруживает, что в течение последних 24 часов в журнал было занесено событие предупреждения 4006 для MSExchangeTransport, выводится предупреждение.

Это предупреждение обычно означает, что попытка отправить почту на удаленный сервер завершилась неудачей.

Событие предупреждения MSExchangeTransport 4006 может возникнуть по одной из следующих причин:

  • Подключение было разорвано удаленным хостом.

  • Удаленная SMTP-служба отклонила AUTH-согласование.

  • Сервер, который пытается доставить сообщение, не может получить доступ к данным о доставке сообщения.

  • Произошла SMTP-ошибка.

  • Сервер, пытающийся доставить сообщение, не может установить подключение к удаленному серверу.

  • Промежуточный узел, указанный в свойствах виртуального SMTP-сервера, недоступен по одной из причин.

Для получения дополнительных сведений о событии предупреждения MSExchangeTransport 4006 просмотрите подробные сведения о конкретном событии в центре сообщений о событиях и ошибках (http://go.microsoft.com/fwlink/?LinkId=34258).

Дополнительные сведения о проблемах ретрансляции в сервере Exchange см. в статье 895853 базы знаний Майкрософт, «How to troubleshoot mail relay issues in Exchange Server 2003 and in Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853) (Инструкции по устранению неполадок при ретрансляции почты в Exchange Server 2003 и Exchange 2000 Server).

Дополнительные сведения о проблемах, связанных с потоком почты и SMTP, см. в разделе «Troubleshooting Mail Flow and SMTP» (Устранение неполадок, связанных с потоком почты и SMTP) в материале Exchange Server and Transport Routing Guide (http://go.microsoft.com/fwlink/?LinkID=67875) (Руководство по серверу Exchange и маршрутизации транспорта).


Предупреждение диспетчера транспортного соединения было зарегистрировано в течение последних 24 часов
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-07-07

Средство анализа Microsoft® Exchange Server запрашивает класс инструментария Win32_NTLogEvent Microsoft Windows® Management Instrumentation (WMI) для определения того, было ли в течение последних 24 часов зарегистрировано предупреждение события 4001 для MSExchangeTransport.

Если средство анализа Exchange Server обнаружит, что предупреждение события 4001 было зарегистрировано для MSExchangeTransport в течение последних 24 часов, появится предупреждение.

Такое предупреждение обычно означает ошибку отправки почты удаленному серверу.

Предупреждение события 4001 MSExchangeTransport может произойти при наличии у службы SMTP в Exchange 2000 Server или Exchange Server 2003 одной или нескольких проблем с доставкой почты. Причинами проблем с доставкой почты могут быть DNS, конфигурация IP или установка неверных файлов DLL.

Для получения дополнительных сведений о предупреждении 4001 можно найти детали события в центре сообщений об ошибках и событиях (http://go.microsoft.com/fwlink/?LinkId=34258).

Дополнительные сведения о проблемах с ретрансляцией почты в Exchange Server см. в статье 895853 базы знаний корпорации Майкрософт «Устранение неполадок ретрансляции почты в Exchange Server 2003 и Exchange 2000 Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853).

Дополнительные сведения о неполадках с потоком почты и SMTP см. в разделе «Устранение неполадок потока почты и SMTP» руководства Руководство по отправке и доставке почты Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875).


Не найден файл приемника события передачи
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-01-10

Средство анализатора сервера Microsoft® Exchange опрашивает метабазу IIS (Microsoft Internet Information Server) для получения списка привязок приемника события передачи SMTP. Анализатор сервера Exchange пытается найти несколько стандартных привязок события на основе списка, предварительно заданного в анализаторе сервера Exchange. Для каждой привязки анализатор сервера Exchange проверяет данные регистрации COM (Component Object Model) а следующем разделе реестра:

HKEY_CLASSES_ROOT\CLSID\

Данные регистрации COM содержат полный путь связанного DLL-файла. Анализатор сервера Exchange использует инструментарий WMI (Microsoft Windows® Management Instrumentation) для поиска DLL-файла и отображения номера его версии. Если анализатору сервера Exchange не удается найти DLL-файл, то выводится предупреждение с указанием имени и пути отсутствующего файла.

Если анализатор сервера Exchange обнаруживает, что отсутствует одно или несколько стандартных привязок события, то выдается предупреждение.

Событие транспорта SMTP происходит, когда данные сообщения передаются в службу или из службы SMTP. Все сообщения имеют связанные события. Это относится, в числе прочего, к входящим и исходящим сообщениям X.400 и RPC. Типичным примером события входящего транспорта является получение сообщения службой SMTP по сети или в папку раскладки SMTP. Когда происходит это событие передачи, источник события оповещает приемники события передачи, каждый из которых может предпринять какое-то действие в зависимости от содержимого сообщения. Система не предпринимает никаких других действий в отношении данных сообщения после передачи этих данных приемнику до тех пор, пока приемник не завершит действие и не возвратит сообщение. На время выполнения этого действия приемник наделяется эксклюзивными правами управления содержимым сообщения и его состоянием.

Потеря DLL-файлов для COM-регистраций приемника события передачи может вызвать проблемы в почтовом потоке. Если Exchange Server проявляет симптомы, указывающие на проблемы в почтовом потоке, например наличие очереди сообщений, проверьте наличие идентифицированных DLL-файлов и при необходимости переустановите их.

Чтобы устранить эту проблему

  1. Воспользуйтесь проводником, чтобы вручную выбрать обнаруженный DLL-файл. Обычно этот файл находится в папке \Program Files\Exchsrvr\Bin.

  2. Можно пренебречь предупреждением анализатора сервера Exchange при соблюдении следующих условий:

    • DLL-файл присутствует в указанной папке.

    • Отсутствуют признаки наличия проблем почтового потока на сервере.

  3. Скопируйте отсутствующий DLL-файл с исходного установочного носителя Exchange Server при соблюдении следующих условий:

    • DLL-файл отсутствует в папке, указанной анализатором сервера Exchange.

    • Есть признаки наличия проблем почтового потока на сервере.

    Вместо выполнения указанных действий можно применить новейший пакет обновления для Exchange.

  4. Повторно запустите анализатор сервера Exchange и убедитесь, что предупреждение больше не отображается.


Изменения пользовательской версии в сведениях о состоянии ссылок подавляются
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2005-11-18

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить, был ли атрибут heuristics настроен на запрет изменений пользовательской версии в сведениях о состоянии ссылок. По умолчанию атрибут heuristics не настроен. Если анализатор сервера Exchange обнаружит, что атрибут heuristics установлен равным 2048, на экран будет выведено сообщение о том, что конфигурация отличается от конфигурации по умолчанию.

Чтобы гарантировать эффективность и надежность маршрутизации сообщений, используются таблицы состояний ссылок. Таблица состояний ссылок содержит сведения о версии для каждой группы маршрутизации в форме номеров основной, второстепенной и пользовательской версий. Изменения основных версий имеют наивысший приоритет, за ними следуют изменения второстепенных версий и в конце находятся изменения номеров пользовательских версий.

Изменения пользовательских версий возникают, когда происходит обновление службы каталогов на базовом уровне. Когда службы запускаются или останавливаются на сервере Exchange, когда в группу маршрутизации добавляется еще один сервер или когда рядовой сервер теряет связь, эти минимальные изменения включают изменения хозяина группы маршрутизации.

Обновление службы каталогов на базовом уровне может происходить, когда администратор сервера Exchange изменяет что-нибудь на уровне группы маршрутизации. Например, изменение версии пользователя возникает, когда администратор изменяет имя группы маршрутизации, добавляет сервер или удаляет сервер. Однако основной причиной изменений пользовательских версий являются данные WMI (Microsoft Windows® Management Instrumentation), которые находятся на каждом сервере. Эти данные сообщают, какие службы выполняются. Если остановить и запустить службу, изменения пользовательских версий в таблице состояний ссылок реплицируются на все компьютеры серверов Exchange в организации.

Частые обновления пользовательских версий могут создать нежелательный объем сетевого трафика и их можно запретить, получив сначала оперативное исправление из службы поддержки продуктов Майкрософт и затем установив атрибут heuristics равным 2048 (0x800 в шестнадцатеричной системе счисления).

Рекомендуется не запрещать обновления пользовательских версий, если они не создают избыточный сетевой трафик.

Чтобы восстановить конфигурацию по умолчанию

  1. Откройте оснастку Edit интерфейса службы Active Directory (ADSI)

  2. В оснастке Edit интерфейса ADSI разверните узел Контейнер конфигурации, разверните узел CN=Конфигурация, DC=имя_домена, DC=com, разверните CN=Службы, а затем разверните CN=Microsoft Exchange.

  3. Щелкните правой кнопкой мыши CN=имя_организации и в контекстном меню выберите пункт Свойства.

  4. В поле «Выберите свойство для просмотра» щелкните Эвристика.

  5. В поле Изменение атрибута очистите значение 0x800.

  6. Щелкните Установить, а затем нажмите кнопку OK.

  7. Закройте оснастку Edit интерфейса ADSI.
Внимание!
Могут возникнуть серьезные неполадки, если некорректно изменить атрибуты объектов Active Directory при использовании средства ADSI Edit, средства LDP (ldp.exe) или другого клиента LDAP (Lightweight Directory Access Protocol) версии 3. Для устранения этих неполадок может потребоваться переустановка Microsoft Windows Server™ 2003, Exchange Server 2003 или обоих приложений. Ответственность за изменение атрибутов объектов Active Directory полностью лежит на лице, производящем изменения.

Дополнительные сведения о состоянии ссылки и номерах пользовательских версий см. в описании распространения состояний ссылок, содержащемся в техническом справочнике по Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=49367).


Пользователь, указанный в качестве общего получателя
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-09-06

Средство анализа Microsoft® Exchange Server запрашивает класс WMI (Microsoft Windows® Management Instrumentation) Exchange_Queue, чтобы определить значение следующих атрибутов очереди SMTP на виртуальном сервере SMTP.

LinkId | Указывает на код ссылки, содержащей очередь.
QueueId | Указывает на код очереди.
QueueName | Указывает на имя очереди.
VirtualMachine | Указывает на имя виртуальной машины, содержащей очередь.
VirtualServerName | Указывает на имя виртуального сервера, на котором находится очередь.
MessageCount | Указывает на количество сообщений в очереди.

Средство анализа Exchange Server использует вышеуказанные данные для запроса у класса WMI Exchange_QueuedSMTPMessage значений следующих атрибутов сообщений из очереди:

Recipients | Указывает на получателей сообщения.
Received | Указывает на полученную метку времени сообщения.
MessageId | Указывает на код сообщения, находящегося в очереди.
StateRetry | Указывает, что происходит повторная передача сообщения, которое не было удачно доставлено.

Кроме того, с помощью данных, полученных по предыдущему запросу, средство анализа Exchange Server запрашивает у службы Active Directory® следующие значения каждого объекта Recipient, чтобы определить, является ли получатель отдельным пользователем, группой рассылки, общедоступной папкой или хранилищем общих папок:

distinguishedName | Указывает на отличительное имя объекта.
msExchHomeServerName | Указывает на сервер, к которому подключен получатель.
homeMDB | Указывает на хранилище почтовых ящиков получателя.

Если анализатор сервера Exchange Server определяет, что как минимум 25 процентов сообщений, скопившихся в очереди, содержат адрес определенного пользователя в поле «Кому», или «Копия» на экран выводится предупреждение.

Если анализатор сервера Exchange Server определяет, что как минимум 50 процентов сообщений, скопившихся в очереди, содержат адрес определенного пользователя в поле «Кому», или «Копия» на экран выводится сообщение об ошибке.

Такое предупреждение или сообщение об ошибке означает, что указанный пользователь является общим получателем сообщений, скопившихся в очереди SMTP.

Для решения данной проблемы следует проверить учетную запись пользователя на неполадки конфигурации и другие проблемы, которые могли вызвать скопление сообщений в очереди на отправку данному пользователю.

Процедура проверки включает в себя следующие действия:

  • Убедитесь, что атрибуты объекта пользователя правильно установлены и содержат правильные значения в службе каталогов Active Directory.

  • Убедитесь в правильности параметров разрешений объекта пользователя в службе Active Directory.

  • Проверьте наличие нежелательной почты (спама) или вирусных атак, направленных против компьютера пользователя.

  • Определите, не принадлежит ли пользователь к группе рассылки, для которой неправильно заданы ограничения доставки.

  • Если объект принадлежит специальному пользователю, который является назначенным получателем журнала, проверьте правильность конфигурации службы или компонентов, к которым относится пользователь.

Дополнительные сведения об устранении проблем, связанных с очередями SMTP, см. в следующих ресурсах Exchange:

  • Раздел по устранению проблем, связанных с потоком почты и протоколом SMTP в руководстве по транспортировке и маршрутизации сервера Exchange Server по адресу http://go.microsoft.com/fwlink/?LinkID=67875 (на английском языке).

  • Статья 823489 базы знаний Майкрософт «Использование средства просмотра очереди для устранения проблем потока почты в Exchange Server 2003» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

Дополнительные сведения о влиянии ограничения групп рассылок на поток почты сервера Exchange см. в следующих статьях базы знаний Майкрософт:

  • Статья 895407 «В Exchange Server 2003 доставка сообщений в локальные и внешние почтовые ящики неожиданно замедляется после настройки ограничений по доставке на основе групп рассылок» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 329171 «XADM: доставка почты задерживается, если получатели настроены с ограничениями по доставке на основе членства в группе» по адресу: http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 839949 «Устранение неполадок почтового транспорта и групп рассылок в Exchange 2000 Server и Exchange Server 2003» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

  • Статья 812298 «Доставка почты замедляется после настройки ограничений доставки на основе списка рассылки» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298 (эта ссылка может указывать на содержимое полностью или частично на английском языке).


Неизвестная проблема SMTP
Анализатор сервера Microsoft Exchange — статьи > Транспорт >

Дата последнего изменения раздела: 2006-10-06

Средство анализа Microsoft® Exchange Server запрашивает WMI-класс Win32_Service, чтобы определить значение ключа Started для службы SMTP. Значение False указывает на то, что служба SMTP не запущена. Значение True указывает на то, что служба SMTP запущена.

Средство анализа Exchange Server запрашивает метабазу служб Microsoft IIS для получения значения свойства ServerState для экземпляра виртуального сервера протокола SMTP.

Свойство ServerState представляет текущее состояние экземпляра сервера. Ниже приведены коды состояний и соответствующие им состояния:

Код состояния | Состояние
1 | Запускается
2 | Запущен
3 | Останавливается
4 | Остановлен
5 | Приостанавливается
6 | Приостановлен
7 | Возобновляется

Средство анализа сервера Exchange выводит на экран предупреждение, если выполняются следующие условия:

  • Запущена служба SMTP.

  • Все экземпляры виртуального SMTP-сервера запущены.

Это предупреждение означает, что, несмотря на то, что видимые неполадки в работе службы SMTP и виртуального SMTP-сервера отсутствуют, существует проблема, препятствующая корректным ответам портов SMTP, которая требует дополнительного изучения.

Кроме того, возможны следующие причины появления этой проблемы:

  • Служба SMTP перестала отвечать на запросы.

  • Связь с SMTP-портами блокируется брандмауэром или антивирусным ПО.

Устранение этой проблемы

  • Перезапустите службу SMTP.

  • Проверьте конфигурацию любых брандмауэров и антивирусов, имеющую отношение к SMTP-портам.

  • Просмотрите руководство по действиям в случае ошибок и ссылки, указанные анализатором сервера Exchange Server.

Запуск, остановка и приостановка работы службы SMTP

  1. Выберите пункты Start и Administrative Tools, а затем выберите элемент Component Services.

  2. В дереве консоли щелкните узел Services (Local).

  3. В панели результатов щелкните правой кнопкой мыши элемент Simple Mail Transfer Protocol (SMTP), а затем нажмите кнопку Start, Stop или Pause.


Готовность сервера Exchange Server 2007
Анализатор сервера Microsoft Exchange — статьи >

Дата последнего изменения раздела: 2006-07-18

Статьи данного раздела содержат сведения о том, какие показатели, связанные с готовностью сервера, оценивает средство анализа Microsoft® Exchange Server. Кроме того, в данных статьях описаны действия, которые можно предпринять для устранения ошибок, связанных с предварительными условиями, и какие настройки, отличные от настроек по умолчанию, средство анализа Exchange Server может обнаружить.


Наследование списков управления доступом (ACL) заблокировано
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-06-19

Не удается продолжить установку Microsoft Exchange Server 2007, так как не удалось распространить необходимые разрешения.

Программе установки Exchange требуется, чтобы для объектов дерева общих папок было включено наследование разрешений.

Чтобы устранить данную проблему, убедитесь, что параметр «Allow permissions to propagate to follow to this object and child objects» (Разрешить распространение разрешений для этого объекта и его дочерних объектов) включен, а затем повторно запустите программу установки Exchange Server 2007.

Повторное включение наследования разрешений для дерева общих папок

  1. Откройте диспетчер Exchange Server 2003.

  2. Щелкните правой кнопкой мыши хранилище общих папок и выберите пункт Properties (Свойства).

  3. Откройте вкладку «Security» (Безопасность) и установите флажок Allow inheritable permissions to propagate to this object (Разрешить распространение наследуемых разрешений для этого объекта).


Расширение схемы Active Directory требует установки Ldifde.exe
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-06-19

Не удается продолжить установку Microsoft Exchange Server 2007, так как локальному компьютеру не удается обновить схему Active Directory.

Для установки Microsoft Exchange требуется, чтобы на локальном компьютере было установлено средство Ldifde.exe для внесения необходимых расширений в схему Active Directory.

Чтобы устранить данную проблему, установите на локальном компьютере средство Ldifde.exe и повторно запустите программу установки Exchange Server 2007 либо запустите программу установки Exchange Server 2007 с контроллера домена.

Примечание.
После расширения схемы Active Directory роли сервера Exchange Server 2007 можно будет устанавливать на локальный компьютер без установки средства ldifde.exe.
Установка средства Ldifde.exe на локальный компьютер

  1. Нажмите последовательно кнопки «Пуск», «Выполнить» и введите в поле Открыть команду ServerManagerCmd -i RSAT-ADDS.


Путь установки ADAM существует
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-26

Не удается продолжить установку Microsoft Exchange Server 2007 из-за сбоя установки режима ADAM.

В папке по умолчанию находится ранее установленная версия ADAM. Программа установки Exchange не может выполнить новую установку ADAM в существующую структуру каталогов ADAM.

Чтобы устранить данную проблему, удалите существующую папку ADAM, а затем повторно запустите программу установки Microsoft Exchange.


На локальном компьютере не установлен режим ADAM
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-22

Не удается продолжить установку Microsoft Exchange Server 2007, поскольку на компьютере не установлен режим ADAM.

ADAM — это служба каталогов LDAP, специально разработанная для работы с приложениями, поддерживающими службу каталогов. ADAM хранит и реплицирует только сведения, связанные с определенным приложением, не требует развертывания на контроллере домена и не зависит от службы каталогов Active Directory. ADAM не обеспечивает проверку подлинности или авторизацию сетевых операционных систем.

В Exchange Server 2007 роль транспортного сервера Exchange использует ADAM для хранения сведений о конфигурации. Если ADAM синхронизирован с Active Directory, его также можно использовать для поиска получателей в целях обеспечения безопасности сообщений.

Для установки Microsoft Exchange требуется, чтобы на локальном компьютере была установлена служба ADAM.

Чтобы устранить данную проблему, установите ADAM с пакетом обновления 1 (SP1), следуя рекомендациям, приведенным в статье «Режим ADAM» (http://go.microsoft.com/fwlink/?linkid=71063) (на английском языке), и запустите программу установки повторно.


На локальном компьютере не установлен ADAM (Longhorn)
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-08-13

Не удается продолжить установку Microsoft Exchange Server 2007, так как на компьютере с операционной системой Windows Server 2008 не установлен режим ADAM.

ADAM — это служба каталогов LDAP, специально разработанная для работы с приложениями, поддерживающими службу каталогов. ADAM хранит и реплицирует только сведения, связанные с определенным приложением, не требует развертывания на контроллере домена и не зависит от службы каталогов Active Directory. ADAM не обеспечивает проверку подлинности или авторизацию сетевых операционных систем.

В Exchange Server 2007 роль транспортного сервера Exchange использует ADAM для хранения сведений о конфигурации. Если ADAM синхронизирован с Active Directory, его также можно использовать для поиска получателей в целях обеспечения безопасности сообщений.

Для установки Microsoft Exchange требуется, чтобы на локальном компьютере была установлена служба ADAM.

Чтобы устранить эту проблему, установите на локальном компьютере с операционной системой Windows Server 2008 режим ADAM, а затем повторно запустите программу установки.

Установка режима ADAM в операционной системе Windows Server 2008

  1. Нажмите кнопку «Пуск», выберите пункт Выполнить и введите следующую команду:

  2. cmd.exe /c start /w pkgmgr.exe /iu:"DirectoryServices-ADAM"

  3. Повторно запустите программу установки Exchange Server 2007.


Предупреждение анализатора Exchange при поиске данных
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-08-09

В данном разделе приведены сведения об устранении проблем, обнаруженных с помощью анализатора Exchange. Используйте эти сведения для решения конкретных проблем только на тех системах, для которых был запущен анализатор Exchange.

Анализатор Exchange, который можно бесплатно загрузить из Интернета, удаленно собирает конфигурационные данные с каждого сервера в топологии и автоматически анализирует их. В итоговый отчет записываются важные сведения о неправильных настройках, потенциальных проблемах и параметрах, для которых были изменены значения по умолчанию. Следуя рекомендациям анализатора Exchange, можно улучшить производительность, масштабируемость и надежность сервера Exchange Server и сократить время вынужденных простоев.

Дополнительные сведения об анализаторе Exchange и о том, как загрузить его новейшие версии, см. в документе «Анализаторы Microsoft Exchange» по адресу http://go.microsoft.com/fwlink/?linkid=34707 (на английском языке).


Предупреждение о совместимости с 32-разрядной архитектурой
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-08-13

Программа установки Microsoft Exchange Server 2007 выводит данное предупреждение, так как устанавливается 32-разрядная версия Microsoft Exchange.

Существует две версии Exchange Server 2007 для двух платформ: 64-разрядная версия предназначена для производственных сред, 32-разрядная версия — для непроизводственных сред (для лабораторий, учебных заведений, демонстраций и оценки). Приобрести можно только 64-разрядную версию, поскольку 32-разрядные серверы Exchange Server 2007 нельзя использовать в производстве.

Существует два исключения из правила, касающегося применения 32-разрядной платформы, поскольку корпорация Майкрософт разрешает минимальное использование 32-разрядной версии в производственных средах. Эти исключения описаны ниже.

  • 32-разрядную версию средств управления Exchange можно использовать в производстве для администрирования серверов Exchange Server 2007 в операционной системе Windows Server 2003 или Windows XP. В настоящее время ни 32-разрядную, ни 64-версию сервера Exchange Server 2007 нельзя использовать в операционных системах Windows Vista и Windows Server 2008. Поддержку операционных систем Windows Vista и Windows Server 2008 планируется реализовать в пакете обновления 1 (SP1) для Exchange Server 2007.

  • 32-разрядную версию программы установки можно использовать в производстве для расширения схемы службы каталогов Active Directory. Подробные инструкции по подготовке Active Directory к установке Exchange Server 2007 см. в статье «Подготовка Active Directory и доменов».

Все прочие варианты использования 32-разрядной версии Exchange Server 2007 в производственных средах не поддерживаются.

Сведения о загрузке 32-разрядной версии средств управления Exchange см. в статье «Средства управления Microsoft Exchange Server 2007 (32-разрядная версия)» (http://go.microsoft.com/fwlink/?LinkId=82335) (на английском языке). Дополнительные сведения о версиях Exchange Server 2007 для различных платформ см. в разделе «Exchange Server 2007: платформы, выпуски и версии» (http://go.microsoft.com/fwlink/?LinkId=88051) документации на сервер Exchange Server 2007 (на английском языке).


Необходимо установить обновление часовых поясов за 2007 год для операционных систем Microsoft Windows
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-02-20

Установка сервера Microsoft Exchange Server 2007 не может быть продолжена, так как на компьютере не установлено обновление, исправляющее параметры часовых поясов.

Для установки сервера Exchange 2007 необходимо установить обновление часовых поясов, указанное в статье 931836 базы знаний Майкрософт.

Чтобы решить эту проблему, установите обновление, указанное в статье 931836 базы знаний Майкрософт «Накопительное обновление за февраль 2007 года для систем Microsoft Windows, исправляющее параметры часовых поясов» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=931836, на английском языке) и запустите программу установки сервера Exchange 2007 повторно.


Службы каталогов Active Directory не существует или с ней невозможно связаться
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-04-18

Не удается продолжить установку Microsoft Exchange Server 2007, так как программе установки не удалось связаться с допустимым сайтом службы каталогов Active Directory.

Для установки Microsoft Exchange требуется, чтобы сервер, на котором производится установка, мог обнаружить контекст именования конфигурации в службе каталогов Active Directory.

Чтобы решить этот вопрос, убедитесь, что учетная запись пользователя, используемая для установки Microsoft Exchange, была подключена к службе каталогов Active Directory, затем повторите установку. Если это не позволит устранить проблему, для ее дальнейшей диагностики следуйте инструкциям по использованию средств поддержки NETDIAG.exe и DCDIAG.exe, указанным в последующих разделах.

Дополнительные сведения об устранении неполадок, связанных со службой каталогов Active Directory, а также о конфигурации службы каталогов для Microsoft Exchange см. в следующих статьях:

  • статья, посвященная устранению неполадок, связанных с операциями службы каталогов Active Directory, на веб-узле, посвященном операциям в Windows Server 2003(может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=68099);

  • веб-страница, посвященная средствам для устранения неполадок, связанных с Active Directory, в руководстве по операциям в Active Directory (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=68100);

  • статья, посвященная контексту именования конфигурации, на веб-узле, посвященном работе с разрешениями Active Directory в Exchange Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47592);

  • веб-узел, посвященный работе с разрешениями Active Directory в Exchange Server (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47592).

  • «Обзор средства Netdiag» (http://go.microsoft.com/fwlink/?LinkID=69481) (на английском языке).

  • «Обзор средства Dcdiag» (http://go.microsoft.com/fwlink/?LinkID=68936) (на английском языке).


Домен Active Directory находится в смешанном режиме
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-08-10

Установку Microsoft® Exchange Server 2007 не удается продолжить, так как существующий домен Active Directory не установлен в основной режим Microsoft Windows®°2000 Server или в более совершенный режим.

При установке Exchange 2007 создаются универсальные группы безопасности, которые могут существовать только в доменах, находящихся в основном режиме Windows 2000 Server или в более совершенном режиме.

Для устранения этой проблемы выполните приводимые ниже шаги, чтобы повысить функциональный уровень домена, по крайней мере, до основного режима Windows 2000 Server, а затем повторно запустите программу установки Exchange 2007.

Чтобы повысить функциональный уровень домена

  1. Откройте оснастку «Active Directory — домены и доверие».

  2. В дереве консоли щелкните правой кнопкой мыши домен, функциональный уровень которого хотите повысить, а затем щелкните Повысить функциональный уровень домена.

  3. В окне Выбор доступного функционального уровня домена выполните одну из следующих процедур:

    • Чтобы повысить функциональный уровень домена до основного режима Windows 2000 Server, щелкните Основной режим Windows 2000, а затем щелкните Повысить.

    • Чтобы повысить функциональный уровень домена до Windows Server® 2003, щелкните Windows Server 2003, а затем щелкните Повысить.
Внимание!

Если имеются или предполагается иметь контроллеры домена под управлением Windows NT® 4.0 и более ранних версий, не повышайте функциональный уровень домена до основного режима Windows 2000 Server. После установки функционального уровня домена в основной режим Windows 2000 Server его невозможно вернуть обратно в смешанный режим Windows 2000 Server.

Если имеются или предполагается иметь контроллеры домена под управлением Windows NT 4.0 и более ранних версий или Windows 2000 Server, не повышайте функциональный уровень домена до Windows Server 2003. После установки функционального уровня домена в режим Windows Server 2003 его невозможно изменить обратно в смешанный режим Windows 2000 Server или в основной режим Windows 2000 Server.


Требуется подготовка Active Directory
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-26

Не удается продолжить установку Microsoft Exchange Server 2007 из-за сбоя подготовки домена.

Перед подготовкой доменов в Active Directory необходимо изменить службу каталогов Active Directory для Exchange Server 2007.

Чтобы устранить данную проблему, подготовьте Active Directory с помощью команды Setup /PrepareAD, а затем выполните подготовку доменов.

Дополнительные сведения о выполнении процесса PrepareAD см. в статье «Подготовка Active Directory и доменов» (http://go.microsoft.com/fwlink/?LinkId=78453) (на английском языке).


Порт ADAM уже используется
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-06

Установка Microsoft® Exchange Server 2007 не может быть продолжена, потому что при попытке установки роли шлюза сервера было установлено, что назначенные для синхронизации ADAM (Active Directory® Application Mode) порты уже используются.

ADAM - это служба каталога протокола LDAP, специально разработанная для работы с приложениями, пользующимися каталогами. ADAM сохраняет и реплицирует только информацию, связанную с определенным приложением, и не требует внедрения на контроллере домена, а также не зависит от службы Active Directory. ADAM не предоставляет проверку подлинности или авторизацию сетевой операционной системы.

В Exchange 2007 сервер шлюза использует ADAM, чтобы хранить информацию о настройке. Когда ADAM синхронизирован со службой каталога Active Directory, его можно также использовать для выполнения проверки получателя для безопасности сообщений.

Настройка Microsoft Exchange требует, чтобы определенные порты были свободны (не использовались), чтобы их можно было назначить процессу синхронизации ADAM, если установлена роль шлюза сервера.

Для решения этой проблемы определите и остановите процесс, испольщующий нужные для ADAM порты или запустите настройку Exchange 2007 с переключателями в командной строке, чтобы изменить назначение порта ADAM по умолчанию.

Для запуска программы установки с изменением назначения порта ADAM по умолчанию выполните следующее:

  1. В командной строке введите следующую команду:

    Setup.exe /adamport:xxxx /adamsslport:yyyy

    • /adamport:<номер порта, назначенного для ADAM>

    • /adamsslport:<номер порта, назначенного для ADAM>


Существует иерархия общих папок приложений
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-05

Средство анализатора сервера Microsoft® Exchange выполняет поиск иерархии общих папок приложений в домене службы каталогов Active Directory® . Если анализатор сервера Exchange обнаруживает деревья общих папок, отличных от MAPI, на экран будет выведено предупреждение. Это предупреждение указывает, что в организации Exchange существуют деревья общих папок, отличных от MAPI. Эти особые деревья приложений не поддерживаются в Exchange Server 2007.

Деревья общих папок, отличных от MAPI, используются для разработки пользовательских приложений. Эти деревья могут присутствовать в Microsoft Exchange 2000 Server и Microsoft Exchange Server 2003, но не поддерживаются в Exchange 2007. Перед развертыванием Exchange 2007 рекомендуется выполнить какое-либо из следующих действий:

  • Переместите деревья общих папок, отличных от MAPI, на сервер SharePoint Portal.

  • Храните данные на сервере Exchange 2003.

Дополнительные сведения о различных иерархиях общих папок см. в статье, посвященной выбору подходящего клиента для доступа к общим папкам Exchange (может быть на английском языке) (http:// go.microsoft.com/fwlink/?LinkId =46439).


Не удается определить имя сайта Active Directory
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-06

Программа установки Microsoft® Exchange Server 2007 не может продолжить работу, так как данный сервер, по-видимому, не входит в допустимый сайт службы каталогов Active Directory®.

Для программы установки Microsoft Exchange требуется, чтобы сервер, используемый для установки Exchange 2007, входил в допустимый сайт Active Directory.

Чтобы устранить эту неполадку, убедитесь, что локальный сервер является членом допустимого сайта Active Directory, а затем повторно выполните программу установки Exchange Server 2007.

Проверить и отобразить членов сайтов можно с помощью параметра /DsGetSite средства командной строки Nltest.exe. Дополнительные сведения см. в разделе «Nltest.exe: NLTest Overview» (Общие сведения о средстве Nltest.exe части «Tools and Settings Collection» (Коллекция средств и параметров) документа Windows Server 2003 Technical Reference (http://go.microsoft.com/fwlink/?LinkId=27734) (Техническое руководство по Windows Server 2003).

Дополнительные сведения об устранении неполадок в Active Directory см. в разделе «Troubleshooting Active Directory Operations» (Устранение неполадок в операциях Active Directory) документа Windows Server 2003: Operations (http://go.microsoft.com/fwlink/?linkid=68099) (Операции Windows Server 2003).


Не удается найти службу обновления получателей
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-05-16

Программа установки Microsoft® Exchange Server 2007 должна завершить свою работу, поскольку не удается найти службу обновления получателей, отвечающую за один из доменов существующей организации Exchange.

Для программы установки Microsoft Exchange требуется, чтобы у каждого из доменов существующей организации Exchange был собственный экземпляр службы обновления получателей.

Если экземпляр службы обновления получателей отсутствует, новые объекты пользователей, созданные в этом домене, не получат присвоенные им адреса электронной почты.

Чтобы устранить эту проблему, проверьте наличие экземпляра службы обновления получателей для каждого из доменов и создайте такие экземпляры для доменов, где они отсутствуют, а затем повторно выполните программу установки Microsoft Exchange.

Чтобы создать экземпляр службы обновления получателей для домена

  1. Откройте системный диспетчер Exchange.

  2. Раскройте узел Получатели.

  3. Щелкните правой кнопкой мыши узел Службы обновления получателей, выберите команду Создать, а затем — команду Службы обновления получателей.

  4. В окне «Создать объект» нажмите кнопку Обзор и найдите имя нужного домена.

  5. Выберите имя домена и нажмите кнопку ОК.

  6. В окне «Создать объект» нажмите кнопку Далее, а затем — кнопку Готово.

Дополнительные сведения о службе обновления получателей см. в следующих статьях базы знаний Майкрософт:

  • «How the Recipient Update Service applies recipient policies» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738) (Порядок применения политик получателей в службе обновления получателей).

  • «How the Recipient Update Service Populates Address Lists» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828) (Порядок заполнения списков адресов в службе обновления получателей).

  • «How to check the progress of the Exchange Recipient Update Service» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127) (Порядок проверки хода выполнения в службе обновления получателей).

  • «Tasks performed by the Exchange Recipient Update Service» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770) (Задачи службы обновления получателей в Exchange).


Невозможно удалить базу данных почтовых ящиков
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-06-20

Не удается продолжить установку Microsoft Exchange Server 2007, так как процессу удаления роли сервера почтовых ящиков не удается удалить базу данных (хранилище) почтовых ящиков пользователей с локального сервера без потенциальной потери данных.

Перед удалением роли сервера почтовых ящиков программа установки Exchange Server 2007 проверяет, все ли хранилища почтовых ящиков удалены с сервера. Однако почтовые ящики пользователей могут остаться на сервере.

Чтобы устранить данную проблему, переместите или отключите все почтовые ящики пользователей на сервере, а затем повторно запустите программу установки Exchange Server 2007.

Дополнительные сведения об определении почтовых ящиков в базе данных см. в разделе «Get-Mailbox» (http://go.microsoft.com/fwlink/?LinkId=93470) документации на сервер Exchange Server 2007 (на английском языке).

Дополнительные сведения об отключении почтового ящика см. в разделе «Отключение почтового ящика» (http://go.microsoft.com/fwlink/?LinkId=93471) документации на сервер Exchange Server 2007 (на английском языке).

Дополнительные сведения об удалении баз данных почтовых ящиков в сервере Exchange Server 2007 см. в разделе «Удаление базы данных почтовых ящиков» (http://go.microsoft.com/fwlink/?LinkId=93473) документации на сервер Exchange Server 2007 (на английском языке).

Дополнительные сведения об управлении хранилищами или репликами баз данных пользовательских почтовых ящиков см. в статье, посвященной управлению хранилищами почтовых ящиков и общих папок в руководстве по администрированию Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47617).


Невозможно удалить базу данных общих папок
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-01-23

Невозможно продолжить установку Microsoft® Exchange Server 2007, так как процесс удаления роли сервера почтовых ящиков не может удалить базу данных общих папок с локального сервера без возможной потери данных.

Для установки Exchange 2007 требуется, чтобы база данных общих папок была удалена с сервера перед удалением роли сервера почтовых ящиков.

Реплики общих папок могут остаться на сервере или база данных общих папок может быть последней в организации Exchange.

Чтобы решить этот вопрос, удалите и переместите базу данных общих папок на сервере и повторите установку Exchange 2007.

Дополнительные сведения об удалении баз данных общих папок в Exchange Server 2007 см. в статье «How to Remove a Public Folder Database» (http://go.microsoft.com/fwlink/?LinkId=81409) в документации Exchange Server 2007.

Дополнительные сведения об управлении хранилищами или репликами баз данных общих папок см. в статье, посвященной управлению хранилищами почтовых ящиков и общих папок в руководстве по администрированию Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=47617).


Не удается удалить роль сервера единой системы обмена сообщениями
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-26

Не удается продолжить установку Microsoft Exchange Server 2007 из-за сбоя попытки удаления роли сервера единой системы обмена сообщениями.

Программа установки Exchange Server 2007 проверяет, содержит ли удаляемая роль сервера единой системы обмена сообщениями пункт публикации приглашений для абонентской группы и связаны ли с данной абонентской группой другие серверы.

Если роль сервера единой системы обмена сообщениями содержит пункт публикации приглашений для абонентской группы, произойдет сбой процесса удаления.

Чтобы устранить данную проблему, переместите пункт публикации приглашений на другой сервер, а затем повторно запустите программу установки Exchange Server 2007.

Дополнительные сведения о перемещении пункта публикации приглашений для абонентской группы см. в статье «Изменение пункта публикации приглашений» (http://go.microsoft.com/fwlink/?LinkId=82356) (на английском языке).


Не удается выполнить запись в путь к данным кластерного сервера почтовых ящиков
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-26

Не удается продолжить установку Microsoft Exchange Server 2007 из-за сбоя установки роли кластерного сервера почтовых ящиков на общий диск кластера.

Программе установки Exchange не удалось записать данные в конечный путь установки, указанный в параметре /CMSDataPath. Программе установки Exchange требуется, чтобы конечный путь к данным кластерного сервера почтовых ящиков указывал на записываемый том.

Чтобы устранить данную проблему, укажите в параметре /CMSDataPath конечный путь, указывающий на записываемый носитель.

Дополнительные сведения об установке кластерного сервера почтовых ящиков см. в разделе «Установка роли сервера почтовых ящиков на активном узле» (http://go.microsoft.com/fwlink/?LinkId=86624) документации на сервер Exchange Server 2007 (на английском языке).


Не удается выполнить запись в контейнер организации Exchange
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-05-04

Не удается продолжить установку Microsoft Exchange Server 2007, так как пользователь, вошедший в систему, не имеет разрешений на запись в контейнер организации в службе каталогов Active Directory.

Для установки Microsoft Exchange необходимо, чтобы пользователь пользователь, находящийся в системе во время установки Exchange 2007, имел учетные данные администратора предприятия или администратора организации Exchange.

В ходе установки Exchange 2007 могут создаваться объекты в контейнере организации Microsoft Exchange.

Чтобы решить эту проблему, предоставьте пользователю, вошедшему в систему, разрешения администратора предприятия или администратора организации Exchange, или же войдите в систему с другой учетной записью, обладающей такими разрешениями, затем вернитесь к установке Exchange 2007.

Важно!
Межлесная установка Exchange Server 2007 не поддерживается. Для установки Exchange Server 2007 используйте учетную запись, которая является членом леса Active Directory.

Дополнительные сведения о разрешениях Active Directory, необходимых для работы с Microsoft Exchange, см. в статье «Работа с разрешениями Active Directory в Exchange Server» (http://go.microsoft.com/fwlink/?LinkId=47592) (на английском языке).


Роль «Клиентский доступ» на локальном узле не обнаружена
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-06

Программа настройки Microsoft® Exchange Server 2007 выводит это предупреждение, поскольку существующая роль «Клиентский доступ» на локальном узле службы каталогов Active Directory® не обнаружена.

Была выбрана установка роли сервера почтовых ящиков до установки на узле Active Directory экземпляра роли «Клиентский доступ».

Роль сервера «Клиентский доступ» принимает подключения к серверу Exchange 2007 от различных клиентов. Программные клиенты, такие как Microsoft Outlook Express и Eudora, для связи с сервером Exchange используют подключения POP3 и IMAP4. Аппаратные клиенты, такие как мобильные устройства, для связи с сервером Exchange используют ActiveSync, POP3 или IMAP4.

Если пользователи получают доступ к папке «Входящие» с помощью клиента, отличного от Microsoft Office Outlook®, в организации Exchange необходимо установить роль сервера «Клиентский доступ».

Пользователи смогут входить на свои почтовые ящики с помощью Outlook, но не смогут использовать веб-клиент Outlook или мобильные устройства для доступа к этому почтовому ящику, пока на локальном узле Active Directory присутствует роль «Клиентский доступ».


Управляемые кластерные ресурсы необходимо переместить или перевести в автономный режим
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-04-09

Не удается продолжить установку Microsoft Exchange Server 2007 из-за сбоя установки новой роли активного кластерного сервера почтовых ящиков.

Сервер Exchange Server 2007 требует, чтобы управляемые кластерные ресурсы на узле кластера, для которого запущена программа установки, были неактивны.

Чтобы устранить данную проблему, переместите все управляемые кластерные ресурсы, принадлежащие к этому узлу, в том числе ресурсы, не относящиеся к серверу Exchange Server, на другой узел кластера. Также можно перевести эти ресурсы в автономный режим и повторно запустить программу установки.

Дополнительные сведения о перемещении управляемых кластерных служб Exchange см. в разделе «Move-ClusteredMailboxServer» (http://go.microsoft.com/fwlink/?LinkId=86627) документации на сервер Exchange Server 2007 (на английском языке).

Дополнительные сведения о переводе управляемых кластерных служб Exchange в автономный режим см. в разделе «Stop-ClusteredMailboxServer» (http://go.microsoft.com/fwlink/?LinkId=86635) документации на сервер Exchange Server 2007 (на английском языке).

Дополнительные сведения об управлении кластерными ресурсами, которые не относятся к Exchange, см. в разделе «Управление ресурсами» (http://go.microsoft.com/fwlink/?LinkId=86637) справки Windows Server 2003 (на английском языке).


Служба кластеров не запущена
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-26

Не удается продолжить установку Microsoft Exchange Server 2007, так как служба кластеров Microsoft Windows Server не запущена.

Программе установки Exchange Server 2007 требуется, чтобы при установке на локальный компьютер службы кластеров была запущена служба кластеров.

Чтобы устранить эту проблему, запустите на локальном компьютере службу кластеров и повторно запустите программу установки Exchange.

Сведения о запуске службы кластеров см. в статье «Запуск службы кластеров» (http://go.microsoft.com/fwlink/?LinkId=86638) в технической библиотеке Windows Server 2003 (на английском языке).


Требуется обновление кластера (KB921181)
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-08-11

Установку Microsoft® Exchange Server 2007 не удается продолжить, так как требуется обновление для узла кластера.

Для программы установки Exchange 2007 требуется установить на узле кластера обновление, указанное в базе знаний Майкрософт, в статье 921181.

Чтобы устранить эту проблему, установите обновление, указанное в базе знаний Майкрософт, в статье 921181, сообщающей о доступности обновления, которое добавляет функциональную возможность свидетеля общего файлового ресурса и настраиваемого пульса кластера в кластеры серверов, работающих на платформе Windows Server 2003 с пакетом обновления 1 (SP1) (http://go.microsoft.com/fwlink/?LinkId=69785), а затем перезапустите программу установки Exchange 2007.


Путь к данным кластерного сервера почтовых ящиков должен указывать на том NTFS
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-26

Не удается продолжить установку Microsoft Exchange Server 2007 из-за сбоя установки роли кластерного сервера почтовых ящиков на общий диск кластера.

Конечный путь установки, указанный в параметре /CMSDataPath, не является томом NTFS. Программе установки Exchange требуется, чтобы конечный путь к данным кластерного сервера почтовых ящиков указывал на том NTFS.

Чтобы устранить данную проблему, укажите для параметра /CMSDataPath другой конечный путь либо преобразуйте конечный том в формат NTFS, а затем повторно запустите программу установки Exchange Server 2007.

Дополнительные сведения о преобразовании тома в NTFS см. в разделе «Преобразование» (http://go.microsoft.com/fwlink/?LinkId=86642) документации на Windows XP Professional (на английском языке).


Текущему узлу принадлежат кластерные службы управления
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-04-09

Не удается продолжить установку Microsoft Exchange Server 2007 из-за сбоя попытки удаления пассивного узла кластера.

Этому узлу принадлежат кластерные службы управления Exchange. Для удаления файлов Exchange Server 2007 требуется, чтобы кластерные службы управления Exchange были перемещены с этого узла.

Чтобы устранить данную проблему, переместите все управляемые кластерные ресурсы, расположенные на этом узле, в том числе кластерные ресурсы, не относящиеся к серверу Exchange Server, на другой узел кластера либо переведите их в автономный режим, а затем повторно запустите программу установки.

Дополнительные сведения о перемещении управляемых кластерных служб Exchange см. в разделе «Move-ClusteredMailboxServer» (http://go.microsoft.com/fwlink/?LinkId=86627) документации на сервер Exchange Server 2007 (на английском языке).

Дополнительные сведения о переводе управляемых кластерных служб Exchange в автономный режим см. в разделе «Stop-ClusteredMailboxServer» (http://go.microsoft.com/fwlink/?LinkId=86635) документации на сервер Exchange Server 2007 (на английском языке).

Дополнительные сведения об управлении кластерными ресурсами, не относящимися к Exchange Server, см. в разделе «Управление ресурсами» (http://go.microsoft.com/fwlink/?LinkId=86637) справки Windows Server 2003 (на английском языке).


Перед продолжением установки необходимо запустить службу «Система событий COM+»
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-16

Не удается продолжить установку Microsoft Exchange Server 2007, поскольку при установке роли сервера клиентского доступа или пограничного транспортного сервера произошел сбой вследствие того, что на конечном компьютере не запущена служба «Система событий COM+».

Программе установки Exchange Server 2007 требуется, чтобы служба «Система событий COM+» на компьютере, на который устанавливается Microsoft Exchange, находилась в состоянии Работает.

Служба «Система событий COM+» поддерживает уведомление о системных событиях для компонентов COM+, которые обеспечивают автоматическое распространение событий подписанным компонентам COM.

Как роль сервера клиентского доступа, так и роль пограничного транспортного сервера зависит от компонентов COM+, подписанных на службу «Система событий COM+».

Чтобы устранить данную проблему, убедитесь, что служба «Система событий COM+» на локальном компьютере работает, а затем повторно запустите программу установки Microsoft Exchange.

Перевод службы «Система событий COM+» в состояние «Работает»

  1. Щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.

  2. Разверните узел Службы и приложения, а затем выберите узел Службы.

  3. В правой области найдите службу Система событий COM+.

  4. Щелкните правой кнопкой мыши службу Система событий COM+ и выберите команду Свойства.

  5. Установите для параметра Тип запуска значение Авто, а для параметра Состояние — значение Работает.

  6. Нажмите кнопку Применить, а затем — кнопку ОК.


Обнаружена модель сложной организации Exchange
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-08-10

Анализатор сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить количество групп маршрутизации в организации Exchange. Анализатор сервера Exchange также опрашивает службу каталогов Active Directory, чтобы определить количество узлов Active Directory, имеющих серверы Exchange, на которых выполняется приложение Exchange 2000 Server или Microsoft Exchange Server 2003.

Анализатор сервера Exchange классифицирует организацию Exchange как сложную организацию Exchange, если выполняются следующие условия:

  • Существует более одного леса Active Directory.

  • Программное обеспечение Microsoft Identity Integration Server (MIIS) установлено в одном или нескольких лесах.

Из четырех определенных моделей организации для Microsoft Exchange Server 2007 сложная организация Exchange — это единственная модель, предусматривающая использование нескольких лесов службы каталогов Active Directory или технологии синхронизации.

Чтобы переместить сложную организацию Exchange в Exchange 2007

  1. Посетите веб-узел интерактивной документации по продукту Exchange 2007 (http://go.microsoft.com/fwlink/?LinkId=69434).

  2. Ознакомьтесь с разделом, посвященным планированию для сложной организации Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=70505).


Невозможно найти веб-узел по умолчанию на локальном компьютере
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-06

Невозможно продолжить установку Microsoft® Exchange Server 2007, так как невозможно получить доступ к веб-узлу по умолчанию на этом сервере.

Для установки Exchange 2007 требуется, чтобы программа установка роли клиентского доступа могла получить доступ к веб-узлу по умолчанию, созданному службами IIS.

Роль сервера клиентского доступа обеспечивает возможности доступа клиентов, например: Microsoft Office Outlook® (при подключении через HTTP), веб-клиент Outlook, Exchange ActiveSync® и клиенты. использующие протоколы POP3 или IMAP4.

Службы IIS работают в качестве модуля протоколов для следующих протоколов: HTTP, POP3, IMAP4, SMTP и NNTP.

Может случиться так, что веб-узел служб IIS по умолчанию перестанет существовать. Он может быть удален или переименован (стандартное имя — веб-узел по умолчанию).

Чтобы решить этот вопрос, удалите, а затем переустановите службы IIS на этом сервере. Затем повторно запустите программу установки Exchange 2007.

Важно!
Чтобы решить эту проблему, необходимо сначала удалить, а затем переустановить службы IIS. Повторное создание или переименование каталога будет недостаточным.
Чтобы удалить службы IIS с помощью компонента панели управления «Установка и удаление программ»

  1. В меню «Пуск» выберите Панель управления.

  2. Дважды щелкните значок Установка и удаление программ.

  3. Щелкните Установка компонентов Windows.

  4. В списке Компоненты установите флажок Сервер приложений.

  5. Щелкните Сведения.

  6. Щелкните Диспетчер служб IIS.

  7. Нажмите кнопку Далее.

  8. Когда службs IIS будут удалены, нажмите кнопку Готово.
Чтобы удалить службы IIS с помощью панели управления

  1. В меню «Пуск» выберите Панель управления.

  2. Дважды щелкните значок Установка и удаление программ.

  3. Щелкните Установка компонентов Windows.

  4. В списке Компоненты установите флажок Сервер приложений.

  5. Щелкните Сведения.

  6. Установите флажок Диспетчер служб IIS.

  7. Нажимайте кнопку ОК, пока не вернетесь в мастер компонентов Windows.

  8. Нажмите кнопку Готово, чтобы закрыть мастер компонентов Windows.


Перед продолжением установки необходимо запустить службу «Координатор распределенных транзакций»
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-16

Не удается продолжить установку Microsoft Exchange Server 2007, поскольку при установке роли сервера клиентского доступа или сервера единой системы обмена сообщениями произошел сбой вследствие того, что на конечном компьютере не запущена служба «Координатор распределенных транзакций».

Программе установки Exchange Server 2007 требуется, чтобы служба «Координатор распределенных транзакций» на компьютере, на который устанавливается Microsoft Exchange, находилась в состоянии Работает.

Служба «Координатор распределенных транзакций» обеспечивает успешное и полное завершение транзакций даже в случае сбоев системы, процессов и связи.

Каждый компьютер, участвующий в распределенной транзакции, управляет собственными ресурсами и данными, а также согласуют свою работу с другими компьютерами, участвующими в транзакции. Кроме того, распределенная транзакция должна фиксироваться или прерываться на всех участвующих в ней компьютерах. Служба «Координатор распределенных транзакций» координирует транзакцию для всех ее компонентов и выступает в качестве диспетчера транзакций для каждого компьютера, управляющего транзакциями.

Как роль сервера клиентского доступа, так и роль сервера единой системы обмена сообщениями зависит от службы «Координатор распределенных транзакций».

Чтобы устранить данную проблему, убедитесь, что служба «Координатор распределенных транзакций» работает на локальном компьютере, а затем повторно запустите программу установки Microsoft Exchange.

Перевод службы «Координатор распределенных транзакций»» в состояние «Работает»

  1. Щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.

  2. Разверните узел Службы и приложения, а затем выберите узел Службы.

  3. В правой области найдите службу Координатор распределенных транзакций.

  4. Щелкните правой кнопкой мыши службу Координатор распределенных транзакций и выберите команду Свойства.

  5. Установите для параметра Тип запуска значение Авто, а для параметра Состояние — значение Работает.

  6. Нажмите кнопку Применить, а затем — кнопку ОК.


На локальном компьютере не определен суффикс DNS
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-05

Установка Microsoft® Exchange Server 2007 не может быть продолжена, так как полное доменное имя (FQDN) для локального компьютера не определено.

Программа установки Exchange 2007 требует, чтобы для локального компьютера был определен допустимый суффикс системы доменных имен (DNS).

Для решения этой проблемы определите для локального компьютера суффикс DNS, перезагрузите компьютер и заново запустите установку Exchange 2007.

Определение основного суффикса DNS локального компьютера

  1. Щелкните правой кнопкой мыши Мой компьютер и в контекстном меню выберите Свойства. Появится диалоговое окно «Свойства системы».

  2. Щелкните вкладку Имя компьютера.

  3. Щелкните Изменить. Появится диалоговое окно Изменение имени компьютера.

  4. Нажмите Дополнительно. Появится диалоговое окно DNS-суффикс и NetBIOS-имя компьютера.

  5. Введите соответствующий DNS-суффикс домена.

  6. Установите флажок Сменить основной DNS-суффикс при смене членства в домене.

  7. Нажмите кнопку OK, чтобы сохранить изменения, а затем нажмите кнопку OK, чтобы закрыть окно Изменение имени компьютера.

  8. Нажмите кнопку OK, чтобы закрыть диалоговое окно Свойства системы, а затем перезапустите компьютер, чтобы изменение вступило в силу.

Дополнительные сведения об именах DNS см. в статье 909264 базы знаний Майкрософт, посвященной соглашениям об именовании в службе Active Directory для компьютеров, доменов, узлов и подразделений, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=909264 (возможно, на английском языке).


Контроллер домена переопределен в реестре
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-27

Не удается продолжить установку Microsoft Exchange Server 2007 из-за сбоя попытки использования указанного контроллера домена. Контроллер домена статически назначен в реестре.

Для установки Exchange Server 2007 требуется, чтобы указанный в команде контроллер домена соответствовал контроллеру домена, статически назначенному с помощью переопределения в реестре.

Чтобы устранить данную проблему, запустите программу установки повторно и укажите статически назначенный контроллер домена для параметра /DomainController: <полное_доменное_имя статически_назначенного_контроллера_домена> .

Дополнительные сведения о DSAccess и обнаружении служб каталогов см. в статье 250570 базы знаний Майкрософт «Обнаружение сервера службы каталогов и использование DSAccess» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570) (на английском языке).


Требуется подготовка домена
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-27

Не удается продолжить установку Microsoft Exchange Server 2007 из-за сбоя установки роли сервера.

Для установки Microsoft Exchange перед установкой определенных ролей Exchange Server 2007 необходимо выполнить подготовку локального домена.

Подготовка домена для установки сервера Exchange Server 2007 состоит из следующих задач:

  • установка разрешений на контейнер домена для серверов Exchange Server, администраторов организации Exchange, пользователей, прошедших проверку подлинности, и администраторов почтовых ящиков Exchange;

  • создание контейнера системных объектов Microsoft Exchange (если такой контейнер не существует) и установка разрешений на этот контейнер для серверов Exchange Server, администраторов организации Exchange и пользователей, прошедших проверку подлинности;

  • создание в текущем домене новой глобальной группы домена с названием «Серверы домена Exchange»;

  • добавление группы «Серверы домена Exchange» в универсальную группу безопасности «Серверы Exchange» в корневом домене.

Чтобы устранить данную проблему, выполните команду setup /PrepareDomain для подготовки локального домена и запустите установку роли сервера повторно.

Дополнительные сведения о выполнении процесса PrepareDomain см. в статье «Подготовка Active Directory и доменов» (http://go.microsoft.com/fwlink/?LinkId=78453) (на английском языке).


Роль «Граничный транспорт» не может быть установлена на локальный компьютер
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-01-03

Установка Microsoft® Exchange Server 2007 не может быть продолжена, поскольку при попытке установить роль пограничного сервера обнаружены другие роли Microsoft Exchange, уже установленные на этом сервере.

Exchange 2007 не может установить роль пограничного сервера на сервер, на котором уже установлены другие роли Microsoft Exchange.

Роль пограничного сервера Microsoft Exchange разворачивается в демилитаризованной зоне вашей организации. Эта роль обрабатывает весь поток почты с выходом в Интернет. Кроме того, она проводит шифрование и дешифровку сообщений между доверенными организациями Microsoft Exchange и обеспечивает защиту от нежелательной почты.

Для решения этой проблемы установите роль пограничного сервера на компьютере, на котором не установлены другие роли Microsoft Exchange.


В топологии обнаружен EDK-соединитель
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-04

Анализатор сервера Microsoft® Exchange проверяет службу каталогов Active Directory® на наличие соединителей пакета разработки Exchange (Exchange Development Kit, EDK) в данной конфигурации Exchange. Ели в Active Directory обнаружены EDK-соединители, выводится предупреждение. В этом предупреждении указывается, что EDK-соединители не поддерживаются в Microsoft Exchange Server 2007.

Для замены продукта соединителя в Exchange 2007 рекомендуется обратиться к стороннему поставщику этого продукта. Кроме того, можно сохранить поддержку данного EDK-соединителя в Exchange 2003 или Microsoft Exchange 2000 Server.

Примечание.
EDK-соединители представляют собой приложения сторонних разработчиков, предназначенные для обеспечения соединения с системами связи, например факсимильными аппаратами, СМС, телексом, а также для подключения к другим системам обмена сообщениями, такими как Lotus Notes, в которых используется соединитель-шлюз. Сторонние поставщики используют пакет разработки Exchange для разработки собственных соединителей.


Файл Esm.dll используется одним или несколькими процессами
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-28

Не удается продолжить установку Microsoft Exchange Server 2007, так как при обновлении сервера возникла проблема с доступом к модулю.

Для установки Exchange Server 2007 требуется, чтобы определенные модули не были запущены. Это необходимо, чтобы в процессе обновления можно было изменять двоичные файлы. Одним из таких модулей является файл Esm.dll.

Чтобы устранить данную проблему, выгрузите процессы, использующие Esm.dll, а затем повторно запустите программу установки Exchange Server 2007.

Остановка процесса, использующего Esm.dll

  1. Откройте командную консоль Exchange.

  2. Чтобы найти идентификаторы процессов, определенных анализатором Exchange, воспользуйтесь командлетом Get-Process.

  3. Get-Process < имя_процесса >

  4. Для остановки процесса выполните командлет Stop-Process.

  5. Stop-Process < идентификатор_процесса >

  6. <process ID> — это значение идентификатора процесса, возвращенное командлетом Get-Process в действии 2.

Дополнительные сведения о командлете Get-Process см. в подразделе Использование командлета Get-Process раздела «Возможности среды Windows PowerShell» (на английском языке).


Файл ExchHelp.chm открыт
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-16

Не удается продолжить установку Microsoft Exchange Server 2007, так как при обновлении сервера возникла проблема с доступом к файлу.

Для установки Exchange Server 2007 требуется, чтобы определенные файлы были закрыты. Это необходимо, чтобы в процессе обновления можно было изменять файлы или процессы, получающие к ним доступ. Одним из таких файлов является локальный файл справки Exchange (ExchHelp.chm).

Чтобы устранить данную проблему, закройте файл ExchHelp.chm, а затем повторно запустите программу установки Exchange Server 2007.


На компьютеры с сервером Exchange 2000 Server необходимо установить пакет обновления 3 (SP3)
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-27

Не удается продолжить установку Microsoft Exchange Server 2007, так как на одном или нескольких серверах в существующей организации установлен Exchange 2000 Server без пакета обновления 3 (SP3) или более поздней версии.

Для установки Exchange 2007 Server на всех компьютерах с Exchange 2000 Server в организации должен быть установлен пакет обновления 3 (SP3) для Exchange 2000 Server.

Чтобы устранить эту проблему, установите на всех компьютерах с Exchange 2000 Server пакет обновления 3 (SP3) или более поздней версии, а затем повторно запустите программу установки Exchange Server 2007.

Дополнительные сведения об установке пакета обновления 3 (SP3) или более поздней версии на компьютерах с Exchange 2000 Server см. в статье «Файлы для загрузки для Exchange 2000 Server» (http://go.microsoft.com/fwlink/?LinkId=86647) (на английском языке).


Организация Exchange в смешанном режиме
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-05

Средство анализатора сервера Microsoft® Exchange запрашивает контейнер организации Exchange, чтобы определить режим организации Exchange. Анализатор сервера Exchange проверяет значение атрибута msExchangeMixedMode. Если значение атрибута msExchangeMixedMode равно True, анализатор сервера Exchange выведет на экран сообщение об ошибке. Сообщение об ошибке указывает, что организация Exchange работает в смешанном режиме. Приложение Microsoft Exchange Server 2007 может быть установлено только в организации, которая находится в основном режиме. Поэтому организацию, которая работает в смешанном режиме, необходимо переключить в основной режим, чтобы подготовить ее для развертывания Exchange 2007.

Примечание.
Организация, работающая в основном режиме, может содержать только серверы Exchange 2000 или более поздние версии приложения.

Чтобы подготовиться к развертыванию Exchange 2007, следует преобразовать организацию Exchange в основной режим, выполнив следующие шаги:

  1. Выполните удаление или списание всех оставшихся серверов Exchange 5.5.

  2. В системном диспетчере откройте свойства объекта организации Exchange, а затем переключитесь в основной режим.

Дополнительные сведения о преобразовании организации Exchange в основной режим см. в статье, описывающей принципы преобразования из смешанного режима в основной режим в Exchange (может быть на английском языке), (http://go.microsoft.com/fwlink/?LinkId=56642) из Руководства по развертыванию Exchange Server 2003.

Дополнительные сведения о смешанном режиме и основном режиме Microsoft Exchange см. в следующих статьях базы знаний Майкрософт:

  • Статья 270143, содержащая описание смешанного режима и основного режима в Exchange 2000 Server и в Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270143).

  • Статья 327779, содержащая инструкции по переходу из смешанного режима в основной режим в Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779).

  • Статья 272314, описывающая подготовку организации, находящейся в смешанном режиме, к переходу в основной режим (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=272314).


Компьютеры с Exchange Server 2003 требуют установки пакета обновления 2 (SP2)
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-27

Не удается продолжить установку Microsoft Exchange Server 2007, так как на одном или нескольких серверах в существующей организации установлен Exchange Server 2003 без пакета обновления 2 (SP2) или более поздней версии.

Для установки Exchange Server 2007 на всех компьютерах с Exchange Server 2003 в организации должен быть установлен пакет обновления 2 (SP2) для Exchange Server 2003 или более поздняя версия пакета обновления.

Чтобы устранить эту проблему, установите на всех компьютерах с Exchange Server 2003 пакет обновления 2 (SP2) или более поздней версии, а затем повторно запустите программу установки Exchange Server 2007.

Дополнительные сведения об установке пакета обновления 2 (SP2) или более поздней версии на компьютерах с Exchange Server 2003 см. в статье «Файлы для загрузки для Exchange Server 2003» (http://go.microsoft.com/fwlink/?LinkId=21030) (на английском языке).


Exchange Server 2007 нельзя использовать с данной версией Windows
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-27

Не удается продолжить установку Microsoft Exchange Server 2007, так как на локальном компьютере не выполняется версия операционной системы Microsoft Windows Server, поддерживаемая Exchange Server 2007.

Программе установки Exchange Server 2007 требуется, чтобы установленная на локальном компьютере версия Windows Server поддерживала запуск Exchange Server 2007 в соответствии с требованиями к системе для Exchange Server 2007.

Чтобы устранить данную проблему, установите на локальный компьютер версию операционной системы Windows Server, поддерживаемую Exchange Server 2007, либо установите Exchange Server 2007 на компьютер, на котором выполняется поддерживаемая версия Windows Server.

Дополнительные сведения о требованиях к системе для Exchange Server 2007 см. в документе «Требования к системе для Exchange Server 2007» (http://go.microsoft.com/fwlink/?LinkId=86651) (на английском языке).


Файловый ресурс-свидетель не настроен
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-23

Не удается продолжить установку Microsoft Exchange Server 2007, так как для кластера с непрерывной репликацией не настроен файловый ресурс-свидетель.

Для обеспечения работоспособности при сбое любого узла в кластере кворума с набором узлов большинства необходимо иметь по крайней мере три устройства, которые можно считать доступными. Файловый ресурс-свидетель позволяет использовать в качестве свидетеля внешнюю общую папку. Этот свидетель выступает в качестве третьего доступного устройства в двухузловом кластере кворума с набором узлов большинства.

Для установки роли кластерного сервера почтовых ящиков в среде кластера с непрерывной репликацией Exchange Server 2007 требуется настроенный файловый ресурс-свидетель.

Чтобы устранить данную проблему, выполните действия по созданию и защите общей папки для файлового ресурса-свидетеля, как указано в статье «Настройка файлового ресурса-свидетеля» (http://go.microsoft.com/fwlink/?LinkId=78278) (на английском языке). Затем установите значение MNSFileShare, переместите дважды кластерную группу и запустите программу установки Microsoft Exchange повторно.


Невозможно делегировать установку первой роли
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-06

Программа установки Microsoft® Exchange Server 2007 не может продолжить работу, поскольку вошедший в систему пользователь не имеет разрешений, необходимых для установки первой из ролей сервера в топологии.

Хотя программа установки Microsoft Exchange допускает использование делегирования для установки последующих ролей сервера, необходимо, чтобы при установке первой роли сервера Exchange 2007 в топологии вошедший в систему пользователь имел разрешения администратора организации Exchange.

В рамках установки первой из ролей сервера программе установки Exchange 2007 может потребоваться создать объекты в контейнере организации Exchange.

Для устранения этой неполадки следует предоставить вошедшему в систему пользователю разрешения администратора организации Exchange или войти в систему с использованием учетной записи, имеющей такие разрешения, и повторно запустить программу установки Exchange 2007.


Необходимо отключить Forefront Security для служб Exchange Server
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-06-20

Программе установки сервера Microsoft Exchange Server 2007 не удается продолжить обновление сервера Exchange Server 2007, поскольку на локальном компьютере запущены службы Microsoft Forefront Security для Exchange Server.

Для продолжения обновления сервера Exchange Server 2007 необходимо отключить службы Forefront Security для Exchange Server.

Чтобы устранить эту проблему, отключите службы Forefront Security для Exchange Server и заново запустите обновление сервера Exchange Server.

Дополнительные сведения об установке пакета обновления или обновления программного обеспечения для сервера Exchange Server, на котором запущено приложение Forefront Security, см. в статье 929080 базы знаний Майкрософт Установка пакета обновления или обновления программного обеспечения на компьютер с сервером Exchange Server, на котором запущено приложение Forefront Security (эта ссылка может указывать на содержимое полностью или частично на английском языке).


Необходимо обновить решение Forefront Security для Exchange Server
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Применимо к: Exchange Server 2007, Exchange Server 2007 SP1
Дата последнего изменения раздела: 2007-08-08

Программа установки сервера Microsoft Exchange Server 2007 не может продолжить обновление Exchange Server 2007, так как на локальном компьютере выполняется версия решения Microsoft Forefront Security для Exchange Server, которая не поддерживается сервером Exchange Server 2007 с пакетом обновления 1 (SP1).

При обновлении сервера Exchange Server 2007 программа установки Exchange Server требует, чтобы решение Microsoft Forefront Security для Exchange Server было обновлено, а его службы отключены.

Для устранения данной проблемы обновите решение Microsoft Forefront Security версии 10.0 для Exchange Server до версии Microsoft Forefront Security для Exchange Server с пакетом обновления 1 и отключите службы Microsoft Forefront Security для Exchange Server, после чего возобновите обновление Exchange Server.

Дополнительные сведения

Дополнительные сведения о том, как установить пакет обновления или обновление программного обеспечения на сервере Exchange Server с решением Forefront Security, см. в статье 929080 базы знаний Майкрософт «Установка пакета обновления или обновлений программного обеспечения на компьютере с сервером Exchange Server и решением Forefront Security» по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=929080 (на английском языке).


Полное доменное имя компьютера совпадает с политикой получателей
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-05-16

Установку приложения Microsoft® Exchange Server 2007 невозможно продолжить, т.к. полное доменное имя FQDN локального компьютера совпадет с SMTP-адресом политики получателей.

Для установки Microsoft Exchange необходимо, чтобы в одной и той же организации полные доменные имена (FQDN) серверов организации Exchange не совпадали ни с какими SMTP-адресами политик получателей.

Если FQDN компьютера совпадает с SMTP-адресом политики получателей, такое совпадение может привести к тому, что почтовое сообщение не будет передано с помощью SMTP, а будет задержано в очередях MTA.

Чтобы решить эту проблему, переименуйте локальный компьютер или удалите или переименуйте политику получателя и повторно запустите установку приложения Microsoft Exchange.

Чтобы переименовать локальный компьютер

  1. Откройте вкладку Система на Панели управления.

  2. На вкладке Имя компьютера щелкните Изменить.

  3. В поле Имя компьютера введите новое имя компьютера и затем нажмите кнопку ОК. Появится приглашение ввести имя пользователя и пароль пользователя, чтобы переименовать компьютер в домене.

  4. Нажмите кнопку ОК, чтобы закрыть диалоговое окно Свойства системы. Появится приглашение перезагрузить компьютер, чтобы изменения вступили в действие.
Важно!
Если компьютер, который предполагается переименовать, является контроллером домена, см. раздел "Переименование контроллера домена" (http://go.microsoft.com/fwlink/?LinkId=66828).
Чтобы изменить адрес SMTP-политики получателей

  1. Запустите диспетчер Exchange.

  2. Щелкните последовательно Организация, Получатели и Политики получателей.

  3. Дважды щелкните политику, которую предполагается изменить.

  4. Щелкните вкладку Адреса электронной почты и затем измените соответствующий SMTP-адрес

Для получения дополнительных сведений о политике получателей см. в базе знаний Майкрософт статью 288175, в которой описывается, что политика получателей не может совпадать с FQDN любого сервера в организации, п. 5.4.8 отчетов о недоставке (http://go.microsoft.com/fwlink/?linkid=3052&kbid=288175).


Сервер глобального каталога не существует на локальном узле
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-06

Установка Microsoft® Exchange Server 2007 не может продолжаться, т.к. сервер глобального каталога не существует на узле, на котором делается попытка установить Microsoft Exchange.

Для установки Microsoft Exchange требуется, чтобы узел службы каталогов Active Directory® компьютера, на котором выполняется установка, содержал сервер, действующий как глобальный каталог.

Чтобы устранить эту ошибку, выполните следующие шаги:

  • Сделайте существующий контроллер домена на узле сервером глобального каталога.

  • Установите новый сервер в роли сервера глобального каталога.

Чтобы сделать существующий контроллер домена сервером глобального каталога

  1. Откройте узлы и службы Active Directory.

  2. Разверните Узлы, разверните Узел и разверните Серверы.

  3. Выберите контроллер домена, который предполагается определить в качестве сервера глобального каталога.

  4. В правой области щелкните правой кнопкой мыши Параметры NTDS и выберите Свойства.

  5. На вкладке Общие установите флажок Глобальный каталог. Изменение происходит динамически без перезагрузки сервера.
  • Дополнительные сведения о том, как создавать серверы глобального каталога, см. в базе знаний Майкрософт в статье 313994 "How to create or move a Global Catalog in Windows 2000" (Как создать или переместить глобальный каталог в Windows 2000) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372).

  • Дополнительные сведения о размещении и доступности сервера глобального каталога и его соотношении с сервером Exchange см. в базе знаний Майкрософт в статье 875427 "Global catalog server placement and ratios in an Exchange 2000 Server organization or in an Exchange Server 2003 organization" (Размещение сервера глобального каталога в организации Exchange 2000 Server или организации Exchange Server 2003 и их сопоставление) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=875427).


Требуются глобальные обновления
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-09-19

Программа установки Microsoft® Exchange Server 2007 не может продолжить работу, поскольку пользователь, вошедший в систему, не имеет соответствующих разрешений, необходимых для выполнения глобальных обновлений службы каталогов Active Directory®.

Для работы программы установки Microsoft Exchange необходимо, чтобы при выполнении установки Exchange 2007 вошедший в систему пользователь имел права администратора предприятия.

В рамках процесса установки программе установки Exchange 2007 может потребоваться выполнить следующее:

  • создать или изменить объекты организации Exchange в службе каталогов Active Directory;

  • подготовить все домены в лесу Active Directory для Exchange 2007;

  • подготовить существующие домены Exchange 2000 Server и Exchange Server 2003 для Exchange 2007.

Для устранения этой неполадки следует предоставить вошедшему в систему пользователю разрешения администратора предприятия или войти в систему с использованием учетной записи, имеющей такие разрешения, и повторно запустить программу установки Exchange 2007.

Дополнительные сведения о разрешениях Active Directory, необходимых при использовании Exchange, см. в статье, посвященной работе с разрешениями Active Directory в сервере Exchange (http://go.microsoft.com/fwlink/?LinkId=47592).


Не удается найти запись «Host» для локального компьютера в базе данных DNS
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-05

Программа установки Microsoft® Exchange Server 2007 не может продолжить выполнение установки, так как не удается найти в базе данных службы DNS запись «Host (A)» для данного компьютера.

Программе установки Exchange 2007 требуется, чтобы локальный компьютер имел допустимую запись «HOST (A)», зарегистрированную с авторизованной для этого домена базой данных DNS.

Чтобы разрешить IP-адрес своего следующего внутреннего или внешнего конечного сервера, приложению Microsoft Exchange требуются записи DNS.

Чтобы устранить эту проблему

  • Убедитесь, что локальная конфигурация TCP/IP указывает на правильный DNS-сервер.

    Чтобы проверить локальную конфигурацию TCP/IP

    1. Проанализируйте локальную конфигурацию TCP/IP. Дополнительные сведения см. в документе «Configure TCP/IP to use DNS» (http://go.microsoft.com/fwlink/?LinkId=68094) (Инструкции по настройке TCP/IP для использования службы DNS).
  • С помощью команды Nslookup.exe проверьте, что на DNS-сервере существует запись «Host (A)». Дополнительные сведения см. в документе «To verify A resource records exist in DNS» (http://go.microsoft.com/fwlink/?LinkId=63001) (Проверка наличия записей ресурса «А» в службе DNS).

Сведения о разрешении DNS-имен, устранении неполадок и записях «Host (A)» см. в следующих документах:

  • Статья 322856 базы знаний Майкрософт «How to configure DNS to use with Exchange Server» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856) (Инструкции по настройке DNS для использования с сервером Exchange).

  • «Troubleshooting DNS» (http://go.microsoft.com/fwlink/?LinkId=63003) (Устранение неполадок в работе службы DNS).

  • «Managing resource records» (http://go.microsoft.com/fwlink/?LinkId=63004) (Управление записями ресурсов).


Роль «Узловой транспорт» не найдена в локальном сайте
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-06

При установке Microsoft® Exchange Server 2007 появляется это сообщение, поскольку существующая роль сервера «Узловой транспорт» не найдена в местном сайте службы каталога Active Directory.

Выбрана установка роли «Сервер почтовых ящиков» до установкой экземпляра роли «Узловой транспорт» в сайте Active Directory.

Роль «Узловой транспорт» Exchange 2007 разворачивается внутри службы каталогов Active Directory организации. Служба узлового транспорта обрабатывает все почтовые потоки внутри организации, применяет правила маршрутизации потоков почты и отвечает за доставку сообщений в почтовый ящик получателя.

Пока не установлена роль узлового транспорта, пользователи могут заходить в свои почтовые ящики, но не могут отправлять или получать сообщения.


Hub Transport Server Not Present in Active Directory Site
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-07-25

Анализатор Microsoft Exchange запрашивает у службы каталогов Active Directory значение любого объекта класса msExchAdminGroupContainer в организации Exchange, включающей специфический для сервера Exchange Server 2007 идентификатор административной группы FYDIBOHF23SPDLT.

Если анализатор Exchange определяет, что в организации Exchange имеется административная группа сервера Exchange Server 2007, у всех сайтов Active Directory в организации запрашивается значение атрибута msExchCurrentServerRoles для каждого объекта msExchExchangeServer, чтобы определить, установлена ли на каком-либо из обнаруженных узлов роль сервера почтовых ящиков.

Наконец, если анализатор Exchange определяет, что на сайте установлена роль сервера почтовых ящиков, запрашивается атрибут msExchCurrentServerRoles каждого объекта msExchExchangeServer на этом узле, чтобы выяснить, установлена ли также на этом узле роль транспортного сервера-концентратора.

Если анализатор Exchange определит, что на сайте Active Directory, на котором не установлена роль транспортного сервера-концентратора, установлена роль сервера почтовых ящиков, будет выведено сообщение об ошибке.

Эта ошибка указывает на то, что хотя на сайте Active Directory установлена роль сервера почтовых ящиков, почта не будет передаваться между почтовыми ящиками (даже если почтовые ящики расположены на одном сервере), пока на сайте не будет установлена по крайней мере одна роль транспортного сервера-концентратора.

Роль транспортного сервера-концентратора развертывается внутри службы каталогов Active Directory организации. Эта роль обрабатывает весь поток почты внутри организации, применяет политики сообщений организации и отвечает за доставку сообщений в почтовый ящик получателя. Транспортные серверы-концентраторы выполняют указанные ниже функции.

Передача почтовых сообщений. Прежде чем сообщения, отправляемые внутри организации Exchange 2007, доставляются в папку «Входящие» получателя или направляются пользователям вне организации, все они обрабатываются ролью транспортного сервера-концентратора. Из этого правила нет исключений.

Классификация. Классификатор выполняет разрешение получателей, разрешение маршрутизации и преобразование содержимого для всех сообщений, проходящих через транспортный конвейер сервера Exchange Server 2007.

Маршрутизация. Роль транспортного сервера-концентратора определяет путь маршрутизации для всех сообщений, отправляемых и принимаемых в организации.

Доставка. Сообщения доставляются в почтовый ящик получателя драйвером хранилища. Сообщения, отправляемые пользователями организации, отбираются из папки «Исходящие» отправителя драйвером хранилища и помещаются в очередь передачи на транспортном сервере-концентраторе.

Чтобы устранить эту ошибку, установите роль транспортного сервера-концентратора на сайтах, на которых установлена роль сервера почтовых ящиков.

Дополнительные сведения

Дополнительные сведения о развертывании на сайте роли транспортного сервера-концентратора см. в разделе «Развертывание ролей сервера» (http://go.microsoft.com/fwlink/?LinkId=83282) документации к серверу Exchange Server 2007.


Компоненты совместимости служб IIS 6 не установлены
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-08-13

Программе установки Microsoft Exchange Server 2007 не удается продолжить установку роли сервера клиентского доступа, роли сервера почтовых ящиков или средств администрирования Exchange Server 2007 на компьютере с операционной системой Windows Server 2008, поскольку не установлены компоненты совместимости метабазы IIS 6 и консоли управления IIS 6.

Программе установки Microsoft Exchange Server 2007 требуется, чтобы на компьютере с операционной системой Windows Server 2008, на который устанавливается роль сервера клиентского доступа Exchange Server 2007, роль сервера почтовых ящиков или средства администрирования Exchange 2007, были установлены компоненты совместимости метабазы IIS 6 и консоль управления IIS 6.

Чтобы устранить эту проблему, установите на конечный компьютер компонент совместимости метабазы IIS 6, а затем повторно запустите программу установки Microsoft Exchange.

Установка компонентов совместимости управления IIS 6.0 с помощью диспетчера сервера Windows Server 2008

  1. Нажмите кнопку Start (Пуск), выберите пункт Administrative Tools (Администрирование), а затем — Server Manager (Диспетчер сервера).

  2. В левой области переходов разверните узел Roles (Роли), щелкните правой кнопкой мыши узел Web Server (IIS) (Веб-сервер, IIS) и выберите команду Add Role Services (Добавить службы роли).

  3. В области Select Role Services (Выбор служб роли) прокрутите список вниз и выберите пункт IIS 6 Management Compatibility (Совместимость управления IIS 6).

  4. Установите флажки IIS 6 Metabase Compatibility (Совместимость метабазы IIS 6) и IIS 6 Management Console (Консоль управления IIS 6).

  5. В области Select Role Services (Выбор служб роли) нажмите кнопку Next (Далее), затем в области Confirm Installations Selections (Подтверждение установки выбранных компонентов) нажмите кнопку Install (Установить).

  6. Чтобы завершить работу мастера добавления служб роли, нажмите кнопку Close (Закрыть).


Компонент IIS 7 не установлен
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-08-09

Программа установки сервера Microsoft Exchange Server 2007 не может продолжить установку роли сервера клиентского доступа на компьютере с Microsoft Windows Server 2008, так как отсутствуют необходимые компоненты сервера Internet Information Server (IIS) 7.

При установке роли сервера клиентского доступа на компьютер с Windows Server 2008 программа установки сервера Exchange Server 2007 требует, чтобы на компьютере уже были установлены указанные ниже компоненты сервера IIS 7.

Необходимые компоненты IIS 7

Сжатие динамического содержимого

Сжатие статического содержимого

Обычная проверка подлинности

Проверка подлинности Windows

Чтобы устранить эту проблему, установите на целевом компьютере необходимые компоненты сервера IIS 7, а затем повторно запустите программу установки Microsoft Exchange Server.

Установка компонентов сервера IIS 7 с помощью диспетчера сервера Windows Server 2008

  1. Нажмите кнопку Start (Пуск) и выберите пункт Administrative Tools (Администрирование), а затем — Server Manager (Диспетчер сервера).

  2. В левой области навигации разверните узел Roles (Роли), щелкните правой кнопкой мыши узел Web Server (IIS) (Веб-сервер (IIS)) и выберите команду Add Role Services (Добавить службы роли).

  3. В области Select Role Services (Выбор служб роли) прокрутите список вниз и выберите пункт IIS.

  4. В разделе Security (Безопасность) установите флажки Basic Authentication (Обычная проверка подлинности) и Windows Authentication (Проверка подлинности Windows).

  5. В разделе Performance (Производительность) установите флажки Static Compression (Сжатие статического содержимого) и Dynamic Compression (Сжатие динамического содержимого).

  6. В области Select Role Services (Выбор служб роли) нажмите кнопку Next (Далее), а затем в области Confirm Installations Selections (Подтверждение установки выбранных компонентов) нажмите кнопку Install (Установить).

  7. Нажмите кнопку Close (Закрыть), чтобы завершить работу мастера добавления служб роли.


Требуются общие файлы службы IIS
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-08-14

Установку Microsoft® Exchange Server 2007 не удается продолжить, так как на этом сервере не установлены общие файлы службы IIS (Microsoft Internet Information Services).

Среде управления Microsoft Exchange может потребоваться удаленный доступ к метабазе IIS. Метабаза — это хранилище большинства значений конфигурации службы IIS. Для удаленного доступа к метабазе требуется, чтобы на локальном компьютере были установлены соответствующие DLL-библиотеки COM+.

Чтобы устранить эту проблему, установите на этом сервере общие файлы службы IIS, а затем повторно запустите программу установки Exchange 2007.

Чтобы установить общие файлы службы IIS с помощью панели управления Windows Server™ 2003

  1. В меню «Пуск» выберите Панель управления.

  2. Дважды щелкните значок Установка и удаление программ.

  3. Щелкните Установка компонентов Windows.

  4. В списке Компоненты установите флажок Сервер приложений.

  5. Щелкните Сведения.

  6. В списке Сервер приложений — состав: установите флажок Службы IIS.

  7. Щелкните Сведения.

  8. Установите флажок Общие файлы.

  9. Нажимайте кнопку ОК, пока не вернетесь в мастер компонентов Windows.

  10. Нажмите кнопку Готово, чтобы закрыть мастер компонентов Windows.
Чтобы установить общие файлы службы IIS с помощью панели управления Windows® XP

  1. В меню «Пуск» выберите Панель управления.

  2. Дважды щелкните значок Установка и удаление программ.

  3. Щелкните Установка компонентов Windows.

  4. В списке Компоненты установите флажок Службы IIS.

  5. Щелкните Сведения.

  6. Установите флажок Общие файлы.

  7. Нажимайте кнопку ОК, пока не вернетесь в мастер компонентов Windows.

  8. Нажмите кнопку Готово, чтобы закрыть мастер компонентов Windows.


Служба IIS находится в режиме, совместимом с 32-разрядными приложениями
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-08-11

Установку Microsoft® Exchange Server 2007 не удается продолжить, так как служба IIS (Microsoft Internet Information Service) работает на данном 64-разрядном компьютере в 32-разрядном режиме.

Для приложения Exchange 2007 требуется, чтобы на 64-разрядном компьютере служба IIS работала в 64-разрядном режиме.

Чтобы устранить данную проблему, переключите службу IIS в 64-разрядный режим, а затем перезапустите программу установки Microsoft Exchange

Чтобы переключить службу IIS в 64-разрядный режим

  1. Откройте окно командной строки.

  2. Введите следующую команду:

    cscript c:\inetpub\adminscripts\adsutil.vbs SET /w3svc/AppPools/Enable32BitAppOnWin64 False

  3. Нажмите клавишу ВВОД.


Недостаточно разрешений для подготовки Active Directory
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-21

Не удается продолжить установку Microsoft Exchange Server 2007 из-за сбоя подготовки домена.

Перед подготовкой доменов в Active Directory необходимо изменить службу каталогов Active Directory для Exchange Server 2007.

Учетная запись, используемая для выполнения команды setup /PrepareAD, имеет недостаточно разрешений для выполнения этой команды, хотя она может входить в группу администраторов предприятия. Возможно, срок действия этой учетной записи истек.

Чтобы устранить данную проблему, убедитесь, что учетная запись пользователя, вошедшего в систему, является допустимой и входит в группу администраторов предприятия, либо войдите в систему с учетной записью, которая обладает подобными разрешениями, и повторно выполните команду setup /PrepareAD.

Дополнительные сведения о выполнении процесса PrepareAD см. в статье «Подготовка Active Directory и доменов» (http://go.microsoft.com/fwlink/?LinkId=78453) (на английском языке).

Дополнительные сведения о разрешениях Active Directory, необходимых для работы с Microsoft Exchange, см. в статье «Работа с разрешениями Active Directory в Exchange Server» (http://go.microsoft.com/fwlink/?LinkId=47592) (на английском языке).


Недостаточно разрешений для удаления всех ролей сервера
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-27

Не удается продолжить установку Microsoft Exchange Server 2007 из-за сбоя попытки удаления всех ролей сервера.

Программе установки Exchange Server 2007 требуется, чтобы пользователь, вошедший в систему при удалении всех ролей сервера, был членом группы администраторов организации Exchange или группы администраторов предприятия.

Чтобы устранить эту проблему, предоставьте пользователю, вошедшему в систему, разрешения администратора организации Exchange или включите его в группу администраторов предприятия либо войдите в систему с учетной записью, обладающей такими разрешениями, а затем повторно запустите программу установки Exchange Server 2007.

Дополнительные сведения о разрешениях Active Directory, необходимых для работы с Microsoft Exchange, см. в статье «Работа с разрешениями Active Directory в Exchange Server» (http://go.microsoft.com/fwlink/?LinkId=47592) (на английском языке).


Недостаточно разрешений для выполнения команды /PrepareDomain
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-27

Не удается продолжить установку Microsoft Exchange Server 2007 из-за сбоя запуска процесса /PrepareDomain. У вошедшего в систему пользователя недостаточно разрешений для выполнения процесса /PrepareDomain.

Для установки Exchange Server 2007 требуется, чтобы пользователь, вошедший в систему и запускающий процесс /PrepareDomain , был членом группы администраторов домена для подготавливаемого домена и членом группы администраторов организации Exchange либо членом группы администраторов предприятия.

Чтобы устранить эту проблему, предоставьте пользователю, вошедшему в систему, разрешения группы администраторов домена для подготавливаемого домена и включите его в группу администраторов организации Exchange или администраторов предприятия либо войдите в систему с учетной записью, обладающей такими разрешениями, а затем повторно запустите программу установки Exchange Server 2007.

Дополнительные сведения о разрешениях Active Directory, необходимых для работы с Microsoft Exchange, см. в статье «Работа с разрешениями Active Directory в Exchange Server» (http://go.microsoft.com/fwlink/?LinkId=47592) (на английском языке).


Недопустимое DNS-имя домена
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-04-13

Не удается продолжить установку Microsoft Exchange Server 2007, так как для локального компьютера задано недопустимое DNS-имя домена.

Для установки Exchange Server 2007 требуется, чтобы DNS-имя домена не содержало знаков, отличных от «A — Z», «a — z»,«0—9», «.» и «-».

Чтобы устранить эту проблему, определите, содержатся ли недопустимые знаки в имени локального компьютера или в фактическом DNS-имени домена.

  • Если недопустимые знаки содержатся в имени локального компьютера, измените на локальном компьютере DNS-имя домена, используя только допустимые знаки («A — Z», «a — z»,«0—9», «.» и «-»), перезапустите компьютер и повторно запустите программу установки Exchange Server 2007.

  • Если недопустимые знаки содержатся в DNS-имени домена организации, рассмотрите возможность переименования DNS-домена или установки Exchange Server 2007 в новое доменное дерево.

Внимание!
Изменение DNS-имени домена может оказать существенное влияние на работу всей сети. Перед внесением любых изменений в DNS-имя домена обратитесь к администратору сети.
Проверка DNS-имени домена локального компьютера

  1. Щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Свойства. Откроется диалоговое окно «Свойства системы».

  2. Откройте вкладку Имя компьютера.

  3. Нажмите кнопку Изменить. Откроется диалоговое окно Изменение имени компьютера.

  4. Нажмите кнопку Дополнительно. Откроется диалоговое окно DNS-суффикс и NetBIOS-имя компьютера.

  5. Убедитесь, что используются только знаки «A — Z», «a — z»,«0—9», «.» и «-».

  6. Установите флажок Сменить основной DNS-суффикс при смене членства в домене.

  7. Нажмите кнопку ОК, чтобы сохранить изменения, затем нажмите кнопку ОК, чтобы закрыть диалоговое окно Изменение имени компьютера .

  8. Нажмите кнопку ОК, чтобы закрыть диалоговое окно Свойства системы, и перезапустите компьютер, чтобы изменения вступили в силу.

Дополнительные сведения о DNS-именах см. в статье 909264 базы знаний Майкрософт «Соглашения об именах компьютеров, доменов, сайтов и подразделений в Active Directory» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=909264) (на английском языке).


Недопустимый путь установки
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-27

Не удается продолжить установку Microsoft Exchange Server 2007 из-за сбоя установки роли сервера почтовых ящиков или кластерного сервера почтовых ящиков на общий диск кластера.

Программе установки Exchange требуется, чтобы роли сервера Exchange Server устанавливались на диск, который не является общим кластерным ресурсом.

Чтобы устранить данную проблему, установите роль сервера почтовых ящиков или кластерного сервера почтовых ящиков на диск, который не назначен в качестве общего диска кластера.

Дополнительные сведения о конфигурациях кластеров см. в разделе «Высокий уровень доступности» (http://go.microsoft.com/fwlink/?linkid=68190) документации на сервер Exchange Server 2007 (на английском языке).


Недопустимый формат конечного пути к кластерному серверу почтовых ящиков
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-27

Не удается продолжить установку Microsoft Exchange Server 2007 из-за сбоя установки роли кластерного сервера почтовых ящиков на общий диск кластера.

Параметр /CMSDataPath: <путь_к_базе_данных> имеет недопустимый формат UNC. Программе установки Exchange требуется, чтобы в указанном параметре /CMSDataPath: <путь_к_базе_данных> использовалось допустимое назначение буквы диска, например /CMSDataPath: s:\<путь_к_базе_данных>, а не формат UNC.

Чтобы устранить эту проблему, используйте допустимое назначение буквы диска для параметра /CMSDataPath: <путь_к_базе_данных>.

Дополнительные сведения об установке кластерного сервера почтовых ящиков см. в разделе «Установка роли сервера почтовых ящиков на активном узле» (http://go.microsoft.com/fwlink/?LinkId=86624) документации на сервер Exchange Server 2007 (на английском языке).


Установленная версия MOUNTMGR.SYS несовместима с сервером Exchange
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-06

Не удается продолжить выполнение программы установки Microsoft® Exchange Server 2007, поскольку установленная версия Mountmgr.sys несовместима с Microsoft Exchange.

Для программы установки Exchange 2007 требуется установить на узле кластера обновление, указанное в статье базы знаний Майкрософт 898790.

Установленная в настоящий момент на узле кластера версия Mountmgr.sys может вызвать сбои в точке подключения тома. Возникновение данной проблемы связано с проблемой драйвера Mountmgr.sys. Эта проблема определения времени нерегулярно возникает в точке подключения, когда в ней появляется новый том, который нужно подключить.

Чтобы устранить проблему, установите обновление, указанное в статье базы знаний Майкрософт 898790 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790), а затем повторно выполните программу установки Exchange 2007.

Дополнительные сведений об этой проблеме см. в статье 898790 базы знаний Майкрософт под названием «Volume mount points on disks in a server cluster may intermittently become unavailable after you install Windows Server 2003 Service Pack 1» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790) (Точки подключения томов дисков на сервере кластера могут время от времени становиться недоступными после установки ОС Windows Server 2003 с пакетом обновления 1).


Установленная версия TCPIP.SYS несовместима с сервером Exchange
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-06

Программа установки Microsoft® Exchange Server 2007 не может продолжить выполнение, так как установленная версия файла Tcpip.sys несовместима с Microsoft Exchange.

Установка Exchange 2007 требует, чтобы на локальном компьютере было установлено обновление, описываемое в статье 898060 базы знаний Майкрософт.

На данном компьютере в настоящее время выполняется драйвер Tcpip.sys из пакета обновлений SP1 для Windows Server™ 2003. Этот драйвер может вызвать проблемы подключения в глобальных сетях.

Чтобы решить эту проблему, установите обновление, описываемое в статье 898060 базы знаний Майкрософт, воспользовавшись ссылкой «Обновление для Windows Server 2003 x64 Edition (KB898060)» (http://go.microsoft.com/fwlink/?linkid=59272), и снова запустите установку Exchange 2007.

Дополнительные сведения об этом предупреждении см. в статье 898060 базы знаний Майкрософт, посвященной возможному отказу сетевого соединения между клиентами и серверами из-за установки обновления безопасности MS05-019 или пакета обновлений Windows Server 2003 SP1 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=898060).


Обнаружена модель большой организации Exchange
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-08-10

Анализатор сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить количество групп маршрутизации в организации Exchange. Анализатор сервера Exchange также опрашивает службу каталогов Active Directory, чтобы определить количество узлов Active Directory, имеющих серверы Exchange, на которых выполняется приложение Exchange 2000 Server или Microsoft Exchange Server 2003.

Анализатор сервера Exchange классифицирует организацию Exchange как большую организацию Exchange, если выполняются следующие условия:

  • В организации Exchange существует более 5 групп маршрутизации.

  • Серверы, на которых выполняется Exchange 2000 или Exchange 2003, установлены на более чем 5 узлах Active Directory.

Чтобы переместить большую организацию Exchange в Exchange 2007

  1. Посетите веб-узел интерактивной документации по продукту Microsoft Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkId=69434).

  2. Ознакомьтесь с разделом, посвященным планированию для большой организации Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=70504).


Локальный компьютер является контроллером дочернего домена
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-12-29

Невозможно продолжить установку Microsoft® Exchange Server 2007, так как локальный компьютер является контроллером дочернего домена.

Exchange 2007 невозможно установить на контроллер дочернего домена, если только этот контроллер домена не является сервером глобального каталога.

Чтобы устранить эту неполадку, повысьте уровень контроллера домена до сервера глобального каталога или установите Exchange 2007 на рядовой сервер в дочернем домене, затем повторите установку Microsoft Exchange.

Чтобы устранить это предупреждение, сделав сервер Exchange сервером глобального каталога, выполните следующие действия.

  1. На контроллере домена нажмите кнопку Пуск, укажите Программы, Администрирование, затем щелкните Active Directory — сайты и службы.

  2. В дереве консоли дважды щелкните Сайты, дважды щелкните имя сайта, затем Серверы.

  3. Дважды щелкните необходимый контроллер домена.

  4. В правой области щелкните правой кнопкой мыши Параметры NTDS и выберите Свойства.

  5. На вкладке Общие установите флажок Глобальный каталог.

  6. Перезапустите контроллер домена.


На локальном компьютере уже запущен сервер Exchange
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-01-15

Продолжение установки Microsoft® Exchange Server 2007 невозможно, поскольку на локальном компьютере уже установлены компоненты Microsoft Exchange.

Для установки Exchange 2007 требуется, чтобы на локальном компьютере не было установлено никаких компонентов Microsoft Exchange.

Для решения этой проблемы удалите все компоненты Microsoft Exchange 2000 Server или Microsoft Exchange Server 2003 и затем повторно запустите программу установки Microsoft Exchange.

Чтобы удалить компоненты Microsoft Exchange

  1. Нажмите кнопку Пуск, выделите пункт Настройка и выберите Панель управления.

  2. Дважды щелкните значок Установка и удаление программ.

  3. В списке Установленные программы щелкните Microsoft Exchange и нажмите кнопку Изменить/удалить.

  4. В окне мастера установки Microsoft Exchange нажмите кнопку Далее.

  5. В списке действий на странице «Выбор компонентов» щелкните стрелку вниз рядом с каждым установленным компонентом и затем нажмите кнопку Удалить.

    Примечание.
    Установленные компоненты помечены галочками в списке «Действие». При нажатии кнопки Удалить каждая галочка заменяется словом Удаление.

  6. Нажмите кнопку Далее два раза.

  7. Нажмите кнопку Готово.


На локальном компьютере установлена система, отличная от Windows Server 2003 с пакетом обновлений 1 или более поздней версии
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-05

Установка Microsoft Exchange Server 2007 не может быть продолжена, поскольку на локальном компьютере установлена система, отличная от Microsoft Windows Server™ 2003 с пакетом обновлений 1 (SP1) или более поздней версии.

Для установки Exchange 2007 необходимо, чтобы на компьютере, который используется для Microsoft Exchange, был установлен Windows Server 2003 SP1 или более поздней версии.

Чтобы решить эту проблему, сделайте следующее:

  • Запустите установку Exchange 2007 на компьютере, на котором установлен Windows Server 2003 SP1 или более поздней версии.

  • Обновите систему компьютера, на котором будет устанавливаться Exchange 2007, до Windows Server 2003 SP1 или более поздней версии.

Для получения дополнительных сведений об обновлении системы до Windows Server 2003 см. статью 810613 базе данных корпорации Майкрософт «Доступные способы обновления до Windows Server 2003 или Windows Small Business Server 2003» (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810613).

Последний пакет обновлений для Windows Server 2003 можно получить на веб-узле Windows Server TechCenter (http://go.microsoft.com/fwlink/?LinkId=45315).


Локальный компьютер отвечает за расширение членства в группе
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-06

Установку приложения Microsoft® Exchange Server 2007 не удается продолжить из-за сбоя попытки удалить роль транспортного сервера-концентратора, отвечающую за расширение членства в группе.

Для работы программы установки Exchange 2007 требуется, чтобы расширение списка рассылки было удалено с текущего сервера-плацдарма, прежде чем можно будет удалить роль транспортного сервера-концентратора.

Расширение списков рассылки позволяет идентифицировать отдельных получателей, которые принадлежат определяемому списку рассылки или идентифицировать дополнительные списки рассылки для расширения. Расширенный список рассылки может вернуть путь для любого требуемого уведомления о состоянии доставки. Уведомления о состоянии доставки сообщают администратору Microsoft Exchange или отправителю электронной почты о состоянии определенного сообщения электронной почты. Кроме того, расширение списка рассылки определяет, должны ли сообщения об отсутствии на рабочем месте или автоматически создаваемые ответы посылаться отправителю исходного сообщения.

Чтобы устранить эту проблему, переместите расширение группы рассылки на другой сервер и повторно запустите установку Microsoft Exchange.

Чтобы изменить сервер расширения для группы рассылки или динамической группы рассылки

  1. Откройте консоль управления Exchange.

  2. В дереве консоли разверните узел Конфигурация получателя.

  3. В дереве консоли щелкните узел Группа рассылки.

  4. Создайте фильтр для просмотра всех групп рассылки и динамических групп рассылки, которые используют текущий сервер-плацдарм в качестве сервера расширения.

    1. В области действий щелкните Создать фильтр.

    2. В раскрывающемся списке свойств щелкните Сервер расширения.

    3. В раскрывающемся списке операторов щелкните Равно.

    4. Рядом с полем значения нажмите кнопку Обзор, чтобы выбрать сервер-плацдарм, который в текущий момент действует как сервер расширения.
Примечание.
Следующий шаг является необязательным.
  1. Щелкните Добавить выражение, чтобы указать дополнительные условия отбора. На экран будут выведены только те сообщения, которые удовлетворяют всем условиям отбора.

  2. Нажмите Применить фильтр. На экране отображаются результаты, которые соответствуют условиям отбора.

  1. В области результатов щелкните группу рассылки, для которой хотите изменить сервер расширения, а затем щелкните Свойства в области действий.

  2. На странице Свойства откройте вкладку Дополнительно.

  3. В раскрывающемся списке серверов расширения выберите определенный сервер или выберите пункт Любой сервер в организации.

  4. Повторите шаги 5-7 для всех групп рассылки или для динамических групп рассылки, которые используют сервер-плацдарм в качестве сервера расширения.


Локальный компьютер является ответственным за создание автономной адресной книги
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-06

Настройка Microsoft® Exchange Server 2007 не может быть продолжена из-за ошибки, возникшей при попытке удалить роль «Почтовый ящик», ответственную за создание автономной адресной книги.

При настройке Exchange 2007 требуется (если только роль «Почтовый ящик» не является последней ролью данного типа в организации Exchange), чтобы создание автономной адресной книги было удалено с текущего сервера почтового ящика перед удалением роли «Почтовый ящик».

Чтобы устранить эту неполадку, переместите создание автономной адресной книги на другой сервер и перезапустите установку Microsoft Exchange.

Чтобы переместите создание автономной адресной книги с помощью диспетчера Exchange

  1. Откройте диспетчер Exchange.

  2. В разделе Получатели щелкните Автономные списки адресов.

  3. В правой области щелкните правой кнопкой мыши Автономный список адресов по умолчанию, затем щелкните Свойства.

    Примечание.
    Используйте эту процедуру для других автономных списков адресов, которые приводят к отображению этого сообщения.

  4. На вкладке Общие в разделе Сервер автономных списков адресов, щелкните Обзор, а затем щелкните сервер Exchange, который предполагается использовать.
Чтобы переместить создание автономной адресной книги с помощью консоли управления Exchange

  1. Откройте консоль управления Exchange.

  2. Разверните Microsoft Exchange, затем разверните Конфигурация организации и выберите Почтовый ящик.

  3. В области результатов щелкните вкладку Автономная адресная книга.

  4. На вкладке Автономная адресная книга выберите автономную адресную книгу, которую требуется переместить. В области действий щелкните Переместить.

  5. Когда появится мастер перемещения автономной адресной книги, выберите новый сервер для размещения создания автономной адресной книги, нажав кнопку Обзор, а затем щелкните Переместить.

  6. Чтобы закрыть окно мастера, нажмите кнопку Готово.
Чтобы использовать среду управления Exchange для перемещения создания автономной адресной книги

  • Выполните следующую команду:

    Копировать код
    Move-OfflineAddressBook -Identity <OfflineAddressBookIdParameter> -Server <ServerIdParameter> [-DomainController <String>]


На локальном компьютере выполняется роль сервера пограничной передачи
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-06

Программа установки Microsoft® Exchange Server 2007 не может продолжить выполнение установки, поскольку при попытке установить роль сервера Exchange 2007 обнаружена установленная на данном сервере роль сервера шлюза.

Программа установки Exchange 2007 не может установить роли сервера на сервер с установленной ролью сервера шлюза Microsoft Exchange.

Роль сервера шлюза Microsoft Exchange развертывается в граничной сети организации, в ней выполняется обработка всего потока почты Интернета, шифрование и дешифровка сообщений, пересылаемых между доверенными организациями Microsoft Exchange, а также обеспечивается защита от нежелательной почты.

Чтобы устранить эту проблему, установите другие роли Microsoft Exchange 2007 на компьютер, на котором не установлена роль сервера шлюза.


Локальный компьютер работает под управлением Windows 2003 Web Edition
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-06

Невозможно продолжить установку Microsoft® Exchange Server 2007, так как локальный компьютер работает под управлением операционной системы Microsoft Windows Server ™ 2003 Web Edition.

Для установки Exchange 2007 требуется, чтобы компьютер работал под управлением поддерживаемой операционной системы.

Чтобы решить этот вопрос, установите Microsoft Exchange на компьютер, не работающий под управлением операционной системы Windows Server 2003 Web Edition с пакетом обновления 1 или более поздней версии.


Необходимо обновить локальный домен
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-27

Не удается продолжить установку Microsoft Exchange Server 2007, поскольку вошедший в систему пользователь не обладает разрешениями, необходимыми для подготовки домена.

Программе установки Exchange требуется, чтобы пользователь, вошедший в систему при выполнении команды Setup /PrepareDomain, был членом групп администраторов домена и администраторов организации Exchange или группы администраторов предприятия.

Чтобы устранить эту проблему, предоставьте пользователю, вошедшему в систему, разрешения администратора домена и администратора организации Exchange, включите его в группу администраторов предприятия либо войдите в систему с учетной записью, обладающей такими разрешениями, а затем повторно запустите программу установки Exchange Server 2007.

Дополнительные сведения о разрешениях Active Directory, необходимых для работы с Microsoft Exchange, см. в статье «Работа с разрешениями Active Directory в Exchange Server» (http://go.microsoft.com/fwlink/?LinkId=47592) (на английском языке).


Не удается получить доступ к локальной метабазе
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-06

Невозможно продолжить установку Microsoft® Exchange Server 2007, так как не удалось прочитать данные из локальной метабазы.

Для установки Exchange 2007 требуется, чтобы установленные роли сервера почтовых ящиков или клиентского доступа могли считывать данные из метабазы IIS (Microsoft Internet Information Services).

Метабаза IIS содержит сведения, которые влияют на работу Microsoft Exchange, например, параметры протокола HTTP, виртуальные каталоги для доступа к почтовым ящикам и мобильным устройствам, а также параметры безопасности HTTP.

Чтобы устранить эту проблему, проверьте правильность установки служб IIS, а затем повторно запустите программу установки Microsoft Exchange.

Сведения, необходимые для проверки правильности установки служб IIS, см. в следующих ресурсах:

  • База знаний Майкрософт, статья 843093, содержащая инструкции по исправлению поврежденной метабазы IIS на компьютере под управлением Windows 2000 Server, на котором выполняется Exchange 2000 Server или Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=843093).

  • База знаний Майкрософт, статья 240225, содержащая описание служебных программ Adsutil и MetaEdit, используемых для изменения метабазы (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240225).

  • База знаний Майкрософт, статья 317678, содержащая инструкции по перезапуску служб IIS на сервере Exchange 2000 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317678).

Если сведения, содержащиеся в этих ресурсах, не помогли устранить проблему, возможно, потребуется удалить, а затем повторно установить службы IIS.

Чтобы удалить службы IIS с помощью компонента «Установка компонентов Windows» панели управления

  1. В меню «Пуск» выберите команду Панель управления.

  2. Дважды щелкните значок Установка и удаление программ.

  3. Щелкните Установка компонентов Windows.

  4. В списке Компоненты установите флажок Сервер приложений.

  5. Щелкните Состав.

  6. Щелкните Диспетчер IIS-служб.

  7. Нажмите кнопку Далее.

  8. Когда службы IIS будут удалены, нажмите кнопку Готово.
Чтобы установить службы IIS с помощью панели управления

  1. В меню «Пуск» выберите команду Панель управления.

  2. Дважды щелкните значок Установка и удаление программ.

  3. Щелкните Установка компонентов Windows.

  4. В списке Компоненты установите флажок Сервер приложений.

  5. Щелкните Состав.

  6. Установите флажок Диспетчер IIS-служб.

  7. Нажимайте кнопку OK, пока не вернетесь к окну Мастер компонентов Windows.

  8. Нажмите кнопку Далее и выполните инструкции мастера компонентов Windows.


Пользователь, вошедший в систему, не является членом локальной группы администраторов
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-06

Программа установки Microsoft® Exchange Server 2007 не может продолжить работу, так как вошедший пользователь не является членом локальной группы администраторов этого компьютера.

Программа установки Exchange 2007 требует, чтобы вошедший пользователь, устанавливающий Microsoft Exchange, имел полный доступ к локальному компьютеру.

Для решения этой проблемы войдите с использованием учетной записи, имеющей локальные права администратора, и вернитесь к установке Microsoft Exchange.


Вошедший в систему пользователь не является членом группы администраторов схемы
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-09-06

Установка Microsoft® Exchange Server 2007 не может продолжаться, так как процесс обновления схемы не имеет учетных данных администратора схемы и администратора предприятия для службы каталогов Active Directory®.

Для установки Exchange 2007 требуется, чтобы вошедший в систему пользователь, который устанавливает Microsoft Exchange, имел учетные данные администратора схемы и администратора предприятия для леса Active Directory.

В качестве части процесса установки процедура установки Microsoft Exchange расширяет схему Active Directory для добавления классов и атрибутов, относящихся к Exchange 2007.

Если вошедший в систему пользователь не имеет прав администратора схемы и администратора предприятия, произойдет сбой процесса обновления схемы.

Чтобы устранить эту проблему, добавьте вошедшего в систему пользователя в группы администраторов схемы и администраторов предприятия, затем выйдите из системы и снова войдите в нее или выйдите из системы и войдите в систему с помощью учетной записи, которая уже имеет учетные данные администратора схемы и администратора предприятия для леса Active Directory.


Слишком много активных узлов
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-23

Не удается продолжить установку Microsoft Exchange Server 2007 из-за сбоя создания новой роли активного кластерного сервера почтовых ящиков.

Для установки Exchange Server 2007 требуется, чтобы по крайней мере один узел кластера был пассивным для поддержки восстановления после сбоев.

Чтобы устранить данную проблему, установите сначала в среде другую роль пассивного кластерного сервера почтовых ящиков, а затем повторно запустите программу установки Microsoft Exchange.

Дополнительные сведения об установке активных и пассивных узлов см. разделе «Высокий уровень доступности» (http://go.microsoft.com/fwlink/?LinkId=68190) документации на сервер Exchange Server 2007 (на английском языке).


Отсутствует спецификация диска базы данных почтовых ящиков
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-05-15

Настройка восстановления после аварий 2007 Microsoft® Exchange Server не может быть продолжена, так как программа настройки восстановления после аварий не может обратиться к спецификации диска базы данных почтовых ящиков, которая использовалась в предыдущей установке этого сервера.

Программа настройки восстановления после аварий Microsoft Exchange требует, чтобы во время восстановления были доступны спецификации дисков базы данных почтовых ящиков, использованные для этого сервера ранее.

Чтобы разрешить эту ситуацию, настройте диски в соответствии с исходной логической конфигурацией и повторно запустите программу настройки восстановления Microsoft Exchange после аварий.

Назначьте или измените букву диска

  1. Откройте консоль Управление компьютером (локальным).

  2. В дереве консоли щелкните Управление компьютером (локальным), щелкните Запоминающие устройства и затем выберите Управление дисками.

  3. Щелкните правой кнопкой мыши раздел, логический диск или том и в контекстном меню выберите Изменить букву диска или путь к диску.

  4. Выполните одну из следующих процедур:

    • Чтобы назначить букву диска, нажмите кнопку Добавить, щелкните букву диска, которую хотите использовать, и нажмите кнопку ОК.

    • Чтобы изменить букву диска, щелкните ее, нажмите кнопку Изменить, щелкните букву диска, которую хотите использовать, и нажмите кнопку ОК.

Дополнительные сведения о назначении буквы диска см. на веб-странице «Assign, change, or remove a drive letter» (Назначение, изменение и удаление буквы диска) (http://go.microsoft.com/fwlink/?LinkId=66764).


В данный момент в одной или более очередях имеются сообщения
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-05

При установке приложения Microsoft® Exchange Server 2007 на экран выводится это предупреждение, т.к. попытка удаления роли транспорта может привести к потере данных из транспортной очереди.

Программа установки приложения Exchange 2007 проверяет, чтобы транспортные очереди были пустыми, перед удалением ролей, связанных с управлением этими очередями.

При удалении ролей транспорта до получения предупреждения о наличии сообщений в транспортных очередях, эти сообщения могут сохраняться неопределенно долго.

Чтобы разрешить эту проблему, перед продолжением установки проверьте указанные очереди, чтобы убедиться, что сообщения в них отсутствуют .

Чтобы просмотреть содержимое очередей

  1. Откройте консоль управления Exchange.

  2. В дереве консоли щелкните узел Элементы управления.

  3. В области результатов щелкните Средство просмотра очереди Exchange.

  4. В области действий выберите Открыть средство.

  5. В средстве просмотра очереди откройте вкладку Очереди. Откроется список всех очередей на подключенном сервере.

  6. Щелкните правой кнопкой мыши нужную очередь и выберите Свойства, чтобы просмотреть свойства очереди.
Чтобы просмотреть сообщения в очереди

  1. Выполните шаги с 1 по 4

  2. В средстве просмотра очереди откройте вкладку Сообщения. Отображается список всех сообщений на подключенном сервере. Чтобы просмотреть отдельную очередь, откройте вкладку Очереди дважды щелкните имя очереди и откройте появившуюся вкладку «Сервер\Очередь».

  3. Чтобы просмотреть подробные сведения о сообщении, выберите сообщение и нажмите кнопку Свойства в области действий.


Требуется обновление Microsoft .NET Framework
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-02-26

Установку Microsoft Exchange Server 2007 не удается продолжить, так как необходимо обновить программное обеспечение на локальном компьютере.

Для установки сервера Exchange 2007 требуется установить на локальном компьютере соответствующее обновление Microsoft .NET Framework, указанное ниже.

Чтобы устранить данную проблему, выйдите из программы установки сервера Exchange 2007, загрузите и установите соответствующее 32- или 64-разрядное обновление, ссылка на которое приведена ниже, и запустите программу установки сервера Exchange 2007 заново.

Примечание.
После выбора одной из указанных ниже ссылок система предложит загрузить файлы напрямую.
  • Загрузка 64-разрядного обновления — http://go.microsoft.com/fwlink/?linkid=74465

  • Загрузка 32-разрядного обновления — http://go.microsoft.com/fwlink/?linkid=74469


Требуются службы Microsoft Core XML Services (MSXML) 6.0
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-08-21

Установку Microsoft® Exchange Server 2007 не удается продолжить, так как на этом сервере не установлены службы Microsoft Core XML Services (MSXML) 6.0.

Для всех установок роли сервера единой системы обмена сообщениями программа установки Exchange 2007 требует, чтобы на компьютере были установлены службы MSXML 6.0 для поддержки речевых служб Майкрософт.

Чтобы устранить эту проблему, установите программное обеспечение MSXML 6.0 с веб-узла http://go.microsoft.com/fwlink/?LinkId=70796, а затем повторно запустите программу установки Exchange 2007.


Недопустимый путь MNSFileShare
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-27

Не удается продолжить установку Microsoft Exchange Server 2007 из-за недопустимого пути MNSFileShare.

Значение свойства MNSFileShare должно быть строкой, содержащей UNC-путь к общей папке, внешней по отношению к кластеру, например \\сервер\имя_общей_папки.

Чтобы устранить эту проблему, укажите в качестве значения свойства MNSFileShare допустимый UNC-путь.

Дополнительные сведения о настройке свойства MNSFileShare см. в статье «Настройка файлового ресурса-свидетеля» (http://go.microsoft.com/fwlink/?LinkId=78278) (на английском языке).


Требуется обновление файла MSDAPS.DLL
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-12-05

Установку Microsoft® Exchange Server 2007 не удается продолжить, так как требуется обновление программного обеспечения для локального компьютера.

Программа установки Exchange 2007 требует установки указанного ниже обновления файла MSDAPS.DLL на локальный компьютер.

Чтобы устранить эту проблему, загрузите и установите обновление, щелкнув указанную ниже ссылку, а затем повторно запустите программу установки Exchange 2007.

  • http://go.microsoft.com/fwlink/?linkid=74467


Служба Network News Transport Service в настоящее время установлена
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-01-22

Невозможно продолжить установку Microsoft® Exchange Server 2007, так как на этом компьютере установлена служба NNTP Microsoft Windows® Server™ 2003.

Для установки Microsoft Exchange требуется, чтобы служба NNTP не была установлена на серверах, используемых для Exchange 2007.

Чтобы устранить эту неисправность, удалите службу NNTP и повторите попытку установки Microsoft Exchange.

Чтобы удалить службу NNTP с помощью компонента Windows «Установка и удаление программ» в панели управления.

  1. В меню Пуск выберите Панель управления.

  2. Дважды щелкните Установка и удаление программ.

  3. Щелкните Установка компонентов Windows.

  4. В списке Компоненты установите флажок Сервер приложений и нажмите кнопку Состав.

  5. Выберите Диспетчер служб Internet Information Services и нажмите кнопку Состав.

  6. Выберите Служба NNTP и затем снимите флажок.

  7. Нажмите кнопку ОК дважды, чтобы вернуться в список Компоненты и нажмите кнопку Далее.

  8. Нажмите кнопку Готово, когда завершится удаление службы NNTP.


Роль сервера клиентского доступа не найдена
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-02-16

Средство анализа Microsoft Exchange запрашивает у службы каталогов Active Directory значение любого объекта класса msExchAdminGroupContainer в организации Exchange, включающей специфический для сервера Exchange Server 2007 идентификатор административной группы FYDIBOHF23SPDLT.

Если средство анализа Exchange определяет, что в организации Exchange имеется административная группа Exchange Server 2007, у всех узлов Active Directory в организации запрашивается значение атрибута msExchCurrentServerRoles для каждого объекта msExchExchangeServer, чтобы определить, установлена ли на каком-либо из обнаруженных узлов роль сервера почтовых ящиков.

Наконец, если средство анализа Exchange определяет, что на узле установлена роль сервера почтовых ящиков, запрашивается атрибут msExchCurrentServerRoles каждого объекта msExchExchangeServer на этом узле, чтобы выяснить, установлена ли также на этом узле роль сервера клиентского доступа.

Если средство анализа Exchange определит, что на узле Active Directory без установленной роли сервера клиентского доступа установлена роль сервера почтовых ящиков, будет выведено предупреждение.

Это предупреждение свидетельствует о том, что несмотря на наличие на узле Active Directory роли сервера почтовых ящиков, пользователи клиентских мобильных устройств, использующие средства Microsoft Office Outlook Web Access и Exchange ActiveSync, не смогут получить доступ к своим электронным письмам на этом сервере почтовых ящиков, пока на узле не будет установлена хотя бы одна роль сервера клиентского доступа.

Роль сервера клиентского доступа принимает подключения к серверу Exchange 2007 от различных клиентов. Программные клиенты, такие как Microsoft Outlook Express и Eudora, используют для связи с сервером Exchange подключения POP3 и IMAP4. Аппаратные клиенты, такие как мобильные устройства, используют для этого подключения ActiveSync, POP3 или IMAP4.

Если пользователи заходят в папку «Входящие» с помощью клиента, отличного от Microsoft Outlook, необходимо установить в организации Exchange роль сервера клиентского доступа.

Если для доступа к почтовым ящикам используются клиенты, отличные от Microsoft Outlook, для устранения указанного предупреждения следует установить роль сервера клиентского доступа на узлах с установленной ролью сервера почтовых ящиков.

Дополнительные сведения

Дополнительные сведения об установке роли сервера клиентского доступа на узле см. в документации по Exchange Server 2007, в разделе «Развертывание ролей сервера» (http://go.microsoft.com/fwlink/?LinkId=83282, на английском языке).


Обнаружено нестандартное адресное пространство
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-08-21

Если средство анализатора сервера Microsoft® Exchange определит, что в одной или нескольких политиках получателя существует нестандартное адресное пространство, на экран выводится это предупреждение.

Нестандартное адресное пространство или пространство прокси-адресов — это адрес, по которому объект получателя сервера Exchange опознается в сторонних системах обмена сообщениями.

В более ранних версиях сервера Exchange за поддержку нестандартных адресных пространств отвечала служба обновления получателей.

В приложении Microsoft Exchange Server 2007 служба обновления получателей не реализована. За создание прокси-адресов в Exchange 2007 отвечает административная консоль.

Административные консоли должны загружать DLL-библиотеку генератора прокси-адресов для каждого обнаруженного нестандартного адресного пространства.

Важно!
Если административная консоль выполняется на 64-разрядном компьютере, потребуется 64-разрядная версия DLL-библиотеки генератора прокси-адресов.

Для устранения причин появления этого предупреждения обратитесь к поставщику, поддерживающему стороннее адресное пространство, чтобы получить DLL-библиотеку генератора прокси-адресов, совместимую с Exchange 2007.


Отсутствует в узле/домене хозяина схемы
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-08-10

Установку Microsoft® Exchange Server 2007 не удается продолжить, так как компьютер, на котором выполняется установка, не находится в том же узле или домене службы каталогов Active Directory®, что и сервер с назначенной ролью хозяина схемы домена, также известной как гибкие операции одного мастера (flexible single master operations, FSMO).

Для установки Exchange 2007 требуется, чтобы контроллер домена, функционирующий как хозяин схемы домена, находился в том же узле и домене, что и локальный компьютер, на котором выполняется установка Exchange.

Хозяин схемы домена управляет всеми обновлениями и изменениями схемы Active Directory.

Чтобы разрешить эту проблему, выполните установку Exchange Server 2007 в том же узле и домене, в которых находится хозяин схемы домена.

Чтобы определить роль можно использовать средство хозяина схемы. Однако чтобы сделать средство схемы доступным в виде оснастки консоли MMC, необходимо зарегистрировать DLL-библиотеку Schmmgmt.dll.

Чтобы просмотреть текущего хозяина схемы

  1. В командной строке введите regsvr32 schmmgmt.dll

    Примечание.
    Регистрация RegSvr32 будет успешно выполнена, если появится следующее диалоговое окно:

    Успешная регистрация DllRegisterServer в schmmgmt.dll.

  2. Чтобы открыть новую консоль управления, нажмите кнопку Пуск, щелкните Выполнить, а затем введите mmc.

  3. В меню консоли выберите команду Добавить или удалить оснастку.

  4. Нажмите кнопку Добавить, чтобы открыть диалоговое окно Добавление изолированной оснастки.

  5. Выберите Схема Active Directory и нажмите кнопку Добавить.

  6. В окне «Добавить или удалить оснастку» появится «Схема Active Directory». Щелкните Закрыть, а затем нажмите кнопку OK, чтобы вернуться к консоли.

  7. Выберите Схема Active Directory, чтобы в правой области отображались разделы Классы и Атрибуты.

  8. Щелкните правой кнопкой мыши Схема Active Directory и в контекстном меню выберите пункт Хозяин операций.

  9. На экране отобразится текущий хозяин схемы.


В домене отсутствуют контроллеры домена под управлением Windows Server 2003 с пакетом обновления 1 (SP1)
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-27

Не удается продолжить установку Microsoft Exchange Server 2007, так как процессу setup /PrepareLegacyExchangePermissions не удалось найти в подготавливаемом домене контроллер домена под управлением Microsoft Windows Server 2003 с пакетом обновления 1 (SP1) или более поздней версии.

В каждом домене, в котором выполняется команда setup /PrepareLegacyExchangePermissions, программа установки должна связаться с контроллером домена под управлением Windows Server 2003 с пакетом обновления 1 (SP1). Команда Setup /PrepareLegacyExchangePermissions не будет выполнена успешно, если не будет найден по крайней мере один контроллер домена под управлением операционной системы Windows Server 2003 с пакетом обновления 1 (SP1).

Команда setup /PrepareLegacyExchangePermissions обеспечивает правильную работу устаревшей службы обновления получателей. Перед импортом новой схемы Exchange Server 2007 сервер Exchange Server 2007 должен предоставить новые разрешения в каждом домене, в котором была выполнена команда DomainPrep для Exchange Server 2003 или Exchange 2000 Server. Команда setup /PrepareLegacyExchangePermissions предоставляет такие новые разрешения.

Чтобы устранить данную проблему, обновите по крайней мере один контроллер домена в каждом домене, в котором выполняется команда setup /PrepareLegacyExchangePermissions, до Windows Server 2003 с пакетом обновления 1 (SP1) или более поздней версии и запустите программу установки повторно.

Дополнительные сведения о подготовке устаревших разрешений Exchange см. в разделе «Подготовка устаревших разрешений Exchange» (http://go.microsoft.com/fwlink/?linkid=81776) документации на сервер Exchange Server 2007 (на английском языке).


Сервер автономной адресной книги удален
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-21

Не удается продолжить установку Microsoft Exchange Server 2007 из-за сбоя установки роли сервера клиентского доступа. Сервер почтовых ящиков Exchange, предназначенный для размещения автономной адресной книги, удален.

Для продолжения установки роли сервера клиентского доступа Exchange Server 2007 требуется наличие допустимого сервера почтовых ящиков Exchange, на котором выполняется создание автономной адресной книги.

Чтобы устранить данную проблему, назначьте допустимый сервер почтовых ящиков Exchange в качестве узла создания автономной адресной книги, а затем повторно запустите программу установки Exchange Server 2007.

Дополнительные сведения о назначении сервера Exchange Server в качестве узла для создания автономной адресной книги см. в разделе «Создание автономной адресной книги» (http://go.microsoft.com/fwlink/?LinkId=86314) документации на сервер Exchange Server 2007 (на английском языке).


Обнаружены файлы базы данных
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-06

Программе установки Microsoft® Exchange Server 2007 не удается продолжить работу, поскольку в расположении установки обнаружены файлы базы данных Microsoft Exchange.

Для выполнения установки Exchange 2007 требуется, в расположении установки отсутствовали файлы базы данных Microsoft Exchange.

Чтобы устранить эту проблему, удалите существующие файлы из расположения установки, а затем повторно выполните программу установки.

Чтобы удалить файлы базы данных сервера Exchange из расположения установки

  1. В окне «Мой компьютер» или в проводнике Windows перейдите в расположение установки.

    Примечание.
    По умолчанию файлы базы данных находятся по следующему адресу:

    <системный_диск>:\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group.

  2. Щелкните правой кнопкой мыши файлы, которые нужно удалить, а затем выберите команду Удалить.

  3. В диалоговом окне Подтверждение удаления файлов нажмите кнопку Да.

  4. Повторите шаги 2 и 3 для всех файлов в расположениях установки.


Обнаружена старая версия ADAM
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-06

Это предупреждение выдается программой установки Microsoft® Exchange Server 2007, когда при попытке установить роль «Сервер-шлюз» на текущем сервере обнаруживается более ранняя версия ADAM (Active Directory® Application Mode).

ADAM — это служба каталогов на базе протокола LDAP (Lightweight Directory Access Protocol), предназначенная для использования в приложениях, поддерживающих каталоги. Служба ADAM сохраняет и реплицирует только данные, относящиеся к приложению, не требует развертывания в контроллере домена и не зависит от службы Active Directory. ADAM не осуществляет проверку подлинности или авторизацию в сетевой операционной системе.

В Exchange 2007 сервер-шлюз использует ADAM для хранения конфигурационных данных. При синхронизации службы ADAM с Active Directory ее можно также использовать для поиска получателей в целях обеспечения безопасности сообщений.

Программа установки Exchange 2007 автоматически обновляет установленную версию ADAM до версии пакета обновлений 1 (SP1).

Никаких действий выполнять не требуется, кроме случая, когда обновление ADAM нежелательно. В этом случае не следует устанавливать роль «Сервер-шлюз» на локальном компьютере.


Обнаружен один или несколько серверов Active Directory Connector
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-06

Продолжение установки Microsoft® Exchange Server 2007 невозможно, поскольку в текущей среде Microsoft Exchange обнаружен один или несколько серверов Active Directory Connector (ADC).

ADC реплицирует объекты из Exchange Server версии 5.5 в службу каталогов Active Directory® в среде Microsoft Exchange со смешанным режимом и не поддерживается в Exchange 2007.

Для установки Exchange 2007 необходимо удалить все компоненты ADC.

Для устранения этой проблемы удалите все компоненты ADC и повторно запустите установку Exchange 2007.

Чтобы удалить компоненты Active Directory Connector

  1. Чтобы отключить службу ADC на сервере, на котором она запущена, щелкните правой кнопкой мыши значок Мой компьютер на рабочем столе и выберите команду Управление.

  2. Разверните узел Службы и приложения и щелкните узел Службы.

  3. В правой области окна щелкните правой кнопкой мыши службу Microsoft Active Directory Connector и выберите команду Свойства.

  4. В списке Тип запуска выберите Выключено. При следующем запуске компьютера служба ADC не будет запущена.

  5. Нажмите кнопку Применить и затем кнопку ОК.

  6. Чтобы удалить службу ADC из системы, воспользуйтесь мастером установки Active Directory с компакт-диска Microsoft Exchange 2000 Server или Microsoft Exchange Server 2003. Откройте папку \ADC\I386 и дважды щелкните файл программы Setup.exe. Выберите вариант Удалить все для компонентов службы ADC и следуйте указаниям мастера.

    Важно!
    Для устранения данной проблемы необходимо выполнить шаг 6 и Удалить все компоненты ADC. Простого отключения службы ADC недостаточно.

Дополнительные сведения о службе ADC см. в следующих статьях базы знаний Майкрософт:

  • статья 325300 с веб-презентацией службы поддержки, знакомящей со службой Active Directory Connector (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325300);

  • статья 325221 с веб-презентацией службы поддержки, описывающей службу Microsoft Advanced Active Directory Connector (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325221);

  • статья 312632 с инструкциями по установке и настройке службы Active Directory Connector в системе Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=312632).


Допускается использовать только один сервер с непрерывной репликацией кластера
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-27

Не удается продолжить установку Microsoft Exchange Server 2007 из-за сбоя создания кластерного сервера почтовых ящиков.

Сервер Exchange Server 2007 требует наличия только одного кластерного сервера почтовых ящиков с непрерывной репликацией кластера в кластере с непрерывной репликацией. В данном кластере с непрерывной репликацией уже имеется кластерный сервер почтовых ящиков.

Чтобы устранить данную проблему, не устанавливайте в этот кластер дополнительный кластерный сервер почтовых ящиков с непрерывной репликацией кластера.

Дополнительные сведения об установке кластерного сервера почтовых ящиков в среде кластера с непрерывной репликацией см. в разделе «Установка роли сервера почтовых ящиков на активном узле» (http://go.microsoft.com/fwlink/?LinkId=86624) документации на сервер Exchange Server 2007 (на английском языке).


На сервере кластера может быть установлена только роль сервера почтовых ящиков
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-07

Установка Microsoft® Exchange Server 2007 не может быть продолжена, поскольку попытка установить на этом кластерном сервере роль сервера, отличную от роли сервера почтовых ящиков, завершилась неудачей.

В Microsoft Exchange поддерживается установка на серверах с установленной кластерной службой только роли сервера почтовых ящиков Exchange 2007.

Чтобы устранить эту проблему, изучите раздел «Высокий уровень доступности в Exchange 2007» в руководстве по работе с Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkId=68190).


Организация находится в смешанном режиме
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-05-15

Программа Microsoft® Exchange Server 2007 не может продолжить работу, поскольку существующая организация Microsoft Exchange находится не в основном режиме.

Для выполнения программы установки Exchange 2007 необходимо, чтобы существующая организация Exchange находилась в основном режиме.

Чтобы устранить эту проблему, выполните следующие действия после обновления последнего сервера с Exchange Server 5.5 в существующей организации или до списания последнего сервера с Exchange 5.5. Затем повторно запустите программу установки Exchange 2007.

Примечание.
После переключения в основной режим вновь переключиться в смешанный режим нельзя.
Чтобы переключиться в основной режим

  1. Запустите системный диспетчер Exchange: Нажмите кнопку Пуск и последовательно выберите Все программы, Microsoft Exchange, Диспетчер системы.

  2. В дереве консоли щелкните правой кнопкой мыши организацию, которую требуется переключить в основной режим, и выберите команду Свойства.

  3. На странице <Имя организации> Свойства в группе Изменить режим работы щелкните Изменить режим.

  4. Нажмите кнопку Да в окне предупреждения, если вы уверены, что хотите переключиться в основной режим без возможности отмены. Нажмите кнопку Применить, чтобы принять изменение режима Exchange.

Для использования всех возможностей основного режима Exchange необходимо перезапустить службу «Банк данных Microsoft Exchange» на всех серверах Exchange в организации. Не требуется перезапускать все службы «Банк данных Microsoft Exchange» одновременно, однако необходимо перезапустить службу на каждом сервере, чтобы этот сервер мог использовать все возможности основного режиме Exchange. Перезапустите эту службу на серверах после того, как будет завершена репликация изменения режима на локальный контроллер домена Microsoft Windows®.

Чтобы перезапустить службу «Банк данных Microsoft Exchange»

  1. Нажмите кнопку Пуск, выберите команду Выполнить, введите services.msc и нажмите кнопку ОК.

  2. В области Службы (локальные) найдите службу Банк данных Microsoft Exchange.

  3. Щелкните эту службу правой кнопкой мыши и выберите команду Перезапустить.

Дополнительные сведения см. в статье 32779 базы знаний Майкрософт, посвященной переходу от смешанного к основному режиму в Exchange (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779).


Не удается связаться с основным DNS-сервером
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-05

Установка Microsoft® Exchange Server 2007 не может быть продолжена, так как не удается установить связь с основным сервером службы DNS (Domain Name System).

Для установки Exchange 2007 требуется, чтобы локальный компьютер взаимодействовал с заслуживающей доверия базой данных DNS домена.

Чтобы разрешить IP-адрес своего следующего внутреннего или внешнего сервера-получателя, для приложения Microsoft Exchange необходима служба DNS.

Отказы связи с основным DNS-сервером могут возникать по следующим причинам:

  • Локальная конфигурация TCP/IP не указывает на правильный DNS-сервер.

  • DNS-сервер выключен или недостижим из-за отказа сети или по другим причинам.

Чтобы устранить эту проблему, выполните следующие действия:

  • Убедитесь, что локальная конфигурация TCP/IP указывает на правильный DNS-сервер.

Чтобы проверить локальную конфигурацию TCP/IP

  1. Проанализируйте локальную конфигурацию TCP/IP:

    Дополнительные сведения см. в описании настройки TCP/IP для использования службы DNS (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=68094).
  • Убедитесь, что DNS-сервер работает и с ним можно связаться.

Чтобы убедиться в работоспособности DNS-сервера и возможности подключения к нему

  1. Убедитесь, что DNS-сервер работает, выполнив одну или несколько следующих проверок:

    • Узнайте состояние DNS-сервера, воспользовавшись программой администрирования службы DNS на DNS-сервере.

    • Перезапустите DNS-сервер.

      Дополнительные сведения см. в описании процедур запуска, останова, временного останова и перезапуска DNS-сервера (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Убедитесь в возможности DNS-сервера реагировать на внешние воздействия, выполнив команду nslookup.

      Дополнительные сведения см. в описании инструкций по проверке реакции DNS-сервера на внешние воздействия с помощью команды nslookup (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=63000).


Имя диска с базой данных общих папок отсутствует
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-05-15

Установка программы аварийного восстановления Microsoft® Exchange Server 2007 не может быть продолжена из-за того, что при установке программы аварийного восстановления обнаружилось, что нет доступа к имени диска базы данных общих папок, использованному при предыдущей установке данного сервера.

Для установки программы аварийного восстановления Microsoft Exchange необходимо, чтобы во время восстановления было доступно имя диска базы данных общих папок, использованное ранее для данного сервера.

Чтобы разрешить эту ситуацию, настройте диски в соответствии с исходной логической конфигурацией и повторно запустите установку программы аварийного восстановления Microsoft Exchange.

Назначьте или измените букву диска

  1. Откройте консоль Управление компьютером (локальным).

  2. В дереве консоли щелкните Управление компьютером (локальным), щелкните Запоминающие устройства и затем выберите Управление дисками.

  3. Щелкните правой кнопкой мыши раздел, логический диск или том и в контекстном меню выберите Изменить букву диска или путь к диску.

  4. Выполните одну из следующих процедур:

    • Чтобы назначить букву диска, нажмите кнопку Добавить, щелкните букву диска, которую хотите использовать, и нажмите кнопку ОК.

    • Чтобы изменить букву диска, щелкните ее, нажмите кнопку Изменить, щелкните букву диска, которую хотите использовать, и нажмите кнопку ОК.

Дополнительные сведения о назначении буквы диска см. на веб-странице назначения, изменения и удаления буквы диска (http://go.microsoft.com/fwlink/?LinkId=66764).


Не удается получить удаленный доступ к реестру на узле кластера
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-04-13

Не удается продолжить установку Microsoft Exchange Server 2007, так как не удалось получить доступ к реестру на узле кластера.

Для установки Exchange Server 2007 требуется доступ к реестру на всех узлах кластера для получения различных параметров.

Чтобы устранить данную проблему, выполните указанные ниже действия.

  • Убедитесь, что служба удаленного реестра запущена на всех узлах кластера.

  • Проверьте, что совместный доступ к файлам и принтерам для сетей Microsoft включен для первой по порядку привязки сетевой платы.

  • Убедитесь, что значения следующих разделов реестра совпадают для всех узлов кластера и являются допустимыми для соответствующей групповой политики:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Lanmanworkstation\parameters\RequireSecuritySignature

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Rdr\Parameters\EnableSecuritySignature

Дополнительные сведения об устранении неполадок с подключением к реестру см. в разделе «Устранение проблем с подключением к реестру» статьи «Устранение проблем с подключением для анализатора соответствия рекомендациям для Microsoft Exchange Server» (http://go.microsoft.com/fwlink/?linkid=56285) (на английском языке).


Перед удалением роли сервера необходимо удалить пограничную подписку
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-21

Не удается продолжить установку Microsoft Exchange Server 2007 из-за сбоя удаления роли пограничного транспортного сервера или транспортного сервера-концентратора вследствие наличия пограничной подписки для этой роли сервера.

Для сопоставления пограничного транспортного сервера с организацией Exchange он подписывается на сайт Active Directory. Подписанный пограничный транспортный сервер помечается атрибутом сайта Active Directory. Помимо прочего это сопоставление позволяет настроить пограничную подписку в качестве исходного сервера для соединителей отправки, созданных в организации Exchange. Транспортные серверы-концентраторы в организации Exchange используют неявный соединитель отправки внутри организации для маршрутизации сообщений электронной почты в Интернет через подписанный пограничный транспортный сервер. Сопоставление с сайтом Active Directory позволяет транспортным серверам-концентраторам находить пограничный транспортный сервер для маршрутизации.

Для установки Exchange Server 2007 требуется, чтобы все пограничные подписки для конечной роли пограничного транспортного сервера или последней роли транспортного сервера-концентратора на сайте были удалены перед удалением роли пограничного транспортного сервера или транспортного сервера-концентратора.

Чтобы устранить эту ошибку, воспользуйтесь командлетом Get-EdgeSubscription для получения сведений о пограничных подписках и командлетом Remove-EdgeSubscription для удаления пограничной подписки с конечного сервера, а затем запустите программу установки Exchange Server 2007 повторно.

Определение и удаление пограничной подписки

  1. Чтобы определить пограничные подписки для конечного сервера, следуйте инструкциям, приведенным в разделе Get-EdgeSubscription (http://go.microsoft.com/fwlink/?LinkId=86320) (на английском языке).

  2. Чтобы удалить пограничную подписку для конечного сервера, следуйте инструкциям, приведенным в разделе Remove-EdgeSubscription (http://go.microsoft.com/fwlink/?LinkId=86321) (на английском языке).


Схема FSMO не является Windows Server 2003 с пакетом обновления 1 или более новой версии
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-05

Средство анализатора сервера Microsoft® Exchange проверяет лес службы каталогов Active Directory®, чтобы определить, какая версия операционной системы работает в качестве хозяина схемы контроллера домена Active Directory. Если анализатор сервера Exchange обнаружит, что главный контроллер домена операций службы каталогов Active Directory, также известные как FSMO, не работает под управлением Microsoft Windows Server™ 2003 с пакетом обновления 1 или более поздней версии, анализатор отобразит сообщение об ошибке.

Эта ошибка указывает, что для установки Microsoft Exchange Server 2007 требуется Windows Server 2003 с пакетом обновления 1. Чтобы поддерживать новые структуры разрешений Exchange 2007, требуется Windows Server 2003 с пакетом обновления 1 или более поздние версии.

Если контроллер домена схемы FSMO службы каталогов Active Directory не работает под управлением Windows Server 2003 с пакетом обновления 1 или более поздней версии, установка Exchange 2007 завершится со сбоем.

Это сообщение является предварительной проверкой перед развертыванием Exchange 2007. Для установки Exchange 2007 рекомендуется, чтобы хозяин схемы контроллера домена Active Directory всего леса работал под управлением Windows Server 2003 с пакетом обновления 1.


На хозяине схемы используется операционная система Windows 2000 Server
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-01-08

Программа установки Microsoft® Exchange Server 2007 не может продолжить работу, так как на контроллере домена, которому назначена роль хозяина схемы службы каталогов Active Directory®, также известная как гибкие операции одного мастера (flexible single master operations — FSMO), используется операционная система Microsoft Windows® 2000 Server.

Программа установки Exchange 2007 требует, чтобы на контроллере домена, играющем роль FSMO схемы, использовалась операционная система Microsoft Windows Server™ 2003 с пакетом обновлений SP1 или более поздняя версия.

FSMO управляет всеми обновлениями и изменениями схемы Active Directory.

Для устранения этой проблемы следует обновить контроллер домена FSMO или переместить его на сервер под управлением Windows Server 2003 с пакетом обновления 1 (SP1) или более поздней версии, затем следует заново запустить установку Microsoft Exchange.

Дополнительные сведения см. в статье 325379 базы знаний Майкрософт, описывающей модернизацию контроллеров домена Windows 2000 до Windows Server 2003, по адресу http://go.microsoft.com/fwlink/?linkid=3052&kbid=325379.

Дополнительные сведения о передаче роли хозяина инфраструктуры от одного контроллера домена другому контроллеру домена см. в следующих статьях базы знаний Майкрософт:

  • Сведения для Microsoft Windows Server™ 2003 см. в статье 324801 «Просмотр и передача ролей FSMO в Windows Server 2003» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801).

  • Сведения для Microsoft Windows 2000 Server см. в статье 255690 «Как просматривать и передавать роли FSMO с помощью графического интерфейса пользователя» (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Хозяин схемы не работает под управлением Windows Server 2003 с пакетом обновления 1 или более поздней версии
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-27

Не удается продолжить установку Microsoft Exchange Server 2007, поскольку на контроллере домена, которому назначена роль хозяина схемы службы каталогов Active Directory (FSMO, Flexible Single Master Operations), не установлена операционная система Microsoft Windows Server 2003 с пакетом обновления 1 (SP1) или более поздней версии.

Для установки Exchange 2007 требуется, чтобы контроллер домена, служащий схемой FSMO, работал под управлением Windows Server 2003 с пакетом обновления 1 или более поздней версии.

FSMO управляет всеми обновлениями и изменениями схемы службы каталогов Active Directory.

Чтобы устранить данную проблему, выполните одно или несколько из указанных ниже действий.

  • Обновите контроллер домена FSMO до Windows Server 2003 с пакетом обновления 1 (SP1) или более поздней версии, а затем повторно запустите программу установки Microsoft Exchange.

  • Если в организации Exchange имеется контроллер домена FSMO с операционной системой Microsoft Windows Server 2003 с пакетом обновления 1 (SP1) или более поздней версии, запустите программу установки Exchange 2007 с параметром /domaincontroller, указывающим на этот контроллер домена FSMO:

    [/DomainController или /dc <полное_доменное_имя_контроллера_домена>]

    Параметр /DomainController используется для задания контроллера домена, который применяется для чтения и записи данных в Active Directory в процессе установки. Можно использовать формат NetBIOS или полное доменное имя.

Чтобы получить последний пакет обновления для Windows Server 2003, посетите веб-узел технического центра Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=45315).

Дополнительные сведения о параметрах установки Exchange Server 2007 см. в разделе «Автоматическая установка Exchange Server 2007» (http://go.microsoft.com/fwlink/?LinkId=86476) документации на сервер Exchange Server 2007 (на английском языке).


Setup Cannot Install Exchange to a Read-Only Domain Controller
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-07-23

Не удается продолжить установку сервера Microsoft Exchange Server 2007, поскольку конечный компьютер является контроллером домена только для чтения.

Контроллеры домена только для чтения являются возможностью Active Directory операционной системы Windows Server 2008. Контроллер домена только для чтения является одним из вариантов установки контроллера домена, используемым при установке на удаленные сайты с низким уровнем физической безопасности.

Программе установки Exchange требуется доступ на запись для конечного компьютера.

Чтобы устранить эту проблему, выберите конечный компьютер, не являющийся контроллером домена только для чтения, и заново запустите программу установки.


При установке роли сервера произошел сбой программы установки
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-04-12

Не удается продолжить установку Microsoft Exchange Server 2007, поскольку в процессе предыдущей установки произошел сбой при установке роли сервера.

Для продолжения установки Exchange Server 2007 требуется повторить установку сбойной роли сервера либо удалить эту роль из процесса установки.

Чтобы устранить данную проблему, либо переустановите только сбойные роли сервера, либо удалите их.

Переустановка сбойной роли сервера из командной строки

  1. Откройте окно командной строки и перейдите к файлам установки.

  2. Выполните следующую команду:

    Копировать код
    Setup /roles:<Failed Server Role>

    Выберите одну или несколько из указанных ниже ролей, разделяя их запятыми.

    ClientAccess (CA, C)

    EdgeTransport (ET, E)

    Примечание.
    Роль пограничного транспортного сервера нельзя устанавливать на один и тот же компьютер с другими ролями сервера.
    Примечание.
    Роль пограничного транспортного сервера необходимо развертывать в демилитаризованной зоне вне леса Active Directory.

    HubTransport (HT, H)

    Mailbox (MB, M)

    UnifiedMessaging (UM, U)

    ManagementTools (MT, T)

    Примечание.
    При выборе компонента ManagementTools будет установлена консоль управления Exchange, командлеты Exchange для командной консоли Exchange, файл справки Exchange, анализатор соответствия рекомендациям для Exchange и помощник по устранению неполадок Exchange. При установке любой другой роли сервера средства управления устанавливаются автоматически.

    Например, чтобы добавить роль транспортного сервера-концентратора на существующий сервер почтовых ящиков, выполните следующую команду: %LocalExchangeInstallationDir%\bin\Setup.com /role:HubTransport /Mode:Install

Примечание.
Если какая-либо роль Exchange Server 2007 была успешно установлена ранее, программа установки запустится в режиме обслуживания. Если никакие роли Exchange Server 2007 не были ранее установлены, программа установки продолжит работу с места последней остановки.
Переустановка сбойной роли сервера с помощью мастера установки Exchange Server 2007 в режиме обслуживания

  1. Войдите в систему на сервере, для которого необходимо переустановить роль сервера.

  2. Откройте панель управления и дважды щелкните значок Установка и удаление программ.

  3. На странице Изменение или удаление программ выберите пункт Microsoft Exchange Server и нажмите кнопку Изменить.

  4. В окне мастера установки Exchange Server 2007 на странице Режим обслуживания Exchange нажмите кнопку Далее.

  5. На странице Выбор роли сервера установите флажки для ролей сервера, которые необходимо установить, и нажмите кнопку Далее.

    Примечание.
    Роль пограничного транспортного сервера нельзя устанавливать на один и тот же компьютер с другими ролями сервера.
    Примечание.
    Роль пограничного транспортного сервера необходимо развертывать в демилитаризованной зоне вне леса Active Directory.
    Примечание.
    Если выбраны средства управления, будут установлены консоль управления Exchange, командлеты Exchange для командной консоли Exchange и файл справки Exchange. При установке любой другой роли сервера средства управления устанавливаются автоматически.

  6. Если выбрана роль транспортного сервера-концентратора, а Exchange 2007 устанавливается в лес, в котором уже существует организация Exchange Server 2003 или Exchange 2000 Server, выберите на странице Параметры потока почты сервер-плацдарм в существующий организации, который является членом группы маршрутизации Exchange 2003 или Exchange 2000, в которой требуется создать соединитель группы маршрутизации.

  7. На странице Проверка готовности просмотрите состояние, чтобы убедиться, что проверки предварительных условий для организации и ролей сервера выполнены успешно. Если проверки выполнены успешно, нажмите кнопку Установить, чтобы установить Exchange 2007.

  8. На странице Завершение нажмите кнопку Готово.
Переустановка сбойной роли сервера с помощью мастера установки Exchange Server 2007 в случаях, когда роли сервера не были установлены ранее

  1. Следуйте рекомендациям, приведенным в разделе «Выполнение выборочной установки с помощью мастера установки Exchange Server 2007» (http://go.microsoft.com/fwlink/?LinkId=86648) документации на сервер Exchange Server 2007 (на английском языке).
Удаление сбойной роли сервера

  1. Следуйте рекомендациям, приведенным в разделе «Удаление ролей сервера Exchange Server 2007» (http://go.microsoft.com/fwlink/?LinkId=86649) документации на сервер Exchange Server 2007 (на английском языке).

Дополнительные сведения

Дополнительные сведения об автоматической установке Exchange Server 2007 см. в статье «Автоматическая установка Exchange Server 2007» (http://go.microsoft.com/fwlink/?LinkId=86476) (на английском языке).


Этот сервер является источником для соединителя группы маршрутизации
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-27

Не удается продолжить установку Microsoft Exchange Server 2007 из-за сбоя удаления роли транспортного сервера-концентратора. Локальный компьютер является источником для одного или нескольких соединителей группы маршрутизации в организации Exchange.

Соединитель группы маршрутизации используется для отправки и приема сообщений между транспортными серверами-концентраторами Exchange Server 2007 и серверами-плацдармами Exchange Server 2003 или Exchange 2000 Server. При установке сервера Exchange Server 2007 в существующую организацию Exchange Server 2003 и Exchange 2000 Server создается необходимый соединитель группы маршрутизации.

Для установки Exchange Server 2007 необходимо, чтобы перед удалением роли сервера с компьютера с ролью транспортного сервера-концентратора были перемещены или удалены все соединители группы маршрутизации для организации Exchange.

Чтобы устранить данную проблему, переместите или удалите с локального компьютера все соединители группы маршрутизации, а затем повторно запустите программу установки.

Перемещение соединителя группы маршрутизации с помощью командной консоли Exchange

  1. Для изменения свойств существующего соединителя группы маршрутизации между группой маршрутизации Microsoft Exchange Server 2007 и группой маршрутизации Exchange Server 2003 или Exchange 2000 Server воспользуйтесь командлетом Set-RoutingGroupConnector.

  2. В данном примере командлет Set-RoutingGroupConnector используется для изменения источника для соединителя группы маршрутизации.
Копировать код
Set-RoutingGroupConnector -Identity "[[Administrative Group Name\]Routing Group Name]\Routing Group Connector Name" -SourceTransportServers [FQDN of desired Hub Transport Server]
 Удаление соединителя группы маршрутизации с помощью командной консоли Exchange

  1. Для удаления соединителя группы маршрутизации между группой маршрутизации Microsoft Exchange Server 2007 и группой маршрутизации Exchange Server 2003 или Exchange 2000 Server воспользуйтесь командлетом Remove-RoutingGroupConnector.

  2. В приведенном ниже примере показано. как использовать командлет Remove-RoutingGroupConnector для удаления указанного соединителя группы маршрутизации.
Копировать код
Remove-RoutingGroupConnector -Identity"[[Administrative Group Name\]Routing Group Name]\Routing Group Connector Name"

Дополнительные сведения об изменении и удалении соединителей группы маршрутизации см. в следующих разделах документации на сервер Exchange Server 2007:

  • Set-RoutingGroupConnector (http://go.microsoft.com/fwlink/?LinkId=86659) (на английском языке).

  • Remove-RoutingGroupConnector (http://go.microsoft.com/fwlink/?LinkId=86660) (на английском языке).


Этот сервер является источником для соединителя отправки
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-27

Не удается продолжить установку Microsoft Exchange Server 2007 из-за сбоя попытки удаления роли транспортного сервера-концентратора. Локальный компьютер является источником для одного или нескольких соединителей отправки в организации Exchange.

Соединитель отправки представляет собой логический шлюз, через который отправляются исходящие сообщения.

Программе установки Exchange Server 2007 требуется, чтобы перед удалением роли сервера все соединители отправки для организации Exchange были перемещены или удалены с компьютера с ролью транспортного сервера-концентратора.

Чтобы устранить данную проблему, переместите или удалите с локального компьютера все соединители отправки, а затем повторно запустите программу установки.

Дополнительные сведения об изменении и перемещении соединителей отправки см. в следующих разделах документации на сервер Exchange Server 2007:

  • «Удаление соединителя отправки» (http://go.microsoft.com/fwlink/?LinkId=86655) (на английском языке).

  • «Изменение конфигурации соединителя отправки» (http://go.microsoft.com/fwlink/?LinkId=86655) (на английском языке).


Обнаружена модель простой организации Exchange
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-08-18

Средство анализатора сервера Microsoft® Exchange запрашивает службу каталогов Active Directory®, чтобы определить количество почтовых ящиков на сервере. Каждый объект хранилища почтовых ящиков (класс msExchPrivateMDB) имеет многозначный атрибут homeMDBBL, перечисляющий все почтовые ящики в хранилище. Анализатор сервера Exchange подсчитывает эти значения, чтобы получить общее количество почтовых ящиков на сервере.

Анализатор сервера Exchange также опрашивает службу Active Directory, чтобы определить число узлов Active Directory, на которых содержатся серверы Exchange. Кроме того, анализатор сервера Exchange опрашивает службу каталогов Active Directory, чтобы определить количество серверов, на которых выполняется Microsoft Exchange 2000 Server или Microsoft Exchange Server 2003. Наконец, анализатор сервера Exchange опрашивает WMI-объект (Microsoft Windows® Management Instrumentation) Win32_Service, чтобы определить, существует ли служба кластеров Windows и работает ли она.

Анализатор сервера Exchange классифицирует организацию Exchange как простую организацию Exchange, если выполняются следующие условия:

  • Общее количество почтовых ящиков в организации меньше 1000.

  • Серверы Exchange установлены только на одном узле Active Directory.

  • Существует менее 3 компьютеров, на которых выполняется Exchange 2000 или Exchange 2003.

  • Не существует развернутых кластерных серверов Exchange.

Из четырех определенных моделей организации для Microsoft Exchange Server 2007 простая организация Exchange представляет собой самую базовую топологию, которая может быть использована для развертывания Exchange 2007. Простая организация Exchange может быть реализована в любом из двух следующих вариантов:

  • Один сервер Exchange, обеспечивающий работу всех служб Exchange и хранящий все данные Exchange для всей организации.

  • Несколько серверов Exchange в топологии, включающей резервные серверы каталогов и сервер граничного транспорта на периметре сети.

Чтобы переместить простую организацию Exchange в Exchange 2007

  1. Посетите веб-узел интерактивной документации по продукту Exchange 2007 (http://go.microsoft.com/fwlink/?LinkId=69434).

  2. Последовательно разверните узел «Планирование и архитектура», узел «Планирование развертывания», а затем щелкните «Планирование простой организации Exchange».


Установлена слжуба SMTP (Simple Mail Transport Protocol)
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-01-22

Программа установки Microsoft® Exchange Server 2007 не может продолжить работу, поскольку на компьютере установлена служба SMTP сервера Microsoft Windows Server™ 2003.

Для выполнения программы установки Microsoft Exchange на серверах, используемых для Exchange 2007, не должна быть установлена служба SMTP.

Чтобы устранить эту проблему, удалите службу SMTP и повторно запустите программу установки Microsoft Exchange.

Чтобы удалить службу SMTP с помощью модуля «Установка компонентов Windows» на панели управления

  1. В меню Пуск выберите команду Панель управления.

  2. Дважды щелкните значок Установка и удаление программ.

  3. Щелкните Установка компонентов Windows.

  4. В списке Компоненты установите флажок Сервер приложений и нажмите кнопку Состав.

  5. Выберите Диспетчер служб IIS и нажмите кнопку Состав.

  6. Выберите Служба SMTP и затем снимите флажок.

  7. Дважды нажмите кнопку ОК для возврата к списку Компоненты, а затем нажмите кнопку Далее.

  8. Когда служба SMTP будет удалена, нажмите кнопку Готово.


Узел не может поддерживать серверы Exchange 2007
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-08-11

Средство анализатора сервера Microsoft® Exchange вывело данное предупреждение, потому что в лесу службы каталогов Active Directory существуют узлы, которые не имеют, по крайней мере, одного сервера глобального каталога, работающего под управлением операционной системы Microsoft Windows Server™ 2003 с пакетом обновления 1 (SP1) или более поздней версии.

Для установки Microsoft Exchange Server 2007 требуется, чтобы каждый узел Active Directory, на котором размещается сервер с работающим приложением Exchange 2007, имел хотя бы один сервер глобального каталога, управляемый операционной системой Windows Server 2003 с пакетом обновления 1 (SP1) или более поздней версией.

Для устранения этой проблемы обновите хотя бы один сервер глобального каталога на каждом узле Active Directory до Windows Server 2003 с пакетом обновления 1 (SP1) или до более поздней версии.

Дополнительные сведения об обновлении до Windows Server 2003 см. в базе знаний Майкрософт, в статье 810613, описывающей поддерживаемые пути для обновления до Windows Server 2003 или до Windows Small Business Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810613).

Чтобы получить последний пакет обновления для Windows Server 2003, посетите веб-узел технического центра Windows (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=45315).


Обнаружена модель стандартной организации Exchange
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-08-10

Средство анализатора сервера Microsoft® Exchange опрашивает службу каталогов Active Directory®, чтобы определить следующие параметры:

  • Количество почтовых ящиков в организации.

  • Количество групп маршрутизации в организации.

  • Количество узлов Active Directory в организации.

  • Количество лесов Active Directory в организации.

  • Установлено ли программное обеспечение Microsoft Identity Integration Server (MIIS).

Величина каждого параметра определяет, является ли модель организации Exchange простой, стандартной, большой или сложной. Любая организация, которая не классифицирована как простая, большая или сложная, автоматически классифицируется как стандартная организация Exchange.

Из четырех определенных моделей организации для Microsoft Exchange Server 2007 стандартная организация Exchange представляет наиболее распространенную топологию, в которой разворачивается Exchange 2007. Когда служба обмена сообщениями вырастает за пределы ресурсов одного компьютера, разделение служб Exchange 2007 на несколько компьютеров становится следующим разделением топологии: стандартная организация Exchange. Стандартная организация Exchange строится на основе простой организации Exchange путем развертывания нескольких компьютеров, на которых выполняется Exchange.

Чтобы переместить стандартную организацию Exchange в Exchange 2007

  1. Ознакомьтесь на веб-узле с интерактивной документацией по продукту Exchange 2007 (http://go.microsoft.com/fwlink/?LinkId=69434).

  2. Последовательно разверните узел «Планирование и архитектура», узел «Планирование развертывания», а затем щелкните «Планирование стандартной организации Exchange».


В кластере рекомендуется использовать статические IP-адреса
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-05

Программа установки Microsoft® Exchange Server 2007 отображает это предупреждение, потому что один или несколько сетевых интерфейсов настроены на использование DHCP.

Рекомендуется использовать статические IP-адреса на сетевых интерфейсах, которые управляют клиентскими подключениями и пульсом, в кластере серверов Microsoft Windows. Использование динамической конфигурации посредством DHCP не рекомендуется, так как невозможность обновления выдачи DHCP может прервать операции кластера.

Чтобы устранить причины появления этого предупреждения, настройте статические IP-адреса для каждого сетевого интерфейса, управляющего клиентскими подключениями или пульсом.

Чтобы настроить статический IP-адрес для сетевого подключения

  1. В меню «Пуск» щелкните Настройке, а затем Сетевые подключения.

  2. Щелкните правой кнопкой мыши настраиваемое подключение и в контекстном меню выберите Свойства.

  3. На вкладке Общие в окне Компоненты, используемые этим подключением щелкните Протокол Интернета (TCP/IP), затем щелкните Свойства.

  4. Щелкните Использовать следующий IP-адрес и в поле IP-адрес введите необходимое значение.

  5. Нажмите кнопку ОК дважды, чтобы сохранить изменения.

Дополнительные сведения об оптимальной сетевой конфигурации для кластеров серверов Windows см. на веб-узле, посвященном рекомендациям по конфигурации сети кластеров серверов в Windows 2000 и Windows Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=34304).

Дополнительные сведения о корректной конфигурации пульса кластера см. в статье 258750 базы знаний Майкрософт, посвященной рекомендуемой частной конфигурации пульса на сервере кластера (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750).


Путь к хранилищу для кластера с единым хранилищем должен быть диском кластера
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-27

Не удается продолжить установку Microsoft Exchange Server 2007, так как путь к хранилищу для кластера с единым хранилищем должен быть диском кластера.

Кластер с единым хранилищем в Exchange Server 2007 — это кластерное решение, в котором используется единая копия группы хранения в хранилище, общем для всех узлов кластера.

Чтобы устранить данную проблему, укажите в качестве пути к данным диск кластера, а затем повторно запустите программу установки Exchange Server 2007.

Дополнительные сведения о кластерах с единым хранилищем см. в разделе «Установка кластера с единым хранилищем» (http://go.microsoft.com/fwlink/?LinkId=76162) документации на Exchange Server 2007 (на английском языке).


Формат адресации SMTP не поддерживается
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-27

Не удается продолжить установку Microsoft Exchange Server 2007, так как в указанной политике получателей используется неподдерживаемый формат SMTP-адреса.

Для установки Exchange Server 2007 требуется, чтобы все SMTP-адреса, используемые для политик адресов электронной почты, не содержали литералы IP-адресов, например: user@[10.10.1.1].

Чтобы устранить эту проблему, измените значение SMTP-адреса в политике получателей так, чтобы оно не содержало литерала IP-адреса. Замените квадратные скобки ([]) и цифры (10.10.1.1) литерала IP-адреса на формат имен службы доменных имен (DNS), например: user@contoso.com, а затем повторно запустите программу установки Microsoft Exchange.

Дополнительные сведения об управлении политиками получателей для сервера Exchange Server 2007 см. в статье «Управление политиками адресов электронной почты» (http://go.microsoft.com/fwlink/?LinkId=86653) (на английском языке).


Обнаружена SMTP-связь узла
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-12-07

Средство анализатора сервера Microsoft® Exchange отображает это предупреждение, если в службе каталогов Active Directory® обнаружены связи узлов, работающие по протоколу SMTP (Simple Mail Transfer Protocol).

Служба маршрутизации в Microsoft Exchange Server 2007 игнорирует узлы Active Directory, подключенные с помощью SMTP-связей узлов. Если приложение Exchange 2007 установлено на узлах, которые подключаются только с помощью SMTP-связей узлов, возникают ошибки маршрутизации.

Чтобы устранить эту проблему, замените SMTP-связи узлов связями узлов на основе протокола IP.

Дополнительные сведения о связях IP-сайтов службы Active Directory см. в разделе «Планирование использования сайтов Active Directory для маршрутизации почты», http://go.microsoft.com/fwlink/?LinkId=71803 (на английском языке).


Отсутствует спецификация дисков группы хранилища
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-05-15

Программа аварийного восстановления Microsoft® Exchange Server 2007 не может продолжить выполнение, так как не может получить доступ к спецификации дисков группы хранилища, использовавшейся при предыдущей установке этого сервера.

Программа аварийного восстановления Microsoft Exchange требует, чтобы при восстановлении этого сервера были доступны те же спецификации дисков баз данных группы хранилища, что и раньше.

Чтобы решить эту проблему, настройте диски в соответствии с первоначальной конфигурацией логических дисков и запустите заново программу аварийного восстановления Microsoft Exchange.

Назначение или изменение буквы диска

  1. Откройте Управление компьютером (локальным).

  2. В дереве консоли щелкните Управление компьютером (локальным), щелкните Запоминающие устройства, а затем щелкните Управление дисками.

  3. Щелкните правой кнопкой мыши раздел, логический диск или том, а затем выберите команду Изменить букву диска или путь к диску.

  4. Используйте одну из следующих процедур:

    • Чтобы назначить букву диска, щелкните Добавить, щелкните нужную букву диска, а затем нажмите кнопку OK.

    • Чтобы изменить букву диска, щелкните ее, щелкните Изменить, щелкните нужную букву диска, а затем нажмите кнопку OK.

Дополнительные сведения о назначении букв дисков см. в материале о назначении, изменении или удалении буквы диска по адресу http://go.microsoft.com/fwlink/?LinkId=66764.


Несоответствие конечного пути установки
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-27

Не удается продолжить установку Microsoft Exchange Server 2007, поскольку конечный путь для двоичных файлов Exchange не соответствует текущему пути установки Exchange на других узлах кластера.

Для установки Exchange Server 2007 требуется, чтобы узлы одного кластера имели одинаковые конечные пути установки для двоичных файлов Exchange.

Чтобы устранить данную проблему, используйте одинаковый путь установки для двоичных файлов Exchange на всех узлах кластера.

Дополнительные сведения об обеспечении высокого уровня доступности в Exchange Server 2007 см. в разделе «Высокий уровень доступности» (http://go.microsoft.com/fwlink/?linkid=68190) документации на сервер Exchange Server 2007 (на английском языке).


Для целевого местоположения включено сжатие
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-06

Программа установки Microsoft® Exchange Server 2007 не может продолжить выполнение установки, так как путь к целевой папке для установки Microsoft Exchange указан в сжатом виде.

Для программы установки Microsoft Exchange требуется, чтобы первая папка в целевом местоположении для данной установки была указана не в сжатом виде. По умолчанию первой папкой целевого местоположения для данной установки является папка «C:\Program Files».

Чтобы устранить эту неполадку, отключите сжатие для первой папки целевого местоположения и повторно выполните программу установки Exchange 2007.

Чтобы отключить сжатие для целевой папки

  1. В окне «Мой компьютер» или в проводнике Windows щелкните правой кнопкой мыши папку, для которой нужно отменить сжатие.

  2. Выберите команду Свойства. Откроется диалоговое окно Свойства.

  3. На вкладке Общие щелкните Дополнительно.

  4. В диалоговом окне Дополнительные атрибуты снимите флажок Сжимать содержимое для экономии дискового пространства и нажмите кнопку ОК.

  5. В диалоговом окне Свойства нажмите кнопку ОК.

  6. После того как для папки изменено состояние сжатия, выберите в диалоговом окне Подтверждение изменения атрибута командуПрименить изменения к данной папке, вложенным папкам и файлам.

  7. Нажмите кнопку ОК.


Для кластера рекомендуется два или более сетевых интерфейса
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-05

Программа настройки Microsoft® Exchange Server 2007 отображает это предупреждение, если текущая среда кластера Microsoft Windows содержит только один назначенный сетевой интерфейс.

Из практики рекомендуется реализовать хотя бы один сетевой интерфейс для общей сети (клиентское подключение) и один сетевой интерфейс для частной сети (администрирование/диагностика), чтобы избежать появления единой точки отказа.

Чтобы устранить причину этого предупреждения, реализуйте для кластера Microsoft Windows по крайней мере один дополнительный сетевой интерфейс.

Дополнительные сведения об оптимальной сетевой конфигурации для кластеров серверов Windows см. в документе «Server Clusters: Network Configuration Best Practices for Windows 2000 and Windows Server 2003» (Кластеры серверов: рекомендации по сетевым конфигурациям для Windows 2000 и Windows Server 2003) (может быть на английском языке) (http://go.microsoft.com/fwlink/?linkid=34304).


Не удается подключиться к службе удаленного реестра
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-01-23

Программа установки Microsoft® Exchange Server 2007 не может продолжить работу, поскольку нет доступа к реестру локального компьютера.

Программе установки Exchange 2007 требуется доступ к локальному реестру для получения различных параметров.

Программа установки Exchange пытается получить полное доменное имя компьютера посредством DNS для доступа к реестру.

Программе установки не удалось получить полное доменное имя посредством DNS из-за ошибки сети или из-за отсутствия доступа к реестру.

Для устранения этой неполадки убедитесь, что служба удаленного реестра запущена на локальном компьютере и что общий доступ к файлам и принтерам включен для первого сетевого адаптера в порядке привязки, затем снова запустите программу установки Exchange.

Чтобы проверить, работает ли служба удаленного реестра, выполните следующие действия.

  1. Нажмите кнопку Пуск, выберите Настройка, Панель управления, Администрирование, затем дважды щелкните Службы.

  2. Убедитесь, что служба Удаленный реестр находится в состоянии Работает.
Чтобы включить общий доступ к файлам и принтерам для первого сетевого адаптера, выполните следующие действия.

  1. Нажмите кнопку Пуск, выберите Настройка, Панель управления, Администрирование, затем дважды щелкните Подключение по локальной сети.

  2. Убедитесь, что установлен флажок Служба доступа к файлам и принтерам сетей Microsoft.
Примечание.
В случае с кластерным сервером убедитесь, что служба удаленного реестра работает на всех узлах кластера, и что Служба доступа к файлам и принтерам сетей Microsoft включена для первого сетевого адаптера в порядке привязки.


Необходимо обновление голосового аудиокодека Windows Media
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-07-13

Невозможно продолжить установку Microsoft® Exchange Server 2007, так как голосовой аудиокодек Microsoft Windows Media не установлен или доступна более новая версия этого кодека.

Для установки Exchange 2007 требуется наличие на сервере самой последней версии голосового аудиокодека Windows Media. Голосовой аудиокодек Windows Media необходим для поддержки роли сервера единой системы обмена сообщениями Exchange Server 2007.

Чтобы устранить эту проблему, установите самую последнюю версию голосового аудиокодека Windows Media с веб-узла http://go.microsoft.com/fwlink/?LinkId=67407 и повторите установку Exchange 2007.


Необходимо обновление кодировщика Windows Media
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-07-13

Программа установки Microsoft® Exchange Server 2007 не может продолжать работу, так как кодировщик Microsoft Windows Media не установлен, или доступна более поздняя версия кодировщика Windows Media.

Для программы установки Exchange 2007 необходимо установить на сервере последнюю версию кодировщика Windows Media. Кодировщик Windows Media необходим для поддержки роли сервера единой системы обмена сообщениями Exchange Server 2007

Чтобы решить эту проблему, установите последнюю версию кодировщика Windows Media с веб-узла http://go.microsoft.com/fwlink/?LinkId=67406 и повторно запустите программу установки Exchange 2007.


Служба публикации в Интернете отключена или отсутствует
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-02-14

Установку Microsoft® Exchange Server 2007 невозможно продолжить, так как при попытке установить роль почтового сервера или клиентского доступа было обнаружено, что служба публикации в Интернете отключена или не установлена на этом компьютере.

Для установки Exchange 2007 требуется, чтобы на компьютере, на котором устанавливается Microsoft Exchange, имелась установленная служба публикации в Интернете, и чтобы она была установлена в состояние, отличное от отключенного.

Чтобы устранить эту проблему, убедитесь, что служба публикации в Интернете установлена и не отключена на локальном компьютере, а затем повторно запустите программу установки Microsoft Exchange.

Чтобы убедиться, что служба публикации в Интернете установлена и не отключена

  1. Щелкните правой кнопкой мыши Мой компьютер и в контекстном меню выберите Управление.

  2. Разверните узел Службы и приложения, а затем щелкните узел Службы.

  3. В правой области найдите Служба публикации в Интернете.

    Если Служба публикации в Интернете не отображается в списке установленных служб, установите ее, выполнив описанные ниже действия.

  4. Если Служба публикации в Интернете отображается, но не запущена, ее нужно запустить, выполнив указанные ниже действия.

  5. Щелкните правой кнопкой мыши Служба публикации в Интернете и в контекстном меню выберите Свойства.

  6. Убедитесь в том, что параметр Тип запуска имеет значение Авто, а служба находится в состоянии Работает.

  7. Нажмите Применить, затем — ОК.
Чтобы установить службу публикации в Интернете

  1. Нажмите кнопку Пуск, выделите пункт Настройка, щелкните пункт Панель управления и дважды щелкните значок Установка и удаление программ.

  2. Щелкните Установка компонентов Windows.

  3. В списке Компоненты установите флажок Сервер приложений и нажмите кнопку Состав.

  4. Выберите Диспетчер служб IIS и нажмите кнопку Состав.

  5. Выберите Служба Интернета, а затем установите флажок.

  6. Два раза нажмите кнопку ОК для возврата к списку Компоненты, а затем нажмите кнопку Далее.

  7. Когда службы IIS будут установлены, нажмите кнопку Готово.


Удаление языковых пакетов единой системы обмена сообщениями
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-16

Не удается продолжить установку Microsoft Exchange Server 2007 из-за сбоя обновления роли сервера единой системы обмена сообщениями.

Для продолжения обновления роли сервера единой системы обмена сообщениями Exchange Server 2007 требуется, чтобы все языковые пакеты роли сервера единой системы обмена сообщениями, за исключением языкового пакета для английского языка (США), были удалены.

Языковые пакеты единой системы обмена сообщениями, входящие в состав Exchange Server 2007, содержат предварительно записанные приглашения и поддерживают преобразование текста в речь для соответствующего языка.

Языковые пакеты Exchange Server 2007 позволяют звонящим и пользователям голосового доступа к Outlook взаимодействовать с единой системой обмена сообщениями на нескольких языках.

Установленные языковые пакеты для языков, отличных от английского, необходимо удалить, чтобы можно было установить новые языковые пакеты.

Чтобы устранить эту проблему, удалите все языковые пакеты для роли сервера единой системы обмена сообщениями, кроме языкового пакета для английского языка (США), а затем повторно запустите программу установки Exchange Server 2007.

Дополнительные сведения об удалении языковых пакетов роли сервера единой системы обмена сообщениями см. в разделе Удаление языкового пакета единой системы обмена сообщениями с сервера единой системы обмена сообщениями документации на Exchange Server 2007 (на английском языке).


Для аварийного восстановления необходимо обновление

Для аварийного восстановления необходимо обновление |
 | См. также
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2007-03-27

Не удается продолжить аварийное восстановление Microsoft Exchange Server 2007, так как для установки сервера Exchange Server на данном компьютере использовалась более поздняя версия Exchange Server 2007.

Для аварийного восстановления Microsoft Exchange требуется, чтобы номер версии Exchange Server 2007, используемой для восстановления Exchange Server, был равен номеру версии Exchange Server, которая использовалась для установки Exchange Server, или превышал его.

Чтобы устранить эту проблему, запустите аварийное восстановление Exchange Server 2007 в версии Exchange Server 2007, равной версии, которая использовалась для установки Exchange Server, или более поздней.

См. также

© 2007 Microsoft Corporation. Все права защищены.


В топологии обнаружен соединитель X.400
Анализатор сервера Microsoft Exchange — статьи > Готовность сервера Exchange Server 2007 >

Дата последнего изменения раздела: 2006-06-05

Средство анализатора Microsoft® Exchange запрашивает службу каталогов Active Directory® на наличие соединителей X.400. Если анализатор сервера Exchange обнаружит в организации Microsoft Exchange соединители X.400, анализатор сервера Exchange выведет на экран предупреждение. Предупреждение, указывает, что соединитель X.400, представляющий собой протокол для транспортировки сообщений между системами обмена сообщениями предыдущих версий, не поддерживается в Microsoft Exchange Server 2007.

В приложениях Microsoft Exchange 2000 Server и Microsoft Exchange Server 2003 в качестве транспортного протокола по умолчанию применяется SMTP (Simple Mail Transfer Protocol). Хотя соединители X.400 поддерживаются в Exchange 2000 и Exchange 2003, они не поддерживаются в Exchange 2007, так по прошествии нескольких лет использование соединителей X.400 существенно уменьшилось. Если поддержка X.400 все еще требуется, рекомендуется сохранить сервер Exchange 2000 или Exchange 2003. В противном случае соединитель X.400 можно заменить SMTP.

Дополнительные сведения о транспортной архитектуре X.400 в Exchange 2003 см. в описании маршрутизации сообщений Exchange Server 2003 (может быть на английском языке) (http://go.microsoft.com/fwlink/?LinkId=65578).

Дополнительные сведения о реализации соединителя X.400 в Exchange 2003 см. в статье, описывающей целесообразность использования соединителя X.400 с приложением Exchange Server 2003 (может быть на английском языке) (http://www.msexchange.org/tutorials/X400-Connector-Exchange-Server-2003.html)

Примечание.
Сведения о веб-узлах сторонних компаний в этом разделе предоставлены для оказания помощи в нахождении необходимой технической информации. URL-адреса могут быть изменены без предварительного уведомления.


Юридические уведомления

Дата последнего изменения раздела: 2007-04-06

Сведения в этом документе, в том числе URL-адреса и другие веб-ссылки, могут быть изменены. Если не оговорено обратное, названия организаций и изделий, доменные имена, адреса электронной почты, эмблемы, а также имена, места и события, используемые в качестве примеров, являются вымышленными и не имеют никакого отношения к реально существующим организациям, изделиям, доменным именам, адресам электронной почты, эмблемам, именам, местам и событиям, а все возможные совпадения являются случайными. Пользователь должен действовать в согласии со всеми применимыми законами об авторских правах. Согласно законам об авторских правах никакие части этого документа нельзя воспроизводить, хранить или использовать в поисковых системах или передавать в любой форме (электронной, механической, в виде фотокопий, записей или иными способами) или для любых целей без письменного разрешения корпорации Майкрософт.

Корпорация Майкрософт может являться правообладателем патентов и заявок, поданных на получение патентов, товарных знаков и объектов авторского права, которые имеют отношение к содержанию данного документа. Предоставление вам данного документа не означает передачи какой-либо лицензии на использование данных патентов, товарных знаков и объектов авторского права, за исключением использования, явно оговоренного в лицензионном соглашении корпорации Майкрософт.

© Корпорация Майкрософт, 2004-2006. Все права защищены.

Microsoft, Active Directory, ActiveSync, ActiveX, MSDN, Outlook, SharePoint, Visual C++, Win32, Windows, Windows NT, Windows Server и Windows Server System являются охраняемыми товарными знаками корпорации Майкрософт в США и других странах.

Названия реальных компаний или продуктов, указанные здесь, могут быть товарными знаками соответствующих владельцев.