Microsoft Exchange Server 最佳实践分析工具概述

主题上次修改时间： 2005-07-08

Microsoft® Exchange Server 最佳实践分析工具是执行下列功能的诊断工具：

  • 从 Microsoft Exchange Server 组织中收集配置信息。

  • 对 Exchange Server 组织执行特定测试。

  • 报告测试所发现的结果。

可以使用 Exchange Server 最佳实践分析工具执行下列任务：

  • 主动验证是否按所建议的最佳实践对配置进行了设置。

  • 报告与默认设置不同的所有设置。

  • 报告 Exchange Server 组织的最近更改。此功能帮助您诊断因 Exchange Server 组织的更改而造成的问题。

  • 帮助您识别处于非正常状况中的 Exchange Server 组织的问题根源。

  • 将一组服务器与基线配置进行比较，并报告配置的所有差异。

注意：
Exchange Server 最佳实践分析工具可以只报告包括"上次修改时间"属性的配置对象的最近更改。

Exchange Server 最佳实践分析工具使用配置文件来确定从 Exchange Server 组织中收集什么信息。它将所收集的数据与一组为 Exchange Server 设置和配置预定义的规则进行比较，然后报告问题。

Exchange Server 最佳实践分析工具为每个问题提供三种数据：

  • 报告在所扫描的 Exchange Server 组织中发现的情况。

  • 提供推荐配置。

  • 提供与问题和相关主题有关的更详细信息的链接。

我们欢迎您对 Exchange Server 最佳实践分析工具提出意见、建议和反馈。可以通过许多方式将反馈发送给我们：

  • Microsoft 公共新闻组 Exchange Server 最佳实践分析工具开发团队的成员经常监视 news.microsoft.com 上的 microsoft.public.exchange.tools 新闻组。有关如何加入此新闻组以及其他 Microsoft 新闻组的详细信息，请访问 Microsoft Exchange Server 最佳实践分析工具网站 (http://go.microsoft.com/fwlink/?LinkId=33938) 和 Microsoft 产品支持新闻组网站 (http://go.microsoft.com/fwlink/?LinkId=50219)。

  • Exchange Server 最佳实践分析工具文档反馈 如果您对 Exchange Server 最佳实践分析工具所附带的任何文档和文章有任何意见、疑问或反馈，请将反馈发送到 exbpadoc@microsoft.com。


安装 Microsoft Exchange Server 最佳实践分析工具

安装 Microsoft Exchange Server 最佳实践分析工具 |
 | 另请参阅
Microsoft Exchange Server 最佳实践分析工具概述 >

主题上次修改时间： 2006-02-08

若要安装 Microsoft® Exchange Server 最佳实践分析工具，请在将要运行此工具的计算机上运行 Microsoft 安装程序文件 ExBPA.msi。安装程序将创建名为 ExBPA 的目录（默认情况下，该目录位于 <system drive>\Program Files\），并将所需文件复制到该新目录。

选择计算机进行安装

建议安装 Exchange Server 最佳实践分析工具的计算机应当是专用的管理站。有关如何安装和使用专用管理站的详细信息，请参阅"Exchange Server 2003 管理指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=98e45481-1458-4809-97d6-50d8aeebd8a1&DisplayLang=zh-cn)。

若要在位于 Exchange 组织以外的计算机上安装此工具，需要明确地设置用于登录到 Active Directory® 目录服务和 Exchange 服务器的用户名和密码。有关如何为用来运行扫描的用户帐户设置凭据的详细信息，请参阅 Microsoft Exchange Server 最佳实践分析工具的权限。

也可以在 Exchange 服务器上安装此工具。该工具可以运行在 Exchange 服务器上；但是，这将消耗大量的系统资源，尤其是 CPU 和 RAM。因此，建议在单独的计算机上安装此工具。如果在 Exchange 服务器上安装此工具，建议您只扫描该 Exchange 服务器。

检查更新

启动 Exchange Server 最佳实践分析工具时，它将确定是否可以从 www.microsoft.com 得到新的最佳实践规则文件。如果有新的版本，则可以下载新文件。必须作为管理员登录到计算机，才能下载文件。如果选择不下载新文件，或工具无法访问 Internet，它将尝试使用运行该工具的计算机上的该文件。

注意：
如果需要进行代理身份验证才能访问 Internet，该工具将无法访问要下载的配置文件的新版本。但是，可以将文件从 www.microsoft.com 手动复制到本地计算机。
手动复制配置文件的新版本

  1. 在安装该工具的目录中，将现有 ExBPA.Config.xml 文件重命名。

  2. 在 Web 浏览器中导航到：http://go.microsoft.com/fwlink/?LinkId=34290。

  3. 下载自解压包，并将新文件解压到工具所安装到的目录（通常为 C:\Program Files\ExBPA）。

另请参阅

概念

Microsoft Exchange Server 最佳实践分析工具对性能的影响
Microsoft Exchange Server 最佳实践分析工具的权限

其他资源

在 Microsoft Exchange Server 最佳实践分析工具中设置扫描

© 2007 Microsoft Corporation.保留所有权利。


运行 Microsoft Exchange Server 最佳实践分析工具的先决条件
Microsoft Exchange Server 最佳实践分析工具概述 >

主题上次修改时间： 2005-07-08

Exchange 组织中的计算机必须满足几个先决条件，才能正确运行 Microsoft® Exchange Server 最佳实践分析工具。如果不满足这些要求，很多情况下此工具仍然会运行，但可能不会以完整功能运行，或者可能运行在性能级别降低的状态下。

这一部分中的主题包括有关运行 Exchange Server 最佳实践分析工具的必需权限的信息，还包括 Exchange 组织和运行此工具的计算机的所有其他先决条件。"其他先决条件"主题还列出了运行此工具的受支持环境。

在此章中

Microsoft Exchange Server 最佳实践分析工具的权限

Microsoft Exchange Server 最佳实践分析工具的其他先决条件


Microsoft Exchange Server 最佳实践分析工具的权限

Microsoft Exchange Server 最佳实践分析工具的权限 |
 | 另请参阅
Microsoft Exchange Server 最佳实践分析工具概述 > 运行 Microsoft Exchange Server 最佳实践分析工具的先决条件 >

主题上次修改时间： 2005-07-08

如果使用拥有所有必需权限的凭据来运行此工具，Microsoft® Exchange Server 最佳实践分析工具只能访问 Active Directory® 目录服务和 Exchange 服务器。

权限

若要成功运行 Exchange Server 最佳实践分析工具，必须有下列权限：

  • Domain Administrator，或 Active Directory 服务器上的 Builtin\Administrators 组的成员，用于在域控制器和全局编录服务器上枚举 Active Directory 信息和调用 Microsoft Windows® Management Instrumentation (WMI) 提供程序。

  • 每个 Exchange 服务器上的 Local Administrators 组的成员，用于调用 WMI 提供程序和访问注册表以及元数据库。

  • 至少是委派的 Exchange 仅查看权限（对 Exchange 组织）。

如果用没有足够权限的帐户登录到将要运行 Exchange Server 最佳实践分析工具的计算机，则有两个选项：

  1. 使用 runas 命令打开一个将运行在有足够权限的帐户下的命令提示窗口，再从该窗口启动此工具。其语法如下：

    runas /netonly /user:<domain>\<username> exbpa.exe

  2. 在工具中的"连接到 Active Directory"页上，设置将要使用的帐户的凭据。单击"显示高级登录选项"展开选项。可以输入两个帐户，一个用来连接到 Active Directory，一个用来连接到 Exchange 服务器。如果不指定这两帐户中的某一个帐户，将使用运行此工具时所使用的帐户。

另请参阅

概念

Microsoft Exchange Server 最佳实践分析工具的其他先决条件

© 2007 Microsoft Corporation.保留所有权利。


Microsoft Exchange Server 最佳实践分析工具的其他先决条件

Microsoft Exchange Server 最佳实践分析工具的其他先决条件 |
 | 另请参阅
Microsoft Exchange Server 最佳实践分析工具概述 > 运行 Microsoft Exchange Server 最佳实践分析工具的先决条件 >

主题上次修改时间： 2007-05-16

为了运行 Microsoft® Exchange Server 最佳实践分析工具，除了需要使用对 Active Directory® 目录服务拥有所需权限的帐户，以及对 Exchange 服务器拥有所需权限的帐户以外，还需要检查其他一些先决条件，才能成功运行该工具。

先决条件

为了正确运行 Exchange Server 最佳实践分析工具，必须符合下列条件：

  • 必须在将要运行 Exchange Server 最佳实践分析工具的计算机上安装 .NET Framework 1.1。

  • 必须将 Internet 信息服务 (IIS) 公用文件安装在将要运行 Exchange Server 最佳实践分析工具的计算机上，以便允许进行远程元数据库访问。

    注意：
    如果安装了 Internet 信息服务、Internet Information Services Admin 或 Exchange 系统管理器，将自动安装 Internet 信息服务公用文件。
  • 将要运行 Exchange Server 最佳实践分析工具的计算机必须有至少 256 MB 随机访问内存 (RAM)。该内存数量足以用于扫描最多 50 个 Exchange 服务器。如果在 Exchange 组织中每添加最多 50 个服务器，则需要在运行该工具的计算机上增加 256 MB RAM。例如，如果组织中的 Exchange 服务器数介于 50 和 100 之间，则运行此工具的计算机上必须至少有 512 MB RAM。如果组织中的 Exchange 服务器数介于 100 和 150 之间，则运行该工具的计算机必须至少有 768 MB RAM。

  • 对于组织中将要扫描的每个 Exchange 服务器来说，在将要运行 Exchange Server 最佳实践分析工具的计算机上，必须至少有 2 MB 的磁盘空间。

  • 在拓扑结构中，必须在 Microsoft Windows® 2000 Server 或 Windows Server™ 2003 上安装 Active Directory。

  • 必须在 Active Directory 中至少安装一个 Exchange 2003 或 Exchange 2000 服务器。

  • 在 Active Directory 服务器和 Exchange 服务器上都必须运行 Remote Registry (RemoteRegistry) 服务。

  • Active Directory 服务器和 Exchange 服务器上都必须运行 Windows Management Instrumentation (WMI) (winmgmt) 服务。

  • 所有使用 Exchange 2000 Server 或更高版本的 Exchange 服务器都必须运行 Exchange Management (MSExchangeMGMT) 服务。

  • 登录和运行 Exchange Server 最佳实践分析工具的用户必须对运行工具时该工具所在的文件夹拥有读取/写入权限。

  • 若要收集主机总线适配器 (HBA) 信息，必须在想要用来收集 HBA 信息的任何服务器上安装符合 HBA API 的驱动程序和远程处理服务（例如，Emulex 的 HBAnywhere 服务）。另外，将要运行 Exchange Server 最佳实践分析工具的计算机和安装 HBA 的目标服务器都必须运行 HBA API 管理对象格式 (MOF) 安装程序。如果不安装符合 HBA API 的驱动程序和远程处理服务，Exchange Server 最佳实践分析工具仍然会运行，但不会收集 HBA 信息。

支持的环境

Exchange Server 最佳实践分析工具可以运行在下列环境中：

  • Windows 2000 Server SP3 和更高版本上的 Exchange Server 5.5

注意：
Exchange Server 5.5 服务器必须作为混合模式的 Exchange 组织的一部分出现在 Active Directory 中。
  • Windows 2000 Server SP3 和更高版本上的 Exchange 2000 Server（所有 Service Pack）

注意：
Windows 2000 Server 和 Exchange 2000 Server 都不能广泛支持各种 WMI 提供程序。数据收集和分析可能是有限的。
  • Windows 2000 Server SP3 和更高版本上的 Exchange 2003 Server（所有 Service Pack）

注意：
Windows 2000 Server 不能广泛支持各种 WMI 提供程序。数据收集和分析可能是有限的。
  • Windows Server 2003 上的 Exchange Server 2003（所有 Service Pack）

  • Windows Server 2003 上的 Exchange Server 2007

另请参阅

概念

Microsoft Exchange Server 最佳实践分析工具的权限

© 2007 Microsoft Corporation.保留所有权利。


用 Microsoft Exchange Server 最佳实践分析工具扫描 Exchange 组织
Microsoft Exchange Server 最佳实践分析工具概述 >

主题上次修改时间： 2005-07-08

Microsoft® Exchange Server 最佳实践分析工具将扫描 Exchange 组织中在所选作用域以内的计算机。它将把配置设置与建议的一组最佳实践进行比较，并报告结果。

在扫描进行当中，进度栏会动态更新，以显示整个扫描完成的百分比。百分比基于为特定类型的扫描收集的数据量，以及扫描作用域内的服务器数。

"估计剩余时间"动态更新，每 60 秒重新计算一次。Exchange Server 最佳实践分析工具是多线程工具，因此，可以同时扫描多台 Exchange 服务器。Exchange Server 最佳实践分析工具可以同时扫描最多 10 个管理组中的计算机，并同时扫描最多 50 个 Exchange 服务器。额外的服务器将排队，并在完成其他扫描后被扫描。

"服务器正在扫描详细信息"窗口会显示每个被选中的待扫描服务器的状态。服务器可以处于三种状态之一："挂起"、"进行中"或"已完成"。如果服务器处于"进行中"状态，则进度栏将显示它的完成百分比。服务器处于"已完成"状态之后，系统将用一个图标来表示 Exchange Server 最佳实践分析工具是否能够访问服务器。绿色选中标记图标说明 Exchange Server 最佳实践分析工具能够访问服务器，并且在扫描期间不会失败或超过超时阈值。黄色警告图标说明 Exchange Server 最佳实践分析工具能够访问服务器，但在扫描期间 Exchange Server 最佳实践分析工具会失败或超过超时阈值。红色 X 图标说明 Exchange Server 最佳实践分析工具不能访问服务器，并且服务器未被扫描。

除了从 Exchange 服务器收集数据以外，Exchange Server 最佳实践分析工具还必须从 Active Directory® 目录服务收集数据。从 Active Directory 收集数据的进度将作为页首的进度栏和"估计剩余时间"的一部分显示，但不显示在"服务器正在扫描详细信息"窗口中。因此，即使所有 Exchange 服务器都处于"挂起"或"已完成"状态，而扫描的总体状态可能仍然是进行中。

Exchange Server 最佳实践分析工具完成对所有所选服务器的扫描之后，您可以打开"查看最佳实践报告"页。

在此章中

在 Microsoft Exchange Server 最佳实践分析工具中设置扫描

Microsoft Exchange Server 最佳实践分析工具的网络和权限检查

配置 Microsoft Exchange Server 最佳实践分析工具


在 Microsoft Exchange Server 最佳实践分析工具中设置扫描

在 Microsoft Exchange Server 最佳实践分析工具中设置扫描 |
 | 另请参阅
Microsoft Exchange Server 最佳实践分析工具概述 > 用 Microsoft Exchange Server 最佳实践分析工具扫描 Exchange 组织 >

主题上次修改时间： 2005-07-08

启动 Microsoft® Exchange Server 最佳实践分析工具时，必须设置扫描的参数。首先，必须选择是否要下载最佳实践规则的最新更新。有关检查更新和下载最新的更新文件的详细信息，请参阅 安装 Microsoft Exchange Server 最佳实践分析工具。

然后，必须选择一项操作。在"欢迎使用"页上，选择"为新扫描选择选项"或"选择要查看的最佳实践报告"。如果选择查看现有报告，则可以从存储在本地的输出文件的列表中选择文件。还可以从另一个位置导入输出文件，而不是选择一个存储在本地的输出文件。选择输出文件之后，可以从该文件查看报告。有关报告的详细信息，请参阅 了解 Microsoft Exchange Server 最佳实践分析工具输出。

如果选择"为新扫描选择选项"，必须连接到 Active Directory® 目录服务并运行新的扫描。默认情况下，Exchange Server 最佳实践分析工具将检测最邻近的 Active Directory 服务器。可以连接到该服务器，也可以通过键入相应服务器的名称连接到其他 Active Directory 服务器。

默认情况下，Exchange Server 最佳实践分析工具使用运行该工具所使用的帐户。若要使用其他帐户登录到 Active Directory 或登录到 Exchange 服务器，请单击"显示高级登录选项"以展开选项。在所展开的窗口的上部分，输入帐户凭据以登录到 Active Directory。在所展开的窗口的下部分，输入帐户凭据以登录到 Exchange 服务器。

可以使用同一帐户登录到 Active Directory 和 Exchange 服务器，也可以使用不同的帐户登录到 Active Directory 和 Exchange 服务器。如果将所展开的窗口的上部分或下部分保留空白，Exchange Server 最佳实践分析工具将使用用来运行 Exchange Server 最佳实践分析工具的帐户进行登录。

另请参阅

概念

安装 Microsoft Exchange Server 最佳实践分析工具
Microsoft Exchange Server 最佳实践分析工具的权限
配置 Microsoft Exchange Server 最佳实践分析工具

其他资源

了解 Microsoft Exchange Server 最佳实践分析工具输出
Microsoft Exchange Server 最佳实践分析工具的网络和权限检查

© 2007 Microsoft Corporation.保留所有权利。


Microsoft Exchange Server 最佳实践分析工具的网络和权限检查

Microsoft Exchange Server 最佳实践分析工具的网络和权限检查 |
 | 另请参阅
Microsoft Exchange Server 最佳实践分析工具概述 > 用 Microsoft Exchange Server 最佳实践分析工具扫描 Exchange 组织 >

主题上次修改时间： 2005-07-08

在开始扫描之前，Microsoft® Exchange Server 最佳实践分析工具将执行网络和权限检查，以确保所指定的帐户凭据是有效的，并且该工具可以连接到 Active Directory® 目录服务。如果这些检查中的任意一项失败，将返回"连接到 Active Directory"页，您可以在该页中重新输入正在运行 Active Directory 的服务器的名称，以及用来登录到 Active Directory 和 Exchange 服务器的凭据。

另请参阅

概念

Microsoft Exchange Server 最佳实践分析工具的权限
配置 Microsoft Exchange Server 最佳实践分析工具

其他资源

在 Microsoft Exchange Server 最佳实践分析工具中设置扫描

© 2007 Microsoft Corporation.保留所有权利。


配置 Microsoft Exchange Server 最佳实践分析工具

配置 Microsoft Exchange Server 最佳实践分析工具 |
 | 另请参阅
Microsoft Exchange Server 最佳实践分析工具概述 > 用 Microsoft Exchange Server 最佳实践分析工具扫描 Exchange 组织 >

主题上次修改时间： 2006-10-10

运行扫描之前，必须执行以下最后步骤：

  1. 设置扫描标签。

  2. 设置作用域。

  3. 设置扫描类型。

  4. 设置网络速度。

指定了扫描的标签、作用域、类型和网络速度之后，Microsoft® Exchange Server 最佳实践分析工具开始进行扫描。

设置扫描标签

要设置扫描标签，请在"启动新的最佳实践扫描"页上的"输入扫描的识别标签"框中，输入一个唯一标签。如果稍后选择查看现有报告，可以通过在"输入扫描的识别标签"框中输入的标签来识别报告。

可以用两种方法查看现有报告：

  • 在"欢迎使用"页上，选择"选择要查看的最佳实践报告"。

  • 在 Exchange Server 最佳实践分析工具窗口的左侧导航窗格中，选择"选择扫描以进行查看"。

设置扫描的作用域

要指定扫描的作用域，请在"启动新的最佳实践扫描"页上选择想要扫描的服务器或管理组。

有三个作用域可供选择：

  • 可以选择整个 Exchange Server 组织。

  • 可以选择一个或多个管理组。

  • 可以从 Exchange Server 组织中的任意管理组选择一台或多台服务器。

选择扫描类型

接下来，选择扫描类型。有三种扫描类型可供选择：

  • 健全检查

  • 健全/性能检查

  • 连接测试

  • 基线

"健全检查"扫描执行完整扫描。它检查是否有错误、警告、非默认配置、最近更改和其他配置信息。如果要检查 Exchange Server 组织的运行状况或对特定问题进行故障排除，应当运行"健全检查"扫描。

"健全/性能检查"扫描在两个小时的时间段内执行"健全检查"扫描，然后继续抽取 Exchange Server 性能计数器的范围的样本。

"连接测试"扫描对作用域中指定的每台 Exchange 服务器执行网络连接测试和权限测试。如果怀疑有权限访问问题，或拓扑结构中有防火墙，应当运行"连接测试"扫描。如果"连接测试"成功，则可以运行"健全检查"扫描。

"连接测试"扫描运行非常快。Exchange Server 最佳实践分析工具查询一个注册表参数和两个 Microsoft Windows® Management Instrumentation (WMI) 类。第一个 WMI 查询验证 WMI 库访问权。第二个 WMI 查询则查询 Exchange Server 所使用的 Active Directory® 目录服务服务器。扫描完作用域中指定的所有 Exchange Server 后，Exchange Server 最佳实践分析工具尝试验证 Exchange Server 所使用的 Active Directory 服务器上的网络连接和权限。

"基线"扫描执行以下任务：

  • 选择属性。

  • 为这些属性设置基线值。

  • 然后选择比较这些属性的服务器。

"基线"扫描检查与您设置的基线值相比是否有偏离。对于所选服务器上其值与所选属性的源值不同的所有属性，"基线"扫描报告将其标识为基线不匹配。

运行基线扫描

  1. 在"启动新的最佳实践扫描"页的"选择要执行的扫描类型"菜单上，选择"基线"，然后单击"基线选项"。

  2. 在"基线选项"菜单上，选择一个现有扫描或键入一个新标签。

  3. 单击"源值"箭头展开基线属性列表。

    • 这些属性是 ExBPA.config.xml 文件收集的属性。通过清除或设置相应复选框选择要在基线扫描中进行比较的属性。属性值都是 ExBPA.config.xml 文件中的默认值。在文本框中设置这些值。

  4. 单击"测试对象"箭头展开要扫描的服务器列表。

  5. 选择希望对其执行扫描以检查是否存在基线不匹配的所有服务器。

设置网络速度

选择了扫描类型之后，可以设置网络速度。若要设置网络速度，请选择四个选项之一：

  • 快速 LAN

  • LAN

  • 快速 WAN

  • WAN

使用网络速度设置可以估计完成扫描所需的时间。也可以使用网络速度设置来设置超时值。

在扫描期间，Exchange Server 最佳实践分析工具将在指定时间内等待从服务器返回的响应。如果在指定的超时时间内没有收到响应，Exchange Server 最佳实践分析工具将继续运行以完成扫描，而不是继续等待。在更慢的网络上，该指定超时时间会更长，以便将更长的网络滞后时间考虑在内。建议您选择拓扑结构中最慢的链接作为该参数的值，以便 Exchange Server 最佳实践分析工具不会太快发生超时。

运行扫描

设置完所有扫描选项后，您可以选择"开始扫描"或"安排扫描"。如果选择"开始扫描"，Exchange Server 最佳实践分析工具将立即开始扫描 Exchange 组织。有关详细信息，请参阅用 Microsoft Exchange Server 最佳实践分析工具扫描 Exchange 组织。

如果选择"安排扫描"，将显示"安排扫描"页。要安排扫描，必须首先输入必要的安全凭据，然后选中"启用扫描安排"框。有关输入必要安全凭据的详细信息，请参阅在 Microsoft Exchange Server 最佳实践分析工具中设置扫描。

接下来，设置开始时间。开始时间是首次运行所安排扫描的日期和时间。

最后，必须设置频率。频率是指隔多长时间运行一次安排的扫描。要关闭 Exchange Server 最佳实践分析工具，请单击"退出该工具"。即使不运行 Exchange Server 最佳实践分析工具也可以运行安排的扫描。如果退出了 Exchange Server 最佳实践分析工具，安排的扫描会按照指定的日期和时间在后台运行。要查看安排的扫描所生成的报告，必须重新启动 Exchange Server 最佳实践分析工具。

另请参阅

概念

输出信息的类型

其他资源

用 Microsoft Exchange Server 最佳实践分析工具扫描 Exchange 组织

© 2007 Microsoft Corporation.保留所有权利。


高级配置
Microsoft Exchange Server 最佳实践分析工具概述 > 用 Microsoft Exchange Server 最佳实践分析工具扫描 Exchange 组织 >

主题上次修改时间： 2006-10-26

Microsoft® Exchange Server 分析工具拥有以下可配置的注册表参数：

位置 | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
值 | OpenRelayTest
类型 | REG_DWORD
描述 | 如果不希望最佳实践分析工具测试每个 SMTP 服务器的开放中继功能，请设置为 0x0。如果参数丢失，则最佳实践分析工具将默认为 0x1。

位置 | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
值 | OpenRelayTestSender
类型 | REG_SZ
描述 | 将此设置为要用于 MAIL FROM 的 SMTP 地址：执行开放中继测试时的地址。如果参数丢失，则最佳实践分析工具将默认为"ExBPA-OpenRelayTest@Fabrikam.com"。

位置 | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
值 | TopoCreateTimeoutSecs
类型 | REG_SZ
描述 | 将此设置为要用于 RCPT TO 的 SMTP 地址：执行开放中继测试时的地址。如果参数丢失，则最佳实践分析工具将默认为"ExBPA-OpenRelayTest@Fabrikam.com"。

位置 | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
值 | SMTPTest
类型 | REG_DWORD
描述 | 如果不希望最佳实践分析工具将测试邮件提交给扫描中包含的每个 SMTP 服务器，请设置为 0x0。如果参数丢失，则最佳实践分析工具将默认为 0x1。

位置 | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
值 | SMTPTestSender
类型 | REG_SZ
描述 | 将此设置为要用于 MAIL FROM 的 SMTP 地址：执行 SMTP 邮件接受测试时的地址。如果参数丢失，则最佳实践分析工具将默认为"ExBPA-MailAcceptTest@Fabrikam.com"。

位置 | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
值 | T SMTPTestRecipient
类型 | REG_SZ
描述 | 将此设置为要用于 RCPT TO 的 SMTP 地址：执行 SMTP 邮件接受测试时的地址。如果参数丢失，则最佳实践分析工具将默认为由 SMTP 服务定义的邮局主管帐户。


了解 Microsoft Exchange Server 最佳实践分析工具输出
Microsoft Exchange Server 最佳实践分析工具概述 >

主题上次修改时间： 2006-02-08

Microsoft® Exchange Server 最佳实践分析工具报告将显示对在扫描 Exchange 组织时收集到的数据进行分析所得到的结果。可以从三种报告中选择：列表报告、树状报告以及其他报告。

  • 列表报告包括：

    • 关键问题

    • 所有问题

    • 非默认设置

    • 最近更改

    • 基线

    • 信息项目

  • 树状报告包括：

    • 详细视图

    • 摘要视图

  • 其他报告

    • 隐藏项目

    • 运行时日志

列表报告

默认视图是关键问题列表。该关键问题列表只显示找到的错误。这些错误是直接影响 Exchange Server 性能和可用性的关键问题。所有问题列表显示错误、警告以及最佳实践中发生的冲突。非默认设置列表显示自 Exchange Server 产品安装以来，对服务器所作的配置更改。最近更改列表显示过去五天中对服务器所作的配置更改，其中包括 Service Pack 的安装以及其他更新。基线列表显示群集中各节点间的配置差异。

树状报告

详细视图显示 Exchange Server 分析工具已收集到的所有配置设置。摘要视图显示 Exchange 环境中找到的所有问题的层次结构表示形式。

其他报告

隐藏项目报告显示 Exchange 管理员选择的、要对其他 Exchange Server 分析工具报告屏蔽的问题。如果选择不隐藏，则该列表中的项目可包含在其他报告中。运行时日志报告显示收集的重要信息和收集过程中返回的所有错误。

在关键问题列表、所有问题列表和非默认设置列表中，单击任何一个错误或警告问题都可看到解释。然后，可以单击"告诉我有关该问题及其解决方法的更多信息"，来获得更详细的信息。

注意：
扫描的输出数据 XML 文件和日志文件位于 <system drive>\Documents and Settings\<user>\Application Data\Microsoft\ExBPA。

在此章中

输出信息的类型

解决和隐藏问题

查看以前的 Microsoft Exchange Server 最佳实践分析工具报告


输出信息的类型

输出信息的类型 |
 | 另请参阅
Microsoft Exchange Server 最佳实践分析工具概述 > 了解 Microsoft Exchange Server 最佳实践分析工具输出 >

主题上次修改时间： 2006-09-29

Microsoft® Exchange Server 最佳实践分析工具报表显示六种信息：

  • 错误

  • 警告

  • 非默认配置

  • 最近更改

  • 基线不匹配

  • 最佳实践

  • 信息

错误

"错误"代表要求进行更改才能解决的关键问题。例如，服务器实例关闭或服务器不可访问即属于错误。

下列报表中会显示错误：

  • 关键问题列表

  • 全部问题列表

  • 详细视图列表

  • 详细视图 — 全部问题列表

如果禁用错误，则 Exchange Server 最佳实践分析工具将在禁用问题列表上显示错误。

Exchange Server 最佳实践分析工具使用红色的 X 代表错误（图 1）。

图 1 错误图标

表示错误状态的图标

警告

"警告"代表不属于所建议的最佳实践的问题。该问题可能要求进行更改才能解决，也可能是 Exchange Server 组织中的已知问题，不要求进行更改。例如，服务在服务器上未启动即属于警告。

下列报表中会显示警告：

  • 全部问题列表

  • 详细视图列表

  • 详细视图 — 全部问题列表

如果禁用警告，Exchange Server 最佳实践分析工具将在禁用问题列表上显示警告。

Exchange Server 最佳实践分析工具使用黄色的警告符号代表警告（图 2）。

图 2 警告图标

警告图标，带感叹号的黄色三角

非默认配置

"非默认配置"代表已从默认值更改为其他值的设置。如果 Exchange Server 最佳实践分析工具确定某个非默认配置属于错误或警告，则除了将其标识为非默认配置之外，还会在报表中的其他位置使用相应的错误符号或警告符号标识该非默认配置。

下列报表中会显示非默认配置：

  • 全部问题列表

  • 详细视图列表

  • 详细视图 — 全部问题列表

如果禁用非默认配置，则 Exchange Server 最佳实践分析工具将在禁用问题列表上显示非默认配置。

Exchange Server 最佳实践分析工具使用文档指针符号代表非默认配置（图 3）。

图 3 非默认配置图标

非默认属性的图标

最近更改

"最近更改"表示在最近 5 天内更改过的设置。Exchange Server 最佳实践分析工具可以只将具有"上次修改时间"属性的设置标识为最近更改。如果 Exchange Server 最佳实践分析工具确定某个最近更改设置属于错误、警告或非默认配置，则除了将其标识为最近更改之外，还会在报表中的其他位置使用相应的错误符号、警告符号或非默认配置符号标识该最近更改。

下列报表中会显示最近更改：

  • 全部问题列表

  • 详细视图列表

  • 详细视图 — 全部问题列表

如果禁用最近更改，则 Exchange Server 最佳实践分析工具将在禁用问题列表上显示最近更改。

Exchange Server 最佳实践分析工具使用铅笔形更改符号代表最近更改（图 4）。

图 4 最近更改图标

表示最近更改的图标

基线不匹配

"基线不匹配"代表值不同于基线服务器上该设置的值的设置。若要查看基线不匹配，必须运行基线扫描。如果 Exchange Server 最佳实践分析工具确定某个基线不匹配属于错误、警告或非默认配置，则除了将该基线不匹配标识为基线不匹配之外，还会使用相应的错误符号、警告符号或非默认配置符号标识该基线不匹配。

下列报表中会显示基线不匹配：

  • 全部问题列表

  • 详细视图列表

  • 详细视图 — 全部问题列表

如果禁用基线不匹配，则 Exchange Server 最佳实践分析工具将在禁用问题列表上显示基线不匹配。

Exchange Server 最佳实践分析工具使用剪贴板和选中标记符号代表基线不匹配（图 5）。

图 5 基线不匹配图标

代表 ExBPA 中基准报告的图标

最佳实践

"最佳实践"消息代表不属于最佳实践的设置。最佳实践消息因为不会影响 Exchange Server 组织的整体稳定性，所以不属于警告。最佳实践消息是建议的操作。如果 Exchange Server 最佳实践分析工具确定某个最佳实践消息属于非默认配置或最近更改，则除了将该最佳实践消息标识为最佳实践消息之外，还会在报表中的其他位置使用相应的非默认配置符号或最近更改符号标识该最佳实践消息。

下列报表中会显示最佳实践消息：

  • 全部问题列表

  • 详细视图列表

  • 详细视图 — 全部问题列表

如果禁用最佳实践消息，则 Exchange Server 最佳实践分析工具将在禁用问题列表上显示最佳实践项目。

Exchange Server 最佳实践分析工具使用蓝色的感叹号代表最佳实践消息（图 6）。

图 6 最佳实践图标

最佳实践警报图标

信息

"信息"消息代表 Exchange Server 最佳实践分析工具在其他五种报表中未提供的信息。例如，信息项目可以传达 Active Directory® 目录服务中的 Exchange Server 对象数的信息。

下列报表中会显示信息消息：

  • 详细视图列表

  • 详细视图 — 全部问题列表

Exchange Server 最佳实践分析工具使用小写字母"i"符号代表信息项目（图 7）。

图 7 信息图标

信息图标

另请参阅

概念

配置 Microsoft Exchange Server 最佳实践分析工具

其他资源

解决和隐藏问题

© 2007 Microsoft Corporation.保留所有权利。


解决和隐藏问题
Microsoft Exchange Server 最佳实践分析工具概述 > 了解 Microsoft Exchange Server 最佳实践分析工具输出 >

主题上次修改时间： 2006-02-08

在 Exchange 组织中运行 Microsoft® Exchange Server 最佳实践分析工具之后，将在报告中列出需要解决的问题。如果单击某个问题，将显示解释和三个选项：

  • 单击第一个选项可以查找有关该问题的更详细信息及其解决方案。

  • 单击第二个选项可以隐藏该服务器的此问题。

  • 单击第三个选项可以隐藏所有服务器的此问题。隐藏问题列表上的问题不会显示在该报告或所查看的任何其他报告的关键问题列表或全部问题列表中。若要查看已隐藏的问题，请转到隐藏问题列表。在隐藏问题列表中，可以取消隐藏问题，使其再次显示在关键问题列表或全部问题列表中。

Exchange Server 最佳实践分析工具不会对 Exchange 组织进行更改以解决问题。它只显示有关如何解决问题的信息。

在此章中

输出信息的类型


查看以前的 Microsoft Exchange Server 最佳实践分析工具报告

查看以前的 Microsoft Exchange Server 最佳实践分析工具报告 |
 | 另请参阅
Microsoft Exchange Server 最佳实践分析工具概述 > 了解 Microsoft Exchange Server 最佳实践分析工具输出 >

主题上次修改时间： 2005-07-08

您可能需要使用 Microsoft® Exchange Server 最佳实践分析工具查看以前的扫描所产生的报告，而不是运行新的扫描。

查看以前的报告

  1. 通过运行 ExBPA.exe 启动 Exchange Server 最佳实践分析工具。

  2. 选择是否要下载最新的规则。

  3. 在"欢迎使用"页上，选择"选择要查看的最佳实践报告"。

  4. 从存储在本地的报告的列表中选择想要查看的报告。

    该工具将从存储在 <systemdrive>\Documents and Settings\<user>\Application Data\Microsoft\ExBPA 的文件创建此列表。单击报告时，该工具将显示有关该报告的大小和作用域的更多信息。单击"查看此报告"可以查看完整的报告。

    还可以通过单击该页右上角的"导入报告"，从另一个位置导入报告。如果 ExBPA.Config.xml 文件的版本与用来收集被导入的报告中的数据的版本不匹配，则此工具可能在执行导入之后重新分析所导入的文件。

  5. 查看 Exchange Server 最佳实践分析工具报告。

另请参阅

其他资源

了解 Microsoft Exchange Server 最佳实践分析工具输出

© 2007 Microsoft Corporation.保留所有权利。


Microsoft Exchange Server 最佳实践分析工具对性能的影响

Microsoft Exchange Server 最佳实践分析工具对性能的影响 |
 | 另请参阅
Microsoft Exchange Server 最佳实践分析工具概述 >

主题上次修改时间： 2005-07-08

Microsoft® Exchange Server 最佳实践分析工具可以影响 Exchange 组织中下列计算机的性能：

  • 正在运行 Exchange Server 最佳实践分析工具的计算机

  • 正在运行 Active Directory® 目录服务的服务器

  • 该工具所访问的 Exchange 服务器

正在运行 Exchange Server 最佳实践分析工具的计算机的性能

Exchange Server 最佳实践分析工具将使用运行该工具的计算机上的下列资源：

  • 对于工具所扫描的每个服务器，使用 5 到 10 MB RAM

  • 在扫描 Exchange 组织期间，使用 50% 到 75% CPU

  • 0.5 到 2 MB 磁盘空间，用于可扩展标记语言 (XML) 数据

有关选择哪个计算机以安装和运行 Exchange Server 最佳实践分析工具的详细信息，请参阅 安装 Microsoft Exchange Server 最佳实践分析工具。

Active Directory 服务器的性能

Exchange Server 最佳实践分析工具将使用 Active Directory 服务器上的下列资源：

  • 在该工具访问 Active Directory 服务器期间，使用 25% 到 50% CPU

注意：
该工具将偶尔访问 Active Directory 服务器，每次访问间隔平均持续 10 到 15 秒。在非常大型的 Exchange 组织中，该间隔将更长。

Exchange 服务器上的性能

在 Exchange Server 最佳实践分析工具扫描组织时，您不会注意到在 Exchange 服务器上性能有任何显著的降低。

注意：
根据 Exchange 服务器上的负载和网络速度，此工具在从 Exchange 服务器收集数据时所用的时间各不相同。在慢速网络上，工具将用一小时或更多时间来收集数据。在快速网络上，工具将用不到十分钟来收集数据。

另请参阅

概念

安装 Microsoft Exchange Server 最佳实践分析工具

© 2007 Microsoft Corporation.保留所有权利。


使用命令行 Microsoft Exchange Server 最佳实践分析工具

使用命令行 Microsoft Exchange Server 最佳实践分析工具 |
 | 另请参阅
Microsoft Exchange Server 最佳实践分析工具概述 >

主题上次修改时间： 2005-07-08

Microsoft® Exchange Server 最佳实践分析工具的命令行程序版本是可用的。该命令行程序的可执行文件是 ExBPACmd.exe，在安装图形用户界面 (GUI) 版本时，该文件被安装于 <systemdrive>\Program Files\ExBPA 目录中。某些情况下，可能需要使用命令行程序而不是 GUI 版本。例如，可以使用命令行程序创建一个脚本，以便运行计划好的扫描。另一个示例是，为了帮助您解决问题，Microsoft 产品支持服务可能指示您运行命令行程序。

ExBPACmd.exe 语法

用法：ExBPACmd.exe [-cfg <config XML>] [-dat <data XML>] [-d <dc name>] [-n <name>] [-u <context> <[domain\]user> <password | *> ...][-rs <scope> <sub1> ...][-rc <cat>,...][-rl <level>] [-th <max threads>] [-to <timeout>] [-a] [-c] [-e] [-?]

-cfg：指定用于确定检索什么设置的配置 XML 文件。默认值是 ExBPA.Config.xml。

-dat：指定要使用的数据 XML 文件。如果所指定的数据 XML 文件名不在当前目录中，该工具将使用指定的文件名作为输出文件的名称。如果指定了现有的数据 XML 文件名，并且正在运行分析扫描，那么，该工具将读取在指定的文件中所收集的数据，然后分析该数据，并用扫描的输出覆盖指定的文件。如果指定了现有的数据 XML 文件名，并且正在运行集合扫描，那么，该工具将用扫描的输出覆盖指定的文件。

如果正在运行分析扫描，则默认值是 output.<ts>.xml，其中 <ts> 是当前目录中最新的时间戳。如果正在运行集合扫描，则默认值是 output.<ts>.xml，其中 <ts> 是新时间戳。

-d：指定用来访问 Active Directory® 目录服务的域控制器。默认情况下，该工具将使用最靠近的 Active Directory 服务器。

-n：为该工具正在扫描其拓扑结构的客户提供描述性名称。

-u：提供每个上下文的单独凭据。

有效用户上下文：ADLOGON 表示登录到 Active Directory 的凭据，或 EXLOGON 表示登录到 Exchange 服务器的凭据。

-rs：将扫描范围限制为只包括在指定作用域内的对象。<sub> 字段是指定的作用域的值。如果不使用 -rs 开关，则扫描将包括整个 Exchange 组织。如果使用 -rs 开关，则可以按管理组或服务器对扫描进行限制。可以指定一个或多个管理组，或一个或多个服务器。

有效作用域：AdminGroup, Server

-rc：将扫描范围限制为只包括与指定的类别匹配的设置和对象。配置 XML 文件定义了设置和对象的类别。如果使用 -rc 开关将扫描范围限制为一个类别，则扫描将只包括已定义该类别的设置。可以用该开关包括多个类别。

可以用 -rc 开关指定的有效类别可能基于不同的配置 XML 文件版本而各不相同。若要确定对于配置 XML 文件版本有效的类别，请运行 ExBPACmd.exe -?。

-rl：将扫描范围限制为只包括指定的详细级别或更少的级别的设置和对象。配置 XML 文件定义了设置和对象的详细级别。默认值是 4。

可以与 -rl 开关一起使用的有效级别可能基于不同的配置 XML 文件版本而各不相同。若要确定对于配置 XML 文件版本有效的级别，请运行 ExBPACmd.exe -?。

-th：设置同时运行的最大线程数。默认值是 25。

-to：设置该工具在从 Exchange 组织中的服务器收集数据时所等待的默认时间（秒）。默认值是 300 秒。

-a：使用配置 XML 文件中的规则来分析数据 XML 文件。可以使用该选项通过指定要使用的数据 XML 文件，来分析作为集合扫描的现有输出文件。还可以使用该选项通过指定不在当前目录中的数据 XML 文件，或通过不指定数据 XML 文件，来收集并分析新扫描的数据。

-c：从配置 XML 文件中所指定的 Exchange 组织收集数据。该工具不使用配置 XML 文件中的规则分析数据，它只收集数据。如果既不指定分析 (-a) 也不指定收集 (-c) 操作步骤，默认情况下将启用该选项。

-e：说明该工具应当删除在配置 XML 文件中被标记为 NotForExport 的任何设置的值。

-? 显示语法信息。

另请参阅

其他资源

用 Microsoft Exchange Server 最佳实践分析工具扫描 Exchange 组织

© 2007 Microsoft Corporation.保留所有权利。


Microsoft Exchange Server 分析工具 - 文章

主题上次修改时间： 2006-10-06

此部分中的文章对应以下 Microsoft® Exchange 分析工具生成的规则和最终消息：

  • Exchange 最佳实践分析工具

  • Exchange 故障排除助理

通过 Exchange 故障排除助理可以访问以下功能：

  • Exchange 性能故障排除程序

  • Exchange 数据库故障排除程序

  • Exchange 数据库恢复管理

  • Exchange 邮件流故障排除程序

每篇文章介绍 Exchange Server 分析工具可能检测到的一个错误、警告或非默认配置消息。

Microsoft Exchange 分析工具网页 ( http://go.microsoft.com/fwlink/?linkid=34707 ) 包含了当前版本的 Exchange 最佳实践分析工具和 Exchange 故障排除助理的下载资源。此外，该页还包含系统要求的相关信息和指向用于分析工具讨论的新闻组的链接。

如果所运行的环境不能使用 Exchange 最佳实践的自动更新功能，可以访问网址为 http://go.microsoft.com/fwlink/?linkid=34290 的"Microsoft Exchange Best Practices Analyzer Web Update Pack"(Microsoft Exchange 最佳实践分析网站更新包)网页。在此处可以下载最近的配置和帮助文件。

注意：
如果可以自动应用更新，则不必使用此下载。


Active Directory
Microsoft Exchange Server 分析工具 - 文章 >

主题上次修改时间： 2005-11-17

此部分中的文章提供了有关 Microsoft® Exchange Server 分析工具就 Active Directory® 软件进行评估的详细信息。此外，这些文章还描述了为解决 Exchange Server 分析工具发现的与 Active Directory 有关的错误、警告和非默认配置所能采取的措施。


Active Directory 连接器服务器停机或不可访问
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具使用远程过程调用 (RPC)，从 Active Directory 连接器 (ADC) 服务器的以下注册表项中读取 CurrentVersion 字符串值：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

在运行 Microsoft Windows® 2000 Server 的计算机上，CurrentVersion 字符串的期望值是 5.0。在运行 Microsoft Windows Server™ 2003 的计算机上，该期望值是 5.2。

如果 Exchange Server 分析工具由于任何原因而无法读取该注册表值，则会显示错误。

更正此错误

  1. 确保 ADC 服务器已启动，并且已连接到网络。

  2. 使用 PING 命令确定 ADC 服务器是否可访问。

  3. 如果有防火墙，请检查以确定 RPC 端口是否被阻止。

  4. 确保 ADC 服务器上的 Remote Registry 服务已启动。

  5. 检查用来运行 Exchange Server 分析工具的帐户的权限，确保它有足够的权限来读取 ADC 服务器上的注册表。

有关解决网络连接问题的详细信息，请参阅下列文章：

  • Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)

  • "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"（英文）(http://go.microsoft.com/fwlink/?LinkId=56285)


Active Directory 连接器服务器没有执行任何连接协议，应当将其删除
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchChildSyncAgreements 属性值，该值代表在 Active Directory 连接器 (ADC) 服务器上执行的连接协议。该属性是一个在以下 Active Directory 对象上设置的多值字符串：CN=Active Directory Connector (ServerName),CN=Exchange Settings,CN=ServerName,CN=Servers,CN=SiteName,CN=Sites,CN=Configuration,DC=Domain,DC=com

Exchange Server 分析工具检索该属性中的条目数（计数）。如果计数结果为 0（说明没有正在运行的连接协议），则会显示警告。

如果确定所有必需的连接协议都正在其他 ADC 服务器上执行，则应当删除或禁用该服务器上的 ADC 服务。在没有任何连接协议的情况下运行 ADC 服务不会有问题。但是，如果服务不是必需的，则建议的最佳做法是不要运行这样的服务。因此，应当禁用 ADC 服务，或从该 ADC 服务器上卸载 ADC 服务。

解决此警告问题

  1. 若要在运行 ADC 服务的服务器上禁用 ADC 服务，请在桌面上用鼠标右键单击"我的电脑"，再单击"管理"。

  2. 展开"服务和应用程序"节点，再单击"服务"节点。

  3. 在右侧窗格中，用鼠标右键单击"Microsoft Active Directory 连接器"，再单击"属性"。

  4. 将"启动类型"更改为"禁用"。计算机下次启动时，将不会启动 ADC 服务。

  5. 单击"应用"，再单击"确定"。

如果决定卸载 ADC 服务，则可以使用 Microsoft Exchange 2000 Server 或 Exchange Server 2003 CD 来执行该操作。转到 \ADC\I386 文件夹，并双击 Setup.exe 程序。执行提示以卸载 ADC 服务。

有关 Active Directory 连接器的详细信息，请参阅下列 Microsoft Support Webcast：

  • "Support Webcast:Introduction to the Active Directory Connector"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325300)

  • "Support Webcast:Microsoft Advanced Active Directory Connector"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325221)

  • 有关安装和配置 Active Directory 连接器的详细信息，请参阅 Microsoft 知识库文章 312632"HOW TO：在 Exchange 2000 Server 中安装和配置 Active Directory 连接器"(http://support.microsoft.com/kb/312632/zh-cn)。


Active Directory 连接器服务器没有运行 Windows 2000 Server 的最新 Service Pack
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具检查 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Active Directory 连接器 (ADC) 服务器上 ServicePackMajorVersion 项的值。Exchange Server 分析工具还检查以下注册表项，以确定正在 ADC 服务器上运行的 Windows 的版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

如果 Exchange Server 分析工具确定 ADC 服务器运行的是 Microsoft Windows 2000 Server 操作系统，但未运行 Windows 2000 Server Service Pack 4 (SP4)，则显示警告。

Microsoft 建议的最佳做法是，对于 Exchange 部署（包括 ADC 服务器）中的所有软件，都要运行它们的最新 Service Pack。

更正此错误

  1. 将该 ADC 服务器以及任何其他运行 Windows 2000 Server 操作系统的服务器更新到 SP4，同时从 Windows Update 安装最新的修补程序和更新。

  2. 将运行 Windows 2000 Server 操作系统的所有其他 Exchange Server 计算机更新到最新的 Service Pack 和更新汇总。

有关获取和安装 Windows 2000 Server 操作系统的 Service Pack 的详细信息，请访问 http://go.microsoft.com/fwlink/?LinkId=18353。

有关获取和安装 Exchange Server Service Pack 和更新汇总的详细信息，请访问 http://go.microsoft.com/fwlink/?LinkId=21573。


Active Directory 连接器服务器可能超载
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchChildSyncAgreements 属性的值。该属性代表运行在 Active Directory 连接器 (ADC) 服务器上的连接协议，它是一个在以下 Active Directory 对象上设置的多值字符串：CN=Active Directory Connector (ServerName),CN=Exchange Settings,CN=ServerName,CN=Servers,CN=SiteName,CN=Sites,CN=Configuration,DC=Domain,DC=com

Exchange Server 分析工具检索该属性中的条目数（计数）。如果计数超过 80，则会显示警告。

建议在每个 ADC 服务器上运行的连接协议的数目小于 80。如果有另外一些 ADC 服务器所承载的连接协议未达到推荐的最大数目，应将某些连接协议从该服务器移至其他 ADC 服务器上。如果没有其他 ADC 服务器，应将 Microsoft Exchange 2000 Server 或 Exchange Server 2003 所包含的 ADC 程序安装在另一台运行 Microsoft Windows® 2000 Server 或 Windows Server™ 2003 的计算机上。

请注意，将连接协议从一个 ADC 服务器移至另一个 ADC 服务器时，该特定连接协议的核心属性不发生改变。例如，用于复制的源容器和目标容器以及已被配置为参与复制的数据保持不变。移动连接协议后，只有运行该连接协议的 ADC 服务器发生改变。

解决此警告问题

  1. 单击"开始"，再单击"程序"，指向"管理工具"，然后单击"Active Directory 连接器管理"打开"ADC 管理"控制台。

  2. MMC 控制台的左侧窗格显示运行 ADC 服务的服务器的列表。选择要移动的连接协议所在的服务器的 ADC。

  3. MMC 控制台的详细信息窗格显示驻留在选定的 ADC 服务器上的连接协议。

  4. 用鼠标右键单击要移动的连接协议，再单击"属性"。

  5. 在"常规"选项卡上的"选择运行连接协议的服务器"下拉列表中，选择要运行此连接协议的服务器，再单击"确定"。

  6. 在"连接用户（Windows 服务器）"下，输入 ADC 服务的帐户名和密码，再单击"确定"。

  7. 在"连接用户（Exchange 服务器）"下，输入 Exchange 服务的帐户和密码，再单击"确定"。

有关移动连接协议的详细信息，请参阅 Microsoft 知识库文章 326060"XADM:How to Move a Connection Agreement to Another Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=326060)。

有关在另一台服务器上安装 Exchange 2000 Server ADC 程序的详细信息，请参阅 Microsoft 知识库文章 312632"HOW TO：在 Exchange 2000 Server 中安装和配置 Active Directory 连接器"()。

有关在另一台服务器上安装 Exchange 2003 ADC 程序的详细信息，请参阅"Exchange 2003 部署指南"()。


需要安装 Active Directory 连接器软件更新
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2006-10-10

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Active Directory 连接器 (ADC) 文件 Adc.exe 的 Version 关键字的值。Version WMI 关键字代表此文件的内部版本号。

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定 Active Directory 中林对象的 msDS-Behavior-Version 属性的值，即 NTDS 设置。该值表明 Active Directory 林的功能级别。msDS-Behavior-Version 属性的有效值如下表中所示。

值 | 林的功能级别
0 | Microsoft Windows 2000 Server 混合模式
1 | Windows Server™ 2003 临时模式
2 | Windows Server 2003 纯模式

如果 Exchange Server 分析工具发现在 Windows Server 2003 临时模式或纯模式的 Active Directory 林中，某台运行 Exchange Server 的计算机上的 Adc.exe 的内部版本号低于 6.0.6615.0，则会显示错误。该错误说明 Exchange 2000 Server 版本的 ADC 程序正在不兼容的 Windows Server 2003 Active Directory 林级别中运行。需要更新 Exchange Active Directory 连接 (ADC) 程序才能解决此问题。

如果在混合模式或纯模式的林功能级别中运行较早版本的 ADC，可能会造成目录更新不完整和数据丢失。建议在组织中的所有计算机上升级到最新 Exchange Server 2003 版本的 ADC。

可以从"Downloads for Exchange 2000 Server"（Exchange 2000 Server 下载）页 (http://go.microsoft.com/fwlink/?LinkId=25097) 下载最新版本的 ADC 以及最新版本的 Exchange Server 2003 Service Pack。还可以从 Exchange Server CD 安装 Exchange Server 2003 最终版本的 ADC。

升级到最新版本的 ADC

  1. 在运行较早版本 ADC 的服务器上，单击"开始"，再单击"运行"，然后键入 E:\setup\adc\i386\setup.exe，其中 E 是 Exchange Server Service Pack 下载文件的位置。

  2. 在"欢迎使用 Active Directory 连接器安装向导"页上，单击"下一步"。

  3. 在"检测到以前曾进行过安装"页上，单击"重新安装"升级 ADC。

  4. 在"完成 Active Directory 连接器安装向导"页上，单击"完成"。

有关林功能级别如何影响 ADC 的详细信息，请参阅 Microsoft 知识库文章 825916"Exchange 2000 Active Directory Connector Does Not Successfully Replicate Changes to Group Membership in Windows Server 2003 Active Directory in Forest Functional Levels 1 or 2"（Exchange 2000 Active Directory 连接器不能成功复制更改成林功能级别 1 或 2 中的 Windows Server 2003 Active Directory 组成员）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=825916)。

有关域和林功能级别的详细信息，请参阅知识库文章 322692"如何在 Windows Server 2003 中提升域和林功能级别"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322692)。


此 Active Directory 目录林已针对驻留的 Exchange 进行配置
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Global-Address-List 架构属性对象的 LinkID 属性的值。Global-Address-List 对象在 Exchange 容器上用于存储新创建的全局地址列表 (GAL) 的可分辨名称。

如果 Exchange Server 分析工具发现 Global-Address-List 对象的 LinkID 属性值已设置为 4048，则 Exchange Server 分析工具将显示非默认配置消息。值为 4048 说明 Active Directory 目录林已针对驻留的 Exchange 环境进行配置。

Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。

有关驻留的 Exchange 环境的详细信息，请参阅下列文章：

  • ""Information for Hosters"（英文）(http://go.microsoft.com/fwlink/?LinkId=46307)

  • "Exchange Server 2000 Resource Kit"中的"Chapter 23 - Hosted Service Environments"（英文）(http://go.microsoft.com/fwlink/?LinkId=46326)


Active Directory 服务器停机或不可访问
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具使用远程过程调用 (RPC)，从 Active Directory® 目录服务器上的以下注册表项中读取 CurrentVersion 字符串值：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

在运行 Microsoft Windows® 2000 Server 的计算机上，CurrentVersion 字符串的期望值是 5.0。在运行 Windows Server™ 2003 的计算机上，该期望值是 5.2。

如果 Exchange Server 分析工具由于任何原因而无法读取该注册表值，则会显示错误。

更正此错误

  1. 确保目录服务器已启动，并且已连接到网络。

  2. 使用 PING 命令确定目录服务器是否可访问。

  3. 如果有防火墙，请检查以确定 RPC 端口是否被阻止。

  4. 确保目录服务器上的 Remote Registry 服务已启动。

  5. 检查用来运行 Exchange Server 分析工具的帐户的权限，确保它有足够的权限来读取 Active Directory 服务器上的注册表。

有关解决网络连接问题的详细信息，请参阅下列文章：

  • Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)

  • "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"（英文）(http://go.microsoft.com/fwlink/?LinkId=56285)


Active Directory 服务器的内存少于 1 GB，但在 Boot.ini 文件中设置了 /3GB 和 /USERVA=3030 开关
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询两个 Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Active Directory® 目录服务器中的物理内存量以及分配给用户模式进程的虚拟地址空间量。下表描述了 Exchange Server 分析工具评估的类和关键字。

类 | 关键字 | 描述
Win32_OperatingSystem | MaxProcessMemorySize | 可以分配给进程的最大内存 KB 数。
Win32_OperatingSystem | OSProductSuite | 添加到操作系统中的已安装和已许可的系统产品。
Win32_ComputerSystem | TotalPhysicalMemory | 安装在计算机中的随机访问内存 (RAM) 的量。

如果 Exchange Server 分析工具确定目录服务器的 RAM 少于 950 MB，并且 MaxProcessMemorySize 的值大于 2097024 但小于 3104640，则会显示警告。

该警告说明没有正确配置目录服务器，以获得最佳内存使用效果，这表现在两个方面：

  • 已设置 /USERVA=3030 启动开关。只有在配备 1 GB 或更多内存并且运行 Microsoft Windows Server™ 2003 操作系统的 Exchange Server 计算机上，该开关才是必需的。

  • 已设置 /3GB 启动开关。此开关应当只用在运行下列任意操作系统并且内存不低于 1 GB 的 Exchange 服务器上：

    • Microsoft Windows Server 2003 标准版

    • Microsoft Windows Server 2003 企业版

    • Microsoft Windows Server 2003 Datacenter 版

    • Microsoft Windows 2000 Advanced Server

    • Microsoft Windows 2000 Datacenter Server

重要信息：
/3GB 开关不应当用在 Windows 2000 Server 上，因为它不被支持，并且可能导致应用程序或操作系统崩溃。此外，只有在安装了 1 GB 或更多物理内存时，上述操作系统才支持 /3GB 开关。

如果在安装了 1 GB 物理内存的系统上遇到该警告，可以说明已在硬件级别为另一个组件（例如，视频卡）分配了该物理内存的一部分，因此使所分配的物理内存对操作系统不可用。在这些情况中，Windows 所使用的已物理安装的内存数量将小于计算机上所安装的实际物理内存数量。如果遇到该情况，应当将 BIOS 所报告的已安装内存数量与 Windows 所报告的已安装内存数量进行比较。

在 Windows Server 2003 上解决此警告问题

  1. 用鼠标右键单击"我的电脑"，然后选择"属性"。将出现"系统属性"对话框。

  2. 单击"高级"。

  3. 在"启动和故障恢复"区域中，单击"设置"。将出现"启动和故障恢复"对话框。

  4. 在"系统启动"区域中，单击"编辑"。这将在记事本中打开 Windows Boot.ini 文件。

  5. 在 [Operating Systems] 部分，从所有启动行中删除以下开关：/3GB /USERVA=3030

  6. 保存更改，关闭记事本。

  7. 单击"确定"两次关闭打开的对话框，并重新启动计算机，以使更改生效。

在 Windows 2000 Server 上解决此警告问题

  1. 在 Windows 资源管理器中，找到系统分区。

  2. 如果看不到 Boot.ini 文件，则可能是由于"文件夹选项"设置为"隐藏受保护的操作系统文件"。如果是这种情况，请在资源管理器中，单击"工具"，再单击"文件夹选项"，然后单击"查看"选项卡。清除"隐藏受保护的操作系统文件（推荐）"复选框。当出现警告对话框时，单击"是"。

  3. 当 Boot.ini 文件显示在资源管理器中后，用鼠标右键单击该文件，再单击"打开方式"，然后单击"记事本"打开该文件。

  4. 在 [Operating Systems] 部分，从所有启动行中删除以下开关：/3GB /USERVA=3030

  5. 保存更改，关闭记事本。

  6. 重新启动计算机，以使更改生效。

有关如何使用 /3GB 和 /USERVA 启动开关的详细信息，请参阅下列 Microsoft 知识库文章：

  • 308356"基于 Windows 2000 Server 的域控制器上的 Lsass.exe 进程的内存使用量"(http://support.microsoft.com/?kbid=308356)

  • 297812"How to Use the 4GT RAM Tuning Feature"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901"The effects of 4GT tuning on system Page Table Entries"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739"如何使用 Boot.ini 文件中的 /USERVA 开关优化 /3GB 配置"(http://support.microsoft.com/?kbid=316739)

  • 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://support.microsoft.com/kb/325044/zh-cn)

  • 815372"如何在 Exchange Server 2003 中优化内存使用"(http://support.microsoft.com/kb/815372/zh-cn)


Active Directory 服务器的内存少于 1 GB，但在 Boot.ini 文件中设置了 /3GB 开关
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询两个 Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Active Directory® 目录服务器中的物理内存量以及分配给用户模式进程的虚拟地址空间量。下表描述了 Exchange Server 分析工具所评估的类和关键字。

类 | 关键字 | 描述
Win32_OperatingSystem | MaxProcessMemorySize | 可以分配给进程的最大内存 KB 数。
Win32_OperatingSystem | OSProductSuite | 操作系统的已安装和已授权的系统产品。
Win32_ComputerSystem | TotalPhysicalMemory | 安装在计算机中的随机访问内存 (RAM) 字节数。

如果 Exchange Server 分析工具确定目录服务器的 RAM 少于 950 MB，并且 MaxProcessMemorySize 的值大于 2097024 但小于 3104640，则会显示警告。

该警告说明没有将目录服务器正确地配置为可获得最佳内存使用效果。该计算机上已设置 /3GB 启动开关，应当删除该开关。此开关应当只用在运行下列任意操作系统并且内存不低于 1 GB 的 Active Directory 服务器上：

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server™ 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

重要信息：
/3GB 开关不应当用在 Windows 2000 Server 上，因为它不被支持，并且可能导致应用程序或操作系统崩溃。此外，只有在安装了 1 GB 或更多物理内存时，上述操作系统才支持 /3GB 开关。

如果在安装了 1 GB 物理内存的系统上遇到该警告，可以说明已在硬件级别为另一个组件（例如，视频卡）分配了该物理内存的一部分，因此使所分配的物理内存对操作系统不可用。在这些情况中，Windows 所使用的已物理安装的内存数量将小于计算机上所安装的实际物理内存数量。如果遇到该情况，应当将 BIOS 所报告的已安装内存数量与 Windows 所报告的已安装内存数量进行比较。

在 Windows Server 2003 上解决此警告问题

  1. 用鼠标右键单击"我的电脑"，再单击"属性"。将出现"系统属性"对话框。

  2. 单击"高级"。

  3. 在"启动和故障恢复"区域中，单击"设置"。将出现"启动和故障恢复"对话框。

  4. 在"系统启动"区域中，单击"编辑"。这将在记事本中打开 Windows Boot.ini 文件。

  5. 在 [Operating Systems] 部分中，从所有启动行中删除以下开关：/3GB

  6. 保存更改，关闭记事本。

  7. 单击"确定"两次关闭打开的对话框，再重新启动计算机，以使更改生效。

在 Windows 2000 Server 上解决此警告问题

  1. 在 Windows 资源管理器中，导航至系统分区。

  2. 如果看不到 Boot.ini 文件，则可能是由于"文件夹选项"设置为"隐藏受保护的操作系统文件"。如果是这种情况，请在资源管理器中，单击"工具"，再单击"文件夹选项"，然后单击"查看"。清除"隐藏受保护的操作系统文件（推荐）"复选框。当出现警告对话框时，单击"是"。

  3. 当 boot.ini 文件显示在资源管理器中后，用鼠标右键单击该文件，再单击"打开方式"，然后选择"记事本"打开该文件。

  4. 在 [Operating Systems] 部分中，从所有启动行中删除以下开关：/3GB

  5. 保存更改，关闭记事本。

  6. 重新启动计算机，以使更改生效。

有关使用 /3GB 启动开关的详细信息，请参阅下列 Microsoft 知识库文章：

  • 308356"基于 Windows 2000 Server 的域控制器上的 Lsass.exe 进程的内存使用量"(http://support.microsoft.com/?kbid=308356)

  • 297812"How to Use the 4GT RAM Tuning Feature"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901"The effects of 4GT tuning on system Page Table Entries"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739"如何使用 Boot.ini 文件中的 /USERVA 开关优化 /3GB 配置"(http://support.microsoft.com/kb/316739/zh-cn)

  • 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://support.microsoft.com/kb/325044/zh-cn)

  • 815372"如何在 Exchange Server 2003 中优化内存使用"(http://support.microsoft.com/kb/815372/zh-cn)


Active Directory 服务器正在运行 Windows 2000 Server 并设置了 /3GB 开关
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定分配给用户模式进程的虚拟地址空间量 (MaxProcessMemorySize)，并确定 Active Directory® 目录服务服务器上运行的 Windows 的版本 (OSProductSuite)。下表描述了 Exchange Server 分析工具所评估的类和关键字。

如果 Exchange Server 分析工具确定 MaxProcessMemorySize 的值为 3104640，并且 OSProductSuite 的值解析为 Windows 2000 Server，则显示错误。

该错误说明在运行 Microsoft Windows 2000 Server 的目录服务器上的 Boot.ini 文件中设置了 /3GB 启动开关。该开关在 Windows 2000 Server 上不受支持，并且应当只用在有 1 GB 或更多内存并运行下列任一操作系统的计算机上：

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

从 Boot.ini 文件中删除 /3GB 开关

  1. 在 Windows 资源管理器中，导航至系统分区。

  2. 如果看不到 Boot.ini 文件，可能是由于"文件夹选项"设置为"隐藏受保护的操作系统文件"。如果是这种情况，请在资源管理器中，单击"工具"，再单击"文件夹选项"，然后单击"查看"选项卡。清除"隐藏受保护的操作系统文件（推荐）"复选框。当出现警告对话框时，单击"是"。

  3. 当 Boot.ini 文件显示在资源管理器中后，用鼠标右键单击该文件，再单击"打开方式"，然后选择"记事本"打开该文件。

  4. 在 [Operating Systems] 部分中，从所有启动行中删除下列开关：/3GB /USERVA=3030

  5. 保存更改，关闭记事本。

  6. 重新启动目录服务器，以使更改生效。

有关使用 /3GB 启动开关的详细信息，请参阅下列 Microsoft 知识库文章：

  • 297812"How to Use the 4GT RAM Tuning Feature"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901"The effects of 4GT tuning on system Page Table Entries"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739"如何使用 Boot.ini 文件中的 /USERVA 开关优化 /3GB 配置"(http://support.microsoft.com/?kbid=316739)

  • 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372"如何在 Exchange Server 2003 中优化内存使用"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


无法访问 Active Directory 服务器注册表
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具在每个域控制器上读取以下注册表项：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion\CurrentVersion

如果 Exchange Server 分析工具由于任何原因而无法读取该注册表值，Exchange Server 分析工具将显示错误。

更正此错误

  1. 确保域控制器已启动，并且已连接到网络。

  2. 使用 PING 命令确定域控制器是否可访问。

  3. 如果有防火墙，请检查以确定 RPC 端口是否被阻止。

  4. 确保域控制器上的 Remote Registry 服务已启动。

  5. 检查用来运行 Exchange Server 分析工具的帐户的权限。用来运行 Exchange Server 分析工具的帐户在每个所扫描的域控制器上必须具有管理员权限。

有关解决网络连接问题的详细信息，请参阅下列文章：

  • Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)

  • "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"（英文）(http://go.microsoft.com/fwlink/?LinkId=56285)

有关端口要求的详细信息，请参阅知识库文章"Windows 服务器系统的端口要求"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)。


Active Directory 服务器软件更新可用
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2007-02-20

Microsoft Exchange 分析工具查询 ROOT\MicrosoftExchangeV2 命名空间中的 Exchange_DSAccessDC Microsoft Windows Management Instrumentation (WMI) 类，以确定 Name 属性的值。Name 属性指定 Exchange 服务器用于 Active Directory 目录服务查找的域控制器的计算机名称。

然后，Exchange 分析工具向 Active Directory 查询该域控制器的特定属性的值，以确定下列情况：

  • Active Directory 域控制器是否正在运行 Windows Server 2003 操作系统

  • Active Directory 域控制器是否正在运行非英文版的 Microsoft Windows Server 2003 操作系统

  • Exchange 组织中是否有 Microsoft Exchange Server 2007 服务器

  • 服务器上 ntdsa.dll 文件的 Version 关键字的值是否小于 2700

如果 Exchange 分析工具发现上述所有条件均为真，Exchange 分析工具将显示警告。

此警告表明 Exchange Outlook Web Access 客户端可能遇到 Exchange 通讯簿索引问题。

Outlook Web Access 允许用户选择希望使用的用户界面 (UI) 语言。用户选择的语言将确定区域设置。Outlook Web Access 还使用该语言对 Active Directory 结果（例如通讯簿）进行排序。如果 Exchange 运行虚拟列表视图 (VLV) 查询并且指定的语言在域控制器上不可用，则会出现错误。发生此问题的原因在于：如果为 VLV 查询指定的语言与域控制器的语言不匹配，当前没有任何默认的索引机制使 Exchange 可以使用其他语言。

若要解决此警告指明的问题，请获取并安装 Microsoft 知识库文章 919166"Exchange OWA 客户端与基于 Windows Server 2003 的域控制器的区域设置不同时，会破坏 Exchange 2007 中的通讯簿功能"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=919166) 提到的文件更新。


无法访问 Active Directory 服务器 WMI
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定是否为域控制器设置了 Name 关键字的值。如果 WMI 查询失败，Exchange Server 分析工具将显示错误。

此错误可能有两种原因：

  • 运行 Exchange Server 分析工具的帐户没有足够的权限，无法查询 WMI 信息

  • 网络问题使 Exchange Server 分析工具无法与计算机联系。

更正此错误

  1. 确保 Exchange Server 计算机已启动并连接到了网络。

  2. 使用 PING 命令确定 Exchange Server 计算机是否可访问。

  3. 如果有防火墙，请检查以确定 RPC 端口是否被阻止。

  4. 检查用来运行 Exchange Server 分析工具的帐户的权限。用来运行 Exchange Server 分析工具的帐户在每个所扫描的 Exchange Server 计算机上必须具有本地管理员权限。

    也可以为用来运行 Exchange Server 分析工具的帐户授予特定的 WMI 权限。

    1. 在 Exchange 计算机上，打开"计算机管理"MMC 控制台树。

    2. 在"服务和应用程序"下，用鼠标右键单击"WMI 控件"，再单击"属性"。

    3. 在"WMI 控件属性"页上，单击"安全性"选项卡，再展开"根"。

    4. 选择 CIMV2 文件夹，再单击"安全性"。

    5. 在"ROOT\CIMV2 安全性"页上，添加用来运行 Exchange Server 分析工具的帐户。

    6. 选择在步骤 e 中所添加的帐户；在"所选帐户权限"中的"允许"列下，选中"远程启用"和"读取安全性"，再单击"确定"。

有关解决网络连接问题的详细信息，请参阅下列文章：

  • Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)

  • "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"（英文）(http://go.microsoft.com/fwlink/?LinkId=56285)

有关端口要求的详细信息，请参阅知识库文章"Windows 服务器系统的端口要求"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)。


检测到 ADCDisabledMail 属性
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Exchange 组织处于混合模式还是纯模式。如果发现 Exchange 组织处于纯模式，Exchange Server 分析工具将查询 Active Directory，以确定组织的域中任何启用了邮件的对象是否将 legacyExchangeDN 属性的值设置为 ADCDisabledMail。如果发现了 legacyExchangeDN 属性值设置为 ADCDisabledMail 的启用邮件的对象，将显示警告，列出相应对象及其域。

在删除邮箱时，Exchange 2000 Server 和 Exchange Server 2003 环境中均可能发生此问题。在删除邮箱时，帐户的 legacyExchangeDN 属性的值标记为 ADCDisabledMail。关联的对象在 Active Directory 中禁用了邮件时，此值用于指示 Active Directory 连接器 (ADC) 将对象从 Exchange Server 5.5 目录服务中删除。如果大型通讯组中包含多个已删除的邮箱，邮件将延迟，同时，在 Active Directory 中搜索 ADCDisabledMail 唯一的 legacyExchangeDN 属性值。因为多个邮箱可能具有此相同的 legacyExchangeDN attribute value，搜索可能需要很长时间。因此造成邮件的延迟。如果通讯组在 Microsoft Office Outlook® 2003 客户端的邮件"收件人：/抄送：/密件抄送："行中展开，也将发生邮件延迟。

解决方案是删除对象或使用 Active Directory 服务接口 (ADSI) Edit 工具、ldp.exe 工具或另一个轻型目录访问协议 (LDAP) 版本 3 客户端删除 legacyExchangeDn 属性的内容。如果 legacyExchangeDN 属性值设置为 NULL，对 Active Directory 的搜索将设置为"/O=NT5/ou=<域的对象 GUID>/cn=<用户的对象 GUID>"，未送达报告 (NDR) 的生成速度将快得多。

警告：
在使用 ADSI Edit、LDP 工具或其他 LDAP 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。
删除 legacyExchangeDN 属性的 ADCDisabledMail 值

  1. 从 Windows 2000 支持工具或 Windows Server 2003 支持工具启动 ADSI Edit 工具。

  2. 展开下列节点：

    • Domain Container

    • DC=域名

    • Users Container

  3. 用鼠标右键单击用户名，再单击 Properties。

  4. 单击 Attributes 列表中的 legacyExchangeDN，再单击 Edit。

  5. 选择原始值，再单击 Clear，可以删除包含 ADCDisabledMail 的原始 legacyExchangeDN 值。

  6. 单击 OK 两次以应用更改。

有关如何使用 ADSI Edit 的详细信息，请参阅 Windows Server 联机帮助中的"Adsiedit.msc: ADSI Edit"主题。

有关 LDP 工具的详细信息，请参阅 Microsoft 知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。


地址列表筛选器设置可能会使新收件人无法在地址列表中显示
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定为每个 Address List 对象的 purportedSearch 属性设置的属性。如果 Exchange Server 分析工具发现 purportedSearch 属性包含字符串"proxyAddresses=*"，则显示错误。

创建了新用户对象之后，收件人更新服务为代理地址等收件人对象指定特定的属性。但是，收件人更新服务可能无法指定 ShowInAddressBook 属性。收件人对象的 ShowInAddressBook 属性表明收件人所属的地址列表。未指定此属性的收件人对象不会显示在全局地址列表或任何其他地址列表中，即使对象符合地址列表筛选器的标准。

如果一个或多个地址列表筛选器中包含 proxyAddresses 属性，则可能发生这种情况。可以通过查看每个 Address List 的属性并在"筛选规则"框中查找"proxyAddresses=*"，确定是否发生这种情况。

通过执行下列步骤，使收件人更新服务可以正确地为收件人对象指定属性，以便可以显示在全局地址列表或任何其他地址列表中。

警告：
在使用 ADSI（Active Directory 服务接口）Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。
更正此错误

  1. 打开 Exchange 系统管理器。

  2. 展开"收件人"，再展开"所有全局地址列表"，然后选择"收件人策略"。

  3. 在右侧窗格中，用鼠标右键单击要编辑的地址列表，再选择"属性"。

  4. 在"属性"页的"常规"选项卡上，在"筛选规则"下单击"修改"。

  5. 在"查找 Exchange 收件人"下拉菜单中，选择"自定义搜索"。如果地址列表原来是通过自定义搜索创建，则在步骤 3 中单击"修改"之后，将显示"查找自定义搜索"页。

  6. 在标准列表中选择"代理地址为(准确)*"条目，再单击"删除"。

  7. 单击"确定"关闭对话框。

  8. 用鼠标右键单击收件人策略，再单击"立即应用此策略"。

有关收件人更新服务的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328738"XADM:How the Recipient Update Service Applies Recipient Policies"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328738)

  • 319065"HOW TO: Work with the Exchange Recipient Update Service"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319065)


管理组模式未知
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以通过检查 Active Directory 中 Administrative Groups 容器内的管理组对象的 msExchAdminGroupMode 属性来验证管理组的模式。如果 Exchange Server 分析工具发现 msExchAdminGroupMode 属性值不等于 0、1 或 2，则显示错误。

Exchange 使用管理组模式来说明管理组是否可以包括 Exchange Server 5.5 服务器或 Exchange Server 2003 服务器（或 Exchange 2000 Server 服务器）。如果该属性的值不是 0、1 或 2，则很可能管理员已手动更改了它的值。Exchange 安装程序或 Exchange 系统管理器不会错误地设置该值。

必须使用 Active Directory 服务接口 (ADSI) Edit 管理单元、LDP (ldp.exe) 工具或其他任何轻型目录访问协议 (LDAP) 版本 3 客户端等工具来更正该值。

警告：
在使用 ADSI Edit、LDP 工具或其他 LDAP 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

修改 MSExchAdminGroupMode 属性

  1. 使用 Active Directory 编辑器（例如，ADSI Edit）找到 Active Directory 中的管理组对象。

    MSExchAdminGroupMode 属性位于：

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=Organization, CN=Administrative Groups, CN=Administrative group

  2. 键入下列整数值之一：

    0=纯模式（管理组是使用 Exchange 2000 Server 或 Exchange Server 2003 创建的）

    1=Exchange Server 5.5 模式（管理组是使用 Exchange Server 5.5 创建的，并且只包括 Exchange Server 5.5 服务器）

    2=混合模式（管理组可能同时包括 Exchange Server 5.5 服务器和 Exchange 2000 Server 或 Exchange Server 2003 服务器）

有关使用 LDP 工具的详细信息，请参阅 Microsoft 知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

有关使用 ADSI Edit 的详细信息，请参阅 Windows Server 联机帮助中的主题"Adsiedit.msc:ADSI Edit"。


驻留的 Exchange 的 Authenticated Users 配置不正确
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Exchange Server 环境是否配置为驻留的 Exchange 环境。如果 Exchange Server 环境为驻留的 Exchange 环境，Exchange Server 分析工具将查询 Active Directory，以确定 Authenticated Users 组是否属于域中的 Pre-Windows® 2000 Compatible Access 组。

如果 Authenticated Users 组是 Pre-Windows 2000 Compatible Access 组的成员，Exchange Server 分析工具将显示警告。此配置不是驻留的 Exchange 解决方案的建议配置。

若要解决此警告问题，请将 Authenticated Users 从 Pre-Windows 2000 Compatible Access 安全组中删除

  1. 打开"Active Directory 用户和计算机"。

  2. 展开域节点，再单击 Builtin 容器。

  3. 用鼠标右键单击 Pre-Windows 2000 Compatible Access 安全组，再选择"属性"。

  4. 单击"成员"选项卡。

  5. 选择"通过身份验证的用户"。

  6. 单击"删除"。

  7. 单击"确定"。

有关驻留的 Exchange 环境的详细信息，请参阅下列文章：

  • ""Information for Hosters"（英文）(http://go.microsoft.com/fwlink/?LinkId=46307)

  • "Exchange Server 2000 Resource Kit"中的"Chapter 23 - Hosted Service Environments"（英文）(http://go.microsoft.com/fwlink/?LinkId=46326)


证书主体不匹配
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2007-01-09

Microsoft® Exchange Server 分析工具在 Exchange 服务器系统中查询 Server Certificate 对象，以检索 X509 证书的各种属性。对于每个已找到的安全套接字层 (SSL) 证书，Exchange Server 分析工具会对其 Principal 属性进行评估，以识别分配给该证书的完全限定域名 (FQDN)，如 www.microsoft.com。

Principal 完全限定域名 (FDQN) 与主机地址或 URL 不匹配时，Microsoft Exchange Server 分析工具将发出警告。证书主体不匹配警告表示，用户可能无法使用 Microsoft Office Outlook® Web Access for Exchange Server 2003、Outlook Anywhere for Exchange Server 2007、Exchange Server ActiveSync 和 RPC over HTTP 连接到其邮箱。

注意：
一台服务器必须拥有一个服务器证书，才能运行 SSL 协议。作为选择，服务器还可以请求客户端证书。服务器证书包含该网站名称。浏览器会验证该网站名称是否与输入的名称相同。例如，如果网站为 https://www.example.com，则该证书的名称应该为 www.example.com。

如果以下任一条件为真，则会发生不匹配。

  • 无意中将该证书应用到错误的服务器

  • 服务器拥有多个主机名时，客户端通过错误的主机 URL 访问服务器中的数据

解决证书名称不匹配

  • 验证是否已将此 SSL 证书授权并应用到正确的主机。

详细信息

  • 有关如何在 Exchange Server 2003 的虚拟服务器中使用证书的详细信息，请参阅 Microsoft 知识库文章 823024"如何在 Exchange Server 2003 的虚拟服务器中使用证书"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823024)。

  • 有关如何使用 SSL 以及如何获得并安装服务器证书的信息，请参阅 Exchange Server 2003 Client Access Guide (http://go.microsoft.com/fwlink/?LinkId=47568) 中的"Configuring Exchange Server 2003 for Client Access"（英文）。

  • 有关如何使用 SSL 以及如何为 Exchange Server 2007 获取并安装服务器证书的信息，请参阅"How to Configure SSL for Outlook Anywhere"（如何为 Outlook Anywhere 配置 SSL）(http://go.microsoft.com/fwlink/?LinkId=80875)。


连接协议激活日程安排已设置为"从不"
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个连接协议对象的 activationStyle 属性的值。activationStyle 属性表示连接协议的日程安排设置。如果日程安排设置为"从不"，将显示警告。

如果确定不再需要此连接协议，应将它删除。如果需要此连接协议，应将它配置为按适当的日程运行。

解决此警告问题

  1. 依次单击"开始"、"程序"、"管理工具"、"Active Directory 连接器"。

  2. 在左侧窗格中，单击要修改的连接协议所在的 Active Directory 连接器 (ADC) 服务器。

  3. 在右侧窗格中，用鼠标右键单击要修改的连接策略，再单击"属性"。

  4. 单击"日程安排"选项卡。

  5. 将日程安排设置为"始终"或"选定时间"。如果选择后者，请单击网格中的相应区域以使连接协议在这些时间运行。

有关配置双向收件人连接协议的详细信息，请参阅 Microsoft 知识库文章 296260"XGEN: How to Configure a Two-Way Recipient Connection Agreement for Exchange 5.5 Users"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=296260)。


连接协议已被孤立
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个连接协议的 msExchHomeSyncService 值是否有效。如果 Exchange Server 分析工具发现连接协议的此属性值无效，将显示警告。

msExchHomeSyncService 属性包含连接协议所在的 Active Directory 连接器 (ADC) 服务器。

如果在删除 ADC 服务器之前没有先删除 ADC 或删除 ADC 服务器上的连接协议，可以看到此警告。在删除 ADC 服务器时，连接协议与 ADC 服务器之间的连接将断开。因此，这些连接协议所负责的对象将不再复制。如果使用另一个 ADC 服务器上的"ADC 管理器"管理单元，则已删除的 ADC 服务器上的连接协议将不再显示。但是，这些连接协议在 Active Directory 中仍存在。

解决此问题的方法是，将旧的连接协议与新的 ADC 服务器重新关联。重新关联的一种方式是在新的 ADC 服务器上创建新的连接协议，然后将 msExchHomeSyncService 属性从新的连接协议复制并粘贴到旧的连接协议中。

将连接协议与 ADC 服务器重新关联

  1. 启动"ADC 管理器"管理单元。

  2. 创建新的连接协议。

  3. 启动 Active Directory 服务接口 (ADSI) Edit。

  4. 依次展开"配置"、"服务"和 Microsoft Exchange，然后单击 Active Directory Connections。

  5. 在右侧窗格中，打开刚创建的连接协议的属性。

  6. 在"选择一个要查看的属性"下拉列表中，单击 msExchHomeSyncService。

  7. 复制 Value(s) 框中的整个属性，然后单击 OK。

  8. 打开必须重新关联的连接协议的属性。

  9. 单击"选择一个要查看的属性"下拉列表，然后单击 msExchHomeSyncService 属性。

  10. 将复制的值粘贴到"编辑属性"框中。

  11. 单击"设置"，再单击"应用"，然后单击"确定"。

有关孤立的连接协议的详细信息，请参阅 Microsoft 知识库文章 319486"XADM:Connection Agreements Disappear After You Remove Active Directory Connector"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=319486)。


默认显示名已修改
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 displaySpecifier 类中对象的 createDialog 属性值。具有 displaySpecifier 类的对象描述了要与 Active Directory 中的对象一起使用的上下文菜单和属性页。如果 Exchange Server 分析工具确定已设置 createDialog 属性，则显示非默认配置消息。

在 Active Directory 中创建新的用户或联系人对象时，总是会以"名姓"的格式生成全名字段。然后，该字段将在创建时设置显示名字段，因此，您最终将得到"名姓"格式的全局地址列表。

如果您愿意，可以使用 Active Directory 编辑器（例如，Active Directory 服务接口 (ADSI) Edit）来修改显示名字段的建立方式。ADSI Edit 不仅可以更改该字段的建立方式，而且能更改全名字段；因此，在 Active Directory 用户和计算机中查看用户时，用户将以您选择的格式出现。

警告：
在使用 ADSI Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

在进行这些更改之前，应当知道它们可能产生负面效果。有关该更改的潜在后果的详细信息，请参阅 Microsoft 知识库文章 276266"Group Changes for Users with LDAP-Restricted Characters"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=276266)。

更改用户和联系人对象的默认显示格式

  1. 打开 Active Directory 编辑器，例如 ADSI Edit。

  2. 用鼠标右键单击顶级节点，再单击 Connect to。

  3. 将命名上下文更改为 Configuration Container，再单击 OK 以便进行绑定和身份验证。

  4. 展开 Configuration Container 节点，再展开 Configuration 节点。

  5. 展开 cn=DisplaySpecifiers 节点，再双击 CN=409。注意：409 是美国英语的区域设置 ID。如果您处在多语言环境中，可能需要更改为其他代码。

  6. 在右侧窗格中，打开 CN=user-Display 的属性。

  7. 滚动到 createDialog 可选属性。

  8. 将属性设置为 %<sn>.%<givenName> 再单击 Set。注意：注意：只能格式化令牌 %<sn>、%<givenName> 和 %<initials>。

  9. 单击 OK 关闭该对话框。

  10. 在 Active Directory 中创建新的用户，以验证能按预期建立全名和显示名。注意：在多域环境中，可能需要先等待复制完成，之后 Active Directory 用户和计算机工具才能反映出您的更改。

上述步骤将导致显示名以"姓.名"格式出现。此外，上述过程是针对用户对象的。对于联系人对象，请将步骤 6 更改为 contact-Display。

有关如何使用 ADSI 脚本来执行该任务的详细信息，请参阅 Microsoft 知识库文章 277717"如何使用 Active Directory 服务接口脚本更改 Active Directory 用户的显示名称"(http://support.microsoft.com/kb/277717/zh-cn)。

代码页是由国际电信联合会 (ITU) 和国际标准化组织 (ISO) 定义的。有关详细信息，请访问下列 ITU 和 ISO 网页：

  • http://www.itu.int

  • http://www.iso.ch/iso/en/ISOOnline.openerpage

    注意：
    Web 地址可能会改变，所以，也许无法连接到此处提到的网站。

有关支持本地化的 Exchange 客户端的其他信息，请参阅 Microsoft 知识库文章 150977"XADM：支持本地化的 Exchange 客户端"(http://support.microsoft.com/kb/150977/zh-cn)。


对邮箱存储禁用已删除项目保留功能
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个邮箱存储的 garbageCollPeriod 属性的值。如果 Exchange Server 分析工具发现任何邮箱存储的 garbageCollPeriod 属性设置为 0，则会显示最佳实践建议消息。

垃圾收集是 Exchange 的一个内部维护管理过程，可以释放邮箱存储数据库中的空间。默认情况下，已删除项目会存储在邮箱存储数据库中指定天数，然后由 Exchange 永久删除。可以使用邮箱存储的默认值或选择已删除项目在永久删除之前保留的天数，设置已删除项目保持期的时长。

在指定保留已删除项目的天数时，可以选择从 0 到 24,855 之间的某个数字。建议将此设置配置为 7 天。如果将已删除项目的保持期设置为 0，将立即将已删除项目从服务器中永久删除。除非磁盘空间有限，否则，建议不要禁用已删除项目保留功能。按照下列步骤指定已删除项目在永久删除之前存储的天数。

在 Exchange 系统管理器中配置已删除项目保留功能

  1. 打开 Exchange 系统管理器。

  2. 展开"管理组"或"组织"，再单击"服务器"，然后单击"邮箱存储"。

  3. 用鼠标右键单击邮箱存储，再单击"属性"。

  4. 在"限制"选项卡上，通过执行下列操作设置已删除项目的保持期：

    • 若要设置已删除项目的保持期，请单击"保留已删除项目的期限(天)"，再键入值。

    • 若要将项目保留到备份完成，单击"完成对存储的备份之后才永久删除邮箱和项目"。

在 Active Directory 用户和计算机中配置已删除项目保留功能

  1. 打开"Active Directory 用户和计算机"。

  2. 在控制台树中展开域。

  3. 双击"用户"，或双击包含要修改的收件人信息的节点。

  4. 在详细信息窗格中，双击修改的收件人。

  5. 在"Exchange 常规"选项卡上，单击"存储限制"。

  6. 在"存储限制"对话框中的"已删除项目的保留时间"下，通过单击清除"使用邮箱存储默认设置"复选框，然后在"保留已删除项目的期限(天)"中键入值。

    若要避免已删除项目在备份之前被永久删除，请选中"完成对存储的备份之后才永久删除项目"复选框。

有关设置邮箱存储限制的详细信息，请参阅 Microsoft 知识库文章 319583"HOW TO: Configure Storage Limits on Mailboxes in Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=319583)。


对公用文件夹存储禁用已删除项目保留功能
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个公用文件夹存储的 garbageCollPeriod 属性的值。如果 Exchange Server 分析工具发现任何公用文件夹存储的 garbageCollPeriod 属性设置为 0，则会显示最佳实践建议消息。

垃圾收集是 Exchange 的一个内部维护管理过程，可以释放公用文件夹存储数据库中的空间。默认情况下，已删除项目会在公用文件夹存储数据库中存储指定天数，然后由 Exchange 永久删除。可以使用公用文件夹存储的默认值或选择已删除项目在永久删除之前保留的天数，设置已删除项目保持期的时长。

在指定保留已删除项目的天数时，可以选择从 0 到 24,855 之间的某个数字。建议将此设置配置为 7 天。如果将已删除项目的保持期设置为 0，将立即将已删除项目从服务器中永久删除。除非磁盘空间有限，否则，建议不要禁用已删除项目保留功能。

在 Exchange 系统管理器中配置已删除项目保留功能

  1. 打开 Exchange 系统管理器。

  2. 展开"管理组或服务器"，单击"服务器"，然后单击"公用文件夹存储"。

  3. 用鼠标右键单击公用文件夹存储，再单击"属性"。

  4. 在"限制"选项卡上，通过执行下列操作设置已删除项目的保持期：

    • 若要设置已删除项目的保持期，请单击"保留已删除项目的期限(天)"，再键入值。

    • 若要将项目保留到备份完成，单击"完成对存储的备份之后才永久删除项目"。

有关设置公用文件夹存储限制的详细信息，请参阅 Microsoft 知识库文章 319439"HOW TO: Configure Storage Limits on Mailboxes in Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=319439)。


已删除邮箱保留功能已禁用
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个邮箱存储的 msExchMailboxRetentionPeriod 属性值。如果 Exchange Server 分析工具发现任何邮箱存储的 msExchMailboxRetentionPeriod 属性值设置为 0，则显示最佳做法建议。

msExchMailboxRetentionPeriod 属性代表已删除邮箱在删除之前保留的天数。在指定保留已删除邮箱的天数时，可以选择从 0 到 24,855 之间的某个数字。已删除邮箱保留功能的默认设置为 30 天。如果邮箱保持期设置为 0，将立即将已删除邮箱从服务器中永久删除。除非磁盘空间有限，否则，建议不要禁用已删除邮箱保留功能。

配置已删除邮箱保留功能

  1. 打开 Exchange 系统管理器。

  2. 依次展开"管理组"、您的管理组、"服务器"、您的存储组。如果"管理组"节点未显示在 Exchange 系统管理器中，请展开"服务器"，再展开您的存储组。

  3. 用鼠标右键单击想要配置的邮箱存储，再选择"属性"。

  4. 在"限制"选项卡上的"保留已删除邮箱的期限(天)"字段中输入邮箱保持期。

  5. 单击"确定"保存更改。
注意：
如果邮箱保持期尚未过期，并且关联的用户对象未删除，您也许可以恢复邮箱。

有关恢复已删除邮箱的详细信息，请参阅下列 Microsoft 知识库文章：

  • 274343"How to Recover a Deleted Mailbox in Exchange"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=274343)

  • 813337"How to：在 Exchange 2000 Server 中恢复或还原单个邮箱"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=813337)

  • 823176"How to：在 Exchange Server 2003 中恢复或还原单个邮箱"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823176)


域有未知的 Exchange 签名
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2006-12-04

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定在给定域中最后一次运行的 DomainPrep 的版本。DomainPrep 的版本号充当了域的 Exchange 签名。Exchange Server 分析工具检查给定域的 Exchange System Objects 对象的 objectVersion 属性。该属性有两个有效的整数：

  • 对于 Exchange 2000 Server，objectVersion 值是 4406。

  • 对于 Exchange Server 2003，objectVersion 值是 6936。

  • 对于 Exchange Server 2007，objectVersion 值是 10628。

如果 Exchange Server 分析工具发现 objectVersion 属性的值不是上述某一个值，则会显示错误。

如果在给定域中安装了 Exchange 2000 Server 或 Exchange Server 2003 的预发行版本，但没有运行 DomainPrep 的发行版本，则该值很可能不正确。

注意：
在 Microsoft Exchange 2000 Server 和 Exchange Server 2003 中，通过运行 setup /forestprep 和 setup /domainprep 来执行 Active Directory 准备步骤。Exchange 2007 没有 /forestprep 和 /domainprep 选项。对于 Exchange Server 2007，您使用具有准备 Active Directory 和域所需权限的帐户，来运行 setup /PrepareDomain 进程或安装向导。

若要为 Exchange 2000 Server 或 Exchange Server 2003 修复此错误，请运行 Exchange 2000 Server DomainPrep、Exchange Server 2003 DomainPrep 的最终发行版本，或 PrepareDomain 进程的最终发行版本、Exchange Server 2007 安装向导。用来运行 DomainPrep、PrepareDomain 或安装向导的帐户必须是本地域中 Domain Admins 安全组的成员和本地计算机管理员。

  • 根域。

  • 将包含 Exchange 2000 Server 或 Exchange Server 2003 计算机的所有域。

  • 将包含启用了 Exchange 2000 Server 或 Exchange Server 2003 邮箱的对象（如用户和组）的所有域，即使这些域中不会安装 Exchange 服务器。

  • 将包含 Exchange 目录访问组件可能使用的全局编录服务器的所有域。

  • 将包含要用来管理 Exchange 组织的 Exchange 2000 Server 或 Exchange Server 2003 用户和组的所有域。

为 Exchange 2000 Server 或 Exchange Server 2003 运行 DomainPrep

  1. 将 Exchange Server 2003 CD 插入 CD-ROM 驱动器。可以在域中的任何计算机上运行 DomainPrep。

  2. 在命令提示符下，键入 <drive>:\setup\i386\setup /DomainPrep，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上，确保"操作"已设置为 DomainPrep。如果不是这样，请单击下拉箭头，然后单击 DomainPrep。单击"下一步"。

  7. 在"完成 Microsoft Exchange 向导"页上，单击"完成"。

为 Exchange Server 2007 运行 PrepareDomain

  1. 根据"How to Prepare Active Directory and Domains"（如何准备 Active Directory 和域）(http://go.microsoft.com/fwlink/?LinkId=78453) 中的指导，按步骤进行操作。

有关运行 Exchange Server 2003 DomainPrep 的详细信息，请参阅"Exchange Server 2003 部署指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=77B6D819-C7B3-42D1-8FBB-FE6339FFA1ED&DisplayLang=zh-cn)。

有关运行 Exchange 2000 Server DomainPrep 的详细信息，请参阅"Microsoft Exchange 2000 Server Installation and Setup"（Microsoft Exchange 2000 Server 安装和设置）(http://go.microsoft.com/fwlink/?LinkId=5906)。

有关如何为 Exchange Server 2007 准备 Active Directory 和域的详细信息，请参阅"How to Prepare Active Directory and Domains"（如何准备 Active Directory 和域）(http://go.microsoft.com/fwlink/?LinkId=78453)。


域控制器正在运行 Exchange Server 以来宾身份安装在其中的 Virtual Server 2005
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Model 关键字的值是否设置为 Virtual Machine。

Exchange Server 分析工具还检查是否存在以下注册表值：

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

此外，Exchange Server 分析工具还读取运行 Microsoft Virtual Server 2005 的物理计算机上 Win32_ComputerSystem 的 Domain Role 关键字。值大于 3 指示物理计算机为域控制器。

如果 Exchange Server 分析工具发现 Model 关键字包含字符串 Virtual Machine，并且存在上述注册表分支，且 Domain Role 大于 3，则显示错误。

Model 关键字的值为 Virtual Machine 说明 Exchange Server 计算机正在作为来宾虚拟计算机运行在 Virtual Server 2005 或 Virtual PC 2004 中。由于上述注册表分支只能由 Virtual Server 2005 创建，因此它的存在意味着 Exchange Server 计算机正在作为来宾虚拟计算机运行在 Virtual Server 2005 中。

Microsoft 不支持在虚拟计算机或仿真器上运行任何版本的 Exchange Server。这适用于运行在 Virtual Server 2005、Virtual PC 2004 或任何第三方虚拟计算机程序上的 Exchange Server。Exchange Server 平台的设计和测试只是针对在物理硬件上运行而进行的，尤其是针对 Windows Server Catalog (http://go.microsoft.com/fwlink/?linkid=17219) 中列出的那些硬件平台。

而且，将 Exchange 作为虚拟服务器来宾运行在域控制器上不是最佳做法，因为它没有考虑到足够的跨服务冗余。

更正此错误

  1. 将运行在 Virtual Server 2005 下的 Exchange 服务器中的邮箱移至非虚拟 Exchange Server 计算机上。

  2. 重新连接所有公用文件夹，并在必要时传输虚拟 Exchange 服务器保留的所有角色。

  3. 将 Exchange 从虚拟计算机中卸载以便不再使用它，并将它从 Exchange 基础结构及 Active Directory® 目录服务中删除。

有关移动邮箱的详细信息，请参阅下列 Microsoft 知识库文章：

  • 822892"在 Exchange 2003 中移动邮箱工具的改进"(http://support.microsoft.com/kb/822892/zh-cn)

  • 224975"XADM:Differences Between Move Mailbox Methods"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

有关对运行在虚拟环境中的 Exchange Server 计算机的支持的详细信息，请参阅 Microsoft 知识库文章 320220"Support Boundaries for Exchange Server on a Virtual Machine or an Emulation Machine"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)。

有关 Microsoft Virtual Server 2005 的详细信息，请访问 http://go.microsoft.com/fwlink/?LinkId=34938。

有关 Microsoft Virtual PC 2004 的详细信息，请访问 http://go.microsoft.com/fwlink/?linkid=34663。


域命名 FSMO 角色未响应
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定配置命名上下文中域命名操作主机的 fSMORoleOwner 属性值。例如，在名为 contoso.com 的域中，域命名操作主机的 fSMORoleOwner 是 CN=Partitions,CN=Configuration,DC=contoso,DC=com 的一个属性。然后，Exchange Server 分析工具尝试在打开到当前担任该角色的域控制器上的 TCP 端口 389 的轻型目录访问协议 (LDAP) 连接。如果 Exchange Server 分析工具无法连接到该域控制器，则显示错误。

域命名主机在目录林范围内充当操作主机的角色，因为它管理目录林层次结构中的所有目录分区（与域无关）的添加和删除。具有域命名主机角色的域控制器是可以执行下列操作的唯一域控制器：

  • 向林中添加新的域。

  • 从林中删除现有的域。

  • 将交叉引用对象添加到外部目录或从中删除。

在整个林中只能有一个域命名主机。

更正此错误

  1. 验证此错误中指定的目录服务器已联机，并可以通过您的组织中的 Exchange 服务器进行访问。

  2. 如果此目录服务器已不再使用，则必须将域命名主机角色指定给另一个域控制器。

有关将域命名操作主机角色从一个域控制器转移到另一个域控制器的详细信息，请参阅下列 Microsoft 知识库文章：

  • 对于 Microsoft Windows Server™ 2003，请参阅 324801"如何查看和转移 Windows Server 2003 中的 FSMO 角色"(http://support.microsoft.com/kb/324801/zh-cn)。

  • 对于 Microsoft Windows® 2000 Server，请参阅 255690"HOW TO:在图形用户界面中查看和转移 FSMO 角色"(http://support.microsoft.com/kb/255690/zh-cn)。


找不到域名 FSMO 角色
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定配置命名上下文中域命名操作主机的 fSMORoleOwner 属性。例如，在名为 contoso.com 的域中，域命名主域控制器的 fSMORoleOwner 是 CN=Partitions, CN=Configuration, DC=contoso, DC=com 的属性。然后，Exchange Server 分析工具尝试打开到该域控制器的轻型目录访问协议 (LDAP) 连接。如果 Exchange Server 分析工具发现 fSMORoleOwner 属性中指定的域控制器不响应，则显示错误。

域命名主域控制器控制目录林中的域的添加或删除。整个目录林中只能有一个域命名主域控制器。

必须为 Active Directory 目录林指定一个域命名主域控制器。如果域命名主域控制器在安装过程中未联机，Exchange 安装程序和 Exchange Service Pack 安装程序将失败。如果作为域命名主域控制器的域控制器脱机，必须将它重新联机。

更正此错误

  1. 确认指定的 Active Directory 服务器确实存在。

  2. 如果该目录服务器已停止使用，应当为另一个域控制器分配域命名主域控制器角色。

有关如何为另一个域控制器分配域命名主域控制器角色的详细信息，请参阅下列 Microsoft 知识库文章：

  • 对于 Microsoft Windows Server™ 2003，请参阅 324801"如何查看和转移 Windows Server 2003 中的 FSMO 角色"(http://support.microsoft.com/kb/324801/zh-cn)。

  • 对于 Microsoft Windows® 2000 Server，请参阅 255690"HOW TO:在图形用户界面中查看和转移 FSMO 角色"(http://support.microsoft.com/kb/255690/zh-cn)。


目录服务器 DNS 名称解析失败
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具尝试对每台 Active Directory® 目录服务服务器的已配置 DNS 服务器执行域名系统 (DNS) 查询。此连接是通过使用执行名称解析请求并分析结果的自定义对象处理器来建立的。如果 Exchange Server 分析工具收到的查询结果中没有 IP 地址，则显示错误。

该错误说明没有在 DNS 中找到目录服务器。Exchange Server 和 Active Directory 都需要配置正确且运行正常的 DNS 才能正确工作。DNS 注册和解析问题可能对发送、接收和传递邮件的功能产生广泛的影响。

必须正确配置 DNS 以确保 Active Directory 和 Exchange Server 正常工作。有关 Active Directory 的 DNS 配置的更深入处理，请参阅 Microsoft 知识库文章 237675"设置 Active Directory 的域名系统"(http://support.microsoft.com/kb/237675/zh-cn)。

更正此错误

  1. 检查下列配置项，确保 DNS 工作正常，并且 Active Directory DNS 项将被正确注册：

    • DNS IP 配置

    • 动态区域更新

    • DNS 转发器

  2. 检查根目录区域项是否存在。在 DNS 管理控制台中查看正向查找区域。应该有一个针对域的项。也可能存在其他区域项，但应该不是 dot (".") 区域。如果 dot (".") 区域存在，请删除 dot (".") 区域。dot (".") 区域将 DNS 服务器标识为根服务器。通常情况下，需要外部 (Internet) 访问的 Active Directory 域不应该配置为根 DNS 服务器。请在删除 dot (".") 后，在目录服务器上使用 Ipconfig /registerdns 手动重新注册目录服务器 IP 地址。可能还需要重新启动 Netlogon 服务。

  3. 在目录服务器上使用 netdiag /fix 手动重新填充 Active Directory DNS 项。

有关将 DNS 与 Active Directory 一起使用的详细信息，请参阅 Microsoft 知识库文章 323418"如何在 Windows Server 2003 中启用了 Active Directory 的情况下将 DNS 与现有 DNS 结构集成"(http://support.microsoft.com/kb/323418/zh-cn)。

有关解决 DNS 和 Active Directory 问题的详细信息，请参阅 Microsoft 知识库文章 260371"解决 Windows 2000 中的常见 Active Directory 安装问题"(http://support.microsoft.com/kb/260371/zh-cn)。


驻留 Exchange 的 dSHeuristics 设置不正确
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定部署是否为驻留的 Exchange 部署。如果 Exchange 部署在驻留的环境中运行，则 Exchange Server 分析工具查询 Active Directory，以确定是否为驻留的 Exchange 部署正确设置了 Directory Service 容器的 dSHeuristics 属性。

如果 dSHeuristics 的值不等于 1，则 Exchange Server 分析工具将显示警告。在驻留的 Exchange 环境中，dSHeuristics 属性应设置为 1。

警告：
在使用 ADSI（Active Directory 服务接口）Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。
解决此警告问题

  1. 使用 Active Directory 编辑器（例如，ADSI Edit）找到 Active Directory 中的目录服务对象。

    dSHeuristics 属性位于：

    CN=Configuration, CN=Services, CN=Windows NT, CN=Directory Service

  2. 为 dSHeuristics 输入值 1。

有关驻留的 Exchange 环境的详细信息，请参阅下列文章：

  • ""Information for Hosters"（英文）(http://go.microsoft.com/fwlink/?LinkId=46307)

  • "Exchange Server 2000 Resource Kit"中的"Hosted Service Environments"（英文）(http://go.microsoft.com/fwlink/?LinkId=46326)


Active Directory 中存在重复的 Microsoft Exchange System Objects 容器
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定域命名上下文中是否存在 Microsoft Exchange System Objects 容器。

如果 Exchange Server 分析工具发现 Active Directory 中存在重复的 Microsoft Exchange System Objects 容器，则 Exchange Server 分析工具将显示以下错误："Active Directory 域显示为已为 Exchange 做好准备，但同时存在多个'Microsoft Exchange System Objects'容器。可能必须清理。"

下列 Exchange Server 环境可能出现此问题：

  • 从 Active Directory 到 Exchange Server 5.5 的双向 Active Directory 连接器 (ADC) 服务器连接协议被删除和替换。

  • 从 Exchange Server 5.5 到 Active Directory 的新单向 ADC 服务器连接协议已就位。

  • 运行 Exchange Server 5.5 的混合模式环境迁移到 Exchange Server 2003 环境。

  • 执行了从外部邮件服务器到 Exchange Server 2003 的迁移。

如果 Exchange Server 分析工具显示此错误，则必须删除不正确的重复 Microsoft Exchange System Objects 容器或组织单位 (OU)。如果存在重复的 Microsoft Exchange System Objects 容器，再次运行 DomainPrep 不能解决问题。必须标识并删除不正确的重复 Microsoft Exchange System Objects 容器。

删除重复的 Microsoft Exchange System Object 容器

  1. 使用管理凭据登录到域控制器。

  2. 依次单击"开始"、"程序"、"管理工具"、"Active Directory 用户和计算机"。

  3. 在"Active Directory 用户和计算机"管理控制台窗格中，单击工具栏菜单中的"查看"，然后选择"高级功能"。

  4. 在"Active Directory 用户和计算机"管理控制台窗格中，找到不正确的重复 Microsoft Exchange System Objects 容器或组织单位 (OU)。

  5. 确认不正确的重复 Microsoft Exchange System Objects 容器或 OU 不包含有效的 Active Directory 对象。

  6. 用鼠标右键单击不正确的重复 Microsoft Exchange System Objects 容器或 OU，再单击"删除"。

  7. 在 Active Directory 对话框中单击"是"来确认删除。

    注意：
    如果要立即复制更改，必须手动启动域控制器之间的复制。

有关此 Exchange Server 问题的详细信息，请参阅下列 Microsoft 知识库文章：

  • 316280"XADM:A Description of the 'ADC Global Names' Attribute"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=316280)

  • 252228"XADM:ADC Appears to Create Duplicate Objects"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=252228)

  • 253800"XADM:ADC May Create Duplicate Objects in Active Directory"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=253800)

  • 274480"XADM:Duplicate Object Created When Replicating Objects from Exchange Server 5.5 to Windows 2000 Active Directory"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=274480)

  • 288578"XADM:ADC Creates Duplicate Accounts in Exchange Server 5.5 and Active Directory"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=288578)


访问 Active Directory 时出错
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具确定 Active Directory® 目录服务域控制器可能无法使用。验证 Active Directory 域控制器是否已进行网络连接。

更正此错误

  • 如果在 Exchange Server 分析工具中指定了 Active Directory 域控制器，则请尝试在不指定域控制器的情况下进行连接。

  • 如果未指定域控制器，则请指定正在运行并可使用的域控制器。


访问 Exchange 管理组时出现错误
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具确定 Active Directory® 目录服务林中已安装 Exchange 组织，并且您已成功访问 Active Directory 中的 Exchange 组织配置信息。但是，未发现包含 Exchange 服务器的管理组。

若要更正此错误，请执行下列操作：

  • 验证您在 Active Directory 中具有访问 Exchange 管理组容器的相应权限。

  • 如果运行 Exchange Server 分析工具的工作站属于其他 Active Directory 林，或您未使用域帐户登录，则必须连接至 Active Directory 域控制器以查找承载 Exchange 服务器的林。


访问 Exchange 配置容器时出错
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具已确定 Exchange 配置容器无法访问。Exchange 组织、管理组和服务器的配置信息存储在 Active Directory® 目录服务的配置命名上下文中。若要访问任何 Exchange 配置信息，必须能够读取 Active Directory 配置容器的 Microsoft Exchange 分支。

若要更正此错误，请执行下列操作：

  • 验证您拥有读取 Active Directory 配置容器所需的权限。

  • 验证您拥有到 Active Directory 域控制器的网络连接。


未拒绝 Everyone 安全组创建顶级公用文件夹的权限
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2006-12-04

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定是否已在 Exchange 组织对象的 ntSecurityDescriptor 中列出 Everyone 安全组的安全标识符 (SID)。如果 Exchange Server 分析工具发现组织对象的 ntSecurityDescriptor 中具有 Everyone 组的 SID，则显示警告。该警告表明未拒绝 Everyone 组创建顶级公用文件夹的权限。

在 Exchange 2000 Server 中，默认情况下允许创建顶级公用文件夹的权限。但是，在运行 Exchange Server 2003 版的 ForestPrep 或运行 Exchange Server 2007 的 PrepareAD 时，拒绝 Everyone 安全组创建顶级公用文件夹的权限。拒绝功能作为一项安全措施实现。如果允许 Everyone 安全组创建顶级公用文件夹，则您的组织容易受到拒绝服务攻击。

因此，最好拒绝 Everyone 安全组创建顶级公用文件夹的权限。如果您安装有 Exchange Server 2003 或 Exchange Server 2007，则应运行相应的 Exchange Server 2003 版的 ForestPrep 或 Exchange Server 2007 版的 PrepareAD。可以在 Exchange 2000 Server 环境中运行 Exchange Server 2003 版的 ForestPrep。但是，以后安装 Exchange 2000 Server 时将重置权限，以允许 Everyone 安全组创建顶级公用文件夹。

如果没有安装 Exchange Server 2003 或 Exchange Server 2007，则可手动设置此权限。记住，以后安装 Exchange 2000 Server 时将重置此权限。因此，在每次安装 Exchange 2000 Server 之后，必须手动配置此权限。设置此权限之前，必须允许在 Exchange 系统管理器中显示"安全性"选项卡，要完成操作，可以将 ShowSecurityPage 项添加到 Exchange Server 计算机的注册表中。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
将 ShowSecurityPage 项添加到注册表中

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKEY_CURRENT_USER\Software\Microsoft\Exchange\ExAdmin

  3. 单击"编辑"，再单击"新建"，然后单击"DWORD 值"。

  4. 对于新值的名称，键入 ShowSecurityPage，再按 Enter 键。

  5. 双击 ShowSecurityPage，在"数据数值"字段中键入 1，再单击"确定"。

手动拒绝 Everyone 安全组在 Exchange 2000 Server 环境中创建顶级公用文件夹的权限

  1. 打开 Exchange 系统管理器。

  2. 右键单击 Organization_Name，再单击"属性"。

  3. 在"Organization_Name 属性"页上单击"安全性"选项卡。

  4. 在"安全性"选项卡上的"组或用户名"中，选择 Everyone。在"Everyone 的权限"框中，向下滚动到"创建顶级公用文件夹"权限，清除"允许"列中的复选框，再单击"应用"。

编辑注册表之前，要获取有关如何编辑注册表的信息，请阅读 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关运行 Exchange Server 2003 ForestPrep 的详细信息，请参阅"Exchange Server 2003 部署指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=77B6D819-C7B3-42D1-8FBB-FE6339FFA1ED&DisplayLang=zh-cn)。

有关运行 Exchange Server 2007 PrepareAD 的详细信息，请参阅"How to Prepare Active Directory and Domains"（如何准备 Active Directory 和域）(http://go.microsoft.com/fwlink/?LinkId=78453)。

有关如何拒绝 Everyone 安全组在 Exchange 2000 Server 中创建顶级公用文件夹的权限的详细信息，请参阅知识库文章 328808"如何在 Exchange 2000 中删除创建顶级公用文件夹的用户权限"(http://support.microsoft.com/kb/328808/zh-cn)。


Exchange 域容器问题
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定域命名上下文中是否存在 Microsoft Exchange System Objects 容器。如果 Exchange Server 分析工具发现 Microsoft Exchange System Objects 容器不存在或者无效或不正确，则显示错误。

Microsoft Exchange System Objects 容器是运行 Exchange DomainPrep 时在每个域中创建的。

必须在发现该错误的域中运行 DomainPrep。Exchange Server 分析工具的输出中将列出丢失 Microsoft Exchange System Objects 容器的域名。

用来运行 DomainPrep 的帐户必须是本地域中 Domain Admins 安全组的成员和本地计算机管理员。

通常，必须在以下域中运行 DomainPrep：

  • 根域。

  • 将包含 Exchange 2000 Server 或 Exchange Server 2003 计算机的所有域。

  • 将包含启用了 Exchange 2000 Server 或 Exchange Server 2003 邮箱的对象（如用户和组）的所有域，即使这些域中不会安装 Exchange 服务器。

  • 将包含 Exchange 目录访问组件可能使用的全局编录服务器的所有域。

  • 将包含将用来管理 Exchange 组织的 Exchange 2000 Server 或 Exchange Server 2003 用户和组的所有域。

运行 DomainPrep

  1. 将 Exchange Server 2003 CD 插入 CD-ROM 驱动器。可以在域中的任何计算机上运行 DomainPrep。

  2. 在命令提示符处，键入 <drive>:\setup\i386\setup /DomainPrep，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上，确保"操作"已设置为 DomainPrep。如果不是这样，请单击下拉箭头，然后单击"DomainPrep"。单击"下一步"。

  7. 在"完成 Microsoft Exchange 向导"页上，单击"完成"。

有关运行 Exchange Server 2003 DomainPrep 的详细信息，请参阅"Exchange Server Deployment Guide"（英文）(http://go.microsoft.com/fwlink/?LinkId=47569)。

有关运行 Exchange 2000 Server DomainPrep 的详细信息，请参阅技术文章"Microsoft Exchange 2000 Server Installation and Setup"（英文）(http://go.microsoft.com/fwlink/?LinkId=5906)。


找不到 Exchange Domain Servers 组
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Microsoft Exchange System Objects 对象的 ntSecurityDescriptor 属性值，从而确定已在域中运行的 DomainPrep 的版本。

有两个有效整数：

  • 对于 Exchange 2000 Server，ntSecurityDescriptor 值是 4406。

  • 对于 Exchange Server 2003，ntSecurityDescriptor 值是 6936。

如果确定使用了上述 DomainPrep 版本之一，Exchange Server 分析工具将查询 Active Directory，以确定 Microsoft Exchange System Objects 对象的 objectGuid 属性值，以便判断是否存在 Exchange Domain Servers 组。如果 Exchange Server 分析工具确定该组不存在，则显示错误。

若要解决该错误，请运行 Exchange 2000 Server DomainPrep 或 Exchange Server 2003 DomainPrep 的最终发行版本。用来运行 DomainPrep 的帐户必须是本地域中 Domain Admins 安全组的成员和本地计算机管理员。

必须在以下域中运行 DomainPrep：

  • 根域。

  • 将包含 Exchange 2000 Server 或 Exchange Server 2003 计算机的所有域。

  • 将包含启用了 Exchange 2000 Server 或 Exchange Server 2003 邮箱的对象（如用户和组）的所有域，即使这些域中不会安装 Exchange 服务器。

  • 将包含 Exchange 目录访问组件可能使用的全局编录服务器的所有域。

  • 将包含将用来管理 Exchange 组织的 Exchange 2000 Server 或 Exchange Server 2003 用户和组的所有域。

运行 DomainPrep

  1. 在 CD 驱动器中插入 Exchange CD。可以在域中的任何计算机上运行 DomainPrep。

  2. 在命令提示符处，键入 <drive>:\setup\i386\setup /DomainPrep，其中 <drive> 是 CD 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上，确保"操作"已设置为 DomainPrep。如果不是这样，请单击下拉箭头，然后单击"DomainPrep"。单击"下一步"。

  7. 在"完成 Microsoft Exchange 向导"页上，单击"完成"。

有关运行 Exchange Server 2003 DomainPrep 的详细信息，请参阅"Exchange 2003 Server 部署指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=77B6D819-C7B3-42D1-8FBB-FE6339FFA1ED&DisplayLang=zh-cn)。

有关运行 Exchange 2000 Server DomainPrep 的详细信息，请参阅"Microsoft Exchange 2000 Server Installation and Setup"（英文）(http://go.microsoft.com/fwlink/?LinkId=5906)。


找不到 Exchange Enterprise Servers 组
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Microsoft Exchange System Objects 对象的 ntSecurityDescriptor 属性值，从而确定已在域中运行的 DomainPrep 的版本。

有两个有效整数：

  • 对于 Exchange 2000 Server，ntSecurityDescriptor 值是 4406。

  • 对于 Exchange Server 2003，ntSecurityDescriptor 值是 6936。

如果确定使用了上述 DomainPrep 版本之一，Exchange Server 分析工具将查询 Active Directory，以确定 Microsoft Exchange System Objects 对象的 objectGuid 属性的值，以便判断是否存在 Exchange Enterprise Servers 组。如果 Exchange Server 分析工具确定该组不存在，则会显示错误。

若要解决该错误，请运行 Exchange 2000 Server DomainPrep 或 Exchange Server 2003 DomainPrep 的最终发行版本。用来运行 DomainPrep 的帐户必须是本地域中 Domain Admins 安全组的成员和本地计算机管理员。

必须在以下域中运行 DomainPrep：

  • 根域。

  • 将包含 Exchange 2000 Server 或 Exchange Server 2003 计算机的所有域。

  • 将包含启用了 Exchange 2000 Server 或 Exchange Server 2003 邮箱的对象（如用户和组）的所有域，即使这些域中不会安装 Exchange 服务器。

  • 将包含 Exchange 目录访问组件可能使用的全局编录服务器的所有域。

  • 将包含将用来管理 Exchange 组织的 Exchange 2000 Server 或 Exchange Server 2003 用户和组的所有域。

运行 DomainPrep

  1. 在 CD 驱动器中插入 Exchange CD。可以在域中的任何计算机上运行 DomainPrep。

  2. 在命令提示符处，键入 <drive>:\setup\i386\setup /DomainPrep，其中 <drive> 是 CD 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上，确保"操作"已设置为 DomainPrep。如果不是这样，请单击下拉箭头，然后单击"DomainPrep"。单击"下一步"。

  7. 在"完成 Microsoft Exchange 向导"页上，单击"完成"。

有关运行 Exchange Server 2003 DomainPrep 的详细信息，请参阅"Exchange 2003 Server 部署指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=77B6D819-C7B3-42D1-8FBB-FE6339FFA1ED&DisplayLang=zh-cn)。

有关运行 Exchange 2000 Server DomainPrep 的详细信息，请参阅"Microsoft Exchange 2000 Server Installation and Setup"（英文）(http://go.microsoft.com/fwlink/?LinkId=5906)。


在"Lost and Found (找回丢失的项目)"容器中的 Exchange 对象
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2006-12-01

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Configuration 容器下的 LostAndFoundConfig 容器中是否存在任何对象。如果 Exchange Server 分析工具发现 LostAndFoundConfig 容器中存在对象，则显示错误，同时显示该对象和派生该对象的对象类。

LostAndFoundConfig 容器包含 Active Directory 无法协调的对象。由于 Exchange 将尝试使用这些对象，因此，请确保删除 LostAndFoundConfig 容器中的所有对象。例如，当 Exchange 按对象类（即 Servers）查询 Active Directory 时，所有对象（不管它们是否可能在 LostAndFoundConfig 容器中）都将作为有效的对象返回。结果是，Exchange 可能尝试连接到在 the LostAndFoundConfig 容器下的服务器，而不是连接真实的对象。这可以导致 Exchange 出现不可预料的行为，甚至导致服务器失败。这些对象的出现还可能导致无法创建相同类的对象。

若要解决该问题，必须使用 Active Directory 服务接口 (ADSI) Edit 从 Active Directory 中删除 LostAndFoundConfig 容器中的条目。

警告：
在使用 ADSI Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003/Exchange Server 2007 才能解决。修改 Active Directory 对象的属性的风险由您自己承担。
注意：
ADSI Edit 是 Windows 2000 Server 和 Windows Server 2003 支持工具附带的工具。

更正此错误

  1. 打开 ADSI Edit MMC 管理单元。

  2. 在"操作"菜单上，单击"连接到"。

  3. 在 Connection Settings 对话框的 Name 字段中，输入 ADSI 连接的名称。在"连接点"下，选择"选择已知的命名上下文"，再在下拉菜单中选择"配置"。单击"确定"。

  4. 在左窗格中，双击"配置"对象，再双击 LostAndFoundConfig。

  5. 在右侧窗格中，删除所有对象和容器。右键单击对象或容器，单击"删除"，再单击"是"。

  6. 退出 ADSI Edit。


Exchange 组织没有收件人策略
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 Exchange 组织的收件人策略中的 Name 属性值。如果 Exchange Server 分析工具确定没有收件人策略对象或者收件人策略对象不包含任何收件人策略，则显示错误。

在安装 Exchange Server 时，会创建一个默认的收件人策略，将 SMTP（简单邮件传输协议）和 X.400 地址应用于 Exchange 组织中的所有收件人。可以修改默认策略，也可以创建新策略。但是，不能删除默认策略。Exchange 组织中的所有收件人必须具有 SMTP 和 X.400 地址。如果 Exchange 组织中没有收件人策略，可靠性可能会出现问题。

创建收件人策略

  1. 依次单击"开始"、"所有程序"、"Microsoft Exchange"、"系统管理器"。

  2. 在 Exchange 系统管理器的左侧窗格中，展开组织，再展开"收件人"，用鼠标右键单击"收件人策略"，指向"新建"，然后单击"收件人策略"。

  3. 在"新建策略"对话框中，选中"电子邮件地址"复选框或"邮箱管理器设置"复选框，或者两者同时选中，以选择要创建的策略类型，再单击"确定"。

  4. 在"属性"对话框中，键入新收件人策略的名称，再单击"修改"为该收件人策略创建筛选器。

    注意：
    如果不创建筛选器，策略无法应用于任何收件人。

  5. 若要自定义收件人策略，在"属性"对话框中切换到"电子邮件地址(策略)"选项卡或"邮箱管理器设置(策略)"选项卡。。使用这些选项卡上的设置配置收件人策略，再单击"确定"创建策略。

  6. 在 Exchange 系统管理器中用鼠标右键单击该收件人策略，再单击"立即应用策略"。

有关收件人和收件人策略的详细信息，请参阅"Exchange Server 2003 管理指南"中的"管理收件人和收件人策略"(http://www.microsoft.com/downloads/details.aspx?FamilyID=98e45481-1458-4809-97d6-50d8aeebd8a1&DisplayLang=zh-cn)。

有关如何创建和配置收件人策略的详细信息，请参阅 Microsoft 知识库文章 249299"HOW TO：在 Exchange 中配置收件人策略"(http://support.microsoft.com/kb/249299/zh-cn)。


Exchange 组织没有系统策略
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 Exchange 组织的系统策略对象中每个系统策略的名称。如果 Exchange Server 分析工具确定没有系统策略对象或者系统策略对象不包含任何系统策略，则显示错误。

使用系统策略对象可以通过一个配置对象（例如邮箱存储、公用文件夹存储或服务器设置）配置多个 Exchange 服务器的参数，从而简化系统的管理。默认情况下，在组织中运行 ForestPrep 时，将创建下列系统策略：

  • Hidden DL Membership

  • Mail-Enabled Recipient

  • Mailbox-Enabled User

如果这些默认的系统策略在 Exchange 组织中不存在，则可靠性可能会出现问题。若要重新创建默认的系统策略，必须运行 ForestPrep。

运行 Exchange Server 2003 ForestPrep

  1. 在 CD 驱动器中插入 Exchange CD。

  2. 在"开始"菜单上，单击"运行"，再键入 驱动器:\setup\i386\setup /ForestPrep，其中 驱动器 是 CD 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上，验证"操作"是否已设置为 ForestPrep。如果不是这样，请单击下拉箭头，然后单击 ForestPrep。单击"下一步"。

    重要信息：
    如果"操作"下没有出现 ForestPrep，可能是第 2 步中的 ForestPrep 命令拼写有误。如果 ForestPrep 命令拼写有误，请返回第 2 步重新键入命令。

  7. 在"Microsoft Exchange 服务器管理员帐户"页的"帐户"框中，键入负责安装 Exchange 的帐户或组的名称。

    注意：
    您指定的帐户还将有权使用 Exchange 管理委派向导创建其他 Exchange 管理员帐户。有关 Exchange 管理委派向导的详细信息，请参阅"Exchange Server 2003 管理指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=98e45481-1458-4809-97d6-50d8aeebd8a1&DisplayLang=zh-cn)。

  8. 单击"下一步"启动 ForestPrep。ForestPrep 启动之后，即不能取消该进程。

    注意：
    根据网络拓扑以及 Microsoft Windows® 2000 或 Microsoft Windows Server™ 2003 域控制器的速度，ForestPrep 可能需要很长时间才能完成。

  9. 在"完成 Microsoft Exchange 向导"页上，单击"完成"。

有关在 Exchange 中使用系统策略的详细信息，请参阅 Microsoft 知识库文章 253838"XADM:How the Recipient Update Service Applies System Policies"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=253838)。

有关系统策略的详细信息，请参阅"Exchange Server 2003 技术参考指南"中的"Exchange 系统管理器体系结构"(http://go.microsoft.com/fwlink/?LinkId=34251)。

有关如何在 Exchange 中创建非默认系统策略的信息，请参阅知识库文章 256141"How to Create System Policies in Exchange"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256141)。


全局编录 NSPI 端口已被覆盖
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2007-01-15

Microsoft® Exchange Server 分析工具读取全局编录服务器上的以下注册表项，以确定是否已设置 TCP/IP Port 注册表项：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Parameters\TCP/IP Port

如果 Exchange Server 分析工具发现创建并设置了 TCP/IP Port 注册表项，则显示非默认配置消息。

当全局编录服务器需要使用特定端口以便为 MAPI 客户端提供服务时，TCP/IP Port 注册表项是必需的。如果 Exchange 环境中没有此类要求，则可以删除此项。

.

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

在全局编录服务器上删除该 TCP/IP 端口

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\SYSTEM\CurrentControlSet\Services\NTDS\Parameters

  3. 右键单击 TCP/IP Port 注册表项，再单击"删除"。

  4. 关闭注册表编辑器。

  5. 重新启动计算机，以使此设置生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关配置 RPC over HTTP 的详细信息，请参阅下列知识库文章：

  • 833401"如何在一台服务器上的 Exchange Server 2003 中配置 RPC over HTTP"(http://support.microsoft.com/kb/833401/zh-cn)

  • 827330"How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)。

  • 298369"How to Configure a Global Catalog Server to Use a Specific Port When Servicing MAPI Clients"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=298369)

  • 24823"Exchange Server 2003 RPC over HTTP Deployment Scenarios"（英文）(http://go.microsoft.com/fwlink/?linkid=24823)


全局编录端口 3268 无响应
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定此服务器的 isGlobalCatalogReady 属性的值。如果此属性的值为 True，表明该目录服务器同时作为全局编录服务器，如果值为 False，表明该目录服务器不是全局编录服务器。

然后，Exchange Server 分析工具连接到 Exchange 服务器上的端口 3268，确认该端口有响应。

如果符合以下条件，Exchange Server 分析工具将显示错误：

  • 该服务器是全局编录服务器。

  • 端口 3268 无响应。

注意：
如果运行 Exchange Server 分析工具的计算机与全局编录服务器之间存在防火墙，可能会在错误中显示此消息。

如果选中了"全局编录服务器"复选框，但是服务器尚未重新启动，通常会出现此问题。

解决此问题

  • 重新启动服务器。

有关提升域控制器的详细信息，请参阅 Microsoft 知识库文章 304403"XADM:Exchange Considerations for Promoting a Domain Controller to a Global Catalog Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=304403)


组类架构错误
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2006-12-01

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchBaseClass 类是否出现在 Active Directory 架构中组对象的 auxiliaryClass 属性中。

Active Directory 已预定义如下的类，这些类定义了目录正常工作所必需的各种对象类型。通过在彼此的内部嵌套类来创建对象定义。嵌套的类生成类之间的父/子关系。

安装 Exchange 2000 Server、Exchange Server 2003 和 Exchange Server 2007 时，将 msExchBaseClass 类添加到 Active Directory。msExchBaseClass 类是基本辅助类，它适用于由 Exchange 2000 Server、Exchange Server 2003 和 Exchange Server 2007 的 CDO (CDOEX) 扩展的所有类。CDOEX 提供基本组件对象模型 (COM) 类和用于管理 Exchange 存储中大多数信息类型的界面。

Active Directory 架构的修改不当会中断组对象的 msExchBaseClass 类和 auxiliaryClass 属性之间的关系。此中断可以导致 Exchange 服务器不稳定，例如收件人更新服务处理错误，或无法在组织中安装新的 Exchange Server 200x 服务器。

如果 Exchange Server 分析工具发现 msExchBaseClass 类未出现在 Active Directory 架构的组对象的 auxiliaryClass 属性中，则表明此关系已中断。如果 msExchBaseClass 类未出现在 Active Directory 架构的组对象的 auxiliaryClass 属性中，Exchange Server 分析工具会显示错误。

要更正此错误，请联系 Microsoft 客户支持服务 (http://go.microsoft.com/fwlink/?LinkId=41364)。


驻留的 Exchange 要求纯模式的 Exchange 组织
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Exchange Server 环境是否配置为驻留的 Exchange 环境。如果 Exchange Server 环境为驻留的 Exchange 环境，则 Exchange Server 分析工具将查询 Active Directory，以确定 Exchange 组织是否在混合模式下运行。

如果 Exchange 组织在混合模式下运行，则会显示警告。驻留的 Exchange 解决方案要求纯模式组织。

切换到纯模式之后，将无法切换回混合模式。

切换到纯模式

  1. 启动 Exchange 系统管理器：单击"开始"，指向"所有程序"，指向"Microsoft Exchange"，再单击"系统管理器"。

  2. 在控制台树中，用鼠标右键单击要切换到纯模式的组织，再单击"属性"。

  3. 在"<组织名> 属性"中的"更改操作模式"下，单击"更改模式"。

  4. 如果确定要永久切换到纯模式，请在警告对话框中单击"是"。单击"应用"接受新的 Exchange 模式。

若要充分利用 Exchange 纯模式，必须在组织中的所有 Exchange 服务器上重新启动 Microsoft Exchange 信息存储服务。不必同时启动所有 Microsoft Exchange 信息存储服务，但是必须在每台服务器上重新启动该服务，才能使服务器利用所有 Exchange 纯模式的功能。在纯模式切换已复制到本地 Microsoft Windows® 域控制器之后，请在服务器上重新启动该服务。

重新启动 Microsoft Exchange 信息存储服务

  1. 单击"开始"，再单击"运行"，键入 services.msc，然后单击"确定"。

  2. 在"服务（本地）"窗格中，找到 Microsoft Exchange Information Store 服务。

  3. 用鼠标右键单击该服务，再单击"重新启动"。

有关驻留的 Exchange 环境的详细信息，请参阅下列文章：

  • ""Information for Hosters"（英文）(http://go.microsoft.com/fwlink/?LinkId=46307)

  • "Exchange Server 2000 Resource Kit"中的"Chapter 23 - Hosted Service Environments"（英文）(http://go.microsoft.com/fwlink/?LinkId=46326)

有关从混合模式转换到纯模式的详细信息，请参阅 Microsoft 知识库文章 32779"在 Exchange 2000 Server 中从混合模式转换到本机模式"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779)。


基础结构 FSMO 服务器角色不响应
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定域命名上下文中的基础结构主域控制器的 fSMORoleOwner 属性的值。例如，在名为 contoso.com 的域中，基础结构主域控制器的 fSMORoleOwner 是 CN=Infrastructure,DC=contoso,DC=com 的属性。然后，Exchange Server 分析工具尝试打开与当前担任此角色的域控制器上的 TCP 端口 389 的轻型目录访问协议 (LDAP) 连接。如果 Exchange Server 分析工具无法连接到该域控制器，则会显示错误。

只要域内部的组成员重命名或发生更改，基础结构主域控制器就更新 group-to-user 引用。担任组所在的域的基础结构主域控制器角色的域控制器更新交叉域的 group-to-user 引用以反映用户的新名称。基础结构主域控制器定期扫描域帐户并验证组的成员。如果用户帐户移至一个新域中，基础结构主域控制器将识别用户帐户所在的新域并相应地更新组。当基础结构主域控制器在本地更新这些引用后，将使用复制来更新域的其他所有副本。如果基础结构主域控制器不可用，这些更新将延迟。任何时候，每个域中都只能有一个域控制器充当基础结构主域控制器。

更正此错误

  1. 确认错误消息中指定的目录服务器已联机并可供组织中的 Exchange 服务器访问。

  2. 如果该目录服务器已停止使用，必须为另一个域控制器分配基础结构主域控制器角色。

有关将基础结构主域控制器角色从一个域控制器转移到另一个域控制器的详细信息，请参阅下列 Microsoft 知识库文章：

  • 对于 Microsoft Windows Server™ 2003，请参阅 324801"如何查看和转移 Windows Server 2003 中的 FSMO 角色"(http://support.microsoft.com/kb/324801/zh-cn)

  • 对于 Microsoft Windows 2000 Server，请参阅 255690"HOW TO:在图形用户界面中查看和转移 FSMO 角色"(http://support.microsoft.com/kb/255690/zh-cn)


Exchange 组织对象上的版本属性无效
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2007-02-28

Microsoft Exchange Server 分析工具查询 Active Directory 目录服务，以确定 Exchange 的架构版本信息。具体地说，Exchange Server 分析工具检查以下 Active Directory 对象，以确定 rangeUpper 属性的当前值：

CN=ms-Exch-Schema-Version-Pt,CN=Schema,CN=Configuration,DC=<DN-of-forest-root-domain>

rangeUpper 值为 4397 表明安装的是 Exchange 2000 Server。

rangeUpper 值为 6870 表明安装的是 Exchange Server 2003。

rangeUpper 值为 10637 表明安装的是 Exchange Server 2007。

如果 Exchange Server 分析工具发现 rangeUpper 的值为其他任何数字，则会显示错误。

rangeUpper 值是由 Exchange 2000 Server 或 Exchange Server 2003 在 ForestPrep 进程中输入的。4397、6870 或 10637 以外的值通常意味着执行 ForestPrep 时使用的是 Exchange 的试用版或预发行版，或是执行 PrepareDomain 时使用的是 Exchange Server 2007。

若要在 Exchange 2000 Server 或 Exchange Server 2003 中解决此问题，请使用安装在环境中的 Exchange 发行版重新运行 ForestPrep 进程。对于 Exchange Server 2007，请使用安装在环境中的 Exchange 发行版重新运行 PrepareSchema。要运行 ForestPrep 或 PrepareSchema，必须以至少具有下列权限的帐户登录：

  • 企业管理员

  • 架构管理员

  • 域管理员

  • 本地计算机管理员（如果仅运行在成员服务器上）

在 Exchange 2000 Server 或 Exchange Server 2003 上更正此错误

  1. 运行 setup.exe /forestprep。

  2. 验证 ForestPrep 过程已成功完成。

在 Exchange Server 2007 上更正此错误

  1. 运行 setup.exe /PrepareSchema。

  2. 确定 PrepareSchema 进程已成功完成。

有关如何安装 Exchange 并执行 PrepareSchema 进程的详细信息，请参阅下列产品文档：

  • "How to Prepare Active Directory and Domains"（如何准备 Active Directory 和域）http://go.microsoft.com/fwlink/?LinkId=78453

有关如何安装 Exchange 并执行 ForestPrep 过程的详细信息，请参阅下列 Microsoft 知识库文章：

  • 312371"如何使用 Exchange 2000 Server 中的 ForestPrep 准备林"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=312371)。该文章同时适用于 Exchange 2000 Server 和 Exchange Server 2003。

  • 274737"如何确定已在 Exchange 2000 Server 或 Exchange Server 2003 中成功完成 ForestPrep 和 DomainPrep"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=274737)。

  • 828765"在 Exchange Server 2003 中安装组件所需的权限"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=828765)。


旧版帐户信息出现在纯模式管理组中
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 Exchange 管理组对象的 msExchLegacyAccount 属性是否包含数据。

Exchange Server 分析工具还查询 Active Directory，以确定每个管理组的 msExchAdminGroupMode 属性的值。msExchAdminGroupMode 属性的值为 0 说明管理组处于 Exchange 纯模式。值为 1 说明这是纯 Exchange Server 5.5 环境，而值为 2 则说明这是 Exchange 混合模式。

如果 Exchange Server 分析工具发现 msExchLegacyAccount 属性包含数据，并且 msExchAdminGroupMode 属性的值是 0，则会显示错误。

切换到 Exchange 纯模式时，将删除 msExchLegacyAccount 属性。只在仍然有 Exchange Server 5.5 的混合模式 Exchange 组织中使用该属性。实际的属性数据是 Exchange Server 5.5 服务帐户，如果它出现在纯模式 Exchange 组织内的 msExchLegacyAccount 属性中，将在升级和 Service Pack 安装期间导致故障。实际上，正是由于该属性的出现而导致故障（即使其中没有数据也是如此）。这是因为，Exchange 安装程序使用该属性作为发现 Exchange 组织是处在混合模式还是纯模式的手段。如果存在该属性，那么，假如安装实际是在纯模式下进行的，则 Exchange 安装程序也将运行在混合模式配置下。

如果使用 Active Directory 服务接口 (ADSI) Edit 管理单元从 Active Directory 中手动删除数据，很可能 msExchLegacyAccount 属性仍然存在。

必须通过用 LDP (ldp.exe) 工具手动编辑 msExchLegacyAccount 属性，从该属性中删除此数据。必须使用 LDP 工具或另一个轻型目录访问协议 (LDAP) 版本 3 客户端，这样的工具将从目录中完整地删除数据和属性。在这种情况下，使用 ADSI Edit 管理单元是不够的，因为它只删除数据，但保留了属性。LDP.exe 包含在 Windows® 支持工具软件包中。

警告：
在使用 ADSI Edit、LDP 工具或其他 LDAP 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

删除 msExchLegacyAccount 属性

  1. 启动 LDP.exe。

  2. 在 Connection 菜单上，单击 Connect，在 Connect 对话框中，输入 Exchange 组织所在的 Active Directory 目录林的域控制器名称，再单击 OK。

  3. 在 Connection 菜单上，单击 Bind；在 Bind 对话框中，输入至少在管理组级别拥有 Exchange 管理员（完全控制）权限的凭据，再单击 OK。

  4. 在 View 菜单上，单击 Tree；在 Tree View 对话框上，如果从根域连接，请将该字段留空，否则，请输入 CN=Configuration,DC=Domain_name, DC=Domain_suffix，其中 Domain_name 是 Active Directory 目录林的根域，Domain_suffix 是域后缀，例如 com、net 和 org。单击 OK。

  5. 在 LDP 的左侧窗格中展开层次结构视图，直到打开管理组。要这样做，请按下列顺序双击节点（注意，LDP 中的每个节点的后面都是完整的可分辨名称 (DN)；为清晰起见，在这里只记下最左侧的 CN）：

    1. DC=Domain_name

    2. CN=Configuration

    3. CN=Services

    4. CN=Microsoft Exchange

    5. CN=Organization_name

    6. CN=Administrative Groups

    7. CN=Administrative_group_name

    在 LDP 的详细信息（右）窗格中，向下滚动以查看管理组的属性。如果 msExchLegacyAccount 属性在那里，则必须删除它。如果 msExchLegacyAccount 属性在那里，那么很可能 msExchLegacyDomain 和 msExchEncryptedPassword 属性也在那里。如果它们都在，也必须删除它们。

  6. 在 LDP 的层次结构（左）窗格中，用鼠标右键单击 Administrative_group_name，再单击 Modify。

  7. 在 Modify 对话框中，验证在 Dn 字段中列出的完整 DN 正确标识了需要修改的管理组。它应当是：CN=Administrative_group_name,CN=Administrative Groups,CN=Organization_name,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Domain_name。

  8. 在 Modify 对话框的 Operations 下，选择 Delete，在 Edit entry 下的 Attribute 字段中，输入 msExchLegacyAccount，再单击 Enter。这会将 msExchLegacyAccount 添加到 Entry List。Entry List 定义了在单击 Run 时将被删除的属性。

  9. 如果 msExchLegacyDomain 或 msExchEncryptedPassword 属性存在于管理组中，那么请按步骤 8 中的说明，将它们添加到 Entry List 中。

  10. 如果 Entry List 包含必须删除的属性，请单击 Run。状态消息将出现在 LDP 详细信息窗格中。

  11. 在 Connection 菜单上，单击 New 以清除 LDP 详细信息窗格。

  12. 导航到 CN=Administrative_group_name，并在对象上双击。复查右侧窗格的内容，验证属性已删除。

有关使用 LDP 工具修改 Active Directory 的详细信息，请参阅 Microsoft 知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。


Exchange 组织的 legacyExchangeDN 属性无效
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2007-02-01

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Exchange 组织对象的 legacyExchangeDN 属性的格式。如果 Exchange Server 分析工具发现 legacyExchangeDN 属性无效或格式不正确，则会显示错误。

此属性的值采用 /o=Organization 格式，其中 Organization 是 Exchange 组织的名称。如果该值以 /o= 或 /O= 以外的其他任何内容开头，将被视为格式不正确。此问题应尽快更正。

在 Exchange 2000 Server 或 Exchange Server 2003 上更正此错误

  1. 执行 Exchange Server ForestPrep 过程。在此过程中，如果安装程序确定 legacyExchangeDN 的格式不正确，将自动更正此问题。

在 Exchange Server 2007 上更正此错误

  1. 执行 Exchange Server PrepareAD 进程。在此过程中，如果安装程序确定 legacyExchangeDN 的格式不正确，将自动更正此问题。

有关 ForestPrep 进程的详细信息，请参阅 Microsoft 知识库文章 312371"HOW TO:Prepare the Forest by Using ForestPrep in Exchange 2000 Server"（如何使用 Exchange 2000 Server 中的 ForestPrep 准备林）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=312371)。

有关 PrepareAD 进程的详细信息，请参阅"How to Prepare Active Directory and Domains"（如何准备 Active Directory 和域）(http://go.microsoft.com/fwlink/?LinkId=78453)。

有关 legacyExchangeDN 属性及其更改方法的详细信息，请参阅下列 Microsoft 知识库文章：

  • 324606"XADM：如何使用 Legacydn.exe 更正 Exchange 组织或管理组名"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=324606)。

  • 286783XADM：更新 Exchange 2000 Server 中忙/闲数据时的错误消息"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=286783)。

  • 301585XADM：MBconn.exe 问题的解决方法"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=301585)。


旧版域信息出现在纯模式管理组中
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 Exchange 管理组的 msExchLegacyDomain 属性是否包含数据。

Exchange Server 分析工具还查询 Active Directory，以确定每个管理组的 msExchAdminGroupMode 属性值。msExchAdminGroupMode 属性的值为 0 说明管理组处于 Exchange 纯模式。值为 1 说明这是纯 Exchange Server 5.5 环境，而值为 2 则说明这是 Exchange 混合模式。

如果 Exchange Server 分析工具发现 msExchLegacyDomain 属性包含数据，并且 msExchAdminGroupMode 属性值为 0，则显示错误。

将 Exchange 切换到纯模式时，将删除 msExchLegacyDomain 属性。只在仍然有 Exchange Server 5.5 的混合模式 Exchange 组织中使用该属性。实际的属性数据是 Exchange Server 5.5 服务帐户域，如果它出现在纯模式 Exchange 组织内的 msExchLegacyDomain 属性中，将在升级和 Service Pack 安装期间导致故障。实际上，正是由于该属性的出现而导致故障（即使其中没有数据也是如此）。这是因为，Exchange 安装程序使用该属性作为发现 Exchange 组织是处于混合模式还是纯模式的手段。如果存在该属性，那么，假如安装实际是在纯模式下进行的，则 Exchange 安装程序也将运行在混合模式配置下。

如果使用 Active Directory 服务接口 (ADSI) Edit 管理单元从 Active Directory 中手动删除数据，很可能 msExchLegacyDomain 属性仍然存在。

必须通过用 LDP (ldp.exe) 工具手动编辑 msExchLegacyDomain 属性，从该属性中删除此数据。必须使用 LDP 工具或另一个轻型目录访问协议 (LDAP) 版本 3 客户端，这样的工具将从目录中完整地删除数据和属性。在这种情况下，使用 ADSI Edit 管理单元是不够的，因为它只删除数据，但保留了属性。LDP.exe 包含在 Windows® 支持工具软件包中。

警告：
在使用 ADSI Edit、LDP 工具或其他 LDAP 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

删除 msExchLegacyDomain 属性

  1. 启动 LDP.exe。

  2. 在 Connection 菜单上，单击 Connect，在 Connect 对话框中，输入 Exchange 组织所在的 Active Directory 目录林的域控制器名称，再单击 OK。

  3. 在 Connection 菜单上，单击 Bind；在 Bind 对话框中，输入至少在管理组级别拥有 Exchange 管理员（完全控制）权限的凭据，再单击 OK。

  4. 在 View 菜单上，单击 Tree；在 Tree View 对话框上，如果从根域连接，请将该字段留空，否则，请输入 CN=Configuration,DC=Domain_name, DC=Domain_suffix，其中 Domain_name 是 Active Directory 目录林的根域，Domain_suffix 是域后缀，例如 com、net 或 org。单击"确定"。

  5. 在 LDP 的左侧窗格中展开层次结构视图，直到打开管理组。要这样做，请按下列顺序双击节点（注意，LDP 中的每个节点的后面都是完整的可分辨名称 (DN)；为清晰起见，在这里只记下最左侧的 CN）：

    • DC=Domain_name

    • CN=Configuration

    • CN=Services

    • CN=Microsoft Exchange

    • CN=Organization_name

    • CN=Administrative Groups

    • CN=Administrative_group_name

    在 LDP 的详细信息（右）窗格中，向下滚动以查看管理组的属性。如果有 msExchLegacyDomain 属性，则必须删除它。如果有 msExchLegacyDomain 属性，那么很可能也有 msExchLegacyDomain 和 msExchEncryptedPassword 属性。如果它们都在，也必须删除它们。

  6. 在 LDP 的层次结构（左）窗格中，用鼠标右键单击 Administrative_group_name，再单击 Modify。

  7. 在 Modify 对话框中，验证在 Dn 字段中列出的完整 DN 正确标识了需要修改的管理组。它将读取下列各项：CN=Administrative_group_name,CN=Administrative Groups,CN=Organization_name,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Domain_name。

  8. 在 Modify 对话框的 Operations 下，选择 Delete，在 Edit entry 下的 Attribute 字段中，输入 msExchLegacyAccount，再单击 Enter。这会将 msExchLegacyAccount 添加到 Entry List。Entry List 定义了在单击 Run 时将被删除的属性。

  9. 如果 msExchLegacyAccount 或 msExchEncryptedPassword 属性存在于管理组中，那么请按步骤 8 中的说明，将它们添加到 Entry List 中。

  10. 如果 Entry List 包含必须删除的属性，请单击 Run。状态消息将出现在 LDP 详细信息窗格中。

  11. 在 Connection 菜单上，单击 New 以清除 LDP 详细信息窗格。

  12. 导航到 CN=Administrative_group_name，并在对象上双击。复查右侧窗格的内容，验证属性已删除。

有关使用 LDP 工具修改 Active Directory 的详细信息，请参阅 Microsoft 知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。


该管理组的 LegacyExchangeDN 与父组织不匹配
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2006-11-30

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定管理组容器对象的 legacyExchangeDN 属性的格式。如果 Exchange Server 分析工具发现管理组的 legacyExchangeDN 属性与 Exchange 组织的 legacyExchangeDN 不匹配，则会显示错误。

在 Active Directory 中，Exchange 使用 legacyExchangeDN 值来标识 Exchange 对象。legacyExchangeDN 值是一个可分辨名称，它指出该对象在 Exchange 组织中的位置，例如：

/o= organization /ou= administrative group

对于诸如邮箱存储和公用文件夹存储这样的对象，其 legacyExchangeDN 值的一部分是从服务器继承而来的。这意味着，如果服务器值有问题，则其他对象可能继承了相同的问题。

通常，如果管理员尝试直接修改该值，则 legacyExchangeDN 会发生问题。必须使用 Active Directory 服务接口 (ADSI) Edit 管理单元、LDP (ldp.exe) 工具或其他任何轻型目录访问协议 (LDAP) 版本 3 客户端等工具来更正该值。

警告：
在使用 ADSI Edit、LDP 工具或其他 LDAP 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003/Exchange Server 2007。修改 Active Directory 对象的属性的风险由您自己承担。

更正此错误

  1. 使用 Active Directory 编辑器（例如，ADSI Edit）找到 Active Directory 中的管理组对象。

    可以在以下位置找到 legacyExchangeDN 属性：

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=Organization, CN=Administrative Groups, CN= Administrative group

  2. 键入以下形式的新字符串值：

    /o= organization /ou= administrative group

有关使用 LDP 工具的详细信息，请参阅 Microsoft 知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（使用 LDP 实用程序修改 Active Directory 对象属性）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

有关使用 ADSI Edit 的详细信息，请参阅 Windows Server 联机帮助中的主题"Adsiedit.msc:ADSI Edit"。


该管理组的 legacyExchangeDN 无效
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以验证管理组的 legacyExchangeDN 值。如果在 legacyExchangeDN 值中指定的组织或管理组名称与组织或管理组的实际名称不匹配，或者，如果该值的某一部分完全不存在，则会显示此错误。

Exchange 使用 legacyExchangeDN 值在 Active Directory 中标识 Exchange 对象。legacyExchangeDN 值是一个可分辨名称，它指出该对象位于 Exchange 组织中的哪个位置，例如：

/o=organization/ou=administrative group

诸如服务器和文件夹层次结构的对象从管理组那里继承其 legacyExchangeDN 值的一部分。这意味着，如果管理组的值存在问题，那么可能有其他许多对象都继承同样的问题。

通常，legacyExchangeDN 的问题是由于管理员试图直接修改该值而导致的。必须使用 Active Directory 服务接口 (ADSI) Edit 管理单元、LDP (ldp.exe) 工具或其他任何轻型目录访问协议 (LDAP) 版本 3 客户端等工具来更正该值。

警告：
在使用 ADSI Edit、LDP 工具或其他 LDAP 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改这些 Active Directory 对象属性的风险由您自己承担。

更正此错误

  1. 使用 Active Directory 编辑器（例如，ADSI Edit）找到 Active Directory 中的管理组对象。

    可以在以下位置找到 legacyExchangeDN 属性：

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=Organization, CN=Administrative Groups, CN=Administrative group

  2. 键入以下形式的新字符串值：

    /o=organization/ou=administrative group

有关使用 LDP 工具的详细信息，请参阅 Microsoft 知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

有关使用 ADSI Edit 的详细信息，请参阅 Windows Server 联机帮助中的主题"Adsiedit.msc:ADSI Edit"。


存在启用邮件的非通用组
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定环境中的域数。如果 Exchange Server 分析工具在目录林中发现多个分离的 Active Directory 域，则查询每个域，以确定这些域中是否存在一个或多个启用邮件的非通用组。

如果 Exchange Server 分析工具确定多域目录林中存在启用邮件的非通用组，将显示警告。

如果在多域目录林中使用域本地或全局通讯组，下列原因可能会造成电子邮件传递问题：

  • 若要将通讯组展开为各个收件人，则 Exchange 需要与全局编录服务器联系。

  • 尽管全局编录服务器包含每个域中所有类型的组的列表，但是，全局编录服务器不包含在远程域中创建的域本地和全局通讯组的成员身份列表。

  • 如果将邮件发送给全局通讯组，但是在非主域中展开，Exchange 则无法正确地将邮件传递给组成员。

  • 因为分类程序无法展开通讯组，所以当用户在多域目录林中向全局通讯组或启用邮件的安全组发送邮件时，全局通讯组中的用户可能无法收到邮件。

  • 跟踪日志中的最后一个条目是分类程序的提交项。邮件的发件人不接收未送达报告 (NDR)。

要解决此问题并确保电子邮件送达，请在多域环境中使用通用通讯组。将通用通讯组成员复制到每个域中的每个全局编录服务器。

有关此特殊问题以及通用通讯组的常见问题的详细信息，请参阅下列主题：

  • "Administration Guide for Exchange Server 2003"（英文）中的"Using Mail-Enabled Groups in Multi-Domain Environments"（英文）(http://go.microsoft.com/fwlink/?LinkId=47617)。

  • "Active Directory"（英文）中"Understanding Groups"（英文）的"Group scope"（英文）部分 (http://go.microsoft.com/fwlink/?LinkId=51276)。

  • "Administration Guide for Exchange Server 2003"（英文）中的"Guidelines for Creating Query-Based Distribution Groups"（英文）(http://go.microsoft.com/fwlink/?LinkId=47617)。

此外，请参阅下列 Microsoft 知识库文章：

  • 231273"XADM:Message Delivery to Global Groups Does Not Work"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=271930)。

  • 283051"XCON:E-Mail Sent to Mail-Enabled Global Group May Disappear"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=283051)。

  • 231273"Windows 2000 中的组类型和范围使用"(http://support.microsoft.com/?kbid=231273)。


要求更改"邮箱启用用户"系统策略
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2006-08-10

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 Exchange 系统策略对象的 purportedSearch 属性值。purportedSearch 属性表明应用策略时使用的搜索参数。

Exchange Server 分析工具还查询 Active Directory，以确定 Active Directory 中林对象的 msDS-Behavior-Version 属性值，即 NTDS 设置。该值表明 Active Directory 林的功能级别。msDS-Behavior-Version 属性的有效值如下表中所示。

值 | 林的功能级别
0 | Microsoft Windows® 2000 Server 混合模式
1 | Microsoft Windows Server™ 2003 临时模式
2 | Microsoft Windows Server 2003 纯模式

Exchange Server 分析工具还查询 Active Directory，以确定 Windows2003Update 容器的 revision 属性值。该属性的值表明是否已运行 Active Directory 准备实用程序 (ADPrep.exe)。

最后，Exchange Server 分析工具查询 Win32_OperatingSystem Microsoft Windows Management Instrumentation (WMI) 类，以确定 OSProductSuite 关键字的值。OSProductSuite 关键字的值表明计算机上运行的 Windows 的版本。

如果 Exchange Server 分析工具发现下列条件为真，则显示警告：

  • "邮箱启用用户"系统策略的 purportedSearch 属性值不等于 (&(objectCategory=person)(objectClass=user)(mailnickname=*)(homeMdb=*))

  • Active Directory 林的功能级别为 Windows Server 2003 临时模式或 Windows Server 2003 纯模式。

  • Exchange Server 计算机没有运行 Windows Small Business Server 2003。

为了避免邮箱重新连接问题，必须修改系统策略。可以使用 Active Directory 服务接口 (ADSI) Edit (ADSIEdit.msc)、LDP (ldp.exe) 工具或其他 Active Directory 编辑器工具进行此更新。

如果 Windows Server 2003 作为域控制器使用，并且"邮箱启用用户"策略没有更新，Windows Server 2003 中的链接值复制会使收件人更新服务覆盖新用户的 homeMDB 属性的值，并将邮箱重新连接到服务器的第一个存储上。

警告：
在使用 ADSI Edit、LDP 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Windows Server 2003 和/或 Exchange Server 2003 才能解决。修改 Active Directory 对象的属性的风险由您自己承担。
更正此错误

  1. 启动 ADSI Edit。

  2. 双击"配置"容器，依次展开 CN=Services、CN=Microsoft Exchange、CN=<ExchangeOrganizationName>。

  3. 选择 CN=System Policies。

  4. 在右侧窗格中，右键单击 CN=Mailbox Enable User，再选择"属性"。

  5. 向下滚动以选择 purportedSearch 属性，再单击"编辑"。

  6. 清除该属性，再为其配置以下筛选器：

    (&(objectCategory=person)(objectClass=user)(mailnickname=*)(homeMdb=*))

    注意：
    步骤 6 中所示的筛选器已进行换行，以便于阅读。确保输入的筛选器没有任何空格或回车符。

  7. 再次单击"确定" 保存更改，再关闭 ADSI Edit。

有关使用 LDP 工具的详细信息，请参阅 Microsoft 知识库文章 260745"XADM: Using the LDP Utility to Modify Active Directory Object Attributes"（使用 LDP 工具来修改 Active Directory 对象属性）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

有关此问题及其影响的详细信息，请参阅 Microsoft 知识库文章 903291"Recipient Update Service may overwrite the value of the homeMDB attribute for new Exchange Server 2003 users"（收件人更新服务可能会覆盖新的 Exchange Server 2003 用户的 homeMDB 属性值）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=903291)。


全局编录上禁用了 MAPI 接口
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定该注册表项是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NTDS\Parameters\Initialize MAPI interface

如果 Exchange Server 分析工具发现 Initialize MAPI interface 注册表项存在并配置为任意数字值，则 Exchange Server 分析工具将显示错误。

如果 Initialize MAPI interface 注册表项存在，Microsoft Office Outlook® 客户端将无法与此服务器上的通讯簿联系。要更正此问题，必须删除 Initialize MAPI interface 注册表项。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\NTDS\Parameters\Initialize MAPI interface

  3. 用鼠标右键单击 Initialize MAPI interface 注册表项，然后选择"删除"。

  4. 关闭注册表编辑器，然后重新启动 Exchange 服务器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Initialize MAPI interface 注册表项的详细信息，请参阅 Microsoft 知识库文章 275127"XADM: How to Configure Exchange Server 5.5 to Run on a Domain Controller that is a Global Catalog"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=275127)


MaxActiveQueries 已修改
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定最多可以同时处理的轻型目录访问协议 (LDAP) 查询的数目。该值是通过检查当前的 LDAP 管理策略来获得的。具体地说，Exchange Server 分析工具检查 MaxActiveQueries 是否存在。如果 Exchange Server 分析工具确定 MaxActiveQueries 存在并配置为 20 以外的任意值，则显示非默认配置消息。

LDAP 管理限额在 Active Directory 的操作功能与其性能之间进行平衡。这些限额防止特定操作对服务器的性能造成不利的影响。将此设置提高到默认值以上会对 Active Directory 基础结构造成不利的影响。

LDAPAdminLimits 属性的 MaxActiveQueries 值控制默认查询策略最多可以同时处理的 LDAP 查询的数目。默认情况下，限制在 20 个活动的查询以内。如果达到此限额，Active Directory 将返回"LDAP_ADMIN_LIMIT_EXCEEDED"并且不会处理额外的 LDAP 查询。

启动 Ntdsutil.exe

  1. 单击"开始"，再单击"运行"。

  2. 在"打开"文本框中，键入 ntdsutil，再按 Enter。要查看帮助，可以随时在命令提示符处键入 ?。

查看策略设置

  1. 在 Ntdsutil.exe 命令提示符处，键入 LDAP policies，再按 Enter。

  2. 在 LDAP 策略命令提示符处，键入 connections，再按 Enter。

  3. 在服务器连接命令提示符处，键入 connect to server DNS name of server，再按 Enter。您要连接到当前使用的服务器。

  4. 在服务器连接命令提示符处，键入 q，再按 Enter 返回上一级菜单。

  5. 在 LDAP 策略命令提示符处，键入 Show Values，再按 Enter。

    将显示已存在的策略。
注意：
该过程只显示默认域策略设置。您看不到自己应用的策略设置。

更改策略设置

  1. 在 Ntdsutil.exe 命令提示符处，键入 LDAP policies，再按 Enter。

  2. 在 LDAP 策略命令提示符处，键入 Set MaxActiveQueries to 20，再按 Enter 键。

    可以使用 Show Values 命令来验证更改。

  3. 要保存更改，请使用 Commit Changes。

  4. 完成后，键入 q，再按 Enter。

  5. 要退出 Ntdsutil.exe，请在命令提示符处，键入 q，再按 Enter。

有关配置 LDAP 策略的详细信息，请参阅 Microsoft 知识库文章 315071"How to view and set lightweight directory access protocol policies by using Ntdsutil.exe in Windows 2000"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=315071)。


MaxPageSize 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具通过检查 Active Directory® 目录服务中查询策略容器内默认查询策略对象的属性，验证域控制器的轻型目录访问协议 (LDAP) 配置。如果 Exchange Server 分析工具确定 LDAPAdminLimits 属性的 MaxPageSize 值已从其默认值 1000 更改为其他值，则显示非默认配置消息。

LDAP 管理限额在 Active Directory 的操作功能与其性能之间进行平衡。这些限制可以防止特定的操作对服务器性能造成负面影响，还会使服务器对拒绝服务攻击拥有防御能力。将该设置增加到它的默认值以上会对 Active Directory 基础结构造成负面影响。

实现 LDAP 策略需要使用 queryPolicy 类的对象。可以在查询策略容器中创建查询策略对象，该容器是配置命名上下文中的目录服务容器的子容器。

LDAPAdminLimits 属性的 MaxPageSize 值用于控制执行 LDAP 查询时可以返回的记录数。默认值为 1000 个记录。如果要返回多于 1000 个的项，则 Active Directory 将检测到该最大值，并且不返回任何内容。

这项限制控制了可支持的几种 Active Directory 对象类型的数目。例如，每个组织可以有最多 1000 个服务器、最多 1000 个管理组和最多 1000 个地址列表；每个管理组可以有最多 1000 个路由组；每个路由组可以有最多 1000 个连接器。

除非 Microsoft 产品支持服务指导您使用其他值，否则您应当将该值重置回 1000。

启动 Ntdsutil.exe

  1. 单击"开始"，再单击"运行"。

  2. 在"打开"文本框中，键入 ntdsutil，再按 Enter。要查看帮助，可以随时在命令提示符下键入 ?。

查看策略设置

  1. 在 Ntdsutil.exe 命令提示符处，键入 LDAP policies，再按 Enter。

  2. 在 LDAP 策略命令提示符处，键入 connections，再按 Enter。

  3. 在服务器连接命令提示符处，键入 connect to server DNS name of server，再按 Enter。需要连接到当前使用的服务器。

  4. 在服务器连接命令提示符下，键入 q，再按 Enter 返回上一个菜单。

  5. 在 LDAP 策略命令提示符处，键入 Show Values，再按 Enter。

    将显示已存在的策略。

    注意：
    该过程只显示默认域策略设置。如果应用您自己的策略设置，则无法看见它。

更改策略设置

  1. 在 Ntdsutil.exe 命令提示符处，键入 LDAP policies，再按 Enter。

  2. 在 LDAP 策略命令提示符处，键入 Set MaxPageSize to 1000，再按 Enter。

    可以使用 Show Values 命令来验证更改。

  3. 若要保存更改，请使用 Commit Changes。

  4. 完成后，请键入 q，再按 Enter。

  5. 若要退出 Ntdsutil.exe，请在命令提示符处键入 q，再按 Enter。

有关配置 LDAP 策略的详细信息，请参阅 Microsoft 知识库文章 315071"How to view and set lightweight directory access protocol policies by using Ntdsutil.exe in Windows 2000"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=315071)。


MaxPageSize 的设置太高
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Query-Policies 容器中 Default Query Policy 对象的 LDAPAdminLimits 属性的 MaxPageSize 值。如果 Exchange Server 分析工具确定 MaxPageSize 的值大于 2,500，则显示错误。

轻型目录访问协议 (LDAP) 管理限额在 Active Directory 的操作功能与其性能之间进行平衡。这些限额防止特定操作对服务器的性能造成不利的影响。限额还使服务器对拒绝服务攻击拥有防御能力。将该设置增加到它的默认值以上会对 Active Directory 基础结构造成负面影响。

实现 LDAP 策略需要使用 queryPolicy 类的对象。可以在查询策略容器中创建查询策略对象，该容器是配置命名上下文中的目录服务容器的子容器。

LDAPAdminLimits 属性的 MaxPageSize 值用于控制执行 LDAP 查询时可以返回的记录数。默认数目为 1,000 个记录。如果要返回多于 1,000 个的项，则 Active Directory 将检测到该最大值，并且不返回任何内容。

这项限制控制了可支持的几种 Active Directory 对象类型的数目。例如，每个组织最多可以有 1000 台服务器、1000 个管理组和 1000 个地址列表。每个管理组最多可以有 1000 个路由组，每个路由组最多可以有 1000 个连接器。

除非 Microsoft 产品支持服务指导您使用其他值，否则您应当将该值重置回 1,000。

启动 Ntdsutil.exe

  1. 单击"开始"，再单击"运行"。

  2. 在"打开"文本框中，键入 ntdsutil，再按 Enter 键。要查看帮助，可以随时在命令提示符处键入 ?。
查看策略设置

  1. 在 Ntdsutil.exe 命令提示符处，键入 LDAP policies，再按 Enter 键。

  2. 在 LDAP 策略命令提示符处，键入 connections，再按 Enter 键。

  3. 在服务器连接命令提示符处，键入 connect to server <服务器的 DNS 名称>，再按 Enter 键。连接到当前使用的服务器。

  4. 在服务器连接命令提示符处，键入 q，再按 Enter 键返回上一菜单。

  5. 在 LDAP 策略命令提示符处，键入 Show Values，再按 Enter 键。

    将显示已存在的策略。

    注意：
    该过程只显示默认域策略设置。您看不到自己应用的策略设置。
更改策略设置

  1. 在 Ntdsutil.exe 命令提示符处，键入 LDAP policies，再按 Enter 键。

  2. 在 LDAP 策略命令提示符处，键入 Set MaxPageSize to 1000，再按 Enter 键。

    可以使用 Show Values 命令来验证更改。

  3. 要保存更改，请使用 Commit Changes。

  4. 完成后，请键入 q，再按 Enter 键。

  5. 要退出 Ntdsutil.exe，请在命令提示符处，键入 q，再按 Enter 键。

有关配置 LDAP 策略的详细信息，请参阅 Microsoft 知识库文章 315071"How to view and set LDAP policy in Active Directory by using Ntdsutil.exe"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=315071)。


存在的地址列表数超过 800 个
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Active Directory 内 All Address Lists 组中的地址列表数是否大于 800。如果 Exchange Server 分析工具发现 Exchange Server 组织中的地址列表数大于 800，则将显示警告。

建议将 All Address Lists 组中的地址列表数减少到低于 800 个，避免在收件人更新服务操作期间出现严重的延迟。如果 Exchange Server 组织中的地址列表数超过 800 个，收件人更新服务在标记启用邮件的对象时，将出现严重的延迟。

此外，也可以禁用收件人更新服务，并使用脚本来处理收件人更新服务所执行的任务。

有关禁用收件人更新服务的详细信息，请参阅 Microsoft 知识库文章 296479"Requirements for Disabling the Recipient Update Service"（英文）(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=296479)。

有关地址列表和收件人更新服务的详细信息，请参阅"Exchange Server 2003 管理指南"中的"管理收件人和收件人策略"(http://www.microsoft.com/downloads/details.aspx?FamilyID=98e45481-1458-4809-97d6-50d8aeebd8a1&DisplayLang=zh-cn)。


存在超过 800 个全局地址列表
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Active Directory 内 All Global Address Lists 组中的地址列表数是否大于 800。如果 Exchange Server 分析工具发现 Exchange Server 组织中的全局地址列表数大于 800，则会显示警告。

建议将 All Global Address Lists 组中的地址列表数减少到低于 800 个，以避免在收件人更新服务操作期间出现严重的延迟。如果 Exchange Server 组织中的全局地址列表数超过 800 个，则收件人更新服务在标记启用邮件的对象时，将出现严重的延迟。

此外，也可以禁用收件人更新服务，并使用脚本来处理收件人更新服务所执行的任务。

有关禁用收件人更新服务的详细信息，请参阅 Microsoft 知识库文章 296479"Requirements for Disabling the Recipient Update Service"（英文）(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=296479)。

有关地址列表和收件人更新服务的详细信息，请参阅"Exchange Server 2003 管理指南"中的"管理收件人和收件人策略"(http://www.microsoft.com/downloads/details.aspx?FamilyID=98e45481-1458-4809-97d6-50d8aeebd8a1&DisplayLang=zh-cn)。


msExchHomeMDB 属性编入了索引
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定是否已将 Routing Group Back-Link 属性配置为编入 Active Directory 中的索引。具体地说，Exchange Server 分析工具查询 Active Directory 以确定 msExchHomeMDB 属性的当前索引值。该属性是 Active Directory 中的已启用邮箱对象的属性。默认情况下，不将此属性编入索引。如果 Exchange Server 分析工具发现该属性配置为编入索引，则会显示非默认配置消息。

将 msExchHomeMDB 属性编入索引的效果非常小。在内存中维持该索引后，全局编录服务器上使用的内存量的增加幅度很小。

如果您的组织满足下列任何条件，则将此属性编入索引会有益：

  • 有许多已启用邮件的对象。在规模非常大的环境中（具有 100,000 个或更多已启用邮件的对象），将此属性编入索引也会提高 Exchange 系统管理器以及可以使用 Active Directory 用户和计算机执行的 Exchange 特定任务的性能。

  • 如果您经常使用 Exchange 邮箱合并程序 (ExMerge)，可能已经发现在偶尔的情况下，将 msExchHomeMDB 属性编入索引在使用 ExMerge 的中到大型环境中是必要的。将 msExchHomeMDB 属性编入索引已被证明可提高 ExMerge 的速度和性能。

如果不满足上述任何条件，则建议将设置改回默认值，即不编入索引。

更正此错误

  • 不需要执行任何操作，因为 Exchange Server 分析工具生成的消息仅用于提供信息。


msExchRoutingGroupMembersBL 属性编入了索引
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定是否已将 Routing Group Back-Link 属性配置为编入 Active Directory 中的索引。具体地说，Exchange Server 分析工具检查以下 Active Directory 对象，以确定 msExchRoutingGroupMembersBL 属性的当前索引值：

CN=Configuration,DC=domain,DC=com, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Administrative Groups, CN=AdministrativeGroupName, CN=Routing Groups, CN=RoutingGroupName

默认情况下，不将此属性编入索引。如果 Exchange Server 分析工具发现该属性配置为编入索引，则会显示非默认配置消息。

在包含大量路由组的分布式或分支机构的 Exchange 部署中，如果将该属性保留为不编入索引，则会导致性能降低。例如，如果 Exchange 组织中有数百个路由组，那么，您可能每隔 15 分钟在一个或多个全局编录服务器上注意到活动有所增加。发生这种活动增加的原因是 Exchange 中的 DSAccess 组件重复读取路由组配置。在极端情况下，这种活动可能会占用全局编录。

若要尽量减少全局编录的这种负担，可以将路由组 Back-Link 属性编入索引，这样可以减少 DSAccess 读取路由组信息所耗费的时间，而且减少了这种活动对全局编录带来的负担。

更正此错误

  • 不需要执行任何操作，因为 Exchange Server 分析工具生成的消息仅用于提供信息。

有关调整 Exchange 以获得最佳性能的详细信息，请参阅"Exchange Server 2003 性能和可伸缩性指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&DisplayLang=zh-cn)。


发现多个公用文件夹层次结构
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchPFTreeType 属性值为 1 的公用文件夹层次结构的数量。msExchPFTreeType 属性值为 1 表明公用文件夹层次结构是为 MAPI 客户端指定的公用文件夹层次结构。如果 Exchange Server 分析工具确定在 Exchange 组织中包含多个 msExchPFTreeType 属性值为 1 的公用文件夹层次结构，Exchange Server 分析工具将显示错误。

该错误表明在 Exchange 组织中发现了多个 MAPI 客户端的公用文件夹层次结构。出现多个 MAPI 客户端的公用文件夹层次结构可能会造成问题。

若要解决该问题，可以使用 Active Directory 编辑工具将除 MAPI 公用文件夹层次结构以外的所有公用文件夹层次结构的 msExchPFTreeType 属性值设置为 0。如有比要，请重新配置 Exchange 服务器上的邮箱存储，将其指向 MAPI 公用文件夹层次结构作为 MAPI 客户端的默认公用文件夹存储。

下列工具属于 Active Directory 编辑工具：

  • Active Directory 服务接口 (ADSI) Edit (AdsiEdit.msc)

  • LDP (ldp.exe) 工具

警告：
在使用 ADSI Edit、LDP 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。
更正此错误

  1. 使用 Active Directory 编辑工具在 Active Directory 中找到公用文件夹对象。这些公用文件夹对象可以在下列位置找到： CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdminGroupName>, CN=Folder Hierarchies

  2. 通过输入新值 0，更改除 MAPI 公用文件夹层次结构以外的所有公用文件夹层次结构对象的 msExchPFTreeType 属性。

  3. 关闭 Active Directory 编辑器。

  4. 打开 Exchange 系统管理器。

  5. 要访问每个邮箱存储的属性，单击"管理组"，再依次展开您的管理组、"服务器"、您的服务器，然后展开您的存储组。然后，用鼠标右键单击要更改属性的邮箱存储，再选择"属性"。

  6. 在"常规"选项卡上，对"默认公用存储"字段单击"浏览"。

  7. 选择 MAPI 公用文件夹层次结构，再单击两次"确定"保存更改。

  8. 对每个邮箱存储重复步骤 5-7。

有关使用 LDP 工具修改 Active Directory 的详细信息，请参阅 Microsoft 知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

有关 MAPI 和应用程序的公用文件夹层次结构的详细信息，请参阅下列资源：

  • Microsoft 知识库文章 258509"Description of public folder tree types in Exchange 2000 Server and in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258509)

  • Exchange Team Blog 条目"How mail-enabled Public Folders work"（英文）(http://go.microsoft.com/fwlink/?LinkId=41913)


推荐的"NeverPing"参数
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2006-03-16

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定为每个域建立的信任数。如果每个域中至少有一个域控制器设置了 NeverPing 值，此工具就会显示最佳实践信息。

如果 Exchange Server 2003 环境中的各个域出现以下情况，Exchange Server 分析工具就会显示警告：

  • 该域建立的信任超过 50 个

  • 该域中的域控制器的 NeverPing 注册表子项值被设置为 Null (0)

此警告表明 LSASS.exe 进程或验证域用户的进程可能被延迟。本地安全授权子系统服务 (LSASS) 是 Microsoft Windows 操作系统中的一个进程，用于验证登录到基于 Windows 的计算机或服务器的用户。

若要解决此问题，将域控制器的 NeverPing 注册表子项值设置为 1，如下所示。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
在 Exchange 2003 环境中为域控制器设置 NeverPing 参数

  1. 单击"开始"，再单击"运行"，键入 regedit，然后单击"确定"。

  2. 找到以下注册表子项：HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters。

  3. 用鼠标右键单击此子项，指向"新建"，单击"DWORD 值"，键入 NeverPing，然后按 Enter。

  4. 用鼠标右键单击 NeverPing，再单击"修改"，在数值数据框中键入 1，然后单击"确定"。

  5. 退出注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关此问题以及如何为域控制器设置 NeverPing 参数的详细信息，请参阅 Microsoft 知识库文章 825107"The Lsass.exe process may stop responding if you have many external trusts on a Windows 2000 Server-based domain controller"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=825107)。

注意：
尽管该文介绍 Microsoft Windows 2000 Server，但其中的信息同样适用于 Windows Server™ 2003。文中提及的更新对于 Windows Server 2003 不是必要的。


有更新版本的 Active Directory 连接器可用
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个连接协议对象的 versionNumber 属性值。versionNumber 属性表示计算机上运行的 Active Directory 连接器 (ADC) 的版本。

Exchange Server 分析工具还查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Active Directory 连接器 (ADC) 文件 Adc.exe 的 Version 关键字的值。Version WMI 关键字指示此文件的内部版本号。

如果下列条件为真，则 Exchange Server 分析工具将显示警告：

  • 连接协议对象的 versionNumber 属性设置为 16973842。

  • 连接协议对象的 versionNumber 属性设置为 16973843，并且 Adc.exe 的 Version 关键字的值小于 7250.0。

如果值为 16973842，则指示计算机运行的是通过 Exchange Server 2003 CD 提供的原始商业版本的 ADC ；如果值为 16973843，并且 Adc.exe 的 Version 关键字的值小于 7250.0，则指示计算机运行的是 Exchange Server 2003 Service Pack 1 (SP1) 版本的 ADC。

Exchange Server 2003 Service Pack 2 中提供了更新版本的 ADC。建议的最佳做法是使用最新版本的 ADC。

解决此警告问题

  1. 转到 Service Pack 2 for Exchange Server 2003 http://go.microsoft.com/fwlink/?LinkId=54751 以下载最新版本的 ADC。

  2. 卸载现有版本的 ADC 并安装更新版本的 ADC。

有关 ADC 连接协议的详细信息，请参阅下列 Microsoft 知识库文章：

  • 823601"Active Directory 连接器在整个组织内的要求和影响"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180"Active Directory Connector Connection Agreement Requirements for Mixed Administrative Groups"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)

  • 317721"XADM:Exchange Server 5.5 Mailbox Owner Rights Are Removed When You Change the ADC Connection Agreement from a One-Way Connection Agreement to a Two-Way Connection Agreement"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721)


组织中不存在该连接协议的指定 Exchange 服务器
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个连接协议对象的 msExchServer2NetworkAddress 属性的值。msExchServer2NetworkAddress 属性代表了参与该连接协议的服务器的网络地址。Exchange Server 分析工具将枚举 Active Directory 中的管理组，以确定是否为管理组的连接协议成员列出该服务器名称。如果该服务器名称没有在管理组中列出，则显示错误。

该错误说明这是一个孤立的连接协议。如果 Exchange Server 计算机已退役，则会发生这种情况。如果 Exchange Server 计算机已从组织中删除，则应当通过 Active Directory 连接器 (ADC) 管理工具在连接协议的属性上的"连接"选项卡中更改 Exchange 服务器名称。如果被怀疑的 Exchange 服务器因为维护或某些其他已知原因而处于脱机状态，则可以忽略该错误。

更正此错误

  1. 单击"开始"，单击"程序"，单击"管理工具"，再单击"Active Directory 连接器"。

  2. 在左侧窗格中，单击要修改的连接协议所在的 ADC 服务器。

  3. 在右侧窗格中，用鼠标右键单击想要修改的连接协议，再单击"属性"。

  4. 单击"连接"选项卡。

  5. 将用于连接的服务器的名称更改为一个存在的服务器的名称。

有关 ADC 连接协议的详细信息，请参阅下列 Microsoft 知识库文章：

  • 823601"Active Directory 连接器在整个组织内的要求和影响"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180"Active Directory Connector Connection Agreement Requirements for Mixed Administration Groups"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)


组织中不存在指定的脱机通讯簿服务器
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2006-12-03

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定脱机通讯簿配置对象的 offLineABServer 属性值。offLineABServer 属性是单值的可分辨名称属性，该属性存储负责生成脱机通讯簿的 Exchange Server 计算机的可分辨名称。

Exchange Server 分析工具还检查 Active Directory 中 Exchange Server 对象的 distinguishedName 属性值。

如果 Exchange Server 分析工具发现在 offLineABServer 属性中列出的服务器与所找到的 Exchange Server 对象的 distinguishedName 属性不匹配，并且 offLineABServer 属性不包含字符串"DEL:"，则显示错误。

对于每个脱机通讯簿，Exchange 将在指定服务器上的一组公用文件夹中生成和存储脱机通讯簿文件。如果看见该消息，则意味着在脱机地址列表对象中指定的服务器不存在。如果旧的脱机通讯簿服务器已退役或从拓扑结构中错误删除，则可能发生这种情况。必须在指定新的服务器之后，Exchange 才会生成脱机通讯簿。

在 Exchange 2000 Server 和 Exchange Server 2003 上更正此错误

  1. 在 Exchange 系统管理器的"收件人"下，单击"脱机地址列表"。在右侧窗格中，右键单击"默认脱机地址列表"（或产生该消息的任何其他脱机地址列表），再单击"属性"。

  2. 在"常规"选项卡的"脱机地址列表服务器"下，单击"浏览"，再单击想要使用的服务器。

在 Exchange Server 2007 上更正此警告

  1. 打开 Exchange 管理控制台。

  2. 展开 Microsoft Exchange，展开"组织配置"，然后选择"邮箱"。

  3. 在结果窗格中，单击"脱机通讯簿"选项卡。

  4. 在"脱机通讯簿"选项卡上，选择"默认脱机通讯簿"。在操作窗格中，单击"移动"以启动"移动脱机通讯簿"向导。通过此向导，可以将 OAB 生成移动到其他服务器。它还会将现有的 OAB 文件复制到指定的服务器。

使用 Exchange 命令行管理程序来设置将承载脱机通讯簿生成的服务器

  • 运行下列命令：

    复制代码
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    其中：<OAB> 是可分辨名称 (DN)、域\帐户名称或 OAB 的 GUID，而 <Server> 则指定了将在其上执行所选操作的 Exchange 服务器。

    例如，若要将 OAB 生成移至 SERVER01.，应输入：
复制代码
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

有关在 Exchange Server 2003 中使用脱机通讯簿的详细信息，请参阅"Working with the Exchange Server 2003 Store"（使用 Exchange Server 2003 存储）中的"Configuring Exchange Server 2003 Offline Address Books"（配置 Exchange Server 2003 脱机通讯簿）(http://go.microsoft.com/fwlink/?LinkId=47595)。

有关在 Exchange Server 2007 中使用脱机通讯簿的详细信息，请参阅"Organization Configuration > Mailbox > Offline Address Books"（组织配置 > 邮箱 > 脱机通讯簿）(http://go.microsoft.com/fwlink/?LinkId=79247)。


组织中不存在指定的收件人更新服务 Exchange 服务器
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2006-03-29

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定目录中所有 Exchange Server 对象的 distinguishedName 属性值。Exchange Server 分析工具还查询 Active Directory，以确定目录中每个 Recipient Update Service 对象的 msExchAddressListServiceLink 属性值。msExchAddressListServiceLink 属性是从地址列表服务到它应当运行于其上的 Exchange Server 计算机的链接。如果 Exchange Server 分析工具发现 msExchAddressListServiceLink 属性值不包含字符串"DEL："，并且该属性与目录中任何 Exchange Server 对象的 distinguishedName 属性都不匹配，则显示错误。

每个收件人更新服务实例都与一个运行收件人更新服务的 Exchange Server 计算机关联。如果收到该消息，则说明收件人更新服务实例与不存在于 Exchange 组织中的 Exchange Server 计算机关联。该服务器可能已退役，或者已从拓扑结构中删除。

要让该收件人更新服务实例运行，必须将它与现有的 Exchange 服务器关联。

更正此错误

  1. 打开 Exchange 系统管理器。

  2. 在"收件人"下，单击"收件人更新服务"。在右侧窗格中，用鼠标右键单击合适的收件人更新服务实例，再单击"属性"。

  3. 在"常规"选项卡上的"Exchange Server"下，单击"浏览"，并指定要运行该实例的新服务器。

  4. 单击"确定"，然后再次单击"确定"，以使更改生效。

  5. 关闭 Exchange 系统管理器。

有关收件人更新服务的详细信息，请参阅下列主题和 Microsoft 知识库文章：

  • "Exchange Server 2003 管理指南"中的"在 Exchange Server 2003 中管理收件人和收件人策略"(http://www.microsoft.com/downloads/details.aspx?FamilyID=98e45481-1458-4809-97d6-50d8aeebd8a1&DisplayLang=zh-cn)

  • 328738"XADM:How the Recipient Update Service Applies Recipient Policies"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828"How the Recipient Update Service Populates Address Lists"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127"XADM:How to Check the Progress of the Recipient Update Service"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770"XADM:Tasks Performed by the Recipient Update Service"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


在该管理组中没有检测到所指定的路由组主服务器
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个路由组容器的 msExchRoutingMasterDN 属性的值。如果 Exchange Server 分析工具发现 msExchRoutingMasterDN 属性的值不包含有效的服务器名称，并且该属性不包含字符串"DEL:"，则会显示警告。

如果以前的路由组主服务器已退役，或从拓扑结构中不正确地删除，则会发生该问题。如果没有路由组主服务器，Exchange 将无法正确更新或维护路由拓扑结构。

创建路由组时，该路由组中的第一台服务器将被指定为"路由组主服务器"角色。路由组主服务器维护其路由组的最新链接状态信息，并将它传播到路由组内的其他服务器。路由组主服务器仅监视写入到 Active Directory 中的路由配置中与其路由组有关的部分。成员服务器可以将任何连接器状态或服务器可用性信息传递到路由组主服务器。例如，如果成员服务器试图通过连接器连接另一个路由组中的另一台服务器，而该链接不可用，则成员服务器会立即通知路由组主服务器。同样，当非主服务器收到新的链接状态信息时，会立即将连接器状态信息传递到路由组主服务器，以便其他服务器可以收到有关路由变化的信息。

解决此警告问题

  1. 在 Exchange 系统管理器的"管理组"下，展开管理组，再展开"路由组"。

  2. 展开路由组，再单击"成员"。

  3. 在右侧窗格中，用鼠标右键单击想要将其配置为路由组主服务器的 Exchange 计算机，再单击"设为主服务器"。

有关路由组主服务器的详细信息，请参阅"Exchange Server 2003 传输和路由指南"中的"配置路由拓扑"(http://go.microsoft.com/fwlink/?linkid=47579)。


公用文件夹连接协议的数目小于配置连接协议的数目
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定在 Active Directory 和每个 Exchange Server 5.5 站点之间是否具有公用文件夹连接协议。为此，它同时查询公用文件夹连接协议的数目与配置连接协议的数目。如果 Exchange Server 分析工具确定公用文件夹连接协议的数目小于配置连接协议的数目，则显示警告。

此警告意味着至少在一个 Exchange Server 5.5 站点与 Active Directory 之间没有公用文件夹连接协议，因此该站点无法将公用文件夹的目录对象复制到 Active Directory。因此，邮件既不能从 Exchange 2000 Server 或 Exchange Server 2003 邮箱流动至 Exchange Server 5.5 公用文件夹，也不能从 Exchange Server 5.5 邮箱流动至已启用邮件的 Exchange 2000 Server 或 Exchange Server 2003 公用文件夹。

配置连接协议是当您在纯 Exchange Server 5.5 站点中安装 Exchange 2000 Server 或 Exchange Server 2003 计算机时自动生成的。公用文件夹连接协议是用户定义的。如果每个 Exchange Server 5.5 站点与 Active Directory 之间都存在公用文件夹连接协议，则公用文件夹连接协议至少与配置连接协议一样多。

创建公用文件夹连接协议

  1. 在 Active Directory 连接器 (ADC) 服务器上，启动 Active Directory 连接器管理器。（在"开始"菜单上，指向"程序"或"所有程序"，再指向"Microsoft Exchange"，然后单击"Active Directory 连接器"。）

  2. 在控制台树中，单击"Active Directory 连接器"。右侧窗口中列出连接协议。使用此列表确定哪些站点没有公用文件夹连接协议。

  3. 在"操作"菜单上，指向"新建"，再单击"公用文件夹连接协议"以显示"属性"对话框。

  4. 在"常规"选项卡上的"名称"中，为该连接协议键入一个名称。

  5. 在"Active Directory 连接器服务"框中，选择要运行该连接协议的服务器。

  6. 在"连接"选项卡上，选择要复制公用文件夹对象的 Active Directory 服务器和 Exchange Server 5.5 服务器，并为每个服务器指定适当的帐户和凭据。

  7. 在"日程安排"选项卡上，选择复制日程安排。

  8. 单击"确定"。

有关公用文件夹和配置连接协议的详细信息，请参阅下列 Microsoft 知识库文章：

  • 264889"XADM:Public Folder Connection Agreements"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=264889)

  • 281223"Understanding Connection Agreements in Exchange"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=281223)。


脱机通讯簿生成设置为连续更新
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2006-12-04

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定是否已针对脱机通讯簿的生成配置了 msExchOAB 类中的 offLineABSchedule 属性值。offLineABSchedule 属性确定脱机地址列表的日程安排。如果 Exchange Server 分析工具发现为脱机地址列表生成脱机通讯簿的日程安排已设置为连续更新，则 Exchange Server 分析工具将显示错误。

"脱机通讯簿"是存储脱机地址列表集合的容器。管理员配置可用的脱机通讯簿。Microsoft Office Outlook® 2003 和 Outlook 2007 用户可以选择要下载的脱机地址列表。MAPI 客户端（例如 Outlook 2003 和 Outlook 2007）可以下载脱机地址列表。这样，即使用户与 Exchange 服务器断开，也可以编写电子邮件。

可以安排脱机地址列表的更新时间。但是，请确保配置的更新日程安排为完成脱机地址列表的生成留出充足的时间，然后再开始下一次更新。例如，如果符合下列条件，每个更新间隔之间必须至少留出四个小时：

  • 在 24 小时的期限内指定三次更新。

  • 更新脱机地址列表需要四个小时。

通常不建议频繁地更新，因为频繁更新可能会以下列方式影响客户端和服务器的性能：

  • 服务器必须更频繁地生成脱机通讯簿。可能需要数个小时才能完成更新，视 Active Directory 的大小而定。

  • 对于每次更新，Outlook 必须在本地计算机上备份脱机通讯簿，并应用从服务器上获取的增量更改。如果本地计算机上的脱机通讯簿为 150 MB，则 Outlook 必须为每次更新备份这么大量的数据。

  • Outlook 具有"限制"机制，可以在检测到用户活动时减慢脱机通讯簿的更新速度。如果有连续的用户活动，脱机通讯簿的大小会影响更新所需的时间。此时间期限可能从一个小时到八个小时不等。

如果要提高更新的频率，请确保脱机通讯簿适当小一些。适当的未压缩大小从 1 MB 到 25 MB。

安排更新 Exchange 2000 Server 和 Exchange Server 2003 中脱机地址列表的时间

  1. 在"系统管理员"中，双击"收件人"，再单击"脱机地址列表"。

  2. 在详细信息窗格中，双击要设置更新日程安排的脱机地址列表。

    1. 若要选择预先配置的更新间隔，在"常规"选项卡中，从"更新间隔"下拉列表中选择提供的一个间隔。

      重要信息：
      如果从下拉列表中选择"从不运行"，则不会更新脱机地址列表。
    2. 若要设置特定的更新日程安排，请单击"自定义"。在"日程安排"对话框中，在显示的日期和时间网格上设置更新日程安排，再单击"确定"。

在 Exchange Server 2007 上更正此警告

  1. 打开 Exchange 管理控制台。

  2. 展开 Microsoft Exchange，展开"组织配置"，然后选择"邮箱"。

  3. 在结果窗格中，单击"脱机通讯簿"选项卡。

  4. 在"脱机通讯簿"选项卡上，选择"默认脱机通讯簿"。在操作窗格中，单击"属性"。

  5. 在"常规"选项卡上，从"更新日程安排"下拉列表中选择运行时间，或单击"自定义"以设置自定义安排。

  6. 单击"确定"保存更改。
使用 Exchange 命令行管理程序来设置脱机通讯簿生成日程安排

  • 运行下列命令：

    复制代码
    Set-OfflineAddressBook -Identity <OAB Name> -Schedule <Schedule>

    其中：<OAB> 是可分辨名称 (DN)、域\帐户名、或者 OAB 的 GUID，<日程安排> 指定开始 OAB 生成的日程安排时间，该格式是"起始日.小时:分钟 [AM/PM]"。日期可以使用如下值：

    • 该日的全名

    • 该日的缩写名称

    • 从 0 至 6 的整数，其中 0 = 星期日

    如果想要使用 24 小时制，请忽略 AM/PM。

    例如，若将默认脱机通讯簿生成时间安排设置为每日 1AM 至 3AM，应该输入：
复制代码
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -Schedule 0.01:00-0.03:00,1.01:00-1.03:00,2.01:00-2.03:00,3.01:00-3.03:00,4.01:00-4.03:00,5.01:00-5.03:00,6.01:00-6.03:00

有关详细信息，请参阅"Offline Address Book Best Practices Guide"（脱机通讯簿最佳实践指南）(http://go.microsoft.com/fwlink/?LinkId=47583)。

有关在 Exchange Server 2003 中使用脱机通讯簿的详细信息，请参阅"Working with the Exchange Server 2003 Store"（使用 Exchange Server 2003 存储）中的"Configuring Exchange Server 2003 Offline Address Books"（配置 Exchange Server 2003 脱机通讯簿）(http://go.microsoft.com/fwlink/?LinkId=47595)。

有关在 Exchange Server 2007 中使用脱机通讯簿的详细信息，请参阅"Organization Configuration > Mailbox > Offline Address Books"（组织配置 > 邮箱 > 脱机通讯簿）(http://go.microsoft.com/fwlink/?LinkId=79247)。


脱机通讯簿生成安排被设置为"从不"
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2006-12-04

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定脱机通讯簿配置对象的 offLineABSchedule 属性值。offLineABSchedule 属性表示在 Active Directory 的地址列表容器中，默认脱机地址列表对象的脱机通讯簿生成安排。如果 Exchange Server 分析工具发现 offLineABSchedule 属性设置为"从不"， 则显示警告。

默认情况下，Exchange 保留一个脱机通讯簿。Exchange 每天晚上都会在其维护周期内更新此脱机通讯簿（或生成脱机通讯簿的新版本）。可以创建其他脱机通讯簿，并使用以下步骤来检查这些脱机通讯簿的生成安排。

此警告表明日程安排已更改为"从不"。在设置新的安排之前，Exchange 不会更新现有的脱机通讯簿。这意味着用户仍然可以下载现有的脱机通讯簿，但不能接收到任何更新。

在 Exchange 2000 Server 和 Exchange Server 2003 上更正此警告

  1. 打开 Exchange 系统管理器。

  2. 在"收件人"中，单击"脱机地址列表"。

  3. 在右侧窗格中，右键单击"默认""脱机地址列表"，再单击"属性"。如果不想使用脱机通讯簿，请右键单击"默认""脱机通讯簿"，再单击"删除"。使用该过程的其余步骤设置一个日程安排。

  4. 在"常规"选项卡上，从"更新间隔"下拉列表中选择运行时间，或单击"自定义"以设置自定义安排。

  5. 单击"确定"以保存更改。

在 Exchange Server 2007 上更正此警告

  1. 打开 Exchange 管理控制台。

  2. 展开 Microsoft Exchange，展开"组织配置"，再选择"邮箱"。

  3. 在结果窗格中，单击"脱机通讯簿"选项卡。

  4. 在"脱机通讯簿"选项卡上，选择"默认脱机通讯簿"。在操作窗格中，单击"属性"。

  5. 在"常规"选项卡上，从"更新日程安排"下拉列表中选择运行时间，或单击"自定义"以设置自定义安排。

  6. 单击"确定"保存更改。

使用 Exchange 命令行管理程序来设置脱机通讯簿生成日程安排

  • 运行下列命令：

    复制代码
    Set-OfflineAddressBook -Identity <OAB Name> -Schedule <Schedule>

    其中：<OAB> 是可分辨名称 (DN)、域\帐户名、或者 OAB 的 GUID，<日程安排> 指定开始 OAB 生成的日程安排时间，该格式是"起始日.小时:分钟 [AM/PM]"。日期可以使用如下值：

    • 该日的全名

    • 该日的缩写名称

    • 从 0 至 6 的整数，其中 0 = 星期日

    如果想要使用 24 小时制，请忽略 AM/PM。

    例如，若将默认脱机通讯簿生成时间安排设置为每日 1AM 至 3AM，应该输入：
复制代码
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -Schedule 0.01:00-0.03:00,1.01:00-1.03:00,2.01:00-2.03:00,3.01:00-3.03:00,4.01:00-4.03:00,5.01:00-5.03:00,6.01:00-6.03:00

有关在 Exchange Server 2003 中使用脱机通讯簿的详细信息，请参阅"Working with the Exchange Server 2003 Store"（使用 Exchange Server 2003 存储）中的"Configuring Exchange Server 2003 Offline Address Books"（配置 Exchange Server 2003 脱机通讯簿）(http://go.microsoft.com/fwlink/?LinkId=47595)。

有关在 Exchange Server 2007 中使用脱机通讯簿的详细信息，请参阅"Organization Configuration > Mailbox > Offline Address Books"（组织配置 > 邮箱 > 脱机通讯簿）(http://go.microsoft.com/fwlink?LinkId=79247)。


检测到旧的连接协议版本
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 Active Directory 连接器 (ADC) 连接协议的 versionNumber 属性的值。

如果 Exchange Server 分析工具发现，在包含一个或多个 Exchange Server 2003 计算机的 Exchange 组织中，任何连接协议的 versionNumber 属性的值小于 16973842，则会显示警告。

值小于 16973842 表示连接协议已经创建，并且正由 Exchange 2000 Server ADC 进行管理。如果在正运行 Exchange 2000 Server 或 Exchange Server 5.5 的组织中运行任何 Exchange Server 2003 实例，必须将所有 ADC 实例升级到 Exchange Server 2003 所附带的版本。升级到 Exchange Server 2003 或 Exchange Server 2003 Service Pack 1 (SP1) 的 ADC 版本之后，还将更新该 ADC 拥有的连接协议。将用最新的值更新每个连接协议的 versionNumber 属性。

解决此警告问题

  1. 从 http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&DisplayLang=zh-cn 下载 Exchange Server 2003 SP1。

  2. 对 Exchange Server 计算机执行完整备份。

  3. 在运行 Exchange 2000 Server ADC 的服务器上，单击"开始"，单击"运行"，再键入 <path>\adc\i386\setup.exe，其中 <path> 是 Exchange Server 2003 SP1 下载后的保存位置。

  4. 在"欢迎使用 Active Directory 连接器安装向导"页上，单击"下一步"。

  5. 在"检测到以前曾进行过安装"页上，单击"重新安装"，将 Exchange 2000 Server ADC 升级到 Exchange Server 2003 ADC。

  6. 在"完成 Active Directory 连接器安装向导"页上，单击"完成"。

有关安装和升级 ADC 的详细信息，请参阅下列 Microsoft 知识库文章：

  • 823601"Active Directory 连接器在整个组织内的要求和影响"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823601)

  • 822942"升级到 Exchange Server 2003 时应考虑的因素"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822942)


PDC 仿真器 FSMO 角色不响应
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定域命名上下文中域目录分区的根的 fSMORoleOwner 属性值。例如，在名为 contoso.com 的域中，主域控制器 (PDC) 仿真器的 fSMORoleOwner 是 DC=contoso,DC=com 的属性。然后，Exchange Server 分析工具尝试打开到当前充当此角色的域控制器上 TCP 端口 389 的轻型目录访问协议 (LDAP) 连接。如果 Exchange Server 分析工具无法连接到该域控制器，则显示错误。

PDC 仿真器充当主域控制器以便与早期的 Microsoft Windows® 操作系统兼容。Microsoft Windows 2000 Server 和 Microsoft Windows Server™ 2003 与 Microsoft Windows NT® 工作站、成员服务器以及备份域控制器进行互操作。Microsoft Windows NT 3.51 或 Microsoft Windows NT 4.0 域中的 PDC 负责下列工作：

  • 处理来自用户和计算机的密码更改

  • 将更新复制到备份域控制器

  • 运行域主浏览器

任何时候都只能为每个域中的一个域控制器分配 PDC 仿真器主控角色。

更正此错误

  1. 确认错误消息中指定的目录服务器已联机并可供组织中的 Exchange 服务器访问。

  2. 如果该目录服务器已停止使用，必须为另一个域控制器分配 PDC 仿真器角色。

有关将 PDC 仿真器角色从一个域控制器转移到另一个域控制器的详细信息，请参阅下列 Microsoft 知识库文章：

  • 对于 Windows Server 2003，请参阅 324801"如何查看和转移 Windows Server 2003 中的 FSMO 角色"(http://support.microsoft.com/kb/324801/zh-cn)

  • 对于 Windows 2000 Server，请参阅 255690"HOW TO:在图形用户界面中查看和转移 FSMO 角色"(http://support.microsoft.com/kb/255690/zh-cn)


配置对象的权限继承被阻止
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2006-04-13

Microsoft® Exchange Server 分析工具查询 Active Directory® 数据库中的每个 Exchange 配置对象，以确定是否存在权限继承被阻止的对象。如果某个 Exchange 配置对象的权限继承被阻止，Exchange Server 分析工具就会显示错误。

Exchange Server 分析工具识别权限继承被阻止的配置对象。

Exchange Server 分析工具从 Active Directory 中检索 Exchange 配置对象的随机访问控制列表 (DACL)。默认情况下，在安装 Exchange 时，Exchange 服务器和 Exchange Server 协议之类的配置对象被设置为继承权限。如果偶然取消选中或修改了权限，可能会阻止配置对象继承权限。在这种情况下，邮件流问题（如邮件滞留在队列中）和存储装入问题可能会降低 Exchange Server 的响应速度。

注意：
访问控制列表 (ACL) 是应用于某个对象的所有属性、一组属性或个别属性的安全保护列表。有两种类型的访问控制列表：随机访问控制列表和系统访问控制列表。

通过重新启用该对象的权限继承，可以解决该问题。

重新启用 Exchange 配置对象的权限继承

  1. 通过设置注册表参数，启用 Exchange 系统管理器的对象属性框的"安全"选项卡。有关详细步骤，请参阅 Microsoft 知识库文章 264733"How to enable the Security tab for the organization object in Exchange 2000 and in Exchange 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264733)。

    注意：
    默认情况下，此配置对象属性框的"安全"选项卡未启用。

  2. 打开 Exchange 系统管理器，找到讨论的对象，然后重新启用权限继承。

  3. 重新启动 Exchange Server。

有关 Windows Server 2003 Active Directory 中随机访问控制列表的详细信息，请参阅"How Security Descriptors and Access Control Lists Work"（英文）

(http://go.microsoft.com/fwlink/?LinkId=64193)。

有关权限继承的详细信息，请参阅"How Permissions Work"（英文）(http://go.microsoft.com/fwlink/?LinkId=64195)。


域对象的权限继承被阻止
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2006-04-13

Microsoft® Exchange Server 分析工具检查 Active Directory® 域对象（例如容器和组织单位）。如果容器或组织单位中阻止权限继承，Exchange Server 分析工具就会显示错误。

Exchange Server 分析工具识别特定的对象。

如果对 Active Directory 域对象进行了修改，将覆盖对访问控制列表 (ACL) 的更改。即使手动启用了"从父级继承"，向 ACL 应用更改时，应用的继承仍然被禁用。因为收件人更新服务 (RUS) 不具有帐户所在的 Active Directory 组织单位的必要权限，所以这种情况会导致 RUS 问题。

如果禁用了帐户所在的 Active Directory 组织单位中的"允许来自父级的可继承权限传播到此对象"复选框，则可能发生以上行为。

若要解决此问题，使用 Active Directory 用户和计算机管理单元或 Active Directory 服务接口 (ADSI) Edit 对组织单位重新建立可继承权限。请按照 Microsoft 知识库文章 254030"Missing permissions cause the Recipient Update Service not to process accounts in Exchange 2000 Server and Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=254030) 中方案二的详细步骤进行操作。

有关 Microsoft Windows Server 2003™ Active Directory 中访问控制列表 (ACL) 的详细信息，请参阅"How Security Descriptors and Access Control Lists Work"（英文）(http://go.microsoft.com/fwlink/?LinkId=64193)。

有关权限继承的详细信息，请参阅"How Permissions Work"（英文）(http://go.microsoft.com/fwlink/?LinkId=64195)。


找不到公用文件夹层次结构
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchPFTreeType 属性值为 1 的公用文件夹层次结构数。msExchPFTreeType 属性值为 1 表明特定公用文件夹层次结构是为 MAPI 客户端指定的公用文件夹层次结构。如果 Exchange Server 分析工具确定在 Exchange 组织中没有 msExchPFTreeType 属性值为 1 的公用文件夹层次结构，Exchange Server 分析工具将显示错误。

此错误表明组织中没有 MAPI 客户端的公用文件夹层次结构。没有 MAPI 客户端的公用文件夹层次结构可能会造成问题。例如，如果没有 MAPI 客户端的公用文件夹层次结构，可能会造成在 Microsoft Windows® 服务器群集中运行的 Exchange 虚拟服务器升级失败。

若要解决该问题，可以使用 Active Directory 编辑工具将 MAPI 客户端的公用文件夹层次结构的 msExchPFTreeType 属性值设置为 1。下列工具属于 Active Directory 编辑工具：

  • Active Directory 服务接口 (ADSI) Edit (AdsiEdit.msc)

  • LDP (ldp.exe) 工具

只应修改 MAPI 公用文件夹层次结构。如果 Exchange 组织中包含应用程序公用文件夹层次结构，请确保只修改 MAPI 公用文件夹层次结构的属性。

在将 MAPI 公用文件夹层次结构的 msExchPFTreeType 属性值设置为 1 之后，在 Exchange 服务器上配置邮箱存储，使其作为默认的公用文件夹存储指向 MAPI 公用文件夹层次结构。

警告：
在使用 ADSI Edit、LDP 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。
更正此错误

  1. 使用 Active Directory 编辑工具在 Active Directory 中找到公用文件夹层次结构对象。这些公用文件夹对象可以在 CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdminGroupName>, CN=Folder Hierarchies 中找到。

  2. 通过输入一个新的值 1 更改 msExchPFTreeType 属性。

  3. 关闭 Active Directory 编辑器。

  4. 打开 Exchange 系统管理器。

  5. 要访问每个邮箱存储的属性，请单击"管理组"，再依次展开您的管理组、"服务器"、您的服务器，然后展开您的存储组。然后，用鼠标右键单击要更改属性的邮箱存储，再选择"属性"。

  6. 在"常规"选项卡上，对"默认公用存储"字段单击"浏览"。

  7. 选择 MAPI 公用文件夹层次结构，再单击两次"确定"保存更改。

  8. 对每个邮箱存储重复步骤 5-7。

有关使用 LDP 工具修改 Active Directory 的详细信息，请参阅 Microsoft 知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

有关 MAPI 和应用程序的公用文件夹层次结构的详细信息，请参阅下列资源：

  • Microsoft 知识库文章 258509"Description of public folder tree types in Exchange 2000 Server and in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258509)

  • Exchange Team Blog 条目"How mail-enabled Public Folders work"（英文）(http://go.microsoft.com/fwlink/?LinkId=41913)


收件人连接协议复制日程安排未设置为"始终"
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 Active Directory 连接器 (ADC) 连接协议中 activationStyle 属性的设置。activationStyle 属性对应 ADC 连接协议的运行频率。值为 0 表示复制日程安排设置为"从不"。值为 1 表示日程安排设置为"选定时间"。值为 2 表示日程安排设置为"始终"。

Exchange Server 分析工具还查询 Active Directory，以确定每个 ADC 连接协议对象的 msExchServer2SearchFilter 属性值。msExchServer2SearchFilter 属性代表在搜索目录时将使用的搜索筛选器。

如果 Exchange Server 分析工具发现 activationStyle 属性未设置为 Always，并且 msExchServer2SearchFilter 属性正在复制收件人信息，将显示警告。

通常，最佳实践是将收件人连接协议的复制日程安排设置为始终复制。在某些情况下，将该连接协议设置为其他任何日程安排可能会导致在邮箱从 Exchange Server 5.5 站点移至 Exchange Server 2003 组织后产生未送达报告 (NDR)。

解决此警告问题

  1. 打开 Active Directory Connector 服务 MMC 管理单元。

  2. 打开"连接协议"。

  3. 在连接协议属性页上，选择"日程安排"选项卡，再选择"始终"，然后单击"确定"。

有关部署 ADC 并配置连接协议的详细信息，请参阅"Exchange Server 2003 部署指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=77B6D819-C7B3-42D1-8FBB-FE6339FFA1ED&DisplayLang=zh-cn)。


收件人策略中包含变量
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个收件人策略对象的 gatewayProxy 属性的值。如果 Exchange Server 分析工具发现某个收件人策略对象的 gatewayProxy 属性中包含字符串 SMTP:%，则会显示非默认配置消息。

如果已将收件人策略修改为使用替换字符串生成简单邮件传输协议 (SMTP) 地址，收件人策略将包含变量。如果在默认收件人策略中使用变量，可能会造成在 Exchange 2000 Server Service Pack 2 (SP2) 之前的版本中进行复制时出现问题。因此，建议您不要在收件人策略中使用变量，或者将 Exchange 2000 Server 升级到最新的 Service Pack。Exchange 2000 Server SP2 及更高版本支持在默认收件人策略中使用变量。

修改任何收件人策略

  1. 启动 Exchange 系统管理器。

  2. 单击"组织"，再单击"收件人"，然后单击"收件人策略"。

  3. 双击要更改的策略。

  4. 单击"电子邮件地址"选项卡，然后编辑相应的 SMTP 地址或生成规则。

有关如何配置收件人策略的详细信息，请参阅 Microsoft 知识库文章 249299"HOW TO:在 Exchange 中配置收件人策略"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=249299)。

有关使用生成规则自定义 SMTP 地址的详细信息，请参阅知识库文章 822447"How to Modify an SMTP E-mail Address by Using Recipient Policies"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822447)。

有关默认收件人策略中包含变量时 Exchange 2000 Server 中可能出现的问题的详细信息，请参阅知识库文章 271339"XADM: Cannot Mount Database and Event ID 9546 Occurs"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=271339)。

若要获取最新的 Exchange 2000 Server Service Pack，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


收件人更新服务似乎已停止
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Active Directory 中每个收件人更新服务对象的 msExchServer1HighestUSN 属性值。Exchange Server 分析工具还查询 Active Directory，以确定 Active Directory 中每个收件人更新服务对象的 activationStyle 属性值。activationStyle 属性代表收件人更新服务的更新间隔。

Exchange Server 分析工具还查询 Active Directory，以确定 highestCommittedUSN 属性的值，该属性属于收件人更新服务所使用的域控制器的 RootDSE 属性。highestCommittedUSN 属性是服务器上已提交到此域控制器数据库中的任何对象的最高更新序列号 (USN)。

Exchange Server 分析工具还查询 Active Directory，以确定每个收件人更新服务对象的 msExchServer1LastUpdateTime 属性值。msExchServer1LastUpdateTime 属性代表此目录中上次成功同步的最近更新的日期和时间。

如果 Exchange Server 分析工具发现下列三个条件为真，则显示警告：

  • activationStyle 属性设置为 2，表明此收件人更新服务的日程安排设置为"始终"。

  • msExchServer1HighestUSN 值中列出的序号为 5,000 或 5,000 以上，在 highestCommittedUSN 中列出的序号后面。

  • 自 msExchServer1LastUpdateTime 属性中记录的时间戳以来已过去六个小时或六个小时以上。

此警告表明指定的收件人更新服务已数个小时未运行，可能已停止。

解决此警告问题

  1. 打开 Exchange 系统管理器。

  2. 展开"收件人"，再选择"收件人更新服务"。

  3. 用鼠标右键单击指定的收件人更新服务，再选择"立即更新"。

  4. 等待 30 分钟，然后重新运行 Exchange Server 分析工具，以确认是否仍存在该警告说明的情况。如果仍存在，请继续执行第 5 步。如果不再存在，则不需要执行其他操作。

  5. 重新启动 Microsoft Exchange System Attendant 服务。

有关收件人更新服务的详细信息，请参阅下列 Microsoft 知识库文章：

  • 253770"Tasks performed by the Recipient Update Service"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828"How the Recipient Update Service Populates Address Lists"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838"XADM:How the Recipient Update Service Applies System Policies"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738"XADM:How the Recipient Update Service Applies Recipient Policies"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


收件人更新服务没有处理所有更改
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2006-03-16

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Active Directory 中任何收件人更新服务对象是否具有 gatewayProxy 属性值。如果 Exchange Server 分析工具发现所有收件人更新服务对象的 gatewayProxy 属性值均已设置，则显示警告。

此警告表明收件人更新服务对象的 gatewayProxy 属性包含未完全处理的旧数据。应手动删除这些数据。

必须删除 gatewayProxy 属性中的旧数据，否则这些地址将处于"已应用"状态。如果管理员选择使用"重建"或"立即更新"选项来更改策略，可能会无意间覆盖了有效的用户地址，进而导致更改各个用户的 SMTP 地址。有关详细信息，请参阅 Exchange Blog 文章 Recipient Policies and pure Exchange 2000/2003 sites（英文）。

注意：
指向该 Blog 的链接仅供参考。该内容如有更改，恕不另行通知。

如果符合下列任何条件，表明收件人更新服务对象的 gatewayProxy 属性可能包含未完全处理的旧数据：

  • Active Directory 复制出现问题。如果 Exchange 系统管理器使用的域控制器不是运行收件人更新服务的 Exchange 服务器所使用的域控制器，则 Active Directory 复制可能会出现延迟问题或其他问题。

  • 存在造成更改丢失的非事务计时问题。Exchange 系统管理器和 System Attendant 同时访问 gatewayProxy 属性时，可能会出现这种情况。Exchange 系统管理器和 System Attendant 均尝试读取属性，执行更改，然后尝试回写该属性。

必须使用 Active Directory 服务接口 (ADSI) Edit (AdsiEdit.msc)、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端等工具删除旧数据。

警告：
在使用 ADSI Edit、LDP 工具或其他 LDAP 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。
解决此警告问题

  1. 按如下所述将收件人更新服务的更新间隔设置为"从不"：

    1. 打开 Exchange 系统管理器。

    2. 展开"收件人"，再展开"收件人更新服务"。

    3. 用鼠标右键单击要修改的收件人更新服务，再选择"属性"。

    4. 在"常规"选项卡上，使用"更新间隔"列表将日程安排设置为"从不运行"。

  2. 等待大约 1 到 2 分钟。

  3. 接下来，使用 ADSI Edit 或类似的工具找到 gatewayProxy 属性包含旧数据的收件人更新服务对象。收件人更新服务对象位于：

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Address Lists Container,CN=Recipient Update Services

    1. 用鼠标右键单击包含旧数据的收件人更新服务对象，再选择 Properties。

    2. 在 Attribute Editor 选项卡上，向下滚动并选择 gatewayProxy 属性。

    3. 单击 Edit 编辑此属性。

    4. 在 Value(s) 框中，选择要删除的旧地址类型，单击 Remove，再单击 OK。重复执行此步骤，直到删除所有地址类型。

    5. 单击 OK 保存更改，再关闭 ADSI Edit。

  4. 清除 gatewayProxy 属性之后强制进行目录复制。确保在域收件人更新服务再次运行之前进行复制。

  5. 将收件人更新服务重新配置为原始日程安排。

  6. 根据需要重新应用特定的收件人策略。使用 Active Directory 站点和服务管理单元执行手动的 Active Directory 复制。

有关此问题的详细信息，请参阅 Microsoft 知识库文章 821743"The gatewayProxy attribute on the Recipient Update Service object is not cleared"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821743)。

有关使用 LDP 工具的详细信息，请参阅知识库文章 260745"XADM: Using the LDP Utility to Modify Active Directory Object Attributes"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

有关执行目录复制的详细信息，请参阅 Microsoft 知识库文章 232072"Initiating Replication Between Active Directory Direct Replication Partners"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072)。

有关使用 ADSI Edit 的详细信息，请参阅 Windows Server 2003 帮助中的"Adsiedit.msc：ADSI Edit"主题。


收件人更新服务完全重建
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Exchange Server 使用的配置域控制器中收件人更新服务对象的 msDS-ReplAttributeMetaData 属性值。msDS-ReplAttributeMetaData 属性包含上次更改此属性的日期和时间以及其他信息。如果 Exchange Server 分析工具发现自 msDS-ReplAttributeMetaData 属性中列出的日期和时间以来经过的时间不到五天，则显示警告。

此警告表明最近安排了此收件人更新服务的完全重建。配置了完全重建后，下一次日程安排启动收件人更新服务或通过"立即更新"命令启动该服务时，收件人更新服务将检查每个对象，而不仅仅是查询新对象。该过程可能需要很长时间，可能造成系统延迟。

如果打算进行完全重建，可以放心地忽略此警告。如果不打算进行完全重建，可以使用 Active Directory 服务接口 (ADSI) Edit (AdsiEdit.msc) 和以下过程将 Active Directory 中的 msExchDoFullReplication 属性值由 True 更改为 False，以解决该问题。

警告：
在使用 ADSI Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。
解决此警告问题

  1. 使用 ADSI Edit 或类似的工具找到指定收件人更新服务对象的 msExchDoFullReplication 属性。收件人更新服务对象位于：CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Address Lists Container,CN=Recipient Update Services

  2. 用鼠标右键单击指定的收件人更新服务，再选择 Properties。

  3. 在 Attribute Editor 选项卡上，向下滚动并选择 msExchDoFullReplication 属性。

  4. 单击 Edit 编辑此属性。

  5. 在 Boolean Attribute Editor 对话框中，将选择由 True 更改为 False，再单击 OK。

  6. 再次单击 OK 保存更改，再关闭 ADSI Edit。

有关收件人更新服务的详细信息，请参阅下列 Microsoft 知识库文章：

  • 253770"Tasks performed by the Recipient Update Service"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828"How the Recipient Update Service Populates Address Lists"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838"XADM:How the Recipient Update Service Applies System Policies"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738"XADM:How the Recipient Update Service Applies Recipient Policies"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


收件人更新服务已配置为完全重建
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Active Directory 中每个收件人更新服务对象的 msExchDoFullReplication 属性值。如果 Exchange Server 分析工具发现任何收件人更新服务对象的 msExchDoFullReplication 属性值设置为 True，则显示警告。

此警告表明此收件人更新服务已配置为在下一个处理周期中执行完全重建。如果 msExchDoFullReplication 属性设置为 True，则收件人更新服务下一次按日程安排或通过"立即更新"命令启动时，将检查每个对象，而不是仅查询新对象。该过程可能需要很长时间，可能造成系统延迟。

如果打算进行完全重建，可以放心地忽略此警告。如果不打算进行完全重建，可以使用 Active Directory 服务接口 (ADSI) Edit (AdsiEdit.msc) 和以下过程将 Active Directory 中的 msExchDoFullReplication 属性值由 True 更改为 False，以解决该问题。

警告：
在使用 ADSI Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。
解决此警告问题

  1. 使用 ADSI Edit 或类似的工具找到指定收件人更新服务对象的 msExchDoFullReplication 属性。收件人更新服务对象位于：CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Address Lists Container,CN=Recipient Update Services

  2. 用鼠标右键单击指定的收件人更新服务，再选择 Properties。

  3. 在 Attribute Editor 选项卡上，向下滚动并选择 msExchDoFullReplication 属性。

  4. 单击 Edit 编辑此属性。

  5. 在 Boolean Attribute Editor 对话框中，将选择由 True 更改为 False，再单击 OK。

  6. 再次单击 OK 保存更改，再关闭 ADSI Edit。

有关收件人更新服务的详细信息，请参阅下列 Microsoft 知识库文章：

  • 253770"Tasks performed by the Recipient Update Service"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828"How the Recipient Update Service Populates Address Lists"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838"XADM:How the Recipient Update Service Applies System Policies"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738"XADM:How the Recipient Update Service Applies Recipient Policies"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


收件人更新服务未激活
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Active Directory 中每个收件人更新服务对象的 activationStyle 属性值。如果 Exchange Server 分析工具发现任何收件人更新服务对象的 activationStyle 属性值设置为 0，则会显示警告。

此警告表明该收件人更新服务对象的安排设置为"从不"。如果收件人更新服务的安排设置为"从不"，则不会处理新对象。

如果不再需要该收件人更新服务对象，建议将其删除。如果需要该收件人更新服务对象，建议配置其安排。

通过配置安排解决此警告问题

  1. 打开 Exchange 系统管理器。

  2. 展开"收件人"，再选择"收件人更新服务"。

  3. 用鼠标右键单击其安排设置为"从不"的收件人更新服务，再选择"属性"。

  4. 使用"更新间隔"列表选择预定义的安排，或单击"自定义"创建自定义安排。

  5. 单击"确定"保存更改。

  6. 用鼠标右键单击该收件人更新服务，再选择"立即更新"。

有关收件人更新服务的详细信息，请参阅下列 Microsoft 知识库文章：

  • 253770"Tasks Performed by the Recipient Update Service"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828"How the Recipient Update Service Populates Address Lists"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838"XADM:How the Recipient Update Service Applies System Policies"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738"XADM:How the Recipient Update Service Applies Recipient Policies"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


要求安装收件人更新服务的软件更新
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定通讯簿视图和动态组服务 (abv_dg.dll)（也称为收件人更新服务）的 Version 关键字的值。Version WMI 关键字代表此文件的内部版本号。

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定 NTDS 设置对象的 msDS-Behavior-Version 属性值。该值表明 Active Directory 目录林的功能级别。msDS-Behavior-Version 属性的有效值如下表中所示。

值 | 目录林的功能级别
0 | Microsoft Windows 2000 Server 混合模式
1 | Microsoft Windows Server™ 2003 临时模式
2 | Microsoft Windows Server 2003 纯模式

如果 Exchange Server 分析工具发现在 Windows Server 2003 临时模式或纯模式的 Active Directory 目录林中，某台 Exchange 服务器上的 abv_dg.dll 的内部版本号低于 6.0.6615.0，则显示错误。该错误说明 Exchange 2000 Server 版本的收件人更新服务正在不兼容的 Windows Server 2003 Active Directory 目录林级别中运行。需要安装收件人更新服务更新才能解决此问题。

使用 Exchange 2000 Server 中的收件人更新服务更新 Windows Server 2003 目录林中的收件人对象时，收件人更新服务无法正确地更新对象。例如，收件人更新服务无法识别对组成员身份所作的更改。而且，如果使用 Exchange 2000 Server Active Directory 连接器 (ADC)，ADC 可能无法将对组成员身份的更改从 Active Directory 复制到 Exchange Server 5.5 目录中。

升级到最新版本的收件人更新服务

  1. 按照 Microsoft 知识库文章 873059"The Recipient Update Service does not update objects correctly when Exchange 2000 Server is running in a Windows Server 2003 forest"（英文）中的说明获取所需的更新 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=873059)。

  2. 应用更新。应用此更新之后，不必重新启动计算机。但是，与 Exchange 有关的服务在应用此更新之后自动重新启动。


该域不存在 RUS 实例
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以返回林中的域列表。Exchange Server 分析工具还查询 msExchangeDomainLink 属性，以获取现有域收件人更新服务 (RUS) 实例的列表。然后，Exchange Server 分析工具将返回的域列表与返回的 RUS 实例列表比较，并确定是否存在匹配项。如果符合以下条件，Exchange Server 分析工具将显示错误：

  • 域存在

  • 该域不存在 RUS 实例

如果已使用 DomainPrep 准备该域，但是该域不存在 RUS 实例，此 Exchange Server 分析工具将显示此错误。如果管理员在目录林中添加了新的 Active Directory 域，并使用 DomainPrep 为 Exchange 准备该域，但是后来忘记为该域添加 RUS 实例，则会出现不匹配。如果发生这种情况，在域中创建的新用户对象将无法接收发送给他们的电子邮件地址。如果出现此错误消息，请为该域创建一个新的收件人更新服务。

更正此错误

  1. 打开 Exchange 系统管理器。

  2. 展开"收件人"。

  3. 用鼠标右键单击"收件人更新服务"节点，再单击"新建"，然后单击"收件人更新服务"。

  4. 在"新建对象"窗口中，单击"浏览"查找该域的名称。

  5. 选中该域的名称，然后单击"确定"。

  6. 在"新建对象"窗口中，单击"下一步"，然后单击"完成"。

有关收件人更新服务的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328738"How the Recipient Update Service applies recipient policies"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828"How the Recipient Update Service Populates Address Lists"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127"How to check the progress of the Exchange Recipient Update Service"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770"Tasks performed by the Exchange Recipient Update Service"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


复制时段更改
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定任何域控制器的 NTDS Settings 对象的 ms-DS-ReplicationEpoch 属性是否已设置。

"时段"是指域采用特定名称的时间段。新时段从域初次创建时以及域名更改时开始。

ms-DS-ReplicationEpoch 属性应用于所有域控制器正在复制的时段。如果 Exchange Server 分析工具发现已设置此属性的值，则会显示非默认配置消息。

如果 ms-DS-ReplicationEpoch 属性的值存在，通常表明受影响的服务器所驻留的域已重命名。Microsoft Windows Server™ 2003 Standard Edition、Windows Server 2003 Enterprise Edition 和 Windows Server 2003 Datacenter Edition 使管理员可以在目录林结构建立后为 Active Directory 目录林中的域重命名。Windows® 2000 Server 操作系统不允许管理员在目录林结构建立后为 Active Directory 目录林中的域重命名。

Active Directory 目录林的结构由创建域的顺序以及这些域的层次名称确定。从目录林的根域开始。所有子域从目录林的根域名称得到自己的可分辨名称和默认的 DNS 名称。对目录林中的其他每棵目录树重复上述操作。

通过为域重命名来更改现有域目录树的层次结构。例如，可以将子域重命名为采用其他父域，也可以将子域重命名为新的目录树根域。在这两个示例中，均通过调整现有域的位置来创建其他域目录树结构。

也可以在不影响结构的情况下为域重命名。例如，如果为根域重命名，将更改该根域下的所有子域的名称，但并未创建其他域目录树结构。

如果目录林中包含 Exchange 2000 Server 或 Exchange Server 5.5，则不支持域的重命名。Windows Server 2003 域重命名工具设计用于为不包含 Exchange 2000 Server 服务器或 Exchange Server 5.5 服务器的 Active Directory 目录林中的域重命名。Windows Server 2003 域重命名工具的这一局限性是因为下列情况：

  • 域的重命名会影响多个 Exchange 属性。

  • Windows Server 2003 域重命名工具没有修正这些属性的功能。

包含 Exchange Server 2003 的目录林支持域的重命名。Exchange 域重命名修正工具 (XDR-fixup.exe) 可以在为包含 Exchange 2003 Server 服务器的域重命名之后修正 Exchange Server 属性。可以将 Exchange 域重命名修正工具与 Windows Server 2003 目录重命名工具 (Rendom.exe) 配合使用。

有关 Windows Server 2003 Active Directory 域重命名工具的详细信息，或要下载 Windows Server 2003 Active Directory 域重命名工具，请参阅"Windows Server 2003 Active Directory Domain Rename Tools"（英文）(http://go.microsoft.com/fwlink/?LinkId=40992)。

若要为域重命名，必须运行 XDR-fixup 工具。XDR-fixup 工具修改 Exchange Server 中的 Active Directory 属性，以反映新的域名。XDR-fixup 工具不会取代 Windows Server 2003 域重命名工具。XDR-fixup 工具也不会扩展 Windows Server 2003 域重命名工具的功能。每次运行 Rendom.exe 时必须运行 XDR-fixup 工具。

有关为域重命名的过程以及域的重命名过程如何影响 Exchange Server 的详细信息，请参阅下列工具和文档：

  • "Windows Server 2003 Active Directory Domain Rename Tools"（英文）(http://go.microsoft.com/fwlink/?LinkId=40992)

  • "Understanding How Domain Rename Works"（英文）(http://go.microsoft.com/fwlink/?LinkId=41906)

  • "Step-by-Step Guide to Implementing Domain Rename"（英文）(http://go.microsoft.com/fwlink/?LinkId=41359)

  • "Exchange Server 域重命名修正 (XDR-Fixup)"(http://www.microsoft.com/downloads/details.aspx?displaylang=zh-cn&FamilyID=24b47d4a-c4b9-4031-b491-29839148a28c)

  • "Exchange and Domain Rename Operations"（英文）(http://go.microsoft.com/fwlink/?LinkId=41908)


找不到脱机通讯簿版本 2 的副本
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2007-01-29

Microsoft® Exchange Server 分析工具查询 Exchange_Public_Folder Microsoft Windows® Management Instrumentation (WMI) 类，以确定 HasLocalReplica 的当前值。如果 Exchange Server 分析工具发现脱机地址列表的脱机通讯簿版本 2 实例的 HasLocalReplica 值设置为 False，则显示错误。

如果脱机地址列表的脱机通讯簿版本 2 实例的 HasLocalReplica 设置为 False，将无法正确生成脱机地址列表。因此，Microsoft Outlook® 2002 及更早版本的用户无法下载脱机地址列表。

如果尚未配置任何公用文件夹存储以包含脱机通讯簿版本 2 的副本，则可能出现此问题。默认情况下，脱机通讯簿将内容复制到其安装在的服务器的公用文件夹存储中。如果将公用文件夹存储从脱机通讯簿的复制配置中删除，则会发生上一段中所述的问题。

更正此错误

  1. 打开 Exchange 系统管理器。

  2. 展开"管理组"，再单击"文件夹"。

  3. 右键单击"公用文件夹"，再单击"查看系统文件夹"。

  4. 单击以展开"脱机通讯簿"对象。

  5. 在"脱机通讯簿"中，右键单击 o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List，再单击"属性"。

  6. 在"复制"选项卡上，验证已在"将内容复制到下列公用存储"框中输入了公用文件夹存储。如果未输入公用文件夹存储，请单击"添加"并输入适合脱机通讯簿的公用存储。

  7. 单击"应用"，再单击"确定"。

  8. 单击以展开 o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List。

  9. 在 o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List 中，右键单击"脱机通讯簿版本 2"，再单击"属性"。

  10. 在"复制"选项卡上，验证已在"将内容复制到下列公用存储"框中输入了公用文件夹存储。如果未输入公用文件夹存储，请单击"添加"并输入适合脱机通讯簿的公用存储。

  11. 单击"应用"，再单击"确定"。

有关此问题的详细信息，请参阅 Microsoft 知识库文章 286328"Offline Address Book Is Missing and Cannot Be Generated in Microsoft Exchange"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328)。

有关脱机通讯簿列表生成的详细信息，请参阅"Offline Address List Generation Overview"（脱机通讯簿列表生成概述）(http://go.microsoft.com/fwlink/?LinkId=82242)。

有关如何从管理组中删除第一台运行 Exchange Server 2003 的计算机的详细信息，请参阅知识库文章 822931"如何从站点中删除第一台 Exchange Server 2003 计算机"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822931)。


找不到脱机通讯簿版本 3a 的副本
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Exchange_Public_Folder Microsoft Windows® Management Instrumentation (WMI) 类，以确定 HasLocalReplica 的当前值。如果 Exchange Server 分析工具发现脱机地址列表的脱机通讯簿版本 3a 实例的 HasLocalReplica 值设置为 False，则会显示错误。

如果脱机地址列表的脱机通讯簿版本 3a 实例的 HasLocalReplica 设置为 False，将无法正确生成脱机地址列表。因此，Microsoft Office Outlook® 2003 用户无法下载任何脱机地址列表。

如果尚未配置任何公用文件夹存储以包含脱机通讯簿版本 3a 的副本，则可能出现此问题。默认情况下，脱机通讯簿将内容复制到其所在服务器的公用文件夹存储中。如果将公用文件夹存储从脱机通讯簿的复制配置中删除，则会发生上一段中所述的问题。

更正此错误

  1. 打开 Exchange 系统管理器。

  2. 展开"管理组"，再单击"文件夹"。

  3. 用鼠标右键单击"公用文件夹"，再单击"查看系统文件夹"。

  4. 单击以展开"脱机通讯簿"对象。

  5. 在"脱机通讯簿"中，用鼠标右键单击 o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List，再单击"属性"。

  6. 在"复制"选项卡上，验证已在"将内容复制到下列公用存储"框中输入了公用文件夹存储。如果未输入公用文件夹存储，请单击"添加"并输入适合脱机通讯簿的公用存储。

  7. 单击"应用"，再单击"确定"。

  8. 单击以展开 o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List。

  9. 在 o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List 中，用鼠标右键单击"脱机通讯簿版本 3a"，再单击"属性"。

  10. 在"复制"选项卡上，验证已在"将内容复制到下列公用存储"框中输入了公用文件夹存储。如果未输入公用文件夹存储，请单击"添加"并输入适合脱机通讯簿的公用存储。

  11. 单击"应用"，再单击"确定"。

有关此问题的详细信息，请参阅 Microsoft 知识库文章 286328"Offline Address Book Is Missing and Cannot Be Generated in Microsoft Exchange"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328)。

有关如何从管理组中删除第一台运行 Exchange Server 2003 的计算机的详细信息，请参阅知识库文章 822931"如何从站点中删除第一台 Exchange Server 2003 计算机"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822931)。


目录复制连接器日程安排
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 Active Directory 连接器 (ADC) 连接协议对象的 activationSchedule 属性值。activationSchedule 属性对应 ADC 连接协议的运行频率。值为 0 意味着复制日程安排设置为"从不"。值为 1 意味着日程安排设置为"选定时间"。值为 2 意味着日程安排设置为"始终"。

Exchange Server 分析工具还查询 Active Directory，以确定每个 ADC 连接协议对象的 msExchServer2SearchFilter 属性值。msExchServer2SearchFilter 属性代表在搜索目录时将使用的搜索筛选器。

如果 Exchange Server 分析工具发现 activationSchedule 属性设置为复制间隔大于 6 小时的"选定时间"，并且 msExchServer2SearchFilter 属性复制收件人信息，则显示警告。

通常，最好将收件人连接协议的复制日程安排设置为始终复制（"始终"）。在某些情况下，将该连接协议设置为其他任何日程安排都可能会导致在邮箱从 Exchange Server 5.5 站点移至 Exchange 2000 Server 或 Exchange Server 2003 后产生未送达报告 (NDR)。

解决此警告问题

  1. 打开 Active Directory 连接器服务 MMC 管理单元。

  2. 打开"连接协议"。

  3. 在"Connection_Agreement 属性"页上，单击"日程安排"选项卡，再选择"始终"，然后单击"确定"。

有关部署 ADC 并配置连接协议的详细信息，请参阅"Exchange Server 2003 部署指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=77B6D819-C7B3-42D1-8FBB-FE6339FFA1ED&DisplayLang=zh-cn)。


RID FSMO 服务器角色没有响应
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定域命名上下文中的相对 ID (RID) 操作主域控制器的 fSMORoleOwner 属性的值。例如，在名为 contoso.com 的域中，RID 操作主机的 fSMORoleOwner 是 CN=RID Manager$, CN=System, DC=contoso, DC=com 的属性。然后，Exchange Server 分析工具尝试打开与当前担任此角色的域控制器上的 TCP 端口 389 的轻型目录访问协议 (LDAP) 连接。如果 Exchange Server 分析工具无法连接到该域控制器，则会显示错误。

RID 主机将向所有域控制器分配相对 ID，以确保所有安全主体都有唯一的标识符。可以在任何域控制器上创建新的安全主体对象（用户、组或计算机）。创建安全主体对象时，域控制器会将唯一的安全标识符 (SID) 附加到该对象上。域 SID 有四个元素，其中一个是域的 RID。RID 操作主机负责处理来自特定域中的所有域控制器的 RID 池请求。在任何时候，都只能有一个域控制器充当域中的 RID 主机。

更正此错误

  1. 确认错误中指定的目录服务器已联机，并可被组织中的 Exchange 服务器访问。

  2. 如果该目录服务器已退役，则必须将 RID 主机角色分配给另一个域控制器。

有关将 RID 操作主机角色从一个域控制器转移到另一个域控制器的详细信息，请参阅下列 Microsoft 知识库文章：

  • 对于 Microsoft Windows Server™ 2003，请参阅 324801"如何查看和转移 Windows Server 2003 中的 FSMO 角色"(http://support.microsoft.com/kb/324801/zh-cn)

  • 对于 Microsoft Windows® 2000 Server，请参阅 255690"HOW TO:在图形用户界面中查看和转移 FSMO 角色"(http://support.microsoft.com/kb/255690/zh-cn)


找不到架构 FSMO 角色
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定指定为架构 FSMO（架构命名上下文中的 fSMORoleOwner ）的域控制器。如果 Exchange Server 分析工具发现 fSMORoleOwner 属性中指定的域控制器在目录林中不存在，则显示错误。

位于架构命名上下文 (CN=Schema,CN=Configuration,DC=domain,DC=com) 的 fSMORoleOwner 属性指定作为目录林的架构主域控制器的域控制器。架构主域控制器控制架构的所有更新和修改。要更新目录林的架构，必须能够访问架构主域控制器。整个目录林中只能有一个架构主域控制器。

必须为 Active Directory 目录林指定一个架构主域控制器。如果架构主域控制器在安装过程中未联机，Exchange 2000 Server 安装程序和 Exchange 2000 Server Service Pack 安装程序将失败（即便不更新架构也是如此）。如果作为架构主域控制器列出的域控制器脱机，必须将它重新联机。该情况不适用于 Exchange Server 2003。Exchange Server 2003 安装程序只有确定架构尚未扩展时，才会与架构主域控制器联系。

更正此错误

  1. 确认指定的 Active Directory 服务器确实存在。

  2. 如果该目录服务器已停止使用，应当为另一个域控制器指定架构主域控制器角色。

有关如何为另一个域控制器指定架构主域控制器角色的详细信息，请参阅下列 Microsoft 知识库文章：

  • 280178"XADM:Exchange 2000 Installation Requires Access to Schema Master"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=280178)

  • 对于 Microsoft Windows Server™ 2003，请参阅 324801"如何查看和转移 Windows Server 2003 中的 FSMO 角色"(http://support.microsoft.com/kb/324801/zh-cn)

  • 对于 Microsoft Windows® 2000 Server，请参阅 255690"HOW TO:在图形用户界面中查看和转移 FSMO 角色"(http://support.microsoft.com/kb/255690/zh-cn)


架构 FSMO 角色没有响应
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定架构命名上下文中架构操作主机的 fSMORoleOwner 属性值。例如，在一个称为 contoso.com 的域中，架构操作主机的 fSMORoleOwner 属性是 CN=Schema,CN=System,DC=contoso,DC=com。Exchange Server 分析工具然后尝试打开到当前持有此角色的域控制器上 TCP 端口 389 的轻型目录访问协议 (LDAP) 连接。如果 Exchange Server 分析工具无法连接到该域控制器，则显示错误。

持有架构主机角色的域控制器是唯一可以对目录架构执行写入操作的域控制器。这些架构更新将从架构主机复制到目录林中的所有其他域控制器。架构主机是一个对应于每个目录林的操作主机角色，因为不管域的个数是多少，目录林中只有一个架构。若要更新目录林的架构，必须访问架构主机。整个目录林中只能有一个架构主机。

更正此错误

  1. 验证错误消息所中指定的目录服务器已联机，并且可以被组织中的 Exchange 服务器访问。

  2. 如果该目录服务器已退役，则必须将架构主机角色分配给另一个域控制器。

有关将架构操作主机角色从一个域控制器转移到另一个域控制器的详细信息，请参阅下列 Microsoft 知识库文章：

  • 对于 Microsoft Windows Server™ 2003，请参阅 324801"如何查看和转移 Windows Server 2003 中的 FSMO 角色"(http://support.microsoft.com/kb/324801/zh-cn)。

  • 对于 Microsoft Windows® 2000 Server，请参阅 255690"HOW TO:在图形用户界面中查看和转移 FSMO 角色"(http://support.microsoft.com/kb/255690/zh-cn)。


安全套接字层证书即将到期
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2007-01-09

Microsoft® Exchange Server 分析工具在 Exchange 服务器系统中查询 Server Certificate 对象，以检索 X509 证书的各种属性。对于找到的每个安全套接字层 (SSL) 证书，Exchange Server 将分析其 ExpirationDate 属性以识别该证书的到期日期。

注意：
一台服务器必须拥有一个服务器证书，才能运行 SSL 协议。服务器证书包含该网站名称。浏览器会验证该网站名称是否与输入的名称相同。例如，如果网站为 https://www.example.com，则该证书的名称应该为 www.example.com。

如果 ExpirationDate 在 3 天之后 20 之前，Exchange Server 分析工具就会显示警告。如果 ExpirationDate 在 3 天以内，Exchange Server 分析工具就会显示错误。

如果证书过期，到此消息中指定的 URL 的 SSL 连接就会失败。同理，使用此 URL 的连接，无论是 RPC over HTTP 还是 Exchange Server ActiveSync 连接，都将失败。

若要解决证书到期的警告或错误问题，请续订消息中指定的证书。续订证书的具体步骤取决于您所使用的证书颁发机构。

详细信息

有关 SSL 和在 Exchange Server 虚拟服务器中使用证书的详细信息，请参阅下列 Exchange 资源：

  • 有关如何在 Exchange Server 2003 的虚拟服务器中使用证书的详细信息，请参阅 Microsoft 知识库文章 823024"如何在 Exchange Server 2003 的虚拟服务器中使用证书"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823024)。

  • 有关如何使用 SSL 以及如何获得并安装服务器证书的信息，请参阅 Exchange Server 2003 Client Access Guide (http://go.microsoft.com/fwlink/?LinkId=47568) 中的"Configuring Exchange Server 2003 for Client Access"（英文）。

  • 有关如何使用 SSL 以及如何为 Exchange Server 2007 获取并安装服务器证书的信息，请参阅"How to Configure SSL for Outlook Anywhere"（如何为 Outlook Anywhere 配置 SSL）(http:// go.microsoft.com/fwlink/?LinkId =80875)


缺少"服务器"容器
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2006-08-21

Microsoft® Exchange Server 分析工具将查询 Active Directory® 目录服务，以获取当前管理组中发现的每个 Routing Group 对象的 distingushedName 属性值。

然后，Exchange Server 分析工具将查询 Active Directory，以确定当前管理组中是否存在"服务器"容器。

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • 当前管理组包含一个或多个路由组。

  • 不存在"服务器"容器。

此错误指示管理组中未安装任何服务器，并且不可以在整个 Exchange 组织中的服务器之间动态传播路由信息。

若要解决此错误，请确保 Exchange 组织处于纯模式，同时请遵循下列步骤。

解决步骤

  1. 新建一个管理组。

  2. 在新的管理组中新建一个"路由组"容器。

  3. 将现有的路由组从旧的"路由组"容器拖放到新容器。

  4. 重新启动所有 Exchange 服务。

有关此错误的详细信息，请参阅 Microsoft 知识库文章 318491"XADM:Routing Information Is Not Propagated Across an Exchange 2000 Organization"（XADM：无法在 Exchange 2000 组织之间传播路由信息）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=318491)。


全局编录服务器缺少服务主体名称
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2006-05-12

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务全局编录服务器，以找到为 exchangeAB 和 HOST 资源的 servicePrincipalName 属性的完全限定域名 (FQDN) 和 NetBIOS 名称返回的值。

如果下列条件的任意一个为真，则 Exchange Server 分析工具将显示错误：

  • exchangeAB 资源的 servicePrincipalName 属性缺少一个期望的 FQDN 或 NetBIOS 名称值。

  • HOST Exchange 资源的 servicePrincipalName 属性缺少一个期望的 FQDN 或 NetBIOS 名称值。

服务主体名称 (SPN) 是标识服务实例的唯一名称，并且与运行服务实例的登录帐户相关联。如果没有正确设置 SPN，Kerberos 身份验证将无法用于 Exchange 服务。

  • 如果运行 Microsoft Outlook® 2003 或更高版本的客户端存在 Active Directory 身份验证问题，这些问题可能表示缺少 exchangeAB 资源的有效 SPN。

  • 服务器之间的身份验证失败可能表示缺少 HOST 资源的有效的 SPN。

若要解决此问题，请执行下列步骤添加 servicePrincipalName 属性缺少的值。

使用 SETSPN.exe 工具添加带有缺少的值的 SPN

  1. 安装 Setspn.exe 工具。若要获得 Setspn.exe 工具，请参阅"Windows 2000 Resource Kit Tool : Setspn.exe"（英文）(http://go.microsoft.com/fwlink/?LinkId=28103)。

    Windows Server 2003 版本的 Setspn.exe 命令行工具可以在 Windows Server 2003 CD 所包括的 Windows Server 2003 支持工具中找到。若要安装 Server 2003 支持工具，请双击 Support/Tools 文件夹中的 Suptools.msi 文件。

  2. 按照 SETSPN.EXE"Setspn_d.txt"文件中的指导向 Exchange 服务器的 Active Directory 对象添加缺少的值。以下示例说明为虚拟 SMTP 服务器 SPN 添加 FQDN 值的过程：

    • 启动命令提示符，然后更改为安装 Setspn.exe 的目录。

    • 在命令提示符处，输入以下命令：

      setspn.exe-a SMTPSVC/ mail.yourdomain.com YOURSERVERNAME

      注意：
      使用您的 SMTP 虚拟服务器 FQDN 替换 mail.yourdomain.com，并使用 Exchange 服务器的名称替换 YOURSERVERNAME。
      然后按 Enter。


该管理组的"站点文件夹服务器"公用文件夹存储不在该管理组中
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个公用文件夹存储的 distinguishedName 的值。此外，Exchange Server 分析工具还会查询 Active Directory，以确定每个管理组的 siteFolderServer 和 msExchAdminGroupMode 属性的值。siteFolderServer 属性代表了负责驻留站点文件夹的服务器（通常，它是站点或管理组中的第一个服务器）的名称。msExchAdminGroupMode 属性代表管理组的模式，模式可以是：

  • 纯 Exchange Server 5.5

  • Exchange Server 5.5、Exchange 2000 Server 和 Exchange Server 2003 Server 混合模式

  • Exchange 2000 Server 或 Exchange Server 2003 纯模式

如果 Exchange Server 分析工具确定管理组不在纯模式中，并且 siteFolderServer 的值与任何公用文件夹存储的 distinguishedName 的值不匹配，而且 siteFolderServer 属性值不包含字符串 DEL:，则显示警告。

默认情况下，站点文件夹服务器是安装在管理组中的第一个服务器。该服务器上的公用文件夹存储是管理组的忙/闲文件夹和脱机通讯簿文件夹的默认位置。如果删除站点文件夹服务器或使其退役，却没有将这些文件夹复制到另一个服务器上，并将此服务器指定为脱机通讯簿服务器，则 Outlook 用户将看到脱机通讯簿和忙/闲数据出现问题。

警告：
在使用 ADSI（Active Directory 服务接口）Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003 才能解决。修改 Active Directory 对象的属性的风险由您自己承担。

解决此警告问题

  1. 打开 Active Directory 编辑器，如 ADSI Edit。

  2. 展开下列各项，找到想要指定为站点文件夹服务器的公用文件夹信息存储：CN=<PublicFolderStoreName>, CN=<StorageGroupName>, CN=InformationStore, CN=<ServerName>, CN=Servers, CN=<AdministrativeGroupName> ,CN=Administrative Groups, CN=<OrganizationName>, CN=Microsoft Exchange, CN=Services, CN=Configuration,DC=<DomainName>,DC=com.

  3. 在右侧窗格中，右键单击 CN=<PublicFolderStoreName>，并选择"属性"。

  4. 在"属性"字段中，向下滚动并选择 distinguishedName 属性。

  5. 单击"编辑"按钮，再将整个属性复制到剪贴板。

  6. 展开"配置"容器，再展开 CN=Administrative Groups,CN=<OrganizationName>,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=<DomainName>,DC=com。

  7. 右键单击想要修改的管理组，并选择"属性"。

  8. 在"属性"字段中，向下滚动并选择 siteFolderServer 属性。

  9. 单击"编辑"按钮，并将 distinguishedName 属性的值粘贴到"值"字段中。

  10. 仔细检查"值"字段的内容，确保粘贴正确完成，再单击"确定"保存更改。

  11. 单击"确定"关闭管理组属性对话框。

  12. 退出 ADSI Edit，并在站点中的所有 Exchange Server 计算机上重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

有关重新创建系统文件夹和重置站点文件夹服务器的详细信息，请参阅下列 Microsoft 知识库文章：

  • 275171"如何在 Exchange 2000 Server 上重置系统文件夹"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=275171)

  • 284200"Schedule+ Free/Busy System Folder Is Missing"（缺少 Schedule+ 忙/闲系统文件夹）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=284200)

有关使用 LDP 工具的详细信息，请参阅 Microsoft 知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（使用 LDP 实用程序修改 Active Directory 对象属性）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

有关使用 ADSI Edit 的详细信息，请参阅 Windows Server 联机帮助中的主题"Adsiedit.msc:ADSI Edit"主题。


检测不到脱机通讯簿所使用的站点文件夹服务器公用文件夹存储
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2007-02-01

Microsoft® Exchange Server 分析工具查询 Active® Directory 目录服务，以确定所有 Exchange 公用文件夹存储（objectClass 为 objectClass=msExchPublicMDB 的存储）的 siteFolderServer 属性值。siteFolderServer 属性代表用于脱机通讯簿服务器的公用文件夹存储。

如果 Exchange Server 分析工具确定未列出服务器、所列服务器已停机或所列服务器不存在，则显示警告。如果 siteFolderServer 属性包含字符串"DEL:"，则 Exchange Server 分析工具将显示错误消息。

默认情况下，Exchange Server 2003 在站点文件夹服务器（安装在管理组中的第一个服务器）上生成脱机通讯簿文件。如果已经指定了另外一个服务器充当脱机通讯簿服务器，则该属性中列出的公用文件夹存储将是新的脱机通讯簿服务器上的存储，而不是管理组的实际站点文件夹服务器上的存储。

Exchange Server 2003 生成脱机通讯簿文件时，会将这些文件附加到邮件中，并将邮件放入特殊的公用文件夹。Microsoft Office Outlook® 2003 从文件夹中检索该邮件，并下载所附文件。

在 Exchange Server 2003 中，脱机通讯簿邮件存储在 OFFLINE ADDRESS BOOK 文件夹（它是默认的"公用文件夹"树中的一个系统文件夹）的子文件夹中。拓扑结构中的每个管理组或站点在该文件夹中都有一个子文件夹。默认情况下，特定管理组文件夹的内容副本驻留在该管理组中安装的第一台服务器（称为"站点文件夹服务器"）上。

如果您的 Exchange 组织是 Exchange Server 2007，且不包含任何下级（Outlook 2003 或更低版本）客户端，则可以放心地忽略此警告或错误。如果您的 Exchange Server 2007 组织承载了运行 Outlook 2003 或更低版本的客户端，请按照以下步骤启用脱机通讯簿文件的公用文件夹通讯组。公用文件夹通讯组是一种通讯组方法，运行脱机工作或通过拨号连接的 Outlook 2003 或更低版本的客户端可通过该方法访问 OAB。

在 Exchange Server 2003 上更正此警告

  1. 如果知道服务器确实存在，请在 Exchange 系统管理器的"服务器"下，展开服务器，展开存储组，再单击"公用文件夹存储"。检查右侧窗格，确保存储正在运行。

  2. 若要指定新的脱机通讯簿服务器，请在"收件人"下，单击"脱机地址列表"。然后在右侧窗格中，单击"默认脱机地址列表"（或产生该邮件的任何其他脱机地址列表）。

    如果不想使用脱机通讯簿，请右键单击"默认脱机地址列表"，再单击"删除"。否则，使用该过程的其余步骤设置一个日程安排。

  3. 右键单击"默认脱机地址列表"，再单击"属性"。

  4. 在"常规"选项卡的"脱机地址列表服务器"下，单击"浏览"选择一个服务器。

在 Exchange Server 2007 上更正此警告

  1. 打开 Exchange 管理控制台。

  2. 展开 Microsoft Exchange，展开"组织配置"，然后选择"邮箱"。

  3. 在结果窗格中，单击"脱机通讯簿"选项卡。

  4. 在"脱机通讯簿"选项卡上，选择"默认脱机通讯簿"。

    1. 若要启用脱机通讯簿的公用文件夹通讯组，请在"通讯组"选项卡上选择"启用公用文件夹通讯组"。

    2. 单击"确定"保存更改

  5. 若要指定新的脱机通讯簿服务器，请在操作窗格中单击"移动"来启动"移动脱机通讯簿向导"。通过此向导，可以将 OAB 生成移动到其他服务器。它还会将现有的 OAB 文件复制到指定的服务器。

使用 Exchange 命令行管理程序启用脱机通讯簿文件的公用文件夹通讯组。

  • 运行下列命令：

    复制代码
    Set-OfflineAddressBook -Identity <OAB> -PublicFolderDistributionEnabled $true

    其中：<OAB> 是可分辨名称 (DN)、域\帐户名称或 OAB 的 GUID。

    例如，若要启用默认脱机通讯簿的公用文件夹通讯组，应输入：
复制代码
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -PublicFolderDistributionEnabled $true

使用 Exchange 命令行管理程序来设置将承载脱机通讯簿生成的服务器

  • 运行下列命令：

    复制代码
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    其中：<OAB> 是可分辨名称 (DN)、域\帐户名称或 OAB 的 GUID，而 <Server> 则指定了将在其上执行所选操作的 Exchange 服务器。

    例如，若要将 OAB 生成移至 SERVER01.，应输入：
复制代码
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

有关在 Exchange Server 2003 中使用脱机通讯簿的详细信息，请参阅"Working with the Exchange Server 2003 Store"（使用 Exchange Server 2003 存储）中的"Configuring Exchange Server 2003 Offline Address Books"（配置 Exchange Server 2003 脱机通讯簿）(http://go.microsoft.com/fwlink/?LinkId=47595)。

有关在 Exchange Server 2007 中使用脱机通讯簿的详细信息，请参阅"Organization Configuration > Mailbox > Offline Address Books"（组织配置 > 邮箱 > 脱机通讯簿）(http:// go.microsoft.com/fwlink/?LinkId =79247)。


SiteName 为硬编码
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Exchange 服务器上是否存在 SiteName 注册表值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Netlogon\Parameters\SiteName

如果 Exchange Server 分析工具发现 SiteName 注册表值存在，将显示警告。

该警告表明在该运行 Microsoft Windows® 操作系统的计算机上，Active Directory® 目录服务站点成员身份已硬编码。Exchange Server 不建议使用该配置。

如果对 Windows 站点进行硬编码，可能会造成 Microsoft Exchange System Attendant 服务故障以及常规 Exchange Server 故障。应考虑删除 SiteName 注册表值。如果删除 SiteName 注册表值，Windows 将自动加入相应的 Active Directory 站点。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
删除 SiteName 注册表值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\Netlogon\Parameters

  3. 在右侧窗格中，找到并删除 SiteName 注册表值。

  4. 关闭注册表编辑器，并重新启动服务器，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 SiteName 注册表值的详细信息，请参阅知识库文章 322834"XADM: Event 1005, System Attendant Does Not Start"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322834)。


Exchange 组织中有 900 个以上的管理组
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2006-04-21

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Exchange 组织中存在的管理组的数目。如果 Exchange Server 分析工具发现管理组的数目超过 900，将显示警告消息。

建议任何单一 Exchange 对象类型的实例数不超过 900 个。这是因为 Active Directory 默认将 1,000 作为它返回给任何给定请求的最大页大小。这意味着，如果发出对某个对象的轻型目录访问协议 (LDAP) 请求，并且 Active Directory 中存在该对象的 1,000 个以上的实例，则由于超过了最大页面大小而不会返回任何结果。

在 Exchange 中，会有各种进程请求特定对象类型的实例。例如，Exchange 系统管理器向 Active Directory 发出 LDAP 查询，以创建 Exchange 组织中的所有管理组的列表视图。如果存在 1,000 个以上的管理组，Active Directory 将不会返回任何结果。因此，Exchange 系统管理器中显示错误，并且不会显示任何管理组。

尽管可以增加 Active Directory 的最大页大小值，但是对于 Exchange 不建议或不支持这样做。在 Exchange 环境中增加最大页大小值会出现奇怪的行为或产生故障。

尽管建议将 Exchange 中的任何单一对象类型的实例数保持在 900 或 900 以下，但最多可支持 1,000 个对象实例。

要解决此问题，应考虑合并管理组。

有关合并 Exchange 站点和管理组的详细信息，请参阅：

  • Deploying a Worldwide Site Consolidation Solution for Exchange Server 2003 at Microsoft（英文）(http://go.microsoft.com/fwlink/?LinkId=33531)


Exchange 组织中有超过 900 个 Exchange 服务器
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2006-03-30

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以获得该目录中 objectCategory 为 msExchExchangeServer 的对象数。该计数代表在 Active Directory 中找到的 Exchange Server 计算机数目。如果 Exchange Server 分析工具发现有超过 900 个 Exchange Server 计算机，则会显示警告。

建议任何单个 Exchange 对象类型的实例个数不超过 900 个。这是因为 Active Directory 默认将 1,000 作为它返回给任何给定请求的最大页面大小。这意味着，如果发出对某个对象的轻型目录访问协议 (LDAP) 请求，并且 Active Directory 中存在该对象的 1,000 个以上的实例，则由于超过了最大页面大小而不会返回任何结果。

对于 Exchange Server 来说，各种进程都会请求对具体的对象类型进行实例化。例如，Exchange 系统管理器向 Active Directory 发出 LDAP 查询，以创建 Exchange 组织中所有 Exchange 服务器的列表视图。如果存在 1,000 个以上的 Exchange 服务器，Active Directory 将不会返回任何结果。结果，将在 Exchange 系统管理器上显示错误，并且不会显示任何 Exchange Server 计算机。

尽管可以增加 Active Directory 的最大页面大小值，但是对于 Exchange 不建议或不支持这样做。已经发现在 Exchange 环境中增加最大页面大小值导致了意外的行为或故障。

尽管我们建议在 Exchange Server 中任何单个对象类型不超过 900，但系统可支持最多 1,000 个对象类型。

解决此警告问题

  1. 考虑合并组织中的 Exchange 服务器。

  2. 检查 Active Directory 中是否有孤立的 Exchange Server 计算机，并将它们从 Active Directory 中删除。

有关合并 Exchange 服务器的详细信息，请参阅"Server Consolidation Using Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=47586)。


在组织级别委派了十个以上的管理员
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2006-12-03

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定拥有 Exchange 管理员和/或 Exchange 管理员（完全控制）权限的用户数。Exchange Server 分析工具对 msExchAdmins 属性中列出的条目数进行计数，该属性代表指向组织中所有 Exchange 管理员及其相应权限的链接。如果 Exchange Server 分析工具发现有超过 10 个用户拥有 Exchange 管理员和/或 Exchange 管理员（完全控制）权限，则显示警告。

msExchAdmins 是 Exchange 根组织容器的多值属性。它所包含的安全标识符 (SID) 列表代表具有所委派的 Exchange 权限的用户帐户。

最佳做法是限制对 Exchange 组织有写入访问权的用户数。请考虑在组织级别减少 Exchange 管理员和 Exchange 管理员（完全控制）的人数。通过对照邮件基础结构的要求对管理角色进行复查，可能会发现可以在组织级别将很多这样的用户转换为 Exchange 管理员（仅查看），而在管理组级别将 Exchange 管理员角色委派给他们。

解决此警告问题

  1. 考虑减少拥有 Exchange 管理员和/或 Exchange 管理员（完全控制）权限的用户数。

  2. 考虑对组织中的 Exchange Server 权限执行审核，以确保它们是合适的。

有关计划和配置 Exchange 中权限的详细信息，请参阅：

  • "Working with Active Directory Permissions in Exchange Server"（在 Exchange Server 中使用 Active Directory 权限）(http://go.microsoft.com/fwlink/?LinkId=47592)。

  • Microsoft Exchange Server 2007，操作"Configuring Permissions"（配置权限）(http://go.microsoft.com/fwlink/?LinkId=78432)。

  • Microsoft Exchange Server 2007，规划和体系结构，规划 Active Directory"Permission Considerations"（权限注意事项）(http://go.microsoft.com/fwlink/?LinkId=78433)。

有关 Exchange Server 2003 中的管理角色的详细信息，请参阅 Microsoft 知识库文章 823018"Overview of Exchange Administrative Role Permissions in Exchange 2003"（Exchange 2003 中 Exchange 管理角色权限概述）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823018)。

有关 Exchange 2000 Server 中管理角色的详细信息，请参阅知识库文章 289811"XGEN:Exchange 2000 Role Permissions"（XGEN: Exchange 2000 角色权限）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=289811)。


未将该连接协议设置为在出现不匹配时创建禁用的帐户
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个连接协议对象的 msExchServer1AlwaysCreateAs 属性值。如果 Exchange Server 分析工具确定 msExchServer1AlwaysCreateAs 属性未设置为 1，则显示警告。

msExchServer1AlwaysCreateAs 属性确定 X.500 对象如何与 Active Directory 同步。值为 0 说明已将连接协议配置为创建 Microsoft Windows® 联系人。如果该属性的值为 1，则说明已将连接协议配置为在 Active Directory 中创建禁用的 Windows 用户帐户。值为 2 说明已将连接协议配置为创建新的 Windows 用户帐户。

Exchange Server 分析工具将发出警告，因为如果 Exchange Server 5.5 必须与 Active Directory 共存，并且已计划完整迁移到 Exchange Server 2003，则让 Active Directory 连接器 (ADC) 创建禁用的 Windows 用户帐户是很重要的。这些禁用的 Windows 用户帐户是"已启用邮箱的"，这意味着它们在逻辑上与存在于 Exchange Server 5.5 计算机上的邮箱关联。创建禁用的 Windows 用户帐户是有必要的，这样一来，代表该禁用的 Windows 帐户的用户对象最后才能访问公用文件夹和 Active Directory 中其他受保护的对象。

在 ADC 用户界面中有三个创建新对象的选项，如果没有在 Active Directory 中找到 Exchange Server 5.5 中的邮箱的匹配对象，则可以使用这些选项。这些选项在连接协议的属性的"高级"选项卡中列出，如下所示：

  • 创建 Windows 联系人 这不是推荐设置，因为 Contact 对象没有安全上下文。

  • 创建新的 Windows 用户帐户 这不是推荐设置，因为所创建的新帐户将有新的 SID，因此，在迁移期间 Microsoft Windows NT® Server 4.0 用户帐户的 SID 历史记录将不会传递到该新帐户（因为 SID 不同）。

  • 创建禁用的 Windows 用户帐户 这是推荐设置，因它为允许 Windows NT Server 4.0 用户（对资源有正确的访问权）共存，直到完成完整的迁移。

解决此警告问题

  1. 将 Active Directory 收件人连接协议配置为创建已启用邮箱的、禁用的 Windows 用户帐户。

  2. 使用 Active Directory 迁移工具，该工具可以将 Windows NT Server 4.0 用户帐户迁移到 Active Directory，并创建启用的 Windows 帐户。这些启用的 Windows 帐户将与 ADC 所创建的禁用的 Windows 帐户拥有相同的 SID。

  3. 使用 Active Directory 清理向导 (ADClean)，该向导可以将 Active Directory 迁移工具所创建的帐户中的信息合并到 ADC 所创建的帐户中。

有关 Active Directory 连接器收件人连接协议的详细信息，请参阅下列 Microsoft 知识库文章：

  • 823601"Active Directory 连接器在整个组织内的要求和影响"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180"Active Directory Connector Requirements for Mixed Administrative Groups"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)

  • 296260"XGEN:How to Configure a Two-Way Recipient Connection Agreement for Exchange 5.5 Users"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=296260)

  • 有关 Active Directory 清理向导的详细信息，请参阅下列知识库文章：

  • 270652"Possible Uses of the Active Directory Account Cleanup Wizard"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270652)

  • 有关 Active Directory 迁移工具的详细信息，请参阅下列知识库文章：

  • 260871"HOW TO：设置 ADMT 以从 Windows NT 4.0 迁移到 Windows 2000"(http://support.microsoft.com/kb/260871/zh-cn)


这是来自 Exchange 的单向连接协议
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个连接协议对象的 msExchSynchronizationDirection 属性值。msExchSynchronizationDirection 属性表示将沿着哪个方向进行目录同步。如果该属性设置为 2，则会显示警告。

msExchSynchronizationDirection 属性的值可以是 0 或 2。如果该属性被设置为 0，则说明这是双向连接协议。如果该属性被设置为 2，则说明它是来自 Exchange Server 计算机的单向连接协议。

作为最佳做法，建议您使用双向连接协议。混合模式下的 Exchange 环境（Exchange Server 5.5 与 Exchange 2000 Server 和/或 Exchange Server 2003 共存）要求使用双向连接协议。

解决此警告问题

  1. 删除现有的单向连接协议。

  2. 创建一个替代的双向连接协议。

有关 Active Directory 连接器 (ADC) 连接协议的详细信息，请参阅下列 Microsoft 知识库文章：

  • 823601"Active Directory 连接器在整个组织内的要求和影响"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180"Active Directory Connector Connection Agreement Requirements for Mixed Administrative Groups"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)

  • 317721"XADM:Exchange Server 5.5 Mailbox Owner Rights Are Removed When You Change the ADC Connection Agreement from a One-Way Connection Agreement to a Two-Way Connection Agreement"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721)


这是来自 Windows 的单向连接协议
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个连接协议对象的 msExchSynchronizationDirection 属性的值。msExchSynchronizationDirection 属性代表将沿着哪个方向同步目录。如果该属性设置为 1，则会显示警告。

msExchSynchronizationDirection 属性的值可以为 0、1 或 2。0 表示双向连接协议，1 表示来自 Active Directory 的单向连接协议，2 表示来自 Exchange Server 计算机的单向连接协议。

推荐的最佳实践是使用双向连接协议。混合模式下的 Exchange 环境（Exchange Server 5.5 与 Exchange 2000 Server 和/或 Exchange Server 2003 共存）要求使用双向连接协议。

解决此警告问题

  1. 删除现有的单向连接协议。

  2. 创建一个替代的双向连接协议。

有关 Active Directory 连接器 (ADC) 连接协议的详细信息，请参阅下列 Microsoft 知识库文章：

  • 823601"Active Directory 连接器在整个组织内的要求和影响"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180"Active Directory Connector Connection Agreement Requirements for Mixed Administrative Groups"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)

  • 317721"XADM:Exchange Server 5.5 Mailbox Owner Rights Are Removed When You Change the ADC Connection Agreement from a One-Way Connection Agreement to a Two-Way Connection Agreement"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721)


Exchange 与 Active Directory 之间的时间戳比较超过 5 分钟
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Win32_UTCTime Microsoft Windows® Management Instrumentation (WMI) 类，以确定每台 Exchange 服务器上的日期和时间。Exchange Server 分析工具还检索默认域控制器上的当前日期和时间。如果 Exchange Server 分析工具确定两台服务器之间相差 5 分钟或 5 分钟以上，则显示错误。

Microsoft Windows 2000 Server 和 Windows Server™ 2003 使用 Windows 时间服务来同步在基于 Windows 的网络上运行的计算机的日期和时间。在 Windows 2000 Server 和 Windows Server 2003 中，时间同步至关重要，因为默认的身份验证协议使用工作站时间作为身份验证凭据生成进程的一部分。MIT Kerberos 版本 5 是默认的身份验证协议。

对于 Active Directory® 目录服务域中的所有基于 Windows 的服务器，Windows 时间服务使用域控制器上提供的 Windows 时间服务自动对自身进行配置。Windows 时间服务将其域中的域控制器配置为可靠的时间源，并定期将自身与此时间源进行同步。

若要更正此错误，请将 Exchange 服务器上的时钟与目录服务器进行同步。

同步 Active Directory 域中的服务器上的时钟

  1. 打开命令提示。

  2. 键入 w32tm /resync，再按 Enter 键。

如果此错误仍然存在，或组织中的许多计算机出现此错误，请检查 Windows 时间服务是如何在您的 Active Directory 目录林中进行部署和配置的。有关 Windows 时间服务的详细信息，请参阅"Windows Time Service Technical Reference"（英文）(http://go.microsoft.com/fwlink/?LinkId=40648)。

如果 Exchange 前端服务器与 Active Directory 时间不同步，客户端在尝试连接到 Microsoft Office Outlook® Web Access 时，可能会收到"HTTP 500 内部服务器"错误。有关这种情况的详细信息，请参阅 Microsoft 知识库文章 841546"Known issues that cause the 'HTTP 500 internal server error' error message in Exchange 2000 Outlook Web Access"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841546)。


Active Directory 连接器服务器与 Active Directory 之间的时间戳比较超过 5 分钟
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Win32_UTCTime Microsoft Windows® Management Instrumentation (WMI) 类，以确定每个 Active Directory 连接器 (ADC) 服务器上的日期和时间。Exchange Server 分析工具还检索默认域控制器上的当前日期和时间。如果 Exchange Server 分析工具确定两台服务器之间相差 5 分钟或 5 分钟以上，则会显示错误。

Microsoft Windows 2000 Server 和 Windows Server™ 2003 使用 Windows 时间服务来同步在基于 Windows 的网络上运行的计算机的日期和时间。在 Windows 2000 Server 和 Windows Server 2003 中，时间同步至关重要，因为默认的身份验证协议使用工作站时间作为身份验证凭据生成进程的一部分。MIT Kerberos 版本 5 是默认的身份验证协议。

对于 Active Directory® 目录服务域中的所有 Windows 服务器，Windows 时间服务使用域控制器上提供的 Windows 时间服务自动对自身进行配置。Windows 时间服务将其域中的域控制器配置为可靠的时间源，并定期将自身与此时间源进行同步。

若要更正此错误，请将 ADC 服务器上的时钟与目录服务器进行同步。

同步 Windows 2000 Server 或 Windows Server 2003 域中的服务器上的时钟

  1. 打开命令提示。

  2. 键入 w32tm /resync，再按 Enter 键。

如果此错误仍然存在，或组织中的许多计算机出现此错误，请检查 Windows 时间服务是如何在您的 Active Directory 目录林中进行部署和配置的。有关 Windows 时间服务的详细信息，请参阅"Windows Time Service Technical Reference"（英文）(http://go.microsoft.com/fwlink/?LinkId=40648)。


Windows Server 2003 未运行最终发行的内部版本
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange 组织中 Active Directory 连接器 (ADC) 服务器的 Version 关键字的值。Exchange Server 分析工具还检查以下注册表项，以确定正在 ADC 服务器上运行的 Windows 的版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

如果 Exchange Server 分析工具发现第二个 CurrentVersion 实例的值是 5.2，并且 Version 的值不等于 5.2.3790，则会显示错误。

CurrentVersion 值为 5.2 说明计算机正在运行 Windows Server 2003 操作系统。所有 Windows Server 2003 操作系统的发行版本的 Version 值都是 5.2.3790。如果 Version 关键字是任何其他值，则说明正在使用 Windows Server 2003 的预发行版本。

除非您是 Technology Adoption Program (TAP) 或类似 Microsoft 发起的计划的参与者，否则 Microsoft 不支持或不推荐在生产环境中使用预发行软件。

更正此错误

  1. 将包括域控制器、全局编录服务器、ADC 服务器以及 Exchange Server 计算机在内的所有 Exchange 基础结构服务器升级到最新发行的软件。

  2. 如果升级选项可用或受支持，请重建操作系统，并还原 Exchange Server 设置和数据。

将包括域控制器、全局编录服务器、ADC 服务器以及 Exchange Server 计算机在内的所有 Exchange 基础结构服务器升级到最新发行的软件。

有关 Windows Server 2003 软件更新的详细信息，请参阅网站上的"Windows Server 2003 Software Updates"（英文）(http://go.microsoft.com/fwlink/?LinkId=33760)。


Windows Server 2003 正在运行预发行软件
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具检查 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 ServicePackMajorVersion 关键字的值。Exchange Server 分析工具还检查以下注册表项，以确定目标计算机上运行的 Windows 的版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

如果第二个 CurrentVersion 实例的值为 5.2，并且 ServicePackMajorVersion 的值大于 1，则 Exchange Server 分析工具将显示警告消息。

CurrentVersion 值为 5.2 说明计算机正在运行 Microsoft Windows Server™ 2003 操作系统。ServicePackMajorVersion 大于 1 表明已安装的 Service Pack 版本要高于的 Service Pack 1 (SP1)。因为 SP1 是为 Windows Server 2003 发行的唯一一个 Service Pack，所以已安装的任何 Windows Server 2003 Service Pack 2 或更高版本一定是预发行软件。

除非您是 Technology Adoption Program (TAP) 或类似 Microsoft 发起的计划的参与者，否则不推荐在生产环境中运行预发行软件。

解决此警告问题

  1. 卸载任何已安装的预发行软件。

  2. 如果卸载选项可用，请重建操作系统，并还原 Exchange Server 设置和数据。

有关 Windows Server 2003 软件更新的详细信息，请参阅网站上的"Windows Server 2003 Software Updates"（英文）(http://go.microsoft.com/fwlink/?LinkId=33760)。


Windows 2000 Server 未运行 Service Pack 4
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具检查 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 ServicePackMajorVersion 关键字的值。Exchange Server 分析工具还检查以下注册表项，以确定目标计算机上运行的 Windows 的版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

如果 Exchange Server 分析工具确定目标系统运行的是 Windows 2000 Server 操作系统，但未运行 Windows 2000 Server 的 Service Pack 4，则会显示警告。

建议在 Exchange 部署环境中安装所有软件的最新 Service Pack，这是最佳实践。

解决此警告问题

  1. 将运行 Windows 2000 Server 操作系统的所有域控制器和全局编录服务器更新到 Service Pack 4，并安装从 Windows Update 获取的最新修补程序和更新。

  2. 将所有 Exchange Server 计算机更新到最新的 Service Pack 和更新汇总。

有关获取和安装 Windows 2000 Server 操作系统的 Service Pack 的详细信息，请参阅网站上的"Windows 2000 Service Packs"（英文）(http://go.microsoft.com/fwlink/?linkid=18353)。

有关获取和安装 Exchange Server Service Pack 和更新汇总的详细信息，请参阅网站上的"Microsoft Exchange Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=21573)。


Windows 2000 Server 运行的不是最终发行的内部版本
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2005-11-17

Microsoft® Exchange Server 分析工具查询 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Version 关键字的值。

Exchange Server 分析工具还检查以下注册表项，以确定计算机上运行的 Windows 的版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 值为 5.0 说明计算机正在运行 Microsoft Windows 2000 Server 操作系统。所有 Windows 2000 Server 操作系统发行版的 Version 值都为 5.0.2195。如果 Version 关键字为其他任何值，则意味着使用的是 Windows 2000 Server 的预发行版。

如果 Exchange Server 分析工具发现第二个 CurrentVersion 实例的值为 5.0，而 Version 的值不等于 5.0.2195，则显示错误。

除非您是 Technology Adoption Program (TAP) 或类似 Microsoft 发起的计划的参与者，否则 Microsoft 不支持或不推荐在生产环境中使用预发行软件。

更正此错误

  1. 将包括域控制器、全局编录服务器、Active Directory 连接器 (ADC) 服务器以及 Exchange Server 计算机在内的所有 Exchange 基础结构服务器升级到最新发行的软件。

  2. 如果升级选项可用或受支持，请重建操作系统，并还原 Exchange Server 设置和数据。

有关获取并安装 Windows 2000 Service Pack 4 的信息，请参阅网站上的"Windows 2000 Service Pack 4"（英文）(http://go.microsoft.com/fwlink/?LinkId=33241)。


X.400 地址的终止符无效
Microsoft Exchange Server 分析工具 - 文章 > Active Directory >

主题上次修改时间： 2006-12-03

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定收件人策略中 gatewayProxy 的值并验证 X.400 地址是否以分号结尾。

收件人策略中 X.400 地址的正确格式指明了地址以分号结尾。如果没有分号，将使到 X.400 地址的邮件路由中断。

若要解决此问题，必须使用 Active Directory 服务接口 (ADSI) Edit 或 LDP 工具在地址结尾添加分号。

警告：
在使用 ADSI Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003/Exchange Server 2007 才能解决。修改 Active Directory 对象的属性的风险由您自己承担。
更正此错误

  1. 打开 Active Directory 编辑器，如 ADSI Edit。

  2. 展开 Configuration [DomainName]，再展开 CN=Configuration, DC=DomainName, DC=DomainSuffix。

  3. 展开 CN=Services，再展开 CN=Microsoft Exchange。

  4. 展开 CN=OrganizationName，再展开 CN=Administrative Groups，然后展开 CN=Recipient Policies。

  5. 右键单击 CN=PolicyName，然后选择"属性"。

  6. 向下滚动到 gatewayProxy 并选中该项，然后单击"编辑"。

  7. 在"值"字段中，输入正确的 gatewayProxy。

  8. 关闭 Active Directory 编辑器，并重新启动 Exchange Server 计算机，以使更改生效。


数据库恢复
Microsoft Exchange Server 分析工具 - 文章 >

主题上次修改时间： 2007-01-22

此部分中的文章提供了有关 Microsoft® Exchange 数据库故障排除程序工具在应用程序事件日志中检测到的数据库错误和警告事件的详细信息。数据库故障排除程序使用与 Microsoft Exchange 故障排除助理相同的引擎，以编程方式执行一组故障排除步骤来确定数据库装入问题的根本原因。此外，这些文章还提供了用于确定症状并解决数据库相关问题的步骤。

有关此工具以及如何下载的详细信息，请参阅 Microsoft Exchange Troubleshooting Assistant v1.0（Microsoft Exchange 故障排除助理 1.0 版）。


ESE 428 (0xfffff8f0)：事务日志驱动器上保留的可用空间不足
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-04-02

Microsoft® Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个 ESE 428 事件。此事件表明事务日志驱动器上的可用空间不足。发生此错误时，Exchange Server 将无法新建事务日志文件。这将导致在受影响存储组中的所有数据库脱机，因为对数据库的更新必须记录在事务日志中。

解释

Exchange Server 提供两种机制来防止事务日志驱动器被占满：

  • 循环日志记录。数据库检查点前移过事务日志后，事务日志会被自动删除。在大多数条件下，用于事务日志文件的磁盘空间将保持在 50 MB 以下。在备份期间，对事务日志的删除可能被挂起，直至备份完成。

    注意：
    默认情况下，Microsoft Exchange 2000 Server 和更高版本中不启用循环日志记录。
  • 存储组备份。通过使用可实现 Exchange Server 的卷影复制服务 (VSS) 或联机流式备份 API 的备份方法，对存储组中的所有数据库执行了完整或增量联机备份后，Exchange Server 会删除多余的日志。

如果未启用循环日志记录并且下述任一条件为真，则事务日志文件的数量会一直增长，直至硬盘驱动器空间用尽：

  • 备份程序不会删除事务日志文件。

  • 备份程序已经停止运行。

  • 不应通过其他某种方法清除事务日志文件。

在耗尽硬盘空间的情况下，可能偶尔需要手动删除事务日志文件。或者，如果期望在对特定存储组中所有数据库进行完整或增量联机备份之前腾出硬盘空间，可能偶尔需要手动删除事务日志文件。如果删除了仍位于任何数据库检查点之前的日志，则数据库会异常停止，直到恢复了必要的日志才能装入该数据库。因此，在手动删除任何 Exchange Server 事务日志文件之前，必须确定删除哪些日志是安全的。

也可能以 JET_errDiskFull 或错误代码 0xfffff8f0 的形式报告该错误。此错误适用于以下版本的 Exchange Server：

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

用户操作

若要解决此错误，请选择下述两个解决方案之一：

  • 运行"数据库恢复管理"工具。在 Microsoft Exchange Server 2007 中，该工具在 Exchange 管理控制台的"工具箱"中的"数据恢复"工具下列出。Exchange Server 分析工具可以自动确定可安全删除哪些日志文件并为您将其复制到相应的备份位置。强烈建议使用 Exchange Server 分析工具移动日志文件。

    注意：
    如果为群集连续复制 (CCR) 启用了包含数据库的存储组，则 Exchange Server 分析工具将不能在 Exchange 2007 中工作。
  • 检查每个数据库头中"状态"和"所需日志"值，以确定哪些事务日志文件可以安全手动删除。

    注意：
    就本文而言，"移除"事务日志文件意味着将事务日志文件移至其他位置，在该处可以对其进行备份、存储或删除。该操作视您的要求而定。就本文而言，"删除"事务日志文件是指那种使您无法备份或恢复该事务日志文件的删除类型。

遵循以下详细步骤，以确定哪些事务日志文件可以安全手动删除。

检查数据库头并删除不必要的日志文件

  1. 卸除要检查其头的数据库。

  2. 单击"开始"，单击"运行"，然后键入 cmd 以打开命令提示符窗口。

  3. 在命令提示符下，移到数据库文件所在的目录路径。

    注意：
    在 Exchange 2000 Server 和 Exchange Server 2003 中，要确定数据库的 .edb 和 .stm 文件的路径和文件名，请使用 Exchange 系统管理器查看每个数据库对象的属性对话框的"数据库"选项卡。在 Exchange Server 2007 中，要确定数据库文件的名称和路径，请在"服务器配置"下展开"Exchange 管理控制台"，单击"邮箱"，然后查看"数据库管理"选项卡。

  4. 在命令提示符下，键入以下 Eseutil 命令以及 /MH 开关：

    复制代码
    "eseutil /MH databasefilename.edb"
    注意：
    在此语法中，databasefilename 是要检查的数据库的名称。

  5. 检查所出现的头信息中的"状态"和"所需日志"值。

    "状态"值提供了有关数据库是否已经正确分离的下述信息：

    • 如果数据库已经正确分离，则"状态"值为"干净关闭"或"一致"。该值视正在运行的 Exchange Server 版本而定。可以删除当前事务日志文件之外的所有事务日志文件。

      注意：
      如果在所有数据库都处于"干净关闭"状态时删除了当前日志文件，将导致日志文件序列的重置。此操作无法避免数据库启动。但是，在发生此情况时，日志文件序列的重置将影响通过以前的备份对数据库进行前滚的能力。
    • 如果数据库没有正确分离，则"状态"值为"肮脏关闭"或"不一致"。通过检查数据库头中的"所需日志"字段，确定可以删除哪些事务日志文件。

      注意：
      在数据库处于"肮脏关闭"或"不一致"状态时，意味着某些现有事务日志文件包含未处理的数据库所需事务。如果在此情况下删除事务日志文件，则无法再次启动数据库，除非通过备份还原数据库。或者，可以使用 Eseutil 命令和 Isinteg 命令修复数据库。
      在删除存储组中的任何日志之前，都应该检查该存储组中每个数据库的"所需日志"值。

      "所需日志"字段列出了启动此数据库所需的编号日志文件的范围。如果范围为 0 - 0，则启动此数据库不需要任何日志文件。这表明数据库处于"干净关闭"或"一致"状态。如果存在早于检查点日志的日志文件，则可以删除这些日志文件（不包括检查点日志）。

      如果所运行的 Exchange Server 版本早于 Exchange Server 2003 Service Pack 1 (SP1)，则必须将"所需日志"字段中列出的十进制范围转换为十六进制值。例如，如果"所需日志"值为 28217 - 28221，则此数据库所需日志文件的范围是从 06E39 到 06E3D。在 Exchange 2003 SP1 中，已经对"所需日志"字段进行了增强以报告十进制值和十六进制值。

      注意：
      可以使用 Windows 计算器的"科学型"将十进制转换为十六进制。启动"计算器"，在"查看"菜单中单击"科学型"。输入十进制数，然后单击"十六进制"。
      因为在 Exchange 2000 和 Exchange 2003 中可以拥有多达四个存储组，并且每个存储组都拥有一组特定的日志文件，所以事务日志文件名称中不会出现 Edb 前缀。在 Exchange 2000 和 Exchange 2003 中，Edb 前缀被替换为 E00、E01、E02 或 E03。对于恢复存储组，Edb 前缀被替换为 R00。存储组日志文件名前缀出现在 Exchange 系统管理器中特定存储组对象的属性对话框中的"常规"选项卡上。因此，如果存储组前缀为 E01 并且"所需日志"条目为 28217 - 28221 (0x06E39 - 0x06E3D)，则实际所需日志的范围是 E0106E39.log 到 E0106E3D.log。

  6. 可以安全删除小于存储组中任何数据库的"所需日志"字段最低条目的所有编号日志文件。

    注意：
    请记住，是移动而不是删除日志文件。
    注意：
    作为最佳实践，不应删除最近的事务日志文件。它指的是拥有最近的时间戳并且其文件名中不带有序列号的日志文件。即使已经确定可以安全删除此文件，也要保留它以避免将日志文件序列重置回 0。如果重置日志文件序列，将影响备份周期。您可能无法通过重置之前执行的备份对数据库进行前滚。


ESE 454 -515：缺少所需的事务日志文件
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-01-23

Microsoft® Exchange Server 分析工具发现错误代码为 -515 的 ESE 事件 454。此错误表明由于缺少所需的事务日志文件而无法装入 Exchange 数据库。

解释

如果可扩展存储引擎 (ESE) 在恢复过程中尝试使存储组中的所有数据库保持一致状态，则可能会发生错误代码为 -515 的 ESE 454 事件。如果缺少所需的任何事务日志文件，则会发生 -515 错误，恢复过程将会失败并且无法装入数据库。

用户操作

若要解决该问题，请执行以下一个或多个操作：

  • 请使用此处的过程来确定缺少的事务日志文件及其所在的位置。然后，将这些文件移回到存储组的事务日志目录中。

  • 从备份中还原受影响的数据库。

警告：
除非先前查找并还原缺少的特定事务日志文件的解决方案已失败，否则，不应尝试还原数据库。这样做将导致覆盖自上次备份以后生成的所有数据。
注意：
在还原数据库之前，请移动或删除目标路径中与受影响的存储组关联的所有事务日志文件。
使用 Exchange Server 2003 和 Exchange Server 2007 中的 Microsoft Exchange 故障排除助理来确定缺少的事务日志文件

  1. 从 Microsoft Exchange 故障排除助理的"显示检查事件日志结果"窗口中，单击"使用相关数据库恢复管理任务来验证并解决此问题"链接来确定缺少的所需事务日志文件。

  2. 记录在步骤 1 中报告的日志文件名称。

  3. 确定日志文件的当前位置，并将它们移回到预期位置。
注意：
在确定缺少的事务日志文件的当前位置时，应确保搜索回收站和所有防病毒隔离文件夹。
  1. 尝试装入受影响的 Exchange 数据库。

 在 Exchange 2000 Server 或 Exchange Server 2003 中手动确定并还原缺少的事务日志

  1. 启动 Exchange 系统管理器。

  2. 展开"管理组"，展开您的管理组，然后展开"服务器"，右键单击您的存储组，然后单击"属性"。

  3. 在"常规"选项卡的"事务日志位置"下，记录事务日志文件位置的路径。

  4. 在命令提示符下，打开 Eseutil.exe 所在的目录。在 Exchange 2000 Server 和 Exchange Server 2003 中，Eseutil.exe 的默认路径是 C:\program files\exchsrvr\bin。

  5. 在命令提示符下，输入以下命令：

    复制代码
    eseutil /ml "logpath\logprefix"

    其中，logpath 是在步骤 3 中记录的事务日志文件的路径，logprefix 是事务日志文件的前缀，通常为 e00。

    下面是此命令的一个示例（使用默认值）：

    eseutil /ml "c:\program files\exchsrvr\mdbdata\e00".

  6. 将按以下两种格式之一报告缺少的事务日志文件，具体取决于缺少的日志文件：

    • 缺少日志文件：c:\program files\exchsrvr\mdbdata\E0002BE2.log

    • 错误：缺少日志文件。日志文件的生成编号为 11,235 (0x2BE3)，而需要的生成编号为 11,234 (0x2BE2)。

    其中，0x2BE2 就是缺少的日志文件 E0002BE2.log。

  7. 记录在步骤 6 中报告的日志文件名称。

  8. 确定日志文件的当前位置，并将它们移回到步骤 3 中的预期位置。
注意：
在确定缺少的事务日志文件的当前位置时，应确保搜索回收站和所有防病毒隔离文件夹。
  1. 尝试装入受影响的 Exchange 数据库。

 在 Exchange Server 2007 中手动确定并还原缺少的事务日志

  1. 在存储组所在的服务器上启动 Exchange 管理控制台。

  2. 在控制台树中，展开"服务器配置"，然后单击"邮箱"。

  3. 在结果窗格中，单击某个邮箱服务器，其中包含要还原缺少的事务日志文件的存储组。

  4. 右键单击您的存储组，然后单击"属性"。

  5. . 在"常规"选项卡的"日志路径"下，记录事务日志文件位置的路径。

  6. 在命令提示符下，打开 Eseutil.exe 所在的目录。在 Exchange Server 2007 中，Eseutil 位于 Exchange 默认安装文件夹中。即，<SystemDrive>:\Program Files\Microsoft\Exchange Server\Bin。

  7. 在命令提示符下，输入以下命令：

    复制代码
    eseutil /ml "logpath\logprefix"

    其中，logpath 是在步骤 5 中记录的事务日志文件的路径，logprefix 是事务日志文件的前缀，通常为 e00。

    下面是此命令的一个示例（使用默认值）：

    eseutil /ml "c:\Program Files\Microsoft\Exchange Server\Bin\e00".

  8. 将按以下两种格式之一报告缺少的事务日志文件，具体取决于缺少的日志文件：

    • 缺少日志文件：c:\Program Files\Microsoft\Exchange Server\Bin\E000000049A.log

    • 错误：缺少日志文件。日志文件的生成编号为 11,235 (0x2BE3)，而需要的生成编号为 11,234 (0x2BE2)。

    其中，0x2BE2 就是缺少的日志文件 E0002BE2.log。

  9. 记录在步骤 8 中报告的日志文件名称。

  10. 确定日志文件的当前位置，并将它们移回到步骤 5 中的预期位置。
注意：
在确定缺少的事务日志文件的当前位置时，应确保搜索回收站和所有防病毒隔离文件夹。
  1. 尝试装入受影响的 Exchange 数据库。

有关 ESE 事件 454 的详细信息，请参阅"Events and Errors Message Center"（事件和错误消息中心）(http://go.microsoft.com/fwlink/?LinkId=81883)。


ESE 455 -1811 (0xfffff8ed):缺少当前 (Exx.log) 事务日志文件
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-05-31

Microsoft Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 -1811 (0xfffff8ed) 的 ESE 455 事件。此事件表明当前事务日志 (exx.log) 丢失、无法访问或具有不匹配的签名。

解释

此错误可能是由以下原因引起的：

  • 对应于 JET_errFileNotFound 的错误 1811。具有不匹配的签名和内部日志生成编号 (LGeneration) 的 Exchange 日志文件可能会出现该问题。通常，Exchange 日志文件是 E00.log 文件。如果 E00.log 文件具有不匹配的签名，即使数据库是一致的，也可能无法装入信息存储。

  • 防病毒程序隔离或删除了当前 Exchange 日志文件。

  • 为受影响的数据库运行了 eseutil /p 修复命令，并且没有删除日志文件。

  • 使用不正确的日志文件基本名称运行了 eseutil /r 恢复命令，例如，eseutil /r Exx.log，其中 Exx.log 是包含三个字符的日志文件基本名称。

也可能会将该错误标识为 -1811, JET_errFileNotFound。此错误适用于以下版本的 Exchange Server：

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

用户操作

若要纠正该错误，请执行下列一个或多个操作：

  • 如果日志文件具有不匹配的签名和日志生成编号，请与 Microsoft 客户支持服务联系。有关详细信息，请访问 Microsoft 帮助和支持网站的"联系我们"页。

  • 如果防病毒程序隔离或删除了当前的 Exchange 日志文件，请执行下列步骤：

    • 检查防病毒程序的配置。

    • 确保防病毒程序未配置为扫描 Exchange Server 目录。

    • 默认情况下，某些防病毒程序设置为每周以手动模式或自动模式扫描驱动器和目录。此设置可能容易被忽略。确保将 Exchange Server 目录添加到防病毒程序排除的位置。有关如何配置防病毒程序以便与 Exchange 配合使用的详细信息，请参阅 Microsoft 知识库文章 823166 Exchange Server 2003 和防病毒软件概述。

    • 复查防病毒程序的日志文件，以确认 Exchange 日志文件已被隔离或删除。

    使用下列方法之一恢复 Exchange 日志文件：

方法 1：如果 Exchange 日志文件被隔离

  1. 将 Exchange 日志恢复到包含生产日志文件的文件夹。

  2. 启动"Microsoft Exchange 信息存储"服务。如果不缺少任何其他日志文件，将装入数据库。如果缺少其他日志文件，请查看缺少的日志文件是否位于防病毒程序的隔离文件夹中。如果日志文件不在隔离文件夹中，请参阅方法 2。

如果 Exchange 日志文件被删除，则必须通过备份还原存储组数据库。然后必须重播日志文件。若要还原可用的数据库，请执行下列步骤：

方法 2：如果 Exchange 日志文件被删除

  1. 将所有不一致的数据库移动到备份文件夹中。

  2. 如果新建了 E00.log 文件，则将新的 E00.log 文件移动到备份文件夹中。此外，将 E00.chk 文件也移动到备份文件夹中。

  3. 将所有现有的日志文件复制到备份文件夹。注意 必须复制日志文件。不要移动日志文件。

  4. 将最新的 E00*.log 文件重命名为 E00.log。

  5. 通过备份还原数据库。然后重播日志文件。这样可使数据库处于一致状态。但是，数据库中不包括复制到备份文件夹中的 E00.log 文件。尽管存在一定的数据损失，但是现在您有了可以装入的数据库。

    注意：
    如果无法通过备份还原数据库，则对数据库运行修复实用程序，以使数据库处于一致状态

  6. 启动"Microsoft Exchange 信息存储"服务。

如果对受影响的数据库运行了 eseutil /p 修复命令但没有删除日志文件，请执行下列步骤：

若要确定是否运行了 eseutil /p 命令，请执行下列操作：

  1. 单击"开始"，再单击"运行"，键入 cmd，然后单击"确定"。

  2. 在命令提示符下键入以下命令：

    复制代码
    c:\program files\exchsrvr\bin\eseutil /mh "c:\program files\exchsrvr\mdbdata\<name of Exchange database.edb>"

    上述语法假定下列条件为真：

    • Exchange Server 程序文件安装在 c:\program files\exchsrvr 文件夹中。

    • 数据库位于 c:\program files\exchsrvr\mdbdata 文件夹中。

  3. 读取修复计数属性。如果修复计数属性为 0（零），则未运行 eseutil /p 命令。如果修复计数属性不是 0，则对数据库运行了 eseutil /p 命令。

如果公用数据库和私人数据库处于一致状态或干净关闭状态，则可以将事务日志文件移动到其他文件夹中。若要确定数据库是否处于一致状态或干净关闭状态，请执行下列步骤：

若要确定数据库是否处于一致状态或干净关闭状态，请执行下列操作：

  1. 单击"开始"，再单击"运行"，键入 cmd，然后单击"确定"。

  2. 若要检查私人信息存储，请键入以下命令：

    复制代码
    c:\program files\exchsrvr\bin>eseutil /mh "drive:\program files\exchsrvr\mdbdata\priv1.edb"

  3. 若要检查公用信息存储，请键入以下命令：

    复制代码
    c:\program files\exchsrvr\bin>eseutil /mh "drive:\program files\exchsrvr\mdbdata\pub1.edb"

    步骤 2 和 3 中的语法假定下列条件为真：

    • Exchange Server 程序文件安装在 c:\program files\exchsrvr 文件夹中。

    • 数据库位于 c:\program files\exchsrvr\mdbdata 文件夹中。

  4. 复查一致性检查的结果。如果数据库处于一致状态（状态 = 干净关闭），则已将所有日志文件提交到信息存储。如果数据库处于不一致状态（状态 = 肮脏关闭），数据库可能未损坏。可能尚未将日志文件提交到数据库。

  5. 如果状态显示为干净关闭，请将所有 mdbdata 目录中的所有日志文件移动到备份文件夹中。

  6. 装入数据库。
  • 如果使用不正确的日志文件基本名称运行了 eseutil /r 恢复命令，请使用正确的开关成功地运行该命令。常用的日志文件基本名称为 e00、e01、e02 和 e03。例如，以下命令包含正确的日志文件基本名称：

    复制代码
    eseutil /r e00
  • 如果问题仍存在，请与 Microsoft 客户支持服务联系。有关详细信息，请访问 Microsoft 帮助和支持网站的"联系我们"页。


ESE 474 -1018:在数据库中检测到无法恢复的错误
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-03-28

Microsoft Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 -1018 的 ESE 474 事件。如果 Microsoft Exchange 完整性验证组件确定 Exchange Server 无法从硬盘子系统正确存储或检索 Exchange 数据库文件数据，则生成此错误。

解释

由于硬盘子系统硬件组件存在缺陷，或者由于硬盘子系统中的驱动程序和/或固件已过时或不兼容，可能出现错误代码为 -1018 的 ESE 474 事件。

遇到 -1018 错误后，对服务器运行的诊断硬件测试可能报告无磁盘子系统硬件问题，因此自然认定是 Exchange Server 导致了该问题。

Microsoft 和硬件供应商经过广泛调查，已确定磁盘子系统硬件组件、支持驱动程序和/或固件存在的小问题才是大多数 -1018 错误的罪魁祸首。

发现数据库文件中的初始化页面存在下列任一情况时，Exchange 将报告 -1018 错误：

  • 在页面上存储的校验和与读取页面时执行的校验和重新计算的结果不匹配。

  • 在页面上存储的页码与页面上应该具有的页码，即指定页面在数据库文件中的物理位置不匹配。

如果出现下列情况之一，则 Exchange 可能导致自生成的 -1018 错误：

  • Exchange 构建具有错误校验和的页面。

  • Exchange 正确构建了页面，但却令操作系统将该页面写入了错误的位置。

在将所有数据写入页面后，Exchange 为将要写入磁盘的页面生成校验和。这包括页码本身。Exchange 将校验和添加到页面后，通过使用基于已发布的标准 Windows 的 API 指示 Windows 操作系统将页面写入磁盘。

暂时性内存错误可能会导致将页面写入硬盘上的错误位置。

即使页面校验和是正确的，Exchange 也会报告 -1018 错误，因为逻辑页码与物理页码不匹配。

在 Exchange 数据库中报告的单个 -1018 错误通常不会导致 Exchange 数据库停止，或者导致除出现 -1018 错误之外的其他症状。受影响的页面可能位于很少访问的文件夹（如 Sent Items 或 Deleted Items 文件夹）中或很少打开（或者甚至为空）的附件中。

虽然单个 -1018 错误不大可能导致大量数据丢失，但是 -1018 错误确实是个问题，因为它们表明存储系统至少有一次未能可靠地存储或检索数据。-1018 错误是问题可能会日趋恶化的一个预警。即使第一个 -1018 错误是针对数据库中的空白页面报告的，但却无法预知接下来哪一个页面可能会被损坏。如果关键的全局表被损坏，则 Exchange 数据库可能无法启动，而且数据库修复可能不成功或仅部分成功。

记录 -1018 错误后，在找到错误的根本原因之前，请对即将出现故障和其他随机损坏的可能性予以考虑并制定相应计划。

用户操作

尝试更正应用程序日志中记录的 ESE 474 -1018 错误之前，请确保服务器的磁盘子系统是稳定的。

若要解决磁盘子系统问题，请执行下列操作：

  1. 打开应用程序日志，并搜索 ESE 474 事件。在每个事件中，记录受影响数据库的完整路径。在编译受影响数据库列表后，记录在数据库路径中引用的驱动器号。利用此信息可以直接解决这些物理磁盘的问题。

  2. 查看系统日志，并确保未记录磁盘读取、写入或超时错误。

  3. 使用制造商提供的磁盘子系统诊断实用程序，并在验证磁盘子系统的完整性时与磁盘子系统硬件供应商联系以获取更多帮助。

更正了磁盘子系统的任何问题或验证其稳定性后，使用下列方法从 -1018 错误进行恢复。按优先顺序或首选用法列出了这些方法：

第一种方法 从应用程序日志的 ESE 474 事件中提及的数据库移动邮箱。将邮箱移动到现有的、已知良好的存储，或者专为此目的新建一个邮箱存储。移动所有邮箱后，删除损坏的邮箱存储。

移动邮箱（Exchange 2000 Server 或 Exchange Server 2003）

  1. 在 Active Directory 用户和计算机中，选择要移动其邮箱的一个或多个用户。

  2. 右键单击上一步中选择的用户列表，再单击"Exchange 任务"。

  3. 在"Exchange 任务向导"的"可用任务"页上，单击"移动邮箱"，再单击"下一步"。

  4. 小心阅读并执行向导的其余步骤。
移动邮箱（仅限 Exchange Server 2003）

  1. 在"Exchange 系统管理器"中，依次展开"服务器"、要从中移动邮箱的服务器、要从中移动邮箱的"存储组"和包含要移动的邮箱的"邮箱存储"，再单击"邮箱"。

  2. 在详细信息窗格中，右键单击要移动其邮箱的一个或多个用户，再单击"Exchange 任务"。

  3. 在"Exchange 任务向导"的"可用任务"页上，单击"移动邮箱"，再单击"下一步"。

  4. 小心阅读并执行向导的其余步骤。
使用 Exchange 管理控制台移动邮箱（仅限 Exchange Server 2007）

  1. 启动 Exchange 管理控制台。

  2. 在控制台树中，展开"收件人配置"，再单击"邮箱"。

  3. 在结果窗格中，单击要移动的一个或多个邮箱。

  4. 在操作窗格中，单击"移动邮箱"。

  5. 在"移动邮箱向导"的"简介"页上，依次选择要向其移动邮箱的服务器、存储组和邮箱数据库，再单击"下一步"。

  6. 在"移动选项"页上，选择用于处理邮箱中已损坏邮件的选项，再单击"下一步"。

  7. 在"移动日程安排"页上，指定移动应开始的时间，再单击"下一步"。

  8. 在"移动邮箱"页上，查看摘要来确认邮箱移动，再单击"移动"。

  9. 在"完成"页上，单击"完成"。

有关使用"移动邮箱"向导和 Move-Mailbox cmdlet 的支持方案的详细信息，请参阅 Exchange Server 2007 产品文档中的"Moving Mailboxes"（移动邮箱）(http://go.microsoft.com/fwlink/?LinkId=85754)。

第二种方法 从已知良好的备份还原数据库。有关如何还原 Exchange Server 数据库的详细信息，请参阅下列文章：

  • Exchange Server 2007"Disaster Recovery"（灾难恢复）(http://go.microsoft.com/fwlink/?LinkId=85802)

  • "Exchange 2003 Disaster Recovery Operations Guide"（Exchange Server 2003 灾难恢复操作指南）(http://go.microsoft.com/fwlink/?linkid=30250)

第三种方法 使用 Eseutil 对受影响数据库执行硬修复。仅当前两种方法失败时才应使用此方法。运行硬修复后，还必须对已修复数据库执行脱机碎片整理，并运行 Isinteg 工具修复逻辑损坏。可以使用 Exchange 数据库故障排除程序修复任务执行这些步骤。这将自动运行 Eseutil /P、Eseutil /D 和 Isinteg 操作。

详细信息

有关此问题的详细信息，请参阅下列 Microsoft 知识库文章和 Exchange 资源：

  • 314917"理解和分析 -1018、-1019 和 -1022 Exchange 数据库错误"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=314917)

  • 867626"在 Exchange Server 2003 SP1 中包括了新的错误纠正码"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=867626)

  • 259851"在 Exchange 中运行 ESEUTIL /P 或 EDBUTIL /D /R 命令的结果"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=259851)

  • "Exchange Server Error -1018"（Exchange Server 错误 -1018）(http://go.microsoft.com/fwlink/?LinkId=85807)


MSExchangeIS 1003：Exchange 数据库驱动器上的剩余可用空间不足
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-01-22

Microsoft® Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个 MSExchangeIS 1003 事件。如果包含尝试装入的数据库的驱动器上没有足够的可用磁盘空间，则可能会发生此错误。

解释

如果包含 Exchange 数据库的磁盘出现可用磁盘空间不足的问题，Microsoft Exchange 信息存储服务将记录 MSExchangeIS 1003 事件并卸除受影响的数据库。出现此问题后，您可能无法为受影响的存储组装入数据库。此错误适用于以下版本的 Exchange Server：

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

用户操作

若要解决该问题，请在数据库驱动器上释放一些磁盘空间，然后再次尝试装入数据库。为此，请执行以下一个或多个操作：

  • 如果 Exchange 数据库文件是位于硬盘上的唯一文件，则可能需要对数据库执行脱机碎片整理以释放磁盘空间。

    注意：
    取决于数据库中的可用空间数量，此步骤可能无法解决该问题。
    有关执行此步骤的详细信息，请参阅 Microsoft 知识库文章 328804"如何对 Exchange 数据库进行碎片整理"。

    此外，请参阅"How to Run Eseutil /D (Defragmentation)"（如何运行 Eseutil /D（碎片整理））。

  • 如果 Exchange 事务日志文件也位于此驱动器上，则可以通过删除不需要的日志文件来释放磁盘空间。

    有关执行此步骤的详细信息，请参阅 Microsoft 知识库文章 240145"How to remove Exchange Server transaction log files"（如何删除 Exchange Server 事务日志文件）。


MSExchangeIS 1088：由于 legacyExchangeDN 无效而无法装入数据库
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-01-23

Microsoft® Exchange 数据库故障排除程序工具检测到 MSExchangeIS 1088 事件。此事件表明 Exchange 数据库由于其 legacyExchangeDN 属性值不同于 Active Directory 中存储的属性值而无法装入。

解释

如果将 Exchange 数据库还原到某个管理组，而该管理组具有的 legacyExchangeDN 属性值不同于原始管理组，则可能会发生 MSExchangeIS 1088 事件。这种情况是设计所致。若要在 Exchange Server 中装入存储，Exchange 数据库的组织和管理组的 legacyExchangeDN 属性值必须与 Active Directory 中组织和管理组的 legacyExchangeDN 属性值匹配。

用户操作

若要解决该问题，请执行下列操作：

  • 将 Exchange 数据库还原到其原始管理组。

  • 如果无法将 Exchange 数据库还原到其原始管理组，请重命名预期目标的 Active Directory 对象，以使它们具有与 Exchange 数据库相同的 legacyExchangeDN 属性值。您可以使用 Active Directory 服务接口 (ADSI) Edit、LDP (ldp.exe) 工具或任何其他轻型目录访问协议 (LDAP) 版本 3 客户端等工具来更正该值。

警告：
在使用 ADSI Edit、LDP 工具或其他 LDAP 版本 3 客户端时，如果未正确修改 Active Directory 对象的属性，则可能会出现严重问题。若要解决这些问题，您可能需要重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003/Exchange Server 2007。修改 Active Directory 对象的属性的风险由您自己承担。
更正此错误

  1. 使用 ADSI Edit 或类似工具，在 Active Directory 中找到管理组对象。

    可以在以下位置找到 legacyExchangeDN 属性：

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group

  2. 键入以下形式的新字符串值：

    /o= organization /ou= administrative group

有关使用 LDP 工具的详细信息，请参阅 Microsoft 知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（XADM：使用 LDP 实用程序修改 Active Directory 对象属性）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

有关使用 ADSI Edit 的详细信息，请参阅 Windows Server 2003 帮助中的主题"Adsiedit.msc：ADSI Edit"。

有关 MSExchangeIS 事件 1088 的详细信息，请参阅下列资源：

  • Events and Errors Message Center（事件和错误消息中心）

  • Microsoft 知识库文章 280652"XADM: "Event ID 1088" Is Logged and Store Fails to Mount"（XADM：记录"事件 ID 1088"并且无法装入存储）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=280652)


MSExchangeIS 5000 (0x3f5)：为信息存储服务配置的服务帐户无效
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-02-27

Microsoft® Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 0x3f5 的 MSExchangeIS 5000 事件。将 Microsoft Exchange 信息存储服务配置为使用 Local System 以外的帐户进行启动时，将会发生此错误。

解释

如果 Microsoft Exchange 信息存储服务 (Store.exe) 使用 Local System 以外的帐户，或者域控制器、域或本地计算机安全策略在"生成安全审核"策略中不包含 Local Service 帐户，则可能会出现此问题。出现此问题时，Exchange 信息存储服务无法进行初始化。此错误适用于以下版本的 Exchange Server：

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

用户操作

若要解决该问题，请执行以下一个或多个操作：

  • 默认情况下，Exchange 信息存储服务使用 Local System 帐户来启动信息存储服务 (MACHINENAME$)。请使用 Services.msc 管理单元来检查用于启动信息存储服务的帐户。如果帐户是 Local System 帐户，则必须为 Local System 帐户授予"生成安全审核"权利。为此，请使用下列方法之一：

    • 从此计算机中重新运行 Exchange 安装程序 /domainprep 命令。

    • 在以下策略之一中，手动为 Local System 帐户授予"生成安全审核"权利：

    1. 域控制器策略

    2. 域策略

    3. 本地计算机安全策略

      若要为成员服务器的本地计算机安全策略重新授予此权利，请执行下列步骤。

      注意：
      如果仅在一个服务器上出现此问题，建议使用此解决方案。
      为成员服务器的本地计算机安全策略重新授予审核权利

      1. 依次单击"开始"、"管理工具"和"本地安全策略"。

      2. 展开"安全设置"，单击"本地策略"，然后单击"用户权限分配"。

      3. 在右侧窗格中，双击"生成安全审核"，单击"添加"，输入 MACHINENAME$，然后单击两次"确定"。

      4. 退出组策略管理单元。
  • 如果使用 Local System 以外的帐户启动信息存储服务，则应该将其改回到 Local System 帐户 (MACHINENAME$)。然后，尝试启动信息存储服务。有关 Exchange 2000 Server 和 Exchange Server 2003 为什么使用 Local System 帐户来启动 Exchange 服务的详细信息，请参阅 Microsoft 知识库文章 239762"Exchange Services Run Under LocalSystem"（使用 LocalSystem 运行 Exchange 服务）。

详细信息

有关详细信息，请参阅 Microsoft 知识库文章 281850"Information store does not start with event ID 9530 and 5000 messages in Exchange 2000 Server and in Exchange Server 2003"（在 Exchange 2000 Server 和 Exchange Server 2003 中，信息存储无法启动并显示事件 ID 9530 和 5000 消息）。


MSExchangeIS 5000 (0x80004005)：由于服务帐户不正确、缺少 SeSecurityPrivilege 权限或者组成员身份不正确而无法装入数据库
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-02-19

Microsoft Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 0x80004005 的 MSExchangeIS 5000 事件。此事件表明由于服务帐户不正确、缺少 SeSecurityPrivilege 权限或者组成员身份不正确而无法装入 Exchange 服务器上的一个或多个数据库。

解释

如果以下任何条件成立，则可能会发生此事件：

  • 从一个或多个域控制器的 Exchange Enterprise Servers 组中删除了"管理审核和安全日志权限"(SeSecurityPrivilege)。在域中的所有域控制器上，Exchange Enterprise Servers 组都必须具有"管理审核和安全日志权限"。如果此条件成立，一个或多个与 Exchange Server 有关的服务将无法启动。

  • Microsoft Exchange 信息存储服务使用 Local System 以外的帐户进行启动，或者域控制器、域或本地计算机安全策略在"生成安全审核"策略中不包含 Local Service 帐户。如果此条件成立，将无法启动 Exchange 信息存储服务。

  • 父域中的 Exchange Enterprise Servers 组不包含子域中的 Exchange Domain Servers 组。

也可能会将该事件标识为 MAPI_E_CALL_FAILED。此事件适用于以下版本的 Exchange Server：

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

用户操作

若要解决该问题，请执行以下一个或多个操作：

  • 如果从一个或多个域控制器的 Exchange Enterprise Servers 组中删除了"管理审核和安全日志权限"(SeSecurityPrivilege)，请执行下列步骤：

    若要为一个或多个域控制器添加权限，请执行下列操作：

    1. 使用 Policytest.exe 解决权限问题。Policytest.exe 位于 Exchange 2000 Server CD 上的 Support\Utils\I386 文件夹中或 Exchange Server 2003 CD 上的 Support\ExDeploy 文件夹中。使用 Policytest.exe 确定域控制器中是否缺少 Exchange Enterprise Servers 组的"管理审核和安全日志"权限。成功结果返回类似如下所示的信息：

      Local domain is "<contoso.com>" (contoso) Account is "CONTOSO\Exchange Enterprise Servers" DC = "<ComputerName>" In site = "<Default-First-Site-Name>" Right found: "SeSecurityPrivilege"

      注意 成功结果表明存在"管理审核和安全日志"权限。只有拥有域管理员权限才能运行 Policytest.exe。有关 Policytest.exe 实用程序的详细信息，请参阅 Microsoft 知识库文章 281537 XADM：Policytest.exe 实用程序说明。

    2. 在域级别重设 Exchange Enterprise Server 默认权限。为此，请执行下列步骤：

      1. 从 Exchange Server CD 或网络安装点运行 setup /domainprep 命令。setup /domainprep 命令将 Exchange Enterprise Servers 组添加到拥有默认权限的域。运行 setup /domainprep 命令时，会立即将权限添加到一个域控制器。然后，更改会复制到其他域控制器。

      2. 将权限继承还原到其他组织单位。然后，等待域控制器在整个域中复制更改。

      3. 运行 Policytest.exe。注意哪些域控制器返回以下成功结果：

        Right found: "SeSecurityPrivilege"

        如果所有域控制器都拥有正确的权限，则重新启动 Exchange Server 服务。如果没有任何域控制器拥有正确的权限，请参阅步骤 3。

    3. 验证默认域控制器的策略。为此，请执行下列步骤：

      1. 启动"Active Directory 用户和计算机"管理单元。

      2. 右键单击"域控制器"容器，然后单击"属性"。

      3. 单击"组策略"选项卡，确保"组策略对象链接"框中列出了"默认域控制器策略"。注意 如果未列出"默认域控制器策略"，请依次单击"添加"、"默认域控制器策略"、"确定"。然后等待此更改复制到所有其他域控制器。

      4. 从 Exchange Server CD 或网络安装点运行 setup /domainprep 命令。setup /domainprep 命令将 Exchange Enterprise Servers 组添加到拥有默认权限的域。

      5. 运行 Policytest.exe。注意哪些域控制器返回以下成功结果：

      Right found: "SeSecurityPrivilege"

      如果所有域控制器都拥有正确的权限，则重新启动 Exchange Server 服务。如果某些域控制器没有正确的权限，请参阅步骤 4。

    4. 手动将权限添加到域控制器。在运行 setup /domainprep 命令之后，文件复制服务 (FRS) 可能未将更新的安全策略复制到一个或多个域控制器。如果发生此问题，必须手动为 Exchange Enterprise Servers 组分配正确的权限。如果某些域控制器或所有域控制器没有正确的权限，请为 Exchange Enterprise Servers 组分配"管理审核和安全日志"权限。然后等待该设置复制到其他域控制器。为此，请执行下列步骤：

      1. 启动"Active Directory 用户和计算机"管理单元。

      2. 右键单击"域控制器"容器，然后单击"属性"。

      3. 依次单击"组策略"选项卡、"组策略对象链接"框中的"默认域控制器策略"、"编辑"。

      4. 依次展开"计算机配置"、"Windows 设置"、"安全设置"、"本地策略"，然后单击"用户权限分配"。

      5. 在右侧窗格中，双击"管理审核和安全日志"，依次单击"添加"、"浏览"，然后添加"Exchange Enterprise Servers 组"。

      6. 在"添加用户或组"对话框中，单击"确定"。然后再次单击"确定"。

      7. 退出"组策略"管理单元，然后单击"域控制器属性"对话框中的"确定"。注意 有时，单击"添加用户或组"对话框中的"浏览"时可能看不到 Exchange Enterprise Servers 组。如果出现此情况，则添加 Exchange Domain Servers 组。然后再次运行 setup /domainprep 命令。此过程持续地在所有域控制器中添加 Exchange Enterprise Servers 组。
  • 如果 Exchange Information Store 服务使用 Local System 以外的帐户进行启动，或者域控制器、域或本地计算机安全策略在"生成安全审核"策略中不包含 Local Service 帐户，请按照如下所述的解决方法操作。

    默认情况下，Exchange Information Store 服务使用 Local System 帐户来启动 Information Store 服务 (MACHINENAME$)。请使用 Services.msc 管理单元来检查用于启动 Information Store 服务的帐户。如果帐户是 Local System 帐户，则必须重新为 Local System 帐户授予"生成安全审核"权限。为此，请使用下列方法之一：

    若要重新为 Local System 帐户授予"生成安全审核"权限，请执行下列操作：

    1. 从此计算机中重新运行 Exchange Setup /domainprep 命令。

    2. 在下列某个策略中手动为 Local System 帐户授予"生成安全审核"权限：

      • 域控制器策略

      • 域策略

      • 本地计算机安全策略

    若要重新为成员服务器的本地计算机安全策略授予"生成安全审核"权限，请执行下列操作：

    1. 依次单击"开始"、"管理工具"和"本地安全策略"。

    2. 展开"安全设置"，单击"本地策略"，然后单击"用户权限分配"。

    3. 在右侧窗格中，双击"生成安全审核"，单击"添加"，输入 MACHINENAME$，然后单击两次"确定"。

    4. 退出"组策略"管理单元。

    如果使用 Local System 以外的帐户启动 Information Store 服务，则应该将其改回到 Local System 帐户 (MACHINENAME$)。然后，尝试启动 Information Store 服务。有关 Exchange 2000 Server 和 Exchange Server 2003 为什么使用 Local System 帐户来启动 Exchange 服务的详细信息，请参阅 Microsoft 知识库文章 239762 Exchange 服务在 LocalSystem 下运行。

  • 如果父域中的 Exchange Enterprise Servers 组不包含子域中的 Exchange Domain Servers 组，请将子域中的 Exchange Domain Servers 组添加到父域中的 Exchange Enterprise Servers 组中。也可以通过在根级域中创建收件人更新服务来解决此问题。

    若要解决此问题，请在远程 Windows 域中的服务器上运行包含 /domainprep 开关的 Exchange Setup。然后，在 Exchange 服务器上使用 Exchange 系统管理器为远程域创建收件人更新服务。为此，请执行下列步骤：

    若要为远程域创建收件人更新服务，请执行下列操作：

    1. 依次单击"开始"、"程序"、"Microsoft Exchange"、"系统管理器"。

    2. 展开"组织"对象，然后展开"收件人"容器。

    3. 单击"收件人更新服务"。

    4. 在右侧窗格中，右键单击"新建"，然后单击"收件人更新服务"。

    5. 单击没有收件人更新服务实例并且包含必须由 Exchange 更新的用户的域。

    6. 单击"下一步"。

    7. 选择要运行收件人更新服务的服务器并使用 Exchange 属性处理所有必要的用户。

    8. 单击"下一步"。

    9. 单击"完成"。

    10. 若要手动启动对该域中的收件人的更新，右键单击"收件人更新服务"，然后单击"立即更新"强制进行更新。
    有关详细信息，请参阅 Microsoft 知识库文章 253770 Exchange 收件人更新服务执行的任务。


MSExchangeIS 5000 (0x80040154)：SMTP 服务扩展丢失或损坏
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-02-19

Microsoft Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 0x80040154 的 MSExchangeIS 5000 事件。如果 Exchange Server 简单邮件传输协议 (SMTP) 服务扩展丢失或损坏，则可能会发生此错误。

解释

发生此问题是因为 Exchange SMTP 服务扩展丢失或损坏。这种情况可导致 Exchange 和 SMTP 服务之间的功能丢失。SMTP 服务是作为 Microsoft Internet Information Services (IIS) 子组件安装的必需服务。

发生此错误的可能原因如下：

  • 已删除 IIS。

  • 已从 IIS 中删除 SMTP 服务子组件。

  • 删除了 IIS，然后将其作为 Windows 组件重新安装，但没有安装所需的 SMTP 服务子组件。

  • 删除了 IIS，然后将其作为 Windows 组件重新安装，安装了相应的子组件列表，但是，没有重新安装 Exchange SMTP 服务扩展。

此错误适用于以下版本的 Exchange Server：

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

用户操作

若要纠正此错误，请参阅 Microsoft 知识库文章 326305 信息存储未启动，并在 Exchange 2000 Server 和 Exchange Server 2003 中出现 MSExchangeIS 事件 ID 5000 和 9538 消息。

若要还原 SMTP 服务扩展，请执行下列操作：

  1. 确认 Exchange SMTP 服务扩展丢失。为此，请执行下列步骤：

    1. 使用具有管理凭据的帐户登录到运行 Microsoft Exchange 的计算机。

    2. 单击"开始"，再单击"运行"，键入 cmd，然后单击"确定"。

    3. 在命令提示符下键入 telnet 127.0.0.1 25，以查看"220 server.domain.com Microsoft ESMTP Mail Service"项。

    4. 键入 EHLO，然后按 Enter 键查看 250 个命令谓词的列表。如果没有任何名称以"X"开头的谓词，则 SMTP 服务扩展丢失。

  2. 完整备份系统分区。包括系统状态和 Exchange 数据库文件。有关如何操作的详细信息，请参阅 Microsoft 知识库文章 258243 如何使用 Windows 备份程序备份和还原 Exchange 计算机。

  3. 确认已正确地重新安装 IIS，包含所需的 Exchange 相关子组件。

    IIS 6.0

    1. 单击"开始"，指向"设置"，然后单击"控制面板"。

    2. 双击"添加/删除程序"。

    3. 在左侧窗格中，单击"添加/删除 Windows 组件"。

    4. 在"Windows 组件向导"的组件列表中找到"应用程序服务器"，然后单击"详细信息"。

    5. 如果未安装下列任意组件，请完成安装：

      ASP.NET

      启用网络 COM+ 访问

      Internet Information Services (IIS)

    6. 单击 Internet Information Services (IIS)，然后单击"详细信息"。

    7. 如果未安装下列任意组件，请完成安装：

      公用文件

      Internet Information Services 管理器

      NNTP 服务

      SMTP 服务

      万维网服务

    8. 单击两次"确定"。在主"Windows 组件"页上，单击"下一步"，然后单击"完成"。

    IIS 5.0

    1. 单击"开始"，指向"设置"，然后单击"控制面板"。

    2. 双击"添加/删除程序"。

    3. 在左侧窗格中，单击"添加/删除 Windows 组件"。

    4. 在"Windows 组件向导"对话框的组件列表中找到"Internet Information Services (IIS)"。如果选中了"Internet Information Services (IIS)"复选框，则已安装 IIS。若要查看已安装的 IIS 子组件，请单击 Internet Information Services (IIS)，然后单击"详细信息"。

    5. 如果未安装 IIS，则通过单击选中 Internet Information Services (IIS) 复选框，然后单击"详细信息"。安装 IIS 5.0 子组件，然后单击"确定"。在安装 Exchange 2000 之前，要求至少安装下列 IIS 5.0 子组件：

      公用文件

      Internet Information Services 管理单元

      SMTP 服务

      网络新闻传输协议 (NNTP) 服务（对于新闻组）

      万维网服务

    6. 单击"下一步"，然后单击"完成"。

  4. 还原 Exchange SMTP 服务扩展。

    Exchange Server 2003

    如果重新安装 Exchange 2003 来覆盖现有的 Exchange 2003 安装，数据库文件和权限将保持不变。为此，请执行下列步骤：

    1. 插入 Exchange 2003 CD。

    2. 在 \SETUP\I386 文件夹中，双击 Setup.exe 文件。

    3. 在"欢迎"页上单击"下一步"，直到出现"组件选择"页。

    4. 在"组件选择"页上，单击"操作"列中的"重新安装"，然后单击"下一步"。

    5. 在"安装摘要"页上确认选择，然后单击"下一步"继续安装 Exchange 2003。

    Exchange 2000 Server

    还原 Exchange 2000 SMTP 服务扩展可以使用的方法取决于被删除的 IIS 子组件数。如果 SMTP 服务是唯一被删除的 IIS 子组件，并且已安装了 Exchange 2000 Server Service Pack 2 (SP2) 或更高版本的 Service Pack，则使用 Smtpreinstall.exe 命令行实用程序。Smtpreinstall.exe 命令行实用程序位于 Server\Support\Utils\I386 文件夹中。

    若要使用 Smtpreinstall.exe 实用程序，请执行下列操作：

    1. 将 Smtpreinstall.exe 文件复制到 Exchsrvr\Bin 文件夹中。

    2. 在命令提示符下，切换到 Exchsrvr\Bin 文件夹，然后键入以下命令：

      smtpreinstall.exe

    3. 按照提示重新启动计算机。

    如果 IIS 5.0 被作为一个组件删除，或不只是从 IIS 5.0 中删除了 SMTP 服务子组件，则在集成安装 Microsoft Small Business Server 2000 期间，重新安装 Exchange 2000 来覆盖现有的安装。

    若要重新安装 Exchange 2000 Server，请执行下列操作：

    注意：
    如果重新安装 Exchange 2000 来覆盖现有的 Exchange 2000 安装，数据库文件和权限将保持不变。
    1. 插入 Exchange 2000 Server CD。

    2. 在 \SETUP\I386 文件夹中，双击 Setup.exe 文件。

    3. 在"欢迎"页上，单击"下一步"。

    4. 根据提示输入 CD 密钥，然后单击"下一步"。

    5. 在"组件选择"页上，单击"操作"列中的"重新安装"，然后单击"下一步"。

    6. 在"安装摘要"页上确认选择，然后单击"下一步"继续安装 Exchange 2000。

  5. 重新安装 Exchange Service Pack 和修补程序。

    有关详细信息，请参阅下列 Microsoft 知识库文章：

    836993 如何获取最新的 Exchange Server 2003 Service Pack.

    301378 如何获取最新的 Exchange 2000 Server Service Pack


MSExchangeIS 5000 (0xc004038a)：由于权限不正确或删除了路由组而无法装入数据库
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-05-31

Microsoft Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 0xc004038a 的 MSExchangeIS 5000 事件。发生此错误时，Microsoft Exchange 信息存储服务将无法初始化并且不能装入数据库。

解释

发生错误代码为 0xc004038a 的事件 MSExchangeIS 5000 的可能原因是权限不正确或删除了路由组。此事件可能是由于下列一个或多个原因导致的：

  • Exchange Server 不再是路由组的成员，或者从 Active Directory 中删除了其路由组。

  • Exchange Domain Servers 组在 Active Directory 中没有相应的权限。

此事件适用于以下版本的 Exchange Server：

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

用户操作

若要纠正该错误，请执行下列一个或多个操作：

  • 如果 Exchange Domain Servers 组没有相应的权限，请使用 ADSI（Active Directory 服务接口）编辑实用程序确保 Exchange Domain Servers 组在 Active Directory 中具有所需的权限。应确保在 Administrators 组、Exchange Domain Servers 组以及与配置有关的任何其他组的"安全"选项卡上选中"允许可继承的权限从父对象传送到此对象"复选框。

    注意：
    如有必要，请强制在域控制器之间进行复制以确保在整个域中传播更改。
    注意：
    ADSI 编辑工具包含在 Microsoft Windows 2000 和 Microsoft Windows Server 2003 支持工具（在 Windows 2000 和 Windows 2003 安装 CD 中提供）中。
  • 如果 Exchange Server 不再是路由组的成员，或者从 Active Directory 中删除了其路由组，请添加或还原路由组。按照下列方法解决最适合您的情况的问题：

解决方法 1：将服务器添加到路由组中。通过执行下列步骤，确认服务器不再是路由组的成员：

  1. 启动 Exchange 系统管理器。

  2. 依次展开"组织"、"管理组"、AdministrativeGroupName、"路由组"。

    注意：
    在此步骤中，AdministrativeGroupName 是管理组的名称。
  3. 浏览所有可用的路由组，确认未列出此服务器。

    注意：
    如果看不到任何路由组，请参阅解决方法 2。
  4. 确认此服务器不是路由组的成员之后，将服务器添加回现有路由组。为此，请执行下列步骤：

    重要信息：
    如果使用 ADSI 编辑管理单元、LDAP 实用程序或者任何其他 LDAP 版本 3 客户端错误地修改了 Active Directory 对象的属性，可能会导致严重的问题。这些问题可能迫使您重新安装 Microsoft Windows 2000 Server、Microsoft Windows Server 2003、Microsoft Exchange 2000 Server、Microsoft Exchange Server 2003，或者 Windows 和 Exchange 都需要重新安装。Microsoft 无法保证由于错误地修改 Active Directory 对象属性而导致的问题能够得到解决。修改这些属性的风险由您自己承担。
将服务器添加回路由组中

  1. 单击"开始"，单击"运行"，键入 adsiedit.msc，然后单击"确定"。

    注意：
    ADSI 编辑工具包含在 Microsoft Windows 2000 支持工具和 Microsoft Windows Server 2003 支持工具中。若要安装这些支持工具，请执行下列步骤：
    • 对基于 Windows 2000 Server 的计算机，在 Windows 2000 CD 的 Support\Tools 文件夹中双击 Setup.exe，然后按照 Windows 支持工具安装向导中的步骤操作，以完成 Windows 2000 支持工具的安装。

    • 对基于 Windows Server 2003 的计算机，在 Windows 2003 CD 的 Support\Tools 文件夹中右键单击 Suptools.msi，然后按照 Windows 支持工具安装向导中的步骤操作，以完成 Windows Server 2003 支持工具的安装。

  2. 依次展开 Configuration [ servername.domain_name.com ]、CN=Configuration、DC= domain_name、DC= com、CN=Services、CN=Microsoft Exchange、CN= OrganizationName、CN=Administrative Groups、CN= AdministrativeGroupName，然后单击 CN=Routing Groups。

    注意：
    在此步骤中，servername 是服务器的名称，domain_name.com 是域的名称，OrganizationName 是 Exchange Server 组织的名称，AdministrativeGroupName 是管理组的名称。

  3. 右键单击希望此服务器成为其成员的路由组，然后单击"属性"。

  4. 单击 distinguishedName 属性，然后单击"编辑"。

  5. 将 distinguishedName 属性的值复制到记事本中。

  6. 单击两次"取消"关闭属性。

  7. 在 ADSI 编辑工具中，依次展开 Configuration [ servername.domain_name.com ]、CN=Configuration,DC= domain_name、DC= com、CN=Services、CN=Microsoft Exchange、CN= OrganizationName、CN=Administrative Groups、CN= AdministrativeGroupName、CN=Servers。

  8. 右键单击 servername，然后单击"属性"。

  9. 单击 msExchHomeRoutingGroup 属性，然后单击"编辑"。

  10. 粘贴在步骤 5 中复制到记事本的值，然后单击两次"确定"保存新值。

  11. 在 Exchange 系统管理器中，找到要将此服务器添加到其中的路由组。

  12. 更新 Exchange 系统管理器以查看此服务器。

    注意：
    如果该 Exchange 服务器未立即出现，请等待 Active Directory 复制的进行。

  13. 如果此路由组中没有任何其他 Exchange 服务器的"服务器类型"设置为"主服务器"，则右键单击此 Exchange 服务器，然后单击"设为主服务器"。

  14. 启动 Information Store 服务和 MTA Stacks 服务。

解决方法 2：还原路由组。如果意外地删除了路由组，可以使用最新的系统状态数据备份还原路由组。如果没有最新的系统状态数据备份，并且有多个域控制器，可以对所删除的路由组执行权威还原操作。

还原路由组

  1. 启动 Exchange 系统管理器，然后新建一个与所删除的路由组同名的路由组。为此，请执行下列步骤：

    1. 依次展开"管理组"、AdministrativeGroupName、"路由组"。

      在此步骤中，AdministrativeGroupName 是管理组的名称。

    2. 右键单击"路由组"，指向"新建"，然后单击"路由组"。

    3. 在"名称"框中，键入路由组的名称，然后单击"确定"。

      使用您意外删除的路由组所使用的相同名称。

    4. 退出 Exchange 系统管理器。

  2. 启动 ADSI 编辑。为此，请依次单击"开始"、"运行"，在"打开"框中键入 adsiedit.msc，然后单击"确定"。

    注意：
    ADSI 编辑工具包含在 Microsoft Windows 2000 支持工具和 Microsoft Windows Server 2003 支持工具中。若要安装这些支持工具，请执行下列操作：
    • 对基于 Windows 2000 Server 的计算机，在 Windows 2000 CD 的 Support\Tools 文件夹中双击 Setup.exe，然后按照 Windows 支持工具安装向导中的步骤操作，以完成 Windows 2000 支持工具的安装。

    • 对基于 Windows Server 2003 的计算机，在 Windows 2003 CD 的 Support\Tools 文件夹中右键单击 Suptools.msi，然后按照 Windows 支持工具安装向导中的步骤操作，以完成 Windows Server 2003 支持工具的安装。

  3. 依次展开 Configuration [ servername.domain_name.com ]、CN=Configuration、DC=domain_name、DC=com、CN=Services、CN=Microsoft Exchange、CN=OrganizationName、CN=Administrative Groups、CN=AdministrativeGroupName，然后单击 CN=Routing Groups。

    在此步骤中，servername 是服务器的名称，domain_name.com 是域的名称，OrganizationName 是 Exchange Server 组织的名称，AdministrativeGroupName 是管理组的名称。

  4. 在右侧窗格中，右键单击新建的路由组，然后单击"属性"。

  5. 单击选中"显示必需属性"复选框和"显示可选属性"复选框（如果尚未选中）。

  6. 在"属性"列表中，单击 msExchRoutingGroupMembersBL，然后单击"编辑"。

    "值"列表为空。

  7. 单击"取消"。

  8. 在"属性"列表中，双击 distinguishedName。

  9. 右键单击"值"框中的可分辨名称，然后单击"复制"。

  10. 启动一个文本编辑器（如记事本），然后单击"编辑"菜单上的"粘贴"，以粘贴可分辨名称。

  11. 在"字符串属性编辑器"对话框中，单击"取消"，然后再次单击"取消"关闭 CN=RoutingGroupName 对话框。

    在此步骤中，RoutingGroupName 是路由组的名称。

  12. 在 ADSI 编辑中的 CN=AdministrativeGroupName 下单击 CN=Servers。

  13. 在右侧窗格中，右键单击 CN=ServerName，然后单击"属性"。

    在此步骤中，ServerName 是此路由组中的一台 Exchange 计算机。

  14. 在"属性"列表中，单击 msExchHomeRoutingGroup，然后单击"编辑"。

  15. 在"值"框中，粘贴在步骤 9 和 10 中复制的可分辨名称，然后单击"确定"。

  16. 单击"应用"，然后单击"确定"。

  17. 对属于意外删除的路由组的每台服务器重复步骤 13 到 15。

  18. 在 CN=AdministrativeGroupName 下单击 CN=Routing Groups。

  19. 在右侧窗格中，右键单击新建的路由组，再单击"属性"。

  20. 在"属性"列表中，单击 msExchRoutingGroupMembersBL，再单击"编辑"。

    "值"列表不再为空。

  21. 单击两次"取消"。

  22. 退出 ADSI 编辑。

  23. 使用 Exchange 系统管理器设置路由组主服务器。为此，请执行下列步骤：

    1. 启动 Exchange 系统管理器。

    2. 依次展开"管理组"、AdministrativeGroupName 和"路由组"。

    3. 展开新建的路由组，然后单击"成员"。

    4. 在右侧窗格中，右键单击想要将其配置为路由组主服务器的 Exchange 计算机，然后单击"设为主服务器"。

    5. 退出 Exchange 系统管理器。

  24. 等待在整个域中传播更改。

  25. 启动已停止的 Microsoft Exchange 服务。


MSExchangeIS 5000 (0x8004010f)：由于权限不正确或组织名中的字符无效而无法装入数据库
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-01-23

Microsoft® Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 0x8004010f 的 MSExchangeIS 5000 事件。该事件表明由于权限不正确或 Exchange 组织名中的字符无效而无法装入 Exchange 服务器中的一个或多个数据库。

解释

如果以下任何条件成立，则可能会发生错误代码为 0x8004010f 的 MSExchangeIS 5000 事件：

  • 经过身份验证的用户在 Active Directory 的"域"或"配置"容器中没有读取访问权限。如果此条件成立，并且尝试在已包含 Exchange 服务器的管理组中安装第二个 Exchange 服务器，则可能无法安装第二个服务器。此外，Microsoft Exchange 信息存储服务也可能无法启动。

  • Active Directory 的"配置"容器下的"已知安全主体"容器中缺少 Everyone 帐户的读取访问权限。如果此条件成立，将无法在成员服务器上启动 Exchange 信息存储服务。

  • Exchange 组织名中包含不支持的字符。如果此条件成立，在安装 Exchange 2000 Server 或 Exchange Server 2003 后，Exchange 信息存储服务可能无法启动，并且您可能会发现在应用程序日志中记录了事件 MSExchangeIS 5000 和 MSExchangeIS 1121。

也可能会将该事件标识为 MAPI_E_NOT_FOUND。此事件适用于以下版本的 Exchange Server：

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

用户操作

若要解决该问题，请执行以下一个或多个操作。

重要信息：
如果使用 Active Directory 服务接口 (ADSI) Edit 管理单元、LDP 实用程序或任何其他 LDAP 版本 3 客户端错误地修改了 Active Directory 对象属性，则可能会导致出现严重问题。若要解决这些问题，您可能需要重新安装 Windows® 2000 Server/Microsoft Windows Server™ 2003 和/或 Microsoft Exchange 2000 Server/Microsoft Exchange Server 2003。Microsoft 无法保证由于错误地修改 Active Directory 对象属性而出现的问题都能够得到解决。修改这些属性的风险由您自己承担。
  • 如果经过身份验证的用户在 Active Directory 的"域"或"配置"容器中没有读取访问权限，请使用 Exchange Server 2003 和 Exchange 2000 Server 中的 ADSI 编辑工具为经过身份验证的用户授予 Active Directory 的"域"和"配置"容器中的读取访问权限。请执行下列步骤：

    注意：
    ADSI 编辑工具位于 Microsoft Windows 2000 和 Microsoft Windows Server 2003 支持工具中。若要安装 Windows 支持工具，请运行 Windows CD 上的 Support\Tools 文件夹中的安装程序。有关 Windows 支持工具的详细信息，请参阅 Windows CD 上的 Support\Tools 文件夹中的 Sreadme.doc 文件。
为经过身份验证的用户授予 Active Directory 的"域"或"配置"容器中的读取访问权限

  1. 单击"开始"，单击"运行"，键入 adsiedit.msc，然后单击"确定"。

  2. 展开"域 NC"容器，右键单击域 (DC=domain,DC=com) 的文件夹，然后单击"属性"以打开文件夹属性。

  3. 单击"安全"选项卡，并确保 Authenticated Users 组在"允许"列中选择了"读取"访问权限。如果未选择"读取"，请单击以选择"读取"，然后单击"确定"。

  4. 展开"配置容器"，右键单击配置 (CN=Configuration,DC=domain,DC=com) 的文件夹，然后单击"属性"以打开文件夹属性。

  5. 单击"安全"选项卡，并确保 Authenticated Users 组在"允许"列中选择了"读取"访问权限。如果未选择"读取"，请单击以选择"读取"，然后单击"确定"。

  6. 退出 ADSI 编辑。

  7. 请稍等片刻，以便将更改复制到域控制器中。

  8. 启动信息存储服务。
  • 如果 Active Directory 的"配置"容器下的"已知安全主体"容器中缺少 Everyone 帐户的读取访问权限，请执行下列步骤来解决该问题：

为 Everyone 帐户授予 Active Directory 的"已知安全主体"容器中的读取访问权限

  1. 作为域管理员登录，然后启动 ADSI 编辑。

  2. 展开"配置"容器，然后单击 CN=WellKnown Security Principals 容器。

  3. 右键单击"属性"，然后找到"安全"选项卡。

  4. 单击"添加"，键入 everyone，然后单击"确定"。

  5. 在"允许"列下，单击以选中"读取"复选框。
  • 如果 Exchange 组织名中的字符无效，请删除组织名中的无效字符。有关无效字符的详细信息，请参阅 Microsoft 知识库文章 329599"Exchange Information Store Does Not Start and Events 1121 and 5000 Are Logged"（Exchange 信息存储无法启动并记录事件 1121 和 5000）。


MSExchangeIS 9518 (0xfffffddc)：超过此存储组的最大可用事务日志数
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-01-22

Microsoft® Exchange Server 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 0xfffffddc 的 MSExchangeIS 9518 事件。这表明已超过此存储组的最大可用事务日志数。

解释

尝试装入存储组的数据库时，如果以下两个条件都成立，则会记录错误代码为 0xfffffddc 的 MSExchangeIS 9518 事件：

  • 已超过此存储组的最大可用事务日志数。

  • 此存储组中的所有数据库均处于"干净关闭"状态。

此外，在受影响的数据库关闭之前，还会在应用程序日志中记录错误代码为 0xfffffdf9 的 MSExchangeIS 1159 事件。此事件表明 Exchange Server 已使用了此存储组的所有可用事务日志文件。当填充最后一个事务日志后，此存储组内的所有数据库将被卸除，并且无法重新启动。

Exchange 按顺序使用编号的事务日志文件。在 Exchange 2000 Server 和 Exchange Server 2003 中，事务日志文件以 Exx00001.log 开始，并按顺序增加到 ExxFFFF0.log。可以在单个序列中生成的最大事务日志文件数是 1,048,560 个 (0xFFFF0)。通常，需要经过数年的时间，执行的操作才会生成这么多日志文件。

在 Exchange Server 2007 中，事务日志文件较大。日志流中最多可以包含 2,147,483,647 个日志文件（十六进制为 0x7FFFFFFF，因为日志文件名称采用十六进制）。每个事务日志文件的大小为 1 MB。在 Exchange Server 2007 中，很可能不会发生此错误。

用户操作

要更正该错误，您必须删除所有事务日志文件，并将事务日志文件序列重置回 1。重置日志文件序列后，Exchange Server 2003 或更早版本中的日志文件名为 Exx00001.log；Exchange Server 2007 中的文件名则为 Exx00000001.log。

应使用作为 Microsoft Exchange 故障排除助理一部分的数据库恢复管理工具中的"重置日志生成编号"任务来执行此操作。该工具将验证所有数据库是否正常关闭，然后将所有事务日志文件安全地移到备份位置。

注意：
也可以手动删除事务日志文件，但手动删除可能会导致存储组中的数据库无法正常关闭，并且无法再次装入该数据库。为了防止出现此类故障，我们建议您使用数据库恢复管理工具。

有关此工具以及如何下载的详细信息，请参阅 Microsoft Exchange Troubleshooting Assistant v1.0（Microsoft Exchange 故障排除助理 1.0 版）。


MSExchangeIS 9518 (0xfffff745)：无法创建或访问 TMP 文件
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-01-23

Microsoft® Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 0xfffff745 的 MSExchangeIS 9518 事件。如果 Exchange 无法创建或访问在 TMP 或 TEMP 系统环境变量中指定的文件夹中的文件，则可能会发生此错误。

解释

如果以下任何条件成立，则可能会导致出现此问题：

  • TMP 或 TEMP 环境变量指向的路径不可用或者为只读。例如，如果将 TMP 环境变量映射到远程驱动器或存储区域网络 (SAN)，并且映射的该驱动器或 SAN 不再可用，则会出现此问题。

  • TMP 或 TEMP 环境变量具有不正确的注册表设置。

  • Exchange 没有驱动器根目录到事务日志和数据库的完全控制权限。

用户操作

若要解决该问题，可以执行以下一个或多个操作：

注意 由于存在几个 Microsoft Windows 版本，以下步骤可能会因计算机而异。如果是这种情况，请参阅产品文档以完成这些步骤。

  • 确保 TMP 环境变量和 TEMP 环境变量均指向 Windows 中的有效位置。为此，请执行下列步骤：

    设置 Temp 和 TMP 变量的有效路径

    1. 单击"开始"，指向"设置"，然后单击"控制面板"。

    2. 双击"系统"，单击"高级"选项卡，然后单击"环境变量"。

    3. 在"系统变量"下，单击 TEMP，然后单击"编辑"。

    4. 如果"变量值"框中没有显示有效路径，请为 TEMP 变量键入有效路径，然后单击"确定"。例如，键入 %systemroot%\Temp，然后单击"确定"。

    5. 在"系统变量"下，单击 TMP，然后单击"编辑"。

    6. 如果"变量值"框中没有显示有效路径，请为 TMP 变量键入有效路径，然后单击"确定"。例如，键入 %systemroot%\Temp，然后单击"确定"。

    7. 单击"确定"两次以关闭"系统属性"对话框。

    8. 重新启动计算机。
  • 验证并为本地 Administrators 组或 SYSTEM 帐户分配 Temp 文件夹的"完全控制"权限。仅为 Domain Admins 组分配"完全控制"权限是不够的。默认情况下，将为 TMP 和 TEMP 系统环境变量指定以下路径：

    %SYSTEMROOT%\Temp

    Exchange 必须使用 SYSTEM 帐户来访问此文件夹位置。若要查看这些权限，请执行下列步骤：

    验证 Temp 文件夹权限

    1. 右键单击"开始"，然后单击"资源管理器"。

    2. 右键单击在系统环境变量中指定的 Temp 文件夹，然后单击"属性"。通常，此文件夹是 %systemroot%\Temp。

    3. 单击"安全"选项卡。

    4. 在"名称"列表中，单击 SYSTEM，然后查看"权限"列表中显示的已分配权限。
    如果 Temp 文件夹权限正确无误，请验证包含 Exchange 数据库文件或 Exchange 日志文件的每个驱动器的权限。SYSTEM 帐户必须具有驱动器根目录和包含 Exchange 数据库文件或 Exchange 事务日志文件的每个文件夹的"完全控制"权限。例如，如果将事务日志放在 C:\Exchsrvr\Mdbdata 文件夹中，则 SYSTEM 帐户必须具有驱动器 C 的根目录、Exchsrvr 文件夹以及 Mdbdata 文件夹的"完全控制"权限。

  • 检查问题是否出在注册表设置不正确上。请执行下列步骤：

    验证注册表设置

    1. 单击"开始"，单击"运行"，键入 Regedt32.exe，然后单击"确定"。

    2. 找到下列注册表项：

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

    3. 找到 TMP（或 TEMP）名称。该项的类型应该为 REG_EXPAND_SZ。

    4. 如果任一项不正确，请备份"环境"子项，然后删除右侧的 TMP 或 TEMP 值。

    5. 单击"开始"，单击"运行"，键入 Sysdm.cpl，然后单击"确定"。

    6. 在"高级"选项卡上，单击"环境变量"。

    7. 在"系统变量"列表中，验证在第 4 步中删除的值在列表中是否不存在。

      注意：
      您可能需要向下滚动以查看 TEMP 或 TMP 变量。

    8. 单击"新建"。在"变量名"框中，键入在第 4 步中删除的名称。例如，键入 C:\Winnt\TEMP。

    9. 单击"确定"三次，然后重新启动计算机。


MSExchangeIS 9518 0xfffffbc4:日志文件路径已在使用中
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-05-14

Microsoft Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 0xfffffbc4 的 MSExchangeIS 9518 事件。此错误代码表明一个或多个存储组被配置为使用相同的日志文件路径或系统文件路径。

解释

如果将多个存储组配置为使用相同的日志文件路径或系统文件路径，则可能出现此错误。Exchange 要求每个存储组具有唯一的日志文件路径和系统文件路径。

用户操作

若要解决此问题，请确保为每个存储组配置唯一的日志文件路径和系统文件路径。

注意：
分离的存储组可以共享同一日志文件路径和系统文件路径。但是，该同一路径不能用作其他存储组的日志文件路径或系统文件路径。
在 Exchange 2000 Server 或 Exchange Server 2003 上验证或设置日志文件路径或系统文件路径

  1. 打开 Exchange 系统管理器。

  2. 依次展开"管理组"、您的管理组和"服务器"，右键单击您的存储组，再单击"属性"。

  3. 在"常规"选项卡的"事务日志位置"下，单击"浏览"。

  4. 验证"日志文件路径"和"系统文件路径"对存储组是否是唯一的。

  5. 如果存储组的"日志文件路径"和"系统文件路径"对存储组不是唯一的，请为日志文件和/或系统文件输入新位置的路径，再单击"确定"。

  6. 单击"确定"。
在 Exchange Server 2007 上验证或设置存储组的日志文件路径和系统文件路径

  1. 打开 Exchange 管理控制台。

  2. 展开"服务器配置"，并突出显示"邮箱"

  3. 在"邮箱"窗格中，选择要使用的服务器。

  4. 在"数据库管理"窗格中，右键单击要使用的存储组，再选择"属性"。

  5. 验证"日志文件路径"和"系统文件路径"对存储组是否是唯一的。

  6. 如果存储组的"日志文件路径"和"系统文件路径"对存储组不是唯一的，请按照 Exchange Server 2007 文档"How to Set or Change the Location of Storage Group Log Files"（如何设置或更改存储组日志文件的位置）(http://go.microsoft.com/fwlink/?LinkId=80702) 中的指导操作，将文件路径设置为每个存储组的唯一位置。

有关如何在 Exchange Server 2003 上移动日志文件的详细信息，请参阅 Microsoft 知识库文章 821915"如何在 Exchange Server 2003 中移动 Exchange 数据库和日志"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915)。

有关如何在 Exchange 2000 Server 上移动日志文件的详细信息，请参阅 Microsoft 知识库文章 239944"XADM：如何将事务或系统日志移动到其他位置"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239944)。


MSExchangeIS 9518 (0xfffffd9a)：缺少检查点文件并且存在的事务日志文件超过 1,008 个
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-01-23

Microsoft® Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 0xfffffd9a 的 MSExchangeIS 9518 事件。此错误表明此存储组的检查点文件 (Exx.chk) 丢失或被删除，并且要将超过 1,008 个事务日志文件播放到数据库中。

解释

如果以下条件成立，则可能会出现该问题：

  • 日志文件和数据库是正常关闭的。因此，没有要进行恢复的崩溃。

  • 重命名或删除了 Exx.chk 检查点文件。

  • 要在服务器上检查点之间重播的日志文件超过 1,008 个。

  • 在"前滚"恢复中，存储组中的一个或多个数据库丢失，但在进行恢复时，日志文件在服务器上保持不变。"前滚"恢复操作没有成功完成。

在这种情况下，Microsoft Exchange 信息存储服务在启动过程中执行软恢复并重播所有日志文件。由于日志文件和数据库是正常关闭的，因此不会执行任何恢复。由于没有检查点，Exchange 将处理所有日志，直至到达处于干净关闭状态的记录。由于日志文件超过 1,008 个，Exchange 在找到处于干净关闭状态的记录之前就会达到 1,008 个日志文件的限制。

注意：
如果前面列出的条件成立，并使用 eseutil /r 命令重播日志文件，也可能会出现所描述的症状。eseutil /r 命令还会对邮箱存储执行软恢复。

也可能会将此错误标识为错误 JET_errCheckpointDepthTooDeep, -614。此错误仅适用于 Microsoft Exchange Server 2003。

用户操作

要在 Exchange Server 2003 中解决此问题，请应用 Microsoft 知识库文章 836611"Information Store databases do not mount and you receive an "Operation terminated with error -614" error message when you start a computer that is running Exchange Server 2003"（启动运行 Exchange Server 2003 的计算机时，无法装入信息存储数据库并显示"运行由于错误 -614 而终止"错误消息）中介绍的修补程序。


MSExchangeIS 9518 0xfffffb40:缺少数据库文件
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-05-23

Microsoft Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 0xfffffb40 的 MSExchangeIS 9518 事件。这表明存储组缺少一个或多个数据库文件。

解释

可扩展存储引擎 (ESE) 尝试在恢复过程中将存储组中的所有数据库置于一致状态，但发现缺少数据库文件或者这些文件已被替换为其他版本时，可能会出现此错误。

如果存储组缺少任何数据库文件，或者该文件已被替换为其他版本，则 ESE 将返回错误 -1216，中止恢复过程，且不会启动存储组。

用户操作

若要解决此问题，请执行下列一项或多项操作：

  • 方法一：如果缺少的数据库文件已被移动或重命名，则在应用程序日志中查找在尝试装入数据库之后发生的任何 ESE 494 事件。对于每个事件，记录报告缺少的特定数据库文件，查找该文件的当前位置，然后将它移动到正确的位置。

注意：
如果此服务器上安装了文件级防病毒软件，但尚未正确配置排除项，则数据库可能已被防病毒软件删除或隔离。确保检查防病毒隔离和删除日志以查看是否发生了此情况。
  • 方法二：

    • 方法二 A：如果缺少的数据库文件已被删除或丢失，请将该文件从备份还原到生产存储组。可以使用 Exchange 数据库恢复管理工具的"验证数据库和事务日志文件"任务，验证已还原的数据库文件是否可用于执行还原。

      还原此数据库文件时，还可以通过完成下列步骤装入和访问存储组中其他未受影响的数据库：

允许用户邮箱访问未受影响的数据库

  1. 运行 eseutil /R /L <日志文件的路径> /S <Path to System Files> Log Base Name /I （其中日志基名称是此存储组日志文件的前三个字符，即 E00、E01 等）。这样，ESE 就可以使数据库文件呈现为一致的状态，同时忽略缺少的数据库文件。运行此命令后，将需要从备份还原所有缺少的数据库文件。
注意：
/L 和 /S 选项是可选的；如果从日志文件和系统文件所在的位置运行 eseutil，则无需使用这两个选项。
  1. 在存储组中装入现存的、一致的数据库文件。

  2. 具有由当前装入的数据库驻留的邮箱的用户现在可以访问其邮件了。
  • 方法二 B：将数据库文件从备份还原到恢复存储组。通过尽快使用新数据库启动，可以立即提供发送/接收功能（称为拨号音恢复）。客户端会看到空邮箱，但与等待还原或修复完成相比，它们可以较快地具有发送和接收功能。

注意：
拨号音选项要求最终将任何新的（拨号音之后的）数据与已还原的数据进行合并。

有关拨号音恢复的详细信息，请参阅 Exchange 2007 产品文档的灾难恢复主题中的"拨号音可移植性"。

有关恢复存储组的详细信息，请参阅 Exchange 2007 产品文档的灾难恢复主题中的"了解恢复存储组"。
  • 方法三：如果对存储组中的一个或多个数据库运行硬修复（手动运行或者从 Exchange 故障排除助理的"修复数据库"任务运行），且数据库处于一致的状态，则存储组的日志文件可能未被删除。如果存储组的所有数据库都处于正确的位置，则通过运行以下命令，验证所有数据库是否处于一致状态。

若要手动验证数据库文件是否处于一致状态，请执行下列操作：

  1. 运行 eseutil /mh <path to database .edb file>

  2. 在此命令的输出内容中，查找"状态："字段，并验证其值是否为"干净关闭"。

  3. 如果存储组的所有数据库都处于"干净关闭"状态，则将存储组的所有事务日志和系统日志移动到备份位置，再尝试装入存储。如果能够正确装入所有数据库，建议立即备份存储组。

详细信息

有关错误代码为 0xfffffb40 的 MSExchangeIS 9518 事件的详细信息，请参阅"Events and Errors Message Center"（事件和错误消息中心）(http://go.microsoft.com/fwlink/?LinkId=91705)。

有关从此错误恢复的详细信息，请参阅 Microsoft 知识库文章 296843"如何在出现错误 -1216 后恢复 Exchange 2000 Server 数据库"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=296843)。

有关 Exchange 灾难恢复规划的详细信息，请参阅"Exchange 灾难恢复规划指南"(http://go.microsoft.com/fwlink/?LinkId=91706)。

有关数据库恢复管理和数据库故障排除程序向导的详细信息，请参阅"Database Recovery Management and Database Troubleshooter Tool"（数据库恢复管理和数据库故障排除程序工具）(http://go.microsoft.com/fwlink/?LinkId=91707)。

有关拨号音恢复的详细信息，请参阅 Exchange 2007 产品文档的"Disaster Recovery"（灾难恢复）主题中的"Dial Tone Portability"（拨号音可移植性）(http://go.microsoft.com/fwlink/?LinkId=91703)。

有关恢复存储组的详细信息，请参阅 Exchange 2007 产品文档的"Disaster Recovery"（灾难恢复）主题中的"Understanding Recovery Storage Groups"（了解恢复存储组）(http://go.microsoft.com/fwlink/?LinkID=80784)。


MSExchangeIS 9518 (0xfffffea8)：数据库文件中的数据库时间戳不匹配
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-01-23

Microsoft® Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 0xfffffea8 的 MSExchangeIS 9518 事件。如果受影响的数据库的当前页上的 dbtime 大于数据库的全局数据库 dbtime，则会发生此错误。

解释

发生此错误时，将无法装入受影响的邮箱或公用文件夹数据库。此错误也被标识为 JET_errDbTimeCorrupted。

此错误适用于以下版本的 Exchange Server：

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

用户操作

若要解决数据库时间戳不匹配的问题，请运行 eseutil /d 命令以对出现此问题的数据库进行碎片整理，然后再装入该数据库。有关如何运行 eseutil /d 的详细信息，请参阅 How to Run Eseutil /D (Defragmentation)（如何运行 Eseutil /D（碎片整理））。另外，请参阅 Microsoft 知识库文章 328804"如何对 Exchange 数据库进行碎片整理"。


MSExchangeIS 9518 (0xfffff764)：流式文件丢失或无法访问
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-01-23

Microsoft® Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 0xfffff764 的 MSExchangeIS 9518 事件。如果 Exchange 无法访问与数据库关联的流式文件 (.stm)，则可能会发生此错误。

解释

如果已删除或移动与数据库关联的流式文件 (.stm)，或者 Exchange 由于权限更改而无法访问流式文件，则可能会发生此错误。

注意：
在某些情况下，如果尚未按照 Microsoft Exchange 最佳实践将 Exchange 目录从扫描中排除，防病毒程序可能会删除或更改 Exchange 文件（包括 .stm 文件）的权限。有关此主题的详细信息，请参阅 Microsoft 知识库文章 823166"Exchange Server 2003 和防病毒软件概述"。

也可能会将该错误标识为 -2204。此错误适用于以下版本的 Exchange Server：

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

用户操作

若要解决该问题，请执行以下一个或多个操作：

  • 从数据库的备份副本中还原流式文件。

  • 检查防病毒软件是否已将流式文件移到隔离文件夹。如果文件位于隔离文件夹，请将其移到原始位置，然后配置防病毒程序以使其不扫描 Exchange Server 2003 文件夹。

    注意：
    某些防病毒程序将文件移到隔离文件夹时，会将文件属性更改为只读。如果发现流式文件位于隔离文件夹中，请右键单击该文件，然后单击"属性"。单击以清除"只读"复选框，然后再尝试装入数据库。
  • 您可以运行作为 Microsoft Exchange 故障排除助理一部分的 Microsoft Exchange 数据库恢复管理工具。数据库恢复管理工具可以分析数据库以及此存储组的事务日志文件，并提供有关此问题的其他详细信息。有关此工具以及如何下载的详细信息，请参阅 Microsoft Exchange Troubleshooting Assistant v1.0（Microsoft Exchange 故障排除助理 1.0 版）。


MSExchangeIS 9518 (0xfffffbf8):在 Exchange 数据库文件夹或驱动器上缺少所需权限
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-03-15

Microsoft Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 0xfffffbf8 的 MSExchangeIS 9518 事件。这表明没有为包含 Exchange 数据库的文件夹或驱动器分配适当的权限。

解释

此错误表明没有为承载 Exchange 数据库文件的文件夹或驱动器分配执行最低功能所需的权限。在访问或装入邮箱存储或公用文件夹存储时，可能会遇到困难。

用户操作

若要解决此问题，请将默认权限授予包含 Exchange 数据库的文件夹以及此文件夹所驻留的驱动器。

在 Exchange 2007 中将默认权限授予包含 Exchange 数据库的文件夹

  1. 启动 Windows 资源管理器，再导航到包含 Exchange 数据库的文件夹。默认为 C:\Program Files\Microsoft\Exchange\Mailbox\存储组名称\

  2. 右键单击该文件夹，再单击"属性"。

  3. 单击"安全"选项卡，再授予下列默认权限

帐户 | 权限
Administrators | 完全控制
System | 完全控制
 在 Exchange 2007 中将默认权限授予包含 Exchange 数据库的驱动器

  1. 启动 Windows 资源管理器。

  2. 右键单击包含 Exchange 数据库文件夹的本地磁盘对象，再单击"属性"。

  3. 选择"安全"选项卡，再根据安装的操作系统授予下列默认权限：

对于 Windows 2000 Server：

帐户 | 权限
Everyone | 完全控制

对于 Windows Server 2003：

帐户 | 权限
Administrators | 完全控制
Creator Owner | 无
Everyone | 无
System | 完全控制
Users | 读取和执行，列出文件夹内容，读取
 在 Exchange 2000 Server 和 Exchange Server 2003 中将默认权限授予 Mdbdata 文件夹

  1. 启动 Windows 资源管理器，再导航到 Exchsvr 文件夹并展开它。

  2. 右键单击 Mdbdata 文件夹，再单击"属性"

  3. 单击"安全"选项卡，再授予下列默认权限：

帐户 | 权限
Administrators | 完全控制
Authenticated Users | 读取和执行，列出文件夹内容，读取
Creator Owner | 无
Server Operators | 修改，读取和执行，列出文件夹内容，读取，写入
System | 完全控制
 在 Exchange 2000 Server 和 Exchange Server 2003 中将默认权限授予包含 Mdbdata 文件夹的驱动器

  1. 启动 Windows 资源管理器。

  2. 右键单击包含 Mdbdata 文件夹的本地磁盘对象，再单击"属性"。

  3. 选择"安全"选项卡，再根据安装的操作系统授予下列默认权限：

对于 Windows 2000 Server：

帐户 | 权限
Everyone | 完全控制

对于 Windows Server 2003：

帐户 | 权限
Administrators | 完全控制
Creator Owner | 无
Everyone | 无
System | 完全控制
Users | 读取和执行，列出文件夹内容，读取

详细信息

有关此问题的详细信息，请参阅 Microsoft 知识库文章 823022"已记录事件 ID 490，您在 Exchange Server 中尝试装入邮箱存储或公用存储时收到以下错误消息：'ID 号：c1041724'"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823022)。


MSExchangeIS 9518 (0xfffff743):临时文件过多
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-03-14

Microsoft Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 0xfffff743 的 MSExchangeIS 9518 事件。这表明服务器的临时文件命名空间已用尽，或者没有可用于写入 temp 文件夹的空间。

解释

当较大的对象（如邮件或文件）流入存储区中且 .stm 文件太过碎片化而无法在其中写入整个对象时，Exchange 2000 Server 和 Exchange Server 2003 将在 Temp 文件夹中创建临时文件。

在正常操作过程中，停止 Exchange 服务时，将从 Temp 文件夹中删除这些文件。如果 Exchange 服务器意外关闭或者 Exchange 服务意外终止，则不会删除这些文件。稍后重新启动 Exchange 服务时，会创建新的临时文件。这会导致性能降低。用尽 64,000 临时文件命名空间时，Exchange 服务就无法启动，且将在事件查看器应用程序日志中记录错误代码为 0xfffff743 的 9518 事件。

用户操作

若要解决该问题，请执行下列操作：

  • 检查 Windows Temp 文件夹中是否存在 lb*.tmp 文件。如果存在这些文件，请按照以下过程中的步骤删除它们。

  • 检查驻留 Temp 文件夹的驱动器是否有可用磁盘空间。如果磁盘可用空间不足，则使用以下过程将 Temp 和 Tmp 文件夹移动到其他驱动器。

从 Windows Temp 文件夹中删除 lb*.tmp 文件

  1. 单击"开始"，选择"程序"，再选择"管理工具"，然后单击"服务"。

  2. 向下滚动到"Microsoft Exchange 信息存储"。

  3. 如果服务的状态为 Started，则右键单击该服务，再单击"停止"
注意：
这将断开所有用户与其邮箱的连接。
  1. 导航到 %windir%\temp 文件夹，其中 %windir% 是 Windows 系统根文件夹，默认为 C:\Windows\Temp。

  2. 删除所有 lb*.tmp 文件。

  3. 在"服务"管理控制台中，右键单击"Microsoft Exchange 信息存储"服务，再单击"启动"。

 将 Temp 和 Tmp 文件夹移动到其他驱动器

  1. 在 Exchange Server 计算机上，单击"开始"，再单击"控制面板"，然后双击"系统"。

  2. 单击"高级"选项卡，再单击"环境变量"。

  3. 在"系统变量"下，单击包含 TEMP 变量和该驱动器的一行，再单击"编辑"，然后键入新驱动器的位置。

  4. 在"系统变量"下，单击包含 TMP 变量和该驱动器的一行，再单击"编辑"，然后键入新驱动器的位置
注意：
确保此更改应用于"系统变量"而不是"用户变量"。
注意：
如果此处概述的过程未解决此问题，请查看 Microsoft 知识库文章 307242"信息存储未能装入，出现 0xfffff745 和 -2235 错误"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307242) 中的信息。

详细信息

有关此问题的详细信息，请参阅下列 Microsoft 知识库文章：

  • 294462"Windows Temp 文件夹中的 Exchange lb*.tmp 文件导致 ESE -2237 错误"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=294462)

  • 307242"信息存储未能装入，出现 0xfffff745 和 -2235 错误"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307242)


MSExchangeIS 9519 (0xfffffb3a)：检测到正在使用多个具有相同签名的数据库
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-01-23

Microsoft® Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 0xfffffb3a 的 MSExchangeIS 9519 事件。此错误表明已在运行相同数据库的另一个副本。

解释

每个 Exchange 数据库具有其自己的唯一签名。如果 Microsoft Exchange 信息存储服务检测到多个具有相同签名的数据库，它将禁止装入重复的数据库。

也可能会将该事件标识为错误 -1222 JET_errDatabaseSignInUse。

用户操作

可通过执行下列步骤，验证在单个存储组中是否存在相同数据库的两个副本：

  1. 卸除存储组中的所有其他数据库，然后尝试装入导致该错误消息的数据库。

  2. 如果能够装入数据库，则必须随后尝试装入存储组中的所有其他数据库。

  3. 如果存储组中的不同数据库现在在应用程序日志中记录相同的错误，则两个数据库具有相同的签名；因而它们是相同数据库的副本。

要解决该问题，请确保在此特定存储组中仅存在数据库的一个副本。


MSExchangeIS 9519 (0xfffffe07)：由于运行备份过程而无法装入数据库
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-02-27

Microsoft Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 0xfffffe07 的 MSExchangeIS 9519 事件。此错误表明由于运行备份过程而无法装入指定的数据库。

解释

如果此数据库所属的存储组中包含多个数据库（邮箱数据库或公用文件夹数据库），并且在尝试装入此数据库的同时正在备份其中的另一个数据库，则可能会发生此错误。这种情况是设计所致。在备份存储组中的一个数据库时，无法装入相同存储组中的其他数据库。

也可能会将该错误标识为错误 -505, JET_errBackupInProgress。

用户操作

确保未在备份存储组中的其他数据库，然后再尝试装入该数据库。或者，等到存储组中的其他数据库的备份过程完成后，再尝试装入此数据库。


MSExchangeIS 9519 (0x3f3)：在还原后没有选中"还原时可以覆盖此数据库"复选框
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-01-23

Microsoft® Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 0x3f3 的 MSExchangeIS 9519 事件。此错误表明对数据库执行还原时没有选中"还原时可以覆盖此数据库"复选框。

解释

如果已执行了数据库还原操作，并且 Exchange 检测到没有选中存储属性上的"还原时可以覆盖此数据库"复选框，则会发生此事件。

用户操作

若要解决该问题，请执行下列操作以确保还原可以覆盖数据库。

在 Exchange Server 2003 和 Exchange 2000 Server 中启用此选项

  1. 启动"Exchange 系统管理器"。

  2. 展开"管理组"（如果适用）。

  3. 依次展开"服务器"、<服务器名> 和 <存储组>，然后单击还原的数据库。

  4. 右键单击该数据库，然后单击"属性"。

  5. 单击"数据库"选项卡。

  6. 单击以选中"还原时可以覆盖此数据库"复选框。

  7. 单击"确定"。

  8. 若要装入数据库，请右键单击数据库，然后单击"装入存储"。
在 Exchange Server 2007 中启用此选项

  1. 启动"Exchange 管理控制台"。

  2. 在"服务器配置"下，选择"邮箱"。

  3. 在"数据库管理"窗格中，右键单击还原的数据库。

  4. 单击"属性"。

  5. 选择"常规"选项卡。

  6. 单击以选中"还原时可以覆盖此数据库"复选框。

  7. 单击"确定"。

  8. 若要装入数据库，请右键单击数据库，然后单击"装入数据库"。


MSExchangeIS 9518 (0xfffffc01)：数据库或事务日志的驱动器或目录不正确
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-01-23

Microsoft® Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 0xfffffc01 的 MSExchangeIS 9518 事件。这表明为 Exchange 数据库或日志文件设置的驱动器号或路径不正确。

解释

此错误表明受影响的存储组中的数据库或日志文件路径指向无效的驱动器号或者文件路径不正确。发生此错误时，将无法装入受影响的存储组中的所有数据库。

如果防病毒软件阻止对包含 Exchange 数据库或事务日志文件的驱动器进行写入访问，也可能会出现此问题。

也可能会将该事件标识为错误 -1023 JET_errInvalidPath。

用户操作

若要解决该问题，请执行以下一个或多个操作：

  • 若要确定防病毒软件是否导致此问题，请在"服务"控制台中暂时禁用防病毒软件。然后，尝试装入受影响的数据库。如果数据库成功装入，请与防病毒软件供应商联系以获取最新软件版本。

  • 验证并为此错误影响的每个存储组和数据库设置正确的系统、数据库以及事务日志文件路径。请执行下列步骤。

在 Exchange Server 2003 或 Exchange 2000 Server 中验证并设置正确的文件路径

  1. 启动"Exchange 系统管理器"。单击"开始"，指向"程序"，指向 Microsoft Exchange，然后单击"系统管理器"。

  2. 如果 Exchange 系统管理器中显示管理组，请展开"管理组"，然后展开出现问题的管理组。

  3. 展开"服务器"，然后展开出现问题的服务器。

  4. 右键单击包含无法装入的存储的存储组，然后单击"属性"。

  5. 在"常规"选项卡上，检查"事务日志位置"框中显示的路径。检查"系统路径位置"框中的路径。

    如果这些路径不正确，请与 Microsoft 产品支持服务联系以帮助解决此问题。

  6. 对于可能存在的每个存储组，执行步骤 3 至 5 以验证数据库路径和事务日志文件路径。

  7. 验证每个存储组的系统路径和事务日志文件路径后，请验证每个存储组中每个存储的数据库路径。为此，请执行下列步骤：

    1. 展开某个存储组。例如，展开"第一个存储组"。

    2. 右键单击 StoreName (ServerName)，然后单击"属性"。

    3. 单击"数据库"选项卡，然后验证"Exchange 数据库"框中显示的路径。接下来，验证"Exchange 流式数据库"框中显示的路径。

      如果特定路径不正确，请与 Microsoft 产品支持服务联系以帮助解决此问题。

    4. 重复步骤 7b 和 7c，以验证每个存储组中存在的每个邮箱存储或公用文件夹存储的路径。

  8. 装入邮箱存储或公用文件夹存储。

在 Exchange Server 2007 中验证并设置正确的文件路径

  1. 启动"Exchange 管理控制台"。单击"开始"，指向"程序"，指向 Microsoft Exchange，然后单击"Exchange 管理控制台"。

  2. 展开"服务器配置"，选择"邮箱"

  3. 在"数据库管理"窗格中，选择包含无法装入的数据库的存储组。

  4. 右键单击该存储组，然后单击"属性"。

  5. 在"常规"选项卡上，检查"日志路径"和"系统路径"位置中列出的路径。

    如果这些路径不正确，请右键单击该存储组，然后选择"移动存储组路径"。在"日志文件路径"和"系统文件路径"下，单击"浏览"以找到包含事务日志文件或数据库文件的文件夹。默认情况下，事务日志文件和数据库文件位于下列文件夹中：

    %PROGRAMFILES%\Microsoft\Exchange Server\Mailbox\<storage group name>

  6. 单击"确定"。

  7. 对于可能存在的每个存储组，执行步骤 3 至 5 以验证系统路径和事务日志文件路径。

  8. 验证每个存储组的系统路径和事务日志文件路径后，请验证每个存储组中每个数据库的数据库路径。为此，请执行下列步骤：

    1. 展开某个存储组。例如，展开"第一个存储组"。

    2. 验证"数据库管理"窗格中"数据库文件路径"下显示的路径。

    3. 如果特定路径不正确，请右键单击数据库，然后单击"移动数据库路径"。

    4. 单击"浏览"，找到数据库文件的正确文件夹。默认情况下，Exchange 数据库文件 (.edb) 位于下列文件夹中：

      %PROGRAMFILES%\Microsoft\Exchange Server\Mailbox\<storage group name>\<database name.edb>

    5. 单击"确定"。

    6. 重复步骤 8b 至 8e，以验证每个存储组中存在的每个邮箱或公用文件夹数据库的路径。

  9. 装入邮箱数据库或公用文件夹数据库。


MSExchangeIS 9519 (0xfffffbda)：缺少配置为默认系统区域设置的双字节字符集区域设置
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-01-23

Microsoft® Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 0xfffffbda 的 MSExchangeIS 9519 事件。此事件表明安装了非英文默认系统区域设置。安装 Exchange Server 后，卸载了默认系统区域设置。

解释

如果在重新启动 Exchange Server 时触发了错误代码为 0xfffffbda 的事件 MSExchangeIS 9519，则无法装入 Exchange 数据库。此外，还会在应用程序事件日志中记录错误事件 ESE 604 和 MSExchangeIS 9519。

如果以前将非英文区域设置设为默认系统区域设置，则可能会出现这种情况。如果选择另一种区域设置作为默认系统区域设置，删除非英文区域设置，然后重新启动 Exchange 2000 Server 或 Exchange Server 2003，则会发生此事件。

也可能会将该事件标识为 -1062, JET_errInvalidLanguageId。此事件适用于以下版本的 Exchange Server：

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

用户操作

若要解决该问题，请重新安装非英文区域设置，或者创建新的数据库。如果重新安装非英文区域设置，则不必将其设置为默认系统区域设置。


MSExchangeIS 9519 (0xfffff05b)：在运行 Exchange Server 2000 SP3 或更高版本的服务器上压缩了数据库或日志
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-02-19

Microsoft Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 0xfffff05b 的 MSExchangeIS 9519 事件。此错误表明 Exchange 数据库或事务日志文件所在的驱动器启用了文件系统压缩。

解释

如果将 Exchange 2000 Server Service Pack 3 (SP3) 应用于 Exchange 2000 Server，而 Exchange 2000 Server 包含使用 NTFS 文件系统压缩进行压缩的信息存储数据库，则可能会发生此事件。如果将 Exchange 2000 Server 计算机升级到 Exchange Server 2003，也可能会发生此问题。Exchange 2000 Server SP3、Exchange Server 2003 和 Exchange Server 2007 禁止装入压缩的信息存储数据库。

也可能会将该错误标识为 -4005, JET_errFileCompressed。此错误适用于以下版本的 Exchange Server：

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server SP3

用户操作

若要解决该问题，必须解压缩信息存储数据库和日志所在的文件夹，对数据库进行碎片整理，然后对数据库和日志所在的信息存储存储组进行 Exchange 支持的联机备份。为此，请参阅 Microsoft 知识库文章 327772"Database does not mount, and you receive error 0xfffff05b after you apply SP3 to Exchange 2000"（将 SP3 应用于 Exchange 2000 后，无法装入数据库并出现错误 0xfffff05b）。


MSExchangeIS 9519 (0xfffffa84)：数据库索引丢失或损坏
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-01-22

Microsoft® Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 0xfffffa84 的 MSExchangeIS 9519 事件。此事件表明此数据库的索引已损坏或丢失。

解释

下列原因可能会导致数据库索引损坏或丢失：

  • 应用新的 Microsoft Windows Service Pack 后，在 Exchange 数据库索引清理过程中可能会发生此事件。在应用 Service Pack 后，无法在 Exchange 服务器中装入邮箱或公用文件夹数据库。此外，还会在应用程序事件日志中记录事件 ESE 609 和 ESE 611。

  • 在运行数据库修复操作 (eseutil /p) 后可能发生此事件。这可能会删除第一次创建数据库时生成的索引。运行 Eseutil 修复命令会删除索引。

也可能会将该错误标识为 -1404, JET_errIndexNotFound。此错误适用于以下版本的 Exchange Server：

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

用户操作

若要解决该问题，请按照与以前描述的问题方案匹配的解决方法进行操作：

  • 应用新的 Windows Service Pack 后，如果在 Exchange 数据库索引清理过程中某个索引损坏，请执行下列步骤：

    1. 从已知良好的备份中还原受影响的邮箱或公用文件夹数据库。

    2. 通过运行 eseutil /d，对受影响的数据库执行脱机碎片整理。有关如何对受影响的数据库执行脱机碎片整理的信息，请参阅下列主题：

      Exchange 2000 Server 和 Exchange Server 2003 数据库：How to Run Eseutil /D （如何运行 Eseutil /D（碎片整理））

      Exchange Server 2007 数据库：How to Run Eseutil /D (Defragmentation)（如何运行 Eseutil /D（碎片整理））

  • 如果在运行数据库修复 (eseutil /p) 操作后索引丢失，请应用 Microsoft 知识库文章 924627"Event ID 9519 that includes error 0xfffffa84 is logged when you try to mount a database after you use the Eseutil and Isinteg utilities to recover the database in Exchange 2003"（在 Exchange 2003 中使用 Eseutil 和 Isinteg 实用程序恢复数据库后，尝试装入该数据库时记录包含错误 0xfffffa84 的事件 ID 9519）中介绍的修补程序。


MSExchangeIS 9519 0x972：公用文件夹容器被删除，或缺少所需属性
Microsoft Exchange Server 分析工具 - 文章 > 数据库恢复 >

主题上次修改时间： 2007-08-30

Microsoft Exchange 数据库故障排除程序工具在应用程序日志中检测到一个或多个错误代码为 0x972 的 MSExchangeIS 9519 事件。这表示由于公用文件夹容器已被删除，或缺少所需属性而在装入公用文件夹数据库时失败。

解释

在公用文件夹容器已从 Active Directory 中删除，或是受影响的公用存储未配置为使用公用文件夹容器，即公用文件夹容器 msExchOwningPFTreeBL 属性的值未指向公用存储时会发生此错误。最有可能出现此错误的原因是，在未将公用文件夹容器移动到新的管理组之前就删除了包含该公用文件夹容器的管理组。

用户操作

若要解决此问题，请使用 ADSI Edit 或类似工具确定是否存在公用文件夹容器，以及 msExchOwningPFTreeBL 属性是否已正确配置为指向相关的公用存储。

警告：
在使用 ADSI Edit、LDP 工具或其他 LDAP 版本 3 客户端时，如果未正确修改 Active Directory 对象的属性，则可能会出现严重问题。若要解决这些问题，您可能需要重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003/Exchange Server 2007。修改 Active Directory 对象属性的风险由您自己承担。
确定造成该错误的原因

  1. 使用 ADSI Edit 或类似工具，找到 Active Directory 中每个管理组对象。

    可以在下列位置找到管理组对象：

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group

  2. 依次展开每个管理组，检查是否存在 CN=Folder Hierarchies 容器。如果存在 CN=Folder Hierarchies 容器，则突出显示该容器，验证右侧窗格中是否存在 CN=Public Folders 对象。如果在任何管理组中都不存在 CN=Public Folders 对象，则转至解决方案 1，重新创建文件夹层次结构和公用文件夹容器。如果确实找到了 CN=Public Folders 容器，则继续执行步骤 3。

  3. 右键单击 CN=Public Folders 对象，再单击"属性"。

  4. 在"属性" 列表中，选择 msExchOwningPFTreeBL 属性，再单击"编辑"。

  5. 确保"数值"列表中显示有受影响的公用文件夹存储。如果其中未列出，则继续进行解决方案 2。
解决方案 1：重新创建文件夹层次结构和公用文件夹容器

  1. 使用 ADSI Edit 或类似工具，找到并展开"Exchange 管理组 (FYDIBOHF23SPDLT)"。

    "Exchange 管理组 (FYDIBOHF23SPDLT)"对象可以在下列位置找到：

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups

  2. 右键单击"Exchange 管理组 (FYDIBOHF23SPDLT)"对象，依次单击"新建"和"对象"。

  3. 从"选择类别"列表中，选择 msExchPublicFolderTreeContainer，再单击"下一步"。

  4. 针对"数值"框，键入"文件夹层次结构"，再依次单击"下一步"和"完成"。

  5. 右键单击新创建的"文件夹层次结构"对象，然后依次单击"新建"和"对象"。

  6. 从"选择类别"列表中，选择 msExchPFTree，再单击"下一步"。

  7. 针对"数值"框，键入"公用文件夹"，再单击"下一步"。

  8. 单击"更多属性"。

  9. 从"选择要查看的属性"下拉列表中，选择 msExchPFTree。

  10. 针对"编辑属性"框，键入 1，然后依次单击"设置"、"确定"和"完成"。

  11. 若要将公用文件夹容器分配至每个公用存储，请右键单击"公用文件夹"容器，然后选择"属性"。

  12. 从"属性"列表中，选择 distinguishedName，再单击"编辑"。

  13. 将"数值"框中的内容复制到剪贴板，再单击"取消"。

  14. 对于出现错误代码为 0x972 的 MSExchangeIS 9519 事件的每台服务器，导航到公用文件夹存储对象。此对象的默认位置为：

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups, CN=Exchange Administrative Group (FYDIBOHF23SPDLT), CN=Servers, CN= ServerName , CN= InformationStore , CN=Second Storage Group。

  15. 右键单击公用文件夹存储对象，再单击"属性"。

  16. 从"属性"列表中，选择 msExchOwningPFTree，再单击"编辑"。

  17. 将在步骤 13 中复制到剪贴板的数值粘贴到"数值"框中，再单击"确定"两次完成操作。

  18. 对于出现错误代码为 0x972 的 MSExchangeIS 9519 事件的每台服务器，重复操作步骤 15 至 17。

  19. 在受影响的服务器上，重新启动 Microsoft Exchange 信息存储服务。

解决方案 2：针对公用文件夹容器对象，重新填充 msExchOwningPFTreeBL 属性的值

  1. 使用 ADSI Edit 或类似工具，在 Active Directory 中找到"公用文件夹"对象。

    "公用文件夹"对象可以在下列位置找到：

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Folder Hierarchies,CN=Public Folders

  2. 右键单击"公用文件夹"容器，然后选择"属性"。

  3. 从"属性"列表中，选择 distinguishedName，再单击"编辑"。

  4. 将"数值"框中的内容复制到剪贴板，再单击"取消"。

  5. 对于出现错误代码为 0x972 的 MSExchangeIS 9519 事件的每台服务器，导航到公用文件夹存储对象。此对象的默认位置为：

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups, CN=Exchange Administrative Group (FYDIBOHF23SPDLT), CN=Servers, CN= ServerName , CN= InformationStore , CN=Second Storage Group。

  6. 右键单击公用文件夹存储对象，再单击"属性"。

  7. 从"属性"列表中，选择 msExchOwningPFTree，再单击"编辑"。

  8. 将在步骤 4 中复制到剪贴板的数值粘贴到"数值"框中，再单击"确定"两次完成操作。

  9. 对于出现错误代码为 0x972 的 MSExchangeIS 9519 事件的每台服务器，重复操作步骤 6 至 8。

  10. 在受影响的服务器上，重新启动 Microsoft Exchange 信息存储服务。


Exchange 群集
Microsoft Exchange Server 分析工具 - 文章 >

主题上次修改时间： 2005-11-18

此部分中的文章提供了有关 Microsoft® Exchange Server 分析工具就 Exchange 群集进行评估的详细信息。此外，这些文章还描述了为解决 Exchange Server 分析工具发现的与 Exchange 群集有关的错误、警告和非默认配置所能采取的措施。


群集调试已启用
Microsoft Exchange Server 分析工具 - 文章 > Exchange 群集 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定服务器上是否已启用群集调试：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Cluster\Debug

如果 Exchange Server 分析工具发现 Debug 值等于 1，则 Exchange Server 分析工具将显示警告。

如果使用此注册表值进行群集调试，将阻止群集资源在各个节点之间进行故障转移。只有调试的问题要求阻止资源进行故障转移时，才应使用此注册表值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
禁用群集调试注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到 HKLM\Software\Microsoft\Exchange\Cluster。

  3. 将 Debug 值更改为 0。

  4. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Exchange 群集的详细信息，请参阅"Exchange 2003 Server 管理指南"中的"管理 Exchange 群集"主题(http://www.microsoft.com/downloads/details.aspx?FamilyID=98e45481-1458-4809-97d6-50d8aeebd8a1&DisplayLang=zh-cn)。


群集专用检测信号网络优先级的设置不正确
Microsoft Exchange Server 分析工具 - 文章 > Exchange 群集 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Exchange 服务器群集中的每个网络接口资源的优先级顺序：

HKEY_LOCAL_MACHINE\Cluster\Networks\<NetworkInterfaceGUID>\Priority

Priority 的值表明为网络接口资源配置的网络优先级。优先级最高的网络接口资源的 Priority 值为 1，优先级其次的网络接口资源的 Priority 值为 2，依此类推。

Exchange Server 分析工具还读取以下注册表项，以确定为 Exchange 服务器群集中的每个网络定义的角色：

HKLM\Cluster\Networks\<NetworkInterfaceGUID>\Role

值为 1 表明网络资源已配置为专用的私有（检测信号）网络。值为 2 表明网络资源已配置为专用的公用网络（客户端访问）。值为 3 表示网络资源已配置为既允许检测信号通信又允许客户端访问通信的混合网络。

如果 Exchange Server 分析工具确定 Role 值为 1 的网络接口资源具有大于 1 的 Priority 值，则会显示警告。此警告意味着找到了专用的检测信号网络，但其网络优先级的设置不正确。

对于所有 Exchange Server 群集，推荐的最佳实践都是配置专用的私有网络以供群集检测信号使用。节点之间的通信对于群集的正常工作至关重要。请依照下面的说明正确地为专用的检测信号网络配置网络优先级。

解决此警告问题

  1. 打开群集管理器并连接到 Exchange 服务器群集。

  2. 在左侧窗格中，用鼠标右键单击层次结构顶部的"群集"对象，再单击"属性"。

  3. 单击"网络优先级"。

  4. 选择专用的检测信号网络资源。

  5. 单击"上移"，直到专用的检测信号网络资源到达所列出的网络资源的顶部。

  6. 单击"确定"。

有关群集检测信号网络的详细信息，请参阅下列 Microsoft 知识库文章：

  • 258750"建议在群集服务器上使用的专用'检测信号'配置"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)

  • 307962"Multicast Support Enabled for the Cluster Heartbeat"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307962)

有关详细信息，请查阅"Exchange Server 2003 Cluster Configuration Checklist"（英文）(http://go.microsoft.com/fwlink/?linkid=36083)。


群集节点的 Windows 内部版本号与第一个节点不匹配
Microsoft Exchange Server 分析工具 - 文章 > Exchange 群集 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定在群集中的每个节点上运行的 Microsoft Windows® 操作系统的核心版本：

HKEY_LOCAL_MACHINE\Cluster\Nodes\<Node Number>\BuildNumber

如果 Exchange Server 分析工具发现 Exchange 群集中的第二个或后续节点上的 BuildNumber 值与 Exchange 群集中的第一个节点上的 BuildNumber 值不同，则显示错误。

如果 Exchange 群集中的节点运行完全不同的 Windows 版本，则故障转移可能不会像所期望或所配置的那样工作。在混合旧版 Windows 的环境中，只能从早期的操作系统向更高版本的操作系统进行故障转移（例如，从 Windows 2000 Advanced Server 向 Windows Server™ 2003 企业版进行故障转移），而不能从较高版本的操作系统向早期的操作系统进行故障转移（例如，从 Windows Server 2003 向 Windows 2000 Server 进行故障转移）。

要解决此问题，必须将所有节点升级至同一操作系统和 Service Pack。要尽量减少停机时间，可以执行群集的滚动升级。

更正此错误

  1. 阅读 Microsoft 知识库文章 811272"如何执行 Windows Server 2003 服务器群集的滚动升级"(http://support.microsoft.com/kb/811272/zh-cn)，了解关于执行群集的滚动升级的说明。

  2. 查阅文章"Windows 2000 Clustering: Performing a rolling upgrade"（英文）(http://go.microsoft.com/fwlink/?linkid=1718)。

  3. 对 BuildNumber 值与群集中第一个节点的 BuildNumber 值不同的每个节点执行滚动升级。

有关其他方法的信息，请参阅"Alternatives to Rolling Upgrades"（英文）(http://go.microsoft.com/fwlink/?LinkId=41363)。


群集节点的 Windows Service Pack 的版本与第一个节点不匹配
Microsoft Exchange Server 分析工具 - 文章 > Exchange 群集 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定群集中每个节点上安装的 Microsoft Windows® Service Pack 的版本：

HKEY_LOCAL_MACHINE\Cluster\Nodes\<Node Number>\CSDVersion

如果 Exchange Server 分析工具发现 Exchange 群集中的第二个或后续节点上的 CSDVersion 值与 Exchange 群集中的第一个节点上的 CSDVersion 值不同，则显示错误。

此错误意味着该 Exchange 群集中的各节点运行的不是同一级别的 Windows Service Pack。推荐的最佳实践是在 Exchange 群集中的所有节点上运行同一级别的操作系统和 Service Pack。

若要解决此问题，必须将所有节点升级到同一操作系统和 Service Pack。为了尽量减少停机时间，可以执行群集的滚动升级。

解决此警告问题

  1. 查阅 Microsoft 知识库文章 811272"如何执行 Windows Server 2003 服务器群集的滚动升级"(http://support.microsoft.com/kb/811272/zh-cn)，了解关于执行群集的滚动升级的说明。

  2. 查阅文章"Windows 2000 Clustering:Performing a Rolling Upgrade"（英文）(http://go.microsoft.com/fwlink/?linkid=34288)。

  3. 对 CSDVersion 值与群集中的第一个节点不同的每个节点执行滚动升级。

有关其他方法的信息，请参阅"Alternatives to rolling upgrades"（英文）(http://go.microsoft.com/fwlink/?linkid=34289)。


群集 TEMP/TMP 路径与系统分区位于同一个驱动器上
Microsoft Exchange Server 分析工具 - 文章 > Exchange 群集 >

主题上次修改时间： 2005-11-18

在非群集 Exchange Server 计算机上，Microsoft® Exchange Server 分析工具读取下列注册表项，以确定 TEMP 和 TMP 环境变量的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

HKLM\System\CurrentControlSet\Control\Session Manager\Environment\TMP

当 Exchange Server 分析工具针对 Microsoft Windows® 服务器群集中的 Exchange 虚拟服务器 (EVS) 运行时，它不会读取 HKLM 注册表配置单元。而是读取下列注册表项：

HKEY_USERS\<Cluster service account SID>\Environment\TEMP

HKEY_USERS\<Cluster service account SID>\Environment\TMP

如果 Exchange Server 分析工具发现 TEMP 和/或 TMP 环境变量以 %SYSTEMROOT 开头，则显示警告。

Microsoft Exchange 信息存储服务进程在多种操作（例如，邮件转换和邮箱移动操作）期间都将使用 TEMP 和 TMP 文件夹作为临时存储区。在非群集的 Exchange 服务器上，Microsoft Exchange 信息存储服务会使用 SYSTEM（例如，Local System）帐户，而该帐户则会将默认的环境变量设置 %Systemroot%\Temp 作为 TEMP 和 TMP 来使用。

运行在 Windows Server 群集中的 EVS 在处理群集服务帐户时将使用环境变量设置，而群集服务帐户运行在特定用户安全规定的上下文之下。对于用户帐户，TEMP 和 TMP 的默认环境变量被设置为 %Userprofile%\temp。

TEMP 和 TMP 环境变量用来指定文件系统中的哪些文件夹（例如哪个路径）应当被需要临时工作区的应用程序使用。TEMP 通常由应用程序（例如，Exchange）使用，而 TMP 通常由开发工具（例如，Microsoft Visual C++®）使用。每个变量的路径通常相对于应用程序或工具的安全上下文。

为了获得最佳性能，建议 Exchange 所使用的 TEMP 和 TMP 文件夹不要在包含操作系统的磁盘上。此外，应当确保将这些环境变量设置为快速磁盘或磁盘子系统（例如 RAID 0+1 心轴组）上的路径。还建议您不要将 Exchange 或 EVS 所使用的 TEMP 和 TMP 文件夹设置在包含操作系统的磁盘上。

解决此警告问题

  1. 作为群集服务帐户登录到群集中的节点。

  2. 用鼠标右键单击"我的电脑"，然后选择"属性"。

  3. 选择"高级"。

  4. 单击"环境变量"。

  5. 在"<account name> 的用户变量"区域中，选择 TEMP 并单击"编辑"。

  6. 在"变量值"字段中，输入 TEMP 环境变量的新路径，再单击"确定"。

  7. 在"<account name> 的用户变量"区域中，选择 TMP 并单击"编辑"。

  8. 在"变量值"字段中，输入 TMP 环境变量的新路径，再单击"确定"。

  9. 单击"确定"关闭"环境变量"对话框，再次单击"确定"关闭"系统属性"对话框。

  10. 重新启动该节点，以便应用更改。

  11. 对群集中的每个节点重复步骤 1 到 10。

有关在非群集 Exchange Server 计算机上更改 TEMP/TMP 环境变量的信息，请参阅TEMP/TMP 变量可能指向无效或不合适的文件夹。


找不到专用群集检测信号
Microsoft Exchange Server 分析工具 - 文章 > Exchange 群集 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Exchange 服务器群集中每个网络接口资源的已定义角色：

HKEY_LOCAL_MACHINE\Cluster\Networks\<NetworkInterfaceGUID>\Role

值为 1 表示网络资源已配置为专用的私有（检测信号）网络。值为 2 表示网络资源已配置为专用的公用网络（客户端访问）。值为 3 表示网络资源已配置为既允许检测信号通信又允许客户端访问通信的混合网络。

Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定群集服务 (ClusSvc) 的 Started 项的值。值为 True 意味着群集服务已启动，值为 False 意味着群集服务未运行。

如果 Exchange Server 分析工具找不到 Exchange 群集中被配置为专用私有网络的网络资源，则显示警告。

配置专用的私有网络以便用于群集检测信号是对所有 Exchange Server 群集的最佳推荐做法。节点之间的通信对于群集的正常工作至关重要。必须确保用于群集通信的网络被配置到最佳状态，并满足所有硬件兼容列表要求。对于网络配置，必须用两个或更多个独立的网络来连接群集的节点，以避免发生单点故障。典型做法是使用两个局域网。Microsoft 产品支持服务不支持只用一个网络连接节点的群集配置。

解决此警告问题

  1. 如果 Exchange 群集中的每个节点上还没有网络接口卡，请添加网络接口卡，并在群集管理器中将网络接口卡配置为私有网络。

  2. 如果有其他网卡但用于混合网络，则应当通过重新配置合适的网络，使其充当专用的私有网络，来修改该配置。

有关群集检测信号网络的详细信息，请参阅下列 Microsoft 知识库文章：

  • 258750"建议在群集服务器上使用的专用'检测信号'配置"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)

  • 307962"Multicast Support Enabled for the Cluster Heartbeat"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307962)

有关详细信息，请查阅文档"Exchange Server 2003 Cluster Configuration Checklist"（英文）(http://go.microsoft.com/fwlink/?linkid=36083)。


cluster.log 的默认文件大小应增大到 32
Microsoft Exchange Server 分析工具 - 文章 > Exchange 群集 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已设置 ClusterLogSize 参数：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment\

如果 Exchange Server 分析工具发现 ClusterLogSize 值不存在，或 ClusterLogSize 的值小于或等于 8，则会显示警告。在繁忙的群集上，cluster.log 文件的换行速度很快，如果您在下列情况下对故障转移状况进行故障排除，条目可能会丢失：

  • 排除故障需要详细复查群集日志文件。

  • 群集管理着许多资源。

因此，如果排除故障需要使用 cluster.log 文件，请创建参数 ClusterLogSize（如果不存在），并将其默认大小至少增加到 32、64 或 96。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
创建参数 ClusterLogSize 并设置其值。

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedit32.exe。

  2. 导航到： HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment.

  3. 在左侧窗格中，单击"环境"。

  4. 在"编辑"菜单上，指向"新建"，然后单击"DWORD 值"。

  5. 键入 ClusterLogSize，再按 ENTER 键为新的注册表项命名。

  6. 用鼠标右键单击 ClusterLogSize，再单击"修改"。

  7. 将 ClusterLogSize 数值数据修改为新的日志文件大小。例如，将 ClusterLogSize 值修改为 32、64 或 96，再按 ENTER 键。

  8. 退出注册表编辑器
修改 cluster.log 文件的默认大小

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment.

  3. 用鼠标右键单击 ClusterLogSize，再单击"修改"。

  4. 将 ClusterLogSize 数值数据修改为新的日志文件大小。例如，将 ClusterLogSize 值修改为 32、64 或 96，再按 ENTER 键。

  5. 退出注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Microsoft 群集服务器中群集日志记录的详细信息，请参阅 Microsoft 知识库文章 168801"How to Turn on Cluster Logging in Microsoft Cluster Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=168801)


为 SMTP 启用 Kerberos 身份验证
Microsoft Exchange Server 分析工具 - 文章 > Exchange 群集 >

主题上次修改时间： 2006-05-12

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Windows™ Server 2003 群集服务上安装的 Microsoft Exchange Server 2003 服务器是否使用服务器的完全限定域名 (FQDN) 作为 servicePrincipalName 属性的"SMTPSVC"资源的值。

如果 Exchange Server 分析工具发现群集服务上的"SMTPSVC"Exchange 资源的 servicePrincipalName 属性没有包含该服务器的 FQDN 作为值，则 Exchange Server 分析工具将显示最佳实践消息。

最好为运行 Exchange Server 2003 的 Windows Server 2003 群集服务上的简单邮件传输协议 (SMTP) 服务启用 Kerberos 身份验证。可以通过手动为"SMTPSVC"Exchange 资源设置新的服务主体名称 (SPN) 值来启用 Kerberos 身份验证。

默认情况下，Windows Server 2003 使用 NTLM 身份验证。Kerberos 协议比 NTLM 更为灵活和高效，也更加安全。使用 Kerberos 身份验证的优势如下所示：

  • 更快速的连接。使用 NTLM 身份验证，应用程序服务器必须连接到域控制器，以便验证每个客户端的身份。使用 Kerberos 身份验证，服务器不必定位到域控制器。服务器可以通过检查客户端出示的凭据来验证客户端的身份。客户端在获得一次特定服务器的凭据后，即可在整个网络登录会话期间重复使用这些凭据。

  • 相互的身份验证。NTLM 使服务器可以验证客户端的身份。但 NTLM 无法使客户端验证服务器的身份，或者使服务器之间相互验证身份。NTLM 身份验证旨在用于服务器假定为真的网络环境。Kerberos 协议不进行此假设。网络连接两端的每一方可知道另一方所宣称的身份。

  • 委派的身份验证。Windows 服务在代表客户端访问资源时将模拟客户端。通常，服务通过访问本地计算机上的资源为客户端完成工作。NTLM 和 Kerberos 都可以提供服务在本地模拟客户端所必需的信息。但是，一些分布式应用程序设计为当前端服务连接其他计算机上的后端服务时，必须模拟客户端。Kerberos 协议有一个代理机制，可以使服务在连接其他服务时模拟客户端。NTLM 不提供效果类似的功能。

若要解决此问题，请执行下列步骤为受影响的属性添加缺少的值。

使用 SETSPN.exe 工具添加带有缺少的值的 SPN

  1. 安装 Setspn.exe 工具。若要获得 Setspn.exe 工具，请参阅"Windows 2000 Resource Kit Tool : Setspn.exe"（英文）(http://go.microsoft.com/fwlink/?LinkId=28103)。

    Windows Server 2003 版本的 Setspn.exe 命令行工具可以在 Windows Server 2003 CD 所包括的 Windows Server 2003 支持工具中找到。若要安装 Server 2003 支持工具，请双击 Support/Tools 文件夹中的 Suptools.msi 文件。

  2. 按照 SETSPN.EXE"Setspn_d.txt"文件中的指导向 Exchange 服务器的 Active Directory 对象添加缺少的值。以下示例说明为虚拟 SMTP 服务器 SPN 添加 FQDN 值的过程：

    • 启动命令提示符，然后更改为安装 Setspn.exe 的目录。

    • 在命令提示符处，输入以下命令：

      setspn.exe-a SMTPSVC/ mail.yourdomain.com YOURSERVERNAME

      注意：
      使用您的 SMTP 虚拟服务器 FQDN 替换 mail.yourdomain.com，并使用 Exchange 服务器的名称替换 YOURSERVERNAME。
    • 然后按 Enter。


无法与 Exchange 群集节点联系
Microsoft Exchange Server 分析工具 - 文章 > Exchange 群集 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定群集服务 (ClusSvc) 的 Started 关键字的值。值为 True 意味着群集服务已启动，值为 False 意味着群集服务未运行。

Exchange Server 分析工具还读取以下注册表项，以确定运行于 Exchange Server 计算机上的 Windows 的版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 的值为 4.0 说明计算机正在运行 Microsoft Windows NT® Server 4.0。值为 5.0 说明计算机正在运行 Windows 2000 Server，值为 5.2 说明计算机正在运行 Windows Server™ 2003。

如果 Exchange Server 分析工具无法确定群集中运行的 Windows 的版本，或者如果 Exchange Server 分析工具无法确定群集服务是否在运行，则会显示错误。此错误表明 Exchange Server 分析工具无法与 Exchange Server 群集中的某个节点联系。

更正此错误

  1. 确保 Exchange Server 计算机已启动并连接到网络。

  2. 使用 ping 命令确定是否可以访问 Exchange Server 计算机。

  3. 如果有防火墙，请检查以确定远程过程调用 (RPC) 端口是否被阻止。

  4. 确保在 Exchange Server 计算机上已启动 Remote Registry 服务。

  5. 检查运行 Exchange Server 分析工具的帐户的权限，以确保该帐户有足够的权限读取 Exchange Server 计算机上的注册表。

有关解决网络连接问题的详细信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"(http://support.microsoft.com/kb/325487/zh-cn)。


Active Directory 中的 Exchange 数据路径与群集注册表不匹配
Microsoft Exchange Server 分析工具 - 文章 > Exchange 群集 >

主题上次修改时间： 2006-04-28

Microsoft® Exchange Server 分析工具查询群集注册表 (HKEY_LOCAL_MACHINE\Cluster) 和 Active Directory® 目录服务，以确定 Exchange 数据文件（例如，邮件跟踪日志文件）的路径在这两个位置中是否相同。使用 Exchange 安装程序在 Microsoft Windows® 群集中的节点上安装 Exchange 时，Exchange Server 将在注册表和 Active Directory 中配置这些值。

由 Exchange 安装程序创建并由 Exchange Server 分析工具读取的注册表值是：

HKLM\Cluster\Resources\<Resource GUID of Information Store resource>\Parameters\DestPath

由 Exchange 安装程序创建并由 Exchange Server 分析工具读取的 Active Directory 值是：msExchDataPath.该值是 Active Directory 中的 Exchange Server 计算机对象的属性，它位于：

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN= OrganizationName =Administrative Groups, CN= AdministrativeGroupName , CN=Servers, CN= ServerName

如果 Exchange Server 分析工具发现 DestPath 和 msExchDataPath 的值不匹配，则显示错误。

这些值不同的常见原因是，在 Exchange 已经进入生产状态之后，某些或所有 Exchange 数据文件的位置发生了变化。例如，如果升级了硬件、移动了邮件跟踪日志文件、更改了驱动器号，则更改将反映到群集注册表中，但不会反映到 Active Directory 中。进行这样的更改之后，尤其在应用 Exchange Service Pack 或安装更新汇总包以后，可能导致服务启动错误、数据库装入问题和其他问题。

注意：
应当尽快解决这种不一致。在该问题得到纠正之前，不要安装用于 Exchange Server 的任何 Service Pack 或更新。

若要执行以下过程，将需要使用 Active Directory 服务接口 (ADSI) Edit 或 LDP (ldp.exe) 工具等 Active Directory 编辑器。

警告：
在使用 ADSI Edit、LDP 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

更正此错误

  1. 修改受影响的 Exchange 虚拟服务器 (EVS) 的 msExchDataPath 的值，使它与群集注册表中 DestPath 的值匹配。可在下列位置中找到 msExchDataPath 属性：CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName=Administrative Groups, CN=AdministrativeGroupName, CN=Servers, CN=ServerName

  2. 重新启动虚拟服务器的 Exchange System Attendant 资源，以使更改生效。

有关使用 LDP 工具修改 Active Directory 的详细信息，请参阅 Microsoft 知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=260745)。

有关如何使用 ADSI Edit 修改 msExchDataPath 属性的详细信息，请参阅知识库文章 288362"XADM:"The System Cannot Find the Path Specified"Event ID 5007 Message is Logged by the Microsoft Exchange System Attendant"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=288362)。


事件日志复制已启用
Microsoft Exchange Server 分析工具 - 文章 > Exchange 群集 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具在每台属于群集节点的服务器上读取以下注册表项：

HKEY_LOCAL_MACHINE\Cluster\Nodes\X\EnableEventLogReplication

注意：
X 是节点的编号，从 1 开始。

如果 Exchange Server 分析工具发现 EnableEventLogReplication 的值为 1，则 Exchange Server 分析工具将显示最佳实践消息。

如果 EnableEventLogReplication 注册表项设置为 1，群集节点会将事件日志中的事件复制到群集中的所有其他节点。如果事件日志复制已启用，监视多台服务器的工具（例如 Microsoft Operations Manager，MOM）将多次报告单个事件，每个节点一次。如果使用自动监视，建议在群集节点上禁用事件日志复制。

在群集的所有节点上禁用事件日志复制

  1. 使用域用户帐户或全局组成员的帐户登录到群集的任意节点。

  2. 单击"开始"，再单击"运行"，然后键入

    cluster /prop EnableEventLogReplication=0
在单个群集节点上禁用事件日志复制

  1. 使用域用户帐户或全局组成员的帐户登录到群集的任意节点。

  2. 单击"开始"，再单击"运行"，然后键入

    Cluster <要禁用的节点名称> /prop EnableEventLogReplication=0

有关如何配置事件日志复制的详细信息，请参阅 Microsoft 知识库文章 224969"HOW TO:Configure Event Log Replication in Windows 2000 Cluster Servers"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224969)。

有关管理服务器群集的详细信息，请参阅"Administering Server Clusters"（英文）(http://go.microsoft.com/fwlink/?LinkId=45971)。


对网络名称资源禁用 Kerberos
Microsoft Exchange Server 分析工具 - 文章 > Exchange 群集 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定运行于服务器上的 Microsoft Windows® 操作系统的版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 的值为 4.0 说明计算机正在运行 Windows NT® Server 4.0。值为 5.0 说明计算机正在运行 Windows 2000 Server 操作系统，值为 5.2 说明计算机正在运行 Windows Server™ 2003 操作系统。

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定具有对象类 msExchExchangeServer 的所有对象的 serialNumber 属性值。如果字符串值包含"Version 5.5"，说明计算机运行的是 Exchange Server 5.5。如果字符串值包含"Version 6.0"，说明计算机运行的是 Exchange 2000 Server。如果字符串值包含"Version 6.5"，说明计算机运行的是 Exchange Server 2003。

最后，Exchange Server 分析工具读取以下注册表值，以确定 Exchange Server 是否正运行在一个包含启用了 Kerberos 的网络名称群集资源的群集中：

HKLM\Cluster\Resources\<Resource GUID for Network Name resource>\Parameters\RequireKerberos

RequireKerberos 的值为 0 说明网络名称资源没有启用 Kerberos，值为 1 说明网络名称资源启用了 Kerberos。

如果 Exchange Server 分析工具发现，在运行于基于 Windows Server 2003 服务器的群集中的 Exchange Server 2003 虚拟服务器上 RequireKerberos 的值设置为 0，则会显示警告。

该警告说明 Exchange Server 2003 虚拟服务器没有使用启用了 Kerberos 的网络名称群集资源。这不是受支持的配置，应尽快纠正。

解决此警告问题

  1. 打开群集管理器程序。

  2. 使网络名称资源脱机。这还将使依赖网络名称资源的所有资源（包括 Microsoft Exchange System Attendant 资源）脱机。

  3. 用鼠标右键单击网络名称资源，再单击"属性"。

  4. 在"参数"选项卡上，单击"启用 Kerberos 身份验证"选项，再单击"确定"。

  5. 使网络名称资源联机，再让其余脱机资源联机。

有关使用 Windows Server 2003 群集上启用了 Kerberos 的网络名称资源的详细信息，请参阅 Microsoft 知识库文章 302389"Description of the Properties of the Cluster Network Name Resource in Windows Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=302389)。

有关群集的详细信息，请参阅下列主题：

  • "Exchange Server 2003 部署指南"中的"在群集中部署 Exchange Server 2003"(http://www.microsoft.com/downloads/details.aspx?FamilyID=77B6D819-C7B3-42D1-8FBB-FE6339FFA1ED&DisplayLang=zh-cn)

  • "Exchange Server 2003 High Availability Guide"（英文）中的"规划 Exchange 群集"(http://www.microsoft.com/downloads/details.aspx?FamilyID=fe6a573c-11ff-4cb6-be2e-9b6f2164c54a&DisplayLang=zh-cn)


在网络名资源上启用了 Kerberos
Microsoft Exchange Server 分析工具 - 文章 > Exchange 群集 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定运行于服务器上的 Microsoft Windows® 操作系统的版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 的值为 4.0 说明计算机正在运行 Windows NT® Server 4.0。值为 5.0 说明计算机正在运行 Windows 2000 Server 操作系统，值为 5.2 说明计算机正在运行 Windows Server™ 2003 操作系统。

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定具有对象类 msExchExchangeServer 的所有对象的 serialNumber 属性值。如果字符串值包含"Version 5.5"，说明计算机运行的是 Exchange Server 5.5。如果字符串值包含"Version 6.0"，说明计算机运行的是 Exchange 2000 Server。如果字符串值包含"Version 6.5"，说明计算机运行的是 Exchange Server 2003。

最后，Exchange Server 分析工具读取以下注册表值，以确定 Exchange 是否运行在具有启用了 Kerberos 的网络名群集资源的群集中：

HKLM\Cluster\Resources\<Resource GUID for Network Name resource>\Parameters\RequireKerberos

RequireKerberos 的值为 0 说明网络名称资源没有启用 Kerberos，值为 1 说明网络名称资源启用了 Kerberos。

如果 Exchange Server 分析工具发现运行在基于 Windows 2000 Server 服务器的群集中的 Exchange 2000 Server 虚拟服务器上的 RequireKerberos 值设置为 1，将显示警告。

此警告意味着启用了 Kerberos 的网络名群集资源用于 Exchange 2000 Server 虚拟服务器。这是不支持的配置，应尽快更正。Microsoft 知识库文章 235529"Kerberos support on Windows 2000-based server clusters"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=235529)指出，Exchange 2000 Server 网络名资源不支持 Kerberos 身份验证。未对 Exchange 2000 Server 进行这方面的测试，无法确保群集 Exchange 2000 Server 虚拟服务器支持 Kerberos 身份验证。

解决此警告问题

  1. 在群集中的任意节点上打开命令提示符。

  2. 运行下列命令：cluster res "Name of Network Name Resource" /priv requirekerberos=0:dword

    注意：
    资源名两侧应加上引号。

  3. 使网络名资源脱机并将其删除。

  4. 打开"Active Directory 用户和计算机"。

  5. 找到已删除的网络名资源的计算机帐户对象并将其从 Active Directory 中删除。

  6. 为此 Exchange 虚拟服务器 (EVS) 创建一个新的网络名资源，并且不对它启用 Kerberos。可以使用与在步骤 3 中删除的网络名资源相同的名称和配置。

  7. 将新的网络资源名联机，然后将 EVS 中的其余资源联机。

有关在 Windows 2000 Server 群集中使用启用了 Kerberos 的网络名资源的详细信息，请参阅 Microsoft 知识库文章 235529"Kerberos support on Windows 2000-based server clusters"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=235529)。


群集中的 MSDTC 可能已丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange 群集 >

主题上次修改时间： 2006-04-20

Microsoft® Exchange Server 分析工具通过读取以下注册表项来确定群集中是否存在 Microsoft 分布式事务协调器 (MSDTC) 资源：

HKEY_LOCAL_MACHINE\Cluster\Resources\

如果 ClusterMSDTCInstance 的值为 0，Exchange Server 分析工具将显示警告。

MSDTC 资源必须存在于 Exchange Server 群集中，以支持初始化安装和 Service Pack 升级。然而，在 Exchange 运行时，它不是关键组件，甚至不是必需的。

因为您或组织中的其他管理员知道在 Exchange 运行时 MSDTC 资源不是必需的，所以可能已经将其删除。

但是，我们建议，在完成 Exchange Server 2003 的初始安装后，不要删除 MSDTC 资源。只有在群集中保留 MSDTC 资源，才能运行 Service Pack 安装和其他更新。

若要解决此警告问题，请创建新的 MSDTC 资源。有关如何创建 MSDTC 资源的具体步骤，请参阅"Exchange Server 2003 部署指南" (http://go.microsoft.com/fwlink/?LinkId=47569) 中"Deploying Exchange Server 2003 in a Cluster"中的"How to Install the Microsoft Distributed Transaction Coordinator in a Windows Server 2003 Server Cluster"（英文）。

详细信息

有关 MSDTC 和 Exchange 的详细信息，请参阅 Exchange Server 2003 High Availability Guide (http://go.microsoft.com/fwlink/?LinkId=47571)中"Understanding Exchange Server 2003 Clustering"中的"Cluster Groups"（英文）。

有关如何在 Microsoft Windows Server™ 2003 中添加 MSDTC 资源的详细信息，请参阅 Microsoft 知识库文章 301600"如何在 Windows Server 2003 群集上配置 Microsoft 分布式事务处理协调器"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=301600)。

注意：
知识库文章 301600 中包含文章 817064"如何在 Windows Server 2003 中启用网络 DTC 访问"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=817064) 的链接。为了 Exchange Server 的安全，最好不要对 Exchange 群集启用网络 DTC 访问。为 Exchange 群集配置分布式事务协调器资源时，请不要启用网络 DTC 访问。


MSDTC 中断将影响群集组
Microsoft Exchange Server 分析工具 - 文章 > Exchange 群集 >

主题上次修改时间： 2006-03-16

Microsoft® Exchange Server 分析工具通过读取以下注册表项来确定 Microsoft 分布式事务协调器 (MSDTC) 资源配置故障是否影响群集组：

HKEY_LOCAL_MACHINE\Cluster\Resources\

如果 ClusterMSDTCInstance 的值为 2，Exchange Server 分析工具将显示警告。

MSDTC 资源必须存在于 Exchange 群集中，以支持初始化安装和 Service Pack 升级。但是，在 Exchange 运行时，它不是必需的。

默认情况下，MSDTC 资源故障会影响群集组。以下是两个资源故障示例：

  • 日志文件大小超出磁盘容量。

  • MSDTC 资源所在的物理磁盘损坏。

具体地说，MSDTC 资源故障将导致运行在该群集节点上的所有 Exchange 服务故障转移到群集中的另一个节点。但是，因为 MSDTC 资源不是必需资源，所以可以将它配置为不影响群集组。

若要解决此警告问题，请配置 Exchange 群集，使 MSDTC 资源故障不影响群集组。

配置 Exchange，使 MSDTC 资源故障不影响群集组

  1. 登录到群集的任一节点。

  2. 单击"开始"，指向"所有程序"，再指向"管理工具"，然后单击"群集管理器"。

  3. 用鼠标右键单击"组"下面包含 MSDTC 资源的群集组。

  4. 用鼠标右键单击 MSDTC 资源，然后单击"属性"。

  5. 清除"高级"选项卡中的"影响组"复选框，然后单击"确定"。

详细信息

有关如何创建 MSDTC 资源的具体步骤，请参阅"Exchange Server 2003 部署指南" (http://go.microsoft.com/fwlink/?LinkId=47569) 中"Deploying Exchange Server 2003 in a Cluster"中的"How to Install the Microsoft Distributed Transaction Coordinator in a Windows Server 2003 Server Cluster"（英文）。

有关 MSDTC 和 Exchange 的详细信息，请参阅 Exchange Server 2003 High Availability Guide(http://go.microsoft.com/fwlink/?LinkId=47571)中"Understanding Exchange Server 2003 Clustering"中的"Cluster Groups"（英文）。

有关如何在 Microsoft Windows Server™ 2003 中添加 MSDTC 资源的详细信息，请参阅 Microsoft 知识库文章 301600"如何在 Windows Server 2003 群集上配置 Microsoft 分布式事务处理协调器"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=301600)。

注意：
知识库文章 301600 中包含文章 817064"如何在 Windows Server 2003 中启用网络 DTC 访问"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=817064) 的链接。为了 Exchange Server 的安全，最好不要对 Exchange 群集启用网络 DTC 访问。为 Exchange 群集配置分布式事务协调器资源时，请不要启用网络 DTC 访问。


MTA 中断将影响群集组
Microsoft Exchange Server 分析工具 - 文章 > Exchange 群集 >

主题上次修改时间： 2006-03-16

Microsoft® Exchange Server 分析工具检查 Exchange 服务器系统的 Cluster\Resources 注册表设置。

HKEY_LOCAL_MACHINE\Cluster\Resources

如果 Exchange Server 分析工具发现 Message Transfer Agent (MTA) Stacks 服务资源在纯模式组织中的 Exchange Server 2003 群集上运行，Exchange Server 分析工具将显示一条最佳实践消息。

作为最佳实践，建议 Exchange 管理员配置 MTA 资源，以免在 MTA 停止运行或发生故障时导致 Exchange 虚拟服务器发生故障转移。

注意：
Microsoft Exchange 2000 Server 和 Microsoft Exchange Server 2003 中的 MTA Stacks 服务通常用于在混合模式环境中提供 Exchange 2000 Server 或 Exchange Server 2003 服务器与 Microsoft Exchange Server 5.5 服务器之间的向后兼容邮件传输服务。如果转换是在纯 Exchange 2000 Server 或 Exchange Server 2003 纯模式环境中执行的，MTA 就不是运行 Exchange 服务的关键资源。

如果 MTA Stacks 服务停止运行或发生故障，则可能会导致 Exchange 虚拟服务器发生故障转移。若要防止可能发生的 Exchange 虚拟服务器 (EVS) 故障转移，则建议的最佳实践是通过执行以下操作来配置 MTA Stacks 服务以避免发生故障转移。

在 Exchange 服务器群集中将 MTA Stacks 服务配置为不受影响的状态

  1. 打开 Cluster Administrator

  2. 清除 MTA Stack 服务资源的 Affect this Group 选项。

详细信息

有关 Exchange Server 2003 对 MTA Stacks 服务的支持指南，请参阅 Microsoft 知识库文章 810489"MTA Stacks service supportability guidelines for Exchange 2000 Server and Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=810489)。

有关 Exchange Server 2003 体系结构中 MTA 的详细信息，请参阅"Exchange MTA in Exchange Server 2003 Architecture"（英文）(http://go.microsoft.com/fwlink/?LinkId=63496)。

有关如何在群集中部署 Exchange Server 2003 的信息，请参阅"Deploying Exchange Server 2003 in a Cluster"（英文）(http://go.microsoft.com/fwlink/?LinkId=63495)。

有关如何使用群集管理员的信息，请参阅"Using Cluster Administrator to Manage Exchange Clusters"（英文）(http://go.microsoft.com/fwlink/?LinkId=63493)。


这是一个 2 节点的主动/主动群集
Microsoft Exchange Server 分析工具 - 文章 > Exchange 群集 >

主题上次修改时间： 2006-04-28

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 ClusSvc（群集服务）的 Started 关键字的值。值为 True 说明群集服务正在运行，值为 False 说明未运行该服务。

Exchange Server 分析工具还读取以下注册表项，以确定群集中的节点数：

HKEY_LOCAL_MACHINE\Cluster\Nodes\ <Node Number> \NodeName

NodeName 的实例数代表群集中的节点数。此外，Exchange Server 分析工具还读取以下注册表项，以确定群集中的 Exchange Server 资源的数目：

HKLM\Cluster\Resources\ <Cluster Resource GUID> \Parameters\DestPath

Exchange Server 群集上的下列资源将有 DestPath 值：

  • Microsoft Exchange 邮件传输代理

  • Microsoft Exchange Information Store

DestPath 的实例数表示群集中运行 Exchange 虚拟服务器 (EVS) 的服务器数目。

如果 Exchange Server 分析工具确定某个群集有 2 个 NodeName 实例，而该群集中存在 3 个 DestPath 实例，则会显示警告。此警告意味着这是一个具有两个运行 EVS 的服务器的两节点群集（称为主动/主动群集）。

  • 在主动/主动群集模型中，群集中的 Exchange 虚拟服务器的数目等于或大于群集中的物理节点的数目。

注意：
只能在由两个节点组成的群集中创建主动/主动 Exchange 群集。如果群集中有三个或三个以上的节点，则必须使用主动/被动模型。
  • 在主动/被动群集模型中，群集中的 Exchange 虚拟服务器的数目小于群集中的物理节点的数目。

尽管 Microsoft 支持 Exchange Server 的主动/主动群集，但强烈建议对 Exchange 群集使用主动/被动实现。Microsoft 仅支持遵循下列伸缩限制的主动/主动 Exchange 群集：

  • 每个物理节点的每个 Exchange 虚拟服务器的并发用户连接的数目永远也不应大于 1,900。如果群集中的某个节点不可用，并且所有 Exchange 虚拟服务器都在单个节点上联机，伸缩限制将保持在两个 Exchange 虚拟服务器 3,800 个连接。由于每个用户都可能建立多个连接，因此无法通过邮箱数准确地估计出连接数。

  • 每个 Exchange 存储进程的平均 CPU 使用率都不应超过 40%。如果一个节点上的 STORE.EXE 进程的总 CPU 使用率在连续 10 分钟或更长的时间内超过 40%，必须将用户移至另一个 Exchange 虚拟服务器或 Exchange 服务器上。注意，此负载不包括管理任务所消耗的 CPU 使用率。

要从主动/主动群集配置迁移到主动/被动配置，需要将第二个 EVS 上的资源移到别处，然后停止使用该虚拟服务器。

从主动/主动群集迁移到主动/被动群集

  1. 将第二个 EVS 上驻留的邮箱移动到群集中的第一个 EVS。群集中的第一个 EVS 始终仅包含群集中的 Microsoft Exchange 邮件传输代理 (MTA) 资源。

  2. 将所有邮箱移动到第一个 EVS 之后，使第二个 EVS 脱机。

  3. 通过执行下列操作之一删除第二个 EVS：

    • 在 Exchange Server 2003 群集上，用鼠标右键单击"Microsoft Exchange System Attendant"资源，并单击"删除 Exchange 虚拟服务器"。

    • 在 Exchange 2000 Server 群集上，用鼠标右键单击"Microsoft Exchange System Attendant"资源，并单击"删除"。

  4. 验证 EVS 对象已从 Active Directory® 目录服务中删除。由于 Exchange Server 2003 中群集服务帐户权限的更改，您的帐户必须有删除 Active Directory 对象的权限。

  5. 使第二个 EVS（例如，物理磁盘、网络名和 IP 地址）中的剩余资源脱机，然后再删除它们。

  6. 删除第二个 EVS 中包含的资源组。

有关如何删除 EVS 的详细信息，请参阅"Deploying Microsoft Exchange 2000 Server Clusters Exchange"（英文）中的"Removing an Exchange virtual server from a Cluster"（英文）部分 (http://go.microsoft.com/fwlink/?LinkId=9393)。

有关 Exchange 群集的最佳实践及建议的详细信息，请参阅"Exchange Server 2003 部署指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=77B6D819-C7B3-42D1-8FBB-FE6339FFA1ED&DisplayLang=zh-cn)。

有关在 Windows 服务器群集中部署 Exchange 的详细信息，请参阅 Microsoft 知识库文章 815180"在主动/主动群集上部署 Exchange 2000 时的注意事项"(http://support.microsoft.com/kb/815180/zh-cn)。


仲裁日志过小
Microsoft Exchange Server 分析工具 - 文章 > Exchange 群集 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定为群集配置的仲裁日志大小：

HKEY_LOCAL_MACHINE\Cluster\Quorum\MaxQuorumLogSize

如果 Exchange Server 分析工具发现 MaxQuorumLogSize 的值小于 4194304（十进制）或 0x400000（十六进制），则会显示警告。

MaxQuorumLogSize 注册表值代表当前为"将仲裁日志重设在"群集仲裁参数配置的值。如果 MaxQuorumLogSize 小于 4096 KB，将产生此警告。

群集将群集数据库的所有更改记录在仲裁日志文件中。当仲裁日志达到了指定的大小时，群集将保存数据库并重置日志文件。在基于 Microsoft Windows® 2000 Server 的群集上，默认仲裁大小限制为 64 KB。在基于 Windows Server™ 2003 的群集上，默认仲裁大小限制为 4096 KB。对于 Exchange Server 群集，建议将"将仲裁日志重设在"属性配置为 4096 KB。这样可确保将有足够的空间来存放群集配置信息，例如，群集包含哪些服务器、群集中安装了哪些资源，以及这些资源分别处于什么状态（例如，联机或脱机）。

解决此警告问题

  1. 打开群集管理器。

  2. 在左侧窗格中，用鼠标右键单击代表群集的对象，再单击"属性"。

  3. 在"仲裁"选项卡上，将"将仲裁日志重设在"的值配置为 4096。

  4. 单击"确定"保存更改。

有关默认仲裁日志大小限制的详细信息，请参阅 Microsoft 知识库文章 225081"Cluster Resources Quorum Log Size Defaults to 64 KB"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=225081)。


Exchange Server
Microsoft Exchange Server 分析工具 - 文章 >

主题上次修改时间： 2005-11-18

此部分中的文章提供了有关 Microsoft® Exchange Server 分析工具就 Exchange Server 计算机进行评估的详细信息。此外，这些文章还描述了为解决 Exchange Server 分析工具发现的与 Exchange 有关的错误、警告和非默认配置所能采取的措施。


帐户锁定已安装
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-08-28

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange 服务器上的 System32 文件夹中是否存在名为 ALockout.dll 的文件。ALockout.dll 是帐户锁定和管理工具 (ALTools.exe) 的一部分。这些工具可帮助管理员管理帐户，并查找和排除与帐户锁定有关的问题。

如果 Exchange Server 分析工具发现 Exchange 服务器上存在 ALockout.dll，则会显示错误。

帐户锁定和管理工具不应在驻留网络应用程序或服务的服务器（包括 Exchange 服务器）上使用。如果 Exchange 服务器上安装有帐户锁定和管理工具，则这些工具会阻止 Exchange 服务的启动。因此，极力建议您从该 Exchange 服务器上卸载帐户锁定和管理工具。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
更正此错误

  1. 在命令提示符处，键入 regsvr32 /u alockout.dll。

  2. 删除以下注册表项下的 ALockout.dll 值：HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Windows\AppInit_DLLs
注意：
删除 ALockout.dll 值之后，AppInit_DLLs 注册表项为空。重新启动计算机。
  1. 从 System32 文件夹中删除 ALockout.dll 文件。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关帐户锁定和管理工具的详细信息，请参阅"帐户密码与策略"中的"帐户锁定工具"(http://go.microsoft.com/fwlink/?LinkId=52465)。


Active Directory 站点不匹配
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-03-16

Microsoft® Exchange Server 分析工具实现了 Win32 API DsGetSiteName 功能，可查询域控制器的 Active Directory® 目录服务站点名和本地 Exchange Server 的 Active Directory 站点名。

如果 Exchange Server 分析工具确定域控制器的 Active Directory 站点名和本地 Exchange Server 的 Active Directory 站点名不匹配，则会显示警告。

此警告说明目录服务访问 (DSAccess) 进程将由于其轻型目录访问协议 (LDAP) 请求离开本地 Active Directory 站点，这些请求可能严重降低 Exchange Server 的性能。

这种情况可能由如下原因导致：离站域控制器的静态配置、网络或域控制器计算机中断使得无法访问域控制器所驻留的域，或者是因为 Active Directory 拓扑的设计不正确，使 Exchange Server 所在的站点中不包含 Active Directory 域控制器。

DSAccess 是共享的 Exchange Server 组件，用于访问和存储缓存中的目录信息。DSAccess 基于 Active Directory 站点配置和 Active Directory 服务器可用性之类的标准，动态地检测其他 Exchange 组件应联系的目录服务器。Exchange 前端服务器使用 DSAccess 确定包含特定用户邮箱的服务器、某个用户对象的简单邮件传输协议 (SMTP) 地址以及包含公用文件夹存储的服务器。

初始化时，如果 DSAccess 在注册表中找不到一组静态配置的域控制器或全局编录，DSAccess 将使用探查进程识别网络拓扑并评估目录服务器的可用性和适用性。确定域控制器适用性的一部分因素是域控制器是否与 Exchange Server 位于同一个 Active Directory 站点。

若要降低跨站点 LDAP 请求可能导致的延迟，Exchange Server 应该位于拥有驻留域控制器的 Active Directory 站点。

解决此问题：

  • 评估 Active Directory 拓扑的站点定义，以验证每个 Exchange Server 是否拥有访问相同 Active Directory 站点中某个域控制器的权限。

  • 验证所有静态配置的域控制器是否都位于 Exchange Server 所在的同一个 Active Directory 站点。

详细信息

有关如何配置 DSAccess 和解决 DSAccess 问题的详细信息，请参阅以下 Exchange 资源：

  • Directory Integration and Exchange Server（英文）(http://go.microsoft.com/fwlink/?LinkId=63447)

  • Understanding and Troubleshooting Directory Access（英文）(http://go.microsoft.com/fwlink/?LinkId=39012)

  • Microsoft 知识库文章 250570"Directory service server detection and DSAccess usage"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)


管理文件共享已禁用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定默认管理共享是否已禁用：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters\AutoShareServer

如果 Exchange Server 分析工具发现 AutoShareServer 的值被设置为 0，则会显示错误。

该错误说明服务器创建的默认管理共享在此服务器上已禁用。如果禁用了默认管理共享，可能无法进行 Exchange Server 的联机备份或还原。在尝试还原数据时可能会出现错误消息，视备份程序而定。在磁带备份日志中可能也会出现错误消息。

此外，如果管理共享已删除，在进行 Exchange Server 联机备份时可能会出现以下消息："意外错误 0xc0040000 Microsoft Exchange Server 计算机不可用"。若要解决此问题，建议编辑注册表并重新启动 Server 服务，以便重新启用默认管理共享。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
更正此错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

  3. 在右侧窗格中，找到并双击 AutoShareServer。

  4. 将值由 0 更改为 1。

  5. 关闭注册表编辑器，并重新启动 Server 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关在 Microsoft Windows Server™ 2003 中还原默认管理共享的详细信息，请参阅知识库文章 816113"HOW TO: Use Registry Editor to Restore Administrative Shares in Windows Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=816113)。


AFD.SYS 驱动程序和 X.400 连接器的互操作性
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Exchange Server 计算机上运行的 Microsoft Windows® 版本。

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 值为 4.0 表示 Exchange Server 计算机运行的是 Microsoft Windows NT® Server 4.0。值为 5.0 表示 Exchange Server 计算机运行的是 Windows 2000 Server，值为 5.2 表示 Exchange Server 计算机运行的是 Windows Server™ 2003。

Exchange Server 分析工具还查询 Win32_ComputerSystem Microsoft Windows Management Instrumentation (WMI) 类，以确定为 NumberOfProcessors 关键字设置的值。该值代表计算机所安装的处理器的数目。这些处理器包括物理处理器和逻辑处理器。使用 Intel 开发的超线程技术，物理处理器可以拆分为两个逻辑处理器。

Exchange Server 分析工具还读取以下注册表项，以确定 Exchange Server 是否是 X.400 连接器的桥头：

HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeMTA

最后，Exchange Server 分析工具查询 CIM_Datafile Windows Management Instrumentation (WMI) 类，以确定 Afd.sys 文件的 Version 关键字的值。

如果以下条件为真，Exchange Server 分析工具将显示警告：

  • Exchange Server 计算机运行的是 Windows Server 2000。

  • NumberOfProcessors 的值大于 1。

  • Exchange Server 是 X.400 连接器的桥头。

  • WINDOWSPATH%\\system32\\drivers\\afd.sys 的 Version 关键字的值处于 5.0.2195.7036 到 5.0.2195.7060 的范围内。

此警告表示服务器上安装的 Afd.sys 版本可能造成此服务器上的 X.400 连接器发生邮件流问题。

要解决此问题，请获取 Microsoft 知识库文章 904712"Mail delivery is slower than expected, or mail delivery stops, on an X.400 connector to a remote site in Exchange Server 5.5"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=904712) 中提到的更新。


数据库的老化计时间隔为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchAgingKeepTime 属性是否已设置。此属性代表用于确定何时删除索引、视图和分类的时间值。如果 Exchange Server 分析工具发现此属性已设置，则会显示非默认配置消息。

由 Exchange 客户端在 Exchange 数据库表中创建的视图所使用的索引如果在给定的时间内尚未使用，这些索引将在此时被清理。msExchAgingKeepTime 属性指定索引被删除之前的最短时间。最初发行版的 Exchange 2000 Server 中的默认值为八天。在 Exchange 2000 Server Service Pack 1 (SP1) 以及所有后续 Exchange Server 版本（包括 Exchange Server 2003 和 Exchange Server 2007）中，默认值为 40 天。

警告：
在使用 ADSI（Active Directory 服务接口）Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。若要解决这些问题，您可能需要重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003/Exchange Server 2007。修改 Active Directory 对象的属性的风险由您自己承担。
查看或修改老化计时值

  1. 启动 ADSI Edit。

  2. 双击 Configuration 容器，展开 CN=Services，展开 CN=Microsoft Exchange，再展开 CN=<ExchangeOrganizationName>。

  3. 展开 CN=Administrative Groups，展开 CN=<AdministrativeGroupName>，再展开 CN=Servers。

  4. Expand CN=<ServerName>, expand CN=InformationStore, and then select CN=<StorageGroupName>.

  5. 在详细信息窗格中，右键单击 CN=<MailboxStoreName>，再单击 Properties。

  6. 在 Attribute Editor 中，单击 msExchAgingKeepTime 属性，再单击 Edit。

  7. 在 Edit Attribute 框中，单击 Clear 清除该值。

  8. 单击 Apply，再单击 OK。

  9. 关闭 ADSI Edit。如果进行了更改，请重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

有关使用 LDP 工具的详细信息，请参阅 Microsoft 知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（XADM：使用 LDP 实用程序来修改 Active Directory 对象属性）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

有关在 Exchange Server 中访问信息存储文件夹时存在的潜在问题的详细信息，请参阅 Microsoft 知识库文章 216076"访问信息存储文件夹的速度可能会变慢"(http://support.microsoft.com/kb/216076/zh-cn)。


Antigen 更新已可用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-06-20

Microsoft Exchange Server 分析工具查询 CIM_Datafile Microsoft® Windows® Management Instrumentation (WMI) 类，以确定 MimeNavigator.dll 的 Version 关键字的值。Microsoft Antigen 版本 8 和 9 附带有此模块。

如果 Exchange 分析工具发现 MimeNavigator.dll 的 Version 关键字值小于 8.00.1517.0（对于版本 8）和 9.00.1055.0（对于版本 9），则 Exchange 分析工具将显示警告。

此警告表明 Microsoft Antigen 版本 8 或 9 已安装在 Exchange 服务器上并且软件更新已可用。强烈建议安装此更新，它可以提高服务器的总体性能和可靠性。

若要解决此问题，请查看 Microsoft 知识库文章 928082 在 Antigen 中进行扫描的过程中 SMTP 邮件的大小可能增加中的建议并应用它们。


应用程序日志大小
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-11-09

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定应用程序日志文件的最大大小：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Eventlog\Application\MaxSize

如果 Exchange Server 分析工具发现 MaxSize 的值小于 41,943,040 字节 (40 MB)，则 Exchange Server 分析工具将显示最佳实践消息。

默认情况下，应用程序日志文件针对 Windows Server 2003 的最大日志大小是 16,777,216 字节 (16384 KB)，针对 Windows 2000 Server 的最大日志大小是 524288 (512 KB)。对于运行 Exchange Server 的计算机，最好将应用程序日志文件的最大大小设置为 40 MB（输入为 40960 KB）或更多。通过增大应用程序日志文件的大小，可以保留更多的应用程序事件。其他事件信息在您进行故障排除时会有帮助。

增大应用程序日志的最大大小

  1. 打开"事件查看器"Microsoft 管理控制台 (MMC) 管理单元。

  2. 右键单击"应用程序"日志，再单击"属性"。

  3. 在"常规"选项卡上的"日志大小"下，在"最大日志大小"框中输入 40960 或更多，然后单击"确定"。


ASP.NET Rootver 已损坏
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定为 ASP.NET 的 Rootver 项设置的值：

HKEY_LOCAL_MACHINE\Software\Microsoft\ASP.NET

如果以下条件为真，Exchange Server 分析工具将显示错误：

  • Exchange Server 分析工具发现 Rootver 值设置为 0.0.0.0。

  • 群集服务正在运行。

有时，ASP.NET 安装程序可能未提供故障通知即失败。在这种情况下，Rootver 项设置为 0.0.0.0。如果将 Rootver 值设置为 0.0.0.0，则会导致无法在 Exchange Server 2003 和 Exchange Server 2007 群集中启动 Microsoft Exchange 系统助理服务或其他 Exchange Server 服务。必须将 Rootver 值设置为以下值之一以更正此错误：

  • Exchange Server 2003 Rootver 项 = 1.1.4322.0。

  • Exchange Server 2007 Rootver 项 = 2.0.50727.0。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
将 Rootver 设置为 1.1.4322.0

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\Software\Microsoft\ASP.NET\

  3. 在详细信息窗格中，双击 RootVer 项。

  4. 在"编辑字符串"对话框中，按照本文前面所述将"值数据"设置为相应的值，然后单击"确定"。

  5. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


自动操作系统调试已禁用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定操作系统调试是否已禁用：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AeDebug\Auto

如果 Exchange Server 分析工具发现 Auto 的值设置为 0，则会显示警告。

默认情况下，名为 Dr. Watson 的应用程序调试程序随同 Microsoft Windows® 2000 Server 和 Microsoft Windows Server™ 2003 操作系统一起安装。调试程序是一种程序，它使程序员可以单步调试程序、检查数据并监视变量的值等条件，从而有助于检测、查找和更正另一个程序中的错误。

默认选项是在 Dr. Watson 第一次由于程序出错或在您的启动下而运行时设置的。

当应用程序出错时，Windows 搜索程序错误处理程序。程序错误处理程序处理程序运行过程中出现的错误。如果 Windows 找不到程序错误处理程序，将确认当前未调试该程序，并认为错误未处理。然后 Windows 通过在注册表中查找程序错误调试程序来处理未处理的错误。

Windows 的行为取决于 HKLM\Software\Microsoft\Windows NT\CurrentVersion\AeDebug 下面的两个注册表值的设置。

这两项的名称分别为 Debugger 和 Auto。Debugger 项的值指定将用来分析程序错误的调试程序的命令。如果找到了 Debugger 项的值，Windows 将查看 Auto 项的值设置为 0 还是 1：

  • 如果 Auto 项的值设置为 0，Windows 将产生一个消息框，通知您程序出错。如果 Debugger 项的值指定了有效调试程序的命令，消息框将显示两个按钮："确定"和"取消"。如果单击"确定"，程序将停止。如果单击"取消"，指定的调试程序将启动。如果 Debugger 项的值为空，消息框将仅仅显示"确定"，并且将不会有任何调试程序启动。

  • 如果 Auto 项的值设置为 1，并且 Debugger 项的值指定了有效调试程序的命令，系统将自动启动调试程序，而不会产生消息框。

安装 Windows 后，Auto 项的值默认设置为 1，Debugger 项的值指定启动 Dr. Watson 的命令 (drwtsn32 -p %ld -e %ld -g)。这意味着当程序出错时，Dr. Watson 将自动诊断错误并记录相应的诊断信息。

建议的最佳实践是在 Exchange Server 计算机上使用程序错误调试程序。如果之前将 Dr. Watson 以外的程序用作默认调试程序，现在希望改用 Dr. Watson，请转至命令提示符处，键入命令 drwtsn32 -i 以启动 Dr. Watson。键入 -i 会导致对注册表进行必要的更改。

从命令提示符处将 Dr. Watson 注册为默认调试程序

  1. 打开命令提示窗口。

  2. 运行下列命令：drwtsn32 -i

  3. 此时将出现消息"已安装 Dr. Watson 作为默认的应用程序调试程序"。单击"确定"确认此消息。

从用户界面中将 Dr. Watson 注册为默认调试程序

  1. 单击"开始"，再单击"运行"，然后键入 drwtsn32，再按 Enter 键。此时出现 Dr. Watson for Windows 用户界面。

  2. 选中"创建故障转储文件"复选框。

  3. 单击"确定"保存更改并关闭 Dr. Watson for Windows 用户界面。

有关 Dr. Watson for Windows 的详细信息，请参阅 Dr. Watson 帮助文件（在 Dr. Watson 用户界面中按 F1 键即可打开该帮助文件）。

如果计划使用 Dr. Watson 以外的程序错误调试程序，可以禁用 Dr. Watson。有关的步骤信息，请参阅 Microsoft 知识库文章 188296"How to Disable Dr. Watson for Windows"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=188296)。


平均 LDAP 读取滞后时间已超过 50 毫秒
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-03-14

Microsoft Exchange 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 MSExchangeDSAccess Process 性能对象的 LDAP Read Time 性能计数器收集数据，以分析性能数据。

LDAP Read Time 性能计数器显示实现轻型目录访问协议 (LDAP) 读取请求所需的时间（毫秒）。Exchange 分析工具在 5 分钟内每 5 秒检索一个示例。然后，Exchange 分析工具在收集间隔期间报告性能计数器的最大值。如果平均值超过 50 毫秒，则 Exchange 分析工具将显示警告。

较长的远程过程调用 (RPC) 延迟和队列的增加可能会导致较长的 LDAP 读取延迟。较长的 LDAP 读取延迟通常表明存在下列问题之一：

  • 到域控制器的网络连接出现性能问题。

  • 域控制器自身出现性能问题。

注意：
在用户连接到位于不同物理站点的域控制器时，LDAP 延迟通常较长。但是，一般不会超过本文所建议的最长延迟。

如果已记录此警告的域控制器位于不同的物理站点上，则只要可以确定 Exchange 服务器没有使用报告此警告的域控制器，就能够安全地忽略此错误。确定 Exchange 是否使用域控制器的一种方法是，将 MSExchangeDSAccess 服务的"拓扑"组件中的诊断日志记录调整到"最小"。如果没有显示 MSExchangeDSAccess 事件 ID 事件 2080，则可以安全地忽略此警告。

若要解决此警告问题，请执行下列操作：

  • 验证与域控制器之间的所有网络连接是否正常工作且支持 Internet 控制监视协议 (ICMP) 通信。

  • 请考虑使用下列文章中提供的最佳方法：

    • 有关用于解决 Active Directory 相关问题的 LDAP Read Time 性能计数器和其他计数器的信息，请参阅 Troubleshooting Microsoft Exchange Server Performance（解决 Microsoft Exchange Server 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)中的"Ruling Out Active Directory-Bound Problems"（解决 Active Directory 相关问题）主题。该文章也包含有关如何提高 Active Directory 性能的信息。

    • 有关如何使 Active Directory 性能达到最大化的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"中的"Active Directory Integration Tuning"主题（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

    • 有关确保 Active Directory 服务器达到高可用性的信息，请参阅 Exchange 2003 High Availability Guide（Exchange 2003 高可用性指南）(http://go.microsoft.com/fwlink/?LinkId=47571) 的"System-Level Fault Tolerant Measures"（系统级容错措施）主题中的"Ensuring Reliable Access to Active Directory and Domain Name System"（确保对 Active Directory 和域名系统的可靠访问）下的各个部分。

    • 有关网络带宽注意事项的信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"中的"Understanding Exchange Performance"主题（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。


最长的 LDAP 读取延迟已超过 100 毫秒
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-03-14

Microsoft Exchange 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 MSExchangeDSAccess Process 性能对象的 LDAP Read Time 性能计数器收集数据，以分析性能数据。

LDAP Read Time 性能计数器显示实现轻型目录访问协议 (LDAP) 读取请求所需的时间（毫秒）。Exchange 分析工具在 5 分钟内每 5 秒检索一个示例。然后，Exchange 分析工具在收集间隔期间报告性能计数器的最大值。如果最大值超过 100 毫秒，则 Exchange 分析工具将显示错误。

较长的远程过程调用 (RPC) 延迟和队列的增加可能会导致较长的 LDAP 读取延迟。较长的 LDAP 读取延迟通常表明存在下列问题之一：

  • 到域控制器的网络连接出现性能问题。

  • 域控制器自身出现性能问题。

注意：
在用户连接到位于不同物理站点的域控制器时，LDAP 延迟通常较长。但是，一般不会超过本文所建议的最长延迟。

Exchange 服务器每 15 分钟对域外的全局编录服务器进行一次查询，以保持全局编录服务器和域控制器列表最新。由于其中一些目录服务器可能是远程服务器，所以这些查询的延迟可能较长。只要请求不是很频繁，即速率低于每秒 0.5 次请求，这就是可以接受的。

如果已记录此错误的域控制器位于不同的物理站点上，则只要可以确定 Exchange 服务器没有使用报告此错误的域控制器，就能够安全地忽略此错误。确定 Exchange 是否使用域控制器的一种方法是，将 MSExchangeDSAccess 服务的"拓扑"组件中的诊断日志记录调整到"最小"。如果没有显示 MSExchangeDSAccess 事件 ID 事件 2080，则可以安全地忽略此错误。

重要信息：
仅对于混合模式环境，考虑到与某种特定安全性相关的用户属性（如 tokenGroups 和 tokengroupsGlobalandUniversal之类的用户属性可用来确定用户是哪个安全组的成员，从而确定此用户拥有哪些权限以保证诸如公用文件夹之类的资源的安全），在 Exchange 2000 SP2 时间范围内引入了一种行为，即要求 Exchange 服务器查询对用户主域有权限的域控制器。该享有权限的域控制器可能位于远程站点中，而且从访问本地公共文件夹的大量远程主域用户中进行查询可能会导致较长的 RPC 延迟。

有关此行为的详细信息，请参阅下列 Exchange Server 博客主题：

  • Exchange Does Not Always Use Local GCs

    注意：
    提供了博客的链接以帮助您查找所需的技术信息。每篇博客的内容及其 URL 如有更改，恕不另行通知。

若要解决此错误，请执行下列操作：

  • 验证与域控制器之间的所有网络连接是否正常工作且支持 Internet 控制监视协议 (ICMP) 通信。

  • 请考虑使用下列文章中提供的最佳方法：

    • 有关用于解决 Active Directory 相关问题的 LDAP Read Time 性能计数器和其他计数器的信息，请参阅 Troubleshooting Microsoft Exchange Server Performance（解决 Microsoft Exchange Server 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)中的"Ruling Out Active Directory-Bound Problems"（解决 Active Directory 相关问题）主题。该文章也包含有关如何提高 Active Directory 性能的信息。

    • 有关如何使 Active Directory 性能达到最大化的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"中的"Active Directory Integration Tuning"主题（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

    • 有关确保 Active Directory 服务器达到高可用性的信息，请参阅 Exchange 2003 High Availability Guide（Exchange 2003 高可用性指南）(http://go.microsoft.com/fwlink/?LinkId=47571) 的"System-Level Fault Tolerant Measures"（系统级容错措施）主题中的"Ensuring Reliable Access to Active Directory and Domain Name System"（确保对 Active Directory 和域名系统的可靠访问）下的各个部分。

    • 有关网络带宽注意事项的信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"中的"Understanding Exchange Performance"主题（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。


平均 LDAP 搜索滞后时间超过 50 毫秒
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-03-14

Microsoft Exchange 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 MSExchangeDSAccess Process 性能对象的 LDAP Search Time 性能计数器收集数据，以分析性能数据。

LDAP Search Time 性能计数器显示实现轻型目录访问协议 (LDAP) 搜索请求所需的时间（毫秒）。Exchange 分析工具在 5 分钟内每 5 秒检索一个示例。然后，Exchange 分析工具在收集间隔期间报告性能计数器的最大值。如果平均值超过 50 毫秒，则 Exchange 分析工具将显示警告。

较长的远程过程调用 (RPC) 延迟和队列的增加可能会导致较长的 LDAP 搜索延迟。较长的 LDAP 搜索延迟通常表明存在下列问题之一：

  • 到域控制器的网络连接出现性能问题。

  • 域控制器自身出现性能问题。

注意：
在用户连接到位于不同物理站点的域控制器时，LDAP 延迟通常较长。但是，一般不会超过本文所建议的最长延迟。

如果已记录此警告的域控制器位于不同的物理站点上，则只要可以确定 Exchange 服务器没有使用报告此警告的域控制器，就能够安全地忽略此错误。确定 Exchange 是否使用域控制器的一种方法是，将 MSExchangeDSAccess 服务的"拓扑"组件中的诊断日志记录调整到"最小"。如果没有显示 MSExchangeDSAccess 事件 ID 事件 2080，则可以安全地忽略此警告。

若要解决此警告问题，请执行下列操作：

  • 验证与域控制器之间的所有网络连接是否正常工作且支持 Internet 控制监视协议 (ICMP) 通信。

  • 请考虑使用下列文章中提供的最佳方法：

    • 有关用于解决 Active Directory 相关问题的 LDAP Read Time 性能计数器和其他计数器的信息，请参阅 Troubleshooting Microsoft Exchange Server Performance（解决 Microsoft Exchange Server 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)中的"Ruling Out Active Directory-Bound Problems"（解决 Active Directory 相关问题）主题。该文章也包含有关如何提高 Active Directory 性能的信息。

    • 有关如何使 Active Directory 性能达到最大化的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"中的"Active Directory Integration Tuning"主题（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

    • 有关确保 Active Directory 服务器达到高可用性的信息，请参阅 Exchange 2003 High Availability Guide（Exchange 2003 高可用性指南）(http://go.microsoft.com/fwlink/?LinkId=47571) 的"System-Level Fault Tolerant Measures"（系统级容错措施）主题中的"Ensuring Reliable Access to Active Directory and Domain Name System"（确保对 Active Directory 和域名系统的可靠访问）下的各个部分。

    • 有关网络带宽注意事项的信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"中的"Understanding Exchange Performance"主题（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。


最大 LDAP 搜索延迟超过 100 毫秒
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-03-14

Microsoft Exchange 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 MSExchangeDSAccess Process 性能对象的 LDAP Search Time 性能计数器收集数据，以分析性能数据。

LDAP Search Time 性能计数器显示实现轻型目录访问协议 (LDAP) 搜索请求所需的时间（毫秒）。Exchange 分析工具在 5 分钟内每 5 秒检索一个示例。然后，Exchange 分析工具在收集间隔期间报告性能计数器的最大值。如果最大值超过 100 毫秒，则 Exchange 分析工具将显示错误。

较长的远程过程调用 (RPC) 延迟和队列的增加可能会导致较长的 LDAP 搜索延迟。较长的 LDAP 搜索延迟通常表明存在下列问题之一：

  • 到域控制器的网络连接出现性能问题。

  • 域控制器自身出现性能问题。

注意：
在用户连接到位于不同物理站点的域控制器时，LDAP 延迟通常较长。但是，一般不会超过本文所建议的最长延迟。

Exchange 服务器每 15 分钟对域外的全局编录服务器进行一次查询，以保持全局编录服务器和域控制器列表最新。由于其中一些目录服务器可能是远程服务器，所以这些查询的延迟可能较长。只要请求不是很频繁，即速率低于每秒 0.5 次请求，这就是可以接受的。

如果记录此错误的域控制器位于不同的物理站点上，则只要可以确定 Exchange 服务器没有使用报告此错误的域控制器，就能够安全地忽略此错误。确定 Exchange 是否使用域控制器的一种方法是，将 MSExchangeDSAccess 服务的"拓扑"组件中的诊断日志记录调整到"最小"。如果没有显示 MSExchangeDSAccess 事件 ID 事件 2080，则可以安全地忽略此错误。

重要信息：
仅对于混合模式环境，考虑到与某种特定安全性相关的用户属性（如 tokenGroups 和 tokengroupsGlobalandUniversal），在 Exchange 2000 SP2 时间范围内引入了一种行为。这些用户属性用于确定用户是哪个安全组的成员，从而确定此用户拥有哪些权限以保证诸如公用文件夹之类的资源的安全，此行为要求 Exchange 服务器查询对用户主域有权限的域控制器。该享有权限的域控制器可能位于远程站点中，而且从访问本地公共文件夹的大量远程主域用户中进行查询可能会导致较长的 RPC 延迟。

有关此行为的详细信息，请参阅下列 Exchange Server Blog 文章（英文）：

  • Exchange Does Not Always Use Local GCs

    注意：
    提供了博客的链接以帮助您查找所需的技术信息。每篇博客的内容及其 URL 如有更改，恕不另行通知。

若要解决此错误，请执行下列操作：

  • 验证与域控制器之间的所有网络连接是否正常工作且支持 Internet 控制监视协议 (ICMP) 通信。

  • 请考虑使用下列文章中提供的最佳方法：

    • 有关用于解决 Active Directory 相关问题的 LDAP Read Time 性能计数器和其他计数器的信息，请参阅 Troubleshooting Microsoft Exchange Server Performance（解决 Microsoft Exchange Server 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)中的"Ruling Out Active Directory-Bound Problems"（解决 Active Directory 相关问题）主题。该文章也包含有关如何提高 Active Directory 性能的信息。

    • 有关如何使 Active Directory 性能达到最大化的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"中的"Active Directory Integration Tuning"主题（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

    • 有关确保 Active Directory 服务器达到高可用性的信息，请参阅 Exchange 2003 High Availability Guide（Exchange 2003 高可用性指南）(http://go.microsoft.com/fwlink/?LinkId=47571) 的"System-Level Fault Tolerant Measures"（系统级容错措施）主题中的"Ensuring Reliable Access to Active Directory and Domain Name System"（确保对 Active Directory 和域名系统的可靠访问）下的各个部分。

    • 有关网络带宽注意事项的信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"中的"Understanding Exchange Performance"主题（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。


无法识别指定的 Exchange 网关
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-08-08

Microsoft® Exchange Server 分析工具将查询 Active Directory® 目录服务，以获取具有对象类 msExchExchangeServer 的每个目录对象的名称 (cn)，从而确定用户指定的 Exchange 网关服务器是否存在匹配项。

cn 值是包含 Exchange Server 计算机简短名称的字符串。

如果 Exchange Server 分析工具无法在 Active Directory 中找到用户指定的 Exchange 网关服务器的 cn 值匹配项，则会显示错误。

此错误指示存在下列情况之一：

  • 本地 Exchange Server 组织中不存在用户指定的 Exchange 网关服务器。

  • 未正确输入用户指定的 Exchange 网关服务器。

若要解决此错误，请验证是否正确输入了指定的 Exchange 网关服务器，然后重试操作。

警告：
如果在使用 Active Directory 服务接口 (ADSI) Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，不当地修改了 Active Directory 对象的属性，则可能会导致严重的问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象属性的风险由您自己承担。
验证服务器名 (cn) 值

  1. 使用 ADSI Edit 或类似工具在 Active Directory 中找到服务器对象。

    CN 属性位于：

    复制代码
    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Servers,CN=Server.


Categorizer queue length 超出阈值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-02-13

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 SMTP Server 性能对象的 Categorizer Queue Length 性能计数器收集数据，以分析性能数据。

如果 Exchange Server 分析工具确定 Categorizer Queue Length 计数器在示例时间段内超出峰值 10，则将显示错误信息。

SMTP Server\Categorizer Queue Length 计数器表示简单邮件传输协议 (SMTP) 分类程序队列中正在等待进行使用全局编录服务器的目录服务属性搜索的邮件数。

分类程序执行下列核心操作：

  • 解析并验证所有收件人。

  • 确定所有收件人的限制。

  • 展开通讯组列表（如果需要）。

  • 确定邮件用于本地传递还是远程传递。

该错误表示服务器、网络性能、目录服务访问 (DSAccess)、Active Directory® 目录服务可能有问题，或 Exchange Server 组织中的关键服务器发生中断。Categorizer Queue Length 计数器的增加可能表示在咨询 Active Directory 时或发出邮件进行本地传递或 SMTP 传递时，会有一个很慢的速度或无响应。这可能导致邮件传递延迟。

若要解决此错误，请执行下列操作：

  • 验证 Exchange 服务器是否具有足够的 Active Directory 资源。这包括域控制器和全局编录服务器。建议的做法是使 Exchange 服务器的处理器和速度相当的全局编录服务器的处理器保持 4:1 的比率。

  • 在 Exchange 系统管理器中，验证 Exchange server 的 DSAccess 选项卡上列出的所有域控制器是否都在正常运行。这包括 ConfigDC 中列出的服务器、域控制器和全局编录服务器角色。

  • 监视 Exchange 服务器和其所选择的域控制器和全局编录服务器之间的网络性能，以确定是否存在网络性能瓶颈。

  • 监视 Exchange 服务器的处理器利用率和 Inetinfo.exe 进程的处理器利用率。这包括分类程序组件。

  • 通过使用来自 Microsoft Exchange Server 部署工具中 ConfigDSInteg 工具的 e2kdsinteg 配置对象，验证与 Exchange 有关的用户和组对象的工作状况 (http://go.microsoft.com/fwlink/?LinkId=21231)。地址格式错误或信息不完整的对象可能导致收件人决定延迟和延迟分类。

详细信息

有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。


CDO.DLL 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查是否存在下列几个核心 Exchange 二进制文件：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


CimWin32.dll 更新已可用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-09-19

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Exchange Server 计算机上运行的 Microsoft Windows® 版本。

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 值为 4.0 表示 Exchange Server 计算机运行的是 Microsoft Windows NT® Server 4.0。值为 5.0 表示 Exchange Server 计算机运行的是 Windows 2000 Server，值为 5.2 表示 Exchange Server 计算机运行的是 Windows Server™ 2003。

Exchange Server 分析工具还查询 CIM_Datafile Microsoft Windows Management Instrumentation (WMI) 类，以确定为 Cimwin32.dll 文件的 Version 关键字设置的值。

如果符合下列条件，Exchange Server 分析工具将显示最佳实践消息：

  • Exchange Server 计算机运行的是 Windows 2000 Server。

  • Version 关键字的值与 Cimwin32.dll 文件的特定版本对应。

对 Cimwin32.dll 文件的更新将提高 Exchange Server 分析工具的工作效率。

若要解决此问题，请查看并应用 Microsoft 知识库文章 820608"CIM_DataFile class returns an incorrect or null value for files that are larger than 2 GB in Windows 2000"（CIM_DataFile 类将为 Windows 2000 中大于 2 GB 的文件返回错误值或空值）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=820608) 中的建议。


客户端应用程序对服务器性能的影响
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具已确定您拥有特定类型的客户端计算机或客户端应用程序，可能会增大 Exchange 组织中的服务器负载。

许多应用程序可以增大服务器的负载。如果负载增大，那么应调查用户正在运行的应用程序，并决定是否要限制用户运行某些应用程序。有些访问电子邮件的应用程序（第三方应用程序或 Microsoft Office Outlook® 插件）可能会增大服务器的负载。如果服务器发生远程过程调用 (RPC) 延迟次数增加或负载增大，那么建议您调查来源。

可以使用 Exchange Server User Monitor (ExMon) 来确定延迟发生率高的用户或增大服务器负载的用户。要下载 ExMon，请访问 Microsoft 下载中心 (http://go.microsoft.com/fwlink/?LinkId=54983)。

步骤

解决此警告问题

  • 使用 ExMon 确定造成服务器负载增大的用户。在确定了用户之后，与相应用户联系，确定下列应用程序是否造成负载增大：

    • 第三方客户端计算机插件

    • 桌面同步设备，例如 Exchange ActiveSync® 或 Blackberry

    • 其他 MAPI 应用程序，例如桌面搜索引擎

    如果商业用途不需要这些应用程序，或应用程序已发布了修复程序，那么禁用或更新这些应用程序，以便将负载减少到适合的水平。

  • 将运行成本最高的客户端计算机（尤其是在 Restrict、SetColumns 或 FindRow 操作方面延迟时间长的客户端计算机）配置为使用缓存 Exchange 模式。缓存 Exchange 模式将服务器与大多数过量的 RPC 通信隔离开。

    此外，鼓励文件夹中包含许多项目的用户将较旧的数据存档到 .pst 文件。或者，如果这些用户希望将数据保留在服务器上，那么鼓励他们将较旧的项目移至新创建的文件夹。

    最后，建议您在"收件箱"、"日历"、"已发送邮件"、"联系人"和"已删除邮件"文件夹中保留的项目少于 5,000 个。
注意：
有些应用程序可能会显著增大服务器负载，而又没有发出大量的 MAPI 操作。这是因为某些操作的成本比其他操作更高。成本较高的操作数可能只需要少量的增加，就会显著影响服务器的性能。在 ExMon 中，这些用户的报告是对 CPU 产生相对较大的影响，而未必已发出大量的 MAPI 操作。

详细信息

  • 有关 Exchange Server 性能的详细信息，请参阅 Performance and Scalability Guide for Exchange Server 2003（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关解决 Outlook 客户端性能问题的详细信息，请参阅"Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)。

  • 有关桌面搜索软件的详细信息，请参阅 Microsoft 知识库文章 905184"Exchange 2000 Server and Exchange Server 2003 performance may be affected when desktop search engine software is running on Outlook or other MAPI client computers"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184)。


群集 TEMP 路径无效或为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

在非群集的 Exchange Server 计算机上，Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 TEMP 环境变量的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

如果对 Microsoft Windows® 服务器群集中的 Exchange 虚拟服务器 (EVS) 运行 Exchange Server 分析工具，则 Exchange Server 分析工具不会读取 HKLM 注册表配置单元，而是读取以下注册表项：

HKEY_USERS\<Cluster service account SID>\Environment\TEMP

如果 Exchange Server 分析工具发现 TEMP 环境变量未设置为当前系统上的可用路径，将显示警告。如果此路径无效，则您的组织可能会遇到邮件传递故障。默认情况下，Exchange Server 分析工具的默认配置期望发现此路径设置为 %USERPROFILE%\Local Settings\Temp。尽管可以将此路径修改为指向其他位置，但是在应用修补程序或更新程序并重新启动群集节点之后，系统可能期望发现该路径设置为默认值。

TEMP 环境变量用于指定文件系统中供需要临时工作区的应用程序使用的文件夹。TEMP 通常供 Exchange Server 等应用程序使用。每个变量的路径通常与应用程序的上下文相关。例如，Microsoft Exchange 信息存储服务进程在多种操作（例如，邮件转换和邮箱移动操作）期间都将使用 TEMP 文件夹作为临时存储区。

解决此警告问题

  1. 作为群集服务帐户登录到群集中的节点。

  2. 用鼠标右键单击"我的电脑"，然后选择"属性"。

  3. 选择"高级"。

  4. 单击"环境变量"。

  5. 在"<account name> 的用户变量"区域中，选择 TEMP 并单击"编辑"。

  6. 在"变量值"字段中，输入 TEMP 环境变量的默认路径，再单击"确定"。

  7. 单击"确定"关闭"环境变量"对话框，再次单击"确定"关闭"系统属性"对话框。

  8. 重新启动该节点，以便应用更改。

  9. 对于采用非默认设置的群集中的每个节点，重复第 1 步到第 8 步。


考虑使用多个脱机通讯簿副本
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-08-14

Microsoft® Exchange Server 分析工具查询 root\MicrosoftExchangeV2 命名空间下的 Exchange_PublicFolder Microsoft Windows® Management Instrumentation (WMI) 类，以确定 ReplicaList 关键字中的条目数。条目数代表每个管理组中存在的脱机通讯簿副本数。

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定具有 legacyExchangeDN 属性集的公用文件夹数据库对象数。具有此属性集的对象数代表组织中存在的公用文件夹存储数。

如果 Exchange Server 分析工具确定存在多个公用文件夹存储的 Exchange 组织中只有一个脱机通讯簿副本，则 Exchange Server 分析工具将显示最佳做法消息。

为了提高可用性和性能，建议您考虑针对每个脱机通讯簿部署多个副本。有时，多个脱机通讯簿副本可以提高性能并改善恢复能力。在大型 Exchange 组织中，如果脱机通讯簿只有一个副本，则可能会出现超载情况。在所有 Exchange 组织中，如果脱机通讯簿只有一个副本，则此副本便是单个故障点。

虽然存在多个副本意味着会产生更多的网络复制通信，但仍建议使用多个副本。每个脱机通讯簿至少应有两个副本。

若要向 Exchange 组织中添加脱机通讯簿副本，请执行下列操作：

  1. 打开 Exchange 系统管理器

  2. 展开"文件夹"，右键单击"公用文件夹"，再选择"查看系统文件夹"。注意 如果没有"文件夹"节点，则展开"管理组"，然后展开包含要查看的系统文件夹的管理组。然后，右键单击"公用文件夹"并选择"查看系统文件夹"。

  3. 展开 OFFLINE ADDRESS BOOK 容器，然后右键单击要添加副本的"脱机通讯簿"，在出现的下拉列表中选择"属性"进行添加。

  4. 选择"复制"选项卡，再单击"添加"以选择要添加副本的"公用存储"。单击"确定"即可完成。

  5. 对 Offline Address Book 容器下需要副本的所有子对象，重复执行步骤 3 和 4。执行此重复操作将确保所有支持的格式都包含在副本中，具体是指"添加"子对象 OAB Version 2、OAB Version 3a 等。

有关如何管理和配置脱机通讯簿的详细信息，请参阅下列 Microsoft Exchange Server TechCenter 文章：

  • "Offline Address Book - Things to Consider"（可能为英文网页）(http://go.microsoft.com/fwlink/?LinkId=57581)

  • "Working with Exchange Server 2003 Stores"（可能为英文网页）(http://go.microsoft.com/fwlink/?LinkId=47595)。

  • "Offline Address Book Best Practices Guide"（可能为英文网页）(http://go.microsoft.com/fwlink/?LinkId=47583)。

  • "OAB Version 4 in Exchange Server 2003 Service Pack 2"（可能为英文网页）(http://go.microsoft.com/fwlink/?linkid=53097)。

  • "How Outlook 2003 SP2 and Exchange Server 2003 SP2 OAB Version 4 Work Together"（可能为英文网页）(http://go.microsoft.com/fwlink/?linkid=53099)。


与收件人更新服务域控制器的连接
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-05-18

Microsoft® Exchange Server 分析工具打开到每个域控制器上端口 389 的 TCP 套接字连接。此连接是通过使用自定义对象处理器来建立的。该处理器在连接成功时返回一个特定的字符串。

如果 Exchange Server 分析工具收到的返回字符串中没有 389 Available，则显示警告。

该警告说明域控制器没有响应 TCP 端口 389 上的连接尝试。TCP 端口 389 是轻型目录访问协议 (LDAP) 通信的默认端口。如果收到此警告，则可能存在下列情况：

  • Exchange Server 分析工具与域控制器之间可能存在连接问题。

  • 服务器可能已关闭。

  • 服务器可能已停止使用。

当 Exchange Server 分析工具查询域控制器时，有很多原因会导致 LDAP 请求可能没有得到域控制器的正确处理。

解决此警告问题

  1. 验证运行 Exchange Server 分析工具的帐户有权查询域控制器。您必须在域控制器所运行在的域中拥有用户级权限。在随 Exchange Server 分析工具提供的帮助文件中，可以找到有关运行 Exchange Server 分析工具所需的权限的详细信息。若要打开 Exchange Server 分析工具帮助文件，请在 Exchange Server 分析工具中单击"帮助"，再单击"Microsoft Exchange Server 分析工具帮助"。

  2. 验证在运行 Exchange Server 分析工具的计算机与没有响应的域控制器之间没有防火墙或端口限制。

  3. 验证域控制器与网络保持连接并正常工作。

  4. 验证服务器尚未停止使用，仍作为 Exchange Server 的可用域控制器列出。

有关详细信息，请参阅下列 Microsoft 知识库文章：

  • 319065"How to work with the Exchange Recipient Update Service"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=319065)

  • 816103"HOW TO:Use Portqry to Troubleshoot Active Directory Connectivity Issues"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103)


内容更新可用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-06-21

有关详细信息，请参阅 Exchange Server 2007 文档下载页。


对此公用文件夹存储启用了内容索引，但未安排更新日程
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个公用文件夹存储的 msExchCIAvailable 属性值。该属性的值表明是否对公用文件夹存储启用了内容索引。如果值为 True，意味着公用文件夹存储存在内容索引，并且 Exchange 系统管理器设置"客户端当前可以使用此索引进行搜索"处于选中状态。如果值为 False，则意味着公用文件夹存储存在内容索引，但 Exchange 系统管理器设置"客户端当前可以使用此索引进行搜索"不处于选中状态。如果值为 <Not Set>，则意味着公用文件夹存储不存在内容索引。

Exchange Server 分析工具还查询 Active Directory，以确定每个公用文件夹存储的 msExchCIRebuildSchedule 属性值。该属性的值表明内容索引的重建日程安排设置。该属性作为一个具有 82 对十六进制值的八位字节字符串存储。

如果 Exchange Server 分析工具发现 msExchCIAvailable 属性值设置为 True，但 msExchCIRebuildSchedule 属性的八位字节字符串值解释为"从不运行"，则显示警告。

关于更新间隔的设置，推荐的最佳做法是将增量更新安排为每天至少运行一次。您可能希望安排更频繁的更新，因为索引仅仅与上次填充后的结果一样新。不定期更新的索引会产生既不准确又过时的结果。

还应考虑完成增量填充所需的时间。例如，典型的日程安排将增量更新设置在每小时的开头。但是，如果更新的持续时间超过一小时，则下一次增量填充将从下一小时的开头开始。

通常，如果公用文件夹存储为 6 GB 或更小，则可以每小时执行一次增量更新。如果存储大于 6 GB，或者服务器的内存使用率很高，则可能需要降低索引更新的频率。

在特定的公用文件夹存储上设置全文索引更新间隔

  1. 打开 Exchange 系统管理器。

  2. 依次展开"管理组"、您的管理组、"服务器"、您的服务器、您的存储组，用鼠标右键单击您的公用文件夹存储，再单击"属性"。如果"管理组"节点未显示在 Exchange 系统管理器中，请展开"服务器"，用鼠标右键单击您的服务器，再单击"属性"。

  3. 在"全文索引"选项卡上，选择"从不运行"以外的选项。

  4. 如果选择"使用自定义日程安排"，请单击"自定义"，设置您自己的自定义日程安排，再单击"确定"。

  5. 单击"应用"。

有关 Exchange Server 的全文索引的详细信息，请参阅"Best Practices for Deploying Full-Text Indexing"（英文）(http://go.microsoft.com/fwlink/?linkid=5223)。


对此邮箱存储启用了内容索引，但未安排更新日程
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个邮箱存储的 msExchCIAvailable 属性值。该属性的值表明是否对邮箱存储启用了内容索引。值为 True 意味着邮箱存储存在内容索引，并且 Exchange 系统管理器设置"客户端当前可以使用此索引进行搜索"处于选中状态。值为 False 意味着邮箱存储存在内容索引，但 Exchange 系统管理器设置"客户端当前可以使用此索引进行搜索"不处于选中状态。值为 <Not Set> 意味着邮箱存储不存在内容索引。

Exchange Server 分析工具还查询 Active Directory，以确定每个邮箱存储的 msExchCIRebuildSchedule 属性值。该属性的值表明内容索引的重建日程安排设置。该属性作为一个具有 82 对十六进制值的八位字节字符串存储。

如果 Exchange Server 分析工具发现 msExchCIAvailable 属性值设置为 TRUE，但 msExchCIRebuildSchedule 属性的八位字节字符串值解释为"从不运行"，则显示警告。

关于更新间隔的设置，推荐的最佳实践是将增量更新安排为每天至少运行一次。您可能希望安排更频繁的更新，因为索引仅仅与上次填充后的结果一样新。不定期更新的索引会产生既不准确又过时的结果。

此外，还应考虑完成增量填充所需的时间。例如，典型的日程安排将增量更新设置在每小时的开头。但是，如果更新的持续时间超过一小时，则下一次增量填充将从下一小时的开头开始。

通常，如果邮箱存储的大小不超过 6 GB，可以每小时执行一次增量更新。如果存储大于 6 GB，或者服务器的内存使用率很高，则可能需要降低索引更新的频率。

在特定的邮箱存储上设置全文索引更新间隔

  1. 打开 Exchange 系统管理器。

  2. 依次展开"管理组"、您的管理组、"服务器"、您的服务器、您的存储组，用鼠标右键单击您的邮箱存储，再单击"属性"。如果"管理组"节点未显示在 Exchange 系统管理器中，请展开"服务器"，用鼠标右键单击您的服务器，再单击"属性"。

  3. 在"全文索引"选项卡上，选择"从不运行"以外的选项。

  4. 如果选择"使用自定义日程安排"，请单击"自定义"，设置您自己的自定义日程安排，然后单击"确定"。

  5. 单击"应用"。

有关在 Exchange 中配置全文索引并解决相关问题的详细信息，请参阅 Microsoft 知识库文章 822932"HOW TO:Configure Full-Text Indexing on Mailbox Stores in Exchange 2003"（英文）(http://go.microsoft.com/fwlink/?LinkID=3052&kbid=822932) 和 319436"How to configure full-text indexing on mailbox stores in Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=319436)。

有关 Exchange Server 的全文索引的详细信息，请参阅"Best Practices for Deploying Full-Text Indexing"（英文）(http://go.microsoft.com/fwlink/?LinkId=5223)。


CQPCIDRV.SYS 驱动程序更新可用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-08-14

Microsoft® Exchange Server 分析工具将读取以下注册表项，以确定在运行 Exchange Server 计算机上使用的 Microsoft Windows® 版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

如果 CurrentVersion 的值为 4.0，则表示 Exchange 服务器运行的是 Microsoft Windows NT® Server 4.0。如果该值为 5.0，则表示 Exchange 服务器运行的是 Windows 2000 Server。如果该值为 5.2，则表示 Exchange Server 计算机运行的是 Windows Server™ 2003。

Exchange Server 分析工具还将检查 Win32_Processor Windows Management Instrumentation (WMI) 类，以确定 DataWidth 项值。

如果 DataWidth 项值为 32，则表示服务器运行的是 32 位版本的 Windows 操作系统；如果 DataWidth 项值为 64，则表示服务器运行的是 64 位版本的 Windows 操作系统。

最后，Exchange Server 分析工具将查询 CIM_Datafile WMI 类，以确定名为 CpqCiDrv.sys 文件的 Version 项值。

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • Exchange 服务器运行的是 Windows Server 2003。

  • Exchange 服务器运行的是 64 位版本的 Windows 操作系统。

  • HP Integrated Lights-Out 管理接口驱动程序 CPQCIDRV.sys 的版本低于 1.8。

此错误指示在服务器上安装的 CpqCiDrv.sys 版本可能会导致内核内存分配错误。

若要解决此问题，请遵循文档 ID：c00688313 (http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c00688313) 中的供应商指导。

注意：
在本主题中提供第三方网站信息是为了帮助您查找所需的技术信息。URL 如有更改，恕不另行通知。


CrashOnAuditFail 有效
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已设置 CrashOnAuditFail 参数：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\LSA\CrashOnAuditFail

如果 Exchange Server 分析工具发现 CrashOnAuditFail 的值等于 2，则显示错误。

CrashonAuditFail 注册表项的目的是配置服务器以便当安全日志到达所配置的大小限制时，不允许最终用户访问计算机。禁止访问计算机可以确保在相反情况下所记录的审核信息不会丢失。

启用时，CrashonAuditFail 注册表项将设置为值 1。但是，在达到安全日志限制时，服务器将把注册表项设置为值 2，该设置将停止服务器上的处理过程。有时，该进程将导致完全失败，即 STOP 0xC0000244，也叫做 Stop 错误。至少，用户将无法访问服务器资源，并且性能将极大降低。另外，服务器处在该状态时，只有具有管理员权限的用户才能访问该计算机。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

更正此错误

  1. 打开注册表编辑器，例如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\SYSTEM\CurrentControlSet\Control\LSA.

  3. 删除称为 CrashOnAuditFail 的值（必须删除整个值，而不仅是值数据）。

  4. 将安全事件日志复制到单独的位置。默认情况下，安全事件日志 (SecEvent.Evt) 位于 %SystemRoot%\System32\Config，其中，%SystemRoot% 是安装 Microsoft Windows® 操作系统的路径。

  5. 打开事件查看程序，用鼠标右键单击"安全日志"，再单击"属性"。

  6. 在"安全日志属性"页上，单击"清除日志"。系统提示保存日志时，单击"是"，再指定用来保存日志文件的位置。

    注意 在"安全属性"页上，还可以通过编辑"最大日志文件大小"字段，再单击"应用"，来增加日志大小。

  7. 重新启动服务器。

  8. 通过登录到 Exchange 邮箱，验证用户可以访问服务器资源。

  9. 重新创建 CrashonAuditFail 注册表项，并将值数据设置为 1。

  10. 重新启动服务器，以使 CrashonAuditFail 设置生效。

  11. 定期清除和保存服务器的安全日志，以便不超过最大日志大小。有关详细信息，请参阅 Microsoft 知识库文章 312571"The event log stops logging events before reaching the maximum log size"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=312571)。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅知识库文章"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关从 CrashOnAuditFail 故障恢复正常的详细信息，请参阅下列知识库文章：

  • 232564"STOP 0xC0000244 when security log full"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232564)

  • 829082"You receive a "Stop error 0xC0000244 {Audit Failed}" error message when the crashonauditfail registry key is set to 1 on a Windows Server 2003-based computer"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=829082)


自定义公用文件夹引用列表
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-09

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchFolderAffinityCustom 属性是否包含一些 Exchange 服务器名。如果 Exchange Server 分析工具发现 msExchFolderAffinityCustom 属性列出服务器名，则显示非默认配置消息。

默认情况下，Exchange Server 2003 使用路由组来确定公用文件夹引用。

Exchange Server 2007 默认设置是使用 Active Directory 目录服务站点间开销来确定公用文件夹引用路由。

如果 msExchFolderAffinityCustom 属性列出服务器名称，则 Exchange 服务器上已配置了自定义引用。msExchFolderAffinityCustom 属性是服务器特定的属性。

一般情况下，建议的最佳做法是使用公用文件夹引用的默认行为。但是，您可能必须创建自定义引用列表。非默认配置消息是一个信息性消息。不需要执行任何操作。

恢复为 Exchange Server 2003 中的默认配置

  1. 打开 Exchange 系统管理器。

  2. 找到配置了自定义公用文件夹引用的服务器对象。配置了自定义公用文件夹引用的 Exchange 服务器名在 Exchange Server 分析工具消息中指定。

  3. 右键单击"服务器名称"，再单击"属性"。

  4. 在"公用文件夹引用"选项卡上，选择"公用文件夹引用选项"下拉框中的"使用路由组"。

  5. 单击"应用"，再单击"确定"。
恢复为 Exchange Server 2007 中的默认配置

  1. 下列代码是 Exchange 命令行管理程序 Set-PublicFolderDatabase 命令的示例，该命令用于禁止将 PublicFolderRefferalServerList 用于"MyServer\First Storage Group\Public Folder Databas"公用文件夹数据库。
复制代码
Set-PublicFolderDatabase -Identity "MyServer\First Storage Group\Public Folder Database" -UseCustomReferralServerList $false

UseCustomReferralServerList 参数指定是否使用 PublicFolderReferralServerList 参数指定的服务器开销。如果设置为 $true，则服务器使用 PublicFolderReferralServerList 参数开销进行公用文件夹引用。如果设置为 $false，则服务器使用 Active Directory 站点间开销进行公用文件夹引用。

注意：
如果将此参数设置为 $false，则还会清除 PublicFolderReferralServerList 参数。

有关 Exchange 命令行管理程序 Set-PublicFolderDatabase 命令的详细信息，请参阅 Exchange Server 2007 产品文档技术参考"Set-PublicFolderDatabase"(http://go.microsoft.com/fwlink/?LinkId=80813)。

有关公用文件夹复制的详细信息，请参阅"Best Practices for Exchange Server Public Folders"（英文）(http://go.microsoft.com/fwlink/?LinkId=46437)。


Database 性能监视器对象不可用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包括性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎从 Database 性能对象的 Log Record Stalls/sec 性能计数器收集数据以分析性能数据。如果计数器未返回有效数据，Exchange Server 分析工具将显示基准消息。

如果性能数据收集引擎未返回有效数据，则可能出现下列情况的任意组合：

  • Database 性能对象已禁用。

  • Database 性能监视器对象丢失或损坏。

  • Exchange Server 分析工具没有访问性能对象的相应权限。

如果某些可扩展计数器破坏了注册表，或基于 Microsoft Windows Management Instrumentation (WMI) 的程序修改了注册表，可能会发生前两种情况。

以下过程说明如何处理前两种情况。在执行该过程之前，请验证 Exchange Server 分析工具是否具有相应的权限。有关运行 Exchange Server 分析工具所需的权限的详细信息，请参阅随 Exchange Server 分析工具提供的帮助文档。要获得帮助，请打开 Exchange Server 分析工具，然后按 F1 键。

更正此错误

  1. 验证 Database 性能对象是否已启用。

    1. 下载并安装可扩展性能计数器列表工具 (Exctrlst.exe)。可以从以下位置下载 Exctrlst.exe："Exctrlst.exe:Extensible Performance Counter List"（英文）(http://go.microsoft.com/fwlink/?LinkId=34436)。

    2. 打开 Exctrlst.exe，再单击"Sort Order"，然后单击"Service"。

    3. 找到性能对象所报告的服务，并确认选中了"Performance Counters Enabled"复选框。

      如果未选中"Performance Counters Enabled"复选框，请选中该复选框，然后重新启动与性能计数器关联的服务，确认性能计数器工作正常。如果性能计数器无法正常工作，或"Performance Counters Enabled"复选框已选中，请继续执行第 2 步。

  2. 重建丢失或损坏的性能计数器，请参阅 Microsoft 知识库文章 300965"如何手动重新生成性能计数器库值"(http://support.microsoft.com/?kbid=300956)。

  3. 如果按照此知识库文章操作不能解决问题，将必须在"修复"模式下重新安装 Exchange Server，然后应用最新的 Exchange Server Service Pack。


DAVEX.DLL 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查是否存在下列几个核心 Exchange 二进制文件：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


DHCP 客户端服务未运行
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Windows® Management Instrumentation (WMI) 类，以确定动态主机配置协议 (DHCP) 客户端服务的 Started 关键字的值。如果 Exchange Server 分析工具发现 Exchange 服务器上 DHCP 客户端服务的 Started 关键字的值设置为 False，则显示警告。

此警告表明 DHCP 客户端服务未运行。DHCP 客户端服务执行动态域名系统 (DNS) 更新。如果 DHCP 客户端服务未运行，则会出现动态更新故障。如果 Exchange 服务器未运行该项服务，则最常见的问题是邮件流问题。

要解决该问题，请将 DHCP 客户端服务设置为自动启动，然后启动该项服务。

注意：
即使服务器被配置为使用静态 IP 地址而非 DHCP，也必须运行 DHCP 客户端服务。
启用 DHCP 客户端服务

  1. 打开"服务"管理单元。

  2. 在详细信息窗格中，用鼠标右键单击"DHCP 客户端服务"，再单击"属性"。

  3. 在"常规"选项卡上，单击"启动类型"，选择"自动"。

  4. 单击"开始"，然后单击"确定"。

有关 DHCP 客户端服务的详细信息，请参阅 Microsoft 知识库文章 264539"Dynamic DNS updates do not work if the DHCP client service stops"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264539)。

有关 DNS 动态更新协议的详细信息，请参阅 Microsoft 知识库文章 816592"How to configure DNS dynamic updates in Windows Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592)。


未启用 Dr. Watson
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项的值，以确定 Dr. Watson 是否已配置为 Microsoft Windows® 操作系统的默认应用程序调试程序：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger

如果 Exchange Server 分析工具发现 Debugger 的值不是以 drwtsn32 开头，则会显示非默认配置消息。

此消息表明 Dr. Watson 未启用。如果一开始使用的是 Windows NT®，则 Windows 附带一个名为 Dr. Watson 的应用程序模式调试程序。应用程序崩溃时，Dr. Watson 可以捕获错误，这将记录各种信息，如平台信息、所运行进程的列表、错误进程的标识、错误进程的内存转储、一个或多个调用堆栈，以及指向错误本身的指针。所收集的大多数信息都是低级调试信息，可专供错误进程开发人员使用。

建议的最佳做法是，运行启用了应用程序模式调试程序的 Windows。如果未启用 Dr. Watson，并且您未在使用其他应用程序调试程序，则建议您使用以下步骤启用 Dr. Watson。

启用 Dr. Watson

  1. 打开命令提示窗口。

  2. 在命令提示符下，键入 drwtsn32 -i。

有关启用和禁用 Dr. Watson 的详细信息，请参阅 Microsoft 知识库文章 188296"How to Disable Dr. Watson for Windows"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=188296)。


DSA 计算机名不匹配
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 DSA Computer 值的设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定每个 Exchange 服务器对象的 name 属性值。

最后，Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定群集服务 (ClusSvc) 的 Started 关键字的值。值为 True 意味着群集服务已启动，值为 False 意味着群集服务未运行。

如果 Exchange Server 分析工具发现 DSA Computer 项的值与未在 Windows Server 群集中运行的任何 Exchange Server 计算机的 Active Directory 中服务器对象的 name 属性值不匹配，则显示错误。

若要更正此错误，必须编辑 DSA Computer 注册表项，以便与 Active Directory 中的 name 属性值匹配。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何编辑注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

更正此错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右侧窗格中，双击"DSA Computer"，输入此计算机的正确名称，再单击"确定"。

  4. 关闭注册表编辑器，并重新启动 Exchange Server 计算机，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


DSACCESS.DLL 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查几个核心 Exchange 二进制文件是否存在：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


DSAccess 配置缓存已满
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-05-24

Microsoft® Exchange Server 分析工具查询 Win32_PerfRawData_MSExchangeDSAccess_MSExchangeDSAccessCaches Microsoft Windows® Management Instrumentation (WMI) 类，以确定 TotalEntriesMemoryConfigurationData 的当前值。如果 Exchange Server 分析工具发现 TotalEntriesMemoryConfigurationData 的值等于目录服务访问 (DSAccess) 配置缓存 (MaxMemoryConfig) 的总大小，则会显示警告。

DSAccess 是 Exchange 2000 Server 和 Exchange Server 2003 的内部组件，用于控制所有 Exchange 组件如何访问 Active Directory® 目录服务。DSAccess 的主要功能是维护与目录有关的各种事件和操作的相关信息。例如，DSAccess 发现 Active Directory 拓扑结构，并检测域控制器和全局编录服务器是否可用、是否能对查询做出响应。此外，由内部 Exchange 组件（例如，Microsoft Exchange 存储）所发起的所有目录查询（例如，收件人解析、配置设置查找和其他操作）都将通过 DSAccess 进行路由。作为其作业的一部分，DSAccess 维护着一个在内存中的缓存，该缓存用来存放某些这类查询的结果，以便如果两次请求相同的信息，就可以从 DSAccess 缓存中检索该信息，而不用对 Active Directory 进行另一次轻型目录访问协议 (LDAP) 查询。

由于 DSAccess 配置缓存的默认设置最大大小已从 Exchange 2000 Server 中的 25 MB 减少到 Exchange Server 2003 中的 5 MB，因此该警告消息可以在这两个 Exchange 版本中的任何一个上生成。无论此警告消息是哪个版本的 Exchange 产生的，都应尽快更正此问题。

MaxMemoryConfig 值通常与 MaxMemoryUser 值配合使用，后者控制 DSAccess 缓存中的用户数据对象最多可以使用的内存量。如果按照下面的过程编辑或删除了 MaxMemoryConfig 值，应按照 DSAccess 用户缓存值是非默认的中的说明以类似的方法编辑或删除 MaxMemoryUser 值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. 增大 MaxMemoryConfig 的值。如果 Instance0 项或 MaxMemoryConfig DWORD 值不存在，可以手动创建它。MaxMemoryConfig 注册表项的数值数据以 KB 为单位，因此，十进制的 15000 等于 15 MB。如果该值存在，请将它增加 10%。如果该值不存在，建议以 10 MB 作为初始起点。

  4. 关闭注册表编辑器，然后重新启动 Microsoft Exchange System Attendant，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


DSAccess 配置缓存值为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-17

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定目录服务访问 (DSAccess) 配置对象缓存的大小是否已从默认值修改为其他值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0\MaxMemoryConfig

如果 Exchange Server 分析工具发现 MaxMemoryConfig 存在并已配置，则会显示非默认配置消息。

MaxMemoryConfig 是 Exchange 2000 Server 注册表参数，通常在 Exchange Server 2003 中不再需要。MaxMemoryConfig 控制 DSAccess 配置缓存中的配置数据对象最多可以使用的内存量。DSAccess 是 Exchange 2000 Server 和 Exchange Server 2003 内部的一个组件，用于控制所有 Exchange 组件如何访问 Active Directory® 目录服务。DSAccess 的主要功能是维护各个与目录有关的事件和操作的信息。例如，DSAccess 探查 Active Directory 拓扑，并检测域控制器和全局编录服务器是否可用以及是否响应查询。此外，由内部 Exchange 组件（例如，Microsoft Exchange 存储）所发起的所有目录查询（例如，收件人解析、配置设置查找和其他操作）都将通过 DSAccess 进行路由。作为其作业的一部分，DSAccess 维护着一个在内存中的缓存，该缓存用来存放某些这类查询的结果，以便如果两次请求相同的信息，就可以从 DSAccess 缓存中检索该信息，而不用对 Active Directory 进行另一次轻型目录访问协议 (LDAP) 查询。

在 Exchange 2000 Server 中，配置缓存的大小最初设置为 25 MB。在大多数 Exchange 服务器上，此设置远远大于需要的大小。MaxMemoryConfig 设置用于回收并重新分配 DSAccess 配置缓存使用的部分内存。它通常配置为 5 MB。Microsoft 根据内部测试的结果及客户反馈得出 3 MB 是最佳大小。Exchange Server 2003 将此大小用作现成的设置。当从 Exchange 2000 Server 升级到 Exchange Server 2003 时，所有手动设置都保留。如果此 Exchange 服务器是从 Exchange 2000 Server 升级到 Exchange Server 2003 的，应确保 MaxMemoryConfig 的值不超过 5 MB。

MaxMemoryConfig 值通常与 MaxMemoryUser 值配合使用，后者控制 DSAccess 缓存中的用户数据对象最多可以使用的内存量。如果按照下面的过程所述编辑或删除 MaxMemoryConfig 值，应按照 DSAccess 用户缓存值是非默认的中的说明以类似方式编辑或删除 MaxMemoryUser 值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

使用 MaxMemoryConfig 注册表值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. 检查或编辑 MaxMemoryConfig 的值。
注意：
此注册表项的值以 KB 为单位。如果该值设置为 3000 或更小的数，应删除 MaxMemoryConfig 并重新启动 Microsoft Exchange 系统助理服务，以便恢复为默认的 Exchange Server 2003 设置。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 DSAccess 的详细信息，请参阅知识库文章 250570"Directory Service Server Detection and DSAccess Usage"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)。


DSAccess DisableNetLogonCheck 注册表参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已将目录服务访问 (DSAccess) 配置为使用非默认的 ping 协议：

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\DisableNetLogonCheck

如果 Exchange Server 分析工具发现 DisableNetLogonCheck 存在并且配置的值大于 0，则显示非默认配置消息。

DSAccess 在探查 Active Directory® 目录服务拓扑后，将确定所探查到的域控制器和全局编录服务器是否适于使用。初始探查和后续探查过程中，DSAccess 通过运行一系列测试来确定服务器的适用性。为了测试目录服务器的一般适用性，一个测试向其发送远程过程调用 (RPC)。在通常不允许 RPC 通信的外围网络中，DSAccess RPC 请求将失败。但是，DSAccess 会继续发出 RPC，直到运行失败。此过程可能需要很长的时间。此类重复的检查可能会对运行 Exchange Server 的计算机的性能造成负面影响。因此，在位于外围网络的 Exchange 服务器上，管理员经常会添加 DisableNetLogonCheck 注册表项并将其值配置为 1。

如果生成非默认配置消息的 Exchange 服务器处于禁用 RPC 的外围网络中，或您确定不希望 DSAccess 执行此适用性测试，应将 DisableNetLogonCheck 注册表项设置为 1。否则，应删除 DisableNetLogonCheck 注册表项。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

使用 DisableNetLogonCheck 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. 双击 DisableNetLogonCheck 注册表项，然后将 DWORD 值设置为 1.。

  4. 关闭注册表编辑器。不需要重新启动服务来使更改生效。

删除 DisableNetLogonCheck 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. 删除名为 DisableNetLogonCheck 的值。

  4. 关闭注册表编辑器。不需要重新启动服务来使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 DisableNetLogonCheck 注册表项的详细信息，请参阅知识库文章 320228"XGEN:The DisableNetLogonCheck Registry Value and How to Use It"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320228)。


DSAccess 已硬编码
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 ROOT\MicrosoftExchangeV2 命名空间中的 Exchange_DSAccessDC Microsoft Windows® Management Instrumentation (WMI) 类，以确定 ConfigurationType 项的值。如果该项的值为 0，则会显示非默认配置消息。

ConfigurationType 属性指出实例描述的是自动检测的域控制器还是手动指定的域控制器。Exchange Server 中的目录服务访问 (DSAccess) 组件的现成设置是动态检测 Active Directory® 目录服务拓扑并自动找到域控制器和全局编录服务器。在运行 Exchange Server 2000 Service Pack 2（或更高版本）或 Exchange Server 2003 的计算机上，Exchange 系统管理器提供一项功能，使用户能够输入供 DSAccess 使用的 Active Directory 服务器的硬编码列表。

除非出于某一特定原因对用于 DSAccess 的目录服务器进行了硬编码，否则，应删除服务器列表并回复到自动探查默认设置。建议使用自动拓扑探查以利用全局编录故障转移。

回复到默认设置

  1. 依次单击"开始"、"程序"、"Microsoft Exchange"、"系统管理器"。

  2. 依次展开"管理组"、"<AdminGroupName>"、"服务器"、"<ServerName>"（其中，AdminGroupName 是 Exchange 服务器所在管理组的名称，ServerName 是要配置的 Exchange 服务器的名称）。

  3. 用鼠标右键单击该 Exchange 服务器，再单击"属性"。

  4. 单击"目录访问"选项卡。

  5. 在"显示"列表框中，选择"配置域控制器"。

  6. 选中"自动探查服务器"复选框。

  7. 当出现以下 Exchange 系统管理器提示时，单击"是"："已经指定的、手动选择的服务器将被清除。要继续吗?"

  8. 在"显示"列表框中，选择"域控制器"。

  9. 选中"自动探查服务器"复选框。

  10. 当出现以下 Exchange 系统管理器提示时，单击"是"："已经指定的、手动选择的服务器将被清除。要继续吗?"

  11. 在"显示"列表框中，选择"全局编录服务器"。

  12. 选中"自动探查服务器"复选框。

  13. 当出现以下 Exchange 系统管理器提示时，单击"是"："已经指定的、手动选择的服务器将被清除。要继续吗?"

  14. 单击"确定"保存更改。

有关 DSAccess 和目录服务检测的详细信息，请参阅 Microsoft 知识库文章 250570"Directory Service Server Detection and DSAccess Usage"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)。


DSAccess 没有使用端口 389 来处理 LDAP 域控制器请求
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 ROOT\MicrosoftExchangeV2 命名空间中的 Exchange_DSAccessDC Microsoft Windows® Management Instrumentation (WMI) 类，以确定 LDAPPort 关键字的值。如果没有将 LDAPPort 关键字的值设置为 389，则会显示非默认配置消息。

LDAPPort 关键字代表域控制器用来侦听轻型目录访问协议 (LDAP) 请求的 TCP 端口号。管理员可以在 TCP 端口 636（域控制器）或 TCP 端口 3269（全局编录）上使用安全套接字层 (SSL) 上的 LDAP 作为安全措施。

默认情况下，全局编录服务器在端口 3268 侦听 LDAP 通信。但是，如果安装了企业证书颁发机构，则所有域控制器将自动请求证书，并且可以在 TCP 端口 636 上支持 SSL 上的 LDAP 通信。如果域控制器还被配置为全局编录，那么，它还可以在 TCP 端口 3269 上支持 SSL 上的 LDAP 通信。

更正此错误

  • 不需要您执行任何操作。Exchange Server 分析工具识别非默认的配置。

有关 DSAccess 和 LDAP 端口的详细信息，请参阅下列 Microsoft 知识库文章：

  • 247078"如何对 Windows 2000 域控制器启用 LDAP 上的安全套接字层 (SSL) 通讯"(http://support.microsoft.com/kb/247078/zh-cn)

  • 246228"XGEN:DSAccess Profiles"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246228)


DSAccess 没有使用端口 3268 来处理 LDAP 全局编录请求
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 ROOT\MicrosoftExchangeV2 命名空间中的 Exchange_DSAccessDC Microsoft Windows® Management Instrumentation (WMI) 类，以确定 LDAPPort 关键字的值。如果没有将 LDAPPort 关键字的值设置为 3268，则会显示非默认配置消息。

LDAPPort 关键字代表域控制器用来侦听轻型目录访问协议 (LDAP) 请求的 TCP 端口号。管理员可以在 TCP 端口 636（域控制器）或 TCP 端口 3269（全局编录）上使用安全套接字层 (SSL) 上的 LDAP 作为安全措施。

默认情况下，全局编录服务器在端口 3268 侦听 LDAP 通信。但是，如果安装了企业证书颁发机构，则所有域控制器将自动请求证书，并且可以在 TCP 端口 636 上支持 SSL 上的 LDAP 通信。如果域控制器还被配置为全局编录，那么，它还可以在 TCP 端口 3269 上支持 SSL 上的 LDAP 通信。

有关 DSAccess 和 LDAP 端口的详细信息，请参阅下列 Microsoft 知识库文章：

  • 247078"如何对 Windows 2000 域控制器启用 LDAP 上的安全套接字层 (SSL) 通讯"(http://support.microsoft.com/kb/247078/zh-cn)

  • 246228"XGEN:DSAccess Profiles"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246228)


DSAccess LdapKeepAliveSecs 注册表参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定目录服务访问 (DSAccess) 是否已配置为使用轻型目录访问协议 (LDAP) Microsoft Windows® 操作系统实现 (wLDAP) 协议：

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\ LdapKeepAliveSecs

如果 Exchange Server 分析工具发现 LdapKeepAliveSecs 存在并且配置的值为 0，则显示非默认配置消息。

DSAccess 在探查 Active Directory® 目录服务拓扑后，将确定所探查到的工作的域控制器和全局编录服务器列表是否适于使用。初始探查和后续探查过程中，DSAccess 通过运行一系列测试来确定服务器的适用性。默认情况下，其中一项适用性测试使用 Internet 控制消息协议 (ICMP) 来 ping 域控制器，验证服务器是否可用。

网络中并非所有连接都可以支持 ICMP。在不允许 Exchange 服务器和域控制器之间的 ICMP 连接的外围网络就属于这种情况。对于此类情况，LdapKeepAliveSecs 注册表参数设置为 0 后，将强制 DSAccess 使用 LDAP 的 Windows 实现 (wLDAP) 进行适用性测试。

如果生成非默认配置消息的 Exchange 服务器处于禁用远程过程调用 (RPC) 的外围网络中或不允许 ICMP 的网络中，请保留 LdapKeepAliveSecs 注册表项的原始配置。否则，应删除该注册表项。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

删除 LdapKeepAliveSecs 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. 删除名为 LdapKeepAliveSecs 的值。

  4. 关闭注册表编辑器。不需要重新启动服务来使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 LdapKeepAliveSecs 注册表项的详细信息，请参阅知识库文章 320529"XADM:Using DSAccess in a Perimeter Network Firewall Scenario Requires a Registry Key Setting"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320529)。


DSAccess LdapKeepAliveSecs 注册表参数设置为不支持的值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已将目录服务访问 (DSAccess) 配置为使用轻型目录访问协议 (LDAP) Microsoft Windows® 操作系统实现协议 (wLDAP)：

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\ LdapKeepAliveSecs

如果 Exchange Server 分析工具发现 LdapKeepAliveSecs 属性存在并且被配置的值不是 0，则显示警告。

DSAccess 在探查 Active Directory® 目录服务拓扑后，将确定所探查到的工作的域控制器和全局编录服务器列表是否适于使用。初始探查和后续探查过程中，DSAccess 通过运行一系列测试来确定服务器的适用性。默认情况下，其中一项适用性测试使用 Internet 控制消息协议 (ICMP) 来 ping 域控制器，验证服务器是否可用。

网络中并非所有连接都可以支持 ICMP。在不允许 Exchange 服务器和域控制器之间的 ICMP 连接的外围网络就属于这种情况。对于此类情况，LdapKeepAliveSecs 注册表参数设置为 0 后，将强制 DSAccess 使用 wLDAP 进行适用性测试。

如果生成此警告的 Exchange 服务器处于禁用远程过程调用 (RPC) 的外围网络中或不允许 ICMP 的网络中，请将 LdapKeepAliveSecs 注册表项设置为 0。否则，应删除该注册表项。此注册表项不支持任何非零值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

修改 LdapKeepAliveSecs 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. 双击 LdapKeepAliveSecs 注册表项，然后将 DWORD 值设置为 0（零）。

  4. 关闭注册表编辑器。不需要重新启动服务来使更改生效。

删除 LdapKeepAliveSecs 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. 删除名为 LdapKeepAliveSecs 的值。

  4. 关闭注册表编辑器。不需要重新启动服务来使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 LdapKeepAliveSecs 注册表项的详细信息，请参阅知识库文章 320529"XADM:Using DSAccess in a Perimeter Network Firewall Scenario Requires a Registry Key Setting"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320529)。


DSAccess PreloadBaseDNs 注册表参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已将目录服务访问 (DSAccess) 的搜索预加载功能从默认配置更改为其他配置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\PreloadBaseDNs

PreloadBaseDNs 的默认数值数据为：

'"'

'"'

'"'

'"'

'"'

如果 Exchange Server 分析工具发现 PreloadBaseDNs 的值从默认值修改为其他值，则显示警告消息。Exchange Server 分析工具报告此配置，因为该设置只有在向 Microsoft 产品支持服务部门联系后才应更改。

DSAccess 缓存驻留在 Exchange server 上，收集从 Active Directory® 目录服务检索的配置和用户记录。DSAccess 缓存中的记录可以使用对象的可分辨名称、全局唯一标识符 (GUID) 或在 Active Directory 中查找此对象时使用的作用域、BaseDN 和搜索筛选器所构成的关键字进行访问。以后再使用相同的可分辨名称、GUID 或关键字进行访问时，将在缓存中查找该记录。因此，可以避免相同的搜索对 Active Directory 产生的不必要的负载。但是，如果搜索筛选器与缓存中包含的搜索筛选器不同，即使 DSAccess 请求相同的用户对象属性集，DSAccess 也无法避免对 Active Directory 产生负载。

如果对同一个用户对象应用多个不同的搜索筛选器，通过搜索预加载功能可以避免可能发生的多个 Active Directory 搜索问题。通过上面提到的关键字结构（搜索条目由作用域、BaseDN 和搜索筛选器构成）实现搜索预加载。

有关配置 DSAccess 搜索预加载的详细信息，请参阅 Microsoft 知识库文章 250572"XCON:Preloading and the DSAccess Cache"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250572)。


DSAccess PreloadFilters 注册表参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定目录服务访问 (DSAccess) 的搜索预加载功能是否已从默认配置更改为其他配置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\PreloadFilters

PreloadFilters 的默认数值数据为：

(&(|(msExchMasterAccountSID=%)(objectSid=%))(!(objectClass=foreignSecurityPrincipal)))(|(msExchMailboxGUID=%)(objectGUID=%))(legacyExchangeDN=%)(msExchMailboxGUID=%)(&(proxyAddresses=%)(|(objectClass=user)(objectClass=contact)))

如果 Exchange Server 分析工具发现 PreloadFilters 的值从默认值修改为其他值，将显示警告。Exchange Server 分析工具报告此配置，因为 PreloadFilters 注册表设置只有在向 Microsoft 产品支持服务部门联系后才应更改。

DSAccess 缓存驻留在 Exchange server 上，收集从 Active Directory® 目录服务检索的配置和用户记录。缓存中的记录可以使用对象的可分辨名称、全局唯一标识符 (GUID) 或在 Active Directory 中查找此对象时使用的作用域、BaseDN 和搜索筛选器所构成的关键字进行访问。以后再使用相同的可分辨名称、GUID 或关键字进行访问时，将在缓存中查找该记录。因此，可以避免相同的搜索对 Active Directory 产生的不必要的负载。但是，如果搜索筛选器与缓存中包含的搜索筛选器不同，即使 DSAccess 请求相同的用户对象属性集，DSAccess 也无法避免对 Active Directory 产生负载。

如果对同一个用户对象应用多个不同的搜索筛选器，通过搜索预加载功能可以避免可能发生的多个 Active Directory 搜索问题。通过上面提到的关键字结构（搜索条目由作用域、BaseDN 和搜索筛选器构成）实现搜索预加载。

有关配置 DSAccess 搜索预加载的详细信息，请参阅 Microsoft 知识库文章 250572"XCON:Preloading and the DSAccess Cache"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250572)。


DSAccess 报告该 Active Directory 服务器失效
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 ROOT\MicrosoftExchangeV2 命名空间中的 Exchange_DSAccessDC Microsoft Windows® Management Instrumentation (WMI) 类，以确定 IsUp 关键字的值。如果 IsUp 关键字被设置为 False，则显示错误。

如果 IsUp 关键字被设置为 True，则说明在上一次 Exchange 服务器尝试建立连接时域控制器作出了响应。如果 IsUp 被设置为 False，则说明域控制器没有对连接尝试作出响应。

没有响应并不总是意味着域控制器或全局编录已停机或发生故障。有时，在 Exchange 服务器和域控制器之间可能存在的网络连接问题可以导致该故障。这样的故障还可以是 Exchange 服务器与尚未打开合适端口的域控制器之间的防火墙所导致的。

更正此错误

  1. 通过对域控制器尝试 ping 命令，检查它是否正在运行。

  2. 如果有防火墙，请确保防火墙已打开正确的端口。请注意还可以将防火墙配置为丢弃 PING 数据包。检查防火墙文档中是否有关于如何打开或关闭具体端口的详细信息。

  3. 确保没有其他与网络相关的问题，例如交换机、路由器和电缆故障。

有关 DSAccess 和目录服务检测的详细信息，请参阅 Microsoft 知识库文章 250570"Directory Service Server Detection and DSAccess Usage"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)。

有关解决网络连接问题的详细信息，请参阅知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。


DSAccess 报告该 Active Directory 服务器未与拓扑结构的其余部分同步
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-04-21

Microsoft® Exchange Server 分析工具查询 ROOT\MicrosoftExchangeV2 命名空间中的 Exchange_DSAccessDC Microsoft Windows® Management Instrumentation (WMI) 类，以确定 IsInSync 关键字的值。如果 IsInSync 的值是 False，则会显示错误。

IsInSync 关键字表明域控制器是否与全局编录服务器以及配置域控制器同步。值为 True 表明服务器已同步，值为 False 表明域控制器未同步。

更正此错误

  1. 检查域控制器或全局控制器上的时间。确保时间服务已启动，或者手动同步 Exchange 服务器与全局编录服务器或配置域控制器的时间。

  2. 使用复制监视工具 (Replmon) 检查、验证并（如果需要）解决域控制器复制问题。Replmon 是 Microsoft Windows 2000 Server 和 Microsoft Windows Server™ 2003 支持工具的一部分，这些工具位于 Windows Server CD 的 Support\Tools 文件夹中。

有关 DSAccess 和目录服务检测的详细信息，请参阅下列 Microsoft 知识库文章：

  • 316300"Event ID 2080 and MSExchangeDSAccess"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=316300)

  • 250570"Directory Service Server Detection and DSAccess Usage"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)


DSAccess 报告该 Active Directory 服务器用了超过 2 秒的时间来响应 LDAP 请求
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 ROOT\MicrosoftExchangeV2 命名空间中的 Exchange_DSAccessDC Microsoft Windows® Management Instrumentation (WMI) 类，以确定 IsFast 关键字和 IsUp 关键字的值。如果 IsUp 关键字的值是 True，则说明 Exchange Server 中的目录服务访问 (DSAccess) 组件所使用的目录服务器已连接到网络并且正在响应。值为 False 则说明目录服务器没有响应。如果 IsFast 的值是 True，则说明该目录服务器的响应时间少于两秒。值为 False 则说明响应时间超过两秒。如果 IsUp 的值是 True，但 IsFast 的值是 False，则会显示错误。

更正此错误

  1. 检查域控制器和全局编录的负载。超载的域控制器和全局编录在响应轻型目录访问协议 (LDAP) 调用时会很缓慢。

  2. 确保在本地 Active Directory® 目录服务站点中至少有一个全局编录，以获得最佳性能。

有关 DSAccess 和目录服务检测的详细信息，请参阅 Microsoft 知识库文章 250570"Directory Service Server Detection and DSAccess Usage"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)。


DSAccess TopoCreateTimeoutSecs 注册表参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定目录服务访问 (DSAccess) 初始化超时的默认值是否已更改：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess\TopoCreateTimeoutSecs

如果 Exchange Server 分析工具发现 TopoCreateTimeoutSecs 项存在，并且值大于 0，则会显示非默认配置消息。

在启动时，DSAccess 使用探查进程识别 Active Directory® 目录服务拓扑并评估域控制器和全局目录服务器的可用性。启动完成后，每隔 15 分钟，DSAccess 将使用几乎相同的进程来重新探查拓扑并检查服务器可用性是否改变。默认情况下，启动期间的 DSAccess 初始化必须在一分钟之内完成。否则，DSAccess 将停止。通常，一分钟足够 DSAccess 进行初始化。

注意：
如果对 DSAccess 使用的目录服务器进行硬编码，DSAccess 将绕过探查过程，只检查服务器的可用性。
重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess

  3. 删除名为 TopoCreateTimeoutSecs 的值。

  4. 关闭注册表编辑器。

如果存在该注册表项，应考虑评估网络拓扑。如果组织中需要更多的 DSAccess 初始化时间，可能表明存在设计问题或网络问题。快速可靠地访问域控制器（尤其是全局目录服务器）对于保证 Exchange 运行的最佳状态是非常必要的。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关目录访问的详细信息，请参阅"Understanding and Troubleshooting Directory Access"（英文）(http://go.microsoft.com/fwlink/?LinkId=39012)。


DSAccess 用户缓存已满
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-04-20

Microsoft® Exchange Server 分析工具查询 Win32_PerfRawData_MSExchangeDSAccess_MSExchangeDSAccessCaches Microsoft Windows® Management Instrumentation (WMI) 类，以确定 TotalEntriesMemoryUserData 的当前值。如果 Exchange Server 分析工具发现 TotalEntriesMemoryUserData 的值等于目录服务访问 (DSAccess) 用户缓存的总大小 (MaxMemoryUser)，则显示警告。

DSAccess 是 Exchange 2000 Server 和 Exchange Server 2003 的内部组件，用于控制所有 Exchange 组件如何访问 Active Directory® 目录服务。DSAccess 的主要功能是维护与目录有关的各种事件和操作的相关信息。例如，DSAccess 发现 Active Directory 拓扑结构，并检测域控制器和全局编录服务器是否可用、是否能对查询做出响应。此外，由内部 Exchange 组件（例如，Exchange 存储）发起的所有目录查询（例如，收件人解析、配置设置查找和其他操作）都将通过 DSAccess 进行路由。作为其作业的一部分，DSAccess 维护着一个在内存中的缓存，该缓存用来存放某些这类查询的结果，以便如果两次请求相同的信息，就可以从 DSAccess 缓存中检索该信息，而不用对 Active Directory 进行另一次轻型目录访问协议 (LDAP) 查询。

在 Exchange 2000 Server 中，用户缓存一开始设置为 25 MB。在向大量 Microsoft Office Outlook® 2003 客户端提供服务的 Exchange 2000 Server 计算机上，默认的 DSAccess 用户缓存大小是不够的。为了提高性能，Exchange Server 2003 中用户缓存的默认值已经优化并设置为 140 MB。

由于 DSAccess 用户缓存的最大大小默认设置已从 Exchange 2000 Server 中的 25 MB 提高到 Exchange Server 2003 中的 140 MB，因此该警告消息很可能在 Exchange 2000 Server 计算机上生成。无论此警告消息是哪个版本的 Exchange 产生的，都应尽快更正此问题。在 DSAccess 缓存不够大的系统上，本地邮件传递和通讯簿名称解析速度可能比您需要的速度慢。

可以在 Exchange 服务器上使用注册表项，手动配置用户缓存的最大大小。MaxMemoryUser 是一个 Exchange 2000 Server 注册表参数，它使得 Exchange 管理员可以控制 DSAccess 缓存中用户数据对象允许消耗的最大内存数。

MaxMemoryUser 值通常与 MaxMemoryConfig 值一起使用，后者控制 DSAccess 缓存中配置数据对象可以消耗的最大内存数。如果按下面描述的过程编辑或删除 MaxMemoryUser 值，则应当用类似的方法编辑或删除 MaxMemoryConfig 值（如 DSAccess 配置缓存值为非默认值中所述）。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

在 Exchange 2000 Server 计算机上解决此问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. 增大 MaxMemoryUser 的值。如果该 DWORD 值不存在，可以手动创建它。该注册表项的数值数据以 KB 为单位，因此，十进制的 140000 等于 140 MB。

  4. 减小 MaxMemoryConfig 的值。如果该 DWORD 值不存在，可以手动创建它。该注册表项的数值数据也以 KB 为单位。建议使用十进制值 5000，它等于 5 MB。

  5. 退出注册表编辑器，然后重新启动 Microsoft Exchange System Attendant，以使更改生效。

在 Exchange Server 2003 计算机上解决此问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. 如果 MaxMemoryUser 存在并配置为小于 140 MB 的值，请删除 MaxMemoryUser 值。如果 MaxMemoryUser 存在并大于 140 MB，请将其值增大 10%。

  4. 如果 MaxMemoryConfig 存在，请删除它。

  5. 退出注册表编辑器，然后重新启动 Exchange System Attendant，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请阅读 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 DSAccess 的详细信息，请参阅知识库文章 250570"Directory service server detection and DSAccess usage"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570)。


DSAccess 用户缓存值是非默认的
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定目录服务访问 (DSAccess) 用户对象缓存的大小是否已从默认值修改为其他值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0\MaxMemoryUser

如果 Exchange Server 分析工具发现 MaxMemoryUser 存在并已配置，则会显示非默认配置消息。

MaxMemoryUser 是一个 Exchange 服务器注册表参数，它允许 Exchange 管理员控制允许 DSAccess 缓存中的用户数据对象消耗的最大内存量。

DSAccess 是 Exchange 2000 Server 和 Exchange Server 2003 的内部组件，用于控制所有 Exchange 组件如何访问 Active Directory® 目录服务。DSAccess 的主要功能是维护各种与目录有关的事件和操作的相关信息。例如，DSAccess 发现 Active Directory 拓扑结构，并检测域控制器和全局编录服务器是否可用、是否能对查询做出响应。此外，由内部 Exchange 组件（例如，Exchange 存储）所发起的所有目录查询（例如，收件人解析、配置设置查找和其他操作）都将通过 DSAccess 进行路由。作为其作业的一部分，DSAccess 维护着一个在内存中的缓存，该缓存用来存放某些这类查询的结果，以便如果两次请求相同的信息，就可以从 DSAccess 缓存中检索该信息，而不用对 Active Directory 进行另一次轻型目录访问协议 (LDAP) 查询。

在 Exchange 2000 Server 中，用户缓存的大小最初设置为 25 MB。在向大量 Microsoft Office Outlook® 2003 客户端提供服务的 Exchange 2000 Server 计算机上，默认的 DSAccess 用户缓存大小是不够的。在 DSAccess 缓存不够大的系统上，本地邮件传递和通讯簿名称解析速度可能比预期缓慢。

为了提高性能，在 Exchange Server 2003 中，用户缓存的默认值已经过优化，并设置为 140 MB。从 Exchange 2000 Server 升级到 Exchange Server 2003 时，任何手动设置都将保留下来。如果该 Exchange 服务器是从 Exchange 2000 Server 升级到 Exchange Server 2003，则应当确保 MaxMemoryUser 的值至少是 140 MB。

MaxMemoryUser 值通常与 MaxMemoryConfig 值配合使用，后者用于控制允许 DSAccess 缓存中的配置数据对象消耗的最大内存量。如果按照下面的过程编辑或删除了 MaxMemoryUser 值，应按照 DSAccess 配置缓存值为非默认值 中的说明以类似的方法编辑或删除 MaxMemoryConfig 值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

使用 MaxMemoryUser 注册表项

  1. 打开注册表编辑器，例如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. 检查或编辑 MaxMemoryUser 的值。

    该注册表项的值以 KB 为单位。如果该值设置为 140000 或更小的数，应删除 MaxMemoryUser 并重新启动 Microsoft Exchange System Attendant，以便恢复为默认的 Exchange Server 2003 设置。

编辑注册表之前，要获取有关如何编辑注册表的信息，请阅读 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 DSAccess 的详细信息，请参阅知识库文章 250570"Directory Service Server Detection and DSAccess Usage"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)。


DSProxy RFR 服务已禁用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取下列注册表项，以确定是否已禁用目录服务代理引用 (DSProxy RFR) 服务：

HKEY_LOCAL_MACHINE\ System\CurrentControlSet\Services\MSExchangeSA\Parameters\ No RFR Service

如果 Exchange Server 分析工具发现 No RFR Service 存在并设置为 1，则显示非默认配置消息。

Microsoft Outlook® 98 和 Outlook 97 客户端可以通过 Exchange 2000 Server 和 Exchange Server 2003 中的 DSProxy 组件对域控制器或全局编录进行目录访问。Outlook 2000 Service Release 2 (SR-2) 和更高版本的客户端可以直接查询全局编录服务器。

当 Outlook 2000 SR-2 或更高版本的客户端首次连接到运行 Exchange 2000 服务器或更高版本的计算机时，将在主 Exchange 服务器上查找目录服务。Outlook 最初通过 DSProxy 进程来完成第一次会话。在客户端通过尝试所有可用的传输协议联系到 DSProxy 服务后，会收到一个返回的引用，该引用通知它将来的所有目录请求都应发送到全局编录服务器。Outlook 在注册表中的 MAPI 配置文件中设置该引用。DSProxy 引用机制减少了 Exchange 服务器上的负载，并减少了搜索通讯簿的延迟时间。如果在配置文件中输入了明确的服务器名，则当 Active Directory® 目录服务服务器出现故障时，Outlook 必须重新启动。如果发生这种情况，Exchange 服务器将向 Outlook 发送一个新引用。

在某些情况下，您可能希望强制 Outlook 客户端（甚至包括最新的版本）始终通过 DSProxy 进程来访问目录，而不为其返回引用。例如，如果 Outlook 与 Exchange 服务器之间存在防火墙，您可能需要这样做。

通过添加 No RFR Service 注册表项并将它设置为 1，Exchange 服务器将充当 Outlook 客户端的代理而不是将客户端指引到相应的全局编录服务器，以便直接通信。将 No RFR Service 注册表参数设置为 1 会降低 Exchange 服务器的性能，因为 Exchange 服务器将充当所有 Outlook 客户端（包括可以直接与 Active Directory 通信的 Outlook 2000 SR-2 和更新的客户端）的代理。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

启用 DSProxy RFR 服务

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 创建一个名为 No RFR Service 的新 DWORD 值。

  4. 将 No RFR Service 的值配置为 1。

若要禁用 DSProxy RFR 服务，请删除 No RFR Service 注册表值或将它设置为 0。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Outlook 2000 SR-2 及更新的客户端如何与 Active Directory 交互的详细信息，请参阅知识库文章 256976"XCCC:How Outlook 2000 Accesses Active Directory"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914)。

有关 MAPI 客户端如何访问 Active Directory 的信息，请参阅知识库文章 256976"XCLN:How MAPI Clients Access Active Directory"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976)。


EMSMTA.EXE 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查是否存在下列几个核心 Exchange 二进制文件：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


EnableAuthEpResolution 注册表项已启用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已启用远程过程调用 (RPC) 接口限制注册表项：

HKEY_LOCAL_MACHINE\ Software\Policies\Microsoft\Windows NT\RPC

如果 Exchange Server 分析工具发现 EnableAuthEpResolution 注册表值存在，则显示非默认配置消息。

RPC 接口限制增强了网络保护，将使系统不易受到来自网络的攻击。

可以远程匿名使用并且默认情况下在 Microsoft Windows® XP 上注册的 RPC 接口将遭受大范围的严重攻击。RPC 本身必须注册此类接口，才能为使用动态终结点的调用提供终结点解析。RestrictRemoteClients 注册表项修改系统上所有 RPC 接口的行为。默认情况下，除一些例外情况外，RestrictRemoteClients 注册表项将禁止对系统上的 RPC 接口进行远程匿名访问。因此，将不再可以匿名使用 RPC 终结点映射器接口。

尝试使用动态终结点进行调用的 RPC 客户端将首先查询服务器上的 RPC 终结点映射器，以确定 RPC 客户端应连接到的动态终结点。此查询匿名执行，即使 RPC 客户端调用本身时由 RPC 安全性执行。默认情况下，在 Microsoft Windows XP Service Pack 2 上，对 RPC 终结点映射器接口的匿名调用将失败，因为默认的 RestrictRemoteClients 功能禁止对系统上的 RPC 接口进行远程的匿名访问。因为此 RPC 接口限制，RPC 客户端运行时修改为对终结点映射器执行通过身份验证的查询。此 RPC 接口限制是 Windows XP Service Pack 2 中的默认行为。然后，RPC 客户端运行时使用集成 Windows 身份验证（以前名为 NTLM）向终结点映射器验证身份。如果实际的 RPC 客户端调用使用集成 Windows 身份验证，将执行这种身份验证。如果符合下列条件，则存在非默认配置：

  • 所描述的 RPC 注册表项和 EnableAuthEpResolution 值已创建。

  • EnableAuthEpResolution 注册表值已设置为 0。

有关 Windows XP Service Pack 2 对 RPC 服务的更改的详细信息，请参阅"RPC Interface Restrictions"（英文）(http://go.microsoft.com/fwlink/?LinkId=47371)。


Epoxy Client Out Queue Length (IMAP) 超出阈值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-02-13

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 Epoxy 性能对象的 Client Out Queue Length (IMAP) 性能计数器收集数据，以分析性能数据。

Client Out Queue Length (IMAP) 性能计数器显示队列中的邮件的数目，其中包括由 Inetinfo.exe 进程发送到 Store.exe 进程的 IMAP4 邮件。队列应始终小于 50。如果 Exchange Server 分析工具确定 Client Out Queue Length (IMAP) 计数器在示例时间段内超出峰值 50，则将显示错误信息。

Epoxy (ExIPC) 是一种共享内存机制，它启用了 Microsoft Internet 信息服务 (IIS) 进程 (Inetinfo.exe) 和 Microsoft Exchange 信息存储服务进程 (Store.exe) 以迅速来回移动数据。它允许在 Inetinfo.exe 进程和 Store.exe 进程之间进行双向的进程间通信。

注意：
Inetinfo.exe 接受来自 Internet 协议（如 WebDAV、IMAP4、NNTP、POP3 和 SMTP）的请求。

缓存 Active Directory® 信息的 Exchange 组件 DSAccess 也使用该内存。

该错误表明，在 Store.exe 进程或 Store.exe 进程所依赖的资源中存在导致队列增加的性能问题。这可能是导致服务器响应时间增加的原因。

若要解决该问题，请使用"详细信息"部分中提到的资源，以识别 Store.exe 进程或相关资源的性能瓶颈。该瓶颈可能与磁盘性能较差或 CPU 使用率较高有关。

详细信息

  • 有关如何识别 Epoxy 中不断增加的队列的信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"中的"Identifying Rising Queues in Epoxy"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关处理器瓶颈的详细信息，请参阅处理器瓶颈。

  • 有关磁盘瓶颈的详细信息，请参阅检测到磁盘瓶颈。

  • 有关解决存储性能问题的详细信息，请参阅 Microsoft 知识库文章 257725"XADM：如何为信息存储故障排除收集诊断数据"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。


Epoxy Client Out Queue Length (POP) 超出阈值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-02-13

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 Epoxy 性能对象的 Client Out Queue Length (POP) 性能计数器收集数据，以分析性能数据。

Client Out Queue Length (POP) 性能计数器显示队列中的邮件的数目，其中包括由 Inetinfo.exe 进程发送到 Store.exe 进程的 POP3 邮件。队列应始终小于 50。Exchange Server 分析工具在 5 分钟的期限内每 5 秒钟检索该计数器的一个示例。如果 Exchange Server 分析工具确定 Client Out Queue Length (POP) 计数器在示例时间段内超过了峰值 50，则会显示错误信息。

Epoxy (ExIPC) 是一种共享内存机制，它启用了 Microsoft Internet 信息服务 (IIS) 进程 (Inetinfo.exe) 和 Microsoft Exchange 信息存储服务进程 (Store.exe) 以迅速来回移动数据。它允许在 Inetinfo.exe 进程和 Store.exe 进程之间进行双向的进程间通信。

注意：
Inetinfo.exe 接受来自 Internet 协议（如 WebDAV、IMAP4、NNTP、POP3 和 SMTP）的请求。

缓存 Active Directory® 信息的 Exchange 组件 DSAccess 也使用该内存。

该错误表明，在 Store.exe 进程或 Store.exe 进程所依赖的资源中存在导致队列增加的性能问题。这可能是导致服务器响应时间增加的原因。

若要解决该问题，请使用"详细信息"部分中提到的资源，以识别 Store.exe 进程或相关资源的性能瓶颈。该瓶颈可能与磁盘性能较差或 CPU 使用率较高有关。

详细信息

  • 有关如何识别 Epoxy 中不断增加的队列的信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"中的"Identifying Rising Queues in Epoxy"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关处理器瓶颈的详细信息，请参阅处理器瓶颈。

  • 有关磁盘瓶颈的详细信息，请参阅检测到磁盘瓶颈。

  • 有关解决存储性能问题的详细信息，请参阅 Microsoft 知识库文章 257725"XADM：如何为信息存储故障排除收集诊断数据"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。


EPOXY.DLL 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查几个核心 Exchange 二进制文件是否存在：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则会显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


Epoxy 性能监视器对象不可用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 Epoxy 性能对象的 Client Out Queue Length 性能计数器收集数据，以分析性能数据。如果计数器未返回有效数据，Exchange Server 分析工具将显示基准消息。

如果性能数据收集引擎未返回有效数据，则可能出现下列情况的任意组合：

  • Epoxy 性能监视器对象已禁用。

  • Epoxy 性能监视器对象丢失或损坏。

  • Exchange Server 分析工具没有访问性能对象的相应权限。

如果某些可扩展计数器破坏了注册表，或基于 Microsoft Windows® Management Instrumentation (WMI) 的程序修改了注册表，可能会发生前两种情况。以下过程说明如何处理前两种情况。在执行该过程之前，请验证 Exchange Server 分析工具是否具有相应的权限。有关运行 Exchange Server 分析工具所需的权限的详细信息，请参阅随 Exchange Server 分析工具提供的帮助文档。要获得帮助，请打开 Exchange Server 分析工具，然后按 F1 键。

更正此错误

  1. 验证 Epoxy 性能对象是否已启用：

    1. 下载并安装可扩展性能计数器列表工具 (Exctrlst.exe)。可以在网站上的"Exctrlst.exe: Extensible Performance Counter List"(http://go.microsoft.com/fwlink/?LinkId=34436) 下载 Exctrlst.exe。

    2. 打开 Exctrlst.exe，再单击"Sort Order"，然后单击"Service"。

    3. 找到性能对象所报告的服务，并确认选中了"Performance Counters Enabled"复选框。

      如果未选中"Performance Counters Enabled"复选框，请选中该复选框，然后重新启动与性能计数器关联的服务，确认性能计数器工作正常。如果性能计数器无法正常工作，或"Performance Counters Enabled"复选框已选中，请继续执行第 2 步。

  2. 重建丢失或损坏的性能计数器，请参阅 Microsoft 知识库文章 300956"如何手动重新生成性能计数器库值"(http://support.microsoft.com/?kbid=300956)。

  3. 如果按照此知识库文章操作不能解决问题，将必须在"修复"模式下重新安装 Exchange Server，然后应用最新的 Exchange Server Service Pack。


Epoxy Store Out Queue Length (IMAP) 超出阈值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-02-13

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 Epoxy 性能对象的 Store Out Queue Length (IMAP) 性能计数器收集数据，以分析性能数据。

Store Out Queue Length (IMAP) 性能计数器显示队列中的邮件的数目，其中包括由 Store.exe 进程发送到 Inetinfo.exe 进程的 IMAP4 邮件。队列应始终小于 50。Exchange Server 分析工具在 5 分钟的期限内每 5 秒钟检索该计数器的一个示例。如果 Exchange Server 分析工具确定 Store Out Queue Length (IMAP) 计数器在示例时间段内超过了峰值 50，则会显示错误信息。

Epoxy (ExIPC) 是一种共享内存机制，它启用了 Microsoft Internet 信息服务 (IIS) 进程 (Inetinfo.exe) 和 Microsoft Exchange 信息存储服务进程 (Store.exe) 以迅速来回移动数据。它允许在 Inetinfo.exe 进程和 Store.exe 进程之间进行双向的进程间通信。

注意：
Inetinfo.exe 接受来自 Internet 协议（如 WebDAV、IMAP4、NNTP、POP3 和 SMTP）的请求。

缓存 Active Directory® 信息的 Exchange 组件 DSAccess 也使用该内存。

该错误表明，在 Inetinfo.exe 进程或 Inetinfo.exe 进程所依赖的资源中存在导致队列增加的性能问题。这可能是导致服务器响应时间增加的原因。因此，用户将遇到服务器响应延迟。

若要解决该问题，请使用"详细信息"部分中提到的资源，以识别 Inetinfo.exe 或相关资源的性能瓶颈。该瓶颈可能与磁盘性能较差或 CPU 使用率较高有关。

详细信息

  • 有关如何识别 Epoxy 中不断增加的队列的信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"中的"Identifying Rising Queues in Epoxy"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关处理器瓶颈的详细信息，请参阅处理器瓶颈。

  • 有关磁盘瓶颈的详细信息，请参阅检测到磁盘瓶颈。

  • 有关排除存储性能问题的详细信息，请参阅 Microsoft 知识库文章 257725"XADM：如何为信息存储故障排除收集诊断数据"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。


Epoxy Store Out Queue Length (POP) 超出阈值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-02-13

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 Epoxy 性能对象的 Store Out Queue Length (POP) 性能计数器收集数据，以分析性能数据。

Store Out Queue Length (POP) 性能计数器显示队列中的邮件的数目，其中包括由 Store.exe 进程发送到 Inetinfo.exe 进程的 POP3 邮件。队列应始终小于 50。Exchange Server 分析工具在 5 分钟的期限内每 5 秒钟检索该计数器的一个示例。如果 Exchange Server 分析工具确定 Store Out Queue Length (POP) 计数器在示例时间段内超过了峰值 50，则会显示一个错误信息。

Epoxy (ExIPC) 是一种共享内存机制，它启用了 Microsoft Internet 信息服务 (IIS) 进程 (Inetinfo.exe) 和 Microsoft Exchange 信息存储服务 (Store.exe) 进程以迅速来回移动数据。它允许在 Inetinfo.exe 进程和 Store.exe 进程之间进行双向的进程间通信。

注意：
Inetinfo.exe 接受来自 Internet 协议（如 WebDAV、IMAP4、NNTP、POP3 和 SMTP）的请求。

缓存 Active Directory® 信息的 Exchange 组件 DSAccess 也使用该内存。

该错误表明，在 Inetinfo.exe 进程或 Inetinfo.exe 进程所依赖的资源中存在导致队列增加的性能问题。这可能是导致服务器响应时间增加的原因。因此，用户将遇到服务器响应延迟。

若要解决该问题，请使用"详细信息"部分中提到的资源，以识别 Inetinfo.exe 或相关资源的性能瓶颈。该瓶颈可能与磁盘性能较差或 CPU 使用率较高有关。

详细信息

  • 有关如何识别 Epoxy 中不断增加的队列的信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"中的"Identifying Rising Queues in Epoxy"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关处理器瓶颈的详细信息，请参阅处理器瓶颈。

  • 有关磁盘瓶颈的详细信息，请参阅检测到磁盘瓶颈。

  • 有关排除存储性能问题的详细信息，请参阅 Microsoft 知识库文章 257725"XADM：如何为信息存储故障排除收集诊断数据"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。


访问 Exchange Server 时出错
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具不能访问 Exchange 服务器。此错误指示未在 Active Directory® 目录服务中找到指定的 Exchange 服务器的配置信息。

更正此错误

  • 确保已正确键入服务器名。

  • 仅输入服务器的主机名或 NetBIOS 名称（例如，Server1），而不用输入完全限定域名（例如，Server1.example.com）。

  • 验证您是否具有访问此服务器的 Active Directory 配置信息所需的权限。


访问 Exchange Server 信息时出错
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具在访问 Exchange 服务器的 Active Directory® 目录服务配置信息时出现问题。

若要更正此错误，请执行下列操作：

  • 验证当前登录帐户是否具有读取 Active Directory 中 Exchange 服务器配置信息的相应权限。

  • 验证 Active Directory 域控制器是否已进行网络连接。

  • 向 Exchange Server 分析工具中输入用于访问 Active Directory 的显式帐户凭据。

  • 在 Exchange Server 分析工具中指定 Active Directory 域控制器。

  • 确保您指定的 Exchange 服务器存在并正确键入了服务器名。


访问邮件跟踪日志时出错
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-06

Microsoft® Exchange Server 分析工具会查询 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 类的每个实例的 MessageID 属性。

如果 Exchange Server 分析工具没有收到查询的结果，则 Exchange Server 分析工具将显示一个错误。

发生此错误的最可能原因是已禁用邮件跟踪中心。

邮件跟踪中心（在已启用时）将记录有关发件人、邮件以及邮件收件人的信息。具体地说，您可以复查统计信息，如发送和接收邮件的时间、邮件大小和优先级以及邮件收件人列表。还可以记录电子邮件的主题行。邮件跟踪中心将搜索各种邮件，如系统邮件、公用文件夹邮件以及电子邮件。

必须在要跟踪其邮件的每一台服务器上启用邮件跟踪中心。启用后，通过服务器路由的所有邮件都将添加到邮件跟踪日志中。

Exchange Server 分析工具要求为其启用邮件跟踪以便启动其扫描。

注意：
执行此步骤需要有下列权限：本地管理员组的成员，以及在管理组级别应用了 Exchange 管理员角色的组的成员
在服务器上启用邮件跟踪中心

  1. 在 Exchange 系统管理器中，展开"服务器"，用鼠标右键单击要启用邮件跟踪的服务器，再单击"属性"。

  2. 在"常规"选项卡上，选中"启用邮件跟踪"复选框。

  3. 若要记录发送到服务器、由服务器发出或经过服务器的任何邮件的主题，请选中"启用主题日志记录和显示"复选框。

    注意：
    如果启用主题日志记录，则可能导致性能方面有一些降低。

  4. 在"日志文件维护"下，可以防止删除日志文件，或修改日志文件所保留的时间长度。跟踪日志的默认保留时间为 7 天。

    注意：
    在处理大量邮件的服务器上，跟踪日志的增长速度很快。应确保有足够的磁盘空间来存放日志文件和供使用该磁盘的其他服务或应用程序使用。

  5. 单击"确定"或"应用"。不需要重新启动服务来使上述更改生效。

有关如何使用邮件跟踪中心的详细信息，请参阅 Microsoft 知识库文章 262162"XADM:Using the Message Tracking Center to Track a Message"（XADM：使用邮件跟踪中心来跟踪邮件）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162)。

有关如何解决 Exchange Server 传输问题的详细信息，请参阅 Microsoft 知识库文章 821910"如何解决 Exchange Server 2003 传输问题"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821910)。


升级 ACL 时出错
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-02-15

Microsoft Exchange 分析工具查询 Win32_NTLogEvent Microsoft Windows Management Instrumentation (WMI) 类，以确定是否在前一个小时内记录了 MSExchangeIS 的事件 9551 错误。

如果 Exchange 分析工具发现在前一个小时内记录了事件 9551 错误，Exchange 分析工具将计算该小时内记录的事件 9551 错误的总数。

最后，如果 Exchange 分析工具发现事件 9551 错误在前一个小时内记录了 20 次或 20 次　以上，Exchange 分析工具将显示警告。

此错误表明，可能有用户帐户出现在邮箱资源或公用文件夹的访问控制列表 (ACL) 中，但是没有与有效的 Active Directory 目录服务对象关联。

运行 Microsoft Exchange Server 2003 或 Exchange 2000 Server 的服务器上的邮箱只有在 Active Directory 中按有效的 Active Directory 目录服务用户帐户表示，才可以进行访问。

如果在基于 Exchange Server 5.5 的计算机上删除了邮箱后未更新 Exchange 2000 Server 或 Exchange Server 2003 邮箱资源或公用文件夹，则可以创建在 Active Directory 中未有效表示的帐户。

如果已删除的邮箱帐户仍保留在邮箱资源或公用文件夹的 ACL 中，每次访问该邮箱资源或公用文件夹并且 Exchange 尝试解析列出的帐户时，将无法解析在 Active Directory 中未有效表示的帐户。此过程可能表现为性能问题。

若要解决此问题，请执行下列操作：

  • 确保安装了 Exchange 2000 Server Service Pack 3 (SP3) 或更高版本。若要获取最新的 Exchange 2000 Server Service Pack，请参阅 Microsoft 知识库文章 301378"如何获取最新的 Exchange 2000 Server Service Pack"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378)。

  • 使用 Exchange 系统管理器手动将无效的邮箱帐户从 ACL 中删除。

  • 如果 Exchange 环境处于 Exchange 混合模式，请对信息存储运行 DS/IS 一致性检查程序。

  • 如果 Exchange 环境处于 Exchange 纯模式，请按照 Microsoft 知识库文章 324323"XADM：在访问控制列表转换期间跳过 Active Directory 中未表示的用户帐户"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=324323) 中的指导操作。

若要使用 Exchange 系统管理器手动将无效的帐户从 ACL 中删除，请执行下列操作：

  1. 启动 Exchange 系统管理器并找到 9551 错误标识的文件夹。

  2. 右键单击该文件夹并选择"属性"。

  3. 选择"权限"选项卡，然后单击"客户端权限"。

  4. 在"名称"窗格中，选择 9551 错误标识的用户帐户，然后单击"删除"按钮将该帐户从 ACL 中删除。
若要在 Exchange 混合模式下对信息存储运行 DS/IS 一致性检查程序，请执行下列操作：

  1. 在 Exchange Server 5.5 管理员程序中，单击包含信息存储的 Exchange 5.5 Server 计算机。

  2. 在"文件"菜单中，单击"属性"，然后单击"高级"选项卡。

  3. 单击"一致性调整"。

  4. 单击选中"从公用文件夹权限中删除未知用户帐户"和"从邮箱权限中删除未知用户帐户"复选框，然后单击"所有不一致性"。

  5. 单击清除所有其他复选框，然后单击"确定"。

详细信息

有关此问题的详细信息，请参阅下列 Microsoft 知识库文章和 Exchange Server 资源：

  • Events and Errors Message Center: Event Details: MSExchangeIS Mailbox Store Event 9551 details（事件和错误消息中心：事件详细信息：MSExchangeIS 邮箱存储事件 9551 详细信息）(http://go.microsoft.com/fwlink/?LinkId=83189)

  • Microsoft 知识库文章 301378"如何获取最新的 Exchange 2000 Server Service Pack"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378)

  • Microsoft 知识库文章 324323"XADM：在访问控制列表转换期间跳过 Active Directory 中未表示的用户帐户"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=324323)


ESE.DLL 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-04-21

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查几个核心 Exchange 二进制文件是否存在：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则会显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=33457)。


ESEUTIL.EXE 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查是否存在下列几个核心 Exchange 二进制文件：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


EXCDO.DLL 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查几个核心 Exchange 二进制文件是否存在：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则会显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


EXCHMEM.DLL 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查下列几个核心 Exchange 二进制文件：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


EXMIME.DLL 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查几个核心 Exchange 二进制文件是否存在：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则会显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


EXOLEDB.DLL 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查是否存在下列几个核心 Exchange 二进制文件：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


EXPOP3.DLL 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查下列几个核心 Exchange 二进制文件：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


EXPOP3.DLL 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查几个核心 Exchange 二进制文件是否存在：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则会显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


EXRES.DLL 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查是否存在下列几个核心 Exchange 二进制文件：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


EXSMTP.DLL 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查几个核心 Exchange 二进制文件是否存在：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则会显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


EXSMTP.DLL 文件版本已过时
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

错误消息

简介

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 EXSMTP.DLL 的 Version 关键字的值。如果 Exchange Server 分析工具确定 EXSMTP.DLL 的 Version 关键字不等于 6556.0，则会显示警告。

该警告说明此 Exchange Server 计算机上的 EXSMTP.DLL 版本来自 2004 年 5 月的 Exchange 2000 Server Post-Service Pack 3 第 1 版的更新汇总。而更高版本的更新汇总已经可供下载。

解决此警告问题

  1. 从"Downloads for Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=33457) 下载最新的更新（2004 年 8 月）。

  2. 查看 Microsoft 知识库文章 870540"Availability of the August 2004 Exchange 2000 Server Post-Service Pack 3 Update Rollup"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540)，了解有关最新更新的信息。

  3. 对 Exchange Server 计算机进行完整备份。

  4. 应用 2004 年 8 月更新。

有关安装此更新以及其他 Exchange Server 更新的详细信息，请参阅 Microsoft 知识库文章 328839"HOW TO：应用 Exchange Service Pack 和修复程序"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)。


Exchange ActiveSync 跟踪当前已启用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否对 Exchange ActiveSync® 启用了跟踪：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Tracing\Microsoft Server ActiveSync\MasSync\Enabled

如果 Exchange Server 分析工具发现 Enabled 的值存在并配置为大于 0 的值，则会显示警告。

Exchange ActiveSync 是作为 Internet 信息服务 (IIS) 中的 Internet 服务器应用程序编程接口 (ISAPI) 扩展实现的。由于 IIS、Exchange ActiveSync 以及许多使用 Exchange ActiveSync 的客户端设备都包含固有的跟踪功能，因此不需要使用 Microsoft Windows Server™ 2003 的固有跟踪功能。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\Software\Microsoft\Windows NT\CurrentVersion\Tracing\Microsoft Server ActiveSync\MasSync

  3. 删除 Enabled 值。

  4. 关闭注册表编辑器，并重新启动 Exchange Server 计算机，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请阅读 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Exchange ActiveSync 和 Exchange ActiveSync 客户端的跟踪和日志记录功能的详细信息，请参阅下列知识库文章：

  • 330463"XCCC:Server ActiveSync HTTP 错误代码疑难解答"(http://support.microsoft.com/kb/330463/zh-cn)

  • 330461"HOW TO:Server ActiveSync 疑难解答"(http://support.microsoft.com/kb/330461/zh-cn)

  • 822176"Exchange 2003'始终使用最新通知'疑难解答"(http://support.microsoft.com/kb/822176/zh-cn)


Exchange 二进制文件版本高于 Exchange Server 上安装的版本
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定下列几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中都检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中都检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值大于 Exchange Server 的 Version 值，则显示警告消息。较新的版本号说明文件的版本高于预期值。如果安装了修补程序，则会出现此情况。

解决此警告问题

  1. 不需要执行任何操作。警告消息仅仅说明存在较高版本的文件，这可能是由于安装修补程序或者其他更新所造成的。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


此 Exchange 群集节点也是一个域控制器
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Microsoft Windows® Management Instrumentation (WMI) 对象（Win32_ComputerSystem 类），以确定服务器的 DomainRole 值。DomainRole 值代表某计算机在域中的角色。下表列出了 DomainRole 的有效值。

值 | 含义
0 | 独立工作站
1 | 成员工作站
2 | 独立服务器
3 | 成员服务器
4 | 备份域控制器
5 | 主域控制器

此外，Exchange Server 分析工具还查询 ClusSvc WMI 对象（Windows 群集服务对象，Win32_Service 类），以确定其 Started 值。值为 True 意味着群集服务已启动，值为 False 意味着服务未启动。

如果 Exchange Server 分析工具确定 Exchange Server 计算机（已启动群集服务）上的 DomainRole 的值大于 3，则显示错误。此错误表明运行 Exchange 服务器的 Windows 服务器群集的节点是域控制器。

不支持将 Exchange Server 群集节点作为域控制器来运行的配置。

更正此错误

  1. 选择一个非群集服务器充当域控制器，然后运行 Active Directory 安装向导 (dcpromo) 以提升该服务器。

  2. 针对新的域控制器对 Active Directory® 目录服务进行配置后，等待现有的 Active Directory 内容复制到新的服务器。

    根据 Active Directory 的大小，此操作可能会花费数小时。

  3. 在群集服务器上运行 Active Directory 安装向导 (dcpromo) 以降级该服务器，然后删除 Active Directory。

有关提升和降级域控制器的详细信息，请参阅 Microsoft 知识库文章 238369"在 Windows 2000 中提升和降级域控制器"(http://support.microsoft.com/kb/238369/zh-cn)。


Exchange 错误报告已禁用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-04-21

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已启用 Exchange 错误报告：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\DisableErrorReporting

如果 Exchange Server 分析工具发现 DisableErrorReporting 的值为 1，则会显示警告。值为 1 意味着 Exchange 错误报告已禁用。

对 Microsoft 错误报告（也称为 Windows 错误报告、Microsoft 事件报告和自动错误报告）的支持最初是在 Exchange 2000 Server Service Pack 2 中添加的。Exchange Server 2003 包含增强版本的 Microsoft 错误报告（称为 Exchange 错误报告），此增强版本与公司错误报告集成在一起，简化了管理员的错误报告过程，并为 Exchange Server 2003 收件人更新服务提供增强的报告功能。

Exchange 错误报告使 Exchange Server 管理员可以使用 HTTPS 并通过 Internet 将崩溃错误以及其他致命错误传输到 Microsoft 错误报告服务器。建议将错误报告发送到 Microsoft Online Crash Analysis。从 Exchange 服务器中收集致命错误数据有助于 Exchange 产品组发现并修复您所使用的软件中的错误。

如果在使用 Exchange 系统管理器时或者在安装了 Exchange 系统管理器的计算机上使用 Active Directory 用户和计算机执行与 Exchange 有关的任务时出现致命错误，Exchange 错误报告将通知管理员出现此错误，并询问是否要将错误报告给 Microsoft。此外，Exchange 错误报告还捕获并报告 Microsoft Exchange 系统助理、Microsoft Exchange 信息存储以及其他 Exchange 服务遇到的错误。而且，由于收件人更新服务遇到的错误可能使系统助理组件处于不正确的状态，因此 Exchange 错误报告还报告收件人更新服务中发生的访问冲突以及其他内部错误。

通过在 Exchange 系统管理器中的服务器属性页上选中一个相应的框，可以配置每一台 Exchange 服务器以发送致命错误信息。

配置 Exchange 2000 Server 或 Exchange Server 2003 将致命服务器错误数据发送给 Microsoft

  1. 打开 Exchange 系统管理器。

  2. 展开"管理组"，展开您的管理组，展开"服务器"，用鼠标右键单击您的服务器，再单击"属性"。如果"管理组"节点未显示在 Exchange 系统管理器中，请展开"服务器"，用鼠标右键单击您的服务器，再单击"属性"。

  3. 在"<Server Name> 属性"页的"常规"选项卡上，选中"自动将致命的服务错误信息发送到 Microsoft"复选框，再单击"应用"。

  4. 单击"是"确认要启用 Exchange 错误报告。

  5. 单击"确定"。

当遇到致命错误时，会创建一个压缩的错误报告文件（通常为 10-50 KB）。此报告包含一个转储文件以及其他信息。转储文件包含遇到错误的进程的有关信息。尽管在各个编程级别（例如，线程级别、接口级别以及方法或函数级别）都可能发生错误，但这些错误均发生在单个进程的上下文内。转储文件通常包含出错进程的有关信息，例如，每个线程执行的工作的详细信息、进程使用的各个内存区域、系统信息以及其他相关的调试信息。对于 Exchange Server，错误报告还包含 Exchange Server 的状态信息、操作系统版本信息、计算机硬件的详细信息、计算机的 IP 地址以及用于标识产品许可证的数字产品 ID。

虽然 Microsoft 并不有意地收集个人信息，但我们承认收集的信息中可能有一部分包含用于唯一地标识您的系统的信息。但是，Microsoft 不以这种方式使用所收集的数据，而仅仅将它用于崩溃报告和错误修复。有关详细信息，请参阅错误报告策略"Data Collection Policy"（英文）(http://go.microsoft.com/fwlink/?LinkId=33818)。


此 Exchange 前端服务器的 Boot.ini 文件中包含 /3GB 启动开关
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange Server 计算机上分配给用户模式进程的虚拟地址空间量 (MaxProcessMemorySize)。Exchange Server 分析工具还检查 root\MicrosoftExchangeV2 命名空间中的 Exchange_Server WMI 类，以确定 IsFrontEndServer 关键字的值。值为 False 意味着 Exchange Server 计算机不是前端服务器。值为 True 意味着 Exchange Server 计算机是前端服务器。

如果 Exchange Server 分析工具确定 MaxProcessMemorySize 关键字的值不等于 2097024，而 IsFrontEndServer 项设置为 True，将显示警告。

此警告意味着 Exchange Server 计算机未正确配置最佳内存使用，因为 Boot.ini 文件中设置了 /3GB 启动开关。此开关应当只用在运行下列任意操作系统并且内存不低于 1 GB 的 Exchange 服务器上：

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

重要信息：
/3GB 开关不应当用在 Windows 2000 Server 上，因为它不被支持，并且可能导致应用程序或操作系统崩溃。此外，只有在安装了 1 GB 或更多物理内存时，前面列出的操作系统才支持 /3GB 开关。

如果运行 Microsoft Windows 2000 Server 或 Windows Server 2003 的服务器的 Boot.ini 文件中包含 /3GB 参数，则 Windows 会将最大虚拟地址空间 4 GB 中的 3 GB 分配给用户进程，将 1 GB 分配给内核。正常情况下（当不使用 /3GB 参数时），Windows 为用户进程分配 2 GB，为内核分配 2 GB。因此，当使用 /3GB 开关时，占用内存的应用程序有大量的虚拟内存地址空间可使用，因此性能得到改善。

使用 /3GB 开关主要对驻留用户邮箱的 Exchange 服务器上占用内存的应用程序（如 Store.exe 进程）有利。前端服务器不驻留用户邮箱，因此，在前端服务器上使用 /3GB 开关没有帮助。

解决此警告问题

  1. 在 Windows 资源管理器中，导航至系统分区。

  2. 如果看不到 Boot.ini 文件，可能是由于"文件夹选项"设置为"隐藏受保护的操作系统文件"。如果是这种情况，请在 Windows 资源管理器窗口中，依次"工具"、"文件夹选项"、"查看"选项卡。清除"隐藏受保护的操作系统文件（推荐）"复选框。当出现警告对话框时，单击"是"。

  3. 当 Boot.ini 文件显示在资源管理器中后，用鼠标右键单击该文件，再单击"打开方式"，然后选择"记事本"打开该文件。

  4. 在 [Operating Systems] 部分中，从所有启动行中删除以下开关：/3GB

  5. 保存更改，关闭记事本。

  6. 重新启动计算机，以使更改生效。

有关使用 /3GB 启动开关的更多详细信息，请参阅下列 Microsoft 知识库文章：

  • 297812"How to Use the 4GT RAM Tuning Feature"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901"The effects of 4GT tuning on system Page Table Entries"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 31679"如何使用 Boot.ini 文件中的 /USERVA 开关优化 /3GB 配置"(http://support.microsoft.com/?kbid=316739)

  • 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372"如何在 Exchange Server 2003 中优化内存使用"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Exchange IFS 驱动器未明确地从 Windows 备份程序中排除
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，确定已从使用备份程序的备份中排除的文件和文件夹：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

Exchange Server 分析工具明确地查找一个名为 Exchange IFS 的字符串值。

Exchange Server 分析工具还读取以下注册表项，以获取表示 Exchange 可安装文件系统 (IFS) 驱动器的驱动器号：

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

在 Exchange 2000 Server 中，默认驱动器号是 M。在 Exchange Server 2003 中，IFS 驱动器默认情况下是关闭的。

如果 Exchange Server 分析工具发现 FilesNotToBackup 项不包含名为 Exchange IFS 的字符串值，或者虽然包含 Exchange IFS，但 Exchange IFS 的数值数据不等于 M:\* /s（其中 M 是表示 IFS 的驱动器号），将显示警告。

默认情况下，当启用 IFS 驱动器号映射时，Exchange IFS 会添加到 FilesNotToBackup 注册表项中。M:\ 驱动器是 Exchange 存储的逻辑视图，而不是真正的驱动器，对它进行备份会导致严重的问题，如附件丢失。此外，备份软件可能不会在适当的情况下对日志文件进行截断，从而导致意外地产生服务器运行空间不足的情况。

如果您使用的不是备份程序，可以放心地忽略此警告。如果您使用的是备份程序，则建议将 IFS 驱动器排除在所有备份作业之外。如果使用备份程序或其他任何备份程序备份 IFS 驱动器，可能会破坏信息存储数据库，丢失数据，并无法从 IFS 驱动器的备份中还原数据。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

  3. 用鼠标右键单击"FilesNotToBackup"，在单击"新建"|"多字符串值"。在"名称"中键入 Exchange IFS，然后按 Enter。

  4. 在右侧窗格中，双击"Exchange IFS"，在"数值数据"中输入 M:\* /s。如果系统使用的不是默认的驱动器号 M，请确保使用正确的驱动器号。

  5. 关闭注册表编辑器。

有关 Microsoft Windows® 注册表的详细信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关备份和还原 Exchange 的详细信息，请参阅"Exchange Server 2003 灾难恢复操作指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=a58f49c5-1190-4fbf-aede-007a8f366b0e&displaylang=zh-cn)。有关其他信息，请参阅下列知识库文章：

  • 258243"如何使用 Windows 备份程序备份和还原 Exchange 计算机"(http://support.microsoft.com/kb/258243/zh-cn)

  • 233427"Files and folders that are not backed up when the Ntbackup.exe tool is used in Windows Server 2003, Windows XP, and Windows 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=233427)

有关使用防病毒软件扫描 IFS 驱动器时可能出现的问题的详细信息，请参阅下列知识库文章：

  • 298924"XADM:不要备份或扫描 Exchange 2000 驱动器 M"(http://support.microsoft.com/kb/298924/zh-cn)

  • 300608"XADM：当您尝试装入数据库时可能会显示'C1041737'错误和事件 ID 470 消息"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046"XADM:看不到用户文件夹中的日历项目"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


此 Exchange 邮箱服务器有 1 GB 或更多内存，但 Boot.ini 文件中未设置 /3GB
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询两个 Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange 服务器中的物理内存量以及分配给用户模式进程的虚拟地址空间量。下表描述了 Exchange Server 分析工具所评估的类和关键字。

查询的类 | 查询的关键字 | 描述
Win32_OperatingSystem | MaxProcessMemorySize | 可以分配给进程的最大内存 KB 数。
Win32_OperatingSystem | OSProductSuite | 操作系统的已安装和已授权的系统产品。
Win32_ComputerSystem | TotalPhysicalMemory | 计算机中安装的随机访问内存 (RAM) 的字节数。

如果 Exchange Server 分析工具确定 Exchange Server 计算机运行的不是 Windows 2000 Server、安装的物理内存量不低于 1 GB，并且 MaxProcessMemorySize 的值大于 2097024 但小于 3104640，则会显示警告。

此警告意味着 Exchange 服务器不符合 Microsoft 知识库文章 266096"Exchange 2000 requires /3GB switch with more than 1 gigabyte of physical RAM"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096) 中提出的要求。这不是推荐的生产配置。

Microsoft Windows Server™ 2003 支持两个启动开关：/3GB 和 /USERVA。这两个开关可用于调整内存及内存地址空间的分配。无论系统中的物理内存为多少，Windows 都使用 4 GB 的虚拟地址空间，其中 2 GB 分配给用户模式进程（例如，应用程序），余下的 2 GB 分配给内核模式进程（例如，操作系统和内核模式驱动程序）。在物理内存不低于 1 GB 的系统上，这两个启动开关可用于为应用程序分配更多内存 (3 GB)，为操作系统分配较少的内存 (1 GB)。更多的虚拟地址空间有助于减少 Exchange 信息存储进程的虚拟地址空间中的内存碎片。

/3GB 开关用于实现内存分配上的这一更改。在系统的 Boot.ini 文件中输入此开关，并将在系统重新启动后生效。此开关应当只用在运行下列任意操作系统并且内存不低于 1 GB 的 Exchange 服务器上：

  • Microsoft Windows Server 2003 标准版

  • Microsoft Windows Server 2003 企业版

  • Microsoft Windows Server 2003 Datacenter 版

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

重要信息：
/3GB 开关不应当用在 Windows 2000 Server 上，因为它不被支持，并且可能导致应用程序或操作系统崩溃。此外，只有在安装了 1 GB 或更多物理内存时，前面列出的操作系统才支持 /3GB 开关。

/USERVA 开关是 Windows Server 2003 中新增加的，其用途是更精确地控制虚拟地址空间在用户模式进程与内核模式进程之间的划分。此开关应仅仅用于支持它的应用程序（如 Exchange 2000 Server 和 Exchange Server 2003），并且应当与这些应用程序支持的特定值一起使用。

注意：
Microsoft 产品支持服务不支持任何 /USERVA 设置。客户应仅仅在制造商的建议下将此设置添加到 Boot.ini 文件中。

当用在 Exchange Server 2003 系统上时，/USERVA 唯一支持的值是 3030（例如，/USERVA=3030）。该值会导致为操作系统额外分配 40 MB，并使您可以在不消耗所有可用系统资源的情况下添加更多用户。

解决此警告问题

  1. 用鼠标右键单击"我的电脑"，然后选择"属性"。将出现"系统属性"对话框。

  2. 单击"高级"选项卡。

  3. 在"启动和故障恢复"区域中，单击"设置"。将出现"启动和故障恢复"对话框。

  4. 在"系统启动"区域中，单击"编辑"。这将在记事本中打开 Windows Boot.ini 文件。

  5. 在 [Operating Systems] 部分中，将下列开关添加到包含 /fastdetect 开关的启动行的末尾：/3GB /USERVA=3030

  6. 保存更改，关闭记事本。

  7. 单击"确定"两次关闭打开的对话框，然后重新启动 Exchange Server 计算机，以使更改生效。

有关优化 Exchange Server 的内存使用和性能的详细信息，请参阅下列 Microsoft 知识库文章：

  • 266096"Exchange 2000 requires /3GB switch with more than 1 gigabyte of physical RAM"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096)

  • 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://support.microsoft.com/kb/325044/zh-cn)

  • 815372"如何在 Exchange Server 2003 中优化内存使用"(http://support.microsoft.com/kb/815372/zh-cn)

  • 810371"XADM:在基于 Windows 2003 Server 的 Exchange Servers 上使用 /Userva 参数"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371)

  • 823440"在基于 Windows Server 2003 的系统中安装 Exchange Server 2003 时必须使用 /3GB 参数"(http://support.microsoft.com/kb/823440/zh-cn)

  • 822178"Exchange Server 2003 功能的依存关系和要求概述"(http://support.microsoft.com/kb/822178/zh-cn)


已启用 Exchange 提供程序跟踪
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-06-20

Microsoft Exchange Server 分析工具查询 Active Directory 目录服务以确定所有具有 msExchExchangeServer 对象类的对象的 serialNumber 属性值。如果字符串值包含"Version 5.5"，则说明计算机运行的是 Microsoft Exchange Server 5.5。如果字符串值包含"Version 6.0"，则说明计算机运行的是 Microsoft Exchange 2000 Server。如果字符串值包含"Version 6.5"，则说明计算机运行的是 Microsoft Exchange Server 2003。如果字符串值包含"Version 8.0"，则说明计算机运行的是 Microsoft Exchange Server 2007。

Exchange 分析工具还查询 CIM_Datafile Microsoft® Windows® Management Instrumentation (WMI) 类，以确定 Exchange 传输提供程序 Emsmdb32.dll 的 Version 关键字的值。Version WMI 关键字代表此文件的内部版本号。

最后，Exchange 分析工具查询以下注册表项以确定是否已配置和启用 Exchange 提供程序跟踪。

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Enable Tracing

如果下列条件为真，则 Exchange 分析工具将显示一条错误消息：

  • 服务器未运行 Exchange Server 2007

  • Emsmdb32.dll 的 Version 关键字是 6.5.7233.47 或更高版本

  • 存在 HKML\Software\Microsoft\Exchange\Exchange Provider\Enable Tracing 项，且该项已设置为一个非 0 值

此错误表明计算机上已启用 Exchange 传输提供程序跟踪。

6.5.7233.47 和更高版本的 Exchange 传输提供程序具有内置的跟踪功能。.ttd 文件启用对下列程序的跟踪：

  • 运行 Exchange Server 2003 的服务器上任何使用 MAPI 的程序

  • 使用 Microsoft Exchange 系统管理工具安装的任何程序。

应仅对主动故障排除启用 Exchange 传输提供程序跟踪，否则可能会对典型服务器性能产生负面影响。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保已了解在出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
在 Exchange Server 2003 上禁用 Exchange 提供程序跟踪

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 浏览：HKML\Software\Microsoft\Exchange\Exchange Provider\

  3. 在右侧导航窗格中：

    1. 右键单击并"删除""启用跟踪"子项，或者

    2. 双击"启用跟踪"。

  4. 配置"启用跟踪"子项，使其值为 0。

  5. 关闭注册表编辑器。

  6. 重新启动 Exchange 信息存储服务，以便使这些更改生效。

在编辑注册表之前，有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986 Microsoft Windows 注册表说明。


Exchange 管理服务未作为 LocalSystem 运行
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Microsoft Exchange Management (MSExchangeMGMT) 服务的 StartName 属性值。如果 Exchange Server 分析工具发现运行 Exchange 管理服务的帐户不是 LocalSystem (SYSTEM) 帐户，则 Exchange Server 分析工具将显示错误。

该错误说明 Exchange 管理服务未在支持的配置中运行。如果在任何其他帐户下运行 Exchange 管理服务，将造成权限和访问错误。

若要解决该错误，必须将 Exchange 管理服务配置为在 LocalSystem (SYSTEM) 帐户下启动。

配置 Exchange 管理服务帐户

  1. 打开"服务"Microsoft 管理控制台 (MMC) 管理单元。

  2. 找到并停止 Microsoft Exchange Management 服务。

  3. 双击 Microsoft Exchange Management 服务。

  4. 在"Microsoft Exchange Management 属性"页的"登录"选项卡上，在"登录作为"下选择"本地系统帐户"，再单击"应用"。

  5. 在"服务状态"下，单击"启动"，再单击"确定"。

  6. 关闭"服务"管理单元。

有关在 LocalSystem 帐户下运行 Exchange 服务的详细信息，请参阅 Microsoft 知识库文章 239762"Exchange Services Run Under LocalSystem"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)。


Exchange Management 服务已停止
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Process Microsoft Windows® Management Instrumentation (WMI) 类，以确定 MSExchangeMGMT 实例（代表 Microsoft Exchange Management 服务）的 Started 关键字的值。如果 Exchange Server 分析工具发现 MSExchangeMGMT 实例的 Started 关键字的值不等于 True，则会显示警告。

Exchange Management 服务是在 Exchange 2000 Server Service Pack 2 中引入的。Exchange Server 邮件跟踪中心功能以及 Exchange 系统管理器的某些功能依赖于此服务才能工作。

Exchange Management 服务使您可以通过用户界面来指定 Exchange Server 2003 或 Exchange 2000 Server 使用哪个域控制器或全局编录服务器访问 Active Directory® 目录服务。此服务对于邮件跟踪功能也是必需的。可以禁用此服务，而不会影响到 Exchange 的核心功能。但是，当审核 Exchange Server 功能时，可能需要路由邮件的所有 Exchange Server 计算机上的邮件跟踪功能。

注意：
由于前端服务器的最常见用途是访问邮件而不是路由邮件，因此您可能发现不需要在前端服务器上运行 Exchange Management 服务。

配置 Exchange Management 服务自动启动

  1. 打开"服务"Microsoft 管理控制台 (MMC) 管理单元。

  2. 双击"Microsoft Exchange Management"服务。

  3. 在"Microsoft Exchange Management 的属性"页的"常规"选项卡上，从"启动类型"对话框中选择"自动"，再单击"应用"。

  4. 在"服务状态"下，单击"启动"，再单击"确定"。

有关 Exchange Management 服务的详细信息，请参阅 Microsoft 知识库文章 307413"XGEN: General Information on Exchange Management Service"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307413)。

有关管理 Exchange 的详细常规信息，请参阅"Exchange Server 2003 管理指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=98e45481-1458-4809-97d6-50d8aeebd8a1&DisplayLang=zh-cn)。


Exchange 2000 Server 未运行最新的 Service Pack
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 Exchange Server 对象的 versionNumber 属性值。versionNumber 属性表示运行在计算机上的 Exchange Server 的版本。

Exchange Server 分析工具还查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 STORE.EXE 进程的 Version 关键字的值。如果 Exchange Server 分析工具确定 STORE.EXE 的 Version 关键字的值大于 4416 并且小于或等于 6249，则显示警告。

此警告说明 Exchange Server 计算机上所运行的 Exchange 版本的代码不是最新的可用代码。

解决此警告问题

  1. 下载 Exchange 2000 Server Service Pack 3 (http://go.microsoft.com/fwlink/?LinkId=17058)。

  2. 查看"Exchange 2000 Server Service Pack 3 Deployment Guide"（英文）(http://go.microsoft.com/fwlink/?LinkId=12337)。

  3. 下载最新的更新（2004 年 8 月）(http://go.microsoft.com/fwlink/?LinkId=33457)。

  4. 查看 Microsoft 知识库文章 870540"Availability of the August 2004 Exchange 2000 Server Post-Service Pack 3 Update Rollup"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540)，了解最新的更新信息。

  5. 对 Exchange Server 计算机进行完整备份。

  6. 应用 Exchange 2000 Server Service Pack 3。

  7. 应用 2004 年 8 月更新。

有关获取 Exchange 2000 Server 的最新 Service Pack 的详细信息，请参阅 Microsoft 知识库文章 301378"如何获取最新的 Exchange 2000 Server Service Pack"(http://support.microsoft.com/?kbid=301378)。

有关安装此更新以及其他 Exchange Server 更新的详细信息，请参阅知识库文章 328839"HOW TO：应用 Exchange Service Pack 和修复程序"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)。


Windows Server 2003 不支持 Exchange 2000 Server
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定运行于 Exchange Server 计算机上的 Microsoft Windows® 操作系统的版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 的值为 4.0 说明计算机正在运行 Microsoft Windows NT® Server 4.0。值为 5.0 说明计算机正在运行 Windows 2000 Server，值为 5.2 说明计算机正在运行 Windows Server™ 2003。

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定具有对象类 msExchExchangeServer 的所有对象的 serialNumber 属性值。如果字符串值包含"Version 5.5"，说明计算机运行的是 Microsoft Exchange Server 5.5 版。如果字符串值包含"Version 6.0"，说明计算机运行的是 Exchange 2000 Server。如果字符串值包含"Version 6.5"，说明计算机运行的是 Exchange Server 2003。

如果 Exchange Server 分析工具发现 CurrentVersion 的值等于 5.2 并且 serialNumber 的值包含"Version 6.0"，则会显示错误。这不是受支持的配置，应尽快更正此错误。

更正此错误

  1. 执行下列操作之一：

    • 在运行受支持的操作系统的服务器上安装 Exchange 2000 Server，并将邮箱移到此服务器上。

    • 将 Exchange 2000 Server 升级到 Exchange Server 2003。

有关所支持的配置的详细信息，请参阅"Exchange 2003 部署指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=77B6D819-C7B3-42D1-8FBB-FE6339FFA1ED&DisplayLang=zh-cn)。

有关 Exchange Server 和 Windows Server 2003 的详细信息，请参阅 Microsoft 知识库文章 810591"Exchange Server 与 Windows Server 2003 的兼容性"()。


安装 Exchange 2007 预发行版
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-02-20

Microsoft Exchange Server 分析工具查询 Active Directory 目录服务，以确定目录中所有 Exchange Server 对象的 serialNumber 属性值。serialNumber 属性是一个字符串值，它同时包含 Exchange Server 的版本以及 Service Pack 的版本（如果已安装）。例如，在未安装任何 Service Pack 的 Exchange Server 2007 计算机上，serialNumber 属性等于 Version 8.0 (Build 0685)。

如果 Exchange Server 分析工具发现 serialNumber 属性值的字符串中包含 8.0，但是该字符串中包含的内部版本号小于 0685，则会显示错误。

此错误表明 Exchange Server 2007 计算机上运行的是 Exchange Server 2007 预发行版。

不支持在生产环境中安装 Exchange Server 2007 预发行版。

若要纠正此错误，请安装 Exchange Server 2007 生产版。


已将 Exchange 2007 服务器对象移至另一个管理组
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-08-11

Microsoft® Exchange Server 分析工具将查询 Active Directory® 目录服务，以确定目录中所有 Exchange Server 对象的 serialNumber 属性值。

Exchange Server 分析工具还将查询运行 Exchange Server 的服务器所驻留的管理组的 cn 属性值，以确定该组是否为专用的 Exchange 2007 管理组"Exchange 管理组 (FYDIBOHF23SPDLT)"。

如果 Exchange Server 分析工具确定服务器运行的是 Microsoft Exchange Server 2007，但不是驻留在管理组 Exchange Administrative Group (FYDIBOHF23SPDLT) 中，那么，Exchange Server 分析工具将显示错误。

此错误指示，服务器可能已从 Exchange 2007 管理组中手动移走，并且可能导致了邮件流问题。

serialNumber 属性是一个字符串值，其中包含 Exchange Server 版本和 Service Pack 版本（如果已安装）。如果 serialNumber 属性值等于 Version 8.0，则表示服务器运行的是 Exchange 2007。

Microsoft Exchange Server 2003 和 Microsoft Exchange 2000 Server 使用管理组来对 Exchange 对象进行分组，以便委派权限来管理这些对象。Exchange 2007 不使用管理组作为逻辑管理单元。为了使 Exchange Server 2003 或 Exchange 2000 Server 与 Exchange 2007 共存，在安装 Exchange 2007 时，会自动将所有 Exchange 2007 服务器添加到单个管理组。在 Exchange Server 2003 的 Exchange 系统管理器中，此管理组将识别为"Exchange 管理组 (FYDIBOHF23SPDLT)"。

若要解决此问题，请删除并重新安装服务器。


Exchange 所驻留的域控制器不是全局编录服务器
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-09

Microsoft® Exchange Server 分析工具查询 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 DomainRole 关键字的值。此关键字的有效值如下表中所示。

值 | 含义
0 | 独立工作站
1 | 成员工作站
2 | 独立服务器
3 | 成员服务器
4 | 备份域控制器
5 | 主域控制器

Exchange Server 分析工具还查询 Win32_Service WMI 类，以确定群集服务 ClusSvc 的 Started 关键字的值。此外，Exchange Server 分析工具还查询 Win32_OperatingSystem WMI 类，以确定 OSProductSuite 关键字的值。OSProductSuite 关键字的值表明计算机上运行的 Windows 的版本。

Exchange Server 分析工具也会查询 Active Directory® 目录服务，以确定 msExchExchangeServer 对象类中所有目录对象的 serialNumber 属性值。serialNumber 属性的值表明使用的 Exchange Server 的版本。

最后，Exchange Server 分析工具查询 Active Directory，以确定此服务器的 isGlobalCatalogReady 属性值。如果此属性的值为 True，表明该目录服务器同时作为全局编录服务器，如果值为 False，表明该目录服务器不是全局编录服务器。

如果 Exchange Server 分析工具确定 Exchange Server 计算机上的 DomainRole 关键字的值大于 3；Exchange Server 计算机运行的不是 Windows Small Business Server、Exchange Server 版本 5.5 或者未在 Windows 群集中运行；并且 isGlobalCatalogReady 属性设置为 False，则显示警告。

该警告表明运行 Exchange Server 的目录服务器不是有效的全局编录服务器。不支持此配置，此配置可能会使 Exchange 服务失败。

如果在未运行 Small Business Server 的域控制器上运行 Exchange Server，请考虑下列问题：

  • Exchange Server 和 Active Directory 都是耗费资源的应用程序。当两个应用程序运行在同一台计算机上时，存在一些需要考虑的性能影响。

  • 如果 Exchange Server 运行在域控制器上，还必须使该域控制器成为全局编录服务器。

  • 几个 Exchange Server 目录组件（如目录服务访问 (DSAccess)、目录服务代理 (DSProxy) 以及邮件分类程序）将不会故障转移到其他任何域控制器或全局编录服务器。

  • 不应在 Windows 中使用 /3GB 启动开关，因为它会导致 Exchange Server 消耗掉所有内存，从而减少 Active Directory 的可用内存。

  • 如果在关闭或重新启动服务器之前没有停止 Exchange Server 服务，系统关闭所需的时间将大大延长。

  • 此配置的安全性较低，因为 Exchange 管理员拥有 Active Directory 的本地管理访问权限。因而，他们可以提升其自己的特权。此外，在 Exchange Server 或 Active Directory 中找到的任何安全漏洞都可能危及另一方的安全性。

  • 如果域控制器上运行的是 Exchange Server 2003 或 Exchange Server 2007，则不支持使用域控制器提升工具 (DCPromo) 来更改计算机角色，如果这样做，已知的后果是会破坏 Microsoft Outlook® Mobile Access 等组件。

  • 不支持且永远也不应当在同时充当 Active Directory 域控制器的群集节点上运行 Exchange Server 2003 或 Exchange Server 2007。也就是说，如果在同时充当域控制器的群集节点上运行 Exchange 2000 Server，必须在从 Exchange 2000 Server 升级至 Exchange Server 2003 之前，将该服务器降级为成员服务器。

如果计算机运行的是 Exchange 2000 Server，建议尽早使用 DCPromo 将服务器降级为成员服务器。如果计算机运行的是 Exchange Server 2003 或 Exchange Server 2007，请按照下列过程之一解决此警告问题。

通过将 Exchange 移至另一台计算机来解决此警告问题

  1. 在另一台计算机上安装 Exchange Server。

  2. 使用 Exchange 任务向导中的"移动邮箱"将现有的所有邮箱从域控制器移至新的 Exchange 服务器上。

  3. 将原来的 Exchange Server 计算机保存的所有公用文件夹及角色转移到新的 Exchange Server 计算机上。

  4. 从域控制器中卸载 Exchange Server。
通过使 Exchange 服务器成为全局编录服务器来解决此警告问题

  1. 打开"Active Directory 站点和服务"。

  2. 展开"站点"，再展开相应站点，然后展开"服务器"。

  3. 选择要指定为全局编录服务器的域控制器。

  4. 在右侧窗格中，右键单击"NTDS 设置"，再选择"属性"。

  5. 在"常规"选项卡上，选择"全局编录"复选框。如果目录服务器运行 Windows 2000 Server Service Pack 2 或更低版本，请重新启动服务器以使更改生效。如果目录服务器运行的是 Windows 2000 Server Service Pack 3 或更高版本或者运行的是 Windows Server™ 2003，更改可以动态生效，不必重新启动服务器。

有关在域控制器上安装 Exchange Server 的详细信息，请参阅 Microsoft 知识库文章 250989"XADM:Installing the ADC on a Windows 2000 Domain Controller That Also Runs Exchange Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250989)。


检测到 Exchange Server 5.5
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-10-06

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定具有 serialNumber 对象类的所有对象的 msExchExchangeServer 属性值。如果字符串值包含"Version 5.5"，说明计算机运行的是 Microsoft Exchange Server 5.5 版。如果字符串值包含"Version 6.0"，说明计算机运行的是 Exchange 2000 Server。如果字符串值包含"Version 6.5"，说明计算机运行的是 Exchange Server 2003。

如果 Exchange Server 分析工具发现 serialNumber 的值包含"Version 5.5"，则显示错误。

此错误表明检测到的 Exchange Server 版本不能由此版本的 Exchange Server 分析工具进行进一步分析。

Exchange Server 分析工具所依赖的各种特定程序接口在检测到的 Exchange Server 版本中不可用。

要解决此错误，请指定运行 Exchange 2000 或更高版本的 Exchange Server。

如果确信错误地触发了此规则，请验证是否正确设定了 Active Directory 中 Exchange Server 对象的 serialNumber 属性值。

警告：
在使用 ADSI（Active Directory 服务接口）Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003 才能解决。修改 Active Directory 对象的属性的风险由您自己承担。
查看 serialNumber 属性值

  1. 启动 ADSI Edit。

  2. 双击"配置"容器，展开 CN=Services，展开 CN=Microsoft Exchange，再展开 CN=<ExchangeOrganizationName>。

  3. 展开 CN=Administrative Groups，展开 CN=<AdministrativeGroupName>，再展开 CN=Servers。

  4. 右键单击服务器对象，再单击"属性"。

  5. 双击 serialNumber 属性以显示其当前值。

有关如何部署 Exchange Server 2003 的详细信息，请参阅"Exchange Server 2003 Deployment Guide"（Exchange Server 2003 部署指南）(http://go.microsoft.com/fwlink/?LinkId=47569)。

有关如何从 Exchange Server 5.5 迁移到 Exchange Server 2003 的详细信息，请参阅知识库文章 259912"有关 Exchange Server 5.5 升级到 Exchange 2000 服务器或 Exchange Server 2003 先决条件"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=259912)。

有关如何迁移和升级到 Exchange Server 2003 的信息，请参阅"Upgrade to Exchange Server 2003"（升级到 Exchange Server 2003）(http://go.microsoft.com/fwlink/?LinkId=34186)。


Exchange Server 5.5 未运行最新的 Service Pack
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 Exchange Server 对象的 versionNumber 属性值。versionNumber 属性表示运行在计算机上的 Exchange Server 的版本。

Exchange Server 分析工具还查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 STORE.EXE 进程的 Version 关键字的值。如果 Exchange Server 分析工具确定 STORE.EXE 的 Version 关键字的值大于 1959 但小于 2653，则显示警告。这说明计算机正在运行 Exchange Server 5.5 Service Pack 4 之前的版本。

此警告说明 Exchange Server 计算机上所运行的 Exchange 版本的代码不是最新的可用代码。

解决此警告问题

  1. 下载 Exchange Server 5.5 Service Pack 4 (http://go.microsoft.com/fwlink/?LinkId=33456)。

  2. 从 Microsoft 下载中心 (http://go.microsoft.com/fwlink/?LinkId=33456) 下载 Exchange Server 5.5 的最新更新（2004 年 5 月）。

  3. 阅读 Microsoft 知识库文章 841765"May 2004 Update Rollup for Exchange Server 5.5"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=841765)，了解有关该更新的信息。

  4. 对 Exchange Server 计算机进行完整备份。

  5. 应用 Exchange Server 5.5 Service Pack 4。

  6. 应用 2004 年 5 月的更新。

有关安装此更新以及其他 Exchange Server 更新的详细信息，请参阅 Microsoft 知识库文章 328839"HOW TO：应用 Exchange Service Pack 和修复程序"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)。


Windows 2003 不支持 Exchange Server 5.5
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定运行于 Exchange Server 计算机上的 Microsoft Windows® 操作系统的版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 的值为 4.0 说明计算机正在运行 Microsoft Windows NT® Server 4.0。值为 5.0 说明计算机正在运行 Windows 2000 Server，值为 5.2 说明计算机正在运行 Windows Server™ 2003。

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定具有对象类 msExchExchangeServer 的所有对象的 serialNumber 属性值。如果字符串值包含"Version 5.5"，说明计算机运行的是 Microsoft Exchange Server 5.5 版。如果字符串值包含"Version 6.0"，说明计算机运行的是 Exchange 2000 Server。如果字符串值包含"Version 6.5"，说明计算机运行的是 Exchange Server 2003。

如果 Exchange Server 分析工具发现 CurrentVersion 的值等于 5.2 并且 serialNumber 的值包含"Version 5.5"，则会显示错误。这不是受支持的配置，应当尽快纠正该错误。

更正此错误

  • 执行下列操作之一：

    • 在运行受支持的操作系统的服务器上安装 Exchange Server 5.5，然后将邮箱移动到该服务器上。

    • 从 Exchange Server 5.5 迁移到 Exchange Server 2003。

有关部署 Exchange Server 2003 的详细信息，请参阅"Exchange Server 2003 部署指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=77B6D819-C7B3-42D1-8FBB-FE6339FFA1ED&DisplayLang=zh-cn)。

有关 Exchange Server 和 Windows Server 2003 的详细信息，请参阅 Microsoft 知识库文章 810591"Exchange Server 与 Windows Server 2003 的兼容性"()。

有关从 Exchange Server 5.5 迁移到 Exchange Server 2003 的详细信息，请参阅知识库文章 259912"Prerequisites for Upgrading Exchange Server 5.5 to Exchange 2000 Server or to Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=259912)。

有关迁移和升级到 Exchange Server 2003 的信息，请参阅迁移和升级页"Upgrade to Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=34186)。


Exchange Server 5.0 未运行最新的 Service Pack 或更新汇总
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 Exchange Server 对象的 versionNumber 属性值。versionNumber 属性表示运行在计算机上的 Exchange Server 的版本。

Exchange Server 分析工具还查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 STORE.EXE 进程的 Version 关键字的值。如果 Exchange Server 分析工具确定 STORE.EXE 的 Version 关键字的值大于 1456 但小于 1460，则显示警告。

此警告说明 Exchange Server 计算机上所运行的 Exchange 版本的代码不是最新的可用代码。

解决此警告问题

  1. 下载 Service Pack 2 for Exchange Server 5.0 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168858)。

  2. 阅读 Service Pack 2 README.TXT 文件 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168735)。

  3. 访问 Microsoft 下载中心 (http://go.microsoft.com/fwlink/?LinkId=41361) 下载 Exchange Server 5.0 的最新更新（2004 年 4 月）。

  4. 阅读 Microsoft 知识库文章 834130"Microsoft Exchange Server 5.0 Update Rollup"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=834130)，了解有关该更新的信息。

  5. 对 Exchange Server 计算机进行完整备份。

  6. 应用 Exchange Server 5.0 Service Pack 2。

  7. 应用 2004 年 4 月更新。

有关安装此更新以及其他 Exchange Server 更新的详细信息，请参阅 Microsoft 知识库文章 328839"HOW TO：应用 Exchange Service Pack 和修复程序"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)。


Exchange Server 5.5 驻留在 Active Directory 域控制器上
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 DomainRole 关键字的值。此关键字的有效值如下表中所示。

值 | 含义
0 | 独立工作站
1 | 成员工作站
2 | 独立服务器
3 | 成员服务器
4 | 备份域控制器
5 | 主域控制器

Exchange Server 分析工具还查询 Win32_Service WMI 类，以确定群集服务 ClusSvc 的 Started 关键字的值。

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定具有对象类别 msExchExchangeServer 的所有目录对象的 serialNumber 属性值。serialNumber 属性的值表明使用的 Exchange Server 的版本。

如果 Exchange Server 分析工具确定 Exchange Server 计算机上的 DomainRole 关键字的值大于 3，Exchange Server 计算机未运行在 Windows 群集中，并且运行的 Exchange 版本不是 Exchange Server 5.5，则会显示警告。

此警告表明 Exchange Server 5.5 正在 Active Directory 服务器上运行。这种情况可能会因为潜在的端口冲突而造成 Active Directory 连接器 (ADC) 出现问题。如果 ADC 使用此服务器作为目标，应确保使用正确的 Exchange 轻型目录访问协议 (LDAP) 端口号。默认情况下，目录服务器在 TCP 端口 389 上侦听 LDAP 请求。除非更改了 Exchange 的端口并且 ADC 配置为使用 Exchange 端口，否则，ADC 将无法与 Exchange 进行通信。

Active Directory 使用标准的 LDAP 端口 389 进行 LDAP 访问。但是，如果使用标准端口号，会覆盖驻留在同一服务器上的、同样尝试侦听 LDAP 端口 389 的 Exchange 服务器。必须重新分配 Exchange LDAP 端口，授予该 Exchange 服务器对其目录的 LDAP 访问权限。

解决此警告问题

  1. 打开"Exchange 管理器"。

  2. 依次展开站点名、"配置"、"协议"和"LDAP（目录）站点默认设置"。

  3. 将端口分配从 389 更改为当前未使用的端口。

  4. 单击"确定"保存更改。

  5. 重新启动 Microsoft Exchange 目录服务，以使更改生效。

  6. 如果需要，可以重新配置 ADC，使其使用此服务器作为目标来使用新端口。

有关如何更改 Exchange Server 5.5 中的 LDAP 端口分配的详细信息，请参阅 Microsoft 知识库文章 224447"XADM：如何更改 Exchange Server 中的 LDAP 端口分配"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=224447)。


Exchange Server DNS 名称解析失败
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具尝试对每台 Exchange Server 计算机的已配置 DNS 服务器执行域名系统 (DNS) 查询。此连接是通过使用执行名称解析请求并分析结果的自定义对象处理器来建立的。如果 Exchange Server 分析工具所收到的查询结果中没有 Internet 协议 (IP) 地址，则显示错误。

此错误意味着在 DNS 中找不到 Exchange Server 计算机。配置正确且工作正常的 DNS 对于 Exchange Server 和 Active Directory® 目录服务的正常运行都是必需的。DNS 注册和解析问题可能对发送、接收和传递邮件的功能产生广泛的影响。

必须正确配置 DNS 以确保 Active Directory 和 Exchange Server 正常工作。有关 Active Directory 的 DNS 配置的更深入处理，请参阅 Microsoft 知识库文章 237675"设置 Active Directory 的域名系统"(http://support.microsoft.com/kb/237675/zh-cn)。

更正此错误

  1. 检查下列配置项，确保 DNS 工作正常并且 Exchange Server DNS 项将被正确注册：

    • DNS IP 配置

    • 动态区域更新

    • DNS 转发器

  2. 检查根目录区域项是否存在。在 DNS 管理控制台中查看正向查找区域。应该有一个针对域的项。也可能存在其他区域项，但应该不是 dot (".") 区域。如果 dot (".") 区域存在，请删除 dot (".") 区域。dot (".") 区域将 DNS 服务器标识为根服务器。通常情况下，需要外部 (Internet) 访问的 Active Directory 域不应该配置为根 DNS 服务器。请在删除 dot (".") 后，在目录服务器上使用 Ipconfig /registerdns 手动重新注册 Exchange Server IP 地址。可能还需要重新启动 Netlogon 服务。

  3. 在 Exchange Server 计算机上使用 netdiag /fix 手动重新填充 Exchange Server DNS 项。

有关将 DNS 与 Active Directory 一起使用的详细信息，请参阅 Microsoft 知识库文章 323418"如何在 Windows Server 2003 中启用了 Active Directory 的情况下将 DNS 与现有 DNS 结构集成"(http://support.microsoft.com/kb/323418/zh-cn)。

有关解决 DNS 和 Active Directory 问题的详细信息，请参阅知识库文章 260371"解决 Windows 2000 中的常见 Active Directory 安装问题"(http://support.microsoft.com/kb/260371/zh-cn)。


Exchange 服务器已指定为前端并且似乎驻留了邮箱
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Exchange Server Microsoft Windows® Management Instrumentation (WMI) 对象（Exchange_Server 类），以确定服务器的 IsFrontEndServer 值。如果值为 True，那么 Exchange 服务器正在充当前端服务器。如果服务器具有邮箱存储，则 Exchange Server 分析工具会查询 Active Directory® 目录服务以确定服务器上的邮箱数。每个邮箱存储对象（msExchPrivateMDB 类）都有一个多值属性 homeMDBBL，该属性列出了存储中的所有邮箱。通过计算这些值，Exchange Server 分析工具就能获得服务器上邮箱的总数。

如果将 Exchange 服务器指定为前端服务器，而且还配置了超过 20 个邮箱，则显示警告。

取决于具体的配置，Exchange 可能需要将服务邮箱放在前端服务器上。例如，如果前端服务器从 Internet 接受简单邮件传输协议 (SMTP) 邮件，则 Exchange SMTP 服务可能需要专用的邮箱服务器。如果 Exchange 服务器上配置了超过 20 个邮箱，则 Exchange Server 分析工具将通过只显示警告来说明这些服务邮箱。

不应当将用户邮箱放在前端服务器上。这样的配置不受支持。

如果用户邮箱驻留在前端服务器上，请使用 Exchange 系统管理器（仅 Exchange Server 2003）或 Active Directory 用户和计算机将它们移动到适合的后端服务器上。

移动邮箱（Exchange 2000 Server 或 Exchange Server 2003）

  1. 在 Active Directory 用户和计算机中，选择想要移动其邮箱的一个或多个用户。

  2. 用鼠标右键单击在上一步中选择的用户列表，再单击"Exchange 任务"。

  3. 在"Exchange 任务向导"的"可用任务"页上，单击"移动邮箱"，再单击"下一步"。

  4. 小心阅读并执行向导的其余步骤。

移动邮箱（仅限 Exchange Server 2003）

  1. 在"Exchange 系统管理器"中，展开"服务器"，展开想要从中移动邮箱的服务器，展开想要从中移动邮箱的"存储组"，展开包含想要移动的邮箱的"邮箱存储"，再单击"邮箱"。

  2. 在详细信息窗格中，用鼠标右键单击要移动其邮箱的一个或多个用户，然后单击"Exchange 任务"。

  3. 在"Exchange 任务向导"的"可用任务"页上，单击"移动邮箱"，再单击"下一步"。

  4. 小心阅读并执行向导的其余步骤。

有关正确配置 Exchange 前端服务器的详细信息，请参阅 Microsoft 知识库文章 822443"Front-End Server Considerations in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822443)。

有关部署和配置 Exchange 前端服务器的常规建议，请参阅"Exchange 2003 部署指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=77B6D819-C7B3-42D1-8FBB-FE6339FFA1ED&DisplayLang=zh-cn)。

有关在 Exchange 前端服务器上运行用户邮箱时出错的详细信息，请参阅知识库文章 273296"XCON:Users Cannot Retrieve Mail on a Front-End Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=273296)。

有关在 Exchange Server 2003 上移动邮箱的详细信息，请参阅下列知识库文章：

  • 821829"在 Exchange Server 2003 中移动邮箱"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)

  • 822892"在 Exchange 2003 中移动邮箱工具的改进"(http://support.microsoft.com/kb/822892/zh-cn)


此 Exchange 服务器也是一个域控制器，这不是推荐的配置
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-03-28

Microsoft® Exchange Server 分析工具查询 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 DomainRole 关键字的值。此关键字的有效值如下表中所示。

值 | 含义
0 | 独立工作站
1 | 成员工作站
2 | 独立服务器
3 | 成员服务器
4 | 备份域控制器
5 | 主域控制器

此外，Exchange Server 分析工具还查询 Win32_Service WMI 类，以确定 ClusSvc（群集服务）的 Started 关键字的值。

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定对象类别为 msExchExchangeServer 的所有目录对象的 serialNumber 属性的值。serialNumber 属性的值表明了使用的 Exchange Server 的版本。

如果 Exchange Server 分析工具确定 Exchange Server 计算机上的 DomainRole 关键字的值大于 3，并且 Exchange Server 计算机运行的不是 Exchange Server 5.5 或者未运行在 Windows 群集中，则会显示警告。

如果 Exchange Server 作为 Microsoft Small Business Server 2000 或 Windows Small Business Server 2003 的一部分运行，可以在域控制器上安装 Exchange Server。但是，如果 Exchange Server 不是作为Small Business Server 的一部分运行，则建议避免在域控制器上运行 Exchange Server。

如果在未运行 Small Business Server 的域控制器上运行 Exchange Server，请注意下列问题：

  • Exchange Server 和 Active Directory 都是耗费资源的应用程序。当两者运行在同一台计算机上时，存在一些需要考虑的性能因素。

  • 如果 Exchange Server 运行在域控制器上，还必须使该域控制器成为全局编录服务器。有关创建全局编录服务器的详细信息，请参阅 Microsoft 知识库文章 313994"如何在 Windows Server 2003、Windows 2000 或 Small Business Server 2000 中创建或移动全局编录"(http://go.microsoft.com/fwlink/?linkid=3052&kbid= 313994)。

  • 几个 Exchange Server 目录组件（如目录服务访问 (DSAccess)、目录服务代理 (DSProxy) 以及邮件分类程序）将不会故障转移到其他任何域控制器或全局编录服务器。

  • 不应在 Windows 中使用 /3GB 启动开关，因为它会导致 Exchange Server 消耗掉所有内存，从而减少 Active Directory 的可用内存。

  • 如果在关闭或重新启动服务器之前未停止 Exchange Server 的服务，则关闭系统所需的时间将大大延长。

  • 此配置安全性较低，因为 Exchange 管理员将拥有对 Active Directory 的本地管理权限，从而使其可以提升自己的特权。此外，在 Exchange Server 或 Active Directory 中找到的任何安全漏洞都可能危及另一方的安全性。

  • 如果域控制器上运行的是 Exchange Server 2003 或 Exchange Server 2007，则不支持使用域控制器提升工具 (DCPromo) 来更改计算机角色，如果这样做，已知的后果是会破坏 Microsoft Outlook® Mobile Access 等组件。

  • 不支持且永远也不应当在同时充当 Active Directory 域控制器的群集节点上运行 Exchange Server 2003 或 Exchange Server 2007。这意味着如果在也充当域控制器的群集节点上运行 Exchange 2000 Server，必须在从 Exchange 2000 Server 升级至 Exchange Server 2003 之前，将该服务器降级为成员服务器。

如果计算机运行的是 Exchange 2000 Server，建议尽早使用 DCPromo 将服务器降级为成员服务器。如果计算机运行的是 Exchange Server 2003，请按照下列过程解决此警告问题。

解决此警告问题

  1. 在另一台计算机上安装 Exchange Server。

  2. 使用 Exchange 任务向导中的"移动邮箱"将域控制器上现有的所有邮箱移至新的 Exchange 服务器上。

  3. 将原来的 Exchange Server 计算机保存的所有公用文件夹及角色转移到新的 Exchange Server 计算机上。

  4. 从域控制器中卸载 Exchange Server。

有关在域控制器上安装 Exchange Server 的详细信息，请参阅 Microsoft 知识库文章 250989"XADM:Installing the ADC on a Windows 2000 Domain Controller That Also Runs Exchange Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250989)。


此 Exchange 服务器已停机或不可访问
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-04-20

Microsoft® Exchange Server 分析工具使用远程过程调用 (RPC) 从 Exchange Server 计算机上的下列注册表项中读取 CurrentVersion 字符串值：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

如果 Exchange Server 分析工具由于任何原因而无法读取该注册表值，则会显示错误。

更正此错误

  1. 确保 Exchange Server 计算机已启动并连接到了网络。

  2. 使用 Ping 命令确定是否可以访问 Exchange Server 计算机。

  3. 如果有防火墙，请检查以确定 RPC 端口是否被阻止。

  4. 确保 Exchange Server 计算机上的 Remote Registry 服务已启动。

  5. 检查运行 Exchange Server 分析工具所用帐户的权限，以确保此帐户具有足够的读取 Exchange Server 计算机上注册表的权限。

有关解决网络连接问题的详细信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"(http://support.microsoft.com/kb/325487/zh-cn)。

有关解决 Exchange Server 分析工具连接问题的详细信息，请参阅"Microsoft Exchange Server Analyzer Tool Troubleshooting Connectivity Problems"（英文）(http://go.microsoft.com/fwlink/?linkid=56285)。


该 Exchange 服务器正在 Windows NT 4.0 上运行；可用的诊断信息有限
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Exchange Server 计算机上运行的 Microsoft Windows® 操作系统的版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 的值为 4.0 说明计算机正在运行 Microsoft Windows NT® Server 4.0。值为 5.0 说明计算机正在运行 Windows 2000 Server，值为 5.2 说明计算机正在运行 Windows Server™ 2003。

如果 Exchange Server 分析工具发现 CurrentVersion 的值等于 4.0，则显示警告。

该警告说明此 Exchange Server 计算机正在运行 Windows NT Server 4.0。Windows NT Server 4.0 提供的诊断信息不如更高版本的 Windows Server 提供的信息多。因此，Exchange Server 分析工具只能收集和分析数量有限的信息。

解决此警告问题

  1. 不需要立即执行任何操作。该警告供信息参考。

  2. 因为 Windows NT Server 4.0 和 Exchange Server 5.5 版的产品生命周期即将结束，所以，您应当考虑升级到 Windows Server 2003 和 Exchange Server 2003。

有关 Windows NT Server 4.0 和 Exchange Server 5.5 的产品生命周期的详细信息，请参阅网站上的"Microsoft Support Lifecycle"（英文）(http://go.microsoft.com/fwlink/?LinkId=21759)。

有关 Windows Server 2003 的详细信息，请参阅产品主页"Microsoft Windows Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=26095)。

有关 Exchange Server 2003 的详细信息，请参阅产品主页"Microsoft Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=21573)。


此 Exchange Server 2003 服务器运行的不是最终的 Service Pack 2 内部版本
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定目录中所有 Exchange Server 对象的 serialNumber 属性值。serialNumber 属性是一个字符串值，它同时包含 Exchange Server 的版本号以及 Service Pack 的版本号（如果已安装）。例如，在安装了 Service Pack 1 的 Exchange Server 2003 计算机上，serialNumber 属性等于 Version 6.5 (Build 7638:Service Pack 2)。

如果 Exchange Server 分析工具发现 serialNumber 属性值在其字符串中包含 6.5 和 Service Pack 2，但不包含 7638，则会显示警告。

此警告意味着 Exchange Server 2003 计算机运行的是 Exchange Server2003 Service Pack 2 的预发行版本。

注意：
由于无法卸载 Exchange Server Service Pack，因此极力建议在应用任何 Service Pack 之前先完整备份运行 Exchange Server 的计算机。
解决此警告问题

  1. 从 Exchange Server 2003 Service Pack 2 网站 (http://go.microsoft.com/fwlink/?LinkId=52073) 获取 Exchange Server 2003 Service Pack 2 的最终版本。

  2. 查看 Exchange Server 2003 Service Pack 2 发行说明 (http://go.microsoft.com/fwlink/?LinkId=52072)。

  3. 执行 Exchange Server 计算机的完整备份。

  4. 应用 Exchange Server 2003 Service Pack 2。

  5. 再次创建运行 Exchange Server 的计算机的完整备份。

有关安装 Exchange Server Service Pack 的详细信息，请参阅 Microsoft 知识库文章 328839"HOW TO：应用 Exchange Service Pack 和修复程序"(http://support.microsoft.com/kb/328839/zh-cn)。


Exchange Server 正在运行 SharePoint Portal Server
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Microsoft Windows SharePoint® Portal Server (MSDMSERV) 的 Started 关键字的值。值为 True 说明该 Exchange 服务器上正在运行 SharePoint Portal Server。

如果 Exchange Server 分析工具确定 Exchange Server 计算机上正在运行 SharePoint Portal Server，则显示警告。

SharePoint Portal Server 与 Exchange Server 不兼容，应删除。SharePoint Portal Server 和 Exchange Server 设计用于配合使用，在组织的协作环境中起到一定作用。但是，SharePoint Portal Server 和 Exchange Server 设计为互相配合工作，而不是共存于同一硬件上。

解决此警告问题

  • 将 Exchange Server 或 SharePoint Portal Server 移至其他计算机。建议从计算机上删除这两个程序之一。

有关如何移动 Exchange Server 邮箱的详细信息，请参阅 Microsoft 知识库文章 821829"在 Exchange Server 2003 中移动邮箱"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)。

有关 Exchange Server 和 SharePoint Portal Server 兼容性的详细信息，请参阅知识库文章 277567"Cannot Install SharePoint Portal Server on a Computer Running Exchange Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=277567)。


Exchange Server 运行 Virtual Server 2005，而该 Virtual Server 2005 中有另一个 Exchange Server 以来宾身份安装在其中
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项中的值，以确定服务器是否是虚拟服务器：

HKEY_LOCAL_MACHINE\Software\Classes\Installer\Products\354F2D7F395B57846953B997DF778AC1

Exchange Server 分析工具还检查以下注册表值：

HKLM\Software\Microsoft\Virtual Machine\Guest\Parameters

此外，Exchange Server 分析工具还查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Microsoft Exchange 信息存储服务 (MSExchangeIS) 是否运行在运行 Microsoft Virtual Server 2005 的物理计算机上。

如果 Exchange Server 分析工具发现服务器是虚拟服务器、上述注册表分支存在，并且 MSExchangeIS 运行在物理计算机上，将显示错误。

HKLM\Software\Classes\Installer\Products\354F2D7F395B57846953B997DF778AC1 项的存在意味着 Exchange Server 计算机上安装了虚拟计算机附加项。此项以及 HKLM\Software\Microsoft\Virtual Machine\Guest\Parameters 项的存在意味着 Exchange Server 计算机以来宾虚拟计算机的身份运行在 Virtual Server 2005 中。

Microsoft 不支持在虚拟计算机或仿真器上运行任何版本的 Exchange Server。这适用于运行在 Virtual Server 2005、Microsoft Virtual PC 2004 或任何第三方虚拟计算机程序上的 Exchange Server。Exchange Server 平台的设计和测试只是针对在物理硬件上运行而进行的，尤其是针对 Windows Server Catalog (http://go.microsoft.com/fwlink/?linkid=17219) 中列出的那些硬件平台。

此外，使 Exchange 以 Virtual Server 来宾身份运行在运行 Exchange Server 的计算机上不是最佳实践，因为这样无法在服务之间实现足够的冗余。

更正此错误

  1. 将运行在 Virtual Server 2005 下的 Exchange Server 中的邮箱移至非虚拟 Exchange Server 计算机上。

  2. 必要时重新放置所有公用文件夹，并转移虚拟 Exchange 服务器担任的所有角色。

  3. 将 Exchange 从虚拟计算机中卸载以便不再使用它，并将它从 Exchange 基础结构及 Active Directory® 目录服务中删除。

有关移动邮箱的详细信息，请参阅下列 Microsoft 知识库文章：

  • 822892"在 Exchange 2003 中移动邮箱工具的改进"(http://support.microsoft.com/kb/822892/zh-cn)

  • 224975"XADM:Differences Between Move Mailbox Methods"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

有关对运行在虚拟环境中的 Exchange Server 计算机的支持的详细信息，请参阅知识库文章 320220"Support Boundaries for Exchange Server on a Virtual Machine or an Emulation Machine"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)。

有关 Virtual Server 2005 的详细信息，请参阅"Microsoft Virtual Server 2005"（英文）(http://go.microsoft.com/fwlink/?linkid=34938)。

有关 Virtual PC 2004 的详细信息，请参阅"Microsoft Virtual PC 2004"（英文）(http://go.microsoft.com/fwlink/?linkid=34663)。


运行 DNS 服务的 Exchange 服务器
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 DNS Server 服务 (DNS) 的 Started 关键字的值。值为 True 说明该 Exchange 服务器上正在运行 DNS Server 服务。

Exchange Server 分析工具还查询 Win32_OperatingSystem WMI 类，以确定 OSProductSuite 关键字的值。该关键字的返回值表示正在 Exchange Server 计算机上运行的 Windows 操作系统的版本。

此外，Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定在每个邮箱存储的 homeMDBBL 属性中列出的条目数。该属性的个数代表邮箱存储中的邮箱数。

如果 Exchange Server 分析工具确定在符合下列所有条件的 Exchange Server 计算机上启动了 DNS Server 服务，则会显示警告：

  • Exchange Server 计算机驻留了超过 100 个邮箱。

  • Exchange Server 计算机未运行 Windows Small Business Server 2003 或 Small Business Server 2000。

建议不要在用作生产 Exchange 邮箱服务器的计算机上运行 DNS Server 服务。在生产环境中将 DNS Server 服务和 Exchange Server 共同驻留在同一台计算机上，很可能导致它们中的一个或两个的性能降低。

解决此警告问题

  1. 应当考虑使用下列选项之一来解决此警告问题：

    • 从计算机上移走 Exchange Server 或 DNS Server 服务。建议从计算机上完全移除上述服务器应用程序之一。

    • 从服务器上移走 Exchange 邮箱。至少应该移除邮箱，并将 Exchange 服务器转换为协议或基础结构服务器。这会极大地降低磁盘 I/O 的负载，并稍稍地降低 CPU 的负载（后者将取决于 Exchange 基础结构角色）。

    • 改为考虑安装 Small Business Server。如果在运行 Exchange 的小型环境（有少于 75 个用户）中您不需要多个 Exchange 服务器，则安装 Small Business Server 可能会受益匪浅。Small Business Server 包含 Microsoft SQL Server™ 和 Exchange Server 以及其他核心 Microsoft 服务器应用程序，并且是针对单机安装进行开发、测试和优化的。

有关移动邮箱和 Exchange 服务器的详细信息，请参阅下列 Microsoft 知识库文章：

  • 822892"在 Exchange 2003 中移动邮箱工具的改进"(http://support.microsoft.com/kb/822892/zh-cn)

  • 224975"XADM:Differences Between Move Mailbox Methods"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

  • 297289"如何将 Exchange 2000 移至新硬件并保持同一服务器名"(http://support.microsoft.com/kb/297289/zh-cn)

有关 Small Business Server 的详细信息，请参阅"Microsoft Windows Small Business Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=23456)。


运行 SQL Server 的 Exchange 服务器
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Microsoft SQL Server™ 服务 (MSSQLSERVER) 的 Started 关键字的值。值为 True 说明该 Exchange 服务器上正在运行 SQL Server 服务。

Exchange Server 分析工具还查询 Win32_OperatingSystem WMI 类，以确定 OSProductSuite 关键字的值。该关键字的返回值表示正在 Exchange Server 计算机上运行的 Windows 操作系统的版本。

此外，Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定在每个邮箱存储的 homeMDBBL 属性中列出的条目数。该属性的个数代表邮箱存储中的邮箱数。

如果 Exchange Server 分析工具确定在符合下列所有条件的 Exchange Server 计算机上启动了 SQL Server 服务，则会显示警告：

  • Exchange Server 计算机驻留了超过 100 个邮箱。

  • Exchange Server 计算机未运行 Windows Small Business Server 2003 或 Small Business Server 2000。

建议不要在用作生产 Exchange 邮箱服务器的计算机上运行 SQL Server。为了以最佳状态运行，SQL Server 和 Exchange 邮箱服务器都会消耗大量内存及磁盘资源。在生产环境中将 SQL Server 和 Exchange Server 共同驻留在同一台计算机上，很可能导致它们中的一个或两个的性能降低。另外，对这样的安装进行故障排除和安全保护也不好理解。

最后，如果在同一台计算机上运行 SQL Server 和 Exchange Server，有可能遇到很多已知的互操作性问题。大多数这样的问题都是由于两个服务器公用的文件或程序发生版本不一致而导致的，例如，Microsoft 分布式事务协调器 (MS DTC)、Microsoft ActiveX® 数据对象 (ADO) 和 OLE 数据库 (OLE DB)。

解决此警告问题

  • 应当考虑使用下列选项之一来解决此警告问题：

    • 从计算机上移走 Exchange Server 或 SQL Server。建议从计算机上完全移除上述程序之一。

    • 从服务器上移走 Exchange 邮箱。至少应该移除邮箱，并将 Exchange 服务器转换为协议或基础结构服务器。这会极大地降低磁盘 I/O 的负载，并稍稍地降低 CPU 的负载（后者将取决于 Exchange 基础结构角色）。

    • 也可以考虑安装 Small Business Server。如果是在不需要多个 Exchange 服务器的小型环境中运行 Exchange，则安装 Small Business Server 可能会受益匪浅。Small Business Server 包含 SQL Server 和 Exchange Server 以及其他核心 Microsoft 服务器应用程序，并且是针对单机安装进行开发、测试和优化的。

有关移动邮箱和 Exchange 服务器的详细信息，请参阅下列 Microsoft 知识库文章：

  • 822892"在 Exchange 2003 中移动邮箱工具的改进"(http://support.microsoft.com/kb/822892/zh-cn)

  • 224975"XADM:Differences Between Move Mailbox Methods"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

  • 297289"如何将 Exchange 2000 移至新硬件并保持同一服务器名"(http://support.microsoft.com/kb/297289/zh-cn)

有关 Small Business Server 的详细信息，请参阅"Microsoft Windows Small Business Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=23456)。


在 VMware 下运行的 Exchange 服务器
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-10-26

有关对运行在虚拟环境中的 Exchange Server 计算机的支持的详细信息，请参阅知识库文章 897615"Support policy for Microsoft software running in non-Microsoft hardware virtualization software"（运行在非 Microsoft 硬件虚拟化软件环境中 Microsoft 软件的支持策略）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=897615)。


此 Exchange 服务器的内存不足 1 GB，但 boot.ini 文件中有 /3GB 和 /USERVA=3030 开关
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询两个 Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange Server 计算机中的物理内存量以及分配给用户模式进程的虚拟地址空间量。下表描述了 Exchange Server 分析工具所评估的类和关键字。

类 | 关键字 | 描述
Win32_OperatingSystem | MaxProcessMemorySize | 可以分配给进程的最大内存 KB 数。
Win32_OperatingSystem | OSProductSuite | 操作系统的已安装和已授权的系统产品。
Win32_ComputerSystem | TotalPhysicalMemory | 计算机中安装的随机存取内存 (RAM) 的字节数。

如果 Exchange Server 分析工具确定 Exchange Server 计算机的 RAM 不足 950 MB，而且 MaxProcessMemorySize 的值大于 2097024 但小于 3104640，则会显示警告。

此警告表明，Exchange Server 计算机在两个方面未针对最佳内存使用进行正确配置：

  • 设置了 /USERVA=3030 启动开关。只有在配备 1 GB 或更多内存并且运行 Microsoft Windows Server™ 2003 操作系统的 Exchange Server 计算机上，该开关才是必需的。

  • 设置了 /3GB 启动开关。此开关应当只用在运行下列任意操作系统并且内存不低于 1 GB 的 Exchange Server 上：

    • Microsoft Windows Server 2003 Standard Edition

    • Microsoft Windows Server 2003 Enterprise Edition

    • Microsoft Windows Server 2003 Datacenter Edition

    • Microsoft Windows 2000 Advanced Server

    • Microsoft Windows 2000 Datacenter Server

重要信息：
/3GB 开关不应当用在 Windows 2000 Server 上，因为它不被支持，并且可能导致应用程序或操作系统崩溃。此外，只有在安装了 1 GB 或更多物理内存时，前面列出的操作系统才支持 /3GB 开关。

如果在安装了 1 GB 物理内存的系统上遇到该警告，可以说明已在硬件级别为另一个组件（例如，视频卡）分配了该物理内存的一部分，因此使所分配的物理内存对操作系统不可用。在这些情况下，根据 Windows 安装的物理内存量将小于计算机中安装的实际物理内存量。如果遇到此种情况，您应当将 BIOS 报告的已安装内存量和 Windows 报告的已安装内存量进行比较。

在 Windows Server 2003 上解决此警告问题

  1. 用鼠标右键单击"我的电脑"，然后单击"属性"。将显示"系统属性"对话框。

  2. 单击"高级"。

  3. 在"启动和故障恢复"区域中，单击"设置"。将显示"启动和故障恢复"对话框。

  4. 在"系统启动"区域中，单击"编辑"。将在记事本中打开 Windows Boot.ini 文件。

  5. 在 [Operating Systems] 部分，从所有启动行中删除以下开关：/3GB /USERVA=3030

  6. 保存更改，关闭记事本。

  7. 单击"确定"两次关闭打开的对话框，再重新启动计算机，以使更改生效。

在 Windows 2000 Server 上解决此警告问题

  1. 在 Windows 资源管理器中，导航到系统分区。

  2. 如果看不到 Boot.ini 文件，则原因可能是"文件夹选项"已设置为"隐藏受保护的操作系统文件"。如果是这种情况，请在 Windows 资源管理器窗口中，单击"工具"，再单击"文件夹选项"，然后单击"查看"。清除"隐藏受保护的操作系统文件（推荐）"复选框。出现警告框提示时，单击"是"。

  3. 当 Boot.ini 文件显示在 Windows 资源管理器中后，用鼠标右键单击该文件，再单击"打开方式"，然后单击"记事本"打开该文件。

  4. 删除 /3GB 和 /USERVA=3030（如果有）。

  5. 保存更改，关闭记事本。

  6. 重新启动计算机，以使更改生效。

有关使用 /3GB 和 /USERVA 启动开关的详细信息，请参阅下列 Microsoft 知识库文章：

  • 308356"基于 Windows 2000 Server 的域控制器上的 Lsass.exe 进程的内存使用量"(http://support.microsoft.com/?kbid=308356)

  • 297812"How to Use the 4GT RAM Tuning Feature"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901"The effects of 4GT tuning on system Page Table Entries"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739"如何使用 Boot.ini 文件中的 /USERVA 开关优化 /3GB 配置"(http://support.microsoft.com/?kbid=316739)

  • 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372"如何在 Exchange Server 2003 中优化内存使用"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


该 Exchange 服务器的内存少于 1 GB，但在 Boot.ini 文件中设置了 /3GB 开关
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询两个 Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange Server 计算机中的物理内存量以及分配给 Exchange Server 计算机上运行的用户模式进程的虚拟地址空间量。下表描述了 Exchange Server 分析工具所评估的类和关键字。

查询的类 | 查询的关键字 | 描述
Win32_OperatingSystem | MaxProcessMemorySize | 可以分配给进程的最大内存 KB 数。
Win32_ComputerSystem | TotalPhysicalMemory | 安装在计算机中的随机访问内存 (RAM) 的字节数。

如果 Exchange Server 分析工具确定 TotalPhysicalMemory 的值小于 1073741824，并且 MaxProcessMemorySize 的值等于 3145600，则显示警告。

该警告说明系统的物理内存少于 950 MB，但它已在 Boot.ini 文件中配置了 /3GB 启动开关。此开关应当只用在运行下列任意操作系统并且内存不低于 1 GB 的 Exchange 服务器上：

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

重要信息：
/3GB 开关不应当用在 Windows 2000 Server 上，因为它不被支持，并且可能导致应用程序或操作系统崩溃。此外，只有在安装了 1 GB 或更多物理内存时，前面列出的操作系统才支持 /3GB 开关。

如果在安装了 1 GB 物理内存的系统上遇到该警告，可以说明已在硬件级别为另一个组件（例如，视频卡）分配了该物理内存的一部分，因此使所分配的物理内存对操作系统不可用。在这些情况中，Windows 所使用的已物理安装的内存数量将小于计算机上所安装的实际物理内存数量。如果遇到该情况，应当将 BIOS 所报告的已安装内存数量与 Windows 所报告的已安装内存数量进行比较。

在 Windows Server 2003 上解决此警告问题

  1. 用鼠标右键单击"我的电脑"，再单击"属性"。将出现"系统属性"对话框。

  2. 单击"高级"。

  3. 在"启动和故障恢复"区域中，单击"设置"。将出现"启动和故障恢复"对话框。

  4. 在"系统启动"区域中，单击"编辑"。这将在记事本中打开 Windows Boot.ini 文件。

  5. 在 [Operating Systems] 部分中，从所有启动行中删除下列开关：/3GB

  6. 保存更改，关闭记事本。

  7. 单击"确定"两次关闭打开的对话框，再重新启动计算机，以使更改生效。

在 Windows 2000 Server 上解决此警告问题

  1. 在 Windows 资源管理器中，导航到系统分区。这是存放硬件特有文件（如 Boot.ini 和 NTLDR）的分区。

  2. 如果看不到 Boot.ini 文件，可能是由于"文件夹选项"设置为"隐藏受保护的操作系统文件"。如果是这种情况，请在 Windows 资源管理器窗口中，单击"工具"，再单击"文件夹选项"，然后单击"查看"。清除"隐藏受保护的操作系统文件（推荐）"复选框。当出现提示时，单击"是"。

  3. 当 Boot.ini 文件显示在 Windows 资源管理器中后，用鼠标右键单击该文件，再单击"打开方式"，然后单击"记事本"打开该文件。

  4. 在 [Operating Systems] 部分中，从所有启动行中删除下列开关：/3GB

  5. 保存更改，关闭记事本。

  6. 重新启动计算机，以使更改生效。

有关优化 Exchange Server 的内存使用的详细信息，请参阅下列 Microsoft 知识库文章：

  • 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372"如何在 Exchange Server 2003 中优化内存使用"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


该 Exchange 服务器的 Boot.ini 文件中设置了 /3GB 启动开关
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange Server 计算机上分配给用户模式进程的虚拟地址空间量 (MaxProcessMemorySize)。

Exchange Server 分析工具还检查 root\MicrosoftExchangeV2 命名空间中的 Exchange_Server WMI 类，以确定 IsFrontEndServer 关键字的值。值为 False 说明 Exchange Server 计算机不是前端服务器。值为 True 说明 Exchange Server 计算机是前端服务器。

Exchange Server 分析工具还查询 Win32_Service WMI 类，以确定群集服务 (ClusSvc) 是否存在并已启动。

最后，Exchange Server 分析工具查询 Active Directory® 目录服务，以确定邮箱存储对象 (msExchPrivateMDB) 的 homeMDBBL 属性的个数。所得到的个数是在 Exchange Server 计算机上找到的邮箱数。

如果 Exchange Server 分析工具确定：MaxProcessMemorySize 关键字的值不等于 2097024、IsFrontEndServer 关键字被设置为 False、群集服务未运行、Exchange Server 的邮箱存储包含的邮箱数少于 20 个，并且 Exchange 未运行在 Microsoft Windows Small Business Server 2003 上，则会显示警告。

该警告说明：由于 Boot.ini 文件中已经设置了 /3GB 启动开关，所以目录服务器没有被正确配置为最佳内存使用状态。此开关应当只用在运行下列任意操作系统并且内存不低于 1 GB 的 Exchange 服务器上：

  • Microsoft Windows Server™ 2003 标准版

  • Microsoft Windows Server 2003 企业版

  • Microsoft Windows Server 2003 Datacenter 版

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

重要信息：
/3GB 开关不应当用在 Windows 2000 Server 上，因为它不被支持，并且可能导致应用程序或操作系统崩溃。此外，只有在安装了 1 GB 或更多物理内存时，前面列出的操作系统才支持 /3GB 开关。

如果所支持的操作系统的 Boot.ini 文件中包含 /3GB 参数，Windows 会将最大虚拟地址空间 4 GB 中的 3 GB 分配给用户进程，将余下的 1 GB 分配给内核。正常情况下（当不使用 /3GB 参数时），Windows 为用户进程分配 2 GB，为内核分配 2 GB。因此，当使用 /3GB 开关时，占用内存的应用程序有大量的虚拟内存地址空间可使用，因此性能得到改善。

使用 /3GB 开关主要对驻留用户邮箱的 Exchange 服务器上占用内存的应用程序（如 Store.exe 进程）有利。前端服务器不驻留用户邮箱，因此，在前端服务器上使用 /3GB 开关没有帮助。

解决此警告问题

  1. 在 Windows 资源管理器中，导航至系统分区。

  2. 如果看不到 Boot.ini 文件，可能是由于"文件夹选项"设置为"隐藏受保护的操作系统文件"。如果是这种情况，请在 Windows 资源管理器窗口中，依次"工具"、"文件夹选项"、"查看"选项卡。清除"隐藏受保护的操作系统文件（推荐）"复选框。当出现警告对话框时，单击"是"。

  3. 当 Boot.ini 文件显示在 Windows 资源管理器中后，用鼠标右键单击该文件，再单击"打开方式"，然后选择"记事本"打开该文件。

  4. 在 [Operating Systems] 部分中，从所有启动行中删除以下开关：/3GB

  5. 保存更改，关闭记事本。

  6. 重新启动计算机，以使更改生效。

有关使用 /3GB 开关的详细信息，请参阅下列 Microsoft 知识库文章：

  • 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"

    (http://support.microsoft.com/kb/325044/zh-cn)

  • 815372"如何在 Exchange Server 2003 中优化内存使用"

    (http://support.microsoft.com/kb/815372/zh-cn)


此 Exchange 2003 服务器运行的不是最终的 Service Pack 1 内部版本 (7226.6)
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-04-21

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定目录中所有 Exchange Server 对象的 serialNumber 属性值。serialNumber 属性是一个字符串值，它同时包含 Exchange Server 的版本号以及安装的 Service Pack 的版本号（如果已安装）。例如，在安装了 Service Pack 1 的 Exchange Server 2003 计算机上，serialNumber 属性等于 Version 6.5 (Build 7226.6:Service Pack 1)。

如果 Exchange Server 分析工具发现 serialNumber 属性的值（字符串）包含 6.5 和 Service Pack 1，但该字符串中不包含 7226.6，则显示警告。

此警告意味着 Exchange Server 2003 计算机运行的是 Exchange Server 2003 Service Pack 1 的预发行版本。

注意：
由于无法卸载 Exchange Service Pack，因此强烈建议在应用任何 Service Pack 之前先执行 Exchange Server 计算机的完整备份。

解决此警告问题

  1. 获取 Exchange Server 2003 Service Pack 1 的最终版本 (http://go.microsoft.com/fwlink/?linkid=29090)。

  2. 查看 Exchange Server 2003 发行说明 (http://go.microsoft.com/fwlink/?linkid=23235)。

  3. 查看 Service Pack 1 中包含的更新 (http://go.microsoft.com/fwlink/?linkid=34272)。

  4. 执行 Exchange Server 计算机的完整备份。

  5. 应用 Exchange Server 2003 Service Pack 1。

  6. 再次创建 Exchange Server 计算机的完整备份。

有关安装 Exchange Server Service Pack 的详细信息，请参阅 Microsoft 知识库文章 328839"HOW TO：应用 Exchange Service Pack 和修复程序"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)。


该 Exchange 服务器正在运行 Windows 2000 Server，但在 boot.ini 文件中设置了 /3GB 开关
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询两个 Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange Server 计算机中的物理内存量以及分配给用户模式进程的虚拟地址空间量。下表描述了 Exchange Server 分析工具所评估的类和关键字。

类 | 关键字 | 描述
Win32_OperatingSystem | MaxProcessMemorySize | 可以分配给进程的最大内存 KB 数。
Win32_OperatingSystem | OSProductSuite | 操作系统的已安装和已授权的系统产品。
Win32_ComputerSystem | TotalPhysicalMemory | 安装在计算机中的随机访问内存 (RAM) 字节数。

如果 Exchange Server 分析工具确定 MaxProcessMemorySize 关键字的值不等于 2097024，并且 OSProductSuite 关键字的值解析为 Windows 2000 Server，则显示错误。

该警告说明：由于 Boot.ini 文件中已经设置了 /3GB 启动开关，所以目录服务器没有被正确配置为最佳内存使用状态。此开关应当只用在运行下列任意操作系统并且内存不低于 1 GB 的 Exchange 服务器上：

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

重要信息：
/3GB 开关不应当用在 Windows 2000 Server 上，因为它不被支持，并且可能导致应用程序或操作系统崩溃。此外，只有在安装了 1 GB 或更多物理内存时，前面列出的操作系统才支持 /3GB 开关。

在 Windows Server 2003 上更正此错误

  1. 用鼠标右键单击"我的电脑"，然后选择"属性"。将出现"系统属性"对话框。

  2. 单击"高级"选项卡。

  3. 在"启动和故障恢复"区域中，单击"设置"按钮。将出现"启动和故障恢复"对话框。

  4. 在"系统启动"区域中，单击"编辑"按钮。这将在记事本中打开 Windows Boot.ini 文件。

  5. 在 [Operating Systems] 部分中，从所有启动行中删除下列开关：/3GB。

  6. 保存更改，关闭记事本。

  7. 单击"确定"两次关闭打开的对话框，再重新启动目录服务器，以使更改生效。

在 Windows 2000 Server 上更正此错误

  1. 在 Windows 资源管理器中，导航至系统分区。

  2. 如果看不到 Boot.ini 文件，可能是由于"文件夹选项"设置为"隐藏受保护的操作系统文件"。如果是这种情况，请在 Windows 资源管理器窗口中，依次"工具"、"文件夹选项"、"查看"选项卡。清除"隐藏受保护的操作系统文件（推荐）"复选框。当出现警告对话框时，单击"是"。

  3. 当 Boot.ini 文件显示在 Windows 资源管理器中后，用鼠标右键单击该文件，再单击"打开方式"，然后选择"记事本"打开该文件。

  4. 删除 /3GB 并保存该文件。

  5. 重新启动目录服务器，以使更改生效。

有关使用 /3GB 和 /USERVA 启动开关的详细信息，请参阅下列 Microsoft 知识库文章：

  • 297812"How to Use the 4GT RAM Tuning Feature"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901"The effects of 4GT tuning on system Page Table Entries"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739"如何使用 Boot.ini 文件中的 /USERVA 开关优化 /3GB 配置"(http://support.microsoft.com/?kbid=316739)

  • 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372"如何在 Exchange Server 2003 中优化内存使用"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


无法访问 Exchange Server WMI
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-08-24

Microsoft® Exchange Server 分析工具查询 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定是否为 Name 关键字设置了值。如果 WMI 查询失败，并且 Exchange Server 未在 Microsoft Windows NT® Server 4.0 上运行，则 Exchange Server 分析工具将显示错误。

此错误可能有两种原因：

  • 运行 Exchange Server 分析工具的帐户没有足够的权限，无法查询 WMI 类。

  • 网络问题使 Exchange Server 分析工具无法与计算机联系。

更正此错误

  1. 确保 Exchange Server 计算机已启动并连接到了网络。

  2. 使用 PING 命令确定 Exchange Server 计算机是否可访问。

  3. 如果有防火墙，请检查以确定远程过程调用 (RPC) 端口是否被阻止。

  4. 检查用来运行 Exchange Server 分析工具的帐户的权限。用来运行 Exchange Server 分析工具的帐户在每个所扫描的 Exchange 服务器上必须具有本地管理员权限。

    也可以为用来运行 Exchange Server 分析工具的帐户授予特定的 WMI 权限：

    1. 在 Exchange 计算机上，打开"计算机管理"Microsoft 管理控制台 (MMC) 树。

    2. 在"服务和应用程序"下，右键单击"WMI 控件"，再单击"属性"。

    3. 在"WMI 控件属性"页上，单击"安全性"选项卡，再展开"根"。

    4. 选择 CIMV2 文件夹，再单击"安全性"。

    5. 在"ROOT\CIMV2 安全性"页上，添加用来运行 Exchange Server 分析工具的帐户。

  5. 请选择在上述步骤 5 中添加的帐户。在"所选帐户权限"中的"允许"列下，选择"远程启用"和"读取安全性"，然后单击"确定"。

有关解决网络连接问题的详细信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

有关解决 Exchange Server 分析工具连接问题的详细信息，请参阅"Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"（解决连接问题的 Microsoft Exchange Server 最佳实践分析工具）(http://go.microsoft.com/fwlink/?LinkId=56285)。

有关端口需求的详细信息，请参阅 Microsoft 知识库文章 832017"Windows 服务器系统的服务概述和网络端口要求"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)。


该前端服务器上未运行 Exchange System Attendant 服务
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Microsoft Exchange System Attendant 服务的 Started 关键字的值。值为 False 说明没有运行 Exchange System Attendant 服务。值为 True 说明 Exchange System Attendant 服务正在运行。

Exchange Server 分析工具还检查 root\MicrosoftExchangeV2 命名空间中的 Exchange_Server WMI 类，以确定 IsFrontEndServer 关键字的值。值为 False 说明 Exchange Server 计算机不是前端服务器。值为 True 说明 Exchange Server 计算机是前端服务器。

如果 Exchange Server 分析工具发现 Exchange 前端服务器上的 Started 关键字的值设置为 False，则显示警告。

通常，大多数 Exchange 服务器会一直运行系统助理服务。但是，有时运行系统助理服务不是必需的。例如，在前端服务器上，只有在对服务器进行配置更改时，系统助理服务才是必需的。

Exchange Server 将它的所有配置信息存储在 Active Directory® 目录服务中，这包括有关以下各项的信息：收件人策略、简单邮件传输协议 (SMTP) 虚拟服务器配置、RPC over HTTP（超文本传输协议远程过程调用）设置和用户邮箱。但是，SMTP 则从 Internet 信息服务 (IIS) 元数据库读取它的设置。为了将 Exchange 用于 SMTP 和 RPC over HTTP 功能的信息填充到 IIS 元数据库，系统助理中的目录服务到元数据库 (DS2MB) 组件会将配置信息从 Active Directory 复制到 IIS 元数据库。如果未运行系统助理，对存储在 Active Directory 中的 Exchange Server 配置设置所做的更改将不会被复制到 Exchange Server 的 IIS 元数据库中。如果没有进行配置更改，并且当前没有处理 SMTP 邮件，则系统助理服务可以继续处于停止状态。

如果确实有配置要进行更改，请启动系统助理服务，并进行配置更改，然后等待这些更改被复制到 IIS 元数据库。若要确定是否更改已从 Active Directory 复制到 IIS 元数据库，请在 Exchange 服务器的应用程序事件日志中，检查是否存在事件源为 MSExchangeMU 并且事件 ID 为 1005 的三个条目。成功进行 DS2MB 复制之后，将记录这些事件。一旦记录了这些事件，就可以停止系统助理服务。

除非前端服务器正在使用 SMTP，否则建议的配置是停止系统助理服务，然后将它设置为禁用。在使用 SMTP 的前端服务器上，以及所有其他 Exchange Server 计算机上，都必须运行 Exchange System Attendant 服务，以便可以传递邮件、为 SMTP 和邮箱存储事务提供服务以及执行 DS2MB 复制。

Exchange System Attendant 服务应当总是运行在包含邮箱或公用文件夹的后端服务器和任何其他 Exchange 服务器上。

解决此警告问题

  1. 打开"服务"Microsoft 管理控制台 (MMC) 管理单元。

  2. 在右侧窗格中，向下滚动到 Microsoft Exchange System Attendant 服务，并双击它。这将显示"Microsoft Exchange System Attendant 的属性"对话框。

  3. 将"启动类型"下拉列表中的值设置为"自动"。

  4. 单击"启动"，以启动系统助理服务。

  5. 单击"确定"保存更改，并关闭"Microsoft Exchange System Attendant 的属性"对话框。

  6. 关闭"服务"管理单元。

有关禁用系统助理服务和保护 Exchange Server 的详细信息，请参阅下列 Exchange Server 主题：

  • "Securing Exchange 2000 Servers Based on Role"（英文）(http://go.microsoft.com/fwlink/?LinkId=35585)

  • "Exchange Server 2003 Security Hardening Guide"（英文）(http://go.microsoft.com/fwlink/?LinkId=47578)


未运行 Exchange 系统助理服务
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-09

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Microsoft Exchange 系统助理服务的 Started 关键字的值。值为 False 说明未运行 Exchange 系统助理服务。值为 True 说明正在运行 Exchange 系统助理服务。

Exchange Server 分析工具还检查 root\MicrosoftExchangeV2 命名空间中的 Exchange_Server WMI 类，以确定 IsFrontEndServer 关键字的值。值为 False 说明 Exchange Server 计算机不是前端服务器。值为 True 说明 Exchange Server 计算机是前端服务器。

如果 Exchange Server 分析工具发现 Started 关键字的值为 False，则此 Exchange Server 计算机不是前端服务器，且会显示警告。

通常，大多数 Exchange 服务器都会一直运行系统助理服务。但是，有时并不需要运行系统助理服务。例如，在 Exchange 2000 Server 或 Exchange Server 2003 前端服务器上，只有在对服务器配置进行更改时，才需要使用系统助理服务。

Exchange Server 将它的所有配置信息存储在 Active Directory® 目录服务中，这包括有关以下各项的信息：收件人策略、简单邮件传输协议 (SMTP) 虚拟服务器配置、RPC over HTTP（超文本传输协议远程过程调用）设置和用户邮箱。但是，SMTP 从 Internet 信息服务 (IIS) 元数据库中读取其设置。为了将 Exchange 用于 SMTP 和 RPC over HTTP 功能的信息填充到 IIS 元数据库，系统助理中的目录服务到元数据库 (DS2MB) 组件会将配置信息从 Active Directory 复制到 IIS 元数据库。如果未运行系统助理，对存储在 Active Directory 中的 Exchange Server 配置设置所做的更改将不会被复制到 Exchange Server 的 IIS 元数据库中。如果未对配置进行更改，且未处理 SMTP 邮件，则可将系统助理服务保持为停止状态。

如果确实有配置要进行更改，请启动系统助理服务，并进行配置更改，然后等待这些更改被复制到 IIS 元数据库。若要确定更改是否已从 Active Directory 复制到 IIS 元数据库，请在 Exchange 服务器的应用程序事件日志中，检查是否存在事件源为 MSExchangeMU 并且事件 ID 为 1005 的三个条目。成功进行 DS2MB 复制之后，将记录这些事件。一旦记录了这些事件，即可停止系统助理服务。

除非 Exchange 2000 Server 或 Exchange Server 2003 前端服务器上正在使用 SMTP，否则，建议的配置是停止系统助理服务，然后将其设置为禁用。在使用 SMTP 的 Exchange 2000 Server 或 Exchange Server 2003 前端服务器以及所有其他 Exchange Server 计算机上，必须运行 Exchange 系统助理服务才能传递邮件、为 SMTP 和邮箱存储事务提供服务以及执行 DS2MB 复制。

Exchange 系统助理服务应当总是运行在包含邮箱或公用文件夹的后端服务器和任何其他 Exchange 服务器上。

解决此警告问题

  1. 打开"服务"Microsoft 管理控制台 (MMC) 管理单元。

  2. 在右侧窗格中，向下滚动屏幕到"Microsoft Exchange 系统助理"服务，并双击。此时会显示"系统助理服务属性"对话框。

  3. 在"启动类型"下拉菜单中，将值设置为"自动"。

  4. 单击"启动"以启动系统助理服务。

  5. 单击"确定"，以保存更改并关闭"系统助理服务属性"对话框。

  6. 关闭服务管理单元。

有关禁用系统助理服务以及保护 Exchange Server 的详细信息，请参阅"Securing Exchange 2000 Servers Based on Role"（英文）(http://go.microsoft.com/fwlink/?linkid=35585)。


指明性能问题的 Exchmem 堆
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具已分析 MSExchangeIS 性能对象下的 Exchmem Heap 性能计数器，以确定 Exchange 服务器的性能是否已降低。Exchange Server 分析工具如下所示报告 Exchmem 计数器：

  • 如果 Exchmem: Number of heaps with memory errors 的数目大于 0，Exchange Server 分析工具将报告警告。如果此值大于 5，Exchange Server 分析工具将报告错误。

  • 如果 Exchmem: Number of memory errors 的数目大于 500，Exchange Server 分析工具将报告错误。

  • 如果 Exchmem: Number Additional Heaps 的数目大于 3，Exchange Server 分析工具将报告错误。

Store.exe 进程使用其自己的堆分配机制和结构。这些机制和结构称为 Exchmem。启动时，Store.exe 进程会创建多个 Exchmem 堆。Store.exe 不会增加堆数，除非现有堆数已完全使用，或碎片化程度使分配因为找不到足够的连续内存而无法成功进行。

如果存在内存利用率问题或内部碎片（即 Exchmem 堆中的碎片，这些堆驻留在 Exchange 存储的虚拟内存空间内部），Store.exe 进程将创建新的 Exchmem 堆。

通常，如果 Store.exe 进程必须反复创建更多的堆，那么整体 Exchange 存储虚拟内存将碎片化或被耗尽。通过跟踪上面列出的计数器，可以确定 Exchmem 堆是否是问题的来源，或是否因为堆的碎片化而降低了性能。

纠正警告或错误

  • 下载并安装最新的 Exchange 存储更新。

    • 要获得最新的 Exchange Server 2003 下载，请访问 Downloads for Exchange Server 2003 网站 (http://go.microsoft.com/fwlink/?LinkId=25097)。

    • 要获得最新的 Exchange 2000 Server 下载，请访问 Downloads for Exchange 2000 Server 网站 (http://go.microsoft.com/fwlink/?LinkId=33457)。

  • 为 Store.exe 进程中运行的所有应用程序运行并安装最新的更新。有时，Store.exe 进程中运行的第三方应用程序可能会造成堆的碎片化。

  • 考虑将用户邮箱从受影响的服务器转移到其他服务器，以减小服务器的负载。有关详细信息，请参阅将用户邮箱移至其他服务器。

  • 确定了问题原因之后，可以根据需要重新启动，以便重置内存。

详细信息

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。


Windows System32 文件夹中具有 EXCHMEM.DLL
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定它是否可以读取 \Windows\System32\Exchmem.dll. 的 Version 关键字的值。如果 Exchange Server 分析工具可以读取 Version 关键字，则 System32 文件夹中具有 Exchmem.dll。

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定 msExchExchangeServer 对象类中所有对象的 serialNumber 属性值。如果字符串值包括"Version 6"，则表示计算机运行的是 Exchange 2000 Server 或 Exchange Server 2003。

如果下列条件为真，则 Exchange Server 分析工具将显示最佳做法消息：

  • System32 文件夹中具有 Exchmem.dll。

  • 计算机运行的是 Exchange 2000 Server 或 Exchange Server 2003。

通常，Exchange 服务器上不能有两个 Exchmem.dll 副本。但是，有时通过就地升级早期产品版本来添加第二个 Exchmem.dll 文件。如果有两个版本的该文件，则可能导致 Service Pack 安装过程中的设置操作失败。为了防止出现问题，建议重命名或删除 \Windows\System32 文件夹中的 Exchmem.dll 文件。

若要删除或重命名 Exchmem.dll 的第二个版本，请执行下列操作：

  1. 停止所有 Exchange 服务。

  2. 重命名或删除 \Windows\System32 文件夹中的 Exchmem.dll 文件。

  3. 重新启动所有 Exchange 服务。


发现的致命错误
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-10-06

Microsoft® Exchange Server 分析工具试图访问各种特定的资源以执行其分析：

  • Microsoft Active Directory® 目录服务

  • Exchange Server 邮件跟踪中心

  • Microsoft Windows® 注册表

  • Microsoft Windows® Management Instrumentation (WMI)

  • Internet 信息服务 (IIS) 元数据库

如果 Exchange Server 分析工具不能访问一个或多个所需的资源，则 Exchange Server 分析工具会显示一个错误。

此错误表明，因为不能访问一个或多个基本资源，所以不可能进行其他分析。

若要解决此错误，请复查 Exchange Server 分析工具提供的该资源特定错误指南和链接。


未启用服务器的 FCL 日志记录
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-20

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务以确定所有具有 msExchExchangeServer 对象类的对象的 serialNumber 属性值。如果该字符串值包括 Version 5.5，则计算机正在运行 Microsoft Exchange Server 5.5。如果该字符串值包括 Version 6.0，则该计算机正在运行 Exchange 2000 Server。如果该字符串值包括 Version 6.5，则该计算机正在运行 Exchange Server 2003。

Exchange Server 分析工具还会查询下列注册表项中现有的"禁用调用跟踪"子项，以确定是否已为 Exchange 服务器启用了 Microsoft Exchange 函数调用日志记录 (FCL) 功能：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server 可跟踪 Microsoft Exchange Information Store 服务 (Store.exe) 所执行的内部调用的性能。可以使用 FCL 隔离可能是造成性能问题根本原因的组件和函数调用。

Microsoft Exchange Information Store 服务中的 FCL 功能会跟踪对以下组件的相关调用：

  • 本地安全身份验证服务器 (Lsass.exe)

  • DSAccess

  • 可扩展存储引擎 (ESE)

  • IMAIL

  • Virusscan

FCL 是一种低开销日志记录，收集有关问题方案（如 Exchange Server 中的关机问题或在 Exchange Information Store 服务 (Store.exe) 出现性能降低或无响应时的情况）的数据。

FCL 启用后，将自动记录函数调用数据。不需要用户干预或特定配置，例如获取生产服务器的用户转储文件或使用调试程序。

默认情况下，FCL 已在 Exchange Server 2003 上启用，但在 Exchange 2000 Server 上必须明确启用。

如果满足以下条件，则 Exchange Server 分析工具将显示最佳实践消息：

  • 服务器正在运行 Exchange 2000 Server，并且不存在"禁用调用跟踪"子项，或者存在"禁用调用跟踪"但包含 0 以外的值。

  • 服务器正在运行 Exchange 2003 Server，并且"禁用调用跟踪"子项存在且包含 0 以外的值

此最佳实践消息指示 FCL 已禁用。

建议您最好在所有 Exchange 服务器上启用 FCL。

重要信息：
本文包含有关如何编辑注册表的信息。在编辑注册表之前，请确保已了解在出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
在 Exchange 2000 Server 上启用函数调用日志记录

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Disable Call Tracing

  3. 在右侧窗格中，双击"禁用调用跟踪"。如果"禁用调用跟踪"子项不存在，请将其作为新 DWORD 值创建。

  4. 将"禁用调用跟踪"子项的值配置为 0。
注意：
默认情况下，FCL 在 Exchange 2000 Server 上处于关闭状态，并且此值会设置为 1。
  1. 关闭注册表编辑器。

  2. 重新启动 Exchange Information Store 服务，以便使这些更改生效。

 在 Exchange Server 2003 上启用函数调用日志记录

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Disable Call Tracing。

  3. 在右侧窗格中，双击"禁用调用跟踪"。

  4. 将"禁用调用跟踪"子项的值配置为 0。
注意：
默认情况下，FCL 在 Exchange Server 2003 中处于打开状态，并且已创建"禁用调用跟踪"子项，该子项的值已设置为 0 以外的值以使其关闭。
  1. 关闭注册表编辑器。

  2. 重新启动 Exchange Information Store 服务，以便使这些更改生效。

编辑注册表之前，若要了解有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


可用页表条目数达到临界阈值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_PerfRawData_PerfOS_Memory Microsoft Windows® Management Instrumentation (WMI) 类，以确定 FreeSystemPageTableEntries 对象的当前值。如果 FreeSystemPageTableEntries 的值小于或等于 5000，则会显示错误。

不管安装了多少物理 RAM，Microsoft Windows Server™ 2003 和 Windows 2000 Server 可以直接寻址的内存地址空间最多都是 4 GB。从进程角度看，虚拟地址的每个元素在概念上都是指一个字节的物理内存。虚拟内存管理器 (VMM) 配合处理器内存管理器单元 (MMU) 负责将每个虚拟地址转换或映射到相应的物理地址。VMM 执行映射的过程是：先将 RAM 划分为固定大小的页框架，再创建系统页表条目 (PTE) 来存储有关这些页框架的信息，然后映射它们。系统 PTE 是小型内核模式的内存缓冲区，该缓冲区用来与磁盘 I/O 子系统和网络通信。每个 PTE 代表一个页框架，并包含 VMM 用来定位页的所需信息。

在基于 x86 并使用 4 KB 页大小的系统上，映射 2 GB 地址空间所需的最大 PTE 数是 524,288 (2 GB/4 KB)。在使用 /3GB 开关的类似系统上，映射 3 GB 地址空间所需的 PTE 数是 786,432 (3 GB/4 KB)。在典型系统上，按如下方式使用该空间：

  • 最多 50,000 PTE（大约 195 MB 地址空间）被保留用于常规用途。

  • 其余部分用于映射系统缓存、超空间、页面缓冲池、非页面缓冲池、故障转储区域等等。

该 PTE 池大小是在系统启动时基于系统中的物理内存数量而自动确定的。该池位于页面缓冲池和非页面缓冲池之间，后者也会随系统中的物理内存数量增长。

系统 PTE 池可能被过度使用，并严重碎片化。这会导致驱动程序可能无法加载的情况。而且，如果系统 PTE 池完全耗尽，则系统的其他部分的性能将会降低，甚至造成线程无法创建、系统停止运行和系统可能崩溃。

运行正常的 Exchange Server 计算机应当始终有至少 8,000 个系统 PTE 可用。如果可用的系统 PTE 数低于 8,000 但仍然在 5,000 以上，则会显示在 可用页表条目数达到警告阈值 中所述的警告。当可用的系统 PTE 数低于 5,000 时，则会显示该错误。

若要解决该问题，可以使用下面的过程来适当地配置 Exchange Server 计算机操作系统的 SystemPages 注册表值。在有 1 GB 或更多 RAM 的 Windows Server 2003 上运行 Exchange 2003 Service Pack 1 (SP1) 时，建议将 SystemPages 注册表项设置为零。此建议与对 Windows 2000 Server 的建议明显不同，Windows 2000 Server 将 SystemPages 的值设置为 31000（十进制）。

执行下述过程之后，应当监视可用的系统 PTE 数。可以通过用 Windows 系统监视器（也称为"性能监视器"）监视 Memory | Free System Page Table Entries 性能计数器来监视该数字。如果在进行注册表更改之后，可用的系统 PTE 数仍然很低，则应当检查下列内容，以确保 Exchange Server 计算机已进行最佳配置：

  • 驱动程序 出现故障的驱动程序是系统 PTE 较低的一个最常见原因。请咨询硬件制造商，以确保所有硬件均使用的是最新驱动程序。也有可能需要降级到更基本的驱动程序。例如，运行基于服务器的应用程序（例如，Exchange Server）的计算机通常不需要有具备所有功能的最高级的视频驱动程序。而更基本的驱动程序通常就已足够。从高级视频驱动程序切换到基本视频驱动程序应当可以增加可用的系统 PTE 数。

  • 系统配置 如果 Windows Server 2003 系统安装了 1 GB 或更多物理内存，应当检查并确保它的 Boot.ini 文件正确配置了 /3GB 和 /USERVA=3030 开关。有关这方面的信息，请参阅 Microsoft 知识库文章 823440"在基于 Windows Server 2003 的系统中安装 Exchange Server 2003 时必须使用 /3GB 参数"(http://support.microsoft.com/kb/823440/zh-cn) 和 810371"XADM:在基于 Windows 2003 Server 的 Exchange Servers 上使用 /Userva 参数"(http://support.microsoft.com/kb/810371/zh-cn)。

  • 事件日志 检查 Exchange 服务器上的应用程序事件日志中是否有相关的错误和警告，尤其是 MSExchangeIS 事件 9582（错误和警告）、9665（警告）和 12880（错误）。如果出现事件 9665，则还可以说明未将 SystemPages 配置成使系统获得最佳性能的状态。有关这些事件的详细信息，请参阅知识库文章 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://support.microsoft.com/kb/325044/zh-cn)。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

在运行 Windows 2000 Server 的计算机上更正此错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. 在右侧窗格中，双击 SystemPages。

  4. 在"数值数据"字段中，键入十进制值 31000（十进制的 31000 代表十六进制的 7918。Regedit.exe 默认为十六进制值），然后单击"确定"。

  5. 关闭注册表编辑器，并重新启动计算机，以使更改生效。

在运行 Windows Server 2003 最初发行版的计算机更正此错误

  • 查看 Microsoft 知识库文章 894067"The Performance tool does not accurately show the available Free System Page Table entries in Windows Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067)，确定实际的可用页表条目数。

在运行 Windows Server 2003 SP1 的计算机上更正此错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. 在右侧窗格中，双击 SystemPages。

  4. 在"数值数据"字段中，键入 0，再单击"确定"。

  5. 关闭注册表编辑器。

  6. 用鼠标右键单击"我的电脑"，再单击"属性"。将出现"系统属性"对话框。

  7. 单击"高级"。

  8. 在"启动和故障恢复"区域中，单击"设置"。将出现"启动和故障恢复"对话框。

  9. 在"系统启动"区域中，单击"编辑"。这将在记事本中打开 Windows Boot.ini 文件。

  10. 查看 [Operating Systems] 部分。

    1. 如果存在 /3GB 开关，但并非 /USERVA=3030 开关，在启动行中添加开关 /USERVA=3030 即可将其配置为 /3GB /USERVA=3030。

    2. 如果 /3GB /USERVA=3030 开关已配置，将 /USERVA 开关的值更改为 /USERVA=2970。

  11. 保存更改，关闭记事本。

  12. 单击"确定"两次关闭打开的对话框，再重新启动计算机，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关优化 Exchange Server 的内存的详细信息，请参阅下列知识库文章：

  • 894067"The Performance tool does not accurately show the available Free System Page Table entries in Windows Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067)

  • 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://support.microsoft.com/kb/325044/zh-cn)

  • 823150"如何收集数据以解决 Exchange Server 2003 虚拟内存问题"(http://support.microsoft.com/kb/823150/zh-cn)

  • 815372"如何在 Exchange Server 2003 中优化内存使用"(http://support.microsoft.com/kb/815372/zh-cn)

  • 311901"The effects of 4GT tuning on System Page Table Entries"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


可用页表条目数达到警告阈值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_PerfRawData_PerfOS_Memory Microsoft Windows® Management Instrumentation (WMI) 类，以确定 FreeSystemPageTableEntries 对象的当前值。如果 FreeSystemPageTableEntries 的值大于 5000 但小于或等于 8000，则会显示警告。

不管安装了多少物理 RAM，Microsoft Windows Server™ 2003 和 Windows 2000 Server 可以直接寻址的内存地址空间最多都是 4 GB。从进程角度看，虚拟地址的每个元素在概念上都是指一个字节的物理内存。虚拟内存管理器 (VMM) 配合处理器内存管理器单元 (MMU) 负责将每个虚拟地址转换或映射到相应的物理地址。VMM 执行映射的过程是：先将 RAM 划分为固定大小的页框架，再创建系统页表条目 (PTE) 来存储有关这些页框架的信息，然后映射它们。系统 PTE 是小型内核模式的内存缓冲区，该缓冲区用来与磁盘 I/O 子系统和网络通信。每个 PTE 代表一个页框架，并包含 VMM 用来定位页的所需信息。

在基于 x86 并使用 4 KB 页大小的系统上，映射 2 GB 地址空间所需的最大 PTE 数是 524,288 (2 GB/4 KB)。在使用 /3GB 开关的类似系统上，映射 3 GB 地址空间所需的 PTE 数是 786,432 (3 GB/4 KB)。在典型系统上，按如下方式使用该空间：

  • 最多 50,000 PTE（大约 195 MB 地址空间）被保留用于常规用途。

  • 其余部分用于映射系统缓存、超空间、页面缓冲池、非页面缓冲池、故障转储区域等等。

该 PTE 池大小是在系统启动时基于系统中的物理内存数量而自动确定的。该池位于页面缓冲池和非页面缓冲池之间，后者也会随系统中的物理内存数量增长。

系统 PTE 池可能被过度使用，并严重碎片化。这会导致驱动程序可能无法加载的情况。而且，如果系统 PTE 池完全耗尽，则系统的其他部分的性能将会降低，甚至造成线程无法创建、系统停止运行和系统可能崩溃。

运行正常的 Exchange Server 计算机应当始终有至少 8,000 个系统 PTE 可用。如果可用的系统 PTE 数低于 5,000，将显示在 可用页表条目数达到临界阈值 中描述的错误。如果可用的系统 PTE 数低于 8,000，但仍然在 5,000 以上，则显示该警告。

若要解决该问题，可以使用下面的过程来适当地配置 Exchange Server 计算机的操作系统的 SystemPages 注册表值。在有 1 GB 或更多 RAM 的 Windows Server 2003 上运行 Exchange 2003 Service Pack 1 (SP1) 时，建议将 SystemPages 注册表项设置为零。此建议与对 Windows 2000 Server 的建议明显不同，Windows 2000 Server 将 SystemPages 的值设置为 31,000（十进制）。

执行下述过程之后，应当监视可用的系统 PTE 数。可以通过用 Windows 系统监视器（也称为"性能监视器"）监视 Memory | Free System Page Table Entries 性能计数器来监视该数字。如果在进行本文下面描述的注册表更改之后，可用的系统 PTE 数仍然很低，则应当检查下列内容，以确保 Exchange Server 计算机已进行最佳配置：

  • 驱动程序 出现故障的驱动程序是系统 PTE 较低的一个最常见原因。请与硬件制造商联系，以确保所有硬件均使用的是最新驱动程序。也有可能需要降级到更基本的驱动程序。例如，运行基于服务器的应用程序（例如，Exchange Server）的计算机通常不需要有具备所有功能的最高级的视频驱动程序。而更基本的驱动程序通常就已足够。从高级视频驱动程序切换到基本视频驱动程序应当可以增加可用的系统 PTE 数。

  • 系统配置 如果 Windows Server 2003 系统安装了 1 GB 或更多物理内存，应当检查并确保它的 Boot.ini 文件正确配置了 /3GB 和 /USERVA=3030 开关。有关这方面的信息，请参阅 Microsoft 知识库文章 823440"在基于 Windows Server 2003 的系统中安装 Exchange Server 2003 时必须使用 /3GB 参数"(http://support.microsoft.com/kb/823440/zh-cn) 和"XADM:在基于 Windows 2003 Server 的 Exchange Servers 上使用 /Userva 参数"(http://support.microsoft.com/kb/810371/zh-cn)。

  • 事件日志 检查 Exchange 服务器上的应用程序事件日志中是否有相关的错误和警告，尤其是 MSExchangeIS 事件 9582（错误和警告）、9665（警告）和 12880（错误）。事件 9665 还可以说明未将 SystemPages 配置成使系统获得最佳性能的值。有关这些事件的详细信息，请参阅知识库文章 324044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://support.microsoft.com/kb/325044/zh-cn)。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

在运行 Windows 2000 Server 的计算机上解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. 在右侧窗格中，双击 SystemPages。

  4. 在"数值数据"字段中，键入十进制值 31000（十进制的 31000 代表十六进制的 7918。Regedit.exe 默认为十六进制值），然后单击"确定"。

  5. 关闭注册表编辑器，并重新启动计算机，以使更改生效。

在运行 Windows Server 2003 最初发行版的计算机上解决此警告问题

  • 查看 Microsoft 知识库文章 894067"The Performance tool does not accurately show the available Free System Page Table entries in Windows Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067)，确定实际的可用页表条目数。

在运行 Windows Server 2003 SP1 的计算机上解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. 在右侧窗格中，双击 SystemPages。

  4. 在"数值数据"字段中，键入 0，再单击"确定"。

  5. 关闭注册表编辑器。

  6. 用鼠标右键单击"我的电脑"，再单击"属性"。将出现"系统属性"对话框。

  7. 单击"高级"。

  8. 在"启动和故障恢复"区域中，单击"设置"。将出现"启动和故障恢复"对话框。

  9. 在"系统启动"区域中，单击"编辑"。这将在记事本中打开 Windows Boot.ini 文件。

  10. 查看 [Operating Systems] 部分。

    1. 如果存在 /3GB 开关，但并非 /USERVA=3030 开关，在启动行中添加开关 /USERVA=3030 即可将其配置为 /3GB /USERVA=3030。

    2. 如果 /3GB /USERVA=3030 开关已配置，将 /USERVA 开关的值更改为 /USERVA=2970。

  11. 保存更改，关闭记事本。

  12. 单击"确定"两次关闭打开的对话框，再重新启动计算机，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关优化 Exchange Server 的内存的详细信息，请参阅下列知识库文章：

  • 894067"The Performance tool does not accurately show the available Free System Page Table entries in Windows Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067)

  • 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://support.microsoft.com/kb/325044/zh-cn)

  • 823150"如何收集数据以解决 Exchange Server 2003 虚拟内存问题"(http://support.microsoft.com/kb/823150/zh-cn)

  • 815372"如何在 Exchange Server 2003 中优化内存使用"(http://support.microsoft.com/kb/815372/zh-cn)

  • 311901"The effects of 4GT tuning on System Page Table Entries"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


前端服务器正在运行站点复制服务
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Exchange Server Microsoft Windows® Management Instrumentation (WMI) 对象（Exchange_Server 类），以确定服务器的 IsFrontEndServer 值。如果值为 True，那么 Exchange 服务器正在充当前端服务器。Exchange Server 分析工具还查询 MSExchangeSRS WMI 对象（Win32_Service 类），以确定该对象的 Started 属性的值。如果值为 True，那么该服务器正在运行站点复制服务。

如果 Exchange 服务器被指定为前端服务器，并且还有正在运行的站点复制服务实例，则会显示警告。

如果拓扑中包含运行 Exchange Server 5.5 版和 Exchange 2000 Server 或 Exchange Server 2003 的服务器，Exchange 将使用站点复制服务。使用该服务，更高版本的 Exchange 就可以将服务器配置信息以与 Exchange Server 5.5 目录兼容的形式复制到 Exchange Server 5.5 服务器，并且它们还可以正确地处理从 Exchange Server 5.5 目录复制来的配置信息，以便这些信息可以存储在 Active Directory® 目录服务中。如果您的拓扑结构被配置为使用前端和后端服务器，则站点复制服务应当只在后端服务器上运行。对于 Exchange 2000 Server Service Pack 2 以及之前的版本，站点复制服务不能在前端服务器上正确工作，并且可能导致问题。

若要解决该问题，请将前端服务器转换为后端服务器，并配置新的前端服务器。建议不要试图从服务器上删除站点复制服务。

更正此错误

  1. 配置新的前端服务器。

  2. 在有问题的前端服务器上，在 Exchange 系统管理器的"服务器"下，用鼠标右键单击问题服务器，并单击"属性"。

  3. 清除"这是前端服务器"复选框。

有关前端服务器和站点复制服务的详细信息，请参阅 Microsoft 知识库文章 313646"Services are Disabled on Front-end Servers After an Exchange 2000 Server SP2 Upgrade"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=313646)。


bin 文件夹中缺少 GAPI32.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查是否存在下列几个核心 Exchange 二进制文件：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


system32 文件夹中缺少 GAPI32.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查是否存在下列几个核心 Exchange 二进制文件：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


GlobalFlag 已设置
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取下列注册表项，以确定 GlobalFlag 项的值：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\MAD.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\INETINFO.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\EMSMTA.EXE

如果 Exchange Server 分析工具发现 GlobalFlag 的值存在，并被配置为 0 或 Null 以外的任何值，则显示警告。

GlobalFlag 注册表值设置是一个位掩码，它确定已对特定的进程启用了哪些调试选项。在这种情况下，Exchange Server 分析工具将具体检查是否已为多种 Exchange 组件启用了任何调试选项：

  • STORE.EXE （信息存储进程）

  • MAD.EXE （系统助理进程）

  • INETINFO.EXE （IIS 管理和父进程）

  • EMSMTA.EXE （邮件传输代理进程）

除非您要在 Microsoft 产品支持服务的帮助下对问题进行调试或跟踪，否则建议您将 GlobalFlag 值始终设置为 0，或将其完整删除（效果相同）。

默认情况下 GlobalFlag 注册表值不存在，如果需要调试 STORE.EXE 进程（或任何其他进程），必须手动添加该注册表值。可以使用 Microsoft Windows Server™ 2003 支持工具（在 Windows CD 内的 \Support 文件夹中）所附带的 Gflags 工具。另外，可以手动将该值设置为 0，或使用注册表编辑器将 GlobalFlag 值完全删除。本文将描述这两个过程。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

使用 GFlags 纠正该错误

  1. 单击"开始"，再单击"运行"，然后在"打开"字段中执行 GFlags。将出现 Global Flags 用户界面。

  2. 在 Image File Name 字段中，键入 STORE.EXE。

  3. 选择 Image File Options。

  4. 清除所有复选框，再单击 Apply。

  5. 对本文列出的每个 Exchange 进程重复步骤 2 到 4。

  6. 单击 OK 退出 GFlags 工具，并重新启动受影响的服务，以使更改生效。

使用注册表编辑器纠正该错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

  3. 删除名为 GlobalFlag 的值。

  4. 对本文列出的每个 Exchange 进程重复步骤 2 和 3。

  5. 退出注册表编辑器，并重新启动受影响的服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


出现大量 ACL 升级故障
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_PerfRawData_MSExchangeIS_MSExchangeIS Microsoft Windows® Management Instrumentation (WMI) 类，以确定 ACLUpgradefailures 关键字的当前值。ACLUpgradefailures 关键字代表 MSExchangeIS 性能对象下的 ACL Upgrade: failures 性能计数器。

如果 Exchange Server 分析工具发现 ACLUpgradefailures 关键字的值大于 500，则 Exchange Server 分析工具将显示警告。

此警告表明 Exchange 服务器已报告了许多访问控制列表 (ACL) 升级故障。过多的 ACL 升级故障可能会造成严重的性能问题，包括信息存储进程 (store.exe) 中的随机停止。

ACL 升级故障的原因可能有很多，在符合下列条件时，会发生 ACL 升级故障：

  • 在混合模式的 Exchange 组织中，在实现 Active Directory 连接器 (ADC) 服务器之前未运行 Exchange Server 5.5 版一致性调整程序。Exchange Server 5.5 一致性调整程序删除孤立的 ACL。

  • Active Directory 复制无法正常工作。

  • Active Directory 连接器复制无法将帐户正确地从 Exchange Server 5.5 复制到 Active Directory。

  • 用户帐户的迁移不正确。

解决此警告问题

  1. 查看 Microsoft 知识库文章 812963"Using the Ignore Zombie Users Registry Key"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812963)。

  2. 在了解了使用 Ignore Zombie Users 注册表项的影响后，根据自己的决定添加该注册表项。

  3. 运行 Exchange Server 分析工具或监视 ACL Upgrade: failures 性能计数器，以查找过多的 ACL 升级故障。


活动频繁的 Exmon 用户
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-04-21

Microsoft® Exchange Server 分析工具使用 Exchange Server User Monitor (ExMon) 工具确定用户或进程（或者用户组或进程组）是否为造成当前服务器的负载百分比严重过高的原因。

下面是 ExMon 评估的几种方案：

  • 客户端限制

  • 大批量远程过程调用 (RPC) 操作

  • 大批量 RPC 同步操作

  • 大量客户端联机操作

  • 用户视图操作

以下各节针对每种方案提供了详细信息和建议的操作。

客户端限制

在此方案中，ExMon RPC 数据指示客户端计算机限制是导致服务器负载过高的原因。在 MAPI 的上下文中，限制是指称为"限制"的 MAPI 操作。此操作用于选择与特定条件匹配的项目。"限制"操作是请求 Exchange 针对一个或一组文件夹创建视图（实际上为具有关联条件的数据库表）的过程的一部分。如果一个或一组文件夹的视图已有匹配的限制，则 Exchange 将使用现有的视图满足用户的请求。如果视图没有匹配的限制，则 Exchange 将创建一个新视图。创建视图的成本高于使用现有视图的成本。

多次移动邮箱之后，短期内客户端限制的成本更高。使用 move-mailbox 操作，服务器可以针对文件夹重建索引。因此，如果客户是首次在新的服务器上查看文件夹，则必须重新创建所有限制，因而可能导致性能降低。如果最近没有移动邮箱，则请检查是否存在下列情况：

  • 客户端计算机上未安装其他 MAPI 应用程序。通常，Microsoft Office Outlook® 加载项或其他 MAPI 应用程序可能导致创建太多的限制。

  • 调整了邮箱的大小并在整个组织内适当地设置了限制。

有关邮箱大小和项目数的详细信息，请参阅 Microsoft Exchange Team Blog 上的"Recommended Mailbox Size Limits"（英文）(http://go.microsoft.com/fwlink/?linkid=55097)。

大批量 RPC 操作

大批量 RPC 操作的示例包括：在一个操作中，移动、删除或设置成百上千个项目的属性（即，"读取标志"）。这些类型的操作可能在短期内导致服务器性能降低。如果经常执行大批量 RPC 操作，且服务器出现了磁盘或处理器瓶颈，则同一服务器上其他用户的 Outlook 性能将会降低。

更正此错误

  1. 验证是否已设置邮箱限制。

  2. 建议用户将多个项目压缩为 .pst 文件。

    注意：
    最佳做法是使常用文件夹包含的项目数低于 5,000。

大批量 RPC 同步操作

大批量 RPC 同步操作指示当前有许多用户正在对项目进行同步。因而增加了服务器的负载。

更正此错误

  • 确保您已根据在缓存 Exchange 模式下运行 Outlook 的客户端计算机数调整了 Exchange 服务器。有关详细信息，请参阅"Introduction to Exchange Server 2003 RPC over HTTP Deployment Scenarios"（英文）(http://go.microsoft.com/fwlink/?LinkId=47577)。

  • 延缓缓存 Exchange 模式客户端请求有助于防止因出现大批量 RPC 同步操作而导致性能问题。有关详细信息，请参阅 Microsoft 知识库文章 818484"Registry Values and Counters That You Can Use to Configure and Monitor Outlook Client Synchronization"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=818484)。

大量客户端联机操作

有时，由于在各个用户当中分布的负载过高，Exchange 性能问题可能会出现罕见的高峰。在组织成长过程中，如果计划有误，便会导致这一问题。如果您在调整组织规模时遵循了 Microsoft 的最佳做法，但是仍然遇到了因大量客户端联机操作而导致的性能降低问题，则表示您的用户正在运行第三方 MAPI 应用程序或 Outlook 插件。

用户视图操作

ExMon RPC 数据指示用户正在构建新的视图，该视图可能导致服务器上负载过高。在此方案中，单个用户导致了 RPC CPU 使用率的百分比过高。

若要调查此问题，请考虑下列情况：

  • 用户可能正在对包含大量项目的文件夹执行操作。若要更正此问题，请建议用户减少所有单个文件夹中的项目数。最佳做法是使文件夹包含的项目数低于 2,000。

  • 用户可能正在运行编写质量很差并能导致过载的应用程序。若要更正此问题，请删除此应用程序。

详细信息

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关邮箱大小和项目数的详细信息，请参阅 Microsoft Exchange Team Blog 上的"Recommended Mailbox Size Limits"（英文）(http://go.microsoft.com/fwlink/?linkid=55097)。

  • 有关邮箱限制的详细信息，请参阅 Microsoft Exchange Team Blog 上的"Putting the Restrictions on Restrictions"（英文）(http://go.microsoft.com/fwlink/?LinkId=55098)。

  • 有关 ExMon 的详细信息，请参阅 ExMon 下载网站 (http://go.microsoft.com/fwlink/?LinkId=54983)。


IIS 正在 64 位计算机上创建 32 位进程
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-05-03

Microsoft Exchange Server 分析工具在 Internet Information Services (IIS) 元数据库中查询运行 Exchange Server 2007 的所有 64 位 Windows Server 2003 Service Pack 1 (SP1) 服务器上 w3svc/AppPools/Enable32BitAppOnWin64 元数据库属性的值，以确定 IIS 是否已配置为创建 32 位工作进程。

值 1 (true) 表明 IIS 已配置为创建 32 位工作进程。值 0 (false) 表明 IIS 已配置为创建 64 位工作进程。

如果 Exchange 分析工具确定 w3svc/AppPools/Enable32BitAppOnWin64 元数据库属性的值设置为 1 (true)，则 Exchange 分析工具将显示错误。此错误表明 IIS 已配置为在运行 Exchange 2007 的 64 位 Windows 服务器上创建 32 位工作进程。此配置将导致 Exchange 2007 虚拟目录功能失常。

若要解决此错误，请将 IIS 配置为在运行 Exchange 2007 的 64 位 Windows Server 2003 (SP1) 服务器上创建 64 位工作进程。

将 IIS 切换到 64 位模式

  1. 打开命令提示符。

  2. 键入以下命令：

    cscript c:\inetpub\adminscripts\adsutil.vbs SET /w3svc/AppPools/Enable32BitAppOnWin64 False

  3. 按 Enter

有关在 64 位 Windows Server 2003 SP1 服务器上运行 IIS 6.0 32 位工作进程的详细信息，请参阅 Microsoft 知识库文章 895976"Windows Server 2003 SP1 为 IIS 6.0 中的 32 位 Web 应用程序启用 WOW64 兼容性"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=895976)。


改进内核内存
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具测试系统内存级别，以验证是否在可接受的范围内。如果 Exchange Server 分析工具发现任何性能监视器 (Perfmon) 内核内存计数器低于相应的级别，则会显示故障排除消息。

Microsoft Windows® 内核内存由多个内存结构组成，包括页面缓冲池内存和非页面缓冲池内存以及系统页表项。操作系统使用这些内存结构（也称为内核内存）为 Exchange 等应用程序提供环境。要保持 Exchange 部署的正常运行，请确保监视内核内存。

优化内核内存可能是一项复杂的任务。有关内核内存用法的详细信息（包括故障排除信息），请参阅"Troubleshooting Exchange Server 2003 Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。释放服务器资源的一个注意事项是查看服务器上的用户邮箱负载。考虑将用户邮箱转移到其他服务器，以减少服务器负载，确认问题是否停止出现。有关详细信息，请参阅将用户邮箱移至其他服务器。

详细信息

有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

有关通过转移用户邮箱减少服务器负载的详细信息，请参阅 将用户邮箱移至其他服务器。


改善用户内存
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-04-28

Microsoft® Exchange Server 分析工具确定用户内存性能计数器超过了 Exchange 服务器的正常阈值。Exchange Server 分析工具查询 Memory 性能对象下的 Available Mbytes 性能计数器和 Memory Pages/sec 计数器。当服务器内存不足或分页率过高时，表示内存出现瓶颈。

Available MBytes 性能计数器显示可立即分配给进程或供系统使用的物理内存量 (MB)。可用内存量等于分配给备用（缓存）、可用和零页列表的内存总和。

Memory Pages/sec 性能计数器指示为解决硬页面故障从磁盘读取页或将页写入磁盘的速率。当服务器使用内存而可用内存不足时，操作系统便开始整理进程工作集并大量使用页面文件。使用页面文件会影响整体性能，因为磁盘操作比内存操作所用的时间要长。此计数器是导致系统范围的延迟的故障类型的主要指示器。它包括通过检索而消除文件系统缓存中页面故障的页。通常，应用程序需要这些页。此计数器应该始终低于 1,000。

如果 Exchange Server 分析工具发现 Available Mbytes 性能计数器指示可用内存少于 50 MB，或者向磁盘写入或从磁盘读取内存页的速率大于 1,000 页/秒，则会显示错误。

以下列表说明如何才能提高用户空间内存的性能。

解决此问题

  1. 使用 Microsoft Exchange Server 分析工具 (http://go.microsoft.com/fwlink/?LinkId=34705) 验证是否已正确配置服务器的内存设置。

  2. 删除多余的软件。为使 Exchange 可以使用更多的内存资源，请删除所有执行监视功能的第三方软件工具或所有不重要的服务类型。可以借助于性能管理单元 (Perfmon.msc) 了解应用程序所使用的内存量。

  3. 在非高峰时段运行服务器维护任务。在高峰时段运行维护工具（如 Eseutil）或任务（如邮箱管理）可能会占用可由 Exchange 使用的内存。最佳做法是在非高峰时段或在内存使用量较低的时段运行这些工具和任务。

  4. 请考虑将用户邮箱从受影响的服务器移至其他服务器，以降低服务器负载。有关详细信息，请参阅将用户邮箱移至其他服务器。

详细信息

有关详细信息，请参阅以下 Microsoft 资源：

  • 将用户邮箱移至其他服务器

  • "Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)

  • "Performance and Scalability Guide for Exchange Server 2003"中的"Optimizing Memory Usage in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)

  • Microsoft Exchange Server Best Practices Analyzer Tool v2.7（英文）(http://go.microsoft.com/fwlink/?LinkId=34705)

  • Microsoft 知识库文章 815372"如何优化 Exchange Server 2003 中的内存使用"(http://support.microsoft.com/kb/815372/zh-cn)

  • "Exchange 2003 Memory Configuration change for Windows 2003 (PAE Support)"（英文）(http://go.microsoft.com/fwlink/?LinkId=54979)

    注意：
    每个 Blog 的内容及其 URL 如有变更，恕不另行通知。


改进虚拟内存
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具已确定服务器遇到虚拟内存碎片化的问题。

在 32 位 Microsoft Windows® 系统中存在两种内存：

  • 物理内存 系统中安装的实际内存量

  • 虚拟内存地址空间 虚拟化 4GB 内存空间

不管系统安装了多少物理内存，虚拟地址空间的总计大小始终都是相同的：4 GB。对于 Exchange Server 而言，虚拟地址空间等于虚拟内存，也就是说，这两个词可以互换。但这并不适用于所有 32 版的应用程序。

在常规的操作过程中，Exchange 存储反复地分配、使用和释放虚拟内存。当频繁地分配、使用和释放虚拟内存时，会造成虚拟内存碎片化。虚拟内存碎片类似于随着时间的积累产生的文件系统碎片。经过一段时间后，分配的虚拟内存段将不再是连续的，因此性能开始下降。对于文件系统，可以运行执行文件系统碎片整理的应用程序。大多数情况下，碎片整理可以在系统联机并接受访问时完成。对于虚拟内存碎片化，没有碎片整理工具。要解决该问题，必须停止并启动 Microsoft Exchange 信息存储服务或重新启动系统。

store/inetinfo 进程中运行的第三方软件可能会造成虚拟内存碎片化。确保拥有任何第三方应用程序最新的驱动程序。如果重新启动之后问题仍然出现，请考虑禁用第三方软件，或将用户邮箱转移到其他服务器，以减小服务器负载，确认问题是否停止出现。有关详细信息，请参阅将用户邮箱移至其他服务器。

详细信息

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关解决 Microsoft Exchange Server 2003 和 Exchange 2000 Server 中的虚拟内存碎片问题的详细信息，请参阅 Microsoft 知识库文章 325044"HOW TO：解决 Exchange Server 2003 和 Exchange 2000 Server 中的虚拟内存碎片问题"(http://support.microsoft.com/kb/325044/zh-cn)。

  • 有关如何优化虚拟内存使用的详细信息，请参阅 Microsoft 知识库文章 815372"如何在 Exchange Server 2003 中优化内存使用"(http://support.microsoft.com/kb/815372/zh-cn)。

  • 有关通过转移用户邮箱来减小服务器负载的详细信息，请参阅将用户邮箱移至其他服务器。


一台或多台运行 Exchange Server 2003 的服务器上未安装智能邮件筛选器
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定组织中每个 Exchange Server 对象的 msExchExchangeServer 属性值。Exchange Server 分析工具使用此查询的结果来确定组织中运行 Exchange Server 2003 的服务器总数。Exchange Server 分析工具还查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定组织内所有的 Exchange Server 2003 服务器上是否都安装了 Microsoft Exchange 智能邮件筛选器。如果 Exchange Server 分析工具发现一台或多台运行 Exchange Server 2003 的服务器上未安装智能邮件筛选器，则 Exchange Server 分析工具将显示最佳做法消息。

智能邮件筛选器识别很可能是未经请求的商业电子邮件 (UCE) 的邮件。在典型的 Exchange Server 2003 拓扑中，智能邮件筛选器安装在网关服务器上，用于筛选传入 Internet 电子邮件。如果使用非 Microsoft 电子邮件系统作为 Internet 网关服务器，应将智能邮件筛选器安装在从网关服务器接受传入 Internet 电子邮件的 Exchange 桥头服务器上。

若要安装智能邮件筛选器，所使用的帐户应具有本地管理权限并且属于分配了 Exchange 管理员角色的组的成员。

有关详细信息，请参阅"Exchange Intelligent Message Filter"（英文）(http://go.microsoft.com/fwlink/?LinkId=21607)。


ISA Server 2000 更新可用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Microsoft Internet Security and Acceleration (ISA) Server 2000 简单邮件传输协议 (SMTP) 邮件筛选器功能所使用的 smtpfltr.dll 文件的版本。如果 Exchange Server 分析工具发现版本号的值早于 2004，则显示警告。

该警告表明有更新的 ISA Server 2000 版本可用。建议您安装 ISA Server 2000 Service Pack 2。如果正在运行 SMTP Message Screener 功能，那么升级到 Service Pack 2 是非常重要的。较低的 SMTP Message Screener 版本会产生瓶颈，并且随后会降低总体邮件吞吐量性能。

解决此警告问题

  1. 从 Microsoft 下载中心 (http://go.microsoft.com/fwlink/?linkid=37592) 下载 ISA Server 2000 Service Pack 2。

  2. 查看 Service Pack 2 发行说明 (http://go.microsoft.com/fwlink/?linkid=37584)。

  3. 使用发行说明中的说明安装 Service Pack 2。

有关 ISA Server 下载（包括 ISA Server 2000 Service Pack 2）的详细信息，请参阅"ISA Server 2000 Downloads"（英文）(http://go.microsoft.com/fwlink/?LinkId=18919)。


日记收件人无效
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-03-27

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定日记收件人对象的mailNickname 属性值是否有效。必须为有效的 mailNickname 属性设置昵称。如果指定的日记收件人对象的 mailNickname 属性无效，则日记邮件将排成队列。另外，无效的 mailNickname 可能表示日记被配置为将日记邮件复制到已禁用邮箱的收件人对象。如果 Exchange Server 分析工具发现日记收件人对象的 mailNickname 属性值无效，则 Exchange Server 分析工具将显示错误。

若要在 Exchange Server 2003 中更正此错误，请按照要求使用 Active Directory 用户和计算机以及 Exchange 系统管理器完成下列操作：

  • 启用日记收件人对象的邮箱。

  • 指定一个新的用户邮箱作为日记收件人。

若要在 Exchange Server 2003 中更正此错误，请按照要求使用 Active Directory 用户和计算机以及 Exchange 系统管理器完成下列操作：

在 Exchange Server 2003 中启用日记收件人对象的邮箱

  1. 打开"Active Directory 用户和计算机"。

  2. 在控制台树中展开域。

  3. 导航到要修改的收件人的父容器。

  4. 在详细信息窗格中，右键单击要修改的收件人，再选择"Exchange 任务"。

  5. 在"Exchange 任务向导"的"可用任务"对话框中，选择"创建邮箱"，再单击"下一步"。

  6. 在"创建邮箱"对话框中，验证"别名"、"存储"和"邮箱服务器"等字段的信息，再单击"下一步"。

  7. 单击"结束"关闭 Exchange 任务向导。
在 Exchange Server 2003 中将一个新用户邮箱指定为日记收件人

  1. 启动"Exchange 系统管理器"。

  2. 依次展开"服务器"、<您的 Exchange 服务器>、<存储组>，再右键单击邮箱存储并选择"属性"。

  3. 单击"存档由此存储中的邮箱发送或接收的所有邮件"文本右侧的"浏览"，指定一个邮箱作为日记邮箱。

    注意：
    此邮箱存储中发件人的所有日记邮件都将发送到指定的邮箱。

若要在 Exchange Server 2007 中更正此错误，请按照要求使用 Exchange 管理控制台或 Exchange 命令行管理程序完成下列操作：

  • 为日记收件人对象创建一个邮箱。

  • 将一个新用户邮箱指定为日记收件人。

在 Exchange Server 2007 中使用 Exchange 管理控制台启用日记收件人对象的邮箱

  1. 在 Exchange 管理控制台中，展开"收件人配置"，右键单击邮箱对象，然后选择"新建邮箱"以启动"新建邮箱"向导。

  2. 在"简介"窗口中，选择"用户邮箱"，然后单击"下一步"。

  3. 在"用户类型"窗口中，选择"现有用户"，然后使用"浏览"按钮来选择要创建邮箱的日记收件人对象。

  4. 在"邮箱设置"窗口中，验证"别名"、"服务器"、"存储组"和"邮箱数据库"字段的信息，然后单击"下一步"。

  5. 在"新建邮箱"窗口中，单击"新建"为日记收件人对象创建邮箱。

  6. 单击"完成"关闭"新建邮箱"向导。
在 Exchange Server 2007 中使用 Exchange 命令行管理程序启用日记收件人对象的邮箱

  1. 按照 Exchange Server 2007 产品文档"Enable-Mailbox"(http://go.microsoft.com/fwlink/?LinkID=80827) 中的指导进行操作

在 Exchange Server 2007 中将一个新用户邮箱指定为日记收件人

  1. 在 Exchange 管理器控制台中，依次展开"服务器配置"、<您的 Exchange 服务器>、<存储组>，右键单击邮箱数据库，然后选择"属性"。

  2. 在"常规"选项卡的"日记收件人"下，单击"浏览"以将邮箱指定为日记邮箱。

有关如何使用 Exchange Server 2003 部署日记解决方案的详细信息，请参阅 Journaling with Exchange Server（Exchange Server 的日记功能）(http://go.microsoft.com/fwlink/?LinkId=47581)。

有关使用 Exchange Server 2007 部署日记解决方案的详细信息，请参阅 Overview of Journaling（日记功能概述）(http://go.microsoft.com/fwlink/?LinkId=80820)。


日记收件人指向已删除的对象
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-02-01

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchMessageJournalRecipient 属性的值是否包含 DEL: 字符串。此属性表明日记已配置为将邮件复制到已删除的邮箱。要使日记正常使用，必须存在有效的日记收件人邮箱，以便复制的邮件发送到该邮箱。在邮箱数据库上启用日记时，将设置 msExchMessageJournalRecipient 属性。此属性是邮箱数据库属性，包含日记邮箱的可分辨名称。

如果日记收件人邮箱已删除，那么日记邮件将开始排队。如果 Exchange Server 分析工具发现 msExchMessageJournalRecipient 属性的值包含字符串"DEL:"，则会显示错误。

若要更正此错误，请使用 Exchange 系统管理器或 Exchange 管理控制台将一个新邮箱指定为日记收件人。

在 Exchange Server 2003 中将一个新用户邮箱指定为日记收件人

  1. 启动 Exchange 系统管理器。

  2. 依次展开"服务器"、<您的 Exchange 服务器>、<存储组>，然后右键单击邮箱存储并选择"属性"。

  3. 单击"浏览"，在"存档由此存储中的邮箱发送或接收的所有邮件"文本的右侧，将某个邮箱指定为日记邮箱。

    注意：
    此邮箱存储上的发件人的所有日记邮件均发送到您指定的邮箱。
在 Exchange Server 2007 中将一个新用户邮箱指定为日记收件人

  1. 在 Exchange 管理器控制台中，依次展开"服务器配置"、<您的 Exchange 服务器>、<存储组>，右键单击邮箱数据库，然后选择"属性"。

  2. 在"常规"选项卡的"日记收件人"下，单击"浏览"以将邮箱指定为日记邮箱。

有关如何使用 Exchange Server 2003 部署日记解决方案的详细信息，请参阅 Journaling with Exchange Server（Exchange Server 的日记功能）(http://go.microsoft.com/fwlink/?LinkId=47581)。

有关使用 Exchange Server 2007 部署日记解决方案的详细信息，请参阅 Overview of Journaling（日记功能概述）(http://go.microsoft.com/fwlink/?LinkId=80820)。


日记收件人指向已禁用的帐户
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-09

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定日记收件人对象的 msExchUserAccountControl 属性值是否已设置为表示已禁用的用户帐户。如果日记收件人对象 msExchUserAccountControl 属性的值为 2，则表示此日记已配置为将日记邮件复制到已禁用的用户帐户。此配置可导致日记邮件进行排队或发送到死信文件夹。如果 Exchange Server 分析工具发现日记收件人的 msExchUserAccountControl 属性值设置为表示已禁用的日记收件人用户帐户，则 Exchange Server 分析工具将显示错误。

若要在 Exchange Server 2003 中更正此错误，请按照要求使用 Active Directory 用户和计算机以及 Exchange 系统管理器完成下列操作：

  • 启用当前日记收件人的用户帐户。

  • 指定一个新的用户邮箱作为日记收件人。

在 Exchange Server 2003 中启用日记收件人帐户

  1. 打开"Active Directory 用户和计算机"。

  2. 在控制台树中展开域。

  3. 导航到要修改的日记收件人的父容器。

  4. 在详细信息窗格中，右键单击要修改的收件人并选择"启用帐户"。
在 Exchange Server 2003 中将一个新用户邮箱指定为日记收件人

  1. 启动 Exchange 系统管理器。

  2. 依次展开"服务器"、<您的 Exchange 服务器>、<存储组>，再右键单击邮箱存储并选择"属性"。

  3. 单击"浏览"，在"存档由此存储中的邮箱发送或接收的所有邮件"文本的右侧，指定一个邮箱作为日记邮箱。

    注意：
    此邮箱存储中发件人的所有日记邮件都将发送到指定的邮箱。

若要在 Exchange Server 2007 中更正此错误，请按照要求使用 Exchange 管理控制台或 Exchange 命令行管理程序完成下列操作：

  • 为日记收件人对象创建一个邮箱。

  • 将一个新用户邮箱指定为日记收件人。

在 Exchange Server 2007 中使用 Exchange 管理控制台启用日记收件人对象的邮箱

  1. 在 Exchange 管理控制台中，展开"收件人配置"，右键单击邮箱对象，然后选择"新建邮箱"以启动"新建邮箱"向导。

  2. 在"简介"窗口中，选择"用户邮箱"，然后单击"下一步"。

  3. 在"用户类型"窗口中，选择"现有用户"，然后使用"浏览"按钮来选择要创建邮箱的日记收件人对象。

  4. 在"邮箱设置"窗口中，验证"别名"、"服务器"、"存储组"和"邮箱数据库"字段的信息，然后单击"下一步"。

  5. 在"新建邮箱"窗口中，单击"新建"为日记收件人对象创建邮箱。

  6. 单击"完成"关闭"新建邮箱"向导。
在 Exchange Server 2007 中使用 Exchange 命令行管理程序启用日记收件人对象的邮箱

  1. 按照 Exchange Server 2007 产品文档"Enable-Mailbox"（启用邮箱）(http://go.microsoft.com/fwlink/?LinkId=80827) 中的指导进行操作。

在 Exchange Server 2007 中将一个新用户邮箱指定为日记收件人

  1. 在 Exchange 管理器控制台中，依次展开"服务器配置"、<您的 Exchange 服务器>、<存储组>，右键单击邮箱数据库，然后选择"属性"。

  2. 在"常规"选项卡的"日记收件人"下，单击"浏览"以将邮箱指定为日记邮箱。

有关如何使用 Exchange Server 2003 部署日记解决方案的详细信息，请参阅 Journaling with Exchange Server（Exchange Server 的日记功能）(http://go.microsoft.com/fwlink/?LinkId=47581)。

有关使用 Exchange Server 2007 部署日记解决方案的详细信息，请参阅 Overview of Journaling（日记功能概述）(http://go.microsoft.com/fwlink/?LinkID=80820)。


日记收件人指向本地服务器
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-09

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定邮箱存储的日记收件人对象的 msExchHomeServerName 属性值与本地服务器的 legacyExchangeDN 属性值是否匹配。如果这两个属性的值匹配，表明日记邮件已复制到运行活动日记的服务器上的邮箱中。因为可能产生大量日记通信，所以，建议日记收件人邮箱驻留在专用的日记服务器上。

如果 Exchange Server 分析工具发现日记收件人对象的 msExchHomeServerName 属性值与本地服务器的 legacyExchangeDN 属性值匹配，则会显示最佳实践消息。

有关如何使用 Exchange Server 2003 部署日记解决方案的详细信息，请参阅 Journaling with Exchange Server（Exchange Server 的日记功能）(http://go.microsoft.com/fwlink/?LinkId=47581)。

有关使用 Exchange Server 2007 部署日记解决方案的详细信息，请参阅 Overview of Journaling（日记功能概述）(http://go.microsoft.com/fwlink/?LinkId=80820)。


应隐藏日记收件人
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-09

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定是否已将日记收件人对象的 msExchHideFromAddressLists 属性值设置为 True。如果此属性的值不为 True，则指示邮箱存储的日记收件人并未在 Exchange Server 地址列表中隐藏，并且可以成为非日记相关邮件的收件人。如果 Exchange Server 分析工具发现未将日记收件人对象的 msExchHideFromAddressLists 属性值设置为 True，则 Exchange Server 分析工具将显示最佳用法消息。

若要在 Exchange Server 2003 中解决此问题，请使用 Active Directory 用户和计算机工具在 Exchange Server 地址列表中隐藏日记收件人邮箱。

若要在 Exchange Server 2007 中解决此问题，请使用 Exchange 管理控制台在 Exchange Server 地址列表中隐藏日记收件人邮箱。

在 Exchange Server 2003 的 Exchange Server 地址列表中隐藏命名的日记收件人邮箱

  1. 打开"Active Directory 用户和计算机"。

  2. 在控制台树中展开域。

  3. 导航到要修改的收件人的父容器。

  4. 在详细信息窗格中，双击要修改的收件人。

  5. 在 Exchange 的"高级"选项卡上，选中"不显示在 Exchange 地址列表中"复选框。

  6. 单击"确定"。
在 Exchange Server 2007 的 Exchange Server 地址列表中隐藏命名的日记收件人邮箱

  1. 打开 Exchange 管理控制台。

  2. 在控制台树中，导航到要修改的收件人的父容器。

  3. 在详细信息窗格中，双击指定的日记收件人的邮箱对象以显示其属性。

  4. 在"常规"选项卡上，选中"不显示在 Exchange 地址列表中"复选框。

  5. 单击"确定"。

有关如何使用 Exchange Server 2003 部署日记解决方案的详细信息，请参阅 Journaling with Exchange Server（Exchange Server 的日记功能）(http://go.microsoft.com/fwlink/?LinkId=47581)。

有关如何使用 Exchange Server 2007 部署日记解决方案的详细信息，请参阅 Overview of Journaling（日记功能概述）(http://go.microsoft.com/fwlink/?LinkId=80820)。


Junk store threshold not configured
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-07-30

Microsoft Exchange Server 分析工具会查询 Exchange 环境中是否存在 Exchange Server 2007 集线器传输角色或邮箱服务器角色。

如果找到 Exchange Server 2007 集线器传输角色或邮箱服务器角色，则 Exchange 分析工具会执行以下 Exchange 命令行管理程序 cmdlet，查询 Exchange 组织的 SCLJunkThreshold 参数值：

Get-OrganizationConfig

组织的 SCLJunkThreshold 参数指定将哪个垃圾邮件可信度 (SCL) 的邮件移动到"垃圾邮件"文件夹。

如果 Exchange 分析工具确定组织的 SCLJunkThreshold 参数设置为默认值 8，则 Exchange 分析工具将会显示警告。

此警告表示将邮件移至"垃圾邮件"文件夹的垃圾邮件可信度阈值已被设置为以下情况：可能会将来自合法用户的电子邮件也过滤掉并将其作为垃圾邮件移至"垃圾邮件"文件夹。SCLJunkThreshold 参数的建议值为 4。

若要解决此警告，请在 Exchange 命令行管理程序中使用 Set-OrganizationConfig cmdlet 将 SCLJunkThreshold 参数的值设置为 4。

使用 Set-OrganizationConfig cmdlet 将 SCLJunkThreshold 参数的值设置为 4

  1. 下列代码是 Set-OrganizationConfig 命令的示例，可将 SCLJunkThreshold 参数的值设置为 4。

  2. Set-OrganizationConfig -SCLJunkThreshold 4


内核内存耗尽
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-02-15

Microsoft Exchange 分析工具查询 Win32_NTLogEvent Microsoft Windows Management Instrumentation (WMI) 类，以确定是否在过去 24 小时内记录了 SRV（服务器）或 NCP Server 源的事件 2000、事件 2019 或事件 2020 错误。

  • SRV（服务器）事件 ID 2000 表明由于常规系统内核内存耗尽，服务器对系统服务的调用意外失败。

  • SRV 事件 ID 2019 表明系统非页面缓冲池内存耗尽。

  • SRV 事件 ID 2020 表明系统页面缓冲池内存耗尽。

如果 Exchange 分析工具发现在过去 24 小时内记录了一个或多个此类事件，Exchange 分析工具将显示错误。

此警告表明服务器的内核内存已耗尽，服务器可能遇到性能问题。

Microsoft Windows 内核内存由多种内存结构组成，包括页面缓冲池内存和非页面缓冲池内存以及系统页表项。操作系统使用这些内存结构（也称为内核内存）为 Exchange 等应用程序提供环境。

若要解决此问题，请按照下面列出的 Exchange 分析工具的针对性文章中的指导进行操作：

  • 改进内核内存

  • 页面缓冲池超过了警告阈值

  • 非页面缓冲池超过了警告阈值

  • 分页缓存超过错误阈值

通常，为了保持 Exchange 部署的正常运行，请确保定期监视 Exchange Server 的内核内存。

详细信息

有关 SRV 事件 2000、2019 或 2020 的详细信息，请参阅"Events and Errors Message Center: Event Details（事件和错误消息中心：事件详细信息）"

  • SRV 事件 ID 2000 http://go.microsoft.com/fwlink/?LinkId=83250

  • SRV 事件 ID 2019 http://go.microsoft.com/fwlink/?LinkId=83251

  • SRV 事件 ID 2020 http://go.microsoft.com/fwlink/?LinkId=83252

有关优化 Exchange Server 的内存的详细信息，请参阅下列 Microsoft 知识库文章：

  • 912376"如何监视 Exchange Server 2003 或 Exchange 2000 Server 中的页面缓冲池内存的使用并解决出现的问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=912376)

  • 815372"如何优化 Exchange Server 2003 中的内存使用"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 894067"The Performance tool does not accurately show the available Free System Page Table entries in Windows Server 2003（性能工具无法准确地显示 Windows Server 2003 中的可用系统页表项数）"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067)

  • 311901"The effects of 4GT tuning on System Page Table Entries（4GT 调优对系统页表项数的影响）"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 912376"如何监视 Exchange Server 2003 或 Exchange 2000 Server 中的页面缓冲池内存的使用并解决出现的问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=912376)


内核资源消耗：卷影复制服务更新
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-02-13

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows Management Instrumentation (WMI) 类，以验证 Vssvc.exe 文件是否存在。

Exchange Server 分析工具查询以下注册表项以确定 Windows Server 上是否正在运行卷影复制服务 (VSS) 或虚拟磁盘服务 (VDS)：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VSS

此外，Exchange Server 分析工具还读取以下注册表值，以确定 Exchange 服务器上运行的 Microsoft Windows® 操作系统版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

如果 CurrentVersion 值等于 5.0，则 Exchange 服务器正在 Microsoft Windows 2000 Server 上运行。如果 CurrentVersion 值等于 5.2，则 Exchange 服务器正在 Microsoft Windows Server™ 2003 上运行。

最后，Exchange Server 分析工具查询 Win32_OperatingSystem Windows Management Instrumentation (WMI) 类，以确定 ServicePackMajorVersion 关键字的值。ServicePackMajorVersion 关键字的值表示计算机上安装的是哪个 Windows Service Pack。

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • 将 Exchange 服务器安装在 Windows Server 2003 Service Pack 1 (SP1) 上。

  • Windows Server 2003 SP 1 上正在运行卷影复制服务或虚拟磁盘服务。

  • 此 Exchange 服务器配置上未安装 VSS 更新。

如果应用 VSS 更新，则诸如内核资源消耗这类问题将会得到解决。

修复错误

  • 应用 VSS 更新，可从 Microsoft 知识库文章 891957"Update is available that fixes various Volume Shadow Copy Service issues in Windows Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=891957)下载此更新。

有关将 VSS 与 Exchange Server 2003 一起使用的最佳做法信息，请参阅"Best Practices for Using Volume Shadow Copy Service with Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=56571)。


LeakDiag 已安装
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定计算机中是否安装了 LeakDiag.exe：

HKEY_LOCAL_MACHINE\Software\Microsoft\LeakDiag

如果 Exchange Server 分析工具发现该注册表分支存在，则将显示非默认配置消息。

LeakDiag 是一组工具，开发人员、支持专家和 IT（信息技术）人员可以借助这一组工具来诊断运行在 Microsoft Windows NT® Server 4.0、Windows® 2000 Server、Windows XP 和 Windows Server™ 2003 上的应用程序或服务中的内存泄漏、碎片以及其他与内存有关的问题。

可以使用 LeakDiag 工具将内存泄漏精确地定位到代码行。借助 Microsoft 的 Detours 技术，LeakDiag 可以截取对指定内存分配的调用，并跟踪各种调用堆栈。它对已进行分配但尚未释放的内存进行报告。通过该信息，可以对内存泄漏问题进行故障排除，以准确确定哪些组件进行了分配。凭借正确的调试符号，甚至可以看到请求分配的代码行。

建议您不要在处于生产环境的 Exchange 服务器上运行 LeakDiag。启用 LeakDiag 后，LeakDiag 将在 Exchange 服务器每次启动时跟踪所有进程的所有内存分配。这会耗费大量的处理器资源和内存资源，因此，不建议您如此操作，除非您正在主动地对内存相关问题进行故障排除。如果您不是在主动地对内存相关问题进行故障排除，则应该禁用 LeakDiag。在 Exchange Server 生产环境中运行 LeakDiag 会导致内存碎片和损耗，并最终会导致 Exchange 出现故障。

注意：
始终应该在非高峰时间对 LeakDiag 问题进行故障排除。在重载使用或高峰使用期间使用 LeakDiag，会导致 Exchange Server 计算机的性能严重降低。

有关此消息的信息

  1. 本消息仅以提供信息为目的。只要未启用和运行 LeakDiag，仅仅是安装了 LeakDiag，则不会影响 Exchange Server 性能。LeakDiag 要求大约 4 MB 的硬盘空间（不包括日志）。

  2. 若要释放该硬盘空间，可以删除 LeakDiag.exe，方法是：转到"控制面板"，单击"添加/删除程序"，单击"LeakDiag"，再单击"删除"。

有关 LeakDiag 的最新版本，请访问 Microsoft 公用 FTP 站点 (http://go.microsoft.com/fwlink/?LinkId=41401)。


LeakDiag 已启用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已在计算机上启动 LeakDiag.exe：

HKEY_LOCAL_MACHINE\Software\Microsoft\LeakDiag\EnableAutoStart

如果 Exchange Server 分析工具发现 EnableAutoStart 的值设置为 1，则显示警告。EnableAutoStart 是使用 LeakDiag 用户界面配置的。默认值为 0。值为 1 意味着 LeakDiag 已启用并处于活动状态。

LeakDiag 是一组工具，开发人员、支持专家和 IT（信息技术）人员可以借助这一组工具来诊断运行在 Microsoft Windows NT® Server 4.0、Windows® 2000 Server、Windows XP 和 Windows Server™ 2003 上的应用程序或服务中的内存泄漏、碎片以及其他与内存有关的问题。

使用 LeakDiag 工具可以将内存泄漏的查找范围缩小到某一行代码。LeakDiag 使用 Microsoft 提供的 Detours 技术拦截指定内存分配调用并跟踪各个调用堆栈。它报告已分配但尚未释放的内存。解决内存泄漏问题的人员可以通过此信息准确地找出分配此内存的组件。使用正确的调试符号，甚至可以找到请求分配此内存的代码行。

建议不要在生产环境中的 Exchange 服务器上运行 LeakDiag。启用 LeakDiag 后，LeakDiag 将在 Exchange 服务器每次启动时跟踪所有进程的所有内存分配。这将消耗大量的处理器资源和内存资源，因此，除非您在对内存相关问题进行故障排除，否则不建议启用 LeakDiag。如果您未在对内存相关问题进行故障排除，则应禁用 LeakDiag。在 Exchange Server 生产环境中运行 LeakDiag 可能导致内存碎片和内存消耗，并最终导致 Exchange 运行失败。

注意：
要使用 LeakDiag 来解决问题，应始终选择在非高峰时段进行。在高峰时段使用 LeakDiag 可能导致 Exchange Server 计算机的性能大幅度下降。

在 LeakDiag.exe 中关闭自动启动

  1. 单击"开始"，再单击 LeakDiag。

  2. 在 Tools 菜单上，单击 Options。

  3. 在 Options 页上，清除 Allow AutoStart 复选框，再单击 OK。

有关 LeakDiag 的最新版本，请访问 Microsoft 公用 FTP 站点 (http://go.microsoft.com/fwlink/?LinkId=41401)。


距日志空间用尽还有不到 7 天
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-04-13

Microsoft Exchange Server 分析工具可估计距 Exchange Server 存储组中事务日志驱动器空间用尽的剩余时间。Exchange Server 分析工具通过检查日志驱动器上事务日志文件的时间戳，估计该驱动器达到最大容量的时间。Exchange Server 分析工具发现日志驱动器空间将在不足 7 天后用完时，Exchange Server 分析工具将显示错误。

Exchange Server 数据库日志文件所在的驱动器的磁盘空间即将用尽。

日志驱动器空间不足时，可能发生以下问题：

  • 数据库无法启动，或者将关闭。

  • 数据库将异常关闭，并发生不一致现象。

  • 用户将无法访问邮件和/或公用文件夹。

禁用循环日志记录可能导致日志驱动器空间用尽。因此，在通过使用 Exchange Server 感知备份软件执行完整或增量联机备份之前，事务日志文件将一直留在驱动器上。

在低于 Exchange 2003 的 Exchange Server 版本中，数据库可能无法在停止之前达到"干净关闭"状态。在磁盘空间发生紧急情况时，两个备用事务日志文件 Res1.log 和 Res2.log 将被转换成普通的事务日志。

对 Exchange Server 2003 进行了优化，因此在备用日志文件空间用尽之前，数据库都可以干净关闭。如果数据库未能干净关闭，切勿删除与此数据库关联的几个最新的事务日志。这些事务日志仍包含还原数据库时为保持一致必须应用到此数据库的信息。如果删除这些日志文件，在修复或还原数据库之前，将无法再次启动该数据库。

如果存储组中的所有数据库都处于"干净关闭"状态，则删除所有事务日志也不会阻止数据库的启动。但是，如果删除事务日志，以前的备份将失效。删除并不意味着无法还原以前的备份，而是无法将被还原的数据库前滚到删除这些日志文件的时间点。

Exchange Server 分析工具中的日志空间向导会分析现有的事务日志文件，然后帮助您移动数据库不再需要的文件。日志空间向导还可确保即使所有数据库都处于"干净关闭"状态，也不会删除当前的日志文件。如果不删除当前的日志文件，以前的备份仍然有效。

若要重新获得日志驱动器空间，应该删除不必要的日志文件。建议执行以下操作。

在日志驱动器空间已满或即将用尽时重新获得日志驱动器空间

  • 对此数据库执行 Exchange 所支持的联机流式备份或卷影复制服务 (VSS) 备份。有关 VSS 备份的详细信息，请参阅"Best Practices for Using Volume Shadow Copy Service with Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=56571)。

    注意：
    清除不必要日志文件的首选方法是执行联机流式备份或 VSS 备份。

  • 如果数据库由于日志驱动器空间即将用尽而关闭，则可以使用 Exchange Server 分析工具日志空间管理向导。可以使用此向导移动多余日志文件。另外，也可在重新装入数据库之前手动移动多余日志文件。

    要手动移动日志文件，请按照 Microsoft 知识库文章 240145"How to remove Exchange Server transaction log files"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240145)中的步骤和建议进行操作。


该 Exchange 服务器的 LegacyExchangeDN 与父管理组不匹配
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-09

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，通过检查 Active Directory 中 Servers 容器内的服务器对象的属性是否与驻留该服务器的组织和管理组的实际名称相同，来验证该服务器的 legacyExchangeDN 值。如果服务器的 legacyExchangeDN 值与组织或管理组的名称不同，则会显示错误。

在 Active Directory 中，Exchange 使用 legacyExchangeDN 值来标识 Exchange 对象。legacyExchangeDN 值是一个可分辨名称，它指出该对象在 Exchange 组织中的位置，例如：

/o= organization /ou= administrative group /ou= server

对于诸如邮箱存储和公用文件夹存储这样的对象，其 legacyExchangeDN 值的一部分是从服务器继承而来的。这意味着，如果服务器值有问题，则其他对象可能继承了相同的问题。

通常，如果管理员尝试直接修改该值，则 legacyExchangeDN 会发生问题。必须使用 Active Directory 服务接口 (ADSI) Edit、LDP (ldp.exe) 工具或其他任何轻型目录访问协议 (LDAP) 版本 3 客户端等工具来更正该值。

警告：
在使用 ADSI Edit、LDP 工具或其他 LDAP 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。若要解决这些问题，您可能需要重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003/Exchange Server 2007。修改 Active Directory 对象的属性的风险由您自己承担。

更正此错误

  1. 使用 ADSI Edit 或类似的工具在 Active Directory 中找到管理组对象。

    可以在以下位置找到 legacyExchangeDN 属性：

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Servers,CN=server

  2. 键入以下形式的新字符串值：

    /o= organization /ou= administrative group /ou= server

有关使用 LDP 工具的详细信息，请参阅 Microsoft 知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

有关使用 ADSI Edit 的详细信息，请参阅 Windows Server 2003 帮助中的主题"Adsiedit.msc:ADSI Edit"主题。


此 Exchange 服务器的 LegacyExchangeDN 无效
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-09

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以验证 Exchange 服务器的 legacyExchangeDN 值。如果在 legacyExchangeDN 值中指定的组织或管理组名称与组织或管理组的实际名称不匹配，或者，如果该值的某一部分完全不存在，则会显示此错误。

Exchange 使用 legacyExchangeDN 值在 Active Directory 中标识 Exchange 对象。legacyExchangeDN 值是一个可分辨名称，它指出该对象位于 Exchange 组织中的哪个位置，例如：

/o= organization /ou= administrative group

诸如服务器和文件夹层次结构的对象从管理组那里继承其 legacyExchangeDN 值的一部分。这意味着，如果管理组的值存在问题，那么可能有其他许多对象都继承同样的问题。

通常，legacyExchangeDN 的问题是由于管理员试图直接修改该值而导致的。必须使用 Active Directory 服务接口 (ADSI) Edit、LDP (ldp.exe) 工具或其他任何轻型目录访问协议 (LDAP) 版本 3 客户端等工具来更正该值。

警告：
在使用 ADSI Edit、LDP 工具或其他 LDAP 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。要解决这些问题，您可能需要重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003/Exchange Server 2007。修改 Active Directory 对象的属性的风险由您自己承担。

更正此错误

  1. 使用 ADSI Edit 或类似的工具在 Active Directory 中找到管理组对象。

    可以在以下位置找到 legacyExchangeDN 属性：

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group

  2. 键入以下形式的新字符串值：

    /o= organization /ou= administrative group

有关使用 LDP 工具的详细信息，请参阅 Microsoft 知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

有关使用 ADSI Edit 的详细信息，请参阅 Windows Server 2003 帮助中的主题"Adsiedit.msc:ADSI Edit"主题。


许可证记录服务设置为"自动"
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定许可证记录服务 (LicenseService) 的 Started 关键字的值。值为 False 意味着许可证记录服务未运行在此 Exchange 服务器上。值为 True 意味着许可证记录服务正在运行。

Exchange Server 分析工具还查询 root\MicrosoftExchangeV2 命名空间中的 Exchange_Server WMI 类，以确定 IsFrontEndServer 关键字的值。值为 False 意味着 Exchange Server 计算机不是前端服务器。值为 True 意味着 Exchange Server 计算机是前端服务器。

Exchange Server 分析工具还查询 Win32_OperatingSystem WMI 类，以确定 OSProductSuite 关键字的值。该关键字的返回值表示正在 Exchange Server 计算机上运行的 Windows 操作系统的版本。

另外，Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定每个邮箱存储的 homeMDBBL 属性中列出的条目数。该属性的个数代表邮箱存储中的邮箱数。

如果 Exchange Server 分析工具确定在满足下列所有条件的 Exchange Server 计算机上启动了许可证记录服务，则显示警告：

  • Exchange Server 计算机不是前端服务器。

  • Exchange Server 计算机驻留了超过 20 个邮箱。

  • Exchange Server 计算机未运行 Microsoft Windows Small Business Server 2003 或 Small Business Server 2000。

许可证记录服务是一个工具，最初设计它是为了帮助客户管理在服务器客户端访问许可证 (CAL) 模型中许可的 Microsoft 服务器产品的许可证。

默认情况下，许可证记录服务在 Microsoft Windows Server™ 2003 中被禁用。由于最初的设计限制以及许可证条款和条件的不断发展，通过许可证记录服务无法准确地查看与在单个服务器上或整个企业中使用的 CAL 的总数相比的所购买的 CAL 的总数。许可证记录服务所报告的 CAL 可能与最终用户许可协议 (EULA) 的解释及产品使用权利 (PUR) 冲突。许可证记录服务将不会包括在将来的 Windows 操作系统版本中。

关于许可证记录服务在 Exchange Server 计算机上的使用，Microsoft 提出了特定的要求和建议：

  • 在使用安全套接字层 (SSL) 的前端 Exchange 服务器上，必须启用并启动许可证记录服务。如果许可证记录服务未运行，Internet 信息服务 (IIS) 将限制已通过身份验证的并发 SSL 连接的数目不得超过 10。

  • 在后端 Exchange 服务器上，建议停止许可证记录服务并将它设置为"已禁用"。

  • 在群集 Exchange 服务器上，建议停止许可证记录服务并将它设置为"已禁用"。

  • 在运行 Microsoft Windows Small Business Server 2003 或 Small Business Server 2000 的 Exchange 服务器上，只有当需要 10 个以上的已通过身份验证的 SSL 连接时，许可证记录服务才是必需的。

设置许可证记录服务的状态

  1. 从"管理工具"菜单中启动"服务"管理单元。

  2. 找到并双击"License Logging Service"。

  3. 在"启动类型"下拉列表中，选择相应的选项：

    • 对于使用 SSL 的前端 Exchange 服务器，将服务设置为"自动"。

    • 对于后端 Exchange 服务器以及群集 Exchange 服务器，将服务设置为"已禁用"。

  4. 如果要禁用 License Logging 服务，还应单击"停止"以停止该服务。

  5. 单击"确定"保存更改，然后关闭"服务"管理单元。

有关许可证记录服务的详细信息，请参阅下列 Microsoft 知识库文章：

  • 824196"Description of the License Logging Service in Windows Server Operating Systems"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=824196)

  • 316631"如何关闭许可证记录服务"(http://support.microsoft.com/kb/316631/zh-cn)


日志文件名与日志生成编号不匹配
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-07

Microsoft® Exchange Server 分析工具将来自事务日志文件头的 lGeneration 内部生成编号的值与事务日志文件的文件名进行比较，以确定它们是否匹配。

如果来自事务日志文件头的内部生成编号与事务日志文件名中内部生成编号的表示形式不匹配，则 Exchange Server 分析工具将显示一条错误。

除非日志文件是当前日志，否则最新的可用日志文件必须具有与其生成编号匹配的文件名。如果日志文件是当前日志，则其文件名不应包含其生成编号，而仅应包含存储组的日志前缀。例如，某一系列中以前的事务日志可能命名为 E0154321.LOG、E0154322.LOG、E0154323.LOG 等，而当前日志则命名为 E01.LOG。

可以使用 Eseutil /ML LOGFILE 命令来显示日志文件的内部 lGeneration 值。

有关 Exchange Server 事务日志记录的详细信息，请参阅"Using Recovery Storage Groups in Exchange Server 2003"（使用 Exchange Server 2003 中的恢复存储组）中的"Exchange Transaction Logging in Exchange Server 2003"（Exchange Server 2003 中的 Exchange 事务日志记录）(http://go.microsoft.com/fwlink/?LinkId=47589)。


日志序列签名不匹配
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-07

Microsoft® Exchange Server 分析工具会将日志文件的 Signature 值与后续日志文件的 Signature 值进行比较，以确定其是否匹配。

如果日志文件的 Signature 值与后续日志文件的 Signature 值不匹配，则 Exchange Server 分析工具将显示一个错误。

Exchange 使用一系列的日志文件（每个文件都恰好为 5 MB），而不是将所有日志信息写入一个大文件。某个日志文件已满时，Exchange 会关闭该日志文件，并会使用一个序列号来重命名该文件。

为 Exchange 存储组初始化一个新的事务日志文件序列时，会将一个 Signature 写入第一个日志文件，并将其复制到每个后续日志文件中。Signature 可将特定的日志文件唯一地标识为特定日志序列的成员。

不存在可从相同文件夹中找到具有不同签名的日志文件的情况。如果发生了此种情况，则表明已将外部日志文件复制到该存储组中，或在未先删除所有以前日志文件的情况下重置了日志文件。

可以使用 Eseutil /ML LOGFILE 命令来显示日志文件的 Signature 值。

有关 Exchange Server 事务日志记录的详细信息，请参阅"Using Recovery Storage Groups in Exchange Server 2003"（使用 Exchange Server 2003 中的恢复存储组）中的"Exchange Transaction Logging in Exchange Server 2003"（Exchange Server 2003 中的 Exchange 事务日志记录）(http://go.microsoft.com/fwlink/?LinkId=47589)。


日志签名问题
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-07

Microsoft® Exchange Server 分析工具将服务器上当前 Exchange 事务日志文件头中的签名与存储组数据库文件中的日志签名进行比较。

如果事务日志文件的签名与任何数据库文件中的日志签名都不匹配，则 Exchange Server 分析工具将显示一个错误。

此错误表明存在以下情况之一：

  • 当前事务日志文件不存在。

  • 当前事务日志文件与存储组中的数据库之一不匹配。

发生此情况的可能原因如下：

  • 已手动删除了存储组的事务日志。

  • 已将来自其他存储组的数据库还原或复制到此存储组中。

  • 已将来自不同序列或存储组的事务日志文件复制到此存储组中。

此情况是否会阻止数据库执行装入取决于数据库文件是处于"干净关闭"状态还是处于"异常关闭"状态。

注意：
数据库可能在处于"干净关闭"状态时，由于存储组中的其他数据库不可装入而仍然无法进行装入。使用 Exchange Server 灾难恢复分析工具可进行诊断，并提出有关如何在这些情况下装入数据库的建议。

Exchange 数据库正常关闭时，所有尚未处理的数据都将写入数据库文件。正常关闭之后，数据库文件集（.edb 和 .stm 扩展名）将处于一致状态。然后，Exchange 会将数据库文件集从其日志流中分离出来。这意味着数据库文件现在是自包含的，即这些文件是最新的。不需要使用以前的事务日志来启动数据库文件。

处于"干净关闭"状态的数据库已从其日志文件中分离出来并可能附加到其他日志流上。因此，日志文件和数据库之间的不匹配不一定说明出现了问题。

处于"异常关闭"状态的数据库已错误地从其日志文件中分离出来。必须使用其附加的日志文件恢复这些数据库。如果无法找到附加的日志文件，则无法装入数据库。必须先从备份还原数据库或修复数据库，然后才可装入该数据库。

如果您输入 Eseutil /mh 命令并检查文件头，则可辨别是否已干净关闭了数据库。在 Microsoft Exchange 2000 Service Pack 1 和更高版本中，文件头中的行会显示"状态:干净关闭"或"状态:异常关闭"。在 Exchange 的早期版本中，会将与以上相同的状态报告为"状态:一致"或"状态:不一致"。

有关 Exchange Server 事务日志记录的详细信息，请参阅"Using Recovery Storage Groups in Exchange Server 2003"（使用 Exchange Server 2003 中的恢复存储组）中的"Exchange Transaction Logging in Exchange Server 2003"（Exchange Server 2003 中的 Exchange 事务日志记录）(http://go.microsoft.com/fwlink/?LinkId=47589)。


Log record bytes/sec 超出错误阈值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-23

Microsoft® Exchange Server 分析工具使用 Exchange Server 用户监视器 (ExMon) 工具来确定用户 MAPI 操作的完成时间是否为正常 Exchange 服务器上的合理预期时间。

作为其分析的一部分，Exchange Server 分析工具检查事务日志使用情况以确定用户 MAPI 操作是否导致每分钟将超过 5MB 的数据写入到 Exchange 事务日志中。

如果 MAPI 操作导致事务日志文件变得过大，则可能会导致服务器资源瓶颈和错误，如超过了检查点深度、磁盘 I/O 瓶颈以及磁盘空间不足。

如果 Exchange Server 分析工具确定一个或多个用户 MAPI 操作导致每分钟将超过 5MB 的数据写入到 Exchange 事务日志中，Exchange Server 分析工具将显示错误。

每分钟将超过 5MB 的数据写入到 Exchange 事务日志中的 MAPI 操作并非始终会出现问题。某些操作应以较高的速率写入数据，如邮箱移动或对许多邮件执行的其他批量操作（将生成大量事务日志数据）。在这种情况下，较高速率的持续时间不会超过几分钟。

如果服务器出现其他问题（如较长 RPC 延迟时间），请与生成事务日志数据的用户一起确定导致较高日志记录写入速率的用户活动。

详细信息

有关详细信息，请参阅下列 Exchange Server 资源：

  • Performance and Scalability Guide for Exchange Server 2003（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)

  • Troubleshooting Microsoft Exchange Server 2003 Performance（解决 Microsoft Exchange Server 2003 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)

  • Exchange Server 2003 Performance:10 Things to Think About（Exchange Server 2003 性能：要考虑的 10 件事情）(http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft 知识库文章 905803"Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server"（Outlook 用户在运行 Exchange Server 2003 或 Exchange 2000 Server 的服务器上使用包含许多项目的文件夹时出现性能下降问题）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


LogicalDisk 性能监视器对象不可用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包括性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎从 LogicalDisk 性能对象的 Avg. Disk sec/Read 性能计数器收集数据以分析性能数据。如果计数器未返回有效数据，则 Exchange Server 分析工具将显示基准消息。

如果性能数据收集引擎未返回有效数据，则可能出现下列情况的任意组合：

  • LogicalDisk 性能对象已禁用。默认情况下，在 Microsoft Windows Server™ 2003 中启用 LogicalDisk 性能对象。但是，在 Microsoft Windows® 2000 Server 中，默认情况下不启用 LogicalDisk。

  • LogicalDisk 性能监视器对象丢失或损坏。

  • Exchange Server 分析工具没有访问性能对象的相应权限。

如果某些可扩展计数器破坏了注册表，或基于 Microsoft Windows Management Instrumentation (WMI) 的程序修改了注册表，可能会发生前两种情况。

以下过程说明如何处理前两种情况。在执行此过程之前，请验证 Exchange Server 分析工具是否具有相应的权限。有关运行 Exchange Server 分析工具所需的权限的详细信息，请参阅随 Exchange Server 分析工具提供的帮助文档。要获得帮助，请打开 Exchange Server 分析工具，然后按 F1 键。

更正此错误

  1. 验证 LogicalDisk 性能对象是否已启用：

    1. 下载并安装可扩展性能计数器列表工具 (Exctrlst.exe)。可以从以下位置下载 Exctrlst.exe："Exctrlst.exe:Extensible Performance Counter List"（英文）(http://go.microsoft.com/fwlink/?LinkId=34436)。

    2. 打开 Exctrlst.exe，再单击"Sort Order"，然后单击"Service"。

    3. 找到性能对象所报告的服务，并确认选中了"Performance Counters Enabled"复选框。

      如果未选中"Performance Counters Enabled"复选框，请选中该复选框，然后重新启动与性能计数器关联的服务，确认性能计数器工作正常。如果性能计数器无法正常工作，或"Performance Counters Enabled"复选框已选中，请继续执行第 2 步。

  2. 重建丢失或损坏的性能计数器，请参阅 Microsoft 知识库文章 300956"如何手动重新生成性能计数器库值"(http://support.microsoft.com/?kbid=300956)。

  3. 如果按照此知识库文章操作不能解决问题，将必须在"修复"模式下重新安装 Windows 操作系统，然后应用最新的 Windows Service Pack。


发现延迟时间较长的 MAPI 操作
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-11-22

Microsoft® Exchange Server 分析工具使用 Exchange Server 用户监视器 (ExMon) 工具收集数据（5 分钟的样本）以确定用户 MAPI 操作的完成时间是否比正常 Exchange 服务器上的合理预期时间长。

如果 Exchange Server 分析工具确定用户执行的一个或多个 MAPI 操作的完成时间超过 30 秒（在收集数据的时间范围内），Exchange Server 分析工具将显示错误，并对触发错误的用户的操作执行其他分析。

完成时间超过 30 秒的 MAPI 操作并非始终会出现问题。如果要保存大量邮件数据或文件附件，则可能会导致 MAPI 操作的完成时间比正常情况长。

如果一个或多个用户经常出现延迟，或者延迟对其邮件传递体验造成负面影响，则应该对这些 MAPI 操作延迟进行进一步的调查，以确保它们没有更严重延迟问题的症状，如资源瓶颈或嵌套依赖关系。

要更正此错误，请执行下列操作：

  • 考虑使用 ExMon 工具来捕获更大的数据样本以供 Exchange Server 分析工具进行检查。由于 ExMon 生成的数据量较大，因此，我们建议将数据收集样本控制在 30 分钟或更短。

  • 查看所有相关的延迟错误以及附带提供的文章（描述用于解决这些问题的特定操作和步骤）。如果 Exchange Server 分析工具没有报告相关的延迟错误，对用户操作执行的其他分析不会发现任何问题。


长时间运行的 MAPI 批量操作
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-23

Microsoft® Exchange Server 分析工具使用 Exchange Server 用户监视器 (ExMon) 工具来确定用户 MAPI 操作的完成时间是否比正常 Exchange 服务器上的合理预期时间长。

作为其分析的一部分，Exchange Server 分析工具检查 ExMon 数据来确定用户发出的完成时间超过 30 秒的 MAPI 批量操作。

MAPI 批量操作是为多个对象执行的操作，这些操作的开销通常很高（需要许多 I/O）。

如果 Exchange Server 分析工具确定用户发出的 MAPI 批量操作的完成时间超过 30 秒，Exchange Server 分析工具将显示错误。

完成时间超过 30 秒的 MAPI 批量操作并非始终会出现问题。如果用户同时对一千个或更多邮件执行操作（复制、删除、设置属性标志等），则可能会导致 MAPI 批量操作的完成时间比正常情况长。

如果一个或多个用户经常出现延迟，或者延迟对其邮件传递体验造成负面影响，则应该对这些 MAPI 批量操作延迟进行进一步的调查，以确保它们没有更严重延迟问题的症状，如资源瓶颈或嵌套依赖关系。

若要更正此错误，请执行下列操作：

  • 考虑使用 ExMon 工具来捕获更大的数据样本以供 Exchange Server 分析工具进行检查。由于 Exchange 生成的数据量较大，因此，我们建议将数据收集样本控制在 30 分钟或更短。

详细信息

有关详细信息，请参阅下列 Exchange Server 资源：

  • Performance and Scalability Guide for Exchange Server 2003（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)

  • Troubleshooting Microsoft Exchange Server 2003 Performance（解决 Microsoft Exchange Server 2003 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)

  • "Exchange Server 2003 Performance: 10 Things to Think About"（Exchange Server 2003 性能：要考虑的 10 件事情）(http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft 知识库文章 905803"Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server"（Outlook 用户在运行 Exchange Server 2003 或 Exchange 2000 Server 的服务器上使用包含许多项目的文件夹时出现性能下降问题）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


长时间运行的 MAPI 'FindRow' 操作
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-11-22

Microsoft® Exchange Server 分析工具使用 Exchange Server 用户监视器 (ExMon) 工具来确定用户 MAPI 操作的完成时间是否比正常 Exchange 服务器上的合理预期时间长。

作为其分析的一部分，Exchange Server 分析工具检查 ExMon 数据来确定用户发出的完成时间超过 30 秒的 MAPI FindRow 操作。

如果增加每个文件夹的视图数，则可能会增加许多 MAPI 操作的开销。客户端应用程序使用 MAPI 操作 SeekRow 或 FindRow 在视图中的各行之间移动指针。SeekRow 指定指针移动的行数，此操作与 CPU 时间有关的开销很低。FindRow 开销较高，因为该操作将指针移至未实体化（无法缓存）视图中符合限制条件的第一项，并在客户端应用程序完成操作后丢弃该视图。FindRow 的最终 CPU 开销取决于限制的复杂性以及存储在找到符合条件的第一项之前必须检查的行数，而与文件夹中的项目数关系不大。

FindRow 可能会产生较高的开销，因而非常适于在缓存模式下运行，这样可以减少服务器的开销。请注意，有时，此操作占用较高百分比的 CPU 时间，而这可能只是由共享日历造成的；在这种情况下，缓存模式不起作用。如果 FindRow 操作占用较高百分比的 CPU 时间，则可能表明执行了大量视图创建操作、视图的开销较高或文件夹项目计数较大。

如果 Exchange Server 分析工具确定用户发出的 MAPI FindRow 操作的完成时间超过 30 秒，Exchange Server 分析工具将显示错误。

完成时间超过 30 秒的 MAPI FindRow 操作并非始终会出现问题。如果指定的一个或多个用户经常出现延迟，或者延迟对其邮件传递体验造成负面影响，则应该了解出现延迟的原因。请与经常出现延迟的用户一起来确定以下情况：

  • 文件夹中的项目计数是否很高。

  • 用户正在运行哪些应用程序。

若要解决该问题，请执行下列操作：

  • 鼓励文件夹中包含许多项目的用户减少每个文件夹中的项目数。我们建议您在"收件箱"、"日历"、"已发送邮件"、"联系人"和"已删除邮件"文件夹中保存的项目不应超过 5,000 个。

  • 将运行开销最高的客户端计算机（尤其是 Restrict、SetColumns 或 FindRow 操作延迟时间较长的客户端计算机）配置为使用缓存 Exchange 模式。缓存 Exchange 模式将服务器与大多数过量 RPC 通信隔离开。

  • 尝试关闭所有应用程序，然后逐个打开它们以查找可能导致此问题的应用程序。如果工作中不需要使用这些应用程序，或应用程序已发布了修补程序，应永久性关闭这些应用程序，或者对其进行更新以将负载减少到相应的级别。

注意：
有些应用程序即使没有发出许多 MAPI 操作，也可能会显著增加服务器负载。这是因为某些操作的开销比其他操作高。开销较高的操作数量只要稍稍增加，就可能会显著影响服务器的性能。在 ExMon 中，将报告这些用户对 CPU 产生较大的影响，但他们未必发出了许多 MAPI 操作。

还要注意，只要存在资源瓶颈（通常是磁盘或 CPU 瓶颈），FindRow 操作的延迟时间就会增加。

详细信息

有关详细信息，请参阅下列 Exchange Server 资源：

  • Performance and Scalability Guide for Exchange Server 2003（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)

  • Troubleshooting Microsoft Exchange Server Performance（解决 Microsoft Exchange Server 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)

  • Exchange Server 2003 Performance:10 Things to Think About（Exchange Server 2003 性能：要考虑的 10 件事情）(http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft 知识库文章 905803"Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server"（Outlook 用户在运行 Exchange Server 2003 或 Exchange 2000 Server 的服务器上使用包含许多项目的文件夹时出现性能下降问题）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


长时间运行的 MAPI 联机操作
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-23

Microsoft® Exchange Server 分析工具使用 Exchange Server 用户监视器 (ExMon) 工具来确定用户 MAPI 联机操作的完成时间是否比正常 Exchange 服务器上的合理预期时间长。

MAPI 联机操作的一个示例是 QueryRows 操作。

QueryRows 操作用于在当前视图中返回行。QueryRows 使用表中的数据来满足用户的请求。SetColumns 操作确定可用于 QueryRows 的数据。QueryRows 开销随请求的属性大小、请求的属性数量以及请求的数据行数而增加。如果请求许多列和行，QueryRows 开销也可能会很高。

随着核心 Exchange Server 2003 文件夹中项目数的增加，Outlook 用户执行某些操作的物理磁盘开销也会随之增加。第一次按大小对收件箱进行排序的开销很高（需要许多磁盘 I/O）。以后，按大小对收件箱进行排序的开销较低。

如果 Exchange Server 分析工具确定用户发出的 MAPI 联机操作的完成时间超过 30 秒（在收集数据的时间范围内），Exchange Server 分析工具将显示错误。

如果 MAPI 联机操作的延迟时间较长，则可能表明出现了服务器资源瓶颈。对于 QueryRows 操作，这也可能表明文件夹中的项目计数较大，或者在内部表中设置了许多属性。

如果同时对许多数据执行联机操作时出现较长时间的延迟，这并不表明出现了服务器性能问题。一个示例是，用户选择文件夹中的所有项目，并将它们标记为在单个操作中读取。请与经常出现延迟的用户一起来确定以下情况：

  • 文件夹中的项目计数是否很高。

  • 用户正在运行哪些应用程序。

若要解决该问题，请执行下列操作：

  • 鼓励文件夹中包含许多项目的用户减少每个文件夹中的项目数。我们建议您在"收件箱"、"日历"、"已发送邮件"、"联系人"和"已删除邮件"文件夹中保存的项目不应超过 5,000 个。

  • 尝试关闭所有应用程序，然后逐个打开它们以查找可能导致此问题的应用程序。如果工作中不需要使用这些应用程序，或应用程序已发布了修补程序，应永久性关闭这些应用程序，或者对其进行更新以将负载减少到相应的级别。

注意：
有些应用程序即使没有发出许多 MAPI 联机操作，也可能会显著增加服务器负载。这是因为某些操作的开销比其他操作高。开销较高的操作数量只要稍稍增加，就可能会显著影响服务器的性能。在 ExMon 中，将报告这些用户对 CPU 产生相对较大的影响，但他们未必发出了许多 MAPI 操作。

还要注意，只要存在资源瓶颈（通常是磁盘或 CPU 瓶颈），MAPI 联机操作的延迟时间就会增加。应找出服务器资源瓶颈，并提高服务器资源容量或者将用户移到负载较少的服务器上。

详细信息

有关详细信息，请参阅下列 Exchange Server 资源：

  • Performance and Scalability Guide for Exchange Server 2003（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)

  • Troubleshooting Microsoft Exchange Server 2003 Performance（解决 Microsoft Exchange Server 2003 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)

  • Exchange Server 2003 Performance:10 Things to Think About（Exchange Server 2003 性能：要考虑的 10 件事情）(http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft 知识库文章 905803"Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server"（Outlook 用户在运行 Exchange Server 2003 或 Exchange 2000 Server 的服务器上使用包含许多项目的文件夹时出现性能下降问题）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


长时间运行的 MAPI 操作
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-11-22

Microsoft® Exchange Server 分析工具使用 Exchange Server 用户监视器 (ExMon) 工具来确定用户 MAPI 操作的完成时间是否比正常 Exchange 服务器上的合理预期时间长。

如果 Exchange Server 分析工具确定用户执行的一个或多个 MAPI 操作的完成时间超过 30 秒，Exchange Server 分析工具将显示错误。

如果增加每个文件夹的视图数，则可能会增加许多 MAPI 操作的开销。本主题中讨论了两个最常见的操作：SeekRow 和 FindRow。通常，可以使用与 SeekRow 和 FindRow MAPI 操作相同的方法来解决 Exchange Server 分析工具标识为"长时间运行"的其他 MAPI 操作。

客户端应用程序使用 MAPI 操作 SeekRow 或 FindRow 在视图中的各行之间移动指针。SeekRow 指定指针移动的行数，此操作与 CPU 时间有关的开销很低。FindRow 开销较高，因为该操作将指针移至未实体化（无法缓存）视图中符合限制条件的第一项，并在客户端应用程序完成操作后丢弃该视图。FindRow 的最终 CPU 开销取决于限制的复杂性、为每个邮件访问的邮件属性数以及存储在找到符合条件的第一项之前必须检查的行数，而与文件夹中的项目数关系不大。

完成时间超过 30 秒的 MAPI 操作并非始终会出现问题。如果指定的一个或多个用户经常出现延迟，或者延迟对其邮件传递体验造成负面影响，则应该了解出现延迟的原因。请与经常出现延迟的用户一起来确定以下情况：

  • 文件夹中的项目计数是否很高。

  • 用户正在运行哪些应用程序。

若要解决该问题，请执行下列操作：

  • 鼓励文件夹中包含许多项目的用户减少每个文件夹中的项目数。我们建议您在"收件箱"、"日历"、"已发送邮件"、"联系人"和"已删除邮件"文件夹中保存的项目不应超过 5,000 个

  • 将运行开销最高的客户端计算机（尤其是 Restrict、SetColumns 或 FindRow 操作延迟时间较长的客户端计算机）配置为使用缓存 Exchange 模式。缓存 Exchange 模式将服务器与大多数过量 RPC 通信隔离开。

  • 尝试关闭所有应用程序，然后逐个打开它们以查找可能导致此问题的应用程序。如果工作中不需要使用这些应用程序，或应用程序已发布了修补程序，应永久性关闭这些应用程序，或者对其进行更新以将负载减少到相应的级别。

注意：
有些应用程序即使没有发出许多 MAPI 操作，也可能会显著增加服务器负载。这是因为某些操作的开销比其他操作高。开销较高的操作数量只要稍稍增加，就可能会显著影响服务器的性能。在 ExMon 中，将报告这些用户对 CPU 产生较大的影响，但他们未必发出了许多 MAPI 操作。

还要注意，只要存在资源瓶颈（通常是磁盘或 CPU 瓶颈），MAPI 操作的延迟时间就会增加。应确定服务器资源瓶颈，并提高服务器资源容量或者将用户移到负载较少的服务器上。

详细信息

有关详细信息，请参阅下列 Exchange Server 资源：

  • Performance and Scalability Guide for Exchange Server 2003（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)

  • Troubleshooting Microsoft Exchange Server Performance（解决 Microsoft Exchange Server 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)

  • Exchange Server 2003 Performance:10 Things to Think About（Exchange Server 2003 性能：要考虑的 10 件事情）(http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft 知识库文章 905803"Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server"（Outlook 用户在运行 Exchange Server 2003 或 Exchange 2000 Server 的服务器上使用包含许多项目的文件夹时出现性能下降问题）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


长时间运行的 MAPI 'SaveChangesMessage' 操作
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-11-22

Microsoft® Exchange Server 分析工具使用 Exchange Server 用户监视器 (ExMon) 工具来确定用户 MAPI 操作的完成时间是否比正常 Exchange 服务器上的合理预期时间长。

作为其分析的一部分，Exchange Server 分析工具检查 ExMon 数据来确定用户发出的完成时间超过 30 秒的 MAPI SaveChangesMessage 操作。

应用程序将邮件内容或属性保存到服务器时，将调用 MAPI SaveChangesMessage 操作。完成此操作所需的时间取决于写入的数据、要写入到的数据库和事务日志磁盘的速度以及是否存在资源瓶颈。

如果 Exchange Server 分析工具确定用户发出的 MAPI SaveChangesMessage 操作的完成时间超过 30 秒，Exchange Server 分析工具将显示错误。

完成时间超过 30 秒的 MAPI SaveChangesMessage 操作并非始终会出现问题。如果要保存大量邮件数据或文件附件，则可能会导致 MAPI SaveChangesMessage 操作的完成时间比正常情况长。如果一个或多个用户经常出现延迟，或者延迟对其邮件传递体验造成负面影响，最可能的原因是出现了磁盘瓶颈。

详细信息

  • 有关磁盘瓶颈的详细信息，请参阅检测到磁盘瓶颈。

  • 有关 Exchange Server 性能的详细信息，请参阅 Performance and Scalability Guide for Exchange Server 2003（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关如何解决 Exchange Server 性能问题的详细信息，请参阅 Troubleshooting Microsoft Exchange Server 2003 Performance（解决 Microsoft Exchange Server 2003 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关设计存储体系结构的最佳实践的详细信息，请参阅 Best Practices Common to Multiple Architectures（多种体系结构的通用最佳实践）(http://go.microsoft.com/fwlink/?LinkId=72988)。

  • 有关如何移动用户邮箱以降低服务器负载的详细信息，请参阅将用户邮箱移至其他服务器。

  • 有关磁盘大小调整、延迟时间和 I/O 速率的详细信息，请参阅 Microsoft Exchange 工作组博客网站上的下列博客：

    • "A few basic concepts in disk sizing"（有关磁盘大小调整的一些基本概念）(http://go.microsoft.com/fwlink/?linkid=39538)

    • "Some more thoughts on disk IO and calculations..."（有关磁盘 IO 和计算的一些其他思路...）(http://go.microsoft.com/fwlink/?linkid=39539)

    • How to Calculate Your Disk I/O Requirements（如何计算磁盘 I/O 要求）(http://go.microsoft.com/fwlink/?linkid=69747)


长时间运行的 MAPI 'SetColumns' 操作
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-23

Microsoft® Exchange Server 分析工具使用 Exchange Server 用户监视器 (ExMon) 工具来确定用户 MAPI 操作的完成时间是否比运行 Exchange Server 的正常服务器上的合理预期时间长。

作为其分析的一部分，Exchange Server 分析工具检查 ExMon 数据来确定用户发出的完成时间超过 30 秒的 MAPI SetColumns 操作。

将使用 MAPI 调用 SetColumns 创建一个基本视图。SetColumns 调用定义了一些属性，它们将作为新视图表中的列。

第一次在视图中请求某个属性时，服务器必须执行额外的操作才能生成视图。在视图中请求该属性后，它将始终显示在以后的视图中。这意味着，第一次请求新属性时，SetColumns 调用需要的时间可能更长。所需的时间与新属性的数量以及文件夹中的项目数成比例。例如，在移动邮箱后，用户第一次查看其收件箱时，服务器需要更长的时间才能生成视图。这是因为，视图没有随邮箱一起移动。将会重新创建这些视图。

通常，将属性添加到视图中的开销较大。添加属性的开销与文件夹中的项目数以及要添加的属性数成比例。一般情况下，使用 Microsoft Office® Outlook® 不会导致在邮件文件夹表中添加许多属性，但可以手动添加更多属性。这通常并不会出现问题。但是，如果应用程序定期添加列、一次添加许多列，或者任何客户端在许多项目上添加了一些列，则可能会出现延迟。邮件文件夹表中的列越多，对该文件夹中的项目执行的所有其他操作的开销就会越大。添加列后，就无法将其删除。邮件文件夹表中的每个属性都会增加在该文件夹中插入项目的开销。

如果 Exchange Server 分析工具确定用户发出的 MAPI SetColumns 操作的完成时间超过 30 秒，Exchange Server 分析工具将显示错误。

将用户邮箱移到新的数据库或新的服务器后，用户第一次访问其邮箱时，服务器必须创建新的视图。在这种情况下，SetColumns 和 Restrict 调用所需的时间较长。在移动邮箱后的几天内，您可以安全地忽略这些错误。

某些应用程序将创建新的视图，并导致将属性提升为内部存储数据结构。如果服务器访问该用户的数据，这可能会对服务器性能产生长期影响。如果指定的一个或多个用户经常出现延迟，或者延迟对其邮件传递体验造成负面影响，则应该了解出现延迟的原因。请与经常出现延迟的用户一起来确定以下情况：

  • 文件夹中的项目计数是否很高。

  • 用户正在运行哪些应用程序。

若要解决该问题，请执行下列步骤：

  • 鼓励文件夹中包含许多项目的用户减少每个文件夹中的项目数。建议在"收件箱"、"日历"、"已发送邮件"、"联系人"和"已删除邮件"文件夹中保存的项目不应超过 5,000 个。

  • 将运行开销最高的客户端计算机配置为使用缓存 Exchange 模式。应额外注意在执行 Restrict、SetColumns 或 FindRow 操作时出现较长时间延迟的客户端计算机。缓存 Exchange 模式将服务器与大多数过量 RPC 通信隔离开。

  • 尝试关闭所有应用程序。然后逐个打开它们，以查找可能导致此问题的应用程序。如果以下任一条件成立，应永久性关闭任何有问题的应用程序，或者对其进行更新以将负载减少到相应的级别：

    • 工作中不需要使用该应用程序。

    • 该应用程序已发布了更新。

注意：
有些应用程序即使没有发出许多 MAPI 操作，也可能会显著增加服务器负载。这是因为某些操作的开销比其他操作高。开销较高的操作数量只要稍稍增加，就可能会显著影响服务器的性能。在 ExMon 中，将报告这些用户对 CPU 产生较大的影响，但他们未必发出了许多 MAPI 操作。

还应注意，只要存在资源瓶颈（通常是磁盘或 CPU 瓶颈），SetColumns 操作的延迟时间就会增加。

详细信息

有关详细信息，请参阅下列 Exchange Server 资源：

  • "Performance and Scalability Guide for Exchange Server 2003"（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)

  • "Troubleshooting Microsoft Exchange Server Performance"（解决 Microsoft Exchange Server 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)

  • Exchange Server 2003 Performance:10 Things to Think About（Exchange Server 2003 性能：要考虑的 10 件事情）(http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft 知识库文章 905803"Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server"（Outlook 用户在运行 Exchange Server 2003 或 Exchange 2000 Server 的服务器上使用包含许多项目的文件夹时出现性能下降问题）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


长时间运行的 MAPI 同步操作
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-23

Microsoft® Exchange Server 分析工具使用 Exchange Server 用户监视器 (ExMon) 工具来确定用户 MAPI 操作的完成时间是否比正常 Exchange 服务器上的合理预期时间长。

作为其分析的一部分，Exchange Server 分析工具检查 ExMon 数据来确定用户发出的完成时间超过 30 秒的 MAPI 同步操作。

MAPI 同步操作旨在使 Microsoft Office® Outlook® 脱机文件夹文件 (.ost) 或用户邮箱的本地副本与服务器上的用户邮箱数据保持同步。

完成时间超过 30 秒的 MAPI 同步操作并非始终会出现问题。默认情况下，在 Outlook 2003 中第一次启用缓存 Exchange 模式时，存储在 Exchange Server 上以及作为全局地址列表完整副本的所有电子邮件将下载到用户的计算机上。

在与 Exchange Server 的初始同步期间，Outlook 2003 用户可能会出现响应延迟的情况。

在进行初始缓存模式同步后，如果一个或多个用户经常出现延迟，或者延迟对其邮件传递体验造成负面影响，则应该对这些 MAPI 同步操作延迟进行进一步的调查，以确保它们没有更严重延迟问题的症状，如资源瓶颈。

只要存在资源瓶颈（通常是磁盘或 CPU 瓶颈），MAPI 同步操作的延迟时间就会增加。应找出服务器资源瓶颈，并提高服务器资源容量或者将用户移到负载较少的服务器上。

详细信息

有关详细信息，请参阅下列 Exchange Server 资源：

  • Performance and Scalability Guide for Exchange Server 2003（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)

  • Troubleshooting Microsoft Exchange Server 2003 Performance（解决 Microsoft Exchange Server 2003 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)

  • "Exchange Server 2003 Performance: 10 Things to Think About"（Exchange Server 2003 性能：要考虑的 10 件事情）(http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft 知识库文章 905803"Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server"（Outlook 用户在运行 Exchange Server 2003 或 Exchange 2000 Server 的服务器上使用包含许多项目的文件夹时出现性能下降问题）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


长时间运行的 MAPI"TaskQ"操作
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-02-20

Microsoft Exchange 分析工具使用 Exchange Server 用户监视器 (ExMon) 工具，来确定用户 MAPI 操作的完成时间是否比正常运行的 Exchange 服务器上的合理预期时间长一些。

作为其分析过程的一部分，Exchange 分析工具复查 ExMon 数据，以查找用户发出的完成时间超过 30 秒的 MAPI TaskQ 操作。

TaskQ 操作是在 RPC 调用上下文之外执行的异步任务。TaskQ 和 TaskQ User Unknown 操作是根据 Exchange 的请求执行的任务，包括存储维护。TaskQ User Known 操作是应用户的直接请求而启动的异步任务，包括搜索文件夹填充、排序以及批量操作（例如移动、复制和删除多封邮件以及将其标记为已读）。

如果 Exchange 分析工具确定用户发出的 MAPI TaskQ 操作的完成时间超过 30 秒，Exchange 分析工具将显示警告。

此警告并非总是表明存在性能问题，因为 TaskQ 操作通常是需要很长时间才能完成的操作。

若要解决此问题，请执行下列操作：

  • 考虑使用 ExMon 工具来捕获更大的数据样本以供 Exchange Server 分析工具进行复查。由于 Exchange 生成的数据量较大，因此，我们建议将数据收集样本控制在 30 分钟或更短。

详细信息

有关详细信息，请参阅下列 Exchange Server 资源：

  • Performance and Scalability Guide for Exchange Server 2003（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)

  • Troubleshooting Microsoft Exchange Server 2003 Performance（解决 Microsoft Exchange Server 2003 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)

  • Exchange Server 2003 Performance: 10 Things to Think About（Exchange Server 2003 性能：要考虑的 10 件事情）(http://go.microsoft.com/fwlink/?LinkId=56460)


由于 MAPI 'Restrict' 操作而长时间运行的操作
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-23

Microsoft® Exchange Server 分析工具使用 Exchange Server 用户监视器 (ExMon) 工具来确定用户 MAPI 操作的完成时间是否比运行 Exchange Server 的正常服务器上的合理预期时间长。

作为其分析的一部分，Exchange Server 分析工具检查 ExMon 数据来确定用户发出的完成时间超过 30 秒的 MAPI Restrict 操作。

客户端应用程序使用 MAPI Restrict 操作来选择符合特定条件的项目。服务器将创建一个视图，该视图实际上是具有关联条件（称为限制）的表。如果具有匹配限制的视图已存在，服务器将使用现有视图来满足用户请求。当服务器使用此视图时，产生的开销比服务器创建新视图时的开销小。默认情况下，存储仅为每个文件夹缓存 11 个视图。如果要求服务器创建第 12 个视图，服务器将删除最早的缓存视图并创建一个新视图。视图会增加对项目执行的所有操作的开销。

如果 Exchange Server 分析工具确定用户发出的 MAPI Restrict 操作的完成时间超过 30 秒，Exchange Server 分析工具将显示错误。

完成时间超过 30 秒的 MAPI Restrict 操作并非始终会出现问题。但是，如果一个或多个用户经常出现延迟，或者延迟对其邮件传递体验造成负面影响，则这些延迟可能表明用户应用程序导致创建新的视图。

若要更正此错误，请与经常出现延迟的用户一起来确定以下情况：

  • 文件夹中的项目计数是否很高。

  • 用户正在运行哪些应用程序。

若要解决该问题，请执行下列步骤：

  • 鼓励文件夹中包含许多项目的用户减少每个文件夹中的项目数。建议在"收件箱"、"日历"、"已发送邮件"、"联系人"和"已删除邮件"文件夹中保存的项目不应超过 5,000 个。

  • 将运行开销最高的客户端计算机配置为使用缓存 Exchange 模式。应额外注意在执行 Restrict、SetColumns 或 FindRow 操作时出现较长时间延迟的客户端计算机。缓存 Exchange 模式将服务器与大多数过量 RPC 通信隔离开。

  • 按照以下部分中提到的 Exchange 工作组博客中的指导来打开事件日志限制跟踪。然后逐个打开用户应用程序，以跟踪可能导致长时间运行的限制的应用程序。

  • 尝试关闭所有应用程序。然后逐个打开它们，以查找可能导致此问题的应用程序。如果以下任一条件成立，应永久性关闭任何有问题的应用程序，或者对其进行更新以将负载减少到相应的级别：

    • 工作中不需要使用该应用程序。

    • 该应用程序已发布了更新。

注意：
有些应用程序即使没有发出许多 MAPI 操作，也可能会显著增加服务器负载。这是因为某些操作的开销比其他操作高。开销较高的操作数量只要稍稍增加，就可能会显著影响服务器的性能。在 ExMon 中，将报告这些用户对 CPU 产生较大的影响，但他们未必发出了许多 MAPI 操作。

还应注意，只要存在资源瓶颈（通常是磁盘或 CPU 瓶颈），Restrict 操作的延迟时间就会增加。

详细信息

有关 MAPI Restrict 操作的详细信息，请参阅 Microsoft Exchange 工作组博客"Putting the Restrictions on Restrictions"（进行严格限制）(http://go.microsoft.com/fwlink/?linkid=55098)。

注意：
每篇博客的内容及其 URL 如有更改，恕不另行通知。

有关详细信息，请参阅下列 Exchange Server 资源：

  • "Performance and Scalability Guide for Exchange Server 2003"（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)

  • "Troubleshooting Microsoft Exchange Server Performance"（解决 Microsoft Exchange Server 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)

  • "Exchange Server 2003 Performance: 10 Things to Think About"（Exchange Server 2003 性能：要考虑的 10 件事情）(http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft 知识库文章 905803"Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server"（Outlook 用户在运行 Exchange Server 2003 或 Exchange 2000 Server 的服务器上使用包含许多项目的文件夹时出现性能下降问题）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


MAD.EXE 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查几个核心 Exchange 二进制文件是否存在：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则会显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


MAD NSPI 端口低于 5000
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Microsoft Exchange System Attendant 服务的 TCP/IP NSPI Port 设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

如果 Exchange Server 分析工具发现 TCP/IP NSPI Port 的值设置为低于 5000（十进制），则显示警告。

如果必须将 TCP/IP NSPI Port 设置为静态值，建议您将其值设置为刚好大于 5000。如果分配的静态端口号低于 5000，可能会造成与另一个进程的端口冲突，导致 Exchange System Attendant 服务进程失败。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

设置 TCP/IP NSPI Port 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 双击 TCP/IP NSPI Port 注册表项，然后将"数值数据"字段设置为刚好大于 5000 的整数（十进制）。

  4. 关闭注册表编辑器。

  5. 重新启动 Microsoft Exchange System Attendant 服务，以使此更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关端口限制的详细信息，请参阅知识库文章 194952"XADM：Exchange Server 静态映射端口限制"(http://support.microsoft.com/kb/194952/zh-cn)。


MAD RFR 端口已被手动覆盖
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Microsoft Exchange System Attendant 目录引用端口的端口值是否已被手动覆盖：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

如果 Exchange Server 分析工具发现 TCP/IP Port 存在并已配置，则会显示非默认配置消息。

配置该值的最常见理由是为了使 MAPI 客户端能够连接到在防火墙另一侧的 Exchange 服务器。该方案涉及打开防火墙上的多个端口，以便使 Microsoft Office Outlook® 2003 客户端能够使用 MAPI 连接到 Exchange 服务器（通常通过 Internet）。支持此配置。有关将 MAPI 客户端配置为通过防火墙连接到 Exchange 的详细信息，请参阅 Microsoft 知识库文章 270836"Exchange 2000 和 Exchange 2003 静态端口映射"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)。如果使用的不是此方案，应删除该注册表项。

如果要在 MAPI 模式下使用 Outlook 通过 Internet 连接到 Exchange 服务器，则推荐的部署是使用 RPC over HTTP（超文本传输协议远程过程调用）功能，该功能可以在 Microsoft Windows Server™ 2003、Exchange Server 2003、Outlook 2003 和 Windows® XP Professional 上找到。MAPI 模式以前称为"公司"或"工作组"模式。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

删除 TCP/IP Port 注册表值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 删除名为 TCP/IP Port 的注册表值。

  4. 关闭注册表编辑器，然后重新启动 Microsoft Exchange System Attendant 服务。

部署 RPC over HTTPS

  1. 查看"Exchange Server 2003 RPC over HTTP Deployment Scenarios"（英文）(http://go.microsoft.com/fwlink/?linkid=47577)。

  2. 查看知识库文章 833401"如何在一台服务器上的 Exchange Server 2003 中配置 RPC over HTTP"(http://support.microsoft.com/kb/833401/zh-cn)。

  3. 查看知识库文章 827330"How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)。

  4. 查看 Microsoft 支持 Web 广播"Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


MAD RFR 端口低于 5000
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Microsoft Exchange System Attendant 服务的 TCP/IP Port 设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

如果 Exchange Server 分析工具发现 TCP/IP Port 的值设置为低于 5000（十进制），则会显示警告。

如果必须将 TCP/IP Port 设置为静态值，建议您将其值设置为刚好大于 5000。如果分配的静态端口号低于 5000，可能会造成与另一个进程的端口冲突，导致 Microsoft Exchange System Attendant 服务进程失败。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

设置 TCP/IP 端口注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 双击 TCP/IP Port 注册表项，然后将"数值数据"字段设置为刚好大于 5000 的整数（十进制）。

  4. 关闭注册表编辑器。

  5. 重新启动 Microsoft Exchange System Attendant 服务，以使此更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关端口设置的详细信息，请参阅知识库文章 194952"XADM：Exchange Server 静态映射端口限制"(http://support.microsoft.com/?kbid=194952)。


bin 文件夹中缺少 MAPI32.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft?Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows?Management Instrumentation (WMI) 类，以检查几个核心 Exchange 二进制文件是否存在：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


system32 文件夹中缺少 MAPI32.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查几个核心 Exchange 二进制文件是否存在：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则会显示错误。若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式下运行安装程序将仅仅安装二进制文件，而不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头选择"重新安装"，然后单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


MAPISTUB.DLL 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查是否存在下列几个核心 Exchange 二进制文件：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


MAPISP32.EXE 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查是否存在下列几个核心 Exchange 二进制文件：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


最大 ESE 缓存大小大于 1.2 GB
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-02-13

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 DataBase 性能对象的 DataBase Cache Size (DBCacheSize) 性能计数器收集数据，以分析性能数据。

DataBase Cache Size (DBCacheSize) 性能计数器表示存储使用的当前缓存大小。如果 Exchange Server 分析工具发现 DataBase Cache Size (DBCacheSize) 性能计数器的值大于 307200 (1.2 GB)，则将显示错误。

该错误表明 Microsoft Exchange 信息存储 (MSExchangeIS) 对象的 msExchESEParamCacheSizeMax 属性值已经增长到超过最大推荐值 307200 (1.2 GB) 的水平。

存储数据库缓存也称为 ESE（可扩展存储引擎）缓冲区。它在数据库事务提交到数据库之前缓存这些数据库事务。

在 Exchange 2000 Server 中，Store.exe 所使用的大型虚拟内存区域是为 ESE 缓冲区分配的。对于该缓冲区，Exchange 2000 Server 使用硬编码的 858 MB 作为其默认大小。在 Exchange Server 2003 中，ESE 缓冲区的分配是基于在 Boot.ini 文件中是否出现 /3GB 开关来进行的。如果有 /3GB 开关，则 ESE 缓冲区被调整为 896 MB。如果没有 /3GB，则 ESE 缓冲区被调整为 576 MB。虽然在每种情况下自动调整都是有用的，但您可能需要覆盖该自动调整设置，并手动设置更适合于具体环境的值。

虽然按照分配的实际内存是 8,192 字节的倍数的方法，可以将此值调整到任何数字，还是推荐您只使用下表中的值。

推荐值 | 分配的内存 | 注释
147456 | 576 MB | 这是最低推荐值。不要将该值设置为任何更低的值。在虚拟内存有限的服务器上，以及在以不支持 /3GB 开关的 Microsoft Windows® 2000 Server 作为操作系统的 Exchange Server 2003 计算机上，该值是有用的。它还是不使用 /3GB 开关的系统上的默认值。
196608 | 768 MB | 在有大量虚拟内存并且频繁记录 9582 事件的服务器上，该值是推荐值。
219726 | 858 MB | 这是 Exchange2000 Server 中的默认值，对于正在就地进行升级并有大量虚拟内存的系统来说，它是一个很有用的值。
229376 | 896 MB | 这是 Exchange Server 2003 中的默认值，并且适合用在新系统上（除非应用程序事件日志中出现 9582 事件，说明该值不合适）。
307200 | 1.2 GB | 这是可以设置的最大值。应仅在具有 2 GB 或更多物理内存的系统上使用该值。

在重新配置该值之前，应当监视 Store.exe 进程消耗的虚拟内存数量。可以通过在 Microsoft Windows 中监视 Process 性能对象来监视该数量。在使用 /3GB 开关的系统上，Process 对象的 Store.exe 实例的 Virtual Bytes 计数器应当小于 2.8 GB。在未使用 /3GB 开关的系统上，Process 对象的 Store.exe 实例的 Virtual Bytes 计数器应当小于 1.8 GB。如果值大于这些数量，则可能必须减少 msExchESEParamCacheSizeMax 的值。如果值小于该数量，则可能需要增加 msExchESEParamCacheSizeMax 的值。

警告：
在使用 Active Directory 服务接口 (ADSI) Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory® 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。
调整 msExchESEParamCacheSizeMax 属性

  1. 打开 Active Directory 编辑器，如 ADSI Edit。

  2. 双击 Configuration 容器。

  3. 展开 CN=Services。

  4. 展开 CN=Microsoft Exchange。

  5. 展开 CN=<Exchange Organization Name>。

  6. 展开 CN=Administrative Groups。

  7. 展开 CN=<Administrative Group Name>。

  8. 展开 CN=Servers。

  9. 展开 CN=<Exchange Server Name>。

  10. 右键单击 CN=InformationStore，再单击"属性"。

  11. 在属性字段中，滚动到 msExchESEParamCacheSizeMax 并双击它。

  12. 在 Value 字段中，键入要设置的值。使用上表来确定系统的最佳值。

  13. 单击 OK，然后再次单击 OK。

  14. 关闭 Active Directory 编辑器，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

有关优化内存使用的详细信息，请参阅"Planning a Microsoft Exchange Server 2003 Messaging System"(http://go.microsoft.com/fwlink/?LinkId=47584) 中的"Optimizing Memory Usage for Exchange Server 2003"（英文）。

有关 msExchESEParamCacheSizeMax 属性的详细信息，请参阅 Microsoft 知识库文章 266768"How to modify the Store Database maximum cache size in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768)。


最大收件人数限制已更改
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchRecipLimit 属性是否已从默认值更改为其他值。msExchRecipLimit 属性存储每封电子邮件的全局最大收件人数的值。默认情况下，msExchRecipLimit 属性的值为 5000。如果 Exchange Server 分析工具发现 msExchRecipLimit 属性的值不等于 5000，Exchange Server 分析工具将显示非默认配置消息。

全局最大收件人数限制适用于整个 Exchange 组织。msExchRecipLimit 属性的值限制单个电子邮件的收件人数。全局最大收件人数限制影响系统邮件和非系统邮件。系统邮件包括公用文件夹复制邮件。

注意：
还可以使用 Active Directory 用户和计算机为每个用户设置收件人数限制。每个用户的设置优先于全局设置，并将覆盖全局设置。默认情况下，每个用户的收件人数限制设置为使用全局最大收件人数限制。
注意：
在简单邮件传输协议 (SMTP) 虚拟服务器上，可以为从 Internet 用户接收的邮件设置每封邮件的收件人数限制。此限制与全局最大收件人数限制和每个用户的收件人数限制不同。全局最大收件人数限制和每个用户的收件人数限制均限制 Exchange 用户可以将邮件发送到的收件人数。
将全局最大收件人数限制更改为默认值

  1. 启动 Exchange 系统管理器。

  2. 在左侧窗格中，展开"全局设置"。

  3. 用鼠标右键单击"邮件传递"，再单击"属性"。

  4. 在"默认值"选项卡的"收件人限制"下，单击"最大收件人数"，再键入 5000。

  5. 重新启动 Microsoft Exchange 信息存储服务。

有关设置收件人数限制和配置 Microsoft Office Outlook® Web Access 客户端的详细信息，请参阅"Exchange Server 2003 邮件安全指南"中的"与 Outlook Web Access S/MIME 控件相关的设置"(http://www.microsoft.com/downloads/details.aspx?FamilyID=2305405C-FAF1-488A-A856-AD467BB59B26&displaylang=zh-cn)。

有关最大收件人数限制的历史的详细信息，请参阅 Exchange 网络日志文章"Me Too!"（英文）(http://go.microsoft.com/fwlink/?LinkId=41848)。


最大收件人数限制过高
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定邮件的 msExchRecipLimit 值是否超过 7500。如果 Exchange Server 分析工具发现 msExchRecipLimit 属性的值大于 7500，Exchange Server 分析工具将显示警告。

msExchRecipLimit 属性存储每封电子邮件的全局最大收件人数的值。该值限制单个电子邮件的收件人数。该值还影响系统邮件和非系统邮件。系统邮件包括公用文件夹复制邮件。默认情况下，msExchRecipLimit 属性的值为 5000。

如果 msExchRecipLimit 属性的值超过 7500，因为包含许多收件人的邮件造成问题的风险会增大。

注意：
还可以使用 Active Directory 用户和计算机为每个用户设置收件人数限制。每个用户的设置优先于全局设置，并将覆盖全局设置。默认情况下，每个用户的收件人数限制设置为使用全局最大收件人数限制。
注意：
在简单邮件传输协议 (SMTP) 虚拟服务器上，可以为从 Internet 用户接收的邮件设置每封邮件的收件人数限制。此限制与全局最大收件人数限制和每个用户的收件人数限制不同。全局最大收件人数限制和每个用户的收件人数限制均限制 Exchange 用户可以将邮件发送到的收件人数。
将全局最大收件人数限制更改为默认值

  1. 启动 Exchange 系统管理器。

  2. 在左侧窗格中，展开"全局设置"。

  3. 用鼠标右键单击"邮件传递"，再单击"属性"。

  4. 在"默认值"选项卡的"收件人限制"下，单击"最大收件人数"，再键入 5000。

  5. 重新启动 Microsoft Exchange 信息存储服务。

有关设置收件人数限制和配置 Microsoft Office Outlook® Web Access 客户端的详细信息，请参阅"Exchange Server 2003 邮件安全指南"中的"与 Outlook Web Access S/MIME 控件相关的设置"(http://www.microsoft.com/downloads/details.aspx?FamilyID=2305405C-FAF1-488A-A856-AD467BB59B26&displaylang=zh-cn)。

有关全局最大收件人数限制的历史的详细信息，请参阅 Exchange 网络日志文章"Me Too!"（英文）(http://go.microsoft.com/fwlink/?LinkId=41848)。


最大收件人数限制太低
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定邮件的 msExchRecipLimit 值是否小于 Exchange 组织中的公用文件夹存储数。如果 Exchange Server 分析工具发现 msExchRecipLimit 属性的值小于公用文件夹存储数，Exchange Server 分析工具将显示错误。

msExchRecipLimit 属性存储每封电子邮件的全局最大收件人数的值。该值限制单个电子邮件的收件人数。该值还影响系统邮件和非系统邮件。系统邮件包括公用文件夹复制邮件。默认情况下，msExchRecipLimit 属性的值为 5000。如果 msExchRecipLimit 属性的值小于 Exchange 组织中的公用文件夹存储数，在复制公用文件夹层次结构时会遇到问题。

注意：
还可以使用 Active Directory 用户和计算机为每个用户设置收件人数限制。每个用户的设置优先于全局设置，并将覆盖全局设置。默认情况下，每个用户的收件人数限制设置为使用全局最大收件人数限制。
注意：
在简单邮件传输协议 (SMTP) 虚拟服务器上，可以为从 Internet 用户接收的邮件设置每封邮件的收件人数限制。此限制与全局最大收件人数限制和每个用户的收件人数限制不同。全局最大收件人数限制和每个用户的收件人数限制均限制 Exchange 用户可以将邮件发送到的收件人数。
将全局最大收件人数限制更改为默认值

  1. 启动 Exchange 系统管理器。

  2. 在左侧窗格中，展开"全局设置"。

  3. 用鼠标右键单击"邮件传递"，再单击"属性"。

  4. 在"默认值"选项卡上的"收件人限制"下，单击"最大收件人数"，确保该值不小于 Exchange 组织中的公用文件夹存储数。

  5. 重新启动 Microsoft Exchange 信息存储服务。

有关设置收件人数限制和配置 Microsoft Office Outlook® Web Access 客户端的详细信息，请参阅"Exchange Server 2003 邮件安全指南"中的"与 Outlook Web Access S/MIME 控件相关的设置"(http://www.microsoft.com/downloads/details.aspx?FamilyID=2305405C-FAF1-488A-A856-AD467BB59B26&displaylang=zh-cn)。

有关全局最大收件人数限制的历史的详细信息，请参阅 Exchange 网络日志文章"Me Too!"（英文）(http://go.microsoft.com/fwlink/?LinkId=41848)。


MaxUserPort 项缺少或为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-03-23

Microsoft Exchange 分析工具查询 Active Directory 目录服务以确定所有具有 msExchExchangeServer 对象类的对象的 serialNumber 属性值。如果字符串值包括"Version 5.5"，则表示计算机运行的是 Exchange Server 5.5。如果字符串值包括"Version 6.0"，则表示计算机运行的是 Exchange 2000 Server。如果字符串值包括"Version 6.5"，则表示计算机运行的是 Exchange Server 2003。如果字符串值包括"Version 8.0"，则表示计算机运行的是 Exchange Server 2007。

然后，Exchange 分析工具读取找到的每个 Exchange Server 2007 服务器的以下注册表分支，以确定 MaxUserPort 项的值是否设置为默认值 60000。

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

MaxUserPort 项确定在应用程序向系统请求可用的用户端口时，TCP 可以分配的最高端口号。

默认情况下，Microsoft Windows Server 2003 将 MaxUserPort 值设置为 5000。Microsoft Windows 2000 不将 MaxUserPort 值添加到注册表中。但可以手动添加它。但是，在 Windows Server 2003 和 Windows 2000 Server 上，Exchange Server 2003 和 Exchange Server 2007 将默认值设置为 60000。Exchange 2000 Server 不设置值。

建议将 MaxUserPort 值设置为 60000。如果设置的 MaxUserPort 值低于 60000，可能会显示名称服务提供程序接口 (NSPI) 代理警告，例如事件 9040。事件 9040 在下表中介绍：

事件 ID | 9040
事件类别 | NSPI 代理
事件来源 | MSExchangeSA
事件类型 | 警告
事件描述 | NSPI 代理在接收数据包时出错。目标域控制器、网络或某个客户端可能已关闭。Winsock 子系统返回错误：[0x2746]。收到此错误的电路将关闭。
重要信息：
本主题包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

  3. 双击 MaxUserPort，将"数值数据"字段设置为 60000（十进制），再单击"确定"。

  4. 关闭注册表编辑器，并重新启动计算机，以使此设置生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

此问题与 TcpTimedWaitDelay 项缺少或为非默认值分析工具问题有关。

有关 MaxUserPort 和 TcpTimedWaitDelay 注册表项的影响的详细信息，请参阅 Windows 2000 Resource Kit（Windows 2000 资源工具包）中的"Transmission Control Protocol"（传输控制协议）主题 (http://go.microsoft.com/fwlink/?LinkId=85654)。


MaxUserPort 值太低
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 TCP 临时端口的最大值：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\MaxUserPort

临时端口是短暂使用的端口。

如果 Exchange Server 分析工具发现 MaxUserPort 注册表项的值小于 50000，则 Exchange Server 分析工具将显示警告。

MaxUserPort 值指定在应用程序向系统请求可用的用户端口时，TCP 可以分配的最高端口号。通常，为临时端口分配的端口号为 1024 到 5000。

默认情况下，Microsoft Windows Server™ 2003 将 MaxUserPort 值设置为 5000。Microsoft Windows® 2000 不将 MaxUserPort 值添加到注册表中。可以手动将 MaxUserPort 值添加到注册表中。但是，在 Windows Server 2003 和 Windows 2000 Server 上，Exchange Server 2003 将默认值设置为 60000。Exchange 2000 Server 不设置值。

建议将 MaxUserPort 值设置为 60000。如果设置的 MaxUserPort 值低于 60000，可能会显示名称服务提供程序接口 (NSPI) 代理警告，例如事件 9040。事件 9040 在下表中介绍。

事件 ID | 9040
事件类别 | NSPI 代理
事件来源 | MSExchangeSA
事件类型 | 警告
事件描述 | NSPI 代理在接收数据包时出错。目标域控制器、网络或某个客户端可能已关闭。Winsock 子系统返回错误：[0x2746]。收到该错误的电路将关闭。

若要解决此警告问题，请将 MaxUserPort 注册表项的值设置为 60000。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

  3. 双击 MaxUserPort，将"数值数据"字段设置为 ea60（十六进制），再单击"确定"。

  4. 关闭注册表编辑器，并重新启动计算机，以使该设置生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


MDBSZ.DLL 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类以检查下列几个核心 Exchange 二进制文件：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。如果在重新安装模式中运行安装程序，将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。在 CD 驱动器中插入 Exchange 2000 Server 或 Exchange Server 2003 CD。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


Memory 性能监视器对象不可用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包括性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎从 Memory 性能对象的 Available Mbytes 性能计数器收集数据以分析性能数据。如果计数器未返回有效数据，则 Exchange Server 分析工具将显示基准消息。

如果性能数据收集引擎未返回有效数据，则可能出现下列情况的任意组合：

  • Memory 性能对象已禁用。

  • Memory 性能监视器对象丢失或损坏。

  • Exchange Server 分析工具没有访问性能对象的相应权限。

如果某些可扩展计数器破坏了注册表，或基于 Microsoft Windows® Management Instrumentation (WMI) 的程序修改了注册表，可能会发生前两种情况。

在执行此过程之前，请验证 Exchange Server 分析工具是否具有相应的权限。有关运行 Exchange Server 分析工具所需的权限的详细信息，请参阅随 Exchange Server 分析工具提供的帮助文档。要获得帮助，请打开 Exchange Server 分析工具，然后按 F1 键。

更正此错误

  1. 验证 Memory 性能对象是否已启用：

    1. 下载并安装可扩展性能计数器列表工具 (Exctrlst.exe)。可以在"Exctrlst.exe: Extensible Performance Counter List"（英文）(http://go.microsoft.com/fwlink/?LinkId=34436) 下载 Exctrlst.exe。

    2. 打开 Exctrlst.exe，再单击"Sort Order"，然后单击"Service"。

    3. 找到性能对象所报告的服务，并确认选中了"Performance Counters Enabled"复选框。

      如果未选中"Performance Counters Enabled"复选框，请选中该复选框，然后重新启动与性能计数器关联的服务，确认性能计数器工作正常。如果性能计数器无法正常工作，或"Performance Counters Enabled"复选框已选中，请继续执行第 2 步。

  2. 重建丢失或损坏的性能计数器，请参阅 Microsoft 知识库文章 300956"如何手动重新生成性能计数器库值"(http://support.microsoft.com/?kbid=300956)。

  3. 如果按照此知识库文章操作不能解决问题，将必须在"修复"模式下重新安装 Windows 操作系统，然后应用最新的 Windows Service Pack。


MSExchangeDSAccess Processes 性能监视器对象不可用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 MSExchangeDSAccess 性能对象的 LDAP Read Time 性能计数器收集数据，以分析性能数据。如果计数器未返回有效数据，Exchange Server 分析工具将显示基准消息。

如果性能数据收集引擎未返回有效数据，则可能出现下列情况的任意组合：

  • MSExchangeDSAccess 性能对象被禁用。

  • MSExchangeDSAccess 性能监视器对象缺失或损坏。

  • Exchange Server 分析工具没有访问性能对象的相应权限。

如果某些可扩展计数器破坏了注册表，或基于 Microsoft Windows® Management Instrumentation (WMI) 的程序修改了注册表，可能会发生前两种情况。以下过程说明如何处理前两种情况。在执行该过程之前，请验证 Exchange Server 分析工具是否具有相应的权限。

有关运行 Exchange Server 分析工具所需的权限的详细信息，请参阅随 Exchange Server 分析工具提供的帮助文档。要获得帮助，请打开 Exchange Server 分析工具，然后按 F1 键。

更正此错误

  1. 验证 MSExchangeDSAccess 性能对象是否已启用：

    1. 下载并安装可扩展性能计数器列表工具 (Exctrlst.exe)。可以在"Exctrlst.exe: Extensible Performance Counter List"(http://go.microsoft.com/fwlink/?LinkId=34436) 下载 Exctrlst.exe。

    2. 打开"Exctrlst.exe"，再单击"排列顺序"，然后单击"服务"。

    3. 找到性能对象所报告的服务，并确认选中了"Performance Counters Enabled"复选框。

      如果未选中"Performance Counters Enabled"复选框，请选中该复选框，然后重新启动与性能计数器关联的服务，确认性能计数器工作正常。如果性能计数器无法正常工作，或"Performance Counters Enabled"复选框已选中，请继续执行第 2 步。

  2. 请按照 Microsoft 知识库文章 300956"如何手动重新生成性能计数器库值"(http://support.microsoft.com/?kbid=300956) 重建丢失或损坏的性能计数器。

  3. 如果按照此知识库文章操作不能解决问题，则必须在"修复"模式下重新安装 Exchange Server，然后应用最新的 Exchange Server Service Pack。


MSExchangeIS Mailbox 性能监视器对象不可用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 MSExchangeIS Mailbox 性能对象的 Send Queue Size 性能计数器收集数据，以分析性能数据。如果计数器未返回有效数据，Exchange Server 分析工具将显示基准消息。

如果性能数据收集引擎未返回有效数据，则可能出现下列情况的任意组合：

  • MSExchangeIS Mailbox 性能对象已禁用。

  • MSExchangeIS Mailbox 性能监视器对象丢失或损坏。

  • Exchange Server 分析工具没有访问性能对象的相应权限。

如果某些可扩展计数器破坏了注册表，或基于 Microsoft Windows® Management Instrumentation (WMI) 的程序修改了注册表，可能会发生前两种情况。

在执行该过程之前，请验证 Exchange Server 分析工具是否具有相应的权限。有关运行 Exchange Server 分析工具所需的权限的详细信息，请参阅随 Exchange Server 分析工具提供的帮助文档。要获得帮助，请打开 Exchange Server 分析工具，然后按 F1 键。

更正此错误

  1. 验证 MSExchangeIS Mailbox 性能对象是否已启用：

    1. 下载并安装可扩展性能计数器列表工具 (Exctrlst.exe)。可以在"Exctrlst.exe: Extensible Performance Counter List"(http://go.microsoft.com/fwlink/?LinkId=34436) 下载 Exctrlst.exe。

    2. 打开 Exctrlst.exe，再单击"Sort Order"，然后单击"Service"。

    3. 找到性能对象所报告的服务，并确认选中了"Performance Counters Enabled"复选框。

      如果未选中"Performance Counters Enabled"复选框，请选中该复选框，然后重新启动与性能计数器关联的服务，确认性能计数器工作正常。如果性能计数器无法正常工作，或"Performance Counters Enabled"复选框已选中，请继续执行第 2 步。

  2. 重建丢失或损坏的性能计数器，请参阅 Microsoft 知识库文章 300956"如何手动重新生成性能计数器库值"(http://support.microsoft.com/?kbid=300956)。

  3. 如果按照此知识库文章操作不能解决问题，将必须在"修复"模式下重新安装 Exchange Server，然后应用最新的 Exchange Server Service Pack。


MSExchangeIS 性能监视器对象不可用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-04-03

Microsoft® Exchange Server 分析工具包括性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎从 MSExchangeIS 性能对象的 RPC Operations/sec 性能计数器收集数据以分析性能数据。如果计数器未返回有效数据，则 Exchange Server 分析工具将显示基准消息。

如果性能数据收集引擎未返回有效数据，则可能出现下列情况的任意组合：

  • MSExchangeIS 性能对象被禁用。

  • MSExchangeIS 性能监视器对象丢失或损坏。

  • Exchange Server 分析工具没有访问性能对象的相应权限。

如果某些可扩展计数器破坏了注册表，或基于 Microsoft Windows® Management Instrumentation (WMI) 的程序修改了注册表，可能会发生前两种情况。在执行此过程之前，请验证 Exchange Server 分析工具是否具有相应的权限。有关运行 Exchange Server 分析工具所需的权限的详细信息，请参阅随 Exchange Server 分析工具提供的帮助文档。要获得帮助，请打开 Exchange Server 分析工具，然后按 F1 键。

更正此错误

  1. 验证 MSExchangeIS 性能对象是否已启用：

    1. 下载并安装可扩展性能计数器列表工具 (Exctrlst.exe)。可以在"Exctrlst.exe: Extensible Performance Counter List"(http://go.microsoft.com/fwlink/?LinkId=34436)（英文）下载 Exctrlst.exe。

    2. 打开 Exctrlst.exe，再单击"Sort Order"，然后单击"Service"。

    3. 找到性能对象所报告的服务，并确认选中了"Performance Counters Enabled"复选框。

      如果未选中"Performance Counters Enabled"复选框，请选中该复选框，然后重新启动与性能计数器关联的服务，确认性能计数器工作正常。如果性能计数器无法正常工作，或"Performance Counters Enabled"复选框已选中，请继续执行第 2 步。

  2. 重建丢失或损坏的性能计数器，请参阅 Microsoft 知识库文章 300956"如何手动重新生成性能计数器库值"(http://support.microsoft.com/?kbid=300956)。

  3. 如果按照此知识库文章操作不能解决问题，将必须在"修复"模式下重新安装 Exchange Server，然后应用最新的 Exchange Server Service Pack。

有关解决 Exchange Server 分析工具连接问题的详细信息，请参阅"Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"（英文）(http://go.microsoft.com/fwlink/?LinkId=56285)。


MSExchangeIS Public 性能监视器对象不可用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包括性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎从 MSExchangeIS Public 性能对象的 Send Queue Size 性能计数器收集数据以分析性能数据。如果计数器未返回有效数据，则 Exchange Server 分析工具将显示基准消息。

如果性能数据收集引擎未返回有效数据，则可能出现下列情况的任意组合：

  • MSExchangeIS Public 性能对象已禁用。

  • MSExchangeIS Public 性能监视器对象丢失或损坏。

  • Exchange Server 分析工具没有访问性能对象的相应权限。

如果某些可扩展计数器破坏了注册表，或基于 Microsoft Windows® Management Instrumentation (WMI) 的程序修改了注册表，可能会发生前两种情况。在执行此过程之前，请验证 Exchange Server 分析工具是否具有相应的权限。有关运行 Exchange Server 分析工具所需的权限的详细信息，请参阅随 Exchange Server 分析工具提供的帮助文档。要获得帮助，请打开 Exchange Server 分析工具，然后按 F1 键。

更正此错误

  1. 验证 MSExchangeIS Public 性能对象是否已启用：

    1. 下载并安装可扩展性能计数器列表工具 (Exctrlst.exe)。可以在"Exctrlst.exe: Extensible Performance Counter List"（英文）(http://go.microsoft.com/fwlink/?LinkId=34436) 下载 Exctrlst.exe。

    2. 打开 Exctrlst.exe，再单击"Sort Order"，然后单击"Service"。

    3. 找到性能对象所报告的服务，并确认选中了"Performance Counters Enabled"复选框。

      如果未选中"Performance Counters Enabled"复选框，请选中该复选框，然后重新启动与性能计数器关联的服务，确认性能计数器工作正常。如果性能计数器无法正常工作，或"Performance Counters Enabled"复选框已选中，请继续执行第 2 步。

  2. 重建丢失或损坏的性能计数器，请参阅 Microsoft 知识库文章 300956"如何手动重新生成性能计数器库值"(http://support.microsoft.com/?kbid=300956)。

  3. 如果按照此知识库文章操作不能解决问题，将必须在"修复"模式下重新安装 Exchange Server，然后应用最新的 Exchange Server Service Pack。


MSGINA.DLL 驱动程序更新可用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-08-21

Microsoft® Exchange Server 分析工具将读取以下注册表项，以确定在运行 Exchange Server 计算机上使用的 Microsoft Windows® 版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

如果 CurrentVersion 的值为 4.0，则表示 Exchange 服务器运行的是 Microsoft Windows NT® Server 4.0。如果该值为 5.0，则表示 Exchange 服务器运行的是 Windows 2000 Server。如果该值为 5.2，则表示 Exchange 服务器运行的是 Windows Server™ 2003。

Exchange Server 分析工具还将检查 Win32_OperatingSystem Microsoft Windows Management Instrumentation (WMI) 类，以确定 ServicePackMajorVersion 项的值。

如果 ServicePackMajorVersion 项值为 1，则表示服务器上已安装 Service Pack 1 (SP1)。

最后，Exchange Server 分析工具将查询 CIM_Datafile WMI 类，以确定 Msgina.dll 文件的 Version 项值。

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • 服务器运行的是 Windows Server™ 2003 SP1。

  • Msgina.dll 文件的内部版本号低于 5.2.3790.2525。

此错误指示服务器上安装的 Msgina.dll 版本可能会导致页面文件产生过多的活动，并可能导致性能下降。

若要解决此问题，请参考 Microsoft 知识库文章 905865"The sizes of the working sets of all the processes in a console session may be trimmed when you use Terminal Services to log on to or log off from a computer that is running Windows Server 2003"（使用终端服务登录或注销运行 Windows Server 2003 的计算机时，可能会剪裁掉控制台会话中所有进程的工作集大小）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905865)来获取更新。


MTA APDU logging required 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定其当前值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\APDU logging required

如果 Exchange Server 分析工具发现 APDU logging required 的值存在并设置为 0 以外的任意值，则会显示非默认配置消息。

应用程序协议数据单元 (APDU) 文本日志是不同站点中的 Exchange 邮件传输代理 (MTA) 之间以及某个站点内的 MTA 与客户端应用程序之间的通信的二进制表示法。APDU 日志可以用于诊断 MTA 所出现的问题。但是，它们仅仅对熟悉 X.400 协议的 ASCII 转换的人有价值。

当 APDU logging required 注册表参数存在并配置为 0 时，MTA 发送或接收的所有 APDU 都以二进制数据的形式记录到 MTADATA\BF*.LOG 中。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何编辑注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原为默认的 MTA APDU 日志记录配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右侧窗格中，找到并双击"APDU logging required"值。

  4. 在"数值数据"字段中，输入 0，然后单击"确定"。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange MTA Stacks 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 APDU 日志的详细信息，请参阅知识库文章 163324"XCON:Application Protocol Data Unit (APDU) Logs (BF0.LOG)"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=163324)。


MTA Call-stack diagnostics required 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定其当前值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Call-stack diagnostics required

如果 Exchange Server 分析工具发现 Call-stack diagnostics required 的值存在并设置为 1 以外的任何值，则显示非默认配置消息。

Call-stack diagnostics required 注册表值仅用于高级调试目的，并且只能被邮件传输代理 (MTA) 的调试版本读取。它的数值数据应当总是设置为 1。使用 MTA 的调试版本时，该值在终止时为每个 MTA 线程提供调用堆栈。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

更正此错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右侧窗格中，找到并双击 Call-stack diagnostics required 值。

  4. 在"数值数据"字段中，输入 1，然后单击"确定"。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange MTA Stacks 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请阅读 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


MTA Computer 与 name 不匹配
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定邮件传输代理 (MTA) Computer 值的设置：HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定每个 Exchange 服务器对象的 name 属性值。

最后，Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定群集服务 (ClusSvc) 的 Started 项的值。值为 True 意味着群集服务已启动，值为 False 意味着群集服务未运行。

如果 Exchange Server 分析工具发现 MTA Computer 项的值与未在 Windows Server 群集中运行的任何 Exchange Server 计算机的 Active Directory 中服务器对象的 name 属性值不匹配，则显示错误。

若要更正此错误，必须编辑 MTA Computer 注册表项，以便与 Active Directory 中的 name 属性值匹配。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何编辑注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

更正此错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右侧窗格中，双击"MTA Computer"，输入此计算机的正确名称，再单击"确定"。

  4. 关闭注册表编辑器，并重新启动 Exchange Server 计算机，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


MTA Concurrent connections to LAN-MTAs 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定其当前值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent connections to LAN-MTAs

如果 Exchange Server 分析工具发现 Concurrent connections to LAN-MTAs 的值存在并已设置为 0x28（十六进制）或 40（十进制）以外的其他任何值，则显示非默认配置消息。

Concurrent connections to LAN-MTAs 注册表值确定通过局域网 (LAN) 与邮件传输代理 (MTA) 的最大并发连接数。通过 LAN 进行通信的 MTA 称为 LAN-MTA。本地 MTA 可能与远程 MTA 有多个连接，具体取决于它的配置和系统负载。基于 LAN 的最大并发 MTA 连接数是 240。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认的 MTA 并发连接配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右侧窗格中，找到并双击 Concurrent connections to LAN-MTAs 值。

  4. 确保"基数"设置为十六进制，并在"值数据"字段中，输入 28，再单击"确定"。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange MTA Stacks 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关基于 LAN 的并发 MTA 连接数最大值的详细信息，请参阅知识库文章 243402"XCON:Exchange Server MTA Event ID 9280"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=243402)。


MTA Concurrent connections to X.400 gateways 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定其当前值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent connections to X.400 gateways

如果 Exchange Server 分析工具发现 Concurrent connections to X.400 gateways 的值存在并设置为 6 以外的任意值，则显示非默认配置消息。

Concurrent connections to X.400 gateways 注册表值是与远程 X.400 邮件传输代理 (MTA) 的并发连接的最大数目。默认值 6 对于大多数组织已足够。当在运行 Exchange Server 5.5 版的服务器上使用 4 个以上的 EDK Connector 时，存在一个已知的问题。要解决此问题，必须将 Concurrent connections to X.400 gateways 的值提高到 0x12（十六进制）或 18（十进制）。有关此问题的详细信息，请参阅 Microsoft 知识库文章 282115"If more than 4 Exchange EDK connectors are installed, mail flow stops"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=282115)。除非遇到了该文章所介绍的问题，否则应将 Concurrent connections to X.400 gateways 注册表值保持在 6。

若要更正此问题，请恢复到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右侧窗格中，找到并双击"Concurrent connections to X.400 gateways"值。

  4. 在"数值数据"字段中，输入 6，然后单击"确定"。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange MTA Stacks 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


MTA Concurrent MDB/delivery queue clients 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定其当前值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent MDB/delivery queue clients

如果 Exchange Server 分析工具发现 Concurrent MDB/delivery queue clients 的值存在并设置为 3 以外的任何值，则会显示非默认配置消息。

Concurrent MDB/delivery queue clients 值是邮件传输代理 (MTA) 可以支持的邮件数据库 (MDB) 和 Exchange API 邮件访问传递队列客户端的最大数目。每个客户端都可以有多个会话。该值应当至少设置为 2，以便支持专用和公用的 MDB 实体。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

更正此错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右侧窗格中，找到并双击 Concurrent MDB/delivery queue clients 值。

  4. 在"数值数据"字段中，输入 3，然后单击"确定"。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange MTA Stacks 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


MTA 数据文件正在写入压缩文件夹
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 类，以确定邮件传输代理 (MTA) 数据路径的 Compressed 关键字的值。如果 Exchange Server 分析工具确定 Compressed 关键字的值为 True，则显示错误。

Microsoft 不支持在 NTFS 文件系统压缩卷上存储 Exchange 数据文件。在压缩卷上存储 Exchange 数据文件时，额外的开销会极大地影响 Exchange 性能。此外，Exchange 存储数据库在达到某个大小（大约 4 GB）之后，则可能始终无法装入，或者会被损坏。

Exchange 数据文件包括所有下列文件：

  • .edb 文件

  • .stm 文件

  • .log 文件

  • .dat 文件

  • .eml 文件

  • .chk 文件

由可扩展存储引擎 (ESE) 管理的文件的设计初衷是不能存储在压缩驱动器上。ESE 依赖于扇区独立性来进行基于日志的恢复，而压缩文件会使扇区独立性无效。如果卷驻留了 ESE 数据库或驻留了使用提前写入日志记录方式的任何数据库，则不应当打开该卷的压缩功能。

在 Exchange 2000 Server Service Pack 3 之前，能够装入经过压缩的 Exchange 存储数据库。但是，已使用 NTFS 压缩功能进行压缩的任何 Exchange 2000 Exchange 存储数据库或日志都可以导致文件被破坏。

如果使用 Exchange 2000 Server Service Pack 3，将自动对 128 MB 或更小的压缩信息存储数据库文件进行解压缩。数据库文件增长到大于 128 MB 时，数据库将无法装入，并在应用程序日志中生成错误消息。Exchange 2000 Server Service Pack 3 禁止装入大于 128 MB 的压缩数据库。

关闭指定文件夹的文件压缩

  1. 用鼠标右键单击想要关闭文件压缩的文件夹，再单击"属性"。

  2. 在"常规"选项卡上，单击"高级"。

  3. 在"高级属性"对话框中，清除"压缩内容以便节省磁盘空间"复选框，再单击"确定"。

移动 MTA 数据库文件的位置

  1. 在 Exchange Server 5.5 版上，可以使用性能优化工具移动 MTA 数据库文件。有关在 Exchange 2000 Server 和 Exchange Server 2003 中如何执行此操作的详细信息，请参阅 Microsoft 知识库文章 259896"XCON:How to Change the Location of the MTA Database and Run Directory"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=259896)。

有关 Exchange 数据文件和 NTFS 压缩的详细信息，请参阅下列 Microsoft 知识库文章：

  • 170009"XADM:NTFS Compressed Volume Causes Store to Fail"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=170009)

  • 327772"XADM:Database Does Not Mount and You Receive Error 0xfffff05b After You Apply SP3"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=327772)


MTA 数据文件正在写入加密文件夹
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-17

Microsoft® Exchange Server 分析工具查询 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 类，以确定邮件传输代理 (MTA) 数据路径的 Encrypted 关键字的值。如果 Exchange Server 分析工具发现该关键字的值是 True，则会显示错误。

在 Exchange 2000 Server 或 Exchange Server 2003 计算机上，MTA 文件被写入下列默认位置：

<drive> :\Program Files\Exchsrvr\MTAdata

Microsoft 不支持在以加密文件系统 (EFS) 方式加密的卷上存储 Exchange 数据文件。如果将 Exchange 数据文件存储在加密卷上，则额外的开销会极大地影响 Exchange 性能。Exchange 数据文件包括下列所有文件：

  • .edb 文件

  • .stm 文件

  • .log 文件

  • .dat 文件

  • .eml 文件

  • .chk 文件

为帮助确保 Exchange 数据文件的安全性，建议禁止对 Exchange 计算机的未经授权访问，并使用 S/MIME 邮件格式加密邮件数据。

关闭指定文件夹的文件加密功能

  1. 右键单击想要关闭文件加密的文件夹，再单击"属性"。

  2. 在"常规"选项卡上，单击"高级"。

  3. 在"高级属性"对话框中，清除"加密内容以便保护数据"复选框，再单击"确定"。

有关 Exchange Server 数据文件和 EFS 的详细信息，请参阅 Microsoft 知识库文章 834638"Information about the storage of data files on an encrypted volume in Exchange Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638)。

有关在 Microsoft Exchange Server 2003 中如何保护邮件安全的信息，请参阅"Exchange Server 2003 邮件安全指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=2305405C-FAF1-488A-A856-AD467BB59B26&DisplayLang=zh-cn)。


MTA 数据文件正在写入非 NTFS 分区
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-17

Microsoft® Exchange Server 分析工具查询 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange 邮件传输代理 (MTA) 数据文件夹的 FSName 关键字的值。如果 Exchange Server 分析工具确定 FSName 关键字的值不等于 NTFS，则显示错误。

Microsoft 不支持将 Exchange 数据文件存储在非 NTFS 卷上。Exchange 数据文件包括所有下列文件：

  • .edb 文件

  • .stm 文件

  • .log 文件

  • .dat 文件

  • .eml 文件

  • .chk 文件

如果遇到该错误，则必须将 MTA 数据文件夹移动到 NTFS 驱动器上。另外，如果用于存储 MTA 数据文件夹的驱动器被格式化为文件分配表 (FAT) 分区，可以使用 convert.exe 命令行工具将该驱动器转换为 NTFS。

移动 Exchange mtadata 文件夹

  1. 打开 Exchange 系统管理器。

  2. 展开"管理组"，再展开您的管理组，再展开"服务器"，右键单击您的存储组，再单击"属性"。

  3. 在存储组属性页的"系统路径位置"字段的旁边，单击"浏览"。

  4. 键入 mtadata 文件夹的新路径，再单击"确定"。

  5. 单击"确定"。

作为上述过程的替代方案，如果存储文件的驱动器格式化为 FAT 驱动器，可以使用 convert.exe 命令行工具将该驱动器转换为 NTFS。有关使用 convert.exe 命令行工具将 FAT 分区转换为 NTFS 分区的详细信息，请参阅 Microsoft 知识库文章 214579"How to Use Convert.exe to Convert a Partition to the NTFS File System"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579)。


MTA DB data buffers per object 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定其当前值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\DB data buffers per object

如果 Exchange Server 分析工具发现 DB data buffers per object 的值存在并且为大于零但不等于 3 或 6 的任意值，则会显示非默认配置消息。

DB data buffers per object value 是为每个数据库对象配置的 4 KB 数据库服务器缓冲区的数目。缓冲区越多，需要的内存越多，但会减小当缺少缓冲区空间时数据库对象转出到磁盘的可能性。如果邮件传输代理 (MTA) 与一个或多个站点中的多台 Exchange Server 5.5 版计算机通信，建议更改该值，并建议将该值更改为 6。如果此 MTA 不满足此条件，应将值改回默认设置 3。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右侧窗格中，找到并双击"DB data buffers per object" 值。

  4. 在"数值数据"字段中，输入 3，然后单击"确定"。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange MTA Stacks 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


MTA DB file handles 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定其当前值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\DB file handles

如果 Exchange Server 分析工具发现 DB file handles 的值存在并已设置为 192 以外的任何值，则会显示非默认配置消息。

DB file handles 值是通过配置产生的数据库服务器文件句柄的个数。它确定了可以并发打开的最大数据库文件数。如果需要打开比所配置的值更多的文件，则数据库对象将复制到磁盘。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

更正此错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右侧窗格中，找到并双击 DB file handles 值。

  4. 在"数值数据"字段中，输入 192，然后单击"确定"。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange MTA Stacks 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


MTA 诊断日志记录级别大于 5 （MTA 处于调试模式）
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取一系列注册表项，以确定在 Exchange 服务器上设置的邮件传输代理 (MTA) 诊断日志记录级别。该注册表项驻留于：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Diagnostics

这些项的默认值是 0。如果 Exchange Server 分析工具发现其中任一项的值大于 5，则会显示错误。

当您在特定服务器的属性页的"诊断日志记录"选项卡上调整日志记录级别时，Exchange 系统管理器将设置这些注册表项。Exchange 系统管理器允许管理员设置指定的日志记录级别："无"、"最低"、"中等"和"最高"。注册表项的相应值分别是 0、1、3 或 5。

因此，只能通过手动编辑注册表来设置大于 5 的值，并且只应当在非高峰时段设置这样的级别，以便进行非常短的调试和故障排除。将这些项设置为大于 5 的整数将使日志记录调高到调试级别，该级别非常耗费资源。除调试级别的日志记录以外，如果将这些项设置为大于 5，将会每几秒就输出一个大小约为 40 MB 的"call.out"调试跟踪文件。这会在不到一分钟内填满计算机的事件日志。

下表显示了在 Exchange 系统管理器的"诊断日志记录"选项卡上列出的 MTA 日志记录类别，及其在注册表中的对应项名称。

显示在 Exchange 系统管理器中的类别 | 对应的注册表项名称
X.400 服务 | 1 X.400 Service
资源 | 2 Resource
安全性 | 3 Security
接口 | 4 Interface
字段工程 | 5 Field Engineering
MTA 管理 | 6 MTA Administration
配置 | 7 Configuration
目录访问 | 8 Directory Access
操作系统 | 9 Operating System
内部处理 | 10 Internal Processing
互操作性 | 11 Interoperability
APDU（应用程序协议数据单元） | 12 APDU

本文末尾的参考材料提供了有关每个 MTA 类别日志的详细信息。

除非您在进行故障排除，否则建议将每个 MTA 类别的日志记录设置为"无"(0)。该建议的理由是为了让所记录的事件数保持在可管理的范围内。甚至级别为"最低"(1) 也有可能在几天后产生数百个事件日志（取决于设置了级别的类别）。

如果当前未在进行故障排除，很可能会在故障排除期间将这些值设置得较高，并无意中保留了该设置。必须至少将这些值设置为"最高"(5)，但是，除非您在进行故障排除，否则应考虑将每个 MTA 诊断日志记录类别的日志记录级别设置为"无"(0)。

将 MTA 诊断日志记录类别设置为"无"

  1. 启动 Exchange 系统管理器：单击"开始"，指向"所有程序"，指向"Microsoft Exchange"，再单击"系统管理器"。

  2. 在控制台树中，展开"服务器"，展开所需的服务器，再单击"属性"。

  3. 在"<Server>属性"上，单击"诊断日志记录"。

  4. 在"服务"下，单击 MSExchangeMTA。

  5. 对"类别"下的每一项，通过选择类别，再在"日志记录级别"下选择"无"，将日志记录级别设置为"无"。

  6. 将所有类别设置为"无"后，单击"应用"，再单击"确定"。

有关在 Exchange 2000 Server 和 Exchange Server 2003 中的 MTA 诊断日志记录的详细信息，请参阅 Microsoft 知识库文章 163033"XCON:Description of Diagnostics Categories for MTA"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163033)。

有关在 Exchange Server 5.5 版中的 MTA 诊断日志记录的详细信息，请参阅知识库文章 163032"XCON:Description of Diagnostics Logging for MTA"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163032)。


MTA 诊断日志记录级别为非零值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取一系列注册表项，以确定 Exchange 服务器中设置的邮件传输代理 (MTA) 诊断日志记录的级别。该注册表项位于：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Diagnostics

这些项的默认值是 0。如果 Exchange Server 分析工具发现其中任意项的值大于 1 但小于 6，则会显示非默认配置消息。

当在指定服务器的属性页的"诊断日志记录"选项卡上调整日志记录级别时，这些注册表项将由 Exchange 系统管理器设置。管理员可以使用 Exchange 系统管理器将指定的日志记录级别设置为"无"、"最低"、"中等"和"最高"。注册表项的对应值分别为 0、1、3 或 5。

下表显示了在 Exchange 系统管理器的"诊断日志记录"选项卡上列出的 MTA 日志记录类别，及其在注册表中的对应项名称。

显示在 Exchange 系统管理器中的类别 | 对应的注册表项名称
X.400 服务 | 1 X.400 Service
资源 | 2 Resource
安全性 | 3 Security
接口 | 4 Interface
字段工程 | 5 Field Engineering
MTA 管理 | 6 MTA Administration
配置 | 7 Configuration
目录访问 | 8 Directory Access
操作系统 | 9 Operating System
内部处理 | 10 Internal Processing
互操作性 | 11 Interoperability
APDU（应用程序协议数据单元） | 12 APDU

本文末尾的参考材料提供了有关每个 MTA 类别日志的详细信息。

除非您要进行排除故障，否则，关于诊断日志记录，通常的最佳实践是将每个 MTA 类别的日志记录设置为"无"(0)。该建议的理由是为了让所记录的事件数保持在可管理的范围内。甚至级别为"最低"(1) 也有可能在几天后产生数百个事件日志（取决于设置了级别的类别）。

如果当前未进行故障排除，则较高的值很可能是在故障排除期间设置的，并在无意中保留了下来。应考虑将每个 MTA 诊断日志记录类别的日志记录级别设置为"无"(0)。

在 Exchange Server 2003 或 Exchange 2000 Server 上更正此错误

  1. 打开 Exchange 系统管理器。

  2. 在控制台树中，展开"服务器"，展开所需的服务器，再单击"属性"。

  3. 在"<Server> 属性"上，单击"诊断日志记录"选项卡。

  4. 在"服务"下，选择"MSExchangeMTA"。

  5. 对"类别"下的每一项，通过选择类别，再在"日志记录级别"下选择"无"，将日志记录级别设置为"无"。

  6. 将所有类别设置为"无"后，单击"应用"，再单击"确定"。

在 Exchange Server 5.5 版上更正此错误

  1. 启动 Microsoft Exchange Server Administrator 程序。

  2. 打开代表 MTA 出现问题的服务器的对象。

  3. 在右侧窗格中，双击"Message Transfer Agent"对象。

  4. 在"Diagnostics Logging"选项卡上，选择"X.400 Service"，然后单击"Maximum"。

  5. 选择"Resource"。

  6. 按住 CTRL 键，然后单击要调试的每个资源。

  7. 单击与"None"日志记录级别对应的选项。

  8. 单击"OK"。

有关在 Exchange 2000 Server 中的 MTA 诊断日志记录的详细信息，请参阅 Microsoft 知识库文章 163033"XCON:Description of Diagnostics Categories for MTA"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163033)。

有关 Exchange Server 5.5 中回滚高级日志记录的详细信息，请参阅知识库文章 168906"XCON:Setting up Advanced Logging on the Exchange 5.0 and 5.5 MTAs"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168906)。

有关 Exchange Server 5.5 中的 MTA 诊断日志记录的详细信息，请参阅知识库文章 163032"XCON:Description of Diagnostics Categories for MTA"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163032)。


MTA Dispatcher threads 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

错误消息

简介

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定其当前值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Dispatcher threads

如果 Exchange Server 分析工具发现 Dispatcher threads 的值存在并且大于零，但设置为 1 或 2 以外的任意值，则显示非默认配置消息。

Dispatcher threads 值是邮件传输代理 (MTA) 发送器线程的个数。对于发送器线程的三个子类型（路由器、扇出、结果），此值应乘以三。更改该值的一个建议理由是，如果 MTA 与站点内或站点间的五个以上 Exchange Server 5.5 版计算机通信，或者如果过度使用通讯组列表。在这种情况下，建议您将该值更改为 3。如果此 MTA 不满足该条件，则应当将它的值更改回默认设置 1。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右侧窗格中，找到并双击 Dispatcher threads 值。

  4. 在"数值数据"字段中，输入 1，然后单击"确定"。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange MTA Stacks 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


MTA 未在 LocalSystem 帐户下运行
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Microsoft Exchange MTA Stacks 服务的 StartName 关键字的值集。Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定目录中 Exchange Server 对象的 serialNumber 属性值。Exchange Server 对象的 serialNumber 属性标识了运行在该对象所代表的计算机上的 Exchange Server 的版本。在运行 Exchange 2000 Server 或 Exchange Server 2003 的 Exchange 服务器上，如果 StartName 关键字的值不等于 LocalSystem，则会显示错误。

在任何其他帐户下运行 Exchange MTA Stacks 服务将导致权限和访问错误，并且不是受支持的配置。

若要解决该错误，必须将 Exchange MTA Stacks 服务配置为在 LocalSystem (aks SYSTEM) 帐户下启动。

注意：
该错误不适用于 Exchange Server 5.5 版。只有 Exchange 2000 Server 和 Exchange Server 2003 要求 Exchange MTA Stacks 服务在 LocalSystem 帐户下运行。

配置 Exchange MTA Stacks 服务帐户

  1. 打开"服务"Microsoft 管理控制台 (MMC) 管理单元。

  2. 找到并停止 Microsoft Exchange MTA Stacks 服务。

  3. 双击 Microsoft Exchange MTA Stacks 服务。

  4. 在"Microsoft Exchange MTA Stacks 的属性"页的"登录"选项卡上，在"登录身份"下选择"本地系统帐户" ，再单击"应用"。

  5. 在"服务状态"下，单击"启动"，再单击"确定"。

  6. 关闭"服务"管理单元。

有关在 LocalSystem 帐户下运行 Exchange 服务的详细信息，请参阅 Microsoft 知识库文章 239762"Exchange Services Run Under LocalSystem"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)。


MTA Kernel threads 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定其当前值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Kernel threads

如果 Exchange Server 分析工具发现 Kernel threads 的值存在，并且为大于 0 但不等于 1 或 3 的任意值，则会显示非默认配置消息。

Kernel threads 值是处理开放系统互连 (OSI) 堆栈的表示层和会话层的平台线程数。这些线程是邮件传输代理 (MTA) 邮件处理的核心。如果此 MTA 使用远程过程调用 (RPC) 并通过速度很慢或延迟时间非常长的网络连接与其他许多 Exchange Server 5.5 版服务器通信，则建议使用下表中列出的值。

值 | 描述
0x3（十六进制） | 标准推荐。对使用 RPC 并通过速度很慢或延迟时间非常长的网络连接与其他 Exchange Server 5.5 服务器通信的任何 MTA 使用该值。
0x8（十六进制） | 对属于包含 15 台以上 Exchange Server 5.5 计算机的站点的 Exchange 2000 Server 或 Exchange Server 2003 MTA 使用该值。
0xC（十六进制） | 对属于包含 30 台以上 Exchange Server 5.5 计算机的站点的 Exchange 2000 Server 或 Exchange Server 2003 MTA 使用该值。
重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何编辑注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

配置 Kernel threads 值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右侧窗格中，找到并双击"Kernel threads"值。

  4. 在"数值数据"字段中，输入适合于您组织的值，再单击"确定"。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange MTA Stacks 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


MTA LAN-MTAs 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定其当前值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\LAN-MTAs

如果 Exchange Server 分析工具发现 LAN-MTAs 的值存在并设置为 20 以外的任意值，则显示非默认配置消息。

LAN-MTAs 值是 MTA 可以支持的网络邮件传输代理 (MTA) 的个数。建议该注册表值为 20。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右侧窗格中，找到并双击 LAN-MTAs 值。

  4. 在"数值数据"字段中，输入 20，然后单击"确定"。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange MTA Stacks 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


MTA MDB users 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定其当前值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\MDB users

如果 Exchange Server 分析工具发现 MDB users 的值存在并设置为 500 以外的任意值，则显示非默认配置消息。

MDB users 值是邮件传输代理 (MTA) 所支持的最大邮件数据库 (MDB) 用户数。默认情况下，所有 Exchange Server 用户都是 MDB 用户，除非将他们显式设置为不是。

MDB users 注册表值定义了要从目录中缓存的可分辨名称的数目。如果组织包含超过 1500 个用户，则应当将该值更改为全局地址列表大小的三分之一，但不超过最大值 5000。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

更正此错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右侧窗格中，找到并双击 MDB users 值。

  4. 在"数值数据"字段中，输入 500，然后单击"确定"。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange MTA Stacks 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


MTA Max RPC calls outstanding 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定其当前值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Max RPC Calls Outstanding

如果 Exchange Server 分析工具发现 Max RPC Calls Outstanding 的值存在并已设置为 50 以外的任何值，则会显示非默认配置消息。

Max RPC Calls Outstanding 值是最大远程过程调用 (RPC) 线程数。它限制保证会同时被处理的最大 RPC 数。该值被 RpcServerUseAllProtSeqs() 和 RpcServerListen() 使用。

如果 Exchange 2000 Server 和/或 Exchange Server 2003 与 Exchange Server 5.5 版计算机共存，并且您已经增加了 Store.exe 进程中的网关进/出线程数，在这样的混合情形中，建议您将该数值数据增加为 0x80（十六进制）或 128（十进制）。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右侧窗格中，找到并双击 Max RPC Calls Outstanding 值。

  4. 在"数值数据"字段中，输入 50，然后单击"确定"。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange MTA Stacks 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


MTA Min RPC threads 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

错误消息

简介

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定其当前值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Min RPC Threads

如果 Exchange Server 分析工具发现 Min RPC Threads 的值存在并设置为 4 以外的任意值，则显示非默认配置消息。

Min RPC Threads 值是最小远程过程调用 (RPC) 线程数。该值用于标识最小调用线程数。该值由 RpcServerListen() 使用。通常，不应当将该注册表值从其默认设置修改为其他值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

更正此错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右侧窗格中，找到并双击 Min RPC Threads 值。

  4. 在"数值数据"字段中，输入 4，然后单击"确定"。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange MTA Stacks 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


MTA RTS threads 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定其当前值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\RTS threads

如果 Exchange Server 分析工具发现 RTS threads 的值存在并且大于 0，但被设置为 1 或 3 以外的任何值，则会显示非默认配置消息。

RTS threads 值是用于处理开放式系统互联 (OSI) 堆栈的可靠传输服务元素 (RTSE) 级别的平台线程的个数。RTS 线程负责将数据放在队列中。如果该邮件传输代理 (MTA) 与站点中或站点间的多个 Exchange Server 5.5 版计算机通信，则应当将 RTS threads 注册表值从默认值 1 调整为 3。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

优化 RTS 线程注册表值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右侧窗格中，找到并双击 RTS threads 值。

  4. 在"数值数据"字段中，输入合适的值（1 或 3），并单击"确定"。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange MTA Stacks 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


MTA 服务未运行
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-02-19

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定是否将下列服务的 Started 关键字的值集设置为 True 或 False：

  • Microsoft Exchange MTA Stacks 服务

  • 群集服务

值为 False 说明该服务未运行在此 Exchange Server 计算机上。值为 True 说明该服务正在运行。

Exchange Server 分析工具还检查 root\MicrosoftExchangeV2 命名空间中的 Exchange_Server WMI 类，以确定 IsFrontEndServer 关键字的值。值为 False 说明 Exchange Server 计算机不是前端服务器。值为 True 说明 Exchange Server 计算机是前端服务器。

如果所评估的三个关键字的值均为 False，则会显示警告。

建议在路由邮件的所有 Exchange Server 计算机上都启动 Exchange MTA Stacks 服务。对于混合模式环境而言，这一点尤其重要。在混合模式环境中，邮件在 Exchange Server 5.5 版与 Exchange Server 2003 和/或 Exchange 2000 Server 之间传输。另外，任何 X.400 连接器都需要 Exchange MTA Stacks 服务，因此，禁用该服务将产生错误，并且功能可能失败。移动邮箱时也必须启动 Exchange MTA Stacks 服务。

若要解决此警告指明的问题，请启动 Exchange MTA Stacks 服务。

启动 Exchange MTA Stacks 服务

  1. 在"开始"菜单中，依次选择"程序"、"管理工具"、"服务"Microsoft 管理控制台 (MMC) 管理单元。

  2. 用鼠标右键单击"Microsoft Exchange MTA Stacks"服务，再单击"属性"。

  3. 在 Microsoft Exchange MTA Stacks 属性页的"常规"选项卡上，确保"启动类型"设置为"自动"。如果不是，请单击"应用"，再单击"确定"。

  4. 用鼠标右键单击"Microsoft Exchange MTA Stacks"服务，再单击"启动"。

  5. 关闭"服务"管理单元。

有关在混合模式 Exchange 环境中使 Exchange MTA Stacks 服务保持运行的详细信息，请参阅 Microsoft 知识库文章 810489"MTA Stacks Service Must Remain Enabled on Exchange 2000 and 2003"（在 Exchange 2000 和 2003 中，MTA 堆栈服务必须保持为启用）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810489)。


MTA 服务被设置为已禁用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定为 Microsoft Exchange MTA Stacks 服务 StartMode 关键字所设置的值。值为 Disabled 说明 Exchange MTA Stacks 服务已被禁用，并且不能启动，直到 StartMode 值更改为 Manual 或 Automatic。

Exchange Server 分析工具还查询 Win32_Service WMI 类，以确定简单邮件传输协议 (SMTP) 服务的 Started 关键字的值。值为 False 说明服务未运行。值为 True 说明服务正在运行。

最后，Exchange Server 分析工具查询 Win32_OperatingSystem WMI 类，以确定 OSProductSuite 关键字的值。该关键字的值对应于 Microsoft Windows Server™ 2003 操作系统的特定版本。

如果 Exchange Server 分析工具发现，在已经启动 SMTP 服务的 Exchange Server 计算机上 StartMode 关键字的值被设置为 Disabled，并且该 Exchange Server 计算机不是 Microsoft Windows Small Business Server 2003 安装的一部分，则会显示警告。

除非该服务器是 Microsoft Windows Small Business Server 2003 安装的一部分，或者是在纯 Exchange Server 2003 纯模式环境中，否则，所有执行邮件路由的 Exchange Server 计算机都必须将 Exchange MTA Stacks 服务设置为"自动"。在禁用 Exchange MTA Stacks 服务的服务器上执行邮件路由可能产生多种错误消息。在某些情况下，如果您正在那些仍然有 Exchange Server 5.5 运行的 Exchange 2000 Server 或 Exchange Server 2003 环境中运行，将会在日志中记录下错误。另外，任何 X.400 连接器都需要 Exchange MTA Stacks 服务，因此，禁用该服务将产生错误，并且功能可能失败。

注意：
除了与外部 X.400 邮件系统的直接连接或运行 Exchange 开发工具包 (EDK) 连接器（如 Novell GroupWise 连接器、Lotus Notes 连接器或第三方传真连接器），Exchange Server 2003 中删除了其他依赖 MTA Stacks 服务的项。因此，Microsoft 现在支持禁用 MTA Stacks 服务的纯模式的纯 Exchange Server 2003 部署。

若要解决该错误，必须在执行邮件路由的服务器上将 Exchange MTA Stacks 服务配置为自动启动。

将 Exchange MTA Stacks 服务配置为自动启动

  1. 打开"服务"Microsoft 管理控制台 (MMC) 管理单元。

  2. 双击 Microsoft Exchange MTA Stacks 服务。

  3. 在"Microsoft Exchange MTA Stacks 的属性"页的"常规" 选项卡上，从"启动类型"下拉对话框中选择"自动"，再单击"应用"。

  4. 在"服务状态"下，单击"启动"，再单击"确定"。

  5. 关闭"服务"管理单元。

有关在 Exchange 中使 Exchange MTA Stacks 服务保持运行的详细信息，请参阅 Microsoft 知识库文章 810489"MTA Stacks service supportability guidelines for Exchange 2000 Server and Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810489)。


MTA Submit/deliver threads 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定其当前值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\ Submit/deliver threads

如果 Exchange Server 分析工具发现 Submit/deliver threads 的值存在并设置为 2 以外的任意值，则显示非默认配置消息。

Submit/deliver threads 值是邮件传输代理 (MTA) Submit/Deliver 线程的数目。MTA 使用这些线程将邮件传递到信息存储。在某些 Exchange Server 5.5 计算机上，该值可能被 Exchange 性能优化程序从它的默认值 2 自动更改为更适合于 Exchange 服务器的值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何编辑注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

回复到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右侧窗格中，找到并双击 Submit/deliver threads 值。

  4. 在"数值数据"字段中，确保输入的值为 2，再单击"确定"。

  5. 退出注册表编辑器，并重新启动 Microsoft Exchange MTA Stacks 服务，以使更改生效。

在 Exchange 2000 Server 和 Exchange Server 2003 计算机上，应当将该项的值设置为不大于 3 的值。对于 Exchange Server 5.5 计算机，如果不采取上述步骤，可以在详细模式中运行 Exchange 性能优化程序 (perfwiz.exe -v)，并使用该工具设置值。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 MTA Submit/deliver threads 注册表值应当从其默认值改变为其他值这一情况的详细信息，请参阅下列知识库文章：

  • 234280"XCON:How to Increase the Ability of the MTA to Pass Mail over Slow Network Connections"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=234280)

  • 265186"XCON:MTA Fanout Slows on Multiprocessor Servers and Messages Back Up in Information Store"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=265186)

  • 234702"XGEN:MTA Queue to Information Store Processing Slowly"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=234702)

  • 327260"MTA 在 Exchange Server 5.5 中降低速度或停止，邮件在专用信息存储中积压"(http://support.microsoft.com/?kbid=327260)

  • 有关在详细模式下使用 Exchange 性能优化程序的详细信息，请参阅知识库文章 246125"XADM:Exchange Server 5.5 Performance Optimizer Verbose Mode"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246125)。


MTA TCP/IP control blocks 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

错误消息

简介

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定其当前值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\TCP/IP control blocks

如果 Exchange Server 分析工具发现 TCP/IP control blocks 的值存在并设置为 20 以外的任意值，则会显示非默认配置消息。

TCP/IP control blocks 值是最多支持的并发 RFC1006 (TCP/IP) 连接的数目。此设置控制 X.400 连接可以使用的缓冲区数。如果此邮件传输代理 (MTA) 承载一个以上的 X.400 连接器，则应当调整 TCP/IP control blocks 值。对于所承载的每个 X.400 连接器，都应当有 10 个控制块可用，并有一个控制块处理传入连接。因此，对于具有三个 X.400 连接的系统而言，适合的值为 33。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

配置 TCP/IP control blocks 值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右侧窗格中，找到并双击"TCP/IP control blocks"值。

  4. 在"数值数据"字段中，输入适合于此 MTA 的值，再单击"确定"。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange MTA Stacks 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


MTA TCP/IP threads 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

错误消息

简介

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定其当前值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\TCP/IP threads

如果 Exchange Server 分析工具发现 TCP/IP threads 的值存在并设置为 2 以外的任何值，则显示非默认配置消息。

TCP/IP threads 值是用于处理 RFC1006 连接的邮件传输代理 (MTA) 动态地址模块 (DMOD) 线程的最大数目。对于 RFC1006 线程的两个子类型（Driver 和 Async Notify），该数字要乘以 2。在需要处理大量连接的 X.400 目录复制桥头服务器和专用的公用文件夹服务器上，建议您将该值从它的默认值 2 修改为 10。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何编辑注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

配置 TCP/IP threads 值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右侧窗格中，找到并双击 TCP/IP threads 值。

  4. 在"数值数据"字段中，输入合适的值，并单击"确定"。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange MTA Stacks 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


MTA 传输线程参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

错误消息

简介

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定其当前值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Transfer threads

如果 Exchange Server 分析工具发现 Transfer threads 的值存在，并且为大于 0 但不等于 1 或 2 的任意值，则会显示非默认配置消息。

Transfer threads 值是邮件传输代理 (MTA) 传输线程的个数。对于每个传输线程的两个子类型（Transfer In 和 Transfer Out），该值应乘以二。这等价于"提交/传递线程数"值（该值与 MTA 和信息存储邮件传输相关），但用于网关和 MTA。有关"提交/传递线程"值的详细信息，请参阅MTA Submit/deliver threads 参数为非默认值。

如果这是与站点内或站点间的多个 Exchange Server 5.5 版计算机通信的 Exchange 2000 Server 或 Exchange Server 2003 MTA，则建议您将 Transfer threads 的值调整为 3。

在某些 Exchange Server 5.5 计算机上，该值可能被 Exchange 性能优化程序从它的默认值 2 自动更改为更适合于 Exchange Server 计算机的值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

配置传输线程值

  1. 打开注册表编辑器，例如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右侧窗格中，找到并双击 Transfer threads 值。

  4. 在"数值数据"字段中，输入合适的值，并单击"确定"。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange MTA Stacks 服务，以使更改生效。

在 Exchange 2000 Server 和 Exchange Server 2003 计算机上，应当将该项的值设置为不大于 3 的值。作为上述过程的可替代方案，可以在详细模式中运行 Exchange 性能优化程序 (perfwiz.exe -v)，并使用该工具设置值。

编辑注册表之前，要获取有关如何编辑注册表的信息，请阅读 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 MTA Transfer threads 注册表值应当从其默认值改变为其他值这一情况的详细信息，请参阅下列知识库文章：

  • 234280"XCON:How to Increase the Ability of the MTA to Pass Mail over Slow Network Connections"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=234280)

  • 265186"XCON:MTA Fanout Slows on Multiprocessor Servers and Messages Back Up in Information Store"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=265186)

  • 327260"MTA 在 Exchange Server 5.5 中降低速度或停止，邮件在专用信息存储中积压"(http://support.microsoft.com/kb/327260/zh-cn)。


MTA Transport threads 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

错误消息

简介

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定其当前值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Transport threads

如果 Exchange Server 分析工具发现 Transport threads 的值存在并设置为 1 以外的任意值，则显示非默认配置消息。

Transport threads 值是邮件传输代理 (MTA) 传输线程的个数。通常，默认值 1 对所有组织就已足够。除非得到 Microsoft 产品支持服务的指导，否则应当将该值设置为 1。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

配置 Transport threads 值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右侧窗格中，找到并双击 Transport threads 值。

  4. 在"数值数据"字段中，输入 1，然后单击"确定"。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange MTA Stacks 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


邮件跟踪已禁用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-06

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务以确定服务器对象的 messageTrackingEnabled 属性是已设置为 TRUE（已启用），还是已设置为 FALSE（已禁用）。

如果 Exchange Server 分析工具确定服务器对象的 messageTrackingEnabled 属性已设置为 False，则 Exchange Server 分析工具会显示一个错误。

服务器对象的 messageTrackingEnabled 属性决定服务器的邮件跟踪中心的状态。

邮件跟踪中心（在已启用时）将记录有关发件人、邮件以及邮件收件人的信息。具体地说，您可以复查统计信息，如发送和接收邮件的时间、邮件大小和优先级以及邮件收件人列表。还可以记录电子邮件的主题行。邮件跟踪中心将搜索各种邮件，如系统邮件、公用文件夹邮件以及电子邮件。

必须在要跟踪其邮件的每一台服务器上启用邮件跟踪中心。启用后，通过服务器路由的所有邮件都将添加到邮件跟踪日志中。

Exchange Server 分析工具要求为其启用邮件跟踪以便启动其扫描。

注意：
执行此步骤需要有下列权限：本地管理员组的成员，以及在管理组级别应用了 Exchange 管理员角色的组的成员
在服务器上启用邮件跟踪中心

  1. 在 Exchange 系统管理器中，展开"服务器"，用鼠标右键单击要启用邮件跟踪的服务器，再单击"属性"。

  2. 在"常规"选项卡上，选中"启用邮件跟踪"复选框。

  3. 若要记录发送到服务器、由服务器发出或经过服务器的任何邮件的主题，请选中"启用主题日志记录和显示"复选框。

    注意：
    如果启用主题日志记录，则可能导致性能方面有一些降低。

  4. 在"日志文件维护"下，可以防止删除日志文件，或修改日志文件所保留的时间长度。跟踪日志的默认保留时间为 7 天。

    注意：
    在处理大量邮件的服务器上，跟踪日志的增长速度很快。应确保有足够的磁盘空间来存放日志文件和供使用该磁盘的其他服务或应用程序使用。

  5. 单击"确定"或"应用"。不需要重新启动服务来使上述更改生效。

有关如何使用邮件跟踪中心的详细信息，请参阅 Microsoft 知识库文章 262162"XADM:Using the Message Tracking Center to Track a Message"（XADM：使用邮件跟踪中心来跟踪邮件）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162)。

有关如何解决 Exchange Server 传输问题的详细信息，请参阅 Microsoft 知识库文章 821910"如何解决 Exchange Server 2003 传输问题"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821910)。


邮件跟踪日志正在写入压缩文件夹
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-17

Microsoft® Exchange Server 分析工具查询 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 类，以确定邮件跟踪日志文件路径的 Compressed 关键字的值。如果 Exchange Server 分析工具确定 Compressed 关键字的值为 True，则显示错误。

在 Exchange 2000 Server 或 Exchange Server 2003 计算机上启用邮件跟踪时，跟踪日志将写入下列默认位置：

<drive> :\Program Files\Exchsrvr\ ServerName .log

其中，<drive> 是包含 \Program Files\Exchsrvr 路径的驱动器，而 ServerName 是 Exchange Server 计算机的主机名称。

Microsoft 不支持将 Exchange 数据文件存储在 NTFS 压缩卷上。如果将 Exchange 数据文件存储在压缩卷上，则额外的开销会极大地影响 Exchange 的性能。此外，信息存储数据库在达到某个大小（大约 4 GB）之后，则可能无法装入，或会被损坏。

Exchange 数据文件包括下列所有文件：

  • .edb 文件

  • .stm 文件

  • .log 文件

  • .dat 文件

  • .eml 文件

  • .chk 文件

由可扩展存储引擎 (ESE) 管理的文件的设计初衷是不能存储在压缩驱动器上。ESE 依赖于扇区独立性来进行基于日志的恢复，而压缩文件会使扇区独立性无效。如果卷驻留了 ESE 数据库或驻留了使用提前写入日志记录方式的任何数据库，则不应当打开该卷的压缩功能。

在 Exchange 2000 Server Service Pack 3 之前，允许装入经过压缩的信息存储数据库。但是，可能会破坏已使用 NTFS 压缩功能进行压缩的任何 Exchange 2000 Server 信息存储数据库或信息存储日志。

如果使用 Exchange 2000 Server Service Pack 3，将自动对 128 MB 或更小的压缩信息存储数据库文件进行解压缩。数据库文件增长到大于 128 MB 时，数据库将无法装入，并在应用程序日志中生成错误消息。Exchange 2000 Server Service Pack 3 禁止装入大于 128 MB 的压缩数据库。

关闭指定文件夹的文件压缩

  1. 右键单击想要关闭文件压缩的文件夹，再单击"属性"。

  2. 在"常规"选项卡上，单击"高级"。

  3. 在"高级属性"对话框中，清除"压缩内容以便节省磁盘空间"复选框，再单击"确定"。

可替代上述过程的另一个做法是，将邮件跟踪日志文件移动到其他非压缩文件夹中。有关移动邮件跟踪日志文件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 84103"How to change the location of the message tracking logs in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=841089)

  • 317700"How to change the location of the message tracking logs in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700)

有关 Exchange 数据文件和 NTFS 压缩的详细信息，请参阅下列知识库文章：

  • 170009"XADM:NTFS Compressed Volume Causes Store to Fail"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=170009)

  • 327772"XADM:Database Does Not Mount and You Receive Error 0xfffff05b After You Apply SP3"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=327772)


邮件跟踪日志正在被写入非 NTFS 分区
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-17

Microsoft® Exchange Server 分析工具查询 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange 邮件跟踪日志文件路径的 FSName 关键字的值。如果 Exchange Server 分析工具确定 FSName 关键字的值不等于 NTFS，则显示错误。

Microsoft 不支持将 Exchange 数据文件存储在非 NTFS 卷上。Exchange 数据文件包括所有下列文件：

  • .edb 文件

  • .stm 文件

  • .log 文件

  • .dat 文件

  • .eml 文件

  • .chk 文件

如果遇到该错误，则必须将邮件跟踪日志移动到 NTFS 驱动器上的文件夹中。或者，如果用于存储邮件跟踪日志的驱动器被格式化为 FAT 驱动器，那么，可以使用 convert.exe 命令行工具将该驱动器转换为 NTFS。

在 Exchange Server 2003 中移动邮件跟踪日志

  1. 打开 Exchange 系统管理器。

  2. 展开"管理组"，再展开您的管理组，再展开"服务器"，右键单击您的服务器，再单击"属性"。

  3. 在"常规"选项卡上，单击"更改"。

  4. 输入邮件跟踪日志的新路径，再单击"确定"。

  5. 单击"确定"。
注意：
默认情况下，对跟踪日志文件位置的修改在协调世界时 (UTC) 的午夜生效。该更改生效之后，Exchange 邮件跟踪组件将在您指定的新位置创建新的日志文件。但是，以前的日志文件不会移动到新位置。因此，请等到新日志文件位置更改已经生效，然后再将日志文件从旧位置手动移动到新的日志文件位置。如果 Microsoft Exchange 系统助理服务重新启动，则日志文件路径将立即更改到新位置。在此情形中，当用户发送邮件时，Exchange 邮件跟踪功能将在新位置创建新的日志文件。在此情形中，可能存在两个同名日志文件：一个日志文件位于原始位置，而另一个日志文件位于指定的新位置。如果发生这种情况，在将存储在原始日志文件位置的日志文件移动到新的日志文件位置之前，请重命名在原始位置的文件。请使用 Exchange 邮件跟踪 (yyyymmdd) 所使用的相同命名约定。但是，在这种情况下，请使用早于任何一个现有日志文件的日期，以便这个重命名的日志文件不会干扰未来的日志文件。

有关在运行 Exchange 2000 Server 的计算机上移动邮件跟踪日志文件的详细信息，请参阅 Microsoft 知识库文章 317700"How to change the location of the message tracking logs in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700)。

作为上述过程的替代方案，如果存储文件的驱动器格式化为 FAT 驱动器，可以使用 convert.exe 命令行工具将该驱动器转换为 NTFS。有关使用 convert.exe 命令行工具将 FAT 分区转换为 NTFS 分区的详细信息，请参阅 Microsoft 知识库文章 214579"How to Use Convert.exe to Convert a Partition to the NTFS File System"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579)。


邮件跟踪日志正被写入加密文件夹
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-17

Microsoft® Exchange Server 分析工具查询 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 类，以确定邮件跟踪日志文件的 Encrypted 关键字的值。如果该关键字的值是 True，则显示错误。

在 Exchange 2000 Server 或 Exchange Server 2003 计算机上启用邮件跟踪时，跟踪日志将写入下列默认位置：

<drive>:\Program Files\Exchsrvr\ ServerName .log

其中，<drive> 是包含 \Program Files\Exchsrvr 路径的驱动器，而 ServerName 是 Exchange Server 计算机的主机名称。

Microsoft 不支持在加密文件系统 (EFS) 的加密卷上存储 Exchange 数据文件。如果在加密卷上存储 Exchange 数据文件，则额外的开销会极大地影响 Exchange 性能。Exchange 数据文件包括所有下列文件：

  • .edb 文件

  • .stm 文件

  • .log 文件

  • .dat 文件

  • .eml 文件

  • .chk 文件

为了确保 Exchange 数据文件的安全，建议您禁止对 Exchange 计算机的未经授权的访问，并使用 S/MIME 邮件格式加密邮件数据。

禁用指定文件夹的文件加密

  1. 右键单击想要关闭其文件压缩的文件夹，再单击"属性"。

  2. 在"常规"选项卡上，单击"高级"。

  3. 在"高级属性"对话框中，清除"加密内容以便保护数据"复选框，再单击"确定"。

可替代上述过程的另一个做法是，可以将邮件跟踪日志文件移动到其他非加密文件夹中。有关移动邮件跟踪日志文件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 841089"How to change the location of the message tracking logs in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=841089)

  • 317700"How to change the location of the message tracking logs in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700)


无法访问元数据库
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-02-13

Microsoft® Exchange Server 分析工具试图按照 Internet Information Services (IIS) 元数据库的路径读取简单邮件传输协议 (SMTP) 虚拟服务器实例的各种属性：

/LM/SmtpSvc/<SMTP 虚拟服务器实例>

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • 元数据库查询失败。

  • Exchange Server 不是在 Microsoft Windows NT® Server 4.0 上运行。

此错误表示 Exchange Server 分析工具无法连接到 IIS 元数据库。

IIS 元数据库包括影响 Exchange Server 的信息，例如，HTTP 的协议设置、邮箱和移动设备访问的虚拟目录以及 HTTP 安全设置。

要解决此问题，请验证元数据库的完整性以及是否已正确安装 IIS。

要验证元数据库未损坏并且已正确安装 IIS，请参阅以下资源：

  • Microsoft 知识库文章 240225"用来修改元数据库的 Adsutil 和 MetaEdit 实用程序的描述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240225)。

  • Microsoft 知识库文章 317678"如何重新启动 Exchange 2000 Server 上的 Internet Information Services (IIS)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=317678)。

如果这些资源提供的指导无法解决问题，则可能需要先卸载 IIS，然后重新进行安装。

使用控制面板中的"添加/删除 Windows 组件"来卸载 IIS

  1. 单击"开始"，然后单击"控制面板"。

  2. 双击"添加或删除程序"。

  3. 单击"添加/删除 Windows 组件"。

  4. 在"组件"列表中单击"应用程序服务器"复选框。

  5. 单击"详细信息"。

  6. 单击"Internet Information Services 管理器"。

  7. 单击"下一步"。

  8. 卸载 IIS 后，单击"完成"。
使用控制面板安装 IIS

  1. 单击"开始"，然后单击"控制面板"。

  2. 双击"添加或删除程序"。

  3. 单击"添加/删除 Windows 组件"。

  4. 在"组件"列表中单击"应用程序服务器"复选框。

  5. 单击"详细信息"。

  6. 单击"Internet Information Services 管理器"复选框。

  7. 单击"确定"，直到返回"Windows 组件向导"。

  8. 单击"下一步"，然后完成"Windows 组件向导"。


MinUserDC 值为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-02-08

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定充当主域控制器 (PDC) 仿真器的 Active Directory® 目录服务域控制器是否已被手动排除在可供 Exchange 使用的域控制器的列表以外：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default

如果 Exchange Server 分析工具发现 MinUserDC 存在并已配置，则会显示非默认配置消息。

PDC 仿真器是一台 Active Directory 操作主机角色的计算机，它处理来自 Microsoft Windows NT® Server 4.0 备份域控制器的复制请求，并处理那些未运行支持 Active Directory 的客户端软件的客户端的所有密码更新。PDC 仿真器也是域控制器，因此可供诸如 Exchange 这样的应用程序使用。

目录服务访问 (DSAccess) 是 Exchange 2000 Server 和 Exchange Server 2003 的内部组件，用于控制所有 Exchange 组件访问 Active Directory 的方式。DSAccess 的主要功能是维护各种与目录有关的事件和操作的相关信息。例如，DSAccess 发现 Active Directory 拓扑结构，并检测域控制器和全局编录服务器是否可用、是否能对查询做出响应。

默认情况下，DSAccess 在它的可用域控制器列表中包括 PDC 仿真器计算机。如果非 Exchange 程序过度使用 PDC 仿真器，则 DSAccess 使用 PDC 仿真器时会导致在 PDC 仿真器计算机上以及在 Exchange 服务器和非 Exchange 程序计算机上出现性能问题。

若要防止发生这样的性能问题，可以在 Exchange 服务器上将 MinUserDC 注册表值添加到注册表中，以便强制 DSAccess 在查询具有 PDC 仿真器操作主机角色的域控制器之前，先查询其他所有可用的域控制器。

注意：
配置了 MiniUserDC 注册表值的 Exchange 服务器将首先尝试使用同一个域中的其他服务器，因此建议仅在站点至少包含两个域控制器（用于包含 Exchange 服务器的域）的情况下采用这种配置。
重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

检查并编辑 MinUserDC 注册表值

  1. 打开注册表编辑器，例如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default

  3. 找到 MinUserDC 值，并进行任何所需更改。如果该 DWORD 值不存在，可以手动创建它。

  4. 为 MinUserDC 注册表项所配置的值数据是在联系 PDC 仿真器之前要首先联系的最大域控制器数。例如，通过将 MinUserDC 设置为 4，可以将 DSAccess 配置为仅当共有 4 台域控制器可用时才排除 PDC 仿真器。满足该条件时，将不使用 PDC 仿真器，并且 DSAccess 只与其余 3 个域控制器通信。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关使用 MinUserDC 注册表项的详细信息，请参阅知识库文章 298879"XADM:Exchange 2000 May Experience Performance Problems When PDC Emulator Is Used for DSAccess"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=298879)。


存在 1000 多个邮箱存储
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-12-13

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，并维护 Microsoft Exchange 信息存储对象（对象类为 msExchPrivateMDB）的计数。如果 Exchange Server 分析工具确定组织中有超过 1,000 个邮箱存储，则显示警告。

显示警告是因为存在已知问题，该问题是指当用户通过有超过 1,000 个邮箱存储的组织中的前端服务器以 Microsoft Office Outlook® Web Access 2003 访问邮箱时，将无法访问他们的邮箱。该问题是由于前端 Exchange 服务器向后端 Exchange 服务器转发身份验证请求的方式所导致的。

如果您有正在访问其在前端 Exchange 服务器上的邮箱存储的用户，并且您得到该警告，则必须执行下列操作之一：

  • 获取并安装 Microsoft 知识库文章 899902"Users receive a 401 error message when they try to access a mailbox that is in an Exchange Server 2003 front-end server by using Outlook Web Access"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=899902) 所述的 Exchange Server 修复程序。

  • 如果可以，将邮箱合并到更少的邮箱存储上。

  • 将前端服务器设置为用基本身份验证方法来向后端服务器进行身份验证。本文其余部分将描述该选项。

默认情况下，Exchange Server 2003 前端服务器使用 Kerberos 身份验证来帮助保护用户凭据在前端服务器与后端服务器之间的安全性。如果 Kerberos 身份验证失败，将记录警告事件，并且前端服务器将改为尝试 NTLM。如果 NTLM 失败，将记录错误。在 30 分钟内重新尝试 Kerberos 身份验证。当 Exchange 2000 Server 或 Exchange Server 2003 前端计算机向 Exchange 2000 Server 后端计算机验证身份时，将使用 NTLM。在 Internet 信息服务 (IIS) 或 Exchange 系统管理器中，没有选择身份验证机制的用户界面。

如果要将前端 Exchange 服务器配置为使用基本身份验证，则需要在组织中所有前端服务器上设置注册表项。下列过程解释了如何手动设置注册表项。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

将 Exchange 前端服务器配置为对 Exchange 后端服务器使用基本身份验证

  1. 打开注册表编辑器，例如 Regedit.exe 或 Regedt32.exe。

    导航到：HKEY_LOCAL_MACHINE\System\CurrentControlSet\Service\MSExchangeWeb

  2. 用鼠标右键单击"MSExchangeWeb"，指向"新建"，再单击"项"。将新项命名为 Dav。

  3. 用鼠标右键单击新的 Dav 项，指向"新建"，再单击"DWORD 值"。

  4. 将新的值命名为 UseBasicAuthToBE，再将该值设置为 1。

  5. 打开"服务"Microsoft 管理控制台 (MMC) 管理单元，用鼠标右键单击"IIS Admin 服务"，再单击"重新启动"。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


多数持续 store.exe 调用正在等待来自 ESE 的响应
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-13

Microsoft® Exchange Server 分析工具会检查 Exchange 函数调用日志 (FCL)（Store.fcl 文件）中的某类事件，此类事件表示从 Microsoft Exchange Information Store 服务 (Store.exe) 到 Exchange 可扩展存储引擎 (ESE) 的持续跨组件调用。

持续调用是 Microsoft Exchange Information Store 服务 (Store.exe) 向其他将 Exchange FCL 数据写入 Store.fcl 文件时尚未收到响应的组件发出的请求。

Microsoft Exchange Information Store 位于 ESE 数据库的顶部。ESE 是复杂的、基于事务的数据库引擎。事务是一系列被视为原子（不可划分）单位的操作。对于一个事务中的所有操作，要么将其完成并永久保存，要么不执行任何操作。

Exchange Server 使用 ESE 作为嵌入数据库引擎，该引擎决定数据库的结构并管理内存。数据库引擎通过将 4 KB 数据块（页）传进和传出内存，从而在内存中缓存数据库。它更新内存中的数据页，并将新的数据页或经过更新的数据页写入磁盘。当请求到达系统时，数据库引擎可以在内存中缓冲数据。因此其不必经常访问磁盘。

虽然在内存中缓存数据是处理数据的最快和最有效方式，但它意味着 Exchange 正在运行时，磁盘上的信息永远不是完全最新的。数据库的最新版本存于内存中。但是，因为内存中的许多更改尚未保存在磁盘上，所以数据库和内存不同步。事务日志磁盘将始终与有关每个事务的信息保持一致。

如果 Exchange Server 分析工具发现 Store.fcl 日志记录文件中的事件反映出从 Exchange Information Store 服务 (Store.exe) 到 ESE 数据库的调用占据了主导地位，则 Exchange Server 分析工具会显示一个错误。

当来自 Microsoft Exchange Information Store 服务 (Store.exe) 的跨组件调用等待响应时，远程过程调用 (RPC) 线程会在这些请求后面备份，并导致出现 Exchange Server 性能问题，如服务器对客户端的响应发生延迟。

从 Microsoft Exchange Information Store 服务到 ESE 的持续调用可由下列情况引起：

  • Exchange 联机碎片整理。

  • 数据备份。

    注意：
    如果在 Exchange 调用跟踪日志记录收集期间进行数据备份或联机碎片整理，则可安全地忽略此错误消息，而不将其作为 Exchange Server 性能问题的标志。
  • 数据库驱动器上的瓶颈，例如，对于服务器上的用户数而言，容量不足。

  • TEMP 和 TMP 驱动器上的瓶颈。

要解决此错误，请执行下列步骤：

  • 作为最佳做法，建议不要将备份窗口或联机维护与高峰用户需求间隔重叠。

  • 请确保数据库磁盘驱动器运行状况良好并对于 I/O 负载而言具有足够的吞吐量。

  • 运行 Exchange Server 分析工具以进行其他的服务器分析。可在"Microsoft Exchange Server Best Practices Analyzer Tool v2.7"（Microsoft Exchange Server 最佳实践分析工具 v2.7）(http://go.microsoft.com/fwlink/?LinkId=34705) 上下载 Exchange Server 分析工具。

  • 查看此文档"详细信息"部分中的文章。

详细信息

有关如何配置联机碎片整理时间范围的详细信息，请参阅 Microsoft 知识库文章 244524"XADM：如何配置 Exchange Server 联机碎片整理时间范围"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524)。

有关 Exchange Server 磁盘瓶颈问题的详细信息，请参阅检测到磁盘瓶颈。

有关如何调整 Exchange Server 磁盘大小并对该磁盘进行优化的详细信息，请参阅"Optimizing Storage for Exchange Server 2003"（优化用于 Exchange Server 2003 的存储）中的"How to Calculate Your Disk I/O Requirements"（如何计算磁盘 I/O 需求）和"Best Practices Common to Multiple Architectures"（多种体系结构通用的最佳做法）(http://go.microsoft.com/fwlink/?linkid=49324)。

有关 ESE 的详细信息，请参阅"Extensible Storage Engine Architecture"（可扩展存储引擎体系结构）(http://go.microsoft.com/fwlink/?linkid=67009)。


多数持续 store.exe 调用正在等待来自 IMAIL 的响应
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-13

Microsoft® Exchange Server 分析工具会检查 Exchange Server 函数调用日志 (FCL)（Store.fcl 文件）中的某类事件，此类事件表明从 Microsoft Exchange Information Store 服务 (Store.exe) 到 MAPI 客户端的 IMAIL 组件的持续跨组件调用占据了主导地位。

持续调用是 Microsoft Exchange Information Store 服务 (Store.exe) 向其他将 Exchange FCL 数据写入 Store.fcl 文件时尚未收到响应的组件发出的请求。

Exchange Server 的 IMAIL 组件是一种灵活的转换服务，Microsoft Exchange Information Store 服务会在 Internet 邮件和 MAPI 邮件之间使用该转换服务。此组件可以实现使用 RFC-822 或 Internet 格式的客户端和使用 Exchange Server 内部存储格式的客户端（如 MAPI 客户端或内部 STORE 任务）之间的互操作性。

Exchange 使用 IMAIL 机制对内容应用邮件格式，这些格式是在 Exchange 系统管理器中对 Internet 域所指定的，或者是由用户在 Microsoft Office Outlook® 中针对每个收件人所指定的。+如果没有向 IMAIL 传递任何格式参数，则 IMAIL 会将 MAPI 邮件设置为 Summary TNEF (S/TNEF) 格式以便进行服务器之间的传输。

如果 Exchange Server 分析工具发现 Store.fcl 日志记录文件中的事件反映出从 Microsoft Exchange Information Store 服务 (Store.exe) 到 MAPI 客户端的 IMAIL 组件的持续调用占据了主导地位，则 Exchange Server 分析工具会显示一个错误。

当来自 Microsoft Exchange Information Store 服务 (Store.exe) 的跨组件调用等待响应时，远程过程调用 (RPC) 线程会在这些请求后面备份，并导致出现 Exchange Server 性能问题，如服务器对客户端的响应发生延迟。

当满足以下一个或多个条件时，会发生从 Microsoft Exchange Information Store 服务到 MAPI 客户端的 IMAIL 组件的持续调用：

  • IMAIL 尝试处理某个邮件或附件中的许多数据。

  • 许多客户端请求进行数据转换。

  • 对 DSAccess 请求的响应速度很慢。

  • TEMP 和 TMP 驱动器上存在瓶颈。

  • 存在持续的邮箱移动。

要解决此错误，请执行下列步骤：

  • 将进行任何邮箱移动的时间安排在非高峰时间。

  • 运行 Exchange Server 分析工具以进行其他的服务器问题分析（如邮件和附件大小限制）。可在"Microsoft Exchange Server Best Practices Analyzer Tool v2.7"（Microsoft Exchange Server 最佳实践分析工具 v2.7）(http://go.microsoft.com/fwlink/?LinkId=34705) 上下载 Exchange Server 分析工具。

  • 查看此文档"详细信息"部分中的文章。

详细信息

有关 Exchange Server 的磁盘瓶颈问题的详细信息，请参阅检测到磁盘瓶颈。

有关如何调整 Exchange Server 磁盘大小并对该磁盘进行优化的详细信息，请参阅"Optimizing Storage for Exchange Server 2003"（优化用于 Exchange Server 2003 的存储）中的"How to Calculate Your Disk I/O Requirements"（如何计算磁盘 I/O 需求）和"Best Practices Common to Multiple Architectures"（多种体系结构通用的最佳做法）(http://go.microsoft.com/fwlink/?linkid=49324)。

有关针对 Exchange Server 上邮件大小限制的最佳做法的详细信息，请参阅未设置最大传出邮件大小。

有关 DSAccess 和 Exchange Server 性能的详细信息，请参阅"Exchange Server 2003 性能和可伸缩性指南"中的"如何配置 DSAccess 用户缓存"(http://go.microsoft.com/fwlink/?LinkId=47576)。

有关如何解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（解决 Microsoft Exchange Server 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)。

有关如何解决信息存储性能问题的详细信息，请参阅 Microsoft 知识库文章 257725"XADM：如何为信息存储故障排除收集诊断数据"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。


多数持续的 store.exe 调用正在等待来自 LSASS 的响应
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-11

Microsoft® Exchange Server 分析工具检查 Exchange Server 函数调用日志 (FCL)（Store.fcl 文件）中的某些事件，这些事件指示从 Microsoft Exchange Information Store 服务 (Store.exe) 到本地安全身份验证服务器 (Lsass.exe) 进程中持续跨组件调用占据了主导地位。

持续调用是 Microsoft Exchange Information Store 服务 (Store.exe) 向其他组件发出的请求，其中这些组件在将 Exchange FCL 数据写入 Store.fcl 文件时尚未收到响应。

本地安全身份验证服务器进程 (Lsass.exe) 是由其他进程调用的一种安全子系统，用以验证帐户信息和登录验证。

Exchange 客户端的每次登录都会使运行 Exchange Server 的服务器发送一个请求以查找该客户端的帐户安全标识符 (SID)，并会在本地安全身份验证服务器 (Lsass.exe) 进程中创建调用。

如果 Exchange Server 分析工具发现 Store.fcl 日志记录文件中的事件反映出从 Microsoft Exchange Information Store 服务 (Store.exe) 到本地安全身份验证服务器 (Lsass.exe) 进程的持续调用占据了主导地位，则 Exchange Server 分析工具会显示一个错误。

来自 Microsoft Exchange Information Store 服务 (Store.exe) 的跨组件调用等待响应时，远程过程调用 (RPC) 线程会备份这些请求之后的日志记录，并可能导致出现诸如服务器对客户端的响应发生延迟的 Exchange Server 性能问题。

来自 Microsoft Exchange Information Store 服务到 LSASS 进程的持续调用可由下列情况引起：

  • 与同时进行身份验证的用户数有关的服务器资源问题。

  • Exchange 服务器和域控制器或全局编录服务器之间的网络延迟。

  • 服务器资源瓶颈问题。

要解决此错误，请执行下列步骤：

  • 考虑按照推荐的"NeverPing"参数中所述，设置 NeverPing 参数。

  • 查看此文档"详细信息"部分中的文章。

详细信息

有关 Lsass.exe 进程和内存使用情况的详细信息，请参阅 Microsoft 知识库文章 308356"运行 Windows Server 2003 或 Windows 2000 Server 的域控制器上 Lsass.exe 进程的内存使用量"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)。

有关 Exchange 客户端登录和 LSASS 问题的详细信息，请参阅 Microsoft 知识库文章 161938"Slow Exchange Client Logons Due to Resource Deadlock"（由于资源死锁导致 Exchange 客户端登录速度很慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938)。

有关 Exchange 服务器和域控制器或全局编录服务器之间网络延迟的详细信息，请参阅以下 Exchange Server 工作组博客文章"Exchange Does Not Always Use Local GCs"（Exchange 并不总是使用本地 GC）(http://go.microsoft.com/fwlink/?LinkId=69166)。

注意：
每篇博客的内容及其 URL 都可能随时更改，恕不另行通知。

有关服务器资源瓶颈问题的详细信息，请参阅处理器瓶颈。

有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)。

有关如何解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（解决 Microsoft Exchange Server 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)。

有关如何解决信息存储性能问题的详细信息，请参阅 Microsoft 知识库文章 257725"XADM：如何为信息存储故障排除收集诊断数据"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。


多数持续 store.exe 调用正在等待来自某个目录的响应
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-14

Microsoft® Exchange Server 分析工具会检查 Exchange 函数调用日志 (FCL)（Store.fcl 文件）中的某类事件，此类事件表明从 Microsoft Exchange Information Store 服务 (Store.exe) 到 Active Directory® 目录服务的持续跨组件调用占据了主导地位。

持续调用是 Microsoft Exchange Information Store 服务 (Store.exe) 向其他将 Exchange FCL 数据写入 Store.fcl 文件时尚未收到响应的组件发出的请求。

Active Directory 提供所有邮箱信息、地址列表服务以及其他与收件人有关的信息。大多数 Exchange Server 2003 配置信息也存储在 Active Directory 中。

Exchange Server 服务会访问存储在 Active Directory 中的信息，并将信息写入到 Active Directory 中。

如果 Exchange Server 分析工具发现 Store.fcl 日志记录文件中的事件反映出从 Microsoft Exchange Information Store 服务 (Store.exe) 到 Active Directory 的调用占据了主导地位，则 Exchange Server 分析工具会显示一个错误。

当来自 Microsoft Exchange Information Store 服务 (Store.exe) 的跨组件调用等待响应时，远程过程调用 (RPC) 线程会在这些请求后面备份，并导致出现 Exchange Server 性能问题，如服务器对客户端的响应发生延迟。

从 Microsoft Exchange Information Store 服务到 Active Directory 的持续调用可由下列情况引起：

  • Exchange 服务器和域控制器之间的网络延迟。

  • DSAccess 的静态配置或错误配置。

  • 超载的域控制器和全局编录。

  • Active Directory 拓扑设计错误。

要解决此错误，请执行下列步骤：

  • 运行 Exchange Server 分析工具以进行其他的服务器问题分析（如邮件和附件大小限制）。可在"Microsoft Exchange Server Best Practices Analyzer Tool v2.7"（Microsoft Exchange Server 最佳实践分析工具 v2.7）(http://go.microsoft.com/fwlink/?LinkId=34705) 上下载 Exchange Server 分析工具。

  • 检查 Active Directory 域控制器服务器的性能。

  • 查看此文档"详细信息"部分中的文章。

详细信息

有关 Exchange 性能和 DSAccess 的详细信息，请参阅 Microsoft 知识库文章 250570"Directory Service Server Detection and DSAccess Usage"（目录服务服务器检测和 DSAccess 用法）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570)。

有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)。

有关如何解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（解决 Microsoft Exchange Server 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)。

有关如何解决信息存储性能问题的详细信息，请参阅 Microsoft 知识库文章 257725"XADM：如何为信息存储故障排除收集诊断数据"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。

有关域控制器性能的详细信息，请参阅以下 Windows Server 资源：

  • "Planning Domain Controller Capacity"（规划域控制器容量）(http://go.microsoft.com/fwlink/?LinkId=70191)。

  • "Windows 2000 Server Active Directory Planning and Deployment Guides"（Windows 2000 Server Active Directory 规划和部署指南）中的"Active Directory Monitoring of Domain Controllers"（域控制器的 Active Directory 监视）(http://go.microsoft.com/fwlink/?LinkId=70193)。


多数持续 store.exe 调用正在等待来自病毒扫描程序的响应
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-13

Microsoft® Exchange Server 分析工具会检查 Exchange 函数调用日志 (FCL)（Store.fcl 文件）中的某类事件，此类事件表明从 Exchange Information Store 服务 (Store.exe) 到 Virusscan 病毒 API (VAPI) 组件的持续跨组件调用占据了主导地位。

持续调用是 Microsoft Exchange Information Store 服务 (Store.exe) 向其他将 Exchange FCL 数据写入 Store.fcl 文件时尚未收到响应的组件发出的请求。

如果 Exchange Server 分析工具发现 Store.fcl 日志记录文件中的事件反映出从 Microsoft Exchange Information Store 服务 (Store.exe) 到 Virusscan VAPI 组件的持续调用占据了主导地位，则 Exchange Server 分析工具会显示一个错误。

当来自 Microsoft Exchange Information Store 服务 (Store.exe) 的跨组件调用等待响应时，远程过程调用 (RPC) 线程会在这些请求后面备份，并导致出现 Exchange Server 性能问题，如服务器对客户端的响应发生延迟。

从 Microsoft Exchange Information Store 服务到 Virusscan VAPI 组件的持续调用可由下列情况引起：

  • 对病毒扫描程序的更新，这些更新将生成对信息存储中项目的重新扫描。

  • 病毒扫描程序配置错误

  • 病毒扫描程序软件处理很大的邮件或附件

若要解决此错误，请执行下列步骤：

  • 将对病毒引擎进行更新的时间安排在资源占用较少的时间，即非高峰需求时间。

  • 考虑重新安装病毒扫描软件，但要在非高峰需求间隔进行重新安装。

  • 检查病毒扫描引擎的配置中是否存在正确的线程配置、文件级排除等。请参阅 Microsoft 知识库文章 823166"Exchange Server 2003 和防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)。

  • 查看此文档"详细信息"部分中的文章。

详细信息

有关通常与 Microsoft Exchange Server 2003 一起使用的病毒扫描程序的详细信息，请参阅 Microsoft 知识库文章 823166"Exchange Server 2003 和防病毒软件概述"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)。

有关通常与 Microsoft Exchange 2000 Server 一起使用的病毒扫描程序的详细信息，请参阅 Microsoft 知识库文章 328841"Exchange 和防病毒软件"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)。

有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)。

有关如何解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（解决 Microsoft Exchange Server 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)。

有关如何解决信息存储性能问题的详细信息，请参阅 Microsoft 知识库文章 257725"XADM：如何为信息存储故障排除收集诊断数据"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。


多数持续 store.exe 调用正在等待来自 VSS 快照的响应
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-13

Microsoft® Exchange Server 分析工具会检查 Exchange Server 函数调用日志 (FCL)（Store.fcl 文件）中的某类事件，此类事件表明从 Exchange Information Store 服务 (Store.exe) 到卷影复制服务 (VSS) 快照组件的持续跨组件调用。

持续调用是 Microsoft Exchange Information Store 服务 (Store.exe) 向其他将 Exchange FCL 数据写入 Store.fcl 文件时尚未收到响应的组件发出的请求。

VSS 是一组 COM API，可用于实现一个框架，该框架允许在系统中的应用程序继续写入卷的情况下执行卷备份。

Microsoft Exchange Server 2003 使用包含在 Microsoft Windows Server™ 2003 操作系统中的 VSS 来获取 Exchange Server 2003 数据库和事务日志文件的卷影副本。

VSS 快照不完全独立于原始数据。通常，快照是在您定义了时间标记并确保数据可回滚到该时间的情况下创建的。

如果 Exchange Server 分析工具发现 Store.fcl 日志记录文件中的事件反映出从 Microsoft Exchange Information Store 服务 (Store.exe) 到 VSS 快照组件的持续调用，则 Exchange Server 分析工具会显示一条最佳做法消息。

当来自 Microsoft Exchange Information Store 服务 (Store.exe) 的跨组件调用等待响应时，远程过程调用 (RPC) 线程会在这些请求后面备份，并导致出现 Exchange Server 性能问题，如服务器对客户端的响应发生延迟。

注意：
如果在 20 秒的 Exchange 调用跟踪日志记录收集时间内特意启动了 VSS 快照，则可安全地忽略此消息，而不将其作为 Exchange Server 性能问题的标志。

作为最佳做法，建议不要将备份窗口与联机维护或高峰用户需求间隔重叠。

详细信息

有关 VSS 的详细信息，请参阅"Best Practices for Using Volume Shadow Copy Service with Exchange Server 2003"（使用 Exchange Server 2003 的卷影复制服务的最佳做法）(http://go.microsoft.com/fwlink/?LinkId=56571)。


MOUNTMGR.SYS 文件版本不正确
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-02-13

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已安装 Microsoft Windows® Server 2003：HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\

Exchange Server 分析工具还执行下列查询：

  • Win32_OperatingSystem Microsoft Windows Management Instrumentation (WMI) 类，以确定是否已安装 Windows Server 2003 Service Pack 1。

  • Win32_Service WMI 类，以确定是否正在运行群集服务。

  • Win32_Volume WMI 类，以确定是否有卷装入点。

  • CIM_Datafile WMI 类，以确定 Mountmgr.sys 的 Version 关键字的值是否小于 2443。

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • Mountmgr.sys 的 Version 关键字小于 2443。

  • 服务器是运行 Windows Server 2003 Service Pack 1 的群集的一个节点。

  • 服务器具有卷装入点。

群集节点上安装的 Mountmgr.sys 版本可能会导致卷装入点失败。出现该问题的原因是因为 Mountmgr.sys 驱动器有问题。这是一个时断时续的计时问题，可能会在将卷装入到装入点时发生。

注意：
通常，该问题不会在非群集环境中出现。在非群集环境中，卷装入进程的计时有所不同。

有关该问题的详细信息，请参阅 Microsoft 知识库文章 898790"Volume mount points on disks in a server cluster may intermittently become unavailable after you install Windows Server 2003 Service Pack 1"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790)。


移动 TEMP 和 TMP 目录
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-09-01

Microsoft® Exchange Server 分析工具已确定服务器的 TEMP 和 TMP 文件所在的位置不能实现最佳磁盘性能。作为最佳做法，建议将 TEMP 和 TMP 文件夹存储在未由系统文件夹或 Exchange 数据文件共享的磁盘子系统上。

Microsoft Exchange 信息存储服务在各种操作（例如，邮件转换、使用大附件以及邮箱移动操作）中使用 TEMP 和 TMP 文件夹作为临时存储。TEMP 和 TMP 环境变量用来指定文件系统中的哪些文件夹（例如哪个路径）应当被需要临时工作区的应用程序使用。通常，TEMP 供应用程序（如 Microsoft Exchange）使用，TMP 供开发工具（如 Microsoft Visual C++®）使用。每个变量的路径通常相对于应用程序或工具的安全上下文。

在非群集的 Exchange 服务器上，Exchange 存储使用 SYSTEM （如 Local System）文件夹，此文件夹使用 TEMP 和 TMP 的默认环境变量设置 %Systemroot%\Temp。运行于 Microsoft Windows® 服务器群集中的 Exchange 虚拟服务器使用群集服务帐户的环境变量设置，此帐户在特定用户安全规则的上下文中运行。对于用户帐户，将 TEMP 和 TMP 的默认环境变量设置为 %Userprofile%\Temp。

本文介绍了如何在群集环境和非群集环境中移动 TEMP 和 TMP 目录。在执行本文中的过程之前，请考虑下列建议：

  • 为了获得最佳性能，建议 Exchange 所使用的 TEMP 和 TMP 文件夹不要在包含操作系统的磁盘上。此外，还应确保将这些环境变量设置为快速磁盘或磁盘子系统（如 RAID-0+1 轴集）中的路径。

  • 建议不要使用已使用的 TEMP 和 TMP 文件夹的磁盘 Exchange 事务日志。

若要在非群集环境中移动 TEMP 或 TMP 文件夹，请执行下列操作：

  1. 使用具有管理权限的帐户登录到运行 Exchange Server 的计算机。

  2. 右键单击"我的电脑"，然后选择"属性"。

  3. 选择"高级"选项卡。

  4. 单击"环境变量"。

  5. 在"系统变量"区域中，选择 TEMP，再单击"编辑"。

  6. 在"变量值"字段中，输入 TEMP 环境变量的新路径，然后单击"确定"。

  7. 在"系统变量"区域中，选择 TMP，再单击"编辑"。

  8. 在"变量值"字段中，输入 TMP 环境变量的新路径，然后单击"确定"。

  9. 单击"确定"关闭"环境变量"对话框，再单击"确定"关闭"系统属性"对话框。

  10. 重新启动服务器以应用所有更改。
若要在群集环境中移动 TEMP 或 TMP 文件夹，请执行下列操作：

  1. 作为群集服务帐户登录到群集中的节点。

  2. 右键单击"我的电脑"，然后选择"属性"。

  3. 选择"高级"。

  4. 单击"环境变量"。

  5. 在"<account name> 的用户变量"区域中，选择 TEMP，再单击"编辑"。

  6. 在"变量值"字段中，输入 TEMP 环境变量的新路径，然后单击"确定"。

  7. 在"<account name> 的用户变量"区域中，选择 TMP，再单击"编辑"。

  8. 在"变量值"字段中，输入 TMP 环境变量的新路径，然后单击"确定"。

  9. 单击"确定"关闭"环境变量"对话框，再单击"确定"关闭"系统属性"对话框。

  10. 重新启动该节点，以便应用更改。

  11. 对群集中的每个节点重复步骤 1 到 10。
重要信息：
必须为 Authenticated Users 帐户授予对 TMP 文件夹和 TEMP 文件夹的新路径的相应权限。
为 Authenticated Users 组分配对 TMP 文件夹或 TEMP 文件夹的权限

  1. 启动 Windows 资源管理器，找到并用鼠标右键单击 TEMP 变量或 TMP 变量指向的文件夹，然后单击"属性"。

  2. 在"临时属性"对话框中，单击"安全"选项卡，然后单击"添加"。

  3. 在"选择用户、计算机或组"对话框中，将 Authenticated Users 组添加到对象名列表，然后单击"确定"。

  4. 单击"高级"访问高级安全设置。

  5. 在"名称"列表中选择 Authenticated Users，然后单击"编辑"显示"权限条目"对话框。

  6. 使用"权限"区域中的字段授予下列特殊权限：

    遍历文件夹/执行文件

    创建文件/写入数据

    创建文件夹/附加数据

  7. 单击"确定"三次以应用权限并退出。

详细信息

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。


将用户邮箱移至其他服务器
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-09-06

Microsoft® Exchange Server 分析工具确定服务器的当前用户负载超过能有效支持的负载。当前的用户负载导致出现性能问题。建议您通过每晚移动少量用户（通常是总用户数的百分之五），将他们移到其他位置，直到性能问题得到解决。

建议使用此方法是因为出现了下列问题之一：

  • 某些 Exchange 数据库文件所在的磁盘达到或超过了其吞吐容量限制。

  • 其他服务器资源（例如，内存或 CPU）也超过了容量限制。

  • 磁盘超过了其容量限制意味着当前支持一个或多个 Exchange 存储的磁盘子系统的平均磁盘 I/O 延迟超过了当前建议的级别。应当每次将百分之五的用户移至其他磁盘子系统上的数据库中，直到解决问题。如果数据库驱动器成为瓶颈，则将用户移至其他驱动器上的数据库中。如果存储组驱动器成为瓶颈，则将用户移至其他数据库上的其他存储组的数据库中。如果驱动器由其他资源共享，则另一个可用的解决方案为：减少这些驱动器上其他应用程序的负载。

  • 您的物理服务器超过了其容量限制。当前没有足够的处理器或内存来支持由用户产生的服务器负载。应当每次将百分之五的用户移至其他服务器中，直到解决性能问题。

注意：
尽管在执行邮箱移动操作过程中，不需要断开 Exchange 客户端与其邮箱的连接，但是，建议在 Exchange 客户端的活动较慢（例如非高峰时段）时执行移动操作，以防出现服务中断。
在 Exchange Server 2003 上移动邮箱

  1. 在要运行进程的 Exchange Server 2003 计算机上启动 Exchange 系统管理器。

  2. 双击"服务器"，再找到用户邮箱所在的服务器容器。

    例如，如果要将邮箱移出默认的存储组和邮箱存储，请依次双击"第一个存储组"和"邮箱存储"，再单击"邮箱"。

  3. 在详细信息窗格中，单击要移动的邮箱。

  4. 用鼠标右键单击选定的用户，再单击"Exchange 任务"。

  5. 在 Exchange 任务向导中，单击"下一步"。

  6. 在"可用任务"页中，单击"选择要执行的任务"下的"移动邮箱"，再单击"下一步"。

  7. 在"移动邮箱"页的"服务器"列表中，单击所需的服务器，再在"邮箱存储"列表中，单击所需的邮箱存储。

  8. 单击"下一步"。

  9. 配置移动过程中发现的任何损坏邮件的处理方式，再单击"下一步"。

  10. 单击"下一步"。

详细信息

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关使用 Exchange Server 2003 移动邮箱的详细信息，请参阅 Microsoft 知识库文章 821829"在 Exchange Server 2003 中移动邮箱"(http://support.microsoft.com/kb/821829/zh-cn)。

  • 有关在 Exchange 2000 Server 和 Exchange Server 5.5 之间移动邮箱的详细信息，请参阅 Microsoft 知识库文章 328810"XADM：在服务器之间移动邮箱"(http://support.microsoft.com/kb/328810/zh-cn)。


NAS 配置问题
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个存储组对象的 msExchESEParamLogFilePath 属性的值。该属性指定了此存储组中的数据库所使用的事务日志文件的位置。

Exchange Server 分析工具还查询 Active Directory，以确定在每个邮箱存储的 homeMDBBL 属性中所列出的条目数。该属性的个数代表邮箱存储中的邮箱数。

此外，Exchange Server 分析工具还查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Microsoft Windows Storage Server 2003 Feature Pack 服务 (wssexchmap) 的 Started 关键字的值。值为 False 说明该 Exchange 服务器没有运行 Windows Storage Server 2003 Feature Pack 服务。值为 True 说明正在运行 Windows Storage Server 2003 Feature Pack 服务。

如果 Exchange Server 分析工具确定有任何 msExchESEParamLogFilePath 属性的值是以 S:\{ 开头的，并且在包含超过 1500 个邮箱的 Exchange Server 计算机上启动了 Windows Storage Server 2003 Feature Pack 服务，则会显示警告。

Windows Storage Server 2003 是 NAS 设备的 Microsoft 平台。建议将 Windows Storage Server 2003 存储布局与 Exchange Server 2003 一起使用，它与标准的 Exchange Server 布局有点不同。建议的配置是将 Exchange Server 数据库放在 Windows Storage Server 2003 上，并将事务日志文件放在 Exchange Server 计算机的本地磁盘上。

Microsoft 为三种特定的工作负荷而开发 Windows Storage Server 2003 Feature Pack：

  • 小型工作负荷，连接到一个 Windows Storage Server 计算机的一个 Exchange Server 驻留有最多 250 个邮箱。在这种情况下，建议 Windows Storage Server 的配置是 1 GHz 或更快的处理器、512 MB RAM、四个配置为 RAID 5 卷的 SCSI 或 IDE/SATA 磁盘，以及两个网络接口卡 (NIC)：一个连接到 LAN，另一个专用的 Gigabit 以太网适配器则直接连接到 Exchange 服务器。Exchange 数据库存储在 RAID 5 卷上；事务日志则留在 Exchange 服务器的本地 RAID 1 上。

  • 中等工作负荷，一个存储组中有最多 750 个邮箱，驻留于一个 Exchange Server 和一个 Windows Storage Server 计算机上。在该配置中，Windows Storage Server 计算机应当有一对 1 GHz 或更快的处理器、1 GB RAM、六个 SCSI 磁盘和一对 NIC。磁盘应当配置为用于数据库的 4 磁盘 RAID 5 阵列，以及用于事务日志的单个双磁盘镜像集。

  • 大型工作负荷，有一个或两个 Exchange Server 2003 服务器，在两个存储组中驻留了最多 1,500 个邮箱。在该配置中，Windows Storage Server 应当有两个 1 GHz 或更快的处理器、2 GB RAM 和 14 个磁盘：10 个磁盘用于 RAID 0+1 阵列以存放数据库，两组镜像磁盘用于事务日志。

该警告说明 Exchange Server 计算机已经被配置为使用 Windows Storage Server 2003 作为存储方式。使用 Windows Storage Server 作为 Exchange Server 数据存储方式时，建议访问 Exchange Server 的并发用户少于 1,500 个。

解决此警告问题

  • 执行下列操作之一：

    • 将事务日志移到 Exchange Server 计算机中的本地磁盘。

    • 将该 Exchange Server 计算机上的某些邮箱移动到另一个 Exchange Server 计算机上，以便在使用 Windows Storage Server 的 Exchange Server 计算机上的邮箱数不超过 1,500。

有关将 Windows Storage Server 2003 Feature Pack 与 Exchange Server 2003 一起使用的详细信息，请参阅文档"Managing Exchange Storage with the Windows Storage Server 2003 Feature Pack"（英文）(http://go.microsoft.com/fwlink/?linkid=34942)。

有关详细信息，请参阅以下附加资源：

  • "Introduction to Windows Storage Server 2003 Architecture and Deployment"（英文）(http://go.microsoft.com/fwlink/?linkid=34943)

  • "Building Better Protected Storage using Windows Storage Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=34944)

  • "Server Consolidation Using Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=47586)


networkAddress 属性的设置不正确
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 networkAddress 属性是否包含 ncacn_ip_tcp 字符串。如果符合以下任一条件，Exchange Server 分析工具将显示错误：

  • ncacn_ip_tcp 字符串不存在。

  • ncacn_ip_tcp 字符串已损坏。

在 Microsoft Office Outlook® Web Access for Exchange Server 2003 中，前端服务器在尝试连接到 Exchange 后端服务器时检查 networkaddress 属性的值。

注意：
Exchange 2000 Server 不会对 Outlook Web Access 这样做。

前端服务器要求完全限定域名 (FQDN) 值。前端服务器检查 networkaddress ncacn_ip_tcp 返回的值中的句点。如果符合以下条件，对特定后端服务器上的邮箱的连接请求将失败，前端服务器向用户返回"HTTP 500 内部服务器错误"的错误消息：

  • networkaddress ncacn_ip_tcp 的值只是主机名或网络基本输入/输出系统 (NetBIOS) 名称。

  • networkaddress ncacn_ip_tcp 的值不是 FQDN。

必须更新 Active Directory 中的服务器对象上的 networkaddress ncacn_ip_tcp 值，以确保 Outlook Web Access 2003 可以执行相应的功能。受影响的服务器名称在 Exchange Server 分析工具的错误消息中提供。

警告：
在使用 ADSI（Active Directory 服务接口）Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。
注意：
在更新 ncacn_ip_tcp 值之前，请先阅读本文的其他内容。为了使重新启动 Exchange Server 服务造成的停机时间最短，应先执行其他一些步骤，然后再重新启动 Exchange Server 服务。
更新 networkAddress 属性上的 ncacn_ip_tcp 值

  1. 从 Windows 2000 Server 支持工具或 Windows Server 2003 支持工具启动 ADSI Edit 工具。

  2. 展开下列节点：

    • Configuration Container

    • Configuration

    • Services

    • Microsoft Exchange

    • Organization_Name

    • Administrative Groups

    • Administrative_Group_Name

    • Servers

  3. 用鼠标右键单击 Exchange 服务器名称，再单击 Properties。

  4. 单击 Attributes 列表中的 networkaddress，再单击 Edit。

  5. 为 ncacn_ip_tcp 添加新值。使用服务器的 FQDN，而不是服务器的 NetBIOS 名称或主机名。

    此值的语法为 ncacn_ip_tcp:FQDN。例如，如果 Exchange 后端服务器的主机名为 EXCHANGE1，FQDN 为 EXCHANGE1.contoso.com，请对 ncacn_ip_tcp 使用以下值： ncacn_ip_tcp:EXCHANGE1.contoso.com

  6. 单击 OK 两次以应用更改。

  7. 重新启动服务器上的所有 Exchange Server 的服务。

  8. 如果有多个域控制器，请等待进行复制，然后再尝试从前端服务器登录。如果复制完成后问题仍没有解决，请重新启动前端服务器上的 IIS 管理服务。

如果在后端服务器上维护主机文件以关联包含短主机名的服务器 IP 地址，必须还要更新 UpdateProtocols registry 注册表值。如果使用了主机文件，在重新启动 Microsoft System Attendant 时，Exchange Server 可能会更改回 ncacn_ip_tcp 值。如果后端服务器是群集服务器，在故障转移之后，Exchange Server 可能会更改回 ncacn_ip_tcp 值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
为使用主机文件的后端服务器修改 UpdateProtocols 注册表值

  1. 使用注册表编辑器在一个或多个后端服务器上配置以下注册表值： HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\UpdateProtocols

    注意：
    如果 UpdateProtocols 值不存在，必须创建该值。若要这样做，请执行下列步骤：

  2. 打开注册表编辑器并找到以下注册表子项： HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\

    1. 用鼠标右键单击"参数"，指向"新建"，再单击"DWORD 值"。

    2. 键入 UpdateProtocols，再按 Enter 键。

  3. 用鼠标右键单击 UpdateProtocols，单击"修改"，在"数值数据"字段中键入 0，再单击"确定"。

  4. 如果网络使用后端群集节点上的主机文件，请按如下所示修改 UpdateProtocols 的输入顺序：

    IPAddress to FQDN

    IPAddress to NetBIOS

    而不是：

    IPAddress to NetBIOS

    IPAddress to FQDN

  5. 重新启动服务器上的所有 Exchange Server 的服务。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


Network Interface 性能监视器对象不可用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包括性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎从 Network Interface 性能对象的 Bytes Total/sec 性能计数器收集数据以分析性能数据。如果计数器未返回有效数据，则 Exchange Server 分析工具将显示基准消息。

如果性能数据收集引擎未返回有效数据，则可能出现下列情况的任意组合：

  • Network Interface 性能对象已禁用。

  • Network Interface 性能监视器对象丢失或损坏。

  • Exchange Server 分析工具没有访问性能对象的相应权限。

如果某些可扩展计数器破坏了注册表，或基于 Microsoft Windows® Management Instrumentation (WMI) 的程序修改了注册表，可能会发生前两种情况。在执行此过程之前，请验证 Exchange Server 分析工具是否具有相应的权限。有关运行 Exchange Server 分析工具所需的权限的详细信息，请参阅随 Exchange Server 分析工具提供的帮助文档。要获得帮助，请打开 Exchange Server 分析工具，然后按 F1 键。

更正此错误

  1. 验证 Network Interface 性能对象是否已启用。

    1. 下载并安装可扩展性能计数器列表工具 (Exctrlst.exe)。可以从以下位置下载 Exctrlst.exe："Exctrlst.exe:Extensible Performance Counter List"（英文）(http://go.microsoft.com/fwlink/?LinkId=34436)。

    2. 打开 Exctrlst.exe，再单击"Sort Order"，然后单击"Service"。

    3. 找到性能对象所报告的服务，并确认选中了"Performance Counters Enabled"复选框。

      如果未选中"Performance Counters Enabled"复选框，请选中该复选框，然后重新启动与性能计数器关联的服务，确认性能计数器工作正常。如果性能计数器无法正常工作，或"Performance Counters Enabled"复选框已选中，请继续执行第 2 步。

  2. 重建丢失或损坏的性能计数器，请参阅 Microsoft 知识库文章 300956"如何手动重新生成性能计数器库值"(http://support.microsoft.com/?kbid=300956)。

  3. 如果按照此知识库文章操作不能解决问题，将必须在"修复"模式下重新安装 Windows 操作系统，然后应用最新的 Windows Server Service Pack。


较新的可用 MSGTRACK.dll
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-10-05

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从处理器性能对象的多个性能计数器收集数据，以分析性能数据。

Exchange Server 分析工具还查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定为 Msgtrak.dll 文件的 Version 关键字设置的值。

如果下列条件为真，Exchange Server 分析工具将显示警告：

  • 服务器正处于高 CPU 使用率。

  • Msgtrak.dll 文件 Version 关键字的值早于 6.0.6373.0。

此警告表示发现的 Msgtrack.dll 版本可能会引起高 CPU 使用率。警告还表示发现的 Msgtrack.dll 版本可能导致 Inetinfo.exe 进程显示使用了非常高的内存。

要解决此问题，请获取 Microsoft 知识库文章 811409 所引用的更新，"XADM：邮件跟踪可能导致 Inetinfo.exe 进程显示使用了非常高的内存"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=811409)。


较新的可用 WLDAP32.DLL
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-10-06

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从处理器性能对象的多个性能计数器收集数据，以分析性能数据。

Exchange Server 分析工具还读取以下注册表项，以确定在 Exchange Server 计算机上运行的 Microsoft Windows® 的版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 值为 4.0 表示 Exchange Server 计算机运行的是 Microsoft Windows NT® 4.0。值为 5.0 表示 Exchange Server 计算机运行的是 Windows 2000 Server，值为 5.2 表示 Exchange Server 计算机运行的是 Windows Server™ 2003。

最后，Exchange Server 分析工具还查询 CIM_Datafile Microsoft Windows Management Instrumentation (WMI) 类，以确定为 Wldap32.dll 文件的 Version 关键字设置的值。

如果下列条件为真，Exchange Server 分析工具将显示警告：

  • Exchange Server 分析程序已检测到所分析服务器具有高的 CPU 使用率。

  • Exchange Server 计算机运行的是 Windows 2000 Server。

  • Wldap32.dll 文件 Version 关键字的值表明该版本早于版本 5.0.2195.7044。

此警告表示找到的 Wldap32.dll 版本可能导致 Inetinfo.exe 进程消耗 Windows 2000 Server 系统 100% 的 CPU。

若要解决此问题，请获取 Microsoft 知识库文章 899019 所引用的更新，"对于正在运行 Exchange 2000 Server 的 Windows 2000 Server 计算机，Inetinfo.exe 进程可能使用该计算机 100% 的 CPU 资源"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=899019)。


NNTP 服务已启用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定网络新闻传输协议服务 (NntpSvc) 的 Started 关键字的值。值为 True 意味着网络新闻传输协议 (NNTP) 服务运行在此 Exchange 服务器上。

Exchange Server 分析工具还读取 Internet 信息服务 (IIS) 元数据库中的以下属性，以确定是否为 Exchange 服务器配置了 NNTP 新闻复制：

/LM/NNTPSVC/1/Feeds

如果 Exchange Server 分析工具发现 NNTP 服务已启动，但没有为服务器配置新闻复制，则显示警告。

为节省资源，不应对未使用的组件运行任何服务。这也是一条通用的安全防范准则。恶意用户可能利用运行的每个服务所暴露的功能。建议禁用所有未使用的服务。

禁用 NNTP 服务

  1. 依次单击"开始"、"程序"、"管理工具"、"服务"。

  2. 用鼠标右键单击"Network News Transfer Protocol (NNTP)"服务，再单击"属性"。

  3. 在"常规"选项卡上，单击"停止"。

  4. 在"启动类型"下，选择"已禁用"，再单击"确定"。

有关保证 Exchange Server 2003 安全的详细信息，请参阅"Exchange Server 2003 Security Hardening Guide"（英文）(http://go.microsoft.com/fwlink/?linkid=47578)。


没有可用于测试的 DNS 服务器
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-12-05

Microsoft® Exchange Server 分析工具可以查询 Win32_NetworkAdapterConfiguration Microsoft Windows® Management Instrumentation (WMI) 类，为运行 Exchange Server 的服务器尝试向其发送邮件的远程服务器获取 DNSServerSearchOrder 属性。此属性是在查询域名系统 (DNS) 服务器时使用的服务器 IP 地址数组。

Exchange Server 分析工具还查询 Microsoft Active Directory® 目录服务，以确定 Exchange 2000 Server 和 Exchange Server 2003 服务器对象的 protocolCfgSMTPServer 类中 msExchSMTPExternalDNSServers 属性值。protocolCfgSMTPServer 类包含简单邮件传输协议 (SMTP) 虚拟服务器的设置。如果已设置 msExchSMTPExternalDNSServers 属性，则 SMTP 虚拟服务器会使用外部 DNS 服务器。

最后，Exchange Server 分析工具使用以下 Exchange 命令行管理程序 cmdlet，查询任意目标 Exchange 2007 传输服务器角色的 ExternalDNSServers 和 InternalDNSServers 属性值。ExternalDNSServers 属性指定外部 DNS 服务器列表，该服务器在解析远程域时执行查询。InternalDNSServers 属性指定用于为目标服务器解析本地域名的 DNS 服务器列表。

复制代码
get-TransportServer -Identity %ExchangeServerName% -DomainController %DomainControllerName%

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • Exchange Server 分析工具无法成功地检索 DNSServerSearchOrder 属性的值。或者，该属性没包含数据。

  • 未设置 Exchange 2000 Server 和 Exchange Server 2003 服务器对象的 msExchSMTPExternalDNSServers 属性。

  • 目标 Exchange 2007 传输服务器角色的 ExternalDNSServers 和 InternalDNSServers 属性值没包含数据。

该错误表明 Exchange Server 分析工具无法识别目标 Exchange 服务器所使用的任意 DNS 服务器。另外，该状况可能对邮件流产生负面影响。

此状况可能是由以下原因造成的：

  • 在目标服务器上，DNS 配置不当。

  • WMI 失败或者无法访问。

若要解决该问题，请执行下列操作：

  • 检查目标服务器上的 DNS 配置。

  • 验证是否可以访问 Exchange WMI。

验证是否可以访问 Exchange WMI

  1. 确保已启动 Exchange 服务器，并且已将其连接到网络。

  2. 使用 PING 命令来查看是否可访问 Exchange 服务器。

  3. 如果有防火墙，请检查以确定远程过程调用 (RPC) 端口是否被阻止。

  4. 检查用来运行 Exchange Server 分析工具的帐户的权限。用来运行 Exchange Server 分析工具的帐户在每个所扫描的 Exchange 服务器上必须具有本地管理员权限。

    也可以为用来运行 Exchange Server 分析工具的帐户授予特定的 WMI 权限：

    1. 在 Exchange 服务器上，打开"计算机管理"Microsoft 管理控制台 (MMC) 树。

    2. 在"服务和应用程序"下，右键单击"WMI 控件"，再单击"属性"。

    3. 在"WMI 控件属性"页上，单击"安全性"选项卡，再展开"根"。

    4. 选择 CIMV2 文件夹，再单击"安全性"。

    5. 在"ROOT\CIMV2 安全性"页上，添加用来运行 Exchange Server 分析工具的帐户。

  5. 选择在步骤 4 中所添加的帐户。在"所选帐户权限"中的"允许"列下，选择"远程启用"和"读取安全性"，再单击"确定"。

有关如何配置 DNS 以便与 Exchange Server 一起工作的详细信息，请参阅 Microsoft 知识库文章 322856"如何配置 DNS 以用于 Exchange Server"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322856)。

有关网络连接问题的详细信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

有关 Exchange Server 分析工具连接问题的详细信息，请参阅"Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"（解决连接问题的 Microsoft Exchange Server 最佳实践分析工具）(http://go.microsoft.com/fwlink/?LinkId=56285)。

有关端口要求的详细信息，请参阅 Microsoft 知识库文章 832017"Windows Server 系统的服务概述和网络端口要求"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)。


无主帐户 SID
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-02-14

Microsoft Exchange 分析工具查询 Win32_NTLogEvent Microsoft Windows Management Instrumentation (WMI) 类，以确定是否在前一个小时内记录了 MSExchangeIS 的事件 9548 警告。

如果 Exchange 分析工具发现在前一个小时内记录了事件 9548 警告，Exchange 分析工具将计算该小时内记录的事件 9548 警告的总数。

最后，如果 Exchange 分析工具发现事件 9548 警告在前一个小时内记录了 20 次或超过 20 次，Exchange 分析工具将显示警告。

此警告表明，可能存在禁用的 Active Directory 目录服务用户帐户，这些帐户与 Exchange Server 邮箱关联，但没有有效的 msExchMasterAccountSID 属性。

运行 Microsoft Exchange Server 2003 或 Exchange 2000 Server 的服务器上的邮箱只有链接到 Active Directory 目录服务用户帐户才可以使用。通过为邮箱设置 msExchMasterAccountSid Active Directory 属性可以部分完成此链接。Exchange 邮箱链接到的 Active Directory 帐户可能处于启用状态，也可能处于禁用状态。只有已禁用的帐户应使用户具有 msExchMasterAccountSid 属性。

如果已禁用的用户帐户的 msExchMasterAccountSid 属性值为空或已损坏，并且构建的访问控制列表 (ACL) 包含该用户帐户，在使用该 ACL 访问邮箱资源或公用文件夹资源时，可能会出现性能问题。

若要解决此警告指明的问题，请执行下列操作：

  • 确保安装了 Exchange Server 2003 Service Pack 2 (SP2)，并且包含 Microsoft 知识库文章 916783"提供了一个修补程序，可以改变 Exchange Server 2003 SP2 处理与 Exchange Server 2003 邮箱关联的已禁用 Active Directory 用户帐户的方式"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=916783) 中提到的修补程序。

  • 检查事件 9548 警告提到的 ACL 和用户帐户，以确定 msExchMasterAccountSid 属性值是否为空或已损坏，如果需要，可以按照 Microsoft 知识库文章 328880"与 ACL 转换相关的公用文件夹性能问题疑难解答"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328880) 中的指导为该帐户生成有效的 msExchMasterAccountSID 属性值。

  • 按照 Microsoft 知识库文章 278966"无法移动或登录 Exchange 资源邮箱"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=278966) 中的指导将已禁用的用户帐户从 ACL 中删除。

详细信息

有关此问题的详细信息，请参阅下列 Microsoft 知识库文章和 Exchange Server 资源：

  • Events and Errors Message Center: Event Details: MSExchangeIS Mailbox Store Event 9548 details（事件和错误消息中心：事件详细信息：MSExchangeIS 邮箱存储事件 9548 详细信息）(http://go.microsoft.com/fwlink/?LinkId=83135)

  • Microsoft 知识库文章 916783"提供了一个修补程序，可以改变 Exchange Server 2003 SP2 处理与 Exchange Server 2003 关联的已禁用 Active Directory 用户帐户的方式"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=916783)

  • Microsoft 知识库文章 328880"与 ACL 转换相关的公用文件夹性能问题疑难解答"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328880)

  • Microsoft 知识库文章 278966"无法移动或登录 Exchange 资源邮箱"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=278966)


未找到 SMTP 实例
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-08-08

Microsoft® Exchange Server 分析工具将查询 protocolCfgSMTPServer 对象类的 Active Directory® 目录服务 distingushedName 属性，以确定用户指定的 Exchange 网关服务器名的简单邮件传输协议 (SMTP) 虚拟服务器实例是否正在运行。

如果 Exchange Server 分析工具无法找到用户指定的 Exchange 网关服务器的 SMTP 虚拟服务实例，Exchange Server 分析工具将会显示错误。

此错误可能是由暂时性网络问题产生的，但它也可能表示 Active Directory 中存在错误的信息。

若要解决此问题，请查看用户指定的 Exchange 网关服务器的 SMTP 虚拟服务器配置。

查看 SMTP 虚拟服务器实例配置

  1. 启动 Exchange 系统管理器：

    单击"开始"，指向"程序"，指向 Microsoft Exchange，然后单击"系统管理器"。

  2. 导航到以下容器：

    \Administrative Groups\GroupName\Servers\ServerName\Protocols\SMTP\SMTP Virtual Server Instance\

  3. 用鼠标右键单击所需的 SMTP 虚拟服务器实例，然后选择"属性"。

  4. 验证 SMTP 虚拟服务器实例配置是否正确。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列知识库文章：

  • 266686"XCON：如何配置 SMTP 虚拟服务器（第 1 部分）"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)。

  • 268163"XCON：如何配置 SMTP 虚拟服务器（第 2 部分）"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)。

有关 SMTP 服务设计的详细信息，请参阅"Exchange Server 2003 技术参考指南"中的"SMTP 服务设计"(http://go.microsoft.com/fwlink/?LinkId=58876)。

有关网络连接问题的详细信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。


NSPI 目标服务器已被手动覆盖
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取下列注册表项，以确定名称服务提供程序接口目标服务器 (NSPI target server) 服务是否已被手动覆盖：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\NSPI Target Server

如果 Exchange Server 分析工具发现 NSPI Target Server 存在并已配置，则显示非默认配置消息。

客户端的类型不同，则为了访问全局地址列表 (GAL) 而使用域控制器和全局编录服务器的方式也不同。Microsoft Outlook® 2000 Service Release 2 (SR-2) 之前的 Exchange 客户端希望在 Exchange 服务器上找到目录服务。Exchange 2000 Server 和 Exchange Server 2003 使用一种名为目录服务代理 (DSProxy) 的机制代表客户端与距离最近的全局编录服务器建立连接，并代理 Outlook 与该全局编录服务器之间的通信。根据部署要求，您可能希望明确指定应当用来处理 DSProxy 请求的特定全局编录服务器。为此，可以在 Exchange 服务器上的注册表中对 NSPI Target Server 项进行硬编码。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

手动指定 NSPI 服务器

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 创建一个名为 NSPI Target Server 的新 REG_MULTISZ 值。

  4. 将 NSPI Target Server 的值配置为要指定的服务器的完全限定域名。

若要禁用 NSPI 服务器的静态设置，请删除要删除的服务器的完全限定域名条目。如果仅输入了一个 NSPI 目标服务器，那么应删除 NSPI Target Server 注册表值。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Outlook 2000 SR-2 和较新的客户端如何与 Active Directory® 目录服务交互的详细信息，请参阅下列知识库文章：

  • 302914"XCCC:How Outlook 2000 Accesses Active Directory"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914)

  • 256976"XCLN:How MAPI Clients Access Active Directory"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976)


安装了非 Exchange Server MAPI 子系统
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定以下两个文件夹中 MAPI32.dll 的版本：

<drive>:\Program Files\Exchsrvr\Bin

%Systemroot%\System32

如果在这两个文件夹中没有找到相同的 MAPI32.dll 版本和副本，则会显示错误。

为了确保正在使用唯一的 MAPI 版本，Exchange Server 安装程序将 MAPI32.dll 同时复制到 <drive>:\Program Files\Exchsrvr\Bin 和 %Systemroot%\system32 目录。如果将另一个 MAPI 应用程序（例如 Microsoft Office Outlook® 2003 或第三方程序）安装在 Exchange Server 计算机上，则该程序可能将不同的 MAPI32.dll 版本复制到 System32 文件夹中，并且有可能中断 Exchange 功能。发生这些问题是因为这两个产品的版本产生了 MAPI 子系统冲突，如果不中断 Exchange Server 或其他 MAPI 应用程序，可能无法彻底解决该冲突。

强烈建议您不要将 Outlook 2000 或更高版本的Outlook 与 Exchange Server 2003、Exchange 2000 Server 或 Exchange Server 5.5 安装在同一台计算机上。

之所以会在同一台计算机上将 Outlook 与 Exchange Server 安装在一起，通常是为了在服务器端程序中利用某些 Outlook 组件。对于大多数程序开发需求来说，Outlook 不是必须安装在 Exchange 计算机上的程序。Exchange Server 包含协作数据对象 (CDO)，CDO 可以提供类似于 Outlook 对象模型的功能。CDO 是为在服务器端使用而设计的，它还避免了后续 Outlook 版本中所涉及的问题。有关详细信息，请参阅 Microsoft 知识库文章 290500"OL2002:有关电子邮件安全功能的开发人员信息"(http://support.microsoft.com/?kbid=290500)。

另一个常见原因是需要创建 MAPI 配置文件。Exchange Server 包含创建 MAPI 配置文件时所需的所有功能，它不会因为任何理由而需要 Outlook。有关如何在未安装 Outlook 的情况下创建 MAPI 配置文件的详细信息，请参阅知识库文章 306962"HOWTO：在未安装 Outlook 的情况下创建 MAPI 配置文件"(http://support.microsoft.com/kb/306962/zh-cn)。

如果为了进行演示而必须将 Outlook 和 Exchange Server 安装在同一台计算机上，建议您使用下列配置之一，这些配置已经为用于演示而进行了测试：

  • Exchange 2000 Server 与 Outlook 2000 一起使用

  • Exchange 2000 Server 与 Outlook 2002 一起使用

更正此错误

  1. 从 Exchange 服务器上卸载 Microsoft Outlook 或第三方 MAPI 应用程序。

  2. 重新运行 Exchange Server 安装程序，并单击"重新安装"。

有关在同一台计算机上使用 Microsoft Office Outlook 2003 和 Microsoft Exchange Server 的详细信息，请参阅 Microsoft 知识库文章 266418"Microsoft does not support installing Exchange Server components and Outlook on the same computer"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266418)。

有关解决 MAPI 冲突的详细信息，请参阅知识库文章 229700"如何在 Microsoft Outlook 中确定 Mapisvc.inf 文件的正确路径"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=229700)。

有关 MAPI32 存根库的详细信息，请参阅"Messaging API (MAPI)"（英文）(http://go.microsoft.com/fwlink/?linkid=34395)。


检测到非 Microsoft 的 ESE 引擎
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Ese.dll 的 Version 关键字的值。Ese.dll 是 Exchange 数据库存储引擎，也称为可扩展存储引擎 (ESE)。

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定具有对象类 msExchExchangeServer 的所有对象的 serialNumber 属性值。如果字符串值包含"Version 5.5"，说明计算机运行的是 Microsoft Exchange Server 5.5。如果字符串值包含"Version 6.0"，说明计算机运行的是 Microsoft Exchange 2000 Server。如果字符串值包含"Version 6.5"，说明计算机运行的是 Microsoft Exchange Server 2003。

如果 Exchange Server 分析工具发现 Version 的值不包含子字符串 6 作为其版本信息的一部分，但 serialNumber 的值说明已安装 Exchange 2000 Server 或 Exchange Server 2003，则会显示警告。该警告说明此 Exchange Server 计算机安装了非 Microsoft 版本的 Ese.dll，并且正在使用它。应当尽快纠正该问题。

一个可能的原因是使用了基于 ESE 的防病毒软件。某些基于 ESE 的防病毒程序在 Exchange 信息存储和 ESE 之间使用了不受支持的接口。使用这种软件时，如果软件的实现有错误，则存在数据库损坏和数据丢失的风险。

在安装期间，基于 ESE 的扫描程序将更改 Microsoft Exchange 信息存储服务，以使它依赖于基于 ESE 的防病毒程序的服务。这样可以确保基于 ESE 的防病毒程序的服务在 Microsoft Exchange 信息存储服务启动之前先启动。基于 ESE 的防病毒程序启动时，Exchange Server 所附带的 Ese.dll 版本会临时重命名为 Xese.dll，并且基于 ESE 的防病毒程序的 Ese.dll 版本会替换原始文件。基于 ESE 的防病毒程序的 Ese.dll 版本被加载后，Exchange Server 附带的版本将重新重命名为 Ese.dll，并且 Microsoft Exchange 信息存储服务将完成启动进程。

强烈建议不要在 Exchange Server 计算机上使用非 Microsoft 的 ESE 实现。与 Microsoft 产品支持服务联系的客户可能被要求禁用基于 ESE 的防病毒程序，以便有助于找出问题，但在正确诊断问题根源之后，客户可以自行再次启用该软件。

最广为使用的基于 ESE 的防病毒程序是 Sybari Software 的 Antigen for Microsoft Exchange。Microsoft 和 Sybari 一致认为禁用 Sybari Antigen 是确定问题根源的有效故障排除方法。若要与 Sybari Software 联系，请访问 Sybari Software 网站：http://www.sybari.com。

注意：
提供第三方网站信息是为了帮助您查找所需的技术信息。URL 如有更改，恕不通知。

此外，还建议您使用支持病毒扫描应用程序编程接口 (VSAPI)（又称为 AntiVirus API (AVAPI)）的防病毒程序。

解决此警告问题

  1. 对 Exchange Server 计算机执行完整备份。

  2. 从计算机上卸载 Exchange Server。

  3. 在计算机上重新安装 Exchange Server。

  4. 应用 Exchange Server 的最新 Service Pack 和更新。

有关在 Exchange Server 上运行防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://support.microsoft.com/kb/823166/zh-cn)

  • 328841"XADM:Exchange 和防病毒软件"(http://support.microsoft.com/?kbid=328841)


检测到非 Microsoft 可扩展存储引擎
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Ese.dll 的 Version 关键字的值。Ese.dll 是 Exchange 数据库存储引擎，也称为可扩展存储引擎 (ESE)。

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定具有对象类 msExchExchangeServer 的所有对象的 serialNumber 属性值。如果字符串值包含"Version 5.5"，说明计算机运行的是 Microsoft Exchange Server 5.5。如果字符串值包含"Version 6.0"，说明计算机运行的是 Microsoft Exchange 2000 Server。如果字符串值包含"Version 6.5"，说明计算机运行的是 Microsoft Exchange Server 2003。

如果 Exchange Server 分析工具发现 Version 的值不包含子字符串 5.5 作为其版本信息的一部分，但 serialNumber 的值说明已安装 Exchange Server 5.5，则会显示警告。该警告说明此 Exchange Server 计算机安装了非 Microsoft 版本的 Ese.dll，并且正在使用它。应当尽快纠正该问题。

一个可能的原因是使用了基于 ESE 的防病毒软件。某些基于 ESE 的防病毒程序在 Exchange 信息存储和 ESE 之间使用了不受支持的接口。使用这种软件时，如果软件的实现有错误，则存在数据库损坏和数据损失的风险。

在安装期间，基于 ESE 的扫描程序将更改 Microsoft Exchange 信息存储服务，以使它依赖于基于 ESE 的防病毒程序的服务。这样可以确保基于 ESE 的防病毒程序的服务在 Microsoft Exchange 信息存储服务启动之前先启动。基于 ESE 的防病毒程序启动时，Exchange Server 所附带的 Ese.dll 版本会临时重命名为 Xese.dll，并且基于 ESE 的防病毒程序的 Ese.dll 版本会替换原始文件。基于 ESE 的防病毒程序的 Ese.dll 版本被加载后，Exchange Server 附带的版本将重新重命名为 Ese.dll，并且 Microsoft Exchange 信息存储服务将完成启动进程。

强烈建议不要在 Exchange Server 计算机上使用非 Microsoft 的 ESE 实现。与 Microsoft 产品支持服务联系的客户可能被要求禁用基于 ESE 的防病毒程序，以便有助于找出问题，但在正确诊断问题根源之后，客户可以自行再次启用该软件。

解决此警告问题

  1. 对 Exchange Server 计算机执行完整备份。

  2. 在计算机上重新安装 Exchange Server。

  3. 若要应用 Exchange Server 最新的 Service Pack 和更新，可以从 Microsoft Exchange Server 网站 (http://go.microsoft.com/fwlink/?LinkId=21573) 获得最新的 Service Pack 和更新。
  • 有关在 Exchange Server 上运行防病毒软件的详细信息，请参阅 Microsoft 知识库文章 328841"XADM:Exchange 和防病毒软件"(http://support.microsoft.com/?kbid=328841)。

  • 有关使用相同计算机名称重建 Exchange Server 5.5 计算机的详细信息，请参阅知识库文章 155216"XADM：如何以相同的名称将 Exchange Server 移到新计算机上"(http://support.microsoft.com/kb/155216/zh-cn)。


非页面缓冲池超过了警告阈值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

MMicrosoft® Exchange Server 分析工具查询 Win32_PerfRawData_PerfOS_Memory Microsoft Windows® Management Instrumentation (WMI) 类，以确定 PoolNonpagedBytes 关键字的当前值。Exchange Server 分析工具采取的操作取决于底层的操作系统、Windows Boot.ini 文件中是否存在 /3GB 开关以及所发现的该注册表项的值。

下表显示了 Exchange Server 分析工具在确定该值对于指定 Exchange 服务器是否超出界限时所使用的计算矩阵。如果匹配下表中的条件，则会显示警告。

操作系统 | Boot.ini 设置 | 当前非页面缓冲池是
Microsoft Windows 2000 Server 或 Microsoft Windows 2000 Advanced Server | /3GB | 100 MB 或更多
Microsoft Windows 2000 Server 或 Microsoft Windows 2000 Advanced Server | 无 | 200 MB 或更多
Microsoft Windows Server™ 2003 | /3GB | 100 MB 或更多
Microsoft Windows Server 2003 | 无 | 200 MB 或更多

PoolNonpagedBytes 关键字的值是内核内存非页面缓冲池的大小（字节）。这是用于存放无法写入磁盘的对象的物理系统内存区域（即使在未使用这些对象时也是如此）。该关键字的这个值是上次观察到的值。在工作正常的 Exchange Server 上，除非正在发生备份或还原，否则，所使用的非页面缓冲池内存不应超过 85 MB。

在 Windows 2000 Server 和 Windows 2000 Advanced Server 中，非页面缓冲池内存的最大值是 256 MB。由于无法增加非页面缓冲池内存的限制使其超过上述所列值，因此应当尽快纠正这种情况。无论正在使用什么操作系统，或是否出现 /3GB 开关，Windows 都只能访问这么多的非页面缓冲池内存。如果 Windows 用尽了内核内存，它可能会显示错误消息并崩溃。内核内存对于操作系统的正确运行十分重要，因此您应当小心地监视内核内存。

如果重新启动 Exchange Server 之后该情况重现，那么下一步是确保对系统进行正确的调整，并确保该系统上的所有软件和硬件都是最新的。这包括安装最新的下列软件：

  • Windows 操作系统 Service Pack

  • Exchange Server Service Pack

  • 硬件固件和驱动程序

  • 系统 BIOS 更新

  • 已安装和正在运行的任何第三方应用程序的更新

如果软件和硬件更新没有解决该问题，那么应当禁用所有第三方软件，然后重新启动 Exchange Server 计算机，并监视内核内存。

更正此错误

  1. 在方便时尽早重新启动 Exchange Server 计算机。

  2. 监视 Memory | Pool Nonpaged Bytes 性能计数器，确保它没有超过上面列出的阈值。

有关正确调整 Exchange Server 的详细信息，请参阅下列 Microsoft 知识库文章和白皮书：

  • 815372"如何在 Exchange Server 2003 中优化内存使用"(http://support.microsoft.com/kb/815372/zh-cn)

  • 266096"XGEN:Exchange 2000 Requires /3GB Switch with More Than 1 Gigabyte of Physical RAM"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096)

  • "Troubleshooting Exchange Server 2003 Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)

  • "Troubleshooting Exchange 2000 Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=18177)

  • "Exchange Server 2003 性能和可伸缩性指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&displaylang=zh-cn)。

有关非页面缓冲池内存和相关主题的详细信息，请参阅下列知识库文章：

  • 294418"Comparison of 32-Bit and 64-Bit Architecture"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=294418)。

  • 177415"How to Use Memory Pool Monitor (Poolmon.exe) to Troubleshoot Kernel Mode Memory Leaks"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=177415)

  • 268343"Umdhtools.exe: How to Use Umdh.exe to Find Memory Leaks"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268343)


可用页表条目数很低，会导致系统不稳定
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 SystemPages 注册表值的设置：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

如果 Exchange Server 分析工具发现 SystemPages 的值被设置为 0，并且可用的系统页表条目 (PTE) 数少于 3001，则显示警告。

不管安装了多少物理 RAM，Microsoft Windows Server™ 2003 和 Windows® 2000 Server 可以直接寻址的内存地址空间最多是 4 GB。从进程角度看，虚拟地址的每个元素在概念上都是指一个字节的物理内存。虚拟内存管理器 (VMM) 配合处理器内存管理单元 (MMU) 负责将每个虚拟地址转换或映射到相应的物理地址。VMM 执行映射的过程是：先将 RAM 划分为固定大小的页框架，再创建系统 PTE 来存储有关这些页框架的信息，然后映射它们。系统 PTE 是小型内核模式的内存缓冲区，该缓冲区用来与磁盘 I/O 子系统和网络通信。每个 PTE 代表一个页框架，并包含 VMM 用来定位页的所需信息。

在基于 x86 并使用 4 KB 页大小的系统上，映射 2 GB 地址空间所需的最大 PTE 数是 524,288 (2 GB/4 KB)。在使用 /3GB 开关的类似系统上，映射 3 GB 地址空间所需的 PTE 数是 786,432 (3 GB/4 KB)。在典型系统上，按如下方式使用该空间：

  • 最多 50,000 PTE（大约 195 MB 地址空间）被保留用于常规用途。

  • 其余部分用于映射系统缓存、超空间、页面缓冲池、非页面缓冲池、故障转储区域等等。

该 PTE 池大小是在系统启动时基于系统中的物理内存数量而自动确定的。该池位于页面缓冲池和非页面缓冲池之间，后者也会随系统中的物理内存数量增长。

系统 PTE 池可能被过度使用，并严重碎片化。这可能会导致驱动程序无法加载。而且，如果系统 PTE 池完全耗尽，则系统的其他部分的性能将会降低，甚至造成线程无法创建、系统停止运行和系统可能崩溃。

正常工作的 Exchange Server 计算机应当一直有至少 5,000 个系统 PTE 可用。如果可用的系统 PTE 数低于 5,000 但仍然在 3,001 以上，则会显示在 可用页表条目数达到警告阈值 中所述的警告。当可用的系统 PTE 数低于 3,001 时，则会显示该错误。若要解决该问题，可以使用下面的过程来适当地配置 Exchange Server 计算机的操作系统的 SystemPages 注册表值。在配备 1 GB 或更多 RAM 的 Windows Server 2003 上运行 Exchange Server 2003 Service Pack 1 (SP1) 时，建议将 SystemPages 注册表项设置为 0。该建议与对 Windows 2000 Server 的建议明显不同，后者是将 SystemPages 设置为在 24,000 和 31,000 之间的值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

执行下述过程之后，应当监视可用的系统 PTE 数。可以通过用 Windows 系统监视器（也称为"性能监视器"）监视 Memory | Free System Page Table Entries 性能计数器来监视该数字。如果在进行下面描述的注册表更改之后，可用的系统 PTE 数仍然很低，则应当检查下列内容，以确保 Exchange Server 计算机已进行最佳配置：

  • 驱动程序 出现故障的驱动程序是系统 PTE 较低的一个最常见原因。请咨询硬件制造商，确保所有硬件正在使用最新的驱动程序。也有可能需要降级到更基本的驱动程序。例如，运行基于服务器的应用程序（例如，Exchange Server）的计算机通常不需要有具备所有功能的最高级的视频驱动程序。而更基本的驱动程序通常就已足够。从高级视频驱动程序切换到基本视频驱动程序应当可以增加可用的系统 PTE 数。

  • 系统配置 如果系统安装了 1 GB 或更多物理内存，应当检查并确保它的 Boot.ini 文件正确配置了 /3GB 和 /USERVA=3030 开关。有关这方面的信息，请参阅下列 Microsoft 知识库文章：

    • 823440"在基于 Windows Server 2003 的系统中安装 Exchange Server 2003 时必须使用 /3GB 参数"(http://support.microsoft.com/kb/823440/zh-cn)

    • 810371"XADM:在基于 Windows 2003 Server 的 Exchange Servers 上使用 /Userva 参数"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371)

  • 事件日志 检查 Exchange Server 上的应用程序事件日志中是否有相关的错误和警告，尤其是 MSExchangeIS 事件 9582（错误和警告）、9665（警告）和 12880（错误）。如果出现事件 9665，则还可以说明未将 SystemPages 配置成使系统获得最佳性能的状态。有关这些事件的详细信息，请参阅知识库文章 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://support.microsoft.com/kb/325044/zh-cn)。

在 Windows 2000 Server 上解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. 在右侧窗格中，双击"SystemPages"。

  4. 在"数值数据"字段中，键入在 24000 和 31000（十进制）之间的值，再单击"确定"。

  5. 关闭注册表编辑器，并重新启动计算机，以使更改生效。

在 Windows Server 2003 上解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. 在右侧窗格中，双击"SystemPages"。

  4. 在"数值数据"字段中，键入 0，再单击"确定"。

  5. 关闭注册表编辑器，并重新启动计算机，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关优化 Exchange Server 的内存的详细信息，请参阅下列知识库文章：

  • 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372"如何在 Exchange Server 2003 中优化内存使用"(http://support.microsoft.com/kb/815372/zh-cn)

  • 311901"The effects of 4GT tuning on System Page Table Entries"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


当前等待病毒扫描的持续调用数已接近限制数。
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-13

Microsoft® Exchange Server 分析工具会检查 Exchange 函数调用日志 (FCL)（Store.fcl 文件）以确定当前从 Microsoft Exchange Information Store 服务 (Store.exe) 到病毒 API (VAPI) 组件的持续跨组件调用的数量。

Exchange Server 分析工具还会从下列注册表项中查询 ScanningThreads 键以确定允许用于 VAPI 组件调用的最大线程数：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

持续调用是 Microsoft Exchange Information Store 服务 (Store.exe) 向其他将 Exchange FCL 数据写入 Store.fcl 文件时尚未收到响应的组件发出的请求。

如果 Exchange Server 分析工具发现从 Exchange Information Store 服务 (Store.exe) 到 VAPI 组件的持续调用数达到了允许的最大线程数，则 Exchange Server 分析工具将显示一个错误。

当来自 Microsoft Exchange Information Store 服务 (Store.exe) 的跨组件调用等待响应时，远程过程调用 (RPC) 线程会在这些请求后面备份，并导致出现 Exchange Server 性能问题，如服务器对客户端的响应发生延迟。

从 Microsoft Exchange Information Store 服务到 VAPI 组件的持续调用可由下列情况引起：

  • 对病毒扫描程序的更新，这些更新将生成对信息存储中项目的重新扫描。

  • 病毒扫描程序配置错误

  • 病毒扫描程序软件处理很大的邮件或附件

要解决此错误，请执行下列步骤：

  • 将对病毒引擎进行更新的时间安排在资源占用较少的时间，即非高峰需求间隔。

  • 考虑重新安装病毒扫描软件，但要在非高峰需求间隔进行重新安装。

  • 检查病毒扫描引擎的配置中是否存在正确的线程配置、文件级排除等。请参阅 Microsoft 知识库文章 823166"Exchange Server 2003 和防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)。

  • 增加用于病毒扫描 API 的线程数：

    ScanningThreads 的最佳值等于 (2 * NumberOfProcessors) + 1。例如，对于运行 Exchange Server 并具有两个处理器的服务器，ScanningThreads 的最佳值是 5。

    注意：
    如果启用了超线程，则 NumberOfProcessors 的值将是物理处理器个数的两倍。建议与防病毒软件生产商联系，以确定在此公式中是应使用物理处理器还是应使用逻辑处理器。
重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
增加线程数

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

  3. 在右侧窗格中，双击 ScanningThreads。

  4. 输入从上一公式中返回的值。

  5. 关闭注册表编辑器，然后重新启动 Microsoft Exchange Information Store 服务，以便使更改生效。

在编辑注册表之前，若要了解有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

  • 查看此文档"详细信息"部分中的文章。

详细信息

有关通常与 Microsoft Exchange Server 2003 一起使用的病毒扫描程序的详细信息，请参阅 Microsoft 知识库文章 823166"Exchange Server 2003 和防病毒软件概述"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)。

有关通常与 Microsoft Exchange 2000 Server 一起使用的病毒扫描程序的详细信息，请参阅 Microsoft 知识库文章 328841"Exchange 和防病毒软件"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)。

有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)。

有关如何解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（解决 Microsoft Exchange Server 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)。

有关如何解决信息存储性能问题的详细信息，请参阅 Microsoft 知识库文章 257725"XADM：如何为信息存储故障排除收集诊断数据"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。

有关超线程技术的详细信息，请访问 Intel 网站 (http://www.intel.com/technology/hyperthread)。

注意：
在本主题中提供第三方网站信息是为了帮助您查找所需的技术信息。URL 如有更改，恕不通知。


OABGEN.DLL 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查几个核心 Exchange 二进制文件是否存在：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现一个或多个上述文件丢失，则会显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


获取 Exchange Server 5.0 的最新 Service Pack/更新汇总
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 Exchange Server 对象的 versionNumber 属性值。versionNumber 属性表示运行在计算机上的 Exchange Server 的版本。

Exchange Server 分析工具还查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 STORE.EXE 进程的 Version 关键字的值。如果 Exchange Server 分析工具确定 STORE.EXE 的 Version 关键字的值大于或等于 1460 但小于 1462，则显示警告。

此警告说明 Exchange Server 计算机上所运行的 Exchange 版本的代码不是最新的可用代码。

解决此警告问题

  1. 访问 Microsoft 下载中心 (http://go.microsoft.com/fwlink/?LinkId=41361) 下载 Exchange Server 5.0 的最新更新（2004 年 4 月）。

  2. 阅读 Microsoft 知识库文章 834130"Microsoft Exchange Server 5.0 Update Rollup"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=834130)，了解有关该更新的信息。

  3. 对 Exchange Server 计算机进行完整备份。

  4. 应用 2004 年 4 月更新。

若要获得 Exchange Server 5.0 Service Pack 2 的最新更新汇总，请参阅知识库文章 168858"XGEN:How to Obtain Exchange Server 5.0 U.S. Service Pack 2"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168858)。

有关安装此更新以及其他 Exchange Server 更新的详细信息，请参阅知识库文章 328839"HOW TO：应用 Exchange Service Pack 和修复程序"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)。


获取 Exchange Server 5.5 的最新 Service Pack/更新汇总
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 Exchange Server 对象的 versionNumber 属性的值。versionNumber 属性代表运行在计算机上的 Exchange Server 的版本。

Exchange Server 分析工具还查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 STORE.EXE 进程的 Version 关键字的值。如果 Exchange Server 分析工具确定 STORE.EXE 的 Version 关键字具有大于或等于 2653、但小于 2658 的值，则会显示警告。这意味着计算机运行的是 Exchange Server 5.5 Service Pack 4 或带修补程序的 Exchange Server 5.5 Service Pack 4。

此警告意味着 Exchange Server 计算机未对所运行的 Exchange 版本运行最新的可用代码。

解决此警告问题

  1. 访问 Microsoft 下载中心 (http://go.microsoft.com/fwlink/?LinkId=33456) 下载 Exchange Server 5.5 的最新更新（2004 年 5 月）。

  2. 阅读 Microsoft 知识库文章 841765"May 2004 Update Rollup for Exchange Server 5.5"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=841765)，了解有关该更新的信息。

  3. 创建 Exchange Server 计算机的完整备份。

  4. 应用 2004 年 5 月的更新。

有关安装此更新以及其他 Exchange Server 更新的详细信息，请参阅 Microsoft 知识库文章 328839"HOW TO：应用 Exchange Service Pack 和修复程序"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)。


获取 Exchange Server 2003 的最新 Service Pack/更新汇总
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 Exchange Server 对象的 versionNumber 属性的值。versionNumber 属性表示运行在计算机上的 Exchange Server 的版本。

Exchange Server 分析工具还查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 STORE.EXE 进程的 Version 关键字的值。

  • Version 关键字的值 7638 表示 Exchange Server 2003 Service Pack 2

  • Version 关键字的值 7226 表示 Exchange Server 2003 Service Pack 1

  • Version 关键字的值 6944 表示 Exchange Server 2003 的最初发行版

  • 介于上述版本之间的值表示服务器运行的是 Store.exe 进程的修复程序更新版。

如果 Exchange Server 分析工具确定 Store.exe 的 Version 关键字的值小于 7638，则会显示警告。

此警告意味着 Exchange Server 计算机未运行所运行的 Exchange Server 版本的最新可用代码。

解决此警告问题

  1. 从网站 (http://go.microsoft.com/fwlink/?LinkId=54751) 上的"Service Pack2 for Exchange Server2003"下载或订购 Exchange Server 2003 的 Service Pack 2。

  2. 在网站 (http://go.microsoft.com/fwlink/?LinkId=52072) 的"Exchange Server 2003 Service Pack 2 (SP2) Release Notes"上查看 Service Pack2 发行说明。

  3. 对 Exchange Server 计算机进行完整备份。

  4. 应用 Exchange Server 2003 Service Pack 2。

有关安装此更新以及其他 Exchange Server 更新的详细信息，请参阅 Microsoft 知识库文章 328839"HOW TO：应用 Exchange Service Pack 和修复程序"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)。


获取 Exchange 2000 Server 的最新 Service Pack/更新汇总
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 Exchange Server 对象的 versionNumber 属性的值。versionNumber 属性表示运行在计算机上的 Exchange Server 的版本。

Exchange Server 分析工具还查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 STORE.EXE 进程的 Version 关键字的值。如果 Exchange Server 分析工具确定 STORE.EXE 的 Version 关键字的值属于下列范围之一，则会显示警告：

  • 大于 6249 并且小于或等于 6396

  • 大于 6396 并且小于或等于 6487

  • 大于 6487 并且小于或等于 6556

  • 大于 6556 并且小于或等于 6603

  • 大于 6603 并且小于 6700

此警告说明 Exchange Server 计算机上所运行的 Exchange 版本的代码不是最新的可用代码。

解决此警告问题

  1. 从网站上的"Downloads for Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=33457) 下载最新的更新（2004 年 8 月）。

  2. 查看 Microsoft 知识库文章 870540"Availability of the August 2004 Exchange 2000 Server Post-Service Pack 3 Update Rollup"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540)，了解有关最新更新的信息。

  3. 对 Exchange Server 计算机进行完整备份。

  4. 应用 2004 年 8 月更新。

有关安装此更新以及其他 Exchange Server 更新的详细信息，请参阅知识库文章 328839"HOW TO：应用 Exchange Service Pack 和修复程序"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)。


脱机通讯簿服务器已经删除
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-12-03

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定脱机通讯簿配置对象的 offLineABServer 属性值。如果 Exchange Server 分析工具发现 offLineABServer 属性值包含字符串"DEL:"，则显示错误。

offLineABServer 属性是单值的可分辨名称属性，该属性存储负责生成脱机通讯簿的 Exchange Server 计算机的可分辨名称。对于每个脱机通讯簿，Exchange 将在指定服务器上的一组公用文件夹中生成和存储脱机通讯簿文件。该错误说明脱机通讯簿配置对象的 offLineABServer 属性所指定的服务器不存在。如果旧的脱机通讯簿服务器已退役或从拓扑结构中被错误删除，则会发生这种情况。必须在指定新的服务器之后，Exchange 才会生成脱机通讯簿。

在 Exchange 2000 Server 和 Exchange Server 2003 上更正此错误

  1. 在 Exchange 系统管理器的"收件人"下，单击"脱机地址列表"。在右侧窗格中，右键单击"默认脱机地址列表"（或产生该消息的任何其他脱机地址列表），再单击"属性"。

  2. 在"常规"选项卡的"脱机地址列表服务器"下，单击"浏览"，再单击想要使用的服务器。

在 Exchange Server 2007 上更正此警告

  1. 打开 Exchange 管理控制台。

  2. 展开 Microsoft Exchange，展开"组织配置"，然后选择"邮箱"。

  3. 在结果窗格中，单击"脱机通讯簿"选项卡。

  4. 在"脱机通讯簿"选项卡上，选择"默认脱机通讯簿"。在操作窗格中，单击"移动"以启动"移动脱机通讯簿"向导。通过此向导，可以将 OAB 生成移动到其他服务器。它还会将现有的 OAB 文件复制到指定的服务器。

使用 Exchange 命令行管理程序来设置将承载脱机通讯簿生成的服务器

  • 运行下列命令：

    复制代码
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    其中：<OAB> 是可分辨名称 (DN)、域\帐户名称或 OAB 的 GUID，而 <Server> 则指定了将在其上执行所选操作的 Exchange 服务器。

    例如，若要将 OAB 生成移至 SERVER01.，应输入：
复制代码
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

有关在 Exchange Server 2003 中使用脱机通讯簿的详细信息，请参阅 Working with the Exchange Server 2003 Store（使用 Exchange Server 2003 存储）中的"Configuring Exchange Server 2003 Offline Address Books"（配置 Exchange Server 2003 脱机通讯簿）(http://go.microsoft.com/fwlink/?LinkId=47595)。

有关在 Exchange Server 2007 中使用脱机通讯簿的详细信息，请参阅"Organization Configuration > Mailbox > Offline Address Books"（组织配置 > 邮箱 > 脱机通讯簿）(http://go.microsoft.com/fwlink/?LinkId=79247)。


脱机通讯簿服务器正在前端服务器上运行
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定脱机通讯簿配置对象的 offLineABServer 属性的值。offLineABServer 属性为单值可分辨名称属性，该属性存储负责生成脱机通讯簿的 Exchange Server 计算机的可分辨名称。

Exchange Server 分析工具还查询 Exchange_Server Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange 服务器的 IsFrontEndServer 关键字的值。如果 IsFrontEndServer 关键字的值为 True，那么 Exchange 服务器正在充当前端服务器。

如果 Exchange Server 分析工具确定指定的脱机通讯簿服务器也是前端服务器，则将显示错误消息。

此错误表明为生成脱机通讯簿指定的 Exchange 服务器是前端服务器。如果指定的脱机通讯簿服务器也是前端服务器，则脱机通讯簿的生成将失败。应为此任务指定新的服务器。如果指定为前端服务器的服务器运行的是使用 Service Pack 2 或更高版本的 Microsoft Exchange 2000 Server，下列服务将不再运行：

  • DSProxy

  • 脱机地址列表生成

  • 收件人更新服务

  • 忙/闲任务

  • 邮箱清理代理

  • Exchange 事件服务

  • 站点复制服务 (SRS)

前端服务器用于处理从配置为使用 RPC over HTTP 的 Microsoft Office Outlook® Web Access、POP3、IMAP4、Exchange ActiveSync、Outlook Mobile Access 和 Outlook 客户端传入的客户端请求。有时，前端服务器还用于将 SMTP 邮件中继到内部 Exchange 服务器。

为了解决此问题，建议您将后端 Exchange 服务器指定为脱机通讯簿服务器。

更正此错误

  1. 打开 Exchange 系统管理器

  2. 在"收件人"中，单击"脱机地址列表"。

  3. 在右侧窗格中，用鼠标右键单击"默认脱机地址列表"，再单击"属性"。

    注意：
    对任何其他生成此消息的脱机地址列表执行同样的操作。

  4. 在"常规"选项卡的"脱机地址列表服务器"下，单击"浏览"，再单击要使用的后端 Exchange 服务器。

有关如何使用脱机通讯簿的详细信息，请参阅"使用 Exchange Server 2003 存储"中的"配置 Exchange Server 2003 脱机通讯簿"(http://www.microsoft.com/downloads/details.aspx?FamilyID=9d438545-7697-4384-bd24-87e0cd3378cd&DisplayLang=zh-cn)。


脱机通讯簿站点公用文件夹已删除
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-12-03

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个公用文件夹存储对象的 siteFolderServer 属性的值。如果 Exchange Server 分析工具发现 siteFolderServer 属性值包含字符串"DEL:"，则显示错误。

siteFolderServer 属性代表用于脱机通讯簿服务器的公用文件夹存储。默认情况下，Exchange Server 在站点文件夹服务器（安装在管理组中的第一个服务器）上生成脱机通讯簿文件。如果已经指定了另外一个服务器充当脱机通讯簿服务器，则该属性中列出的公用文件夹存储将是新的脱机通讯簿服务器上的存储，而不是管理组的实际站点文件夹服务器上的存储。

Exchange Server 2003 生成脱机通讯簿文件时，会将这些文件附加到邮件中，并将邮件放入特殊的公用文件夹。Microsoft Office Outlook® 2003 从文件夹中检索该邮件，并下载所附文件。

脱机通讯簿邮件存储在脱机通讯簿文件夹的子文件夹中，脱机通讯簿文件夹是默认的公用文件夹树中的一个系统文件夹。拓扑结构中的每个管理组或站点在该文件夹中都有一个子文件夹。默认情况下，特定管理组文件夹的内容副本驻留在该管理组中安装的第一台服务器（称为"站点文件夹服务器"）上。

如果您的 Exchange 组织是 Exchange Server 2007，且不包含任何下级（Outlook 2003 或更低版本）客户端，则可以放心地忽略此警告或错误。如果您的 Exchange Server 2007 组织承载了运行 Outlook 2003 或更低版本的客户端，请按照以下步骤启用脱机通讯簿文件的公用文件夹通讯组。公用文件夹通讯组是一种通讯组方法，运行脱机工作或通过拨号连接的 Outlook 2003 或更低版本的客户端可通过该方法访问 OAB。

更正此错误

  1. 如果您确定此服务器确实存在，请在 Exchange 系统管理器的"服务器"下，展开服务器，展开存储组，再单击"公用文件夹存储"。查看右侧窗格以确保 Exchange 存储正在运行。

  2. 若要指定新的脱机通讯簿服务器，请在"收件人"下单击"脱机地址列表"。然后在右侧窗格中，单击"默认脱机地址列表"（或生成此消息的任何其他脱机地址列表）。

    如果不想使用脱机通讯簿，请右键单击"默认脱机地址列表"，再单击"删除"。否则，使用该过程的其余步骤设置一个日程安排。

  3. 右键单击"默认脱机地址列表"，再单击"属性"。

  4. 在"常规"选项卡的"脱机地址列表服务器"下，单击"浏览"选择一个服务器。

在·Exchange·Server·2007·上更正此警告

  1. 打开 Exchange 管理控制台。

  2. 展开 Microsoft Exchange，展开"组织配置"，然后选择"邮箱"。

  3. 在结果窗格中，单击"脱机通讯簿"选项卡。

  4. 在"脱机通讯簿"选项卡上，选择"默认脱机通讯簿"。

    1. 若要启用脱机通讯簿的公用文件夹通讯组，请在"通讯组"选项卡上选择"启用公用文件夹通讯组"。

    2. 单击"确定"保存更改

  5. 若要指定新的脱机通讯簿服务器，请在操作窗格中，单击"移动"来启动"移动脱机通讯簿向导"。通过此向导，可以将 OAB 生成移动到其他服务器。它还会将现有的 OAB 文件复制到指定的服务器。

使用 Exchange 命令行管理程序启用脱机通讯簿文件的公用文件夹通讯组。

  • 运行下列命令：

    复制代码
    Set-OfflineAddressBook -Identity <OAB> -PublicFolderDistributionEnabled $true

    其中：<OAB> 是可分辨名称 (DN)、域\帐户名称或 OAB 的 GUID。

    例如，若要启用默认脱机通讯簿的公用文件夹通讯组，应输入：
复制代码
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -PublicFolderDistributionEnabled $true

使用 Exchange 命令行管理程序来设置将承载脱机通讯簿生成的服务器

  • 运行下列命令：

    复制代码
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    其中：<OAB> 是可分辨名称 (DN)、域\帐户名称或 OAB 的 GUID，而 <Server> 则指定了将在其上执行所选操作的 Exchange 服务器。

    例如，若要将 OAB 生成移至 SERVER01.，应输入：
复制代码
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

有关在 Exchange Server 2003 中使用脱机通讯簿的详细信息，请参阅 Working with the Exchange Server 2003 Store（使用 Exchange Server 2003 存储）中的"Configuring Exchange Server 2003 Offline Address Books"（配置 Exchange Server 2003 脱机通讯簿）(http://go.microsoft.com/fwlink/?LinkId=47595)。

有关在 Exchange Server 2007 中使用脱机通讯簿的详细信息，请参阅"Organization Configuration > Mailbox > Offline Address Books"（组织配置 > 邮箱 > 脱机通讯簿）(http://go.microsoft.com/fwlink/?LinkId=79247)。


检测到较旧的 CDO.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定下列几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则显示警告。早期版本号表明可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


检测到较旧的 DAVEX.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定下列几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则显示警告。早期版本号表明可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


检测到较旧的 DRVIIS.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-10-06

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • DrvIis.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中任何一个文件的 Version 值小于 Exchange Server 的 Version 值，则会显示警告。早期版本号表示可能在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，然后选择"重新安装"。如果以重新安装模式运行安装程序，则将只安装二进制文件。重新安装模式不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或更新。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。在 CD 驱动器中插入 Exchange 2000 Server 或 Exchange Server 2003 CD。

  2. 单击"开始"，再单击"运行"，然后键入 <drive>:\setup\i386\setup<，其中 <drive> 是指 CD 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，然后单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（Exchange Server 2003 的下载）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（Exchange 2000 Server 的下载）(http://go.microsoft.com/fwlink/?LinkId=33457)。


检测到较旧的 DSACCESS.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则会显示警告。早期版本号表明可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。以重新安装模式运行安装程序将仅安装二进制文件，不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，再单击"下一步"。

  6. 在"组件选择"页的"操作"列中，使用"Microsoft Exchange"节点旁边的下拉箭头选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


检测到较旧的 EMSMTA.EXE 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定下列几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则显示警告。早期版本号表明可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


检测到较旧的 EPOXY.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定下列几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则显示警告。早期版本号表明可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


检测到较旧的 ESE.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-06-20

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则会显示警告。早期版本号表明可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


检测到较旧的 ESEUTIL.EXE 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定下列几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则显示警告。早期版本号表明可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


检测到较旧的 EXCDO.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定下列几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则显示警告。早期版本号表明可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


检测到较旧的 EXCHMEM.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定下列几个核心 Exchange 二进制文件的 Version 项的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则显示警告。早期版本号表明可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


存在较旧的 EXCHMEM.DLL
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定几个核心 Exchange Server 二进制文件的 Version 关键字的值。这些文件包括 Exchmem.dll。如果 Exchange Server 分析工具确定 \%systemroot%\system32 文件夹中的 Exchmem.dll 文件比 \%exchangeroot%\bin 文件夹中的 Exchmem.dll 文件要旧，则会显示警告。

通常，服务器上不会存在两个 Exchmem.dll 副本。但是，有时会添加第二个 Exchmem.dll 文件，包含从产品的上一个发行版的就地升级。该文件存在两个版本可能会造成安装服务发行版时失败。为了避免出现问题，建议您重命名 \%systemroot%\system32 文件夹中的 Exchmem.dll 文件。

解决此警告问题

  1. 停止所有 Exchange 服务。

  2. 将 \%systemroot%\system32 文件夹中的 Exchmem.dll 文件重命名为 Exchmem.dll.old。

  3. 重新启动所有 Exchange 服务。


检测到较旧的 EXMIME.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则会显示警告。早期版本号表明可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


检测到较旧的 EXOLEDB.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定下列几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则显示警告。早期版本号表明可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


检测到较旧的 EXPOP3.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定下列几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则显示警告。早期版本号表明可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


检测到较旧的 EXPROX.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定下列几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则显示警告。早期版本号表明可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


检测到较旧的 EXRES.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则会显示警告。早期版本号表明可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2000"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


检测到较旧的 EXSMTP.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则会显示警告。早期版本号表明可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


检测到较旧的 MAD.EXE 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定下列几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则显示警告。早期版本号表明可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


检测到较旧的 MAPI32.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定下列几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则显示警告。早期版本号表明可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


在 system32 文件夹中检测到较旧的 MAPI32.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定下列几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则显示警告。早期版本号表明可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


检测到较旧的 MDBSZ.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定下列几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则显示警告。早期版本号表明可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


检测到较旧的 OABGEN.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定下列几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则显示警告。早期版本号表明可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


检测到较旧的 PHATCAT.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则会显示警告。早期版本号表明可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


检测到较旧的 PHATQ.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定下列几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则显示警告。早期版本号表明可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


检测到较旧的 REAPI.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则会显示警告。早期版本号表明可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


检测到较旧的 RESVC.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现上述任一文件的 Version 值小于 Exchange Server 的 Version 值，则会显示警告。较早的版本号说明可能正在使用过时的文件。

若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


检测到较旧的 STORE.EXE 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-10-06

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定几个核心 Exchange 二进制文件的 Version 关键字的值：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中任何一个文件的 Version 值小于 Exchange Server 的 Version 值，则会显示警告。早期版本号表示可能正在使用过时文件。

若要更正此错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，然后选择"重新安装"。如果以重新安装模式运行安装程序，则将只安装二进制文件。重新安装模式不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或更新。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。在 CD 驱动器中插入 Exchange 2000 Server 或 Exchange Server 2003 CD。

  2. 单击"开始"，再单击"运行"，然后键入 <drive>:\setup\i386\setup，其中 <drive> 是指 CD 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，然后单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange Server 2003"（Exchange Server 2003 的下载）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅"Downloads for Exchange 2000 Server"（Exchange 2000 Server 的下载）(http://go.microsoft.com/fwlink/?LinkId=33457)。


发现对 Active Directory 的持续调用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-14

Microsoft® Exchange Server 分析工具会检查 Exchange 函数调用日志 (FCL)（Store.fcl 文件）中的某类事件，此类事件表明从 Microsoft Exchange Information Store 服务 (Store.exe) 到 Active Directory® 目录服务的持续跨组件调用。

持续调用是 Microsoft Exchange Information Store 服务 (Store.exe) 向其他将 Exchange FCL 数据写入 Store.fcl 文件时尚未收到响应的组件发出的请求。

Active Directory 提供所有邮箱信息、地址列表服务以及其他与收件人有关的信息。大多数 Exchange Server 2003 配置信息也存储在 Active Directory 中。

Exchange Server 服务会访问存储在 Active Directory 中的信息，并将信息写入到 Active Directory 中。

如果 Exchange Server 分析工具发现 Store.fcl 日志记录文件中的事件反映出从 Microsoft Exchange Information Store 服务 (Store.exe) 到 Active Directory 的持续调用，则 Exchange Server 分析工具会显示警告。

此警告表明，性能可能将成为此服务器的问题。偶尔的持续调用不一定表示存在问题，但对同一区域的反复持续调用可能表示存在问题。

当来自 Microsoft Exchange Information Store 服务 (Store.exe) 的跨组件调用等待响应时，远程过程调用 (RPC) 线程会在这些请求后面备份，并导致出现 Exchange Server 性能问题，如服务器对客户端的响应发生延迟。

从 Microsoft Exchange Information Store 服务到 Active Directory 的持续调用可由下列情况引起：

  • Exchange 服务器和域控制器之间的网络延迟。

  • DSAccess 的静态配置或错误配置。

  • 超载的域控制器和全局编录。

  • Active Directory 拓扑设计错误。

要解决此警告，请执行下列步骤：

  • 运行 Exchange Server 分析工具以进行其他的服务器问题分析。可在"Microsoft Exchange Server Best Practices Analyzer Tool v2.7"（Microsoft Exchange Server 最佳实践分析工具 v2.7）(http://go.microsoft.com/fwlink/?LinkId=34705) 上下载 Exchange Server 分析工具。

  • 检查 Active Directory 域控制器服务器的性能。

  • 查看此文档"详细信息"部分中的文章。

详细信息

有关 Exchange 性能和 DSAccess 的详细信息，请参阅 Microsoft 知识库文章 250570"Directory Service Server Detection and DSAccess Usage"（目录服务服务器检测和 DSAccess 用法）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570)。

有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)。

有关如何解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（解决 Microsoft Exchange Server 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)。

有关如何解决信息存储性能问题的详细信息，请参阅 Microsoft 知识库文章 257725"XADM：如何为信息存储故障排除收集诊断数据"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。

有关域控制器性能的详细信息，请参阅以下 Windows Server 资源：

  • "Planning Domain Controller Capacity"（规划域控制器容量）(http://go.microsoft.com/fwlink/?LinkId=70191)。

  • "Windows 2000 Server Active Directory Planning and Deployment Guides"（Windows 2000 Server Active Directory 规划和部署指南）中的"Active Directory Monitoring of Domain Controllers"（域控制器的 Active Directory 监视）(http://go.microsoft.com/fwlink/?LinkId=70193)。


发现对 ESE 的持续调用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-13

Microsoft® Exchange Server 分析工具会检查 Exchange 函数调用日志 (FCL)（Store.fcl 文件）中的某类事件，此类事件表示从 Microsoft Exchange Information Store 服务 (Store.exe) 到 Exchange 可扩展存储引擎 (ESE) 的持续跨组件调用。

持续调用是 Microsoft Exchange Information Store 服务 (Store.exe) 向其他将 Exchange FCL 数据写入 Store.fcl 文件时尚未收到响应的组件发出的请求。

Microsoft Exchange Information Store 位于可扩展存储引擎 (ESE) 数据库的顶部。ESE 是复杂的、基于事务的数据库引擎。事务是一系列被视为原子（不可划分）单位的操作。对于一个事务中的所有操作，要么将其完成并永久保存，要么不执行任何操作。

Exchange Server 使用 ESE 作为嵌入数据库引擎，该引擎决定数据库的结构并管理内存。数据库引擎通过将数据块（页）传进和传出内存，从而在内存中缓存数据库。它更新内存中的数据页，并将新的数据页或经过更新的数据页写入磁盘。当请求到达系统时，数据库引擎可以在内存中缓冲数据。因此其不必经常访问磁盘。

虽然在内存中缓存数据是处理数据的最快和最有效方式，但它意味着 Exchange 正在运行时，磁盘上的信息永远不是完全最新的。数据库的最新版本存于内存中。但是，因为内存中的许多更改尚未保存在磁盘上，所以数据库和内存不同步。事务日志磁盘将始终与有关每个事务的信息保持一致。

如果 Exchange Server 分析工具发现 Store.fcl 日志记录文件中的事件反映出从 Microsoft Exchange Information Store 服务 (Store.exe) 到可扩展存储引擎 (ESE) 数据库的持续调用，则 Exchange Server 分析工具将显示警告。

此警告表明，性能可能将成为此服务器的问题。偶尔的持续调用不一定表示存在问题，但对同一区域的反复持续调用可能表示存在问题。

当来自 Microsoft Exchange Information Store 服务 (Store.exe) 的跨组件调用等待响应时，远程过程调用 (RPC) 线程会在这些请求后面备份，并导致出现 Exchange Server 性能问题，如服务器对客户端的响应发生延迟。

从 Microsoft Exchange Information Store 服务到可扩展存储引擎 (ESE) 的持续调用可由下列情况引起：

  • Exchange 联机碎片整理。

  • 数据备份。

    注意：
    如果在 Exchange 调用跟踪日志记录收集期间进行数据备份或联机碎片整理，则可安全地忽略此警告，而不将其作为 Exchange Server 性能问题的标志。
  • 数据库驱动器上的瓶颈，例如，对于服务器上的用户数而言，容量不足。

  • TEMP 和 TMP 驱动器上的瓶颈。

若要解决此错误，请执行下列步骤：

  • 作为最佳做法，建议不要将备份窗口或联机维护与高峰用户需求间隔重叠。

  • 请确保数据库磁盘驱动器运行状况良好并对于 I/O 负载而言具有足够的吞吐量。

  • 运行 Exchange Server 分析工具以进行其他的服务器问题分析（如邮件和附件大小限制）。可在"Microsoft Exchange Server Best Practices Analyzer Tool v2.7"（Microsoft Exchange Server 最佳实践分析工具 v2.7）(http://go.microsoft.com/fwlink/?LinkId=34705) 上下载 Exchange Server 分析工具。

  • 查看此文档"详细信息"部分中的文章。

详细信息

有关如何配置联机碎片整理时间范围的详细信息，请参阅 Microsoft 知识库文章 244524"XADM：如何配置 Exchange Server 联机碎片整理时间范围"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524)。

有关 Exchange Server 磁盘瓶颈问题的详细信息，请参阅检测到磁盘瓶颈。

有关如何调整 Exchange Server 磁盘大小并对该磁盘进行优化的详细信息，请参阅"Optimizing Storage for Exchange Server 2003"（优化用于 Exchange Server 2003 的存储）中的"How to Calculate Your Disk I/O Requirements"（如何计算磁盘 I/O 需求）和"Best Practices Common to Multiple Architectures"（多种体系结构通用的最佳做法）(http://go.microsoft.com/fwlink/?linkid=49324)。

有关 ESE 的详细信息，请参阅"Extensible Storage Engine Architecture"（可扩展存储引擎体系结构）(http://go.microsoft.com/fwlink/?linkid=67009)。


发现对 IMail 的持续调用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-13

Microsoft® Exchange Server 分析工具会检查 Exchange 函数调用日志 (FCL)（Store.fcl 文件）中的某类事件，此类事件表明从 Microsoft Exchange Information Store 服务 (Store.exe) 到 MAPI 客户端的 IMAIL 组件的持续跨组件调用。

持续调用是 Microsoft Exchange Information Store 服务 (Store.exe) 向其他将 Exchange FCL 数据写入 Store.fcl 文件时尚未收到响应的组件发出的请求。

Exchange Server 的 IMAIL 组件是一种灵活的转换服务，Microsoft Exchange Information Store 服务会在 Internet 邮件和 MAPI 邮件之间使用该转换服务。此组件可以实现使用 RFC-822 或 Internet 格式的客户端和使用 Exchange Server 内部存储格式的客户端（如 MAPI 客户端或内部存储任务）之间的互操作性。

Exchange 使用 IMAIL 机制对内容应用邮件格式，这些格式是在 Exchange 系统管理器中对 Internet 域所指定的，或者是由用户在 Microsoft Office Outlook® 中针对每个收件人所指定的。+如果没有向 IMAIL 传递任何格式参数，则 IMAIL 会将 MAPI 邮件设置为 Summary TNEF (S/TNEF) 格式以便进行服务器之间的传输。

如果 Exchange Server 分析工具发现 Store.fcl 日志记录文件中的事件反映出从 Microsoft Exchange Information Store 服务 (Store.exe) 到 MAPI 客户端的 IMAIL 组件的持续调用，则 Exchange Server 分析工具会显示一条警告。

此警告表明，性能可能将成为此服务器的问题。偶尔的持续调用不一定表示存在问题，但对同一区域的反复持续调用可能表示存在问题。

当来自 Microsoft Exchange Information Store 服务 (Store.exe) 的跨组件调用等待响应时，远程过程调用 (RPC) 线程会在这些请求后面备份，并导致出现 Exchange Server 性能问题，如服务器对客户端的响应发生延迟。

当满足以下一个或多个条件时，会发生从 Exchange Information Store 服务到 MAPI 客户端的 IMAIL 组件的持续调用：

  • IMAIL 尝试处理某个邮件或附件中的许多数据。

  • 许多客户端请求进行数据转换

  • 对 DSAccess 请求的响应速度很慢。

  • TEMP 和 TMP 驱动器上存在瓶颈。

  • 存在持续的邮箱移动。

要解决此警告，请执行下列步骤：

  • 将进行任何邮箱移动的时间安排在非高峰需求间隔内。

  • 运行 Exchange Server 分析工具以进行其他的服务器问题分析（如邮件和附件大小限制）。可在"Microsoft Exchange Server Best Practices Analyzer Tool v2.7"（Microsoft Exchange Server 最佳实践分析工具 v2.7）(http://go.microsoft.com/fwlink/?LinkId=34705) 上下载 Exchange Server 分析工具。

  • 查看此文档"详细信息"部分中的文章。

详细信息

有关 Exchange Server 的磁盘瓶颈问题的详细信息，请参阅检测到磁盘瓶颈。

有关如何调整 Exchange Server 磁盘大小并对该磁盘进行优化的详细信息，请参阅"Optimizing Storage for Exchange Server 2003"（优化用于 Exchange Server 2003 的存储）中的"How to Calculate Your Disk I/O Requirements"（如何计算磁盘 I/O 需求）和"Best Practices Common to Multiple Architectures"（多种体系结构通用的最佳做法）(http://go.microsoft.com/fwlink/?linkid=49324)。

有关针对 Exchange Server 上邮件大小限制的最佳做法的详细信息，请参阅未设置最大传出邮件大小。

有关 DSAccess 和 Exchange Server 性能的详细信息，请参阅"Exchange Server 2003 性能和可伸缩性指南"中的"如何配置 DSAccess 用户缓存"(http://go.microsoft.com/fwlink/?LinkId=47576)。

有关如何解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（解决 Microsoft Exchange Server 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)。

有关如何解决信息存储性能问题的详细信息，请参阅 Microsoft 知识库文章 257725"XADM：如何为信息存储故障排除收集诊断数据"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。


发现对 LSASS 的持续调用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-13

Microsoft® Exchange Server 分析工具会检查 Exchange 函数调用日志 (FCL)（Store.fcl 文件）中的某类事件，此类事件表明从 Exchange Information Store 服务 (Store.exe) 到本地安全身份验证服务器 (Lsass.exe) 进程的持续跨组件调用。

持续调用是 Microsoft Exchange Information Store 服务 (Store.exe) 向其他将 Exchange FCL 数据写入 Store.fcl 文件时尚未收到响应的组件发出的请求。

本地安全身份验证服务器进程 (Lsass.exe) 是由其他进程调用的一种安全子系统，用以验证帐户信息和登录验证。

Exchange 客户端的每次登录都会使运行 Exchange Server 的服务器发送一个请求以查找该客户端的帐户安全标识符 (SID)，并会在本地安全身份验证服务器 (Lsass.exe) 进程中创建一个调用。

如果 Exchange Server 分析工具发现 Store.fcl 日志记录文件中的事件反映出从 Microsoft Exchange Information Store 服务 (Store.exe) 到本地安全身份验证服务器 (Lsass.exe) 进程的持续调用，则 Exchange Server 分析工具会显示一个警告。

此警告表明，性能可能将成为此服务器的问题。偶尔的持续调用不一定表示存在问题，但对同一区域的反复持续调用可能表示存在问题。

当来自 Microsoft Exchange Information Store 服务 (Store.exe) 的跨组件调用等待响应时，远程过程调用 (RPC) 线程会在这些请求后面备份，并导致出现 Exchange Server 性能问题，如服务器对客户端的响应发生延迟。

从 Exchange Information Store 服务到 LSASS 进程的持续调用可由下列情况引起：

  • 与同时进行身份验证的用户数有关的服务器资源问题。

  • Exchange 服务器和域控制器或全局编录服务器之间的网络延迟。

  • 服务器资源瓶颈问题。

要解决此警告，请执行下列步骤：

  • 考虑按照推荐的"NeverPing"参数中所述，设置 NeverPing 参数

  • 查看此文档"详细信息"部分中的文章。

详细信息

有关 Lsass.exe 进程和内存使用量的详细信息，请参阅 Microsoft 知识库文章 308356"运行 Windows Server 2003 或 Windows 2000 Server 的域控制器上 Lsass.exe 进程的内存使用量"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)。

有关 Exchange 客户端登录和 LSASS 问题的详细信息，请参阅 Microsoft 知识库文章 161938"Slow Exchange Client Logons Due to Resource Deadlock"（由于资源死锁导致 Exchange 客户端登录速度很慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938)。

有关 Exchange 服务器和域控制器或全局编录服务器之间网络延迟的详细信息，请参阅以下 Exchange Server 工作组博客文章"Exchange Does Not Always Use Local GCs"（Exchange 并不总是使用本地 GC）(http://go.microsoft.com/fwlink/?LinkId=69166)。

注意：
每篇博客的内容及其 URL 都可能随时更改，恕不另行通知。

有关服务器资源瓶颈问题的详细信息，请参阅处理器瓶颈。

有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)。

有关如何解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（解决 Microsoft Exchange Server 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)。

有关如何解决信息存储性能问题的详细信息，请参阅 Microsoft 知识库文章 257725"XADM：如何为信息存储故障排除收集诊断数据"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。


发现对病毒扫描的持续调用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-13

Microsoft® Exchange Server 分析工具会检查 Exchange 函数调用日志 (FCL)（Store.fcl 文件）中的某类事件，此类事件表明从 Microsoft Exchange Information Store 服务 (Store.exe) 到 Virusscan 病毒 API (VAPI) 组件的持续跨组件调用。

持续调用是 Microsoft Exchange Information Store 服务 (Store.exe) 向其他将 Exchange FCL 数据写入 Store.fcl 文件时尚未收到响应的组件发出的请求。

如果 Exchange Server 分析工具发现 Store.fcl 日志记录文件中的事件反映出从 Microsoft Exchange Information Store 服务 (Store.exe) 到 VAPI 组件的持续调用，则 Exchange Server 分析工具会显示警告。

此警告表明，性能可能将成为此服务器的问题。偶尔的持续调用不一定表示存在问题，但对同一区域的反复持续调用可能表示存在问题。

当来自 Microsoft Exchange Information Store 服务 (Store.exe) 的跨组件调用等待响应时，远程过程调用 (RPC) 线程会在这些请求后面备份，并导致出现 Exchange Server 性能问题，如服务器对客户端的响应发生延迟。

从 Microsoft Exchange Information Store 服务到 VAPI 组件的持续调用可由下列情况引起：

  • 对病毒扫描程序的更新，这些更新将生成对信息存储中项目的重新扫描。

  • 病毒扫描程序配置错误

  • 病毒扫描程序软件处理很大的邮件或附件。

若要解决此警告，请执行下列步骤：

  • 将对病毒引擎进行更新的时间安排在资源占用较少的时间，即非高峰需求间隔。

  • 考虑重新安装病毒扫描软件，但要在非高峰需求间隔进行重新安装。

  • 检查病毒扫描引擎的配置中是否存在正确的线程配置、文件级排除等。请参阅 Microsoft 知识库文章 823166"Exchange Server 2003 和防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)。

  • 查看此文档"详细信息"部分中的文章。

详细信息

有关通常与 Microsoft Exchange Server 2003 一起使用的病毒扫描程序的详细信息，请参阅 Microsoft 知识库文章 823166"Exchange Server 2003 和防病毒软件概述"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)。

有关通常与 Microsoft Exchange 2000 Server 一起使用的病毒扫描程序的详细信息，请参阅 Microsoft 知识库文章 328841"Exchange 和防病毒软件"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)。

有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)。

有关如何解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（解决 Microsoft Exchange Server 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)。

有关如何解决信息存储性能问题的详细信息，请参阅 Microsoft 知识库文章 257725"XADM：如何为信息存储故障排除收集诊断数据"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。


设置了操作系统 GlobalFlag
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 GlobalFlag 关键字的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager

如果 Exchange Server 分析工具发现 GlobalFlag 的值存在，并被配置为 0 或 Null 以外的任意值，则显示警告。

  • GlobalFlag 注册表值设置是一个位掩码，它确定已对操作系统启用了哪些调试选项。除非您正在 Microsoft 产品支持服务的帮助下对问题进行调试或跟踪，否则建议在任何时候都将 GlobalFlag 值设置为 0。

GlobalFlag 注册表值默认情况下设置为 0。如果该值已改为默认值 0 以外的值，则您可以使用 Microsoft Windows Server™ 2003 支持工具（可以在 Windows Server 2003 CD-ROM 的 \Support 文件夹中找到）中包含的 Gflags 工具。或者，可以通过使用注册表编辑器手动将该值设置为 0。下面分别介绍了上面提到的两个过程。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

使用 GFlags 更正此错误

  1. 单击"开始"，再单击"运行"，然后在"打开"字段中键入 GFlags。将出现 Global Flags 用户界面。

  2. 清除所有复选框，再单击 Apply。

  3. 单击 OK退出 GFlags 工具，并重新启动计算机，以使更改生效。

使用注册表编辑器更正此错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\ System\CurrentControlSet\Control\Session Manager

  3. 双击名为 GlobalFlag 的值，将它的值数据设置为 0。

  4. 退出注册表编辑器，并重新启动计算机，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


此操作系统处于调试模式
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定是否为 Debug 属性设置了值。如果 Exchange Server 计算机上的该关键字的值设置为 True，则会显示错误。

Windows 调试模式是通过在 Boot.ini 文件中添加 /debug 参数来切换的。如果在 Windows Server 计算机的 Boot.ini 文件中指定了 /debug，内核调试程序将在启动过程中加载并将一直保留在内存中。这样支持专家便可以拨入到所调试的系统并进入调试程序，即便系统未在 Kernel STOP 屏幕挂起也是如此。与 /crashdebug 开关不同，/debug 开关无论您是否正在进行调试都使用 COM 端口。此开关在调试定期出现的问题时使用。/debug 参数可能是作为一种解决问题的手段而设置的，而并非是意外地设置的。

由于同时运行了其他进程，因此性能受到严重的影响。因此，不建议在以调试模式运行 Windows 的计算机上运行 Exchange Server。

要消除此错误，请编辑 Boot.ini 文件并删除 /debug 参数。

更正此错误

  1. 在 Windows 资源管理器中，导航到系统分区。这是存放硬件特定文件（如 Boot.ini 和 NTLDR）的分区。

  2. 如果看不到 Boot.ini 文件，可能是由于"文件夹选项"设置为"隐藏受保护的操作系统文件"。如果是这种情况，请在 Windows 资源管理器窗口中，单击"工具"，再单击"文件夹选项"，然后单击"查看"。清除"隐藏受保护的操作系统文件（推荐）"复选框。当提示您确认时，单击"是"。

  3. 当 Boot.ini 文件显示在 Windows 资源管理器中后，用鼠标右键单击该文件，再单击"打开方式"，然后选择"记事本"打开该文件。

  4. 在 Operating Systems 部分，删除 /debug 参数。

  5. 保存并关闭文件，然后重新启动 Exchange Server 计算机，以使更改生效。

有关 Boot.ini 文件可以使用的参数的详细信息，请参阅 Microsoft 知识库文章 833721"Windows XP 和 Windows Server 2003 的 Boot.ini 文件的可用开关选项"(http://support.microsoft.com/kb/833721/zh-cn)。


Outlook Web Access 要求安装 Windows Server 2003 SP1 修补程序
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-08-28

Microsoft® Exchange Server 分析工具查询各种 Microsoft Windows® Management Instrumentation (WMI) 类，以收集下列信息：

  • Exchange Server 安装在哪个版本的 Microsoft Windows Server 操作系统上？

  • Exchange 服务器是运行在群集上吗？

如果确定下列条件为真，Exchange Server 分析工具将显示警告：

  • 安装了 Exchange Server 2003 Service Pack 1 (SP1)。

  • 未安装 Microsoft Windows Server™ 2003 SP1。

  • 群集服务正在运行。

  • Davex.dll 的 Version 值低于 6.5.7232。

如果运行的是该配置，则在安装 Windows Server 2003 SP1 之前必须下载并安装 Exchange Server 修补程序。如果不安装 Exchange Server 修补程序，Microsoft Office Outlook® Web Access for Exchange Server 2003 用户将无法登录到自己的邮箱。对于拥有驻留在群集上的邮箱的用户，在尝试使用 Outlook Web Access 进行连接时，将收到以下错误消息：

  • "500 - 内部服务器错误"

该错误是由 Windows Server 2003 SP1 附带的一些安全性增强功能所导致的。

用户尝试使用 Outlook Web Access 登录到邮箱时，HTTP 会模拟登录用户向群集 API 提交请求。但是，Windows Server 2003 SP1 中已更改了某些安全功能。对于执行远程注册表访问的 API 的安全限制已更改。因此，登录尝试没有成功。

要解决此错误，必须下载并安装 Exchange Server 修补程序，Microsoft 知识库文章 841561"当用户尝试使用 Outlook Web Access 访问群集 Exchange Server 2003 后端服务器时出现"500 - 内部服务器错误"错误消息"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841561) 描述了该修补程序。


Outlook Web Access 模板文件不匹配
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Wmtemplates.dll 文件的版本号。然后，Exchange Server 分析工具将比较管理组中所有服务器上的 Wmtemplates.dll 的版本号。如果 Exchange Server 分析工具发现前端和后端 Exchange 服务器之间的 Wmtemplates.dll 的版本号不匹配，则显示最佳做法消息。

Wmtemplates.dll 文件通过 Microsoft Office Outlook® Web Access 控件使用。如果前端和后端 Exchange 服务器上的 Wmtemplates.dll 版本不匹配，在用户尝试通过访问前端 Exchange 服务器登录到 Outlook Web Access 时，可能造成 400 级别的错误。

Microsoft 最近发布了两个用于更新 Wmtemplates.dll 的更新：

  • "Microsoft Exchange Information Store service crashes periodically after you install Exchange Server 2003 SP1"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=872963)

  • "The S/MIME control does not load in OWA when you are running the Exchange Server 2003 OWA client on a Windows XP Service Pack 2-based computer"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=883543)

如果您最近安装了其中任意一个更新，可能是发生了下列情况：

  • 安装更新的顺序不正确。

  • 更新未同时安装在前端和后端服务器上。

在安装 Outlook Web Access 的更新时，应在前端服务器上安装更新，重新启动服务器，然后在后端服务器上安装更新。

如果尚未安装其中任意一个更新，请确保所有服务器正在运行最新的 Exchange Server Service Pack 和更新。

有关最新的 Exchange Server Service Pack 和更新的信息，请访问下列网站：

  • "Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=21236)。

  • "Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


未完成的 RPC 请求达到最大阈值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-02-13

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 MSExchangeIS 性能对象的 RPC Requests 性能计数器收集数据，以分析性能数据。

如果 Exchange Server 分析工具确定 RPC 请求的数量在示例时间段内超出峰值 100，则将显示错误。

RPC Requests 性能计数器表示 Microsoft Exchange 信息存储服务当前处理的 MAPI 远程过程调用 (RPC)（即客户端）请求数。RPC Requests 性能计数器的平均值应始终低于 30。默认情况下，RPC 请求的最多数量为 100。因此，除非另行配置，否则 Microsoft Exchange 信息存储服务同时只能处理 100 个 RPC 请求，之后所有新的 RPC 操作将受到拒绝，并且用户无法连接到服务器，直到 RPC 请求数下降到 100 之下。届时服务器将变得没有反应，邮件流可能会停止。Outlook 用户可能会收到"RPC 取消请求"对话框。

此错误表示服务器存在性能瓶颈，或者某个进程停止响应。

性能瓶颈可能是相关的 CPU、磁盘、网络或内存，也可能由服务器负载增加或服务器资源不足所造成。使用性能监视器 (Perfmon.msc) 工具可确定瓶颈是否由服务器负载增加或服务器不够大所造成。如果服务器负载增加，则识别增加的来源并减少它。如果服务器资源不足，则增加必要的资源或将用户从服务器上移开。

由于存储正在等待无法返回的资源，某个进程可能停止响应。例如，丢失驻留邮件跟踪的驱动器的群集或病毒扫描程序问题。当某个进程停止响应时，PRC 请求将不会返回，必须重新启动存储。

详细信息

  • 有关处理器瓶颈的详细信息，请参阅处理器瓶颈。

  • 有关磁盘瓶颈的详细信息，请参阅检测到磁盘瓶颈。

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关如何针对 Exchange Server 性能进行计划的详细信息，请参阅"Exchange Server 2003 Performance: 10 Things to Think About"（英文）(http://go.microsoft.com/fwlink/?LinkID=56460)。

  • 有关如何移动用户邮箱以降低服务器负载的详细信息，请参阅将用户邮箱移至其他服务器。


PHATCAT.DLL 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查下列几个核心 Exchange 二进制文件：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现一个或多个上述文件丢失，则显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


PHATQ.DLL 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查几个核心 Exchange 二进制文件是否存在：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现这些文件中有一个或多个丢失，则会显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


页面文件性能问题
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-09-06

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎为 LogicalDisk 性能对象的 PAGEDISK 实例收集 Avg Disk sec/Read 和 Avg Disk sec/Write 计数器的数据，以分析性能数据。

如果 Exchange Server 分析工具确定 Avg Disk sec/Read 和 Avg Disk sec/Write 计数器在示例时间段内超出 10 毫秒，则将显示错误。

LogicalDisk 性能对象由监视硬盘逻辑分区的 Avg Disk sec/Read 和 Avg Disk sec/Write 等计数器组成。Avg Disk sec/Read 性能计数器显示从磁盘读取数据的平均时间（秒）。Avg Disk sec/Write 性能计数器显示向磁盘写入数据的平均时间（秒）。Avg Disk sec/Read 和 Avg Disk sec/Write 性能计数器的平均值应小于 10 毫秒。

服务器上 LogicalDisk 性能对象的 PAGEDISK 实例表示页面文件 (Pagefile.sys)。Pagefile.sys 是 Microsoft Windows® 所使用的硬盘上的一个隐藏系统文件，在系统 RAM 不足时存储临时数据。页面文件也称为分页文件或交换文件。

此错误表示驻留页面文件的磁盘存在滞后问题。

若要解决该问题，请采取下列步骤：

  • 识别延迟原因。如果此问题是由过多的分页造成，则可能是由服务器内存问题造成的。

  • 考虑在专用分区或高速磁盘中定位页面文件。

  • 请考虑在备用驱动器上创建辅助页面文件，相关信息请参阅 Microsoft 知识库文章 197379"在 Windows Server 2003、Windows 2000 和 Windows NT 中配置页面文件以进行优化和恢复"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379)。

  • 在非高峰时段运行服务器维护任务。如果在高峰时段运行维护工具（如 Exchange Server 数据库实用工具 Eseutil.exe）或任务（如邮箱管理），则可能会占用本来由 Exchange 使用的内存。最佳做法是在非高峰时段或在内存使用量较低的时段运行这些工具和任务。

详细信息

  • 有关磁盘瓶颈的详细信息，请参阅检测到磁盘瓶颈。

  • 有关优化页面文件性能的详细信息，请参阅 Microsoft 知识库文章 197379"在 Windows Server 2003、Windows 2000 和 Windows NT 中配置页面文件以进行优化和恢复"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379)。

  • 有关 Exchange Server 性能的详细信息，请参阅 Performance and Scalability Guide for Exchange Server 2003（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关设计存储体系结构的最佳实践的详细信息，请参阅"Best Practices Common to Multiple Architectures"（多种体系结构通用的最佳实践） (http://go.microsoft.com/fwlink/?LinkId=72988).

  • 有关磁盘大小调整、滞后时间和 I/O 速率的详细信息，请参阅 Microsoft Exchange Team Blog 网站上的下列 Blog：

    • "A few basic concepts in disk sizing"（英文）(http://go.microsoft.com/fwlink/?linkid=39538)

    • Some more thoughts on disk IO and calculations…（磁盘 IO 和计算的更多思路...）(http://go.microsoft.com/fwlink/?linkid=39539)

    • How to Calculate Your Disk I/O Requirements（如何计算磁盘 I/O 要求）(http://go.microsoft.com/fwlink/?linkid=69747)


Page File Usage 计数器大于 50%
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-09-18

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 Paging File 性能对象的 % Usage 计数器收集数据，以分析性能数据。

如果 Exchange Server 分析工具确定 % Usage 计数器在示例时间段内超出 50%，则会显示错误。

页面文件 (Pagefile.sys) 是 Windows 所使用的硬盘上的一个隐藏系统文件，在系统 RAM 不足时存储临时数据。页面文件也称为分页文件或交换文件。由于磁盘操作所需的时间长于内存操作所需的时间，使用页面文件会影响整体性能。同时，当从磁盘分页和分页到磁盘变得十分频繁时，最后会产生磁盘瓶颈并影响性能。在这种情况下，真正问题在于内存，而磁盘瓶颈只是症状。

系统允许内存争用，直到系统需消耗大量时间来管理与实际工作所需时间相关的有限内存时。如果根据平均响应时间，画出内存争用，从零争用到响应时间大量增加这一点，将是一条相当平滑的线。该点称为阈值点。当内存争用继续加剧超过这一点时，响应时间将以指数级增加。在某些环境中，允许临时设置阈值，但应尽力避免。

该错误表示宿主页面文件的磁盘存在性能问题。该问题最终可能与服务器的内存问题有关。

若要解决该问题，请采取下列步骤：

  • 考虑在备用驱动器上创建辅助页面文件，相关信息请参阅 Microsoft 知识库文章 197379"在 Windows Server 2003、Windows 2000 和 Windows NT 中配置页面文件以进行优化和恢复"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379)。

  • 考虑在专用分区或高速磁盘中定位页面文件。

  • 删除多余的软件。为使 Exchange 可以使用更多的内存资源，请删除所有执行监视功能的第三方软件工具或所有不重要的服务类型。可以借助性能管理单元 (http://go.microsoft.com/fwlink/?LinkId=56118) 了解应用程序所使用的内存量。

  • 在非高峰时段运行服务器维护任务。如果在高峰时段运行维护工具（如 Exchange Server 数据库实用工具 Eseutil.exe）或任务（如邮箱管理），则可能会占用本来由 Exchange 使用的内存。最佳做法是在非高峰时段或在内存使用量较低的时段运行这些工具和任务。

  • 考虑将用户邮箱从受影响的服务器移至其他服务器，以降低服务器负载。有关详细信息，请参阅将用户邮箱移至其他服务器。

详细信息

  • 有关磁盘瓶颈的详细信息，请参阅检测到磁盘瓶颈。

  • 有关优化页面文件性能的详细信息，请参阅 Microsoft 知识库文章 197379"在 Windows Server 2003、Windows 2000 和 Windows NT 中配置页面文件以进行优化和恢复"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379)。

  • 有关改善内存性能的详细信息，请参阅改善用户内存。

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关设计存储体系结构的最佳实践的详细信息，请参阅"Best Practices Common to Multiple Architectures"（多种体系结构通用的最佳实践） (http://go.microsoft.com/fwlink/?LinkId=72988).

  • 有关磁盘大小调整、滞后时间和 I/O 速率的详细信息，请参阅 Microsoft Exchange Team Blog 网站上的下列 Blog：

    • "A few basic concepts in disk sizing"（磁盘大小调整的一些基本概念）(http://go.microsoft.com/fwlink/?linkid=39538)。

    • "Some more thoughts on disk IO and calculations..."（英文） (http://go.microsoft.com/fwlink/?linkid=39539)。

    • How to Calculate Your Disk I/O Requirements（如何计算磁盘 I/O 要求）(http://go.microsoft.com/fwlink/?linkid=69747)。


PageHeapFlags 已设置
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取下列注册表项，以确定 PageHeapFlags 项的值：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\MAD.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\INETINFO.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\EMSMTA.EXE

如果 Exchange Server 分析工具发现 PageHeapFlags 的值存在并配置为除 0 或 null 以外的其他任何值，则会显示警告。

PageHeapFlags 选项应与 GlobalFlag 已设置 中所描述的 GlobalFlag 注册表值一起配合使用。PageHeapFlags 选项用于选择标准的堆验证，该验证会在每个堆分配的末尾写入填充模式，并在分配被释放或进行全页堆验证时检查这些模式。这会在每个分配的末尾放置不可访问的页，这样，如果程序访问超出分配的内存时，就会立即停止该程序。由于整页堆验证将完整的内存页用于每个分配，所以，它的广泛使用会导致系统内存不足。

在这种情况下，Exchange Server 分析工具将具体检查是否已为多种 Exchange 组件启用了任何 PageHeapFlags 值：

  • STORE.EXE - 信息存储进程

  • MAD.EXE - 系统助理进程

  • INETINFO.EXE - IIS 管理和父进程

  • EMSMTA.EXE - 邮件传输代理进程

除非您正在 Microsoft 产品支持服务的帮助下积极地对问题进行调试或跟踪，否则建议您在任何时候都将 PageHeapFlags 值设置为 0，或将其完整删除（效果相同）。

默认情况下 PageHeapFlags 注册表值不存在，如果需要调试 STORE.EXE 进程（或任何其他进程），必须手动添加该注册表值。可以使用 Microsoft Windows Server™ 2003 支持工具（在 Windows Server 2003 CD 内的 \Support 文件夹中）所附带的 Gflags 工具。或者，可以手动将该值设置为 0，或使用注册表编辑器将 PageHeapFlags 值完整删除。本文将描述这两个过程。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

使用 GFlags 更正此错误

  1. 单击"开始 | 运行"，并在"打开"字段中执行 GFlags。将出现 Global Flags 用户界面。

  2. 在 Image File Name 字段中，输入 STORE.EXE。

  3. 单击 Image File Options。

  4. 清除所有复选框，再单击 Apply。

  5. 对每个上面列出的 Exchange 进程重复步骤 2 到 4。

  6. 单击"确定"退出 GFlags 工具，并重新启动受影响的服务，以使更改生效。

  7. 使用 GFlags 工具来清除该值时，不会删除或更改 PageHeapFlags 的值。而是将 GlobalFlag 值设置为 0，这将覆盖并禁用通过 PageHeapFlags 条目所配置的行为。

使用注册表编辑器更正此错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

  3. 删除名为 PageHeapFlags 的值。

  4. 对每个列出的 Exchange 进程重复步骤 2 和 3。

  5. 退出注册表编辑器，并重新启动受影响的服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


分页缓存超过错误阈值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_PerfRawData_PerfOS_Memory Microsoft Windows® Management Instrumentation (WMI) 类，以确定 PoolNonpagedBytes 项的当前值。Exchange Server 分析工具采取的操作取决于底层的操作系统、Windows Boot.ini 文件中是否存在 /3GB 开关以及所发现的该注册表项的值。

Exchange Server 分析工具使用下面的评估表来确定该值是否在给定 Exchange 服务器的允许范围内。如果满足此表格中的条件，将显示错误。

操作系统 | Boot.ini 设置 | 当前非页面缓冲池为
Windows 2000 Server 或 Advanced Server | /3GB | 110 MB 或更多
Windows 2000 Server 或 Advanced Server | 无 | 220 MB 或更多
Windows Server™ 2003 | /3GB | 110 MB 或更多
Windows Server 2003 | 无 | 220 MB 或更多

PoolNonpagedBytes 项值是内核内存非页面缓冲池的大小（字节）。非页面缓冲池是对象的物理系统内存中不能写入到磁盘、但一旦分配就必须保留在物理内存中的区域。该项值是最后观察的值。在正常运行的 Exchange 服务器上，该值应保持在固定的级别。如果此计数器的值持续增长，则可能意味着存在内存泄漏。

由于无法将非页面缓冲池内存的限额增加到超过上面所列出的值，因此这一情况应尽快予以更正。无论使用的是哪个操作系统以及 /3GB 开关是否存在，Windows 操作系统都只能访问这么多非页面缓冲池内存。如果 Windows 没有足够的内核内存使用，可能显示错误消息并崩溃。内核内存对于系统的正常运行是必需的，因此应仔细监视内核内存。

如果在重新启动 Exchange 服务器后这一情况仍然出现，则接下来应确保系统经过了正确的调整并且此系统上的所有软件和硬件都是最新的。这包括安装最新的：

  • Windows 操作系统 Service Pack

  • Exchange Server Service Pack

  • 硬件固件和驱动程序

  • 系统 BIOS 更新

  • 已安装的并且正在运行的任何第三方应用程序的更新

如果软硬件更新未能解决此问题，应禁用所有第三方软件、重新启动 Exchange Server 计算机，然后监视内核内存。

更正此错误

  1. 尽早地在方便的时候重新启动 Exchange Server 计算机。

  2. 监视 Memory | Pool Nonpaged Bytes 性能计数器，确保它未超过上面列出的与您的系统有关的阈值。

有关正确调整 Exchange Server 的详细信息，请参阅下列 Microsoft 知识库文章和主题：

  • 815372"如何在 Exchange Server 2003 中优化内存使用"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 266096"XGEN:Exchange 2000 Requires /3GB Switch with More Than 1 Gigabyte of Physical RAM"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096)

  • "Troubleshooting Exchange Server 2003 Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)

  • "Troubleshooting Exchange 2000 Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=18177)

  • "Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)


页面缓冲池超过了警告阈值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-03-16

Microsoft® Exchange Server 分析工具查询 Win32_PerfRawData_PerfOS_Memory Microsoft Windows® Management Instrumentation (WMI) 类，以确定 PoolPagedBytes 关键字的当前值。Exchange Server 分析工具采取的操作取决于底层的操作系统、Windows Boot.ini 文件中是否存在 /3GB 开关以及所发现的该注册表项的值。

下表显示了 Exchange Server 分析工具在确定该值对于给定 Exchange 服务器是否超出界限时所使用的计算矩阵。如果匹配下表中的条件，将显示警告。

操作系统 | Boot.ini 设置 | 当前页面缓冲池是
Windows 2000 Server 或 Advanced Server | /3GB | 180 MB 或更多
Windows 2000 Server 或 Advanced Server | 无 | 180 MB 或更多
Windows Server™ 2003 | /3GB | 200 MB 或更多
Windows Server 2003 | 无 | 300 MB 或更多

PoolPagedBytes 关键字的值是内核内存页面缓冲池的大小（字节）。对于不使用时可以写入磁盘的对象来说，页面缓冲池是这些对象的物理系统内存区域。该关键字的这个值是最后观察到的值。在工作正常的 Exchange 服务器上，除非正在发生备份或还原，否则，正在使用的页面缓冲池内存不应超过 180 MB。

在 Windows 2000 Server 和 Windows 2000 Advanced Server 中，页面缓冲池内存的最大值是 470 MB。在运行 Windows 2000 Advanced Server 的计算机上添加 /3GB 开关时，页面缓冲池内存的最大值是 192 MB。在没有 /3GB 开关的 Windows Server 2003 计算机上，页面缓冲池内存的最大值是 491 MB。在有 /3GB 开关的 Windows Server 2003 计算机上，页面缓冲池内存的最大值是 256 MB。

由于您无法将对页面缓冲池内存的限制增加到上述所列值以上，因此应当尽快纠正这种情况。不管正在使用什么操作系统，或是否存在 /3GB 开关，Windows 都只能访问这么多的页面缓冲池内存。如果 Windows 用尽了内核内存，它可能会显示错误消息并崩溃。内核内存对于操作系统的正确运行十分重要，因此您应当小心地监视内核内存。

如果重新启动 Exchange 服务器之后该情况重新出现，那么下一步是确保对系统进行正确的调整，并确保该系统上的所有软件和硬件都是最新的。这包括安装下列软件的最新版本：

  • Windows 操作系统 Service Pack

  • Exchange Server Service Pack

  • 硬件固件和驱动程序

  • 系统 BIOS 更新

  • 已安装并正在运行的任何第三方应用程序的更新

如果软件和硬件更新没有解决该问题，那么应当禁用所有第三方软件，然后重新启动 Exchange Server 计算机，并监视内核内存。

解决此警告问题

  1. 在方便的时候尽早重新启动 Exchange Server 计算机。

  2. 监视 Memory | Paged Pool Bytes 性能计数器，确保在您的系统上它没有超过上面列出的阈值。

有关正确调整 Exchange Server 的详细信息，请参阅下列 Microsoft 知识库文章和 Exchange 主题：

  • 815372"如何在 Exchange Server 2003 中优化内存使用"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 266096"XGEN:Exchange 2000 Requires /3GB Switch with More Than 1 Gigabyte of Physical RAM"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096)

  • "Troubleshooting Exchange Server 2003 Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)

  • "Troubleshooting Exchange 2000 Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=18177)

  • "Exchange Server 2003 性能和可伸缩性指南"(http://go.microsoft.com/fwlink/?LinkId=47576)

有关详细信息，请参阅下列 Exchange Blog 文章：

  • "Microsoft Windows Kernel Memory Management and Microsoft Exchange Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=63477)

  • "Configuring Hot-Add and Large Memory for Exchange 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=63478)

  • "Large Security Tokens and Kernel Memory Exhaustion"（英文）(http://go.microsoft.com/fwlink/?LinkId=63479)

    注意：
    指向这些 Blog 的链接仅供参考。该内容如有更改，恕不另行通知。


RPC 代理服务器扩展的路径不正确
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取 Internet 信息服务 (IIS) 元数据库中的以下属性，以确定其值是否已正确配置：

LM/W3SVC/Filters/RpcProxy

此元数据库属性是 IIS 的 Web 服务扩展中的远程过程调用 (RPC) 代理服务器扩展属性。此属性正确的值如下：

<Windows 目录>\system32\rpcproxy\rpcproxy.dll

如果 Exchange Server 分析工具发现该属性的值不正确，则显示警告。

RPC 代理服务器扩展属性在安装网络服务 Microsoft Windows® 组件的 RPC over HTTP 代理子组件时设置。如果该属性的设置不正确，或您手动更改了该值，应执行下列操作：

  1. 删除不正确的 RPC 代理服务器扩展属性。

  2. 删除 RPC over HTTP 代理子组件。

  3. 重新安装 RPC over HTTP 代理子组件。

删除不正确的 RPC 代理服务器扩展属性

  1. 打开"Internet 信息服务 (IIS) 管理器"。

  2. 在"Internet 信息服务 (IIS) 管理器"窗口的左侧窗格中，展开服务器名称，再单击"Web 扩展"。

  3. 在"IIS 管理器"窗口的右侧窗格中，用鼠标右键单击"RPC 代理服务器扩展"，再单击"属性"。

  4. 在"必需文件"选项卡上，从文件列表中选择不正确的文件，再单击"删除"，然后单击"确定"。

    注意：
    若要查看完整路径，请在文件列表中调整"文件名"列的宽度。
删除 RPC over HTTP 代理子组件

  1. 单击"开始"，再单击"控制面板"，然后单击"添加或删除程序"。

  2. 在左侧窗格中，单击"添加/删除 Windows 组件"。

  3. 选择"网络服务"，再单击"详细信息"。

  4. 清除"RPC over HTTP 代理"复选框，单击"确定"，再单击"下一步"。

  5. Windows 组件向导完成之后，单击"完成"关闭向导。
重新安装 RPC over HTTP 代理子组件

  1. 单击"开始"，再单击"控制面板"，然后单击"添加或删除程序"。

  2. 在左侧窗格中，单击"添加/删除 Windows 组件"。

  3. 选择"网络服务"，再单击"详细信息"。

  4. 选中"RPC over HTTP 代理"复选框，单击"确定"，再单击"下一步"。

  5. Windows 组件向导完成之后，单击"完成"关闭向导。

有关 RPC 代理服务器扩展未正确加载的问题的详细信息，请参阅 Microsoft 知识库文章 833401"如何在一台服务器上的 Exchange Server 2003 中配置 RPC over HTTP"的"疑难解答"部分(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=833401)。

有关在 Exchange Server 2003 上部署 RPC over HTTP 的详细信息，请参阅"Exchange Server 2003 RPC over HTTP Deployment Scenarios"（英文）(http://go.microsoft.com/fwlink/?LinkId=24823)。


PDC 仿真器未从 DSAccess 拓扑中排除
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取下列注册表项，以确定是否已从可供 Exchange Server 使用的域控制器列表中手动排除充当主域控制器 (PDC) 仿真器的 Active Directory® 域控制器：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default\MinUserDC

如果 Exchange Server 分析工具发现充当 PDC 仿真器的域控制器未被手动排除在可供 Exchange Server 使用的域控制器的列表以外，则显示最佳做法建议。

PDC 仿真器是一台 Active Directory 操作主机角色的计算机，它处理来自 Microsoft Windows NT® Server 4.0 备份域控制器的复制请求，并处理那些未运行支持 Active Directory 的客户端软件的客户端的所有密码更新。PDC 仿真器也是域控制器，因此可供诸如 Exchange Server 这样的应用程序使用。

目录服务访问 (DSAccess) 是 Exchange 2000 Server 和 Exchange Server 2003 的内部组件，用于控制所有 Exchange Server 组件访问 Active Directory 的方式。DSAccess 的主要功能是维护与目录有关的各种事件和操作的相关信息。例如，DSAccess 发现 Active Directory 拓扑结构，并检测域控制器和全局编录服务器是否可用、是否能对查询做出响应。

默认情况下，DSAccess 在它的可用域控制器列表中包括 PDC 仿真器计算机。如果非 Exchange Server 程序过度使用 PDC 仿真器，则 DSAccess 使用 PDC 仿真器时会导致在 PDC 仿真器计算机上以及在 Exchange 服务器和非 Exchange Server 计算机上出现性能问题。

若要防止发生这样的性能问题，可以在 Exchange 服务器上将 MinUserDC 注册表值添加到注册表中，以便强制 DSAccess 在查询具有 PDC 仿真器操作主机角色的域控制器之前，先查询其他所有可用的域控制器。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
检查并更改 MinUserDC 注册表值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default

  3. 找到 MinUserDC 值，并进行任何所需更改。如果该 DWORD 值不存在，可以手动创建它。

    注意：
    为 MinUserDC 注册表项所配置的值数据是在联系 PDC 仿真器之前要首先联系的最大域控制器数。例如，通过将 MinUserDC 设置为 4，可以将 DSAccess 配置为仅当共有 4 台域控制器可用时才排除 PDC 仿真器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关如何使用 MinUserDC 注册表项的详细信息，请参阅知识库文章 298879"Exchange 2000 may experience performance problems when PDC emulator is used for DSAccess"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=298879)。


来自 Available MBytes 计数器的性能数据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包括性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎收集从 Memory 性能对象的 Available MBytes 性能计数器中收集数据以分析性能数据。如果 Exchange Server 分析工具从 Available MBytes 性能计数器收集到任何数据，会将收集到的数据的有关信息显示为基准信息。

Available MBytes 性能计数器显示立即可以分配给进程或供系统使用的物理内存量 (MB)。可用内存量等于分配给备用（缓存）、可用和零页列表的内存总和。

默认情况下，Exchange Server 分析工具在两个小时内每 30 秒检索一个示例。Exchange Server 分析工具在收集间隔期间报告性能计数器的最大值。Exchange Server 分析工具还报告所有收集的值的第九十百分位的值。

注意：
如果按照升序列出 Exchange Server 分析工具收集的所有值，第九十百分位数是列表中 90% 位置的值。第九十百分位数的值指示在收集间隔期间此计数器的峰值。

在某些情况下，最大值将为间隔中的峰值。因此，最大值不是整个间隔的代表。中值并非始终准确地指示负载，因为中值包括收集间隔期间的空闲时间。因此，Exchange Server 分析工具报告最大值和第九十百分位数的值。

此基准消息中的信息仅以提供信息为目的。不需要您执行任何操作。

有关性能计数器建议的阈值的详细信息，请参阅"Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)。


来自 LogicalDisk 性能对象的 Average Disk sec/Read 计数器的性能数据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 LogicalDisk 性能对象的 Avg. Disk sec/Read 性能计数器收集数据，以分析性能数据。如果 Exchange Server 分析工具从 Avg. Disk sec/Read 性能计数器收集到任何数据，会将收集到的数据的有关信息显示为基准信息。

Logical Disk 性能对象由 Avg. Disk sec/Read 等计数器组成，监视硬盘的逻辑分区。Avg. Disk sec/Read 性能计数器显示从磁盘读取数据的平均时间（秒）。Avg. Disk sec/Read 性能计数器的平均值应低于 10 毫秒。Avg. Disk sec/Read 性能计数器的最大值不应超过 50 毫秒。

默认情况下，Exchange Server 分析工具在两个小时内每 30 秒检索一个示例。Exchange Server 分析工具报告在收集间隔期间性能计数器的最大值。Exchange Server 分析工具还报告所有收集的值的第九十百分位数的值。

注意：
如果按照升序列出 Exchange Server 分析工具收集的所有值，第九十百分位数是列表中 90% 位置的值。第九十百分位数的值指示在收集间隔期间此计数器的峰值。

在某些情况下，最大值将为间隔中的峰值。因此，最大值不是整个间隔的代表。中值并非始终准确地指示负载，因为中值包括收集间隔期间的空闲时间。因此，Exchange Server 分析工具报告最大值和第九十百分位数的值。

此基准消息中的信息仅以提供信息为目的。不需要您执行任何操作。

有关如何优化 Exchange Server 2003 的存储系统的详细信息，请参阅"Optimizing Storage for Exchange Server 2003"（英文） (http://go.microsoft.com/fwlink/?LinkId=49324)。

有关性能计数器建议的阈值的详细信息，请参阅"Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)。


来自 PhysicalDisk 性能对象的 Average Disk sec/Read 计数器的性能数据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 PhysicalDisk 性能对象的 Avg. Disk sec/Read 性能计数器收集数据，以分析性能数据。如果 Exchange Server 分析工具从 Avg. Disk sec/Read 性能计数器收集到任何数据，会将收集到的数据的有关信息显示为基准信息。

Avg. Disk sec/Read 性能计数器指示从磁盘读取数据的平均时间（秒）。Avg. Disk sec/Read 性能计数器的平均值应低于 10 毫秒。Avg. Disk sec/Read 性能计数器的最大值不应超过 50 毫秒。

如果从 Disk Reads/sec 和 Disk Writes/sec 计数器收集结果，可以确定 Exchange Server 生成的 I/O 随时间增加还是减少。如果从 Avg. Disk sec/Read 和 Avg. Disk sec/Write 计数器收集结果，可以确定存储延迟是否随时间更改。例如，下列步骤可以帮助您预测存储吞吐量是否是瓶颈或即将成为瓶颈：

  1. 每月进行评估，最好在每个月的同一天以及每天的同一时段。

  2. 分析收集的数据。

默认情况下，Exchange Server 分析工具在两个小时内每 30 秒检索一个示例。Exchange Server 分析工具报告在收集间隔期间性能计数器的最大值。Exchange Server 分析工具还报告所有收集的值的第九十百分位数的值。

注意：
如果按照升序列出 Exchange Server 分析工具收集的所有值，第九十百分位数是列表中 90% 位置的值。第九十百分位数的值指示在收集间隔期间此计数器的峰值。

在某些情况下，最大值将为间隔中的峰值。因此，最大值不是整个间隔的代表。中值并非始终准确地指示负载，因为中值包括收集间隔期间的空闲时间。因此，Exchange Server 分析工具报告最大值和第九十百分位数的值。

此基准消息中的信息仅以提供信息为目的。不需要您执行任何操作。

有关性能计数器建议的阈值的详细信息，请参阅"Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)。


来自 LogicalDisk 性能对象的 Average Disk sec/Write 计数器的性能数据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包括性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎从 LogicalDisk 性能对象的 Avg. Disk sec/Write 性能计数器收集数据以分析性能数据。如果 Exchange Server 分析工具从 Avg. Disk sec/Write 性能计数器收集到任何数据，会将收集到的数据的有关信息显示为基准信息。

Logical Disk 性能对象由 Avg. Disk sec/Write 等计数器组成，监视硬盘的逻辑分区。Avg. Disk sec/Write 性能计数器显示将数据写入磁盘所用的平均时间（秒）。Avg. Disk sec/Write 性能计数器的平均值应低于 10 毫秒。Avg. Disk sec/Write 性能计数器的最大值不应超过 50 毫秒。

默认情况下，Exchange Server 分析工具在两个小时内每 30 秒检索一个示例。Exchange Server 分析工具报告在收集间隔期间性能计数器的最大值。Exchange Server 分析工具还报告所有收集的值的第九十百分位的值。

注意：
如果按照升序列出 Exchange Server 分析工具收集的所有值，第九十百分位数是列表中 90% 位置的值。第九十百分位数的值指示在收集间隔期间此计数器的峰值。

在某些情况下，最大值将为间隔中的峰值。因此，最大值不是整个间隔的代表。中值并非始终准确地指示负载，因为中值包括收集间隔期间的空闲时间。因此，Exchange Server 分析工具报告最大值和第九十百分位数的值。

此基准消息中的信息仅以提供信息为目的。不需要您执行任何操作。

有关如何优化 Exchange Server 2003 的存储系统的详细信息，请参阅 Microsoft TechNet 网站上的"Optimizing Storage for Exchange Server 2003"（英文） (http://go.microsoft.com/fwlink/?LinkId=34649)。

有关性能计数器建议的阈值的详细信息，请参阅"Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)。


来自 Average Disk sec/Write 计数器的性能数据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包括性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎从 Physical Disk 性能对象的 Avg. Disk sec/Write 性能计数器收集数据以分析性能数据。如果 Exchange Server 分析工具从 Avg. Disk sec/Write 性能计数器收集到任何数据，会将收集到的数据的有关信息显示为基准信息。

Avg. Disk sec/Write 性能计数器显示将数据写入磁盘所用的平均时间（秒）。Avg. Disk sec/Write 性能计数器的平均值应低于 10 毫秒。Avg. Disk sec/Write 性能计数器的最大值不应超过 50 毫秒。

默认情况下，Exchange Server 分析工具在两个小时内每 30 秒检索一个示例。Exchange Server 分析工具报告在收集间隔期间性能计数器的最大值。Exchange Server 分析工具还报告所有收集的值的第九十百分位的值。

注意：
如果按照升序列出 Exchange Server 分析工具收集的所有值，第九十百分位数是列表中 90% 位置的值。第九十百分位数的值指示在收集间隔期间此计数器的峰值。

在某些情况下，最大值将为间隔中的峰值。因此，最大值不是整个间隔的代表。中值并非始终准确地指示负载，因为中值包括收集间隔期间的空闲时间。因此，Exchange Server 分析工具报告最大值和第九十百分位数的值。

此基准消息中的信息仅以提供信息为目的。不需要您执行任何操作。

有关性能计数器建议的阈值的详细信息，请参阅"Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)。


来自 Epoxy Client Out Queue Length (DSAccess) 计数器的性能数据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包括性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎收集从 Epoxy 性能对象的 Client Out Queue Length (DSAccess) 性能计数器中收集数据以分析性能数据。如果 Exchange Server 分析工具从 Client Out Queue Length (DSAccess) 性能计数器收集到任何数据，会将收集到的数据的有关信息显示为基准信息。

Client Out Queue Length (DSAccess) 性能计数器表明包含由 Inetinfo.exe 进程发送的目录服务访问 (DSAccess) 邮件的队列中的邮件数。队列应始终低于 10。

默认情况下，Exchange Server 分析工具在两个小时内每 30 秒检索一个示例。Exchange Server 分析工具在收集间隔期间报告性能计数器的最大值。Exchange Server 分析工具还报告所有收集的值的第九十百分位的值。

注意：
如果按照升序列出 Exchange Server 分析工具收集的所有值，第九十百分位数是列表中 90% 位置的值。第九十百分位数的值指示在收集间隔期间此计数器的峰值。

在某些情况下，最大值将为间隔中的峰值。因此，最大值不是整个间隔的代表。中值并非始终准确地指示负载，因为中值包括收集间隔期间的空闲时间。因此，Exchange Server 分析工具报告最大值和第九十百分位数的值。

此基准消息中的信息仅以提供信息为目的。不需要您执行任何操作。

有关性能计数器建议的阈值的详细信息，请参阅"Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)。


来自 Epoxy Client Out Queue Length (SMTP) 计数器的性能数据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包括性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎从 Epoxy 性能对象的 Client Out Queue Length (SMTP) 性能计数器收集数据以分析性能数据。如果 Exchange Server 分析工具从 Client Out Queue Length (SMTP) 性能计数器收集到任何数据，会将收集到的数据的有关信息显示为基准信息。

Client Out Queue Length (SMTP) 性能计数器表明包含由 Inetinfo.exe 进程发送的简单邮件传输协议 (SMTP) 邮件的队列中的邮件数。除非存在邮件队列，否则，队列应始终低于 50。

默认情况下，Exchange Server 分析工具在两个小时内每 30 秒检索一个示例。Exchange Server 分析工具报告在收集间隔期间性能计数器的最大值。Exchange Server 分析工具还报告所有收集的值的第九十百分位的值。

注意：
如果按照升序列出 Exchange Server 分析工具收集的所有值，第九十百分位数是列表中 90% 位置的值。第九十百分位数的值指示在收集间隔期间此计数器的峰值。

在某些情况下，最大值将为间隔中的峰值。因此，最大值不是整个间隔的代表。中值并非始终准确地指示负载，因为中值包括收集间隔期间的空闲时间。因此，Exchange Server 分析工具报告最大值和第九十百分位数的值。

此基准消息中的信息仅以提供信息为目的。不需要您执行任何操作。

有关性能计数器建议的阈值的详细信息，请参阅"Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)。


来自 Epoxy Store Out Queue Length (DSAccess) 计数器的性能数据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 Epoxy 性能对象的 Store Out Queue Length (DSAccess) 性能计数器收集数据，以分析性能数据。如果 Exchange Server 分析工具从 Store Out Queue Length (DSAccess) 性能计数器收集到任何数据，会将收集到的数据的有关信息显示为基准信息。

Store Out Queue Length (DSAccess) 性能计数器表明包含由 Store.exe 进程发送的目录服务访问 (DSAccess) 邮件的队列中的邮件数。队列应始终低于 10。

默认情况下，Exchange Server 分析工具在两个小时内每 30 秒检索一个示例。Exchange Server 分析工具报告在收集间隔期间性能计数器的最大值。Exchange Server 分析工具还报告所有收集的值的第九十百分位数的值。

注意：
如果按照升序列出 Exchange Server 分析工具收集的所有值，第九十百分位数是列表中 90% 位置的值。第九十百分位数的值指示在收集间隔期间此计数器的峰值。

在某些情况下，最大值将为间隔中的峰值。因此，最大值不是整个间隔的代表。中值并非始终准确地指示负载，因为中值包括收集间隔期间的空闲时间。因此，Exchange Server 分析工具报告最大值和第九十百分位数的值。

此基准消息中的信息仅以提供信息为目的。不需要您执行任何操作。

有关性能计数器建议的阈值的详细信息，请参阅"Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)。


来自 Epoxy Store Out Queue Length (SMTP) 计数器的性能数据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 Epoxy 性能对象的 Store Out Queue Length (SMTP) 性能计数器收集数据，以分析性能数据。如果 Exchange Server 分析工具从 Store Out Queue Length (SMTP) 性能计数器收集到任何数据，会将收集到的数据的有关信息显示为基准信息。

Store Out Queue Length (SMTP) 性能计数器表明包含由 Store.exe 进程发送的简单邮件传输协议 (SMTP) 邮件的队列中的邮件数。除非存在邮件队列，否则，队列应始终低于 50。

默认情况下，Exchange Server 分析工具在两个小时内每 30 秒检索一个示例。Exchange Server 分析工具报告在收集间隔期间性能计数器的最大值。Exchange Server 分析工具还报告所有收集的值的第九十百分位数的值。

注意：
如果按照升序列出 Exchange Server 分析工具收集的所有值，第九十百分位数是列表中 90% 位置的值。第九十百分位数的值指示在收集间隔期间此计数器的峰值。

在某些情况下，最大值将为间隔中的峰值。因此，最大值不是整个间隔的代表。中值并非始终准确地指示负载，因为中值包括收集间隔期间的空闲时间。因此，Exchange Server 分析工具报告最大值和第九十百分位数的值。

此基准消息中的信息仅以提供信息为目的。不需要您执行任何操作。

有关性能计数器建议的阈值的详细信息，请参阅"Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)。


来自 RPC Averaged Latency 计数器的性能数据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 MSExchangeIS 性能对象的 RPC Averaged Latency 性能计数器收集数据，以分析性能数据。如果 Exchange Server 分析工具从 RPC Averaged Latency 性能计数器收集到任何数据，会将收集到的数据的有关信息显示为基准信息。

RPC Averaged Latency 性能计数器显示过去 1,024 个数据包的平均远程过程调用 (RPC) 延迟（毫秒）。RPC Averaged Latency 性能计数器的最大值应始终小于 50 毫秒。

默认情况下，Exchange Server 分析工具在两个小时内每 30 秒检索一个示例。Exchange Server 分析工具报告在收集间隔期间性能计数器的最大值。Exchange Server 分析工具还报告所有收集的值的第九十百分位数的值。

注意：
如果按照升序列出 Exchange Server 分析工具收集的所有值，第九十百分位数是列表中 90% 位置的值。第九十百分位数的值指示在收集间隔期间此计数器的峰值。

在某些情况下，最大值将为间隔中的峰值。因此，最大值不是整个间隔的代表。中值并非始终准确地指示负载，因为中值包括收集间隔期间的空闲时间。因此，Exchange Server 分析工具报告最大值和第九十百分位数的值。

此基准消息中的信息仅以提供信息为目的。不需要您执行任何操作。

有关性能计数器建议的阈值的详细信息，请参阅"Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)。


来自 RPC Operations/sec 计数器的性能数据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 MSExchangeIS 性能对象的 RPC Operations/sec 性能计数器收集数据，以分析性能数据。如果 Exchange Server 分析工具从 RPC Operations/sec 性能计数器收集到任何数据，会将收集到的数据的有关信息显示为基准信息。

RPC Operations/sec 性能计数器显示进行远程过程调用 (RPC) 操作的速率。RPC Operations/sec 性能计数器是一个很好的测量 Exchange Server 工作量的速率计数器，因为所有基于 MAPI 的操作均使用 RPC 协议。

默认情况下，Exchange Server 分析工具在两个小时内每 30 秒检索一个示例。Exchange Server 分析工具报告在收集间隔期间性能计数器的最大值。Exchange Server 分析工具还报告所有收集的值的第九十百分位数的值。

注意：
如果按照升序列出 Exchange Server 分析工具收集的所有值，第九十百分位数是列表中 90% 位置的值。第九十百分位数的值指示在收集间隔期间此计数器的峰值。

在某些情况下，最大值将为间隔中的峰值。因此，最大值不是整个间隔的代表。中值并非始终准确地指示负载，因为中值包括收集间隔期间的空闲时间。因此，Exchange Server 分析工具报告最大值和第九十百分位数的值。

此基准消息中的信息仅以提供信息为目的。不需要您执行任何操作。

有关性能计数器建议的阈值的详细信息，请参阅"Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)。


来自 RPC Requests 计数器的性能数据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包括性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎从 MSExchangeIS 性能对象的 RPC Requests 性能计数器收集数据以分析性能数据。如果 Exchange Server 分析工具从 RPC Requests 性能计数器收集到任何数据，会将收集到的数据的有关信息显示为基准信息。

RPC Requests 性能计数器指示 Microsoft Exchange 信息存储服务当前处理的 MAPI 远程过程调用 (RPC) （即客户端）请求数。RPC Requests 性能计数器的平均值应始终低于 30。默认情况下，RPC 请求数的最大值为 100。因此，除非特别配置，否则，Microsoft Exchange 信息存储服务只能同时为 100 个 RPC 请求提供服务，之后将拒绝客户端请求。

默认情况下，Exchange Server 分析工具在两个小时内每 30 秒检索一个示例。Exchange Server 分析工具报告在收集间隔期间性能计数器的最大值。Exchange Server 分析工具还报告所有收集的值的第九十百分位的值。

注意：
如果按照升序列出 Exchange Server 分析工具收集的所有值，第九十百分位数是列表中 90% 位置的值。第九十百分位数的值指示在收集间隔期间此计数器的峰值。

在某些情况下，最大值将为间隔中的峰值。因此，最大值不是整个间隔的代表。中值并非始终准确地指示负载，因为中值包括收集间隔期间的空闲时间。因此，Exchange Server 分析工具报告最大值和第九十百分位数的值。

此基准消息中的信息仅以提供信息为目的。不需要您执行任何操作。

有关性能计数器建议的阈值的详细信息，请参阅"Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)。


来自 SMTP Categorizer Queue Length 计数器的性能数据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包括性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎从 SMTP Server 性能对象的 Categorizer Queue Length 性能计数器收集数据以分析性能数据。Exchange Server 分析工具报告分类程序队列中发现的邮件总数。

SMTP Server\Categorizer Queue Length 计数器指示简单邮件传输协议 (SMTP) 分类程序队列中正在等待使用全局编录服务器的目录服务属性搜索的邮件数。通常的准则是，最大值应小于 10。

默认情况下，Exchange Server 分析工具在两个小时内每 30 秒检索一个示例。Exchange Server 分析工具报告在收集间隔期间性能计数器的最大值。Exchange Server 分析工具还报告所有收集的值的第九十百分位的值。

注意：
如果按照升序列出 Exchange Server 分析工具收集的所有值，第九十百分位数是列表中 90% 位置的值。第九十百分位数的值指示在收集间隔期间此计数器的峰值。

在某些情况下，最大值将为间隔中的峰值。因此，最大值不是整个间隔的代表。中值并非始终准确地指示负载，因为中值包括收集间隔期间的空闲时间。因此，Exchange Server 分析工具报告最大值和第九十百分位数的值。

Categorizer Queue Length 计数器指示邮件分类程序队列中的邮件数。分类程序执行下列核心操作：

  • 解析和验证所有收件人。

  • 确定所有收件人的限制。

  • 根据需要展开通讯组列表。

  • 确定邮件用于本地传递还是远程传递。

Categorizer Queue Length 计数器的增大指示服务器性能、目录服务访问 (DSAccess)、Active Directory® 目录服务可能存在问题，或 Exchange Server 组织中的关键服务器中断。Categorizer Queue Length 计数器的增大指示在咨询 Active Directory 时或发出邮件进行本地传递或 SMTP 传递时的速度很慢或无响应。

此基准消息中的信息仅以提供信息为目的。不需要您执行任何操作。

有关性能计数器建议的阈值的详细信息，请参阅"Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)。


来自 SMTP Local Queue Length 计数器的性能数据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft®Exchange Server 分析工具包括性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎从 SMTP Server 性能对象的 Local Queue Length 性能计数器中收集数据以分析性能数据。Exchange Server 分析工具报告在简单邮件传输协议 (SMTP) 本地队列中发现的邮件总数。

SMTP Server\Local Queue Length 计数器指示用于本地传递的 SMTP 队列中的邮件数。通常的准则是，最大值应小于 1,000。队列应在平均值附近保持稳定，变化较小。

默认情况下，Exchange Server 分析工具在两个小时内每 30 秒检索一个示例。Exchange Server 分析工具报告在收集间隔期间性能计数器的最大值。Exchange Server 分析工具还报告所有收集的值的第九十百分位的值。

注意：
如果按照升序列出 Exchange Server 分析工具收集的所有值，第九十百分位数是列表中 90% 位置的值。第九十百分位数的值指示在收集间隔期间此计数器的峰值。

在某些情况下，最大值将为间隔中的峰值。因此，最大值不是整个间隔的代表。中值并非始终准确地指示负载，因为中值包括收集间隔期间的空闲时间。因此，Exchange Server 分析工具报告最大值和第九十百分位数的值。

本地传递队列中邮件的累积表明服务器上的性能问题或中断，因为服务器无法再及时地传递传入邮件。下列条件可能造成此延迟：

  • 未及时咨询 Active Directory 目录服务。

  • 邮件未及时发出进行本地传递或 SMTP 传递。

  • 数据库已卸载。

此基准消息中的信息仅以提供信息为目的。不需要您执行任何操作。

有关性能计数器建议的阈值的详细信息，请参阅"Troubleshooting Exchange Server2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)。


来自 SMTP Remote Queue Length 计数器的性能数据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 SMTP Server 性能对象的 Remote Queue Length 性能计数器收集数据，以分析性能数据。Exchange Server 分析工具报告在简单邮件传输协议 (SMTP) 远程队列中发现的邮件总数。

SMTP Server\Remote Queue Length 计数器指示用于远程传递的 SMTP 队列中的邮件数。通常的准则是，最大值应小于 1,000。队列应在平均值附近保持稳定，变化较小。

默认情况下，Exchange Server 分析工具在两个小时内每 30 秒检索一个示例。Exchange Server 分析工具报告在收集间隔期间性能计数器的最大值。Exchange Server 分析工具还报告所有收集的值的第九十百分位数的值。

注意：
如果按照升序列出 Exchange Server 分析工具收集的所有值，第九十百分位数是列表中 90% 位置的值。第九十百分位数的值指示在收集间隔期间此计数器的峰值。

在某些情况下，最大值将为间隔中的峰值。因此，最大值不是整个间隔的代表。中值并非始终准确地指示负载，因为中值包括收集间隔期间的空闲时间。因此，Exchange Server 分析工具报告最大值和第九十百分位数的值。

远程队列长度的增加意味着邮件不会发送到其他服务器。这种发送邮件失败的情况可以解释为网络或远程服务器的中断或性能问题。这些中断或性能问题使网络或远程服务器无法有效地接收邮件。

此基准消息中的信息仅以提供信息为目的。不需要您执行任何操作。

有关性能计数器建议的阈值的详细信息，请参阅"Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)。


来自 Virus Scan Queue Length 计数器的性能数据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 MSExchangeIS 性能对象的 Virus Scan Queue Length 性能计数器收集数据，以分析性能数据。如果 Exchange Server 分析工具从 Virus Scan Queue Length 性能计数器收集到任何数据，会将收集到的数据的有关信息显示为基准信息。

Virus Scan Queue Length 性能计数器指示病毒扫描队列中当前未完成的请求数。此计数器建议的值视组织的情况而定。

默认情况下，Exchange Server 分析工具在两个小时内每 30 秒检索一个示例。Exchange Server 分析工具报告在收集间隔期间性能计数器的最大值。Exchange Server 分析工具还报告所有收集的值的第九十百分位数的值。

注意：
如果按照升序列出 Exchange Server 分析工具收集的所有值，第九十百分位数是列表中 90% 位置的值。第九十个百分点的值指示在收集间隔期间此计数器的峰值。

在某些情况下，最大值将为间隔中峰值点的值。因此，最大值不能代表整个间隔。中值并非始终准确地指示负载，因为中值包括收集间隔期间的空闲时间。因此，Exchange Server 分析工具报告最大值和第九十百分位数的值。

此基准消息中的信息仅以提供信息为目的。不需要您执行任何操作。

有关性能计数器建议的阈值的详细信息，请参阅"Troubleshooting Exchange Server 2003 Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。


来自 Log Record Stalls/sec 计数器的性能数据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包括性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎从 Database 性能对象的 Log Record Stalls/sec 性能计数器收集数据以分析性能数据。如果 Exchange Server 分析工具从 Log Record Stalls/sec 性能计数器收集到任何数据，会将收集到的数据的有关信息显示为基准信息。

Log Record Stalls/sec 性能计数器是指每秒钟内由于日志缓冲区已满而无法添加到日志缓冲区中的日志记录的数目。Log Record Stalls/sec 性能计数器的平均值应低于 10 个/秒。最大值不应超过 100 个/秒。

默认情况下，Exchange Server 分析工具在两个小时内每 30 秒检索一个示例。Exchange Server 分析工具报告在收集间隔期间性能计数器的最大值。Exchange Server 分析工具还报告所有收集的值的第九十百分位的值。

注意：
如果按照升序列出 Exchange Server 分析工具收集的所有值，第九十百分位数是列表中 90% 位置的值。第九十百分位数的值指示在收集间隔期间此计数器的峰值。

在某些情况下，最大值将为间隔中的峰值。因此，最大值不是整个间隔的代表。中值并非始终准确地指示负载，因为中值包括收集间隔期间的空闲时间。因此，Exchange Server 分析工具报告最大值和第九十百分位数的值。

此基准消息中的信息仅以提供信息为目的。不需要您执行任何操作。

有关性能计数器建议的阈值的详细信息，请参阅"Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)。


来自 Log Threads Waiting 计数器的性能数据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 Database 性能对象的 Log Threads Waiting 性能计数器收集数据，以分析性能数据。如果 Exchange Server 分析工具从 Log Threads Waiting 性能计数器收集到任何数据，会将收集到的数据的有关信息显示为基准信息。

Log Threads Waiting 性能计数器显示通过将数据写入日志来等待数据库更新完成的线程数。如果 Log Threads Waiting 性能计数器的值太高，日志可能成为其他事务的瓶颈。

默认情况下，Exchange Server 分析工具在两个小时内每 30 秒检索一个示例。Exchange Server 分析工具报告在收集间隔期间性能计数器的最大值。Exchange Server 分析工具还报告所有收集的值的第九十百分位数的值。

注意：
如果按照升序列出 Exchange Server 分析工具收集的所有值，第九十百分位数是列表中 90% 位置的值。第九十百分位数的值指示在收集间隔期间此计数器的峰值。

在某些情况下，最大值将为间隔中的峰值。因此，最大值不是整个间隔的代表。中值并非始终准确地指示负载，因为中值包括收集间隔期间的空闲时间。因此，Exchange Server 分析工具报告最大值和第九十百分位数的值。

此基准消息中的信息仅以提供信息为目的。不需要您执行任何操作。

有关性能计数器建议的阈值的详细信息，请参阅"Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)。


来自 Pages/sec 计数器的性能数据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包括性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎从 Memory 性能对象的 Pages/sec 性能计数器收集数据以分析性能数据。如果 Exchange Server 分析工具从 Pages/sec 性能计数器收集到任何数据，Exchange Server 分析工具都会将收集到的数据的有关信息显示为基准信息。

Pages/sec 性能计数器显示为解决硬页面故障而读取或写入磁盘的速率。此计数器是造成系统范围的延迟的故障类型的主要指示器。该计数包括为解决文件系统缓存中的页面故障而检索的页面。这些页面一般通过应用程序请求。此计数器应始终低于 1,000。

默认情况下，Exchange Server 分析工具在两个小时内每 30 秒检索一个示例。Exchange Server 分析工具报告在收集间隔期间性能计数器的最大值。Exchange Server 分析工具还报告所有收集的值的第九十百分位的值。

注意：
如果按照升序列出 Exchange Server 分析工具收集的所有值，第九十百分位数是列表中 90% 位置的值。第九十百分位数的值指示在收集间隔期间此计数器的峰值。

在某些情况下，最大值将为间隔中的峰值。因此，最大值不是整个间隔的代表。中值并非始终准确地指示负载，因为中值包括收集间隔期间的空闲时间。因此，Exchange Server 分析工具报告最大值和第九十百分位数的值。

此基准消息中的信息仅以提供信息为目的。不需要您执行任何操作。

有关性能计数器建议的阈值的详细信息，请参阅"Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)。


来自 % Processor Time 计数器的性能数据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包括性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎从 Processor 性能对象的 % Processor Time 性能计数器收集数据以分析性能数据。如果 Exchange Server 分析工具从 % Processor Time 性能计数器收集到任何数据，会将收集到的数据的有关信息显示为基准信息。

% Processor Time 性能计数器显示处理器运行非空闲线程的时间的百分比。可以使用此计数器监视处理器的整体利用率，也可以监视每个处理器的利用率。平均的 CPU 利用率应始终低于 90%。

注意：
Exchange Server 分析工具显示的 % Processor Time 是基于检测到的物理和逻辑 CPU 总数除以 CPU 计数总和的聚合值。

默认情况下，Exchange Server 分析工具在两个小时内每 30 秒检索一个示例。Exchange Server 分析工具报告在收集间隔期间性能计数器的最大值。Exchange Server 分析工具还报告所有收集的值的第九十百分位的值。

注意：
如果按照升序列出 Exchange Server 分析工具收集的所有值，第九十百分位数是列表中 90% 位置的值。第九十百分位数的值指示在收集间隔期间此计数器的峰值。

在某些情况下，最大值将为间隔中的峰值。因此，最大值不是整个间隔的代表。中值并非始终准确地指示负载，因为中值包括收集间隔期间的空闲时间。因此，Exchange Server 分析工具报告最大值和第九十百分位数的值。

此基准消息中的信息仅以提供信息为目的。不需要您执行任何操作。

有关性能计数器建议的阈值的详细信息，请参阅"Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)。


来自 Bytes Total/sec 计数器的性能数据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 Network Interface 性能对象的 Bytes Total/sec 性能计数器收集数据，以分析性能数据。如果 Exchange Server 分析工具从 Bytes Total/sec 性能计数器收集到任何数据，会将收集到的数据的有关信息显示为基准信息。

Bytes Total/sec 性能计数器显示网络适配器处理数据字节的速率。此计数器包含所有应用程序和文件数据以及协议信息（包括数据包头）。对于 100 Mbps 的网络适配器，Bytes Total/sec 性能计数器的值应低于 7 MB/秒。对于 1000 Mbps 的网络适配器，Bytes Total/sec 性能计数器的值应低于 70 MB/秒。

默认情况下，Exchange Server 分析工具在两个小时内每 30 秒检索一个示例。Exchange Server 分析工具报告在收集间隔期间性能计数器的最大值。Exchange Server 分析工具还报告所有收集的值的第九十百分位数的值。

注意：
如果按照升序列出 Exchange Server 分析工具收集的所有值，第九十百分位数是列表中 90% 位置的值。第九十百分位数的值指示在收集间隔期间此计数器的峰值。

在某些情况下，最大值将为间隔中的峰值。因此，最大值不是整个间隔的代表。中值并非始终准确地指示负载，因为中值包括收集间隔期间的空闲时间。因此，Exchange Server 分析工具报告最大值和第九十百分位数的值。

此基准消息中的信息仅以提供信息为目的。不需要您执行任何操作。

有关性能计数器建议的阈值的详细信息，请参阅"Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)。


来自 LDAP Read Time 计数器的性能数据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-02-06

Microsoft® Exchange Server 分析工具包括性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎从 MSExchangeDSAccess Process 性能对象的 LDAP Read Time 性能计数器收集数据以分析性能数据。如果 Exchange Server 分析工具从 LDAP Read Time 性能计数器收集到任何数据，则会将收集到的数据的有关信息显示为基准信息。

LDAP Read Time 性能计数器显示实现轻型目录访问协议 (LDAP) 读取请求所需的时间（毫秒）。平均值应低于 50 毫秒。最大值不应超过 100 毫秒。

默认情况下，Exchange Server 分析工具在两个小时内每 30 秒检索一个示例。Exchange Server 分析工具报告在收集间隔期间性能计数器的最大值。Exchange Server 分析工具还报告所有收集的值的第九十百分位的值。

注意：
如果按照升序列出 Exchange Server 分析工具收集的所有值，第九十百分位数是列表中 90% 位置的值。第九十百分位数的值指示在收集间隔期间此计数器的峰值。

在某些情况下，最大值将为间隔中的峰值。因此，最大值不是整个间隔的代表。中值并非始终准确地指示负载，因为中值包括收集间隔期间的空闲时间。因此，Exchange Server 分析工具报告最大值和第九十百分位数的值。

此基准消息中的信息仅以提供信息为目的。不需要您执行任何操作。

有关性能计数器建议的阈值的详细信息，请参阅"Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)。


来自 LDAP Search Time 计数器的性能数据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包括性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎从 MSExchangeDSAccess Processes 性能对象的 LDAP Search Time 性能计数器中收集数据以分析性能数据。如果 Exchange Server 分析工具从 LDAP Search Time 性能计数器收集到任何数据，会将收集到的数据的有关信息显示为基准信息。

LDAP Search Time 性能计数器显示完成轻型目录访问协议 (LDAP) 搜索请求所需的时间（毫秒）。平均值应低于 50 毫秒。最大值不应超过 100 毫秒。

默认情况下，Exchange Server 分析工具在两个小时内每 30 秒检索一个示例。Exchange Server 分析工具报告在收集间隔期间性能计数器的最大值。Exchange Server 分析工具还报告所有收集的值的第九十百分位的值。

注意：
如果按照升序列出 Exchange Server 分析工具收集的所有值，第九十百分位数是列表中 90% 位置的值。第九十百分位数的值指示在收集间隔期间此计数器的峰值。

在某些情况下，最大值将为间隔中的峰值。因此，最大值不是整个间隔的代表。中值并非始终准确地指示负载，因为中值包括收集间隔期间的空闲时间。因此，Exchange Server 分析工具报告最大值和第九十百分位数的值。

此基准消息中的信息仅以提供信息为目的。不需要您执行任何操作。

有关性能计数器建议的阈值的详细信息，请参阅"Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)。


PhysicalDisk 性能监视器对象不可用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包括性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎从 PhysicalDisk 性能对象的 Avg. Disk sec/Read 性能计数器收集数据以分析性能数据。如果计数器未返回有效数据，Exchange Server 分析工具将显示基准消息。

如果性能数据收集引擎未返回有效数据，则可能出现下列情况的任意组合：

  • PhysicalDisk 性能对象已禁用。

  • PhysicalDisk 性能监视器对象丢失或损坏。

  • Exchange Server 分析工具没有访问性能对象的相应权限。

如果某些可扩展计数器破坏了注册表，或基于 Microsoft Windows® Management Instrumentation (WMI) 的程序修改了注册表，可能会发生前两种情况。以下过程说明如何处理前两种情况。在执行该过程之前，请验证 Exchange Server 分析工具是否具有相应的权限。有关运行 Exchange Server 分析工具所需的权限的详细信息，请参阅随 Exchange Server 分析工具提供的帮助文档。要获得帮助，请打开 Exchange Server 分析工具，然后按 F1 键。

更正此错误

  1. 验证 PhysicalDisk 性能对象是否已启用。

    1. 下载并安装可扩展性能计数器列表工具 (Exctrlst.exe)。可以在 Microsoft 网站上下载 Exctrlst.exe："Exctrlst.exe:Extensible Performance Counter List"（英文）(http://go.microsoft.com/fwlink/?LinkId=34436)。

    2. 打开 Exctrlst.exe，再单击"Sort Order"，然后单击"Service"。

    3. 找到性能对象所报告的服务，并确认选中了"Performance Counters Enabled"复选框。

      如果未选中"Performance Counters Enabled"复选框，请选中该复选框，然后重新启动与性能计数器关联的服务，确认性能计数器工作正常。如果性能计数器无法正常工作，或"Performance Counters Enabled"复选框已选中，请继续执行第 2 步。

  2. 重建丢失或损坏的性能计数器，请参阅 Microsoft 知识库文章 300956"如何手动重新生成性能计数器库值"(http://support.microsoft.com/?kbid=300956)。

  3. 如果按照此知识库文章操作不能解决问题，将必须在"修复"模式下重新安装 Windows 操作系统，然后应用最新的 Windows Service Pack。


端口冲突："站点复制服务"的定义
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取下列注册表项，以确定是否存在端口冲突：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

如果 Exchange Server 分析工具发现 HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP 的值与本文前面列出的其他六个端口注册表值中指定的任何一个值匹配，将显示错误。Exchange Server 分析工具还将对与 HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP 冲突的端口显示错误。

若要纠正此错误，必须将此注册表项或 Exchange Server 分析工具输出中指定的冲突项的值更改为唯一值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

设置 TCP/IP 注册表参数

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters

  3. 双击 TCP/IP 注册表项，然后将"数值数据"字段设置为刚好大于 5000 的唯一值（十进制）。

  4. 关闭注册表编辑器。

  5. 重新启动计算机，以使此设置生效。

部署 RPC over HTTP

  1. 查看"Exchange Server 2003 RPC over HTTP Deployment Scenarios"（英文）(http://go.microsoft.com/fwlink/?linkid=47577)。

  2. 查看 Microsoft 知识库文章 833401"如何在一台服务器上的 Exchange Server 2003 中配置 RPC over HTTP"(http://support.microsoft.com/kb/833401/zh-cn)。

  3. 查看知识库文章 827330"How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)。

  4. 查看 Microsoft 支持 Web 广播"Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关由 Exchange 使用的静态映射端口的详细信息，请参阅下列知识库文章：

  • 194952"XADM:Exchange Server 静态映射端口限制"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952)

  • 270836"Exchange 2000 和 Exchange 2003 静态端口映射"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)。


端口冲突:存储 HTTP
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-03-21

Microsoft® Exchange Server 分析工具读取下列注册表项，以确定是否存在端口冲突：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Exchange 使用注册表 Rpc/HTTP Port 项来支持 Microsoft Office Outlook® 2003 RPC/HTTP 和 Exchange Server 2007 Outlook Anywhere 功能。如果 Exchange Server 分析工具发现 HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters\Rpc/HTTP Port 的值与本文前面列出的其他六个端口注册表值中指定的任何一个值匹配，则显示错误。Exchange Server 分析工具还将针对与 HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters\Rpc/HTTP Port 冲突的端口显示错误。

若要解决此错误，必须将此注册表项或 Exchange Server 分析工具输出中指定的冲突项的值更改为唯一值。

如果要支持 RPC/HTTP Outlook 2003 或 Outlook 2007 客户端，应将 Rpc/HTTP Port 项设置为十进制值 6001。此外，还应查看环境中的 RPC/HTTP 配置。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

设置 Rpc/HTTP 端口注册表值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters

  3. 双击 Rpc/HTTP Port 注册表项，然后将"数值数据"字段设置为刚好大于 5000 的唯一值（十进制）。

  4. 关闭注册表编辑器。

  5. 重新启动计算机，以使此设置生效。

查看 RPC over HTTP 配置

  1. 查看"Exchange Server 2003 RPC over HTTP Deployment Scenarios"（英文）(http://go.microsoft.com/fwlink/?linkid=47577)。

  2. 查看"Deploying Outlook Anywhere"（部署 Outlook Anywhere）(http://go.microsoft.com/fwlink/?LinkId=80831)。

  3. 查看 Microsoft 知识库文章 833401"如何在一台服务器上的 Exchange Server 2003 中配置 RPC over HTTP"(http://support.microsoft.com/kb/833401/zh-cn)。

  4. 查看知识库文章 827330"How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)。

  5. 查看 Microsoft 支持网络广播"Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


端口冲突：存储 TCP
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-30

Microsoft® Exchange Server 分析工具读取下列注册表项，以确定是否存在端口冲突：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

如果 Exchange Server 分析工具发现 HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port 的值与本文前面列出的其他六个端口注册表值中指定的任何一个值匹配，将显示错误。Exchange Server 分析工具还将对与 HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port 冲突的端口显示错误。

配置该值的最常见理由是为了使 MAPI 客户端能够连接到在防火墙另一侧的 Exchange 服务器。该方案涉及打开防火墙上的多个端口，以使 Microsoft Office Outlook® 2003 或 Outlook 2007 客户端能够使用 MAPI 连接到 Exchange 服务器（通常通过 Internet）。

如果要在 MAPI 模式下使用 Outlook 通过 Internet 连接到 Exchange 服务器，则建议的部署是使用 RPC over HTTP 功能，可以在 Microsoft Windows Server™ 2003、Exchange Server 2003、Outlook 2003、Exchange Server 2007、Outlook 2007 和 Microsoft Windows® XP Professional 中找到该功能。MAPI 模式以前称为"公司"或"工作组"模式。

若要解决此错误，必须将此注册表项或 Exchange Server 分析工具输出中指定的冲突项的值更改为唯一值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

设置 TCP/IP Port 注册表值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 双击 TCP/IP Port 注册表项，然后将"数值数据"字段设置为刚好大于 5000 的唯一值（十进制）。

  4. 关闭注册表编辑器。

  5. 重新启动计算机，以使此设置生效。

部署 RPC over HTTP

  1. 查看"Exchange Server 2003 RPC over HTTP Deployment Scenarios"（英文）(http://go.microsoft.com/fwlink/?linkid=47577)。

  2. 查看"Deploying Outlook Anywhere"（部署 Outlook Anywhere）(http://go.microsoft.com/fwlink/?LinkId=80831)。

  3. 查看 Microsoft 知识库文章 833401"如何在一台服务器上的 Exchange Server 2003 中配置 RPC over HTTP"(http://support.microsoft.com/kb/833401/zh-cn)。

  4. 查看知识库文章 827330"How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)。

  5. 查看 Microsoft 支持 Web 广播"Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关静态映射 Exchange 使用的端口的详细信息，请参阅 Microsoft 知识库文章 270836"Exchange Server 静态端口映射"(http://support.microsoft.com/kb/270836/zh-cn)。


端口冲突:系统助理 HTTP
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-03-21

Microsoft® Exchange Server 分析工具读取下列注册表项，以确定是否存在端口冲突：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Exchange 使用 HTTP Port 项来支持 Microsoft Office Outlook® 2003 RPC/HTTP 和 Exchange Server 2007 Outlook Anywhere 功能。如果 Exchange Server 分析工具发现 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port 的值与本文前面列出的其他六个端口注册表值中指定的任何一个值匹配，则显示错误。Exchange Server 分析工具还将针对与 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port 冲突的端口显示错误。

若要解决此错误，必须将此注册表项或 Exchange Server 分析工具输出中指定的冲突项的值更改为唯一值。

如果要支持 RPC/HTTP Outlook 2003 或 Outlook 2007 客户端，应将 HTTP Port 项设置为十进制值 6002。此外，还应查看环境中的 RPC/HTTP 配置。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

设置 HTTP Port 注册表值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 双击 HTTP Port 注册表项，然后将"数值数据"字段设置为刚好大于 5000 的唯一值（十进制）。

  4. 关闭注册表编辑器。

  5. 重新启动计算机，以使此设置生效。

查看 RPC over HTTP 配置

  1. 查看"Exchange Server 2003 RPC over HTTP Deployment Scenarios"（英文）(http://go.microsoft.com/fwlink/?linkid=47577)。

  2. 查看"Deploying Outlook Anywhere"（部署 Outlook Anywhere）(http://www.microsoft.com/technet/prodtechnol/exchange/e2k7help/7b2d1ce2-b6df-4604-80fd-2f6cafc47e82.mspx)。

  3. 查看 Microsoft 知识库文章 833401"如何在一台服务器上的 Exchange Server 2003 中配置 RPC over HTTP"(http://support.microsoft.com/kb/833401/zh-cn)。

  4. 查看知识库文章 827330"How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)。

  5. 查看 Microsoft 支持 Web 广播"Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


端口冲突：System Attendant HTTP NSPI
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-30

Microsoft® Exchange Server 分析工具读取下列注册表项，以确定是否存在端口冲突：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Exchange 使用注册表 Rpc/HTTP NSPI Port 项来支持 Microsoft Office Outlook® 2003 RPC/HTTP 和 Exchange Server 2007 Outlook Anywhere 功能。如果 Exchange Server 分析工具发现 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port 的值与本文前面列出的其他六个端口注册表值中指定的任何一个值匹配，将显示错误。Exchange Server 分析工具还将对与 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\ Rpc/HTTP NSPI Port 冲突的端口显示错误。

若要解决此错误，必须将此注册表项或 Exchange Server 分析工具输出中指定的冲突项的值更改为唯一值。

如果要支持 RPC/HTTP Outlook 2003 客户端或 Outlook 2007，应将 Rpc/HTTP NSPI Port 项设置为十进制值 6004。此外，还应查看环境中的 RPC/HTTP 配置。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

设置 Rpc/HTTP NSPI Port 注册表值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 双击 Rpc/HTTP NSPI Port 注册表项，然后将"数值数据"字段设置为刚好大于 5000 的唯一值（十进制）。

  4. 关闭注册表编辑器。

  5. 重新启动计算机，以使此设置生效。

查看 RPC over HTTP 配置

  1. 查看"Exchange Server 2003 RPC over HTTP Deployment Scenarios"（英文）(http://go.microsoft.com/fwlink/?linkid=47577)。

  2. 查看"Deploying Outlook Anywhere"（部署 Outlook Anywhere）(http://go.microsoft.com/fwlink/?LinkId=80831)。

  3. 查看 Microsoft 知识库文章 833401"如何在一台服务器上的 Exchange Server 2003 中配置 RPC over HTTP"(http://support.microsoft.com/kb/833401/zh-cn)。

  4. 查看知识库文章 827330"How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)。

  5. 查看 Microsoft 支持 Web 广播"Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


端口冲突:系统助理 NSPI
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-03-21

Microsoft® Exchange Server 分析工具读取下列注册表项，以确定是否存在端口冲突：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

如果 Exchange Server 分析工具发现 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port 的值与本文前面列出的其他六个端口注册表值中指定的任何一个值匹配，则显示错误。Exchange Server 分析工具还将对与 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port 冲突的端口显示错误。

配置该值的最常见理由是为了使 MAPI 客户端能够连接到在防火墙另一侧的 Exchange 服务器。该方案涉及打开防火墙上的多个端口，以使 Microsoft Office Outlook® 2003 和 Outlook 2007 客户端能够使用 MAPI 连接到 Exchange 服务器（通常通过 Internet）。

如果要在 MAPI 模式下使用 Outlook 通过 Internet 连接到 Exchange 服务器，则建议的部署是使用 RPC over HTTP 功能，可以在 Microsoft Windows Server™ 2003、Exchange Server 2003、Outlook 2003、Exchange Server 2007、Outlook 2007 和 Microsoft Windows® XP Professional 中找到该功能。MAPI 模式以前称为"公司"或"工作组"模式。

若要解决此错误，必须将此注册表项或 Exchange Server 分析工具输出中指定的冲突项的值更改为唯一值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

设置 TCP/IP NSPI Port 注册表值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 双击 TCP/IP NSPI Port 注册表项，然后将"数值数据"字段设置为刚好大于 5000 的唯一值（十进制）。

  4. 关闭注册表编辑器。

  5. 重新启动计算机，以使此设置生效。

部署 RPC over HTTP

  1. 查看"Exchange Server 2003 RPC over HTTP Deployment Scenarios"（英文）(http://go.microsoft.com/fwlink/?linkid=47577)。

  2. 查看"Deploying Outlook Anywhere"（部署 Outlook Anywhere）(http://go.microsoft.com/fwlink/?LinkId=80831)。

  3. 查看 Microsoft 知识库文章 833401"如何在一台服务器上的 Exchange Server 2003 中配置 RPC over HTTP"(http://support.microsoft.com/kb/833401/zh-cn)。

  4. 查看知识库文章 827330"How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)。

  5. 查看 Microsoft 支持 Web 广播"Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关由 Exchange 使用的静态映射端口的详细信息，请参阅以下知识库文章：

  • 270836"Exchange Server 静态端口映射"(http://support.microsoft.com/kb/270836/zh-cn)。


端口冲突：System Attendant RFR
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-30

Microsoft® Exchange Server 分析工具读取下列注册表项，以确定是否存在端口冲突：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

如果 Exchange Server 分析工具发现 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port 的值与本文前面列出的其他六个端口注册表值中指定的任何一个值匹配，则显示错误。Exchange Server 分析工具还将对与 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port 冲突的端口显示错误。

配置该值的最常见理由是为了使 MAPI 客户端能够连接到在防火墙另一侧的 Exchange 服务器。该方案涉及打开防火墙上的多个端口，以使 Microsoft Office Outlook® 2003 或 Outlook 2007 客户端能够使用 MAPI 连接到 Exchange 服务器（通常通过 Internet）。

如果要在 MAPI 模式下使用 Outlook 通过 Internet 连接到 Exchange 服务器，则建议的部署是使用 RPC over HTTP 功能，可以在 Microsoft Windows Server™ 2003、Exchange Server 2003、Outlook 2003、Exchange Server 2007、Outlook 2007 和 Microsoft Windows® XP Professional 中找到该功能。MAPI 模式以前称为"公司"或"工作组"模式。

若要解决此错误，必须将此注册表项或 Exchange Server 分析工具输出中指定的冲突项的值更改为唯一值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

设置 TCP/IP Port 注册表值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 双击 TCP/IP Port 注册表项，然后将"数值数据"字段设置为刚好大于 5000 的唯一值（十进制）。

  4. 关闭注册表编辑器。

  5. 重新启动计算机，以使此设置生效。

部署 RPC over HTTP

  1. 查看"Exchange Server 2003 RPC over HTTP Deployment Scenarios"（英文）(http://go.microsoft.com/fwlink/?linkid=47577)。

  2. 查看"Deploying Outlook Anywhere"（部署 Outlook Anywhere）(http://go.microsoft.com/fwlink/?LinkId=80831)。

  3. 查看 Microsoft 知识库文章 833401"如何在一台服务器上的 Exchange Server 2003 中配置 RPC over HTTP"(http://support.microsoft.com/kb/833401/zh-cn)。

  4. 查看知识库文章 827330"How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)。

  5. 查看 Microsoft 支持 Web 广播"Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关静态映射 Exchange 使用的端口的详细信息，请参阅 Microsoft 知识库文章 270836"Exchange Server 静态端口映射"(http://support.microsoft.com/kb/270836/zh-cn)。


检测到预发布的 Service Pack 累积更新
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 Exchange Server 对象的 versionNumber 属性值。versionNumber 属性代表计算机上所运行的 Exchange Server 的版本。

Exchange Server 分析工具还查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange Collaboration Data Object (ExCDO) 库文件 ExCDO.dll 的 Version 关键字的值。如果 Exchange Server 分析工具确定 ExCDO.dll 的 Version 关键字的值等于 6603.0，则显示警告。

如果 Exchange 2000 服务器计算机正在运行 6603.0 版本的 ExCDO.dll，则说明服务器正在运行 2004 年 8 月版本 1 的 Exchange 2000 Server Post-Service Pack 3 (SP3) 累积更新。该累积更新的版本 2 现在已经可用。建议您安装 2004 年 8 月的累积更新。

解决此警告问题

  1. 查看 Microsoft 知识库文章 870540"Availability of the August 2004 Exchange 2000 Server Post-Service Pack 3 Update Rollup"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540)，了解有关最新更新的信息。

  2. 从"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457) 下载最新的更新（2004 年 8 月）。

  3. 备份 Exchange Server 计算机。

  4. 应用 2004 年 8 月的累积更新。

有关获取 Exchange 2000 Server 的最新 Service Pack 的详细信息，请参阅 Microsoft 知识库文章 301378"如何获取最新的 Exchange 2000 Server Service Pack"(http://support.microsoft.com/?kbid=301378)

有关安装此更新以及其他 Exchange Server 更新的详细信息，请参阅知识库文章 328839"HOW TO：应用 Exchange Service Pack 和修复程序"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)


页面文件位置问题
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具确定您的页面文件位于会对服务器性能产生不良影响的位置。页面文件不应与 Exchange 数据库或 Exchange 日志文件位于相同的磁盘中。最好将页面文件从系统文件中隔离出来。

建议将页面文件放置在专用分区或高速磁盘中。

解决此警告问题

  • 将页面文件移至不包含 Exchange 数据库或日志文件的位置，如果可能，移至不包含系统分区的位置。

详细信息

  • 有关页面文件配置的详细信息，请参阅 Microsoft 知识库文章 197379"在 Windows Server 2003、Windows 2000 和 Windows NT 中配置页面文件以进行优化和恢复"(http://support.microsoft.com/kb/197379/zh-cn)。

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。


处理器瓶颈
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-02-24

Microsoft® Exchange Server 分析工具已确定服务器遇到 CPU 瓶颈。服务器的 CPU 利用率已经超过推荐的阈值。用于识别处理器瓶颈或处理器利用率问题的计数器包括：

  • System 性能对象下的 Context Switches/sec 性能计数器。

  • Processor 性能对象下的 % Processor Time (_Total) 性能计数器。

  • System 性能对象下的 Processor Queue Length 性能计数器。

检测处理器瓶颈

如果符合下列条件之一，则 Exchange Server 分析工具检测到是否存在瓶颈：

  • Process 性能对象下的 % Processor Time (_Total) 性能计数器的平均值大于 70%。

  • Process 性能对象下的 % Processor Time (_Total) 性能计数器的最大值大于 90%。

  • System 性能对象下的 Context Switches/second 性能计数器的平均值大于 20,000。

  • System 性能对象下的 Processor Queue Length 性能计数器大于 2。

  • Process 性能对象下的此 % Processor Time (_Total) 性能计数器提供处理器的整体利用率。平均的 CPU 利用率应始终低于 80%。更高的平均值表明存在处理器瓶颈。如果处理器平均利用率高于 70%，将显示警告。如果处理器时间中频繁出现高于 90% 的峰值，也表明存在处理器瓶颈。

  • System 性能对象下的 Processor Queue Length 性能计数器表示处理器队列中的线程数。即使在拥有多个处理器的计算机上，也只有一个队列用于处理器时间。数字大于 2 则表明线程正在等待处理器时间，存在处理器瓶颈。

确定处理器负载的来源

如果找到处理器瓶颈，则必须确定大多数 CPU 利用率的来源。在 Exchange 后端服务器上，大多数 CPU 利用率应来自 Store.exe 进程。如果超过 20% 的 CPU 利用率来自 Store.exe 以外的其他进程，则需要找到占用 CPU 利用率的其他进程，这一点非常重要。

如果下表中列出的进程的 CPU 利用率高于阈值，Exchange Server 分析工具将显示错误。

进程 | Process 性能对象下的 %Processor Time 性能计数器的阈值
Store | 90%
Inetinfo | 20%
Emsmts | 40%
Lsass | 40%
System | 40%
Mad | 40%
ExMGMT | 20%
W3WP | 40%

Exchange Server 分析工具还评估 %Processor Time 性能计数器（Idle 实例）测量的空闲处理器时间与 Process 性能对象下的 %Processor Time 性能计数器（_Total 实例）之间的差异。在正常运行的 Exchange 后端服务器上，所用的处理器时间应至少有 70% 花费在 Store.exe 进程上。

在下列条件下，Exchange Server 分析工具将显示错误：

  • 未用于与 Exchange 服务器有关的进程（Store.exe、inetinfo.exe、emsmta.exe、lsass.exe、w3wp.exe、exmgmt.exe 或 mad.exe 进程）的处理器时间高于 35%。

  • 与 Exchange 无关的处理器时间高于 20%。

  • 存在处理器瓶颈，并且用于 Store.exe 进程的处理器时间不到 70%。

在上述所有情况下，建议您找到占用服务器 CPU 时间的其他进程。

后端服务器处理器瓶颈的常见原因

性能瓶颈可能有许多原因，包括：

  • 服务器上其他应用程序占用了 CPU 利用率

  • 高 RPC 速率

  • 通讯组列表扩展

  • 在高峰期进行备份和维护

  • 因为下列原因对邮件中的邮件内容进行转换：

    • 运行的协议（例如 HTTP、POP3、IMAP4、Microsoft Office Outlook®）有多个

    • 使用脱机文件夹（.ost 文件）的是 Outlook 2000 或更早版本

消除处理器瓶颈

可以通过许多方式消除 Exchange 服务器的处理器瓶颈。

消除处理器瓶颈

  • 如果可能，应为服务器添加更多或更快的处理器。此外，如果处理器支持，应启用超线程。可以通过配置系统 BIOS 来启用超线程。有关详细信息，请参阅计算机制造商的帮助文档。

  • 如果提高处理能力不可行，那么必须减小处理器负载。若要降低对服务器的整体影响，请确保在正常工作时间范围以外执行 I/O 密集型、CPU 密集型或内存密集型的任务，这一点很重要。

    首先，确定产生服务器负载的应用程序或任务。如果非 Exchange 应用程序对于该服务器并不重要，则在其他服务器上运行该应用程序。如果可能，将服务器角色也转移到其他计算机上。例如，如果 Inetinfo 进程占用大量 CPU 利用率，则应考虑添加前端服务器来承担 Inetinfo 执行的协议工作的职责。也可以将公用文件夹存取转移到专用的公用文件夹服务器。最后，如果服务器执行大量通讯组列表扩展，那么可以通过将通讯组列表扩展转移到专用的通讯组列表扩展服务器来降低 CPU 利用率。

  • 确保在非高峰期执行 CPU 密集型任务（例如备份任务和维护任务）。此外，确保分阶段执行这些任务。分阶段执行任务意味着为每个任务设置不同的开始时间，同时最好设置不同的结束时间。分阶段维护和备份数据库或存储组还可以减小这些资源密集型任务产生的影响。

  • 如果已删除了所有可选的负载来源，但是 CPU 利用率仍太高，则必须通过将用户转移到其他服务器来减小负载。有关详细信息，请参阅将用户邮箱移至其他服务器

详细信息

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关移动用户邮箱以降低服务器负载的详细信息，请参阅将用户邮箱移至其他服务器


Processor 性能监视器对象不可用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 Processor 性能对象的 % Processor Time 性能计数器收集数据，以分析性能数据。如果计数器未返回有效数据，Exchange Server 分析工具将显示基准消息。

如果性能数据收集引擎未返回有效数据，则可能出现下列情况的任意组合：

  • Processor 性能对象已禁用。

  • Processor 性能监视器对象丢失或损坏。

  • Exchange Server 分析工具没有访问性能对象的相应权限。

如果某些可扩展计数器破坏了注册表，或基于 Microsoft Windows® Management Instrumentation (WMI) 的程序修改了注册表，可能会发生前两种情况。以下过程说明如何处理前两种情况。在执行该过程之前，请验证 Exchange Server 分析工具是否具有相应的权限。有关运行 Exchange Server 分析工具所需的权限的详细信息，请参阅随 Exchange Server 分析工具提供的帮助文档。要获得帮助，请打开 Exchange Server 分析工具，然后按 F1 键。

更正此错误

  1. 验证 Processor 性能对象是否已启用。

    1. 下载并安装可扩展性能计数器列表工具 (Exctrlst.exe)。可以在"Exctrlst.exe: Extensible Performance Counter List"（英文）(http://go.microsoft.com/fwlink/?LinkId=34436) 下载 Exctrlst.exe。

    2. 打开 Exctrlst.exe，再单击"Sort Order"，然后单击"Service"。

    3. 找到性能对象所报告的服务，并确认选中了"Performance Counters Enabled"复选框。

      如果未选中"Performance Counters Enabled"复选框，请选中该复选框，然后重新启动与性能计数器关联的服务，确认性能计数器工作正常。如果性能计数器无法正常工作，或"Performance Counters Enabled"复选框已选中，请继续执行第 2 步。

  2. 重建丢失或损坏的性能计数器，请参阅 Microsoft 知识库文章 300956"如何手动重新生成性能计数器库值"(http://support.microsoft.com/?kbid=300956)。

  3. 如果按照此知识库文章操作不能解决问题，将必须在"修复"模式下重新安装 Windows 操作系统，然后应用最新的 Windows Service Pack。


公用文件夹内容复制已暂停
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定是否为 Exchange Server 组织设置了 heuristics 属性。如果 Exchange Server 分析工具发现在 heuristics 中设置了 1024 位，则会显示警告。

Exchange Server 2003 SP2 允许管理员停止组织中的所有公用文件夹内容复制。在"Exchange 系统管理"中用鼠标右键单击组织名，再单击"停止公用文件夹内容复制"，可以停止所有公用文件夹复制。单击"停止公用文件夹内容复制"后，即在 heuristics 属性中设置了 1024 位。只有在极端的情况下才应停止所有公用文件夹复制，例如解决组织范围内的公用文件夹或邮件流问题。

如果下列条件为真，必须恢复公用文件夹内容复制：

  • 您未在进行故障排除。

  • 您不需要停止所有公用文件夹内容复制。

在组织级别恢复公用文件夹内容复制

  1. 打开 Exchange 系统管理器。

  2. 用鼠标右键单击"组织名"，然后单击"恢复公用文件夹内容复制"。

有关公用文件夹复制的详细信息，请参阅"Best Practices for Exchange Server Public Folders"（英文）(http://go.microsoft.com/fwlink/?LinkId=46437)。


公用文件夹存储出现在前端服务器上
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-09-07

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 Exchange 服务器上是否存在公用文件夹存储。如果 Exchange Server 分析工具发现 InformationStore 对象属于对象类 msExchPublicMDB，则该服务器当前承载了公用文件夹存储。

Exchange Server 分析工具还查询 MicrosoftExchangeV2 Microsoft Windows® Management Instrumentation (WMI) 类，以确定是否设置了 IsFrontEndServer 关键字的值。值为 True 表示 Exchange 服务器被配置为前端服务器，而值为 False 则表示 Exchange 服务器没有配置为前端服务器。如果 Exchange Server 分析工具发现被配置为前端服务器的 Exchange 服务器正在承载公用信息存储，则会显示警告。

建议不要在前端服务器上运行公用文件夹存储。在前端服务器上，公用文件夹存储不是必需的，因为前端服务器不承载邮箱。此外，如果公用文件夹存储位于运行 Exchange 2000 Server 的前端服务器上，则公用文件夹复制、公用文件夹引用和内存泄漏会存在一些已知问题。因此，应当在所有前端服务器上卸除所有公用文件夹存储。

卸除公用文件夹存储之后，可以禁用 Microsoft Exchange 信息存储服务，因为它在前端服务器上不再执行任何功能。通过删除不需要的服务，可以减少负载并提高安全性和性能。

注意：
如果前端服务器还从 Internet 接收简单邮件传输协议 (SMTP) 邮件，则应当让 Microsoft Exchange 信息存储服务继续运行，并且还必须装入邮箱存储。但是，始终不应在前端服务器上运行公用文件夹存储。

停止并禁用邮箱和公用文件夹数据库

  1. 在 Exchange 系统管理器中，展开"服务器"，展开您的服务器，再展开"第一个存储组"。

    用鼠标右键单击"邮箱存储"（服务器名），再单击"卸除存储"，然后单击"是"卸除存储。

    重要信息：
    如果使用前端服务器作为 SMTP 桥头服务器，必须在服务器上装入邮箱存储。在这种情况下，不要卸除和删除该存储，但要确保没有将任何邮箱存储在该服务器上。

  2. 用鼠标右键单击"邮箱存储（服务器名）"，再单击"属性"。

  3. 单击"数据库"选项卡，选中"启动时不装入此存储"复选框，再单击"确定"。

    用鼠标右键单击"公用文件夹存储"（服务器名），再单击"卸除存储"。

    警告：
    在卸除公用文件夹存储之前，请确保在另一个公用文件夹存储上存在这些公用文件夹的副本。否则，可能丢失信息。

  4. 单击"是"卸除公用文件夹存储。

禁用 Microsoft Exchange Information Store 服务

  1. 在"服务"Microsoft 管理控制台 (MMC) 管理单元中，用鼠标右键单击"名称"列表中的"Microsoft Exchange Information Store"，再单击"属性"。

  2. 在"启动类型"列表中，选择"禁用"，再单击"停止"。

永久删除邮箱和公用文件夹数据库

  • 遵循"Exchange Server 安全强化指南"中的指导"How to Dismount and Delete the Mailbox and Public Folder Stores"（如何卸除和删除邮箱存储和公用文件夹存储）(http://go.microsoft.com/fwlink/?LinkId=25210)

有关在前端服务器上运行存储服务的相关问题的详细信息，请参阅下列 Microsoft 知识库文章：

  • 286822"XCCC:Front-End Servers Establish Large Number of Connections to Themselves"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=286822)

  • 320298"Large number of connections established on front-end servers that are running Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320298)

有关前端和后端服务器的详细信息，请参阅"Front-End and Back-End Server Topology Guide for Exchange Server 2003 and Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=34216)。


REAPI.DLL 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查几个核心 Exchange 二进制文件是否存在：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现一个或多个上述文件丢失，则显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


Recipient Update Service is missing or is not configured
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-07-11

Microsoft Exchange Server 分析工具查询 Active Directory 目录服务，以确定该目录中每个"收件人更新服务"对象的 msExchAddressListServiceLink 属性值。msExchAddressListServiceLink 属性是从地址列表服务到它应当运行于其上的 Exchange Server 计算机的链接。如果 Exchange 分析工具发现"收件人更新服务"对象没有 msExchAddressListServiceLink 属性，或是未填充该对象的 msExchAddressListServiceLink 属性值，则会显示一条错误消息。

通常每个收件人更新服务实例都与一个运行收件人更新服务的 Exchange Server 计算机关联。如果收到该消息，则说明收件人更新服务实例未与任何 Exchange Server 计算机关联。这可能会导致 Exchange 地址列表和收件人不会被更新。

若要运行该收件人更新服务实例，必须将它其现有 Exchange 服务器关联。

更正此错误

  1. 打开 Exchange 系统管理器。

  2. 在"收件人"下，单击"收件人更新服务"。在右侧窗格中，用鼠标右键单击合适的收件人更新服务实例，再单击"属性"。

  3. 在"常规"选项卡上的 Exchange Server 下，单击"浏览"，并指定要运行该实例的新服务器。

  4. 单击"确定"，然后再次单击"确定"，以使更改生效。

  5. 关闭 Exchange 系统管理器。

有关收件人更新服务的详细信息，请参阅下列主题和 Microsoft 知识库文章：

  • "Exchange Server 2003 管理指南"中的"在 Exchange Server 2003 中管理收件人和收件人策略"(http://go.microsoft.com/fwlink/?linkid=47617)

  • 328738"收件人更新服务如何应用收件人策略"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828"收件人更新服务如何填充地址列表"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127"如何检查 Exchange 收件人更新服务的进度"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770"Exchange 收件人更新服务执行的任务"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


对群集上的 Windows 2000 Server SP 4 的建议更新
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定运行于 Exchange 服务器上的 Microsoft Windows® 操作系统的版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion

注意：
CurrentVersion 的值为 4.0 说明计算机正在运行 Microsoft Windows NT® Server 4.0。值为 5.0 说明计算机正在运行 Microsoft Windows 2000 Server。值为 5.2 说明计算机正在运行 Microsoft Windows Server™ 2003。

Exchange Server 分析工具还查询 Win32_OperatingSystem Windows Management Instrumentation (WMI) 类，以确定 ServicePackMajorVersion 关键字的值。

最后，Exchange Server 分析工具查询 Win32_Service WMI 类，以确定 ClusSvc 服务是否已启动。

如果符合下列条件，Exchange Server 分析工具将显示最佳做法配置消息：

  • Exchange 服务器位于正在运行已使用 Service Pack 4 进行升级的 Windows 2000 Server 的计算机上。

  • ClusSvc 服务已启动。

建议评估可用的更新和修补程序，确定是否可以解决您的环境中的问题。

有关详细信息以及运行 Windows 2000 Server 的服务器可用的更新列表，请参阅 Microsoft 知识库文章 895090"Recommended hotfixes for Windows 2000 Service Pack 4-based server clusters"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895090)。


Remote Queue length 超出阈值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-04-09

Microsoft Exchange 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 SMTP Server 性能对象的 Remote Queue Length 性能计数器收集数据，以分析性能数据。

如果 Exchange 分析工具确定 Remote Queue Length 计数器在示例时间段内超出峰值 1000，则将显示错误信息。

SMTP Server\Remote Queue Length 计数器指示简单邮件传输协议 (SMTP) 队列中等待远程传递的邮件数。Remote Queue Length 的增加意味着邮件没有发送到其他服务器。

这种发送邮件失败的情况可以解释为网络或远程服务器中断或性能问题。这些中断或性能问题使网络或远程服务器无法有效地接收邮件。

若要解决该错误，请使用下列链接中的资源，以识别有问题的服务器或网络组件，然后解决这些性能问题。

详细信息

  • 有关排除 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"中"Identifying the Symptoms of Poor Performance"部分的"Identifying Rising Mail Queues"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关 Exchange Server 性能的详细信息，请参阅 Performance and Scalability Guide for Exchange Server 2003（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关 Exchange Server 性能的详细信息，请参阅"Exchange Server 2003 Performance:10 Things to Think About"（Exchange Server 2003 性能：要考虑的 10 件事情）(http://go.microsoft.com/fwlink/?LinkID=56460)。


Remote Retry Queue length 超出阈值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-02-13

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 SMTP Server 性能对象的 Remote Retry Queue Length 性能计数器收集数据，以分析性能数据。

SMTP Server\Remote Retry Queue Length 计数器表示在简单邮件传输协议 (SMTP) 远程重试队列中无法被发送到目标服务器的邮件数。如果 Exchange Server 分析工具确定 Remote Retry Queue Length 计数器在示例时间段内已超过了峰值 1000，则将显示一个错误信息。

这种发送邮件失败的情况可以解释为网络或远程服务器中断或性能问题。这些中断或性能问题使网络或远程服务器无法有效地接收邮件。

若要解决该错误，请使用下列链接中的资源，以识别有问题的服务器或网络组件，然后解决这些性能问题。

详细信息

  • 有关排除 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"中"Identifying the Symptoms of Poor Performance"部分的"Identifying Rising Mail Queues"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关 Exchange Server 性能的详细信息，请参阅"Exchange Server 2003 Performance: 10 Things to Think About"（英文）(http://go.microsoft.com/fwlink/?LinkID=56460)。


找不到脱机通讯簿版本 4 的副本
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-02-13

Microsoft® Exchange Server 分析工具查询 Exchange_Public_Folder Microsoft Windows® Management Instrumentation (WMI) 类，以确定 HasLocalReplica 的当前值。如果 Exchange Server 分析工具发现脱机地址列表的脱机通讯簿版本 4 实例的 HasLocalReplica 值设置为 False，则将显示错误信息。

当脱机地址列表的脱机通讯簿版本 4 实例的 HasLocalReplica 设置为 False 时，则无法正确生成脱机地址列表。因此 Microsoft Office Outlook® 2003 无法下载任何脱机地址列表。

如果尚未配置任何公用文件夹存储以包含脱机通讯簿版本 4 的副本，则可能出现此问题。默认情况下，脱机通讯簿将内容复制到其所安装到的服务器的公用文件夹存储中。如果将公用文件夹存储从脱机通讯簿的复制配置中删除，则会发生上一段中所述的问题。

更正此错误

  1. 打开"Exchange 系统管理器"。

  2. 展开"管理组"，再单击"文件夹"。

  3. 右键单击"公用文件夹"，再单击"查看系统文件夹"。

  4. 单击以展开"脱机通讯簿"对象。

  5. 在"脱机通讯簿"中，右键单击 o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List，再单击"属性"。

  6. 在"复制"选项卡上，验证已在"将内容复制到下列公用存储"框中输入了公用文件夹存储。如果未输入公用文件夹存储，请单击"添加"，并输入适合脱机通讯簿的公用存储。

  7. 单击"应用"，再单击"确定"。

  8. 单击以展开 o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List。

  9. 在 o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List 中，右键单击"脱机通讯簿版本 4"，再单击"属性"。

  10. 在"复制"选项卡上，验证已在"将内容复制到下列公用存储"框中输入了公用文件夹存储。如果未输入公用文件夹存储，请单击"添加"，并输入适合脱机通讯簿的公用存储。

  11. 单击"应用"，再单击"确定"。

有关此问题的详细信息，请参阅 Microsoft 知识库文章 286328"Offline Address Book Is Missing and Cannot Be Generated in Microsoft Exchange"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328)。

有关如何从管理组中删除第一台运行 Exchange Server 2003 的计算机的详细信息，请参阅知识库文章 822931"如何从管理组中删除第一台 Exchange Server 2003 计算机"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822931)。

有关脱机通讯簿问题的详细信息，请参阅下列 Exchange Server 资源：

  • "Offline Address Book - Things to Consider"（英文）(http://go.microsoft.com/fwlink/?LinkId=57581)

  • "How Outlook 2003 SP2 and Exchange Server 2003 SP2 OAB Version 4 Work Together"（英文）(http://go.microsoft.com/fwlink/?linkid=53099)。

  • "OAB Version 4 in Exchange Server 2003 Service Pack 2"（英文）(http://go.microsoft.com/fwlink/?linkid=53097)。


Replication Receive Queue 队列长度超出阈值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-02-13

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 MSExchangeIS Public 性能对象的 Replication Receive Queue Size 性能计数器收集数据，以分析性能数据。

如果 Exchange Server 分析工具确定 Replication Receive Queue Size 计数器在示例时间段内超出峰值 1000，则将显示错误信息。

公用文件夹复制邮件通过 SMTP 进行接收、分类并传递到本地 SMTP 队列。然后系统将这些邮件提交到公用文件夹存储。当提交到公用文件夹存储后，这些邮件将被放入到 Replication Receive Queue 中。随后系统将处理 Replication Receive Queue 中的邮件，并对相应的公用文件夹执行更改。Replication Receive Queue Size 性能计数器表示正在等待处理的公用文件夹复制邮件的数目。

复制队列越大，文件夹中的内容越不同步。当复制队列增大后，因为要处理复制队列中的邮件，资源负载将增加。另外，复制队列增大也表明服务器上的公用文件夹内容已过时。

在下列两个实例中（其中 Replication Receive Queue 的增加是预期中的且可计划的）不需要执行任何操作：

  • 对于新引入的公用文件夹服务器，Replication Receive Queue 中的增长可能是由预期的初始回填复制导致的。

  • 如果 Exchange 拓扑结构中出现站点合并或其他重要更改，则在移动内容时会出现大量复制。

对于未对其公用文件夹副本进行批量更改的现有的、状态稳定的服务器而言，该错误可能表示：

  • 服务器资源性能瓶颈（如磁盘、CPU、网络或内存）。如果服务器上存在资源瓶颈，则 Store.exe 进程将无法足够快地处理复制邮件，因此队列就会增大。

  • 公用文件夹复制间隔太短，以至在下一轮复制开始前复制无法完成。

若要解决该问题，请采取下列步骤：

  • 加大复制间隔时间，并监视 MSExchangeIS Public\Replication Receive Queue Size，直到它显示复制完成，然后启动下一轮复制。

  • 使用以下链接中的资源来确定是否因为性能瓶颈而导致队列增长，并解决该瓶颈。

  • 考虑减少 Exchange 组织中的副本总数，从而减少所需的复制通信量。

详细信息

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"(http://go.microsoft.com/fwlink/?LinkId=47588) 中的"Handling Special Exchange Roles and Performance"（英文）。

  • 有关 Exchange Server 公用文件夹复制的详细信息，请参阅"Working with Exchange Server 2003 Stores"(http://go.microsoft.com/fwlink/?LinkId=47595) 中的"Controlling Exchange Server 2003 Public Folder Replication"（英文）。

  • 有关 Exchange 公用文件夹最佳做法的详细信息，请参阅"Exchange Public Folder Best Practices: Implementing Replication"（英文）(http://go.microsoft.com/fwlink/?LinkId=46440)。

  • 有关随 Exchange Server 2003 Service Pack 2 引入的公用文件夹管理中的改进功能的详细信息，请参阅"Microsoft Exchange Server 2003 Service Pack 2 Release Notes"（英文）(http://go.microsoft.com/fwlink/?linkid=52072)。


RESVC.DLL 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查是否存在下列几个核心 Exchange 二进制文件：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现一个或多个上述文件丢失，则显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


RestrictRemoteClients 注册表项已启用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定远程过程调用 (RPC) 接口限制是否已启用：

HKEY_LOCAL_MACHINE\ Software\Policies\Microsoft\Windows NT\RPC

如果 Exchange Server 分析工具发现 RestrictRemoteClients 注册表项已配置，则会显示非默认配置消息。

RPC 接口限制增强了网络保护，将使系统不易受到来自网络的攻击。RestrictRemoteClients 注册表值修改系统上所有 RPC 接口的行为。默认情况下，RestrictRemoteClients 注册表值将禁止对系统上的 RPC 接口进行远程匿名访问，但有一些例外。

使用 RpcServerRegisterIf 注册了接口后，RPC 允许服务器应用程序限制对接口的访问（通常通过安全回调）。RestrictRemoteClients 注册表值启用 RPC 以便对所有接口执行附加的安全检查，即使接口没有已注册的安全回调时，也是如此。

注意：
使用命名管道协议序列的 RPC 客户端不受任何限制。由于存在严重的向后兼容问题，导致无法限制管道协议序列。
注意：
也可以使用"组策略编辑器"配置 the RestrictRemoteClients 注册表项。

使用 DWORD 值配置 RestrictRemoteClients 注册表项。如果该注册表值不存在，则空值等同于 RPC_Restrict_Remote_Client_Default 值。

下表提供有关 RestrictRemoteClients 配置设置的信息。

注册表项值 (DWORD) 说明

0（默认值）

RPC_RESTRICT_REMOTE_CLIENT_NONE (0) 代表 Microsoft Windows Server™ 2003 Service Pack 1 中的默认值。默认值设置使系统绕过 RPC 接口限制。

默认值设置对应于 RPC_RESTRICT_REMOTE_CLIENT_NONE 的值。服务器应用程序负责强制实施相应的 RPC 限制。此默认设置等同于早期 Windows 版本中的 RestrictRemoteClients 的设置 。

1

RestrictRemoteClients 注册表项中的值 1 代表 Microsoft Windows® XP Service Pack 2 中的默认值。值设置 1 限制对所有 RPC 接口的访问。RPC 运行时拒绝所有远程匿名调用。

此值设置对应于 RPC_RESTRICT_REMOTE_CLIENT_DEFAULT 的值。如果接口注册了安全回调并提供 RPC_IF_ALLOW_CALLBACKS_WITH_NO_AUTH 标志，则此限制将不应用于该接口。

2

如果 RestrictRemoteClients 注册表项的值为 2，则说明 RPC 运行时拒绝所有远程匿名调用，没有任何例外。

此值设置对应于 RPC_RESTRICT_REMOTE_CLIENT_HIGH 的值。如果 RestrictRemoteClients 值配置为 2，系统无法使用 RPC 接收远程匿名调用。

有关 Windows XP Service Pack 2 对 RPC 服务所做更改的详细信息，请参阅 MSDN® 文章"RPC Interface Restrictions"（英文）(http://go.microsoft.com/fwlink/?LinkId=47371)。


RFR 目标服务器已被手动覆盖
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取 Exchange 服务器上的下列注册表项，以确定目录服务代理引用 (DSProxy referral) 服务是否被手动覆盖：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\RFR Target Server

如果 Exchange Server 分析工具发现 RFR Target Server 存在并已配置，则显示非默认配置消息。

当 Microsoft Outlook® 2000 服务发布版 2 (SR 2) 或更高版本的客户端第一次连接到 Exchange 2000 Server 或 Exchange Server 2003 计算机时，它将在主 Exchange 服务器上查找目录服务。Outlook 最初通过 DSProxy 进程来完成第一次会话。在客户端联系到 DSProxy 服务之后，DSProxy 引用将传回客户端，并通知客户端所有未来的目录请求都应当转到全局编录服务器。Outlook 在注册表内的 MAPI 配置文件中设置 DSProxy 引用信息。

DSProxy 引用机制减少了 Exchange 服务器上的负载，并减少了搜索通讯簿的延迟时间。如果在配置文件中输入了明确的服务器名，则当全局编录服务器出现故障时，Outlook 必须重新启动。如果发生这种情况，Exchange 服务器将向 Outlook 发送一个新引用。

在某些情况下，首选做法是对 RFR Target Server 条目进行硬编码，以指定应当用于 MAPI 客户端引用服务的服务器。例如，在将全局编录服务器降级为成员服务器之前的一周，应当对 RFR Target Server 条目进行硬编码，以定义全局编录服务器的组。这将确保 Outlook 客户端上的 MAPI 配置文件不再引用被降级的全局编录服务器。有关 RFR Target Server 注册表项的这种特定用法的详细信息，请参阅 Microsoft 知识库文章 305065"XADM:Exchange Server-Related Considerations for Demoting a Global Catalog Server to a Domain Controller"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=305065)。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

使用 RFR Target Server 注册表值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 创建一个名为 RFR Target Server 的新 REG_MULTISZ 值。

  4. 用想要指定的一个或多个服务器的完全限定的域名来配置 RFR Target Server 值。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange System Attendant 服务，以使更改生效。

若要禁用 RFR 服务器的静态设置，请删除要删除的服务器的完全限定域名条目。如果只输入了一个 RFR 目标服务器，那么请删除 RFR Target Server 注册表值。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Outlook 2000 SR-2 和较新的客户端如何与 Active Directory® 目录服务交互的详细信息，请参阅下列 Microsoft 知识库文章：

  • 302914"XCCC:How Outlook 2000 Accesses Active Directory"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914)

  • 256976"XCLN:How MAPI Clients Access Active Directory"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976)


当前启用了 RegTrace
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已对 Exchange Server 计算机启用高级诊断跟踪：

HKEY_LOCAL_MACHINE\Software\Microsoft\MosTrace\CurrentVersion\DebugAsyncTrace\EnabledTraces

如果 Exchange Server 分析工具发现存在 EnabledTraces 注册表项，并且它被配置为 0 以外的任何值，则会显示错误。

使用 Regtrace 实用程序 (Regtrace.exe)，可以实现 Exchange Server 传输和路由组件的高级诊断跟踪。Regtrace 工具对于进行未送达报告 (NDR) 的诊断和故障排除尤其有用。可以在 Exchange Server CD 的 \Support\Utils\I386 文件夹中找到 Regtrace 实用程序。

跟踪文件位于在 Regtrace 实用程序的 Output 选项卡上所指定的位置。该文件的默认位置是 C:\Trace.atf。跟踪文件是二进制编码的文件，其中包含有关被跟踪的传输和路由组件的调试级别信息。因此，Microsoft 产品支持服务要求客户发送跟踪文件，以便进行内部分析。

除非您在对问题进行故障排除，否则，Microsoft 提醒您，如果启用 Regtrace，可能会严重影响服务器的性能，只应当在 Microsoft 产品支持服务的指导下短时间使用。除了性能之外，跟踪文件的磁盘空间可以以每分钟 10 MB 或更高的速率使用。如果您未在对问题进行故障排除，若要解决此错误，可以使用 Regtrace 禁用跟踪。

使用 Regtrace 禁用高级诊断跟踪

  1. 将 Regtrace.exe 从 Exchange Server CD 复制到 Exchange Server 计算机。

  2. 在 Exchange Server 计算机上执行 Regtrace.exe。将出现 Regtrace 用户界面。

  3. 在 Traces 选项卡上，清除所有复选框。

  4. 选择 Output 选项卡，并选择 No Tracing。

  5. 单击"确定"，保存您的更改并关闭 Regtrace 实用程序。
  • 有关 Regtrace 工具的详细信息，请参阅 Microsoft 知识库文章 238614"XCON:How to Set Up Regtrace for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=238614)。

  • 有关常规邮件故障排除的详细信息，请参阅知识库文章 281800"XCON:Troubleshooting Message Failures in Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=281800)。


Rejection threshold not configured
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-07-30

Microsoft Exchange 分析工具查询 Active Directory 目录服务，在所有具有 ContentFilterConfig 类的对象上查找下列属性值：

msExchAgentsFlags msExchAgentsFlag 属性值表示 Microsoft Exchange Server 2007 内容筛选器代理和垃圾邮件可信度 (SCL) 拒绝操作的状态。在计算机上启用内容筛选器代理时，内容筛选器代理将筛选该计算机上通过所有接收连接器收到的所有邮件。当启用 SCL 拒绝操作时，将在 SMTP 事务期间针对所有超出 SCL 拒绝阈值的邮件发送拒绝响应。

msExchMessageHygieneSCLRejectThreshold msExchMessageHygieneSCLRejectThreshold 属性值表示为 SCL 拒绝操作设置的级别。此值表示要使内容筛选器代理拒绝特定邮件并向发件人发送未送达报告 (NDR)，特定邮件必须超过的 SCL 分级。

Exchange 分析工具还会执行以下 Exchange 命令行管理程序 cmdlet，查询已安装反垃圾邮件代理的全部集线器传输服务器角色：

Get-TransportServer | where { $_.AntispamAgentsEnabled -eq $True}

如果 Exchange 分析工具发现服务器符合以下所有条件，则 Exchange 分析工具将显示警告：

  • 内容筛选功能已启用

  • SCL 拒绝操作已启用

  • SCL 拒绝阈值设置为数值 9

  • 该服务器已启用反垃圾邮件代理。

此警告表示尽管启用了内容过滤功能和 SCL 拒绝操作，SCL 拒绝操作阈值仍设置为默认值 9。这可能会导致系统拒绝来自合法用户的邮件。建议将 SCL 拒绝操作阈值设置为 7。

若要解决此警告，请将 SCL 拒绝操作阈值设置为 7，方法为在 Exchange 管理器控制台中使用"反垃圾邮件"选项卡或在 Exchange 命令行管理程序中使用 Set-ContentFilterConfig cmdlet。

若要配置 SCL 拒绝操作阈值，请按照 Exchange Server 2007 产品文档中主题为"如何启用和配置垃圾邮件可信度阈值"(http://go.microsoft.com/fwlink/?LinkId=96099)中的指导进行操作。

详细信息

有关 Exchange Server 2007 管理反垃圾邮件和反病毒功能的详细信息，请参阅 Exchange Server 2007 产品文档中的"管理反垃圾邮件和反病毒功能"(http://go.microsoft.com/fwlink/?LinkId=96103)。


删除了收件人更新服务
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-04-20

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定目录中每个收件人更新服务的 msExchAddressListServiceLink 属性值。msExchAddressListServiceLink 属性是从地址列表服务到它应当运行于其上的 Exchange Server 计算机的链接。如果 Exchange Server 分析工具发现 msExchAddressListServiceLink 属性的值被设置为"DEL:"，则会显示错误。

每个收件人更新服务实例都与一个运行收件人更新服务的 Exchange Server 计算机关联。如果收到该消息，则说明收件人更新服务实例与不存在于 Exchange 组织中的 Exchange Server 计算机关联。该服务器可能已经退役，或从拓扑结构中删除。

要让该收件人更新服务实例运行，必须将它与现有的 Exchange 服务器关联。

更正此错误

  1. 打开 Exchange 系统管理器。

  2. 在"收件人"下，单击"收件人更新服务"。在右侧窗格中，用鼠标右键单击适合的收件人更新服务实例，再单击"属性"。

  3. 在"常规"选项卡的"Exchange Server"下，单击"浏览"并指定新的服务器来运行该实例。

  4. 单击"确定"，然后再次单击"确定"，以使更改生效。

  5. 关闭 Exchange 系统管理器。

有关收件人更新服务的详细信息，请参阅下列 Exchange 主题和 Microsoft 知识库文章：

  • "Exchange Server 2003 管理指南"中的"管理收件人和收件人策略"(http://www.microsoft.com/downloads/details.aspx?FamilyID=98e45481-1458-4809-97d6-50d8aeebd8a1&DisplayLang=zh-cn)

  • 328738"XADM:How the Recipient Update Service Applies Recipient Policies"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828"How the Recipient Update Service Populates Address Lists"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127"XADM:How to Check the Progress of the Recipient Update Service"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770"XADM:Tasks Performed by the Recipient Update Service"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


RPC 绑定中不包含 FQDN
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 networkAddress 属性的 ncacn_ip_tcp 值是否包含完全限定域名 (FQDN)。如果 Exchange Server 分析工具发现 ncacn_ip_tcp 值不包含句点 (.)，Exchange Server 分析工具将显示错误。

在 Microsoft Office Outlook® Web Access for Exchange Server 2003 中，前端服务器在尝试连接到 Exchange 后端服务器时检查 networkaddress 属性的值。

注意：
Outlook Web Access for Exchange 2000 Server 不会这样做。前端服务器要求 FQDN 值。

前端服务器检查 networkaddress ncacn_ip_tcp 返回的值中的句点。如果符合以下条件，对特定后端服务器上的邮箱的连接请求将失败，前端服务器向用户返回"HTTP 500 内部服务器错误"的错误消息：

  • ncacn_ip_tcp 的值只是主机名或网络基本输入/输出系统 (NetBIOS) 名称。

  • ncacn_ip_tcp 的值不是 FQDN。

必须更新 Active Directory 中的服务器对象上的 ncacn_ip_tcp 值，以确保 Outlook Web Access for Exchange Server 2003 正常运行。Exchange Server 分析工具的输出提供受影响的服务器的名称。

警告：
在使用 ADSI（Active Directory 服务接口）Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。
注意：
在更新 ncacn_ip_tcp 值之前，请先阅读本文的其他内容。您可能希望先执行另一步骤，然后再重新启动 Exchange Server 的服务。
更新 networkAddress 属性上的 ncacn_ip_tcp 值

  1. 从 Windows 2000 Server 支持工具或 Windows Server 2003 支持工具启动 ADSI Edit 工具。

  2. 展开下列节点：

    • Configuration Container

    • Configuration

    • Services

    • Microsoft Exchange

    • Organization_Name

    • Administrative Groups

    • Administrative_Group_Name

    • Servers

  3. 用鼠标右键单击 Exchange 服务器名称，再单击 Properties。

  4. 单击 Attributes 列表中的 networkaddress，再单击 Edit。

  5. 为 ncacn_ip_tcp 添加新值。使用服务器的 FQDN，而不是服务器的 NetBIOS 名称或服务器的主机名。

    此值的语法为 ncacn_ip_tcp:FQDN。例如，如果 Exchange 后端服务器的主机名为 EXCHANGE1，FQDN 为 EXCHANGE1.contoso.com，请对 ncacn_ip_tcp 使用以下值：ncacn_ip_tcp:EXCHANGE1.contoso.com。

  6. 通过选择原来的值，再单击 Remove，删除原来包含后端服务器的 NetBIOS 名称或主机名的 ncacn_ip_tcp 值。单击 OK 两次以应用更改。

  7. 重新启动服务器上的所有 Exchange Server 服务。

  8. 如果有多个域控制器，请等待进行复制，然后再尝试从前端服务器登录。如果复制完成后问题仍没有解决，请重新启动前端服务器上的 IIS 管理服务。

如果在后端服务器上维护主机文件以关联包含短主机名的服务器 IP 地址，必须还要更新 UpdateProtocols 值。如果使用了主机文件，在重新启动 Microsoft System Attendant 时，Exchange Server 可能会更改回 ncacn_ip_tcp 值。如果后端服务器是群集服务器，在故障转移之后，Exchange Server 可能会更改回 ncacn_ip_tcp 值。

为了使重新启动 Exchange Server 的服务造成的停机时间最短，请先执行下列步骤，然后再按照上述步骤中所述更新 networkaddress 属性上的 ncacn_ip_tcp 值，以重新启动 Exchange Server 的服务。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
为使用主机文件的后端服务器修改 UpdateProtocols 注册表值

  1. 使用注册表编辑器在后端服务器上配置以下注册表值： HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\UpdateProtocols

    注意：
    如果 UpdateProtocols 值不存在，必须创建该值。若要这样做，请执行下列步骤：
    1. 打开注册表编辑器并找到以下注册表子项： HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\

    2. 用鼠标右键单击"参数"，指向"新建"，再单击"DWORD 值"。

    3. 键入 UpdateProtocols，再按 Enter 键。

  2. 用鼠标右键单击 UpdateProtocols，单击"修改"，在"数值数据"字段中键入 0，再单击"确定"。

  3. 如果网络使用后端群集节点上的主机文件，请按如下所示修改 UpdateProtocols 的输入顺序：

    IPAddress to FQDN

    IPAddress to NetBIOS

    而不是：

    IPAddress to NetBIOS

    IPAddress to FQDN

  4. 重新启动服务器上的所有 Exchange Server 服务。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


RPC 绑定与 DNS 解析名不匹配
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-03-21

Microsoft® Exchange Server 分析工具尝试对每台 Exchange Server 计算机的已配置 DNS 服务器执行域名系统 (DNS) 查询。此连接是通过使用执行名称解析请求并分析结果的自定义对象处理器来建立的。Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定 networkAddress 属性中的服务器 ncacn_ip_tcp 值与 DNS 解析后返回的完全限定域名 (FQDN) 是否不同。networkAddress 属性是 Active Directory 中每个 Exchange Server 对象的一个属性。如果 Exchange Server 分析工具发现 Active Directory 中的服务器 ncacn_ip_tcp 值与 DNS 解析后返回的 FQDN 不匹配，Exchange Server 分析工具将显示警告。

如果在安装 Exchange 之后更改了服务器的 FQDN，会发生这种情况。Exchange Server 和 Active Directory 都需要配置正确且运行正常的 DNS 才能正确工作。域命名服务的注册和解析问题会对 Exchange Server 计算机发送、接收和传递邮件的能力造成很大的影响。如果通过手动编辑 Active Directory 中的 Exchange Server 对象的 networkAddress 属性来使两个地址匹配，可以避免这些问题。

必须更新 Active Directory 中的服务器对象的 ncacn_ip_tcp 值，以确保 ncacn_ip_tcp 值与服务器的 DNS FQDN 匹配。Exchange Server 分析工具的输出提供受影响的服务器的名称。

警告：
在使用 ADSI（Active Directory 服务接口）Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。若要解决这些问题，您可能需要重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003/Exchange Server 2007。修改 Active Directory 对象的属性的风险由您自己承担。
更新 networkAddress 属性上的 ncacn_ip_tcp 值

  1. 从 Windows® 2000 支持工具或 Windows Server 2003 支持工具启动 ADSI Edit 工具。

  2. 展开下列节点：

    • Configuration Container

    • Configuration

    • Services

    • Microsoft Exchange

    • Organization_Name

    • Administrative Groups

    • Administrative_Group_Name

    • Servers

  3. 右键单击 Exchange 服务器名称，再单击 Properties。

  4. 单击 Attributes 列表中的 networkaddress，再单击 Edit。

  5. 为 ncacn_ip_tcp 添加新值。使用服务器的 FQDN 取代当前值。

    此值的语法为 ncacn_ip_tcp:FQDN。例如，如果 Exchange 后端服务器的主机名为 EXCHANGE1，FQDN 为 EXCHANGE1.contoso.com，请对 ncacn_ip_tcp 使用以下值：ncacn_ip_tcp:EXCHANGE1.contoso.com。

  6. 删除包含不正确的服务器名称的原始 ncacn_ip_tcp 值，方法是选择原始值，然后单击"删除"。单击 OK 两次以应用更改。

  7. 重新启动服务器上的所有 Exchange Server 的服务。

有关如何将 DNS 与 Active Directory 一起使用的详细信息，请参阅 Microsoft 知识库文章 323418"如何在 Windows Server 2003 中启用了 Active Directory 的情况下将 DNS 与现有 DNS 结构集成"(http://support.microsoft.com/kb/323418/zh-cn)。


RPC 绑定顺序不正确
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Exchange Server 计算机使用的远程过程调用 (RPC) 绑定顺序：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Svr_Binding_Order

如果 Exchange Server 分析工具发现 Rpc_Svr_Binding_Order 的值不是以 ncacn_ip_tcp 开头，则会显示错误。

Rpc_Svr_Binding_Order 注册表项是在计算机上安装 Exchange Server 时创建的。此项决定了用于服务器到服务器的 RPC 通信的协议顺序。

默认情况下，Rpc_Svr_Binding_Order 项包含以下数值数据：

ncacn_ip_tcp、ncacn_spx、ncacn_vns_spp

注意：
如果 Exchange Server 计算机上还安装了其他协议，则字符串中还会出现其他值。

此项指定了当 Exchange Server 与其他服务器进行 RPC 通信时尝试使用网络通信协议的顺序。例如，由于 TCP/IP 是最先指定的，因此 Exchange Server 将首先尝试在 TCP/IP 上使用 RPC 与其他服务器进行通信，然后再尝试在其他协议上使用 RPC。

建议不要更改默认的 RPC 绑定顺序。如果更改默认值，可能在服务器或服务启动过程中或者进行服务器到服务器的通信时出现问题。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

更正此错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\Software\Microsoft\Exchange\Exchange Provider

  3. 在右侧窗格中，双击"Rpc_Svr_Binding_Order"。

  4. 在"数值数据"对话框中，键入 ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp。

  5. 单击"确定"，然后关闭注册表编辑器。

  6. 重新启动所有 Exchange Server 服务，或者重新启动 Exchange Server 计算机，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 RPC 绑定顺序的详细信息，请参阅知识库文章 325930"如何解决由 RPC 客户端协议注册表条目导致的连接问题"(http://support.microsoft.com/kb/325930/zh-cn)。


Rpc_Binding_Order 注册表项存在
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以检查 Exchange Server 计算机上是否存在面向客户端的远程过程调用 (RPC) 绑定顺序注册表项：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Binding_Order

如果 Exchange Server 分析工具发现 Rpc_Binding_Order 存在，则会显示警告。

如果 Rpc_Binding_Order 值存在，意味着计算机上安装了下面的一个或多个软件：

  • Exchange Server 5.5 版

  • Microsoft Office Outlook® 2003

  • Windows 群集

  • RPC_Binding_Order 项决定了当 Outlook RPC 通信启动时使用的协议序列。此项不在 Exchange Server 2003 或 Exchange 2000 Server 中创建。此项只在 Exchange Server 5.5 以及更早版本的 Exchange 中创建。如果此计算机上以前安装了 Exchange Server 5.5 或 Microsoft Outlook，并且已经删除，可以手动删除此注册表项。此外，应将 Outlook 从任何运行 Exchange Server 的计算机中删除，因为它是不支持的配置。有关在同一台计算机上运行 Exchange 和 Outlook 的详细信息，请参阅 Microsoft 知识库文章 266418"Microsoft does not recommend installing Exchange Server and Outlook on the same computer"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266418)。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

删除 Rpc_Binding_Order 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\Software\Microsoft\Exchange\Exchange Provider

  3. 删除 Rpc_Binding_Order 值。

  4. 关闭注册表编辑器，并重新启动所有 Exchange Server 服务或重新启动 Exchange Server 计算机，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 RPC_Binding_Order 注册表项的详细信息，请参阅下列知识库文章：

  • 325930"如何解决由 RPC 客户端协议注册表项导致的连接问题"(http://support.microsoft.com/kb/325930/zh-cn)

  • 326036"XADM:Cannot Log On to Exchange 2000 Server Computer by Using the Correct Credentials"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=326036)


Rpc_Svr_Binding_Order 注册表值已从其默认值修改为其他值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Exchange Server 计算机使用的远程过程调用 (RPC) 绑定顺序：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Svr_Binding_Order

如果 Exchange Server 分析工具发现 Rpc_Svr_Binding_Order 的值未设置为 ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp，则会显示警告。

Rpc_Svr_Binding_Order 注册表项是在计算机上安装 Exchange Server 时创建的。此项决定了用于服务器到服务器的 RPC 通信的协议顺序。

默认情况下，Rpc_Svr_Binding_Order 项包含以下数值数据：

ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp

注意：
如果 Exchange Server 计算机上还安装了其他协议，则上述字符串中还会出现其他值。

此项指定了当 Exchange Server 与其他服务器进行 RPC 通信时尝试使用网络通信协议的顺序。例如，由于 TCP/IP 是最先指定的，因此 Exchange Server 将首先尝试使用 TCP/IP 上的 RPC 与其他服务器通信，然后再尝试使用基于其他协议的 RPC。

Microsoft 建议不要将 RPC 绑定顺序从默认值更改为其他值。如果更改默认值，在服务器或服务启动过程中，或者进行服务器到服务器通信时，可能出现问题。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

更正此错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\Software\Microsoft\Exchange\Exchange Provider

  3. 在右侧窗格中，双击"Rpc_Svr_Binding_Order"。

  4. 在"数值数据"对话框中，键入 ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp。

  5. 单击"确定"，然后关闭注册表编辑器。

  6. 重新启动所有 Exchange Server 服务，或者重新启动 Exchange Server 计算机，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 RPC 绑定顺序的详细信息，请参阅知识库文章 325930"如何解决由 RPC 客户端协议注册表条目导致的连接问题"(http://support.microsoft.com/kb/325930/zh-cn)。


到 Active Directory 服务器的往返时间超过 100 ms
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-03-16

Microsoft® Exchange Server 分析工具查询 root\cimv2 命名空间中的 WIN32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 类，以确定 ResponseTime 关键字的值。如果 Exchange Server 分析工具发现 ResponseTime 关键字的值大于 100 毫秒 (ms)，则会显示错误。

ResponseTime 关键字代表了响应 Internet 控制消息协议 (ICMP) 回显请求 (ping) 时所用的时间（毫秒）。Exchange Server 计算机所使用的域控制器的响应时间应当总是小于或等于 10 ms。如果响应时间超过 100 ms，则说明存在性能或连接问题。

更正此错误

  1. 检查受怀疑的域控制器以确保其没有超载。使用 ADTest.exe 工具对域控制器执行测试，以确定硬件是否可以处理预期的负载。

  2. 检查 Exchange 服务器和域控制器上的事件日志，以确定是否记录了表明一个或多个问题的任何网络相关事件。

  3. 在域控制器上使用 DCDiag.exe 和 NetDiag.exe 命令来验证正确的配置和运行状况。

  4. 最后，调查 Active Directory® 目录服务站点设计。Active Directory 站点被认为是具有高带宽、低延迟时间的网络段。如果未按照此规范对网络进行分区，请考虑将网络分成更多的 Active Directory 站点。
注意：
分析工具运行 WMI 查询进行 ping 测试时，默认的包大小和超时值将被覆盖。分析工具使用 4096 ICMP 包大小（代替默认值 32 字节）和 2000 ms 超时值（代替默认值 1000 ms）。

按照以下步骤手动模拟分析工具的 ping 行为。

手动执行以下 ping 测试

  • 在 Exchange 服务器的命令行窗口中运行以下命令：ping -L 4096 -N 6 <Active Server server name>注意 此命令启动了 6 个各为 4096 字节的 ping 请求。

有关 ADTest.exe 工具的详细信息，请参阅网站上的"Active Directory Performance Testing Tool (ADTest.exe)"（英文）(http://go.microsoft.com/fwlink/?LinkId=33758)。

有关 Win32_PingStatus WMI 类的详细信息，请参阅 MSDN® 文章"Win32_PingStatus"（英文）(http://go.microsoft.com/fwlink/?LinkId=33549)。

有关 Active Directory 站点设计的详细信息，请参阅"Designing the Site Topology"（英文）(http://go.microsoft.com/fwlink/?LinkId=33551)。


到 Active Directory 服务器的往返时间超过 10 ms
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-03-16

Microsoft® Exchange Server 分析工具查询 root\cimv2 命名空间中的 WIN32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 类，以确定 ResponseTime 关键字的值。如果 Exchange Server 分析工具发现 ResponseTime 关键字的值大于 10 毫秒 (ms) 但小于 100 ms，则显示警告。

ResponseTime 关键字代表响应自 Exchange 服务器发送到域控制器的 Internet 控制消息协议 (ICMP) 回应请求 (ping) 包所用的时间（毫秒）。Exchange Server 计算机所使用的域控制器的响应时间应当总是小于或等于 10 ms。如果响应时间超过 10 ms，则说明有性能或连接问题。

解决此警告问题

  1. 检查并确保受怀疑的域控制器没有超载。使用 ADTest.exe 工具对域控制器执行测试，以确定硬件是否可以处理预期的负载。

  2. 检查 Exchange 服务器和域控制器上的事件日志，以确定是否记录了表明一个或多个问题的任何网络相关事件。

  3. 在域控制器上使用 DCDiag.exe 和 NetDiag.exe 命令来验证正确的配置和运行状况。

  4. 最后，查明 Active Directory® 目录服务站点设计。Active Directory 站点被认为是具有高带宽、低延迟时间的网络段。如果未按照此规范对网络进行分区，请考虑将网络分成更多的 Active Directory 站点。
注意：
分析工具运行 WMI 查询进行 ping 测试时，默认的包大小和超时值将被覆盖。分析工具使用 4096 ICMP 包大小（代替默认值 32 字节）和 2000 ms 超时值（代替默认值 1000 ms）。

按照以下步骤手动模拟分析工具的 ping 行为。

手动执行以下 ping 测试

  • 在 Exchange 服务器的命令行窗口中运行以下命令：ping -L 4096 -N 6 <Active Server server name>注意 此命令启动了 6 个各为 4096 字节的 ping 请求。

有关 ADTest.exe 工具的详细信息，请参阅网站上的"Active Directory Performance Testing Tool (ADTest.exe)"（英文）(http://go.microsoft.com/fwlink/?LinkId=33758)。

有关 Win32_PingStatus WMI 类的详细信息，请参阅 MSDN® 文章"Win32_PingStatus"（英文）(http://go.microsoft.com/fwlink/?LinkId=33549)。

有关 Active Directory 站点设计的详细信息，请参阅"Designing the Site Topology"（英文）(http://go.microsoft.com/fwlink/?LinkId=33551)。


到全局编录服务器的往返行程时间超过 100 ms
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-03-16

Microsoft® Exchange Server 分析工具查询 root\cimv2 命名空间中的 WIN32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 类，以确定 ResponseTime 关键字的值。如果 Exchange Server 分析工具发现 ResponseTime 关键字的值超过 100 毫秒 (ms)，则将显示错误。

ResponseTime 关键字代表响应自 Exchange Server 发送到全局编录服务器的 Internet 控制消息协议 (ICMP) 回应请求 (ping) 包所用的时间（毫秒）。Exchange Server 计算机使用的全局编录服务器的响应时间应始终小于或等于 10 ms。如果响应时间大于 10 ms，则会产生性能或连接问题。

更正此错误

  1. 检查以确保有问题的全局编录服务器未超载。使用 ADTest.exe 工具对全局编录服务器执行测试，以确定硬件是否可以处理预期的负载。

  2. 查看 Exchange 服务器和全局编录服务器上的事件日志，以确定是否记录了表明一个或多个问题的任何网络相关事件。

  3. 在全局编录服务器上使用 DCDiag.exe 和 NetDiag.exe 命令，以验证该服务器是否具有正确的配置和运行状况。

  4. 最后，调查 Active Directory® 目录服务站点设计。Active Directory 站点被认为是具有高带宽、低延迟时间的网络段。如果未按照此规范对网络进行分区，请考虑将网络分成更多的 Active Directory 站点。
注意：
分析工具运行 WMI 查询进行 ping 测试时，默认的包大小和超时值将被覆盖。分析工具使用 4096 ICMP 包大小（代替默认值 32 字节）和 2000 ms 超时值（代替默认值 1000 ms）。

按照以下步骤手动模拟分析工具的 ping 行为。

手动执行以下 ping 测试

  • 在 Exchange 服务器的命令行窗口中运行以下命令：ping -L 4096 -N 6 <Active Server server name>注意 此命令启动了 6 个各为 4096 字节的 ping 请求。

有关 ADTest.exe 工具的详细信息，请参阅网站上的"Active Directory Performance Testing Tool (ADTest.exe)"（英文）(http://go.microsoft.com/fwlink/?LinkId=33758)。

有关 Win32_PingStatus WMI 类的详细信息，请参阅 MSDN® 文章"Win32_PingStatus"（英文）(http://go.microsoft.com/fwlink/?LinkId=33549)。

有关 Active Directory 站点设计的详细信息，请参阅"Designing the Site Topology"（英文）(http://go.microsoft.com/fwlink/?LinkId=33551)。

有关安装 Windows 2000 Server 支持工具的信息，请参阅 Microsoft 知识库文章 301423"如何在基于 Windows 2000 Server 的计算机上安装 Windows 2000 Support Tools"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=301423)。

有关安装 Windows Server 2003 支持工具的信息，请参阅"Install Windows Support Tools"（英文）(http://go.microsoft.com/fwlink/?LinkId=41362)。


到全局编录服务器的往返行程时间超过 10 ms
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-03-16

Microsoft® Exchange Server 分析工具查询 root\cimv2 命名空间中的 WIN32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 类，以确定 ResponseTime 关键字的值。如果 Exchange Server 分析工具发现 ResponseTime 关键字的值大于 10 毫秒 (ms) 但小于 100 毫秒 (ms)，则会显示警告。

ResponseTime 关键字代表响应自 Exchange 服务器发送到全局编录服务器的 Internet 控制消息协议 (ICMP) 回应请求 (ping) 包所用的时间（毫秒）。Exchange Server 计算机所使用的全局编录服务器的响应时间应当总是小于或等于 10 毫秒。如果响应时间超过 10 毫秒，则可能有性能或连接问题。

解决此警告问题

  1. 检查以确保有问题的全局编录服务器未超载。使用 ADTest.exe 工具对全局编录服务器执行测试，以确定硬件是否可以处理预期的负载。

  2. 查看 Exchange 服务器和全局编录服务器上的事件日志，以确定是否记录了表明一个或多个问题的任何网络相关事件。

  3. 在全局编录服务器上，使用 DCDiag.exe 和 NetDiag.exe 命令验证正确的配置和运行状况。

  4. 最后，查明 Active Directory® 目录服务站点设计。Active Directory 站点被认为是具有高带宽、低延迟时间的网络段。如果未按照此规范对网络进行分区，请考虑将网络分成更多的 Active Directory 站点。
注意：
分析工具运行 WMI 查询进行 ping 测试时，默认的包大小和超时值将被覆盖。分析工具使用 4096 ICMP 包大小（代替默认值 32 字节）和 2000 ms 超时值（代替默认值 1000 ms）。

按照以下步骤手动模拟分析工具的 ping 行为。

手动执行以下 ping 测试

  • 在 Exchange 服务器的命令行窗口运行以下命令：

    ping -L 4096 -N 6 <Active Server server name>

    注意：
    此命令将启动 6 个各为 4096 字节的 ping 请求。

有关 ADTest.exe 工具的详细信息，请参阅网站上的"Active Directory Performance Testing Tool (ADTest.exe)"（英文）(http://go.microsoft.com/fwlink/?LinkId=33758)。

有关 Win32_PingStatus WMI 类的详细信息，请参阅 MSDN® 文章"Win32_PingStatus"（英文）(http://go.microsoft.com/fwlink/?linkid=33549)。

有关 Active Directory 站点设计的详细信息，请参阅"Designing the Site Topology"（英文）(http://go.microsoft.com/fwlink/?linkid=33551)。


收件人策略要求更改搜索筛选器
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-02-21

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 Exchange 收件人策略对象的 purportedSearch 属性的值。purportedSearch 属性表明应用策略时使用的搜索参数。

Exchange Server 分析工具还查询 Active Directory，以确定 Active Directory 中目录林对象的 msDS-Behavior-Version 属性的值，即 NTDS 设置。该值表明 Active Directory 目录林的功能级别。msDS-Behavior-Version 属性的有效值如下表中所示。

值 | 目录林的功能级别
0 | Microsoft Windows® 2000 Server 混合模式
1 | Microsoft Windows Server™ 2003 临时模式
2 | Windows Server 2003 纯模式

Exchange Server 分析工具还查询 Active Directory，以确定 Windows2003Update 容器的 revision 属性的值。该属性的值表明是否已运行 Active Directory 准备工具 (ADPrep.exe)。

最后，Exchange Server 分析工具查询 Win32_OperatingSystem Windows Management Instrumentation (WMI) 类，以确定 OSProductSuite 关键字的值。OSProductSuite 关键字的值表明计算机上运行的 Windows 的版本。

如果 Exchange Server 分析工具发现符合以下条件，Exchange Server 分析工具将显示警告：

  • 收件人策略的 purportedSearch 属性值包括 homeMdb。

  • Active Directory 目录林的功能级别为 Windows Server 2003 临时模式或 Windows Server 2003 纯模式。

  • Exchange Server 计算机没有运行 Microsoft Windows Small Business Server 2003。

该警告表明 Active Directory 目录林是为 Windows Server 2003 而准备。为了避免在目录林升级到 Windows Server 2003 完整功能级别时出现电子邮件标记问题，要求修改收件人策略。受影响的收件人策略在 Exchange Server 分析工具的输出中指定。

如果使用 Windows Server 2003 作为域控制器，并且没有更新收件人策略，Windows Server 2003 中的链接值复制将使收件人更新服务不正确地写入新用户的电子邮件地址。收件人更新服务初次看到用户可能是在复制 mailnickname 和复制 homeMDB 之间，因为链接值的复制。因此，用户在此时将执行默认策略，而不是基于 homeMDB 的策略。几分钟之后，在复制 homeMDB 时，用户将执行 homeMDB 策略。但是，用户已拥有与默认策略匹配的地址。

解决此警告问题

  1. 打开 Exchange 系统管理器。

  2. 展开"收件人"，选择"收件人策略"，用鼠标右键单击 RecipientPolicyName，再单击"属性"。

  3. 在"RecipientPolicyName 属性"页的"常规"选项卡上，在"筛选规则"下单击"修改"。

  4. 在"查找 Exchange 收件人"菜单上，选择"自定义搜索"。如果收件人策略原来是通过自定义搜索创建，在步骤 3 中单击"修改"之后，将显示"查找自定义搜索"页。

  5. 更改轻型目录访问协议 (LDAP) 查询，使 homeMdb 属性不作为筛选条件的一部分使用。extensionAttribute、msExchHomeServerName 或 UPN 等属性是有效参数，可以帮助您得到相同的搜索结果。

  6. 单击"确定"保存更改，再关闭 Exchange 系统管理器。


收件人策略要求更改搜索筛选器
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 Exchange 收件人策略对象的 purportedSearch 属性值。purportedSearch 属性表明应用策略时使用的搜索参数。

Exchange Server 分析工具还查询 Active Directory，以确定 Active Directory 中目录林对象的 msDS-Behavior-Version 属性值，即 NTDS 设置。该值表明 Active Directory 目录林的功能级别。msDS-Behavior-Version 属性的有效值如下表中所示。

值 | 目录林的功能级别
0 | Windows® 2000 Server 混合模式
1 | Windows Server™ 2003 临时模式
2 | Windows Server 2003 纯模式

Exchange Server 分析工具还查询 Active Directory，以确定 Windows2003Update 容器的 revision 属性值。该属性的值表明是否已运行 Active Directory 准备工具 (ADPrep.exe)。

最后，Exchange Server 分析工具查询 Win32_OperatingSystem Windows Management Instrumentation (WMI) 类，以确定 OSProductSuite 关键字的值。OSProductSuite 关键字的值表明计算机上运行的 Windows 的版本。

如果 Exchange Server 分析工具发现下列条件为真，则显示警告：

  • 收件人策略的 purportedSearch 属性的值包含 (homeMdb=)。

  • Active Directory 目录林的功能级别为 Windows 2000 Server 混合模式。

  • Active Directory 目录林是为 Windows Server 2003 域控制器而准备的。

  • Exchange Server 计算机没有运行 Microsoft Windows Small Business Server 2003。

该警告表明 Active Directory 目录林是为 Windows Server 2003 而准备。为了避免在 Active Directory 目录林升级到 Windows Server 2003 完整功能级别时出现电子邮件地址标记问题，必须修改收件人策略。受影响的收件人策略在 Exchange Server 分析工具的输出中指定。

如果使用 Windows Server 2003 作为域控制器，并且没有更新收件人策略，Windows Server 2003 中的链接值复制将使收件人更新服务不正确地写入新用户的电子邮件地址。

因为链接值复制，收件人更新服务可以在复制 mailnickname 和复制 homeMdb 之间初次检测新用户。因此，用户在此时将执行默认策略，而不是基于 homeMdb 的策略。几分钟之后，在复制 homeMdb 时，用户将执行 homeMdb 策略。但是，用户已拥有与默认策略匹配的地址。

解决此警告问题

  1. 打开 Exchange 系统管理器。

  2. 展开"收件人"，选择"收件人策略"，用鼠标右键单击 RecipientPolicyName，再单击"属性"。

  3. 在"RecipientPolicyName 属性"页的"常规"选项卡上，在"筛选规则"下单击"修改"。

  4. 在"查找 Exchange 收件人"菜单上，选择"自定义搜索"。如果收件人策略原来是通过自定义搜索创建的，在步骤 3 中单击"修改"之后，将显示"查找自定义搜索"页。

  5. 更改轻型目录访问协议 (LDAP) 查询，使 homeMdb 属性不作为筛选条件的一部分使用。extensionAttribute、msExchHomeServerName 或 UPN 等属性是有效参数，可以帮助您得到相同的搜索结果。

  6. 单击两次"确定"保存更改，再关闭 Exchange 系统管理器。


未配置发件人 ID
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-05-10

Microsoft Exchange 最佳实践分析工具使用以下 Exchange 命令行管理程序 cmdlet，查询任意目标 Exchange Server 2007 边缘传输服务器角色或集线器传输服务器角色的 SenderIdConfig 对象的 Enabled 和 ExternalMailEnabled 属性值。

复制代码
- get-SenderIdConfig

Enabled 属性的值指定是否启用发件人 ID 代理。Enabled 参数的有效输入是 $true 或 $false。默认设置是 $true。当 Enabled 参数设置为 $true 时，发件人 ID 代理已启用。

ExternalMailEnabled 属性的值指定是否通过发件人 ID 代理传递来自未通过身份验证的连接的所有邮件以供处理。ExternalMailEnabled 参数的有效输入是 $true 或 $false。默认设置是 $true。当 ExternalMailEnabled 参数设置为 $true 时，将通过发件人 ID 代理传递来自未通过身份验证的连接的所有邮件以供处理。

如果 Exchange 最佳实践分析工具确定 SenderIdConfig 对象的 Enabled 或 ExternalMailEnabled 属性值未设置为 $true，则 Exchange 最佳实践分析工具将显示最佳实践消息。

此消息表明在目标 Exchange 2007 边缘传输服务器角色或集线器传输服务器角色上未启用发件人 ID。

发件人 ID 试图验证每封电子邮件是否来自它所显示的 Internet 域。

在计算机上启用发件人 ID 时，它将筛选该计算机上通过所有接收连接器收到的所有邮件。只会筛选从外部发来的邮件。外部来源定义为未通过身份验证的来源。它们被视为匿名 Internet 来源。

若要解决此问题，请在目标 Exchange 2007 边缘传输服务器角色或集线器传输服务器角色上启用发件人 ID。

使用 Exchange 命令行管理程序启用发件人 ID 功能

  • 若要启用发件人筛选，请运行以下命令：

    复制代码
    Set-SenderIdConfig -Enabled $true -ExternalMailEnabled $true

有关发件人 ID 的详细信息，请参阅下列主题：

  • Sender ID Home Page（发件人 ID 主页）(http://go.microsoft.com/fwlink/?linkid=50977)

  • Exchange 2007 Sender ID（Exchange 2007 发件人 ID）(http://go.microsoft.com/fwlink/?LinkId=89719)

  • Configuring Sender ID（配置发件人 ID）(http://go.microsoft.com/fwlink/?LinkId=89720)


服务器名称大小写不匹配
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Active Directory 中存储的 Exchange 服务器名称 (CN=<ExchangeServerName>) 的值。Exchange Server 分析工具检索此名称后，将计算该名称中的字符数。

Exchange Server 分析工具还读取以下注册表项，以确定存储在 Exchange Server 计算机的注册表中的 Exchange 服务器主机名：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

Exchange Server 分析工具还查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Windows® 群集服务 ClusSvc 的 Started 关键字的值。

如果下列条件为真，则 Exchange Server 分析工具将显示非默认配置消息：

  • CN=<ExchangeServerName> 的值与 Hostname 中的值的大小写不匹配。例如，CN=ComputerName and Hostname 设置为 COMPUTERNAME。

    注意：
    尽管支持在注册表中更改服务器名称的大小写，但是不建议这样做。
  • Exchange 服务器名不超过 15 个字符。

  • Exchange 服务器未运行在 Windows 群集中。

此错误的最常见原因是在注册表中手动更改了 Exchange 服务器的名称。


服务器名称不匹配
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 This Server 值的设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定每个 Exchange 服务器对象的 name 属性值。

最后，Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定群集服务 (ClusSvc) 的 Started 关键字的值。值为 TRUE 说明群集服务已启动，值为 FALSE 说明群集服务未运行。

如果 Exchange Server 分析工具发现 This Server 关键字的值与 Active Directory 中针对未在服务器群集中运行的任何 Exchange Server 计算机的服务器对象的 name 属性值都不匹配，则显示错误。

若要更正此错误，必须编辑 This Server 注册表项，以便与 Active Directory 中的 name 属性值匹配。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

更正此错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem.

  3. 在右侧窗格中，双击"This Server"，输入此计算机的正确名称，再单击"确定"。

  4. 关闭注册表编辑器，并重新启动 Exchange Server 计算机，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


服务器名太长
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-02-22

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定具有目录类 msExchExchangeServer 的每个目录对象的名称 (cn)。cn 值是包含 Exchange Server 计算机简短名称的字符串。Exchange Server 分析工具检索 cn，然后确定字符串的长度。字符串的长度是 Exchange 服务器名称的字符数。如果 Exchange Server 分析工具确定 Exchange 服务器名超过 15 个字符，则会显示错误。

Exchange Server 2007、Exchange Server 2003 和 Exchange 2000 Server 有几个 NetBIOS 依赖项，它们可能需要您跨越不同的子网使用 NetBIOS 名称解析，以便成功操作所有 Exchange 组件，具体情况取决于网络拓扑结构。NetBIOS 命名约定允许 NetBIOS 名称中有 16 个字符。但是，Microsoft 将 NetBIOS 名称限制为不超过 15 个字符，并使用第 16 个字符作为 NetBIOS 后缀。

由于 Exchange Server 有 NetBIOS 依赖性，并且 NetBIOS 名称不能超过 15 个字符，因此 Exchange 组织中不支持超过 15 个字符的服务器名称。另外，由于重命名 Exchange Server 计算机可以在整个 Active Directory 和 Exchange 组织中造成广泛的影响，因此，系统不支持重命名 Exchange Server 计算机。

更正此错误

  1. 使用"删除"选项，删除不正确命名的 Exchange Server 计算机。

  2. 用 15 个或更少的字符作为名称，重命名此计算机。

  3. 在该计算机上重新安装 Exchange Server。

有关删除 Exchange Server 2007 的详细信息，请参阅"Exchange Server 2007 Deployment"（Microsoft Exchange 2007 部署）文档中的"How to Completely Remove Exchange 2007 from a Server"（如何从服务器上完全删除 Exchange 2007）(http://go.microsoft.com/fwlink/?LinkId=79246)。

有关删除 Exchange Server 2003 的信息，请参阅"Exchange Server 2003 部署指南"中的"如何卸载 Exchange Server 2003"(http://www.microsoft.com/downloads/details.aspx?FamilyID=77B6D819-C7B3-42D1-8FBB-FE6339FFA1ED&DisplayLang=zh-cn)。

有关详细信息，请参阅下列 Microsoft 知识库文章：

  • 833396"How to manually remove Exchange 2003 from your computer"（如何从计算机中手动删除 Exchange 2003）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=833396)

  • 260378"如何手动删除 Exchange 2000 安装"(http://support.microsoft.com/kb/260378/zh-cn)

  • 328810"在服务器之间移动邮箱"(http://support.microsoft.com/kb/328810/zh-cn)

  • 821829"在 Exchange Server 2003 中移动邮箱"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)


服务器 RPC 网络地址与 Exchange 服务器名不匹配
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定目录中每个 Exchange Server 对象的 networkAddress 属性值。此多字符串属性中通常列出若干个条目，如下例所示：

ncacn_ip_tcp:<fully-qualified domain name of Exchange Server>

ncacn_np:<host name of Exchange Server>

ncacn_spx:<host name of Exchange Server>

ncacn_vns_spp:<host name of Exchange Server>

ncalrpc:<host name of Exchange Server>

netbios:<host name of Exchange Server>

Exchange Server 分析工具还查询 Active Directory，以确定每个 Exchange Server 对象的 name 属性值。

如果 Exchange Server 分析工具发现 name 属性的值与在 networkAddress 属性中找到的任何字符串的名称部分都不匹配，则显示错误。

如果管理员手动更改了服务器对象的 cn 值，将会出现此错误。networkAddress 属性由 Exchange Server 创建并维护，它包含多个字符串值以支持 Exchange Server 支持的不同网络通信协议。每个值都将某个协议与该特定协议所要求的相应形式的服务器名关联。

要更正该错误，请查看服务器名是否已更改或者值是否无效，然后采取相应的操作：

  • 如果服务器名已更改，请按照本文后面的步骤相应地修复这些值。

  • 如果由于另外某个原因而导致值无效，请在服务器上重新运行 Exchange 安装程序。

警告：
在使用 ADSI（Active Directory 服务接口）Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

更正此错误

  1. 使用 ADSI Edit 或类似的工具在 Active Directory 中找到管理组对象。

    可以在以下位置找到 networkAddress 属性：

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Administrative Groups, CN=Administrative Group Name, CN=Servers, CN=Server Name

  2. 请注意列表中的每个值的格式。根据需要更新这些值，并仅仅更改每个值的服务器名部分。

    注意：
    确保 ncacn_ip_tcp 值中的服务器名采用完全限定域名形式，而不是采用 NetBIOS 名或 Internet 协议地址形式。

  3. 关闭 Active Directory 编辑器，并重新启动 Exchange Routing Engine 服务。

有关使用 LDP 工具的详细信息，请参阅 Microsoft 知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

有关 Exchange 路由问题的详细信息，请参阅"Exchange Server 2003 传输和路由指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=c092b7a7-9034-4401-949c-b29d47131622&displaylang=zh-cn) 中的"排除路由故障"。


缺少服务主体名称
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-08-14

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以便找到为下表列出的 Exchange 资源的 Exchange 服务器计算机帐户的 servicePrincipalName 属性返回的值。

Exchange 资源 servicePrincipalName 值 | 返回的期望值
exchangeMDB | 完全限定的域名 (FQDN)
exchangeMDB | NetBIOS 名称
exchangeRFR | 完全限定的域名 (FQDN)
exchangeRFR | NetBIOS 名称
SMTP | 完全限定的域名 (FQDN)
SMTP | NetBIOS 名称
SMTPSVC | 完全限定的域名 (FQDN)
SMTPSVC | NetBIOS 名称
HOST | 完全限定的域名 (FQDN)
HOST | NetBIOS 名称

如果 Exchange Server 分析工具发现 Exchange 资源的计算机帐户的 servicePrincipalName 属性缺少此处列出的期望值之一，则 Exchange Server 分析工具将显示错误。

服务主体名称 (SPN) 是标识服务实例的唯一名称，并且与运行服务实例的登录帐户相关联。如果没有正确设置 SPN，Kerberos 身份验证将无法用于 Exchange 服务。

  • 运行 Microsoft Office Outlook® 2003 或更高版本的客户端与 Exchange 信息存储（邮箱数据）之间的身份验证问题可能表示缺少 exchangeMDB 资源的有效 SPN。

  • Outlook 2003 或更高版本的客户端存在 Active Directory 身份验证问题可能表示缺少 exchangeRFR 资源的有效 SPN。

  • 简单邮件传输协议 (SMTP) 虚拟服务器之间的身份验证失败可能表示缺少 SMTPSVC 或 HOST 资源的有效 SPN。

若要解决此问题，请执行下列步骤为受影响的属性添加缺少的值。

使用 SETSPN.exe 工具添加带有缺少的值的 SPN

  1. 安装 Setspn.exe 工具。若要获取 Setspn.exe 工具，请参阅"Windows 2000 Resource Kit Tool:Setspn.exe"（Windows 2000 资源工具包工具：Setspn.exe）(http://go.microsoft.com/fwlink/?LinkId=28103)。

    Windows Server 2003 版本的 Setspn.exe 命令行工具可以在 Windows Server 2003 CD 所包括的 Windows Server 2003 支持工具中找到。若要安装 Server 2003 支持工具，请双击 Support/Tools 文件夹中的 Suptools.msi 文件。

  2. 按照 SETSPN.EXE"Setspn_d.txt"文件中的指导向 Exchange 服务器的 Active Directory 对象添加缺少的值。以下示例说明为虚拟 SMTP 服务器 SPN 添加 FQDN 值的过程：

    • 启动命令提示符，然后更改为安装 Setspn.exe 的目录。

    • 在命令提示符处，输入以下命令：

      setspn.exe-a SMTPSVC/ mail.yourdomain.com YOURSERVERNAME

      注意：
      使用您的 SMTP 虚拟服务器 FQDN 替换 mail.yourdomain.com，并使用 Exchange 服务器的名称替换 YOURSERVERNAME。
      然后按 Enter。


某项服务在过去 24 小时内意外终止
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-02-14

Microsoft Exchange 分析工具查询 Win32_NTLogEvent Microsoft Windows Management Instrumentation (WMI) 类，以确定是否在过去 24 小时内记录了服务控制管理器源的事件 7031 警告。

事件 7031 警告表示指定的服务无法继续。该服务配置为报告失败次数，报告了特定的失败次数之后，服务控制管理器将执行为指定服务配置的恢复操作。

如果 Exchange 分析工具发现在过去 24 小时内一次或多次记录了这些事件，Exchange 分析工具将显示信息性消息。

此问题可能是由于多种问题造成的，包括但不限于下列最常见的问题：

  • 正在处理已损坏的邮件。

  • 防病毒应用程序的配置问题。

若要解决此问题，请执行下列操作：

  • 按照 Microsoft 知识库文章 286350"如何使用 ADPlus 解决'挂起'和'崩溃'问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=286350) 中的指导操作，以找出进程没有响应（挂起）或意外停止（崩溃）的原因。

  • 获取最新的 Microsoft Windows 2000 Service Pack。

  • 获取最新的 Microsoft Exchange Server Service Pack。

  • 与防病毒应用程序供应商联系，以获取最新的更新和配置信息。

详细信息

有关事件 7031 警告的详细信息，请参阅"Events and Errors Message Center:Event Details"（事件和错误消息中心：事件详细信息）(http://go.microsoft.com/fwlink/?LinkId=83114)。

有关如何获取最新的 Windows 2000 Server Service Pack 的详细信息，请参阅 Microsoft 知识库文章 260910"如何获取最新的 Windows 2000 Service Pack"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=260910)

有关如何获取最新的 Exchange 2000 Server Service Pack 的详细信息，请参阅 Microsoft 知识库文章 301378"如何获取最新的 Exchange 2000 Server Service Pack"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378)

有关如何获取最新的 Exchange Server 2003 Service Pack 的详细信息，请参阅"Why Try Service Pack 2 for Exchange Server 2003?"（为什么不试试 Exchange Server 2003 Service Pack 2？）(http://go.microsoft.com/fwlink/?LinkId=52073)

有关如何对 Exchange Server 使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"Exchange 和防病毒软件"(http://support.microsoft.com/kb/328841/zh-cn)

  • 823166"Exchange Server 2003 和防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN：Microsoft 在 Exchange 2000 防病毒解决方案方面的立场"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange Server 计算机上排除故障的建议"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请访问"Exchange Partners: Antivirus"（Exchange 合作伙伴：防病毒）网站 (http://go.microsoft.com/fwlink/?LinkId=16226)。


Services Value is Missing or Inaccessible
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-07-24

Microsoft Exchange 分析工具读取以下注册表项，以验证是否存在 Services 字符串类型值：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Setup

如果 Exchange 分析工具发现 Services 字符符类型值丢失或无法访问，则 Exchange 分析工具会显示一条错误消息。

该错误表明用于保存 Exchange 安装根路径的 Services 字符串类型值丢失或无法访问。缺少 Exchange 安装根路径可能会导致初始化关键驱动程序和协议失败，这将使启动时 Exchange 信息存储服务和相关服务执行失败。

若要解决此错误，请按照 Microsoft 知识库文章 285116"Exchange 存储服务未启动：错误 7024、1026、9542 和 5000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=285116) 中的指导操作。


找到单个忙/闲副本
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具查询 root\MicrosoftExchangeV2 命名空间下的 Exchange_PublicFolder Microsoft Windows® Management Instrumentation (WMI) 类，以确定每个管理组中存在的忙/闲副本数。

如果 Exchange Server 分析工具发现管理组中只有一个忙/闲副本，则会显示最佳实践消息。

通常建议每个管理组中的忙/闲文件夹副本多于一个。有时，多个忙/闲副本可以提高性能和恢复能力。在大型 Exchange 组织中，单个忙/闲数据副本可能会过载。在所有 Exchange 组织中，单个忙/闲数据副本是一个故障点。

尽管要注意下列事项，但是建议使用多个副本：

  • 多个副本会在网络上产生更多的复制通信量。

  • 多个副本增大了计划冲突的风险。

每 10,000 个邮箱至少应有一个副本。

有关忙/闲文件夹和发布忙/闲信息的详细信息，请参阅"Working with Exchange Server 2003 Stores"（英文）(http://go.microsoft.com/fwlink/?LinkId=47595)。


已找到大量邮箱的单个忙/闲副本
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具查询 root\MicrosoftExchangeV2 命名空间下的 Exchange_PublicFolder Microsoft Windows® Management Instrumentation (WMI) 类，以确定 ReplicaList 关键字中的条目数。条目数代表每个管理组中存在的忙/闲副本数。

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定每个邮箱存储的 homeMDBBL 属性中列出的条目数。该属性的个数代表邮箱存储中的邮箱数。

如果 Exchange Server 分析工具发现包含超过 10,000 个邮箱的管理组中存在一个忙/闲副本，则 Exchange Server 分析工具将显示错误。

通常，建议每个管理组中应具有多个忙/闲文件夹副本。有时，多个忙/闲副本可以提高性能并改善恢复能力。在大型 Exchange 组织中，如果忙/闲数据只有一个副本，则可能会出现超载情况。在所有 Exchange 组织中，如果忙/闲数据只有一个副本，则此副本便是单个故障点。

建议应使用多个副本，而不考虑下列情况：

  • 多个副本会产生更多的网络复制通信。

  • 计划冲突的风险随副本的增加而增大。

每 10,000 个邮箱至少应有一个副本。

有关忙/闲文件夹以及发布忙/闲信息的详细信息，请参阅"Working with Exchange Server 2003 Stores"（英文）(http://go.microsoft.com/fwlink/?LinkId=47595)。


拓扑中存在一个全局编录
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-09

Microsoft® Exchange Server 分析工具查询 root\MicrosoftExchangeV2 命名空间中的 Exchange_DSAccess Microsoft Windows® Management Instrumentation (WMI) 类，以确定拓扑中存在的全局编录服务器数。全局编录服务器数通过计算 DSAccessNameGC WMI 关键字的项数确定。如果 Exchange Server 分析工具发现拓扑中只存在一台全局编录服务器，Exchange Server 分析工具将显示最佳做法建议。

为了容错，最好至少有两台全局编录服务器用于为 Exchange Server 和用户提供服务。一台全局编录服务器代表一个故障点。Exchange 2000 Server、Exchange Server 2003 和 Exchange Server 2007 依靠全局编录服务器来实现各种功能。如果没有全局编录服务器，邮件传递速度可能会减慢或完全停止。而且，如果没有全局编录服务器，Exchange Server 服务可能无法启动。如果 Exchange Server 服务没有启动，用户就无法访问邮箱。

为了可伸缩性和容错，建议您在每个 Active Directory® 目录服务站点中至少配置两台全局编录服务器。如果站点跨越多个域，建议您为 Exchange 2000 Server 计算机、Exchange Server 2003 计算机或 Exchange Server 2007 计算机和客户端所在的每个域配置全局编录。此外，建议您为每四个 Exchange Server 计算机处理器部署一台全局编录服务器。

有关如何创建其他全局编录服务器的详细信息，请参阅 Microsoft 知识库文章 313994"HOW TO：在 Windows 2000 中创建或移动全局编录"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=313994)。

有关全局编录服务器与 Exchange Server 有关时的位置和可用性的详细信息，请参阅下列知识库文章：

  • 875427"Global catalog server placement and ratios in an Exchange 2000 Server organization or in an Exchange Server 2003 organization"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=875427)

  • 322801"Exchange System Attendant Does Not Start, and You Receive a "Global Catalog Servers Not Responding" Error Message"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322801)

  • 829361"Exchange Server 2003 Computer Takes Longer Than You Expect to Shut Down"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829361)

  • 304403"Exchange Considerations for Promoting a Domain Controller to a Global Catalog Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=304403)

  • 305065"Exchange Server-Related Considerations for Demoting a Global Catalog Server to a Domain Controller"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=305065)


站点文件夹服务器已删除
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-03-01

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个管理组对象的 siteFolderServer 属性的值。如果 Exchange Server 分析工具确定 siteFolderServer 属性的值包含字符串 DEL:，则会显示错误。

siteFolderServer 属性代表负责宿主站点文件夹的公用文件夹存储（通常是站点或管理组中的第一个服务器）的可分辨名称 (DN)。

默认情况下，站点文件夹服务器是安装在管理组中的第一个服务器。该服务器上的公用文件夹存储是管理组的忙/闲文件夹和脱机通讯簿文件夹的默认位置。如果删除此服务器或使其退役，却没有将这些文件夹复制到另一台服务器上，并将此服务器指定为脱机通讯簿服务器，则 Microsoft Office Outlook® 2003 用户将看到脱机通讯簿和忙/闲数据出现问题。

警告：
在使用 ADSI（Active Directory 服务接口）Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

更正此错误

  1. 打开 Active Directory 编辑器，如 ADSI Edit。

  2. 通过在配置容器中展开以下节点，找到想要指定为站点文件夹服务器的公用文件夹信息存储：

    CN=Configuration,DC=<DomainName>,DC=com, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdministrativeGroupName> CN=Servers, CN=<ServerName>, CN=InformationStore, CN=<StorageGroupName>

  3. 在右侧窗格中，用鼠标右键单击 CN=<PublicFolderStoreName>,，再单击 Properties。

  4. 在 Attributes 字段中，向下滚动并选择 distinguishedName 属性。

  5. 单击 Edit，然后将整个属性复制到剪贴板。

  6. 展开 Configuration 容器，再展开 CN=Configuration,CN=<DomainName>,CN=com, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups

  7. 用鼠标右键单击要修改的管理组，再单击 Properties。

  8. 在 Attributes 字段中，向下滚动并选择 siteFolderServer 属性。

  9. 单击 Edit，再将 distinguishedName 属性的值粘贴到 Value 字段中。

  10. 仔细检查 Value 字段的内容，确保粘贴已正确完成，再单击 OK 以保存更改。

  11. 单击 OK，关闭管理组属性。

  12. 退出 Active Directory 编辑器，并在站点中的所有 Exchange Server 计算机上重新启动 Microsoft Exchange Server 信息存储服务，以使更改生效。

有关重新创建系统文件夹和重置站点文件夹服务器的详细信息，请参阅下列 Microsoft 知识库文章：

  • 822444"HOW TO：在 Exchange Server 2003 中重置站点文件夹"(http://support.microsoft.com/?kbid=822444)

  • 275171"XADM：如何在 Exchange 2000 Server 上重置系统文件夹"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=275171)

  • 284200"Schedule+ Free/Busy System Folder Is Missing"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=284200)

有关使用 LDP 工具的详细信息，请参阅知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

有关使用 ADSI Edit 的详细信息，请参阅 Windows Server 帮助中的主题"Adsiedit.msc:ADSI Edit"。


低速 Active Directory 目录服务调用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-14

Microsoft® Exchange Server 分析工具会检查 Exchange 函数调用日志 (FCL)（Store.fcl 文件）中超过 2.5 秒响应时间的 Active Directory® 目录服务组件事件。

Exchange FCL Active Directory 组件事件代表对 Active Directory 组件的 Microsoft Exchange Information Store 服务 (Store.exe) 函数调用。

Active Directory 提供所有邮箱信息、地址列表服务以及其他与收件人有关的信息。大多数 Exchange Server 2003 配置信息也存储在 Active Directory 中。

Exchange Server 服务会访问存储在 Active Directory 中的信息，并将信息写入到 Active Directory 中。

如果 Exchange Server 分析工具发现 FCL 文件中的事件反映出来自 Microsoft Exchange Information Store 服务 (Store.exe) 的 Active Directory 函数调用响应时间超过 2.5 秒，则 Exchange Server 分析工具会显示一个错误。

当来自 Microsoft Exchange Information Store 服务 (Store.exe) 的跨组件调用等待响应时，远程过程调用 (RPC) 线程会在这些请求后面备份，并导致出现 Exchange Server 性能问题，如服务器对客户端的响应发生延迟。

从 Microsoft Exchange Information Store 服务到 Active Directory 的调用，所需时间超过 2.5 秒的情况可由下列情况引起：

  • Exchange 服务器和域控制器之间的网络延迟。

  • DSAccess 的静态配置或错误配置。

  • 超载的域控制器和全局编录。

  • Active Directory 拓扑设计错误。

若要解决此错误，请执行下列步骤：

  • 运行 Exchange Server 分析工具以进行其他的服务器问题分析。可在"Microsoft Exchange Server Best Practices Analyzer Tool v2.7"（Microsoft Exchange Server 最佳实践分析工具 v2.7）(http://go.microsoft.com/fwlink/?LinkId=34705) 上下载 Exchange Server 分析工具。

  • 检查 Active Directory 域控制器服务器的性能。

  • 查看此文档"详细信息"部分中的文章。

详细信息

有关 Exchange 性能和 DSAccess 的详细信息，请参阅 Microsoft 知识库文章 250570"Directory Service Server Detection and DSAccess Usage"（目录服务服务器检测和 DSAccess 用法）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570)。

有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)。

有关如何解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（解决 Microsoft Exchange Server 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)。

有关如何解决信息存储性能问题的详细信息，请参阅 Microsoft 知识库文章 257725"XADM：如何为信息存储故障排除收集诊断数据"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。

有关域控制器性能的详细信息，请参阅以下 Windows Server 资源：

  • "Planning Domain Controller Capacity"（规划域控制器容量）(http://go.microsoft.com/fwlink/?LinkId=70191)。

  • "Windows 2000 Server Active Directory Planning and Deployment Guides"（Windows 2000 Server Active Directory 规划和部署指南）中的"Active Directory Monitoring of Domain Controllers"（域控制器的 Active Directory 监视）(http://go.microsoft.com/fwlink/?LinkId=70193)。


低速 ESE 调用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-13

Microsoft® Exchange Server 分析工具会检查 Exchange 函数调用日志 (FCL)（Store.fcl 文件）中超过 2.5 秒响应时间的 Exchange 可扩展存储引擎 (ESE) 组件事件。

Exchange FCL ESE 组件事件表示对 ESE 组件的 Microsoft Exchange Information Store 服务 (Store.exe) 函数调用。

Exchange Information Store 位于 ESE 数据库的顶部。ESE 是复杂的、基于事务的数据库引擎。事务是一系列被视为原子（不可划分）单位的操作。对于一个事务中的所有操作，要么将其完成并永久保存，要么不执行任何操作。

Exchange Server 使用 ESE 作为嵌入数据库引擎，该引擎决定数据库的结构并管理内存。数据库引擎通过将 4 KB 数据块（页）传进和传出内存，从而在内存中缓存数据库。它更新内存中的数据页，并将新的数据页或经过更新的数据页写入磁盘。当请求到达系统时，数据库引擎可以在内存中缓冲数据。因此其不必经常访问磁盘。

虽然在内存中缓存数据是处理数据的最快和最有效方式，但它意味着 Exchange 正在运行时，磁盘上的信息永远不是完全最新的，不过，事务日志磁盘将始终与有关每个事务的信息保持一致。但是，因为内存中的许多更改尚未保存在磁盘上，所以数据库和内存不同步。

如果 Exchange Server 分析工具发现 Store.fcl 文件中的事件反映出来自 Microsoft Exchange Information Store 服务 (Store.exe) 的 ESE 组件函数调用响应时间超过 2.5 秒，则 Exchange Server 分析工具会显示一个错误。

当来自 Microsoft Exchange Information Store 服务 (Store.exe) 的跨组件调用等待响应时，远程过程调用 (RPC) 线程会在这些请求后面备份，并导致出现 Exchange Server 性能问题，如服务器对客户端的响应发生延迟。

来自 ESE 的持续调用可由下列情况引起：

  • Exchange 联机碎片整理。

  • 数据备份。

    注意：
    如果特意在 Exchange 调用跟踪日志记录收集期间进行数据备份或联机碎片整理，则可安全地忽略此消息，而不将其作为 Exchange Server 性能问题的标志
  • 数据库驱动器上的瓶颈。

若要解决此错误，请执行下列步骤：

  • 作为最佳做法，建议不要将备份窗口或联机维护与高峰用户需求间隔重叠。

  • 运行 Exchange Server 分析工具以进行其他的服务器分析。可在"Microsoft Exchange Server Best Practices Analyzer Tool v2.7"（Microsoft Exchange Server 最佳实践分析工具 v2.7）(http://go.microsoft.com/fwlink/?LinkId=34705) 上下载 Exchange Server 分析工具。

  • 查看此文档"详细信息"部分中的文章。

详细信息

有关如何配置联机碎片整理时间范围的详细信息，请参阅 Microsoft 知识库文章 244524"XADM：如何配置 Exchange Server 联机碎片整理时间范围"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524)。

有关 Exchange Server 磁盘瓶颈问题的详细信息，请参阅检测到磁盘瓶颈。

有关如何调整 Exchange Server 磁盘大小并对该磁盘进行优化的详细信息，请参阅"Optimizing Storage for Exchange Server 2003"（优化用于 Exchange Server 2003 的存储）中的"How to Calculate Your Disk I/O Requirements"（如何计算磁盘 I/O 需求）和"Best Practices Common to Multiple Architectures"（多种体系结构通用的最佳做法）(http://go.microsoft.com/fwlink/?linkid=49324)。

有关 ESE 的详细信息，请参阅"Extensible Storage Engine Architecture"（可扩展存储引擎体系结构）(http://go.microsoft.com/fwlink/?linkid=67009)。


低速 IMAIL 调用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-12

Microsoft® Exchange Server 分析工具会检查 Exchange 函数调用日志 (FCL)（Store.fcl 文件）中超过 2.5 秒响应时间的 MAPI 客户端的 IMAIL 组件事件。

Exchange FCL IMAIL MAPI 组件事件代表将邮件转换为 Internet 格式和将邮件从 Internet 格式转换为 MAPI 格式的 Microsoft Exchange Information Store 服务 (Store.exe) 函数调用。

Exchange Server 的 IMAIL 组件是一种灵活的转换服务，Microsoft Exchange Information Store 服务会在 Internet 邮件和 MAPI 邮件之间使用该转换服务。此组件可以实现使用 RFC-822 或 Internet 格式的客户端和使用 Exchange Server 内部存储格式的客户端（如 MAPI 客户端或内部 STORE 任务）之间的互操作性。

Exchange 使用 IMAIL 机制对内容应用邮件格式，这些格式是在 Exchange 系统管理器中对 Internet 域所指定的，或者是由用户在 Microsoft Office Outlook® 中针对每个收件人所指定的。+如果没有向 IMAIL 传递任何格式参数，则 IMAIL 会将 MAPI 邮件设置为 Summary TNEF (S/TNEF) 格式以便进行服务器之间的传输。

如果 Exchange Server 分析工具发现 Store.fcl 日志文件中的事件反映出从 Microsoft Exchange Information Store 服务 (Store.exe) 到 MAPI 客户端的 IMAIL 组件的组件函数调用响应时间超过 2.5 秒，则 Exchange Server 分析工具会显示一个错误。

当来自 Microsoft Exchange Information Store 服务 (Store.exe) 的跨组件调用等待响应时，远程过程调用 (RPC) 线程会在这些请求后面备份，并导致出现 Exchange Server 性能问题，如服务器对客户端的响应发生延迟。

对 IMAIL 的 Exchange Information Store 服务 (Store.exe) 函数调用响应时间很慢可由下列情况引起：

  • IMAIL 尝试处理某个邮件或附件中的许多数据。

  • 许多客户端请求进行数据转换。

  • 对 DSAccess 请求的响应速度很慢。

  • TEMP 和 TMP 驱动器上存在瓶颈。

  • 存在持续的邮箱移动。

  • 要解决此错误，请执行下列步骤：

  • 将进行任何邮箱移动的时间安排在非高峰需求间隔内。

  • 运行 Exchange Server 分析工具以进行其他的服务器问题分析（如邮件和附件大小限制）。可在"Microsoft Exchange Server Best Practices Analyzer Tool v2.7"（Microsoft Exchange Server 最佳实践分析工具 v2.7）(http://go.microsoft.com/fwlink/?LinkId=34705) 上下载 Exchange Server 分析工具。

  • 查看此文档"详细信息"部分中的文章。

详细信息

有关 Exchange Server 磁盘瓶颈问题的详细信息，请参阅检测到磁盘瓶颈。

有关如何调整 Exchange Server 磁盘大小并对该磁盘进行优化的详细信息，请参阅"Optimizing Storage for Exchange Server 2003"（优化用于 Exchange Server 2003 的存储）中的"How to Calculate Your Disk I/O Requirements"（如何计算磁盘 I/O 需求）和"Best Practices Common to Multiple Architectures"（多种体系结构通用的最佳做法）(http://go.microsoft.com/fwlink/?linkid=49324)。

有关针对 Exchange Server 上邮件大小限制的最佳做法的详细信息，请参阅未设置最大传出邮件大小。


低速 LSASS 调用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-12-04

Microsoft® Exchange Server 分析工具会检查 Exchange 函数调用日志 (FCL)（Store.fcl 文件）中超过 25 毫秒响应时间的本地安全身份验证服务器 (Lsass.exe) 进程组件事件。

Exchange FCL LSASS 进程组件事件代表对本地安全身份验证服务器 (Lsass.exe) 进程组件的 Microsoft Exchange Information Store 服务 (Store.exe) 函数调用。

本地安全身份验证服务器进程 (Lsass.exe) 是由其他进程调用的一种安全子系统，用以验证帐户信息和登录验证。

Exchange 客户端的每次登录都会使运行 Exchange Server 的服务器发送一个请求以查找该客户端的帐户安全标识符 (SID)，并会在本地安全身份验证服务器 (Lsass.exe) 进程中创建一个调用。

如果 Exchange Server 分析工具发现 Store.fcl 日志记录文件中的事件反映出来自 Microsoft Exchange 信息存储服务 (Store.exe) 的本地安全身份验证服务器 (Lsass.exe) 组件函数调用的响应时间超过 25 毫秒，则 Exchange Server 分析工具会显示错误。

当来自 Microsoft Exchange Information Store 服务 (Store.exe) 的跨组件调用等待响应时，远程过程调用 (RPC) 线程会在这些请求后面备份，并导致出现 Exchange Server 性能问题，如服务器对客户端的响应发生延迟。

对 LSASS 的 Microsoft Exchange Information Store 服务 (Store.exe) 函数调用响应时间很慢可由下列情况引起：

  • 与同时进行身份验证的用户数有关的服务器资源问题。

  • Exchange 服务器和域控制器或全局编录服务器之间的网络延迟。

  • 服务器资源瓶颈问题。

若要解决该问题，请采取下列步骤：

  • 考虑按照推荐的"NeverPing"参数中所述，设置 NeverPing 参数

  • 运行 Exchange Server 分析工具以进行其他的服务器问题分析（如邮件和附件大小限制）。可在"Microsoft Exchange Server Best Practices Analyzer Tool v2.7"（Microsoft Exchange Server 最佳实践分析工具 v2.7）(http://go.microsoft.com/fwlink/?LinkId=34705) 上下载 Exchange Server 分析工具。

  • 查看此文档"详细信息"部分中的文章。

详细信息

有关 Lsass.exe 进程和内存使用量的详细信息，请参阅 Microsoft 知识库文章 308356"运行 Windows Server 2003 或 Windows 2000 Server 的域控制器上 Lsass.exe 进程的内存使用量"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)。

有关 Exchange 客户端登录和 LSASS 问题的详细信息，请参阅 Microsoft 知识库文章 161938"Slow Exchange Client Logons Due to Resource Deadlock"（由于资源死锁导致 Exchange 客户端登录速度很慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938)。

有关 Exchange 服务器和域控制器或全局编录服务器之间网络延迟的详细信息，请参阅以下 Exchange Server 工作组博客文章"Exchange Does Not Always Use Local GCs"（Exchange 并不总是使用本地 GC）(http://go.microsoft.com/fwlink/?LinkId=69166)。

注意：
每篇博客的内容及其 URL 都可能随时更改，恕不另行通知。

有关服务器资源瓶颈问题的详细信息，请参阅处理器瓶颈。

有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)。

有关如何解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（排除 Microsoft Exchange Server 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)。

有关如何解决信息存储性能问题的详细信息，请参阅 Microsoft 知识库文章 257725"XADM：如何为信息存储故障排除收集诊断数据"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。


低速病毒扫描程序调用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-11

Microsoft® Exchange Server 分析工具会检查 Exchange 函数调用日志 (FCL)（Store.fcl 文件）中超过 2.5 秒响应时间的 Virusscan 病毒 API (VAPI) 组件事件。

Exchange FCL Virusscan VAPI 组件事件代表对外部病毒扫描程序软件的 Microsoft Exchange Information Store 服务 (Store.exe) 函数调用。

为了增强 VAPI 的故障排除功能，Exchange Server 实施了可用于跟踪病毒扫描 API 性能的事件日志记录。

记录的事件包括：

  • 供应商 DLL 的加载和卸载。

  • 项目的成功扫描。

  • 位于信息存储中的病毒。

  • VAPI 中的意外行为。

如果 Exchange Server 分析工具发现 Store.fcl 日志记录文件中的事件反映出来自 Microsoft Exchange Information Store 服务 (Store.exe) 的外部病毒扫描程序软件函数调用响应时间超过 2.5 秒，则 Exchange Server 分析工具会显示一个错误。

当来自 Microsoft Exchange Information Store 服务 (Store.exe) 的跨组件调用等待响应时，远程过程调用 (RPC) 线程会在这些请求后面备份，并导致出现 Exchange Server 性能问题，如服务器对客户端的响应发生延迟。

对病毒扫描软件的 Microsoft Exchange Information Store 服务 (Store.exe) 外部函数调用的响应时间很慢可由下列情况引起：

  • 对病毒扫描程序的更新，这些更新将生成对信息存储中项目的重新扫描。

  • 病毒扫描程序配置错误

  • 病毒扫描程序软件处理很大的邮件或附件。

若要解决此错误，请执行下列步骤：

  • 将对病毒引擎进行更新的时间安排在资源占用较少的时间，即非高峰需求间隔。

  • 考虑重新安装病毒扫描软件，但要在非高峰需求间隔进行重新安装。

  • 检查病毒扫描引擎的配置中是否存在正确的线程配置、文件级排除等。请参阅 Microsoft 知识库文章 823166"Exchange Server 2003 和防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)。

  • 查看此文档"详细信息"部分中的文章。

详细信息

有关通常与 Microsoft Exchange Server 2003 一起使用的病毒扫描程序的详细信息，请参阅 Microsoft 知识库文章 823166"Exchange Server 2003 和防病毒软件概述"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)。

有关通常与 Microsoft Exchange 2000 Server 一起使用的病毒扫描程序的详细信息，请参阅 Microsoft 知识库文章 328841"Exchange 和防病毒软件"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)。

有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)。

有关如何解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（解决 Microsoft Exchange Server 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)。

有关如何解决信息存储性能问题的详细信息，请参阅 Microsoft 知识库文章 257725"XADM：如何为信息存储故障排除收集诊断数据"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。


低速 VSS 快照调用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-13

Microsoft® Exchange Server 分析工具将检查 Exchange 函数调用日志 (FCL)（Store.fcl 文件）中超过 20 秒响应时间的卷影复制服务 (VSS) 快照组件事件。

Exchange FCL VSS 组件事件代表对 VSS 快照组件的 Microsoft Exchange Information Store 服务 (Store.exe) 函数调用。

VSS 是一组 COM API，可用于实现一个框架，该框架允许在系统中的应用程序继续写入卷的情况下执行卷备份。

Microsoft Exchange Server 2003 使用包含在 Microsoft Windows Server™ 2003 操作系统中的 VSS 来获取 Exchange Server 2003 数据库和事务日志文件的卷影副本。

VSS 快照不完全独立于原始数据。通常，快照是在您定义了时间标记并确保数据可回滚到该时间的情况下创建的。

如果 Exchange Server 分析工具发现 Store.fcl 文件中的事件反映出来自 Microsoft Exchange Information Store 服务 (Store.exe) 的 VSS 快照组件函数调用响应时间超过 20 秒，则 Exchange Server 分析工具会显示一个错误。

当来自 Microsoft Exchange Information Store 服务 (Store.exe) 的跨组件调用等待响应时，远程过程调用 (RPC) 线程会在这些请求后面备份，并导致出现 Exchange Server 性能问题，如服务器对客户端的响应发生延迟。

注意：
如果在 20 秒的 Exchange 调用跟踪日志记录收集时间内特意启动了 VSS 快照，则可安全地忽略此错误消息，而不将其作为 Exchange Server 性能问题的标志。

作为最佳做法，建议不要将备份窗口与联机维护或高峰用户需求间隔重叠。

详细信息

有关 VSS 的详细信息，请参阅"Best Practices for Using Volume Shadow Copy Service with Exchange Server 2003"（使用 Exchange Server 2003 的卷影复制服务的最佳做法）(http://go.microsoft.com/fwlink/?LinkId=56571)。


在最近 24 小时内记录了"SMTPSVC"错误事件 (ID:429)
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-03-16

Microsoft Exchange 分析工具查询 IIS 元数据库，以确定简单邮件传输协议 (SMTP) 虚拟服务器的各个实例的 LM/SmtpSvc/%SMTPInstance%/ServerState 属性值。

ServerState 属性可显示服务器实例的当前状态。状态和相应的状态代码如下所示：1（正在启动），2（已启动），3（即将停止)），4（已停止），5（即将暂停)，6（已暂停）或 7（正在继续）。

如果 Exchange 分析工具确定 SMTP 虚拟服务器实例的 ServerState 属性值不等于 2（已启动），则它将查询 Win32_NTLogEvent Microsoft Windows Management Instrumentation (WMI) 类，以确定在最近 24 个小时内是否为 SMTP 服务 (SMTPSVC) 记录了事件 429 错误。

如果 Exchange 分析工具发现未启动 SMTP 虚拟服务器实例 (VSI) 且在过去 24 个小时内为 SMTPSVC 记录了至少一个事件 429 错误，则 Exchange 分析工具将显示警告。

此警告表明 SMTP 虚拟服务器实例的指定目录可能存在问题。

SMTP 是 Exchange Server 进行邮件提交和邮件传输的本机邮件协议。这意味着客户端使用 SMTP 发送邮件，而 Exchange 服务器使用 SMTP 传递邮件和邮件数据。

当邮件通过 SMTP 服务到达 Exchange 计算机时，数据将以 .eml 文件的形式写入硬盘。默认情况下，这些文件存储在安装 Exchange 的同一个分区上的 <drive>:\Program Files\Exchsrvr\Mailroot 文件夹中。

此问题可能是由下列原因之一导致的：

  • <drive>:\Program Files\Exchsrvr\Mailroot 目录路径或该目录路径下的文件夹已被移动、丢失或已损坏

  • 未正确设置 <drive>:\Program Files\Exchsrvr\Mailroot 或该目录路径下文件夹的权限。

  • 防病毒应用程序正在扫描 <drive>:\Program Files\Exchsrvr\Mailroot 目录路径或该目录路径下的文件夹。

若要解决此警告问题，请执行下列一项或多项操作：

  • 验证 <drive>:\Program Files\Exchsrvr\Mailroot 目录路径和该目录路径下文件夹的位置和完整性。

  • 验证 <drive>:\Program Files\Exchsrvr\Mailroot 目录路径和该目录路径下文件夹的权限。

  • 确保防病毒应用程序没有在扫描 <drive>:\Program Files\Exchsrvr\Mailroot 目录路径中的文件夹。

在 Exchange Server 2003 上验证 Mailroot 目录路径

  1. 打开 Exchange 系统管理器。

  2. 展开"服务器"，展开 Exchange 服务器，展开"协议"，再展开 SMTP。

  3. 右键单击 SMTP 虚拟服务器（例如，默认 SMTP 虚拟服务器），再单击"停止"。

  4. 再次右键单击 SMTP 虚拟服务器，再单击"属性"。

  5. 单击"邮件"选项卡。

  6. 在"队列目录"字段中，验证相应 Mailroot 文件夹的完整路径。可以单击"浏览"在本地计算机上找到该路径。

  7. 单击"确定"保存更改。

  8. 右键单击 SMTP 虚拟服务器，再单击"启动"。
在 Exchange 2000 Server 上验证 Mailroot 目录路径

  1. 在要验证其 SMTP 虚拟服务器 Mailroot 文件夹的 Exchange 2000 Server 计算机上停止所有 Exchange Server 和 IIS 服务。

  2. 验证受影响的 SMTP 虚拟服务器的 msExchSmtpQueueDirectory 值是否配置为适当的路径。

  3. 等待 Active Directory 将此更改复制到此 Exchange 服务器使用的全局编录服务器。

  4. 启动 Microsoft Exchange System Attendant 服务。

  5. 在 Exchange Server 计算机上，检查应用程序事件日志中是否存在事件来源为 MSExchangeMU、类别为"常规"的事件 ID 1005 的三个实例。

  6. 重新启动 Exchange Server 计算机以使所做更改生效。
在 Exchange 2000 Server 和 Exchange Server 2003 上验证 Mailroot 目录路径的默认权限

  1. 启动 Windows 资源管理器，再导航到 Exchsvr 文件夹并展开它。

  2. 右键单击 Mailroot 文件夹，再单击"属性"

  3. 单击"安全"选项卡，再验证下列默认权限：

帐户 | 权限
Administrators | 完全控制
Authenticated Users | 读取和执行，列出文件夹内容，读取
Creator Owner | 无
Server Operators | 修改，读取和执行，列出文件夹内容，读取，写入
System | 完全控制
  1. 验证每个虚拟服务器实例的所有文件夹的这些默认权限是否存在。

有关上面介绍的过程的详细信息，请参阅下列 Microsoft 知识库文章：

  • 822933"如何更改 Exchange 2003 SMTP Mailroot 文件夹位置"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822933)

  • 318230"XCON：如何更改 Exchange 2000 SMTP Mailroot 目录位置"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=318230)

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列 Microsoft 知识库文章：

  • 266686"XCON：如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)

  • 268163"XCON：如何配置 SMTP 虚拟服务器（第 2 部分）"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

有关配置与 Exchange 结合使用的防病毒扫描应用程序的详细信息，请参阅尚未配置 Anti-Virus 文件夹排除。

有关如何在 Symantec AntiVirus 企业版中为实时扫描配置排除项的详细信息，请访问 Symantec 防病毒网站 (http://www.symantec.com)。

注意：
Web 地址可能会改变，所以，也许无法连接到此处提到的网站。

有关加强 Exchange Server 环境的防御措施以抵抗通过电子邮件传输的病毒和蠕虫的详细信息，请参阅"在 Exchange 2003 环境中抑制和阻止通过电子邮件传输的病毒"(http://go.microsoft.com/fwlink/?LinkId=47587)。

有关如何对 Exchange Server 使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"Exchange 和防病毒软件"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166"Exchange Server 2003 和防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN：Microsoft 在 Exchange 2000 防病毒解决方案方面的立场"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange Server 计算机上排除故障的建议"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅"Exchange Server 2007 Partners:Antivirus, Antispam"（Exchange Server 2007 合作伙伴：防病毒，防垃圾邮件）(http://go.microsoft.com/fwlink/?linkid=16226)。


SMTP 实例完全限定的域名与服务器名称不匹配
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-07

Microsoft® Exchange Server 分析工具会查询 Active Directory® 目录服务以确定服务器对象的 networkAddress 属性的 ncacn_ip_tcp: 字符串值是否与来自简单邮件协议 (SMTP) 虚拟服务器对象的 msExchSmtpFullyQualifiedDomainName 属性中的完全限定的域名 (FQDN) 相匹配。

如果 Exchange Server 分析工具确定这些属性的值不匹配，则 Exchange Server 分析工具将显示一个警告。

此警告表明，这些属性的值可能已手动更改并可能是导致此服务器上出现邮件流问题的原因。

msExchSmtpFullyQualifiedDomainName 属性的值指定 SMTP 虚拟服务器的 FQDN，并且必须可由域名系统 (DNS) 网络协议进行解析。

必须存在此属性值的有效 DNS 主机 (A) 记录，以便尝试解析 SMTP 虚拟服务器的 FQDN 的邮件服务器可检索到正确的 IP 地址并正确地路由邮件。

有关 Exchange 中反向 DNS 查找功能的详细信息，请参阅"Add a resource record to a DNS zone"（将资源记录添加到 DNS 区域）(http://go.microsoft.com/fwlink/?LinkId=63002)。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列知识库文章：

  • 266686"XCON：如何配置 SMTP 虚拟服务器（第 1 部分）"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)。

  • 268163"XCON：如何配置 SMTP 虚拟服务器（第 2 部分）"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)。

有关 SMTP 服务设计的详细信息，请参阅"Exchange Server 2003 技术参考指南"中的"SMTP 服务设计"(http://go.microsoft.com/fwlink/?LinkId=58876)。


SMTP Local Queue length 超出阈值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-04-20

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 SMTP Server 性能对象的 Local Queue Length 性能计数器收集数据，以分析性能数据。

如果 Exchange Server 分析工具确定 Local Queue Length 计数器在示例时间段内超出峰值 1000，则将显示错误信息。

SMTP Server\Local Queue Length 计数器表示简单邮件传输协议 (SMTP) 队列中要在本地传递到 Microsoft Exchange 信息存储服务的邮件数。在 Exchange Server 处理 SMTP 本地队列数据（Mailroot 目录）时，这些数据将临时保存在存储设备中。如果服务器失败，该设计可防止数据丢失。例如，当无法到达目标服务器时，将被路由到此服务器的邮件将存储在本地服务器队列目录中，直到能够进行传递。

此错误表示服务器上出现性能问题或中断，因为该服务器无法继续及时地传递传入邮件。下列条件可能造成此延迟：

  • 未及时咨询 Active Directory® 目录服务。

  • 邮件未及时发出以进行本地传递或 SMTP 传递。

  • 数据库（邮箱存储和公用文件夹存储）已卸除。

  • 若要解决此问题，请采取下列步骤：

  • 确保安装了所有数据库（邮箱存储和公用文件夹存储）。

  • 识别性能瓶颈的来源。性能瓶颈可能是相关的 CPU、磁盘、网络或内存，也可能由服务器负载增加或服务器资源不足所造成。使用性能监视器 (Perfmon.msc) 工具可确定瓶颈是否由服务器负载增加或服务器不够大所造成。如果服务器负载增加，则识别增加的来源并减少它。如果服务器资源不足，则增加必要的资源或将用户从服务器上移开。

  • 监视外部依赖项（如 Active Directory 目录服务）以查找性能问题并进行故障排除，必要时进行纠正。

详细信息

  • 有关 SMTP 传输调整的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"中的"SMTP Transport Tuning"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决邮件流问题的详细信息，请参阅 Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)。

  • 有关解决传输问题的详细信息，请参阅 Microsoft 知识库文章 257265"General troubleshooting for transport issues in Exchange 2000 Server and in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)。

  • 有关处理器瓶颈的详细信息，请参阅处理器瓶颈。

  • 有关磁盘瓶颈的详细信息，请参阅检测到磁盘瓶颈。

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关如何移动用户邮箱以降低服务器负载的详细信息，请参阅将用户邮箱移至其他服务器。


SMTP Server 性能监视器对象不可用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具包括性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎从 SMTP Server 性能对象的 Local Queue Length 性能计数器收集数据以分析性能数据。如果计数器未返回有效数据，则 Exchange Server 分析工具将显示基准消息。

如果性能数据收集引擎未返回有效数据，则可能出现下列情况的任意组合：

  • SMTP Server 性能对象已禁用。

  • SMTP Server 性能监视器对象丢失或损坏。

  • Exchange Server 分析工具没有访问性能对象的相应权限。

如果某些可扩展计数器破坏了注册表，或基于 Microsoft Windows® Management Instrumentation (WMI) 的程序修改了注册表，可能会发生前两种情况。以下过程说明如何处理前两种情况。在执行此过程之前，请验证 Exchange Server 分析工具是否具有相应的权限。有关运行 Exchange Server 分析工具所需的权限的详细信息，请参阅随 Exchange Server 分析工具提供的帮助文档。要获得帮助，请打开 Exchange Server 分析工具，然后按 F1 键。

更正此错误

  1. 验证 SMTP Server 性能对象是否已启用。

    1. 下载并安装可扩展性能计数器列表工具 (Exctrlst.exe)。可以从以下位置下载 Exctrlst.exe："Exctrlst.exe:Extensible Performance Counter List"网站 (http://go.microsoft.com/fwlink/?LinkId=34436)。

    2. 打开 Exctrlst.exe，再单击"Sort Order"，然后单击"Service"。

    3. 找到性能对象所报告的服务，并确认选中了"Performance Counters Enabled"复选框。

      如果未选中"Performance Counters Enabled"复选框，请选中该复选框，然后重新启动与性能计数器关联的服务，确认性能计数器工作正常。如果性能计数器无法正常工作，或"Performance Counters Enabled"复选框已选中，请继续执行第 2 步。

  2. 重建丢失或损坏的性能计数器，请参阅 Microsoft 知识库文章 300956"如何手动重新生成性能计数器库值"(http://support.microsoft.com/?kbid=300956)。

  3. 如果按照此知识库文章操作不能解决问题，将必须在"修复"模式下重新安装 Windows 操作系统，然后应用最新的 Windows Service Pack。


SQL Server 正在运行 Exchange Server 以来宾身份安装在其中的 Virtual Server 2005
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Model 关键字的值是否设置为 Virtual Machine。

Exchange Server 分析工具还检查是否存在以下注册表值：

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

另外，Exchange Server 分析工具还查询 Win32_Services WMI 类，以确定运行 Microsoft Virtual Server 2005 的物理计算机上是否正在运行 Microsoft SQL Server™ 服务 (MSSQLSERVER)。

如果 Exchange Server 分析工具发现 Model 关键字包含字符串 Virtual Machine，同时上述注册表分支存在，并且 MSSQLSERVER 在运行，则显示错误。

Model 关键字的值为 Virtual Machine 说明 Exchange Server 计算机正在作为来宾虚拟计算机运行在 Virtual Server 2005 或 Virtual PC 2004 中。由于上述注册表分支只能由 Virtual Server 2005 创建，因此它的存在意味着 Exchange Server 计算机正在作为来宾虚拟计算机运行在 Virtual Server 2005 中。

Microsoft 不支持在虚拟计算机或仿真器上运行任何版本的 Microsoft Exchange。这适用于运行在 Microsoft Virtual Server 2005、Microsoft Virtual PC 2004 或任何第三方虚拟计算机程序上的 Exchange Server。Microsoft Exchange Server 平台的设计和测试只是针对在物理硬件上运行而进行的，尤其是针对 Windows Server Catalog (http://go.microsoft.com/fwlink/?linkid=17219) 中列出的那些硬件平台。

此外，使 Exchange 作为虚拟服务器来宾运行在 SQL Server 计算机上不是最佳实践，因为这样无法在服务之间实现足够的冗余。

更正此错误

  1. 将运行在 Virtual Server 2005 下的 Exchange Server 中的邮箱移至非虚拟的 Exchange Server 计算机上。

  2. 重新连接所有公用文件夹，并在必要时传输虚拟 Exchange 服务器保留的所有角色。

  3. 将 Exchange 从虚拟计算机中卸载以便不再使用它，并将它从 Exchange 基础结构及 Active Directory® 目录服务中删除。

有关移动邮箱的详细信息，请参阅下列 Microsoft 知识库文章：

  • 822892"在 Exchange 2003 中移动邮箱工具的改进"(http://support.microsoft.com/kb/822892/zh-cn)

  • 224975"XADM:Differences Between Move Mailbox Methods"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

有关对运行在虚拟环境中的 Exchange Server 计算机的支持的详细信息，请参阅知识库文章 320220"Support Boundaries for Exchange Server on a Virtual Machine or an Emulation Machine"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)。

有关 Microsoft Virtual Server 2005 的详细信息，请参阅网站上的"Microsoft Virtual Server 2005"（英文）(http://go.microsoft.com/fwlink/?linkid=34938)。

有关 Microsoft Virtual PC 2004 的详细信息，请参阅网站上的"Microsoft Virtual PC 2004"（英文）(http://go.microsoft.com/fwlink/?linkid=34663)。


SRS port is below 5000
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Microsoft Exchange 站点复制服务的 TCP/IP 设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

如果 Exchange Server 分析工具发现 TCP/IP 的值设置为低于 5,000（十进制），则会显示警告。

如果必须将 TCP/IP 设置为静态值，建议您将其值设置为刚好大于 5,000。如果分配的静态端口号低于 5,000，可能会造成与另一个进程的端口冲突，导致 Microsoft Exchange 站点复制服务进程失败。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

设置 TCP/IP 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters

  3. 双击 TCP/IP 注册表项，然后将"数值数据"字段设置为刚好大于 5000 的整数（十进制）。

  4. 关闭注册表编辑器。

  5. 重新启动 Microsoft Exchange 站点复制服务，以使此更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关端口限制的详细信息，请参阅知识库文章 194952"XADM：Exchange Server 静态映射端口限制"(http://support.microsoft.com/?kbid=194952)。


SRS 端口已被手动覆盖
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Microsoft Exchange 站点复制服务的端口值是否已被手动覆盖：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

如果 Exchange Server 分析工具发现 TCP/IP 存在并已配置，则会显示非默认配置消息。

配置该值的最常见理由是为了使 MAPI 客户端能够连接到在防火墙另一侧的 Exchange 服务器。该方案涉及打开防火墙上的多个端口，以便使 Microsoft Office Outlook® 2003 客户端能够使用 MAPI 连接到 Exchange 服务器（通常通过 Internet）。这是一个支持的配置。有关将 MAPI 客户端配置为通过防火墙连接到 Exchange 的详细信息，请参阅 Microsoft 知识库文章 270836"Exchange 2000 和 Exchange 2003 静态端口映射"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)。如果使用的不是此方案，应删除该注册表项。

如果要在 MAPI 模式下使用 Outlook 通过 Internet 连接到 Exchange 服务器，则推荐的部署是使用 RPC over HTTP 功能，该功能可以在 Microsoft Windows Server™ 2003、Exchange Server 2003、Outlook 2003 和 Microsoft Windows® XP Professional 上找到。MAPI 模式以前称为"公司"或"工作组"模式。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

删除 TCP/IP 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters

  3. 删除名为 TCP/IP 的注册表值。

  4. 退出注册表编辑器，然后重新启动 Microsoft Exchange 站点复制服务。

部署 RPC over HTTP

  1. 查看"Exchange Server 2003 RPC over HTTP Deployment Scenarios"（英文）(http://go.microsoft.com/fwlink/?linkid=47577)。

  2. 查看 Microsoft 知识库文章 833401"如何在一台服务器上的 Exchange Server 2003 中配置 RPC over HTTP"(http://support.microsoft.com/kb/833401/zh-cn)。

  3. 查看知识库文章 827330"How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)。

  4. 查看 Microsoft 支持 Web 广播"Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


不支持为 System Attendant 配置的启动帐户
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Services Microsoft Windows® Management Instrumentation (WMI) 类，以确定在 Microsoft Exchange System Attendant 服务 (MSExchangeSA) 的 StartName 属性中指定的启动帐户是否使用 LocalSystem 帐户。如果 Exchange Server 分析工具发现 Exchange 2000 Server 或 Exchange Server 2003 计算机上 StartName 属性的值是 LocalSystem 帐户以外的任何其他帐户，则 Exchange Server 分析工具将显示错误。LocalSystem 帐户也称为 SYSTEM 帐户。

在 Exchange 2000 Server 和 Exchange Server 2003 中，必须在 LocalSystem 安全上下文下启动 MSExchangeSA。不得通过关联特定的用户帐户来启动 MSExchangeSA。如果作为 LocalSystem 运行的 Exchange 服务访问远程服务器，则 Exchange 服务将使用计算机帐户的凭据进行身份验证。

标准的密码更改机制每隔七天更改一次计算机帐户的密码。通过每隔七天更改一次密码，可以提高计算机帐户的安全性。因为下列原因，计算机帐户比典型的用户帐户更加安全：

  • 典型用户帐户的密码更改频率较低。

  • 典型用户帐户的密码没有随机生成的计算机帐户密码的随机性大。

在 Exchange Server 5.5 中，用户帐户用于服务。某些熟悉 ExchangeServer 5.5 的管理员会将 Exchange 2000 Server 服务和 Exchange Server 2003 服务上的启动帐户由默认 LocalSystem 帐户更改为用户帐户。

在 Exchange 2000 Server 和 Exchange Server 2003 中，Microsoft 不支持在任何默认 LocalSystem 帐户以外的帐户上运行 MSExchangeSA。

更正此错误

  1. 单击"开始"，指向"程序"，再指向"管理工具"，然后单击"服务"。

  2. 在服务列表中，用鼠标右键单击 Microsoft Exchange System Attendant，再单击"属性"。

  3. 在"登录"选项卡的"登录作为"下，单击"本地系统帐户"，再单击"确定"。

  4. 用鼠标右键单击 Microsoft Exchange System Attendant，再单击"重新启动"。

有关 Exchange 服务的详细信息，请参阅 Microsoft 知识库文章 239762"Exchange Services Run Under LocalSystem"（英文）( http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)。


STORE.EXE 文件丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以检查是否存在下列几个核心 Exchange 二进制文件：

  • Exres.dll

  • Gapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapi32.dll（在 System32 文件夹和 \Exchsrvr\bin 文件夹中检查）

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server 分析工具发现一个或多个上述文件丢失，则显示错误。若要解决该错误，请安装适用于您的 Exchange 版本的最新 Service Pack 或更新汇总。如果该错误继续存在，请运行 Exchange 2000 Server 或 Exchange Server 2003 安装程序，并选择"重新安装"。在重新安装模式中运行安装程序将只安装二进制文件。它不会删除或重置任何用户数据或配置数据。如果重新安装 Exchange Server，还必须重新安装任何已经安装过的 Exchange Service Pack 或修补程序。

重新安装 Exchange 2000 Server 或 Exchange Server 2003

  1. 登录到想要重新安装 Exchange 的服务器。将 Exchange 2000 Server 或 Exchange Server 2003 CD 插入 CD-ROM 驱动器。

  2. 在"开始"菜单上，单击"运行"，再键入 <drive>:\setup\i386\setup，其中 <drive> 是 CD-ROM 驱动器。

  3. 在"欢迎使用 Microsoft Exchange 安装向导"页上，单击"下一步"。

  4. 在"许可协议"页上，阅读协议。如果同意条款，请单击"我同意"，再单击"下一步"。

  5. 在"产品标识"页上，键入 25 位产品密钥，然后单击"下一步"。

  6. 在"组件选择"页上的"操作"列中，使用 Microsoft Exchange 节点旁边的下拉箭头，并选择"重新安装"，再单击"下一步"。

有关最新的 Exchange Server 2003 Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=25097)。

有关最新的 Exchange 2000 Server Service Pack、更新汇总和加载项的详细信息，请参阅网站上的"Downloads for Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=33457)。


存储 HTTP 端口低于 5000
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-03-21

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Microsoft Exchange 信息存储服务的 Rpc/HTTP Port 设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

如果 Exchange Server 分析工具发现 Rpc/HTTP Port 的值设置为低于 5000（十进制），则显示警告。

Exchange Server 2003 和 Exchange Server 2007 安装程序将 Rpc/HTTP Port 注册表项设置为 6001。Rpc/HTTP Port 注册表项用于支持 Microsoft Office Outlook® 2003 和 Microsoft Office Outlook 2007 的 RPC over HTTP 功能。

除非您借助于 Microsoft 咨询服务或按照 Microsoft 产品支持服务的建议自定义了 RPC over HTTP 部署，否则，建议您为 RPC over HTTP 部署默认的端口值。

如果必须将 Rpc/HTTP Port 设置为 6001 以外的其他值，建议您将其值设置为刚好大于 5000。如果分配的静态端口号低于 5000，可能会造成与另一个进程的端口冲突，导致 Microsoft Exchange 信息存储服务进程失败。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

将 Rpc/HTTP Port 注册表项设置为默认值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

  3. 双击 Rpc/HTTP Port 注册表项，然后将"数值数据"字段设置为 6001（十进制）或刚好大于 5000 的整数（十进制）。

  4. 关闭注册表编辑器。

  5. 重新启动计算机，以使此设置生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关配置 RPC over HTTP 的详细信息，请参阅下列知识库文章：

  • 833401"如何在一台服务器上的 Exchange Server 2003 中配置 RPC over HTTP"(http://support.microsoft.com/kb/833401/zh-cn)

  • 827330"How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)。


存储：HTTP 端口为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-09

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 HTTP Port 是否已设置为默认值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

如果 Exchange Server 分析工具发现 Rpc/HTTP Port 的值不是 6001（十进制），则会显示非默认配置消息。

Exchange Server 2003 和 Exchange Server 2007 安装程序将 Rpc/HTTP Port 注册表项设置为 6001。Rpc/HTTP Port 注册表项用于支持 Microsoft Office Outlook® 2003 和 Microsoft Office Outlook 2007 的 RPC over HTTP 功能。

除非您借助于 Microsoft 咨询服务或按照 Microsoft 产品支持服务的建议自定义了 RPC over HTTP 部署，否则，建议您为 RPC over HTTP 部署默认的端口值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

将 Rpc/HTTP Port 注册表项设置为默认值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 双击 Rpc/HTTP Port 注册表项，然后将"数值数据"字段设置为 6001（十进制）。

  4. 关闭注册表编辑器。

  5. 重新启动计算机，以使此设置生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关配置 RPC over HTTP 的详细信息，请参阅下列知识库文章：

  • 833401"如何在一台服务器上的 Exchange Server 2003 中配置 RPC over HTTP"(http://support.microsoft.com/kb/833401/zh-cn)

  • 827330"How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)。


次最佳的内存设置
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-02-15

Microsoft Exchange 分析工具查询 Win32_NTLogEvent Microsoft Windows Management Instrumentation (WMI) 类，以确定是否在过去 24 小时内记录了 MSExchangeIS 的事件 9665 错误。

Microsoft Exchange Server 2003 将在存储进程开始时执行最佳内存配置检查。如果不是最佳的内存设置，将在事件查看器中看到事件 9665。

如果 Exchange 分析工具发现在过去 24 小时内记录了事件 9665，Exchange 分析工具将读取事件的数据字段，以确定事件中存在下表中哪个可能的标志。

事件数据字段标志 | 显示的 Exchange Server 分析工具警告 | Exchange Server 2003 问题
0x00000001 | 未设置 /3GB 开关 | 服务器正在运行 Microsoft Windows 2000 Advanced Server 或 Microsoft Windows 2000 Datacenter Server，有 1 GB 或更多物理内存，但 boot.ini 文件中未设置 /3GB 开关。
0x00000002 | 未正确地设置 /Userva 开关 | 服务器正在运行 Microsoft Windows Server 2003 Standard Edition、Microsoft Windows Server 2003 Enterprise Edition 或 Microsoft Windows Server 2003 Datacenter Edition，有 1 GB 或更多物理内存，并且设置了 /3GB 开关，但是 boot.ini 文件中不存在 /USERVA 设置。
0x00000004 | 需要设置"SystemPages"设置。 | 服务器正在运行任意版本的 Microsoft Windows 2000 Server，注册表中设置的 SystemPages 值超出了 24000 到 31000 的范围。
0x00000008 | 需要重设"SystemPages"设置 | 服务器正在运行 Microsoft Windows Server 2003 Standard Edition、Microsoft Windows Server 2003 Enterprise Edition 或 Microsoft Windows Server 2003 Datacenter Edition，注册表中设置的 SystemPages 值不是 0。
0x00000010 | 未正确地设置 HeapDecommitFreeBlockThreshold 设置 | 服务器正在运行任意版本的 Microsoft Windows 2000 Server 或 Microsoft Windows Server 2003，注册表中设置的 HeapDeCommitFreeBlockThreshold 值不是 0x00040000

根据事件 9665 数据字段中存在的标志，Exchange 分析工具会显示上表中对应的警告。

这些警告表明 Exchange Server 内存设置为次最佳状态。

若要解决这些警告，请按照下面列出的针对问题的 Exchange 分析工具文章的指导操作：

  • 此 Exchange 邮箱服务器有 1 GB 或更多内存，但 Boot.ini 文件中未设置 /3GB

  • USERVA 未正确设置

  • SystemPages 设置得太高

  • 该服务器正在运行 Windows Server 2003，并且 SystemPages 值不等于 0

  • 此服务器有 1 GB 或更多物理内存，并且 HeapDeCommitFreeBlockThreshold 未设置为 262144

详细信息

有关这些问题的详细信息，请参阅 Microsoft 知识库文章 325044"如何解决 Exchange Server 2003 和 Exchange 2000 Server 中的虚拟内存碎片问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)。

有关 MSExchangeIS 事件 9665 的详细信息，请参阅"Events and Errors Message Center: Event Details"（事件和错误消息中心：事件详细信息）。

  • 有关邮箱存储事件 9665 的详细信息，请参阅 (http://go.microsoft.com/fwlink/?LinkId=83210)

  • 有关公用存储事件 9665 的详细信息，请参阅 (http://go.microsoft.com/fwlink/?LinkId=83213)


怀疑客户端上安装了桌面搜索软件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-09-05

Microsoft® Exchange Server 分析工具已确定您有许多用户正在使用桌面搜索引擎。桌面搜索引擎可能会产生许多对用户装入邮箱的远程过程调用 (RPC)，因为这些搜索引擎会爬行访问公用文件夹存储的文件结构，所以还会产生对公用文件夹的大量通信。许多搜索引擎只会爬行访问处于用户的公用文件夹收藏夹列表中的公用文件夹。因此，也许可以看到桌面搜索对公用文件夹服务器的负载，也许看不到。

为缓解这一问题可以采取的措施如下所述：

  • 让用户禁用扫描程序的 Microsoft Office Outlook® 功能，或限制只能扫描各自的个人邮箱。

  • 在缓存 Exchange 模式下运行 Outlook，以使扫描只影响本地工作站，而不影响服务器。

  • 遵循 Microsoft 知识库文章 889086"You may experience unexpected behavior in a Windows XP-based computer when you try to access public folders on Exchange 2000 Server"（尝试访问 Exchange 2000 Server 上的公用文件夹时，可能会遇到基于 Windows XP 的计算机的意外行为）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=889086) 中的指导可以获取修补程序，并设置桌面搜索用户访问的、运行 Exchange Server 的计算机上的 MaxObjsPerMapiSession 注册表值。

若要验证桌面搜索应用程序是否是特定用户高负载的原因，请使用 Microsoft Exchange Server User Monitor (ExMon) 监视搜索引擎执行的 RPC 操作，确保收集充足时段的数据（至少五分钟）。然后，删除搜索引擎，并再次运行 ExMon 工具。如果 RPC 速率明显提高，则可确认是桌面搜索引擎造成负载的增加。如果发现平均 RPC 延迟缩短，则可确认是高负载造成 RPC 延迟延长。

注意：
RPC 延迟速率在一天内变化很大。因此，五分钟测试可能还不够。可能需要测量更长的时间。

若要下载 ExMon，请访问 Microsoft 下载中心 (http://go.microsoft.com/fwlink/?linkid=54983)。

详细信息

  • 有关桌面搜索软件的详细信息，请参阅：

    • Microsoft 知识库文章 905184"在 Outlook 或其他 MAPI 客户端计算机上运行桌面搜索引擎软件时，Exchange 2000 Server 和 Exchange Server 2003 的性能可能会受影响"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184)。

    • Microsoft Exchange 工作组博客文章"Are your clients using desktop search engines that index Exchange mailboxes or public folders?"（您的客户端是否使用对 Exchange 邮箱或公用文件夹建立索引的桌面搜索引擎？）(http://go.microsoft.com/fwlink/?LinkId=54475)。

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（排除 Microsoft Exchange Server 性能故障）(http://go.microsoft.com/fwlink/?LinkId=47588)。


SystemPages 设置得太高
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-03-13

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 SystemPages 的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

如果 Exchange Server 分析工具发现 SystemPages 的值大于 50000，则显示警告。

不管安装了多少物理 RAM，Microsoft Windows Server™ 2003 和 Microsoft Windows® 2000 Server 可以直接寻址的内存地址空间最多都是 4 GB。从进程角度看，虚拟地址的每个元素在概念上都是指一个字节的物理内存。虚拟内存管理器 (VMM) 配合处理器内存管理器单元 (MMU) 负责将每个虚拟地址转换或映射到相应的物理地址。VMM 执行映射的过程是：先将 RAM 划分为固定大小的页框架，再创建系统页表条目 (PTE) 来存储有关这些页框架的信息，然后映射它们。系统 PTE 是小型内核模式的内存缓冲区，该缓冲区用来与磁盘 I/O 子系统和网络通信。每个 PTE 代表一个页框架，并包含 VMM 用来定位页的所需信息。

在基于 x86 并使用 4 KB 页大小的系统上，映射 2 GB 地址空间所需的最大 PTE 数是 524,288 (2 GB/4 KB)。在使用 /3GB 开关的类似系统上，映射 3 GB 地址空间所需的 PTE 数是 786,432 (3 GB/4 KB)。在典型系统上，按如下方式使用该空间：

  • 最多 50,000 PTE（大约 195 MB 地址空间）被保留用于常规用途。

  • 其余部分用于映射系统缓存、超空间、页面缓冲池、非页面缓冲池、故障转储区域等等。

该 PTE 池大小是在系统启动时基于系统中的物理内存数量而自动确定的。该池位于页面缓冲池和非页面缓冲池之间，后者也会随系统中的物理内存数量增长。

系统 PTE 池可能被过度使用，并严重碎片化。这会导致驱动程序可能无法加载等情况。而且，如果系统 PTE 池完全耗尽，则系统的其他部分的性能将会降低，甚至造成线程无法创建、系统停止运行和系统可能崩溃。

若要防止系统 PTE 池严重碎片化，应当始终针对 Exchange Server 计算机的操作系统正确配置 SystemPages 注册表值。在 Windows Server 2003 上运行 Exchange Server 时，建议将 SystemPages 注册表项设置为 0。此建议与对 Windows 2000 Server 的建议明显不同，Windows 2000 Server 将 SystemPages 设置为 24000 和 31000 之间的值。

执行下述过程之后，应当监视可用的系统 PTE 数。可以通过用 Windows 性能监视器（也称为"系统监视器"）监视 Memory | Free System Page Table Entries 性能计数器来监视该数字。如果在进行下面描述的注册表更改之后，可用的系统 PTE 数仍然很低，则应当检查下列内容，以确保 Exchange Server 计算机已进行最佳配置：

  • 驱动程序 出现故障的驱动程序是系统 PTE 较低的一个最常见原因。此外，我们已经知道某些 S3 Savage 4 视频卡驱动程序版本将 SystemPages 设置为 208896。该驱动程序通常存在于 IBM E 系列服务器上。请咨询硬件制造商，以确保所有硬件均使用的是最新驱动程序。也有可能需要降级到更基本的驱动程序。例如，运行基于服务器的应用程序（例如，Exchange Server）的计算机通常不需要有具备所有功能的最高级的视频驱动程序。而更基本的驱动程序通常就已足够。从高级视频驱动程序切换到基本视频驱动程序应当可以增加可用的系统 PTE 数。

  • 系统配置如果 Windows Server 2003 系统安装了 1 GB 或更多物理内存，应当检查并确保它的 Boot.ini 文件正确配置了 /3GB 和 /USERVA=3030 开关。有关这方面的信息，请参阅下列 Microsoft 知识库文章：

    • 823440"在基于 Windows Server 2003 的系统中安装 Exchange Server 2003 时必须使用 /3GB 参数"(http://support.microsoft.com/kb/823440/zh-cn)

    • 810371"XADM:在基于 Windows 2003 Server 的 Exchange Servers 上使用 /Userva 参数"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371)。

  • 事件日志 检查 Exchange Server 上的应用程序事件日志中是否有相关的错误和警告，尤其是 MSExchangeIS 事件 9582（错误和警告）、9665（警告）和 12880（错误）。如果出现事件 9665，则还可以说明未将 SystemPages 配置成使系统获得最佳性能的状态。有关这些事件的详细信息，请参阅知识库文章 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://support.microsoft.com/kb/325044/zh-cn)。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

在 Windows 2000 Server 上通过更改 SystemPages 的值来解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. 在右侧窗格中，双击 SystemPages。

  4. 在"数值数据"字段中，键入介于 24000 和 31000（十进制）之间的值，再单击"确定"。如果不确定要使用的值，建议使用 31000（十进制）。

  5. 关闭注册表编辑器，并重新启动计算机，以使更改生效。

在 Windows Server 2003 上通过更改 SystemPages 的值来解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. 在右侧窗格中，双击 SystemPages。

  4. 在"数值数据"字段中，键入 0，再单击"确定"。

  5. 关闭注册表编辑器，并重新启动计算机，以使更改生效。

通过更新或降级视频驱动程序来解决此警告问题

  • 执行下列操作之一：

    • 与硬件制造商联系，以获取没有配置 SystemPages 设置的更新的视频驱动程序。

    • 将视频驱动程序降级到标准 VGA 驱动程序，并按上述说明更正 SystemPages 值。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关优化 Exchange Server 的内存的详细信息，请参阅下列知识库文章：

  • 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://support.microsoft.com/kb/325044/zh-cn)

  • 815372"如何在 Exchange Server 2003 中优化内存使用"(http://support.microsoft.com/kb/815372/zh-cn)

  • 311901"The effects of 4GT tuning on System Page Table Entries"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


System Attendant HTTP 端口低于 5000
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-03-21

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Microsoft Exchange 系统助理的 HTTP Port 设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

如果 Exchange Server 分析工具发现 HTTP Port 的值设置为低于 5000（十进制），则显示警告。

Exchange Server 2003 和 Exchange Server 2007 安装程序将 HTTP Port 注册表项设置为 6002。HTTP Port 注册表项用于支持 Microsoft Office Outlook® 2003 和 Microsoft Office Outlook 2007 的 RPC over HTTP 功能。

除非您借助于 Microsoft 咨询服务或按照 Microsoft 产品支持服务的建议自定义了 RPC over HTTP 部署，否则，建议您为 RPC over HTTP 部署默认的端口值。

如果必须将 HTTP Port 设置为 6002 以外的其他值，建议您将其设置为刚好大于 5000 的值。如果分配的静态端口号低于 5000，可能造成与另一个进程的端口冲突，导致 Microsoft Exchange 系统助理进程失败。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

将 HTTP Port 注册表项设置为默认值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 双击 HTTP Port 注册表项，然后将"数值数据"字段设置为 6002（十进制）或刚好大于 5000 的整数（十进制）。

  4. 关闭注册表编辑器。

  5. 重新启动计算机，以使此设置生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关配置 RPC over HTTP 的详细信息，请参阅下列知识库文章：

  • 833401"如何在一台服务器上的 Exchange Server 2003 中配置 RPC over HTTP"(http://support.microsoft.com/kb/833401/zh-cn)

  • 827330"How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)。


System Attendant HTTP NSPI 端口低于 5000
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-03-21

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Microsoft Exchange 系统助理的 Rpc/HTTP NSPI Port 设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

如果 Exchange Server 分析工具发现 Rpc/HTTP NSPI Port 的值设置为低于 5000（十进制），则显示警告。

Exchange Server 2003 和 Exchange Server 2007 安装程序将 Rpc/HTTP NSPI Port 注册表项设置为 6004。Rpc/HTTP NSPI Port 注册表项用于支持 Microsoft Office Outlook® 2003 和 Microsoft Office Outlook 2007 的 RPC over HTTP 功能。

除非您借助于 Microsoft 咨询服务或按照 Microsoft 产品支持服务的建议自定义了 RPC over HTTP 部署，否则，我们建议您使用默认端口值来部署 RPC over HTTP。

如果必须将 Rpc/HTTP NSPI Port 设置为 6004 以外的其他值，建议您将其值设置为刚好大于 5000。如果分配的静态端口号低于 5000，可能会造成与另一个进程的端口冲突，导致 Microsoft Exchange 系统助理进程失败。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

将 Rpc/HTTP NSPI Port 注册表项设置为默认值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 双击 Rpc/HTTP NSPI Port 注册表项，然后将"数值数据"字段设置为 6004（十进制）或刚好大于 5000 的整数（十进制）。

  4. 关闭注册表编辑器。

  5. 重新启动计算机，以使此设置生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关配置 RPC over HTTP 的详细信息，请参阅下列知识库文章：

  • 833401"如何在一台服务器上的 Exchange Server 2003 中配置 RPC over HTTP"(http://support.microsoft.com/kb/833401/zh-cn)

  • 827330"How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


System Attendant：HTTP NSPI 端口为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已将 HTTP Port 设置为默认值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

如果 Exchange Server 分析工具发现 Rpc/HTTP NSPI Port 的值不是 6004（十进制），则显示非默认配置消息。

Exchange Server 2003 安装程序将 Rpc/HTTP NSPI Port 注册表项设置为 6004。Rpc/HTTP NSPI Port 注册表项用于支持 Microsoft Office Outlook® 2003 的 RPC over HTTP 功能。

除非您借助于 Microsoft 咨询服务或按照 Microsoft 产品支持服务的建议自定义了 RPC over HTTP 部署，否则，建议您为 RPC over HTTP 部署默认的端口值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

设置 Rpc/HTTP NSPI Port 注册表值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 双击 Rpc/HTTP NSPI Port 注册表项，然后将"数值数据"字段设置为 6004（十进制）。

  4. 关闭注册表编辑器。

  5. 重新启动计算机，以使此设置生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关配置 RPC over HTTP 的详细信息，请参阅下列知识库文章：

  • 833401"如何在一台服务器上的 Exchange Server 2003 中配置 RPC over HTTP"(http://support.microsoft.com/kb/833401/zh-cn)

  • 827330"How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)。


系统助理：HTTP 端口值为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-09

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 HTTP Port 是否已设置为默认值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

如果 Exchange Server 分析工具发现 HTTP Port 的值不是 6002（十进制），则会显示非默认配置消息。

Exchange Server 2003 和 Exchange Server 2007 安装程序将 HTTP Port 注册表项设置为 6002。HTTP Port 注册表项用于支持 Microsoft Office Outlook® 2003 和 Microsoft Office Outlook 2007 的 RPC over HTTP 功能。

除非您借助于 Microsoft 咨询服务或按照 Microsoft 产品支持服务的建议自定义了 RPC over HTTP 部署，否则，建议您为 RPC over HTTP 部署默认的端口值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

将 HTTP 端口注册表项设置为默认值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 双击 HTTP Port 注册表项，然后将"数值数据"字段设置为 6002（十进制）。

  4. 关闭注册表编辑器。

  5. 重新启动计算机，以使此设置生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关配置 RPC over HTTP 的详细信息，请参阅下列知识库文章：

  • 833401"如何在一台服务器上的 Exchange Server 2003 中配置 RPC over HTTP"(http://support.microsoft.com/kb/833401/zh-cn)

  • 827330"How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


System Attendant legacyExchangeDN 值丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-09

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每台 Exchange Server 计算机的系统助理对象的 legacyExchangeDN 属性值。如果 Exchange Server 分析工具未发现任何系统助理对象的 legacyExchangeDN 属性值，则 Exchange Server 分析工具将显示错误消息。

如果管理员修改 Active Directory 来恢复处于故障恢复情况下的数据库，可能造成 legacyExchangeDN 丢失。若要解决该错误，必须使用 LDP (ldp.exe) 工具或 Active Directory 服务接口 (ADSI) Edit 等 Active Directory 编辑器修改 legacyExchangeDN 属性。

若要确保 legacyExchangeDN 属性正确，还应检查此服务器或另一个未生成此错误的 Exchange 服务器的其他系统助理对象，因为这些对象的 legacyExchangeDN 属性应具有类似的值。

如果数据库丢失了 legacyExchangeDN 属性，则可能其他几个系统对象也丢失了该属性。因此，如果使用 LDP 或 ADSI Edit 来添加新的 legacyExchangeDN 值，那么也必须在其他所有系统对象上添加新的 legacyExchangeDN 值。

警告：
在使用 ADSI Edit、LDP 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。若要解决这些问题，您可能需要重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003/Exchange Server 2007。修改 Active Directory 对象的属性的风险由您自己承担。
更正此错误

  1. 打开 Active Directory 编辑器，如 ADSI Edit。

  2. 展开 Configuration [DomainName]，再展开 CN=Configuration, DC=DomainName, DC=DomainSuffix。

  3. 展开 CN=Services，再展开 CN=Microsoft Exchange。

  4. 依次展开 CN=OrganizationName、CN=Administrative Groups、CN=AdminGroupName。

  5. 展开 CN=Servers，再展开 CN=ServerName。

  6. 右键单击 CN=Microsoft System Attendant，然后选择 Properties。

  7. 向下滚动找到 legacyExchangeDN，选择它，并单击 Edit。

  8. 在 Value 字段中，输入正确的 legacyExchangeDN。

  9. 关闭 Active Directory 编辑器，并重新启动 Exchange Server 计算机，以使更改生效。

有关使用 ADSI Edit 创建新的 legacyExchangeDN 属性的详细信息，请参阅 Microsoft 知识库文章 273863"How to Change the LegacyExchangeDN Attribute in Native Mode with ADSI Edit"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863)。


系统助理 NSPI 端口已被手动覆盖
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-17

Microsoft® Exchange Server 分析工具读取下列注册表项，以确定名称服务提供程序接口目标服务器 (NSPI target server) 服务是否已被手动覆盖：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

如果 Exchange Server 分析工具发现 TCP/IP NSPI Port 存在并已配置，则会显示非默认配置消息。

配置该值的最常见理由是为了使 MAPI 客户端能够连接到在防火墙另一侧的 Exchange 服务器。该情形涉及打开防火墙上的多个端口，以便使 Microsoft Office Outlook® 2003 客户端能够使用 MAPI 连接到 Exchange 服务器（通常通过 Internet）。

如果要在公司或在工作组模式下使用 Outlook 通过 Internet 连接到 Exchange 服务器，则推荐的部署是使用 RPC over HTTP（HTTP 远程过程调用）功能，该功能可以在 Microsoft Windows Server™ 2003、Exchange Server 2003、Outlook 2003 和 Windows® XP Professional 上找到。

RPC over HTTP 使您不需要使用虚拟专用网 (VPN) 连接，也不需要打开防火墙上的多个端口，即可允许从 Outlook 2003 到 Exchange Server 2003 进行 MAPI 访问。运行 Outlook 2003 的用户可以通过 Internet 连接到 Exchange 服务器。RPC 客户端通过在 HTTP 协议的基础上建立一个 RPC 通信隧道，来建立 Internet 连接。如果 RPC 客户端可以与正在运行 Internet 信息服务 (IIS) 的远程计算机建立 HTTP/HTTPS 连接，则 RPC 客户端就可以连接到远程网络上的任何服务器。远程网络上的服务器必须被配置为可以使用 RPC over HTTP 通过 Internet 进行访问。另外，RPC 客户端和 RPC 服务器程序可以跨越 Internet 连接起来，即使双方程序都在位于不同网络的防火墙的后面。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

删除 TCP/IP NSPI Port 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 删除名为 TCP/IP NSPI Port 的注册表值。

  4. 退出注册表编辑器，并重新启动 Exchange 系统助理服务。

部署 RPC over HTTP

  1. 查看"Exchange Server 2003 RPC over HTTP Deployment Scenarios"（英文）(http://go.microsoft.com/fwlink/?linkid=47577)。

  2. 查看 Microsoft 知识库文章 833401"如何在一台服务器上的 Exchange Server 2003 中配置 RPC over HTTP"(http://support.microsoft.com/kb/833401/zh-cn)。

  3. 查看知识库文章 827330"How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)。

  4. 查看 Microsoft 支持网络广播"Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关在防火墙环境中使用 TCP/IP NSPI Port 注册表值的详细信息，请参阅知识库文章 270836"Exchange 2000 和 Exchange 2003 静态端口映射"(http://support.microsoft.com/kb/270836/zh-cn)。


系统助理服务配置为与台式机交互
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Microsoft Exchange System Attendant (MSExchangeSA) 服务的 DesktopInteract 属性值。如果 Exchange Server 分析工具发现 Exchange System Attendant 服务配置为与台式机交互，则 Exchange Server 分析工具将显示错误。

此配置只应当在 Microsoft 产品支持服务的指导下使用。除非 Microsoft 产品支持服务指导您在此配置中运行 System Attendant 服务，否则，建议重新配置 System Attendant 服务的属性，使其不会与台式机交互。

配置 Exchange System Attendant 服务帐户

  1. 打开"服务"Microsoft 管理控制台 (MMC) 管理单元。

  2. 找到并停止 Microsoft Exchange System Attendant 服务。注意，停止 System Attendant 服务将同时停止所有依赖于 System Attendant 服务的服务。包括 Microsoft Exchange 信息存储服务。

  3. 双击 Microsoft Exchange System Attendant 服务。

  4. 在"Microsoft Exchange System Attendant 属性"页的"登录"选项卡上，在"登录作为"下选择"本地系统帐户"。

  5. 清除"允许服务与台式机交互"复选框，再单击"应用"。

  6. 在"服务状态"下，单击"启动"，再单击"确定"。

  7. 关闭"服务"管理单元。

有关正确的 Exchange 服务配置的详细信息，请参阅 Microsoft 知识库文章 239762"Exchange Services Run Under LocalSystem"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)。


System Attendant 服务未作为 LocalSystem 运行
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-01-09

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Microsoft Exchange 系统助理 (MSExchangeSA) 服务的 StartName 属性的值。Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定目录中 Exchange Server 对象的 serialNumber 属性的值。Exchange Server 对象的 serialNumber 属性标识了运行在该对象所代表的计算机上的 Exchange Server 的版本。如果 Exchange Server 分析工具发现在运行 Exchange 2000 Server、Exchange Server 2003 或 Exchange Server 2007 的 Exchange 服务器上使用 LocalSystem (SYSTEM) 以外的任何其他帐户运行 Exchange 系统助理服务，Exchange Server 分析工具将显示错误。

该错误说明系统助理服务未在支持的配置中运行。如果在任何其他帐户下运行系统助理服务，将造成权限和访问错误。

若要解决该错误，必须将 Exchange 系统助理服务配置为在 LocalSystem (SYSTEM) 帐户下启动。

注意：
该错误不适用于 Exchange Server 5.5 版。仅 Exchange 2000 Server、Exchange Server 2003 和 Exchange Server 2007 要求使用 LocalSystem 帐户运行 Exchange 系统助理服务。
配置 Exchange 系统助理服务帐户

  1. 打开"服务"Microsoft 管理控制台 (MMC) 管理单元。

  2. 找到并停止"Microsoft Exchange 系统助理"服务。注意，停止系统助理服务将同时停止所有依赖于系统助理服务的服务。包括 Microsoft Exchange 信息存储服务。

  3. 双击"Microsoft Exchange 系统助理"服务。

  4. 在"Microsoft Exchange 系统助理属性"页的"登录"选项卡上，在"登录作为"下选择"本地系统帐户"，再单击"应用"。

  5. 在"服务状态"下，单击"启动"，再单击"确定"。

  6. 关闭"服务"管理单元。

有关在 LocalSystem 帐户下运行 Exchange 服务的详细信息，请参阅 Microsoft 知识库文章 239762"Exchange Services Run Under LocalSystem"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)。


TcpTimedWaitDelay 项缺少或为非默认值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-03-13

Microsoft Exchange 分析工具查询 Active Directory 目录服务以确定所有具有 msExchExchangeServer 对象类的对象的 serialNumber 属性值。如果字符串值包括"Version 5.5"，则表示计算机运行的是 Exchange Server 5.5。如果字符串值包括"Version 6.0"，则表示计算机运行的是 Exchange 2000 Server。如果字符串值包括"Version 6.5"，则表示计算机运行的是 Exchange Server 2003。如果字符串值包括"Version 8.0"，则表示计算机运行的是 Exchange Server 2007。

然后，Exchange 分析工具读取找到的每个 Exchange Server 2007 服务器的以下注册表分支，以确定 TcpTimedWaitDelay 项的值是否设置为默认值 60。

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

TcpTimedWaitDelay 项确定在 TCP 释放已关闭的连接并重用其资源之前必须经过的时间。关闭和释放之间的这段间隔称为 TIME_WAIT 状态或 2MSL 状态。在此期间，可以重新打开连接，对客户端和服务器来说这比建立新连接的成本要低得多。

如果减小此项的值，则允许 TCP 更快地释放已关闭的连接，从而为新连接提供更多的资源。但是，如果该值过小，则 TCP 可能会在连接完成之前释放连接资源，要求服务器使用其他资源重新建立连接。

如果 Exchange 分析工具确定缺少 TcpTimedWaitDelay 项的值或该值不等于默认值 60，则 Exchange 分析工具将显示一条警告。

为了获得最佳性能，建议在 Exchange Server 2007 服务器上将 TcpTimedWaitDelay 项设置为其默认值 60。

重要信息：
本主题包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
将 TcpTimedWaitDelay 注册表项设置为其默认值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\Tcpip\Parameters

  3. 双击 TcpTimedWaitDelay，然后将"数值数据"字段设置为 60（十进制）。

  4. 关闭注册表编辑器，然后重新启动计算机。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

此问题与 MaxUserPort 项缺少或为非默认值分析工具问题有关。

有关 MaxUserPort 和 TcpTimedWaitDelay 注册表项的影响的详细信息，请参阅 Windows 2000 Resource Kit（Windows 2000 资源工具包）中的"Transmission Control Protocol"（传输控制协议）主题 (http://go.microsoft.com/fwlink/?LinkId=85654)。


TEMP/TMP 变量可能指向无效或不合适的文件夹
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

在非群集 Exchange Server 计算机上，Microsoft® Exchange Server 分析工具读取下列注册表项，以确定 TEMP 和 TMP 环境变量的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

HKLM\System\CurrentControlSet\Control\Session Manager\Environment\TMP

Microsoft Exchange 信息存储服务在多种操作（例如，邮件转换和邮箱移动操作）期间都将使用 TEMP 和 TMP 文件夹作为临时存储区。在非群集的 Exchange 服务器上，Microsoft Exchange 信息存储服务会使用 SYSTEM（例如，Local System）帐户，而该帐户则会将默认的环境变量设置 %Systemroot%\Temp 作为 TEMP 和 TMP 来使用。如果 Exchange Server 的 TEMP 或 TMP 环境变量中有一个或两个都以 %SYSTEMROOT 开头，则会显示警告。

TEMP 和 TMP 环境变量用来指定文件系统中的哪些文件夹（哪个路径）应当被需要临时工作区的应用程序使用。TEMP 通常由应用程序（例如，Microsoft Exchange）使用，而 TMP 通常由开发工具（例如，Microsoft Visual C++®）使用。每个变量的路径通常相对于应用程序或工具的安全上下文。

如果对 Microsoft Windows Server™ 2003 群集中的 Exchange 虚拟服务器运行 Exchange Server 分析工具，则分析工具不会读取 HKLM 注册表树。而是读取下列注册表项：

HKEY_USERS\<Cluster service account SID>\Environment\TEMP

HKEY_USERS\<Cluster service account SID>\Environment\TMP

运行在 Windows Server 2003 群集中的 Exchange 虚拟服务器的群集服务帐户需要使用环境变量设置，该帐户运行在具体用户安全原则的上下文下。对于用户帐户，TEMP 和 TMP 的默认环境变量被设置为 %Userprofile%\temp。如果 Exchange 虚拟服务器的 TEMP 或 TMP 环境变量中有一个或两个都以 %SYSTEMROOT 开头，则会显示警告。

为了获得最佳性能，建议不要使用包含操作系统的磁盘作为 Exchange 所使用的 TEMP 和 TMP 文件夹的所在地。此外，应当确保将这些环境变量设置为快速磁盘或磁盘子系统（例如 RAID 0+1 盘轴集）上的路径。还建议您不要将 Exchange 或 Exchange 虚拟服务器所使用的 TEMP 和 TMP 文件夹设置在包含操作系统的磁盘上。

解决此警告问题

  1. 以具有管理权限的帐户登录到 Exchange 服务器计算机。

  2. 用鼠标右键单击"我的电脑"，然后选择"属性"。

  3. 选择"高级"选项卡。

  4. 单击"环境变量"按钮。

  5. 在"系统变量"区域中，选择 TEMP 并单击"编辑"按钮。

  6. 在"变量值"字段中，输入 TEMP 环境变量的新路径，再单击"确定"。

  7. 在"系统变量"区域中，选择 TMP 并单击"编辑"按钮。

  8. 在"变量值"字段中，输入 TMP 环境变量的新路径，再单击"确定"。

  9. 单击"确定"关闭"环境变量"对话框，再次单击"确定"关闭"系统属性"对话框。

  10. 重新启动该节点，以便应用更改。

有关在群集 Exchange 服务器上更改 TEMP/TMP 环境变量的详细信息，请参阅群集 TEMP/TMP 路径与系统分区位于同一个驱动器上。


此服务器有 1 GB 或更多物理内存，并且 HeapDeCommitFreeBlockThreshold 未设置为 262144
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-08-14

错误消息

简介

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已基于系统中物理内存量优化微调了 Exchange：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\HeapDeCommitFreeBlockThreshold

如果 Exchange Server 分析工具发现在安装了 1 GB 或更多物理内存的 Exchange Server 计算机上未设置 HeapDeCommitFreeBlockThreshold 的值，则显示警告。

当在给定的地址释放内存后，操作系统堆管理器检查该地址周围有多少个相邻的字节空闲。该检查完成后，堆管理器可以执行下面两个操作中的某一个：

  • 保持相邻的内存块提交。

  • 回收相邻的内存块，而仅仅将它标记为保留。

只有在相邻字节超过了一定的数目时才回收内存，HeapDeCommitFreeBlockThreshold 注册表项即指定该数目。默认情况下，堆管理器不一定合并所有空闲块或分配新内存。因此，块可能回收并成为虚拟地址空间中的无用空洞。这可能导致产生虚拟内存碎片、性能下降，并最终导致系统不稳定。

在安装了 1 GB 或更多物理内存的系统上，可以通过控制回收的内存块的大小来优化性能。HeapDeCommitFreeBlockThreshold 注册表项控制对释放的内存的处理。将该值添加到注册表中时，必须对它配置十六进制值 0x00040000（相当于十进制的 262144）。

对于 HeapDeCommitFreeBlockThreshold 注册表项，Microsoft 除了支持十六进制值 0x00040000（相当于十进制的 262144）以外，不支持其他任何值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Control\Session Manager

  3. 创建一个名为 HeapDeCommitFreeBlockThreshold 的 DWORD 值。

  4. 双击 HeapDeCommitFreeBlockThreshold 值，然后输入十六进制值 0x00040000（相当于十进制的 262144）。

  5. 关闭注册表编辑器，并重新启动 Exchange Server 计算机，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 HeapDeCommitFreeBlockThreshold 注册表项的详细信息，请参阅下列知识库文章：

  • 315407"XADM:"HeapDeCommitFreeBlockThreshold"注册表项"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=315407)

  • 815372"如何在 Exchange Server 2003 中优化内存使用"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)


该服务器正在运行 Windows Server 2003，并且 SystemPages 值不等于 0
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 SystemPages 值的设置：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

Exchange Server 分析工具还查询 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 OSProductSuite 关键字的值。该关键字的值对应于 Microsoft Windows 操作系统的特定版本。

如果 Exchange Server 分析工具发现，在运行不是 Microsoft Windows Small Business Server 2003 安装的一部分的 Microsoft Windows Server™ 2003 的 Exchange Server 计算机上，SystemPages 的值未设置为 0，则会显示警告。

在配备 1 GB 或更多 RAM 的 Microsoft Windows Server 2003 上运行 Exchange Server 2003 Service Pack 1 (SP1) 时，建议将 SystemPages 注册表项设置为 0。该建议与对 Microsoft Windows 2000 Server 的建议明显不同，后者是将 SystemPages 设置为在 24000 和 31000 之间的值。

在不是作为 Microsoft Windows Small Business Server 2003 安装的一部分的 Windows Server 2003 计算机上，应当永远不要将 SystemPages 注册表值设置为 0 以外的任何其他值。如果更改该值，将使系统无法针对您的系统计算出最佳值，并无法在系统更改时调整该值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
警告：
在运行 Windows Server 2003 的计算机上设置 SystemPages 注册表值的结果是将减小页面缓冲池的最大大小。这可能会造成页面缓冲池耗尽和服务器的不稳定。

解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. 在右侧窗格中，双击"SystemPages"。

  4. 在"数值数据"字段中，键入 0，再单击"确定"。

  5. 退出注册表编辑器，并重新启动计算机，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关优化 Exchange Server 的内存的详细信息，请参阅下列知识库文章：

  • 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://support.microsoft.com/kb/325044/zh-cn)

  • 815372"如何在 Exchange Server 2003 中优化内存使用"(http://support.microsoft.com/kb/815372/zh-cn)

  • 311901"The effects of 4GT tuning on System Page Table Entries"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


该 Exchange 服务器的 Boot.ini 文件中设置了 /PAE 启动开关
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_ComputerSystem Windows® Management Instrumentation (WMI) 类，以确定在 SystemStartupOptions 属性中设置的选项。Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定邮箱存储对象 (msExchPrivateMDB) 的 homeMDBBL 属性的个数。所得到的个数是在 Exchange Server 计算机上找到的邮箱数。

如果 Exchange Server 分析工具发现在 Exchange 服务器上的 boot.ini 文件中设置了 /PAE 启动开关，而该 Exchange 服务器包含的邮箱数少于 500 个，并且运行的是 Windows 2000 Server，则会显示警告。

物理地址扩展 (PAE) 使计算机可以访问超过 4 GB 的物理内存 (RAM)。Exchange Server 不支持 PAE。通过 PAE，Windows 可以访问超过 4 GB 的物理内存。Exchange Server 无法使用 4 GB 以上的物理内存，因此在专门运行 Exchange Server 的计算机上安装 4 GB 以上的 RAM 没有益处。如果 Boot.ini 文件中有 /PAE 启动开关，则将启用 PAE。

要解决此警告问题（仅限 Windows 2000），建议您将 /PAE 开关从 Boot.ini 文件中删除。

解决此警告问题

  1. 在 Windows 资源管理器中，导航至系统分区。这是存放硬件特定文件（如 Boot.ini 和 NTLDR）的分区。

  2. 如果看不到 Boot.ini 文件，则原因可能是"文件夹选项"已设置为"隐藏受保护的操作系统文件"。如果是这种情况，请在资源管理器窗口中，依次单击"工具"、"文件夹选项"、"查看"。单击"显示所有文件和文件夹"。清除"隐藏受保护的操作系统文件 (推荐)"复选框。出现提示时，单击"是"。

  3. 当 Boot.ini 文件显示在 Windows 资源管理器中后，用鼠标右键单击该文件，再单击"打开方式"，然后单击"记事本"打开该文件。

  4. 在 [Operating Systems] 部分中，删除 /PAE 开关。

  5. 保存并关闭该文件，并重新启动 Exchange Server 计算机，以使更改生效。

有关 Boot.ini 中的 /PAE 开关的详细信息，请参阅下列 Microsoft 知识库文章：

  • 268363: "Intel Physical Addressing Extensions (PAE) in Windows 2000"（英文）

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882: "Exchange Memory Use and the /3GB Switch"（英文）

    (http://support.microsoft.com/kb/328882/zh-cn)


此 Exchange 服务器在启用了物理地址扩展的情况下运行
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-05-08

Microsoft® Exchange Server 分析工具查询 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定下列关键字的值。

  • PAEEnabled 此关键字的值表明是否启用了物理地址扩展 (PAE)。值为 True 表明已启用 PAE，值为 False 表明未启用 PAE。

  • Version 此关键字的值表明计算机上运行的 Microsoft Windows 操作系统的版本。值为 5.0.2195 表明运行的是 Microsoft Windows 2000 Server 操作系统，值为 5.2.3790 表明运行的是 Microsoft Windows Server™ 2003 操作系统。

  • ServicePackMajorVersion 此关键字的值表明安装的 Windows Service Pack 的主要版本号。

Exchange Server 分析工具还在 CIM_Datafile WMI 类中查询系统上运行的 ntoskrnl.exe 的次要版本，以确定计算机上是否安装了安全更新 MS04-032。如果 ntoskrnl.exe 的次要版本小于等于 174，表明未安装 MS04-032。如果 ntoskrnl.exe 的次要版本大于 174，表明已安装 MS04-032。

如果 Exchange Server 分析工具发现对于在没有安装安全更新 MS04-032 的 Windows Server 2003 上运行的 Exchange Server，PAEEnabled 的值设置为 True，则会显示错误。此错误表明计算机易受一个已知问题的影响，该问题可导致 Microsoft Exchange 信息存储服务 (Store.exe) 崩溃。

Exchange Server 不使用 PAE。通过 PAE，Windows 可以访问超过 4 GB 的物理内存。Exchange Server 不能使用超过 4 GB 的物理内存，因此在专用于运行 Exchange Server 的计算机上安装超过 4 GB 的 RAM 没有任何益处。如果在启动时 Boot.ini 文件中包含 /PAE 启动开关，或 Windows Server 2003 操作系统检测到热添加的内存设备，则会启用 PAE。只有服务器正在使用热添加的内存设备时，Windows Server 2003 Enterprise Edition 和 Windows Server 2003 Datacenter Edition 才会自动启用 PAE。

通过安装 MS04-032 更新更正此错误

  1. 若要获取 MS04-032 更新，请参阅 Microsoft 知识库文章 840987"MS04-032：Microsoft Windows 安全更新"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=840987)。

  2. 完整备份系统。

  3. 应用更新，然后重新启动计算机以使更新生效。

有关 PAE 的详细信息，请参阅下列知识库文章：

  • 268363: "Intel Physical Addressing Extensions (PAE) in Windows 2000"（英文）

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882: "Exchange Memory Use and the /3GB Switch"（英文）

    (http://support.microsoft.com/kb/328882/zh-cn)

有关 Boot.ini 中的 /NOPAE 开关的详细信息，请参阅 MSDN 文章"/nopae"（英文）(http://go.microsoft.com/fwlink/?LinkId=51490)。


此 Exchange 服务器运行时启用了物理地址扩展并设置了 /3GB 启动开关
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 PAEEnabled 关键字的值。此关键字的值表明是否启用了物理地址扩展 (PAE)。值为 True 表明已启用 PAE，值为 False 表明未启用 PAE。Exchange Server 分析工具还查询 Win32_OperatingSystem WMI 类，以确定 MaxProcessMemorySize 关键字的值。

如果 Exchange Server 分析工具发现 PAEEnabled 的值等于 True 并且 MaxProcessMemorySize 的值大于 2097024，则显示警告。此警告表明这些值不是默认值。Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。

有关 PAE 的详细信息，请参阅下列 Microsoft 知识库文章：

  • 268363: "Intel Physical Addressing Extensions (PAE) in Windows 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882: "Exchange 2000 Server 内存使用和 /3GB 开关"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882)


该 Exchange 服务器使用 /PAE 和 /3GB 启动开关运行
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定在 SystemStartupOptions 关键字中设置的选项。Exchange Server 分析工具还查询 Win32_OperatingSystem WMI 类，以确定 MaxProcessMemorySize 关键字的值。

如果 Exchange Server 分析工具发现 SystemStartupOptions 关键字的值包含 /PAE，Win32_OperatingSystem 值指示 Microsoft Windows 2000 Server，并且 MaxProcessMemorySize 的值大于 2097024，则会显示错误。

该错误表明在 Boot.ini 文件中同时设置了 /PAE 和 /3GB 启动开关。物理地址扩展 (PAE) 使计算机可以访问超过 4 GB 的物理内存 (RAM)。Exchange Server 不支持 PAE。Exchange Server 不能使用超过 4 GB 的物理内存，因此在专用于运行 Exchange Server 的计算机上安装超过 4 GB 的 RAM 没有任何益处。如果启动时 Boot.ini 文件中有 /PAE 启动开关，则将启用 PAE。

要更正此错误（仅限 Windows 2000 Server），建议您将 /PAE 开关从 Boot.ini 文件中删除。

更正此错误

  1. 在 Windows 资源管理器中，导航到系统分区。这是存放硬件特定文件（如 Boot.ini 和 NTLDR）的分区。

  2. 如果看不到 Boot.ini 文件，则原因可能是"文件夹选项"已设置为"隐藏受保护的操作系统文件"。如果是这种情况，请在 Windows 资源管理器窗口中，依次单击"工具"、"文件夹选项"、"查看"。单击"显示所有文件和文件夹"。清除"隐藏受保护的操作系统文件 (推荐)"复选框。出现提示时，单击"是"。

  3. 当 Boot.ini 文件显示在 Windows 资源管理器中后，用鼠标右键单击该文件，再单击"打开方式"，然后单击"记事本"打开该文件。

  4. 在 [Operating Systems] 部分中，删除 /PAE 开关。

  5. 保存并关闭文件，然后重新启动 Exchange Server 计算机，以使更改生效。

有关 Boot.ini 中的 /PAE 开关的详细信息，请参阅下列 Microsoft 知识库文章：

  • 268363"Intel Physical Addressing Extensions (PAE) in Windows 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882"Exchange 2000 Server 内存使用和 /3GB 开关"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882)


此前端服务器配置了收件人更新服务
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定目录中每个 Recipient Update Service 对象的 msExchAddressListServiceLink 属性值。msExchAddressListServiceLink 属性是从地址列表服务到运行收件人更新服务 (RUS) 的 Exchange Server 计算机的链接。如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • Exchange Server 配置为前端服务器。

  • Exchange Server 计算机正在运行收件人更新服务。

收件人更新服务是 Exchange System Attendant 服务中的一个组件。收件人更新服务在 Active Directory 中创建并维护 Exchange 特有的属性值。如果为用户创建邮箱，收件人更新服务负责自动生成简单邮件传输协议 (SMTP) 地址以及在收件人策略中定义的任何其他代理地址。

如果配置为使用收件人更新服务的 Exchange Server 同时配置为前端服务器，收件人更新服务将不处理新创建的用户对象。结果是用户对象可能无法接收电子邮件，收件人不会显示在地址列表中。此外，不会处理对脱机通讯簿的更新。

如果收到此消息，收件人更新服务正在配置为前端服务器的 Exchange Server 上运行。

更正此错误

  1. 打开 Exchange 系统管理器。

  2. 在"收件人"下，单击"收件人更新服务"。在右侧窗格中，用鼠标右键单击合适的收件人更新服务实例，再单击"属性"。

  3. 在"常规"选项卡上的"Exchange Server"下，单击"浏览"，并指定要运行该 RUS 实例的新服务器。

  4. 单击"确定"，然后再次单击"确定"，以使更改生效。

有关收件人更新服务的详细信息，请参阅下列主题和 Microsoft 知识库文章：

  • 328738"How the Recipient Update Service applies recipient policies"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)。

  • 253828"How the Recipient Update Service Populates Address Lists"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)。

  • 246127"How to check the progress of the Exchange Recipient Update Service"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)。

  • 253770"XADM:Tasks Performed by the Recipient Update Service"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)。


注册表中的 Exchange 服务器名与 Active Directory 中的 Exchange 服务器名之间存在差异
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-12-03

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定存储在 Active Directory 中的 Exchange 服务器名 (CN=<ExchangeServerName>) 的值。检索此名称后，Exchange Server 分析工具计算该名称中的字符数。

Exchange Server 分析工具还读取以下注册表项，以确定存储在 Exchange Server 计算机注册表中的 Exchange 服务器主机名的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

另外，Exchange Server 分析工具还查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 ClusSvc（群集服务）的 Started 关键字的值。

如果 Exchange Server 分析工具确定满足下列所有条件，则会显示错误：

  • CN=<ExchangeServerName> 的值与 Hostname 的值不匹配。

  • Exchange 服务器名不超过 15 个字符。

  • Exchange 服务器未运行在 Windows 群集中。

此错误的最常见原因是 Exchange 服务器的名称已更改。以这种方式更改名称会更改计算机注册表中的名称，并且会更改 Active Directory 中的计算机帐户名，但不会更改在 Active Directory 中的 Exchange 属性和对象中找到的许多 Exchange 服务器名称引用。

注意：
一些第三方软件为了提供群集功能也更改计算机名。如果您使用了此类软件，可能不得不忽略此问题。

不支持重命名 Exchange Server 计算机，并且已确知此操作会导致问题，例如，在计算机名更改后，将无法启动 Microsoft Exchange 系统助理服务。如果重命名后的 Exchange Server 计算机的运行看起来不是完全正常，可以按照本文介绍的手动删除过程手动将 Exchange Server 从计算机中删除。如果重命名之后的 Exchange Server 计算机的运行看起来完全正常，应按照下面的重建过程重建 Exchange 服务器，因为这是不支持的配置，将来可能会导致问题。

通过执行 Exchange Server 的手动删除过程来更正此错误

  1. 停止所有 Exchange Server 服务并执行计算机的完整备份。

  2. 根据正在运行的 Exchange Server 版本，请参阅以下 Microsoft 知识库文章：

    • 如果运行的是 Exchange Server 2007，请按照 Exchange Server 2007 文档"How to Completely Remove Exchange 2007 from a Server"（如何从服务器中完全删除 Exchange 2007）(http://go.microsoft.com/fwlink/?LinkId=79246) 中介绍的过程执行操作。

    • 如果运行的是 Exchange Server 2003，请按照知识库文章"How to remove Exchange Server 2003 from your computer"（如何从计算机中删除 Exchange Server 2003）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833396) 中介绍的过程执行操作。

    • 如果运行的是 Exchange 2000 Server，请按照知识库文章 260378"如何手动删除 Exchange 2000 安装"(http://support.microsoft.com/?kbid=260378) 中介绍的过程执行操作。

  3. 如果运行的是 Exchange 2000 Server 或 Exchange Server 2003，且是组织中唯一的 Exchange 服务器，请按照知识库文章 273478"如何从 Active Directory 中完全删除 Exchange 2000"(http://support.microsoft.com/?kbid=273478) 中介绍的过程执行操作。

通过重建 Exchange Server 计算机来更正此错误

  1. 将邮箱、公用文件夹、连接器和角色移至组织中的另一台 Exchange Server 计算机上。

  2. 从计算机上卸载 Exchange Server。

  3. 若要清理运行 Exchange Server 2003 或 Exchange Server 2000 的计算机上的注册表，请按照下列 Microsoft 知识库文章中介绍的过程中注册表清理部分执行操作：

    • 833396"如何从计算机中删除 Exchange Server 2003"(http://support.microsoft.com/?kbid=833396)

    • 260378"如何手动删除 Exchange 2000 安装"(http://support.microsoft.com/kb/260378/zh-cn)

    或者，可以重建操作系统。

  4. 在计算机上安装 Exchange Server。

  5. 将邮箱、公用文件夹、连接器和角色移至新建的 Exchange Server 计算机上。

有关如何在群集上部署 Exchange Server 2003 的详细信息，请参阅 Microsoft 知识库文章 810986"Microsoft support policy for Exchange Server installations that are running with a third-party Cluster service"（运行第三方群集服务的 Exchange Server 安装的 Microsoft 支持策略）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=810986)。


Active Directory 中的 Exchange 服务器名存在差异
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-12-03

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定服务器（msExchExchangeServer 类的对象）的 Name 属性与 cn 属性是否匹配。如果 Exchange Server 分析工具发现这些属性之间存在差异，将显示错误消息。

Exchange 使用服务器对象的 cn 值在内部标识服务器，使用 Name 值在 Microsoft Exchange 系统管理器用户界面中标识该服务器。

如果管理员使用 Active Directory 服务接口 (ADSI) Edit 或 LDP (ldp.exe) 工具等工具更改了 Name 值，将出现此错误。虽然此操作更改用户界面中的服务器名，但会产生差异，从而导致生成存储事件和系统助理事件。必须使用 ADSI Edit 管理单元、LDP 工具或其他任何轻型目录访问协议 (LDAP) 版本 3 客户端等工具来更正该值。

警告：
在使用 ADSI Edit、LDP 工具或其他 LDAP 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003/Exchange Server 2007 才能解决。修改 Active Directory 对象的属性的风险由您自己承担。

更正此错误

  1. 使用 ADSI Edit 或类似工具在 Active Directory 中找到服务器对象。

    可以在以下位置找到 CN 和 Name 属性：

    复制代码
    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Servers,CN=Server

  2. 对于 Name 属性，请键入与 CN 属性的值匹配的新字符串值。

有关使用 LDP 工具的详细信息，请参阅 Microsoft 知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（使用 LDP 实用程序修改 Active Directory 对象属性）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

有关使用 ADSI Edit 的详细信息，请参阅 Windows Server 帮助中的主题"Adsiedit.msc:ADSI Edit"。


Active Directory 服务器与该 Exchange 服务器之间存在多个网络
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 root\cimv2 命名空间中的 WIN32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 类，以确定 RouteRecord 关键字的值。RouteRecord 关键字包含 Exchange 服务器与域控制器之间的中间跃点的记录（例如，路由器的数目）。Exchange Server 分析工具计数 RouteRecord 关键字中列出的路由器的数目。如果 Exchange Server 分析工具发现列出了多个路由器，则显示错误。

最佳的 Active Directory® 目录服务是这样一种服务：其设计确保 Exchange Server 计算机可与其子网中的域控制器或全局编录服务器通信。此错误意味着 Exchange Server 计算机正在与和它相距多个跃点的网络中的域控制器通信。

更正此错误

  1. 检查网络拓扑并重新评估 Active Directory 服务器的布置。

  2. 监视 Exchange Server 和域控制器上的事件日志，查看是否记录了任何意味着潜在问题的网络相关事件。

  3. 研究 Active Directory 站点的设计。如果网络未根据此规范进行划分，应考虑将网络划分成更多的 Active Directory 站点。

有关 Win32_PingStatus WMI 类的详细信息，请参阅 MSDN 文章"Win32_PingStatus"（英文）(http://go.microsoft.com/fwlink/?linkid=33549)。

有关 Active Directory 站点设计的详细信息，请参阅"Designing the Site Topology"（英文）(http://go.microsoft.com/fwlink/?linkid=33551)。


跃点太多
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-07-06

Microsoft® Exchange Server 分析工具会从 Exchange 服务器将测试邮件发送到简单邮件传输协议 (SMTP) 域的邮局主管帐户或用户定义的帐户，然后扫描服务器的邮件跟踪日志以确定测试邮件的传递过程中是否存在问题。

作为此扫描的一部分，Exchange Server 分析工具会针对该邮件传送到的每个服务器在 root\MicrosoftExchangeV2 命名空间下查询 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 类的 MessageID 属性。

邮件到达其最终目标之前，可能会通过许多不同的 SMTP 服务器进行路由。此路由上的每个服务器都称为一个"跃点"。

如果特定 MessageID 的Exchange_MessageTrackingEntry 实例增长到 30，则 Exchange Server 分析工具将显示一个错误。

此错误表明，测试邮件可能陷入了传递循环。因此，作为防止产生可能的无限循环情况的一种安全预防措施，Exchange Server 分析工具已停止查询其他 Exchange_MessageTrackingEntry 实例。

对 Exchange Server 分析工具输出的邮件跟踪日志部分所做的其他分析可能有助于您确定是否存在循环情况。


检测到不支持的虚拟机配置 - 群集 Exchange Server
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具查询 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Model 关键字的值是否设置为"Virtual Machine"。

Exchange Server 分析工具还查询 Win32_Service WMI 类，以确定 Windows Cluster 服务 (ClusSvc) 的 Started 关键字的值。Started 关键字的值为 True 意味着已启动群集服务，而 False 值意味着未启动群集服务。

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • Model 关键字的值设置为"Virtual Machine"。

  • 群集服务的 Started 关键字的值设置为 True。

该错误说明 Exchange 服务器是在虚拟机环境中运行的群集 Exchange 服务器。不支持该配置。

更正此错误

  1. 构建一个物理群集并将邮箱从在虚拟环境中运行的群集 Exchange 服务器中移至物理群集。

  2. 如果无法构建物理群集，则可以按照如下所示更正此错误：

    1. 将邮箱从在虚拟环境中运行的 Exchange Server 中移至单独的非虚拟 Exchange Server 计算机。

    2. 必要时重新放置所有公用文件夹，并转移群集 Exchange 服务器担任的所有角色。

    3. 从虚拟机中卸载 Exchange Server 以便不再使用它，并将它从 Exchange Server 基础结构和 Active Directory 中删除。

有关在虚拟环境中运行 Exchange Server 2003 的 Microsoft 支持策略的详细信息，请参阅 Microsoft 知识库文章 320220"Support policy for Exchange Server 2003 running on hardware virtualization software"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)。


不支持的虚拟机配置 - 未检测到 Exchange Server 2003 Service Pack 2 或更高版本
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具查询 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Model 关键字的值是否已设置为"Virtual Machine"。

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定 msExchExchangeServer 对象类中所有对象的 serialNumber 属性值。如果字符串值包括"Version 5.5"，则表示计算机运行的是 Exchange Server 5.5。如果字符串值包括"Version 6.0"，则表示计算机运行的是 Exchange 2000 Server。如果字符串值包括"Version 6.5"，则表示计算机运行的是 Exchange Server 2003。如果字符串值包括"Version 6.5"和"Service Pack 2"，则表示计算机运行的是带有 Service Pack 2 (SP2) 的 Exchange Server 2003。

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • Model 关键字设置为"Virtual Machine"。

  • 计算机未运行带有 SP2 或更高版本的 Exchange Server 2003。

此错误表明 Exchange 服务器是虚拟机，但未安装 Exchange Server 2003 SP2 或更高版本。不支持该配置。

更正此错误

  1. 为 Exchange Server 2003 安装 Service Pack 2 或更高版本。

  2. 参阅 Microsoft 知识库文章 320220"Support policy for Exchange Server 2003 running on hardware virtualization software"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)。

  3. 如果无法应用 Service Pack 2 或更高版本，则可以按照下列操作更正此错误：

    1. 将邮箱从运行 Virtual Server 2005 的 Exchange Server 移至非虚拟的 Exchange Server 计算机中。

    2. 根据需要重新配置所有公用文件夹并转移由虚拟 Exchange 服务器执行的所有角色。

    3. 从虚拟机中卸载 Exchange Server，从而将其从 Exchange Server 结构和 Active Directory 中禁用并删除。


不支持的虚拟机配置 - 未检测到虚拟机的添加操作
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具查询 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Model 关键字的值是否设置为"Virtual Machine"。

Exchange Server 分析工具还读取以下注册表项，以确定是否已安装虚拟机的添加操作：

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

如果存在上述注册表路径，则指示已安装了虚拟机的添加操作。如果此注册表路径不存在，则指示尚未安装虚拟机的添加操作。

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • Model 关键字的值设置为"Virtual Machine"。

  • 此注册表路径不存在。

此错误指示 Exchange 服务器是虚拟机，但是未安装虚拟机的添加操作。不支持该配置。

若要安装虚拟机的添加操作，请执行下列操作：

  1. 备份在虚拟环境中运行的 Exchange Server。

  2. 使用 Virtual Server 2005 管理控制台或通过网站安装虚拟机的添加操作。

有关如何在虚拟环境中运行 Exchange Server 2003 的详细信息，请参阅 Microsoft 知识库文章 320220"Support policy for Exchange Server 2003 running on hardware virtualization software"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)。


更新可用夏令时
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-07-30

Microsoft Exchange 分析工具查询 Active Directory 目录服务，以确定每个 Exchange Server 对象的 versionNumber 属性值。versionNumber 属性表示运行在计算机上的 Exchange Server 的版本。

Exchange 分析工具还查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Store.exe 进程的 Version 关键字的值。

  • Version 关键字的值 7638 表示 Exchange Server 2003 Service Pack 2

  • Version 关键字的值 7226 表示 Exchange Server 2003 Service Pack 1

  • Version 关键字的值 6944 表示 Exchange Server 2003 的最初发行版

  • 介于上述版本之间的值表示服务器运行的是 Store.exe 进程的修复程序更新版。

如果 Exchange 分析工具确定一台运行 Exchange Server 2003 SP2 的服务器上 Store.exe 的 Version 关键字值小于 7561，或一台运行 Exchange Server 2003 SP1 的服务器上其值小于 7234，就会显示警告。

该警告表示 Exchange Server 计算机正在运行 Exchange Server 2003 Service Pack 1 或 Exchange Server 2003 SP2，而未按 2007 年的夏令时进行更新。

如果没有此更新，那么在基于 CDO 程序中的日历项目和在 Outlook Web Access 中的日历项目会在夏令时以外的额外周中使用标准时间。

在 Exchange Server 2003 SP2 中更正此问题

  1. 按照 Microsoft 知识库文章 926666"针对 Exchange 2003 Service Pack 2 更新 2007 年夏令时"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=926666)中的指导操作。
在 Exchange Server 2003 SP1 中更正此问题

  1. 按照 Microsoft 知识库文章 931978"针对 Exchange 2003 Service Pack 1 更新 2007 年夏令时"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=931978)中的指导操作。


未安装 Windows 2000 SP4 的更新汇总
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Microsoft Windows® Management Instrumentation (WMI) 类，以确定 ServicePackMajorVersion 关键字的值。Exchange Server 分析工具还检查以下注册表项，以确定目标计算机上运行的 Windows 的版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

如果 Exchange Server 分析工具确定目标系统运行的是 Windows 2000 Server 操作系统，但未运行 Windows 2000 Server Service Pack 4 的更新汇总，则显示警告。

建议在 Exchange 部署环境中安装所有软件的最新 Service Pack 和更新汇总，这是最佳实践。

解决此警告问题

  1. 将运行 Windows 2000 Server 的所有域控制器和全局编录服务器更新到 Service Pack 4 的更新汇总，并安装通过 Windows Update 获取的最新修补程序和更新。

  2. 将所有 Exchange Server 计算机更新到最新的汇总和更新汇总。

有关 Windows 2000 SP4 的更新汇总的详细信息，请参阅 Microsoft 知识库文章 891861"Windows 2000 SP4 的累积更新 1"(http://support.microsoft.com/?kbid=891861)。

有关如何获取和安装 Exchange Server Service Pack 和更新汇总的详细信息，请访问 Exchange Server 网站 (http://go.microsoft.com/fwlink/?LinkId=21573)。


URLScan 已安装
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-04-20

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange 服务器的以下位置中是否具有以下文件：

%WINDOWSPATH%\\SYSTEM32\\INETSRV\URLSCAN\URLSCAN.DLL

如果 Urlscan.dll 存在，表明 URLScan 工具已安装在 Exchange 服务器上。如果 Exchange Server 分析工具发现 Exchange 服务器上已安装有 URLScan 工具，则显示最佳做法建议。

URLScan 是一个 Internet 服务器应用程序编程接口 (ISAPI) 筛选器，使网站管理员可以限制服务器处理的 HTTP 请求类型。通过阻止特定的 HTTP 请求，URLScan 筛选器可以避免可能有害的请求提交到服务器并造成损坏。

在 Exchange 服务器上运行 URLScan 时，应确保 Urlscan.ini 已针对 Exchange 服务器的角色进行调整。若要帮助提高 Exchange 服务器的安全性，必须编辑 Urlscan.ini 配置文件，以删除所有多余的功能。若要针对特定的 Exchange Server 2003 计算机角色自定义 Urlscan.ini 文件，必须删除 Urlscan.ini 文件的 [AllowVerbs] 部分中的谓词。但是，应确保包含计算机角色建议的谓词，以便实现相应的功能。如果一台计算机上需要多项基于 Web 的功能，必须合并 [AllowVerbs] 部分中相应的要求。

可以使用 Exchange Server 2003 Urlscan 模板中的信息，根据 Exchange Server 2003 计算机的角色修改 Urlscan.ini 文件，有关该模板的信息，请参阅 Microsoft 知识库文章 823175"Fine-tuning and known issues when you use the Urlscan utility in an Exchange 2003 environment"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823175)。

有关 URLScan 的详细信息，请参阅"UrlScan Security Tool"（英文）(http://go.microsoft.com/fwlink/?LinkId=24490)。

有关在 Exchange Server 环境中使用 URLScan 的详细信息，请参阅下列 Microsoft 知识库文章：

  • 309677"XADM:Known Issues and Fine Tuning When You Use the IIS Lockdown Wizard in an Exchange 2000 Environment"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=309677)

  • 309508"Exchange 环境中的 IIS 锁定和 URLscan 配置"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=309508)

  • 325965"The URLScan tool may cause problems in Outlook Web Access"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325965)

  • 326444"How to：配置 URLScan 工具"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=326444)


USERVA 未正确设置
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-09-19

Microsoft® Exchange Server 分析工具查询三个 Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange Server 计算机中的物理内存量以及分配给运行在 Exchange Server 计算机上的用户模式进程的虚拟地址空间量。下表描述了 Exchange Server 分析工具所评估的类和关键字。

查询的类 | 查询的关键字 | 描述
Win32_OperatingSystem | MaxProcessMemorySize | 可以分配给进程的最大内存 KB 数。
Win32_ComputerSystem | TotalPhysicalMemory | 计算机上安装的随机访问内存 (RAM) 的字节数。
Win32_Service | Started | 服务的状态。值为 True 意味着服务在运行，值为 False 意味着服务未运行。

Exchange Server 分析工具还读取以下注册表项，以确定在 Exchange Server 计算机上运行的 Microsoft Windows 的版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 值为 4.0 意味着 Exchange Server 计算机运行的是 Microsoft Windows NT® Server 4.0。值为 5.0 说明 Exchange Server 计算机正在运行 Windows 2000 Server，值为 5.2 说明 Exchange Server 计算机正在运行 Windows Server™ 2003。

最后，Exchange Server 分析工具查询 Active Directory® 目录服务，以确定邮箱存储对象 (msExchPrivateMDB) 的 homeMDBBL 属性的个数。所得到的个数是在 Exchange Server 计算机上找到的邮箱数。

如果 Exchange Server 分析工具确定满足下列所有条件，则会显示警告：

  • Exchange Server 计算机运行的是 Windows Server 2003。

  • TotalPhysicalMemory 的值大于 1073741824。

  • MaxProcessMemorySize 的值等于 3145600。

  • 群集服务 (ClusSvc) 的 Win32_Service\Started 值为 True，或者 Exchange Server 计算机包含 20 个以上的邮箱。

此警告意味着 Exchange Server 计算机未进行相应的配置以实现最佳虚拟内存使用。具体地说，Exchange Server 计算机的 Boot.ini 文件中不存在 /USERVA=3030 启动开关。添加此开关有助于提高可伸缩性和性能。

Windows Server 2003 支持两个 Boot.ini 启动开关：/3GB 和 /USERVA。这两个开关可用于调整内存及内存地址空间的分配和使用。无论系统中的物理内存为多少，Windows 都使用 4 GB 的虚拟地址空间，其中 2 GB 分配给用户模式进程（例如，应用程序），余下的 2 GB 分配给内核模式进程（例如，操作系统和内核模式驱动程序）。在物理内存不低于 1 GB 的系统上，这两个启动开关可用于为应用程序分配更多内存 (3 GB)，为操作系统分配较少的内存 (1 GB)。在 Exchange Server 计算机上，此额外的虚拟地址空间有助于减少信息存储进程的虚拟地址空间中的内存碎片。/3GB 开关用于实现内存分配上的这一更改。在系统的 Boot.ini 文件中输入此开关，并将在系统重新启动后生效。此开关应当只用在运行下列任意操作系统并且内存不低于 1 GB 的 Exchange Server 上：

  • Microsoft Windows Server 2003 标准版

  • Microsoft Windows Server 2003 企业版

  • Microsoft Windows Server 2003 Datacenter 版

重要信息：
/3GB 开关不应当用在 Windows 2000 Server 上，因为它不被支持，并且可能导致应用程序或操作系统崩溃。此外，只有在安装了 1 GB 或更多物理内存时，上述操作系统才支持 /3GB 开关。此外，/3GB 开关不应当用在 Windows Server 2003 标准版上运行的 Active Directory 服务器（域控制器和全局编录服务器）上。

/USERVA 开关是 Windows Server 2003 中新增加的，其用途是更精确地控制虚拟地址空间在用户模式进程与内核模式进程之间的划分。此开关应仅仅用于支持它的应用程序（如 Exchange Server 2003），并应与这些应用程序支持的特定值一起使用。当用在 Exchange Server 2003 系统上时，/USERVA 应始终等于 3030（即 /USERVA=3030）。该值会导致为操作系统额外分配 40 MB，并使您可以在不消耗所有可用系统资源的情况下添加更多用户。

在 Windows Server 2003 上解决此警告问题

  1. 用鼠标右键单击"我的电脑"，然后选择"属性"。将出现"系统属性"对话框。

  2. 单击"高级"选项卡。

  3. 在"启动和故障恢复"区域中，单击"设置"。将出现"启动和故障恢复"对话框。

  4. 在"系统启动"区域中，单击"编辑"。这将在记事本中打开 Windows Boot.ini 文件。

  5. 在 [Operating Systems] 部分中，将以下开关添加到启动命令行：/3GB /USERVA=3030

  6. 保存更改，关闭记事本。

  7. 单击"确定"两次关闭打开的对话框，然后重新启动 Exchange Server 计算机，以使更改生效。

有关使用 /3GB 和 /USERVA 启动开关的详细信息，请参阅下列 Microsoft 知识库文章：

  • 297812"How to Use the 4GT RAM Tuning Feature"（如何使用 4GT RAM 调节功能）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)。

  • 311901"The effects of 4GT tuning on system Page Table Entries"（4GT 调节对系统页表项的影响）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)。

  • 316739"How to use the /userva switch with the /3GB switch to tune the User-mode space to a value between 2 GB and 3 GB"（如何同时使用 /userva 开关和 /3GB 开关将用户模式空间调节到 2 GB 和 3 GB 之间的值）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)。

  • 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://support.microsoft.com/kb/325044/zh-cn)。

  • 815372"如何在 Exchange Server 2003 中优化内存使用"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)。


此计算机上安装的 Tcpip.sys 文件的版本可能需要安装修补程序
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定为 Tcpip.sys 文件的 Version 关键字设置的值。如果 Exchange Server 分析工具发现 Version 关键字的值对应于 Tcpip.sys 文件的特定版本，Exchange Server 分析工具将显示警告。

有关此警告的详细信息，请遵循 Microsoft 知识库文章 898060"安装安全更新 MS05-019 或 Windows Server 2003 Service Pack 1 可能导致客户端和服务器之间的网络连接失败"(http://support.microsoft.com/kb/898060/zh-cn) 中的建议。


检测到虚拟计算机配置
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具查询 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定是否将 Model 关键字的值设置为"Virtual Machine"。

Exchange Server 分析工具还查询 Win32_Service WMI 类，以确定 Windows 群集服务 ClusSvc 的 Started 关键字的值。Started 关键字的值为 True，则表明群集服务已启动。值为 False 则表明群集服务未启动。

Exchange Server 分析工具查询 Active Directory® 目录服务，以确定具有对象类 msExchExchangeServer 的所有对象的 serialNumber 属性值。如果字符串值包含"Version 6.5"和"Service Pack 2"，表明计算机运行的是 Exchange Server 2003 Service Pack 2 (SP2)。

最后，Exchange Server 分析工具读取以下注册表项，以确定是否安装了虚拟计算机附加项：

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

存在此注册表路径表明已安装了虚拟计算机附加项。不存在此注册表路径表明未安装虚拟计算机附加项。

如果符合下列条件，Exchange Server 分析工具将显示最佳实践消息：

  • Exchange 服务器以来宾身份运行 Microsoft Virtual Server 2005。

  • Exchange 服务器运行的是 Exchange Server 2003 Service Pack 2 或更高版本。

  • Exchange 服务器不在群集中。

  • Virtual Server 2005 虚拟计算机附加项已安装在 Exchange 服务器上。

要在这个 Exchange Server 分析工具无法检测到的配置中运行，需要满足一些要求。因此，我们建议您在 Virtual Server 2005 环境中运行 Exchange Server 2003 之前参阅下列文章，了解有关此配置的支持能力和性能调优的最新信息。

Microsoft 知识库文章 320220"Support policy for Exchange Server 2003 running on hardware virtualization software"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)。


虚拟内存已碎片化
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2007-02-15

Microsoft Exchange 分析工具查询 Win32_NTLogEvent Microsoft Windows Management Instrumentation (WMI) 类，以确定是否在过去 24 小时内记录了 MSExchangeIS 的事件 9582 错误。

如果 Exchange 分析工具发现在过去 24 小时内记录了事件 9582，Exchange 分析工具将显示错误。

此错误表明运行 Exchange 服务器所需的虚拟内存已碎片化。

在 32 位 Microsoft Windows 系统中，有两类内存：

  • 物理内存 系统中安装的实际内存量

  • 虚拟内存地址空间 虚拟化 4GB 内存空间

无论系统上安装多少物理内存，总的虚拟地址空间大小始终相同：4 GB。对于 Exchange Server 而言，虚拟地址空间等于虚拟内存，这两个词可以互换。但这并不适用于所有 32 位的应用程序。

在常规的操作过程中，Exchange 存储反复地分配、使用和释放虚拟内存。当频繁地分配、使用和释放虚拟内存时，会导致虚拟内存碎片。虚拟内存碎片类似于在一段时间后出现的文件系统碎片。经过一段时间后，分配的虚拟内存段将不再是连续的，因此性能开始下降。在文件系统中，可以运行执行文件系统碎片整理的应用程序。大多数情况下，可以在系统联机和被访问的情况下完成文件系统碎片整理。还没有任何针对虚拟内存碎片的碎片整理工具。要解决该问题，必须停止并启动 Microsoft Exchange 信息存储服务或重新启动系统。

若要解决该问题，请执行下列操作：

  • store/inetinfo 进程中运行的第三方软件可能会造成虚拟内存碎片。确保拥有任何第三方应用程序最新的驱动程序。

  • 使用"性能日志和警报"工具监视 MSExchangeIS 性能对象的 VM Total Large Free Block Bytes 计数器。使用通过此计数器收集的数据确定关闭并重新启动服务器的最佳时间窗（在接下来的 36 到 72 个小时内）。

注意：
如果是群集服务器，则先停止并重新启动被动节点，然后再将群集资源转移到该节点，以确保目标虚拟内存地址空间是干净的。
  • 如果重新启动后仍出现该问题，请考虑禁用第三方软件。

  • 还可以考虑将用户邮箱转移到其他服务器以减少服务器负载，看问题是否不再出现。有关详细信息，请参阅将用户邮箱移至其他服务器。

详细信息

  • 有关 MSExchangeIS 事件 9852 的详细信息，请参阅"Events and Errors Message Center:Event Details（事件和错误消息中心：事件详细信息）"(http://go.microsoft.com/fwlink/?LinkId=83209)。

  • 有关 Exchange Server 性能的详细信息，请参阅 Performance and Scalability Guide for Exchange Server 2003（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关如何解决 Exchange Server 性能问题的详细信息，请参阅 Troubleshooting Microsoft Exchange Server 2003 Performance（解决 Microsoft Exchange Server 2003 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关如何解决 Microsoft Exchange Server 2003 和 Exchange 2000 Server 中的虚拟内存碎片问题的详细信息，请参阅 Microsoft 知识库文章 325044"如何解决 Exchange Server 2003 和 Exchange 2000 Server 中的虚拟内存碎片问题"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)。

  • 有关如何优化虚拟内存使用的详细信息，请参阅 Microsoft 知识库文章 815372"如何优化 Exchange Server 2003 中的内存使用"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)。

  • 有关如何移动用户邮箱以降低服务器负载的详细信息，请参阅将用户邮箱移至其他服务器。


未检测到 Virtual Server 2005 R2 或更高版本
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Vssrvc.exe（Microsoft Virtual Server 2005 提供的 Virtual Server 服务所代表的进程）的 Version 关键字的值。如果 Exchange Server 分析工具发现 Vssrvc.exe 的 Version 关键字的值等于 1.1.465.0，Exchange Server 分析工具将显示错误。

此错误表明该 Exchange 服务器在未运行 Virtual Server 2005 R2 或更高版本的 Microsoft Virtual Server 2005 环境中以来宾身份运行。不支持此配置。只有运行 Microsoft Virtual Server 2005 R2 或更高版本的虚拟环境中支持以来宾身份运行 Exchange Server 2003 Service Pack 2 或更高版本。

更正此错误

  1. 请参阅 Microsoft 知识库文章 320220"Support policy for Exchange Server 2003 running on hardware virtualization software"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)。

  2. 安装 Microsoft Virtual Server 2005 R2 或更高版本。有关 Microsoft Virtual Server 2005 R2 的信息，请访问 Microsoft Virtual Server 2005 R2 网站 (http://go.microsoft.com/fwlink/?LinkId=34938)。

  3. 如果无法安装 Virtual Server 2005 R2 或更高版本，可以如下所述纠正此错误：

    1. 将邮箱从运行 Virtual Server 2005 的 Exchange Server 移动到非虚拟 Exchange Server 计算机或运行 Virtual Server 2005 R2 的虚拟 Exchange Server 计算机。

    2. 重新连接所有公用文件夹，并根据需要转移不支持的虚拟 Exchange 服务器执行的任何角色。

    3. 将 Exchange Server 从不支持的虚拟计算机中卸载以便不再使用它，并将它从 Exchange Server 基础结构及 Active Directory 中删除。


Virus Scan queue length 超出阈值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-02-27

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 MSExchangeIS 性能对象的 Virus Scan Queue Length 性能计数器收集数据，以分析性能数据。

如果 Exchange Server 分析工具确定 Virus Scan Queue Length 计数器的第九十百分位的值在示例时间段大于 10，则将显示一个错误信息。

Virus Scan Queue Length 性能计数器显示列队等待病毒扫描的、当前未完成的请求数。

该错误表示存在与下列各项有关的性能问题：

  • 服务器性能下降，通常由 CPU 瓶颈导致。

  • 服务器负载高于平时。

  • 病毒扫描引擎过时。

  • 病毒扫描引擎配置不当。

若要解决该问题，请采取下列步骤：

  • 寻找病毒引擎的更新。

  • 考虑重新安装病毒扫描软件。

  • 检查病毒扫描引擎的配置是否具有正确的线程配置、文件级别排除项等内容。请参阅 Microsoft 知识库文章 823166"Exchange Server 2003 和防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)。

  • 使用性能监视器 (Perfmon.msc) 工具确定瓶颈是否是由服务器上不断增长的负载所造成的，或者确定瓶颈是否是由服务器不够大而造成的。如果服务器负载增加，请识别负载的来源并降低它。如果服务器没有足够的资源，请增加必要的资源或将用户从服务器上移开。

消除处理器瓶颈

可以通过许多方式消除 Exchange 服务器的处理器瓶颈。

  • 第一，检查在服务器中导致负载的应用程序和任务。确定该应用程序是否正在占用处理器时间；或者确定进程是否存在问题。

  • 如果某个非 Exchange 应用程序对于该服务器并不重要，则应在其他服务器上运行该应用程序。如果可以在其他服务器上运行该应用程序，则也要将服务器角色转移给其他计算机。例如，如果 Inetinfo 进程占用了大量 CPU 利用率，请考虑增加前端服务器，以承担 Inetinfo 执行的协议工作责任。也可以将公用文件夹存取转移到专用的公用文件夹服务器。最后，如果服务器执行大量通讯组列表扩展，则可以通过将通讯组列表扩展转移到专用的通讯组列表扩展服务器，来降低 CPU 利用率。

  • 如果可能的话，请为服务器添加更多或速度更快的处理器。此外，如果处理器支持，应启用超线程。可以通过配置系统 BIOS 来启用超线程。有关详细信息，请参阅计算机制造商的帮助文档。

  • 如果增加处理能力不可行，则必须降低处理器的负载。为了降低负载对服务器的总体影响，请务必在正常工作时间以外执行 I/O 密集型、CPU 密集型或占用内存型的任务。

  • 请务必使 CPU 密集型任务（如备份和维护）在非高峰时段进行，同时确保这些任务以分阶段的方式执行。将任务分阶段意味着为每个任务设置不同的开始时间，同时最好也设置不同的结束时间。分阶段维护和备份数据库或存储组还可以减小这些资源密集型任务产生的影响。

详细信息

  • 有关 Exchange Server 和病毒扫描的概述，请参阅 Microsoft 知识库文章 823166"Exchange Server 2003 与防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)。

  • 有关病毒扫描和 Exchange Server 的详细信息，请参阅 Microsoft 知识库文章 285667"XADM: Understanding Virus Scanning API 2.0 in Exchange 2000 Server SP1"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=285667)。

  • 有关处理器瓶颈的详细信息，请参阅处理器瓶颈。

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关如何移动用户邮箱以降低服务器负载的详细信息，请参阅将用户邮箱移至其他服务器。


Virus Scan queue length 超出警告阈值
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-04-20

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 MSExchangeIS 性能对象的 Virus Scan Queue Length 性能计数器收集数据，以分析性能数据。

如果 Exchange Server 分析工具确定 Virus Scan Queue Length 计数器的第九十百分位的值在示例时间段大于 5，则将显示警告信息。

Virus Scan Queue Length 性能计数器显示列队等待病毒扫描的、当前未完成的请求数。

该警告表示对于此服务器来说，性能已成为一个问题。性能问题可能与下列各项有关：

  • 服务器性能下降，通常由新出现的 CPU 瓶颈导致。

  • 服务器负载高于平时。

  • 病毒扫描引擎过时。

  • 病毒扫描引擎配置不当。

若要解决该警告，请采取下列步骤：

  • 寻找病毒引擎的更新。

  • 考虑重新安装病毒扫描软件。

  • 检查病毒扫描引擎的配置是否具有正确的线程配置、文件级别排除项等内容。请参阅 Microsoft 知识库文章 823166"Exchange Server 2003 和防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)。

  • 使用性能监视器 (Perfmon.msc) 工具识别新出现的瓶颈是否是由服务器上不断增长的负载所导致的，或者确定瓶颈是否是由服务器不够大而导致的。如果服务器负载增加，请识别导致负载的源并降低它。如果服务器没有足够的资源，请增加必要的资源或将用户从服务器上移开。

消除处理器瓶颈

可以通过许多方式解决 Exchange 服务器的处理器瓶颈。

  • 第一，检查在服务器中导致负载的应用程序和任务。确定该应用程序是否正在占用处理器时间；或者确定进程是否存在问题。

  • 如果某个非 Exchange 应用程序对于该服务器并不重要，则应在其他服务器上运行该应用程序。如果可行，也要将服务器角色转移到其他计算机。例如，如果 Inetinfo 进程占用了大量 CPU 利用率，请考虑增加前端服务器，以承担 Inetinfo 执行的协议工作责任。也可以将公用文件夹存取转移到专用的公用文件夹服务器。最后，如果服务器执行大量通讯组列表扩展，则可以通过将通讯组列表扩展转移到专用的通讯组列表扩展服务器，来降低 CPU 利用率。

  • 如果可能的话，请为服务器添加更多或速度更快的处理器。此外，如果处理器支持，应启用超线程。可以通过配置系统 BIOS 来启用超线程。有关详细信息，请参阅计算机制造商的帮助文档。

  • 如果增加处理能力不可行，则必须降低处理器的负载。为了降低负载对服务器的总体影响，请务必在正常工作时间以外执行 I/O 密集型、CPU 密集型或占用内存型的任务。

  • 确保在非高峰期执行 CPU 密集型任务（例如备份任务和维护任务）。此外，确保分阶段执行这些任务。分阶段执行任务意味着为每个任务设置不同的开始时间，同时最好设置不同的结束时间。分阶段维护和备份数据库或存储组还可以减小这些资源密集型任务产生的影响。

详细信息

  • 有关 Exchange Server 和病毒扫描的概述，请参阅 Microsoft 知识库文章 823166"Exchange Server 2003 与防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)。

  • 有关病毒扫描和 Exchange Server 的详细信息，请参阅 Microsoft 知识库文章 285667"XADM: Understanding Virus Scanning API 2.0 in Exchange 2000 Server SP1"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=285667)。

  • 有关处理器瓶颈的详细信息，请参阅处理器瓶颈。

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关如何移动用户邮箱以降低服务器负载的详细信息，请参阅将用户邮箱移至其他服务器。


卷装入点失败：未安装 Windows Server 2003 SP1
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2006-02-13

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Windows® Management Instrumentation (WMI) 类，以验证 Mountmgr.sys 驱动程序是否存在。

Exchange Server 分析工具读取以下注册表值，以确定 Exchange 服务器上运行的 Microsoft Windows® 操作系统的版本： HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

如果 CurrentVersion 值等于 5.0，则 Exchange 服务器运行在 Microsoft Windows 2000 Server 上。如果 CurrentVersion 值为 5.2，则 Exchange 服务器运行在 Microsoft Windows Server™ 2003 上。

Exchange Server 分析工具还查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定群集服务 (ClusSvc) 的 Started 关键字的值。值为 TRUE 说明群集服务已启动，值为 FALSE 说明群集服务未运行。

如果下列条件为真，则 Exchange Server 分析工具将显示警告：

  • Exchange Server 计算机运行的是 Windows Server 2003。

  • 未安装 Windows Server 2003 SP1。

  • Exchange Server 运行在群集环境中。

  • 存在卷装入点。

此警告表示如果 Exchange 群集节点环境已更新为 Windows Server 2003 SP1，则需要以下部分中引用的更新。如果没有此更新，则在更新后可能会发生卷装入点失败。

解决此警告问题

  • 应用在 Microsoft 知识库文章 898790"Volume mount points on disks in a server cluster may intermittently become unavailable after you install Windows Server 2003 Service Pack 1"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790) 中引用的更新。


在 Exchange Server 上启用 Windows 防火墙服务
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Windows 防火墙服务 (SharedAccess) 的 Started 关键字的值。值为 True 说明在此 Exchange 服务器上启用了 Windows 防火墙服务。

如果 Exchange Server 分析工具确定在 Exchange Server 计算机上启用了 Windows 防火墙服务，则显示警告。如果启用了 Windows 防火墙服务，可能会出现下列问题：

  • 有些 Exchange Server 组件（例如邮件跟踪服务或远程过程调用 (RPC) 通信）可能会停止响应。

  • 可能会出现错误消息，表明可用内存不足。

默认情况下，在应用 Microsoft Windows Server™ 2003 Service Pack 1 (SP1) 后将停止 Windows 防火墙服务。但是，如果符合下列任意条件，服务会自动设置为运行：

  • 管理员手动启用 Windows 防火墙服务。

  • 在运行安全配置向导之后启用 Windows 防火墙服务。

解决此警告问题

  • 检查排除的程序。

  • 检查排除的端口。

  • 如果客户端无法连接到 Exchange 服务器上，请检查防火墙异常。

  • 在防火墙中手动打开端口，使 Exchange 系统管理器和 Microsoft Exchange 管理员可以运行。在 Windows 防火墙服务中打开端口后，会提高其他程序通过这些端口访问您的计算机的机率。在 Windows 防火墙服务中打开端口之前，请认真考虑网络安全要求。

  • 停止 Windows 防火墙服务。


Windows Management Instrumentation 服务未作为 LocalSystem 运行
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 ObjectName 值的数值数据：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winmgmt

此注册表分支中的 ObjectName 值表明 Microsoft Windows® Management Instrumentation (WMI) 服务（称为 Winmgmt 服务）的服务帐户设置。如果 Exchange Server 分析工具发现 ObjectName 的数值数据不等于 LocalSystem，则会显示错误。

该错误说明 WMI 服务未在支持的配置中运行。如果运行 WMI 服务的帐户不是 LocalSystem 帐户，则可能造成权限错误和访问错误。

若要解决该错误，必须将 WMI 服务配置为在 LocalSystem (SYSTEM) 帐户下启动。

配置 WMI 服务帐户

  1. 打开"服务"Microsoft 管理控制台 (MMC) 管理单元。

  2. 找到并停止 Windows Management Instrumentation 服务。

  3. 双击 Windows Management Instrumentation 服务。

  4. 在"Windows Management Instrumentation 属性"页的"登录"选项卡上，在"登录作为"下选择"本地系统帐户"，再单击"应用"。

  5. 在"服务状态"下，单击"启动"，再单击"确定"。

  6. 关闭"服务"管理单元。


Windows Server 2003 SP1：要求安装 Outlook Web Access 修补程序
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询各种 Microsoft Windows® Management Instrumentation (WMI) 类，以收集下列信息：

  • Exchange Server 安装在哪个版本的 Microsoft Windows Server 操作系统上？

  • Exchange Server 是运行在群集上吗？

如果确定下列条件为真，Exchange Server 分析工具将显示错误：

  • 安装了 Exchange Server 2003 Service Pack 1 (SP1)。

  • 安装了 Microsoft Windows Server™ 2003 Service Pack 1 (SP1)。

  • 群集服务正在运行。

  • Davex.dll 的 Version 值低于 6.5.7232。

如果运行的是该配置，则在安装 Windows Server 2003 SP1 之前必须下载并安装 Exchange Server 修补程序。如果不安装 Exchange Server 修补程序，Microsoft Office Outlook® Web Access for Exchange Server 2003 用户将无法登录到自己的邮箱。对于拥有驻留在群集上的邮箱的用户，在尝试使用 Outlook Web Access 进行连接时，将收到以下错误消息：

  • "500 - 内部服务器错误"

该错误是由 Windows Server 2003 SP1 附带的一些安全性增强功能所导致的。

用户尝试使用 Outlook Web Access 登录到邮箱时，HTTP 会模拟登录用户向群集 API 提交请求。但是，Windows Server 2003 SP1 中已更改了某些安全功能。对于执行远程注册表访问的 API 的安全限制已更改。因此，登录尝试没有成功。

要解决该错误，必须下载并安装 Exchange Server 修补程序，Microsoft 知识库文章 841561""500 - Internal server error" error message when a user tries to access a clustered Exchange Server 2003 back-end server by using Outlook Web Access"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841561) 描述了该修补程序。


检测到 Windows Server 2003 SP1 安全配置向导
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表值，以确定 Exchange 服务器上运行的 Microsoft Windows® 操作系统的版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

如果 CurrentVersion 值等于 5.0，则 Exchange 服务器运行在 Microsoft Windows 2000 Server 上。如果 CurrentVersion 值为 5.2，则 Exchange 服务器运行在 Microsoft Windows Server™ 2003 上。

此外，Exchange Server 分析工具还读取以下注册表值，以确定 Windows Program Files 目录的路径：

HKLM\Software\Microsoft\Windows\CurrentVersion\ProgramFilesDir

然后，Exchange Server 分析工具检查 Windows Program Files 目录，以确定 Windows Program Files 目录是否包含用于 Exchange Server 的 \Exchsrvr 文件夹。

最后，Exchange Server 分析工具查询 Win32_OperatingSystem Windows Management Instrumentation (WMI) 类，以确定 ServicePackMajorVersion 关键字的值。ServicePackMajorVersion 关键字值指明计算机上安装的是哪个 Windows Service Pack。

如果下列条件为真，则 Exchange Server 分析工具将显示警告：

  • Exchange Server 分析工具确定 Exchange Server 计算机运行的是 Windows Server 2003 Service Pack 1。

  • Exchange Server 分析工具确定 Exchange Server 2003 未安装在默认路径 \Program Files\Exchsrvr 下。

该警告指出，Exchange Server 2003 未安装在服务器上默认的 Program Files 文件夹中，Exchange 服务器上安装了安全配置向导。安全配置向导是一种工具，作为可选组件包括在 Windows Server 2003 Service Pack 1 中。如果 Exchange 服务器上安装了安全配置向导，那么需要手动配置"网络安全性"部分。

注意：
若要安装安全配置向导，必须先安装 Windows Server 2003 Service Pack 1。安装了 Service Pack 1 之后，在"控制面板"中打开"添加/删除程序"安装安全配置向导。

安全配置向导有助于减小 Windows 服务器遭受攻击的范围，方法是向用户提出一系列问题，以此确定对服务器的功能要求。具体地说，安全配置向导可帮助您执行以下任务：

  • 自动禁用不需要的服务。

  • 自动阻止未使用的端口。

  • 帮助您针对开放的端口应用其他地址限制或安全限制。

  • 防止不需要的 Internet 信息服务 (IIS) Web 扩展（如果可行）。

  • 降低协议对服务器消息块 (SMB)、LanMan 以及轻型目录访问协议 (LDAP) 的暴露程度。

  • 定义高级信噪审核策略。

安全配置向导将指导您完成创建、编辑、应用或回滚安全策略的整个过程，该策略基于所选的服务器角色。在应用时，使用安全配置向导创建的安全策略是用于配置服务、网络安全性、特定注册表值和审核策略的 XML 文件。如果可行，也可以配置 Internet 信息服务 (IIS)。

除了执行其他功能，安全配置向导还包括配置 Windows 防火墙和向 Windows 防火墙添加异常的网络安全性功能。Windows 防火墙是 Windows Server 2003 Service Pack 1 中包含的新版有状态数据包过滤器。Windows 防火墙在 Windows XP Service Pack 2 中首次引入。在 Windows XP Service Pack 2 中称为 Internet 连接防火墙。

如果在 Exchange Server 未安装于默认路径的 Exchange 服务器上运行安全配置向导中的网络安全性功能，会发生一个已知的问题。在这种配置中，应用由此产生的策略可能会导致客户端不能访问 Exchange Server。在 Exchange Server 未安装到默认路径下的 Exchange 服务器上使用网络安全性功能时，安全配置向导可以配置 Windows 防火墙以阻止某些 Exchange Server 进程访问 TPC/IP 端口，例如系统助理 (Mad.exe)、Microsoft Exchange 信息存储 (Store.exe) 或邮件传输代理 (Emsmta.exe)。在这种配置中，安全配置向导会在每个进程旁边显示"找不到！"。如果在某个进程旁边显示"找不到！"的情况下继续运行安全配置向导直至完成，那么安全配置向导会对 Windows 防火墙应用安全策略，阻止该进程进行网络访问。

如果被阻止的进程中包括一个或多个 Exchange Server 进程，则客户端和其他服务器可能无法访问 Exchange Server。如果存在这种情况，您应该执行以下过程之一解决该问题。

解决该问题

  • 请执行以下过程之一解决该问题：

    • 在应用了安全策略之后，使用安全配置向导的回滚功能对其执行回滚。有关如何执行该操作的详细信息，请参阅 Windows Server 2003 Service Pack 1 附带的安全配置向导帮助文件。有关 Windows Server 2003 Service Pack 1 和安全配置向导的详细信息，请参阅"Windows Server 2003 TechCenter"（英文）(http://go.microsoft.com/fwlink/?LinkId=45315)。

    • 在安全配置向导中，手动填写"应用程序路径"字段，以指定 Exchange Server 可执行进程文件的位置。若要这样做，选择旁边显示"找不到！"的进程，再单击"编辑"。建议您在 Exchange 服务器上运行安全配置向导，以确保每个 Exchange Server 进程可执行文件的路径正确。每个进程可执行文件得到批准之后，即可应用安全配置向导安全策略，Exchange Server 应可以进行所需的网络访问。

有关 Windows Server 2003 Service Pack 1 和安全配置向导的详细信息，请参阅"Windows Server 2003 TechCenter"（英文） (http://go.microsoft.com/fwlink/?LinkId=45315)。


存在 XESE.DLL 文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Xese.dll 文件的 Version 关键字的值。

如果 Exchange Server 分析工具能够获得此文件的 Version 值，则指示存在此文件，并显示错误。

某些基于 ESE 的防病毒程序在 Exchange 信息存储和可扩展的存储引擎 (ESE) 之间使用了不受支持的接口。使用这种软件时，如果软件的实现有错误，则存在数据库损坏和数据损失的风险。

在安装期间，基于 ESE 的扫描程序将更改 Microsoft Exchange 信息存储服务，以使它依赖于基于 ESE 的防病毒程序的服务。这样可以确保基于 ESE 的防病毒程序的服务在 Microsoft Exchange 信息存储服务启动之前先启动。基于 ESE 的防病毒程序启动时，Exchange Server 所附带的 Ese.dll 版本会临时重命名为 Xese.dll，并且基于 ESE 的防病毒程序的 Ese.dll 版本会替换原始文件。基于 ESE 的防病毒程序的 Ese.dll 版本被加载后，Exchange Server 附带的版本将重新重命名为 Ese.dll，并且 Microsoft Exchange 信息存储服务将完成启动进程。

解决此警告问题

  1. 强烈建议不要在 Exchange Server 计算机上使用非 Microsoft 的 ESE 实现。与 Microsoft 产品支持服务联系的客户可能被要求禁用基于 ESE 的防病毒程序，以便有助于找出问题，但在正确诊断问题根源之后，客户可以自行再次启用该软件。

  2. 最广为使用的基于 ESE 的防病毒程序是 Sybari Software 的 Antigen for Microsoft Exchange。Microsoft 和 Sybari 同意禁用 Sybari Antigen 是为了确定问题原因而采取的有效的故障解决步骤。若要与 Sybari Software 联系，请访问 Sybari Software 网站 (http://www.sybari.com)。

    注意：
    提供第三方网站信息是为了帮助您查找所需的技术信息。URL 如有更改，恕不通知。

  3. 建议您使用支持病毒扫描应用程序编程接口 (VSAPI)（又称为 AntiVirus API (AVAPI)）的防病毒程序。

有关在 Exchange Server 上运行防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://support.microsoft.com/kb/823166/zh-cn)。

  • 328841"XADM:Exchange 和防病毒软件"(http://support.microsoft.com/?kbid=328841)。


硬件
Microsoft Exchange Server 分析工具 - 文章 >

主题上次修改时间： 2005-11-18

本部分中的文章详细介绍 Microsoft® Exchange Server 分析工具对硬件进行的相关评估。此外，这些文章还描述了为解决由 Exchange Server 分析工具发现的与硬件有关的错误、警告和非默认配置所能采取的操作。


BIOS 已过时
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_BIOS Microsoft Windows® Management Instrumentation (WMI) 类，以确定 SMBIOSBIOSVersion 和 ReleaseDate 关键字的值。返回的值分别表示计算机上安装的 BIOS 的版本号和发行日期。Exchange Server 分析工具还检查 Win32_ComputerSystem WMI 类，以确定 Model 关键字的值。

如果 Exchange Server 分析工具从 ReleaseDate 的值确定它已过时一年以上，并且 Model 关键字中包含下列任意字符串，则会显示警告：

  • ProLiant DL320

  • ProLiant DL320 G2

  • ProLiant DL320 G3

  • ProLiant DL360

  • ProLiant DL360 G2

  • ProLiant DL360 G3

  • ProLiant DL360 G4

  • ProLiant DL380

  • ProLiant DL380 G2

  • ProLiant DL380 G3

  • ProLiant DL380 G4

  • ProLiant DL560

  • ProLiant DL570 G3

  • ProLiant DL580

  • ProLiant DL580 G2

  • ProLiant DL580 G3

  • ProLiant DL585 G1

  • ProLiant ML350

  • ProLiant ML350 G2

  • ProLiant ML350 G3

  • ProLiant ML350 G4

  • ProLiant ML370

  • ProLiant ML370 G2

  • ProLiant ML370 G3

  • ProLiant ML370 G4

  • ProLiant ML530

  • ProLiant ML530 G2

  • ProLiant ML570

  • ProLiant ML570 G2

  • ProLiant ML750

若要解决此警告问题，并了解有关获取和更新更高 BIOS 版本的详细信息，请参阅 Hewlett-Packard 网站上的"ROM-BIOS/Firmware Updates"（英文）(http://h18023.www1.hp.com/support/files/server/us/romtabl.html)。

有关 Hewlett-Packard ProLiant 服务器的详细信息，请访问 Hewlett-Packard 网站 (http://www.hp.com)。

注意：
Web 地址可能会改变，所以，也许无法连接到此处提到的网站。


Dell PowerEdge 服务器上的 BIOS 已过时
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_BIOS Microsoft Windows® Management Instrumentation (WMI) 类，以确定 SMBIOSBIOSVersion 关键字的值。返回的值表示计算机上安装的 BIOS 的版本号。Exchange Server 分析工具还检查 Win32_ComputerSystem WMI 类，以确定 Model 关键字的值。

如果 Exchange Server 分析工具发现 Model 关键字包含下面的任意字符串，而 SMBBIOSBIOSVersion 不是该型号的最新版本，则会显示警告：

  • PowerEdge 2400

  • PowerEdge 2450

  • PowerEdge 2500

  • PowerEdge 2550

  • PowerEdge 2600

  • PowerEdge 2650

  • PowerEdge 2800

  • PowerEdge 2850

  • PowerEdge 3250

  • PowerEdge 4300

  • PowerEdge 4350

  • PowerEdge 4400

  • PowerEdge 4600

  • PowerEdge 6300

  • PowerEdge 6350

  • PowerEdge 6400

  • PowerEdge 6450

  • PowerEdge 6600

  • PowerEdge 6650

  • PowerEdge 6800

  • PowerEdge 6850

  • PowerEdge 7150

  • PowerEdge 7250

  • PowerEdge 8450

若要解决此警告问题，或要了解有关获取和更新更高的 BIOS 版本的详细信息，请参阅 Dell 网站上的"Downloads"(http://support.dell.com/support/downloads)。

有关 Dell PowerEdge 服务器的详细信息，请访问 Dell 网站 (http://www.dell.com)。

注意：
Web 地址可能会改变，所以，也许无法连接到此处提到的网站。


有 BIOS 更新可用
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_BIOS Microsoft Windows® Management Instrumentation (WMI) 类，以确定 SMBIOSBIOSVersion 项的值。返回的值表示计算机上安装的 BIOS 的版本号和发行日期。Exchange Server 分析工具还检查 Win32_ComputerSystem WMI 类，以确定 Model 项的值。如果 Exchange Server 分析工具确定计算机为 IBM X445 系统，并且 BIOS 版本早于 REJT48A，Exchange Server 分析工具将显示错误。

若要更正此错误，并了解如何获取并更新到更新的 BIOS 版本的详细信息，请访问 IBM 网站上的"Flash BIOS update (DOS update package) with RSA I and RSA II EXA support - IBM eServer xSeries 445"(http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-54089)。

注意：
Web 地址可能会改变，所以，也许无法连接到此处提到的网站。


群集网络接口卡启用了 DHCP
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_NetworkAdapterConfiguration Microsoft Windows® Management Instrumentation (WMI) 类，以确定群集中所有网络接口的 DHCPEnabled 关键字的值。如果 Exchange Server 分析工具发现群集中任何专用网络接口的 DHCPEnabled 值设置为 True，则显示错误。

DHCPEnabled WMI 关键字的值为 True 表示网络接口被配置为使用动态主机配置协议 (DHCP)。Microsoft 不支持 Windows 服务器群集中的专用网络上的节点使用 DHCP。另外，建议 Windows 服务器群集中的公用网络上的节点使用静态 IP 地址。不建议通过 DHCP 使用公用网络的动态配置，因为如果续订 DHCP 租约失败，就会中断群集操作。另外，不支持通过 DHCP 使用专用网络的动态配置，并且应当永远不执行。

若要解决该问题，必须重新配置专用网络的网络接口，使它使用静态 IP 地址。建议在下列范围内选择地址：

  • 10.0.0.0 - 10.255.255.255（A 类网络）

  • 172.16.0.0 - 172.31.255.255（B 类网络）

  • 192.168.0.0 - 192.168.255.255（C 类网络）

更正此错误

  1. 在网络连接中，用鼠标右键单击专用网络适配器的网络连接，再单击"属性"。

  2. 单击"Internet 协议 (TCP/IP)"，再单击"属性"。

  3. 在"常规"选项卡上，输入不在同一子网或网络上的静态 IP 地址作为另一个公用网络适配器。用于专用适配器的较好 IP 地址示例是节点 1 上的 10.10.10.10 和节点 2 上的 10.10.10.11（子网掩码为 255.0.0.0）。如果公用网络使用 10.x.x.x 网络和 255.0.0.0 子网掩码，请使用备用的专用网络 IP 和子网。

  4. 确保"默认网关"框中没有设置值。

  5. 验证在"使用下面的 DNS 服务器地址"框中没有定义值。

  6. 单击"高级"。

  7. 在"DNS"选项卡上，验证没有定义值。确保"在 DNS 中注册此连接的地址"和"在 DNS 注册中使用此连接的 DNS 后缀"复选框已清除。

  8. 在"WINS"选项卡上，验证没有定义值。单击"禁用 TCP/IP 上的 NetBIOS"。

  9. 关闭对话框时，可能会收到以下提示。如果收到此"此连接具有空的主 WINS 地址。要继续吗？"提示，请单击"是"。

  10. 单击"确定"保存更改。

  11. 在群集中其他所有节点上完成上述步骤。

有关 Windows 服务器群集的最佳网络配置的详细信息，请参阅"Server Clusters:Network Configuration Best Practices for Windows 2000 and Windows Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=34304)。

有关正确的群集检测信号配置的详细信息，请参阅 Microsoft 知识库文章 258750"建议在群集服务器上使用的专用'检测信号'配置"(http://support.microsoft.com/kb/258750/zh-cn)。


计算机的主 DNS 后缀与它所在域的 FQDN 不匹配
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2006-05-18

Microsoft® Exchange Server 分析工具读取下列注册表项，以确定此 Exchange Server 的主域名系统 (DNS) 后缀：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\NV Domain

HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Domain

如果 Exchange Server 分析工具发现 NV Domain 和 Domain 的值不匹配，则显示警告。

NV Domain 注册表值包含计算机的主 DNS 后缀。Domain 注册表值包含计算机的主 DNS 域。默认情况下，计算机的完全限定域名 (FQDN) 的主 DNS 后缀部分必须与计算机所在的 Active Directory® 目录服务域的名称相同。不匹配的名称可以导致 DNS 注册无法正确进行。如果计算机的 DNS 域名与 Active Directory 域名不匹配，您将在计算机的系统事件日志中每隔 22 分钟看到错误记录。这种情况称为脱节命名空间。若要使用不同的主 DNS 后缀，可以通过在域对象容器中创建名为 msDS-AllowedDNSSuffixes 的 Active Directory 属性，创建一个受限制的允许后缀列表。

确保有正确配置的脱节命名空间的过程各不相同，这取决于 Active Directory 域控制器所使用的操作系统。

  • 如果 Active Directory 域控制器上运行的是 Microsoft Windows® 2000 Server 操作系统，则可以使用 Microsoft 知识库文章 258503"DNS 域和 Active Directory 域名不一致时出现 DNS 注册错误 5788 和 5789"(http://support.microsoft.com/kb/258503/zh-cn) 中所述的过程来正确配置命名空间。该文包括了纠正不需要的脱节命名空间的过程，以及正确配置脱节命名空间的过程（如果需要这样一个命名空间）。

  • 如果正在 Active Directory 域控制器上运行 Microsoft Windows Server™ 2003，并且不需要脱节命名空间，则可以使用下面的第一个过程来纠正不需要的脱节命名空间，并解决该警告问题。如果正在 Active Directory 域控制器上运行 Windows Server 2003，并且需要脱节命名空间，则可以使用下面的第二个过程来正确配置它。

若要执行以下第二个过程，将需要使用 Active Directory 服务接口 (ADSI) Edit 或 LDP (Ldp.exe) 工具等 Active Directory 编辑器。有关使用 LDP 工具修改 Active Directory 的详细信息，请参阅 Microsoft 知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=260745)。

警告：
在使用 ADSI Edit、LDP 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Windows Server 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

如果脱节命名空间是不需要的，请执行下列操作：

  1. 用鼠标右键单击"我的电脑"，然后单击"属性"。将出现"系统属性"对话框。

  2. 单击"计算机名"选项卡。

  3. 单击"更改"。将出现"计算机名称更改"对话框。

  4. 单击"其他"。将出现"DNS 后缀和 NetBIOS 计算机名"对话框。

  5. 选中"在域成员身份变化时，更改主 DNS 后缀"复选框。

  6. 单击"确定"保存更改，再单击"确定"退出"计算机名称更改"对话框。

  7. 单击"确定"关闭"系统属性"对话框，然后重新启动计算机，以使更改生效。

如果脱节命名空间是需要的，请执行下列操作：

  1. 使用上面的过程，确保"在域成员身份变化时，更改主 DNS 后缀"复选框已清除。

  2. 修改域对象容器上的"msDS-AllowedDNSSuffixes"Active Directory 属性。可以用 ADSI Edit 通过执行下列步骤来完成该操作：

    1. 双击要修改的域的域目录分区。

    2. 用鼠标右键单击域容器对象，再单击"属性"。

    3. 在"属性编辑器"选项卡的"属性"框中，双击"msDS-AllowedDNSSuffixes"属性。

    4. 在"多值字符串编辑器"对话框的"要添加的值"框中，输入 DNS 后缀，然后单击"添加"。

    5. 为该域添加了所有 DNS 后缀以后，单击"确定"。

    6. 单击"确定"关闭该域的"属性"对话框。

    7. 如果要为多个域进行类似配置，请重复执行以上步骤。

有关 msDS-AllowedDNSSuffixes 属性的详细信息，请参阅 Windows Server 2003 帮助和支持中心。有关用于编辑此属性的过程的其他信息，请参阅"Step-by-Step Guide to Implementing Domain Rename"（英文）(http://go.microsoft.com/fwlink/?LinkId=41359)。


有关键的 BIOS 更新可用
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2006-04-20

Microsoft® Exchange Server 分析工具查询 Win32_BIOS Microsoft Windows® Management Instrumentation (WMI) 类，以确定 SMBIOSBIOSVersion 关键字的值。SMBIOSBIOSVersion 关键字值代表安装在服务器上的 BIOS 的版本。Exchange Server 分析工具还查询 Win32_ComputerSystem WMI 类，以确定 Model 关键字的值。Model 关键字值代表硬件制造商提供的硬件型号信息。

如果在 Model 关键字以 eserver xSeries 445 开头的服务器上，Exchange Server 分析工具发现 Version 关键字的值是 42B，则显示错误。此错误意味着该 IBM xSeries 445 服务器的 BIOS 必须更新。

42B 版的 BIOS 固件有一个已知问题可能会导致数据破坏。此问题仅仅在安装了 BIOS 42B（1.15 版）的 X445 系统上出现。此问题在 BIOS 45A 中已修正。应尽快将此服务器上的 BIOS 更新为 45A 或更高版本。

更正此错误

  1. 有关此问题的详细信息，请访问 IBM 网站"Flash BIOS Update (DOS update package) - IBM eServer xSeries 445"（英文）(http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-54089#BIOSVersion)。

  2. 有关信息，请参阅 BIOS 更新的自述文件（英文）(ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers/39y4888.txt)。

  3. 从 IBM 网站 (http://www-307.ibm.com/pc/support/site.wss/license.do?filename=pc_servers/26r0663.exe) 下载 BIOS 更新。

  4. 更新服务器上的 BIOS。

有关应用此关键 BIOS 更新的详细信息，请访问 IBM 网站（英文）(http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=DSHY-3TEPF6)。

注意：
Web 地址可能会改变，所以，也许无法连接到此处提到的网站。


当前处理器速度低于最大可能速度
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Processor Microsoft Windows® Management Instrumentation (WMI) 类，以确定 MaxClockSpeed 和 CurrentClockSpeed 的当前值。如果 Exchange Server 分析工具发现 CurrentClockSpeed 的值小于 MaxClockSpeed 的值，则会显示警告。

CurrentClockSpeed 值是每个处理器的当前速度 (MHz)。MaxClockSpeed 是每个处理器的最大速度 (MHz)。如果显示了此警告消息，则表明您的 Exchange 服务器上有一个或多个处理器未以全速运行。有几个已知的原因：

  1. Exchange Server 安装在运行 Microsoft Windows® 2000 Server 或 Windows 2000 Advanced Server 的计算机上，该计算机上未安装 Windows 2000 Server Service Pack 3（最低要求）。对于 WMI 没有为 MaxClockSpeed 或 CurrentClockSpeed 返回正确值的问题，Windows 2000 Server Service Pack 3 更正了此问题。

  2. Exchange 服务器 BIOS 中不正确的节能设置可能会强制处理器在节能模式中以降低的速度运行。

解决此警告问题

  1. 如果 Exchange Server 安装在运行 Windows 2000 Server 或 Windows 2000 Advanced Server 的计算机上，该计算机上未安装 Windows 2000 Server Service Pack 3（最低要求），则应当安装最新的 Service Pack。有关最新的 Windows 2000 Service Pack 的详细信息，请访问 Microsoft Windows 2000 网站 (http://go.microsoft.com/fwlink/?LinkId=18353)。

  2. 如果 Exchange Server 安装在运行 Windows 2000 Server 或 Windows 2000 Advanced Server 的计算机上，该计算机上安装了 Windows 2000 Server Service Pack 3 或更高版本，请检查您的 Exchange 服务器的 BIOS 设置。还应该检查 BIOS 中以及控制面板或设备管理器中的电源管理设置。

有关如何查看和配置系统 BIOS、处理器和电源管理设置的信息，请咨询您的硬件制造商。

有关 Windows 2000 Server 的电源管理功能的详细信息，请参阅 Microsoft 知识库文章 244806"Windows 2000 电源管理概述"(http://support.microsoft.com/kb/244806/zh-cn)。

有关 Microsoft Windows Server™ 2003 的电源管理功能的详细信息，请在 Windows Server 2003 帮助和支持中心（可在运行 Windows Server 2003 的计算机中从"开始"菜单运行）中搜索"电源管理"和"电源选项"。

有关 Windows 2000 Server 的电源管理功能的详细信息，请参阅 Windows 2000 Server 帮助（可在运行 Windows 2000 Server 的计算机中从"开始"菜单运行）中的主题"电源管理"和"电源选项"。


Windows 2003 Server 上的 DisableDHCPMediaSense 当前未正确设置
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2006-10-02

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已正确配置了媒体感知检测：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\DisableDHCPMediaSense

Exchange Server 分析工具还检查以下注册表项，以确定目标计算机上运行的 Windows 的版本：

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 的值为 4.0 说明计算机正在运行 Microsoft Windows NT® Server 4.0。值为 5.0 说明计算机正在运行 Windows® 2000 Server 操作系统，值为 5.2 说明计算机正在运行 Windows Server™ 2003 操作系统。

此外，Exchange Server 分析工具还查询 Win32_Service Microsoft Windows Management Instrumentation (WMI) 类，以确定 ClusSvc（Microsoft Windows 群集服务）的 Started 关键字的值。值为 True 说明 Windows 群集服务正在运行，值为 False 说明未运行该服务。

如果 Exchange Server 分析工具发现 Windows 群集服务正运行在 Windows Server 2003 Enterprise Edition 或 Windows Server 2003 Datacenter Edition 上，并且 DisableDHCPMediaSense 注册表项的值被设置为 1，则显示警告。

使用 Windows Server 2003 群集服务时，如果丢失了网络连接，则默认情况下不会卸载 TCP/IP 堆栈，而在 Windows2000 Server 中则会。因此，不再需要设置 DisableDHCPMediaSense 注册表项。在 Windows 2000 Server 中，如果丢失网络连接，则会卸载 TCP/IP 堆栈，这意味着依赖于 IP 地址的所有群集资源（包括 Exchange 虚拟服务器中的资源）都会脱机。当网络重新联机时，其网络角色将转换为默认设置（即客户端和私人）。通过在默认情况下禁用媒体感知，意味着网络角色将得以保持，而且还能让所有依赖 IP 地址的资源保持联机状态。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：

    HKLM\System\CurrentControlSet\Services\Tcpip\Parameters

  3. 在右侧窗格中，单击右键以修改（设置为 0 可禁用）或删除 DisableDHCPMediaSense 注册表值。

  4. 关闭注册表编辑器。

  5. 将所有群集资源移至另一个节点，或使其脱机。然后，重新启动群集节点使更改生效。

  6. 对产生此警告的群集中的所有其他节点重复上述过程。

有关 Microsoft Windows 注册表的详细信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关媒体感知检测和 Windows 群集的详细信息，请参阅下列知识库文章：

  • 254651"Cluster network role changes automatically"（群集网络角色自动更改）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=254651)

  • 239924"如何在 Windows 中为 TCP/IP 禁用'媒体感知'"(http://support.microsoft.com/kb/239924/zh-cn)

  • 242430"Network Adapter Not Available During Cluster Configuration with a Crossover Cable"（用交叉电缆进行群集配置期间不能使用网络适配器）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=242430)

  • 278007"Windows Server 2003 群集中可用的功能"(http://support.microsoft.com/kb/278007/zh-cn)


Windows 2000 Server 上的 DisableDHCPMediaSense 当前未正确设置
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已正确配置了媒体感知检测：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\DisableDHCPMediaSense

Exchange Server 分析工具还检查以下注册表项，以确定目标计算机上运行的 Windows 的版本：

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 的值为 4.0 说明计算机正在运行 Microsoft Windows NT® Server 4.0。值为 5.0 说明计算机正在运行 Microsoft Windows® 2000 Server 操作系统，值为 5.2 说明计算机正在运行 Microsoft Windows Server™ 2003 操作系统。

此外，Exchange Server 分析工具还查询 Win32_Service Microsoft Windows Management Instrumentation (WMI) 类，以确定 ClusSvc（Microsoft Windows 群集服务）的 Started 关键字的值。值为 True 说明 Windows 群集服务正在运行，值为 False 说明未运行该服务。

如果 Exchange Server 分析工具发现在 Windows 2000 Advanced Server 或 Windows 2000 Datacenter Server 中运行 Windows 集群服务，并且如果 DisableDHCPMediaSense 注册表值存在而其值未设置为 1，则显示警告。

当使用 Windows2000 Server 群集服务时，如果网络连接断开，TCP/IP 堆栈将卸载。这意味着依赖于 IP 地址的所有群集资源（包括 Exchange 虚拟服务器中的资源）都将脱机。当网络重新联机时，其网络角色将转换为默认设置（客户端和私人）。为了防止这种情况发生，建议在所有基于 Windows 2000 Server 的群集上禁用媒体感知检测。在基于 Windows Server 2003 的群集上，自动禁用媒体感知检测。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：

    HKLM\System\CurrentControlSet\Services\Tcpip\Parameters

  3. 用鼠标右键单击"Parameters"，再单击"新建"|"DWORD 值"。在"名称"中键入 DisableDHCPMediaSense，然后按 Enter 键。

  4. 在右侧窗格中，双击"DisableDHCPMediaSense"，在"数值数据"中输入 1。

  5. 关闭注册表编辑器。

  6. 将所有群集资源移至另一个节点，或使其脱机。然后，重新启动群集节点使更改生效。

  7. 对产生此警告的群集中的所有节点重复上述过程。

有关 Microsoft Windows 注册表的详细信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关媒体感知检测和 Windows 群集的详细信息，请参阅下列知识库文章：

  • 254651"Cluster network role changes automatically"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=254651)

  • 239924"如何在 Windows 中为 TCP/IP 禁用'媒体感知'"(http://support.microsoft.com/kb/239924/zh-cn)

  • 242430"Network Adapter Not Available During Cluster Configuration with a Crossover Cable"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=242430)

  • 278007"Windows Server 2003 群集中可用的功能"(http://support.microsoft.com/kb/278007/zh-cn)


磁盘超时默认情况下未设置
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已将磁盘超时值从默认值更改为其他值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Disk\TimeOutValue

如果 Exchange Server 分析工具发现 TimeOutValue 存在并配置为 10 以外的任意值，并且服务器为非群集服务器，则显示非默认配置消息。如果 Exchange Server 分析工具发现 TimeOutValue 存在并配置为 20 以外的任意值，并且服务器为群集服务器，则显示非默认配置消息。

磁盘超时是一个注册表设置，它指定 Microsoft Windows® 等待硬盘响应命令的时间。在非群集系统上，此项不存在，默认值 10 秒用于所有磁盘。在 Windows 群集上，此项存在，并使用默认值 20 秒。如果超时时间大于此注册表设置中的值，Windows 将显示错误并停止磁盘访问。有时（例如，运行了多路径磁盘访问软件），可以将此项设置为一个更大的值。使用多路径软件可以将多个物理路径（如光纤）连接到单个磁盘驱动器以实现冗余。多路径软件管理多个物理连接，以便 Windows 仅处理该磁盘的一个句柄。

安装主机总线适配器 (HBA) 或其他存储控制器会导致创建并配置此项。当安装或重新安装这些驱动程序时，TimeOutValue 注册表值会被这些驱动程序所需的值覆盖。可能必须联系硬件供应商才能确定对于您的配置而言正确的 TimeOutValue 注册表值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：

    HKLM\System\CurrentControlSet\Services\Disk\TimeOutValue

  3. 在右侧窗格中，删除 TimeOutValue 项。或者，双击 TimeOutValue 项，将它设置为下面的某个值：

    • 在非群集服务器上，将该值设置为 10。

    • 在群集服务器上，将该值设置为 20。

    • 如果硬件制造商对群集系统或非群集系统推荐了另一个值，请改用硬件制造商推荐的值。

  4. 关闭注册表编辑器，然后重新启动计算机，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关群集系统上的 TimeOutValue 项的详细信息，请参阅知识库文章 818877"Cluster Servers May Experience Connection Timeouts to Drives After You Install or Upgrade to the Windows Clustering Feature in Windows Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=818877)。


DNS 搜索顺序为空白
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_NetworkAdapterConfiguration Microsoft Windows® Management Instrumentation (WMI) 类，以确定是否为 DNSServerSearchOrder 设置了值。如果 Exchange 服务器上的该关键字的值为空白，则会显示警告。

该警告意味着此计算机上的一个或多个网络适配器没有关联的 DNS IP 地址。因此，当此计算机试图连接到另一台计算机时，会在本地网络中广播 IP 地址。因此，名称解析的速度将很慢，从而导致 Exchange 的运行速度很慢。

建议至少输入一个有效 DNS 服务器的 IP 地址。如果计算机上有多个适配器，请确认所有适配器都至少有一个有效的 DNS 服务器 IP 地址。

在网络适配器上设置 DNS IP 地址

  1. 在"网络连接"中，用鼠标右键单击相应的局域网适配器，再单击"属性"。

  2. 在"常规"选项卡上，双击"Internet 协议 (TCP/IP)"。

  3. 在"Internet 协议 (TCP/IP)"页的"常规"选项卡上，至少输入一个有效 DNS 服务器的 IP 地址，再单击"确定"。

有关配置 DNS 以便与 Exchange 一起工作的详细信息，请参阅 Microsoft 知识库文章 322856"HOW TO：配置 DNS 以用于 Exchange Server"(http://support.microsoft.com/kb/322856/zh-cn)。


检测信号连接有默认网关
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_NetworkAdapter Microsoft Windows® Management Instrumentation (WMI) 类，以确定 NetConnectionID 关键字的值。如果 NetConnectionID 关键字的值包含字符串 Internal 或 HEART，则说明该接口是群集专用（检测信号）网络。

Exchange Server 分析工具还查询 Win32_NetworkAdapterConfiguration WMI 类，以确定是否为 DefaultIPGateway 关键字设置了值。如果设置了值，则说明已为该网络接口配置了默认网关。

如果 Exchange Server 分析工具发现在用于群集检测信号网络的网络接口上为 DefaultIPGateway 关键字设置了值，则会显示警告。

由于专用群集网络用于内部群集通信，所以不需要配置默认网关。若要消除可能的通信问题，建议您从用作群集专用网络适配器的网络适配器上，删除所有不需要的网络通信。

解决此警告问题

  1. 打开"网络连接"窗口。用鼠标右键单击"网上邻居"，再单击"属性"，或者，如果"网上邻居"没有显示在桌面上，请单击"开始"，单击"程序"，单击"附件"，单击"通信"，再单击"网上邻居"。

  2. 在"网络连接"窗口中，用鼠标右键单击用于专用网络的网络适配器，再单击"属性"。

  3. 选择"Internet 协议 (TCP/IP)"，再单击"属性"。

  4. 在"使用下面的 IP 地址"区域中，删除默认网关 IP 地址。

  5. 单击"确定"两次，以保存更改。

  6. 对群集中的每个节点重复步骤 1 到 5。

有关 Windows 服务器群集中专用网络的推荐设置的详细信息，请参阅 Microsoft 知识库文章 258750"建议在群集服务器上使用的专用'检测信号'配置"(http://support.microsoft.com/kb/258750/zh-cn)。


检测信号连接有 DNS 搜索地址
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_NetworkAdapter Microsoft Windows® Management Instrumentation (WMI) 类，以确定 NetConnectionID 关键字的值。如果 NetConnectionID 关键字的值包含字符串 Internal 或 HEART，则说明该接口是群集专用（检测信号）网络。

Exchange Server 分析工具还查询 Win32_NetworkAdapterConfiguration WMI 类，以确定是否为 DNSServerSearchOrder 关键字设置了值。如果设置了值，则说明已经为该网络接口配置了域名系统 (DNS) 搜索地址。

如果 Exchange Server 分析工具发现在用于群集检测信号网络的网络接口上为 DNSServerSearchOrder 关键字设置了值，则会显示警告。

由于专用群集网络用于内部群集通信，所以不需要配置任何 DNS 服务器。若要消除可能的通信问题，建议从用作群集专用网络适配器的网络适配器上，删除所有不需要的网络通信。

解决此警告问题

  1. 打开"网络连接"窗口。用鼠标右键单击"网上邻居"，再单击"属性"，或者，如果"网上邻居"没有显示在桌面上，请单击"开始"，单击"程序"，单击"附件"，单击"通信"，再单击"网上邻居"。

  2. 在"网络连接"窗口中，用鼠标右键单击用于专用网络的网络适配器，再单击"属性"。

  3. 选择"Internet 协议 (TCP/IP)"，再单击"属性"。

  4. 单击"高级"。

  5. 在"DNS"选项卡上，选择 DNS 服务器地址，再单击"删除"。对列出的每个 DNS 服务器地址重复该步骤。

  6. 清除"在 DNS 中注册此连接的地址"和"在 DNS 注册中使用此连接的 DNS 后缀"复选框。

  7. 单击"确定"三次，以保存更改。

  8. 对群集中的每个节点重复步骤 1 到 7。

有关 Windows 服务器群集中专用网络的推荐设置的详细信息，请参阅 Microsoft 知识库文章 258750"建议在群集服务器上使用的专用'检测信号'配置"(http://support.microsoft.com/kb/258750/zh-cn)。


检测信号连接有 WINS 地址
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_NetworkAdapter Microsoft Windows® Management Instrumentation (WMI) 类，以确定 NetConnectionID 关键字的值。如果 NetConnectionID 关键字的值包含字符串 Internal 或 HEART，则说明该接口是群集专用（检测信号）网络。

Exchange Server 分析工具还查询 Win32_NetworkAdapterConfiguration WMI 类，以确定是否为 WINSPrimaryServer 关键字设置了值。如果设置了值，则说明已为该网络接口配置了主 Windows Internet 名称服务 (WINS) 地址。

如果 Exchange Server 分析工具发现为用于群集检测信号网络的网络接口的 WINSPrimaryServer 关键字设置了值，则显示警告。

由于使用专用群集网络来进行内部群集通信，因此不必配置任何 WINS 服务器，也不必使用 NetBIOS。若要消除可能的通信问题，建议您从用作群集专用网络适配器的网络适配器上，删除所有不需要的网络通信。

解决此警告问题

  1. 打开"网络连接"窗口。用鼠标右键单击"网上邻居"，再单击"属性"，或者，如果"网上邻居"没有显示在桌面上，请单击"开始"，单击"程序"，单击"附件"，单击"通信"，再单击"网上邻居"。

  2. 在"网络连接"窗口中，用鼠标右键单击用于专用网络的网络适配器，再单击"属性"。

  3. 选择"Internet 协议 (TCP/IP)"，再单击"属性"。

  4. 单击"高级"。

  5. 在"WINS"选项卡上，选择 WINS 地址，再单击"删除"。对每个列出的 WINS 地址重复该步骤。

  6. 在"NetBIOS 设置"区域中，选择"禁用 TCP/IP 上的 NetBIOS"。

  7. 单击"确定"三次，以保存更改。第一次单击"确定"之后，可能收到下列提示。如果收到此"此连接具有空的主 WINS 地址。要继续吗？"提示，请单击"是"。

  8. 对群集中的每个节点重复步骤 1 到 7。

有关 Windows 服务器群集中专用网络的推荐设置的详细信息，请参阅 Microsoft 知识库文章 258750"建议在群集服务器上使用的专用'检测信号'配置"(http://support.microsoft.com/kb/258750/zh-cn)。


检测信号连接在 TCP/IP 绑定顺序中位于最前面并且不是公用连接
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询两个 Microsoft Windows® Management Instrumentation (WMI) 类以执行下列操作：

  • 查询 Win32_NetworkConfiguration WMI 类，以确定群集中所有网络接口的 SettingID 关键字的值。SettingsID 关键字的值是代表唯一网络适配器的 GUID。

  • 查询 Win32_NetworkAdapter WMI 类，以确定在 Exchange 群集中将哪些网络适配器用于专用网络通信。专用网络用于内部群集通信，包括群集检测信号。

  • Exchange Server 分析工具还检查以下注册表值，以确定网络适配器绑定顺序：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Linkage\Bind

Bind 注册表值是一个多字符串值，它包含按绑定顺序列出的网络适配器列表。列表中的第一个条目是第一个绑定的网络适配器；第二个条目是绑定顺序中的第二个网络适配器；依此类推。

如果 Exchange Server 分析工具确定群集检测信号网络适配器在绑定顺序中是第一个，则会显示警告。

若要解决该问题，请确保公用网络适配器是位于绑定列表顶部的第一个绑定项。如果有多个公用网络适配器，请确保专用检测信号网络适配器最后一个列出。如果检测信号网络适配器第一个列出，它会使 Service Pack 的安装和升级无法正确进行。

解决此警告问题

  1. 在"网络连接"窗口中，单击"高级"，再单击"高级设置"。

  2. 单击"适配器和绑定"选项卡。

  3. 在"连接"字段中，选择专用网络适配器，并使用向下箭头将专用网络适配器移动到列表的底部。

  4. 对群集中的每个节点重复这些步骤。

有关 Windows 服务器群集的最佳网络配置的详细信息，请参阅"Server Clusters: Network Configuration Best Practices for Windows 2000 and Windows Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=34304)

有关正确的群集检测信号配置的详细信息，请参阅 Microsoft 知识库文章 258750"建议在群集服务器上使用的专用'检测信号'配置"(http://support.microsoft.com/kb/258750/zh-cn)。


检测信号网络速度被设置为自动感知/自动检测
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_NetworkAdapter Microsoft Windows® Management Instrumentation (WMI) 类，以确定 NetConnectionID 关键字的值。如果 NetConnectionID 关键字的值包含字符串 Internal 或 HEART，则说明该接口是群集专用（检测信号）网络。

Exchange Server 分析工具还读取以下注册表值，以确定用于群集检测信号网络的网络接口卡的链路速度和双工设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\<NetworkCardDeviceID>\SpeedDuplex

另外，Exchange Server 分析工具还读取以下注册表值，以确定是否启用了自动网络速度检测：

HKLM\System\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\%NICDEVICEID%\Ndi\Params\SpeedDuplex\enum\0

如果 0 关键字的值包含字符串 AUTO，则说明启用了自动网络速度检测。

如果 Exchange Server 分析工具确定 SpeedDuplex 设置为 0，并且启用了群集检测信号网络的自动网络速度检测，则显示警告。

服务器群集节点之间的通信对于群集的正常工作至关重要。如果将多个速度的以太网网络适配器用于群集通信，并将适配器配置为自动检测网络速度，则该适配器可能导致在群集中出现问题。在检测进程期间，适配器将无法处理数据包，数据包必须排队。某些适配器可能会无意识地触发自动检测进程偶尔重新发生。因此，通信将排队，并且出现延迟。这种延迟可能导致群集节点不能迅速接收到关键的数据包，并且可能导致群集资源提前发生故障转移。建议将群集中的检测信号网络手动设置为 10 MB 和半双工。该配置将提供足够的带宽和可靠的通信。

解决此警告问题

  • 将检测信号网络接口卡的链路速度配置为 10 MB，并将其双工设置配置为半双工。由于每个网络卡的配置步骤不同，所以，请根据硬件提供商的说明来正确配置检测信号网络。配置这些选项可能需要您更新驱动程序。

有关 Windows 服务器群集中专用网络的推荐设置的详细信息，请参阅 Microsoft 知识库文章 258750"建议在群集服务器上使用的专用'检测信号'配置"(http://support.microsoft.com/kb/258750/zh-cn)。


主机总线适配器队列深度设置为 32
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2006-10-11

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定安装在 Exchange Server 计算机上的主机总线适配器 (HBA) 的队列深度：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\elxstor\Parameters\Device\DriverParameter

如果 Exchange Server 分析工具发现 DriverParameter 的值设置为 32，则显示警告。

HBA 是存储区域网络 (SAN) 的磁盘控制器。HBA 队列深度定义了尚未处理队列请求的最大数目。通常，DriverParameter 的建议值是 128。但是，对于每个 Exchange Server 计算机中的每个 HBA 来说，这可能不是其 HBA 队列深度的最佳值。因此，您应当咨询 HBA 制造商，以获得具体硬件的最佳值。

解决此警告问题

  1. 联系硬件制造商，以确定 HBA 的最佳设置。

  2. 使用 Microsoft Windows® 系统监视器实用程序监视磁盘性能。

  3. 将 HBA 硬件更新到最新固件和驱动程序。

有关 Exchange Server 存储设计和优化的详细信息，请参阅"优化 Exchange Server2003 的存储"(http://www.microsoft.com/downloads/details.aspx?FamilyID=c6084d20-9730-4ffc-805d-b957327604c6&DisplayLang=zh-cn)。


热添加内存的配置
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2006-02-22

Microsoft® Exchange Server 分析工具查询 Win32_Computer System Microsoft Windows® Management Instrumentation (WMI) 类，以确定服务器是否支持热添加内存功能。Exchange Server 分析工具还查询 Win32_OperatingSystem WMI 类，以确定下列事项：

  • Boot.ini 文件中是否设置了 /3GB 选项。

  • 是否加载了物理地址扩展 (PAE) 内核。

  • 服务器上运行的操作系统版本。

最后，Exchange Server 分析工具查询以下注册表项，以确定 DynamicMemory 配置参数是否存在并已正确设置：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

如果确定下列全部条件均为真，Exchange Server 分析工具将显示一条错误消息：

  • 计算机支持热添加内存，并且在默认情况下启用该功能。

  • 计算机运行的是 Microsoft Windows Server™ 2003 Enterprise Edition 或 Windows Server 2003 Datacenter Edition。

  • PAE 内核已加载。

  • Boot.ini 中设置了 /3GB 选项。

  • 未设置 DynamicMemory 注册表配置参数，设置的值是 0，或设置的值大于 3。

注意：
如果计算机支持热添加内存，但是硬件制造商在默认情况下禁用该功能，则 Exchange Server 分析工具将显示警告消息，而不是错误消息。

热添加内存功能在 Windows Server 2003 Enterprise Edition 和 Windows Server 2003 Datacenter Edition 中引入，使系统管理员可以在不重新启动计算机的情况下，为计算机添加更多的物理内存。在支持内存密集型关系数据库应用程序（例如 Microsoft SQL Server）的服务器上，此功能非常有用。但是，因为 Exchange Server 无法使用超过 4 GB 的物理内存，所以此功能对于 Exchange Server 没有用处。

并非所有计算机都支持热添加内存。对于支持热添加内存的计算机，有些硬件制造商在默认情况下启用该功能，其他制造商则在基本输入输出系统 (BIOS) 中提供控件。如果在启动过程中启用了热添加内存，则操作系统内核必须预先分配空间，用于处理以后可能为该计算机添加的任何内存。因此，应根据计算机的能力（而不是实际安装的配置）分配内核资源。在运行 Microsoft Exchange Server 的计算机上，内核内存是宝贵的资源。因为内核可能会为从不安装的内存分配大量的资源，并且因为 Exchange Server 所使用的物理内存的本质，所以，通过禁用热添加内存功能，可以提高性能和可伸缩性。启用该功能可能会使页面缓冲池的最大大小远低于预期值。这可能会严重影响性能，造成系统死机，最终造成服务崩溃。

预期的最大页面缓冲池大小示例（越多越好）：

  • 240 MB 拥有 4 GB 物理内存的计算机，不支持热添加内存或禁用了热添加内存的支持

  • 210 MB 拥有 4 GB 物理内存的计算机，但是最多可以支持 32 GB 热添加内存

  • 160 MB 拥有 4 GB 物理内存的计算机，但是最多可以支持 64 GB 热添加内存

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
在运行 Windows Server 2003 Service Pack 1 (SP1) 或更高版本的计算机上纠正此问题

  1. 通过设置以下注册表参数来禁用热添加内存功能：

    路径

    HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

    值

    DynamicMemory

    类型

    REG_DWORD

    数据

    0x1
    注意：
    如果启动时安装的物理内存不很大，则该配置参数的值表示为最大可寻址物理内存值 (GB)，包括热添加内存。通过将该值设置为 1，内核为总计 1 GB 的系统内存或在启动时安装的总物理内存量保留空间，以较大的值为准。

  2. 重新启动计算机
在运行未安装 SP1 的 Windows Server 2003 的计算机上纠正此问题

  • 与硬件供应商联系，以确定是否可以在 BIOS 中禁用热添加内存功能。

  • 如果无法通过硬件控制热添加内存，建议的方法是升级到 Windows Server 2003 SP1 并按照此处所述的解决步骤来实现 DynamicMemory 参数。如果无法升级到 SP1，则备选方法是在 Boot.ini 文件中设置 /NOPAE 选项。设置此选项将强制计算机不识别任何超出 4 GB 范围的内存。在运行 SP1 之前的 Windows Server 2003 的计算机上使用此选项，但是不应在运行 SP1 的计算机上使用此选项，因为这样可能会无意中禁用包括阻止数据执行 (DEP) 支持在内的一些新功能。

详细信息

有关 Windows Server 2003 中的热添加内存支持的详细信息，请参阅"Hot-Add Memory Support in Windows Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=57183)。


Internet SCSI Initiator 软件已过时
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2006-04-03

Microsoft® Exchange Server 分析工具查询 Win32_SCSIController Microsoft Windows® Management Instrumentation (WMI) 类，以确定 iScsciPrt 驱动程序的 DriverName 关键字的值。Exchange Server 分析工具还查询 CIM_Datafile WMI 类，以确定 iScsciPrt 驱动程序文件中列出的 Version 关键字的值。如果 Exchange Server 分析工具发现 iScsciPrt 驱动程序 Version 关键字的子字符串值小于 1748，则显示警告。

Internet 小型计算机系统接口 (iSCSI) 是一种基于 Internet 协议（基于 IP）的方法，它专门用于发送小型计算机系统接口 (SCSI) 命令，这些命令是通过 TCP/IP 网络在 IP 包中封装的。由于 iSCSI 基于 IP，因此数据可以通过局域网 (LAN)、广域网 (WAN) 和 Internet 传输到远程存储位置。Microsoft Windows 操作系统将 Exchange Server 2003 或 Exchange 2000 Server 等程序的 iSCSI 硬盘显示为直接连接到 Exchange Server 计算机的硬盘。

Microsoft 建议您在部署具有 iSCSI 的 Exchange Server 2003 或具有 iSCSI 的 Exchange 2000 Server 时务必要谨慎。由于 iSCSI 使用 SCSI 传输协议通过 TCP/IP 网络传输块数据，因此这种网络的参与可以引入传统上认为不是高速输入/输出路径的组件。若要最大化吞吐量，必须配置 Exchange Server 以最大化缓存活动，还必须进行测试以验证 iSCSI 通信所涉及的延迟为最小值。除非您的存储设备供应商另有说明，否则还强烈建议您使用 Microsoft iSCSI Software Initiator 的最新可用内部版本。

解决此警告问题

  1. 从 Microsoft 下载中心 (http://go.microsoft.com/fwlink/?LinkId=33817) 下载 Microsoft iSCSI Software Initiator 的最新版本。

  2. 在 Microsoft 网站 (http://go.microsoft.com/fwlink/?LinkId=40951) 上查看发行说明。

  3. 在 Microsoft 网站 (http://go.microsoft.com/fwlink/?LinkId=40963) 上查看用户指南。

  4. 对计算机进行完整备份。

  5. 应用最新版本的更新。

有关 Exchange 2000 Server 和 Exchange Server 2003 中的 iSCSI 支持的详细信息，请参阅 Microsoft 知识库文章 839686"Support for iSCSI technology components in Exchange Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839686)。

有关 iSCSI 技术以及 Microsoft 的 iSCSI 支持的详细信息，请参阅 Microsoft 网站上的"Microsoft Storage Technologies - iSCSI"（英文）(http://go.microsoft.com/fwlink/?LinkId=27514)。


逻辑和物理磁盘性能计数器已禁用
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已禁用逻辑和物理磁盘性能计数器：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Perfdisk\Performance\Disable Performance Counters

如果 Exchange Server 分析工具发现 Disable Performance Counters 的值存在并配置为 1，则显示警告。

有两种与磁盘有关的性能计数器已针对运行 Microsoft Windows® 操作系统的服务器计算机发布：

  • Microsoft Win32® 性能子系统和 Windows Management Instrumentation (WMI) 使用的性能计数器。

  • 调用 IOCTL_DISK_PERFORMANCE API 检索原始计数器信息的旧版应用程序使用的性能计数器。

  • Win32 和 WMI 使用的性能计数器默认情况下在 Microsoft Windows Server™ 2003 和 Windows 2000 Server 上启用。原始计数器默认情况下在这两个操作系统上被禁用。如果 Disable Performance Counters 注册表值（默认情况下不存在于这两个操作系统上）已添加并配置为 1，则 Win32/WMI 性能计数器将被禁用，并且这些计数器的性能数据收集将无法完成。

禁用 Win32/WMI 计数器的最常用方法是使用可扩展计数器列表工具 (ExCtrLst.exe)。这是一个在 Windows 2000 Server 和 Windows Server 2003 资源工具包中提供的图形工具。管理员可以使用它选择性地启用或禁用性能对象的发布。当使用 ExCtrLst.exe 禁用性能对象时，会将 Disable Performance Counters 项添加到注册表中并将它的值配置为 1。如果之后使用 ExCtrLst.exe 重新启用已禁用的计数器，会将 Disable Performance Counters 的值更改为 0。（注意，Disable Performance Counters 项不删除）。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\SYSTEM\CurrentControlSet\Services\Perfdisk\Performance

  3. 在右侧窗格中，双击"Disable Performance Counters"并将它的值设置为 0。或者，可以删除 Disable Performance Counters 项以便重新启用计数器。

  4. 退出注册表编辑器，并重新启动收集性能数据的任意应用程序，以使更改生效。

有关 ExCtrLst.exe 的详细信息，请参阅"Exctrlst.exe:Extensible Performance Counter List"（英文）(http://go.microsoft.com/fwlink/?linkid=34436)。


检测到多个默认网关
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_NetworkAdapterConfiguration Microsoft Windows® Management Instrumentation (WMI) 类，以确定 DefaultIPGateway 关键字的实例数。每个网络适配器都通过此关键字将其已配置的默认网关地址发布到 WMI。如果 Exchange Server 分析工具确定存在 DefaultIPGateway 关键字的 1 个以上的配置实例，则会显示警告。

此警告意味着找到了多个网络适配器，并且其中的一个以上的适配器配置了默认网关。当使用多个适配器时，如果为这些适配器配置不同的默认网关，则与远程网络中的计算机的连接可能断开。此外，已确知当使用链接到不同网络子网的多个默认网关时会导致域名系统 (DNS) 解析、简单邮件传输协议 (SMTP) 邮件传递、轻型目录访问协议 (LDAP) 查询以及 Microsoft Office Outlook® 2003 客户端的新邮件通知出现问题。其中的许多问题会导致 Exchange Server 无法启动，或者无法发送和接收邮件。

建议仅仅在 Exchange Server 计算机上的一个网络接口适配器中保留一个默认网关，而删除其他所有网关。如果 Exchange Server 计算机上同时安装了 Microsoft Internet Security and Acceleration (ISA) Server，则该计算机通常是多宿主的。即便当在同一台计算机上运行 Exchange Server 和 ISA Server 时，也不推荐使用多个默认网关。如果 Exchange Server 和 ISA Server 未安装在同一台计算机上，则建议不要使 Exchange Server 计算机成为多宿主计算机。

解决此警告问题

  1. 打开"网络连接"窗口。用鼠标右键单击"网上邻居"，再单击"属性"，或者，如果"网上邻居"没有显示在桌面上，请单击"开始"，单击"程序"，单击"附件"，单击"通讯"，再单击"网络连接"。

  2. 在"网络连接"窗口中，用鼠标右键单击包含要删除的默认网关条目的网络连接，再单击"属性"。

  3. 选择"Internet 协议 (TCP/IP)"，再单击"属性"。

  4. 删除"默认网关"字段中的 IP 地址。

  5. 单击"确定"两次保存更改。

  6. 对包含默认网关条目的其他所有网络连接（包含要保留的条目的网络连接除外）重复上述过程。

有关使用多个默认网关的计算机上出现的问题的详细信息，请参阅 Microsoft 知识库文章 159168"Multiple Default Gateways Can Cause Connectivity Problems"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=159168)。

有关在多宿主计算机上配置默认网关的详细信息，请参阅知识库文章 157025"多宿主计算机的默认网关配置"(http://support.microsoft.com/kb/157025/zh-cn)。


页面文件大小超过总物理内存
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2007-07-30

Microsoft Exchange 分析工具查询 Win32_PageFile Windows® Management Instrumentation (WMI) 类，以确定 MaximumSize 关键字的值。此关键字代表当前配置的最大页面文件大小。

Exchange 分析工具还查询 Win32_ComputerSystem WMI 类，以确定 TotalPhysicalMemory 关键字的值。该值代表计算机上安装的 RAM 数目。

如果 Exchange 分析工具确定 Win32_PageFile MaximumSize 关键字的值比 Win32_ComputerSystem TotalPhysicalMemory 关键字的值大 1.5 倍，就会显示错误。

页面文件 (pagefile.sys) 是 Windows 所使用的硬盘上的一个隐藏文件，在系统 RAM 不足时保留临时数据。页面文件也称为分页文件或交换文件。虚拟内存由页面文件和 RAM 组成。

建议的页面文件大小相当于 RAM 量的 1.05 倍，最大为 4,095 MB。这意味着每个卷可以设置的最大分页文件大小为 4,095 MB。

注意：
为了避免出现页面文件碎片，建议将分页文件大小的初始值和最大值设置为同一个值。如果减小初始页面文件或最大页面文件设置的大小，则必须重新启动计算机才能看到更改的效果。增大时通常不需要重新启动。
更改页面文件设置

  1. 依次单击"开始"、"控制面板"，再单击"系统"。

  2. 在"高级"选项卡上的"性能"下，单击"设置"。

  3. 在"性能选项"对话框中的"高级"选项卡上，单击"虚拟内存"下的"更改"。

  4. 在"驱动器 [卷标]"下，单击包含要更改的分页文件的驱动器。

  5. 在"所选驱动器的页面文件大小"下，单击"自定义大小"，在"初始大小 (MB)"和"最大值 (MB)"字段中以 MB 为单位输入建议的页面文件大小，再单击"设置"。

有关页面文件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 197379"Configuring paging files for optimization and recovery in Windows Server 2003, in Windows 2000, and in Windows NT"（可能为英文网页）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379)

  • 307973,"How to configure system failure and recovery options in Windows"（可能为英文网页）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307973)

  • 254649,"Overview of memory dump file options for Windows Server 2003, Windows XP, and Windows 2000"（可能为英文网页）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=254649)

  • 241046,"Cannot Create a Memory.dmp File on Computers with over 4 GB RAM"（可能为英文网页）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=241046)


辅 WINS 服务器地址为空
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_NetworkAdapterConfiguration Microsoft Windows® Management Instrumentation (WMI) 类，以确定是否为 WINSSecondaryServer 关键字设置了值。如果在 Exchange 服务器上该关键字的值为空，则会显示警告。

Exchange Server 2003 和 Exchange 2000 Server 有几个 NetBIOS 依赖项。此外，运行早于 Microsoft Office Outlook 2003 的 Microsoft Outlook® 版本的客户端也需要进行 NetBIOS 名称解析。例如，下列 Exchange 功能依赖于 NetBIOS 名称解析：

  • Exchange Server 2003 和 Exchange 2000 Server 安装程序，尤其是在群集服务器上。

  • Exchange Server 2003 或 Exchange 2000 Server 计算机上的 Exchange 邮箱合并向导 (ExMerge)。

  • 通过 Outlook Web Access 更改 Exchange Server 2003 或 Exchange 2000 Server 邮箱的密码。

  • Exchange Server 2003 或 Exchange 2000 Server 计算机上的 Exchange 系统管理器。

您可能能够安全地忽略该警告，具体情况取决于组织的网络拓扑结构。在由单个子网 NetBIOS 构成的网络上，广播通常能够处理 Exchange 部署的 NetBIOS 名称解析要求。

在大型组织中，通过广播进行 NetBIOS 名称解析可能无法正确运行。由于 NetBIOS 广播通常不能跨越子网，所以路由网络就需要以其他方法来解析 NetBIOS 名称。要这样做，首选的方法是 Windows Internet 名称服务 (WINS)。WINS 提供分布式数据库来注册和查询在网络上使用的计算机和组的 NetBIOS 名称的动态映射。WINS 将 NetBIOS 名称映射为 IP 地址，它是为了解决由于路由环境中的 NetBIOS 名称解析而发生的问题而设计的。WINS 是在使用 TCP/IP 上的 NetBIOS 的路由网络中进行 NetBIOS 名称解析的最佳选择。

在没有 WINS 的大型或子网化组织中，Exchange Server 2003 和 Exchange 2000 Server 的操作和功能尚未进行完全测试。Microsoft 要求在路由或分段网络上运行 Exchange 的公司使用 WINS 进行 NetBIOS 名称解析。不支持在没有 WINS 的路由或分段环境中运行 Exchange。

建议您部署至少包括两个 WINS 服务器的容错 WINS 环境。WINS 服务器可以充当客户端的主 WINS 服务器或辅 WINS 服务器。主和辅 WINS 服务器之间的差异在于客户端与它们联系的优先级。主 WINS 服务器是客户端执行它的 NetBIOS 名称服务操作时首先联系的服务器。只有当主 WINS 服务器无法完成请求时（例如，当客户端发出请求时它不可用，或者无法解析客户端的名称），客户端才联系辅 WINS 服务器。

如果主 WINS 服务器没有完成请求，则客户端会向它的辅 WINS 服务器发出相同的请求。如果为客户端配置了两个以上的 WINS 服务器，则客户端将尝试其他辅 WINS 服务器，直到列表中的所有 WINS 服务器都已尝试，或某个 WINS 服务器成功地响应了请求。客户端在使用辅 WINS 服务器之后，将定期尝试切换回主 WINS 服务器，以便由该服务器来完成将来的名称服务请求。

最佳做法是，至少在路由或分段网络中的 Exchange 服务器计算机上配置一个辅 WINS 服务器。

解决此警告问题

  1. 打开"网络连接"。

  2. 用鼠标右键单击想要配置的网络连接，再单击"属性"。

  3. 在"常规"选项卡（对于本地连接）或"网络"选项卡（对于所有其他连接）上，单击"Internet 协议 (TCP/IP)"，再单击"属性"。

  4. 单击"高级"，单击"WINS"选项卡，再单击"添加"。

  5. 在"TCP/IP WINS 服务器"中，键入辅助 WINS 服务器的 IP 地址，再单击"添加"。

  6. 对想要添加的其他每个 WINS 服务器 IP 地址，重复步骤 4 和 5，再单击"确定"。可以使用箭头键更改 WINS 服务器的优先顺序。

  7. 确保"启用 TCP/IP 上的 NetBIOS"处于选中状态。

  8. 单击"确定"保存更改。

有关 Exchange 的 NetBIOS 名称解析要求的详细信息，请参阅 Microsoft 知识库文章 837391"Exchange Server 2003 和 Exchange 2000 Server 需要 NetBIOS 名称解析才能实现全部功能"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=837391)。


服务器是虚拟 PC
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2007-03-28

Microsoft® Exchange Server 分析工具查询 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange Server 计算机的 Model 关键字的值。如果该项的值包含字符串"Virtual Machine"，将显示错误。

字符串"Virtual Machine"的存在意味着 Exchange Server 计算机运行在 Microsoft Virtual PC 200x 虚拟计算机内。Virtual PC 200x 是软件虚拟化解决方案，使用它可以在一个工作站上同时运行基于 PC 的多个操作系统。Microsoft 不支持在虚拟计算机或仿真器上运行任何版本的 Microsoft Exchange Server。这适用于运行在 Microsoft Virtual Server 200x、Microsoft Virtual PC 200x 或任何第三方虚拟计算机程序上的 Exchange Server。Microsoft Exchange Server 平台的设计和测试只是针对在物理硬件上运行而进行的，尤其是针对 Windows Server Catalog (http://go.microsoft.com/fwlink/?linkid=17219) 中列出的那些硬件平台。

更正此错误

  1. 将运行在 Virtual PC 200x 下的 Exchange Server 中的邮箱移至非虚拟 Exchange Server 计算机上。

  2. 重新连接所有公用文件夹，并在必要时传输虚拟 Exchange 服务器保留的所有角色。

  3. 将 Exchange 从虚拟计算机中卸载以便不再使用它，并将它从 Exchange 基础结构及 Active Directory® 目录服务中删除。

有关对在虚拟环境中运行的 Exchange Server 计算机的支持的详细信息，请参阅 Microsoft 知识库文章 320220"在硬件虚拟化软件上运行的 Exchange Server 2003 的支持策略"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320220)。

有关 Microsoft Virtual PC 的详细信息，请访问 Microsoft Virtual PC 主页 (http://go.microsoft.com/fwlink/?linkid=34663)。


该磁盘正在报错
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_DiskDrive Microsoft Windows® Management Instrumentation (WMI) 类，以确定每个磁盘的 Status 关键字的值。如果 Exchange Server 分析工具确定任一磁盘的 Status 关键字的值不等于 OK，则显示错误。

Status 关键字提供磁盘对象的当前状态。您可以定义各种操作状态和非操作状态。操作状态包括：

  • OK

  • Degraded

  • Pred Fail（诸如启用 SMART 功能的硬盘驱动器这样的元素可能正常工作，但预示在不久以后会发生故障）。

  • 非操作状态包括：

  • Error

  • Starting

  • Stopping

  • Service（在重新建立磁盘镜像、重新加载用户权限列表或其他管理工作期间，可以应用该状态）。

Status 关键字是从 CIM_ManagedSystemElement WMI 类继承而来的，它包括下列值：

  • OK

  • Error

  • Degraded

  • Unknown

  • Pred Fail

  • Starting

  • Stopping

  • Service

  • Stressed

  • NonRecover

  • No Contact

  • Lost Comm

通常，Microsoft 不提供有关如何排除特定硬件供应商的磁盘故障的文档。

更正此错误

  1. 验证所有磁盘和电缆连接是否正确，然后等待 10 分钟，再检查 Status 的值。

  2. 如果返回的值不是维护模式的值（例如，值不等于 Service），则应当执行硬盘制造商所建议的磁盘故障排除步骤。在某些情况下，硬盘制造商可能提供故障排除软件，您可以安装该软件来分析问题。

有关与 Exchange 相关的一般存储信息，请参阅 Microsoft 下载中心中的"Storage Solutions for Microsoft Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=1715)。

有关与 Microsoft Windows Server™ 2003 相关的一般存储信息，请参阅 Microsoft Windows Server 2003 TechCenter 中的"Windows Server 2003 Storage Services"（英文）(http://go.microsoft.com/fwlink/?LinkId=33811)。

有关与 Windows 2000 Server 相关的一般存储信息，请参阅 Windows 2000 网站中的"Windows 2000 Storage Services"（英文）(http://go.microsoft.com/fwlink/?LinkId=33812)。


此 Exchange 服务器的处理器数量超过 8 个
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 NumberOfProcessors 的当前值。如果 Exchange Server 分析工具发现 NumberOfProcessors 的值大于 8，则会显示警告。但是，如果已将此服务器配置为使用 Intel 超线程技术，则可以安全地忽略该警告。通过超线程技术，多线程软件应用程序可以并行运行多个线程。超线程技术要求所使用的计算机系统必须配有支持超线程技术的 Intel Pentium 4 处理器，以及支持超线程技术的芯片集、BIOS 和操作系统。

Exchange 2000 Server 和 Exchange Server 2003 在一台计算机上只能有效地使用八个处理器。特别是，Microsoft Exchange 信息存储服务针对八个处理器进行了最优化。

对于处理器数量超过八个的计算机，建议您使用硬件分区将计算机分区为多个八台处理器的计算机或多个四台处理器的计算机。或者，可以将 Microsoft Exchange 信息存储进程 (Store.exe) 的 CPU 关联配置为仅八个处理器。

通过 CPU 关联或硬件分区将 Microsoft Exchange 信息存储进程限制为八个处理器后，建议您立即升级到可用的最新 Service Pack 和 Exchange 更新汇总。如果您运行的是 Exchange Server 2003，则这一点尤为重要。

以前，当后端服务器的处理器数量超过四个时，Exchange 服务器性能的改进余地很小。如果使用的处理器数量超过八个，即使在最好的情况下，其性能改进的余地也很小，并且有时性能会降低。附加处理器产生的性能增加范围的下降随着新型计算机上使用的处理器类型的发展而变得更加显著。使用 Exchange Server 2003 Service Pack 1，大大改进了附加处理器的可伸缩性。启用超线程后，现在八个处理器的服务器性能比四个处理器的服务器性能提高了 50%。当前，使用八个处理器的计算机作为后端服务器在许多方案中都是比较合适的。但是，仍然建议使用双处理器的服务器作为前端服务器。

如上所述，如果此 Exchange Server 计算机正在使用超线程技术，则可以安全地忽略该警告。

在未使用超线程技术的系统中解决此警告问题

  1. 应用最新的 Service Pack 和 Exchange 更新汇总，您可以从 Downloads for Exchange Server 2003 网站 (http://go.microsoft.com/fwlink/?linkid=25097) 下载。

  2. 将 Microsoft Exchange 信息存储服务 (Store.exe) 的 CPU 关联设置为八个 CPU，或使用硬件分区创建八个处理器的 Exchange 服务器。有关如何执行此操作的详细信息，请与您的硬件制造商联系。

有关 Exchange Server 资源可伸缩性的详细信息，请参阅 Microsoft 知识库文章 827281"CPU and Memory Scalability for Exchange 2000 and Exchange 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827281)。

有关详细信息，也可参阅知识库文章 271088"XGEN:Optimizing Windows 2000 Active Directory Servers with Six or Eight Processors to Run with Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=271088)。

有关超线程技术的详细信息，请访问 Intel 网站 (http://www.intel.com/info/hyperthreading)。

注意：
Web 地址可能会改变，所以，也许无法连接到此处提到的网站。


此 Exchange 服务器具有 4 GB 以上的内存
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2006-06-20

Microsoft® Exchange Server 分析工具查询 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定每台 Exchange Server 计算机的 TotalPhysicalMemory 关键字的值。

如果 Exchange Server 分析工具发现 TotalPhysicalMemory 的值大于 4294967296 但小于 6442450944，则显示警告。

如果 Exchange Server 分析工具发现 TotalPhysicalMemory 的值大于 6442450944，则显示错误。

如果 TotalPhysicalMemory 的值大于 4294967296，则指示 Exchange Server 计算机安装的内存量超过 4 GB，而 TotalPhysicalMemory 的值大于 6442450944 则指示 Exchange Server 计算机安装的内存量超过 6 GB。在物理内存达到或超过 4 GB 的计算机上，Exchange Server 使用的内存不会超过 3 GB。因此，如果该计算机仅仅用于运行 Exchange Server，则安装 4 GB 以上的内存是无益的。

更重要的是，物理 RAM 越大，执行必要的虚拟 - 物理映射所需的内核地址条目就越多。这会减少系统可用的系统页表项 (PTE) 和页面缓冲池内存，从而可能影响稳定性。

例如，与物理 RAM 为 4 GB 的计算机相比，物理 RAM 为 8 GB 的计算机少了 3,000 个可用系统页表项 (PTE)，并且最大页面缓冲池大小也减少了 30 MB。

建议采用下面两个解决方案中的某一个：

  • 将系统中的内存量减少到 4 GB

  • 按照本文后面的说明对 Boot.ini 文件中的 BurnMemory 参数进行设置，以将物理内存减少为 4 GB。

此外，如果运行要求额外内存的多个应用程序，可以运行一个 Windows 修补程序，以帮助防止当可用 RAM 超过 4 GB 时 Exchange 信息存储可能出现的故障。请注意，推荐的最佳实践是专门使用一台计算机来运行 Exchange Server。有关修补程序的详细信息，请参阅 Microsoft 知识库文章 834628"Data is corrupted when PAE is enabled on a Windows Server 2003-based computer"（英文）(http://go.microsoft.com/fwlink/?linkid=3052)。

解决此警告问题

  1. 在 Windows 资源管理器中，导航至系统分区。

  2. 如果看不到 boot.ini 文件，可能是由于"文件夹选项"设置为"隐藏受保护的操作系统文件"。如果是这种情况，请在 Windows 资源管理器中，单击"工具"，再单击"文件夹选项"，然后单击"查看"选项卡。清除"隐藏受保护的操作系统文件（推荐）"复选框。当出现警告对话框时，单击"是"。

  3. 当 boot.ini 文件显示在资源管理器中后，用鼠标右键单击该文件，再单击"打开方式"，然后选择"记事本"打开该文件。

  4. 在 [Operating Systems] 部分中，向启动行添加以下开关：/BURNMEMORY=<Value in MB>

    例如：

    如果安装了 6 GB 的物理内存，请使用 /BURNMEMORY=2048，将可用的内存减少到 4 GB。如果安装了 8 GB 的物理内存，请使用 /BURNMEMORY=4096。

  5. 保存更改，关闭记事本。

  6. 重新启动 Exchange Server 计算机以使更改生效。

有关 Boot.ini 文件中可以使用的参数的详细信息，请参阅下列 Microsoft 知识库文章：

  • 833721: "Windows XP 和 Windows Server 2003 的 Boot.ini 文件的可用开关选项"(http://go.microsoft.com/fwlink/?linkid=3052)

  • 102873: "BOOT.INI 和 ARC 路径命名约定与用法"(http://go.microsoft.com/fwlink/?linkid=3052)


此逻辑磁盘的可用空间小于 3 GB
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2007-03-14

Microsoft® Exchange Server 分析工具查询 Win32_LogicalDisk Microsoft Windows® Management Instrumentation (WMI) 类，以确定其 Win32_LogicalDisk DriveType 关键字设置为 3（表示本地磁盘）的磁盘的 FreeSpace 关键字的值。如果 Exchange Server 计算机中本地磁盘的 FreeSpace 关键字的值小于 3 GB，则会显示警告。建议 Exchange Server 计算机中所有包含邮箱的磁盘始终至少保留 50% 的可用空间。

具有足够的磁盘容量至关重要。当数据库磁盘空间不足时，数据库将脱机。事务日志磁盘空间不足时，将导致该存储组中的所有数据库脱机。提供其他空间通常很难快速进行，而执行脱机压缩回收空间可能要花费很长的时间。大多数情况下，磁盘空间不足可导致一个或多个数据库在一段时间内无法使用，这通常超出了大多数恢复时间目标 (RTO)。

解决此警告问题

  1. 从该磁盘中删除不必要的文件，以释放磁盘空间。

  2. 如果可用空间小于 50% 的磁盘中包含可以安全移到另一磁盘（例如邮箱或 Windows 页面文件）的数据，请执行移动数据所需的步骤。

  3. 为 Exchange Server 计算机添加磁盘容量。

有关使用 Exchange Server 2003 移动邮箱的详细信息，请参阅 Microsoft 知识库文章 821829"在 Exchange Server 2003 中移动邮箱"(http://support.microsoft.com/kb/821829/zh-cn)。

有关在 Exchange 2000 Server 和 Exchange Server 5.5 之间移动邮箱的详细信息，请参阅知识库文章 328810"在服务器之间移动邮箱"(http://support.microsoft.com/kb/328810/zh-cn)。

有关在 Exchange Server 2003 上使用系统策略设置邮箱限制的详细信息，请参阅知识库文章 822938"如何在 Exchange Server 2003 中使用系统策略配置邮箱存储限制"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822938)。

有关在 Exchange 2000 Server 上使用系统策略设置邮箱限制的详细信息，请参阅知识库文章 319130"如何在 Exchange Server 2000 中使用系统策略配置邮箱存储限制"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319130)。

有关详细信息


此装入点至少应有 3 GB 的可用空间
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Volume Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange Server 计算机使用的卷装入点的 FreeSpace 关键字的值。如果 FreeSpace 的值除以 1,000,000,000 所得到的结果向上舍入到最近的整数后小于 4，则会显示警告。

此警告意味着卷装入点的可用存储空间不足 3 GB。在 Exchange Server 2003 中，如果 Exchange Server 2003 安装在运行 Microsoft Windows Server™ 2003 企业版或 Windows Server 2003 Datacenter 版的计算机上，那么在群集配置中支持将卷装入点（也称为 NTFS 文件系统交接点）作为一个数据存储位置。使用 NTFS 卷装入点功能，可以超越 26 个驱动器号的限制。通过使用卷装入点，可以将目标分区移植或装入到另一个物理磁盘上的文件夹中。卷装入点对于像 Exchange Server 2003 这样的程序是透明的。

在下列方案中不支持装入点：

  • 当它们用作 Exchange Server 2003 二进制数据的存储位置时。

  • 当它们与运行 Microsoft Exchange 2000 Server 或更早版本的 Exchange 群集一起使用时。

  • 当它们与运行 Microsoft Windows 2000 Server 或更早版本的 Windows 群集一起使用时。

无论 Exchange Server 使用的卷是本地物理磁盘、逻辑卷还是卷装入点，关于 Exchange Server 实现的最佳实践都是在所有驱动器上至少留有 50% 的可用磁盘空间。作为常规的经验法则，Microsoft 建议至少留出 25% 到 30% 的可用磁盘空间用于 Exchange 维护，例如使用 Eseutil 和 Isinteg 等数据库实用程序执行的任务。此外，对于某些维护操作（如脱机碎片整理），Microsoft 建议可用空间应达到进行碎片整理的空间量的 100%。例如，如果要对 1 GB 的数据库进行碎片整理，那么至少应有 1 GB 的可用磁盘空间。

此外，从安全的角度以及可用性的角度来看，拥有充足的可用磁盘空间也很有益。普遍存在的拒绝服务攻击、邮件循环或病毒爆发可能会导致由于邮件通信、事务日志活动等活动的增加，磁盘空间被过度消耗。

解决此警告问题

  1. 调查可以从哪些方面回收磁盘空间从而增加可用空间。

  2. 如果磁盘空间非常小，应考虑将数据移至另一个 Exchange Server 计算机或没有空间约束的 Exchange 虚拟服务器上。如果还没有这样做，在管理磁盘的使用时，设置邮箱限制也很有用。

有关在 Exchange Server 2003 群集中使用卷装入点的详细信息，请参阅 Microsoft 知识库文章 318458"Volume Mount Point Support for an Exchange Server 2003 Cluster on a Windows Server 2003-based System"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=318458)。

有关在 Windows Server 2003 群集中使用卷装入点的详细信息，请参阅知识库文章 280297"如何在群集服务器上配置卷装入点"(http://support.microsoft.com/kb/280297/zh-cn)。


该网卡是启用 DHCP 的网卡
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_NetworkAdapterConfiguration Microsoft Windows® Management Instrumentation (WMI) 类，以确定是否为 DHCPEnabled 属性设置了值。如果在 Exchange 服务器上该属性的值是一 (1)，则会显示错误。

在启用 DHCP 的网卡上运行 Exchange 是受支持的配置。但是，建议不要使用该配置。在启用 DHCP 的计算机上运行 Exchange 不是最佳做法，因为如果 DHCP 服务失败或中断，则 Exchange 可能停止传递邮件或可能发生其他情况的失败。

建议将所有运行 Exchange 的计算机配置为使用静态 IP 地址。

有关设计 Windows TCP/IP 网络的详细信息，请参阅 Microsoft TechNet 网站上的"Networking"（英文）(http://go.microsoft.com/fwlink/?LinkId=33819)。


主 WINS 服务器地址为空白
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_NetworkAdapterConfiguration Microsoft Windows® Management Instrumentation (WMI) 类，以确定是否已为 WINSPrimaryServer 关键字设置值。如果 Exchange Server 分析工具发现 Exchange 服务器上的该关键字的值为空白，则显示警告。

Exchange Server 2003 和 Exchange 2000 Server 有几个 NetBIOS 依赖项。此外，运行早于 Microsoft Office Outlook 2003 的 Microsoft Outlook® 版本的客户端也需要进行 NetBIOS 名称解析。例如，下列 Exchange 功能依赖于 NetBIOS 名称解析：

  • Exchange Server 2003 和 Exchange 2000 Server 安装程序，尤其是在群集服务器上。

  • Exchange Server 2003 或 Exchange 2000 Server 计算机上的 Exchange 邮箱合并向导 (ExMerge)。

  • 通过 Outlook Web Access 更改 Exchange Server 2003 或 Exchange 2000 Server 邮箱的密码。

  • Exchange Server 2003 或 Exchange 2000 Server 计算机上的 Exchange 系统管理器。

如果组织采用的是某一种特定的网络拓扑，您可能能够放心地忽略此警告。在由单个子网组成的网络中，NetBIOS 广播通常可以处理 Exchange 部署中的 NetBIOS 名称解析要求。

在大型组织中，通过广播进行的 NetBIOS 名称解析不会正常工作。由于 NetBIOS 广播通常不跨越子网，因此在路由的网络中必须采用另一种方法来解析 NetBIOS 名称。首选的方法是 Windows Internet 名称服务 (WINS)。WINS 提供分布式数据库来注册和查询在网络上使用的计算机和组的 NetBIOS 名称的动态映射。WINS 将 NetBIOS 名称映射到 IP 地址。设计它是为了解决由于路由环境中的 NetBIOS 名称解析而导致的问题。对于使用 TCP/IP 上的 NetBIOS 的路由网络中的 NetBIOS 名称解析而言，WINS 是最佳选择。

在没有 WINS 的大型或子网化组织中，Exchange Server 2003 和 Exchange 2000 Server 的操作和功能尚未进行完全测试。Microsoft 要求在路由或分段网络上运行 Exchange 的公司使用 WINS 进行 NetBIOS 名称解析。不支持在没有 WINS 的路由环境或分段环境中运行 Exchange。

建议部署至少包含两台 WINS 服务器的 WINS 环境以实现容错。WINS 服务器可以充当客户端的主 WINS 服务器或辅 WINS 服务器。主 WINS 服务器与辅 WINS 服务器仅仅在客户端与之联系的优先级上有所不同。当客户端要执行其 NetBIOS 名称服务操作时，首先与主 WINS 服务器联系。只有当主 WINS 服务器无法完成请求时（例如，当客户端发出请求时它不可用，或者无法解析客户端的名称），客户端才联系辅 WINS 服务器。

如果主 WINS 服务器未完成请求，客户端将向辅 WINS 服务器发出同样的请求。如果为客户端配置了两台以上的 WINS 服务器，客户端将尝试额外的辅 WINS 服务器，直到列表中的所有 WINS 服务器都已尝试，或者某个 WINS 服务器成功地响应了请求。客户端在使用辅 WINS 服务器之后，将定期尝试切换回主 WINS 服务器，以便由该服务器来完成将来的名称服务请求。

最佳实践是在路由网络或分段网络中的 Exchange 服务器计算机上至少配置一台辅 WINS 服务器。

解决此警告问题

  1. 打开"网络连接"。

  2. 用鼠标右键单击要配置的网络连接，再单击"属性"。

  3. 在"常规"选项卡（本地连接）或"网络"选项卡（其他所有连接）上，单击"Internet 协议 (TCP/IP)"，再单击"属性"。

  4. 依次单击"高级"、"WINS"选项卡、"添加"。

  5. 在"TCP/IP WINS 服务器"中，键入 WINS 服务器的 IP 地址，再单击"添加"。

  6. 对要添加的其他每个 WINS 服务器 IP 地址重复步骤 4 和步骤 5，然后单击"确定"。可以使用箭头键更改 WINS 服务器的优先顺序。

  7. 确保"启用 TCP/IP 上的 NetBIOS"处于选中状态。

  8. 单击"确定"保存更改。

有关 Exchange 的 NetBIOS 名称解析要求的详细信息，请参阅知识库文章 837391"Exchange Server 2003 and Exchange 2000 Server require NetBIOS name resolution for full functionality"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=837391)。


检测到虚拟服务器
Microsoft Exchange Server 分析工具 - 文章 > 硬件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Model 关键字的值是否设置为 Virtual Machine。

Exchange Server 分析工具还检查是否存在以下注册表值：

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

如果 Exchange Server 分析工具发现 Model 关键字包含字符串 Virtual Machine，并且存在上述注册表分支，则显示错误。

Model 关键字的值为 Virtual Machine 说明 Exchange Server 计算机正在作为来宾虚拟计算机运行在 Microsoft Virtual Server 2005 或 Microsoft Virtual PC 2004 中。由于上述注册表分支只能由 Virtual Server 2005 创建，因此它的存在意味着 Exchange Server 计算机正在作为来宾虚拟计算机运行在 Microsoft Virtual Server 2005 中。

Microsoft 不支持在虚拟计算机或仿真器上运行任何版本的 Microsoft Exchange Server。这适用于运行在 Microsoft Virtual Server 2005、Microsoft Virtual PC 2004 或任何第三方虚拟计算机程序上的 Exchange Server。Microsoft Exchange Server 平台的设计和测试只是针对在物理硬件上运行而进行的，尤其是针对 Microsoft Windows Server Catalog (http://go.microsoft.com/fwlink/?linkid=17219) 中列出的那些硬件平台。

更正此错误

  1. 将运行在 Virtual Server 2005 下的 Exchange Server 中的邮箱移至非虚拟 Exchange Server 计算机上。

  2. 重新连接所有公用文件夹，并在必要时传输虚拟 Exchange 服务器保留的所有角色。

  3. 将 Exchange 从虚拟计算机中卸载以便不再使用它，并将它从 Exchange 基础结构及 Active Directory® 目录服务中删除。

有关移动邮箱的详细信息，请参阅下列 Microsoft 知识库文章：

  • 822892"在 Exchange 2003 中移动邮箱工具的改进"(http://support.microsoft.com/kb/822892/zh-cn)

  • 224975"XADM:Differences Between Move Mailbox Methods"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

有关 Microsoft Virtual Server 2005 的详细信息，请参阅网站上的"Microsoft Virtual Server 2005"（英文）(http://go.microsoft.com/fwlink/?LinkId=34938)。

有关 Microsoft Virtual PC 2004 的详细信息，请参阅网站上的"Microsoft Virtual PC 2004"（英文）(http://go.microsoft.com/fwlink/?linkid=34663)。


网络
Microsoft Exchange Server 分析工具 - 文章 >

主题上次修改时间： 2005-11-18

本部分中的文章详细介绍了 Microsoft® Exchange Server 分析工具对网络进行的相关评估。此外，这些文章还描述了为解决由 Exchange Server 分析工具发现的与网络有关的错误、警告和非默认配置所能采取的措施。


DNS"主机"记录可能已丢失
Microsoft Exchange Server 分析工具 - 文章 > 网络 >

主题上次修改时间： 2006-04-13

Microsoft® Exchange Server 分析工具在域名系统 (DNS) 服务器上执行 DNS 查找操作，以检索 Exchange 服务器的主机 (A) 记录。如果 DNS 查找操作没有返回任何 IP 地址，Exchange Server 分析工具就会显示警告，指出主机 (A) 记录可能已丢失。

对 Exchange Server 2003 计算机的主机 (A) 记录进行 DNS 查找失败的可能原因如下：

  • DNS 服务器关机，或者因为网络故障等原因而无法作出响应。

  • DNS 服务器上丢失 Exchange Server 2003 主机 (A) 记录的可能原因为：记录不可用或出错，或者没有将 DNS 服务器配置为允许动态主机记录更新。

如果 DNS 服务器关机，将导致邮件路由延迟和其他服务故障。

注意：
对于网络中的本地和外部基于 SMTP 的邮件系统，Exchange Server 2003 都依赖主机名解析。主机名解析主要基于 DNS，因此 DNS 是关键的网络服务。DNS 服务器故障将使用户找不到您的邮件系统。没有 DNS，Active Directory 和 Exchange Server 2003 组织将无法工作。邮件客户端通过查询 DNS 来定位域控制器和邮箱服务器等内部资源。另一方面，在目录查找时，Exchange Server 2003 依赖 DNS 检索域控制器的 Internet 协议 (IP) 地址，而向 Internet 发送邮件时，它依赖 DNS 检索外部的简单邮件传输协议 (SMTP) 主机的 IP 地址。

若要解决该问题，请确认 DNS 服务器正在运行，并且已注册主机 (A) 记录。

确认 DNS 服务器联机，并且存在主机记录

  1. 通过执行以下一个或多个步骤，验证 DNS 服务器正在运行：

    • 使用 DNS 服务器上的 DNS 管理程序来检查 DNS 服务器的状态。

    • 重新启动 DNS 服务器。有关详细信息，请参阅"Start, stop, pause, or restart a DNS server"（英文）(http://go.microsoft.com/fwlink/?LinkId=62999)。

    • 使用 nslookup 检查 DNS 服务器的响应。有关详细信息，请参阅"Verify DNS server responsiveness using the nslookup command"（英文）(http://go.microsoft.com/fwlink/?LinkId=63000)。

  2. 使用 nslookup 验证 DNS 服务器上是否存在主机 (A) 记录。有关详细信息，请参阅"To verify A resource records exist in DNS"（英文）(http://go.microsoft.com/fwlink/?LinkId=63001)。

  3. 如果主机 (A) 资源记录不存在，请手动添加或修改 A 资源记录，或配置 DNS 服务器为允许动态记录更新。

    • 手动添加 A 资源记录。有关详细信息，请参阅"Add a resource record to a DNS zone"（英文）(http://go.microsoft.com/fwlink/?LinkId=63002)。

    • 手动修改 A 资源记录。有关详细信息，请参阅"Modify an existing resource record"（英文）(http://go.microsoft.com/fwlink/?LinkId=63014)。

    • 使 DNS 服务器允许动态主机记录更新。有关详细信息，请参阅 Microsoft 知识库文章 816592"How to configure DNS dynamic updates in Windows Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592)。
  • 有关 Exchange Server 2003 如何使用 DNS 解析外部 IP 地址的详细信息，请参阅 Exchange Server 2003 Transport and Routing Guide (http://go.microsoft.com/fwlink/?LinkId=47579) 中的"Transport Dependencies for Exchange Server 2003"（英文）。

  • 有关 DNS 名称解析的详细信息，请参阅 Microsoft 知识库文章 322856"如何配置 DNS 以用于 Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)。

  • 有关解决 DNS 问题的详细信息，请参阅"Troubleshooting DNS"（英文）(http://go.microsoft.com/fwlink/?LinkId=63003)。

有关 Exchange Server 2003 系统监视的详细信息，请参阅 Exchange Server 2003 Management Pack Guide for MOM 2000 SP1 (http://go.microsoft.com/fwlink/?LinkId=47573) 中的"System Monitoring with Exchange Server 2003 Management Pack"（英文）。

  • 有关主机 (A) 资源记录的详细信息，请参阅"Managing resource records"（英文）(http://go.microsoft.com/fwlink/?LinkId=63004)。


DNS 响应在 UDP 和 TCP 之间存在差异
Microsoft Exchange Server 分析工具 - 文章 > 网络 >

主题上次修改时间： 2007-03-16

Microsoft Exchange 分析工具查询 Win32_NetworkAdapterConfiguration Microsoft Windows Management Instrumentation (WMI) 类，以获取 DNSServerSearchOrder 属性。此属性是在查询域名系统 (DNS) 服务器时使用的服务器 IP 地址数组。

检索主 DNS 服务器的地址后，Exchange 分析工具将尝试对每个 Active Directory 目录服务服务器的已配置 DNS 服务器进行 DNS 查询。此连接是通过使用执行传输控制协议 (TCP) 和用户数据报协议 (UDP) 名称解析请求的自定义对象处理器建立的。

如果 TCP 和 UDP 名称解析请求都成功，则 Exchange 分析工具将比较成功的请求所返回的响应。如果 TCP 查询和 UDP 查询返回的响应不相同，则 Exchange 分析工具将显示警告。

此警告表明可能存在影响邮件流性能的 DNS 服务器配置问题。

简单邮件传输协议 (SMTP) 是 Exchange Server 进行邮件提交和邮件传输的本机邮件协议。这意味着客户端使用 SMTP 发送邮件，而 Exchange 服务器使用 SMTP 传递邮件和邮件数据。

Exchange Server 若要通过 SMTP 服务传递出站 Internet 邮件，则会按以下方法使用 DNS：

  1. 内部用户将邮件发送给远程域中的收件人。

  2. 若要确定收件人是本地的还是远程的，发件人 Exchange 服务器上的 SMTP 虚拟服务器使用内部传输功能查询收件人地址的全局编录服务器。如果邮件上的收件人地址不在收件人策略中，则不会将它存储在 Active Directory 中。因此，Exchange 确定该邮件将发往远程域。

  3. 如有必要，Exchange 服务器将邮件传递到适当的 SMTP 虚拟服务器。

  4. SMTP 虚拟服务器使用其 IIS 元数据库信息确定将邮件传递到远程域的方法。

  5. 然后 Exchange 服务器上的 SMTP 虚拟服务器执行下列两项操作之一：

    • 使用 DNS 查找目标域的 IP 地址，再尝试传递邮件。

    • 将邮件转发到负责 DNS 解析和邮件传递的智能主机。

若要解决此警告问题，请考虑 Microsoft 知识库文章 820284"服务器 OS 为 Windows Server 2003 时无法将邮件传递到某些域"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=820284) 中的指导。

有关 DNS 和 Exchange Server 的详细信息，请参阅下列 Microsoft 知识库文章和 Web 广播：

  • 322856"HOW TO：配置 DNS 以用于 Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237"XCON：Windows 2000 和 Exchange 2000 SMTP 使用 TCP DNS 查询"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759"支持 Web 广播：Microsoft Exchange 2000 Server：解决传输中的 DNS 问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


DNS 服务器正在运行 Exchange Server 以来宾身份安装在其中的 Virtual Server 2005
Microsoft Exchange Server 分析工具 - 文章 > 网络 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Model 关键字的值是否设置为 Virtual Machine。

Exchange Server 分析工具还检查是否存在以下注册表值：

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

此外，Exchange Server 分析工具还查询 Win32_Services WMI 类，以确定域名系统服务 (DNS) 是否在运行 Microsoft Virtual Server 2005 的物理计算机上运行。

如果 Exchange Server 分析工具发现 Model 关键字包含字符串 Virtual Machine，并且存在上述注册表分支，而且 DNS 正在运行，则显示错误。

Model 关键字的值为 Virtual Machine 说明 Exchange Server 计算机正在作为来宾虚拟计算机运行在 Virtual Server 2005 或 Virtual PC 2004 中。由于上述注册表分支只能由 Virtual Server 2005 创建，因此它的存在意味着 Exchange Server 计算机正在作为来宾虚拟计算机运行在 Virtual Server 2005 中。

Microsoft 不支持在虚拟计算机或仿真器上运行任何版本的 Microsoft Exchange Server。这适用于运行在 Virtual Server 2005、Virtual PC 2004 或任何第三方虚拟计算机程序上的 Exchange Server。Microsoft Exchange Server 平台的设计和测试只是针对在物理硬件上运行而进行的，尤其是针对 Windows Server Catalog (http://go.microsoft.com/fwlink/?linkid=17219) 中列出的那些硬件平台。

而且，将 Exchange 作为 Virtual Server 2005 来宾运行在正在运行域名系统的计算机上不是最佳做法，因为它没有考虑到足够的跨服务冗余。

更正此错误

  1. 将运行在 Virtual Server 2005 下的 Exchange Server 中的邮箱移至非虚拟 Exchange Server 计算机上。

  2. 重新连接所有公用文件夹，并在必要时传输虚拟 Exchange 服务器保留的所有角色。

  3. 将 Exchange 从虚拟计算机中卸载以便不再使用它，并将它从 Exchange 基础结构及 Active Directory® 目录服务中删除。

有关移动邮箱的详细信息，请参阅下列 Microsoft 知识库文章：

  • 822892"在 Exchange 2003 中移动邮箱工具的改进"(http://support.microsoft.com/kb/822892/zh-cn)

  • 224975"XADM:Differences Between Move Mailbox Methods"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

有关对运行在虚拟环境中的 Exchange Server 计算机的支持的详细信息，请参阅知识库文章 320220"Support Boundaries for Exchange Server on a Virtual Machine or an Emulation Machine"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)。

有关 Microsoft Virtual Server 2005 的详细信息，请参阅网站上的"Microsoft Virtual Server 2005"（英文）(http://go.microsoft.com/fwlink/?linkid=34938)。

有关 Microsoft Virtual PC 2004 的详细信息，请参阅网站上的"Microsoft Virtual PC 2004"（英文）(http://go.microsoft.com/fwlink/?linkid=34663)。


外部 DNS 服务器响应在 UDP 和 TCP 之间存在差异
Microsoft Exchange Server 分析工具 - 文章 > 网络 >

主题上次修改时间： 2007-03-16

Microsoft Exchange 分析工具查询 Active Directory 目录服务，以确定每个 Exchange Server 对象的 protocolCfgSMTPServer 类中 msExchSmtpExternalDNSServers 属性的值。msExchSmtpExternalDNSServers 属性的值（如果已设置）指定简单邮件传输协议 (SMTP) 虚拟服务器实例使用的外部域名系统 (DNS) 服务器的地址。

检索外部主 DNS 服务器的地址后，Exchange 分析工具将尝试对每个 Active Directory 目录服务服务器的已配置 DNS 服务器进行 DNS 查询。此连接是通过使用执行传输控制协议 (TCP) 和用户数据报协议 (UDP) 名称解析请求的自定义对象处理器建立的。

如果 TCP 和 UDP 名称解析请求都成功，则 Exchange 分析工具将比较成功的请求所返回的响应。如果 TCP 查询和 UDP 查询返回的响应不相同，则 Exchange 分析工具将显示警告。

此警告表明可能存在影响邮件流性能的外部 DNS 服务器配置问题。

SMTP 是 Exchange Server 进行邮件提交和邮件传输的本机邮件协议。这意味着客户端使用 SMTP 发送邮件，而 Exchange 服务器使用 SMTP 传递邮件和邮件数据。

Exchange Server 若要通过 SMTP 服务传递出站 Internet 邮件，则会按以下方法使用 DNS：

  1. 内部用户将邮件发送给远程域中的收件人。

  2. 若要确定收件人是本地的还是远程的，发件人 Exchange 服务器上的 SMTP 虚拟服务器使用内部传输功能查询收件人地址的全局编录服务器。如果邮件上的收件人地址不在收件人策略中，则不会将它存储在 Active Directory 中。因此，Exchange 确定该邮件将发往远程域。

  3. 如有必要，Exchange 服务器将邮件传递到适当的 SMTP 虚拟服务器。

  4. SMTP 虚拟服务器使用其 IIS 元数据库信息确定将邮件传递到远程域的方法。

  5. 然后 Exchange 服务器上的 SMTP 虚拟服务器执行下列两项操作之一：

    • 使用 DNS 查找目标域的 IP 地址，再尝试传递邮件。

    • 将邮件转发到负责 DNS 解析和邮件传递的智能主机。

若要解决此警告问题，请参阅 Microsoft 知识库文章 820284"服务器 OS 为 Windows Server 2003 时无法将邮件传递到某些域"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=820284)。

有关 DNS 和 Exchange Server 的详细信息，请参阅下列 Microsoft 知识库文章和 Web 广播：

  • 322856"HOW TO：配置 DNS 以用于 Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237"XCON：Windows 2000 和 Exchange 2000 SMTP 使用 TCP DNS 查询"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759"支持 Web 广播：Microsoft Exchange 2000 Server：解决传输中的 DNS 问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


Network Bytes Total per second 超出阈值
Microsoft Exchange Server 分析工具 - 文章 > 网络 >

主题上次修改时间： 2006-02-13

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 Network Interface 性能对象的 Bytes Total/sec 性能计数器收集数据，以分析性能数据。

Bytes Total/sec 性能计数器显示网络适配器处理数据字节的速率。此计数器包含所有应用程序和文件数据以及协议信息（包括数据包头）。Bytes Total/sec 性能计数器是 Network Interface\Bytes Received/sec 和 Network Interface/Bytes Sent/sec 之和。

Exchange Server 分析工具在收集间隔期间报告性能计数器的最大值。对于每秒 100 MB 的网络适配器，Bytes Total/sec 性能计数器的值将低于 7 MB/秒。对于 1000 MB 的网络适配器，Bytes Total/sec 性能计数器的值将低于 70 MB/秒。如果 Bytes Total/sec 超过网络带宽的 7%，则 Exchange Server 分析工具将显示错误信息。

该错误通常表示该服务器正处于无反应阶段，这会导致邮件流变慢或停止。此外连接到该服务器的 Microsoft Outlook® 客户端可能收到一个"RPC 取消请求"对话框。

下面列出了一些可能导致该错误的原因：

  • 计算机上的网络接口卡 (NIC) 不支持网络基础结构所支持的最大带宽。

  • 服务器上的负载过大。

  • 病毒或垃圾邮件致使网络使用模式突然增加。

解决此错误

  • 如果 NIC 不支持网络最大带宽，请更新 NIC 以支持更快的带宽。

  • 减少服务器上的负载。通过将邮箱移到邮箱较少的服务器上，即可达到此目的。如果需要，可为当前环境添加一个额外的 Exchange 服务器。

  • 如果怀疑异常的高负载并不是由于服务器上拥有过多的邮箱而所造成的，请尝试识别异常高负载的来源并停止它。

  • 请考虑下列文章中提供的最佳做法：

    • 有关网络带宽注意事项的信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"的"Understanding Exchange Performance"中的"Network Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

    • 有关排除网络问题的信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"中的"Ruling Out Network-Bound Problems"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。


已启用网络接口卡 (NIC) 成组
Microsoft Exchange Server 分析工具 - 文章 > 网络 >

主题上次修改时间： 2006-10-16

Microsoft® Exchange Server 分析工具查询 Win32_NetworkAdapter Microsoft Windows® Management Instrumentation (WMI) 类，以确定绑定到 TCP/IP 协议的所有网络接口卡 (NIC)。

然后，Exchange Server 分析工具查询以下注册表分支，以确定这些适配器是否存在 TeamAdapters 项：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\%NICDEVICEID%\

如果 Exchange Server 分析工具确定正在分析的服务器上的一个或多个 NIC 存在 TeamAdapters 项，则 Exchange Server 分析工具将显示警告。

此警告表示所分析的 Exchange 服务器上已启用 NIC 分组。虽然 NIC 成组通常不是邮件流问题，但是应当对其加以注意，以确保使用最近可用的 NIC 驱动程序正确配置此成组。

若要解决该问题，请执行下列操作：

  • 如果邮件流问题出现于已启用 NIC 成组的服务器上，请先暂时禁用成组以查看是否已解决邮件流问题。

  • 将 NIC 驱动程序更新至可从 NIC 制造商处获得的最新版本。

  • 严格遵守 NIC 制造商的成组配置建议。

有关 NIC 成组的详细信息，请参阅下列 Microsoft 知识库文章：

  • 278431"使用具有网络负载平衡的成组适配器可能导致网络问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=278431)。

  • 814607"Microsoft 支持具有第三方系统组件的服务器群集"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=814607)。


网络出站数据包超出阈值
Microsoft Exchange Server 分析工具 - 文章 > 网络 >

主题上次修改时间： 2006-02-13

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询性能计数器对象。性能数据收集引擎从 Network Interface 性能对象的 Packet Outbound errors 性能计数器收集数据，以分析性能数据。

Packet Outbound errors 性能计数器表示由于错误而无法传输的出站数据包的数目。Packet Outbound errors 性能计数器的值应该为零。如果 Exchange Server 分析工具确定 Packet Outbound errors 性能计数器的值大于零，则将显示错误。

该错误通常表示该服务器正处于无反应阶段，这会导致邮件流变慢或停止。此外连接到该服务器的 Microsoft Outlook® 客户端可能收到一个"RPC 取消请求"对话框。

该错误很有可能是由网络接口卡 (NIC) 故障或损坏而引起的。

要解决此错误，必须确定导致出站数据包错误的原因，然后更正该问题。如果出站数据包错误由 NIC 故障引起，请立即更换卡。

请考虑下列文章中提供的最佳做法：

  • 有关网络带宽注意事项的信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=47576) 的"Understanding Exchange Performance"中的"Network Performance"（英文）。

  • 有关排除网络问题的信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"(http://go.microsoft.com/fwlink/?LinkId=47588) 中的"Ruling Out Network-Bound Problems"（英文）。


Network Output Queue length 超出阈值
Microsoft Exchange Server 分析工具 - 文章 > 网络 >

主题上次修改时间： 2007-02-13

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 Network Interface 性能对象的 Output Queue Length 性能计数器收集数据，以分析性能数据。

Output Queue Length 性能计数器按数据包显示输出数据包队列的长度。Exchange Server 分析工具在收集间隔期间报告性能计数器的最大值。如果平均值超过 10，则 Exchange Server 分析工具将显示错误。

此错误通常表示该服务器正处于无反应阶段，这会导致邮件流变慢或停止。此外，连接到该服务器的 Outlook 客户端可能会收到一个"RPC 取消请求"对话框。

下面列出了一些可能导致该错误的原因：

注意：
某些情况下，在运行 Microsoft Windows 2000 Server 操作系统的计算机上，Output Queue Length 性能计数器可能会持续显示一个大于零的随机值。有关可能会发生 Output Queue Length 性能显示随机值的情况，以及如何更正这种情况的详细信息，请参阅 Microsoft 知识库文章 834940"在 Windows 2000 中，系统监视器可能会为 Output Queue Length 性能计数器显示较大值"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=834940)。
  • 计算机上的网络接口卡 (NIC) 不支持网络基础结构所支持的最大带宽。

  • 服务器上的负载过大。

  • 病毒或垃圾邮件致使网络使用模式突然增加。

可以执行下列步骤来解决此错误：

  • 如果 NIC 不支持网络最大带宽，请升级 NIC 以支持更快的带宽。

  • 减少服务器的负载。通过将邮箱移动到拥有较少邮箱的服务器上，就可以实现这一点。如果需要，可以为环境添加额外的 Exchange 服务器。

  • 如果怀疑异常的高负载并不是由于服务器上拥有过多的邮箱而所造成的，请尝试识别异常高负载的来源并停止它。

请考虑下列文章中提供的最佳做法：

  • 有关网络带宽注意事项的信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"(Exchange Server 2003 性能和可伸缩性指南)(http://go.microsoft.com/fwlink/?LinkId=47576) 的"Understanding Exchange Performance"(了解 Exchange 性能)中的"Network Performance"（网络性能）。

  • 有关排除网络问题的信息，请参阅"Microsoft Exchange Server 性能疑难解答"(http://go.microsoft.com/fwlink/?LinkId=47588) 中的"Ruling Out Network-Bound Problems"（解决网络绑定问题）。


主 DNS 无法响应 UDP 连接
Microsoft Exchange Server 分析工具 - 文章 > 网络 >

主题上次修改时间： 2007-03-16

Microsoft Exchange 分析工具查询 Win32_NetworkAdapterConfiguration Microsoft Windows Management Instrumentation (WMI) 类，以获取 DNSServerSearchOrder 属性。此属性是在查询 DNS 服务器时使用的服务器 IP 地址数组。

检索主域名系统 (DNS) 服务器的地址后，Exchange 分析工具将尝试对每个 Active Directory 目录服务服务器的已配置 DNS 服务器进行 DNS 查询。此连接是通过使用执行用户数据报协议 (UDP) 名称解析请求并分析结果的自定义对象处理器来建立的。

如果 UDP 名称解析请求失败，则 Exchange 分析工具将显示一条警告。

此警告表明主 DNS 服务器可能配置为仅接受 TCP 查询。

简单邮件传输协议 (SMTP) 是 Exchange Server 进行邮件提交和邮件传输的本机邮件协议。这意味着客户端使用 SMTP 发送邮件，而 Exchange 服务器使用 SMTP 传递邮件和邮件数据。

Exchange Server 若要通过 SMTP 服务传递出站 Internet 邮件，则会按以下方法使用 DNS：

  1. 内部用户将邮件发送给远程域中的收件人。

  2. 若要确定收件人是本地的还是远程的，发件人 Exchange 服务器上的 SMTP 虚拟服务器使用内部传输功能查询收件人地址的全局编录服务器。如果邮件上的收件人地址不在收件人策略中，则不会将它存储在 Active Directory 中。因此，Exchange 确定该邮件将发往远程域。

  3. 如有必要，Exchange 服务器将邮件传递到适当的 SMTP 虚拟服务器。

  4. SMTP 虚拟服务器使用其 IIS 元数据库信息确定将邮件传递到远程域的方法。

  5. 然后 Exchange 服务器上的 SMTP 虚拟服务器执行下列两项操作之一：

    • 使用 DNS 查找目标域的 IP 地址，再尝试传递邮件。

    • 将邮件转发到负责 DNS 解析和邮件传递的智能主机。

默认情况下，DNS 服务器在 UDP 套接字 53 上侦听名称解析查询等通信。

如果 Exchange Server 上的 SMTP 服务配置为仅发送 UDP 查询，而主 DNS 服务器配置为仅接受 TCP 查询，则可能出现邮件路由故障，对邮件流性能产生负面影响。

若要解决此警告问题，请执行下列操作：

  1. 确保 DNS 服务器已启动，并且已连接到网络。

  2. 验证网络防火墙或数据包过滤器是否没有刻意阻止众所周知的 DNS 端口，如 UDP 端口 53。

  3. 验证主 DNS 服务器是否配置为支持 UDP 名称解析查询。

有关 DNS 和 Exchange Server 的详细信息，请参阅下列 Microsoft 知识库文章和 Web 广播：

  • 322856"HOW TO：配置 DNS 以用于 Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237"XCON：Windows 2000 和 Exchange 2000 SMTP 使用 TCP DNS 查询"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759"支持 Web 广播：Microsoft Exchange 2000 Server：解决传输中的 DNS 问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


主 DNS 服务器不可访问
Microsoft Exchange Server 分析工具 - 文章 > 网络 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_NetworkAdapterConfiguration Microsoft Windows® Management Instrumentation (WMI) 类，以获取 DNSServerSearchOrder 属性。此属性是在查询 DNS 服务器时使用的服务器 IP 地址数组。检索到主 DNS 服务器的地址后，Exchange Server 分析工具将在服务器上打开一个到端口 53 的 TCP 套接字连接。此连接是通过使用自定义对象处理器来建立的。该处理器在连接成功时返回一个特定的字符串。如果 Exchange Server 分析工具收到的返回字符串中没有 53 Available，则显示警告。

该警告表明服务器对连接 TCP 端口 53 的尝试没有响应。默认情况下，DNS 服务器在 TCP 套接字 53 上侦听名称解析查询等通信。

如果主 DNS 服务器不可访问，而您运行的是 Exchange 2000 Server，则邮件传递将会很慢。Microsoft 提供了一个支持的修补程序，可以解决在主 DNS 服务器不可访问时，向外部收件人传递邮件的速度比预期慢的问题。与 Microsoft 产品技术支持服务部门联系以获取此修补程序。

此外，您还需要找到主 DNS 服务器不可访问的原因，或将 Exchange 服务器上的 DNS 设置更改为使用其他 DNS 服务器进行名称解析。

解决此警告问题

  1. 确保 DNS 服务器已启动，并且已连接到网络。

  2. 使用 PING 命令确定 DNS 服务器是否可访问。

有关主 DNS 服务器不可访问时邮件传递速度慢的详细信息，以及如何获取此问题的修补程序的详细信息，请参阅 Microsoft 知识库文章 829722"Mail delivery is slow in Exchange 2000 when the primary DNS server is not available"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829722)。

有关 DNS 和 Exchange Server 的详细信息，请参阅下列 Microsoft 知识库文章和 WebCast：

  • 322856"HOW TO：配置 DNS 以用于 Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237"XCON:Windows 2000 and Exchange 2000 SMTP Use TCP DNS Queries"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759"Support WebCast:Microsoft Exchange 2000 Server:DNS Troubleshooting in Transports"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


外部主 DNS 服务器无法响应 TCP 连接
Microsoft Exchange Server 分析工具 - 文章 > 网络 >

主题上次修改时间： 2007-03-16

Microsoft Exchange 分析工具查询 Active Directory 目录服务，以确定每个 Exchange Server 对象的 protocolCfgSMTPServer 类中 msExchSmtpExternalDNSServers 属性的值。msExchSmtpExternalDNSServers 属性的值（如果已设置）指定简单邮件传输协议 (SMTP) 虚拟服务器实例使用的外部域名系统 (DNS) 服务器的地址。

检索到外部主 DNS 服务器的地址后，Exchange Server 分析工具将在服务器上打开一个到端口 53 的 TCP 套接字连接。此连接是通过使用自定义对象处理器来建立的。该处理器在连接成功时返回一个特定的字符串。如果 Exchange Server 分析工具收到的返回字符串中没有 53 Available，则显示警告。

此警告表明服务器对连接 TCP 端口 53 的尝试没有响应。默认情况下，DNS 服务器在 TCP 套接字 53 上侦听名称解析查询等通信。

SMTP 是 Exchange Server 进行邮件提交和邮件传输的本机邮件协议。这意味着客户端使用 SMTP 发送邮件，而 Exchange 服务器使用 SMTP 传递邮件和邮件数据。

Exchange Server 若要通过 SMTP 服务传递出站 Internet 邮件，则会按以下方法使用 DNS：

  1. 内部用户将邮件发送给远程域中的收件人。

  2. 若要确定收件人是本地的还是远程的，发件人 Exchange 服务器上的 SMTP 虚拟服务器使用内部传输功能查询收件人地址的全局编录服务器。如果邮件上的收件人地址不在收件人策略中，则不会将它存储在 Active Directory 中。因此，Exchange 确定该邮件将发往远程域。

  3. 如有必要，Exchange 服务器将邮件传递到适当的 SMTP 虚拟服务器。

  4. SMTP 虚拟服务器使用其 IIS 元数据库信息确定将邮件传递到远程域的方法。

  5. 然后 Exchange 服务器上的 SMTP 虚拟服务器执行下列两项操作之一：

    • 使用 DNS 查找目标域的 IP 地址，再尝试传递邮件。

    • 将邮件转发到负责 DNS 解析和邮件传递的智能主机。

如果外部主 DNS 服务器不可访问，而您运行的是 Exchange 2000 Server，则邮件传递将会很慢。Microsoft 提供了一个支持的修补程序，可以解决在外部主 DNS 服务器不可访问时，向外部收件人传递邮件的速度比预期慢的问题。与 Microsoft 产品技术支持服务部门联系以获取此修补程序。

此外，您还需要找到外部主 DNS 服务器不可访问的原因，或将 Exchange 服务器上的 DNS 设置更改为使用其他 DNS 服务器进行名称解析。

若要解决此警告问题，请执行下列操作：

  1. 确保外部 DNS 服务器已启动，而且已连接到 Exchange 网络。

  2. 使用 PING 命令确定外部 DNS 服务器是否可以访问。

有关主 DNS 服务器不可访问时邮件传递速度慢的详细信息，以及如何获取此问题的修补程序的详细信息，请参阅 Microsoft 知识库文章 829722"主 DNS 服务器不可访问时在 Exchange 2000 中邮件传递速度慢"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829722)。

有关 DNS 和 Exchange Server 的详细信息，请参阅下列 Microsoft 知识库文章和 Web 广播：

  • 322856"HOW TO：配置 DNS 以用于 Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237"XCON：Windows 2000 和 Exchange 2000 SMTP 使用 TCP DNS 查询"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759"支持 Web 广播：Microsoft Exchange 2000 Server：解决传输中的 DNS 问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


外部主 DNS 无法响应 UDP 连接
Microsoft Exchange Server 分析工具 - 文章 > 网络 >

主题上次修改时间： 2007-03-16

Microsoft Exchange 分析工具查询 Active Directory 目录服务，以确定每个 Exchange Server 对象的 protocolCfgSMTPServer 类中 msExchSmtpExternalDNSServers 属性的值。msExchSmtpExternalDNSServers 属性的值（如果已设置）指定简单邮件传输协议 (SMTP) 虚拟服务器实例使用的外部域名系统 (DNS) 服务器的地址。

检索外部主 DNS 服务器的地址后，Exchange 分析工具将尝试对每个 Active Directory 目录服务服务器的已配置外部 DNS 服务器进行 DNS 查询。此连接是通过使用执行用户数据报协议 (UDP) 名称解析请求并分析结果的自定义对象处理器来建立的。

如果 UDP 名称解析请求失败，则 Exchange 分析工具将显示一条警告。

此警告表明外部主 DNS 服务器可能配置为仅接受 TCP 查询。

SMTP 是 Exchange Server 进行邮件提交和邮件传输的本机邮件协议。这意味着客户端使用 SMTP 发送邮件，而 Exchange 服务器使用 SMTP 传递邮件和邮件数据。

Exchange Server 若要通过 SMTP 服务传递出站 Internet 邮件，则会按以下方法使用 DNS：

  1. 内部用户将邮件发送给远程域中的收件人。

  2. 若要确定收件人是本地的还是远程的，发件人 Exchange 服务器上的 SMTP 虚拟服务器使用内部传输功能查询收件人地址的全局编录服务器。如果邮件上的收件人地址不在收件人策略中，则不会将它存储在 Active Directory 中。因此，Exchange 确定该邮件将发往远程域。

  3. 如有必要，Exchange 服务器将邮件传递到适当的 SMTP 虚拟服务器。

  4. SMTP 虚拟服务器使用其 IIS 元数据库信息确定将邮件传递到远程域的方法。

  5. 然后 Exchange 服务器上的 SMTP 虚拟服务器执行下列两项操作之一：

    • 使用 DNS 查找目标域的 IP 地址，再尝试传递邮件。

    • 将邮件转发到负责 DNS 解析和邮件传递的智能主机。

默认情况下，DNS 服务器在 UDP 套接字 53 上侦听名称解析查询等通信。

如果 Exchange 服务器上的 SMTP 服务配置为仅发送 UDP 查询，而外部主 DNS 服务器配置为仅接受 TCP 查询，则可能出现邮件路由故障，对邮件流性能产生负面影响。

若要解决此警告问题，请执行下列操作：

  1. 确保外部 DNS 服务器已启动，而且已连接到网络。

  2. 验证网络防火墙或数据包过滤器没有刻意阻止众所周知的 DNS 端口，如 UDP 端口 53。

  3. 验证外部主 DNS 服务器是否配置为支持 UDP 名称解析查询。

有关 DNS 和 Exchange Server 的详细信息，请参阅下列 Microsoft 知识库文章和 Web 广播：

  • 322856"HOW TO：配置 DNS 以用于 Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237"XCON：Windows 2000 和 Exchange 2000 SMTP 使用 TCP DNS 查询"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759"支持 Web 广播：Microsoft Exchange 2000 Server：解决传输中的 DNS 问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


主 WINS 服务器不响应
Microsoft Exchange Server 分析工具 - 文章 > 网络 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_NetworkAdapterConfiguration Microsoft Windows® Management Instrumentation (WMI) 类，以获取 WINSPrimaryServer 属性。此属性是 Exchange Server 计算机的主 Windows Internet 名称服务 (WINS) 服务器的 IP 地址。Exchange Server 分析工具检索到主 WINS 服务器的地址之后，Exchange Server 分析工具将打开到服务器上的端口 137 的 TCP 套接字连接。此连接是通过使用自定义对象处理器来建立的。该处理器在连接成功时返回一个特定的字符串。如果 Exchange Server 分析工具未接收作为返回字符串部分的 137 Available，则显示警告。

该警告表明服务器对连接 TCP 端口 137 的尝试没有响应。默认情况下，WINS 服务器在 TCP 套接字 137 上侦听名称解析查询等通信。

如果主 WINS 服务器不可访问，而您运行的是 Exchange Server，则邮件传递将会很慢，尤其在规模较大的组织中。您应找到主 WINS 服务器不可访问的原因，或将 Exchange 服务器上的 WINS 设置更改为使用其他 WINS 服务器进行名称解析。

解决此警告问题

  1. 确保 WINS 服务器已启动，并且已连接到网络。

  2. 使用 PING 命令确定 WINS 服务器是否可访问。

有关 Exchange 2000 Server 和 Exchange Server 2003 需要 WINS 的原因的信息，请参阅 Microsoft 知识库文章 837391"Exchange Server 2003 和 Exchange 2000 Server 需要 NetBIOS 名称解析才能实现全部功能"(http://support.microsoft.com/?kbid=837391)。


端口 389 没有响应
Microsoft Exchange Server 分析工具 - 文章 > 网络 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Active Directory 中所有域控制器的 dNSHostName 属性值。检索到域控制器的名称后，Exchange Server 分析工具将在每个域控制器上打开一个到端口 389 的 TCP 套接字连接。此连接是通过使用自定义对象处理器来建立的。该处理器在连接成功时返回一个特定的字符串。如果 Exchange Server 分析工具收到的返回字符串中没有 389 Available，则显示警告。

该警告说明域控制器没有响应 TCP 端口 389 上的连接尝试。TCP 端口 389 是轻型目录访问协议 (LDAP) 通信的默认端口。

如果收到该警告，则可能是因为 Exchange Server 分析工具与域控制器之间存在连接问题。当 Exchange Server 分析工具查询域控制器时，有很多原因会导致 LDAP 请求无法得到域控制器的正确服务。

解决此警告问题

  1. 验证运行此工具的帐户有权查询域控制器。您将需要在域控制器所运行在的域中拥有用户级权限。有关运行 Exchange Server 分析工具所需的权限的详细信息，请参阅此工具附带的帮助文件。要打开此帮助文件，请打开 Exchange Server 分析工具，单击"帮助"，再单击"Microsoft Exchange Server 分析工具帮助"。

  2. 验证在运行 Exchange Server 分析工具的计算机与没有响应的域控制器之间没有防火墙或端口限制。

  3. 验证域控制器连接到了网络并正常工作。

有关解决 Active Directory 连接问题的详细信息，请参阅 Microsoft 知识库文章 816103"HOW TO:Use Portqry to Troubleshoot Active Directory Connectivity Issues"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103)。

有关在域控制器上配置 Microsoft Windows® 时间的详细信息，请参阅知识库文章 816042"如何在 Windows Server 2003 中配置权威时间服务器"(http://support.microsoft.com/?kbid=816042)。


端口 636 没有响应
Microsoft Exchange Server 分析工具 - 文章 > 网络 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Active Directory 中所有域控制器的 dNSHostName 属性值。检索到域控制器的名称后，Exchange Server 分析工具将在每个域控制器上打开一个与端口 636 的 TCP 套接字连接。此连接是通过使用自定义对象处理器来建立的。该处理器在连接成功时返回一个特定的字符串。如果 Exchange Server 分析工具收到的返回字符串中没有 636 Available，则会显示警告。

此警告意味着域控制器不响应 TCP 端口 636 上的连接尝试。TCP 端口 636 是安全轻型目录访问协议（SSL 上的 LDAP）通信的默认端口。

引入 Exchange 2000 Server Service Pack 3 后，如果在 Exchange Server 计算机上的本地证书存储中存在有效证书，Exchange Server 将使用 SSL 上的 LDAP 进行连接。如果此类证书不存在，或者返回了与证书有关的错误（例如，域控制器不信任 Exchange 证书，或者使用的证书要求强密钥保护），Exchange Server 将自动退回到没有 SSL 的 LDAP。如果收到该警告，则可能是因为 Exchange Server 分析工具与域控制器之间存在连接问题。此警告不意味着公钥基础结构 (PKI) 存在问题或存在其他证书问题。

如果当 Exchange Server 分析工具查询域控制器时，域控制器可能未正确处理 SSL 上的 LDAP 请求，可能的原因有很多。

解决此警告问题

  1. 验证运行此工具的帐户有权查询域控制器。您将需要在域控制器所运行在的域中拥有用户级权限。有关运行 Exchange Server 分析工具所需的权限的更多信息，请参阅此工具附带的帮助文件。要打开此帮助文件，请打开 Exchange Server 分析工具，单击"帮助"，然后单击"Microsoft Exchange Server 分析工具帮助"。

  2. 验证在运行 Exchange Server 分析工具的计算机与没有响应的域控制器之间没有防火墙或端口限制。

  3. 验证域控制器连接到了网络并正常工作。

  4. 验证运行 Exchange Server 分析工具的计算机上的时间与不响应的域控制器上的时间同步。如果域控制器上的 Microsoft Windows® Time 服务已停止或禁用，域控制器本地的时间可能不同步。在这种情况下，域控制器将不会响应 SSL 上的 LDAP 请求，直到其时钟同步。

有关使用 SSL 上的 LDAP 的详细信息，请参阅 Microsoft 知识库文章 321051"How to enable LDAP over SSL with a third-party Certification Authority"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=321051)。

有关解决 Active Directory 连接问题的详细信息，请参阅知识库文章 816103"HOW TO:Use Portqry to Troubleshoot Active Directory Connectivity Issues"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103)。

有关 Windows 时间服务的详细信息，请参阅知识库文章 816042"如何配置基于 Windows Server 2003 的林根 PDC 主机上的 Windows 时间服务"(http://support.microsoft.com/kb/816042/zh-cn)。


SMTP 服务器不支持 X-LINK2STATE 动作
Microsoft Exchange Server 分析工具 - 文章 > 网络 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具通过 Exchange 服务器启动 SMTP 会话，以验证是否列出了合适的 Exchange SMTP 谓词。如果没有列出 X-LINK2STATE 谓词，则会显示警告。

Exchange 使用 X-LINK2STATE 谓词来更新路由主服务器上的链接状态表。链接状态表记录了在整个 Exchange 组织中有关 SMTP 链接状态的最新信息。Exchange 在路由邮件时使用该信息来选取成本最低且最可靠的路由。该功能也称为"智能路由"。

X-LINK2STATE 谓词是 Exchange 进行有效路由所必需的，其他 SMTP 提供程序不使用该谓词。同样，在由 Exchange 安装程序安装和注册的文件 (xlsasink.dll) 中也提供了该功能。

之所以可能返回该警告，有两个已知原因。首先，某些管理员可能禁用了 xlsasink.dll，以此作为规避它所提供的智能路由功能的方式。这不是建议的最佳做法，并且很可能导致性能和可靠性问题。在这种情况下，建议您在受影响的计算机上重新安装 Exchange，以便安装并注册 xlsasink.dll。

其次，如果正在运行的防病毒产品安装并使用它自己的 SMTP 协议堆栈来扫描邮件，则可能返回该警告。这种情况下，防病毒软件可能运行它自己的 SMTP 堆栈，该堆栈会在邮件到达 Exchange SMTP 堆栈之前截取和扫描这些邮件。这种情况下，防病毒 SMTP 堆栈不使用 X-LINK2STATE 谓词。建议您在不需要防病毒软件在 Exchange 服务器上安装它自己的 SMTP 堆栈的模式下运行防病毒软件。

有关 Exchange 所使用的 X-LINK2STATE 和其他专有谓词的详细信息，请参阅 Microsoft 知识库文章 812455"两个 Exchange 服务器之间使用的动词定义"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=812455)。

有关如何查看 Exchange 命令谓词和重新安装 Exchange 2000 Server 的详细信息，请参阅知识库文章 319885"XCON:Messages Sent in the Exchange 2000 Server Organization Are Not Delivered"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319885)。

有关如何查看 Exchange 命令谓词和重新安装 Exchange Server 2003 的详细信息，请参阅知识库文章 822939"Messages That Are Sent in the Exchange Server 2003 Organization Are Not Delivered"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822939)。


SMTP 服务器未通过邮件接受测试
Microsoft Exchange Server 分析工具 - 文章 > 网络 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具尝试通过执行下列任务，将邮件发送到简单邮件传输协议 (SMTP) 域的邮局主管帐户：

  • 打开与 SMTP 服务器的套接字连接。如果 Exchange Server 分析工具收到响应代码 220，则认为此步骤已成功完成。

  • 发送 EHLO SMTP 命令谓词。如果 Exchange Server 分析工具收到一系列响应代码 250，其中包括含有 250-X-LINK2STATE 和 250-XEXCH50 的响应，则认为此步骤已成功完成。

  • 传输 MAIL FROM:ExBPA-MailAcceptTest@Fabrikam.com SMTP 命令动作。如果 Exchange Server 分析工具收到响应代码 250，则认为此步骤已成功完成。

  • 传输 RCPT TO:Postmaster@<domainname>.com SMTP 命令动作。如果 Exchange Server 分析工具收到响应代码 250，则认为此步骤已成功完成。

如果 Exchange Server 分析工具无法成功完成所有步骤，则显示错误。此错误意味着可能存在一般的邮件流问题。应按顺序尝试下列链接以排除故障，并从服务器级别开始，一直继续到网络级别。

更正此错误

  1. 请参阅"Exchange Server Transport and Routing Guide" 中的"Troubleshooting Routing"（英文）(http://go.microsoft.com/fwlink/?linkid=47579)。

  2. 请参阅 Microsoft 知识库文章 324867"Support WebCast:Microsoft Exchange 2000 Server:Troubleshooting Mail Flow Problems (Revisited)"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324867)。

  3. 请参阅 Microsoft 知识库文章 823489"How to Use Queue Viewer to Troubleshoot Mail Flow Issues"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  4. 请参阅 Microsoft 知识库文章 324759"Support WebCast:Microsoft Exchange 2000 Server:DNS Troubleshooting in Transports"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324759)。

有关 Exchange Server 中的 Postmaster 帐户的详细信息，请参阅下列 Microsoft 知识库文章：

  • 223860"XCON:SMTP Postmaster Mailbox Must Be Set Manually"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=223860)

  • 313832"HOW TO:Set an SMTP Postmaster Account in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=313832)


SMTP 服务器无法打开中继测试
Microsoft Exchange Server 分析工具 - 文章 > 网络 >

主题上次修改时间： 2007-03-14

Microsoft® Exchange Server 分析工具通过执行下列任务来尝试通过简单邮件传输协议 (SMTP) 服务器中继邮件：

  • 打开与 SMTP 服务器的套接字连接。如果 Exchange Server 分析工具收到响应代码 220，则认为此步骤已成功完成。

  • 发送 EHLO SMTP 命令谓词。如果 Exchange Server 分析工具收到一系列响应代码 250，其中包括含有 250-X-LINK2STATE 和 250-XEXCH50 的响应，则认为此步骤已成功完成。

  • 传输 MAIL FROM:ExBPA-OpenRelayTest@Fabrikam.com SMTP 命令谓词。如果 Exchange Server 分析工具收到响应代码 250，则认为此步骤已成功完成。

  • 传输 RCPT TO:ExBPA-OpenRelayTest@Fabrikam.com SMTP 命令谓词。如果 Exchange Server 分析工具收到响应代码 250，则认为此步骤已成功完成。

Exchange Server 分析工具还查询 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 OSProductSuite 关键字的值。该关键字的值对应于 Windows Server 操作系统的特定版本。

如果 Exchange Server 分析工具可以成功地在运行 Microsoft Small Business Server 2000 或 Microsoft Windows Small Business Server 2003 的 Exchange Server 计算机上完成所有步骤，则会显示错误。

此错误意味着该服务器配置为开放中继。

允许开放中继不是建议的最佳做法。

当电子邮件服务器允许电子邮件通过系统中继，而未对可中继的电子邮件施加任何限制或任何控制时，便发生了开放中继。

注意：
如果您的 Exchange 组织出于某个原因使用了名为 Fabrikam.com 的 SMTP 域，可能会出现此错误。在这种情况下，您可能能够放心地忽略此错误。Fabrikam.com 域由 Microsoft Corporation 所有，它用于培训、归档以及类似的目的。

中继本质上并不是坏事，因为设计 SMTP 便是为了实现此目的（有关详细信息，请参阅 http://ietf.org/ 上的 RFC 2821 文档中的 2.1 节 和 3.7 节）。但是，如果不控制中继（不受控制的主机称为开放中继主机），则恶意用户可能使用中继来发送大量未经请求的商业电子邮件（垃圾邮件或 UCE）。恶意用户使这些未经请求的电子邮件以某个中间主机为中转站，从而试图掩盖其身份。这还会占用中继主机上的资源，并可能使中继主机无法发送有效的电子邮件。更糟糕的是，大多数发送此类未经请求的电子邮件的用户可以借助他人的带宽将单个邮件发送给大量的收件人。

请确保不允许在面向 Internet 的 SMTP 虚拟服务器上允许匿名中继。默认配置下的 Exchange 仅允许已通过身份验证的用户中继邮件。只有已通过身份验证的用户能够使用 Exchange 向外部域发送邮件。如果修改默认中继设置，以便允许未通过身份验证的用户中继邮件，或者，允许开放中继支持（即允许任何用户通过连接器将邮件中继到某个域），则未经授权的用户或恶意蠕虫将能够使用您的 Exchange 服务器发送垃圾邮件。您的服务器可能出现在阻止列表中，从而无法向合法的远程服务器发送邮件。若要阻止未经授权的用户使用您的 Exchange 服务器中继邮件，至少应使用默认的中继限制。

如果您有合理的理由允许中继，应遵循相应的准则以确保实施方案具备安全性。实现这一点的主要方法是保留全部拒绝默认设置，而只添加将接受其中继邮件的 IP 地址，并禁止已通过身份验证的用户访问。

检查内置帐户（本地管理员）和其他用户是如何在网关服务器上使用的。您不可能对所有类型的中继都使用内置帐户。如果允许中继，则中继可能被一组已知的用户或计算机使用。建议只对明确的用户和计算机或 IP 地址授予中继权限。

配置明确的中继权限将有助于进一步增强服务器的安全性。恶意用户可以使用强力攻击来试图获得内置帐户或 Internet 上的用户帐户的密码，以便可以将您的服务器用作垃圾邮件代理。因此，建议不要对可以从 Internet 访问到的计算机使用默认设置，因为该设置允许任何已通过身份验证的计算机中继。建议禁用该设置。

下面的步骤说明了如何根据 SMTP 虚拟服务器是否面向 Internet 来禁用匿名中继。本文前面已提到，应只有在意识到了安全风险并且此安全风险对于您的组织是可接受的情况下，才启用任何形式的匿名中继。本文末尾的参考提供了有关如何使用中继的详细信息。

如果 SMTP 虚拟服务器不能从 Internet 访问，建议将中继配置重置为默认值。这将导致 SMTP 虚拟服务器仅仅处理来自已通过身份验证的计算机的内部中继请求。

对于可以从 Internet 访问的 SMTP 虚拟服务器，建议额外保护默认的中继配置，以便只允许具有明确权限的用户和计算机中继。

如果已确认 Exchange 配置为阻止中继，但 Exchange Server 分析工具仍然显示此错误，应确认任何代理服务器或进程（如防火墙、防病毒或防垃圾邮件软件）都不允许匿名中继。

在内部 SMTP 虚拟服务器上将匿名中继配置重置为默认设置

  1. 打开 Exchange 系统管理器。

  2. 在控制台树中，展开"服务器"，然后依次展开相应的服务器、"协议"、"SMTP"。

  3. 用鼠标右键单击要应用中继限制的 SMTP 虚拟服务器，再单击"属性"。

  4. 在"<SMTP Virtual Server> 属性"中，单击"访问"选项卡，然后单击"中继"。

  5. 在"中继限制"中的"选择可以通过此虚拟服务器进行中继的计算机"下，选择"仅以下列表"，选中"不管上表中如何设置，所有通过身份验证的计算机都可以进行中继"复选框，然后单击"确定"。

在面向 Internet 的 SMTP 虚拟服务器上配置明确的中继权限 (Exchange Server 2003)

  1. 打开 Exchange 系统管理器。

  2. 在控制台树中，展开"服务器"，然后依次展开相应的服务器、"协议"、"SMTP"。

  3. 用鼠标右键单击要应用中继限制的 SMTP 虚拟服务器，再单击"属性"。

  4. 在"<SMTP Virtual Server> 属性"中，单击"访问"选项卡，然后单击"中继"。

  5. 在"中继限制"中，清除"不管上表中如何设置，所有通过身份验证的计算机都可以进行中继"复选框，然后单击"用户"以指定要允许其通过该 SMTP 虚拟服务器中继邮件的那部分用户。

  6. 在"提交和中继的权限"中，若要删除用户或组，请选择该用户或组，然后单击"删除"。

  7. 若要添加用户或组，请单击"添加"，然后选择要为其指定权限的用户或组。请选择下列选项之一：

    • (Microsoft Windows Server™ 2003) 在"选择用户、计算机或组"中的"输入对象名称来选择"下，键入用户或组的名称。如果要搜索用户或组，请单击"高级"，搜索该用户名或组名，然后单击"检查名称"验证输入。

      提示：
      单击"示例"链接可查看输入名称的可接受格式。
    • (Windows 2000 Server) 在"选择用户、计算机或组"中，选择要授予其提交权限的组或用户，然后单击"添加"。

  8. 单击"确定"返回"提交和中继的权限"对话框。

  9. 在"组或用户名称列表"下，选择刚刚添加的组。

  10. 如果必要，请在"<selected group> 的权限"下面的"提交权限"旁，选中"允许"下面的复选框以便允许选定的用户或组通过此 SMTP 虚拟服务器提交邮件。

  11. 在"中继权限"旁，选中"允许"下面的复选框以便允许选定的对象通过该 SMTP 虚拟服务器中继邮件，或者选中"拒绝"下面的复选框阻止选定的对象通过该虚拟服务器中继邮件。

    注意：
    如果要授予中继权限，必须先授予提交权限。

  12. 单击"确定"。

在面向 Internet 的 SMTP 虚拟服务器上配置中继权限 (Exchange 2000 Server)

  1. 打开 Exchange 系统管理器。

  2. 在控制台树中，展开"服务器"，然后依次展开要配置的服务器、"协议"、"SMTP"。

  3. 用鼠标右键单击要应用中继限制的 SMTP 虚拟服务器，再单击"属性"。

  4. 在"<SMTP Virtual Server> 属性"中，单击"访问"选项卡，然后单击"中继"。

  5. 在"中继限制"中的"选择可以通过此虚拟服务器进行中继的计算机"下，选择"仅以下列表"。

  6. 单击"添加"添加单个计算机、计算机组或 SMTP 域名，然后单击"确定"。对要添加的其他每个条目重复此步骤。

  7. 选择"不管上表中如何设置，所有通过身份验证的计算机都可以进行中继"，然后单击"确定"两次。

有关邮件中继和安全性的详细信息，请参阅 Exchange Server 2003 技术库中的下列指南：

  • "Exchange Server 2003 传输和路由指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=c092b7a7-9034-4401-949c-b29d47131622&DisplayLang=zh-cn)。

  • "在 Exchange 2003 环境中抑制和阻止通过电子邮件传输的病毒"(http://www.microsoft.com/downloads/details.aspx?FamilyID=fb3f649a-2b0a-443d-92a5-8f8cf4bf9fdb&DisplayLang=zh-cn)

有关在 Exchange 和 Microsoft Windows 环境中测试和保护开放中继行为的详细信息，请参阅 Microsoft 知识库文章 304897"SMTP relay behavior in Windows 2000, Windows XP, and Exchange Server"（英文）(http://support.microsoft.com/kb/304897/zh-cn)。


正在运行的 SMTP 版本不支持 XEXCH50 动作
Microsoft Exchange Server 分析工具 - 文章 > 网络 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具启动与 Exchange 服务器的 SMTP 会话，以验证是否列出了合适的 Exchange SMTP 动作。如果没有列出 XEXCH50 谓词，则会显示警告。

此外，Exchange 使用 XEXCH50 谓词来进行公用文件夹复制。如果在 Exchange 服务器上运行不支持 XEXCH50 谓词的 SMTP 版本，将使公用文件夹复制中断。

其他 SMTP 提供程序不会使用 XEXCH50 谓词，因此，在一个由 Exchange 安装程序所安装和注册的文件 (peexch50.dll) 中提供该功能。

如果正在运行防病毒产品，并且该产品安装和使用它自己的 SMTP 协议堆栈来扫描邮件，则 Exchange Server 分析工具可能返回该警告。这种情况下，在邮件到达 Exchange SMTP 堆栈之前，防病毒软件将使用它自己的 SMTP 堆栈来截获和扫描这些邮件。如果这样，则防病毒软件中的 SMTP 堆栈将不使用 XEXCH50 谓词。

建议在不要求在 Exchange 服务器上安装防病毒软件自己的 SMTP 堆栈的模式下运行防病毒软件，或者在 SMTP 网络的传入外围运行这样的软件。如果禁用了防病毒软件的 SMTP 堆栈，并且仍然遇到该警告，请重新安装 Exchange，以便正确安装和注册 peexch50.dll。

有关 Exchange 所使用的 XEXCH50 和其他私有谓词的详细信息，请参阅 Microsoft 知识库文章 812455"两个 Exchange 服务器之间使用的动词定义"(http://support.microsoft.com/kb/812455/zh-cn)。

有关如何查看 Exchange 命令谓词和重新安装 Exchange 2000 Server 的详细信息，请参阅知识库文章 319885"XCON:Messages Sent in the Exchange 2000 Server Organization Are Not Delivered"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319885)。

有关如何查看 Exchange 命令谓词和重新安装 Exchange Server 2003 的详细信息，请参阅知识库文章 822939"Messages That Are Sent in the Exchange Server 2003 Organization Are Not Delivered"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822939)。


协议
Microsoft Exchange Server 分析工具 - 文章 >

主题上次修改时间： 2005-11-18

本部分中的文章详细介绍 Microsoft® Exchange Server 分析工具对 Internet 协议进行的相关评估。此外，这些文章还描述了为解决由 Exchange Server 分析工具发现的与 Internet 协议有关的错误、警告和非默认配置所能采取的操作。


Active Directory 往返响应错误
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Active Directory® 目录服务服务器返回的 StatusCode 关键字的值。Win32_PingStatus 返回一个具有 24 个属性的对象，提供有关该类发送的 Ping 数据包的详细信息。

如果 Exchange Server 分析工具发现此关键字的值与下表中的某个值匹配，则会显示错误。

Exchange Server 分析工具显示该 Active Directory 服务器名称以及随此错误返回的相应的 StatusCode 值。

StatusCode 值 | 含义 | 描述
11001 | 缓冲区太小 | 不太可能返回此错误，因为 Exchange Server 分析工具生成的是标准请求。
11002 | 目标网络不可访问 | 请求失败，因为包含目标计算机的网络不可访问或没有到目标计算机的有效路由。 有关信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"（http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487）。
11003 | 目标主机不可访问 | 请求失败，因为目标计算机不可访问。 有关信息，请参阅Active Directory 服务器停机或不可访问。 或者，运行 Exchange Server 分析工具的位置与目标域控制器之间的防火墙也可能会造成此错误，甚至可能造成 DNS 错误。 有关信息，请参阅知识库文章 325487"如何解决网络连接问题"（http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487）。
11004 | 目标协议不可访问 | 请求失败，因为目标计算机对数据包的协议没有响应。 运行 Exchange Server 分析工具的位置与目标域控制器之间的防火墙也可能会造成此错误。
11005 | 目标端口不可访问 | 请求失败，因为目标计算机上的端口不可用。 有关信息，请参阅知识库文章 325487"如何解决网络连接问题"（http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487）。
11006 | 无资源 | 请求失败，因为网络资源不足。 有关信息，请参阅知识库文章 325487"如何解决网络连接问题"（http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487）。
11007 | 错误选项 | 请求失败，因为请求中包含无效选项。 不太可能返回此错误，因为 Exchange Server 分析工具生成的是标准请求。
11008 | 硬件错误 | 请求因为硬件错误而失败。 通过运行计算机制造商的硬件健全检查工具来验证域控制器是否正常运行。
11009 | 数据包太大 | 请求失败，因为包含请求的数据包大于位于源计算机和目标计算机之间的节点（路由器或网关）的最大传输单元 (MTU)。MTU 定义可传输的最大数据包大小。 Exchange Server 分析工具所发送的请求的大小不会大于 10 KB。确认组织中的路由器和网关的配置正确。 有关信息，请参阅知识库文章 159211"Diagnoses and Treatment of Black Hole Routers"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211)。
11010 | 请求已超时 | 在指定时间内未收到回复。允许的默认回复时间为五秒。 有关信息，请参阅知识库文章 325487"如何解决网络连接问题"（http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487）。
11011 | 错误请求 | 请求失败，因为请求的编码不正确。 不太可能返回此错误，因为 Exchange Server 分析工具生成的是标准请求。
11012 | 错误路由 | 请求失败，因为源计算机和目标计算机之间没有有效路由。 有关信息，请参阅知识库文章 325487"如何解决网络连接问题"（http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487）。
11013 | 传输 TimeToLive 已过 | 请求失败，因为生存期 (TTL) 值已达到零，使转发节点（路由或网关）丢弃该数据包。 有关信息，请参阅知识库文章 325487"如何解决网络连接问题"（http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487）。
11014 | 重组 TimeToLive 已过 | 请求失败，因为数据包为了传输而被分为多个片断，在分配的重组时间内未收到所有片断。RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) 将必须收到所有数据包片断的时间限制指定为 60 秒。 有关信息，请参阅知识库文章 325487"如何解决网络连接问题"（http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487）。
11015 | 参数问题 | 请求失败，因为某个节点（路由器或网关）在处理数据包头时遇到问题。例如，如果数据包头中包含无效的字段数据或无法识别的选项，可能会出现此状态。 不太可能返回此错误，因为 Exchange Server 分析工具生成的是标准请求。
11016 | 源结束 | 请求失败，因为数据包已被丢弃。如果源计算机的输出队列的存储空间不足，或数据包因到达目标计算机的速度太快而无法处理，可能会出现此状态。 不太可能返回此错误，因为 Exchange Server 分析工具生成的是标准请求。
11017 | 选项太大 | 请求失败，因为请求中包含无效选项。 不太可能返回此错误，因为 Exchange Server 分析工具生成的是标准请求。
11018 | 错误目标 | 请求失败，因为目标 IP 地址无法收到 PING 请求，或不应出现在任何 IP 数据报的目标地址字段中。 运行 Exchange Server 分析工具的位置与目标域控制器之间的防火墙也可能会造成此错误。
11032 | 正在协商 IPSEC | 请求失败，因为 IPsec 连接无法协商。
11050 | 一般性失败 | 请求因未知原因而失败。 有关信息，请参阅知识库文章 325487"如何解决网络连接问题"（http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487）。


从 Active Directory 到 Exchange Server 的往返响应错误
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2006-05-15

Microsoft® Exchange Server 分析工具查询 Win32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 类，以确定从 Active Directory® 目录服务服务器返回的 StatusCode 关键字的值。Win32_PingStatus 返回一个具有 24 个属性的对象，这些属性可提供有关该类发送的 Ping 数据包的详细信息。

如果 Exchange Server 分析工具发现此关键字的值与下表中的某个值匹配，则 Exchange Server 分析工具会显示错误。

Exchange Server 分析工具显示 Active Directory 服务器名称、Exchange Server 名称以及随此错误返回的相应的 StatusCode 值。

StatusCode 值 含义 说明

11001

缓冲区太小

因为 Exchange Server 分析工具将生成标准请求，所以不可能出现该错误。

11002

目标网络不可访问

因为包含目标计算机的网络不可访问，所以请求失败。没有到目标计算机的有效路由。

有关详细信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11003

目标主机不可访问

因为目标计算机不可访问，所以请求失败。

有关详细信息，请参阅 Active Directory 服务器停机或不可访问。

该错误也可能是由下列某种情况而引起的：

  • 防火墙位于运行 Exchange Server 分析工具的位置与目标域控制器之间。

  • DNS 错误。

有关详细信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11004

目标协议不可访问

因为目标计算机对数据包的协议没有响应，所以请求失败。

运行 Exchange Server 分析工具的位置与目标域控制器之间的防火墙也可能导致此错误。

11005

目标端口不可访问

因为目标计算机上的端口不可用，所以请求失败。

有关详细信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11006

无资源

因为网络资源不足，所以请求失败。

有关详细信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11007

错误选项

因为请求中包含无效选项，所以请求失败。

因为 Exchange Server 分析工具将生成标准请求，所以不可能出现该错误。

11008

硬件错误

请求因为硬件错误而失败。

通过运行由计算机制造商提供的硬件健全检查工具来验证域控制器是否正常运行。

11009

数据包太大

因为包含请求的数据包大于位于源计算机和目标计算机之间的路由器节点或网关节点的最大传输单元 (MTU)，所以请求失败。MTU 定义可传输的最大数据包大小。

Exchange Server 分析工具所发送的请求不会大于 10 KB。确认组织中的路由器和网关的配置是正确的。

有关详细信息，请参阅 Microsoft 知识库文章 159211"Diagnoses and Treatment of Black Hole Routers"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211)。

11010

请求已超时

在指定时间内未收到回复。默认的允许回复时间为 5 秒。

有关详细信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11011

错误请求

因为请求的编码不正确，所以请求失败。

因为 Exchange Server 分析工具将生成标准请求，所以不可能出现该错误。

11012

错误路由

因为源计算机和目标计算机之间没有有效路由，所以请求失败。

有关详细信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11013

传输 TimeToLive 已过期

因为生存期 (TTL) 值已达到零，所以请求失败。这会导致转发路由节点或网关节点丢弃数据包。

有关详细信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11014

重组 TimeToLive 已过期

因为数据包为了进行传输而被分为多个片断，在分配的重组时间内未收到所有片断，所以请求失败。RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) 将必须收到所有数据包片断的时间限制指定为 60 秒。

有关详细信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11015

参数问题

因为某个路由器节点或网关节点在处理数据包头时遇到问题，所以请求失败。如果头中包含无效的字段数据或无法识别的选项，则可能会出现此情况。

因为 Exchange Server 分析工具将生成标准请求，所以不可能出现该错误。

11016

源结束

因为数据包已被丢弃，所以请求失败。当源计算机的输出队列的存储空间不足时，就会出现此情况。当数据包因到达目标计算机的速度太快而无法得到处理时也可能会出现此情况。

因为 Exchange Server 分析工具将生成标准请求，所以不可能出现该错误。

11017

选项太大

因为请求中包含无效选项，所以请求失败。

因为 Exchange Server 分析工具将生成标准请求，所以不可能出现该错误。

11018

错误目标

请求可能会因下列某个原因而失败：

  • 目标 IP 地址无法收到 PING 请求。

  • 目标 IP 地址不应出现在任何 IP 数据报的目标地址字段中。

运行 Exchange Server 分析工具的位置与目标域控制器之间的防火墙也可能导致此错误。

11032

正在协商 IPSEC

因为 IPsec 连接无法协商，所以请求失败。

11050

一般性失败

请求因未知原因而失败。

有关详细信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。


在内部 SMTP 虚拟服务器和 IMAP 和 POP 客户端专用的 SMTP 虚拟服务器上允许匿名访问
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Exchange Server 对象的 protocolCfgSMTPServer 类中 msExchAuthenticationFlags 属性值。protocolCfgSMTPServer 类包含 SMTP 虚拟服务器的设置。msExchAuthenticationFlags 属性代表 SMTP 服务器上允许的身份验证类型。如果符合以下条件，则 Exchange Server 分析工具将显示警告消息：

  • msExchAuthenticationFlags 属性上的身份验证已配置为允许对 SMTP 服务器进行匿名访问。

  • 服务器未运行 Microsoft Small Business Server 2000 或 Microsoft Windows® Small Business Server 2003。

  • Exchange Server 驻留了超过 20 个邮箱。

为了提高安全性，请在不接受传入 Internet 邮件的内部 SMTP 虚拟服务器上禁用匿名访问。为了提高安全性，还可以在远程 IMAP 和 POP 用户的专用 SMTP 虚拟服务器上禁用匿名访问。

重要信息：
不要在 Internet 桥头 SMTP 虚拟服务器上禁用匿名访问。从 Internet 接受邮件的 SMTP 虚拟服务器必须允许匿名访问。

在发送内部邮件时，组织中的 Exchange 服务器会相互进行身份验证，以便发送邮件。因此，不必在内部 SMTP 虚拟服务器上启用匿名访问。在内部服务器上禁止匿名访问不会中断邮件流，并且在内部 SMTP 虚拟服务器上增加了一层安全保护。

同样，IMAP 和 POP 客户端在将邮件发送到 SMTP 虚拟服务器之前，会与 SMTP 虚拟服务器进行身份验证。因此，如果对 IMAP 和 POP 客户端使用专用的 SMTP 虚拟服务器，可以将这些服务器配置为仅允许通过身份验证的访问。如果在这些服务器上禁用匿名访问，可以帮助阻止未经授权的用户访问这些服务器。

如果因为业务原因不能在 SMTP 虚拟服务器上禁用通过身份验证（例如合作伙伴公司的身份验证）的访问，请执行下列步骤以帮助提高网关服务器的安全性：

  • 对所有用户帐户，尤其是管理员帐户，强制执行强密码策略。

  • 禁用来宾帐户。有关禁用来宾帐户的详细信息，请参阅 Microsoft 知识库文章 320053"How to rename the administrator and guest account in Windows 2000"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320053)。尽管该文章适用于 Windows 2000 Server，但是类似的原则同样适用于 Windows Server 2003。

禁用 SMTP 虚拟服务器上的匿名访问身份验证

  1. 在 Exchange 系统管理器中，依次展开"服务器"、<your inbound Exchange server>、"协议"、SMTP。

  2. 用鼠标右键单击入站 SMTP 虚拟服务器，再单击"属性"。

  3. 选择"访问"选项卡，再单击"身份验证"。

  4. 在"身份验证"中清除"匿名访问"复选框。

有关对 Exchange Server 2003 组织进行配置以便更安全地收发 Internet 邮件的详细信息，请参阅"Exchange Server 2003 传输和路由指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=c092b7a7-9034-4401-949c-b29d47131622&displaylang=zh-cn)。


后台防病毒扫描已启用
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已启用后台病毒扫描：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

如果 Exchange Server 分析工具发现 BackgroundScanning 项的值设置为 1，则显示警告。

当 BackgroundScanning 注册表项存在并设置为 1 时，将在每次防病毒程序的签名文件更新时都在后台重新扫描所有邮件。无论防病毒签名文件何时更新，此行为都会严重地影响性能，因此 Microsoft 不推荐此配置。

如果使用的是基于病毒扫描应用程序编程接口 (VSAPI) 2.0 的防病毒程序，则当客户端试图打开邮件时，会进行比较以确保邮件正文和附件已被当前的病毒签名文件扫描。如果未使用当前的签名模式文件扫描内容，则相应的邮件将提交到防病毒程序，然后，客户端才能使用该邮件。

如果安装的防病毒程序不包括使用户可以禁用后台扫描的用户界面，可以通过按照下面的过程修改 Exchange Server 计算机上的注册表来控制此行为。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

  3. 在右侧窗格中，双击 BackgroundScanning 值。

  4. 在"数值数据"字段中，将值更改为 0。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange Information Store 服务和防病毒软件服务，以使更改生效。
  • 编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

  • 有关 Exchange 使用的不同类型的防病毒扫描程序的详细信息，请参阅知识库文章 328841"XADM：Exchange 和防病毒软件"(http://support.microsoft.com/kb/328841/zh-cn)。


CheckPop3Tail 值已更改
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取下列注册表项，以确定以下注册表值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\CheckPop3Tail

如果 Exchange Server 分析工具发现 CheckPop3Tail 值存在并配置为 1，则会显示非默认配置消息。

Internet 工程任务组 (IETF) Request for Comments (RFC) 1939 (http://www.ietf.org/rfc/rfc1939.txt) 指定了 POP3 邮件的 CRLF 终止序列。在 Exchange 领域，CRLF 序列称为 POP3Tail。如果 POP3 客户端（如 Microsoft Office Outlook® 2003 或 Microsoft Outlook Express）遇到了具有错误的 POP3Tail 的不正确邮件（例如，缺少 CRLF），会停止响应，从而使得收件箱中的邮件不能全部下载。管理员可以使用 CheckPop3Tail 注册表值来指示 Microsoft Exchange POP3 服务检查每个 POP3 邮件的 POP3Tail，并在缺少终止序列时添加正确的终止序列。

注意：
此设置将更正不正确的邮件，并使 POP3 客户端能够下载用户收件箱中的所有邮件。但是，它也会导致性能稍稍下降，因为要检查每个邮件中是否有正确的 POP3Tail。

如果需要，可以按照下面的步骤删除 CheckPop3Tail 注册表值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

删除 CheckPop3Tail 注册表值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. 删除名为 CheckPop3Tail 的值。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange POP3 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关使用 CheckPop3Tail 注册表值的详细信息，请参阅知识库文章 816896"XCCC：您试图下载邮件时 POP3 客户端停止响应（挂起）或超时"(http://support.microsoft.com/kb/816896/zh-cn)。


防卫邮件系统已启用
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定是否已将 heuristics 属性配置为启用防卫邮件系统。默认情况下不配置 heuristics 属性。如果 Exchange Server 分析工具发现 heuristics 属性已设置为 256，则 Exchange Server 分析工具将显示非默认配置消息。

Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。

防卫邮件系统 (DMS) 计划由国防部助理部长（采购）制订，简化和协调集成公共用户邮件系统的开发，满足编写和阅读邮件的用户的要求，降低成本和人员水平，提高功能、安全性、稳定性和可用性。

有关防卫邮件系统的详细信息，请参阅 Lockheed Martin 网站 (http://www.lockheedmartin.com)。

注意：
Web 地址可能会改变，所以，也许无法连接到此处提到的网站。


禁用 MAPI 客户端警告
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2007-05-01

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已设置 MAPI 客户端阻止功能：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable MAPI Clients

如果 Exchange Server 分析工具发现设置的 Disabled MAPI Clients 值以 -10、-11 或 -12 开头，Exchange Server 分析工具将显示警告。

默认情况下，Disable MAPI Clients 项不启用。因此，管理员可以阻止特定 Microsoft Office Outlook® 版本连接到运行 Exchange 2000 Server、Exchange Server 2003 或 Exchange Server 2007 的计算机上。

如果设置 Disabled MAPI Clients 项以使其值以 -10、-11 或 -12 开头，则会阻止整个范围内的 MAPI 版本。这些范围对应于 Outlook 2000、Outlook 2003 和 Outlook 2007 版本以及 Exchange Server 2003 中的 Exchange 系统助理。如果阻止 Exchange 系统助理服务，可能会导致 Exchange Server 无法正常运行。

若要解决该警告问题，请按照允许所有版本的 Outlook 访问服务器中的建议和过程进行操作。

有关阻止特定 MAPI 客户端连接到运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328240"How to put server-side restrictions on clients that are used to access Exchange 2000 mailboxes"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328240)

  • 288894"How to disable MAPI client access to an Exchange Server 2003 computer or to an Exchange 2000 Server computer"（如何禁止 MAPI 客户端访问 Exchange Server 2003 计算机或 Exchange 2000 Server 计算机）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=288894)

有关阻止特定 MAPI 客户端连接到运行 Exchange Server 2007 的计算机的详细信息，请参阅 Exchange Server 2007 产品文档中的 Exchange 命令行管理程序"Set-CasMailbox"cmdlet (http://go.microsoft.com/fwlink/?LinkId=80698)。

有关如何为较早版本的 Outlook 下载安全更新以及阻止其他版本的 Outlook 的详细信息，请参阅 Slowing and Stopping E-Mail Viruses in an Exchange Server 2003 Environment（在 Exchange Server 2003 环境中抑制和阻止通过电子邮件传播的病毒）(http://go.microsoft.com/fwlink/?LinkId=30732)。


已设置 DisableSMTPMailboxAddressing 值
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2006-08-11

Microsoft® Exchange Server 分析工具将读取以下注册表项，以确定是否将该值设置为禁用简单邮件传输协议 (SMTP) 邮箱寻址：

HKeyLocalMachine\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\DisableSMTPMailboxAddressing

如果 DisableSMTPMailboxAddressing 项的值为 1，则表示 SMTP 邮箱寻址已禁用（真）；而如果其值为 0，则表示 SMTP 邮箱寻址未禁用（假）。

如果 Exchange Server 分析工具确定已使用值 1 将 DisableSMTPMailboxAddressing 项的值设置为禁用 SMTP 邮箱寻址，则会显示警告。

此错误指示 SMTP 邮箱寻址已禁用。这可能会导致与此服务器连接的 Microsoft Exchange ActiveSync 客户端出现同步错误。

若要解决此警告，请将 DisableSMTPMailboxAddressing 项的值设置为 0。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
修改 DisableSMTPMailboxAddressing 项的值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：

HKeyLocalMachine\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA

  1. 在右窗格中，找到并双击 DisableSMTPMailboxAddressing

  2. 将值由 1 更改为 0。

  3. 关闭注册表编辑器，并重新启动 Server 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关与此警告相关的同步错误的详细信息，请参阅 Microsoft 知识库文章 886346"You receive an HTTP_500 error message when you synchronize your mobile device with Microsoft Exchange Server 2003"（将移动设备与 Microsoft Exchange Server 2003 同步时收到 HTTP_500 错误消息）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=886346)。


用户负载分布
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2006-09-06

Microsoft® Exchange Server 分析工具确定您的服务器上每秒执行的 RPC 操作计数过高。

如果您的服务器上每秒执行的 RPC 操作计数过高，则可以使用 Exchange Server User Monitor (ExMon) 来确定负载的分布方式。确定负载是否由下列某种情况引起非常重要：

  • 活动用户数量相对较少。

  • 负载在多个用户之间分布。

如果 Exchange Server 分析工具确定一个用户导致负载百分比过高，则显示一条警告，说明高使用率可以追溯到一个用户。如果没有出现这种情况，则 Exchange Server 分析工具将显示一条消息，说明负载在多个用户之间分布。

注意：
RPC 通讯量随时间而变化。因此，若要静态地捕获有关用户如何使用 Exchange 的数据，则可能需要收集数据多次。

此外，某些常见用户操作通常在较短时期内占用大量 CPU。不必考虑此活动，除非同一用户频繁地或长时间占用大量 CPU。

注意：
如果高负载是由已知的服务或进程导致的，而可以预料到此服务或进程会产生高负载，并且此服务或进程需要处理许多用户的请求，因此产生的负载高于单个用户产生的负载，那么，您可以安全地忽略此警告。产生负载高于单个用户产生负载的服务或进程的示例包括：用于同步移动设备的某些服务、用于管理忙/闲数据的服务器进程、与语音邮件或统一消息有关的服务，以及用于移动用户的服务器进程。
更正此问题

  • 如果 RPC 速率过高（对于某个用户或所有用户），则请查看用户是否具有桌面搜索引擎、第三方客户端插件或者同步电子邮件与用户邮箱的移动设备。有关解决第三方应用程序问题的详细信息，请参阅在客户端上禁用第三方加载项。

  • 用户的默认文件夹以及常用文件夹中的项目数应小于 5,000。

  • 最佳做法是使邮箱的大小小于或等于 1 GB。对于引起负载过高的用户，建议他们将其邮箱项目存档为 .pst 文件。然后，可以再次运行 Exchange 性能 (Perfmon) 工具以查看用户是否仍然导致负载过高。

  • 请与用户联系，以确定可以访问客户端电子邮件应用程序的客户端应用程序。删除这些应用程序，然后一次重新安装一个应用程序，以观察这些应用程序对服务器的影响。

  • 在解决用户负载问题时，通常会出现误报现象。因此，建议在出现高负载期间再次运行 ExMon 以查看分析是否一致。

详细信息

  • 若要下载 Exchange Server User Monitor (ExMon)，请参阅 Microsoft 下载中心 (http://go.microsoft.com/fwlink/?LinkId=54983)。

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关解决 Outlook 客户端性能问题的详细信息，请参阅 Microsoft 知识库文章 905803"Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)。

  • 有关桌面搜索软件的详细信息，请参阅 Microsoft 知识库文章 905184"Exchange 2000 Server and Exchange Server 2003 performance may be affected when desktop search engine software is running on Outlook or other MAPI client computers"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184)。


用于 OMA 和 EAS 的 Exchange 虚拟目录已被覆盖
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Exchange ActiveSync® 的 SMTP 代理地址是否已被覆盖：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MasSync\Parameters\ExchangeVDir

如果 Exchange Server 分析工具发现 ExchangeVDir 注册表项存在并已配置，则显示非默认配置消息。

ExchangeVDir 注册表项供 Microsoft Outlook® Mobile Access 和 Exchange ActiveSync 使用。它指定当 Outlook Mobile Access 和 Exchange ActiveSync 访问用户邮箱所在的 Exchange Server 2003 后端服务器上的 Microsoft Office Outlook Web Access for Exchange Server 2003 模板以及 WebDAV 时使用的虚拟目录。

如果 ExchangeVDir 项不存在，或者未设置值，将使用默认值 /Exchange。否则，将包含虚拟目录的名称（包括斜杠字符"/"）。当要为 Outlook Mobile Access 或 Exchange ActiveSync 指定虚拟目录时，可以配置该值。

Exchange Server 2003 中存在一个已知的问题，也就是当在单个 Exchange Server 2003 计算机拓扑中使用基于表单的身份验证时，Exchange 移动服务不工作。当 Exchange Server 2003 后端服务器上的 /Exchange 虚拟目录配置为要求安全套接字层 (SSL) 时，或者当启用了基于表单的身份验证时，Outlook Mobile Access 无法访问此虚拟目录。当在前端服务器上的 /Exchange 虚拟目录中启用这些设置时，不会出现此问题。

可以通过创建 ExchangeVDir 注册表值来解决此问题。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：

    HKLM\System\CurrentControlSet\Services\MasSync\Parameters

  3. 检查和（如果需要）更改 ExchangeVDir 值。

  4. 关闭注册表编辑器。如果进行了更改，请重新启动 Exchange Server 计算机，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关解决此问题的详细信息，请参阅知识库文章 817317"Mapping Multiple Proxy Addresses to Multiple Back-End Virtual Root Directories on the Same Server Is Not Supported"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=817317)。


检测到 Exchange 病毒扫描 API 兼容产品，但是当前未启用它
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Exchange Server 计算机上是否启用了与病毒扫描应用程序编程接口 (VSAPI) 兼容的软件：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Exchange Server 分析工具还查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Ese.dll 的 Version 关键字的值。Ese.dll 是 Exchange 数据库存储引擎，也称为可扩展存储引擎 (ESE)。

最后，Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定具有对象类 msExchExchangeServer 的所有对象的 serialNumber 属性值。如果字符串值包含"Version 5.5"，说明计算机运行的是 Microsoft Exchange Server 5.5。如果字符串值包含"Version 6.0"，说明计算机运行的是 Microsoft Exchange 2000 Server。如果字符串值包含"Version 6.5"，说明计算机运行的是 Microsoft Exchange Server 2003。

如果 Exchange Server 分析工具发现 Version 的值不包含子字符串 6 作为其版本信息的一部分，但 serialNumber 的值指示已安装了 Exchange 2000 Server 或 Exchange Server 2003，则表明非 Exchange 版本的 ESE 正在 Exchange Server 上运行。

如果 Exchange Server 分析工具确定未运行非 Exchange 版本的 ESE，并且 VirusScan\Enabled 注册表项的值等于 0，则会显示警告。如果 Exchange Server 分析工具确定非 Exchange 版本的 ESE 正在 Exchange Server 上运行，则会显示单独的警告。

通常建议您在简单邮件传输协议 (SMTP) 网关或在驻留有邮箱的 Exchange Server 计算机上部署为了邮件系统而设计的防病毒软件。若要获得最大的保护，请在网关运行用于扫描传入 Mime 邮件的防病毒软件，并在使用 VSAPI 2.0 (Exchange 2000 Server) 或 VSAPI 2.5 (Exchange Server 2003) 的 Exchange Server 计算机上运行扫描程序。

此外，还应当在客户端计算机上运行防病毒软件。如果在网关或在 Exchange 服务器上运行为邮件系统而设计的防病毒软件（这表示它可以分析和扫描 MIME），那么在客户端计算机上运行文件级别的扫描程序就已足够了。

解决此警告问题

  1. 在防病毒软件程序用户界面中，启用 VSAPI 扫描。

  2. 如果在启用 VSAPI 扫描之后问题继续存在，请与防病毒软件供应商联系，以寻求协助。

有关通常与 Microsoft Exchange Server 2003 一起使用的病毒扫描程序的详细信息，请参阅 Microsoft 知识库文章 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)。

有关通常与 Microsoft Exchange 2000 Server 一起使用的病毒扫描程序的详细信息，请参阅知识库文章 328841"Exchange 和防病毒软件"(http://support.microsoft.com/kb/328841/zh-cn)。

有关加强 Exchange 环境的防御措施以抵抗通过电子邮件传输的病毒和蠕虫的详细信息，请参阅"在 Exchange 2003 环境中抑制和阻止通过电子邮件传输的病毒"(http://www.microsoft.com/downloads/details.aspx?FamilyID=fb3f649a-2b0a-443d-92a5-8f8cf4bf9fdb&DisplayLang=zh-cn)。


检测到 Exchange 病毒扫描 API 兼容产品，但它没有正确安装
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定与病毒扫描应用程序编程接口 (VSAPI) 兼容的软件是否正在计算机上运行并且引用了有效的库：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

如果 Exchange Server 分析工具发现 Library 的值不包含 VSAPI 防病毒库文件 (DLL) 的有效路径，则会显示警告。

通常建议在简单邮件传输协议 (SMTP) 网关或在驻留有邮箱的 Exchange Server 计算机上部署为邮件系统而设计的防病毒软件。若要获得最大的保护，请在网关运行用于扫描传入 Mime 邮件的防病毒软件，并在使用 VSAPI 2.0 (Exchange 2000 Server) 或 VSAPI 2.5 (Exchange Server 2003) 的 Exchange Server 计算机上运行扫描程序。

此外，还应当在客户端计算机上运行防病毒软件。如果在网关或在 Exchange 服务器上运行为邮件系统而设计的防病毒软件（这表示它可以分析和扫描 MIME），那么在客户端计算机上运行文件级别的扫描程序就已足够了。

解决此警告问题

  1. 卸载防病毒软件然后重新安装它。

  2. 如果重新安装软件之后问题仍然存在，请与防病毒软件供应商联系，以便寻求帮助。

有关通常与 Microsoft Exchange Server 2003 一起使用的病毒扫描程序的详细信息，请参阅 Microsoft 知识库文章 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)。

有关通常与 Microsoft Exchange 2000 Server 一起使用的病毒扫描程序的详细信息，请参阅知识库文章 328841"Exchange 和防病毒软件"(http://support.microsoft.com/kb/328841/zh-cn)。

有关加强 Exchange 环境的防御措施以抵抗通过电子邮件传输的病毒和蠕虫的详细信息，请参阅"在 Exchange 2003 环境中抑制和阻止通过电子邮件传输的病毒"(http://www.microsoft.com/downloads/details.aspx?FamilyID=fb3f649a-2b0a-443d-92a5-8f8cf4bf9fdb&DisplayLang=zh-cn)。


Exchange 病毒扫描 API 的线程数较低
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 ScanningThreads 的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

ScanningThreads 注册表值表示最多可以为扫描分配的病毒扫描 API (VSAPI) 线程数。

Exchange Server 分析工具还读取以下注册表项，以确定是否启用了 VSAPI 邮件扫描：

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Enabled 的值为 1 说明启用了 VSAPI 扫描。值为 0 说明未启用 VSAPI 扫描。

此外，Exchange Server 分析工具还查询 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定为 NumberOfProcessors 关键字设置的值。该值代表计算机上安装的处理器数，包括物理处理器和逻辑处理器。使用 Intel 的超线程技术，一个物理处理器可以拆分为两个逻辑处理器。

如果 Exchange Server 分析工具发现启用了 VSAPI 扫描的 Exchange Server 计算机上的 ScanningThreads 值小于 (2 × NumberOfProcessors) + 1，则会显示警告。ScanningThreads 的最佳值等于 (2 × NumberOfProcessors) + 1。例如，在有两个处理器的 Exchange Server 计算机上，ScanningThreads 的最佳值为 5。

注意：
如果启用了超线程，NumberOfProcessors 的值将是物理处理器数的两倍。建议您与防病毒软件制造商联系，确定在上述公式中应使用物理处理器还是逻辑处理器。
重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

  3. 在右侧窗格中，双击"ScanningThreads"。

  4. 输入根据上述公式得出的值。

  5. 关闭注册表编辑器，然后重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关超线程技术的详细信息，请访问 Intel 网站 (http://www.intel.com/technology/hyperthread)。

注意：
Web 地址可能会改变，所以，也许无法连接到此处提到的网站。


外部 DNS 服务器用于 SMTP
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Exchange Server 对象的 protocolCfgSMTPServer 类中 msExchSMTPExternalDNSServers 属性值。protocolCfgSMTPServer 类包含 SMTP 虚拟服务器的设置。如果 msExchSMTPExternalDNSServers 属性已设置，则 SMTP 虚拟服务器将使用外部 DNS 服务器。如果 Exchange Server 分析工具发现 msExchSMTPExternalDNSServers 属性已设置，则显示警告。

如果将 SMTP 虚拟服务器配置为使用外部 DNS 服务器，则可能会遇到性能问题。因此，建议不要使用该配置。

更改 SMTP 虚拟服务器上的外部 DNS 设置

  1. 在 Exchange 系统管理器中，依次展开"服务器"、<您的入站 Exchange 服务器>、"协议"、SMTP。

  2. 用鼠标右键单击 SMTP 虚拟服务器，再单击"属性"。

  3. 单击"传递"选项卡，再单击"高级"。

  4. 单击"配置"配置外部 DNS 服务器。

  5. 若要添加外部 DNS 服务器，单击"添加"，在"添加"对话框中键入外部 DNS 服务器的 IP 地址，再单击"确定"。

  6. 若要删除外部 DNS 服务器，请选择 IP 地址，再单击"删除"。

  7. 单击"确定"。

有关在 Exchange Server 2003 组织中配置 DNS 的详细信息，请参阅"Exchange Server 2003 传输和路由指南"中的"配置 DNS"(http://www.microsoft.com/downloads/details.aspx?FamilyID=c092b7a7-9034-4401-949c-b29d47131622&displaylang=zh-cn)。

有关在 Exchange 中配置 SMTP 连接器以链接到 Internet 域的详细信息，请参阅 Microsoft 知识库文章 319426"How To：在 Exchange 中配置 SMTP 连接器以链接到 Internet 域"(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=319426)。


前端服务器正在使用基本身份验证
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否在前端服务器和后端服务器之间配置了基本身份验证：

HKEY_LOCAL_MACHINE\CurrentControlSet\Services\MSExchangeWeb\DAV\UseBasicAuthToBE

如果 Exchange Server 分析工具发现已设置了 UseBasicAuthToBE 关键字，则显示非默认配置消息。

默认情况下，Exchange Server 2003 前端服务器使用 Kerberos 身份验证来帮助保护用户凭据在前端服务器与后端服务器之间的安全性。如果 Kerberos 身份验证失败，将记录警告事件，并且前端服务器将改为尝试 NTLM。如果 NTLM 失败，将记录错误。30 分钟后将重试 Kerberos。当 Exchange 2000 Server 或 Exchange Server 2003 前端计算机向 Exchange 2000 Server 后端计算机验证身份时，将使用 NTLM。

设置 UseBasicAuthToBE 注册表项将覆盖此默认逻辑，它强制 Exchange 前端服务器对与后端服务器的所有通信使用基本身份验证。如果 Exchange 组织中有 1,000 个以上的邮箱存储，则必须设置此注册表项。有一个已知的问题，即：当用户使用 Microsoft Office Outlook® Web Access for Exchange Server 2003 并通过拥有 1,000 个以上的邮箱存储的组织中的前端服务器访问邮箱时，将无法访问其邮箱。

如果邮箱存储的数目未超过 1,000，并且没有理由要强制使用基本身份验证，应考虑删除 UseBasicAuthToBE 注册表项。

基本身份验证以明文形式发送凭据。如果您在设置了 UseBasicAuthToBE 注册表项的情况下运行 Exchange 前端服务器，则强烈建议您使用 IPSec 加密。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

删除 UseBasicAuthToBE 注册表项

  1. 在 Exchange 前端服务器上，打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Service\MSExchangeWeb\Dav\ UseBasicAuthToBE.

  3. 用鼠标右键单击"UseBasicAuthToBE"，再单击"删除"，然后单击"是"。

  4. 打开"服务"MMC 管理单元，用鼠标右键单击"IIS Admin 服务"，再单击"重新启动"。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


网关服务器 PING 失败
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具查询 Win32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 类，以确定从非 Exchange 网关服务器返回的 StatusCode 关键字的值。Win32_PingStatus 返回一个具有 24 个属性的对象，这些属性可提供有关该类发送的 Ping 数据包的详细信息。

如果 Exchange Server 分析工具发现此关键字的值与下表中的某个值匹配，则 Exchange Server 分析工具会显示错误。

Exchange Server 分析工具显示网关服务器名称、Exchange Server 名称，以及随此错误返回的相应的 StatusCode 值。

StatusCode 值 含义 说明

11001

缓冲区太小

因为 Exchange Server 分析工具将生成标准请求，所以不可能出现该错误。

11002

目标网络不可访问

因为包含目标计算机的网络不可访问，所以请求失败。没有到目标计算机的有效路由。

有关信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"（http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487）。

11003

目标主机不可访问

因为目标计算机不可访问，所以请求失败。

有关信息，请参阅 Active Directory 服务器停机或不可访问。

该错误也可能是由下列某种情况而引起的：

  • 防火墙位于运行 Exchange Server 分析工具的位置与目标域控制器之间。

  • DNS 错误。

有关信息，请参阅知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11004

目标协议不可访问

因为目标计算机对数据包的协议没有响应，所以请求失败。

运行 Exchange Server 分析工具的位置与目标域控制器之间的防火墙也可能导致此错误。

11005

目标端口不可访问

因为目标计算机上的端口不可用，所以请求失败。

有关信息，请参阅知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11006

无资源

因为网络资源不足，所以请求失败。

有关信息，请参阅知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11007

错误选项

因为请求中包含无效选项，所以请求失败。

因为 Exchange Server 分析工具将生成标准请求，所以不可能出现该错误。

11008

硬件错误

请求因为硬件错误而失败。

通过运行由计算机制造商提供的硬件健全检查工具来验证域控制器是否正常运行。

11009

数据包太大

因为包含请求的数据包大于位于源计算机和目标计算机之间的路由器节点或网关节点的最大传输单元 (MTU)，所以请求失败。MTU 定义可传输的最大数据包大小。

Exchange Server 分析工具所发送的请求不会大于 10 KB。确认组织中的路由器和网关的配置是正确的。

有关信息，请参阅知识库文章 159211"Diagnoses and Treatment of Black Hole Routers"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211)。

11010

请求已超时

在指定时间内未收到回复。默认的允许回复时间为 5 秒。

有关信息，请参阅知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11011

错误请求

因为请求的编码不正确，所以请求失败。

因为 Exchange Server 分析工具将生成标准请求，所以不可能出现该错误。

11012

错误路由

因为源计算机和目标计算机之间没有有效路由，所以请求失败。

有关信息，请参阅知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11013

传输 TimeToLive 已过期

因为其生存期 (TTL) 值已达到零，所以请求失败。这会导致转发路由节点或网关节点丢弃数据包。

有关信息，请参阅知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11014

重组 TimeToLive 已过期

因为数据包为了进行传输而被分为多个片断，在分配的重组时间内未收到所有片断，所以请求失败。RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) 将必须收到所有数据包片断的时间限制指定为 60 秒。

有关信息，请参阅知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11015

参数问题

因为某个路由器节点或网关节点在处理数据包头时遇到问题，所以请求失败。如果头中包含无效的字段数据或无法识别的选项，则可能会出现此情况。

因为 Exchange Server 分析工具将生成标准请求，所以不可能出现该错误。

11016

源结束

因为数据包已被丢弃，所以请求失败。当源计算机的输出队列的存储空间不足时，就会出现此情况。当数据包因到达目标计算机的速度太快而无法得到处理时也可能会出现此情况。

因为 Exchange Server 分析工具将生成标准请求，所以不可能出现该错误。

11017

选项太大

因为请求中包含无效选项，所以请求失败。

因为 Exchange Server 分析工具将生成标准请求，所以不可能出现该错误。

11018

错误目标

请求可能会因下列某个原因而失败：

  • 目标 IP 地址无法收到 PING 请求。

  • 目标 IP 地址不应出现在任何 IP 数据报的目标地址字段中。

运行 Exchange Server 分析工具的位置与目标域控制器之间的防火墙也可能导致此错误。

11032

正在协商 IPSEC

因为 IPsec 连接无法协商，所以请求失败。

11050

一般性失败

请求因未知原因而失败。

有关信息，请参阅知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。


IIS 6.0 MaxFieldLength 参数设置不正确
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已在注册表中对 HTTP 请求的最大字段长度进行了硬编码。

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters\MaxFieldLength

Exchange Server 分析工具还检查以下注册表项，以确定目标计算机上运行的 Microsoft Windows® 操作系统版本。

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 的值为 4.0 说明计算机正在运行 Microsoft Windows NT® Server 4.0。值为 5.0 表明计算机运行的是 Microsoft Windows 2000 Server 操作系统，值为 5.2 表明计算机运行的是 Microsoft Windows Server™ 2003 操作系统。

最后，Exchange Server 分析工具还检查 root\MicrosoftExchangeV2 命名空间中的 Exchange_Server Windows Management Instrumentation (WMI) 类，以确定 IsFrontEndServer 关键字的值。值为 False 说明 Exchange Server 计算机不是前端服务器。值为 True 说明 Exchange Server 计算机是前端服务器。

如果 Exchange Server 分析工具发现符合下列条件的 Exchange 后端服务器上的 MaxFieldLength 值未设置为 32768，则显示警告：

  • Exchange 后端服务器正在运行 Windows Server 2003。

  • Exchange 后端服务器未配置为前端服务器。

  • Exchange 后端服务器包含的邮箱超过 500 个。

MaxFieldLength IIS 注册表参数默认情况下不存在，它指定任何单独的 HTTP 客户端请求的最大大小。该值通常与随附值 MaxRequestBytes 一起设置。在大型环境中，如果没有将这些值设置为 32768，Microsoft Office Outlook® Web Access for Exchange Server 用户可能会发生登录失败。具体地说，缺少这些值可能导致"HTTP 400 - 错误的请求"错误。配置 MaxFieldLength 注册表值时，还必须将 MaxRequestBytes 参数设置为 32768，以便使同时属于超过 75 个组的用户能够登录到 Outlook Web Access。MaxRequestBytes 注册表值决定了请求行和请求头的总计大小的上限。如果它的值低于 MaxFieldLength，将调整 MaxFieldLength 值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

设置 MaxRequestBytes 和 MaxFieldLength 参数

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：

    HKLM\System\CurrentControlSet\Services\HTTP\Parameters

  3. 右键单击"Parameters"，再单击"新建"|"DWORD 值"，并将该值命名为 MaxFieldLength。

  4. 右键单击"Parameters"，再单击"新建"|"DWORD 值"，并将该值命名为 MaxRequestBytes。

  5. 在右侧窗格中，双击"MaxFieldLength"并将它的值设置为 32768（十进制）。

  6. 在右侧窗格中，双击"MaxRequestBytes"并将它的值设置为 32768（十进制）。

  7. 关闭注册表编辑器，并重新启动 IIS Admin 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Internet 信息服务 (IIS) 的 HTTP 注册表设置的详细信息，请参阅知识库文章 820129"INF：用于 IIS 的 Http.sys 注册表设置"(http://support.microsoft.com/kb/820129/zh-cn)。


IIS 6.0 MaxRequestBytes 参数设置不正确
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2007-01-05

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已在以下注册表中对 HTTP 请求的最大大小进行了硬编码：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters\MaxRequestBytes

Exchange Server 分析工具还检查以下注册表项，以确定目标计算机上运行的 Microsoft Windows® 操作系统的版本：

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 的值为 4.0 说明计算机正在运行 Microsoft Windows NT® Server 4.0。值为 5.0 说明计算机正在运行 Microsoft Windows 2000 Server 操作系统，值为 5.2 说明计算机正在运行 Microsoft Windows Server™ 2003 操作系统。

最后，Exchange Server 分析工具还检查 root\MicrosoftExchangeV2 命名空间中的 Exchange_Server Windows Management Instrumentation (WMI) 类，以确定 IsFrontEndServer 关键字的值。值为 False 说明 Exchange Server 计算机不是前端服务器。值为 True 说明 Exchange Server 计算机是前端服务器。

如果 Exchange Server 分析工具发现符合下列条件的 Exchange 后端服务器上的 MaxRequestBytes 值设置为 32768，则显示警告：

  • Exchange 后端服务器正在运行 Windows Server 2003。

  • Exchange 后端服务器未配置为前端服务器。

  • Exchange 后端服务器包含的邮箱超过 500 个。

MaxRequestBytes 注册表值（默认情况下不存在）用于确定请求行和请求头的总计大小的上限。该值通常与伴随值 MaxFieldLength 一起设置。MaxFieldLength IIS 注册表参数指定任何单个 HTTP 客户端请求的最大大小。在大型环境中，如果没有将这些值设置为 32768，Microsoft Office Outlook® Web Access for Exchange Server 用户可能会发生登录失败。具体地说，缺少这些值可能导致"HTTP 400 - 错误的请求"错误。配置 MaxFieldLength 注册表值时，还必须将 MaxRequestBytes 参数设置为 32768，以便使同时属于超过 75 个组的用户能够登录到 Outlook Web Access。如果它的值低于 MaxFieldLength，将调整 MaxFieldLength 值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

设置 MaxRequestBytes 和 MaxFieldLength 参数

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：

    HKLM\System\CurrentControlSet\Services\HTTP\Parameters

  3. 右键单击"Parameters"，选择"新建"|"DWORD 值"，并将该值命名为 MaxFieldLength。

  4. 右键单击"Parameters"，选择"新建"|"DWORD 值"，并将该值命名为 MaxRequestBytes。

  5. 在右侧窗格中，双击"MaxFieldLength"，并将它的值设置为 32768（十进制）。

  6. 在右侧窗格中，双击"MaxRequestBytes"，并将它的值设置为 32768（十进制）。

  7. 关闭注册表编辑器，并重新启动 IIS Admin 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Internet 信息服务 (IIS) 的 HTTP 注册表项设置的详细信息，请参阅知识库文章 820129"INF：用于 IIS 的 Http.sys 注册表设置"(http://support.microsoft.com/kb/820129/zh-cn)。


已在注册表中设置 IMAP4 兼容标记
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定以下注册表值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\Compatibility

如果 Exchange Server 分析工具发现 Compatibility 值存在并已配置为值 0xfffffffe（十六进制），则显示非默认配置消息。

使用 IMAP4 和邮局协议版本 3 (POP3) 的 Exchange Server Internet 协议 (IP) 客户端计算机完全使用流式存储 (.stm) 文件来读取和写入数据。当 IP 客户端通过 POP3 或 IMAP4 请求下载邮件时，包含此用户邮箱的 Exchange 信息存储将在对收件箱中要发送给客户端的邮件进行传输之前，先计算该邮件的准确大小。在大型环境中，尤其是在驻留 Exchange 的环境中，这样的计算会占用大量时间。Compatibility 值代表了一个配置机会，它使管理员能够指示 Exchange 存储使用近似的邮件大小，而不是准确的邮件大小计算结果。

Compatibility 注册表值对 Exchange IMAP4 服务可用（如本文中所述），并且对 Exchange POP3 服务可用（如 已在注册表中设置 POP3 兼容标记 中所述）。

在移动很多邮箱或包含几个 MIME 邮件的邮箱时，Compatibility 注册表值也是有用的。移动数据时，数据将从流式存储提升到 MAPI 存储（.edb 文件）中。对于使用 POP3 和 IMAP4 来访问其邮箱的客户端来说，在数据库或服务器之间移动它们的邮箱之后，这些客户端可能遇到性能问题。用户登录之后，必须计算邮件大小，并且会在内存中和服务器磁盘上执行 MAPI 到 MIME 的转换。在极端情况下，当执行该操作时，可能会在 Exchange Server 计算机上创建非常大型的临时文件。

并非所有 POP3 和 IMAP4 邮件客户端都能配合 Compatibility 注册表值集正确工作。更改此设置会造成一些较旧的邮件客户端（例如 Fetchmail）中断。设置此注册表项还会破坏 IMAP4 协议的 RFC 兼容性。如果在用 POP3 和 IMAP4 下载邮件时遇到问题，并且正在使用 Compatibility 注册表值，那么，作为邮件下载问题的故障排除步骤，可以使用下面的过程删除该注册表值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

删除 Compatibility 注册表值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. 删除名为 Compatibility 的值。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange Information Store 服务和 IIS Admin 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关使用 Compatibility 注册表值的详细信息，请参阅下列知识库文章：

  • 317722"XADM:Client Latencies Occur When Exchange 2000 Converts Mail from MAPI to MIME Format"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=317722)

  • 329067"XADM:Move Mailbox Functionality Promotes Contents of .stm Files"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329067)


IMAP4 MaxBufferSize 值已经更改
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2007-08-07

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定以下注册表值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

如果 Exchange Server 分析工具发现 MaxBufferSize 值存在并已配置为大于 0 的任何数字值，则会显示非默认配置消息。

MaxBufferSize 注册表值在 Exchange 前端/后端拓扑结构中使用。它定义了在前端服务器和后端服务器之间的 TCP/IP 缓冲区大小。默认的缓冲区大小是 1 KB。在具有高滞后时间的网络上，通过调整 MaxBufferSize 值可以提高 IMAP4 客户端的性能。

将 TCP/IP 缓冲区大小设置为 MaxBufferSize 注册表值时，应当总是以 1,024 的倍数来设置缓冲区大小。建议您用下列缓冲区大小测试前端/后端服务器配置性能，以确定适合组织的最佳值：

  • 8,192 字节

  • 16,384 字节

  • 32,768 字节

建议您不要将 MaxBufferSize 注册表项设置为大于 32,768 的值。但是，如果缓冲区大小值为 65,536，您可能会注意到性能有所提高，具体取决于网络情况。更大的缓冲区大小会用掉 Exchange Server 计算机的更多内存，并且可能减少能够访问前端服务器的用户数。虽然系统对 MaxBufferSize 注册表值可以具有的最大值没有限制，但如果为该注册表项分配太大的值，则可能遇到不稳定的性能和内存问题。

注意：
若要使用 MaxBufferSize 注册表值，必须运行 Exchange 2000 Server Service Pack 2 或更高版本。

如果 MaxBufferSize 注册表值设置过低，则性能将得不到提高，并且 Exchange Server 分析工具将显示错误消息（如 IMAP4 MaxBufferSize 值太低中所述）。如果 MaxBufferSize 注册表值设置过高，则会导致系统不稳定，并且 Exchange Server 分析工具将显示错误消息（如 IMAP4 MaxBufferSize 值太高中所述）。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

配置 MaxBufferSize 值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. 创建一个名为 MaxBufferSize 的新 DWORD 值。

  4. 双击 MaxBufferSize 值，并将它设置为新的缓冲区大小（字节）。例如，可以输入 8192，将它设置为 8,192 字节。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange IMAP4 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关何时以及如何使用 MaxBufferSize 注册表值的详细信息，请参阅知识库文章 823857"XADM:IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers"（可能为英文网页）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857)。


IMAP4 MaxBufferSize 值太高
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2007-08-07

Microsoft® Exchange Server 分析工具读取 Exchange Server 计算机上的注册表，以确定以下注册表值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

如果 Exchange Server 分析工具发现 MaxBufferSize 值存在并已配置为超过 32768 的任何数字值，则显示警告。

MaxBufferSize 注册表值在 Exchange 前端/后端拓扑结构中使用。它定义了在前端服务器和后端服务器之间的 TCP/IP 缓冲区大小。默认的缓冲区大小是 1 KB。在具有高滞后时间的网络上，通过调整 MaxBufferSize 值可以提高 IMAP4 客户端的性能。

利用 MaxBufferSize 注册表值设置 TCP/IP 缓冲区大小时，应当始终以 1,024 的倍数来设置缓冲区大小。建议您用下列缓冲区大小测试前端/后端服务器配置性能：

  • 8,192 字节

  • 16,384 字节

  • 32,768 字节

使用该注册表项时，必须将它至少设置为 1,024。建议您不要将 MaxBufferSize 注册表项设置为大于 32,768 的值。但是，如果缓冲区大小值为 65536，您可能会注意到性能有所提高，具体取决于网络情况。更大的缓冲区大小会用掉 Exchange Server 计算机的更多内存，并且可能减少能够访问前端服务器的用户数。虽然系统对 MaxBufferSize 注册表值可以具有的最大值没有限制，但如果为该注册表项分配太大的值，则可能遇到不稳定的性能和内存问题。

注意：
若要使用 MaxBufferSize 注册表值，必须运行 Exchange 2000 Server Service Pack 2 或更高版本。

如果将 MaxBufferSize 注册表值设置过低，则性能不会有所提高，并且 Exchange Server 分析工具将显示错误消息（如 IMAP4 MaxBufferSize 值太低中所述）。如果将 MaxBufferSize 注册表值设置得太高，则可能导致系统不稳定，并且 Exchange Server 分析工具将显示消息（如本文所述）。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. 创建一个名为 MaxBufferSize 的新 DWORD 值。

  4. 双击 MaxBufferSize 值，并将它设置为新的缓冲区大小（字节）。例如，可以输入 8192，将它设置为 8,192 字节。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange IMAP4 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关何时以及如何使用 MaxBufferSize 注册表值的详细信息，请参阅知识库文章 823857"XADM:IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857)。


IMAP4 MaxBufferSize 值太低
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2007-08-07

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定以下注册表值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

如果 Exchange Server 分析工具发现 MaxBufferSize 值存在并已配置为大于 0 但小于 1024 的任何数字值，则显示错误。

MaxBufferSize 注册表值在 Exchange 前端/后端拓扑结构中使用。它定义了在前端服务器和后端服务器之间的 TCP/IP 缓冲区大小。默认的缓冲区大小是 1 KB。在具有高滞后时间的网络上，通过调整 MaxBufferSize 值可以提高 IMAP4 客户端的性能。

将 TCP/IP 缓冲区大小设置为 MaxBufferSize 注册表值时，应当总是以 1,024 的倍数来设置缓冲区大小。建议您用下列缓冲区大小测试前端/后端服务器配置性能，以确定适合组织的最佳值：

  • 8,192 字节

  • 16,384 字节

  • 32,768 字节

使用该注册表项时，必须将它至少设置为 1,024。建议您不要将 MaxBufferSize 注册表项设置为大于 32,768 的值。但是，如果缓冲区大小值为 65,536，您可能会注意到性能有所提高，具体取决于网络情况。更大的缓冲区大小会用掉 Exchange Server 计算机的更多内存，并且可能减少能够访问前端服务器的用户数。虽然系统对 MaxBufferSize 注册表值可以具有的最大值没有限制，但如果为该注册表项分配太大的值，则可能遇到不稳定的性能和内存问题。

注意：
若要使用 MaxBufferSize 注册表值，必须运行 Exchange 2000 Server Service Pack 2 或更高版本。

如果将 MaxBufferSize 注册表值设置得太低，则性能将不会有所提高，并且 Exchange Server 分析工具将显示错误消息（如本文中所述）。如果将 MaxBufferSize 注册表值设置过高，则可能导致系统不稳定，并且 Exchange Server 分析工具将显示消息（如 IMAP4 MaxBufferSize 值太高中所述）。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

更正此错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. 创建一个名为 MaxBufferSize 的新 DWORD 值。

  4. 双击 MaxBufferSize 值，并将它设置为新的缓冲区大小（字节）。例如，可以输入 8192，将它设置为 8,192 字节。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange IMAP4 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关何时以及如何使用 MaxBufferSize 注册表值的详细信息，请参阅知识库文章 823857"XADM:IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers"（可能为英文网页）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857)。


MAPI 操作失败
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具已确定服务器报告了许多 MAPI 失败。有时，有些 MAPI 操作应返回错误。但是有时，客户端应用程序可能没有正确响应错误。因此，应用程序可能会重新发出导致错误的 RPC 请求，从而增大了服务器的负载。

MAPI 客户端批量请求项目列表时，在 Exchange 已返回请求之后仍继续请求项目，此时经常会发生客户端错误。例如，客户端计算机可能会请求给定文件夹中包含附件的所有项目。客户端可能会进一步请求每批返回 30 个项目。某些情况下，在 Exchange 服务器已返回了请求中的最后一个项目之后，客户端将继续请求新一批的 30 个项目。在上述情况下，Exchange 返回"找不到"的错误。如果即使在返回了"找不到"的错误之后，客户端计算机仍继续请求项目，那么客户端计算机无法正确响应错误。在这种情况下，Exchange Server User Monitor (ExMon) 将报告多次 MAPI 失败。此时，尽管失败次数与操作数的比率很高，但是会出现较高的失败速率。预计失败速率较高的 MAPI 操作包括 GetPerUserGuid、ImportMsgMove 和 Logon。

更正此错误

  1. 使用 ExMon 确定造成多次 MAPI 失败的用户或用户组。

  2. 确定客户端计算机上造成此问题的应用程序。

  3. 修复或删除造成该问题的应用程序。

详细信息

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。


MaxClientRequestBuffer 设置为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定该关键字是否存在：

HKEY_LOCAL_MACHINE System\CurrentControlSet\w3svc\Parameters\MaxClientRequestBuffer

如果 Exchange Server 分析工具发现 MaxClientRequestBuffer 注册表项已设置，则 Exchange Server 分析工具将显示非默认值消息。

默认情况下，此注册表值不存在。

Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。

有关 MaxClientRequestBuffer 注册表项的详细信息，请参阅 Microsoft 知识库文章 260694"Description of the MaxClientRequestBuffer Registry Value"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260694)


MaxClientRequestBuffer 的设置太低
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 MaxClientRequestBuffer 值的数值数据：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer

如果 Exchange Server 分析工具发现 MaxClientRequestBuffer 值的数值数据低于 16,384，则 Exchange Server 分析工具将显示警告。

如果 MaxClientRequestBuffer 的值太低，则可能造成 Microsoft Office Outlook® Web Access 用户出错。尤其可能会将 HTTP 400 - Bad Request 返回浏览器。若要解决此警告问题，建议您将该值增大到大于 16,384 的数字，或删除该注册表值，以恢复到默认设置。默认情况下，MaxClientRequestBuffers 值不存在。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
通过增大数值数据的值来解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer

  3. 双击 MaxClientRequestBuffer 值并编辑数值数据。将数值数据设置为大于等于 16,384 的十进制数字。

  4. 关闭注册表编辑器，然后重新启动 Exchange 服务器。
通过删除该值来解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer

  3. 用鼠标右键单击 MaxClientRequestBuffer 值，再单击"删除"。

  4. 关闭注册表编辑器，然后重新启动 Exchange 服务器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 MaxClientRequestBuffer 注册表值的详细信息，请参阅 Microsoft 知识库文章 260694"Description of the MaxClientRequestBuffer Registry Value"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=260694)。


配置了多个 SMTP 端口绑定
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchServerBindings 属性的配置值是否已配置了多个端口绑定。默认情况下，msExchServerBindings 属性配置为 TCP 端口 25。如果 Exchange Server 分析工具发现 msExchServerBindings 属性配置了多个端口绑定，将显示非默认配置消息。

msExchServerBindings 属性代表该简单邮件传输协议 (SMTP) 服务器用来侦听传入连接的 TCP 端口。可以将 SMTP 虚拟服务器配置为侦听一个或多个 TCP 端口。默认情况下，所有 SMTP 虚拟服务器均配置为侦听 TCP 端口 25。如果对内部邮件基础结构的其他部分进行了相应修改，可以更改 SMTP 侦听端口。但是，对于直接从 Internet 接受邮件的 SMTP 虚拟服务器，通常应使用端口 25，因为 Internet 上的 SMTP 服务器通过端口 25 发送邮件。

注意，Exchange Server 分析工具检查 Exchange SMTP 协议虚拟服务器的值。Exchange SMTP 协议虚拟服务器可能是直接从 Internet 接收邮件的 SMTP 服务器，也可能不是。一些防病毒产品和防垃圾邮件产品设计为通过端口 25 接收来自 Internet 的 SMTP 邮件，而通过另一个端口将邮件重定向到 Exchange SMTP 虚拟服务器。

查看或修改 SMTP 虚拟服务器侦听端口

  1. 在 Exchange 系统管理器中，依次展开"服务器"、Exchange 服务器、"协议"、SMTP。

  2. 用鼠标右键单击 SMTP 虚拟服务器（例如，默认的 SMTP 虚拟服务器），再单击"属性"。

  3. 选择"常规"选项卡，再单击"高级"。

  4. 将显示 IP 地址和端口列表。

    • 若要更改现有端口，请选择 IP 地址，再单击"编辑"。

    • 若要删除现有端口，请选择 IP 地址，再单击"删除"。

  5. 若要保存更改，请单击"确定"，再单击"确定"退出"高级"对话框。

  6. 单击"确定"关闭 SMTP 虚拟服务器的"属性"对话框。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列 Microsoft 知识库文章：

  • 266686"XCON:如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)

  • 268163"XCON:How to Configure a SMTP Virtual Server Part 2"（英文） (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


PING 答复的大小不一致
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具使用特定 BufferSize 设置值查询 Win32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 类，并将其与返回的 BufferSize 值进行比较，以确定它们是否相同。

如果返回的 BufferSize 值不同于已发送的值，则 Exchange Server 分析工具将显示警告。

该警告表示数据包在传输过程中的某个位置被截断了。这可能表示存在一般性的网络故障，也可能表示环境中存在黑洞路由器。

在 TCP/IP 广域网 (WAN) 中，如果中间网络分段的数据包大小比通信主机小，而且路由器没有发送针对此情况的相应 ICMP 响应，则通过某些路由器的通信可能会失败。该路径上的防火墙也会减缓这种响应。导致该情况的路由器有时被称为"黑洞"路由器。

黑洞路由器的存在会导致多种错误，而在程序连接到本地子网上的计算机时，则不会出现这些错误。此行为可能时断时续，但是在更仔细地检查情况时，可能会发现此行为再次出现，例如，让客户端读取从远程主机发送的大型文件时就会再次出现。

有关详细信息，请按照 Microsoft 知识库文章 314825"如何对黑洞路由器问题进行故障排除"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825) 中的指南进行操作。

详细信息

有关检测和处理可能出现的黑洞路由器的详细信息，请参阅下列资源：

  • Microsoft 知识库文章 159211"Diagnoses and Treatment of Black Hole Routers"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211)。

  • "Path Maximum Transmission Unit (PMTU) Black Hole Routers"（英文）(http://go.microsoft.com/fwlink/?LinkId=66963)。


未执行 Ping 测试
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2006-08-09

Microsoft® Exchange Server 分析工具将尝试查询 Win32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 类，以分析各种邮件流特定配置设置的响应对象。

Win32_PingStatus 通常会返回一个具有 24 个属性的对象，这些属性提供有关类发送的 ping 数据包的详细信息。

如果连续经过六次尝试后，Exchange Server 分析工具未收到响应其查询的预期对象，则会显示警告。

此警告指示可能无法执行 Win32_PingStatus。

出现这种失败最有可能的原因是，尝试执行 Win32_PingStatus 命令的计算机是在 Microsoft Windows® 2000 Server 操作系统上运行的。Windows 2000 Server 不支持 Win32_PingStatus WMI 类。

如果尝试执行 Win32_PingStatus 命令的计算机不是在 Windows 2000 Server 操作系统上运行的，则此问题可能是由一般网络问题或权限问题引起的。

更正此错误

  1. 请确保已启动了 Exchange Server 计算机并已将其连接到网络。

  2. 在运行了 Exchange Server 分析工具的计算机上使用 PING 命令，以确定是否可以到达 Exchange Server 目标计算机。

  3. 在与 Exchange 目标服务器位于同一子网的服务器上使用 PING 命令，以确定是否可以到达 Exchange Server 目标计算机。

  4. 如果有防火墙，请检查以确定远程过程调用 (RPC) 端口是否被阻止。

  5. 检查运行 Exchange Server 分析工具的帐户的权限。运行 Exchange Server 分析工具的帐户必须对其扫描的每台 Exchange 服务器都拥有本地管理员权限。

有关网络连接问题的详细信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

有关 Exchange Server 分析工具连接问题的详细信息，请参阅"Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"（解决连接问题的 Microsoft Exchange Server 最佳实践分析工具）(http://go.microsoft.com/fwlink/?LinkId=56285)。

有关 Win32_PingStatus WMI 类的详细信息，请参阅 MSDN® 文章"Win32_PingStatus"(http://go.microsoft.com/fwlink/?linkid=33549)。


纯文本防病毒扫描已被禁用
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 RTF 邮件防病毒扫描的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

如果 Exchange Server 分析工具发现 ScanPlainText 的值被设置为 0，则会显示警告。

ScanPlainText 注册表项是由使用 Exchange 病毒扫描 API (VSAPI) 的第三方防病毒软件供应商设置的。建议您扫描所有类型的邮件（包括纯文本邮件）以查看是否有病毒。应当对流经 Exchange Server 计算机的所有邮件启用病毒扫描。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

更正此错误

  • 在支持 Exchange 的防病毒应用程序中，启用对所有邮件的扫描。

    - 或者 -

  • 执行下列过程，手动修改注册表中的项：

    1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

    2. 导航到：

      HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

    3. 双击 ScanPlainText 注册表项，将它的"数值数据"设置为 1。

    4. 退出注册表编辑器，并重新启动 Microsoft Exchange Information Store 服务以及代表支持 Exchange 的防病毒软件的服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关防御病毒的详细信息，请参阅网站上的"在 Exchange 2003 环境中抑制和阻止通过电子邮件传输的病毒"(http://www.microsoft.com/downloads/details.aspx?FamilyID=fb3f649a-2b0a-443d-92a5-8f8cf4bf9fdb&DisplayLang=zh-cn)。


已在注册表中设置 POP3 兼容标记
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定以下注册表值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\Compatibility

如果 Exchange Server 分析工具发现 Compatibility 值存在并已配置为值 0xfffffffe（十六进制），则会显示非默认配置消息。

使用 IMAP4 和邮局协议版本 3 (POP3) 的 Exchange Server Internet 协议 (IP) 客户端计算机完全使用流式存储 (.stm) 文件来读取和写入数据。当 IP 客户端使用 POP3 或 IMAP4 请求下载邮件时，包含此用户的邮箱的 Exchange 存储将在传输邮件之前，计算收件箱中要发送给客户端的邮件的准确大小。在大型环境中，尤其是在驻留 Exchange 的环境中，这样的计算会占用非常多的时间。Compatibility 值代表了一个配置机会，它使管理员能够指示 Exchange 存储使用近似的邮件大小，而不是准确的邮件大小计算结果。

Compatibility 注册表值对 Exchange POP3 服务可用（本文将对此进行描述），并且对 Exchange IMAP4 服务可用（在 已在注册表中设置 IMAP4 兼容标记 中有相关描述）。

在移动大量邮箱时，或移动有大量的多用途 Internet 邮件扩展 (MIME) 邮件的邮箱时，Compatibility 注册表值也是有用的。移动数据时，数据将从流式存储提升到 MAPI 存储（.edb 文件）中。对于使用 POP3 和 IMAP4 来访问其邮箱的客户端来说，在数据库或服务器之间移动它们的邮箱之后，这些客户端可能遇到性能问题。用户登录之后，必须计算邮件大小，并且会在内存中和服务器磁盘上进行 MAPI 到 MIME 的转换。在极端的情况下，当发生该行为时，可能会在 Exchange Server 计算机上创建非常大型的临时文件。

并非所有 POP3 和 IMAP4 邮件客户端都能在此 Compatibility 注册表值集下正常工作。更改此设置会造成一些较旧的邮件客户端（例如 Fetchmail）中断。设置此注册表项还会破坏 POP3 协议的 RFC 兼容性。如果在用 POP3 和 IMAP4 下载邮件时遇到问题，并且正在使用 Compatibility 注册表值，那么，作为邮件下载问题的故障排除步骤，可以使用下面的过程删除该注册表值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

删除 Compatibility 注册表值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. 删除名为 Compatibility 的值。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange Information Store 服务和 IIS Admin 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关使用 Compatibility 注册表值的详细信息，请参阅下列知识库文章：

  • 317722"XADM:Client Latencies Occur When Exchange 2000 Converts Mail from MAPI to MIME Format"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=317722)

  • 329067"XADM:Move Mailbox Functionality Promotes Contents of .stm Files"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329067)


POP3 MaxBufferSize 值已经更改
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取下列注册表项，以确定以下注册表值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

如果 Exchange Server 分析工具发现 MaxBufferSize 值存在并已配置为超过 0 的任何数字值，则会显示非默认配置消息。

MaxBufferSize 注册表值在 Exchange 前端/后端拓扑结构中使用。它定义了前端服务器与后端服务器之间的 TCP/IP 缓冲区大小。默认的缓冲区大小是 1 KB。在具有高延迟时间的网络上，通过调整 MaxBufferSize 值可以提高 POP3 客户端的性能。

将 TCP/IP 缓冲区大小设置为 MaxBufferSize 注册表值时，应当总是以 1,024 的倍数来设置缓冲区大小。建议您用下列缓冲区大小测试前端/后端服务器配置性能：

  • 8,192 字节

  • 16,384 字节

  • 32,768 字节

使用该注册表项时，必须将它至少设置为 1,024。建议您不要将 MaxBufferSize 注册表项设置为超过 32,768 的值。但是，如果缓冲区大小值为 65,536，您可能会注意到性能有所提高，视网络情况而定。更大的缓冲区大小会用掉 Exchange Server 计算机的更多内存，并且可能减少能够访问前端服务器的用户数。虽然系统对 MaxBufferSize 注册表值可以具有的最大值没有限制，但如果为该注册表项分配太大的值，则可能遇到不稳定的性能和内存问题。

注意：
若要使用 MaxBufferSize 注册表值，必须运行 Exchange 2000 Server Service Pack 2 或更高版本。

如果将 MaxBufferSize 注册表值设置得太低，性能将不会有提高，并且 Exchange Server 分析工具将显示错误消息（如 POP3 MaxBufferSize 值太低中所述）。如果将 MaxBufferSize 注册表值设置得太高，可能导致系统不稳定，并且 Exchange Server 分析工具将显示错误消息（如 POP3 MaxBufferSize 值太高中所述）。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

更正此错误

  1. 打开注册表编辑器，例如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. 创建一个名为 MaxBufferSize 的 DWORD 值。

  4. 双击 MaxBufferSize 值，并将它设置为新的缓冲区大小（字节）。例如，可以输入 8192，将它设置为 8,192 字节。

  5. 退出注册表编辑器，并重新启动 Microsoft Exchange POP3 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关何时以及如何使用 MaxBufferSize 注册表值的详细信息，请参阅知识库文章 823857"XADM:IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857)。


POP3 MaxBufferSize 值太高
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定以下注册表值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

如果 Exchange Server 分析工具发现 MaxBufferSize 值存在并已配置为超过 32768 的任何数字值，则会显示警告。

MaxBufferSize 注册表值在 Exchange 前端/后端拓扑结构中使用。它定义了在前端服务器和后端服务器之间的 TCP/IP 缓冲区大小。默认的缓冲区大小是 1 KB。在具有高滞后时间的网络上，通过调整 MaxBufferSize 值可以提高 POP3 客户端的性能。

将 TCP/IP 缓冲区大小设置为 MaxBufferSize 注册表值时，应当总是以 1,024 的倍数来设置缓冲区大小。建议您用下列缓冲区大小测试前端/后端服务器配置性能：

  • 8,192 字节

  • 16,384 字节

  • 32,768 字节

使用该注册表项时，必须将它至少设置为 1,024。建议您不要将 MaxBufferSize 注册表项设置为大于 32,768 的值。但是，如果缓冲区大小值为 65,535，您可能会注意到性能有所提高，具体取决于网络情况。更大的缓冲区大小会用掉 Exchange Server 计算机的更多内存，并且可能减少能够访问前端服务器的用户数。虽然系统对 MaxBufferSize 注册表值可以具有的最大值没有限制，但如果为该注册表项分配太大的值，则可能遇到不稳定的性能和内存问题。

注意：
若要使用 MaxBufferSize 注册表值，必须运行 Exchange 2000 Server Service Pack 2 或更高版本。

如果将 MaxBufferSize 注册表值设置得太低，则性能不会有所提高，并且 Exchange Server 分析工具将显示错误消息（如 POP3 MaxBufferSize 值太低中所述）。如果将 MaxBufferSize 注册表值设置得太高，则可能导致系统不稳定，并且 Exchange Server 分析工具将显示消息（如本文所述）。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

更正此错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. 创建一个名为 MaxBufferSize 的新 DWORD 值。

  4. 双击 MaxBufferSize 值，并将它设置为新的缓冲区大小（字节）。例如，可以输入 8192，将它设置为 8,192 字节。

  5. 退出注册表编辑器，并重新启动 Microsoft Exchange POP3 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关何时以及如何使用 MaxBufferSize 注册表值的详细信息，请参阅知识库文章 823857"XADM:IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857)。


POP3 MaxBufferSize 值太低
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定以下注册表值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

如果 Exchange Server 分析工具发现 MaxBufferSize 值存在并已配置为大于 0 但小于 1024 的任何数字值，则显示错误。

MaxBufferSize 注册表值在 Exchange 前端/后端拓扑结构中使用。它定义了在前端服务器和后端服务器之间的 TCP/IP 缓冲区大小。默认的缓冲区大小是 1 KB。在具有高滞后时间的网络上，通过调整 MaxBufferSize 值可以提高 POP3 客户端的性能。

将 TCP/IP 缓冲区大小设置为 MaxBufferSize 注册表值时，应当总是以 1,024 的倍数来设置缓冲区大小。建议您用下列缓冲区大小测试前端/后端服务器配置性能，以确定适合组织的最佳值：

  • 8,192 字节

  • 16,384 字节

  • 32,768 字节

使用该注册表项时，必须将它至少设置为 1,024。建议您不要将 MaxBufferSize 注册表项设置为大于 32,768 的值。但是，如果缓冲区大小值为 65,535，您可能会注意到性能有所提高，具体取决于网络情况。更大的缓冲区大小会用掉 Exchange Server 计算机的更多内存，并且可能减少能够访问前端服务器的用户数。虽然系统对 MaxBufferSize 注册表值可以具有的最大值没有限制，但如果为该注册表项分配太大的值，则可能遇到不稳定的性能和内存问题。

注意：
若要使用 MaxBufferSize 注册表值，必须运行 Exchange 2000 Server Service Pack 2 或更高版本。

如果将 MaxBufferSize 注册表值设置得太低，性能将不会有提高，并且 Exchange Server 分析工具将显示错误消息（如本文中所述）。如果将 MaxBufferSize 注册表值设置得太高，则可能导致系统不稳定，并且 Exchange Server 分析工具将显示消息（如 POP3 MaxBufferSize 值太高 所述）。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

更正此错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. 创建一个名为 MaxBufferSize 的新 DWORD 值。

  4. 双击 MaxBufferSize 值，并将它设置为新的缓冲区大小（字节）。例如，可以输入 8192，将它设置为 8,192 字节。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange POP3 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关何时以及如何使用 MaxBufferSize 注册表值的详细信息，请参阅知识库文章 823857"XADM:IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857)。


端口没有响应
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2006-05-16

Microsoft® Exchange Server 分析工具查询用户定义的服务器，并尝试打开与默认配置 TCP 端口 25 或用户定义的端口上的特定服务器的套接字连接。如果 Exchange Server 分析工具没有收到预期的 xx Available 自定义响应（其中 XX 为默认的端口 25 或用户定义的备选端口号），则 Exchange Server 分析工具将显示错误。

此错误表明无法在所需的 TCP 端口中访问服务器，并且可能出现错误。若要更正此错误，应解决服务器的连接问题。

解决服务器的连接问题

  1. 是否可以从指定的服务器自身通过 Telnet 连接到所需端口？如果不能，则不是网络问题。

  2. 所有硬件是否都已插入？所有硬件是否均正常运行？

  3. DNS 是否正常运行并已正确配置？

  4. 路由器是否正常运行？

  5. 是否有防火墙阻止您进行连接？

有关如何解决服务器连接问题的详细信息，请参阅"Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"（英文）(http://go.microsoft.com/fwlink/?LinkId=56285)。


潜在的黑洞路由器
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具使用各种特定的 BufferSize 和 NoFragmentation 设置值来查询 Win32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 类，以确定 WAN 环境中是否存在黑洞路由器。

BufferSize 设置 | NoFragmentation 设置
548 | True
1472 | True
1472 | False
4096 | True
4096 | False

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • BufferSize 较小且 NoFragmentation 等于 True 的 PING 成功

  • BufferSize 较大且 NoFragmentation 等于 True 的 PING 超时

  • BufferSize 较大且 NoFragmentation 等于 False 的 PING 成功，但回复的 BufferSize 大小不同于发送的 BufferSize 大小。

此错误表明在广域网 (WAN) 中可能存在一个或多个黑洞路由器。

在 TCP/IP WANT 中，如果下列条件为真，则一些路由中的通信可能失败：

  • 中间网络分段的数据包大小小于通信主机的数据包大小

  • 路由器不会发送对此情况的相应 ICMP 响应。

该路径上的防火墙也会减缓这种响应。导致该情况的路由器有时被称为"黑洞"路由器。

黑洞路由器的存在会导致多种错误，而在程序连接到本地子网上的计算机时，则不会出现这些错误。此行为可能时断时续，但是有时您会发现此行为再次出现，例如，通过客户端读取从远程主机发送的大型文件时。

有关详细信息，请按照 Microsoft 知识库文章 314825 中的"如何对黑洞路由器问题进行故障排除"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825) 指南进行操作。

详细信息

有关检测和处理可能出现的黑洞路由器的详细信息，请参阅下列资源：

  • Microsoft 知识库文章 159211"Diagnoses and Treatment of Black Hole Routers"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211)。

  • "The Cable Guy - July 2004"专栏 (http://go.microsoft.com/fwlink/?LinkId=66963) 中的"Path Maximum Transmission Unit (PMTU) Black Hole Routers"（英文）。


远程主机 PING 失败
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2006-05-03

Microsoft Exchange Server 分析工具通过使用各种 BufferSize 和 NoFragmentation 设置来查询 Win32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 类，以确定网络的最大传输单元 (MTU) 的大小，并找到可能的黑洞路由。Exchange Server 分析工具通过对每种设置组合检查从远程主机返回的 StatusCode 关键字值来进行确定。

BufferSize 设置 | NoFragmentation 设置
548 | True
1472 | True
1472 | False
4096 | True
4096 | False

Win32_PingStatus 返回一个具有 24 个属性的对象，这些属性提供有关该类发送的 Ping 数据包的详细信息。

如果 Exchange Server 分析工具发现此关键字的值与下表中的某个值匹配，则 Exchange Server 分析工具会显示错误。

Exchange Server 分析工具显示远程主机名、Exchange Server 名称，以及随此错误返回的相应的 StatusCode 值。

StatusCode 值 含义 说明

11001

缓冲区太小

因为 Exchange Server 分析工具将生成标准请求，所以不可能出现该错误。

11002

目标网络不可访问

因为包含目标计算机的网络不可访问，所以请求失败。没有到目标计算机的有效路由。

有关详细信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11003

目标主机不可访问

因为目标计算机不可访问，所以请求失败。

有关详细信息，请参阅 Active Directory 服务器停机或不可访问。

该错误也可能是由下列某种情况而引起的：

  • 防火墙位于运行 Exchange Server 分析工具的位置与目标域控制器之间。

  • DNS 错误。

有关详细信息，请参阅知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11004

目标协议不可访问

因为目标计算机对数据包的协议没有响应，所以请求失败。

运行 Exchange Server 分析工具的位置与目标域控制器之间的防火墙也可能导致此错误。

11005

目标端口不可访问

因为目标计算机上的端口不可用，所以请求失败。

有关详细信息，请参阅知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11006

无资源

因为网络资源不足，所以请求失败。

有关详细信息，请参阅知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11007

错误选项

因为请求中包含无效选项，所以请求失败。

因为 Exchange Server 分析工具将生成标准请求，所以不可能出现该错误。

11008

硬件错误

请求因为硬件错误而失败。

通过运行由计算机制造商提供的硬件健全检查工具来验证域控制器是否正常运行。

11009

数据包太大

因为包含请求的数据包大于位于源计算机和目标计算机之间的路由器节点或网关节点的最大传输单元 (MTU)，所以请求失败。MTU 定义可传输的最大数据包大小。

Exchange Server 分析工具所发送的请求不会大于 10 KB。确认组织中的路由器和网关的配置是正确的。

有关详细信息，请参阅知识库文章 159211"Diagnoses and Treatment of Black Hole Routers"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211)。

11010

请求已超时

在指定时间内未收到回复。默认的允许回复时间为 5 秒。

有关详细信息，请参阅知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11011

错误请求

因为请求的编码不正确，所以请求失败。

因为 Exchange Server 分析工具将生成标准请求，所以不可能出现该错误。

11012

错误路由

因为源计算机和目标计算机之间没有有效路由，所以请求失败。

有关详细信息，请参阅知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11013

传输 TimeToLive 已过期

因为其生存期 (TTL) 值已达到零，所以请求失败。这会导致转发路由节点或网关节点丢弃数据包。

有关详细信息，请参阅知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11014

重组 TimeToLive 已过期

因为数据包为了进行传输而被分为多个片断，在分配的重组时间内未收到所有片断，所以请求失败。RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) 将必须收到所有数据包片断的时间限制指定为 60 秒。

有关详细信息，请参阅知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11015

参数问题

因为某个路由器节点或网关节点在处理数据包头时遇到问题，所以请求失败。如果头中包含无效的字段数据或无法识别的选项，则可能会出现此情况。

因为 Exchange Server 分析工具将生成标准请求，所以不可能出现该错误。

11016

源结束

因为数据包已被丢弃，所以请求失败。当源计算机的输出队列的存储空间不足时，就会出现此情况。当数据包因到达目标计算机的速度太快而无法得到处理时也可能会出现此情况。

因为 Exchange Server 分析工具将生成标准请求，所以不可能出现该错误。

11017

选项太大

因为请求中包含无效选项，所以请求失败。

因为 Exchange Server 分析工具将生成标准请求，所以不可能出现该错误。

11018

错误目标

请求可能会因下列某个原因而失败：

  • 目标 IP 地址无法收到 PING 请求。

  • 目标 IP 地址不应出现在任何 IP 数据报的目标地址字段中。

运行 Exchange Server 分析工具的位置与目标域控制器之间的防火墙也可能导致此错误。

11032

正在协商 IPSEC

因为 IPsec 连接无法协商，所以请求失败。

11050

一般性失败

请求因未知原因而失败。

有关详细信息，请参阅知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

有关这些测试的详细信息，请参阅 Microsoft 知识库文章 314825"How to Troubleshoot Black Hole Router Issues"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825)。


路由引擎已停止
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Microsoft Exchange Routing Engine 服务 (RESvc) 和简单邮件传输协议 (SMTP) 服务 (SMTPSVC) 是否正在运行。如果 Exchange Server 分析工具发现符合下列任一条件，Exchange Server 分析工具将显示错误：

  • SMTPSVC 正在运行。

  • RESvc 未在运行。

如果所有中继邮件的 Exchange 服务器上均未运行 RESvc，可能会出现路由问题。不支持不运行 RESvc 的中继邮件 Exchange Server 配置。

与 Exchange 2000 Server 类似，Exchange Server 2003 使用链接状态路由算法和路由协议，以链接状态表的形式传播链接状态信息。链接状态表存储在组织中所有 Exchange 2000 Server 和 Exchange Server 2003 服务器上的内存中。

链接状态算法具有下列优势：

  • 每个 Exchange 服务器可以在源端选择最佳的邮件路由，而不必沿着链路不可用的路由发送邮件。

  • 邮件不会再在服务器之间来回传递，因为每个 Exchange 服务器上都包含有关备选路由或冗余路由是否可用的最新信息。

  • 不会再发生邮件循环。较早版本的 Exchange Server 中有时会发生邮件循环问题。

Exchange Server 从链接状态表中收集下列信息：

  • 链接状态表包含整个 Exchange 组织的路由拓扑。

  • 链接状态表包含拓扑中的每个连接器的可用性。可用拓扑的状态为"up"。不可用拓扑的状态为"down"。

  • 链接状态表包含与每个可用连接器关联的成本和地址空间。

Exchange Server 使用该信息确定以最低成本到达目标地址的路由。如果成本为最低的路由上的某个连接器不可用，Exchange Server 会根据成本和连接器可用性来确定最佳的备选路由。链接状态路由必须运行 RESvc。

若要更正此错误，必须将 RESvc 配置为自动启动。还必须确保 RESvc 在工作期间运行。

更正此错误

  1. 单击"开始"，指向"程序"，再指向"管理工具"，然后单击"服务"。

  2. 在服务列表中，用鼠标右键单击 Microsoft Exchange Routing Engine，再单击"属性"。

  3. 在"常规"选项卡的"启动类型"菜单上，选择"自动"，再单击"确定"。

  4. 用鼠标右键单击"Microsoft Exchange Routing Engine"服务，再单击"启动"。

有关在 Exchange Server 2003 中路由邮件的详细信息，请参阅"Exchange Server 2003 传输和路由指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=c092b7a7-9034-4401-949c-b29d47131622&displaylang=zh-cn)。


RPC Performance Counters Indicate Poor Server Performance
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2006-08-24

Microsoft® Exchange Server 分析工具确定服务器未达到最佳的操作性能。Exchange Server 分析工具对多个远程过程调用 (RPC) 性能计数器进行计算。如果 RPC 性能计数器中报告的数据未达到下表中的级别，则显示警告。

Exchange Server 上的用户数 | RPC Averaged Latency 阈值
小于 500 | 平均大于 15
大于或等于 500 但小于 3000 | 平均大于 30
大于 3000 | 平均大于 50

下列性能计数器将在本文进行讨论，并由 MSExchangeIS 性能对象进行管理：

  • RPC Averaged Latency

  • RPC Requests

RPC Averaged Latency

RPC Averaged Latency 性能计数器记录处理最后 1024 个包所用的平均时间 (ms)。延迟是指 Store.exe 进程从接收包到返回包所用的时间。RPC Averaged Latency 性能计数器不包括任何网络延迟，也不包括任何非 Store.exe 进程所引起的任何延迟。虽然 RPC Averaged Latency 性能计数器数据不包括网络传输时间，但是它可提供客户端计算机等待服务器响应的最短时间段的相关数据。如果 RPC Averaged Latency 性能计数器数据低于 50 ms，则服务器可以在合理时间内处理请求。如果在数秒内，该计数器一直大于 50 ms，则表明服务器很难满足负载增加的要求。因此，用户在访问其电子邮件时，可能会遇到延迟。如果平均延迟大于 100 ms，则用户将在其 Microsoft Office Outlook® 客户端计算机中看到以下弹出窗口："Retrieving data from Exchange Server."

解释 RPC Averaged Latency 性能计数器

下列两种情况可能会使 RPC Averaged Latency 计数器出错：

  • 第一种情况是，某些 MAPI 操作预计会占用较长时间。例如，如果客户端计算机搜索包含数千个项目的文件夹试图查找所有符合复杂条件的项目，则通常此操作会占用数秒的时间。如果服务器上的用户较少，则此正在进行的操作可能会导致 RPC Average Latency 中出现峰值。如果服务器上的 RPC 负载较低，则应在较长时间段（至少数分钟）内测定此值的平均值，而不是根据短期且非常不稳定的行为进行测定。

  • 第二种情况可能在服务器上的 RPC 负载非常低时出现。有时，根据最忙用户的活动，延迟可能会出现显著的变化。由于服务器出现严重的超载情况，因此，单个用户频繁操作的结果可能会无意间改变 RPC 平均延迟数据。

RPC Requests

RPC Requests 性能计数器记录 Exchange 当前处理的客户端计算机请求数。此计数器的最大值为 100。Exchange 存储在具有 100 个正在处理的 RPC 操作之后，它通常会拒绝所有的新连接。在正常运行的服务器上，尚未处理的请求数应低于 50。如果此数在很长时间内都大于 50，则表明 RPC 进行备份并等待处理，客户端计算机可能会出现延迟。

解释 RPC 请求

50 个请求这一阈值并不是严格的阈值。负载较少的服务器在计数器达到 30 之前便可能开始出现性能问题；但是，负载过多的服务器在达到 50 个请求时可能还会正常运行。理想的情况是，对于每台服务器，应测量此计数器的基线值。Exchange Server Performance Troubleshooting Analyzer 使用阈值 50，此值适用于大多数大型服务器。

与负载过多的服务器相比，负载较少的服务器的 RPC 请求值较低。这是因为负载较少的服务器只需较少线程便可跟上负载增加的速度。为了避免出现滞后现象并获得较大的 RPC 请求值，较忙的服务器必须执行更多的并行操作。因此，在负载过多的服务器上，较大的 RPC 请求值本身并不表示出现性能问题。若要评估服务器的"缓慢"情况，还必须考虑 RPC Average Latency 性能计数器。

延迟的原因

下列情况可能会导致延迟的增加：

  • RPC 负载增加

  • 一个或多个服务器资源出现瓶颈

而且，瓶颈可能是由下列原因导致：

  • RPC 负载（或服务器上的任何其他负载）过高

  • 硬件故障或配置错误

更正此错误

  • 请遵循下列 Exchange Server 2003 指南中提供的建议和最佳做法：

    • "Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)

    • "Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)


非群集服务器上设置的 RPC 端口范围
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定端口的数值数据：

HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\Internet\Ports

如果发现下列条件为真，Exchange Server 分析工具将显示一条错误消息：

  • HKLM\Software\Microsoft\Rpc\Internet\Ports 注册表项存在。

  • 服务器不是群集 Exchange 服务器。

  • 服务器存在其他错误。

如果该注册表项存在，Exchange Server 将限于使用特定范围的端口进行 RPC 调用。如果 Exchange 服务器负载不重，但当前可用的端口数不能满足需要，可能会发生错误。

要纠正此问题，应为 HKLM\Software\Microsoft\Rpc\Internet\Ports 注册表项再添加 100 个端口，直到问题消失。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
解决此警告问题

  1. 打开注册表编辑器 Regedt32.exe。

    注意：
    要编辑 REG_MULTI_SZ 值，必须使用 Regedt32.exe，而不是 Regedit.exe。

  2. 导航到：HKLM\Software\Microsoft\Rpc\Internet。

  3. 在右侧窗格中，双击 Ports 注册表项。在"值"框中，增大"端口范围"。

  4. 关闭注册表编辑器，然后重新启动 Exchange 服务器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 HKLM\Software\Microsoft\Rpc\Internet 注册表项的详细信息，请参阅 Microsoft 知识库文章 154596"HOWTO：配置与防火墙一起使用的 RPC 动态端口分配"(http://support.microsoft.com/?kbid=154596)。


群集服务器上设置的 RPC 端口范围
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定端口的数值数据：HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\Internet\Ports

如果发现下列条件为真，则 Exchange Server 分析工具将显示一条错误消息：

  • HKLM\Software\Microsoft\Rpc\Internet\Ports 注册表项存在。

  • 服务器是群集 Exchange 服务器。

  • 服务器存在其他错误。

如果该注册表项存在，Exchange Server 将限于使用特定范围的端口进行 RPC 调用。如果 Exchange 服务器负载不重，但当前可用的端口数不能满足需要，可能会发生错误。

要解决此问题，应为 HKLM\Software\Microsoft\Rpc\Internet\Ports 注册表项额外添加 100 个端口，直到问题消失。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
解决此警告问题

  1. 打开注册表编辑器 Regedt32.exe。

    注意：
    要编辑 REG_MULTI_SZ 值，必须使用 Regedt32.exe，而不是 Regedit.exe。

  2. 导航到：HKLM\Software\Microsoft\Rpc\Internet。

  3. 在右侧窗格中，双击 Ports 注册表项。在"值"框中，增大"端口范围"。

  4. 关闭注册表编辑器，然后重新启动 Exchange 服务器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 HKLM\Software\Microsoft\Rpc\Internet 注册表项的详细信息，请参阅 Microsoft 知识库文章 154596"HOWTO：配置与防火墙一起使用的 RPC 动态端口分配"(http://support.microsoft.com/?kbid=154596)。


来自性能计数器的 RPC 用户活动
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2007-02-14

Microsoft® Exchange Server 分析工具已确定服务器当前承受很大的远程过程调用 (RPC) 负载。

每秒 RPC 操作数的速率表明服务器上存在的 RPC 负载是多大。有时，RPC 操作负载的异常增大可能会降低服务器的性能。如果服务器遇到性能问题，则应首先确定服务器的负载是否高于预期值。多个性能计数器可以提供有关服务器上的 RPC 活动的信息。本文讨论的下列性能计数器全部在 MSExchangeIS、MSExchangeIS Public 或 MSExchangeIS Mailbox 性能对象下：

  • RPC OPERATIONS/SEC

  • Active User Count

  • Active Client Logons (MSExchangeIS Public)

  • Active Client Logons (MSExchangeIS Mailbox)

确定客户端 RPC 负载

可以使用两个计数器来确定客户端计算机当前的活动速率。

  • RPC Operations/sec 此计数器提供客户端计算机当前每秒向服务器请求的 RPC 操作数。可以通过下列方式计算用户数：

    • 可以计算服务器上的总邮箱数。

    • 可以通过 MSExchangeIS Public 的 Active Client Logons 与 MSExchangeIS Mailbox 的 Active Client Logons 的总和计算总登录次数。

    • 可以通过 Active User Count 计算总登录次数。

    Exchange Server 分析工具使用最后一种方法。要计算每个活动用户的速率，将 RPC Operations/sec 的平均值除以 Active User Count。

  • RPC Operations/sec per user 此计数器提供用户在服务器上的活动程度的指示。通常，使用 Microsoft Office Outlook® 的知识型员工的速率大约为邮箱服务器上每个用户每秒 0.1 个操作。如果服务器上的用户要运行其他应用程序，那么该数字可能会增加。

如果 Exchange Server 分析工具确定每个用户每秒的 RPC 操作数大于 0.15 但是小于 0.25，则认为用户的活动程度为中等，Exchange Server 分析工具将显示警告。

如果 Exchange Server 分析工具确定每个用户每秒的 RPC 操作数大于 0.25，则认为用户的活动程度异常，Exchange Server 分析工具将显示错误。

如果 RPC 负载很大该怎么办

如果每秒的操作数大于预期值，则应首先尝试确定高负载的原因，然后减小负载。可以使用 Exchange Server User Monitor (ExMon) 工具来确定特定用户是否发出高速率的 RPC 操作。

如果无法减小服务器的负载，则必须确定性能瓶颈并提高服务器的处理能力。

确定高登录次数

服务器必须在内存中保留一些有关登录的信息（无论在用户内存中还是在内核内存中）。留出的内存量有限。如果使用此内存，服务器则可能会遇到内存瓶颈。因此，如果 Exchange 服务器遇到性能问题，则应确保每个用户的总登录次数未过量。

通常，知识型员工将有两到三次登录。如果用户要运行其他应用程序，则登录次数可能会增加。Exchange Server 分析工具计算每个用户的登录次数，方法是使用服务器的总登录次数除以服务器上的邮箱数。可以确定服务器的总登录次数，方法是将 MSExchangeIS Mailbox 和 MSExchangeIS Public 性能对象的 Active Client Logons 性能计数器加在一起。对于邮箱服务器或混合邮箱和公用文件夹的服务器，Exchange Server 分析工具只查看此比率。

注意：
如果大量用户要查看其他用户的共享文件夹（例如共享日历），登录次数也可能会增加。

如果每个用户的平均登录次数超过五次，并且服务器遇到内存瓶颈，可能表明用户正在运行的应用程序产生大量登录。如果商业用途不需要用户所运行的应用程序，那么请求用户不要运行使 Exchange 服务器登录次数过量的应用程序。

如果无法减少用户所运行的应用程序数，则必须通过将用户转移到其他服务器来减少每个服务器的用户数。要确定是否许多用户进行登录或是否单个用户进行次数异常多的登录，可以使用 Exchange 系统管理器查看每个用户的活动登录。

详细信息

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（Microsoft Exchange Server 性能疑难解答）(http://go.microsoft.com/fwlink/?LinkId=47588)。


RTF 防病毒扫描已禁用
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 RTF 邮件防病毒扫描的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

如果 Exchange Server 分析工具发现 ScanRTF 的值设置为 0，则显示警告。

ScanRTF 注册表项是由使用 Exchange 病毒扫描 API (VSAPI) 的第三方防病毒软件供应商设置的。通过 RTF 邮件，可以使用颜色、字体和格式，但是 RTF 只能被 Microsoft Office Outlook® 2003 识别。Exchange Server RTF 格式不同于在诸如 Microsoft Office Word 2003 这样的字处理程序中读取 RTF 格式的文件。

建议您扫描所有类型的邮件（包括 RTF 邮件）以查看是否有病毒。应当对流经 Exchange Server 计算机的所有邮件启用病毒扫描。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

更正此错误

  1. 在支持 Exchange 的防病毒应用程序中，启用对所有邮件的扫描。

    或者

  2. 执行下列过程，手动修改注册表中的项：

    • 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

    • 导航到：

      HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

    • 双击 ScanRTF 注册表项，将它的"数值数据"设置为 1。

    • 退出注册表编辑器，并重新启动 Microsoft Exchange Information Store 服务以及代表支持 Exchange 的防病毒软件的服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关防御病毒的详细信息，请参阅网站上的"在 Exchange 2003 环境中抑制和阻止通过电子邮件传输的病毒"(http://www.microsoft.com/downloads/details.aspx?FamilyID=fb3f649a-2b0a-443d-92a5-8f8cf4bf9fdb&DisplayLang=zh-cn)。


已经自定义了 SMTP 标题
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具尝试向简单邮件传输协议 (SMTP) 域的邮局主管帐户或用户定义的帐户发送邮件。如果 Exchange Server 分析具从该帐户收到的响应与以下默认响应不同，则会显示警告。

"220 Computer Name .Domain Name .com Microsoft ESMTP MAIL Service, Version:Version Number ready at Date Time +0000"

此警告表示，在程序连接到 Exchange SMTP 虚拟服务器时出现的默认响应已经被自定义了。

如果 Exchange Server 管理员已经按照 Microsoft 知识库文章 281224"XCON：如何修改 SMTP 标题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=281224) 中所介绍的方式特意更改了标题，则自定义的 SMTP 标题可能不会有问题。

如果 Exchange Server 管理员还没有特意自定义默认的 SMTP 标题，则此警告可能表示 Exchange Server 处于正在筛选 Exchange Server Extended SMPT (ESMTP) 命令的防火墙或 SMTP 代理之后。

如果筛选 Exchange Server ESMTP 命令，则会对 Exchange 性能产生显著影响，可能导致 Microsoft 知识库文章 320027"在 Cisco PIX 防火墙后无法发送或接收电子邮件"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027) 中所描述的行为。

有关自定义的 SMTP 标题的详细信息，请参阅下列 Microsoft 知识库文章：

  • "XCON：如何修改 SMTP 标题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=281224)。

  • "在 Cisco PIX 防火墙后无法发送或接收电子邮件"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027)。


SMTP 实例已暂停
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2006-05-16

Microsoft® Exchange Server 分析工具查询 IIS 元数据库，以便确定简单邮件传输协议 (SMTP) 虚拟服务器的各个实例的 ServerState 属性值。

ServerState 属性可显示服务器实例的当前状态。状态和相应的状态代码如下所示：1（正在启动），2（已启动），3（即将停止)），4（已停止），5（即将暂停)，6（已暂停）或 7（正在继续）。

如果 Exchange Server 分析工具确定 SMTP 虚拟服务器实例的 ServerState 属性的值等于 6（已暂停），则 Exchange Server 分析工具会显示错误。

SMTP 是 Exchange Server 进行邮件提交和邮件传输的本机邮件协议。这意味着客户端使用 SMTP 发送邮件，而 Exchange 服务器使用 SMTP 传递邮件和邮件数据。

虚拟服务器运行在一个服务器进程下，您可以启动、停止或暂停此进程，就像处理其他服务器进程一样。例如，如果要更改虚拟服务器的配置或执行其他维护任务，则可能必须停止该虚拟服务器以进行更改，然后重新启动它。在停止虚拟服务器后，该服务器将不接受来自用户的连接，也无法使用它传递或检索邮件。

停止虚拟服务器的另一种作法是暂停它。暂停虚拟服务器后，该服务器将阻止新客户端的连接，但不会断开当前的连接。暂停 SMTP 虚拟服务器后，活动客户端可以继续提交邮件，虚拟服务器也可以传递排队等候传递的现有邮件。但不会接受新的连接。

对于普通邮件操作，Exchange Server SMTP 虚拟服务器实例应为"已启动"。

若要解决此错误，请执行下列步骤来启动 SMTP 虚拟服务器实例。

启动 SMTP 虚拟服务器实例

  1. 在 Exchange 系统管理器中，用鼠标右键单击要启动的虚拟服务器实例。

  2. 在"操作"菜单上，单击"启动"。

有关如何启动、停止或暂停 SMTP 虚拟服务器的详细信息，请参阅下列 Microsoft 知识库文章：

  • "XCON：如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)。

  • "XCON：如何配置 SMTP 虚拟服务器（第 2 部分）"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)。

  • "XIMS:How to Flush the SMTP Mail Queue in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=251087)。

  • "XGEN:Disabling Protocols in Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=291330)。


SMTP 实例已停止
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2006-05-16

Microsoft® Exchange Server 分析工具查询 IIS 元数据库，以便确定简单邮件传输协议 (SMTP) 虚拟服务器的各个实例的 ServerState 属性值。

ServerState 属性可显示服务器实例的当前状态。状态和相应的状态代码如下所示：1（正在启动），2（已启动），3（即将停止)），4（已停止），5（即将暂停)，6（已暂停）或 7（正在继续）。

如果 Exchange Server 分析工具确定 SMTP 虚拟服务器实例的 ServerState 属性的值等于 4（已停止），则 Exchange Server 分析工具会显示错误。

SMTP 是 Exchange Server 进行邮件提交和邮件传输的本机邮件协议。这意味着客户端使用 SMTP 发送邮件，而 Exchange 服务器使用 SMTP 传递邮件和邮件数据。

虚拟服务器运行在一个服务器进程下，您可以启动、停止或暂停此进程，就像处理其他服务器进程一样。例如，如果要更改虚拟服务器的配置或执行其他维护任务，则可能必须停止该虚拟服务器以进行更改，然后重新启动它。在停止虚拟服务器后，该服务器将不接受来自用户的连接，也无法使用它传递或检索邮件。

对于普通邮件操作，Exchange Server SMTP 虚拟服务器实例应为"已启动"。

若要解决此错误，请执行下列步骤来启动 SMTP 虚拟服务器实例。

启动 SMTP 虚拟服务器实例

  1. 在 Exchange 系统管理器中，用鼠标右键单击要启动的虚拟服务器实例。

  2. 在"操作"菜单上，单击"启动"。

有关如何启动、停止或暂停 SMTP 虚拟服务器的详细信息，请参阅下列 Microsoft 知识库文章：

  • "XCON：如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)。

  • "XCON：如何配置 SMTP 虚拟服务器（第 2 部分）"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)。

  • "XIMS:How to Flush the SMTP Mail Queue in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=251087)。

  • "XGEN:Disabling Protocols in Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=291330)。


SMTP 最大收件人数的设置可能太低
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchSmtpMaxRecipients 属性的配置值是否小于 250。默认情况下，msExchSmtpMaxRecipients 属性配置为 64,000 个收件人。如果 Exchange Server 分析工具发现为 msExchSmtpMaxRecipients 属性配置的值小于 250，则 Exchange Server 分析工具将显示警告。

从安全角度考虑，最好限制每封邮件的最大收件人数。建议将 msExchSmtpMaxRecipients 属性的设置保留默认值 64000。

每个组织应根据自己的业务要求，确定可接受的最大收件人数。但是，建议最大收件人数的设置值不要小于 250。发向多个通讯组列表的邮件的收件人数很可能大于 250。如果最大收件人数的设置值小于 250，则 Exchange 必须使用邮件的其他副本来处理剩余的收件人。增加的邮件副本会增大网络通信量。

查看并配置最大收件人数

  1. 打开 Exchange 系统管理器。

  2. 展开"服务器"，展开 Exchange 服务器，展开"协议"，再展开 SMTP。

  3. 用鼠标右键单击 SMTP 虚拟服务器（例如，默认 SMTP 虚拟服务器），再选择"属性"。

  4. 选择"邮件"选项卡。

  5. 若要还原到默认设置 64000，请确保选中了"限制每封邮件的收件人数不超过"复选框并输入值 64000。此外，还可以使用任何所需的值配置此字段，或清除该复选框，以便不限制收件人数。

  6. 单击"确定"保存更改，并关闭 SMTP 虚拟服务器的"属性"对话框。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列 Microsoft 知识库文章：

  • 266686"XCON:如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)

  • 268163"XCON:How to Configure a SMTP Virtual Server Part 2"（英文） (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


EAS 的 SMTP 代理地址已被覆盖
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

错误消息

简介

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Exchange ActiveSync® 的 SMTP 代理地址是否已被覆盖：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MasSync\Parameters\SMTPProxy

如果 Exchange Server 分析工具发现 SMTPProxy 注册表项存在并已配置，则会显示非默认配置消息。

在 Exchange Server 中，SMTP 地址用来标识邮箱的路径，并且它们必须是唯一的。每个地址都有左侧 (LHS) 部分和右侧 (RHS) 部分，二者以 @ 符号分隔。例如，SMTP 地址的格式如下所示：

用户名@域.com = 左侧@右侧（或 LHS@RHS）

Exchange ActiveSync 使用 WebDAV 请求访问 Exchange 服务器中的邮箱信息。Exchange ActiveSync 选择要在 WebDAV 请求中使用的关联的 RHS 值，并用 LHS@RHS 代表 SMTP 代理地址。在其默认的 RHS 地址与用户的主 SMTP 地址不同的环境中，SMTPProxy 注册表值提供了一个配置机会，以便允许 Exchange ActiveSync 使用备用的 SMTP 代理地址。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

查看或修改 SMTPProxy 注册表值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：

    HKLM\System\CurrentControlSet\Services\MasSync\Parameters

  3. 检查和（如果需要）更改 SMTPProxy 值。

  4. 如果进行了更改，请关闭注册表编辑器，并重新启动 Exchange Server 计算机，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Exchange ActiveSync 的详细信息，请参阅"Exchange Server 2003 ActiveSync Architecture"（英文）(http://go.microsoft.com/fwlink/?linkid=34203)。

有关移动访问和 Exchange Server 2003 的详细信息，请参阅"Mobile Access Using Exchange 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=20098)。


SMTP 服务器接受基本身份验证
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Exchange Server 对象的 protocolCfgSMTPServer 类中 msExchAuthenticationFlags 属性的值。protocolCfgSMTPServer 类包含 SMTP 虚拟服务器的设置。msExchAuthenticationFlags 属性代表 SMTP 服务器上允许的身份验证类型。如果 Exchange Server 分析工具确定在 SMTP 服务器上配置了基本身份验证，并且该服务器不是 Microsoft Small Business Server 2000 或 Microsoft Windows® Small Business Server 2003，则 Exchange Server 分析工具将显示警告消息。

如果在 SMTP 服务器上配置了基本身份验证，则安全违规的风险会增大。基本身份验证允许以明文形式通过网络发送用户名和密码。未经加密的用户名和密码很容易在 Internet 上被截获。

如果使用基本身份验证，强烈建议您要同时使用传输层安全 (TLS) 加密，以提高安全性。TLS 对用户名、密码和邮件数据进行加密。可以要求连接到 SMTP 虚拟服务器的客户端使用 TLS 加密。TLS 设计用于帮助保护传出邮件，但 TLS 无法帮助保护从客户端传输到服务器的通信。

Microsoft Outlook Express 支持 TLS。若要对 SMTP 虚拟服务器使用 TLS 加密，必须创建密钥对并配置密钥证书。然后，客户端即可使用 TLS 对与 SMTP 服务的会话进行加密。因此，所有邮件均将发送。SMTP 服务还可以使用 TLS 对与远程服务器的会话进行加密。

注意：
不支持 TLS 的客户端无法通过虚拟服务器中继电子邮件。

如果因为业务原因不能在 SMTP 虚拟服务器上禁用通过身份验证（例如合作伙伴公司的身份验证）的访问，请执行下列步骤以帮助提高网关服务器的安全性：

  • 对所有用户帐户，尤其是管理员帐户，强制执行强密码策略。

  • 禁用来宾帐户。有关禁用来宾帐户的详细信息，请参阅 Microsoft 知识库文章 320053"How to rename the administrator and guest account in Windows 2000"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320053)。尽管该文章适用于 Microsoft Windows 2000 Server，但是类似的原则同样适用于 Windows Server™ 2003。

禁用基本身份验证

  1. 在 Exchange 系统管理器中，依次展开"服务器"、<您的入站 Exchange 服务器>、"协议"、SMTP。

  2. 用鼠标右键单击入站 SMTP 虚拟服务器，再单击"属性"。

  3. 选择"访问"选项卡，再单击"身份验证"。

    "身份验证"对话框

  4. 在"身份验证"中，清除"基本身份验证"复选框。

    重要信息：
    如果使用基本身份验证，请考虑实现 TLS，以提高安全性。如果拥有数字证书，可以使用"要求 TLS 加密"复选框。在对安全性要求很高的环境中，数字证书很常见。选中此复选框后，如果用户没有指定域，必须在相应的"默认域"框中键入用户应进行身份验证的 Windows 2000 Server 域名或 Windows Server 2003 域名。有关 TLS 加密的详细信息，请参阅 Exchange 联机文档。

有关如何对 Exchange Server 2003 组织进行配置以便更安全地收发 Internet 邮件的详细信息，请参阅"Exchange Server 2003 传输和路由指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=c092b7a7-9034-4401-949c-b29d47131622&displaylang=zh-cn)。


已禁用 SMTP 服务
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2006-05-16

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定为简单邮件传输协议 (SMTP) 服务 StartMode 关键字设置的值。Disabled 的值表示已禁用了简单邮件传输协议 (SMTP) 服务，并且在将 StartMode 值更改为 Manual 或 Automatic 之前不能启动该服务。

Exchange Server 分析工具查询 Win32_Service WMI 类，以确定 SMTP 服务的 Started 关键字的值。值为 False 说明服务未运行。值为 True 说明服务正在运行。

如果 Exchange Server 分析工具发现在启动了 SMTP 服务的 Exchange Server 计算机上 StartMode 关键字的值设置为 Disabled，则 Exchange Server 分析工具将显示错误。

Windows SMTP 服务是 Internet 信息服务 (IIS) 的组件，并作为 Inetinfo.exe 的一部分来运行。Exchange Server 将依赖 SMTP 服务作为其本机传输协议。因此，Exchange 使用 SMTP 来路由所有内部邮件和外部邮件。

所有 Exchange Server 计算机都应将 SMTP 服务设置为 Automatic。

若要解决该错误，必须在路由邮件的服务器上将 SMTP 服务配置为自动启动。

将简单邮件传输协议 (SMTP) 服务配置为自动启动

  1. 打开"服务"Microsoft 管理控制台 (MMC) 管理单元。

  2. 双击"简单邮件传输协议 (SMTP)"服务。

  3. 在"简单邮件传输协议 (SMTP)"的"属性"页的"常规"选项卡中，从"启动类型"的下拉对话框中选择"自动"，然后单击"应用"。

  4. 在"服务器状态"下，单击"启动"，再单击"确定"。

  5. 关闭"服务"管理单元。

有关 SMTP 服务和 Exchange Server 的详细信息，请参阅"Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"SMTP 传输体系结构"。

有关如何为 Exchange 配置 SMTP 服务的详细信息，请参阅"Configuring SMTP in Microsoft Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=24866)。


未启动 SMTP 服务
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2007-03-13

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP) 服务的 Started 关键字的值。值为 False 说明 SMTP 服务未运行。值为 True 说明服务正在运行。

如果 Exchange Server 分析工具发现 Started 关键字的值已设置为 False，则 Exchange Server 分析工具将显示错误。

Windows SMTP 服务是 Internet 信息服务 (IIS) 的组件，并作为 Inetinfo.exe 的一部分来运行。Exchange Server 将依赖 SMTP 服务作为其本机传输协议。因此，Exchange 使用 SMTP 来路由所有内部邮件和外部邮件。

SMTP 服务应始终在 Exchange 服务器上运行。

更正此错误

  1. 打开"服务"Microsoft 管理控制台 (MMC) 管理单元。

  2. 在右侧窗格中，向下滚动到"简单邮件传输协议 (SMTP)"服务，并双击它。此时将显示"简单邮件传输协议 (SMTP)"的"属性"对话框。

  3. 在"启动类型"下拉菜单中，将值设置为"自动"。

  4. 单击"启动"，启动系统助理服务。

  5. 单击"确定"保存更改，然后关闭"简单邮件传输协议 (SMTP)"的"属性"对话框。

  6. 关闭"服务"管理单元。

有关简单邮件传输协议 (SMTP) 服务和 Exchange Server 的详细信息，请参阅"Technical Reference Guide for Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=47891) 中的"SMTP Transport Architecture"（英文）。

有关如何为 Exchange 配置 SMTP 服务的详细信息，请参阅"Configuring SMTP in Microsoft Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=24866)。


SMTP 服务被设置为手动
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2006-05-16

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定为简单邮件传输协议 (SMTP) 服务 StartMode 关键字设置的值。值为 Manual 说明简单邮件传输协议 (SMTP) 服务已设置为要求手动启动且不会自动启动。

Exchange Server 分析工具还查询 Win32_Service WMI 类，以确定 SMTP 服务的 Started 关键字的值。值为 False 说明服务未运行。值为 True 说明服务正在运行。

如果 Exchange Server 分析工具发现在启动了 SMTP 服务的 Exchange Server 计算机上 StartMode 关键字的值设置为 Manual，则 Exchange Server 分析工具将显示警告。

Windows SMTP 服务是 Internet 信息服务 (IIS) 的组件，并作为 Inetinfo.exe 的一部分来运行。Exchange Server 将依赖 SMTP 服务作为其本机传输协议。因此，Exchange 使用 SMTP 来路由所有内部邮件和外部邮件。

如果在启动时 SMTP 服务不是自动启动的，则会忽略此操作。这会导致严重的邮件流问题。

所有 Exchange Server 计算机都应将 SMTP 服务设置为 Automatic。

若要解决该错误，必须在路由邮件的服务器上将 SMTP 服务配置为自动启动。

将简单邮件传输协议 (SMTP) 服务配置为自动启动

  1. 打开"服务"Microsoft 管理控制台 (MMC) 管理单元。

  2. 双击"简单邮件传输协议 (SMTP)"服务。

  3. 在"简单邮件传输协议 (SMTP)"的"属性"页的"常规"选项卡中，从"启动类型"的下拉对话框中选择"自动"，然后单击"应用"。

  4. 在"服务器状态"下，单击"启动"，再单击"确定"。

  5. 关闭"服务"管理单元。

有关 SMTP 服务和 Exchange Server 的详细信息，请参阅"Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"SMTP 传输体系结构"。

有关如何为 Exchange 配置 SMTP 服务的详细信息，请参阅"Configuring SMTP in Microsoft Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=24866)。


未知 SMTP 服务状态
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2006-10-06

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP) 服务的 Started 关键字的值。值为 False 说明 SMTP 服务未运行。值为 True 说明服务正在运行。

如果 Exchange Server 分析工具无法确定 Started 关键字的值，则 Exchange Server 分析工具将显示错误。

此错误意味着 WMI 查询无法检索请求的数据。

此错误可能是由如下原因造成的：

  • 运行 Exchange Server 分析工具的帐户没有足够的权限，无法查询 WMI 类。

  • 网络问题使 Exchange Server 分析工具无法与计算机联系。

  • 未知源的短暂情况导致查询超时。

更正此错误

  1. 确保已启动运行 Exchange Server 的服务器，并已将其连接到网络。

  2. 使用 PING 命令来查看是否可访问 Exchange 服务器。

  3. 如果有防火墙，请检查以确定远程过程调用 (RPC) 端口是否被阻止。

  4. 检查用来运行 Exchange Server 分析工具的帐户的权限。用来运行 Exchange Server 分析工具的帐户在每个所扫描的 Exchange 服务器上必须具有本地管理员权限。

    也可以为用来运行 Exchange Server 分析工具的帐户授予特定的 WMI 权限：

    1. 在 Exchange 服务器上，打开"计算机管理"Microsoft 管理控制台 (MMC) 树。

    2. 在"服务和应用程序"下，右键单击"WMI 控件"，再单击"属性"。

    3. 在"WMI 控件属性"对话框上，单击"安全性"选项卡，再展开"根"。

    4. 选择 CIMV2 文件夹，再单击"安全性"。

    5. 在"ROOT\CIMV2 安全性"页上，添加用来运行 Exchange Server 分析工具的帐户。

  5. 选择在步骤 5 中所添加的帐户。在"所选帐户权限"中的"允许"列下，选择"远程启用"和"读取安全性"，再单击"确定"。

有关 SMTP 服务和 Exchange Server 的详细信息，请参阅"Technical Reference Guide for Exchange Server 2003"（Exchange Server 2003 技术参考指南）(http://go.microsoft.com/fwlink/?LinkId=47891) 中的"SMTP Transport Architecture"（SMTP 传输体系结构）。

有关如何为 Exchange 配置 SMTP 服务的详细信息，请参阅"Configuring SMTP in Microsoft Exchange 2000 Server"（在 Microsoft Exchange 2000 Server 中配置 SMTP）(http://go.microsoft.com/fwlink/?LinkId=24866)。

有关排除网络连接问题的详细信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

有关如何排除 Exchange Server 分析工具连接问题的详细信息，请参阅"Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"（解决连接问题的 Microsoft Exchange Server 最佳实践分析工具）(http://go.microsoft.com/fwlink/?LinkId=56285)。


已同时启用 UseAltRegionalCharset 和 UseRegionalCharset 注册表值
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具读取下列注册表项，以确定 Microsoft Outlook® Web Access 客户端所使用的语言设置：

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

    如果设置为 1，则会使 UTF-8 邮件正文以区域字符集或代码页而不是 UTF-8 格式保存在存储区中。这是 Exchange Server 2003 UseRegionalCharset 注册表值的默认设置。

  • HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseAltRegionalCharset

如果下列条件为真，则浏览器的级别确定邮件编码：

  • 未设置 UseAltRegionalCharset 关键字或将其设置为 0。

  • 同样未设置相关的 UseRegionalCharset 或将其设置为 0。

Internet Explorer 5 或更高版本的高级浏览器以 UTF-8 格式发送邮件。较早版本的浏览器或 Internet Explorer 5 之外的浏览器以该浏览器所接受语言的相应编码发送邮件。

UseAltRegionalCharset 关键字仅更改为以下列表中语言配置的浏览器行为：

  • 朝鲜语：KS_C_5601-1987

  • 日语：shift_jis

  • 西欧语言：windows-1252

  • 俄语：windows-1251

  • 中欧语言：windows-1250

如果将 UseAltRegionalCharset 关键字设置为 1，则高级版本的浏览器和早期版本的浏览器都将按照下列编码发送邮件：

  • 朝鲜语：euc_kr

  • 日语：iso-2022-jp (JIS)

  • 西欧语言：iso-8859-1

  • 俄语：koi8-r

  • 中欧语言：iso-8859-2

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定 msExchExchangeServer 对象类中所有对象的 serialNumber 属性值。

  • 如果字符串值包括"Version 6.0"，则表示计算机运行的是 Exchange 2000 Server。

  • 如果字符串值包括"Version 6.5"，则表示计算机运行的是 Exchange Server 2003。

如果下列条件为真，则 Exchange Server 分析工具将显示警告：

  • UseAltRegionalCharset 和 UseRegionalCharset 同时存在

  • 在 Exchange 2000 服务器或 Exchange 2003 服务器上，UseAltRegionalCharset 和 UseRegionalCharset 均配置为使用值 1。

对于 Exchange 2000 Server 和 Exchange Server 2003，如果下列条件为真，则优先使用备用字符集：

  • 已启用区域字符，即 UseRegionalCharset 注册表项 REG_DWORD 值设置为 -1。

  • 已启用备用字符集，即 UseAltRegionalCharset 注册表项 REG_DWORD 值设置为 0x1。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
解决此问题

  1. 在 Exchange 计算机上，打开 Regedit.exe 或 RegEdt32.exe 等注册表编辑器。

  2. 确定适用于 Exchange Server 环境的 Outlook Web Access 语言设置并删除不适用的项。

    1. 导航到：HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

    2. 选择要删除的项，右键单击该项，然后从下拉列表中选择"删除"。

  3. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Outlook Web Access 语言设置的详细信息，请参阅下列 Exchange Server 资源：

"Exchange Server Client Access Guide"（英文）(http://go.microsoft.com/fwlink/?LinkId=47568)。

Microsoft 知识库文章 311342"XCCC:Exchange 2000 Server SP2 Server-Side OWA Registry Keys"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311342)。


在 Exchange 2000 Server 中启用 UseAltRegionalCharset 注册表值
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否将 UseAltRegionalCharset 用于 Microsoft Outlook® Web Access 的客户端语言设置：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseAltRegionalCharset

如果下列条件为真，则浏览器的级别确定邮件编码：

  • 未设置 UseAltRegionalCharset 关键字或将其设置为 0。

  • 同样未设置相关的 UseRegionalCharset 或将其设置为 0。

UseAltRegionalCharset 关键字仅更改为以下列表中语言配置的浏览器行为：

  • 朝鲜语：KS_C_5601-1987

  • 日语：shift_jis

  • 西欧语言：windows-1252

  • 俄语：windows-1251

  • 中欧语言：windows-1250

如果将 UseAltRegionalCharset 关键字设置为 1，则高级版本的浏览器和早期版本的浏览器都将按照下列编码发送邮件：

  • 朝鲜语：euc_kr

  • 日语：iso-2022-jp (JIS)

  • 西欧语言：iso-8859-1

  • 俄语：koi8-r

  • 中欧语言：iso-8859-2

Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchExchangeServer 对象类中所有对象的 serialNumber 属性值。如果字符串值包括"Version 6.0"，则表示计算机运行的是 Exchange 2000 Server。

如果 Exchange Server 分析工具发现在运行 Exchange 2000 Server 的计算机中将 UseAltRegionalCharset 配置为使用大于 0 的任何值，则 Exchange Server 分析工具将显示非默认配置消息。

此消息指示已在 Exchange 2000 服务器中启用 UseAltRegionalCharset 注册表参数。如果您希望组织中的 Outlook Web Access 用户经常将邮件发送给使用多种字符集的收件人，则可以修改注册表设置，以便运行 Internet Explorer 5 或更高版本的用户可以使用 UTF-8 编码的 UNICODE 字符发送邮件。如果不需要多个字符集，则可以使用以下过程还原默认配置。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
若要还原 Outlook Web Access 的默认语言设置，请执行下列操作：

  1. 在 Exchange 计算机上，打开 Regedit.exe 或 RegEdt32.exe 等注册表编辑器。

  2. 导航到：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. 在右侧窗格中，删除 UseAltRegionalCharSet 注册表值。

  4. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Outlook Web Access 语言设置的详细信息，请参阅 Microsoft 知识库文章 311342"XCCC:Exchange 2000 Server SP2 Server-Side OWA Registry Keys"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311342)。


Exchange Server 2003 上已启用了 UseAltRegionalCharset 注册表值
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具读取以下注册表项，以查找是否存在 UseAltRegionalCharset 注册表值：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\

通过 UseAltRegionalCharset 注册表值，Microsoft Outlook® Web Access 用户可以使用其他字符集对电子邮件进行编码。

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定 msExchExchangeServer 对象类中所有对象的 serialNumber 属性值。如果字符串值包括"Version 6.5"，则表示计算机运行的是 Exchange Server 2003。

如果 Exchange Server 分析工具发现 Exchange 2003 服务器上的 UseAltRegionalCharset 注册表值设置为大于 0 的任何值，Exchange Server 分析工具将显示非默认配置消息。

此消息表明 Exchange 2003 服务器上已配置 UseAltRegionalCharset。此设置可能会导致对 Outlook Web Access 邮件进行意外字符集编码，某些客户端可能无法读取其中某些邮件。建议您验证客户端语言设置是否正确。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
在 Exchange Server 2003 上还原 Outlook Web Access 的默认语言设置

  1. 在 Exchange 计算机上，打开 Regedit.exe 或 RegEdt32.exe 等注册表编辑器。

  2. 导航到：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. 在右侧窗格中，删除 UseAltRegionalCharSet 注册表值。

  4. 如果 UseRegionalCharset 注册表值不存在，则按照下列步骤进行创建：

    1. 在"编辑"菜单上，单击"新建"，再单击"DWORD 值"。

    2. 键入 UseRegionalCharset 作为 DWORD 的名称，再按 Enter 键。

  5. 如果 UseRegionalCharset 存在，则双击它进行修改。

  6. 在"数值数据"框中，键入 1，再单击"确定"。

  7. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 UseAltRegionalCharSet 和 UseRegionalCharset 注册表值的详细信息，请参阅 Microsoft 知识库文章 283214"XCCC:Outlook Web Access May Send a Japanese-Language Message in SJIS"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=283214)。


UseRegionalCharset 注册表值已在 Exchange 2000 Server 上启用
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Microsoft Outlook® Web Access 客户端所使用的语言设置：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

UseRegionalCharset 注册表值使 UTF-8 邮件正文以地区字符集或代码页（而不是 UTF-8 格式）添加到存储中。

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定具有对象类 msExchExchangeServer 的所有对象的 serialNumber 属性值。如果字符串值包含"Version 6.0"，说明计算机运行的是 Exchange 2000 Server。

在运行 Exchange 2000 Server 的计算机上，如果 Exchange Server 分析工具发现 UseRegionalCharset 配置为使用大于或等于 1 的值，则会显示非默认配置消息。

此消息指示该 Exchange 2000 服务器上的 UseRegionalCharset 注册表参数已启用。如果期望组织中的 Outlook Web Access 用户经常向使用各种字符集的收件人发送邮件，则可以修改注册表设置，使运行 Internet Explorer 5 或更高版本的用户可以使用 UTF-8 编码的 UNICODE 字符发送邮件。如果不需要多个字符集，则可以使用以下过程还原默认配置。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
还原 Outlook Web Access 的默认语言设置

  1. 在 Exchange 计算机上打开注册表编辑器，例如 Regedit.exe 或 RegEdt32.exe。

  2. 导航到：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. 在右侧窗格中，删除 UseRegionalCharSet 注册表值。

  4. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


UseRegionalCharset 注册表值已禁用
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Microsoft Outlook® Web Access 客户端所使用的语言设置：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

UseRegionalCharset 注册表值使 UTF-8 邮件正文以地区字符集或代码页（而不是 UTF-8 格式）保存在存储中。

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定具有对象类 msExchExchangeServer 的所有对象的 serialNumber 属性值。如果字符串值包含"Version 6.5"，说明计算机运行的是 Exchange Server 2003。

在运行 Exchange Server 2003 的计算机上，如果 Exchange Server 分析工具发现 UseRegionalCharset 配置为使用值 0，则会显示非默认配置消息。

此消息指示该 Exchange 2003 服务器上的 UseRegionalCharset 注册表参数已禁用。此设置可能造成 Outlook Web Access 邮件使用不需要的字符集编码，有些客户端可能无法读取某些邮件。

使用 Microsoft Internet Explorer 5 或更高版本访问 Outlook Web Access 时，Exchange Server 2003 使用浏览器的语言设置来确定用于为电子邮件和会议请求等信息编码的字符集。

如果期望组织中的 Outlook Web Access 用户经常向使用各种字符集的收件人发送邮件，则可以修改注册表设置，使运行 Internet Explorer 5 或更高版本的用户可以使用 UTF-8 编码的 UNICODE 字符发送邮件。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
还原 Outlook Web Access 的默认语言设置

  1. 在 Exchange 计算机上打开注册表编辑器，例如 Regedit.exe 或 RegEdt32.exe。

  2. 导航到：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. 如果 UseRegionalCharset 不存在，则按照下列步骤创建：

    1. 在"编辑"菜单上，单击"新建"，然后单击"DWORD 值"。

    2. 键入 UseRegionalCharset 作为 DWORD 的名称，然后按 Enter。

  4. 如果 UseRegionalCharset 存在，则双击进行修改。

  5. 在"数值数据"框中，输入 1，再单击"确定"。

  6. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Outlook Web Access 语言设置的详细信息，请参阅"Exchange Server Client Access Guide"（英文）(http://go.microsoft.com/fwlink/?LinkId=47568)。


Exchange Server 2003 上的 UseRegionalCharset 注册表值已禁用或丢失
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Microsoft Outlook® Web Access 客户端所使用的语言设置：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

UseRegionalCharset 注册表值使 UTF-8 邮件正文以地区字符集或代码页（而不是 UTF-8 格式）保存在存储中。

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定具有对象类 msExchExchangeServer 的所有对象的 serialNumber 属性值。如果字符串值包含"Version 6.5"，说明计算机运行的是 Exchange Server 2003。

如果符合下列任一条件，则 Exchange Server 分析工具将显示警告消息：

  • Exchange 2003 服务器的 UseRegionalCharset 项不存在。

  • UseRegionalCharset 项的值不是 1。

此消息指示该 Exchange 2003 服务器上的 UseRegionalCharset 注册表参数已禁用或丢失。此设置可能造成 Outlook Web Access 邮件使用不需要的字符集编码，有些客户端可能无法读取某些邮件。

使用 Microsoft Internet Explorer 5 或更高版本访问 Outlook Web Access 时，Exchange Server 2003 使用浏览器的语言设置来确定用于为电子邮件和会议请求等信息编码的字符集。

如果期望组织中的 Outlook Web Access 用户经常向使用各种字符集的收件人发送邮件，则可以修改注册表设置，使运行 Internet Explorer 5 或更高版本的用户可以使用 UTF-8 编码的 UNICODE 字符发送邮件。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
还原 Outlook Web Access 的默认语言设置

  1. 在 Exchange 计算机上打开注册表编辑器，例如 Regedit.exe 或 RegEdt32.exe。

  2. 导航到：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. 如果 UseRegionalCharset 不存在，则按照下列步骤创建：

    1. 在"编辑"菜单上，单击"新建"，然后单击"DWORD 值"。

    2. 键入 UseRegionalCharset 作为 DWORD 的名称，然后按 Enter。

  4. 如果 UseRegionalCharset 存在，则双击进行修改。

  5. 在"数值数据"框中，输入 1，再单击"确定"。

  6. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Outlook Web Access 语言设置的详细信息，请参阅"Exchange Server Client Access Guide"（英文）(http://go.microsoft.com/fwlink/?LinkId=47568)。


用户负载和 MAPI 操作
Microsoft Exchange Server 分析工具 - 文章 > 协议 >

主题上次修改时间： 2006-10-17

Microsoft® Exchange Server 分析工具已确定服务器上的少数 MAPI 操作产生服务器用户负载中较大的百分比。通过查询占用处理所有 RPC 请求使用的总 CPU 时间 4% 以上的操作，可以确定这一点。

占用高百分比 CPU 时间的 MAPI 操作的常见原因

管理员在调查较差的 Exchange Server 性能时，应检查任何性能表现较差的服务器上的平均邮箱大小是否比较大。如果各个文件夹过大（用户的"收件箱"、"已发送邮件"、"已删除邮件"或"日历"文件夹中的项目数超过 5000 个），则应确定这一点。大文件夹和邮箱增长可能造成 CPU 和 I/O 的负载增大。每个文件夹的视图数的增加也可能为许多 MAPI 操作增加开销。

视图

许多常见的、运行时间较长的 MAPI 操作与视图有关。比较突出的两个操作是 Restrict 和 FindRow。这些操作并非总是需要很长时间，因此如果性能出现问题，应了解具体的原因。此外应注意，除了下面的原因之外，只要存在资源瓶颈（通常是磁盘瓶颈或 CPU 瓶颈），操作的延迟时间就会延长。

注意：
有时，TaskQ User Known 与 Restrict 或 FindRow 操作结合使用的成本可能会很高；这是因为这些操作的有些工作在 TaskQ 中执行，成本归于 TaskQ User Known。

限制

MAPI Restrict 操作用于选择符合特定条件的项目。服务器创建一个视图，该视图实际上是具有关联条件（称为限制）的表。如果具有匹配限制的视图已存在，那么服务器将使用现有视图来满足用户的请求。使用此视图的成本相对较低；但是，创建新视图的成本相对较高。默认情况下，存储仅为每个文件夹缓存 11 个视图。如果要求服务器创建第十二个视图，那么服务器将删除最旧的缓存视图，并创建一个新视图。视图为对符合视图限制的项目的所有操作增加了开销。

Findrow

客户端应用程序使用 MAPI 操作 SeekRow 或 FindRow 在视图的各行之间移动光标。SeekRow 指定光标移动的行数，在 CPU 时间方面成本很低。FindRow 成本非常高，因为该操作将光标移至符合限制条件的未实体化（无法缓存）视图中的第一项，在客户端应用程序完成操作之后丢弃该视图。FindRow 最终的 CPU 成本取决于限制的复杂性以及存储在找到符合条件的第一项之前必须检查的行数，与文件夹中的项目数关系不大。

Restrict 和 FindRow 可能产生的高成本使在缓存模式下运行成为好的备选方式，这样可以减少服务器付出的成本。注意，有时，这些操作占用高百分比的 CPU 时间可能只是因为共享日历造成的，这种情况下缓存模式不起作用。这些操作占用高百分比的 CPU 时间可能表明大量的视图创建操作、成本较高的视图或大文件夹项目计数。

详细信息

有关详细信息，请参阅下列 Exchange Server 资源：

  • "Exchange Server 2003 性能和可伸缩性指南"(http://go.microsoft.com/fwlink/?LinkId=47576)

  • "Exchange Server 2003 Performance:10 Things to Think About"（Exchange Server 2003 性能：要考虑的 10 件事情）(http://go.microsoft.com/fwlink/?LinkId=56460)


存储
Microsoft Exchange Server 分析工具 - 文章 >

主题上次修改时间： 2005-11-18

此部分中的文章提供了有关 Microsoft® Exchange Server 分析工具就存储进行评估的详细信息。此外，这些文章还描述了为解决由 Exchange Server 分析工具发现的与存储有关的错误、警告和非默认配置所能采取的措施。


邮箱存储的老化清除间隔为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-05

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否将删除不用的数据库索引的间隔从默认设置修改为其他设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Aging Clean Interval

如果 Exchange Server 分析工具发现 Aging Clean Interval 注册表项存在并已配置，则显示非默认配置消息。

可扩展存储引擎的一项功能是按不同的排序顺序重新排序或请求信息时动态创建索引。因此，Exchange 存储数据库的表上可能会包含成千上万个索引。Exchange 存储通过为索引分配过期时间来处理此情况。索引的有关信息添加到称为索引老化表的内部表中。在联机维护时，将复查索引老化表，并将每个条目的删除时间值与当前时间进行比较。如果索引已过期，将删除该索引。默认情况下，该过程在 Exchange 存储维护周期内每 24 小时运行一次，对于 Exchange Server 5.5，该过程删除超过 8 天的条目；对于 Exchange 2000 Server、Exchange Server 2003 和 Exchange Server 2007，该过程删除超过 40 天的条目。Aging Clean Interval 项是 Exchange 存储尝试删除未使用的索引的间隔（毫秒）。该注册表项可以用于覆盖该默认值，以自定义的间隔执行该功能。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. 删除 Aging Clean Interval 注册表项。

  4. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Aging Clean Interval 注册表项的详细信息，请参阅下列知识库文章：

  • 159197"XADM:Controlling Folder Index Aging"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=159197)

  • 216076"XADM：访问信息存储文件夹的速度可能会变慢"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=216076)


公用文件夹存储的老化清除间隔为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定删除未使用的数据库索引的间隔是否已从默认设置更改为其他设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\Aging Clean Interval

如果 Exchange Server 分析工具发现 Aging Clean Interval 注册表项存在并已配置，则会显示非默认配置消息。

可扩展存储引擎的一项功能是按不同的排序顺序重新排序或请求信息时动态创建索引。因此，Exchange 存储数据库的表上可能会包含成千上万个索引。Exchange 存储通过为索引分配过期时间来处理此情况。索引的有关信息添加到称为索引老化表的内部表中。在联机维护时，将复查索引老化表，并将每个条目的删除时间值与当前时间进行比较。如果索引已过期，将删除该索引。默认情况下，该过程在 Exchange 存储维护周期内每 24 小时运行一次，对于 Exchange Server 5.5，删除超过 8 天的条目，对于 Exchange 2000 Server 和 Exchange Server 2003，删除超过 40 天的条目。Aging Clean Interval 项是 Exchange 存储尝试删除索引的间隔（毫秒）。该注册表项可以用于覆盖该默认值，以自定义的间隔执行该功能。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. 删除 Aging Clean Interval 注册表项。

  4. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Aging Clean Interval 注册表项的详细信息，请参阅下列知识库文章：

  • 159197"XADM: Controlling Folder Index Aging"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=159197)

  • 216076"XADM：访问信息存储文件夹的速度可能会变慢"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=216076)


允许所有版本的 Outlook 访问服务器
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-05

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否阻止任何 Microsoft Office Outlook® 版本连接到 Exchange Server：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server 分析工具发现 Disable MAPI Clients 项不存在，则会显示警告。

默认情况下，不启用 Disable MAPI Clients 项。管理员可以通过该项来阻止特定 Outlook 版本连接到运行 Exchange 2000 Server、Exchange Server 2003 或 Exchange Server 2007 的计算机。

最新 Outlook 发行版和 Service Pack 包含许多安全和防病毒增强功能。从 Outlook 2002 开始，即包含并默认启用附件阻止和对象模型保护功能。这些功能是抵抗病毒的关键组件。Microsoft 产品支持服务支持的最早 Outlook 版本是 Outlook 2000 Service Pack 3 (SP3)。如果您的组织运行的是更早版本的 Outlook，请升级到 Outlook 2003，或者至少使用最新的安全发行版来更新 Outlook 客户端。

更新 Outlook 后，可以阻止尚未更新的早期 Outlook 版本访问 Exchange。封锁不支持附件阻止和对象模型保护功能的早期 Outlook 版本，有助于为 MAPI 客户端连接提供已知的一层客户端安全保护。

若要阻止所有较早的 Outlook 版本（Outlook 97、Outlook 98、SP3 之前的 Outlook 2000 及更早版本），强烈建议禁止内部版本号等于或小于 5.3164.0.0 的所有 Outlook 版本连接到 Exchange Server。

客户端本身指明了客户端的版本字符串。该字符串与客户端的"关于"对话框中报告的版本号类似。但是，不要依赖此版本号，而应使用 Exchange 系统管理器在"邮箱存储登录"页上查看"客户端版本"属性。

重要信息：
在进行任何更改之前应注意，修补程序和 Service Pack 发行版可能会影响客户端版本字符串。在限制客户端访问时应注意，因为服务器端 Exchange 组件也必须使用 MAPI 登录。有些组件以组件名的形式报告其客户端版本（例如 SMTP 和 OLEDB），其他组件则报告 Exchange 内部版本号（例如 6.0.4712.0）。因此，不要限制版本号以 6.<x.x> 开头的客户端。例如，若要完全阻止 MAPI 访问，不应指定 0.0.0-65535.65535.65535，而应指定两个范围，以便服务器组件可以登录，如下所示：0.0.0-5.9.9; 7.0.0-65535.65535.65535。 0.0.0-5.9.9; 7.0.0-65535.65535.65535.
重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 创建一个名为 Disable MAPI Clients 的新字符串值项。

  4. 双击"Disable MAPI Clients"注册表项，将数值数据设置为需要的级别。"数据数据"字符串中的值列表表示可以用来禁用 MAIP 客户端版本范围的不同方法。版本 (vX) 通常采用下列格式（其中 Maj 表示主版本，Min 表示次版本，Build 表示内部版本，Dot 表示点）：

    • 对于 Microsoft Outlook 2003 和 Outlook 2007：Maj.Min.Build

    • 对于 Microsoft Outlook 2000：Maj.Build.Dot

    • 对于较早版本的 Microsoft Outlook：Maj.Min.Build

    可以在该字符串中指定要禁用的所有特定版本或版本范围。应使用 Exchange 系统管理器来确定连接到 Exchange Server 2003 邮箱存储的 MAPI 客户端版本。在 Exchange 系统管理器中，找到邮箱存储的"登录"容器。"客户端版本"列将显示与邮箱存储连接的 MAPI 客户端的版本。

    在 Exchange Server 2007 中，请使用 Exchange 命令行管理程序 Get-LogonStatistics cmdlet 来检索连接到邮箱数据库的 MAPI 客户端的客户端版本。
重要信息：
在 Exchange 系统管理器和 Exchange 命令行管理程序中，MAPI 客户端版本是按 X.0.Y.Z 形式列出的。必须在注册表值中以 X.Y.Z 形式输入此版本。例如，如果 Exchange 系统管理器以 5.0.2819.0 的形式列出 MAPI 客户端版本，请在 Disable MAPI Clients 注册表值中输入 5.2819.0。
  1. 关闭注册表编辑器，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的详细信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)。

有关阻止特定的 MAPI 客户端连接到 Exchange 2000 Server 或 Exchange Server 2003 计算机的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328240"如何对用于访问 Exchange 2000 邮箱的客户端设置服务器端限制"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328240)

  • 288894"XADM：用于禁用 MAPI 客户端访问的功能"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=288894)

有关下载适用于 Outlook 早期版本的安全更新以及阻止其他版本的 Outlook 的详细信息，请参阅"在 Exchange Server 2003 环境中抑制和阻止通过电子邮件传输的病毒"(http://www.microsoft.com/downloads/details.aspx?FamilyID=fb3f649a-2b0a-443d-92a5-8f8cf4bf9fdb&DisplayLang=zh-cn)。

有关 Get-LogonStatistics cmdlet 的详细信息，请参阅 Exchange Server 2007 产品文档中的"Get-LogonStatistics"(http://go.microsoft.com/fwlink/?LinkId=80699)。


AssertOnEvent 已设置
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已对 Microsoft Exchange 信息存储启用了调试：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\AssertOnEvent

如果 Exchange Server 分析工具发现为 AssertOnEvent 设置了值，Exchange Server 分析工具将显示警告。

AssertOnEvent 注册表值包含的十进制值用于指定应触发 Microsoft Exchange 信息存储的调试模式的存储事件。AssertOnEvent 注册表只有在运行 store.exe 的调试版本时才会触发。Microsoft Exchange 信息存储在调试模式下运行时会占用许多资源。在生产环境中调试存储不是最好的做法。

除非您要借助于 Microsoft 产品支持服务积极地排除 Exchange 信息存储故障，否则，应删除 AssertOnEvent 注册表值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
删除 AssertOnEvent 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右侧窗格中，找到并删除 AssertOnEvent 值。

  4. 关闭注册表编缉器，并重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


至少已识别一个受损邮件
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-05

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 PoisonIDs 值中的条目数：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<ExchangeServerName> \Private- <PrivateInformationStoreGUID>

如果 Exchange Server 分析工具确定 PoisonIDs 值中的条目数大于 0，则会显示警告。

Exchange Server 2003 Service Pack 1 以后的 Exchange Server 版本实现了一些性能，有助于防止受损邮件或坏邮件导致 Microsoft Exchange 信息存储服务意外停止或无法成功启动。

在 Exchange Server 2003 Service Pack 1 或更高版本中，系统将跟踪在将 MAPI 格式转换为 MIME 格式的过程中导致 Exchange 信息存储服务意外停止的邮件。发生崩溃时，受损邮件的邮件 ID 将存储在注册表中。如果受损邮件导致存储发生三次意外停止，那么，当 Exchange 信息存储服务第四次重新启动时，将用该信息防止该邮件被再次处理。

当 Exchange 信息存储服务由于受损邮件而意外停止时，将在以下位置创建 PoisonIDs 注册表值：

HKLM\System\CurrentControlSet\Services\MSExchangeIS \<ExchangeServerName> \Private- <PrivateInformationStoreGUID>

另外，管理员可以创建 PoisonThreshold 注册表项。PoisonThreshold 项用于控制在将邮件添加到 PoisonIDs 注册表项之前该邮件可以通过 Exchange 信息存储传递的最大次数。默认情况下，该阈值是 2。若要触发该行为，必须超过阈值。因此，在该邮件被阻止之前，Exchange 信息存储服务可以因为受损邮件而停止 3 次。例如，如果 3 次崩溃都涉及某邮件，则该邮件将被阻止，因为 3 超过了阈值 2。

当受损邮件事件写入注册表时，将在应用程序事件日志中记录错误事件消息（事件 ID 9680 和 9681）。成功启动 Exchange 信息存储服务后，Exchange 会阻止该邮件并尝试为其发送未送达报告。在某些情况下，Exchange 可能无法发送未送达报告。在这些情况下，被阻止的邮件可能保留在队列中，直到过期时为止。PoisonIDs 注册表项最多可以包含 10 个邮件 ID 值。超过限制 10 后，将添加新的受损邮件事件，将删除含有最早崩溃日期的受损邮件事件。

解决此警告问题

  1. 如果邮箱存储出现受损邮件问题，则必须进一步调查该问题。有关 Microsoft IT 如何恢复受损 Exchange 数据库的详细信息，请访问 http://go.microsoft.com/fwlink/?LinkId=56372。

  2. 如果由于受损邮件而出现 Exchange Server 2003 关机问题，在 Exchange Server 计算机上启用自动错误报告可能会有所帮助。错误报告数据可用来查找并修复所使用的软件中存在的问题。有关如何启用 Exchange 错误报告的详细信息，请参阅 Exchange 错误报告已禁用。

有关 Exchange Server 2003 Service Pack 1 的详细信息，请参阅"Exchange Server 2003 Service Pack 1"(http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&DisplayLang=zh-cn)。


邮箱存储的后台清理为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Background Cleanup 注册表值的当前数值数据：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Background Cleanup

如果 Exchange Server 分析工具发现 Background Cleanup 的数值数据设置的值不是 60,000（十进制）或 0xEA60（十六进制），则会显示非默认配置消息。我们建议您将 Background Cleanup 设置为默认值。

如果将 Background Cleanup 值设置得太高，则可能无法经常运行后台清理进程，并且可能会出现许多问题。其中包括：

  • 移动邮箱可能会失败，并记录错误代码为 0x4e3 的事件 1205。

  • Exchange 系统管理器或 Exchange 管理控制台中显示的文件夹大小和项目计数可能与 Microsoft Outlook® 显示的内容存在很大差异。此外，这些项目占用的数据库空间可能不会回收。

  • 在某些情况下，可能不会生成已删除的未读项目的未读回执。

  • 不会清理 DeliveredTo 表中的旧条目。Exchange 存储使用 DeliveredTo 表来防止传递重复的邮件。

如果 Background Cleanup 值设置得太低，后台清理过程可能会为服务器带来不必要的负载。

警告：
如果按照本主题中的过程将过高的值恢复为默认配置，在所有通常本应已按默认间隔进行清理的项目完成后台清理之前，服务器的负载可能会增大。因此，我们建议您在对用户影响最小的时候进行这些更改。此外，如果请求已读回执的邮件在未读的情况下即被删除，并且由于此问题而没有被清理，在解决此警告问题后，将会为每个此类邮件生成未读回执。
重要信息：
本文包含有关如何编辑注册表的信息。在编辑注册表之前，请确保已了解在出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. 将 Background Cleanup 的值更改为 60,000（十进制）或 0xEA60（十六进制）。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


邮件存储的后台清理间隔丢失
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Background Cleanup 注册表值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Background Cleanup

如果 Exchange Server 分析工具发现 Background Cleanup 值丢失，则显示警告。

如果 Background Cleanup 值丢失，则不会进行后台清理过程，并且可能会遇到许多问题，包括：

  • 移动邮箱可能会失败，并记录错误代码为 0x4e3 的事件 1205。

  • Exchange 系统管理器或 Exchange 管理控制台中显示的邮箱大小和项目计数可能与 Microsoft Outlook® 显示的内容存在很大差异。此外，这些项目占用的数据库空间可能不会回收。

  • 在某些情况下，可能不会生成已删除的未读项目的未读回执。

  • 不会清理 DeliveredTo 表。Exchange 存储使用 DeliveredTo 表来防止传递重复的邮件。Track Duplicates 值控制保留 DeliveredTo 表中的条目的时间范围。如果 Background Cleanup 值存在但是 Track Duplicates 值丢失，则超过 24 小时的条目将通过后台清理清除。Track Duplicates 的建议值为 1（十进制或十六进制）。

建议将 Background Cleanup 设置为默认值 60,000（十进制）或 0xEA60（十六进制）。

警告：
如果按照下面的过程解决此警告问题，在所有通常本应已定期清理的项目完成后台清理之前，服务器的负载可能会增大。因此，建议在对用户影响最小的时候进行这些更改。此外，如果请求已读回执的邮件在未读的情况下即被删除，并且因为此问题而没有被清理，则一旦解决了此警告问题，就会为每个此类邮件生成未读回执。
重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. 创建一个名为 Background Cleanup 的 DWORD 值，数值数据为 60000（十进制）或 0xEA60（十六进制）。

  4. 关闭注册表编辑器。若要使更改生效，请执行下列操作之一：

    • 卸除后再装入受影响的信息存储。

    • 重新启动 Microsoft Exchange 信息存储服务。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


公用文件夹存储的后台清除间隔为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Background Cleanup 注册表值的当前数值数据：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<PublicStoreGUID>\Background Cleanup

如果 Exchange Server 分析工具发现 Background Cleanup 的数值数据设置的值不是 60,000（十进制）或 0xEA60（十六进制），则会显示非默认配置消息。建议将 Background Cleanup 设置为默认值。

如果 Background Cleanup 值设置得太高，则可能无法以足够的频率运行后台清理过程，并且可能会遇到许多问题，包括：

  • Exchange 系统管理器中显示的文件夹大小和项目计数与 Microsoft Outlook® 的显示可能差距很大。此外，这些项目占用的数据库空间可能不会回收。

  • 在某些情况下，可能不会生成已删除的未读项目的未读回执。

  • 不会清理 DeliveredTo 表中的旧条目。Exchange 存储使用 DeliveredTo 表来防止传递重复的邮件。

如果 Background Cleanup 值设置得太低，后台清理过程可能会为服务器带来不必要的负载。

警告：
如果按照下面的过程从过高的值还原为默认配置，在所有通常本应已按默认间隔进行清理的项目完成后台清理之前，服务器的负载可能会增大。因此，建议在对用户影响最小的时候进行这些更改。此外，如果请求已读回执的邮件在未读的情况下即被删除，并且因为此问题而没有被清理，则一旦解决了此警告问题，就会为每个此类邮件生成未读回执。
重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<PublicStoreGUID>

  3. 将 Background Cleanup 的数值数据更改为 60,000（十进制）或 0xEA60（十六进制）。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


公用文件夹存储的后台清理间隔丢失
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-05

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Background Cleanup 注册表值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicStoreGUID>\Background Cleanup

如果 Exchange Server 分析工具发现 Background Cleanup 值丢失，则显示警告。

如果 Background Cleanup 值丢失，则不会进行后台清理过程，并且可能会遇到许多问题，包括：

  • Exchange 系统管理器或 Exchange 管理控制台中显示的文件夹大小和项目计数可能与 Microsoft Outlook® 显示的内容存在很大差异。此外，这些项目占用的数据库空间可能不会回收。

  • 在某些情况下，可能不会生成已删除的未读项目的未读回执。

  • 不会清理 DeliveredTo 表。Exchange 存储使用 DeliveredTo 表来防止传递重复的邮件。Track Duplicates 值控制保留 DeliveredTo 表中的条目的时间范围。如果 Background Cleanup 值存在但是 Track Duplicates 值丢失，则超过 24 小时的条目将通过后台清理清除。Track Duplicates 的建议值为 1（十进制或十六进制）。

建议将 Background Cleanup 设置为默认值 60,000（十进制）或 0xEA60（十六进制）。

警告：
如果按照下面的过程解决此警告问题，在所有通常本应已定期清理的项目完成后台清理之前，服务器的负载可能会增大。因此，建议在对用户影响最小的时候进行这些更改。此外，如果请求已读回执的邮件在未读的情况下即被删除，并且因为此问题而没有被清理，则一旦解决了此警告问题，就会为每个此类邮件生成未读回执。
重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicStoreGUID>

  3. 创建一个名为 Background Cleanup 的 DWORD 值，数值数据为 60000（十进制）或 0xEA60（十六进制）。

  4. 关闭注册表编辑器。若要使更改生效，请执行下列操作之一：

    • 卸除后再装入受影响的信息存储。

    • 重新启动 Microsoft Exchange 信息存储服务。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


BreakOnEvent 已设置
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已对 Microsoft Exchange 信息存储启用了调试：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\BreakOnEvent

如果 Exchange Server 分析工具发现已设置 BreakOnEvent 注册表值，则 Exchange Server 分析工具将显示警告。

BreakOnEvent 注册表值包含的十进制值用于指定触发 Microsoft Exchange 信息存储的调试模式的存储事件。Microsoft Exchange 信息存储在调试模式下运行时会占用许多资源。在生产环境中调试存储不是最好的做法。

除非您要借助于 Microsoft 产品支持服务积极地排除 Exchange 信息存储故障，否则，应删除 BreakOnEvent 注册表值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
删除 BreakOnEvent 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右侧窗格中，找到并删除 BreakOnEvent 值。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


调用跟踪功能已禁用
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已启用调用跟踪日志记录：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable Call Tracing

如果 Exchange Server 分析工具发现 Disable Call Tracing 的注册表值存在并已配置为使用值 1，并且计算机运行的是 Exchange Server 2003，则 Exchange Server 分析工具将显示非默认配置消息。

启用了调用跟踪日志记录后，将记录 Store.exe 进程的功能调用数据。默认情况下，运行 Exchange Server 2003 的计算机上启用调用跟踪功能。注意，默认情况下，Exchange 2000 Server 上禁用此功能。但是，如果运行的是 Exchange Server 2003，除非在 Microsoft 产品支持服务的指导下特殊要求，否则，应启用调用跟踪功能。如果启用了调用跟踪功能，将收集重要信息，可以用于解决存储过程中出现的任何问题。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
还原到默认配置

  1. 打开注册表编辑器（Regedit.exe 或 Regedt32.exe）。

  2. 导航到：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 将 Disable Call Tracing 注册表值设置为 0。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


调用跟踪功能已启用
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定调用跟踪日志记录是否已启用：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable Call Tracing

如果 Exchange Server 分析工具发现 Disable Call Tracing 的注册表值存在并且配置的值为 0，则会显示非默认配置消息。

启用了调用跟踪日志记录后，将记录 Store.exe 进程的功能调用数据。调用跟踪日志记录最多可以使性能降低 4%。只有需要用来解决 Store.exe 进程速度慢或无响应时，才应启用该功能。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 将 Disable Call Tracing 注册表值设置为 1。在禁用调用跟踪功能时，不使用 Flush Call Traces 注册表项、RPC Requests Threshold 注册表项和 Call Tracing Logging Interval 注册表项。

  4. 关闭注册表编辑器，然后重新启动 Exchange 服务器，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


在该群集上没有正确设置检查点深度
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个存储组的 msExchESEParamCheckpointDepthMax 属性的值。如果 Exchange Server 分析工具发现在 Exchange 2000 Server 群集上 msExchESEParamCheckpointDepthMax 不等于 5242880，则会显示警告。

msExchESEParamCheckpointDepthMax 属性是以字节为单位设置的，它管理最大检查点深度。检查点深度是等待提交到 Exchange 存储的数据量。最大检查点深度是可以在任何时候滞留的最大数据量。因此，如果最大检查点深度设置为 20 MB，则这就是可以在任何时候滞留（不提交到 Exchange 存储）的最大数据量。在群集环境中，该参数的值越小，则故障转移时间越快。在 Exchange Server 2003 中的测试显示：该参数的值 5 MB（5242880 字节）（而不是 20 MB，这是 Exchange 2000 Server 的默认值）将导致更快的故障转移时间，而不会严重影响服务器的 I/O 性能。

在 Exchange 2000 Server 群集上，该值应当始终设置为 5242880。

警告：
在使用 ADSI（Active Directory 服务接口）Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory® 目录服务对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

使用 ADSI Edit 设置 msExchESEParamCheckpointDepthMax 属性

  1. 运行 Active Directory 服务界面 (ADSI) Edit。ADSI Edit 是 Microsoft Windows® 2000 Server 和 Microsoft Windows Server™ 2003 Server 支持工具所附带的工具。

  2. 在控制台树中，用鼠标右键单击 ADSIEdit，单击 Connect To，再连接到 Configuration Naming Context。

  3. 展开配置容器 CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdminGroupName>, CN=Servers, CN=<ServerName>, CN=Information Store。

  4. 用鼠标右键单击 CN=<StorageGroupName>，再单击"属性"。

  5. 在属性列表中，选择 msExchESEParamCheckpointDepthMax。

  6. 单击"编辑"，并以 5 MB 为增量键入想要设置的大小。必须以字节为单位输入该值。例如，5 MB 检查点深度是 5242880 字节，而 10 MB 检查点深度是 10485760 字节。可以输入的最小大小是 5 MB。如果输入的值超过 20 MB，则 Microsoft Exchange Information Store 服务资源故障转移时间将增加。

  7. 关闭 ADSIEdit，再重新启动 Microsoft Exchange Information Store 服务。

有关部署 Exchange 2000 Server 群集的详细信息，请参阅"Deploying Microsoft Exchange 2000 Server Clusters"（英文）(http://go.microsoft.com/fwlink/?LinkID=14578)。


检查点文件位置
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-05

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Exchange 服务器上的每个存储组的检查点文件路径 (msExchESEParamSystemPath) 与该存储组的事务日志路径 (msExchESEParamLogFilePath) 是否匹配。如果 Exchange Server 分析工具发现存储组的检查点文件路径与事务日志路径不匹配，Exchange Server 分析工具将显示最佳实践消息。

如果检查点文件的位置与事务日志文件的位置不匹配，在磁盘发生故障时，可能会延长停机时间。

在 Exchange 2000 Server 和 Exchange Server 2003 中更改 Exchange 存储组检查点文件的位置

  1. 在 Exchange 系统管理器中，右键单击存储组，再单击"属性"。

  2. 在"常规"选项卡上的"系统路径位置"中，单击"浏览"，再选择检查点文件的位置。
在 Exchange 2000 Server 和 Exchange Server 2003 中更改 Exchange 存储组事务日志文件的位置

  1. 在 Exchange 系统管理器中，右键单击存储组，再单击"属性"。

  2. 在"常规"选项卡上的"事务日志位置"中，单击"浏览"，再选择事务日志文件的位置。
在 Exchange Server 2007 中更改 Exchange 存储组事务日志文件的位置

  1. 按照核心 Exchange Server 2007 文档"How to Set or Change the Location of Storage Group Log Files"（如何设置或更改存储组日志文件的位置）(http://go.microsoft.com/fwlink/?LinkId=80702) 中的指导进行操作。

有关事务日志文件的位置的详细信息，请参阅"Exchange Server 2003 管理指南"中的"管理邮箱存储和公用文件夹存储"(http://www.microsoft.com/downloads/details.aspx?FamilyID=98e45481-1458-4809-97d6-50d8aeebd8a1&DisplayLang=zh-cn)。

有关检查点文件的详细信息，请参阅Using Exchange Server 2003 Recovery Storage Groups（使用 Exchange Server 2003 恢复存储组）中的"Transaction Log File Replay: Soft Recovery and Hard Recovery in Exchange Server 2003"（事务日志文件重播：Exchange Server 2003 中的软恢复和硬恢复）(http://go.microsoft.com/fwlink/?LinkId=47589)。


在该前端服务器上禁用循环日志记录
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2006-03-27

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定为循环日志记录 (msExchESEParamCircularLog) 属性配置的值。如果 Exchange Server 分析工具发现该属性被配置为值 0，则显示警告。

msExchESEParamCircularLog 属性的值为 1 表示启用循环日志记录。msExchESEParamCircularLog 属性的值为 0 表示禁用循环日志记录。

在 Exchange Server 所使用的标准事务日志记录中，存储组中的每个数据库事务都会被写入日志文件，然后写入数据库。日志文件达到某个大小时，将被重命名，并创建新的日志文件。经过一段时间后，这会产生一组日志文件。如果系统崩溃，可以通过将这些日志文件中的数据重播到数据库来恢复事务。

在第一个日志文件所包含的数据已经写入数据库之后，循环日志记录将覆盖并重用该日志文件。在 Exchange Server 中，默认情况下禁用循环日志记录。通过启用它，可以减少对驱动器的存储空间需求，但如果没有完整的事务日志文件，将无法恢复比最后一次完整备份更新的任何数据。因此，在包含邮箱或公用文件夹数据的生产服务器上，建议不要使用循环日志记录。但是，在没有邮箱或公用文件夹的前端 Exchange 服务器上，唯一要提交的邮件是未送达报告 (NDR)；因此，不需要保留这些服务器的事务文件，也不是非常需要备份这些服务器。在前端服务器上启用循环日志记录将允许事务日志文件被覆盖，并且永远不会超过 20 MB 数据。

启用循环日志记录

  1. 在 Exchange 系统管理器中，展开"服务器"，再展开 Exchange 服务器。

  2. 用鼠标右键单击想要启用其循环日志记录的存储组，并选择"属性"。此时出现存储组属性对话框。

  3. 选中"启用循环日志记录"复选框，再单击"确定"以保存更改。

  4. 退出 Exchange 系统管理器，并重新启动 Microsoft Exchange Information Store，以使更改生效。

有关循环日志记录的详细信息，请参阅下列 Microsoft 知识库文章：

  • 258470"XADM:How to Modify the Circular Logging Setting"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=258470)

  • 147524"XADM:How Circular Logging Affects the Use of Transaction Logs"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524)

  • 296788"Exchange 的脱机备份和还原过程"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296788)

  • 314605"HOW TO:Turn On or Turn Off Circular Logging in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314605)


循环日志记录已启用
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-05

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Exchange 服务器上每个存储组的 msExchESEParamCircularLog 属性值。值为 1 意味着已对该存储组启用循环日志记录。值为 2 意味着未对该存储组启用循环日志记录。此外，Exchange Server 分析工具还查询 Active Directory，以确定在每个邮箱存储的 homeMDBBL 属性中所列出的条目数。该属性的个数代表邮箱存储中的邮箱数。

Exchange Server 分析工具还查询 root\MicrosoftExchangeV2 命名空间中的 Exchange_Server Microsoft Windows® Management Instrumentation (WMI) 类，以确定 IsFrontEndServer 关键字的值。值为 True 意味着 Exchange Server 计算机是前端服务器。值为 False 意味着 Exchange Server 计算机不是前端服务器。

如果 Exchange Server 分析工具发现 msExchESEParamCircularLog 属性值设置为 1，IsFrontEndServer 关键字的值设置为 False，并且 homeMDBBL 属性值大于 20，则显示警告。

这些值共同存在意味着在包含 20 个以上邮箱的邮箱服务器上启用了循环日志记录。在 Exchange 2000 Server、Exchange Server 2003 和 Exchange Server 2007 使用的标准事务日志记录中，存储组中的每个数据库事务先写入到日志文件中，然后再写入到数据库中。日志文件达到某个大小时，将被重命名，并创建新的日志文件。经过一段时间后，这会产生一组日志文件。如果系统崩溃，可以通过将这些日志文件中的数据重播到数据库来恢复事务。

在第一个日志文件所包含的数据已经写入数据库之后，循环日志记录将覆盖并重用该日志文件。在 Exchange 2000 Server、Exchange Server 2003 和 Exchange Server 2007 中，默认禁用循环日志记录。通过启用它，可以减少对驱动器的存储空间需求，但如果没有完整的事务日志文件，将无法恢复比最后一次完整备份更新的任何数据。因此，在普通生产环境中，建议不要使用循环日志记录。

在 Exchange 2000 Server 和 Exchange Server 2003 中解决此警告问题

  1. 打开 Exchange 系统管理器。

  2. 展开"服务器"，再展开要修改的服务器。

  3. 右键单击要更改的存储组，再单击"属性"。

  4. 在"属性"对话框中，清除"启用循环日志记录"复选框。

  5. 单击"确定"保存设置。

  6. 关闭 Exchange 系统管理器，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

在 Exchange Server 2007 中使用 Exchange 管理控制台解决此警告问题

  1. 打开 Exchange 管理控制台。

  2. 展开"服务器配置"，然后展开要修改的服务器。

  3. 右键单击要更改的存储组，然后单击"属性"。

  4. 在"属性"对话框中，清除"启用循环日志记录"复选框。

  5. 单击"确定"以保存设置。

  6. 关闭 Exchange 管理控制台，然后重新启动 Microsoft Exchange 信息存储服务以使更改生效。

在 Exchange Server 2007 中使用 Exchange 命令行管理程序解决此警告问题

  1. 以下代码是 Set-StorageGroup 命令的示例，该命令用于为"MyStorageGroup"存储组禁用循环日志记录。
复制代码
Set-StorageGroup -Identity MyStorageGroup -CircularLoggingEnabled $false
  • 有关循环日志记录的详细信息，请参阅下列 Microsoft 知识库文章：

  • 147524"How Circular Logging affects the Use of Transaction Logs"（循环日志记录如何影响事务日志的使用）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524)

  • 240145"How to Tell Which Transaction Log Files Can Be Safely Removed"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=240145)


循环日志记录已禁用
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-03-23

Microsoft Exchange 分析工具查询 Active Directory 目录服务，以确定为 msExchESEParamCircularLog 属性配置的值。

msExchESEParamCircularLog 属性的值为 1 表示启用循环日志记录。msExchESEParamCircularLog 属性的值为 0 表示禁用循环日志记录。

Exchange 分析工具还确定是否符合下列条件：

  • Exchange Server 配置为前端服务器。

  • SMTP 服务正在运行，并确定已配置的邮箱数。

如果 Exchange 分析工具发现符合下列条件，将显示警告：

  • msExchESEParamCircularLog 属性的值配置为 0。

  • 该服务器未配置为前端服务器。

  • 配置的邮箱数不到 20 个。

在 Exchange Server 所使用的标准事务日志记录中，存储组中的每个数据库事务都会被写入日志文件，然后写入数据库。日志文件达到一定大小时，将被重命名，并创建新的日志文件。经过一段时间后，这个标准事务日志记录会创建一组日志文件。如果系统出现故障，可以通过将这些日志文件中的数据重播到数据库来恢复事务。

在第一个日志文件所包含的数据已经写入数据库之后，循环日志记录将覆盖并重用该日志文件。在 Exchange Server 中，默认情况下禁用循环日志记录。

重要信息：
通过启用循环日志记录，可以降低对驱动器存储空间的要求。但是，如果没有完整的事务日志文件，就无法恢复上次完整备份以来的任何新内容。因此，在包含邮箱数据或公用文件夹数据的生产服务器上，建议不要使用循环日志记录。

在前端 Exchange 服务器、邮件路由服务器（也称为基础结构服务器）和没有用户邮箱或公用文件夹的桥头服务器上，唯一提交的邮件是未送达报告 (NDR)。因此，不必为这些服务器保留事务文件。也不必备份这些服务器。如果在未驻留用户邮箱的服务器上启用了循环日志记录，则可以覆盖事务日志文件，事务日志文件的数据永远不会超过 20 MB。

在 Exchange 2000 Server 和 Exchange Server 2003 中启用循环日志记录

  1. 打开 Exchange 系统管理器。

  2. 展开"服务器"，再展开某个 Exchange 服务器。

  3. 右键单击想要启用其循环日志记录的存储组，并选择"属性"。此时出现存储组属性对话框。

  4. 选中"启用循环日志记录"复选框，再单击"确定"保存更改。

  5. 关闭 Exchange 系统管理器，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。
在 Exchange Server 2007 中使用 Exchange 管理控制台启用循环日志记录

  1. 打开 Exchange 管理控制台。

  2. 展开"服务器配置"，然后展开要修改的服务器。

  3. 右键单击要更改的存储组，然后单击"属性"。

  4. 在"属性"对话框中，选中"启用循环日志记录"复选框。

  5. 单击"确定"以保存设置。

  6. 关闭 Exchange 管理控制台，然后重新启动 Microsoft Exchange 信息存储服务以使更改生效。
在 Exchange Server 2007 中使用 Exchange 命令行管理程序启用循环日志记录

  1. 以下代码是 Set-StorageGroup 命令的示例，该命令用于为 MyStorageGroup 存储组启用循环日志记录。
复制代码
Set-StorageGroup -Identity MyStorageGroup -CircularLoggingEnabled $true

有关循环日志记录的详细信息，请参阅下列 Microsoft 知识库文章：

  • 258470"XADM:How to Modify the Circular Logging Setting"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=258470)

  • 147524"XADM:How Circular Logging Affects the Use of Transaction Logs"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524)

  • 296788"Exchange 的脱机备份和还原过程"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296788)

  • 314605"如何在 Exchange 2000 Server 和 Exchange Server 2003 中启用或禁用循环日志记录"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314605)


客户端/服务器 RPC 压缩已禁用
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-05

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定远程过程调用 (RPC) 压缩是否已启用：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Rpc Compression Enabled

如果 Exchange Server 分析工具发现 Rpc Compression Minimum Size 的值存在并且配置的值为 0，则会显示非默认配置消息。

默认情况下，将压缩在 Microsoft Office Outlook® 2003 或 Outlook 2007 与 Exchange Server 2003 或 Exchange Server 2007 之间移动的所有 RPC 数据，而与其大小无关。在某些方案中，您可能需要控制 RPC 压缩。例如，如果要通过查看在网络上发送的数据包来解决连接问题，RPC 压缩可能会使分析很难进行，因为您只能看到跟踪的压缩数据。

要配置 RPC 压缩设置，可以在系统设置中添加三个注册表项值：

  • Rpc Compression Minimum Size

  • Rpc Compression Enabled

  • Rpc Packing Enabled

Rpc Compression Enabled 注册表值确定是否使用 RPC 压缩算法。如果此注册表项不存在，将启用并使用 RPC 压缩。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 删除 Rpc Compression Enabled 注册表项。如果 Rpc Compression Minimum Size 和 Rpc Packing Enabled 注册表项存在，将这两项也删除。

  4. 关闭注册表编辑器，然后重新启动 Exchange 服务器，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关控制 RPC 压缩的详细信息，请参阅知识库文章 825371"Modify Remote Procedure Call Compression in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=825371)。


ClientMonitoringReportLevel 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Exchange Server 2003 如何监视 Microsoft Office Outlook® 2003 的网络性能数据：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server 分析工具发现 ClientMonitoringReportLevel 注册表项的值不是 1，则 Exchange Server 分析工具将显示非默认配置消息。

Exchange Server 使用 ClientMonitoringReportLevel 注册表项的值识别 Outlook 2003 客户端的网络错误和延迟问题。ClientMonitoringReportLevel 注册表项的值有三个可能的设置。

值 | 功能
0 | 不从任何 Outlook 2003 客户端收集任何性能数据。
1 | 仅从具有高速网络连接的 Outlook 2003 客户端收集性能数据。
2 | 从所有 Outlook 2003 收集性能数据。

如果将 ClientMonitoringReportLevel 注册表项的值设置为 1 或 2，则 Outlook 2003 客户端会将数据发送到服务器。发送到服务器的数据表明网络连接的状态。发送到服务器的数据包括有关失败的远程过程调用 (RPC) 请求和错误情况的信息。服务器将信息集合在一起，并在事件日志条目中记录信息。

Exchange 安装程序不会创建 ClientMonitoringReportLevel 注册表项。但是，Exchange Server 2003 中的默认行为是仅从具有高速网络连接的 Outlook 2003 客户端收集性能数据。在功能上，Exchange Server 2003 的默认行为与 ClientMonitoringReportLevel 注册表项的值设置为 1 时的功能相同。

Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。但是，如果要还原默认值，可以编辑 ClientMonitoringReportLevel 注册表项的值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
还原默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 双击 ClientMonitoringReportLevel。

  4. 在"数值数据"字段中，键入 1，再单击"确定"。

  5. 关闭注册表编辑器。

Microsoft Exchange 信息存储服务可以在几分钟内检测到更改。不需要重新启动计算机。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


考虑实现存储配额
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-03-21

Microsoft® Exchange Server 分析工具查询 Active Directory® 目标服务，以确定是否已为每个 private 邮件数据库 (MDB) 对象设置了邮箱配额。如果 Exchange Server 分析工具发现特定的专用 MDB 包含的邮箱多于 20 个，且 MDB 未设置配额，则 Exchange Server 分析工具将显示最佳做法配置消息。

最好将配额应用于承载用户邮箱的 Exchange Server 计算机上的所有数据库。在数据库级别应设置三个限额。这些限额是在邮箱存储属性页的"限制"选项卡上设置的。使用 KB 表示每个限额。

  • 警告 Issue warning 限额定义用于触发传送给用户的警告电子邮件的邮箱大小。警告电子邮件通知用户邮箱大小接近 Prohibit send 限额。

  • 禁止发送 Prohibit send 限制定义禁止用户发送电子邮件的邮箱大小。用户将从 Exchange 服务器收到一封电子邮件，说明已达到邮箱大小限额。

  • 禁止发送和接收 Prohibit send and receive 限制定义禁止用户发送和接收电子邮件的邮箱大小。所有发送给该用户的邮件将为发件人返回一个未送达报告 (NDR)。

在设置这些规则时，请确保在"禁止发送"限制和"禁止发送和接收"限制之间提供足够大的差值。如果两个限制之间的差值太小，用户可能还没来得及清理邮箱，邮箱就已拒收了邮件。因此，最好在"禁止发送"限制和"禁止发送和接收"限制之间提供至少 20% 的缓冲区。例如，如果在邮箱达到 100 MB 时禁止用户发送新邮件，"禁止发送和接收"限制应至少为 120MB。

在 Exchange 2000 Server 和 Exchange Server 2003 中设置邮箱限制

  1. 打开"Exchange 系统管理器"。

  2. 找到 Exchange Server 分析工具消息中显示的有关此问题的邮箱存储。

  3. 右键单击 MailboxStore_Name，然后选择"属性"。

  4. 选择"限制"选项卡。

  5. 修改"达到该限度时发出警告 (KB)"、"达到该限度时禁止发送 (KB)"限制和"达到该限度时禁止发送和接收 (KB)"限制。

  6. 单击"应用"，再单击"确定"。
在 Exchange Server 2007 中使用 Exchange 管理控制台设置邮箱限制

  1. 打开 Exchange 管理控制台。

  2. 找到 Exchange Server 分析工具中显示的有关此问题的邮箱存储。

  3. 右键单击 MailboxStore_Name，然后选择"属性"。

  4. 选择"限制"选项卡。

  5. 修改"达到该限度时发出警告 (KB)"、"达到该限度时禁止发送 (KB)"限制和"达到该限度时禁止发送和接收 (KB)"限制。

  6. 单击"应用"，然后单击"确定"。
在 Exchange Server 2007 中使用 Exchange 命令行管理程序设置邮箱限制

  1. 下列示例说明了如何设置向用户发送警告消息时的邮箱大小。此属性适用于该邮箱数据库中所有未设置其自己的警告配额属性的邮箱。您必须指定一个整数或"无限制"。默认值为 1.9 GB。

    复制代码
    Set-MailboxDatabase "Mailbox Database Name" -IssueWarningQuota 1991680

  2. 下列示例说明了如何设置与此邮箱数据库中的邮箱关联的用户无法再发送邮件时的邮箱大小。此属性适用于该邮箱数据库中所有未设置其自己的禁止发送配额属性的邮箱。设置的限制值必须是一个整数或"无限制"。

    复制代码
    Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendQuota 2097152

  3. 下列示例说明了如何设置与此邮箱关联的用户无法再发送或接收邮件时的邮箱大小。此属性适用于该邮箱数据库中所有未设置其自己的禁止发送和接收配额属性的邮箱。您必须指定一个整数或"无限制"。

    复制代码
    Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendReceiveQuota 2411520

有关如何在 Exchange Server 2003 中管理 Exchange 邮箱的详细信息，请参阅 Working with Exchange Server 2003 Stores（使用 Exchange Server 2003 存储）(http://go.microsoft.com/fwlink/?LinkId=47595)。

有关如何在 Exchange Server 2007 中管理 Exchange 邮箱限制的详细信息，请参阅"How to Configure Database Limits and Properties"（如何配置数据库限制和属性）(http://go.microsoft.com/fwlink/?LinkId=80746)。


在此邮箱存储上启用了内容索引
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定内容索引重建计划 (msExchCIRebuildSchedule) 属性是否已设置为任何非空的值，以及内容索引重建样式 (msExchCIRebuildStyle) 属性是否已设置。这些属性是每个私人邮箱数据库的属性。如果 Exchange Server 分析工具发现两个属性均为索引进行了配置，则会显示警告。

不建议在邮箱存储上运行内容索引（也称为"全文索引"），因为全文索引占用资源，并且邮箱数据更改频繁。因此，保持给定数据库的最新索引是一个非常占用资源的进程。全文索引更适用于公用文件夹。

如果要在邮箱存储上运行全文索引，建议将索引日程安排设置为频繁更新，并监视计算机的性能，以确保计算机未过载，并能够在对内容编制索引的同时继续传递邮件并响应客户端请求。

否则，建议您通过删除邮箱存储上的全文索引来禁用全文索引。

在给定的邮箱存储上禁用全文索引

  1. 打开 Exchange 系统管理器。

  2. 依次展开"管理组"、您的管理组、"服务器"、您的服务器、您的存储组，用鼠标右键单击"邮箱存储"，再单击"删除全文索引"。

有关在 Exchange 中配置全文索引并解决相关问题的详细信息，请参阅 Microsoft 知识库文章"HOW TO:Configure Full-Text Indexing on Mailbox Stores in Exchange 2003"（英文）(http://go.microsoft.com/fwlink/?LinkID=3052&kbid=822932)。


已在此公用文件夹存储上启用了内容索引
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Content Indexing Rebuild Schedule (msExchCIRebuildSchedule) 属性和 Content Indexing Rebuild Style (msExchCIRebuildStyle) 属性是否存在并设置为 0 以外的任意值。这些属性是每个公用信息存储数据库的属性。

如果 Exchange Server 分析工具发现这两个属性存在并设置为 0 以外的任意值，则显示非默认配置消息。

如果这两个属性均设置为 1，表明已对信息存储数据库启用了全文索引。全文索引通过对指定数据库中的每个字编制索引来启用强大而快速的搜索。当部署全文索引时，请选择要编制索引的单个公用文件夹存储或邮箱存储。然后，用户才能对包含在公用文件夹存储或邮箱存储中的邮件和附件进行全文搜索。

默认情况下，索引包含邮件的主题和正文，发件人和收件人的名称以及出现在"抄送"和"密件抄送"字段中的所有名称。索引还包含下列类型附件内的文本：.doc, .xls, .ppt, .html, .htm, .asp, .txt 和 .eml（嵌入式多用途 Internet 邮件扩展 (MIME) 邮件）文件。不对二进制附件（如图片和声音）编制索引。

搜索结果的准确性仅取决于上次索引更新的结果。当公用文件夹存储或邮箱存储的内容发生改变时，索引必须更新以反映新内容。索引更新可以手动执行，也可以按照日程安排自动执行。

全文索引文件主要分为四个类别。可以通过按如下所述安排这些文件的磁盘位置来优化全文索引的性能：

  • 编录：编录是主索引。每个 Exchange 存储都只能有一个编录。请将编录放置在 RAID-0+1 阵列上。当创建编录时，可以在 Exchange 系统管理器中指定编录位置。

  • 属性存储：这是一个数据库，它包含已在编录中编制索引的项目的各个属性。每个服务器都只有一个属性存储。请将全文属性存储放置在 RAID 阵列上。默认情况下，这些文件与 Exchange Server 安装在同一个驱动器上。

  • 临时文件：这些文件包含 Microsoft Search 服务使用的临时信息。请将全文索引临时目录放置在 RAID 阵列上。默认情况下，这些文件安装在通常没有 RAID 阵列的 I/O 吞吐量的系统驱动器上。

  • 收集器日志：这些文件包含索引服务的日志信息。每个编录都存在一组日志。既可以将收集器日志保留在其默认位置，也可以将其移至其他位置（如果您选择这样做）。

启用或禁用全文索引

  1. 打开 Exchange 系统管理器。

  2. 依次展开"服务器"、Exchange 服务器、包含您要处理的公用文件夹存储的存储组。

  3. 用鼠标右键单击该公用文件夹存储，然后选择"属性"。

  4. 选择"全文索引"选项卡。

  5. 根据需要编辑"更新间隔"字段。

  6. 单击"确定"保存更改并退出该公用文件夹存储的"属性"对话框。

有关对公用文件夹进行全文索引的详细信息，请参阅 Microsoft 知识库文章 319433"HOW TO:Configure Full-Text Indexing on Public Folders"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=319433)。

有关对邮箱存储配置全文索引以及相关的故障排除的详细信息，请参阅下列知识库文章：

  • 822932"HOW TO:Configure Full-Text Indexing on Mailbox Stores in Exchange 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822932)

  • 319436"HOW TO:Configure Full-Text Indexing on Mailbox Stores in Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=319436)

有关多语言环境中的全文索引的信息，请参阅知识库文章 325624"XGEN:Full-Text Indexing with Multiple Languages"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325624)。

有关全文索引最佳实践的详细信息，请参阅知识库文章 326186"XADM:White Paper - The Best Practices for Deploying Full-Text Indexing"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=326186)。


DSN 当前以邮件形式呈现
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-03-21

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Exchange Server 计算机上的传递状态通知 (DSN) 是否作为标准消息发送：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent\RenderDSNsAsMessages

如果 Exchange Server 分析工具发现 RenderDSNsAsMessages 注册表项存在并配置为大于 0 的值，则显示非默认配置消息。

顾名思义，通过对 RenderDSNsAsMessages 注册表项进行配置，管理员可以控制在 Exchange 2000 Server、Exchange Server 2003 和 Exchange Server 2007 计算机上呈现 DSN 的方式：

  • 如果 RenderDSNsAsMessages 的数值数据设置为 0，DSN（包括送达报告和未送达报告）将以标准 MAPI 邮件的形式呈现。

  • 如果 RenderDSNsAsMessages 的数值数据设置为大于 0 的任意值，DSN 将以多节/混合 MIME 邮件的形式呈现。

此注册表值默认情况下不存在，要使用它，必须手动添加。此外，要使该项对 Exchange 2000 Server 产生正确的影响，计算机必须至少运行 2003 年 9 月版 Exchange 2000 Server Post-Service Pack 3 更新汇总。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

回复到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

  3. 删除 RenderDSNsAsMessages 注册表项。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。
  • 编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

  • 有关传递状态通知格式问题的详细信息，请参阅知识库文章 812806"Exchange 用户意外地收到标准未送达报告 (NDR) 而不是自定义 NDR"(http://support.microsoft.com/kb/812806/zh-cn)。

  • 有关 Exchange 2000 Server 后 Service Pack 3 累积修补程序的详细信息，请参阅知识库文章 824282"2003 年 9 月版 Exchange 2000 Server 后 Service Pack 3 累积修补程序"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=824282)。


数据库老化计时间隔已从默认值修改为其他值
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已覆盖 Exchange 客户端视图数据库索引的默认老化值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Private-<Private Information Store GUID>\Aging Keep Time

如果 Exchange Server 分析工具发现 Aging Keep Time 注册表项存在并已配置，则显示非默认配置消息。

由 Exchange 客户端在 Exchange 数据库表中创建的视图所使用的索引如果在给定的时间内尚未使用，这些索引将在此时被清除。下列注册表项用来控制索引老化：

  • Aging Keep Time 索引被删除之前的最短时间。对于 Exchange Server 5.5，默认时间为 8 天；对于 Exchange 2000 Server、Exchange Server 2003 和 Exchange Server 2007，则是 40 天。

  • Aging Clean Interval 索引时间任务运行之间的最小时间间隔（毫秒）。默认间隔是 24 小时。

  • Reset Views 如果该设置存在并且非零，那么，这会在下一个索引老化任务运行时强制删除所有缓存的索引。索引老化完成时，Reset Views 值将设置为 0。

建议不要添加 Aging Keep Time 注册表值，除非得到 Microsoft 产品支持服务的指导。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

查看或修改 Aging Keep Time 注册表值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Private-<Private Information Store GUID>

  3. 检查并（如果需要）更改 Aging Keep Time 值。

  4. 关闭注册表编辑器。如果进行了更改，请重新启动 Exchange Server 计算机，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


数据库文件和日志文件存储在同一个磁盘卷上
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-05

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定此邮箱存储的数据库文件是否与此存储组的事务日志文件驻留在同一个物理磁盘上。具体地说，Exchange Server 分析工具查询 Active Directory，以确定：

  • 邮箱存储是否有 100 个以上的邮箱，这通过计数邮箱存储对象（msExchPrivateMDB 类）的 homeMDBBL 属性的值来确定。如果邮箱存储的邮箱数少于 100，则文件位置对性能的影响很有限。

  • 邮箱存储的数据库文件的路径，这通过读取邮箱存储对象的 msExchEDBFile 的值来确定。

  • 存储组的事务日志文件的路径，这通过读取存储组对象（msExchStorageGroup 类）的 msExchESEParamLogFilePath 的值来确定。

  • msExchESEParamLogFilePath 中的路径是否与 msExchEDBFile 中的路径在同一个磁盘上。

此外，Exchange Server 分析工具还确定：

  • Windows 驱动的 NAS 的 Exchange Server 扩展是否运行在服务器上，这通过在 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类中查询 Exchange Server NAS 扩展 (wssexchmap) 的 Started 属性的值来确定。如果 Windows 驱动的 NAS 的 Exchange Server 扩展在运行，则意味着所考虑的文件可能不在本地驱动器上，因此性能考虑因素可能不适用。

  • 文件是否位于名称超过三个字符的磁盘卷上，这通过查询 Win32_Volume WMI 类来确定。这也意味着文件可能不在本地驱动器上，因此性能考虑因素可能不适用。

为了在硬盘出现故障时提供容错，应将 Exchange 事务日志文件和数据库文件存放在不同的物理硬盘上。将这些日志文件和数据库文件存放在不同的硬盘上可以大大提高硬盘的 I/O 性能。

注意：
为了提供容错以便可以在必要时还原数据库，每个存储组都有它自己的一组事务日志文件。事务日志文件保存对该存储组中的每个数据库的每次更改的记录。在创建存储组中的所有数据库的完整备份之前，不会删除事务日志文件。

下面的示例说明了如何恢复数据。这些示例甚至适用于极端的情况，例如，包含数据库文件或事务日志文件的硬盘丢失。此外，这些示例的假设前提是存在备份，并且事务日志文件在一个单独的磁盘上。

  • 如果包含数据库文件的硬盘出现故障，可以更换出现故障的硬盘、还原数据库文件的最新备份，然后使用存储在另一个硬盘上的当前日志文件还原 Exchange 服务器上的数据，并将它更新到硬盘出现故障时的状态。

  • 如果包含事务日志的硬盘出现故障，但包含数据库文件的硬盘正常工作，并且数据库存储文件正常关闭，则可能能够修复出现故障的事务日志磁盘并重新装入数据库存储。如果数据库存储文件未正常关闭，则会处于不一致的状态，只有在使用 eseutil.exe 进行硬修复（可能导致某些数据丢失）后才能装入。另一个选择是从备份（不包括备份后创建的新邮箱数据）中还原数据库存储文件。

重要信息：
如果将 Exchange 数据库文件和事务日志文件存放在同一个物理硬盘上，则当该硬盘出现故障时，将丢失上一次备份后创建的数据。

此外，将数据库文件和事务日志文件放在不同的物理磁盘上可提高总体性能。Exchange 首先将每个事务写入到事务日志文件中，然后再写入到数据库文件中。此外，事务日志文件由存储组中的所有邮箱存储共享。当这些文件位于同一个物理磁盘上时，驱动器头必须在当前事务日志文件的位置与数据库文件的位置之间来回移动才能完成写入操作。当这些文件位于不同的磁盘上时，一个驱动器头只需保持在适当的位置即可写入到事务日志文件中，因此，相对于文件位于单个磁盘上，事务可以更快地完成。当只有一个事务时，两种方式在性能上的差别很小。但是，如果系统负载很高，则差别会变得很显著。

若要更正配置，可以移动事务日志文件或数据库文件。

将事务日志文件移到 Exchange 2000 Server 或 Exchange Server 2003 的新驱动器中

  1. 在 Exchange 系统管理器中，展开适当的 Exchange 服务器对象，右键单击相应的存储组，再单击"属性"。

  2. 在"常规"选项卡上，指定文件的新位置。

    例如，如果 E:\ 驱动器将仅仅包含此存储组的日志文件，请在"事务日志位置"中，单击"浏览"，再选择 E:\ 驱动器。

在 Exchange Server 2007 中更改 Exchange 存储组事务日志文件的位置

  1. 按照核心 Exchange Server 2007 文档"How to Set or Change the Location of Storage Group Log Files"（如何设置或更改存储组日志文件的位置）(http://go.microsoft.com/fwlink/?LinkId=80702) 中的指导进行操作。

将数据库文件移到 Exchange 2000 Server 或 Exchange Server 2003 的新驱动器中

  1. 在 Exchange 系统管理器中，展开驻留存储的 Exchange 服务器对象，再展开适当的存储组容器，右键单击相应的邮箱存储对象，然后单击"属性"。

  2. 在"属性"对话框的"数据库"选项卡中，指定新文件位置。
警告：
若要移动数据库文件，必须临时卸除该数据库，然后再重新装入。这是由向导自动完成的，但是，所有用户在此过程中无法访问该数据库。

使用"移动数据库路径"向导将数据库文件移到 Exchange Server 2007 的新驱动器中

  1. 在存储组所在的服务器上启动 Exchange 管理控制台。

  2. 在控制台树中，展开"服务器配置"，然后单击"邮箱"。

  3. 在结果窗格中，展开相应的存储组容器，右键单击所需的邮箱数据库对象，然后单击"移动数据库路径"。将显示"移动数据库路径"向导。

  4. 在"简介"页中，数据库文件路径框将显示数据库文件的当前存储位置。请单击"浏览"以指定要将这些文件移动到的位置。

  5. 单击"移动"。

  6. 在"完成"页中，确认是否成功更改了数据库文件路径。"已完成"状态表示向导成功完成了该任务。"失败"状态表示未完成该任务。如果任务失败，请查看说明摘要，然后单击"上一步"，以对配置进行任何更改。单击"完成"以完成"移动数据库路径"向导。
注意：
也可以在 Exchange Server 2007 中使用 Exchange 命令行管理程序来移动数据库文件。有关详细信息，请参阅 Move- DatabasePath。

有关 Exchange Server 数据库文件的详细信息，请参阅下列主题：

  • "Exchange Server 2003 管理指南"中的"Managing Mailbox Stores and Public Folder Stores"（英文）(http://go.microsoft.com/fwlink/?LinkId=47617)。

  • "使用 Exchange Server 2003 存储"中的"Understanding the Exchange Server 2003 Store"（英文）(http://go.microsoft.com/fwlink/?LinkId=47595)。

有关管理 Exchange Server 数据库文件的详细信息，请参阅 Microsoft 知识库文章 328794"How to Protect Exchange Data from Hard Disk Failure"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328794)。

有关对 Exchange 数据库存储执行硬修复的详细信息，请参阅知识库文章 296788"Exchange 的脱机备份和还原过程"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296788)。

有关对 Exchange 数据库存储文件执行硬修复的详细信息，请参阅知识库文章 810190"XADM：记录了"The Information Store Terminated Abnormally"（信息存储异常终止）错误消息和事件 ID 447"(http://support.microsoft.com/kb/810190/zh-cn)。


数据库的所有日志文件均存在
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具已确定恢复此数据库所需的所有日志文件均存在，并且处于恢复的正确位置。因此，不是因为事务日志文件丢失或不匹配造成恢复失败。

可能数据库或事务日志文件已损坏，或其他文件正在干扰恢复过程。

更正此错误

  • 使用 Exchange 系统管理器装入存储组中的一个数据库，然后在应用程序日志中查看可能指示失败原因的错误。

  • 恢复隔离的数据库。分析了数据库之后，Exchange Server 分析工具将显示恢复隔离的数据库的说明。

  • 运行 Eseutil.exe /ML 以验证所需日志文件的完整性。有关如何使用 Eseutil 的详细信息，请参阅 Microsoft 知识库文章 248122"How to use Eseutil to test transaction log files for damage in Exchange 2000 Server and in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=248122)。


数据库处于"干净关闭"状态
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具已确定 Exchange 数据库处于"干净关闭"状态。

处于"干净关闭"状态的数据库已正确关闭，并且与日志文件流断开。因此，如果要重新装入该数据库，那么不需要执行任何恢复操作即可进行装入。

如果无法装入处于"干净关闭"状态的数据库，那么原因不是数据库需要其他事务日志文件重播。但是，同一个存储组中的其他数据库所需的事务日志重播可能会使处于"干净关闭"状态的数据库无法装入。在装入 Exchange 存储组中的任何数据库之前，该存储组中的所有数据库必须已恢复并进入可装入状态。

处于"干净关闭"状态的数据库可以使用以前的事务日志或其他事务日志集进行装入。如果装入处于"干净关闭"状态的数据库并且没有事务日志，那么将生成新的事务日志集。

注意：
通常，即使存储组中的所有数据库均处于"干净关闭"状态，也不应删除现有的事务日志文件。如果删除现有的事务日志文件，那么将无法通过以前的备份进行前滚。但是，在存储组中的所有数据库均处于"干净关闭"状态时删除事务日志文件，不会影响当前的数据库。最佳做法是，如果删除存储组的所有事务日志文件，那么应立即创建该存储组中所有数据库的完整备份。


数据库处于"肮脏关闭"状态，不需要任何日志
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2006-08-10

Microsoft® Exchange Server 分析工具已确定数据库处于"肮脏关闭"状态。

根据定义，处于"肮脏关闭"状态的数据库要求至少重播一个事务日志文件。"肮脏关闭"不是数据库的可装入状态，不应在常规操作期间进行。

更正此错误

  • 有关数据库文件和日志文件的高级分析，请与 Microsoft 帮助和支持中心联系 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=31845)。


数据库处于未知状态
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具发现您的数据库处于未知状态。通常，您的数据库应处于"干净关闭"状态或"肮脏关闭"状态。（在 Exchange 2000 Server 和更早版本中，这两种状态分别称为"一致"或"不一致"。）

更正此错误

  • 有关数据库状态的高级分析，请联系 Microsoft 帮助和支持 (http://go.microsoft.com/fwlink/?LinkId=31845)。


数据库缺少可选的和必要的日志文件
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具确定无法在日志文件的文件夹中找到恢复此数据库所需的日志文件。如果缺少必要的日志文件，则在找到该日志文件之前，无法恢复数据库。

如果 Exchange 数据库没有正确关闭，则总是有一些日志文件需要重播到该数据库，才能重新装入此数据库。在最低限度的情况下，可能仅有一份日志文件必须重播。但是，通常有若干个日志文件必须重播。

除了必要的日志文件外，也可以将其他日志文件播放到数据库中。尽管在数据库能够装入之前，重播这些可选的日志文件不是必须的，但可以使用这些日志文件恢复其他数据。如果不重播这些可选的日志文件，则其中包含的所有数据都将丢失。

更正此错误

  • 找到缺少的事务日志文件并将其添加到相应的文件夹中。

  • 如果无法找到所有可选的日志文件，则可以仅使用必要的日志文件单独恢复数据库。若要在不使用可选的日志文件的情况下恢复数据库，请按照 Exchange Server 分析工具中的说明执行操作。请记住，如果不使用可选的日志文件恢复数据库，则会丢失那些可选文件中的数据。

    但是，可以将某些可选的日志文件重播到数据库中，这取决于丢失的是哪一个日志文件。例如，请考虑以下情况。您有编号为从一到十的日志文件。第十个日志文件是必要文件（其余文件是可选文件），缺少第六个日志文件。在这种情况下，由于到必要文件的序列顺序不变，因此，可以重播第七至第十个日志文件。

  • 修复当前的数据库。

    注意：
    尽管修复数据库可能会成功，但无法保证一定如此。即使修复成功，也可能导致数据少量或大量丢失。有关修复 Exchange 数据库的详细信息，请参阅 Microsoft 知识库文章 812357"XADM：在使用 Eseutil /p 工具修复 Exchange 数据库后维护该数据库"(http://support.microsoft.com/kb/812357/zh-cn)。

  • 实施包括修复和还原数据库的混合策略。有些时候，即使无法使用其他日志文件前滚数据库，仍可以将其还原。在这些情况下，可能能够在还原以前数据库副本的同时修复无法装入的当前副本。然后，可以合并数据库的内容，以最大程度地抢救数据。这是一项高级策略，在实施前，可能需要联系 Microsoft 帮助和支持 (http://go.microsoft.com/fwlink/?LinkId=31845)。有关该策略的详细信息，请参阅"Using Recovery Storage Groups in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47589)。


数据库缺少可选的日志文件但不缺少必要的日志文件
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具确定其中一个数据库没有正确关闭。

如果 Exchange 数据库未正确关闭，则必须始终将日志文件重播到该数据库才能重新装入它。至少必须重播一个单独的日志文件。但是，通常有若干个日志文件。

除了必要的日志文件外，也可以将其他日志文件播放到数据库中。尽管在装入数据库之前，不必重播这些可选的日志文件，但可以使用这些日志文件恢复其他数据。如果未重播这些可选的日志文件，则其中包含的所有数据都将丢失。

更正此错误

  • 找到缺少的可选日志文件并将其复制到事务日志文件夹中。

  • 如果无法找到所有可选的日志文件，则可以仅使用必要的日志文件单独恢复数据库。若要在不使用可选的日志文件的情况下恢复数据库，请按照 Exchange Server 分析工具中的说明执行操作。请记住，如果不使用可选的日志文件恢复数据库，则会丢失那些可选文件中的数据。

    但是，根据丢失的日志文件，可以将某些可选的日志文件重播到数据库中。以下面的方案为例。您有编号为从 1 到 10 的日志文件。第十个日志文件是必要文件（其余文件是可选文件），缺少第六个日志文件。在这种情况下，由于到必要文件的序列顺序是连续的，因此，将可以重播第七至第十个日志文件。


数据库缺少必要的日志文件
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具已确定，在日志文件文件夹中找不到恢复此数据库所需的日志文件。如果缺少必要的日志文件，则在找到该文件之前，无法恢复数据库。

更正此错误

  • 找到缺少的事务日志文件并将其添加到相应的文件夹中。

  • 从备份中还原数据库。然后通过将剩余的事务日志文件播放到数据库中来前滚数据库。

    重要信息：
    缺少的日志文件和后续日志文件中的数据将会丢失。从备份中还原数据库之前，应当保存当前数据库的副本。如果还原失败，可以修复当前的数据库。

  • 修复当前的数据库。

    注意：
    尽管修复数据库可能会成功，但不能保证一定会这样。即使修复成功，也会导致数据少量或大量丢失。有关如何修复 Exchange 数据库的详细信息，请参阅 Microsoft 知识库文章 812357"XADM：在使用 Eseutil /p 工具修复 Exchange 数据库后维护该数据库"(http://support.microsoft.com/kb/812357/zh-cn)。

  • 实施包括修复和还原数据库的混合策略。有些时候，即使数据库无法使用可选的日志文件前滚，但仍可以将其还原。在这些情况下，可以在还原以前的数据库副本的同时修复无法装入的当前副本。然后，可以将数据库的内容合并为最大数据残值。这是一个高级策略，在实施前，可能需要查看 Microsoft 帮助和支持 (http://go.microsoft.com/fwlink/?LinkId=31845)。有关该策略的详细信息，请参阅"Using Recovery Storage Groups in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47589)。


备份期间将此存储组中的数据库设置为零页面
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-05

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定服务器上每个存储组的 msExchESEParamZeroDatabaseDuringBackup 属性的值。如果 Exchange Server 分析工具发现 msExchESEParamZeroDatabaseDuringBackup 属性已设置为 1，则会显示非默认配置消息。

msExchESEParamZeroDatabaseDuringBackup 属性代表一个配置设置，通过此设置可以在备份期间使用零覆盖已删除的记录/长数值。此过程称为"清零"。您可以在存储组级别控制数据库页的清零操作。每个存储组可以有不同的策略，用于对删除的数据库页进行清零。

默认情况下，清零处于禁用状态，并且 msExchESEParamZeroDatabaseDuringBackup 属性的值设置为 0。如果属性设置为 1，则将使用该存储组中任意数据库联机备份末尾的其他字符覆盖已删除的数据库页。

可以使用 Exchange 系统管理器来启用和禁用 Exchange 2000 Server 和 Exchange Server 2003 清零功能；以及使用 Exchange 命令行管理程序来启用和禁用 Exchange Server 2007 清零功能（如本文所述）。尽管此选项提供了更强大的安全性，但是它会影响服务器性能。

注意 如果要在 Exchange 2000 Server 计算机上启用清零功能，建议您安装 Exchange 2000 Server Service Pack 3 或更高版本。Service Pack 3 更正了一个已知问题，该问题可导致 Exchange 信息存储停止响应。有关此问题的详细信息，请参阅 Microsoft 知识库文章 320883"XADM:The Information Store Stops Responding During an Online Backup If Database Zeroing Is Turned On"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320883)。

启用或禁用 Exchange 2000 Server 和 Exchange Server 2003 清零功能

  1. 打开 Exchange 系统管理器。

  2. 展开"服务器"，再展开要修改的服务器。

  3. 右键单击要更改的存储组，再单击"属性"。

  4. 在"属性"对话框中，根据需要选中或清除"将已删除的数据库页清零"复选框。选中该复选框将启用清零，清除该复选框将禁用清零。

  5. 单击"确定"保存设置。

  6. 关闭 Exchange 系统管理器，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

启用或禁用 Exchange Server 2007 已删除页的清零功能

  1. 以下代码是 Set-StorageGroup 命令的示例，该命令用于为"MyStorageGroup"存储组启用或禁用数据库清零功能。
复制代码
Set-StorageGroup -Identity MyStorageGroup -ZeroDatabasePages
 $false
Set-StorageGroup -Identity MyStorageGroup -ZeroDatabasePages
 $true

有关覆盖已删除的数据库页对性能的影响的详细信息，请参阅知识库文章 815068"XADM:Online Backup Performance Decreases Over Time"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815068)。


Debug Break At Startup 已设置
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Microsoft Exchange 信息存储上是否启用了调试：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Debug Break At Startup

如果 Exchange Server 分析工具发现为 Debug Break At Startup 设置了值，Exchange Server 分析工具将显示警告。

Debug Break At Startup 注册表值在下次启动 Microsoft Exchange 信息存储服务时打开调试模式。Microsoft Exchange 信息存储在调试模式下运行时会占用许多资源。在生产环境中调试存储不是最好的做法。

除非您要借助于 Microsoft 产品支持服务积极地排除存储故障，否则，应删除 Debug Break At Startup 注册表值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
删除 Debug Break At Startup 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右侧窗格中，找到并删除 Debug Break At Startup 值。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


默认 ESE 日志缓冲区已更改
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具搜索 Active Directory® 目录服务，以获取 Exchange Server 计算机上每个存储组的 msExchESEParamLogBuffers 属性值。如果 Exchange Server 分析工具发现 msExchESEParamLogBuffers 的值等于 512，则显示非默认配置消息。

msExchESEParamLogBuffers 存储组属性用于控制 Exchange 信息存储所使用的可扩展存储引擎 (ESE) 日志缓冲区的个数。ESE 使用一组日志缓冲区以便在将信息写入到事务日志中之前先暂时存放在 RAM 中。使用这些缓冲区有助于提高事务日志记录的性能。对于大型服务器而言，默认值 84 太低。这可能导致事务日志驱动器上产生过多的磁盘 I/O 操作，因此，当服务器负载很重或者当用户发送大型邮件时，性能会大幅度下降。增加 ESE 日志缓冲区的数目有助于改善性能，但也需要使用更多的虚拟内存。

若要正确地设置该值，请使用下列信息：

  • 对于 Exchange 2000 Server、Exchange 2000 Server Service Pack 1 (SP1) 或 Exchange 2000 Server Service Pack 2 (SP2)，将该值设置为 9000。

  • 对于 Exchange 2000 Server Service Pack 3 (SP3)，将该值设置为 512。

  • 对于 Exchange Server 2003，使用默认值 500，并且应将 msExchESEParamLogBuffers 属性值更改为 9000。

注意：
如果以前将日志缓冲区调整为 9000，在应用 Exchange 2000 Server SP3 之后，请确保手动减少该设置。安装 Exchange 2000 Server SP3 时，不会自动进行该更改。

如果存在日志停止的情况，可能是由于缓冲区数目过低而导致的。最多可以将该值提高到 9000。可以监视 Database\Log Record Stalls/sec 性能计数器以确定是否发生了日志停止的情况。不要使用大于 9000 的值，因为这样会破坏事务日志文件。

注意：
Log Record Stalls/sec 是指每秒钟内由于日志缓冲区已满而无法添加到日志缓冲区中的日志记录的数目。如果该计数器在大多数情况下都显示非零的值，则日志缓冲区大小可能是一个瓶颈。

必须使用 Active Directory 服务接口 (ADSI) Edit 管理单元、LDP (ldp.exe) 工具或其他任何轻型目录访问协议 (LDAP) 版本 3 客户端等工具来更正该值。

警告：
在使用 ADSI Edit、LDP 工具或其他 LDAP 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

还原到默认配置

  1. 启动 ADSI Edit。

  2. 双击 Configuration 容器，展开 CN=Services，展开 CN=Microsoft Exchange，再展开 CN=<ExchangeOrganizationName>。

  3. 展开 CN=Administrative Groups，展开 CN=<AdministrativeGroupName>，再展开 CN=Servers。

  4. 展开 CN=<ServerName>，展开 CN=InformationStore，用鼠标右键单击 CN=<StorageGroupName>，再单击"属性"。

  5. 在 Attribute Editor 中，单击 msExchESEParamLogBuffers 属性，再单击 Edit。

  6. 在 Edit Attribute 框中，针对 Exchange 2000 Server 将该值设置为 512 或针对 Exchange Server 2003 将该值设置为 9000。

  7. 单击 Apply，再单击 OK。

  8. 关闭 ADSI Edit，并重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

有关 ESE 日志缓冲区的详细信息，请参阅 Microsoft 知识库文章 328466"XADM:ESE Log Buffers That Are Set Too Low Can Cause the Store to Stop Responding"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466)。

有关使用 LDP 工具的详细信息，请参阅知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

有关使用 ADSI Edit 的详细信息，请参阅 Windows Server 帮助中的主题"Adsiedit.msc:ADSI Edit"。


默认的公用文件夹存储为远程存储
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-03

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个邮箱存储的 msExchHomePublicMDB 属性是否包含本地 Exchange Server。默认情况下，邮箱存储的公用文件夹存储在本地 Exchange Server 上。如果 msExchHomePublicMDB 属性不包含本地 Exchange Server，邮箱存储使用远程的默认公用文件夹存储。如果 Exchange Server 分析工具发现邮箱存储使用远程默认公用文件夹存储，Exchange Server 分析工具将显示非默认配置消息。

更改默认公用文件夹存储

  1. 在 Exchange 系统管理器中，依次展开"服务器"、<您的 Exchange 服务器>、<存储组>，再右键单击邮箱存储，然后选择"属性"。

  2. 在"常规"选项卡的"默认公用存储"下，单击"浏览"选择一个公用文件夹存储。

有关邮箱存储和公用文件夹存储的详细信息，请参阅"Exchange Server 2003 管理指南"中的"管理邮箱存储和公用文件夹存储"(http://www.microsoft.com/downloads/details.aspx?FamilyID=98e45481-1458-4809-97d6-50d8aeebd8a1&DisplayLang=zh-cn)。


邮箱存储的删除线程期限为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定去除已删除的项的间隔是否已由默认设置修改为其他设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Deletion Thread Period

如果 Exchange Server 分析工具发现 Deletion Thread Period 注册表项存在并已配置，则显示非默认配置消息。

删除邮件时，Exchange 将标记删除的邮件。Exchange 还将邮件标记为隐藏，直到将其从 Exchange 存储中永久删除。如果 Exchange 存储收到删除邮件 ID 引用的特定文件夹中的邮件的请求，Exchange 存储将确定邮件应软删除还是硬删除。在已删除项的保留期限过后，邮件将被永久删除。软删除也称为逻辑删除。硬删除也称为物理删除。

默认情况下，dumpster 清理过程每 24 小时运行一次，确定是否到了硬删除某项的时间。dumpster 清理过程是 Exchange 存储联机维护过程的一部分。如果已删除项的保留期限过后，将硬删除该项。Deletion Thread Period 注册表值用于覆盖默认的 24 小时间隔，并为 dumpster 清理过程指定自定义间隔。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. 删除 Deletion Thread Period 注册表项。

  4. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关已删除项的保留和恢复的详细信息，请参阅下列知识库文章：

  • 249680"XADM:Understanding Deleted Item Retention and Message Deletion Process"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=249680)

  • 287544"XADM:Public Information Store Grows Significantly When the Deleted Item Retention Functionality Is Enabled"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=287544)

  • 822938"HOW TO:Use System Policies to Configure Mailbox Storage Limits in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822938)


公用文件夹存储的删除线程期限为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定移除已删除的项的间隔是否已从默认设置更改为其他设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\Deletion Thread Period

如果 Exchange Server 分析工具发现 Deletion Thread Period 注册表项存在并已配置，则会显示非默认配置消息。

删除邮件时，Exchange 将标记删除的邮件。Exchange 还将邮件标记为隐藏，直到将其从 Exchange 存储中永久删除。如果信息存储收到删除邮件 ID 引用的特定文件夹中的邮件的请求，Exchange 存储将确定邮件应软删除还是硬删除。软删除也称为逻辑删除，硬删除也称为物理删除。在已删除项的保留期限过后，邮件将被永久删除。

默认情况下，dumpster 清理过程每 24 小时运行一次，确定是否到了硬删除某项的时间。dumpster 清理过程是 Exchange 存储联机维护过程的一部分。如果已删除项的保留期限过后，将硬删除该项。Deletion Thread Period 注册表值用于覆盖默认的 24 小时间隔，并为 dumpster 清理过程指定自定义间隔。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. 删除 Deletion Thread Period 注册表项。

  4. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关已删除项的保留和恢复的详细信息，请参阅下列知识库文章：

  • 249680"XADM:Understanding Deleted Item Retention and Message Deletion Process"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=249680)

  • 287544"XADM:Public Information Store Grows Significantly When the Deleted Item Retention Functionality Is Enabled"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=287544)

  • 319098"HOW TO:Use System Policies to Configure Public Folder Storage Limits in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319098)


检测到磁盘瓶颈
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2006-11-14

Microsoft® Exchange Server 分析工具已确定您的磁盘系统当前正在可用吞吐量最大预期值的 20% 以内工作。通过执行下列计算之一可以确定这一点：

  • 测量磁盘延迟时间。表示延迟时间的性能计数器是 LogicalDisk\Avg、Disk sec/Read 和 LogicalDisk\Avg.Disk sec/Write。

  • 将当前磁盘配置和心轴数每秒可能的最大磁盘 I/O (IOPS) 与性能监视器 (Perfmon) 记录的当前 IOPS 值进行比较。

可接受的延迟时间

Exchange 服务器可以接受的延迟时间取决于正在访问的数据类型。因此，可接受的最大平均延迟时间阈值取决于磁盘上的资源类型。在除下表所述情况以外的所有情况中，读取或写入延迟时间可接受的最大值是 50 毫秒 (ms)。

  • 事务日志驱动器 保存事务日志的驱动器的平均写入延迟应低于 10 ms。写入延迟的峰值应低于 50 ms。对事务日志的写入是同步发生的操作。这意味着 Store.exe 进程中的线程必须等待写入完成后，才能执行其他任务。缩短事务日志的写入延迟对于服务器性能非常重要。事务日志驱动器的平均读取延迟应低于 20 ms。读取延迟的峰值应低于 50 ms。Database Log Record Stalls/sec 应小于 10。Database Log Threads Waiting 应小于 10。

    通常，Exchange 服务器不读取事务日志。因此，该驱动器的读取延迟并不重要。但是，因为事务日志写入延迟对于 Exchange 性能非常重要，所以，在大型服务器上，建议不要出于任何其他目的来使用宿主事务日志的驱动器。在这种情况下，与写入速率（由 LogicalDisk\Disk Writes/sec 度量）相比，读取速率（由 LogicalDisk\Disk Reads/sec 度量）应最小。Exchange Server 分析工具将检测事务日志驱动器上读取与写入的比率是否大于 0.10（每写入十次，读取多于一次）。

    如果读取与写入之比大于 0.10，那么应确定读取事务日志驱动器的应用程序，然后禁止进行此操作。

  • 数据库驱动器 包含 Exchange 数据库文件（*edb 和 *stm 文件）的驱动器可以接受的延迟时间如下（更高的值表示磁盘瓶颈）：

    • 数据库驱动器上 Logical Disk\Avg.Disk sec/Read 的最大值应小于 50 毫秒（0.050 秒）。

    • 数据库驱动器上 Logical Disk\Avg.Disk sec/Read 的平均值应小于 20 毫秒（0.020 秒）。

  • TEMP 和 TMP 驱动器 包含 TEMP 和 TMP 目录的驱动器的延迟时间应使读取延迟和写入延迟低于 10 ms。读取延迟或写入延迟的最大值应低于 50 ms。

  • 页面驱动器和系统驱动器 包含页面文件和 Windows 系统文件的驱动器的延迟时间应使读取延迟和写入延迟低于 10 ms。

  • SMTP 驱动器 包含 SMTP 服务器文件的驱动器的延迟时间应使读取延迟和写入延迟低于 10 ms。

延迟原因

以高于磁盘子系统可以支持的速率访问磁盘是磁盘延迟最常见的原因之一。在这种情况下，磁盘称为"瓶颈"。这也意味着磁盘子系统达到或超过其吞吐能力。

如果磁盘 IOPS 的速率 (LogicalDisk\Disk Transfers/sec) 接近或超过估计的处理能力，该磁盘将称为"超过吞吐能力"或"超过处理能力"。在上述情况下，要提高服务器性能，必须减小磁盘子系统的负载（将用户转移到其他服务器上）或提高驱动器的处理能力（通过添加更多或更快的心轴）。

如果硬件没有达到预期的性能，那么即使 I/O 速率远低于估计的处理能力，也可能会发生延迟。

缩短磁盘延迟

若要减小磁盘子系统的负载，可以减少由服务器执行的一些任务。尤其是应该删除任何产生磁盘负载的可选应用程序。Store.exe 进程是应访问数据库驱动器和事务日志驱动器的唯一应用程序。

根据当前的磁盘系统配置，可能需要采取几项措施来降低此问题的影响。

缩短磁盘延迟

  • 如果数据库或事务日志驱动器成为瓶颈，则可以通过将用户转移到尚未接近最大容量的驱动器上托管的数据库或存储组，从而减少该驱动器的负载。如果所有数据库或事务日志驱动器都接近最大容量，则可能必须将用户转移到其他服务器。有关详细信息，请参阅将用户邮箱移至其他服务器

  • 有时，高 I/O 速率是由占用大量资源的 MAPI 操作导致的，因此它的持续时间很短。在这种情况下，要确定造成高 I/O 速率的用户或操作，可以将 Exchange Server User Monitor (ExMon) 工具和逻辑磁盘性能计数器结合使用。如果可以隔离该用户，那么也许可以确定产生较大负载的客户端应用程序。可以从 Microsoft 下载中心下载 ExMon (http://go.microsoft.com/fwlink/?LinkId=54983)。

  • 如果运行的是 RAID-5 磁盘阵列，那么可能需要更改为 RAID-10 磁盘阵列，以便提高磁盘子系统支持的可用 IOPS。

  • 要提高磁盘系统支持的可用 IOPS，请考虑为其添加更多磁盘。

详细信息

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（排除 Microsoft Exchange Server 性能故障）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关设计存储体系结构的最佳实践的详细信息，请参阅"Best Practices Common to Multiple Architectures"（多种体系结构通用的最佳实践） (http://go.microsoft.com/fwlink/?LinkId=72988).

  • 有关移动用户邮箱以降低服务器负载的详细信息，请参阅将用户邮箱移至其他服务器。

  • 有关磁盘大小调整、延迟时间和 I/O 速率的详细信息，请参阅 Microsoft Exchange 工作组博客网站上的下列博客：

    • "A few basic concepts in disk sizing"（磁盘大小调整的一些基本概念）(http://go.microsoft.com/fwlink/?linkid=39538)

    • "Some more thoughts on disk IO and calculations..."（磁盘 IO 和计算的更多思路...）(http://go.microsoft.com/fwlink/?linkid=39539)

    • How to Calculate Your Disk I/O Requirements（如何计算磁盘 I/O 要求）(http://go.microsoft.com/fwlink/?linkid=69747)


在包含事务日志文件的磁盘上发现磁盘瓶颈
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具已确定存放 Exchange Server 日志文件的磁盘系统执行的任务过多，造成性能瓶颈。通过检查下列一个或多个性能计数器可以确定这一点：

  • Database\Log Record Stalls/sec 平均值大于 10。

  • Database\Log Record Stalls/sec 最大值大于 100。

  • Database\Log Threads Waiting 平均值大于 10。

  • Database\Log Threads Waiting 最大值大于 20。

如果达到上述任意一个阈值，则会显示错误，表明日志驱动器是磁盘瓶颈。日志文件需要低写入延迟。写入日志文件时的任何备份或停止都可能导致服务器性能问题。日志缓冲区设置 msExchESEParamLogBuffers 低或连接到服务器的用户过多可能造成日志停止。

缩短日志磁盘延迟

  • 可以将 ESE 缓冲区参数 msExchESEParamLogBuffers 增大到 9,000。不要使用大于 9,000 的值，因为这样可能会损坏事务日志文件。有关详细信息，请参阅默认 ESE 日志缓冲区已更改。

  • 如果数据库或事务日志驱动器成为瓶颈，则可以将用户转移到尚未接近最大容量的驱动器上驻留的数据库或存储组，从而减少该驱动器的负载。如果所有数据库或事务日志驱动器都接近最大容量，则可能必须将用户转移到其他服务器。有关详细信息，请参阅将用户邮箱移至其他服务器。


EnableChangeNotification 为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表值，以确定是否已启用 Exchange 可安装文件系统 (ExIFS) 的文件更改通知：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIFS\Parameters\ EnableChangeNotification

如果 Exchange Server 分析工具发现 EnableChangeNotification 项存在并且配置的值大于 0，则显示非默认配置消息。

默认情况下，ExIFS 禁用文件更改通知。ExIFS 在发送文件或目录的更改通知时，不会清除文件或目录的缓存版本。因此，在 Exchange Server 或 Microsoft SharePoint® Portal Server 等应用程序收到更改通知并重新加载文件或目录时，应用程序将获取缓存的版本，而不是获取新修改的文件或目录。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\EXIFS\Parameters

  3. 删除 EnableChangeNotification 注册表项。

  4. 关闭注册表编辑器，然后重新启动 Exchange 服务器，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Exchange 可安装文件系统的详细信息，请参阅下列文章：

  • "Exchange 2000 Server Resource Kit"（英文）的第 26 章"Exchange 2000 Architecture"（英文）(http://go.microsoft.com/fwlink/?LinkId=51224)

  • "Exchange Server 2003 Technical Reference Guide"（英文）(http://go.microsoft.com/fwlink/?linkid=47891)


访问日志目录时出错
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具已确定在 Exchange 服务器上为此存储组的事务日志定义的路径无法访问。

更正此错误

  • 验证该路径在服务器上是否实际存在。

  • 验证是否拥有读取事务日志路径中存储的文件所需的权限。


访问流式数据库文件时出错
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具确定 Exchange 流式数据库 (.stm) 文件不可访问。

Exchange 2000 Server 和 Exchange Server 2003 中的每个数据库都包括两个文件：.edb Exchange 数据库文件和 .stm 流式数据库文件。必须同时访问和处理这两个文件。

若要更正此错误，请执行下列操作：

  • 找到 .stm 文件的路径。在 Exchange 系统管理器中，此路径在每个数据库对象的数据库属性页上定义。

  • 验证此数据库的 .stm 文件是否存在。

  • 验证您是否具有访问 .stm 文件所在文件夹的权限。

  • 验证此文件尚未由另一个进程独占锁定。验证此情况的一种方法是尝试重命名此文件。如果可以成功重命名此文件，则指示它尚未被独占锁定。（请记住再将此文件重命名为其原始名称。）


检查日志文件时出错
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具无法读取事务日志文件。

更正此错误

  • 验证您拥有访问事务日志文件文件夹所需的权限。

  • 验证文件未被其他进程独占锁定。验证这一点的一种方式是尝试重命名文件。如果可以成功重命名文件，则表明文件未被独占锁定。（记住将文件重命名回原始名称。）


此存储组上的 ESE 日志缓冲区处于最大值设置
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个存储组的 msExchESEParamLogBuffers 属性的值。如果 Exchange Server 分析工具发现 msExchESEParamLogBuffers 属性的值等于 9,000，则会显示非默认配置消息。

可扩展存储引擎 (ESE) 使用一组日志缓冲区以便在将信息写入到事务日志中之前先暂时存放在 RAM 中。使用这些缓冲区有助于提高事务日志记录的性能。对于大型服务器而言，默认值 84 太低。这可能导致事务日志驱动器上产生过多的磁盘 I/O 操作，因此，当服务器负载很重或者当用户发送大型邮件时，性能会大幅度下降。增加 ESE 日志缓冲区的数目有助于改善性能，但也需要使用更多的虚拟内存。

若要正确地设置此值，请使用以下信息：

  • 对于 Exchange 2000 Server、Exchange 2000 Server Service Pack 1 (SP1) 或 Exchange 2000 Server Service Pack 2 (SP2)，将该值设置为 9000。

  • 对于 Exchange 2000 Server Service Pack 3 (SP3)，将该值设置为 512。

  • 对于 Exchange Server 2003，则使用默认值 500，并且应当将 msExchESEParamLogBuffers 属性的值更改为 9000。

注意：
如果以前将日志缓冲区调整为 9000，在应用 Exchange 2000 Server SP3 之后，请确保手动减少该设置。安装 Exchange 2000 Server SP3 时，不会自动进行该更改。

如果存在日志停止的情况，可能是由于缓冲区数目过低而导致的。最多可以将该值提高到 9000。可以监视 Database\Log Record Stalls/sec 性能计数器以确定是否发生了日志停止的情况。不要使用大于 9000 的值，因为这样会破坏事务日志文件。

注意：
Log Record Stalls/sec 是指每秒钟内由于日志缓冲区已满而无法添加到日志缓冲区中的日志记录的数目。如果该计数器在大多数情况下都显示非零的值，则日志缓冲区大小可能是一个瓶颈。

必须使用 Active Directory 服务接口 (ADSI) Edit 管理单元、LDP (ldp.exe) 工具或其他任何轻型目录访问协议 (LDAP) 版本 3 客户端等工具来更正该值。

警告：
在使用 ADSI Edit、LDP 工具或其他 LDAP 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

还原为默认配置

  1. 启动 ADSI Edit。

  2. 双击 Configuration 容器，然后依次展开 CN=Services、CN=Microsoft Exchange、CN=<ExchangeOrganizationName>。

  3. 依次展开 CN=Administrative Groups、CN=<AdministrativeGroupName>、CN=Servers。

  4. 展开 CN=<ServerName>，展开 CN=InformationStore，用鼠标右键单击 CN=<StorageGroupName>，再单击"属性"。

  5. 在 Attribute Editor 中，单击 msExchESEParamLogBuffers 属性，再单击 Edit。

  6. 在"编辑属性"框中，对于 Exchange 2000 Server 将值设置为 512，对于 Exchange Server 2003 将值设置为 9000。

  7. 单击 Apply，再单击 OK。

  8. 关闭 ADSI Edit，并重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

有关设置 ESE 日志缓冲区的详细信息，请参阅 Microsoft 知识库文章 328466"XADM: ESE Log Buffers That Are Set Too Low Can Cause the Store to Stop Responding"（英文）(http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466)。


此存储组上的 ESE 日志缓冲区数目设置得过低
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 InformationStore 容器中每个存储组对象（msExchStorageGroup 类）的 msExchESEParamLogBuffers 值。如果 Exchange Server 分析工具发现该属性的值小于 500，则显示警告。

可扩展存储引擎 (ESE) 使用一组日志缓冲区以便在将信息写入到事务日志中之前先暂时存放在 RAM 中。使用这些缓冲区有助于提高事务日志记录的性能。对于大型服务器而言，默认值 84 太低。这可能导致事务日志驱动器上产生过多的磁盘 I/O 操作，因此，当服务器负载很重或者当用户发送大型邮件时，性能会大幅度下降。增加 ESE 日志缓冲区的数目有助于改善性能，但也需要使用更多的虚拟内存。

要正确地设置该值，请根据下列信息执行操作：

  • 对于 Exchange 2000 Server、Exchange 2000 Server Service Pack 1 (SP1) 或 Exchange 2000 Server Service Pack 2 (SP2)，将该值设置为 9000。

  • 对于 Exchange 2000 Server Service Pack 3 (SP3)，将该值设置为 512。

  • 对于 Exchange Server 2003，使用默认值 500，同时应当将 msExchESEParamLogBuffers 属性值更改为 9000。

注意：
如果以前将日志缓冲区调整为 9000，在应用 Exchange 2000 Server SP3 之后，请确保手动减少该设置。安装 Exchange 2000 Server SP3 时，不会自动进行该更改。

如果存在日志停止的情况，可能是由于缓冲区数目过低而导致的。最多可以将该值提高到 9000。可以监视 Database\Log Record Stalls/sec 性能计数器以确定是否发生了日志停止的情况。不要使用大于 9000 的值，因为这样会破坏事务日志文件。

注意：
Log Record Stalls/sec 是指每秒钟内由于日志缓冲区已满而无法添加到日志缓冲区中的日志记录的数目。如果该计数器在大多数情况下都显示非零的值，则日志缓冲区大小可能是一个瓶颈。

必须使用 Active Directory 服务接口 (ADSI) Edit 管理单元、LDP (ldp.exe) 工具或其他任何轻型目录访问协议 (LDAP) 版本 3 客户端等工具来更正该值。

警告：
在使用 ADSI Edit、LDP 工具或其他 LDAP 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

解决此警告问题

  1. 启动 ADSI Edit。

  2. 双击 Configuration 容器，然后依次展开 CN=Services、CN=Microsoft Exchange、CN=<ExchangeOrganizationName>。

  3. 依次展开 CN=Administrative Groups、CN=<AdministrativeGroupName>、CN=Servers。

  4. 展开 CN=<ServerName>，展开 CN=InformationStore，用鼠标右键单击 CN=<StorageGroupName>，再单击"属性"。

  5. 在 Attribute Editor 中，单击 msExchESEParamLogBuffers 属性，再单击 Edit。

  6. 在 Edit Attribute 框中，对于 Exchange 2000 Server，将该值设置为 512 或对于 Exchange Server 2003，将该值设置为 9000。

  7. 单击 Apply，再单击 OK。

  8. 关闭 ADSI Edit，并重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

有关 ESE 日志缓冲区的详细信息，请参阅 Microsoft 知识库文章 328466"XADM:ESE Log Buffers That Are Set Too Low Can Cause the Store to Stop Responding"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466)。

有关使用 LDP 工具的详细信息，请参阅知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

有关设置 ESE 日志缓冲区的详细信息，请参阅知识库文章 328466"XADM:ESE Log Buffers That Are Set Too Low Can Cause the Store to Stop Responding"（英文）(http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466)。

有关使用 ADSI Edit 的详细信息，请参阅 Windows Server 帮助中的主题"Adsiedit.msc:ADSI Edit"。


此存储组上的 ESE 日志缓冲区数目设置得过高
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个存储组的 msExchESEParamLogBuffers 属性值。如果 Exchange Server 分析工具发现任何存储组的 msExchESEParamLogBuffers 属性值大于 9,000，则显示错误。

可扩展存储引擎 (ESE) 使用一组日志缓冲区以便在将信息写入到事务日志中之前先暂时存放在 RAM 中。使用这些缓冲区有助于提高事务日志记录的性能。对于大型服务器而言，默认值 84 太低。这可能导致事务日志驱动器上产生过多的磁盘 I/O 操作，因此，当服务器负载很重或者当用户发送大型邮件时，性能会大幅度下降。增加 ESE 日志缓冲区的数目有助于改善性能，但也需要使用更多的虚拟内存。

若要正确地设置该值，请使用下列信息：

  • 对于 Exchange 2000 Server、Exchange 2000 Server Service Pack 1 (SP1) 或 Exchange 2000 Server Service Pack 2 (SP2)，将该值设置为 9000。

  • 对于 Exchange 2000 Server Service Pack 3 (SP3)，将该值设置为 512。

  • 对于 Exchange Server 2003，使用默认值 500，同时应当将 msExchESEParamLogBuffers 属性值更改为 9000。

注意：
如果以前将日志缓冲区调整为 9000，在应用 Exchange 2000 Server SP3 之后，请确保手动减少该设置。安装 Exchange 2000 Server SP3 时，不会自动进行该更改。

如果存在日志停止的情况，可能是由于缓冲区数目过低而导致的。最多可以将该值提高到 9000。可以监视 Database\Log Record Stalls/sec 性能计数器以确定是否发生了日志停止的情况。不要使用大于 9000 的值，因为这样会破坏事务日志文件。

注意：
Log Record Stalls/sec 是指每秒钟内由于日志缓冲区已满而无法添加到日志缓冲区中的日志记录的数目。如果该计数器在大多数情况下都显示非零的值，则日志缓冲区大小可能是一个瓶颈。

必须使用 Active Directory 服务接口 (ADSI) Edit 管理单元、LDP (ldp.exe) 工具或其他任何轻型目录访问协议 (LDAP) 版本 3 客户端等工具来更正该值。

警告：
在使用 ADSI Edit、LDP 工具或其他 LDAP 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

更正此错误

  1. 启动 ADSI Edit。

  2. 双击 Configuration 容器，然后依次展开 CN=Services、CN=Microsoft Exchange、CN=<ExchangeOrganizationName>。

  3. 依次展开 CN=Administrative Groups、CN=<AdministrativeGroupName>、CN=Servers。

  4. 展开 CN=<ServerName>，展开 CN=InformationStore，用鼠标右键单击 CN=<StorageGroupName>，再单击"属性"。

  5. 在 Attribute Editor 中，单击 msExchESEParamLogBuffers 属性，再单击 Edit。

  6. 在 Edit Attribute 框中，对于 Exchange 2000 Server，将该值设置为 512或对于 Exchange Server 2003，将该值设置为 9000。

  7. 单击 Apply，再单击 OK。

  8. 关闭 ADSI Edit，并重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

有关使用 LDP 工具的详细信息，请参阅 Microsoft 知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

有关设置 ESE 日志缓冲区的详细信息，请参阅知识库文章 328466"XADM:ESE Log Buffers That Are Set Too Low Can Cause the Store to Stop Responding"（英文）(http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466)。


已手动更改 ESE 日志文件大小
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 InformationStore 容器的 msExchESEParamLogFileSize 属性的值。如果 Exchange Server 分析工具发现 msExchESEParamLogFileSize 属性的值不等于 5120，则显示错误。

该值应用于服务器上的所有存储组。如果该属性的值已从其默认值（5120 KB 或 5 MB）更改为其他值，则会出现该特定错误。这是唯一受支持的值，何时都不能更改。

必须使用 Active Directory 服务接口 (ADSI) Edit 管理单元、LDP (ldp.exe) 工具或其他任何轻型目录访问协议 (LDAP) 版本 3 客户端等实用程序来更正该值。

警告：
在使用 ADSI Edit、LDP 工具或其他 LDAP 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

更正此错误

  1. 打开 Active Directory 编辑器（如 ADSI Edit），在 Active Directory 中找到该 Exchange Server 计算机的 InformationStore 对象。

    可以在以下位置找到 msExchESEParamLogFileSize 属性：

    CN=Configuration, DC=Domain, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Administrative Groups, CN=AdministrativeGroupName, CN=Servers, CN=ServerName, CN=InformationStore

  2. 双击 msExchESEParamLogFileSize 属性，并将其值设置为 5120。

  3. 关闭注册表编辑器，并重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

有关使用 LDP.exe 编辑 Active Directory 属性的详细信息，请参阅 Microsoft 知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

有关使用 ADSI Edit 的详细信息，请参阅 Windows Server 帮助中的主题"Adsiedit.msc:ADSI Edit"。


ESE 最大打开表数已硬编码
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Exchange Server 对象的 InformationStore 对象下面的任意存储组对象是否存在 msExchESEParamMaxOpenTables 属性。如果 Exchange Server 分析工具发现 msExchESEParamMaxOpenTables 属性存在并已配置，则会显示非默认配置消息。

默认情况下，在 Exchange 2000 Server 和 Exchange Server 2003 中，此属性存在但不设置任何值。Exchange Server 缓存当前未被访问的文件夹的有关数据。在某些情况下，这样可能产生虚拟内存碎片。缓解这一问题的一种方法是减少最多可以同时打开的数据库表的数目。该属性的实际建议值因 Exchange Server 的版本及安装的 Exchange Service Pack 的不同而不同。对于 Exchange 2000 Server Service Pack 2，8 处理器服务器的默认设置为每个存储组 85,000 个表。在 Exchange 2000 Server Service Pack 3 中，8 处理器服务器的此限额减少到 27,600。对于 4 处理器服务器，该值为 13,800。可以降低该值以减少虚拟内存碎片问题。但是，降低该值还可能导致由于打开的表过多而操作失败。由于最多可以同时打开的表的数目降低（意味着会更迅速地达到最大值），因此会出现此错误。

Exchange Server 2003 使用另一种方法来缓存当前未被访问的文件夹的有关数据。因此，减小打开表的最大数目既没有必要，对减少虚拟内存碎片问题也无效。该属性不应在 Exchange Server 2003 服务器上设置。

除非在 Microsoft 产品支持服务的指导下在此处输入值，否则应使用 Active Directory 服务接口 (ADSI) Edit 工具来清除在此属性上设置的值。

警告：
在使用 ADSI Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

清除 msExchESEParamMaxOpenTables 属性值

  1. 打开 Active Directory 编辑器，如 ADSI Edit。

  2. 双击 Configuration 容器，然后依次展开 CN=Services、CN=Microsoft Exchange、CN=ExchangeOrganizationName。

  3. 依次展开 CN=Administrative Groups、CN=AdministrativeGroupName、CN=Servers。

  4. 展开 CN=ExchangeServerName，再展开 CN=InformationStore，右键单击 CN=StorageGroupName，然后单击"属性"。

  5. 在选择要查看的属性框中，单击 msExchESEParamMaxOpenTables。

  6. 在编辑属性框中，单击 Clear 将该值更改为 <not set>。

  7. 单击 OK，然后再次单击 OK。

  8. 关闭 Active Directory 编辑器，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

有关此属性的详细信息，请参阅 Microsoft 知识库文章 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://support.microsoft.com/kb/325044/zh-cn)。

有关使用 LDP 工具的详细信息，请参阅知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。


Exchange 数据库的大小超过 100 GB
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-17

Microsoft® Exchange Server 分析工具查询 CIM_DataFile Microsoft Windows® Management Instrumentation (WMI) 类，以确定每个 Exchange 信息存储数据库的 FileSize 关键字的值。如果信息存储的 .edb 文件和 .stm 文件的合计大小超过 100 GB，则会显示警告。

Microsoft 建议不要使信息存储数据库增长到 50 GB 以上。在进行适当维护的情况下，运行超过 50 GB 的邮箱存储不会导致操作问题。但是，当进行备份和还原时，过大的邮箱存储可能不适合于某些服务等级协定 (SLA)。

如果邮箱存储超过 50 GB，请确认硬件与服务等级协定完全匹配，以便大型数据库的还原在 SLA 的规范之内。否则，建议将邮箱分布在多个邮箱存储中，以便单个邮箱存储的大小不超过 50 GB。

解决此警告问题

  1. 考虑将大型信息存储中的某些邮箱移动到此 Exchange Server 计算机或另一台 Exchange Server 计算机上的新信息存储中。

  2. 如果最近已将此信息存储中的邮箱移动到另一个存储，或者最近已从此信息存储中删除了邮箱，则执行脱机碎片整理可能会使文件大小减小。

  3. 考虑设置邮箱或邮件大小限制，以防止信息存储数据库无限增长。

有关 .stm 和 .edb 文件的详细信息，请参阅 Microsoft 知识库文章 232323"Native Content Storage in Microsoft Exchange"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323)。

有关在 Exchange Server 2003 中移动邮箱的详细信息，请参阅知识库文章 821829"在 Exchange Server 2003 中移动邮箱"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)。

有关在 Exchange 2000 Server 中移动邮箱的详细信息，请参阅知识库文章 328810"XADM：在服务器之间移动邮箱"(http://support.microsoft.com/kb/328810/zh-cn)。

有关对 Exchange Server 数据库执行脱机碎片整理的详细信息，请参阅知识库文章 328804"XADM：如何对 Exchange 2000 Server 数据库进行碎片整理"(http://support.microsoft.com/kb/328804/zh-cn)。

有关设置邮件大小限制的详细信息，请参阅知识库文章 322679"为邮件设置大小限制"(http://support.microsoft.com/kb/322679/zh-cn)。


Exchange 数据库文件正被写入压缩文件夹
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具查询 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 类，以确定包含 Exchange 信息存储数据库文件的文件夹的 Compressed 关键字的值。如果该文件夹的 Compressed 的值设置为 True，则会显示错误。

在 Exchange 2000 Server 或 Exchange Server 2003 计算机上，信息存储数据库被写入下列默认位置：

<drive> :\Program Files\Exchsrvr\mdbdata

在 Exchange Server 2007 计算机上，数据库文件被写入到下列默认位置：

<drive> :\Program Files\Microsoft\Exchange Server\Mailbox\<Storage Group Name>

Microsoft 不支持将 Exchange 数据文件存储在 NTFS 压缩卷上。如果将 Exchange 数据文件存储在压缩卷上，则额外的开销会极大地影响 Exchange 的性能。此外，信息存储数据库在达到某个大小（大约 4 GB）之后，则可能无法装入，或会被损坏。

Exchange 数据文件包括所有下列文件：

  • .edb 文件

  • .stm 文件

  • .log 文件

  • .dat 文件

  • .eml 文件

  • .chk 文件

由可扩展存储引擎 (ESE) 管理的文件的设计初衷是不能存储在压缩驱动器上。ESE 依赖于扇区独立性来进行基于日志的恢复，而压缩文件会使扇区独立性无效。对于驻留了 ESE 数据库或使用提前写入日志的任何数据库的卷，不应当打开其压缩功能。

在 Exchange 2000 Server Service Pack 3 之前，允许经过压缩的信息存储数据库装入。但是，已使用 NTFS 压缩功能进行压缩的任何 Exchange 2000 Server 信息存储数据库或信息存储日志可以导致文件被破坏。

如果使用 Exchange 2000 Server Service Pack 3，将自动对 128 MB 或更小的压缩信息存储数据库文件进行解压缩。数据库文件增长到大于 128 MB 时，数据库将无法装入，并在应用程序日志中生成错误消息。Exchange 2000 Server Service Pack 3 禁止装入大于 128 MB 的压缩数据库。

对给定文件夹关闭文件压缩功能

  1. 右键单击要为其关闭文件压缩功能的文件夹，再单击"属性"。

  2. 在"常规"选项卡上，单击"高级"。

  3. 在"高级属性"对话框中，清除"压缩内容以便节省磁盘空间"复选框，再单击"确定"。

移动 Exchange 2000 Server 或 Exchange Server 2003 上的数据库文件

  1. 打开 Exchange 系统管理器。

  2. 展开"管理组"，展开您的管理组，展开"服务器"，展开您的服务器，再展开您的存储组，右键单击"邮箱存储"，再单击"属性"。

  3. 在"数据库"选项卡的"Exchange 数据库"或"Exchange 流式数据库"下，单击"浏览"，键入未启用压缩功能的文件夹的路径位置，再单击"确定"。

  4. 单击"确定"或"应用"以应用更改，出现警告消息时再单击"是"。

    单击"是"之后，存储（数据库）将被卸除、移动和重新装入。成功完成上述过程后，您将会收到以下信息性消息：

    数据库文件已成功移动

在 Exchange Server 2007 中移动 Exchange 存储组数据库文件的位置

  1. 按照核心 Exchange Server 2007 文档"How to Move a Storage Group Path"（如何移动存储组路径）(http://go.microsoft.com/fwlink/?LinkID=80747) 中的指导进行操作。

有关 .stm 和 .edb 文件的详细信息，请参阅 Microsoft 知识库文章 232323"Native Content Storage in Microsoft Exchange"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323)。


Exchange 数据库文件正被写入非 NTFS 分区
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具查询 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange 数据库文件路径的 FSName 关键字的值。如果 Exchange Server 分析工具确定 FSName 关键字的值不等于 NTFS File System，则显示错误。

Microsoft 不支持将 Exchange 数据文件存储在非 NTFS 卷上。Exchange 数据文件包括下列所有文件：

  • .edb 文件

  • .stm 文件

  • .log 文件

  • .dat 文件

  • .chk 文件

  • .eml 文件

如果出现该错误，则必须将数据库文件移到 NTFS 驱动器上的某个文件夹中。或者，如果存储数据库文件的驱动器是 FAT 格式的驱动器，可使用 convert.exe 命令行工具将驱动器转换为 NTFS 格式。

在 Exchange 2000 Server 或 Exchange Server 2003 中移动 Exchange 数据库文件

  1. 打开 Exchange 系统管理器。

  2. 依次展开"管理组"、您的管理组、"服务器"、您的服务器、您的存储组，右键单击"邮箱存储"，再单击"属性"。

  3. 在"数据库"选项卡上的"Exchange 数据库"或"Exchange 流式数据库"下，单击"浏览"，键入 NTFS 卷上适当文件夹的路径位置，再单击"确定"。

  4. 单击"确定"或"应用"以应用更改，或者如果不想应用更改，请单击"取消"。

  5. 如果单击了"确定"或"应用"，您将会收到以下警告消息：

    注意 将要执行下列操作：

    • 更改 Exchange 数据库位置

    • 更改 Exchange 流式数据库位置

    若要执行所请求的操作，必须卸除存储，这将使所有用户都无法访问此存储。

    要继续吗？

    注意：
    只有所选的操作会在警告消息中列出。警告消息中包含"是"和"否"按钮。

  6. 一切就绪后请单击"是"，否则单击"否"。

  7. 如果单击了"是"，则存储（数据库）将被卸除、移动和重新装入。成功完成上述过程后，您将会收到以下信息性消息：

    数据库文件已成功移动

在 Exchange Server 2007 中移动 Exchange 存储组数据库文件的位置

  1. 按照核心 Exchange Server 2007 文档"How to Move a Storage Group Path"（如何移动存储组路径）(http://go.microsoft.com/fwlink/?LinkID=80747) 中的指导进行操作。

作为上述过程的可替代方案，如果用于存储文件的驱动器被格式化为 FAT 驱动器，那么，可以使用 convert.exe 命令行工具将该驱动器转换为 NTFS。有关使用 convert.exe 命令行工具将 FAT 分区转换为 NTFS 分区的信息，请参阅 Microsoft 知识库文章 214579"How to Use Convert.exe to Convert a Partition to the NTFS File System"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579)。


Exchange 数据库文件正在写入加密文件夹
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具查询 Win32_Directory Microsoft Windows? Management Instrumentation (WMI) 类，以确定包含 Microsoft Exchange 信息存储数据库文件的文件夹的 Encrypted 关键字的值。如果 Exchange Server 分析工具发现 Encrypted 的值设置为 True，则显示错误。

在 Exchange 2000 Server 或 Exchange Server 2003 计算机上，数据库文件被写入下列默认位置：

<drive> :\Program Files\Exchsrvr\mdbdata

在 Exchange Server 2007 计算机上，数据库文件被写入到下列默认位置：

<drive> :\Program Files\Microsoft\Exchange Server\Mailbox\<Storage Group Name>

Microsoft 不支持在以加密文件系统 (EFS) 方式加密的卷上存储 Exchange 数据文件。如果将 Exchange 数据文件存储在加密卷上，则额外的开销会极大地影响 Exchange 性能。Exchange 数据文件包括下列所有文件：

  • .edb 文件

  • .stm 文件

  • .log 文件

  • .dat 文件

  • .eml 文件

  • .chk 文件

为帮助确保 Exchange 数据文件的安全性，建议禁止对 Exchange 计算机的未经授权访问，并使用 S/MIME 邮件格式加密邮件数据。

若要解决该错误，必须关闭数据库文件正写入其中的文件夹的加密，或将数据库文件移动到未启用加密的文件夹。

关闭给定文件夹上的文件加密

  1. 右键单击想要关闭文件加密的文件夹，再单击"属性"。

  2. 在"常规"选项卡上，单击"高级"。

  3. 在"高级属性"对话框中，清除"加密内容以便保护数据"复选框，再单击"确定"。

移动 Exchange 2000 Server 或 Exchange Server 2003 上的数据库文件

  1. 打开 Exchange 系统管理器。

  2. 依次展开"管理组"、您的管理组、"服务器"、您的服务器、您的存储组，右键单击"邮箱存储"，再单击"属性"。

  3. 在"数据库"选项卡上的"Exchange 数据库"或"Exchange 流式数据库"下，单击"浏览"，键入未启用加密的文件夹的路径位置，再单击"确定"。

  4. 单击"确定"或"应用"以应用更改，然后在出现警告消息时单击"是"。

  5. 单击"是"之后，存储（数据库）将被卸除、移动和重新装入。成功完成上述过程后，您将会收到以下信息性消息：

    数据库文件已成功移动

在 Exchange Server 2007 中移动 Exchange 存储组数据库文件的位置

  1. 按照核心 Exchange Server 2007 文档"How to Move a Storage Group Path"（如何移动存储组路径）(http://go.microsoft.com/fwlink/?LinkId=80747) 中的指导进行操作。

有关移动数据库文件的详细信息，请参阅 Microsoft 知识库文章 821915"如何在 Exchange Server 2003 中移动 Exchange 数据库和日志"(http://support.microsoft.com/kb/821915/zh-cn)。

有关 Exchange Server 数据文件和 EFS 的详细信息，请参阅知识库文章 834638"Information about the storage of data files on an encrypted volume in Exchange Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638)。

有关在 Exchange Server 2003 中如何保护邮件安全的信息，请参阅"Exchange Server 2003 邮件安全指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=2305405C-FAF1-488A-A856-AD467BB59B26&DisplayLang=zh-cn)。


Exchange 数据库处于"肮脏关闭"状态
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2006-10-30

Microsoft® Exchange Server 分析工具已确定您的一个数据库未正确关闭。因此，数据库文件仍连接到日志文件上。

"肮脏关闭"状态并不表明数据库已损坏。"肮脏关闭"状态只表明数据库文件未正确与日志流断开。因此，在重新启动数据库之前，必须先恢复数据库文件。

下一次装入数据库时，将自动运行此恢复。如果自动恢复失败，则可以使用 Microsoft Exchange Server 灾难恢复分析工具来分析失败原因。在分析之后，Exchange Server 灾难恢复分析工具将提供手动恢复数据库文件的建议。

更正此错误

  • 通过将所需的事务日志文件重播到数据库中，使数据库处于"干净关闭"状态。要重播日志文件，请装入数据库。如果失败，可以使用 Exchange Server 灾难恢复分析工具帮助确定失败原因。

有关 Exchange Server 灾难恢复分析工具的详细信息，请参阅 Microsoft 知识库文章 922247"描述 Exchange Server 2003 中的 Microsoft Exchange Server 灾难恢复分析工具"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=922247)。


Exchange 数据库联机维护日程安排设置为"从不"
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-05

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定邮箱存储和公用存储上的 activationSchedule 属性的值。如果 Exchange Server 分析工具发现 activationSchedule 的值解析为"从不"，则会显示警告。

activationSchedule 属性代表联机数据库维护日程安排的设置。Exchange Server 中的联机数据库维护极为重要。在此期间，将执行类似于 dumpster 清理（对超过已删除邮件保留日期的邮件进行删除）、公用文件夹过期（早于特定日期的公用文件夹中的邮件已过期）、已删除邮箱的清理以及联机碎片整理（不再使用的数据库对象将被检测到并删除，以便可以使用更多的数据库空间）等任务。这些过程使得 Exchange Server 计算机能够保持稳定的性能以及良好的状态。应该将联机维护设置为每天至少运行四小时；如果做不到这一点，将会导致性能随时间的推移而降低。

建议您将联机数据库维护配置为每个数据库（邮箱存储或公用文件夹存储）每天运行四小时。使用备份日程安排错开联机维护间隔。例如，如果备份从午夜运行到凌晨 2:00，请从凌晨 3:00 到上午 7:00 之间运行联机维护。

这一点极为重要，因为如果备份会话仍在运行，则不会开始联机维护。如果发生时间范围重叠，则备份优先于维护。在这种情况下，Exchange 将每隔 15 分钟检查一次以确定备份是否已完成。备份结束后，将开始进行维护。

要运行维护，存储需要历经 18 项任务。开始一项任务后，它将完成任务，而无论维护计时窗口如何。但是，如果计时窗口已过期，则维护不会开始新的任务。因此，在某些情况下，并非所有任务都是在指定的维护间隔内完成的。如果维护被中止，则它将在下一个维护周期内从其停止维护的位置开始进行维护。

为 Exchange 2000 Server 和 Exchange Server 2003 启用联机数据库维护

  1. 打开 Exchange 系统管理器。

  2. 展开"服务器"，再展开想要处理的服务器。

  3. 展开想要处理的存储组。

  4. 在详细信息窗格的可用数据存储列表中，右键单击要使用的存储，再单击"属性"。

  5. 在"存储属性"对话框中，单击"数据库"选项卡。

  6. 执行下列操作之一：

    • 在"维护"间隔列表中，选择一个间隔。

    • 单击"自定义"以访问"日程安排"对话框，然后创建自定义间隔。

  7. 单击"确定"。

在 Exchange Server 2007 中解决此警告问题

  1. 打开 Exchange 管理控制台。

  2. 展开"服务器配置"，然后选择要使用的服务器。

  3. 展开要使用的存储组。

  4. 右键单击要使用的存储，然后单击"属性"。

  5. 在"常规"选项卡上，单击"维护日程安排"下拉列表并选择一个间隔，或者单击"自定义"以创建自定义日程安排。

有关联机数据库维护任务的详细信息，请参阅 Microsoft 知识库文章 159196"XADM:Tasks Controlled by the IS Maintenance Schedule"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=159196)。


未将 Exchange 信息存储服务配置成作为 LocalSystem 运行
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-02-27

Microsoft® Exchange Server 分析工具查询 Win32_Services Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Microsoft Exchange 信息存储服务 (MSExchangeIS) 的 StartName 属性指定的启动帐户是否在使用 LocalSystem 帐户。如果 Exchange Server 分析工具发现 Exchange 2000 Server、Exchange Server 2003 或 Exchange Server 2007 计算机上的此属性值是 LocalSystem（也称为 SYSTEM 帐户）以外的任何其他帐户，则会显示警告。对于 Exchange Server 5.5 计算机，则不触发此警告。因为在 Exchange Server 5.5 计算机上，应当且必须以用户帐户运行 Microsoft Exchange 信息存储服务。

必须使用 LocalSystem 安全上下文来启动 Exchange 2000 Server、Exchange Server 2003 和 Exchange Server 2007，而不是关联特定用户帐户（和密码）来启动这些服务。这可确保更改密码或删除用户帐户不会妨碍 Exchange 正常运行。当作为 LocalSystem 运行的 Exchange 服务访问远程服务器时，Microsoft Windows 2000 Server 或 Windows Server™ 2003 将使用计算机帐户的凭据对其进行身份验证。

使用标准的更改密码机制，计算机帐户所对应的密码每七天更改一次。这有助于使计算机帐户比典型用户帐户更安全，典型用户帐户的密码不但更改次数较少，而且可能比随机生成的计算机帐户密码的随机性低。

一些使用过 Exchange Server 5.5（使用用户帐户来提供服务）的管理员会将 Exchange 2000 Server、Exchange Server 2003 和 Exchange Server 2007 服务上的启动帐户由使用默认 LocalSystem 帐户更改为使用用户帐户。

在 Exchange 2000 Server、Exchange Server 2003 和 Exchange Server 2007 上，Microsoft 不支持使用 LocalSystem 以外的任何其他帐户来运行 Microsoft Exchange 信息存储服务。

更正此错误

  1. 单击"开始"，指向"程序"，指向"管理工具"，然后单击"服务"。

  2. 在服务列表中，右键单击"Microsoft Exchange 信息存储"，再单击"属性"。

  3. 在"登录"选项卡的"登录为"下，单击"本地系统帐户"，再单击"确定"。

  4. 右键单击"Microsoft Exchange 信息存储"，再单击"重新启动"。

有关 Exchange 服务的详细信息，请参阅 Microsoft 知识库文章 239762"Exchange 服务在 LocalSystem 下运行"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)。


Exchange 信息存储服务未运行
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-05

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定为 Microsoft Exchange 信息存储服务中的 Started 关键字设置的值为 True 还是 False。

值为 False 说明该 Exchange Server 计算机未运行 Microsoft Exchange 信息存储服务。值为 True 说明正在运行 Microsoft Exchange 信息存储服务。

Exchange Server 分析工具还检查 root\MicrosoftExchangeV2 命名空间中的 Exchange_Server WMI 类，以确定 IsFrontEndServer 关键字的值。值为 False 说明 Exchange Server 计算机不是前端服务器。值为 True 表明 Exchange Server 计算机是 Exchange Server 2003 或 Exchange 2000 Server 前端服务器。

如果所评估的两个关键字的值均为 False，则会在 Exchange 2000 Server 和 Exchange Server 2003 系统上显示警告。

如果为 Win32_Service Started 关键字返回的值是 False，并且 Exchange Server 计算机运行的是 Exchange Server 2007，则会显示警告。

如果启动 Microsoft Exchange 信息存储服务的尝试失败，则说明该 Exchange Server 计算机有更严重的问题。在这种情况下，应当检查事件日志，以了解有关操作失败的详细信息。还应该确保运行的是 Exchange Server 版本的最新 Service Pack。

可以从"Downloads for Exchange Server 2003"（Exchange Server 2003 下载）(http://go.microsoft.com/fwlink/?LinkId=25097) 中获取最新的 Exchange Server 2003 Service Pack。

有关 Microsoft Exchange 信息存储服务失败的已知原因的详细信息，请参阅下列 Microsoft 知识库文章：

  • 827915"The Information Store service may stop unexpectedly while converting a message that does not contain the PR_MESSAGE_CLASS property in Exchange 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827915)

  • 830602"Exchange Server 2003 Information Store service stops responding"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=830602)

  • 839115"The Information Store service does not start after you upgrade to Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839115)

  • 330197"The Information Store service stops unexpectedly when a message with a null Internet message ID is delivered locally"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=330197)

  • 831130"The Folders pane does not appear or the Information Store service quits unexpectedly when you use OWA to access your mailbox on your Exchange Server 2003 computer"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=831130)

  • 823163"'Setup Cannot Locate a Qualifying Global Catalog Server' Error Message When You Try to Start the Information Store Service"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823163)

  • 822579"在安装 Exchange Server 2003 后出现事件 ID 7024，并且 Exchange 信息存储服务不启动"(http://support.microsoft.com/?kbid=822579)

  • 833841"The Microsoft Exchange Information Store service unexpectedly stops responding"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833841)

有关使用 Exchange Server 2003 和 Exchange 2000 Server 前端服务器的详细信息，请访问下列网站：

  • "Using Microsoft Exchange 2000 Front-End Servers"（英文）(http://go.microsoft.com/fwlink/?linkid=12055)

  • "Exchange Server 2003 and Exchange 2000 Server Front-End and Back-End Topology"（英文）(http://go.microsoft.com/fwlink/?linkid=47567)


Exchange 信息存储服务未运行在该前端服务器上
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定为 Microsoft Exchange 信息存储和简单邮件传输协议 (SMTP) 服务的 Started 关键字所设置的值。值为 False 说明服务未运行。值为 True 说明服务正在运行。

Exchange Server 分析工具还检查 root\MicrosoftExchangeV2 命名空间中的 Exchange_Server WMI 类，以确定 IsFrontEndServer 关键字的值。值为 False 说明 Exchange Server 计算机不是前端服务器。值为 True 说明 Exchange Server 计算机是前端服务器。

如果 Exchange Server 分析工具发现 SMTP 服务的 Started 的值是 True，Microsoft Exchange 信息存储服务的 Started 的值是 False，并且 IsFrontEndServer 的值是 True，将显示警告。

Exchange 2000 Server 和 Exchange Server 2003 使用前端服务器来代理 POP3、IMAP4 和 Microsoft Office Outlook® Web Access 客户端请求。另外，可以将它们作为面对 Internet 的 SMTP 服务器使用。如果该前端服务器接受并路由 SMTP 邮件，支持 IMAP 客户端（它使用 SMTP 提交邮件），或者该前端服务器正在运行与 Virus Scan API (VSAPI) 兼容的软件，则必须正在运行 Microsoft Exchange 信息存储服务。否则，前端服务器将不能处理 SMTP 邮件，或使用 VSAPI 来扫描邮件。

除非前端服务器上正在使用 SMTP 或与 VSAPI 兼容的防病毒软件，否则，建议的配置是断开并删除前端服务器上的所有公用文件夹存储，并停止 Microsoft Exchange 信息存储服务，然后将 Microsoft Exchange 信息存储服务设置为禁用。此外，如果未使用 SMTP 服务，则应当将它停止。在使用 SMTP 或与 VSAPI 兼容的软件的 Exchange Server 计算机上，必须运行 Microsoft Exchange 信息存储服务，以便传递邮件并服务于邮件客户端。

解决此警告问题

  1. 打开"服务"MMC 管理单元。

  2. 用鼠标右键单击 Microsoft Exchange Information Store 服务，再单击"属性"。

  3. 在"Microsoft Exchange 信息存储"属性页的"常规"选项卡上，确保"启动类型"已设置为"自动"。如果不是这样，请将它设置为"自动"，再单击"应用"，再单击"确定"。

  4. 用鼠标右键单击"Microsoft Exchange 信息存储"服务，再单击"启动"。

  5. 关闭"服务"管理单元。

如果启动 Microsoft Exchange 信息存储服务的尝试失败，则说明该 Exchange Server 计算机有更严重的问题。在这种情况下，应当检查事件日志，以了解有关操作失败的详细信息。还应当确保正在运行针对该 Exchange Server 版本的最新 Service Pack。可以在网站上的"Microsoft Exchange Server 主页"(http://go.microsoft.com/fwlink/?LinkId=21573) 获得 Exchange Server 的最新 Service Pack。

有关 Microsoft Exchange 信息存储服务失败的已知原因的详细信息，请参阅下列 Microsoft 知识库文章：

  • 827915"The Information Store service may stop unexpectedly while converting a message that does not contain the PR_MESSAGE_CLASS property in Exchange 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827915)

  • 830602"Exchange Server 2003 Information Store service stops responding"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=830602)

  • 839115"The Information Store service does not start after you upgrade to Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839115)

  • 330197"The Information Store service stops unexpectedly when a message with a null Internet message ID is delivered locally"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=330197)

  • 831130"The Folders pane does not appear or the Information Store service quits unexpectedly when you use OWA to access your mailbox on your Exchange Server 2003 computer"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=831130)

  • 823163"'Setup Cannot Locate a Qualifying Global Catalog Server' Error Message When You Try to Start the Information Store Service"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823163)

  • 822579"在安装 Exchange Server 2003 后出现事件 ID 7024，并且 Exchange 信息存储服务不启动"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822579)

  • 833841"The Microsoft Exchange Information Store service unexpectedly stops responding"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833841)

有关使用前端服务器的详细信息，请参阅"Front-End and Back-End Server Topology Guide for Exchange Server 2003 and Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=47567)。


Exchange 可安装文件系统驱动器已启用
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2006-02-28

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已启用 Exchange 可安装文件系统（ExIFS 或 IFS）驱动器号映射：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

如果 Exchange Server 分析工具发现 DriveLetter 注册表值配置为驱动器号（如 M），则显示错误。

Exchange 2000 Server 引入了一项名为 IFS 的功能。IFS 是内核级别驱动程序，它使 Exchange 信息存储中的某些数据可以显示在 Microsoft Windows® 文件系统中。在新安装的 Exchange 2000 Server 以及从 Exchange Server 5.5 升级的 Exchange 2000 Server 上，自动安装 IFS 并为其分配驱动器号（默认情况下，为驱动器 M），并且该 IFS 映射到信息存储。这是使用 \\.\BackOfficeStorage\ 命名空间来执行的。

Exchange Server 2003 支持 IFS，但默认情况下禁用驱动器号映射。在新安装的 Exchange Server 2003 中不存在 DriveLetter 注册表值。在从 Exchange 2000 Server 升级的 Exchange Server 2003 中，注册表值数据被删除，因此驱动器号映射也被删除。

建议不要在 Exchange Server 2003 中启用 IFS 驱动器号映射，并在 Exchange 2000 Server 中将它删除。这是最佳实践。如果防病毒应用程序或基于文件系统的应用程序访问或扫描映射到此 IFS 的驱动器号，则会发生已知问题。因此，建议在不使用 IFS 功能时删除驱动器号映射。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

更正此错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：

    HKLM\System\CurrentControlSet\Services\EXIFS\Parameters

  3. 在右侧窗格中，双击 DriveLetter 值。

  4. 在"数值数据"字段中，删除列出的驱动器号，以便"数值数据"字段为空白。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange System Attendant 服务和 World Wide Web Publishing 服务，以使更改生效。在 System Attendant 服务重新启动后，依赖于 System Attendant 服务的所有服务（包括 Microsoft Exchange MTA Stacks 和 Microsoft Exchange Information Store 服务）也都将重新启动。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关在 Exchange 2000 Server 中删除驱动器 M 映射的详细信息，请参阅知识库文章 305145"删除驱动器 M 的 IFS 映射"(http://support.microsoft.com/kb/305145/zh-cn)。

有关在 Exchange Server 2003 中添加驱动器 M 映射的详细信息，请参阅知识库文章 821836"默认情况下 Exchange Server 2003 中不存在驱动器 M 到 IFS 的映射"(http://support.microsoft.com/kb/821836/zh-cn)。


Exchange Server 配置和性能
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2006-09-06

Microsoft® Exchange Server 分析工具已确定未将 Exchange 服务器配置为可获得最佳性能的状态。

在常规操作过程中，Exchange 服务器会访问各种文件。文件的位置可能会导致出现性能瓶颈。相关文件组（如事务日志驱动器）也称为"资源"。

如果这些资源的分布导致出现磁盘瓶颈，则 Exchange Server 分析工具可能会显示有关 Exchange 服务器上资源位置的警告或错误。若要确保特定的资源不会产生其他负载要求，请将这些资源置于专用存储设备。以下列表描述了每个资源的使用方式，其中包括有关如何配置资源的建议。

  • 事务日志驱动器 事务日志文件维护 .edb 和 .stm 文件的状态和完整性。这意味着日志文件实际上相当于数据。针对每个存储组都有一个事务日志文件集。由于事务日志是 Exchange 服务器数据库文件中的重要数据备份组件，因此，Exchange 服务器必须在它完成许多有关数据的事务之前，向日志文件提交所有数据。写入事务日志驱动器时出现的任何延迟都可能会严重影响服务器的性能。因此，必须将事务日志驱动器隔离出来，以使这些驱动器有自己未与其他服务器、应用程序或资源共享的磁盘子系统。为了获得最佳性能，请确保每个事务日志都有专用驱动器。

  • TEMP 驱动器的位置 首次安装时，操作系统会在它使用的同一驱动器上设置临时文件位置。这意味着 TEMP 驱动器的任何 I/O 都会与通过此驱动器运行的程序和页面文件操作的 I/O 进行竞争。这种 I/O 竞争会影响性能。TEMP 驱动器用于邮件传递和大邮件的内容转换。如果 TEMP 驱动器出现瓶颈现象，则将影响邮件流以及某些客户端应用程序。若要避免操作系统与 TEMP 驱动器竞争 I/O，并降低 Exchange 服务器上出现性能问题的风险，建议您执行下列操作：

    • 将全局环境设置 TEMP 更改为指向其他磁盘。

    • 将 TEMP 驱动器移至它自己的磁盘。

  • .edb 和 .stm 文件的位置 Exchange 数据库包括两个文件：

    • .edb 文件（MAPI 内容） 此文件存储 Store.exe 进程使用的所有 MAPI 邮件和表，以查找所有邮件，并查找 .edb 与 .stm 文件与 MAPI 邮件的校验和。

    • .stm 文件（非 MAPI 内容） 此文件包含与本机 Internet 内容一起传输的邮件。

    由于通常是随机访问这两个文件的任一类型，因此，这两种文件类型可以位于同一个磁盘卷中。但是，一定不要将 .edb 和 .stm 文件置于事务日志所在的驱动器。此外，由于必须避免包含数据库文件的驱动器出现性能瓶颈，因此建议您根据每个存储组将这些文件置于专用驱动器。

  • SMTP 目录的位置 SMTP 队列存储 SMTP 邮件，直到 Exchange 将这些邮件写入数据库（邮箱存储或公用文件夹存储）或者将它们发送到其他服务器或连接器。通常，SMTP 队列随机排列，因此使用较少的 I/O。如果 SMTP 目录位于由下列任一项共享的驱动器中，则 Exchange Server 分析工具将显示警告：

    • 任何其他 Exchange 数据文件

    • TEMP 目录或 TMP 目录

    • 页面文件

    • 系统驱动器

    如果 SMTP 目录没有磁盘瓶颈，则可以安全地忽略此警告。但是，如果此驱动器的通信量较高并出现性能瓶颈，则请考虑将 SMTP 目录移至它自己的驱动器或者增加宿主 SMTP 目录的驱动器的容量。

  • 页面文件的位置 页面文件用作物理内存的扩展。具体地说，页面文件是系统存储未使用或稍后将需要使用的页面的位置。页面文件始终处于使用状态，具有足够可用内存的服务器甚至也可以使用它。出现这种情况的原因是操作系统尝试仅存储用于操作的必要页面和足够的可用空间。例如，仅在启动时使用的印刷工具可能会将它的一些内存分页到磁盘，并且如果不使用这些内存，则永远不会恢复它们。

    在大量使用物理内存的服务器中，请确保尽快执行所有对页面文件的访问。建议在页面文件的专用驱动器上再创建一个页面文件。

详细信息

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关设计存储体系结构的最佳实践的详细信息，请参阅"Best Practices Common to Multiple Architectures"（多种体系结构通用的最佳实践） (http://go.microsoft.com/fwlink/?LinkId=72988).

  • 有关磁盘大小调整、延迟和 I/O 速率的详细信息，请参阅"How to Calculate Your Disk I/O Requirements"（如何计算磁盘 I/O 要求）(http://go.microsoft.com/fwlink/?linkid=69747)。


Exchange Store TCP/IP 端口已被手动覆盖
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-03-21

Microsoft® Exchange Server 分析工具将读取以下注册表项，以确定 Exchange 存储接口的端口值是否已被手动覆盖：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

如果 Exchange Server 分析工具发现 TCP/IP Port 存在并已配置，则会显示非默认配置消息。

配置该值的最常见理由是为了使 MAPI 客户端能够连接到在防火墙另一侧的 Exchange 服务器。该方案涉及打开防火墙上的多个端口，以使 Microsoft Office Outlook® 2003 或 Outlook 2007 客户端能够使用 MAPI 连接到 Exchange 服务器（通常通过 Internet）。这是一个支持的配置。有关将 MAPI 客户端配置为通过防火墙连接到 Exchange 的详细信息，请参阅 Microsoft 知识库文章 270836"Exchange 2000 和 Exchange 2003 静态端口映射"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)。但是，如果使用的不是此方案，应删除该注册表项。

如果要在 MAPI 模式下使用 Outlook 通过 Internet 连接到 Exchange 服务器，则建议的部署是使用 RPC over HTTP 功能，可以在 Microsoft Windows Server™ 2003、Exchange Server 2003、Outlook 2003、Exchange Server 2007、Outlook 2007 和 Microsoft Windows® XP Professional 中找到该功能。MAPI 模式以前称为"公司"或"工作组"模式。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

删除 TCP/IP Port 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 删除名为 TCP/IP Port 的注册表值。

  4. 关闭注册表编辑器，然后重新启动 Microsoft Exchange 信息存储服务。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

部署 RPC over HTTPS

  1. 查阅"Exchange Server 2003 RPC over HTTP Deployment Scenarios"（Exchange Server 2003 RPC over HTTP 部署方案）(http://go.microsoft.com/fwlink/?linkid=47577)。

  2. 查看知识库文章 833401"如何在一台服务器上的 Exchange Server 2003 中配置 RPC over HTTP"(http://support.microsoft.com/kb/833401/zh-cn)。

  3. 查看知识库文章 827330"How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)。

  4. 查看 Microsoft 支持 Web 广播"Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)。


Exchange 存储 TCP/IP 端口低于 5000
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2006-01-11

Microsoft? Exchange Server 分析工具读取以下注册表项，以确定 Exchange 存储的 TCP/IP Port 设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

如果 Exchange Server 分析工具发现 TCP/IP Port 的值设置为低于 5000（十进制），则显示警告。

如果必须将 TCP/IP Port 设置设为静态值，则建议将其设置为等于或大于 5000 的数值。如果设置的值小于 5000，则可能会导致 Exchange Server 停止侦听该端口。Exchange Server 将保持这种状态，直到重新启动服务为止（要重新启动的服务取决于已硬编码的 Exchange 组件）。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

设置 TCP/IP 端口注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 双击 TCP/IP Port 注册表项，然后将"数值数据"字段设置为刚好大于 5000 的整数（十进制）。

  4. 关闭注册表编辑器。

  5. 重新启动 Microsoft Exchange Information Store 服务，以使此更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986，"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关端口设置的详细信息，请参阅知识库文章 270836，"Exchange 2000 和 Exchange 2003 静态端口映射"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)。


Exchange 事务日志正被写入非 NTFS 分区
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-02-27

错误消息

简介

Microsoft Exchange 分析工具查询 Win32_Directory Microsoft Windows Management Instrumentation (WMI) 类，以确定 Exchange 事务日志文件路径的 FSName 关键字的值。如果 Exchange Server 分析工具确定 FSName 关键字的值不等于 NTFS，则会显示错误。

Microsoft 不支持将 Exchange 数据文件存储在非 NTFS 卷上。Exchange 数据文件包括所有下列文件：

  • .edb 文件

  • .stm 文件

  • .log 文件

  • .dat 文件

  • .eml 文件

如果遇到该错误，则必须将事务日志移动到 NTFS 驱动器上的文件夹中。或者，如果存储事务日志目录的驱动器是 FAT 格式的驱动器，可使用 convert.exe 命令行工具将驱动器转换为 NTFS 格式。

移动 Exchange 2000 Server 或 Exchange Server 2003 上的事务日志

  1. 打开 Exchange 系统管理器。

  2. 展开"管理组"，展开您的管理组，再展开"服务器"，用鼠标右键单击您的存储组，再单击"属性"。

  3. 在"常规"选项卡的"事务日志位置"下，单击"浏览"。

  4. 输入日志文件的新位置的路径，再单击"确定"。

  5. 单击"确定"。

在 Exchange Server 2007 中移动 Exchange 存储组事务日志文件的位置

  1. 按照核心 Exchange Server 2007 文档"How to Set or Change the Location of Storage Group Log Files"（如何设置或更改存储组日志文件的位置）(http://go.microsoft.com/fwlink/?LinkID=80702) 中的指导进行操作。

作为上述过程的可替代方案，如果用于存储文件的驱动器被格式化为 FAT 驱动器，那么，可以使用 convert.exe 命令行工具将该驱动器转换为 NTFS。有关使用 convert.exe 命令行工具将 FAT 分区转换为 NTFS 分区的信息，请参阅 Microsoft 知识库文章 214579"How to Use Convert.exe to Convert a Partition to the NTFS File System"（如何使用 Convert.exe 将分区转换为 NTFS 文件系统）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=214579)。


Exchange 事务日志被写入压缩文件夹
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-05

Microsoft® Exchange Server 分析工具查询 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 类，以确定包含 Exchange 信息存储事务日志的文件夹的 Compressed 关键字的值。如果该文件夹的 Compressed 的值设置为 True，则会显示错误。

邮件传递到 Exchange 时，首先将它写入事务日志，然后将它提交到存储，并进行传递。在 Exchange 2000 Server 或 Exchange Server 2003 计算机上，事务日志被写入下列默认位置：

<drive> :\Program Files\Exchsrvr\mdbdata

在 Exchange Server 2007 计算机上，事务日志被写入到下列默认位置：

<drive> :\Program Files\Microsoft\Exchange Server\Mailbox\<Storage Group Name>

Microsoft 不支持将 Exchange 数据文件存储在 NTFS 压缩卷上。如果将 Exchange 数据文件存储在压缩卷上，则额外的开销会极大地影响 Exchange 的性能。此外，信息存储数据库在达到某个大小（大约 4 GB）之后，则可能无法装入，或会被损坏。

Exchange 数据文件包括下列所有文件：

  • .edb 文件

  • .stm 文件

  • .log 文件

  • .dat 文件

  • .eml 文件

  • .chk 文件

由可扩展存储引擎 (ESE) 管理的文件的设计初衷是不能存储在压缩驱动器上。ESE 依赖于扇区独立性来进行基于日志的恢复，而压缩文件会使扇区独立性无效。如果卷驻留了 ESE 数据库或驻留了使用提前写入日志记录方式的任何数据库，则不应当打开该卷的压缩功能。

在 Exchange 2000 Server Service Pack 3 之前，允许经过压缩的信息存储数据库装入。但是，可能对已使用 NTFS 压缩功能进行压缩的任何 Exchange 2000 Server 信息存储数据库或信息存储日志造成破坏。

如果使用 Exchange 2000 Server Service Pack 3，则将自动对 128 MB 或更小的压缩信息存储数据库文件进行解压缩。数据库文件增长到大于 128 MB 时，数据库将无法装入，并在应用程序日志中生成错误消息。Exchange 2000 Server Service Pack 3 禁止装入大于 128 MB 的压缩数据库。

关闭给定文件夹的压缩

  1. 右键单击想要关闭文件压缩的文件夹，再单击"属性"。

  2. 在"常规"选项卡上，单击"高级"。

  3. 在"高级属性"对话框中，清除"压缩内容以便节省磁盘空间"复选框，再单击"确定"。

移动 Exchange 2000 Server 或 Exchange Server 2003 上的事务日志

  1. 打开 Exchange 系统管理器。

  2. 展开"管理组"，再展开您的管理组，再展开"服务器"，右键单击您的存储组，再单击"属性"。

  3. 在"常规"选项卡的"事务日志位置"下，单击"浏览"。

  4. 输入日志文件的新位置的路径，再单击"确定"。

  5. 单击"确定"。

在 Exchange Server 2007 中移动 Exchange 存储组事务日志文件的位置

  1. 按照核心 Exchange Server 2007 文档"How to Set or Change the Location of Storage Group Log Files"（如何设置或更改存储组日志文件的位置）(http://go.microsoft.com/fwlink/?LinkId=80702) 中的指导进行操作。

有关在 Exchange Server 2003 上移动日志文件的详细信息，请参阅 Microsoft 知识库文章 821915"如何在 Exchange Server 2003 中移动 Exchange 数据库和日志"(http://support.microsoft.com/kb/821915/zh-cn)。

有关在 Exchange 2000 Server 上移动日志文件的详细信息，请参阅知识库文章 239944"How to Move the Transaction or System Logs to Another Location"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239944)。


Exchange 事务日志被写入加密文件夹
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-02-27

Microsoft Exchange 分析工具查询 Win32_Directory Microsoft Windows Management Instrumentation (WMI) 类，以确定包含信息存储事务日志的文件夹的 Encrypted 关键字的值。如果 Exchange 分析工具发现 Encrypted 的值设置为 True，则显示错误。

邮件传递到 Exchange 时，首先将被写入事务日志，然后将被提交到存储，并进行传递。在 Exchange 2000 Server 或 Exchange Server 2003 计算机上，事务日志被写入下列默认位置：

<drive> :\Program Files\Exchsrvr\mdbdata

在 Exchange Server 2007 计算机上，事务日志被写入到下列默认位置：

<drive> :\Program Files\Microsoft\Exchange Server\Mailbox\<Storage Group Name>

Microsoft 不支持在以加密文件系统 (EFS) 方式加密的卷上存储 Exchange 数据文件。如果将 Exchange 数据文件存储在加密卷上，则额外的开销会极大地影响 Exchange Server 性能。Exchange 数据文件包括所有下列文件：

  • .edb 文件

  • .stm 文件

  • .log 文件

  • .dat 文件

  • .eml 文件

  • .chk 文件

为了确保 Exchange 数据文件的安全，建议您禁止对 Exchange 计算机的未经授权的访问，并使用 S/MIME 邮件格式加密邮件数据。

若要解决该错误，必须关闭正在写入事务日志的文件夹的文件加密功能，或将事务日志移动到未启用加密的文件夹。

关闭指定文件夹的文件加密功能

  1. 用鼠标右键单击想要关闭文件加密的文件夹，再单击"属性"。

  2. 在"常规"选项卡上，单击"高级"。

  3. 在"高级属性"对话框中，清除"加密内容以便保护数据"复选框，再单击"确定"。

移动 Exchange 2000 Server 或 Exchange Server 2003 上的事务日志

  1. 打开 Exchange 系统管理器。

  2. 展开"管理组"，再展开您的管理组，再展开"服务器"，用鼠标右键单击您的存储组，再单击"属性"。

  3. 在"常规"选项卡的"事务日志位置"下，单击"浏览"。

  4. 输入日志文件的新位置的路径，再单击"确定"。

  5. 单击"确定"。

在 Exchange Server 2007 中移动 Exchange 存储组事务日志文件的位置

  1. 按照核心 Exchange Server 2007 文档"How to Set or Change the Location of Storage Group Log Files"（如何设置或更改存储组日志文件的位置）(http://go.microsoft.com/fwlink/?LinkID=80702) 中的指导进行操作。

有关移动日志文件的详细信息，请参阅 Microsoft 知识库文章 821915"如何在 Exchange Server 2003 中移动 Exchange 数据库和日志"(http://support.microsoft.com/kb/821915/zh-cn)。

有关 Exchange Server 数据文件和 EFS 的详细信息，请参阅 Microsoft 知识库文章 834638"有关在 Exchange Server 中的加密卷上存储数据文件的信息"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638)。

有关在 Microsoft Exchange Server 2003 中如何保护邮件安全的信息，请参阅"Exchange Server 2003 邮件安全指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=2305405C-FAF1-488A-A856-AD467BB59B26&DisplayLang=zh-cn)。


扩展 ESE 性能计数器已启用
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Exchange 服务器的性能计数器库中是否包括可扩展存储引擎 (ESE) 扩展计数器：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ESE\Performance\Show Advanced Counters

如果 Exchange Server 分析工具发现 Show Advanced Counters 注册表项的数据数值为 1，则 Exchange Server 分析工具将显示非默认配置消息。

Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
禁用扩展 ESE 性能计数器

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 在注册表中删除 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ESE\Performance 注册表项下的 Show Advanced Counters 值。

  3. 关闭注册表编辑器。

  4. 重新启动性能监视器，以应用更改。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


扩展存储性能计数器已启用
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Mdbperfx.dll 是否存在于 Exchange 服务器的性能计数器库中：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\Performance

如果 Exchange Server 分析工具发现 Library 的值包含字符串"mdbperfx.dll"，则 Exchange Server 分析工具将显示非默认配置消息。

Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。

DLL Mdbperf.dll 包含默认的存储性能计数器集。DLL Mdbperfx.dll 包含相同的默认存储性能计数器集，还包含扩展的存储性能计数器集。

默认情况下，Library 的数值数据包含 DLL Mdbperf.dll。默认情况下，Library 的数值数据不包含 DLL Mdbperfx.dll。下表列出了 DLL Mdbperfx.dll 包含的扩展存储性能计数器。

计数器 | 目标
FXGetBufferRopsCalled | FXGetBuffer 远程过程调用 (RPC) 操作的总数
FXGetBufferRopsCalledPerSec | 每秒的 FXGetBuffer RPC 操作数
FXGetBufferRopsAcceptedPerSec | 每秒接受的 FXGetBuffer RPC 操作数
FXGetBufferRopsDenied | 拒绝的 FXGetBuffer RPC 操作总数
FXGetBufferRopsDeniedPerSec | 每秒拒绝的 FXGetBuffer RPC 操作数
FXGetBufferCurrentCallerCount | 并发的 FXGetBuffer RPC 操作数
FXGetBufferCurrentUsersExecuting | 正在运行的并发 FXGetBuffer RPC 操作数
Messages Scanned as MIME | 由病毒扫描程序作为 MIME 处理的顶级邮件总数
Messages Scanned as MIME/sec | 由病毒扫描程序作为 MIME 处理顶级邮件的速率
Messages Scanned as MAPI | 由病毒扫描程序作为 MAPI 处理的顶级邮件总数
Messages Scanned as MAPI/sec | 由病毒扫描程序作为 MAPI 处理顶级邮件的速率
Bytes Read | 病毒扫描程序读取的总字节数
Bytes Written | 病毒扫描程序写入的总字节数
Queue Length (Low Priority) | 排队等待病毒扫描的尚未处理的低优先级请求的当前数目。
Threads | 线程池中用于病毒扫描的线程的当前数目。此数字不包含用于后台扫描的线程数。
Checks Satisfied by MFT Stamp | 满足 Message Folder 表中标记需求的病毒扫描检查的次数
Checks Satisfied by MFT Stamp/sec | 满足 Message Folder 表中标记需求的病毒扫描检查的速率
Checks Satisfied by Instance Stamp | 满足实例标记需求的病毒扫描检查的次数
Checks Satisfied by Instance Stamp/sec | 满足主实例标记需求的病毒扫描检查的次数
Checks Satisfied by Master Instance Stamp/sec | 满足主实例标记需求的病毒扫描检查的速率
Checks Not Satisfied | 不满足任何标记需求的病毒扫描检查的次数
Checks Not Satisfied/sec | 不满足任何标记需求的病毒扫描检查的速率
Checks Blocked | 为等待病毒扫描完成而阻止处理的次数
Checks Blocked/sec | 为等待病毒扫描完成而阻止处理的速率
Check Timeouts | 因等待完成病毒扫描而操作超时的次数
Check Timeouts/sec | 因等待完成病毒扫描而操作超时的速率
重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
只启用默认的存储性能计数器

  1. 启动注册表编辑器，例如 Regedit.exe 或 Regedt32.exe。

  2. 在以下注册表项下找到 Library 值：

    HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\Performance

  3. 在"编辑"菜单上，单击"修改"。

  4. 在"数据数值"框中，将值从 c:\Program Files\Exchsrvr\bin\mdbperfx.dll 更改为 c:\Program Files\exchsrvr\bin\mdbperf.dll。

  5. 单击"确定"，然后关闭注册表编辑器。

  6. 重新启动性能监视器，以应用更改。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关收集 Exchange 存储的性能数据的详细信息，请参阅知识库文章 821912"How to Collect Diagnostic Data to Help Troubleshoot Information Store Issues"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821912)。


FXGetBuffer Backoff Constant 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 FXGetBuffer Backoff Constant 值是否已创建：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server 分析工具发现 FXGetBuffer Backoff Constant 值已在 ParametersSystem 注册表项下创建，则 Exchange Server 分析工具将显示非默认配置消息。

可以使用 FXGetBuffer Backoff Constant 值控制同时与 Exchange Server 2003 服务器进行同步的 Microsoft Office Outlook® 2003 客户端数。设置 FXGetBuffer Backoff Constant 值，配置 Outlook 客户端在再次尝试进行同步之前等待的时间。FXGetBuffer Backoff Constant 值的默认值为 500 毫秒。

Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。但是，如果要还原默认配置，可以删除 FXGetBuffer Backoff Constant 注册表项。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
还原默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 删除 FXGetBuffer Backoff Constant 值。

  4. 关闭注册表编辑器。

Microsoft Exchange 信息存储服务可以在几分钟内检测到更改。不需要重新启动计算机。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关通过设置注册表项来控制可以与 Exchange Server 2003 进行同步的 Outlook 客户端数的详细信息，请参阅知识库文章 818484"Registry Values and Counters That You Can Use to Configure and Monitor Outlook Client Synchronization"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484)。


FXGetBuffer Retry Count 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 FXGetBuffer Retry Count 值是否已创建：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server 分析工具发现 FXGetBuffer Retry Count 值已在 ParametersSystem 注册表项下创建，则 Exchange Server 分析工具将显示非默认配置消息。

可以使用 FXGetBuffer Retry Count 值控制同时与 Exchange Server 2003 服务器进行同步的 Microsoft Office Outlook® 2003 客户端数。设置 FXGetBuffer Retry Count 值，以配置 Outlook 客户端在获得访问权限之前可以尝试同步的次数。默认值为 10。

Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。但是，如果要还原默认配置，可以删除 FXGetBuffer Retry Count 注册表项。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
还原默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 删除 FXGetBuffer Retry Count 值。

  4. 关闭注册表编辑器。

Microsoft Exchange 信息存储服务可以在几分钟内检测到更改。不需要重新启动计算机。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关通过设置注册表项来控制可以与 Exchange Server 2003 进行同步的 Outlook 客户端数的详细信息，请参阅知识库文章 818484"Registry Values and Counters That You Can Use to Configure and Monitor Outlook Client Synchronization"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484)。


Ignore Bad Oof Rule 注册表参数已设置
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具读取 Exchange Server 计算机的注册表，以检查是否存在 Ignore Bad Oof Rule 注册表项。该注册表值出现在以下位置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

如果 Exchange Server 分析工具发现 Ignore Bad Oof Rule 注册表项已存在并配置为 1 或更大的值，则显示非默认配置消息。

Ignore Bad Oof Rule 注册表项是 Exchange 2000 Server、Exchange Server 2003 和 Exchange Server 2007 中的一个配置设置，它是专门为了与 Microsoft 知识库文章 828875"You cannot move an Exchange mailbox after you use the Exmerge.exe utility"（在使用 Exmerge.exe 实用程序后，无法移动 Exchange 邮箱）(http://go.microsoft.com/fwlink/?LinkID=3052&kbid=828875) 中描述的修补程序配合使用而设计的。

使用 Microsoft Exchange 邮箱合并程序 (Exmerge.exe) 将邮件和其他项从一个邮箱存储上的邮箱移动到另一个邮箱存储上的邮箱中时，随后再移动第二个邮箱的尝试可能会失败。发生这种情况是因为，该邮箱的外出 (OOF) 规则不正确。如果需要，可以使用此处简要介绍的过程将其恢复为默认配置。

重要信息：
本文包含有关如何编辑注册表的信息。在编辑注册表之前，请确保已了解在出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原为默认配置

  1. 打开注册表编辑器，例如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. 在右侧窗格中，找到并删除 Ignore Bad Oof Rule 值。

  4. 关闭注册表编辑器，并重新启动"Microsoft Exchange 信息存储"服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


Ignore Zombie Users 注册表参数已设置
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具检查 Exchange Server 计算机的注册表，以查看是否存在 Ignore Zombie users 注册表项。该注册表值位于：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server 分析工具发现 Ignore Zombie users 注册表项存在并配置为大于或等于 1 的值，则显示非默认配置消息。

在包含 Exchange Server 5.5 和 Exchange 2000 Server 的混合模式 Exchange Server 组织中，或者在以前混合的环境中，如果满足下列条件，则可能出现问题：

  • 将邮箱和公用文件夹的访问控制列表 (ACL) 从 Exchange Server 5.5 升级到 Exchange 2000 Server。

  • ACL 包含未在 Active Directory® 目录服务中表示的用户帐户。

这些未用的访问控制条目 (ACE) 也称为"僵用户"。从 2003 年 3 月版 Exchange 2000 Server Post-Service Pack 3 更新汇总开始，处理僵用户的默认行为已更改。可以通过使用 Ignore Zombie users 注册表项来控制此行为。

Ignore Zombie users 注册表值可以用在安装了 Exchange 2000 Server Service Pack 3 或更高版本的服务器上。应慎用此注册表项，并且只有当您确信僵用户不是由于 Active Directory 连接器 (ADC) 复制问题（如延迟）而产生时才使用。此注册表值会导致 Exchange Server 忽略僵用户并将其从邮箱或公用文件夹的 ACL 中删除。如果用户有效但在 ACL 升级后未出现在 Active Directory 中，则说明用户被删除，您必须稍后手动将该用户添加到每个 ACL 中。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

回复到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右侧窗格中，找到并删除 Ignore Zombie users 值。

  4. 关闭注册表编辑器，然后重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请阅读 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关使用 Ignore Zombie Users 注册表项的详细信息，请参阅下列知识库文章：

  • 812963"Using the Ignore Zombie Users Registry Key"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812963)

  • 324323"XADM:在访问控制列表转换期间跳过 Active Directory 中未表示的用户帐户"(http://support.microsoft.com/kb/324323/zh-cn)


IMAIL 异常处理已被手动禁用
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-17

Microsoft® Exchange Server 分析工具检查以下注册表项，以确定 ExceptionHandling 注册表值的设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

如果 Exchange Server 分析工具发现 ExceptionHandling 注册表值配置为 0，则会显示警告。

在 ExchangeServer 中，IMAIL 异常处理是默认打开的，并且不能通过用户界面将它关闭。但是，可以通过使用注册表来关闭 IMAIL 异常处理。

Microsoft 建议将 IMAIL 异常处理保留为启用，除非您在对问题进行故障排除。例如，如果您有基于错误的多用途 Internet 邮件扩展 (MIME) 或 MAPI 内容触发事件的自定义应用程序，可以关闭 IMAIL 异常处理。Microsoft 建议仅在 Microsoft 产品支持服务支持专家的建议和指导下关闭 IMAIL 异常处理。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent.

  3. 双击 ExceptionHandling：

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 ExceptionHandling 注册表值的详细信息，请参阅知识库文章 832174"There is no option to turn off IMAIL exception handling in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832174)。


信息存储服务配置为与台式机交互
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Microsoft Exchange 信息存储 (MSExchangeIS) 服务的 DesktopInteract 属性值。如果 Exchange Server 分析工具发现 Microsoft Exchange 信息存储服务配置为与台式机交互，则 Exchange Server 分析工具将显示错误。

此配置只应当在 Microsoft 产品支持服务的指导下使用。除非 Microsoft 产品支持服务指导您在此配置中运行 Microsoft Exchange 信息存储服务，否则，建议重新配置 Microsoft Exchange 信息存储服务的属性，使其不会与台式机交互。

配置 Exchange 信息存储服务帐户

  1. 打开"服务"MMC 管理单元。

  2. 找到并停止 Microsoft Exchange Information Store 服务。

  3. 双击 Microsoft Exchange Information Store 服务。

  4. 在"Microsoft Exchange Information Store 属性"页的"登录"选项卡上，在"登录作为"下选择"本地系统帐户"。

  5. 清除"允许服务与台式机交互"复选框，再单击"应用"。

  6. 在"服务状态"下，单击"启动"，再单击"确定"。

  7. 关闭"服务"管理单元。

有关正确的 Exchange 服务配置的详细信息，请参阅 Microsoft 知识库文章 239762"Exchange Services Run Under LocalSystem"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)。


增加邮箱存储的最大数据库大小
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具查询 CIM_DataFile Microsoft Windows® Management Instrumentation (WMI) 类，以确定下列信息：

  • Exchange 数据库文件的完整路径。

  • 邮箱存储的当前大小。

Exchange Server 分析工具还查询 Win32_OperatingSystem WMI 类，以确定其他信息：

  • Exchange 服务器上运行的 Windows 操作系统的版本。

  • 安装的 Exchange Server 的版本。

  • 安装的 Exchange Server 的版本。

  • Exchange Server 的 Service Pack 版本级别。

最后，Exchange Server 分析工具还读取以下注册表项，以确定是否已设置 Database Size in Gb 值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • 服务器运行的是 Exchange Server 2003。

  • 服务已安装了 Exchange Server 2003 Service Pack 2。

  • Exchange Server 数据库大小大于 16 GB。

  • 尚未设置 Database Size in Gb 注册表值。

此错误指示已识别的 Exchange 数据库接近其大小限制。Exchange Server 2003 Service Pack 2 将数据库存储限制从 16 GB 提高到 75 GB。但是，若要使用新的限制，必须在 Exchange Server 上手动添加 Database Size in Gb 注册表值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
若要通过添加数据库大小 (GB) 注册表值更正此错误，请执行下列操作：

  1. 在运行 Exchange Server 的计算机上，打开 Regedit.exe 或 RegEdt32.exe 等注册表编辑器。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. 右键单击 MailboxStoreGUID，指向"新建"，再单击"DWORD 值"。

  4. 键入新值名称 Database Size Limit in Gb。

  5. 双击 Database Size Limit in Gb。在"数值数据"中，为最大数据库大小键入一个合适的值 (GB)。单击"确定"。

  6. 右键单击 MailboxStoreGUID，指向"新建"，再单击"DWORD 值"。

  7. 键入新值名称 Database Size Buffer in Percentage。

  8. 双击 Database Size Buffer in Percentage。在"数值数据"中，键入 1 到 100 之间的一个值，指定何时记录事件，以警告即将达到最大数据库大小。单击"确定"。

    注意：
    如果默认值为 10，则在达到最大数据库大小之前尚有 10% 的容量时，系统将记录警告事件。

  9. 右键单击 MailboxStoreGUID，指向"新建"，再单击"DWORD 值"。

  10. 键入新值名称 Database Size Check Start Time in Hours From Midnight。

  11. 双击 Database Size Check Start Time in Hours From Midnight。在"数值数据"中，键入 0 到 23 之间的一个值，指定何时需要 Exchange 查看数据库大小。单击"确定"。

    注意：
    如果默认值为 5，则 Exchange Server 在凌晨 5 点 (05:00) 查看数据库大小。

  12. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关如何配置和管理 Exchange Server 数据库大小限制的详细信息，请参阅"Database Size Limit Configuration and Management"（英文）(http://go.microsoft.com/fwlink/?LinkId=57029)。

有关 Exchange Server 2003 Standard Edition 和 Exchange 2000 Server Standard Edition 的最大数据库大小的信息，请参阅知识库文章 828070"当邮箱存储数据库达到 16 GB 限制时，Exchange Server 邮箱存储无法装入"(http://support.microsoft.com/?kbid=828070)。

有关 Exchange Server 2003 SP2 的详细信息，请参阅 Exchange Server 2003 Service Pack 2 网站"Why Try Service Pack 2 for Exchange Server 2003?"（英文）(http://go.microsoft.com/fwlink/?LinkId=52073)。


增加公用文件夹存储的最大数据库大小
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具查询 CIM_DataFile Microsoft Windows® Management Instrumentation (WMI) 类，以确定下列信息：

  • Exchange Server 数据库文件的完整路径。

  • 公用文件夹存储的当前大小。

Exchange Server 分析工具还查询 Win32_OperatingSystem WMI 类，以确定其他信息：

  • Exchange 服务器上运行的 Windows 操作系统的版本。

  • 安装的 Exchange Server 的版本 (Version)。

  • 安装的 Exchange Server 的版本 (Edition)。

  • Exchange Server 的 Service Pack 版本级别。

最后，Exchange Server 分析工具还读取以下注册表项，以确定是否已设置 Database Size in Gb 值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicStoreGUID>

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • 服务器运行的是 Exchange Server 2003。

  • 服务已安装了 Exchange Server 2003 Service Pack 2。

  • Exchange 数据库大小大于 16 GB。

  • 尚未设置 Database Size in Gb 注册表值。

此错误指示已识别的 Exchange Server 数据库接近其大小限制。Exchange Server 2003 Service Pack 2 将数据库存储限制从 16 GB 提高到 75 GB。但是，若要使用新的限制，必须手动添加有关 Exchange Server 的 Database Size in Gb 注册表值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
若要通过添加数据库大小 (GB) 注册表值更正此错误，请执行下列操作：

  1. 在运行 Exchange Server 的计算机上，打开 Regedit.exe 或 RegEdt32.exe 等注册表编辑器。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicStoreGUID>

  3. 右键单击 PublicStoreGUID，指向"新建"，再单击"DWORD 值"。

  4. 键入新值名称 Database Size Limit in Gb。

  5. 双击 Database Size Limit in Gb。在"数值数据"中，为最大数据库大小键入一个合适的值 (GB)。单击"确定"。

  6. 右键单击 PublicStoreGUID，指向"新建"，再单击"DWORD 值"。

  7. 键入新值名称 Database Size Buffer in Percentage。

  8. 双击 Database Size Buffer in Percentage。在"数值数据"中，键入 1 到 100 之间的一个值，指定何时记录事件，以警告即将达到最大数据库大小。单击"确定"。

    注意：
    如果默认值为 10，则在达到最大数据库大小之前尚有 10% 的容量时，系统将记录警告事件。

  9. 右键单击 PublicStoreGUID，指向"新建"，再单击"DWORD 值"。

  10. 键入新值名称 Database Size Check Start Time in Hours From Midnight。

  11. 双击 Database Size Check Start Time in Hours From Midnight。在"数值数据"中，键入 0 到 23 之间的一个值，指定何时需要 Exchange 查看数据库大小。单击"确定"。

    注意：
    如果默认值为 5，则 Exchange Server 在凌晨 5 点 (05:00) 查看数据库大小。

  12. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关如何配置和管理 Exchange 数据库大小限制的详细信息，请参阅"Database Size Limit Configuration and Management"（英文）(http://go.microsoft.com/fwlink/?LinkId=57029)。

有关 Exchange Server 2003 Standard Edition 和 Exchange 2000 Server Standard Edition 的最大数据库大小的信息，请参阅知识库文章 828070"当邮箱存储数据库达到 16 GB 限制时，Exchange Server 邮箱存储无法装入"(http://support.microsoft.com/?kbid=828070)。

有关 Exchange Server 2003 SP2 的详细信息，请参阅 Exchange Server 2003 Service Pack 2 网站"Why Try Service Pack 2 for Exchange Server 2003?"（英文）(http://go.microsoft.com/fwlink/?LinkId=52073)。


增加事务日志的日志缓冲区设置
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具已确定您的服务器上日志缓冲区的数量太少。此工具检测到服务器的 Database（信息存储实例）\Log Record Stalls/sec 的值大于每秒中止 10 次。大于 10 的值指示有一个写入事务日志中的备份。由于事务日志驱动器超过了其吞吐容量，或者日志缓冲区数设置过低，因此可能出现上述情况。

日志写入 I/O 是连续的并通过单一线程实现，所以日志 I/O 延迟通常成为系统的瓶颈。首先将日志 I/O 写入日志缓冲区，然后通过非惰性提交或容量提交清除缓冲区。非惰性提交意味着立即将日志缓冲区写入磁盘。容量提交意味着在日志缓冲区填满时，将其写入磁盘。

增加日志缓冲区的大小将减小容量刷新的频率，增加日志写入的大小并进一步缩短整个日志写入延迟时间。缩短日志 I/O 写入的延迟时间是改善 Exchange 部署的性能/可伸缩性的重要方法。

一般建议针对 Exchange Server 2003，将缓冲区的大小增加到最大 9,000；针对 Exchange 2000 Server，将缓冲区的大小增加到最大 512。

警告：
在使用 ADSI Edit、LDP 工具或其他 LDAP 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能要求您重新安装 Microsoft Windows Server™ 2003 或 Exchange Server 2003，或者同时重新安装这两个软件。修改 Active Directory 对象的属性的风险由您自己承担。
更正此警告

  1. 启动 ADSI Edit。

  2. 双击 Configuration 容器，依次展开 CN=Services、CN=Microsoft Exchange 和 CN=ExchangeOrganizationName。

  3. 依次展开 CN=Administrative Groups、CN=AdministrativeGroupName 和 CN=Servers。

  4. 展开 CN=ExchangeServerName，再展开 CN=InformationStore，用右键单击 CN=Storage Group Name，再单击"属性"。

  5. 在 Select a property to view 框中，单击 msExchESEParamLogBuffers。

  6. 在 Edit Attribute 框中，针对您的 Exchange 版本为 msExchESEParamLogBuffers 键入适当的值，再单击 Set。

    注意：
    对于运行 Exchange 2000 Server、Exchange 2000 Server Service Pack 1 (SP1)、Exchange 2000 Server SP2 或 Exchange 2000 SP3 的计算机，将值设置为 512。对于运行 Exchange Server 2003 或 Exchange Server 2003 SP1 的原始版本的计算机，将值设置为 9,000。

  7. 单击 Apply，再单击 OK。

详细信息

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关使用日志缓冲功能的详细信息，请参阅 Microsoft 知识库文章"ESE log buffers that are set too low can cause the Microsoft Exchange Information Store service to stop responding"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328466)。


Initial Memory Percentage 已设置
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-05

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已设置 Initial Memory Percentage 值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server 分析工具发现 Initial Memory Percentage 值存在，且其值大于 0，则会显示非默认配置消息。

引入 Initial Memory Percentage 注册表设置这一机制是为了精确地将分配给 Exchange 信息存储的初始内存量调整到 Exchange 服务器中总物理内存的百分之十。通过从该初始分配开始，然后再逐渐增加，将不会经常产生虚拟内存碎片。不能随意设置该注册表值，只能在 Microsoft 产品支持服务的建议和指导下对其进行设置。

Exchange Server 2003 或更高版本包括对 Microsoft Windows® 2000 Advanced Server 和 Windows Server™ 2003 中特殊启动开关的支持（这有助于减少虚拟内存碎片），此外还进行了其他更改以防止 Exchange Server 群集中产生虚拟内存碎片。因此，Exchange Server 2003 或更高版本中不再需要 Initial Memory Percentage 注册表值。

Initial Memory Percentage 注册表值仅在运行 Exchange 2000 Server 的计算机上有效。Exchange Server 2003 和 Exchange Server 2007 将忽略存在的此注册表值，并且此值不起作用。因此，在将 Exchange Server 从 Exchange 2000 Server 升级到 Exchange Server 2003 时应删除此注册表项。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

删除 Initial Memory Percentage 注册表设置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右侧窗格中，删除 Initial Memory Percentage 值。

  4. 关闭注册表编缉器，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。
  • 有关使用此注册表值时已知问题的详细信息，请参阅 Microsoft 知识库文章 810883"Initial Memory Percentage" Registry Value Has No Effect"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810883)。

  • 编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


Initial Reserve Size KB 注册表项已设置
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2006-04-27

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Initial Reserve Size KB 注册表项是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

如果 Exchange Server 分析工具发现 Initial Reserve Size 注册表值存在并配置为大于 0 的值，则会显示非默认配置消息。

Initial Reserve Size KB 注册表值用于为堆空间留出额外的内存。指定的值以 KB 为单位。大多数 Exchange 服务器上的默认值都为 655360 KB（即 640 MB）。可以减小该值以增加可用空闲内存量并减少虚拟内存碎片。该值仅应当在 Microsoft 产品支持服务支持专家的建议和指导下设置。如果此注册表值是在 Microsoft 产品支持服务支持专家的建议下添加的，则此消息仅仅是信息性消息，您不需要采取更正措施。

如果确信此项的设置有错误，可以将它删除并回复到默认配置。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

回复到默认配置设置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

  3. 删除名为 Initial Reserve Size KB 的值。

  4. 关闭注册表编辑器，然后重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关解决虚拟内存碎片问题的详细信息，请参阅知识库文章"如何解决 Exchange Server 2003 和 Exchange 2000 Server 中的虚拟内存碎片问题"(http://support.microsoft.com/kb/325044/zh-cn)。


此 Exchange 数据库的 legacyExchangeDN 与 Exchange 服务器不一致
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Exchange Server 计算机上所有邮箱存储数据库的 legacyExchangeDN 属性值。如果 Exchange Server 分析工具发现有任意邮箱存储的 legacyExchangeDN 属性的值与包含该邮箱存储的 Exchange Server 计算机不一致，则显示错误。

legacyExchangeDN 不匹配可能是由于管理员在灾难恢复情况下为恢复数据库而修改 Active Directory 所导致的。若要解决该错误，必须使用 LDP (ldp.exe) 工具或 Active Directory 服务接口 (ADSI) Edit 等 Active Directory 编辑器修改 legacyExchangeDN 属性。

若要确保 legacyExchangeDN 属性是正确的，请检查驻留该数据库的服务器的 legacyExchangeDN 属性，因为作为该服务器的子对象，此数据库将有相同的 legacyExchangeDN。

还应检查该 Exchange 服务器上未生成该错误的其他数据库，因为它们应当有相同的 legacyExchangeDN。应明确还有其他几个系统对象也有该属性。如果数据库的 legacyExchangeDN 属性不匹配，则其他几个系统对象的该属性可能也不匹配。因此，如果使用 LDP 或 ADSI Edit 来更正 legacyExchangeDN 值，还必须在其他所有系统对象上执行此操作。

警告：
在使用 ADSI Edit、LDP 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。要解决这些问题，您可能需要重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003/Exchange Server 2007。修改 Active Directory 对象的属性的风险由您自己承担。

更正此错误

  1. 打开 Active Directory 编辑器，如 ADSI Edit。

  2. 展开 Configuration[DomainName]，然后展开 CN=Configuration,DC=DomainName,DC=DomainSuffix。

  3. 展开 CN=Services，再展开 CN=Microsoft Exchange。

  4. 依次展开 CN=OrganizationName、CN=Administrative Groups、CN=AdminGroupName。

  5. 依次展开 CN=Servers、CN=ServerName、CN=InformationStore。

  6. 选择 CN=StorageGroupName，然后在右侧窗格中，右键单击 legacyExchangeDN 属性不匹配的邮箱存储，再单击"属性"。

  7. 向下滚动至 legacyExchangeDN，选择该属性，再单击 Edit。

  8. 在 Value 字段中，输入正确的 legacyExchangeDN。

  9. 关闭 Active Directory 编辑器，并重新启动 Exchange Server 计算机，以使更改生效。

有关使用 ADSI Edit 创建新的 legacyExchangeDN 属性的详细信息，请参阅 Microsoft 知识库文章 273863"How to Change the LegacyExchangeDN Attribute in Native Mode with ADSI Edit"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863)。


从该 Exchange 数据库丢失 legacyExchangeDN 值
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Exchange Server 计算机上所有邮箱存储数据库的 legacyExchangeDN 属性的值。如果 Exchange Server 分析工具没有在任何邮箱存储上找到 legacyExchangeDN 属性的值，则会显示错误。

丢失 legacyExchangeDN 可能是管理员在灾难恢复情况下修改 Active Directory 以便恢复数据库而造成的。若要解决该错误，必须使用 LDP (ldp.exe) 工具或 Active Directory 服务接口 (ADSI) Edit 等 Active Directory 编辑器修改 legacyExchangeDN 属性。

为了确保 legacyExchangeDN 属性是正确的，请检查承载该数据库的服务器的 legacyExchangeDN 属性，因为作为该服务器的子对象，此数据库将有相同的 legacyExchangeDN。

还应检查该 Exchange 服务器上未生成该错误的其他数据库，因为它们应具有相同的 legacyExchangeDN。应当知道有其他几个系统对象也有该属性。如果数据库丢失了 legacyExchangeDN 属性，则可能其他几个系统对象也丢失了该属性。因此，如果使用 LDP 或 ADSI Edit 来添加新的 legacyExchangeDN 值，那么也必须在其他所有系统对象上执行该操作。

警告：
在使用 ADSI Edit、LDP 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。若要解决这些问题，您可能需要重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003/Exchange Server 2007。修改 Active Directory 对象的属性的风险由您自己承担。

更正此错误

  1. 打开 Active Directory 编辑器，例如 ADSI Edit。

  2. 展开 Configuration DomainName，展开 CN=Configuration,DC=DomainName,DC=DomainSuffix。

  3. 展开 CN=Services，再展开 CN=Microsoft Exchange。

  4. 依次展开 CN=OrganizationName、CN=Administrative Groups、CN=AdminGroupName。

  5. 依次展开 CN=Servers、CN=ServerName、CN=InformationStore。

  6. 选择 CN=StorageGroupName，然后在右侧窗格中，右键单击其 legacyExchangeDN 属性已丢失的邮箱存储，并单击"属性"。

  7. 向下滚动找到 legacyExchangeDN，选择它，并单击 Edit。

  8. 在 Value 字段中，输入正确的 legacyExchangeDN。

  9. 关闭 Active Directory 编辑器，并重新启动 Exchange Server 计算机，以使更改生效。

有关使用 ADSI Edit 创建新的 legacyExchangeDN 属性的详细信息，请参阅 Microsoft 知识库文章 273863"How to Change the LegacyExchangeDN Attribute in Native Mode with ADSI Edit"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863)。


LimitBodyParts 参数已被手动设置
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已更改邮件附件的默认限制：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent\LimitBodyParts

如果 Exchange Server 分析工具发现 LimitBodyParts 注册表项存在并已配置，则显示非默认配置消息。

由于设计和安全原因，Exchange Server 对附件（称为"正文部分"）个数的限制是不超过 250。如果邮件包含超过 250 个附件，则会生成 MAPI_E_TOO_BIG 错误。此外，Microsoft Exchange 信息存储服务在处理包含大量附件的邮件时，可能消耗额外的内存和 CPU 资源。

作为一个配置机会，系统允许管理员添加 LimitBodyParts 注册表值，并将它配置为使用大于 250 的值。在没有该项的情况下，则使用默认值 250。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

查看或更改 LimitBodyParts 注册表值

  1. 打开注册表编辑器，例如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

  3. 检查和（如果需要）更改 LimitBodyParts 值。该注册表值的可接受值是 250 和 4294967295 之间的任何整数。

  4. 如果进行了更改，请重新启动 Exchange Server 计算机，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


LimitEmbeddingDepth 参数已被手动设置
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-30

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Exchange 中的默认 MIME 头限制是否已被更改：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

如果 Exchange Server 分析工具发现已为 LimitEmbeddingDepth 设置了任何值，则会显示非默认配置消息。

Exchange 2000 Server Service Pack 3、Exchange Server 2003 和 Exchange Server 2007 在信息存储进程 (store.exe) 中包括经过更新的功能，用于定义如何处理大型或格式不规则的 MIME。添加该功能是为了进一步保护 Exchange Server，使它能够抵御由恶意的和无意识的大型和复杂 MIME 邮件所导致的拒绝服务攻击。对提交到存储的 MIME 邮件所设定的一些限制示例包括：限制收件人数、限制嵌入邮件数和限制单个 MIME 头的大小。

这些不同的 MIME 头限制的默认值是在存储进程内设置的。但是，如果通过设置注册表项定义了其中的任何一个限制，那么该注册表项将覆盖默认的 store.exe 值。如果在 MIME 邮件中超出了多种限制中的任何一个，就将向发件人发送未送达报告 (NDR)。

限制 MIME 的嵌入深度是指可以相互嵌入的 MIME 邮件数。例如，假设您收到邮件 (m1)，其中带有附加邮件 (m2)。打开附加邮件 (m2) 时，您发现该邮件 (m2) 中还附加了邮件 (m3)。因此，原始邮件 (m1) 的邮件嵌入深度是 3 个级别。默认情况下，Exchange 将允许嵌入深度级别为 100 的邮件。对于其嵌入邮件超过 100 深度级别的邮件来说，在服务器对它进行"解包"、分析并转换为 MAPI 期间，该邮件可能会消耗掉 Exchange 服务器上的所有内存。任何电子邮件客户端或服务器都几乎完全不可能会生成有如此邮件嵌入深度的邮件。而这样的邮件更有可能是恶意用户试图对邮件系统发起拒绝服务攻击的结果。

恢复为默认配置

  • 不需要执行任何操作。仅当安装了 Microsoft 知识库文章 833607"The Microsoft Exchange Information Store service uses 100 percent of the CPU resources on an Exchange 2000 Server or an Exchange Server 2003"（在 Exchange 2000 Server 或 Exchange Server 2003 上，Microsoft Exchange 信息存储服务使用 100% CPU 资源）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833607) 中介绍的修补程序后，才会显示该注册表项。该修补程序会创建 LimitEmbeddingDepth 注册表项，并将它的值设置为 10。

有关 Exchange Server Service Pack 和修补程序的详细信息，请参阅知识库文章 328839"How to apply Exchange service packs and hotfixes"（英文）(http://support.microsoft.com/kb/328839/zh-cn)。


LimitNestingLevels 参数已被手动设置
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已更改 Exchange 中默认的多用途 Internet 邮件扩展 (MIME) 邮件头限制：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

如果 Exchange Server 分析工具发现 LimitNestingLevels 已设置为任何值，则显示非默认配置消息。

邮件中的 MIME 正文部分可以是嵌套的。如果嵌套级别很高，则转换过程需要越来越多的资源，才能对整个邮件进行解码。要处理其 MIME 正文部分嵌套到 700 级的单个邮件，将需要占用多达 10 分钟的时间。如果从 Internet 接收包含嵌套的 MIME 正文部分的邮件，则 MIME 正文部分的转换过程可能导致这些邮件的传递变得很缓慢。传递邮件时，服务器将需要大量系统资源，尤其是内存。如果同时收到很多这样的邮件，则系统可能报告它正运行于虚拟内存不足的状态中。

限制 MIME 的嵌套级别是指限制可以相互嵌套的 MIME 内容类型（例如 multipart/mixed 或 multipart/alternative）的数目。大多数电子邮件客户端（包括 Microsoft Outlook® 和 Outlook Express）和电子邮件服务器所生成的邮件都包含非常少的嵌套 MIME 内容类型。例如，典型的邮件（甚至包含多个答复）在 MIME 邮件中，只能表示为一个内容类型。多个嵌套级别通常是由为特定用途而建立 MIME 邮件的自动化过程（例如，工作流应用程序）所产生的，或者是由出于消耗邮件服务器资源的特定目的而构造的恶意邮件所产生的。

除了按照内容类型强制执行嵌套级别，Exchange Server 还将使用 LimitNestingLevels 值（不管被定义为注册表值，还是定义为存储进程中的默认值）来对嵌入邮件进行强制限制。如果未定义 LimitNestingLevels 注册表值，将强制使用 30 个嵌套级别这一默认值。嵌入邮件限制是通过 LimitNestingLevels 值乘以 16 来定义的。因此，嵌入邮件数的默认值是 480。例如，如果 LimitNestingLevels 被配置为值 5，则最多可接受 80 个附件。

还原到默认配置

  • 不需要执行任何操作。Exchange Server 分析工具显示仅供参考的非默认配置。

有关与 LimitNestingLevels 注册表值相关的 Exchange 2000 Server 修复程序的详细信息，请参阅 Microsoft 知识库文章 289775"XADM:Exchange 2000 Server Experiences Memory Leaks Because of Many Embedded Messages"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=289775)。


已手动设置 LimitRecipients 参数
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Exchange 中的默认 MIME 头限制是否已被更改：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

如果 Exchange Server 分析工具发现已经为 LimitRecipients 设置了任意值，则会显示非默认配置警报。

Exchange 2000 Server Service Pack 2 (SP2) 和更高版本在存储进程 (store.exe) 中包括经过更新的功能，用于定义如何处理大型或格式不规则的 MIME。添加此功能是为了进一步防止 Exchange 成为恶意的或异常的（意外的大型且复杂的）MIME 邮件的拒绝服务攻击的目标。对提交到存储中的 MIME 邮件施加的一些限制包括收件人数限制、嵌入邮件数限制以及单个 MIME 头大小限制。在以前版本的 Exchange 中，由于允许无限大的 MIME 头进入 Exchange 存储进行处理，因此分析、索引和处理过大或过于复杂的 MIME 邮件可能消耗掉几乎所有资源（主要是 CPU）。

这些不同的 MIME 头限制的默认值是在存储进程内设置的。但是，如果通过设置注册表项定义了其中的任何一个限制，那么该注册表项将覆盖默认的 store.exe 值。当 MIME 邮件超过了不同限制中的任何一个时，将向发件人发送未送达报告 (NDR)。

如果 LimitRecipients 注册表项已设置，那么可能是在 Microsoft 产品支持服务的建议下设置的，因为该项尚未发布。同样，Microsoft 不建议更改该设置。

存储进程中的 LimitRecipients 默认值（如果无注册表项存在）为每个 MIME 邮件 65,535 个收件人。


日志缓冲区未针对包含复制磁盘存储的 Exchange Server 2003 服务器进行优化
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定下列条件是否为真：

  • 计算机正在运行 Exchange Server 2003。

  • msExchESEParamLogBuffers 的值在 0 到 8,960 之间。

Exchange Server 分析工具查询 Win32_PerfRawData_MSExchangeIS_MSExchangeIS Microsoft Windows® Management Instrumentation (WMI) 类，以确定下列条件是否为真：

  • VMLargestBlockSize 的值大于 150,000,000。

Exchange Server 分析工具确定是否正在运行下列任意服务：

  • GeoSpanService

  • SRDFService

如果符合上述所有条件，将显示错误。

可扩展存储引擎 (ESE) 使用日志缓冲区将事务保存在内存中，然后再将其提交给事务日志。如果没有足够的日志缓冲区，可能遇到事务日志驱动器上的磁盘 I/O 过多的情况，从而影响性能。

警告：
在使用 ADSI Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。
更正此错误

  1. 在 Active Directory 服务接口 (ADSI) Edit 中，双击 Configuration 容器，展开 CN=Services，再展开 CN=Microsoft Exchange，然后展开 CN=ExchangeOrganizationName。

  2. 展开 CN=Administrative Groups，再展开 CN=AdministrativeGroupName，然后展开 CN=Servers。

  3. 展开 CN=ExchangeServerName，再展开 CN=InformationStore，用鼠标右键单击 CN=Storage Group Name，然后单击 Properties。

  4. 在 Select a property to view 框中，单击 msExchESEParamLogBuffers。

  5. 在"Edit Attribute"框中，为 msExchESEParamLogBuffers 键入 9000，再单击"Set"。

  6. 单击"Apply"，再单击"OK"。

  7. 若要使更改生效，必须重新启动 Microsoft Exchange 信息存储服务。

有关详细信息，请参阅 Microsoft 知识库文章 328466"ESE log buffers that are set too low can cause the Microsoft Exchange Information Store service to stop responding"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466)。


对于包含大量邮箱的 Exchange Server 2003 服务器，日志缓冲区可能不够
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-03-27

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定是否符合下列条件：

  • 计算机正在运行 Exchange Server 2003。

  • msExchESEParamLogBuffers 的值在 0 到 8,960 之间。

  • 存储组中的邮箱数超过 500 个。

Exchange Server 分析工具查询 Win32_PerfRawData_MSExchangeIS_MSExchangeIS Microsoft Windows® Management Instrumentation (WMI) 类，以确定是否符合下列条件：

  • VMLargestBlockSize 的值大于 150,000,000。

如果符合上述所有条件，将显示警告。

可扩展存储引擎 (ESE) 使用日志缓冲区将事务保存在内存中，然后再将其提交给事务日志。如果没有足够的日志缓冲区，可能遇到事务日志驱动器上的磁盘 I/O 过多的情况，从而影响性能。

解决此警告问题

  1. 在 Active Directory 服务接口 (ADSI) Edit 中，双击 Configuration 容器，展开 CN=Services，再展开 CN=Microsoft Exchange，然后展开 CN=ExchangeOrganizationName。

  2. 展开 CN=Administrative Groups，再展开 CN=AdministrativeGroupName，然后展开 CN=Servers。

  3. 展开 CN=ExchangeServerName，再展开 CN=InformationStore，右键单击 CN=Storage Group Name，然后单击 Properties。

  4. 在"Select a property to view"框中，单击 msExchESEParamLogBuffers。

  5. 在"Edit Attribute"框中，为 msExchESEParamLogBuffers 键入 9000，再单击"Set"。

  6. 单击"应用"，再单击"确定"。

  7. 若要使更改生效，必须重新启动 Microsoft Exchange 信息存储服务。
警告：
在使用 ADSI Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

有关详细信息，请参阅 Microsoft 知识库文章 328466"ESE 日志缓冲区数目设置过低可能导致 Microsoft Exchange 信息存储服务停止响应"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466)。


日志文件存储在网络驱动器上
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个存储组对象的 msExchESEParamLogFilePath 属性值。该属性指定了此存储组中的数据库所使用的事务日志文件的位置。

Exchange Server 分析工具还查询 Active Directory，以确定在每个邮箱存储的 homeMDBBL 属性中所列出的条目数。该属性的个数代表邮箱存储中的邮箱数。

如果 Exchange Server 分析工具发现在有超过 50 个邮箱的 Exchange Server 上 msExchESEParamLogFilePath 属性以"\\"开头，则显示错误。

该错误说明存储组的事务日志文件正存储在网络共享上。如果 msExchESEParamLogFilePath 属性以"\\"开头，则表示日志文件路径使用了通用命名约定 (UNC) 路径。这不是建议的做法，因为如果网络连接中断，就会导致事务日志和数据库错误，从而导致数据丢失或数据库损坏。建议尽快纠正该问题。

更正此错误

  • 将事务日志从网络共享移动到本地磁盘。为了获得最佳性能，请将所有事务日志存放在单独的驱动器中。

有关如何将事务日志移至其他位置的信息，请参阅 Microsoft 知识库文章 239944"XADM:How to Move the Transaction or System Logs to Another Location"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=239944)。


日志生成差异
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具确定存在日志文件生成差异。此错误表明事务日志文件已使用不适当的序列号进行了重命名。

Exchange 事务日志文件根据以下格式命名：EnnXXXXX.log

  • XXXXX = 五位的十六进制序列号。生成一组新的事务日志文件后，序列中的第一个日志为 000001，下一个日志为 00002，依此类推。由于每个事务日志都在其标题中记录了其自己的序列号，因此可以确定日志文件名是否已更改。

  • Enn = 日志前缀，是由该存储组的每个事务日志共享的三个字符序列。通常，前缀为 E00、E01、E02、E03 或 R00（对于恢复存储组）。

当前正在写入的日志仅使用日志前缀命名。此日志不需要序列号，直到其已关闭并生成新的当前日志。因此，当前日志文件可以命名为 E00.log。此日志文件填满时，可以将其重命名为 E0012345.log。如果生成新的 E00.log，则其内部序列号将为 12346。

更正此错误

  • 将日志文件重命名为相应的序列号。
若要查看内部序列号，请执行下列操作：

  • 运行以下命令：

    C:\Program Files\Exchsrvr\Bin\Eseutil.exe /ML [log filename]

    此命令输出中的 lGeneration 值列出了日志文件的实际序列号。


日志对不一致
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具已确定有些所需的日志文件不一致。此错误表明日志文件可能已被篡改、手动移动、复制、重命名或删除。

更正此错误

  • 有关日志文件的高级分析，请与 Microsoft 帮助和支持中心联系 (http://go.microsoft.com/fwlink/?LinkId=31845)。


日志签名差异
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具已确定一个或多个日志文件中的日志签名与同一文件夹中的其他日志文件不匹配。

如果手动移动、删除日志文件或打乱其顺序，则会出现此问题。

注意：
这是一种高级恢复方案，您可能需要在实现之前联系 Microsoft 帮助和支持 (http://go.microsoft.com/fwlink/?LinkId=31845)。

每个 Exchange 事务日志文件都使用签名（称为日志签名）进行标记。此签名可识别属于相同日志序列的各个日志文件。每个 Exchange 数据库记录上次附加数据库的事务日志序列的日志签名。

Exchange 数据库也有签名，称为数据库签名。首次创建数据库时便会生成数据库签名。如果使用 Eseutil 对数据库进行碎片整理或修复，此签名将发生更改，其原因是：修复和碎片整理过程对数据库文件进行了更改，而且未将这些更改记录到事务日志。对于日志记录而言，通过修复或碎片整理操作后的数据库是一个新的或不同的数据库。

与数据库签名不同，日志签名在日志文件序列的生存期内从不会发生更改。

日志文件记录创建日志之后附加的所有数据库的数据库签名。数据库记录最近附加了数据库的日志序列的日志签名。因此，数据库签名和日志签名可用于将数据库与事务日志文件进行匹配。

可以将 Exchange 数据库从一组日志中分离出来并将其附加到其他日志。可以通过将数据库移至其他存储组，或通过删除存储组的所有事务日志并开始新的日志序列来执行此操作。

如果数据库处于"肮脏关闭"状态，则只能将签名与数据库头中日志签名匹配的事务日志文件成功重播到数据库。在"肮脏关闭"状态下，数据库仍附加到特殊的日志流，并且仅可使用此日志流执行恢复。

如果数据库处于"干净关闭"状态下，则可以播放签名与数据库头中当前日志签名不匹配的事务日志文件。只在以下情况下才能成功实现此操作：

  1. 在先前日志文件序列的结尾处正常关闭数据库。

  2. 然后，数据库附加到新的事务日志文件序列，并且您可以访问其中数据库首次附加到一组新的日志的事务日志。

更正此错误

  • 必须了解数据库的历史记录以及在什么情况下生成有关数据库的事务日志。

  • 在这种情况下，在尝试恢复之前，应始终复制事务日志和数据库文件。错误的恢复尝试可能会更改事务日志或数据库文件，以致于无法进行其他恢复尝试。

  • 一次只将一组事务日志重播到数据库。将其他事务日志从恢复文件夹中移出。

  • 如果数据库处于"肮脏关闭"状态，则必须首先成功重播附加了数据库的事务日志，并使数据库处于"干净关闭"状态。然后才可以将第二组日志文件播放到数据库。

  • 如果数据库处于"干净关闭"状态，则无法检查日志或数据库，以最终验证应首先重播哪组事务日志。


仅限某些用户登录
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取 Exchange Server 计算机上的以下注册表项，以确定是否限定了允许登录到 Exchange 信息存储的用户的列表：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Logon Only As

如果 Exchange Server 分析工具发现 Logon Only As 注册表值存在，将显示警告。

Logon Only As 注册表值是一个多字符串值 (REG_MULTI_SZ)，它包含被批准登录到 Exchange 信息存储的帐户的 legacyExchangeDN 属性的列表。该注册表值（默认情况下不存在）通常在故障排除、维护以及邮箱移动操作过程中添加。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右侧窗格中，删除 Logon Only As 注册表值。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的详细信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Logon Only As 注册表值的详细信息，请参阅知识库文章 146764"Limiting Logons to the Information Store"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=146764)。

有关如何在邮箱移动操作过程中限制登录的信息，请参阅知识库文章 218920"XADM: How to Prevent Logons During Move Mailbox"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=218920)。


Lookup SID Cache Expire 注册表值已设置
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否存在 Lookup Sid Cache Expire 注册表项：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果符合下列条件，Exchange Server 分析工具将显示非默认配置消息：

  • Lookup Sid Cache Expire 注册表项存在。

  • Lookup Sid Cache Expire 注册表项的值为 3,600 以外的其他值。

在运行 Exchange 2000 Server Service Pack 3 或更高版本的 Exchange 服务器上，信息存储创建一个包含安全标识符 (SID) 的缓存，并指明 SID 为用户对象还是组对象。首次接触公用文件夹时即创建并填充该缓存。填充该缓存后，查找帐户 SID 的所有调用将首先被定向到信息存储缓存。如果 SID 不在信息存储缓存中，则调用将转至域控制器，并将有关该 SID 的信息添加至缓存中。

默认情况下，缓存将保留一小时。如果缓存中条目的大小超过默认的 8 KB，则会删除旧的缓存条目，以便为新的条目腾出空间。可以使用两个注册表项调整默认缓存时间 (Lookup Sid Cache Expire) 和默认缓存大小 (Lookup Sid Cache Size)。除非能够证明此更改可提高性能，否则建议不要更改这些默认设置。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. 在右侧窗格中，找到并删除 Lookup Sid Cache Expire 值。如果 Lookup SID Cache Size 值也已设置，则也将其删除。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Lookup Sid Cache Expire 注册表值的详细信息，请参阅 Microsoft 知识库文章 328907"XADM:Access Control List Upgrades Cause Slow Public Folder Performance; Fix Requires Exchange 2000 SP2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328907)。


Lookup SID Cache Size 注册表值已设置
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否存在 Lookup Sid Cache Size 注册表项：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果下列条件为真，则 Exchange Server 分析工具将显示非默认配置消息：

  • Lookup Sid Cache Size 注册表项存在。

  • Lookup Sid Cache Size 注册表项的值为 1,024 以外的其他值。

在运行 Exchange 2000 Server Service Pack 3 或更高版本的 Exchange 服务器上，信息存储创建一个包含安全标识符 (SID) 的缓存，并指明 SID 为用户对象还是组对象。首次接触公用文件夹时即创建并填充该缓存。填充该缓存后，查找帐户 SID 的所有调用将首先被定向到信息存储缓存。如果 SID 不在信息存储缓存中，则调用将转至域控制器，并将有关该 SID 的信息添加至缓存中。

默认情况下，缓存将保留一小时。如果缓存中条目的大小超过默认的 8 KB，则会删除旧的缓存条目，以便为新的条目腾出空间。可以使用两个注册表项调整默认缓存时间 (Lookup Sid Cache Expire) 和默认缓存大小 (Lookup Sid Cache Size)。除非能够证明此更改可提高性能，否则建议不要更改这些默认设置。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. 在右侧窗格中，找到并删除 Lookup Sid Cache Size 值。如果 Lookup SID Cache Expire 值也已设置，则也将其删除。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Lookup Sid Cache Size 注册表值的详细信息，请参阅 Microsoft 知识库文章 328907"XADM:Access Control List Upgrades Cause Slow Public Folder Performance; Fix Requires Exchange 2000 SP2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328907)。


低虚拟内存错误事件已被覆盖
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定虚拟内存碎片的相关事件日志记录的阈值是否已被手动覆盖：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\VM Error Level

如果 Exchange Server 分析工具发现 VM Error Level 注册表值存在并已配置，则显示非默认配置消息。

在 32 位 Microsoft Windows® 系统中，有两类内存：物理内存（系统中安装的实际内存量）和虚拟内存地址空间（虚拟化的 4 GB 内存空间）。无论系统上安装多少物理内存量，总的虚拟地址空间大小始终相同：4 GB。对于 Exchange Server 而言，虚拟地址空间等于虚拟内存，也就是说，这两个词可以互换。但这并不适用于所有 32 版的应用程序。

在常规的操作过程中，Exchange 信息存储反复地分配、使用和释放虚拟内存。当频繁地分配、使用和释放虚拟内存时，会产生虚拟内存碎片。虚拟内存碎片类似于随着时间的积累产生的文件系统碎片。在一段时间之后，所分配的虚拟内存段将不再相邻，而性能也将开始降低。 对于文件系统，可以运行执行文件系统碎片整理的应用程序。在大多数情况下，可以在系统联机并且正在执行存取操作时运行此应用程序。对于虚拟内存碎片，不存在相应的碎片整理工具。若要解决此问题，必须停止并启动 Microsoft Exchange 信息存储服务或重新启动系统。

当 Exchange Server 计算机的空闲连续虚拟地址空间不足 16 MB 时，应用程序事件日志中会记录下列错误消息：

来源： | MSExchangeIS
类别： | 性能
ID: | 9582
类型： | 错误
描述： | 运行 Exchange 服务器所需的虚拟内存有较多碎片，可能使正常操作失败。强烈建议重新启动所有 Exchange 服务，以解决此问题。

管理员可以通过 VM Error Level 注册表值来覆盖默认的 16 MB 级别警告并设置替代值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右侧窗格中，删除 VM Error Level 的值。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

有关解决 Exchange Server 2003 和 Exchange 2000 Server 中虚拟内存碎片问题的详细信息，请参阅 Microsoft 知识库文章 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://support.microsoft.com/kb/325044/zh-cn)。


低虚拟内存警告事件已被覆盖
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定虚拟内存碎片的相关事件日志记录的阈值是否已被手动覆盖：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\VM Warning Level

如果 Exchange Server 分析工具发现 VM Warning Level 注册表值存在并已配置，则显示非默认配置消息。

在 32 位 Microsoft Windows® 系统中，有两类内存：物理内存（系统中安装的实际内存量）和虚拟内存地址空间（虚拟化的 4 GB 内存空间）。无论系统上安装多少物理内存量，总的虚拟地址空间大小始终相同：4 GB。对于 Exchange Server 而言，虚拟地址空间等于虚拟内存，也就是说，这两个词可以互换。但这并不适用于所有 32 版的应用程序。

在常规的操作过程中，Exchange 信息存储反复地分配、使用和释放虚拟内存。当频繁地分配、使用和释放虚拟内存时，会产生虚拟内存碎片。虚拟内存碎片类似于随着时间的积累产生的文件系统碎片。经过一段时间后，分配的虚拟内存段将不再是连续的，因此性能开始下降。对于文件系统，可以运行执行文件碎片整理的应用程序。通常，可以在系统联机并且正在执行存取操作时运行此应用程序。对于虚拟内存碎片，不存在相应的碎片整理工具。要解决此问题，必须停止再启动 Microsoft Exchange 信息存储服务或重新启动系统。

默认情况下，当 Exchange Server 计算机的可用连续虚拟地址空间不足 32 MB 时，应用程序事件日志中会记录下列警告消息：

来源： | MSExchangeIS
类别： | 性能
ID: | 9582
类型： | 警告
描述： | 运行 Exchange 服务器所需的虚拟内存有较多碎片，可能会影响性能。强烈建议重新启动所有 Exchange 服务，以纠正此问题。

管理员可以通过 VM Warning Level 注册表值来覆盖默认的 32 MB 级别警告并设置替代值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原为默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右侧窗格中，删除 VM Warning Level 的值。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

有关解决 Exchange Server 2003 和 Exchange 2000 Server 中虚拟内存碎片问题的详细信息，请参阅 Microsoft 知识库文章 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://support.microsoft.com/kb/325044/zh-cn)。


Mailbox Cache Age Limit 已设置
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-15

Microsoft® Exchange Server 分析工具检查 Exchange Server 计算机的注册表中是否存在 Mailbox Cache Age Limit 注册表项。该注册表值位于：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server 分析工具发现 Mailbox Cache Age Limit 注册表项存在并被配置为大于或等于 1 的值，则会显示非默认配置消息。

Exchange Server 允许在邮箱上设置大小限额（配额）。配额设置存储在 Active Directory® 目录服务中，Exchange Server 定期在 Active Directory 中读取此信息，以确定是否对这些限额进行了任何更改。默认情况下，Exchange Server 缓存此信息的期限为两小时（120 秒），超过此时间后，Exchange Server 将重新在 Active Directory 中读取此信息。

Mailbox Cache Age Limit 注册表值（用分钟表示）用于覆盖默认时间期限。当用户由于已达到邮箱限额而无法访问其邮箱时，此注册表值非常有用。如果默认缓存期限生效，用户将可能在长达两个小时的时间内无法访问其邮箱。推荐值为 20 分钟。不要将该值设置得过低，因为这样会导致性能问题。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

回复到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. 在右侧窗格中，找到并删除 Mailbox Cache Age Limit 值。

  4. 关闭注册表编辑器，并重新启动"Microsoft Exchange 信息存储"服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Mailbox Cache Age Limit 注册表值的详细信息，请参阅知识库文章 327378"XADM:Exchange 2000 and Exchange Server 2003 Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time; Fix Requires Exchange 2000 SP3"（XADM：没有在合理的时段内强制实施 Exchange 2000 和 Exchange Server 2003 邮箱大小限制；要解决此问题，需要使用 Exchange 2000 SP3）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378)。


Mailbox Cache Idle Limit 已设置
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否存在 Mailbox Cache Idle Limit：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server 分析工具发现 Mailbox Cache Idle Limit 注册表项存在，则将显示非默认配置消息。

Exchange Server 允许对邮箱设置大小限制（配额）。配额设置存储于 Active Directory® 目录服务中，并且 Exchange 服务器定期读取 Active Directory 中的信息，以确定这些限制是否有任何更改。Exchange Server 在一个时间段内缓存该信息，此后，它将重新读取 Active Directory 中的该信息。

Mailbox Cache Age Limit 设置和 Mailbox Cache Idle Limit 设置控制条目在邮箱信息缓存中保留的时间。如果某项在缓存中的时间超过了 Mailbox Cache Age Limit 设置中的时间（秒），就将从缓存中删除该项。如果在 Mailbox Cache Idle Limit 所设定的时间（秒）内没有使用某项，就将从缓存中删除该项。Mailbox Cache Age Limit 设置的默认值为 7,200 秒（120 分钟），Mailbox Cache Idle Limit 设置的默认值为 900 秒（15 分钟）。Mailbox Cache Idle Limit 设置的值不应大于 Mailbox Cache Age Limit 设置的值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，例如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem.

  3. 在右侧窗格中，找到并删除 Mailbox Cache Idle Limit 值。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关使用 Mailbox Cache Age Limit 注册表值的详细信息，请参阅知识库文章 327378"XADM:Exchange 2000 Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time; Fix Requires Exchange 2000 SP3"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378)。


邮箱缓存大小已设置
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Mailbox Cache Size 是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server 分析工具发现 Mailbox Cache Size 注册表项存在，则会显示非默认配置消息。

Mailbox Cache Size 值控制此邮箱缓存的大小。默认值为 256 MB。Exchange Server 允许在邮箱上设置大小限额（配额）。配额设置存储在 Active Directory® 目录服务中，Exchange Server 定期在 Active Directory 中读取此信息，以确定是否对这些限额进行了任何更改。默认情况下，Exchange Server 缓存此信息的期限为两个小时（7,200 秒），超过此时间后，Exchange Server 将重新在 Active Directory 中读取此信息。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

回复到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右侧窗格中，找到并删除 Mailbox Cache Size 值。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Mailbox Cache Age Limit 注册表值的详细信息，请参阅知识库文章 327378"XADM: Exchange 2000 Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time; Fix Requires Exchange 2000 SP3"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378)。


Mailbox Cache Size 被设置为零
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Mailbox Cache Size 值的设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server 分析工具发现 Mailbox Cache Size 注册表值设置为 0，则显示错误。

Exchange Server 允许对邮箱设置大小限制（配额）。配额设置存储在 Active Directory® 目录服务中，Exchange Server 定期在 Active Directory 中读取此信息，以确定是否对这些限额进行了任何更改。Mailbox Cache Size 值控制此邮箱缓存的大小。默认值为 256。如果设置为 0，则会关闭邮箱缓存。建议不要将该值设置为 0，因为它会导致目录服务访问 (DSAccess) 组件执行更多的 Active Directory 查找。另外，将该值设置为 0 会导致 Exchange 存储失败，并且会导致移动邮箱时失败。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

更正此错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右侧窗格中，找到并删除 Mailbox Cache Size 值。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关使用 Mailbox Cache Age Limit 注册表值的详细信息，请参阅知识库文章 327378"XADM:Exchange 2000 Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time; Fix Requires Exchange 2000 SP3"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378)。


由策略控制的邮箱存储
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2006-06-06

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个邮箱存储对象的 msExchPolicyList 属性的值。msExchPolicyList 属性确定 Exchange Server 邮箱策略是否已创建并分配给邮箱存储。如果 Exchange Server 分析工具发现 msExchPolicyList 属性已设置，Exchange Server 分析工具将显示非默认配置消息。

默认情况下，在创建邮箱存储时，不会为其分配邮箱策略。但是，在大多数情况下，管理员会创建邮箱策略并将其分配给多个邮箱存储。这些策略将应用存储限制、索引更新、维护间隔、与公共存储的映射和脱机地址列表等管理设置。如果邮箱策略已创建并分配给邮箱存储，Exchange Server 分析工具将显示一条消息，表明邮箱存储当前受邮箱策略的控制。不需要执行任何其他操作。

删除应用于邮箱存储的邮箱策略

  1. 打开 Exchange 系统管理器，并在控制台树中展开"管理组"。

  2. 展开"第一个管理组"，然后选择"系统策略"。

  3. 在结果窗格中，用鼠标右键单击"邮箱存储"，然后选择"从策略中删除"。

  4. 在"Exchange 系统管理器"窗口中，单击"是"确认邮箱存储的删除。
注意：
如果在 Exchange 系统管理器的控制台树中看不到"系统策略"节点，请配置 Exchange 系统管理器，以显示"管理组"。

有关邮箱存储策略的详细信息，请参阅下列 Microsoft 知识库文章：

  • 822938"How To:Use System Policies to Configure Mailbox Storage Limits in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822938)。

  • 256141"如何在 Exchange 中创建系统策略"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256141)。

有关 Exchange Server 数据库文件的详细信息，请参阅下列 Exchange Server 2003 主题：

  • "Administration Guide for Exchange Server 2003"（英文）中的"Managing Mailbox Stores and Public Folder Stores"（英文）(http://go.microsoft.com/fwlink/?LinkId=47617)。

  • "Working with Exchange Server 2003 Stores"（英文）中的"Understanding the Exchange Server 2003 Store"（英文）(http://go.microsoft.com/fwlink/?LinkId=47595)。


邮箱存储数据库文件存储在网络驱动器上
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个邮箱存储对象的 msExchEDBFile 属性的值。此属性指定该邮箱存储所使用的数据库文件的位置。

Exchange Server 分析工具还查询 Active Directory，以确定在该服务器上每个邮箱存储的 homeMDBBL 属性中所列出的值的个数。该属性的个数代表邮箱存储中的邮箱数。然后，Exchange Server 分析工具可以计算出该服务器所管理的邮箱总数。

如果 Exchange Server 分析工具发现在有超过 50 个邮箱的 Exchange 服务器上 msExchEDBFile 属性以"\\"开头，则会显示错误。

该错误表示邮箱存储的数据库文件存储于网络共享上。如果 msExchEDBFile 属性以 \\ 开头，则表示日志文件路径使用通用命名约定 (UNC) 路径。这不是建议的做法，因为如果网络连接中断，就会导致数据库错误，从而导致数据丢失或数据库损坏。建议尽可能快地纠正该问题。

将数据库文件移动到新驱动器

  1. 在 Exchange 系统管理器中，展开驻留了存储的 Exchange 服务器对象，展开适合的存储组容器，用鼠标右键单击所选的邮箱存储对象，再单击"属性"。

  2. 在"属性"对话框的"数据库"选项卡中，指定新文件位置。

有关 Exchange Server 数据库文件的详细信息，请参阅下列主题：

  • "Administration Guide for Exchange Server 2003"中的"Managing Mailbox Stores and Public Folder Stores"（英文）(http://go.microsoft.com/fwlink/?LinkId=47617)

  • "Working with the Exchange Server 2003 Store"中的"Understanding the Exchange Server 2003 Store"（英文）(http://go.microsoft.com/fwlink/?LinkId=47595)

有关将 Exchange Server 与网络驱动器一起使用的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328879"Using Exchange Server with Storage Attached Network and network-attached storage devices"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328879)

  • 839687"Microsoft support policy on the use of network-attached storage devices with Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839687)

  • 317173"Exchange Server and network-attached storage"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317173)

  • 317172"Exchange Server 5.5 and network-attached storage"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317172)


邮箱存储数据库大小限制已设置
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定邮箱存储数据库的 Database Size Limit in Gb 注册表值是否存在并已经过配置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

如果 Exchange Server 分析工具发现 Database Size Limit in Gb 值存在并已配置，则显示非默认配置消息。

当 Exchange Server 2003 Standard Edition 应用了 Exchange Server 2003 Service Pack 2 (SP2) 后，其硬编码许可数据库大小限制从 16 GB 增加到了 75 GB。您可以设定保护性数据库大小限制，以防止数据库意外增大。SP2 的默认大小限制值为 18 GB，并且可以通过创建 Database Size Limit in Gb 注册表值覆盖该默认值。

也可以通过创建 Database Size Limit in Gb 注册表值，将 Exchange Server 2007 Standard Edition 硬编码许可数据库大小限制提高到 50 GB 以上。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. 删除 Database Size Limit in Gb 值。

  4. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Exchange Server 2003 SP2 的详细信息，请访问 Exchange Server 2003 Service Pack 2 网站 (http://go.microsoft.com/fwlink/?LinkId=52073)。


邮箱存储没有关联默认的公用文件夹存储
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchPrivateMDB 属性是否具有分配给邮箱存储的默认公用文件夹存储。

msExchPrivateMDB 属性是邮箱存储对象的专用数据库配置。默认情况下，msExchHomePublicMDB 属性与邮箱存储关联。msExchPrivateMDB 属性为主公用邮件数据库 (MDB)。

如果 Exchange Server 分析工具发现 msExchHomePublicMDB 属性已删除或配置不正确，Exchange Server 分析工具将显示错误。

每个邮箱存储必须与本地服务器或其他服务器上的默认公用文件夹存储关联。对于特定邮箱存储所支持的每个启用邮箱的用户，关联的公用文件夹存储为用户的主公用文件夹存储。如果可以，请使用与邮箱存储处于同一服务器上的默认公用文件夹存储。

注意：
通过使用与邮箱存储处于同一服务器上的默认公用文件夹存储，在用户访问公用文件夹时可以提高性能，并且可以简化排除公用文件夹访问问题的过程。
为邮箱存储分配默认的公用文件夹存储

  1. 在 Exchange 系统管理器中，用鼠标右键单击驻留"邮箱存储"的存储组。

  2. 用鼠标右键单击邮箱存储，再单击"属性"。

  3. 在"常规"选项卡上的"默认公用文件夹存储"中单击"浏览"，再选择要与此邮箱存储关联的公用文件夹存储。

    注意：
    如果要创建新的邮箱存储，Exchange Server 将自动选择与公用文件夹目录树关联的默认公用存储以及用户将为脱机使用而下载的脱机通讯簿。

有关管理邮箱存储和公用文件夹存储的详细信息，请参阅"Exchange Server 2003 管理指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=98e45481-1458-4809-97d6-50d8aeebd8a1&DisplayLang=zh-cn)。


邮箱存储超过 12 GB
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2006-02-28

Microsoft® Exchange Server 分析工具查询 CIM_DataFile Microsoft Windows® Management Instrumentation (WMI) 类，以确定每个 Exchange 邮箱存储数据库文件 (.edb file) 和流式文件 (.stm file) 的 FileSize 关键字的值。Exchange Server 分析工具还读取以下注册表分支，以确定所安装的 Exchange Server 的版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<Exchange Product GUID>

如果 Exchange Server 分析工具发现，在运行 Microsoft Exchange Server 2003 Standard Edition 或 Microsoft Exchange 2000 Server Standard Edition 的计算机上，邮箱存储数据库文件和流式文件的合计大小超过 12 GB，则会显示警告。

Exchange Server 2003 Standard Edition 和 Exchange 2000 Server Standard Edition 上的 Exchange 存储数据库无法增长到大于 16 GB。达到该限制之后，邮箱存储将不再装入，并且 Exchange 将不可访问。Exchange Server 2003 Enterprise Edition 和 Exchange 2000 Server Enterprise Edition 中的 Exchange 存储数据库没有 16 GB 的限制；它们只受可用硬件的限制，理论最大大小为 16 TB。

解决此警告问题

  1. 考虑将某些邮箱从大型邮箱存储移动到同一个或另一个 Exchange Server 计算机上的新邮箱存储中。

  2. 如果最近已将邮箱从该信息存储移动到另一个存储，或者最近已从该邮箱存储中删除邮箱，则执行脱机碎片整理可能会减少文件大小。

  3. 考虑设置邮箱和邮件的大小限制，以便防止邮箱存储无限制增长。
注意：
随着 Exchange Server 2003 Standard Edition 的 Exchange Server 2003 Service Pack 2 (SP2) 的发行，其硬编码许可数据库大小限制已经从 16 GB 增加到了 75 GB。管理员能够设定保护性数据库大小限制（防止数据库的意外增大）。标准版 SP2 的默认值为 18 GB，并且可以通过编辑 Database Size Limit in Gb 注册表项覆盖该默认值。
重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

使用 Exchange Server 2003 SP2 配置数据库的数据库大小限制

  1. 在运行 Exchange 服务器的计算机上启动 Regedit.exe。

  2. 打开下列注册表项：HKLM\System\CurrentControlSet\Services\MSExchangeIS\Server name\Private-Mailbox Store GUID

  3. 用鼠标右键单击"专用存储 GUID"，指向"新建"，再单击"DWORD 值"。

  4. 键入新值名称 Database Size Limit in Gb。

  5. 双击 Database Size Limit in Gb。在"数值数据"中，为最大数据库大小键入一个合适的值（以 GB 为单位）。对于 Exchange Server 2003 Standard Edition，请键入一个 1 到 75 之间的十进制值（默认值为 18 GB）。对于 Exchange Server 2003 Enterprise Edition，请键入一个 1 到 8000 之间的十进制值（默认值为 8000 GB）。单击"确定"。

  6. 用鼠标右键单击"专用存储 GUID"，指向"新建"，再单击"DWORD 值"。

  7. 键入新值名称 Database Size Buffer in Percentage。

  8. 双击 Database Size Buffer in Percentage。在"数值数据"中，键入一个 1 到 100 之间的十进制值，指定何时记录事件，以警告即将达到最大数据库大小。默认值 10 将导致在达到最大数据库大小前、剩余容量为 10% 时记录警告事件。单击"确定"。

  9. 用鼠标右键单击"专用存储 GUID"，指向"新建"，再单击"DWORD 值"。

  10. 键入新值名称 Database Size Check Start Time in Hours From Midnight。

  11. 双击 Database Size Check Start Time in Hours From Midnight。在"数值数据"中，键入 0 到 23 之间的一个值，指定 Exchange 何时检查数据库大小。默认值 5 导致 Exchange 服务器在凌晨 5 点 (5:00 AM) 检查数据库大小。单击"确定"。

  12. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 .stm 和 .edb 文件的详细信息，请参阅 Microsoft 知识库文章 232323"Native Content Storage in Microsoft Exchange"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323)。

有关在 Exchange Server 2003 中移动邮箱的详细信息，请参阅知识库文章 821829"在 Exchange Server 2003 中移动邮箱"(http://support.microsoft.com/kb/821829/zh-cn)。

有关在 Exchange 2000 Server 中移动邮箱的详细信息，请参阅知识库文章 328810"XADM：在服务器之间移动邮箱"(http://support.microsoft.com/kb/328810/zh-cn)。

有关对 Exchange Server 数据库执行脱机碎片整理的详细信息，请参阅知识库文章 328804"XADM：如何对 Exchange 2000 Server 数据库进行碎片整理"(http://support.microsoft.com/kb/328804/zh-cn)。

有关设置邮件大小限制的详细信息，请参阅知识库文章 322679"为邮件设置大小限制"(http://support.microsoft.com/kb/322679/zh-cn)。

有关 Exchange Server 2003 Standard Edition 或 Microsoft Exchange 2000 Server Standard Edition 达到最大数据库大小的信息，请参阅知识库文章 828070"当邮箱存储数据库达到 16 GB 限制时 Exchange Server 邮箱存储将无法装入"(http://support.microsoft.com/kb/828070/zh-cn)。

有关 Exchange Server 2003 SP2 的详细信息，请参阅 Exchange Server 2003 Service Pack 2 网站 (http://go.microsoft.com/fwlink/?LinkId=52073)。


邮箱存储超过 15 GB
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2006-02-28

Microsoft® Exchange Server 分析工具查询 CIM_DataFile Microsoft Windows® Management Instrumentation (WMI) 类，以确定每个 Exchange 邮箱存储数据库文件 (.edb file) 和流式文件 (.stm file) 的 FileSize 关键字的值。Exchange Server 分析工具还读取以下注册表分支，以确定所安装的 Exchange Server 的版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<Exchange Product GUID>

如果 Exchange Server 分析工具发现，在运行 Microsoft Exchange Server 2003 Standard Edition 或 Microsoft Exchange 2000 Server Standard Edition 的计算机上，邮箱存储数据库文件和流式文件的合计大小超过 15 GB，则显示错误。

Exchange Server 2003 Standard Edition 和 Exchange 2000 Server Standard Edition 上的 Exchange 存储数据库无法增长到大于 16 GB。达到该限制之后，邮箱存储将不再装入，并且 Exchange 将不可访问。Exchange Server 2003 Enterprise Edition 和 Exchange 2000 Server Enterprise Edition 中的 Exchange 存储数据库没有 16 GB 的限制；它们只受可用硬件的限制，理论最大大小为 16 TB。

更正此错误

  1. 考虑将某些邮箱从大型邮箱存储移动到同一个或另一个 Exchange Server 计算机上的新邮箱存储中。

  2. 如果最近已将邮箱从该信息存储移动到另一个存储，或者最近已从该邮箱存储中删除邮箱，则执行脱机碎片整理可能会减少文件大小。

  3. 考虑设置邮箱和邮件的大小限制，以便防止邮箱存储无限制增长。
注意：
随着 Exchange Server 2003 Standard Edition 的 Exchange Server 2003 Service Pack 2 (SP2) 的发行，其硬编码许可数据库大小限制已经从 16 GB 增加到了 75 GB。管理员能够设定保护性数据库大小限制（防止数据库的意外增大）。标准版 SP2 的默认值为 18 GB，并且可以通过编辑 Database Size Limit in GB 注册表项覆盖该默认值。
重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

使用 Exchange Server 2003 SP2 配置数据库的数据库大小限制

  1. 在运行 Exchange 服务器的计算机上启动 Regedit.exe。

  2. 打开下列注册表项：HKLM\System\CurrentControlSet\Services\MSExchangeIS\Server name\Private-Mailbox Store GUID

  3. 用鼠标右键单击"专用存储 GUID"，指向"新建"，再单击"DWORD 值"。

  4. 键入新值名称 Database Size Limit in Gb。

  5. 双击 Database Size Limit in Gb。在"数值数据"中，为最大数据库大小键入一个合适的值（以 GB 为单位）。对于 Exchange Server 2003 Standard Edition，请键入一个 1 到 75 之间的十进制值（默认值为 18 GB）。对于 Exchange Server 2003 Enterprise Edition，请键入一个 1 到 8000 之间的十进制值（默认值为 8000 GB）。单击"确定"。

  6. 用鼠标右键单击"专用存储 GUID"，指向"新建"，再单击"DWORD 值"。

  7. 键入新值名称 Database Size Buffer in Percentage。

  8. 双击 Database Size Buffer in Percentage。在"数值数据"中，键入一个 1 到 100 之间的十进制值，指定何时记录事件，以警告即将达到最大数据库大小。默认值 10 将导致在达到最大数据库大小前、剩余容量为 10% 时记录警告事件。单击"确定"。

  9. 用鼠标右键单击"专用存储 GUID"，指向"新建"，再单击"DWORD 值"。

  10. 键入新值名称 Database Size Check Start Time in Hours From Midnight。

  11. 双击 Database Size Check Start Time in Hours From Midnight。在"数值数据"中，键入 0 到 23 之间的一个值，指定 Exchange 何时检查数据库大小。默认值 5 导致 Exchange 服务器在凌晨 5 点 (5:00 AM) 检查数据库大小。单击"确定"。

  12. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 .stm 和 .edb 文件的详细信息，请参阅 Microsoft 知识库文章 232323"Native Content Storage in Microsoft Exchange"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323)。

有关在 Exchange Server 2003 中移动邮箱的详细信息，请参阅知识库文章 821829"在 Exchange Server 2003 中移动邮箱"(http://support.microsoft.com/kb/821829/zh-cn)。

有关在 Exchange 2000 Server 中移动邮箱的详细信息，请参阅知识库文章 328810"XADM：在服务器之间移动邮箱"(http://support.microsoft.com/kb/328810/zh-cn)。

有关对 Exchange Server 数据库执行脱机碎片整理的详细信息，请参阅知识库文章 328804"XADM：如何对 Exchange 2000 Server 数据库进行碎片整理"(http://support.microsoft.com/kb/328804/zh-cn)。

有关设置邮件大小限制的详细信息，请参阅知识库文章 322679"为邮件设置大小限制"(http://support.microsoft.com/kb/322679/zh-cn)。

有关 Exchange Server 2003 Standard Edition 和 Exchange 2000 Server Standard Edition 达到最大数据库大小的信息，请参阅知识库文章 828070"当邮箱存储数据库达到 16 GB 限制时 Exchange Server 邮箱存储将无法装入"(http://support.microsoft.com/kb/828070/zh-cn)。

有关 Exchange Server 2003 SP2 的详细信息，请参阅 Exchange Server 2003 Service Pack 2 网站 (http://go.microsoft.com/fwlink/?LinkId=52073)。


邮箱存储已超过 8 天未进行完整备份
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具查询每个邮箱存储，以确定上次进行完整备份的日期和时间。Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定每个邮箱存储中具有邮箱的用户数。如果同时符合下列两个条件，Exchange Server 分析工具将显示警告：

  • 自上次对邮箱存储进行完整备份以来已超过八天。

  • 邮箱存储中的邮箱数超过十个。

邮箱存储是 Microsoft Exchange Server 2003 和 Exchange Server 2007 中用于存储邮箱的数据库。邮箱存储由丰富文本 (.edb) 文件和流式本机 Internet 内容 (.stm) 文件组成。尽管有两个文件（.edb 和 .stm 文件），但是这两个文件代表的是一个数据库的两半，而不是两个不同的数据库。

Exchange Server 数据库和事务日志文件中的邮箱存储和公用文件夹存储数据是 Exchange Server 组织中要备份的最重要的数据。可以使用 Exchange Server 数据库备份将损坏的邮箱还原为运行 Exchange Server 的正常服务器。也可以使用 Exchange Server 数据库备份将 Exchange Server 数据库还原到其他服务器。

最好应每天对数据库文件和事务日志执行完整备份。完成了存储组的完整备份之后，Exchange Server 数据库上提交的事务日志文件将从服务器中删除。在恢复方案中，完整备份具有速度优势，因为只需要一套磁带即可还原所有数据。

注意：
最好将事务日志文件保存在与数据库文件不同的专用磁盘上。这可在数据库磁盘损坏时提供容错功能，并在某些情况下提高数据库性能。
重要信息：
尝试备份或还原文件和文件夹时，必须为登录时所使用的用户帐户分配必要的权限。若要创建 Exchange Server 备份，必须具有域级的备份操作员权限。若要备份 Microsoft Windows Server™ 2003 操作系统，至少必须具有本地备份操作员权限。

为 Exchange Server 数据选择的备份策略取决于存储的大小、备份软件和硬件的速度、硬件容量以及时间要求。

有关备份策略和灾难恢复操作的详细信息，请参阅：

  • Exchange Server 2003 Disaster Recovery Operations Guide（Exchange Server 2003 灾难恢复操作指南）(http://go.microsoft.com/fwlink/?LinkId=47570)

  • Database Backup and Restore（数据库备份和还原）(http://go.microsoft.com/fwlink/?LinkId=80766)


邮箱存储已超过 60 天未进行完整备份
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具查询每个邮箱存储，以确定上次进行完整备份的日期和时间。Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定每个邮箱存储中具有邮箱的用户数。如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • 自上次对邮箱存储进行完整备份以来已超过 60 天。

  • 邮箱存储中的邮箱数超过 10 个。

邮箱存储是 Microsoft Exchange Server 2003 和 Microsoft Exchange Server 2007 中用于存储邮箱的数据库。邮箱存储由丰富文本 (.edb) 文件和流式本机 Internet 内容 (.stm) 文件组成。尽管有两个文件（.edb 和 .stm 文件），但是这两个文件代表的是一个数据库的两半，而不是两个不同的数据库。

Exchange Server 数据库和事务日志文件中的邮箱存储和公用文件夹存储数据是 Exchange Server 组织中要备份的最重要的数据。可以使用 Exchange Server 数据库备份将损坏的邮箱还原为运行 Exchange Server 的正常服务器。也可以使用 Exchange Server 数据库备份将 Exchange Server 数据库还原到其他服务器。

最好应每天对数据库文件和事务日志执行完整备份。完成了存储组的完整备份之后，Exchange Server 数据库上提交的事务日志文件将从服务器中删除。在恢复方案中，完整备份具有速度优势，因为只需要一套磁带即可还原所有数据。

注意：
最好将事务日志文件保存在与数据库文件不同的专用磁盘上。这可在数据库磁盘损坏时提供容错功能，并在某些情况下提高数据库性能。
重要信息：
尝试备份或还原文件和文件夹时，必须为登录时所使用的用户帐户分配必要的权限。若要创建 Exchange Server 备份，必须具有域级的备份操作员权限。若要创建您的 Microsoft Windows Server™ 2003 操作系统的备份，必须至少具有本地备份操作员权限。

为 Exchange Server 数据选择的备份策略取决于存储的大小、备份软件和硬件的速度、硬件容量以及时间要求。

有关备份策略和灾难恢复操作的详细信息，请参阅：

  • Exchange Server 2003 Disaster Recovery Operations Guide（Exchange Server 2003 灾难恢复操作指南）(http://go.microsoft.com/fwlink/?LinkId=47570)。

  • Database Backup and Restore（数据库备份和还原）(http://go.microsoft.com/fwlink/?LinkID=80766)。


邮箱存储联机维护日程重叠
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定存储组中的所有邮箱存储是否都有相同的维护日程。如果存储组容器（msExchStorageGroup 类）有两个或更多个邮箱存储对象（msExchPrivMDB 类），则 Exchange Server 分析工具将检查每个邮箱存储对象的 activationSchedule 属性。如果 Exchange Server 分析工具发现每个邮箱存储的这些值（作为八位字符串存储）都是相同的，或者说它们是重叠的，则显示警告。

默认情况下，邮箱存储维护进程的运行时间是每晚 1:00 A.M. 到 5:00 A.M.。因为服务器资源需要维护进程，所以建议您修改维护日程，以使邮箱存储的日程有至少 15 分钟的差异。

在 Exchange 2000 Server 和 Exchange Server 2003 中解决此警告问题

  1. 打开 Exchange 系统管理器。

  2. 展开"服务器"，再展开想要处理的服务器。

  3. 展开想要处理的存储组。

  4. 右键单击想要处理的存储，再单击"属性"。

  5. 在"数据库"选项卡上，单击"维护间隔"并单击新的间隔，或单击"自定义"以创建自定义日程。

在 Exchange Server 2007 中解决此警告问题

  1. 打开 Exchange 管理控制台。

  2. 展开"服务器配置"，然后选择要使用的服务器。

  3. 展开要使用的存储组。

  4. 右键单击要使用的存储，然后单击"属性"。

  5. 在"常规"选项卡上，单击"维护日程安排"下拉列表并选择一个新的间隔，或者单击"自定义"以创建自定义日程安排。

有关 Exchange Server 2003 存储维护的详细信息，请参阅"Exchange Server 2003 管理指南"中的"Configuring Store Maintenance and Backup Options"（配置存储维护和备份选项）(http://go.microsoft.com/fwlink/?LinkId=47617)。


邮箱存储禁止发送限制和接收限制过于类似
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定为邮箱设置的邮箱大小限制。如果 Exchange Server 分析工具发现 Prohibit send 和 Prohibit send and receive 邮箱限制之间的差异小于 20%，将显示最佳实践配置消息。

Prohibit send 和 Prohibit send and receive 限制之间的差异最好至少为 20%。如果两种限制之间的差异小于 20%，邮箱用户可能没有足够的时间来清理邮箱，邮箱就已开始拒收邮件。例如，如果在邮箱达到 100 MB 时禁止用户发送新邮件，Prohibit send and receive 限制应至少为 120MB。

注意：
为邮箱设置警告限制也非常重要。邮箱达到警告限制时，将向用户发送一封电子邮件，警告用户邮箱已接近 Prohibit send 限制中定义的限制。

若要解决此问题，应将 Prohibit send 和 Prohibit send and receive 邮箱限制之间的差异增大到超过 20%。

设置邮箱限制

  1. 打开"Exchange 系统管理器"。

  2. 找到 Exchange Server 分析工具消息中显示的邮箱存储。

  3. 右键单击 MailboxStore_Name，然后选择"属性"。

  4. 选择"限制"选项卡。

  5. 修改"达到该限度时禁止发送 (KB)"限制或"达到该限度时禁止发送和接收 (KB)"限制，或同时修改两种限制。

  6. 单击"应用"，再单击"确定"。
在 Exchange Server 2007 中使用 Exchange 管理控制台设置邮箱限制

  1. 打开 Exchange 管理控制台。

  2. 找到 Exchange Server 分析工具中显示的有关此问题的邮箱存储。

  3. 右键单击 MailboxStore_Name，然后选择"属性"。

  4. 选择"限制"选项卡。

  5. 修改"达到该限度时发出警告 (KB)"、"达到该限度时禁止发送 (KB)"限制和"达到该限度时禁止发送和接收 (KB)"限制。

  6. 单击"应用"，然后单击"确定"。
在 Exchange Server 2007 中使用 Exchange 命令行管理程序设置邮箱限制

  1. 下列示例说明了如何设置向用户发送警告消息时的邮箱大小。此属性适用于该邮箱数据库中所有未设置其自己的警告配额属性的邮箱。您必须指定一个整数或"无限制"。默认值为 1.9 GB。
复制代码
Set-MailboxDatabase "Mailbox Database Name" -IssueWarningQuota 1991680
  1. 下列示例说明了如何设置与此邮箱数据库中的邮箱关联的用户无法再发送邮件时的邮箱大小。此属性适用于该邮箱数据库中所有未设置其自己的禁止发送配额属性的邮箱。设置的限制值必须是一个整数或"无限制"。

复制代码
Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendQuota 2097152
  1. 下列示例说明了如何设置与此邮箱关联的用户无法再发送或接收邮件时的邮箱大小。此属性适用于该邮箱数据库中所有未设置其自己的禁止发送和接收配额属性的邮箱。您必须指定一个整数或"无限制"。

复制代码
Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendReceiveQuota 2411520

有关管理 Exchange 邮箱的详细信息，请参阅"Working with Exchange Server 2003 Stores"（英文）(http://go.microsoft.com/fwlink/?LinkId=47595)。

有关在 Exchange Server 2007 中管理 Exchange 邮箱限制的详细信息，请参阅"How to Configure Database Limits and Properties"（如何配置数据库限制和属性）(http://go.microsoft.com/fwlink/?LinkID=80746)。


启动时邮箱存储不会装入
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定所有具有 msExchPrivateMDB 类的对象的 msExchEDBOffline 属性值。此类的对象为邮箱存储。

如果 msExchEDBOffline 属性的值为 True，表明在 Microsoft Exchange 信息存储服务启动时，邮箱存储不会自动装入。如果值为 False，表明邮箱存储将在启动时装入。如果 Exchange Server 分析工具发现该属性的值为 True，则显示警告。

该警告表明选中了"启动时不装入此存储"复选框。该复选框位于邮箱存储的"属性"对话框的"数据库"选项卡上。如果选中该复选框，在 Microsoft Exchange 信息存储服务启动时，邮箱存储不会自动装入。下一次 Microsoft Exchange 信息存储服务启动时（例如在重新启动服务器之后），该属性设置为 True 的邮箱存储不会装入。我们建议在 Microsoft Exchange 信息存储服务启动时自动装入邮箱存储。

在 Exchange 2000 Server 或 Exchange Server 2003 中解决此警告问题

  1. 打开 Exchange 系统管理器。

  2. 展开"服务器"，再展开包含要修改的邮箱存储的服务器。

  3. 展开包含要修改的邮箱存储的存储组。

  4. 右键单击邮箱存储，再单击"属性"。

  5. 在"数据库"选项卡上，清除"启动时不装入此存储"复选框。

  6. 单击"确定"保存设置。

  7. 关闭 Exchange 系统管理器。

在 Exchange Server 2007 中解决此警告问题

  1. 打开 Exchange 管理控制台。

  2. 展开"服务器配置"，然后选择要使用的服务器。

  3. 展开要使用的存储组。

  4. 右键单击要使用的数据库，然后单击"属性"。

  5. 在"常规"选项卡上，清除"启动时不装入此数据库"复选框。

  6. 单击"确定"以保存设置。

  7. 关闭 Exchange 管理控制台。

有关该选项的详细信息，请参阅下列 Microsoft 知识库文章：

  • 314218"HOW TO:Turn Off or Turn On Automatic Mounting of Data Stores at Startup in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=314218)

  • 285169"XADM:Information Stores Do Not Mount After You Use the "/disasterrecovery" Switch"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=285169)


Max FXGetBuffer Users 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已创建 Max FXGetBuffer Users 注册表项：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server 分析工具发现 Max FXGetBuffer Users 注册表项已在 ParametersSystem 注册表项下创建，则 Exchange Server 分析工具将显示非默认配置消息。

可以使用 Max FXGetBuffer Users 注册表项控制同时与 Exchange Server 2003 服务器进行同步的 Microsoft Office Outlook® 2003 客户端数。设置 Max FXGetBuffer Users 注册表项的值，以覆盖对 Outlook 客户端建立的并发远程过程调用 (RPC) 连接数的限制。有时，这些连接称为 ropFXSrcGetBuffers。通过将服务器上的处理器数乘以 2，然后再加 3，计算出 Max FXGetBuffer Users 注册表项的默认值。例如，在具有两个处理器的 Exchange Server 2003 服务器上，默认值为 7 ([2*2] + 3=7)。

Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
还原默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 删除 Max FXGetBuffer Users 值。

  4. 关闭注册表编辑器。

Microsoft Exchange 信息存储服务可以在几分钟内检测到更改。不需要重新启动计算机。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关通过设置注册表项来控制可以与 Exchange Server 2003 进行同步的 Outlook 客户端数的详细信息，请参阅知识库文章 818484"Registry Values and Counters That You Can Use to Configure and Monitor Outlook Client Synchronization"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484)。


每个提交邮件的最大附件数已更改
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定每个提交邮件的默认最大附件数是否已发生更改：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtAttachment

如果 Exchange Server 分析工具发现 objtAttachment 注册表值存在，并被配置为下表显示的值以外的任意值，则会显示非默认配置消息。

项 | Exchange Server 2003 RTM 默认值 | Exchange Server 2003 SP1 和更高版本默认值 | Exchange Server 2007 默认值
objtAttachment | 100 | 500 | 500

手动添加和配置的 objtAttachment 注册表值决定了每个 MAPI 客户端提交的每个邮件的最大附件数。当 MAPI 客户端试图发送的邮件中包含的附件数超过允许的数量时，将在包含客户端邮箱的 Exchange Server 计算机的应用程序事件日志中记录下列事件：

事件类型： | 错误
事件 ID： | 9646
事件来源： | MSExchangeIS
事件类别： | 常规
描述： | 正在关闭 Mapi 会话"/o=OrganizationName/ou=AdministrativeGroupName/cn=Recipients/cn=UserName"，因为它超过了"objtAttachment"类型的最大对象数 xxx 个。

管理员可以通过 objtAttachment 注册表值对 MAPI 客户端使用的 Exchange Server 资源进行更高级别的控制。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原为默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. 删除 objtAttachment 注册表值。

  4. 关闭注册表编辑器，并重新启动"Microsoft Exchange 信息存储"服务，以使更改生效。

如果要使用 objtAttachment 注册表值，而不是将它删除，请保留现有的值或者根据需要对它进行调整。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关详细信息，请参阅知识库文章 830829"Your Exchange Server 2003 computer may stop responding after a MAPI client opens more than the default value of certain server objects"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829)。


最大缓存视图数已修改
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定是否已修改每个数据库的最大缓存视图数。如果 Exchange Server 分析工具发现 msExchMaxCachedViews 属性已从默认值 11 更改为其他值，Exchange Server 分析工具将显示非默认配置消息。为每个数据库配置的缓存视图数在 Exchange Server 分析工具输出中提供。缓存视图数最好介于 5 到 20 之间。

msExchMaxCachedViews 是 msExchangePrivateMDB 对象类的属性。因此，Active Directory 中的每个邮箱数据库存储对象具有一个 msExchMaxCachedViews 属性值。msExchMaxCachedViews 属性值指定为邮箱中的特定文件夹缓存的最大视图数。在此上下文中，"视图"是指用户访问其他用户的 Microsoft Office Outlook® 2003 邮箱时所显示的文件夹。如果用户与其他用户共享访问某个 Outlook 文件夹，Exchange Server 将生成一个隐藏私有项目的视图。

Outlook 用户第一次查看某个其他用户的日历、联系人文件夹或其他数据时，可能会遇到延迟。用户查看了该文件夹之后，在以后尝试查看时速度可能会更快，但是经过一段时间之后，用户再次尝试访问该文件夹时，可能会遇到延迟。在文件夹中包含大量项目时，此延迟通常最明显。"大量"是指 5,000 个或 5,000 个以上的项目。

将视图应用于文件夹的操作会在 Exchange 存储中为每个访问该 Outlook 文件夹的唯一用户创建搜索文件夹。搜索文件夹在创建后会存入缓存，供以后使用。Exchange Server 创建新的搜索文件夹之前，会确定该搜索文件夹是否已存在。如果搜索文件夹存在，Exchange Server 会使用缓存的搜索文件夹加快后续查看的速度。

msExchMaxCachedViews 属性定义特定文件夹中缓存的搜索文件夹数。例如，msExchMaxCachedViews 属性可以定义日历文件夹中缓存的搜索文件夹数。

如果许多用户与您共享 Outlook 文件夹，则必须决定如何平衡服务器资源和可接受的客户端性能。搜索文件夹存入缓存后，会随着该搜索文件夹中数据的更改而更新。此类更新会占用 CPU 和磁盘资源。如果保持搜索文件夹的多个缓存，可能会进一步影响 CPU 性能和磁盘性能。

另一方面，Exchange Server 第一次创建搜索文件夹时，在建立搜索文件夹时，访问该 Outlook 文件夹的用户可能会遇到延迟。

例如，假定为 Exchange Server 配置了 11 个搜索文件夹。11 是默认的搜索文件夹数。用户 A 与 15 个其他用户共享日历文件夹。用户 B 访问该文件夹，在建立搜索文件夹时会遇到延迟。为用户 B 创建了搜索文件夹后，访问用户 A 的日历文件夹会比较快。假定用户 B 在当天的其他时间没有访问该文件夹。同时，如果 11 个其他用户访问该文件夹，将为这些用户创建唯一的搜索文件夹。因为只有 11 个搜索文件夹存入缓存，下一次用户 B 访问用户 A 的日历时，在为其建立新的搜索文件夹时，用户 B 会再次遇到延迟。

最好将最大搜索文件夹缓存数限制在 20 个或 20 个以下。超过此数目后，尤其对于包含的项目超过 5,000 个的文件夹，在服务器尝试保持缓存的文件夹时，可能会使服务器超载。

此外，缓存数最好不少于五个。如果用户与多个用户共享 Outlook 文件夹，只缓存四个搜索文件夹会对客户端体验造成负面影响，使服务器将更多资源用于更频繁地创建新缓存。

公用文件夹数据库也可以设置 msExchMaxCachedViews 属性。同样会为公用文件夹创建搜索文件夹。默认情况下，公用文件夹是许多用户可能访问的共享资源。如果公用文件夹接收许多公告，应尽量减少搜索文件夹数，因为 Exchange Server 在更新搜索文件夹时，可能会使 CPU 和磁盘负载过重。此外，如果许多不同用户访问公用文件夹，尝试通过提供许多搜索文件夹缓存来优化客户端体验不是最好的做法。在为新用户创建新搜索文件夹，很可能会丢弃这些缓存。

警告：
在使用 ADSI（Active Directory 服务接口）Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。
修改 msExchMaxCachedViews 属性

  1. 从 Microsoft Windows® 2000 支持工具或 Windows Server 2003 支持工具启动 ADSI Edit 工具。

  2. 展开下列节点：

    • Configuration Container

    • Configuration

    • Services

    • Microsoft Exchange

    • Organization_Name

    • Administrative Groups

    • Administrative_Group_Name

    • Servers

    • InformationStore

    • Storage_Group_Name

  3. 在详细信息窗格中，用鼠标右键单击数据库名称，再单击 Properties。

  4. 在 Attributes 框中，双击 msExchMaxCachedViews。

  5. 在 Integer Attribute Editor 对话框中，在 Value 字段中输入介于 5 到 20 之间的一个整数，再单击 OK。

  6. 单击 Apply，再关闭 ADSI Edit。

  7. 至少等待 15 分钟进行复制，然后在进行修改的 Exchange Server 上重新启动 Microsoft Exchange 信息存储服务。


最大缓存视图数的设置太高
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定是否已修改每个数据库的最大缓存视图数。如果 Exchange Server 分析工具发现为 msExchMaxCachedViews 属性设置的值大于 20，则 Exchange Server 分析工具将显示警告。为每个数据库配置的缓存视图数在 Exchange Server 分析工具输出中提供。缓存视图数最好介于 5 到 20 之间。

msExchMaxCachedViews 是 msExchangePrivateMDB 对象类的属性。因此，Active Directory 中的每个邮箱数据库存储对象具有一个 msExchMaxCachedViews 属性值。msExchMaxCachedViews 属性值指定为邮箱中的特定文件夹缓存的最大视图数。在此上下文中，"视图"是指用户访问其他用户的 Microsoft Office Outlook® 2003 邮箱时所显示的文件夹。如果用户与其他用户共享访问某个 Outlook 文件夹，Exchange Server 将生成一个隐藏私有项目的视图。

Outlook 用户第一次查看某个其他用户的日历、联系人文件夹或其他数据时，可能会遇到延迟。用户查看了该文件夹之后，在以后尝试查看时速度可能会更快，但是经过一段时间之后，用户再次尝试访问该文件夹时，可能会遇到延迟。在文件夹中包含大量项目时，此延迟通常最明显。"大量"是指 5,000 个或 5,000 个以上的项目。

将视图应用于文件夹的操作会在 Exchange 存储中为每个访问该 Outlook 文件夹的唯一用户创建搜索文件夹。搜索文件夹在创建后会存入缓存，供以后使用。Exchange Server 创建新的搜索文件夹之前，会确定该搜索文件夹是否已存在。如果搜索文件夹存在，Exchange Server 会使用缓存的搜索文件夹加快后续查看的速度。

msExchMaxCachedViews 属性定义特定文件夹中缓存的搜索文件夹数。例如，msExchMaxCachedViews 属性可以定义日历文件夹中缓存的搜索文件夹数。

如果许多用户与您共享 Outlook 文件夹，则必须决定如何平衡服务器资源和可接受的客户端性能。搜索文件夹存入缓存后，会随着该搜索文件夹中数据的更改而更新。此类更新会占用 CPU 和磁盘资源。如果保持搜索文件夹的多个缓存，可能会进一步影响 CPU 性能和磁盘性能。

另一方面，Exchange Server 第一次创建搜索文件夹时，在建立搜索文件夹时，访问该 Outlook 文件夹的用户可能会遇到延迟。

例如，假定为 Exchange Server 配置了 11 个搜索文件夹。11 是默认的搜索文件夹数。用户 A 与 15 个其他用户共享日历文件夹。用户 B 访问该文件夹，在建立搜索文件夹时会遇到延迟。为用户 B 创建了搜索文件夹后，访问用户 A 的日历文件夹会比较快。假定用户 B 在当天的其他时间没有访问该文件夹。同时，如果 11 个其他用户访问该文件夹，将为这些用户创建唯一的搜索文件夹。因为只有 11 个搜索文件夹存入缓存，下一次用户 B 访问用户 A 的日历时，在为其建立新的搜索文件夹时，用户 B 会再次遇到延迟。

最好将最大搜索文件夹缓存数限制在 20 个或 20 个以下。超过此数目后，尤其对于包含的项目超过 5,000 个的文件夹，在服务器尝试保持缓存的文件夹时，可能会使服务器超载。

此外，缓存数最好不少于五个。如果用户与多个用户共享 Outlook 文件夹，只缓存四个搜索文件夹会对客户端体验造成负面影响，使服务器将更多资源用于更频繁地创建新缓存。

公用文件夹数据库也可以设置 msExchMaxCachedViews 属性。同样会为公用文件夹创建搜索文件夹。默认情况下，公用文件夹是许多用户可能访问的共享资源。如果公用文件夹接收许多公告，应尽量减少搜索文件夹数，因为 Exchange Server 在更新搜索文件夹时，可能会使 CPU 和磁盘负载过重。此外，如果许多不同用户访问公用文件夹，尝试通过提供许多搜索文件夹缓存来优化客户端体验不是最好的做法。在为新用户创建新搜索文件夹，很可能会丢弃这些缓存。

警告：
在使用 ADSI（Active Directory 服务接口）Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。
修改 msExchMaxCachedViews 属性

  1. 从 Microsoft Windows® 2000 支持工具或 Windows Server 2003 支持工具启动 ADSI Edit 工具。

  2. 展开下列节点：

    • Configuration Container

    • Configuration

    • Services

    • Microsoft Exchange

    • Organization_Name

    • Administrative Groups

    • Administrative_Group_Name

    • Servers

    • InformationStore

    • Storage_Group_Name

  3. 在详细信息窗格中，用鼠标右键单击数据库名称，再单击 Properties。

  4. 在 Attributes 框中，双击 msExchMaxCachedViews。

  5. 在 Integer Attribute Editor 对话框中，在 Value 字段中输入介于 5 到 20 之间的一个整数，再单击 OK。

  6. 单击 Apply，再关闭 ADSI Edit。

  7. 至少等待 15 分钟进行复制，然后在进行修改的 Exchange Server 上重新启动 Microsoft Exchange 信息存储服务。


最大缓存视图数的设置太低
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定是否已修改每个数据库的最大缓存视图数。如果 Exchange Server 分析工具发现为 msExchMaxCachedViews 属性设置的值小于 5，Exchange Server 分析工具将显示警告。为每个数据库配置的缓存视图数在 Exchange Server 分析工具输出中提供。缓存视图数最好介于 5 到 20 之间。

msExchMaxCachedViews 是 msExchangePrivateMDB 对象类的属性。因此，Active Directory 中的每个邮箱数据库存储对象具有一个 msExchMaxCachedViews 属性值。msExchMaxCachedViews 属性值指定为邮箱中的特定文件夹缓存的最大视图数。

在此上下文中，"视图"是指用户访问其他用户的 Microsoft Office Outlook® 2003 邮箱时所显示的文件夹。如果用户与其他用户共享访问某个 Outlook 文件夹，Exchange Server 将生成一个隐藏私有项目的视图。

Outlook 用户第一次查看某个其他用户的日历、联系人文件夹或其他数据时，可能会遇到延迟。用户查看了该文件夹之后，在以后尝试查看时速度可能会更快，但是经过一段时间之后，用户再次尝试访问该文件夹时，可能会遇到延迟。在文件夹中包含大量项目时，此延迟通常最明显。"大量"是指 5,000 个或 5,000 个以上的项目。

将视图应用于文件夹的操作会在 Exchange 存储中为每个访问该 Outlook 文件夹的唯一用户创建搜索文件夹。搜索文件夹在创建后会存入缓存，供以后使用。Exchange Server 创建新的搜索文件夹之前，会确定该搜索文件夹是否已存在。如果搜索文件夹存在，Exchange Server 会使用缓存的搜索文件夹加快后续查看的速度。

msExchMaxCachedViews 属性定义特定文件夹中缓存的搜索文件夹数。例如，msExchMaxCachedViews 属性可以定义日历文件夹中缓存的搜索文件夹数。

如果许多用户与您共享 Outlook 文件夹，则必须决定如何平衡服务器资源和可接受的客户端性能。搜索文件夹存入缓存后，会随着该搜索文件夹中数据的更改而更新。此类更新会占用 CPU 和磁盘资源。如果保持搜索文件夹的多个缓存，可能会进一步影响 CPU 性能和磁盘性能。

另一方面，Exchange Server 第一次创建搜索文件夹时，在建立搜索文件夹时，访问该 Outlook 文件夹的用户可能会遇到延迟。

例如，假定为 Exchange Server 配置了 11 个搜索文件夹。11 是默认的搜索文件夹数。用户 A 与 15 个其他用户共享日历文件夹。用户 B 访问该文件夹，在建立搜索文件夹时会遇到延迟。为用户 B 创建了搜索文件夹后，访问用户 A 的日历文件夹会比较快。假定用户 B 在当天的其他时间没有访问该文件夹。同时，如果 11 个其他用户访问该文件夹，将为这些用户创建唯一的搜索文件夹。因为只有 11 个搜索文件夹存入缓存，下一次用户 B 访问用户 A 的日历时，在为其建立新的搜索文件夹时，用户 B 会再次遇到延迟。

最好将最大搜索文件夹缓存数限制在 20 个或 20 个以下。超过此数目后，尤其对于包含的项目超过 5,000 个的文件夹，在服务器尝试保持缓存的文件夹时，可能会使服务器超载。

此外，缓存数最好不少于五个。如果用户与多个用户共享 Outlook 文件夹，只缓存四个搜索文件夹会对客户端体验造成负面影响，使服务器将更多资源用于更频繁地创建新缓存。

公用文件夹数据库也可以设置 msExchMaxCachedViews 属性。同样会为公用文件夹创建搜索文件夹。默认情况下，公用文件夹是许多用户可能访问的共享资源。如果公用文件夹接收许多公告，应尽量减少搜索文件夹数，因为 Exchange Server 在更新搜索文件夹时，可能会使 CPU 和磁盘负载过重。此外，如果许多不同用户访问公用文件夹，尝试通过提供许多搜索文件夹缓存来优化客户端体验不是最好的做法。在为新用户创建新搜索文件夹，很可能会丢弃这些缓存。

警告：
在使用 ADSI（Active Directory 服务接口）Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。
修改 msExchMaxCachedViews 属性

  1. 从 Microsoft Windows® 2000 支持工具或 Windows Server 2003 支持工具启动 ADSI Edit 工具。

  2. 展开下列节点：

    • Configuration Container

    • Configuration

    • Services

    • Microsoft Exchange

    • Organization_Name

    • Administrative Groups

    • Administrative_Group_Name

    • Servers

    • InformationStore

    • Storage_Group_Name

  3. 在详细信息窗格中，用鼠标右键单击数据库名称，再单击 Properties。

  4. 在 Attributes 框中，双击 msExchMaxCachedViews。

  5. 在 Integer Attribute Editor 对话框中，在 Value 字段中输入介于 5 到 20 之间的一个整数，再单击 OK。

  6. 单击 Apply，再关闭 ADSI Edit。

  7. 至少等待 15 分钟进行复制，然后在进行修改的 Exchange 服务器上重新启动 Microsoft Exchange 信息存储服务。


最大 ESE 缓存已被手动更改
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2006-02-21

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定所有邮箱存储对象的 msExchESEParamCacheSizeMax 属性值。如果 Exchange Server 分析工具发现任何邮箱存储的 msExchESEParamCacheSizeMax 属性值大于 0 但小于 219727，则显示非默认配置消息。

在 Exchange 2000 Server 中，STORE.EXE 所使用的大型虚拟内存区域是为 ESE 缓冲区而分配的。对于该缓冲区，Exchange 2000 Server 使用硬编码的 858 MB 作为其默认大小。在 Exchange Server 2003 中，ESE 缓冲区的分配是基于在 Boot.ini 文件中是否出现 /3GB 开关来进行的。如果有 /3GB 开关，则 ESE 缓冲区被调整为 896 MB。如果没有 /3GB，则 ESE 缓冲区被调整为 576 MB。虽然在每种情况下自动调整都是有用的，但您可能需要覆盖该自动调整设置，并手动设置更适合于具体环境的值。虽然可以将该值调整为 8192 的任何倍数，但建议您只使用下表中的值。

推荐值 | 分配的内存 | 注释
147456 | 576 MB | 这是最低推荐值。不要将该值设置为任何更低的值。在虚拟内存受约束的服务器上，以及在以不支持 /3GB 开关的 Microsoft Windows® 2000 Server 作为操作系统的 Exchange Server 2003 计算机上，该值是有用的。它还是不使用 /3GB 开关的系统上的默认值。
196608 | 768 MB | 在有大量虚拟内存并且频繁记录 9582 事件的服务器上，该值是推荐值。
219726 | 858 MB | 这是 Exchange 2000 Server 中的默认值，对于正在就地升级并有大量虚拟内存的系统来说，它是一个很好的值。
229376 | 896 MB | 这是 Exchange Server 2003 中的默认值，并且适合用在新系统上（除非由于应用程序事件日志中出现 9582 事件，说明该值不合适）。
311296 | 1.2 GB | 这是可以设置的最大值。该值只应当用在有 2 GB 或更多物理内存的系统上。

在重新配置该值之前，应当监视 STORE.EXE 进程所消耗的虚拟内存数量。可以通过在 Windows 中监视 Process 性能对象来监视该数量。在使用 /3GB 开关的系统上，Process 对象的 STORE.EXE 实例的 Virtual Bytes 计数器应当小于 2.8 GB。在没有 /3GB 开关的系统上，它应当小于 1.8 GB。如果值大于这些数量，则可能需要减少 msExchESEParamCacheSizeMax 的值。如果值小于该值，则可能需要增加 msExchESEParamCacheSizeMax 的值。

警告：
在使用 ADSI（Active Directory 服务接口）Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

调整 msExchESEParamCacheSizeMax 属性

  1. 打开 Active Directory 编辑器，如 ADSI Edit。

  2. 双击 Configuration 容器。

  3. 展开 CN=Services。

  4. 展开 CN=Microsoft Exchange。

  5. 展开 CN=<Exchange Organization Name>。

  6. 展开 CN=Administrative Groups。

  7. 展开 CN=<Administrative Group Name>。

  8. 展开 CN=Servers。

  9. 展开 CN=<Exchange Server Name>。

  10. 用鼠标右键单击 CN=InformationStore，然后单击"属性"。

  11. 在属性字段中，滚动到 msExchESEParamCacheSizeMax 并双击它。

  12. 在 Value 字段中，键入要设置的值。使用本文中的表来确定系统的最佳值。注意，所使用的值必须是 8192 的倍数。

  13. 单击 OK，然后再次单击 OK。

  14. 关闭注册表编辑器，并重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

有关优化内存使用的详细信息，请参阅 Microsoft 知识库文章 815372"如何在 Exchange Server 2003 中优化内存使用"(http://support.microsoft.com/kb/815372/zh-cn)。

有关 msExchESEParamCacheSizeMax 属性的详细信息，请参阅知识库文章 266768"XSTR:How to modify the Store Database maximum cache size"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768)。


ESE 缓存的最大值设置得太高
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2006-02-21

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定所有邮箱存储对象的 msExchESEParamCacheSizeMax 属性值。Exchange Server 分析工具还查询 Win32_PerfRawData_MSExchangeIS_MSExchangeIS Microsoft Windows® Management Instrumentation (WMI) 类，以确定 VMLargestBlockSize 关键字的值。VMLargestBlockSize 关键字代表最大可用虚拟内存块的大小（字节）。

此外，Exchange Server 分析工具还查询 Active Directory，以确定在每个邮箱存储的 homeMDBBL 属性中所列出的条目数。该属性的个数代表邮箱存储中的邮箱数。

如果 Exchange Server 分析工具发现，在有超过 20 个邮箱的 Exchange Server 计算机上 msExchESEParamCacheSizeMax 的值大于 219726，并且 VMLargestBlockSize 的值大于 50000000 但小于 150000000，则会显示错误。该错误说明在该 Exchange Server 计算机上 msExchESEParamCacheSizeMax 属性的设置太高。

在 Exchange 2000 Server 中，STORE.EXE 所使用的大型虚拟内存区域是为 ESE 缓冲区分配的。对于该缓冲区，Exchange 2000 Server 使用硬编码的 858 MB 作为其默认大小。在 Exchange Server 2003 中，ESE 缓冲区的分配是基于在 Boot.ini 文件中是否出现 /3GB 开关来进行的。如果有 /3GB 开关，则 ESE 缓冲区被调整为 896 MB。如果没有 /3GB，则 ESE 缓冲区被调整为 576 MB。虽然在每种情况下自动调整都是有用的，但您可能需要覆盖该自动调整设置，并手动设置更适合于具体环境的值。虽然可以将该值调整为 8192 的任何倍数，但建议您只使用下表中的值。

推荐值 | 分配的内存 | 注释
147456 | 576 MB | 这是最低推荐值。不要将该值设置为任何更低的值。在虚拟内存受约束的服务器上，以及在以不支持 /3GB 开关的 Microsoft Windows 2000 Server 作为操作系统的 Exchange Server 2003 计算机上，该值是有用的。这也是在不使用 /3GB 开关的系统上的默认值。
196608 | 768 MB | 在有大量虚拟内存并且频繁记录 9582 事件的服务器上，该值是推荐值。
219726 | 858 MB | 这是 Exchange 2000 Server 中的默认值，对于正在就地升级并有大量虚拟内存的系统来说，它是一个很好的值。
229376 | 896 MB | 这是 Exchange Server 2003 中的默认值，并且适合用在新系统上（除非由于应用程序事件日志中出现 9582 事件，说明该值不合适）。
311296 | 1.2 GB | 这是可以设置的最大值。该值只应当用在有 2 GB 或更多物理内存的系统上。

在重新配置该值之前，应当监视 STORE.EXE 进程所消耗的虚拟内存数量。可以通过在 Windows 中监视 Process 性能对象来监视该数量。在使用 /3GB 开关的系统上，Process 对象的 STORE.EXE 实例的 Virtual Bytes 计数器应当小于 2.8 GB。在没有 /3GB 开关的系统上，它应当小于 1.8 GB。如果值大于这些数量，则可能需要减少 msExchESEParamCacheSizeMax 的值。如果值小于该值，则可能需要增加 msExchESEParamCacheSizeMax 的值。

警告：
在使用 ADSI（Active Directory 服务接口）Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

调整 msExchESEParamCacheSizeMax 属性

  1. 打开 Active Directory 编辑器，如 ADSI Edit。

  2. 双击 Configuration 容器。

  3. 展开 CN=Services。

  4. 展开 CN=Microsoft Exchange。

  5. 展开 CN=<Exchange Organization Name>。

  6. 展开 CN=Administrative Groups。

  7. 展开 CN=<Administrative Group Name>。

  8. 展开 CN=Servers。

  9. 展开 CN=<Exchange Server Name>。

  10. 用鼠标右键单击 CN=InformationStore，然后单击"属性"。

  11. 在属性字段中，滚动到 msExchESEParamCacheSizeMax 并双击它。

  12. 在 Value 字段中，键入要设置的值。使用上表来确定系统的最佳值。注意，所使用的值必须是 8192 的倍数。

  13. 单击 OK，然后再次单击 OK。

  14. 关闭注册表编辑器，并重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

有关优化内存使用的详细信息，请参阅 Microsoft 知识库文章 815372"如何在 Exchange Server 2003 中优化内存使用"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)。

有关 msExchESEParamCacheSizeMax 属性的详细信息，请参阅知识库文章 266768"How to modify the Store Database maximum cache size"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768)。


最大 ESE 缓存大小已增加
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2006-02-21

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定所有邮箱存储对象的 msExchESEParamCacheSizeMax 属性值。

Exchange Server 分析工具还查询 Win32_PerfRawData_MSExchangeIS_MSExchangeIS Microsoft Windows® Management Instrumentation (WMI) 类，以确定 VMLargestBlockSize 关键字的值。VMLargestBlockSize 关键字代表最大可用虚拟内存块的大小（字节）。

此外，Exchange Server 分析工具还查询 Active Directory，以确定在每个邮箱存储的 homeMDBBL 属性中所列出的条目数。该属性的个数代表邮箱存储中的邮箱数。

如果 Exchange Server 分析工具发现 msExchESEParamCacheSizeMax 值超过 219726，并且在具有超过 20 个邮箱的 Exchange Server 计算机上，VMLargestBlockSize 的值不在下列取值范围内，则显示警告：

  • 大于 50000000 并且小于 150000000

  • 大于 0 并且小于 50000001

该警告说明此 Exchange Server 计算机上的 msExchESEParamCacheSizeMax 属性已经增加，并且可能导致虚拟内存较低的状况。

在 Exchange 2000 Server 中，STORE.EXE 所使用的大型虚拟内存区域是为 ESE 缓冲区而分配的。对于该缓冲区，Exchange 2000 Server 使用硬编码的 858 MB 作为其默认大小。在 Exchange Server 2003 中，ESE 缓冲区的分配是基于在 Boot.ini 文件中是否出现 /3GB 开关来进行的。如果有 /3GB 开关，则 ESE 缓冲区被调整为 896 MB。如果没有 /3GB，则 ESE 缓冲区被调整为 576 MB。虽然在每种情况下自动调整都是有用的，但您可能需要覆盖该自动调整设置，并手动设置更适合于具体环境的值。虽然可以将该值调整为 8192 的任何倍数，但建议您只使用下表中的值：

推荐值 | 分配的内存 | 注释
147456 | 576 MB | 这是最低推荐值。不要将该值设置为任何更低的值。在虚拟内存受约束的服务器上，以及在以不支持 /3GB 开关的 Microsoft Windows 2000 Server 作为操作系统的 Exchange Server 2003 计算机上，该值是有用的。在不使用 /3GB 开关的系统上，这也是默认值。
196608 | 768 MB | 在有大量虚拟内存并且频繁记录 9582 事件的服务器上，该值是推荐值。
219726 | 858 MB | 这是 Exchange 2000 Server 中的默认值，对于正在就地升级并有大量虚拟内存的系统来说，它是一个很好的值。
229376 | 896 MB | 这是 Exchange Server 2003 中的默认值，并且适合用在新系统上（除非由于应用程序事件日志中出现 9582 事件，说明该值不合适）。
311296 | 1.2 GB | 这是可以设置的最大值。该值只应当用在有 2 GB 或更多物理内存的系统上。

在重新配置该值之前，应当监视 STORE.EXE 进程所消耗的虚拟内存数量。可以通过在 Windows 中监视 Process 性能对象来监视该数量。在使用 /3GB 开关的系统上，Process 对象的 STORE.EXE 实例的 Virtual Bytes 计数器应当小于 2.8 GB。在没有 /3GB 开关的系统上，它应当小于 1.8 GB。如果值大于这些数量，则可能需要减少 msExchESEParamCacheSizeMax 的值。如果值小于该值，则可能需要增加 msExchESEParamCacheSizeMax 的值。

警告：
在使用 ADSI（Active Directory 服务接口）Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

调整 msExchESEParamCacheSizeMax 属性

  1. 打开 Active Directory 编辑器，例如 ADSI Edit。

  2. 双击 Configuration 容器。

  3. 展开 CN=Services。

  4. 展开 CN=Microsoft Exchange。

  5. 展开 CN=<Exchange Organization Name>。

  6. 展开 CN=Administrative Groups。

  7. 展开 CN=<Administrative Group Name>。

  8. 展开 CN=Servers。

  9. 展开 CN=<Exchange Server Name>。

  10. 用鼠标右键单击 CN=InformationStore，然后单击"属性"。

  11. 在属性字段中，滚动到 msExchESEParamCacheSizeMax 并双击它。

  12. 在 Value 字段中，键入想要设置的值。请使用本文提供的表格，确定适合具体系统的最佳值。注意，所使用的值必须是 8192 的倍数。

  13. 单击 OK，然后再次单击 OK。

  14. 关闭注册表编辑器，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

有关优化内存使用的详细信息，请参阅 Microsoft 知识库文章 815372"如何在 Exchange Server 2003 中优化内存使用"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)。

有关 msExchESEParamCacheSizeMax 属性的详细信息，请参阅知识库文章 266768"XSTR:How to modify the Store Database maximum cache size"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768)。


MaxOpenMessagesPerLogon 已设置
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-05-14

Microsoft Exchange 分析工具读取以下注册表项，以确定 MaxOpenMessagesPerLogon 注册表值是否存在并已配置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange 分析工具发现 MaxOpenMessagesPerLogon 注册表值存在并配置为大于 0 的值，则显示非默认配置消息。

MAPI 客户端或应用程序每次在 Exchange Server 计算机上打开邮件时，都会导致 Microsoft Exchange 信息存储服务 (store.exe) 占用少量的物理内存。当 Microsoft Office Outlook 2003 或 Outlook 2007 客户端关闭此邮件时，内存将被释放。为了防止一个或多个 MAPI 客户端导致 Exchange 存储服务不断地分配内存，在 Exchange2000 Server Service Pack1 (SP1) 中引入了一项新的配置功能，此功能使管理员可以限制每个 MAPI 客户端登录会话可以同时打开的邮件数。如果由于某些客户端应用程序意外地打开大量的邮件而影响到服务器的总体性能，则设置此类限制对您的环境很有益。

此功能是使用 Exchange Server 计算机上的 MaxOpenMessagesPerLogon 注册表值实现的。建议设置的限制不要超过 1000。当设置为 1,000 时，每个客户端都可以使用大约 4 到 6 MB 的内存。对于某些环境，更小的值 500 可能更适合。

重要信息：
本文包含有关如何编辑注册表的信息。在编辑注册表之前，请确保已了解在出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

配置最多可以同时打开的邮件数

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 打开：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 用鼠标右键单击"ParametersSystem"，选择"新建"|"DWORD 值"，并为新值指定名称 MaxOpenMessagesPerLogon。

  4. 在右侧窗格中，双击 MaxOpenMessagesPerLogon 值，然后输入最多可以同时打开的邮件数（十进制）。

  5. 关闭注册表编辑器，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 MaxOpenMessagesPerLogon 注册表值的详细信息，请参阅 Microsoft 知识库文章 289109"XADM：如何限制为每个 MAPI 登录打开的邮件数）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=289109)。


每个存储组的最大数据库数已被手动更改
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个存储组的 msExchMaxStoresPerGroup 属性值。如果 Exchange Server 分析工具发现任何存储组的 msExchMaxStoresPerGroup 属性的值不等于 5，则显示错误。

该值应用于服务器上的所有存储组。如果该属性的值已从其默认值 5 更改为其他值，就将出现该特定错误。5 是唯一受支持的值，应当永远不要更改它。如果增加该值，Exchange Server 将无法正常工作。

必须使用 Active Directory 服务接口 (ADSI) Edit 管理单元、LDP (ldp.exe) 工具或其他任何轻型目录访问协议 (LDAP) 版本 3 客户端等工具来更正该值。

警告：
在使用 ADSI Edit、LDP 工具或其他 LDAP 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

更正此错误

  1. 启动 ADSI Edit。

  2. 双击 Configuration 容器，然后依次展开 CN=Services、CN=Microsoft Exchange、CN=<ExchangeOrganizationName>。

  3. 依次展开 CN=Administrative Groups、CN=<AdministrativeGroupName>、CN=Servers。

  4. 展开 CN=<ServerName>，用鼠标右键单击 CN=InformationStore，再单击 Properties。

  5. 在 Attribute Editor 中，单击 msExchESEParamLogBuffers 属性，再单击 Edit。

  6. 在编辑属性框中，将该值设置为 5。

  7. 单击 Apply，再单击 OK。

  8. 关闭 ADSI Edit，并重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

有关使用 LDP 工具的详细信息，请参阅 Microsoft 知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

有关系统所允许的最大存储组数的详细信息，请参阅知识库文章 251123"XADM:Maximum Number of Storage Groups in Exchange 2000 for Database Capacity Planning"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=251123)。

有关使用 ADSI Edit 的详细信息，请参阅 Windows Server 帮助中的主题"Adsiedit.msc:ADSI Edit"。


手动更改了存储组的最大数目
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 InformationStore 容器的 msExchMaxStorageGroups 属性的值。如果 Exchange Server 分析工具确定有任何一个 msExchMaxStorageGroups 属性的值不等于 4，则会显示错误。

对于 msExchMaxStorageGroups 属性，系统唯一支持的值是 4，该值永远也不应更改。如果修改了该值，Exchange 将不会正常工作。

必须使用 Active Directory 服务接口 (ADSI) Edit 管理单元、LDP (ldp.exe) 工具或其他任何轻型目录访问协议 (LDAP) 版本 3 客户端等 Active Directory 编辑器来更正该值。

警告：
在使用 ADSI Edit、LDP 工具或其他 LDAP 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

更正此错误

  1. 使用 ADSI Edit 或类似的工具，在 Active Directory 中找到此服务器的 InformationStore 对象。

    可以在以下位置找到 msExchMaxStorageGroups 属性：

    CN=Configuration,DC=Domain,CN=com, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Administrative Groups, CN=AdminGroupName, CN=Servers, CN=ServerName, CN=InformationStore

  2. 通过输入一个新的值 4 来编辑 msExchMaxStorageGroups 属性。

  3. 关闭 Active Directory 编辑器，并重新启动 Exchange Server 计算机，以使更改生效。

有关使用 LDP 工具的详细信息，请参阅 Microsoft 知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。


每次登录时最多允许打开的文件夹对象的数目已更改
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定每个 MAPI 会话最多可以打开的文件夹数目的默认值是否已更改：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtFolder

如果 Exchange Server 分析工具发现 objtFolder 注册表值存在并配置为 500 以外的任何值，则显示非默认配置消息。

手动添加和配置的 objtFolder 注册表值确定每个 MAPI 客户端最多可以打开的文件夹的数目。默认情况下，Exchange Server 2003 和 Exchange Server 2007 将打开的文件夹数限制为不超过 500 个。当 MAPI 客户端试图打开超过 500 个文件夹时，则会在包含客户端邮箱的 Exchange Server 计算机的应用程序事件日志中记录下列事件：

事件类型： | 错误
事件 ID： | 9646
事件来源： | MSExchangeIS
事件类别： | 常规
描述： | 正在关闭 Mapi 会话"/o=OrganizationName/ou=AdministrativeGroupName/cn=Recipients/cn=UserName"，因为它超过了"objtFolder"类型的对象的最大数目 500。

管理员可以通过 objtFolder 注册表值对 MAPI 客户端使用的 Exchange Server 资源进行更高级别的控制。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原为默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. 删除 objtFolder 注册表值。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

  5. 或者，如果要使用 objtFolder 注册表值，而不是将它删除，请保留现有的值或者根据需要对它进行调整。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关详细信息，请参阅知识库文章 830829"Your Exchange Server 2003 computer may stop responding after a MAPI client opens more than the default value of certain server objects"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829)。


每次登录时最多允许打开的文件夹视图的数目已更改
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定每个 MAPI 会话的默认最大打开文件夹视图数是否已发生更改：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtFolderView

如果 Exchange Server 分析工具发现 objtFolderView 注册表值存在并配置为 500 以外的任意值，则显示非默认配置消息。

手动添加和配置的 objtFolderView 注册表值确定每个 MAPI 客户端最多可以打开的文件夹视图的数目。默认情况下，Exchange Server 2003 和 Exchange Server 2007 将打开的文件夹视图数限制为不超过 500 个。当 MAPI 客户端试图打开超过 500 个文件夹视图时，则会在包含客户端邮箱的 Exchange Server 计算机的应用程序事件日志中记录下列事件：

事件类型：错误

事件来源：MSExchangeIS

事件类别：常规

描述：正在关闭 Mapi 会话"/o= OrganizationName /ou= AdministrativeGroupName /cn=Recipients/cn= UserName "，因为它超过了"objtFolderView"类型的最大对象数 500 个。

管理员可以通过 objtFolderView 注册表值对 MAPI 客户端使用的 Exchange Server 资源进行更高级别的控制。

重要信息：
本文包含有关如何编辑注册表的信息。在编辑注册表之前，请确保已了解在出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. 删除 objtFolderView 注册表值。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

  5. 或者，如果要使用 objtFolderView 注册表值，而不是将它删除，请保持现有的值或者根据需要对它进行调整。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关详细信息，请参阅 Microsoft 知识库文章 830829"Your Exchange Server 2003 computer may stop responding after a MAPI client opens more than the default value of certain server objects"（在 MAPI 客户端打开某些服务器对象的多个默认值后，Exchange Server 2003 计算机可能会停止响应）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829)。


每个登录的最大打开邮件对象数已被更改
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定每个 MAPI 会话的默认最大打开邮件数是否已发生更改：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtMessage

如果 Exchange Server 分析工具发现 objtMessage 注册表值存在并已配置为 250 以外的任何值，则显示非默认配置消息。

如果手动添加和配置 objtMessage 注册表值，该值可以确定每个 MAPI 客户端的最大打开邮件数。默认情况下，Exchange Server 2003 和 Exchange Server 2007 将打开的邮件数限制为不超过 250 个。当 MAPI 客户端试图打开超过 250 个邮件时，则会在包含客户端邮箱的 Exchange Server 计算机的应用程序事件日志中记录下列事件：

事件类型：错误

Event ID: 9646

事件来源：MSExchangeIS

事件类别：常规

描述：正在关闭 Mapi 会话"/o= OrganizationName /ou= AdministrativeGroupName /cn=Recipients/cn= UserName "，因为它超过了"objtMessage"类型的最大对象数 250 个。

objtMessage 注册表值代表了一个配置机会，它使管理员能够对 MAPI 客户端所使用的 Exchange Server 资源进行更高级别的控制。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，例如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. 删除 objtMessage 注册表值。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

  5. 另外，如果想要使用 objtMessage 注册表值，而不是删除它，请继续让它设置为其现有值，或根据需要对它进行调整。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关详细信息，请参阅知识库文章 830829"Your Exchange Server 2003 computer may stop responding after a MAPI client opens more than the default value of certain server objects"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829)。


Maximum Polling Frequency 为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具读取以下注册表值，以确定是否已将使用 RPC over HTTP 访问 Exchange Server 2003 或 Exchange Server 2007 的 Microsoft Office Outlook® 2003 和 Outlook 2007 客户端的轮询间隔默认值修改为其他值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Maximum Polling Frequency

如果 Exchange Server 分析工具发现 Maximum Polling Frequency 项存在并且配置的值大于 0，则会显示非默认配置消息。

在初次连接 Exchange 服务器时，Outlook 会为自身注册新邮件通知。只要 Outlook 用户的邮箱中收到新邮件，Exchange 就会使用用户数据报协议 (UDP) 向 Outlook 发送通知。Outlook 收到此通知后，将从 Exchange 服务器上检索邮件，并在相应的文件夹中显示该邮件。如果 Outlook 不接收新邮件通知，将还原到轮询 Exchange 服务器。尽管轮询由 Outlook 发起，但是轮询频率由 Exchange 服务器指定。

默认情况下，Outlook 2003 每 60 秒轮询一次。可以通过将 Maximum Polling Frequency 注册表项添加到包含用户邮箱的 Exchange 服务器中来更改频率。输入的值为轮询间隔之间的最短毫秒数。如果 Maximum Polling Frequency 不存在，将使用默认值 60 秒（60,000 毫秒）。此默认值并不意味着每 60 秒轮询一次。而是意味着在该轮询频率间隔与该间隔两倍之间的任意时间进行轮询。例如，假定 Maximum Polling Frequency 设置为 90 秒。在该示例中，在上次轮询后的 90 到 180 秒之间进行轮询。

该值不应减小到低于默认值 60 秒，因为这样做将降低 Exchange、Outlook 和网络的性能。您可能不需要调整此值，因为许多用户操作将作为内部操作的一部分检查是否有新邮件。例如，如果用户在文件夹之间切换或打开一封邮件，就会显示服务器上的新项目。出现这个结果的原因是，在 Outlook 向 Exchange 发送必要的 RPC 请求以使该用户操作生效时，会检查新邮件标记，如果存在，在发送回 Outlook 的 RPC 回复中会包含新邮件通知。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 删除 Maximum Polling Frequency 注册表值。

  4. 重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 RPC over HTTP 的详细信息，请参阅"Exchange Server 2003 RPC over HTTP Deployment Scenarios"指南（英文）(http://go.microsoft.com/fwlink/?LinkId=47577)。


最小 ESE 缓存已被手动更改
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2006-01-16

Microsoft? Exchange Server 分析工具查询 Active Directory? 目录服务，以确定所有邮箱存储对象的 msExchESEParamCacheSizeMin 属性值。如果 Exchange Server 分析工具发现有任何邮箱存储的 msExchESEParamCacheSizeMin 属性值大于 0，则显示非默认配置消息。

Microsoft Exchange 信息存储服务在将存储数据写入到磁盘中时，将可扩展存储引擎 (ESE) 缓存用作缓冲区。Exchange 2000 Server 使用的最大缓存大小为 858 MB。Exchange Server 2003 基于服务器中安装的物理随机访问内存 (RAM) 的数量动态地确定 msExchESEParamCacheSizeMin 属性的默认值。

例如，在 boot.ini 文件中设置了 /3GB 开关的 Exchange Server 2003 计算机的最大缓存大小为 896 MB。如果计算机未设置 /3GB 开关，则最大缓存大小为 576 MB。

可以遵照下列信息将 msExchESEParamCacheSizeMin 属性还原到它原来的值：

  • 如果 Exchange Server 2003 运行在 Microsoft Windows Server? 2003 上并且服务器有 2 GB 或 2 GB 以上的 RAM，则 msExchESEParamCacheSizeMin 将为 131072 (512 MB)。

  • 如果 Exchange Server 2003 运行在 Windows Server 2003 上并且服务器有大于或等于 768 MB 但小于 2 GB 的 RAM，则 msExchESEParamCacheSizeMin 将等于"RAM/4*(4*1024)"。

  • 如果 Exchange Server 2003 运行在 Windows Server 2003 上并且服务器的 RAM 小于 768 MB，则 msExchESEParamCacheSizeMin 将等于"RAM/8*(4*1024)"。

例如：

  • 具有 512 MB RAM 的 Windows Server 2003 的 msExchESEParamCacheSizeMin 的默认值为 16384（4 KB 页）。

  • 具有 1 GB RAM 的 Windows Server 2003 的 msExchESEParamCacheSizeMin 的默认值为 65536（4 KB 页）。

  • 具有 4 GB RAM 的 Windows Server 2003 的 msExchESEParamCacheSizeMin 的默认值为 131072（4 KB 页）。

  • 如果 Exchange Server 2003 运行在 Microsoft Windows® 2000 Server 上，则 msExchESEParamCacheSizeMin 没有默认值。

警告：
在使用 ADSI（Active Directory 服务接口）Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Windows Server 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

解决此警告问题

  1. 打开 Active Directory 编辑器，如 ADSI Edit。

  2. 双击 Configuration 容器。

  3. 展开 CN=Services。

  4. 展开 CN=Microsoft Exchange。

  5. 展开 CN=<Exchange Organization Name>。

  6. 展开 CN=Administrative Groups。

  7. 展开 CN=<Administrative Group Name>。

  8. 展开 CN=Servers。

  9. 展开 CN=<Exchange Server Name>。

  10. 用鼠标右键单击 CN=InformationStore，然后单击"属性"。

  11. 在属性字段中，滚动至 msExchESEParamCacheSizeMin 并双击该属性。

  12. 在 Value 字段中，键入要设置的值。可以使用默认公式并根据实际情况对它进行编辑。使用的值必须是 32 MB 的倍数。

  13. 单击 OK，然后再次单击 OK。

  14. 关闭注册表编辑器，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

有关调整 msExchESEParamCacheSizeMin 属性的详细信息，请参阅 Microsoft 知识库文章 822894"Jet Database Does Not Work Correctly During a Backup or During a Content Indexing Operation"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822894)。


存储进程的线程数很高
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Process Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange 信息存储进程的 ThreadCount 的值。该值代表服务器上活动存储线程的个数。如果有超过 400 个活动存储线程，则会显示警告消息。

该问题的最常见原因是在同一台计算机上运行了不兼容的防病毒软件。

解决此警告问题

  1. 与供应商联系，确保您正在运行最新并与 Exchange 兼容的防病毒软件。

  2. 更新防病毒软件。

有关防病毒软件和 Exchange Server 2003 的详细信息，请参阅 Microsoft 知识库文章 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://support.microsoft.com/kb/823166/zh-cn)。


OAB Bandwidth Threshold (KBps) 注册表参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已创建 OAB Bandwidth Threshold (KBps) 注册表项：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server 分析工具发现 OAB Bandwidth Threshold (KBps) 注册表项已在 ParametersSystem 注册表项下创建，则 Exchange Server 分析工具将显示非默认配置消息。

在 Microsoft Exchange Server 2003 Service Pack 1 (SP1) 中，管理员可以设置并配置 OAB Bandwidth Threshold (KBps) 注册表项，以覆盖默认功能并限制从特定公用存储下载完整的脱机通讯簿所占用的带宽。

默认情况下，每个下载完整的脱机通讯簿的客户端请求会立即接受。此外，公用存储不会限制同时下载完整的脱机通讯簿的数目。Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。但是，如果要还原默认配置，可以删除 OAB Bandwidth Threshold (KBps) 注册表项。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
还原默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 删除 OAB Bandwidth Threshold (KBps) 值。

  4. 关闭注册表编辑器。

Microsoft Exchange 信息存储服务可以在几分钟内检测到更改。不需要重新启动计算机。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关限制下载脱机通讯簿期间占用的带宽的详细信息，请参阅知识库文章 867623"Throttling full offline Address Book downloads to limit the effect on a LAN in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=867623)。


脱机通讯簿未与特定的邮箱存储关联
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定是否已将 msExchPrivateMDB 类中的 msExchUseOAB 属性配置为针对数据库中的邮箱存储使用特定的脱机通讯簿。msExchPrivateMDB 类确定专用数据库上的配置。msExchUseOAB 属性确定特定邮箱存储所使用的特定脱机通讯簿。如果 Exchange Server 分析工具发现数据库中的邮箱存储的脱机通讯簿丢失，则 Exchange Server 分析工具将显示错误消息。

在 Exchange 2000 Server 和更高版本中，脱机地址列表与信息存储中包含的所有用户相关联。不能自动将脱机地址列表与特定邮箱相关联，或者覆盖信息存储或存储组的全局脱机地址列表设置。

若要将脱机地址列表与特定的邮箱关联，必须先创建一个脱机地址列表，包含经过筛选的全局地址列表副本。然后，必须使用 ADSI（Active Directory 服务接口）Edit 或其他轻型目录访问协议 (LDAP) 版本 3 客户端将 msExchUseOAB 属性设置为脱机地址列表的完整可分辨名称，将脱机地址列表与特定的邮箱关联。

警告：
在使用 ADSI Edit、LDP (ldp.exe) 工具或其他 LDAP 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。若要解决这些问题，您可能需要重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003/Exchange Server 2007。修改 Active Directory 对象的属性的风险由您自己承担。

有关如何将脱机通讯簿与特定的邮箱关联的详细说明，请参阅 Microsoft 知识库文章 275203"Offline Address Book Cannot Be Associated with a Particular Mailbox"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=275203)。

若要了解有关脱机通讯簿的详细信息，请参阅"Offline Address Book Best Practices Guide"（英文）(http://go.microsoft.com/fwlink/?LinkId=47583)。


公用文件夹存储的 OLD Completion Time 为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定联机碎片整理的启动延迟是否已从默认设置更改为其他设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\OLD Completion Time

如果 Exchange Server 分析工具发现 OLD Completion Time 注册表项存在，则会显示非默认配置消息。OLD Completion Time 注册表项指定联机碎片整理在信息存储维护窗口显示多少秒后运行。默认值为 1 小时（3600 秒）。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. 删除 OLD Completion Time 注册表项。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


公用文件夹存储的 OLD Minimum RunTime 为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取下列注册表项，以确定联机碎片整理的最短运行时间是否已从默认值修改为其他值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\OLD Minimum RunTime

如果 Exchange Server 分析工具发现 OLD Minimum RunTime 注册表项存在，则会显示非默认配置消息。OLD Minimum RunTime 注册表项指定联机碎片整理的最短运行时间（秒）。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. 删除 OLD Minimum RunTime 注册表项。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


联机碎片整理已被禁用
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个存储组对象的 msExchESEParamEnableOnlineDefrag 属性值。值为 True 说明按照所配置的日程安排，将发生联机数据库维护。值为 False 说明将不发生联机维护。如果 Exchange Server 分析工具发现 msExchESEParamEnableOnlineDefrag 属性的值设置为 False，则显示错误。

在 Exchange Server 中，联机数据库维护（包括碎片整理）是非常重要的。在此期间，将执行类似于 dumpster 清理（对超过已删除邮件保留日期的邮件进行删除）、公用文件夹过期（早于特定日期的公用文件夹中的邮件已过期）、已删除邮箱的清理以及联机碎片整理（不再使用的数据库对象将被检测到并删除，以便可以使用更多的数据库空间）等任务。这些过程有助于使 Exchange 服务器保持正常的工作状态以及稳定的性能。不应当将联机数据库维护设置为"从不运行"，因为这会导致在一段时间后性能降低。

警告：
在使用 ADSI（Active Directory 服务接口）Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。若要解决这些问题，您可能需要重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003/Exchange Server 2007。修改 Active Directory 对象的属性的风险由您自己承担。

更正此错误

  1. 单击"开始"、"运行"，键入 MMC，再单击"确定"。

  2. 在 Microsoft 管理控制台 (MMC) 中，单击"文件"，再单击"添加/删除管理单元"。

  3. 在"可用的独立管理单元"列表中，选择 ADSI Edit 并单击"添加"，再单击"关闭"。在"添加/删除管理单元"框中，单击"确定"。

  4. 右键单击 ADSI Edit，再单击 Connect to。在 Select a well known Naming Context 列表对话框中，选择 Configuration，再单击 OK。

  5. 展开配置容器 CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdminGroupName>, CN=Servers, CN=<ServerName>, CN=Information Store。

  6. 右键单击 CN=<StorageGroupName>，再单击"属性"。

  7. 在存储组属性对话框中，从属性列表中选择 msExchESEParamEnableOnlineDefrag，并单击 Edit，再将值更改为 True。

  8. 关闭 ADSI Edit，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

有关联机数据库维护的详细信息，请参阅下列 Exchange 资源：

  • Microsoft 知识库文章 314214"How to set maintenance intervals in data stores in Exchange 2000 Server"（如何在 Exchange 2000 Server 中设置数据存储维护间隔）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=314214)

  • Exchange Server 2007 内幕文章"Exchange Store Maintenance"（Exchange 存储维护）(http://go.microsoft.com/fwlink/?LinkId=80787)


首选回填源已启用
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取下列注册表项，以确定 Preferred Backfill Source 项是否已由以下默认值更改为其他值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Preferred Backfill Source

默认情况下，Preferred Backfill Source 不存在。如果 Exchange Server 分析工具发现 Preferred Backfill Source 存在，则显示非默认配置消息。

当公用文件夹存储确定自己尚未收到所复制的文件夹或层次结构的所有更新，并且必须从另一个存储中检索缺少的更新时，将发生回填。

为了使回填过程顺利执行，Exchange Server 在回填数组中存储了缺少的更新的相关信息。

回填数组在指定的时间（称为回填超时）以内存储此信息。如果在此时间内缺少的更新在后续的复制邮件中到达，则会从回填数组中删除这些缺少的更新。下表列出了默认的回填超时值，该值取决于缺少的更新所在的位置，以及此前它们是否已被请求过。

请求类型 | 内容存在于本地站点的存储中 | 内容存在于远程站点的存储中
初始回填 | 6 小时 | 12 小时
第一次回填重试 | 12 小时 | 24 小时
后续回填重试 | 24 小时 | 48 小时

如果在回填超时到期时仍然缺少更新，Exchange Server 2003 将创建一个或多个回填请求，并确定将哪些服务器用作回填来源。

为了选择某一台或多台服务器作为回填来源，Exchange Server 2003 将首先创建一个包含该文件夹的副本的所有服务器的列表，然后按照下面的一系列标准对该列表进行排序：

  • 按照服务器状态排序。已停机或不可用的服务器位于列表的末尾。

  • 按照首选的回填服务器排序。（如果有；只有 Exchange Server 2003 以及更高版本中才能使用此功能）。Exchange Server 2003 通过检查 Active Directory® 目录服务中的公用文件夹存储对象来确定首选的回填服务器。此设置很少使用。大多数情况下，如果 Exchange Server 2003 自动选择回填服务器，则回填过程的工作效率是最高的。大多数 Exchange Server 2003 部署都不需要首选的回填服务器。Microsoft 产品支持服务可以提供一个相应的脚本，该脚本可以根据部署要求设置首选的回填服务器。

  • 按照传输开销排序（从最低到最高）。同一站点中的服务器优先于远程站点中的服务器。服务器的传输开销是由 Exchange Server 2003 路由引擎计算的，通常用于计算最有效的邮件传递途径。注意，在 Exchange Server 2003 之前的 Exchange 版本中，传输开销的优先级较低，并且只在 Exchange 版本和可用更改数之后才被考虑。

  • 按照 Exchange 版本排序（从最新到最旧）。

  • 按照服务器上可用的必要更改数排序（从最大到最小）。不具有任何缺少的更改的服务器将从列表中删除。

如果某个服务器没有所有必要的更改，Exchange Server 2003 将选择排序列表中的下一个服务器，并将回填请求也发送到该服务器。此过程将重复，直到对所有的更改提出了请求。该功能只在 Exchange Server 2003 和更高版本中可用；如果没有任何一台服务器存放了特定文件夹的所有缺少的更新，则 Exchange 将每次向一台服务器发送回填请求。每次请求后，早期版本的 Exchange 都将等待重试超时（从 24 小时到 48 小时不等）过期，然后才发送下一个请求。

如果选定的服务器未对回填请求做出响应，存储会将该服务器标记为已停机，并重复选择过程。标记为停机的服务器将被排到列表的末尾。

大多数情况下，当允许 Exchange Server 自动选择回填服务器时，您的拓扑能够有效地工作。出于故障排除的目的，Microsoft 产品支持服务可能建议设置 Preferred Backfill Source。但是，应仅当必须解决某个特定的问题时才使用它。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

重置 Preferred Backfill Source 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>

  3. 检查或编辑 Preferred Backfill Source 的值。

    此注册表项的值以 KB 为单位。要恢复默认值，应删除 Preferred Backfill Source 并重新启动 Microsoft Exchange Information Store 服务。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关公用文件夹复制的详细信息，请参阅"使用 Exchange Server 2003 存储"中的"控制 Exchange Server 2003 公用文件夹复制"(http://go.microsoft.com/fwlink/?LinkId=47595)。


首选公用文件夹回填源已启用
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Exchange 是否已配置为具有公用文件夹层次结构的首选回填源：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Public-<Public Information Store GUID>\Preferred Backfill Source

如果 Exchange Server 分析工具发现 Preferred Backfill Source 注册表项存在并已配置，则显示非默认配置消息。

Exchange Server 2003 引入了一个名为 msexchPreferredBackfillSource 的新 Active Directory® 目录服务属性，该属性可以用来指定哪一个 Exchange Server 应接收回填请求消息。

当公用文件夹必须复制内容时，将为回填请求向 Exchange 组织发出查询。将使用第一个响应的公用文件夹服务器来回填数据。此逻辑假定第一个响应的公用文件夹服务器是距离最近的服务器，但情况并不总是这样。Exchange Server 2003 中引入了配置环境，使管理员可以指定用于回填的首选服务器。

在 Exchange Server 2003 中，可以使用 Active Directory 属性或公用文件夹服务器上的 Preferred Backfill Source 注册表项来设置用于回填公用文件夹层次结构和内容的首选服务器。首先检查 Active Directory 参数。如果它为空，再检查注册表参数。如果注册表参数也不存在，将使用默认的公用文件夹回填算法。

要使用 Active Directory 属性，请在公用文件夹存储对象上的 msExchPreferredBackfillSource 属性中设置所要求的回填公用文件夹存储的可分辨名称 (DN)。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

如果选择在 Active Directory 中编辑 msExchPreferredBackfillSource 属性，需要使用 Active Directory 编辑器，如 Active Directory 服务接口 (ADSI) Edit 或 LDP (ldp.exe) 工具。

警告：
在使用 ADSI Edit、LDP 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

在注册表中指定首选的公用文件夹回填源

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Public-<Public Information Store GUID>

  3. 检查和（如果需要）更改 Preferred Backfill Source 值。所输入的值应当是要作为回填源的 Exchange 公用文件夹存储的可分辨名称 (DN)。

  4. 如果进行了更改，应卸载再重新装入公用信息存储才能使更改生效。

在 Active Directory 中指定首选的公用文件夹回填源

  1. 修改受影响的公用文件夹存储对象的值，使 msExchPreferredBackfillSource 指向相应的回填源。可在以下位置中找到 msExchPreferredBackfillSource 属性：CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Administrative Groups, CN=AdministrativeGroupName, CN=Servers, CN=ServerName, CN=InformationStore, CN=StorageGroupName, CN=Public Folder Store

  2. 所输入的值应当是要作为回填源的 Exchange 公用文件夹存储的可分辨名称 (DN)。

  3. 如果进行了更改，应卸载再重新装入公用信息存储才能使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关使用 LDP 工具修改 Active Directory 的详细信息，请参阅知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=260745)。


提供更多磁盘空间
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2006-09-06

Microsoft® Exchange Server 分析工具已确定运行 Exchange Server 的计算机上的磁盘空间低于可接受的级别。Exchange Server 分析工具测量可用磁盘空间，以验证其是否在可接受的范围内。如果该工具发现磁盘空间低于可接受的级别，则显示错误消息。建议在运行 Exchange Server 的计算机上，所有磁盘中包含的邮箱始终至少具有其容量 10% 的可用空间。

Exchange Server 分析工具测试下列驱动器：

  • 数据库驱动器

  • Temp 驱动器

  • MailRoot 驱动器

  • STM 驱动器

  • 系统驱动器

  • 日志驱动器

    注意：
    状态表要求日志驱动器大小增大并对日志进行存档。
  • 页驱动器

更正此错误

  1. 若要释放磁盘空间，请删除磁盘中不需要的文件。

  2. 如果具有小于 10% 可用空间的磁盘包含可以安全移至其他磁盘（例如，邮箱或 Microsoft Windows® 页面文件）的数据，则执行移动数据所需的步骤。

  3. 向运行 Exchange Server 的计算机添加磁盘容量。

  4. 减小邮箱大小或将用户移至其他服务器。

详细信息

  • 有关在 Exchange Server 2003 中移动邮箱的详细信息，请参阅 Microsoft 知识库文章 821829"在 Exchange Server 2003 中移动邮箱"(http://support.microsoft.com/kb/821829/zh-cn)。

  • 有关在 Exchange 2000 Server 和 Exchange 5.5 Server 之间移动邮箱的详细信息，请参阅 Microsoft 知识库文章 328810"XADM：在服务器之间移动邮箱"(http://support.microsoft.com/kb/328810/zh-cn)。

  • 有关在 Exchange Server 2003 上使用系统策略设置邮箱限制的详细信息，请参阅 Microsoft 知识库文章 822938"HOW TO:Use System Policies to Configure Mailbox Storage Limits in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822938)。

  • 有关在 Exchange 2000 Server 上使用系统策略设置邮箱限制的详细信息，请参阅 Microsoft 知识库文章 319130"HOW TO:Use System Policies to Configure Mailbox Storage Limits in Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319130)。

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关设计存储体系结构的最佳实践的详细信息，请参阅"Best Practices Common to Multiple Architectures"（多种体系结构通用的最佳实践） (http://go.microsoft.com/fwlink/?LinkId=72988).

  • 有关磁盘大小调整、延迟和 I/O 速率的详细信息，请参阅"How to Calculate Your Disk I/O Requirements"（如何计算磁盘 I/O 要求）(http://go.microsoft.com/fwlink/?linkid=69747)。


公用文件夹存储数据库文件存储在网络驱动器上
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个公用文件夹存储对象的 msExchEDBFile 属性值。此属性指定该公用文件夹存储所使用的数据库文件的位置。

Exchange Server 分析工具还查询 Active Directory，以确定在该服务器上每个邮箱存储的 homeMDBBL 属性中所列出的值的个数。该属性的个数代表邮箱存储中的邮箱数。然后，Exchange Server 分析工具可以计算出该服务器所管理的邮箱总数。

如果 Exchange Server 分析工具发现在具有超过 50 个邮箱的 Exchange Server 上 msExchEDBFile 属性以 \\ 开头，则显示错误。

该错误表示公用文件夹存储的数据库文件存储于网络共享上。如果 msExchEDBFile 属性以 \\ 开头，则表示日志文件路径使用通用命名约定 (UNC) 路径。这不是建议的做法，因为如果网络连接中断，就会导致数据库错误，从而导致数据丢失或数据库损坏。建议尽快纠正该问题。

将数据库文件移动到新驱动器

  1. 在 Exchange 系统管理器中，展开驻留了存储的 Exchange 服务器对象，展开合适的存储组容器，用鼠标右键单击要设置的公用文件夹存储对象，再单击"属性"。

  2. 在"属性"对话框的"数据库"选项卡中，指定新文件位置。

有关 Exchange Server 数据库文件的详细信息，请参阅下列主题：

  • "Administration Guide for Exchange Server 2003"中的"Managing Mailbox Stores and Public Folder Store"（英文）(http://go.microsoft.com/fwlink/?LinkId=47617)

  • "Working with the Exchange Server 2003 Store"中的"Understanding the Exchange Server 2003 Store"（英文）(http://go.microsoft.com/fwlink/?LinkId=47595)

有关将 Exchange Server 与网络驱动器一起使用的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328879"Using Exchange Server with Storage Attached Network and network-attached storage devices"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328879)

  • 839687"Microsoft support policy on the use of network-attached storage devices with Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839687)

  • 317173"Exchange Server and network-attached storage"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317173)

  • 317172"Exchange Server 5.5 and network-attached storage"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317172)


公用文件夹存储数据库大小限制已设置
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Database Size Limit in Gb 注册表值是否存在以及是否对公用文件夹存储进行了配置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Server_Name>\Public-<MailboxStoreGUID>

如果 Exchange Server 分析工具发现 Database Size Limit in Gb 值存在并已配置，则会显示非默认配置消息。

当 Exchange Server 2003 Standard Edition 应用了 Exchange Server 2003 Service Pack 2 (SP2) 后，其硬编码许可数据库大小限制从 16 GB 增加到了 75 GB。您可以设定保护性数据库大小限制，以防止数据库意外增大。SP2 的默认大小限制值为 18 GB，并且可以通过创建 Database Size Limit in Gb 注册表值覆盖该默认值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<MailboxStoreGUID>

  3. 删除 Database Size Limit in Gb 值。

  4. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Exchange Server 2003 SP2 的详细信息，请参阅 Exchange Server 2003 Service Pack 2 网站 (http://go.microsoft.com/fwlink/?LinkId=52073)。


公用文件夹存储已超过 8 天未进行完整备份
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具查询公用文件夹存储，以确定上次进行完整备份的日期和时间。如果 Exchange Server 分析工具发现公用文件夹存储自上次进行完整备份以来已超过八天，则 Exchange Server 分析工具将显示警告。

公用文件夹存储存放与特定公用文件夹目录树关联的信息，例如目录树的结构以及目录树中包含的文件夹。还存放公用文件夹内容。公用文件夹存储由丰富文本 .edb 文件和流式本机 Internet 内容 .stm 文件组成。

Exchange Server 数据库和事务日志文件中的邮箱存储和公用文件夹存储数据是 Exchange Server 组织中要备份的最重要的数据。可以使用 Exchange Server 数据库备份将损坏的公用文件夹存储还原为运行 Exchange Server 的正常服务器。也可以使用 Exchange Server 数据库备份将 Exchange Server 数据库还原到其他服务器。

最好应每天对数据库文件和事务日志执行完整备份。完成了存储组的完整备份之后，Exchange Server 数据库上提交的事务日志文件将从服务器中删除。在恢复方案中，完整备份具有速度优势，因为只需要一套磁带即可还原所有数据。

注意：
最好将事务日志文件保留在与数据库文件不同的专用磁盘上。这样做可以在数据库磁盘损坏时提供容错能力，并且在某些情况下还可提高数据库性能。
重要信息：
尝试备份或还原文件和文件夹时，必须为登录时所使用的用户帐户分配必要的权限。若要创建 Exchange Server 备份，必须具有域级的备份操作员权限。若要创建您的 Microsoft Windows Server™ 2003 操作系统的备份，必须至少具有本地备份操作员权限。

为 Exchange Server 数据选择的备份策略取决于存储的大小、备份软件和硬件的速度、硬件容量以及时间要求。

有关备份策略以及灾难恢复操作的详细信息，请参阅：

  • Exchange Server 2003 Disaster Recovery Operations Guide（Exchange Server 2003 灾难恢复操作指南）(http://go.microsoft.com/fwlink/?linkid=47570)。

  • Database Backup and Restore（数据库备份和还原）(http://go.microsoft.com/fwlink/?LinkID=80766)。


公用文件夹存储已超过 60 天未进行完整备份
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具查询公用文件夹存储，以确定上次进行完整备份的日期和时间。如果 Exchange Server 分析工具发现公用文件夹存储自上次进行完整备份以来已超过 60 天，则 Exchange Server 分析工具将显示错误。

公用文件夹存储存放与特定公用文件夹目录树关联的信息，例如目录树的结构以及目录树中包含的文件夹。公用文件夹存储还存放公用文件夹内容。公用文件夹存储由丰富文本 .edb 文件和流式本机 Internet 内容 .stm 文件组成。

Exchange Server 数据库和事务日志文件中的邮箱存储数据和公用文件夹存储数据是 Exchange Server 组织中最重要的备份数据。可以使用 Exchange Server 数据库备份将损坏的公用文件夹存储还原为运行 Exchange Server 的正常服务器。也可以使用 Exchange Server 数据库备份将 Exchange Server 数据库还原到其他服务器。

最好应每天对数据库文件和事务日志执行完整备份。完成了存储组的完整备份之后，Exchange Server 数据库上提交的事务日志文件将从服务器中删除。在恢复方案中，完整备份具有速度优势，因为只需要一套磁带即可还原所有数据。

注意：
最好将事务日志文件保留在与数据库文件不同的专用磁盘上。这样不仅可以提高数据库性能，而且可以在数据库磁盘损坏时提供容错功能。
重要信息：
尝试备份或还原文件和文件夹时，必须为登录时所使用的用户帐户分配必要的权限。若要创建 Exchange Server 备份，必须具有域级的备份操作员权限。若要创建您的 Microsoft Windows Server™ 2003 操作系统的备份，必须至少具有本地备份操作员权限。

为 Exchange Server 数据选择的备份策略取决于存储的大小、备份软件和硬件的速度、硬件容量以及时间要求。

有关备份策略以及灾难恢复操作的详细信息，请参阅：

  • Exchange Server 2003 Disaster Recovery Operations Guide（Exchange Server 2003 灾难恢复操作指南）(http://go.microsoft.com/fwlink/?linkid=47570)

  • Database Backup and Restore（数据库备份和还原）(http://go.microsoft.com/fwlink/?LinkId=80766)


公用文件夹存储超过 12 GB
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_DataFile Microsoft Windows® Management Instrumentation (WMI) 类，以确定每个 Exchange 公用文件夹存储数据库文件（.edb 文件）和流式文件（.stm 文件）的 FileSize 关键字的值。Exchange Server 分析工具还读取以下注册表分支，以确定所安装的 Exchange Server 的版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<Exchange Product GUID>

如果 Exchange Server 分析工具发现，在运行 Microsoft Exchange Server 2003 Standard Edition 或 Exchange 2000 Server Standard Edition 的计算机上，公用文件夹存储数据库文件和流式文件的合计大小超过 12 GB，则会显示警告。

Exchange Server 2003 Standard Edition 和 Exchange 2000 Server Standard Edition 上的 Exchange 存储数据库无法增长到大于 16 GB。达到该限制之后，邮箱存储将不再装入，并且 Exchange 将不可访问。Exchange Server 2003 Enterprise Edition 和 Exchange 2000 Server Enterprise Edition 中的 Exchange 存储数据库没有 16 GB 的限制；它们只受可用硬件的限制，理论最大大小为 16 TB。

解决此警告问题

  1. 考虑对公用文件夹设置过期策略，以便删除早于特定期限的邮件。

  2. 考虑对公用文件夹存储和单个公用文件夹设置存储限制，以便防止公用文件夹存储发生无限制的增长。

  3. 如果最近从该公用文件夹存储中删除了大量邮件或删除了公用文件夹副本，通过执行脱机碎片整理，有可能减少文件大小。
注意：
随着 Exchange Server 2003 Standard Edition 的 Exchange Server 2003 Service Pack 2 (SP2) 的发行，其硬编码许可数据库大小限制已经从 16 GB 增加到了 75 GB。管理员能够设定保护性数据库大小限制（防止数据库的意外增大）。标准版 SP2 的默认值为 18 GB，并且可以通过编辑 Database Size Limit in Gb 注册表项覆盖该默认值。
重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

使用 Exchange Server 2003 SP2 配置数据库的数据库大小限制

  1. 在运行 Exchange 服务器的计算机上启动 Regedit.exe。

  2. 打开下列注册表项：HKLM\System\CurrentControlSet\Services\MSExchangeIS\Server name\Public-Public Store GUID

  3. 用鼠标右键单击"公用存储 GUID"，指向"新建"，再单击"DWORD 值"。

  4. 键入新值名称 Database Size Limit in Gb。

  5. 双击 Database Size Limit in Gb。在"数值数据"中，为最大数据库大小键入一个合适的值（以 GB 为单位）。对于 Exchange Server 2003 Standard Edition，请键入 1 到 75 之间的一个值（默认值为 18 GB）。对于 Exchange Server 2003 Enterprise Edition，请键入 1 到 8000 之间的一个值（默认值为 8000 GB）。单击"确定"。

  6. 用鼠标右键单击"公用存储 GUID"，指向"新建"，再单击"DWORD 值"。

  7. 键入新值名称 Database Size Buffer in Percentage。

  8. 双击 Database Size Buffer in Percentage。在"数值数据"中，键入 1 到 100 之间的一个值，指定何时记录事件，以警告即将达到最大数据库大小。默认值 10 将导致在达到最大数据库大小前、剩余容量为 10% 时记录警告事件。单击"确定"。

  9. 用鼠标右键单击"公用存储 GUID"，指向"新建"，再单击"DWORD 值"。

  10. 键入新值名称 Database Size Check Start Time in Hours From Midnight。

  11. 双击 Database Size Check Start Time in Hours From Midnight。在"数值数据"中，键入 0 到 23 之间的一个值，指定 Exchange 何时检查数据库大小。默认值 5 导致 Exchange 服务器在凌晨 5 点 (5:00 AM) 检查数据库大小。单击"确定"。

  12. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 .stm 和 .edb 文件的详细信息，请参阅 Microsoft 知识库文章 232323"Native Content Storage in Microsoft Exchange"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323)。

有关在 Exchange Server 2003 中移动邮箱的详细信息，请参阅知识库文章 821829"在 Exchange Server 2003 中移动邮箱"(http://support.microsoft.com/kb/821829/zh-cn)。

有关在 Exchange 2000 Server 中移动邮箱的详细信息，请参阅知识库文章 328810"XADM：在服务器之间移动邮箱"(http://support.microsoft.com/kb/328810/zh-cn)。

有关对 Exchange Server 数据库执行脱机碎片整理的详细信息，请参阅知识库文章 328804"XADM：如何对 Exchange 2000 Server 数据库进行碎片整理"(http://support.microsoft.com/kb/328804/zh-cn)。

有关对公用文件夹设置存储限制的详细信息，请参阅知识库文章 823144"HOW TO:Configure Storage Limits on Public Folders in Exchange 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823144)。

有关 Exchange Server 2003 Standard Edition 和 Exchange 2000 Server Standard Edition 达到最大数据库大小的信息，请参阅 Microsoft 知识库文章 828070"当邮箱存储数据库达到 16 GB 限制时 Exchange Server 邮箱存储将无法装入"(http://support.microsoft.com/kb/828070/zh-cn)。

有关 Exchange Server 2003 SP2 的详细信息，请参阅 Exchange Server 2003 Service Pack 2 网站 (http://go.microsoft.com/fwlink/?LinkId=52073)。


公用文件夹存储超过 15 GB
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_DataFile Microsoft Windows® Management Instrumentation (WMI) 类，以确定每个 Exchange 公用文件夹存储数据库文件（.edb 文件）和流式文件（.stm 文件）的 FileSize 关键字的值。Exchange Server 分析工具还读取以下注册表分支，以确定所安装的 Exchange Server 的版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<Exchange Product GUID>

如果 Exchange Server 分析工具发现运行 Microsoft Exchange Server 2003 Standard Edition 或 Exchange 2000 Server Standard Edition 的计算机上的公用文件夹存储数据库文件和流式文件对的合计大小超过了 15 GB，则会显示错误。

Exchange Server 2003 Standard Edition 和 Exchange 2000 Server Standard Edition 上的 Exchange 存储数据库无法增长到大于 16 GB。达到该限制之后，邮箱存储将不再装入，并且 Exchange 将不可访问。Exchange Server 2003 Enterprise Edition 和 Exchange 2000 Server Enterprise Edition 中的 Exchange 存储数据库没有 16 GB 的限制；它们只受可用硬件的限制，理论最大大小为 16 TB。

更正此错误

  1. 考虑对公用文件夹设置过期策略，以便删除早于特定期限的邮件。

  2. 考虑对公用文件夹存储和单个公用文件夹设置存储限制，以便防止公用文件夹存储发生无限制的增长。

  3. 如果最近从该公用文件夹存储中删除了大量邮件或删除了公用文件夹副本，通过执行脱机碎片整理，有可能减少文件大小。
注意：
随着 Exchange Server 2003 Standard Edition 的 Exchange Server 2003 Service Pack 2 (SP2) 的发行，其硬编码许可数据库大小限制已经从 16 GB 增加到了 75 GB。管理员能够设定保护性数据库大小限制（防止数据库的意外增大）。标准版 SP2 的默认值为 18 GB，并且可以通过编辑 Database Size Limit in Gb 注册表项覆盖该默认值。
重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

使用 Exchange Server 2003 SP2 配置数据库的数据库大小限制

  1. 在运行 Exchange 服务器的计算机上启动 Regedit.exe。

  2. 打开下列注册表项：HKLM\System\CurrentControlSet\Services\MSExchangeIS\Server name\Public-Public Store GUID

  3. 用鼠标右键单击"公用存储 GUID"，指向"新建"，再单击"DWORD 值"。

  4. 键入新值名称 Database Size Limit in Gb。

  5. 双击 Database Size Limit in Gb。在"数值数据"中，为最大数据库大小键入一个合适的值（以 GB 为单位）。对于 Exchange Server 2003 Standard Edition，请键入 1 到 75 之间的一个值（默认值为 18 GB）。对于 Exchange Server 2003 Enterprise Edition，请键入 1 到 8000 之间的一个值（默认值为 8000 GB）。单击"确定"。

  6. 用鼠标右键单击"公用存储 GUID"，指向"新建"，再单击"DWORD 值"。

  7. 键入新值名称 Database Size Buffer in Percentage。

  8. 双击 Database Size Buffer in Percentage。在"数值数据"中，键入 1 到 100 之间的一个值，指定何时记录事件，以警告即将达到最大数据库大小。默认值 10 将导致在达到最大数据库大小前、剩余容量为 10% 时记录警告事件。单击"确定"。

  9. 用鼠标右键单击"公用存储 GUID"，指向"新建"，再单击"DWORD 值"。

  10. 键入新值名称 Database Size Check Start Time in Hours From Midnight。

  11. 双击 Database Size Check Start Time in Hours From Midnight。在"数值数据"中，键入 0 到 23 之间的一个值，指定 Exchange 何时检查数据库大小。默认值 5 导致 Exchange 服务器在凌晨 5 点 (5:00 AM) 检查数据库大小。单击"确定"。

  12. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 .stm 和 .edb 文件的详细信息，请参阅 Microsoft 知识库文章 232323"Native Content Storage in Microsoft Exchange"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323)。

有关在 Exchange Server 2003 中移动邮箱的详细信息，请参阅知识库文章 821829"在 Exchange Server 2003 中移动邮箱"(http://support.microsoft.com/kb/821829/zh-cn)。

有关在 Exchange 2000 Server 中移动邮箱的详细信息，请参阅知识库文章 328810"XADM：在服务器之间移动邮箱"(http://support.microsoft.com/kb/328810/zh-cn)。

有关对 Exchange Server 数据库执行脱机碎片整理的详细信息，请参阅知识库文章 328804"XADM：如何对 Exchange 2000 Server 数据库进行碎片整理"(http://support.microsoft.com/kb/328804/zh-cn)。

有关对公用文件夹设置存储限制的详细信息，请参阅知识库文章 823144"HOW TO:Configure Storage Limits on Public Folders in Exchange 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823144)。

有关 Exchange Server 2003 Standard Edition 和 Exchange 2000 Server Standard Edition 达到最大数据库大小的信息，请参阅知识库文章 828070"当邮箱存储数据库达到 16 GB 限制时 Exchange Server 邮箱存储将无法装入"(http://support.microsoft.com/kb/828070/zh-cn)。

有关 Exchange Server 2003 SP2 的详细信息，请访问 Exchange Server 2003 Service Pack 2 网站 (http://go.microsoft.com/fwlink/?LinkId=52073)。


公用文件夹存储没有电子邮件地址
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2006-03-28

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个公用文件夹存储的 mail 属性的配置值。如果 Exchange Server 分析工具发现没有为任何公用文件夹存储配置 mail 属性，则显示错误。

如果没有用简单邮件传输协议 (SMTP) 地址来配置公用文件夹存储，则针对该存储的公用文件夹层次结构复制将无法正确进行。

在技术上，公用文件夹存储是特殊的 Exchange 邮箱类型。像所有已启用邮箱的对象一样，必须对公用文件夹存储正确配置下列属性，它才能发送和接收邮件：

  • legacyExchangeDN 这是对象的 Exchange 样式的可分辨名称。

  • proxyAddresses 该属性用于存放可能用来向该收件人发送邮件的所有电子邮件地址。

  • textEncodedORAddress 该属性包含主 X.400 地址。

  • Mail 该属性包含对象的主 SMTP 地址（没有地址前缀）。

  • mailNickname 该属性用来生成用于访问邮箱的 URL。

  • displayName 该属性包含对象的显示名，该显示名与对象作为成员出现在全局地址列表以及其他任何地址列表中的名称相同。

如果没有为公用文件夹存储设置邮件属性，通常意味着收件人更新服务没有配置或没有正常工作。收件人更新服务有两种类型。一种类型负责处理配置容器中的 Exchange 系统对象（企业收件人更新服务），另一种类型负责处理每个域中的收件人（域收件人更新服务）。

整个 Active Directory 目录林中只有一个企业收件人更新服务，因为其中只有一个配置容器。此外，正是这个收件人更新服务负责配置公用文件夹存储的 mail 属性。如果该收件人更新服务被禁用、被错误配置，或者如果收件人更新服务遇到问题，则该属性可能被错误配置，并且公用文件夹复制将不会正确运行。应当通过验证企业收件人更新服务的配置来解决该问题。

更正此错误

  1. 打开 Exchange 系统管理器。

  2. 展开"收件人"，再选择"收件人更新服务"节点。

  3. 在右侧窗格中，用鼠标右键单击名称中包含"（企业配置）"的收件人更新服务，并单击"属性"。

  4. 验证"域"字段列出了正确的域名称。

  5. 验证在"Exchange 服务器"和"Windows 域控制器"字段中列出的计算机正在正常运行，并且可在网络上使用。如果这些系统停止工作、不可用或不是执行收件人更新服务任务的必需系统，则可以使用该字段的"浏览"按钮来指定备用计算机。

  6. 验证"更新间隔"设置为"始终运行"。

  7. 单击"确定"保存更改。

  8. 在右侧窗格中，用鼠标右键单击名称中包含"（企业配置）"的收件人更新服务，并选择"重建"。此时将显示以下消息：

    "在安排的下一次更新间隔内，此操作将重新计算'contoso.com'中所有收件人的地址列表成员身份和收件人策略设置。根据域中收件人的数量，此操作可能需要几个小时。要继续吗?"

  9. 单击"是"重建收件人更新服务。

  10. 15 分钟之后，开始通过下列过程监视收件人更新服务的进度，这些过程在 Microsoft 知识库文章 246127"XADM:How to Check the Progress of the Recipient Update Service"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127) 中进行了概述。

有关收件人更新服务的详细信息，请参阅下列知识库文章：

  • 296479"XADM:Requirements for Disabling the Recipient Update Service"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=296479)

  • 328738"XADM:How the Recipient Update Service Applies Recipient Policies"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253770"XADM:Tasks Performed by the Recipient Update Service"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 288807"收件人更新服务疑难解答"(http://support.microsoft.com/kb/288807/zh-cn)

  • 319065"HOW TO:Work with the Exchange Recipient Update Service"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=319065)


公用文件夹存储不会在启动时装入
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchPublicMDB 类中所有对象的 msExchEDBOffline 属性值。此类对象为公用文件夹存储。

如果 msExchEDBOffline 属性的值为 True，则表明在 Microsoft Exchange 信息存储服务启动时，公用文件夹存储不会自动装入。如果值为 False，则表明公用文件夹存储将在启动时装入。如果 Exchange Server 分析工具发现该属性的值设置为 True，则显示警告。

该警告表明选中了"启动时不装入此存储"复选框。该复选框位于公用文件夹存储的"属性"对话框的"数据库"选项卡上。如果选中该复选框，则在 Microsoft Exchange 信息存储服务启动时，公用文件夹存储不会自动装入。下一次 Microsoft Exchange 信息存储服务启动时（例如在重新启动服务器之后），该属性设置为 True 的公用文件夹存储不会装入。建议公用文件夹存储在 Microsoft Exchange 信息存储服务启动时自动装入。

在 Exchange 2000 Server 和 Exchange Server 2003 中解决此警告问题

  1. 打开 Exchange 系统管理器。

  2. 展开"服务器"，再展开包含要修改的公用文件夹存储的服务器。

  3. 展开包含要修改的公用文件夹存储的存储组。

  4. 右键单击公用文件夹存储，再单击"属性"。

  5. 在"数据库"选项卡上，清除"启动时不装入此存储"复选框。

  6. 单击"确定"保存设置。

  7. 关闭 Exchange 系统管理器。

在 Exchange Server 2007 中解决此警告问题

  1. 打开 Exchange 管理控制台。

  2. 展开"服务器配置"，然后选择要使用的服务器。

  3. 展开要使用的存储组。

  4. 右键单击要使用的公用文件夹数据库，然后单击"属性"。

  5. 在"常规"选项卡上，清除"启动时不装入此数据库"复选框。

  6. 单击"确定"以保存设置。

  7. 关闭 Exchange 管理控制台。

有关该选项的详细信息，请参阅下列 Microsoft 知识库文章：

  • 314218"HOW TO:Turn Off or Turn On Automatic Mounting of Data Stores at Startup in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314218)

  • 285169"XADM:Information Stores Do Not Mount After You Use the "/disasterrecovery" Switch"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=285169)


公用文件夹树数据库分配
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 msExchPFTree 对象类的 msExchOwningPFTreeBL 属性的值。msExchOwningPFTreeBL 属性存储了公用文件夹存储（其中包含公用文件夹树的副本）的可分辨名称列表。如果 Exchange Server 分析工具发现公用文件夹树对象的 msExchOwningPFTreeBL 属性为空，则会显示警告。该警告表示公用文件夹树不由任何公用文件夹存储拥有。

每个公用文件夹树（又称为"公用文件夹层次结构"）均链接回公用文件夹存储。必须先创建树，再创建存储。如果尚未将树链接到数据库，将显示该警告。在特定服务器上，每个公用文件夹树只能有一个存储。如果每个存储存在于单独的服务器上，则树可以有多个存储。在这样的配置中，Exchange 将在存储之间复制信息，以便保持层次结构的一致。

如果 Microsoft Office Outlook® Web Access 客户端尝试连接到位于不含关联公用文件夹存储的树中的任何公用文件夹，将发生"服务不可用"(HTTP 503) 错误。

若要解决此警告问题，必须执行下列操作之一：

  • 将公用文件夹树与公用文件夹数据库链接起来。若要将公用文件夹树与公用文件夹数据库链接起来，必须先创建新的公用文件夹数据库，再定位到公用文件夹树并链接它们。

  • 删除公用文件夹树。如果尚未将公用文件夹树链接到公用文件夹数据库，则删除树时不会丢失任何用户数据。

将公用文件夹树与公用文件夹数据库相链接

  1. 在 Exchange 系统管理器中，展开想要向其中添加公用文件夹存储的服务器。

  2. 用鼠标右键单击特定的存储组，指向"新建"，再单击"公用存储"。

  3. 在"名称"中，键入新数据库的名称。

  4. 若要将公用文件夹树与数据库关联在一起，请单击"浏览"，再选择在 Exchange Server 分析工具警告中显示的公用文件夹树。

  5. 若要保存您的设置，请单击"确定"。

  6. 若要装入新存储，请单击"是"。

删除公用文件夹树

  1. 在 Exchange 系统管理器中，展开包含公用文件夹树的"文件夹"节点。

  2. 用鼠标右键单击想要删除的公用文件夹树，单击"删除"，再单击"是"。

有关公用文件夹管理的详细信息，请参阅"Exchange Server 2003 管理指南"中的"管理邮箱存储和公用文件夹存储"(http://go.microsoft.com/fwlink/?linkid=21769)。

有关详细信息，请参阅"Exchange Server 2003 Service Pack 1 (SP1) Online Help"（英文）(http://go.microsoft.com/fwlink/?LinkId=29847)。


恢复存储组已启用
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定具有 msExchStorageGroup 类的所有对象的 msExchESEParamBaseName 属性值。此类的对象为存储组对象。如果 msExchESEParamBaseName 属性的值为 R00，表明存储组对象为恢复存储组。如果 Exchange Server 分析工具发现该属性的值为 R00，则会显示警告。

该警告表明存在恢复存储组。我们建议在完成恢复过程后删除恢复存储组。如果不删除恢复存储组，对恢复存储组不熟悉的管理员在以后执行标准恢复时可能会混淆。

在 Exchange 2000 Server 和 Exchange Server 2003 中解决此警告问题

  1. 打开 Exchange 系统管理器。

  2. 展开"服务器"，再展开包含要删除的恢复存储组的服务器。

  3. 右键单击恢复存储组，再单击"删除"。

  4. 关闭 Exchange 系统管理器。

在 Exchange Server 2007 中解决此警告问题

  1. 按照核心 Exchange Server 2007 文档"How to Remove a Recovery Storage Group"（如何删除恢复存储组）(http://go.microsoft.com/fwlink/?LinkId=80783) 中的指导进行操作。

有关恢复存储组和 Exchange Server 2003 的详细信息，请参阅 Using Exchange Server 2003 Recovery Storage Groups（使用 Exchange Server 2003 恢复存储组）(http://go.microsoft.com/fwlink/?LinkId=23233) 和 Microsoft 知识库文章 824126"如何使用 Exchange Server 2003 中的恢复存储组"(http://support.microsoft.com/kb/824126/zh-cn)。

有关恢复存储组和 Exchange Server 2007 的详细信息，请参阅"Understanding Recovery Storage Groups"（了解恢复存储组）(http://go.microsoft.com/fwlink/?LinkId=80784)。


恢复存储组功能已禁用
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定是否已修改 msExchMaxRestoreStorageGroups 属性。如果 Exchange Server 分析工具发现 msExchMaxRestoreStorageGroups 属性已设置为 0，Exchange Server 分析工具将显示错误。

msExchMaxRestoreStorageGroups 属性是每台 Exchange 计算机的信息存储对象的二进制属性。如果 msExchMaxRestoreStorageGroups 属性设置为 0，则无法为给定的 Exchange 计算机创建恢复存储组。

如果在 Windows 群集上执行了从 Exchange 2000 Server SP3 到 Exchange Server 2003 SP1 的就地升级（其中 Exchange 虚拟服务器未使用 Exchange Server 2003 升级），可能会出现此错误。注意，有时，这种就地升级方案还可能会造成 Outlook® Mobile Access 失败。

必须通过将每台 Exchange 计算机的信息存储对象的 msExchMaxRestoreStorageGroups 属性设置为 1，更正恢复存储组错误。受影响的信息存储对象显示在 Exchange Server 分析工具输出中。如果需要有关 Outlook Mobile Access 问题的帮助，请与 Microsoft 技术支持联系。

警告：
在使用 ADSI（Active Directory 服务接口）Edit、LDP 工具 (ldp.exe) 或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。若要解决这些问题，您可能需要重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003/Exchange Server 2007。修改 Active Directory 对象的属性的风险由您自己承担。
更正恢复存储组错误

  1. 启动 ADSI Edit。

  2. 双击 Configuration 容器，展开 CN=Services，展开 CN=Microsoft Exchange，再展开 CN=<ExchangeOrganizationName>。

  3. 展开 CN=Administrative Groups，展开 CN=<AdministrativeGroupName>，再展开 CN=Servers。

  4. 在详细信息窗格中，右键单击 CN=InformationStore，再单击 Properties。

  5. 在 Attribute Editor 中，单击 msExchMaxRestoreStorageGroups 属性，再单击 Edit。

  6. 在 Edit Attribute 框中，输入 1。

  7. 单击"应用"，再单击"确定"。

  8. 关闭 ADSI Edit。重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

有关 LDP 工具的详细信息，请参阅 Microsoft 知识库文章 260745"XADM:Using the LDP Utility to Modify Active Directory Object Attributes"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

有关 Exchange 恢复存储组的详细信息，请参阅下列 Exchange 资源：

  • Using Exchange Server 2003 Recovery Storage Groups（使用 Exchange Server 2003 恢复存储组）(http://go.microsoft.com/fwlink/?LinkId=47589)

  • Understanding Recovery Storage Groups（了解恢复存储组）(http://go.microsoft.com/fwlink/?LinkID=80784)


公用文件夹服务器的复制过期为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2006-05-25

Microsoft® Exchange Server 分析工具读取以下注册表值，以确定 Exchange 存储删除已超过保持期的项目的间隔是否已从默认设置修改为其他设置：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>\Replication Expiry

如果 Exchange Server 分析工具发现 Replication Expiry 注册表值存在并已配置，则会显示非默认配置消息。

邮件过期是使公用文件夹中超过指定时间值的邮件过期的过程。默认的邮件过期间隔为 24 小时。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>

  3. 删除 Replication Expiry 注册表值。

  4. 重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关公用文件夹复制的详细信息，请参阅 Working with the Exchange Server 2003 Store（英文）(http://go.microsoft.com/fwlink/?LinkId=47595) 和知识库文章 273479"Description of the public folder referral functionality in Exchange 2000 Server and in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=273479)。


公用文件夹存储的复制文件夹冲突期限为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表值，以确定是否已将文件夹冲突期限从其默认设置修改为其他设置：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>\Replication Folder Conflict Age Limit

如果 Exchange Server 分析工具发现 Replication Folder Conflict Age Limit 注册表值存在并已配置，则显示非默认配置消息。

如果两个用户编辑并修改了公用文件夹中的同一封邮件，生成的保存邮件则定义为冲突邮件。如果在同一个公用文件夹服务器上同时进行保存，或在两个包含该文件夹副本的服务器上编辑邮件，可能会发生这种情况。如果在冲突期限设置的期限内，公用文件夹的所有者未执行任何操作，期限过后，将由公用文件夹存储解决该冲突。Replication Folder Conflict Age Limit 注册表值控制此期限。其值是允许冲突项存在的天数。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>

  3. 删除 Replication Folder Conflict Age Limit 注册表值。

  4. 重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关公用文件夹复制的详细信息，请参阅知识库文章 273479"Understanding Public Folder Replication and Referrals"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=273479)。


Replication Folder Count Limit 值已更改
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取下列注册表项，以确定 Replication Folder Count Limit 项是否已从默认值修改为其他值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Folder Count Limit

如果 Exchange Server 分析工具发现 Replication Folder Count Limit 存在，则显示非默认配置消息。

默认情况下，Replication Folder Count Limit 不存在。Replication Folder Count Limit 值代表要打包到一个层次结构复制邮件（用于复制公用文件夹树的层次结构和公用文件夹的属性）中的最大文件夹数。该值必须介于 1 和 1000 之间；默认值为 20。在 Exchange Server 2003 和更高版本中，该注册表项无效；只在以前的 Exchange Server 版本中使用它。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

重置 Replication Folder Count Limit 注册表项

  1. 打开注册表编辑器，例如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>

  3. 检查或编辑 Replication Folder Count Limit 的值。

    此注册表项的值以 KB 为单位。若要恢复默认值，应删除 Replication Folder Count Limit，并重新启动 Microsoft Exchange 信息存储服务。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关公用文件夹复制的详细信息，请参阅"使用 Exchange Server 2003 存储"中的"控制 Exchange Server 2003 公用文件夹复制"(http://go.microsoft.com/fwlink/?LinkId=47595)。


Replication Folder Tree RMQ Timeout 值已更改
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已更改 Replication Folder Tree RMQ Timeout 关键字的默认值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Folder Tree RMQ Timeout

如果 Exchange Server 分析工具发现存在 Replication Folder Tree RMQ Timeout，则会显示非默认配置消息。

默认情况下，Replication Folder Tree RMQ Timeout 不存在。Exchange 使用层次结构消息来复制公用文件夹树的层次结构和公用文件夹的属性。公用文件夹存储在接收到复制的更改后，会将更改加载到内存（复制消息队列）中以进行处理。Replication Folder Tree RMQ Timeout 值表示复制的层次结构更改可在内存中保存的最长时间。值（以秒为单位）必须在 3600（一小时）到 2592000（30 天）之间；默认值为 604800（7 天）。已成功处理完的更改会立即从内存中删除；否则，这些更改会继续保存在内存中，直到被处理或者超时之后再被删除。

例如，假定为一个文件夹复制更改，并为此文件夹的子文件夹复制另一个更改。则由于拓扑结构的不同以及更改之间的时间差，更改可能以任意的先后顺序到达目标公用文件夹存储。如果子文件夹更改首先到达，则在应用父文件夹更改之前不会正确处理此更改，公用文件夹存储将在内存中保留此子文件夹更改，直到父文件夹更改到达并被处理后才对其进行处理。如果在处理完父文件夹更改之前发生超时，则将从内存中删除子文件夹更改。在处理完父文件夹更改后，公用文件夹存储可能会接收到子文件夹更改的另一个副本，随后会成功处理此副本。如果存储未接收到子文件夹更改的另一个副本，则在公用文件夹存储对照拓扑结构中其他公用文件夹存储检查其状态时，会发现其公用文件夹树的副本丢失了子文件夹更改，并开始回填更改。

多数情况下，不建议更改 Replication Folder Tree RMQ Timeout 的默认值。如果更改此值，则此值可能会在复制通信高峰期（例如，添加新的公用文件夹存储之后）临时增大。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

重置 Replication Folder Tree RMQ Timeout 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>

  3. 检查或编辑 Replication Folder Tree RMQ Timeout 的值。

    此注册表项的值以秒为单位。若要恢复默认值，应删除 Replication Folder Tree RMQ Timeout，并重新启动 Microsoft Exchange Information Store 服务。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关公用文件夹复制的详细信息，请参阅"使用 Exchange Server 2003 存储"中的"控制 Exchange Server 2003 公用文件夹复制"(http://go.microsoft.com/fwlink/?LinkId=47595)。


公用文件夹逻辑删除的复制文件夹冲突期限为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已将删除公用文件夹逻辑删除项的间隔从以下默认值修改为其他值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder Store GUID>\Replication Folder Tombstone Age Limit

如果 Exchange Server 分析工具发现 Replication Folder Tombstone Age Limit 在注册表中存在，则显示非默认配置消息。

文件夹逻辑删除信息供公用文件夹复制使用。为了避免文件夹逻辑删除列表无限制增大，需要设置期限。默认值 180 天可以使用 Replication Folder Tombstone Age Limit 注册表值覆盖。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder Store GUID>

  3. 删除 Replication Folder Tombstone Age Limit 注册表值。

  4. 重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Replication Folder Tombstone Age Limit 注册表值的详细信息，请参阅知识库文章 159196"XADM:Tasks Controlled by the IS Maintenance Schedule"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=159196)。


Replication Long Backfill Request Delay 值已更改
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已将 Replication Long Backfill Request Delay 项从默认值修改为其他值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Long Backfill Request Delay

如果 Exchange Server 分析工具发现 Replication Long Backfill Request Delay 存在，则显示非默认配置消息。

默认情况下，Replication Long Backfill Request Delay 不存在。当公用文件夹存储确定自己尚未收到已复制文件夹或层次结构的所有更新，并且必须从另一个存储中检索缺少的更新时，将发生回填。

为了使回填过程顺利执行，Exchange Server 在回填数组中存储了缺少的更新的相关信息。回填数组在指定的时间（称为回填超时）以内存储此信息。如果在此时间内缺少的更新在后续的复制邮件中到达，则会从回填数组中删除这些缺少的更新。下表列出了默认的回填超时值，该值取决于缺少的更新所在的位置，以及此前它们是否已被请求过。

请求类型 | 内容存在于本地站点的存储中 | 内容存在于远程站点的存储中
初始回填 | 6 小时 | 12 小时
第一次回填重试 | 12 小时 | 24 小时
后续回填重试 | 24 小时 | 48 小时

如果在回填超时到期时仍然缺少更新，Exchange Server 2003 将创建一个或多个回填请求，并确定将哪些服务器用作回填来源。

为了选择某一台或多台服务器作为回填来源，Exchange Server 2003 将首先创建一个包含该文件夹的副本的所有服务器的列表，然后按照下面的一系列标准对该列表进行排序：

  • 按照服务器状态排序 已停机或不可用的服务器放在列表的末尾。

  • 按照首选的回填服务器（如果有）排序 该功能只在 Exchange Server 2003 和更高版本中可用。Exchange Server 2003 通过检查 Active Directory® 目录服务中的公用文件夹存储对象来确定首选的回填服务器。此设置很少使用。大多数情况下，如果 Exchange Server 2003 自动选择回填服务器，则回填过程的工作效率是最高的。大多数 Exchange Server 2003 部署都不需要首选的回填服务器。Microsoft 产品支持服务可以提供一个相应的脚本，该脚本可以根据部署要求设置首选的回填服务器。

  • 按照传输开销排序（从最低到最高） 同一站点中的服务器优先于远程站点中的服务器。服务器的传输开销是由 Exchange Server 2003 路由引擎计算的，通常用于计算最有效的邮件传递途径。注意，在 Exchange Server 2003 之前的 Exchange 版本中，传输开销的优先级较低，并且只在 Exchange 版本和可用更改数之后才被考虑。

  • 按照 Exchange 版本排序（从最新到最旧）

  • 按照服务器上可用的必要更改数排序（从最大到最小） 从列表中排除不缺少任何更改的服务器。

如果某个服务器没有所有必需的更改，Exchange Server 2003 会选择已排序列表中的下一个服务器，并也将回填请求发送到该服务器。重复此过程，直到已经请求了所有的更改。该功能只在 Exchange Server 2003 和更高版本中可用；如果没有任何一台服务器存放了特定文件夹的所有缺少的更新，则早期版本的 Exchange 将每次向一台服务器发送回填请求。每次请求后，早期版本的 Exchange 都将等待重试超时（从 24 小时到 48 小时不等）过期，然后才发送下一个请求。

如果选定的服务器未对回填请求做出响应，存储会将该服务器标记为已停机，并重复选择过程。标记为停机的服务器将被排到列表的末尾。

Replication Long Backfill Request Delay 值代表在对同一个 Exchange 站点中不可用的数据发送回填请求之前，存储所延迟的时间长度。该值（秒）必须在 900 和 2592000 秒（30 天）之间；默认值是 43200 秒（12 小时）。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

重置 Replication Long Backfill Request Delay 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>

  3. 检查或编辑 Replication Long Backfill Request Delay 的值。

    该注册表项的值以秒为单位。若要恢复默认值，应当删除 Replication Long Backfill Request Delay，并重新启动 Microsoft Exchange Information Store 服务。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关公用文件夹复制的详细信息，请参阅"使用 Exchange Server 2003 存储"中的"控制 Exchange Server 2003 公用文件夹复制"(http://go.microsoft.com/fwlink/?LinkId=47595)。


Replication Long Backfill Request Timeout 值已更改
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Replication Long Backfill Request Timeout 项是否已从默认值修改为其他值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Long Backfill Request Timeout

如果 Exchange Server 分析工具发现 Replication Long Backfill Request Timeout 存在，则会显示非默认配置消息。

默认情况下，Replication Long Backfill Request Timeout 不存在。当公用文件夹存储确定自己尚未收到所复制的文件夹或层次结构的所有更新，并且必须从另一个存储中检索缺少的更新时，将发生回填。

为了使回填过程顺利执行，Exchange Server 在回填数组中存储了缺少的更新的相关信息。回填数组在指定的时间（称为回填超时）以内存储此信息。如果在此时间内缺少的更新在后续的复制邮件中到达，则会从回填数组中删除这些缺少的更新。下表列出了默认的回填超时值，该值取决于缺少的更新所在的位置，以及此前它们是否已被请求过。

请求类型 | 内容存在于本地站点的存储中 | 内容存在于远程站点的存储中
初始回填 | 6 小时 | 12 小时
第一次回填重试 | 12 小时 | 24 小时
后续回填重试 | 24 小时 | 48 小时

如果在回填超时到期时仍然缺少更新，Exchange Server 2003 将创建一个或多个回填请求，并确定将哪些服务器用作回填来源。

为了选择某一台或多台服务器作为回填来源，Exchange Server 2003 将首先创建一个包含该文件夹的副本的所有服务器的列表，然后按照下面的一系列标准对该列表进行排序：

  • 按照服务器状态排序 已停机或不可用的服务器放在列表的末尾。

  • 按照首选的回填服务器（如果有）排序 该功能只在 Exchange Server 2003 和更高版本中可用。Exchange Server 2003 通过检查 Active Directory® 目录服务中的公用文件夹存储对象来确定首选的回填服务器。此设置很少使用。大多数情况下，如果 Exchange Server 2003 自动选择回填服务器，则回填过程的工作效率是最高的。大多数 Exchange Server 2003 部署都不需要首选的回填服务器。Microsoft 产品支持服务可以提供一个相应的脚本，该脚本可以根据部署要求设置首选的回填服务器。

  • 按照传输开销排序（从最低到最高） 同一站点中的服务器优先于远程站点中的服务器。服务器的传输开销是由 Exchange Server 2003 路由引擎计算的，通常用于计算最有效的邮件传递途径。注意，在 Exchange Server 2003 之前的 Exchange 版本中，传输开销的优先级较低，并且只在 Exchange 版本和可用更改数之后才被考虑。

  • 按照 Exchange 版本排序（从最新到最旧）

  • 按照服务器上可用的必要更改数排序（从最大到最小） 从列表中排除不缺少任何更改的服务器。

如果某个服务器没有所有必需的更改，Exchange Server 2003 会选择已排序列表中的下一个服务器，并也将回填请求发送到该服务器。重复此过程，直到已经请求了所有的更改。该功能只在 Exchange Server 2003 和更高版本中可用；如果没有任何一台服务器存放了特定文件夹的所有缺少的更新，则早期版本的 Exchange 将每次向一台服务器发送回填请求。每次请求后，早期版本的 Exchange 都将等待重试超时（从 24 小时到 48 小时不等）过期，然后才发送下一个请求。

如果选定的服务器未对回填请求做出响应，存储会将该服务器标记为已停机，并重复选择过程。标记为停机的服务器将被排到列表的末尾。

Replication Long Backfill Request Timeout 值代表公用文件夹存储在尝试对相同 Exchange 站点中不可用的数据发送回填请求时所使用的超时值。该值（秒）必须在 900 和 2592000 秒（30 天）之间；默认值是 86400 秒（24 小时）。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

重置 Replication Long Backfill Request Timeout 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>

  3. 检查或编辑 Replication Long Backfill Request Timeout 的值。

    该注册表项的值以秒为单位。若要恢复默认值，应当删除 Replication Long Backfill Request Timeout，并重新启动 Microsoft Exchange Information Store 服务。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关公用文件夹复制的详细信息，请参阅"使用 Exchange Server 2003 存储"中的"控制 Exchange Server 2003 公用文件夹复制"(http://go.microsoft.com/fwlink/?LinkId=47595)。


Replication Long Backfill Request Timeout Retry 值已更改
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Replication Long Backfill Request Timeout Retry 项是否已从默认值修改为其他值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Long Backfill Request Timeout Retry

如果 Exchange Server 分析工具发现 Replication Long Backfill Request Timeout Retry 存在，则会显示非默认配置消息。

默认情况下，Replication Long Backfill Request Timeout Retry 不存在。当公用文件夹存储确定自己尚未收到所复制的文件夹或层次结构的所有更新，并且必须从另一个存储中检索缺少的更新时，将发生回填。

为了使回填过程顺利执行，Exchange Server 在回填数组中存储了缺少的更新的相关信息。回填数组在指定的时间（称为回填超时）以内存储此信息。如果在此时间内缺少的更新在后续的复制邮件中到达，则会从回填数组中删除这些缺少的更新。下表列出了默认的回填超时值，该值取决于缺少的更新所在的位置，以及此前它们是否已被请求过。

请求类型 | 内容存在于本地站点的存储中 | 内容存在于远程站点的存储中
初始回填 | 6 小时 | 12 小时
第一次回填重试 | 12 小时 | 24 小时
后续回填重试 | 24 小时 | 48 小时

如果在回填超时到期时仍然缺少更新，Exchange Server 2003 将创建一个或多个回填请求，并确定将哪些服务器用作回填来源。

为了选择某一台或多台服务器作为回填来源，Exchange Server 2003 将首先创建一个包含该文件夹的副本的所有服务器的列表，然后按照下面的一系列标准对该列表进行排序：

  • 按照服务器状态排序 已停机或不可用的服务器放在列表的末尾。

  • 按照首选的回填服务器（如果有）排序 该功能只在 Exchange Server 2003 和更高版本中可用。Exchange Server 2003 通过检查 Active Directory® 目录服务中的公用文件夹存储对象来确定首选的回填服务器。此设置很少使用。大多数情况下，如果 Exchange Server 2003 自动选择回填服务器，则回填过程的工作效率是最高的。大多数 Exchange Server 2003 部署都不需要首选的回填服务器。Microsoft 产品支持服务可以提供一个相应的脚本，该脚本可以根据部署要求设置首选的回填服务器。

  • 按照传输开销排序（从最低到最高） 同一站点中的服务器优先于远程站点中的服务器。服务器的传输开销是由 Exchange Server 2003 路由引擎计算的，通常用于计算最有效的邮件传递途径。注意，在 Exchange Server 2003 之前的 Exchange 版本中，传输开销的优先级较低，并且只在 Exchange 版本和可用更改数之后才被考虑。

  • 按照 Exchange 版本排序（从最新到最旧）

  • 按照服务器上可用的必要更改数排序（从最大到最小） 从列表中排除不缺少任何更改的服务器。

如果某个服务器没有所有必需的更改，Exchange Server 2003 会选择已排序列表中的下一个服务器，并也将回填请求发送到该服务器。重复此过程，直到已经请求了所有的更改。该功能只在 Exchange Server 2003 和更高版本中可用；如果没有任何一台服务器存放了特定文件夹的所有缺少的更新，则早期版本的 Exchange 将每次向一台服务器发送回填请求。每次请求后，早期版本的 Exchange 都将等待重试超时（从 24 小时到 48 小时不等）过期，然后才发送下一个请求。

如果选定的服务器未对回填请求做出响应，存储会将该服务器标记为已停机，并重复选择过程。标记为停机的服务器将被排到列表的末尾。

Replication Long Backfill Request Timeout Retry 值代表在对同一个 Exchange 站点中不可用的数据发送回填请求时，以及该请求是上一个回填请求的重试时，公用文件夹存储所使用的超时值。该值（秒）必须在 900 和 2592000 秒（30 天）之间；默认值是 172800 秒（48 小时）。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

重置 Replication Long Backfill Request Timeout Retry 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>

  3. 检查或编辑 Replication Long Backfill Request Timeout Retry 的值。

    该注册表项的值以秒为单位。若要恢复默认值，应当删除 Replication Long Backfill Request Timeout Retry，并重新启动 Microsoft Exchange Information Store 服务。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关公用文件夹复制的详细信息，请参阅"使用 Exchange Server 2003 存储"中的"控制 Exchange Server 2003 公用文件夹复制"(http://go.microsoft.com/fwlink/?LinkId=47595)。


已启用在启动时复制邮件
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Exchange 是否已配置为针对公用文件夹层次结构生成状态请求消息：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Public-<Public Information Store GUID>\Enable Replication Messages At Startup

如果 Exchange Server 分析工具发现 Enable Replication Messages At Startup 存在并已配置，则显示非默认配置消息。

Exchange Server 5.5 中，具有公用文件夹存储的每台计算机每晚都发送状态请求邮件，以确定公用文件夹层次结构的状态。但 Exchange 2000 Server 和 Exchange Server 2003 不会执行此操作。通常 Exchange 2000 Server 和 Exchange Server 2003 在公用文件夹存储的生存期内只发送一次状态请求邮件；并在创建存储时发送。

但是，某些情况下，可能需要生成状态请求邮件。例如，如果在 Exchange 2000 Server 或 Exchange Server 2003 计算机上不能复制公用文件夹层次结构，或者复制公用文件夹层次结构的速度很慢，则生成状态请求邮件可能会允许继续复制公用文件夹层次结构。如果在创建公用文件夹存储时发送的初始状态请求邮件被丢弃且未得到确认，或者将该邮件发送到了层次结构非常不完整的服务器，则复制公用文件夹层次结构可能会发生问题。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

查看或修改老化计时注册表值

  1. 打开注册表编辑器，例如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Public-<Public Information Store GUID>

  3. 检查或（如果需要）更改 Enable Replication Messages At Startup 值。必须将 REG_DWORD 值设置为 1，以使其生效。如果将此值设为 0（默认设置），则在启动公用信息存储时不会发送状态请求邮件。

  4. 如果作了某些更改，请关闭注册表编辑器，然后卸除并重新装入公用信息存储，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关公用文件夹复制状态邮件和 Enable Replication Messages At Startup 注册表值的详细信息，请参阅以下知识库文章：

  • 321082"XADM:How to Send Replication Status Request Messages in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=321082)

  • 842273"How to troubleshoot public folder replication problems in Exchange 2000 Server and in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=842273)


Replication Short Backfill Request Delay 值已更改
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Replication Short Backfill Request Delay 项是否已从默认值修改为其他值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Short Backfill Request Delay

如果 Exchange Server 分析工具发现 Replication Short Backfill Request Delay 存在，则会显示非默认配置消息。

默认情况下，Replication Short Backfill Request Delay 不存在。当公用文件夹存储确定自己尚未收到所复制的文件夹或层次结构的所有更新，并且必须从另一个存储中检索缺少的更新时，将发生回填。

为了使回填过程顺利执行，Exchange Server 在回填数组中存储了缺少的更新的相关信息。回填数组在指定的时间（称为回填超时）以内存储此信息。如果在此时间内缺少的更新在后续的复制邮件中到达，则会从回填数组中删除这些缺少的更新。下表列出了默认的回填超时值，该值取决于缺少的更新所在的位置，以及此前它们是否已被请求过。

请求类型 | 内容存在于本地站点的存储中 | 内容存在于远程站点的存储中
初始回填 | 6 小时 | 12 小时
第一次回填重试 | 12 小时 | 24 小时
后续回填重试 | 24 小时 | 48 小时

如果在回填超时到期时仍然缺少更新，Exchange Server 2003 将创建一个或多个回填请求，并确定将哪些服务器用作回填来源。

为了选择将某一台或多台服务器作为回填来源，Exchange Server 2003 将首先创建一个由拥有文件夹副本的所有服务器组成的列表，然后按照下面的标准序列对该列表进行排序：

  • 按照服务器状态排序 已停机或不可用的服务器放在列表的末尾。

  • 按照首选的回填服务器（如果有）排序 该功能只在 Exchange Server 2003 和更高版本中可用。Exchange Server 2003 通过检查 Active Directory® 目录服务中的公用文件夹存储对象来确定首选的回填服务器。此设置很少使用。大多数情况下，如果 Exchange Server 2003 自动选择回填服务器，则回填过程的工作效率是最高的。大多数 Exchange Server 2003 部署都不需要首选的回填服务器。Microsoft 产品支持服务可以提供一个相应的脚本，该脚本可以根据部署要求设置首选的回填服务器。

  • 按照传输开销排序（从最低到最高） 同一站点中的服务器优先于远程站点中的服务器。服务器的传输开销是由 Exchange Server 2003 路由引擎计算的，通常用于计算最有效的邮件传递途径。注意，在 Exchange Server 2003 之前的 Exchange 版本中，传输开销的优先级较低，并且只在 Exchange 版本和可用更改数之后才被考虑。

  • 按照 Exchange 版本排序（从最新到最旧）

  • 按照服务器上可用的必要更改数排序（从最大到最小） 从列表中丢弃不缺少任何更改的服务器。

如果某个服务器没有所有必需的更改，Exchange Server 2003 会选择已排序列表中的下一个服务器，并也将回填请求发送到该服务器。重复此过程，直到已经请求了所有的更改。该功能只在 Exchange Server 2003 和更高版本中可用；如果没有任何一台服务器存放了特定文件夹的所有缺少的更新，则早期版本的 Exchange 将每次向一台服务器发送回填请求。每次请求后，早期版本的 Exchange 都将等待重试超时（从 24 小时到 48 小时不等）过期，然后才发送下一个请求。

如果选定的服务器未对回填请求做出响应，存储会将该服务器标记为已停机，并重复选择过程。Servers marked as down drop to the end of the list.

Replication Short Backfill Request Delay 值代表在对同一个 Exchange 站点中的可用数据发送回填请求之前公用文件夹存储所延迟的时间长度。该值（秒）必须在 900 和 2592000 秒（30 天）之间；默认值是 21600 秒（6 小时）。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

重置 Replication Short Backfill Request Delay 注册表项

  1. 打开注册表编辑器，例如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>

  3. 检查或编辑 Replication Short Backfill Request Delay 的值。

    该注册表项的值以秒为单位。若要恢复默认值，应当删除 Replication Short Backfill Request Delay，并重新启动 Microsoft Exchange Information Store 服务。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关公用文件夹复制的详细信息，请参阅"使用 Exchange Server 2003 存储"中的"控制 Exchange Server 2003 公用文件夹复制"(http://go.microsoft.com/fwlink/?LinkId=47595)。


Replication Short Backfill Request Timeout 值已更改
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Replication Short Backfill Request Timeout 项是否已从默认值修改为其他值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Short Backfill Request Timeout

如果 Exchange Server 分析工具发现 Replication Short Backfill Request Timeout 存在，则会显示非默认配置消息。

默认情况下，Replication Short Backfill Request Timeout 不存在。当公用文件夹存储确定自己尚未收到所复制的文件夹或层次结构的所有更新，并且必须从另一个存储中检索缺少的更新时，将发生回填。

为了使回填过程顺利执行，Exchange Server 在回填数组中存储了缺少的更新的相关信息。回填数组在指定的时间（称为回填超时）以内存储此信息。如果在此时间内缺少的更新在后续的复制邮件中到达，则会从回填数组中删除这些缺少的更新。下表列出了默认的回填超时值，该值取决于缺少的更新所在的位置，以及此前它们是否已被请求过。

请求类型 | 内容存在于本地站点的存储中 | 内容存在于远程站点的存储中
初始回填 | 6 小时 | 12 小时
第一次回填重试 | 12 小时 | 24 小时
后续回填重试 | 24 小时 | 48 小时

如果在回填超时到期时仍然缺少更新，Exchange Server 2003 将创建一个或多个回填请求，并确定将哪些服务器用作回填来源。

为了选择某一台或多台服务器作为回填来源，Exchange Server 2003 将首先创建一个包含该文件夹的副本的所有服务器的列表，然后按照下面的一系列标准对该列表进行排序：

  • 按照服务器状态排序 已停机或不可用的服务器放在列表的末尾。

  • 按照首选的回填服务器（如果有）排序 该功能只在 Exchange Server 2003 和更高版本中可用。Exchange Server 2003 通过检查 Active Directory® 目录服务中的公用文件夹存储对象来确定首选的回填服务器。此设置很少使用。大多数情况下，如果 Exchange Server 2003 自动选择回填服务器，则回填过程的工作效率是最高的。大多数 Exchange Server 2003 部署都不需要首选的回填服务器。Microsoft 产品支持服务可以提供一个相应的脚本，该脚本可以根据部署要求设置首选的回填服务器。

  • 按照传输开销排序（从最低到最高） 同一站点中的服务器优先于远程站点中的服务器。服务器的传输开销是由 Exchange Server 2003 路由引擎计算的，通常用于计算最有效的邮件传递途径。注意，在 Exchange Server 2003 之前的 Exchange 版本中，传输开销的优先级较低，并且只在 Exchange 版本和可用更改数之后才被考虑。

  • 按照 Exchange 版本排序（从最新到最旧）

  • 按照服务器上可用的必要更改数排序（从最大到最小） 从列表中排除不缺少任何更改的服务器。

如果某个服务器没有所有必需的更改，Exchange Server 2003 会选择已排序列表中的下一个服务器，并也将回填请求发送到该服务器。重复此过程，直到已经请求了所有的更改。该功能只在 Exchange Server 2003 和更高版本中可用；如果没有任何一台服务器存放了特定文件夹的所有缺少的更新，则早期版本的 Exchange 将每次向一台服务器发送回填请求。每次请求后，早期版本的 Exchange 都将等待重试超时（从 24 小时到 48 小时不等）过期，然后才发送下一个请求。

如果选定的服务器未对回填请求做出响应，存储会将该服务器标记为已停机，并重复选择过程。标记为停机的服务器将被排到列表的末尾。

Replication Short Backfill Request Timeout 值代表公用文件夹存储在尝试对相同 Exchange 站点中可用的数据发送回填请求时所使用的超时值。该值（秒）必须在 900 和 2592000 秒（30 天）之间；默认值是 43200 秒（12 小时）。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

重置 Replication Short Backfill Request Timeout 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>

  3. 检查或编辑 Replication Short Backfill Request Timeout 的值。

    该注册表项的值以秒为单位。若要恢复默认值，应当删除 Replication Short Backfill Request Timeout，并重新启动 Microsoft Exchange Information Store 服务。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关公用文件夹复制的详细信息，请参阅"使用 Exchange Server 2003 存储"中的"控制 Exchange Server 2003 公用文件夹复制"(http://go.microsoft.com/fwlink/?LinkId=47595)。


Replication Short Backfill Request Timeout Retry 值已更改
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Replication Short Backfill Request Timeout Retry 项是否已从默认值修改为其他值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Short Backfill Request Timeout Retry

如果 Exchange Server 分析工具发现 Replication Short Backfill Request Timeout Retry 存在，则会显示非默认配置消息。

默认情况下，Replication Short Backfill Request Timeout Retry 不存在。当公用文件夹存储确定自己尚未收到所复制的文件夹或层次结构的所有更新，并且必须从另一个存储中检索缺少的更新时，将发生回填。

为了使回填过程顺利执行，Exchange Server 在回填数组中存储了缺少的更新的相关信息。回填数组在指定的时间（称为回填超时）以内存储此信息。如果在此时间内缺少的更新在后续的复制邮件中到达，则会从回填数组中删除这些缺少的更新。下表列出了默认的回填超时值，该值取决于缺少的更新所在的位置，以及此前它们是否已被请求过。

请求类型 | 内容存在于本地站点的存储中 | 内容存在于远程站点的存储中
初始回填 | 6 小时 | 12 小时
第一次回填重试 | 12 小时 | 24 小时
后续回填重试 | 24 小时 | 48 小时

如果在回填超时到期时仍然缺少更新，Exchange Server 2003 将创建一个或多个回填请求，并确定将哪些服务器用作回填来源。

为了选择某一台或多台服务器作为回填来源，Exchange Server 2003 将首先创建一个包含该文件夹的副本的所有服务器的列表，然后按照下面的一系列标准对该列表进行排序：

  • 按照服务器状态排序 已停机或不可用的服务器放在列表的末尾。

  • 按照首选的回填服务器（如果有）排序 该功能只在 Exchange Server 2003 和更高版本中可用。Exchange Server 2003 通过检查 Active Directory® 目录服务中的公用文件夹存储对象来确定首选的回填服务器。此设置很少使用。大多数情况下，如果 Exchange Server 2003 自动选择回填服务器，则回填过程的工作效率是最高的。大多数 Exchange Server 2003 部署都不需要首选的回填服务器。Microsoft 产品支持服务可以提供一个相应的脚本，该脚本可以根据部署要求设置首选的回填服务器。

  • 按照传输开销排序（从最低到最高） 同一站点中的服务器优先于远程站点中的服务器。服务器的传输开销是由 Exchange Server 2003 路由引擎计算的，通常用于计算最有效的邮件传递途径。注意，在 Exchange Server 2003 之前的 Exchange 版本中，传输开销的优先级较低，并且只在 Exchange 版本和可用更改数之后才被考虑。

  • 按照 Exchange 版本排序（从最新到最旧）

  • 按照服务器上可用的必要更改数排序（从最大到最小） 从列表中排除不缺少任何更改的服务器。

如果某个服务器没有所有必需的更改，Exchange Server 2003 会选择已排序列表中的下一个服务器，并也将回填请求发送到该服务器。重复此过程，直到已经请求了所有的更改。该功能只在 Exchange Server 2003 和更高版本中可用；如果没有任何一台服务器存放了特定文件夹的所有缺少的更新，则早期版本的 Exchange 将每次向一台服务器发送回填请求。每次请求后，早期版本的 Exchange 都将等待重试超时（从 24 小时到 48 小时不等）过期，然后才发送下一个请求。

如果选定的服务器未对回填请求做出响应，存储会将该服务器标记为已停机，并重复选择过程。标记为停机的服务器将被排到列表的末尾。

Replication Short Backfill Request Timeout Retry 值代表在对同一个 Exchange 站点中可用的数据发送回填请求时，以及该请求是上一个回填请求的重试时，公用文件夹存储所使用的超时值。该值（秒）必须在 900 和 2592000 秒（30 天）之间；默认值是 86400 秒（24 小时）。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

重置 Replication Short Backfill Request Timeout Retry 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>

  3. 检查或编辑 Replication Short Backfill Request Timeout Retry 的值。

    该注册表项的值以秒为单位。若要恢复默认值，应当删除 Replication Short Backfill Request Timeout Retry，并重新启动 Microsoft Exchange Information Store 服务。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关公用文件夹复制的详细信息，请参阅"使用 Exchange Server 2003 存储"中的"控制 Exchange Server 2003 公用文件夹复制"(http://go.microsoft.com/fwlink/?LinkId=47595)。


保留增量大小设置
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-30

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已设置 Reserve Increment KB 的值：HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server 分析工具还会查询 Active Directory® 目录服务，以确定对象类别为 msExchExchangeServer 的所有对象的 serialNumber 属性值。如果字符串值包含"Version 5.5"，说明计算机运行的是 Microsoft Exchange Server 5.5。如果字符串值包含"Version 6.0"，说明计算机运行的是 Microsoft Exchange 2000 Server。如果字符串值包含"Version 6.5"，则说明计算机运行的是 Microsoft Exchange Server 2003。如果字符串值包含"Version 8.0"，则说明计算机运行的是 Microsoft Exchange Server 2007。

如果 Exchange Server 分析工具发现在运行 Exchange Server 2003 的计算机上存在 Reserve Increment KB 注册表值，则显示非默认配置消息。

Reserve Increment KB 注册表值会覆盖 Microsoft Windows® 中本机内存堆的值。Windows 中包括进程范围内的堆管理器，此管理器可以处理所有进程的内存操作。每次进程进行实例化时，都会为此进程创建一个默认堆（称为进程堆）。进程中加载的程序或模块还可以在需要时创建其他堆。Microsoft Exchange 信息存储服务 Store.exe 是一个可在需要时创建其他堆的进程示例。默认情况下，Store.exe 将保留给堆空间的初始内存设置为物理 RAM 的 20%。Reserve Increment KB 值将保留给堆的初始内存更改为物理内存的 10%。

Reserve Increment KB 注册表值仅在某些特定情况下有用。此外，应仅在 Microsoft 产品支持服务的建议和指导下设置此值。不正确的设置或不正确地使用此值可能会导致性能下降，并增加虚拟内存碎片。如果在没有咨询 Microsoft 产品支持服务的情况下设置了此值，请考虑使用以下步骤将其删除。

还原为默认配置

  1. 打开注册表编辑器，例如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右侧窗格中，删除 Reserve Increment KB 值。

  4. 关闭注册表编缉器，并重新启动"Microsoft Exchange 信息存储"服务，以使更改生效。

有关如何优化 Exchange Server 2003 的详细信息，请参阅下列 Microsoft 知识库文章：

  • 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372"如何在 Exchange Server 2003 中优化内存使用"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)


RPC 缓冲区压缩已禁用
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定远程过程调用 (RPC) 缓冲区压缩是否已禁用：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc Packing Enabled

如果 Exchange Server 分析工具发现 Rpc Packing Enabled 注册表项的数值数据设置为 0，Exchange Server 分析工具将显示非默认配置消息。Rpc Packing Enabled 注册表项在数值数据设置为 0 时禁用。

Rpc Packing Enabled 注册表项的数值数据是管理员在配置 Microsoft Office Outlook® 2003 和 Exchange Server 2003 之间的 RPC 压缩时可以添加的三个注册表项之一。

Outlook 2003 可以请求 96 KB 的数据缓冲区。但是，在 Exchange Server 2003 压缩了数据之后，数据缓冲区可能明显小于 Outlook 2003 所请求的大小。

Exchange Server 2003 支持缓冲区压缩，以便支持不同的压缩率并保持缓冲区满以提高效率。

Rpc Packing Enabled 注册表项启用时，Exchange Server 2003 会不断将压缩的数据添加到缓冲区中，直到缓冲区满为止。对于每个数据请求，Outlook 2003 可以下载的数据量要远多于早期版本的 Outlook，原因如下：

  • Outlook 2003 可以请求更大的缓冲区。

  • Exchange Server 2003 支持缓冲区压缩。

Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。但是，如果要还原默认配置，可以删除 Rpc Packing Enabled 注册表项。也可以将 Rpc Packing Enabled 注册表项的数据数值设置为 1，以启用 RPC 缓冲区压缩。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
还原默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

    • 若要删除该项，请删除 Rpc Packing Enabled 值。

    • 要保留该项并启用 RPC 缓冲区压缩，请双击 Rpc Packing Enabled，再将值设置为 1，然后单击"确定"。

  3. 关闭注册表编辑器。

Microsoft Exchange 信息存储服务可以在几分钟内检测到更改。不需要重新启动计算机。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关通过设置注册表项来配置 Outlook 客户端和 Exchange Server 2003 之间的 RPC 压缩的详细信息，请参阅知识库文章 825371"Modify Remote Procedure Call Compression in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=825371)。


RPC Compression Minimum Size 为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定远程过程调用 (RPC) 压缩的最小数据包大小：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc Compression Minimum Size

如果 Exchange Server 分析工具发现 Rpc Compression Minimum Size 的值大于 0，则会显示非默认配置消息。

默认情况下，将压缩在 Microsoft Office Outlook® 2003 或 Outlook 2007 与 Exchange Server 2003 或 Exchange Server 2007 之间移动的所有 RPC 数据，而与其大小无关。在某些方案中，您可能需要控制 RPC 压缩。例如，如果要通过查看在网络上发送的数据包来解决连接问题，RPC 压缩可能会使分析很难进行，因为您只能看到跟踪的压缩数据。

若要配置 RPC 压缩设置，可以在系统设置中添加三个注册表项值：

  • Rpc Compression Minimum Size

  • Rpc Compression Enabled

  • Rpc Packing Enabled

Rpc Compression Minimum Size 注册表值确定激活压缩的 RPC 数据包最小字节数。如果此注册表项不存在，将使用默认值 1,024 字节。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 删除 Rpc Compression Minimum Size 注册表项。如果 Rpc Compression Enabled 和 Rpc Packing Enabled 注册表项存在，将这两项也删除。

  4. 关闭注册表编辑器，然后重新启动 Exchange 服务器，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关控制 RPC 压缩的详细信息，请参阅知识库文章 825371"Modify Remote Procedure Call Compression in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=825371)。


RpcEtwTracing 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定数值数据：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\RpcEtwTracing

如果 Exchange Server 分析工具发现 RpcEtwTracing 注册表项的数值数据设置为 1，Exchange Server 分析工具将显示非默认配置消息。

RpcEtwTracing 注册表项的数值数据只能用于解决 Microsoft Office Outlook® 2003 和 Exchange Server 之间的网络问题。如果当前没有在解决问题，建议禁用 RpcEtwTracing 注册表项。

Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。但是，如果要还原默认配置，可以删除 RpcEtwTracing 注册表项。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
还原默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 删除 RpcEtwTracing 值。

  4. 关闭注册表编辑器。

Microsoft Exchange 信息存储服务可以在几分钟内检测到更改。不需要重新启动计算机。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


服务器定义的存储组少于四个，但是定义的邮箱存储多于四个
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以对运行 Exchange Server 2003 的服务器上的 StorageGroup 对象和 MailboxGroup 对象进行计数。如果 Exchange Server 分析工具确定 StorageGroup 对象的总数小于四并且 MailboxStore 对象的总数大于四，则显示错误。

如果使用的是 Exchange Server 2003 标准版，则每个 Exchange Server 计算机可以有一个存储组，支持一个邮箱存储和一个公用文件夹存储。如果使用的是 Exchange Server 2003 企业版，则每个服务器可以有多达四个存储组，每个存储组可以支持多达五个数据库（邮箱存储或公用文件夹存储）。

为运行 Exchange Server 2003 企业版的计算机配置存储组而推荐的最佳做法是，为每个新的数据库添加附加的存储组，直到创建了最大存储组数。可以将 Exchange Server 存储拓扑中的邮箱负载分散到尽可能多的存储组上。此类拓扑具有下列优势：

  • 提高了存储拓扑的可靠性。

  • 增强了存储拓扑的可恢复性。

  • 可以更好地管理驱动器 I/O。

在运行 Exchange Server 2003 企业版的服务器上，如果存储组少于四个，邮箱存储多于四个，请执行下列步骤将邮箱分散到尽可能多的存储组上。

解决此错误

  1. 在 Exchange 系统管理器中，选择报告此错误的服务器。记录该服务器上的存储组和邮箱存储的数目。记录包含多个邮箱存储的存储组。

  2. 在运行 Exchange Server 2003 企业版的计算机上包含四个存储组之前，需要创建其他的存储组。有关如何创建新的存储组的信息，请参阅"Exchange Server 2003 管理指南"中的"Adding a Storage Group"（英文）(http://go.microsoft.com/fwlink/?LinkId=47617)。

  3. 在创建的每个新存储组中创建新的邮箱存储。有关如何创建新的邮箱存储的信息，请参阅"Exchange Server 2003 管理指南"中的"Adding a Mailbox Store"（英文）(http://go.microsoft.com/fwlink/?LinkId=47617)。

  4. 将邮箱从包含多个邮箱存储的存储组的一个邮箱存储中移动到新创建的存储组的邮箱存储中。使用"移动邮箱向导"移动邮箱。有关如何使用"移动邮箱向导"的详细信息，请参阅"Exchange Server 2003 部署指南"的"Migrating from Exchange Server 5.5 to Exchange Server 2003"（英文）一章中的"Using Exchange Task Wizard to Move Mailboxes"（英文）(http://go.microsoft.com/fwlink/?LinkId=47569)。

有关如何在 Exchange Server 2003 中配置存储组的详细信息，请参阅 Microsoft 知识库文章 890699"How to configure storage groups in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=890699)。

有关如何配置存储组的信息，请参阅"Exchange Server 2003 High Availability Guide"（英文）的"Planning a Reliable Back-End Storage Solution"（英文）中的存储组配置部分 (http://go.microsoft.com/fwlink/?LinkId=47571)。

有关帮助您最大程度地提高可用性、容错能力和性能的总体建议，请参阅"Optimizing Storage for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=49324)。


数据库与流式文件之间的签名差异
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具已确定在 Exchange 数据库 (.edb) 文件与其相应的 Exchange 流式数据库 (.stm) 文件之间存在签名差异。

Exchange 2000 Server 和 Exchange Server 2003 中的每个数据库由两个文件组成：.edb MAPI 数据库文件和 .stm 流式数据库文件。匹配的文件对共享公用的数据库签名。如果数据库签名不匹配，则文件也不匹配。

应将 .edb 文件和 .stm 文件视作单个文件。这两个文件应始终一起移动或复制。

更正此错误

  • 调查数据库文件的历史。很可能已手动复制、移动或删除了文件。必须先更正此错误，才能恢复数据库。

  • 如果找不到匹配的 .edb 文件和 .stm 文件，也许可以使用 Eseutil.exe 仅修复 .edb 文件，并使用带 /createstm 开关的 Eseutil 放弃 .stm 文件。此方法将导致流式数据库中的所有信息丢失。

    注意：
    如果所有数据库用户使用 MAPI 客户端（例如 Microsoft Office Outlook®）连接到数据库上，则流式数据库中存储的信息最少。如果用户使用 POP3、IMAP 或 Outlook Web Access 客户端连接到数据库上，则流式数据库中包含部分或全部用户邮箱内容。

有关如何修复 Exchange 数据库的详细信息，请参阅 Microsoft 知识库文章 812357"XADM：在使用 Eseutil /p 工具修复 Exchange 数据库后维护该数据库"(http://support.microsoft.com/kb/812357/zh-cn)。


默认收件人策略中未定义 SMTP 地址
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2006-12-03

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定是否在 Exchange Server 组织中默认收件人策略的 gatewayProxy 属性中指定了 SMTP 地址。如果 Exchange Server 分析工具发现 gatewayProxy 属性不包含 SMTP 地址，则 Exchange Server 分析工具将显示错误。

此错误属于严重错误。必须将 SMTP 地址（例如 SMTP:@contoso.com）添加到 Exchange Server 组织中默认收件人策略的 gatewayProxy 属性中。默认收件人策略必须包含 SMTP 地址。如果默认收件人策略不包含 SMTP 地址，则 Microsoft Exchange 信息存储服务在重新启动之后将无法进行初始化。下一次重新启动 Microsoft Exchange 信息存储服务时，Exchange Server 组织中的所有 Exchange 服务器都会出现此故障。

警告：
在使用 Active Directory 服务接口 (ADSI) Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003、Exchange Server 2003 和/或 Exchange Server 2007 才能解决。修改 Active Directory 对象的属性的风险由您自己承担。
将 SMTP 地址添加到默认收件人策略的 gatewayProxy 属性中

  1. 从 Microsoft Windows® 2000 支持工具或 Windows Server 2003 支持工具启动 ADSI Edit 工具。

  2. 展开下列节点：

    • 配置容器

    • 配置

    • 服务

    • Microsoft Exchange

    • 组织名称

    • 收件人策略

  3. 在详细信息窗格中，右键单击 CN=Default Policy，再单击"属性"。

  4. 在"属性"框中，双击 gatewayProxy。

  5. 在"多值字符串编辑器"对话框的"要添加的值"字段中输入 SMTP:@domain_name.com，再单击"添加"。

    注意：
    输入的语法非常重要。在输入 Exchange Server 组织的域名之前，必须先输入 SMTP:@。此字符串中没有空白字符。

  6. 单击"确定"，再单击"应用"，然后关闭 ADSI Edit。

  7. 等待至少 15 分钟进行复制。


存储 RPC prorate 注册表参数未设置为正确值
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取三个注册表项，以确定它们的值是否已从默认值修改为其他值。这三项都是 DWORD 值，可以在以下位置找到它们：

HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Image File Execution Options\STORE.EXE\RpcThreadPoolThrottle

这些项有下列名称和默认值：

DWORD 值 默认十进制值
  • ProrateStart
  • 40
  • ProrateMax
  • 10,000
  • ProrateFactor
  • 100

如果 Exchange Server 分析工具发现任何一个上述默认值已更改，则会显示非默认配置消息。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认值

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\Software\Microsoft\WindowsNT\CurrentVersion\Image File Execution Options\STORE.EXE\RpcThreadPoolThrottle

  3. 在右侧窗格中，双击其值已更改的项，并将其配置为它的默认值。

  4. 如果多个值被更改，请重复步骤 3。

  5. 关闭注册表编缉器，并重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关存储进程的线程的详细信息，请参阅知识库文章 267255"Store.exe Threads Use Up Available Memory"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=267255)。


存储工作目录丢失或不正确
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-30

Microsoft® Exchange Server 分析工具读取以下注册表项，以验证 Microsoft Exchange 信息存储服务的工作目录。

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Working Directory

如果符合以下条件，Exchange Server 分析工具将显示警告：

  • 指定为工作目录的目录不存在。

  • 如果运行的是 Exchange 2000 Server、Exchange Server 2003 或 Exchange Server 2007。

Exchange Server 使用工作目录进行临时存储。例如，Exchange Server 在邮件转换过程中使用工作目录。进行碎片整理期间，Exchange Server 还使用工作目录存储临时数据库。如果未正确指定工作目录，可能会出现下列问题：

  • 包含附件的邮件可能会堵塞 SMTP 本地传递队列。

  • 接收到的邮件可能不包含附件。

  • 邮件可能无法成功传递。

默认情况下，Exchange 2000 Server 和 Exchange Server 2003 将工作目录设置为 Exchange Server 安装目录下的 mdbdata 目录。例如，如果将 Exchange Server 安装在 C:\Program Files\Exchsrvr 目录中，Exchange Server 则将工作目录设置为 C:\Program Files\Exchsrvr\mdbdata。

默认情况下，Exchange Server 2007 将工作目录设置为 Exchange Server 安装目录下的邮箱数据库目录。例如，如果将 Exchange Server 安装在 C:\Program Files\Exchange Server 目录中，Exchange Server 2007 则会将工作目录设置为 C:\ Program Files\Exchange Server\Mailbox\MDBTemp。

若要解决此警告问题，请将工作目录指定为 Exchange 服务器上现有的目录。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
使用 regedit 指定工作目录

  1. 启动注册表编辑器 (regedit)。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 使用 Microsoft Exchange 信息存储服务的正确工作目录（例如 C:\Program Files\Exchsrvr\mdbdata）更新 Working Directory 注册表值。

    注意：
    此更改不需要重新启动 Microsoft Exchange 信息存储服务。

  4. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Working Directory 注册表值的详细信息，请参阅知识库文章 298415"未按照预期传送具有附件的邮件并且记录了事件 ID 12003 和 327 消息"(http://support.microsoft.com/kb/298415/zh-cn)。


已设置禁止将外出邮件发送到通讯组列表
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-02-27

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否禁止将外出邮件发送到通讯组列表：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\SuppressOOFsToDistributionLists

如果 Exchange Server 分析工具发现 SuppressOOFsToDistributionLists 的值大于 0，则显示非默认配置消息。

将邮件发送到启用了"外出助理"的邮箱时，发件人会接收到"收件人"或"抄送"字段没有地址的邮件，但此邮件的"密件抄送"字段中具有通讯组列表，"外出"邮件将发送到"密件抄送"字段中的通讯组列表。

如果向收件人发送邮件，仅在"密件抄送"字段输入收件人地址，而不在通讯组列表中输入，并且收件人打开了"外出助理"，则收件人的邮箱存储仍将发送"外出"邮件，尽管设置了 SuppressOOFsToDistributionLists 注册表值。该限制仅适用于在"密件抄送"字段中输入了收件人地址，而"收件人"和"抄送"字段皆为空白的情况。如果"收件人"或"抄送"字段中至少有一个用户，则 Exchange Server 计算机上的注册表参数将禁止"密件抄送"字段中列出的收件人生成"外出"邮件。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

修改生成"外出"邮件的行为

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 右键单击"ParametersSystem"，指向"新建"，再单击"DWORD 值"。

  4. 将新值命名为 SuppressOOFsToDistributionLists。

  5. 右键单击"SuppressOOFsToDistributionLists"，再单击"修改"。

  6. 在"数值数据"框中，输入 1，再用鼠标单击"确定"。

  7. 关闭注册表编缉器，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 SuppressOOFsToDistributionLists 注册表值的详细信息，请参阅知识库文章 825370"Out-of-Office Messages Are Sent to Distribution Lists That Are in the BCC Field"（将"外出"邮件发送到"密件抄送"字段中的通讯组列表）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=825370)。


用于控制允许受损邮件通过存储次数的阈值已更改
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-08

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 PoisonThreshold 的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<ExchangeServerName> \Private- <PrivateInformationStoreGUID>

如果 Exchange Server 分析工具确定 PoisonThreshold 的值不等于 2，则会显示非默认配置消息。

Exchange Server 2003 Service Pack 1 以后的 Exchange Server 版本实现了一些性能，有助于防止受损邮件或坏邮件导致 Microsoft Exchange 信息存储服务意外停止或无法成功启动。

在 Exchange Server 2003 Service Pack 1 或更高版本中，系统将跟踪在将 MAPI 格式转换为 MIME 格式的过程中导致 Microsoft Exchange 信息存储服务意外停止的邮件。发生崩溃时，受损邮件的邮件 ID 存储在注册表中。如果受损邮件导致存储发生三次意外停止，那么，当 Microsoft Exchange 信息存储服务第四次重新启动时，将用该信息防止该邮件被再次处理。

当 Microsoft Exchange 信息存储服务由于受损邮件而意外停止时，将在以下位置创建 PoisonIDs 注册表值：

HKLM\System\CurrentControlSet\Services\MSExchangeIS \<ExchangeServerName> \Private- <PrivateInformationStoreGUID>

另外，管理员可以创建 PoisonThreshold 注册表项。PoisonThreshold 项用于控制在将邮件添加到 PoisonIDs 注册表项之前允许邮件通过 Exchange 信息存储的最大次数。默认情况下，该阈值是 2。若要触发该行为，必须超过阈值。因此，在该邮件被阻止之前，Microsoft Exchange 信息存储服务可以因为受损邮件而停止 3 次。例如，如果 3 次崩溃都涉及某邮件，则该邮件将被阻止，因为 3 超过了阈值 2。

将受损邮件事件写入注册表时，错误事件消息（事件 ID 为 9680 和 9681）将出现在应用程序事件日志中。Microsoft Exchange 信息存储服务成功启动之后，Exchange 会阻止该邮件，并试图发送它的未送达报告。在某些情况下，Exchange 可能无法发送未送达报告。在这样的情况下，被阻止的邮件可能留在队列中，直到过期为止。PoisonIDs 注册表项可以存放最多十个邮件 ID 值。如果超过限制数十，将添加新的受损邮件事件。包含最早崩溃日期的受损邮件事件会被删除。

注意：
对单个受损邮件进行错误排除的步骤超出了 Exchange Server 分析工具的处理范围。在某些情况下，Microsoft 产品支持服务可能能够帮助您解决单个受损邮件的问题。如果由于受损邮件而出现 Exchange Server 2003 或更高版本关机问题，在 Exchange Server 计算机上启用自动错误报告可能会有所帮助。错误报告数据可用来查找并修复所使用的软件中存在的问题。有关如何启用 Exchange 错误报告的详细信息，请参阅 Exchange 错误报告已禁用。

建议将 PoisonThreshold 的值改回它的默认值 2。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

更正此错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ExchangeServerName>\Private-<PrivateInformationStoreGUID>

  3. 在右侧窗格中，双击 PoisonThreshold。

  4. 在值数据中，输入 2（十进制）并单击"确定"。

  5. 关闭注册表编辑器，并重新启动"Microsoft Exchange 信息存储"服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


对存储进程启用了跟踪
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具检查注册表，以查看 Enable Tracing 注册表项是否与 Trace User LegacyDN 注册表值同时存在。这两个注册表值存在于下列注册表项的下面：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

如果 Exchange Server 分析工具发现这两个注册表项均存在并均已配置，则显示警告。

Enable Tracing DWORD 注册表值对 Microsoft Exchange 信息存储服务启用跟踪。跟踪用于解决 Exchange 存储的启动问题。启用跟踪会严重地影响性能。除非您在对问题进行故障排除，否则不应使用此注册表设置。可以通过添加 Trace User LegacyDN 注册表字符串值对特定的用户启用跟踪（筛选跟踪）。如果 Trace User LegacyDN 值不存在，将对所有用户启用跟踪。如果 Trace User LegacyDN 值存在，将仅仅对该项下面列出的特定用户进行跟踪。

如果未在 Exchange Server 计算机上执行故障排除，则这些注册表值不应当出现。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 删除 Enable Tracing 和 Trace User LegacyDN 注册表值。

  4. 关闭注册表编辑器，并重新启动计算机，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关在 Exchange 服务器上跟踪每个用户的详细信息，请参阅知识库文章"Per-User Tracing Feature Added to Exchange 2000 Server Service Pack 2 (SP2)"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296624)。


在 Microsoft Exchange 信息存储服务上对所有用户启用了跟踪
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2007-01-17

Microsoft® Exchange Server 分析工具读取注册表，以确定在以下注册表项下面是否存在 Enable Tracing 项：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

如果 Exchange Server 分析工具发现 Enable Tracing 注册表值存在并已配置，则会显示警告。

Enable Tracing DWORD 注册表值对 Microsoft Exchange 信息存储服务启用跟踪。跟踪用于解决存储启动问题。启用跟踪会严重地影响性能。除非要解决问题，否则不应使用此注册表设置。可以通过添加 Trace User LegacyDN 注册表字符串值对特定的用户启用跟踪。如果该值不存在，则意味着对所有用户启用跟踪。

如果不在 Exchange Server 计算机上执行故障排除，则该值不应当出现。

注意：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 删除 Enable Tracing 注册表值。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange 信息存储服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的详细信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关在 Exchange 服务器上跟踪每个用户的详细信息，请参阅知识库文章"Per-User Tracing Feature Added to Exchange 2000 Server Service Pack 2 (SP2)"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296624)。


事务日志文件名不够用
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具通过检查服务器磁盘上的日志文件来验证每个存储组的事务日志文件的工作状况。为了找到日志文件的位置，Exchange Server 分析工具查询 Active Directory® 目录服务。对于每个存储组对象（msExchStorageGroup 类）而言，日志文件的文件路径都存储在 msExchESEParamLogFilePath 属性中。

事务日志文件名包含标识日志文件顺序的十六进制连续编号。例如，默认的第一个存储组的第一个日志文件命名为 E0000001.log，第二个日志文件命名为 E0000002.log，依此类推。此序列一直可以到 E00FFFFF.log。Exchange 最多可以创建 1,030,000 个唯一的日志文件。但是，当 Exchange 到达序列的末尾时，如果受影响的存储组中的存储是在达到限制之后卸载的，那么这些存储将不再装入。如果保持装入，即使不会发生 Jet 操作，存储也不会卸载数据库。正常情况下，Exchange 要经过几年的时间才能达到此限制。

如果指定的服务器所使用的事务日志文件数超过 950000，则将显示此作为"警告"的消息。

如果指定的服务器所使用的事务日志文件数超过 1,020,000，则将显示此作为"错误"的消息。

为了使存储在达到此限制时可以正确地卸载数据库，Exchange Server 2003 Service Pack 1 中提供了一个修补程序。Service Pack 3 后的修补程序为 Exchange 2000 Server 提供，请参阅 Microsoft 知识库文章 830408"Exchange database stores remain mounted although all transaction logs that are available to a storage group have been used"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830408)。

如果 Exchange 尚未达到 1,030,000 个事务日志的限制，请尽快对服务器进行完全联机备份。有关对 Exchange 存储进行完全联机备份的详细信息，请参阅"Exchange 2003 灾难恢复操作指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=a58f49c5-1190-4fbf-aede-007a8f366b0e&displaylang=zh-cn)。

如果 Exchange 达到此限制，必须将所有现有的事务日志移至其他位置。然后，将生成一个新的日志文件序列，从 0x00001 开始。为了确保 Exchange 存储可以正确地卸载数据库，还必须要对您的 Exchange 版本应用适当的修补程序。

注意：
在移动事务日志之前，必须验证存储组中的所有数据库是否均处于"干净关闭"状态。
重要信息：
执行了下面的过程之后，所有以前的备份均将失效。这并不意味着备份无法还原。但是，备份无法再通过其他事务日志实现前滚。如果在删除事务日志之后必须还原以前的备份，只能将数据还原到创建新日志时的状态。

解决此问题

  1. 对于 Exchange Server 2003，请安装 Service Pack 1（位于 Exchange Server 下载网站 http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&DisplayLang=zh-cn）。

    - 或者 -

    对于 Exchange 2000 Server，请获取并安装 Microsoft 知识库文章 830408"Exchange database stores remain mounted although all transaction logs that are available to a storage group have been used"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830408) 中提到的修补程序。

  2. 在事务日志文件已满的存储组中，卸除所有数据库。若要这样做，请执行下列步骤：

    1. 打开 Exchange 系统管理器。

    2. 依次展开"管理组"、<管理组名称>、"服务器"、<服务器名称>、<存储组名称>。

    3. 在此存储组中用鼠标右键单击第一个存储，再单击"卸除存储"。对此存储组中的每个存储重复上述步骤。

  3. 验证存储组中的每个数据库是否均处于"干净关闭"状态。若要这样做，请执行下列步骤：

    1. 在 Exchange 系统管理器中，用鼠标右键单击事务日志文件已满的存储组中的第一个存储，再单击"属性"。

    2. 单击"数据库"选项卡，然后记下"Exchange 数据库"框和"Exchange 流式数据库"框中数据库文件的路径和文件名。每个 Exchange 数据库由一对文件组成，文件扩展名分别为 .edb 和 .stm。对该存储组中的每个存储重复上述步骤。

    3. 在命令提示符后，将目录更改为 Exchange Server bin 文件夹。例如，将目录更改为 C:\Program Files\Exchsrvr\bin。

    4. 键入 Eseutil /mh 数据库文件名称，再按 Enter。对该存储组中的每个数据库重复上述步骤。此命令将显示数据库文件头。文件头将包含下列两行之一："状态：干净关闭"或"状态：肮脏关闭"。

  4. 如果文件头包含"状态：肮脏关闭"行，在删除日志文件之前，必须先手动恢复数据库。若要这样做，请执行下列步骤：

    1. 在 Exchange 系统管理器中，用鼠标右键单击事务日志文件已满的存储组，再单击"属性"。

    2. 单击"常规"选项卡，然后记下"事务日志位置"框中的事务日志路径。

    3. 记下"系统路径位置"框中的检查点文件路径。

    4. 在命令提示符后，将目录更改为 Exchange Server bin 文件夹。

    5. 键入以下命令，再按 Enter:Eseutil /r 3-CharacterLogfileBaseName /lDirectory:\LogfilePath /sDirectory:\CheckpointFilePath。

      注意：
      在选项开关和目录路径之间不要键入空格。如果命令中列出的路径键入错误，恢复可能会失败。若要避免这种情况，可以将检查点文件复制到事务日志文件文件夹中。在默认目录为日志文件目录的命令提示符后，运行命令 Eseutil /r 3-CharacterLogfileBaseName。因为 /l 开关和 /s 开关默认为当前目录，所以，不必提供日志文件的路径或检查点文件的路径。
    6. 恢复完成后，先验证所有数据库文件现在是否处于"干净关闭"状态，然后再移动事务日志文件和检查点文件。如果在数据库处于"肮脏关闭"状态时移动日志文件，将无法重新启动数据库。如果无法将所有数据库恢复到"干净关闭"状态，请与 Microsoft 产品支持服务联系，以了解详细信息。

  5. 在 Exchange 系统管理器中，用鼠标右键单击事务日志文件已满的存储组，再单击"属性"。

  6. 单击"常规"选项卡，然后记下"事务日志位置"框中的事务日志路径。

  7. 记下"系统路径位置"框中的检查点文件路径。

  8. 将事务日志文件和检查点文件移至其他位置。日志文件的文件扩展名为 .log，检查点文件的文件扩展名为 .chk。

  9. 在 Exchange 系统管理器中，用鼠标右键单击存储组中第一个卸除的存储，再单击"装入存储"。

  10. 对该存储组中的每个存储重复上述步骤。现在，存储组中的日志文件序列已重置。

  11. 对存储组上的所有数据库执行完整备份。

有关 Exchange Server 的 Service Pack 的信息，请访问 Exchange Server 网站 (http://go.microsoft.com/fwlink/?LinkId=21573)。


VM 最大块大小较低
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_PerfRawData_MSExchangeIS_MSExchangeIS Microsoft Windows® Management Instrumentation (WMI) 类，以确定 VMLargestBlockSize 关键字的值。VMLargestBlockSize 关键字代表最大可用虚拟内存块的大小（字节）。

此外，Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定在每个邮箱存储的 homeMDBBL 属性中列出的条目数。该属性的个数代表邮箱存储中的邮箱数。

如果 Exchange Server 分析工具发现具有 20 个以上邮箱的 Exchange Server 计算机上的 VMLargestBlockSize 值大于 50000000 但小于 150000000，则会显示警告。

此外，在 MIME 和 MAPI 之间转换邮件格式时，Exchange Server 使用虚拟内存来存储邮件，而在从事务日志提交邮件和将邮件提交到存储时，又将虚拟内存当作缓冲区。这些操作通常需要有大型的连续虚拟内存块才能快速有效地完成。如果已显示此警告，则说明 Exchange 计算机上的虚拟内存已消耗至不足 150 MB 连续空间。这就叫做虚拟内存碎片。

如果虚拟内存过度消耗，事件日志中可能开始出现表示虚拟内存错误的错误消息（事件 ID 9582）。如果虚拟内存低到一定的程度，将出现事件 ID 12800，这意味着由于没有处理邮件所需的足够内存，邮件未传递。

若要解决此警告问题，请按顺序尝试下面的推荐方法。

在 Exchange Server 分析工具的输出中查找错误"ESE 缓存的最大大小已增加"。

如果在返回了此虚拟内存碎片警告的 Exchange 计算机上同时返回了"ESE 缓存的最大大小已增加"错误，请采用文章 ESE 缓存的最大值设置得太高 中推荐的方法。

同时出现这两个消息可能意味着虚拟内存碎片问题是由于手动增加了 ESE 缓存而导致的。

重新启动 Exchange 信息存储服务

在关于此错误消息的描述中，Exchange Server 分析工具指定了 Microsoft Exchange 信息存储服务已运行的天数。如果指定的天数大于 30，请重新启动此服务。

重新启动 Microsoft Exchange 信息存储服务

  1. 打开"服务"MMC 管理单元。

  2. 用鼠标右键单击"Microsoft Exchange Information Store"服务，然后单击"重新启动"。

评估邮件大小限制

如果许多用户同时发送大型邮件（超过 30 MB），则虚拟内存产生碎片的速度将比没有许多用户同时发送大型邮件的情况要快。前面已提到，当存储进程将数据从日志文件中移出并提交到存储中时，虚拟内存用作缓冲区。如果移动的数据量通常非常大，那么连续的大型虚拟内存块将很快消耗殆尽。

如果定期使用电子邮件发送大型数据，并且该数据在内部发送，应考虑在用户可以投递大型数据块的文件服务器上设置共享目录。

建议将最大邮件大小限制设置为不超过 30 MB。但是，如果需要对通过您的 Exchange 组织发送并带有大型附件的邮件使用更大的邮件大小限制，则可能需要将最大传出邮件大小限制增加到 30 MB 以上。将邮件大小限制增加到 30 MB 以上除了会产生虚拟内存碎片外，还会导致系统更易于受到恶意攻击。建议不要使用 30 MB 以上的邮件大小限制。

设置邮件大小限制

  1. 在 Exchange 系统管理器中，展开"全局设置"，用鼠标右键单击"邮件传递"，再单击"属性"。

  2. 在"邮件传递属性"对话框的"默认设置"选项卡上，选择"发送邮件大小"下的"最大值"选项，然后输入所需的大小限制。

确认防病毒软件是最新的

有时，在 Exchange 病毒扫描 API (VSAPI) 模式下运行的过时防病毒软件会导致虚拟内存碎片。如果在 VSAPI 模式下运行防病毒软件，请与防病毒软件供应商联系，确认您运行的是相应软件和驱动程序的最新版本。

将邮箱移至另一台 Exchange 服务器上

如果完成了上述所有过程，Exchange Server 分析工具仍然显示此警告，那么必须将邮箱从受影响的服务器上移走以减小其负载。此服务器上存在过多的邮箱。

在 Exchange 2000 Server 和 Exchange Server 2003 上移动邮箱

  1. 在 Active Directory 用户和计算机中，选择想要移动其邮箱的一个或多个用户。

  2. 用鼠标右键单击在上一步中选择的用户列表，再单击"Exchange 任务"。

  3. 在"Exchange 任务向导"的"可用任务"页上，单击"移动邮箱"，再单击"下一步"。

  4. 小心阅读并执行向导的其余步骤。

在 Exchange Server 2003 上移动邮箱

  1. 在 Exchange 系统管理器中，展开"服务器"，展开想要从中移动邮箱的服务器，展开想要从中移动邮箱的存储组，展开包含想要移动的邮箱的邮箱存储，再单击"邮箱"。

  2. 在详细信息窗格中，用鼠标右键单击要移动其邮箱的一个或多个用户，然后单击"Exchange 任务"。

  3. 在"Exchange 任务向导"的"可用任务"页上，单击"移动邮箱"，再单击"下一步"。

  4. 小心阅读并执行向导的其余步骤。

有关解决虚拟内存碎片问题的详细信息，请参阅下列 Microsoft 知识库文章：

  • 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://support.microsoft.com/kb/325044/zh-cn)

  • 838233"Your computer may slow or stop responding and repeatedly log event IDs 9582 and 1160 in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=838233)

有关设置邮件大小限制的详细信息，请参阅知识库文章 322679"为邮件设置大小限制"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)

有关移动邮箱的详细信息，请参阅下列知识库文章：

  • 328810"在服务器之间移动邮箱"(http://support.microsoft.com/kb/328810/zh-cn)

  • 821829"在 Exchange Server 2003 中移动邮箱"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)


最大 VM 块大小即将达到临界点
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_PerfRawData_MSExchangeIS_MSExchangeIS Microsoft Windows® Management Instrumentation (WMI) 类，以确定 VMLargestBlockSize 关键字的值。VMLargestBlockSize 关键字代表最大可用虚拟内存块的大小（字节）。

此外，Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定在每个邮箱存储的 homeMDBBL 属性中列出的条目数。该属性的个数代表邮箱存储中的邮箱数。

如果 Exchange Server 分析工具发现在包含超过 20 个邮箱的 Exchange Server 计算机上 VMLargestBlockSize 的值大于 0 但小于 50000001，则会显示错误。

此外，在 MIME 和 MAPI 之间转换邮件格式时，Exchange 服务器使用虚拟内存来存储邮件，而在从事务日志提交邮件和将邮件提交到存储时，又将虚拟内存当作缓冲区。这些操作通常需要有大型的连续虚拟内存块才能快速有效地完成。如果已显示该错误，则说明 Exchange 计算机上的虚拟内存已消耗至不足 50 MB 连续空间。这称为虚拟内存碎片。以小于 50 MB 连续虚拟内存空间运行的 Exchange 邮箱服务器是主要错误。

如果虚拟内存过度消耗，事件日志中可能开始出现表示虚拟内存错误的错误警报（事件 ID 9582）。如果虚拟内存低到一定的程度，将出现事件 ID 12800，这意味着由于没有处理邮件所需的足够内存，邮件未传递。

若要更正该错误，请按顺序执行下面的推荐方法。

在 Exchange Server 分析工具的输出中查找错误"ESE 缓存的最大大小已增加"。

如果在返回了此虚拟内存碎片警告的 Exchange 计算机上同时返回了"ESE 缓存的最大大小已增加"错误，请采用文章 ESE 缓存的最大值设置得太高 中推荐的方法。

同时出现这两个警报可能意味着虚拟内存碎片问题是由于手动增加了 ESE 缓存而导致的。

重新启动 Exchange 信息存储服务

在该警报的描述中，Exchange Server 分析工具指定了 Microsoft Exchange 信息存储服务已运行的天数。如果指定的天数超过 30，请重新启动该服务。

重新启动 Exchange 信息存储

  1. 打开"服务"MMC 管理单元。

  2. 用鼠标右键单击"Microsoft Exchange Information Store"服务，再单击"重新启动"。

评估邮件大小限制

如果有很多用户发送大型邮件（超过 30 MB），则虚拟内存碎片化的速度可能比没有很多用户发送大型邮件的情况更快。上面已经提到，当存储进程从日志文件移动数据并将它提交到存储时，将把虚拟内存作为缓冲区使用。如果频繁出现大型的被移动数据，就会快速消耗掉大型连续虚拟内存块。

如果经常使用电子邮件发送大型数据，并且该数据在内部发送，那么，请考虑在用户可以投递大型数据的文件服务器上设置共享目录。

建议将最大邮件大小限制设置为不超过 30 MB。但是，如果需要对通过您的 Exchange 组织发送并带有大型附件的邮件使用更大的邮件大小限制，则可能需要将最大传出邮件大小限制增加到 30 MB 以上。将邮件大小限制增加到 30 MB 以上除了会产生虚拟内存碎片外，还会导致系统更易于受到恶意攻击。因此，建议不要使用超过 30 MB 的邮件大小限制。

设置邮件大小限制

  1. 在 Exchange 系统管理器中，展开"全局设置"，用鼠标右键单击"邮件传递"，再单击"属性"。

  2. 在"邮件传递属性"对话框的"默认设置"选项卡上，选择"发送邮件大小"下的"最大值"选项，然后输入所需的大小限制。

确认防病毒软件是最新的

在某些情况下，在 Exchange 病毒扫描 API (VSAPI) 模式下运行的过时防病毒软件会导致虚拟内存碎片。如果在 VSAPI 模式下运行防病毒软件，请与防病毒软件供应商联系，确认您运行的是相应软件和驱动程序的最新版本。

将邮箱移动到另一个 Exchange 服务器

如果完成了上面的所有过程，而 Exchange Server 分析工具仍然显示该错误或该警报的警告版本（剩余的连续虚拟内存空间小于 150 MB），那么，必须将邮箱从受影响的服务器移动到其他地方，以便减少它的负载。该服务器上有太多邮箱。

在 Exchange 2000 Server 和 Exchange Server 2003 上移动邮箱

  1. 在 Active Directory 用户和计算机中，选择想要移动其邮箱的一个或多个用户。

  2. 用鼠标右键单击在上一步中选择的用户列表，再单击"Exchange 任务"。

  3. 在"Exchange 任务向导"的"可用任务"页上，单击"移动邮箱"，再单击"下一步"。

  4. 小心阅读并执行向导的其余步骤。

在 Exchange Server 2003 上移动邮箱

  1. 在 Exchange 系统管理器中，展开"服务器"，展开想要从中移动邮箱的服务器，展开想要从中移动邮箱的存储组，展开包含想要移动的邮箱的邮箱存储，再单击"邮箱"。

  2. 在详细信息窗格中，用鼠标右键单击要移动其邮箱的一个或多个用户，然后单击"Exchange 任务"。

  3. 在"Exchange 任务向导"的"可用任务"页上，单击"移动邮箱"，再单击"下一步"。

  4. 小心阅读并执行向导的其余步骤。

有关解决虚拟内存碎片问题的详细信息，请参阅下列 Microsoft 知识库文章：

  • 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://support.microsoft.com/kb/325044/zh-cn)

  • 838233"Your computer may slow or stop responding and repeatedly log event IDs 9582 and 1160 in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=838233)

有关设置邮件大小限制的详细信息，请参阅知识库文章 322679"为邮件设置大小限制"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)。

有关移动邮箱的详细信息，请参阅下列知识库文章：

  • 328810"在服务器之间移动邮箱"(http://support.microsoft.com/kb/328810/zh-cn)

  • 821829"在 Exchange Server 2003 中移动邮箱"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)


VirtualReserveSize is non-default
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表值，以确定 Exchange 进程间通信 (ExIPC) 组件的初始内存分配是否已从默认值更改为其他值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIPC\Parameters\VirtualReserveSize

如果 Exchange Server 分析工具发现 VirtualReserveSize 项存在并且配置的值大于 0，则会显示非默认配置消息。

ExIPC 是一个排队组件，允许 Inetinfo.exe（Internet 信息服务）和 Store.exe（Microsoft Exchange 信息存储服务）快速来回移动数据。通常，ExIPC 的默认初始内存分配就足够了。默认情况下，VirtualReserveSize 项不存在。只有在 Microsoft 咨询服务或 Microsoft 产品支持服务的指导下，才应添加和配置该项。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\EXIPC\Parameters

  3. 删除 VirtualReserveSize 注册表项。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange Information Store 服务和 IIS Admin 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 ExIPC 的详细信息，请参阅下列知识库文章：

  • 821879"Definitions of key transport components in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821879)

  • 260995"XCON:Definitions of Key Transport Components in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=260995)


虚拟内存事件间隔已被覆盖
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定虚拟内存碎片的相关事件日志记录的阈值是否已被手动覆盖：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ VM Info Update Interval

如果 Exchange Server 分析工具发现 VM Info Update Interval 注册表值存在但不等于 3600，则显示非默认配置消息。

在 32 位 Microsoft Windows® 系统中，有两类内存：物理内存（系统中安装的实际内存量）和虚拟内存地址空间（虚拟化的 4 GB 内存空间）。无论系统上安装多少物理内存量，总的虚拟地址空间大小始终相同：4 GB。尽管并非适用于所有 32 位应用程序，但对于 Exchange Server 来说，虚拟地址空间等于虚拟内存；换句话说，这两个术语可互换使用。

在其日常运行过程中，Microsoft Exchange 信息存储服务将重复地对虚拟内存进行分配、使用和解除分配。当频繁地分配、使用和释放虚拟内存时，会产生虚拟内存碎片。虚拟内存碎片类似于会在一段时间后出现的文件系统碎片。在一段时间之后，所分配的虚拟内存段将不再相邻，而性能也将开始降低。对于文件系统来说，可以通过运行应用程序对文件系统执行碎片整理，并且在大多数时间里您可以在系统已联机和正在被访问的情况下做这件工作。对于虚拟内存碎片来说，则没有碎片整理工具；为了纠正问题，必须停止并启动 Microsoft Exchange 信息存储服务，或重新启动系统。

默认情况下，Microsoft Exchange 信息存储服务将每小时一次（例如，每隔 3,600 秒）查找可用的虚拟内存。VM Info Update Interval 注册表值代表了允许管理员覆盖默认的 3,600 秒间隔的配置机会。如果您要覆盖默认级别，建议您不要将该值设置为低于 5 分钟（300 秒）。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，例如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右侧窗格中，删除 VM Info Update Interval 的值。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange Information Store 服务，以使更改生效。

有关解决 Exchange Server 2003 和 Exchange 2000 Server 中虚拟内存碎片问题的详细信息，请参阅 Microsoft 知识库文章 325044"HOW TO:解决 Exchange 2003 和 Exchange 2000 中的虚拟内存碎片问题"(http://support.microsoft.com/kb/325044/zh-cn)。


未启用写回缓存
Microsoft Exchange Server 分析工具 - 文章 > 存储 >

主题上次修改时间： 2006-08-18

Microsoft® Exchange Server 分析工具已确定磁盘阵列控制器没有为存放事务日志的驱动器正确设置写回缓存。

建议在阵列控制器上为所有存放事务日志的驱动器全部启用写回缓存。很少会从中读取事务日志。事务日志驱动器的写入速度越快，运行 Exchange Server 的服务器的性能就会越好。

解决此警告问题

  • 启用写回缓存。

有关如何配置 Exchange 服务器硬盘的详细信息，请参阅 Microsoft 知识库文章 188589"Exchange DB and caching hard disks and controllers"（Exchange 数据库和缓存硬盘和控制器）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=188589)。


第三方软件
Microsoft Exchange Server 分析工具 - 文章 >

主题上次修改时间： 2005-11-18

此部分中的文章提供了有关 Microsoft® Exchange Server 分析工具就第三方软件进行评估的详细信息。此外，这些文章还描述了为解决由 Exchange Server 分析工具发现的与第三方软件有关的错误、警告和非默认配置所能采取的措施。


尚未配置 Anti-Virus 文件夹排除
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Exchange Server 上是否安装了 Symantec AntiVirus 企业版 (Symantec AV)，并且是否启用了实时保护 (RTP)：

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Storages\Filesystem\RealTimeScan

如果 Exchange Server 分析工具发现 HaveExceptionDirs 注册表值设置为 0，Exchange Server 分析工具将显示错误。如果 HaveExceptionDirs 注册表值为 0，表明文件夹排除已禁用。

文件夹排除可以防止在实时防病毒扫描期间扫描特定的文件夹。如果在 Exchange Server 上尚未启用文件夹排除，可能会出现下列问题：

  • 对于在普通程序活动期间访问的某些无病毒文件，Symantec AV RTP 可能会提供虚假的感染报告。

  • 在公司安全策略已允许在 Exchange Server 上运行的软件中，Symantec AV RTP 可能会提供错误的文件感染报告。

  • Symantec AV RTP 可能会扫描 Exchange Server 目录结构，并造成病毒检测不准确，Exchange 服务器上发生意外的行为，或对 Exchange Server 数据库造成损坏。

重要信息：
对于 Exchange Server 数据库、日志、临时文件、Internet 信息服务 (IIS) 系统文件或可安装的文件系统 (IFS) 驱动器（驱动器 M），一定不要运行基于文件的扫描软件。对防病毒软件进行配置，避免扫描包含这些文件的文件夹。

对于 Exchange Server 计算机的操作系统以及 Exchange Server 程序文件（Exchsrvr\Bin 文件夹），可以运行基于文件的防病毒软件。但是，不要对下列文件和文件夹运行基于文件的防病毒软件：

  • Exchange Server 数据库（.mdb 和 .stm 文件）和事务日志 (.log) 文件（默认位置：\Exchsrvr\MDBData）

  • Exchange Server .mta 文件（默认位置：\Exchsrvr\Mtadata）

  • Exchange Server 邮件跟踪日志文件（默认位置：\Exchsrvr\Server_Name.log）

  • 虚拟服务器文件夹（默认位置：\Exchsrvr\Mailroot）

  • 站点复制服务 (SRS) 文件（默认位置：\Exchsrvr\Srsdata）

  • Internet 信息服务 (IIS) 系统文件（默认位置：\%SystemRoot%\System32\Inetsrv）

  • Internet 邮件连接器文件（默认位置：\Exchsrvr\IMCData）

  • 存储用于邮件转换的流式临时文件的工作文件夹。默认情况下，此工作文件夹位于 \Exchsrvr\MDBData

  • 与脱机维护实用程序（例如 Eseutil.exe）配合使用的一个临时文件夹。默认情况下，此文件夹是运行 .exe 文件的位置，但是可以在运行实用程序时进行配置。

对下列文件夹可以运行基于文件的扫描：

  • Exchsrvr\Address

  • Exchsrvr\Bin

  • Exchsrvr\Exchweb

  • Exchsrvr\Res

  • Exchsrvr\Schema

有关如何在 Symantec AntiVirus 企业版中为实时扫描配置排除的详细信息，请访问 Symantec 防病毒网站 (http://www.symantec.com)。

注意：
Web 地址可能会改变，所以，也许无法连接到此处提到的网站。

有关加强 Exchange Server 环境的防御措施以抵抗通过电子邮件传输的病毒和蠕虫的详细信息，请参阅"在 Exchange 2003 环境中抑制和阻止通过电子邮件传输的病毒"(http://www.microsoft.com/downloads/details.aspx?FamilyID=fb3f649a-2b0a-443d-92a5-8f8cf4bf9fdb&DisplayLang=zh-cn)。

有关如何对 Exchange Server 使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"Exchange 和防病毒软件"(http://support.microsoft.com/kb/328841/zh-cn)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange Server 计算机上排除故障的建议"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅"Exchange Server Partners:Antivirus 网站 (http://go.microsoft.com/fwlink/?linkid=16226)。


Antigen 正在扫描公用文件夹复制邮件
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2006-03-13

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 Exchange 服务器上是否都存在一个公用文件夹存储。如果 Exchange Server 分析工具发现 InformationStore 对象属于对象类 msExchPublicMDB，则该服务器承载了公用文件夹存储。

Microsoft® Exchange Server 分析工具还查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 ANTIGENVSAPI.DLL 文件的 Version 关键字的值。如果 ANTIGENVSAPI.DLL 文件的 Version 关键字的值大于或等于 1517，则表示 Exchange Server 上安装了 Sybari Antigen for Microsoft Exchange 8.0 版 SR3 或更高版本。

最后，Exchange Server 分析工具查询以下注册表分支，以确定 DoNotScanIPMReplicationMessages 关键字是否存在以及其值是否小于等于 0：

HKEY_LOCAL_MACHINE\Software\Sybari Software\Antigen for Exchange\DoNotScanIPMReplicationMessages

DoNotScanIPMReplicationMessages 关键字的值决定了已安装的 Sybari Antigen 是否要扫描或者删除 Exchange Server 公用文件夹复制邮件。如果 DoNotScanIPMReplicationMessages 关键字的值为小于 1 的任何值，则意味着 Antigen 要扫描 winmail.dat 文件，以查看是否存在病毒。Exchange Server 出于多种目的使用 Winmail.dat 文件，其中包括使服务器之间的公用文件夹复制变得更容易。如果 Antigen 修改了其中任何一个 Winmail.dat 文件，则将导致公用文件夹复制过程失败。

如果 Exchange Server 分析工具确定存在以下条件，则 Exchange Server 分析工具将显示错误：

  • 该 Exchange Server 承载了一个或多个公用文件夹存储

  • 该服务器上安装了内部版本号为 1517 或更高版本的 Sybari Antigen

  • DoNotScanIPMReplicationMessages 关键字不存在，或存在但其值小于等于 0。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
更正此错误

  1. 打开注册表编辑器，例如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\Software\Sybari Software\Antigen for Exchange

  3. 如果在右侧窗格中已经存在 DoNotScanIPMReplicationMessages 注册表子项，请双击它并将其值设置为 1。

  4. 如果不存在 DoNotScanIPMReplicationMessages 注册表子项，请在右侧窗格中用鼠标右键单击，以创建一个新的 DWORD 值。

  5. 将 DoNotScanIPMReplicationMessages 的值配置为 1。

    注意：
    如果公用文件夹复制对病毒进行了复制，即使已启用新注册表项，Antigen 仍将通过实时扫描任务检测到该病毒。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关如何对 Exchange Server 使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"XADM：Exchange 和防病毒软件"(http://support.microsoft.com/kb/328841/zh-cn)。

  • 823166"Exchange Server 2003 和防病毒软件概述"(http://support.microsoft.com/kb/823166/zh-cn)。

  • 306105"XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)。

  • 245822"有关在安装了防病毒软件的 Exchange Server 计算机上排除故障的建议"(http://support.microsoft.com/kb/245822/zh-cn)。


CA eTrust：EML/LOG/EDB/STM/DAT 文件未出现在实时文件排除列表中
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取下列注册表项，以获取从 Computer Associates eTrust Antivirus 中的实时文件级防病毒扫描中排除的文件扩展名的列表：

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeExtList

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeExtList

如果 Exchange Server 分析工具发现 szExcludeExtList 的值不包含与 Exchange 数据文件类型对应的文件扩展名（.eml, .log, .edb, .stm 或 .dat），则显示警告。

eTrust Antivirus 是文件级防病毒扫描程序。若要确定 Exchange Server 计算机上安装的 eTrust Antivirus 的版本，请执行下列操作：

  1. 导航到"开始"|"程序"|"eTrust Antivirus"，再单击"eTrust Antivirus"以启动该应用程序。

  2. 在 eTrust Antivirus 应用程序菜单上，单击"帮助"，再单击"关于 eTrust Antivirus"。

  3. 检查"产品版本"字段以确定 eTrust Antivirus 的版本。

当在 Exchange Server 计算机上使用文件级扫描程序时，会出现下列问题：

  • 文件级扫描程序扫描正在使用的文件，或者按照日程安排中设定的间隔扫描文件，并且可能在 Exchange 试图使用 Exchange 日志文件或数据库文件时将该文件锁定或隔离。这会导致 Exchange Server 出现严重的故障，并且还会产生数据库错误。

  • 如果使用文件级扫描程序软件扫描用 Exchange 可安装文件系统 (IFS) 表示的驱动器（通常为驱动器 M），则会发生更多问题。

无论您使用的是何种文件级防病毒程序，应该始终从文件级扫描程序中排除下列文件和文件夹：

  • .eml, .edb, .stm, .log, .dat 和 .chk 文件。

  • 用 IFS 表示的 Exchange Server 驱动器。默认情况下，它为驱动器 M。

  • Exchange 数据库文件和日志文件。默认情况下，这些文件位于 Exchsrvr\Mdbdata 文件夹中。

  • Exchsrvr\Mtadata 文件夹中的 Exchange MTA 文件。

  • 其他日志文件，如 Exchsrvr\server_name.log 文件。

  • Exchsrvr\Mailroot 虚拟服务器文件夹。

  • 用于存储转换邮件时使用的流式临时文件的工作文件夹。默认情况下，此文件夹位于 \Exchsrvr\MDBData 中，但此位置是可配置的。

  • 用于脱机维护工具（如 Eseutil.exe）的临时文件夹。默认情况下，该文件夹是从中运行 .exe 文件的位置，但您可以在运行维护工具时配置该位置。

  • Exchsrvr\Srsdata 文件夹中的站点复制服务 (SRS) 文件。

  • %SystemRoot%\System32\Inetsrv 文件夹中的 Microsoft Internet 信息服务 (IIS) 系统文件。

  • %SystemRoot%\IIS Temporary Compressed Files 文件夹中的 IIS 工作文件。

解决此警告问题

  1. 使用 eTrust Antivirus 用户界面从文件级防病毒扫描中排除上述文件夹和文件。

  2. 有关在 Exchange Server 计算机上使用 eTrust Antivirus 的最新信息，请访问 CA eTrust Antivirus 网站 (http://www3.ca.com/Solutions/Product.asp?ID=156)。

    注意：
    Web 地址可能会改变，所以，也许无法连接到此处提到的网站。

有关与 Exchange Server 一起使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"XADM:Exchange 和防病毒软件"(http://support.microsoft.com/?kbid=328841)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange 计算机上排除故障的建议"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅网站上的"Exchange Server Partners:Antivirus 网站 (http://go.microsoft.com/fwlink/?LinkId=16226)。

有关在扫描 IFS 驱动器时会发生的问题的详细信息，请参阅下列知识库文章：

  • 298924"XADM:不要备份或扫描 Exchange 2000 驱动器 M"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608"XADM:当您尝试装入数据库时可能会显示'C1041737'错误和事件 ID 470 消息"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046"XADM:看不到用户文件夹中的日历项目"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust：Exchange 数据驱动器尚未从手动作业扫描中排除
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取下列注册表项，以获取从 Computer Associates eTrust Antivirus 的手动文件级防病毒扫描中排除的目录的列表：

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

Exchange Server 分析工具还读取 Active Directory® 目录服务中 MsExchESEParamSystemPath 属性的值，它是对应于 Exchange 系统数据文件位置的存储组属性。

如果 Exchange Server 分析工具发现 szExcludeDirs 的值不包括对应于 Exchange 系统数据文件位置的路径，则会显示警告。

eTrust Antivirus 是文件级防病毒扫描程序。若要确定 Exchange Server 计算机上安装的 eTrust Antivirus 的版本，请执行下列操作：

  1. 导航到"开始"|"程序"|"eTrust Antivirus"，再单击"eTrust Antivirus"以启动该应用程序。

  2. 在 eTrust Antivirus 应用程序菜单上，单击"帮助"，再单击"关于 eTrust Antivirus"。

  3. 检查"产品版本"字段，确定 eTrust Antivirus 的版本。

在 Exchange Server 计算机上使用文件级扫描程序时，会发生下列问题：

  • 文件级扫描程序在文件被使用时或按照日程安排中设定的间隔扫描文件，并且可能在 Exchange 试图使用 Exchange 日志或数据库文件时锁定或隔离该文件。这会导致 Exchange Server 出现严重故障，还会生成数据库错误。

  • 如果使用文件级扫描程序软件扫描用 Exchange 可安装文件系统 (IFS) 表示的驱动器（通常为驱动器 M），则会发生更多问题。

无论您使用的是何种文件级防病毒程序，应该始终从文件级扫描程序中排除下列文件和文件夹：

  • .eml, .edb, .stm, .log, .dat 和 .chk 文件。

  • 用 IFS 表示的 Exchange Server 驱动器。默认情况下，它为驱动器 M。

  • Exchange 数据库和日志文件。默认情况下，这些文件位于 Exchsrvr\Mdbdata 文件夹中。

  • Exchsrvr\Mtadata 文件夹中的 Exchange MTA 文件。

  • 其他日志文件，例如 Exchsrvr\server_name.log 文件。

  • Exchsrvr\Mailroot 虚拟服务器文件夹。

  • 存储用于邮件转换的流式临时文件的工作文件夹。默认情况下，该文件夹位于 \Exchsrvr\MDBData，但是可以配置该位置。

  • 用于脱机维护工具（如 Eseutil.exe）的临时文件夹。默认情况下，该文件夹是从中运行 .exe 文件的位置，但您可以在运行维护工具时配置该位置。

  • Exchsrvr\Srsdata 文件夹中的站点复制服务 (SRS) 文件。

  • %SystemRoot%\System32\Inetsrv 文件夹中的 Microsoft Internet 信息服务 (IIS) 系统文件。

  • %SystemRoot%\IIS Temporary Compressed Files 文件夹中的 IIS 工作文件。

解决此警告问题

  1. 使用 eTrust Antivirus 用户界面从文件级防病毒扫描中排除上述文件夹和文件。

  2. 有关在 Exchange Server 计算机上使用 eTrust Antivirus 的最新信息，请访问 CA eTrust Antivirus 网站 (http://www3.ca.com/Solutions/Product.asp?ID=156)。

    注意：
    Web 地址可能会改变，所以，也许无法连接到此处提到的网站。

有关与 Exchange Server 一起使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"XADM:Exchange 和防病毒软件"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)。

  • 245822"有关在安装了防病毒软件的 Exchange 计算机上排除故障的建议"(http://support.microsoft.com/kb/245822/zh-cn)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅网站上的"Exchange Server Partners:Antivirus"（英文）(http://go.microsoft.com/fwlink/?LinkId=16226)。

有关在扫描 IFS 驱动器时会发生的问题的详细信息，请参阅下列知识库文章：

  • 298924"XADM:不要备份或扫描 Exchange 2000 驱动器 M"(http://support.microsoft.com/kb/298924/zh-cn)

  • 300608"XADM:当您尝试装入数据库时可能会显示'C1041737'错误和事件 ID 470 消息"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046"XADM:看不到用户文件夹中的日历项目"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust：Exchange 数据器驱动尚未排除在实时扫描范围以外
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取下列注册表项，以获取从 Computer Associates eTrust Antivirus 的实时文件级防病毒扫描中排除的目录的列表：

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定每个存储组的 MsExchESEParamSystemPath 属性的值。该属性代表 Exchange 数据文件的路径。

如果 Exchange Server 分析工具发现 szExcludeDirs 的值不包括对应于 Exchange 系统数据文件位置的路径，则会显示警告。

eTrust Antivirus 是文件级病毒扫描程序。若要确定 Exchange Server 计算机上安装的 eTrust Antivirus 的版本，请执行下列操作：

  1. 导航到"开始"|"程序" |"eTrust Antivirus"，再单击"eTrust Antivirus"启动该应用程序。

  2. 在 eTrust Antivirus 应用程序菜单上，单击"帮助"，再单击"关于 eTrust Antivirus"。

  3. 检查"产品版本"字段，确定 eTrust Antivirus 的版本。

在 Exchange Server 计算机上使用文件级扫描程序时，会发生下列问题：

  • 文件级扫描程序在文件被使用时或按照日程安排中设定的间隔扫描文件，并且可能在 Exchange 试图使用 Exchange 日志或数据库文件时锁定或隔离该文件。这会导致 Exchange Server 出现严重故障，还会生成数据库错误。

  • 如果使用文件级扫描程序软件扫描用 Exchange 可安装文件系统 (IFS) 表示的驱动器（通常为驱动器 M），则会发生更多问题。

无论您使用的是何种文件级防病毒程序，应该始终从文件级扫描程序中排除下列文件和文件夹：

  • .eml, .edb, .stm, .log, .dat 和 .chk 文件。

  • 用 IFS 表示的 Exchange Server 驱动器。默认情况下，它为驱动器 M。

  • Exchange 数据库文件和日志文件。默认情况下，这些文件位于 Exchsrvr\Mdbdata 文件夹中。

  • Exchsrvr\Mtadata 文件夹中的 Exchange MTA 文件。

  • 其他日志文件，如 Exchsrvr\server_name.log 文件。

  • Exchsrvr\Mailroot 虚拟服务器文件夹。

  • 存储用于邮件转换的流式临时文件的工作文件夹。默认情况下，该文件夹位于 \Exchsrvr\MDBData，但您可以配置该位置。

  • 用于脱机维护工具（如 Eseutil.exe）的临时文件夹。默认情况下，该文件夹是从中运行 .exe 文件的位置，但您可以在运行维护工具时配置该位置。

  • Exchsrvr\Srsdata 文件夹中的站点复制服务 (SRS) 文件。

  • %SystemRoot%\System32\Inetsrv 文件夹中的 Microsoft Internet 信息服务 (IIS) 系统文件。

  • %SystemRoot%\IIS Temporary Compressed Files 文件夹中的 IIS 工作文件。

解决此警告问题

  1. 使用 eTrust Antivirus 用户界面从文件级病毒扫描中排除上述文件夹和文件。

  2. 有关在 Exchange Server 计算机上使用 eTrust Antivirus 的最新信息，请访问 CA eTrust Antivirus 网站 (http://www3.ca.com/Solutions/Product.asp?ID=156)。

    注意：
    Web 地址可能会改变，所以，也许无法连接到此处提到的网站。

有关将防病毒软件与 Exchange Server 一起使用的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"XADM:Exchange 和防病毒软件"(http://support.microsoft.com/?kbid=328841)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange 计算机上排除故障的建议"(http://support.microsoft.com/kb/245822/zh-cn)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅网站上的"Exchange Server Partners: Antivirus"（英文）(http://go.microsoft.com/fwlink/?LinkId=16226)。

有关在扫描 IFS 驱动器时会发生的问题的详细信息，请参阅下列知识库文章：

  • 298924"XADM:不要备份或扫描 Exchange 2000 驱动器 M"(http://support.microsoft.com/kb/298924/zh-cn)

  • 300608"XADM：当您尝试装入数据库时可能会显示'C1041737'错误和事件 ID 470 消息"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046"XADM:看不到用户文件夹中的日历项目"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust：Exchange IFS 路径尚未从手动作业扫描中排除
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取下列注册表项，以获取从 Computer Associates eTrust Antivirus 的手动文件级防病毒扫描中排除的目录的列表：

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

Exchange Server 分析工具还读取以下注册表项，以获取表示 Exchange 可安装文件系统 (IFS) 驱动器的驱动器号：

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

在 Exchange 2000 Server 中，默认驱动器号是 M。在 Exchange Server 2003 中，默认情况下 IFS 驱动器处于关闭状态。

如果 Exchange Server 分析工具发现 szExcludeDirs 的值不包括对应于 IFS 驱动器的路径，则会显示警告。

eTrust Antivirus 是文件级防病毒扫描程序。若要确定 Exchange Server 计算机上安装的 eTrust Antivirus 的版本，请执行下列操作：

  1. 导航到"开始"|"程序"|"eTrust Antivirus"，再单击"eTrust Antivirus"以启动该应用程序。

  2. 在 eTrust Antivirus 应用程序菜单上，单击"帮助"，再单击"关于 eTrust Antivirus"。

  3. 检查"产品版本"字段，确定 eTrust Antivirus 的版本。

在 Exchange Server 计算机上使用文件级扫描程序时，会发生下列问题：

  • 文件级扫描程序在文件被使用时或按照日程安排中设定的间隔扫描文件，并且可能在 Exchange 试图使用 Exchange 日志或数据库文件时锁定或隔离该文件。这会导致 Exchange Server 出现严重故障，还会生成数据库错误。

  • 如果使用文件级扫描程序软件扫描用 IFS 表示的驱动器（通常为驱动器 M），则会发生更多问题。

无论您使用的是何种文件级防病毒程序，应该始终从文件级扫描程序中排除下列文件和文件夹：

  • .eml, .edb, .stm, .log, .dat and .chk files.

  • 用 IFS 表示的 Exchange Server 驱动器。默认情况下，它为驱动器 M。

  • Exchange 数据库和日志文件。默认情况下，这些文件位于 Exchsrvr\Mdbdata 文件夹中。

  • Exchsrvr\Mtadata 文件夹中的 Exchange MTA 文件。

  • 其他日志文件，如 Exchsrvr\server_name.log 文件。

  • Exchsrvr\Mailroot 虚拟服务器文件夹。

  • 存储用于邮件转换的流式临时文件的工作文件夹。默认情况下，该文件夹位于 \Exchsrvr\MDBData，但是可以配置该位置。

  • 用于脱机维护工具（如 Eseutil.exe）的临时文件夹。默认情况下，该文件夹是从中运行 .exe 文件的位置，但您可以在运行维护工具时配置该位置。

  • Exchsrvr\Srsdata 文件夹中的站点复制服务 (SRS) 文件。

  • %SystemRoot%\System32\Inetsrv 文件夹中的 Microsoft Internet 信息服务 (IIS) 系统文件。

  • %SystemRoot%\IIS Temporary Compressed Files 文件夹中的 IIS 工作文件。

解决此警告问题

  1. 使用 eTrust Antivirus 用户界面从文件级防病毒扫描中排除上述文件夹和文件。

  2. 有关在 Exchange Server 计算机上使用 eTrust Antivirus 的最新信息，请访问 Computer Associates eTrust Antivirus 网站 (http://www3.ca.com/Solutions/Product.asp?ID=156)。

    注意：
    Web 地址可能会改变，所以，也许无法连接到此处提到的网站。

有关与 Exchange Server 一起使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"XADM:Exchange 和防病毒软件"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange 计算机上排除故障的建议"(http://support.microsoft.com/kb/245822/zh-cn)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅网站上的"Exchange Server Partners: Antivirus"（英文）(http://go.microsoft.com/fwlink/?LinkId=16226)。

有关在扫描 IFS 驱动器时会发生的问题的详细信息，请参阅下列知识库文章：

  • 298924"XADM:不要备份或扫描 Exchange 2000 驱动器 M"(http://support.microsoft.com/kb/298924/zh-cn)

  • 300608"XADM:当您尝试装入数据库时可能会显示'C1041737'错误和事件 ID 470 消息"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046"XADM:看不到用户文件夹中的日历项目"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust：Exchange IFS 路径尚未从实时扫描中排除
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取下列注册表项，以获取从 Computer Associates eTrust Antivirus 的实时文件级防病毒扫描中排除的目录的列表：

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

Exchange Server 分析工具还读取以下注册表项，以获取表示 Exchange 可安装文件系统 (IFS) 驱动器的驱动器号：

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

在 Exchange 2000 Server 中，默认驱动器号是 M。在 Exchange Server 2003 中，默认情况下 IFS 驱动器处于关闭状态。

如果 Exchange Server 分析工具发现 szExcludeDirs 的值不包括对应于 IFS 驱动器的路径，则会显示警告。

eTrust Antivirus 是文件级防病毒扫描程序。若要确定 Exchange Server 计算机上安装的 eTrust Antivirus 的版本，请执行下列操作：

  1. 导航到"开始"|"程序"|"eTrust Antivirus"，再单击"eTrust Antivirus"以启动该应用程序。

  2. 在 eTrust Antivirus 应用程序菜单上，单击"帮助"，再单击"关于 eTrust Antivirus"。

  3. 检查"产品版本"字段，确定 eTrust Antivirus 的版本。

在 Exchange Server 计算机上使用文件级扫描程序时，会发生下列问题：

  • 文件级扫描程序在文件被使用时或按照日程安排中设定的间隔扫描文件，并且可能在 Exchange 试图使用 Exchange 日志或数据库文件时锁定或隔离该文件。这会导致 Exchange Server 出现严重故障，还会生成数据库错误。

  • 如果使用文件级扫描程序软件扫描用 IFS 表示的驱动器（通常为驱动器 M），则会发生更多问题。

无论您使用的是何种文件级防病毒程序，应该始终从文件级扫描程序中排除下列文件和文件夹：

  • .eml, .edb, .stm, .log, .dat 和 .chk 文件。

  • 用 IFS 表示的 Exchange Server 驱动器。默认情况下，它为驱动器 M。

  • Exchange 数据库和日志文件。默认情况下，这些文件位于 Exchsrvr\Mdbdata 文件夹中。

  • Exchsrvr\Mtadata 文件夹中的 Exchange MTA 文件。

  • 其他日志文件，例如 Exchsrvr\server_name.log 文件。

  • Exchsrvr\Mailroot 虚拟服务器文件夹。

  • 存储用于邮件转换的流式临时文件的工作文件夹。默认情况下，该文件夹位于 \Exchsrvr\MDBData，但是可以配置该位置。

  • 用于脱机维护工具（如 Eseutil.exe）的临时文件夹。默认情况下，该文件夹是从中运行 .exe 文件的位置，但您可以在运行维护工具时配置该位置。

  • Exchsrvr\Srsdata 文件夹中的站点复制服务 (SRS) 文件。

  • %SystemRoot%\System32\Inetsrv 文件夹中的 Microsoft Internet 信息服务 (IIS) 系统文件。

  • %SystemRoot%\IIS Temporary Compressed Files 文件夹中的 IIS 工作文件。

解决此警告问题

  1. 使用 eTrust Antivirus 用户界面从文件级防病毒扫描中排除上述文件夹和文件。

  2. 有关在 Exchange Server 计算机上使用 eTrust Antivirus 的最新信息，请访问 CA eTrust Antivirus 网站 (http://www3.ca.com/Solutions/Product.asp?ID=156)。

    注意：
    Web 地址可能会改变，所以，也许无法连接到此处提到的网站。

有关与 Exchange Server 一起使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"XADM:Exchange 和防病毒软件"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange 计算机上排除故障的建议"(http://support.microsoft.com/kb/245822/zh-cn)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅网站上的"Exchange Server Partners:Antivirus"（英文）(http://go.microsoft.com/fwlink/?LinkId=16226)。

有关在扫描 IFS 驱动器时会发生的问题的详细信息，请参阅下列知识库文章：

  • 298924"XADM:不要备份或扫描 Exchange 2000 驱动器 M"(http://support.microsoft.com/kb/298924/zh-cn)

  • 300608"XADM:当您尝试装入数据库时可能会显示'C1041737'错误和事件 ID 470 消息"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046"XADM:看不到用户文件夹中的日历项目"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust：实时扫描被设置为扫描所有文件（无论扩展名如何）
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2006-04-21

Microsoft® Exchange Server 分析工具读取下列注册表项，以获取从 Computer Associates eTrust Antivirus 的实时文件级防病毒扫描中排除的文件扩展名的列表：

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\dwFileFilterType

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\dwFileFilterType

如果 Exchange Server 分析工具确定 dwFileFilterType 的值配置为扫描所有文件（无论文件扩展名如何），则显示警告。

eTrust Antivirus 是文件级防病毒扫描程序。若要确定 Exchange Server 计算机上安装的 eTrust Antivirus 的版本，请执行下列操作：

  1. 导航到"开始"|"程序"|"eTrust Antivirus"，再单击"eTrust Antivirus"以启动该应用程序。

  2. 在 eTrust Antivirus 应用程序菜单上，单击"帮助"，再单击"关于 eTrust Antivirus"。

  3. 检查"产品版本"字段，确定 eTrust Antivirus 的版本。

在 Exchange Server 计算机上使用文件级扫描程序时，可能发生下列问题：

  • 文件级扫描程序在文件被使用时或按照日程安排中设定的间隔扫描文件，并且可能在 Exchange 试图使用 Exchange 日志或数据库文件时将该文件锁定或隔离。这会导致 Exchange Server 发生严重失败，还可以生成数据库错误。

  • 如果使用文件级扫描程序软件扫描用 Exchange 可安装文件系统 (IFS) 表示的驱动器（通常为驱动器 M），则会发生更多问题。

无论您使用的是何种文件级防病毒程序，应该始终从文件级扫描程序中排除下列文件和文件夹：

  • .eml, .edb, .stm, .log, .dat 和 .chk 文件。

  • 用 IFS 表示的 Exchange Server 驱动器。默认情况下，它为驱动器 M:驱动器。

  • Exchange 数据库和日志文件。默认情况下，这些文件位于 Exchsrvr\Mdbdata 文件夹中。

  • Exchsrvr\Mtadata 文件夹中的 Exchange MTA 文件。

  • 其他日志文件，例如 Exchsrvr\server_name.log 文件。

  • Exchsrvr\Mailroot 虚拟服务器文件夹。

  • 存储用于邮件转换的流式临时文件的工作文件夹。默认情况下，该文件夹位于 \Exchsrvr\MDBData，但是可以配置该位置。

  • 用于脱机维护工具（如 Eseutil.exe）的临时文件夹。默认情况下，该文件夹是从中运行 .exe 文件的位置，但您可以在运行维护工具时配置该位置。

  • Exchsrvr\Srsdata 文件夹中的站点复制服务 (SRS) 文件。

  • %SystemRoot%\System32\Inetsrv 文件夹中的 Microsoft Internet 信息服务 (IIS) 系统文件。

  • %SystemRoot%\IIS Temporary Compressed Files 文件夹中的 IIS 工作文件。

解决此警告问题

  1. 使用 eTrust Antivirus 用户界面从文件级防病毒扫描中排除列出的文件夹和文件。

  2. 有关在 Exchange Server 计算机上使用 eTrust Antivirus 的最新信息，请访问 CA eTrust Antivirus 网站 (http://www3.ca.com/Solutions/Product.asp?ID=156)。

    注意：
    Web 地址可能会改变，所以，也许无法连接到此处提到的网站。

有关与 Exchange Server 一起使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"XADM:Exchange 和防病毒软件"(http://support.microsoft.com/?kbid=328841)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange 计算机上排除故障的建议"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅网站上的"Exchange Server Partners:Antivirus 网站 (http://go.microsoft.com/fwlink/?LinkId=16226)。

有关在扫描 IFS 驱动器时会发生的问题的详细信息，请参阅下列知识库文章：

  • 298924"XADM:不要备份或扫描 Exchange 2000 驱动器 M"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608"XADM：当您尝试装入数据库时可能会显示'C1041737'错误和事件 ID 470 消息"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046"XADM:看不到用户文件夹中的日历项目"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust：存储组驱动器尚未排除在手动作业扫描范围以外
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取下列注册表项，以获取从 Computer Associates eTrust Antivirus 的手动文件级防病毒扫描中排除的目录的列表：

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

Exchange Server 分析工具还读取 Active Directory® 目录服务中 MsExchESEParamSystemPath 属性的值，它是对应于 Exchange 系统日志文件位置的存储组属性。

如果 Exchange Server 分析工具发现 szExcludeDirs 的值不包括对应于 Exchange 系统日志文件位置的路径，则会显示警告。

eTrust Antivirus 是文件级防病毒扫描程序。若要确定 Exchange Server 计算机上安装的 eTrust Antivirus 的版本，请执行下列操作：

  1. 导航到"开始"|"程序"|"eTrust Antivirus"，再单击"eTrust Antivirus"以启动该应用程序。

  2. 在 eTrust Antivirus 应用程序菜单上，单击"帮助"，再单击"关于 eTrust Antivirus"。

  3. 检查"产品版本"字段，确定 eTrust Antivirus 的版本。

在 Exchange Server 计算机上使用文件级扫描程序时，会发生下列问题：

  • 文件级扫描程序在文件被使用时或按照日程安排中设定的间隔扫描文件，并且可能在 Exchange 试图使用 Exchange 日志或数据库文件时锁定或隔离该文件。这会导致 Exchange Server 出现严重故障，还会生成数据库错误。

  • 如果使用文件级扫描程序软件扫描用 Exchange 可安装文件系统 (IFS) 表示的驱动器（通常为驱动器 M），则会发生更多问题。

无论您使用的是何种文件级防病毒程序，应该始终从文件级扫描程序中排除下列文件和文件夹：

  • .eml, .edb, .stm, .log, .dat 和 .chk 文件。

  • 用 IFS 表示的 Exchange Server 驱动器。默认情况下，它为驱动器 M。

  • Exchange 数据库和日志文件。默认情况下，这些文件位于 Exchsrvr\Mdbdata 文件夹中。

  • Exchsrvr\Mtadata 文件夹中的 Exchange MTA 文件。

  • 其他日志文件，例如 Exchsrvr\server_name.log 文件。

  • Exchsrvr\Mailroot 虚拟服务器文件夹。

  • 存储用于邮件转换的流式临时文件的工作文件夹。默认情况下，该文件夹位于 \Exchsrvr\MDBData，但是可以配置该位置。

  • 用于脱机维护工具（如 Eseutil.exe）的临时文件夹。默认情况下，该文件夹是从中运行 .exe 文件的位置，但您可以在运行维护工具时配置该位置。

  • Exchsrvr\Srsdata 文件夹中的站点复制服务 (SRS) 文件。

  • %SystemRoot%\System32\Inetsrv 文件夹中的 Microsoft Internet 信息服务 (IIS) 系统文件。

  • %SystemRoot%\IIS Temporary Compressed Files 文件夹中的 IIS 工作文件。

解决此警告问题

  1. 使用 eTrust Antivirus 用户界面从文件级防病毒扫描中排除上述文件夹和文件。

  2. 有关在 Exchange Server 计算机上使用 eTrust Antivirus 的最新信息，请访问 Computer Associates eTrust Antivirus 网站 (http://www3.ca.com/Solutions/Product.asp?ID=156)。

    注意：
    Web 地址可能会改变，所以，也许无法连接到此处提到的网站。

有关与 Exchange Server 一起使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"XADM:Exchange 和防病毒软件"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange 计算机上排除故障的建议"(http://support.microsoft.com/kb/245822/zh-cn)

  • 有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅网站上的"Exchange Server Partners:Antivirus"（英文）(http://go.microsoft.com/fwlink/?LinkId=16226)。

有关在扫描 IFS 驱动器时会发生的问题的详细信息，请参阅下列知识库文章：

  • 298924"XADM:不要备份或扫描 Exchange 2000 驱动器 M"(http://support.microsoft.com/kb/298924/zh-cn)

  • 300608"XADM:当您尝试装入数据库时可能会显示'C1041737'错误和事件 ID 470 消息"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046"XADM:看不到用户文件夹中的日历项目"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust：存储组驱动器尚未排除在实时扫描范围以外
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取下列注册表项，以获取从 Computer Associates eTrust Antivirus 的实时文件级防病毒扫描中排除的目录列表：

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

Exchange Server 分析工具还查询 Active Directory® 目录服务中的 MsExchESEParamSystemPath 属性值，该属性是对应于 Exchange 系统数据文件位置的存储组属性。

如果 Exchange Server 分析工具发现 szExcludeDirs 的值不包括对应于 Exchange 系统数据文件位置的路径，则显示警告。

eTrust Antivirus 是文件级防病毒扫描程序。若要确定 Exchange Server 计算机上安装的 eTrust Antivirus 的版本，请执行下列操作：

  1. 导航到"开始"|"程序"|"eTrust Antivirus"，再单击"eTrust Antivirus"以启动该应用程序。

  2. 在 eTrust Antivirus 应用程序菜单上，单击"帮助"，再单击"关于 eTrust Antivirus"。

  3. 检查"产品版本"字段以确定 eTrust Antivirus 的版本。

当在 Exchange Server 计算机上使用文件级扫描程序时，会出现下列问题：

  • 文件级扫描程序在文件被使用时或按照日程安排中设定的间隔扫描文件，并且可能在 Exchange 试图使用 Exchange 日志或数据库文件时锁定或隔离该文件。这会导致 Exchange Server 出现严重的故障，并且还会产生数据库错误。

  • 如果使用文件级扫描程序软件扫描用 Exchange 可安装文件系统 (IFS) 表示的驱动器（通常为驱动器 M），则会发生更多问题。

无论您使用的是何种文件级防病毒程序，应该始终从文件级扫描程序中排除下列文件和文件夹：

  • .eml, .edb, .stm, .log, .dat 和 .chk 文件。

  • 用 IFS 表示的 Exchange Server 驱动器。默认情况下，它为驱动器 M。

  • Exchange 数据库和日志文件。默认情况下，这些文件位于 Exchsrvr\Mdbdata 文件夹中。

  • Exchsrvr\Mtadata 文件夹中的 Exchange MTA 文件。

  • 其他日志文件，例如 Exchsrvr\server_name.log 文件。

  • Exchsrvr\Mailroot 虚拟服务器文件夹。

  • 用于存储转换邮件时使用的流式临时文件的工作文件夹。默认情况下，该文件夹位于 \Exchsrvr\MDBData，但是可以配置该位置。

  • 用于脱机维护工具（如 Eseutil.exe）的临时文件夹。默认情况下，该文件夹是从中运行 .exe 文件的位置，但您可以在运行维护工具时配置该位置。

  • Exchsrvr\Srsdata 文件夹中的站点复制服务 (SRS) 文件。

  • %SystemRoot%\System32\Inetsrv 文件夹中的 Microsoft Internet 信息服务 (IIS) 系统文件。

  • %SystemRoot%\IIS Temporary Compressed Files 文件夹中的 IIS 工作文件。

解决此警告问题

  1. 使用 eTrust Antivirus 用户界面从文件级防病毒扫描中排除上述文件夹和文件。

  2. 有关在 Exchange Server 计算机上使用 eTrust Antivirus 的最新信息，请访问 CA eTrust Antivirus 网站 (http://www3.ca.com/Solutions/Product.asp?ID=156)。

    注意：
    Web 地址可能会改变，所以，也许无法连接到此处提到的网站。

有关与 Exchange Server 一起使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"XADM:Exchange 和防病毒软件"(http://support.microsoft.com/?kbid=328841)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange 计算机上排除故障的建议"(http://support.microsoft.com/kb/245822/zh-cn)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅网站上的"Exchange Server Partners:Antivirus"（英文）(http://go.microsoft.com/fwlink/?LinkId=16226)。

有关在扫描 IFS 驱动器时会发生的问题的详细信息，请参阅下列知识库文章：

  • 298924"XADM:不要备份或扫描 Exchange 2000 驱动器 M"(http://support.microsoft.com/kb/298924/zh-cn)

  • 300608"XADM:当您尝试装入数据库时可能会显示'C1041737'错误和事件 ID 470 消息"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046"XADM:看不到用户文件夹中的日历项目"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust：Exchange 进程尚未排除在实时扫描范围以外
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取下列注册表项，以获取从 Computer Associates eTrust Antivirus 的实时文件级防病毒扫描中排除的进程列表：

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\RealTime\szExcludeProcessNames

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeProcessNames

如果 Exchange Server 分析工具发现 szExcludeProcessNames 的值不包括 STORE.EXE、EMSMTA.EXE 和 MAD.EXE，则显示警告。

当 Microsoft Exchange 信息存储进程 (Store.exe)、Exchange MTA 进程 (Emsmta.exe) 或系统助理进程 (Mad.exe) 正在运行时，建议不要用基于文件级的防病毒扫描程序扫描这些进程。

eTrust Antivirus 是文件级防病毒扫描程序。若要确定 Exchange Server 计算机上安装的 eTrust Antivirus 的版本，请执行下列操作：

  1. 导航到"开始"|"程序"|"eTrust Antivirus"，再单击"eTrust Antivirus"以启动该应用程序。

  2. 在 eTrust Antivirus 应用程序菜单上，单击"帮助"，再单击"关于 eTrust Antivirus"。

  3. 检查"产品版本"字段以确定 eTrust Antivirus 的版本。

当在 Exchange Server 计算机上使用文件级扫描程序时，会出现下列问题：

  • 文件级扫描程序在文件被使用时或按照日程安排中设定的间隔扫描文件，并且可能在 Exchange 试图使用 Exchange 日志或数据库文件时锁定或隔离该文件。这会导致 Exchange Server 出现严重的故障，并且还会产生数据库错误。

  • 如果使用文件级扫描程序软件扫描用 IFS 表示的驱动器（通常为驱动器 M），则会发生更多问题。

无论您使用的是何种文件级防病毒程序，应该始终从文件级扫描程序中排除下列文件和文件夹：

  • .eml, .edb, .stm, .log, .dat 和 .chk 文件。

  • 用 IFS 表示的 Exchange Server 驱动器。默认情况下，它为驱动器 M。

  • Exchange 数据库和日志文件。默认情况下，这些文件位于 Exchsrvr\Mdbdata 文件夹中。

  • Exchsrvr\Mtadata 文件夹中的 Exchange MTA 文件。

  • 其他日志文件，例如 Exchsrvr\server_name.log 文件。

  • Exchsrvr\Mailroot 虚拟服务器文件夹。

  • 用于存储转换邮件时使用的流式临时文件的工作文件夹。默认情况下，该文件夹位于 \Exchsrvr\MDBData，但是可以配置该位置。

  • 用于脱机维护工具（如 Eseutil.exe）的临时文件夹。默认情况下，该文件夹是从中运行 .exe 文件的位置，但您可以在运行维护工具时配置该位置。

  • Exchsrvr\Srsdata 文件夹中的站点复制服务 (SRS) 文件。

  • %SystemRoot%\System32\Inetsrv 文件夹中的 Microsoft Internet 信息服务 (IIS) 系统文件。

  • %SystemRoot%\IIS Temporary Compressed Files 文件夹中的 IIS 工作文件。

解决此警告问题

  1. 使用 eTrust Antivirus 用户界面从文件级防病毒扫描中排除上述文件夹和文件。

  2. 有关在 Exchange Server 计算机上使用 eTrust Antivirus 的最新信息，请访问 Computer Associates eTrust Antivirus 网站 (http://www3.ca.com/Solutions/Product.asp?ID=156)。

    注意：
    Web 地址可能会改变，所以，也许无法连接到此处提到的网站。

有关与 Exchange Server 一起使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"XADM:Exchange 和防病毒软件"(http://support.microsoft.com/?kbid=328841)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange 计算机上排除故障的建议"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅网站上的"Exchange Server Partners:Antivirus 网站 (http://go.microsoft.com/fwlink/?LinkId=16226)。

有关在扫描 IFS 驱动器时会发生的问题的详细信息，请参阅下列知识库文章：

  • 298924"XADM:不要备份或扫描 Exchange 2000 驱动器 M"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608"XADM:当您尝试装入数据库时可能会显示'C1041737'错误和事件 ID 470 消息"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046"XADM:看不到用户文件夹中的日历项目"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


可以更新用于 SMB 2.0 的客户端服务器邮件安全程序
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2006-02-13

Microsoft® Exchange Server 分析工具读取以下注册表项：

HKEY_LOCAL_MACHINE\SOFTWARE\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Version 值为 6.2100 表示已安装了用于 SMB 2.0 的 Trend Micro ScanMail 客户端服务器邮件安全程序。

Microsoft® Exchange Server 分析工具也查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定所安装的用于 SMB 2.0 的客户端服务器邮件安全程序版本。如果主要的版本号小于 1145，则 Exchange Server 分析工具将显示警告信息。

该警告表示用于 SMB 2.0 的客户端服务器邮件安全程序已安装在 Exchange 服务器上，并且可以使用推荐的软件更新程序。推荐的更新程序是用于邮件组件的 SMB 2.0 修补程序 2 的客户端服务器邮件安全程序。强烈建议安装该更新程序，它可以提高服务器的总体性能和可靠性。

解决此警告问题

  1. 请访问 Trend Micro Update Center 的"Client Server Messaging Security for SMB"（英文）(http://www.trendmicro.com/download)。

  2. 下载并安装修补程序 2。
注意：
本主题中提供了第三方网站信息，可以帮助您找到需要的技术信息。URL 如有更改，恕不通知。

有关其他 Trend Micro 产品更新的详细信息，请参阅 Trend Micro Update Center 网站（英文）(http://www.trendmicro.com/download/)。

有关如何对 Exchange Server 使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"Exchange 和防病毒软件"(http://support.microsoft.com/kb/328841/zh-cn)

  • 823166"Exchange Server 2003 与防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)。

  • 245822"有关在安装了防病毒软件的 Exchange Server 计算机上排除故障的建议"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅"Exchange Server Partners:Antivirus"（英文）(http://go.microsoft.com/fwlink/?linkid=16226)。


考虑安装 HP Command View EVAPerf
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-12-09

Microsoft® Exchange Server 分析工具查询 Win32_SCSIController Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Name 关键字的值。如果 Name 关键字的值等于 Compaq HSV110CCL，说明服务器上至少有一个磁盘卷是通过 HP EVA 存储区域网络 (SAN) 提供的。

Exchange Server 分析工具还查询 Win32_Service WMI 类，以确定 HP StorageWorks Command View EVAPerf (EVSPDCS) 服务的 Started 关键字的值。值为 False 说明服务未运行。值为 True 说明服务正在运行。

如果同时符合下列两个条件，则 Exchange Server 分析工具将显示最佳做法建议：

  • 服务器上至少有一个磁盘卷是通过 HP EVA SAN 提供的。

  • HP StorageWorks Command View EVAPerf (EVSPDCS) 服务不存在或未在运行。

HP 提供免费的软件管理应用程序，用于为 HP StorageWorks SAN 发布附加的性能计数器。管理员可以使用此软件管理应用程序来监视 SAN 中各个控制器和物理磁盘的性能。

按照建议的最佳实践操作

  1. 转到 HP StorageWorks Command View EVAPerf Software 网站以下载 HP Command View EVAPerf 应用程序 (http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?pnameOID=471498&locale=en_US&taskId=135&prodSeriesId=471497&prodTypeId=12169&swEnvOID=1005http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?pnameOID=471498&locale=en_US&taskId=135&prodSeriesId=471497&prodTypeId=12169&swEnvOID=1005)。

    注意：
    提供第三方网站信息是为了帮助您查找所需的技术信息。URL 如有更改，恕不通知。

  2. 运行下载的自解压缩可执行文件，然后按照说明安装应用程序。


EMC PowerPath 服务已停止
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 EMC PowerPath Service 服务的 Started 关键字的值。值为 True 说明 EMC PowerPath Service 服务正在运行，值为 False 说明 EMC PowerPath Service 服务没有运行。如果 Exchange Server 分析工具发现 Started 关键字的值是 False，则显示警告。

EMC PowerPath 是多路径 I/O (MPIO) 软件。多路径通过允许主机有最多 32 个访问外部存储设备的路径，从而提供了高可用性数据访问能力，这给故障转移和负载平衡提供了很大的便利。多路径不是操作系统的功能，但可通过 MPIO 驱动程序开发工具包 (DDK) 支持该功能，此工具包使存储供应商能够创建可互操作的多路径解决方案。

MPIO 软件运行时，Microsoft Windows® 只会检测到一个驱动器，而由 MPIO 软件来管理与多种存储设备的多个连接。如果 MPIO 软件已停止，则所有已连接的存储驱动器将作为独立的驱动器被 Windows 检测到。这很可能导致存储错误和故障。

启动 EMC PowerPath Service 服务

  1. 打开"服务"MMC 管理单元。

  2. 用鼠标右键单击"EMC PowerPath Service"服务，再单击"属性"。

  3. 在"EMC PowerPath Service"属性页的"常规"选项卡上，确保将"启动类型"设置为"自动"。如果不是，请单击"应用"，再单击"确定"。

  4. 用鼠标右键单击"EMC PowerPath Service"服务，再单击"启动"。

  5. 关闭"服务"管理单元。

有关与 Windows 一起部署其他存储技术的常规信息，请参阅"Planning to Use Windows Storage Features with SANs"（英文）(http://go.microsoft.com/fwlink/?LinkId=33626)。


EMC PowerPath Version Mismatch Between Cluster Nodes
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2007-07-25

Microsoft Exchange 分析工具读取以下注册表项，以确定在群集中的每个节点上安装的 EMC PowerPath 版本：

HKEY_LOCAL_MACHINE\SOFTWARE\EMC\PowerPath\Version

如果 Exchange 分析工具发现 Exchange 群集中的第二个或后续节点上的 Version 值与 Exchange 群集中的第一个节点上的 Version 值不同，则显示错误。

此错误意味着该 Exchange 群集中的各节点运行的不是同一级别的 EMC PowerPath 驱动程序。作为最佳实践，建议 Exchange 群集中的所有节点都运行同一级别的 EMC PowerPath 驱动程序。

EMC PowerPath 是多路径 I/O (MPIO) 软件。多路径允许主机最多有 32 个访问外部存储设备的路径，从而提供高可用性的数据访问能力，这给故障转移和负载平衡提供了很大的便利。多路径不是操作系统的功能，但可通过 MPIO 驱动程序开发工具包 (DDK) 支持该功能，存储供应商使用该工具包可以创建可互操作的多路径解决方案。

MPIO 软件运行时，Microsoft Windows® 仅能检测到一个驱动器，而由 MPIO 软件来管理与多种存储设备的多个连接。如果群集中不同节点间的 MPIO 驱动程序不匹配，则可能会造成群集故障转移问题。

要解决此问题，必须将所有节点升级至同一 EMC PowerPath 驱动程序版本。

详细信息

有关与 Windows 一起部署其他存储技术的常规信息，请参阅"计划使用 Windows 存储功能及 SAN"(http://go.microsoft.com/fwlink/?LinkId=33626)。


Emulex FC Port 驱动程序已超过两年未更新
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2006-04-19

Microsoft® Exchange Server 分析工具查询 Win32_SCSIController Microsoft® Windows® Management Instrumentation (WMI) 类，以确定是否为 DriverName 关键字设置了值。Exchange Server 分析工具确定是否存在下列条件：

  • Emulex FC Port 驱动程序安装在 Exchange 服务器上。

  • 最新版本的 Emulex FC Port 驱动程序安装在 Exchange 服务器上。

  • Emulex FC Port 驱动程序在前两年中已更新。

如果 Exchange Server 分析工具发现 DriverName 关键字的值已超过两年未更新，则 Exchange Server 分析工具将显示警告。

Emulex FC Port 驱动程序在单个主机总线适配器 (HBA) 或多个 HBA 中提供仅 SCSI 或并发 SCSI 和 IP 功能。FC Port 驱动程序支持光纤通道仲裁环 (FC-AL) 拓扑、点到点拓扑和结构拓扑。FC Port 驱动程序针对一些特殊的应用程序，这些应用程序需要基于主机的逻辑单元号码 (LUN) 映射或持久绑定。

若要更新 Emulex FC Port 驱动程序，请参阅"Downloads and Manuals for Windows"（英文）(http://www.emulex.com/ts/docfc/winframe.htm)。如果需要特殊的 OEM 驱动程序，请参阅 Emulex 网站 (http://www.emulex.com/ts/index.html) 中的"software and documentation"（英文）。

注意：
在本主题中提供的第三方网站信息是为了帮助您查找所需的技术信息。URL 如有更改，恕不另行通知。


Emulex SCSIport Miniport 驱动程序已超过两年未更新
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2006-06-14

Microsoft® Exchange Server 分析工具查询 Win32_SCSIController Microsoft Windows® Management Instrumentation (WMI) 类，以确定是否为 DriverName 关键字设置了值。Exchange Server 分析工具确定是否存在下列条件：

  • Emulex SCSIport Miniport 驱动程序安装在 Exchange 服务器上。

  • 最新版本的 Emulex SCSIport Miniport 驱动程序安装在 Exchange 服务器上。

  • Emulex SCSIport Miniport 驱动程序在前两年中已更新。

如果 Exchange Server 分析工具发现 DriverName 关键字的值已超过两年未更新，则 Exchange Server 分析工具将显示警告。

SCSIport Miniport 驱动程序支持光纤通道仲裁环 (FC-AL) 拓扑、点到点拓扑和结构拓扑上的 SCSI 功能。

若要更新 Emulex SCSIport Miniport 驱动程序，请参阅 Downloads and Manuals for Windows（英文）(http://www.emulex.com/ts/docfc/winframe.htm)。如果需要特殊的 OEM 驱动程序，请参阅 OEM 软件和文档（英文）(http://www.emulex.com/ts/index.html)。

注意：
Web 地址可能会改变，所以，也许无法连接到此处提到的网站。


Emulex Storport Miniport 驱动程序已超过两年未更新
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2006-06-14

Microsoft® Exchange Server 分析工具查询 Win32_SCSIController Microsoft® Windows® Management Instrumentation (WMI) 类，以确定是否为 DriverName 关键字设置了值。Exchange Server 分析工具确定是否存在下列条件：

  • Emulex Storport Miniport 驱动程序安装在 Exchange 服务器上。

  • 最新版本的 Emulex Storport Miniport 驱动程序安装在 Exchange 服务器上。

  • Emulex Storport Miniport 驱动程序在前两年中已更新。

如果 Exchange Server 分析工具发现 DriverName 关键字的值已超过两年未更新，则 Exchange Server 分析工具将显示警告。

Emulex Storport Miniport 驱动程序优化存储区域网络 (SAN) 和基于硬件的磁盘阵列的性能和可管理性。Emulex Storport Miniport 驱动程序支持光纤通道仲裁环 (FC-AL) 拓扑、点到点拓扑和结构拓扑。

若要更新 Emulex Storport Miniport 驱动程序，请参阅"Downloads and Manuals for Windows"（英文）(http://www.emulex.com/ts/docfc/winframe.htm)。如果需要特殊的 OEM 驱动程序，请参阅"OEM software and documentation"（英文）(http://www.emulex.com/ts/index.html)。

注意：
Web 地址可能会改变，所以，也许无法连接到此处提到的网站。


非 Exchange 进程的高 CPU 使用率
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

  • Microsoft® Exchange Server 分析工具发现了一个非 Exchange Server 进程，它当前占用了 20% 以上的服务器可用 CPU。如果非 Exchange Server 进程使用了 20% 以上的可用 CPU，则显示错误。

  • 建议运行 Exchange Server 的服务器尽可能专用于 Exchange Server，并且尽量减少运行 Exchange 以外的应用程序和服务。

更正此错误

  • 如果其他进程占用大多数的 CPU，则尝试执行下列选项之一：

    • 关闭进程并查看问题是否消失。

    • 如有可能，将此进程移至另一台服务器。

    • 确保进程得到正确配置并查找 Microsoft 以及进程提供商提供的用于解决此问题的所有更新。

    • 卸载不需要的进程。

  • 如果无法移动或修复进程，则应重新调整服务器以容纳非 Exchange Server 进程所添加的负载。在上述调整过程中，应考虑将用户移至另一台 Exchange 服务器。


HP/Compaq Secure Path 服务已停止
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 HP/Compaq Secure Path 服务是否正在运行。如果 Exchange Server 分析工具确定未运行 HP/Compaq Secure Path 服务，则显示警告。

HP/Compaq Secure Path 服务是一个多路径 I/O (MPIO) 软件。多路径允许主机有最多 32 个访问外部存储设备的路径，从而提供高可用性的数据访问能力，这给故障转移和负载平衡提供了很大的便利。多路径不是操作系统的功能，但可通过 MPIO 驱动程序开发工具包 (DDK) 支持该功能，此工具包使存储供应商能够创建可互操作的多路径解决方案。

MPIO 软件运行时，Windows 操作系统只会检测到一个驱动器，并由 MPIO 软件来管理与多种存储设备相连的多个连接。如果 MPIO 软件已停止，则所有已连接的存储驱动器将作为独立的驱动器被 Windows 检测到。这很可能导致存储错误和故障。

解决此警告问题

  1. 打开服务 MMC 管理单元。

  2. 用鼠标右键单击"HP/Compaq Secure Path"服务，再单击"属性"。

  3. 在"HP/Compaq Secure Path"服务属性页的"常规"选项卡上，确保"启动类型"被设置为"自动"。如果不是，请单击"应用"，再单击"确定"。

  4. 用鼠标右键单击"HP/Compaq Secure Pat"服务，再单击"启动"。

  5. 关闭服务管理单元。

有关与 Windows 一起部署其他存储技术的常规信息，请参阅站点上的"Planning to Use Windows Storage Features with SANs"（英文）(http://go.microsoft.com/fwlink/?linkid=33626)。


第三方软件的影响
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具确定 Exchange 服务器上正在运行第三方软件。此第三方软件可能会使服务器出现性能问题。第三方软件可能包括（但不限于）下列软件：

  • 文件级防病毒产品

  • Exchange 支持的电子邮件防病毒产品

  • 反垃圾邮件产品

  • 传真服务器软件

  • 外部邮件或协作连接器

  • 文件和打印服务

  • 移动设备连接器

更正此错误

  • 如果您怀疑第三方软件降低 Exchange Server 性能，请卸载或禁用第三方软件并测量 Exchange Server 性能。

  • 如果您确定第三方软件导致性能降低，同时此第三方软件对服务器的功能非常重要，请考虑指定其他服务器以便将负载分布在两台服务器之间。

详细信息

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。


可用的 INO_FLPY.SYS 版本更新
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Ino_flpy.sys Computer Associates 防病毒过滤器驱动程序的版本。

Exchange Server 分析工具查询 CIM_Datafile WMI 类，以根据版本的内部版本号确定 Ino_flpy.sys 的 Version 关键字的值，可能需要进行软件更新。如果 Version 关键字的值表明 Ino_flpy.sys 文件的版本号小于 5.00.6100.109，则会显示警告。

如果版本号小于 5.00.6100.109，表明 Exchange Server 计算机上未安装最新版本的 Ino_flpy.sys 文件，应安装更高版本的过滤器驱动程序。Ino_flpy.sys 文件的防病毒软件更新可以在 Computer Associates 网站上找到。强烈建议安装此防病毒软件更新，它可以提高 Exchange Server 计算机的整体性能和可靠性。

如果 Exchange 2000 Server 或 Exchange Server 2003 计算机上安装了 Inoculan Computer Associates eTrust Antivirus 版本 6.x 或 7.x 以及 InoculateIT 版本 6.x 防病毒软件程序，安装程序将 Ino_flpy.sys 和 Ino_fltr.sys 防病毒过滤器驱动程序文件复制到 %systemroot%\system32\drivers 文件夹中。防病毒驱动程序文件是用于启动所需的防病毒服务的 Windows NT® 内核模式驱动程序。较早版本的过滤器驱动程序可能会使 Exchange Server 计算机发生意想不到的结果。

解决此警告问题

  1. 若要获取 ino_flpy.sys 文件最新的防病毒软件更新，请访问 Computer Associates 网站 (http://supportconnectw.ca.com/premium/antivirus/downloads/nt/4.5/ildrvupdate.asp)。

  2. 下载 eTrust 或 InoculateIT 相应的更新版本。

  3. 对 Exchange Server 计算机进行完整备份，包括 Ino_flpy.sys 文件的备份。

  4. 安装 eTrust 或 InoculateIT 最新的更新。
注意：
Web 地址可能有变化，因此您可能无法连接到这里提到的网站。

有关如何对 Exchange Server 使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 240309"How to Fully Disable Antivirus Software from Filtering Files"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240309)

  • 328841"XADM:Exchange 和防病毒软件"(http://support.microsoft.com/?kbid=328841)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)。

  • 245822"有关在安装了防病毒软件的 Exchange 计算机上排除故障的建议"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅"Exchange Partners:Antivirus 网站 (http://go.microsoft.com/fwlink/?linkid=16226)。


可用的 INO_FLTR.SYS 版本更新
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Ino_fltr.sys Computer Associates 防病毒过滤器驱动程序的版本。

Exchange Server 分析工具查询 CIM_Datafile WMI 类，以根据版本的内部版本号确定 Ino_fltr.sys 的 Version 关键字的值，可能需要进行软件更新。如果 Version 关键字的值表明 Ino_fltr.sys 文件的版本号小于 5.00.6100.142，则会显示警告。

如果版本号小于 5.00.6100.142，表明 Exchange Server 计算机上未安装最新版本的 Ino_fltr.sys 文件，应安装更高版本的过滤器驱动程序。Ino_fltr.sys 文件的防病毒软件更新可以在 Computer Associates 网站上找到。强烈建议安装此防病毒软件更新，它可以提高 Exchange Server 计算机的整体性能和可靠性。

如果 Exchange 2000 Server 或 Exchange Server 2003 计算机上安装了 Inoculan Computer Associates eTrust Antivirus 版本 6.x 或 7.x 以及 InoculateIT 版本 6.x 防病毒软件程序，安装程序将 Ino_flpy.sys 和 Ino_fltr.sys 防病毒过滤器驱动程序文件复制到 %systemroot%\system32\drivers 文件夹中。防病毒驱动程序过滤器文件是用于启动所需的防病毒服务的 Windows NT® 内核模式驱动程序。较早版本的过滤器驱动程序可能会使 Exchange Server 计算机发生意想不到的结果。

解决此警告问题

  1. 若要获取 Ino_fltr.sys 文件的最新防病毒软件更新，请访问 Computer Associates 网站：(http://supportconnectw.ca.com/premium/antivirus/downloads/nt/4.5/ildrvupdate.asp)。

  2. 下载 eTrust 或 InoculateIT 相应的更新版本。

  3. 对 Exchange Server 计算机进行完整备份，包括 Ino_fltr.sys 文件的备份。

  4. 安装 eTrust 或 InoculateIT 最新的更新。
注意：
Web 地址可能有变化，因此您可能无法连接到这里提到的网站。

有关如何对 Exchange Server 使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 240309"How to Fully Disable Antivirus Software from Filtering Files"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240309)

  • 328841"XADM:Exchange 和防病毒软件"(http://support.microsoft.com/?kbid=328841)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange 计算机上排除故障的建议"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅"Exchange Server Partners:Antivirus 网站 (http://go.microsoft.com/fwlink/?linkid=16226)。


McAfee GroupShield 5.2 for Microsoft Exchange Update for Exchange 可用
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2006-04-19

Microsoft® Exchange Server 分析工具将读取以下注册表值，以确定病毒扫描应用程序编程接口 (VSAPI) 库文件是否已向 Microsoft Exchange 信息存储服务注册：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

如果 McAfee GroupShield 5.2 for Microsoft Exchange 安装在 Exchange 2000 Server 或 Exchange Server 2003 上，Library 注册表项的值将为 GSEVS2.DLL。在 GroupShield 5.2 for Microsoft Exchange 中，该库文件执行几个与 VSAPI 相关的功能。

Exchange Server 分析工具还查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 GSEVS2.DLL 的 Version 关键字的值。如果 Version 关键字的值表明该文件的内部版本号小于 682，则会显示警告。

如果 GSEVS2.DLL 的版本号小于 682，则表明没有安装 GroupShield 5.2 for Microsoft Exchange 的最新版本。从 McAfee 网站可以获得 GroupShield 5.2 for Microsoft Exchange 的软件更新。强烈建议安装该更新，它可以提高总体性能和可靠性。此外，升级到 GroupShield for Microsoft Exchange 5.2.682 可以保证您使用的重要 DLL 是最新的版本。使用最新版本的 gsevs2.dll 显著提高了 Exchange Server 邮件部署的性能和可靠性。

解决此警告问题

  1. 访问 McAfee 网站的"Guided Knowledge Search"页 (http://knowledgemap.nai.com/)，以确定 GroupShield 5.2 for Microsoft Exchange Server 的最新版本。使用该站点上的下列 McAfee 解决方案知识库文章和其他 McAfee 解决方案知识库文章，以确定最新的版本：

    • 解决方案 ID KB40567"Getting the latest version of GroupShield and/or SpamKiller"

    • 解决方案 ID KB nai18117"Product Version Information for GroupShield for Exchange 2000"

  2. 访问 McAfee 网站 (https://secure.nai.com/us/forms/downloads/upgrades/login.asp)。

  3. 下载您的 GroupShield 5.2 for Microsoft Exchange Server 版本的最新更新。

  4. 对 Exchange Server 计算机进行完整备份。

  5. 安装 GroupShield 5.2 for Microsoft Exchange Server 的最新更新。
注意：
在本主题中提供的第三方网站信息是为了帮助您查找所需的技术信息。URL 如有更改，恕不另行通知。

有关如何对 Exchange Server 使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"Exchange 和防病毒软件"(http://support.microsoft.com/kb/328841/zh-cn)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange Server 计算机上排除故障的建议"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅"Exchange Server Partners:Antivirus 网站 (http://go.microsoft.com/fwlink/?linkid=16226)


McAfee GroupShield 6.0 for Microsoft Exchange Update for Exchange 可用
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表值，以确定是否已使用 Microsoft Exchange 信息存储服务注册了病毒扫描应用程序编程接口 (VSAPI) 库文件：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

如果 McAfee GroupShield 6.0 for Microsoft Exchange 安装在 Exchange 2000 Server 或 Exchange Server 2003 上，则库注册表项的值将是 VSAPISCANSOURCE.DLL。在 GroupShield 6.0 for Microsoft Exchange 中，该库文件执行几个与 VSAPI 相关的功能。

Exchange Server 分析工具还查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 VSAPISCANSOURCE.DLL 的 Version 关键字的值。如果 Version 关键字的值指示该文件的内部版本号小于 6.0.1148.0，则显示警告。

如果 VSAPISCANSOURCE.DLL 的版本号小于 6.0.1148.0，则指示未安装 GroupShield 6.0 for Microsoft Exchange 的最新版本。从 McAfee 网站可以获得 GroupShield 6.0 for Microsoft Exchange 的软件更新。强烈建议安装该更新，它可以提高总体性能和可靠性。

解决此警告问题

  1. 通过访问 McAfee 网站的 Guided Knowledge Search 页 (http://knowledgemap.nai.com/)，确定 GroupShield 6.0 for Microsoft Exchange 的最新版本。使用下列 McAfee 解决方案文章和位于该站点的其他 McAfee 解决方案文章来确定最新版本：

    • 解决方案 ID nai18117"Product Version Information for GroupShield for Exchange 2000"

    • 解决方案 ID KB37636"Version numbers for McAfee GroupShield 6.x for Microsoft Exchange"

    • 解决方案 ID KB40567"Getting the latest version of GroupShield and/or SpamKiller"

  2. 访问 McAfee 网站的"Product Downloads"页 (https://secure.nai.com/us/forms/downloads/upgrades/login.asp)。

  3. 下载您的 GroupShield 6.0 for Microsoft Exchange 版本的最新更新。

  4. 对 Exchange Server 计算机进行完整备份。

  5. 安装 GroupShield 6.0 for Microsoft Exchange 的最新更新。
注意：
本主题中提供了第三方网站信息，可以帮助您找到需要的技术信息。URL 如有更改，恕不通知。

有关如何对 Exchange Server 使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"Exchange 和防病毒软件"(http://support.microsoft.com/kb/328841/zh-cn)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange Server 计算机上排除故障的建议"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅"Exchange Server Partners:Antivirus 网站 (http://go.microsoft.com/fwlink/?linkid=16226)。


McAfee GroupShield 安装在此 Exchange 服务器上，但该服务未运行
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange 计算机上是否已安装 McAfee GroupShield for Microsoft Exchange，并且正在运行 McAfee GroupShield 服务。

Exchange Server 分析工具还查询 Win32_Service WMI 类，以确定为 Microsoft Exchange 信息存储服务的 Started 关键字设置的值为 True 还是 False。

值为 False 意味着信息存储服务未运行在此 Exchange Server 计算机上。值为 True 意味着 Microsoft Exchange 信息存储服务在运行。

如果 Exchange Server 分析工具发现 Microsoft Exchange 信息存储服务在运行，并且 McAfee GroupShield 已安装，但 McAfee GroupShield 服务未启动，则显示警告。

McAfee GroupShield 为 Exchange 提供防病毒保护。McAfee GroupShield 服务可能由于某些原因而停止。下面列出了这些原因以及相应的解决方案：

  • 运行在 Exchange Server 上的软件可能是评估版或适用版，并且已过期。如果是这样情况，可能需要重新安装 McAfee GroupShield。至少需要将它激活才能继续使用该软件。

  • 管理员可能在无意中停止了 McAfee GroupShield 服务。确认服务设置为自动启动，然后启动该服务。

  • 恶意的蠕虫、病毒或其他程序可能停止了该服务。确认服务设置为自动启动，然后启动该服务。如果服务仍然在没有相关的错误事件发生的情况下意外地停止，请确认计算机未感染恶意蠕虫，并在必要时对系统进行杀毒。

Microsoft 通常建议在简单邮件传输协议 (SMTP) 网关或驻留邮箱的 Exchange 服务器上部署专为邮件系统而设计的防病毒软件。要实施最全面的保护，应在扫描传入 MIME 邮件的网关上运行防病毒软件，在使用 VSAPI 2.5 的 Exchange Server 上运行扫描程序。

启动 McAfee GroupShield 服务

  1. 打开"服务"MMC 管理单元。

  2. 用鼠标右键单击"McAfee GroupShield"服务，再单击"属性"。

  3. 在 McAfee GroupShield 属性页的"常规"选项卡上，确保"启动类型"设置为"自动"。如果不是，请单击"应用"，再单击"确定"。

  4. 用鼠标右键单击"McAfee GroupShield"服务，再单击"启动"。

  5. 关闭"服务"管理单元。

此外，还应当在用户台式机上运行客户端防病毒软件。如果在网关或 Exchange 服务器上运行专门为邮件系统设计的防病毒软件（可以分析并扫描 MIME），则在台式机上运行文件级别的扫描程序已足够。

  • 有关通常与 Microsoft Exchange Server 2003 一起使用的不同类型的病毒扫描程序的详细信息，请参阅 Microsoft 知识库文章 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)。

  • 有关通常与 Microsoft Exchange 2000 Server 一起使用的不同类型的病毒扫描程序的详细信息，请参阅知识库文章 328841"Exchange 和防病毒软件"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)。

  • 有关加强 Exchange 环境以防御通过电子邮件传输的病毒和蠕虫的信息，请参阅 Microsoft 白皮书"在 Exchange 2003 环境中抑制和阻止通过电子邮件传输的病毒"(http://www.microsoft.com/downloads/details.aspx?FamilyID=fb3f649a-2b0a-443d-92a5-8f8cf4bf9fdb&DisplayLang=zh-cn)。


Messageware Plus Pack 已安装
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已在所有 Exchange Server 中安装了 Messageware Plus Pack：

HKEY_LOCAL_MACHINE\Software\Messageware Incorporated\Core Services\PlusPack\Load

如果 Exchange Server 分析工具发现 Load 的数值数据等于 1，则 Exchange Server 分析工具将显示非默认配置消息。

Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。

Messageware Plus Pack 是 Messageware Incorporated 开发的 Microsoft Office Outlook® Web Access for Exchange Server 2003 加载项。Messageware Plus Pack 扩展并增强 Outlook Web Access Basic 用户和 Outlook Web Access Premium 用户的 Outlook Web Access。

有关 Messageware Plus Pack 的详细信息，请参阅网站上的"Messageware OWA Suite"(http://www.messageware.com)。

注意：
Web 地址可能会改变，所以，也许无法连接到此处提到的网站。


Microsoft Antigen 数据执行保护功能的兼容性
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2007-02-19

Microsoft Exchange 分析工具查询 Win32_Service Microsoft Windows Management Instrumentation (WMI) 类，以确定 Microsoft Antigen 服务的 Started 关键字的值。值为 False 表明该服务未运行。值为 True 表明该服务正在运行。

Exchange 分析工具还读取以下注册表项，以确定 Exchange Server 上是否安装了 Microsoft Antigen 的卡巴斯基扫描引擎。只有在 Exchange Server 上安装了卡巴斯基扫描引擎，此注册表项才会存在。

HKEY_LOCAL_MACHINE\Software\Sybari Software\Antigen for Exchange\Scan Engines\Kaspersky

最后，如果 Exchange Server 正在 Microsoft Windows Server 2003 Service Pack 1 (SP1) 或更高版本上运行，Exchange 分析工具将查询 Win32_ComputerSystem WMI 类，以确定 SystemStartupOptions 关键字的值是否包含字符串"/NOEXECUTE=OPTOUT"或"/NOEXECUTE=ALWAYSON"。这表明服务器上已启用数据执行保护 (DEP) 功能。数据执行保护功能是一组硬件和软件技术，对内存执行附加的检查，以帮助阻止恶意代码在系统上运行。

如果 Exchange 分析工具确定下列条件为真，Exchange 分析工具将显示警告：

  • 服务器上已启用 Microsoft Antigen 服务。

  • 已安装 Antigen 的卡巴斯基扫描引擎。

  • Exchange 服务器正在 Microsoft Windows Server 2003 Service Pack 1 (SP1) 或更高版本上运行。

  • 服务器上已启用数据执行保护功能。

此警告表明当前的服务器配置可能会导致邮件传递和病毒扫描的性能问题。

若要解决此警告指明的问题，请按照 Microsoft 知识库文章 905952"Antigen 中的邮件传递性能低于预期，Antigen 客户端停止响应"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905952) 中的指导操作，以便有选择地对各个程序禁用 DEP。

详细信息

有关数据执行保护功能的详细信息，请参阅 Microsoft 知识库文章 875352"Windows XP Service Pack 2、Windows XP Tablet PC Edition 2005 以及 Windows Server 2003 中数据执行保护 (DEP) 功能的详细说明"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=875352)。


NSI Software Double-Take 已安装
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Double-Take 服务的 Started 关键字的值。值为 True 说明该 Exchange Server 上正在运行 Double-Take 服务。如果在 Exchange Server 上检测到 Double-Take 服务，Exchange Server 分析工具将显示非默认配置消息。

Exchange Server 分析工具仅以提供信息为目的报告此非默认配置。不需要执行任何操作。

NSI Software, Inc. 的 Double-Take 通过标准网络连接将用户选择的文件或完整的列从一台或多台源服务器复制到一台或多台目标服务器。通过这种复制，可以在发生灾难或系统崩溃后快速恢复，可能需要也可能不需要用户参与。

有关 Double-Take 的详细信息，请访问网站上的"Double-Take"(http://www.nsisoftware.com/pro/doubletake)。

注意：
Web 地址可能会改变，所以，也许无法连接到此处提到的网站。

Double-Take 是数据复制软件。有关 Exchange 2000 Server 和 Exchange Server 2003 的多站点数据复制的详细信息，请参阅 Microsoft 知识库文章 895847"Multi-site data replication support for Exchange 2003 and Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895847)。


非 Exchange 进程占用 20% 以上的处理器时间
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2006-02-13

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 Processor 性能对象的 %Processor Time (_Total) 计数器收集数据，以分析性能数据。

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • 存在处理器瓶颈。

  • 一个或多个非 Exchange 进程占用了超过 20% 的总平均服务器 CPU 时间。

如果下列条件为真，则 Exchange Server 分析工具将显示警告：

  • 存在处理器瓶颈。

  • 一个或多个非 Exchange 进程占用了超过 20% 的总平均服务器 CPU 时间。

此 % Processor Time (_Total) 性能计数器（位于 Process 性能对象下）提供处理器的总利用率。平均的 CPU 利用率应始终低于 80%。更高的平均值表明存在处理器瓶颈。如果处理器时间中频繁出现高于 90% 的峰值，也表明存在处理器瓶颈。

消除处理器瓶颈

可以通过许多方式消除 Exchange 服务器的处理器瓶颈。

  • 第一，检查在服务器中导致负载的应用程序和任务。确定该应用程序是否正在占用处理器时间；或者确定进程是否存在问题。

  • 如果某个非 Exchange 应用程序对于该服务器并不重要，则应在其他服务器上运行该应用程序。如果可行，也要将服务器角色转移到其他计算机。例如，如果 Inetinfo 进程占用了大量 CPU 利用率，请考虑增加前端服务器，以承担 Inetinfo 执行的协议工作责任。也可以将公用文件夹存取转移到专用的公用文件夹服务器。最后，如果服务器执行大量通讯组列表扩展，则可以通过将通讯组列表扩展转移到专用的通讯组列表扩展服务器，来降低 CPU 利用率。

  • 如果可能，应为服务器添加更多或速度更快的处理器。此外，如果处理器支持，应启用超线程。可以通过配置系统 BIOS 来启用超线程。有关详细信息，请参阅计算机制造商的帮助文档。

  • 如果增加处理能力不可行，则必须降低处理器的负载。为了降低负载对服务器的总体影响，请务必在正常工作时间以外执行 I/O 密集型、CPU 密集型或占用内存型的任务。

  • 请务必使 CPU 密集型任务（如备份和维护）在非高峰时段进行，同时确保这些任务以分阶段的方式执行。将任务分阶段意味着为每个任务设置不同的开始时间，同时最好也设置不同的结束时间。分阶段维护和备份数据库或存储组还可以减小这些资源密集型任务产生的影响。

详细信息

  • 有关处理器瓶颈的详细信息，请参阅处理器瓶颈。

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 有关如何移动用户邮箱以降低服务器负载的详细信息，请参阅将用户邮箱移至其他服务器。


非 Exchange 进程占用 50% 以上的处理器时间
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2006-02-13

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。性能数据收集引擎从 Processor 性能对象的 %Processor Time (_Total) 计数器收集数据，以分析性能数据。

此 % Processor Time (_Total) 性能计数器（位于 Process 性能对象下）提供处理器的总利用率。平均的 CPU 利用率应始终低于 80%。更高的平均值表明存在处理器瓶颈。如果处理器时间中频繁出现高于 90% 的峰值，也表明存在处理器瓶颈。

如果 Exchange Server 分析工具确定某个非 Exchange 进程占用了超过 50% 的总平均服务器 CPU 时间，则即使没有检测到实际的处理器瓶颈，也会显示警告信息。

消除潜在的处理器瓶颈

可以通过许多方式消除 Exchange 服务器的潜在处理器瓶颈。

  • 第一，检查在服务器中导致负载的应用程序和任务。确定该应用程序是否正在占用处理器时间；或者确定进程是否存在问题。

  • 如果某个非 Exchange 应用程序对于该服务器并不重要，则应在其他服务器上运行该应用程序。如果可行，也要将服务器角色转移到其他计算机。例如，如果 Inetinfo 进程占用了大量 CPU 利用率，请考虑增加前端服务器，以承担 Inetinfo 执行的协议工作责任。也可以将公用文件夹存取转移到专用的公用文件夹服务器。最后，如果服务器执行大量通讯组列表扩展，则可以通过将通讯组列表扩展转移到专用的通讯组列表扩展服务器，来降低 CPU 利用率。

  • 如果可能，应为服务器添加更多或速度更快的处理器。此外，如果处理器支持，应启用超线程。可以通过配置系统 BIOS 来启用超线程。有关详细信息，请参阅计算机制造商的帮助文档。

  • 如果增加处理能力不可行，则必须降低处理器的负载。为了降低负载对服务器的总体影响，请务必在正常工作时间以外执行 I/O 密集型、CPU 密集型或占用内存型的任务。

  • 请务必使 CPU 密集型任务（如备份和维护）在非高峰时段进行，同时确保这些任务以分阶段的方式执行。将任务分阶段意味着为每个任务设置不同的开始时间，同时最好也设置不同的结束时间。分阶段维护和备份数据库或存储组还可以减小这些资源密集型任务产生的影响。

详细信息

  • 有关处理器瓶颈的详细信息，请参阅处理器瓶颈。

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。


安装了 HP/Compaq Secure Path 的过时版本
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-12-13

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定在 Exchange 服务器上所安装的 HP/Compaq Secure Path 软件的软件版本。如果 Secure Path 版本不是 3.7.2.540，则会显示警告。

若要解决此警告问题，请更新 Secure Path 软件。请与您的 HP/Compaq 销售商联系，以更新该软件。

有关 HP/Compaq Secure Path 软件更新的详细信息，请访问 HP 网站上的"HP StorageWorks Secure Path"（英文）(http://h18006.www1.hp.com/products/sanworks/softwaredrivers/securepath/index.html)。

注意：
本主题中提供了第三方网站信息，可以帮助您找到需要的技术信息。URL 如有更改，恕不通知。


端口 25 被阻止
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2006-10-06

Microsoft® Exchange Server 分析工具将读取以下注册表值，以确定正在运行 Exchange Server 的服务器上是否安装了 McAfee VirusScan for Microsoft Exchange。

HKEY_LOCAL_MACHINE\Software\Network Associates\TVD\VirusScan Enterprise\CurrentVersion

Exchange Server 分析工具还查询以下注册表分支，以确定如何配置 VirusScan 产品以阻止端口：

HKLM\Software\Network Associates\TVD\Shared Components\On Access Scanner\BehaviourBlocking

此分支中的注册表项用于配置通过 VirusScan 产品的"访问时"扫描功能阻止或允许访问的进程和端口。

最后，Exchange Server 分析工具还将查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Started 关键字的值，通过该值来确定 Exchange 服务器上是否运行了该服务。

值为 False 表明 McAfee VirusScan 服务未运行在此 Exchange 服务器上。值为 True 表明 McAfee VirusScan 服务正在运行。

如果下列条件为真，则 Exchange Server 分析工具将显示警告：

  • Exchange 服务器上已安装并正在运行 McAfee VirusScan。

  • 对端口 25 启用了"防止批量邮件蠕虫病毒发送邮件"阻止规则。

  • Exchange 简单邮件传输协议 (SMTP) 服务未从该阻止规则中排除。

此警告表明已配置了 McAfee VirusScan 应用程序，因此该应用程序可以通过端口 25 阻止合法的 Exchange Server 通信。此时可能出现邮件流问题。

若要解决该问题，请执行下列操作：

  • 请考虑是否禁用"防止批量邮件蠕虫病毒发送邮件"阻止规则。

  • 将 Exchange Server SMTP 服务添加到"防止批量邮件蠕虫病毒发送邮件"阻止规则的排除列表中。

详细信息

  • 有关如何配置 McAfee VirusScan for Microsoft Exchange 的详细信息，请访问 McAfee 服务门户网站 (http://knowledge.mcafee.com/)。

    注意：
    提供第三方网站信息有助于查找所需的技术信息。URL 如有更改，恕不另行通知。
  • 有关通常与 Microsoft Exchange Server 2003 一起使用的不同类型的病毒扫描程序的详细信息，请参阅 Microsoft 知识库文章 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)。

  • 有关通常与 Microsoft Exchange 2000 Server 一起使用的不同类型的病毒扫描程序的详细信息，请参阅知识库文章 328841"Exchange 和防病毒软件"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)。

  • 有关加强 Exchange 环境以防御通过电子邮件传输的病毒和蠕虫的信息，请参阅 Microsoft 白皮书"Slowing and Stopping E-Mail Transmitted Viruses in an Exchange Environment"（在 Exchange 环境中抑制和阻止通过电子邮件传输的病毒）(http://go.microsoft.com/fwlink/?LinkId=30732)。


Red Earth Software Policy Patrol for Exchange Server Needs Update
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2007-07-24

Microsoft Exchange 分析工具读取注册表项，以确定是否存在以下子项之一：

HKEY_LOCAL_MACHINE\Software\Red Earth Software\Policy Patrol\3.0

HKEY_LOCAL_MACHINE\Software\Wow6432Node\Red Earth Software\Policy Patrol\3.0

若存在上述两子项之一，则表示本地计算机上已安装 Exchange Server 的 Red Earth Software Policy Patrol V3.0。

如果 Exchange 分析工具发现本地计算机上已安装 Exchange Server 的 Policy Patrol V3，则 Exchange 分析工具会显示警告。

该警告表明 Exchange Server 的 Policy Patrol 具有推荐的更新。

解决此警告问题

  1. 请访问 http://www.policypatrol.com/download.htm 上的 Exchange Server 的 Red Earth Software Policy Patrol 下载网站。

  2. 下载并安装 Exchange Server 的 Policy Patrol 任何所需的更新或建议的更新。
注意：
提供第三方网站信息是为了帮助您查找所需的技术信息。URL 如有更改，恕不另行通知。


ScanMail for Microsoft Exchange 和 CA eTrust 同时运行
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Exchange 服务器上安装的 Trend Micro ScanMail for Microsoft Exchange 的版本：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

如果 Version 值的数值数据以 7 开始，则指示已安装 ScanMail for Microsoft Exchange 版本 7。

Exchange Server 分析工具还读取以下注册表项，以确定是否还在 Exchange 服务器上安装了 Computer Associates eTrust。

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\

如果 CurrentVersion 注册表值存在，则指示 Exchange 服务器上已安装 Computer Associates eTrust Antivirus 7。

最后，Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation 类，以确定 InoRT 服务（在 eTrust Antivirus 中，也称为 eTrust Antivirus Realtime Server 服务）的 Started 关键字的值。

如果下列条件为真，则 Exchange Server 分析工具将显示最佳做法消息：

  • Exchange 服务器上同时安装了 ScanMail for Microsoft Exchange 和 eTrust Antivirus。

  • eTrust Antivirus Realtime Server 服务已启动。

Trend Micro 建议任何基于文件系统的防病毒软件（如 eTrust Antivirus）将 ScanMail for Microsoft Exchange 文件夹从扫描中排除。ScanMail for Microsoft Exchange 使用其路径中的临时文件夹执行扫描活动。如果基于文件系统的防病毒扫描程序扫描这些临时文件夹，则此扫描操作可能妨碍 ScanMail for Microsoft Exchange 的常规操作。

最佳做法是通过基于文件系统的防病毒软件（如 Computer Associates eTrust Antivirus）将 ScanMail for Microsoft Exchange 文件夹从实时扫描中排除。有关如何在安装有基于文件系统的防病毒软件的计算机上使用 ScanMail for Microsoft Exchange 的详细信息，请参阅 Trend Micro 知识库文章"Installing another antivirus application with ScanMail for Exchange also installed on the same server"（英文）(http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=8540)。

注意：
提供第三方网站信息是为了帮助您查找所需的技术信息。URL 如有更改，恕不通知。


ScanMail for Microsoft Exchange 存档目录包含过多文件
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已安装 Trend Micro ScanMail for Microsoft Exchange 7.0：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server 分析工具然后对 ScanMail for Microsoft Exchange 所使用的存档目录中的文件进行计数。默认情况下，存档目录路径如下所示：

C:\Program Files\Trend Micro\Smex\Storage\Archive

如果下列条件为真，Exchange Server 分析工具将显示警告：

  • 已安装 ScanMail for Microsoft Exchange 7.0。

  • ScanMail for Microsoft Exchange 所使用的存档目录中的文件数超过 1,000 个。

此警告指示 ScanMail for Microsoft Exchange 所使用的存档目录中存在的文件过多。Trend Micro 建议您定期查看并清除 ScanMail for Microsoft Exchange 所使用的存档文件夹。


ScanMail for Microsoft Exchange 备份目录包含的文件过多
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否安装了 Trend Micro ScanMail for Microsoft Exchange 版本 7.0：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

然后，Exchange Server 分析工具计算 ScanMail for Microsoft Exchange 所使用的备份目录中存在的文件数。默认情况下，备份目录路径如下所示：

C:\Program Files\Trend Micro\Smex\Storage\Backup

如果以下条件为真，Exchange Server 分析工具将显示警告：

  • ScanMail for Microsoft Exchange 版本 7.0 已安装。

  • ScanMail for Microsoft Exchange 所使用的备份目录中包含的文件数超过 1,000 个。

此警告表明 ScanMail for Microsoft Exchange 所使用的备份目录中存在许多文件。Trend Micro 建议您定期检查并清理 ScanMail for Microsoft Exchange 所使用的备份文件夹。


ScanMail for Microsoft Exchange 备份排除
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具读取以下注册表项，确定已从使用 Windows 备份程序的备份中排除的文件和文件夹：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

Exchange Server 分析工具专门查找包含"SMEX\DATA"的字符串。

如果 Exchange Server 分析工具发现 FilesNotToBackup 注册表项包含有字符串"SMEX\DATA"的值，则会显示警告。

如果您使用的不是 Windows 备份程序，可以放心地忽略此警告。如果使用的是 Windows 备份程序，则建议您删除 SMEX\DATA 目录的排除。Trend Micro 建议用户备份此文件夹中所有文件扩展名为 .mdb 的文件。万一 SMEX\DATA 文件夹中的生产 .mdb 文件损坏或被删除，可以使用备份文件。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

  3. 在左侧窗格中选择 FilesNotToBackup。

  4. 在右侧窗格中，右键单击包含字符串"SMEX\DATA"的值，然后选择"删除"。

  5. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


ScanMail for Microsoft Exchange 已启用调试模式
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Trend Micro 是否已在 ScanMail for Microsoft Exchange 中启用了调试模式：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\DebugModule

如果 DebugModule 的数值数据包含一个或多个下列字符串，则 Exchange Server 分析工具将显示警告：

  • HOST:1

  • CONFIG:1

  • MASTER:1

  • WATCHER:1

  • STORE:1

  • INETINFO:1

  • TCHER:1

  • MON:1

  • MONITOR:1

此警告表明当前已为一个或多个 ScanMail for Microsoft Exchange 模块启用了调试模式。Trend Micro 建议仅在需要时（例如，进行故障排除）启用调试模式。Trend Micro 建议对普通操作禁用调试模式。

解决此警告问题

  1. 请参阅以下 Trend Micro 知识库文章"Enabling the ScanMail for Exchange (SMEX) 7.0 debugging through the Registry Editor"（英文）(http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=25532)。

  2. 按照 Trend Micro 知识库文章中的说明为所有模块禁用调试功能。
注意：
提供第三方网站信息是为了帮助您查找所需的技术信息。URL 如有更改，恕不通知。


ScanMail for Microsoft Exchange 隔离目录包含的文件过多
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否安装了 Trend Micro ScanMail for Microsoft Exchange 版本 7.0：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

然后，Exchange Server 分析工具计算 ScanMail for Microsoft Exchange 所使用的隔离目录中的文件数。默认情况下，隔离目录的路径如下所示：

C:\Program Files\Trend Micro\Smex\Storage\Quarantine

如果以下条件为真，Exchange Server 分析工具将显示警告：

  • ScanMail for Microsoft Exchange 版本 7.0 已安装。

  • ScanMail for Microsoft Exchange 所使用的隔离目录中包含的文件数超过 1,000 个。

此警告表明 ScanMail for Microsoft Exchange 所使用的隔离目录中存在许多文件。Trend Micro 建议您定期检查并清理 ScanMail for Microsoft Exchange 所使用的隔离文件夹。


默认路径中的 ScanMail for Microsoft Exchange SharedResPool 目录
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2007-06-05

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定所安装的 Trend Micro ScanMail for Microsoft Exchange 的版本：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server 分析工具还读取以下注册表项，以确定 SharedResPool 文件夹的位置：

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\SharedResPool

最后，Exchange Server 分析工具读取以下注册表项，以确定安装 ScanMail for Microsoft Exchange 的位置：

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\HomeDir

如果符合下列条件，Exchange Server 分析工具将显示最佳实践消息：

  • 安装 ScanMail for Microsoft Exchange7。

  • SharedResPool 文件夹位于 ScanMail 根目录的路径中。

最好将 SharedResPool 目录重新定位到比 ScanMail for Microsoft Exchange 所使用的根目录的驱动器速度更快的驱动器。Trend Micro 建议客户将 SharedResPool 文件夹重新定位到速度更快的驱动器，以获得更好的性能。SharedResPool 目录包含内存映射文件，用于 ScanMail for Microsoft Exchange 版本 7.0 附带的进程之间的共享资源。7.0. 不应删除此目录的内容。

有关 SharedResPool 文件夹的详细信息，请参阅"What are the ScanMail for Exchange (SMEX) 7.0 SharedResPool and Engine directories?"（什么是 ScanMail for Exchange (SMEX) 7.0 SharedResPool and Engine 目录？）(http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=26898)。

有关移动 SharedResPool 文件夹的详细信息，请参阅"Moving the ScanMail for Exchange (SMEX) 7.0 SharedResPool directory to another location"（移动 ScanMail for Exchange (SMEX) 7.0 SharedResPool 目录到其他位置）(http://esupport.trendmicro.com/support/viewxml.do?ContentID=EN-127549&id=EN-127549)。

注意：
提供第三方网站信息是为了帮助您查找所需的技术信息。URL 如有更改，恕不另行通知。


已在邮箱服务器中启用 ScanMail for Microsoft Exchange SMTP 扫描
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具读取 Microsoft Internet 信息服务 (IIS) 元数据库中的以下属性，以确定 Trend Micro ScanMail for Microsoft Exchange 的当前配置设置：

LM/SmtpSvc/%SMTPINSTANCE%/EventManager/EventTypes/{76719654-05A6-11d2-9dfd-00C04FA322BA}/Bindings/{6BA0CE4C-AC34-411E-B58A-EB715D04019D}/Enabled

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定 Exchange 服务器对象的 serverRole 属性值。如果 serverRole 属性值为 1，则指示 Exchange 服务器已配置为前端服务器。如果值为 0，则指示 Exchange 服务器未配置为前端服务器。

Exchange Server 分析工具还查询 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange 服务器的 OSProductSuite 关键字的值。执行此查询可以确定 Exchange 服务器上运行的特定操作系统。

Exchange Server 分析工具还读取以下注册表值，以确定 Exchange 服务器上运行的 ScanMail for Exchange 的版本：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

如果 Version 值的数值数据以 7 开始，则指示已安装 ScanMail for Microsoft Exchange 版本 7。

最后，Exchange Server 分析工具查询 Active Directory，以确定已配置 homeMDBBL 属性的对象数。已配置 homeMDBBL 属性的对象是指启用了邮箱的对象。因此，已配置 homeMDBBL 属性的对象数即为存在的邮箱数。

如果下列条件为真，则 Exchange Server 分析工具将显示最佳做法消息：

  • 安装 ScanMail for Microsoft Exchange 7。

  • 将 ScanMail for Microsoft Exchange 配置为在未配置为前端服务器的 Exchange 服务器上执行 SMTP 扫描。

  • Exchange 服务器包含的邮箱数超过 20 个。

  • Exchange 服务器未运行 Microsoft Windows Small Business Server 2003 或 Microsoft Small Business Server 2000。

Trend Micro 为 ScanMail for Microsoft Exchange 7 的用户提供如下建议：如果邮箱服务器为单独的专用网关服务器或桥头服务器，则禁用使用邮箱服务器上 ScanMail 管理控制台的 SMTP 扫描。为了获得最佳性能并提高安全性，Trend Micro 建议在网关服务器和桥头服务器（而非邮箱服务器）上启用 SMTP 扫描。


ScanMail for Microsoft Exchange TEMP 目录包含许多文件
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否安装了 Trend Micro ScanMail for Microsoft Exchange 版本 7.0：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

然后，Exchange Server 分析工具计算 ScanMail for Microsoft Exchange 所使用的 TEMP 目录中的文件数。默认情况下，ScanMail for Microsoft Exchange 所使用的 TEMP 目录的路径如下所示：

C:\Program Files\Trend Micro\Smex\Temp

如果以下条件为真，Exchange Server 分析工具将显示警告：

  • ScanMail for Microsoft Exchange 版本 7.0 已安装。

  • ScanMail for Microsoft Exchange 所使用的 TEMP 目录中包含的文件数超过 100 个。

此警告表明 ScanMail for Microsoft Exchange 所使用的 TEMP 目录中存在许多文件。此文件夹中的文件是 ScanMail for Microsoft Exchange 所使用的临时文件。ScanMail for Microsoft Exchange 应自动删除这些文件。

如果许多文件的日期在当前日期之前，那么 Trend Micro 建议您删除旧文件。


ScanMail for Microsoft Exchange TEMP 目录包含的文件过多
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否安装了 Trend Micro ScanMail for Microsoft Exchange 版本 7.0：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

如果 ScanMail for Microsoft Exchange 版本 7 已安装，Exchange Server 分析工具将读取以下注册表项，以确定 ScanMail for Microsoft Exchange 所使用的 TEMP 目录的位置。

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\TempFolderPath

然后，Exchange Server 分析工具计算 ScanMail for Microsoft Exchange 所使用的 TEMP 目录中的文件数。

如果以下条件为真，Exchange Server 分析工具将显示警告：

  • ScanMail for Microsoft Exchange 版本 7.0 已安装。

  • ScanMail for Microsoft Exchange 所使用的 TEMP 目录中包含的文件数超过 100 个。

此警告表明 ScanMail for Microsoft Exchange 所使用的 TEMP 目录中存在许多文件。此文件夹中的文件是 ScanMail for Microsoft Exchange 所使用的临时文件。ScanMail for Microsoft Exchange 应自动删除这些文件。

如果许多文件的日期在当前日期之前，那么 Trend Micro 建议您删除旧文件。


ScanMail for Microsoft Exchange 临时文件夹路径已更改
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已安装 Trend Micro ScanMail for Microsoft Exchange 7.0：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server 分析工具还读取以下项，以确定 ScanMail for Microsoft Exchange 所使用的临时文件夹的位置：

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\TempFolderPath

如果 TempFolderPath 值存在并已在注册表中进行配置，则它的存在表明 ScanMail for Microsoft Exchange 所使用的临时文件夹已从其默认位置中移走。

最后，Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 AdapterSMTP.dll 的 Version 项的值。该模块随 Trend Micro ScanMail for Microsoft Exchange 一起提供。如果 AdapterSMTP.dll 的 Version 项的值小于 7.0.1366，则表明需要 ScanMail for Microsoft Exchange 的更新版本。

如果下列条件为真，则 Exchange Server 分析工具将显示警告：

  • 已安装 ScanMail for Microsoft Exchange 版本 7。

  • ScanMail for Microsoft Exchange 所使用的临时文件夹已从其原始位置移走。

  • adapterSMTP.dll 的文件版本是 7.0.1366 或更早的版本。

Trend Micro 已在最新的 ScanMail for Microsoft Exchange 内部版本中引入了重定位临时文件夹的功能。此功能仅在 7.0.1366 之后的内部版本中可用。此警告指明临时文件夹已重定位，但重定位不会立即生效，因为此服务器运行的是不支持临时文件夹重定位的 ScanMail for Microsoft Exchange 的较早内部版本。

解决此警告问题

  1. 请访问 Trend Micro 更新中心网站 (http://www.trendmicro.com/download)。

  2. 下载并安装 ScanMail for Microsoft Exchange 的任何所需或建议的更新。
注意：
提供第三方网站信息是为了帮助您查找所需的技术信息。URL 如有更改，恕不通知。


ScanMail for Microsoft Exchange 临时文件夹路径的优化
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否安装了 Trend Micro ScanMail for Microsoft Exchange 版本 7.0：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server 分析工具还读取以下注册表项，以确定 ScanMail for Microsoft Exchange 所使用的临时文件夹的位置：

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\TempFolderPath

如果注册表中存在 TempFolderPath 值并且已配置，则表明 ScanMail for Microsoft Exchange 所使用的临时文件夹已从默认位置转移到其他位置。

最后，Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 AdapterSMTP.dll 的 Version 关键字的值。该模块随 Trend Micro ScanMail for Microsoft Exchange 提供。

如果符合下列条件，Exchange Server 分析工具将显示最佳实践消息：

  • ScanMail for Microsoft Exchange 版本 7 已安装。

  • ScanMail for Microsoft Exchange 所使用的临时文件夹仍处于原来的默认位置。

  • AdapterSMTP.dll 的版本是支持 ScanMail for Microsoft Exchange 所使用的临时文件夹进行重定向的版本。

在最近的 ScanMail for Microsoft Exchange 版本中，Trend Micro 引入了重新定位临时文件夹的功能。此功能仅适用于高于 7.0.1366 的版本。如果使用的 ScanMail for Microsoft Exchange 版本高于版本 7.0.1366，Trend Micro 建议您将临时文件夹重新定位到速度更快的驱动器。

重新定位临时文件夹

  1. 请参阅 Trend Micro 知识库文章"Can users change the location of the ScanMail for Exchange (SMEX) 7.0 temporary folder?"（英文）(http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=26343)。

  2. 执行该主题中所示的过程，将临时文件夹重新定位到速度更快的驱动器。
注意：
提供第三方网站信息是为了帮助您查找所需的技术信息。URL 如有更改，恕不通知。


ScanMail for Microsoft Exchange 更新已可用
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-12-15

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 adapterSMTP.dll 的 Version 关键字的值。该模块随 Trend Micro ScanMail for Microsoft Exchange 提供。

如果 Exchange Server 分析工具发现 adapterSMTP.dll 的 Version 关键字的值小于 7.0.1366，Exchange Server 分析工具将显示警告。

此警告表明 ScanMail for Microsoft Exchange 版本 7 已安装在 Exchange 服务器上并且建议的软件更新已可用。强烈建议安装该更新，它可以提高服务器的总体性能和可靠性。

解决此警告问题

  1. 访问 Trend Micro Update Center 网站 (http://www.trendmicro.com/download/)。

  2. 下载并安装 ScanMail for Microsoft Exchange 任何所需的更新或建议的更新。
注意：
提供第三方网站信息是为了帮助您查找所需的技术信息。URL 如有更改，恕不通知。


SMTP 传输防病毒扫描未启用
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定是否已为 SMSMSE (Symantec Mail Security for Microsoft Exchange) 服务的 Started 关键字设置值。Win32_Service 类确定 Exchange Server 2003 计算机上是否安装了 SMSMSE。值为 True 说明 SMSMSE 服务正在运行。值为 False 说明 SMSMSE 服务未运行。如果存在下列条件，则 Exchange Server 分析工具将显示警告：

  • SMSMSE 已安装在 Exchange Server 2003 计算机上。

  • SMTP 传输防病毒扫描未启用。

在 Exchange Server 2003 中，高级队列引擎使用 Exchange 传输防病毒 API 作为六个传输事件接收器中的一个，用于将邮件传输到目标。Exchange 传输防病毒 API 事件接收器在 OnSubmit.dll 中实现，使非 Microsoft 供应商（例如 Symantec）可以实现病毒扫描程序，用于检查每个邮件是否包含恶意附件和数据结构，然后才允许邮件传递到目标。此事件为 OnSubmission 事件注册。

默认情况下不启用传输防病毒扫描，因为该功能会扫描邮件两次，一次在 SMTP 层，一次在 Exchange 存储中。但是，如果使用前端服务器将 Exchange 组织连接到 Internet 上，可以在这些服务器上启用传输防病毒扫描。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
启用传输防病毒扫描

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到 HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\TransportAVAPI。

  3. 新建数值名称为 Enabled 的 DWORD 值。将 Enabled 数值名称的数值数据指定为 1。

  4. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

注意：
只有基于病毒扫描应用程序编程接口 (VSAPI) 2.5 的 Exchange 病毒扫描程序才能使用传输扫描功能。

有关 SMTP 传输体系结构的详细信息，请参阅"Exchange Server 2003 技术参考指南"(http://go.microsoft.com/fwlink/?LinkId=47891)。

有关如何对 Exchange Server 使用防病毒软件的详细信息，请参阅下列知识库文章：

  • 328841"XADM：Exchange 和防病毒软件"(http://support.microsoft.com/kb/328841/zh-cn)。

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://support.microsoft.com/kb/823166/zh-cn)。

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)。

  • 245822"有关在安装了防病毒软件的 Exchange 计算机上排除故障的建议"(http://support.microsoft.com/kb/245822/zh-cn)。

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅"Exchange Server Partners:Antivirus 网站 (http://go.microsoft.com/fwlink/?linkid=16226)。

注意：
Web 地址可能会改变，所以，也许无法连接到此处提到的网站。


Simpler-Webb Exchange Resource Manager 更新可用
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2006-04-14

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 ERME2KAsyncSink.dll 的 Version 关键字的值。如果 Exchange Server 分析工具发现 ERME2KAsyncSink.dll 的 Version 值小于 1015，则显示警告。

ERME2KAsyncSink.dll 文件是 Simpler-Webb Exchange Resource Manager (ERM) 的核心二进制文件。如果 ERME2KAsyncSink.dll 的版本小于 1015，则说明服务器安装了 ERM 1.2 版或更早的版本。ERM 1.2 版有一个已知问题，该问题可以导致如下故障：当 Exchange OLE DB 等待从 ERM 事件接收器返回调用时，Exchange 本地传递队列将停止传递邮件。在 Exchange 存储关闭过程中，Microsoft Exchange OLEDB 会等待事件接收器 ERME2KAsyncSink.dll 从 OnSyncSave 调用返回。

如果从此调用返回失败，Exchange 存储将无法完成关闭操作。该问题在 ERM 版本 1.35 中已得到解决。

解决此警告问题

  1. 使用"添加或删除程序"手动删除 ERM 版本 1.2。

  2. 安装 ERM 版本 1.35，您可以从 Simpler-Webb 网站 (http://www.swinc.com/products/ERM/upgrade/) 下载该软件。

    注意：
    在本主题中提供的第三方网站信息是为了帮助您查找所需的技术信息。URL 如有更改，恕不另行通知。


可用的 Sybari Antigen 7.5 for Microsoft Exchange Update for Exchange
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表值，以确定病毒扫描应用程序编程接口 (VSAPI) 库文件是否已向 Microsoft Exchange 信息存储服务注册：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Antigen 7.5 for Microsoft Exchange 是 Sybari 产品。如果 Antigen 7.5 for Microsoft Exchange 安装在 Exchange 2000 Server 或 Exchange Server 2003 上，则库注册表项的值将是 ANTIGENVSAPI.DLL。在 Antigen 7.5 for Microsoft Exchange 中，该库文件执行几个与 VSAPI 相关的功能。

Exchange Server 分析工具还查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 ANTIGENVSAPI.DLL 的 Version 关键字的值。如果 Version 关键字的值表明该文件的内部版本号小于 1316，则会显示警告。

如果 ANTIGENVSAPI.DLL 的版本号小于 1316，则表明没有安装 Antigen 7.5 for Microsoft Exchange 的最新版本。从 Sybari 网站可以获得 Antigen 7.5 for Microsoft Exchange 的软件更新。强烈建议安装该更新，它可以提高总体性能和可靠性。

解决此警告问题

  1. 访问 Sybari 网站"Licensed Download Center"(http://www.sybari.com/portal/alias__Rainbow/lang__en-US/tabID__3359/DesktopDefault.aspx)。

    注意：
    Web 地址可能有变化，因此您可能无法连接到这里提到的网站。

  2. 下载您的 Antigen 7.5 for Microsoft Exchange 版本的最新更新。

  3. 对 Exchange Server 计算机进行完整备份。

  4. 安装 Antigen 7.5 for Microsoft Exchange 的最新更新。

有关如何对 Exchange Server 使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"Exchange 和防病毒软件"(http://support.microsoft.com/kb/328841/zh-cn)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)。

  • 245822"有关在安装了防病毒软件的 Exchange Server 计算机上排除故障的建议"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅"Exchange Server Partners:Antivirus 网站 (http://go.microsoft.com/fwlink/?linkid=16226)。


可用的 Sybari Antigen 8.0 for Microsoft Exchange Update for Exchange
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2006-01-09

Microsoft? Exchange Server 分析工具读取以下注册表值，以确定病毒扫描应用程序编程接口 (VSAPI) 库文件是否已向 Microsoft Exchange 信息存储服务注册：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Antigen 8.0 for Microsoft Exchange 是 Sybari 产品。如果 Antigen 8.0 for Microsoft Exchange 安装在 Exchange 2000 Server 或 Exchange Server 2003 上，则库注册表项的值将是 ANTIGENVSAPIEx.DLL。在 Antigen 8.0 for Microsoft Exchange 中，该库文件执行几个与 VSAPI 相关的功能。

Exchange Server 分析工具还查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 ANTIGENVSAPI.DLL 的 Version 关键字的值。如果 Version 关键字的值指示该文件的内部版本号小于 1517，则显示警告。

如果 ANTIGENVSAPI.DLL 的版本号小于 1517，则指示未安装最新版本的 Antigen 8.0 for Microsoft Exchange。从 Sybari 网站可以获得 Antigen 8.0 for Microsoft Exchange 的软件更新。强烈建议安装该更新，它可以提高总体性能和可靠性。

解决此警告问题

  1. 访问 Sybari 网站"Licensed Download Center"(http://www.sybari.com/portal/alias__Rainbow/lang__en-US/tabID__3359/DesktopDefault.aspx)。

    注意：
    Web 地址可能有变化，因此您可能无法连接到这里提到的网站。

  2. 下载您的 Antigen 8.0 for Microsoft Exchange 版本的最新更新。

  3. 对 Exchange Server 计算机进行完整备份。

  4. 安装 Antigen 8.0 for Microsoft Exchange 的最新更新。

有关如何对 Exchange Server 使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"Exchange 和防病毒软件"(http://support.microsoft.com/kb/328841/zh-cn)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange Server 计算机上排除故障的建议"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅"Exchange Server Partners:Antivirus 网站 (http://go.microsoft.com/fwlink/?linkid=16226)。


该 Exchange 服务器安装了 Sybari Antigen，但 AntigenStore 服务未运行
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Windows® Management Instrumentation (WMI) 类，以确定 Sybari Antigen 是否安装以及 AntigenStore 服务是否运行在 Exchange 计算机上。

Exchange Server 分析工具还查询 Win32_Service WMI 类，以确定为 Microsoft Exchange 信息存储服务的 Started 关键字设置的值为 True 还是 False。

值为 False 说明该 Exchange Server 计算机未运行 Microsoft Exchange 信息存储服务。值为 True 说明正在运行 Microsoft Exchange 信息存储服务。

如果 Exchange Server 分析工具发现 Microsoft Exchange 信息存储服务正在运行，并且已安装 Sybari Antigen，但 AntigenStore 服务未启动，则会显示警告。

Sybari Antigen 为 Exchange Server 提供防病毒保护。下面列出了导致 Sybari AntigenStore 服务可能停止的某些原因及其解决方案。

  • 正在 Exchange Server 上运行的软件可能是已过期的评估版或试用版。在这种情况下，可能需要重新安装 Sybari Antigen。若要继续使用该软件，至少必须激活它。

  • 管理员可能无意中停止了 Sybari Antigen 服务。验证服务被设置为自动启动，再启动该服务。

  • 恶意的蠕虫、病毒或其他程序可能停止了该服务。验证服务被设置为自动启动，并启动该服务。如果服务继续意外停止，而没有相关的错误事件，请验证计算机未感染恶意蠕虫，并在必要时对系统进行杀毒。

通常，建议您在简单邮件传输协议 (SMTP) 网关或者在驻留邮箱的 Exchange 服务器上，部署为邮件系统而设计的防病毒软件。要实施最全面的保护，应在扫描传入 MIME 邮件的网关上运行防病毒软件，在使用 VSAPI 2.5 的 Exchange Server 上运行扫描程序。此外，还应当在用户台式机上运行客户端防病毒软件。如果在网关或 Exchange 服务器上运行专门为邮件系统设计的防病毒软件（可以分析并扫描 MIME），则在台式机上运行文件级别的扫描程序已足够。

启动 AntigenStore 服务

  1. 打开"服务"MMC 管理单元。

  2. 用鼠标右键单击"AntigenStore"服务，再单击"属性"。

  3. 在 AntigenStore 属性页的"常规"选项卡上，确保将"启动类型"设置为"自动"。如果不是这样，请将它设置为"自动"，单击"应用"，再单击"确定"。

  4. 用鼠标右键单击"AntigenStore"服务，再单击"启动"。

  5. 关闭"服务"管理单元。

有关加强 Exchange 环境的防御措施以抵抗通过电子邮件传输的病毒和蠕虫的信息，请参阅"在 Exchange 2003 环境中抑制和阻止通过电子邮件传输的病毒"(http://www.microsoft.com/downloads/details.aspx?FamilyID=fb3f649a-2b0a-443d-92a5-8f8cf4bf9fdb&DisplayLang=zh-cn)。

有关与 Exchange Server 一起使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"XADM:Exchange 和防病毒软件"(http://support.microsoft.com/?kbid=328841)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange 计算机上排除故障的建议"(http://support.microsoft.com/kb/245822/zh-cn)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅网站上的"Exchange Server Partners: Antivirus"(http://go.microsoft.com/fwlink/?linkid=16226)。


Sybari Antigen 安装在此 Exchange 服务器上，但该服务未运行
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Sybari Antigen 是否安装以及 AntigenService 服务是否运行在 Exchange Server 计算机上。

Exchange Server 分析工具还查询 Win32_Service WMI 类，以确定为 Microsoft Exchange 信息存储服务的 Started 关键字设置的值为 True 还是 False。

值为 False 意味着 Microsoft Exchange 信息存储服务未运行在此 Exchange Server 计算机上。值为 True 意味着 Microsoft Exchange 信息存储服务在运行。

如果 Exchange Server 分析工具发现 Microsoft Exchange 信息存储服务在运行，并且 Sybari Antigen 已安装，但 AntigenService 服务未启动，则会显示警告。

Sybari Antigen 为 Exchange Server 提供防病毒保护。Sybari Antigen 服务可能由于某些原因而停止。下面列出了这些原因及相应的解决方案：

  • 运行在 Exchange Server 上的软件可能是评估版或适用版，并且已过期。在这种情况下，可能需要重新安装 Sybari Antigen。至少需要将它激活才能继续使用该软件。

  • 管理员可能在无意中停止了 Sybari Antigen 服务。确认服务设置为自动启动，然后启动该服务。

  • 恶意的蠕虫、病毒或其他程序可能停止了该服务。确认服务设置为自动启动，然后启动该服务。如果服务仍然在没有相关的错误事件发生的情况下意外地停止，请确认计算机未感染恶意蠕虫，并在必要时对系统进行杀毒。

通常，建议您在简单邮件传输协议 (SMTP) 网关或者在驻留邮箱的 Exchange 服务器上，部署为邮件系统而设计的防病毒软件。要实施最全面的保护，应在扫描传入 MIME 邮件的网关上运行防病毒软件，而在使用 VSAPI 2.5 的 Exchange 服务器上运行扫描程序。此外，还应当在客户端计算机上运行防病毒软件。如果在网关或 Exchange 服务器上运行专门为邮件系统设计的防病毒软件（可以分析并扫描 MIME），则在台式机上运行文件级别的扫描程序已足够。

启动 AntigenService 服务

  1. 打开"服务"MMC 管理单元。

  2. 用鼠标右键单击"AntigenService"服务，再单击"属性"。

  3. 在 AntigenService 属性页的"常规"选项卡上，确保"启动类型"设置为"自动"。否则，请将它设置为"自动"，再单击"应用"，然后单击"确定"。

  4. 用鼠标右键单击"AntigenService"服务，再单击"启动"。

  5. 关闭"服务"管理单元。
  • 有关加强 Exchange 环境的防御措施以抵抗通过电子邮件传输的病毒和蠕虫的详细信息，请参阅"在 Exchange 2003 环境中抑制和阻止通过电子邮件传输的病毒"(http://www.microsoft.com/downloads/details.aspx?FamilyID=fb3f649a-2b0a-443d-92a5-8f8cf4bf9fdb&DisplayLang=zh-cn)。

有关与 Exchange Server 一起使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"XADM:Exchange 和防病毒软件"(http://support.microsoft.com/?kbid=328841)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange 计算机上排除故障的建议"(http://support.microsoft.com/kb/245822/zh-cn)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅网站上的"Exchange Server Partners: Antivirus"（英文）(http://go.microsoft.com/fwlink/?linkid=16226)。


Symantec Antivirus 定义已超过 30 天未进行更新
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定下列条件是否为真：

  • Symantec Antivirus 已安装在服务器上。

  • 以下防病毒定义文件已更新：

    HKEY_LOCAL_MACHINE\Software\Symantec\SharedDefs\MicroDefs

如果 Exchange Server 分析工具发现 BinHubStamp 注册表项的数值数据已超过 30 天未进行更新，Exchange Server 分析工具将显示警告。

Symantec Antivirus for Microsoft Exchange Server 为 Exchange Server 提供防病毒保护。建议您尽快下载最新发布的 Symantec 防病毒定义。确保将防病毒定义更新部署到组织的下列层中：

  • 邮件网关服务器

  • Exchange 服务器

  • 客户端工作站

若要下载最新的病毒定义，请访问 Symantec 防病毒网站上的"Symantec 主页"(http://www.symantec.com)。

有关加强 Exchange 环境的防御措施以抵抗通过电子邮件传输的病毒和蠕虫的详细信息，请参阅"在 Exchange 2003 环境中抑制和阻止通过电子邮件传输的病毒"(http://www.microsoft.com/downloads/details.aspx?FamilyID=fb3f649a-2b0a-443d-92a5-8f8cf4bf9fdb&DisplayLang=zh-cn)。

有关如何对 Exchange Server 使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"Exchange 和防病毒软件"(http://support.microsoft.com/kb/328841/zh-cn)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange Server 计算机上排除故障的建议"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅"Exchange Server Partners:Antivirus 网站 (http://go.microsoft.com/fwlink/?linkid=16226)。

注意：
Web 地址可能会改变，所以，也许无法连接到此处提到的网站。


Symantec Antivirus 安装在此 Exchange 服务器上，但该服务已停止
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定是否设置了 Started 关键字的值。Win32_Service 类确定是否安装了 Symantec Antivirus for Exchange Server。如果 Started 关键字的值为 True，表明 Symantec Antivirus 服务正在此 Exchange Server 计算机上运行。如果 Started 关键字的值为 False，表明 Symantec Antivirus 服务未在此 Exchange Server 计算机上运行。

如果 Exchange Server 分析工具发现 Symantec Antivirus 安装在此 Exchange Server 计算机上，但 Symantec Antivirus 服务未启动，Exchange Server 分析工具将显示警告。

Symantec Antivirus 为 Exchange Server 提供防病毒保护。下面列出了 Symantec Antivirus 服务可能已停止的某些原因以及解决方案。

  • Exchange 服务器上运行的软件可能是已到期的评估版或试用版。在这种情况下，可能必须重新安装 Symantec Antivirus。至少需要将它激活才能继续使用该软件。

  • 管理员可能无意中停止了 Symantec Antivirus 服务。确认服务设置为自动启动，然后启动该服务。

  • 恶意的蠕虫、病毒或其他程序可能停止了该服务。确认服务设置为自动启动，然后启动该服务。如果服务仍然在没有相关的错误事件发生的情况下意外停止，请确认计算机未感染恶意蠕虫，如果感染，应对系统进行杀毒。

建议您在简单邮件传输协议 (SMTP) 网关或者在驻留邮箱的 Exchange 服务器上，部署为邮件系统而设计的防病毒软件。要实施最全面的保护，应在扫描传入 MIME 邮件的网关上运行防病毒软件，在使用 VSAPI 2.5 的 Exchange Server 上运行扫描程序。

启动 Symantec Antivirus 服务

  1. 打开"服务"MMC 管理单元。

  2. 用鼠标右键单击 Symantec Antivirus 服务，再单击"属性"。

  3. 在 Symantec Antivirus 属性页的"常规"选项卡上，确保将"启动类型"设置为"自动"。如果不是，请单击"应用"，再单击"确定"。

  4. 用鼠标右键单击 Symantec Antivirus 服务，再单击"启动"。

  5. 关闭"服务"管理单元。

此外，还应当在用户台式机上运行客户端防病毒软件。如果符合下列条件之一，台式机上的文件级扫描程序可以提供足够的保护：

  • 运行的防病毒软件针对邮件系统而设计，可以在网关上解析和扫描 MIME。

  • 运行的防病毒软件针对邮件系统而设计，可以在 Exchange 服务器上分析和扫描 MIME。

有关通常与 Microsoft Exchange Server 2003 一起使用的不同类型的病毒扫描程序的详细信息，请参阅 Microsoft 知识库文章 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)。

有关通常与 Microsoft Exchange 2000 Server 一起使用的不同类型的病毒扫描程序的详细信息，请参阅知识库文章 328841"Exchange 和防病毒软件"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)。

有关加强 Exchange Server 环境的防御措施以抵抗通过电子邮件传输的病毒和蠕虫的信息，请参阅"在 Exchange 2003 环境中抑制和阻止通过电子邮件传输的病毒"(http://www.microsoft.com/downloads/details.aspx?FamilyID=fb3f649a-2b0a-443d-92a5-8f8cf4bf9fdb&DisplayLang=zh-cn)。


Symantec Mail Security for Exchange 防病毒扫描配置警报
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定为 SMSMSE (Symantec Mail Security for Microsoft Exchange) 服务的 Started 关键字设置的值。

值为 True 意味着此 Exchange Server 计算机上安装了 Symantec Mail Security for Microsoft Exchange Server，并且 SMSMSE 服务在运行。值为 False 意味着 SMSMSE 服务未运行。

Exchange Server 分析工具还查询 Win32_Service WMI 类，以确定为 Microsoft Exchange 信息存储服务的 Started 关键字设置的值为 True 还是 False。

值为 False 意味着 Microsoft Exchange 信息存储服务未运行在此 Exchange Server 计算机上。值为 True 意味着 Microsoft Exchange 信息存储服务在运行。

如果 Exchange Server 分析工具发现 Microsoft Exchange 信息存储服务在运行，并且已安装 Symantec Mail Security for Microsoft Exchange，但 SMSMSE 服务未运行，则显示警告。

对于您的环境而言，一个重大的威胁就是通过电子邮件传输的病毒。电子邮件病毒可能攻击计算机系统本身，也可能通过向系统发送大量的邮件（使系统超载）来攻击电子邮件环境。您需要确保在环境中有足够多的病毒防范措施。应考虑在防火墙、SMTP 网关或其外部、每个 Exchange 服务器以及每个客户端上防范病毒。

解决此警告问题

  1. 在 Exchange Server 计算机上启动 Windows"服务"管理单元。

  2. 在右侧窗格中，向下滚动至"Symantec Mail Security for Microsoft Exchange"服务，并双击该服务。

  3. 确保"启动类型"下拉框中的值设置为"自动"。

  4. 单击"启动"启动 Symantec Mail Security for Microsoft Exchange 服务。

  5. 单击"确定"保存更改并关闭属性对话框，然后退出此管理单元。

有关加强 Exchange 环境的防御措施以抵抗通过电子邮件传输的病毒和蠕虫的信息，请参阅"在 Exchange 2003 环境中抑制和阻止通过电子邮件传输的病毒"(http://www.microsoft.com/downloads/details.aspx?FamilyID=fb3f649a-2b0a-443d-92a5-8f8cf4bf9fdb&DisplayLang=zh-cn)。

有关与 Exchange Server 一起使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"XADM:Exchange 和防病毒软件"(http://support.microsoft.com/?kbid=328841)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange 计算机上排除故障的建议"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅"Exchange Server Partners:Antivirus 网站 (http://go.microsoft.com/fwlink/?linkid=16226)。


可用的 Symantec Mail Security for Microsoft Exchange 4.5 更新
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2006-02-14

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Savfmsevsapi.dll 的 Version 关键字的值。如果 Version 关键字的值表示该文件的内部版本号为 4.5，则显示警告。

Savfmsevsapi.dll 的版本号为 4.5 表示未运行最新版本的 Symantec Mail Security for Microsoft Exchange 4.6x。Symantec Mail Security for Microsoft Exchange 4.6x 的软件更新可从 Symantec 网站上获取。强烈建议升级到版本 4.63 或更高版本，因为它可提高整体性能和可靠性。

下面列出了一些在运行 4.5 版 Savfmsevsapi.dll 时会遇到的已知问题。

  • Exchange 服务器的邮件流进程在常规操作中出现性能下降。

  • 备份 SMTP 队列（如目录查询队列和本地传递队列）。

  • 无法停止 Microsoft Exchange Information Store 服务。

  • Microsoft Outlook® 客户端无法连接到 Exchange 服务器。

  • 从 Outlook 客户端发送消息所花费的时间，比将消息传递到 Exchange 服务器通常所需的时间更长。Outlook 客户端可能在 30 秒内没有反应。

解决此警告问题

  1. 访问 Symantec 网站的企业支持页（英文）(http://www.symantec.com/techsupp/enterprise/)。

  2. 升级到版本 4.63 或更高版本。
注意：
本主题中提供了第三方网站信息，可以帮助您找到需要的技术信息。URL 如有更改，恕不通知。

有关如何对 Exchange Server 使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"Exchange 和防病毒软件"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166"Exchange Server 2003 与防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)。

  • 245822"有关在安装了防病毒软件的 Exchange Server 计算机上排除故障的建议"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅"Exchange Server Partners:Antivirus"（英文）(http://go.microsoft.com/fwlink/?linkid=16226)。


Trend Micro ScanMail for Microsoft Exchange 更新可用
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2006-01-09

Microsoft? Exchange Server 分析工具读取以下注册表值，以确定是否已使用 Microsoft Exchange 信息存储注册了病毒扫描应用程序编程接口 (VSAPI) 库文件：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

如果 ScanMail for Microsoft Exchange（它是 Trend Micro 产品）安装在 Exchange 2000 Server 或 Exchange Server 2003 上，则库注册表项的值将是 SMXS3DLL.DLL。在 ScanMail for Microsoft Exchange 中，该库文件执行几个与 VSAPI 相关的功能。

Exchange Server 分析工具还查询 CIM_Datafile Microsoft Windows? Management Instrumentation (WMI) 类，以确定 SMXS3DLL.DLL 的 Version 关键字的值。如果 Version 关键字的值指示该文件的内部版本号小于 1174，则显示警告。

如果 SMXS3DLL.DLL 的版本号小于 1174，则表明没有安装 ScanMail for Microsoft Exchange 的最新版本。从 Trend Micro 网站可以获得 ScanMail for Microsoft Exchange 的软件更新。强烈建议安装该更新，它可以提高总体性能和可靠性。

解决此警告问题

  1. 参阅 Trend Micro 网站上的"Update Center, ScanMail for Microsoft Exchange"（英文）(http://www.trendmicro.com/download/product.asp?productid=8)。

  2. 下载您的 ScanMail for Microsoft Exchange 版本的最新更新。

  3. 对 Exchange Server 计算机进行完整备份。

  4. 安装 ScanMail for Microsoft Exchange 的最新更新。

有关与 Exchange Server 一起使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"XADM:Exchange 和防病毒软件"(http://support.microsoft.com/?kbid=328841)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange 计算机上排除故障的建议"(http://support.microsoft.com/kb/245822/zh-cn)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅网站上的"Exchange Server Partners: Antivirus"（英文）(http://go.microsoft.com/fwlink/?linkid=16226)。


Trend Micro ServerProtect for Microsoft Windows 已停止
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 SpntSvc 服务的 Started 关键字的值。SpntSvc 服务是由 Trend Micro 公司的产品 ServerProtect for Microsoft Windows 安装的。Started 关键字的值为 True 意味着服务在运行，值为 False 意味着服务未运行。如果 Exchange Server 分析工具发现 SpntSvc 服务未启动，则会显示警告。

ServerProtect for Microsoft Windows 为服务器提供基于文件系统的防病毒扫描，包括进行实时病毒检测和删除。

启动 SpntSvc 服务

  1. 打开"服务"MMC 管理单元。

  2. 用鼠标右键单击"ServerProtect Server"服务，再单击"属性"。

  3. 在"ServerProtect Server"属性页的"常规"选项卡上，确保"启动类型"被设置为"自动"。如果不是，请将它设置为"自动"，单击"应用"，再单击"确定"。

  4. 用鼠标右键单击"ServerProtect Server"服务，再单击"启动"。

  5. 关闭"服务"管理单元。

有关与 Exchange Server 一起使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"XADM:Exchange 和防病毒软件"(http://support.microsoft.com/?kbid=328841)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange 计算机上排除故障的建议"(http://support.microsoft.com/kb/245822/zh-cn)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅网站上的"Exchange Server Partners: Antivirus"（英文）(http://go.microsoft.com/fwlink/?linkid=16226)。


Trend ScanMail 配置：性能可能得到提高
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2006-09-05

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 TempFileThreshold 的值：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

TempFileThreshold 注册表值适用于邮件正文和附件扫描。如果邮件正文或附件的大小大于 TempFileThreshold 项中指定的值，将在磁盘上创建临时文件。否则，将在内存中创建临时文件。TempFileThreshold 的默认值为 3,072 KB (3 MB)。

Exchange Server 分析工具还查询 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定为 TotalPhysicalMemory 项设置的值。该值表示计算机上安装的随机访问内存 (RAM) 的数量。

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定位于以下位置的全局设置 delivContLength 属性值：

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN= OrganizationName , CN=Global Settings, CN=Message Delivery

该属性表示传入 SMTP 邮件的最大大小。

如果 Exchange Server 分析工具发现具有 1 GB 或 1 GB 以上 RAM 的 Exchange Server 计算机上的 TempFileThreshold 值小于最大传入邮件大小的 70%，则显示警告。

此警告意味着 TempFileThreshold 注册表值对于您的环境不是最佳的。该值应至少设置为等于 Exchange 服务器上设置的附件大小限制。

注意：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

  3. 在右侧窗格中，双击"TempFileThreshold"。

  4. 输入一个等于组织中平均邮件大小的值（以 KB 为单位）。例如，如果平均邮件大小为 10 MB，则输入 10240。
注意：
如果增大此值，则可能需要更多的系统内存。例如，如果"ScanningThreads"值设置为 8，而"TempFileThreshold"值设置为 10240，则进行病毒扫描所需的最少内存为 80 MB (ScanningThreads * TempFileThreshold)。
  1. 关闭注册表编辑器，然后重新启动 ScanMail_RealTimeScan 服务和 Microsoft Exchange Information Store 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请阅读 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


Trend ScanMail 配置：QuerySender 注册表值已启用
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2006-04-20

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Trend Micro ScanMail for Microsoft Exchange ScanMail_Action 服务的 Started 关键字的值。值为 True 意味着 ScanMail_Action 服务在运行，值为 False 意味着该服务未运行。

Exchange Server 分析工具还读取下列注册表项，以确定 ScanMail for Microsoft Exchange 是否被配置为可以对 Active Directory® 目录服务执行通配符字符搜索：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\QuerySender

QuerySender 注册表项的值为 0 意味着通配符搜索已禁用。QuerySender 项的值为 1 意味着通配符搜索已启用。

此外，Exchange Server 分析工具还查询 Active Directory，以确定在每个邮箱存储的 homeMDBBL 属性中列出的条目数。该属性的个数代表邮箱存储中的邮箱数。

如果 Exchange Server 分析工具确定满足下列所有条件，则会显示警告：ScanMail_Action 服务正在运行，Exchange Server 包含 100 个以上的邮箱，并且 QuerySender 注册表项未设置为 0。

Trend Micro ScanMail for Microsoft Exchange 为 Exchange Server 提供防病毒保护。当 ScanMail for Exchange 扫描发送给通讯组列表的邮件时，其默认行为是在 Active Directory 全局编录中查询所有邮件收件人。如果通讯组列表中存在大量的收件人，此行为可能导致性能问题。此外，如果没有执行本文章中的建议，下列性能计数器的值将很高：

  • MSExchangeIS/Virus Scan Queue Length

  • MSExchangeIS/RPC Requests

  • MSExchangeIS/RPC Averaged Latency

将 QuerySender 值设置为 0 可阻止 ScanMail for Microsoft Exchange 在扫描发送给通讯组列表的邮件时在全局编录中查询所有收件人。

解决此警告问题

  1. 有关使用 QuerySender 注册表值的信息，请与 Trend Micro 联系 (http://www.trendmicro.com/en/about/overview.htm)。

  2. 有关 QuerySender 注册表值的详细信息，请参阅 Trend Micro 解决方案 ID 120393(http://esupport.trendmicro.com/support/viewxml.do?ContentID=en-120393)。

    注意：
    Web 地址可能会改变，所以，也许无法连接到此处提到的网站。

有关加强 Exchange 环境的防御措施以抵抗通过电子邮件传输的病毒和蠕虫的详细信息，请参阅"在 Exchange 2003 环境中抑制和阻止通过电子邮件传输的病毒"(http://www.microsoft.com/downloads/details.aspx?FamilyID=fb3f649a-2b0a-443d-92a5-8f8cf4bf9fdb&DisplayLang=zh-cn)。

有关与 Exchange Server 一起使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"XADM:Exchange 和防病毒软件"(http://support.microsoft.com/?kbid=328841)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange 计算机上排除故障的建议"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅"Exchange Server Partners:Antivirus 网站 (http://go.microsoft.com/fwlink/?LinkId=16226)。


Trend ScanMail 配置：ScanMail_Monitor 服务不依赖于群集服务
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2006-02-13

Microsoft® Exchange Server 分析工具在每台作为群集节点的服务器上读取以下注册表项：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Version 值为 6.2.000 表示安装了 ScanMail for Microsoft Exchange 6.2 版。

Exchange Server 分析工具还查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定群集服务 ClusSvc 的 Started 关键字的值。值为 True 表示群集服务正在运行，值为 False 则表示未运行该服务。

Exchange Server 分析工具在每台作为群集节点的服务器上读取以下注册表项：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ScanMail_Monitor

如果 Exchange Server 分析工具发现 ScanMail_Monitor 关键字不包含值为 ClusSvc 的多值注册表项 DependOnService，则 ScanMail_Monitor 服务不依赖于群集服务。

如果下列条件为真，则 Exchange Server 分析工具将显示警告消息：

  • 服务器正在运行 TrendMicro ScanMail for Microsoft Exchange 6.2 版。

  • 服务器正在运行群集服务 (ClusSvc)。

  • 未将 ScanMail_Monitor 服务配置成依赖群集服务。

在安装 ScanMail for Microsoft Exchange 6.2 版后，必须将 ScanMail_Monitor 服务配置成依赖群集服务。如果未配置此依赖性，则群集服务将在节点每次重新启动时停止响应。

解决此警告问题

  1. 请参阅 Trend Micro 网站上解决方案 ID 为 21441 的文章"The Microsoft Exchange Cluster Service unexpectedly stops after applying ScanMail for Exchange (SMEX) 6.2 Patch 1"（英文）(http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionId=21441&id=21441)。

    注意：
    虽然解决方案 ID 为 21441 的文章专门介绍了在安装 Patch 1 后配置该依赖性的要求，但本文适用于运行任何 ScanMail for Microsoft Exchange 6.2 版的服务器。

  2. 按照解决方案 ID 为 21441 的文章的"解决方案"部分中的说明，向注册表添加 DependOnService 多字符串值。
注意：
本主题中提供了第三方网站信息，可以帮助您找到需要的技术信息。URL 如有更改，恕不通知。

有关其他 Trend Micro 产品更新的详细信息，请参阅 Trend Micro Update Center 网站（英文）(http://www.trendmicro.com/download/)。

有关如何对 Exchange Server 使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"Exchange 和防病毒软件"(http://support.microsoft.com/kb/328841/zh-cn)

  • 823166"Exchange Server 2003 与防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange Server 计算机上排除故障的建议"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅"Exchange Server Partners:Antivirus"（英文）(http://go.microsoft.com/fwlink/?linkid=16226)。


Trend ScanMail 配置：SkipWildcardSearchInGC 注册表值被设置为 0
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Trend Micro ScanMail for Microsoft Exchange ScanMail_Action 服务的 Started 关键字的值。值为 True 说明 ScanMail_Action 服务正在运行，值为 False 说明它未运行。

Exchange Server 分析工具还读取以下注册表项，以确定是否已将 ScanMail for Microsoft Exchange 配置为对 Active Directory® 目录服务执行通配符搜索：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\SkipWildcardSearchInGC

SkipWildcardSearchInGC 注册表项的值为 1 说明禁用了通配符搜索。SkipWildcardSearchInGC 项的值为 0 说明启用了通配符搜索。

此外，Exchange Server 分析工具还查询 Active Directory，以确定在每个邮箱存储的 homeMDBBL 属性中所列出的条目数。该属性的个数代表邮箱存储中的邮箱数。

如果 Exchange Server 分析工具确定 ScanMail_Action 服务正在运行，并且 Exchange 服务器包含超过 100 个邮箱，SkipWildcardSearchInGC 注册表项设置为 0，则显示警告。

Trend Micro ScanMail for Microsoft Exchange 为 Exchange Server 提供防病毒保护。将 SkipWildcardSearchInGC 的值设置为 1 将使 ScanMail for Microsoft Exchange 无法解析包含通配符 (*) 的名称。由于 ScanMail for Exchange 最后要检查整个目录，因此查询有通配符的名称会大幅降低 Exchange Server 计算机的性能。此外，如果没有执行本文章中的建议，下列性能计数器的值将很高：

  • MSExchangeIS/Virus Scan Queue Length

  • MSExchangeIS/RPC Requests

  • MSExchangeIS/RPC Averaged Latency

解决此警告问题

  1. 有关使用 SkipWildcardSearchInGC 注册表值的信息，请与 Trend Micro 联系 (http://www.trendmicro.com/en/about/overview.htm)。

  2. 有关 SkipWildcardSearchInGC 注册表值的详细信息，请参阅 Trend Micro 解决方案 ID 20393（英文）(http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=20393)。

    注意：
    Web 地址可能会改变，所以，也许无法连接到此处提到的网站。

有关加强 Exchange 环境的防御措施以抵抗通过电子邮件传输的病毒和蠕虫的详细信息，请参阅"在 Exchange 2003 环境中抑制和阻止通过电子邮件传输的病毒"(http://www.microsoft.com/downloads/details.aspx?FamilyID=fb3f649a-2b0a-443d-92a5-8f8cf4bf9fdb&DisplayLang=zh-cn)。

有关与 Exchange Server 一起使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"XADM:Exchange 和防病毒软件"(http://support.microsoft.com/?kbid=328841)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange 计算机上排除故障的建议"(http://support.microsoft.com/kb/245822/zh-cn)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅网站上的"Exchange Server Partners: Antivirus"（英文）(http://go.microsoft.com/fwlink/?LinkId=16226)。


Trend ScanMail 配置：MaxMessageCount 注册表值小于 500
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 MaxMessageCount 的值：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion

此外，Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定每个邮箱存储的 homeMDBBL 属性中列出的条目数。该属性的个数代表邮箱存储中的邮箱数。

如果 Exchange Server 分析工具确定 Exchange Server 包含超过 100 个邮箱，并且 MaxMessageCount 的值小于 500，则显示警告。

Trend Micro ScanMail for Microsoft Exchange 为 Exchange Server 提供防病毒保护。ScanMail for Exchange 扫描线程在完成任务后，会将扫描结果写入队列。如果队列中有太多项，则扫描线程必须先等待，然后才能写入队列并释放线程。扫描结果队列大小的阈值是由 MaxMessageCount 控制的。将 MaxMessageCount 值设置为 500 可以优化 ScanMail for Exchange 的性能。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion

  3. 在右侧窗格中，双击"MaxMessageCount"。

  4. 输入值 500（十进制）。

  5. 关闭注册表编辑器，然后重新启动 ScanMail_RealTimeScan 服务和 Microsoft Exchange Information Store 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关使用 MaxMessageCount 注册表值的详细信息，请访问 Trend Micro 网站 (http://www.trendmicro.com/en/about/overview.htm)。

注意：
Web 地址可能会改变，所以，也许无法连接到此处提到的网站。

有关加强 Exchange 环境的防御措施以抵抗通过电子邮件传输的病毒和蠕虫的详细信息，请参阅"在 Exchange 2003 环境中抑制和阻止通过电子邮件传输的病毒"(http://www.microsoft.com/downloads/details.aspx?FamilyID=fb3f649a-2b0a-443d-92a5-8f8cf4bf9fdb&DisplayLang=zh-cn)。

有关与 Exchange Server 一起使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"XADM:Exchange 和防病毒软件"(http://support.microsoft.com/?kbid=328841)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange 计算机上排除故障的建议"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅"Exchange Server Partners:Antivirus 网站 (http://go.microsoft.com/fwlink/?LinkId=16226)。


Trend ScanMail 被配置为删除所有文件附件
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取几个注册表项，以确定 ScanMail for Microsoft Exchange 是否被配置为删除附件。被读取的值位于注册表中的如下位置：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption\Advance

值 | 描述
ActionType | 表明要阻止哪些附件（如果打开了附件阻止功能）。值为 0 表明阻止所有附件。值为 3 表明管理员已经指定了文件扩展名、文件名或真实的文件类型的列表。可以通过在 ScanMail 管理控制台的"附件阻止设置"对话框中选择合适的选项，来配置该设置。
EnableAlert | 表明是否启用了附件阻止功能。值为 1 表明启用了附件阻止功能。值为 0 表明它被禁用。可以通过在 ScanMail 管理控制台的"病毒扫描"|"选项"页上选中（启用）或清除（禁用）"启用附件阻止"复选框，来配置该设置。

HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

值 | 描述
EnableEManager | 表明是否启用了 ScanMail eManager。值为 1 表明启用了 eManager。值为 0 表明它被禁用。可以通过在 ScanMail 管理控制台中选中（启用）或清除（禁用）"启用 eManager"复选框，来配置该设置。仅当安装了 ScanMail eManager（一个单独的配套产品）时，该设置才可用。
EnableWebStoreDelMail | 表明是否对入站邮件启用了 ScanMail Active Message Filter。值为 1 表明对入站邮件启用了 Active Message Filter。值为 0 表明未对入站邮件启用它。可以通过在 ScanMail 管理控制台的"活动邮件筛选器"对话框中选中（启用）或清除（禁用）"入站邮件"复选框，来配置该设置。

Exchange Server 分析工具还读取下列注册表项，以确定是否启用了病毒扫描 API (VSAPI) 邮件扫描：

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Enabled 的值为 1 表明启用了 VSAPI 扫描。值为 0 表明未启用 VSAPI 扫描。可以通过在 ScanMail 管理控制台的"病毒扫描"|"选项"页上选中（启用）或清除（禁用）"启用 VS API 病毒扫描"复选框，来配置该设置。

如果 Exchange Server 分析工具发现所有下列条件为真，则会显示警告：

  • 在 ScanMail for Exchange 中，VSAPI 扫描已启用

  • EnableAlert 的值是 1

  • ActionType 的值是 0

  • EnableEManager 的值是 1

  • EnableWebStoreDelMail 的值是 1

该警告表明 ScanMail 被配置为在下一个安排的或手动的扫描期间删除所有附件。

解决此警告问题

  1. 确认您想删除附件。

  2. 如果需要，请禁用附件阻止功能，或将操作从删除更改为隔离。这将使管理员能够检查被隔离的文件，以便找出那些可能需要保留的附件。

有关 ScanMail for Microsoft Exchange 和 ScanMail eManager 的详细信息，请访问 Trend Micro 网站 (http://www.trend.com)。

注意：
Web 地址可能会改变，所以，也许无法连接到此处提到的网站。


Trend ScanMail 被配置为删除具有特定文件名的附件
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取数个注册表项，以确定 ScanMail for Microsoft Exchange 是否已配置为删除附件。被读取的值位于注册表中的如下位置：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption\Advance

值 | 描述
ActionType | 表明要阻止哪些附件（如果打开了附件阻止功能）。值为 0 表明阻止所有附件。值为 3 表明管理员已经指定了文件扩展名、文件名或真实的文件类型的列表。可以通过在 ScanMail 管理控制台的"附件阻止设置"对话框中选择所需的选项，来配置该设置。
EnableAlert | 表明是否启用了附件阻止功能。值为 1 表明启用了附件阻止功能。值为 0 表明它被禁用。可以通过在 ScanMail 管理控制台的"病毒扫描"|"选项"页上选中（启用）或清除（禁用）"启用附件阻止"复选框，来配置该设置。
FileName | 以分号分隔的字符串值，其中包含要删除的文件的列表。所指定的文件被阻止时，可以通过在 ScanMail 管理控制台的"附件阻止设置"对话框中输入所需的文件名，来配置该设置。

HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

值 | 描述
EnableEManager | 表明是否启用了 ScanMail eManager。值为 1 表明启用了 eManager。值为 0 表明它被禁用。可以通过在 ScanMail 管理控制台中选中（启用）或清除（禁用）"启用 eManager"复选框，来配置该设置。仅当安装了 ScanMail eManager（一个单独的配套产品）时，该设置才可用。
EnableWebStoreDelMail | 表明是否对入站邮件启用了 ScanMail Active Message Filter。值为 1 表明对入站邮件启用了 Active Message Filter。值为 0 表明未对入站邮件启用它。可以通过在 ScanMail 管理控制台的"活动邮件筛选器"对话框中选中（启用）或清除（禁用）"入站邮件"复选框，来配置该设置。

Exchange Server 分析工具还读取以下注册表项，以确定是否已启用病毒扫描 API (VSAPI) 邮件扫描：

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Enabled 的值为 1 表明启用了 VSAPI 扫描。值为 0 表明未启用 VSAPI 扫描。可以通过在 ScanMail 管理控制台的"病毒扫描"|"选项"页上选中（启用）或清除（禁用）"启用 VS API 病毒扫描"复选框，来配置该设置。

如果 Exchange Server 分析工具发现下列条件为真，则显示警告：

  • 在 ScanMail for Exchange 中，VSAPI 扫描已启用

  • EnableAlert 的值是 1

  • ActionType 的值是 3

  • EnableEManager 的值是 1

  • EnableWebStoreDelMail 的值是 1

  • FileName 不是 null 或空

该警告表明 ScanMail 被配置为在下一个安排的或手动的扫描期间删除其名称列在 FileName 项中的所有附件。

解决此警告问题

  1. 确认您希望删除其文件名列在 FileName 项中的附件。

  2. 如果需要，请禁用附件阻止功能，或将操作从"删除"更改为"隔离"。这将使管理员能够检查被隔离的文件，以便找出那些可能需要保留的附件。

有关 ScanMail for Microsoft Exchange 和 ScanMail eManager 的详细信息，请访问 Trend Micro 网站（英文）(http://www.trend.com)。

注意：
Web 地址可能会改变，所以，也许无法连接到此处提到的网站。


Trend ScanMail 被配置为删除具有特定文件扩展名的附件
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取数个注册表项，以确定 ScanMail for Microsoft Exchange Server 是否已配置为删除附件。被读取的值位于注册表中的如下位置：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption\Advance

值 | 描述
ActionType | 表明要阻止哪些附件（如果打开了附件阻止功能）。值为 0 表明阻止所有附件。值为 3 表明管理员已经指定了文件扩展名、文件名或真实的文件类型的列表。可以通过在 ScanMail 管理控制台的"附件阻止设置"对话框中选择所需的选项，来配置该设置。
EnableAlert | 表明是否启用了附件阻止功能。值为 1 表明启用了附件阻止功能。值为 0 表明它被禁用。可以通过在 ScanMail 管理控制台的"病毒扫描"|"选项"页上选中（启用）或清除（禁用）"启用附件阻止"复选框，来配置该设置。
Extension | 以分号分隔的字符串值，其中包含要删除的附件的文件扩展名的列表。所指定的附件被阻止时，可以通过在 ScanMail 管理控制台的"附件阻止设置"对话框中输入所需的扩展名，来配置该设置。

HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

值 | 描述
EnableEManager | 表明是否启用了 ScanMail eManager。值为 1 表明启用了 eManager。值为 0 表明它被禁用。可以通过在 ScanMail 管理控制台中选中（启用）或清除（禁用）"启用 eManager"复选框，来配置该设置。仅当安装了 ScanMail eManager（一个单独的配套产品）时，该设置才可用。
EnableWebStoreDelMail | 表明是否对入站邮件启用了 ScanMail Active Message Filter。值为 1 表明对入站邮件启用了 Active Message Filter。值为 0 表明未对入站邮件启用它。可以通过在 ScanMail 管理控制台的"活动邮件筛选器"对话框中选中（启用）或清除（禁用）"入站邮件"复选框，来配置该设置。

Exchange Server 分析工具还读取以下注册表项，以确定是否已启用病毒扫描 API (VSAPI) 邮件扫描：

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Enabled 的值为 1 表明启用了 VSAPI 扫描。值为 0 表明未启用 VSAPI 扫描。可以通过在 ScanMail 管理控制台的"病毒扫描"|"选项"页上选中（启用）或清除（禁用）"启用 VS API 病毒扫描"复选框，来配置该设置。

如果 Exchange Server 分析工具发现下列条件为真，则显示警告：

  • 在 ScanMail for Exchange 中，VSAPI 扫描已启用

  • EnableAlert 的值是 1

  • ActionType 的值是 3

  • EnableEManager 的值是 1

  • EnableWebStoreDelMail 的值是 1

  • Extension 不是 null 或空

该警告表明 ScanMail 被配置为在下一个安排的或手动的扫描期间删除其扩展名列在 Extension 项中的所有附件。

解决此警告问题

  1. 确认您希望删除其扩展名列在 Extension 项中的附件。

  2. 如果需要，请禁用附件阻止功能，或将操作从删除更改为隔离。这将使管理员能够检查被隔离的文件，以便找出那些可能需要保留的附件。

有关 ScanMail for Microsoft Exchange Server 和 ScanMail eManager 的详细信息，请访问 Trend Micro 网站 (http://www.trend.com)。

注意：
Web 地址可能会改变，所以，也许无法连接到此处提到的网站。


Trend ScanMail 被配置为两次处理邮件
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 ScanMail_RealTimeScan 服务的 Started 关键字的值。值为 True 说明 ScanMail_RealTimeScan 服务已启动，值为 False 说明 ScanMail_RealTimeScan 服务未启动。ScanMail_RealTimeScan 服务是 Trend Micro 的 ScanMail for Microsoft Exchange 应用程序的组件。Trend Micro ScanMail for Microsoft Exchange 为 Exchange 提供防病毒保护。

此外，Exchange Server 分析工具还读取以下注册表项，以确定 Enabled 值的设置：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\TransportAVAPI

Enabled 的值为 1 说明传输级别的防病毒扫描（有时称为简单邮件传输协议 (SMTP) 扫描）已启用，值为 0 说明 SMTP 扫描未启用。

如果 Exchange Server 分析工具发现 Enabled 设置为 1，并且 ScanMail_RealTimeScan 服务的 Started 关键字的值设置为 True，则显示警告。

该警告说明流经该 Exchange Server 计算机的邮件被相同应用程序和病毒扫描引擎扫描两次。如果相同邮件在经过 Exchange Server 的传输和存储组件时被不必要地两次扫描，将会消耗资源，并且不会有任何额外的保护或好处。建议您使病毒扫描 API (VSAPI) 病毒扫描保持启用状态，并使用 ScanMail 管理控制台禁用 SMTP 邮件扫描。

通常，建议您在 SMTP 网关或者在驻留邮箱的 Exchange 服务器上，部署为邮件系统而设计的防病毒软件。要实施最全面的保护，应在扫描入站 MIME 邮件的网关运行防病毒软件，而在使用 VSAPI 2.5 的 Exchange 服务器上运行扫描程序。此外，还应当在用户台式机上运行客户端防病毒软件。如果在网关或 Exchange 服务器上运行专门为邮件系统设计的防病毒软件（可以分析并扫描 MIME），则在台式机上运行文件级别的扫描程序已足够。

解决此警告问题

  1. 打开 ScanMail 管理控制台，并输入登录凭据。

  2. 在"病毒扫描"|"选项"页上，确保"启用 VS API 病毒扫描"复选框已选中。

  3. 在此同一页上，清除"启用 SMTP 邮件扫描"复选框。

  4. 单击"应用"保存更改。

  5. 关闭 ScanMail 管理控制台。

有关 Trend Micro ScanMail for Microsoft Exchange 的详细信息，请访问 Trend 网站 (http://kb.trendmicro.com/solutions/search)。

注意：
Web 地址可能会改变，所以，也许无法连接到此处提到的网站。

有关与 Exchange Server 一起使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"XADM:Exchange 和防病毒软件"(http://support.microsoft.com/?kbid=328841)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://support.microsoft.com/kb/823166/zh-cn)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=306105)

  • 245822"XGEN：有关在安装了防病毒软件的 Exchange 计算机上排除故障的建议"(http://support.microsoft.com/kb/245822/zh-cn)


Trend ScanMail 线程数较低
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 MaxScanningThreadCount 的值：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

MaxScanningThreadCount 注册表值代表 ScanMail for Exchange 可以为扫描创建的最大线程数。默认值为 12。

Exchange Server 分析工具还读取以下注册表项，以确定是否启用了病毒扫描 API (VSAPI) 邮件扫描：

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Enabled 的值为 1 说明启用了 VSAPI 扫描。值为 0 说明未启用 VSAPI 扫描。

Exchange Server 分析工具还查询 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 NumberOfProcessors 关键字的值。该值代表计算机上安装的处理器数，包括物理处理器和逻辑处理器。使用 Intel 的超线程技术，一个物理处理器可以拆分为两个逻辑处理器。

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定对象类为 msExchPrivateMDB 的对象数。这些对象计数代表了该 Exchange Server 计算机上的邮箱存储数。

如果 Exchange Server 分析工具发现启用了 VSAPI 扫描的 Exchange Server 计算机上的 MaxScanningThreadCount 值小于 (2 × NumberOfProcessors + 1) + 3 + 邮箱存储数)，则会显示警告。

注意：
如果启用了超线程，NumberOfProcessors 的值将是物理处理器数的两倍。建议对包含物理处理器的系统以及既包含物理处理器又包含逻辑处理器的系统均使用上述公式。

该警告说明可能没有针对您的环境对 MaxScanningThreadCount 注册表值进行优化。应当将该值设置为至少等于在 Exchange 服务器上所设置的附件大小限制。有关相关注册表值的信息，请参阅 Trend ScanMail 线程池数较低。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

  3. 在右侧窗格中，双击"MaxScanningThreadCount"。

  4. 输入 Exchange Server 分析工具提供的建议值。

  5. 关闭注册表编辑器，并重新启动 ScanMail_RealTimeScan 服务和 Microsoft Exchange Information Store 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请阅读 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 MaxScanningThreadCount 注册表值的详细信息，请参阅 Trend Micro Solution ID 13176 (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=13176)。

有关超线程技术的详细信息，请访问 Intel 网站 (http://www.intel.com/technology/hyperthread)。

注意：
Web 地址可能会改变，所以，也许无法连接到此处提到的网站。


Trend ScanMail 线程池数较低
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2006-04-21

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 ScanningThreadPoolCount 的值：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

ScanningThreadPoolCount 注册表值表示当 ScanMail for Exchange 服务启动时将初始化并准备好使用的扫描线程数。默认值为 12。当启动时创建的所有线程都已用完后，ScanMail for Exchange 将创建可使用的额外线程，直到达到了 Trend ScanMail 线程数较低中介绍的 MaxScanningThreadCount 注册表值控制的线程数。

Exchange Server 分析工具还读取下列注册表项，以确定是否启用了病毒扫描 API (VSAPI) 邮件扫描：

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Enabled 的值为 1 说明启用了 VSAPI 扫描。值为 0 说明未启用 VSAPI 扫描。

Exchange Server 分析工具还查询 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 类，以确定 NumberOfProcessors 关键字的值。该值代表计算机上安装的处理器数，包括物理处理器和逻辑处理器。使用 Intel 的超线程技术，一个物理处理器可以拆分为两个逻辑处理器。

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定对象类为 msExchPrivateMDB 的对象数。这些对象的个数表示该 Exchange Server 计算机上的邮箱存储的数目。

如果 Exchange Server 分析工具发现启用了 VSAPI 扫描的 Exchange Server 计算机上的 ScanningThreadPoolCount 值小于 (2 × NumberOfProcessors + 1) + 3 + 邮箱存储数)，则会显示警告。

注意：
如果启用了超线程，NumberOfProcessors 的值将是物理处理器数的两倍。建议对包含物理处理器的系统以及既包含物理处理器又包含逻辑处理器的系统均使用上述公式。

此警告意味着 ScanningThreadPoolCount 注册表值对于您的环境不是最佳的。该值应至少设置为等于 Exchange 服务器上设置的附件大小限制。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption.

  3. 在右侧窗格中，双击"ScanningThreadPoolCount"。

  4. 输入 Exchange Server 分析工具提供的建议值。

  5. 关闭注册表编辑器，然后重新启动 ScanMail_RealTimeScan 服务和 Microsoft Exchange Information Store 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请阅读 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关超线程技术的详细信息，请访问 Intel 网站 (http://www.intel.com/technology/hyperthread)。

注意：
Web 地址可能会改变，所以，也许无法连接到此处提到的网站。


Trend ScanMail 处于调试模式
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2006-06-22

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 ModuleName 的值：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\Tools\Debug

ModuleName 注册表值代表正在使用的调试模块文件的名称。

Exchange Server 分析工具还读取以下注册表项，以确定是否启用了病毒扫描 API (VSAPI) 邮件扫描：

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Enabled 的值为 1 表明启用了 VSAPI 扫描。值为 0 表明未启用 VSAPI 扫描。

如果 Exchange Server 分析工具发现 VSAPI 扫描已启用，并且 ModuleName 注册表值不为空或 Null，则显示警告。

由于涉及后台诊断跟踪，因此在调试模式下运行将导致性能大幅降低。除非您要进行问题诊断和排除（这需要在调试模式下运行 ScanMail for Exchange），否则应当关闭调试模式。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 打开注册表编辑器，例如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\Software\TrendMicro\ScanMail for Exchange\Tools\Debug.

  3. 在右侧窗格中，双击 ModuleName。

  4. 删除该条目的数值数据，将字符串留空。不要删除 ModuleName 关键字。

  5. 关闭注册表编辑器，并重新启动 ScanMail_RealTimeScan 服务和 Microsoft Exchange Information Store 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请阅读 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关验证调试模式是否已禁用的详细信息，请参阅 Trend Micro 解决方案 ID 119149（英文）(http://esupport.trendmicro.com/support/viewxml.do?ContentID=en-119149)。

注意：
在本主题中提供第三方网站信息是为了帮助您查找所需的技术信息。URL 如有更改，恕不另行通知。


Trend ScanMail Mail Action 服务已安装在该 Exchange 服务器上，但该服务已停止
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange 计算机上是否已安装 Trend Micro ScanMail for Exchange，以及是否在运行 ScanMail_MailAction 服务。

Exchange Server 分析工具还查询 Win32_Service WMI 类，以确定为 Microsoft Exchange 信息存储服务的 Started 关键字设置的值为 True 还是 False。

值为 False 说明该 Exchange Server 计算机未运行 Microsoft Exchange 信息存储服务。值为 True 说明正在运行 Microsoft Exchange 信息存储服务。

如果 Exchange Server 分析工具发现 Microsoft Exchange 信息存储服务正在运行，并且 Trend Micro ScanMail for Exchange 已安装，但 ScanMail_MailAction 服务未启动，则会显示警告。

Trend Micro ScanMail for Exchange 为 Exchange Server 提供防病毒保护。下面列出了 Trend ScanMail 服务可能已停止的某些原因以及解决方案。

  • 正在 Exchange 服务器上运行的软件可能是已过期的评估版或试用版。在这种情况下，可能需要重新安装 Trend ScanMail。若要继续使用该软件，至少必须激活它。

  • 管理员可能在无意中停止了 ScanMail_MailAction 服务。请验证服务被设置为自动启动，然后启动该服务。

  • 恶意的蠕虫、病毒或其他程序可能停止了该服务。验证服务被设置为自动启动，并启动此服务。如果服务继续意外停止，而没有相关的错误事件，那么，请验证计算机未感染恶意蠕虫，如果需要，请对系统进行杀毒。

通常，建议您在简单邮件传输协议 (SMTP) 网关或者在驻留邮箱的 Exchange 服务器上，部署为邮件系统而设计的防病毒软件。要实施最全面的保护，应在扫描传入 MIME 邮件的网关上运行防病毒软件，在使用 VSAPI 2.5 的 Exchange 服务器上运行扫描程序。此外，还应当在用户台式机上运行客户端防病毒软件。如果在网关或 Exchange 服务器上运行专门为邮件系统设计的防病毒软件（可以分析并扫描 MIME），则在台式机上运行文件级别的扫描程序已足够。

启动 ScanMail_MailAction 服务

  1. 打开"服务"MMC 管理单元。

  2. 用鼠标右键单击"ScanMail_MailAction"服务，再单击"属性"。

  3. 在 ScanMail_MailAction 属性页的"常规"选项卡上，确保"启动类型"设置为"自动"。如果不是这样，请将它设置为"自动"，单击"应用"，再单击"确定"。

  4. 用鼠标右键单击"ScanMail_MailAction"服务，再单击"启动"。

  5. 关闭"服务"管理单元。
  • 有关加强 Exchange 环境的防御措施以抵抗通过电子邮件传输的病毒和蠕虫的信息，请参阅"在 Exchange 2003 环境中抑制和阻止通过电子邮件传输的病毒"(http://www.microsoft.com/downloads/details.aspx?FamilyID=fb3f649a-2b0a-443d-92a5-8f8cf4bf9fdb&DisplayLang=zh-cn)。

有关与 Exchange Server 一起使用防病毒软件的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"XADM:Exchange 和防病毒软件"(http://support.microsoft.com/?kbid=328841)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822"有关在安装了防病毒软件的 Exchange 计算机上排除故障的建议"(http://support.microsoft.com/kb/245822/zh-cn)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅网站上的"Exchange Server Partners: Antivirus"（英文）(http://go.microsoft.com/fwlink/?linkid=16226)。


Exchange 服务器上安装了 Trend ScanMail 实时服务，但该服务已停止
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange Server 计算机上是否已安装 Trend Micro ScanMail for Microsoft Exchange，以及是否在运行 ScanMail_RealTimeScan 服务。如果 Exchange Server 分析工具发现已安装 Trend Micro ScanMail for Microsoft Exchange，但没有启动 ScanMail_RealTimeScan 服务，则会显示警告。

Trend Micro ScanMail for Microsoft Exchange 为 Exchange 提供防病毒保护。由于某些原因，ScanMail_RealTimeScan 服务可能已停止，以下列出了解决方案：

  • Exchange 服务器上运行的软件可能是已到期的评估（或试用）版。如果是这种情况，则需要重新安装 Trend Micro ScanMail for Microsoft Exchange。要继续使用此软件，至少必须将其激活。

  • 管理员可能无意停止了 ScanMail_RealTimeScan 服务。验证是否已将服务设置为自动启动，然后再启动服务。

  • 恶意的蠕虫、病毒或其他程序可能停止了该服务。验证是否已将服务设置为自动启动，然后再启动服务。如果在没有发生相关错误事件的情况下，服务仍然意外停止，则请验证计算机是否感染了恶意蠕虫，并根据需要对系统杀毒。

通常建议在简单邮件传输协议 (SMTP) 网关或驻留邮箱的 Exchange 服务器上部署专为邮件系统设计的防病毒软件。要实施最全面的保护，应在扫描入站 MIME 邮件的网关运行防病毒软件，而在使用病毒扫描 API (VSAPI) 2.5 版本的 Exchange 服务器上运行扫描程序。此外，应在用户台式机上运行客户端防病毒软件。如果在网关或 Exchange 服务器上运行专门为邮件系统设计的防病毒软件（可以分析并扫描 MIME），则在台式机上运行文件级别的扫描程序已足够。

启动 ScanMail_RealTimeScan 服务

  1. 打开服务 MMC 管理单元。

  2. 用鼠标右键单击"ScanMail_RealTimeScan"服务，再单击"属性"。

  3. 在"ScanMail_RealTimeScan"属性页的"常规"选项卡上，确保其中的"启动类型" 设置为"自动"。如果不是，则请将其设置为"自动"，用鼠标单击"应用"，再单击"确定"。

  4. 用鼠标右键单击"ScanMail_RealTimeScan"服务，再单击"启动"。

  5. 关闭"服务"管理单元。
  • 有关加强 Exchange 环境的防御措施以抵抗通过电子邮件传输的病毒和蠕虫的信息，请参阅"在 Exchange 2003 环境中抑制和阻止通过电子邮件传输的病毒"(http://www.microsoft.com/downloads/details.aspx?FamilyID=fb3f649a-2b0a-443d-92a5-8f8cf4bf9fdb&DisplayLang=zh-cn)。

有关将防病毒软件与 Exchange Server 一起使用的详细信息，请参阅下列 Microsoft 知识库文章：

  • 328841"XADM:Exchange 和防病毒软件"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166"与 Exchange Server 2003 配合使用的防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105"XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)。

  • 245822"有关在安装了防病毒软件的 Exchange 计算机上排除故障的建议"(http://support.microsoft.com/kb/245822/zh-cn)

有关可用于 Exchange Server 的第三方防病毒软件的列表，请参阅网站上的"Exchange Server Partners: Antivirus"（英文）(http://go.microsoft.com/fwlink/?LinkId=16226)。


在客户端上禁用第三方加载项
Microsoft Exchange Server 分析工具 - 文章 > 第三方软件 >

主题上次修改时间： 2006-04-21

Microsoft® Exchange Server 分析工具已确定您运行的是下列第三方软件类型之一：

  • 第三方 Microsoft Office Outlook® 加载项，例如防病毒软件或传真软件

  • 访问 Exchange 服务器的第三方应用程序

  • 用于移动设备的第三方同步软件

建议您调查用户正在运行的第三方应用程序类型，然后决定是否希望限制这些应用程序或完全删除应用程序。记住，运行第三方软件经常会造成服务器过载。

禁用 Outlook 中的第三方加载项

  1. 在 Outlook 中，单击"工具"菜单中的"选项"。

  2. 在"选项"中，单击"其他"选项卡，然后单击"高级选项"。

  3. 在"高级选项"中，单击"加载项管理器"。

  4. 清除任何第三方加载项的复选框。

  5. 单击"确定"。

  6. 重新启动 Outlook。

详细信息

  • 有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 有关解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（英文）(http://go.microsoft.com/fwlink/?LinkId=47588)。


传输
Microsoft Exchange Server 分析工具 - 文章 >

主题上次修改时间： 2005-11-18

本部分中的文章详细介绍 Microsoft® Exchange Server 分析工具对 Exchange 传输组件进行的相关评估。此外，这些文章还描述了为解决由 Exchange Server 分析工具发现的与传输相关的错误、警告和非默认配置所能采取的操作。


未注册 8BITMIME
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-08-18

Microsoft® Exchange Server 分析工具会将 EHLO 扩展的简单邮件传输协议 (ESMTP) 命令谓词发送到某台远程服务器的端口 25，并分析其响应，以确定该远程服务器是否支持 8BITMIME ESMTP 谓词。

如果该远程服务器发出的响应未包含字符串"250-8BITMIME"，Exchange Server 分析工具将显示警告。

Exchange Server 2003 使用这些特定于 Exchange 的扩展 SMTP 谓词与组织中其他运行 Exchange Server 的服务器进行通信。与使用标准 SMTP 相比，使用特定于 Exchange 的扩展 SMTP 谓词进行通信更为有效。如果禁用对 ESMTP 命令集的支持，Exchange Server 性能可能会受到影响。

此错误指示远程服务器不支持 ESMTP 8BITMIME 命令谓词。此错误未指示远程服务器是或者不是 Exchange 服务器。无论是哪种情况，都不会路由需要 8BITMIME 扩展的邮件。

若要解决此问题，请针对需要 8BITMIME 扩展的邮件检查 SMTP 队列的内容。

有关如何为这些谓词删除或还原默认支持的详细信息，请参阅 Microsoft 知识库文章 257569"How to turn off ESMTP verbs in Exchange 2000 Server and in Exchange Server 2003"（如何在 Exchange 2000 Server 和 Exchange Server 2003 中禁用 ESMTP 谓词）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569)。

有关 Exchange Server 使用 ESMTP 命令谓词的方式的详细信息，请参阅"Exchange Server 传输和路由指南"中的"How to Load Exchange SMTP Properly"（如何正确加载 Exchange SMTP）(http://go.microsoft.com/fwlink/?LinkId=71800)


ADAM LDAP Port Identified
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-07-23

Microsoft Exchange 分析工具读取以下注册表项，以确定由边缘传输服务器上的 Active Directory 应用程序模式 (ADAM) 目录服务所使用的端口：

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\EdgeTransportRole\AdamSettings\MsExchangeAdam\LdapPort

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\EdgeTransportRole\AdamSettings\MsExchangeAdam\SslPort

ADAM 是轻型目录访问协议 (LDAP) 目录服务，其专门为与启用目录的应用程序结合使用而设计。ADAM 仅存储和复制应用程序特定的信息，并且不要求在域控制器上进行部署，也不需要依赖 Active Directory 目录服务。ADAM 不提供网络操作系统身份验证或授权。

在 Microsoft Exchange Server 2007 中，边缘传输服务器角色使用 ADAM 存储配置信息和收件人数据以进行内容筛选。ADAM 与 Active Directory 实现同步后，也可以用来执行收件人查找以保证邮件安全。

数据从 Active Directory 发送至 ADAM 时，该数据是使用 LDAP 连接通过以下非默认端口发送的：

  • LDAP：端口 50389/TCP

  • 安全 LDAP：端口 50636/UDP

在 Exchange 分析工具标识 ADAM 所使用的端口后，Exchange 分析工具会显示最佳实践消息。

作为最佳实践，建议您阻止所有可访问外部的非必要端口。

若要解决此问题，请检查 Exchange 分析工具标识为 ADAM 使用的端口未打开外部访问。

警告：
端口 50636/UDP 用于 Exchange EdgeSync 服务，因此如果需要使用 EdgeSync 功能，则应保留该端口的打开状态。
使用 Windows 防火墙阻止所标识 ADAM 端口访问外部

  1. 依次单击"开始"、"运行"，键入 firewall.cpl，然后单击"确定"。

  2. 单击"例外"选项卡。

  3. 选择"名称"框中列出的每个程序或服务，然后单击"编辑"查看这些端口是否处于打开状态。

  4. 请验证 Exchange 分析工具报告用于 ADAM 的端口未在其中列出。

  5. 如果其中列出了所标识的端口，请确保这些端口没有用于其他必要的通信，然后通过在"编辑服务"窗口中取消选择这些端口来将其关闭。

  6. 单击"确定"两次退出 Windows 防火墙配置。

详细信息

有关 Exchange 2007 所使用端口、身份验证及所有数据路径加密的详细信息，请参阅"数据路径安全性参考"(http://go.microsoft.com/fwlink/?LinkId=95630)。


已安装防病毒插件
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-08-18

Microsoft® Exchange Server 分析工具将扫描以下注册表项，以确定是否已安装 Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect 插件：

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail

如果存在此注册表分支，则表示已经在运行 Exchange Server 的服务器上安装了 Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect 插件。

Exchange Server 分析工具还将读取以下注册表项，以确定是否已启用 Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect 插件：

HKLM\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail\RealTimeScan\OnOff

如果 OnOff 的值为 1，则表示 Auto Protect 插件已启用。如果其值为 0，则表示 Auto Protect 插件未启用。

如果下列条件为真，Exchange Server 分析工具将显示警告：

  • 已安装 Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect 插件。

  • 未启用 Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect 插件。

此警告指示应根据当前供应商建议的最佳实践检查插件的安装和配置。

有关供应商为此插件建议的最佳实践的详细信息，请参阅"Best practices for Symantec AntiVirus Corporate Edition 9.x Auto-Protect on a Microsoft Exchange server"（在 Microsoft Exchange 服务器上使用 Symantec AntiVirus Corporate Edition 9.x Auto-Protect 的最佳实践）(http://service1.symantec.com/SUPPORT/ent-security.nsf/c9b1ac1936fbf63488256e77006521df/3d1bcbc855fce10288256e9e007e01f0?OpenDocument&src=bar_sch_nam)。

注意：
本主题中提供了第三方网站信息，可以帮助您找到需要的技术信息。URL 如有更改，恕不另行通知。


已启用防病毒插件
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-08-18

Microsoft® Exchange Server 分析工具将扫描以下注册表项，以确定是否已安装 Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect 插件。

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail

如果存在此注册表项，则表示已经在运行 Exchange Server 的服务器上安装了 Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect 插件。

Exchange Server 分析工具还将读取以下注册表项，以确定是否已启用 Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect 插件。

HKLM\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail\RealTimeScan\OnOff

如果 OnOff 的值为 1，则表示已启用 Auto Protect 插件。如果其值为 0，则表示未启用 Auto Protect 插件。

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • 已安装 Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect 插件。

  • 已启用 Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect 插件。

此错误指示应根据当前供应商建议的最佳实践复查插件的安装和配置。

有关供应商为此插件建议的最佳实践的详细信息，请参阅"Best practices for Symantec AntiVirus Corporate Edition 9.x Auto-Protect on a Microsoft Exchange server"（在 Microsoft Exchange 服务器上使用 Symantec AntiVirus Corporate Edition 9.x Auto-Protect 的最佳实践）(http://service1.symantec.com/SUPPORT/ent-security.nsf/c9b1ac1936fbf63488256e77006521df/3d1bcbc855fce10288256e9e007e01f0?OpenDocument&src=bar_sch_nam)。

注意：
本主题中提供了第三方网站信息，可以帮助您找到需要的技术信息。URL 如有更改，恕不另行通知。


BCC 日记功能已启用
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已启用密件抄送 (Bcc) 日记功能：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\JournalBCC

如果 Exchange Server 分析工具发现 JournalBCC 的值已设置为 1，Exchange Server 分析工具将显示非默认配置消息。

Bcc 日记功能是增加了 Bcc 收件人捕获功能的仅邮件日记功能。如果启用了 Bcc 日记功能，则 Exchange Server 将捕获起始服务器已知的所有收件人（包括 Bcc 收件人）。如果此收件人列表包括隐藏的通讯组列表、基于查询的通讯组列表或在其他服务器上展开的通讯组列表，则这些列表的收件人不会包含在日记的邮件中。

可以通过设置注册表项来启用 Bcc 日记功能。有关设置此注册表值的详细信息，请参阅 Microsoft 知识库文章 810999"XADM:Bcc Information Is Lost for Journaled Messages in Exchange 2000"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810999)。

若要在特定服务器上启用 Bcc 日记功能，必须先配置仅邮件日记功能。如果符合下列条件，表明 JournalBCC 设置未激活：

  • JournalBCC 注册表项设置为 1。

  • 在同一服务器上的任何数据库上均未启用仅邮件日记功能。

邮件日记功能可能会占用许多磁盘资源、网络资源和 CPU 资源。因此，日记功能需要进行全面的部署计划。只有在整体日记解决方案框架的环境下，才应启用日记功能。

如果符合下列条件，请忽略此非默认配置消息：

  • 您的业务需要日记功能。

  • 您已部署了日记解决方案框架。

否则，应关闭日记功能。通过关闭数据库上的日记功能即可禁用日记功能。

关闭数据库上的仅邮件日记功能

  1. 在 Exchange 系统管理器中，依次展开"服务器"、<您的 Exchange 服务器>、<存储组>，再用鼠标右键单击邮箱存储。

  2. 在"常规"选项卡上，清除"存档由此存储中的邮箱发送或接收的所有邮件"复选框。

  3. 等待 15 分钟，让 Exchange 存储应用更改。不必重新启动 Microsoft Exchange 信息存储服务。

如果不希望 Exchange Server 分析工具再显示此消息，必须删除 JournalBCC 注册表项。若要禁用日记功能，不必删除 JournalBCC 注册表项。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
删除 JournalBCC 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\

  3. 在右侧窗格中，找到并删除 JournalBCC 值。

  4. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关部署日记解决方案的详细信息，请参阅"Journaling with Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47581)。


未注册 BDAT
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-08-18

Microsoft® Exchange Server 分析工具会将 EHLO 扩展的简单邮件传输协议 (ESMTP) 命令谓词发送到某台远程服务器的端口 25，并分析其响应，以确定该远程服务器是否支持 BDAT ESMTP 谓词。

如果 Exchange Server 分析工具从远程服务器收到了带有字符串的响应，并且该字符串指示了不可检索错误，那么，Exchange Server 分析工具将会显示错误。

Exchange Server 2003 使用这些特定于 Exchange 的扩展 SMTP 谓词与组织中其他运行 Exchange Server 的服务器进行通信。与使用标准 SMTP 相比，使用特定于 Exchange 的扩展 SMTP 谓词进行通信更为有效。如果禁用对 ESMTP 命令集的支持，Exchange Server 性能可能会受到影响。

此错误指示远程服务器不支持 ESMTP BDAT 命令谓词。此错误未指示远程服务器是或者不是 Exchange 服务器。无论是哪种情况，都不会路由需要 BDAT 扩展的邮件。

若要解决此问题，请针对需要 BDAT 扩展的邮件检查 SMTP 队列的内容。

有关如何为这些谓词删除或还原默认支持的详细信息，请参阅 Microsoft 知识库文章 257569"How to turn off ESMTP verbs in Exchange 2000 Server and in Exchange Server 2003"（如何在 Exchange 2000 Server 和 Exchange Server 2003 中禁用 ESMTP 谓词）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569)。

有关 Exchange Server 使用 ESMTP 命令谓词的方式的详细信息，请参阅"Exchange Server 传输和路由指南"中的"How to Load Exchange SMTP Properly"（如何正确加载 Exchange SMTP）(http://go.microsoft.com/fwlink/?LinkID=71800)。


用于检查 RGC 通讯组传递限制的桥头服务器
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-09-18

Microsoft® Exchange Server 分析工具将查询在 Active Directory® 目录服务中检测到的每个路由组连接器对象 (msExchRoutingGroupConnector) 的下列属性，以确定是否已设置基于通讯组成员身份的传递限制。

dLMemRejectPerms | 包含其成员不可以通过此路由组连接器发送数据的通讯组列表 (DL) 的域名 (DN)。
dLMemSubmitPerms | 包含其成员可以通过此路由组连接器发送数据的通讯组列表 (DL) 的域名 (DN)。

如果 Exchange Server 分析工具发现路由组连接器包含基于通讯组成员身份的传递限制，Exchange Server 分析工具将查询已检测到的路由组连接器的 msExchSourceBridgeheadServersDN 属性，以确定是否将分析的服务器设置为其中任何一个连接器的桥头服务器。

最后，Exchange Server 分析工具将读取以下注册表项，以确定 CheckConnectorRestrictions 注册表值是否存在并已进行配置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

如果下列条件为真，Exchange Server 分析工具将显示警告：

  • 使用路由组连接器来限制基于通讯组成员身份的传递。

  • 所分析的 Exchange 服务器已被指定为该路由组连接器的桥头服务器，其任务是扩展通讯组。

  • 如果 CheckConnectorRestrictions 项存在并设置为 1，则该项已启用。

分类程序的默认行为是以递归方式展开通讯组，并检查通过系统传递的每封邮件的限制。

创建路由组时，需要指定一组可以彼此直接通信的服务器。要使不同路由组中的服务器彼此通信，必须连接这些路由组。

首选的连接方法是使用路由组连接器，因为此连接器是专门为连接路由组而设计的。

桥头服务器是可以通过路由组连接器发送邮件的服务器。桥头服务器是简单邮件传输协议 (SMTP) 虚拟服务器与负责通过连接器传递所有邮件的 Exchange 服务器的组合。

创建路由组连接器时，可以选择将所有服务器保留为该连接器的桥头服务器，也可以将选定的一组服务器指定为该连接器的桥头服务器。指定的桥头服务器负责扩展通讯组成员身份。

使用已设置基于通讯组成员身份的传递限制的路由组连接器发送邮件时，邮件分类程序需要展开通讯组的成员身份，获取成员 DN 的完整列表，然后将此 DN 列表与发送人 DN 列表进行比较。如果两个列表上的 DN 匹配，则会执行访问操作或拒绝操作。如果某个通讯组嵌套在另一个通讯组中，则也会展开嵌套的通讯组。

此警告指示，当分类程序检查限制时，基于通讯组成员身份的传递限制可能会导致发往桥头服务器的邮件排队。

若要解决此警告，请执行下列操作：

  • 将路由组连接器配置到本地路由组，请参考 Microsoft 知识库文章 329171"XADM:Mail Delivery Is Slow if Recipients Are Configured with Delivery Restrictions Based on Group Membership"（XADM：如果为收件人配置了基于组成员身份的传递限制，则邮件传递速度将会减慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)。

  • 将专用且更可靠的全局编录服务器用作连接器的指定桥头服务器。

  • 配置各个邮箱，而不是配置传递限制的通讯组，请参考 Microsoft 知识库文章 812298"Mail delivery is slow after you configure delivery restrictions that are based on a distribution list"（配置基于通讯组列表的传递限制后，邮件传递的速度将会减慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。

  • 考虑实现 SMTP 发件人筛选。

  • 对于运行 Microsoft Exchange Server 2003 Service Pack 2 (SP2) 或更高版本的服务器，请考虑实现非分层限制检查。对于运行早于 Exchange 2003 SP2 的 Exchange 版本的服务器，请考虑升级为 Exchange 2003 SP2。

详细信息

有关非分层限制检查的详细信息，请参阅考虑非层次限制检查。

有关 SMTP 发件人筛选的详细信息，请参阅"Exchange Server 2003 管理指南"中的"How to Enable Sender Filtering"（如何启用发件人筛选）(http://go.microsoft.com/fwlink/?LinkId=71832)。

有关通讯组限制对 Exchange 邮件流的影响的详细信息，请参阅下列 Microsoft 知识库文章：

  • 329171"XADM:Mail Delivery Is Slow if Recipients Are Configured with Delivery Restrictions Based on Group Membership"（XADM：如果为收件人配置了基于组成员身份的传递限制，则邮件传递速度将会减慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)。

  • 895407"In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"（在 Exchange Server 2003 中，配置基于通讯组的传递限制后，向本地邮箱和外部邮箱传递邮件的速度比预期速度要慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 839949"Troubleshooting mail transport and distribution groups in Exchange 2000 Server and in Exchange Server 2003"（排除 Exchange 2000 Server 和 Exchange Server 2003 中的邮件传输和通讯组问题）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。


用于检查 SMTP 连接器通讯组传递限制的桥头服务器
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-08-21

Microsoft® Exchange Server 分析工具将查询在 Active Directory® 目录服务中检测到的每个简单邮件传输协议 (SMTP) 连接器对象 (msExchRoutingSMTPConnector) 的下列属性，以确定是否已设置基于通讯组成员身份的传递限制。

dLMemRejectPerms | 包含通讯组列表 (DL) 的域名 (DN)，该列表的成员不可以通过此 SMTP 连接器发送数据。
dLMemSubmitPerms | 包含通讯组列表 (DL) 的域名 (DN)，该列表的成员可以通过此 SMTP 连接器发送数据。

如果 Exchange Server 分析工具发现 SMTP 连接器包含基于通讯组成员身份的传递限制，Exchange Server 分析工具将查询已检测到的 SMTP 连接器的 msExchSourceBridgeheadServersDN 属性，以确定是否将分析的服务器设置为其中任何一个连接器的桥头服务器。

最后，Exchange Server 分析工具将读取以下注册表项，以确定 CheckConnectorRestrictions 注册表值是否存在并已进行配置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

如果下列条件为真，Exchange Server 分析工具将显示警告：

  • 使用 SMTP 连接器来限制基于通讯组成员身份的传递。

  • 所分析的 Exchange 服务器已被指定为该 SMTP 连接器的桥头服务器，其任务是扩展通讯组。

  • CheckConnectorRestrictions 项存在，并且设置为 1，因此已启用该项。

分类程序的默认行为是以递归方式展开通讯组，并检查通过系统传递的每封邮件的限制。

当您使用接受或拒绝来自通讯组的邮件的连接器发送邮件时，邮件分类程序必须展开通讯组的成员身份，获取成员 DN 的完整列表，然后将此 DN 列表与发送人 DN 列表进行比较。如果两个列表上的 DN 匹配，则会执行访问操作或拒绝操作。如果某个通讯组嵌套在另一个通讯组中，则也会展开嵌套的通讯组。

指定的桥头服务器是其任务为扩展通讯组成员身份的服务器。

限制检查由 CheckConnectorRestrictions 注册表值控制，必须在作为所检查连接器的来源的 Exchange 桥头服务器上设置此值。如果指定了限制但未创建 CheckConnectorRestrictions 注册表值，则不检查限制。

默认情况下会禁用连接器限制检查。为每封经由系统的邮件展开通讯组并检查限制会极大地影响性能。

此警告指示，当分类程序检查限制时，基于通讯组成员身份的传递限制可能会导致发往桥头服务器的邮件排队。

若要解决此警告，请执行下列操作：

  • 针对连接器限制设计专用的路由组，并将其配置到本地路由组，请参考 Microsoft 知识库文章 329171"XADM:Mail Delivery Is Slow if Recipients Are Configured with Delivery Restrictions Based on Group Membership"（XADM：如果为收件人配置了基于组成员身份的传递限制，则邮件传递速度将会减慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)。

  • 将专用且更可靠的全局编录服务器用作连接器的指定桥头服务器。

  • 配置各个邮箱，而不是配置传递限制的通讯组，请参考 Microsoft 知识库文章 812298"Mail delivery is slow after you configure delivery restrictions that are based on a distribution list"（配置基于通讯组列表的传递限制后，邮件传递的速度将会减慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)

  • 考虑实现 SMTP 发件人筛选。

  • 对于运行 Microsoft Exchange Server 2003 Service Pack 2 (SP2) 或更高版本的服务器，请考虑实现非分层限制检查。对于运行早于 Exchange 2003 SP2 的 Exchange 版本的服务器，请考虑升级为 Exchange 2003 SP2。

详细信息

有关非分层限制检查的详细信息，请参阅考虑非层次限制检查。

有关 SMTP 发件人筛选的详细信息，请参阅"Exchange Server 2003 管理指南"中的"How to Enable Sender Filtering"（如何启用发件人筛选）(http://go.microsoft.com/fwlink/?LinkId=71832)。

有关通讯组限制对 Exchange 邮件流的影响的详细信息，请参阅下列 Microsoft 知识库文章：

  • 329171"XADM:Mail Delivery Is Slow if Recipients Are Configured with Delivery Restrictions Based on Group Membership"（XADM：为收件人配置了基于组成员身份的传递限制后，邮件传递的速度将会减慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)。

  • 895407"In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"（在 Exchange Server 2003 中，配置基于通讯组的传递限制后，向本地邮箱和外部邮箱传递邮件的速度比预期速度要慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 839949"Troubleshooting mail transport and distribution groups in Exchange 2000 Server and in Exchange Server 2003"（排除 Exchange 2000 Server 和 Exchange Server 2003 中的邮件传输和通讯组问题）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。


无法通过端口 25 连接到路由主服务器上
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-08-24

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定当前管理组中每个路由组的 msExchRoutingMasterDN 属性的值。然后，Exchange Server 分析工具尝试通过 TCP 端口 25 打开与路由主服务器的套接字连接。如果 Exchange Server 分析工具没有收到预计的"25 可用"的自定义响应，则会显示错误。

该错误表明无法通过 TCP 端口 25 访问路由主服务器，因此可能会出现路由失败。若要更正此错误，可以排除路由主服务器的连接问题，也可以分配新的路由主服务器。

排除路由主服务器的连接问题

  1. 是否可以从路由主服务器自身通过 Telnet 连接到端口 25？如果不能，则不是网络问题。

  2. 是否所有硬件都已插入？是否所有硬件均正常运行？

  3. DNS 是否正常运行并已正确配置？

  4. 路由器是否正常运行？

  5. 是否有任何防火墙或应用程序阻止您进行连接？
分配新的路由主服务器

  1. 打开 Exchange 系统管理器

  2. 用鼠标右键单击左窗格中的树顶上的"组织名称(Exchange)"（其中的"组织名称"是您为 Exchange 2000 组织选择的名称）图标，然后单击"属性"。

  3. 依次单击"显示管理组"、"显示路由组"和"确定"。

  4. 依次展开"管理组"、<管理组>、"路由组"。

  5. 展开路由组，再单击"成员"。

  6. 在右侧窗格中，用鼠标右键单击想要将其配置为路由组主服务器的 Exchange 计算机，再单击"设为主服务器"。

有关排除路由问题、配置路由拓扑和先进的路由概念的详细信息，请参阅"Exchange Server 2003 传输和路由指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=c092b7a7-9034-4401-949c-b29d47131622&DisplayLang=zh-cn) 中的"排除路由故障"。


无法通过端口 691 连接到路由主服务器上
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-08-24

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定当前管理组中每个路由组的 msExchRoutingMasterDN 属性值。然后，Exchange Server 分析工具尝试通过 TCP 端口 691 打开与路由主服务器的套接字连接。如果 Exchange Server 分析工具没有收到预计的"691 可用"的自定义响应，则显示错误。

该错误表明无法通过 TCP 端口 691 访问路由主服务器，因此可能会出现路由失败。若要更正此错误，可以排除路由主服务器的连接问题，也可以分配新的路由主服务器。

排除路由主服务器的连接问题

  1. 是否可以从路由主服务器自身通过 Telnet 连接到端口 691？如果不能，则不是网络问题。

  2. 是否所有硬件都已插入？是否所有硬件均正常运行？

  3. DNS 是否正常运行并已正确配置？

  4. 路由器是否正常运行？

  5. 是否有防火墙阻止您连接？
分配新的路由主服务器

  1. 打开 Exchange 系统管理器

  2. 用鼠标右键单击左窗格中的树顶上的"组织名称(Exchange)"（其中的"组织名称"是您为 Exchange 2000 组织选择的名称）图标，然后单击"属性"。

  3. 依次单击"显示管理组"、"显示路由组"和"确定"。

  4. 依次展开"管理组"、<管理组>、"路由组"。

  5. 展开路由组，再单击"成员"。

  6. 在右侧窗格中，用鼠标右键单击想要将其配置为路由组主服务器的 Exchange 计算机，再单击"设为主服务器"。

有关排除路由问题、配置路由拓扑和先进的路由概念的详细信息，请参阅"Exchange Server 2003 传输和路由指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=c092b7a7-9034-4401-949c-b29d47131622&DisplayLang=zh-cn) 中的"排除路由故障"。


无法找到"主机"或"MX"记录
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-05-10

Microsoft Exchange 分析工具执行域名系统 (DNS) 查找，以检索域的邮件交换器 (MX) 记录。如果 Exchange 分析工具无法从 DNS 服务器中检索到域的 MX 记录，Exchange 分析工具将尝试 DNS 查找，以检索 Exchange 服务器尝试向其发送邮件的域的主机 (A) 记录。

如果下列条件为真，则 Exchange 分析工具将显示错误：

  • Exchange 分析工具无法检索到域的 MX 记录。

  • DNS 查找操作无法返回任一主机 (A) 记录的 IP 地址。

此错误表示域和服务器可能丢失了 DNS 邮件交换器 (MX) 和主机 (A) 记录。除了会造成其他路由或服务延迟外，该错误还可能导致发往远程域的邮件在 Exchange 服务器的"远程传递"队列中进行备份。

为了确定邮件主机，发送 Exchange 服务器会检查 MX 记录。接下来，发送服务器通过检查地址记录（A 记录）将 MX 记录解析为 IP 地址。

邮件交换器 (MX) 和主机 (A) 记录的 DNS 查找可能因下列原因失败：

  • DNS 服务器停机或由于网络故障或其他原因而不可访问。

  • 由于远程服务器的主机 (A) 记录不可用或不正确，DNS 服务器丢失此记录。

  • 未将 DNS 服务器配置为允许动态主机记录更新。

  • 系统正在尝试发送未送达报告 (NDR) 以响应可能伪装了其发件域的垃圾邮件。如果是这种情况，应删除这些邮件。请参阅本文的"详细信息"一节中的"Exchange Server 死信删除和存档工具"链接。

验证 DNS 服务器是否联机，以及 MX 和主机记录是否存在

  1. 通过执行下列一项或多项检查来验证 DNS 服务器是否正在运行：

    • 从 DNS 服务器上的 DNS 管理程序中查看 DNS 服务器的状态。

    • 重新启动 DNS 服务器。有关详细信息，请参阅"Start, stop, pause, or restart a DNS server"（启动、停止、暂停或重新启动 DNS 服务器）(http://go.microsoft.com/fwlink/?LinkId=62999)。

    • 使用 nslookup 命令验证 DNS 服务器是否响应。有关详细信息，请参阅"Verify DNS server responsiveness using the nslookup command"（使用 nslookup 命令验证 DNS 服务器是否响应）(http://go.microsoft.com/fwlink/?LinkId=63000) 中的说明。

  2. 使用 nslookup 来验证是否正确地配置了邮件交换器 (MX) 记录。有关详细信息，请参阅"Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"验证 DNS 设计和配置"部分的"如何使用 Nslookup 来验证 MX 记录配置"。

  3. 使用 nslookup 验证 DNS 服务器上是否存在主机 (A) 记录。有关详细信息，请参阅"To verify A resource records exist in DNS"（验证 DNS 中存在的资源记录）(http://go.microsoft.com/fwlink/?LinkId=63001)。

  4. 如果主机 (A) 资源记录不存在，请手动添加或修改 A 资源记录，或将 DNS 服务器配置为启用动态记录更新：

    • 手动添加 A 资源记录。有关详细信息，请参阅"Add a resource record to a DNS zone"（将资源记录添加到 DNS 区域）(http://go.microsoft.com/fwlink/?LinkId=63002)。

    • 手动修改 A 资源记录。请参阅"Modify an existing resource record"（修改现有的资源记录）(http://go.microsoft.com/fwlink/?LinkId=63014) 中的说明。

    • 将 DNS 服务器配置为启用动态主机记录更新。有关详细信息，请参阅 Microsoft 知识库文章 816592"How to configure DNS dynamic updates in Windows Server 2003"（如何在 Windows Server 2003 中配置 DNS 动态更新）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592)。

详细信息

  • 有关 Exchange Server 2003 如何使用 DNS 解析外部 IP 地址的信息，请参阅"Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"Exchange Server 2003 的传输依赖性"。

  • 有关 DNS 名称解析的信息，请参阅 Microsoft 知识库文章 322856"如何配置 DNS 以用于 Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)。

  • 有关如何解决 DNS 问题的信息，请参阅"Troubleshooting DNS"（DNS 疑难解答）(http://go.microsoft.com/fwlink/?LinkId=63003)。

  • 有关 Exchange Server 2003 系统监视的信息，请参阅 Exchange Server 2003 Management Pack for MOM 2005（用于 MOM 2005 的 Exchange Server 2003 管理包）(http://go.microsoft.com/fwlink/?LinkId=47573) 中的"System Monitoring with Exchange Management Pack"（Exchange 管理包的系统监视）。

  • 有关主机 (A) 资源记录的信息，请参阅"Managing Resource Records"（管理资源记录）(http://go.microsoft.com/fwlink/?LinkId=63004)。

  • 有关 Exchange Server 死信的删除和存档的信息，请参阅"Exchange Server Badmail Deletion and Archiving"（Exchange Server 死信的删除和存档）(http://go.microsoft.com/fwlink/?LinkId=84239)。


无法识别发件人
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-08-08

Microsoft® Exchange Server 分析工具将查询所有用户对象的 Active Directory® 目录服务 proxyAddress 属性值，以确定用户指定的本地发件人简单邮件传输协议 (SMTP) 地址是否存在匹配项。

如果 Exchange Server 分析工具无法找到用户指定的本地发件人 SMTP 地址的 proxyAddress 匹配项，则会显示错误。

此错误表明存在下列情况之一：

  • 本地 Exchange Server 组织中不存在本地发件人。

  • 错误地输入了用户指定的本地发件人 SMTP 地址。

若要解决此错误，请验证指定的本地发件人的 SMTP 地址，然后重试操作。

验证本地发件人的地址

  1. 启动 Exchange 系统管理器。

  2. 展开"收件人"，然后展开"所有全局地址列表"。

  3. 用鼠标右键单击"默认全局地址列表"，然后选择"属性"。

  4. 单击"预览"显示默认全局地址列表中包含的收件人的 SMTP 地址。

  5. 验证是否显示了指定的本地发件人，并记下 SMTP 地址。


CatDbgSink 事件接收器已安装
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取在 Internet 信息服务 (IIS) 元数据库的 LM/SmtpSvc/%SMTPINSTANCE%/EventManager/EventTypes 属性中发现的数据，以确定正在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上是否安装了 CatDbgSink 邮件流诊断应用程序。

CatDbgSink 应用程序是事件接收器，可以用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上解决邮件流问题。如果 CatDbgSink 应用程序安装在 Exchange 服务器上，Exchange Server 分析工具显示警告，表明 CatDbgSink 应用程序已安装，只应在解决邮件流问题时使用。

CatDbgSink 应用程序通常供客户在 Exchange 2000 Server 和 Exchange Server 2003 计算机上解决邮件流问题时使用。CatDbgSink 应用程序通常按 Microsoft 产品支持服务 (PSS) 的指导安装。CatDbgSink 应用程序安装并成功注册之后，客户可以使用 CatDbgSink 应用程序创建日志文件，收集 Exchange 服务器上的邮件流问题的故障排除信息。

有时，在隔离并修复了一个或多个问题之后，CatDbgSink 应用程序无法从生产性 Exchange 服务器中删除。如果 CatDbgSink 应用程序未从 Exchange 计算机中删除，CatDbgSink 应用程序将产生大量的负载，使 Exchange 服务器上出现意想不到的性能问题。在诊断了生产性 Exchange 服务器上的邮件流问题之后，必须删除 CatDbgSink 应用程序。

解决此警告问题

  1. 找到本地 CatDbgSink 安装文件夹。此文件夹包含下列安装文件：Setup.vbs、CatDbgSink.dll、CatDbgSink.pdb 和 MustReadMe.txt。

  2. 在命令提示符窗口中，将目录更改为安装文件的本地驱动器位置，例如：C:\CatDbgSink。

  3. 在命令提示符下，键入 cscript setup.vbs uninstall 1

注意：
命令行中的数字 1 指定 SMTP 虚拟服务器实例，从 1 开始。

有关 CatDbgSink 应用程序的详细信息，请联系 Microsoft 产品支持服务 (http://support.microsoft.com/default.aspx?pr=cntactms)。


对 SMTP 实例禁用了分类程序
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取在 Internet 信息服务 (IIS) 元数据库的 LM/SmtpSvc/%SMTPInstance%/RoutingSources 属性中发现的数据，以确定正在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上每个 SMTP 虚拟服务器实例 (VSI) 的邮件分类程序状态。

Exchange Server 分析工具确定 SMTPDSUseCat 关键字在 IIS 元数据库中是否存在，并报告发现的结果。如果 Exchange Server 分析工具发现 SMTPDSUseCat 存在并设置为禁用 0X000000，将显示错误。如果邮件分类程序被禁用，Exchange 服务器将遇到严重的邮件流问题。

默认情况下，如果 SMTP 服务安装在运行 Microsoft Windows®°2000 Server 或 Microsoft Windows Server™ 2003 的计算机上，将在 IIS 元数据库中创建 SMTPDSUseCat 关键字。默认情况下，SMTPDSUseCat 关键字被禁用 (0)。安装 Exchange Server 后，SMTPDSUseCat IIS 元数据库关键字将被删除。此时将启用邮件分类程序。如果 SMTP 服务或 Exchange Server 安装在运行 Windows 2000 Server 或 Windows Server 2003 的计算机上，将创建默认的 (1) STMP VSI。如果计算机上安装了 Exchange Server 并且卸载并重新安装了 SMTP 服务，可能会禁用邮件分类程序。如果安装了第三方软件或出现管理配置错误，也可能会禁用邮件分类程序。

注意：
Exchange 服务器上的每个 SMTP 虚拟服务器实例都独立控制邮件分类程序的状态。

邮件分类程序检查传入每个 SMTP VSI 的每封邮件并确定选项。邮件可能发送到本地存储，可能通过邮件传输代理 (MTA) 发送到远程主机，也可能通过 SMTP 发向远程主机。邮件分类程序还处理通讯组列表 (DL) 扩展。邮件分类程序检查到达 SMTP 服务器的邮件，并确定如何处理这些邮件。邮件分类程序是高级队列引擎的一个插件，用于在 TCP 端口 3268 对全局编录服务器执行轻型目录访问协议 (LDAP) 查询。邮件分类程序本质上是事件接收器的集合，用来对经过高级队列引擎的每个邮件执行高级地址解析。

注意：
SMTP 重新安装工具 (Smtpreinstall.exe) 位于 Exchange 2000 Server SP2 CD-ROM 的 \SUPPORT\UTILS\I386 文件夹中。
使用 SMTP 重新安装工具启用邮件分类程序

  1. 将 Smtpreinstall.exe 复制到 \Exchsrvr\Bin 文件夹中。

  2. 在 \Exchsrvr\Bin 文件夹中双击 Smtpreinstall.exe。

  3. 在"Microsoft Exchange SMTP 重新安装"对话框中单击"确定"，重新启动 Exchange 服务器。

如果必须在 IIS 元数据库中查看属性，可以安装 Metaedit 2.2 for IIS 4.0/5.0 实用程序或 IIS Metabase Explorer for IIS 6.0 实用程序。

警告：
不建议直接编辑元数据库。

有关邮件分类程序或可用的 IIS 元数据库实用程序的详细信息，请参阅下列 Microsoft 知识库文章：

  • 290290, "XIMS:重新安装 IIS SMTP 服务后无法发送邮件"(http://support.microsoft.com/?kbid=290290)

  • 319885"XCON:Messages Sent in the Exchange 2000 Server Organization Are Not Delivered"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=319885)

  • 231729"XCON:DSUseCat Key and the Message Categorizer"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231729)

  • 232068"How To:Download, Install, and Remove the IIS MetaEdit 2.2 Utility"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=232068)

若要下载 IIS 6.0 资源工具包工具，请参阅"Internet Information Services (IIS) 6.0 Resource Kit Tools"（英文）(http://go.microsoft.com/fwlink/?LinkId=33134)


在过去 24 小时内记录了一个分类程序警告事件 (ID: 6004)
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-10-05

Microsoft® Exchange Server 分析工具将查询 Win32_NTLogEvent Microsoft Windows® Management Instrumentation (WMI) 类以确定是否在过去 24 小时内记录了 MSExchangeTransport 事件 6004 警告。

如果 Exchange Server 分析工具发现在过去 24 小时内记录了 MSExchangeTransport 事件 6004 警告，则 Exchange Server 分析工具将显示警告。

此警告表明分类程序在尝试处理邮件时出错。

邮件分类程序检查到达简单邮件传输协议 (SMTP) 服务器的邮件，并确定对这些邮件执行哪些处理。邮件可能发往本地信息存储，或通过使用邮件传输代理 (MTA) 发往远程主机，或使用 SMTP 发往远程主机。分类程序还处理通讯组列表扩展。分类程序是高级队列引擎的一个插件，用于在 TCP 端口 3268 对全局编录服务器执行轻型目录访问协议 (LDAP) 查询。分类程序本质上是事件接收器的集合，用来对经过高级队列引擎的每个邮件执行高级地址解析。分类程序执行地址解析和邮件转发、设置内容转换标志、展开通讯组列表、强制采用全局设置以及生成传递状态通知。它还检测备用收件人路由并执行分流、日记以及许多其他功能。

一旦邮件进入邮件分类程序，分类程序便会立即通过在 Active Directory® 目录服务中的代理地址属性中搜索地址来解析信封上的发件人。分类程序还会通过在 Active Directory 中的代理地址属性中搜索每个地址，来解析信封上的收件人。例如，如果列表包含一个通讯组列表，它将展开该列表以包含这些成员（如果允许在服务器上展开通讯组列表）。

Possible causes of MSExchangeTransport 警告事件 6004 包括如下内容：

  • 目录服务访问 (DSAccess) 问题。

  • 目录复制延迟或失败。

  • 全局编录服务器超载。

  • DNS 问题。

若要解决此警告，请执行下列操作：

  • 验证 Exchange Server 是否已连接到一个或多个全局编录服务器。对于此操作，Windows 中的网络监视器工具会非常有用。

  • 检查生成的所有传递状态通知 (DSN) 邮件。DSN 可包括未送达报表 (NDR)。DSN 描述了通常以永久性传递错误而告终的永久性失败邮件和暂时性失败邮件。

  • 使用邮件跟踪功能对停留在分类程序中的邮件进行故障排除。

  • 使用存档接收器工具对进出 Exchange Server 的邮件进行存档和分析。

  • 使用系统监视器监视分类程序性能计数器。

有关 Exchange Server 2003 事件和错误的详细信息，请参阅"Events and Errors Message Center"（事件和错误消息中心）(http://go.microsoft.com/fwlink/?LinkId=34258)。

有关 Exchange Server 和 Microsoft Windows Small Business Server 生成的 DSN 和 NDR 的列表，请参阅 Microsoft 知识库文章 284204"Exchange Server 和 Small Business Server 中的传递状态通知"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204)。

有关如何在 Exchange Server 中使用邮件跟踪中心的信息，请参阅下列 Microsoft 知识库文章：

  • 262162"XADM：使用邮件跟踪中心来跟踪邮件"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)。

  • 246856"XADM：如何在 Exchange 2000 Server 和 Exchange Server 2003 中启用邮件跟踪）"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)。

  • 821905"Exchange Server 2003 中的邮件跟踪事件 ID"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)。

  • 823864"Exchange Server 2003 中改进的邮件跟踪功能"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)。

有关如何解决邮件分类程序问题的详细信息，请参阅 Microsoft Support Webcast"Exchange 2000 Server：邮件分类程序和 NDR 故障排除"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)。

有关存档接收器工具的详细信息，请参阅 Microsoft 知识库文章 307798"Service Pack 2 中可以使用存档接收器工具"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)。

有关如何解决与传输有关的问题的常规信息，请参阅下列 Microsoft 知识库文章和资源：

  • 821910"如何解决 Exchange Server 2003 传输问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)。

  • 257265"解决常规的 Exchange 2000 Server 和 Exchange Server 2003 传输问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)。

  • 895853"如何解决 Exchange Server 2003 和 Exchange 2000 Server 中的邮件中继问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853)。

  • "Exchange Server and Transport Routing Guide"（Exchange Server 和传输路由指南）中的"Troubleshooting Mail Flow and SMTP"（排除邮件流和 SMTP 故障）(http://go.microsoft.com/fwlink/?LinkID=67875)。

邮件分类程序性能计数器是专门针对每个 SMTP 虚拟服务器实例发布的。若要查看与邮件分类程序相关的可用性能计数器的列表，请参阅 Microsoft 知识库文章 231734"XCON: 邮件分类程序的性能监视计数器"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)。


在过去 24 小时内记录了一个分类程序警告事件 (ID: 6006)
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-10-06

Microsoft® Exchange Server 分析工具将查询 Win32_NTLogEvent Microsoft Windows® Management Instrumentation (WMI) 类以确定是否在过去 24 小时内记录了 MSExchangeTransport 事件 6006 警告。

如果 Exchange Server 分析工具发现在过去 24 小时内记录了 MSExchangeTransport 事件 6006 警告，则 Exchange Server 分析工具将显示警告。

此警告表示邮件已被捕获到邮件分类程序中。

邮件分类程序检查到达简单邮件传输协议 (SMTP) 服务器的邮件，并确定对这些邮件执行哪些处理。邮件可能发往本地信息存储，或通过使用邮件传输代理 (MTA) 发往远程主机，或使用 SMTP 发往远程主机。分类程序还处理通讯组列表扩展。分类程序是高级队列引擎的一个插件，用于在 TCP 端口 3268 对全局编录服务器执行轻型目录访问协议 (LDAP) 查询。分类程序本质上是事件接收器的集合，用来对经过高级队列引擎的每个邮件执行高级地址解析。分类程序执行地址解析和邮件转发、设置内容转换标志、展开通讯组列表、强制采用全局设置以及生成传递状态通知。它还检测备用收件人路由并执行分流、日记以及许多其他功能。

一旦邮件进入邮件分类程序，分类程序便会立即通过在 Active Directory® 目录服务中的代理地址属性中搜索地址来解析信封上的发件人。分类程序还会通过在 Active Directory 中的代理地址属性中搜索每个地址，来解析信封上的收件人。例如，如果列表包含一个通讯组列表，它将展开该列表以包含这些成员（如果允许在服务器上展开通讯组列表）。

Possible causes of MSExchangeTransport 警告事件 6006 包括如下内容：

  • 过时或配置不正确的防病毒软件。

  • 很多通讯组扩展。

  • 配置不正确的日记收件人。

  • 对 Active Directory 中 Exchange 对象的权限配置不正确。

若要解决此警告，请执行下列操作：

  • 确保您已正确地配置了文件级别防病毒应用程序，以排除特定 Exchange Server 目录。有关扫描运行 Microsoft Exchange Server 的服务器时，不应该包括的文件夹的描述，请参阅 Microsoft 知识库文章 823166"Exchange Server 2003 和防病毒软件概述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)。

  • 确保运行的防病毒应用程序软件是最新版本。

  • 检查通讯组传递限制设置并删除不必要的限制。

  • 检查日记设置是否出现不正确的配置。

  • 检查是否不适当地配置了 Active Directory 中的 Exchange 对象。

详细信息

有关非分层限制检查的详细信息，请参阅考虑非层次限制检查。

有关通讯组限制对 Exchange Server 邮件流的影响的详细信息，请参阅下列 Microsoft 知识库文章：

  • 895407"在 Exchange Server 2003 中，配置基于通讯组的传递限制后，向本地邮箱和外部邮箱传递邮件的速度比预期速度要慢"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 839949"解决 Exchange 2000 Server 和 Exchange Server 2003 中的邮件传输和通讯组问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。

  • 812298"配置基于通讯组列表的传递限制后，邮件传递的速度将会减慢"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。

有关如何部署日记解决方案的详细信息，请参阅"Journaling with Exchange Server"（Exchange Server 的日记功能）(http://go.microsoft.com/fwlink/?LinkId=47581)。

有关可能导致分类程序警告事件 ID 6006 的原因的详细信息，请参阅 Microsoft 知识库文章 922256"电子邮件滞留在 Exchange Server 2003 组织中的"等待目录查找"队列中"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=922256)。

有关 Exchange Server 2003 事件和错误的详细信息，请参阅"Events and Errors Message Center"（事件和错误消息中心）(http://go.microsoft.com/fwlink/?LinkId=34258)。

有关 Exchange Server 和 Microsoft Windows Small Business Server 生成的 DSN 和 NDR 的列表，请参阅 Microsoft 知识库文章 284204"Exchange Server 和 Small Business Server 中的传递状态通知"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204)。

有关如何解决邮件分类程序问题的详细信息，请参阅 Microsoft Support Webcast"Exchange 2000 Server：邮件分类程序和 NDR 故障排除"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)。

有关如何解决与传输有关的问题的常规信息，请参阅下列 Microsoft 知识库文章和资源：

  • 821910"如何解决 Exchange Server 2003 传输问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)。

  • 257265"解决常规的 Exchange 2000 Server 和 Exchange Server 2003 传输问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)。

  • 895853"如何解决 Exchange Server 2003 和 Exchange 2000 Server 中的邮件中继问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853)。

  • "Exchange Server and Transport Routing Guide"（Exchange Server 和传输路由指南）中的"Troubleshooting Mail Flow and SMTP"（排除邮件流和 SMTP 故障）(http://go.microsoft.com/fwlink/?LinkID=67875)。

邮件分类程序性能计数器是专门针对每个 SMTP 虚拟服务器实例发布的。若要查看与邮件分类程序相关的可用性能计数器的列表，请参阅 Microsoft 知识库文章 231734"XCON: 邮件分类程序的性能监视计数器"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)。


在过去 24 小时内已记录了一个分类程序警告事件（ID：6008）
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-10-06

Microsoft® Exchange Server 分析工具将查询 Win32_NTLogEvent Microsoft Windows® Management Instrumentation (WMI) 类，以确定是否在过去 24 小时内记录了 MSExchangeTransport 事件 6008 警告。

如果 Exchange Server 分析工具发现在过去 24 小时内记录了 MSExchangeTransport 事件 6008 警告，则 Exchange Server 分析工具将显示警告。

此警告表明分类程序在尝试处理邮件时出错。

邮件分类程序检查到达简单邮件传输协议 (SMTP) 服务器的邮件，并确定对这些邮件执行哪些处理。邮件可能发往本地信息存储，或通过使用邮件传输代理 (MTA) 发往远程主机，或使用 SMTP 发往远程主机。分类程序还处理通讯组列表扩展。分类程序是高级队列引擎的一个插件，用于在 TCP 端口 3268 对全局编录服务器执行轻型目录访问协议 (LDAP) 查询。分类程序本质上是事件接收器的集合，用来对经过高级队列引擎的每个邮件执行高级地址解析。分类程序执行地址解析和邮件转发、设置内容转换标志、展开通讯组列表、强制采用全局设置以及生成传递状态通知。它还检测备用收件人路由并执行分流、日记以及许多其他功能。

一旦邮件进入邮件分类程序，分类程序便会立即通过在 Active Directory® 目录服务中的代理地址属性中搜索地址来解析信封上的发件人。分类程序还会通过在 Active Directory 中的代理地址属性中搜索每个地址，来解析信封上的收件人。例如，如果列表包含一个通讯组列表，它将展开该列表以包含这些成员（如果允许在服务器上展开通讯组列表）。

Possible causes of MSExchangeTransport 出现下列情况时，会引发警告事件 6008。

  • 目录服务访问 (DSAccess) 问题。

  • 目录复制延迟或失败。

  • 全局编录服务器超载。

  • DNS 问题。

  • 过多的通讯组扩展。

若要解决此警告，请执行下列操作：

  • 验证 Exchange Server 是否已连接到一个或多个全局编录服务器。对于此操作，Windows 中的网络监视器工具会非常有用。

  • 检查生成的所有传递状态通知 (DSN) 邮件。DSN 可包括未送达报告 (NDR)。DSN 描述了通常以永久性传递错误而告终的永久性失败邮件和暂时性失败邮件。

  • 使用邮件跟踪功能对停留在分类程序中的邮件进行故障排除。

  • 使用存档接收器工具对进出 Exchange Server 的邮件进行存档和分析。

  • 使用系统监视器监视分类程序性能计数器。

  • 检查通讯组传递限制设置并删除不必要的限制。

有关 Exchange Server 2003 事件和错误的详细信息，请参阅"Events and Errors Message Center"（事件和错误消息中心）(http://go.microsoft.com/fwlink/?LinkId=34258)。

有关 Exchange Server 和 Microsoft Windows Small Business Server 生成的 DSN 和 NDR 的列表，请参阅 Microsoft 知识库文章 284204"Exchange Server 和 Small Business Server 中的传递状态通知"(http://support.microsoft.com/kb/284204/zh-cn)。

有关如何在 Exchange Server 中使用邮件跟踪中心的信息，请参阅下列 Microsoft 知识库文章：

  • 262162"XADM：使用邮件跟踪中心来跟踪邮件"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)。

  • 246856"XADM：如何在 Exchange 2000 Server 和 Exchange Server 2003 中启用邮件跟踪"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)。

  • 821905"Exchange Server 2003 中的邮件跟踪事件 ID"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)。

  • 823864"Exchange Server 2003 中改进的邮件跟踪功能"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)。

有关如何解决邮件分类程序问题的详细信息，请参阅 Microsoft Support Webcast"Exchange 2000 Server：邮件分类程序和 NDR 故障排除"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)。

有关存档接收器工具的详细信息，请参阅 Microsoft 知识库文章 307798"在 Service Pack 2 才可用存档接收器工具"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)。

有关非分层限制检查的详细信息，请参阅考虑非层次限制检查。

有关通讯组限制对 Exchange Server 邮件流的影响的详细信息，请参阅下列 Microsoft 知识库文章：

  • 895407"在 Exchange Server 2003 中，配置基于通讯组的传递限制后，向本地邮箱和外部邮箱传递邮件的速度比预期速度要慢"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 839949"如何解决 Exchange 2000 Server 和 Exchange Server 2003 中的邮件传输和通讯组问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。

  • 812298"配置基于通讯组列表的传递限制后，邮件传递的速度将会减慢"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。

有关如何解决与传输有关的问题的常规信息，请参阅下列 Microsoft 知识库文章和资源：

  • 821910"如何解决 Exchange Server 2003 传输问题"（http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910）。

  • 257265"解决常规的 Exchange 2000 Server 和 Exchange Server 2003 传输问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)。

  • 895853"如何解决 Exchange Server 2003 和 Exchange 2000 Server 中的邮件中继问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853)。

  • "Exchange Server and Transport Routing Guide"（Exchange Server 传输和路由指南）中的"Troubleshooting Mail Flow and SMTP"（排除邮件流和 SMTP 故障）(http://go.microsoft.com/fwlink/?LinkID=67875)。

邮件分类程序性能计数器是专门针对每个 SMTP 虚拟服务器实例发布的。若要查看与邮件分类程序相关的可用性能计数器的列表，请参阅 Microsoft 知识库文章 231734"XCON：邮件分类程序的性能监视计数器"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)。


已启用连接筛选
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以便确定简单邮件传输协议 (SMTP) 虚拟服务器对象的 msExchServerBindingsFiltering 属性是否指明，已对 SMTP 虚拟服务器实例启用了连接筛选。

Exchange Server 分析工具还查询 Active Directory，以确定 msExchSmtpConnectionRulesPriority、msExchSMTPGlobalIPAcceptList 或 msExchSMTPGlobalIPDenyList 属性是否指明在全局设置级别也启用了连接筛选。

如果符合以下条件，则 Exchange Server 分析工具将显示警告消息：

  • 在 SMTP 虚拟服务器实例启用了连接筛选。

  • 在全局设置级别启用了连接筛选。

此警告表明已有效地启用了连接筛选。通常连接筛选不会有问题。但是，在解决涉及此特定服务器的邮件流问题时，可能要验证筛选器配置或临时禁用连接筛选，以确定它是否错误地阻止了发给有效收件人的邮件。

在 SMTP 虚拟服务器上禁用连接筛选器

  1. 启动 Exchange 系统管理器：单击"开始"，指向"所有程序"，指向"Microsoft Exchange"，再单击"系统管理器"。

  2. 在控制台树中，展开"服务器"，然后依次展开所需的服务器、"协议"和"SMTP"。

  3. 用鼠标右键单击要对其启用筛选器的 SMTP 虚拟服务器，然后单击"属性"。

  4. 在"<SMTP 虚拟服务器> 属性"中的"常规"选项卡上，单击"高级"。

  5. 在"高级"中选择要对其禁用筛选器的 IP 地址，然后单击"编辑"。

  6. 在"标识"中，清除"应用连接筛选器"复选框以禁用筛选器。

  7. 如果有多台虚拟服务器，请对每台要禁用筛选器的虚拟服务器重复步骤 3 到 6。

有关如何配置连接筛选器的详细信息，请参阅 Microsoft 知识库文章 823866"如何在 Exchange 2003 中配置连接筛选以使用实时阻止列表 (RBL) 以及如何配置收件人筛选"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823866)。

有关智能邮件筛选的详细信息，请参阅网站上的"Exchange Intelligent Message Filter"（英文）(http://go.microsoft.com/fwlink/?LinkId=21607)。


连接器设置了接受限制
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定路由组中每个 SMTP 连接器的 dLMemDefault 属性的值。Exchange Server 分析工具还查询 Active Directory，以确定每个连接器的 authOrig 和 unauthOrig 属性的值。unauthOrig 和 authOrig 属性包含帐户的可分辨名称 (DN) 列表。

默认情况下，所有 SMTP 连接器允许所有用户通过连接器发送邮件。如果 dLMemDefault 设置为默认设置 1，将接受除了 unauthOrig 属性中所列出帐户以外的所有帐户的邮件。如果 dLMemDefault 设置为 0，将拒绝除了 authOrig 属性中所列出帐户以外的所有帐户的邮件。

如果符合下列条件，Exchange Server 分析工具将显示非默认配置消息：

  • dLMemDefault 属性的值设置为 0。

  • authOrig 属性包含值。

Exchange Server 分析工具所指定的连接器配置为只接受某些邮件。将只允许在连接器的"传递限制"选项卡上赋予明确权限的帐户通过连接器发送邮件。

Exchange Server 分析工具仅以提供信息为目的显示非默认配置消息。

有关连接器的详细信息，请参阅"Exchange Server 2003 传输和路由指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=c092b7a7-9034-4401-949c-b29d47131622&displaylang=zh-cn)。


连接器设置了拒绝限制
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定路由组中每个 SMTP 连接器的 dLMemDefault 属性值。Exchange Server 分析工具还查询 Active Directory，以确定每个连接器的 authOrig 和 unauthOrig 属性的值。unauthOrig 和 authOrig 属性包含帐户的可分辨名称 (DN) 列表。

默认情况下，所有 SMTP 连接器允许所有用户通过连接器发送邮件。如果 dLMemDefault 设置为默认设置 1，将接受除了 unauthOrig 属性中所列出帐户以外的所有帐户的邮件。如果 dLMemDefault 设置为 0，将拒绝除了 authOrig 属性中所列出帐户以外的所有帐户的邮件。

如果下列条件为真，则 Exchange Server 分析工具将显示非默认配置消息：

  • dLMemDefault 属性的值设置为 1。

  • unauthOrig 属性包含值。

Exchange Server 分析工具所指定的连接器配置为拒绝某些邮件。不允许在连接器的"传递限制"选项卡上被明确拒绝了权限的帐户通过连接器发送邮件。

Exchange Server 分析工具仅以提供信息为目的显示非默认配置消息。

有关连接器的详细信息，请参阅"Exchange Server 2003 传输和路由指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=c092b7a7-9034-4401-949c-b29d47131622&displaylang=zh-cn)。


默认情况下，连接器拒绝所有邮件
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个连接器的 dLMemDefault 属性的值。dLMemDefault 属性控制在默认情况下是接受还是拒绝邮件。

如果 dLMemDefault 属性的值为 0，表明在默认情况下拒绝邮件。如果 dLMemDefault 属性的值为 1，表明在默认情况下接受邮件。如果 Exchange Server 分析工具发现 dLMemDefault 属性的值为 0，则会显示非默认配置消息。

Exchange Server 分析工具所指定的连接器配置为在默认情况下拒绝所有邮件。只允许在连接器的"传递限制"选项卡上赋予明确权限的帐户通过连接器发送邮件。

Exchange Server 分析工具仅以提供信息为目的显示非默认配置消息。

有关连接器的详细信息，请参阅"Exchange Server 2003 传输和路由指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=c092b7a7-9034-4401-949c-b29d47131622&displaylang=zh-cn)。


连接器限制检查已启用
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表分支，以确定 CheckConnectorRestrictions 注册表值是否存在并经过配置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

如果 Exchange Server 分析工具发现 CheckConnectorRestrictions 的值存在并设置为 1，则将显示警告。

如果需要对连接器应用基于通讯组列表的限制，则必须手动启用这些限制的检查过程。限制检查由 CheckConnectorRestrictions 注册表值控制，必须在作为接受检查的连接器的源的 Exchange 桥头服务器上对该注册表值进行设置。如果指定一条限制，但未创建 CheckConnectorRestrictions 注册表值，则不会检查该限制。

由于为每封经由系统的邮件展开通讯组并检查限制会极大地影响性能，因此，默认情况下，连接器限制检查处于禁用状态。如果可能，仅在必需使用该设置的位置启用它（例如，在受限连接器的桥头服务器上启用该设置）。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

禁用连接器限制检查

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\Resvc\Parameters

  3. 在右侧窗格中，找到 CheckConnectorRestrictions 并将其删除。

  4. 关闭注册表编辑器，并重新启动 Microsoft Exchange Routing Engine 服务和 Simple Mail Transfer Protocol (SMTP) 服务，以使更改生效。

有关如何编辑注册表的详细信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关连接器限制检查注册表值的详细信息，请参阅 Microsoft 知识库文章 277872"XCON:Connector Delivery Restrictions May Not Work Correctly"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872)。


连接器的作用域为本地路由
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-04-21

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 SMTP 连接器的 msExchRoutingSMTPConnector 属性的值。如果 Exchange Server 分析工具发现 msExchRoutingSMTPConnector 属性的值包含字符串"Local:"，Exchange Server 分析工具将显示非默认配置消息。出现字符串"Local:"则表明 SMTP 连接器的作用域为本地路由。

SMTP 连接器为邮件指定独立的路由。可以使用 SMTP 连接器建立 Internet 邮件的网关或连接到特定的域或邮件系统。使用连接器可以为指定的邮件路由定义特定的选项。

尽管可以使用 SMTP 虚拟服务器收发 Internet 邮件，但是，许多组织为路由 Internet 邮件配置了专用的 SMTP 连接器。建议使用 SMTP 连接器，因为它可以为发向 Internet 的邮件提供独立的路由。此外，SMTP 连接器上的配置选项要多于 SMTP 虚拟服务器。

Exchange Server 分析工具仅以提供信息为目的显示非默认配置消息。

有关 SMTP 连接器的详细信息，请参阅"Exchange Server 2003 传输和路由指南"(http://go.microsoft.com/fwlink/?LinkId=47579).


考虑非层次限制检查
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定目录中每个 Exchange Server 对象的 serialNumber 属性值。如果 Exchange Server 分析工具发现 Exchange Server 2003 服务器对象的 serialNumber 属性值在其字符串值中包含 Service Pack 2，则读取以下注册表项，以确定 CheckConnectorRestrictions 注册表值是否存在并已配置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

此情况表明服务器在处理邮件之前，先检查发送和接收限制。

如果 Exchange Server 分析工具发现 CheckConnectorRestrictions 的值存在并设置为 1,（即启用），则还读取 HKLM\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod 注册表项，以确定 RestrictionMethod 注册表值是否存在以及如何进行配置。

如果 Exchange Server 分析工具发现 RestrictionMethod 注册表值丢失或设置的值不是 2，则显示最佳做法消息。

总之，如果下列条件为真，则 Exchange Server 分析工具将显示最佳做法消息：

  • Exchange Server 2003 服务器安装了 SP2。

  • HKLM\System\CurrentControlSet\Services\Resvc\Parameters 中的 CheckConnectorRestrictions 注册表值配置为对本地计算机上的连接器使用基于通讯组列表的限制。

  • HKLM\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod 中的 RestrictionMethod 注册表值丢失或设置的值不是 2。

RestrictionMethod 值确定分类程序将如何处理限制。分类程序的默认行为是反复展开通讯组，并检查通过系统传递的每封邮件的限制。此默认的分类程序行为可能对性能造成很大影响，不是最佳实践。

如果将 RestrictionMethod 的值设置为 2，在服务器检查限制时，此 Exchange 服务器上的传输组件不会展开通讯组的成员身份。此配置使限制检查可以实现最佳性能。此外，若要使 RestrictionMethod 注册表项生效，所有通讯组（包括具有传递限制的用户）必须是无层次的。即受限制的通讯组不得包含嵌套的通讯组。如果嵌套了受限制的通讯组，则将无法使用展开逻辑。

对于连接器限制中使用的通讯组，建议您在没有邮箱的连接器桥头服务器上设置 RestrictionMethod 注册表项值。对于 Active Directory 用户限制，如果受限制的通讯组包含扩展服务器，建议您在扩展服务器上创建 RestrictionMethod 注册表项。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
创建 RestrictionMethod 注册表项并将其值设置为 2

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

  3. 在左侧窗格中，单击"参数"。

  4. 在"编辑"菜单上，指向"新建"，然后单击"DWORD 值"。

  5. 键入 RestrictionMethod，再按 ENTER 键为新的注册表项命名。

  6. 用鼠标右键单击 RestrictionMethod，再单击"修改"。

  7. 键入 2，再按 ENTER 键。

  8. 退出注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 RestrictionMethod 注册表值的详细信息，请参阅 Microsoft 知识库文章 895407"In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

有关注册表值的详细信息，请参阅 Microsoft 知识库文章 277872"XCON:Connector Delivery Restrictions May Not Work Correctly"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872)。


ConvertDSNInternetContent 注册表项配置为对所有邮件执行内容转换
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已将 ConvertDSNInternetContent 注册表值配置为在 Exchange Server 2003 计算机上针对 Exchange 信息存储接收到的所有邮件执行内容转换：

HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • ConvertDSNInternetContent 注册表值已手动创建。

  • ConvertDSNInternetContent 注册表值数据设置为 1。

如果 ConvertDSNInternetContent 注册表值的数值数据为 0 或没有值，将禁用对 Exchange 信息存储所接收的 SMTP 邮件的内容转换。数值数据为 1 将启用对所有邮件的内容转换，包括所有 SMTP 虚拟服务器实例 (VSI) 上或到各个 VSI 的 SMTP 邮件。

默认情况下，安装 Exchange Server 2003 的过程中不创建 ConvertDSNInternetContent 注册表值。ConvertDSNInternetContent 注册表值可以在安装 Exchange Server 之后手动创建，以更改 Exchange Server 2003 计算机上的内容转换行为。通常情况下，提交的 SMTP 邮件不得进行内容转换。如果启用对所有邮件（包括 SMTP 邮件）的内容转换，会增加 Exchange 服务器上的处理开销。这种额外的处理开销可能会造成性能和日志文件存储问题。

Exchange Server 分析工具仅以提供信息为目的报告此配置。必须编辑注册表，使 Exchange Server 2003 计算机上的内容转换行为恢复到最有效的内容转换方法。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到以下注册表项： HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

  3. 在详细信息窗格中，用鼠标右键单击 ConvertDSNInternetContent 注册表值，再单击"修改"，然后将"数值数据"更改为 80。单击"确定"。

    注意：
    若要删除 ConvertDSNInternetContent 注册表值，在详细信息窗格中，用鼠标右键单击 ConvertDSNInternetContent 注册表值，然后单击"删除"。在对话框中单击"是"来确认注册表值的删除。

  4. 关闭注册表编辑器。

  5. 重新启动 Exchange 服务器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关编辑 Microsoft Windows 注册表项的详细信息，请参阅下列 Microsoft 知识库文章：

  • 322755"HOW TO：在 Windows 2000 中备份、编辑和还原注册表"(http://support.microsoft.com/default.aspx?scid=kb;zh-cn;322755)

  • 322756"如何在 Windows XP 和 Windows Server 2003 中备份、编辑和还原注册表"(http://support.microsoft.com/default.aspx?scid=kb;zh-cn;322756)


标识为通用目标的通讯组
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-10-04

Microsoft® Exchange Server 分析工具查询 Exchange_Queue Windows® Management Instrumentation (WMI) 类，以确定 SMTP 虚拟服务器的简单邮件传输协议 (SMTP) 队列的下列属性值。

LinkId | 表示包含该队列的链接的标识符。
QueueId | 表示该队列的标识符。
QueueName | 表示该队列的名称。
VirtualMachine | 表示包含该队列的虚拟计算机的名称。
VirtualServerName | 表示该队列所在的虚拟服务器的名称。
MessageCount | 表示该队列中的邮件数。

Exchange Server 分析工具使用此处获得的信息来查询 Exchange_QueuedSMTPMessage WMI 类，以确定该队列中邮件的下列属性值：

Recipients | 表示邮件收件人。
Received | 表示邮件的接收时间戳。
MessageId | 表示队列中邮件的标识符。
StateRetry | 表示重新尝试传输未成功传递的邮件。

最后，Exchange Server 分析工具使用从此处获得的数据查询 Active Directory® 目录服务，以确定每个 Recipient 对象的 distinguishedName 值。然后，Exchange Server 分析工具会确定该收件人是一位用户、一个通讯组、一个公用文件夹还是一个公用文件夹存储。

如果 Exchange Server 分析工具确定队列中滞留的邮件至少有 25％（在 To: 字段或 Cc: 字段中）要发送到特定通讯组，则 Exchange Server 分析工具会显示警告。

如果 Exchange Server 分析工具确定队列中滞留的邮件至少有 50％（在 To: 字段或 Cc: 字段中）要发送到特定通讯组，则 Exchange Server 分析工具会显示错误。

此警告或错误表明被标识的通讯组是 SMTP 队列中滞留邮件的通用目标。

要解决此问题，请按如下方式检查该通讯组，以找出是否因配置问题或其他错误导致发往此通讯组的邮件排队：

  • 确保通讯组对象的属性设置正确，且 Active Directory 包含的值正确无误。

  • 查看该通讯组对象的 Active Directory 权限设置是否正确。

  • 如果该通讯组包含一个特殊的使用用户对象，即一个特定的日记收件人，请查看与此用户对象相关的服务或组件的配置是否正确。

  • 查找可能攻击该通讯组的商业垃圾邮件 (UCE)、垃圾邮件或病毒攻击。

  • 确定该通讯组的传递限制设置是否正确。

有关如何排除 SMTP 队列故障的详细信息，请参阅下列 Exchange 资源：

  • "Exchange Server 传输和路由指南"中的"Troubleshooting Mail Flow and SMTP"（排除邮件流和 SMTP 故障）(http://go.microsoft.com/fwlink/?LinkID=67875)。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)。

有关通讯组限制对 Exchange Server 邮件流的影响的详细信息，请参阅下列 Microsoft 知识库文章：

  • 895407"在 Exchange Server 2003 中，配置基于通讯组的传递限制后，向本地邮箱和外部邮箱传递邮件的速度比预期速度要慢"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 329171"XADM：基于组成员身份为收件人配置传送限制后邮件传送速度变慢"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)。

  • 839949"解决 Exchange 2000 Server 和 Exchange Server 2003 中的邮件传输和通讯组问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。

  • 812298"配置基于通讯组列表的传递限制后，邮件传递的速度将会减慢"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。


早期分类由于可重试错误而失败
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-09-06

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎从 SMTP Server 性能对象的 Cat:Categorizations in progress 和 Categorizer Queue length 性能计数器收集数据以分析性能数据。

Cat:Categorizations in progress 性能计数器显示正在进行的分类数，而 Categorizer Queue length 性能计数器显示分类程序队列中的邮件数。

对于此查询，Exchange Server 分析工具将在 2 分钟的时段内，每隔 6 秒检索一个样本。Exchange Server 分析工具将报告收集间隔期间性能计数器的平均值。

Exchange Server 分析工具将检查正在进行的分类的平均数，并将该数目与仍在队列中的分类数进行比较。

如果在采样期间下列条件为真，则 Exchange Server 分析工具将显示错误：

  • 正在进行的分类的平均数为零。

  • 分类程序平均队列长度大于零。

分类程序执行下列核心操作：

  • 解析并验证所有收件人。

  • 确定所有收件人的限制。

  • 展开通讯组列表（如果需要）。

  • 确定邮件用于本地传递还是远程传递。

此错误指示，分类程序队列中存在滞留的邮件，由于出现可重试错误，未能对这些邮件的进行分类。

一般而言，邮件在队列中进行累积的原因是高级排队引擎无法对邮件进行分类。高级排队引擎可能无法访问全局编录服务器和收件人信息。或者，全局编录服务器不可访问或运行较慢。此外，邮件可能会因以下原因而发生累积：

  • Active Directory® 目录服务不可用。

    注意：
    分类程序使用 Active Directory 对邮件进行分类。
  • 如果许多邮件在预分类队列中排队，Active Directory 可能会承受过重的负载。

  • 存在转换错误。分类程序也可以处理内容转换。

  • 邮件分类程序无法找到邮箱存储。

  • 如果重新安装或删除简单邮件传输协议 (SMTP)，则下列 IIS 元数据库关键字可能失效：/smtpsvc/DsUseCat 和 /smtpsvc/vsi#/DsUseCat。

    注意：
    确定是否重新安装或删除了 SMTP。

可以检查队列的属性，以确定失败的原因。例如，如果队列属性显示类似"已发生 SMTP 错误"的消息，则应查看服务器的事件日志以查找任何 SMTP 错误。如果日志中没有事件，则应增加 SMTP 日志记录级别。

有关如何排除 Exchange 和 SMTP 队列问题的详细信息，请参阅下列 Exchange 资源：

  • "Exchange Server 2003 传输和路由指南"中的"排除邮件流和 SMTP 故障"(http://go.microsoft.com/fwlink/?LinkID=67875)。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)。

  • Microsoft 知识库文章 821877"Description of Fields on the SMTP and X.400 Queue Properties Tabs"（对 SMTP 和 X.400 队列"属性"选项卡上字段的描述）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)。

  • Microsoft 知识库文章 264054"XCON：了解 Exchange 2000 Server 中的队列状态"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。

  • "Troubleshooting Microsoft Exchange Server Performance"（排除 Microsoft Exchange Server 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • "Exchange Server 2003 性能和可伸缩性指南"(http://go.microsoft.com/fwlink/?LinkId=47576)。

邮件分类程序性能计数器是专门针对每个 SMTP 虚拟服务器实例发布的。若要查看与邮件分类程序相关的可用性能计数器的列表，请参阅 Microsoft 知识库文章 231734"XCON:Performance Monitor Counters for Message Categorizer"（XCON：邮件分类程序的性能监视器计数器）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)。


启用智能邮件筛选器自动更新
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-02-13

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定目录中所有 Exchange Server 对象的 serialNumber 属性值。serialNumber 属性是一个字符串值，它同时包含 Exchange Server 的版本号以及 Service Pack 的版本号（如果已安装）。如果 serialNumber 属性的值等于 Version 6.5 (Build 7638:Service Pack 2)，则表示服务器正在运行 Exchange Sever 2003 Service Pack 2。

Exchange Server 分析工具还查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定群集服务 ClusSvc 的 Started 关键字的值。值为 True 表示群集服务正在运行，值为 False 则表示未运行该服务。

Exchange Server 分析工具还读取以下注册表项，以确定服务器上是否已安装并启用了 Microsoft Exchange 智能邮件筛选器：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

如果 Exchange Server 分析工具发现 ContentFilter 注册表项中存在 ContentFilterBindings 项，但是未配置 ContentFilterBindings 值，则表示服务器上未启用智能邮件筛选器。

最后，Exchange Server 分析工具查询下列注册表项，以确定是否存在 ContentFilterState 子项以及服务器上是否启用了智能邮件筛选器自动更新：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\

除 1 外，ContentFilterState 子项的任何值都表示未启用智能邮件筛选器的自动更新。

如果下列条件为真，则 Exchange Server 分析工具将显示最佳做法消息：

  • 服务器正在运行 Exchange Server 2003 Service Pack 2

  • Exchange 服务器不在群集中

  • 启用了智能邮件筛选器

  • 未启用智能邮件筛选器的自动更新。

默认情况下，智能邮件筛选器功能随 Exchange Server 2003 SP2 一起安装。您必须手动启用智能邮件筛选器功能才能获得这种新邮件筛选技术所带来的利益。在启用智能邮件筛选器功能后，必须定期更新 .dat 文件和 .dll 文件以将筛选器保持在最新、最有效的状态。下列部分中引用的文章介绍了将智能邮件筛选器保持在最新状态的更新过程。

有关如何启用智能邮件筛选器的自动更新的详细信息，请参阅 Microsoft 知识库文章 907747"How to update the Intelligent Message Filter version 2 in Exchange Server 2003 SP2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=907747)。


信封日记功能已启用
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-03-30

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定是否已将 heuristics 属性配置为启用信封日记功能。默认情况下不配置 heuristics 属性。如果 Exchange Server 分析工具发现 heuristics 属性已设置为 512，则 Exchange Server 分析工具将显示非默认配置消息。

通过信封日记功能可以存档 P1 邮件头。P1 邮件头是邮件传输代理 (MTA) 路由邮件时所使用的地址信息。此地址信息包括有关实际接收该邮件的收件人的信息，包括密件抄送 (Bcc) 收件人和通讯组中的收件人。信封日记功能使用包含日记报告和原始邮件的信封邮件，传递标记为要存档的邮件。原始邮件作为附件传递。日记报告的正文包含已存档的邮件的传输信封数据。

若要在特定服务器上启用 Bcc 日记功能，必须先在数据库级别配置仅邮件日记功能。如果符合下列条件，表明 heuristics 属性未激活：

  • heuristics 属性设置为 512。

  • 任何数据库存储上均未启用仅邮件日记功能。

邮件日记功能可能会占用许多磁盘资源、网络资源和 CPU 资源。因此，日记功能需要进行全面的部署计划。只有在整体日记解决方案框架的环境下，才应启用日记功能。

如果符合下列条件，请忽略此非默认配置消息：

  • 您的业务需要日记功能。

  • 您已部署了日记解决方案框架。

否则，应关闭日记功能。

关闭数据库上的仅邮件日记功能

  1. 在 Exchange 系统管理器中，依次展开"服务器"、<您的 Exchange 服务器>、<存储组>，再用鼠标右键单击邮箱存储。

  2. 在"常规"选项卡上，清除"存档由此存储中的邮箱发送或接收的所有邮件"复选框。

  3. 等待 15 分钟，让 Exchange 存储应用更改。不必重新启动 Microsoft Exchange 信息存储服务。

如果不希望 Exchange Server 分析工具再次显示此消息，必须禁用 heuristics 属性。若要禁用日记功能，不必禁用 heuristics 属性。

可以使用电子邮件日记功能高级配置工具 (Exejcfg.exe) 禁用信封日记功能。可以从任何有权访问 Active Directory 的服务器上运行该工具，但是建议从域控制器上运行该工具。

要获取电子邮件日记功能高级配置工具和文档，请从 http://go.microsoft.com/fwlink/?LinkId=33122 下载工具软件包。电子邮件日记功能高级配置工具可以在 Exchange 2000 Server 环境和 Exchange Server 2003 环境中使用。

禁用 heuristics 属性

  1. 将电子邮件日记功能高级配置工具下载并解压缩到所选的目录。

  2. 打开命令提示。

  3. 转到安装电子邮件日记功能高级配置工具的目录。

  4. 通过键入以下命令禁用信封日记功能：

    复制代码
    exejcfg -d

有关部署日记解决方案的详细信息，请参阅"Journaling with Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47581)。


不支持 ESMTP 谓词
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定简单邮件传输协议 (SMTP) 虚拟服务器的每个实例的 msExchSmtpInboundCommandSupportOptions 属性值是否已配置为支持传入连接的默认扩展 SMTP 谓词。

下表中列出了这些扩展 SMTP 谓词。如果 Exchange Server 分析工具发现所列出的任何一个传入连接的默认扩展 SMTP 谓词不受支持，则 Exchange Server 分析工具将显示警告。

Exchange Server 2003 使用这些特定于 Exchange 的扩展 SMTP 谓词与组织中的其他 Exchange 服务器进行通信，比通过标准 SMTP 进行通信更有效。这些谓词被控制在元数据库和 Exchange Server 事件接收器中。在 Exchange Server 2003 中，DS2MB 进程通过从 Active Directory 复制值来负责更新元数据库中的值。禁用事件接收器可能会影响 Exchange Server 性能。

扩展的 SMTP 谓词 注释

8BITMIME

表示本地 SMTP 虚拟服务器支持八位 MIME 邮件。

BDAT、CHUNKING

是使用 DATA 命令的另一种方法。该方法使用两个参数。如果 SMTP 虚拟服务器对带有 CHUNKING 的 EHLO 关键字作出响应，则表示 SMTP 服务器支持 BDAT 命令并接受块区中的邮件。

  • 第一个参数表示二进制数据包的长度。因此 SMTP 主机不需要连续扫描数据的末尾。接收服务器计算邮件的字节。邮件大小等于 BDAT 命令发送的值时，服务器就假定已收到所有邮件数据。

  • 第二个参数表示数据包是否是当前传输中的最后一个数据包。第二个参数为可选。

BINARYMIME

表示 SMTP 虚拟服务器通过对 MAIL 命令使用带有 BINARYMIME 值的 BODY 参数，接受包含没有传输编码的二进制材料的邮件。如果 SMTP 服务器接受包含带有 BINARYMIME 的 BODY 参数的 MAIL 命令，则表示该服务器同意保留每个使用 BDAT 命令传递的八进制数中的所有字节。只能将 BINARYMIME SMTP 扩展与 CHUNKING 组合在一起使用。

DSN

ESMTP 命令，该命令启用在 Request for Comments (RFC) 1891 中定义的传递状态通知。

ENHANCEDSTATUSCODES

表示 SMTP 服务器提供增强的错误状态代码。除了初始问候语和任何对 HELO 或 EHLO 的响应外，所有 SMTP 状态响应的文本部分均以 RFC 1893 中定义的状态代码开头。

ETRN

由 SMTP 服务器发送的谓词，它请求本地虚拟服务器发送在 ETRN 命令中指定的域的队列中等候的所有电子邮件。

TURN

允许远程主机和本地主机互换角色，以相反的方向发送邮件而不必建立新的连接。

有关如何为这些谓词还原默认支持的详细信息，请参阅 Microsoft 知识库文章 257569"How to turn off ESMTP verbs in Exchange 2000 Server and in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569)。


Exchange 服务器未传播扩展动作
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取 Internet 信息服务 (IIS) 元数据库中的 SmtpInboundCommandSupportOptions 属性，以确定是否已将 Exchange Server 配置为支持扩展动作。如果 Exchange Server 分析工具发现 SmtpInboundCommandSupportOptions 设置未设置为 7697601，则显示警告。

Exchange 2000 Server 和 Exchange Server 2003 均需要扩展 SMTP 动作。IIS 元数据库中的值必须与 Active Directory® 目录服务中设置的值匹配。如果在混合模式环境中运行 Exchange Server，此值必须设置为 7697601。

警告：
在使用 ADSI（Active Directory 服务接口）Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。
还原 SmtpInboundCommandSupportOptions 的默认值

  1. 打开 ADSI Edit 并连接到域控制器。

  2. 打开 Configuration Container。

  3. 移动到以下位置：

    Configuration/Services/Microsoft Exchange/<Your Organization>/Administrative Groups/<Your Administrative Group>/Servers/<Your Exchange Server>/Protocols/SMTP/<Your Virtual Server>。

  4. 用鼠标右键单击虚拟服务器对象，再单击"Properties"。

  5. 对于 Select a property to view，选择 msExchSmtpInboundCommandsSupportOptions。

  6. 在 Edit Attribute 中，输入 7697601。

  7. 单击 Set，再单击 Apply，然后单击 OK。

  8. 关闭 ADSI Edit。


检测到冻结的队列
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-03

Microsoft® Exchange Server 分析工具查询 ExchangeLink Microsoft Windows® Management Instrumentation (WMI) 类，以确定服务器上简单邮件传输协议 (SMTP) 队列的 StateFrozen 关键字的值。

如果 Exchange Server 分析工具发现 Exchange 服务器上任何一个 SMTP 队列的 StateFrozen 关键字的值已设置为 True，则 Exchange Server 分析工具会显示错误。

已冻结的队列意味着该队列的传输会话已停止。已冻结的队列允许添加新邮件，但将阻止传出邮件。可以使用每个链接队列上的快捷菜单手动更改连接状态。使用"强制连接"命令将队列状态更改为"活动"后，可以立即启用从该队列发送邮件的连接。

有关受影响的特定 SMTP 队列和可能原因的信息，请参阅下列 Exchange Server 分析工具文章：

  • "等待目录查找的邮件"队列已冻结

  • "等待路由的邮件"队列已冻结

  • "暂缓提交的邮件"队列已冻结

  • "本地传递"队列已冻结

  • "远程传递"队列已冻结

有关如何解决 SMTP 队列问题的详细信息，请参阅以下 Exchange 资源：

  • "Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"排除邮件流和 SMTP 故障"

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=823489)

  • Miscrosoft 知识库文章 821877"Description of Fields on the SMTP and X.400 Queue Properties Tabs"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Miscrosoft 知识库文章 264054"XCON:Understanding Queue States in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


智能邮件筛选器的筛选器更新已可用
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange Server 中的以下路径下是否存在 MSExchange.UceContentFilter.dll：

<Exchange 服务器二进制文件的路径>\MSCFv2\MSExchange.UceContentFilter.dll

注意：
在此路径中，<Exchange 服务器二进制文件的路径> 是指 bin 文件夹的位置。

如果此位置中没有 MSExchange.UceContentFilter.dll，则 Exchange Server 分析工具将显示最佳做法建议。

建议在所有安装了智能邮件筛选器的 Exchange Server 上安装 Microsoft Exchange 智能邮件筛选器的筛选器更新。智能邮件筛选器的筛选器更新为智能邮件筛选器提供最新的智能邮件筛选器 SmartScreen™ 的筛选器更新。对 SmartScreen 筛选器的筛选器更新包含更新的垃圾邮件特征，提高了智能邮件筛选器阻止未经请求的商业电子邮件（也称为垃圾邮件）的能力。

注意：
在安装更新之前，必须安装智能邮件筛选器。若要安装智能邮件筛选器，所使用的帐户应具有本地管理权限并且属于应用了 Exchange 管理员角色的组的成员。

安装了智能邮件筛选器之后，请执行以下过程来安装更新。

获取并安装智能邮件筛选器更新

  1. 在 http://go.microsoft.com/fwlink/?LinkId=41026 处获取 Exchange 智能邮件筛选器的最新更新。

  2. 在 http://go.microsoft.com/fwlink/?LinkId=41027 处查看智能邮件筛选器更新的发行说明。

  3. 运行更新软件包并按照更新软件包安装向导中的说明操作。

有关详细信息，请参阅网站上的"Exchange Intelligent Message Filter"（英文）(http://go.microsoft.com/fwlink/?LinkId=21607)。


无层次限制检查已启用
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定目录中每个 Exchange Server 对象的 serialNumber 属性值。如果 Exchange Server 2003 服务器对象的 serialNumber 属性的字符串值包含 Service Pack 2，说明 Exchange 服务器正在运行 Exchange Server 2003 Service Pack 2 的预发行版本。

Exchange Server 分析工具还读取以下注册表项，以确定 RestrictionMethod 注册表值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

如果下列条件为真，则 Exchange Server 分析工具将显示非默认配置消息：

  • 安装了 Exchange Server 2003 Service Pack 2。

  • RestrictionMethod 注册表值存在并且配置的值为 2。

此配置表明此 Exchange 服务器上的传输组件在服务器检查限制时不会展开通讯组的成员身份。此配置使限制检查可以实现最高性能。

如果您确信 RestrictionMethod 注册表值存在并且设置不正确，可以使用以下步骤还原为默认配置。但是，因为在 Exchange Server 2003 Service Pack 2 中存在此注册表项可以为检查限制提供最佳的性能，建议您保留 RestrictionMethod 注册表值的当前设置。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\

  3. 在右侧窗格中，用鼠标右键单击 RestrictionMethod，再选择"属性"。

  4. 关闭注册表编辑器，并重新启动 IIS Admin 服务和 Microsoft Exchange 路由引擎服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 RestrictionMethod 注册表值的详细信息，请参阅 Microsoft 知识库文章 895407"In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。


找到"主机"记录但找不到"MX"记录
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具查询它所使用的域名系统 (DNS) 服务器，以查找接收 Exchange 邮件的远程域的邮件交换器 (MX) 记录。Exchange Server 分析工具随后执行 DNS 查找，以检索远程域的主机 (A) 记录。

如果 Exchange Server 分析工具的 DNS 查找操作没有返回远程域的 MX 记录，但随后却检索到了同一远程域的主机 (A) 记录，则 Exchange Server 分析工具将显示警告。

在这种情况下，在检索 MX 记录失败后，Exchange Server 会尝试向主机 (A) 记录所指向的服务器发送邮件。这些主机 (A) 记录应指向正确的邮件服务器，这一点非常重要。

一些域也许会将其主机 (A) 记录配置为指向 Internet 服务提供商 (ISP)，虽然它可能具有有效的邮件服务器，但可能不是预期收件人的权威邮件服务器。在此情况下，邮件将受到拒绝。

如果 DNS 服务器停机或由于网络故障或其他原因而不可访问，则 MX 记录的 DNS 查找会失败。

验证 DNS 服务器是否联机以及 MX 记录是否存在

  1. 通过执行下列一项或多项检查来验证 DNS 服务器是否正在运行：

    • 从 DNS 服务器上的 DNS 管理程序中查看 DNS 服务器的状态。

    • 重新启动 DNS 服务器。有关详细信息，请参阅"Start, stop, pause, or restart a DNS server"（英文）(http://go.microsoft.com/fwlink/?LinkId=62999)。

    • 使用 nslookup 命令验证 DNS 服务器是否响应。有关详细信息，请参阅"Verify DNS server responsiveness using the nslookup command"（英文）(http://go.microsoft.com/fwlink/?LinkId=63000) 中的说明。

  2. 使用 nslookup 来验证是否正确配置了 MX 记录。有关详细信息，请参阅"Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"验证 DNS 设计和配置"部分的"如何使用 Nslookup 来验证 MX 记录配置"。

详细信息

  • 有关 Exchange Server 2003 如何使用 DNS 解析外部 IP 地址的信息，请参阅"Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"Exchange Server 2003 的传输依赖性"。

  • 有关 DNS 名称解析的信息，请参阅 Microsoft 知识库文章 322856"如何配置 DNS 以用于 Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)。

  • 有关如何解决 DNS 问题的信息，请参阅"Troubleshooting DNS"（英文）(http://go.microsoft.com/fwlink/?LinkId=63003)。


已手动添加并配置 IIS PoolThreadLimit 注册表值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取下列注册表项，以确定 Internet 信息服务 (IIS) 池线程的最大数目是否已从默认值修改为其他值：

HKEY_LOCAL_MACHINE\ System\CurrentControlSet\Services\Inetinfo\Parameters\PoolThreadLimit

如果 Exchange Server 分析工具发现 PoolThreadLimit 已存在，并被配置为其他值，则会显示非默认配置消息。

PoolThreadLimit 注册表值指定可以在 Inetinfo.exe 进程（用于控制可以与 IIS 建立的最大同时连接数）中创建的最大输入/输出 (I/O) 工作线程数。每个池线程都会侦听网络请求，并通过发回静态文件，或者通过将请求传递给 ISAPI 扩展 DLL（例如 ASP.DLL）或公共网关接口 (CGI) 应用程序，来并处理这些请求。如果 ISAPI 扩展同步处理请求，并且处理请求需要很长时间，那么，它将占用工作线程，使得更少的工作线程留给 IIS 来处理其他请求。因此，编写得很好的 ISAPI 扩展（例如，ASP）会实现它们自己的线程池，并将请求放在队列中，然后以与其自己的线程异步的方式来处理这些请求，因此不会占用 IIS 工作线程。

默认情况下，IIS 将 PoolThreadLimit 设置为：

2 * 计算机中具有的 RAM 的 MB 数

如果该值大于 256，将固定于 256。默认情况下，该注册表值不存在。如果该值出现在注册表中，它将覆盖 IIS 的默认计算结果。

通常，如果发现 256 个线程的默认限制不够，则说明可能编写的 ISAPI 扩展效率不高，占用了 IIS 工作线程。256 是很多同时激活的线程数，并将在同步和上下文切换中导致极大的开销。

PoolThreadLimit 注册表值是包括所有 IIS 工作线程（包括 HTTP、FTP、NNTP 和 SMTP 服务）的硬限制。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，例如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

  3. 检查、删除或修改 PoolThreadLimit 值。

  4. 关闭注册表编辑器，并重新启动 IIS Admin 服务，以使更改生效。

在编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


传入邮件和传出邮件的大小限制
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-12-01

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定传出邮件大小限制的属性 submissionContLength 是否不同于传入邮件大小限制的属性 delivContLength。如果 Exchange Server 分析工具发现传出邮件大小限制和传入邮件大小限制不同，Exchange Server 分析工具将显示建议消息。

建议将传出邮件大小限制和传入邮件大小限制设置为相同的值，以保证邮件限制的一致性。

更改 Exchange 2000 Server 和 Exchange Server 2003 的传出邮件大小限制

  1. 启动 Exchange 系统管理器。

  2. 在左侧窗格中，展开"全局设置"。

  3. 右键单击"邮件传递"，再单击"属性"。

  4. 在"默认值"选项卡的"发送邮件大小"下，单击"最大值 (KB)"，再键入一个数字。
设置 Exchange Server 2007 的传出邮件大小限制

  1. 在 Exchange 命令行管理程序中，运行以下命令，其中 <大小> 将输入默认值"无限制"或输入 0 到 2147483647 字节范围内以 B（字节）、KB（千字节）或 MB（兆字节）为单位的大小。
复制代码
Set-TransportConfig -MaxSendSize <size>

例如，若要将 Exchange 组织中用户可以发送的最大邮件大小设置为 10 MB，应输入：

复制代码
Set-TransportConfig -MaxSendSize 10MB

若要将 Exchange 组织中用户可以发送的最大邮件大小设置为默认值"无限制"，应输入：

复制代码
Set-TransportConfig -MaxSendSize unlimited
 更改传入邮件大小限制

  1. 启动 Exchange 系统管理器。

  2. 在左侧窗格中，展开"全局设置"。

  3. 右键单击"邮件传递"，再单击"属性"。

  4. 在"默认值"选项卡的"接收邮件大小"下，单击"最大值 (KB)"，再键入一个数字。
设置 Exchange Server 2007 的传入邮件大小限制

  1. 在 Exchange 命令行管理程序中，运行以下命令，其中 <大小> 将输入默认值"无限制"或输入 0 到 2147483647 字节范围内的以 B（字节）、KB（千字节）或 MB（兆字节）为单位的大小。
复制代码
Set-TransportConfig -MaxReceiveSize <size>

例如，若要将 Exchange 组织中收件人可以接收的最大邮件大小设置为 10 MB，您应该输入：

复制代码
Set-TransportConfig -MaxReceiveSize 10MB

若要将 Exchange 组织中收件人可以接收的最大邮件大小设置为默认值"无限制"，您应该输入：

复制代码
Set-TransportConfig -MaxReceiveSize unlimited

有关如何在 Exchange 2000 Server 和 Exchange Server 2003 中设置邮件的大小限制的详细信息，请参阅 Microsoft 知识库文章 322679"为邮件设置大小限制"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679)。

有关 Exchange Server 2007 的 TransportConfig cmdlet 的详细信息，请参阅 Exchange Server 2007 技术参考中的"Set-TransportConfig"(http://go.microsoft.com/fwlink/?LinkId=79237)。


智能邮件筛选器自定义响应存在
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具将读取以下注册表项，以确定是否存在 CustomRejectResponse 注册表值：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

如果符合下列条件，Exchange Server 分析工具将显示非默认配置消息：

  • 存在 CustomRejectResponse 值。

  • 该值为有效字符串。

    注意：
    响应字符串值必须以 550 5.7.1 开头，才能被识别为有效。

不需要执行任何补救操作。

在 Exchange Server 2003 Service Pack 2 (SP2) 中，智能邮件筛选功能是在安装 SP2 时安装的，且安装后即可用。Exchange Server 2003 SP2 允许自定义服务器响应字符串，该字符串生成后附加到退回给发件人的未送达报告 (NDR)。可将默认响应"550 5.7.1 未执行请求的操作：邮件被拒绝"更改为向被阻止的合法用户提供有意义的解释，指出其邮件被阻止的原因。该解释可帮助减少误报调查，降低与反垃圾邮件处理相关的支持费用。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
更改自定义响应字符串

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\Software\Microsoft\Exchange\ContentFilter

  3. 在右侧的任务窗格中，用鼠标右键单击 CustomRejectResponse 值，并选择"修改"。

  4. 输入要用作自定义响应的字符串值，该字符串应以 550 5.7.1 开头。例如，可以输入 550 5.7.1 Domain not an allowed sender，将字符串设置为要附加至 NDR 的有效字符串。

  5. 保存更改，退出注册表编辑器，并重新启动 SMTP 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关智能邮件筛选的详细信息，请访问 Exchange 智能邮件筛选器网站 (http://go.microsoft.com/fwlink/?LinkId=21607)。

有关如何执行智能邮件筛选任务的详细信息，请参阅 Exchange Server 2003 SP2 联机帮助中的"配置智能邮件筛选"。

有关 Exchange Server 2003 SP2 的详细信息，请参阅 Exchange Server 2003 Service Pack 2 网站 (http://go.microsoft.com/fwlink/?LinkId=52073)。


智能邮件筛选器自定义字列表存在
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 CIM_Datafile Windows® Management Instrumentation (WMI) 类，以确定 Exchange 服务器上是否存在 MSExchange.UCEContentFilter.xml 文件。如果 Exchange Server 分析工具发现 Exchange 服务器上存在 MSExchange.UCEContentFilter.xml 文件，则 Exchange Server 分析工具将显示非默认配置信息。不需要执行任何补救操作。

MSExchange.UCEContentFilter.xml 文件是 Exchange Server 2003 Service Pack 2 (SP2) 智能邮件筛选器中自定义权重功能的一个组件。

SP2 智能邮件过滤器的自定义权重功能，允许管理员根据电子邮件正文、标题或者两者内部的语句，自定义智能邮件筛选器的行为。没有与自定义权重功能相关的用户界面。通过在初始化时被智能邮件筛选器读取的 XML 配置文件 (MSExchange.UCEContentFilter.xml) 可以自定义权重，一旦配置文件更改，将重新加载权重。如果启动智能邮件筛选器时不存在 MSExchange.UCEContentFilter.xml 文件，则必须重新启动 SMTP 服务。MSExchange.UceContentFilter.xml 自定义权重文件应该与 MSExchange.UceContentFilter.dll 和 .dat 文件位于同一目录下。

有关自定义权重文件的详细信息，请参阅 Exchange Server 2003 Service Pack 2 发行说明。Exchange Server 2003 Service Pack 2 发行说明既可通过 SP2 的 CD 文件获得，也可通过访问 Exchange Server 2003 Service Pack 2 发行说明网站 (http://go.microsoft.com/fwlink/?LinkId=52072)获得。

有关 Exchange Server 2003 SP2 的详细信息，请参阅 Exchange Server 2003 Service Pack 2 网站 (http://go.microsoft.com/fwlink/?LinkId=52073)。


智能邮件筛选器自定义响应无效
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否存在 CustomRejectResponse 注册表值：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

如果存在下列条件，则 Exchange Server 分析工具将显示警告：

  • 存在 CustomRejectResponse 值。

  • 该字符串值不是以 550 5.7.1 开头。

    注意：
    响应字符串值必须以 550 5.7.1 开头，才能被识别为有效。

Exchange Server 2003 Service Pack 2 (SP2) 允许自定义服务器响应字符串，该字符串生成后附加到退回给发件人的未送达报告 (NDR)。可将默认响应"550 5.7.1 未执行请求的操作：邮件被拒绝"更改为向被阻止的合法用户提供有意义的解释，指出其邮件被阻止的原因。该解释可帮助减少误报调查，降低与反垃圾邮件处理相关的支持费用。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\Software\Microsoft\Exchange\ContentFilter

  3. 在右侧的任务窗格中，用鼠标右键单击 CustomRejectResponse 值，并选择"修改"。

  4. 输入要用作自定义响应的字符串值，该字符串应以 550 5.7.1 开头。例如，可以输入 550 5.7.1 Domain not an allowed sender，将字符串设置为要附加至 NDR 的有效字符串。

  5. 保存更改，退出注册表编辑器，并重新启动 SMTP 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关智能邮件筛选的详细信息，请访问 Exchange 智能邮件筛选器网站 (http://go.microsoft.com/fwlink/?LinkId=21607)。

有关如何执行智能邮件筛选任务的详细信息，请参阅 Exchange Server 2003 SP2 联机帮助中的"配置智能邮件筛选"。


在邮箱服务器上启用了智能邮件筛选器
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定在服务器上是否已安装并启用了 Microsoft Exchange 智能邮件筛选器：

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

Exchange Server 分析工具读取 ContentFilterBindings 注册表项中的 ContentFilter 值，以确定在服务器上是否已安装并启用了智能邮件筛选器。

然后，Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 Exchange Server 对象的 msExchAuthenticationFlags 属性的值。msExchAuthenticationFlags 属性代表服务器上允许的身份验证类型。如果符合以下条件，则 Exchange Server 分析工具将显示警告消息：

  • msExchAuthenticationFlags 属性上的身份验证已配置为允许对服务器进行匿名访问。

  • 服务器上还驻留邮箱。

智能邮件筛选器识别很可能是未经请求的商业电子邮件 (UCE) 的邮件。如果在网关上使用非 Microsoft 的电子邮件服务器，那么必须在 Exchange 网关服务器上或 Exchange 桥头服务器上部署智能邮件筛选器，才能有效地筛选 UCE。这些网关服务器接受传入的 Internet 电子邮件并将这些邮件转发到相应的邮箱服务器。通常，网关服务器上不驻留邮箱。

此外，在 Exchange 网关服务器上，必须为每个接受 Internet 电子邮件的 SMTP 虚拟服务器启用智能邮件筛选器。

重要信息：
不要在 Internet 网关 SMTP 虚拟服务器上禁用匿名访问。这些从 Internet 接受邮件的 SMTP 虚拟服务器必须允许匿名访问。

若要筛选 UCE，可以对智能邮件筛选器进行配置，方法是，为分配给网关和 Exchange 邮箱存储的传入邮件的 SCL（垃圾邮件信任级别）分级设置阈值。智能邮件筛选器评估每封传入邮件，并根据邮件属于 UCE 的可能性为邮件分配 SCL 分级。Exchange 邮箱服务器使用为邮箱存储指定的 SCL 阈值和设置确定将邮件传递到用户的收件箱中还是用户的垃圾电子邮件文件夹中。

重要信息：
智能邮件筛选器不必安装在 Exchange 邮箱服务器上。如果在网关 SMTP 虚拟服务器上安装并启用了智能邮件筛选器，Exchange 邮箱服务器会收到每封传入邮件及其 SCL 分级，并采取相应的措施。

有关信息，请参阅网站上的"Exchange Intelligent Message Filter"（英文）(http://go.microsoft.com/fwlink/?LinkId=21607)。有关对 Exchange Server 2003 组织进行配置以便收发 Internet 邮件的详细信息，请参阅"Exchange Server 2003 传输和路由指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=c092b7a7-9034-4401-949c-b29d47131622&displaylang=zh-cn)。


在服务器上未启用智能邮件筛选器
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定服务器上是否已安装并启用 Microsoft Exchange 智能邮件筛选器：

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

如果 Exchange Server 分析工具发现 ContentFilter 注册表项中存在 ContentFilterBindings 值项，但是未配置 ContentFilterBindings 值，Exchange Server 分析工具将显示警告消息。

注意：
如果在 ContentFilter 注册表项中存在 ContentFilterBindings 值项，但是未配置 ContentFilterBindings 值，表明服务器上未启用智能邮件筛选器。
重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

Microsoft Exchange 智能邮件筛选器识别很可能是未经请求的商业电子邮件 (UCE) 的邮件。在接受传入电子邮件的 Exchange 网关服务器或 Exchange 桥头服务器上部署了智能邮件筛选器之后，必须在每个接受 Internet 电子邮件的 SMTP 虚拟服务器上启用智能邮件筛选器。

查看 ContentFilter 注册表项

  1. 在注册表编辑器 (regedit) 的详细信息窗格中，用鼠标右键单击 ContentFilter，以查看 ContentFilterBindings 的设置。

    注意：
    如果尚未在 SMTP 虚拟服务器上配置 Exchange 智能邮件筛选器，ContentFilterBindings 值将为 null。

    编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

建议在所有安装了智能邮件筛选器的 Exchange 服务器上启用 Exchange 智能邮件筛选器。若要在 SMTP 虚拟服务器上启用智能邮件筛选器，请执行下列步骤。在启用了智能邮件筛选器之后，可以在注册表中验证 ContentFilter 注册表项的值。

启用智能邮件筛选器

  1. 单击"开始"，指向"所有程序"，指向"Microsoft Exchange"，再单击"系统管理器"。

  2. 在 Exchange 系统管理器中，依次展开"服务器"、服务器名称、"协议"、SMTP，再用鼠标右键单击"智能邮件筛选"，然后单击"属性"。

  3. 在"常规"选项卡的"对下列虚拟服务器的 IP 地址应用智能邮件筛选"下，单击每个要启用智能邮件筛选器的 SMTP 虚拟服务器旁边的复选框。

    "智能邮件筛选属性"对话框

有关信息，请参阅网站上的"Exchange Intelligent Message Filter"（英文）(http://go.microsoft.com/fwlink/?LinkId=21607)。


指定收件人更新服务的服务器无效
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-07-30

Microsoft Exchange 分析工具查询 Active Directory 目录服务，以确定该目录中每个"收件人更新服务"对象的 msExchAddressListServiceLink 属性值。msExchAddressListServiceLink 属性是从地址列表服务到运行收件人更新服务 (RUS) 的 Exchange Server 计算机的链接。

Exchange 分析工具查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定标识的 Exchange Server 计算机上通讯簿视图和动态组服务 (abv_dg.dll) 的 Version 关键字的值。Version WMI 关键字代表此文件的内部版本号。

如果 Exchange 分析工具发现在任意一台标识的计算机上 abv_dg.dll 文件的内部版本号以 08 开始，就会显示错误。

此错误表明，指定为 RUS 服务器的计算机正在运行 Microsoft Exchange Server 2007。

收件人更新服务是在 Exchange 2000 Server 和 Exchange Server 2003 中找到的 Exchange System Attendant 服务中的一个组件。用于 Exchange 2000 和 Exchange 2003 的收件人更新服务在 Active Directory 中创建并维护 Exchange 特定的属性值。该功能在 Exchange 2007 中由收件人创建过程进行处理，并且如果正在 Exchange 2007 服务器上运行，那么旧版收件人更新服务将不会进行更新。

若要解决该问题，则指定驻留收件人更新服务的 Exchange 2000 Server 或 Exchange Server 2003。

更正此错误

  1. 打开 Exchange 系统管理器。

  2. 在"收件人"下，单击"收件人更新服务"。在右侧导航窗格中，右键单击相应的收件人更新服务实例，再单击"属性"。

  3. 在"常规"选项卡上的 Exchange Server 中，单击"浏览"，然后指定要运行该 RUS 实例的新 Exchange 2000 Server 或 Exchange Server 2003 服务器。

  4. 单击"确定"，然后再单击"确定"，以使更改生效。


正在进行大量的分类
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-08-21

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎从 SMTP Server 性能对象的 Cat:Categorizations in progress 性能计数器收集数据以分析性能数据。

Cat:Categorizations in progress 性能计数器显示正在进行的分类数。

对于此查询，Exchange Server 分析工具将在 2 分钟的时段内，每隔 6 秒检索一个样本。Exchange Server 分析工具将报告收集间隔期间性能计数器的平均值。

如果 Exchange Server 分析工具确定采样期间正在进行的分类的平均数超过 800，则将显示错误。

分类程序执行下列核心操作：

  • 解析并验证所有收件人。

  • 确定所有收件人的限制。

  • 展开通讯组列表（如果需要）。

  • 确定邮件用于本地传递还是远程传递。

此错误可能指示服务器遇到了异常的负载，或者存在性能相关的问题。

若要解决此错误，请执行下列操作：

  • 确定分类程序超载是预期中的，还是由典型负载导致的。如果分类程序超载是由预期负载导致的，请查看下列 Microsoft TechNet 文章中的 Exchange 性能指导。

    • "Troubleshooting Exchange Server 2003 Performance"（排除 Exchange Server 2003 性能故障）(http://go.microsoft.com/fwlink/?LinkId=47588)。

    • "Exchange Server 2003 性能和可伸缩性指南"(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 如果分类程序超载不是由预期负载导致的，请检查病毒发作或垃圾邮件是否导致产生负载。

邮件分类程序性能计数器是专门针对每个简单邮件传输协议 (SMTP) 虚拟服务器实例发布的。有关与邮件分类程序相关的可用性能计数器的列表，请参阅 Microsoft 知识库文章 231734"XCON:Performance Monitor Counters for Message Categorizer"（邮件分类程序的性能监视计数器）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)。


大量的邮箱设置了通讯组传递限制
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-08-21

Microsoft® Exchange Server 分析工具将查询 Active Directory® 目录服务中找到的所有域内的每个用户对象的下列属性，以确定是否为域中的任何邮箱设置了基于通讯组成员身份的传递限制：

dLMemDefault | 控制在默认情况下是接受还是拒绝邮件。如果设置为默认设置 1，则接受来自任何用户的邮件。
dLMemRejectPerms | 包含通讯组列表 (DL) 的 DN，这些列表的成员不可以向此收件人发送数据。
dLMemSubmitPerms | 包含通讯组列表 (DL) 的 DN，这些列表的成员可以向此收件人发送数据。

如果 Exchange Server 分析工具确定域中有 500 多个邮箱设置了基于通讯组成员身份的传递限制，则它将显示错误。

此错误指示，如果许多邮箱设置了基于通讯组成员身份的传递限制，则可能会影响 Exchange 邮件流性能。

默认情况下，分类程序将以递归方式展开通讯组，并检查通过系统的每封邮件的限制。

如果邮件分类程序将邮件发送到接受或拒绝来自通讯组的邮件的用户，则必须展开通讯组的成员身份，获取成员 DN 的完整列表，然后将此 DN 列表与发件人 DN 列表进行比较。如果两个列表上都显示了某个 DN，则会执行访问操作或拒绝操作。如果某个通讯组嵌套在另一个通讯组中，则也会展开嵌套的通讯组。

若要解决此错误，请执行下列操作：

  • 检查已设置通讯组传递限制的那些用户，然后删除不必要的限制。

  • 配置各个邮箱，而不是配置传递限制的通讯组，请参考 Microsoft 知识库文章 812298"Mail delivery is slow after you configure delivery restrictions that are based on a distribution list"（配置基于通讯组列表的传递限制后，邮件传递的速度将会减慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。

  • 对于运行 Exchange Server 2003 Service Pack 2 (SP2) 或更高版本的服务器，请考虑实现非分层限制检查。对于运行早于 Exchange Server 2003 SP2 的 Exchange 版本的服务器，请考虑升级为 Exchange Server 2003 SP2。

详细信息

有关非分层限制检查的详细信息，请参阅考虑非层次限制检查

有关通讯组限制对 Exchange Server 邮件流的影响的详细信息，请参阅下列 Microsoft 知识库文章：

  • 895407"In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"（在 Exchange Server 2003 中，配置基于通讯组的传递限制后，向本地邮箱和外部邮箱传递邮件的速度比预期速度要慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 839949"Troubleshooting mail transport and distribution groups in Exchange 2000 Server and in Exchange Server 2003"（排除 Exchange 2000 Server 和 Exchange Server 2003 中的邮件传输和通讯组问题）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。

  • 812298"Mail delivery is slow after you configure delivery restrictions that are based on a distribution list"（配置基于通讯组列表的传递限制后，邮件传递的速度将会减慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。


在混合模式的组织中启用最低成本路由
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定在混合模式环境中运行 Exchange Server 版本 5.5 的服务器上是否启用了最低成本路由。如果符合以下条件，Exchange Server 分析工具将显示警告：

  • 启用了最低成本路由。

  • 您的组织在包含 Exchange Server 5.5 的混合模式环境中运行 Exchange Server 2003。

如果在混合模式环境中启用了最低成本路由，可能会出现邮件循环。Exchange Server 2003 使用链接状态路由。因此，Exchange Server 2003 在检测到链接中断后，会将邮件重新路由到其他服务器上。如果 Exchange Server 5.5 服务器在 Message Transfer Agent 属性页中使用 Only use least cost routes 选项，确定的最佳路由通常为返回刚发送邮件的 Exchange Server 2003 服务器。邮件发送回 Exchange Server 2003 服务器时，路由即变成了循环。

在任何同时运行 Exchange Server 5.5 和 Exchange Server 2003 的混合模式组织中，建议在所有运行 Exchange Server 5.5 的服务器上禁用最低成本路由选项。

在 Exchange Server 5.5 中禁用最低成本路由

  1. 在 Microsoft Exchange Server Administrator 程序中，依次展开"组织"容器、"站点"容器、"配置"容器、"服务器"容器，再单击您的服务器对象。

  2. 在右侧窗格中，单击"邮件传输代理"对象。

  3. 单击"文件"菜单，再单击"属性"。

  4. 在"邮件传输代理属性"对话框中的"常规"选项卡上，清除"只使用最低成本路由"。

  5. 单击"确定"。


SMTP 的侦听端口可能已从默认值 25 更改为其他值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定为 msExchServerBindings 属性配置的值是否已从默认值 25 更改为其他值。默认情况下，msExchServerBindings 属性配置为 TCP 端口 25。如果 Exchange Server 分析工具发现该属性的值不是 25，则会显示非默认配置消息。

msExchServerBindings 属性代表该简单邮件传输协议 (SMTP) 服务器用来侦听入站连接的 TCP 端口。SMTP 虚拟服务器可以配置为侦听一个或多个 TCP 端口。默认情况下，所有 SMTP 虚拟服务器都配置为侦听默认 SMTP 端口，即 TCP 端口 25。如果 SMTP 侦听端口已从默认值修改为其他值，并且在其侦听端口列表中不再包括 TCP 端口 25，则邮件流将中断。

如果内部邮件基础结构的余下部分也相应地修改，则更改 SMTP 侦听端口是可接受的。但通常情况下，备用端口不能用于直接从 Internet 接收邮件的 SMTP 虚拟服务器，因为 Internet 上的 SMTP 服务器通过端口 25 发送邮件。

注意，Exchange Server 分析工具查看 Exchange SMTP 协议虚拟服务器的值。此 SMTP 协议虚拟服务器可能是直接从 Internet 接收邮件的 SMTP 服务器，也可能不是。一些防病毒产品和防垃圾邮件产品设计为通过端口 25 接收来自 Internet 的 SMTP 邮件，而通过另一个端口将邮件重定向到 Exchange SMTP 虚拟服务器。在这种情况下，Exchange SMTP 虚拟服务器侦听 25 以外的端口是一种可接受的配置。

查看或修改 SMTP 虚拟服务器侦听端口

  1. 在 Exchange 系统管理器中，依次展开"服务器"、Exchange 服务器、"协议"、"SMTP"。

  2. 用鼠标右键单击 SMTP 虚拟服务器（例如，默认 SMTP 虚拟服务器），再单击"属性"。

  3. 选择"常规"选项卡，再单击"高级"。

  4. 将显示 IP 地址和端口列表。

    • 若要更改现有端口，请选择 IP 地址，再单击"编辑"。将 TCP 端口字段更改为 25。

    • 若要添加端口 25 将其作为附加侦听端口，请单击"添加"，并添加新的 IP 地址/端口组合。如果要使用连接筛选、发件人筛选或收件人筛选，请确保选择适当的复选框。

  5. 单击"确定"保存更改，再单击"确定"退出"高级"对话框。单击"确定"关闭 SMTP 虚拟服务器的"属性"对话框。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列 Microsoft 知识库文章：

  • 266686"XCON:如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)

  • 268163"XCON:How to Configure a SMTP Virtual Server Part 2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


"本地传递"队列已冻结
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-03

Microsoft® Exchange Server 分析工具查询 ExchangeLink Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP)"本地传递"队列的 StateFrozen 关键字的值。

如果 Exchange Server 分析工具发现 Exchange 服务器上"本地传递"队列的 StateFrozen 关键字的值已设置为 True，则 Exchange Server 分析工具会显示错误。

已冻结的队列意味着该队列的传输会话已停止。已冻结的队列允许添加新邮件，但将阻止传出邮件。可以使用每个链接队列上的快捷菜单手动更改连接状态。使用"强制连接"命令将队列状态更改为"活动"后，可以立即启用从该队列发送邮件的连接。

"本地传递"队列包含在 Exchange 服务器上排队的等待向 Exchange Server 邮箱或公共文件夹存储进行本地传递的邮件。

如果 Exchange 服务器不接受本地传递的邮件，则邮件会在该队列中累积。邮件传递变慢或时断时续可能表示存在邮件循环或性能问题。

要解决此错误，应增加对 MSExchangeTransport 服务的诊断日志记录以收集有关分类程序组件的信息。

有关如何修改日志记录设置的详细信息，请参阅"Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 的"排除邮件流和 SMTP 故障"部分中的"如何修改 MSExchangeTransport 的日志记录设置"。

有关如何解决 SMTP 队列问题的详细信息，请参阅以下 Exchange 资源：

  • "Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"排除邮件流和 SMTP 故障"

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=823489)

  • Miscrosoft 知识库文章 821877"Description of Fields on the SMTP and X.400 Queue Properties Tabs"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Miscrosoft 知识库文章 264054"XCON:Understanding Queue States in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


"本地传递"队列处于重试状态
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-03

Microsoft® Exchange Server 分析工具查询 ExchangeLink Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP)"本地传递"队列的 StateRetry 关键字的值。

如果 Exchange Server 分析工具发现 Exchange 服务器上"本地传递"队列的 StateRetry 关键字的值已设置为 True，则 Exchange Server 分析工具会显示错误。

如果队列处于重试状态，则该状态表明以前尝试处理此队列中的邮件时，至少出现了一个错误。可以使用"强制连接"命令将重试状态或预定状态中的队列更改为活动。这会使队列处于活动中，就好像重试间隔已过或预定时间已到一样。但是，此方法可能不会始终有效。记住队列的属性可以表明队列处于重试状态的特定原因。

"本地传递"队列包含在 Exchange 服务器上排队的等待向 Exchange Server 邮箱或公共文件夹存储进行本地传递的邮件。

如果 Exchange 服务器不接受本地传递的邮件，则邮件会在该队列中累积。邮件传递变慢或时断时续可能表示存在邮件循环或性能问题。

要解决此错误，应增加对 MSExchangeTransport 服务的诊断日志记录以收集有关分类程序组件的信息。

有关如何修改日志记录设置的详细信息，请参阅"Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 的"排除邮件流和 SMTP 故障"部分中的"如何修改 MSExchangeTransport 的日志记录设置"。

有关如何解决 SMTP 队列问题的详细信息，请参阅以下 Exchange 资源：

  • "Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"排除邮件流和 SMTP 故障"

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=823489)

  • Miscrosoft 知识库文章 821877"Description of Fields on the SMTP and X.400 Queue Properties Tabs"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Miscrosoft 知识库文章 264054"XCON:Understanding Queue States in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


邮件接收失败
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具尝试向简单邮件传输协议 (SMTP) 域的邮局主管帐户或用户定义的帐户发送邮件，方法如下：

  • Exchange Server 分析工具打开与 SMTP 服务器的套接字连接。如果 Exchange Server 分析工具收到响应代码 220，则认为此步骤已成功完成。

  • Exchange Server 分析工具传输 EHLO SMTP 命令谓词。如果下列条件为真，则认为此步骤已成功完成：

    • Exchange Server 分析工具收到一系列响应代码 250。

    • 其中一个响应包括 250-X-LINK2STATE 和 250-XEXCH50。

  • Exchange Server 分析工具传输 MAIL FROM:ExMFA-MailAcceptTest@Fabrikam.com SMTP 命令谓词。如果 Exchange Server 分析工具收到响应代码 250，则认为此步骤已成功完成。

  • Exchange Server 分析工具传输 RCPT TO:Postmaster (or a user-defined account)@<domainname>.com SMTP 命令谓词。如果 Exchange Server 分析工具收到响应代码 250，则认为此步骤已成功完成。

  • Exchange Server 分析工具随以句点结尾的示例邮件正文一起传输 DATA SMTP 命令谓词。如果 Exchange Server 分析工具收到响应代码 250，则认为此步骤已成功完成。

如果 Exchange Server 分析工具无法完成所有步骤，则 Exchange Server 分析工具将显示错误。此错误表示可能存在一般性的邮件流问题。下列链接以您在排除故障时应使用的顺序列出，从服务器级别开始，一直到网络级别。

更正此错误

  1. 请参阅"Exchange Server 2003 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"排除路由故障"。

  2. 请参阅 Microsoft 知识库文章 324867"Support WebCast:Microsoft Exchange 2000 Server:Troubleshooting Mail Flow Problems (Revisited)"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324867)。

  3. 请参阅 Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  4. 请参阅 Microsoft 知识库文章 324759"Support WebCast:Microsoft Exchange 2000 Server:DNS Troubleshooting in Transports"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324759)。

有关 Exchange Server 中的邮局主管帐户的详细信息，请参阅下列 Microsoft 知识库文章：

  • 223860"XCON:SMTP Postmaster Mailbox Must Be Set Manually"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=223860)。

  • 313832"How To Set an SMTP Postmaster Account in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=313832)。


邮件接收失败，BDAT 命令
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-08-21

Microsoft® Exchange Server 分析工具会将 EHLO 扩展简单邮件传输协议 (ESMTP) 命令谓词发送到某台远程服务器的端口 25，并分析其响应，以确定该远程服务器是否支持 BDAT ESMTP 动作。

如果远程服务器答复 DBAT 命令谓词时做出的响应未指示不可检索错误，则 Exchange Server 分析工具会向远程服务器发送一封测试邮件，并分析其响应，以确定邮件传输是否成功。

如果 Exchange Server 分析工具没有收到预期的响应字符串"250"，则会显示错误。

Exchange Server 2003 使用这些特定于 Exchange 的扩展 SMTP 动作与组织中其他运行 Exchange Server 的服务器进行通信。与使用标准 SMTP 相比，使用特定于 Exchange 的扩展 SMTP 动作进行通信更为有效。如果禁用对 ESMTP 命令集的支持，Exchange Server 性能可能会受到影响。

BDAT ESMTP 命令谓词是 DATA 命令的备选项。如果 SMTP 虚拟服务器对带有 CHUNKING 的 EHLO 关键字作出响应，则表示 SMTP 服务器支持 BDAT 命令并接受块区中的邮件。这需要使用两个参数：

  • 第一个参数表示二进制数据包的长度。因此 SMTP 主机不需要连续扫描数据的末尾。接收服务器计算邮件的字节。邮件大小等于 BDAT 命令发送的值时，服务器就假定已收到所有邮件数据。

  • 第二个参数表示数据包是否是当前传输中的最后一个数据包。第二个参数是可选的。

此错误指示尽管远程服务器支持 BDAT ESMTP 命令谓词，但是后续的 BDAT 邮件接收测试已失败。

若要解决此错误，请检查邮件环境，以找出相关问题以及可能会阻止 BDAT 命令谓词的配置，例如：

  • 暂时性网络中断

  • SMTP 代理

  • 防火墙

  • 应用程序

有关如何为这些谓词删除或还原默认支持的详细信息，请参阅 Microsoft 知识库文章 257569"How to turn off ESMTP verbs in Exchange 2000 Server and in Exchange Server 2003"（如何在 Exchange 2000 Server 和 Exchange Server 2003 中禁用 ESMTP 动作）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569)。

有关 Exchange Server 使用 ESMTP 命令谓词的方式的详细信息，请参阅"Exchange Server 传输和路由指南"中的"How to Load Exchange SMTP Properly"（如何正确加载 Exchange SMTP）(http://go.microsoft.com/fwlink/?LinkID=71800)。


标识为通用目标的邮箱存储
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-10-04

Microsoft® Exchange Server 分析工具查询 Exchange_Queue Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP) 虚拟服务器的 SMTP 队列的下列属性值。

LinkId | 表示包含该队列的链接的标识符。
QueueId | 表示该队列的标识符。
QueueName | 表示该队列的名称。
VirtualMachine | 表示包含该队列的虚拟计算机的名称。
VirtualServerName | 表示该队列所在的虚拟服务器的名称。
MessageCount | 表示该队列中的邮件数。

Exchange Server 分析工具使用此处获取的信息来查询 Exchange_QueuedSMTPMessage WMI 类，以确定该队列中邮件的下列属性值。

Recipients | 表示邮件收件人。
Received | 表示邮件的接收时间戳。
MessageId | 表示队列中邮件的标识符。
StateRetry | 表示重新尝试传输未成功传递的邮件。

最后，Exchange Server 分析工具使用此处获取的数据查询 Active Directory® 目录服务，以确定每个 Recipient 对象的下列值。然后，Exchange Server 分析工具会确定该收件人是一位用户、一个通讯组、一个公用文件夹还是一个公用文件夹存储：

distinguishedName | 表示该对象的可分辨名称。
msExchHomeServerName | 表示收件人所驻留的服务器。
homeMDB | 表示收件人的邮箱存储。

如果 Exchange Server 分析工具确定队列中滞留的邮件中，至少有 25％（在 To: 字段或 Cc: 字段中）的收件人的邮箱驻留在同一邮箱存储上，则 Exchange Server 分析工具会显示警告。

如果 Exchange Server 分析工具确定队列中滞留的邮件中，至少有 50％（在 To: 字段或 Cc: 字段中）的收件人的邮箱驻留在同一邮箱存储上，则 Exchange Server 分析工具会显示错误。

此警告或错误意味着标识的邮箱存储是 SMTP 队列中滞留的邮件的通用目标。

要解决此问题，请按如下方式调查该邮箱存储，以查出可能导致发往其中的邮件排队的配置问题或其他问题：

  • 确保该存储对象的属性设置正确，且 Active Directory 中的值正确无误。

  • 查看该存储对象的 Active Directory 权限设置是否正确。

  • 如果该邮箱存储为某个特殊用户对象（即一个指定的日记收件人）的存储，请查看与此用户对象相关的服务或组件的配置是否正确。

  • 查找潜在的针对此存储收件人的未经请求的商业垃圾邮件 (UCE)（又称为垃圾邮件）或病毒攻击。

有关如何排除 SMTP 队列故障的详细信息，请参阅下列 Exchange 资源：

  • "Exchange Server Transport and Routing Guide"（Exchange Server 传输和路由指南）中的"Troubleshooting Mail Flow and SMTP"（排除邮件流和 SMTP 故障）(http://go.microsoft.com/fwlink/?LinkID=67875)。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)。


"未到达目的地的邮件"队列存放邮件
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-10-04

Microsoft® Exchange Server 分析工具查询 ExchangeLink Microsoft Windows?Management Instrumentation (WMI) 类，以确定服务器上简单邮件传输协议 (SMTP) 队列的 TypeCurrentlyUnreachable、LinkName 和 NumberofMessages 属性的值。

TypeCurrentlyUnreachable 属性为 True 时，指定链接（Exchange 队列）存放目前无法送达目标的邮件。

LinkName 属性指定链接的名称。

NumberOfMessages 属性指定等待通过链接传输的邮件数。

如果 Exchange Server 分析工具确定"未到达目的地的邮件" SMTP 队列包含邮件，则 Exchange Server 分析工具将显示错误。

此错误表示队列中存在无法送达预期目标服务器的邮件。例如，Exchange 无法确定最终目标的路由或连接器。或者，所有可用路由或连接器都已标记为关闭。

若要解决该问题，请采取下列步骤：

  • 确定"未到达目的地的邮件"队列中的邮件是否合法。

  • 查看由 Exchange Server 分析工具提供的错误指南和链接。

  • 遵循此主题后面的"有关详细信息"中的指导。

详细信息

有关如何排除 SMTP 队列故障的详细信息，请参阅下列 Exchange 资源：

  • "Exchange Server Transport and Routing Guide"（Exchange Server 传输和路由指南）中的"Troubleshooting Mail Flow and SMTP"（排除邮件流和 SMTP 故障）(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)。


"未到达目的地的邮件"队列已冻结
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-10-06

Microsoft® Exchange Server 分析工具查询 ExchangeLink Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP)"未到达目的地的邮件"队列的 StateFrozen 关键字的值。

如果 Exchange Server 分析工具发现 Exchange 服务器上"未到达目的地的邮件"队列的 StateFrozen 关键字的值已设置为 True，则 Exchange Server 分析工具会显示错误。

已冻结的队列意味着该队列的传输会话已停止。已冻结的队列允许添加新邮件，但将阻止传出邮件。

"未到达目的地邮件"队列包含不能到达预期目标服务器的邮件。例如，Exchange 无法确定最终目标的路由或连接器。或者，所有可用路由或连接器都已标记为关闭。如果以下任意条件为真，则邮件会在此队列中累积：

  • 没有路由用于邮件传递。

  • Exchange 连接器或远程传递队列不可用。

  • 当 Exchange 连接器或远程传递队列处于重试状态，并且不存在到此连接器或远程目标的可用备选路由时，新邮件将转移至此队列。

若要解决此错误，请使用每个链接队列上的快捷菜单手动更改连接状态。使用"强制连接"命令将队列状态更改为"活动"后，可以立即启用从该队列发送邮件的连接。如果此错误仍然存在，请提升队列引擎的诊断日志记录级别，如本主题后面的"有关详细信息"所述。

详细信息

有关如何修改日志记录设置的详细信息，请参阅"Exchange Server Transport and Routing Guide"（Exchange Server 传输和路由指南）的"Troubleshooting Mail Flow and SMTP"（排除邮件流和 SMTP 故障）部分中的"How to Modify Logging Settings for MSExchangeTransport"（如何修改 MSExchangeTransport 的日志记录设置）(http://go.microsoft.com/fwlink/?LinkId=47579)。

有关如何排除 SMTP 队列故障的详细信息，请参阅下列 Exchange 资源：

  • "Exchange Server Transport and Routing Guide"（Exchange Server 传输和路由指南）中的"Troubleshooting Mail Flow and SMTP"（排除邮件流和 SMTP 故障）(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)。

  • Microsoft 知识库文章 821877"描述 SMTP 和 X.400 队列属性选项卡上的字段"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)。

  • Microsoft 知识库文章 264054"XCON：了解 Exchange 2000 Server 中的队列状态"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


"未到达目的地的邮件"队列处于重试状态
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-10-06

Microsoft® Exchange Server 分析工具查询 ExchangeLink Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP)"未到达目的地的邮件"队列的 StateRetry 关键字的值。

如果 Exchange Server 分析工具发现 Exchange 服务器上"未到达目的地的邮件"队列的 StateRetry 关键字的值已设置为 True，则 Exchange Server 分析工具会显示错误。

如果队列处于重试状态，则该状态表明以前尝试处理此队列中的邮件时，至少出现了一个错误。

注意：
队列的属性可以表明队列处于重试状态的特定原因。

"未到达目的地邮件"队列包含不能到达预期目标服务器的邮件。例如，Exchange 无法确定最终目标的路由或连接器。或者，所有可用路由或连接器都已标记为关闭。如果以下任意条件为真，则邮件会在此队列中累积：

  • 没有路由用于邮件传递。

  • Exchange 连接器或远程传递队列不可用。

  • 当 Exchange 连接器或远程传递队列处于重试状态，并且不存在到此连接器或远程目标的可用备选路由时，新邮件将转移至此队列。

若要解决此错误，请使用"强制连接"命令将"重试"状态更改为"活动"。这会使队列处于活动中，就好像重试间隔已过。但是，此方法可能不会始终有效。如果此错误仍然存在，请提升队列引擎的诊断日志记录级别，如本主题后面的"有关详细信息"所述。

详细信息

有关如何修改日志记录设置的详细信息，请参阅"Exchange Server Transport and Routing Guide"（Exchange Server 传输和路由指南）的"Troubleshooting Mail Flow and SMTP"（排除邮件流和 SMTP 故障）部分中的"How to Modify Logging Settings for MSExchangeTransport"（如何修改 MSExchangeTransport 的日志记录设置）(http://go.microsoft.com/fwlink/?LinkId=47579)。

有关如何排除 SMTP 队列故障的详细信息，请参阅下列 Exchange 资源：

  • "Exchange Server Transport and Routing Guide"（Exchange Server 传输和路由指南）中的"Troubleshooting Mail Flow and SMTP"（排除邮件流和 SMTP 故障）(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)。

  • Microsoft 知识库文章 821877"描述 SMTP 和 X.400 队列属性选项卡上的字段"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)。

  • Microsoft 知识库文章 264054"XCON：了解 Exchange 2000 Server 中的队列状态"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


已设置通讯组传递限制的邮箱
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-08-21

Microsoft® Exchange Server 分析工具将查询 Active Directory® 目录服务中找到的所有域内的每个用户对象的下列属性，以确定是否为域中的任何邮箱设置了基于通讯组成员身份的传递限制：

dLMemDefault | 控制在默认情况下是接受还是拒绝邮件。如果设置为默认设置 1，则接受来自任何用户的邮件。
dLMemRejectPerms | 包含通讯组列表 (DL) 的 DN，这些列表的成员不可以向此收件人发送数据。
dLMemSubmitPerms | 包含通讯组列表 (DL) 的 DN，这些列表的成员可以向此收件人发送数据。

如果 Exchange Server 分析工具确定域中存在已设置基于通讯组成员身份的传递限制的邮箱，Exchange Server 分析工具将显示警告。

此警告指示基于通讯组成员身份的传递限制可能会影响 Exchange Server 邮件流性能。

默认情况下，分类程序将以递归方式展开通讯组，并检查通过系统传递的每封邮件的限制。

如果邮件分类程序将邮件发送到接受或拒绝来自通讯组的邮件的用户，则必须展开通讯组的成员身份，获取成员 DN 的完整列表，然后将此 DN 列表与发件人 DN 列表进行比较。如果两个列表上都显示了某个 DN，则会执行访问操作或拒绝操作。如果某个通讯组嵌套在另一个通讯组中，则也会展开嵌套的通讯组。

若要解决此警告，请执行下列操作：

  • 对那些设置了通讯组传递限制的用户进行检查，然后删除不必要的限制。

  • 有关只配置单个邮箱而不配置基于传递限制的通讯组的信息，请参考 Microsoft 知识库文章 812298"Mail delivery is slow after you configure delivery restrictions that are based on a distribution list"（配置基于通讯组列表的传递限制后，邮件传递的速度将会减慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。

  • 对于运行 Exchange Server 2003 Service Pack 2 (SP2) 或更高版本的服务器，请考虑实现非分层限制检查。对于运行早于 Exchange Server 2003 SP2 的 Exchange 版本的服务器，请考虑升级为 Exchange Server 2003 SP2。

详细信息

有关非分层限制检查的详细信息，请参阅考虑非层次限制检查。

有关通讯组限制对 Exchange Server 邮件流的影响的详细信息，请参阅下列 Microsoft 知识库文章：

  • 895407"In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"（在 Exchange Server 2003 中，配置基于通讯组的传递限制后，向本地邮箱和外部邮箱传递邮件的速度比预期速度要慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 839949"Troubleshooting mail transport and distribution groups in Exchange 2000 Server and in Exchange Server 2003"（排除 Exchange 2000 Server 和 Exchange Server 2003 中的邮件传输和通讯组问题）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。

  • 812298"Mail delivery is slow after you configure delivery restrictions that are based on a distribution list"（配置基于通讯组列表的传递限制后，邮件传递的速度将会减慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。


尚未设置最大传入邮件大小
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-01-05

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定位于以下位置的全局设置 delivContLength 属性值：

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

如果 Exchange Server 分析工具发现 delivContLength 属性的值小于 1，则显示错误。

该错误说明尚未设置最大传入邮件大小限制。基于您的组织的网络带宽和用户要求，您可能希望限制邮件大小。在 Exchange 2000 Server 和 Exchange Server 2007 中，没有默认的邮件大小限制。在 Exchange Server 2003 中，发送邮件和接收邮件的大小限制默认设置为 10,240 KB。此默认大小限制适用于新安装的 Exchange Server 2003 或者从 Exchange 2000 Server 升级的 Exchange Server 2003（在这两种情况下均未设置邮件大小限制）。

通过设置可防止用户发送和接收大型电子邮件的邮件大小限制，可以节约系统资源。这有助于限制网络通信量、节省磁盘空间并改善网络的总体性能。在 Exchange 2000 Server 和 Exchange Server 2003 中，可以使用"全局设置"的"邮件传递属性"中的"默认设置"选项卡来指定传入和传出邮件的邮件传递限制。若要再设置单个邮件的最大大小，请选择"最大值 (KB)"，然后在文本框中键入最大大小 (KB)。如果不想限制邮件的大小，请选择"无限制"。如果组织中的发件人试图向用户发送超过指定大小限制的邮件，则会收到 NDR。外部发件人可能收不到 NDR，具体取决于在"Internet 邮件格式"中配置的 NDR 设置。

对于 Exchange Server 2007，可以使用 Exchange 命令行管理程序为 Exchange 组织设置 TransportConfig MaxReceiveSize 参数。

我们建议您将最大邮件大小限制设置为不超过 10 MB。但是，对于通过 Exchange 组织发送的具有较大附件的邮件，如果需要为其设置更大的邮件大小限制，则可能需要将最大传入邮件大小限制增加到 30 MB。如果将邮件大小限制增加到 30 MB 以上，可能会造成网络性能下降，甚至导致系统更容易受到安全攻击。

为 Exchange 2000 Server 和 Exchange Server 2003 设置邮件大小限制

  1. 在 Exchange 系统管理器中，展开"全局设置"，右键单击"邮件传递"，再单击"属性"。

  2. 在"邮件传递属性"对话框的"默认设置"选项卡上，选择"接收邮件大小"下的"最大值"选项，并键入所需的大小限制。

为 Exchange Server 2007 设置邮件大小限制

  1. 在 Exchange 命令行管理程序中，运行以下命令，其中 <大小> 会输入默认值"无限制"或输入 0 至 2147483647 字节范围内以 B（字节）、KB（千字节）或 MB（兆字节）为单位的大小。
复制代码
Set-TransportConfig -MaxReceiveSize <size>

例如，若要将 Exchange 组织中的收件人可以接收的最大邮件大小设置为 10 MB，您应该输入：

复制代码
Set-TransportConfig -MaxReceiveSize 10MB

若要将 Exchange 组织中的收件人可以接收的最大邮件大小设置为默认值"无限制"，您应该输入：

复制代码
Set-TransportConfig -MaxReceiveSize unlimited
  • 有关如何为 Exchange 2000 Server 和 Exchange Server 2003 设置邮件大小限制的详细信息，请参阅 Microsoft 知识库文章"Set Size Limits for Messages"（设置邮件大小限制）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)。

  • 有关 Exchange Server 2007 的 TransportConfig cmdlet 的详细信息，请参阅 Exchange Server 2007 技术参考中的"Set-TransportConfig"(http://go.microsoft.com/fwlink/?LinkID=79237) 。

  • 有关 Internet 邮件格式的详细信息，请参阅"Exchange Server 2003 管理指南"中的"Configuring SMTP Policies to Control Outbound Mail Formatting and Automatic Responses"（配置 SMTP 策略以控制出站邮件格式和自动响应）(http://go.microsoft.com/fwlink/?LinkId=47617)。


最大传入邮件大小设置得太高 (>30MB)
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-02-27

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定位于以下位置的全局设置 delivContLength 属性值：

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

如果 Exchange Server 分析工具发现 delivContLength 属性值大于 30720，则显示错误。

该错误说明最大传入邮件大小限制的值已设置为大于 30 MB。在 Exchange 2000 Server 和 Exchange Server 2007 中，没有默认的邮件大小限制。在 Exchange Server 2003 中，发送邮件和接收邮件的大小限制默认设置为 10,240 KB。此默认大小限制适用于新安装的 Exchange Server 2003 或者从 Exchange2000 Server 升级的 Exchange Server 2003（在这两种情况下均未设置邮件大小限制）。

通过设置可防止用户发送和接收大型电子邮件的邮件大小限制，可以节约系统资源。这有助于限制网络通信量、节省磁盘空间并改善网络的总体性能。在 Exchange 2000 Server 和 Exchange Server 2003 中，可以使用"全局设置"的"邮件传递属性"中的"默认设置"选项卡来指定传入和传出邮件的邮件传递限制。若要设置单个邮件的最大大小，请选择"最大值 (KB)"，然后在文本框中键入最大大小 (KB)。如果不想限制邮件的大小，请选择"无限制"。如果组织中的发件人试图向用户发送超过指定大小限制的邮件，则会收到未送达报告 (NDR)。外部发件人可能收不到 NDR，具体取决于在"Internet 邮件格式"中配置的 NDR 设置。

对于 Exchange Server 2007，可以使用 Exchange 命令行管理程序为 Exchange 组织设置 TransportConfig MaxSendSize 参数。

我们建议您将最大邮件大小限制设置为不超过 30 MB。但是，对于通过 Exchange 组织发送的具有较大附件的邮件，如果需要为其设置更大的邮件大小限制，则可能需要将最大传入邮件大小限制增加到 30 MB 以上。如果将邮件大小限制增加到 30 MB 以上，可能会造成网络性能下降，甚至导致系统更容易受到安全攻击。

重要信息：
尽管看起来可能很类似，但是对于纯 Exchange 2000 Server/Exchange Server 2003 环境和纯 Exchange Server 2007 环境来说，下列设置的结果会截然不同。

在纯 Exchange 2000 Server/Exchange Server 2003 环境中，如果在某个已启用邮箱的用户的"全局设置"中将发送邮件大小和接收邮件大小的限制设置为值 0，将彻底取消邮件大小限制。

在纯 Exchange 2007 环境中，如果将 TransportConfig -MaxSendSize 和 TransportConfig -MaxreceiveSize 参数设置为值 0，将禁止发送任何大小的邮件。

为 Exchange 2000 Server 和 Exchange Server 2003 设置邮件大小限制

  1. 在 Exchange 系统管理器中，展开"全局设置"，右键单击"邮件传递"，再单击"属性"。

  2. 在"邮件传递属性"对话框的"默认设置"选项卡上，选择"接收邮件大小"下的"最大值"选项，并键入所需的大小限制。

为 Exchange Server 2007 设置邮件大小限制

  1. 在 Exchange 命令行管理程序中，运行以下命令，其中 <大小> 会输入默认值"无限制"或输入 0 至 2147483647 字节范围内以 B（字节）、KB（千字节）或 MB（兆字节）为单位的大小。
复制代码
Set-TransportConfig -MaxReceiveSize <size>

例如，若要将 Exchange 组织中的收件人可以接收的最大邮件大小设置为 10 MB，您应该输入：

复制代码
Set-TransportConfig -MaxReceiveSize 10MB

若要将 Exchange 组织中的收件人可以接收的最大邮件大小设置为默认值"无限制"，您应该输入：

复制代码
Set-TransportConfig -MaxReceiveSize unlimited
  • 有关如何为 Exchange 2000 Server 和 Exchange Server 2003 设置邮件大小限制的详细信息，请参阅 Microsoft 知识库文章 322679"Set Size Limits for Messages"（设置邮件大小限制）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)。

有关 Exchange Server 2007 的 TransportConfig cmdlet 的详细信息，请参阅 Exchange Server 2007 技术参考中的"Set-TransportConfig"。(http://go.microsoft.com/fwlink/?LinkID=79237)

  • 有关 Internet 邮件格式的详细信息，请参阅"Exchange Server 2003 管理指南"中的"Configuring SMTP Policies to Control Outbound Mail Formatting and Automatic Responses"（配置 SMTP 策略以控制出站邮件格式和自动响应）(http://go.microsoft.com/fwlink/?LinkId=47617)。


最大传入邮件大小也许设置得太低 (<1MB)
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-01-05

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定位于以下位置的全局设置 delivContLength 属性值：

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

如果 Exchange Server 分析工具发现 delivContLength 属性值小于 1024 但大于 0，则显示错误。

该错误说明最大传入邮件大小限制的值已设置为小于 1 MB。这样低的值可能使 Exchange Server 无法接受发送到组织的某些邮件。在 Exchange 2000 Server 和 Exchange Server 2007 中，没有默认的邮件大小限制。在 Exchange Server 2003 中，发送邮件和接收邮件的大小限制默认设置为 10,240 KB。此默认大小限制适用于新安装的 Exchange Server 2003 或者从 Exchange2000 Server 升级的 Exchange Server 2003（在这两种情况下均未设置邮件大小限制）。

通过设置可防止用户发送和接收大型电子邮件的邮件大小限制，可以节约系统资源。这有助于限制网络通信量、节省磁盘空间并改善网络的总体性能。在 Exchange 2000 Server 和 Exchange Server 2003 中，可以使用"全局设置"的"邮件传递属性"中的"默认设置"选项卡来指定传入和传出邮件的邮件传递限制。若要设置单个邮件的最大大小，请选择"最大值 (KB)"，然后在文本框中键入最大大小 (KB)。如果不想限制邮件的大小，请选择"无限制"。如果组织中的发件人试图向用户发送超过指定大小限制的邮件，则会收到 NDR。外部发件人可能收不到 NDR，具体取决于在"Internet 邮件格式"中配置的 NDR 设置。

对于 Exchange Server 2007，可以使用 Exchange 命令行管理程序为 Exchange 组织设置 TransportConfig MaxSendSize 参数。

我们建议您将最大邮件大小限制设置为不超过 10 MB。但是，对于通过 Exchange 组织发送的具有较大附件的邮件，如果需要为其设置更大的邮件大小限制，则可能需要将最大传入邮件大小限制增加到 30 MB。如果将邮件大小限制增加到 30 MB 以上，可能会造成网络性能下降，甚至导致系统更容易受到安全攻击。

为 Exchange 2000 Server 和 Exchange Server 2003 设置邮件大小限制

  1. 在 Exchange 系统管理器中，展开"全局设置"，右键单击"邮件传递"，再单击"属性"。

  2. 在"邮件传递属性"对话框的"默认设置"选项卡上，选择"接收邮件大小"下的"最大值"选项，并键入所需的大小限制。

为 Exchange Server 2007 设置邮件大小限制

  1. 在 Exchange 命令行管理程序中，运行以下命令，其中 <大小> 会输入默认值"无限制"或输入 0 至 2147483647 字节范围内以 B（字节）、KB（千字节）或 MB（兆字节）为单位的大小。
复制代码
Set-TransportConfig -MaxReceiveSize <size>

例如，若要将 Exchange 组织中的收件人可以接收的最大邮件大小设置为 10 MB，您应该输入：

复制代码
Set-TransportConfig -MaxReceiveSize 10MB

若要将 Exchange 组织中的收件人可以接收的最大邮件大小设置为默认值"无限制"，您应该输入：

复制代码
Set-TransportConfig -MaxReceiveSize unlimited
  • 有关如何为 Exchange 2000 Server 和 Exchange Server 2003 设置邮件大小限制的详细信息，请参阅 Microsoft 知识库文章 322679"Set Size Limits for Messages"（设置邮件大小限制）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)。

有关 Exchange Server 2007 的 TransportConfig cmdlet 的详细信息，请参阅 Exchange Server 2007 技术参考中的"Set-TransportConfig"(http://go.microsoft.com/fwlink/?LinkID=79237) 。

  • 有关 Internet 邮件格式的详细信息，请参阅"Exchange Server 2003 Administration Guide"（Exchange Server 2003 管理指南）中的"Configuring SMTP Policies to Control Outbound Mail Formatting and Automatic Responses"（配置 SMTP 策略以控制出站邮件格式和自动响应）(http://go.microsoft.com/fwlink/?LinkId=47617)。


MaxDSNSize 未设置
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定传递状态通知 (DSN) 邮件的最大大小是否已设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MaxDSNSize

Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定具有对象类 msExchExchangeServer 的所有对象的 serialNumber 属性值。如果字符串值包含"Version 5.5"，说明计算机运行的是 Microsoft Exchange Server 5.5。如果字符串值包含"Version 6.0"，说明计算机运行的是 Microsoft Exchange 2000 Server。如果字符串值包含"Version 6.5"，说明计算机运行的是 Microsoft Exchange Server 2003。

如果 Exchange Server 分析工具发现在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上不存在 MaxDSNSize 注册表值，则会显示警告。

MaxDSNSize 注册表值是 Exchange Server 中的一个可选值，它限制 DSN 的大小。此选项用于配置 Exchange 以删除无法送达的邮件的附件。如果添加此注册表值，建议使用 10240000 字节 (10 MB)。

注意：
MaxDSNSize 注册表值是在 Exchange 2000 Server 的 Service Pack 2 (SP2) 中引入的，因此要求 Exchange 的版本至少为 Exchange 2000 Server SP2 才能工作。此外，在 Exchange Server 2003 Service Pack 1 及更高版本中，默认情况下不存在 MaxDSNSize 注册表值，而使用 10 MB。如果需要，可以添加 MaxDSNSize 注册表值以覆盖此默认行为。

如果启用该选项，则可以节约服务器和网络资源。但是，实现这种剥离简单邮件传输协议 (SMTP) 附件的功能也存在缺陷。如果为了从未送达报告 (NDR) 中剥离附件而启用了该选项，则在预览窗格中显示通知时所需要的详细信息也会被剥离，并且邮件的原始发件人将无法使用"再次发送"选项。如果邮件的原始发件人试图从 NDR 使用"再次发送"选项，则邮件的原始发件人将收到下列错误消息："无法重新发送该邮件。未传递报告没有包括有关邮件原件的足够信息。要重新发送邮件，请在'已发送邮件'文件夹中打开该邮件，单击'动作'菜单，然后单击'重新发送该邮件'"。

但是，邮件的原始发件人无法重新发送邮件，甚至无法使用错误消息中提供的方法进行发送。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\SMTPSvc

  3. 用鼠标右键单击"SMTPSvc"，然后选择"新建"|"项"。将新建项命名为 Queuing，并将类保留为空白。

  4. 用鼠标右键单击"Queuing"，然后选择"新建"|"DWORD 值"。将新值命名为 MaxDSNSize。

  5. 在右侧窗格中，双击 MaxDSNSize 注册表值，在"数值数据"字段中输入所需的大小限制（字节）。由于大于该值而产生 NDR 的邮件不会返回附件或完整的邮件属性。

  6. 关闭注册表编辑器，然后重新启动 Simple Mail Transfer Protocol (SMTP) 服务，以使更改生效。

有关 MaxDSNSize 注册表设置的详细信息，请参阅下列 Microsoft 知识库文章：

  • 308303"XCON:Option to Strip Attachments for Messages That Generate an NDR"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=308303)

  • 323484"XCON:Exchange 2000 中的 multipart/report Internet 邮件格式说明"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=323484)


未设置最大传出邮件大小
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-12-04

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定位于下列位置的全局设置 submissionContLength 属性的值：

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

如果 Exchange Server 分析工具发现 submissionContLength 属性的值小于 1，则会显示错误。

此错误意味着未设置最大传出邮件大小限制。基于您的组织的网络带宽和用户要求，您可能希望限制邮件大小。在 Exchange 2000 Server 和 Exchange Server 2007 中，没有默认的邮件大小限制。在 Exchange Server 2003 中，发送邮件和接收邮件的大小限制默认设置为 10,240 KB。此默认大小限制适用于新安装的 Exchange Server 2003 或者从 Exchange2000 Server 升级的 Exchange Server 2003（在这两种情况下均未设置邮件大小限制）。

通过设置可防止用户发送和接收大型电子邮件的邮件大小限制，可以节约系统资源。这有助于限制网络通信量、节省磁盘空间并改善网络的总体性能。在 Exchange 2000 Server 和 Exchange Server 2003 中，可以使用"全局设置"的"邮件传递属性"中的"默认设置"选项卡来指定传入和传出邮件的邮件传递限制。若要设置单个邮件的最大大小，请选择"最大值 (KB)"，然后在文本框中键入最大大小 (KB)。如果不希望限制邮件大小，请选择"无限制"。如果组织中的发件人试图向用户发送超过指定大小限制的邮件，将会收到 NDR。外部发件人可能会或可能不会收到 NDR，这取决于您在"Internet 邮件格式"中配置的 NDR 设置。

在 Exchange Server 2007 中，可以使用 Exchange 命令行管理程序为 Exchange 组织设置 TransportConfig MaxSendSize 参数。

建议将最大邮件大小限制设置为不超过 10 MB。但是，如果需要对通过 Exchange 组织发送的带大型附件的邮件设置更高的邮件大小限制，可能要将最大传出邮件大小限制增加到 30 MB。如果将邮件大小限制增加到 30 MB 以上，会导致网络性能降低，甚至导致系统更容易受到安全攻击的侵害。

为 Exchange 2000 Server 和 Exchange Server 2003 设置邮件大小限制

  1. 在 Exchange 系统管理器中，展开"全局设置"，右键单击"邮件传递"，再单击"属性"。

  2. 在"邮件传递属性"对话框中的"默认设置"选项卡上，选择"发送邮件大小限制"选项，并键入所需的大小限制。

为 Exchange Server 2007 设置邮件大小限制

  1. 在 Exchange 命令行管理程序中，运行以下命令，其中 <大小> 会输入默认值"无限制"或输入 0 至 2147483647 字节范围内以 B（字节）、KB（千字节）或 MB（兆字节）为单位的大小。
复制代码
Set-TransportConfig -MaxSendSize <size>

例如，要将 Exchange 组织中的用户可以发送的最大邮件大小设置为 10 MB，您应该输入：

复制代码
Set-TransportConfig -MaxSendSize 10MB

要将 Exchange 组织中的用户可以发送的最大邮件大小设置为默认值"无限制"，您应该输入：

复制代码
Set-TransportConfig -MaxSendSize unlimited
  • 有关为 Exchange 2000 Server 和 Exchange Server 2003 设置邮件大小限制的详细信息，请参阅 Microsoft 知识库文章 322679"为邮件设置大小限制"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)。

  • 有关 Exchange Server 2007 的 TransportConfig cmdlet 的详细信息，请参阅 Exchange Server 2007 技术参考中的"Set-TransportConfig"(http://go.microsoft.com/fwlink/?LinkID=79237) 。

  • 有关 Internet 邮件格式的详细信息，请参阅"Exchange Server 2003 Administration Guide"（Exchange Server 2003 管理指南）中的"Configuring SMTP Policies to Control Outbound Mail Formatting and Automatic Responses"主题（使配置 SMTP 策略控制出站邮件格式和自动响应）(http://go.microsoft.com/fwlink/?LinkId=47617)。


最大传出邮件大小设置得太高 (>30 MB)
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-12-04

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定位于以下位置的全局设置 submissionContLength 属性值：

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

如果 Exchange Server 分析工具发现 submissionContLength 属性的值大于 30720，则显示错误。

该错误说明最大传出邮件大小限制的值已设置为大于 30 MB。根据您的组织的网络带宽和用户要求，您可能希望将邮件大小限制为更小的邮件。在 Exchange 2000 Server 和 Exchange Server 2007 中，没有默认的邮件大小限制。在 Exchange Server 2003 中，发送邮件和接收邮件的大小限制默认设置为 10,240 KB。此默认大小限制适用于新安装的 Exchange Server 2003 或者从 Exchange2000 Server 升级的 Exchange Server 2003（在这两种情况下均未设置邮件大小限制）。

通过设置可防止用户发送和接收大型电子邮件的邮件大小限制，可以节约系统资源。这有助于限制网络通信量、节省磁盘空间并改善网络的总体性能。在 Exchange 2000 Server 和 Exchange Server 2003 中，可以使用"全局设置"的"邮件传递属性"中的"默认设置"选项卡来指定传入和传出邮件的邮件传递限制。若要设置单个邮件的最大大小，请选择"最大值 (KB)"，然后在文本框中键入最大大小 (KB)。如果不想限制邮件的大小，请选择"无限制"。如果组织中的发件人试图向用户发送超过指定大小限制的邮件，则会收到 NDR。外部发件人可能会或可能不会收到 NDR，这取决于您在"Internet 邮件格式"中配置的 NDR 设置。

在 Exchange Server 2007 中，可以使用 Exchange 命令行管理程序为 Exchange 组织设置 TransportConfig MaxSendSize 参数。

建议将最大邮件大小限制设置为不超过 10 MB。但是，如果需要对通过 Exchange 组织发送的带大型附件的邮件设置更高的邮件大小限制，可能要将最大传出邮件大小限制增加到 30 MB。如果将邮件大小限制增加到 30 MB 以上，会导致网络性能降低，甚至导致系统更容易受到安全攻击的侵害。

为 Exchange 2000 Server 和 Exchange Server 2003 设置邮件大小限制

  1. 在 Exchange 系统管理器中，展开"全局设置"，右键单击"邮件传递"，再单击"属性"。

  2. 在"邮件传递属性"对话框的"默认设置"选项卡上，选择"发送邮件大小限制"下的"最大值"选项，并键入所需的大小限制。

为 Exchange Server 2007 设置邮件大小限制

  1. 在 Exchange 命令行管理程序中，运行以下命令，其中 <大小> 会输入默认值"无限制"或输入 0 至 2147483647 字节范围内以 B（字节）、KB（千字节）或 MB（兆字节）为单位的大小。
复制代码
Set-TransportConfig -MaxSendSize <size>

例如，要将 Exchange 组织中的用户可以发送的最大邮件大小设置为 10 MB，您应该输入：

复制代码
Set-TransportConfig -MaxSendSize 10MB

要将 Exchange 组织中的用户可以发送的最大邮件大小设置为默认值"无限制"，您应该输入：

复制代码
Set-TransportConfig -MaxSendSize unlimited
  • 有关为 Exchange 2000 Server 和 Exchange Server 2003 设置邮件大小限制的详细信息，请参阅 Microsoft 知识库文章 322679"为邮件设置大小限制"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)。

有关 Exchange Server 2007 的 TransportConfig cmdlet 的详细信息，请参阅 Exchange Server 2007 技术参考中的"Set-TransportConfig"(http://go.microsoft.com/fwlink/?LinkID=79237) 。

  • 有关 Internet 邮件格式的详细信息，请参阅"Exchange Server 2003 Administration Guide"(Exchange Server 2003 管理指南)中的"Configuring SMTP Policies to Control Outbound Mail Formatting and Automatic Responses"（配置 SMTP 策略控制出站邮件格式和自动响应）主题(http://go.microsoft.com/fwlink/?LinkId=21769)。


传出邮件最大大小可能设置得过低
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-12-04

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定位于以下位置的全局设置 submissionContLength 属性值：

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN= OrganizationName , CN=Global Settings, CN=Message Delivery

如果 Exchange Server 分析工具发现 submissionContLength 属性的值小于 1024 但大于 0，则会显示警告。

此警告表明，传出邮件的最大大小限制已设置为小于 1 MB。根据您的组织中的网络带宽和用户要求，您可能希望增加邮件大小，以便允许传输更大的邮件。在 Exchange 2000 Server 和 Exchange Server 2007 中，没有默认的邮件大小限制。在 Exchange Server 2003 中，发送邮件和接收邮件的大小限制默认设置为 10,240 KB。此默认大小限制适用于新安装的 Exchange Server 2003 或者从 Exchange2000 Server 升级的 Exchange Server 2003（在这两种情况下均未设置邮件大小限制）。

通过设置可防止用户发送和接收大型电子邮件的邮件大小限制，可以节约系统资源。这有助于限制网络通信量、节省磁盘空间并改善网络的总体性能。在 Exchange 2000 Server 和 Exchange Server 2003 中，可以使用"全局设置"的"邮件传递属性"中的"默认设置"选项卡来指定传入和传出邮件的邮件传递限制。若要设置单个邮件的最大大小，请选择"最大值 (KB)"，然后在文本框中键入最大大小 (KB)。如果不想限制邮件的大小，请选择"无限制"。如果组织中的发件人试图向用户发送超过指定大小限制的邮件，则会收到未送达报告 (NDR)。外部发件人可能会或可能不会收到 NDR，这取决于您在"Internet 邮件格式"中配置的 NDR 设置。

在 Exchange Server 2007 中，可以使用 Exchange 命令行管理程序为 Exchange 组织设置 TransportConfig MaxSendSize 参数。

建议将最大邮件大小限制设置为不超过 30 MB。但是，如果需要更高的邮件大小限制，以便通过 Exchange 组织发送包含较大附件的邮件，您可能需要将传出邮件的最大大小限制增加到 30 MB 以上。如果将邮件大小限制增加到 30 MB 以上，会导致网络性能降低，甚至导致系统更容易受到安全攻击的侵害。

为 Exchange 2000 Server 和 Exchange Server 2003 设置邮件大小限制

  1. 在 Exchange 系统管理器中，展开"全局设置"，右键单击"邮件传递"，再单击"属性"。

  2. 在"邮件传递属性"对话框的"默认设置"选项卡上，选择"发送邮件大小限制"下的"最大值"选项，并键入所需的大小限制。

为 Exchange Server 2007 设置邮件大小限制

  1. 在 Exchange 命令行管理程序中，运行以下命令，其中 <大小> 会输入默认值"无限制"或输入 0 至 2147483647 字节范围内以 B（字节）、KB（千字节）或 MB（兆字节）为单位的大小。
复制代码
Set-TransportConfig -MaxSendSize <size>

例如，要将 Exchange 组织中的用户可以发送的最大邮件大小设置为 10 MB，您应该输入：

复制代码
Set-TransportConfig -MaxSendSize 10MB

要将 Exchange 组织中的用户可以发送的最大邮件大小设置为默认值"无限制"，您应该输入：

复制代码
Set-TransportConfig -MaxSendSize unlimited
  • 有关为 Exchange 2000 Server 和 Exchange Server 2003 设置邮件大小限制的详细信息，请参阅 Microsoft 知识库文章 322679"为邮件设置大小限制"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)。

有关 Exchange Server 2007 的 TransportConfig cmdlet 的详细信息，请参阅 Exchange Server 2007 技术参考中的"Set-TransportConfig"(http://go.microsoft.com/fwlink/?LinkID=79237) 。

  • 有关 Internet 邮件格式的详细信息，请参阅"Exchange Server 2003 Administration Guide"（Exchange Server 2003 管理指南）中的"Configuring SMTP Policies to Control Outbound Mail Formatting and Automatic Responses"（配置 SMTP 策略控制出站邮件格式和自动响应）主题(http://go.microsoft.com/fwlink/?LinkId=47617)。


仅邮件日记功能已启用
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-01-10

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchMessageJournalRecipient 属性是否已配置为将邮件复制到收件人邮箱。msExchMessageJournalRecipient 属性是 Active Directory 中的邮箱存储对象的一个属性。默认情况下不配置 msExchMessageJournalRecipient 属性。如果 Exchange Server 分析工具发现 msExchMessageJournalRecipient 属性已配置，则 Exchange Server 分析工具将显示非默认配置消息。Exchange Server 分析工具还显示启用仅邮件日记功能的数据库名和服务器名。

Exchange Server 2003 的仅邮件日记功能或 Exchange Server 2007 标准日记功能在邮箱数据库上为与用户之间传递的所有邮件及相应的 P2 邮件头数据创建副本，并将邮件副本发送到指定的邮箱。P2 邮件头仅包含发件人声明发送给收件人的邮件收件人数据。如果从 Internet 接收外部邮件，则 Exchange Server 将记录 P1 邮件头。P1 邮件头是邮件传输代理 (MTA) 路由邮件时所使用的地址信息。默认情况下，在启用仅邮件日记功能时，Exchange Server 不会考虑密件抄送 (Bcc) 收件人、传输转发规则中的收件人或通讯组扩展中的收件人。此外，Exchange Server 也不会对 MAPI 报告邮件（例如已读回执）和外出通知进行存档。

邮件日记功能可能会占用许多磁盘资源、网络资源和 CPU 资源。因此，日记功能需要进行全面的部署计划。只有在整体日记解决方案框架的环境下，才应启用日记功能。

如果下列条件成立，请忽略此非默认配置消息：

  • 您的业务需要日记功能。

  • 您已部署了日记解决方案框架。

否则，应关闭日记功能。

在 Exchange 2000 Server 和 Exchange Server 2003 中关闭数据库上的仅邮件日记功能

  1. 在 Exchange 系统管理器中，依次展开"服务器"、<您的 Exchange 服务器>、<存储组>，再右键单击邮箱存储。

  2. 在"常规"选项卡上，清除"存档由此存储中的邮箱发送或接收的所有邮件"复选框。

  3. 等待 15 分钟，让 Exchange 存储应用更改。不必重新启动 Microsoft Exchange 信息存储服务。
在 Exchange Server 2007 中关闭数据库上的标准日记功能

  1. 按照 Exchange Server 2007 产品文档 How to Disable Per-Mailbox Database Journaling（如何禁用每个邮箱数据库的日记功能）(http://go.microsoft.com/fwlink/?LinkId=80889) 中的指导进行操作。

有关如何使用 Exchange Server 2003 部署日记解决方案的详细信息，请参阅 Journaling with Exchange Server 2003（Exchange Server 2003 的日记功能）(http://go.microsoft.com/fwlink/?LinkId=47581)。

有关如何使用 Exchange Server 2007 部署日记解决方案的详细信息，请参阅 Overview of Journaling（日记功能概述）(http://go.microsoft.com/fwlink/?LinkId=80820)。


可能存在邮件路由循环
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每台简单邮件传输协议 (SMTP) 虚拟服务器的 msExchAlternateServer 属性值。Exchange Server 最佳实践分析工具还确定是否已在组织中的任何收件人策略上配置 msExchNonAuthoritativeDomains 属性。如果存在下列条件，则 Exchange Server 分析工具将显示警告：

  • 已设置了 msExchAlternateServer 属性的任何实例。

  • 已在任何收件人策略上设置了 msExchNonAuthoritativeDomains 属性。

因为上述配置可能会造成邮件循环，所以，Exchange Server 分析工具将显示警告。如果不同的邮件系统配置为在一个组织中同时使用，可能会出现邮件循环。在这种情况下，使用 Exchange Server 收件人策略和 SMTP 配置为异构邮件系统上的用户组路由并传递邮件。

在 SMTP 虚拟服务器属性页上的"将具有未解析的收件人的所有邮件转发到下列主机"字段中指定地址时，即设置了 msExchAlternateServer 属性。

在指定收件人策略的 SMTP 地址属性页上清除"此 Exchange 组织负责处理传递到此地址的所有邮件"复选框时，即设置了 msExchNonAuthoritativeDomains 属性。

因此，如果通过清除"此 Exchange 组织负责处理传递到此地址的所有邮件"复选框将 SMTP 域指定为非授权域，并且为任意 SMTP 虚拟服务器上无法解析的收件人指定了地址，则 Exchange Server 分析工具将显示警告。但是一定要注意，出现此警告不一定表明组织中存在邮件循环。

如果非权威域存在，并且组织中至少一台服务器设置了 msExchAlternateServer，可能会存在邮件路由循环。应验证是否存在下列情况：

  • 组织中的所有域均存在权威域。

  • SMTP 虚拟服务器配置为由权威域处理所有未解析的邮件。

尤其是如果与其他组织共享域名，建议该域命名空间只有一个入站路径。一台邮件服务器或一套邮件系统应成为该域的权威，以防止出现循环。权威服务器应为入站路径上的最后一个系统。

哪个系统是初始接收者并不重要。是否存在两个以上的初始接收者也并不重要。重要的是只有一个系统是最终目标。

更改 msExchAlternateServer 属性

  1. 在 Exchange 系统管理器中，依次展开"服务器"、<服务器名称>、"协议"、SMTP。

  2. 用鼠标右键单击 SMTP 虚拟服务器，再单击"属性"。

  3. 在 SMTP 虚拟服务器的"属性"中，单击"邮件"选项卡。

  4. 在"将具有未解析的收件人的所有邮件转发到下列主机"框中，键入将接收未解析邮件的服务器的 FQDN。也可以在方括号 ([ ]) 中输入服务器的 IP 地址。

  5. 单击"确定"。
更改 msExchNonAuthoritativeDomains 属性

  1. 在 Exchange 系统管理器中，展开"收件人"，再双击 <收件人策略名称>。

  2. 在"电子邮件地址(策略)"选项卡上双击 SMTP 地址。

  3. 在"SMTP 地址属性"页上，选中"此 Exchange 组织负责处理传递到此地址的所有邮件"即清除了 msExchNonAuthoritativeDomains 属性。通过清除该复选框，可以使用"地址"字段中指定的 SMTP 地址设置 msExchNonAuthoritativeDomains 属性。

有关共享 SMTP 地址空间的详细信息，请参阅 Microsoft 知识库文章 321721"在 Exchange 2000 中共享 SMTP 地址空间"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=321721)。

有关 Internet 连接的部署方案的详细信息，请参阅"Exchange Server 2003 传输和路由指南"中的"Internet 连接的部署方案"(http://go.microsoft.com/fwlink/?LinkId=47579)。


"等待目录查找的邮件"队列已冻结
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具查询 ExchangeLink Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP)"等待目录查找的邮件"队列的 StateFrozen 关键字的值。

如果 Exchange Server 分析工具发现 Exchange 服务器上"等待目录查找的邮件"队列的 StateFrozen 关键字的值已设置为 True，则 Exchange Server 分析工具会显示错误。

已冻结的队列意味着该队列的传输会话已停止。已冻结的队列允许添加新邮件，但将阻止传出邮件。可以使用每个链接队列上的快捷菜单手动更改连接状态。使用"强制连接"命令将队列状态更改为"活动"后，可以立即启用从该队列发送邮件的连接。

"等待目录查找的邮件"队列包含尚未使用 Active Directory® 目录服务解析收件人的邮件。展开通讯组列表时也可以将邮件存放在此队列中。

由于高级队列引擎无法对邮件进行分类，因此邮件通常会在此队列中累积。高级队列引擎可能无法访问全局编录服务器和收件人信息，或者全局编录服务器不可访问或执行缓慢。此外，邮件可能会因以下原因而发生累积：

  • Active Directory 不可用。

    注意：
    分类程序使用 Active Directory 对邮件进行分类。
  • 如果许多邮件在预分类队列中进行排队，则 Active Directory 可能负载过多。

  • 存在转换故障分类程序也可以处理内容转换。

  • 邮件分类程序无法找到邮箱存储。

  • 如果重新安装或删除 SMTP，则下列 IIS 元数据库关键字可能失效：/smtpsvc/DsUseCat 和 /smtpsvc/vsi#/DsUseCat。

    注意：
    确定是否已重新安装或删除了 SMTP。

要解决此错误，应增加对 MSExchangeDSAccess 服务和 MSExchangeTransport 服务的诊断日志记录以收集有关分类程序组件的信息。

有关如何解决 SMTP 队列问题的详细信息，请参阅以下 Exchange 资源：

  • "Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"排除邮件流和 SMTP 故障"。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=823489)。

  • Miscrosoft 知识库文章 821877"Description of Fields on the SMTP and X.400 Queue Properties Tabs"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)。

  • Miscrosoft 知识库文章 264054"XCON:Understanding Queue States in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


"等待目录查找的邮件"队列处于重试状态
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具查询 ExchangeLink Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP)"等待目录查找的邮件"队列的 StateRetry 关键字的值。

如果 Exchange Server 分析工具发现 Exchange 服务器上"等待目录查找的邮件"队列的 StateRetry 关键字的值已设置为 True，则 Exchange Server 分析工具会显示错误。

如果队列处于重试状态，则该状态表明以前尝试处理此队列中的邮件时，至少出现了一个错误。可以使用"强制连接"命令将重试状态或预定状态中的队列更改为活动。这会使队列处于活动中，就好像重试间隔已过或预定时间已到一样。但是，此方法可能不会始终有效。

注意：
队列的属性可以表明队列处于重试状态的特定原因。

"等待目录查找的邮件"队列包含尚未使用 Active Directory® 目录服务解析收件人的邮件。展开通讯组列表时也可以将邮件存放在此队列中。

由于高级队列引擎无法对邮件进行分类，因此邮件通常会在此队列中累积。高级队列引擎可能无法访问全局编录服务器和收件人信息，或者全局编录服务器不可访问或执行缓慢。此外，邮件可能会因以下原因而发生累积：

  • Active Directory 不可用。

    注意：
    分类程序使用 Active Directory 对邮件进行分类。
  • 如果许多邮件在预分类队列中进行排队，则 Active Directory 可能负载过多。

  • 存在转换故障分类程序也可以处理内容转换。

  • 邮件分类程序无法找到邮箱存储。

  • 如果重新安装或删除 SMTP，则下列 IIS 元数据库关键字可能失效：/smtpsvc/DsUseCat 和 /smtpsvc/vsi#/DsUseCat。

    注意：
    确定是否已重新安装或删除了 SMTP。

要解决此错误，请检查队列的属性，以确定队列为何处于重试状态。例如，如果队列属性显示类似"已发生 SMTP 错误"的消息，则应查看服务器的事件日志以查找任何 SMTP 错误。如果日志中没有事件，则应增加 SMTP 协议日志记录级别。

有关如何解决 SMTP 队列问题的详细信息，请参阅以下 Exchange 资源：

  • "Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"排除邮件流和 SMTP 故障"。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=823489)。

  • Miscrosoft 知识库文章 821877"Description of Fields on the SMTP and X.400 Queue Properties Tabs"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)。

  • Miscrosoft 知识库文章 264054"XCON:Understanding Queue States in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


"暂缓提交的邮件"队列已冻结
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-16

Microsoft® Exchange Server 分析工具查询 ExchangeLink Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP)"暂缓提交的邮件"队列的 StateFrozen 关键字的值。

如果 Exchange Server 分析工具发现 Exchange 服务器上"暂缓提交的邮件"队列的 StateFrozen 关键字的值已设置为 True，则 Exchange Server 分析工具会显示错误。

已冻结的队列意味着该队列的传输会话已停止。已冻结的队列允许添加新邮件，但将阻止传出邮件。可以使用每个链接队列上的快捷菜单手动更改连接状态。使用"强制连接"命令将队列状态更改为"活动"后，可以立即启用从该队列发送邮件的连接。

"暂缓提交的邮件"队列保存 SMTP 服务已经确认和接受的邮件。

在此队列中的邮件尚未得到处理。如果邮件不断累积，则会出现性能问题。偶尔的 CPU 性能峰值可能导致邮件间歇性地出现在此队列中。事件接收器问题（例如，针对防病毒屏蔽和免责声明的自定义 SMTP 处理代码）通常会导致邮件在此队列中累积。

有关如何修改日志记录设置的详细信息，请参阅"Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 的"排除邮件流和 SMTP 故障"部分中的"如何修改 MSExchangeTransport 的日志记录设置"。

有关如何解决 SMTP 队列问题的详细信息，请参阅以下 Exchange 资源：

  • "Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"排除邮件流和 SMTP 故障"。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=823489)。

  • Miscrosoft 知识库文章 821877"Description of Fields on the SMTP and X.400 Queue Properties Tabs"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)。

  • Miscrosoft 知识库文章 264054"XCON:Understanding Queue States in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


"暂缓提交的邮件"队列处于重试状态中
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具查询 ExchangeLink Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP)"暂缓提交的邮件"队列的 StateRetry 关键字的值。

如果 Exchange Server 分析工具发现 Exchange 服务器上"暂缓提交的邮件"队列的 StateRetry 关键字的值已设置为 True，则 Exchange Server 分析工具会显示错误。

如果队列处于重试状态，则该状态表明以前尝试处理此队列中的邮件时，至少出现了一个错误。可以使用"强制连接"命令将重试状态或预定状态中的队列更改为活动。这会使队列处于活动中，就好像重试间隔已过或预定时间已到一样。但是，此方法可能不会始终有效。

注意：
队列的属性可以表明队列处于重试状态的特定原因。

"暂缓提交的邮件"队列保存 SMTP 服务已经确认和接受的邮件。

在此队列中的邮件尚未得到处理。如果邮件不断累积，则会出现性能问题。偶尔的 CPU 性能峰值可能导致邮件间歇性地出现在此队列中。事件接收器问题（例如，针对防病毒屏蔽和免责声明的自定义 SMTP 处理代码）通常会导致邮件在此队列中累积。

有关如何修改日志记录设置的详细信息，请参阅"Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 的"排除邮件流和 SMTP 故障"部分中的"如何修改 MSExchangeTransport 的日志记录设置"。

有关如何解决 SMTP 队列问题的详细信息，请参阅以下 Exchange 资源：

  • "Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"排除邮件流和 SMTP 故障"。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=823489)。

  • Miscrosoft 知识库文章 821877"Description of Fields on the SMTP and X.400 Queue Properties Tabs"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)。

  • Miscrosoft 知识库文章 264054"XCON:Understanding Queue States in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


"等待路由的邮件"队列已冻结
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具查询 ExchangeLink Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP)"等待路由的邮件"队列的 StateFrozen 关键字的值。

如果 Exchange Server 分析工具发现 Exchange 服务器上"等待目录查找的邮件"队列的 StateFrozen 关键字的值已设置为 True，则 Exchange Server 分析工具会显示错误。

已冻结的队列意味着该队列的传输会话已停止。已冻结的队列允许添加新邮件，但将阻止传出邮件。可以使用每个链接队列上的快捷菜单手动更改连接状态。使用"强制连接"命令将队列状态更改为"活动"后，可以立即启用从该队列发送邮件的连接。

在确定下一个目标服务器，然后将邮件移到其各自的链接队列中之前，邮件将存放在"等待路由的邮件"队列中。

如果 Exchange Server 路由存在问题，则邮件会在该队列中累积。可能会对邮件路由进行备份。

要纠正此错误，应增加对 MSExchangeDSAccess 服务和 MSExchangeTransport 服务的诊断日志记录以收集有关分类程序组件的信息。

有关如何修改日志记录设置的详细信息，请参阅"Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 的"排除邮件流和 SMTP 故障"部分中的"如何修改 MSExchangeTransport 的日志记录设置"。

有关如何解决 SMTP 队列问题的详细信息，请参阅以下 Exchange 资源：

  • "Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"排除邮件流和 SMTP 故障"。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=823489)。

  • Miscrosoft 知识库文章 821877"Description of Fields on the SMTP and X.400 Queue Properties Tabs"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)。

  • Miscrosoft 知识库文章 264054"XCON:Understanding Queue States in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


"等待路由的邮件"队列处于重试状态
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具查询 ExchangeLink Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP)"等待路由的邮件"队列的 StateRetry 关键字的值。

如果 Exchange Server 分析工具发现 Exchange 服务器上"等待目录查找的邮件"队列的 StateRetry 关键字的值已设置为 True，则 Exchange Server 分析工具会显示错误。

如果队列处于重试状态，则该状态表明以前尝试处理此队列中的邮件时，至少出现了一个错误。可以使用"强制连接"命令将重试状态或预定状态中的队列更改为活动。这会使队列处于活动中，就好像重试间隔已过或预定时间已到一样。但是，此方法可能不会始终有效。

注意：
队列的属性可以表明队列处于重试状态的特定原因。

在确定下一个目标服务器，然后将邮件移到其各自的链接队列中之前，邮件将存放在"等待路由的邮件"队列中。

如果 Exchange Server 路由存在问题，则邮件会在该队列中累积。可能会对邮件路由进行备份。

要纠正此错误，应增加对 MSExchangeTransport 服务的诊断日志记录以收集有关分类程序组件的信息。因为连接器限制会严重降低服务器的性能，所以应禁用任何不需要的连接器限制。可能必须为某些限制启用 CheckConnectorRestrictions 注册表项。

有关如何修改日志记录设置的详细信息，请参阅"Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 的"排除邮件流和 SMTP 故障"部分中的"如何修改 MSExchangeTransport 的日志记录设置"。

有关如何解决 SMTP 队列问题的详细信息，请参阅以下 Exchange 资源：

  • "Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"排除邮件流和 SMTP 故障"。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=823489)。

  • Miscrosoft 知识库文章 821877"Description of Fields on the SMTP and X.400 Queue Properties Tabs"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)。

  • Miscrosoft 知识库文章 264054"XCON:Understanding Queue States in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


缺少传输事件接收器绑定
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-01-11

Microsoft® Exchange Server 分析工具查询 Microsoft Internet 信息服务 (IIS) 元数据库，以枚举简单邮件传输协议 (SMTP) 传输事件接收器绑定列表。Exchange Server 分析工具尝试基于 Exchange Server 分析工具中以下预填充的列表来查找几个标准事件绑定：

  • 自定义 Exchange DSN 接收器

  • XLSA 的 EHLO 入站命令处理程序接收器

  • X-LSA 的 EHLO 响应处理程序接收器

  • EOD 入站命令处理程序接收器

  • Exchange 分类程序

  • Exchange LoadBalancer

  • Exchange NTFS 存储驱动器

  • Exchange 路由器

  • Exchange SMTP 协议日志记录接收器

  • Exchange SMTP 协议安全 EHLO 接收器

  • Exchange SMTP 协议安全 EXPS 接收器

  • Exchange SMTP 协议安全 EXPS-Aux 接收器

  • Exchange SMTP 协议安全 EXPS-EOD 接收器

  • Exchange SMTP 协议安全邮件接收器

  • Exchange SMTP Protocol XEXCH50 Before Data 接收器

  • Exchange SMTP 协议 XEXCH50 EHLO 响应接收器

  • Exchange SMTP 协议 XEXCH50 EOD 接收器

  • Exchange SMTP 协议 XEXCH50 入站 EHLO 接收器

  • Exchange SMTP 协议 XEXCH50 入站 MAIL 接收器

  • Exchange SMTP 协议 XEXCH50 入站 RCPT 接收器

  • Exchange SMTP 协议 XEXCH50 入站 XEXCH50 接收器

  • Exchange SMTP 协议 XEXCH50 Per Pecipient Event 接收器

  • Exchange SMTP 协议 XEXCH50 RCPT 响应接收器

  • Exchange SMTP 协议 XEXCH50 响应接收器

  • Exchange 存储驱动器

  • Exchange 传输防病毒 API

  • Exchange 传输 XEXCH50 提交接收器

  • TURF 的 MAIL 入站命令处理程序接收器

  • 移动分类程序

  • MSExchange 内容筛选器 EOD 接收器

  • MsgTrackLog 接收器

  • RCPT 入站命令处理程序接收器

  • SMTP Eventlog 接收器

  • UmConvSink

  • X-LSA 入站命令处理程序接收器

  • X-LSA 响应处理程序接收器

  • X-LSA 接收器

如果 Exchange Server 分析工具发现缺少一个或多个标准事件绑定，则 Exchange Server 分析工具会生成警告。

邮件数据传输到 SMTP 服务或从中传出时将发生 SMTP 传输事件。所有邮件都通过事件进行传送。其中包括 X.400 和 RPC 传入或传出邮件。通常，传入传输事件是指邮件通过网络或 SMTP 拾取目录到达 SMTP 服务。此传输事件发生时，事件的源将通知传输事件接收器，每个事件接收器都可以基于邮件的数据内容采取某种类型的操作。系统将邮件数据传递到接收器后，就不再对邮件数据执行其他操作，直到接收器完成其操作并返回邮件为止。接收器在执行此操作时对邮件数据和状态拥有独占控制权。

缺少传输事件接收器绑定会导致邮件流问题。如果 Exchange Server 显示出邮件流问题的症状（如邮件排队），则应重新注册传输事件接收器。

重新注册传输事件接收器

  1. 在 Microsoft Exchange Server 中，打开命令提示符窗口，然后更改到 \Program Files\Exchsrvr\Bin 文件夹。

  2. 键入下列命令重新注册传输事件接收器：

    regsvr32 /i exps.dll

    regsvr32 /i miscat.dll

    regsvr32 /i onsubmit.dll

    regsvr32 /i peexch50.dll

    regsvr32 /i phatcat.dll

    regsvr32 /i protolog.dll

    regsvr32 /i reapi.dll

    regsvr32 /i regsinks.dll

    regsvr32 /i tranmsg.dll

    regsvr32 /i turflist.dll

    regsvr32 /i xlsasink.dll

    regsvr32 /i msgfilter.dll

  3. 重新运行 Exchange Server 分析工具以验证不再出现警告。如果事件接收器警告仍然出现，并且还存在邮件流问题，请与 Microsoft 产品支持服务部门 (PSS) 联系。

有关传输事件接收器绑定的详细信息，请参阅下列 Exchange 资源：

  • Microsoft 知识库文章 258224，"XCON: Enumerating the Registered Transport Event Sinks"（英文）(http://go.microsoft.com/fwlink/?linkID=3052&kbid=258224)

  • "Technical Reference Guide for Exchange Server 2003"中的"SMTP Service Design"（英文）(http://go.microsoft.com/fwlink/?LinkId=58876)


msExchAlternateServer 属性已设置
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每台简单邮件传输协议 (SMTP) 虚拟服务器的 msExchAlternateServer 属性值。默认情况下不设置 msExchAlternateServer 属性值。如果 Exchange Server 分析工具发现 msExchAlternateServer 属性已设置，Exchange Server 分析工具将显示非默认配置消息。

您将在以下示例方案中设置 msExchAlternateServer 属性。在 Exchange Server 2003 和另一个电子邮件系统之间共享 SMTP 地址空间（例如 SMTP 域）。在此方案中，Exchange Server 2003 从 Internet 接受传入邮件。Exchange Server 2003 在 Exchange Server 组织中查找匹配的收件人。如果未找到匹配项，则 Exchange Server 会将邮件转发到外部邮件系统。接收系统同样会查找匹配项。如果未找到匹配项，则将邮件转发到第三个电子邮件系统。链中的最后一个系统必须是该域的权威系统。最后一个接收系统必须查找匹配的收件人。如果未找到匹配的收件人，必须为邮件生成未送达报告 (NDR)。如果某个接收系统查找匹配项，未找到匹配项时将邮件转发回原始系统，则出现循环邮件。

更改 msExchAlternateServer 属性

  1. 在 Exchange 系统管理器中，依次展开"服务器"、<服务器名称>、"协议"、SMTP。

  2. 用鼠标右键单击 SMTP 虚拟服务器，再单击"属性"。

  3. 在 SMTP 虚拟服务器的"属性"中，单击"邮件"选项卡。

  4. 在"将具有未解析的收件人的所有邮件转发到下列主机"框中，键入将接收未解析邮件的服务器的 FQDN。也可以在方括号 ([ ]) 中输入服务器的 IP 地址。

  5. 单击"确定"。

有关共享 SMTP 地址空间的详细信息，请参阅 Microsoft 知识库文章 321721"在 Exchange 2000 中共享 SMTP 地址空间"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=321721)。

有关 Internet 连接的部署方案的详细信息，请参阅"Exchange Server 2003 传输和路由指南"中的"Internet 连接的部署方案"(http://go.microsoft.com/fwlink/?LinkId=47579)。


msExchMaxIncomingConnections 值已从默认设置更改为其他设置
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个 SMTP 虚拟服务器的 msExchSmtpMaxIncomingConnections 属性的配置值。

默认情况下，在未运行 Microsoft Windows® Small Business Server 2003 的 Exchange Server 计算机上，msExchSmtpMaxIncomingConnections 属性配置为不限制连接数。该属性的默认值为 2000000000。在运行 Microsoft Windows Small Business Server 2003 的 Exchange Server 计算机上，默认的最大传入连接数为 500。

Exchange Server 分析工具还查询 Win32_OperatingSystem Windows Management Instrumentation (WMI) 类，以确定 OSProductSuite 关键字的值。该关键字的值对应于 Windows Server 操作系统的特定版本。

如果 Exchange Server 分析工具发现未运行 Microsoft Windows Small Business Server 2003 的 Exchange Server 计算机上的 msExchSmtpMaxIncomingConnections 属性值不为 2000000000，则会显示非默认配置消息。用于此属性的值 2000000000 是理论上的限制，并且此限制作用于可用于配置该值的用户界面元素。

或者，如果 Exchange Server 分析工具发现运行 Microsoft Windows Small Business Server 2003 的 Exchange Server 计算机上的 msExchSmtpMaxIncomingConnections 属性值不为 500，则会显示非默认配置消息。

从安全的角度讲，限制传入连接数有意义。接受任意多传入 SMTP 连接的功能可能导致自身产生拒绝服务的情况。与虚拟服务器的同时连接数太多会使您的网络超载，并导致性能降低。每个组织都应自己决定适合于该属性的值。

查看或配置最大传入连接数

  1. 打开 Exchange 系统管理器。

  2. 依次展开"服务器"、Exchange 服务器、"协议"、"SMTP"。

  3. 用鼠标右键单击 SMTP 虚拟服务器（例如，默认 SMTP 虚拟服务器），再单击"属性"。

  4. 单击"常规"：

    • 若要限制传入连接数，请选中"限制连接数不超过"复选框，并输入所需的值。

    • 若要还原为不限制传入连接的默认设置，请清除"限制连接数不超过"复选框。

  5. 单击"确定"保存更改。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列 Microsoft 知识库文章：

  • 266686"XCON:如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)

  • 268163"XCON:How to Configure a SMTP Virtual Server Part 2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpMaxHopCount 值已从其默认值更改为其他值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchSmtpMaxHopCount 属性的配置值是否已从默认值更改为其他值。

在 Exchange 2000 Server 中，msExchSmtpMaxHopCount 属性被配置为默认值 15。在 Exchange Server 2003 中，该属性具有默认值 30。如果 Exchange Server 分析工具发现该属性不再被设置为默认设置，则会显示非默认配置消息。

在邮件到达它的最终目标之前，可以通过很多不同的 SMTP 服务器（每个服务器称为一个"跃点"）来路由该邮件。为了防止邮件被重复地错误路由（一种称为"邮件循环"的情况），管理员可以控制所允许的最大跃点数。mxExchSmtpMaxHopCount 属性指定了邮件可以经过的最大 SMTP 服务器数，如果超过该数字，邮件将作为未送达邮件返回给发件人。

Exchange 2000 Server 和 Exchange Server 2003 SMTP 虚拟服务器的推荐值都是 30。

更正此错误

  1. 在 Exchange 系统管理器中，展开"服务器"，再展开 Exchange 服务器，再展开"协议"，再展开"SMTP"。

  2. 用鼠标右键单击 SMTP 虚拟服务器（例如，默认 SMTP 虚拟服务器），并选择"属性"。

  3. 选择"传递"选项卡，再单击"高级"。

  4. 在"最大跃点计数"字段中输入所希望的值，并单击"确定"保存更改。

  5. 单击"确定"关闭 SMTP 虚拟服务器的"属性"对话框。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列 Microsoft 知识库文章：

  • 266686"XCON:如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)

  • 268163"XCON:How to Configure a SMTP Virtual Server Part 2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpMaxMessageSize 值已从默认值 0 更改为其他值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchSmtpMaxMessageSize 属性的值是否已从默认值 0 更改为其他值。默认情况下，msExchSmtpMaxMessageSize 属性配置为不限制邮件大小。如果 Exchange Server 分析工具发现该属性的值不为 0，并且 Exchange 未运行在 Microsoft Windows® Small Business Server 2003 上，则会显示警告消息。

msExchSmtpMaxMessageSize 属性表示可以发送或接收的每个 SMTP 邮件的最大大小。从安全的角度来讲，限制可以向（从）Internet 发送（接收）的 SMTP 邮件的最大大小是最佳实践。但是，对于内部 SMTP 邮件，例如，在同一组织中的 Exchange 服务器之间传输的邮件，则建议将 msExchSmtpMaxMessageSize 属性的设置保留为 0。

在内部，Exchange 使用 SMTP 邮件处理公用文件夹复制等任务。如果使用过低的限制值来配置 msExchSmtpMaxMessageSize 属性，可能导致公用文件夹复制问题以及其他的组织内邮件传递故障。

如果此 Exchange 服务器是向（从）Internet 发送（接收）SMTP 邮件的桥头服务器，也许可以放心地忽略此警告。如果此 Exchange 服务器处理内部 SMTP 邮件，则应将 msExchSmtpMaxMessageSize 属性的值改回默认设置 0。

注意：
如果将邮件大小限制设置得过低，可能导致 Exchange Server 计算机之间的脱机通讯簿复制无法进行。有关此问题的详细信息，请参阅 Microsoft 知识库文章 326154"XADM:The OAB Does Not Replicate If You Set a Message Size Restriction at the Transport Level"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=326154)。

查看并配置最大 SMTP 邮件大小

  1. 在 Exchange 系统管理器中，依次展开"服务器"、Exchange 服务器、"协议"、"SMTP"。

  2. 用鼠标右键单击 SMTP 虚拟服务器（例如，默认 SMTP 虚拟服务器），并选择"属性"。

  3. 选择"邮件"选项卡。

  4. 若要还原为默认设置 0，请清除"限制邮件大小不超过 (KB)"复选框。或者，使该复选框保持选中状态，并配置所需的任意值。

  5. 单击"确定"保存更改，并关闭 SMTP 虚拟服务器的"属性"对话框。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列 Microsoft 知识库文章：

  • 266686"XCON:如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)

  • 268163"XCON:How to Configure a SMTP Virtual Server Part 2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpMaxOutboundMsgPerDomain 值已从其默认值 20 更改为其他值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-07-07

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchSmtpMaxOutboundMsgPerDomain 属性的配置值是否已从默认值 20 更改为其他值。默认情况下，msExchSmtpMaxOutboundMsgPerDomain 属性配置为每个连接最多 20 个出站 SMTP 邮件。如果 Exchange Server 分析工具发现该属性的值不是 20，则会显示非默认配置消息。

msExchSmtpMaxOutboundMsgPerDomain 属性表示 Exchange 服务器上的 SMTP 虚拟服务器在每个连接上最多可以发送的邮件数。例如，如果 SMTP 服务器有 35 封邮件要发送到 microsoft.com，而 msExchSmtpMaxOutboundMsgPerDomain 属性设置为 20，将与负责 microsoft.com 邮件的邮件服务器建立两个连接。第一个连接将发送最多允许发送的 20 封邮件，余下的 15 封邮件将由建立的第二个连接发送。

通常，对于如何确定该属性的正确值，并没有最佳做法建议。每个组织都必须自己确定应设置的适当值。

设置每个连接的最大邮件数

  1. 打开 Exchange 系统管理器。

  2. 展开"服务器"，展开 Exchange 服务器，展开"协议"，再展开"SMTP"。

  3. 右键单击 SMTP 虚拟服务器（例如，默认 SMTP 虚拟服务器），再单击"属性"。

  4. 单击"邮件"。

  5. 此时会在"限制连接数不超过"字段中列出 msExchSmtpMaxOutboundMsgPerDomain 属性的当前值。根据需要更改该字段，再单击"确定"保存更改。此字段可接受的值包括介于 1 和 1999999999 之间的任何整数。

  6. 单击"确定"关闭 SMTP 虚拟服务器的"属性"对话框。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列 Microsoft 知识库文章：

  • 266686"XCON:如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)

  • 268163"XCON：如何配置 SMTP 虚拟服务器第 2 部分"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpMaxOutgoingConnections 值已从默认值 1000 更改为其他值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchSmtpMaxOutgoingConnections 属性的配置值是否已从默认值 1000 更改为其他值。默认情况下，msExchSmtpMaxOutgoingConnections 属性被配置为最多 1000 个出站简单邮件传输协议 (SMTP) 连接。如果 Exchange Server 分析工具发现该属性的值不是 1000，则会显示非默认配置消息。

msExchSmtpMaxOutgoingConnections 属性代表 SMTP 虚拟服务器可以在 Exchange 服务器上建立的最大出站连接数。

通常，对于如何确定该属性的正确值，并没有最佳做法建议。每个组织必须自行确定要设置的合适值。就是说，默认值对于某些组织可能太高。通过在 Exchange 服务器上收集下列性能计数器，可以监视并确定 Exchange SMTP 虚拟服务器所建立的实际 SMTP 出站连接数：

对象 | 计数器 | 解释
SMTP Server | Outbound Connections Current | 当前出站连接数。
SMTP Server | Outbound Connections Total | 尝试建立的出站连接总数。

如果组织没有在该 Exchange 服务器上广泛使用传出 SMTP，请考虑降低该属性的值。如果将可以在任何时候建立的最大同时出站 SMTP 连接数降低，则会潜在地减缓任何 SMTP 服务器活动高峰（它们可能由以下情况导致：不正确的配置、无意识的错误、恶意的活动、邮件循环或其他故障，或者病毒攻击或安全破坏）。

查看和配置传出连接限制

  1. 打开 Exchange 系统管理器。

  2. 展开"服务器"，展开 Exchange 服务器，展开"协议"，再展开"SMTP"。

  3. 用鼠标右键单击 SMTP 虚拟服务器（例如，默认 SMTP 虚拟服务器），再单击"属性"。

  4. 单击"传递"，再单击"出站连接"。

  5. "限制连接数不超过"字段中列出了 msExchSmtpMaxOutgoingConnections 属性的当前值。根据需要更改该字段，再单击"确定"保存更改。该字段的可接受值包括 1 和 1999999999 之间的任何整数。

  6. 单击"确定"关闭 SMTP 虚拟服务器的"属性"对话框。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列 Microsoft 知识库文章：

  • 266686"XCON:如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)

  • 268163"XCON:How to Configure a SMTP Virtual Server Part 2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpMaxOutgoingConnectionsPerDomain 值已从其默认值 100 更改为其他值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchSmtpMaxOutgoingConnectionsPerDomain 属性的配置值是否已从默认设置更改为其他设置。msExchSmtpMaxOutgoingConnectionsPerDomain 属性代表 Microsoft Exchange 服务器上的 SMTP 虚拟服务器可以建立的、每个域的最大出站连接数。默认情况下，在不是 Microsoft Windows® Small Business Server 2003 安装的一部分的 Exchange Server 计算机上，msExchSmtpMaxOutgoingConnectionsPerDomain 属性被配置为默认值 100。在作为 Windows Small Business Server 2003 安装的一部分的 Exchange Server 计算机上，默认的每个域的最大传出连接数是 10。

Exchange Server 分析工具还查询 Win32_OperatingSystem Windows Management Instrumentation (WMI) 类，以确定 OSProductSuite 关键字的值。该关键字的值对应于 Windows Server 操作系统的特定版本。

如果 Exchange Server 分析工具发现在未运行 Windows Small Business Server 2003 的 Exchange Server 计算机上的 msExchSmtpMaxOutgoingConnectionsPerDomain 属性的值不是 500，则会显示非默认配置消息。

另外，如果 Exchange Server 分析工具发现在运行 Microsoft Windows Small Business Server 2003 的 Exchange Server 计算机上的 msExchSmtpMaxOutgoingConnectionsPerDomain 属性的值不是 10，则会显示非默认配置消息。

通常，对于如何确定该属性的正确值，并没有最佳做法建议。每个组织都需要确定要设置的合适值。这就是说，默认值对于某些组织可能太高。通过在 Exchange 服务器上收集下列性能计数器，可以监视并确定 Exchange SMTP 虚拟服务器所建立的实际 SMTP 出站连接数：

对象 | 计数器 | 解释
SMTP Server | Outbound Connections Current | 当前出站连接数。
SMTP Server | Outbound Connections Total | 试图进行的出站连接总数。

如果组织没有在该 Exchange 服务器上广泛使用传出 SMTP，请考虑降低该属性的值。通过降低可以在任何给定时间建立的最大同时出站 SMTP 连接数，可以潜在地缓解可能由不正确的配置、非恶意的失误、恶意的活动、邮件循环或其他故障、或者病毒发作或安全性破坏所导致的任何 SMTP 服务器活动高峰。

查看和配置每个域的传出连接限制

  1. 打开 Exchange 系统管理器。

  2. 展开"服务器"，展开 Exchange 服务器，展开"协议"，再展开"SMTP"。

  3. 用鼠标右键单击 SMTP 虚拟服务器（例如，默认 SMTP 虚拟服务器），再单击"属性"。

  4. 单击"传递"，再单击"出站连接"。

  5. "限制每个域的连接数不超过"字段中列出了 msExchSmtpMaxOutgoingConnectionsPerDomain 属性的当前值。根据需要更改该字段，并单击"确定"保存更改。该字段的可接受值包括 1 和 1999999999 之间的任何整数。

  6. 单击"确定"关闭 SMTP 虚拟服务器的"属性"对话框。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列 Microsoft 知识库文章：

  • 266686"XCON:如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)

  • 268163"XCON:How to Configure a SMTP Virtual Server Part 2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpMaxRecipients 值已从默认值 64000 更改为其他值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchSmtpMaxRecipients 属性的配置值是否已从默认值 64000 更改为其他值。默认情况下，msExchSmtpMaxRecipients 属性配置为 64,000 个收件人。如果 Exchange Server 分析工具发现该属性的值不为 64000，则会显示非默认配置消息。

从安全的角度讲，限制每个邮件的最大收件人数是最佳实践。每个组织都应确定对于自己而言可接受的值。除非有足够的理由需要将该属性配置为其他值，否则建议将 msExchSmtpMaxRecipients 属性保留在默认设置 64000。

查看并配置最大收件人数

  1. 在 Exchange 系统管理器中，依次展开"服务器"、Exchange 服务器、"协议"、"SMTP"。

  2. 用鼠标右键单击 SMTP 虚拟服务器（例如，默认 SMTP 虚拟服务器），然后选择"属性"。

  3. 选择"邮件"选项卡。

  4. 若要还原为默认设置 64000，请确保选中"限制每封邮件的收件人数不超过"复选框，然后输入值 64000。或者，可以对该字段配置所需的任意值，或清除该复选框以便允许任意多的收件人。

  5. 单击"确定"保存更改，并关闭 SMTP 虚拟服务器的"属性"对话框。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列 Microsoft 知识库文章：

  • 266686"XCON:如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)

  • 268163"XCON:How to Configure a SMTP Virtual Server Part 2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpMaxSessionSize 值已更改为默认值 0 以外的值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定配置的 msExchSmtpMaxSessionSize 属性值是否已从默认值 0 更改为其他值。默认情况下，msExchSmtpMaxSessionSize 属性被配置为不限制邮件大小。如果 Exchange Server 分析工具发现该属性值不为 0，则显示警告消息。

msExchSmtpMaxSessionSize 属性表示每个 SMTP 会话可以接受的最大数据量（KB）。出于安全性考虑，限制发送到和来自 Internet 的邮件的 SMTP 会话的大小是最佳实践。但是，对于内部 SMTP 会话，如同一组织中的 Exchange 服务器之间的会话，建议将 msExchSmtpMaxSessionSize 属性设置为 0。

在内部，Exchange 使用 SMTP 邮件处理如公用文件夹复制等任务。如果 msExchSmtpMaxSessionSize 属性配置了太低的限制，则会导致公用文件夹复制问题和其他组织内邮件传递失败问题。

如果此 Exchange 服务器是传输来自和发往 Internet 的 SMTP 邮件的桥头服务器，则可放心地忽略此警告。如果此 Exchange 服务器处理内部 SMTP 邮件，则应该将 msExchSmtpMaxSessionSize 属性的值改回默认设置 0。

查看并配置 SMTP 会话的最大大小

  1. 打开 Exchange 系统管理器。

  2. 展开"服务器"，再展开"Exchange 服务器"，展开"协议"，再展开"SMTP"。

  3. 用鼠标右键单击 SMTP 虚拟服务器（例如默认 SMTP 虚拟服务器），再单击"属性"。

  4. 用鼠标单击"邮件"。

  5. 若要还原为默认设置 0，请清除"限制会话大小不超过(KB)"复选框。或者，仍然选中此框，并配置任何所需的值。

  6. 单击"确定"以保存更改，并关闭 SMTP 虚拟服务器的"属性"对话框。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列 Microsoft 知识库文章：

  • 266686"XCON:如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)

  • 268163"XCON:How to Configure a SMTP Virtual Server Part 2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpOutgoingPort 值已从默认值 25 更改为其他值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchSmtpOutgoingPort 属性的配置值是否已从默认值 25 更改为其他值。默认情况下，msExchSmtpOutgoingPort 属性配置为 TCP 端口 25。如果 Exchange Server 分析工具发现该属性配置为 25 以外的端口，则会显示警告。

默认情况下，简单邮件传输协议 (SMTP) 服务器配置为在 TCP 端口 25 上接受入站连接。msExchSmtpOutgoingPort 参数代表此 Exchange 服务器将尝试连接到的所有远程 SMTP 服务器上的 TCP 端口。如果远程 SMTP 服务器未配置为侦听此端口，将无法建立连接。

除非整个或部分内部邮件基础结构已修改为使用非标准端口，否则建议对所有 SMTP 通信使用 TCP 端口 25。

查看或更改默认传出 SMTP 端口

  1. 在 Exchange 系统管理器中，依次展开"服务器"、Exchange 服务器、"协议"、"SMTP"。

  2. 用鼠标右键单击某个 SMTP 虚拟服务器（如默认 SMTP 虚拟服务器），再单击"属性"。

  3. 单击"传递"，再单击"出站连接"。

  4. 在 TCP 端口字段中，输入要用于出站连接的端口。您要与之进行通信的每个远程 SMTP 都必须配置为在指定端口上接受连接。在大多数情况下，不需要更改该值。

  5. 根据需要更改该字段，再单击"确定"保存更改。

  6. 单击"确定"关闭 SMTP 虚拟服务器的"属性"对话框。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列 Microsoft 知识库文章：

  • 266686"XCON:如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)

  • 268163"XCON:How to Configure a SMTP Virtual Server Part 2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpRelayForAuth 值已从默认值 True 更改为其他值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定配置的 msExchSmtpRelayForAuth 属性值是否已从默认值更改为其他值。默认情况下，msExchSmtpRelayForAuth 属性的值配置为 True。如果 Exchange Server 分析工具发现 msExchSmtpRelayForAuth 属性的值不为 True，则显示非默认配置消息。

当该值设置为 True 时，只有已通过身份验证的 SMTP 连接才能够通过此 SMTP 虚拟服务器中继 SMTP 邮件。如果此设置已更改为 False，则意味着 SMTP 虚拟服务器"属性"对话框的"中继"设置中的"不管上表中如何设置，所有通过身份验证的计算机都可以进行中继"复选框被清除。

中继是使用与 SMTP 服务器的入站连接来向外部域发送电子邮件的操作。要发送未经请求的商业电子邮件，只需通过这种方式向 SMTP 服务器发送具有组织外部的域中的多个收件人的单个电子邮件即可。由于 SMTP 服务器的默认设置是使用匿名身份验证，因此用于传播未经请求的商业电子邮件的系统像通常一样接受入站邮件。

邮件被接受后，SMTP 服务器识别出邮件收件人属于外部域，然后传递邮件。因此，未经授权的用户要发送未经请求的商业电子邮件，只须向 SMTP 服务器发送一个入站邮件即可，然后该邮件可以传递给数千个收件人，从而导致 Exchange Server 计算机的响应速度减慢、队列拥塞以及收件人对其收件箱中受到未经请求的邮件的抱怨。

控制中继的主要方式是不将中继权限授予其他任何主机。但是，有时也需要中继。例如，如果有邮局协议 (POP3) 和 Internet 邮件访问协议 (IMAP4) 客户端，则需要中继，因为这两个客户端依赖 SMTP 来传递邮件，因此有向外部域发送电子邮件的合理理由。可以通过创建专门接收来自 POP3 和 IMAP4 客户端的电子邮件的第二个 SMTP 虚拟服务器来解决此问题。这一额外的 SMTP 虚拟服务器可以将身份验证与基于安全套接字层 (SSL) 的加密结合起来使用，并且可以进行配置以便对已通过身份验证的客户端启用中继。有关实现此配置的详细信息，请参阅 Microsoft 知识库文章 31926"如何在Exchange 2000 Server 中保证简单邮件传输协议客户端邮件传递的安全"(http://support.microsoft.com/kb/319267/zh-cn)。

在系统管理器中查看或修改 msExchSmtpRelayForAuth 值

  1. 打开 Exchange 系统管理器。

  2. 依次展开"服务器"、Exchange 服务器、"协议"、"SMTP"。

  3. 用鼠标右键单击某个 SMTP 虚拟服务器（例如，默认 SMTP 虚拟服务器），再单击"属性"。

  4. 选择"访问"选项卡，再单击"中继"。

  5. 清除或选中"不管上表中如何设置，所有通过身份验证的计算机都可以进行中继"复选框。

  6. 单击"确定"保存更改。

如果选中此框，msExchSmtpRelayForAuth 属性应设置为 True。如果清除此框，msExchSmtpRelayForAuth 属性应设置为 False。

有关控制哪些帐户可以中继邮件的其他信息，请参阅下列 Microsoft 知识库文章：

  • 818778"Users Without Permissions to Relay Messages Can Still Send Messages Through the SMTP Virtual Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=818778)。

  • 310380"HOW TO:在 Windows 2000 中防止将 Exchange 2000 用作邮件中继"(http://support.microsoft.com/kb/310380/zh-cn)


msExchSmtpSmartHostType 值已从默认值 0 更改为其他值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定是否已将 msExchSmtpSmartHostType 属性的默认值 0 更改为配置的值。默认情况下，msExchSmtpSmartHostType 属性设置为 0。如果 Exchange Server 分析工具发现该属性的值不是 0，则显示非默认配置消息。

msExchSmtpSmartHostType 属性表明 SMTP 虚拟服务器是否配置为使用智能主机来传递邮件。可以通过智能主机路由发送到远程域的所有传出邮件，而不是直接将这些邮件发送到收件人域。下表详细说明了当 Exchange 配置为使用智能主机时，msExchSmtpSmartHostType 属性的值的更改。

智能主机设置 | msExchSmtpSmartHostType 属性值
无智能主机 | 0
智能主机 | 2
使用智能主机，但首先尝试直接传递 | 1

在 Exchange Server 2003 计算机上，该值为 0 或 2。在 Exchange 2000 Server 计算机上，该值可以为 0、1 或 2。当选中了"发送到智能主机之前尝试直接进行传递"复选框时，该值设置为 1。此复选框仅仅出现在 Exchange 2000 Server 计算机上。Exchange Server 2003 不包含此复选框。

除非有特定的理由，否则建议将 msExchSmtpSmartHostType 属性保留在默认设置 0。

如果您的环境需要智能主机，并且环境中有（或者计划有）多台 Exchange Server 计算机，则建议对所有智能主机条目使用 SMTP 连接器。这样所有内部邮件都将通过 Exchange Server 路由，只有外部邮件才通过智能主机路由。

查看和配置智能主机设置

  1. 打开 Exchange 系统管理器。

  2. 展开"服务器"，展开 Exchange 服务器，展开"协议"，再展开"SMTP"。

  3. 用鼠标右键单击 SMTP 虚拟服务器（例如，默认 SMTP 虚拟服务器），并选择"属性"。

  4. 选择"传递"选项卡，再单击"高级"。

  5. 输入要使用的智能主机。可以通过完全限定域名或 IP 地址来标识智能主机。如果使用 IP 地址，必须在其两侧加上方括号 ([ ])。Exchange 将首先查找服务器名，然后再查找 IP 地址。方括号表示该值是 IP 地址，从而避免了 DNS 查找。

  6. 如果这是 Exchange 2000 Server 计算机，可以选中"发送到智能主机之前尝试直接进行传递"复选框。

  7. 单击"确定"保存更改，再单击"确定"关闭 SMTP 虚拟服务器的"属性"对话框。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列 Microsoft 知识库文章：

  • 266686"XCON:如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)

  • 268163"XCON:How to Configure a SMTP Virtual Server Part 2"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=268163)


MTA 堆栈服务配置为与台式机交互
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Microsoft Exchange MTA 堆栈 (MSExchangeMTA) 服务的 DesktopInteract 属性值。如果 Exchange Server 分析工具发现 MTA 服务配置为与台式机交互，则 Exchange Server 分析工具将显示错误。

此配置只应当在 Microsoft 产品支持服务 (PSS) 的指导下使用。除非 PSS 指导您在此配置中运行 MTA 服务，否则，建议重新配置 MTA 堆栈服务的属性，使其不会与台式机交互。

配置 Exchange MTA Stacks 服务帐户

  1. 打开"服务"MMC 管理单元。

  2. 找到并停止 Microsoft Exchange MTA Stacks 服务。

  3. 双击 Microsoft Exchange MTA Stacks 服务。

  4. 在"Microsoft Exchange MTA Stacks 属性"页的"登录"选项卡上，在"登录作为"下选择"本地系统帐户"。

  5. 清除"允许服务与台式机交互"复选框，再单击"应用"。

  6. 在"服务状态"下，单击"启动"，再单击"确定"。

  7. 关闭"服务"管理单元。

有关正确的 Exchange 服务配置的详细信息，请参阅 Microsoft 知识库文章 239762"Exchange Services Run Under LocalSystem"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)。


找不到"MX"记录的"主机"记录
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-03

Microsoft® Exchange Server 分析工具执行域名系统 (DNS) 查找，以检索域的邮件交换器 (MX) 记录。如果成功检索到了 MX 记录，则 Exchange Server 分析工具接下来会执行 DNS 查找，以检索 MX 记录指向的服务器的主机 (A) 记录。如果 DNS 查找操作没有返回其中任何一个主机 (A) 记录的 IP 地址，则 Exchange Server 分析工具就会显示错误。

该错误表示服务器可能丢失 DNS 主机 (A) 记录。该错误可能导致发往远程域的邮件在 Exchange 服务器"远程传递"队列中进行备份。此错误还可能导致其他路由或服务出现延迟。

对 MX 记录的主机 (A) 记录进行 DNS 查找可能会由于以下原因而失败：

  • DNS 服务器停机，或者因为网络故障或其他原因而无法作出响应。

  • 由于远程服务器的主机 (A) 记录不可用或不正确，DNS 服务器丢失此记录。

  • 未将 DNS 服务器配置为启用动态主机记录更新。

验证 DNS 服务器是否联机以及主机记录是否存在

  1. 通过执行下列一项或多项检查来验证 DNS 服务器是否正在运行：

    • 从 DNS 服务器上的 DNS 管理程序中查看 DNS 服务器的状态。

    • 重新启动 DNS 服务器。有关详细信息，请参阅"Start, stop, pause, or restart a DNS server"（英文）(http://go.microsoft.com/fwlink/?LinkId=62999)。

    • 使用 nslookup 命令验证 DNS 服务器是否响应。有关详细信息，请参阅"Verify DNS server responsiveness using the nslookup command"（英文）(http://go.microsoft.com/fwlink/?LinkId=63000)。

  2. 使用 nslookup 验证 DNS 服务器上是否存在主机 (A) 记录。有关详细信息，请参阅"To verify A resource records exist in DNS"（英文）(http://go.microsoft.com/fwlink/?LinkId=63001)。

  3. 如果主机 (A) 资源记录不存在，请手动添加或修改 A 资源记录，或将 DNS 服务器配置为启用动态记录更新：

    • 手动添加 A 资源记录。有关详细信息，请参阅"Add a resource record to a DNS zone"（英文）(http://go.microsoft.com/fwlink/?LinkId=63002)。

    • 手动修改 A 资源记录。有关详细信息，请参阅"Modify an existing resource record"（英文）(http://go.microsoft.com/fwlink/?LinkId=63014)。

    • 将 DNS 服务器配置为启用动态主机记录更新。有关详细信息，请参阅 Microsoft 知识库文章 816592"How to configure DNS dynamic updates in Windows Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592)。

详细信息

  • 有关 Exchange Server 2003 如何使用 DNS 解析外部 IP 地址的信息，请参阅"Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"Exchange Server 2003 的传输依赖性"。

  • 有关 DNS 名称解析的信息，请参阅 Microsoft 知识库文章 322856"如何配置 DNS 以用于 Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)。

  • 有关如何解决 DNS 问题的信息，请参阅"Troubleshooting DNS"（英文）(http://go.microsoft.com/fwlink/?LinkId=63003)。

  • 有关 Exchange Server 2003 系统监视的信息，请参阅"Exchange Server 2003 Management Pack Guide for MOM 2000 SP1"(http://go.microsoft.com/fwlink/?LinkId=47573) 中的"Chapter 3: System Monitoring with Exchange Server 2003 Management Pack"（英文）。

  • 有关主机 (A) 资源记录的信息，请参阅"Managing Resource Records"（英文）(http://go.microsoft.com/fwlink/?LinkId=63004)。


找不到"主机"记录
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-04

Microsoft® Exchange Server 分析工具执行域名系统 (DNS) 查找，以检索 Exchange 服务器正尝试将邮件发送到的远程服务器的主机 (A) 记录。如果 DNS 查找操作没有返回任何 IP 地址，则 Exchange Server 分析工具就会显示错误。

该错误表示远程服务器可能丢失 DNS 主机 (A) 记录。此错误可能导致邮件在 Exchange 服务器"远程传递"队列中进行备份。

对远程服务器的主机 (A) 记录进行 DNS 查找可能会由于以下原因而失败：

  • DNS 服务器停机，或者因为网络故障或其他原因而无法作出响应。

  • 由于远程服务器的主机 (A) 记录不可用或不正确，DNS 服务器丢失此记录。

  • 未将 DNS 服务器配置为启用动态主机记录更新。

验证 DNS 服务器是否联机以及主机记录是否存在

  1. 通过执行下列一项或多项检查来验证 DNS 服务器是否正在运行：

    • 从 DNS 服务器上的 DNS 管理程序中查看 DNS 服务器的状态。

    • 重新启动 DNS 服务器。有关详细信息，请参阅"Start, stop, pause, or restart a DNS server"（英文）(http://go.microsoft.com/fwlink/?LinkId=62999)。

    • 使用 nslookup 命令验证 DNS 服务器是否响应。有关详细信息，请参阅"Verify DNS server responsiveness using the nslookup command"（英文）(http://go.microsoft.com/fwlink/?LinkId=63000)。

  2. 使用 nslookup 验证 DNS 服务器上是否存在主机 (A) 记录。有关详细信息，请参阅"To verify A resource records exist in DNS"（英文）(http://go.microsoft.com/fwlink/?LinkId=63001)。

  3. 如果主机 (A) 资源记录不存在，请手动添加或修改 A 资源记录，或将 DNS 服务器配置为启用动态记录更新：

    • 手动添加 A 资源记录。有关详细信息，请参阅"Add a resource record to a DNS zone"（英文）(http://go.microsoft.com/fwlink/?LinkId=63002)。

    • 手动修改 A 资源记录。有关详细信息，请参阅"Modify an existing resource record"（英文）(http://go.microsoft.com/fwlink/?LinkId=63014)。

    • 将 DNS 服务器配置为启用动态主机记录更新。有关详细信息，请参阅 Microsoft 知识库文章 816592"How to configure DNS dynamic updates in Windows Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592)。
  • 有关 Exchange Server 2003 如何使用 DNS 解析外部 IP 地址的信息，请参阅"Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"Exchange Server 2003 的传输依赖性"。

  • 有关 DNS 名称解析的信息，请参阅 Microsoft 知识库文章 322856"如何配置 DNS 以用于 Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)。

  • 有关如何解决 DNS 问题的信息，请参阅"Troubleshooting DNS"（英文）(http://go.microsoft.com/fwlink/?LinkId=63003)。

  • 有关 Exchange Server 2003 系统监视的信息，请参阅"Exchange Server 2003 Management Pack Guide for MOM 2000 SP1"(http://go.microsoft.com/fwlink/?LinkId=47573) 中的"Chapter 3: System Monitoring with Exchange Server 2003 Management Pack"（英文）。

  • 有关主机 (A) 资源记录的信息，请参阅"Managing Resource Records"（英文）(http://go.microsoft.com/fwlink/?LinkId=63004)。


找不到"MX"记录
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具查询它所使用的域名系统 (DNS) 服务器，以查找接收 Exchange 邮件的远程域的邮件交换器 (MX) 记录。

如果 Exchange Server 分析工具无法从所用的 DNS 服务器中检索到远程域的 MX 记录，则 Exchange Server 分析工具将显示警告。

该警告表明远程域可能丢失了 DNS MX 记录。

为了确定邮件主机，发送 Exchange 服务器会检查 MX 记录。接下来，发送服务器通过检查地址 (A) 记录将 MX 记录解析为 IP 地址。

如果远程域的 MX 记录丢失，则除了会导致其他路由或服务延迟之外，还会导致发往远程域的邮件在 Exchange 服务器"远程传递"队列中进行备份。

如果 DNS 服务器停机或由于网络故障或其他原因而不可访问，则 MX 记录的 DNS 查找会失败。

验证 DNS 服务器是否联机以及 MX 记录是否存在

  1. 通过执行下列一项或多项检查来验证 DNS 服务器是否正在运行：

    • 从 DNS 服务器上的 DNS 管理程序中查看 DNS 服务器的状态。

    • 重新启动 DNS 服务器。有关详细信息，请参阅"Start, stop, pause, or restart a DNS server"（英文）(http://go.microsoft.com/fwlink/?LinkId=62999)。

    • 使用 nslookup 命令验证 DNS 服务器是否响应。有关详细信息，请参阅"Verify DNS server responsiveness using the nslookup command"（英文）(http://go.microsoft.com/fwlink/?LinkId=63000) 中的说明。

  2. 使用 nslookup 来验证是否正确配置了 MX 记录。有关详细信息，请参阅"Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"验证 DNS 设计和配置"部分的"如何使用 Nslookup 来验证 MX 记录配置"。

详细信息

  • 有关 Exchange Server 2003 如何使用 DNS 解析外部 IP 地址的信息，请参阅"Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"Exchange Server 2003 的传输依赖性"。

  • 有关 DNS 名称解析的信息，请参阅 Microsoft 知识库文章 322856"如何配置 DNS 以用于 Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)。

  • 有关如何解决 DNS 问题的信息，请参阅"Troubleshooting DNS"（英文）(http://go.microsoft.com/fwlink/?LinkId=63003)。

  • 有关 Exchange Server 2003 系统监视的信息，请参阅"Exchange Server 2003 Management Pack Guide for MOM 2000 SP1"(http://go.microsoft.com/fwlink/?LinkId=47573) 中的"Chapter 3: System Monitoring with Exchange Server 2003 Management Pack"（英文）。


在传输限制中找到了嵌套的通讯组
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-08-21

Microsoft® Exchange Server 分析工具将查询 Active Directory® 目录服务中找到的所有域内的每个通讯组对象的下列属性，以确定是否已使用任何组来设置基于组中成员身份的传递限制：

dLMemRejectPermsBL | 包含不接受来自该组的邮件的收件人或连接器的 DN。
dLMemSubmitPermsBL | 包含接受来自该组的邮件的收件人或连接器的 DN。

如果 Exchange Server 分析工具发现已使用组对象来设置传递限制，则 Exchange Server 分析工具将检查这些组，以确定它们是否包含任何嵌套的组。

Exchange Server 分析工具还将读取以下注册表项，以确定 RestrictionMethod 注册表值是否存在，以及该注册表值的配置方式：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

如果下列条件为真，Exchange Server 分析工具将显示警告：

  • 已使用通讯组成员身份来设置传递限制。

  • 已设置传递限制的通讯组中存在嵌套的通讯组。

  • RestrictionMethod 注册表值存在，并且未设置为强制非分层限制检查。

此错误指示基于通讯组成员身份的传递限制可能会极大地影响 Exchange 邮件流性能。

分类程序的默认行为是以递归方式展开通讯组，并检查通过系统传递的每封邮件的限制。

如果将邮件发送到接受或拒绝来自通讯组的邮件的用户，或者发送的邮件需要通过接受或拒绝来自通讯组的邮件的连接器，那么，邮件分类程序必须展开通讯组的成员身份，获取成员 DN 的完整列表，然后将此 DN 列表与发件人 DN 列表进行比较。如果两个列表上的 DN 匹配，则会执行访问操作或拒绝操作。如果某个通讯组嵌套在另一个通讯组中，则也会展开嵌套的通讯组。

RestrictionMethod 值确定分类程序处理限制的方式。如果将 RestrictionMethod 值设置为 2，则运行 Exchange Server 的此服务器上的传输组件在服务器检查限制时不会展开通讯组的成员身份。此配置使限制检查可以实现最高性能。此外，要使 RestrictionMethod 注册表项生效，所有通讯组（包括具有传递限制的用户）都必须是非分层组。也就是说，受限制的通讯组不得包含嵌套的通讯组。如果嵌套了受限制的通讯组，则将无法使用展开逻辑。

对于连接器限制中使用的通讯组，建议您在没有邮箱的连接器桥头服务器上设置 RestrictionMethod 注册表项值。对于 Active Directory 用户限制，如果受限制的通讯组包含扩展服务器，建议您在扩展服务器上创建 RestrictionMethod 注册表项。

若要解决此错误，请执行下列操作：

  • 检查已设置通讯组传递限制的那些用户，然后删除不必要的限制。

  • 配置各个邮箱，而不是配置传递限制的通讯组，请参考 Microsoft 知识库文章 812298"Mail delivery is slow after you configure delivery restrictions that are based on a distribution list"（配置基于通讯组列表的传递限制后，邮件传递的速度将会减慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。

  • 对于运行 Microsoft Exchange Server 2003 Service Pack 2 (SP2) 或更高版本的服务器，请考虑实现非分层限制检查。对于运行早于 Exchange 2003 SP2 的 Exchange 版本的服务器，请考虑升级为 Exchange 2003 SP2。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
创建 RestrictionMethod 注册表项并将其值设置为 2

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

  3. 在左侧窗格中，单击"参数"。

  4. 在"编辑"菜单上，指向"新建"，然后单击"DWORD 值"。

  5. 键入 RestrictionMethod，再按 ENTER 为新的注册表项命名。

  6. 用鼠标右键单击 RestrictionMethod，再单击"修改"。

  7. 键入 2，再按 ENTER。

  8. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

详细信息

有关非分层限制检查的详细信息，请参阅考虑非层次限制检查。

有关通讯组限制对 Exchange 邮件流的影响的详细信息，请参阅下列 Microsoft 知识库文章：

  • 895407"In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"（在 Exchange Server 2003 中，配置基于通讯组的传递限制后，向本地邮箱和外部邮箱传递邮件的速度比预期速度要慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 839949"Troubleshooting mail transport and distribution groups in Exchange 2000 Server and in Exchange Server 2003"（排除 Exchange 2000 Server 和 Exchange Server 2003 中的邮件传输和通讯组问题）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。

  • 812298"Mail delivery is slow after you configure delivery restrictions that are based on a distribution list"（配置基于通讯组列表的传递限制后，邮件传递的速度将会减慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。

有关 RestrictionMethod 注册表值的详细信息，请参阅 Microsoft 知识库文章 895407"In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"（在 Exchange Server 2003 中，配置基于通讯组的传递限制后，向本地邮箱和外部邮箱传递邮件的速度比预期速度要慢）http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

有关注册表值的详细信息，请参阅 Microsoft 知识库文章 277872"XCON:Connector Delivery Restrictions May Not Work Correctly"（XCON：连接器传递限制可能无法正常运行）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872)。


找到了嵌套的通讯组，但已启用非分层限制检查
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-08-21

Microsoft® Exchange Server 分析工具将查询 Active Directory® 目录服务中找到的所有域内的每个通讯组对象的下列属性，以确定是否已使用任何组并根据组中的成员身份来设置传递限制：

dLMemRejectPermsBL | 包含不接受来自该组的邮件的收件人或连接器的 DN。
dLMemSubmitPermsBL | 包含接受来自该组的邮件的收件人或连接器的 DN。

如果 Exchange Server 分析工具发现已使用组对象来设置传递限制，则 Exchange Server 分析工具将检查这些组，以确定它们是否包含任何嵌套的组。

Exchange Server 分析工具还将读取以下注册表项，以确定 RestrictionMethod 注册表值是否存在，以及该注册表值的配置方式：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

如果下列条件为真，Exchange Server 分析工具将显示警告：

  • 已使用通讯组成员身份来设置传递限制。

  • 已设置传递限制的通讯组中存在嵌套的通讯组。

  • RestrictionMethod 注册表值存在，并且已设置为强制非分层限制检查。

此警告指示，尽管 RestrictionMethod 注册表值已设置为强制非分层限制检查，但是，已设置传递限制的通讯组中嵌入（嵌套）了其他通讯组。如果通讯组包含嵌套的通讯组，则非分层限制检查将不能正确识别允许或拒绝的发件人。使用非分层限制检查时，将不扩展嵌套的通讯组。

分类程序的默认行为是以递归方式展开通讯组，并检查通过系统传递的每封邮件的限制。

如果将邮件发送到接受或拒绝来自通讯组的邮件的用户，或者发送的邮件需要通过接受或拒绝来自通讯组的邮件的连接器，那么，邮件分类程序必须展开通讯组的成员身份，获取成员 DN 的完整列表，然后将此 DN 列表与发件人 DN 列表进行比较。如果两个列表上的 DN 匹配，则会执行访问操作或拒绝操作。如果某个通讯组嵌套在另一个通讯组中，则也会展开嵌套的通讯组。

RestrictionMethod 值确定分类程序如何处理限制。如果将 RestrictionMethod 值设置为 2，则运行 Exchange Server 的此服务器上的传输组件在服务器检查限制时不会展开通讯组的成员身份。此配置使限制检查可以实现最高性能。此外，要使 RestrictionMethod 注册表项生效，所有通讯组（包括具有传递限制的用户）必须是非分层的。也就是说，受限制的通讯组不得包含嵌套的通讯组。

要解决此警告，在已启用非分层限制检查的情况下，不要将通讯组嵌套在用于传递限制的其他通讯组中。

详细信息

有关非分层限制检查的详细信息，请参阅考虑非层次限制检查。

有关通讯组限制对 Exchange 邮件流的影响的详细信息，请参阅下列 Microsoft 知识库文章：

  • 895407"In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"（在 Exchange Server 2003 中，配置基于通讯组的传递限制后，向本地邮箱和外部邮箱传递邮件的速度比预期速度要慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 839949"Troubleshooting mail transport and distribution groups in Exchange 2000 Server and in Exchange Server 2003"（排除 Exchange 2000 Server 和 Exchange Server 2003 中的邮件传输和通讯组问题）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。

  • 812298"Mail delivery is slow after you configure delivery restrictions that are based on a distribution list"（配置基于通讯组列表的传递限制后，邮件传递的速度将会减慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。

有关 RestrictionMethod 注册表值的详细信息，请参阅 Microsoft 知识库文章 895407"In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"（在 Exchange Server 2003 中，配置基于通讯组的传递限制后，向本地邮箱和外部邮箱传递邮件的速度比预期速度要慢）http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

有关该注册表值的详细信息，请参阅 Microsoft 知识库文章 277872"XCON: Connector Delivery Restrictions May Not Work Correctly"（XCON：连接器传递限制可能无法正常运行）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872)。


未收到来自指定发件人的邮件
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-03-07

Microsoft Exchange Server 分析工具将查询所有用户对象的 Active Directory 目录服务 proxyAddress 属性值，以确定用户指定的本地发件人简单邮件传输协议 (SMTP) 地址是否存在匹配项。

如果找到用户对象的 proxyAddress 匹配项，则 Exchange Server 分析工具将查询用户对象的 Active Directory msExchHomeServerName 属性值，以确定该值是否与用户指定的 Exchange Server 名称匹配。

最后，Exchange Server 分析工具将查询 root\MicrosoftExchangeV2 命名空间下 Exchange_MessageTrackingEntry Microsoft Windows Management Instrumentation (WMI) 类的 SenderAddress 属性，以便将邮件跟踪日志跟踪的任何邮件标识为来自用户指定的发件人。

如果 Exchange Server 分析工具无法找到带有与用户指定发件人的 legacyDN 或 SMTP 地址匹配的 senderAddress 属性值的邮件跟踪日志条目，则 Exchange Server 分析工具将显示错误。

  • 此错误指示存在下列一种或多种情况：

  • 用户指定的发件人未发送任何邮件。

  • 已经过邮件跟踪日志的保留期，并且已删除相关的日志条目。

  • 未对服务器启用邮件跟踪。

若要解决该问题，请执行下列操作：

  • 让指定的发件人向指定的收件人提交另一封邮件。

  • 启用邮件跟踪中心。

  • 增加邮件跟踪日志保留期，或跟踪时间更近的邮件。

有关如何启用邮件跟踪中心的详细信息，请参阅"Exchange Server and Transport Routing Guide"（Exchange Server 传输和路由指南）的"Troubleshooting Mail Flow and SMTP"（排除邮件流和 SMTP 故障）(http://go.microsoft.com/fwlink/?LinkID=67875)中的"如何在服务器上启用邮件跟踪中心"（如何在服务器上启用邮件跟踪中心）(http://go.microsoft.com/fwlink/?LinkId=71257)。

有关如何使用邮件跟踪的详细信息，请参阅 Microsoft 知识库文章 262162"XADM：使用邮件跟踪中心来跟踪邮件"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162)。


未向指定的收件人发送邮件
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-12-07

Microsoft® Exchange Server 分析工具将查询所有用户对象的 Active Directory® 目录服务 proxyAddress 属性值，以确定用户指定的本地发件人简单邮件传输协议 (SMTP) 地址是否存在匹配项。

如果找到用户对象的 proxyAddress 匹配项，则 Exchange Server 分析工具将查询用户对象的 Active Directory msExchHomeServerName 属性值，以确定该值是否与用户指定的 Exchange Server 名称匹配。

然后，Exchange Server 分析工具将查询 root\MicrosoftExchangeV2 命名空间下 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 类的 SenderAddress 属性，以便将邮件跟踪日志跟踪的任何邮件标识为来自用户指定的发件人。

最后，Exchange Server 分析工具将查询 Exchange_MessageTrackingEntry WMI 类的 RecipientAddress 属性，以便将邮件跟踪日志跟踪的任何邮件标识为发往用户指定的收件人。

如果 Exchange Server 分析工具无法找到带有与用户指定收件人的 SMTP 地址匹配的 RecipientAddress 属性值的邮件跟踪日志条目，则 Exchange Server 分析工具将显示错误。

此错误指示存在下列一种或多种情况：

  • 用户指定的发件人未向用户指定的收件人发送任何邮件。

  • 已经过邮件跟踪日志的保留期，并且已删除相关的日志条目。

若要解决该问题，请执行下列操作：

  • 验证指定的收件人地址是否正确。

  • 让指定的发件人向指定的收件人提交另一封邮件。

  • 增加邮件跟踪日志保留期，或跟踪时间更近的邮件。

有关如何增加邮件跟踪中心日志保留期的详细信息，请参阅"How to Enable Message Tracking Center on a Server"（如何在服务器上启用邮件跟踪中心）(http://go.microsoft.com/fwlink/?LinkID=71257)。

有关如何使用邮件跟踪的详细信息，请参阅 Microsoft 知识库文章 262162"XADM：使用邮件跟踪中心来跟踪邮件"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162)。


队列状态不可用。SMTP 队列分析已中止。
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-03-15

Microsoft Exchange 分析工具查询 ExchangeLink Microsoft Windows Management Instrumentation (WMI) 类，以检查 Exchange 服务器的简单邮件传输协议 (SMTP) 队列的状态。

SMTP 是 Exchange Server 进行邮件提交和邮件传输的本机邮件协议。这意味着客户端使用 SMTP 发送邮件，而 Exchange 服务器使用 SMTP 传递邮件和邮件数据。

ExchangeLink WMI 类的属性返回有关邮件服务器之间邮件处理链接（队列）的信息。一个链接可以包含零个或多个 ExchangeQueue 对象。此数目取决于链接上的当前邮件通信。

SMTP 使用 SMTP 队列在内部和外部传递邮件。在邮件分类和传递过程中，高级队列引擎通过 SMTP 虚拟服务器的 SMTP 队列发送所有邮件。如果在该过程的任一点上传递邮件时出现问题，则邮件将保留在出现问题的队列中。

SMTP 队列描述

SMTP 队列 描述

[本地域名]（本地传递）

包含在 Exchange 服务器上排队的等待向 Exchange 邮箱或公用文件夹存储进行本地传递的邮件。

等待目录查找的邮件

包含尚未使用 Active Directory 目录服务解析收件人的邮件。展开通讯组列表时邮件也存放在此处。

等待路由的邮件

在确定下一个目标服务器之前存放邮件，然后将它们移动到其各自的链接队列中。

远程传递

[连接器名称|

服务器名称| 远程域]

存放要进行远程传递的邮件。队列的名称与远程传递目标（它可能是连接器、服务器或域）匹配。

当前无法到达最终目标

无法到达这些邮件的最终目标服务器。例如，Exchange 无法确定最终目标的网络路径。

预提交

存放 SMTP 服务已经确认和接受的邮件。尚未开始处理这些邮件。

暂缓提交的 DSN 邮件

包含可以由 Exchange 传递的传递状态通知（也称为未送达报告）。

注意 以下操作不适用于此队列：

  • 删除所有邮件（无 NDR）

  • 删除所有邮件 (NDR)

失败的邮件重试队列

包含某些队列提交失败但尚未对其进行其他处理操作的邮件。默认情况下，将在 60 分钟内对此队列中的邮件进行重新处理。

排队等候延迟传递的邮件

包含排队等候稍后传递的邮件，其中包括由 Outlook 早期版本发送的邮件。（可以在 Outlook 客户端计算机上设置此选项。）

Outlook 早期版本依赖于邮件传输代理 (MTA) 进行邮件传递。但现在是由 SMTP 来处理邮件传递，而不是 MTA。因此，Outlook 早期版本发送的邮件将以不同方式处理延迟的传递。

在预定的传递时间之前，这些邮件保留在此队列中。

如果 Exchange 分析工具无法成功完成对服务器的 ExchangeLink WMI 类的查询，则 Exchange 分析工具将显示错误。

此错误意味着 WMI 查询无法检索请求的数据。

此错误可能是由如下原因造成的：

  • 运行 Exchange 分析工具的帐户没有足够的权限，无法查询 WMI 类。

  • 网络问题使 Exchange 分析工具无法与计算机联系。

  • 未知源的短暂情况导致查询超时。

若要更正此错误，请执行下列操作：

  1. 确保 Exchange Server 计算机已启动并连接到了网络。

  2. 使用 PING 命令确定 Exchange Server 计算机是否可访问。

  3. 如果有防火墙，请检查以确定远程过程调用 (RPC) 端口是否被阻止。

  4. 检查用来运行 Exchange 分析工具的帐户的权限。用来运行 Exchange 分析工具的帐户在每个所扫描的 Exchange 服务器上必须具有本地管理员权限。

    也可以为用来运行 Exchange 分析工具的帐户授予特定的 WMI 权限：

    1. 在 Exchange 计算机上，打开"计算机管理"Microsoft 管理控制台 (MMC) 树。

    2. 在"服务和应用程序"下，右键单击"WMI 控件"，再单击"属性"。

    3. 在"WMI 控件属性"页上，单击"安全性"选项卡，再展开"根"。

    4. 选择 CIMV2 文件夹，再单击"安全性"。

    5. 在"ROOT\CIMV2 安全性"页上，添加用来运行 Exchange 分析工具的帐户。

  5. 请选择在上述步骤 5 中添加的帐户。在"所选帐户权限"中的"允许"列下，选择"远程启用"和"读取安全性"，然后单击"确定"。

有关解决网络连接问题的详细信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

有关解决 Exchange 最佳实践分析工具连接问题的详细信息，请参阅"Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"（解决连接问题的 Microsoft Exchange Server 最佳实践分析工具）(http://go.microsoft.com/fwlink/?LinkId=56285)。

有关端口要求的详细信息，请参阅 Microsoft 知识库文章 832017"Windows 服务器系统的服务概述和网络端口要求"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)。


没有远程服务器或域可用于 DNS 记录测试
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-07-06

Microsoft® Exchange Server 分析工具会尝试识别和生成远程服务器的完全限定的域名 (FQDN)、IP 地址和域名的列表，该远程服务器是远程传递队列中的邮件要发送到的服务器。

远程服务器的 FQDN、IP 地址和域名列表是按以下过程生成的：

  • 查询简单邮件传输协议 (SMTP) 虚拟服务器的 Active Directory® 目录服务对象的 msExchSmtpFullyQualifiedDomainName 属性。

    注意：
    针对指定的目标桥头服务器查询 msExchSmtpFullyQualifiedDomainName 属性时，又会从路由组连接器目录对象的 msExchTargetBridgeheadServersDN 属性中读取它。
  • 针对 SMTP 连接器的指定智能主机查询 SMTP 连接器 Active Directory 对象的 msExchSmtpSmartHost 属性。

  • 针对任何远程服务器直接连接查询 ExchangeLink Microsoft Windows® Management Instrumentation (WMI) 类的 LinkName 属性。

如果 Exchange Server 分析工具确定生成此列表的尝试未产生任何条目，则 Exchange Server 分析工具会显示一个错误。

此错误表明：

  • 可能存在导致邮件流问题的暂时性网络问题或 Active Directory 连接问题。

  • 运行 Exchange Server 分析工具的帐户可能没有足够的权限，无法查询信息。

纠正此错误

  1. 请确保已启动了 Exchange Server 计算机并已将其连接到网络。

  2. 验证是否具有到 Active Directory 域控制器的网络连接。

  3. 在 Exchange Server 分析工具中指定 Active Directory 域控制器。

  4. 使用 PING 命令来查看 Exchange Server 计算机是否可访问。

  5. 如果有防火墙，请检查是否阻止了 RPC 端口。

  6. 检查运行 Exchange Server 分析工具的帐户的权限。运行 Exchange Server 分析工具的帐户必须在其扫描的每台 Exchange Server 计算机上都具有本地管理员权限。

有关网络连接问题的详细信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

有关 Exchange Server 分析工具连接问题的详细信息，请参阅"Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"（解决连接问题的 Microsoft Exchange Server 最佳实践分析工具）(http://go.microsoft.com/fwlink/?LinkId=56285)。

有关端口需求的详细信息，请参阅 Microsoft 知识库文章 832017"Windows 服务器系统的服务概述和网络端口要求"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)。


没有可用于 SMTP 命令测试的服务器
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-10-16

Microsoft® Exchange Server 分析工具会尝试识别和生成远程服务器的完全限定的域名 (FQDN)、IP 地址和域名的列表，该远程服务器是远程传递队列中的邮件要发送到的服务器。

远程服务器的 FQDN、IP 地址和域名列表是按以下过程生成的：

  • 查询简单邮件传输协议 (SMTP) 虚拟服务器的 Active Directory® 目录服务对象的 msExchSmtpFullyQualifiedDomainName 属性。

    注意：
    针对指定的目标桥头服务器查询 msExchSmtpFullyQualifiedDomainName 属性时，又会从路由组连接器目录对象的 msExchTargetBridgeheadServersDN 属性中读取它。
  • 针对 SMTP 连接器的指定智能主机查询 SMTP 连接器 Active Directory 对象的 msExchSmtpSmartHost 属性。

  • 针对任何远程服务器直接连接查询 ExchangeLink Microsoft Windows® Management Instrumentation (WMI) 类的 LinkName 属性。

如果 Exchange Server 分析工具确定生成此列表的尝试未产生任何条目，则 Exchange Server 分析工具会显示一个错误。

此错误说明如下问题：

  • 时断时续的网络或 Active Directory 连接问题可能导致邮件流问题。

  • 运行 Exchange Server 分析工具的帐户可能没有足够的权限，无法查询信息。

更正此错误

  1. 确保已启动运行 Exchange Server 的服务器，并已将其连接到网络。

  2. 验证是否具有到 Active Directory 域控制器的网络连接。

  3. 在 Exchange Server 分析工具中指定 Active Directory 域控制器。

  4. 使用 PING 命令来查看是否可访问 Exchange 服务器。

  5. 如果有防火墙，请检查以确定远程过程调用 (RPC) 端口是否被阻止。

  6. 检查用来运行 Exchange Server 分析工具的帐户的权限。运行 Exchange Server 分析工具的帐户必须在其扫描的每台 Exchange Server 计算机上都具有本地管理员权限。

有关网络连接问题的详细信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

有关 Exchange Server 分析工具连接问题的详细信息，请参阅"Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"（解决连接问题的 Microsoft Exchange Server 最佳实践分析工具）(http://go.microsoft.com/fwlink/?LinkId=56285)。

有关端口需求的详细信息，请参阅 Microsoft 知识库文章 832017"Windows 服务器系统的服务概述和网络端口要求"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)。


没有服务器可用于连接测试
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-07-07

Microsoft® Exchange Server 分析工具会尝试识别和生成远程服务器的完全限定的域名 (FQDN)、IP 地址和域名的列表，该远程服务器是远程传递队列中的邮件要发送到的服务器。

  • 远程服务器的 FQDN、IP 地址和域名列表是按以下过程生成的：

  • 查询简单邮件传输协议 (SMTP) 虚拟服务器的 Active Directory® 目录服务对象的 msExchSmtpFullyQualifiedDomainName 属性。

    注意：
    针对指定的目标桥头服务器查询 msExchSmtpFullyQualifiedDomainName 属性时，又会从路由组连接器目录对象的 msExchTargetBridgeheadServersDN 属性中读取它。
  • 针对 SMTP 连接器的指定智能主机查询 SMTP 连接器 Active Directory 对象的 msExchSmtpSmartHost 属性。

  • 针对任何远程服务器直接连接查询 ExchangeLink Microsoft Windows® Management Instrumentation (WMI) 类的 LinkName 属性。

如果 Exchange Server 分析工具确定生成此列表的尝试未产生任何条目，则 Exchange Server 分析工具会显示一个错误。

此错误表明：

  • 可能存在导致邮件流问题的暂时性网络问题或 Active Directory 连接问题。

  • 运行 Exchange Server 分析工具的帐户可能没有足够的权限，无法查询信息。

纠正此错误

  1. 请确保已启动了 Exchange Server 计算机并已将其连接到网络。

  2. 验证是否具有到 Active Directory 域控制器的网络连接。

  3. 在 Exchange Server 分析工具中指定 Active Directory 域控制器。

  4. 使用 PING 命令来查看 Exchange Server 计算机是否可访问。

  5. 如果有防火墙，请检查是否阻止了 RPC 端口。

  6. 检查运行 Exchange Server 分析工具的帐户的权限。运行 Exchange Server 分析工具的帐户必须在其扫描的每台 Exchange Server 计算机上都具有本地管理员权限。

有关网络连接问题的详细信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

有关 Exchange Server 分析工具连接问题的详细信息，请参阅"Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"（解决连接问题的 Microsoft Exchange Server 最佳实践分析工具）(http://go.microsoft.com/fwlink/?LinkId=56285)。

有关端口需求的详细信息，请参阅 Microsoft 知识库文章 832017"Windows 服务器系统的服务概述和网络端口要求"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)。


没有服务器可用于 SMTP 实例名称检查
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-07-07

Microsoft® Exchange Server 分析工具会尝试识别和生成远程服务器的完全限定的域名 (FQDN)、IP 地址和域名的列表，该远程服务器是远程传递队列中的邮件要发送到的服务器。

远程服务器的 FQDN、IP 地址和域名列表是按以下过程生成的：

  • 查询简单邮件传输协议 (SMTP) 虚拟服务器的 Active Directory® 目录服务对象的 msExchSmtpFullyQualifiedDomainName 属性。

    注意：
    针对指定的目标桥头服务器查询 msExchSmtpFullyQualifiedDomainName 属性时，又会从路由组连接器目录对象的 msExchTargetBridgeheadServersDN 属性中读取它。
  • 针对 SMTP 连接器的指定智能主机查询 SMTP 连接器 Active Directory 对象的 msExchSmtpSmartHost 属性。

  • 针对任何远程服务器直接连接查询 ExchangeLink Microsoft Windows® Management Instrumentation (WMI) 类的 LinkName 属性。

如果 Exchange Server 分析工具确定生成此列表的尝试未产生任何条目，则 Exchange Server 分析工具会显示一个错误。

此错误表明：

  • 可能存在导致邮件流问题的暂时性网络问题或 Active Directory 连接问题。

  • 运行 Exchange Server 分析工具的帐户可能没有足够的权限，无法查询信息。

纠正此错误

  1. 请确保已启动了 Exchange Server 计算机并已将其连接到网络。

  2. 验证是否具有到 Active Directory 域控制器的网络连接。

  3. 在 Exchange Server 分析工具中指定 Active Directory 域控制器。

  4. 使用 PING 命令来查看 Exchange Server 计算机是否可访问。

  5. 如果有防火墙，请检查是否阻止了 RPC 端口。

  6. 检查运行 Exchange Server 分析工具的帐户的权限。运行 Exchange Server 分析工具的帐户必须在其扫描的每台 Exchange Server 计算机上都具有本地管理员权限。

有关网络连接问题的详细信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

有关 Exchange Server 分析工具连接问题的详细信息，请参阅"Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"（解决连接问题的 Microsoft Exchange Server 最佳实践分析工具）(http://go.microsoft.com/fwlink/?LinkId=56285)。

有关端口需求的详细信息，请参阅 Microsoft 知识库文章 832017"Windows 服务器系统的服务概述和网络端口要求"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)。


非默认的路由服务缓存设置
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否更改了默认的路由服务缓存设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\

如果 Exchange Server 分析工具发现 ServerCacheRefreshInterval 注册表值为手动创建，更改了默认的 Exchange Server 二进制设置 900，则 Exchange Server 分析工具将显示警告。默认情况下，Exchange Server 安装不创建 ServerCacheRefreshInterval 注册表值。但是，可以在 Exchange Server 安装之后手动创建 ServerCacheRefreshInterval 注册表值，以便更改默认的路由服务缓存设置。如果该注册表值已手动创建，但是注册表值的设置配置不当，Exchange 服务器可能会遇到邮件流问题。

建议在创建或修改 ServerCacheRefreshInterval 注册表值之前，一定要认真考虑。Exchange Server 的二进制默认值经过认真选择，在大多数 Exchange Server 环境下可以获得最佳性能。常见的最佳办法是解决问题的根本原因，而不是通过手动配置注册表来修改 Exchange Server 的默认行为。为了符合最佳办法，如果 ServerCacheRefreshInterval 注册表值存在，可能需要删除此注册表值，以便使 Exchange 服务器恢复路由服务缓存默认的二进制设置。但是，您的决定取决于 Exchange Server 自定义配置设置或 Exchange 环境。

Exchange Server 分析工具仅以提供信息为目的报告此配置。但是，可能需要通过编辑注册表来将该注册表值更改回默认设置。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何执行此操作的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
解决此警告问题

  1. 单击"开始"，再单击"运行"，键入 Regedit，然后单击"确定"。

  2. 在控制台树中，找到并单击下列注册表项： HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\RESvc\Parameters\

  3. 在详细信息窗格中，用鼠标右键单击 ServerCacheRefreshInterval 注册表值。将数值数据更改为 900。

  4. 也可以在详细信息窗格中用鼠标右键单击 ServerCacheRefreshInterval 注册表值，然后单击"删除"。在对话框中单击"是"来确认注册表值的删除。

  5. 重新启动 Exchange 服务器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关编辑 Microsoft Windows 注册表项的详细信息，请参阅下列 Microsoft 知识库文章：

  • 322755"如何在 Windows 2000 中备份、编辑和还原注册表"(http://support.microsoft.com/default.aspx?scid=kb;zh-cn;322755)

  • 322756"如何在 Windows XP 和 Windows Server 2003 中备份、编辑和还原注册表"(http://support.microsoft.com/kb/322756/zh-cn)。


非默认 SMTP LdapRequestTimeLimit 注册表值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否更改了默认的 LdapRequestTimeLimit：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

如果 Exchange Server 分析工具发现 LdapRequestTimeLimit 注册表值已手动创建，更改默认的 Exchange 服务器二进制设置 600 秒，Exchange Server 分析工具将显示非默认值警告消息。默认情况下，Exchange Server 安装不创建 LdapRequestTimeLimit 注册表值。但是，LdapRequestTimeLimit 注册表值可以在 Exchange Server 安装之后手动创建，以便更改单个 LDAP 请求在队列中等待的最长时间（秒）。如果该注册表值为手动创建，并且注册表值的设置配置不当，Exchange 服务器可能会遇到邮件传输问题。

建议在创建或修改 LdapRequestTimeLimit 注册表值之前，一定要认真考虑。Exchange 服务器的二进制默认值经过认真选择，在大多数 Exchange 服务器环境下可以获得最佳性能。常见的最佳办法是解决问题的根本原因，而不是通过手动配置注册表来修改 Exchange Server 的默认行为。为了符合最佳办法，如果 LdapRequestTimeLimit 注册表值存在，可能需要删除此注册表值，以便使 Exchange 服务器恢复默认的二进制设置。

Exchange Server 分析工具仅以提供信息为目的报告此配置。但是，可能需要通过编辑注册表来将该注册表值更改回默认设置。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何执行此操作的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
解决此警告问题

  1. 单击"开始"，再单击"运行"，键入 Regedit，然后单击"确定"。

  2. 在控制台树中，找到并单击下列注册表项： HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. 在详细信息窗格中，用鼠标右键单击 LdapRequestTimeLimit 注册表值。将数值数据更改为 600。

  4. 也可以在详细信息窗格中用鼠标右键单击 LdapRequestTimeLimit 注册表值，然后单击"删除"。在对话框中单击"是"来确认注册表值的删除。

  5. 重新启动 Exchange 服务器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关编辑 Microsoft Windows 注册表项的详细信息，请参阅下列 Microsoft 知识库文章：

  • 322755"HOW TO：在 Windows 2000 中备份、编辑和还原注册表"(http://support.microsoft.com/default.aspx?scid=kb;zh-cn;322755)

  • 322756"如何在 Windows XP 和 Windows Server 2003 中备份、编辑和还原注册表"(http://support.microsoft.com/default.aspx?scid=kb;zh-cn;322756)


非默认 SMTP LdapResultTimeout 注册表值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否更改了默认的 LdapResultTimeout：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

如果 Exchange Server 分析工具发现 LdapResultTimeout 注册表项已手动创建，更改默认的 Exchange 服务器二进制设置 121 秒，Exchange Server 分析工具将显示非默认值警告消息。默认情况下，Exchange Server 安装不创建 LdapResultTimeout 注册表项。但是，LdapResultTimeout 注册表项可以在 Exchange Server 安装之后手动创建，以便更改超时值。LdapResultTimeout 是分类程序的 LDAP 连接的 LDAP 完成线程等待处理的最长时间。如果已超时，并且没有从全局编录服务器收到任何新结果，连接上正在等待的搜索将失败，显示 LDAP_SERVER_DOWN，此过程使那些正在等待的搜索可以重新发给新连接。如果该注册表值为手动创建，并且注册表值的设置配置不当，Exchange 服务器可能会遇到邮件传输问题。

建议在创建或修改 LdapResultTimeout 注册表值之前，一定要认真考虑。Exchange Server 的二进制默认值经过认真选择，在大多数 Exchange Server 环境下可以获得最佳性能。常见的最佳办法是解决问题的根本原因，而不是通过手动配置注册表来修改 Exchange 的默认行为。为了符合最佳办法，如果 LdapResultTimeout 注册表值存在，可能需要删除此注册表值，以便使 Exchange 服务器恢复默认的二进制设置。

Exchange Server 分析工具仅以提供信息为目的报告此配置。但是，可能需要通过编辑注册表来将该注册表值更改回默认设置。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何执行此操作的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
解决此警告问题

  1. 单击"开始"，再单击"运行"，键入 Regedit，然后单击"确定"。

  2. 在控制台树中，找到并单击下列注册表项： HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. 在详细信息窗格中，用鼠标右键单击 LdapResultTimeout 注册表值。将数值数据更改为 121。

  4. 也可以在详细信息窗格中用鼠标右键单击 LdapResultTimeout 注册表值，然后单击"删除"。在对话框中单击"是"来确认注册表值的删除。

  5. 重新启动 Exchange 服务器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关编辑 Microsoft Windows 注册表项的详细信息，请参阅下列 Microsoft 知识库文章：

  • 322755"如何在 Windows 2000 中备份、编辑和还原注册表"(http://support.microsoft.com/default.aspx?scid=kb;zh-cn;322755)

  • 322756"如何在 Windows XP 和 Windows Server 2003 中备份、编辑和还原注册表"(http://support.microsoft.com/default.aspx?scid=kb;zh-cn;322756)


非默认 SMTP MaxConnectionRetries 注册表值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否更改了默认的 MaxConnectionRetries：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

如果 Exchange Server 分析工具发现 MaxConnectionRetries 注册表值为手动创建，更改了默认的 Exchange Server 二进制设置 20，则 Exchange Server 分析工具将显示非默认警告消息。默认情况下，Exchange Server 安装不创建 MaxConnectionRetries 注册表值。但是，可以在 Exchange Server 安装之后手动创建 MaxConnectionRetries 注册表值，以便更改该值。MaxConnectionRetries 值设置单个分类的 LDAP 连接最多可以失败的次数，在该次数内，分类可以在新的连接上重新发出连接命令。MaxConnectionRetries 次连接分类失败后，将被放入重试队列中。如果该注册表值为手动创建，并且注册表值的设置配置不当，Exchange Server 可能会遇到邮件传输问题。

建议在创建或修改 MaxConnectionRetries 注册表值之前，一定要认真考虑。Exchange Server 的二进制默认值经过认真选择，在大多数 Exchange Server 环境下可以获得最佳性能。常见的最佳办法是解决问题的根本原因，而不是通过手动配置注册表来修改 Exchange Server 的默认行为。为了符合最佳办法，如果 MaxConnectionRetries 注册表值存在，可能需要删除此注册表值，以便使 Exchange Server 恢复默认的二进制设置。

Exchange Server 分析工具仅以提供信息为目的报告此配置。但是，可能需要通过编辑注册表来将该注册表值更改回默认设置。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何执行此操作的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
解决此警告问题

  1. 单击"开始"，再单击"运行"，键入 Regedit，然后单击"确定"。

  2. 在控制台树中，找到并单击下列注册表项： HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. 在详细信息窗格中，用鼠标右键单击 MaxConnectionRetries 注册表值。将值更改为 20。

  4. 也可以在详细信息窗格中用鼠标右键单击 MaxConnectionRetries 注册表值，然后单击"删除"。在对话框中单击"是"来确认注册表值的删除。

  5. 重新启动 Exchange Server。

在编辑注册表之前，有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"。(http://support.microsoft.com/kb/256986/zh-cn)

有关编辑 Microsoft Windows 注册表项的详细信息，请参阅下列 Microsoft 知识库文章：

  • 322755"如何在 Windows 2000 中备份、编辑和还原注册表"(http://support.microsoft.com/default.aspx?scid=kb;zh-cn;322755)

  • 322756"如何在 Windows XP 和 Windows Server 2003 中备份、编辑和还原注册表"(http://support.microsoft.com/default.aspx?scid=kb;zh-cn;322756)


非默认 SMTP MaxLdapConnections 注册表值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否更改了默认的 MaxLdapConnections：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

如果 Exchange Server 分析工具发现 MaxLdapConnections 注册表值为手动创建，更改了默认的 Exchange 服务器二进制设置 8，Exchange Server 分析工具将显示非默认值警告消息。默认情况下，Exchange 安装不创建 MaxLdapConnections 注册表值。但是，可以在 Exchange 安装之后手动创建 MaxLdapConnections 注册表值，以便更改该值。MaxLdapConnections 值设置分类程序打开与单个全局编录服务器的最大 LDAP 连接数。如果该注册表值为手动创建，并且注册表值的设置配置不当，Exchange 服务器可能会遇到邮件传输问题。

警告：
MaxLdapConnections 注册表值应始终与 HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters\MaxPoolThreads 注册表值设置的值匹配。

建议在创建或修改 MaxLdapConnections 注册表值之前，一定要认真考虑。Exchange 服务器的二进制默认值经过认真选择，在大多数 Exchange 服务器环境下可以获得最佳性能。常见的最佳办法是解决问题的根本原因，而不是通过手动配置注册表来修改 Exchange Server 的默认行为。为了符合最佳办法，如果 MaxLdapConnections 注册表值存在，可能需要删除此注册表值，以便使 Exchange 服务器恢复默认的二进制设置。

Exchange Server 分析工具仅以提供信息为目的报告此配置。但是，可能需要通过编辑注册表来将该注册表值更改回默认设置。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何执行此操作的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
解决此警告问题

  1. 单击"开始"，再单击"运行"，键入 Regedit，然后单击"确定"。

  2. 在控制台树中，找到并单击下列注册表项： HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. 在详细信息窗格中，用鼠标右键单击 MaxLdapConnections 注册表值。将数值数据更改为 8。

  4. 也可以在详细信息窗格中用鼠标右键单击 MaxLdapConnections 注册表值，然后单击"删除"。在对话框中单击"是"来确认注册表值的删除。

  5. 重新启动 Exchange 服务器。

在编辑注册表之前，有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"。(http://support.microsoft.com/kb/256986/zh-cn)

有关编辑 Microsoft Windows 注册表项的详细信息，请参阅下列 Microsoft 知识库文章：

  • 322755"如何在 Windows 2000 中备份、编辑和还原注册表"(http://support.microsoft.com/default.aspx?scid=kb;zh-cn;322755)

  • 322756"如何在 Windows XP 和 Windows Server 2003 中备份、编辑和还原注册表"(http://support.microsoft.com/default.aspx?scid=kb;zh-cn;322756)


非默认 SMTP MaxPendingSearches 注册表值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否更改了默认的 MaxPendingSearches：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

如果 Exchange Server 分析工具发现 MaxPendingSearches 注册表值为手动创建，更改了默认的 Exchange 服务器二进制设置 60，Exchange Server 分析工具将显示非默认值警告消息。默认情况下，Exchange Server 安装不创建 MaxPendingSearches 注册表值。但是，可以在 Exchange Server 安装之后手动创建 MaxPendingSearches 注册表值，以便更改该值。MaxPendingSearches 值设置分类程序在某一时刻对特定全局编录服务器的未完成的 LDAP 搜索数。在 Exchange 2000 Server SP3 之前的版本中，每个连接最大的未完成搜索数为 1024。Exchange 2000 Server SP3 和 Exchange Server 2003 中的默认值设置为 60。例如，如果将此值从默认值 60 更改为 30，将减少分类程序对全局编录服务器的 LDAP 搜索总数。

如果该注册表值为手动创建，并且注册表值的设置配置不当，Exchange 服务器可能会遇到邮件传输问题。

建议在创建或修改 MaxPendingSearches 注册表值之前，一定要认真考虑。Exchange 服务器的二进制默认值经过认真选择，在大多数 Exchange 服务器环境下可以获得最佳性能。常见的最佳办法是解决问题的根本原因，而不是通过手动配置注册表来修改 Exchange 的默认行为。为了符合最佳办法，如果 MaxPendingSearches 注册表值存在，可能需要删除此注册表值，以便使 Exchange 服务器恢复默认的二进制设置。

Exchange Server 分析工具仅以提供信息为目的报告此配置。但是，可能需要通过编辑注册表来将该注册表值更改回默认设置。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何执行此操作的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
解决此警告问题

  1. 单击"开始"，再单击"运行"，键入 Regedit，然后单击"确定"。

  2. 在控制台树中，找到并单击下列注册表项： HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. 在详细信息窗格中，用鼠标右键单击 MaxPendingSearches 注册表值。将数值数据更改为 60。

  4. 也可以在详细信息窗格中用鼠标右键单击 MaxPendingSearches 注册表值，然后单击"删除"。在对话框中单击"是"来确认注册表值的删除。

  5. 重新启动 Exchange 服务器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关编辑 Microsoft Windows 注册表的详细信息，请参阅下列 Microsoft 知识库文章：

?322755"HOW TO：在 Windows 2000 中备份、编辑和还原注册表"(http://support.microsoft.com/default.aspx?scid=kb;zh-cn;322755)

?322756"如何在 Windows XP 和 Windows Server 2003 中备份、编辑和还原注册表"(http://support.microsoft.com/default.aspx?scid=kb;zh-cn;322756)


非默认 SMTP MaxSearchBlockSize 注册表值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否更改了默认的 MaxSearchBlockSize：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

如果 Exchange Server 分析工具发现 MaxSearchBlockSize 注册表值为手动创建，更改了默认的 Exchange 服务器二进制设置 20，Exchange Server 分析工具将显示非默认值警告消息。默认情况下，Exchange Server 安装不创建 MaxSearchBlockSize 注册表值。但是，可以在 Exchange Server 安装之后手动创建 MaxSearchBlockSize 注册表值，以便更改该值。MhelpsBlockSize 值设置可以作为一个 LDAP 搜索同时提交的分类程序搜索的最大数目。通过设置分类程序搜索的最大数目，可以帮助简化分类程序的搜索筛选器。

此过程使那些正在等待的搜索可以重新发给新连接。如果该注册表值为手动创建，并且注册表值的设置配置不当，Exchange 服务器可能会遇到邮件传输问题。

建议在创建或修改 MaxSearchBlockSize 注册表值之前，一定要认真考虑。Exchange Server 的二进制默认值经过认真选择，在大多数 Exchange 服务器环境下可以获得最佳性能。常见的最佳办法是解决问题的根本原因，而不是通过手动配置注册表来修改 Exchange Server 的默认行为。为了符合最佳办法，如果 MaxSearchBlockSize 注册表值存在，可能需要删除此注册表值，以便使 Exchange 服务器恢复默认的二进制设置。

Exchange Server 分析工具仅以提供信息为目的报告此配置。但是，可能需要通过编辑注册表来将该注册表值更改回默认设置。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何执行此操作的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
解决此警告问题

  1. 单击"开始"，再单击"运行"，键入 Regedit，然后单击"确定"。

  2. 在控制台树中，找到并单击下列注册表项： HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. 在详细信息窗格中，用鼠标右键单击 MaxSearchBlockSize 注册表值。将数值数据更改为 20。

  4. 也可以在详细信息窗格中用鼠标右键单击 MaxSearchBlockSize 注册表值，然后单击"删除"。在对话框中单击"是"来确认注册表值的删除。

  5. 重新启动 Exchange 服务器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关编辑 Microsoft Windows 注册表项的详细信息，请参阅下列 Microsoft 知识库文章：

  • 322755"如何在 Windows 2000 中备份、编辑和还原注册表"(http://support.microsoft.com/default.aspx?scid=kb;zh-cn;322755)

  • 322756"如何在 Windows XP 和 Windows Server 2003 中备份、编辑和还原注册表"(http://support.microsoft.com/default.aspx?scid=kb;zh-cn;322756)


非默认 SMTP TopoRecheckSecs 注册表值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取下列注册表项，以确定其值是否已从默认值更改为其他值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\TopoRecheckSecs.

如果 Exchange Server 分析工具发现 TopoRecheckSecs 的值不等于默认值 900 秒，则显示非默认配置消息。Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。因为 DSAccess 使用 TopoRecheckSecs 注册表值的值设置全局编录列表的重建间隔，不正确的设置可能会影响性能。应尽可能使用 Exchange Server 的默认配置设置。但是，如果此注册表值存在，可能是按照 Microsoft 产品支持服务的建议添加和配置了此注册表值，以解决出现过的某个问题。应考虑删除此注册表值，除非是按照 Microsoft PSS 的建议或其他专家的指导添加和配置了此注册表值。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
删除 TopoRecheckSecs 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess

  3. 在右侧窗格中，找到并删除 TopoRecheckSecs 值。

  4. 关闭注册表编辑器。

  5. 若要使此更改成为永久更改，请重新启动 System Attendant。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关优化 Exchange Server 的全局编录布置的详细信息，请参阅"Understanding and Troubleshooting Directory Access"（英文）(http://go.microsoft.com/fwlink/?LinkId=39012)。


未将非 Exchange 网关服务器设置为智能主机
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-08-09

Microsoft® Exchange Server 分析工具将查询 Active Directory® 目录服务，以获取 protocolCfgSMTPServer 对象类的 distingushedName 属性值，从而列出用户指定的 Exchange 网关上的所有简单邮件传输协议 (SMTP) 虚拟服务器实例。

然后，Exchange Server 分析工具将查询 Active Directory，以获取找到的每个 msExchRoutingSMTPConnector 对象的 msExchSourceBridgeheadServersDN 和 routingList 属性值，从而确定 SMTP 连接器是否已将检测到的 SMTP 虚拟服务器实例之一正确地设置为与外部 SMTP 地址空间连接的本地桥头服务器。

最后，Exchange Server 分析工具将查询 Active Directory，以获取检测到的所有 SMTP 连接器（msExchRoutingSMTPConnector 对象）上的 msExchSmtpSmartHost 属性值，从而确定是否将其中一个 SMTP 连接器指定为用户指定的非 Exchange 网关服务器的智能主机。

如果 Exchange Server 分析工具确定未将用户指定的非 Exchange 网关服务器设置为其中一个 SMTP 连接器的智能主机，则 Exchange Server 分析工具将显示警告。

此警告指示，未设置从用户指定的 Exchange 网关服务器到用户指定的非 Exchange 网关服务器的显式路由，并且非 Exchange 网关以外的服务器可能会意外地路由组织外部的邮件。

若要解决此问题，请将非 Exchange 网关服务器指定为 SMTP 连接器的智能主机。

查看和配置智能主机设置

  1. 打开 Exchange 系统管理器。

  2. 展开"服务器"，展开 Exchange 服务器，展开"协议"，再展开 SMTP。

  3. 用鼠标右键单击一个 SMTP 虚拟服务器（例如"默认 SMTP 虚拟服务器"），然后选择"属性"。

  4. 选择"传递"选项卡，然后单击"高级"。

  5. 输入要使用的智能主机。可以通过完全限定域名或 IP 地址来标识智能主机。如果使用 IP 地址，必须在其两侧加上方括号 ([ ])。Exchange 将首先查找服务器名，然后再查找 IP 地址。方括号表示该值是 IP 地址。因此，可以绕过 DNS 查找操作。

  6. 如果该服务器运行的是 Exchange 2000 Server，则可以视需要选中"发送到智能主机之前尝试直接进行传递"复选框。

  7. 单击"确定"以保存更改，然后单击"确定"关闭 SMTP 虚拟服务器的"属性"对话框。

有关如何配置智能主机连接器的详细信息，请参阅 Microsoft 知识库文章 821911"How to Configure Exchange Server 2003 to Use a Smart Host IP Address"（如何将 Exchange Server 2003 配置为使用使用智能主机 IP 地址）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821911)。

有关如何使用 SMTP 连接器的详细信息，请参阅 Microsoft 知识库文章 294736"When to create SMTP connectors in Exchange 2000 and later versions"（何时在 Exchange 2000 和更高版本中创建 SMTP 连接器）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=294736)。

有关 SMTP 连接器的详细信息，请参阅"Exchange Server 2003 传输和路由指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=c092b7a7-9034-4401-949c-b29d47131622&DisplayLang=zh-cn)。


可能发生的分类程序超载
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-09-06

Microsoft® Exchange Server 分析工具包括性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎从 SMTP Server 性能对象的 Cat:Messages submitted/sec 和 Cat:Categorizations completed/sec 性能计数器收集数据以分析性能数据。

Cat:Messages submitted/sec 性能计数器显示每秒钟向分类程序提交的邮件数，而 Cat:Categorizations completed/sec 显示每秒钟完成的分类的比率。

Exchange Server 分析工具将比较这两个计数器的平均合计值，以确定通常提交的邮件数是否大于处理的邮件数。

如果 Exchange Server 分析工具确定每秒向分类程序提交的平均邮件总数一直大于每秒完成的平均邮件总数（通过比较两封邮件），Exchange Server 分析工具将显示警告。

分类程序执行下列核心操作：

  • 解析并验证所有收件人。

  • 确定所有收件人的限制。

  • 展开通讯组列表（如果需要）。

  • 确定邮件用于本地传递还是远程传递。

此警告指示分类程序可能面临超载。应调查可能的原因，并尽量解决此问题。

在下列情况中由于需要处理多封邮件，可能会导致分类程序超载：

  • 未经请求的商业电子邮件 (UCE) 或垃圾邮件。

  • 病毒繁殖。

  • 服务器性能问题。

若要解决此警告，请执行下列操作：

  • 确定分类程序超载是由预期负载还是由典型负载导致的。如果分类程序超载是由预期负载导致的，请查看下列 Microsoft TechNet 文章中的 Exchange 性能指导。

    • "Troubleshooting Exchange Server 2003 Performance"（排除 Exchange Server 2003 性能故障）(http://go.microsoft.com/fwlink/?LinkId=47588)。

    • "Exchange Server 2003 性能和可伸缩性指南"(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 如果分类程序超载不是由预期负载导致的，请检查是否是由于病毒发作或垃圾邮件产生了负载。


可能的网关问题
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-08-09

Microsoft® Exchange Server 分析工具会从运行 Exchange Server 的服务器向用户定义的外部帐户发送一封测试邮件。然后，Exchange Server 分析工具将扫描服务器的邮件跟踪日志，以确定是否发现了测试邮件的传递问题。

作为此扫描的一部分，Exchange Server 分析工具会查询 root\MicrosoftExchangeV2 命名空间下 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 类的 EntryType 属性，以确定创建一个或多个邮件跟踪日志条目的原因。

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • 可以成功扫描邮件跟踪日志。

  • 测试邮件未成功地从队列中传出。

  • 没有生成未送达报告 (NDR)。

  • EntryType 属性存在值 1034。

  • 邮件已到达指定的本地 Exchange 出站网关服务器。

此错误可能指示用户指定的本地 Exchange 出站网关服务器与远程服务器之间存在连接问题。

若要解决此错误，请使用 NSlookup 实用程序来查看域名系统 (DNS) 解析可能存在的问题。对于连接和协议问题（如主机无法访问错误），请使用 Telnet.exe 尝试连接到目标计算机。若要解决协议错误，请为简单传输协议 (SMTP) 组件的 MSExchangeTransport 服务增加诊断日志记录，然后查看日志中的错误。另外，可以使用网络监视器 (Netmon.exe) 工具获取有关网络连接错误的信息。

有关如何修改日志记录设置的详细信息，请参阅"Exchange Server 2003 传输和路由指南"的"排除邮件流和 SMTP 故障"部分中的"如何修改 MSExchangeTransport 的日志记录设置"(http://go.microsoft.com/fwlink/?LinkId=47579)。

有关如何排除 SMTP 队列故障的详细信息，请参阅下列 Exchange 资源：

  • "Exchange Server 2003 传输和路由指南"中的"排除邮件流和 SMTP 故障"(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)。

  • Microsoft 知识库文章 821877"Description of Fields on the SMTP and X.400 Queue Properties Tabs"（对 SMTP 和 X.400 队列"属性"选项卡上字段的描述）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)。

  • Microsoft 知识库文章 264054"XCON：了解 Exchange 2000 Server 中的队列状态"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


可能的 Inetinfo 问题
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-09-06

Microsoft® Exchange Server 分析工具包含一个性能数据收集引擎，该引擎用于在运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上查询性能计数器对象。性能数据收集引擎从 SMTP Server 性能对象的 Cat:Categorizations in progress 性能计数器收集数据以分析性能数据。

Cat:Categorizations in progress 性能计数器显示正在进行的分类数。

对于此查询，Exchange Server 分析工具将在 2 分钟的时段内，每隔 6 秒检索一个样本。Exchange Server 分析工具将报告收集间隔期间性能计数器的平均值。

如果 Exchange Server 分析工具确定采样期间正在进行的分类的最小数目永远不会等于零，则将显示警告。

分类程序执行下列核心操作：

  • 解析并验证所有收件人。

  • 确定所有收件人的限制。

  • 展开通讯组列表（如果需要）。

  • 确定邮件用于本地传递还是远程传递。

如果服务器未承受重负载，则此警告可能指示 Inetinfo.exe 进程或此进程依赖的资源已被死锁。

简单邮件传输协议 (SMTP) 服务在 Inetinfo.exe 进程中运行。当邮件通过传输子系统时，SMTP 将大量使用 Internet 信息服务 (IIS) 资源。

如果在两个或更多个进程（或线程）中，每一个都需要等到另一个完成后才可以继续，那么就会发生"死锁"。这种情况的结果是所有进程（或线程）都将停止响应（挂起）。在出现死锁时，进程永远都不会完成执行，并且系统资源将被占用。这会阻止其他作业开始运行。

若要解决此警告，请执行下列操作：

  • 确定分类程序是否由于预期负载或典型负载而发生超载。如果分类程序未承受重负载，请使用"详细信息"一节中参考的资源来确定 Inetinfo.exe 进程或相关资源可能存在的性能问题。

  • 检查 Inetinfo.exe 进程是否已启动并在运行。

  • 遵循 Microsoft 知识库文章 919791"How to use the Debug Diagnostics Tool to troubleshoot high CPU usage by a process in IIS"（如何使用调试诊断工具来排除 IIS 中进程占用过多 CPU 的问题）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=919791)中提供的调试指导，来检查 Inetinfo.exe 死锁情况。

详细信息

有关 Inetinfo.exe 的详细信息，请参阅 Technical Reference Guide for Exchange Server 2003（Exchange Server 2003 技术参考指南）中的"Internet Information Services"（Internet 信息服务）(http://go.microsoft.com/fwlink/?LinkId=72966)。

有关如何排除进程死锁问题的详细信息，请参阅 Microsoft 知识库文章 919791"How to use the Debug Diagnostics Tool to troubleshoot high CPU usage by a process in IIS"（如何使用调试诊断工具来排除 IIS 中进程占用过多 CPU 的问题）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=919791)。

有关 Exchange Server 性能的详细信息，请参阅"Performance and Scalability Guide for Exchange Server 2003"（Exchange Server 2003 性能和可伸缩性指南）(http://go.microsoft.com/fwlink/?LinkId=47576)。

有关如何解决 Exchange Server 性能问题的详细信息，请参阅"Troubleshooting Microsoft Exchange Server Performance"（排除 Microsoft Exchange Server 性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)。


可能的非网关问题
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-08-09

Microsoft® Exchange Server 分析工具会从运行 Exchange Server 的服务器向用户定义的外部收件人 SMTP 地址发送一封测试邮件。然后，Exchange Server 分析工具将扫描服务器的邮件跟踪日志，以确定是否发现了测试邮件的传递问题。

作为此扫描的一部分，Exchange Server 分析工具会查询 root\MicrosoftExchangeV2 命名空间下 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 类的 EntryType 属性，以确定创建一个或多个邮件跟踪日志条目的原因。

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • 可以成功扫描邮件跟踪日志。

  • 测试邮件未成功地从队列中传出。

  • 没有生成未送达报告。

  • EntryType 属性存在值 1034。

  • 邮件未到达指定的本地 Exchange 出站网关服务器。

此错误可能表示对于发送服务器，测试邮件仍位于一个简单邮件传输协议 (SMTP) 远程传递队列中，并且此队列存在问题。

远程传递队列存放要进行远程传递的邮件。队列的名称与远程传递目标相匹配。该目标可能是连接器、服务器或域。

要解决协议错误的问题，请为 SMTP 组件的 MSExchangeTransport 服务增加诊断日志记录，然后查看日志中的错误。另外，可以使用网络监视器 (Netmon.exe) 工具获取有关网络连接错误的信息。若要重现问题，可能必须强制队列进行重试操作。检查事件日志中与 Microsoft Exchange Information Store 服务相关联的可能存在的错误。

有关如何修改日志记录设置的详细信息，请参阅"Exchange Server 2003 传输和路由指南"的"排除邮件流和 SMTP 故障"部分中的"如何修改 MSExchangeTransport 的日志记录设置"(http://go.microsoft.com/fwlink/?LinkId=47579)。

有关如何排除 SMTP 队列故障的详细信息，请参阅下列 Exchange 资源：

  • "Exchange Server 2003 传输和路由指南"中的"排除邮件流和 SMTP 故障"(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)。

  • Microsoft 知识库文章 821877"Description of Fields on the SMTP and X.400 Queue Properties Tabs"（对 SMTP 和 X.400 队列"属性"选项卡上字段的描述）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)。

  • Microsoft 知识库文章 264054"XCON：了解队列说明 Exchange 2000 服务器"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


已检测到可能的 SMTP 代理
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-12-06

Microsoft® Exchange Server 分析工具将尝试向简单邮件传输协议 (SMTP) 域的邮局主管帐户或用户定义帐户发送邮件。

Exchange Server 分析工具打开与 SMTP 服务器的套接字连接时，应该会收到以下默认响应：

"220 Computer Name .Domain Name .com Microsoft ESMTP MAIL Service, Version:Version Number ready at Date Time +0000"

如果 Exchange Server 分析工具收到包含第三方特定字符串的非默认响应，Exchange Server 分析工具将会显示错误。

此错误指示远程服务器后面可能运行了第三方 SMTP 代理服务器。

如果 Exchange Server 管理员尚未有意地自定义默认的 SMTP 标题，则此警告可能指示 Exchange Server 处于正在筛选 Exchange Server 扩展的简单邮件传输协议 (ESMTP) 命令的 SMTP 代理之后。

如果筛选 Exchange Server ESMTP 命令，则会对 Exchange 性能产生明显的影响，并可能导致 Microsoft 知识库文章 320027"在 Cisco PIX 防火墙后无法发送或接收电子邮件"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027) 中所描述的行为。

有关自定义的 SMTP 标题的详细信息，请参阅下列 Microsoft 知识库文章：

  • 281224: XCON:"如何修改 SMTP 标题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=281224)


潜在的分类程序性能问题
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-09-06

Microsoft® Exchange Server 分析工具将查询 ExchangeLink Windows® Management Instrumentation (WMI) 类，以获取简单邮件传输协议 (SMTP) ProtocolName 实例的 TypePendingCategorization 属性值，从而确定等待目录查找的邮件 (MADL) SMTP 队列中的邮件数。

ExchangeLink WMI 类的属性将返回有关邮件服务器之间邮件处理链接（队列）的信息。一个链接可以包含零个或多个 ExchangeQueue 对象。该数目取决于链接上的当前邮件通信。

Exchange Server 分析工具还包含一个性能数据收集引擎，该引擎用于查询运行 Exchange 2000 Server 或 Exchange Server 2003 的计算机上的性能计数器对象。

如果 Exchange Server 分析工具确定当前 MADL 队列中的邮件数超过五十个，则会让性能数据收集引擎从 SMTP Server 性能对象的 Cat:Messages Categorized 和 the Cat:Categorizations completed 性能计数器中收集数据，以分析性能数据。

Cat:Messages Categorized 性能计数器显示分类程序提交以进行排队的邮件数，而 Cat:Categorizations completed 性能计数器显示已提交给分类程序的已完成邮件总数。

分类程序执行下列核心操作：

  • 解析并验证所有收件人。

  • 确定所有收件人的限制。

  • 展开通讯组列表（如果需要）。

  • 确定邮件用于本地传递还是远程传递。

Exchange Server 分析工具将检查这两个计数器的平均合计值，以确定这些计数器的读数在采样期间是否会不断增加。

如果下列条件为真，则 Exchange Server 分析工具将显示错误。

  • MADL 队列中有五十封或更多邮件。

  • Cat:Messages Categorized 性能计数器在采样期间显示的增量用于指示将已提交邮件传递给下一进程时的进度。

  • Cat:Categorizations completed 性能计数器在采样期间显示的增量指示成功完成已提交邮件的分类时的进度。

此错误指示，尽管分类程序已成功处理邮件，但是，其队列长度仍然很长，并且性能可能已受损。

分类程序性能受到影响的原因可能是由于存在下列情况，而需要执行命令来处理多封邮件：

  • 商业垃圾邮件 (UCE) 或其他垃圾邮件。

  • 病毒繁殖。

  • 服务器性能问题。

若要解决此警告，请执行下列操作：

  • 确定分类程序超载是预期中的，还是由典型负载导致的。如果分类程序超载是由预期负载导致的，请查看下列 Exchange 资源中的 Exchange 性能指导：

    • Troubleshooting Exchange Server 2003 Performance（排除 Exchange Server 2003 的性能问题）(http://go.microsoft.com/fwlink/?LinkId=47588)

    • "Exchange Server 2003 性能和可伸缩性指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&DisplayLang=zh-cn)

  • 如果分类程序超载不是由预期负载导致的，请检查病毒发作或垃圾邮件是否导致产生负载。


发现潜在的通讯组扩展问题
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Exchange 服务器是否正在运行 Exchange Server 2003 Service Pack 2 (SP2)，并且已配置为在检查传递限制时展开通讯组：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

  • 此项的值为 1 表示已经将服务器配置为在检查传递限制时展开通讯组。

  • 此项的值为 2 表示已经将服务器配置为在检查传递限制时不展开通讯组。

如果 Exchange Server 分析工具发现服务器已设置为在检查传递限制时展开通讯组，则会接着检查服务器事件日志以查看在过去 24 小时内是否发生了错误事件 6004、6006 和 6008。

这些事件表明邮件已经被捕获到邮件分类程序中。邮件分类程序是高级队列引擎的组件，它将轻型目录访问协议 (LDAP) 查询发送到全局编录服务器以执行目录查找。

最后，Exchange Server 分析工具查询 Active Directory® 目录服务，以确定以下事项：

  • 目录林中是否有超过 500 个邮箱设置了传递限制，因此至少一个通讯组被用于允许或禁止发件人。

  • 路由组连接器是否具有基于通讯组成员身份的传递限制，桥头服务器是否启用了连接器限制检查。

  • SMTP 连接器是否具有基于通讯组成员身份的传递限制，桥头服务器是否启用了连接器限制检查。

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • Exchange Server 2003 SP2 服务器已配置为在检查传递限制时展开通讯组。

  • Exchange 服务器在过去的 24 小时内已经记录了事件 6004、6006 和 6008。

  • 目录林中有超过 500 个邮箱设置了传递限制，因此至少一个通讯组被用于允许或禁止发件人，或者路由组连接器具有基于通讯组成员身份的传递限制，并且桥头服务器启用了连接器限制检查，或者 SMTP 连接器具有基于通讯组成员身份的传递限制，并且桥头服务器启用了连接器限制检查。

RestrictionMethod 值确定分类程序将如何处理限制。分类程序的默认行为是反复展开通讯组，并检查通过系统传递的每封邮件的限制。如果向某个收件人发送电子邮件，而此收件人已设置了限制，拒绝来自特定通讯组或安全组成员的邮件，则此时 Exchange Server 必须展开该组，以确保发件人不是受限组的成员。Exchange Server 不会将此组展开的结果存入缓存，所以每次都必须执行此操作。这将导致邮件被保存在分类程序队列中，可能会延迟邮件处理。

如果将 RestrictionMethod 的值设置为 2，则在服务器检查限制时，此 Exchange 服务器上的传输组件将不会展开通讯组的成员身份。此配置使限制检查可以实现最高性能。此外，若要使 RestrictionMethod 注册表项生效，所有通讯组（包括具有传递限制的用户）必须是无层次的。即受限制的通讯组不得包含嵌套的通讯组。如果嵌套了受限制的通讯组，则将无法使用展开逻辑。

对于连接器限制中使用的通讯组，建议您在没有邮箱的连接器桥头服务器上设置 RestrictionMethod 注册表项值。对于 Active Directory 用户限制，如果受限制的通讯组包含扩展服务器，则建议您在扩展服务器上创建 RestrictionMethod 注册表项。

有关在配置传递限制时发生的情况的详细信息，请参阅 Microsoft 知识库文章 812298"Mail delivery is slow after you configure delivery restrictions that are based on a distribution list"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。

有关 RestrictionMethod 注册表值的详细信息，请参阅 Microsoft 知识库文章 895407"In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

有关 Exchange Server 2003 事件和错误的详细信息，请参阅"Events and Errors Message Center"（英文）(http://go.microsoft.com/fwlink/?LinkId=34258)。

有关连接器限制的详细信息，请参阅 Microsoft 知识库文章 277872"XCON:Connector Delivery Restrictions May Not Work Correctly"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872)。

有关 SMTP 队列的详细信息，请参阅 Microsoft 知识库文章 884996"Messages remain in the 'Messages awaiting directory lookup' SMTP queue in Exchange Server 2003 or in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=884996)。


发现潜在邮件日记收件人问题
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具查询 Win32_NTLogEvent Microsoft Windows® Management Instrumentation (WMI) 类，以确定在过去 24 小时内是否出现了以下某种分类程序警告/错误事件组合：

  • 事件 9004 和事件 9003

  • 事件 9035 和事件 6004

这些事件表明邮件已经被捕获到邮件分类程序中。邮件分类程序是高级队列引擎的组件，它将轻型目录访问协议 (LDAP) 查询发送到全局编录服务器以执行目录查找。

  • Exchange Server 分析工具还查询 Active Directory® 目录服务，以确定是否符合下列条件之一：

  • 为存储指定的日记收件人指向删除的对象。

  • 为存储指定的日记收件人指向不具有有效 mailNickname 的对象。

  • 为存储指定的日记收件人指向禁用的帐户。

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • 出现了以前列出的某个警告/错误事件组合。

  • 某个指定的日记收件人条件也为真。

该错误表明在可能导致邮件排队的 Exchange 环境中日记存在潜在问题。

有关如何纠正该问题的信息，请参阅与您的问题相关的具体 Exchange Server 分析工具文章。

  • 日记收件人指向已删除的对象

  • 日记收件人无效

  • 日记收件人指向已禁用的帐户

  • 有关 Exchange Server 2003 事件和错误的信息，请参阅"Events and Errors Message Center"（英文）(http://go.microsoft.com/fwlink/?LinkId=34258)。


发现潜在邮件日记和存储服务问题
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具查询 Win32_NTLogEvent Microsoft Windows® Management Instrumentation (WMI) 类，以确定在过去 24 小时内是否出现了分类程序警告事件 9004。

Exchange Server 分析工具也查询 Win32_Service WMI 类，以确定是否已启动或停止了 Microsoft Exchange Information Store 服务 (MSExchangeIS)。对于 MSExchangeIS 实例，除 Started 外的任何值都表示已停止 MSExchangeIS 服务。

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • 该服务器在过去 24 小时内已记录了一个分类程序警告事件 9003。

  • MSExchangeIS 服务已停止。

该错误表明存在邮件日记问题或存在可能导致邮件排队的 Microsoft Exchange Information Store 服务 (Store.exe) 问题。

如果下列条件之一为真，则可能发生该问题：

  • 日记收件人对象已从 Active Directory® 目录服务中删除。

  • 信息存储服务未运行或在作为 SMTP 桥头服务器的 Exchange Server 计算机上被禁用。

  • 卸载了 SMTP 桥头服务器上的一个或多个邮箱存储。

若要解决该问题，请执行下列操作：

  • 确保 SMTP 桥头服务器已启用并正在运行信息存储服务。确保已在 SMTP 桥头服务器上装入了邮箱存储。

  • 确保已从 Active Directory 删除了邮箱存储的日记收件人对象。

确定邮箱存储的日记收件人

  1. 启动"Exchange 系统管理器"。

  2. 依次展开"服务器"、<您的 Exchange 服务器>、<存储组>，然后用鼠标右键单击邮箱存储并选择"属性"。

  3. 在"常规"选项卡上，查看立即显示在"存档由此存储中的邮箱发送或接收的所有邮件"复选框下的帐户。这就是要用作日记收件人的帐户。

    注意：
    确保验证各个邮箱存储对象的日记收件人。
将新用户邮箱指定为日记收件人

  1. 启动"Exchange 系统管理器"。

  2. 依次展开"服务器"、<您的 Exchange 服务器>、<存储组>，然后用鼠标右键单击邮箱存储并选择"属性"。

  3. 在"常规"选项卡中，单击"存档由此存储中的邮箱发送或接收的所有邮件"文本右侧的"浏览"，指定一个邮箱作为日记邮箱。

    注意：
    此邮箱存储中发件人的所有日记邮件都将发送到指定的邮箱。

有关此问题的信息，请参阅日记收件人指向已删除的对象。

有关 Exchange Server 2003 事件和错误的详细信息，请参阅"Events and Errors Message Center"（英文）(http://go.microsoft.com/fwlink/?LinkId=34258)。

有关如何部署日记解决方案的详细信息，请参阅"Journaling with Exchange Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=47581)。


发现潜在权限问题
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具查询 Win32_NTLogEvent Microsoft Windows® Management Instrumentation (WMI) 类，以确定在过去 24 小时内是否发生了下列 Exchange Server 错误事件：

  • 事件 929。

  • 事件 9035。

  • 事件 9003、9004 和 6004 的组合。

对 Active Directory® 目录服务中 Exchange Server 对象拥有不正确的访问权限可能会导致 Exchange Server 错误事件 929。

Exchange Server 错误事件 9003、9004 和 6004 表明要在邮件分类程序中捕获的邮件。邮件分类程序是高级队列引擎的组件，它将轻型目录访问协议 (LDAP) 查询发送到全局编录服务器以执行目录查找。

Exchange Server 分析工具还查询 Active Directory，以便确定与 Exchange 相关的对象的属性是否指明，这些对象存在权限继承问题。

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • 在过去 24 小时内服务器上记录了下列事件之一或其中几个事件的组合，该服务器在其"等待目录查找的邮件"队列中有排队的邮件：

    • 事件 929。

    • 事件 9035。

    • 事件 9003、9004 和 6004 的组合。

  • 与 Exchange 相关的对象缺少访问权限或访问权限不正确。

该错误意味着在 Exchange 环境中存在可能导致邮件排队的权限继承问题。

要解决此问题，请按照 Microsoft 知识库文章 907969"Event ID 929 is logged, and mail is not delivered from one mail server to another mail server in an Exchange 2000 Server organization"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=907969) 中的步骤完成操作。

有关 Exchange Server 2003 事件和错误的详细信息，请参阅"Events and Errors Message Center"（英文）(http://go.microsoft.com/fwlink/?LinkId=34258)。


标识为通用目标的公用文件夹
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-10-04

Microsoft® Exchange Server 分析工具查询 Exchange_Queue Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP) 虚拟服务器的 SMTP 队列的下列属性值。

LinkId | 表示包含该队列的链接的标识符。
QueueId | 表示该队列的标识符。
QueueName | 表示该队列的名称。
VirtualMachine | 表示包含该队列的虚拟计算机的名称。
VirtualServerName | 表示该队列所在的虚拟服务器的名称。
MessageCount | 表示该队列中的邮件数。

Exchange Server 分析工具使用此处获取的信息来查询 Exchange_QueuedSMTPMessage WMI 类，以确定该队列中邮件的下列属性值。

Recipients | 表示邮件收件人。
Received | 表示邮件的接收时间戳。
MessageId | 表示队列中邮件的标识符。
StateRetry | 表示重新尝试传输未成功传递的邮件。

最后，Exchange Server 分析工具使用此处获取的数据查询 Active Directory® 目录服务，以确定每个 Recipient 对象的 distinguishedName 值。然后，Exchange Server 分析工具会确定该收件人是一位用户、一个通讯组、一个公用文件夹还是一个公用文件夹存储。

如果 Exchange Server 分析工具确定队列中滞留的邮件中，至少有 25％（在 To: 字段或 Cc: 字段中）要发往特定公用文件夹，则 Exchange Server 分析工具会显示警告。

如果 Exchange Server 分析工具确定队列中滞留的邮件中，至少有 50％（在 To: 字段或 Cc: 字段中）要发往特定公用文件夹，则 Exchange Server 分析工具会显示错误。

此警告或错误意味着标识的公用文件夹是 SMTP 队列中滞留的邮件的通用目标。

要解决此问题，请按如下方式调查该公用文件夹，以查出可能导致发往其中的邮件排队的配置问题或其他问题：

  • 确保该存储对象的属性设置正确，且 Active Directory 中的值正确无误。

  • 查看该公用文件夹对象的 Active Directory 权限设置是否正确。

  • 查找潜在的针对此公用文件夹的商业垃圾邮件 (UCE)、垃圾邮件或病毒攻击。

有关如何排除 SMTP 队列故障的详细信息，请参阅下列 Exchange 资源：

  • "Exchange Server Transport and Routing Guide"（Exchange Server 传输和路由指南）中的"Troubleshooting Mail Flow and SMTP"（排除邮件流和 SMTP 故障）(http://go.microsoft.com/fwlink/?LinkID=67875)。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)。


标识为通用目标的公用文件夹存储
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-10-04

Microsoft® Exchange Server 分析工具查询 Exchange_Queue Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP) 虚拟服务器的 SMTP 队列的下列属性值。

LinkId | 表示包含该队列的链接的标识符。
QueueId | 表示该队列的标识符。
QueueName | 表示该队列的名称。
VirtualMachine | 表示包含该队列的虚拟计算机的名称。
VirtualServerName | 表示该队列所在的虚拟服务器的名称。
MessageCount | 表示该队列中的邮件数。

Exchange Server 分析工具使用此处获取的信息来查询 Exchange_QueuedSMTPMessage WMI 类，以确定该队列中邮件的下列属性值。

Recipients | 表示邮件收件人。
Received | 表示邮件的接收时间戳。
MessageId | 表示队列中邮件的标识符。
StateRetry | 表示正在重新尝试传输未能成功传递的邮件。

最后，使用此处获取的数据查询 Active Directory® 目录服务，以确定每个 Recipient 对象的 distinguishedName 值。然后，Exchange Server 分析工具会确定该收件人是一位用户、一个通讯组、一个公用文件夹还是一个公用文件夹存储。

如果 Exchange Server 分析工具确定队列中滞留的邮件中，至少有 25％（在 To: 字段或 Cc: 字段中）的收件人的邮箱驻留在同一公用文件夹存储上，则 Exchange Server 分析工具会显示警告。

如果 Exchange Server 分析工具确定队列中滞留的邮件中，至少有 50％（在 To: 字段或 Cc: 字段中）的收件人的邮箱驻留在同一公用文件夹存储上，则 Exchange Server 分析工具会显示错误。

此警告或错误意味着标识的公用文件夹存储是 SMTP 队列中滞留的邮件的通用目标。

要解决此问题，请按如下方式调查该公用文件夹存储，以查出可能导致发往其中的邮件排队的配置问题或其他问题：

  • 确保该存储对象的属性设置正确，且 Active Directory 中的值正确无误。

  • 查看该存储对象的 Active Directory 权限设置是否正确。

  • 查找潜在的针对此公用文件夹的商业垃圾邮件 (UCE)、垃圾邮件或病毒攻击。

  • 检查对公用文件夹层次结构或内容进行的更改，这些更改可能在公用文件夹存储之间生成大量重复。

有关如何排除 SMTP 队列故障的详细信息，请参阅下列 Exchange 资源：

  • "Exchange Server Transport and Routing Guide"（Exchange Server 传输和路由指南）中的"Troubleshooting Mail Flow and SMTP"（排除邮件流和 SMTP 故障）(http://go.microsoft.com/fwlink/?LinkID=67875)。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)。

  • Microsoft 知识库文章 842273"如何在 Exchange 2000 Server 和 Exchange server 2003 中排除公用文件夹复制问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=842273)。


已启用收件人筛选
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以便确定简单邮件传输协议 (SMTP) 虚拟服务器对象的 msExchServerBindingsFiltering 属性是否指明，已对 SMTP 虚拟服务器实例启用了收件人筛选。

Exchange Server 分析工具还查询 Active Directory，以便确定 msExchRecipTurfListNames 或 msExchRecipTurfListOptions 属性是否指明在全局设置级别也启用了收件人筛选。

如果 Exchange Server 分析工具发现既在 SMTP 虚拟服务器实例又在全局设置级别启用了收件人筛选，则 Exchange Server 分析工具将显示警告。

此警告表明已有效地启用了收件人筛选。通常收件人筛选不会有问题。但是，在解决涉及此特定服务器的邮件流问题时，可能要验证筛选器配置或临时禁用收件人筛选，以确定它是否错误地阻止了发给有效收件人的邮件。

在 SMTP 虚拟服务器上禁用收件人筛选器

  1. 启动 Exchange 系统管理器：单击"开始"，指向"所有程序"，指向"Microsoft Exchange"，再单击"系统管理器"。

  2. 在控制台树中，展开"服务器"，然后依次展开所需的服务器、"协议"和"SMTP"。

  3. 用鼠标右键单击要对其启用筛选器的 SMTP 虚拟服务器，然后单击"属性"。

  4. 在"<SMTP Virtual Server> 属性"的"常规"选项卡上，单击"高级"。

  5. 在"高级"中选择要对其禁用筛选器的 IP 地址，然后单击"编辑"。

在"标识"中，清除"应用收件人筛选器"复选框来禁用筛选器。

  1. 如果有多台虚拟服务器，请对每台要禁用筛选器的虚拟服务器重复步骤 3 到 6。

有关如何配置收件人筛选器的详细信息，请参阅 Microsoft 知识库文章 823866"如何在 Exchange 2003 中配置连接筛选以使用实时阻止列表 (RBL) 以及如何配置收件人筛选"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823866)。

有关智能邮件筛选的详细信息，请参阅网站上的"Exchange Intelligent Message Filter"（英文）(http://go.microsoft.com/fwlink/?LinkId=21607)。


"远程传递"队列已冻结
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具查询 ExchangeLink Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP)"远程传递"队列的 StateFrozen 关键字的值。

如果 Exchange Server 分析工具发现 Exchange 服务器上"远程传递"队列的 StateFrozen 关键字的值已设置为 True，则 Exchange Server 分析工具会显示错误。

已冻结的队列意味着该队列的传输会话已停止。虽然可以添加新的邮件，但已冻结的队列会阻止出站邮件。可以使用每个链接队列上的快捷菜单手动更改连接状态。使用"强制连接"命令将队列状态更改为"活动"后，可以立即启用从该队列发送邮件的连接。

"远程传递"队列存放要进行远程传递的邮件。队列的名称与远程传递目标相匹配。该目标可能是连接器、服务器或域。

要解决此错误，请使用 NSlookup 实用程序来检查域名系统 (DNS) 解析可能存在的问题。对于连接和协议问题，如主机不可访问错误，请使用 Telnet.exe 尝试连接到目标计算机。要解决协议错误，请为 SMTP 协议组件的 MSExchangeTransport 服务增加诊断日记记录，并检查日志中的错误。也可以使用网络监视器 (Netmon.exe) 工具来获取有关网络连接错误的信息。要使此问题再次出现，可能需要强制队列重试。检查事件日志以寻找可能与 Microsoft Exchange Information Store 服务关联的错误。

有关如何修改日志记录设置的详细信息，请参阅"Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 的"排除邮件流和 SMTP 故障"部分中的"如何修改 MSExchangeTransport 的日志记录设置"。

有关如何解决 SMTP 队列问题的详细信息，请参阅以下 Exchange 资源：

  • "Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"排除邮件流和 SMTP 故障"。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=823489)。

  • Miscrosoft 知识库文章 821877"Description of Fields on the SMTP and X.400 Queue Properties Tabs"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)。

  • Miscrosoft 知识库文章 264054"XCON:Understanding Queue States in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


"远程传递"队列处于重试状态
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具查询 ExchangeLink Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP)"远程传递"队列的 StateRetry 关键字的值。

如果 Exchange Server 分析工具发现 Exchange 服务器上"远程传递"队列的 StateRetry 关键字的值已设置为 True，则 Exchange Server 分析工具会显示错误。

如果队列处于重试状态，则该状态表明以前尝试处理此队列中的邮件时，至少出现了一个错误。可以使用"强制连接"命令将重试状态或预定状态中的队列更改为活动。这会使队列处于活动中，就好像重试间隔已过或预定时间已到一样。但是，此方法可能不会始终有效。

注意：
队列的属性可以表明队列处于重试状态的特定原因。

"远程传递"队列存放要进行远程传递的邮件。队列的名称与远程传递目标相匹配。该目标可能是连接器、服务器或域。

要解决此错误，请使用 NSlookup 实用程序来检查域名系统 (DNS) 解析可能存在的问题。对于连接和协议问题，如主机不可访问错误，请使用 Telnet.exe 尝试连接到目标计算机。要解决协议错误，请为 SMTP 协议组件的 MSExchangeTransport 服务增加诊断日记记录，并检查日志中的错误。也可以使用网络监视器 (Netmon.exe) 工具来获取有关网络连接错误的信息。要使此问题再次出现，可能需要强制队列重试。检查事件日志以寻找可能与 Microsoft Exchange Information Store 服务关联的错误。

有关如何修改日志记录设置的详细信息，请参阅"Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 的"排除邮件流和 SMTP 故障"部分中的"如何修改 MSExchangeTransport 的日志记录设置"。

有关如何解决 SMTP 队列问题的详细信息，请参阅以下 Exchange 资源：

  • "Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"排除邮件流和 SMTP 故障"。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=823489)。

  • Miscrosoft 知识库文章 821877"Description of Fields on the SMTP and X.400 Queue Properties Tabs"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)。

  • Miscrosoft 知识库文章 264054"XCON:Understanding Queue States in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


"远程传递"队列问题
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具将测试邮件从 Exchange 服务器发送到简单邮件传输协议 (SMTP) 域的邮局主管帐户或用户定义的帐户，然后扫描服务器的邮件跟踪日志，以确定测试邮件传输是否存在问题。

作为扫描的一部分，Exchange Server 分析工具查询 root\MicrosoftExchangeV2 命名空间下的 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 类的 EntryType 属性，以便确定产生该邮件跟踪日志项的原因。

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • 可以成功扫描邮件跟踪日志。

  • 测试邮件没有成功地从队列中传出。

  • 没有生成未送达报告 (NDR)。

  • EntryType 属性存在值 1034。

该错误表明对于发送服务器，测试邮件仍位于一个简单邮件传输协议 (SMTP)"远程传递"队列中，并且此队列存在问题。

"远程传递"队列存放要进行远程传递的邮件。队列的名称与远程传递目标相匹配。该目标可能是连接器、服务器或域。

要解决此错误，请使用 NSlookup 实用程序来检查域名系统 (DNS) 解析可能存在的问题。对于连接和协议问题，如主机不可访问错误，请使用 Telnet.exe 尝试连接到目标计算机。要解决协议错误，请为 SMTP 协议组件的 MSExchangeTransport 服务增加诊断日记记录，并检查日志中的错误。也可以使用网络监视器 (Netmon.exe) 工具来获取有关网络连接错误的信息。要使此问题再次出现，可能需要强制队列重试。检查事件日志以寻找可能与 Microsoft Exchange Information Store 服务关联的错误。

有关如何修改日志记录设置的详细信息，请参阅"Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 的"排除邮件流和 SMTP 故障"部分中的"如何修改 MSExchangeTransport 的日志记录设置"。

有关如何解决 SMTP 队列问题的详细信息，请参阅以下 Exchange 资源：

  • "Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"排除邮件流和 SMTP 故障"。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=823489)。

  • Miscrosoft 知识库文章 821877"Description of Fields on the SMTP and X.400 Queue Properties Tabs"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)。

  • Miscrosoft 知识库文章 264054"XCON:Understanding Queue States in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


重试分类
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具将测试邮件从 Exchange 服务器发送到简单邮件传输协议 (SMTP) 域的邮局主管帐户或用户定义的帐户，然后扫描服务器的邮件跟踪日志，以确定测试邮件传输是否存在问题。

作为此扫描的一部分，Exchange Server 分析工具查询 root\MicrosoftExchangeV2 命名空间下的 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 类的 EntryType 属性，以确定导致邮件跟踪日志项的原因。

如果 Exchange Server 分析工具发现 EntryType 属性的值为 1032，则 Exchange Server 分析工具将显示警告。

该警告说明测试邮件位于为分类重试安排的队列中。如果队列处于重试状态，则该状态表明以前尝试处理此队列中的邮件时，至少出现了一个错误。可以使用"强制连接"命令将重试状态或预定状态中的队列更改为活动。这会使队列处于活动中，就好像重试间隔已过或预定时间已到一样。但是，此方法可能不会始终有效。

注意：
队列的属性可以表明队列处于重试状态的特定原因。

由于高级队列引擎无法对邮件进行分类，因此邮件通常会在等待重试的队列中累积。高级队列引擎可能无法访问全局编录服务器和收件人信息，或者全局编录服务器不可访问或执行缓慢。此外，邮件可能会因以下原因而发生累积：

  • Active Directory 不可用。

    注意：
    分类程序使用 Active Directory 对邮件进行分类。
  • 如果许多邮件在预分类队列中进行排队，则 Active Directory 可能负载过多。

  • 存在转换故障分类程序还处理内容转换。

  • 邮件分类程序无法找到邮箱存储。

  • 如果重新安装或删除 SMTP，则下列 IIS 元数据库关键字可能失效：/smtpsvc/DsUseCat 和 /smtpsvc/vsi#/DsUseCat。

    注意：
    确定是否已重新安装或删除了 SMTP。

如果队列处于"重试"状态，请检查队列的属性以确定原因。例如，如果队列属性显示类似"已发生 SMTP 错误"的消息，则应查看服务器的事件日志以查找任何 SMTP 错误。如果日志中没有事件，则应增加 SMTP 协议日志记录级别。

有关如何解决 SMTP 队列问题的详细信息，请参阅以下 Exchange 资源：

  • "Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"排除邮件流和 SMTP 故障"。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=823489)。

  • Miscrosoft 知识库文章 821877"Description of Fields on the SMTP and X.400 Queue Properties Tabs"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)。

  • Miscrosoft 知识库文章 264054"XCON:Understanding Queue States in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


重试本地传递
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-04

Microsoft® Exchange Server 分析工具将测试邮件从 Exchange 服务器发送到简单邮件传输协议 (SMTP) 域的邮局主管帐户或用户定义的帐户，然后扫描服务器的邮件跟踪日志，以确定测试邮件传输是否存在问题。

作为扫描的一部分，Exchange Server 分析工具查询 root\MicrosoftExchangeV2 命名空间下的 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 类的 EntryType 属性，以确定邮件跟踪日志项的原因。

如果 Exchange Server 分析工具发现 EntryType 属性的值为 1037，则 Exchange Server 分析工具将显示警告。

该警告表明前面尝试处理"本地传递"队列中的邮件时至少发生了一个错误。

"本地传递"队列包含在 Exchange 服务器上列队以本地传递到 Exchange Server 邮箱或公用文件夹存储的邮件。

如果 Exchange 服务器不接受本地传递的邮件，邮件就可能在该队列中累积。邮件传递缓慢或有间断可以表明存在循环邮件或性能问题。

可以使用"强制连接"命令将处于"重试"或"已安排"状态的队列更改为"活动"状态。这样队列就会像已经过重试间隔或者到达安排的时间一样开始运转。但是，这种方法并不总是行得通。

注意：
队列的属性可以表明队列处于"重试"状态的具体原因。

要改正这种错误，增加对 MSExchangeIS 和 MSExchangeTransport 服务 SMTP 存储驱动程序组件的诊断日志记录。

有关如何修改日志记录设置的详细信息，请参阅"Exchange Server 传输和路由指南"(http://go.microsoft.com/fwlink/?LinkId=47579) 的"Troubleshooting Mailflow and SMTP"部分中的"How to Modify Logging Settings for MSExchangeTransport"。

有关如何解决 SMTP 队列问题的详细信息，请参阅以下 Exchange 资源：

  • "Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"Troubleshooting Mail Flow and SMTP"。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)。

  • Microsoft 知识库文章 821877"Description of Fields on the SMTP and X.400 Queue Properties Tabs"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)。

  • Microsoft 知识库文章 264054"XCON： 了解队列说明 Exchange 2000 服务器"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


重试路由
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具将测试邮件从 Exchange 服务器发送到简单邮件传输协议 (SMTP) 域的邮局主管帐户或用户定义的帐户，然后扫描服务器的邮件跟踪日志，以确定测试邮件传输是否存在问题。

作为此扫描的一部分，Exchange Server 分析工具查询 root\MicrosoftExchangeV2 命名空间下的 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 类的 EntryType 属性，以确定导致邮件跟踪日志项的原因。

如果 Exchange Server 分析工具发现 EntryType 属性的值为 1035，则 Exchange Server 分析工具将显示警告。

该警告说明测试邮件位于为路由重试安排的队列中。如果队列处于重试状态，则该状态表明以前尝试处理此队列中的邮件时，至少出现了一个错误。可以使用"强制连接"命令将重试状态或预定状态中的队列更改为活动。这会使队列处于活动中，就好像重试间隔已过或预定时间已到一样。但是，此方法可能不会始终有效。

注意：
队列的属性可以表明队列处于重试状态的特定原因。

如果 Exchange Server 路由存在问题，则邮件会在等待重试的队列中累积。由于暂时的错误邮件没有得到路由，即路由引擎没有成功地初始化。邮件或者处于等待重试的预路由队列中，或者正在被重新路由。

要解决此问题，请增加对 MSExchangeTransport 服务的诊断日志记录以收集有关路由类别组件的信息。因为连接器限制会严重降低服务器的性能，所以应禁用任何不需要的连接器限制。可能必须为某些限制启用 CheckConnectorRestrictions 注册表项。

有关如何修改日志记录设置的详细信息，请参阅"Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 的"排除邮件流和 SMTP 故障"部分中的"如何修改 MSExchangeTransport 的日志记录设置"。

有关如何解决 SMTP 队列问题的详细信息，请参阅以下 Exchange 资源：

  • "Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"排除邮件流和 SMTP 故障"。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=823489)。

  • Miscrosoft 知识库文章 821877"Description of Fields on the SMTP and X.400 Queue Properties Tabs"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)。

  • Miscrosoft 知识库文章 264054"XCON:Understanding Queue States in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


元数据库中已启用反向 DNS 查找，但在 Active Directory 中关联的 SMTP 服务器上未启用该功能
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-01-17

Microsoft® Exchange Server 分析工具读取 Internet 信息服务 (IIS) 元数据中的以下属性，以确定它的值是否与 Active Directory® 目录服务中 msExchSmtpPerformReverseDnsLookup 属性的配置值相匹配：

/LM/SmtpSvc/<SMTP virtual server instance>/EnableReverseDnsLookup

如果 Exchange Server 分析工具发现上述两个值不匹配，则显示警告消息。

如果 IIS 元数据库中的值与 Active Directory 中的值不匹配，则可以说明 Active Directory 复制有问题，或者 Exchange 中的 Directory-service-to-Metabase-replication (DS2MB) 组件有问题。

DS2MB 进程的功能是将配置信息从 Active Directory 传输到本地元数据库。由于性能和可伸缩性原因，该配置存储在本地元数据库中，而没有存储在注册表中。在 Exchange 2000 Server 和 Exchange Server 2003 中，所有 Internet 协议（SMTP、NNTP、POP3、IMAP4 和 HTTP）都作为 IIS 的组件运行。

每过 15 分钟，DS2MB 进程就会在不更改子目录树形状的情况下，从 Active Directory 复制整个子目录树。这是从 Active Directory 到元数据库的单向写入；元数据库永远不会写入 Active Directory。

EnableReverseDnsLookup 属性和 msExchSmtpPerformReverseDnsLookup 属性都可以具有值 TRUE 或 FALSE。值为 TRUE 意味着 SMTP 虚拟服务器将对所有传入邮件执行反向 DNS 查找。值为 FALSE 意味着将不执行反向 DNS 查找。因为存在由于配置不正确的 DNS 记录或 Internet 连接时断时续而导致的性能降级的可能性，默认情况下 EnableReverseDnsLookup 属性和 msExchSmtpPerformReverseDnsLookup 属性被设置为 FALSE。

如果 EnableReverseDnsLookup 属性被设置为 TRUE（启用）而 msExchSmtpPerformReverseDnsLookup 属性被设置为 FALSE（禁用），则意味着 Active Directory 和 IIS 元数据库不同步。如果问题是由 DS2MB 进程失败所导致的，则可以针对您正在运行的 Exchange Server 版本执行下列过程，来纠正该问题。如果问题是由 Active Directory 复制发生了部分或全部失败所导致的，则可以使用 Active Directory 复制监视实用程序 (ReplMon.exe) 来检查 Active Directory 复制的运行状况和状态。可以在 Windows Server CD-ROM 上的 Windows® 支持工具中找到 ReplMon.exe。

在 Exchange Server 2003 上更正此错误

  1. 检查是否出现了事件源为 MSExchangeMU 的应用程序事件日志条目。如果 DS2MB 失败，它将在 Exchange Server 2003 上记录一个事件。

  2. 如果没有看见任何 DS2MB 失败，请使用 ReplMon 诊断 Active Directory 复制。尤其要注意 SMTP 虚拟服务器所使用的全局编录服务器。

  3. 如果看见 DS2MB 失败，或者已经消除或解决了 Active Directory 复制的任何问题，请重新启动 Exchange 系统助理服务。

在 Exchange 2000 Server 上更正此错误

  1. 使用 ReplMon 诊断 Active Directory 复制。尤其要注意 SMTP 虚拟服务器所使用的全局编录服务器。

  2. 消除或解决 Active Directory 复制存在的任何问题之后，重新启动 Exchange 系统助理服务。

有关 Exchange 中的反向 DNS 查找功能的详细信息，请参阅 Microsoft 知识库文章 297412"The 'Perform Reverse DNS Lookup for Incoming Messages' Option Is for Host Name Resolution"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412)。

有关 SMTP 虚拟服务器设置的详细信息，请参阅 Microsoft 知识库文章 266686"XCON：如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn) 和文章 268163"XCON:How to Configure a SMTP Virtual Server Part 2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)。

有关 Active Directory 复制的详细信息，请参阅 Microsoft 知识库文章 232072"Initiating Replication Between Active Directory Direct Replication Partners"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072)。

有关 DS2MB 进程的详细信息，请参阅 Microsoft 知识库文章 240105"XGEN:General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105)。


路由引擎：AttachedTimeout 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 SMTP（简单邮件传输协议）连接器路由逻辑是否已从默认设置更改为其他设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\AttachedTimeout

如果 Exchange Server 分析工具发现 AttachedTimeout 注册表项存在并且配置的值大于 300，则会显示非默认配置消息。

AttachedTimeout 注册表项是 Exchange Server 的自定义配置设置，确定 ORG_INFO 数据包的发送频率。每次路由客户端未连接到路由服务器时，拓扑的用户版本将递增，将使 ORG_INFO 数据包在整个组织中广播。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. 删除 AttachedTimeout 注册表项。

  4. 关闭注册表编辑器。

  5. 重新启动 IIS 管理服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 AttachedTimeout 注册表值的详细信息，请参阅知识库文章 832281"Link state issues and routing issues in Exchange 2000 Server and in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832281)。


路由引擎：BestAddressMatchOnly 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已将简单邮件传输协议 (SMTP) 连接器路由逻辑从以下默认设置修改为其他设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\BestAddressMatchOnly

如果 Exchange Server 分析工具发现 BestAddressMatchOnly 注册表项存在并且配置的值大于 0，则显示非默认配置消息。

BestAddressMatchOnly 注册表项是 Exchange Server 的自定义配置设置，强制发送到特定域的邮件通过特定的连接器路由，无论是否存在限制。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. 删除 BestAddressMatchOnly 注册表项。

  4. 关闭注册表编辑器。

  5. 重新启动 IIS 管理服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


路由引擎：CheckConnectorRestrictions 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 SMTP（简单邮件传输协议）连接器路由逻辑是否已从默认设置更改为其他设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\CheckConnectorRestrictions

如果 Exchange Server 分析工具发现 CheckConnectorRestrictions 注册表项存在并且配置的值大于 0，则显示非默认配置消息。

CheckConnectorRestrictions 注册表项是 Exchange Server 的自定义配置设置，允许对 Exchange 桥头服务器（所检查的连接器的源）进行限制检查。默认情况下禁用连接器限制检查，因为该检查会显著影响性能，尤其是对于使用许多通讯组的配置。将对每封通过该系统发送到每个通讯组的每个成员的邮件检查限制。如果指定了限制，但是此注册表项不存在，则不会执行限制检查。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. 删除 CheckConnectorRestrictions 注册表项。

  4. 关闭注册表编辑器。

  5. 重新启动 IIS 管理服务。

  6. 在连接器的"传递限制"选项卡上，重新启用限制选项。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 CheckConnectorRestrictions 注册表值的详细信息，请参阅知识库文章 277872"XCON:Connector Delivery Restrictions May Not Work Correctly"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872)。


路由引擎：Configuration 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 Exchange 路由引擎设置的 Active Directory® 目录服务读取间隔是否已从默认设置更改为其他设置：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RESvc\Parameters\ReloadOsInterval

如果 Exchange Server 分析工具发现 ReloadOsInterval 数值数据的设置不是 3600，则会显示非默认配置消息。

ReloadOsInterval 值用于指定在两台运行 Exchange 的服务器之间更新路由链接状态信息的间隔。Exchange 使用路由链接状态信息使每台服务器可以确定成本最低的邮件传递路由，并确定组成路由的连接器是否正常工作。默认情况下，Exchange 服务器每隔 3,600 秒（即 1 小时）从 Active Directory 读取一次链接状态信息。

在某些情况下，路由状态信息可能无法正确地在整个 Exchange 组织的各个服务器之间动态传播。组织中的某些服务器仍在使用可能不正确的旧路由状态信息运行。这种情况的结果可能是，在使用 WinRoute 工具 (Winroute.exe) 查看远程路由组时，新连接器不会出现。可以使用 WinRoute 工具验证链接状态信息是否在传播。若要验证信息是否在传播，请使用 WinRoute 工具从 Exchange 组织中的几个不同位置查看链接状态信息，然后将每个路由组的版本号进行比较。WinRoute 工具连接到 Exchange Server 计算机上的链接状态端口，并提取 Exchange 组织的链接状态信息。尽管链接状态信息是一系列全局唯一标识符 (GUID)，但是，WinRoute 可以将连接器和桥头服务器的 GUID 与 Active Directory 中的对象进行匹配，然后以适合阅读的格式提供信息。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\SYSTEM\CurrentControlSet\Services\RESvc\Parameters

  3. 在右侧窗格中，双击 ReloadOsInterval。

  4. 在"数值数据"框中，输入 3600，再单击"确定"。

  5. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关路由和链接状态信息的详细信息，请参阅下列知识库文章：

  • 842026"Routing status information is not propagated correctly to all servers in Exchange 2000 Server or in Exchange Server 2003"（不能正确地将路由状态信息传播到所有 Exchange 2000 Server 或 Exchange Server 2003 中的服务器）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=842026)

  • 285130"XCON：链接状态信息）"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=285130)

若要下载 WinRoute 工具来帮助您确定路由主服务器已知的链接状态信息，请参阅"Exchange Server WinRoute"(http://go.microsoft.com/fwlink/?LinkId=25049)。


路由引擎：PollingInterval 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 SMTP（简单邮件传输协议）连接器路由逻辑是否已从默认设置更改为其他设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\PollingInterval

如果 Exchange Server 分析工具发现 PollingInterval 注册表项存在并且配置的值大于 300，则会显示非默认配置消息。

PollingInterval 注册表项是 Exchange Server 的自定义配置设置，帮助控制路由组之间的链接状态通信的频率，尤其是与路由组内的路由组主服务器之间的通信。增大此设置可以避免连接失败，但是可能使您无法解决路由组成员之间链接速度慢的更大问题。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. 删除 PollingInterval 注册表项。

  4. 关闭注册表编辑器。

  5. 重新启动 IIS 管理服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


路由引擎：StateChangeDelay 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已将简单邮件传输协议 (SMTP) 连接器路由逻辑从以下默认设置修改为其他设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\StateChangeDelay

如果 Exchange Server 分析工具发现 StateChangeDelay 注册表项存在并且配置的值大于 0，则显示非默认配置消息。

StateChangeDelay 注册表项是 Exchange Server 的自定义配置设置，帮助控制连接器标记为不可用的间隔以及因为连接器和服务器状态改变出现的通知。如果 StateChangeDelay 设置的值大于 0，服务器在此值设置的每个时段中只能标记为可用或不可用一次。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. 删除 StateChangeDelay 注册表项。

  4. 关闭注册表编辑器。

  5. 重新启动 IIS 管理服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


路由引擎：SuppressStateChanges 参数为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 SMTP（简单邮件传输协议）连接器路由逻辑是否已从默认设置更改为其他设置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\SuppressStateChanges

如果 Exchange Server 分析工具发现 SuppressStateChanges 注册表项存在并且配置的值大于 0，则会显示非默认配置消息。

Exchange Server 2003 具有自动检测链接状态更改的功能。此信息可以用于通知其他运行 Exchange Server 2003 的服务器：应使用备选路由，而不应使用最低成本主要路由。链接状态信息分为主要更改和次要更改。在管理员更改路由拓扑时（例如添加新的连接器或成本改变），将发生主要更改。如果系统自动检测到链接的故障或还原，将发生次要更改。

此功能适用于中小型组织。但是，在大型多站点环境中，网络的巨大变化可能会使次要版本产生大量链接更新。若要真正有效，链接状态数据必须广播到组织中的所有服务器。此外，在状态更改时，整个链接状态表将重新广播，这可能会产生大量的数据通过网络传输。在这些情况下，可能需要禁止次要链接状态更改。SuppressStateChanges 注册表项是用于禁止次要链接状态更改的自定义配置设置。如果 SuppressStateChanges 的设置大于 0，将禁止此 Exchange Server 计算机上的所有链接状态更改。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. 删除 SuppressStateChanges 注册表项。

  4. 关闭注册表编辑器。

  5. 重新启动简单邮件传输协议 (SMTP)、Microsoft Exchange 路由引擎和 Microsoft Exchange MTA 堆栈服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 SuppressStateChanges 注册表项的详细信息，请参阅下列 Microsoft 指南：

  • "Exchange Server 2003 传输和路由指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=c092b7a7-9034-4401-949c-b29d47131622&DisplayLang=zh-cn)

  • "Exchange Server 2003 性能和可伸缩性指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&displaylang=zh-cn)


已设置通讯组传递限制的路由组连接器
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-09-06

Microsoft® Exchange Server 分析工具将查询在 Active Directory® 目录服务中检测到的每个路由组连接器对象 (msExchRoutingGroupConnector) 的下列属性，以确定是否已为这些路由组连接器设置基于通讯组成员身份的传递限制。

dLMemRejectPerms | 包含通讯组列表 (DL) 的域名 (DN)，这些列表的成员不可以通过此路由组连接器发送数据。
dLMemSubmitPerms | 包含通讯组列表 (DL) 的域名 (DN)，这些列表的成员可以通过此路由组连接器发送数据。

如果 Exchange Server 分析工具确定存在已设置基于通讯组成员身份的传递限制的路由组连接器，则 Exchange Server 分析工具将显示警告。

此警告指示基于通讯组成员身份的传递限制可能会影响 Exchange 邮件流性能。

使用已设置基于通讯组成员身份的传递限制的路由组连接器发送邮件时，邮件分类程序必须展开通讯组的成员身份，获取成员 DN 的完整列表，然后将此 DN 列表与发送人 DN 列表进行比较。如果两个列表上的 DN 匹配，则会执行访问操作或拒绝操作。如果某个通讯组嵌套在另一个通讯组中，则也会展开嵌套的通讯组。

若要解决此警告，请执行下列操作：

  • 针对连接器限制设计专用的路由组，并将其配置到本地路由组，请参考 Microsoft 知识库文章 329171"XADM:Mail Delivery Is Slow if Recipients Are Configured with Delivery Restrictions Based on Group Membership"（XADM：如果为收件人配置了基于组成员身份的传递限制，则邮件传递速度将会减慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)。

  • 将专用且更可靠的全局编录服务器用作连接器的指定桥头服务器。

  • 配置各个邮箱，而不是配置传递限制的通讯组，请参考 Microsoft 知识库文章 812298"Mail delivery is slow after you configure delivery restrictions that are based on a distribution list"（配置基于通讯组列表的传递限制后，邮件传递的速度将会减慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。

  • 考虑实现简单邮件传输协议 (SMTP) 发件人筛选。

  • 对于运行 Exchange Server 2003 Service Pack 2 (SP2) 或更高版本的服务器，请考虑实现非分层限制检查。对于运行早于 Exchange 2003 SP2 的 Exchange 版本的服务器，请考虑升级为 Exchange 2003 SP2。

详细信息

有关非分层限制检查的详细信息，请参阅考虑非层次限制检查

有关 SMTP 发件人筛选的详细信息，请参阅"Exchange Server 2003 管理指南"中的"How to Enable Sender Filtering"（如何启用发件人筛选）(http://go.microsoft.com/fwlink/?LinkId=72967)。

有关通讯组限制对 Exchange 邮件流的影响的详细信息，请参阅下列 Microsoft 知识库文章：

  • 329171"XADM:Mail Delivery Is Slow if Recipients Are Configured with Delivery Restrictions Based on Group Membership"（XADM：为收件人配置了基于组成员身份的传递限制后，邮件传递的速度将会减慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)。

  • 895407"In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"（在 Exchange Server 2003 中，配置基于通讯组的传递限制后，向本地邮箱和外部邮箱传递邮件的速度比预期速度要慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 839949"Troubleshooting mail transport and distribution groups in Exchange 2000 Server and in Exchange Server 2003"（排除 Exchange 2000 Server 和 Exchange Server 2003 中的邮件传输和通讯组问题）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。


路由组主服务器已经删除
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定每个路由组容器的 msExchRoutingMasterDN 属性。如果 Exchange Server 分析工具发现 msExchRoutingMasterDN 属性的值包含字符串"DEL:"，则显示错误。

msExchRoutingMasterDN 属性是单值的属性，它存储了充当每个路由组的路由组主服务器的 Exchange Server 计算机的可分辨名称。如果字符串"DEL:"存在，则指示使用 Active Directory 用户和计算机工具删除了先前的路由组主服务器。如果没有路由组主服务器，Exchange 将无法正确更新或维护路由拓扑结构。

创建路由组时，该路由组中的第一台服务器会被赋予路由组主服务器的角色。路由组主服务器维护其路由组的最新链接状态信息，并将它传播到路由组内的其他服务器。路由组主服务器仅监视写入到 Active Directory 中的路由配置中与其路由组有关的部分。成员服务器可以将任何连接器状态或服务器可用性信息传递到路由组主服务器。例如，如果成员服务器试图通过连接器连接另一个路由组中的另一台服务器，而该链接不可用，则成员服务器会立即通知路由组主服务器。同样，当非主服务器收到新的链接状态信息时，会立即将连接器状态信息传递到路由组主服务器，以便其他服务器可以收到有关路由变化的信息。

更正此错误

  1. 在 Exchange 系统管理器的"管理组"下，展开 Administrative_Group，再展开"路由组"。

  2. 展开路由组，再单击"成员"。

  3. 在右侧窗格中，用鼠标右键单击想要将其配置为路由组主服务器的 Exchange 计算机，再单击"设为主服务器"。

有关路由组主服务器的详细信息，请参阅"Exchange Server 2003 传输和路由指南"中的"配置路由拓扑"(http://go.microsoft.com/fwlink/?linkid=47579)。


路由组成员身份错误
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-08-21

Microsoft® Exchange Server 分析工具将查询 Active Directory® 目录服务，以获取 Routing Group 对象上的每个 msExchRoutingGroupMembersBL 属性值，从而确定后端链接服务器是否属于专用的 Microsoft Exchange Server 2007 管理组 Exchange Administrative Group (FYDIBOHF23SPDLT)。

Exchange Server 分析工具还将查询 Routing Group 对象的 CN 属性值，以确定该值是否等于 Exchange 2007 路由组默认值 Exchange Routing Group (DWBGZMFD01QNBJR)。

如果下列条件为真，则 Exchange Server 分析工具将显示错误：

  • 向后链接的服务器属于专用的 Exchange 2007 管理组 Exchange Administrative Group (FYDIBOHF23SPDLT)。

  • 路由组不是 Exchange 2007 路由组默认值 Exchange Routing Group (DWBGZMFD01QNBJR)。

此错误指示可能已将 Exchange 2007 默认路由组中手动删除服务器。这可能会导致路由问题。

Microsoft Exchange Server 2003 和 Microsoft Exchange 2000 Server 使用路由组来定义特定于 Exchange 的路由拓扑。Exchange 2007 使用 Active Directory 站点来定义其路由拓扑。Exchange 2003 和 Exchange 2000 使用基于路由组和连接器的路由拓扑。纯 Exchange 2007 组织中不需要特定于 Exchange 的路由配置。纯 Exchange 2007 组织使用 Active Directory 站点拓扑来确定其路由拓扑。

为了使这两种路由拓扑共存，在安装 Exchange 2007 时，会自动将所有 Exchange 2007 服务器添加到单个路由组。在 Exchange 2003 或 Exchange 2000 中，Exchange 系统管理器会将 Exchange 2007 路由组识别为 Exchange Administrative Group (FYDIBOHF23SPDLT) 内的 Exchange Routing Group (DWBGZMFD01QNBJR)。

若要解决此问题，请将 Exchange 2007 服务器移至 Exchange 2007 专用路由组，或者删除并重新安装服务器。


发送连接器已禁用
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-07-30

Microsoft Exchange 分析工具使用以下 Exchange 命令行管理程序 cmdlet 查询 Exchange 环境中所有已将其"启用"属性值设置为 False 的发送连接器。发送连接器"启用"属性的值设置为 False 表示发送连接器被禁用。

Get-SendConnector | where { $_.Enabled -eq $False}

然后 Exchange 分析工具会查询 Active Directory 目录服务，以确定具有 msExchExchangeServer 对象类的所有对象的 serialNumber 属性值。

如果字符串值包含"Version 5.5"，则说明计算机运行的是 Microsoft Exchange Server 5.5。如果字符串值包含"Version 6.0"，则说明计算机运行的是 Exchange 2000 Server。如果字符串值包含"Version 6.5"，则说明计算机运行的是 Exchange Server 2003。如果字符串值包含"Version 8"，则说明计算机运行的是 Exchange Server 2007。

如果 Exchange 分析工具确定在同时具有 Exchange 2000 或 Exchange 2003 服务器的 Exchange 环境中禁用了发送连接器，则 Exchange 分析工具将会显示错误。

此错误表示当 Exchange 2007 路由忽略禁用的发送连接器时，Exchange 2000 和 Exchange 2003 将不会识别连接器的禁用标记，可能仍会试图通过连接器造成的路由循环来路由邮件。

若要解决该错误，请在正在运行 Exchange 2000 或 Exchange 2003 的 Exchange 环境中删除所有禁用的发送连接器。

若要删除禁用的发送连接器，请按照 Exchange Server 2007 产品文档中主题为"删除和发送连接器"中使用 Exchange 命令行管理程序 Remove-SendConnector cmdlet (http://go.microsoft.com/fwlink/?LinkId=96007) 的指导进行操作。


已启用发件人筛选
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以便确定简单邮件传输协议 (SMTP) 虚拟服务器对象的 msExchServerBindingsTurflist 属性是否指明，已为 SMTP 虚拟服务器实例启用了发件人筛选。

Exchange Server 分析工具还查询 Active Directory，以确定 msExchTurfListNames 或 msExchTurfListOptions 属性是否指明在全局设置级别也启用了发件人筛选。

Exchange Server 分析工具显示警告的前提是下列条件为真：

  • 在 SMTP 虚拟服务器实例中启用了发件人筛选。

  • 在全局设置级别启用了发件人筛选。

该警告表明已有效地启用了发件人筛选。除非要解决涉及该特定服务器的邮件流问题，否则发件人筛选通常不是问题。如果出现发件人筛选问题，则可能需要验证筛选器配置是否正确，或者临时禁用发件人筛选以确定它是否错误地阻止了来自有效发件人的合法邮件。

在 SMTP 虚拟服务器上禁用发件人筛选器

  1. 启动 Exchange 系统管理器：单击"开始"，指向"所有程序"，指向"Microsoft Exchange"，再单击"系统管理器"。

  2. 在控制台树中，展开"服务器"，然后依次展开所需的服务器、"协议"和"SMTP"。

  3. 用鼠标右键单击要启用筛选器的 SMTP 虚拟服务器，然后单击"属性"。

  4. 在"<SMTP 虚拟服务器> 属性"中的"常规"选项卡上，单击"高级"。

  5. 在"高级"中选择要禁用筛选器的 IP 地址，然后单击"编辑"。

  6. 在"标识"中，清除"应用发件人筛选器"复选框来禁用筛选器。

  7. 如果有多台虚拟服务器，请对每台要禁用筛选器的虚拟服务器重复步骤 3 到 6。

有关智能邮件筛选的详细信息，请访问网站上的"Exchange Intelligent Message Filter"（英文）(http://go.microsoft.com/fwlink/?LinkId=21607)。

有关如何配置筛选并控制垃圾邮件的详细信息，请参阅"Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"配置筛选并控制垃圾邮件"。


已启用发件人 ID 筛选
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以便确定简单邮件传输协议 (SMTP) 虚拟服务器对象的 msExchServerBindingsFiltering 属性是否指明，已为 SMTP 虚拟服务器实例启用了发件人 ID 筛选。

Exchange Server 分析工具还查询 Active Directory，以确定"UCE 内容筛选器"对象的 wWWHomePage 属性是否包含发件人 ID 和连接筛选的项。

Exchange Server 分析工具显示警告的前提是下列条件为真：

  • 在 SMTP 虚拟服务器实例中启用了发件人筛选。

  • 在"UCE 内容筛选器"对象级别启用了发件人筛选。

该警告表明已有效地启用了发件人 ID 筛选。除非要解决涉及该特定服务器的邮件流问题，否则发件人 ID 筛选通常不是问题。如果出现发件人 ID 筛选问题，则可能需要验证筛选器配置是否正确，或者临时禁用发件人 ID 筛选以确定它是否错误地阻止了来自有效发件人的邮件。

在 SMTP 虚拟服务器上禁用发件人 ID 筛选器

  1. 启动 Exchange 系统管理器：单击"开始"，指向"所有程序"，指向"Microsoft Exchange"，再单击"系统管理器"。

  2. 在控制台树中，展开"服务器"，然后依次展开所需的服务器、"协议"和"SMTP"。

  3. 用鼠标右键单击要禁用筛选器的 SMTP 虚拟服务器，然后单击"属性"。

  4. 在"<SMTP 虚拟服务器> 属性"中的"常规"选项卡上，单击"高级"。

  5. 在"高级"中选择要禁用筛选器的 IP 地址，然后单击"编辑"。

  6. 在"标识"中，清除"应用发件人筛选器"复选框来禁用筛选器。

  7. 如果有多台虚拟服务器，请对每台要禁用筛选器的虚拟服务器重复步骤 3 到 步骤 6。

有关智能邮件筛选的详细信息，请访问网站上的"Exchange Intelligent Message Filter"（英文）(http://go.microsoft.com/fwlink/?LinkId=21607)。


标识为通用目标的服务器
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-10-04

Microsoft® Exchange Server 分析工具查询 Exchange_Queue Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP) 虚拟服务器的 SMTP 队列的下列属性值。

LinkId | 表示包含该队列的链接的标识符。
QueueId | 表示该队列的标识符。
QueueName | 表示该队列的名称。
VirtualMachine | 表示包含该队列的虚拟计算机的名称。
VirtualServerName | 表示该队列所在的虚拟服务器的名称。
MessageCount | 表示该队列中的邮件数。

Exchange Server 分析工具使用此处获取的信息来查询 Exchange_QueuedSMTPMessage WMI 类，以确定该队列中邮件的下列属性值。

Recipients | 表示邮件收件人。
Received | 表示邮件的接收时间戳。
MessageId | 表示队列中邮件的标识符。
StateRetry | 表示正在重新尝试传输未能成功传递的邮件。

最后，Exchange Server 分析工具使用此处获取的数据查询 Active Directory® 目录服务，以确定每个"收件人"对象的下列值。然后，Exchange Server 分析工具会确定该收件人是一位用户、一个通讯组、一个公用文件夹还是一个公用文件夹存储：

distinguishedName | 表示该对象的可分辨名称。
msExchHomeServerName | 表示收件人所驻留的服务器。
homeMDB | 表示收件人的邮箱存储。

如果 Exchange Server 分析工具确定队列中滞留的邮件中，至少有 25％（在 To: 字段或 Cc: 字段中）的收件人驻留在某个特定的服务器上，则 Exchange Server 分析工具会显示警告。

如果 Exchange Server 分析工具确定队列中滞留的邮件中，至少有 50％（在 To: 字段或 Cc: 字段中）的收件人驻留在某个特定的服务器上，则 Exchange Server 分析工具会显示错误。

此警告或错误意味着标识的服务器是 SMTP 队列中滞留的邮件的通用目标。

要解决此问题，请按如下方式调查该服务器，以查出可能导致发其中的邮件排队的配置问题或其他问题：

  • 确保该服务器对象的属性设置正确，且 Active Directory 中的值正确无误。

  • 查看该服务器对象的 Active Directory 权限设置是否正确。

  • 如果该服务器为某个特殊用户对象（即一个指定的日记收件人）的主服务器，请查看与此用户对象相关的服务或组件的配置是否正确。

  • 查找潜在的针对此公用文件夹的商业垃圾邮件 (UCE)、垃圾邮件或病毒攻击。

有关如何排除 SMTP 队列故障的详细信息，请参阅下列 Exchange 资源：

  • "Exchange Server Transport and Routing Guide"（Exchange Server 传输和路由指南）中的"Troubleshooting Mail Flow and SMTP"（排除邮件流和 SMTP 故障）(http://go.microsoft.com/fwlink/?LinkID=67875)。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)。

有关通讯组限制对 Exchange Server 邮件流的影响的详细信息，请参阅下列 Microsoft 知识库文章：

  • 895407"在 Exchange Server 2003 中，配置基于通讯组的传递限制后，向本地邮箱和外部邮箱传递邮件的速度比预期速度要慢"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 329171"XADM：为收件人配置了基于组成员身份的传递限制后，邮件传递的速度将会减慢"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)。

  • 839949"排除 Exchange 2000 Server 和 Exchange Server 2003 中的邮件传输和通讯组问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。

  • 812298"配置基于通讯组列表的传递限制后，邮件传递的速度将会减慢"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。


找不到接收器注册
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-01-11

Microsoft® Exchange Server 分析工具查询 Microsoft Internet 信息服务 (IIS) 元数据库，以枚举简单邮件传输协议 (SMTP) 传输事件接收器绑定列表。Exchange Server 分析工具尝试基于 Exchange Server 分析工具中预填充的列表来查找大量的标准事件绑定。对于每个绑定，Exchange Server 分析工具验证注册表中下列分支下的组件对象模型 (COM) 注册详细信息：

HKEY_CLASSES_ROOT\CLSID\

如果下列条件为真，则 Exchange Server 分析工具将显示警告：

  • 在元数据库中发现传输事件接收器绑定。

  • 注册表中缺少相应的 COM 注册。

当邮件数据传输到 SMTP 服务或从其中传出时将发生 SMTP 传输事件。所有邮件都通过事件进行传送。其中包括 X.400 和 RPC 传入或传出邮件。通常，传入传输事件是指邮件通过网络或 SMTP 拾取目录到达 SMTP 服务。此传输事件发生时，事件的源将通知传输事件接收器，每个事件接收器都可以基于邮件的数据内容采取某种类型的操作。系统将邮件数据传递到接收器后，就不再对邮件数据执行其他操作，直到接收器完成其操作并返回邮件为止。接收器在执行此操作时对邮件数据和状态拥有独占控制权。

传输事件接收器绑定缺少 COM 注册会导致邮件流问题。如果 Exchange Server 显示出邮件流问题的症状（如邮件排队），则应重新注册传输事件接收器。

重新注册传输事件接收器

  1. 在 Microsoft Exchange Server 中，打开命令提示符窗口，然后更改到 \Program Files\Exchsrvr\Bin 文件夹。

  2. 键入下列命令以重新注册传输事件接收器：

    regsvr32 /i exps.dll

    regsvr32 /i miscat.dll

    regsvr32 /i onsubmit.dll

    regsvr32 /i peexch50.dll

    regsvr32 /i phatcat.dll

    regsvr32 /i protolog.dll

    regsvr32 /i reapi.dll

    regsvr32 /i regsinks.dll

    regsvr32 /i tranmsg.dll

    regsvr32 /i turflist.dll

    regsvr32 /i xlsasink.dll

    regsvr32 /i msgfilter.dll

  3. 重新运行 Exchange Server 分析工具以验证不再出现警告。如果事件接收器注册警告仍然出现，并且还存在邮件流问题，请与 Microsoft 产品支持服务部门 (PSS) 联系。

有关传输事件接收器绑定的详细信息，请参阅下列 Exchange 资源：

  • Microsoft 知识库文章 258224，"XCON: Enumerating the Registered Transport Event Sinks"（英文）(http://go.microsoft.com/fwlink/?linkID=3052&kbid=258224）

  • "Technical Reference Guide for Exchange Server 2003"中的"SMTP Service Design"（英文）(http://go.microsoft.com/fwlink/?LinkId=58876)


在 SMTP 虚拟服务器上设置了智能主机
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定特定的 SMTP 虚拟服务器上是否配置了 msExchSmtpSmartHost 属性。如果 Exchange Server 分析工具发现 msExchSmtpSmartHost 属性已配置，则会显示警告。

在 SMTP 虚拟服务器上配置智能主机不是最佳的做法。而应创建 SMTP 连接器，在连接器中配置智能主机。

在 Exchange Server 2003 中，使用 Internet 邮件向导配置 Internet 邮件传递。有关详细信息，请参阅"Exchange Server Transport and Routing Guide"（英文）中的"How to Use Internet Mail Wizard"（英文）(http://go.microsoft.com/fwlink/?LinkId=50099)。

有关如何创建 SMTP 连接器的详细信息，请参阅"Exchange Server Transport and Routing Guide"（英文）中的"How to Create an SMTP Connector"（英文）(http://go.microsoft.com/fwlink/?LinkId=50100)。


手动设置了 SMTP AdditionalPoolThreadsPerProc 注册表值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-01-17

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已手动配置了其他缓冲池线程：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\AdditionalPoolThreadsPerProc

如果 Exchange Server 分析工具发现 AdditionalPoolThreadsPerProc 存在并已配置，则显示非默认配置消息。

在 SMTP 中有五个工作队列使用称为 ATQ 线程的线程所组成的线程池。按照设计，默认情况下，这些队列中有两个最多可以使用可用线程的 90%。该线程池由接受 POP 和 IMAP 请求的进程共享。因此，为了缓和高负载情形，可以出现 SMTP 不让 POP 和 IMAP 服务获得资源的情况。

通过限制 SMTP 可以使用的线程百分比，可以为 POP 和 IMAP 保留足够的线程。若要进行该更改，请增加 IIS 的可用线程总数。在这里，唯一的代价是增加内存的使用量会使线程数增加。

有两个注册表值允许控制每个处理器中 SMTP 可使用的线程的百分比，以及其他线程的百分比：

位置：HKLM\System\CurrentControlSet\Services\SMTPSVC\Parameters

值：AdditionalPoolThreadsPerProc

类型：REG_DWORD

位置：HKLM\System\CurrentControlSet\Services\SMTPSVC\Parameters

值：MaxPercentPoolThreads

类型：REG_DWORD

在群集 Exchange Server 计算机上，如果高 SMTP 活动量导致 POP3、IMAP4 或者二者的资源失败，则应当调整这两个注册表值。可以使用下列公式计算群集的最优值：

注册表值 | 公式
AdditionalPoolThreadsPerProc | ((9 / (MaxPercentPoolThreads/100)) - 4) / 2
MaxPercentPoolThreads | 90 / (2 * 协议虚拟服务器数)

例如，在有两个协议虚拟服务器的 Exchange Server 群集中，MaxPercentPoolThreads 的公式是 90 / (2*2) = 22。计算 MaxPercentPoolThreads 值时，如果计算结果是包括小数点的值，则应当向下四舍五入为下一个整数。计算 AdditionalPoolThreadsPerProc 值时，如果计算结果是大于 200 的值，则还需要将所得到的值赋给其他注册表值：

位置：HKLM\System\CurrentControlSet\Services\InetInfo\Parameters\

值：PoolThreadLimit

类型：REG_DWORD

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

在 Exchange 群集上配置最佳设置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. 创建名为 AdditionalPoolThreadsPerProc 的 DWORD 注册表值，并根据上面的公式将它的数值数据设置为合适的数字。

  4. 创建名为 MaxPercentPoolThreads 的 DWORD 注册表值，并根据上面的公式将它的数值数据设置为合适的数字。

  5. 关闭注册表编辑器，并重新启动 IIS Admin 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关本文所描述的特定群集资源问题的详细信息，请参阅 Microsoft 知识库文章 281868"XADM:POP\IMAP4 Virtual Servers Repeatedly Fail Over Under High Load"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=281868)。


SMTP 存档接收器：存档 P1 头已设置
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 SMTP 存档接收器是否已安装并启用：

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Dump P1

如果 Exchange Server 分析工具发现 Dump P1 的值大于 0，则会显示非默认配置消息。

值为 0 表示 P1 头存档已禁用。值为 1 表示 P1 头存档已启用。不支持 0 或 1 以外的其他值。

SMTP 存档接收器工具是自定义的脚本，允许存档传入和移出 Exchange 服务器上特定文件夹的所有邮件。默认情况下，在启用 SMTP 存档接收器时，所有邮件及其收件人将存档到 .eml 文件中，"密件抄送"收件人除外。

P1 头也称为"信封"数据。信封数据是实际收件人的列表，Exchange 在邮件传输时生成该列表，使邮件可以发送给所有收件人。与 P2 头不同（P2 头是发件人在所接收邮件的特定部分声明的收件人），信封数据在发送给许多目标时会更改。之所以发生这些更改，是因为通讯组列表的扩展和隐藏通讯组列表的行为。

默认情况下，在安装并启用 SMTP 存档接收器时，不会存档 P1 头。通常，只有在进行故障排除时才启用 P1 头存档。

如果不希望在此 Exchange 计算机上存档 P1 头，可以将 Dump P1 注册表项设置为 0，也可以卸载 SMTP 存档接收器。在卸载 SMTP 存档接收器时，SMTP 存档接收器所使用的所有注册表项均将删除。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

禁用 P1 头存档

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. 双击注册表项 Dump P1，在"数值数据"字段中，输入 0，然后单击"确定"。

  4. 关闭注册表编辑器，并重新启动 IIS 管理服务，以使更改生效。

若要卸载 SMTP 存档接收器，请执行下列操作：

  1. 单击"开始"，再单击"运行"，键入 cmd，然后单击"确定"。

  2. 在 C:\Program Files\Exchsrvr\bin 文件夹中，键入 cscript archivesink_setup.vbs，然后按 Enter 键。

  3. 键入 cscript archivesink_setup.vbs uninstall Virtual Server ID，其中 Virtual Server ID 是安装 SMTP 存档接收器的虚拟服务器的虚拟服务器编号。

  4. 退出命令提示符窗口，并重新启动 IIS 管理服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关在 Exchange Server 2003 中设置和配置 SMTP 存档接收器的详细信息，请参阅知识库文章 871110"How to install and use the Archive Sink utility in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110)。

有关在 Exchange 2000 Server 中设置和配置 SMTP 存档接收器的详细信息，请参阅知识库文章 307798"The Archive Sink utility is available in Service Pack 2"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798)。

有关为遵从规章的目的部署综合日记解决方案的信息，请参阅"Journaling with Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47581)。


SMTP 存档接收器已启用
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 SMTP 存档接收器是否已安装并启用：

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable Smtp Messages

如果 Exchange Server 分析工具发现 Enable Smtp Messages 的值大于 0，则会显示非默认配置消息。

值为 0 表示 SMTP 存档接收器已禁用。值为 1 表示 SMTP 存档接收器已启用。不支持 0 或 1 以外的其他值。

SMTP 存档接收器工具是自定义的脚本，允许存档传入和移出 Exchange 服务器上特定文件夹的所有邮件。默认情况下，在启用 SMTP 存档接收器时，所有邮件及其收件人将存档到 .eml 文件中，但"密件抄送"收件人除外。

默认情况下，如果启用了使用 SMTP 存档接收器进行 SMTP 存档，为通过简单邮件传输协议 (SMTP)、Exchange 存储或任何其他接收器传输而提交的所有邮件均触发此事件。在理论上，每封邮件均可触发此事件一次，并且此事件只能存档一次。OnMessageSubmission 事件在路由或分类程序事件之前触发。因此，这些邮件称为 PreCat 邮件。默认情况下，在安装 SMTP 存档接收器工具时，会为此事件存档邮件。为此事件存档的邮件包含前缀文件名 ARCH_random number.xml。

如果不希望在此 Exchange 计算机上存档邮件，可以将 Enable Smtp Messages 注册表项设置为 0，也可以卸载 SMTP 存档接收器。在卸载 SMTP 存档接收器时，SMTP 存档接收器所使用的所有注册表项均将删除。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

禁用 SMTP 存档接收器

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. 双击注册表项 Enable Smtp Messages，在"数值数据"字段中，输入 0，然后单击"确定"。

  4. 退出注册表编辑器，并重新启动 IIS 管理服务，以使更改生效。

卸载 SMTP 存档接收器

  1. 单击"开始"，再单击"运行"，键入 cmd，然后单击"确定"。

  2. 在 C:\Program Files\Exchsrvr\bin 文件夹中，键入 cscript archivesink_setup.vbs，然后按 Enter 键。

  3. 键入 cscript archivesink_setup.vbs uninstall Virtual Server ID，其中 Virtual Server ID 是安装 SMTP 存档接收器的虚拟服务器的虚拟服务器编号。

  4. 退出命令提示符窗口，并重新启动 IIS 管理服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关在 Exchange Server 2003 中设置和配置 SMTP 存档接收器的详细信息，请参阅知识库文章 871110"How to install and use the Archive Sink utility in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110)。

有关在 Exchange 2000 Server 中设置和配置 SMTP 存档接收器的详细信息，请参阅知识库文章 307798"The Archive Sink utility is available in Service Pack 2"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798)。

有关为遵从规章的目的部署综合日记解决方案的详细信息，请参阅"Journaling with Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47581)。


SMTP 存档接收器：分类后已设置
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已安装并启用 SMTP 存档接收器：

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable PostCat

如果 Exchange Server 分析工具发现 Enable PostCat 的值大于 0，则显示非默认配置消息。

值 0 表示禁用分类后邮件存档。值 1 表示启用分类后邮件存档。不支持 0 或 1 以外的其他值。

SMTP 存档接收器工具是自定义的脚本，允许存档传入和移出 Exchange 服务器上特定文件夹的所有邮件。默认情况下，在启用 SMTP 存档接收器时，所有邮件及其收件人将存档到 .eml 文件中，"密件抄送"收件人除外。

如果 Enable PostCat 设置为 1，邮件将在某个邮件分类后存档。邮件可以多次触发此事件，但是只有在邮件分类、排队并重新枚举后才会触发。为此事件存档的邮件包含前缀文件名 ARCH_POSTCAT_random number.xml。

如果不希望在此 Exchange 计算机上存档分类后邮件，可以将 Enable PostCat 注册表项设置为 0。如果根本不希望在此计算机上进行存档，可以卸载 SMTP 存档接收器。在卸载 SMTP 存档接收器时，SMTP 存档接收器所使用的所有注册表项均将删除。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

禁用分类后邮件存档

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. 双击注册表项 Enable PostCat，在"数值数据"字段中，输入 0，然后单击"确定"。

  4. 退出注册表编辑器，并重新启动 IIS 管理服务，以使更改生效。

若要卸载 SMTP 存档接收器，请执行下列操作：

  1. 单击"开始"，再单击"运行"，键入 cmd，然后单击"确定"。

  2. 在 C:\Program Files\Exchsrvr\bin 文件夹中，键入 cscript archivesink_setup.vbs，然后按 Enter 键。

  3. 键入 cscript archivesink_setup.vbs uninstall Virtual Server ID，其中 Virtual Server ID 是安装 SMTP 存档接收器的虚拟服务器的虚拟服务器编号。

  4. 退出命令提示符窗口，并重新启动 IIS 管理服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关在 Exchange Server 2003 上设置和配置 SMTP 存档接收器的详细信息，请参阅知识库文章 871110"How to install and use the Archive Sink utility in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110)。

有关在 Exchange 2000 Server 上设置和配置 SMTP 存档接收器的详细信息，请参阅知识库文章 307798"The Archive Sink utility is available in Service Pack 2"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798)。

有关为遵从规章的目的部署综合日记解决方案的信息，请参阅"Journaling with Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47581)。


SMTP 存档接收器：分类前已设置
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 SMTP 存档接收器是否已安装并启用：

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable PreCat

如果 Exchange Server 分析工具发现 Enable PreCat 的值大于 0，则会显示非默认配置消息。

值 0 表示禁用预分类邮件存档。值 1 表示启用预分类邮件存档。不支持 0 或 1 以外的其他值。

SMTP 存档接收器工具是自定义的脚本，允许存档传入和移出 Exchange 服务器上特定文件夹的所有邮件。默认情况下，在启用 SMTP 存档接收器时，所有邮件及其收件人将存档到 .eml 文件中，"密件抄送"收件人除外。

为通过简单邮件传输协议 (SMTP)、Exchange 存储或任何其他接收器传输提交的所有邮件均触发此事件。在理论上，每封邮件可以触发一次此事件，此事件只能存档一次。OnMessageSubmission 事件在路由或分类程序事件之前触发。因此，这些邮件称为 PreCat 邮件。默认情况下，在安装 SMTP 存档接收器实用程序时，会为此事件存档邮件。为此事件存档的邮件包含前缀文件名 ARCH_random number.xml。

如果不希望在此 Exchange 计算机上存档预分类邮件，可以将 Enable PreCat 注册表项设置为 0。如果根本不希望在此计算机上进行存档，可以卸载 SMTP 存档接收器。在卸载 SMTP 存档接收器时，SMTP 存档接收器所使用的所有注册表项均将删除。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

禁用预分类邮件存档

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. 双击注册表项 Enable PreCat，在"数值数据"字段中，输入 0，然后单击"确定"。

  4. 关闭注册表编辑器，并重新启动 IIS Admin 服务，以使更改生效。

若要卸载 SMTP 存档接收器，请执行下列操作：

  1. 单击"开始"，再单击"运行"，键入 cmd，然后单击"确定"。

  2. 在 C:\Program Files\Exchsrvr\bin 文件夹中，键入 cscript archivesink_setup.vbs，然后按 Enter 键。

  3. 键入 cscript archivesink_setup.vbs uninstall Virtual Server ID，其中 Virtual Server ID 是安装 SMTP 存档接收器的虚拟服务器的虚拟服务器编号。

  4. 关闭命令提示符窗口，并重新启动 IIS Admin 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关在 Exchange Server 2003 中设置和配置 SMTP 存档接收器的详细信息，请参阅知识库文章 871110"How to install and use the Archive Sink utility in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110)。

有关在 Exchange 2000 Server 中设置和配置 SMTP 存档接收器的详细信息，请参阅知识库文章 307798"The Archive Sink utility is available in Service Pack 2"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798)。

有关为遵从规章的目的部署综合日记解决方案的信息，请参阅"Journaling with Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47581)。


SMTP 存档接收器：系统邮件正在存档
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已安装并启用 SMTP 存档接收器：

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Archive System Messages

如果 Exchange Server 分析工具发现 Archive System Messages 的值大于 0，则显示非默认配置消息。

值为 0 表示系统邮件不存档。值为 1 表示系统邮件存档。不支持 0 或 1 以外的其他值。

SMTP 存档接收器工具是自定义的脚本，允许存档传入和移出 Exchange 服务器上特定文件夹的所有邮件。默认情况下，在启用 SMTP 存档接收器时，所有邮件及其收件人将存档到 .eml 文件中，"密件抄送"收件人除外。

如果不希望在此 Exchange 计算机上存档系统邮件，可以将 Archive System Messages 注册表项设置为 0。如果根本不希望在此计算机上进行存档，可以卸载 SMTP 存档接收器。在卸载 SMTP 存档接收器时，SMTP 存档接收器所使用的所有注册表项均将删除。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

禁用系统邮件存档

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. 双击注册表项 Archive System Messages，在"数值数据"字段中，输入 0，然后单击"确定"。

  4. 关闭注册表编辑器，并重新启动 IIS 管理服务，以使更改生效。

若要卸载 SMTP 存档接收器，请执行下列操作：

  1. 单击"开始"，再单击"运行"，键入 cmd，然后单击"确定"。

  2. 在 C:\Program Files\Exchsrvr\bin 文件夹中，键入 cscript archivesink_setup.vbs，然后按 Enter 键。

  3. 键入 cscript archivesink_setup.vbs uninstall Virtual Server ID，其中 Virtual Server ID 是安装 SMTP 存档接收器的虚拟服务器的虚拟服务器编号。

  4. 关闭命令提示符窗口，并重新启动 IIS 管理服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关在 Exchange Server 2003 中设置和配置 SMTP 存档接收器的详细信息，请参阅知识库文章 871110"How to install and use the Archive Sink utility in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110)。

有关在 Exchange 2000 Server 中设置和配置 SMTP 存档接收器的详细信息，请参阅知识库文章 307798"The Archive Sink utility is available in Service Pack 2"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798)。

有关为遵从规章的目的部署综合日记解决方案的信息，请参阅"Journaling with Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?LinkId=47581)。


SMTP 死信数据正被写入压缩文件夹
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP) 死信文件夹的 Compressed 项的值。如果 Exchange Server 分析工具发现 Compressed 的值设置为 True，则显示警告。

当邮件通过 SMTP 服务到达 Exchange 计算机时，数据将以 .eml 文件的形式写入硬盘。默认情况下，这些文件存储在安装 Exchange 的同一个分区上的 <drive>:\Program Files\Exchsrvr\Mailroot 文件夹中。如果用于存储 SMTP 死信数据的文件夹打开了文件压缩功能，那么 Exchange 的性能可能会极大降低。因此，不支持存储 SMTP 死信数据的文件夹打开压缩功能。

如果收到该警告，则必须关闭存储 SMTP 死信数据的文件夹上的压缩，或者必须将 SMTP 死信数据移动到未压缩的文件夹中。

Microsoft 不支持将 Exchange 数据文件存储在压缩卷上。如果将 Exchange 数据文件存储在压缩卷上，则额外的开销会极大地影响 Exchange 的性能。Exchange 数据文件包括下列所有文件：

  • .edb 文件

  • .stm 文件

  • .log 文件

  • .dat 文件

  • .eml 文件

  • .chk 文件

关闭给定文件夹上的文件压缩

  1. 用鼠标右键单击想要关闭文件压缩的文件夹，再单击"属性"。

  2. 在"常规"选项卡上，单击"高级"。

  3. 在"高级属性"对话框中，清除"压缩内容以便节省磁盘空间"复选框，再单击"确定"。

移动 Exchange 2000 Server 或 Exchange Server 2003 上的死信文件夹

  1. 打开 Exchange 系统管理器。

  2. 单击"管理组"，依次展开您的管理组、"服务器"、您的服务器、"协议"、"SMTP"。

  3. 用鼠标右键单击 SMTP 虚拟服务器，再单击"停止"。

  4. 用鼠标右键单击 SMTP 虚拟服务器，再单击"属性"。

  5. 在"邮件"选项卡上的"死信目录"框旁边，单击"浏览"，然后键入队列文件夹的新位置的路径。

  6. 单击"确定"。

  7. 用鼠标右键单击 SMTP 虚拟服务器，再单击"启动"。

有关移动 Mailroot 文件夹的详细信息，请参阅 Microsoft 知识库文章 822933"How to change the Exchange 2003 SMTP Mailroot folder location"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)。


SMTP 死信数据正在写入非 NTFS 分区
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange SMTP BadMail 目录的 FSName 关键字的值。如果 Exchange Server 分析工具确定 FSName 关键字的值不等于 NTFS，则显示警告。

Microsoft 不支持将 Exchange 数据文件存储在非 NTFS 卷上。Exchange 数据文件包括所有下列文件：

  • .edb 文件

  • .stm 文件

  • .log 文件

  • .dat 文件

  • .eml 文件

如果看见该警告，则必须将 SMTP 死信目录移动到 NTFS 文件系统驱动器上的文件夹。或者，如果存储 BadMail 目录的驱动器是 FAT 格式的驱动器，可使用 convert.exe 命令行工具将驱动器转换为 NTFS 格式。

将 SMTP 死信目录移动到另一个文件夹

  1. 启动 Exchange 系统管理器。

  2. 单击"管理组"，依次展开您的管理组、"服务器"、您的服务器、"协议"、"SMTP"。

  3. 用鼠标右键单击 SMTP 虚拟服务器，再单击"停止"。

  4. 用鼠标右键单击 SMTP 虚拟服务器，再单击"属性"。

  5. 在"邮件"选项卡上的"死信目录"框旁边，单击"浏览"，然后键入 BadMail 文件夹的新位置的路径。

  6. 单击"确定"。

  7. 用鼠标右键单击 SMTP 虚拟服务器，再单击"启动"。

有关移动 Mailroot 文件夹的详细信息，请参阅 Microsoft 知识库文章 822933"How to change the Exchange 2003 SMTP Mailroot folder location"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)。

作为上述过程的替代方案，如果存储文件的驱动器格式化为 FAT 驱动器，可以使用 convert.exe 命令行工具将该驱动器转换为 NTFS。有关使用 convert.exe 命令行工具将 FAT 分区转换为 NTFS 分区的信息，请参阅 Microsoft 知识库文章 214579"How to Use Convert.exe to Convert a Partition to the NTFS File System"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579)。


SMTP 死信数据正被写入加密文件夹
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 类，以确定 SMTP 死信文件夹的 Encrypted 关键字的值。如果 Exchange Server 分析工具发现 Encrypted 的值设置为 True，则显示警告。

当邮件通过 SMTP 服务到达 Exchange 计算机时，数据以 .eml 文件的形式写入到硬盘中。默认情况下，这些文件存储在安装 Exchange 的同一个分区上的 <drive>:\Program Files\Exchsrvr\Mailroot 文件夹中。如果存储 SMTP BadMail 数据的文件夹启用了文件加密，那么 Exchange 的性能将大幅度下降。因此，不支持对存储 SMTP 死信数据的文件夹进行加密。

如果收到该警告，则必须关闭存储 SMTP 死信数据的文件夹上的加密，或者必须将 SMTP 死信数据移动到未加密的文件夹中。

Microsoft 不支持在以加密文件系统 (EFS) 方式加密的卷上存储 Exchange 数据文件。如果将 Exchange 数据文件存储在加密卷上，则额外的开销会极大地影响 Exchange 性能。Exchange 数据文件包括所有下列文件：

  • .edb 文件

  • .stm 文件

  • .log 文件

  • .dat 文件

  • .eml 文件

  • .chk 文件

为帮助确保 Exchange 数据文件的安全性，建议禁止对 Exchange 计算机的未经授权访问，并使用 S/MIME 邮件格式加密邮件数据。

若要解决该错误，必须关闭死信文件夹上的文件加密，或将死信文件夹移动到没有启用加密的位置。

关闭给定文件夹上的文件加密

  1. 用鼠标右键单击想要关闭文件加密的文件夹，再单击"属性"。

  2. 在"常规"选项卡上，单击"高级"。

  3. 在"高级属性"对话框中，清除"加密内容以便保护数据"复选框，再单击"确定"。

移动 Exchange 2000 Server 或 Exchange Server 2003 上的死信文件夹

  1. 打开 Exchange 系统管理器。

  2. 单击"管理组"，依次展开您的管理组、"服务器"、您的服务器、"协议"、"SMTP"。

  3. 用鼠标右键单击 SMTP 虚拟服务器，再单击"停止"。

  4. 用鼠标右键单击 SMTP 虚拟服务器，再单击"属性"。

  5. 在"邮件"选项卡上的"死信目录"框旁边，单击"浏览"，然后键入 Queue 文件夹的新位置的路径。

  6. 单击"确定"。

  7. 用鼠标右键单击 SMTP 虚拟服务器，再单击"启动"。

有关移动 Mailroot 文件夹的详细信息，请参阅 Microsoft 知识库文章 822933"How to change the Exchange 2003 SMTP Mailroot folder location"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)。

有关 Exchange Server 数据文件和 EFS 的详细信息，请参阅 Microsoft 知识库文章 834638"Information about the storage of data files on an encrypted volume in Exchange Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638)。

有关在 Exchange Server 2003 中如何保护邮件安全的信息，请参阅"Exchange Server 2003 邮件安全指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=2305405C-FAF1-488A-A856-AD467BB59B26&DisplayLang=zh-cn)。


SMTP CatRetryMinutes 注册表值为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否更改了默认的 SMTP 队列配置：

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

如果 Exchange Server 分析工具发现 CatRetryMinutes 注册表项已设置，则 Exchange Server 分析工具将显示非默认值消息。

建议在修改默认队列值之前，一定要先充分考虑。默认值经过认真选择，在大多数环境下可以获得最佳性能。常见的最佳办法是解决问题的根本原因，而不是修改 Exchange Server 上的排队行为。

Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。

有关 Exchange SMTP 队列的详细信息，请参阅 Microsoft Exchange Team Blog 条目"Explaining the Mysterious SMTP Advanced Queuing Engine"（英文）(http://go.microsoft.com/fwlink/?LinkId=48585)。


SMTP 配置警告
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-03

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchSmtpMaxMessageSize 属性的值是否已从默认值 0 更改为其他值。默认情况下，msExchSmtpMaxMessageSize 属性配置为不限制邮件大小。

如果存在下列条件，则 Exchange Server 分析工具将显示警告：

  • msExchSmtpMaxMessageSize 属性的值不为 0。

  • Exchange 没有运行在 Microsoft Windows® Small Business Server 2003 上。

msExchSmtpMaxMessageSize 属性表示可以发送或接收的每封 SMTP 邮件的最大大小。从安全角度来讲，最佳作法是限制可以向（从）Internet 发送（接收）的 SMTP 邮件的最大大小。但是，对于内部 SMTP 邮件，例如，在同一组织中的 Exchange 服务器之间传输的邮件，则建议将 msExchSmtpMaxMessageSize 属性的值保留为 0。

在内部，Exchange 使用 SMTP 邮件处理公用文件夹复制等任务。如果 msExchSmtpMaxMessageSize 属性配置了太低的限制，则会导致公用文件夹复制问题，并且会导致其他组织内邮件传递失败。

如果此 Exchange 服务器是向（从）Internet 发送（接收）SMTP 邮件的桥头服务器，则也许可以安全地忽略此警告。如果此 Exchange 服务器处理内部 SMTP 邮件，则应将 msExchSmtpMaxMessageSize 属性的值改回默认设置 0。

注意：
如果将邮件大小限制设置得过低，则可能导致 Exchange Server 计算机之间的脱机通讯簿复制无法进行。有关详细信息，请参阅 Microsoft 知识库文章 326154"You cannot download the offline address book in Microsoft Outlook in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=326154)。
查看并配置最大 SMTP 邮件大小

  1. 在 Exchange 系统管理器中，依次展开"服务器"、Exchange 服务器、"协议"和"SMTP"。

  2. 用鼠标右键单击 SMTP 虚拟服务器，例如"默认 SMTP 虚拟服务器"，然后选择"属性"。

  3. 选择"邮件"选项卡。

  4. 若要还原为默认设置 0，请清除"限制邮件大小不超过(KB)"复选框。或者，使该复选框保持选中状态，并配置所需的任意值。

  5. 单击"确定"保存更改，并关闭 SMTP 虚拟服务器的"属性"对话框。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列 Microsoft 知识库文章：

  • 266686"XCON：如何配置 SMTP 虚拟服务器（第 1 部分）"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)。

  • 268163"XCON：如何配置 SMTP 虚拟服务器（第 2 部分）"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163。


已设置通讯组传递限制的 SMTP 连接器
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-09-06

Microsoft® Exchange Server 分析工具将查询在 Active Directory® 目录服务中检测到的每个简单邮件传输协议 (SMTP) 连接器对象 (msExchRoutingSMTPConnector) 的下列属性，以确定是否已设置基于通讯组成员身份的传递限制。

dLMemRejectPerms | 包含通讯组列表 (DL) 的域名 (DN)，这些列表的成员不可以通过此 SMTP 连接器发送数据
dLMemSubmitPerms | 包含通讯组列表 (DL) 的域名 (DN)，这些列表的成员可以通过此 SMTP 连接器发送数据

如果 Exchange Server 分析工具确定存在已设置基于通讯组成员身份的传递限制的 SMTP 连接器，则 Exchange Server 分析工具将显示警告。

此警告指示基于通讯组成员身份的传递限制可能会影响 Exchange 邮件流性能。

使用已设置基于通讯组成员身份的传递限制的 SMTP 连接器发送邮件时，邮件分类程序必须展开通讯组的成员身份，获取成员 DN 的完整列表，然后将此 DN 列表与发送人 DN 列表进行比较。如果两个列表上的 DN 匹配，则会执行访问操作或拒绝操作。如果某个通讯组嵌套在另一个通讯组中，则也会展开嵌套的通讯组。

若要解决此警告，请执行下列操作：

  • 针对连接器限制设计专用的路由组，并将其配置到本地路由组，请参考 Microsoft 知识库文章 329171"XADM:Mail Delivery Is Slow if Recipients Are Configured with Delivery Restrictions Based on Group Membership"（XADM：如果为收件人配置了基于组成员身份的传递限制，则邮件传递速度将会减慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)。

  • 将专用且更可靠的全局编录服务器用作连接器的指定桥头服务器。

  • 配置各个邮箱，而不是配置传递限制的通讯组，请参考 Microsoft 知识库文章 812298"Mail delivery is slow after you configure delivery restrictions that are based on a distribution list"（配置基于通讯组列表的传递限制后，邮件传递的速度将会减慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。

  • 考虑实现 SMTP 发件人筛选。

  • 对于运行 Exchange Server 2003 Service Pack 2 (SP2) 或更高版本的服务器，请考虑实现非分层限制检查。对于运行早于 Exchange 2003 SP2 的 Exchange 版本的服务器，请考虑升级为 Exchange 2003 SP2。

详细信息

有关非分层限制检查的详细信息，请参阅考虑非层次限制检查。

有关 SMTP 发件人筛选的详细信息，请参阅"Exchange Server 2003 管理指南"中的"How to Enable Sender Filtering"（如何启用发件人筛选）(http://go.microsoft.com/fwlink/?LinkId=72967)。

有关通讯组限制对 Exchange 邮件流的影响的详细信息，请参阅下列 Microsoft 知识库文章：

  • 329171"XADM:Mail Delivery Is Slow if Recipients Are Configured with Delivery Restrictions Based on Group Membership"（XADM：为收件人配置了基于组成员身份的传递限制后，邮件传递的速度将会减慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)

  • 895407"In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"（在 Exchange Server 2003 中，配置基于通讯组的传递限制后，向本地邮箱和外部邮箱传递邮件的速度比预期速度要慢）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 839949"Troubleshooting mail transport and distribution groups in Exchange 2000 Server and in Exchange Server 2003"（排除 Exchange 2000 Server 和 Exchange Server 2003 中的邮件传输和通讯组问题）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。


SMTP 域重写已启用
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定该 Exchange 服务器的 SMTP 虚拟服务器对象的 heuristics 属性值。如果 Exchange Server 分析工具发现 heuristics 属性的值不是默认值 131072，则显示错误。

Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。

有关 Exchange Server Address Rewrite 工具的详细信息，请参阅"Exchange Server Address Rewrite"（英文）(http://go.microsoft.com/fwlink/?LinkId=25932)。


SMTP FailedMsgQRetryMinutes 注册表值为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定默认的 SMTP 队列配置是否已发生更改：

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

如果 Exchange Server 分析工具发现 FailedMsgQRetryMinutes 注册表项已设置，Exchange Server 分析工具将显示非默认值消息。

建议在修改默认队列值之前，一定要先充分考虑。默认值经过认真选择，在大多数环境下可以获得最佳性能。常见的最佳办法是解决问题的根本原因，而不是修改 Exchange Server 上的排队行为。

Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。

有关 Exchange SMTP 队列的详细信息，请参阅 Microsoft Exchange Team Blog 条目"Explaining the Mysterious SMTP Advanced Queuing Engine"（英文）(http://go.microsoft.com/fwlink/?LinkId=48585)。


SMTP LocalDeliveryMaxBatch 注册表值为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定 LocalDeliveryMaxBatch 注册表值的默认设置是否已发生更改：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\StoreDriver\Exchange\%SMTPVirtualServerInstance%.

如果 Exchange Server 分析工具发现 LocalDeliveryMaxBatch 注册表值设置已手动创建，更改默认的 Exchange 服务器二进制设置 80，Exchange Server 分析工具将显示非默认值警告消息。

默认情况下，Exchange Server 安装期间不创建 LocalDeliveryMaxBatch 注册表值。LocalDeliveryMaxBatch 注册表值可以在 Exchange Server 安装之后手动创建，以便更改 Exchange 信息存储在内部处理和传递邮件的方式。如果符合下列条件，Exchange 服务器可能会遇到邮件传输和存储性能的问题。

  • LocalDeliveryMaxBatch 注册表值已手动创建。

  • LocalDeliveryMaxBatch 注册表值设置的配置不当。

建议在创建或修改 LocalDeliveryMaxBatch 注册表值之前，一定要认真考虑。Exchange 服务器的二进制默认值经过认真选择，在大多数 Exchange 服务器环境下可以获得最佳性能。常见的最佳办法是解决问题的根本原因，而不是通过手动配置注册表来修改 Exchange Server 的默认行为。为了符合最佳办法，如果 LocalDeliveryMaxBatch 注册表值已存在，可能需要删除此注册表值，以便使 Exchange 服务器恢复默认的二进制设置。

Exchange Server 分析工具仅以提供信息为目的报告此配置。但是，可能需要通过编辑注册表来将该注册表值更改回默认设置。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
解决此警告问题

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到下列注册表项： HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\StoreDriver\Exchange\%SMTPVirtualServerInstance%

  3. 在详细信息窗格中，用鼠标右键单击 LocalDeliveryMaxBatch 注册表值，再单击"修改"，然后将"数值数据"更改为 80。单击"确定"。

    注意：
    若要删除 LocalDeliveryMaxBatch 注册表值，在详细信息窗格中，用鼠标右键单击 LocalDeliveryMaxBatch 注册表值，然后单击"删除"。在对话框中单击"是"来确认注册表值的删除。

  4. 关闭注册表编辑器。

  5. 重新启动 Exchange 服务器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关编辑 Microsoft Windows 注册表项的详细信息，请参阅下列 Microsoft 知识库文章：

  • 322755"HOW TO：在 Windows 2000 中备份、编辑和还原注册表"(http://support.microsoft.com/default.aspx?scid=kb;zh-cn;322755)

  • 322756"如何在 Windows XP 和 Windows Server 2003 中备份、编辑和还原注册表"(http://support.microsoft.com/default.aspx?scid=kb;zh-cn;322756)


SMTP 实例 FQDN 与 DNS 解析的服务器名不匹配
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-10-04

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定默认的简单邮件传输协议 (SMTP) 虚拟服务器对象的 msExchSmtpFullyQualifiedDomainName 属性值。

Exchange Server 分析工具还尝试针对运行 Exchange Server 的服务器的完全限定域名 (FQDN)，对已配置 DNS 服务器执行域名系统 (DNS) 查询。此连接是通过使用执行名称解析请求并分析结果的自定义对象处理器来建立的。

Exchange Server 分析工具比较两个查询的结果。如果默认的简单邮件传输协议 (SMTP) 虚拟服务器对象的 msExchSmtpFullyQualifiedDomainName 属性值与 Exchange 服务器的 DNS FQDN 不匹配，则 Exchange Server 分析工具会显示警告。

该警告表示这些属性值可能进行过手动更改。因此，这些更改过值可能导致服务器上的邮件流错误。

msExchSmtpFullyQualifiedDomainName 属性的值指定 SMTP 虚拟服务器的 FQDN，并且必须可由域名系统 (DNS) 网络协议进行解析。

必须存在此属性值的有效 DNS 主机 (A) 记录，以便尝试解析 SMTP 虚拟服务器的 FQDN 的邮件服务器可检索到正确的 IP 地址并正确地路由邮件。

要解决此警告，请确定是否出于有效目的对这些值进行了更改。如果出于有效目的修改了这些值，请采用下列步骤之一：

  • 更改 msExchSmtpFullyQualifiedDomainName 属性值以与 DNS FQDN 匹配。

  • 配置 Exchange Server DNS FQDN 以匹配 msExchSmtpFullyQualifiedDomainName 属性值。

警告：
在使用 ADSI（Active Directory 服务接口）Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003 才能解决。修改 Active Directory 对象的属性的风险由您自己承担。
更新 msExchSMTPFullyQualifiedDomainName 属性值

  1. 打开 Exchange 系统管理器。

  2. 依次展开"管理组"、"服务器"、Exchange Server、"协议"，再展开 SMTP。

  3. 右键单击默认的 SMTP 虚拟服务器并选择"属性"。

  4. 选择"传递"选项卡，然后单击"高级"。

  5. 在完全限定的域名下，输入 msExchSmtpFullyQualifiedDomainName 属性值。

  6. 单击"确定"以保存更改，然后单击"确定"关闭 SMTP 虚拟服务器的"属性"对话框。
配置 Exchange Server 的 DNS FQDN

  1. 请遵循"How to Configure Settings on the DNS Server"中的指导。

有关 Exchange 中反向 DNS 查找功能的详细信息，请参阅"Add a resource record to a DNS zone"（将资源记录添加到 DNS 区域）(http://go.microsoft.com/fwlink/?LinkId=63002)。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列知识库文章：

  • 266686"XCON：如何配置 SMTP 虚拟服务器（第 1 部分）"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)。

  • 268163"XCON：如何配置 SMTP 虚拟服务器（第 2 部分）"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)。

有关 SMTP 服务设计的详细信息，请参阅"Technical Reference Guide for Exchange Server 2003"（Exchange Server 2003 技术参考指南）中的"SMTP Service Design"（SMTP 服务设计）(http://go.microsoft.com/fwlink/?LinkId=58876)。


未设置出站 SMTP 连接器的 SMTP 实例
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-08-22

Microsoft® Exchange Server 分析工具将查询 Active Directory® 目录服务，以获取 protocolCfgSMTPServer 对象类的 distingushedName 属性值，从而列出用户指定的 Exchange 网关上的所有简单邮件传输协议 (SMTP) 虚拟服务器实例。

然后，Exchange Server 分析工具将查询 Active Directory，以获取找到的每个 msExchRoutingSMTPConnector 对象的 msExchSourceBridgeheadServersDN 和 routingList 属性值，从而确定 SMTP 连接器是否已将检测到的 SMTP 虚拟服务器实例之一设置为与外部 SMTP 地址空间连接的本地桥头服务器。

SMTP 连接器将为邮件指定独立的路由。可以使用 SMTP 连接器建立 Internet 邮件的网关或连接到特定的域或邮件系统。使用连接器可为指定的邮件路由定义特定的选项。

如果 Exchange Server 分析工具确定没有任何 SMTP 连接器将指定的 Exchange 网关服务器中的 SMTP 虚拟服务器实例设置为其本地桥头服务器，则 Exchange Server 分析工具将显示警告。

此警告指示，除用户指定的 Exchange 网关服务器以外的其他服务器可能会意外地路由组织外部的邮件。

可能需要创建一个 SMTP 连接器，以便将指定的 Exchange 网关服务器上的某个 SMTP 虚拟服务器实例指定为其桥头服务器，从而避免出现这种情况：除用户指定的 Exchange 网关服务器以外的其他服务器可能会意外地路由组织外部的邮件。

尽管使用 SMTP 虚拟服务器就可以收发 Internet 邮件，但是，建议的最佳实践是为路由 Internet 邮件配置专用的 SMTP 连接器。建议使用 SMTP 连接器，因为它可以为发向 Internet 的邮件提供独立的路由。此外，SMTP 连接器上的配置选项要多于 SMTP 虚拟服务器。

有关如何使用 SMTP 连接器的详细信息，请参阅 Microsoft 知识库文章 294736"When to create SMTP connectors in Exchange 2000 and later"（何时在 Exchange 2000 和更高版本中创建 SMTP 连接器）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=294736)。

有关 SMTP 连接器的详细信息，请参阅"Exchange Server 传输和路由指南"(http://go.microsoft.com/fwlink/?LinkId=47579)。


SMTP LocalRetryMinutes 注册表值为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否更改了默认的 SMTP 队列配置：

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

如果 Exchange Server 分析工具发现 LocalRetryMinutes 注册表项已设置，则 Exchange Server 分析工具将显示非默认值消息。

建议在修改默认队列值之前，一定要先充分考虑。默认值经过认真选择，在大多数环境下可以获得最佳性能。常见的最佳办法是解决问题的根本原因，而不是修改 Exchange 上的排队行为。

Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。

有关 Exchange SMTP 队列的详细信息，请参阅 Microsoft Exchange Team Blog 条目"Explaining the Mysterious SMTP Advanced Queuing Engine"（英文）(http://go.microsoft.com/fwlink/?LinkId=48585)。


SMTP FileCacheLifeTimeSeconds 注册表值已手动添加但可能不再需要
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已将每个缓存的 Internet 信息服务 (IIS) 文件句柄的默认存在时间从默认值 1,880 秒（30 分钟）修改为其他值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Inetinfo\Parameters\FileCacheLifeTimeSeconds

如果 Exchange Server 分析工具发现 FileCacheLifeTimeSeconds 存在并被配置为其他值，则显示非默认配置消息。

FileCacheLifeTimeSeconds 值指定了缓存的 IIS 文件句柄的生存时间。由于缓存的文件句柄能让服务器免于执行冗余的输入/输出 (I/O) 和 CPU 周期，因此文件句柄被缓存起来，以便提高性能。每当 Exchange Server 计算机上的 SMTP 传输堆栈收到邮件时，该邮件都会流出到文件系统，并在那里等待路由到它的目的地。为了写入文件系统，SMTP 传输堆栈将获得文件句柄，然后将邮件传递给该句柄。每个文件句柄会消耗大约 2 KB 的页面缓冲池内存。默认的 IIS 缓存文件句柄数是每 32 MB 有 800 个句柄。

默认情况下，该注册表值不存在，这是因为 Exchange 2000 Server Service Pack 2 (SP2) 和更高版本以及 Exchange Server 2003 被配置为缓存最佳数目的文件句柄。Exchange Server 2003 动态计算适合于 SMTP 文件句柄的设置，因此这些设置不再需要。因此，在将具有这些设置的任何 Exchange 2000 Server 计算机升级至 Exchange Server 2003 之前，应从注册表中删除这些项。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原为默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

  3. 在右侧窗格中，删除 FileCacheLifeTimeSeconds 值。

  4. 关闭注册表编辑器，并重新启动 IIS Admin 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


SMTP FileCacheMaxHandles 注册表值已手动添加，但可能不再需要
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已将最大 Internet 信息服务 (IIS) 文件缓存句柄数从默认值 800 修改为其他值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Inetinfo\Parameters\FileCacheMaxHandles

如果 Exchange Server 分析工具发现 FileCacheMaxHandles 存在并配置为 800 以外的值，则显示非默认配置消息。

FileCacheMaxHandles 值指定 Exchange 每 32 MB 物理内存最多可以使用的 IIS 文件句柄的数目。缓存文件句柄有助于提高性能，因为缓存了文件句柄后，服务器将不必执行冗余的输入/输出 (I/O) 和 CPU 周期。Exchange Server 计算机上的 SMTP 传输堆栈每次收到邮件时，都会将其转移至文件系统中（邮件将在那里等待路由到目的地）。为了写入到文件系统，SMTP 传输堆栈获取文件句柄，然后将邮件传递到该句柄。每个文件句柄都使用大约 2 KB 的分页池内存。默认的 IIS 缓存文件句柄数是每 32 MB 有 800 个句柄。

在 Exchange 2000 Server Service Pack 2 (SP2) 之前，维持大型 SMTP 邮件队列（例如，平均 1,000 封或更多邮件）的 Exchange 服务器遇到了前所未有的性能约束，因为 SMTP 服务的默认设置为最多 1,000 个文件句柄。由于 Exchange 2000 Server 默认设置是最多 1,000 个文件句柄，因此 SMTP 服务只能同时将 1,000 个邮件写入文件系统。

为了改善这些大型系统的性能，经常同时调整三个注册表项，以增加 SMTP 服务最多可以打开的文件句柄的数目（以便可以处理更多邮件），并减少用于可安装文件系统（另一个 Exchange 组件）的打开文件句柄的数目，以避免当队列非常大时内存不足。这些注册表值默认情况下不存在，因此需要手动添加。下面列出了这些注册表值：

位置：HKLM\System\CurrentControlSet\Services\SMTPSVC\Queuing

值：MsgHandleThreshold

类型：REG_DWORD

位置：HKLM\System\CurrentControlSet\Services\SMTPSVC\Queuing

值：MsgHandleAsyncThreshold

类型：REG_DWORD

位置：HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

值：FileCacheMaxHandles

类型：REG_DWORD

MsgHandleThreshold 和 MsgHandleAsyncThreshold 项通常调整为相同的值（通常为大于 1,000 的值），FileCacheMaxHandles 值通常从 800 减小到 600。

默认情况下，由于 Exchange 2000 Server Service Pack 2 (SP2) 和更高版本动态确定要使用的最佳值，因此该注册表值不存在。如果此 Exchange 服务器运行的是 Exchange 2000 Server Service Pack 1 或更早版本，则建议的最佳实践是升级至最新级别的 Service Pack 和更新汇总软件包。升级到最新代码后，可以立即删除这些注册表项。

Exchange Server 2003 动态计算适合于 SMTP 文件句柄的设置，因此这些设置不再需要。因此，在将具有这些设置的任何 Exchange 2000 Server 计算机升级至 Exchange Server 2003 之前，应从注册表中删除这些项。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

更正此错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

  3. 删除 FileCacheMaxHandles 值。

  4. 关闭注册表编辑器，并重新启动 IIS Admin 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


手动设置了 SMTP GlitchRetrySeconds 注册表值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-01-17

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已手动覆盖了默认的小故障重试的等待时间：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\GlitchRetrySeconds

如果 Exchange Server 分析工具发现 GlitchRetrySeconds 存在并已配置，则显示非默认配置消息。

如果 Exchange 2000 Server 或 Exchange Server 2003 试图将邮件路由到负载很重的外部 SMTP 系统，会收到"服务器忙"错误消息。在这种情况下，Exchange 进入一种称为"小故障重试"的状态。在此状态下，Exchange 等待 60 秒，然后尝试重新发送邮件。Exchange 重复此过程三次，三次均失败后，会继续采取其他措施。如果外部 SMTP 服务器一直忙，建议缩短小故障重试的等待时间，以避免出现大量邮件排队等待传递的情况。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

回复到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. 在右侧窗格中，删除 GlitchRetrySeconds 值。或者，如果已经出现了大量邮件排队等待传递的情况，可以减小 GlitchRetrySeconds 的值。

  4. 关闭注册表编辑器，并重新启动 Simple Mail Transfer Protocol (SMTP) 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


手动设置了 SMTP IgnorePFTimeLimit 注册表值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-01-17

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已手动设置了 SMTP 服务路由引擎绕过新的公用文件夹存储的天数。

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\IgnorePFTimeLimit

如果 Exchange Server 分析工具发现 IgnorePFTimeLimit 存在并已配置，则显示非默认配置消息。

当新公用文件夹存储联机时，您可能注意到队列查看器中的本地传递队列正在增长。如果公用文件夹层次结构非常大，本地队列中的邮件将不断地增长，并且可能需要更长的时间才能传递。在某些情况下，邮件可能不传递。

引入新的服务器后，该服务器的可分辨名称添加到管理组的文件夹层次结构公用文件夹对象（在 Active Directory® 目录服务中）的 msExchOwningPFTreeBL 属性中。当接收发往公用文件夹的邮件的服务器的分类程序读取 msExchOwningPFTreeBL 属性时，将首先选择本地公用文件夹存储（如果存在）。为实现负载平衡，然后再按列出的顺序选择公用文件夹存储。由于新服务器在第一个位置列出，因此邮件将路由到该服务器并添加到新服务器的本地传递队列中。如果公用文件夹存储未收到层次结构的副本，则服务器无法将邮件路由到拥有目标文件夹的副本的存储。

可以通过将 IgnorePFTimeLimit 值添加到新公用文件夹服务器的注册表中来避免此问题。这样可以指定路由引擎避开新公用文件夹存储的天数。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原为默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. 在右侧窗格中，删除 IgnorePFTimeLimit。

  4. 关闭注册表编辑器，并重新启动 IIS Admin 服务，以使更改生效。

有关本文所描述的问题和 IgnorePFTimeLimit 注册表值的详细信息，请参阅 Microsoft 知识库文章 328870"XADM:Public Folder Routing is Enabled Before the Hierarchy is Replicated"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328870)。

编辑注册表之前，要获取有关如何编辑注册表的信息，请阅读 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


SMTP 实例配置了多个端口绑定
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchServerBindings 属性的配置值是否已从默认值 25 更改为其他值或是否设置了多个值。默认情况下，msExchServerBindings 属性配置为 TCP 端口 25。如果 Exchange Server 分析工具发现此属性设置了多个值，则会显示非默认配置消息，同时显示设置了多个值的虚拟 SMTP（简单邮件传输协议）服务器的名称。

msExchServerBindings 属性代表该 SMTP 服务器用来侦听入站连接的 TCP 端口。SMTP 虚拟服务器可以配置为侦听一个或多个 TCP 端口。默认情况下，所有 SMTP 虚拟服务器都配置为侦听默认 SMTP 端口，即 TCP 端口 25。如果 SMTP 侦听端口已从默认值修改为其他值，并且包含多个端口绑定，则可能中断邮件流。

只要内部邮件基础结构的余下部分也相应地修改，更改 SMTP 侦听端口就是可接受的。但通常情况下，备用端口不能用于直接从 Internet 接收邮件的 SMTP 虚拟服务器，因为 Internet 上的 SMTP 服务器通过端口 25 发送邮件。

Exchange Server 分析工具查看 Exchange SMTP 协议虚拟服务器的值。此 SMTP 协议虚拟服务器可能是直接从 Internet 接收邮件的 SMTP 服务器，也可能不是。一些防病毒产品和防垃圾邮件产品设计为通过端口 25 接收来自 Internet 的 SMTP 邮件，而通过另一个端口将邮件重定向到 Exchange SMTP 虚拟服务器。在这种情况下，Exchange SMTP 虚拟服务器侦听多个端口可能是一种可接受的配置。

查看或修改 SMTP 虚拟服务器侦听端口

  1. 打开 Exchange 系统管理器。

  2. 展开"服务器"，展开 Exchange 服务器，展开"协议"，再展开 SMTP。

  3. 用鼠标右键单击 SMTP 虚拟服务器（例如，默认 SMTP 虚拟服务器），再单击"属性"。

  4. 选择"常规"选项卡，再单击"高级"。

  5. 将显示 IP 地址和端口列表。

    • 若要更改现有端口，请选择 IP 地址，再单击"编辑"。将 TCP 端口字段更改为 25。

    • 若要将端口 25 作为附加侦听端口添加，请单击"添加"，并添加新的 IP 地址/端口组合。如果要使用连接筛选、发件人筛选或收件人筛选，请确保选择适当的复选框。

  6. 单击"确定"保存更改，再单击"确定"退出"高级"对话框。

  7. 单击"确定"关闭 SMTP 虚拟服务器的"属性"对话框。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列 Microsoft 知识库文章：

  • 266686"XCON:如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)

  • 268163"XCON:How to Configure a SMTP Virtual Server Part 2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


SMTP 邮件失败警告 - 死信邮件一般性失败
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft Windows® Management Instrumentation (WMI) 类，以确定 BadmailedMessagesGeneralFailure 关键字的值。该关键字的值表示由于与特定计数器无关的原因而发送到死信目录的邮件数。死信目录用来存储未送达的邮件。有关其他某些死信 WMI 计数器的信息，请参阅下列 Exchange Server 分析工具文章：

  • SMTP 邮件失败警告 - 死信邮件跃点计数阈值

  • SMTP 邮件失败警告 - DSN 的死信邮件 NDR

当邮件由于其他原因（包括拾取文件不正确、没有收件人以及通过事件触发）也发送到死信目录时，还存在相应的计数器记录此类邮件的增加。

Exchange Server 分析工具还查询 Win32_PerfRawData_PerfOS_System WMI 关键字，以确定 SystemUpTime 的值。

如果 Exchange Server 分析工具确定 SystemUpTime 关键字的值大于 0，并且 BadmailedMessagesGeneralFailure 的值除以 SystemUpTime 的值所得到的结果大于 1000，则显示警告。

此警告意味着平均每天至少有 1,000 封邮件被标记为无法送达，并存储在死信目录中。死信目录中的邮件必须手动删除。建议在定期维护 Exchange Server 的过程中检查并删除死信目录中的邮件。允许死信目录不受限制地增长可以消耗所有可用的磁盘空间，并转而导致 Exchange 数据库被卸除。

解决此警告问题

  1. 检查死信目录中的邮件，确定邮件来自内部还是外部。死信目录中的邮件是以 ASCII 格式进行存储的，并且可以在记事本或另一个文本编辑器中打开并查看。

    • 如果邮件看起来是内部生成的，则可以检查邮件头以确定其来源。

    • 如果邮件看起来是外部生成的，则可能表明您的 Exchange Server 正被用作邮件中继。

有关如何控制和配置中继选项的信息，请参阅下列 Microsoft 知识库文章：

  • 310380"HOW TO:在 Windows 2000 中防止将 Exchange 2000 用作邮件中继"(http://support.microsoft.com/kb/310380/zh-cn)

  • 313395"HOW TO:HOW TO：在 Exchange 2000 Server 中检查匿名 SMTP 连接的中继限制以及筛选非您要求的电子邮件"(http://support.microsoft.com/kb/313395/zh-cn)

有关由于可用磁盘空间不足而卸除数据库的详细信息，请参阅 Microsoft 知识库文章 321825"Databases Become Dismounted Because of Lack of Disk Space"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=321825)。


SMTP 邮件失败警告 - 死信邮件跃点计数阈值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft Windows® Management Instrumentation (WMI) 类，以确定 BadmailedMessagesHopCountExceeded 关键字的值。此关键字的值代表因超过最大跃点计数而发送到死信目录的邮件的数量。死信目录用来存储未送达的邮件。有关其他某些死信 WMI 计数器的信息，请参阅 Exchange Server 分析工具文章 SMTP 邮件失败警告 - 死信邮件一般性失败 和 SMTP 邮件失败警告 - DSN 的死信邮件 NDR。

当邮件由于其他原因（包括拾取文件不正确、没有收件人以及通过事件触发）也发送到死信目录时，还存在相应的计数器记录此类邮件的增加。

Exchange Server 分析工具还查询 Win32_PerfRawData_PerfOS_System WMI 关键字，以确定 SystemUpTime 的值。

如果 Exchange Server 分析工具确定 SystemUpTime 关键字的值大于 0，并且 BadmailedMessagesHopCountExceeded 的值除以 SystemUpTime 的值所得到的结果大于 100，则会显示警告。

此警告意味着平均每天至少有 100 封邮件因超过最大跃点计数而被标记为无法送达，并存储在死信目录中。最大跃点计数是邮件从发件人到收件人的路途中所经过的 SMTP 服务器的最大数量。邮件每经过一个 SMTP 服务器，就会在邮件头中添加一行文本，以表明该跃点。

最佳邮件跃点数会因网络拓扑和邮件传递需求的不同而有所不同。为了防止邮件被重复地错误路由（一种称为"邮件循环"的情况），管理员可以控制所允许的最大跃点数。通过为 SMTP 虚拟服务器设置最大跃点计数，可达到此目的。在 Exchange 2000 Server 中，默认的跃点计数是 15。在 Exchange Server 2003 中，默认值是 30。建议 Exchange 2000 Server 和 Exchange Server 2003 SMTP 虚拟服务器都使用值 30。

死信目录中的邮件必须手动删除。建议将定期复查和删除死信目录中的邮件作为定期的 Exchange Server 维护工作的一部分。允许死信目录不受限制地增长可以消耗所有可用的磁盘空间，并转而导致 Exchange 数据库被卸除。

解决此警告问题

  1. 检查死信目录中的邮件，确定邮件来自内部还是外部。死信目录中的邮件是以 ASCII 格式进行存储的，并且可以在记事本或另一个文本编辑器中打开并查看。

    • 如果邮件看起来是内部生成的，则可以检查邮件头以确定其来源。

    • 如果邮件看起来是外部生成的，则可能表明您的 Exchange Server 正被用作邮件中继。

  2. 将最大跃点计数值设置为 30。

    1. 打开 Exchange 系统管理器。

    2. 展开"服务器"，展开 Exchange 服务器，展开"协议"，再展开"SMTP"。

    3. 用鼠标右键单击 SMTP 虚拟服务器（例如，默认 SMTP 虚拟服务器），并选择"属性"。

    4. 选择"传递"选项卡，再单击"高级"。

    5. 在"最大跃点计数"字段中输入所需的值，并单击"确定"保存更改。

    6. 单击"确定"关闭 SMTP 虚拟服务器的"属性"对话框。

有关如何控制和配置中继选项的信息，请参阅下列 Microsoft 知识库文章：

  • 310380"HOW TO:在 Windows 2000 中防止将 Exchange 2000 用作邮件中继"(http://support.microsoft.com/kb/310380/zh-cn)

  • 313395"HOW TO:在 Exchange 2000 Server 中检查匿名 SMTP 连接的中继限制以及筛选非您要求的电子邮件"(http://support.microsoft.com/kb/313395/zh-cn)

有关由于可用磁盘空间不足而卸除数据库的详细信息，请参阅 Microsoft 知识库文章 321825"Databases Become Dismounted Because of Lack of Disk Space"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=321825)。


SMTP 邮件失败警告 - DSN 的死信邮件 NDR
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-23

Microsoft® Exchange Server 分析工具查询"Win32_PerfRawData_SMTPSVC_SMTPServer"Microsoft Windows® Management Instrumentation (WMI) 类，以确定"BadmailedMessagesNDRofDSN"关键字的值。该关键字的值表示由于无法送达而发送到死信目录的传递状态通知 (DSN) 邮件的数目。死信目录用来存储未送达的邮件。有关其他某些死信 WMI 计数器的信息，请参阅 Exchange Server 分析工具文章 SMTP 邮件失败警告 - 死信邮件一般性失败和 SMTP 邮件失败警告 - 死信邮件跃点计数阈值。

当邮件由于其他原因（包括拾取文件不正确、没有收件人以及通过事件触发）而发送到死信目录时，也存在相应的计数器记录此类邮件的增加。

Exchange Server 分析工具还查询"Win32_PerfRawData_PerfOS_System"WMI 关键字，以确定"SystemUpTime"的值。

如果 Exchange Server 分析工具确定"SystemUpTime"关键字的值大于"0"，并且"BadmailedMessagesNDRofDSN"的值除以"SystemUpTime"的值所得到的结果大于"1000"，则会显示警告。

此警告意味着平均每天至少有 1,000 个 DSN 由于无法送达而存储在死信目录中。死信目录中的邮件必须手动删除。建议将定期复查和删除死信目录中的邮件作为定期的 Exchange Server 维护工作的一部分。允许死信目录不受限制地增长可以消耗所有可用的磁盘空间，并转而导致 Exchange 数据库被卸除。

解决此警告问题

  • 检查死信目录中的邮件，确定 DSN 发往内部收件人还是外部收件人。死信目录中的邮件是以 ASCII 格式进行存储的，并且可以在记事本或另一个文本编辑器中打开并查看。

    • 如果 DSN 发往内部收件人，则表明邮件流有问题。对这种问题进行故障排除，将取决于随 DSN 返回的特定数字代码。

    • 如果 DSN 发往外部收件人，则可能表明您的 Exchange Server 正被用作邮件中继。对这种问题进行故障排除，也将取决于返回的数字代码。

有关传递 DSN 数字返回代码的详细信息，请参阅 Microsoft 知识库文章 284204 Exchange Server 和 Small Business Server 中的传递状态通知。

有关如何控制和配置中继选项的信息，请参阅以下 Microsoft 知识库文章 313395 HOW TO：在 Exchange 2000 Server 中检查匿名 SMTP 连接的中继限制以及筛选非您要求的电子邮件。

有关由于可用磁盘空间不足而卸除数据库的详细信息，请参阅 Microsoft 知识库文章 321825 Databases Become Dismounted Because of Lack of Disk Space（英文）。


SMTP 邮件失败警告 - 找不到分类程序地址查找数
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-03-20

Microsoft® Exchange Server 分析工具查询 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft Windows® Management Instrumentation (WMI) 类，以确定 CatAddresslookupsnotfound 关键字的值。该关键字的值代表没有找到目录服务对象的邮件分类程序所执行的地址查找的数目。Exchange Server 分析工具还查询 Win32_PerfRawData_PerfOS_System WMI 关键字，以确定 SystemUpTime 的值。

如果 Exchange Server 分析工具确定 SystemUpTime 关键字的值大于 0，并且 CatAddresslookupsnotfound 的值除以 SystemUpTime 的值的结果大于 5000，则显示警告。

邮件分类程序检查到达 SMTP 服务器的邮件，并确定对这些邮件执行哪些处理。邮件可能发往本地信息存储，或通过使用邮件传输代理 (MTA) 发往远程主机，或者邮件可能通过使用 SMTP 发往远程主机。分类程序还处理通讯组列表展开。分类程序是高级队列引擎的一个插件，用于在 TCP 端口 3268 对全局编录服务器执行轻型目录访问协议 (LDAP) 查询。分类程序本质上是事件接收器的集合，用来对经过高级队列引擎的每个邮件执行高级地址解析。它执行地址解析和邮件转发、设置内容转换标志、展开通讯组列表、强制采用全局设置、生成传递状态通知，以及执行备用收件人路由检测、分流、日记以及其他许多功能。

当邮件进入邮件分类程序后，分类程序就通过在 Active Directory® 目录服务中的代理地址属性中搜索地址来解析信封上的发件人。分类程序还会通过在 Active Directory 中的代理地址属性中搜索每个地址，来解析信封上的收件人。例如，如果列表包含一个通讯组列表，它将展开该列表以包含这些成员（如果允许在服务器上展开通讯组列表）。

此警告表明平均每天至少有 5,000 个分类程序地址查找失败。其原因有几个，包括目录服务访问 (DSAccess) 问题、目录复制滞后或失败、对目录的字典攻击、DNS 问题或使用了错误地址。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 检查 Exchange Server 计算机上的事件日志中是否有错误。

  2. 如果没有找到任何可用于解决问题的事件，请考虑将对 MSExchangeTransport 分类程序的诊断日志记录调整到最大。启用诊断日志记录后，重新检查事件日志中是否有错误。如果将诊断日志记录级别配置为最大却未能产生任何事件日志条目，请使用注册表将诊断日志记录级别配置为 7。将级别设置为 7 时，将记录邮件分类程序所生成的事件 ID 9000，其中详细记录了功能、失败原因、失败收件人的名称和收件人的类型。若要将诊断日志记录级别设置为 7，请执行下列操作：

    1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

    2. 导航到：

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. 在右侧窗格中，双击"2 Categorizer"，将数值数据设置为 7，再单击"确定"。

    4. 关闭注册表编辑器。

      注意：
      完成故障排除后，将"2 Categorizer"的数值数据重置回 0。

  3. 验证 Exchange Server 已连接到一个或多个全局编录服务器。对于此操作，Windows 中的网络监视器工具会非常有用。

  4. 检查生成的所有传递状态通知 (DSN) 邮件。DSN（可包含未送达报告 (NDR)）描述了通常以永久性传递错误而告终的永久性失败邮件和暂时性失败邮件。

  5. 使用邮件跟踪功能对停留在分类程序中的邮件进行故障排除。

  6. 使用存档接收器工具对进出 Exchange Server 的邮件进行存档和分析。

  7. 使用系统监视器监视分类程序性能计数器。

有关 Exchange Server 和 Microsoft Windows Small Business Server 生成的 DSN 和 NDR 的列表，请参阅 Microsoft 知识库文章 284204"Exchange 2000 Server 中的传递状态通知"(http://support.microsoft.com/kb/284204/zh-cn)。

有关在 Exchange Server 中使用邮件跟踪中心的信息，请参阅下列 Microsoft 知识库文章：

  • 262162"XADM:Using the Message Tracking Center to Track a Message"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856"XADM:How to Enable Message Tracking in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905"Message Tracking Event IDs in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864"Improved Message Tracking Features in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

有关解决邮件分类程序问题的详细信息，请参阅 Microsoft Support Webcast"Exchange 2000 Server:Message Categorizer and NDR Troubleshooting"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)。

有关存档接收器工具的详细信息，请参阅 Microsoft 知识库文章 307798"The Archive Sink utility is available in Service Pack 2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)。

有关解决与传输有关的问题的常规信息，请参阅下列 Microsoft 知识库文章：

  • 821910"HOW TO：排除 Exchange Server 2003 传输问题"(http://support.microsoft.com/kb/821910/zh-cn)

  • 257265"XCON:General Troubleshooting for Exchange 2000 Transport Issues"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

邮件分类程序性能计数器是专门针对每个 SMTP 虚拟服务器实例发布的。若要查看与邮件分类程序相关的可用性能计数器的列表，请参阅 Microsoft 知识库文章 231734"XCON:Performance Monitor Counters for Message Categorizer"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)。

有关其他某些分类程序 WMI 计数器的信息，请参阅下列 Exchange Server 分析工具文章：

  • SMTP 邮件失败警告 - 分类程序目录服务失败

  • SMTP 邮件失败警告 - 分类程序目录登录失败

  • SMTP 邮件失败警告 - 分类程序不可重试错误

  • SMTP 邮件失败警告 - 分类程序内存不足失败

  • SMTP 邮件失败警告 - 分类程序可重试错误


SMTP 邮件失败警告 - 分类程序目录登录失败
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft Windows® Management Instrumentation (WMI) 类，以确定 CatCategorizationsfailedDSlogonfailure 关键字的值。该关键字的值代表由于目录服务登录失败而未成功的分类数。Exchange Server 分析工具还查询 Win32_PerfRawData_PerfOS_System WMI 关键字，以确定 SystemUpTime 的值。

如果 Exchange Server 分析工具确定 SystemUpTime 关键字的值大于 0，并且 CatCategorizationsfailedDSlogonfailure 值除以 SystemUpTime 值的结果大于 50，则显示警告。

邮件分类程序检查到达 SMTP 服务器的邮件，并确定对这些邮件执行哪些处理。邮件可能发往本地信息存储，或通过使用邮件传输代理 (MTA) 发往远程主机，或者邮件可能通过使用 SMTP 发往远程主机。分类程序还处理通讯组列表展开。分类程序是高级队列引擎的一个插件，用于在 TCP 端口 3268 对全局编录服务器执行轻型目录访问协议 (LDAP) 查询。分类程序本质上是事件接收器的集合，用来对经过高级队列引擎的每个邮件执行高级地址解析。它执行地址解析和邮件转发、设置内容转换标志、展开通讯组列表、强制采用全局设置、生成传递状态通知，以及执行备用收件人路由检测、分流、日记以及其他许多功能。

一旦邮件进入邮件分类程序，分类程序便会立即通过在 Active Directory® 目录服务中的代理地址属性中搜索地址来解析信封上的发件人。分类程序还会通过在 Active Directory 中的代理地址属性中搜索每个地址，来解析信封上的收件人。例如，如果列表包含一个通讯组列表，它将展开该列表以包含这些成员（如果允许在服务器上展开通讯组列表）。

此警告意味着由于登录失败，每天平均有 50 次或更多次由邮件分类程序进行的目录服务连接尝试失败。导致此警告的原因有多种，其中包括目录服务访问 (DSAccess) 问题、目录复制延迟或失败、全局编录服务器超载以及 DNS 问题。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 检查 Exchange Server 计算机上的事件日志中是否有错误。

  2. 如果没有找到任何有助于解决问题的事件，请考虑将 MSExchangeTransport 分类程序的诊断日志记录调整到最大。启用诊断日志记录后，立即重新检查事件日志中是否有错误。如果将诊断日志记录级别配置为最大却未能产生任何事件日志条目，请通过使用注册表将诊断日志记录级别配置为 7。将级别设置为 7 时，将记录邮件分类程序所生成的事件 ID 9000，其中详细记录了功能、失败原因、失败收件人的名称和收件人的类型。若要将诊断日志记录级别设置为 7，请执行下列操作：

    1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

    2. 导航到：

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. 在右侧窗格中，双击"2 Categorizer"，并将数值数据设置为 7，再单击"确定"。

    4. 关闭注册表编辑器。

      注意：
      完成故障排除后，将"2 Categorizer"的数值数据重置回 0。

  3. 验证 Exchange Server 已连接到一个或多个全局编录服务器。对于此操作，Windows 中的网络监视器工具会非常有用。

  4. 检查生成的所有传递状态通知 (DSN) 邮件。DSN（可包含未送达报告 (NDR)）描述了通常以永久性传递错误而告终的永久性失败邮件和暂时性失败邮件。

  5. 使用邮件跟踪功能对停留在分类程序中的邮件进行故障排除。

  6. 使用存档接收器工具对进出 Exchange Server 的邮件进行存档和分析。

  7. 使用系统监视器监视分类程序性能计数器。

有关 Exchange Server 和 Microsoft Windows Small Business Server 生成的 DSN 和 NDR 的列表，请参阅 Microsoft 知识库文章 284204"Exchange 2000 Server 中的传递状态通知"(http://support.microsoft.com/kb/284204/zh-cn)。

有关在 Exchange Server 中使用邮件跟踪中心的信息，请参阅下列知识库文章：

  • 262162"XADM:Using the Message Tracking Center to Track a Message"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856"XADM:How to Enable Message Tracking in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905"Message Tracking Event IDs in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864"Improved Message Tracking Features in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

有关解决邮件分类程序问题的详细信息，请参阅 Microsoft Support Webcast"Exchange 2000 Server:Message Categorizer and NDR Troubleshooting"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)。

有关存档接收器工具的详细信息，请参阅 Microsoft 知识库文章 307798"The Archive Sink utility is available in Service Pack 2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)。

有关解决与传输有关的问题的常规信息，请参阅下列知识库文章：

  • 821910"HOW TO：排除 Exchange Server 2003 传输问题"(http://support.microsoft.com/kb/821910/zh-cn)

  • 257265"XCON:General Troubleshooting for Exchange 2000 Transport Issues"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

邮件分类程序性能计数器是专门针对每个 SMTP 虚拟服务器实例发布的。若要查看与邮件分类程序相关的可用性能计数器的列表，请参阅 Microsoft 知识库文章 231734"XCON:Performance Monitor Counters for Message Categorizer"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)。

有关其他分类程序 WMI 计数器的信息，请参阅下列 Exchange Server 分析工具文章

  • SMTP 邮件失败警告 - 分类程序目录服务失败

  • SMTP 邮件失败警告 - 找不到分类程序地址查找数

  • SMTP 邮件失败警告 - 分类程序不可重试错误

  • SMTP 邮件失败警告 - 分类程序内存不足失败

  • SMTP 邮件失败警告 - 分类程序可重试错误


SMTP 邮件失败警告 - 分类程序目录服务失败
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-03-20

Microsoft® Exchange Server 分析工具查询 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft Windows® Management Instrumentation (WMI) 类，以确定 CatCategorizationsfailedDSconnectionfailure 关键字的值。该关键字的值代表由于目录服务连接服务失败而未成功的分类数。Exchange Server 分析工具还查询 Win32_PerfRawData_PerfOS_System WMI 关键字，以确定 SystemUpTime 的值。

如果 Exchange Server 分析工具确定 SystemUpTime 关键字的值大于 0，并且 CatCategorizationsfailedDSconnectionfailure 的值除以 SystemUpTime 的值的结果大于 50，则显示警告。

邮件分类程序检查到达 SMTP 服务器的邮件，并确定对这些邮件执行哪些处理。邮件可能发往本地信息存储，或通过使用邮件传输代理 (MTA) 发往远程主机，或者邮件可能通过使用 SMTP 发往远程主机。分类程序还处理通讯组列表展开。分类程序是高级队列引擎的一个插件，用于在 TCP 端口 3268 对全局编录服务器执行轻型目录访问协议 (LDAP) 查询。分类程序本质上是事件接收器的集合，用来对经过高级队列引擎的每个邮件执行高级地址解析。它执行地址解析和邮件转发、设置内容转换标志、展开通讯组列表、强制采用全局设置、生成传递状态通知，以及执行备用收件人路由检测、分流、日记以及其他许多功能。

当邮件进入邮件分类程序后，分类程序就通过在 Active Directory® 目录服务中的代理地址属性中搜索地址来解析信封上的发件人。分类程序还会通过在 Active Directory 中的代理地址属性中搜索每个地址，来解析信封上的收件人。例如，如果列表包含一个通讯组列表，它将展开该列表以包含这些成员（如果允许在服务器上展开通讯组列表）。

此警告意味着平均每天至少有 50 次由邮件分类程序进行的目录服务连接尝试失败。导致此警告的原因有多个，其中包括目录服务访问 (DSAccess)、目录复制延迟或失败、全局编录服务器超载以及 DNS 问题。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 检查 Exchange Server 计算机上的事件日志中是否有错误。

  2. 如果没有找到任何可用于解决问题的事件，请考虑将对 MSExchangeTransport 分类程序的诊断日志记录调整到最大。启用诊断日志记录后，立即重新检查事件日志中是否有错误。如果将诊断日志记录级别配置为最大却未能产生任何事件日志条目，请使用注册表将诊断日志记录级别配置为 7。将级别设置为 7 时，将记录邮件分类程序所生成的事件 ID 9000，其中详细记录了功能、失败原因、失败收件人的名称和收件人的类型。若要将诊断日志记录级别设置为 7，请执行下列操作：

    1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

    2. 导航到：

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. 在右侧窗格中，双击"2 Categorizer"，将数值数据设置为 7，再单击"确定"。

    4. 关闭注册表编辑器。

      注意：
      完成故障排除后，将"2 Categorizer"的数值数据重置回 0。

  3. 验证 Exchange Server 已连接到一个或多个全局编录服务器。对于此操作，Windows 中的网络监视器工具会非常有用。

  4. 检查生成的所有传递状态通知 (DSN) 邮件。DSN（可包含未送达报告 (NDR)）描述了通常以永久性传递错误而告终的永久性失败邮件和暂时性失败邮件。

  5. 使用邮件跟踪功能对停留在分类程序中的邮件进行故障排除。

  6. 使用存档接收器工具对进出 Exchange Server 的邮件进行存档和分析。

  7. 使用系统监视器监视分类程序性能计数器。

有关 Exchange Server 和 Microsoft Windows Small Business Server 生成的 DSN 和 NDR 的列表，请参阅 Microsoft 知识库文章 284204"Exchange 2000 Server 中的传递状态通知"(http://support.microsoft.com/kb/284204/zh-cn)。

有关在 Exchange Server 中使用邮件跟踪中心的信息，请参阅下列 Microsoft 知识库文章：

  • 262162"XADM:Using the Message Tracking Center to Track a Message"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856"XADM:How to Enable Message Tracking in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905"Message Tracking Event IDs in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864"Improved Message Tracking Features in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

有关解决邮件分类程序问题的详细信息，请参阅 Microsoft Support Webcast"Exchange 2000 Server:Message Categorizer and NDR Troubleshooting"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)。

有关存档接收器工具的详细信息，请参阅 Microsoft 知识库文章 307798"The Archive Sink utility is available in Service Pack 2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)。

有关解决与传输有关的问题的常规信息，请参阅下列 Microsoft 知识库文章：

  • 821910"HOW TO：排除 Exchange Server 2003 传输问题"(http://support.microsoft.com/kb/821910/zh-cn)

  • 257265"XCON:General Troubleshooting for Exchange 2000 Transport Issues"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

邮件分类程序性能计数器是专门针对每个 SMTP 虚拟服务器实例发布的。若要查看与邮件分类程序相关的可用性能计数器的列表，请参阅 Microsoft 知识库文章 231734"XCON:Performance Monitor Counters for Message Categorizer"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)。

有关其他某些分类程序 WMI 计数器的信息，请参阅下列 Exchange Server 分析工具文章：

  • SMTP 邮件失败警告 - 找不到分类程序地址查找数

  • SMTP 邮件失败警告 - 分类程序目录登录失败

  • SMTP 邮件失败警告 - 分类程序不可重试错误

  • SMTP 邮件失败警告 - 分类程序内存不足失败

  • SMTP 邮件失败警告 - 分类程序可重试错误


SMTP 邮件失败警告 - 分类程序不可重试错误
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft Windows® Management Instrumentation (WMI) 类，以确定 CatCategorizationsfailednonretryableerror 关键字的值。该关键字的值代表由于硬错误（不可重试）而未成功的分类数。Exchange Server 分析工具还查询 Win32_PerfRawData_PerfOS_System WMI 关键字，以确定 SystemUpTime 的值。

如果 Exchange Server 分析工具确定 SystemUpTime 关键字的值大于 0，并且 CatCategorizationsfailednonretryableerror 的值除以 SystemUpTime 的值的结果大于 50，则显示警告。

邮件分类程序检查到达 SMTP 服务器的邮件，并确定对这些邮件执行哪些处理。邮件可能发往本地信息存储，或通过使用邮件传输代理 (MTA) 发往远程主机，或者邮件可能通过使用 SMTP 发往远程主机。分类程序还处理通讯组列表展开。分类程序是高级队列引擎的一个插件，用于在 TCP 端口 3268 对全局编录服务器执行轻型目录访问协议 (LDAP) 查询。分类程序本质上是事件接收器的集合，用来对经过高级队列引擎的每个邮件执行高级地址解析。它执行地址解析和邮件转发、设置内容转换标志、展开通讯组列表、强制采用全局设置、生成传递状态通知，以及执行备用收件人路由检测、分流、日记以及其他许多功能。

一旦邮件进入邮件分类程序，分类程序便会立即通过在 Active Directory® 目录服务中的代理地址属性中搜索地址来解析信封上的发件人。分类程序还会通过在 Active Directory 中的代理地址属性中搜索每个地址，来解析信封上的收件人。例如，如果列表包含一个通讯组列表，它将展开该列表以包含这些成员（如果允许在服务器上展开通讯组列表）。

此警告表明平均每天至少有 50 个硬错误发生。导致此警告的原因有多个，其中包括目录服务访问 (DSAccess)、目录复制延迟或失败、全局编录服务器超载以及 DNS 问题。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 检查 Exchange Server 计算机上的事件日志中是否有错误。

  2. 如果没有找到任何有助于解决问题的事件，请考虑将 MSExchangeTransport 分类程序的诊断日志记录调整到最大。启用诊断日志记录后，重新检查事件日志中是否有错误。如果将诊断日志记录级别配置为最大却未能产生任何事件日志条目，请通过使用注册表将诊断日志记录级别配置为 7。将级别设置为 7 时，将记录邮件分类程序所生成的事件 ID 9000，其中详细记录了功能、失败原因、失败收件人的名称和收件人的类型。若要将诊断日志记录级别设置为 7，请执行下列操作：

    1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

    2. 导航到：

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. 在右侧窗格中，双击"2 Categorizer"，将数值数据设置为 7，再单击"确定"。

    4. 关闭注册表编辑器。

      注意：
      完成故障排除后，将"2 Categorizer"的数值数据重置回 0。

  3. 验证 Exchange Server 已连接到一个或多个全局编录服务器。对于此操作，Windows 中的网络监视器工具会非常有用。

  4. 检查生成的所有传递状态通知 (DSN) 邮件。DSN（可包含未送达报告 (NDR)）描述了通常以永久性传递错误而告终的永久性失败邮件和暂时性失败邮件。

  5. 使用邮件跟踪功能对停留在分类程序中的邮件进行故障排除。

  6. 使用存档接收器工具对进出 Exchange Server 的邮件进行存档和分析。

  7. 使用系统监视器监视分类程序性能计数器。

有关 Exchange Server 和 Microsoft Windows Small Business Server 生成的 DSN 和 NDR 的列表，请参阅 Microsoft 知识库文章 284204"Exchange 2000 Server 中的传递状态通知"(http://support.microsoft.com/kb/284204/zh-cn)。

有关在 Exchange Server 中使用邮件跟踪中心的信息，请参阅下列 Microsoft 知识库文章：

  • 262162"XADM:Using the Message Tracking Center to Track a Message"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856"XADM:How to Enable Message Tracking in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905"Message Tracking Event IDs in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864"Improved Message Tracking Features in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

有关解决邮件分类程序问题的详细信息，请参阅 Microsoft Support Webcast"Exchange 2000 Server:Message Categorizer and NDR Troubleshooting"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)。

有关存档接收器工具的详细信息，请参阅 Microsoft 知识库文章 307798"The Archive Sink utility is available in Service Pack 2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)。

有关解决与传输有关的问题的常规信息，请参阅下列 Microsoft 知识库文章：

  • 821910"HOW TO：排除 Exchange Server 2003 传输问题"(http://support.microsoft.com/kb/821910/zh-cn)

  • 257265"XCON:General Troubleshooting for Exchange 2000 Transport Issues"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

邮件分类程序性能计数器是专门针对每个 SMTP 虚拟服务器实例发布的。若要查看与邮件分类程序相关的可用性能计数器的列表，请参阅 Microsoft 知识库文章 231734"XCON:Performance Monitor Counters for Message Categorizer"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)。

有关其他某些分类程序 WMI 计数器的信息，请参阅下列 Exchange Server 分析工具文章：

  • SMTP 邮件失败警告 - 找不到分类程序地址查找数

  • SMTP 邮件失败警告 - 分类程序目录登录失败

  • SMTP 邮件失败警告 - 分类程序目录服务失败

  • SMTP 邮件失败警告 - 分类程序内存不足失败

  • SMTP 邮件失败警告 - 分类程序可重试错误


SMTP 邮件失败警告 - 分类程序内存不足失败
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-03-28

Microsoft® Exchange Server 分析工具查询 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft Windows® Management Instrumentation (WMI) 类，以确定 CatCategorizationsfailedOutOfMemory 关键字的值。此关键字的值代表由于缺乏可用内存而失败的分类的数目。Exchange Server 分析工具还查询 Win32_PerfRawData_PerfOS_System WMI 关键字，以确定 SystemUpTime 的值。

如果 Exchange Server 分析工具确定 SystemUpTime 关键字的值大于 0，并且 CatCategorizationsfailedOutOfMemory 的值除以 SystemUpTime 的值的结果大于 50，则会显示警告。

邮件分类程序检查到达 SMTP 服务器的邮件，并确定对这些邮件执行哪些处理。邮件可能发往本地信息存储，或通过使用邮件传输代理 (MTA) 发往远程主机，或者邮件可能通过使用 SMTP 发往远程主机。分类程序还处理通讯组列表展开。分类程序是高级队列引擎的一个插件，用于在 TCP 端口 3268 对全局编录服务器执行轻型目录访问协议 (LDAP) 查询。分类程序本质上是事件接收器的集合，用来对经过高级队列引擎的每个邮件执行高级地址解析。它执行地址解析和邮件转发、设置内容转换标志、展开通讯组列表、强制采用全局设置、生成传递状态通知，以及执行备用收件人路由检测、分流、日记以及其他许多功能。

一旦邮件进入邮件分类程序，分类程序便会立即通过在 Active Directory® 目录服务中的代理地址属性中搜索地址来解析信封上的发件人。分类程序还会通过在 Active Directory 中的代理地址属性中搜索每个地址，来解析信封上的收件人。例如，如果列表包含一个通讯组列表，它将展开该列表以包含这些成员（如果允许在服务器上展开通讯组列表）。

此警告意味着由于缺乏可用内存，每天平均有 50 次或更多次分类失败。导致此警告的原因有多个，其中包括目录服务访问 (DSAccess) 问题、目录复制延迟或失败、全局编录服务器超载以及 DNS 问题。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 检查 Exchange Server 计算机上的事件日志中是否有错误。

  2. 如果没有找到任何有助于解决问题的事件，请考虑将 MSExchangeTransport 分类程序的诊断日志记录调整到最大。启用诊断日志记录后，重新检查事件日志中是否有错误。如果将诊断日志记录级别配置为最大却未能产生任何事件日志条目，请通过使用注册表将诊断日志记录级别配置为 7。将级别设置为 7 时，将记录邮件分类程序所生成的事件 ID 9000，其中详细记录了功能、失败原因、失败收件人的名称和收件人的类型。若要将诊断日志记录级别设置为 7，请执行下列操作：

    1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

    2. 导航到：

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. 在右侧窗格中，双击"2 Categorizer"，将数值数据设置为 7，再单击"确定"。

    4. 关闭注册表编辑器。

      注意：
      完成故障排除后，将"2 Categorizer"的数值数据重置回 0。

  3. 验证 Exchange Server 已连接到一个或多个全局编录服务器。对于此操作，Windows 中的网络监视器工具会非常有用。

  4. 检查生成的所有传递状态通知 (DSN) 邮件。DSN（可包含未送达报告 (NDR)）描述了通常以永久性传递错误而告终的永久性失败邮件和暂时性失败邮件。

  5. 使用邮件跟踪功能对停留在分类程序中的邮件进行故障排除。

  6. 使用存档接收器工具对进出 Exchange Server 的邮件进行存档和分析。

  7. 使用系统监视器监视分类程序性能计数器。

有关 Exchange Server 和 Microsoft Windows Small Business Server 生成的 DSN 和 NDR 的列表，请参阅 Microsoft 知识库文章 284204"Exchange 2000 Server 中的传递状态通知"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204)。

有关在 Exchange Server 中使用邮件跟踪中心的信息，请参阅下列 Microsoft 知识库文章：

  • 262162"XADM:Using the Message Tracking Center to Track a Message"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856"XADM:如何在 Exchange 2000 Server 和 Exchange Server 2003 中启用邮件跟踪"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905"Message Tracking Event IDs in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864"Improved Message Tracking Features in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

有关解决邮件分类程序问题的详细信息，请参阅 Microsoft Support Webcast"Exchange 2000 Server:Message Categorizer and NDR Troubleshooting"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)。

有关存档接收器工具的详细信息，请参阅 Microsoft 知识库文章 307798"The Archive Sink utility is available in Service Pack 2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)。

有关解决与传输有关的问题的常规信息，请参阅下列 Microsoft 知识库文章：

  • 821910"HOW TO：排除 Exchange Server 2003 传输问题"(http://support.microsoft.com/kb/821910/zh-cn)。

  • 257265"解决常规的 Exchange 2000 Server 和 Exchange Server 2003 传输问题"(http://go.microsoft.com/fwlink/?linkid=305 2 &kbid=257265)。

邮件分类程序性能计数器是专门针对每个 SMTP 虚拟服务器实例发布的。若要查看与邮件分类程序相关的可用性能计数器的列表，请参阅 Microsoft 知识库文章 231734"XCON:Performance Monitor Counters for Message Categorizer"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)。

有关其他某些分类程序 WMI 计数器的信息，请参阅下列 Exchange Server 分析工具文章：

  • SMTP 邮件失败警告 - 找不到分类程序地址查找数

  • SMTP 邮件失败警告 - 分类程序目录登录失败

  • SMTP 邮件失败警告 - 分类程序目录服务失败

  • SMTP 邮件失败警告 - 分类程序不可重试错误

  • SMTP 邮件失败警告 - 分类程序可重试错误


SMTP 邮件失败警告 - 分类程序可重试错误
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-03-20

Microsoft® Exchange Server 分析工具查询 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft Windows® Management Instrumentation (WMI) 类，以确定 CatCategorizationsfailedretryableerror 关键字的值。该关键字的值代表由于可重试错误而失败的分类数。Exchange Server 分析工具还查询 Win32_PerfRawData_PerfOS_System WMI 关键字，以确定 SystemUpTime 的值。

如果 Exchange Server 分析工具确定 SystemUpTime 关键字的值大于 0，并且 CatCategorizationsfailedretryableerror 的值除以 SystemUpTime 的值所得到的结果大于 500，则会显示警告。

邮件分类程序检查到达 SMTP 服务器的邮件，并确定对这些邮件执行哪些处理。邮件可能发往本地信息存储，或通过使用邮件传输代理 (MTA) 发往远程主机，或者邮件可能通过使用 SMTP 发往远程主机。分类程序还处理通讯组列表展开。分类程序是高级队列引擎的一个插件，用于在 TCP 端口 3268 对全局编录服务器执行轻型目录访问协议 (LDAP) 查询。分类程序本质上是事件接收器的集合，用来对经过高级队列引擎的每个邮件执行高级地址解析。它执行地址解析和邮件转发、设置内容转换标志、展开通讯组列表、强制采用全局设置、生成传递状态通知，以及执行备用收件人路由检测、分流、日记以及其他许多功能。

一旦邮件进入邮件分类程序，分类程序便会立即通过在 Active Directory® 目录服务中的代理地址属性中搜索地址来解析信封上的发件人。分类程序还会通过在 Active Directory 中的代理地址属性中搜索每个地址，来解析信封上的收件人。例如，如果列表包含一个通讯组列表，它将展开该列表以包含这些成员（如果允许在服务器上展开通讯组列表）。

此警告意味着平均每天至少有 500 个分类失败，并出现可重试错误。导致此警告的原因有多种，其中包括目录服务访问 (DSAccess)、目录复制延迟或失败、全局编录服务器超载以及 DNS 问题。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

解决此警告问题

  1. 检查 Exchange Server 计算机上的事件日志中是否有错误。

  2. 如果没有找到任何有助于解决问题的事件，请考虑将 MSExchangeTransport 分类程序的诊断日志记录调整到最大。启用诊断日志记录后，重新检查事件日志中是否有错误。如果将诊断日志记录级别配置为最大却未能产生任何事件日志条目，请通过使用注册表将诊断日志记录级别配置为 7。将级别设置为 7 时，将记录邮件分类程序所生成的事件 ID 9000，其中详细记录了功能、失败原因、失败收件人的名称和收件人的类型。若要将诊断日志记录级别设置为 7，请执行下列操作：

    1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

    2. 导航到：

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. 在右侧窗格中，双击"2 Categorizer"，将数值数据设置为 7，再单击"确定"。

    4. 关闭注册表编辑器。

      注意：
      完成故障排除后，将"2 Categorizer"的数值数据重置回 0。

  3. 验证 Exchange Server 已连接到一个或多个全局编录服务器。对于此操作，Windows 中的网络监视器工具会非常有用。

  4. 检查生成的所有传递状态通知 (DSN) 邮件。DSN（可包含未送达报告 (NDR)）描述了通常以永久性传递错误而告终的永久性失败邮件和暂时性失败邮件。

  5. 使用邮件跟踪功能对停留在分类程序中的邮件进行故障排除。

  6. 使用存档接收器工具对进出 Exchange Server 的邮件进行存档和分析。

  7. 使用系统监视器监视分类程序性能计数器。

有关 Exchange Server 和 Microsoft Windows Small Business Server 生成的 DSN 和 NDR 的列表，请参阅 Microsoft 知识库文章 284204"Exchange 2000 Server 中的传递状态通知"(http://support.microsoft.com/kb/284204/zh-cn)。

有关在 Exchange Server 中使用邮件跟踪中心的信息，请参阅下列 Microsoft 知识库文章：

  • 262162"XADM:Using the Message Tracking Center to Track a Message"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856"XADM:How to Enable Message Tracking in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905"Message Tracking Event IDs in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864"Improved Message Tracking Features in Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

有关解决邮件分类程序问题的详细信息，请参阅 Microsoft Support Webcast"Exchange 2000 Server:Message Categorizer and NDR Troubleshooting"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)。

有关存档接收器工具的详细信息，请参阅 Microsoft 知识库文章 307798"The Archive Sink utility is available in Service Pack 2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)。

有关解决与传输有关的问题的常规信息，请参阅下列 Microsoft 知识库文章：

  • 821910"HOW TO：排除 Exchange Server 2003 传输问题"(http://support.microsoft.com/kb/821910/zh-cn)

  • 257265"XCON:General Troubleshooting for Exchange 2000 Transport Issues"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

邮件分类程序性能计数器是专门针对每个 SMTP 虚拟服务器实例发布的。若要查看与邮件分类程序相关的可用性能计数器的列表，请参阅 Microsoft 知识库文章 231734"XCON:Performance Monitor Counters for Message Categorizer"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)。

有关其他分类程序 WMI 计数器的信息，请参阅下列 Exchange Server 分析工具文章：

  • SMTP 邮件失败警告 - 找不到分类程序地址查找数

  • SMTP 邮件失败警告 - 分类程序目录登录失败

  • SMTP 邮件失败警告 - 分类程序目录服务失败

  • SMTP 邮件失败警告 - 分类程序不可重试错误

  • SMTP 邮件失败警告 - 分类程序内存不足失败


SMTP 邮件队列数据正被写入压缩文件夹
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 类，以确定 SMTP 邮件队列文件夹的 Compressed 关键字的值。如果 Exchange Server 分析工具发现 Compressed 的值设置为 True，则显示警告。

当邮件通过 SMTP 服务到达 Exchange 计算机时，数据将以 .eml 文件的形式写入硬盘。默认情况下，这些文件存储在安装 Exchange 的同一个分区上的 <drive>:\Program Files\Exchsrvr\Mailroot 文件夹中。如果存储 SMTP 邮件队列的文件夹启用了文件压缩，则会严重降低 Exchange 性能。因此，不支持存储 SMTP 邮件队列的文件夹打开压缩功能。

Microsoft 不支持将 Exchange 数据文件存储在压缩卷上。如果将 Exchange 数据文件存储在压缩卷上，则额外的开销会极大地影响 Exchange 的性能。Exchange 数据文件包括下列所有文件：

  • .edb 文件

  • .stm 文件

  • .log 文件

  • .dat 文件

  • .eml 文件

  • .chk 文件

关闭给定文件夹上的文件压缩

  1. 用鼠标右键单击想要关闭文件压缩的文件夹，再单击"属性"。

  2. 在"常规"选项卡上，单击"高级"。

  3. 在"高级属性"对话框中，清除"压缩内容以便节省磁盘空间"复选框，再单击"确定"。

移动 Exchange 2000 Server 或 Exchange Server 2003 上的 Mailroot 文件夹

  1. 打开 Exchange 系统管理器。

  2. 单击"管理组"，依次展开您的管理组、"服务器"、您的服务器、"协议"、"SMTP"。

  3. 用鼠标右键单击 SMTP 虚拟服务器，再单击"停止"。

  4. 用鼠标右键单击 SMTP 虚拟服务器，再单击"属性"。

  5. 在"邮件"选项卡上的"队列目录"框旁边，单击"浏览"，然后键入队列文件夹的新位置的路径。

  6. 单击"确定"。

  7. 用鼠标右键单击 SMTP 虚拟服务器，再单击"启动"。

有关移动 Mailroot 文件夹的详细信息，请参阅 Microsoft 知识库文章 822933"How to change the Exchange 2003 SMTP Mailroot folder location"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)。


SMTP 邮件队列数据正被写入加密文件夹
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP) 邮件队列文件夹的 Encrypted 关键字的值。如果 Exchange Server 分析工具发现 Encrypted 的值设置为 True，则将显示警告。

当邮件通过 SMTP 服务到达 Exchange 计算机时，数据将以 .eml 文件的形式写入硬盘。默认情况下，这些文件存储在安装 Exchange 的同一分区的 <drive>:\Program Files\Exchsrvr\Mailroot 文件夹中。如果存储 SMTP 邮件队列的文件夹启用了文件加密，则会严重降低 Exchange 性能。因此，不支持对存储 SMTP 邮件队列的文件夹进行加密。

Microsoft 不支持在以加密文件系统 (EFS) 方式加密的卷上存储 Exchange 数据文件。如果在加密卷上存储 Exchange 数据文件，则额外的开销会极大地影响 Exchange 性能。Exchange 数据文件包括所有下列文件：

  • .edb 文件

  • .stm 文件

  • .log 文件

  • .dat 文件

  • .eml 文件

  • .chk 文件

为了确保 Exchange 数据文件的安全，建议您禁止对 Exchange 计算机的未经授权的访问，并使用 S/MIME 邮件格式加密邮件数据。

若要更正此错误，必须对 SMTP 邮件队列文件夹禁用文件加密，或将 SMTP 邮件队列文件夹移到未启用加密的位置。

禁用给定文件夹的文件加密

  1. 用鼠标右键单击要禁用文件加密的文件夹，并单击"属性"。

  2. 在"常规"选项卡上，单击"高级"。

  3. 在"高级属性"对话框中，清除"加密内容以便保护数据"复选框，再单击"确定"。

在 Exchange 2000 Server 或 Exchange Server 2003 上移动 SMTP 邮件队列文件夹

  1. 打开 Exchange 系统管理器。

  2. 单击"管理组"，展开您的管理组，展开"服务器"，以展开您的服务器，展开"协议"，再展开"SMTP"。

  3. 用鼠标右键单击 SMTP 虚拟服务器，再单击"停止"。

  4. 用鼠标右键单击 SMTP 虚拟服务器，再单击"属性"。

  5. 在"邮件"选项卡上，单击"死信目录"框旁边的"浏览"，再键入队列文件夹新位置的路径。

  6. 单击"确定"。

  7. 用鼠标右键单击 SMTP 虚拟服务器，再单击"启动"。

有关移动 Mailroot 文件夹的详细信息，请参阅 Microsoft 知识库文章 822933"How to change the Exchange 2003 SMTP Mailroot folder location"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)。

有关 Exchange Server 数据文件和 EFS 的详细信息，请参阅 Microsoft 知识库文章 834638"Information about the storage of data files on an encrypted volume in Exchange Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638)。

有关在 Microsoft Exchange Server 2003 中如何保护邮件安全的信息，请参阅"Exchange Server 2003 邮件安全指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=2305405C-FAF1-488A-A856-AD467BB59B26&DisplayLang=zh-cn)。


SMTP 邮件队列数据写入到非 NTFS 分区
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange SMTP Queue 目录的 FSName 关键字的值。如果 Exchange Server 分析工具确定 FSName 项的值不等于 NTFS File System，将显示错误。

Microsoft 不支持将 Exchange 数据文件存储在非 NTFS 卷上。Exchange 数据文件包括下列所有文件：

  • .edb 文件

  • .stm 文件

  • .log 文件

  • .dat 文件

  • .eml 文件

如果遇到此错误，必须将 SMTP 队列目录移至 NTFS 驱动器上的文件夹中。或者，如果存储队列目录的驱动器是 FAT 格式的驱动器，可使用 convert.exe 命令行工具将驱动器转换为 NTFS 格式。

将 SMTP 队列移至另一个文件夹

  1. 打开 Exchange 系统管理器。

  2. 单击"管理组"，依次展开您的管理组、"服务器"、您的服务器、"协议"、"SMTP"。

  3. 用鼠标右键单击 SMTP 虚拟服务器，再单击"停止"。

  4. 用鼠标右键单击 SMTP 虚拟服务器，再单击"属性"。

  5. 在"邮件"选项卡上的"死信目录"框旁边，单击"浏览"，然后键入 Queue 文件夹的新位置的路径。

  6. 单击"确定"。

  7. 用鼠标右键单击 SMTP 虚拟服务器，再单击"启动"。

有关移动 Mailroot 文件夹的详细信息，请参阅 Microsoft 知识库文章 822933"How to change the Exchange 2003 SMTP Mailroot folder location"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)。

如果存储文件的驱动器格式化为 FAT 驱动器，可以不执行本文前面介绍的步骤，而使用 convert.exe 命令行工具将该驱动器转换为 NTFS。有关使用 convert.exe 命令行工具将 FAT 分区转换为 NTFS 分区的信息，请参阅 Microsoft 知识库文章 214579"How to Use Convert.exe to Convert a Partition to the NTFS File System"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=214579)。


SMTP MaxDSNSize 值已手动设置
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-01-17

Microsoft® Exchange Server 分析工具读取以下注册表子项，以确定传递状态通知 (DSN) 邮件的最大大小是否已被手动覆盖：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MaxDSNSize

如果 Exchange Server 分析工具发现 MaxDSNSize 存在并已配置，则会显示非默认配置消息。

MaxDSNSize 注册表值使运行 Exchange 2000 Server Service Pack 2 (SP2) 或更高版本的计算机能够在邮件无法送达的情况下删除附件。如果启用该选项，则可以节约服务器和网络资源。但是，这种剥离 SMTP 附件的实现存在缺点。

如果为了从未送达报告 (NDR) 中剥离附件而启用了该选项，则在预览窗格中显示通知时所需要的详细信息也会被剥离，并且邮件的原始发件人无法使用"再次发送"选项。如果邮件的原始发件人试图从 NDR 使用"再次发送"选项，则邮件的原始发件人将收到下列错误消息：

"无法重新发送该邮件。未传递报告没有包括有关邮件原件的足够信息。若要重新发送邮件，请在'已发送邮件'文件夹中打开该邮件，单击'动作'菜单，然后单击'重新发送该邮件'。"

但是，邮件的原始发件人无法重新发送邮件，甚至无法使用错误消息中提供的方法进行发送。因此，建议您谨慎使用该选项。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

修改 MaxDSNSize 注册表值

  1. 打开注册表编辑器，例如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. 创建一个名为 MaxDSNSize 的 DWORD 注册表值，并将它的值数据（字节）设置为希望的数字。

  4. 关闭注册表编辑器，并重新启动计算机，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 MaxDSNSize 注册表值的详细信息，请参阅下列知识库文章：

  • 308303"XCON:Option to Strip Attachments for Messages That Generate an NDR"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=308303)

  • 323484"XCON:Exchange 2000 中的 multipart/report Internet 邮件格式说明"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=323484)


SMTP MaxPendingCat 注册表值为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已更改默认的 SMTP 队列配置：

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

如果 Exchange Server 分析工具发现 MaxPendingCat 注册表项已设置，Exchange Server 分析工具将显示非默认值消息。

建议在修改默认队列值之前，一定要先充分考虑。默认值经过认真选择，在大多数环境下可以获得最佳性能。常见的最佳办法是解决问题的根本原因，而不是修改 Exchange 上的排队行为。

Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。

有关 Exchange SMTP 队列的详细信息，请参阅 Microsoft Exchange Team Blog 条目"Explaining the Mysterious SMTP Advanced Queuing Engine"（英文）(http://go.microsoft.com/fwlink/?LinkId=48585)。


SMTP MaxMessageObjects 设置得太低
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定系统可分配的最大邮件数：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\MailMsg\MaxMessageObjects

如果 Exchange Server 分析工具发现 MaxMessageObjects 的值小于 30001，则显示警告。

当队列包含最大数目的邮件时，简单邮件传输协议 (SMTP) 将不再接受其他入站邮件。SMTP 队列中的每封邮件至少使用 4 KB 内存；因此，如果队列非常大，可能会遇到内存不足的情况。

默认情况下没有 MaxMessageObjects 值，并且最大邮件数被设置为 100,000。如果将 MaxMessageObjects 设置为较低的值，将会减少可以驻留在队列中的最大邮件数，从而减少 SMTP 的最大内存占用。达到此限制后，与服务器建立的每个 SMTP 连接将返回内存不足的错误。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

对可能排队的 SMTP 邮件数设置限制

  1. 启动注册表编辑器，例如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\Software\Microsoft\Exchange

  3. 用鼠标右键单击 Exchange 项，再单击"新建""项"。将新项命名为 MailMsg。

  4. 用鼠标右键单击 MailMsg 项，再单击"新建""DWORD 值"。

  5. 用鼠标右键单击新值，单击"重命名"，再键入 MaxMessageObjects。

  6. 双击 MaxMessageObjects 值，再将它设置为队列中在任何时候都不能超过的最大邮件数。除非需要处理更多邮件，否则建议将最大值设置为 100,000。

  7. 退出注册表编辑器，并重新启动 SMTP 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关设置对队列中的邮件的限制的详细信息，请参阅 Microsoft 知识库文章 258748"How to set a limit on the number of SMTP messages in queues"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258748)。


SMTP MaxMessageObjects 注册表参数已从其默认值更改为其他值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定系统可分配的最大邮件数：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\MailMsg\MaxMessageObjects

如果 Exchange Server 分析工具发现 MaxMessageObjects 的值超过 0，则显示非默认配置消息。

队列包含最大邮件数时，SMTP 将无法接受任何其他入站邮件。SMTP 队列中的每封邮件至少使用 4 KB 内存；因此，如果队列非常大，可能会出现内存不足的情况。

默认情况下没有 MaxMessageObjects 值，并且最大邮件数被设置为 100,000。如果将 MaxMessageObjects 设置为较低的值，将会减少可以驻留在队列中的最大邮件数，从而减少 SMTP 的最大内存占用。到达此限制后，与服务器建立的每个 SMTP 连接将返回内存不足的错误。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

对可能排队的 SMTP 邮件数设置限制

  1. 启动注册表编辑器，例如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\Software\Microsoft\Exchange

  3. 用鼠标右键单击 Exchange 项，再单击"新建""项"。将新项命名为 MailMsg。

  4. 用鼠标右键单击 MailMsg 项，再单击"新建""DWORD 值"。

  5. 用鼠标右键单击新值，单击"重命名"，再键入 MaxMessageObjects。

  6. 双击 MaxMessageObjects 值，再将它设置为队列中在任何时候都不能超过的最大邮件数。除非需要处理更多邮件，否则建议您使用最大值 100,000。

  7. 退出注册表编辑器，并重新启动 Simple Mail Transfer Protocol (SMTP) 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关设置对队列中的邮件的限制的详细信息，请参阅知识库文章 258748"How to set a limit on the number of SMTP messages in queues"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258748)。


手动设置了 SMTP MaxPercentPoolThreads 注册表值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-01-17

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已手动配置了其他缓冲池线程：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\MaxPercentPoolThreads

如果 Exchange Server 分析工具发现 MaxPercentPoolThreads 存在并已配置，则显示非默认配置消息。

SMTP 中有五个工作队列使用一池线程，即 ATQ 线程。按照设计，其中的两个工作队列在默认情况下最多可使用百分之九十的可用线程。线程池可由接受了 POP 和 IMAP 请求的进程共享。因此，在由中到高的加载方案中可能会出现一种情况：SMTP 使 POP 和 IMAP 服务不能享用资源。

可以通过限制 SMTP 可使用的线程百分比来为 POP 和 IMAP 保留足够的线程。若要作此更改，则必须增加 IIS 可用的线程总数。唯一的折衷方案是增加其他线程使用的内存。

有两个注册表值允许控制每个处理器中 SMTP 可使用的线程的百分比，以及其他线程的百分比：

位置：HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

值：AdditionalPoolThreadsPerProc

类型：REG_DWORD

位置：HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

值：MaxPercentPoolThreads

类型：REG_DWORD

在群集 Exchange Server 计算机上，如果高 SMTP 活动量导致 POP3、IMAP4 或者二者的资源失败，则应当调整这两个注册表值。可以使用下列公式计算群集的最优值：

注册表值 | 公式
AdditionalPoolThreadsPerProc | ((9 / (MaxPercentPoolThreads/100)) - 4) / 2
MaxPercentPoolThreads | 90 / (2 * 协议虚拟服务器数)

例如，在具有两个协议虚拟服务器的 Exchange Server 群集中，MaxPercentPoolThreads 的公式应为：90 / (2*2) = 22。计算 MaxPercentPoolThreads 值时，如果计算结果中包含小数点，则应该将结果舍入为最接近的整数。计算 AdditionalPoolThreadsPerProc 值时，如果计算结果大于 200，则还需要将所得值赋给其他注册表值：

位置：HKLM\System\CurrentControlSet\Services\InetInfo\Parameters\

值：PoolThreadLimit

类型：REG_DWORD

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

在 Exchange 群集上配置最佳设置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. 创建名为 AdditionalPoolThreadsPerProc 的 DWORD 注册表值，并根据上述公式为其设置适当的数值数据。

  4. 创建名为 MaxPercentPoolThreads 的 DWORD 注册表值，并根据上述公式为其设置适当的数值数据。

  5. 退出注册表编辑器，并重新启动 IIS Admin 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关本文章中描述的特殊群集资源问题的详细信息，请参阅知识库文章 281868"XADM:POP\IMAP4 Virtual Servers Repeatedly Fail Over Under High Load"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=281868)。


SMTP MsgHandleAsyncThreshold 注册表值已手动添加但可能不再需要
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-01-17

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已将最大异步 Internet 信息服务 (IIS) 文件句柄数从默认值 1,000 修改为其他值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MsgHandleAsyncThreshold

如果 Exchange Server 分析工具发现 MsgHandleAsyncThreshold 存在并配置为其他值，则显示警告。

MsgHandleAsyncThreshold 值指定了 IIS 可以使用的最大异步文件句柄数。由于缓存的文件句柄能让服务器免于执行冗余的输入/输出 (I/O) 和 CPU 周期，因此文件句柄被缓存起来以便提高性能。每当 Exchange Server 计算机上的 SMTP 传输堆栈收到邮件时，该邮件都会流出到文件系统，并在那里等待路由到它的目的地。为了写入文件系统，SMTP 传输堆栈将获得文件句柄，然后将邮件传递给该句柄。每个文件句柄会消耗大约 2 KB 的页面缓冲池内存。默认的 IIS 缓存文件句柄数是每 32 MB 有 800 个句柄。

在 Exchange 2000 Server Service Pack 2 (SP2) 之前，由于 SMTP 服务的默认设置是最多 1,000 个文件句柄，使得保持大型 SMTP 邮件队列（例如，平均 1,001 封或更多邮件）的 Exchange 服务器遭遇了性能约束。由于 Exchange 2000 Server 默认设置是最多 1,000 个文件句柄，因此 SMTP 服务只能同时将 1,000 个邮件写入文件系统。

若要提高这些大型系统的性能，通常需要同时调整三个注册表项，以增加 SMTP 服务可以打开的最大文件句柄数（以便可以处理更多邮件），并减少可安装的文件系统（另一个 Exchange 组件，用于避免出现大型队列时内存不足）的打开文件句柄数。默认情况下这些注册表值不存在，因此需要手动添加，下面列出了这些值：

位置：HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

值：MsgHandleThreshold

类型：REG_DWORD

位置：HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

值：MsgHandleAsyncThreshold

类型：REG_DWORD

位置：HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

值：FileCacheMaxHandles

类型：REG_DWORD

MsgHandleThreshold 和 MsgHandleAsyncThreshold 项通常被调整为相同的值（通常是大于 1,000 的值），而 FileCacheMaxHandles 值通常从 800 减少到 600。

默认情况下，由于 Exchange 2000 Server SP2 和更高版本动态确定要使用的最佳值，因此该注册表值不存在。如果此 Exchange 服务器运行的是 Exchange 2000 Server Service Pack 1 (SP1) 或更早版本，则建议的最佳实践是升级至最新的 Service Pack 和更新汇总软件包。升级到最新代码之后，即可删除这些注册表项。

Exchange Server 2003 动态计算适合于 SMTP 文件句柄的设置，因此这些设置不再需要。因此，除非得到 Microsoft 产品支持服务的其他指导，否则在将使用这些设置的任何 Exchange 2000 Server 计算机升级到 Exchange Server 2003 之前，应当从注册表中删除这些项。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

还原到默认配置

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. 在右侧窗格中，删除 MsgHandleAsyncThreshold 值。

  4. 关闭注册表编辑器，并重新启动 IIS Admin 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


SMTP MsgHandleThreshold 注册表值已手动添加但可能不再需要
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-09-06

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已将 Internet 信息服务 (IIS) 文件句柄的最大数修改为默认值 1,000 以外的其他值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MsgHandleThreshold

如果 Exchange Server 分析工具发现 MsgHandleThreshold 存在并被配置为其他值，则显示非默认配置消息。

MsgHandleThreshold 值指定了 IIS 可以使用的最大文件句柄数。由于缓存的文件句柄能让服务器免于执行冗余的输入/输出 (I/O) 和 CPU 周期，因此文件句柄被缓存起来以便提高性能。每当 Exchange Server 计算机上的 SMTP 传输堆栈收到邮件时，该邮件都会流出到文件系统，并在那里等待路由到它的目的地。为了写入文件系统，SMTP 传输堆栈将获得文件句柄，然后将邮件传递给该句柄。每个文件句柄会消耗大约 2 KB 的页面缓冲池内存。默认的 IIS 缓存文件句柄数是每 32 MB 有 800 个句柄。

在 Exchange 2000 Server Service Pack 2 (SP2) 之前，由于 SMTP 服务的该默认设置是最多 1,000 个文件句柄，使得保持大型 SMTP 邮件队列（例如，平均 1,000 封或更多邮件）的 Exchange 服务器已在过去遇到过性能受约束的情况。由于 Exchange 2000 Server 默认设置是最多 1,000 个文件句柄，因此 SMTP 服务只能同时将 1,000 个邮件写入文件系统。

若要提高这些大型系统的性能，通常需要同时调整三个注册表项，以增加 SMTP 服务可以打开的最大文件句柄数（以便可以处理更多邮件），并减少可安装的文件系统（另一个 Exchange 组件，用于避免出现大型队列时内存不足）的打开文件句柄数。默认情况下这些注册表值不存在，因此需要手动添加，下面列出了这些值：

Location:HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

值：MsgHandleThreshold

类型：REG_DWORD

Location:HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

值：MsgHandleAsyncThreshold

类型：REG_DWORD

位置：HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

值：FileCacheMaxHandles

类型：REG_DWORD

MsgHandleThreshold 和 MsgHandleAsyncThreshold 项通常被调整为相同的值（通常是大于 1,000 的值），而 FileCacheMaxHandles 值通常从 800 减少到 600。

如果此 Exchange 服务器运行的是 Exchange 2000 Server ，则建议的最佳实践是升级为最新级别的 Service Pack 和汇总包。升级为最新代码后，建议将 MsgHandleThreshold 值设置为默认值 1000。

Exchange Server 2003 的 MsgHandleThreshold 默认值为 1000，因此，不再需要这些注册表覆盖设置。因此，除非得到 Microsoft 产品支持服务的其他指导，否则在将使用这些设置的任何 Exchange 2000 Server 计算机升级到 Exchange Server 2003 之前，应当从注册表中删除这些项。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。

更正此错误

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到：HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. 删除 MsgHandleThreshold 值。

  4. 关闭注册表编辑器，并重新启动 IIS Admin 服务，以使更改生效。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。


SMTP 拾取文件正在写入压缩文件夹
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP) PickUp 文件夹的 Compressed 关键字的值。如果 Exchange Server 分析工具发现 Compressed 的值设置为 True，则显示警告。

当邮件通过 SMTP 服务到达 Exchange 计算机时，数据以 .eml 文件的形式写入到硬盘中。默认情况下，这些文件存储在 Exchange 安装分区的 <drive>:\Program Files\Exchsrvr\Mailroot 文件夹中。如果存储 SMTP PickUp 数据的文件夹启用了文件压缩，那么 Exchange 的性能将大幅度下降。因此，不支持对存储 SMTP 拾取数据的文件夹进行压缩。

如果收到此警告，则必须关闭存储 SMTP 拾取数据的文件夹上的压缩功能，或者必须将 SMTP 拾取数据移动到未压缩的文件夹中。

Microsoft 不支持将 Exchange 数据文件存储在压缩卷上。在压缩卷上存储 Exchange 数据文件时，额外的开销会极大地影响 Exchange 性能。Exchange 数据文件包括下列所有文件：

  • .edb 文件

  • .stm 文件

  • .log 文件

  • .dat 文件

  • .eml 文件

  • .chk 文件

关闭给定文件夹的文件压缩功能

  1. 用鼠标右键单击想要关闭文件压缩功能的文件夹，再单击"属性"。

  2. 在"常规"选项卡上，单击"高级"。

  3. 在"高级属性"对话框中，清除"压缩内容以便节省磁盘空间"复选框，再单击"确定"。

有关移动 PickUp 文件夹的详细信息，请参阅 Microsoft 知识库文章"How to change the Exchange 2003 SMTP Mailroot folder location"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)。


SMTP Pickup 文件正被写入加密文件夹
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP) PickUp 文件夹的 Encrypted 关键字的值。如果 Exchange Server 分析工具发现 Encrypted 的值设置为 True，则显示警告。

当邮件通过 SMTP 服务到达 Exchange 计算机时，数据以 .eml 文件的形式写入到硬盘中。默认情况下，这些文件存储在 Exchange 安装分区的 <drive>:\Program Files\Exchsrvr\Mailroot 文件夹中。如果存储 SMTP PickUp 数据的文件夹启用了文件加密，那么 Exchange 的性能将大幅度下降。因此，不支持对存储 SMTP PickUp 数据的文件夹进行加密。

如果收到此警告，必须在存储 SMTP PickUp 数据的文件夹上禁用加密，或者必须将 SMTP PickUp 数据移至未加密的文件夹中。

Microsoft 不支持在以加密文件系统 (EFS) 方式加密的卷上存储 Exchange 数据文件。当在加密卷上存储 Exchange 数据文件时，额外开销会大大影响 Exchange 的性能。Exchange 数据文件包括下列文件：

  • .edb 文件

  • .stm 文件

  • .log 文件

  • .dat 文件

  • .eml 文件

  • .chk 文件

为帮助确保 Exchange 数据文件的安全性，建议阻止对 Exchange 计算机的未经授权访问，并使用 S/MIME 邮件格式加密邮件数据。

要解决此错误，必须在 PickUp 文件夹上禁用文件加密，或者将 PickUp 文件夹移至未启用加密的位置。

在给定的文件夹上禁用文件加密

  1. 用鼠标右键单击要在其中禁用文件加密的文件夹，再单击"属性"。

  2. 在"常规"选项卡上，单击"高级"。

  3. 在"高级属性"对话框中，清除"加密内容以便保护数据"复选框，再单击"确定"。

有关移动 PickUp 文件夹的详细信息，请参阅 Microsoft 知识库文章 822933"How to change the Exchange 2003 SMTP Mailroot folder location"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)。

有关 Exchange Server 数据文件和 EFS 的详细信息，请参阅知识库文章 834638"Information about the storage of data files on an encrypted volume in Exchange Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638)。

有关在 Exchange Server 2003 中如何保护邮件安全的信息，请参阅"Exchange Server 2003 邮件安全指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=2305405C-FAF1-488A-A856-AD467BB59B26&DisplayLang=zh-cn)。


SMTP Pickup 文件正被写入非 NTFS 分区
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange SMTP PickUp 目录的 FSName 关键字的值。如果 Exchange Server 分析工具确定 FSName 关键字的值不等于 NTFS，则会显示警告。

Microsoft 不支持将 Exchange 数据文件存储在非 NTFS 卷上。Exchange 数据文件包括下列文件：

  • .edb 文件

  • .stm 文件

  • .log 文件

  • .dat 文件

  • .eml 文件

如果出现此警告，则必须将 SMTP PickUp 目录移动到 NTFS 文件系统驱动器上的文件夹中。或者，如果存储 PickUp 目录的驱动器是 FAT 格式的驱动器，可使用 convert.exe 命令行工具将驱动器转换为 NTFS 格式。

有关移动 PickUp 文件夹的详细信息，请参阅 Microsoft 知识库文章 822933"How to change the Exchange 2003 SMTP Mailroot folder location"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)。

或者，如果存储文件的驱动器是 FAT 格式的驱动器，可使用 convert.exe 命令行工具将驱动器转换为 NTFS 格式。有关使用 convert.exe 命令行工具将 FAT 分区转换为 NTFS 分区的信息，请参阅知识库文章 214579"How to Use Convert.exe to Convert a Partition to the NTFS File System"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579)。


SMTP 端口更改
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-11

Microsoft® Exchange Server 分析工具读取 Internet 信息服务 (IIS) 元数据库中的以下属性，以确定其值是否与默认值 25 相匹配：

LM/SmtpSvc/<SMTP virtual server instance>/SMTPPORT

如果 Exchange Server 分析工具发现 SMTPPORT 属性值不是 25，则 Exchange Server 分析工具将显示警告。

SMTPPORT 属性代表该简单邮件传输协议 (SMTP) 服务器用来侦听传入连接的 TCP 端口。可以将 SMTP 虚拟服务器配置为侦听一个或多个 TCP 端口。默认情况下，所有 SMTP 虚拟服务器都配置为侦听默认 SMTP 端口，即 TCP 端口 25。如果 SMTP 侦听端口已从默认值修改为其他值，并且在其侦听端口列表中不再包括 TCP 端口 25，则此修改可能中断邮件流。

如果对内部邮件基础结构的余下部分也相应地进行了修改，则更改 SMTP 侦听端口是可接受的。但通常情况下，备用端口不能用于直接从 Internet 接收邮件的 SMTP 虚拟服务器，因为 Internet 上的 SMTP 服务器通过端口 25 发送邮件。

注意：
Exchange Server 分析工具检查 Exchange SMTP 协议虚拟服务器的值。此 SMTP 协议虚拟服务器不必是直接从 Internet 接收邮件的 SMTP 服务器。一些防病毒产品和防垃圾邮件产品设计为通过端口 25 接收来自 Internet 的 SMTP 邮件，而通过另一个端口将邮件重定向到 Exchange SMTP 虚拟服务器。在这种情况下，Exchange SMTP 虚拟服务器侦听 25 以外的端口是一种可接受的配置。
查看或修改 SMTP 虚拟服务器侦听端口

  1. 在 Exchange 系统管理器中，依次展开"服务器"、Exchange 服务器、"协议"、"SMTP"。

  2. 用鼠标右键单击 SMTP 虚拟服务器，例如默认的 SMTP 虚拟服务器，再单击"属性"。

  3. 选择"常规"选项卡，再单击"高级"。

  4. 将显示 IP 地址和端口列表。

    • 若要更改现有端口，请选择 IP 地址，再单击"编辑"。将 TCP 端口字段更改为 25。

    • 若要将端口 25 作为附加侦听端口添加，请单击"添加"，并添加新的 IP 地址/端口组合。如果要使用连接筛选、发件人筛选或收件人筛选，请务必选中相应的复选框。

  5. 单击"确定"保存更改，再单击"确定"退出"高级"对话框。单击"确定"关闭 SMTP 虚拟服务器的"属性"对话框。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列 Microsoft 知识库文章：

  • 266686"XCON:如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)。

  • 268163"XCON:如何配置 SMTP 虚拟服务器（第 2 部分）"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)。


SMTP 队列文件夹包含大量文件
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-10-06

Microsoft® Exchange Server 分析工具查询 Internet 信息服务 (IIS) 元数据库，以确定每台简单邮件传输协议 (SMTP) 虚拟服务器实例的 QueueDirectory 属性值。

然后，Exchange Server 分析工具计算为每台 SMTP 虚拟服务器所指定队列文件夹中的文件数。

如果 Exchange Server 分析工具发现 SMTP 虚拟服务器的队列文件夹中的文件超过 50,000 个，则 Exchange Server 分析工具会显示警告。

如果 Exchange Server 分析工具发现 SMTP 虚拟服务器的队列文件夹中的文件超过 90,000 个，则 Exchange Server 分析工具会显示错误。

此警告或错误表示累积了大量的邮件，SMTP 虚拟服务器实例必须对其进行处理。此警告或错误表示服务器上出现严重的性能问题或中断，因为该服务器无法继续及时地传递传入邮件。下列条件可能造成此延迟：

  • 未快速咨询 Active Directory® 目录服务。

  • 未快速发出邮件以进行本地传递或 SMTP 传递。

若要解决该问题，请执行下列操作：

  • 检查队列文件夹中邮件的合法性，以验证服务器并未由于商业垃圾邮件 (UCE)、垃圾邮件或病毒攻击而处于异常负载状态。

  • 验证 SMTP 服务已启用并且正在运行。

验证 SMTP 服务是否已启动

  1. 打开"服务"Microsoft 管理控制台 (MMC) 管理单元。

  2. 在右侧窗格中，向下滚动到"简单邮件传输协议 (SMTP)"服务，并双击它。此时将显示"简单邮件传输协议 (SMTP)"的"属性"对话框。

  3. 确定将"启动类型"下拉菜单中的值设置为"自动"。

  4. 单击"启动"，启动系统助理服务。

  5. 单击"确定"保存更改，然后关闭"简单邮件传输协议 (SMTP)"的"属性"对话框。

  6. 关闭"服务"管理单元。

有关如何排除 SMTP 队列故障的详细信息，请参阅下列 Exchange 资源：

  • "Exchange Server Transport and Routing Guide"（Exchange Server 传输和路由指南）中的"Troubleshooting Mail Flow and SMTP"（邮件流和 SMTP 疑难解答）(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)。

  • Microsoft 知识库文章 821877"描述 SMTP 和 X.400 队列属性选项卡上的字段"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)。

  • Microsoft 知识库文章 264054"XCON：了解 Exchange 2000 Server 中的队列状态"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


SMTP 队列文件夹和拾取文件夹相同
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以验证拾取邮件的目录不是特定 SMTP 虚拟服务器的邮件编队至的目录。如果 Exchange Server 分析工具发现 Queue 目录的属性 msExchSmtpQueueDirectory 与 Pickup 目录的属性 msExchSmtpPickupDirectory 相同，Exchange Server 分析工具将显示错误。

此错误属于严重错误。如果 msExchSmtpQueueDirectory 属性和 msExchSmtpPickupDirectory 属性设置为同一个目录，则会传输重复的邮件。可以使用 ADSI（Active Directory 服务接口）Edit 更新这些属性。

警告：
在使用 ADSI Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。
使用 ADSI Edit 更新 msExchSmtpPickupDirectory 或 msExchSmtpQueueDirectory 属性

  1. 从 Windows® 2000 支持工具或 Windows Server 2003 支持工具启动 ADSI Edit 工具。

  2. 展开下列节点：

    • Configuration Container

    • Configuration

    • Services

    • Microsoft Exchange

    • Organization_Name

    • Recipient Policies

    • Administrative_Group_Name

    • Servers

    • 服务器名称

    • 协议

    • SMTP

  3. 在详细信息窗格中，用鼠标右键单击 CN=1（其中 1 是默认的 SMTP 虚拟服务器），再单击 Properties。

  4. 在 Select which properties to view 列表中，单击 Both。

  5. 更新 msExchSmtpPickupDirectory 属性，使其不再与 msExchSmtpQueueDirectory 冲突，完成后再单击 Set。

  6. 单击 OK，再单击 Apply，然后关闭 ADSI Edit。

  7. 等待至少 15 分钟进行复制。


SMTP 队列与系统分区在同一个驱动器上
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchSmtpQueueDirectory 属性的配置值。

Exchange Server 分析工具还查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP) 服务的 Started 关键字的值。值为 False 说明服务未运行。值为 True 说明服务正在运行。此外，Exchange Server 分析工具还查询 Win32_OperatingSystem WMI 类，以确定 WindowsDirectory 关键字的值。该关键字的值指示 Windows 系统驱动器的位置。

如果 Exchange Server 分析工具发现 msExchSmtpQueueDirectory 属性配置为包含系统驱动器的路径、SMTP 服务正在运行和 Exchange 未运行在 Microsoft Windows Small Business Server 上，则会显示警告。

msExchSmtpQueueDirectory 属性表示 SMTP 队列文件夹（也称为 Mailroot 文件夹）的路径。当邮件通过 SMTP 服务到达 Exchange 服务器时，数据以 .eml 文件的形式写入到硬盘中。默认情况下，这些文件存储在 Exchange 安装分区上的 <drive>:\Program Files\Exchsrvr\Mailroot 文件夹中。

在某些方案中，例如，当配置桥头服务器时，将 SMTP Mailroot 目录移至另一个硬盘或分区会提高 Exchange 服务器的性能。要获得最佳性能，SMTP Mailroot 文件夹不应当在 Windows 系统驱动器上，而应当在快速磁盘或快速磁盘子系统上。这是最佳实践。

虽然可以在 Exchange Server 2003 SMTP 虚拟服务器上的 Exchange 系统管理器中移动 Mailroot 文件夹，但是在 Exchange 2000 Server SMTP 虚拟服务器上移动该文件夹需要使用低级 Active Directory 编辑器，如 Active Directory 服务接口 (ADSI) Edit。

警告：
在使用 ADSI Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

在 Exchange Server 2003 上更正此错误

  1. 打开 Exchange 系统管理器。

  2. 展开"服务器"，展开 Exchange 服务器，展开"协议"，再展开"SMTP"。

  3. 用鼠标右键单击 SMTP 虚拟服务器（例如，默认 SMTP 虚拟服务器），再单击"停止"。

  4. 再次用鼠标右键单击 SMTP 虚拟服务器，再单击"属性"。

  5. 单击"邮件"选项卡。

  6. 在"队列目录"字段中，指定相应的 Mailroot 文件夹的完整路径。可以单击"浏览"在本地计算机上找到该路径。

  7. 单击"确定"保存更改。

  8. 用鼠标右键单击 SMTP 虚拟服务器，再单击"启动"。将立即使用新位置。

在 Exchange 2000 Server 上更正此错误

  1. 在要修改其 SMTP 虚拟服务器 Mailroot 文件夹的 Exchange 2000 Server 计算机上停止所有 Exchange Server 和 IIS 服务。

  2. 修改受影响的 SMTP 虚拟服务器的 msExchSmtpQueueDirectory 值，以便它配置为适当的路径。

  3. 等待 Active Directory 将该更改复制到此 Exchange 服务器使用的全局编录服务器。

  4. 启动"Microsoft Exchange System Attendant"服务。

  5. 在 Exchange Server 计算机上，检查应用程序事件日志中是否存在事件来源为 MSExchangeMU、类别为"常规"的事件 ID 1005 的三个实例。

  6. 重新启动 Exchange Server 计算机以使更改生效。

有关上面介绍的两个过程的详细信息，请参阅下列 Microsoft 知识库文章：

  • 822933"How to change the Exchange 2003 SMTP Mailroot folder location"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822933)

  • 318230"XCON:How to Change the Exchange 2000 SMTP Mailroot Directory Location"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=318230)

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列知识库文章：

  • 266686"XCON:如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)

  • 268163"XCON:How to Configure a SMTP Virtual Server Part 2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


SMTP ResetMessageStatus 注册表值为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否更改了默认的 SMTP 队列配置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing

如果符合以下条件，Exchange Server 分析工具将显示错误：

  • ResetMessageStatus 注册表项未设置为 0（零）。

  • 群集服务未在 Exchange Server 上运行。

如果 ResetMessageStatus 注册表项设置为 1，Exchange Server 重新启动时，队列中当前的所有邮件将重新通过所有内部处理队列。例如，Exchange Server 重新启动时，队列中当前的所有邮件将重新通过分类程序。因此，只有在解决 SMTP 安装问题时，ResetMessageStatus 注册表项才应设置为 1，如 Microsoft 知识库文章 279616"XCON：Adding a Registry Key to Re-Categorize Messages"（英文）(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=279616) 中所述。如果不是在解决 SMTP 安装问题，应删除此注册表项。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
删除 ResetMessageStatus 注册表项

  1. 打开注册表编辑器，如 Regedit.exe 或 Regedt32.exe。

  2. 导航到： HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. 在右侧窗格中，找到并删除 ResetMessageStatus 值。

  4. 关闭注册表编辑器。

编辑注册表之前，要获取有关如何编辑注册表的信息，请参阅 Microsoft 知识库文章 256986"Microsoft Windows 注册表说明"(http://support.microsoft.com/kb/256986/zh-cn)。

有关 Exchange SMTP 队列的详细信息，请参阅 Microsoft Exchange Team Blog 条目"Explaining the Mysterious SMTP Advanced Queuing Engine"（英文）(http://go.microsoft.com/fwlink/?LinkId=48585)。


The SMTP ResetRoutesRetryMinutes registry value is non-default
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否更改了默认的 SMTP 队列配置：

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

如果 Exchange Server 分析工具发现 ResetRoutesRetryMinutes 注册表项已设置，Exchange Server 分析工具将显示非默认值消息。

建议在修改默认队列值之前，一定要先充分考虑。默认值经过认真选择，在大多数环境下可以获得最佳性能。常见的最佳办法是解决问题的根本原因，而不是修改 Exchange Server 上的排队行为。

Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。

有关 Exchange SMTP 队列的详细信息，请参阅 Microsoft Exchange Team Blog 条目"Explaining the Mysterious SMTP Advanced Queuing Engine"（英文）(http://go.microsoft.com/fwlink/?LinkId=48585)。


SMTP RoutingRetryMinutes 注册表值为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否更改了默认的 SMTP 队列配置：

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

如果 Exchange Server 分析工具发现 RoutingRetryMinutes 注册表项已设置，则 Exchange Server 分析工具将显示非默认值消息。

建议在修改默认队列值之前，一定要先充分考虑。默认值经过认真选择，在大多数环境下可以获得最佳性能。常见的最佳办法是解决问题的根本原因，而不是修改 Exchange Server 上的排队行为。

Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。

有关 Exchange SMTP 队列的详细信息，请参阅 Microsoft Exchange Team Blog 条目"Explaining the Mysterious SMTP Advanced Queuing Engine"（英文）(http://go.microsoft.com/fwlink/?LinkId=48585)。


SMTP SecondsPerDSNPass 注册表值为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具将读取以下注册表项，以确定 SecondsPerDSNPass 注册表值的设置：

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

如果 Exchange Server 分析工具发现 SecondsPerDSNPass 注册表项存在并且未设置为 10，则会显示非默认配置的消息。

此设置用于优化传递状态通知 (DSN) 并指定每轮 DSN 处理需要的秒数。只要超过此阈值，DSN 生成过程将停止，稍后再重新启动。建议在修改默认值之前，一定要经过慎重的考虑。此特定设置只有在向 Microsoft 支持服务部门咨询之后才应修改。默认值经过认真选择，在大多数环境下可以获得最佳性能。解决问题的根本途径是常见的最佳实践，而不是修改 Exchange 服务器上的排队方式。

Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。


SMTP 服务器禁用了 NTLM 身份验证
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-11-10

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定是否已在 msExchAuthenticationFlags 属性中设置 NTLM 身份验证协议（也称为集成 Windows 身份验证）位。如果 Exchange Server 分析工具确定未设置位，并且 Exchange 未在 Microsoft Windows® Small Business Server 上运行，则显示警告。

msExchAuthenticationFlags 属性表明了协议虚拟服务器接受的身份验证类型。此属性使用三位掩码。

位 | 身份验证方法
0 | 匿名
1 | 基本
2 | NTLM（集成 Windows 身份验证）

如果控制 NTLM 身份验证的位未设置，SMTP 虚拟服务器将不会允许 NTLM 身份验证。这会导致 Exchange Server 计算机之间出现身份验证问题。

解决此警告问题

  1. 打开 Exchange 系统管理器。

  2. 依次展开"服务器"、服务器名、"协议"、"SMTP"。

  3. 右键单击该 Exchange SMTP 虚拟服务器，再单击"属性"。

  4. 单击"访问"选项卡，再单击"身份验证"，然后单击以选中"集成 Windows 身份验证"复选框。

  5. 单击"确定"，然后再次单击"确定"。

  6. 关闭 Exchange 系统管理器。

有关 SMTP 的身份验证方法的详细信息，请参阅"Exchange Server Transport and Routing Guide"（Exchange Server 传输和路由指南）(http://go.microsoft.com/fwlink/?LinkId=47579) 和 Microsoft 知识库文章 319267"如何在Exchange 2000 Server 中保证简单邮件传输协议客户端邮件传递的安全"(http://support.microsoft.com/kb/319267/zh-cn)。


SMTP SubmissionRetryMinutes 注册表值为非默认值
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已更改默认的 SMTP 队列配置：

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

如果 Exchange Server 分析工具发现 SubmissionRetryMinutes 注册表项已设置，Exchange Server 分析工具将显示非默认值消息。

建议在修改默认队列值之前，一定要先充分考虑。默认值经过认真选择，在大多数环境下可以获得最佳性能。常见的最佳办法是解决问题的根本原因，而不是修改 Exchange 上的排队行为。

Exchange Server 分析工具仅以提供信息为目的报告此配置。不需要执行任何操作。

有关 Exchange SMTP 队列的详细信息，请参阅 Microsoft Exchange Team Blog 条目"Explaining the Mysterious SMTP Advanced Queuing Engine"（英文）(http://go.microsoft.com/fwlink/?LinkId=48585)。


SMTP 虚拟服务器的邮件大小限制高于全局邮件大小限制
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以便将 SMTP 虚拟服务器的传入邮件大小限制与全局传入邮件大小限制进行比较。

代表 SMTP 虚拟服务器的传入和传出邮件大小限制的 Active Directory 属性是 msExchSmtpMaxMessageSize。该值是 Active Directory 中的 SMTP 虚拟服务器对象的属性，该对象可以在以下位置找到：

CN=<Virtual Server Number>, CN=SMTP, CN=Protocols, CN=<ServerName>, CN=Servers, CN=<AdministrativeGroupName>, CN=Administrative Groups, CN=<OrganizationName>, CN=Microsoft Exchange, CN=Services, CN=Configuration, DC=<DomainName>, DC=com

代表全局传入邮件大小限制的 Active Directory 属性是 delivContLength。该值是组织的全局设置邮件传递对象（在 Active Directory 中）的属性，该对象可以在以下位置找到：

CN=Message Delivery, CN=Global Settings, CN=<OrganizationName>, CN=Microsoft Exchange, CN=Services, CN=Configuration, DC=<DomainName>, DC=com

如果 Exchange Server 分析工具发现 msExchSmtpMaxMessageSize 的值大于 delivContLength 的值，则会显示警告。

如果任何 SMTP 虚拟服务器的邮件大小限制高于全局邮件大小限制，可能导致在入站时接受超大的邮件，从而导致邮件未能送达。要解决此问题，请将 SMTP 虚拟服务器的最大邮件大小配置为等于或小于全局传入邮件大小限制。

注意：
如果将邮件大小限制设置得过低，可能导致 Exchange Server 计算机之间的脱机通讯簿复制无法进行。有关此问题的详细信息，请参阅 Microsoft 知识库文章 326154"XADM:The OAB Does Not Replicate If You Set a Message Size Restriction at the Transport Level"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=326154)。

解决此警告问题

  1. 在 Exchange 系统管理器中，依次展开"服务器"、Exchange 服务器、"协议"、"SMTP"。

  2. 用鼠标右键单击 SMTP 虚拟服务器（例如，默认 SMTP 虚拟服务器），并选择"属性"。

  3. 选择"邮件"选项卡。

  4. 编辑"限制邮件大小不超过(KB)"字段的值，使它等于或小于全局邮件大小限制。

  5. 单击"确定"保存更改，并关闭 SMTP 虚拟服务器的"属性"对话框。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列知识库文章：

  • 266686"XCON:如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)

  • 268163"XCON:How to Configure a SMTP Virtual Server Part 2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

有关查看和编辑组织范围的设置的详细信息，请参阅知识库文章 821881"How to Modify Global Settings in Exchange System Manager"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821881)。

有关全局邮件大小限制的详细信息，请参阅下列知识库文章：

  • 298572"An E-Mail Message That Is Larger Than the Sending Message Size Limit or the Receiving Message Size Limit Is Not Delivered"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=298572)

  • 322679"为邮件设置大小限制"(http://support.microsoft.com/kb/322679/zh-cn)

  • 824111"Exchange Server 2003 中引入的安全设置更改和更新"(http://support.microsoft.com/kb/824111/zh-cn)。


此 SMTP 虚拟服务器配置为对传入邮件执行反向 DNS 查找
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-08-24

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定 msExchSmtpPerformReverseDnsLookup 属性的配置值是否已从默认值 False 更改为其他值。默认情况下，msExchSmtpPerformReverseDnsLookup 属性配置为不对传入邮件执行反向 DNS 查找。如果 Exchange Server 分析工具发现该属性设置为 True，则会显示警告。

"对传入邮件执行反向 DNS 查找"选项未提供用于防止接收垃圾电子邮件的功能。如果使用此选项，Exchange Server 会执行 DNS 查询将传入邮件的起始 Internet 协议 (IP) 地址解析为主机名。然后，该主机名附加到电子邮件的头信息中。

如果启用此功能，则当存在配置不正确的 DNS 记录或者 Internet 连接时断时续时，性能会下降。因此，当 Internet 邮件传递速度比预想的慢时，您可能要禁用此选项。

对传入 SMTP 邮件启用或禁用反向 DNS 查找

  1. 打开 Exchange 系统管理器。

  2. 展开"服务器"，展开 Exchange 服务器，展开"协议"，再展开"SMTP"。

  3. 用鼠标右键单击 SMTP 虚拟服务器（例如，默认 SMTP 虚拟服务器），再单击"属性"。

  4. 单击"传递"选项卡，再单击"高级"。

    • 若要启用反向 DNS 查找，请选中"对传入邮件执行反向 DNS 查找"复选框。

    • 若要禁用反向 DNS 查找，请清除"对传入邮件执行反向 DNS 查找"复选框。

  5. 单击"确定"保存更改，再单击"确定"退出 SMTP 虚拟服务器的"属性"对话框。

有关 Exchange 中的反向 DNS 查找功能的详细信息，请参阅 Microsoft 知识库文章 297412"The "Perform Reverse DNS Lookup for Incoming Messages" Option Is for Host Name Resolution"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412)。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列知识库文章：

  • 266686"XCON:如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)

  • 268163"XCON:How to Configure a SMTP Virtual Server Part 2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


已启用智能邮件筛选器 SP1 版
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定服务器上是否已安装并启用了 Microsoft Exchange 智能邮件筛选器：

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

Exchange Server 分析工具读取 ContentFilter 注册表项中的 ContentFilterBindings 值，以确定服务器上是否已安装并启用了智能邮件筛选器。

Exchange Server 分析工具随后查询 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 类，以确定 Exchange Server 2003 Service Pack 1 (SP1) 版的智能邮件筛选器 MSExchange.UceContentFilter.dll 是否位于 Exchange Server 的以下路径中：

<Exchange 服务器二进制文件的路径>\MSCFv1\MSExchange.UceContentFilter.dll

注意：
在此路径中，<Exchange 服务器二进制文件的路径> 是指 bin 文件夹的位置。

如果在此服务器上安装并启用了 Exchange Server 2003 SP1 版的智能邮件筛选器，则 Exchange Server 分析工具将显示警告。

该警告表明有更新版本的智能邮件筛选器可用。建议您安装最新版本的智能邮件筛选器。如果要解决涉及此特定服务器的邮件流问题，则可能需要临时禁用智能邮件筛选器，以确定它是否错误地阻止了合法邮件。

禁用智能邮件筛选器

  1. 单击"开始"，指向"所有程序"，指向"Microsoft Exchange"，再单击"系统管理器"。

  2. 在 Exchange 系统管理器中，依次展开"服务器"、服务器名称、"协议"、"SMTP"，再用鼠标右键单击"智能邮件筛选"，然后单击"属性"。

  3. 在"常规"选项卡的"对下列虚拟服务器的 IP 地址应用智能邮件筛选"下，清除每台要禁用智能邮件筛选器的 SMTP 虚拟服务器旁边的复选框。

    "智能邮件筛选属性"对话框

有关详细信息，请参阅网站上的"Exchange Intelligent Message Filter"（英文）(http://go.microsoft.com/fwlink/?LinkId=21607)。


已启用智能邮件筛选器 SP2 版
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-04

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定简单邮件传输协议 (SMTP) 虚拟服务器对象的 msExchServerBindingsFiltering 属性是否表示已为 SMTP 虚拟服务器实例启用了智能邮件筛选器。

Exchange Server 分析工具还查询 Active Directory，以确定是否在全局设置级别启用了 msExchUceEnabled。

如果下列条件为真，则 Exchange Server 分析工具将显示警告：

  • 为 SMTP 虚拟服务器实例启用了智能邮件筛选器。

  • 在全局设置级别启用了智能邮件筛选器。

该警告表示已有效启用了 Exchange Server 2003 Service Pack 2 (SP2) 版的智能邮件筛选器。除非解决了涉及此特定服务器的邮件流问题，否则启用 SP2 版的智能邮件筛选器通常不是问题。如果出现这种情况，则可能需要验证筛选器配置是否正确，或临时禁用智能邮件筛选器以确定它是否错误地阻止了合法邮件。

禁用智能邮件筛选器

  1. 单击"开始"，指向"所有程序"，指向"Microsoft Exchange"，再单击"系统管理器"。

  2. 在 Exchange 系统管理器中，依次展开"服务器"、"服务器名称"、"协议"和"SMTP"。

  3. 在"SMTP 虚拟服务器 属性"中的"常规"选项卡上，单击"高级"。

  4. 选择要为其禁用智能邮件筛选器的 IP 地址，然后单击"编辑"。

  5. 在"标识"中，清除"应用智能邮件筛选器"。

  6. 如果有多台虚拟服务器，请对每台要禁用智能邮件筛选器的虚拟服务器重复步骤 3 到 6。

有关详细信息，请参阅网站上的"Exchange Intelligent Message Filter"（英文）(http://go.microsoft.com/fwlink/?LinkId=21607)。


未使用指定的网关服务器
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-08-09

Microsoft® Exchange Server 分析工具将从 Exchange 服务器向用户定义的外部帐户发送一封测试邮件，然后扫描服务器的邮件跟踪日志，以确定是否发现了测试邮件的任何传递问题。

作为此扫描操作的一部分，Exchange Server 分析工具将检查以确定用于将邮件路由到外部收件人的 Exchange 网关服务器，是否与用户在执行"服务器名和凭据"步骤时，在"输入服务器和用户信息"页上指定的那个服务器相同。

如果 Exchange Server 分析工具确定邮件已成功地路由到 Exchange 组织以外，但是未使用指定的网关服务器，则 Exchange Server 分析工具将显示警告。

此警告指示 Exchange 路由拓扑可能出现问题，并且存在未知的出站网关服务器。

如果在虚拟服务器级别而不是在连接器级别设置了智能主机条目，则可能会发生路由问题。建议的最佳实践是在 SMTP 连接器上设置任何智能主机条目，而不在 SMTP 虚拟服务器上进行设置。

若要解决此警告中出现的故障，请执行下列步骤：

  • 复查简单邮件传输协议 (SMTP) 虚拟服务器的配置，确保未设置任何智能主机条目。

  • 复查本地桥头服务器的配置，确保连接器上的地址空间和成本适当。

查看和配置智能主机设置

  1. 打开 Exchange 系统管理器。

  2. 展开"服务器"，展开 Exchange 服务器，展开"协议"，再展开 SMTP。

  3. 用鼠标右键单击 SMTP 虚拟服务器（例如"默认 SMTP 虚拟服务器"），然后选择"属性"。

  4. 选择"传递"选项卡，然后单击"高级"。

  5. 清除"智能主机"下的任何条目。

  6. 单击"确定"以保存更改，然后单击"确定"关闭 SMTP 虚拟服务器的"属性"对话框。

有关如何配置 SMTP 连接器的详细信息，请参阅 Microsoft 知识库文章 822941"How to use SMTP connectors to connect routing groups in Exchange 2003"（如何在 Exchange 2003 中使用 SMTP 连接器来连接路由组）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822941)。

有关如何排除 SMTP 队列故障的详细信息，请参阅下列 Exchange 资源：

  • "Exchange Server 传输和路由指南"中的"排除邮件流和 SMTP 故障"(http://go.microsoft.com/fwlink/?LinkID=67875)。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)。


指定的发件人位于不同的服务器上
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-08-10

Microsoft® Exchange Server 分析工具将查询所有用户对象的 Active Directory® 目录服务 proxyAddress 属性值，以确定用户指定的本地发件人简单邮件传输协议 (SMTP) 地址是否存在匹配项。

如果找到用户对象的 proxyAddress 匹配项，则 Exchange Server 分析工具将查询 Active Directory 以获取该用户对象的 msExchHomeServerName 属性值，从而确定该值是否与用户指定的 Exchange Server 名称匹配。

如果 Exchange Server 分析工具确定用户指定的发件人的 msExchHomeServerName 属性值与用户指定的 Exchange Server 名称不匹配，则它会显示警告。

此警告指示，提供了错误的 Exchange Server 名称，或者邮件流问题将会影响除用户指定的服务器以外的服务器。

若要解决此问题，请验证是否输入了正确的 Exchange Server 名称。

在指定的服务器上查看用户邮箱

  1. 启动 Exchange 系统管理器：

    单击"开始"，指向"程序"，指向 Microsoft Exchange，然后单击"系统管理器"。

  2. 在"Exchange 系统管理器"中，导航到以下容器，然后单击此容器：

    \Administrative Groups\ GroupName \Servers\ ServerName \ StorageGroupName \Mailbox Store\Mailboxes

  3. 验证指定的 Exchange 服务器上是否显示了指定的用户邮箱。


无法识别目标服务器
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-07-06

Microsoft® Exchange Server 分析工具会尝试识别和生成远程服务器的完全限定的域名 (FQDN)、IP 地址和域名的列表，该远程服务器是远程传递队列中的邮件要发送到的服务器。

远程服务器的 FQDN、IP 地址和域名列表是按以下过程生成的：

  • 查询简单邮件传输协议 (SMTP) 虚拟服务器的 Active Directory® 目录服务对象的 msExchSmtpFullyQualifiedDomainName 属性。

    注意：
    针对指定的目标桥头服务器查询 msExchSmtpFullyQualifiedDomainName 属性时，又会从路由组连接器目录对象的 msExchTargetBridgeheadServersDN 属性中读取它。
  • 针对 SMTP 连接器的指定智能主机查询 SMTP 连接器 Active Directory 对象的 msExchSmtpSmartHost 属性。

  • 针对任何远程服务器直接连接查询 ExchangeLink Microsoft Windows® Management Instrumentation (WMI) 类的 LinkName 属性。

如果 Exchange Server 分析工具确定生成此列表的尝试未产生任何条目，则 Exchange Server 分析工具会显示一个错误。

此错误表明：

  • 可能存在导致邮件流问题的暂时性网络问题或 Active Directory 连接问题。

  • 运行 Exchange Server 分析工具的帐户可能没有足够的权限，无法查询信息。

纠正此错误

  1. 请确保已启动了 Exchange Server 计算机并已将其连接到网络。

  2. 验证是否具有到 Active Directory 域控制器的网络连接。

  3. 在 Exchange Server 分析工具中指定 Active Directory 域控制器。

  4. 使用 PING 命令来查看 Exchange Server 计算机是否可访问。

  5. 如果有防火墙，请检查是否阻止了 RPC 端口。

  6. 检查运行 Exchange Server 分析工具的帐户的权限。运行 Exchange Server 分析工具的帐户必须在其扫描的每台 Exchange Server 计算机上都具有本地管理员权限。

有关网络连接问题的详细信息，请参阅 Microsoft 知识库文章 325487"如何解决网络连接问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

有关 Exchange Server 分析工具连接问题的详细信息，请参阅"Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"（解决连接问题的 Microsoft Exchange Server 最佳实践分析工具）(http://go.microsoft.com/fwlink/?LinkId=56285)。

有关端口需求的详细信息，请参阅 Microsoft 知识库文章 832017"Windows 服务器系统的服务概述和网络端口要求"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)。


TarpitTime 已实现
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-02-21

Microsoft® Exchange Server 分析工具读取以下注册表项，以确定是否已设置收件人筛选的 tar pit 功能：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\TarpitTime

如果 Exchange Server 分析工具发现 TarpitTime 的值大于 0（零），则 Exchange Server 分析工具将显示非默认值消息。

Tar pitting 是一种有意减慢或延迟非法连接的行为，以便降低发送自动垃圾邮件或进行字典收集攻击的速率。

Microsoft Windows Server™ 2003 Service Pack 1 (SP1) 中提供的 tar pit 功能可以与收件人筛选一起使用，请参阅 Microsoft 知识库文章 842851"Microsoft Windows Server 2003 的 SMTP Tar Pit 功能"(http://support.microsoft.com/?kbid=842851)。尤其是在"全局设置"的"收件人筛选"选项卡上选中了"筛选不在目录中的收件人"复选框时，tar pit 功能扩展了收件人筛选的用途。

tar pit 功能通过设置 TarpitTime 注册表子项来实现。TarpitTime 注册表子项使用十进制值。十进制值转换为收件人不在目标 Exchange Server 组织时，SMTP 会话等待回复发件人的秒数。

tar pit 功能使发送未经请求的邮件的垃圾邮件制造者更难自动进行目录收集攻击。目录收集攻击试图从特定组织中检索已知良好的电子邮件地址列表。

在 SMTP 会话期间，SMTP 协议通过返回"2.1.5 Recipient OK"来确认可接受的收件人。如果邮件发送给未知收件人，则 SMTP 协议将返回"5.x.x"错误。因此，垃圾邮件制造者可以编写自动程序，使用常见的名称或字典术语来构造特定域的电子邮件地址。然后，程序可以收集所有返回"2.1.5 Recipient OK"的电子邮件地址，并丢弃所有导致"5.x.x"错误的电子邮件地址。垃圾邮件制造者可以销售这些"良好"的电子邮件地址，或使用这些电子邮件地址作为未经请求邮件的收件人。

如果选中了"筛选不在目录中的收件人"复选框，但 TarpitTime 注册表子项未设置，当收件人不在目标 Active Directory® 目录服务中时，Exchange Server 将在 SMTP 会话期间立即向发件人返回"5.x.x"错误。

另外，如果设置了 TarpitTime 注册表子项，并且选中了"筛选不在目录中的收件人"复选框，SMTP 在返回"5.x.x"错误之前将会等待。为 TarpitTime 注册表子项输入的十进制值是 SMTP 在返回错误之前将会等待的秒数。SMTP 会话的这一暂停使自动字典收集攻击更加困难。

如上所述，如果设置了 TarpitTime 注册表子项，则 Exchange Server 分析工具将显示非默认消息。本消息仅以提供信息为目的。

重要信息：
本文包含有关编辑注册表的信息。在编辑注册表之前，请确保了解当出现问题时如何还原注册表。有关如何还原注册表的信息，请参阅 Regedit.exe 或 Regedt32.exe 中的"还原注册表"帮助主题。
查看或更改 TarpitTime 注册表子项

  1. 单击"开始"，再单击"运行"，在"打开"框中键入 regedit，然后单击"确定"。

  2. 找到并单击以下注册表子项：

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SMTPSVC\Parameters\TarpitTime

  3. "数值数据"框包含十进制数字。此值代表希望对每个不在 Active Directory 中的地址延迟 SMTP 地址验证回复的时间。

  4. 如果更改该值或删除 TarpitTime 注册表子项，必须重新启动简单邮件传输协议 (SMTP) 服务。

有关详细信息，请参阅 Microsoft 知识库文章 842851"Microsoft Windows Server 2003 的 SMTP Tar Pit 功能"(http://support.microsoft.com/?kbid=842851)。


生成 NDR 的测试邮件
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具将测试邮件从 Exchange 服务器发送到简单邮件传输协议 (SMTP) 域的邮局主管帐户或用户定义的帐户，然后扫描服务器的邮件跟踪日志，以确定测试邮件传输是否存在问题。

作为扫描的一部分，Exchange Server 分析工具查询 root\MicrosoftExchangeV2 命名空间下的 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 类的 EntryType 属性，以确定创建邮件跟踪日志项的原因。

如果 Exchange Server 分析工具发现 EntryType 属性的值为 1030，则 Exchange Server 分析工具将显示警告。

该警告表明测试邮件已生成了一个未送达报告 (NDR)，且服务器的简单邮件传输协议 (SMTP) 配置可能存在问题。如果目标收件人不存在，则会生成 NDR，但是如果测试邮件是发送给合法收件人的，则表示出现了问题。

作为一项故障排除步骤，您可能需要尝试向同一个收件人发送其他邮件，然后查看 NDR 以确定原因。

有关如何解决 NDR 问题的详细信息，请参阅"Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"排除未送达报告邮件故障"。


发送到死信目录的测试邮件
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-05-17

Microsoft® Exchange Server 分析工具将测试邮件从 Exchange 服务器发送到简单邮件传输协议 (SMTP) 域的邮局主管帐户或用户定义的帐户，然后扫描服务器的邮件跟踪日志，以确定测试邮件传输是否存在问题。

作为此扫描的一部分，Exchange Server 分析工具查询 root\MicrosoftExchangeV2 命名空间下的 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 类的 EntryType 属性，以便确定产生该邮件跟踪日志项的原因。

如果 Exchange Server 分析工具发现 EntryType 属性的值为 1021，则 Exchange Server 分析工具将显示警告。

该警告表明已将测试邮件发送到 Exchange 服务器的死信目录，并且该服务器的简单邮件传输协议 (SMTP) 配置存在问题。

邮件可能会因以下某个原因而进入死信目录：

  • 无法传递。

  • 已经超出重试的最多次数。

  • 不能作为未送达邮件返回给发件人。

有关如何测试出站邮件流的详细信息，请参阅 Microsoft 知识库文章 297700"How to test outbound mail flow with a file in the Pickup folder"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297700)。

有关如何排除邮件流和 SMTP 故障的详细信息，请参阅"Exchange Server 传输和路由指南"(http://www.microsoft.com/technet/prodtechnol/exchange/zh-cn/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx?mfr=true) 中的"排除邮件流和 SMTP 故障"。


测试邮件滞留在 SMTP 队列中
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-07-06

Microsoft® Exchange Server 分析工具会从 Exchange 服务器将测试邮件发送到简单邮件传输协议 (SMTP) 域的邮局主管帐户或用户定义的帐户，然后扫描服务器的邮件跟踪日志以确定是否发现了测试邮件的传递问题。

作为此扫描的一部分，Exchange Server 分析工具会查询 root\MicrosoftExchangeV2 命名空间下 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 类的 EntryType 属性，以确定创建此邮件跟踪日志条目的原因。

下表列出了可能返回的 EntryType 值。

值名称 | 值
Message received through X400 | 0
Report received | 2
Message submitted | 4
Message transferred out | 7
Report transferred out | 8
Message delivered | 9
Report delivered | 10
Distribution list expanded | 26
Message redirected | 28
Message rerouted | 29
Server downgraded by MTA | 31
Report absorbed | 33
Report generated | 34
Unroutable report discarded | 43
Message deleted by Administrator | 50
Probe deleted by Administrator | 51
Report deleted by Administrator | 52
Message delivered locally | 1000
Message transferred in over backbone | 1001
Message transferred out over backbone | 1002
Message transferred out over gateway | 1003
Message transferred in over gateway | 1004
Report transferred in over gateway | 1005
Report transferred out over gateway | 1006
Report generated | 1007
SMTP:Message queued outbound | 1010
SMTP:Message transferred out | 1011
SMTP:Inbound message received | 1012
SMTP:Inbound message transferred | 1013
SMTP:Message rerouted | 1014
SMTP:Report transferred in | 1015
SMTP:Report transferred out | 1016
SMTP:Report generated | 1017
SMTP:Report absorbed | 1018
SMTP:Message submitted to Advanced Queuing | 1019
SMTP:Started outbound transfer of message | 1020
SMTP:Message sent to badmail directory | 1021
SMTP:Advanced Queue failure | 1022
SMTP:Message delivered locally | 1023
SMTP:Message submitted to Categorizer | 1024
SMTP:Started message submission to Advanced Queue | 1025
SMTP:Advanced Queue failed to deliver message | 1026
SMTP Store Driver:Message submitted from Store | 1027
SMTP Store Driver:Message delivered locally to Store | 1028
SMTP Store Driver:Message submitted to MTA | 1029
SMTP:Non-delivery report (NDR) generated | 1030
SMTP:Message transferred out | 1031

如果返回的 EntryType 值表明已满足下列条件，则 Exchange Server 分析工具将显示一个错误：

  • 可成功扫描测试邮件跟踪日志。

  • 测试邮件未成功地从队列中传出。

  • 未生成测试邮件的未送达报告 (NDR)。

  • 测试邮件未传送到死信目录。

  • 测试邮件未排入远程传递队列。

  • 测试邮件未成功传递到本地存储。

  • 未安排测试邮件重试进行分类。

  • 未安排测试邮件重试进行路由。

  • 未安排测试邮件重试进行本地传递。

此错误表明，测试邮件滞留在一个 SMTP 队列中，必须进行其他分析以确定其滞留在队列中的原因。

要解决此错误，请使用 NSlookup 实用程序来查看域名系统 (DNS) 解析可能存在的问题。对于连接和协议问题（如主机无法访问错误），请使用 Telnet.exe 尝试连接到目标计算机。要解决协议错误的问题，请为 SMTP 组件的 MSExchangeTransport 服务增加诊断日志记录，然后查看日志中的错误。另外，可以使用网络监视器 (Netmon.exe) 工具获取有关网络连接错误的信息。若要重现问题，可能必须强制队列进行重试操作。检查事件日志中与 Microsoft Exchange Information Store 服务相关联的可能存在的错误。

有关如何修改日志记录设置的详细信息，请参阅"Exchange Server 2003 传输和路由指南"的"排除邮件流和 SMTP 故障"部分中的"如何修改 MSExchangeTransport 的日志记录设置"(http://go.microsoft.com/fwlink/?LinkId=47579)。

有关如何排除 SMTP 队列故障的详细信息，请参阅以下 Exchange 资源：

  • "Exchange Server 2003 传输和路由指南"中的"排除邮件流和 SMTP 故障"(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)。

  • Microsoft 知识库文章 821877"Description of Fields on the SMTP and X.400 Queue Properties Tabs"（对 SMTP 和 X.400 队列"属性"选项卡上字段的描述）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)。

  • Microsoft 知识库文章 264054"XCON：了解 Exchange 2000 Server 中的队列状态"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


路由组中有超过 900 个连接器
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-01-17

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定出现在给定路由组中的连接器的数目，包括 SMTP 连接器、路由组连接器、X.400 连接器和 EDK 连接器。如果 Exchange Server 分析工具发现在任何单个路由组中连接器总数超过 900，则会显示警告。

建议任何单个 Exchange 对象类型的实例个数不超过 900 个。这是因为 Active Directory 在默认情况下使用 1,000 作为它对任何给定的请求所返回的最大页面大小。这意味着，如果发出对某个对象的轻型目录访问协议 (LDAP) 请求，并且 Active Directory 中存在该对象的 1,000 个以上的实例，则由于超过了最大页面大小而不会返回任何结果。

对于 Exchange Server 来说，各种进程都会请求对具体的对象类型进行实例化。例如，Exchange 系统管理器向 Active Directory 发出一个创建路由组中所有连接器的列表视图的 LDAP 请求。如果在任何单个路由组中有超过 1,000 个连接器，则 Active Directory 将不返回任何查询结果。发生这种情况时，将在 Exchange 系统管理器中显示错误。

尽管 Active Directory 的最大页面大小值可以增加，但建议不要这样做，或者 Exchange Server 不支持该操作。在增加了最大页面大小值的 Exchange 环境中，已经发现了反常行为和故障。

尽管我们建议在 Exchange Server 中任何单个对象类型不超过 900，但系统可支持最多 1,000 个对象类型。

解决此警告问题

  1. 考虑合并连接器或创建更多路由组，并在现有连接器中间实现负载平衡。

  2. 检查 Active Directory 中是否有孤立的连接器，并从 Active Directory 中将它们删除。

  3. 考虑合并组织中的 Exchange 服务器。

有关路由组设计和连接器的信息，请参阅"Exchange Server 2003 传输和路由指南"(http://www.microsoft.com/downloads/details.aspx?FamilyID=c092b7a7-9034-4401-949c-b29d47131622&DisplayLang=zh-cn)。

有关合并 Exchange 服务器的详细信息，请参阅"Server Consolidation Using Exchange Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=47586)。


Active Directory 与元数据库的完全限定域名设置存在差异
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2007-01-17

Microsoft® Exchange Server 分析工具读取 Internet 信息服务 (IIS) 元数据中的以下属性，以确定它的值是否与 Active Directory® 目录服务中 msExchSmtpFullyQualifiedDomainName 属性的配置值相匹配：

/LM/SmtpSvc/<SMTP virtual server instance>/FullyQualifiedDomainName

如果 Exchange Server 分析工具发现两个属性的值不匹配，则显示警告消息。

如果 IIS 元数据库中的值与 Active Directory 中的值不匹配，则可以说明 Active Directory 复制有问题，或者 Exchange 中的 Directory-service-to-Metabase-replication (DS2MB) 组件有问题。

DS2MB 进程的功能是将配置信息从 Active Directory 传输到本地元数据库。由于性能和可伸缩性原因，该配置存储在本地元数据库中，而没有存储在注册表中。在 Exchange 2000 Server 和 Exchange Server 2003 中，所有 Internet 协议（SMTP、NNTP、POP3、IMAP4 和 HTTP）都作为 IIS 的组件运行。

每过 15 分钟，DS2MB 进程就会在不更改子目录树形状的情况下，从 Active Directory 复制整个子目录树。这是从 Active Directory 到元数据库的单向写入；元数据库永远不会写入 Active Directory。

FullyQualifiedDomainName 属性和 msExchSmtpFullyQualifiedDomainName 属性使用与 Exchange 服务器的完全限定域名对应的默认服务器名称（例如，server.domain.com）。如果 FullyQualifiedDomainName 属性和 msExchSmtpFullyQualifiedDomainName 属性没有相同的完全限定域名值，则意味着 Active Directory 和 IIS 元数据库不同步。如果问题是由 DS2MB 进程失败所导致的，则可以针对您正在运行的 Exchange Server 版本执行下列过程，来纠正该问题。如果问题是由 Active Directory 复制发生了部分或全部失败所导致的，则可以使用 Active Directory 复制监视实用程序 (ReplMon.exe) 来检查 Active Directory 复制的运行状况和状态。可以在 Windows Server™ 2003 CD-ROM 上的 Microsoft Windows® 支持工具中找到 ReplMon.exe。

在 Exchange Server 2003 上更正此错误

  1. 检查是否出现了事件源为 MSExchangeMU 的应用程序事件日志条目。如果 DS2MB 失败，它将在 Exchange Server 2003 上记录一个事件。

  2. 如果没有看见任何 DS2MB 失败，请使用 ReplMon 诊断 Active Directory 复制。尤其要注意 SMTP 虚拟服务器所使用的全局编录服务器。

  3. 如果看见 DS2MB 失败，或者已经消除或解决了 Active Directory 复制的任何问题，请重新启动 Exchange 系统助理服务。

在 Exchange 2000 Server 上解决此警告问题

  1. 使用 ReplMon 诊断 Active Directory 复制。尤其要注意 SMTP 虚拟服务器所使用的全局编录服务器。

  2. 消除或解决 Active Directory 复制存在的任何问题之后，重新启动 Exchange 系统助理服务。

有关 Exchange 中的反向 DNS 查找功能的详细信息，请参阅 Microsoft 知识库文章 297412"The 'Perform Reverse DNS Lookup for Incoming Messages' Option Is for Host Name Resolution"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412)。

有关 SMTP 虚拟服务器设置的详细信息，请参阅知识库文章 266686"XCON：如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn) 和文章 268163"XCON:How to Configure a SMTP Virtual Server Part 2"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)。

有关 Active Directory 复制的详细信息，请参阅知识库文章 232072"Initiating Replication Between Active Directory Direct Replication Partners"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072)。

有关 DS2MB 进程的详细信息，请参阅知识库文章 240105"XGEN:General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105)。


Active Directory 与元数据库的最大跃点数设置有差异
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取 Internet 信息服务 (IIS) 元数据中的以下属性，以确定它的值是否与 Active Directory® 目录服务中 msExchSmtpMaxHopCount 属性的配置值相匹配：

/LM/SmtpSvc/<SMTP virtual server instance>/HopCount

如果 Exchange Server 分析工具发现上述两个值不匹配，则显示警告。

如果 IIS 元数据库中的值与 Active Directory 中的值不匹配，则可以说明 Active Directory 复制有问题，或者 Exchange 中的 Directory-service-to-Metabase-replication (DS2MB) 组件有问题。

DS2MB 进程的功能是将配置信息从 Active Directory 传输到本地元数据库。由于性能和可伸缩性原因，该配置存储在本地元数据库中，而没有存储在注册表中。在 Exchange 2000 Server 和 Exchange Server 2003 中，所有 Internet 协议（SMTP、NNTP、POP3、IMAP4 和 HTTP）都作为 IIS 的组件运行。

每过 15 分钟，DS2MB 进程就会在不更改子目录树形状的情况下，从 Active Directory 复制整个子目录树。这是从 Active Directory 到元数据库的单向写入；元数据库永远不会写入 Active Directory。

在 Exchange 2000 Server SMTP 虚拟服务器上，默认的跃点计数是 15。在 Exchange Server 2003 SMTP 虚拟服务器上，默认的跃点计数是 30。不管配置值是多少，如果 HopCount 属性和 msExchSmtpMaxHopCount 属性不匹配，则意味着 Active Directory 和 IIS 元数据库不同步。如果问题是由 DS2MB 进程失败所导致的，则可以针对您正在运行的 Exchange Server 版本执行下列过程，来纠正该问题。如果问题是由 Active Directory 复制发生了部分或全部失败所导致的，则可以使用 Active Directory 复制监视实用程序 (ReplMon.exe) 来检查 Active Directory 复制的运行状况和状态。可以在 Windows Server™ 2003 CD-ROM 上的 Microsoft Windows® 支持工具中找到 ReplMon.exe。

在 Exchange Server 2003 上更正此错误

  1. 检查是否出现了事件源为 MSExchangeMU 的应用程序事件日志条目。如果 DS2MB 失败，它将在 Exchange Server 2003 上记录一个事件。

  2. 如果没有看见任何 DS2MB 失败，请使用 ReplMon 诊断 Active Directory 复制。尤其要注意 SMTP 虚拟服务器所使用的全局编录服务器。

  3. 如果看见 DS2MB 失败，或者已经消除或解决了 Active Directory 复制的任何问题，请重新启动 Exchange System Attendant 服务。

在 Exchange 2000 Server 上更正此错误

  1. 使用 ReplMon 诊断 Active Directory 复制。尤其要注意 SMTP 虚拟服务器所使用的全局编录服务器。

  2. 消除或解决 Active Directory 复制存在的任何问题之后，重新启动 Exchange System Attendant 服务。

有关 Exchange 中的反向 DNS 查找功能的详细信息，请参阅 Microsoft 知识库文章 297412"The 'Perform Reverse DNS Lookup for Incoming Messages' Option Is for Host Name Resolution"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412)。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列知识库文章：

  • 266686"XCON:如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)

  • 268163"XCON:How to Configure a SMTP Virtual Server Part 2"（英文） (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

有关 Active Directory 复制的详细信息，请参阅知识库文章 232072"Initiating Replication Between Active Directory Direct Replication Partners"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072)。

有关 DS2MB 进程的详细信息，请参阅知识库文章 240105"XGEN:General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105)。


Active Directory 与元数据库的最大邮件大小设置有差异
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取 Internet 信息服务 (IIS) 元数据中的以下属性，以确定它的值是否与 Active Directory® 目录服务中 msExchSmtpMaxMessageSize 属性的配置值相匹配：

/LM/SmtpSvc/<SMTP virtual server instance>/MaxMessageSize

如果 Exchange Server 分析工具发现上述两个值不匹配，则显示警告消息。

如果 IIS 元数据库中的值与 Active Directory 中的值不匹配，则可以说明 Active Directory 复制有问题，或者 Exchange 中的 Directory-service-to-Metabase-replication (DS2MB) 组件有问题。

DS2MB 进程的功能是将配置信息从 Active Directory 传输到本地元数据库。由于性能和可伸缩性原因，该配置存储在本地元数据库中，而没有存储在注册表中。在 Exchange 2000 Server 和 Exchange Server 2003 中，所有 Internet 协议（SMTP、NNTP、POP3、IMAP4 和 HTTP）都作为 IIS 的组件运行。

每过 15 分钟，DS2MB 进程就会在不更改子目录树形状的情况下，从 Active Directory 复制整个子目录树。这是从 Active Directory 到元数据库的单向写入；元数据库永远不会写入 Active Directory。

MaxMessageSize 属性和 msExchSmtpMaxMessageSize 属性都使用默认设置 0，这意味着没有设定邮件大小限制。如果 MaxMessageSize 属性和 msExchSmtpMaxMessageSize 属性没有相同的值，则意味着 Active Directory 和 IIS 元数据库不同步。如果问题是由 DS2MB 进程失败所导致的，则可以针对您正在运行的 Exchange Server 版本执行下列过程，来纠正该问题。如果问题是由 Active Directory 复制发生了部分或全部失败所导致的，则可以使用 Active Directory 复制监视实用程序 (ReplMon.exe) 来检查 Active Directory 复制的运行状况和状态。可以在 Windows Server™ 2003 CD-ROM 上的 Microsoft Windows® 支持工具中找到 ReplMon.exe。

在 Exchange Server 2003 上更正此错误

  1. 检查是否出现了事件源为 MSExchangeMU 的应用程序事件日志条目。如果 DS2MB 失败，它将在 Exchange Server 2003 上记录一个事件。

  2. 如果没有看见任何 DS2MB 失败，请使用 ReplMon 诊断 Active Directory 复制。尤其要注意 SMTP 虚拟服务器所使用的全局编录服务器。

  3. 如果看见 DS2MB 失败，或者已经消除或解决了 Active Directory 复制的任何问题，请重新启动 Exchange System Attendant 服务。

在 Exchange 2000 Server 上更正此错误

  1. 使用 ReplMon 诊断 Active Directory 复制。尤其要注意 SMTP 虚拟服务器所使用的全局编录服务器。

  2. 消除或解决 Active Directory 复制存在的任何问题之后，重新启动 Exchange System Attendant 服务。

有关 Exchange 中的反向 DNS 查找功能的详细信息，请参阅 Microsoft 知识库文章 297412"The "Perform Reverse DNS Lookup for Incoming Messages" Option Is for Host Name Resolution"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412)。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列知识库文章：

  • 266686"XCON:如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)

  • 268163"XCON:How to Configure a SMTP Virtual Server Part 2"（英文） (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

有关 Active Directory 复制的详细信息，请参阅知识库文章 232072"Initiating Replication Between Active Directory Direct Replication Partners"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072)。

有关 DS2MB 进程的详细信息，请参阅知识库文章 240105"XGEN:General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105)。


Active Directory 与元数据库之间的最大会话大小设置不一致
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具读取 Internet 信息服务 (IIS) 元数据库中的 /LM/SmtpSvc/<SMTP virtual server instance>/MaxSessionSize 属性，以确定它的值是否与 Active Directory® 目录服务中 msExchSmtpMaxSessionSize 属性的配置值匹配。

如果 Exchange Server 分析工具发现值不匹配，则会显示警告消息。

如果 IIS 元数据库中的值与 Active Directory 中的值不匹配，则可以说明 Active Directory 复制有问题，或者 Exchange 中的 Directory-service-to-Metabase (DS2MB) 复制组件有问题。

DS2MB 进程的功能是将配置信息从 Active Directory 传输到本地元数据库。由于性能和可伸缩性原因，该配置存储在本地元数据库中，而不在注册表中。在 Exchange 2000 Server 和 Exchange Server 2003 中，所有 Internet 协议（SMTP、NNTP、POP3、IMAP4 和 HTTP）都作为 IIS 的组件运行。

每隔 15 分钟，DS2MB 进程就会在不更改子目录树形状的情况下，从 Active Directory 复制整个子目录树。这是从 Active Directory 到元数据库的单向写入；元数据库永远不会写入 Active Directory。

MaxSessionSize 属性和 msExchSmtpMaxSessionSize 属性都使用默认设置 0，这意味着没有设定会话大小限制。如果 MaxSessionSize 属性和 msExchSmtpMaxSessionSize 属性没有相同的值，则意味着 Active Directory 和 IIS 元数据库不同步。如果问题是由 DS2MB 进程失败所导致的，则可以针对您正在运行的 Exchange Server 版本执行下列过程，来纠正该问题。如果问题是由 Active Directory 复制发生了部分或全部失败所导致的，则可以使用 Active Directory 复制监视实用程序 (ReplMon.exe) 来检查 Active Directory 复制的运行状况和状态。可以在 Windows Server™ 2003 CD-ROM 上的 Microsoft Windows® 支持工具中找到 ReplMon。

在 Exchange Server 2003 上更正此错误

  1. 检查是否出现了事件源为 MSExchangeMU 的应用程序事件日志条目。如果 DS2MB 失败，它将在 Exchange Server 2003 上记录一个事件。

  2. 如果没有看见任何 DS2MB 失败，请使用 ReplMon 诊断 Active Directory 复制。尤其要注意 SMTP 虚拟服务器所使用的全局编录服务器。

  3. 如果看见 DS2MB 失败，或者已经消除或解决了 Active Directory 复制的所有问题，请重新启动 Exchange System Attendant 服务。

在 Exchange 2000 Server 上更正此错误

  1. 使用 ReplMon 诊断 Active Directory 复制。尤其要注意 SMTP 虚拟服务器所使用的全局编录服务器。

  2. 在已经消除或解决了 Active Directory 复制的所有问题之后，重新启动 Exchange System Attendant 服务。

有关 Exchange 中的反向 DNS 查找功能的详细信息，请参阅 Microsoft 知识库文章 297412"The "Perform Reverse DNS Lookup for Incoming Messages" Option Is for Host Name Resolution"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412)。

有关 SMTP 虚拟服务器设置的详细信息，请参阅下列知识库文章：

  • 266686"XCON:如何配置 SMTP 虚拟服务器（第 1 部分）"(http://support.microsoft.com/kb/266686/zh-cn)

  • 268163"XCON:How to Configure a SMTP Virtual Server Part 2"（英文） (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

有关 Active Directory 复制的详细信息，请参阅知识库文章 232072"Initiating Replication Between Active Directory Direct Replication Partners"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072)。

有关 DS2MB 进程的详细信息，请参阅知识库文章 240105"XGEN:General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105)。


在过去 24 小时内记录了传输连接管理器警告事件
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-07-07

Microsoft® Exchange Server 分析工具将查询 Win32_NTLogEvent Microsoft Windows® Management Instrumentation (WMI) 类以确定是否在过去 24 小时内记录了 MSExchangeTransport 事件 4006 警告。

如果 Exchange Server 分析工具发现在过去 24 小时内记录了 MSExchangeTransport 事件 4006 警告，则 Exchange Server 分析工具将显示警告。

此警告通常表明向远程服务器发送邮件的尝试已失败。

在下列情况发生时，会出现 MSExchangeTransport 事件 4006 警告：

  • 远程主机断开了连接。

  • 远程简单邮件传输协议 (SMTP) 服务拒绝 AUTH 协商。

  • 尝试传递邮件的服务器无法访问邮件中的邮件传递信息。

  • 发生了 SMTP 错误。

  • 尝试传递邮件的服务器无法连接到远程服务器。

  • 由于任何原因导致无法访问已在 SMTP 虚拟服务器的属性中指定的智能主机。

要获取 MSExchangeTransport 事件 4006 警告的详细信息，可以从"Events and Errors Message Center"（事件和错误消息中心）(http://go.microsoft.com/fwlink/?LinkId=34258) 查找事件详细信息。

有关 Exchange Server 中邮件中继问题的详细信息，请参阅 Microsoft 知识库文章 895853"如何解决 Exchange Server 2003 和 Exchange 2000 Server 中的邮件中继问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853)。

有关邮件流和 SMTP 问题的详细信息，请参阅"Exchange Server 和传输路由指南"(http://go.microsoft.com/fwlink/?LinkID=67875) 中的"排除邮件流和 SMTP 故障"。


在过去 24 小时内记录了传输连接管理器警告事件
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-07-07

Microsoft® Exchange Server 分析工具将查询 Win32_NTLogEvent Microsoft Windows® Management Instrumentation (WMI) 类以确定是否在过去 24 小时内记录了 MSExchangeTransport 事件 4001 警告。

如果 Exchange Server 分析工具发现在过去 24 小时内记录了 MSExchangeTransport 事件 4001 警告，则 Exchange Server 分析工具将显示警告。

此警告通常表明向远程服务器发送邮件的尝试已失败。

当 Exchange 2000 Server 或 Exchange Server 2003 上的简单邮件传输协议 (SMTP) 服务有一个或多个邮件传递问题时，就会发生 MSExchangeTransport 事件 4001 警告。产生邮件传递问题的可能原因包括域名系统 (DNS) 问题、IP 配置问题或安装了错误 DLL 文件的问题。

要获取事件 4001 警告的详细信息，可以从"Events and Errors Message Center"（事件和错误消息中心）(http://go.microsoft.com/fwlink/?LinkId=34258) 查找事件详细信息。

有关 Exchange Server 中邮件中继问题的详细信息，请参阅 Microsoft 知识库文章 895853"如何解决 Exchange Server 2003 和 Exchange 2000 Server 中的邮件中继问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853)。

有关邮件流和 SMTP 问题的详细信息，请参阅"Exchange Server 和传输路由指南"(http://go.microsoft.com/fwlink/?LinkID=67875) 中的"排除邮件流和 SMTP 故障"。


找不到传输事件接收器文件
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-01-10

Microsoft® Exchange Server 分析工具查询 Microsoft Internet 信息服务 (IIS) 元数据库，以枚举简单邮件传输协议 (SMTP) 传输事件接收器绑定列表。Exchange Server 分析工具尝试基于 Exchange Server 分析工具中预填充的列表来查找几个标准事件绑定。对于每个绑定，Exchange Server 分析工具验证注册表中下列分支下的组件对象模型 (COM) 注册详细信息：

HKEY_CLASSES_ROOT\CLSID\

COM 注册详细信息包含所关联 .dll 文件的完整路径。Exchange Server 分析工具使用 Microsoft Windows® Management Instrumentation (WMI) 查找 .dll 文件，并显示其版本号。如果 Exchange Server 分析工具找不到 .dll 文件，则 Exchange Server 分析工具将显示一条警告，并在其中详细的列出缺少 .dll 文件的文件名和路径。

如果 Exchange Server 分析工具发现缺少一个或多个标准事件绑定，则 Exchange Server 分析工具将生成警告。

邮件数据传输到 SMTP 服务或从中传出时将发生 SMTP 传输事件。所有邮件都通过事件进行传送。其中包括 X.400 和 RPC 传入或传出邮件。通常，传入传输事件是指邮件通过网络或 SMTP 拾取目录到达 SMTP 服务。此传输事件发生时，事件的源将通知传输事件接收器，每个事件接收器都可以基于邮件的数据内容采取某种类型的操作。系统将邮件数据传递到接收器后，就不再对邮件数据执行其他操作，直到接收器完成其操作并返回邮件为止。接收器在执行此操作时对邮件数据和状态拥有独占控制权。

传输事件接收器 COM 注册缺少 .dll 文件会导致邮件流问题。如果 Exchange Server 出现邮件流问题的症状（如邮件排队），则应验证标识的 .dll 文件是否存在，并根据需要重新安装。

解决此问题

  1. 使用资源管理器手动查找标识的 .dll 文件。一般情况下，此文件位于 \Program Files\Exchsrvr\Bin 文件夹中。

  2. 如果下列条件为真，则忽略 Exchange Server 分析工具生成的警告是安全的：

    • .dll 文件位于上面列出的文件夹中。

    • 服务器没有出现邮件流问题的症状。

  3. 如果下列条件为真，则从原始 Exchange Server 安装媒体中复制缺少的 .dll 文件：

    • Exchange Server 分析工具列出的文件夹中没有此 .dll 文件。

    • 服务器出现邮件流问题的症状。

    另外，还可以重新应用最新的 Exchange Service Pack。

  4. 重新运行 Exchange Server 分析工具以验证不再出现警告。


禁止链路状态信息的用户版本更改
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2005-11-18

Microsoft® Exchange Server 分析工具查询 Active Directory® 目录服务，以确定是否配置了 heuristics 属性，以禁止链路状态信息的用户版本更改。默认情况下不配置 heuristics 属性。如果 Exchange Server 分析工具发现 heuristics 属性已设置为 2048，则 Exchange Server 分析工具将显示非默认配置消息。

链路状态表用于确保有效可靠的邮件路由。链路状态表包含每个路由组的版本信息，其中包括主版本号、次版本号以及用户版本号。主版本更改具有最高的优先级，其次是次版本的更改，最后是用户版本号的更改。

如果存在基础级别的目录服务更新，则发生用户版本更改。当路由组主服务器发生了更改、在 Exchange 服务器上启动或停止了服务、将另一个服务器添加到了路由组中，或者当成员服务器断开了与路由组主服务器的连接时，所发生的更改都是最小更改。

如果 Exchange Server 管理员在路由组级别进行了某些更改，则可能发生基础级别的目录服务更新。例如，如果管理员更改路由组名称、添加服务器或删除服务器，则发生用户版本更改。但是，用户版本更改的主要原因是每个服务器中的 Microsoft Windows® Management Instrumentation (WMI) 数据。此数据表明正在运行的服务。如果停止和启动某项服务，链路状态表中的用户版本更改将复制到组织中的所有 Exchange Server 计算机上。

频繁的用户版本更新会产生不必要的大量网络通信。可以禁止频繁的用户版本更新，方法是先从 Microsoft 产品支持服务获取修补程序，然后将 heuristics 属性设置为 2048（十六进制为 0x800）。

如果用户版本更新不会产生过多的网络通信，建议您不要禁止用户版本更新。

还原到默认配置

  1. 打开 Active Directory 服务接口 (ADSI) Edit。

  2. 在 ADSI Edit 中，展开 Configuration Container，展开 CN=Configuration, DC=DomainName, DC=com，再展开 CN=Services，然后展开 CN=Microsoft Exchange。

  3. 用鼠标右键单击 CN=OrganizationName，再单击"Properties"。

  4. 在"Select a property to view"框中，单击"Heuristics"。

  5. 在"Edit Attribute"框中，清除值 0x800。

  6. 单击"Set"，再单击"OK"。

  7. 关闭 ADSI Edit。
警告：
在使用 ADSI Edit、LDP (ldp.exe) 工具或其他轻型目录访问协议 (LDAP) 版本 3 客户端时，如果 Active Directory 对象的属性修改不当，可能会造成严重问题。这些问题可能需要您重新安装 Microsoft Windows Server™ 2003 和/或 Exchange Server 2003。修改 Active Directory 对象的属性的风险由您自己承担。

有关链路状态和用户版本号的详细信息，请参阅"Exchange Server 2003 技术参考指南"中的"链路状态传播"(http://go.microsoft.com/fwlink/?LinkId=49367)。


标识为通用目标的用户
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-09-06

Microsoft® Exchange Server 分析工具查询 Exchange_Queue Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP) 虚拟服务器的 SMTP 队列的下列属性值。

LinkId | 表示包含该队列的链接的标识符。
QueueId | 表示该队列的标识符。
QueueName | 表示该队列的名称。
VirtualMachine | 表示包含该队列的虚拟计算机的名称。
VirtualServerName | 表示该队列所在的虚拟服务器的名称。
MessageCount | 表示该队列中的邮件数。

Exchange Server 分析工具使用获取的以上信息来查询 Exchange_QueuedSMTPMessage WMI 类，以确定该队列中邮件的下列属性值：

Recipients | 表示邮件的收件人。
Received | 表示邮件的接收时间戳。
MessageId | 表示队列中邮件的标识符。
StateRetry | 表示正在重新尝试传输未能成功传递的邮件。

最后，Exchange Server 分析工具使用上次查询中获取的数据，针对每个"收件人"对象的以下值查询 Active Directory® 目录服务，以确定该收件人是一位用户、一个通讯组、一个公用文件夹还是一个公用文件夹存储：

distinguishedName | 表示该对象的可分辨名称。
msExchHomeServerName | 表示收件人所驻留的服务器。
homeMDB | 表示收件人的邮箱存储。

如果 Exchange Server 分析工具确定队列中滞留的邮件中，至少有 25%（在"收件人"字段或"抄送"字段中）要发给特定用户，则 Exchange Server 分析工具会显示警告。

如果 Exchange Server 分析工具确定队列中滞留的邮件中，至少有 50%（在"收件人"字段或"抄送"字段中）要发给特定用户，则 Exchange Server 分析工具会显示错误。

此警告或错误意味着标识的用户是 SMTP 队列中滞留邮件的通用目标。

要解决此问题，应调查该用户以确定是否存在可能导致邮件排队的配置问题或其他问题。

调查的范围包括：

  • 确保该用户对象的属性设置正确，且 Active Directory 中的值正确无误。

  • 检查该用户对象的 Active Directory 权限设置是否正确。

  • 查找潜在的针对该用户的未经请求的商业垃圾邮件（UCE 或 SPAM）或病毒攻击。

  • 确定该用户是否属于未正确设置传递限制的通讯组。

  • 如果用户对象是特殊用途（例如，指定的日记收件人），请检查是否已正确配置用户对象相关联的服务或组件配置。

有关如何排除 SMTP 队列故障的详细信息，请参阅下列 Exchange 资源：

  • "Exchange Server Transport and Routing Guide"（Exchange Server 传输和路由指南）中的"Troubleshooting Mail Flow and SMTP"（排除邮件流和 SMTP 故障）(http://go.microsoft.com/fwlink/?LinkID=67875)。

  • Microsoft 知识库文章 823489"如何在 Exchange Server 2003 中使用队列查看器解决邮件流问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)。

有关通讯组限制对 Exchange Server 邮件流的影响的详细信息，请参阅下列 Microsoft 知识库文章：

  • 895407"在 Exchange Server 2003 中，配置基于通讯组的传递限制后，向本地邮箱和外部邮箱传递邮件的速度比预期速度要慢"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 329171"XADM：为收件人配置了基于组成员身份的传递限制后，邮件传递的速度将会减慢"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)。

  • 839949"排除 Exchange 2000 Server 和 Exchange Server 2003 中的邮件传输和通讯组问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。

  • 812298"配置基于通讯组列表的传递限制后，邮件传递的速度将会减慢"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。


未知的 SMTP 问题
Microsoft Exchange Server 分析工具 - 文章 > 传输 >

主题上次修改时间： 2006-10-06

Microsoft® Exchange Server 分析工具查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 类，以确定简单邮件传输协议 (SMTP) 服务的 Started 关键字值。值为 False 表明 SMTP 服务未运行。值为 True 表明服务正在运行。

Exchange Server 分析工具还要查询 Internet 信息服务 (IIS) 元数据库，以确定 SMTP 虚拟服务器实例的 ServerState 属性的值。

ServerState 属性可显示服务器实例的当前状态。状态代码和相应的状态如下所示：

状态代码 | 状态
1 | 正在启动
2 | 已启动
3 | 正在停止
4 | 已停止
5 | 正在暂停
6 | 已暂停
7 | 继续

如果下列条件为真，Exchange Server 分析工具将显示警告：

  • SMTP 服务正在运行。

  • 服务器上的所有 SMTP 虚拟服务器实例均已启动。

此警告表明尽管 SMTP 服务和 SMTP 虚拟服务器实例显示为运行正常，但是某个有待进一步调查的问题使 SMTP 端口无法正确响应。

此问题可能由以下原因所致：

  • SMTP 服务处于挂起状态。

  • 防火墙或防病毒应用程序阻止了 SMTP 端口的通信。

若要解决该问题，请执行下列操作：

  • 重新启动 SMTP 服务。

  • 查看所有防火墙或防病毒应用程序与 SMTP 端口相关的配置。

  • 查看 Exchange Server 分析工具提供的特定错误指南和链接。

启动、停止或暂停 SMTP 服务

  1. 单击"启动"，指向"管理工具"，然后单击"组件服务"。

  2. 在控制台树中，单击"服务(本地)"。

  3. 在结果窗格中，右键单击"简单邮件传输协议 (SMTP)"，然后单击"启动"、"停止"或"暂停"。


Exchange Server 2007 准备情况
Microsoft Exchange Server 分析工具 - 文章 >

主题上次修改时间： 2006-07-18

本部分中的文章提供了有关 Microsoft® Exchange Server 分析工具评估 Exchange Server 2007 准备情况哪些内容的详细信息。此外，这些文章还描述了为解决 Exchange Server 分析工具发现的与先决条件有关的错误、警告和非默认配置所能采取的措施。


已阻止访问控制列表 (ACL) 继承
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-06-19

因为所需的权限无法传播，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Exchange 安装程序要求对公用文件夹树对象启用权限继承。

若要解决此问题，请确保已启用"允许权限传播到此对象和子对象"设置，再重新运行 Exchange Server 2007 安装程序。

重新启用公用文件夹树继承

  1. 打开 Exchange Server 2003 系统管理器。

  2. 右键单击公用文件夹存储，再单击"属性"。

  3. 单击"安全性"选项卡，再单击选中"允许可继承的权限传播到此对象"复选框。


Active Directory 架构扩展要求安装 Ldifde.exe
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-06-19

因为本地计算机无法更新 Active Directory 架构，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Microsoft Exchange 安装程序要求在本地计算机上安装 Ldifde.exe，以对 Active Directory 架构进行必要的扩展。

若要解决此问题，请在本地计算机上安装 Ldifde.exe，再重新运行 Exchange Server 2007 安装程序或从域控制器启动 Exchange Server 2007 安装程序。

注意：
扩展 Active Directory 架构后，就可以在本地计算机上安装 Exchange 2007 服务器角色，而无须安装 ldifde.exe。
在本地计算机上安装 Ldifde.exe

  1. 单击"开始"、"运行"，然后在"打开"字段中运行 'ServerManagerCmd -i RSAT-ADDS'


存在 ADAM 安装路径
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-26

因为安装 Active Directory 应用程序模式 (ADAM) 的尝试失败，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

默认位置存在较早安装的 ADAM。Exchange 安装程序无法在现有的 ADAM 目录结构中安装新的 ADAM。

若要解决此问题，请删除现有的 ADAM 文件夹，再重新运行 Exchange 安装程序。


本地计算机上未安装 ADAM
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-22

因为未在此计算机上安装 Active Directory 应用程序模式 (ADAM)，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

ADAM 是一个轻型目录访问协议 (LDAP) 目录服务，为了能与启用目录的应用程序组合使用而进行了特殊设计。ADAM 仅存储和复制应用程序特定的信息，并且不要求在域控制台上进行部署，也不需要依赖 Active Directory 目录服务。ADAM 不提供网络操作系统身份验证或授权。

在 Exchange 2007 中，Exchange 传输服务器角色使用 ADAM 来存储配置信息。ADAM 与 Active Directory 实现同步后，也可以用来执行收件人查找以保证邮件安全。

Microsoft Exchange 安装程序要求先在本地计算机上安装 ADAM 服务，它才能继续进行。

若要解决此问题，请从"Active Directory Application Mode (ADAM)"（Active Directory 应用程序模式 (ADAM)）(http://go.microsoft.com/fwlink/?linkid=71063) 安装 ADAM Service Pack 1 (SP1)，再重新运行安装程序。


本地计算机 (Longhorn) 上未安装 ADAM
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-08-13

因为未在此基于 Windows Server 2008 的计算机上安装 Active Directory 应用程序模式 (ADAM)，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

ADAM 是一个轻型目录访问协议 (LDAP) 目录服务，为了能与启用目录的应用程序组合使用而进行了特殊设计。ADAM 仅存储和复制应用程序特定的信息，并且不要求在域控制台上进行部署，也不需要依赖 Active Directory 目录服务。ADAM 不提供网络操作系统身份验证或授权。

在 Exchange 2007 中，Exchange 传输服务器角色使用 ADAM 来存储配置信息。ADAM 与 Active Directory 实现同步后，也可以用来执行收件人查找以保证邮件安全。

Microsoft Exchange 安装程序要求先在本地计算机上安装 ADAM 服务，它才能继续进行。

若要解决该问题，请在运行 Windows Server 2008 操作系统的本地计算机上安装 ADAM，然后再运行安装程序。

将 ADAM 安装到 Windows Server 2008 操作系统

  1. 单击"开始"，选择"运行"，再输入以下命令：

  2. cmd.exe /c start /w pkgmgr.exe /iu:"DirectoryServices-ADAM"

  3. 再次运行 Exchange 2007 安装程序。


分析工具搜索警告
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-08-09

本主题旨在解决由 Exchange Server 分析工具发现的特定问题。应只将此主题应用到已对其运行 Exchange Server 分析工具并且正面临该特定问题的系统中。

通过可以免费下载的 Exchange Server 分析工具，远程收集拓扑中每台服务器的配置数据并自动分析数据。结果报告详述了重要的配置问题、潜在问题以及一些非默认产品设置。通过遵守这些建议，可以获得更佳的性能、可伸缩性、可靠性及正常运行时间。

有关此工具或下载最新版本的详细信息，请参阅 http://go.microsoft.com/fwlink/?linkid=34707 上的"Microsoft Exchange 分析工具"。


32 位兼容性警告
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-08-13

Microsoft Exchange Server 2007 安装程序会在安装 32 位版本的 Microsoft Exchange 时显示此警告。

Exchange 2007 具有以下两种平台版本：在真正生产环境中使用的平台版本（64 位版本）和在非生产环境（如实验室、培训设施、演示和评估环境）中使用的平台版本（32 位版本）。无法在生产中运行 32 位 Exchange 2007 服务器，因此只能购买 64 位版本。

因为 Microsoft 对在生产环境中使用 32 位版本提供最低限度的支持，因此 32 位平台的生产和非生产使用存在两个例外。具体说来：

  • 可以在生产中使用 32 位版本的 Exchange 管理工具，从 Windows Server 2003 或 Windows XP 管理 Exchange 2007 服务器。此时，在 Windows Vista 上或 Windows Server 2008 上使用 32 位版本或 64 位版本。对 Windows Vista 和 Windows Server 2008 的支持预计在 Exchange 2007 Service Pack 1 中提供。

  • 可以在生产中使用 32 位版本的安装程序，以扩展 Active Directory 目录服务架构。有关为 Exchange 2007 准备 Active Directory 的详细步骤，请参阅"How to Prepare Active Directory and Domains"（如何准备 Active Directory 和域）。

生产环境中 32 位版本 Exchange 2007 的任何其他使用情况均不受支持。

若要下载 32 位版本的 Exchange 管理工具，请参阅"Microsoft Exchange Server 2007 Management Tools (32-Bit)"（Microsoft Exchange Server 2007 管理工具（32 位））(http://go.microsoft.com/fwlink/?LinkId=82335)。有关 Exchange 2007 平台版本的详细信息，请参阅 Exchange 2007 产品文档中的"Exchange Server 2007:Platforms, Editions, and Versions"（Exchange Server 2007：平台、版次和版本）(http://go.microsoft.com/fwlink/?LinkId=88051)。


需要安装 Microsoft Windows 操作系统的 2007 时区更新
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-02-20

需要安装更新以纠正此计算机的时区信息设置，因此 Microsoft Exchange Server 2007 安装程序无法继续。

Exchange 2007 安装程序要求安装 Microsoft 知识库文章 931836 中提到的 Windows 操作系统的时区更新。

若要解决此问题，请安装 Microsoft 知识库文章 931836"Microsoft Windows 操作系统的 2007 年 2 月累积时区更新"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=931836) 中提到的更新，然后重新运行 Exchange 2007 安装程序。


Active Directory 不存在或无法联系
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-04-18

因为无法联系有效的 Active Directory 目录服务站点，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Microsoft Exchange 安装程序要求用于安装 Microsoft Exchange 的服务器必须能够找到 Active Directory 中的配置命名上下文。

要解决此问题，请验证运行 Microsoft Exchange 安装程序的用户帐户是否已登录到 Active Directory，然后重新运行安装程序。如果这没有解决问题，请按照下面主题中使用 NETDIAG.Exe 和 DCDIAG.Exe 支持工具的指导进一步诊断问题。

有关 Microsoft Exchange 的 Active Directory 疑难解答和配置的详细信息，请参阅下列资源：

  • Windows Server 2003:Operations（Windows Server 2003：操作）中的"Troubleshooting Active Directory Operations"（解决 Active Directory 操作问题）(http://go.microsoft.com/fwlink/?LinkId=68099)。

  • Active Directory Operations Guide 中的"Tools for Troubleshooting Active Directory"（英文)(http://go.microsoft.com/fwlink/?LinkId=68100)。

  • "Working with Active Directory Permissions in Exchange Server"(http://go.microsoft.com/fwlink/?LinkId=47592) 中的"Configuration Naming Context"（英文）。

  • "Working with Active Directory Permissions in Exchange Server"（英文）(http://go.microsoft.com/fwlink/?LinkId=47592)。

  • "Netdiag Overview"（Netdiag 概述）(http://go.microsoft.com/fwlink/?LinkID=69481)。

  • "Dcdiag Overview"（Dcdiag 概述）(http://go.microsoft.com/fwlink/?LinkID=68936)。


Active Directory 域处于混合模式
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-08-10

由于现有的 Active Directory 域未设置为 Microsoft Windows® 2000 Server 纯模式或更佳模式，因此 Microsoft® Exchange Server 2007 安装程序无法继续。

Exchange 2007 安装程序将创建通用安全组，这些组只能在使用 Windows 2000 Server 纯模式或更佳模式的域中存在。

若要解决此问题，请遵循下列步骤，至少将域功能级别提升到 Windows 2000 Server 纯模式级别，然后重新运行 Exchange 2007 安装程序。

提升域功能级别

  1. 打开"Active Directory 域和信任"。

  2. 在控制台树中，用鼠标右键单击要提升其功能的域，然后单击"提升域功能级别"。

  3. 在"选择可用的域功能级别"中，使用下列步骤之一：

    • 若要将域功能级别提升到 Windows 2000 Server 纯模式，请单击"Windows 2000 纯模式"，然后单击"提升"。

    • 若要将域功能级别提升到 Windows Server® 2003，请单击"Windows Server 2003"，然后单击"提升"。
警告：

如果已拥有或将会拥有任何运行 Windows NT® 4.0 和更早版本的域控制器，请不要将域功能级别提升到 Windows 2000 Server 纯模式。将域功能级别设置为 Windows 2000 Server 纯模式后，无法将其更改回到 Windows 2000 Server 混合模式。

如果已拥有或将会拥有任何运行 Windows NT 4.0 和更早版本或运行 Windows 2000 Server 的域控制器，请不要将域功能级别提升到 Windows Server 2003。将域功能级别设置为 Windows Server 2003 后，无法将其更改回到 Windows 2000 Server 混合模式或 Windows 2000 Server 纯模式。


需要准备 Active Directory
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-26

因为尝试的域准备失败，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Exchange 安装程序要求在准备 Active Directory 中的域之前修改 Exchange Server 2007 的 Active Directory 目录服务。

若要解决此问题，请使用 Setup /PrepareAD 命令准备 Active Directory，再准备各个域。

有关如何执行 PrepareAD 进程的详细信息，请参阅"How to Prepare Active Directory and Domains"（如何准备 Active Directory 和域）(http://go.microsoft.com/fwlink/?LinkId=78453)。


ADAM 端口已被占用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-06

因为在尝试安装网关服务器角色时检测到为 Active Directory® 应用程序模式 (ADAM) 同步分配的端口已被占用，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

ADAM 是一个轻型目录访问协议 (LDAP) 目录服务，为了能与启用目录的应用程序组合使用而进行了特殊设计。ADAM 仅存储和复制应用程序特定的信息，并且不要求在域控制台上进行部署，也不需要依赖 Active Directory 服务。ADAM 不提供网络操作系统身份验证或授权。

在 Exchange 2007 中，网关服务器使用 ADAM 来存储配置信息。ADAM 与 Active Directory 目录服务实现同步后，也可以用来执行收件人查找以保证邮件安全。

Microsoft Exchange 安装程序要求特定端口必须是可用的（未被占用），这样在安装网关服务器角色时便可将其分配给 ADAM 同步进程。

要解决此问题，请识别并停止已经占用 ADAM 所需端口的进程，或者使用命令行开关来运行 Exchange 2007 安装程序，以覆盖默认的 ADAM 端口分配。

运行安装程序以覆盖默认的 ADAM 端口分配

  1. 在命令提示符下，键入以下命令：

    Setup.exe /adamport:xxxx /adamsslport:yyyy

    • /adamport:<分配给 ADAM 的端口号>

    • /adamsslport:<分配给 ADAM 的端口号>


应用程序公用文件夹层次结构已存在
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-05

Microsoft® Exchange Server 分析工具会在 Active Directory® 目录服务域中搜索应用程序公用文件夹层次结构。当 Exchange Server 分析工具发现非 MAPI 公用文件夹树时，Exchange Server 分析工具将显示一个警告。该警告表明，非 MAPI 公用文件夹树存在于 Exchange 组织中。Exchange Server 2007 不支持这些自定义应用程序树。

非 MAPI 公用文件夹树用于自定义的应用程序开发。这些树出现在 Microsoft Exchange 2000 Server 和 Microsoft Exchange Server 2003 中，但是 Exchange 2007 不支持这些树。建议在部署 Exchange 2007 之前，执行下列操作之一：

  • 将非 MAPI 公用文件夹树移至 SharePoint Portal Server。

  • 维护 Exchange 2003 服务器上的数据。

有关其他公用文件夹层次结构的详细信息，请参阅"Selecting the Appropriate Client for Exchange Public Folder Access"（选择合适的客户端以用于 Exchange 公用文件夹访问）(http:// go.microsoft.com/fwlink/?LinkId =46439)。


无法确定 Active Directory 站点的名称
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-06

因为该服务器似乎不属于一个有效的 Active Directory® 目录服务站点，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

Microsoft Exchange 安装程序要求用于安装 Exchange 2007 的服务器必须属于一个有效的 Active Directory 站点。

要解决此问题，请验证本地服务器是否是有效的 Active Directory 站点的成员，并重新运行 Exchange Server 2007 安装程序。

可以使用 Nltest.exe 命令行工具的 /DsGetSite 选项来验证并显示站点的成员身份。有关详细信息，请参阅"Windows Server 2003 Technical Reference"(http://go.microsoft.com/fwlink/?LinkId=27734) 的"Tools and Settings Collection"中的"Nltest.exe: NLTest Overview"（英文）。

有关 Active Directory 疑难解答的详细信息，请参阅"Windows Server 2003: Operations"中的"Troubleshooting Active Directory Operations"（英文）(http://go.microsoft.com/fwlink/?linkid=68099)。


无法找到收件人更新服务
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-05-16

因为无法找到在现有 Exchange 组织中负责域的收件人更新服务 (RUS)，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

Microsoft Exchange 安装程序要求现有 Exchange 组织中的每个域都有一个收件人更新服务实例。

如果某个域丢失了收件人更新服务实例，则在域中创建的新用户对象将不会收到发送给它们的电子邮件地址。

要解决此问题，请验证每个域是否存在收件人更新服务实例，并为没有的域创建一个收件人更新服务实例，然后重新运行 Microsoft Exchange 安装程序。

为域创建收件人更新服务实例

  1. 打开 Exchange 系统管理器。

  2. 展开"收件人"。

  3. 用鼠标右键单击"收件人更新服务"节点，单击"新建"，然后单击"收件人更新服务"。

  4. 在"新建对象"窗口中，单击"浏览"查找该域的名称。

  5. 选中该域的名称，然后单击"确定"。

  6. 在"新建对象"窗口中，单击"下一步"，然后单击"完成"。

有关收件人更新服务的详细信息，请参阅下列 Microsoft 知识库文章：

  • "How the Recipient Update Service applies recipient policies"（英文)(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)。

  • "How the Recipient Update Service Populates Address Lists"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)。

  • "How to check the progress of the Exchange Recipient Update Service"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)。

  • "Tasks performed by the Exchange Recipient Update Service"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)。


无法删除邮箱数据库
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-06-20

因为卸载邮箱服务器角色进程无法在不丢失数据的情况下，从本地服务器删除用户邮箱数据库（存储），所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

在删除邮箱服务器角色之前，Exchange 2007 安装程序将检查是否从服务器删除所有邮箱存储。但是，用户邮箱可能仍然保留在该服务器上。

若要解决此问题，请移动或禁用该服务器上所有用户邮箱并重新运行 Exchange 2007 安装程序。

有关标识数据库中邮箱的详细信息，请参阅 Exchange Server 2007 产品文档中的"Get-Mailbox"cmdlet (http://go.microsoft.com/fwlink/?LinkId=93470)。

有关禁用邮箱的详细信息，请参阅 Exchange Server 2007 产品文档中的"How to Disable a Mailbox"（如何禁用邮箱）(http://go.microsoft.com/fwlink/?LinkId=93471)。

有关如何在 Exchange Server 2007 中删除邮箱数据库的详细信息，请参阅 Exchange Server 2007 产品文档中的"How to Remove a Mailbox Database"（如何删除邮箱数据库）(http://go.microsoft.com/fwlink/?LinkId=93473)。

有关如何管理用户邮箱数据库存储或副本的详细信息，请参阅"Administration Guide for Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=47617) 中的"Managing Mailbox Stores and Public Folder Stores"（英文）。


无法删除公用文件夹数据库
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-01-23

因为卸载邮箱服务器角色进程无法在不丢失数据的情况下，从本地服务器删除公用文件夹数据库，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求在删除邮箱服务器角色之前，应从服务器删除公用文件夹数据库。

公用文件夹副本可能仍保留在服务器上，或者该公用文件夹数据库可能是 Exchange 组织中的最后一个数据库。

若要解决此问题，请移动或删除服务器上的公用文件夹数据库，并重新运行 Exchange Server 2007 安装程序。

有关在 Exchange Server 2007 中删除公用文件夹数据库的详细信息，请参阅 Exchange Server 2007 产品文档中的"How to Remove a Public Folder Database"（如何删除公用文件夹数据库）(http://go.microsoft.com/fwlink/?LinkId=81409)。

有关如何管理公用文件夹数据库存储或副本的详细信息，请参阅"Administration Guide for Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=47617) 中的"Managing Mailbox Stores and Public Folder Stores"（英文）。


无法删除统一消息服务器角色
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-26

Microsoft Exchange Server 2007 安装程序因其卸载统一消息服务器角色的尝试失败而无法继续进行。

Exchange 2007 安装程序将检查以确定要卸载的统一消息服务器角色是否承载着拨号计划的提示语发布点，以及该拨号计划是否已链接其他服务器。

如果统一消息服务器角色承载着拨号计划的提示语发布点，则卸载过程将失败。

若要解决此问题，请将提示语发布点移动到其他服务器，再重新运行 Exchange 2007 安装程序。

有关移动拨号计划的提示语发布点的详细信息，请参阅"How to Change the Prompt Publishing Point"（如果更改提示语发布点）(http://go.microsoft.com/fwlink/?LinkId=82356)。


无法写入 CMS 数据路径
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-26

因为将群集邮箱服务器角色安装到共享群集驱动器的尝试失败，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Exchange 安装程序无法写入为 /CMSDataPath 参数提交的目标安装路径。Exchange 安装程序要求群集邮箱服务器数据的目标路径是可写入的卷。

若要解决此问题，请指定位于可写入的存储介媒体上的 /CMSDataPath 的目标路径。

有关安装群集邮箱服务器的详细信息，请参阅 Exchange Server 2007 产品文档中的"How to Install the Mailbox Server Role on the Active Node"（如何在主动节点上安装邮箱服务器角色）(http://go.microsoft.com/fwlink/?LinkId=86624)。


无法写入 Exchange 组织容器
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-05-04

因为已登录的用户没有写入 Active Directory 目录服务中组织容器的帐户权限，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Microsoft Exchange 安装程序要求在安装 Exchange 2007 时登录的用户拥有企业管理员凭据或 Exchange 组织管理凭据。

作为安装过程的一部分，Exchange 2007 安装程序可能必须在 Microsoft Exchange 组织容器中创建对象。

若要解决此问题，请向已登录的用户授予企业管理员权限或 Exchange 组织管理员权限，或者使用具有这些权限的帐户登录并重新运行 Exchange 2007 安装程序。

重要信息：
不支持跨林安装 Exchange 2007。使用要在其中安装 Exchange 2007 的 Active Directory 林的成员帐户。

有关 Microsoft Exchange 所需的 Active Directory 权限的详细信息，请参阅"Working with Active Directory Permissions in Exchange Server"（在 Exchange Server 中使用 Active Directory 权限）(http://go.microsoft.com/fwlink/?LinkId=47592)。


未在本地站点中检测到客户端访问角色
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-06

如果没有在本地 Active Directory® 目录服务站点中检测到现有客户端访问角色，Microsoft® Exchange Server 2007 安装程序就会显示此警告。

在 Active Directory 站点安装客户端访问角色实例以前，应已选择安装邮箱服务器角色。

客户端访问服务器角色接受从多种不同客户端连接到 Exchange 2007 服务器。软件客户端（如 Miscrosoft Outlook Express 和 Eudora）使用 POP3 或 IMAP4 连接与 Exchange 服务器进行通信。硬件客户端（如移动设备）使用 ActiveSync、POP3 或 IMAP4 与 Exchange 服务器进行通信。

如果用户使用 Microsoft Office Outlook® 以外的任何客户端访问其收件箱，则您必须在您的 Exchange 组织中安装客户端访问服务器角色。

虽然用户可以使用 Outlook 登录其邮箱，但是在客户端访问角色存在于本地 Active Directory 站点中之前，用户不能对同一邮箱使用 Outlook Web Access 或移动设备。


需要移动群集托管资源或使其脱机
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-04-09

因为安装新的主动群集邮箱服务器角色的尝试失败，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Exchange Server 2007 要求群集托管资源在运行安装程序的群集节点上处于非活动状态。

若要解决此问题，请将此节点所拥有的所有群集托管资源（包括非 Exchange Server 群集资源）移动到群集中的其他节点。或者，使它们脱机，再重新运行安装程序。

有关如何移动与 Exchange 相关的群集托管服务的详细信息，请参阅 Exchange Server 2007 产品文档中的"Move-ClusteredMailboxServer"(http://go.microsoft.com/fwlink/?LinkId=86627) cmdlet 主题。

有关如何使与 Exchange 相关的群集托管服务脱机的详细信息，请参阅 Exchange Server 2007 产品文档中的"Stop-ClusteredMailboxServer"(http://go.microsoft.com/fwlink/?LinkId=86635) cmdlet 主题。

有关管理非 Exchange 群集资源的详细信息，请参阅 Windows Server 2003 产品帮助中的"Manage Resources"（管理资源）(http://go.microsoft.com/fwlink/?LinkId=86637)。


未启动群集服务
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-26

因为未启动 Microsoft Windows Server 群集服务，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

如果本地计算机上安装了群集服务，则 Exchange 2007 安装程序要求启动此群集服务。

若要解决此问题，请在本地计算机上启动群集服务，再重新运行 Exchange 安装程序。

若要启动群集服务，请参阅 Windows Server 2003 技术库中的"Start the Cluster service"（启动群集服务）(http://go.microsoft.com/fwlink/?LinkId=86638)。


需要群集更新 (KB921181)
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-08-11

由于需要更新群集节点，Microsoft® Exchange Server 2007 安装程序无法继续。

Exchange 2007 安装程序要求安装 Microsoft 知识库文章 921181 中所提到的群集节点更新。

若要解决此问题，请安装 Microsoft 知识库文章 921181"An update is available that adds a file share witness feature and a configurable cluster heartbeats feature to Windows Server 2003 Service Pack 1-based server clusters"（现已提供一项更新，用来向基于 Windows Server 2003 Service Pack 1 的服务器群集添加文件共享见证功能和可配置的群集检测信号功能）(http://go.microsoft.com/fwlink/?LinkId=69785) 中提到的更新，然后重新运行 Exchange 2007 安装程序。


CMS 数据路径必须是 NTFS 卷
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-26

因为将群集邮箱服务器角色安装到共享群集驱动器的尝试失败，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

为 /CMSDataPath 参数提交的目标安装路径不是 NTFS 卷。Exchange 安装程序要求群集邮箱服务器数据的目标路径是 NTFS 卷。

若要解决此问题，请为 /CMSDataPath 选择其他目标路径，或者将目标卷转换为 NTFS，再重新运行 Exchange 2007 安装程序。

有关将卷转换为 NTFS 的详细信息，请参阅 Windows XP Professional 产品文档中的"Convert"（转换）(http://go.microsoft.com/fwlink/?LinkId=86642) 主题。


当前群集节点拥有群集管理服务
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-04-09

Microsoft Exchange Server 2007 安装程序因其卸载群集被动节点的尝试失败而无法继续进行。

Exchange 群集管理服务由此群集节点拥有。Exchange 2007 安装程序要求先从此节点删除 Exchange 群集管理服务，才能删除 Exchange 文件。

若要解决此问题，请将此节点所拥有的所有群集托管资源（包括非 Exchange Server 群集资源）移动到群集中的其他节点，或者使它们脱机，再重新运行安装程序。

有关如何移动与 Exchange 相关的群集托管服务的详细信息，请参阅 Exchange Server 2007 产品文档中的"Move-ClusteredMailboxServer"(http://go.microsoft.com/fwlink/?LinkId=86627) cmdlet 主题。

有关如何使与 Exchange 相关的群集托管服务脱机的详细信息，请参阅 Exchange Server 2007 产品文档中的"Stop-ClusteredMailboxServer"(http://go.microsoft.com/fwlink/?LinkId=86635) cmdlet 主题。

有关管理非 Exchange 群集资源的详细信息，请参阅 Windows Server 2003 产品帮助中的"Manage Resources"（管理资源）(http://go.microsoft.com/fwlink/?LinkId=86637)。


必须先启动 COM+ Event System 服务，安装程序才能继续进行
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-16

因目标计算机上未启动 COM+ Event System 服务致使安装客户端访问服务器角色或边缘传输服务器角色的尝试失败，进而导致 Microsoft Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求在即将安装 Microsoft Exchange 的计算机上将 COM+ Event System 服务的状态设置为"已启动"。

COM+ Event System 服务支持 COM+ 组件的系统事件通知，从而使事件能够自动分发到订阅的 COM 组件。

客户端访问服务器角色和边缘传输服务器角色都依赖于订阅 COM+ Event System 服务的 COM+ 组件。

若要解决此问题，请验证在本地计算机上 COM+ Event System 服务的状态是否设置为"已启动"，再重新运行 Microsoft Exchange 安装程序。

将 COM+ Event System 服务的状态设置为"已启动"

  1. 右键单击"我的电脑"，再单击"管理"。

  2. 展开"服务和应用程序"节点，再单击"服务"节点。

  3. 在右侧窗格中，找到 Com+ Event System。

  4. 右键单击 Com+ Event System，再单击"属性"。

  5. 将"启动类型"设置为"自动"，并将"服务状态"设置为"已启动"。

  6. 单击"应用"，再单击"确定"。


检测到复杂 Exchange 组织模型
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-08-10

Microsoft® Exchange Server 分析工具将查询 Active Directory® 目录服务，以确定 Exchange Server 组织中的路由组数。Exchange Server 分析工具还将查询 Active Directory 以确定包含运行 Microsoft Exchange 2000 Server 或 Microsoft Exchange Server 2003 的 Exchange 服务器的 Active Directory 站点的数目。

如果下列条件为真，Exchange Server 分析工具会将 Exchange 组织分类为复杂 Exchange 组织：

  • 存在多个 Active Directory 林。

  • Microsoft Identity Integration Server (MIIS) 安装在一个或多个林中。

在 Microsoft Exchange Server 2007 四个定义的组织模型中，复杂 Exchange 组织是唯一包含多个 Active Directory 林或使用同步技术的模型。

将复杂 Exchange 组织转换到 Exchange 2007

  1. 请访问 Exchange 2007 产品联机文档 (http://go.microsoft.com/fwlink/?LinkId=69434)。

  2. 查看"规划复杂 Exchange 组织"主题 (http://go.microsoft.com/fwlink/?LinkId=70505)。


无法在本地计算机上找到"默认网站"
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-06

因为无法访问此服务器上的默认网站，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求安装客户端访问角色时必须能够访问由 Microsoft Internet 信息服务 (IIS) 创建的默认网站。

客户端访问服务器角色可提供客户端访问功能，例如 Microsoft Office Outlook®（通过 HTTP 连接时）、Outlook Web Access、Exchange ActiveSync® 和使用 POP3 或 IMAP4 协议的客户端。

IIS 可充当 HTTP、POP3、IMAP4、简单邮件传输协议 (SMTP) 和网络新闻传输协议 (NNTP) 协议的协议引擎。

可能会发生 IIS 默认网站不再存在的情况。此网站可能已删除或重命名为不同于默认网站的其他网站。

要解决此问题，请先删除 IIS，然后在该服务器上重新安装此服务，之后再重新运行 Exchange 2007 安装程序。

重要信息：
要解决此问题，必须先卸载然后重新安装 IIS。重新创建或重命名目录是不够的。
使用控制面板中的"添加/删除 Windows 组件"来卸载 IIS

  1. 在"开始"菜单中，单击"控制面板"。

  2. 双击"添加或删除程序"。

  3. 单击"添加/删除 Windows 组件"。

  4. 在"组件"列表中单击"应用程序服务器"复选框。

  5. 单击"详细信息"。

  6. 单击"Internet 信息服务管理器"。

  7. 单击"下一步"。

  8. 完成 IIS 的卸载后，单击"完成"。
使用控制面板安装 IIS

  1. 在"开始"菜单中，单击"控制面板"。

  2. 双击"添加或删除程序"。

  3. 单击"添加/删除 Windows 组件"。

  4. 在"组件"列表中单击"应用程序服务器"复选框。

  5. 单击"详细信息"。

  6. 单击"Internet 信息服务管理器"复选框。

  7. 单击"确定"直到返回"Windows 组件向导"。

  8. 单击"下一步"并完成 Windows 组件向导。


必须先启动分布式事务处理协调器服务，安装程序才能继续进行
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-16

因目标计算机上未启动分布式事务处理协调器服务致使安装客户端访问服务器角色或统一消息服务器角色的尝试失败，进而导致 Microsoft Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求在即将安装 Microsoft Exchange 的计算机上将分布式事务处理协调器服务的状态设置为"已启动"。

分布式事务处理协调器服务所提供的服务旨在确保事务的成功和完整，即使在出现系统故障、进程故障和通信故障的情况下也是如此。

参与分布式事务的每台计算机管理它自己的资源和数据，同时还与事务中的其他计算机协同工作。最重要的是，分布式事务必须在所有参与计算机上提交或中止其整个工作。分布式事务处理协调器充当所牵涉的组件的事务协调角色，并充当管理事务的每台计算机的事务管理器。

客户端访问服务器和统一消息服务器角色都依赖于分布式事务处理协调器服务。

若要解决此问题，请验证在本地计算机上分布式事务处理协调器服务的状态是否设置为"已启动"，再重新运行 Microsoft Exchange 安装程序。

将分布式事务处理协调器服务的状态设置为"已启动"

  1. 右键单击"我的电脑"，再单击"管理"。

  2. 展开"服务和应用程序"节点，再单击"服务"节点。

  3. 在右侧窗格中，找到"分布式事务处理协调器"。

  4. 右键单击"分布式事务处理协调器"，再单击"属性"。

  5. 将"启动类型"设置为"自动"，并将"服务状态"设置为"已启动"。

  6. 单击"应用"，再单击"确定"。


未在本地计算机上设置 DNS 后缀
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-05

因为没有设置本地计算机的完全限定域名 (FQDN)，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求本地计算机必须具有一个有效的域名系统 (DNS) 后缀集。

若要解决此问题，请为本地计算机设置 DNS 后缀，然后重新启动计算机，并重新运行 Exchange 2007 安装程序。

设置本地计算机的主 DNS 后缀

  1. 用鼠标右键单击"我的电脑"，然后单击"属性"。将出现"系统属性"对话框。

  2. 单击"计算机名"选项卡。

  3. 单击"更改"。将出现"计算机名称更改"对话框。

  4. 单击"其他"。将出现"DNS 后缀和 NetBIOS 计算机名"对话框。

  5. 为域输入相应的 DNS 后缀。

  6. 选中"在域成员身份变化时，更改主 DNS 后缀"复选框。

  7. 单击"确定"保存更改，再单击"确定"退出"计算机名称更改"对话框。

  8. 单击"确定"关闭"系统属性"对话框，然后重新启动计算机，以使更改生效。

有关 DNS 名称的详细信息，请参阅 Microsoft 知识库文章 909264"命名计算机、域、站点和 OU 的 ActiveDirectory 中约定"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=909264)。


在注册表中设置了域控制器覆盖
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-27

Microsoft Exchange Server 2007 安装程序因其使用指定域控制器的尝试失败而无法继续进行。在注册表中已静态映射域控制器。

Exchange 2007 安装程序要求在 setup 命令中指定的域控制器与使用注册表覆盖静态映射的域控制器匹配。

若要解决此问题，请再次运行安装程序，为 /DomainController:<静态映射的域控制器的 FQDN> 参数指定静态映射的域控制器。

有关 DSAccess 和目录服务检测的详细信息，请参阅 Microsoft 知识库文章 250570"目录服务服务器检测和 DSAccess 用法"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)。


必须进行域准备
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-27

因为安装服务器角色的尝试失败，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Microsoft Exchange 安装程序要求在安装某些服务器角色之前为 Exchange Server 2007 准备本地域。

为 Exchange Server 2007 准备域包括下列任务：

  • 为 Exchange Servers、Exchange Organization Administrators、Authenticated Users 和 Exchange Mailbox Administrators 设置对 Domain 容器权限。

  • 创建 Microsoft Exchange System Objects 容器（如果它不存在），并为 Exchange Servers、Exchange Organization Administrators 和 Authenticated Users 设置对此容器的权限。

  • 在当前域中新建一个名为 Exchange Install Domain Servers 的域全局组。

  • 将 Exchange Install Domain Servers 组添加到根域中的 Exchange Servers USG。

若要解决此问题，请运行 setup /PrepareDomain 以准备本地域并重新安装服务器角色。

有关如何执行 PrepareDomain 进程的详细信息，请参阅"How to Prepare Active Directory and Domains"（如何准备 Active Directory 和域）(http://go.microsoft.com/fwlink/?LinkId=78453)。


无法在本地计算机中安装边缘传输角色
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-01-03

由于在尝试安装边缘服务器角色时发现该服务器上已安装了其他 Microsoft Exchange 角色，因此 Microsoft® Exchange Server 2007 安装程序无法继续进行安装。

Exchange 2007 安装程序不能在安装了其他 Miscorsoft Exchange 角色的服务器上安装边缘服务器角色。

Microsoft Exchange 边缘服务器角色部署在组织的外围网络中，用于处理所有面向 Internet 的邮件流。它可以加密和解密在受信任的 Microsoft Exchange 组织之间发送的邮件，并且还具有防垃圾邮件功能。

若要解决该问题，请在没有安装其他 Microsoft Exchange 角色的计算机上安装边缘服务器角色。


在拓扑中发现 EDK 连接器
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-04

Microsoft® Exchange Server 分析工具将检查 Exchange 组织的 Active Directory® 目录服务中是否存在 Exchange 开发工具包 (EDK) 连接器。如果在 Active Directory 中发现 EDK 连接器，则 Exchange Server 分析工具将显示一个警告。该警告表明，Microsoft Exchange Server 2007 不支持 EDK 连接器。

建议您与第三方供应商联系，以获取适用于 Exchange 2007 的替代连接器产品。或者，您可以保留 Exchange 2003 或 Microsoft Exchange 2000 Server 以支持 EDK 连接器。

注意：
EDK 连接器是为连接到通信系统（如传真机、短消息服务 (SMS)、电报）或为连接到使用网关连接器的其他邮件系统（如 Lotus Notes）而建立的第三方应用程序。非 Microsoft 供应商可以使用 Exchange 开发工具包 (EDK) 来开发专用连接器。


Esm.dll 正在由一个或多个进程使用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-28

Microsoft Exchange Server 2007 安装程序因其尝试升级服务器时遇到模块访问问题而无法继续进行。

Exchange 2007 安装程序要求某些模块没有在运行，以便升级时可以修改二进制文件。Esm.dll 文件正是一个这样的模块。

若要解决此问题，请卸载已打开 Esm.dll 的进程，再重新运行 Exchange 2007 安装程序。

停止已打开 Esm.dll 的进程

  1. 启动 Exchange 命令行管理程序

  2. 使用 Get-Process cmdlet 查找 Exchange 分析工具已识别的进程的进程 ID。

  3. Get-Process < 进程名称 >

  4. 使用 Stop-Process cmdlet 停止进程。

  5. Stop-Process < 进程 ID >

  6. 其中 <process ID> 是在此处步骤 2 中从 Get-Process cmdlet 返回的进程 ID 值。

有关 Get-Process cmdlet 的详细信息，请参阅"What Can I Do With Windows PowerShell?"（使用 Windows PowerShell 可以执行哪些操作？）主题中的 Using the Get-Process Cmdlet。


"ExchHelp.chm"已打开
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-16

Microsoft Exchange Server 2007 安装程序因其尝试升级服务器时遇到文件访问问题而无法继续进行。

Exchange 2007 安装程序要求关闭某些文件，以便升级进程可以修改文件或访问这些文件的进程。本地 Exchange 帮助 (ExchHelp.chm) 文件就是一个这样的文件。

若要解决此问题，请关闭 ExchHelp.chm 文件，再重新运行 Exchange 2007 安装程序。


Exchange 2000 Server 计算机要求升级到 SP3
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-27

因为现有组织中的一个或多个服务器运行的是没有 Service Pack 3 或更高版本的 Exchange 2000 Server，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求组织中的所有现有 Exchange 2000 Server 计算机运行 Exchange 2000 Server Service Pack 3 (SP3)。

若要解决此问题，请将组织中的所有现有 Exchange 2000 Server 计算机升级到 Exchange 2000 Server SP3 或更高版本，再重新运行 Exchange 2007 安装程序。

有关将 Exchange 2000 Server 计算机升级到 Exchange 2000 Server SP3 或更高版本的详细信息，请参阅"Downloads for Exchange 2000 Server"（Exchange 2000 Server 下载）(http://go.microsoft.com/fwlink/?LinkId=86647)。


Exchange 组织处于混合模式
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-05

Microsoft® Exchange Server 分析工具会查询 Exchange 组织容器以确定 Exchange 组织的模式。Exchange Server 分析工具将检查 msExchangeMixedMode 属性的值。如果 msExchangeMixedMode 属性的值为 True，则 Exchange Server 分析工具将显示一个错误。该错误消息表明，此 Exchange 组织正在混合模式下运行。Microsoft Exchange Server 2007 只能安装在处于纯模式下的组织中。因此，要准备部署 Exchange 2007，必须将运行在混合模式下的组织切换到纯模式。

注意：
运行在纯模式下的组织只能包含 Exchange 2000 服务器或更高版本。

要准备部署 Exchange 2007，必须通过以下这些步骤将 Exchange 组织转换到纯模式：

  1. 删除任何剩余的 Exchange 5.5 服务器或使其退役。

  2. 在 Exchange 系统管理器中，打开 Exchange 组织对象的属性，然后切换到纯模式。

有关如何将 Exchange 组织转换为纯模式的详细信息，请参阅"Exchange Server 2003 部署指南"中的"How to Convert from Mixed Mode to Native Mode in Exchange"（如何在 Exchange 中从混合模式转换到纯模式）(http://go.microsoft.com/fwlink/?LinkId=56642)。

有关 Microsoft Exchange 的混合模式和纯模式的详细信息，请参阅下列 Microsoft 知识库文章：

  • 270143"对 Exchange 2000 Server 和 Exchange Server 2003 中混合模式和纯模式的描述"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270143)。

  • 327779"如何在 Exchange 2000 Server 中从混合模式转换到纯模式"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779)。

  • 272314："XADM：准备将混合模式组织切换到本机模式"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=272314)。


Exchange Server 2003 计算机要求升级到 SP2
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-27

因为现有组织中的一个或多个服务器运行的是没有 Service Pack 2（或更高版本）的 Exchange Server 2003，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求组织中的所有现有 Exchange Server 2003 计算机运行 Exchange Server 2003 Service Pack 2 (SP2) 或更高版本。

若要解决此问题，请将组织中的所有现有 Exchange Server 2003 计算机升级到 Exchange Server 2003 SP2 或更高版本，再重新运行 Exchange 2007 安装程序。

有关将 Exchange Server 2003 计算机升级到 Exchange Server 2003 SP2 或更高版本的详细信息，请参阅"Downloads for Exchange Server 2003"（Exchange Server 2003 下载）(http://go.microsoft.com/fwlink/?LinkId=21030)。


Exchange Server 2007 无法与此 Windows 版本一起使用
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-27

因为本地计算机未运行 Exchange Server 2007 支持的 Microsoft Windows Server 操作系统版本，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求本地计算机上的 Windows Server 版本支持运行 Exchange Server 2007，正如 Exchange Server 2007 系统要求所规定的那样。

若要解决此问题，请在本地计算机上安装支持 Exchange Server 2007 的 Windows Server 操作系统版本，或者在运行受支持 Windows Server 版本的计算机上安装 Exchange Server 2007。

有关 Exchange Server 2007 系统要求的详细信息，请参阅"Exchange Server 2007 System Requirements"（Exchange Server 2007 系统要求）(http://go.microsoft.com/fwlink/?LinkId=86651)。


未配置文件共享证据
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-23

因为尚未为群集连续复制 (CCR) 群集配置文件共享证据，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

若要在多数节点集 (MNS) 仲裁群集中证实任一节点出现故障，必须具有至少三个可视为可用的设备。通过文件共享证据功能，可以将外部文件共享用作证据。在两节点 MNS 仲裁群集中，此证据充当第三个可用设备。

Exchange 2007 安装程序要求配置文件共享证据功能，才能在 CCR 环境中安装群集邮箱服务器角色。

若要解决此问题，请按照"How to Configure the File Share Witness"（如何配置文件共享证据）(http://go.microsoft.com/fwlink/?LinkId=78278) 中所述步骤创建文件共享证据的文件共享并保证文件共享的安全。然后设置 MNSFileShare 值，将群集组移动两次，然后重试 Microsoft Exchange 安装程序。


无法委派首要角色安装
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-06

因为登录用户不具有安装拓扑结构中任何首要服务器角色时所需的帐户权限，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

虽然 Microsoft Exchange 安装程序允许使用委派来安装后续的服务器角色，但在安装拓扑结构中的任何首要 Exchange 2007 服务器角色时，安装程序仍要求登录用户拥有 Exchange 组织管理凭据。

作为任何服务器首要角色安装的一部分，Exchange 2007 安装程序可能需要在 Exchange 组织容器中创建对象。

要解决此问题，请为登录用户授予 Exchange 组织管理员权限，或使用拥有这些权限的帐户登录，并重新运行 Exchange 2007 安装程序。


必须禁用 Forefront Security for Exchange Server 服务
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-06-20

因为 Microsoft Forefront Security for Exchange Server 服务正在本地计算机上运行，所以 Microsoft Exchange Server 2007 安装程序无法继续进行 Exchange Server 2007 升级。

Exchange 安装程序要求禁用 Forefront Security for Exchange Server 服务后，才能继续进行 Exchange Server 2007 升级。

若要解决这一问题，请禁用 Forefront Security for Exchange Server 服务，然后再重新运行 Exchange Server 升级。

有关安装 Service Pack 或将软件更新至运行 Forefront Security 的 Exchange Server 的详细信息，请参阅 Microsoft 知识库文章 929080。


需要 Forefront Security for Exchange Server 升级
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

适用于： Exchange Server 2007, Exchange Server 2007 SP1
主题上次修改时间： 2007-08-08

因为 Exchange Server 2007 Service Pack 1 (SP1) 不支持本地计算机正在运行的 Microsoft Forefront Security for Exchange Server 版本，所以 Microsoft Exchange Server 2007 安装程序无法继续进行 Exchange 2007 升级。

Exchange 安装程序要求升级该版本的 Microsoft Forefront Security for Exchange Server 并禁用其服务后，才能继续升级 Exchange Server 2007。

若要解决这一问题，请将 Microsoft Forefront Security V10.0 for Exchange Server 升级至 Microsoft Forefront Security for Exchange Server SP1，然后禁用 Microsoft Forefront Security for Exchange Server 服务后，再继续 Exchange Server 的升级。

详细信息

有关安装 Service Pack 或将软件更新至运行 Forefront Security 的 Exchange Server 的详细信息，请参阅 Microsoft 知识库文章 929080"如何在运行 Forefront Security 的 Exchange Server 计算机上安装 Service Pack 或软件更新程序"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=929080)。


计算机的完全限定域名与收件人策略相匹配
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-05-16

因为本地计算机的完全限定域名 (FQDN) 与收件人策略的简单邮件传输协议 (SMTP) 地址相匹配，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

Microsoft Exchange 安装程序要求 Exchange 组织中服务器的 FQDN 不能与同一 Exchange 组织中收件人策略的任何 SMTP 地址相匹配。

如果计算机的 FQDN 与收件人策略的 SMTP 地址相匹配，则会导致邮件无法通过 SMTP 并滞留在 MTA 队列中。

要解决此问题，请重命名本地计算机，或者删除或重命名收件人策略，然后重新运行 Microsoft Exchange 安装程序。

重命名本地计算机

  1. 打开"控制面板"中的"系统"。

  2. 在"计算机名称"选项卡上，单击"更改"。

  3. 在"计算机名称"下，键入新的计算机名称，然后单击"确定"。此时会提示您提供用户名和用户密码以便重命名此域中的计算机。

  4. 单击"确定"以关闭"系统属性"对话框。此时会提示您重新启动计算机以应用所做修改。
重要信息：
如果要重命名的计算机是域控制器，请参阅"Rename a domain controller"（英文）(http://go.microsoft.com/fwlink/?LinkId=66828)。
修改收件人策略的 SMTP 地址

  1. 启动 Exchange 系统管理器。

  2. 单击"组织"，再单击"收件人"，然后单击"收件人策略"。

  3. 双击要更改的策略。

  4. 单击"电子邮件地址"选项卡，然后更改相应的 SMTP 地址。

有关收件人策略命名问题的详细信息，请参阅 Microsoft 知识库文章 288175"XCON：收件人策略不能与组织中任何服务器的 FQDN 匹配并导致 5.4.8 NDR"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=288175)。


本地站点中不存在全局编录服务器
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-06

因为尝试安装 Microsoft Exchange 的站点中没有全局编录服务器，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

Microsoft Exchange 安装程序要求运行安装程序的计算机的 Active Directory® 目录服务站点必须包含充当全局编录的服务器。

要解决此问题，请采取下列步骤之一：

  • 使站点中的现有域控制器成为全局编录服务器。

  • 安装一台使用全局编录服务器角色的新服务器。

使现有域控制器成为全局编录服务器

  1. 打开"Active Directory 站点和服务"。

  2. 展开"站点"，再展开相应 站点，然后展开"服务器"。

  3. 选择要指定为全局编录服务器的域控制器。

  4. 在右侧窗格中，用鼠标右键单击"NTDS 设置"，再选择"属性"。

  5. 在"常规"选项卡上，选中"全局编录"复选框。更改可以动态生效，不必重新启动服务器。
  • 有关如何创建全局编录服务器的详细信息，请参阅 Microsoft 知识库文章 313994"HOW TO：在 Windows 2000 中创建或移动全局编录"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=313994)。

  • 有关与 Exchange Server 相关的全局编录服务器的位置和可用性的详细信息，请参阅 Microsoft 知识库文章 875427"Global catalog server placement and ratios in an Exchange 2000 Server organization or in an Exchange Server 2003 organization"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=875427)。


需要全局更新
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-09-19

Microsoft® Exchange Server 2007 安装程序无法继续，因为登录的用户没有所需的帐户权限，无法对 Active Directory® 目录服务进行全局更新。

Microsoft Exchange 安装程序要求在安装 Exchange 2007 时登录的用户具有企业管理员的管理凭据。

作为安装过程的一部分，Exchange 2007 可能需要执行下列操作：

  • 创建或修改 Active Directory 目录服务中的 Exchange 组织对象

  • 为 Exchange 2007 准备好 Active Directory 林中的所有域。

  • 为 Exchange 2007 准备好现有的 Exchange 2000 Server 域和 Exchange Server 2003 域。

若要解决此问题，请向登录的用户授予企业管理员权限，或使用拥有这些权限的帐户登录并重新运行 Exchange 2007 安装程序。

有关 Exchange 所需 Active Directory 权限的详细信息，请参阅"Working with Active Directory Permissions in Exchange Server"（在 Exchange Server 中使用 Active Directory 权限）(http://go.microsoft.com/fwlink/?LinkId=47592)。


在 DNS 数据库中找不到本地计算机的主机记录
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-05

因为在域名系统 (DNS) 数据库中找不到此计算机的主机 (A) 记录，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求本地计算机具有已在该域的权威 DNS 数据库中进行了注册的有效主机 (A) 记录。

Microsoft Exchange 依靠其下一个内部或外部目标服务器的 IP 地址的 DNS 主机 (A) 记录。

若要解决该问题，请执行下列操作：

  • 验证本地 TCP/IP 配置是否指向正确的 DNS 服务器。

    验证本地 TCP/IP 配置

    1. 检查本地 TCP/IP 配置。有关详细信息，请参阅"Configure TCP/IP to use DNS"（英文）(http://go.microsoft.com/fwlink/?LinkId=68094)。
  • 使用 Nslookup.exe 验证 DNS 服务器上是否存在主机 (A) 记录。有关详细信息，请参阅"To verify A resource records exist in DNS"（英文）(http://go.microsoft.com/fwlink/?LinkId=63001)。

有关 DNS 名称解析、疑难解答和主机 (A) 记录的信息，请参阅以下资源：

  • Microsoft 知识库文章 322856"HOW TO：配置 DNS 以用于 Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)。

  • "Troubleshooting DNS"（英文）(http://go.microsoft.com/fwlink/?LinkId=63003)。

  • "Managing resource records"（英文）(http://go.microsoft.com/fwlink/?LinkId=63004)。


未在本地站点中检测到集线器传输角色
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-06

如果没有在本地 Active Directory® 目录服务站点中检测到现有集线器传输服务器角色，Microsoft® Exchange Server 2007 安装程序就会显示此警告。

在 Active Directory 站点安装集线器传输角色实例以前，应已经选择了安装邮箱服务器角色。

Exchange 2007 集线器传输服务将显示在组织的 Active Directory 中。集线器传输服务处理组织内的所有邮件流，应用组织邮件流路由规则，并负责将邮件传递到收件人的邮箱。

用户可以登录到其邮箱，但是在安装集线器传输角色以前，该邮箱服务器无法发送或接收邮件。


Hub Transport Server Not Present in Active Directory Site
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-07-25

Microsoft Exchange 分析工具查询 Active Directory 目录服务，以确定 Exchange 组织中任何包含 Exchange Server 2007 特定管理组标识符 FYDIBOHF23SPDLT 的 msExchAdminGroupContainer 类对象的值。

如果 Exchange 分析工具确定 Exchange 组织中有 Exchange Server 2007 管理组，Exchange 分析工具将查询组织中的所有 Active Directory 站点，以确定每个 msExchExchangeServer 对象的 msExchCurrentServerRoles 属性的值，从而判定发现的任何站点中是否安装了邮箱服务器角色。

最后，如果 Exchange 分析工具判定某个站点中安装了邮箱服务器角色，Exchange 分析工具将查询该站点中每个 msExchExchangeServer 对象的 msExchCurrentServerRoles 属性，以确定该站点中是否也安装了集线器传输服务器角色。

如果 Exchange 分析工具确定某个 Active Directory 站点中安装了邮箱服务器角色，但是没有安装任何集线器传输服务器角色，那么 Exchange 分析工具将显示错误消息。

该错误表明，尽管该 Active Directory 网站中安装了邮箱服务器角色，但即使邮箱都在同一个服务器上，也只有在该网站中至少安装一个集线器传输服务器角色后，邮件才能在邮箱间转移。

集线器传输服务器角色部署在组织的 Active Directory 目录服务中。它会处理组织内的所有邮件流，应用组织邮件策略，并负责将邮件传递到收件人邮箱。集线器传输服务器提供以下功能：

邮件流 集线器传输服务器会处理所有发送到 Exchange 2007 组织中的邮件之后，才将其传递到组织中收件人的收件箱或路由到组织外的用户。该行为没有例外情况。

分类 分类程序可对通过 Exchange 2007 传输管道移动的所有邮件执行收件人解析、路由解析以及内容转换。

路由 集线器传输服务器角色可确定组织中所发送和接收的所有邮件的路由路径。

传递 邮件由存储驱动程序传递到收件人的邮箱。存储驱动程序会从发件人的发件箱中选取由组织中的用户发送的邮件，并将这些邮件放置到集线器传输服务器的"提交"队列中。

若要解决此错误，请在已安装邮箱服务器角色的网站中安装集线器传输服务器角色。

详细信息

有关如何在网站中部署集线器传输服务器角色的详细信息，请参阅 Exchange Server 2007 产品文档中的"部署服务器角色"(http://go.microsoft.com/fwlink/?LinkId=83282)。


未安装 IIS 6 兼容组件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-08-13

因为未安装 Internet 信息服务 (IIS) 6 元数据库兼容组件和 IIS 6 管理控制台组件，所以 Microsoft Exchange Server 2007 安装程序无法继续在基于 Windows Server 2008 的目标计算机上安装客户端访问服务器角色、邮箱服务器角色或 Exchange 2007 管理工具。

Exchange 2007 安装程序要求基于 Windows Server 2008 的计算机（该计算机正在安装 Exchange 2007 客户端访问服务器角色、邮箱服务器角色或 Exchange 2007 管理工具）上安装有 IIS 6 元数据库兼容组件和 IIS 6 管理控制台组件。

若要解决此问题，请将 IIS 6 元数据库兼容组件安装到目标计算机，然后重新运行 Microsoft Exchange 安装程序。

使用 Windows Server 2008 服务器管理器安装 IIS 6.0 管理兼容组件

  1. 依次单击"开始"、"管理工具"和"服务器管理器"。

  2. 在左侧导航窗格中，展开"角色"，再右键单击"Web 服务器 (IIS)"并选择"添加角色服务"。

  3. 在"选择角色服务"窗格上，向下滚动到"IIS 6 管理兼容性"。

  4. 选中"IIS 6 元数据库兼容性"和"IIS 6 管理控制台"所对应的复选框。

  5. 单击"选择角色服务"窗格中的"下一步"，再单击"确认安装选择"窗格中的"安装"。

  6. 单击"关闭"退出"添加角色服务"向导。


IIS 7 组件未安装
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-08-09

因为所需的 Internet Information Server (IIS) 7 组件未安装，所以 Microsoft Exchange Server 2007 安装程序无法继续在基于 Microsoft Windows Server 2008 的系统上安装客户端访问服务器角色。

Exchange 2007 安装程序要求即将安装客户端访问服务器角色的基于 Windows Server 2008 的计算机上安装有下列 IIS 7 组件，才能够安装客户端访问服务器角色。

所需的 IIS 7 组件

动态内容压缩

静态内容压缩

基本身份验证

Windows 身份验证

若要解决此问题，请将所需的 IIS 7 组件安装到目标计算机，然后重新运行 Microsoft Exchange 安装程序。

使用 Windows Server 2008 服务器管理器安装 IIS 7 组件

  1. 依次单击"开始"、"管理工具"和"服务器管理器"。

  2. 在左侧导航窗格中，展开"角色"，再右键单击"Web 服务器 (IIS)"并选择"添加角色服务"。

  3. 在"选择角色服务"窗格上，向下滚动到 IIS。

  4. 选中"安全性"下的"基本身份验证"和"Windows 身份验证"复选框。

  5. 选中"性能"下的"静态压缩"和"动态压缩"复选框。

  6. 单击"选择角色服务"窗格中的"下一步"，再单击"确认安装选择"窗格中的"安装"。

  7. 单击"关闭"退出"添加角色服务"向导。


需要 IIS 公用文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-08-14

由于此服务器上未安装 Microsoft Internet 信息服务 (IIS) 公用文件，因此 Microsoft® Exchange Server 2007 安装程序无法继续。

Microsoft Exchange 命令行管理程序可能需要远程 IIS 元数据库访问权限。元数据库是大多数 IIS 配置值的库。对元数据库进行远程访问需要在本地计算机上安装相应的 COM+ DLL。

若要解决此问题，请在此服务器上安装 IIS 公用文件，然后重新运行 Exchange 2007 安装程序。

使用 Windows Server™ 2003 上的控制面板安装 IIS 公用文件

  1. 在"开始"菜单中，单击"控制面板"。

  2. 双击"添加或删除程序"。

  3. 单击"添加/删除 Windows 组件"。

  4. 在"组件"列表中单击"应用程序服务器"复选框。

  5. 单击"详细信息"。

  6. 在"应用程序服务器的子组件"列表中，单击"Internet 信息服务 (IIS)"复选框。

  7. 单击"详细信息"。

  8. 单击"公用文件"复选框。

  9. 单击"确定"，直到返回"Windows 组件向导"。

  10. 单击"下一步"并完成 Windows 组件向导。
使用 Windows® XP 上的控制面板安装 IIS 公用文件

  1. 在"开始"菜单中，单击"控制面板"。

  2. 双击"添加或删除程序"。

  3. 单击"添加/删除 Windows 组件"。

  4. 在"组件"列表中单击"Internet 信息服务 (IIS)"复选框。

  5. 单击"详细信息"。

  6. 单击"公用文件"复选框。

  7. 单击"确定"，直到返回"Windows 组件向导"。

  8. 单击"下一步"并完成 Windows 组件向导。


IIS 处于 32 位兼容模式
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-08-11

由于 Microsoft Internet 信息服务 (IIS) 在此 64 位计算机上以 32 位模式运行，因此 Microsoft® Exchange Server 2007 安装程序无法继续。

Exchange 2007 要求 IIS 在 64 位计算机上运行时，必须完全处于 64 位模式。

若要解决此问题，请将 IIS 切换到 64 位模式，然后重新运行 Microsoft Exchange 安装程序。

将 IIS 切换到 64 位模式

  1. 打开命令提示符。

  2. 键入以下命令：

    cscript c:\inetpub\adminscripts\adsutil.vbs SET /w3svc/AppPools/Enable32BitAppOnWin64 False

  3. 按 Enter


没有足够的权限来准备 Active Directory
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-21

因为尝试的域准备失败，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Exchange 安装程序要求在准备 Active Directory 中的域之前修改 Exchange Server 2007 的 Active Directory 目录服务。

用于运行 setup /PrepareAD 命令的帐户没有足够的权限来执行此命令，即使它看起来属于 Enterprise Admins 组。该帐户可能已过期。

若要解决此问题，请验证已登录的用户帐户是否有效且属于 Enterprise Admins 组，或者使用拥有这些权限的帐户登录，然后重新运行 setup /PrepareAD。

有关如何执行 PrepareAD 进程的详细信息，请参阅"How to Prepare Active Directory and Domains"（如何准备 Active Directory 和域）(http://go.microsoft.com/fwlink/?LinkId=78453)。

有关 Microsoft Exchange 所需的 Active Directory 权限的详细信息，请参阅"Working with Active Directory Permissions in Exchange Server"（在 Exchange Server 中使用 Active Directory 权限）(http://go.microsoft.com/fwlink/?LinkId=47592)。


没有足够的权限来删除所有服务器角色
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-27

因为卸载所有服务器角色的尝试失败，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求在卸载所有服务器角色时登录的用户是 Exchange Organization Administrators 组或 Enterprise Admins 组的成员。

若要解决此问题，请将 Exchange Organization Administrator 权限授予已登录的用户或在 Enterprise Admins 组中注册这些用户，或者使用拥有这些权限的帐户登录并重新运行 Exchange 2007 安装程序。

有关 Microsoft Exchange 所需的 Active Directory 权限的详细信息，请参阅"Working with Active Directory Permissions in Exchange Server"（在 Exchange Server 中使用 Active Directory 权限）(http://go.microsoft.com/fwlink/?LinkId=47592)。


没有足够的权限来运行 /PrepareDomain
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-27

因为运行 /PrepareDomain 进程的尝试失败，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。已登录用户没有足够的权限来执行 /PrepareDomain 进程。

Exchange 2007 安装程序要求运行 /PrepareDomain 进程时登录的用户是要准备的域的 Domain Admins 组成员，以及 Exchange Organization Administrators 组或 Enterprise Admins 组的成员。

若要解决此问题，请将所准备域的 Domain Admins 组权限授予已登录用户并在 Exchange Organization Administrators 组或 Enterprise Admins 组中注册它们，或者使用拥有这些权限的帐户登录，再重新运行 Exchange 2007 安装程序。

有关 Microsoft Exchange 所需的 Active Directory 权限的详细信息，请参阅"Working with Active Directory Permissions in Exchange Server"（在 Exchange Server 中使用 Active Directory 权限）(http://go.microsoft.com/fwlink/?LinkId=47592)。


域名系统域名无效
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-04-13

因为在本地计算机上设置的域名系统 (DNS) 域名无效，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求 DNS 域名不得包含除"A-Z"、"a-z"、"0-9"、"."和"-"之外的字符。

若要解决此问题，请确定本地计算机的计算机名称或实际 DNS 域名中是否包含无效字符。

  • 如果本地计算机的计算机名称中包含无效字符，请通过仅使用"A-Z"、"a-z"、"0-9"、"."和"-"范围内的有效字符，为本地计算机上的域重置 DNS 域名，重新启动计算机，然后重新运行 Exchange 2007 安装程序。

  • 如果组织的 DNS 域名中包含无效字符，请考虑是否可以重命名 DNS 域或将 Exchange 2007 安装到新域树中。

警告：
更改 DNS 域名可能会对整个网络产生极大的影响。对 DNS 域名进行任何更改之前，请与网络管理员进行协调。
验证本地计算机的 DNS 域名

  1. 右键单击"我的电脑"，再单击"属性"。将出现"系统属性"对话框。

  2. 单击"计算机名"选项卡。

  3. 单击"更改"。将出现"计算机名称更改"对话框。

  4. 单击"其他"。将出现"DNS 后缀和 NetBIOS 计算机名"对话框。

  5. 验证是否仅使用了"A-Z"、"a-z"、"0-9"、"."和"-"范围内的字符。

  6. 选中"在域成员身份变化时，更改主 DNS 后缀"复选框。

  7. 单击"确定"保存所做的更改，再单击"确定"退出"计算机名称更改"对话框。

  8. 单击"确定"关闭"系统属性"对话框，再重新启动计算机，以使更改生效。

有关 DNS 名称的详细信息，请参阅 Microsoft 知识库文章 909264"Active Directory 中计算机、域、站点和 OU 的命名约定"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=909264)。


安装路径无效
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-27

因为将邮箱服务器或群集邮箱服务器角色安装到共享群集驱动器的尝试失败，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Exchange 安装程序要求将 Exchange Server 角色安装到不是共享群集资源的驱动器。

若要解决此问题，请将邮箱服务器角色或群集邮箱服务器安装到未指定为共享群集驱动器的路径。

有关群集配置的详细信息，请参阅 Exchange Server 2007 产品文档中的"High Availability"（高可用性）(http://go.microsoft.com/fwlink/?linkid=68190)。


CMS 目标路径格式无效
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-27

因为将群集邮箱服务器角色安装到共享群集驱动器的尝试失败，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

提交的 /CMSDataPath:<PathToTheDatabase> 参数为无效的通用命名约定 (UNC) 格式。Exchange 安装程序要求指定的 /CMSDataPath:<PathToTheDatabase> 参数使用有效的驱动器号分配，例如，/CMSDataPath:s:\<PathToTheDatabase>，而不是 UNC 格式。

若要解决此问题，请在 /CMSDataPath:<PathToTheDatabase> 参数中使用有效的驱动器号分配。

有关安装群集邮箱服务器的详细信息，请参阅 Exchange Server 2007 产品文档中的"How to Install the Mailbox Server Role on the Active Node"（如何在主动节点上安装邮箱服务器角色）(http://go.microsoft.com/fwlink/?LinkId=86624)。


安装的 MOUNTMGR.SYS 版本与 Exchange Server 不兼容
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-06

Microsoft® Exchange Server 2007 安装程序无法继续，因为安装的 Mountmgr.sys 版本与 Microsoft Exchange 不兼容。

Exchange 2007 安装程序要求群集节点安装了 Microsoft 知识库文章 898790 所提到的更新。

当前安装在群集节点上的 Mountmgr.sys 版本可能导致卷装入点故障。发生该问题是因为 Mountmgr.sys 驱动程序中存在问题。这是一个时断时续的计时问题，可能会在将卷装入到装入点时发生。

要解决此问题，请安装 Microsoft 知识库文章 898790（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790) 中提到的更新，然后重新运行 Exchange 2007 安装程序。

有关该问题的详细信息，请参阅 Microsoft 知识库文章 898790"Volume mount points on disks in a server cluster may intermittently become unavailable after you install Windows Server 2003 Service Pack 1"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790)。


安装的 TCPIP.SYS 版本与 Exchange Server 不兼容
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-06

因为安装的 Tcpip.sys 版本与 Microsoft Exchange 不兼容，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求本地计算机装有 Microsoft 知识库文章 898060 中提到的更新。

此计算机当前正在运行 Windows Server™ 2003 Service Pack 1 中的 Tcpip.sys 驱动程序。此驱动程序可能在广域网中导致连接问题。

要解决此问题，请从"Update for Windows Server x64 Edition (KB898060)"（英文）(http://go.microsoft.com/fwlink/?linkid=59272) 中安装 Microsoft 知识库文章 898060 提到的更新，然后重新运行 Exchange 2007 安装程序。

有关此警告的详细信息，请参阅 Microsoft 知识库文章 898060"安装安全更新 MS05-019 或 Windows Server 2003 Service Pack 1 可能导致客户端和服务器之间的网络连接失败"(http://support.microsoft.com/kb/898060/zh-cn)。


检测到大型 Exchange 组织模型
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-08-10

Microsoft® Exchange Server 分析工具将查询 Active Directory® 目录服务，以确定 Exchange Server 组织中的路由组数。Exchange Server 分析工具还将查询 Active Directory 以确定包含运行 Microsoft Exchange 2000 Server 或 Microsoft Exchange Server 2003 的 Exchange 服务器的 Active Directory 站点的数目。

如果下列条件为真，Exchange Server 分析工具会将 Exchange 组织分类为大型 Exchange 组织：

  • Exchange 组织中有 5 个以上的路由组。

  • 运行 Exchange 2000 或 Exchange 2003 的服务器安装在 5 个以上的 Active Directory 站点中。

将大型 Exchange 组织转换到 Exchange 2007

  1. 请访问 Microsoft Exchange Server 2007 产品联机文档 (http://go.microsoft.com/fwlink/?LinkId=69434)。

  2. 查看"规划大型 Exchange 组织"主题 (http://go.microsoft.com/fwlink/?LinkId=70504)。


本地计算机是子域的域控制器
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-12-29

因为本地计算机是子域的域控制器，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

不能将 Exchange 2007 安装程序安装到子域的域控制器上，除非域控制器是全局编录服务器。

若要解决此问题，请将域控制器提升到全局编录服务器，或将 Exchange 2007 安装到子域中的非域控制器的成员服务器上，然后重新运行 Microsoft Exchange 安装程序。

通过使 Exchange 服务器成为全局编录服务器来解决此警告问题

  1. 在域控制器中，单击"开始"，指向"程序"，单击"管理工具"，然后单击"Active Directory 站点和服务"。

  2. 在控制台树中，双击"站点"，双击该站点的名称，然后双击"服务器"。

  3. 双击目标域控制器。

  4. 在结果窗格中，右键单击"NTDS 设置"，然后单击"属性"。

  5. 在"常规"选项卡上，单击以选中"全局编录"复选框。

  6. 重新启动域控制器。


本地计算机已经在运行 Exchange Server
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-01-15

因为本地计算机安装了以前版本的 Microsoft Exchange 组件，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求本地计算机不能安装现有的 Microsoft Exchange 组件。

若要解决此问题，请删除所有 Microsoft Exchange 2000 Server 或 Microsoft Exchange Server 2003 组件，然后重新运行 Microsoft Exchange 安装程序。

删除 Microsoft Exchange 组件

  1. 单击"开始"，指向"设置"，然后单击"控制面板"。

  2. 双击"添加或删除程序"。

  3. 在"当前安装的程序"列表中，单击"Microsoft Exchange"，然后单击"更改/删除"。

  4. 在 Microsoft Exchange 安装向导中，单击"下一步"。

  5. 在组件选择页的操作列表中，单击每个已安装的组件旁边的向下箭头，然后单击"删除"。

    注意：
    对于已安装的组件，操作列表中会显示一个相应的选中标记。单击"删除"后，此选中标记就会被"删除"一词所取代。

  6. 单击"下一步"两次。

  7. 单击"完成"。


本地计算机未运行 Windows Server 2003 Service Pack 1 或更高版本
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-05

因为本地计算机未运行 Microsoft Windows Server™ 2003 Service Pack 1 (SP1) 或更高版本，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求用于 Microsoft Exchange 的计算机必须运行 Windows Server 2003 SP1 或更高版本。

若要解决该问题，请执行下列操作：

  • 在运行 Windows Server 2003 SP1 或更高版本的计算机中运行 Exchange 2007 安装程序。

  • 升级要从 Windows Server 2003 SP1 或更高版本运行 Exchange 2007 安装程序的计算机。

有关如何升级 Windows Server 2003 的详细信息，请参阅 Microsoft 知识库文章 810613"Supported paths for upgrading to Windows Server 2003 or to Windows Small Business Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=810613)。

要获取 Windows Server 2003 的最新 Service Pack，请参阅 Windows Server TechCenter（英文）(http://go.microsoft.com/fwlink/?LinkId=45315)。


本地计算机负责展开组成员身份
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-06

因为尝试卸载负责展开组成员身份的集线器传输角色失败，所以 Microsoft Exchange Server2007 安装程序无法继续进行。

Exchange2007 安装程序要求从当前桥头服务器删除通讯组列表扩展后，才能卸载集线器传输角色。

通讯组列表扩展启用属于要标识的通讯组列表的各个收件人的标识，或启用用于扩展的其他通讯组列表的标识。展开的通讯组列表可以返回任何所需的传递状态通知 (DSN) 的路径。DSN 将特定电子邮件状态通知给 Microsoft Exchange 管理员或电子邮件发件人。此外，通讯组列表扩展确定是否应将"外出"回复邮件或自动生成的回复邮件发送到原始邮件的发件人。

要解决此问题，请将通讯组扩展移到另一台服务器并重新运行 Microsoft Exchange 安装程序。

为通讯组或动态通讯组更改扩展服务器

  1. 打开 Exchange 管理控制台。

  2. 在控制台树中，展开"收件人配置"。

  3. 在控制台树中，单击"通讯组"。

  4. 创建筛选器来查看将当前桥头服务器用作扩展服务器的所有通讯组以及动态通讯组。

    1. 在操作窗格中，单击"创建筛选器"。

    2. 在属性下拉列表中，单击"扩展服务器"。

    3. 在运算符下拉列表中，单击"等于"。

    4. 在值框中，单击"浏览"按钮来选择当前充当扩展服务器的桥头服务器。
注意：
下列步骤为可选。
  1. 单击"添加扩展"来指定其他筛选器标准。只显示符合所有筛选器标准的邮件。

  2. 单击"应用筛选器"。此时将显示符合筛选器标准的结果。

  1. 在结果窗格中，单击要为其更改扩展服务器的通讯组，然后在操作窗格中单击"属性"。

  2. 在"属性"中，单击"高级"选项卡。

  3. 在扩展服务器下拉列表中，从列表中选择一台特定的服务器或选择"组织中的任意服务器"。

  4. 对将桥头服务器用作其扩展服务器的所有通讯组或动态通讯组重复步骤 5 到 7。


本地计算机负责生成脱机通讯簿
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-06

因为尝试卸载负责生成脱机通讯簿的邮箱角色失败，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求，除非邮箱角色是 Exchange 组织中的最后一个邮箱角色，否则必须先从当前邮箱服务器删除脱机通讯薄生成过程，然后才能卸载邮箱角色。

要解决此问题，请将脱机通讯簿生成过程移到另一台服务器，并重新运行 Microsoft Exchange 安装程序。

使用 Exchange 系统管理器移动脱机通讯簿生成过程

  1. 打开 Exchange 系统管理器。

  2. 在"收件人"下，单击"脱机地址列表"。

  3. 在右侧窗格中，用鼠标右键单击"默认脱机地址列表"，再单击"属性"。

    注意：
    对任何其他生成此消息的脱机地址列表执行同样的操作。

  4. 在"常规"选项卡的"脱机地址列表服务器"下，单击"浏览"，再单击要使用的 Exchange 服务器。
使用 Exchange 管理控制台移动脱机通讯簿生成过程

  1. 打开 Exchange 管理控制台。

  2. 展开"Microsoft Exchange"，展开"组织配置"，再选择"邮箱"。

  3. 在结果窗格中，单击"脱机通讯簿"选项卡。

  4. 在"脱机通讯簿"选项卡中，选择要移动的脱机通讯簿。在操作窗格中，单击"移动"。

  5. "移动脱机通讯簿向导"出现后，通过使用"浏览"按钮，然后单击"移动"来选择要承载脱机通讯簿生成过程的新服务器。

  6. 要关闭向导，请单击"完成"。
使用 Exchange 管理外壳来移动脱机通讯簿生成过程

  • 运行下列命令：

    复制代码
    Move-OfflineAddressBook -Identity <OfflineAddressBookIdParameter> -Server <ServerIdParameter> [-DomainController <String>]


本地计算机正在运行边缘传输角色
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-06

因为在尝试安装 Exchange 2007 角色时发现该服务器上已经安装了网关服务器角色，因此 Microsoft® Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序不能在安装了 Miscorsoft Exchange 网关服务器角色的服务器上安装其他服务器角色。

在组织的外围网络中部署的 Microsoft Exchange 网关服务器角色可处理所有面向 Internet 的邮件流，并且除了具有防垃圾邮件功能以外，还可以加密和解密在受信任的 Microsoft Exchange 组织之间发送的邮件。

若要解决此问题，请为没有安装网关服务器角色的计算机安装其他 Microsoft Exchange 2007 角色。


本地计算机正在运行 Windows Server 2003 Web 版
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-06

因为本地计算机正在运行 Microsoft Windows Server ™ 2003 Web 版，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求在运行受支持的操作系统的计算机上安装 Microsoft Exchange。

要解决此问题，请将 Microsoft Exchange 安装到非 Web 版的 Windows Server 2003 Service Pack 1 (SP1) 或更高版本上。


需要更新本地域
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-27

因为已登录用户没有域准备所需的帐户权限，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Exchange 安装程序要求在运行 Setup /PrepareDomain 时登录的用户是 Domain Administrators 和 Exchange Organization Administrators 组或 Enterprise Admins 组的成员。

若要解决此问题，请向已登录的用户授予 Domain Admins 和 Exchange Organization Administrator 权限，在 Enterprise Admins 组中注册它们，或者使用拥有这些权限的帐户登录，并重新运行 Exchange 2007 安装程序。

有关 Microsoft Exchange 所需的 Active Directory 权限的详细信息，请参阅"Working with Active Directory Permissions in Exchange Server"（在 Exchange Server 中使用 Active Directory 权限）(http://go.microsoft.com/fwlink/?LinkId=47592)。


无法访问本地元数据库
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-06

因为无法从本地元数据库读取数据，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求安装邮箱服务器或客户端访问角色时能够从 Microsoft Internet 信息服务 (IIS) 元数据库读取数据。

IIS 元数据库包括影响 Microsoft Exchange 的信息，例如，HTTP 的协议设置、邮箱和移动设备访问的虚拟目录以及 HTTP 安全设置。

要解决此问题，请验证是否已正确安装了 IIS，然后重新运行 Microsoft Exchange 安装程序。

要验证是否正确安装了 IIS，请参阅下列资源：

  • Microsof 知识库文章 843093"如何在运行 Exchange 2000 Server 或 Exchange Server 2003 的基于 Windows 2000 Server 的计算机上排查 IIS 元数据库损坏问题"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=843093)。

  • Microsoft 知识库文章 240225"Description of Adsutil and MetaEdit Utilities Used to Modify the Metabase"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240225)。

  • Microsoft 知识库文章 317678"HOW TO:Restart Internet Information Services (IIS) on Exchange 2000 Server"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=317678)。

如果这些资源提供的指导无法解决问题，则可能需要先卸载 IIS，然后重新进行安装。

使用控制面板中的"添加/删除 Windows 组件"来卸载 IIS

  1. 在"开始"菜单中，单击"控制面板"。

  2. 双击"添加或删除程序"。

  3. 单击"添加/删除 Windows 组件"。

  4. 在"组件"列表中单击"应用程序服务器"复选框。

  5. 单击"详细信息"。

  6. 单击"Internet 信息服务管理器"。

  7. 单击"下一步"。

  8. 卸载 IIS 后，单击"完成"。
使用控制面板安装 IIS

  1. 在"开始"菜单中，单击"控制面板"。

  2. 双击"添加或删除程序"。

  3. 单击"添加/删除 Windows 组件"。

  4. 在"组件"列表中单击"应用程序服务器"复选框。

  5. 单击"详细信息"。

  6. 单击"Internet 信息服务管理器"复选框。

  7. 单击"确定"直到返回"Windows 组件向导"。

  8. 单击"下一步"并完成 Windows 组件向导。


登录用户不是本地 Administrators 组的成员
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-06

因登录用户不是本地计算机管理员组的成员，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求安装 Microsoft Exchange 的登录用户具有对本地计算机的完全访问权限。

若要解决此问题，请使用具有本地管理员访问权限的帐户登录计算机，然后重新运行 Microsoft Exchange 安装程序。


已登录的用户不是 Schema Admins 组的成员
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-09-06

由于架构更新进程没有 Active Directory® 目录服务架构管理凭据和企业管理凭据，因此 Microsoft® Exchange Server 2007 安装程序无法继续。

Exchange 2007 安装程序要求安装 Microsoft Exchange 的已登录用户拥有 Active Directory 林的架构管理凭据和企业管理凭据。

作为安装过程的一部分，Microsoft Exchange 安装程序扩展了 Active Directory 架构，以添加 Exchange 2007 特定的类和属性。

如果登录的用户没有架构管理员权限和企业管理权限，架构更新进程将会失败。

若要解决此问题，请将已登录的用户添加到 Schema Admins 和 Enterprise Admins 组，然后注销后重新登录；或者在注销后，使用已经拥有 Active Directory 林的架构管理凭据和企业凭据的帐户进行登录。


主动节点过多
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-23

因为新建主动群集邮箱服务器角色的尝试失败，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Exchange Server 2007 要求至少有一个被动群集节点，才能支持故障恢复。

若要解决此问题，请首先在环境中安装另一个被动群集邮箱服务器角色，再重新运行安装程序。

有关安装主动和被动节点的详细信息，请参阅 Exchange Server 2007 产品文档中的"High Availability"（高可用性）(http://go.microsoft.com/fwlink/?LinkId=68190)。


邮箱数据库驱动器规格丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-05-15

因为灾难恢复安装程序无法访问该服务器以前安装所使用的邮箱数据库驱动器规格，所以 Microsoft Exchange Server2007 灾难恢复安装程序无法继续进行。

Microsoft Exchange 灾难恢复安装程序要求，该服务器以前使用的同一邮箱数据库驱动器规格在还原期间是可用的。

要解决此问题，请将驱动器配置为与原始逻辑驱动器配置相匹配，然后重新运行 Microsoft Exchange 灾难恢复安装程序。

分配或更改驱动器号

  1. 打开"计算机管理(本地)"。

  2. 在控制台树中，依次单击"计算机管理(本地)"、"存储"和"磁盘管理"。

  3. 用鼠标右键单击分区、逻辑驱动器或卷，然后单击"更改驱动器号和路径"。

  4. 请使用下列步骤之一：

    • 要分配驱动器号，请单击"添加"，单击要使用的驱动器号，然后单击"确定"。

    • 要更改驱动器号，在单击它后单击"更改"，再单击要使用的驱动器号，然后单击"确定"。

有关如何分配驱动器号的详细信息，请参阅"Assign, change, or remove a drive letter"（英文）(http://go.microsoft.com/fwlink/?LinkId=66764)。


邮件当前存在于一个或多个队列中
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-05

因为尝试卸载传输角色可能会导致传输队列丢失数据，所以 Microsoft® Exchange Server 2007 安装程序显示该警告。

Exchange 2007 安装程序将进行检查以确保在删除与管理这些队列相关的角色之前，传输队列为空。

如果在仍处于传输队列中的邮件被传递之前就删除了传输角色，则这些邮件可能会无限期地留在该队列之中。

要解决此问题，请在继续安装之前，检查引用队列以确保其中没有邮件。

查看队列的内容

  1. 打开 Exchange 管理控制台。

  2. 在控制台树中，单击"工具箱"。

  3. 在结果窗格中，单击"Exchange 队列查看器"。

  4. 在操作窗格中，单击"打开工具"。

  5. 在队列查看器中，单击"队列"选项卡。此时将显示所连接的服务器上的所有队列的列表。

  6. 用鼠标右键单击所需的队列并选择"属性"以查看该队列的属性。
查看队列中的邮件

  1. 依照步骤 1 到 4 进行操作

  2. 在队列查看器中，单击"邮件"选项卡。此时将显示所连接的服务器上的所有邮件的列表。要将视图调整为单个队列，请单击"队列"选项卡，双击队列名称，然后单击显示的"服务器\队列"选项卡。

  3. 要查看有关邮件的详细信息，请选择一个邮件，然后在操作窗格中单击"属性"。


所需 Microsoft .NET Framework 更新
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-02-26

由于本地计算机要求安装软件更新，因此 Microsoft Exchange Server 2007 安装程序无法继续。

Exchange 2007 安装程序要求在本地计算机上安装下面提到的相应 Microsoft .NET Framework 更新。

若要解决此问题，请退出 Exchange 2007 安装程序，通过下列 URL 下载并安装相应（32 位或 64 位）更新，然后重新运行 Exchange 2007 安装程序。

注意：
单击以下链接就会提示您直接下载文件。
  • 64 位下载 - http://go.microsoft.com/fwlink/?linkid=74465

  • 32 位下载 - http://go.microsoft.com/fwlink/?linkid=74469


需要 Microsoft Core XML Services (MSXML) 6.0
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-08-21

由于此服务器上未安装 Microsoft Core XML Services (MSXML) 6.0，因此 Microsoft® Exchange Server 2007 安装程序无法继续。

对于所有统一消息服务器角色安装，Exchange 2007 安装程序要求在计算机上安装 MSXML 6.0，以支持 Microsoft 语音服务。

若要解决此问题，请安装从 http://go.microsoft.com/fwlink/?LinkId=70796 获取的 MSXML 6.0 软件，然后重新运行 Exchange 2007 安装程序。


MNSFileShare 路径无效
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-27

因为 MNSFileShare 路径无效，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

必须将 MNSFileShare 值设置为一个包含群集外部文件共享的通用命名约定 (UNC) 路径的字符串值，如 \\server\sharename。

若要解决此问题，请为 MNSFileShare 属性提供一个为有效 UNC 路径的值。

有关如何配置 MNSFileShare 属性的详细信息，请参阅"How to Configure the File Share Witness"（如何配置文件共享证据）(http://go.microsoft.com/fwlink/?LinkId=78278)。


需要 MSDAPS.DLL 更新
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-12-05

由于本地计算机需要软件更新，因此 Microsoft® Exchange Server 2007 安装程序无法继续。

Exchange 2007 安装程序需要在本地计算机上安装下面引用的 MSDAPS.DLL 更新。

要解决此问题，请下载并安装以下链接的更新，然后重新运行 Exchange 2007 安装程序。

  • http://go.microsoft.com/fwlink/?linkid=74467


当前已安装了网络新闻传输服务
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-01-22

因为该计算机上已安装了 Microsoft Windows® Server™ 2003 网络新闻传输协议 (NNTP) 服务，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

Microsoft Exchange 安装程序要求 NNTP 服务不能安装在用于 Exchange 2007 的服务器上。

若要解决此问题，请卸载 NNTP 服务并重新运行 Microsoft Exchange 安装程序。

通过使用控制面板中的"添加/删除 Windows 组件"来卸载 NNTP 服务

  1. 在"开始"菜单中，单击"控制面板"。

  2. 双击"添加或删除程序"。

  3. 单击"添加/删除 Windows 组件"。

  4. 在"组件"列表中，选中"应用程序服务器"复选框，然后单击"详细信息"。

  5. 选择"Internet 信息服务管理器"，然后单击"详细信息"。

  6. 选择"NNTP 服务"，然后单击以清除此复选框。

  7. 单击"确定"两次以返回到"组件"列表，然后单击"下一步"。

  8. 卸载 NNTP 服务后，单击"完成"。


未找到任何客户端访问服务器角色
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-02-16

Microsoft Exchange 分析工具查询 Active Directory 目录服务，以确定 Exchange 组织中任何包含 Exchange Server 2007 特定管理组标识符 FYDIBOHF23SPDLT 的 msExchAdminGroupContainer 类对象的值。

如果 Exchange 分析工具确定 Exchange 组织中有 Exchange Server 2007 管理组，Exchange 分析工具将查询组织中的所有 Active Directory 站点，以确定每个 msExchExchangeServer 对象的 msExchCurrentServerRoles 属性的值，从而判定发现的任何站点中是否安装了邮箱服务器角色。

最后，如果 Exchange 分析工具判定某个站点中安装了邮箱服务器角色，Exchange 分析工具将查询该站点中每个 msExchExchangeServer 对象的 msExchCurrentServerRoles 属性，以确定该站点中是否也安装了客户端访问服务器角色。

如果 Exchange 分析工具确定某个 Active Directory 站点中安装了邮箱服务器角色，但是没有安装任何客户端访问服务器角色，那么 Exchange 分析工具将显示警告。

此警告表明，尽管该 Active Directory 站点中安装了邮箱服务器角色，但是，只有在该站点中至少安装了一个客户端访问服务器角色，Microsoft Office Outlook Web Access 和 Exchange ActiveSync 移动设备访问客户端才能访问该邮箱服务器上的邮件。

客户端访问服务器角色允许从多种不同的客户端连接到 Exchange 2007 服务器。软件客户端（如 Miscrosoft Outlook Express 和 Eudora）使用 POP3 或 IMAP4 连接与 Exchange 服务器进行通信。硬件客户端（如移动设备）使用 ActiveSync、POP3 或 IMAP4 与 Exchange 服务器进行通信。

如果用户使用 Microsoft Outlook 以外的任何客户端访问其收件箱，则必须在 Exchange 组织中安装客户端访问服务器角色。

此警告指明的问题，在有非 Microsoft Outlook 客户端必须访问邮箱时，请在安装了邮箱服务器角色的站点中安装客户端访问服务器角色。

详细信息

有关如何在站点中安装客户端访问服务器角色的详细信息，请参阅 Exchange Server 2007 产品文档中的"Deploying Server Roles"（部署服务器角色）(http://go.microsoft.com/fwlink/?LinkId=83282)。


已找到非标准地址空间
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-08-21

如果 Microsoft® Exchange Server 分析工具确定一个或多个收件人策略中存在非标准地址空间，则它会显示此警告。

非标准地址空间或代理地址空间，是在外部邮件系统中识别 Exchange Server 收件人对象时使用的地址。

在 Exchange Server 的早期版本中，由收件人更新服务负责支持非标准地址空间。

在 Microsoft Exchange Server 2007 中，未实现收件人更新服务。由 Exchange 2007 管理控制台负责生成代理地址。

管理控制台必须为检测到的每个非标准地址空间加载一个代理生成器 DLL。

重要信息：
如果管理控制台在 64 位计算机上运行，则需要 64 位版本的代理生成器 DLL。

若要解决此警告，请与支持外部地址空间的供应商联系，以获取与 Exchange 2007 兼容的代理生成器 DLL。


不在架构主站点/域中
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-08-10

由于运行安装程序的计算机与分配了域架构主机角色（又称灵活单一主机操作或 FSMO）的服务器不在同一 Active Directory® 目录服务站点或域中，Microsoft® Exchange Server 2007 安装程序无法继续。

Exchange 2007 安装程序要求用作域架构主机的域控制器与运行 Exchange 安装程序的本地计算机位于同一站点或域中。

域架构主机控制对 Active Directory 构架的所有更新和修改。

若要解决此问题，请从与域架构主机所在的同一站点或域运行 Exchange Server 2007 安装程序。

可以使用架构主机工具来标识角色。但是，必须注册 Schmmgmt.dll DLL，以便将架构工具用作 MMC 管理单元。

查看当前的架构主机

  1. 在命令提示符处键入 regsvr32 schmmgmt.dll

    注意：
    如果显示以下对话框，则表示已成功注册 RegSvr32：

    schmmgmt.dll 中的 DllRegisterServer 已成功注册。

  2. 若要打开新的管理控制台，请依次单击"开始"和"运行"，然后键入 mmc。

  3. 在"控制台"菜单上，单击"添加/删除管理单元"。

  4. 单击"添加"打开"添加独立管理单元"对话框。

  5. 选择"Active Directory 架构"，然后单击"添加"。

  6. "添加/删除管理单元"中将显示"Active Directory 架构"。单击"关闭"，然后单击"确定"返回控制台。

  7. 选择"Active Directory 架构"，随后将会在右侧显示"类"和"属性"区域。

  8. 用鼠标右键单击"Active Directory 架构"，然后单击"操作主机"。

  9. 将显示当前的架构主机


域中没有 Windows Server 2003 SP1 域控制器
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-27

因为 setup /PrepareLegacyExchangePermissions 进程在所准备的域中找不到运行 Microsoft Windows Server 2003 Service Pack 1 (SP1) 或更高版本的域控制器，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

在将运行 setup /PrepareLegacyExchangePermissions 的每个域中，安装程序必须与 Windows Server 2003 SP1 域控制器联系。如果 Setup /PrepareLegacyExchangePermissions 找不到任何 Windows Server 2003 SP1 域控制器，则它将无法成功完成。

运行 setup /PrepareLegacyExchangePermissions 命令使旧版收件人更新服务可以正常工作。在导入新的 Exchange 2007 架构之前，Exchange 2007 必须在已运行 Exchange Server 2003 或 Exchange 2000 Server DomainPrep 的每个域中授予新权限。setup /PrepareLegacyExchangePermissions 命令将授予这些新权限。

若要解决此问题，请将运行 setup /PrepareLegacyExchangePermissions 的每个域中至少一个域控制器升级到 Windows Server 2003 SP1 或更高版本，再重新运行安装程序。

有关如何准备旧版 Exchange 权限的详细信息，请参阅 Exchange Server 2007 产品文档中的"Preparing Legacy Exchange Permissions"（准备旧版 Exchange 权限）(http://go.microsoft.com/fwlink/?linkid=81776)。


OAB 服务器已删除
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-21

Microsoft Exchange Server 2007 安装程序因其安装客户端访问服务器角色的尝试失败而无法继续进行。指定承载脱机通讯簿 (OAB) 的 Exchange 邮箱服务器已被删除。

Exchange 2007 安装程序要求存在有效的承载 OAB 生成的 Exchange 邮箱服务器，客户端访问服务器角色安装才能继续进行。

若要解决此问题，请将有效的 Exchange 邮箱服务器指定为 OAB 生成主机，再重新运行 Exchange 2007 安装程序。

有关如何将 Exchange 服务器指定为脱机通讯簿生成的主机的信息，请参阅 Exchange 2007 产品文档中的"How to Create an Offline Address Book"（如何创建脱机通讯簿）(http://go.microsoft.com/fwlink/?LinkId=86314)。


存在较旧的数据库文件
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-06

因为在目标安装路径中检测到了现有 Microsoft Exchange 数据库文件，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求目标安装路径中不能存在 Microsoft Exchange 数据库文件。

要解决此问题，请从目标安装路径中删除所有现有文件，然后重新运行安装程序。

从目标安装路径中删除现有 Exchange Server 数据库文件

  1. 在"我的电脑"或 Windows 资源管理器中，找到目标安装路径。

    注意：
    默认情况下，数据库文件位于：

    <systemDrive>:\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group。

  2. 用鼠标右键单击要删除的文件，然后选择"删除"。

  3. 在"确认文件删除"对话框中，单击"是"。

  4. 对目标安装路径中的所有文件重复步骤 2 和步骤 3。


检测到较早版本的 ADAM
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-06

因为尝试在当前服务器上安装网关服务器角色时检测到较早版本的 Active Directory® 应用程序模式 (ADAM)，所以 Microsoft® Exchange Server 2007 安装程序显示此警告。

ADAM 是一个轻型目录访问协议 (LDAP) 目录服务，为了能与启用目录的应用程序组合使用而进行了特殊设计。ADAM 仅存储和复制应用程序特定的信息，并且不要求在域控制台上进行部署，也不需要依赖 Active Directory 服务。ADAM 不提供网络操作系统身份验证或授权。

在 Exchange 2007 中，网关服务器使用 ADAM 来存储配置信息。ADAM 与 Active Directory 实现同步后，也可以用来执行收件人查找以保证邮件安全。

Exchange 2007 安装程序会将 ADAM 安装自动升级到 Service Pack 1 (SP1) 版本。

不需要执行任何操作，除非您不希望升级 ADAM。在这种情况下，不应该在本地计算机上安装网关服务器。


发现一台或多台 Active Directory 连接器服务器
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-06

因为在当前 Microsoft Exchange 环境中发现了一个或多个 Active Directory 连接器 (ADC)，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

ADC 在混合模式的 Microsoft Exchange 环境中，将对象从 Exchange Server 版本 5.5 复制到 Active Directory® 目录服务，而 Exchange 2007 并不支持此行为。

Exchange 2007 安装程序要求删除所有 ADC 组件。

要解决此问题，请删除所有 ADC 组件，并重新运行 Exchange 2007 安装程序。

删除 Active Directory 连接器组件

  1. 要在运行 ADC 服务的服务器上禁用 ADC 服务，请在桌面上用鼠标右键单击"我的电脑"，再单击"管理"。

  2. 展开"服务和应用程序"节点，然后单击"服务"节点。

  3. 在右侧窗格中，用鼠标右键单击"Microsoft Active Directory 连接器"，然后单击"属性"。

  4. 将"启动类型"更改为"禁用"。计算机下次启动时，将不会启动 ADC 服务。

  5. 单击"应用"，然后单击"确定"。

  6. 要卸载 ADC 服务，请使用 Microsoft Exchange 2000 Server 或 Microsoft Exchange Server 2003 CD 上的 Active Directory 安装向导。打开 \ADC\I386 文件夹，并双击 Setup.exe 程序。执行提示以"全部删除" ADC 服务组件。

    重要信息：
    要解决该问题，必须完成步骤 6 和"全部删除" ADC 组件。禁用 ADC 服务是不够的。

有关 ADC 的详细信息，请参阅下列 Microsoft 知识库文章：

  • 325300"Support WebCast:Introduction to the Active Directory Connector"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325300)。

  • 325221"Support WebCast:Microsoft Advanced Active Directory Connector"（英文）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325221)。

  • 312632"HOW TO：在 Exchange 2000 Server 中安装和配置 Active Directory 连接器"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=312632)。


仅允许一个 CCR 服务器
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-27

因为新建群集邮箱服务器的尝试失败，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Exchange Server 2007 要求在群集连续复制 (CCR) 群集中仅存在一个群集连续复制群集邮箱服务器。在此 CCR 群集中已存在一个群集邮箱服务器。

若要解决此问题，请勿尝试在此群集中安装其他群集连续复制群集邮箱服务器。

有关在 CCR 环境中安装群集邮箱服务器的详细信息，请参阅 Exchange Server 2007 产品文档中的"How to Install the Mailbox Server Role on the Active Node"（如何在主动节点上安装邮箱服务器角色）(http://go.microsoft.com/fwlink/?LinkId=86624)。


只能在群集服务器上安装邮箱角色
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-07

因为尝试在此群集服务器上安装邮箱服务器角色以外的角色失败，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

在已安装了群集服务的服务器上，Microsoft Exchange 不支持除邮箱服务器角色以外的 Exchange 2007 角色。

要解决此问题，请参阅 Exchange Server 2007 操作指南中的"High Availability for Exchange 2007"（英文）(http://go.microsoft.com/fwlink/?LinkId=68190)。


在混合模式中的组织
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-05-15

因为现有 Microsoft Exchange 组织不在纯模式中，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求现有 Exchange 组织必须在纯模式中。

要解决该问题，请在升级现有组织中最后一个 Exchange Server 5.5 版后或停用最后一台 Exchange 5.5 服务器之前，执行下列步骤，然后重新运行 Exchange 2007 安装程序。

注意：
切换到纯模式后不能再切换回混合模式。
切换到纯模式

  1. 启动 Exchange 系统管理器：单击"开始"，指向"所有程序"，指向"Microsoft Exchange"，再单击"系统管理器"。

  2. 在控制台树中，用鼠标右键单击要切换到纯模式的组织，再单击"属性"。

  3. 在"<组织名> 属性"中的"更改操作模式"下，单击"更改模式"。

  4. 如果确定要永久切换到纯模式，请在警告对话框中单击"是"。单击"应用"接受新的 Exchange 模式。

若要充分利用 Exchange 纯模式，必须在组织中的所有 Exchange 服务器上重新启动 Microsoft Exchange 信息存储服务。不必同时启动所有 Microsoft Exchange 信息存储服务，但是必须在每台服务器上重新启动该服务，这样服务器才能利用所有 Exchange 纯模式的功能。在纯模式切换已复制到本地 Microsoft Windows® 域控制器之后，请在服务器上重新启动该服务。

重新启动 Microsoft Exchange 信息存储服务

  1. 单击"开始"，再单击"运行"，键入 services.msc，然后单击"确定"。

  2. 在"服务(本地)"窗格中，找到 Microsoft Exchange Information Store 服务。

  3. 用鼠标右键单击该服务，再单击"重新启动"。

有关如何从混合模式转换到纯模式的详细信息，请参阅 Microsoft 知识库文章 32779"如何在 Exchange 2000 Server 中从混合模式转换到纯模式"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779)。


无法联系主 DNS 服务器
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-05

因为无法建立与主域名系统 (DNS) 服务器的通信，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求本地计算机能够与该域的权威 DNS 数据库进行通信。

Microsoft Exchange 依靠 DNS 解析其下一个内部或外部目标服务器的 IP 地址。

与主 DNS 服务器的通信可能会由于以下原因而失败：

  • 本地 TCP/IP 配置没有指向正确的 DNS 服务器。

  • DNS 服务器停机或由于网络故障或其他原因而不可访问。

若要解决该问题，请执行下列操作：

  • 验证本地 TCP/IP 配置是否指向正确的 DNS 服务器。

验证本地 TCP/IP 配置

  1. 查看本地 TCP/IP 配置：

    有关详细信息，请参阅"Configure TCP/IP to use DNS"（英文）(http://go.microsoft.com/fwlink/?LinkId=68094)。
  • 验证 DNS 服务器是否正在运行并且可以进行联系。

验证 DNS 服务器是否正在运行并且可以进行联系

  1. 通过执行下列一项或多项检查来验证 DNS 服务器是否正在运行：

    • 从 DNS 服务器上的 DNS 管理程序中查看 DNS 服务器的状态。

    • 重新启动 DNS 服务器。

      有关详细信息，请参阅"Start, stop, pause, or restart a DNS server"（英文）(http://go.microsoft.com/fwlink/?LinkId=62999)。

    • 使用 nslookup 命令验证 DNS 服务器是否响应。

      有关详细信息，请参阅"Verify DNS server responsiveness using the nslookup command"（英文）(http://go.microsoft.com/fwlink/?LinkId=63000) 中的说明。


公用文件夹数据库驱动器规格丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-05-15

因为灾难恢复安装程序无法访问此服务器以前安装所使用的公用文件夹数据库驱动器规格，所以 Microsoft® Exchange Server 2007 灾难恢复安装程序不能继续进行。

Microsoft Exchange 灾难恢复安装程序要求，该服务器以前使用的同一公用文件夹数据库驱动器规格在还原期间是可用的。

要解决此问题，请将驱动器配置为与原始逻辑驱动器配置相匹配，然后重新运行 Microsoft Exchange 灾难恢复安装程序。

分配或更改驱动器号

  1. 打开"计算机管理(本地)"。

  2. 在控制台树中，依次单击"计算机管理(本地)"、"存储"和"磁盘管理"。

  3. 用鼠标右键单击分区、逻辑驱动器或卷，然后单击"更改驱动器号和路径"。

  4. 请使用下列步骤之一：

    • 要分配驱动器号，请单击"添加"，单击要使用的驱动器号，然后单击"确定"。

    • 要更改驱动器号，在单击它后单击"更改"，再单击要使用的驱动器号，然后单击"确定"。

有关如何分配驱动器号的详细信息，请参阅"Assign, change, or remove a drive letter"（英文）(http://go.microsoft.com/fwlink/?LinkId=66764)。


无法远程访问群集节点上的注册表
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-04-13

因为无法访问群集节点上的注册表，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求访问群集中所有节点的注册表以检索各种设置。

若要解决此问题，请执行下列操作：

  • 验证远程注册表服务是否正在群集的所有节点上运行。

  • 验证是否在按绑定顺序列出的第一个网络适配器上启用了"Microsoft 网络的文件和打印机共享"。

  • 验证下列注册表项的值在群集的每个节点上是否相同且对相关组策略而言是否有效：

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Lanmanworkstation\parameters\RequireSecuritySignature

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Rdr\Parameters\EnableSecuritySignature

有关解决注册表连接问题的详细信息，请参阅"Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"（解决连接问题的 Microsoft Exchange Server 最佳实践分析工具）(http://go.microsoft.com/fwlink/?linkid=56285) 中的"Troubleshooting Registry Connectivity Issues"（解决注册表连接问题）部分。


在卸载服务器角色之前删除边缘订阅
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-21

由于卸载边缘或集线器传输服务器角色进程因该服务器角色具有边缘订阅而失败，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

为 Active Directory 站点订阅边缘传输服务器，以便将边缘传输服务器与 Exchange 组织关联。已订阅的边缘传输服务器标记有 Active Directory 站点属性。此外，通过此关联，可以将边缘订阅配置为在 Exchange 组织中创建的发送连接器的源服务器。Exchange 组织中的集线器传输服务器使用隐式组织内发送连接器，通过订阅的边缘传输服务器将电子邮件路由到 Internet。通过 Active Directory 站点关联，集线器传输服务器可以查找边缘传输服务器以达到路由目的。

Exchange 2007 安装程序要求在卸载边缘或集线器传输服务器角色之前，删除目标边缘传输服务器角色或站点中的最后一个集线器传输服务器角色的所有边缘订阅。

若要解决此错误，请使用 Get-EdgeSubscription cmdlet 检索有关边缘订阅的信息，并使用 Remove-EdgeSubscription cmdlet 从目标服务器中删除边缘订阅，再重新运行 Exchange 2007 安装程序。

识别和删除边缘订阅

  1. 按照 Get-EdgeSubscription (http://go.microsoft.com/fwlink/?LinkId=86320) cmdlet 主题中的指导识别目标服务器的边缘订阅。

  2. 按照 Remove-EdgeSubscription (http://go.microsoft.com/fwlink/?LinkId=86321) cmdlet 主题中的指导从目标服务器中删除边缘订阅。


架构 FSMO 不是 Windows Server 2003 Service Pack (SP1) 或更高版本
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-05

Microsoft® Exchange Server 分析工具会检查 Active Directory® 目录服务林以了解运行在 Active Directory 域控制器架构主机上的服务器操作系统版本。如果 Exchange Server 分析工具发现 Active Directory 操作主域控制器（也称为 Flexible Single Master Operation 或 FSMO）未运行 Microsoft Windows Server™ 2003 Service Pack 1 (SP1) 或更高版本，则 Exchange Server 分析工具将显示一个错误。

该错误表明，要安装 Microsoft Exchange 2007，必须运行 Windows Server 2003 SP1 或更高版本。而且要支持新的 Exchange 2007 权限结构，也必须运行 Windows Server 2003 SP1 或更高版本。

如果 Active Directory 架构 FSMO 域控制器未运行 Windows Server 2003 SP1 或更高版本，则 Exchange 2007 安装将在安装期间失败。

此消息是部署 Exchange 2007 之前所做的先决条件检查。如果您计划安装 Exchange 2007，则建议您在林范围的 Active Directory 域控制器架构主机上运行 Windows Server 2003 SP1 或更高版本。


架构主机正在运行 Windows 2000 Server
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-01-08

因为分配有 Active Directory® 目录服务架构主机角色（也称为 Flexible Single Master Operations，简称 FSMO）的域控制器正在运行 Microsoft Windows® 2000 Server，所以 Microsoft® Exchange Server 2000 安装程序无法继续进行。

Exchange 2007 安装程序要求作为构架 FSMO 的域控制器必须运行 Microsoft Windows Server™ 2003 Service Pack 1 (SP1) 或更高版本。

FSMO 控制对 Active Directory 构架的所有更新和修改。

若要解决该问题，请将 FSMO 域控制器升级或移动到 Windows Server 2003 SP1 或更高服务器版本，然后重新运行 Microsoft Exchange 安装程序。

有关详细信息，请参阅 Microsoft 知识库文章 325379"如何将 Windows 2000 域控制器升级到 Windows Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325379)。

有关将基础结构主机角色由一个域控制器转移到另一个域控制器的详细信息，请参阅下列 Microsoft 知识库文章：

  • 对于 Microsoft Windows Server™ 2003，请参阅 324801"如何查看和转移 Windows Server 2003 中的 FSMO 角色"(http://support.microsoft.com/kb/324801/zh-cn)

  • 对于 Microsoft Windows 2000 Server，请参阅 255690"HOW TO：在图形用户界面中查看和转移 FSMO 角色"(http://support.microsoft.com/kb/255690/zh-cn)


架构主机未运行 Windows Server 2003 Service Pack 1 或更高版本
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-27

因为分配有 Active Directory 目录服务架构主机角色（也称为 Flexible Single Master Operations，简称 FSMO）的域控制器没有运行 Microsoft Windows Server 2003 Service Pack 1 (SP1) 或更高版本，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求作为构架 FSMO 的域控制器必须运行 Windows Server 2003 SP1 或更高版本。

FSMO 控制对 Active Directory 构架的所有更新和修改。

若要解决此问题，请执行下列一项或多项操作：

  • 将 FSMO 域控制器升级到 Windows Server 2003 SP1 或更高版本，并重新运行 Microsoft Exchange 安装程序。

  • 如果 Exchange 组织中存在运行 Microsoft Windows Server 2003 Service Pack 1 (SP1) 或更高版本的 FSMO 域控制器，请使用指向该 FSMO 域控制器的 /domaincontroller 参数运行 Exchange 2007 安装程序：

    [/DomainController 或 /dc <域控制器的 FQDN>]

    使用 /DomainController 参数指定用来在安装过程中从 Active Directory 读取和向其写入的域控制器。可以使用 NetBIOS 或完全限定的域名 (FQDN) 格式。

要获取 Windows Server 2003 的最新 Service Pack，请参阅"Windows Server TechCenter"（英文）(http://go.microsoft.com/fwlink/?LinkId=45315)。

有关 Exchange Server 2007 安装程序参数的详细信息，请参阅 Exchange Server 2007 产品文档中的"How to Install Exchange 2007 in Unattended Mode"（如何以无人值守模式安装 Exchange 2007）(http://go.microsoft.com/fwlink/?LinkId=86476)。


Setup Cannot Install Exchange to a Read-Only Domain Controller
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-07-23

Microsoft Exchange Server 2007 安装程序无法继续安装，因为目标计算机为只读域控制器 (RODC)。

只读域控制器是 Windows Server 2008 Active Directory 的一项功能。RODC 是一种域控制器安装选项，可以安装于可能具有较低级别物理安全性的远程网站上。

Exchange 安装程序需要对目标安装计算机具有写入访问权限。

要解决此问题，请选择未指定为 RODC 的目标安装计算机，然后重新运行安装程序。


安装服务器角色时发生安装失败
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-04-12

因为在安装服务器角色时曾发生安装失败，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求先成功地重新安装之前安装失败的服务器角色或者将其从安装进程中删除，才能继续执行任何其他安装任务。

若要解决此问题，要么重新安装失败的服务器角色，要么删除该服务器角色。

从命令行重新安装失败的服务器角色

  1. 打开命令提示符窗口，再导航到安装文件。

  2. 运行以下命令：

    复制代码
    Setup /roles:<Failed Server Role>

    选择下列角色中的一个或多个（在逗号分隔列表中）：

    ClientAccess（或 CA，或 C）

    EdgeTransport（或 ET，或 E）

    注意：
    边缘传输服务器角色不能与任何其他服务器角色共存于同一计算机上。
    注意：
    必须在外围网络中和 Active Directory 林的外部部署边缘传输服务器角色。

    HubTransport（或 HT，或 H）

    Mailbox（或 MB，或 M）

    UnifiedMessaging（或 UM，或 U）

    ManagementTools（或 MT，或 T）

    注意：
    如果指定管理工具，则将安装 Exchange 管理控制台、Exchange 命令行管理程序的 Exchange cmdlet、Exchange 帮助文件、Exchange 最佳实践分析工具和 Exchange 故障排除助理。如果安装任何其他服务器角色，则将自动安装管理工具。

    例如，若要将集线器传输服务器角色添加到现有的邮箱服务器，请键入以下内容：%LocalExchangeInstallationDir%\bin\Setup.com /role:HubTransport /Mode:Install

注意：
如果之前曾成功安装了任何 Exchange Server 2007 服务器角色，则安装向导将以维护模式运行。如果之前未成功安装任何 Exchange 2007 服务器角色，则安装向导将从它所停止的位置开始。
以维护模式使用 Exchange Server 2007 安装向导来重新安装失败的服务器角色

  1. 登录到要为其重新安装服务器角色的服务器。

  2. 打开"控制面板"，再双击"添加或删除程序"。

  3. 在"更改或删除程序"页上，选择"Microsoft Exchange Server"，再单击"更改"。

  4. 在 Exchange Server 2007 安装向导中的"Exchange 维护模式" 页上，单击"下一步"。

  5. 在"服务器角色选择"页上，选中要安装的服务器角色的复选框，再单击"下一步"。

    注意：
    边缘传输服务器角色不能与任何其他服务器角色共存于同一计算机上。
    注意：
    必须在外围网络中和 Active Directory 林的外部部署边缘传输服务器角色。
    注意：
    如果选择"管理工具"，则将安装 Exchange 管理控制台、Exchange 命令行管理程序的 Exchange cmdlet 和 Exchange 帮助文件。如果安装任何其他服务器角色，则将自动安装管理工具。

  6. 如果选择了"集线器传输角色"，而且要在具有现有 Exchange Server 2003 或 Exchange 2000 Server 组织的林中安装 Exchange 2007，请在"邮件流设置"页上，在现有组织中选择一个桥头服务器，该桥头服务器应为要为其创建路由组连接器的 Exchange 2003 或 Exchange 2000 路由组的成员。

  7. 在"准备情况检查"页上，查看状态以确定组织和服务器角色先决条件检查是否已成功完成。如果它们成功完成，请单击"安装"来安装 Exchange 2007。

  8. 在"完成"页上，单击"完成"。
在之前未成功安装任何其他服务器角色的情况下使用 Exchange Server 2007 安装向导重新安装失败的服务器角色

  1. 按照 Exchange Server 2007 产品文档中"How to Perform a Custom Installation Using Exchange Server 2007 Setup"（如何使用 Exchange Server 2007 安装程序执行自定义安装）(http://go.microsoft.com/fwlink/?LinkId=86648) 的指导操作。
删除失败的服务器角色

  1. 按照 Exchange Server 2007 产品文档中"How to Remove Exchange 2007 Server Roles"（如何删除 Exchange 2007 服务器角色）(http://go.microsoft.com/fwlink/?LinkId=86649) 的指导操作。

详细信息

有关如何以无人职守模式安装 Exchange 2007 的详细信息，请参阅"How to Install Exchange 2007 in Unattended Mode"（如何以无人值守模式安装 Exchange 2007）(http://go.microsoft.com/fwlink/?LinkId=86476)。


此服务器是路由组连接器的源
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-27

Microsoft Exchange Server 2007 安装程序因其删除集线器传输服务器角色的尝试失败而无法继续进行。本地计算机是 Exchange 组织中一个或多个路由组连接器的源。

路由组连接器用于在 Exchange 2007 集线器传输服务器和 Exchange Server 2003 或 Exchange 2000 Server 桥头服务器之间发送和接收邮件。在现有 Exchange Server 2003 和 Exchange 2000 Server 组织中安装 Exchange Server 2007 时，将在安装过程中创建所需的路由组连接器。

Exchange 2007 安装程序要求在删除该服务器角色之前，从集线器传输服务器计算机中移动或删除 Exchange 组织的所有路由组连接器。

若要解决此问题，请从本地计算机中移动或删除所有路由组连接器，再重新运行安装程序。

使用 Exchange 命令行管理程序移动路由组连接器

  1. 使用 Set-RoutingGroupConnector cmdlet 修改 Microsoft Exchange Server 2007 路由组和 Exchange Server 2003 或 Exchange 2000 Server 路由组之间的现有路由组连接器的属性。

  2. 此示例使用 Set-RoutingGroupConnector cmdlet 修改路由组连接器的源
复制代码
Set-RoutingGroupConnector -Identity "[[Administrative Group Name\]Routing Group Name]\Routing Group Connector Name" -SourceTransportServers [FQDN of desired Hub Transport Server]
 使用 Exchange 命令行管理程序删除路由组连接器

  1. 使用 Remove-RoutingGroupConnector cmdlet 删除 Microsoft Exchange Server 2007 路由组和 Exchange Server 2003 或 Exchange 2000 Server 路由组之间的路由组连接器。

  2. 以下示例说明如何使用 Remove-RoutingGroupConnector cmdlet 删除指定的路由组连接器。
复制代码
Remove-RoutingGroupConnector -Identity"[[Administrative Group Name\]Routing Group Name]\Routing Group Connector Name"

有关修改或删除路由组连接器的详细信息，请参阅 Exchange Server 2007 产品文档中的下列主题：

  • Set-RoutingGroupConnector (http://go.microsoft.com/fwlink/?LinkId=86659)。

  • Remove-RoutingGroupConnector (http://go.microsoft.com/fwlink/?LinkId=86660)。


此服务器是发送连接器的源
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-27

Microsoft Exchange Server 2007 安装程序因其删除集线器传输服务器角色的尝试失败而无法继续进行。本地计算机是 Exchange 组织中一个或多个发送连接器的源。

发送连接器表示通过其发送出站邮件的逻辑网关。

Exchange 2007 安装程序要求在删除该服务器角色之前，从集线器传输服务器计算机中移动或删除 Exchange 组织的所有发送连接器。

若要解决此问题，请从本地计算机中移动或删除所有发送连接器，再重新运行安装程序。

有关修改或删除发送连接器的详细信息，请参阅 Exchange Server 2007 产品文档中的下列主题：

  • "How to Remove a Send Connector"（如何删除发送连接器）(http://go.microsoft.com/fwlink/?LinkId=86655)。

  • "How to Modify the Configuration of a Send Connector"（如何修改发送连接器的配置）(http://go.microsoft.com/fwlink/?LinkId=86656)。


检测到简单 Exchange 组织模型
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-08-18

Microsoft® Exchange Server 分析工具将查询 Active Directory® 目录服务以确定服务器上的邮箱数。每个邮箱存储对象（msExchPrivateMDB 类）都包含一个列出了存储中所有邮箱的多值属性 homeMDBBL。Exchange Server 分析工具将对这些值进行计数，以获取服务器上的邮箱总数。

Exchange Server 分析工具还将查询 Active Directory 以确定包含 Exchange Server 的 Active Directory 站点的数目。此外，Exchange Server 分析工具将查询 Active Directory 以确定运行 Microsoft Exchange 2000 Server 或 Microsoft Exchange Server 2003 的服务器的数目。最后，Exchange Server 分析工具将查询 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 对象以确定 Windows 群集服务是否存在并且正在运行。

如果下列条件为真，Exchange Server 分析工具会将 Exchange 组织分类为简单 Exchange 组织：

  • 组织中的邮箱总数少于 1,000。

  • Exchange 服务器只安装在一个 Active Directory 站点中。

  • 运行 Exchange 2000 或 Exchange 2003 的计算机少于 3 台。

  • 未部署任何群集的 Exchange 服务器。

在 Microsoft Exchange Server 2007 四个定义的组织模型中，简单 Exchange 组织代表可以在其中部署 Exchange 2007 的最基本拓扑。简单 Exchange 组织包含下列两项之一：

  • 由一台 Exchange 服务器为整个组织提供所有 Exchange 服务和存储所有 Exchange 数据。

  • 在包含冗余目录服务器的拓扑中有多台 Exchange 服务器，在外围网络中有一台边缘传输服务器。

将简单 Exchange 组织转换到 Exchange 2007

  1. 请访问 Exchange 2007 产品联机文档 (http://go.microsoft.com/fwlink/?LinkId=69434)。

  2. 依次展开"规划和架构"和"规划部署"，然后单击"规划简单 Exchange 组织"。


当前已安装了简单邮件传输协议
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-01-22

因为该计算机上安装了 Microsoft Windows Server™ 2003 简单邮件传输协议 (SMTP) 服务，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

Microsoft Exchange 安装程序要求 SMTP 服务不能安装在用于 Exchange 2007 的服务器上。

若要解决此问题，请卸载 SMTP 服务并重新运行 Microsoft Exchange 安装程序。

通过使用控制面板中的"添加/删除 Windows 组件"来卸载 SMTP 服务

  1. 在"开始"菜单中，单击"控制面板"。

  2. 双击"添加或删除程序"。

  3. 单击"添加/删除 Windows 组件"。

  4. 在"组件"列表中，选中"应用程序服务器"复选框，然后单击"详细信息"。

  5. 选择"Internet 信息服务管理器"，然后单击"详细信息"。

  6. 选择"SMTP 服务"，然后单击以清除此复选框。

  7. 单击"确定"两次以返回到"组件"列表，然后单击"下一步"。

  8. 卸载 SMTP 服务后，单击"完成"。


站点无法支持 Exchange 2007 服务器
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-08-11

Microsoft® Exchange Server 分析工具显示此警告的原因是，Active Directory 目录服务林中有的站点没有一台运行 Microsoft Windows Server™ 2003 Service Pack 1 (SP1) 或更高版本的全局编录服务器。

Microsoft Exchange Server 2007 安装程序要求，驻留运行 Exchange 2007 的服务器的每个 Active Directory 站点至少有一台运行 Windows Server 2003 SP1 或更高版本的全局编录服务器。

若要解决此问题，请将每个 Active Directory 站点中的至少一台全局编录服务器升级为 Windows Server 2003 SP1 或更高版本。

有关如何升级为 Windows Server 2003 的详细信息，请参阅 Microsoft 知识库文章 810613"Supported paths for upgrading to Windows Server 2003 or to Windows Small Business Server 2003"（升级为 Windows Server 2003 或 Windows Small Business Server 2003 的支持路径）(http://go.microsoft.com/fwlink/?linkid=3052&kbid=810613)。

若要获取 Windows Server 2003 的最新 Service Pack，请参阅 Windows Server TechCenter (http://go.microsoft.com/fwlink/?LinkId=45315)。


检测到标准 Exchange 组织模型
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-08-10

Microsoft® Exchange Server 分析工具将查询 Active Directory® 目录服务，以确定以下事项：

  • 组织中的邮箱数。

  • 组织中的路由组数。

  • 组织中的 Active Directory 站点数。

  • 组织中的 Active Directory 林数。

  • 是否已安装 Microsoft Identity Integration Server (MIIS)。

每个项目的数量将确定 Exchange 组织模型是简单、标准、大型还是复杂模型。未分类为简单、大型或复杂模型的任何组织将自动分类为标准 Exchange 组织。

在 Microsoft Exchange Server 2007 四个定义的组织模型中，标准 Exchange 组织代表部署 Exchange 2007 的最常见拓扑。当邮件服务需求发展到超出单台计算机的资源限制时，分隔到多台计算机的 Exchange 2007 服务将成为下一个拓扑分区：标准 Exchange 组织。部署运行 Exchange 的多台计算机，可以在简单 Exchange 组织上构建标准 Exchange 组织。

将标准 Exchange 组织转换到 Exchange 2007

  1. 请查看 Exchange 2007 产品联机文档 (http://go.microsoft.com/fwlink/?LinkId=69434)。

  2. 依次展开"规划和体系结构"和"规划部署"，然后单击"规划标准 Exchange 组织"。


建议在群集中使用静态 IP 地址
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-05

因为已将一个或多个网络接口配置为使用动态主机配置协议 (DHCP)，所以 Microsoft® Exchange Server 2007 安装程序显示该警告。

建议的最佳作法是在 Microsoft Windows 服务器群集中对管理客户端连接和检测信号链接的网络接口使用静态 IP 地址。不建议通过 DHCP 使用动态配置，因为如果续订 DHCP 租约失败，就会中断群集操作。

要解决该警告，请将所有管理客户端连接或检测信号链接的网络接口配置为使用静态 IP 地址。

为网络连接配置静态 IP 地址

  1. 在"开始"菜单中，单击"设置"，然后单击"网络设置"。

  2. 用鼠标右键单击要配置的连接，然后单击"属性"。

  3. 在"常规"选项卡的"此连接使用下列项目"中，单击"Internet 协议(TCP/IP)"，然后单击"属性"。

  4. 单击"使用下面的 IP 地址"，并在"IP 地址"中，键入 IP 地址。

  5. 单击"确定"两次即可完成此过程。

有关 Windows 服务器群集的最佳网络配置的详细信息，请参阅"Server Clusters:Network Configuration Best Practices for Windows 2000 and Windows Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=34304)。

有关正确的群集检测信号配置的详细信息，请参阅 Microsoft 知识库文章 258750"建议在群集服务器上使用的专用'信号'配置"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)。


单一副本群集的存储路径必须是群集磁盘
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-27

因为单一副本群集的存储路径必须是群集磁盘，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

在 Exchange Server 2007 中，单一副本群集 (SCC) 是在群集节点之间共享的存储上使用存储组的单一副本的群集解决方案。

若要解决此问题，请指定数据路径的群集驱动器，再重新运行 Exchange 2007 安装程序。

有关单一副本群集的详细信息，请参阅 Exchange Server 2007 产品文档中的"Installing a Single Copy Cluster"（安装单一副本群集）(http://go.microsoft.com/fwlink/?LinkId=76162)。


不支持 SMTP 寻址格式
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-27

因为指定的收件人策略使用不支持的简单邮件传输协议 (SMTP) 地址格式，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Exchange 2007 安装程序要求用于电子邮件地址策略的所有 SMTP 地址不得包含 IP 地址文本，例如：user@[10.10.1.1]。

若要解决此问题，请更改收件人策略中 SMTP 地址的值，使其不包含 IP 地址文本。将 IP 地址文本的方括号 ([]) 和数字 (10.10.1.1) 替换为域名系统 (DNS) 命名格式，例如：user@contoso.com，再重新运行 Exchange 安装程序。

有关在 Exchange Server 2007 中管理收件人策略的详细信息，请参阅"Managing E-Mail Address Policies"（管理电子邮件地址策略）(http://go.microsoft.com/fwlink/?LinkId=86653)。


已找到 SMTP 站点链接
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-12-07

如果 Microsoft® Exchange Server 分析工具在 Active Directory® 目录服务中找到了基于简单邮件传输协议 (SMTP) 的站点链接，则会显示此警告。

Microsoft Exchange Server 2007 路由将忽略由 SMTP 站点链接所连接的 Active Directory 站点。如果 Exchange 2007 安装在仅由 SMTP 站点链接所连接的站点上，则将发生路由错误。

若要解决此问题，请将 SMTP 站点链接替换为基于 IP 的站点链接。

有关 Active Directory IP 站点链接的详细信息，请参阅"Planning to Use Active Directory Sites for Routing Mail"（计划使用 Active Directory 站点进行路由邮件）(http://go.microsoft.com/fwlink/?LinkId=71803)。


存储组驱动器规格丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-05-15

因为灾难恢复安装程序无法访问该服务器以前安装所使用的存储组数据库驱动器规格，所以 Microsoft Exchange Server2007 灾难恢复安装程序无法继续进行。

Microsoft Exchange 灾难恢复安装程序要求，该服务器以前使用的同一存储组数据库驱动器规格在还原期间必须是可用的。

要解决此问题，请将驱动器配置为与原始逻辑驱动器配置相匹配，然后重新运行 Microsoft Exchange 灾难恢复安装程序。

分配或更改驱动器号

  1. 打开"计算机管理(本地)"。

  2. 在控制台树中，依次单击"计算机管理(本地)"、"存储"和"磁盘管理"。

  3. 用鼠标右键单击分区、逻辑驱动器或卷，然后单击"更改驱动器号和路径"。

  4. 请使用下列步骤之一：

    • 要分配驱动器号，请单击"添加"，单击要使用的驱动器号，然后单击"确定"。

    • 要更改驱动器号，在单击它后单击"更改"，再单击要使用的驱动器号，然后单击"确定"。

有关如何分配驱动器号的详细信息，请参阅"Assign, change, or remove a drive letter"（英文）(http://go.microsoft.com/fwlink/?LinkId=66764)。


目标安装路径不匹配
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-27

因为 Exchange 二进制文件的目标路径与其他群集节点上的现有 Exchange 安装路径不匹配，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Exchange Server 2007 要求同一群集的节点具有一致的 Exchange 二进制文件目标安装路径。

若要解决此问题，请使用在群集的所有节点之间保持一致的 Exchange 二进制文件目标安装路径。

有关高可用性 Exchange Server 2007 安装的详细信息，请参阅 Exchange Server 2007 产品文档中的"High Availability"（高可用性）(http://go.microsoft.com/fwlink/?linkid=68190)。


目标路径已压缩
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-06

因为安装 Microsoft Exchange 的目标文件夹路径已被压缩，所以 Microsoft® Exchange Server 2007 安装程序无法继续进行。

Microsoft Exchange 安装程序要求不能压缩安装的目标路径的第一个文件夹。默认情况下，安装的目标路径的第一个文件夹是 C:\Program Files。

要解决此问题，请禁用目标路径的第一个文件夹的压缩，并重新运行 Exchange 2007 安装程序。

禁用目标路径的压缩

  1. 在"我的电脑"或 Windows 资源管理器中，用鼠标右键单击此文件夹以解压缩。

  2. 单击"属性"以显示"属性"对话框。

  3. 在"常规"选项卡上，单击"高级"。

  4. 在"高级属性"对话框中，清除"压缩内容以便节省磁盘空间"复选框，再单击"确定"。

  5. 在"属性"对话框中，单击"确定"。

  6. 在更改文件夹的压缩状态时，在"确认属性更改"对话框中，选择"将改动应用于这个文件夹、子文件夹和文件"。

  7. 完成时单击"确定"。


建议在群集中设置两个或更多个网络接口
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-05

因为当前 Miscrosoft Windows 群集环境只有一个已定义的网络接口，所以 Microsoft® Exchange Server 2007 安装程序显示此警告。

建议的最佳作法是为公用网络（客户端连接）至少实现一个网络接口，为专用网络（管理/检测信号）实现一个网络接口，这样便可避免单个故障点。

若要解决该警告，请为 Microsoft Windows 群集至少实现一个额外的网络接口。

有关 Windows 服务器群集的最佳网络配置的详细信息，请参阅"Server Clusters:Network Configuration Best Practices for Windows 2000 and Windows Server 2003"（英文）(http://go.microsoft.com/fwlink/?linkid=34304)。


无法连接到远程注册表服务
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-01-23

由于无法访问本地计算机上的注册表，Microsoft® Exchange Server 2007 安装程序无法继续进行安装。

Exchange 2007 安装程序需要访问本地注册表以检索各种设置。

Exchange 安装程序尝试使用域名系统 (DNS) 来获取本地计算机的完全限定域名 (FQDN) 以访问注册表。

或者是安装程序由于网络错误而无法从 DNS 中检索 FQDN，或者是安装程序无法访问注册表。

若要解决该问题，请确保本地计算机上正在运行远程注册表服务，并且在按绑定顺序列出的第一个网络适配器上启用了文件和打印共享，然后再次运行 Exchange 安装程序。

确保远程注册表服务正在运行

  1. 单击"开始"，指向"设置"、"控制面板"、"管理工具"，然后双击"服务"。

  2. 确保"远程注册表服务"的状态为"已启动"。
在主网络适配器上启用文件和打印共享

  1. 单击"开始"，指向"设置"、"控制面板"、"网络连接"以及"本地连接"。

  2. 确保启用了"Microsoft 网络的文件和打印机共享"，也就是说，选中了该复选框。
注意：
如果这是一个群集服务器，则必须确保群集的所有节点上正在运行远程注册表服务，并且在按绑定顺序列出的第一个网络适配器上启用了"Microsoft 网络的文件和打印机共享"。


需要 Windows Media Audio Voice Codec 更新
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-07-13

Microsoft® Exchange Server 2007 安装程序无法继续，因为尚未安装 Microsoft Windows Media Audio Voice Codec，或者已有较新版本的 Windows Media Audio Voice Codec 可用。

Exchange 2007 安装程序要求在服务器上安装最新版本的 Windows Media Audio Voice Codec。需要使用 Windows Media Audio Voice Codec 支持 Exchange Server 2007 统一消息服务器角色。

要解决此问题，请安装 http://go.microsoft.com/fwlink/?LinkId=67407 处的 Windows Media Audio Voice Codec 最新版本，然后重新运行 Exchange 2007 安装程序。


需要 Windows Media Encoder 更新
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-07-13

Microsoft® Exchange Server 2007 安装程序无法继续，因为尚未安装 Microsoft Windows Media Encoder，或者已有较新版本的 Windows Media Audio Voice Codec 可用。

Exchange 2007 安装程序要求在服务器上安装最新版本的 Windows Media Encoder。必须使用 Windows Media Encoder 来支持 Exchange Server 2007 统一消息服务器角色。

要解决此问题，请安装 http://go.microsoft.com/fwlink/?LinkId=67406 处的 Windows Media Encoder 最新版本，然后重新运行 Exchange 2007 安装程序。


World Wide Web Publishing 服务已禁用或丢失
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-02-14

因为尝试安装邮箱服务器或客户端访问角色时发现万维网发布服务已禁用，或者该计算机上没有安装万维网发布服务，所以 Microsoft® Exchange Server2007 安装程序无法继续进行。

Exchange2007 安装程序要求安装 Microsoft Exchange 的计算机必须先安装万维网发布服务，并将其设置为除禁用外的其他设置。

要解决此问题，请验证本地计算机上是否安装了万维网发布服务，并且未被禁用，然后重新运行 Microsoft Exchange 安装程序。

验证是否安装了万维网发布服务且未被禁用

  1. 在桌面上用鼠标右键单击"我的电脑"，然后单击"管理"。

  2. 展开"服务和应用程序"节点，然后单击"服务"节点。

  3. 在右窗格中，找到"World Wide Web Publishing 服务"。

    如果"万维网发布服务"没有显示在已安装的服务列表中，请按照下列步骤进行安装。

  4. 如果显示了"万维网发布服务"，但状态不是"已启动"，请继续执行下列步骤启动该服务。

  5. 用鼠标右键单击"万维网发布服务"，然后单击"属性"。

  6. 验证"启动类型"是否为"自动"，"服务状态"是否设置为"已启动"。

  7. 单击"应用"，然后单击"确定"。
安装万维网发布服务

  1. 在"开始"菜单上，依次选择"设置"、"控制面板"，然后单击"添加或删除程序"。

  2. 单击"添加/删除 Windows 组件"。

  3. 在"组件"列表中，选中"应用程序服务器"复选框，然后单击"详细信息"。

  4. 选择"Internet Information Services 管理器"，然后单击"详细信息"。

  5. 选择"万维网服务"，然后选中该复选框。

  6. 单击"确定"两次以返回到"组件"列表，然后单击"下一步"。

  7. 安装了 IIS 服务后，单击"完成"。


卸载统一消息语言包
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-16

因为统一消息服务器角色升级失败，所以 Microsoft Exchange Server 2007 安装程序无法继续进行。

Exchange 安装程序要求先卸载所有的统一消息服务器角色语言包（美国英语语言包除外），统一消息服务器角色升级才能继续进行。

Exchange 2007 附带的统一消息 (UM) 语言包包含给定语言的预录制提示、语音合成 (TTS) 转换支持。

通过 Exchange 2007 UM 语言包，呼叫者和 Outlook Voice Access 用户可以用多种语言与统一消息系统进行交互。

需要卸载现有的非美国英语语言包，才能安装新语言包。

若要解决此问题，请卸载所有的统一消息服务器角色语言包（美国英语语言包除外），再重新运行 Exchange 2007 安装程序。

有关卸载统一消息服务器角色语言包的详细信息，请参阅 Exchange 2007 产品文档中的 How to Remove a Unified Messaging Language Pack from a Unified Messaging Server。


灾难恢复所需的更新
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2007-03-27

因为最初在此计算机上使用了 Exchange Server 2007 的更高版本安装 Exchange Server，所以 Microsoft Exchange Server 2007 灾难恢复无法继续进行。

Microsoft Exchange 灾难恢复要求用于执行 Exchange Server 恢复的 Exchange Server 2007 版本不得低于最初用于安装 Exchange Server 的版本。

若要解决此问题，请从最初用于安装 Exchange Server 的版本或更高版本的 Exchange Server 2007 启动 Exchange Server 2007 灾难恢复。


在拓扑中发现 X400 连接器
Microsoft Exchange Server 分析工具 - 文章 > Exchange Server 2007 准备情况 >

主题上次修改时间： 2006-06-05

Microsoft® Exchange Server 分析工具会在 Active Directory® 目录服务中查询 X.400 连接器。如果 Exchange Server 分析工具发现 X.400 连接器存在于 Microsoft Exchange 组织中，则 Exchange Server 分析工具将显示警告。该警告表明，Microsoft Exchange Server 2007 不支持 X.400 连接器，该连接器是用于在以前的邮件系统之间传输邮件的协议。

在 Microsoft Exchange 2000 Server 和 Microsoft Exchange Server 2003 中，简单邮件传输协议 (SMTP) 已成为默认的传输协议。虽然 Exchange 2000 和 Exchange 2003 支持 X.400 连接器，但 Exchange 2007 并不支持 X.400 连接器，因为 X.400 连接器的使用已逐年减少。如果仍需要对 X.400 支持，则建议您保留一个 Exchange 2000 或 Exchange 2003 服务器。否则，可使用 SMTP 替换 X.400 连接器。

有关 Exchange 2003 中 X.400 传输体系结构的详细信息，请参阅"Exchange Server 2003 Message Routing"（Exchange Server 2003 邮件路由）(http://go.microsoft.com/fwlink/?LinkId=65578)。

有关如何在 Exchange 2003 中实现 X.400 连接器的详细信息，请参阅"Implementing the X.400 Connector - Is It Worth Using with Exchange Server 2003?"（实现 X.400 连接器 - 是否值得与 Exchange Server 2003 一起使用？）(http://www.msexchange.org/tutorials/X400-Connector-Exchange-Server-2003.html)

注意：
在本主题中提供第三方网站信息是为了帮助您查找所需的技术信息。URL 如有更改，恕不通知。


法律信息

主题上次修改时间： 2007-04-06

本文档中的信息（包括引用的 URL 和其他 Internet 网站）如有变更，恕不另行通知。除非特别声明，本文档中提及的示例公司、组织、产品、域名、电子邮件地址、徽标、人物、地点和事件纯属虚构，无意与任何真实的公司、组织、产品、域名、电子邮件地址、徽标、人物、地点或事件有任何关联，也不应进行这方面的推断。遵守所有适用的版权法是用户的责任。在不限制版权许可的权利的前提下，未经 Microsoft Corporation 的明确书面许可，无论出于何种目的，均不得以任何形式或借助任何手段（包括电子、机械、影印、录制或其他形式）复制或传播本文档的任何部分，或将其存储或引入检索系统。

Microsoft 的专利、专利申请、商标、版权或其他知识产权可能涉及本文档中的版权问题。除非 Microsoft 的书面许可协议做出了明确规定，提供本文档并不意味着赋予您这些专利、专利申请、商标、版权或其他知识产权的任何许可。

© 2004-2006 Microsoft Corporation。保留所有权利。

Microsoft、Active Directory、ActiveSync、ActiveX、MSDN、Outlook、SharePoint、Visual C++、Win32、Windows、Windows NT、Windows Server 以及 Windows Server System 是 Microsoft Corporation 在美国和/或其他国家/地区的注册商标或商标。

本文档中提到的真实公司和产品名称可能是其各自所有者的商标。