Microsoft Exchange Server Best Practices Analyzer 工具概觀

主題上次修改日期： 2005-07-08

Microsoft® Exchange Server Best Practices Analyzer 工具是一種診斷工具，可執行下列功能：

  • 可從 Microsoft Exchange Server 組織收集組態資訊。

  • 可對 Exchange Server 組織執行特定的測試。

  • 可報告測試結果。

您可以使用 Exchange Server Best Practices Analyzer 來執行下列工作：

  • 主動確認是否已依據建議的最佳作法來設定組態。

  • 報告所有與預設設定不同的設定。

  • 報告 Exchange Server 組織中最新的變更。此功能可協助您診斷因 Exchange Server 組織中的變更所造成的問題。

  • 協助您識別狀況不良的 Exchange Server 組織中的問題來源。

  • 將一組伺服器與基準線組態做比較，並報告所有組態差異。

附註：
Exchange Server Best Practices Analyzer 只能針對具有 last modified time 內容的組態物件，報告最近的變更。

Exchange Server Best Practices Analyzer 會使用組態檔案來判定要從 Exchange Server 組織收集哪些資訊。它會將收集來的資料與一組預先定義的 Exchange Server 設定及組態規則進行比較。接著它會報告問題。

針對每個問題，Exchange Server Best Practices Analyzer 會提供以下三種資料：

  • 在掃描 Exchange Server 組織時找到了哪些項目。

  • 建議的組態。

  • 提供問題與相關主題的詳細資訊連結。

若您對 Exchange Server Best Practices Analyzer 有任何意見，歡迎不吝指教。您可以透過下列幾種方式傳送您的意見反應：

  • Microsoft 公用新聞群組 Exchange Server Best Practices Analyzer 工具開發小組的成員時常會監視 news.microsoft.com 上的 microsoft.public.exchange.tools 新聞群組。若需有關如何參與此新聞群組及其他 Microsoft 新聞群組的詳細資訊，請參閱「Microsoft Exchange Server Best Practices Analyzer 工具」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33938) 及「Microsoft 產品支援新聞群組」網站 (http://go.microsoft.com/fwlink/?LinkId=50219)。

  • 對 Exchange Server Best Practices Analyzer 文件的回應 若您對 Exchange Server Best Practices Analyzer 所附的文件及文章有任何意見、問題或回應，請將您的回應傳送至 exbpadoc@microsoft.com。


安裝 Microsoft Exchange Server Best Practices Analyzer 工具

安裝 Microsoft Exchange Server Best Practices Analyzer 工具 |
 | 請參閱
Microsoft Exchange Server Best Practices Analyzer 工具概觀 >

主題上次修改日期： 2006-02-08

若要安裝 Microsoft® Exchange Server Best Practices Analyzer 工具，請在要執行工具的電腦上執行 Microsoft Installer 檔案 (ExBPA.msi)。安裝程式會建立 ExBPA 目錄 (預設是位在 <system drive>\Program Files\ 中)，並將必要檔案複製到這個新的目錄中。

選擇要安裝的電腦

建議要安裝 Exchange Server Best Practices Analyzer 的電腦是固定的管理站。若需有關如何安裝及使用固定管理站的詳細資訊，請參閱《Exchange Server 2003 系統管理手冊》(英文) (http://go.microsoft.com/fwlink/?linkid=21769)。

若要將工具安裝在 Exchange 組織以外的電腦上，則需要明確設定用來登入 Active Directory® 目錄服務及 Exchange 伺服器的使用者名稱及密碼。若需如何設定用來執行掃描之使用者帳戶認證的詳細資訊，請參閱 Microsoft Exchange Server Best Practices Analyzer 工具的權限。

您也可將工具安裝在 Exchange 伺服器上。工具可在 Exchange 伺服器上執行；不過，它會消耗大量的系統資源 (尤其是 CPU 及 RAM)。因此，建議將工具安裝在另一部電腦上。如果要將工具安裝在 Exchange 伺服器上，則建議只掃描該 Exchange 伺服器。

檢查更新

啟動 Exchange Server Best Practices Analyzer 時，它會判定 www.microsoft.com 中是否有內含最佳作法規則的新檔案。如果有新的版本，則可下載那個新的檔案。您必須以系統管理員的身分登入電腦，才能下載檔案。如果選擇不要下載新檔案，或如果工具無法存取網際網路，則它會嘗試使用工具執行電腦上的檔案複本。

附註：
如果需要 Proxy 驗證才能存取網際網路，則工具會無法存取所要下載的新版組態檔案。不過，您可以手動將檔案從 www.microsoft.com 複製到本機電腦。
若要手動複製新版組態檔案

  1. 在工具的安裝目錄中，重新命名現有的 ExBPA.Config.xml 檔案。

  2. 在網頁瀏覽器中瀏覽至 http://go.microsoft.com/fwlink/?LinkId=34290。

  3. 下載自我解壓縮套件，將新檔案解壓縮到安裝該工具的目錄 (通常是 C:\Program Files\ExBPA)。

請參閱

概念

Microsoft Exchange Server Best Practices Analyzer 工具對於效能的影響
Microsoft Exchange Server Best Practices Analyzer 工具的權限

其他資源

在 Microsoft Exchange Server Best Practices Analyzer 工具中設定掃描

© 2007 Microsoft Corporation. 著作權所有，並保留一切權利。


執行 Microsoft Exchange Server Best Practices Analyzer 工具的必要條件
Microsoft Exchange Server Best Practices Analyzer 工具概觀 >

主題上次修改日期： 2005-07-08

Exchange 組織中的電腦必須符合數個必要條件，才可正確執行 Microsoft® Exchange Server Best Practices Analyzer 工具。如果未符合這些必要條件，雖然工具在大部份情況下仍可執行，但可能會有部份功能無法執行，或是執行的效能會比較差。

本節中的各個主題包含執行 Exchange Server Best Practices Analyzer 所需之必要權限的相關資訊，以及 Exchange 組織及執行工具之電腦的所有其他必要條件。＜其他必要條件＞主題也會列出執行工具的支援環境。

在本節中

Microsoft Exchange Server Best Practices Analyzer 工具的權限

Microsoft Exchange Server Best Practices Analyzer 工具的其他必要條件


Microsoft Exchange Server Best Practices Analyzer 工具的權限

Microsoft Exchange Server Best Practices Analyzer 工具的權限 |
 | 請參閱
Microsoft Exchange Server Best Practices Analyzer 工具概觀 > 執行 Microsoft Exchange Server Best Practices Analyzer 工具的必要條件 >

主題上次修改日期： 2005-07-08

只有當您是以具有所有必要權限的認證來執行 Microsoft Exchange Server Best Practices Analyzer 工具時，此工具才可以存取 Active Directory® 目錄服務及 Exchange 伺服器。

權限

若要順利執行 Exchange Server Best Practices Analyzer，您必須具有下列權限：

  • 網域系統管理員或 Active Directory 伺服器上 Builtin\Administrators 群組的成員，以在網域控制站及通用類別目錄伺服器上列舉 Active Directory 資訊並呼叫 Microsoft Windows® Management Instrumentation (WMI) 提供者。

  • 每部 Exchange 伺服器上的本機系統管理員群組成員，以呼叫 WMI 提供者並存取登錄和 Metabase。

  • 在 Exchange 組織中，至少委派到 Exchange 系統檢視權限。

如果是要使用權限不足的帳戶來登入要執行 Exchange Server Best Practices Analyzer 的電腦，則有二個選擇：

  1. 使用 runas 命令，利用具有足夠權限的帳戶來開啟 [命令提示字元] 視窗，然後從此視窗啟動工具。此命令的語法如下：

    runas /netonly /user:<domain>\<username> exbpa.exe

  2. 在工具的 [連線到 Active Directory] 頁面上，設定所要使用的帳戶認證。按一下 [顯示進階登入選項] 以展開選項。您可以輸入兩個帳戶，一個是用來連線至 Active Directory 的帳戶，而另一個是用來連線至 Exchange 伺服器的帳戶。如果有任何一個帳戶沒有指定，就會使用執行此工具時所使用的帳戶。

請參閱

概念

Microsoft Exchange Server Best Practices Analyzer 工具的其他必要條件

© 2007 Microsoft Corporation. 著作權所有，並保留一切權利。


Microsoft Exchange Server Best Practices Analyzer 工具的其他必要條件

Microsoft Exchange Server Best Practices Analyzer 工具的其他必要條件 |
 | 請參閱
Microsoft Exchange Server Best Practices Analyzer 工具概觀 > 執行 Microsoft Exchange Server Best Practices Analyzer 工具的必要條件 >

主題上次修改日期： 2007-05-16

除了使用具有 Active Directory® 目錄服務必要權限的帳戶，及具有 Exchange 伺服器必要權限的帳戶來執行 Microsoft® Exchange Server Best Practices Analyzer 工具外，您還需要檢查順利執行工具所需的一些其他必要條件。

必要條件

若要讓 Exchange Server Best Practices Analyzer 正確執行，必須符合下列條件：

  • 執行 Exchange Server Best Practices Analyzer 的電腦上必須已安裝 .NET Framework 1.1。

  • 執行 Exchange Server Best Practices Analyzer 的電腦上必須已安裝「網際網路資訊服務 (IIS) 通用檔案」，以允許進行遠端 Metabase 存取。

    附註：
    如果已安裝「網際網路資訊服務」、「網際網路資訊服務管理」或「Exchange 系統管理員」，則「網際網路資訊服務通用檔案」應該會自動安裝。
  • 執行 Exchange Server Best Practices Analyzer 的電腦必須至少要有 256 MB 的隨機存取記憶體 (RAM)。此記憶體量可用來掃描最多 50 部 Exchange 伺服器。Exchange 組織中每增加 50 部伺服器 (最多)，執行工具的電腦上就需要額外的 256 MB 的 RAM。例如，如果組織中有 50 到 100 部 Exchange 伺服器，則執行工具的電腦上就必須至少有 512 MB 的 RAM。如果組織中有 100 到 150 部 Exchange 伺服器，則執行工具的電腦上就必須至少有 768 MB 的 RAM。

  • 在執行 Exchange Server Best Practices Analyzer 的電腦上，至少要有 2 MB 的磁碟空間來存放組織中每部要掃描的 Exchange 伺服器的資料。

  • 拓撲中必須已安裝 Active Directory (不論是安裝在 Microsoft Windows® 2000 Server 還是 Windows Server™ 2003 上)。

  • Active Directory 內至少要安裝一個 Exchange 2003 或 Exchange 2000 伺服器。

  • Active Directory 伺服器及 Exchange 伺服器上都必須執行 Remote Registry (RemoteRegistry) 服務。

  • Active Directory 伺服器及 Exchange 伺服器上都必須執行 Windows Management Instrumentation (WMI) (winmgmt) 服務。

  • 所有 Exchange 2000 Server 或更新版本的 Exchange 伺服器上都必須執行 Exchange Management (MSExchangeMGMT) 服務。

  • 登入並執行 Exchange Server Best Practices Analyzer 的使用者必須具有執行工具之資料夾的讀取/寫入權限。

  • 若要收集主匯流排介面卡 (HBA) 資訊，則想要從中收集 HBA 資訊的所有伺服器上都必須安裝 HBA API 相容驅動程式及遠端服務 (如 Emulex 的 HBAnywhere 服務)。此外，將要執行 Exchange Best Practices Analyzer 的電腦，以及安裝 HBA 的目標伺服器上都必須執行 HBA API 受管理物件格式 (MOF) 安裝程式。如果未安裝 HBA API 相容驅動程式及遠端服務，則仍會執行 Exchange Server Best Practices Analyzer，但不會收集 HBA 資訊。

支援的環境

Exchange Server Best Practices Analyzer 可在下列環境中執行：

  • Windows 2000 Server SP3 及更新版本上的 Exchange Server 5.5

附註：
Exchange Server 5.5 伺服器必須是 Active Directory 中顯示之混合模式 Exchange 組織中的一部分。
  • Windows 2000 Server SP3 和更新版本上的 Exchange 2000 Server (所有 Service Pack)

附註：
Windows 2000 Server 及 Exchange 2000 Server 都不支援大部分的 WMI 提供者。資料收集及分析可能會受限制。
  • Windows 2003 Server SP3 和更新版本上的 Exchange 2000 Server (所有 Service Pack)

附註：
Windows 2000 Server 不支援大部分的 WMI 提供者。資料收集及分析可能會受限制。
  • Windows Server 2003 上的 Exchange Server 2003 (所有 Service Pack)

  • Windows Server 2003 上的 Exchange Server 2007

請參閱

概念

Microsoft Exchange Server Best Practices Analyzer 工具的權限

© 2007 Microsoft Corporation. 著作權所有，並保留一切權利。


使用 Microsoft Exchange Server Best Practices Analyzer 工具掃描 Exchange 組織
Microsoft Exchange Server Best Practices Analyzer 工具概觀 >

主題上次修改日期： 2005-07-08

Microsoft® Exchange Server Best Practices Analyzer 工具會掃描 Exchange 組織內位於選取範圍內的電腦。它會將組態設定與一組建議的最佳作法比較，並報告結果。

進行掃描時，進度列會動態更新，以顯示整個掃描作業的完成百分比。百分比是依據下列項目：特定類型掃描所需要收集的資料量，以及位於掃描範圍內的伺服器數目。

「預估剩餘時間」會動態更新，且每隔 60 秒會重新計算。Exchange Server Best Practices Analyzer 是多執行緒作業，可一次掃描多個 Exchange 伺服器。Exchange Server Best Practices Analyzer 最多可同時掃描 10 個系統管理群組中的電腦，且最多可同時掃描 50 部 Exchange 伺服器。其他伺服器則放在佇列中，並在其他伺服器完成時進行掃描。

[伺服器掃描詳細資料] 視窗顯示每部選取要進行掃描之伺服器的狀態。伺服器可以處於下列三種狀態：擱置、進行中或已完成。如果伺服器是處於進行中狀態，則進度列會顯示它的完成百分比。在伺服器進入「已完成」狀態後，會出現圖示表示 Exchange Server Best Practices Analyzer 是否可以存取伺服器。綠色核取記號圖示表示 Exchange Server Best Practices Analyzer 可以存取伺服器，也未在掃描期間失敗或超過逾時閥值。黃色警告圖示表示 Exchange Server Best Practices Analyzer 能夠存取伺服器，但是在掃描期間失敗或超過逾時閥值。紅色 X 圖示表示 Exchange Server Best Practices Analyzer 無法存取伺服器，所以未掃描伺服器。

除了從 Exchange 伺服器收集資料外，Exchange Server Best Practices Analyzer 也必須從 Active Directory® 目錄服務收集資料。從 Active Directory 收集資料的進度，會顯示在進度列及頁面頂端的 [預估剩餘時間] 中，但不會顯示在 [伺服器掃描詳細資料] 視窗中。因此，即使所有 Exchange 伺服器都是處於擱置或已完成狀態，掃描的整體狀態也可能是進行中。

Exchange Server Best Practices Analyzer 完成對所有選取伺服器的掃描後，您便可以開啟 [檢視最佳作法報告] 頁面。

在本節中

在 Microsoft Exchange Server Best Practices Analyzer 工具中設定掃描

Microsoft Exchange Server Best Practices Analyzer 工具的網路及權限檢查

設定 Microsoft Exchange Server Best Practices Analyzer 工具


在 Microsoft Exchange Server Best Practices Analyzer 工具中設定掃描

在 Microsoft Exchange Server Best Practices Analyzer 工具中設定掃描 |
 | 請參閱
Microsoft Exchange Server Best Practices Analyzer 工具概觀 > 使用 Microsoft Exchange Server Best Practices Analyzer 工具掃描 Exchange 組織 >

主題上次修改日期： 2005-07-08

啟動 Microsoft® Exchange Server Best Practices Analyzer 工具時，必須設定掃描參數。您必須先選擇是否想要下載最佳作法規則的最新更新。若需有關檢查更新及下載最新更新檔案的詳細資訊，請參閱安裝 Microsoft Exchange Server Best Practices Analyzer 工具。

接著，您必須選取動作。在 [歡迎使用] 頁面上，選擇 [選取相關選項以進行新的掃描] 或 [選取要檢視的最佳作法報告]。如果您選擇檢視現有的報告，則可從本機儲存的輸出檔清單中選取檔案。您也可以從另一個位置匯入輸出檔，而不選擇本機儲存的輸出檔。選擇輸出檔後，即可檢視該檔案中的報告。若需有關報告的詳細資訊，請參閱瞭解 Microsoft Exchange Server Best Practices Analyzer 工具輸出。

如果選擇 [選取相關選項以進行新的掃描]，您必須連線到 Active Directory® 目錄服務，並執行新的掃描。在預設的情況下，Exchange Server Best Practices Analyzer 會偵測距離最近的 Active Directory 伺服器。您可以連線到此伺服器，也可以藉由鍵入不同伺服器的名稱而連線到不同的 Active Directory 伺服器。

Exchange Server Best Practices Analyzer 預設會使用執行工具時所使用的帳戶。若要使用不同的帳戶來登入 Active Directory 或 Exchange 伺服器，請按一下 [顯示進階登入選項] 以展開選項。在所展開視窗的上半部，您可輸入用來登入 Active Directory 的帳戶認證。在所展開視窗的下半部，您可輸入用來登入 Exchange 伺服器的帳戶認證。

您可以使用相同的帳戶登入 Active Directory 及 Exchange 伺服器，或可以使用不同的帳戶登入 Active Directory 及 Exchange 伺服器。如果您保留展開視窗的上半部或下半部為空白，Exchange Server Best Practices Analyzer 會使用它執行時所用的帳戶來登入。

請參閱

概念

安裝 Microsoft Exchange Server Best Practices Analyzer 工具
Microsoft Exchange Server Best Practices Analyzer 工具的權限
設定 Microsoft Exchange Server Best Practices Analyzer 工具

其他資源

瞭解 Microsoft Exchange Server Best Practices Analyzer 工具輸出
Microsoft Exchange Server Best Practices Analyzer 工具的網路及權限檢查

© 2007 Microsoft Corporation. 著作權所有，並保留一切權利。


Microsoft Exchange Server Best Practices Analyzer 工具的網路及權限檢查

Microsoft Exchange Server Best Practices Analyzer 工具的網路及權限檢查 |
 | 請參閱
Microsoft Exchange Server Best Practices Analyzer 工具概觀 > 使用 Microsoft Exchange Server Best Practices Analyzer 工具掃描 Exchange 組織 >

主題上次修改日期： 2005-07-08

開始掃描前，Microsoft® Exchange Server Best Practices Analyzer 工具會執行網路及權限檢查，以確定指定的帳戶認證是有效的，且工具可連線到 Active Directory® 目錄服務。如果上述其中一項檢查失敗，則會回到 [連線到 Active Directory] 頁面，您可在此頁面中重新輸入執行 Active Directory 之伺服器的名稱，以及用來登入 Active Directory 及 Exchange 伺服器的認證。

請參閱

概念

Microsoft Exchange Server Best Practices Analyzer 工具的權限
設定 Microsoft Exchange Server Best Practices Analyzer 工具

其他資源

在 Microsoft Exchange Server Best Practices Analyzer 工具中設定掃描

© 2007 Microsoft Corporation. 著作權所有，並保留一切權利。


設定 Microsoft Exchange Server Best Practices Analyzer 工具

設定 Microsoft Exchange Server Best Practices Analyzer 工具 |
 | 請參閱
Microsoft Exchange Server Best Practices Analyzer 工具概觀 > 使用 Microsoft Exchange Server Best Practices Analyzer 工具掃描 Exchange 組織 >

主題上次修改日期： 2006-10-10

執行掃描前，您必須執行下列最後的步驟：

  1. 設定掃描標籤。

  2. 設定範圍。

  3. 設定掃描類型。

  4. 設定網路速度。

在您指定標籤、範圍、掃描類型及網路速度後，Microsoft® Exchange Server Best Practices Analyzer 工具即會開始掃描。

設定掃描標籤

若要設定掃描標籤，請在 [開始新的最佳作法掃描] 頁面中的 [輸入掃描的識別標籤] 方塊中，輸入唯一的標籤。若您稍後選擇要檢視現有的報告，您可以在根據 [輸入掃描的識別標籤] 方塊中所輸入的標籤來識別報告。

您可以透過兩種方式來檢視現有的報告：

  • 在 [歡迎使用] 頁面上，選擇 [選取要檢視的最佳作法報告]。

  • 在 [Exchange Server Best Practices Analyzer] 視窗的左功能窗格中，選擇 [選取要檢視的掃描]。

設定掃描範圍

若要指定掃描的範圍，請在 [開始新的最佳作法掃描] 頁面上，選取想要掃描的伺服器或系統管理群組。

您有三種範圍可以選擇：

  • 您可以選取整個 Exchange Server 組織。

  • 您可以選取一或多個系統管理群組。

  • 您可以選取 Exchange Server 組織中任何系統管理群組的一或多部伺服器。

選擇掃描類型

接著，您必須選擇掃描類型。有三種掃描類型可供選擇：

  • 狀況檢查

  • 狀況/效能檢查

  • 連線測試

  • 基準線

[狀況檢查] 掃描會執行完整的掃描。它會檢查是否有錯誤、警告、非預設組態、最近的變更，以及其他組態資訊。若您要檢查 Exchange Server 組織的狀況，或要進行特定問題的疑難排解，則應執行 [狀況檢查] 掃描。

[狀況/效能檢查] 掃描會執行 [狀況檢查] 掃描，然後在兩個小時內進行 Exchange Server 效能計數器範圍的抽樣。

[連線測試] 掃描會針對範圍內所指定的每個 Exchange Server 執行網路連線及權限的測試。如果您懷疑有權限存取權方面的問題，或如果拓撲中有防火牆，則應執行 [連線測試] 掃描。如果 [連線測試] 順利完成，即可執行 [狀況檢查] 掃描。

[連線測試] 掃描的執行速度很快。Exchange Server Best Practices Analyzer 會查詢一個登錄參數及兩個 Microsoft Windows® Management Instrumentation (WMI) 類別。第一個 WMI 查詢會驗證 WMI 存放庫存取權。第二個 WMI 查詢會查詢 Exchange Server 所使用的 Active Directory® 目錄服務伺服器。掃描完範圍中指定的所有 Exchange Server 之後，Exchange Server Best Practices Analyzer 會嘗試驗證 Exchange Server 所使用之 Active Directory 伺服器的網路連線及權限。

[基準線] 掃描會執行下列工作：

  • 選取內容。

  • 設定這些內容的基準線值。

  • 然後它會選取要比較這些內容的伺服器。

[基準線] 掃描會檢查是否有與您設定的基準線值不同的項目。在 [基準線] 掃描報告中，會將所選伺服器上內容值與所選內容的來源值不同的所有內容，識別為基準線不符。

若要執行基準線掃描

  1. 在 [開始新的最佳作法掃描] 頁面的 [選取要執行的掃描類型] 功能表上，選取 [基準線]，然後按一下 [基準線選項]。

  2. 在 [基準線選項] 功能表上，選取現有的掃描或鍵入新的標籤。

  3. 按一下 [來源值] 箭頭，展開基準線內容的清單。

    • 這些內容為 ExBPA.config.xml 檔案所收集的內容。清除或設定核取方塊，選擇要在「基準線」掃描中比較哪些內容。內容值為 ExBPA.config.xml 檔案中的預設值。在文字方塊中設定這些值。

  4. 按一下 [測試物件] 箭頭，展開要掃描的伺服器清單。

  5. 選取要掃描有無基準線不符的所有伺服器。

設定網路速度

選取掃描類型後，您必須設定網路速度。若要設定網路速度，請選取下列四個選項之一：

  • 快速 LAN

  • LAN

  • 快速 WAN

  • WAN

您可以使用網路速度設定來評估完成掃描所需的時間。您也可以使用網路速度設定來進行逾時值的設定。

掃描期間，Exchange Server Best Practices Analyzer 會在指定的時間內等候伺服器的回應。如果在指定的逾時內未收到回應，Exchange Server Best Practices Analyzer 會繼續完成掃描，而不是繼續等候。在較慢的網路中，因為網路延遲會比較長，所以這個指定的逾時會比較久。建議您針對此參數選取拓撲中最慢的連結，以便 Exchange Server Best Practices Analyzer 不致太快逾時。

執行掃描

在您完成所有掃描選項的設定後，可以選擇 [開始掃描] 或 [排定掃描]。如果您選擇 [開始掃描]，則 Exchange Server Best Practices Analyzer 會立即開始掃描 Exchange 組織。如需詳細資訊，請參閱使用 Microsoft Exchange Server Best Practices Analyzer 工具掃描 Exchange 組織。

如果選擇 [排定掃描]，則會出現 [排定掃描] 頁面。若要排程掃描，您必須先輸入必要的安全性認證，然後選取 [啟用掃描排程] 方塊。若需輸入所需安全性認證的詳細資訊，請參閱在 Microsoft Exchange Server Best Practices Analyzer 工具中設定掃描。

接著，您必須設定開始時間。開始時間是指排定的掃描首次執行的日期與時間。

最後，您必須設定頻率。頻率是指排定的掃描執行的頻率。若要關閉 Exchange Server Best Practices Analyzer，請按一下 [結束此工具]。Exchange Server Best Practices Analyzer 執行與否，對排定的掃描不會有執行上的影響。如果結束 Exchange Server Best Practices Analyzer，排定的掃描會在背景中依據指定的日期與時間執行。若要檢視排定掃描的報告，您必須重新啟動 Exchange Server Best Practices Analyzer。

請參閱

概念

輸出資訊的類型

其他資源

使用 Microsoft Exchange Server Best Practices Analyzer 工具掃描 Exchange 組織

© 2007 Microsoft Corporation. 著作權所有，並保留一切權利。


進階組態
Microsoft Exchange Server Best Practices Analyzer 工具概觀 > 使用 Microsoft Exchange Server Best Practices Analyzer 工具掃描 Exchange 組織 >

主題上次修改日期： 2006-10-26

Microsoft® Exchange Server Analyzer 工具具有下列可設定的登錄參數：

位置 | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
值 | OpenRelayTest
類型 | REG_DWORD
描述 | 如果不想要 Best Practices Analyzer 測試每一個 SMTP 伺服器是否有開放式轉送功能，請設為 0x0。如果遺失此參數，Best Practices Analyzer 將預設為 0x1。

位置 | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
值 | OpenRelayTestSender
類型 | REG_SZ
描述 | 將此位址設為執行開放式轉送測試時您要對 [MAIL FROM:]使用的 SMTP 位址。如果遺失此參數，Best Practices Analyzer 將預設為 'ExBPA-OpenRelayTest@Fabrikam.com'。

位置 | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
值 | TopoCreateTimeoutSecs
類型 | REG_SZ
描述 | 將此位址設為執行 SMTP 郵件接受測試時您要對 [RCPT TO:]使用的 SMTP 位址。如果遺失此參數，Best Practices Analyzer 將預設為 'ExBPA-OpenRelayTest@Fabrikam.com'。

位置 | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
值 | SMTPTest
類型 | REG_DWORD
描述 | 如果不想要 Best Practices Analyzer 提交測試郵件給掃描中包括的每一個 SMTP 伺服器，請設為 0x0。如果遺失此參數，Best Practices Analyzer 將預設為 0x1。

位置 | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
值 | SMTPTestSender
類型 | REG_SZ
描述 | 將此位址設為執行開放式轉送測試時您要對 [MAIL FROM:]使用的 SMTP 位址。如果遺失此參數，Best Practices Analyzer 將預設為 'ExBPA-MailAcceptTest@Fabrikam.com'。

位置 | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
值 | T SMTPTestRecipient
類型 | REG_SZ
描述 | 將此位址設為執行 SMTP 郵件接受測試時您要對 [RCPT TO:]使用的 SMTP 位址。如果遺失此參數，Best Practices Analyzer 將預設為 SMTP 服務所定義的郵件管理員帳戶。


瞭解 Microsoft Exchange Server Best Practices Analyzer 工具輸出
Microsoft Exchange Server Best Practices Analyzer 工具概觀 >

主題上次修改日期： 2006-02-08

Microsoft® Exchange Server Best Practices Analyzer 工具報告會顯示掃描 Exchange 組織時所收集到資料的分析。您可以選取這三種類型的報告：清單報告、樹狀目錄報告及其他報告。

  • 清單報告包括：

    • 重大問題

    • 所有問題

    • 非預設設定

    • 最近的變更

    • 基準線

    • 資訊項目

  • 樹狀目錄報告包括：

    • 詳細檢視

    • 摘要檢視

  • 其他報告

    • 隱藏的項目

    • 執行時間記錄檔

清單報告

預設檢視是「重大問題清單」。這個重大問題清單只會顯示發現的錯誤。立即影響 Exchange 伺服器效能及可用性的錯誤即是重大問題。所有問題清單顯示錯誤、警告及最佳作法違規。非預設設定清單顯示自從安裝 Exchange 伺服器產品之後，對伺服器所做的變更。最近的變更清單顯示過去五天內，對伺服器所做的組態變更。這包括安裝 Service Pack 及其他更新。基準線清單顯示叢集中的節點之間的組態差異。

樹狀目錄報告

詳細檢視會顯示已由 Exchange Server Analyzer 工具收集到的所有組態設定。摘要檢視則會顯示在 Exchange 環境中發現的所有問題，並以階層表示。

其他報告

隱藏的項目報告會顯示 Exchange 系統管理員已從其他 Exchange Server Analyzer 報告選擇要遮罩的報告。如果未遮罩，這個清單中的項目可以併入其他報告。執行時間記錄檔報告則會顯示收集里程碑資訊，以及任何在收集處理程序期間所傳回的錯誤。

在重大問題清單、所有問題清單及非預設設定清單中，按一下任何錯誤或警告問題，即可查看說明。再按一下 [我想知道此問題更詳盡的資訊及其解決方式]，即可取得更詳細的資訊。

附註：
輸出資料 XML 檔案及掃描的記錄檔都是存放在 <system drive>\Documents and Settings\<user>\Application Data\Microsoft\ExBPA 中。

在本節中

輸出資訊的類型

解決及隱藏問題

檢視先前的 Microsoft Exchange Server Best Practices Analyzer 工具報告


輸出資訊的類型

輸出資訊的類型 |
 | 請參閱
Microsoft Exchange Server Best Practices Analyzer 工具概觀 > 瞭解 Microsoft Exchange Server Best Practices Analyzer 工具輸出 >

主題上次修改日期： 2006-09-29

Microsoft® Exchange Server Best Practices Analyzer 工具報告會顯示六種類型的資訊：

  • 錯誤

  • 警告

  • 非預設的組態

  • 最近的變更

  • 基準線不符

  • 最佳作法

  • 資訊

錯誤

「錯誤」表示需要變更才能解決的重大問題。例如，伺服器的執行個體當機或伺服器無法存取均是錯誤。

錯誤會出現在下列報告中：

  • 重大問題清單

  • 完整問題清單

  • 詳細檢視清單

  • 詳細檢視 - 完整問題清單

如果停用錯誤，則 Exchange Server Best Practices Analyzer 會將錯誤顯示在停用的問題清單中。

Exchange Server Best Practices Analyzer 會以紅色的 X表示錯誤 (圖 1)。

圖 1 錯誤圖示

代表錯誤狀態的圖示

警告

「警告」表示非建議最佳作法的問題。該問題可能需要變更才能解決，也可能是不需要在 Exchange Server 組織中進行變更的已知問題。例如，伺服器上未啟動的服務就是警告。

警告會出現在下列報告中：

  • 完整問題清單

  • 詳細檢視清單

  • 詳細檢視 - 完整問題清單

如果停用警告，則 Exchange Server Best Practices Analyzer 會將警告顯示在停用的問題清單中。

Exchange Server Best Practices Analyzer 會以黃色的警告符號來表示警告 (圖 2)。

圖 2 警告圖示

警告的圖示，帶有黑色驚嘆號的黃色三角形

非預設組態

「非預設組態」表示其預設值已變更的設定。如果 Exchange Server Best Practices Analyzer 判定非預設組態是錯誤或警告，則除了將它識別為非預設組態之外，還會在報告中的其他位置，以適當的錯誤符號或警告符號識別非預設組態。

非預設組態會出現在下列報告中：

  • 完整問題清單

  • 詳細檢視清單

  • 詳細檢視 - 完整問題清單

如果停用非預設組態，則 Exchange Server Best Practices Analyzer 會將非預設組態顯示在停用的問題清單中。

Exchange Server Best Practices Analyzer 以文件指標符號來表示非預設組態 (圖 3)。

圖 3 非預設組態圖示

非預設內容的圖示

最近的變更

「最近的變更」指出在最近 5 天內所變更的設定。Exchange Server Best Practices Analyzer 只能將具有 last modified time 屬性的那些設定識別為最近的變更。如果 Exchange Server Best Practices Analyzer 判定最近的變更設定是錯誤、警告或非預設組態，則除了將它識別為最近的變更之外，還會在報告中的其他位置，以適當的錯誤符號、警告符號或非預設組態符號識別最近的變更。

最近的變更會出現在下列報告中：

  • 完整問題清單

  • 詳細檢視清單

  • 詳細檢視 - 完整問題清單

如果停用最近的變更，則 Exchange Server Best Practices Analyzer 會將最近的變更顯示在停用的問題清單中。

Exchange Server Best Practices Analyzer 會以鉛筆變更符號來表示最近的變更 (圖 4)。

圖 4 最近的變更圖示

最近變更的圖示

基準線不符

「基準線不符」表示其值與基準線伺服器上該設定值不同的設定。若要檢視基準線不符，則必須執行基準線掃描。如果 Exchange Server Best Practices Analyzer 判定基準線不符是錯誤、警告或非預設組態，則除了將其識別為基準線不符之外，還會以適當的錯誤符號、警告符號或非預設組態符號識別基準線不符。

基準線不符會出現在下列報告中：

  • 完整問題清單

  • 詳細檢視清單

  • 詳細檢視 - 完整問題清單

如果停用基準線不符，則 Exchange Server Best Practices Analyzer 會將基準線不符顯示在停用的問題清單中。

Exchange Server Best Practices Analyzer 會以剪貼簿及核取記號符號來表示基準線不符 (圖 5)。

圖 5 基準線不符圖示

代表 ExBPA 基準報告的圖示

最佳作法

「最佳作法」訊息表示未視為最佳作法的設定。最佳作法訊息不是警告，因為它們不影響 Exchange Server 組織的整體穩定性。最佳作法訊息是建議的動作。如果 Exchange Server Best Practices Analyzer 判定最佳作法訊息是非預設組態或最近的變更，則除了將它識別為最佳作法訊息之外，還會在報告中的其他位置，以適當的非預設組態符號或最近的變更符號識別最佳作法訊息。

最佳作法訊息會出現在下列報告中：

  • 完整問題清單

  • 詳細檢視清單

  • 詳細檢視 - 完整問題清單

如果停用最佳作法訊息，則 Exchange Server Best Practices Analyzer 會將最佳作法項目顯示在停用的問題清單中。

Exchange Server Best Practices Analyzer 會以藍色的驚嘆號來表示最佳作法訊息 (圖 6)。

圖 6 最佳作法圖示

最佳作法警示圖示

資訊

「資訊」訊息表示 Exchange Server Best Practices Analyzer 未在其他五種報告類型中提供的資訊。例如，資訊項目可以傳達 Active Directory® 目錄服務中 Exchange Server 物件的數目。

資訊訊息會出現在下列報告中：

  • 詳細檢視清單

  • 詳細檢視 - 完整問題清單

Exchange Server Best Practices Analyzer 會以小寫字母 "i" 符號表示資訊項目 (圖 7)。

圖 7 資訊圖示

資訊的圖示

請參閱

概念

設定 Microsoft Exchange Server Best Practices Analyzer 工具

其他資源

解決及隱藏問題

© 2007 Microsoft Corporation. 著作權所有，並保留一切權利。


解決及隱藏問題
Microsoft Exchange Server Best Practices Analyzer 工具概觀 > 瞭解 Microsoft Exchange Server Best Practices Analyzer 工具輸出 >

主題上次修改日期： 2006-02-08

在 Exchange 組織中執行 Microsoft® Exchange Server Best Practices Analyzer 工具後，即可將想要解決的問題列在報告中。如果按一下問題，則會顯示一份說明與三個選項：

  • 按下第一個選項可找出問題的詳細資訊及其解決方式。

  • 按一下第二個選項可隱藏此伺服器的這個問題。

  • 按一下第三個選項來隱藏所有伺服器的問題。在 [隱藏問題] 清單上的問題不會顯示在此報告或您檢視的任何其他報告的 [重要問題] 或 [所有問題] 清單中。若要查看您已加上遮罩的問題，請至 [隱藏問題] 清單。從 [隱藏問題] 清單上，您可以解除問題遮罩，使它們重新顯示在 [重要問題] 和 [所有問題] 清單中。

Exchange Server Best Practices Analyzer 不會變更 Exchange 組織來解決問題。它只會顯示如何解決問題的相關資訊。

在本節中

輸出資訊的類型


檢視先前的 Microsoft Exchange Server Best Practices Analyzer 工具報告

檢視先前的 Microsoft Exchange Server Best Practices Analyzer 工具報告 |
 | 請參閱
Microsoft Exchange Server Best Practices Analyzer 工具概觀 > 瞭解 Microsoft Exchange Server Best Practices Analyzer 工具輸出 >

主題上次修改日期： 2005-07-08

您可能不想執行新的掃描，而想使用 Microsoft® Exchange Server Best Practices Analyzer 工具來檢視先前掃描的報告。

若要檢視先前的報告

  1. 執行 ExBPA.exe 以啟動 Exchange Server Best Practices Analyzer。

  2. 選擇是否想要下載最新的規則。

  3. 在 [歡迎使用] 頁面上，選擇 [選取要檢視的最佳作法報告]。

  4. 從本機儲存的報告清單中選取想要檢視的報告。

    工具會建立 <系統磁碟機>\Documents and Settings\<使用者>\Application Data\Microsoft\ExBPA 中所存放檔案的清單。按一下報告時，工具會顯示關於此報告大小及範圍的更多資訊。按一下 [檢視此報告] 可查看完整的報告。

    也可以按一下頁面右上角的 [匯入報告]，從另一個位置匯入報告。如果 ExBPA.Config.xml 檔案的版本與匯入報告中用來收集資料的版本不符，則工具可能會在匯入後重新分析所匯入的報告。

  5. 檢視 Exchange Server Best Practices Analyzer 報告。

請參閱

其他資源

瞭解 Microsoft Exchange Server Best Practices Analyzer 工具輸出

© 2007 Microsoft Corporation. 著作權所有，並保留一切權利。


Microsoft Exchange Server Best Practices Analyzer 工具對於效能的影響

Microsoft Exchange Server Best Practices Analyzer 工具對於效能的影響 |
 | 請參閱
Microsoft Exchange Server Best Practices Analyzer 工具概觀 >

主題上次修改日期： 2005-07-08

Microsoft® Exchange Server Best Practices Analyzer 工具可能會影響 Exchange 組織中下列電腦的效能：

  • 執行 Exchange Server Best Practices Analyzer 的電腦

  • 執行 Active Directory® 目錄服務的伺服器

  • 工具所存取的 Exchange 伺服器

執行 Exchange Server Best Practices Analyzer 的電腦效能

Exchange Server Best Practices Analyzer 會在它所執行的電腦上使用下列資源：

  • 工具每掃描一個伺服器，就會使用 5 到 10 MB 的 RAM

  • 掃描 Exchange 組織期間，會使用 50% 到 75% 的 CPU

  • 使用 0.5 到 2 MB 的磁碟空間來存放可延伸標記語言 (XML) 資料

若需有關如何選擇電腦來安裝及執行 Exchange Server Best Practices Analyzer 的詳細資訊，請參閱安裝 Microsoft Exchange Server Best Practices Analyzer 工具。

Active Directory 伺服器的效能

Exchange Server Best Practices Analyzer 會在 Active Directory 伺服器上使用下列資源：

  • 工具存取 Active Directory 伺服器期間，會使用 25% 到 50% 的 CPU

附註：
工具偶爾會存取 Active Directory 伺服器，而每次存取間隔都平均持續 10 到 15 秒。若是極大型的 Exchange 組織，則間隔會較長。

Exchange 伺服器的效能

當 Exchange Server Best Practices Analyzer 掃描組織時，您不會發現 Exchange 伺服器有任何明顯的效能衰退。

附註：
工具從 Exchange 伺服器收集資料所需的時間，須視 Exchange 伺服器的負載及網路速度而定。在慢速網路上，工具可能需要 1 小時以上的時間來收集資料。而在快速網路上，工具可能僅需不到 10 分鐘的時間就可收集好資料。

請參閱

概念

安裝 Microsoft Exchange Server Best Practices Analyzer 工具

© 2007 Microsoft Corporation. 著作權所有，並保留一切權利。


使用命令列版本的 Microsoft Exchange Server Best Practices Analyzer 工具

使用命令列版本的 Microsoft Exchange Server Best Practices Analyzer 工具 |
 | 請參閱
Microsoft Exchange Server Best Practices Analyzer 工具概觀 >

主題上次修改日期： 2005-07-08

Microsoft® Exchange Server Best Practices Analyzer 工具備有命令列程式版本可供使用。命令列程式的執行檔是 ExBPACmd.exe，此檔案會跟圖形化使用者介面 (GUI) 版本一起安裝在 <systemdrive>\Program Files\ExBPA 目錄中。在某些情況下，您可能會想要使用命令列程式，而非 GUI 版本。例如，您可以使用命令列程式，建立指令碼來執行排定掃描。另一個例子是，Microsoft 產品支援服務可能會指示您執行命令列程式來協助您解決問題。

ExBPACmd.exe 語法

使用方式：ExBPACmd.exe [-cfg <config XML>] [-dat <data XML>] [-d <dc name>] [-n <name>] [-u <context> <[domain\]user> <password | *> ...][-rs <scope> <sub1> ...][-rc <cat>,...][-rl <level>] [-th <max threads>] [-to <timeout>] [-a] [-c] [-e] [-?]

-cfg：指定組態 XML 檔案，此檔決定將會擷取的設定。預設值是 ExBPA.Config.xml。

-dat：指定所要使用的資料 XML 檔案。如果目前目錄中沒有您指定的資料 XML 檔案名稱，工具將會使用指定的檔案名稱當作輸出檔名。如果您指定現有的資料 XML 檔案名稱，且執行的是分析掃描，則工具會讀取指定檔案中所收集的資料、分析該資料，並用掃描的輸出來覆寫指定的檔案。如果指定現有的資料 XML 檔案名稱，且執行的是收集掃描，則工具會用掃描的輸出來覆寫指定的檔案。

執行分析掃描時，預設值是 output.<ts>.xml，其中 <ts> 是目前目錄中最新的時間戳記。執行收集掃描時，預設值是 output.<ts>.xml，其中 <ts> 是新的時間戳記。

-d：指定用來存取 Active Directory® 目錄服務的網域控制站。工具預設會使用距離最近的 Active Directory 伺服器。

-n：提供工具所掃描的拓撲所屬之客戶的描述性名稱。

-u：針對每個內容提供不同的認證。

有效使用者內容：ADLOGON 適用於登入 Active Directory 的認證，而 EXLOGON 適用於登入 Exchange 伺服器的認證。

-rs：將掃描限制成只包括指定範圍內的物件。<sub> 欄位是指定範圍的值。如果未使用 -rs 參數，則掃描會包括整個 Exchange 組織。如果使用 -rs 參數，則可限制僅對個別系統管理群組或伺服器進行掃描。您可指定一或多個系統管理群組或一或多部伺服器。

有效範圍：AdminGroup、Server

-rc：將掃描限制成只包括符合指定類別的設定及物件。組態 XML 檔案會定義設定及物件的類別。如果使用 -rc 參數將掃描限制成一個類別，則掃描只會包括已定義該類別的設定。您可使用此參數來包括一個以上的類別。

可搭配 -rc 參數使用的有效類別會因組態 XML 檔案版本的不同而有差異。若要判定哪些是對您的組態 XML 檔案版本有效的類別，請執行 ExBPACmd.exe -?。

-rl：將掃描限制成只包括指定詳細資料層級或以下層級的設定及物件。組態 XML 檔案會定義設定及物件的詳細資料層級。預設值是 4。

可搭配 -rl 參數使用的有效層級會因組態 XML 檔案版本的不同而有差異。若要判定哪些是對組態 XML 檔案版本有效的層級，請執行 ExBPACmd.exe -?。

-th：設定同時執行的最大執行緒數目。預設值是 25。

-to：設定工具從 Exchange 組織的伺服器中收集資料時所等待的預設時間 (秒)。預設值是 300 秒。

-a：使用組態 XML 檔案中的規則來分析資料 XML 檔案。透過此選項，您可以藉由指定要使用的資料 XML 檔案，來分析現有的收集掃描輸出檔。您也可以透過此選項，藉由指定目前目錄中所沒有的資料 XML 檔案，或不指定資料 XML 檔案的方式，來收集並分析新的掃描資料。

-c：從組態 XML 檔案指定的 Exchange 組織中收集資料。工具不會使用組態 XML 檔案中的規則來分析資料，而只會收集資料。如果沒有指定要採用分析 (-a) 還是收集 (-c) 的作業步驟，則預設會啟用此選項。

-e：表示工具應移除組態 XML 檔案中標示為 NotForExport 之所有設定的值。

-? 顯示語法資訊。

請參閱

其他資源

使用 Microsoft Exchange Server Best Practices Analyzer 工具掃描 Exchange 組織

© 2007 Microsoft Corporation. 著作權所有，並保留一切權利。


Microsoft Exchange Server Analyzer - 文章

主題上次修改日期： 2006-10-06

本節中的文章對應於下列 Microsoft® Exchange Analyzer 產生的規則和結果訊息：

  • Exchange Best Practices Analyzer

  • Exchange Troubleshooting Assistant

Exchange Troubleshooting Assistant 可讓您存取下列功能：

  • Exchange 效能疑難排解員

  • Exchange 資料庫疑難排解員

  • Exchange 資料庫復原管理

  • Exchange 郵件流程疑難排解員

每一份文件說明了 Exchange Server Analyzer 可偵測到的單一錯誤、警告或非預設組態的訊息。

Microsoft Exchange Analyzer 網頁 (網址為 http://go.microsoft.com/fwlink/?linkid=34707) 包含目前版本的 Exchange Best Practice Analyzer 及 Exchange Troubleshooting Assistant 的下載。另外，此網頁包含系統需求的相關資訊，以及討論分析程式的新聞群組連結。

如果您是在無法使用 Exchange Best Practices 自動更新功能的環境中執行，可以存取 Microsoft Exchange Best Practices Analyzer Web Update Pack 網頁 (網址為 http://go.microsoft.com/fwlink/?linkid=34290)。您可以在這裡下載最新的組態及說明檔。

附註：
如果自動套用更新，您不必使用此下載。


Active Directory
Microsoft Exchange Server Analyzer - 文章 >

主題上次修改日期： 2005-11-17

本節中的文章詳細說明 Microsoft® Exchange Server Analyzer 工具會評估 Active Directory® 目錄服務的哪些方面。此外，這些文章也說明您可以採取哪些動作，來解決 Exchange Server Analyzer 發現的 Active Directory 相關錯誤、警告及非預設組態。


Active Directory 連接器伺服器當機或無法存取
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會使用遠端程序呼叫 (RPC)，從 Active Directory 連接器 (ADC) 伺服器上的下列登錄機碼來讀取 CurrentVersion 字串值：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

在執行 Microsoft Windows® 2000 Server 的電腦上，CurrentVersion 字串值應該是 5.0。在執行 Microsoft Windows Server™ 2003 的電腦上，此值應為 5.2。

若因為某些因素，Exchange Server Analyzer 無法讀取這個登錄值，就會顯示一則錯誤。

若要更正此錯誤

  1. 確定 ADC 伺服器已啟動，並已連線至網路。

  2. 使用 PING 命令來查看是否可與 ADC 伺服器連線。

  3. 若有裝置防火牆，檢查 RPC 通訊埠是否被封鎖。

  4. 確定 ADC 目錄伺服器上的 Remote Registry 服務已啟動。

  5. 檢查執行 Exchange Server Analyzer 之帳戶的權限，以確定該帳戶有足夠權限來讀取 ADC 伺服器上的登錄。

若需有關網路連線問題疑難排解的詳細資訊，請參閱下列文件：

  • 微軟知識庫文件 - 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

  • ＜Microsoft Exchange Server Best Practices Analyzer 工具疑難排解連線問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56285)


Active Directory 連接器伺服器未執行任何連線協定，而且是要移除的候選項目
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 msExchChildSyncAgreements 屬性的值，而此值代表在 Active Directory 連接器 (ADC) 伺服器上執行的連線協定。這個屬性是一個多重值字串，並且是在下列 Active Directory 物件中設定：CN=Active Directory Connector (ServerName),CN=Exchange Settings,CN=ServerName,CN=Servers,CN=SiteName,CN=Sites,CN=Configuration,DC=Domain,DC=com

Exchange Server Analyzer 會擷取這個屬性中的項目數 (計數)。如果計數是 0，表示未執行任何連線協定，而且會顯示一則警告。

如果判定是在其他 ADC 伺服器上執行所有必要的連線協定，則應移除或停用此伺服器上的 ADC 服務。執行未含任何連線協定的 ADC 服務不會造成問題。然而，建議使用的最佳作法是不要執行不需要的服務。因此，應在此 ADC 伺服器上停用 ADC 服務，或解除安裝 ADC 服務。

若要更正此警告

  1. 若要在執行 ADC 服務的伺服器上停用 ADC 服務，請以滑鼠右鍵按一下桌面上的 [我的電腦]，再按 [管理]。

  2. 展開 [服務及應用程式] 節點，再按一下 [服務] 節點。

  3. 在右窗格中，對 [Microsoft Active Directory Connector] 按一下滑鼠右鍵，再按一下 [內容]。

  4. 將 [啟動類型] 變更為 [已停用]。下次啟動電腦時，便不會啟動 ADC 服務。

  5. 按一下 [套用]，再按一下 [確定]。

如果決定要解除安裝 ADC 服務，您可以使用 Microsoft Exchange 2000 Server 或 Exchange Server 2003 CD 來執行此作業。移至 \ADC\I386 資料夾，並對 Setup.exe 程式連按兩下。遵循提示以解除安裝 ADC 服務。

若需 Active Directory 連接器的相關資訊，請參閱下列 Microsoft 支援服務網路廣播：

  • ＜Support Webcast:Active Directory 連接器簡介＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325300)

  • ＜Support Webcast:Microsoft 進階 Active Directory 連接器＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325221)

  • 若需安裝及設定 Active Directory 連接器的相關資訊，請參閱微軟知識庫文件 - 312632＜HOW TO:Install and Configure the Active Directory Connector in Exchange 2000 Server＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=312632)。


Active Directory 連接器伺服器不是執行 Windows 2000 Server 最新的 Service Pack
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會檢查 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Active Directory 連接器 (ADC) 伺服器上的 ServicePackMajorVersion 機碼值。Exchange Server Analyzer 也會檢查下列登錄項目，以判定在 ADC 伺服器上執行的 Windows 版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

如果 Exchange Server Analyzer 判定 ADC 伺服器正在執行 Microsoft Windows 2000 Server 作業系統，但未執行 Windows 2000 Server Service Pack 4 (SP4)，就會顯示警告。

Microsoft 建議的最佳作法，是對 Exchange 部署 (包括 ADC 伺服器) 中的所有軟體執行最新的 Service Pack。

若要更正此錯誤

  1. 將此 ADC 伺服器及任何其他執行 Windows 2000 Server 作業系統的伺服器更新為 SP 4，並且從 Windows Update 安裝最新的 Hotfix 及更新。

  2. 將所有其他執行 Windows 2000 Server 作業系統的 Exchange Server 電腦更新為最新的 Service Pack 及彙總套件。

若需有關取得及安裝 Windows 2000 Server 作業系統之 Service Pack 的詳細資訊，請參閱 http://go.microsoft.com/fwlink/?LinkId=18353 (英文)。

若需有關取得及安裝 Exchange Server Service Pack 及彙總套件的詳細資訊，請參閱 http://go.microsoft.com/fwlink/?LinkId=21573 (英文)。


Active Directory 連接器伺服器可能已超載
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 msExchChildSyncAgreements 屬性的值，該值代表在 Active Directory 連接器 (ADC) 伺服器上執行的連線協定。這個屬性是一個多重值字串，並且是在下列 Active Directory 物件中設定：CN=Active Directory Connector (ServerName),CN=Exchange Settings,CN=ServerName,CN=Servers,CN=SiteName,CN=Sites,CN=Configuration,DC=Domain,DC=com

Exchange Server Analyzer 會擷取這個屬性中的項目數 (計數)。如果此計數大於 80，就會顯示一則警告。

建議每一個 ADC 伺服器執行的連線協定數目在 80 以下。如果有其他 ADC 伺服器未主控所建議之數目上限的連線協定，請將部分連線協定從這部伺服器移至那部 ADC 伺服器。如果沒有其他 ADC 伺服器，請在另一部執行 Microsoft Windows® 2000 Server 或 Windows Server™ 2003 的電腦上，安裝 Microsoft Exchange 2000 Server 或 Exchange Server 2003 所包含的 ADC 程式。

請注意，當您將某個連線協定從一部 ADC 伺服器移至另一部伺服器時，該特定連線協定的核心屬性不變。例如，用於複寫的來源及目的容器以及設定要複寫的資料，仍然保持不變。移動某個連線協定時，只有執行該連線協定的 ADC 伺服器會變更。

若要更正此警告

  1. 依序按一下 [開始] 及 [程式集]，並指向 [系統管理工具] 後，再按 [Active Directory 連接器管理]，以開啟 [ADC 管理] 主控台。

  2. MMC 主控台的左窗格會顯示執行 ADC 服務的伺服器清單。選取要移動之連線協定所在伺服器的 ADC。

  3. MMC 主控台的詳細資料窗格會顯示您選取之 ADC 伺服器上主控的連線協定。

  4. 在要移動的連線協定上按一下滑鼠右鍵，然後按一下 [內容]。

  5. 在 [一般] 索引標籤上，於 [請選取執行連線協定的伺服器] 下拉清單中，選取要執行此連線協定的伺服器，然後按一下 [確定]。

  6. 在 [連線身分 (Windows 伺服器)] 下面，輸入 ADC 服務帳戶名稱及密碼，然後按一下 [確定]。

  7. 在 [連線身分 (Exchange 伺服器)] 下面，輸入 Exchange 服務帳戶及密碼，然後按一下 [確定]。

若需有關移動連線協定的詳細資訊，請參閱微軟知識庫文件 - 326060＜XADM：如何將連線協定移至其他伺服器＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=326060)。

若需有關在其他伺服器上安裝 Exchange 2000 Server ADC 程式的詳細資訊，請參閱微軟知識庫文件 - 312632＜如何在 Exchange 2000 Server 中安裝及設定 Active Directory 連接器＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=312632)。

若需有關在其他伺服器上安裝 Exchange Server 2003 ADC 程式的詳細資訊，請參閱《Exchange Server 2003 部署手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47569)。


要求 Active Directory 連接器軟體更新
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2006-10-10

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Active Directory 連接器 (ADC) 檔案 Adc.exe 的 Version 機碼值。Version WMI 機碼表示此檔案的組建編號。

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定 Active Directory 中之樹系物件 (NTDS 設定) 的 msDS-Behavior-Version 屬性值。此值指示 Active Directory 樹系功能等級。msDS-Behavior-Version 屬性的有效值顯示在下表中。

值 | 樹系功能等級
0 | Microsoft Windows 2000 Server 混合模式
1 | Windows Server™ 2003 過渡模式
2 | Windows Server 2003 原生模式

如果 Exchange Server Analyzer 發現在 Active Directory 樹系 (處於 Windows Server 2003 過渡模式或原生模式) 中執行 Exchange 的電腦，其 Adc.exe 的組建編號小於 6.0.6615.0，就會顯示錯誤。此錯誤表示 Exchange 2000 Server 版本的 ADC 程式在不相容的 Windows Server 2003 Active Directory 樹系層級中執行。若要解決此問題，需要 Exchange Active Directory Connection (ADC) 程式的更新。

在混合模式或原生模式的樹系功能等級中執行舊版的 ADC，可能會導致目錄更新不完整及資料遺失。建議組織中的所有電腦都升級到最新 Exchange Server 2003 版本的 ADC。

您可以從 Downloads for Exchange Server 2003 網頁 (http://go.microsoft.com/fwlink/?LinkId=25097) 下載最新版的 ADC，以及最新的 Exchange Server 2003 Service Pack。您也可以從 Exchange Server CD 安裝 Exchange Server 2003 最終版的 ADC。

升級到最新版本的 ADC

  1. 在執行舊版 ADC 的伺服器上，依序按一下 [開始] 及 [執行]，然後鍵入 E:\setup\adc\i386\setup.exe，其中 E 是 Exchange Server Service Pack 下載的位置。

  2. 在 [歡迎使用 Active Directory 連接器安裝精靈] 頁面上，按 [下一步]。

  3. 在 [偵測到先前的安裝] 頁面上，按一下 [重新安裝] 以升級 ADC。

  4. 在 [正在完成 Active Directory 連接器安裝精靈] 頁面上，按一下 [完成]。

若需有關樹系功能層級如何影響 ADC 的詳細資訊，請參閱微軟知識庫文件 - 825916＜Exchange 2000 Active Directory 連接器未在樹系功能層級 1 或 2 成功複寫 Windows Server 2003 Active Directory 群組成員的變更＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=825916)。

若需有關網域及樹系功能層級的詳細資訊，請參閱知識庫文件 - 322692＜如何在 Windows Server 2003 中提高網域和樹系功能等級＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322692)。


此 Active Directory 樹系針對受主控的 Exchange 而設定
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Microsoft Active Directory® 目錄服務，以判定 Global-Address-List 架構屬性物件上的 LinkID 屬性值。Global-Address-List 物件用於 Exchange 容器上，以儲存新建全域通訊清單 (GAL) 的辨別名稱。

如果 Exchange Server Analyzer 發現 Global-Address-List 物件的 LinkID 屬性值設為 4048，則會顯示非預設的組態訊息。若值為 4048，即表示 Active Directory 樹系是針對受主控的 Exchange 環境而設定的。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要採取任何動作。

對於受主控的 Exchange 環境如需詳細資訊，請參閱下列文件：

  • 《主機資訊》(英文) (http://go.microsoft.com/fwlink/?LinkId=46307)

  • 《Exchange Server 2000 Resource Kit》(http://go.microsoft.com/fwlink/?LinkId=46326)中的＜第 23 章 - 主控式服務環境＞(英文)


Active Directory 伺服器當機或無法存取
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會使用遠端程序呼叫 (RPC)，從 Active Directory® 目錄伺服器上的下列登錄機碼來讀取 CurrentVersion 字串值：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

在執行 Microsoft Windows® 2000 Server 的電腦上，CurrentVersion 字串值應該是 5.0。在執行 Windows Server™ 2003 的電腦上，此值應為 5.2。

若因為某些因素，Exchange Server Analyzer 無法讀取這個登錄值，就會顯示一則錯誤。

若要更正此錯誤

  1. 確定目錄伺服器已啟動，並已連線至網路。

  2. 使用 PING 命令來判定是否可與目錄伺服器連線。

  3. 若有裝置防火牆，檢查 RPC 連接埠是否被封鎖。

  4. 確定目錄伺服器上的 Remote Registry 服務已啟動。

  5. 檢查用來執行 Exchange Server Analyzer 的帳戶之權限，確定有足夠的權限可以讀取 Active Directory 伺服器上的登錄。

若需有關網路連線問題疑難排解的詳細資訊，請參閱下列文件：

  • 微軟知識庫文件 - 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)

  • ＜Microsoft Exchange Server Best Practices Analyzer 工具疑難排解連線問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56285)


Active Directory 伺服器的記憶體低於 1 GB，但 Boot.ini 檔案中已設定 /3GB 及 /USERVA=3030 參數
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢兩個 Windows® Management Instrumentation (WMI) 類別，以判定 Active Directory® 目錄伺服器的實體記憶體數量，以及配置給使用者模式處理程序的虛擬位址空間數量。此表格描述 Exchange Server Analyzer 會評估的類別及機碼。

類別 | 機碼 | 描述
Win32_OperatingSystem | MaxProcessMemorySize | 可以配置給處理程序的記憶體 KB 數上限。
Win32_OperatingSystem | OSProductSuite | 在作業系統上已安裝及授權的系統產品。
Win32_ComputerSystem | TotalPhysicalMemory | 電腦上已安裝的隨機存取記憶體 (RAM) 數量。

如果 Exchange Server Analyzer 判定目錄伺服器的 RAM 小於 950 MB，且 MaxProcessMemorySize 的值大於 2097024 但小於 3104640，就會顯示一則警告。

此警告指出未將目錄伺服器正確設定成達到最佳記憶體使用量的原因有二個：

  • 已設定 /USERVA=3030 啟動參數。只有當 Exchange Server 電腦具有 1 GB 以上的記憶體，且是執行 Microsoft Windows Server™ 2003 作業系統時，才需要此參數。

  • 已設定 /3GB 啟動參數。此參數只能用在具有 1 GB 或更多記憶體，且執行下列任一作業系統的 Exchange 伺服器：

    • Microsoft Windows Server 2003 Standard Edition

    • Microsoft Windows Server 2003 Enterprise Edition

    • Microsoft Windows Server 2003 Datacenter Edition

    • Microsoft Windows 2000 Advanced Server

    • Microsoft Windows 2000 Datacenter Server

重要事項：
在 Windows 2000 Server 上不可以使用 /3GB 參數，因為該參數未受支援，並且會導致應用程式或作業系統當機。此外，只有在上述作業系統上安裝 1 GB 以上的實體記憶體時，才會支援 /3GB 參數。

如果您在已安裝 1 GB 實體記憶體的系統上遇到這個警告，可能是有其他元件 (例如視訊卡)，在硬體層級配置了一部分的實體記憶體，使得該部分配置的實體記憶體不能供作業系統使用。在這種情況下，實際安裝的記憶體數量，就 Windows 的角度來看，會小於電腦上已安裝的實體記憶體數量。如果您遇到這種情況，請將 BIOS 報告的已安裝記憶體數量，和 Windows 報告的已安裝記憶體數量相比。

若要在 Windows Server 2003 上更正這個警告

  1. 在 [我的電腦] 上按一下滑鼠右鍵，然後選取 [內容]。即會出現 [系統內容] 對話方塊。

  2. 按一下 [進階]。

  3. 在 [啟動及修復] 區域中，按一下 [設定]。即會出現 [啟動及修復] 對話方塊。

  4. 在 [系統啟動] 區域中，按一下 [編輯]。這樣會用 [記事本] 開啟 Windows Boot.ini 檔。

  5. 在 [Operating Systems] 區段中，從所有啟動行刪除下列參數：/3GB /USERVA=3030

  6. 儲存變更並結束 [記事本]。

  7. 按 [確定] 兩次，關閉開啟的對話方塊，然後重新啟動電腦，以使變更生效。

若要在 Windows 2000 Server 上更正這個警告

  1. 在 [Windows 檔案總管] 中，尋找系統磁碟分割。

  2. 如果看不見 Boot.ini 檔案，可能是因為 [資料夾選項] 設定為 [隱藏保護的作業系統檔案]。如果是這種情形，請在 [檔案總管] 中，按一下 [工具]、[資料夾選項]，然後按一下 [檢視] 索引標籤。清除 [隱藏保護的作業系統檔案 (建議使用)] 核取方塊。出現警告方塊提示時，按一下 [是]。

  3. 在 [檔案總管] 中看到 Boot.ini 檔案時，請在檔案上按一下滑鼠右鍵，並依序按 [開啟檔案] 及 [記事本] 以開啟檔案。

  4. 在 [Operating Systems] 區段中，從所有啟動行中刪除下列參數：/3GB /USERVA=3030

  5. 儲存變更並結束 [記事本]。

  6. 重新啟動電腦，以使變更生效。

若需有關如何使用 /3GB 及 /USERVA 啟動參數的其他詳細資料，請參閱下列微軟知識庫文件：

  • 308356＜在執行 Windows Server 2003 或 Windows 2000 Server 的網域控制站上，Lsass.exe 處理序使用的記憶體＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)

  • 297812＜如何使用 4GT RAM 調整功能＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901＜4GT 調整對系統分頁表項目的效果＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739＜如何在 Boot.ini 檔中使用 /USERVA 參數調整 /3GB 組態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044＜HOW TO: 疑難排解 Exchange 2003 及 Exchange 2000 的虛擬記憶體分散＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Active Directory 伺服器的記憶體低於 1 GB，但 Boot.ini 檔案中設定了 /3GB 參數
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢兩個 Windows® Management Instrumentation (WMI) 類別，以判定 Active Directory® 目錄伺服器的實體記憶體數量，以及配置給使用者模式處理程序的虛擬位址空間數量。下表說明 Exchange Server Analyzer 會評估的類別與機碼。

類別 | 機碼 | 描述
Win32_OperatingSystem | MaxProcessMemorySize | 可以配置給處理程序的記憶體 KB 數上限。
Win32_OperatingSystem | OSProductSuite | 在作業系統上已安裝及授權的系統產品。
Win32_ComputerSystem | TotalPhysicalMemory | 電腦上已安裝的隨機存取記憶體 (RAM) 位元組數。

如果 Exchange Server Analyzer 判定目錄伺服器的 RAM 小於 950 MB，而且 MaxProcessMemorySize 的值大於 2097024 但小於 3104640，就會顯示一則警告。

此警告表示未正確設定目錄伺服器以達到記憶體使用量的最佳化。這部電腦上已設定 /3GB 啟動參數，應該移除該參數。此參數只能用在具有 1 GB 或更多記憶體，且執行下列任一作業系統的 Active Directory 伺服器上：

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server™ 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

重要事項：
在 Windows 2000 Server 上不可以使用 /3GB 參數，因為該參數未受支援，並且會導致應用程式或作業系統當機。此外，只有在上述作業系統上安裝 1 GB 以上的實體記憶體時，才會支援 /3GB 參數。

如果您在已安裝 1 GB 實體記憶體的系統上遇到這個警告，可能是有其他元件 (例如視訊卡) 在硬體層級配置了一部分的實體記憶體，使得該部分配置的實體記憶體不能供作業系統使用。在這種情況下，實際安裝的記憶體數量，就 Windows 的角度來看，會小於電腦上已安裝的實體記憶體數量。如果您遇到這種情況，請將 BIOS 報告的已安裝記憶體數量，和 Windows 報告的已安裝記憶體數量相比。

若要在 Windows Server 2003 上更正這個警告

  1. 以滑鼠右鍵按一下 [我的電腦]，然後按一下 [內容]。即會出現 [系統內容] 對話方塊。

  2. 按一下 [進階]。

  3. 在 [啟動及修復] 區域中，按一下 [設定]。即會出現 [啟動及修復] 對話方塊。

  4. 在 [系統啟動] 區域中，按一下 [編輯]。這樣會用 [記事本] 開啟 Windows Boot.ini 檔。

  5. 在 [Operating Systems] 區段中，從所有啟動列中刪除下列參數：/3GB

  6. 儲存變更並結束 [記事本]。

  7. 按 [確定] 兩次，關閉開啟的對話方塊，然後重新啟動電腦，以使變更生效。

若要在 Windows°2000 伺服器上更正這個警告

  1. 在 [Windows 檔案總管] 中，瀏覽至系統磁碟分割區。

  2. 如果看不見 Boot.ini 檔案，可能是因為 [資料夾選項] 設定為 [隱藏保護的作業系統檔案]。如果是這種情形，請在 [檔案總管] 中，按一下 [工具]、[資料夾選項]，然後按一下 [檢視]。清除 [隱藏保護的作業系統檔案 (建議使用)] 核取方塊。出現警告框提示時，按一下 [是]。

  3. 在 [檔案總管] 中可看見 Boot.ini 檔案時，請在該檔案上按一下滑鼠右鍵，按一下 [開啟檔案]，然後按一下 [記事本] 以開啟該檔案。

  4. 在 [Operating Systems] 區段中，從所有啟動列中刪除下列參數：/3GB

  5. 儲存變更並結束 [記事本]。

  6. 重新啟動電腦，以使變更生效。

若需有關使用 /3GB 啟動參數的詳細資料，請參閱下列微軟知識庫文件：

  • 308356＜在執行 Windows Server 2003 或 Windows 2000 Server 的網域控制站上，Lsass.exe 處理序使用的記憶體＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)

  • 297812＜如何使用 4GT RAM 調整功能＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901＜4GT 調整對系統分頁表項目的效果＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739＜如何在 Boot.ini 檔中使用 /USERVA 參數調整 /3GB 組態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044＜HOW TO:疑難排解 Exchange 2003 及 Exchange 2000 的虛擬記憶體分散＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Active Directory 伺服器正在 Windows 2000 Server 上執行，且設定了 /3GB 參數
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定對使用者模式處理程序配置的虛擬位址空間量 (MaxProcessMemorySize)，以及在 Active Directory® 目錄服務伺服器上執行的 Windows 版本 (OSProductSuite)。下表說明 Exchange Server Analyzer 會評估的類別與機碼。

如果 Exchange Server Analyzer 判定 MaxProcessMemorySize 的值是 3104640，且 OSProductSuite 的值解析成 Windows 2000 Server，則會顯示錯誤。

此錯誤表示執行 Microsoft Windows 2000 Server 之目錄伺服器的 Boot.ini 檔案中，已設定 /3GB 啟動參數。在 Windows 2000 Server 上不支援此參數，且此參數只能用於具有 1 GB 或以上記憶體且執行下列任何一種作業系統的電腦：

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

若要移除 Boot.ini 檔案中的 /3GB 參數

  1. 在 [Windows 檔案總管] 中，瀏覽至系統磁碟分割區。

  2. 如果您看不到 Boot.ini 檔案，則可能是因為 [資料夾選項] 設定為 [隱藏保護的作業系統檔案]。如果是這種情形，請在 [檔案總管] 中，按一下 [工具]、[資料夾選項]，然後按一下 [檢視] 索引標籤。清除 [隱藏保護的作業系統檔案 (建議使用)] 核取方塊。出現警告框提示時，按一下 [是]。

  3. 如果在 [檔案總管] 中看見 Boot.ini 檔，請在該檔案上按一下滑鼠右鍵、按一下 [開啟檔案]，然後選擇 [記事本] 來開啟檔案。

  4. 在 [Operating Systems] 區段中，從所有啟動行刪除下列參數：/3GB /USERVA=3030

  5. 儲存變更並結束 [記事本]。

  6. 重新啟動目錄伺服器，讓變更生效。

若需使用 /3GB 啟動參數的相關資訊，請參閱下列微軟知識庫文件：

  • 297812＜如何使用 4GT RAM 調整功能＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901＜4GT 調整對系統分頁表項目的效果＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739＜如何在 Boot.ini 檔中使用 /USERVA 參數調整 /3GB 組態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044＜HOW TO: 疑難排解 Exchange 2003 及 Exchange 2000 的虛擬記憶體分散＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


無法存取 Active Directory 伺服器登錄
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會讀取每個網域控制站的下列登錄項目：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion\CurrentVersion

若因為某些因素，Exchange Server Analyzer 無法讀取這個登錄值，就會顯示一則錯誤。

若要更正此錯誤

  1. 確定已啟動網域控制站，且已連線至網路。

  2. 使用 PING 命令來檢查是否可以連接網域控制站。

  3. 若有防火牆，請檢查 RPC 連接埠是否被封鎖。

  4. 請確定已啟動網域控制站上的 Remote Registry 服務。

  5. 檢查執行 Exchange Server Analyzer 的帳戶權限。Exchange Server Analyzer 的執行帳戶，對其所掃描的每個網域控制站必須具備系統管理員權限。

若需有關網路連線問題疑難排解的詳細資訊，請參閱下列文件：

  • 微軟知識庫文件 - 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)

  • ＜Microsoft Exchange Server Best Practices Analyzer 工具疑難排解連線問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56285)

若需有關通訊埠需求的詳細資訊，請參閱微軟知識庫文件 - 832017＜Windows Server 系統的服務概觀及網路通訊埠需求＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)。


有可用的 Active Directory 伺服器軟體更新
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2007-02-20

Microsoft Exchange Analyzer 工具會查詢 ROOT\MicrosoftExchangeV2 命名空間中的 Exchange_DSAccessDC Microsoft Windows Management Instrumentation (WMI) 類別，以判定 Name 內容值。Name 內容指定 Exchange 伺服器用來進行 Active Directory 目錄服務查閱之網域控制站的電腦名稱。

Exchange Analyzer 接著會查詢 Active Directory，取得該網域控制站的特定屬性值，以便判定下列各項：

  • Active Directory 網域控制站是否執行 Windows Server 2003 作業系統

  • Active Directory 網域控制站是否執行非英文版本的 Microsoft Windows Server 2003 作業系統

  • Exchange 組織中是否有 Microsoft Exchange Server 2007 伺服器

  • 伺服器上 ntdsa.dll 檔案的 Version 機碼值是否少於 2700

如果 Exchange Analyzer 發現這些條件都符合，便會顯示警告。

這個警告表示 Exchange Outlook Web Access 用戶端可能有 Exchange 通訊錄索引的問題。

Outlook Web Access 讓使用者選取他們的使用者介面 (UI) 上要用的語言。使用者選取的語言決定了地區設定。Outlook Web Access 也使用該語言來排序 Active Directory 結果，例如通訊錄。當 Exchange 執行 Virtual List View (VLV) 查詢並指定網域控制站上沒有的語言時，便會發生錯誤。這個問題的發生原因是，目前沒有預設索引機制能讓 Exchange 在 VLV 查詢的指定語言和網域控制站語言不符時使用不同的語言。

若要更正此警告，請取得並安裝 Microsoft 知識庫文章 919166＜Exchange OWA 用戶端與 Windows Server 2003 網域控制站的地區設定不同時，Exchange 2007 中的通訊錄功能無法運作＞(機器翻譯) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=919166) 中所提及的檔案更新。


無法存取 Active Directory Server WMI
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定是否已設定網域控制站上 Name 機碼的值。如果 WMI 查詢失敗，Exchange Server Analyzer 將會顯示錯誤。

此錯誤有兩個可能原因：

  • 執行 Exchange Server Analyzer 的帳戶沒有足夠的權限來查詢 WMI 資訊

  • 發生網路問題，使得 Exchange Server Analyzer 無法與電腦連絡。

若要更正此錯誤

  1. 確定 Exchange Server 電腦已經啟動，並且已連線到網路。

  2. 使用 PING 命令來檢查是否可以連接 Exchange Server 電腦。

  3. 若有裝置防火牆，檢查 RPC 連接埠是否被封鎖。

  4. 檢查執行 Exchange Server Analyzer 的帳戶權限。執行 Exchange Server Analyzer 的帳戶，在所掃描的每台 Exchange Server 電腦上都必須擁有本機 Administrator 權限。

    此外，您可以將特定的 WMI 權限授與執行 Exchange Server Analyzer 的帳戶。

    1. 在 Exchange 電腦上，開啟 [電腦管理] MMC 主控台樹狀目錄。

    2. 在 [服務及應用程式] 下，在 [WMI 控制] 上按一下滑鼠右鍵，再按一下 [內容]。

    3. 在 [WMI 控制內容] 頁面上，按一下 [安全性] 索引標籤，然後展開 [Root]。

    4. 選取 [CIMV2] 資料夾，然後按一下 [安全性]。

    5. 在 [安全性 ROOT\CIMV2] 頁面上，新增執行 Exchange Server Analyzer 的帳戶。

    6. 選取您在步驟 e 新增的帳戶；在 [Selected_Account 的權限] 中，於 [允許] 直欄下，核取 [遠端啟用] 和 [讀取安全性]，再按一下 [確定]。

若需有關網路連線問題疑難排解的詳細資訊，請參閱下列文件：

  • 微軟知識庫文件 - 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)

  • ＜Microsoft Exchange Server Best Practices Analyzer 工具疑難排解連線問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56285)

若需有關通訊埠需求的詳細資訊，請參閱微軟知識庫文件 - 832017＜Windows Server 系統的服務概觀及網路通訊埠需求＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)。


已偵測到 ADCDisabledMail 屬性
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 Exchange 組織為混合模式還是原生模式。如果發現 Exchange 組織為原生模式，Exchange Server Analyzer 就會查詢 Active Directory，以判定組織的網域中是否有任何擁有郵件功能的物件將其 legacyExchangeDN 屬性值設為 ADCDisabledMail。如果發現有擁有郵件功能的物件將其 legacyExchangeDN 屬性值設為 ADCDisabledMail，就會顯示警告，列出這些物件及其網域。

在 Exchange 2000 Server 及 Exchange Server 2003 環境中刪除信箱時，都可能發生此問題。刪除信箱後，帳戶的 legacyExchangeDN 屬性值會具有 ADCDisabledMail 戳記。在 Active Directory 中停用物件的郵件功能時，此值會指示 Active Directory 連接器 (ADC) 從 Exchange Server 5.5 目錄服務刪除相關聯的物件。如果已在大型通訊群組中刪除數個信箱，則因會在 Active Directory 中搜尋唯一 legacyExchangeDN 屬性值 ADCDisabledMail，而使郵件延遲。因為可能有數個信箱具有相同的 legacyExchangeDN attribute value，所以搜尋時間會比較長。這會造成郵件延遲。從 Microsoft Office Outlook® 2003 用戶端展開郵件之 [收件者:/副本:/密件副本:] 行中的通訊群組時，也會發生郵件延遲。

解決方式是刪除物件，或使用 [Active Directory Service Interfaces (ADSI) 編輯器] 工具、ldp.exe 或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端，來移除 legacyExchangeDn 屬性的內容。如果 legacyExchangeDN 屬性值設為 NULL，則針對 Active Directory 的搜尋將設為 "/O=NT5/ou=<網域的 objectGUID>/cn=<使用者的 objectGUID>"，從而加快產生未傳遞回報 (NDR) 的速度。

注意：
使用 ADSI 編輯器、LDP 工具或其他 LDAP 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
若要移除 legacyExchangeDN 屬性的 ADCDisabledMail 值

  1. 從 Windows 2000 支援工具或 Windows Server 2003 支援工具啟動 [ADSI 編輯器] 工具。

  2. 展開下列節點：

    • 網域容器

    • DC=Domain_Name

    • 使用者容器

  3. 在 User_Name 上按一下滑鼠右鍵，然後按一下 [內容]。

  4. 按一下 [屬性] 清單中的 legacyExchangeDN，然後按一下 [編輯]。

  5. 選取原始值並按一下 [清除]，以移除包含 ADCDisabledMail 的原始 legacyExchangeDN 值。

  6. 按兩次 [確定] 套用變更。

若需有關如何使用 [ADSI 編輯器] 的詳細資訊，請參閱主題＜Adsiedit.msc：ADSI 編輯器＞(位在 Windows Server 線上說明中)。

若需有關如何使用 LDP 工具的詳細資訊，請參閱微軟知識庫文件 - 260745＜XADM：Using the LDP Utility to Modify Active Directory Object Attributes＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。


通訊清單篩選器設定可能會造成無法在通訊清單中顯示新的收件者
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定為每個通訊清單物件之 purportedSearch 屬性設定的屬性。如果 Exchange Server Analyzer 發現 purportedSearch 屬性包含 "proxyAddresses=*" 字串，就會顯示一則錯誤。

建立新的使用者物件後，收件者更新服務會向該收件者物件指定特定的屬性，如 Proxy 位址。不過，收件者更新服務可能無法指派 ShowInAddressBook 屬性。收件者物件的 ShowInAddressBook 屬性表示收件者為其成員之一的通訊清單。即使收件者物件符合通訊清單篩選器的條件，未指派此屬性的收件者物件也不會顯示在全域通訊清單或任何其他通訊清單中。

如果一或多個通訊清單篩選器包含 proxyAddresses 屬性，就會發生這種情況。您可以藉由檢閱每個通訊清單的內容並在 [篩選規則] 方塊中尋找下列字串，以判定是否屬於這種情況："proxyAddresses=*"。

執行下列程序來啟用收件者更新服務，以將屬性正確地指定給收件者物件，便它們顯示在全域通訊清單或其他任何通訊清單中。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
若要更正此錯誤

  1. 開啟 [Exchange 系統管理員]。

  2. 依序展開 [收件者] 及 [所有全域通訊清單]，然後選取 [收件者原則]。

  3. 在右窗格中，以滑鼠右鍵按一下要編輯的通訊清單，並選取 [內容]。

  4. 在 [內容] 頁面中的 [一般] 索引標籤上，在 [篩選規則] 之下按一下 [修改]。

  5. 在 [尋找 Exchange 收件者] 下拉式功能表中，選取 [自訂搜尋]。如果通訊清單最初是由自訂搜尋建立，則在您按一下步驟 3 中的 [修改] 之後，會顯示 [尋找自訂搜尋] 頁面。

  6. 在條件清單中選取 [ Proxy 地址是 (確切) * ]，然後按一下 [移除]。

  7. 按一下 [確定] 以關閉對話方塊。

  8. 在收件者原則上按一下滑鼠右鍵，再按一下 [立即套用此原則]。

若需「收件者更新服務」的相關資訊，請參閱下列微軟知識庫文件：

  • 328738＜XADM: 收件者更新服務如何套用收件者原則＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328738)

  • 319065＜如何使用 Exchange 收件者更新服務＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319065)


未知的系統管理群組模式
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，並藉由檢查 Active Directory 的系統管理群組容器中之系統管理群組物件的 msExchAdminGroupMode 屬性，來驗證系統管理群組的模式。如果 Exchange Server Analyzer 發現 msExchAdminGroupMode 屬性的值不等於 0、1 或 2，則會顯示錯誤訊息。

Exchange 會使用系統管理群組的模式，指示系統管理群組是否可以包含 Exchange Server 5.5 伺服器或 Exchange Server 2003 伺服器 (或 Exchange 2000 Server 伺服器)。如果代表此屬性的值不是 0、1 或 2，有可能是系統管理員已手動變更此值。「Exchange 安裝程式」或「Exchange 系統管理員」將會正確地設定此值。

您必須使用如 [Active Directory Service Interfaces (ADSI) 編輯器] 嵌入式管理單元、LDP (ldp.exe) 工具或任何其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端等工具來更正此值。

注意：
使用 ADSI 編輯器、LDP 工具或其他 LDAP 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

修改 MSExchAdminGroupMode 屬性

  1. 使用 Active Directory 編輯程式 (如 ADSI 編輯器)，在 Active Directory 中找出系統管理群組物件。

    MSExchAdminGroupMode 屬性會出現在下列位置：

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=Organization, CN=Administrative Groups, CN=Administrative group

  2. 輸入下列其中一個整數值：

    0=原生模式 (系統管理群組是使用 Exchange 2000 Server 或 Exchange Server 2003 來建立的)

    1=Exchange Server 5.5 模式 (系統管理群組是使用 Exchange Server 5.5 來建立的，且只包含 Exchange Server 5.5 伺服器)

    2=混合模式 (系統管理群組可同時包含 Exchange Server 5.5 伺服器及 Exchange 2000 Server (或 Exchange Server 2003 伺服器))

若需有關使用 LDP 工具的詳細資訊，請參閱微軟知識庫文件 - 260745＜XADM:使用 LDP 公用程式修改 Active Directory 物件屬性＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

若需有關使用 ADSI 編輯器的詳細資訊，請參閱主題＜Adsiedit.msc：ADSI 編輯器＞(位在 Windows Server 線上說明中)。


受主控的 Exchange 的驗證使用者組態不正確
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已將 Exchange Server 環境設定為受主控的 Exchange 環境。如果 Exchange Server 環境是受主控的 Exchange 環境，則 Exchange Server Analyzer 會查詢 Active Directory，以判定 Authenticated Users 群組是否為網域中 Pre-Windows® 2000 Compatible Access 群組的一部分。

如果 Authenticated Users 群組是 Pre-Windows 2000 Compatible Access 群組的成員，Exchange Server Analyzer 就會顯示一則警告。不建議受主控的 Exchange 解決方案使用此組態。

若要解決此警告，請從 Pre-Windows 2000 Compatible Access 安全性群組移除 Authenticated Users

  1. 開啟 [Active Directory 使用者及電腦]。

  2. 展開網域節點，然後按一下 [Builtin] 容器。

  3. 在 [Pre-Windows 2000 Compatible Access] 安全性群組上按一下滑鼠右鍵，然後選取 [內容]。

  4. 按一下 [成員] 索引標籤。

  5. 選取 [Authenticated Users]。

  6. 按一下 [移除]。

  7. 按一下 [確定]。

若需有關受主控的 Exchange 環境的詳細資訊，請參閱下列文件：

  • 《主機資訊》(英文) (http://go.microsoft.com/fwlink/?LinkId=46307)

  • 《Exchange Server 2000 Resource Kit》(http://go.microsoft.com/fwlink/?LinkId=46326)中的＜第 23 章 - 主控式服務環境＞(英文)


憑證 Principal 不符
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2007-01-09

Microsoft® Exchange Server Analyzer 工具會查詢 Exchange 伺服器系統中的 Server Certificate 物件，以擷取 X509 憑證的各種內容。對於每個找到的安全通訊端層 (SSL) 憑證，Exchange Server Analyzer 都會評估 Principal 屬性，以識別指派給該憑證的完整網域名稱 (FQDN) (例如，www.microsoft.com)。

Principal FDQN 名稱與主機位址或 URL 不符時，Microsoft Exchange Server Analyzer 會發出警告。出現憑證 Principal 不符警告時，表示使用者可能無法使用 Microsoft Office Outlook® Web Access for Exchange Server 2003、Outlook Anywhere for Exchange Server 2007、Exchange Server ActiveSync 以及 RPC over HTTP 連線至他們的信箱。

附註：
伺服器在執行 SSL 通訊協定時，必須要有伺服器憑證。伺服器也可能會要求提供用戶端憑證。伺服器憑證會包含網站名稱。瀏覽器會驗證網站名稱是否就是您輸入的名稱。例如，對於 https://www.example.com 網站，其憑證名稱應該是 www.example.com。

如果符合下列其中一個條件，會導致不符的情況：

  • 憑證意外地套用至錯誤的伺服器

  • 當伺服器具有多個主機名稱時，用戶端會透過錯誤的主機 URL 存取伺服器上的資料

解決憑證名稱不符

  • 驗證已授與 SSL 憑證，並將其套用至正確的主機。

詳細資訊

  • 若需在 Exchange Server 2003 中讓虛擬伺服器與憑證搭配使用的相關資訊，請參閱微軟知識庫文件 - 823024＜如何在 Exchange Server 2003 中讓虛擬伺服器與憑證搭配使用＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823024)。

  • 若需如何使用 SSL 及如何取得並安裝伺服器憑證的相關資訊，請參閱《Exchange Server 2003 用戶端存取手冊》(http://go.microsoft.com/fwlink/?LinkId=47568) 中的＜設定 Exchange Server 2003 進行用戶端存取＞(英文)。

  • 若需有關如何使用 SSL 以及如何取得並安裝 Exchange Server 2007 伺服器憑證的詳細資訊，請參閱＜如何設定 Outlook Anywhere 的 SSL＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80875)。


連線協定啟動排程已設定為永不
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個連線協定物件上的 activationStyle 屬性值。activationStyle 屬性代表連線協定的排程設定。如果排程的設定為 [永不]，就會顯示一則警告。

如果您確定已不再需要這個連線協定，則應將它刪除。如果這個連線協定是必要的，您應加以設定，以適當的排程來執行。

若要更正此警告

  1. 依序按 [開始]、[程式集]、[系統管理工具]、[Active Directory 連接器]。

  2. 在左窗格中，按一下主控您要修改之連線協定的 Active Directory 連接器 (ADC) 伺服器。

  3. 在右窗格中，以滑鼠右鍵按一下要修改的連線協定，再按一下 [內容]。

  4. 按一下 [排程] 索引標籤。

  5. 將排程設定為 [永遠] 或 [選取的時間]。如果您選擇後者，請在格線中按一下適當的區域，讓連線協定依那些時間來執行。

若需有關設定雙向收件者連線協定的詳細資訊，請參閱微軟知識庫文件 - 296260＜XGEN：如何設定 Exchange 5.5 使用者的雙向收件者連線協定＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=296260)。


連線協定已孤立
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個連線協定的 msExchHomeSyncService 值是否有效。如果 Exchange Server Analyzer 發現有此屬性值無效的連線協定，就會顯示警告。

msExchHomeSyncService 屬性包含連線協定所在的 Active Directory 連接器 (ADC) 伺服器。

如果在移除 ADC 伺服器之前，未先移除 ADC 或 ADC 伺服器上的連線協定，您就會看到此警告。當您移除 ADC 伺服器時，連線協定與 ADC 伺服器之間的連線即告中斷。因此，將不再複寫這些連線協定所負責的物件。如果您在其他 ADC 伺服器上使用 [ADC 管理員] 嵌入式管理單元，就不會再顯示位於已移除之 ADC 伺服器上的連線協定。然而，這些連線協定仍存在於 Active Directory 中。

若要解決此問題，請將舊連線協定與新 ADC 伺服器重新建立關聯。重新建立關聯的一個方法是，在新 ADC 伺服器上建立新連線協定，然後將新連線協定的 msExchHomeSyncService 屬性複製並貼到舊連線協定中。

若要將連線協定與 ADC 伺服器重新建立關聯

  1. 啟動 [ADC 管理員] 嵌入式管理單元。

  2. 建立新的連線協定。

  3. 啟動 [Active Directory Service Interfaces (ADSI) 編輯器]。

  4. 依序展開 [組態]、[服務] 及 [Microsoft Exchange]，然後按一下 [Active Directory 連線]。

  5. 在右窗格中，開啟剛建立之連線協定的內容。

  6. 在 [選取內容來檢視] 下拉清單中，按一下 [msExchHomeSyncService]。

  7. 從 [值] 方塊中複製整個屬性，然後按一下 [確定]。

  8. 開啟您必須重新建立關聯之連線協定的內容。

  9. 按一下 [選取內容來檢視] 下拉清單，再按 [msExchHomeSyncService] 屬性。

  10. 將所複製的值貼到 [編輯屬性] 方塊中。

  11. 依序按一下 [設定]、[套用] 及 [確定]。

若需有關孤立連線協定的詳細資訊，請參閱微軟知識庫文件 - 319486＜XADM：連線協定在您移除 Active Directory 連接器之後消失＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319486)。


已修改預設顯示名稱
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定類別為 displaySpecifier 的物件之 createDialog 屬性值。類別為 displaySpecifier 的物件會描述與 Active Directory 中的物件搭配使用的快顯功能表及內容頁。如果 Exchange Server Analyzer 判定已設定 createDialog 屬性，則會顯示非預設的組態訊息。

在 Active Directory 中建立新使用者或連絡人物件時，一律會以名字姓氏的格式來產生「全名」欄位。接下來，此欄位會在建立時設定「顯示名稱」欄位，因此，最後會產生名字姓氏格式的全域通訊清單。

您可以視需要使用 Active Directory 編輯器 (例如，Active Directory Service Interfaces (ADSI) 編輯器) 來修改 [顯示名稱] 欄位的建置方式。ADSI 編輯器不僅會變更此欄位的建置方式，也會變更 [全名] 欄位；因此，使用者會以 [Active Directory 使用者及電腦] 內所選擇的格式來檢視使用者。

注意：
使用 ADSI 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

進行這些變更之前，請注意它們可能會有反效果。若需有關此變更可能產生之結果的詳細資訊，請參閱微軟知識庫文件 - 276266＜對具有 LDAP 限制字元之使用者進行群組變更＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=276266)。

變更使用者及連絡人物件的預設顯示格式

  1. 開啟一個 Active Directory 編輯程式，如 [ADSI 編輯器]。

  2. 在頂端節點上按一下滑鼠右鍵，然後再按 [連線至]。

  3. 將 [命名內容] 變更為 [組態容器]，再按一下 [確定] 以進行繫結及驗證。

  4. 展開 [組態容器] 節點，然後展開 [組態] 節點。

  5. 展開 cn=DisplaySpecifiers 節點，然後對 CN=409 連按兩下。附註：409 是美式英文 (U.S. English) 的地區設定識別碼。如果您是在多語言環境，您可能需要變更其他程式碼。

  6. 在右窗格中，開啟 CN=user-Display 的內容。

  7. 捲動到 createDialog 選用屬性。

  8. 將屬性設定成 %<sn>.%<givenName>，再按一下 [設定]。附註：可格式化的唯一 Token 是 %<sn>、%<givenName> 及 %<initials>。

  9. 按一下 [確定] 以關閉對話方塊。

  10. 在 Active Directory 中建立新使用者，以驗證已如預期建置「全名」及「顯示名稱」。附註：在多網域環境中，您需要等到複寫完成後，「Active Directory 使用者及電腦」工具才能取得變更。

上述步驟會導致顯示名稱顯示成 LastName.FirstName。此外，上述程序是針對使用者物件。若為連絡人物件，請將步驟 6 變更為 contact-Display。

若需有關如何使用 ADSI 指令碼來執行此工作的詳細資訊，請參閱微軟知識庫文件 - 277717＜如何使用 Active Directory 服務介面指令碼來變更 Active Directory 使用者的顯示名稱＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277717)。

世界電信聯盟 (ITU，International Telecommunication Union) 及國際標準組織 (ISO，International Organization for Standardization) 會定義字碼頁。若需相關資訊，請瀏覽下列 ITU 及 ISO 網頁：

  • http://www.itu.int

  • http://www.iso.ch/iso/en/ISOOnline.openerpage

    附註：
    網址可能會變更，因此您可能無法連線到此處提到的網站。

若需有關支援本地化 Exchange 用戶端的其他資訊，請參閱微軟知識庫文件 - 150977＜XADM：Supporting Localized Exchange Clients＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=150977)。


已停用信箱儲存區的保留已刪除郵件功能
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個信箱儲存區的 garbageCollPeriod 屬性值。如果 Exchange Server Analyzer 發現任何信箱儲存區的 garbageCollPeriod 屬性設為 0，就會顯示一則最佳作法建議訊息。

廢棄項目收集是一項 Exchange 內部管理處理程序，可釋放信箱儲存區資料庫內的空間。在預設的情況下，刪除的郵件會先儲存在信箱儲存區資料庫中數天，再由 Exchange 永久刪除。要設定已刪除郵件保留期間的長度，您可以使用信箱儲存區的預設值，或選取在永久刪除前保留刪除郵件的天數。

指定要保留刪除郵件的天數時，可以選取 0 到 24,855 的數字。建議您將此設定設為 7 天。如果將已刪除郵件的保留期間設為 0，就會立即從伺服器永久移除刪除的郵件。除非磁碟空間不足，否則建議您不要停用保留已刪除郵件的功能。請遵循以下程序，指定要永久刪除前儲存已刪除郵件的天數。

若要在 Exchange 系統管理員中設定保留已刪除郵件功能

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [系統管理群組] 或 [組織]，按一下 [伺服器]，再按一下 [信箱儲存區]。

  3. 在信箱儲存區上按一下滑鼠右鍵，再按一下 [內容]。

  4. 在 [限制] 索引標籤中，執行下列步驟以設定已刪除郵件的保留期間：

    • 若要設定已刪除郵件的保留期間，請按一下 [保留已刪除郵件的天數]，再鍵入數值。

    • 若要將郵件保留到備份完成後，請按一下 [在備份儲存區之後才永久刪除信箱及郵件]。

若要在 [Active Directory 使用者及電腦] 中設定保留已刪除的郵件功能

  1. 開啟 [Active Directory 使用者及電腦]。

  2. 在主控台樹狀目錄中，展開網域。

  3. 連按兩下 [使用者]，或連按兩下包含要修改之收件者資訊的節點

  4. 在詳細資料窗格中，連按兩下要修改的收件者。

  5. 在 [Exchange 一般] 索引標籤上，按一下 [儲存限制]。

  6. 在 [儲存限制] 對話方塊中，於 [保留已刪除的郵件] 下，按一下以清除 [使用信箱儲存區預設值] 核取方塊，再於 [保留已刪除郵件的天數] 中鍵入數值。

    若要防止刪除的郵件在完成備份之前被永久刪除，請選取 [在備份儲存區之後才永久刪除郵件] 核取方塊。

若需有關設定信箱儲存限制的詳細資訊，請參閱微軟知識庫文件 - 319583＜HOW TO：設定 Exchange 2000 信箱的儲存限制＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319583)。


公用資料夾儲存區已停用刪除項目保留
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

MicrosoftR® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個公用資料夾儲存區的 garbageCollPeriod 屬性值。如果 Exchange Server Analyzer 發現任何公用資料夾儲存區的 garbageCollPeriod 屬性設為 0，就會顯示最佳作法建議訊息。

垃圾收集是 Exchange 的內部清理程序，可釋放公用資料夾儲存區資料庫內的空間。根據預設，刪除的項目會儲存在公用資料夾儲存區資料庫中，經過特定的天數後，才會被 Exchange 永久刪除。您可以使用公用資料夾儲存區預設值，或選取在永久刪除之前，要保留已刪除項目的天數，以設定刪除項目的保留期間。

在指定刪除項目的保留天數時，您可以選取 0 到 24,855 之間的數字。建議您將此設定設為 7 天。若將刪除項目保留期間設為 0，則會立即從伺服器上永久移除該刪除項目。若沒有磁碟空間不足的問題，建議您不要停用保留刪除項目的功能。

在 Exchange 系統管理員中設定刪除項目保留功能

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [系統管理群組] 或 [伺服器]，按一下 [伺服器]，再按一下 [公用資料夾儲存區]。

  3. 以滑鼠右鍵按一下 [公用資料夾儲存區]，再按一下 [內容]。

  4. 在 [限制] 索引標籤上，執行下列動作以設定刪除項目保留期間：

    • 若要設定已刪除郵件的保留期間，請按一下 [保留已刪除郵件的天數]，再鍵入數值。

    • 若要在備份之前保留項目，請按一下 [在備份儲存區之後才永久刪除項目]。

若需有關在公用資料夾上設定儲存限制的詳細資訊，請參閱微軟知識庫文件 - 319439＜HOW TO：在 Exchange 2000 的公用資料夾上設定儲存限制＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319439)。


停用保留已刪除的信箱
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個信箱儲存區的 msExchMailboxRetentionPeriod 屬性值。如果 Exchange Server Analyzer 發現有任何信箱儲存區的 msExchMailboxRetentionPeriod 屬性值設為 0，就會顯示最佳作法建議。

msExchMailboxRetentionPeriod 屬性表示在刪除信箱之前，需要對其進行保留的天數。在指定保留已刪除信箱的天數時，您可以選取介於 0 到 24855 之間的數字。保留已刪除信箱的預設值為 30 天。如果信箱保留期限設為 0，已刪除的信箱便會立即從伺服器中永久移除。除非磁碟空間有問題，否則建議您不要停用保留已刪除信箱的功能。

設定保留已刪除的信箱

  1. 開啟 [Exchange 系統管理員]。

  2. 依序展開 [系統管理群組]、您的系統管理群組及 [伺服器]，然後展開您的儲存群組。如果在 [Exchange 系統管理員] 中未顯示 [系統管理群組] 節點，請展開 [伺服器]，然後展開您的儲存群組。

  3. 在要設定的信箱儲存區上按一下滑鼠右鍵，然後選取 [內容]。

  4. 在 [限制] 索引標籤上，在 [保留已刪除信箱的天數] 欄位中輸入信箱保留期限。

  5. 按一下 [確定]，儲存變更。
附註：
如果信箱保留期限尚未過期，而且未刪除相關聯的使用者物件，您就可以復原信箱。

若需復原已刪除信箱的相關資訊，請參閱下列微軟知識庫文件：

  • 274343＜X如何在 Exchange 2000 中復原刪除的信箱＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=274343)

  • 813337＜HOW TO：恢復或還原 Exchange 2000 Server 的單一信箱＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=813337)

  • 823176＜如何復原或還原 Exchange Server 2003 的單一信箱＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823176)


網域有未知的 Exchange 簽章
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2006-12-04

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定上次在給定網域中執行的 DomainPrep 版本。DomainPrep 的版本號碼會當作網域的 Exchange 簽章。Exchange Server Analyzer 會檢查給定網域之 Exchange System Objects 物件的 objectVersion 屬性。有兩個有效整數：

  • 若為 Exchange 2000 Server，則 objectVersion 值是 4406。

  • 若為 Exchange Server 2003，則 objectVersion 值是 6936。

  • 若為 Exchange Server 2007，則 objectVersion 值是 10628

如果 Exchange Server Analyzer 找不到 objectVersion 屬性的上述其中一個值，就會顯示一則錯誤。

如果在給定網域中已安裝 Exchange 2000 Server 或 Exchange Server 2003 的發行前版本，但未執行 DomainPrep 的正式發行版本，則此值可能不正確。

附註：
在 Microsoft Exchange 2000 Server 及 Exchange Server 2003 中，您藉由執行 setup /forestprep 及 setup /domainprep，來執行 Active Directory 準備步驟。Exchange 2007 沒有 /forestprep 及 /domainprep 選項。若為 Exchange Server 2007，您執行 setup /PrepareDomain 處理程序或安裝精靈時所用的帳戶，必須具有準備 Active Directory 及網域所需的權限。

若要對 Exchange 2000 Server 或 Exchange Server 2003 解決此錯誤，請執行確定發行版本的 Exchange 2000 Server DomainPrep、Exchange Server 2003 DomainPrep，或若要對 Exchange Server 2007 解決此錯誤，請執行確定發行版本的 PrepareDomain 處理程序或安裝精靈。您用來執行 DomainPrep、PrepareDomain 或安裝精靈的帳戶必須是本機網域的 Domain Admins 安全性群組的成員，以及是本機電腦系統管理員。

  • 根網域。

  • 所有會包含 Exchange 2000 Server 或 Exchange Server 2003 電腦的網域。

  • 所有會包含 Exchange 2000 Server 或 Exchange Server 2003 信箱功能物件 (如使用者及群組) 的網域，即使在這些網域中不會安裝 Exchange 伺服器。

  • 所有會包含 Exchange 目錄存取元件有可能會使用的通用類別目錄伺服器之網域。

  • 所有會包含 Exchange 2000 Server 或 Exchange Server 2003 使用者及群組的網域，您會使用這些使用者及群組來管理 Exchange 組織。

執行 Exchange 2000 Server 或 Exchange Server 2003 的 DomainPrep

  1. 將 Exchange CD 插入光碟機中。您可以在網域中的任何電腦上執行 DomainPrep。

  2. 在命令提示字元下，鍵入 <drive>:\setup\i386\setup /DomainPrep，其中 <drive> 是光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面，請確定 [動作] 是設定為 [DomainPrep]。如果不是，請按下拉箭頭，然後按一下 [DomainPrep]。按 [下一步]。

  7. 在 [完成 Microsoft Exchange 精靈] 頁面，按一下 [完成]。

執行 Exchange Server 2007 的 PrepareDomain

  1. 遵循＜如何準備 Active Directory 和網域＞(英文) (http://go.microsoft.com/fwlink/?LinkId=78453) 中的逐步指導

若需有關執行 Exchange Server 2003 DomainPrep 的詳細資訊，請參閱《Exchange Server 2003 部署手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47569)。

若需有關執行 Exchange 2000 Server DomainPrep 的詳細資訊，請參閱＜Microsoft Exchange 2000 Server 安裝及設定＞(英文) (http://go.microsoft.com/fwlink/?LinkId=5906)。

若需有關準備 Exchange Server 2007 的 Active Directory 和網域的詳細資訊，請參閱＜如何準備 Active Directory 和網域＞(英文) (http://go.microsoft.com/fwlink/?LinkId=78453)。


網域控制站是以來賓的身分執行已安裝 Exchange Server 的 Virtual Server 2005
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Model 機碼值是否設為 Virtual Machine。

Exchange Server Analyzer 也會檢查下列登錄值是否存在：

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

此外，Exchange Server Analyzer 也會讀取正在執行 Microsoft Virtual Server 2005 之實體電腦上 Win32_ComputerSystem 的 Domain Role 機碼。值大於 3 表示實體電腦為網域控制站。

如果 Exchange Server Analyzer 發現 Model 機碼包含 Virtual Machine 字串、上述登錄分支已存在，而且 Domain Role 大於 3，則會顯示錯誤訊息。

Model 機碼值為 Virtual Machine 表示 Exchange Server 電腦目前是以來賓虛擬機器的身分在 Virtual Server 2005 或 Microsoft Virtual PC 2004 上執行。因為上述登錄分支僅由 Virtual Server 2005 所建立，因此存在此登錄分支表示 Exchange Server 電腦目前是以來賓虛擬機器的身分在 Virtual Server 2005 中執行。

Microsoft 不支援在虛擬機器或模擬器上，執行任何 Exchange Server 版本。對於在 Virtual Server 2005、Virtual PC 2004 或任何協力廠商虛擬機器程式上執行的 Exchange Server，這個情況會成立。Exchange Server 平台的設計及測試都只是針對在實體硬體上來執行，特別是在 Windows Server Catalog (英文) (網址是 http://go.microsoft.com/fwlink/?linkid=17219) 中列出的那些硬體平台。

此外，在網域控制站上以 Virtual Server 來賓的身分執行 Exchange 並不是最好的作法，因為這並不允許各服務間有適當的重複性。

若要更正此錯誤

  1. 將信箱從在 Virtual Server 2005 下執行的 Exchange 伺服器，移到非虛擬 Exchange Server 電腦上。

  2. 視需要，將任何公用資料夾重新歸屬，並且轉移虛擬 Exchange 伺服器持有的角色。

  3. 從虛擬機器解除安裝 Exchange，以從 Exchange 基礎結構及 Active Directory® 目錄服務中進行解除及移除。

若需有關移動信箱的詳細資訊，請參閱下列微軟知識庫文件：

  • 822892＜Exchange 2003 中移動信箱的改良功能＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975＜XADM：移動信箱方法間的差異＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

若需有關支援在虛擬環境中執行之 Exchange Server 電腦的詳細資訊，請參閱微軟知識庫文件 - 320220＜虛擬機器或模擬機器上的 Exchange Server 支援邊界＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)。

若需有關 Microsoft Virtual Server 2005 的詳細資訊，請造訪 http://go.microsoft.com/fwlink/?linkid=34938。

若需有關 Microsoft Virtual PC 2004 的詳細資訊，請造訪 http://go.microsoft.com/fwlink/?linkid=34663。


網域命名 FSMO 角色沒有回應
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定組態命名內容中網域命名操作主機的 fSMORoleOwner 屬性值。例如，在名為 contoso.com 的網域中，網域命名操作主機的 fSMORoleOwner 屬性為 CN=Partitions,CN=Configuration,DC=contoso,DC=com。接著，Exchange Server Analyzer 會嘗試對目前持有這個角色的網域控制站之 TCP 通訊埠 389，開啟輕量型目錄存取通訊協定 (LDAP) 連線。若 Exchange Server Analyzer 無法連線到這個網域控制站，就會顯示一則錯誤。

網域命名主機是整個樹系的操作主機角色，因為它可管理樹系階層中所有目錄磁碟分割區的新增與移除 (不論網域為何)。具有網域命名主機角色的網域控制站，是唯一可以執行下列作業的網域控制站：

  • 將新網域加入到樹系。

  • 從樹系中移除現有的網域。

  • 在外部目錄中新增或移除交互參照物件。

在整個樹系中只能有一個網域命名主機。

若要更正此錯誤

  1. 確認錯誤訊息中指出的目錄伺服器已在連線中，並且可以讓貴組織內的 Exchange 伺服器存取。

  2. 如果此目錄伺服器已除役，您就必須將網域命名主機角色指派給其他網域控制站。

若需有關將某一個網域控制站的 RID 操作主機角色轉移給另一個網域控制站的詳細資訊，請參閱下列微軟知識庫文件：

  • 若為 Microsoft Windows Server™ 2003，請參閱 324801＜HOW TO：在 Windows Server 2003 中檢視及轉移 FSMO 角色＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)。

  • 若為 Microsoft Windows® 2000 Server，請參閱 255690＜HOW TO：在圖形化使用者介面檢視傳送 FSMO 角色＞ (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690)。


找不到網域命名 FSMO 角色
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定組態命名內容中網域命名操作主機的 fSMORoleOwner 屬性。例如，在名為 contoso.com 的網域中，網域命名主機的 fSMORoleOwner 屬性為 CN=Partitions, CN=Configuration, DC=contoso, DC=com。然後，Exchange Server Analyzer 會嘗試對網域控制站開啟輕量型目錄存取通訊協定 (LDAP) 連線。如果 Exchange Server Analyzer 發現 fSMORoleOwner 屬性中所指定的網域控制站沒有回應，就會顯示錯誤。

網域命名主機網域控制站可控制要在樹系中新增或移除的網域。在整個樹系中只能有一個網域命名主機。

您必須為 Active Directory 樹系定義網域命名主機。如果在安裝期間，網域命名主機網域控制站沒有連線，Exchange 安裝程式及 Exchange Service Pack 安裝程式就會失敗。如果列為網域命名主機的網域控制站離線，則必須恢復連線。

若要更正此錯誤

  1. 確認指定的 Active Directory 伺服器確實存在。

  2. 如果這部目錄伺服器關閉，請將網域命名主機指派給其他網域控制站。

若需有關如何將網域命名主機指派給其他網域控制站的詳細資訊，請參閱下列微軟知識庫文件：

  • 若為 Windows Server™ 2003，請參閱 324801＜HOW TO：在 Windows Server 2003 中檢視及轉移 FSMO 角色＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)。

  • 若為 Microsoft Windows® 2000 Server，請參閱 255690＜HOW TO：在圖形化使用者介面檢視傳送 FSMO 角色＞ (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690)。


Directory Server DNS 名稱解析失敗
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會為每一個 Active Directory® 目錄服務伺服器，嘗試對已設定的 DNS 伺服器進行網域名稱系統 (DNS) 查詢。透過使用自訂物件處理器建立此連線，該處理器執行名稱解析要求並分析結果。如果 Exchange Server Analyzer 在查詢結果的部份中未收到 IP 位址，則會顯示錯誤。

此錯誤指出 DNS 中找不到目錄伺服器。Exchange Server 和 Active Directory 都需要正確地設定及狀況良好的 DNS，才能正確地運作。DNS 註冊及解析問題對於傳送、接收及傳遞郵件的能力有廣泛的影響。

您必須正確設定 DNS 以確保 Active Directory 及 Exchange Server 會正確運作。若需有關為 Active Directory 處理 DNS 組態的深入資訊，請參閱微軟知識庫文件 - 237675＜為 Active Directory 設定網域名稱系統＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=237675)。

若要更正此錯誤

  1. 檢閱下列組態項目來確定 DNS 狀況良好，且能正確地登錄 Active Directory DNS 項目：

    • DNS IP 設定

    • 動態區域更新

    • DNS 轉寄站

  2. 檢查 [根區域] 項目是否存在。檢視 [DNS 管理] 主控台中的 [正向對應] 區域。此處應有此網域的項目。也可能有其他的區域項目。 此處不應有「點」(".") 的區域。如果「點」(".") 區域存在，請刪除該「點」(".") 區域。「點」(".") 區域會將 DNS 伺服器識別為根伺服器。一般來說，需要外部 (網際網路) 存取的 Active Directory 網域應設定為根 DNS 伺服器。在您刪除「點」(".")之後，請在目錄伺服器上，使用 Ipconfig /registerdns 來手動解除登錄目錄伺服器的 IP 位址。可能也需要重新啟動 Netlogon 服務。

  3. 在目錄伺服器電腦上，使用 netdiag /fix 來手動重新填入 Active Directory DNS 項目。

若需有關搭配使用 DNS 與 Active Directory 的詳細資訊，請參閱微軟知識庫文件 - 323418＜當 Windows Server 2003 中已啟用 Active Directory 時將 DNS 與現有的 DNS 基礎結構整合＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=323418)。

若需有關疑難排解 DNS 及 Active Directory 問題的詳細資訊，請參閱微軟知識庫文件 - 260371＜疑難排解 Windows 2000 中常見 Active Directory 安裝問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260371)。


Hosted Exchange 的 dSHeuristics 設定不正確
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定部署是否為受主控的 Exchange 部署。如果 Exchange 部署在受主控的環境中執行，Exchange Server Analyzer 就會查詢 Active Directory，以判定是否已針對受主控的 Exchange 部署，正確地設定目錄服務容器上的 dSHeuristics 屬性。

如果 dSHeuristics 的值不等於 1，Exchange Server Analyzer 就會顯示一則警告。在受主控的 Exchange 環境中，dSHeuristics 屬性應該設為 1。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
更正此警告

  1. 使用 Active Directory 編輯器 (如，ADSI 編輯器)，在 Active Directory 中尋找目錄服務物件。

    dSHeuristics 屬性可在下列位置找到

    CN=Configuration, CN=Services, CN=Windows NT, CN=Directory Service

  2. 為 dSHeuristics 輸入值 1。

若需 Hosted Exchange 環境的相關資訊，請參閱下列文件：

  • 《主機資訊》(英文) (http://go.microsoft.com/fwlink/?LinkId=46307)

  • 《Exchange Server 2000 Resource Kit》中的＜受主控的服務環境＞(英文) (http://go.microsoft.com/fwlink/?LinkId=46326)


Active Directory 中存在重複的 Microsoft Exchange 系統物件容器
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定網域命名內容中是否存在 Microsoft Exchange 系統物件容器。

如果 Exchange Server Analyzer 發現 Active Directory 中存在重複的 Microsoft Exchange 系統物件容器，就會顯示錯誤：「已為 Exchange 備妥 Active Directory 網域，但存在多個 Microsoft Exchange 系統物件容器。可能需要進行清理。」

在下列 Exchange Server 環境中，可能會出現此問題：

  • 已刪除及取代從 Active Directory 到 Exchange Server 5.5 的雙向 Active Directory 連接器 (ADC) 伺服器連線協定。

  • 已備妥從 Exchange Server 5.5 到 Active Directory 的新單向 ADC 伺服器連線協定。

  • 執行 Exchange Server 5.5 的混合模式環境已遷移到 Exchange Server 2003 環境。

  • 已執行從外部郵件伺服器至 Exchange Server 2003 的遷移。

當 Exchange Server Analyzer 顯示此錯誤時，您必須刪除不當重複的 Microsoft Exchange 系統物件容器或組織單位 (OU)。存在重複的 Microsoft Exchange 系統物件容器時，無法透過重新執行 DomainPrep 來解決問題。必須識別並刪除不當重複的 Microsoft Exchange 系統物件容器。

若要移除重複的 Microsoft Exchange 系統物件容器

  1. 使用系統管理認證登入網域控制站

  2. 依序按一下 [開始]、[程式集]、[系統管理工具] 及 [Active Directory 使用者及電腦]。

  3. 在 [Active Directory 使用者及電腦] 管理主控台窗格中，按一下工具列功能表中的 [檢視]，並選取 [進階功能]。

  4. 在 [Active Directory 使用者及電腦] 管理主控台窗格中，找出不當重複的 Microsoft Exchange 系統物件容器或組織單位 (OU)。

  5. 確認不當重複的 Microsoft Exchange 系統物件容器或 OU 未包含有效的 Active Directory 物件。

  6. 在不當重複的 Microsoft Exchange 系統物件容器或 OU 上按一下滑鼠右鍵，再按 [刪除]。

  7. 在 Active Directory 對話方塊中按一下 [是]，確認刪除。

    附註：
    如果您要立即複寫變更，則必須手動初始化網域控制站之間的複寫。

若需有關 Exchange Server 發生此問題時的詳細資訊，請參閱下列微軟知識庫文件：

  • 316280＜XADM：'ADC Global Name' 屬性的描述＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=316280)

  • 252228＜XADM：ADC 似乎建立了重複的物件＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=252228)

  • 253800＜XADM：ADC 可能會在 Active Directory 中建立重複的物件＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=253800)

  • 274480＜XADM：從 Exchange Server 5.5 複寫物件到 Windows 2000 Active Directory 時，會建立重複物件＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=274480)

  • 288578＜XADM：ADC 在 Exchange Server 5.5 及 Active Directory 中建立重複的帳戶＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=288578)


存取 Active Directory 時發生錯誤
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具判定 Active Directory® 目錄服務網域控制站可能無法使用。請確認您有 Active Directory 網域控制站的網路連線。

若要更正此錯誤

  • 如果您在 Exchange Server Analyzer 中指定了 Active Directory 網域控制站，請嘗試不指定網域控制站連線。

  • 如果您未指定網域控制站，請指定正在執行且您可以使用的網域控制站。


存取 Exchange 系統管理群組時發生錯誤
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具判定 Exchange 組織已安裝在 Active Directory® 目錄服務樹系，且您已順利存取 Active Directory 中的 Exchange 組織組態資訊。不過，找不到包含 Exchange 伺服器的任何系統管理群組。

若要更正此錯誤：

  • 驗證您在 Active Directory 中有適當的權限可存取 Exchange 系統管理群組的容器。

  • 如果您執行 Exchange Server Analyzer 的工作站屬於不同的 Active Directory 樹系，或您未使用網域帳戶登入，則您可能必須連接到主控 Exchange 伺服器之樹系的 Active Directory 網域控制站。


存取 Exchange 組態容器時發生錯誤
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具判斷 Exchange 組態容器無法存取。Exchange 組織、系統管理群組及伺服器組態資訊是儲存於 Active Directory® 目錄服務中的組態命名內容中。若要存取 Exchange 組態資訊，必須能夠讀取 Active Directory 組態容器的 Microsoft Exchange 分支。

若要更正此錯誤：

  • 請確認您有讀取 Active Directory 組態容器的必要權限。

  • 請確認您有 Active Directory 網域控制站的網路連線。


未拒絕 Everyone 安全性群組建立頂層公用資料夾的權限
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2006-12-04

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 Everyone 安全性群組的安全性識別碼 (SID) 是否列在 Exchange 組織物件的 ntSecurityDescriptor 中。如果 Exchange Server Analyzer 發現組織物件的 ntSecurityDescriptor 中存在 Everyone 群組的 SID，就會顯示一則警告。此警告會指出未拒絕 Everyone 群組建立頂層公用資料夾的權限。

在 Exchange 2000 Server 中，預設會允許建立最上層公用資料夾的權限。然而，當執行 Exchange Server 2003 版本的 ForestPrep 或 Exchange Server 2007 版本的 PrepareAD 時，會拒絕 Everyone 安全性群組建立頂層公用資料夾的權限。這項拒絕功能被當作安全性措施執行。允許 Everyone 安全性群組建立頂層公用資料夾，會使組織易於遭受阻斷服務的攻擊。

因此，拒絕 Everyone 安全性群組建立頂層公用資料夾的權限，是最好的作法。如果您有 Exchange Server 2003 或 Exchange Server 2007，則應該分別執行 Exchange Server 2003 版本的 ForestPrep 或 Exchange Server 2007 版本的 PrepareAD。您可以在 Exchange 2000 Server 環境中執行 Exchange Server 2003 版本的 ForestPrep。不過，Exchange 2000 Server 的後續安裝將重設權限，以允許 Everyone 安全性群組建立最上層公用資料夾。

如果沒有 Exchange Server 2003 或 Exchange Server 2007，您可以手動設定此權限。請記住 Exchange 2000 Server 的後續安裝將重設此權限。因此，在每次安裝 Exchange 2000 Server 後，應手動設定此權限。若要設定權限，必須先在「Exchange 系統管理員」中顯示 [安全性] 索引標籤；只要在 Exchange Server 電腦的登錄中新增 ShowSecurityPage 項目即可。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定您瞭解如何在發生問題時還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要將 ShowSecurityPage 項目新增至登錄

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKEY_CURRENT_USER\Software\Microsoft\Exchange\ExAdmin

  3. 依序按一下 [編輯]、[新增]，再按一下 [DWORD 值]。

  4. 鍵入 ShowSecurityPage 作為新值的名稱，然後按 ENTER 鍵。

  5. 連按兩下 [ShowSecurityPage]，在 [數值資料] 欄位中鍵入 1，然後按一下 [確定]。

若要在 Exchange 2000 Server 環境中，手動拒絕 Everyone 安全性群組建立最上層公用資料夾的權限

  1. 開啟 [Exchange 系統管理員]。

  2. 在 Organization_Name 上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 在 [Organization_Name 內容] 頁面上，按一下 [安全性] 索引標籤。

  4. 在 [安全性] 索引標籤的 [群組或使用者名稱] 中，選取 [Everyone]。在 [Everyone 權限] 方塊中，向下捲動至 [建立頂層公用資料夾] 權限，清除 [允許] 欄位中的核取方塊，然後按一下 [套用]。

在編輯登錄之前，以及想瞭解有關如何編輯登錄的詳細資訊時，請閱讀微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關執行 Exchange Server 2003 ForestPrep 的詳細資訊，請參閱《Exchange Server 2003 部署手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47569)。

若需有關執行 Exchange Server 2007 PrepareAD 的詳細資訊，請參閱＜如何準備 Active Directory 和網域＞(英文) (http://go.microsoft.com/fwlink/?LinkId=78453)。

若需有關如何在 Exchange 2000 Server 中拒絕 Everyone 安全性群組建立最上層公用資料夾之權限的詳細資訊，請參閱知識庫文件 - 328808＜HOW TO：在 Exchange 2000 中移除使用者建立最上層公用資料夾的權限＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328808)。


Exchange 網域容器問題
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定網域命名內容中的 Microsoft Exchange System Objects 容器是否存在。如果 Exchange Server Analyzer 發現 Microsoft Exchange 系統物件容器不存在、無效或有錯誤，則會顯示錯誤。

當 Exchange DomainPrep 執行時，會在每一個網域中建立 Microsoft Exchange 系統物件容器。

您必須在發生此錯誤的網域中執行 DomainPrep。Exchange Server Analyzer 輸出會列出遺失 Microsoft Exchange 系統物件容器的網域名稱。

您用來執行 DomainPrep 的帳戶必須是本機網域的 Domain Admins 安全性群組的成員之一，以及是本機電腦系統管理員。

一般而言，您必須在下列網域中執行 DomainPrep:

  • 根網域。

  • 所有會包含 Exchange 2000 Server 或 Exchange Server 2003 電腦的網域。

  • 所有會包含 Exchange 2000 Server 或 Exchange Server 2003 信箱功能物件 (如使用者及群組) 的網域，即使在這些網域中不會安裝 Exchange 伺服器。

  • 所有會包含 Exchange 目錄存取元件有可能會使用的通用類別目錄伺服器之網域。

  • 所有會包含 Exchange 2000 Server 或 Exchange Server 2003 使用者及群組的網域，您會使用這些使用者及群組來管理 Exchange 組織。

若要執行 DomainPrep：

  1. 將 Exchange CD 插入光碟機中。您可以在網域中的任何電腦上執行 DomainPrep。

  2. 在命令提示字元下，鍵入 <drive>:\setup\i386\setup /DomainPrep，其中 <drive> 是光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面，請確定 [動作] 是設定為 DomainPrep。如果不是，請按下拉箭頭，然後按一下 DomainPrep。按 [下一步]。

  7. 在 [完成 Microsoft Exchange 精靈] 頁面，按一下 [完成]。

若需有關執行 Exchange Server 2003 DomainPrep 的詳細資訊，請參閱《Exchange 2003 Server 部署手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47569)。

若需有關執行 Exchange 2000 Server DomainPrep 的詳細資訊，請參閱技術白皮書＜Microsoft Exchange 2000 Server 安裝及設定＞(英文) (http://go.microsoft.com/fwlink/?LinkId=5906)。


找不到 Exchange 網域伺服器群組
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務來判定 Microsoft Exchange System Objects 物件的 ntSecurityDescriptor 屬性的值，以判定已在網域中執行的 DomainPrep 版本。

有兩個有效整數：

  • 若是 Exchange 2000 Server，ntSecurityDescriptor 值是 4406。

  • 若是 Exchange Server 2003，ntSecurityDescriptor 值是 6936。

如果判定已使用上述任何 DomainPrep 版本，Exchange Server Analyzer 會查詢 Active Directory 來判定 Microsoft Exchange 系統物件物件的 objectGuid 屬性值，以判定 Exchange 網域伺服器群組是否存在。如果 Exchange Server Analyzer 判定此群組不存在，則會顯示錯誤訊息。

若要解決此錯誤，請執行 Exchange 2000 Server DomainPrep 或 Exchange Server 2003 DomainPrep 的最後發行版本。您用來執行 DomainPrep 的帳戶必須是本機網域的 Domain Admins 安全性群組的成員之一，以及是本機電腦系統管理員。

您必須在下列網域中執行 DomainPrep：

  • 根網域。

  • 所有會包含 Exchange 2000 Server 或 Exchange Server 2003 電腦的網域。

  • 所有會包含 Exchange 2000 Server 或 Exchange Server 2003 信箱功能物件 (如使用者及群組) 的網域，即使在這些網域中不會安裝 Exchange 伺服器。

  • 所有會包含 Exchange 目錄存取元件有可能會使用的通用類別目錄伺服器之網域。

  • 所有會包含 Exchange 2000 Server 或 Exchange Server 2003 使用者及群組的網域，您會使用這些使用者及群組來管理 Exchange 組織。

若要執行 DomainPrep：

  1. 將 Exchange CD 插入光碟機中。您可以在網域中的任何電腦上執行 DomainPrep。

  2. 在命令提示字元下，鍵入 <drive>:\setup\i386\setup /DomainPrep，其中 <drive> 是光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面，請確定 [動作] 是設定為 DomainPrep。如果不是，請按下拉箭頭，然後按一下 DomainPrep。按 [下一步]。

  7. 在 [完成 Microsoft Exchange 精靈] 頁面，按一下 [完成]。

若需有關執行 Exchange Server 2003 DomainPrep 的詳細資訊，請參閱《Exchange 2003 Server 部署手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47569)。

若需有關執行 Exchange 2000 Server DomainPrep 的詳細資訊，請參閱＜Microsoft Exchange 2000 Server 安裝及設定＞(英文) (http://go.microsoft.com/fwlink/?LinkId=5906)。


找不到 Exchange Enterprise Servers 群組
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務來判定 Microsoft Exchange 系統物件物件的 ntSecurityDescriptor 屬性值，以判定已在網域中執行的 DomainPrep 版本。

有兩個有效整數：

  • 若是 Exchange 2000 Server，ntSecurityDescriptor 值是 4406。

  • 若是 Exchange Server 2003，ntSecurityDescriptor 值是 6936。

如果判定使用的是上述其中一個 DomainPrep 版本，則 Exchange Server Analyzer 會查詢 Active Directory 以判定 Microsoft Exchange System Objects 物件的 objectGuid 屬性值，來判定 Exchange Enterprise Servers 群組是否存在。如果 Exchange Server Analyzer 判定此群組不存在，則會顯示錯誤訊息。

若要解決此錯誤，請執行 Exchange 2000 Server DomainPrep 或 Exchange Server 2003 DomainPrep 的最後發行版本。您用來執行 DomainPrep 的帳戶必須是本機網域的 Domain Admins 安全性群組的成員之一，以及是本機電腦系統管理員。

您必須在下列網域中執行 DomainPrep：

  • 根網域。

  • 所有會包含 Exchange 2000 Server 或 Exchange Server 2003 電腦的網域。

  • 所有會包含 Exchange 2000 Server 或 Exchange Server 2003 信箱功能物件 (如使用者及群組) 的網域，即使在這些網域中不會安裝 Exchange 伺服器。

  • 所有會包含 Exchange 目錄存取元件有可能會使用的通用類別目錄伺服器之網域。

  • 所有會包含 Exchange 2000 Server 或 Exchange Server 2003 使用者及群組的網域，您會使用這些使用者及群組來管理 Exchange 組織。

若要執行 DomainPrep：

  1. 將 Exchange CD 插入光碟機中。您可以在網域中的任何電腦上執行 DomainPrep。

  2. 在命令提示字元下，鍵入 <drive>:\setup\i386\setup /DomainPrep，其中 <drive> 是光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面，請確定 [動作] 是設定為 DomainPrep。如果不是，請按下拉箭頭，然後按一下 DomainPrep。按 [下一步]。

  7. 在 [完成 Microsoft Exchange 精靈] 頁面，按一下 [完成]。

若需有關執行 Exchange Server 2003 DomainPrep 的詳細資訊，請參閱《Exchange 2003 Server 部署手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47569)。

若需有關執行 Exchange 2000 Server DomainPrep 的詳細資訊，請參閱＜Microsoft Exchange 2000 Server 安裝及設定＞(英文) (http://go.microsoft.com/fwlink/?LinkId=5906)。


Lost and Found 容器中的 Exchange 物件
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2006-12-01

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 Configuration 容器下之 LostAndFoundConfig 容器中是否存在任何物件。如果 Exchange Server Analyzer 發現 LostAndFoundConfig 容器中存在物件，就會顯示一則錯誤，且會一併顯示物件及衍生物件的物件類別。

LostAndFoundConfig 容器保存 Active Directory 無法調解的物件。請確定刪除 LostAndFoundConfig 容器中的所有物件，原因是 Exchange 會嘗試使用這些物件。例如，當 Exchange 依物件類別 (即，伺服器) 查詢 Active Directory 時，會將所有物件 (不論它們是否位於 LostAndFoundConfig 容器中) 當成有效物件來傳回。因此，Exchange 可能會嘗試連線到 the LostAndFoundConfig 容器下的「伺服器」，而非實際物件。這會導致 Exchange 發生無法預期的行為，甚至造成伺服器失敗。存在這些物件，也會導致無法建立相同類別的物件。

若要解決此問題，您必須使用 Active Directory Service Interfaces (ADSI) 編輯器，從 Active Directory 中移除 LostAndFoundConfig 容器中的項目。

注意：
使用 ADSI 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或 Exchange Server 2007，或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
附註：
Windows 2000 Server 及 Windows Server 2003 支援工具有提供 ADSI 編輯器工具。

若要更正此錯誤

  1. 開啟 [ADSI 編輯器] MMC 嵌入式管理單元。

  2. 在 [執行] 功能表上，按一下 [連線至]。

  3. 在 [連線設定] 對話方塊的 [名稱] 欄位中，輸入 ADSI 連線的名稱。在 [連線點] 之下，選取 [選取熟知的命名內容]，然後再選取下拉式功能表中的 [組態]。按一下 [確定]。

  4. 在左窗格中，連按兩下 [組態] 物件，然後再連按兩下 LostAndFoundConfig。

  5. 在右窗格中，刪除所有物件及容器。在物件或容器上按一下滑鼠右鍵，再依序按下 [刪除] 及 [是]。

  6. 結束 ADSI 編輯器。


Exchange 組織沒有收件者原則
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個 Exchange 組織的收件者原則物件內的 Name 屬性值。如果 Exchange Server Analyzer 判定沒有 [收件者原則] 物件，或 [收件者原則] 物件未包含任何收件者原則，將會顯示錯誤。

當已安裝 Exchange Server 時，就會建立將簡易郵件傳送通訊協定 (SMTP) 及 X.400 位址套用到 Exchange 組織內所有收件者的預設收件者原則。您可以修改預設原則或建立新的原則。不過，絕對不能刪除預設的原則。Exchange 組織內的所有收件者都必須要有 SMTP 和 X.400 位址。 如果 Exchange 組織沒有收件者原則，則可能會有可靠性問題。

若要建立收件者原則

  1. 依序按一下 [開始]、[所有程式]、[Microsoft Exchange] 及 [系統管理員]。

  2. 在 [Exchange 系統管理員] 的左窗格中，展開組織，接著展開 [收件者]，在 [收件者原則] 上按一下滑鼠右鍵，指向 [新增]，然後按一下 [收件者原則]。

  3. 在 [新增原則] 對話方塊中，選擇要建立的原則類型，其方法是選取 [電子郵件地址] 核取方塊、 [信箱管理員設定] 核取方塊或兩者皆選，再按一下 [確定]。

  4. 在 [內容] 對話方塊中，鍵入新收件者原則的名稱，然後按一下 [修改] 建立收件者原則的篩選器。

    附註：
    如果不建立篩選器，該原則將不會套用至任何收件者。

  5. 若要自訂收件者原則，請切換至 [內容] 對話方塊中的 [電子郵件地址 (原則)] 索引標籤或 [信箱管理員設定] 索引標籤。請使用這些索引標籤上的設定來設定收件者原則，再按一下 [確定] 建立原則。

  6. 在 [Exchange 系統管理員] 中的收件者原則上按一下滑鼠右鍵，然後按一下 [立即套用原則]。

若需有關收件者及收件者原則的詳細資訊，請參閱《Exchange Server 2003 系統管理手冊》(http://go.microsoft.com/fwlink/?LinkId=47617) 中的＜管理收件者及收件者原則＞(英文)。

若需有關建立及設定收件者原則的詳細資訊，請參閱微軟知識庫文件 - 249299＜如何：設定 Exchange 2000 Server 中的收件者原則＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=249299)。


Exchange 組織沒有系統原則
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個 Exchange 組織的系統原則物件內的每個系統原則名稱。如果 Exchange Server Analyzer 判定沒有系統原則物件，或系統原則物件未包含任何系統原則，將會顯示錯誤。

您可以透過單一組態物件，例如信箱儲存區、公用資料夾儲存區或伺服器設定，來設定多個 Exchange 伺服器的參數，以便使用系統原則物件簡化系統管理。在預設的情況下，在組織中執行 ForestPrep 時會建立下列系統原則。

  • 隱藏 DL 成員資格

  • 擁有郵件功能的收件者

  • 擁有郵件功能的使用者

如果 Exchange 組織中沒有這些預設的系統原則，可能會遇到可靠性問題。若要重新建立預設的系統原則，則必須執行 ForestPrep。

若要執行 Exchange Server 2003 ForestPrep

  1. 將 Exchange CD 插入光碟機中。

  2. 在 [開始] 功能表中，按一下 [執行]，然後輸入磁碟機:\setup\i386\setup /ForestPrep，其中的磁碟機 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面，請確定 [動作] 是設定為 [ForestPrep]。如果不是，請按下拉箭頭，然後按一下 [ForestPrep]。按 [下一步]。

    重要事項：
    如果 [ForestPrep] 未出現在 [動作] 下，則您可能在步驟 2 中拼錯了 ForestPrep 命令。如果拼錯了 ForestPrep 命令，請返回步驟 2，並重新鍵入該命令。

  7. 在 [Microsoft Exchange Server 系統管理員帳戶] 頁面的 [帳戶] 方塊中，鍵入要負責安裝 Exchange 的帳戶或群組名稱。

    附註：
    您指定的帳戶也將具有權限以使用 [Exchange 管理委派精靈]，來建立其他 Exchange 系統管理員帳戶。若需有關 [Exchange 管理委派精靈] 的詳細資訊，請參閱《Exchange Server 2003 系統管理手冊》(英文) (http://go.microsoft.com/fwlink/?linkid=47617)。

  8. 按 [下一步] 以啟動 ForestPrep。ForestPrep 啟動之後，就無法取消該處理程序。

    附註：
    ForestPrep 可能需要很長時間才能完成，視您的網路拓撲及 Microsoft Windows® 2000 Server 或 Microsoft Windows Server™ 2003 網域控制站的速度而定。

  9. 在 [完成 Microsoft Exchange 精靈] 頁面，按一下 [完成]。

若需有關如何在 Exchange 中使用系統原則的詳細資訊，請參閱微軟知識庫文件 - 253838＜XADM：收件者更新服務如何套用系統原則＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=253838)。

若需有關系統原則的詳細資訊，請參閱《Exchange Server 2003 技術參考手冊》(http://go.microsoft.com/fwlink/?LinkId=47891) 中的＜Exchange 系統管理員結構＞(英文)。

若需有關如何在 Exchange 中建立非預設系統原則的詳細資訊，請參閱知識庫文件 - 256141＜XADM：如何在 Exchange 2000 中建立系統原則＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256141)。


已覆寫通用類別目錄 NSPI 通訊埠
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2007-01-15

Microsoft® Exchange Server Analyzer 工具會讀取通用類別目錄伺服器的下列登錄項目，以判定是否已設定 TCP/IP Port 登錄機碼：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Parameters\TCP/IP Port

如果 Exchange Server Analyzer 發現已建立並設定 TCP/IP Port 登錄機碼，就會顯示非預設的組態訊息。

通用類別目錄伺服器需要使用特定通訊埠來服務 MAPI 用戶端時，就需要有 TCP/IP Port 登錄機碼。如果您在 Exchange 環境中沒有這類需求，則可以移除此機碼。

.

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要刪除通用類別目錄伺服器的 TCP/IP 通訊埠

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\SYSTEM\CurrentControlSet\Services\NTDS\Parameters

  3. 以滑鼠右鍵按一下 TCP/IP Port 機碼，再按 [刪除]。

  4. 關閉登錄編輯程式。

  5. 重新啟動電腦，使此設定生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關設定 RPC over HTTP 的詳細資訊，請參閱下列知識庫文件：

  • 833401＜如何在 Exchange Server 2003 中為單一伺服器設定 RPC over HTTP＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330＜如何疑難排解 Office Outlook 2003 用戶端的 RPC over HTTP 連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)

  • 298369＜如何設定通用類別目錄伺服器以在服務 MAPI 用戶端時使用特定的通訊埠＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298369)

  • 24823＜Exchange Server 2003 RPC over HTTP 部署案例＞(英文) (http://go.microsoft.com/fwlink/?linkid=24823)


通用類別目錄通訊埠 3268 未回應
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定此伺服器的 isGlobalCatalogReady 屬性值。此屬性值為 True 表示此目錄伺服器也是一台正在運作的通用類別目錄伺服器，值為 False 則表示此目錄伺服器不是通用類別目錄伺服器。

然後 Exchange Server Analyzer 會連線至 Exchange 伺服器上的通訊埠 3268，以確認通訊埠有回應。

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • 伺服器是通用類別目錄伺服器。

  • 通訊埠 3268 沒有回應。

附註：
如果執行 Exchange Server Analyzer 的電腦與通用類別目錄伺服器之間有防火牆，則可能會錯誤地顯示此訊息。

當已選取通用類別目錄伺服器核取方塊，但尚未重新啟動伺服器時，通常會發生此問題。

若要更正此問題

  • 重新啟動伺服器。

若需有關升級網域控制站的詳細資訊，請參閱微軟知識庫文件 - 304403＜XADM：將網域控制站升級至通用類別目錄伺服器的 Exchange 注意事項＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=304403)。


群組類別架構錯誤
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2006-12-01

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判斷 msExchBaseClass 類別是否出現在 Active Directory 架構中的群組物件的 auxiliaryClass 屬性中。

Active Directory 有預先定義的類別，來定義目錄要正確運作時所需的所有不同物件類型。建立物件定義的方式是在類別彼此間建立巢狀類別。巢狀類別在類別之間產生父子關係。

安裝 Exchange 2000 Server、Exchange Server 2003 及 Exchange Server 2007 時，會將 msExchBaseClass 類別新增至 Active Directory。msExchBaseClass 類別是基本輔助類別，它會套用至 Exchange 2000 Server、Exchange Server 2003 及 Exchange Server 2007 的 CDO (CDOEX) 所延伸的所有類別。CDOEX 提供基本的元件物件模型 (COM) 類別和介面，用來管理 Exchange 儲存區中大部份的資訊類型。

不正確地修改 Active Directory 架構，會破壞 msExchBaseClass 類別和群組物件之 auxiliaryClass 屬性之間的關係。此破壞會造成 Exchange 伺服器不穩定 (例如，收件者更新服務處理錯誤)，或阻止安裝新的 Exchange Server 200x 伺服器到組織中。

如果 Exchange Server Analyzer 發現 msExchBaseClass 類別未出現在 Active Directory 架構中的群組物件的 auxiliaryClass 屬性中，這表示此關係已經破裂。如果 msExchBaseClass 類別未出現在 Active Directory 架構的群組物件的 auxiliaryClass 屬性中，Exchange Server Analyzer 就會顯示錯誤。

若要更正此錯誤，請連絡 Microsoft 客戶支援服務 (http://go.microsoft.com/fwlink/?LinkId=41364)。


受主控的 Exchange 需要原生模式的 Exchange 組織
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已將 Exchange Server 環境設定為受主控的 Exchange 環境。如果 Exchange Server 環境是受主控的 Exchange 環境，則 Exchange Server Analyzer 會查詢 Active Directory，以判定 Exchange 組織是否在混合模式下執行。

如果 Exchange 組織是在混合模式下執行，將會顯示警告。受主控的 Exchange 解決方案需要使用原生模式的組織。

切換至原生模式之後，即無法再切換回混合模式。

若要切換至原生模式

  1. 啟動 [Exchange 系統管理員]：按一下 [開始]，依序指向 [所有程式]、[Microsoft Exchange]，再按一下 [系統管理員]。

  2. 在主控台樹狀目錄中，在要切換到原生模式的組織上按一下滑鼠右鍵，再按一下 [內容]。

  3. 在 [<組織名稱> 內容] 中，按一下 [變更作業模式] 下的 [變更模式]。

  4. 如果確定要永久切換到原生模式，請在警告對話方塊中，按一下 [是]。按一下 [套用] 接受新的 Exchange 模式。

若要完全使用 Exchange 原生模式，您必須重新啟動組織內所有 Exchange 伺服器上的 Microsoft Exchange Information Store 服務。雖然您不需同時重新啟動所有 Microsoft Exchange Information Store 服務，但是必須在每部伺服器上重新啟動此服務，讓每部伺服器都能使用 Exchange 原生模式功能。等到這項原生模式變更複寫到本機 Microsoft Windows® 網域控制站後，再重新啟動伺服器上的服務。

若要重新啟動 Microsoft Exchange Information Store 服務

  1. 按一下 [開始]、[執行]，鍵入 services.msc，再按一下 [確定]。

  2. 在 [服務 (本機)] 窗格中，尋找 [Microsoft Exchange Information Store] 服務。

  3. 在服務上按一下滑鼠右鍵，再按一下 [重新啟動]。

若需有關受主控的 Exchange 環境的詳細資訊，請參閱下列文件：

  • 《主機資訊》(英文) (http://go.microsoft.com/fwlink/?LinkId=46307)

  • 《Exchange Server 2000 Resource Kit》(http://go.microsoft.com/fwlink/?LinkId=46326)中的＜第 23 章 - 主控式服務環境＞(英文)

若需有關從混合模式轉換為原生模式的詳細資訊，請參閱微軟知識庫文件 - 32779＜如何在 Exchange 中從混合模式轉換為原生模式＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779)。


基礎結構 FSMO 伺服器角色沒有回應
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定網域命名內容中之基礎結構主機的 fSMORoleOwner 屬性值。例如，在名為 contoso.com 的網域中，基礎結構主機的 fSMORoleOwner 屬性值為 CN=Infrastructure,DC=contoso,DC=com。接著，Exchange Server Analyzer 會嘗試對目前持有這個角色的網域控制站之 TCP 通訊埠 389，開啟輕量型目錄存取通訊協定 (LDAP) 連線。若 Exchange Server Analyzer 無法連線到這個網域控制站，就會顯示一則錯誤。

每當網域中有群組成員更名或變更，基礎結構主機就會更新群組對使用者 (group-to-user) 的參照。具有群組網域之基礎結構主機角色的網域控制站，會更新跨網域的群組對使用者參考，以反映使用者的新名稱。基礎結構主機會定期掃描網域帳戶，並確認群組的成員資格。如果使用者帳戶移至新的網域，基礎結構主機就會識別使用者帳戶的新網域，並依實際情況來更新群組。基礎結構主機在本機更新這些參照之後，就會使用複寫功能來更新網域的所有其他複本。如果無法使用基礎結構主機，就會延遲更新。無論何時，都只能有一部網域控制站用來作為各網域中的基礎結構主機。

若要更正此錯誤

  1. 確認錯誤訊息中指出的目錄伺服器已在連線中，並且可以讓貴組織內的 Exchange 伺服器存取。

  2. 如果這個目錄伺服器關閉，您必須將基礎結構主機角色指派給其他的網域控制站。

若需有關將基礎結構主機角色從一個網域控制站轉移至另一個網域控制站的資訊，請參閱下列微軟知識庫文件：

  • 若為 Microsoft Windows Server™ 2003，請參閱 324801＜HOW TO：在 Windows Server 2003 中檢視及轉移 FSMO 角色＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)

  • 若為 Microsoft Windows 2000 Server，請參閱 255690＜如何在圖形化使用者介面檢視傳送 FSMO 角色＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690)


Exchange 組織物件的版本屬性無效
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2007-02-28

Microsoft Exchange Server Analyzer 工具會查詢 Active Directory 目錄服務，以判定 Exchange 的架構版本資訊。尤其，Exchange Server Analyzer 會檢查下列 Active Directory 物件，以判定 rangeUpper 屬性目前的值：

CN=ms-Exch-Schema-Version-Pt,CN=Schema,CN=Configuration,DC=<DN-of-forest-root-domain>

rangeUpper 的值為 4397，表示已安裝 Exchange 2000 Server。

rangeUpper 的值為 6870，表示已安裝 Exchange Server 2003。

rangeUpper 的值為 10637，表示已安裝 Exchange Server 2007。

如果 Exchange Server Analyzer 發現 rangeUpper 有其他值，就會顯示一則錯誤。

rangeUpper 值是在 ForestPrep 處理程序期間由 Exchange 2000 Server 或 Exchange Server 2003 輸入。4397、6870 或 10637 以外的值通常表示使用 Exchange Beta 版或發行前版本來執行 ForestPrep，或是使用 Exchange Server 2007 執行 PrepareDomain。

若要對 Exchange 2000 Server 或 Exchange Server 2003 解決這個問題，請使用您環境中安裝的 Exchange 版本來重新執行 ForestPrep 處理程序。若是 Exchange Server 2007，請使用您環境中安裝的 Exchange 版本來重新執行 PrepareSchema。執行 ForestPrep 或 PrepareSchema 時，您必須以至少擁有下列權限的帳戶登入：

  • 企業系統管理員

  • 架構系統管理員

  • 網域系統管理員

  • 本機電腦系統管理員 (如果只在成員伺服器上執行)

對 Exchange 2000 Server 或 Exchange Server 2003 更正此錯誤

  1. 執行 setup.exe /forestprep。

  2. 確認 ForestPrep 處理程序是否順利完成。

對 Exchange Server 2007 更正此錯誤

  1. 執行 setup.exe /PrepareSchema。

  2. 確認 PrepareSchema 處理程序是否順利完成。

若需安裝 Exchange 及執行 PrepareSchema 處理程序的詳細資訊，請參閱下列產品文件：

  • ＜如何準備 Active Directory 和網域＞(英文) http://go.microsoft.com/fwlink/?LinkId=78453

若需安裝 Exchange 及執行 ForestPrep 處理程序的詳細資料，請參閱下列微軟知識庫文件：

  • 312371＜HOW TO: 在 Exchange 2000 Server 中使用 ForestPrep 準備樹系＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=312371)。本文適用於 Exchange 2000 Server 和 Exchange Server 2003。

  • 274737＜如何確認 ForestPrep 及 DomainPrep 在 Exchange 2000 Server 或 Exchange Server 2003 中順利完成＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=274737)。

  • 828765＜安裝 Exchange Server 2003 元件必須具有的權限＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828765)。


原生模式系統管理群組中有舊版帳戶資訊
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每一個 Exchange 系統管理群組物件上的 msExchLegacyAccount 屬性是否包含資料。

Exchange Server Analyzer 也會查詢 Active Directory，以判定每個系統管理群組的 msExchAdminGroupMode 屬性值。msExchAdminGroupMode 屬性值為 0 時，表示該系統管理群組是處於 Exchange 原生模式。值為 1 表示是純 Exchange Server 5.5 環境，值為 2 表示是 Exchange 混合模式。

如果 Exchange Server Analyzer 發現 msExchLegacyAccount 屬性包含資料，但 msExchAdminGroupMode 屬性的值是 0，就會顯示一則錯誤。

當您切換到 Exchange 原生模式時，會刪除 msExchLegacyAccount 屬性。這個屬性僅在仍有 Exchange Server 5.5 存在的混合模式 Exchange 組織中才會使用。實際的屬性資料是 Exchange Server 5.5 服務帳戶，在升級與 Service Pack 安裝期間，該服務帳戶若是存在於原生模式 Exchange 組織中的 msExchLegacyAccount 屬性中，就會造成功能異常。事實上，只要有這個屬性存在，不論其中是否有包含資料，都足以造成功能異常。這是因為 Exchange 安裝程式使用此屬性作為探查 Exchange 組織是處於混合模式或原生模式的方法。如果此屬性已存在，對於實際上在原生模式中的安裝作業，Exchange 安裝程式也會以混合模式組態執行。

通常如果使用 [Active Directory Service Interfaces (ADSI) 編輯器] 嵌入式管理單元手動移除 Active Directory 中的資料，則 msExchLegacyAccount 屬性還是會存在。

您必須使用 LDP (ldp.exe) 工具來手動編輯 msExchLegacyAccount 屬性，才能從該屬性移除此資料。您必須使用 LDP 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端，它們可完全移除目錄中的資料及屬性。在此情況下，ADSI 編輯器嵌入式管理單元不敷使用，因為它只移除資料，並且留下屬性。LDP.exe 內含在 Windows® 支援工具套件中。

注意：
使用 ADSI 編輯器、LDP 工具或其他 LDAP 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要移除 msExchLegacyAccount 屬性

  1. 啟動 LDP.exe。

  2. 在 [Connection] 功能表中，按一下 [Connect]；在 [Connect] 對話方塊中，輸入位於和 Exchange 組織相同的 Active Directory 樹系之網域控制站名稱，然後按一下 [OK]。

  3. 在 [Connection] 功能表中，按一下 [Bind]；在 [Bind] 對話方塊中，輸入在「系統管理群組」的層級上至少具有「Exchange 系統高權限管理員」權限的認證，然後按一下 [OK]。

  4. 在 [View] 功能表上，按一下 [Tree]；在 [Tree View] 對話方塊中，如果您是從根網域連線，請將欄位保持空白，否則請輸入 CN=Configuration,DC=Domain_name, DC=Domain_suffix，其中 Domain_name 是 Active Directory 樹系中的根網域，Domain_suffix 是網域尾碼，例如 com、net 及 org。按一下 [OK]。

  5. 展開 LDP 左側窗格內的階層檢視，直到開啟您的系統管理群組。若要做這樣的處理，依下列順序連按兩下節點 (請注意 LDP 中的每一個節點之後都會跟著完整的「辨別名稱 (DN)」；此處為便於示範，僅顯示最左邊的 CN)：

    1. DC=Domain_name

    2. CN=Configuration

    3. CN=Services

    4. CN=Microsoft Exchange

    5. CN=Organization_name

    6. CN=Administrative Groups

    7. CN=Administrative_group_name

    在 LDP 的詳細資料 (右) 窗格中，向下捲動，檢視您的系統管理群組屬性。如果有 msExchLegacyAccount 屬性，您必須刪除它。如果有 msExchLegacyAccount 屬性，則通常也會有 msExchLegacyDomain 及 msExchEncryptedPassword 屬性。若存在，則必須將其一併刪除。

  6. 在 LDP 的階層 (左) 窗格中，以滑鼠右鍵按一下 Administrative_group_name，再按一下 [Modify]。

  7. 在 [Modify] 對話方塊中，驗證 [Dn] 欄位列出的完整 DN，確實識別您要修改的系統管理群組。它應該類似如下：CN=Administrative_group_name,CN=Administrative Groups,CN=Organization_name,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Domain_name。

  8. 在 [Modify] 對話方塊中，選取位於 [Operations] 下的 [Delete]；在 [Edit entry] 下，於 [Attribute] 欄中輸入 msExchLegacyAccount，然後按一下 [Enter]。此動作會將 msExchLegacyAccount 加到 [Entry List] 中。[Entry List] 定義當您按一下 [Run] 時，將會刪除的屬性。

  9. 如果 msExchLegacyDomain 或 msExchEncryptedPassword 屬性存在於系統管理群組中，請依步驟 8 所述，將它們加到 [Entry List] 中。

  10. 當 [Entry List] 中包含您必須刪除的所有屬性時，按一下 [Run]。LDP 詳細資料窗格中，會出現一則狀態訊息。

  11. 在 [Connection] 功能表中，按一下 [New]，以清除 LDP 詳細資料窗格。

  12. 瀏覽到 CN=Administrative_group_name，並按兩下物件。檢閱右窗格中的內容，確認屬性都已刪除。

若需有關使用 LDP 工具修改 Active Directory 的詳細資訊，請參閱微軟知識庫文件 - 260745＜XADM：Using the LDP Utility to Modify Active Directory Object Attributes＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。


Exchange 組織的 legacyExchangeDN 屬性無效
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2007-02-01

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 Exchange 組織物件上 legacyExchangeDN 屬性的格式。如果 Exchange Server Analyzer 發現 legacyExchangeDN 屬性無效或不正確，就會顯示一則錯誤。

此屬性值的格式是 /o=Organization，其中 Organization 是 Exchange 組織名稱。如果該值的開頭不是 /o= 或 /O=，則會視為格式不正確。應儘快更正此問題。

對 Exchange 2000 Server 或 Exchange Server 2003 更正此錯誤

  1. 執行 Exchange Server ForestPrep 處理程序。在此處理程序期間，如果安裝程式判定 legacyExchangeDN 的格式錯誤，安裝程式就會自動更正問題。

對 Exchange Server 2007 更正此錯誤

  1. 執行 Exchange Server PrepareAD 處理程序。在此處理程序期間，如果安裝程式判定 legacyExchangeDN 的格式錯誤，安裝程式就會自動更正問題。

若需有關 ForestPrep 處理程序的詳細資訊，請參閱微軟知識庫文件 - 312371＜HOW TO：在 Exchange 2000 Server 中使用 ForestPrep 準備樹系＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=312371)。

若需有關 PrepareAD 處理程序的詳細資訊，請參閱＜如何準備 Active Directory 和網域＞(英文) (http://go.microsoft.com/fwlink/?LinkId=78453)。

若需有關 legacyExchangeDN 屬性以及如何變更它的詳細資訊，請參閱下列微軟知識庫文件：

  • 324606＜XADM：如何使用 Legacydn.exe 更正 Exchange 組織或系統管理群組名稱＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324606)。

  • 286783＜XADM：在 Exchange 2000 Server 中更新空閒及忙碌資料時的錯誤訊息＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286783)。

  • 328841＜XADM：MBconn.exe 問題的因應措施＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301585)。


原生模式系統管理群組中有舊版網域資訊
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個 Exchange 系統管理群組物件的 msExchLegacyDomain屬性是否包含資料。

Exchange Server Analyzer 也會查詢 Active Directory，以判定每個系統管理群組的 msExchAdminGroupMode 屬性值。msExchAdminGroupMode 屬性值為 0 時，表示該系統管理群組是處於 Exchange 原生模式。值 1 表示是純 Exchange Server 5.5 環境，值 2 表示是 Exchange 混合模式。

如果 Exchange Server Analyzer 發現 msExchLegacyDomain 屬性包含資料，但 msExchAdminGroupMode 屬性的值是 0，就會顯示一則錯誤。

當您將 Exchange 切換至原生模式時，會刪除 msExchLegacyDomain 屬性。這個屬性僅在仍有 Exchange Server 5.5 存在的混合模式 Exchange 組織中才會使用。實際的屬性資料為 Exchange Server 5.5 服務帳戶網域，在升級和 Service Pack 安裝期間，該服務帳戶若是存在於原生模式 Exchange 組織中的 msExchLegacyDomain 屬性中，就會造成功能異常。事實上，只要有這個屬性存在，不論其中是否有包含資料，都足以造成功能異常。這是因為 Exchange 安裝程式將此屬性作為觀察 Exchange 組織為混合模式或原生模式的方法。如果此屬性已存在，對於實際上在原生模式中的安裝作業，Exchange 安裝程式也會以混合模式組態執行。

如果您使用 Active Directory Service Interfaces (ADSI) 編輯器嵌入式管理單元手動移除 Active Directory 中的資料，則 msExchLegacyDomain 可能還是會存在。

您必須利用 LDP (ldp.exe) 工具來手動編輯 msExchLegacyDomain，才能從該屬性移除此資料。您必須使用 LDP 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端，它們可完全移除目錄中的資料及屬性。在此情況下，[ADSI 編輯器] 嵌入式管理單元不敷使用，因為它只移除資料，卻留下屬性。LDP.exe 內含在 Windows® 支援工具套件中。

注意：
使用 ADSI 編輯器、LDP 工具或其他 LDAP 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要移除 msExchLegacyDomain 屬性

  1. 啟動 LDP.exe。

  2. 在 [Connection] 功能表中，按一下 [Connect]；在 [Connect] 對話方塊中，輸入位於和 Exchange 組織相同的 Active Directory 樹系之網域控制站名稱，然後按一下 [OK]。

  3. 在 [Connection] 功能表中，按一下 [Bind]；在 [Bind] 對話方塊中，輸入在「系統管理群組」層級上至少具有「Exchange 系統高權限管理員」權限的認證，然後按一下 [OK]。

  4. 在 [View] 功能表上，按一下 [Tree]；在 [Tree View] 對話方塊中，如果您是從根網域連線，請將欄位留空，否則請輸入 CN=Configuration,DC=Domain_name, DC=Domain_suffix，其中 Domain_name 是 Active Directory 樹系中的根網域，Domain_suffix 是網域尾碼，例如 com、net 或 org。按一下 [確定]。

  5. 展開 LDP 左側窗格內的階層檢視，直到開啟您的系統管理群組。若要做這樣的處理，依下列順序連按兩下節點 (請注意 LDP 中的每一個節點之後都會跟著完整的「辨別名稱 (DN)」；此處為便於示範，僅顯示最左邊的 CN)：

    • DC=Domain_name

    • CN=Configuration

    • CN=Services

    • CN=Microsoft Exchange

    • CN=Organization_name

    • CN=Administrative Groups

    • CN=Administrative_group_name

    在 LDP 的詳細資料 (右) 窗格中，向下捲動，檢視您的系統管理群組屬性。如果 msExchLegacyDomain 屬性還在的話，您必須將它刪除。如果 msExchLegacyDomain 屬性還在，則有可能 msExchLegacyDomain 與 msExchEncryptedPassword 屬性也還存在。若存在，則必須將其一併刪除。

  6. 在 LDP 的階層 (左) 窗格中，以滑鼠右鍵按一下 Administrative_group_name，再按一下 [Modify]。

  7. 在 [Modify] 對話方塊中，驗證 Dn 欄列出的完整 DN，確實識別您要修改的系統管理群組。它應該類似如下：CN=Administrative_group_name,CN=Administrative Groups,CN=Organization_name,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Domain_name。

  8. 在 [Modify] 對話方塊中，選取位於 [Operations] 下的 [Delete]；在 [Edit entry] 下，於 [Attribute] 欄中輸入 msExchLegacyAccount，然後按一下 [Enter]。此動作會將 msExchLegacyAccount 加到 [Entry List] 中。[Entry List] 定義當您按一下 [Run] 時，將會刪除的屬性。

  9. 如果 msExchLegacyAccount 或 msExchEncryptedPassword 屬性兩者之一存在於系統管理群組中，請如步驟 8 中所述，將這兩個屬性加入至 [Entry List]。

  10. 當 [Entry List] 中包含您必須刪除的所有屬性時，按一下 [Run]。LDP 詳細資料窗格中，會出現一則狀態訊息。

  11. 在 [Connections] 功能表中，按一下 [New]，以清除 LDP 詳細資料窗格。

  12. 瀏覽到 CN=Administrative_group_name，並按兩下物件。檢閱右窗格中的內容，確認屬性都已刪除。

若需有關使用 LDP 工具修改 Active Directory 的詳細資訊，請參閱微軟知識庫文件 - 260745＜XADM：Using the LDP Utility to Modify Active Directory Object Attributes＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。


此系統管理群組的 LegacyExchangeDN 與父組織不符
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2006-11-30

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定系統管理群組容器物件上之 legacyExchangeDN 屬性的格式。如果 Exchange Server Analyzer 發現系統管理群組上的 legacyExchangeDN 屬性與 Exchange 組織的 legacyExchangeDN 不符，就會顯示一則錯誤。

Exchange 會使用 legacyExchangeDN 值來識別 Active Directory 內的 Exchange 物件。legacyExchangeDN 值是一個辨別名稱，指出物件隸屬於 Exchange 組織的何處，例如：

/o= organization /ou= administrative group

像伺服器及資料夾階層之類的物件，會從系統管理群組繼承其 legacyExchangeDN 值的一部分。這表示如果系統管理群組值有問題，許多其他物件也會繼承相同的問題。

通常當系統管理員嘗試直接修改 legacyExchangeDN 時，就會發生問題。您必須使用如 [Active Directory Service Interfaces (ADSI) 編輯器] 嵌入式管理單元、LDP (ldp.exe) 工具或任何其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端等工具來更正此值。

注意：
使用 ADSI 編輯器、LDP 工具或其他 LDAP 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或 Exchange Server 2007，或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要更正此錯誤

  1. 使用 Active Directory 編輯器 (如 ADSI 編輯器) 找出 Active Directory 中的系統管理群組物件。

    legacyExchangeDN 屬性可以在以下位置找到：

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=Organization, CN=Administrative Groups, CN= Administrative group

  2. 鍵入新的字串值，格式如下：

    /o= organization /ou= administrative group

若需有關使用 LDP 工具的詳細資訊，請參閱微軟知識庫文件 - 260745＜XADM:使用 LDP 公用程式修改 Active Directory 物件屬性＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

若需有關使用 ADSI 編輯器的詳細資訊，請參閱主題＜Adsiedit.msc：ADSI 編輯器＞(位於 Windows Server 說明中)。


此系統管理群組的 legacyExchangeDN 無效
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以確認系統管理群組的 legacyExchangeDN 值。若 legacyExchangeDN 值指定的組織或系統管理群組名稱和實際的組織或系統管理群組的名稱不符，或值的一部分完全遺漏時，就會顯示此錯誤。

Exchange 會使用 legacyExchangeDN 值來識別 Active Directory 內的 Exchange 物件。legacyExchangeDN 值是一個辨別名稱，指出物件隸屬於 Exchange 組織的何處，例如：

/o=organization/ou=administrative group

像伺服器及資料夾階層之類的物件，會從系統管理群組繼承其 legacyExchangeDN 值的一部分。這表示如果系統管理群組值有問題，許多其他物件也會繼承相同的問題。

當系統管理員嘗試直接修改 legacyExchangeDN 值時，此值通常會發生問題。您必須使用如 [Active Directory Service Interfaces (ADSI) 編輯器] 嵌入式管理單元、LDP (ldp.exe) 工具或任何其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端等工具來更正此值。

注意：
使用 ADSI 編輯器、LDP 工具或其他 LDAP 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改這些 Active Directory 物件屬性的風險由客戶自行承擔。

若要更正此錯誤

  1. 使用 Active Directory 編輯器 (如 ADSI 編輯器) 找出 Active Directory 中的系統管理群組物件。

    legacyExchangeDN 屬性可以在以下位置找到：

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=Organization, CN=Administrative Groups, CN=Administrative group

  2. 鍵入新的字串值，格式如下：

    /o=organization/ou=administrative group

若需有關使用 LDP 工具的詳細資訊，請參閱微軟知識庫文件 - 260745＜XADM:Using the LDP Utility to Modify Active Directory Object Attributes＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

若需有關使用 ADSI 編輯器的詳細資訊，請參閱主題＜Adsiedit.msc：ADSI 編輯器＞(位在 Windows Server 線上說明中)。


存在擁有郵件功能的非萬用群組
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定環境中的網域數目。如果 Exchange Server Analyzer 在樹系中發現多個不同的 Active Directory 網域，則會查詢每個網域，以判定在這些網域中是否存在一或多個擁有郵件功能的非萬用群組。

如果 Exchange Server Analyzer 判定在多重網域樹系中存在擁有郵件功能的非萬用群組，就會顯示警告。

如果您在多重網域樹系中使用網域本端或全域通訊群組，則可能會出現電子郵件傳遞問題，原因如下：

  • 為了將通訊群組展開成為個別收件者，Exchange 會連絡通用類別目錄伺服器。

  • 雖然通用類別目錄伺服器具有每個網域中之所有類型群組的清單，但是通用類別目錄伺服器並不包含在遠端網域中所建立之網域本端及全域群組的成員清單。

  • 如果郵件傳送至全域通訊群組但在非主網域中展開，則 Exchange 無法將郵件正確傳遞至群組的成員。

  • 因為分類程式無法展開通訊群組清單，所以當使用者將郵件傳送至多重網域樹系中的全域通訊或擁有郵件功能的安全性群組時，全域通訊群組中的使用者可能接收不到該郵件。

  • 追蹤記錄中的最後一個項目會提交給分類程式。郵件的寄件者不會接收到未傳遞回報 (NDR)。

若要解決此問題並確保電子郵件會傳遞，請在多重網域環境中使用萬用通訊群組。萬用通訊群組的成員資格會複寫至每個網域中的每台通用類別目錄伺服器。

若需有關此問題的特殊詳細資訊以及萬用通訊群組的一般資訊，請參閱下列主題：

  • 《Exchange Server 2003 系統管理手冊》(http://go.microsoft.com/fwlink/?LinkId=47617) 中的＜在多重網域環境中使用擁有郵件功能的群組＞(英文)。

  • 《Active Directory》(http://go.microsoft.com/fwlink/?LinkId=51276) 中＜瞭解群組＞的＜群組範圍＞(英文)。

  • 《Exchange Server 2003 系統管理手冊》(http://go.microsoft.com/fwlink/?LinkId=47617) 中的＜建立查詢式通訊群組方針＞(英文)。

此外，請參閱下列微軟知識庫文件：

  • 231273＜XADM：無法將郵件傳遞到全域群組＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=271930)。

  • 283051＜XCON：傳送到擁有郵件功能之全域群組的電子郵件可能會消失＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=283051)。

  • 231273＜Windows 2000 中的群組類型使用範圍＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231273)。


需要啟用信箱的使用者系統原則變更
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2006-08-10

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個 Exchange 系統原則物件的 purportedSearch 屬性值。purportedSearch 屬性表示套用原則時所使用的搜尋引數。

Exchange Server Analyzer 也會查詢 Active Directory，以判定 Active Directory 中之樹系物件 (NTDS 設定) 的 msDS-Behavior-Version 屬性值。此值指示 Active Directory 樹系功能等級。msDS-Behavior-Version 屬性的有效值顯示在下表中。

值 | 樹系功能等級
0 | Microsoft Windows® 2000 Server 混合模式
1 | Microsoft Windows Server™ 2003 過渡模式
2 | Microsoft Windows Server 2003 原生模式

Exchange Server Analyzer 也會查詢 Active Directory，以判定 Windows2003Update 容器的 revision 屬性值。此屬性的值指示是否已執行 Active Directory 準備公用程式 (ADPrep.exe)。

最後，Exchange Server Analyzer 會查詢 Win32_OperatingSystem Microsoft Windows Management Instrumentation (WMI) 類別，以判定 OSProductSuite 機碼值。OSProductSuite 機碼的值表示電腦上執行的 Windows 版本。

如果 Exchange Server Analyzer 發現下列準則符合，則會顯示警告：

  • 「能夠使用信箱的使用者」系統原則的 purportedSearch 屬性值不等於 (&(objectCategory=person)(objectClass=user)(mailnickname=*)(homeMdb=*))

  • Active Directory 樹系功能層級為 Windows Server 2003 過渡模式或 Windows Server 2003 原生模式。

  • Exchange Server 電腦未執行 Windows Small Business Server 2003。

若要避免信箱重新隸屬問題，需要修改系統原則。使用 Active Directory Service Interfaces (ADSI) 編輯器 (ADSIEdit.msc)、LDP (ldp.exe) 工具或其他 Active Directory 編輯程式工具，都可完成此更新。

如果 Windows Server 2003 作為網域控制站且未更新「能夠使用信箱的使用者」原則，則 Windows Server 2003 中的連結數值複寫會使收件者更新服務覆寫新使用者的 homeMDB 屬性值，並使其信箱重新隸屬於伺服器上的第一個儲存區。

注意：
使用 ADSI 編輯器、LDP 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Windows Server 2003、Exchange Server 2003 (或兩者) 才能解決。修改 Active Directory 物件屬性的風險由客戶自行負責。
若要更正此錯誤

  1. 啟動 [ADSI 編輯器]。

  2. 連按兩下 [Configuration] 容器，依序展開 [CN=Services]、[CN=Microsoft Exchange] 及 [CN=<ExchangeOrganizationName>]。

  3. 選取 [CN=System Policies]。

  4. 在右窗格中，在 [CN=Mailbox Enable User] 上按一下滑鼠右鍵，然後選取 [內容]。

  5. 向下捲動以選取 purportedSearch 屬性，然後按一下 [編輯]。

  6. 清除屬性，然後以下列篩選條件來設定它：

    (&(objectCategory=person)(objectClass=user)(mailnickname=*)(homeMdb=*))

    附註：
    為達到較好的可讀性，已將步驟 6 中所顯示的篩選條件換行。請確定您輸入的篩選條件沒有任何空格或換行字元。

  7. 按一下 [確定] 以儲存變更，然後關閉 ADSI 編輯器。

若需有關使用 LDP 工具的詳細資訊，請參閱微軟知識庫文件 - 260745＜XADM:Using the LDP Utility to Modify Active Directory Object Attributes＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

若需此問題與其影響的詳細資訊，請參閱 Microsoft 知識庫文章 903291＜收件者更新服務可能會覆寫新 Exchange Server 2003 使用者的 homeMDB 屬性值＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=903291)。


通用類別目錄上已停用 MAPI 介面
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄機碼，以判定該登錄機碼是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NTDS\Parameters\Initialize MAPI interface

如果 Exchange Server Analyzer 發現 Initialize MAPI interface 機碼存在且已設為任一數值，就會顯示錯誤。

當 Initialize MAPI interface 登錄機碼存在時，Microsoft Office Outlook® 用戶端將無法連絡此伺服器上的通訊錄。若要更正此問題，您必須移除 Initialize MAPI interface 登錄機碼。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\NTDS\Parameters\Initialize MAPI interface

  3. 在 [Initialize MAPI interface] 機碼上按一下滑鼠右鍵，並選取 [刪除]。

  4. 關閉登錄編輯程式並重新啟動 Exchange 伺服器。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Initialize MAPI interface 登錄機碼的詳細資訊，請參閱微軟知識庫文件 - 275127＜XADM：如何將 Exchange Server 5.5 設定為在作為通用類別目錄的網域控制站上執行＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=275127)。


已修改 MaxActiveQueries
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定可同時處理的最大輕量型目錄存取通訊協定 (LDAP) 查詢數目。檢查目前的 LDAP 系統管理原則可以取得此值。更明確地說，Exchange Server Analyzer 會檢查 MaxActiveQueries 存在與否。如果 Exchange Server Analyzer 判定 MaxActiveQueries 存在，且已設為 20 以外的任何值，就會顯示非預設的組態訊息。

LDAP 系統管理限制可平衡 Active Directory 的運作功能及其效能。這些限制可防止特定操作對伺服器的效能造成不良的影響。提高此設定使其超過預設值可能會對 Active Directory 基礎結構造成不良影響。

LDAPAdminLimits 屬性的 MaxActiveQueries 值會控制預設查詢原則的最大同時 LDAP 查詢數。依預設，會施加 20 個作用中查詢的限制。如果已達到此限制，Active Directory 會傳回 LDAP_ADMIN_LIMIT_EXCEEDED，並且不處理其他的 LDAP 查詢。

若要啟動 Ntdsutil.exe

  1. 按一下 [開始]，然後按一下 [執行]。

  2. 在 [開啟] 文字方塊中，輸入 ntdsutil，然後按 Enter 鍵。任何時候，若要檢視說明，請在命令提示字元下輸入 ?。

若要檢視原則設定

  1. 在 Ntdsutil.exe 命令提示字元下，鍵入 LDAP policies，然後按 Enter 鍵。

  2. 在 LDAP 原則命令提示字元中，輸入 connections，然後按 Enter 鍵。

  3. 在伺服器連線命令提示字元中，輸入 connect to server DNS name of server，然後按 Enter 鍵。您需要連線至目前使用的伺服器。

  4. 在伺服器連線命令提示字元中，輸入 q，然後按 Enter 鍵以返回前一個功能表。

  5. 在 LDAP 原則命令提示字元中，輸入 Show Values，然後按 Enter 鍵。

    現有的原則便會出現。
附註：
此程序僅會顯示「預設網域原則」設定。如果套用自己的原則設定，您會看不到它。

若要變更原則設定

  1. 在 Ntdsutil.exe 命令提示字元下，鍵入 LDAP policies，然後按 Enter 鍵。

  2. 在 LDAP 原則命令提示字元中，鍵入 Set MaxActiveQueries to 20，然後按 Enter 鍵。

    您可以使用 Show Values 命令來驗證變更。

  3. 若要儲存變更，請使用 [認可變更]。

  4. 當您完成時，請輸入 q，然後按 Enter 鍵。

  5. 若要結束 Ntdsutil.exe，請在命令提示字元中，輸入 q，然後按 Enter 鍵。

若需有關設定 LDAP 原則的詳細資訊，請參閱微軟知識庫文件 - 315071＜HOW TO：在 Windows 2000 中使用 Ntdsutil.exe 檢視及設定 Lightweight Directory Access Protocol 原則＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=315071)。


MaxPageSize 參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會檢查 Active Directory® 目錄服務中 Query-Policies 容器內預設查詢原則物件的屬性，以便驗證網域控制站的輕量型目錄存取通訊協定 (LDAP) 組態。如果 Exchange Server Analyzer 判定 LDAPAdminLimits 屬性的 MaxPageSize 值已變更為預設值 1000 以外的值，就會顯示非預設的組態訊息。

LDAP 系統管理限制可平衡 Active Directory 的運作功能及其效能。這些限制可防止特定作業對伺服器效能造成不良的影響，也可使伺服器對阻斷服務攻擊較有免疫力。提高此設定使其超過預設值可能會對 Active Directory 基礎結構造成不良影響。

LDAP 原則是使用 queryPolicy 類別的物件來實作。查詢原則物件可建立於 Query-Policies 容器中，此容器為組態命名內容中「目錄服務」容器的子項。

LDAPAdminLimits 屬性的 MaxPageSize 值會控制 LDAP 查詢可傳回的記錄筆數。預設值為 1000 筆記錄。如果傳回了超過 1000 個項目，Active Directory 會先查看此最大值，然後決定不傳回任何項目。

此限制控制了數種 Active Directory 物件的可支援數目。例如，每個組織最多可以有 1000 部伺服器、1000 個系統管理群組，以及 1000 份通訊清單；每個系統管理群組最多可以有 1000 個路由群組，而每個路由群組最多可以有 1000 個連接器。

除非 Microsoft 產品支援服務指示您使用不同的值，否則應將此值設回 1000。

若要啟動 Ntdsutil.exe

  1. 按一下 [開始]，然後按一下 [執行]。

  2. 在 [開啟] 文字方塊中，鍵入 ntdsutil，然後按 ENTER 鍵。任何時候，若要檢視說明，請在命令提示字元下輸入 ?。

若要檢視原則設定

  1. 在 Ntdsutil.exe 命令提示字元中，鍵入 LDAP policies，然後按 ENTER 鍵。

  2. 在 LDAP 原則命令提示字元中，鍵入 connections，然後按 ENTER 鍵。

  3. 在伺服器命令提示字元中，鍵入 connect to server <DNS name of server>，然後按 ENTER 鍵。您需要連線至目前使用的伺服器。

  4. 在伺服器連線命令提示字元中，鍵入 q，然後按 ENTER 鍵返回前一個功能表。

  5. 在 LDAP 原則命令提示字元中，鍵入 Show Values，然後按 ENTER 鍵。

    現有的原則便會出現。

    附註：
    此程序僅會顯示「預設網域原則」設定。如果套用自己的原則設定，您會看不到它。

若要變更原則設定

  1. 在 Ntdsutil.exe 命令提示字元中，鍵入 LDAP policies，然後按 ENTER 鍵。

  2. 在 LDAP 原則命令提示字元中，鍵入 Set MaxPageSize to 1000，然後按 ENTER 鍵。

    您可以使用 Show Values 命令來驗證變更。

  3. 若要儲存變更，請使用 Commit Changes。

  4. 當您完成時，請鍵入 q，然後按 ENTER 鍵。

  5. 若要結束 Ntdsutil.exe，請在命令提示字元中鍵入 q，然後按 ENTER 鍵。

若需有關設定 LDAP 原則的詳細資訊，請參閱微軟知識庫文件 - 315071＜HOW TO：在 Windows 2000 中使用 Ntdsutil.exe 檢視及設定 Lightweight Directory Access Protocol 原則＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=315071)。


MaxPageSize 設得太高
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 Query-Policies 容器中預設查詢原則物件之 LDAPAdminLimits 屬性的 MaxPageSize 值的設定。如果 Exchange Server Analyzer 判定 MaxPageSize 的值大於 2,500，就會顯示一則錯誤。

輕量型目錄存取協定 (LDAP) 系統管理限制會平衡 Active Directory 作業的功能與效能。這些限制可防止特定操作對伺服器的效能造成不良的影響。還能讓伺服器抵擋阻斷服務的攻擊。提高此設定使其超過預設值可能會對 Active Directory 基礎結構造成不良影響。

LDAP 原則是使用 queryPolicy 類別的物件來實作。查詢原則物件可建立於 Query-Policies 容器中，此容器為組態命名內容中「目錄服務」容器的子項。

LDAPAdminLimits 屬性的 MaxPageSize 值會控制 LDAP 查詢可傳回的記錄筆數。預設數目為 1,000 筆記錄。如果傳回的項目數超過 1,000，Active Directory 會先查看此最大值，然後決定不傳回任何項目。

此限制控制了數種 Active Directory 物件的可支援數目。例如，每個組織最多可以有 1,000 個伺服器、1,000 個系統管理群組及 1,000 個通訊清單。每個系統管理群組最多可以有 1,000 個路由群組，而每個路由群組最多可以有 1,000 個連接器。

除非 Microsoft 產品支援服務指示您使用不同的值，否則應將此值設回 1,000。

啟動 Ntdsutil.exe

  1. 按一下 [開始]，然後按一下 [執行]。

  2. 在 [開啟] 文字方塊中，輸入 [ntdsutil]，然後按 [ENTER]。任何時候，若要檢視說明，請在命令提示字元下輸入 ?。
檢視原則設定

  1. 在 Ntdsutil.exe 命令提示字元下，輸入 LDAP policies，然後按 [ENTER]。

  2. 在 LDAP 原則命令提示字元中，輸入 connections，然後按 [ENTER]。

  3. 在伺服器連線命令提示字元中，輸入 connect to server <DNS name of server>，然後按 [ENTER]。連線至您目前使用的伺服器。

  4. 在伺服器連線命令提示字元中，輸入 q，然後按 [Enter] 以返回前一個功能表。

  5. 在 LDAP 原則命令提示字元中，輸入 Show Values，然後按 [Enter]。

    現有的原則便會出現。

    附註：
    此程序僅會顯示「預設網域原則」設定。如果套用自己的原則設定，您會看不到它。
變更原則設定

  1. 在 Ntdsutil.exe 命令提示字元下，輸入 LDAP policies，然後按 [ENTER]。

  2. 在 LDAP 原則命令提示字元中，輸入 Set MaxPageSize to 1000，然後按 [ENTER]。

    您可以使用 [Show Values] 命令來驗證變更。

  3. 若要儲存變更，請使用 [認可變更]。

  4. 當您完成時，請輸入 q，然後按 [Enter]。

  5. 若要結束 Ntdsutil.exe，請在命令提示字元中輸入 q，然後按 [Enter]。

若需有關設定 LDAP 原則的詳細資訊，請參閱微軟知識庫文件 - 315071＜HOW TO：在 Windows 2000 中使用 Ntdsutil.exe 檢視及設定 Lightweight Directory Access Protocol 原則＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=315071)。


存在超過 800 個通訊清單
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 Active Directory 中「所有通訊清單」群組中的通訊清單數目是否大於 800。如果 Exchange Server Analyzer 發現 Exchange Server 組織中的通訊清單數目超過 800，則會顯示警告。

建議您將「所有通訊清單」群組中的通訊清單數目減至 800 個以下，以避免在「收件者更新服務」作業期間發生嚴重的延遲。如果您的 Exchange Server 組織中有超過 800 個全域通訊清單，則「收件者更新服務」在對擁有郵件功能的物件加上戳記時，會發生嚴重的延遲。

或者，您可以停用「收件者更新服務」，而使用指令碼來處理「收件者更新服務」所執行的作業。

若需有關停用收件者更新服務的詳細資訊，請參閱微軟知識庫文件 - 296479＜停用收件者更新服務的需求＞(英文) (http://go.microsoft.com/fwlink/?Linkid=3052&kbid=296479)。

若需有關通訊清單及收件者更新服務的詳細資訊，請參閱《Exchange Server 2003 系統管理手冊》(http://go.microsoft.com/fwlink/?LinkId=47617)中的＜管理收件者及收件者原則＞(英文)。


存在超過 800 個全域通訊清單
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判斷 Active Directory 中，所有全域通訊清單群組中的通訊清單數目是否大於 800。如果 Exchange Server Analyzer 發現 Exchange Server 組織中有超過 800 個全域通訊清單，就會顯示警告。

建議您將「所有全域通訊清單」群組中的通訊清單數目減至 800 個以下，以避免在「收件者更新服務」作業過程中發生嚴重的延遲。如果您的 Exchange Server 組織中有超過 800 個全域通訊清單，則「收件者更新服務」在對擁有郵件功能的物件加上戳記時，會發生嚴重的延遲。

或者，您可以停用「收件者更新服務」，而使用指令碼來處理「收件者更新服務」所執行的作業。

若需有關停用收件者更新服務的詳細資訊，請參閱微軟知識庫文件 - 296479＜停用收件者更新服務的需求＞(英文) (http://go.microsoft.com/fwlink/?Linkid=3052&kbid=296479)。

若需有關通訊清單及收件者更新服務的詳細資訊，請參閱《Exchange Server 2003 系統管理手冊》(http://go.microsoft.com/fwlink/?LinkId=47617)中的＜管理收件者及收件者原則＞(英文)。


已製作 msExchHomeMDB 屬性的索引
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已設定 Routing Group Back-Link 屬性來在 Active Directory 中製作索引。Exchange Server Analyzer 會特別查詢 Active Directory，以判定 msExchHomeMDB 屬性目前的索引值，此屬性為 Active Directory 中擁有信箱功能之物件的屬性。在預設的情況下，這個屬性沒有建立索引。如果 Exchange Server Analyzer 發現已設定此屬性來製作索引，就會顯示非預設的組態訊息。

對 msExchHomeMDB 屬性製作索引所造成的影響是很小的。因為要維護記憶體中的索引，所以通用類別目錄伺服器上所使用的記憶體數量會小幅增加。

若有下列任何一項符合您組織的情況，製作這個屬性的索引對您會有好處：

  • 您有許多擁有郵件功能的物件。在非常大型的環境中 (含有 100,000 個以上擁有郵件功能的物件)，為此屬性製作索引也可以增加 [Exchange 系統管理員] 的效能，對於使用 [Active Directory 使用者及電腦] 來執行的 Exchange 特定作業，也都會增加效能。

  • 如果您經常使用 [Exchange 信箱合併程式] (ExMerge)，我們發現，在使用 ExMerge 的中大型環境中，經常需要替 msExchHomeMDB 屬性製作索引。事實證明，替 msExchHomeMDB 屬性製作索引可以增加 ExMerge 的速度及效能。

如果上述兩種情況都不適用，則建議將設定值變更回沒有製作索引的預設值。

若要更正此錯誤

  • Exchange Server Analyzer 產生此訊息僅供參考，不需要採取任何行動。


msExchRoutingGroupMembersBL 屬性已編製索引
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已設定 Routing Group Back-Link 屬性而能在 Active Directory 中編製索引。Exchange Server Analyzer 會特別檢查下列 Active Directory 物件，以判定目前為 msExchRoutingGroupMembersBL 屬性編製的索引值：

CN=Configuration,DC=domain,DC=com, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Administrative Groups, CN=AdministrativeGroupName, CN=Routing Groups, CN=RoutingGroupName

在預設的情況下，這個屬性沒有建立索引。如果 Exchange Server Analyzer 發現已設定此屬性來製作索引，就會顯示非預設的組態訊息。

在包含大量路由群組之分散式或分公司的 Exchange 部署作業中，讓此屬性保留在未編製索引的狀態下，可能會導致效能降低。假設您的 Exchange 組織中有數百個路由群組，您可能會發現，每 15 分鐘，就有一或數個通用類別目錄伺服器的活動增加。活動會增加是因為 Exchange 中的 DSAccess 元件重新讀取路由群組組態。在嚴重的情況下，通用類別目錄可能會被這個活動消耗掉。

為了將通用類別目錄上的這個負擔降至最低，可以將 Routing Group Back-Link 屬性編製索引，進而縮短它讓 DSAccess 讀取路由群組資訊的時間，並減少這項活動對通用類別目錄造成的負擔。

若要更正此錯誤

  • Exchange Server Analyzer 產生此訊息僅供參考，不需要採取任何行動。

若需有關調整 Exchange 以獲得最佳效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(英文) (http://go.microsoft.com/fwlink/?linkid=47576)。


找到多個公用資料夾階層
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 msExchPFTreeType 屬性值為 1 之公用資料夾階層的數目。msExchPFTreeType 屬性值為 1，表示該公用資料夾階層即為指定給 MAPI 用戶端的公用資料夾階層。如果 Exchange Server Analyzer 判定在 Exchange 組織中有多個公用資料夾階層具有 msExchPFTreeType 屬性值 1，就會顯示錯誤。

此錯誤指出在 Exchange 組織中找到多個 MAPI 用戶端公用資料夾階層。若有多個 MAPI 用戶端公用資料夾階層，就可能會產生問題。

若要解決此問題，您可以使用 Active Directory 編輯工具來將所有公用資料夾階層 (除了 MAPI 公用資料夾階層之外) 的 msExchPFTreeType 屬性值設為 0。必要時，請重新設定 Exchange 伺服器上的信箱儲存區，使其指向 MAPI 公用資料夾階層，作為 MAPI 用戶端的預設公用資料夾儲存區。

下列工具是 Active Directory 編輯工具：

  • Active Directory Service Interfaces (ADSI) 編輯器 (AdsiEdit.msc)

  • LDP (ldp.exe) 工具

注意：
使用 ADSI 編輯器、LDP 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
若要更正此錯誤

  1. 使用 Active Directory 編輯工具找出 Active Directory 中的公用資料夾物件。公用資料夾物件位於： CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdminGroupName>, CN=Folder Hierarchies

  2. 輸入 0 作為新的值，來變更所有公用資料夾階層物件 (除了 MAPI 公用資料夾階層之外) 的 msExchPFTreeType 屬性值。

  3. 關閉 Active Directory 編輯器。

  4. 開啟 [Exchange 系統管理員]。

  5. 若要存取每個信箱儲存區的內容，請按一下 [系統管理群組]，然後依序展開系統管理群組、[伺服器]、您的伺服器，以及儲存群組。接著，在要變更內容的信箱儲存區上按一下滑鼠右鍵，然後選取 [內容]。

  6. 在 [一般] 索引標籤的 [預設公用儲存區] 欄位中，按一下 [瀏覽]。

  7. 選取 MAPI 公用資料夾階層，然後按兩次 [確定] 以儲存變更。

  8. 針對每個信箱儲存區重複步驟 5-7。

若需有關使用 LDP 工具修改 Active Directory 的詳細資訊，請參閱微軟知識庫文件 - 260745＜XADM：Using the LDP Utility to Modify Active Directory Object Attributes＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

如需 MAPI 與應用程式的公用資料夾階層的詳細資訊，請參閱下列資源：

  • 微軟知識庫文件 - 258509＜Exchange 2000 Server 及 Exchange Server 2003 公用資料夾樹狀目錄類型的說明＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258509)

  • Exchange 團隊部落格項目＜擁有郵件功能的公用資料夾如何運作＞(英文) (http://go.microsoft.com/fwlink/?LinkId=41913)


建議使用 'NeverPing' 參數
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2006-03-16

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定針對每一個網域所建立的信任數目。如果每一個網域中至少有一個網域控制站設定了 NeverPing 值，則此工具會顯示最佳作法訊息。

當 Exchange Server 2003 環境中的每一個網域符合下列條件時，Exchange Server Analyzer 會顯示警告：

  • 網域已建立 50 個以上的信任

  • 網域中的網域控制站已將 NeverPing 登錄子機碼值設為 null (0)

這個警告指出 LSASS.exe 處理程序或對網域驗證使用者的處理程序可能延遲。本機安全性授權單位子系統服務 (LSASS) 是 Microsoft Windows 作業系統中的處理程序，它可驗證登入 Windows 型電腦或伺服器的使用者。

若要修正問題，請將網域控制站的 NeverPing 登錄子機碼值設為 1，如下所示。

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
在 Exchange 2003 環境中設定網域控制站的 NeverPing 參數

  1. 依序按一下 [開始]、[執行]，輸入 Regedit，然後按一下 [確定]。

  2. 尋找下列登錄子機碼：HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters。

  3. 在此子機碼上按一下滑鼠右鍵，指向 [新增]，然後輸入 NeverPing，再按 ENTER 鍵。

  4. 在 NeverPing 上按一下滑鼠右鍵，按一下 [修改]，然後在 [數值資料] 方塊中輸入 1，再按一下 [確定]。

  5. 結束登錄編輯程式。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關這個問題的詳細資訊，以及如何設定網域控制站的 NeverPing 參數的詳細資訊，請參閱微軟知識庫文件 - 825107＜如果您在 Windows 2000 伺服器型網域控制站上有多個外部信任，則 Lsass.exe 處理程序會停止回應＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=825107)。

附註：
雖然這篇文章是描述 Microsoft Windows 2000 Server，但是其中的資訊也適用於 Windows Server™ 2003。Windows Server 2003 不需要文章中所提到的更新。


有更新的 Active Directory 連接器版本可用
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個連線協定物件上的 versionNumber 屬性值。versionNumber 屬性代表在電腦上執行的 Active Directory 連接器 (ADC) 版本。

Exchange Server Analyzer 工具也會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Active Directory 連接器 (ADC) 檔案 Adc.exe 的 Version 機碼值。Version WMI 機碼表示此檔案的組建編號。

若符合下列條件，Exchange Server Analyzer 便會顯示警告：

  • 連接協定物件上的 versionNumber 屬性設為 16973842。

  • 連接協定物件上的 versionNumber 屬性設為 16973843，且 Adc.exe 的 Version 機碼值小於 7250.0。

值為 16973842 表示電腦正在執行來自 Exchange Server 2003 CD 的 ADC 原始商業版，值為 16973843 與 Adc.exe Version 機碼值小於 7250.0 則表示電腦正在執行 ADC 的 Exchange Server 2003 Service Pack 1 (SP1) 版。

Exchange Server 2003 的 Service Pack 2 提供更新版本的 ADC。建議使用的最佳作法是使用 ADC 的最新版本。

若要更正此警告

  1. 移至 Exchange Server 2003 Service Pack 2 (英文) (http://go.microsoft.com/fwlink/?LinkId=54751)，下載最新版的 ADC。

  2. 解除安裝 ADC 的現有版本，再安裝 ADC 的更新版本。

若需 ADC 連線協定的相關資訊，請參閱下列微軟知識庫文件：

  • 823601＜Active Directory 連接器需求及對整個組織的用意＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180＜混合系統管理群組的 Active Directory 連接器連線協定需求＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)

  • 317721＜XADM：當您將 ADC 連線協定從單向連線協定變更為雙向連線協定時，Exchange Server 5.5 信箱擁有者權限會被移除＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721)


組織中沒有為此連線協定指定的 Exchange 伺服器
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個連線協定物件的 msExchServer2NetworkAddress 屬性值。msExchServer2NetworkAddress 屬性代表參與此連線協定之伺服器的網路位址。Exchange Server Analyzer 會列舉 Active Directory 中的系統管理群組，查看此伺服器名稱是否已列於系統管理群組的連線協定成員中。如果系統管理群組中未列出此伺服器名稱，就會顯示一則錯誤。

此錯誤表示有孤立的連線協定。如果已將 Exchange Server 電腦除役，就會發生此問題。如果已從組織中移除 Exchange Server 電腦，則應該在 Active Directory 連接器 (ADC) 系統管理工具內於連線協定內容的 [連線] 索引標籤中變更 Exchange 伺服器名稱。如果發生問題的 Exchange 伺服器是因進行維護或因其他一些原因而離線，則可忽略此錯誤。

若要更正此錯誤

  1. 依序按 [開始]、[程式集]、[系統管理工具]、[Active Directory 連接器]。

  2. 在左窗格中，按一下主控您要修改之連線協定的 ADC 伺服器。

  3. 在右窗格中，以滑鼠右鍵按一下要修改的連線協定，再按一下 [內容]。

  4. 按一下 [連線] 索引標籤。

  5. 將用來連線的伺服器名稱變更成現有的名稱。

若需 ADC 連線協定的相關資訊，請參閱下列微軟知識庫文件：

  • 823601＜Active Directory 連接器需求及對整個組織的用意＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180＜混合系統管理群組的 Active Directory 連接器連線協定需求＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)


組織中沒有指定的離線通訊錄伺服器
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2006-12-03

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，判定離線通訊錄組態物件的 offLineABServer 屬性值。offLineABServer 屬性是單值的辨別名稱屬性，該屬性儲存負責產生離線通訊錄的 Exchange Server 電腦的辨別名稱。

Exchange Server Analyzer 也會檢查 Active Directory 中 Exchange Server 物件的 distinguishedName 屬性值。

如果 Exchange Server Analyzer 發現列在 offLineABServer 屬性中的伺服器不符合在 ExchangeServer 物件上找到的 distinguishedName 屬性，而且 offLineABServer 屬性不包含 DEL: 字串，就會顯示一則錯誤。

針對每一個離線通訊錄，Exchange 會產生離線通訊錄檔案並儲存在指定伺服器上的一組公用資料夾內。如果您看見此訊息，就表示在離線通訊清單物件中指定的伺服器不存在。如果舊的離線通訊錄伺服器已除役或已從拓撲中錯誤地移除，就可能會發生這種情況。要等到您指定新的伺服器之後，Exchange 才會產生離線通訊錄。

在 Exchange 2000 Server 及 Exchange Server 2003 更正此錯誤

  1. 在 [Exchange 系統管理員] 中的 [收件者] 之下，按一下 [離線通訊清單]。在右窗格中，在 [預設離線通訊清單] (或產生這封郵件的任何其他離線通訊清單) 上按一下滑鼠右鍵，然後按一下 [內容]。

  2. 在 [一般] 索引標籤上，在 [離線通訊清單伺服器] 下，按一下 [瀏覽]，然後按一下要使用的伺服器。

對 Exchange Server 2007 更正此警告

  1. 開啟 [Exchange 管理主控台]。

  2. 依序展開 [Microsoft Exchange]、[組織組態]，然後選取 [信箱]。

  3. 在結果窗格中，按一下 [離線通訊錄] 索引標籤。

  4. 在 [離線通訊錄] 索引標籤上，選取 [預設離線通訊錄]。在執行窗格中，按一下 [移動]，以啟動 [移動離線通訊錄] 精靈。此精靈可讓您移至不同的伺服器產生 OAB。它也會將現有的 OAB 檔案複製至指定的伺服器。

使用 Exchange 管理命令介面來設定將主控離線通訊錄產生的伺服器

  • 執行下列命令：

    複製程式碼
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    其中：<OAB> 是 OAB 的辨別名稱 (DN)、網域\帳戶名稱或 GUID，而 <Server> 則指定執行所選作業的 Exchange 伺服器。

    例如，若要移至 SERVER01. 產生 OAB，請輸入：
複製程式碼
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

若需有關在 Exchange Server 2003 使用離線通訊錄的詳細資訊，請參閱《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595)中的＜設定 Exchange Server 2003 離線通訊錄＞(英文)。

若需有關在 Exchange Server 2007 使用離線通訊錄的詳細資訊，請參閱＜組織組態 > 信箱 > 離線通訊錄＞(英文) (http://go.microsoft.com/fwlink/?LinkId=79247)。


組織中沒有指定的收件者更新服務 Exchange 伺服器
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2006-03-29

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定目錄中所有 Exchange Server 物件的 distinguishedName 屬性值。Exchange Server Analyzer 也會查詢 Active Directory，以判定目錄中每個 [收件者更新服務] 物件的 msExchAddressListServiceLink 屬性值。msExchAddressListServiceLink 屬性是通訊清單服務和應該在其中執行通訊清單服務的 Exchange Server 電腦兩者之間的連結。如果 Exchange Server Analyzer 發現 msExchAddressListServiceLink 屬性的值不包含 DEL: 字串，且此屬性不符合目錄中任何 Exchange Server 物件的 distinguishedName 屬性，就會顯示一則錯誤。

每一個「收件者更新服務」執行個體都會和一部執行「收件者更新服務」的 Exchange Server 電腦產生關聯。如果您收到這則訊息，表示「收件者更新服務」執行個體是和不在 Exchange 組織內的 Exchange Server 電腦產生關聯。該伺服器可能已除役，或從拓樸中移除。

為了讓這個「收件者更新服務」執行個體執行，必須將其和現有的 Exchange 伺服器產生關聯。

若要更正此錯誤

  1. 開啟 [Exchange 系統管理員]。

  2. 在 [收件者] 之下，按一下 [收件者更新服務]。在右窗格中，以滑鼠右鍵按一下適當的 [收件者更新服務] 執行個體，再按一下 [內容]。

  3. 在 [一般] 索引標籤中，於 [Exchange Server] 之下，按一下 [瀏覽]，然後指定一部要執行此執行個體的新伺服器。

  4. 按 [確定] 兩次，使變更生效。

  5. 關閉 [Exchange 系統管理員]。

若需有關收件者更新服務的詳細資訊，請參閱下列主題及微軟知識庫文件：

  • 《Exchange Server 2003 系統管理手冊》(http://go.microsoft.com/fwlink/?linkid=47617) 中的＜在 Exchange Server 2003 中管理收件者及收件者原則＞(英文)

  • 328738＜XADM：收件者更新服務如何套用收件者原則＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828＜收件者更新服務如何擴展通訊清單＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127＜XADM：如何檢查收件者更新服務的進度＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770＜XADM：收件者更新服務執行的工作＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


在這個系統管理群組中沒有偵測到所指定的路由群組主要伺服器
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個路由群組容器的 msExchRoutingMasterDN 屬性值。如果 Exchange Server Analyzer 發現 msExchRoutingMasterDN 屬性的值未包含有效的伺服器名稱，且該屬性未包含字串 "DEL:"，就會顯示警告。

如果之前的路由群組主要伺服器已解除，或是以不正確的方法從拓樸中移除了，就會發生這個問題。若沒有主要路由群組，Exchange 將無法正確更新或維護路由拓樸。

建立路由群組時，該路由群組中的第一部伺服器會被指派主要路由群組的角色。主要路由群組會維護該路由群組的目前連結狀態資訊，並且將資訊傳播至該路由群組內的其他伺服器。主要路由群組只會監視其本身的路由群組寫入 Active Directory 的路由組態。成員伺服器可以將任何連接器狀態或伺服器可用資訊，傳達給主要路由群組。例如，如果成員伺服器嘗試透過連接器和不同路由群組內的其他伺服器通訊，但是該連結卻無法使用，則成員伺服器就會立即通知主要路由群組。同樣地，當非主要伺服器收到新的連結狀態資訊時，就會立即將連接器狀態資訊傳輸至路由群組主要伺服器，讓其他伺服器可以收到路由變更的相關資訊。

若要更正此警告

  1. 在「Exchange 系統管理員」的「系統管理群組」之下，展開 [系統管理群組]，再展開 [路由群組]。

  2. 展開路由群組，然後按一下 [成員]。

  3. 在右窗格中，以滑鼠右鍵按一下要設定為主要路由群組的 Exchange 電腦，再按一下 [設定為主要]。

若需有關路由群組主機的詳細資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》(http://go.microsoft.com/fwlink/?linkid=47579) 中的＜設定路由拓撲＞(英文)。


公用資料夾連線協定的數目小於組態連線協定的數目
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定您在 Active Directory 與每個 Exchange Server 5.5 站台之間是否有公用資料夾連線協定。作法是查詢公用資料夾連線協定和組態連線協定兩者的數目。如果 Exchange Server Analyzer 判定公用資料夾連線協定的數目小於組態連線協定的數目，就會顯示一則警告。

此警告指出至少一個 Exchange Server 5.5 站台沒有 Active Directory 的公用資料夾連線協定，因此無法將公用資料夾的目錄物件複寫到 Active Directory。因此，郵件無法從 Exchange 2000 Server 或 Exchange Server 2003 信箱流向 Exchange Server 5.5 公用資料夾，也無法從 Exchange Server 5.5 信箱流向擁有郵件功能的 Exchangg 2000 Server 或 Exchange Server 2003 公用資料夾。

當您在純 Exchange Server 5.5 站台上安裝 Exchange 2000 Server 或 Exchange Server 2003 電腦時，會自動產生組態連線協定。公用資料夾連線協定是使用者定義的。如果每個 Exchange Server 5.5 站台和 Active Directory 之間都有公用資料夾連線協定，那麼公用資料夾連線協定的數目至少與組態連線協定的數目一樣。

若要建立公用資料夾連線協定

  1. 在 Active Directory 連接器 (ADC) 伺服器上，啟動 Active Directory 連接器管理員。(在 [開始] 功能表上，指向 [程式集] 或 [所有程式]，再指向 [Microsoft Exchange]，然後按一下 [Active Directory 連接器])。

  2. 在主控台樹狀目錄中，按一下 [Active Directory 連接器]。右視窗會列出連線協定。使用此清單可判定不具有公用資料夾連線協定的站台。

  3. 在 [動作] 功能表上，指向 [新增]，然後按一下 [公用資料夾連線協定] 來顯示 [內容] 對話方塊。

  4. 在 [一般] 索引標籤的 [名稱] 中，鍵入連線協定的名稱。

  5. 在 [Active Directory 連接器服務] 方塊中，選取要執行連線協定的伺服器。

  6. 在 [連線] 索引標籤上，選取您要複寫公用資料夾物件的 Active Directory 伺服器及 Exchange Server 5.5 伺服器，並對每個伺服器指定適當的帳戶及認證。

  7. 在 [排程] 索引標籤上，選取複寫排程。

  8. 按一下 [確定]。

若需有關公用資料夾及組態連線協定的詳細資訊，請參閱微軟知識庫文件：

  • 264889＜XADM：公用資料夾連線協定＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=264889)

  • 281223＜瞭解 Exchange 中的連線協定＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=281223)。


離線通訊錄的產生設為連續更新
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2006-12-04

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已設定 msExchOAB 類別中的 offLineABSchedule 屬性值，以產生離線通訊錄。offLineABSchedule 屬性可判定離線通訊清單的排程。如果 Exchange Server Analyzer 發現離線通訊清單的離線通訊錄產生排程已設為連續更新，則會顯示錯誤。

離線通訊錄是儲存離線通訊清單集合的容器。系統管理員可以設定可用的離線通訊錄。Microsoft Office Outlook® 2003 及 Outlook 2007 使用者可選擇要下載哪些離線通訊清單。MAPI 用戶端 (如 Outlook 2003 及 Outlook 2007) 可以下載離線通訊清單。因此，即使中斷與 Exchange 伺服器的連線，使用者也可編寫電子郵件。

您可以排定何時更新離線通訊清單。不過，請確定您設定的更新排程，在進行下一個更新之前，可以有足夠的時間來完成離線通訊清單的產生。例如，如果下列條件存在，則在每個更新間隔間必須至少有四個小時：

  • 在 24 小時的期間內，您指定了三個更新。

  • 更新離線通訊清單需要花費四個小時。

通常，不建議進行頻繁的更新，因為頻繁更新可能會在下列方面影響用戶端與伺服器的效能：

  • 伺服器必須更頻繁地產生離線通訊錄。依據 Active Directory 大小的不同，可能要花費數小時才能完成此作業。

  • 針對每個更新，Outlook 都必須在本機電腦上建立離線通訊錄的複本，並套用自伺服器提取的遞增變更。如果本機電腦上的離線通訊錄為 150 MB，則 Outlook 必須在每次更新時建立 150 MB 的資料複本。

  • Outlook 具有節流機制，可以在偵測到使用者活動時，降低離線通訊錄更新的速度。當發生連續的使用者活動時，離線通訊錄的大小就會影響到更新所需的時間。這段期間從一個小時到八個小時不等。

如果您要增加更新的頻率，請確定您離線通訊錄的大小相當小。理想的未壓縮大小是 1 MB 到 25 MB。

排定在 Exchange 2000 Server 及 Exchange Server 2003 更新離線通訊清單的時間

  1. 在 [系統管理員] 中，連按兩下 [收件者]，再按一下 [離線清單]。

  2. 在詳細資料窗格中，連按兩下您要為其設定更新排程的離線通訊清單。

    1. 若要選擇預先設定的更新間隔，請在 [一般] 索引標籤中的 [更新間隔] 下拉式清單中選取一個間隔。

      重要事項：
      如果您從下拉式清單中選取 [不執行]，將不更新離線通訊清單。
    2. 若要設定指定的更新排程，請按一下 [自訂]。在 [排程] 對話方塊中，在顯示的日期與時間格線中設定更新排程，然後按一下 [確定]。

對 Exchange Server 2007 更正此警告

  1. 開啟 [Exchange 管理主控台]。

  2. 依序展開 [Microsoft Exchange]、[組織組態]，然後選取 [信箱]。

  3. 在結果窗格中，按一下 [離線通訊錄] 索引標籤。

  4. 在 [離線通訊錄] 索引標籤上，選取 [預設離線通訊錄]。在執行窗格中，按一下 [內容]。

  5. 在 [一般] 索引標籤上，從 [更新排程] 下拉式清單中選取執行時間，或按一下 [自訂] 以設定自訂排程。

  6. 按一下 [確定]，儲存變更。
使用 Exchange 管理命令介面來設定離線通訊錄產生排程

  • 執行下列命令：

    複製程式碼
    Set-OfflineAddressBook -Identity <OAB Name> -Schedule <Schedule>

    其中：<OAB> 是 OAB 的辨別名稱 (DN)、網域\帳戶名稱或 GUID，<Schedule> 指定開始產生 OAB 的排定時間，而格式則是 StartDay.Hour:Minute [AM/PM]。您可以使用下列值代表星期幾：

    • 星期幾的全名

    • 星期幾的縮寫

    • 從 0 到 6 的整數，其中 0 = 星期日

    如果慣用 24 時制，請略過 AM/PM。

    例如，若要將預設離線通訊錄產生排程設為每天的 1AM 與 3AM 之間，請輸入：
複製程式碼
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -Schedule 0.01:00-0.03:00,1.01:00-1.03:00,2.01:00-2.03:00,3.01:00-3.03:00,4.01:00-4.03:00,5.01:00-5.03:00,6.01:00-6.03:00

若需詳細資訊，請參閱《離線通訊錄最佳作法手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47583)。

若需有關在 Exchange Server 2003 使用離線通訊錄的詳細資訊，請參閱《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595)中的＜設定 Exchange Server 2003 離線通訊錄＞(英文)。

若需有關在 Exchange Server 2007 使用離線通訊錄的詳細資訊，請參閱＜組織組態 > 信箱 > 離線通訊錄＞(英文) (http://go.microsoft.com/fwlink/?LinkId=79247)。


已將「離線通訊錄」產生排程設為「永不」
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2006-12-04

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定離線通訊錄組態物件的 offLineABSchedule 屬性值。offLineABSchedule 屬性代表「預設離線通訊清單」物件 (位在 Active Directory 的「通訊清單」容器中) 的離線通訊錄產生排程。如果 Exchange Server Analyzer 發現 offLineABSchedule 屬性設為 Never，就會顯示一則警告。

在預設的情況下，Exchange 會維護單一離線通訊錄。在維護週期內，Exchange 每晚都會更新此離線通訊錄 (或產生它的新版本)。您可以建立其他的離線通訊錄，並使用下列程序來檢查它們的產生排程。

此警告表示排程已變更為「永不」。除非設定新排程，否則 Exchange 不會更新現有的離線通訊錄。這表示使用者仍可下載現有的離線通訊錄，但他們不會收到任何更新。

對 Exchange 2000 Server 及 Exchange Server 2003 更正此警告

  1. 開啟 [Exchange 系統管理員]。

  2. 在 [收件者] 之下，按一下 [離線通訊清單]。

  3. 在右窗格中，在 [預設離線通訊清單] 上按一下滑鼠右鍵，再按一下 [內容]。如果不要使用離線通訊錄，請在 [預設值] [離線通訊錄] 上按一下滑鼠右鍵， 然後按一下 [刪除]。不然的話，使用本程序的其餘動作設定排程。

  4. 在 [一般] 索引標籤上，從 [更新間隔] 下拉式清單中選取執行時間，或按一下 [自訂] 以設定自訂排程。

  5. 按一下 [確定]，儲存變更。

對 Exchange Server 2007 更正此警告

  1. 開啟 [Exchange 管理主控台]。

  2. 依序展開 [Microsoft Exchange]、[組織組態]，然後選取 [信箱]。

  3. 在結果窗格中，按一下 [離線通訊錄] 索引標籤。

  4. 在 [離線通訊錄] 索引標籤上，選取 [預設離線通訊錄]。在執行窗格中，按一下 [內容]。

  5. 在 [一般] 索引標籤上，從 [更新排程] 下拉式清單中選取執行時間，或按一下 [自訂] 以設定自訂排程。

  6. 按一下 [確定]，儲存變更。

使用 Exchange 管理命令介面來設定離線通訊錄產生排程

  • 執行下列命令：

    複製程式碼
    Set-OfflineAddressBook -Identity <OAB Name> -Schedule <Schedule>

    其中：<OAB> 是 OAB 的辨別名稱 (DN)、網域\帳戶名稱或 GUID，<Schedule> 指定開始產生 OAB 的排定時間，而格式則是 StartDay.Hour:Minute [AM/PM]。您可以使用下列值代表星期幾：

    • 星期幾的全名

    • 星期幾的縮寫

    • 從 0 到 6 的整數，其中 0 = 星期日

    如果慣用 24 時制，請略過 AM/PM。

    例如，若要將預設離線通訊錄產生排程設為每天的 1AM 與 3AM 之間，請輸入：
複製程式碼
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -Schedule 0.01:00-0.03:00,1.01:00-1.03:00,2.01:00-2.03:00,3.01:00-3.03:00,4.01:00-4.03:00,5.01:00-5.03:00,6.01:00-6.03:00

若需有關在 Exchange Server 2003 使用離線通訊錄的詳細資訊，請參閱《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595)中的＜設定 Exchange Server 2003 離線通訊錄＞(英文)。

若需有關在 Exchange Server 2007 使用離線通訊錄的詳細資訊，請參閱＜組織組態 > 信箱 > 離線通訊錄＞(英文) (http://go.microsoft.com/fwlink?LinkId=79247)。


偵測到較舊的連線協定
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每一個 Active Directory 連接器 (ADC) 連線協定的 versionNumber 屬性值。

如果 Exchange Server Analyzer 在包含一或多部 Exchange Server 2003 電腦的 Exchange 組織內，發現有任何連線協定的 versionNumber 屬性值小於 16973842，就會顯示警告。

小於 16973842 的值表示已建立連線協定，並由 Exchange 2000 Server ADC 加以管理。如果您要在有執行 Exchange 2000 Server 或 Exchange Server 5.5 的組織內執行任何 Exchange Server 2003 執行個體，您必須將 ADC 的所有執行個體升級至 Exchange Server 2003 所包含的版本。在升級至 ADC 的 Exchange Server 2003 或 Exchange Server 2003 Service Pack 1 (SP1) 版本之後，該 ADC 版本所擁有的連線協定也會跟著更新。每一個連線協定的 versionNumber 屬性將更新為最新值。

若要更正此警告

  1. 從 http://go.microsoft.com/fwlink/?LinkId=29090 下載 Exchange Server 2003 SP1。

  2. 執行 Exchange Server 電腦的完整備份。

  3. 在執行 Exchange 2000 Server ADC 的伺服器上，依序按一下 [開始] 及 [執行]，然後鍵入 <path>\adc\i386\setup.exe，其中 <path> 是 Exchange Server 2003 SP1 的下載位置。

  4. 在 [歡迎使用 Active Directory 連接器安裝精靈] 頁面上，按 [下一步]。

  5. 在 [偵測到先前的安裝] 頁面上，按一下 [重新安裝]，將 Exchange 2000 Server ADC 升級至 Exchange Server 2003 ADC。

  6. 在 [正在完成 Active Directory 連接器安裝精靈] 頁面上，按一下 [完成]。

若需有關安裝及升級 ADC 的詳細資訊，請參閱下列微軟知識庫文件：

  • 823601＜Active Directory 連接器需求及對整個組織的用意＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823601)

  • 822942＜升級至 Exchange Server 2003 的注意事項＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822942)


PDC 模擬器 FSMO 角色沒有回應
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定在網域命名內容中網域目錄磁碟分割之根目錄的 fSMORoleOwner 屬性值。例如，在名為 contoso.com 的網域中，網域主控制站 (PDC) 模擬器的 fSMORoleOwner 屬性值為 DC=contoso,DC=com。接著，Exchange Server Analyzer 會嘗試對目前持有這個角色的網域控制站之 TCP 通訊埠 389，開啟輕量型目錄存取通訊協定 (LDAP) 連線。若 Exchange Server Analyzer 無法連線到這個網域控制站，就會顯示一則錯誤。

PDC 模擬器可做為網域主控制站，以與較舊的 Microsoft Windows® 作業系統相容。Microsoft Windows 2000 Server 和 Microsoft Windows Server™ 2003 可與 Microsoft Windows NT® 工作站、成員伺服器及備份網域控制站相互操作。Microsoft Windows NT 3.51 或 Microsoft Windows NT 4.0 網域中的 PDC 負責下列工作：

  • 處理來自使用者及電腦的密碼變更

  • 將更新內容複寫至備份網域控制站

  • 執行網域主瀏覽器

任何時候，只能將 PDC 模擬器主機的角色指派給每個網域中的某一個網域控制站。

若要更正此錯誤

  1. 確認錯誤訊息中指出的目錄伺服器已在連線中，並且可以讓貴組織內的 Exchange 伺服器存取。

  2. 如果已解除此目錄伺服器，您必須將 PDC 模擬器角色指派給其他網域控制站。

若需將 PDC 模擬器角色從某個網域控制站移轉給另一個網域控制站的相關資訊，請參閱下列微軟知識庫文件：

  • 若為 Windows Server 2003，請參閱 324801＜HOW TO：在 Windows Server 2003 中檢視及轉移 FSMO 角色＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)。

  • 若為 Windows 2000 Server，請參閱 255690＜如何在圖形化使用者介面檢視傳送 FSMO 角色＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690)


組態物件上的權限繼承封鎖
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2006-04-13

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 資料庫中的每一個 Exchange 組態物件，以判定是否有任何物件的權限繼承遭到封鎖。如果 Exchange 組態物件的權限繼承遭到封鎖，則 Exchange Server Analyzer 會顯示錯誤。

Exchange Server Analyzer 會識別權限繼承遭到封鎖的組態物件。

Exchange Server Analyzer 會從 Active Directory for Exchange 組態物件中擷取判別存取控制清單 (DACL)。依預設，會將組態物件 (如 Exchange 伺服器及 Exchange Server 通訊協定) 設為在安裝 Exchange 時繼承權限。當意外地取消勾選或修改權限時，會封鎖組態物件，不讓它繼承權限。在此情況下，郵件流程問題 (例如郵件滯留在佇列) 及儲存裝載問題會使 Exchange Server 回應速度變慢。

附註：
存取控制清單 (ACL) 是一種適用於所有物件的安全性保護清單、一組物件內容，或是物件的個別內容。存取控制清單有兩種類型：判別及系統。

您可以重新啟用物件的權限繼承來矯正問題。

重新啟用 Exchange 組態物件的權限繼承

  1. 設定登錄參數，啟用 [Exchange 系統管理員] 之物件內容方塊的 [安全性] 索引標籤。若需詳細的步驟， 請參閱微軟知識庫文件 - 264733＜XADM：如何啟用組織物件的 [安全性] 索引標籤＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264733)。

    附註：
    依預設，不會在組態物件內容方塊中啟用 [安全性] 索引標籤。

  2. 開啟 [Exchange 系統管理員]，尋找有問題的物件，然後重新啟用權限繼承。

  3. 重新啟動 Exchange Server。

若需有關 Windows Server 2003 Active Directory 中的判別存取控制清單的詳細資訊，請參閱＜安全性描述及存取控制清單如何運作＞(英文)

(http://go.microsoft.com/fwlink/?LinkId=64193)。

若需有關權限繼承的詳細資訊，請參閱＜權限如何運作＞(英文) (http://go.microsoft.com/fwlink/?LinkId=64195)。


網域物件上的權限繼承封鎖
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2006-04-13

Microsoft® Exchange Server Analyzer 工具會檢查 Active Directory® 網域物件，例如容器及組織單位。如果容器或組織單位中的權限繼承遭到封鎖，則 Exchange Server Analyzer 會顯示錯誤。

Exchange Server Analyzer 會識別特定的物件。

對 Active Directory 網域物件進行變更時，會覆寫存取控制清單 (ACL) 的變更。即使手動啟動 [從父代繼承]，在將變更套用至 ACL 時，仍會停用所套用的繼承。這個狀況會導致收件者更新服務 (RUS) 問題，因為 RUS 沒有帳戶所在的 Active Directory 組織單位的必要權限。

只有在帳戶所在的 Active Directory 組織單位中停用了 [允許父系可繼承的權限傳播到這個物件] 核取方塊時，才會發生這種行為。

若要解決問題，請使用 [Active Directory 使用者及電腦] 嵌入式管理單元，或 Active Directory 服務介面 (ADSI) 編輯器，以重新建立組織單位的繼承權限。請遵循微軟知識庫文件 - 254030＜遺失權限會導致收件者更新服務不處理 Exchange 2000 Server 及 Exchange Server 2003 中的帳戶＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=254030)。

若需有關 Microsoft Windows Server 2003™ Active Directory 中的存取控制清單 (ACL) 的詳細資訊，請參閱＜安全性描述元及存取控制清單如何運作＞(英文) (http://go.microsoft.com/fwlink/?LinkId=64193)。

若需有關權限繼承的詳細資訊，請參閱＜權限如何運作＞(英文) (http://go.microsoft.com/fwlink/?LinkId=64195)。


找不到公用資料夾階層
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 msExchPFTreeType 屬性值為 1 之公用資料夾階層的數目。msExchPFTreeType 屬性的值為 1 表示特定公用資料夾階層是 MAPI 用戶端的指定公用資料夾階層。如果 Exchange Server Analyzer 判定 Exchange 組織中沒有 msExchPFTreeType 屬性值為 1 的公用資料夾階層，就會顯示一則錯誤。

此錯誤表示組織中不存在 MAPI 用戶端公用資料夾階層。不存在 MAPI 用戶端的公用資料夾階層會導致問題發生。例如，MAPI 用戶端的公用資料夾階層不存在，會導致無法升級 Microsoft Windows® 伺服器叢集中執行的 Exchange 虛擬伺服器。

若要解決此問題，您可以使用 Active Directory 編輯工具，將 MAPI 用戶端之公用資料夾階層的 msExchPFTreeType 屬性值設為 1。下列工具為 Active Directory 編輯工具：

  • Active Directory Service Interfaces (ADSI) 編輯器 (AdsiEdit.msc)

  • LDP (ldp.exe) 工具

您應該只修改 MAPI 公用資料夾階層。如果 Exchange 組織包括應用程式公用資料夾階層，請確定您只修改 MAPI 公用資料夾階層的屬性。

將 MAPI 公用資料夾階層的 msExchPFTreeType 屬性值設為 1 後，請設定 Exchange 服器上的信箱儲存區，使其指向 MAPI 公用資料夾階層，作為預設公用資料夾儲存區。

注意：
使用 ADSI 編輯器、LDP 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Windows Server™ 2003、Exchange Server 2003 (或兩者) 才能解決。修改 Active Directory 物件屬性的風險由客戶自行負責。
更正此錯誤

  1. 使用 Active Directory 編輯工具來尋找 Active Directory 中的公用資料夾階層物件。公用資料夾物件位於：CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdminGroupName>, CN=Folder Hierarchies

  2. 藉由輸入 1 作為新值，來變更 msExchPFTreeType 屬性。

  3. 關閉 Active Directory 編輯器

  4. 開啟 [Exchange 系統管理員]。

  5. 若要存取每個信箱儲存區的內容，請按一下 [系統管理群組]，然後依序展開系統管理群組、[伺服器]、您的伺服器，以及儲存群組。然後，在您要變更其內容的信箱儲存區上按一下滑鼠右鍵，再選取 [內容]。

  6. 在 [一般] 索引標籤上的 [預設公用儲存區] 欄位中按一下 [瀏覽]。

  7. 選取 MAPI 公用資料夾階層，然後按兩次 [確定] 以儲存變更。

  8. 針對每個信箱儲存區，重複步驟 5 至 7。

若需有關使用 LDP 工具修改 Active Directory 的詳細資訊，請參閱微軟知識庫文件 - 260745＜XADM：Using the LDP Utility to Modify Active Directory Object Attributes＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

若需 MAPI 及應用程式的公用資料夾階層之相關資訊，請參閱下列資源：

  • 微軟知識庫文件 - 258509＜Exchange 2000 Server 及 Exchange Server 2003 公用資料夾樹狀目錄類型的說明＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258509)

  • Exchange 團隊部落格項目＜擁有郵件功能的公用資料夾如何運作＞(英文) (http://go.microsoft.com/fwlink/?LinkId=41913)


收件者連線協定複寫排程不是設為「永遠」
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個 Active Directory 連接器 (ADC) 連線協定上的 activationStyle 屬性設定為何。activationStyle 屬性對應到執行 ADC 連線協定的頻率。值為 0 表示複寫排程是設定為 [永不]。值為 1 表示排程是設定為 [選取的時間]。值為 2 表示排程是設定為 [自動進行]。

Exchange Server Analyzer 也會查詢 Active Directory，以判定每個 ADC 連線協定物件上的 msExchServer2SearchFilter 屬性值。msExchServer2SearchFilter 屬性代表搜尋目錄時會使用的搜尋篩選器。

如果 Exchange Server Analyzer 發現 activationStyle 屬性未設為 [永遠]，且 msExchServer2SearchFilter 屬性正在複寫收件者資訊，就會顯示警告。

通常最佳的作法，是將收件者連線協定的複寫排程設為永遠複寫。在某些情況下，將信箱從 Exchange Server 5.5 站台移至 Exchange Server 2003 組織之後，將連線協定設為任何其他排程可能會產生未傳遞回報 (NDR)。

若要更正此警告

  1. 開啟 [Active Directory 連接器服務] MMC 嵌入式管理單元。

  2. 開啟 [連線協定]。

  3. 在 [Connection_Agreement 內容] 頁面上，選取 [排程] 索引標籤，再選取 [永遠]，然後按一下 [確定]。

若需有關部署 ADC 及設定連線協定的詳細資訊，請參閱《Exchange Server 2003 部署手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47569)。


收件者原則含有變數
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個收件者原則物件的 gatewayProxy 屬性值。如果 Exchange Server Analyzer 發現其 gatewayProxy 屬性中有包含字串 SMTP:% 的收件者原則物件，就會顯示非預設的組態訊息。

若您使用替代字串來修改收件者原則，藉以產生「簡易郵件傳送通訊協定 (SMTP)」位址，則您的收件者原則將含有變數。在預設收件者原則中使用變數，會造成 Service Pack 2 (SP2) 之前的 Exchange 2000 Server 發生複寫問題。因此，建議您不要在收件者原則中使用變數，否則請將 Exchange 2000 Server 升級至最新的 Service Pack。Exchange 2000 Server SP2 及更新版本支援在預設收件者原則中使用變數。

修改收件者原則

  1. 啟動 Exchange 系統管理員。

  2. 依序按一下 [組織]、[收件者]，再按一下 [收件者原則]。

  3. 連按兩下您要變更的原則。

  4. 按一下 [電子郵件地址] 索引標籤，然後編輯適當的 SMTP 地址或產生規則。

若需有關如何設定收件者原則的詳細資訊，請參閱微軟知識庫文件 - 249299＜HOW TO：設定 Exchange 2000 Server 中的收件者原則＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=249299)。

若需有關使用產生規則自訂 SMTP 地址的詳細資訊，請參閱知識庫文件 - 822447＜如何使用收件者原則修改 SMTP 電子郵件地址＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822447)。

若需有關當預設收件者原則包含變數時，Exchange 2000 Server 可能發生之問題的詳細資訊，請參閱知識庫文件 - 271339＜XADM：無法裝載資料庫且發生事件識別碼 9546＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=271339)。

若要取得最新的 Exchange 2000 Server Service Pack，請參閱「Exchange 2000 Server 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


收件者更新服務可能會延遲
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 Active Directory 中每個收件者更新服務物件的 msExchServer1HighestUSN 屬性值。Exchange Server Analyzer 也會查詢 Active Directory，以判定 Active Directory 中每個收件者更新服務物件的 activationStyle 屬性值。activationStyle 屬性表示收件者更新服務的更新間隔。

Exchange Server Analyzer 還會查詢 Active Directory，以判定收件者更新服務所使用之網域控制站的 RootDSE 屬性的 highestCommittedUSN 屬性值。highestCommittedUSN 屬性是此網域控制站上資料庫已確認之伺服器上任何物件的最高更新序號 (USN)。

Exchange Server Analyzer 也會查詢 Active Directory，以判定每個收件者更新服務物件的 msExchServer1LastUpdateTime 屬性值。msExchServer1LastUpdateTime 屬性表示上一次從此目錄成功進行同步處理的最新更新日期及時間。

如果 Exchange Server Analyzer 發現存在下列三種情況，則會顯示警告：

  • activationStyle 屬性設為 2，表示此收件者更新服務的排程設為「永遠」。

  • msExchServer1HighestUSN 值中列出的序號是 5,000 或以上，在 highestCommittedUSN 中列出之序號的後面。

  • 自 msExchServer1LastUpdateTime 屬性中記錄的時間戳記以來，已經過了六個多小時。

此警告指示已有數小時未執行指定的收件者更新服務，因此可能已延遲。

更正此警告

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [收件者]，然後選取 [收件者更新服務]。

  3. 在指定的收件者更新服務上按一下滑鼠右鍵，然後選取 [立即更新]。

  4. 等待 30 分鐘，然後返回 Exchange Server Analyzer，以查看此警告狀況是否仍然存在。如果仍然存在，請繼續進行步驟 5，如果不存在，則無需進行進一步的動作。

  5. 啟動 [Microsoft Exchange System Attendant] 服務。

若需「收件者更新服務」的相關資訊，請參閱下列微軟知識庫文件：

  • 253770＜收件者更新服務執行的工作＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828＜收件者更新服務如何擴展通訊清單＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838＜XADM: 收件者更新服務如何套用系統原則＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738＜XADM: 收件者更新服務如何套用收件者原則＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


收件者更新服務未處理所有的變更
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2006-03-16

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 Active Directory 中任何收件者更新服務物件的 gatewayProxy 屬性值是否存在。如果 Exchange Server Analyzer 發現任何收件者更新服務物件的 gatewayProxy 屬性值已設定，就會顯示一則警告。

此警告表示收件者更新服務物件的 gatewayProxy 屬性包含未完全處理的舊資料。應手動移除此資料。

必須移除來自 gatewayProxy 屬性的舊資料；否則這些位址將處於「已套用」狀態。如果系統管理員選擇使用 [重建] 或 [立即更新] 選項來變更原則，則有效的使用者位址可能會意外地遭到覆寫，因而導致每一個使用者的 SMTP 位址變更。若需相關資訊，請參閱 Exchange 部落格文章＜收件者原則及純 Exchange 2000/2003 站台＞。

附註：
提供這個部落格的連結只是為了參考而已。內容隨時都會變更，不另行通知。

如果存在下列任何情況，收件者更新服務物件的 gatewayProxy 屬性就可能包含未完全處理的舊資料：

  • Active Directory 複寫存在問題。如果「Exchange 系統管理員」使用非 Exchange 使用之執行「收件者更新服務」的網域控制站，則 Active Directory 複寫可能會存在延遲問題或其他問題。

  • 存在非交易式時間問題，導致變更遺失。當 Exchange 系統管理員及系統服務員同時存取 gatewayProxy 屬性時，會發生此行為。Exchange 系統管理員及系統服務員都嘗試讀取該屬性並進行變更，然後寫回屬性。

您必須使用如 Active Directory Service Interfaces (ADSI) 編輯器 (AdsiEdit.msc)、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端等工具，來移除舊資料。

注意：
使用 ADSI 編輯器、LDP 工具或其他 LDAP 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
若要更正此警告

  1. 請將「收件者更新服務」的更新間隔設為 [永不]，步驟如下：

    1. 開啟 [Exchange 系統管理員]。

    2. 依序展開 [收件者] 及 [收件者更新服務]。

    3. 在您要修改的收件者更新服務上按一下滑鼠右鍵，然後選取 [內容]。

    4. 在 [一般] 索引標籤上，使用 [更新間隔] 清單，將排程設為 [不執行]。

  2. 大約要等待一兩分鐘。

  3. 接著，使用 ADSI 編輯器或類似工具來尋找其 gatewayProxy 屬性包含舊資料的收件者更新服務物件。收件者更新服務物件位於下列位置：

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Address Lists Container,CN=Recipient Update Services

    1. 在包含舊資料的收件者更新服務物件上按一下滑鼠右鍵，然後選取 [內容]。

    2. 在 [屬性編輯器] 索引標籤上，向下捲動並選取 gatewayProxy 屬性。

    3. 按一下 [編輯]，以編輯此屬性。

    4. 在 [值] 方塊中，選取要移除的舊地址類型，再按一下 [移除] 與 [確定]。重複此步驟，直到移除完所有的地址類型。

    5. 按一下 [確定] 以儲存變更，然後關閉 ADSI 編輯器。

  4. 清除 gatewayProxy 屬性之後，強制進行目錄複寫。請確定在再次執行網域收件者更新服務之前，先進行複寫。

  5. 將收件者更新服務重新設定為其原始排程。

  6. 如果必須這樣做，請重新套用特定收件者原則。使用 Active Directory 站台及服務嵌入式管理單元來執行手動 Active Directory 複寫。

若需有關此問題的詳細資訊，請參閱微軟知識庫文件 - 821743＜未清除收件者更新服務物件上的 gatewayProxy 屬性＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821743)。

若需有關使用 LDP 工具的詳細資訊，請參閱知識庫文件 - 260745＜XADM:Using the LDP Utility to Modify Active Directory Object Attributes＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

若需有關強制目錄複寫的詳細資訊，請參閱微軟知識庫文件 - 232072＜初始化 Active Directory 直接複寫協力電腦之間的複寫＞ (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072)。

若需有關使用 ADSI 編輯器的詳細資訊，請參閱 Windows Server 2003 說明中的＜Adsiedit.msc:ADSI 編輯器＞主題。


收件者更新服務完整重建
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 Exchange Server 所使用之組態網域控制站上收件者更新服務物件的 msDS-ReplAttributeMetaData 屬性值。msDS-ReplAttributeMetaData 屬性包含其上次變更的日期與時間及其他資訊。如果 Exchange Server Analyzer 發現自 msDS-ReplAttributeMetaData 中列出的日期與時間之後經過的天數少於五天，就會顯示一則警告。

此警告指出最近排定了此收件者更新服務的完整重建。若設定了完整重建，則在下次收件者更新服務由排程或 [立即更新] 指令所啟動時，收件者更新服務將會檢查所有物件，而非僅止於查詢新的物件。這項處理程序十分耗時，可能造成系統延遲。

若您要進行完整重建，可以忽略此警告，無需顧慮安全性。如果不想進行完整的重建，您可以使用 Active Directory Service Interfaces (ADSI) 編輯器 (AdsiEdit.msc) 及下列程序，將 Active Directory 中的 msExchDoFullReplication屬性值從 True 變更為 False，以解決問題。

注意：
使用 ADSI 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
若要更正此警告

  1. 使用 ADSI 編輯器或類似工具，尋找指定之收件者更新服務物件的 msExchDoFullReplication 屬性。收件者更新服務物件位於：CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Address Lists Container,CN=Recipient Update Services

  2. 在指定的收件者更新服務上按一下滑鼠右鍵，然後選取 [內容]。

  3. 在 [屬性編輯器] 索引標籤上，向下捲動並選取 msExchDoFullReplication 屬性。

  4. 按一下 [編輯] 以編輯此屬性。

  5. 在 [Boolean 屬性編輯器] 對話方塊中，將選項由 [True] 變更為 [False]，然後按一下 [確定]。

  6. 再按一下 [確定] 以儲存變更，然後關閉 ADSI 編輯器。

若需收件者更新服務的相關資訊，請參閱下列微軟知識庫文件：

  • 253770＜收件者更新服務執行的工作＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828＜收件者更新服務如何擴展通訊清單＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838＜XADM：收件者更新服務如何套用系統原則＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738＜XADM：收件者更新服務如何套用收件者原則＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


設定收件者更新服務以執行完整重建
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 Active Directory 中每個收件者更新服務物件的 msExchDoFullReplication 屬性值。如果 Exchange Server Analyzer 發現任何收件者更新服務物件的 msExchDoFullReplication 屬性值設為 True，就會顯示一則警告。

這個警告表示此收件者更新服務設定為在下一個處理循環中執行完整重建。當 msExchDoFullReplication 屬性設為 True 時，在下次收件者更新服務依排程或 [立即更新] 命令所啟動時，收件者更新服務將會檢查每個物件，而非僅止於查詢新的物件。此處理需要花費很長的時間，因此可能會造成系統延遲。

如果使用完整重建，您就可以安全地忽略此警告。如果不想進行完整的重建，您可以使用 Active Directory Service Interfaces (ADSI) 編輯器 (AdsiEdit.msc) 及下列程序，將 Active Directory 中的 msExchDoFullReplication屬性值從 True 變更為 False，以解決問題。

注意：
使用 ADSI 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
更正這個警告

  1. 使用 ADSI 編輯器或類似工具，尋找指定之收件者更新服務物件的 msExchDoFullReplication 屬性。收件者更新服務物件位於下列位置：CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Address Lists Container,CN=Recipient Update Services

  2. 在指定的收件者更新服務上按一下滑鼠右鍵，然後選擇 [內容]。

  3. 在 [屬性編輯器] 索引標籤上，向下捲動並選取 msExchDoFullReplication 屬性。

  4. 按一下 [編輯]，以編輯此屬性。

  5. 在 [布林值屬性編輯器] 對話方塊中，將選取的值由 [True] 變為 [False]，再按一下 [確定]。

  6. 按一下 [確定] 以儲存變更，然後關閉 ADSI 編輯器。

若需收件者更新服務的相關資訊，請參閱下列微軟知識庫文件：

  • 253770＜收件者更新服務執行的工作＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828＜收件者更新服務如何擴展通訊清單＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838＜XADM: 收件者更新服務如何套用系統原則＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738＜XADM: 收件者更新服務如何套用收件者原則＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


收件者更新服務並非作用中
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 Active Directory 中每個收件者更新服務物件的 activationStyle 屬性值。如果 Exchange Server Analyzer 發現有任何收件者更新服務物件的 activationStyle 屬性值設為 0，就會顯示警告。

此警告會指出這項收件者更新服務物件的排程設定為 [永不]。若將收件者更新服務的排程設為 [永不]，則不會處理新的物件。

若您已不再需要這項收件者更新服務物件，建議您將它刪除。若您還需要這項收件者更新服務物件，建議您設定其排程。

設定排程以更正這項警告

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [收件者]，然後選取 [收件者更新服務]。

  3. 在排程設為 [永不] 的收件者更新服務上按一下滑鼠右鍵，然後選取 [內容]。

  4. 使用 [更新間隔] 清單來選取預先定義的排程，或按一下 [自訂] 以建立自訂排程。

  5. 按一下 [確定]，儲存變更。

  6. 在此收件者更新服務上按一下滑鼠右鍵，然後選取 [立即更新]。

若需收件者更新服務的相關資訊，請參閱下列微軟知識庫文件：

  • 253770＜收件者更新服務執行的工作＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828＜收件者更新服務如何擴展通訊清單＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838＜XADM：收件者更新服務如何套用系統原則＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738＜XADM：收件者更新服務如何套用收件者原則＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


需要收件者更新服務軟體更新
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定通訊錄檢視及動態群組服務 (abv_dg.dll) (亦稱為收件者更新服務) 的 Version 機碼值。Version WMI 機碼表示此檔案的組建編號。

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定 NTDS 設定物件的 msDS-Behavior-Version 屬性值。此值指示 Active Directory 樹系功能等級。msDS-Behavior-Version 屬性的有效值顯示在下表中。

值 | 樹系功能等級
0 | Microsoft Windows 2000 Server 混合模式
1 | Microsoft Windows Server™ 2003 過渡模式
2 | Microsoft Windows Server 2003 原生模式

如果 Exchange Server Analyzer 發現在 Windows Server 2003 過渡模式或原生模式下 Active Directory 樹系中的 Exchange 伺服器上，abv_dg.dll 的組建編號小於 6.0.6615.0，就會顯示一則錯誤。此錯誤表示 Exchange 2000 Server 版本的收件者更新服務在不相容的 Windows Server 2003 Active Directory 樹系層級中執行。若要解決此問題，需要更新收件者更新服務。

當您使用 Exchange 2000 Server 中的收件者更新服務，來更新 Windows Server 2003 樹系中的收件者物件時，收件者更新服務不會正確更新物件。例如，收件者更新服務不會辨識對群組成員所做的變更。而且，如果使用 Exchange 2000 Server Active Directory 連接器 (ADC)，ADC 可能不會將 Active Directory 中的群組成員變更複寫到 Exchange Server 5.5 目錄。

更新至最新版本的收件者更新服務

  1. 若要取得必要的更新，請遵循微軟知識庫文件 - 873059＜Exchange 2000 Server 在 Windows Server 2003 樹系中執行時收件者更新服務未正確更新物件＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=873059) 中的指示。

  2. 套用更新。套用此更新後，不必重新啟動電腦。但是，當您套用此更新時，Exchange 相關服務會自動重新啟動。


不存在此網域的 RUS 執行個體
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以傳回樹系中網域的清單。Exchange Server Analyzer 也會查詢現有網域收件者更新服務 (RUS) 執行個體清單的 msExchangeDomainLink 屬性。然後，Exchange Server Analyzer 會將傳回的網域清單與傳回的 RUS 執行個體清單相比較，以判定兩者是否相符。若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • 網域已存在

  • 不存在該網域的 RUS 執行個體

如果已使用 DomainPrep 準備網域，但該網域的 RUS 執行個體不存在，則 Exchange Server Analyzer 會顯示此錯誤。如果系統管理員新增 Active Directory 網域至樹系，並使用 DomainPrep 準備 Exchange 的網域，但忘記新增網域的 RUS 執行個體，在這種情況下會出現不符。如果發生此行為，則在網域中建立的新使用者物件將不會收到發送給它們的電子郵件地址。若收到此錯誤訊息，請為網域建立新的收件者更新服務。

若要更正此錯誤

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [收件者]。

  3. 以滑鼠右鍵按一下 [收件者更新服務] 節點，再按 [新增] 及 [收件者更新服務]。

  4. 在 [新物件] 視窗中，按一下 [瀏覽] 以尋找網域名稱。

  5. 選取網域名稱，並按一下 [確定]。

  6. 在 [新物件] 視窗中，按 [下一步]，再按 [完成]。

若需有關收件者更新服務的相關資訊，請參閱下列微軟知識庫文件：

  • 328738＜收件者更新服務如何套用收件者原則＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828＜收件者更新服務如何擴展通訊清單＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127＜如何檢查 Exchange 收件者更新服務的進度＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770＜Exchange 收件者更新服務執行的工作＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


複寫期間變更
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已經設定任一網域控制站之 NTDS Settings 物件的 ms-DS-ReplicationEpoch 屬性。

期間是指網域擁有某個名稱的時段。 網域第一次建立時，以及網域名稱變更時，即開始新的期間。

ms-DS-ReplicationEpoch 屬性會套用至所有網域控制站在其下複寫的期間。如果 Exchange Server Analyzer 發現此屬性已設定為某個值，就會顯示非預設組態的訊息。

存在 ms-DS-ReplicationEpoch 屬性的值通常表示受影響之伺服器所在的網域已重新命名。Microsoft Windows Server™ 2003 Standard Edition、Windows Server 2003 Enterprise Edition 和 Windows Server 2003 Datacenter Edition 允許系統管理員在 Active Directory 樹系結構完成後為該樹系中的網域重新命名。Windows® 2000 Server 作業系統不會在 Active Directory 樹系結構完成後，讓系統管理員重新命名樹系中的網域。

Active Directory 樹系的結構依您建立網域及其階層名稱的順序而決定。您必須從樹系根網域開始。所有的子網域都會從樹系根網域名稱衍生出它們的辨別名稱與預設 DNS 名稱。接著，樹系中的其他各個樹狀目錄也都可比照辦理。

您可以為網域重新命名，以變更現有網域樹狀目錄的階層結構。例如，您可以將子網域重新命名在其他父網域下，您也可以將子網域重新命名為新的樹狀目錄根網域。在這兩個範例中，您都會重新定位現有的網域以建立不同的網域樹狀目錄結構。

此外，您也可以在不影響結構的情況下為網域重新命名。例如，當您為根網域重新命名時，您可以變更根網域下所有子網域的名稱。然而您並不會建立其他網域樹狀目錄結構。

包含 Exchange 2000 Server 或 Exchange Server 5.5 的樹系中不支援網域的重新命名。Windows Server 2003 網域重新命名工具的設計，是為了重新命名不包含 Exchange 2000 Server 伺服器或 Exchange Server 5.5 伺服器之 Active Directory 樹系中的網域。Windows Server 2003 網域重新命名工具之所以會有此限制是因為：

  • 為網域重新命名會影響到幾項 Exchange 屬性。

  • Windows Server 2003 網域重新命名工具沒有修正這些屬性的功能。

包含 Exchange Server 2003 的樹系中支援網域的重新命名。在您重新命名包含 Exchange 2003 Server 伺服器的網域之後，Exchange 網域重新命名修復工具 (XDR-fixup.exe) 會修正 Exchange Server 屬性。您可以與 Windows Server 2003 目錄重新命名工具 (Rendom.exe) 搭配使用 Exchange 網域重新命名修復工具。

若需 Windows Server 2003 Active Directory 網域重新命名工具的詳細資訊及欲下載 Windows Server 2003 Active Directory 網域重新命名工具，請參閱＜Windows Server 2003 Active Directory 網域重新命名工具＞(英文) (http://go.microsoft.com/fwlink/?LinkId=40992)。

若要為網域重新命名，必須執行 XDR-fixup 工具。XDR-fixup 工具可修正 Exchange Server 中的 Active Directory 屬性，以反映新的網域名稱。XDR-fixup 工具不會取代 Windows Server 2003 網域重新命名工具。XDR-fixup 工具也不會擴充 Windows Server 2003 網域重新命名工具的功能。您必須在每次執行 Rendom.exe 時執行 XDR-fixup 工具。

若想進一步瞭解網域重新命名的處理程序以及此處理程序對 Exchange Server 有何影響，請參閱下列工具與文件：

  • ＜Windows Server 2003 Active Directory 網域重新命名工具＞(英文) (http://go.microsoft.com/fwlink/?LinkId=40992)

  • ＜瞭解網域重新命名如何運作＞(英文) (http://go.microsoft.com/fwlink/?LinkId=41906)

  • 《實作網域重新命名逐步手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=41359)

  • ＜Exchange Server 網域重新命名修復＞(英文) (http://go.microsoft.com/fwlink/?LinkId=34171)

  • ＜Exchange 及網域重新命名作業＞(英文) (http://go.microsoft.com/fwlink/?LinkId=41908)


找不到離線通訊錄第 2 版的複本
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2007-01-29

Microsoft® Exchange Server Analyzer 工具會查詢 Exchange_Public_Folder Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 HasLocalReplica 目前的值。如果 Exchange Server Analyzer 發現離線通訊清單之離線通訊錄版本 2 執行個體的 HasLocalReplica 值設為 False，就會顯示錯誤。

當離線通訊清單的離線通訊錄版本 2 執行個體的 HasLocalReplica 設為 False 時，無法正確產生離線通訊清單。因此，Microsoft Outlook® 2002 及更早版本的使用者無法下載離線通訊清單。

若未設定任何公用資料夾儲存區來存放離線通訊錄版本 2 的複本，就會發生這個問題。在預設的情況下，離線通訊錄會將其內容複寫到其安裝所在之伺服器的公用資料夾儲存區中。若從離線通訊錄的複寫組態中移除公用資料夾儲存區，便會產生上一段所提到的問題。

若要更正此錯誤

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [系統管理群組]，再按一下 [資料夾]。

  3. 在 [公用資料夾] 上按一下滑鼠右鍵，再按一下 [檢視系統資料夾]。

  4. 按一下以展開 [離線通訊錄] 物件。

  5. 在 [離線通訊錄] 的 o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List 上按一下滑鼠右鍵，再按一下 [內容]。

  6. 在 [複寫] 索引標籤上，驗證已在 [將內容複寫到這些公用儲存區] 方塊中輸入公用資料夾儲存區。若未輸入公用資料夾儲存區，請按一下 [新增]，然後為離線通訊錄輸入適當的公用儲存區。

  7. 按一下 [套用]，再按一下 [確定]。

  8. 按一下以展開 o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List。

  9. 在 o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List 下的 [離線通訊錄第 2 版] 上按一下滑鼠右鍵，再按一下 [內容]。

  10. 在 [複寫] 索引標籤上，驗證已在 [將內容複寫到這些公用儲存區] 方塊中輸入公用資料夾儲存區。若未輸入公用資料夾儲存區，請按一下 [新增]，然後為離線通訊錄輸入適當的公用儲存區。

  11. 按一下 [套用]，再按一下 [確定]。

若需有關此問題的詳細資訊，請參閱微軟知識庫文件 - 286328＜通訊錄遺失且無法在 Microsoft Exchange 中產生＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328)。

若需有關離線通訊錄清單產生的詳細資訊，請參閱＜離線通訊錄清單產生概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkId=82242)。

若需有關如何從系統管理群組正確移除預設 Exchange Server 2003 電腦的詳細資訊，請參閱知識庫文件 - 822931＜如何從系統管理群組移除預設 Exchange Server 2003 電腦＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822931)。


找不到離線通訊錄 3a 版的複本
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Exchange_Public_Folder Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 HasLocalReplica 目前的值。如果 Exchange Server Analyzer 發現離線通訊清單之離線通訊錄版本 3a 執行個體的 HasLocalReplica 值設為 False，就會顯示錯誤。

當離線通訊清單之離線通訊錄版本 3a 執行個體的 HasLocalReplica 設為 False 時，無法正確產生離線通訊清單。因此，Microsoft Office Outlook® 2003 使用者無法下載任何離線通訊清單。

若未設定任何公用資料夾儲存區來存放離線通訊錄 3a 版的複本，就會產生這個問題。根據預設，離線通訊錄會將內容複寫到其安裝所在之伺服器的公用資料夾儲存區中。若從離線通訊錄的複寫組態中移除公用資料夾儲存區，就會產生上一段所提到的問題。

若要更正此錯誤

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [系統管理群組]，然後按一下 [資料夾]。

  3. 以滑鼠右鍵按一下 [公用資料夾]，然後按一下 [檢視系統資料夾]。

  4. 按一下以展開 [離線通訊錄] 物件。

  5. 在 [離線通訊錄] 下，以滑鼠右鍵按一下 o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List，然後按一下 [內容]。

  6. 在 [複寫] 索引標籤上，驗證已在 [將內容複寫到這些公用儲存區] 方塊中輸入公用資料夾儲存區。若未輸入公用資料夾儲存區，請按一下 [新增]，然後為離線通訊錄輸入適當的公用儲存區。

  7. 按一下 [套用]，再按一下 [確定]。

  8. 按一下以展開 o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List。

  9. 在 o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List 下，以滑鼠右鍵按一下 [離線通訊錄 3a 版]，然後按一下 [內容]。

  10. 在 [複寫] 索引標籤上，驗證已在 [將內容複寫到這些公用儲存區] 方塊中輸入公用資料夾儲存區。若未輸入公用資料夾儲存區，請按一下 [新增]，然後為離線通訊錄輸入適當的公用儲存區。

  11. 按一下 [套用]，再按一下 [確定]。

若需有關此問題的詳細資訊，請參閱微軟知識庫文件 - 286328＜通訊錄遺失且無法在 Microsoft Exchange 中產生＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328)。

若需有關如何從系統管理群組正確移除預設 Exchange Server 2003 電腦的詳細資訊，請參閱知識庫文件 - 822931＜如何從系統管理群組移除預設 Exchange Server 2003 電腦＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822931)。


目錄複寫連接器排程
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個 Active Directory 連接器 (ADC) 連線協定物件的 activationSchedule 屬性值。activationSchedule 屬性對應到執行 ADC 連線協定的頻率。值 0 表示複寫排程是設定為 [永不]。值 1 表示排程是設定為 [選取的時間]。值 2 表示排程是設定為 [永遠]。

Exchange Server Analyzer 也會查詢 Active Directory，以判定每個 ADC 連線協定物件上的 msExchServer2SearchFilter 屬性值。msExchServer2SearchFilter 屬性代表搜尋目錄時會使用的搜尋篩選器。

如果 Exchange Server Analyzer 發現 activationSchedule 屬性設為 [選取的時間] (複寫間隔為 6 個小時以上)，且msExchServer2SearchFilter 屬性正在複寫收件者資訊，就會顯示一則警告。

一般而言，最佳的作法是將收件者連線協定的複寫排程設定成一律複寫 (永遠)。在某些情況下，將信箱從 Exchange Server 5.5 站台移至 Exchange 2000 Server 或 Exchange Server 2003 之後，將連線協定設成任何其他排程都可能會產生未傳遞回報 (NDR)。

若要更正此警告

  1. 開啟 [Active Directory 連接器服務] MMC 嵌入式管理單元。

  2. 開啟 [連線協定]。

  3. 在 [Connection_Agreement 內容] 頁面上，依序按一下 [排程] 索引標籤、[永遠] 及 [確定]。

若需有關部署 ADC 及設定連線協定的詳細資訊，請參閱《Exchange Server 2003 部署手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47569)。


RID FSMO 伺服器角色沒有回應
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定網域命名內容中相對識別碼 (RID) 操作主機的 fSMORoleOwner 屬性值。例如，在名為 contoso.com 的網域中，RID 操作主機的 fSMORoleOwner 是一個值為 CN=RID Manager$, CN=System, DC=contoso, DC=com 的屬性。接著，Exchange Server Analyzer 會嘗試對目前持有這個角色的網域控制站之 TCP 通訊埠 389，開啟輕量型目錄存取通訊協定 (LDAP) 連線。若 Exchange Server Analyzer 無法連線到這個網域控制站，就會顯示一則錯誤。

RID 主機會配置相對識別碼給所有網域控制站，以確定所有安全性主體都有唯一的識別項。您可以在任何網域控制站上建立新的安全性主體物件 (使用者、群組或電腦)。當您建立安全性主體物件時，網域控制站會將唯一的安全性識別碼 (SID) 附加在該物件上。網域 SID 由四個元素組成，其中一個就是網域的 RID。RID 操作主機負責處理特定網域中所有網域控制站提出的 RID 集區要求。無論何時，都只能有一個網域控制站用來作為網域中的 RID 主機。

若要更正此錯誤

  1. 確認錯誤訊息中指出的目錄伺服器已在連線中，並且可以讓貴組織內的 Exchange 伺服器存取。

  2. 如果這部目錄伺服器關閉，您就必須將 RID 主機角色指派給其他的網域控制站。

若需有關將某一個網域控制站的 RID 操作主機角色轉移給另一個網域控制站的詳細資訊，請參閱下列微軟知識庫文件：

  • 若為 Microsoft Windows Server™ 2003，請參閱 324801＜HOW TO：在 Windows Server 2003 中檢視及轉移 FSMO 角色＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)

  • 若為 Microsoft Windows® 2000 Server，請參閱 255690＜HOW TO：在圖形化使用者介面檢視傳送 FSMO 角色＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690)


找不到架構 FSMO 角色
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定指定為架構 FSMO (架構命名內容上的 fSMORoleOwner ) 的網域控制站。如果 Exchange Server Analyzer 發現樹系上沒有 fSMORoleOwner 屬性中所指定的網域控制站，就會顯示一則錯誤。

架構命名內容 (CN=Schema,CN=Configuration,DC=domain,DC=com) 中的 fSMORoleOwner 屬性會定義網域控制站，而此控制站為樹系的架構主機。架構主機網域控制站會控制架構的所有更新及修改。若要更新樹系架構，您必須有架構主機的存取權。在整個樹系中只能有一個架構主機。

您必須為 Active Directory 樹系定義架構主機。如果架構主機網域控制站在安裝期間離線，Exchange 2000 Server 安裝程式及 Exchange 2000 Server Service Pack 安裝程式便會失敗 (即使未更新架構)。如果列示為架構主機的網域控制站離線，則必須讓它重新連線。此情況不會在 Exchange Server 2003 中發生。Exchange Server 2003 安裝程式僅會在判定架構未擴充時才會連絡架構主機。

若要更正此錯誤

  1. 請確認指定的 Active Directory 伺服器確實存在。

  2. 如果已解除委任此目錄伺服器，請將架構主機的角色指派給另一個網域控制站。

若需如何將架構主機角色指派給另一個網域控制站的相關資訊，請參閱下列微軟知識庫文件：

  • 280178＜XADM：Exchange 2000 安裝需要存取架構主機＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=280178)

  • 若為 Microsoft Windows Server™ 2003，請參閱 324801＜HOW TO：在 Windows Server 2003 中檢視及轉移 FSMO 角色＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)

  • 若為 Microsoft Windows® 2000 Server，請參閱 255690＜HOW TO：在圖形化使用者介面檢視傳送 FSMO 角色＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690)


架構 FSMO 角色沒有回應
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定架構命名內容中架構操作主機的 fSMORoleOwner 屬性值。例如，在名為 contoso.com 的網域中，架構操作主機的 fSMORoleOwner 屬性值為 CN=Schema,CN=System,DC=contoso,DC=com。接著，Exchange Server Analyzer 會嘗試對目前持有這個角色的網域控制站之 TCP 通訊埠 389，開啟輕量型目錄存取通訊協定 (LDAP) 連線。若 Exchange Server Analyzer 無法連線到這個網域控制站，就會顯示一則錯誤。

具有架構主機角色的網域控制站，是唯一可以對目錄架構執行寫入操作的網域控制站。這些架構更新會從架構主機複寫至樹系中所有其他網域控制站。架構主機是依照樹系的操作主機角色，因為不論有多少個網域，樹系中都只有一個架構。若要更新樹系架構，您必須有架構主機的存取權。在整個樹系中只能有一個架構主機。

若要更正此錯誤

  1. 確認錯誤訊息中指出的目錄伺服器已在連線中，並且可以讓貴組織內的 Exchange 伺服器存取。

  2. 如果已解除此目錄伺服器，您必須將架構主機角色指派給其他網域控制站。

若需將架構操作主機角色從某個網域控制站移轉至另一個網域控制站的相關資訊，請參閱下列微軟知識庫文件：

  • 若為 Windows Server™ 2003，請參閱 324801＜HOW TO：在 Windows Server 2003 中檢視及轉移 FSMO 角色＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)。

  • 若為 Microsoft Windows® 2000 Server，請參閱 255690＜HOW TO：在圖形化使用者介面檢視傳送 FSMO 角色＞ (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690)。


安全通訊端層憑證即將過期
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2007-01-09

Microsoft® Exchange Server Analyzer 工具會查詢 Exchange 伺服器系統中的 Server Certificate 物件，以擷取 X509 憑證的各種內容。對於每個找到的安全通訊端層 (SSL) 憑證，Exchange Server Analyzer 都會評估 ExpirationDate 屬性，以識別憑證的到期日。

附註：
伺服器在執行 SSL 通訊協定時，必須要有伺服器憑證。伺服器憑證會包含網站名稱。瀏覽器會驗證網站名稱是否就是您輸入的名稱。例如，對於 https://www.example.com 網站，其憑證名稱應該是 www.example.com。

Exchange Server Analyzer 會在 ExpirationDate 落在 3 與 20 天之間時顯示警告，並在 ExpirationDate 少於 3 天時顯示錯誤。

如果憑證逾期，則在此訊息中指定之 URL 的 SSL 連線會失敗。同樣地，使用該 URL 的 RPC over HTTP 與 Exchange Server ActiveSync 連線也會失敗。

若要解決此憑證到期警告或錯誤，請更新此訊息中指定的憑證。更新憑證所需的步驟視使用的憑證授權單位而定。

詳細資訊

若需有關 SSL 以及搭配 Exchange Server 中的虛擬伺服器使用憑證的詳細資訊，請參閱下列 Exchange 資源：

  • 若需在 Exchange Server 2003 中讓虛擬伺服器與憑證搭配使用的相關資訊，請參閱微軟知識庫文件 - 823024＜如何在 Exchange Server 2003 中讓虛擬伺服器與憑證搭配使用＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823024)。

  • 若需如何使用 SSL 及如何取得並安裝伺服器憑證的相關資訊，請參閱《Exchange Server 2003 用戶端存取手冊》(http://go.microsoft.com/fwlink/?LinkId=47568) 中的＜設定 Exchange Server 2003 進行用戶端存取＞(英文)。

  • 若需有關如何使用 SSL 以及如何取得並安裝 Exchange Server 2007 伺服器憑證的詳細資訊，請參閱＜如何設定 Outlook Anywhere 的 SSL＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80875)。


遺失伺服器容器
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2006-08-21

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以取得目前系統管理群組中找到之每個 Routing Group 物件的 distingushedName 屬性值。

然後，Exchange Server Analyzer 會查詢 Active Directory 以判定目前系統管理群組是否具有 [伺服器] 容器。

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • 目前系統管理群組包含一或多個路由群組。

  • [伺服器] 容器不存在。

此錯誤指出系統管理群組中未安裝任何伺服器，且系統可能不會在 Exchange 組織的伺服器之間以動態方式傳播路由資訊。

若要解決此問題，請確定 Exchange 組織正處於原生模式，並遵循下列步驟。

解析步驟

  1. 建立新的系統管理群組。

  2. 於新的系統管理群組中建立新的 [路由群組] 容器。

  3. 從舊的 [路由群組] 容器拖曳現有的路由群組到新容器。

  4. 重新啟動所有 Exchange 服務。

若需此錯誤的詳細資訊，請參閱 Microsoft 知識庫文章 318491＜XADM：路由資訊未在 Exchange 2000 組織之間傳播＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=318491)。


通用類別目錄伺服器缺少服務主要名稱
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2006-05-12

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務通用類別目錄伺服器，針對 exchangeAB 及 HOST 資源的 servicePrincipalName 屬性，尋找其完整網域名稱 (FQDN) 及 NetBIOS 名稱的傳回值。

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • exchangeAB 資源的 servicePrincipalName 屬性遺漏其中一個預期的 FQDN 或 NetBIOS 名稱值。

  • HOST Exchange 資源的 servicePrincipalName 屬性遺漏其中一個預期的 FQDN 或 NetBIOS 名稱值。

服務主要名稱 (SPN) 是唯一的名稱，它能識別服務的執行個體，並且與用來執行服務執行個體的登入帳戶相關聯。若沒有正確地設定 SPN，Exchange 服務便無法使用 Kerberos 驗證。

  • 如果執行 Microsoft Outlook® 2003 (或更新版本) 的用戶端有 Active Directory 驗證問題，這些問題可能表示 exchangeAB 資源缺少有效的 SPN。

  • 伺服器之間的驗證失敗可能表示 HOST 資源缺少有效的 SPN。

若要解決此問題，請遵循下列步驟，為 servicePrincipalName 屬性新增遺漏的值。

使用 SETSPN.exe 工具，新增有遺漏值的 SPN。

  1. 安裝 Setspn.exe 工具。若要取得 Setspn.exe 工具，請參閱＜Windows 2000 Resource Kit Tool :Setspn.exe＞(http://go.microsoft.com/fwlink/?LinkId=28103)。

    Windows Server 2003 版的 Setspn.exe 命令列工具可在 Windows Server 2003 CD 所包含的 Windows Server 2003 Support Tools 中取得。若要安裝 Server 2003 Support Tools，請在 Support/Tools 資料夾中連按兩下 Suptools.msi 檔案。

  2. 請遵循 SETSPN.EXE Setspn_d.txt 檔案中的引導，將遺漏的值新增至 Exchange 伺服器的 Active Directory 物件。下列範例示範如何為虛擬 SMTP 伺服器 SPN 新增 FQDN 值：

    • 啟動命令提示字元，然後切換至 Setspn.exe 的安裝目錄。

    • 在命令提示字元下，輸入下列命令：

      setspn.exe-a SMTPSVC/ mail.yourdomain.com YOURSERVERNAME

      附註：
      將 mail.yourdomain.com 取代為 SMTP 虛擬伺服器 FQDN，並將 YOURSERVERNAME 取代為 Exchange 伺服器的名稱。
      然後按 Enter 鍵。


此系統管理群組的站台資料夾伺服器公用資料夾儲存區不存在於此系統管理群組內
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每一個公用資料夾儲存區的 distinguishedName 值。此外，Exchange Server Analyzer 也會查詢 Active Directory，以判定每一個系統管理群組的 siteFolderServer 及 msExchAdminGroupMode 屬性值。siteFolderServer 屬性代表負責主控站台資料夾的伺服器名稱 (通常是站台或系統管理群組中的第一部伺服器)。msExchAdminGroupMode 屬性代表系統管理群組的模式，包括如下：

  • 純 Exchange Server 5.5

  • Exchange Server 5.5、Exchange 2000 Server 及 Exchange Server 2003 伺服器混合模式

  • Exchange 2000 Server 或 Exchange Server 2003 原生模式

如果 Exchange Server Analyzer 判定系統管理群組不是處於原生模式，而且 siteFolderServer 的值不符合任何公用資料夾儲存區的 distinguishedName 值，siteFolderServer 屬性值也沒有包含 DEL: 這個字串，就會顯示一則警告。

在預設的情況下，「站台資料夾伺服器」是在系統管理群組中安裝的第一部伺服器。在此伺服器上的公用資料夾儲存區，就是空閒/忙碌資訊資料夾，以及系統管理群組的離線通訊錄資料夾的預設位置。如果移除「站台資料夾伺服器」或將其除役，但沒有將這些資料夾複寫到另一部伺服器及指定該伺服器作為離線通訊錄伺服器，則 Outlook 使用者會發現離線通訊錄及空閒/忙碌資料有問題。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要更正此警告

  1. 開啟一個 Active Directory 編輯程式，如 [ADSI 編輯器]。

  2. 展開下列項目來尋找要指定作為「站台資料夾伺服器」的公用資料夾資訊儲存庫：CN=<PublicFolderStoreName>, CN=<StorageGroupName>, CN=InformationStore, CN=<ServerName>, CN=Servers, CN=<AdministrativeGroupName> ,CN=Administrative Groups, CN=<OrganizationName>, CN=Microsoft Exchange, CN=Services, CN=Configuration,DC=<DomainName>,DC=com。

  3. 在右窗格中的 CN=<PublicFolderStoreName> 上按一下滑鼠右鍵，並選取 [內容]。

  4. 在 [Attributes] 欄位中，向下捲動並選取 distinguishedName 屬性。

  5. 按一下 [編輯] 按鈕，然後將整個屬性複製到剪貼簿。

  6. 展開 [組態] 容器，接著展開 CN=Administrative Groups,CN=<OrganizationName>,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=<DomainName>,DC=com。

  7. 在要修改的系統管理群組上按一下滑鼠右鍵，然後選取 [Properties]。

  8. 在 [Attributes] 欄位中，向下捲動並選取 siteFolderServer 屬性。

  9. 按一下 [Edit] 按鈕，然後將 distinguishedName 屬性的值貼到 [Value] 欄位。

  10. 再次檢查 [Value] 欄位的內容以確定有正確執行貼上，然後按一下 [OK] 以儲存變更。

  11. 按一下 [確定] 以關閉系統管理群組內容對話方塊。

  12. 結束 [ADSI 編輯器]，然後重新啟動站台內所有 Exchange Server 電腦上的 Microsoft Exchange Server Information Store 服務，以使變更生效。

若需有關重新建立系統資料夾以及重設「站台資料夾伺服器」的詳細資訊，請參閱下列微軟知識庫文件：

  • 275171＜如何在 Exchange 2000 Server 上重設系統資料夾＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=275171)

  • 284200＜Schedule+ 空閒/忙碌資訊系統資料夾遺失＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=284200)

若需有關使用 LDP 工具的詳細資訊，請參閱微軟知識庫文件 - 260745＜XADM:Using the LDP Utility to Modify Active Directory Object Attributes＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

若需有關使用 ADSI 編輯器的詳細資訊，請參閱主題＜Adsiedit.msc：ADSI 編輯器＞(位在 Windows Server 2003 說明中)。


偵測不到離線通訊錄所使用的「站台資料夾伺服器」公用資料夾儲存區
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2007-02-01

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定所有 Exchange 公用資料夾儲存區 (具有 objectClass=msExchPublicMDB 之 objectClass 的儲存區) 的 siteFolderServer 屬性值。siteFolderServer 屬性代表離線通訊錄伺服器使用的公用資料夾儲存區。

如果 Exchange Server Analyzer 判定未列出伺服器、所列出的伺服器關機，或所列出的伺服器不存在，則會顯示一則警告。如果 siteFolderServer 屬性包含 DEL: 字串，Exchange Server Analyzer 就會顯示一則錯誤訊息。

在預設的情況下，Exchange Server 2003 會在站台資料夾伺服器 (在系統管理群組中安裝的第一部伺服器) 上，產生離線通訊錄檔案。如果您指定別的伺服器作為離線通訊錄伺服器，則這個屬性中列出的公用資料夾儲存區，將會成為新的離線通訊錄伺服器上的儲存區，而不是位在系統管理群組中實際「站台資料夾伺服器」上的儲存區。

當 Exchange Server 2003 產生離線通訊錄檔案時，它會將檔案附加在郵件訊息中，並且將郵件放在特殊的公用資料夾內。Microsoft Office Outlook® 2003 會從資料夾擷取郵件並下載附件檔。

在 Exchange Server 2003 中，離線通訊錄郵件儲存在「離線通訊錄」資料夾的子資料夾中，而此資料夾是預設「公用資料夾」樹狀目錄的其中一個系統資料夾。這個資料夾內會包含子資料夾，對應到您的拓撲內的每一個系統管理群組或站台。在預設的情況下，特定系統管理群組資料夾的內容複本，會放在系統管理群組中安裝的第一部伺服器 (稱為「站台資料夾伺服器」) 上。

如果您的 Exchange 組織是 Exchange Server 2007，沒有向下層級 (Outlook 2003 或更舊版本) 用戶端，您可以安全地捨棄此警告或錯誤。如果您的 Exchange Server 2007 組織正在主控執行 Outlook 2003 或更舊版本的用戶端，請遵循以下程序，啟用離線通訊錄檔案的公用資料夾發佈。公用資料夾發佈是一種發佈方法，執行 Outlook 2003 或更舊版本且離線工作或透過撥號連線工作的用戶端會使用此方法存取 OAB。

對 Exchange Server 2003 更正此警告

  1. 如果您知道該伺服器已存在，請在 [Exchange 系統管理員] 的 [伺服器] 下，展開儲存群組，然後按一下 [公用資料夾儲存區]。請檢查右窗格以確定儲存區正在執行。

  2. 若要指定新的離線通訊錄伺服器，請在 [收件者] 之下，按一下 [離線通訊清單]。然後在右窗格中按一下 [預設離線通訊清單] (或產生此訊息的任何其他離線通訊清單)。

    如果不要使用離線通訊錄，請在 [預設值] [離線通訊錄] 上按一下滑鼠右鍵， 然後按一下 [刪除]。不然的話，使用本程序的其餘動作設定排程。

  3. 在 [預設離線通訊清單] 上按一下滑鼠右鍵，再按一下 [內容]。

  4. 在 [一般] 標籤中的 [離線通訊錄伺服器] 之下，按一下 [瀏覽] 選取一部伺服器。

對 Exchange Server 2007 更正此警告

  1. 開啟 [Exchange 管理主控台]。

  2. 依序展開 [Microsoft Exchange]、[組織組態]，然後選取 [信箱]。

  3. 在結果窗格中，按一下 [離線通訊錄] 索引標籤。

  4. 在 [離線通訊錄] 索引標籤上，選取 [預設離線通訊錄]。

    1. 若要啟用離線通訊錄的公用資料夾發佈，請從 [發佈] 索引標籤選取 [啟用公用資料夾發佈]。

    2. 按一下 [確定]，儲存變更。

  5. 若要指定新的離線通訊錄伺服器，請從執行窗格按一下 [移動]，以啟動 [移動離線通訊錄] 精靈。此精靈可讓您移至不同的伺服器產生 OAB。它也會將現有的 OAB 檔案複製至指定的伺服器。

使用 Exchange 管理命令介面，啟用離線通訊錄檔案的公用資料夾發佈。

  • 執行下列命令：

    複製程式碼
    Set-OfflineAddressBook -Identity <OAB> -PublicFolderDistributionEnabled $true

    其中：<OAB> 是 OAB 的辨別名稱 (DN)、網域\帳戶名稱或 GUID。

    例如，若要啟用預設離線通訊錄的公用資料夾發佈，請輸入：
複製程式碼
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -PublicFolderDistributionEnabled $true

使用 Exchange 管理命令介面來設定將主控離線通訊錄產生的伺服器

  • 執行下列命令：

    複製程式碼
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    其中：<OAB> 是 OAB 的辨別名稱 (DN)、網域\帳戶名稱或 GUID，而 <Server> 則指定執行所選作業的 Exchange 伺服器。

    例如，若要移至 SERVER01. 產生 OAB，請輸入：
複製程式碼
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

若需有關在 Exchange Server 2003 使用離線通訊錄的詳細資訊，請參閱《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595)中的＜設定 Exchange Server 2003 離線通訊錄＞(英文)。

若需有關在 Exchange Server 2007 使用離線通訊錄的詳細資訊，請參閱＜組織組態 > 信箱 > 離線通訊錄＞(英文) (http:// go.microsoft.com/fwlink/?LinkId =79247)。


SiteName 已硬式編碼
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Exchange 伺服器上是否有 SiteName 登錄值。

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Netlogon\Parameters\SiteName

如果 Exchange Server Analyzer 發現 SiteName 登錄值存在，就會顯示警告。

此警告表示已在執行 Microsoft Windows® 作業系統的此電腦上，對 Active Directory® 目錄服務站台成員進行硬式編碼。不建議在 Exchange Server 中使用此組態。

當您對 Windows 站台進行硬式編碼時，可能會造成 Microsoft Exchange System Attendant 服務失敗與一般 Exchange Server 失敗。您應考慮移除 SiteName 登錄值。如果移除 SiteName 登錄值，Windows 將會自動加入適當的 Active Directory 站台。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定您瞭解如何在發生問題時還原登錄。若需如何還原登錄的相關資訊，請檢視 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
移除 SiteName 登錄值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\Netlogon\Parameters

  3. 在右窗格中，尋找並刪除 SiteName 登錄值。

  4. 關閉登錄編輯程式，然後重新啟動伺服器，使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 SiteName 登錄值的詳細資訊，請參閱知識庫文件 - 322834＜XADM：事件 1005，系統服務員未啟動＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322834)。


Exchange 組織中有 900 個以上的系統管理群組
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2006-04-21

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 Exchange 組織中存在的系統管理群組數目。如果 Exchange Server Analyzer 發現有 900 個以上的系統管理群組，就會顯示一則警告。

建議任何單一 Exchange 物件類型最多都只有 900 個執行個體。這是因為 Active Directory 對任意的給定要求傳回的最大分頁大小，預設為 1000。這表示如果針對物件提出了輕量型目錄存取通訊協定 (LDAP) 要求，且 Active Directory 中存在超過 1,000 個該物件的執行個體，則因為已超過分頁的大小上限，所以不會傳回任何結果。

在 Exchange 的情況中，會有各式各樣的處理程序要求產生特定物件類型的實體。例如，[Exchange 系統管理員] 會對 Active Directory 提出 LDAP 要求，以建立 Exchange 組織內所有系統管理群組的清單檢視。如果有 1,000 個以上的系統管理群組，則 Active Directory 不會傳回任何結果。此時，[Exchange 系統管理員] 中會顯示錯誤，而不會顯示任何系統管理群組。

雖然可以增加 Active Directory 的最大分頁大小值，但 Exchange 不建議或支援這個動作。增加最大分頁大小，會使 Exchange 環境出現異常行為及失敗現象。

雖然建議將 Exchange 中的任何單一物件類型的執行個體數目保持在 900 以下，但最多可支援 1,000 個物件類型。

若要解決此問題，請考慮合併系統管理群組。

若需有關合併 Exchange 站台及系統管理群組的詳細資訊，請參閱：

  • 《Microsoft 部署 Exchange Server 2003 的全球站台合併解決方案》(英文) (http://go.microsoft.com/fwlink/?LinkId=33531)


您的 Exchange 組織中有 900 個以上的 Exchange 伺服器
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2006-03-30

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務 ，以取得具有 msExchExchangeServer 的 objectCategory 之目錄中的物件計數。該計數代表在 Active Directory 中找到的 Exchange Server 電腦數量。如果 Exchange Server Analyzer 發現 Exchange Server 電腦有 900 台以上，就會顯示警告。

建議您對於任何一種 Exchange 物件類型，最多只使用 900 個執行個體。這是因為 Active Directory 對任意的給定要求傳回的最大分頁大小，預設為 1000。這表示如果針對物件提出了輕量型目錄存取通訊協定 (LDAP) 要求，且 Active Directory 中存在超過 1,000 個該物件的執行個體，則因為已超過分頁的大小上限，所以不會傳回任何結果。

在 Exchange Server 的情況中，許多處理要求都會要求特定物件類型的個體。例如，「Exchange 系統管理員」會對 Active Directory 提出 LDAP 要求，對 Exchange 組織中的所有 Exchange 伺服器建立清單檢視。如果有 1,000 台以上的 Exchange 伺服器，Active Directory 便不會傳回任何結果。這樣一來，「Exchange 系統管理員」中會顯示錯誤，而且不會顯示任何 Exchange Server 電腦。

雖然可以增加 Active Directory 的最大分頁大小值，但 Exchange 不建議或支援這個動作。若提高最大分頁大小，Exchange 環境會出現異常行為及失敗現象。

雖然建議對 Exchange Server 中的任何一個物件類型維持在 900 或低於 900，但最多仍可支援 1000 個物件類型。

若要更正此警告

  1. 請考慮合併貴組織內的 Exchange 伺服器。

  2. 檢查 Active Directory 以找出孤立的 Exchange Server 電腦，並將它們從 Active Directory 中移除。

若需有關合併 Exchange 伺服器的詳細資訊，請參閱《使用 Exchange Server 2003 合併伺服器》(英文) (http://go.microsoft.com/fwlink/?linkid=47586)。


在組織層級委派的系統管理員超過 10 個
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2006-12-03

Microsoft® Exchange Server Analyzer 工具查詢 Active Directory® 目錄服務，以判定具有「Exchange 系統管理員」或「Exchange 系統高權限管理員」權限的使用者人數。Exchange Server Analyzer 會計算列在 msExchAdmins 屬性中的項目數，此屬性代表一個連結，可連到組織內所有具有適當權限的 Exchange 系統管理員。如果 Exchange Server Analyzer 發現有超過 10 位使用者具有「Exchange 系統管理員」及 (或)「Exchange 系統高權限管理員」權限，就會顯示一則警告。

msExchAdmins 是 Exchange 根目錄組織容器的多重值屬性。它包含了一份安全性識別碼 (SID) 清單，代表委派有 Exchange 權限的使用者帳戶。

最佳的作法就是限制具有 Exchange 組織寫入權限的使用者人數。您可考慮減少組織層級的「Exchange 系統管理員」及「Exchange 系統高權限管理員」數目。針對郵件基礎結構的需求來檢閱系統管理角色，您會發現您可將大多數這些組織層級的使用者轉換為「Exchange 系統檢視管理員」，而在「系統管理群組」層級委派給他們「Exchange 系統管理員」角色。

若要更正此警告

  1. 考慮減少具有「Exchange 系統管理員」及 (或)「Exchange 系統高權限管理員」權限的使用者人數。

  2. 考慮在您的組織內執行 Exchange Server 權限稽核，以確保有適當的權限。

若需有關在 Exchange 中規劃及設定權限的詳細資訊，請參閱：

  • 《在 Exchange 2003 中使用 Active Directory 權限》(http://go.microsoft.com/fwlink/?LinkId=47592)。

  • 《Microsoft Exchange Server 2007》＜操作＞中的＜設定權限＞(英文) (http://go.microsoft.com/fwlink/?LinkId=78432)。

  • 《Microsoft Exchange Server 2007》中，＜規劃與架構＞之＜規劃 Active Directory＞中的＜權限考量＞(英文) (http://go.microsoft.com/fwlink/?LinkId=78433)。

若需有關 Exchange Server 2003 中系統管理角色的詳細資訊，請參閱微軟知識庫文件 - 823018＜Exchange 2003 中 Exchange 系統管理角色權限的概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823018)。

若需有關 Exchange 2000 Server 中系統管理角色的詳細資訊，請參閱知識庫文件 - 289811＜XGEN：Exchange 2000 角色權限＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=289811)。


未將此連線協定設為在找不到相符項目時便建立已停用的帳戶
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個連線協定物件的 msExchServer1AlwaysCreateAs 屬性值。如果 Exchange Server Analyzer 判定 msExchServer1AlwaysCreateAs 屬性未設定成 1，則會顯示警告。

msExchServer1AlwaysCreateAs 屬性會判定 X.500 物件如何與 Active Directory 同步處理。值為 0 表示已將連線協定設為建立 Microsoft Windows® 連絡人。此屬性的值為 1 表示已將連線協定設為在 Active Directory 中建立已停用的 Windows 使用者帳戶。值為 2 表示已將連線協定設為建立新的 Windows 使用者帳戶。

Exchange Server Analyzer 會發出警告，因為在 Exchange Server 5.5 必須與 Active Directory 共存，且計劃要完整遷移到 Exchange Server 2003 的情況下，讓 Active Directory 連接器 (ADC) 建立已停用的 Windows 使用者帳戶是很重要的。這些已停用的 Windows 使用者帳戶是「擁有信箱功能」的，這表示它們是邏輯上連接到位在 Exchange Server 5.5 電腦上的信箱。建立已停用的 Windows 使用者帳戶對於代表此已停用的 Windows 帳戶來說是必要的，這樣才能存取公用資料夾及 Active Directory 中的其他安全物件。

在 ADC 使用者介面中，有三個選項可在無法於 Active Directory 中找到與 Exchange Server 5.5 的信箱相符的物件時建立新物件。這些是列在連線協定的內容中的 [進階] 索引標籤上，如下所示：

  • 建立 Windows 連絡人 不建議使用此選項，因為 [連絡人] 物件沒有安全性內容。

  • 建立新的 Windows 使用者帳戶 不建議使用此選項，因為所建立的新帳戶會有新的 SID，而由於 SID 不同，因此在遷移期間此新帳戶不會有 Microsoft Windows NT® Server 4.0 使用者帳戶的 SID 歷程記錄。

  • 建立已停用的 Windows 使用者帳戶 建議使用此選項，因為它允許 Windows NT Server 4.0 使用者在完成完整遷移之前同時存在 (對資源具有正確的存取權)。

若要更正此警告

  1. 設定「Active Directory 收件者連線協定」以建立擁有信箱功能的已停用 Windows 使用者帳戶。

  2. 使用 Active Directory 遷移工具，此工具可將 Windows NT Server 4.0 使用者帳戶遷移到 Active Directory，並建立已啟用的 Windows 帳戶。這些已啟用的 Windows 帳戶與 ADC 所建立之已停用 Windows 帳戶的 SID 相同。

  3. 使用 Active Directory 清理精靈 (ADClean)，此精靈可將 Active Directory 遷移工具所建立的帳戶合併到 ADC 所建立的帳戶中。

若需 Active Directory 連接器收件者連線協定的相關資訊，請參閱下列微軟知識庫文件：

  • 823601＜Active Directory 連接器需求及對整個組織的用意＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180＜混合系統管理群組的 Active Directory 連接器需求＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)

  • 296260＜XGEN:如何設定 Exchange 5.5 使用者的雙向收件者連線協定＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=296260)

  • 若需有關 Active Directory 清理精靈的詳細資訊，請參閱下列知識庫文件：

  • 270652＜使用 Active Directory 帳戶清理精靈的可能性＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270652)

  • 若需有關 Active Directory 遷移工具的詳細資訊，請參閱下列知識庫文件：

  • 260871＜如何設定 Windows NT 4.0 到 Windows 2000 遷移的 ADMT＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260871)


這是來自 Exchange 的單向連線協定
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個連線協定物件的 msExchSynchronizationDirection 屬性值。msExchSynchronizationDirection 屬性代表同步處理目錄的方向。如果此屬性是設定為 2，則會顯示警告訊息。

msExchSynchronizationDirection 屬性可含有值 0 或 2。如果此屬性設為 0，表示它是雙向連線協定。如果此屬性設為 2，表示它是來自 Exchange Server 電腦的單向連線協定。

最佳的作法是建議您使用雙向連線協定。混合模式的 Exchange 環境 (Exchange Server 5.5 與 Exchange 2000 Server 和/或 Exchange Server 2003 共存的環境) 需要雙向連線協定。

若要更正此警告

  1. 移除現有的單向連線協定。

  2. 建立雙向連線協定加以取代。

若需有關 Active Directory 連接器 (ADC) 連線協定的詳細資訊，請參閱下列微軟知識庫文件：

  • 823601＜Active Directory 連接器需求及對整個組織的用意＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180＜混合系統管理群組的 Active Directory 連接器連線協定需求＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)

  • 317721＜XADM：當您將 ADC 連線協定從單向連線協定變更為雙向連線協定時，Exchange Server 5.5 信箱擁有者權限會被移除＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721)


這是來自 Windows 的單向連線協定
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個連線協定物件的 msExchSynchronizationDirection 屬性值。msExchSynchronizationDirection 屬性代表同步處理目錄的方向。如果此屬性是設定為 1，就會顯示一則警告。

msExchSynchronizationDirection 屬性的值可以是 0、1 或 2。屬性值 0 表示雙向連線協定，屬性值 1 表示來自 Active Directory 的單向連線，屬性值 2 表示來自 Exchange Server 電腦的單向連線協定。

建議最佳的作法是使用雙向連線協定。混合模式的 Exchange 環境 (Exchange Server 5.5 與 Exchange 2000 Server 和/或 Exchange Server 2003 共存的環境) 需要雙向連線協定。

若要更正此警告

  1. 移除現有的單向連線協定。

  2. 建立雙向連線協定加以取代。

若需有關 Active Directory 連接器 (ADC) 連線協定的詳細資訊，請參閱下列微軟知識庫文件：

  • 823601＜Active Directory 連接器需求及對整個組織的用意＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180＜混合系統管理群組的 Active Directory 連接器連線協定需求＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)

  • 317721＜XADM：當您將 ADC 連線協定從單向連線協定變更為雙向連線協定時，Exchange Server 5.5 信箱擁有者權限會被移除＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721)


Exchange 及 Active Directory 之間的時間戳記比較相差 5 分鐘以上
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_UTCTime Microsoft Windows® Management Instrumentation (WMI) 類別，以判定每個 Exchange 伺服器上的日期及時間。Exchange Server Analyzer 還會擷取預設網域控制站上目前的日期與時間。如果 Exchange Server Analyzer 判定兩個伺服器間的差距在 5 分鐘以上，就會顯示錯誤。

Microsoft Windows 2000 Server 及 Windows Server™ 2003 會使用 Windows Time 服務來同步處理在 Windows 型網路上執行之電腦的日期及時間。Windows 2000 Server 及 Windows Server 2003 上必須要有同步的時間，因為預設的驗證通訊協定會使用工作站的時間做為驗證票證產生程序的一部分。MIT Kerberos 版本 5 是預設的驗證通訊協定。

針對 Active Directory® 目錄服務網域中的所有 Windows 伺服器，Windows Time 服務會使用可在網域控制站上使用的 Windows Time 服務，自動設定本身。Windows Time 服務將其網域中的某個網域控制站設定為可靠的時間來源，並依據此來源來定期同步處理它自身。

要更正此錯誤，請使用目錄伺服器來同步處理 Exchange 伺服器上的時鐘。

在 Active Directory 網域中同步處理伺服器上的時鐘

  1. 開啟命令提示字元。

  2. 輸入 w32tm /resync，然後按 ENTER。

如果此錯誤持續發生，或者組織內有很多電腦都產生此錯誤，請重新檢視如何在 Active Directory 樹系中部署及設定 Windows Time 服務。若需有關 Windows Time 服務的詳細資訊，請參閱＜Windows Time 服務技術參考資料＞(英文) (http://go.microsoft.com/fwlink/?LinkId=40648)。

當 Exchange 前端伺服器無法與 Active Directory 時間同步時，客戶可能會在嘗試連線至 Microsoft Office Outlook® Web Access 時收到「HTTP 500 內部伺服器」錯誤。若需有關此情況的詳細資訊，請參閱微軟知識庫文件 - 841546＜在 Exchange 2000 Outlook Web Access 中導致「HTTP 500 內部伺服器錯誤」錯誤訊息的已知問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841546)。


Active Directory 連接器伺服器與 Active Directory 之間的時間戳記差距超過 5 分鐘
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_UTCTime Microsoft Windows® Management Instrumentation (WMI) 類別，以判定每台 Active Directory 連接器 (ADC) 伺服器上的日期與時間。Exchange Server Analyzer 還會擷取預設網域控制站上目前的日期與時間。如果 Exchange Server Analyzer 判定兩個伺服器間的差距在 5 分鐘以上，就會顯示錯誤。

Microsoft Windows 2000 Server 及 Windows Server™ 2003 會使用 Windows Time 服務來同步處理在 Windows 型網路上執行之電腦的日期及時間。Windows 2000 Server 及 Windows Server 2003 上必須要有同步的時間，因為預設的驗證通訊協定會使用工作站的時間做為驗證票證產生程序的一部分。MIT Kerberos 版本 5 是預設的驗證通訊協定。

在 Active Directory® 目錄服務網域中的所有 Windows 伺服器上，Windows Time 服務都會使用網域控制站上可用的 Windows Time 服務，進行自行設定。Windows Time 服務會將網域中的網域控制站設定為可靠的時間來源，然後依此來源定期進行本身的同步化。

若要更正此錯誤，請使用目錄伺服器來同步處理 ADC 伺服器上的時鐘。

若要在 Windows 2000 Server 或 Windows Server 2003 網域中同步處理伺服器上的時鐘

  1. 開啟命令提示字元。

  2. 輸入 w32tm /resync，然後按 ENTER。

若仍發生錯誤，或組織中有許多電腦產生這項錯誤，請檢視 Windows Time 服務在 Active Directory 樹系中部署與設定的情形。若需有關 Windows Time 服務的詳細資訊，請參閱＜Windows Time 服務技術參考資料＞(英文) (http://go.microsoft.com/fwlink/?LinkId=40648)。


所執行的 Windows Server 2003 不是確定發行的組建
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Exchange 組織中 Active Directory 連接器 (ADC) 伺服器的 Version 機碼值。Exchange Server Analyzer 也會檢查下列登錄項目，以判定在 ADC 伺服器上執行的 Windows 版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

如果 Exchange Server Analyzer 發現 CurrentVersion 的第二個執行個體值是 5.2，且 Version 的值不等於 5.2.3790，就會顯示一則錯誤。

CurrentVersion 值為 5.2，表示電腦是執行 Windows Server 2003 作業系統。所有 Windows Server 2003 作業系統之發行版本的 Version 值都是 5.2.3790。任何其他的 Version 機碼值都表示正在使用 Windows Server 2003 的發行前版本。

除非您有參與 Technology Adoption Program (TAP) 或類似的 Microsoft 贊助計劃，否則 Microsoft 不支援或建議在生產環境中使用發行前版本軟體。

若要更正此錯誤

  1. 將所有 Exchange 基礎結構伺服器 (包括網域控制站、通用類別目錄伺服器、ADC 伺服器及 Exchange Server 電腦等) 升級為最新版的軟體。

  2. 若有升級選項可用，或有升級選項支援，請重建作業系統，並且還原 Exchange Server 的設定和資料。

將所有 Exchange 基礎結構伺服器 (包括網域控制站、通用類別目錄伺服器、ADC 伺服器及 Exchange Server 電腦等) 升級為最新版的軟體。

若需有關 Windows Server 2003 軟體更新的詳細資訊，請參閱 Windows Server 2003 軟體更新網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33760)。


Windows Server 2003 正在執行發行前版本的軟體
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會檢查 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 ServicePackMajorVersion 機碼值。Exchange Server Analyzer 也會檢查下列登錄項目，以判定在目的電腦上執行的 Windows 版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

如果第二個 CurrentVersion 執行個體的值是 5.2，而且 ServicePackMajorVersion 的值大於 1，Exchange Server Analyzer 就會顯示一則警告訊息。

CurrentVersion 值為 5.2 表示電腦是執行 Microsoft Windows Server™ 2003 作業系統。ServicePackMajorVersion 大於 1 表示已安裝 Service Pack 1 (SP1) 以後的 Service Pack。因為 SP1 是唯一發行的 Windows Server 2003 Service Pack，所以已安裝的任何 Windows Server 2003 Service Pack 2 或更新版本一定是發行前版本的軟體。

除非您有參與 Technology Adoption Program (TAP) 或類似的 Microsoft 贊助計劃，否則不建議在生產環境中執行發行前版本軟體。

若要更正此警告

  1. 將已安裝的任何發行前版本軟體解除安裝。

  2. 若有解除安裝選項可用，請重建作業系統，並且還原 Exchange Server 的設定和資料。

若需有關 Windows Server 2003 軟體更新的詳細資訊，請參閱 Windows Server 2003 軟體更新網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33760)。


Windows 2000 Server 未執行 Service Pack 4
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會檢查 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 ServicePackMajorVersion 機碼值。Exchange Server Analyzer 也會檢查下列登錄項目，來判定目標電腦上執行的 Windows 版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

如果 Exchange Server Analyzer 判定目標電腦正在執行 Windows 2000 Server 作業系統，但並未執行 Service Pack 4 for Windows 2000 Server，就會顯示一則警告。

建議的最佳作法是為 Exchange 部署中的所有軟體安裝最新的 Service Pack。

若要更正此警告

  1. 將執行 Windows 2000 Server 作業系統的所有網域控制站及通用類別目錄伺服器更新為 Service Pack 4，並且從 Windows Update 安裝最新的 Hotfix 及更新。

  2. 將所有 Exchange Server 電腦更新為最新的 Service Pack 和更新彙總套件。

若需有關取得及安裝 Windows 2000 Server 作業系統 Service Pack 的詳細資訊，請參閱 "Windows 2000 Service Packs" 網站 (英文) (http://go.microsoft.com/fwlink/?linkid=18353)。

若需有關取得及安裝 Exchange Server Service Pack 及彙總套件的詳細資訊，請參閱 "Microsoft Exchange Server" 網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=21573)。


所執行的 Windows 2000 Server 不是確定發行的組建
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2005-11-17

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_OperatingSystem MicrosoftWindows® Management Instrumentation (WMI) 類別，以判定 Version 機碼值。

Exchange Server Analyzer 也會檢查下列登錄項目，以判定電腦上執行的 Windows 版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 值為 5.0 表示電腦是執行 Microsoft Windows 2000 Server 作業系統。所有 Windows 2000 Server 作業系統發行版本的 Version 值皆為 5.0.2195。其他任何 Version 機碼值表示使用的是 Windows 2000 Server 的發行前版本。

如果 Exchange Server Analyzer 發現第二個 CurrentVersion 執行個體的值為 5.0，而且 Version 的值不等於 5.0.2195，就會顯示一則錯誤。

除非您有參與 Technology Adoption Program (TAP) 或類似的 Microsoft 贊助計劃，否則 Microsoft 不支援或建議在生產環境中使用發行前版本軟體。

若要更正此錯誤

  1. 將所有 Exchange 基礎結構伺服器 (包括網域控制站、通用類別目錄伺服器、Active Directory 連接器 (ADC) 伺服器及 Exchange Server 電腦) 升級為最新版的軟體。

  2. 若有升級選項可用，或有升級選項支援，請重建作業系統，並且還原 Exchange Server 的設定和資料。

若需有關取得及安裝 Windows 2000 Service Pack 4 的詳細資訊，請參閱 Windows 2000 Service Pack 4 網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33241)。


X.400 地址具有無效的結尾字元
Microsoft Exchange Server Analyzer - 文章 > Active Directory >

主題上次修改日期： 2006-12-03

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定收件者原則上 gatewayProxy 的值，並確認 X.400 地址以分號結尾。

收件者原則中 X.400 地址的正確格式為以分號結尾。如果沒有分號，則會中斷路由傳送到 X.400 地址的郵件。

若要更正此問題，您必須使用 [Active Directory Service Interfaces (ADSI) 編輯器] 或 LDP 工具，在地址的結尾加上分號。

注意：
使用 ADSI 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或 Exchange Server 2007，或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
若要更正此錯誤

  1. 開啟一個 Active Directory 編輯程式，如 [ADSI 編輯器]。

  2. 依序展開 [組態 [DomainName]]、[CN=Configuration]、[DC=DomainName]、[DC=DomainSuffix]。

  3. 依序展開 CN=Services 及 CN=Microsoft Exchange。

  4. 依序展開 [CN=OrganizationName]、[CN=Administrative Groups] 及 [CN=Recipient Policies]。

  5. 在 [CN=PolicyName] 上按一下滑鼠右鍵，然後選取 [內容]。

  6. 向下捲動以尋找 [gatewayProxy] 並選取它，再按 [編輯]。

  7. 在 [值] 欄位中，輸入正確的 gatewayProxy。

  8. 關閉 Active Directory 編輯器，並重新啟動 Exchange Server 電腦，讓變更生效。


資料庫復原
Microsoft Exchange Server Analyzer - 文章 >

主題上次修改日期： 2007-01-22

本節中的文章可提供 Microsoft® Exchange 資料庫疑難排解員工具在應用程式事件日誌中偵測到的資料庫錯誤與警告事件詳細資料。資料庫疑難排解員使用與 Microsoft Exchange Troubleshooting Assistant 相同的引擎，利用程式設計方式執行一組疑難排解步驟來判斷資料庫裝載問題的根本原因。此外，這些文件所提供的步驟也可用來判斷徵兆，以及解決資料庫相關問題。

若需詳細資訊或要下載此工具，請參閱 Microsoft Exchange Troubleshooting Assistant v1.0。


ESE 428 (0xfffff8f0)：交易記錄磁碟機上剩餘的可用空間不足
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-04-02

Microsoft® Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一或多個 ESE 428 事件。此事件表示交易記錄檔磁碟機上的可用空間不足。產生此錯誤時，Exchange Server 將無法建立新的交易記錄檔。如此會導致受影響儲存群組中的所有資料庫變成離線，因為資料庫的更新必須記錄在交易記錄檔中。

說明

Exchange Server 提供兩種機制來避免填滿交易記錄磁碟機的空間：

  • 循環記錄。在資料庫檢查點向前通過交易記錄後，就會自動刪除這些記錄。在大多數情況下，交易記錄檔所使用的磁碟空間會保持在 50 MB 以下。在備份期間，交易記錄會暫停移除，直到備份完成為止。

    附註：
    Microsoft Exchange 2000 Server 及更新版本預設未啟用循環記錄。
  • 儲存群組備份。Exchange Server 使用一種針對 Exchange Server 實作大量陰影複製服務 (VSS) 或資料流線上備份 API 的備份方法，在執行儲存群組中所有資料庫的完整或增量線上備份之後，移除多餘的記錄。

如果循環記錄未啟用且下列其中一個條件為 true，則交易記錄檔的數量將持續增加，直到用盡硬碟的磁碟空間為止：

  • 備份程式並未移除交易記錄檔。

  • 備份程式已停止執行。

  • 使用其他方法並未清除交易記錄檔。

如果已用完硬碟空間，您必須偶爾手動移除交易記錄檔。或者，如果預計硬碟空間即將用盡，就必須偶爾手動移除交易記錄檔，才能執行特定儲存群組中所有資料庫的完整或增量線上備份。如果您將仍在資料庫檢查點前的記錄移除，資料庫會異常停止；除非還原必要記錄，否則無法裝載資料庫。因此，在手動移除任何 Exchange Server 交易記錄檔前，請務必判斷可放心移除的記錄檔。

該錯誤也會回報為 JET_errDiskFull 或錯誤碼 0xfffff8f0。此錯誤適用於下列 Exchange Server 版本：

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

使用者動作

若要解決此錯誤，請選取下列其中一種解決方案：

  • 執行 [資料庫復原管理] 工具。在 Microsoft Exchange Server 2007 中，此工具列在 Exchange 管理主控台之 [工具箱] 的 [資料庫復原] 工具下。Exchange Server Analyzer 可以自動判定可放心移除的記錄檔，並且會為您將這些記錄檔複製到備份位置。強烈建議您使用 Exchange Server Analyzer 來移動記錄檔。

    附註：
    如果包含資料庫的儲存群組已啟用叢集連續複寫 (CCR)，則 Exchange Server Analyzer 將無法在 Exchange 2007 中運作。
  • 檢查每個資料庫標頭中的 [狀態] 和 [需要的記錄檔] 值，來判斷可放心手動移除的交易記錄檔。

    附註：
    就本文而言，「移除」交易記錄檔指的是，將某個交易記錄檔移至另一個可在該處備份、儲存或刪除交易記錄檔的位置。要執行的動作視您的需求而定。就本文而言，「刪除」交易記錄檔指的是讓您無法備份或還原該交易記錄檔的移除動作。

請遵循這些詳細步驟，來判斷可放心手動移除的交易記錄檔。

檢查資料庫標頭並移除不需要的記錄檔

  1. 卸載您要檢查其標頭的資料庫。

  2. 依序按一下 [開始] 和 [執行]，然後輸入 cmd 以開啟 [命令提示] 視窗。

  3. 在命令提示下，移至資料庫檔案所在的目錄路徑。

    附註：
    在 Exchange 2000 Server 和 Exchange Server 2003 中，若要判斷資料庫的 .edb 和 .stm 檔的路徑和檔名，請使用 Exchange 系統管理員來檢視每個資料庫物件之內容對話方塊中的 [資料庫] 索引標籤。若要在 Exchange Server 2007 中判斷資料庫檔案的名稱和路徑，請展開 [伺服器組態] 下的 [Exchange 管理主控台]，按一下 [信箱]，然後檢視 [資料庫管理] 索引標籤。

  4. 在命令提示中輸入以下的 Eseutil命令和 /MH 參數：

    複製程式碼
    "eseutil /MH databasefilename.edb"
    附註：
    在此語法中，databasefilename 是您要檢查之資料庫的名稱。

  5. 檢查所顯示之標頭資訊中的 [狀態] 和 [需要的記錄檔] 值。

    [狀態] 值提供以下資訊，說明資料庫是否已正確分離：

    • 如果資料庫已正確分離，[狀態] 值為「正常關機」或「一致」。此值依正在執行的 Exchange Server 版本而有所不同。您可以移除所有交易記錄檔，但目前的交易記錄檔除外。

      附註：
      如果您在所有資料庫處於「正常關機」狀態時移除目前的記錄檔，將導致重設記錄檔序列。此舉不會阻止資料庫啟動。不過，如果發生這種狀況，重設記錄檔序列會影響將資料庫從先前備份向前復原的能力。
    • 如果資料庫未正確分離，[狀態] 值則為「不正常關機」或「不一致」。檢查資料庫標頭中的 [需要的記錄檔] 欄位，就可以判斷可移除的交易記錄檔。

      附註：
      如果資料庫處於「不正常關機」或「不一致」狀態，表示部分現有交易記錄檔中包含資料庫所需的未完成交易。如果您在此情況下移除交易記錄檔，除非您從備份還原資料庫，否則無法再次啟動資料庫。另外，您可以使用 Eseutil 命令和 Isinteg 命令來修復資料庫。
      您在移除儲存群組的任何記錄檔前，應該先檢查該儲存群組中每個資料庫的 [需要的記錄檔] 值。

      [需要的記錄檔] 欄位會列出啟動此資料庫所需之記錄檔的編號範圍。如果範圍是 0 - 0，表示啟動此資料庫不需要任何記錄檔。該資訊指出資料庫處於「正常關機」或「一致」狀態。如果有比檢查點記錄還舊的記錄檔，您可以移除這些記錄檔 (不包括檢查點記錄檔)。

      如果您執行的是比 Exchange Server 2003 Service Pack 1 (SP1) 還舊的 Exchange Server 版本，您必須將 [需要的記錄檔] 欄位中列出的十進位範圍轉換成十六進位的值。例如，如果 [需要的記錄檔] 值為 28217 - 28221，則此資料庫需要的是 06E39 到 06E3D 的記錄檔。在 Exchange 2003 SP1 中，[需要的記錄檔] 欄位已增強為可同時報告十進位和十六進位值。

      附註：
      您可以使用 Windows 小算盤的 [工程型] 模式，將十進位轉換為十六進位。啟動小算盤，然後按一下 [檢視] 功能表上的 [工程型]。輸入十進位數字，然後按一下 [十六進位]。
      由於您在 Exchange 2000 和 Exchange 2003 中最多可擁有四個儲存群組，且每個儲存群組都有一組特定的記錄檔，因此交易記錄檔的名稱中不會出現 Edb 前置詞。在 Exchange 2000 和 Exchange 2003 中，是以 E00、E01、E02 或 E03 來取代 Edb 前置詞。若為復原儲存群組，則以 R00 來取代 Edb 前置詞。儲存群組記錄檔名稱的前置詞會顯示在 Exchange 系統管理員中，特定儲存群組物件之 [內容] 對話方塊中的 [一般] 索引標籤上。因此，如果儲存群組的前置詞為 E01，且 [需要的記錄檔] 項目為 28217 - 28221 (0x06E39 - 0x06E3D)，則實際所需的記錄檔為 E0106E39.log 到 E0106E3D.log。

  6. 您可以放心移除儲存群組中，比任何資料庫之 [需要的記錄檔] 欄位中最低項目還小的所有編號記錄檔。

    附註：
    請記得是移動記錄檔，而非刪除。
    附註：
    最佳作法是：不要移除最新的交易記錄檔，也就是具有最新時間戳記且在其檔名中尚未有序列編號的記錄檔。即使您已判斷可放心移除此檔案，但還是請您保留它，以避免將記錄檔序列重設回 0。如果您重設記錄檔序列，就會影響備份週期。您可能無法從重設前所完成的備份中將資料庫向前復原。


ESE 454 -515：遺失必要的交易記錄檔
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-01-23

Microsoft® Exchange Server Analyzer 工具發現錯誤碼 -515 的 ESE 事件 454。這個錯誤由於必要的交易記錄檔遺失，因此無法裝載 Exchange 資料庫

說明

如果可擴充儲存引擎 (ESE) 在復原程序期間，嘗試讓儲存群組的所有資料庫處於一致的狀態，就會發生錯誤碼為 -515 的 ESE 454 事件。如果遺失任何必要的交易記錄檔，復原程序會失敗，且無法裝載資料庫，並會傳回 -515 錯誤。

使用者動作

若要解決這個問題，請執行下列一或多個動作：

  • 使用此處所述的程序判斷遺失的交易記錄檔及其所在位置。接著，將它們移回儲存群組的交易記錄檔目錄。

  • 從備份還原受影響的資料庫。

注意：
除非無法利用上述解決方案尋找並還原遺失的交易記錄檔，否則不要嘗試還原資料庫。這樣做會覆寫自上次備份後的所有資料。
附註：
還原資料庫之前，請從目的地路徑移動或刪除和受影響之儲存群組相關的所有交易記錄檔。
若要使用 Exchange Server 2003 或 Exchange Server 2007 中的 Microsoft Exchange Troubleshooting Assistant 來識別遺失的交易記錄檔

  1. 在 Microsoft Exchange Troubleshooting Assistant 的 [顯示檢查事件日誌結果] 視窗中，按一下 [使用相關的資料庫復原管理工作來驗證並解決此問題] 連結來識別遺失的必要交易記錄檔。

  2. 記錄步驟 1 報告的記錄檔名稱。

  3. 判斷該記錄檔目前的位置，並將它們移回預期的位置。
附註：
當您在判斷遺失之交易記錄檔的目前位置時，請記得搜尋 [資源回收筒] 與所有防毒軟體的隔離資料夾。
  1. 嘗試裝載受影響的 Exchange 資料庫。

 若要在 Exchange 2000 Server 與 Exchange Server 2003 手動識別並還原遺失的交易記錄檔

  1. 啟動 [Exchange 系統管理員]。

  2. 展開 [系統管理群組]，展開您的系統管理群組，展開 [伺服器]，在儲存群組上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 在 [一般] 索引標籤的 [交易記錄位置] 下，記錄交易記錄檔位置的路徑。

  4. 在命令提示字元下，開啟 Eseutil.exe 所在的目錄。在 Exchange 2000 Server 與 Exchange Server 2003 中，Eseutil.exe 的預設路徑為 C:\program files\exchsrvr\bin。

  5. 在命令提示字元下，輸入下列命令：

    複製程式碼
    eseutil /ml "logpath\logprefix"

    其中，logpath 為步驟 3 記錄的交易記錄檔路徑，而 logprefix 則為交易記錄檔的字首，通常為 e00.

    下列為此命令使用預設值的範例：

    eseutil /ml "c:\program files\exchsrvr\mdbdata\e00".

  6. 視遺失的交易記錄檔而定，會以下列兩種格式的其中一種報告遺失的交易記錄檔：

    • 遺失記錄檔:c:\program files\exchsrvr\mdbdata\E0002BE2.log

    • 錯誤:遺失記錄檔。記錄檔為層代 11,235 (0x2BE3)，但是預期的層代為 11,234 (0x2BE2)。

    其中，0x2BE2 為遺失的記錄檔，E0002BE2.log。

  7. 記錄步驟 6 報告的記錄檔名稱。

  8. 判斷該記錄檔目前的位置，並將它們移回步驟 3 的預期位置。
附註：
當您在判斷遺失之交易記錄檔的目前位置時，請記得搜尋 [資源回收筒] 與所有防毒軟體的隔離資料夾。
  1. 嘗試裝載受影響的 Exchange 資料庫。

 若要在 Exchange Server 2007 手動識別並還原遺失的交易記錄檔

  1. 啟動儲存群組所在伺服器上的 [Exchange 管理主控台]。

  2. 在主控台樹狀目錄中，展開 [伺服器組態]，然後按一下 [信箱]。

  3. 在結果窗格中，按一下含有要還原遺失交易記錄檔之儲存群組的信箱伺服器。

  4. 在您的儲存群組上按一下滑鼠右鍵，然後按一下 [內容]。

  5. . 在 [一般] 索引標籤的 [記錄路徑] 下，記錄交易記錄檔位置的路徑。

  6. 在命令提示字元下，開啟 Eseutil.exe 所在的目錄。在 Exchange Server 2007 中，Eseutil 位於 Exchange 預設安裝資料夾中。此為 <SystemDrive>:\Program Files\Microsoft\Exchange Server\Bin。

  7. 在命令提示字元下，輸入下列命令：

    複製程式碼
    eseutil /ml "logpath\logprefix"

    其中，logpath 為步驟 5 記錄的交易記錄檔路徑，而 logprefix 則為交易記錄檔的字首，通常為 e00.

    下列為此命令使用預設值的範例：

    eseutil /ml "c:\Program Files\Microsoft\Exchange Server\Bin\e00".

  8. 視遺失的交易記錄檔而定，會以下列兩種格式的其中一種報告遺失的交易記錄檔：

    • 遺失記錄檔:c:\Program Files\Microsoft\Exchange Server\Bin\E000000049A.log

    • 錯誤:遺失記錄檔。記錄檔為層代 11,235 (0x2BE3)，但是預期的層代為 11,234 (0x2BE2)。

    其中，0x2BE2 為遺失的記錄檔，E0002BE2.log。

  9. 記錄步驟 8 報告的記錄檔名稱。

  10. 判斷該記錄檔目前的位置，並將它們移回步驟 5 的預期位置。
附註：
當您在判斷遺失之交易記錄檔的目前位置時，請記得搜尋 [資源回收筒] 與所有防毒軟體的隔離資料夾。
  1. 嘗試裝載受影響的 Exchange 資料庫。

若需有關 ESE 事件 454 的詳細資訊，請參閱＜事件和錯誤訊息中心＞(英文) (http://go.microsoft.com/fwlink/?LinkId=34258)。


ESE 455 -1811 (0xfffff8ed)：遺失目前的 (Exx.log) 交易記錄檔
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-05-31

Microsoft Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一或多個具有錯誤碼 -1811 (0xfffff8ed) 的 ESE 455 事件。此事件表示目前的交易記錄檔 (exx.log) 遺失、無法存取或簽章不相符。

說明

下列事項可能是造成此錯誤的原因：

  • 對應到 JET_errFileNotFound 的錯誤 1811。此問題可能發生在具有不相符的簽章和內部記錄產生編號 (LGeneration) 的 Exchange 記錄檔。一般而言，Exchange 記錄檔是 E00.log 檔。如果 E00.log 檔含有不相符的簽章，即使資料庫一致，也可能不會裝載資訊儲存庫。

  • 防毒程式隔離或刪除了目前的 Exchange 記錄檔。

  • 已在受影響的資料庫上執行 eseutil /p 修復命令，但記錄檔未移除。

  • 以錯誤的記錄檔基本名稱執行 eseutil /r 復原命令 (例如 eseutil /r Exx.log，其中 Exx.log 為三個字元的記錄檔基本名稱)。

此錯誤也可能被識別為錯誤 -1811，JET_errFileNotFound。此錯誤適用於下列 Exchange Server 版本：

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

使用者動作

若要解決這個錯誤，請執行下列一或多個動作：

  • 如果記錄檔含有不相符的簽章和記錄產生號碼，請連絡 Microsoft 客戶支援服務。如需相關資訊，請造訪 Microsoft 技術支援服務網站的 [與我們連絡] 網頁。

  • 如果防毒程式隔離或刪除了目前的 Exchange 記錄檔，請遵循下列步驟：

    • 檢查防毒程式的組態。

    • 確認未將防毒程式設定為掃描 Exchange Server 目錄。

    • 依預設，有些防毒程式會設定為每週以手動或自動模式掃描磁碟機和目錄。此設定很容易受到忽略。確認您已將 Exchange Server 目錄新增至防毒程式的排除位置。如需如何設定防毒程式以與 Exchange 搭配運作的相關資訊，請參閱 Microsoft 知識庫文章 823166＜Exchange Server 2003 與防毒軟體概觀＞(機器翻譯)。

    • 檢閱防毒程式記錄檔，確認是否已隔離或刪除 Exchange 記錄檔。

    使用下列其中一個方法來復原 Exchange 記錄檔：

方法 1：如果 Exchange 記錄檔已隔離

  1. 將 Exchange 記錄檔復原到包含您工作記錄檔的資料夾中。

  2. 啟動 Microsoft Exchange Information Store 服務。如果其他記錄檔未遺失，則資料庫就會進行裝載。如果有其他記錄檔遺失，請查看遺失的記錄檔是否在防毒程式的隔離資料夾中。如果記錄檔並未在隔離資料夾中，請參閱方法 2。

如果 Exchange 記錄檔已刪除，您必須從備份來還原儲存群組資料庫。接著，您必須重新顯示記錄檔。若要還原可用的資料庫，請遵循以下步驟：

方法 2：如果 Exchange 記錄檔已刪除

  1. 將所有不一致的資料庫移至備份資料夾。

  2. 如果已建立新的 E00.log 檔，請將新的 E00.log 檔移至備份資料夾。此外，將 E00.chk 檔也移至備份資料夾。

  3. 將所有現有的記錄檔複製到備份資料夾。附註 您必須複製記錄檔，不可移動記錄檔。

  4. 將最後一個 E00*.log 檔重新命名為 E00.log。

  5. 從備份來還原資料庫。接著，重新顯示記錄檔。這會使資料庫處於一致狀態。不過，資料庫並不包含已複製到備份資料夾的 E00.log 檔。雖然有部分資料遺失，但您現在已經有可裝載的資料庫。

    附註：
    如果您無法從備份來還原資料庫，請針對資料庫執行修復公用程式，讓資料庫處於一致狀態。

  6. 啟動 Microsoft Exchange Information Store 服務。

如果已在受影響的資料庫上執行 eseutil /p 修復命令，但記錄檔未移除，請遵循以下步驟：

判定是否已執行 eseutil /p 命令

  1. 依序按一下 [開始]、[執行]，輸入 cmd，然後按一下 [確定]。

  2. 在命令提示字元中輸入以下內容：

    複製程式碼
    c:\program files\exchsrvr\bin\eseutil /mh "c:\program files\exchsrvr\mdbdata\<name of Exchange database.edb>"

    上述語法的假設前提如下：

    • Exchange Server 程式檔案是安裝在 c:\program files\exchsrvr 資料夾。

    • 您的資料庫是位於 c:\program files\exchsrvr\mdbdata 資料夾。

  3. 讀取 repair count 屬性。如果 repair count 屬性是 0 (零)，表示並未執行 eseutil /p 命令。如果 repair count 屬性是 0 以外的數字，則表示已在資料庫上執行 eseutil /p 命令。

如果公用資料庫和私人資料庫處於一致或正常關機狀態，您可以將交易記錄檔移至另一個資料夾。若要判定資料庫是否處於一致或正常關機狀態，請遵循以下步驟：

判定資料庫是否處於一致或正常關機狀態

  1. 依序按一下 [開始]、[執行]，輸入 cmd，然後按一下 [確定]。

  2. 若要檢查私人資訊儲存庫，請輸入下列內容：

    複製程式碼
    c:\program files\exchsrvr\bin>eseutil /mh "drive:\program files\exchsrvr\mdbdata\priv1.edb"

  3. 若要檢查公用資訊儲存庫，請輸入下列內容：

    複製程式碼
    c:\program files\exchsrvr\bin>eseutil /mh "drive:\program files\exchsrvr\mdbdata\pub1.edb"

    步驟 2 和 3 的語法其假設前提如下：

    • Exchange Server 程式檔案是安裝在 c:\program files\exchsrvr 資料夾。

    • 您的資料庫是位於 c:\program files\exchsrvr\mdbdata 資料夾。

  4. 檢閱一致性檢查的結果。如果資料庫一致 (狀態 = 正常關機)，表示所有記錄檔都已認可到資訊儲存庫。如果資料庫不一致 (狀態 = 不正常關機)，資料庫可能並未損毀。記錄檔可能還沒有認可到資料庫中。

  5. 如果狀態回報為正常關機，請將所有 mdbdata 目錄中的所有記錄檔移至備份資料夾。

  6. 裝載資料庫。
  • 如果使用錯誤的記錄檔基本名稱執行過 eseutil /r 復原命令，請使用正確參數以便成功執行命令。常用的記錄檔基本名稱為 e00、e01、e02 和 e03。例如，下列命令即包含正確的記錄檔基本名稱：

    複製程式碼
    eseutil /r e00
  • 如果問題仍然存在，請連絡 Microsoft 客戶支援服務。如需相關資訊，請造訪 Microsoft 技術支援服務網站的 [與我們連絡] 網頁。


ESE 474 -1018：在資料庫中偵測到無法回復的錯誤
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-03-28

Microsoft Exchange 資料庫疑難排解員工具在應用程式記錄檔中，偵測到一或多個具有錯誤碼 -1018 的 ESE 474 事件。如果 Microsoft Exchange 完整性驗證元件判定 Exchange Server 無法正確儲存或擷取硬碟子系統中的 Exchange 資料庫檔案資料，就會產生這個錯誤。

說明

發生錯誤為 -1018 的 ESE 474 事件的原因是硬碟子系統硬體元件有問題，或是硬碟子系統中有過時或不相容的驅動程式及/或韌體。

發生 -1018 錯誤之後，針對伺服器執行的診斷硬體測試可能會報告沒有磁碟子系統硬體問題，而合理的假設就是此問題肇因於 Exchange Server。

由 Microsoft 及硬體廠商進行的大規模調查確定，大部份 -1018 錯誤的原因是磁碟子系統硬體元件、支援驅動程式及/或韌體的微妙問題。

在資料庫檔案中找到的初始化分頁有下列任一狀況時，Exchange 就會報告 -1018 錯誤：

  • 分頁上儲存的總和檢查碼不符合讀取分頁時所執行的總和檢查碼重新計算結果。

  • 分頁上儲存的頁碼不符合分頁上應有的頁碼 (也就是分頁在資料庫檔案中的實際位置)。

如果發生下列其中一個案例，則 Exchange 可能就是自行產生的 -1018 錯誤的原因：

  • Exchange 建置的分頁總和檢查碼錯誤。

  • Exchange 正確建置分頁，但要求作業系統將分頁寫入錯誤的位置。

Exchange 針對即將在所有資料都寫入分頁之後寫入磁碟的分頁，產生總和檢查碼。這也包括頁碼本身。當 Exchange 將總和檢查碼新增到分頁之後，Exchange 就會指示 Windows 作業系統使用已發佈的標準 Windows 型 API 將分頁寫入磁碟。

而暫時性記憶體錯誤可能會使分頁寫入硬碟機上的錯誤位置。

即使分頁總和檢查碼正確，Exchange 仍會報告 -1018 錯誤，原因是邏輯頁碼與實體頁碼不符。

在 Exchange 資料庫中報告的單一 -1018 錯誤通常不會造成 Exchange 資料庫停止，也不會導致除了 -1018 錯誤之外的徵兆。受影響的分頁可能位於不常存取的資料夾中 (例如「寄件備份」或「刪除的郵件」資料夾)，或是位於極少開啟或甚至是空的附件中。

雖然單一 -1018 錯誤不太可能造成大規模的資料遺失，但是因為 -1018 錯誤可能表示儲存系統至少有一次並未以可靠的方式儲存或擷取資料，所以還是要加以注意。-1018 錯誤對於會隨著時間逐漸惡化的問題而言是一項早期警訊。即使第一個 -1018 錯誤是針對資料庫中的空白分頁所報告，但下次會是哪個分頁損毀，卻無法預知。如果重要的全域表格損毀，Exchange 資料庫可能就無法啟動，而資料庫修復可能不會成功或只有部份成功。

記錄 -1018 錯誤之後，除非您找到錯誤的起因，否則請準備應對資料庫可能即將發生的失敗或其他隨機損毀。

使用者動作

嘗試修正應用程式記錄檔中記錄的 ESE 474 -1018 錯誤之前，請確定伺服器磁碟子系統的穩定程度。

若要疑難排解磁碟子系統，請執行下列動作：

  1. 開啟應用程式記錄檔並搜尋 ESE 474 事件。記下每個事件中，受影響之資料庫的完整路徑。收集好受影響的資料庫清單之後，請注意資料庫路徑中參照的磁碟機代號。此項資訊可讓您直接針對上述實體磁碟進行疑難排解。

  2. 檢閱系統記錄檔，並確定沒有記錄到磁碟讀取、寫入或逾時等錯誤。

  3. 使用製造商提供的磁碟子系統診斷公用程式，並與磁碟子系統硬體廠商連絡，尋求提供更多協助來驗證磁碟子系統的完整性。

修正磁碟子系統的所有問題或驗證其穩定性之後，請使用下列方法從 -1018 錯誤中復原。這些方法是以偏好的使用順序列出：

第一個方法 將信箱從應用程式記錄檔中 ESE 474 問題所提到的資料庫移出。您可以將信箱移到已知良好的現有儲存區，或是建立一個專供解決此問題的新信箱儲存區。移動所有信箱之後，請刪除損毀的信箱儲存區。

若要移動信箱 (Exchange 2000 Server 或 Exchange Server 2003)

  1. 在 [Active Directory 使用者及電腦] 中，選取要移動其信箱的使用者。

  2. 在您於上一個步驟中選取的使用者清單上按一下滑鼠右鍵，然後按一下 [Exchange 工作]。

  3. 在 [Exchange 工作精靈] 中的 [可用的工作] 頁面上，按一下 [移動信箱]，然後按 [下一步]。

  4. 請仔細閱讀並遵循精靈的其餘步驟。
若要移動信箱 (僅限於 Exchange Server 2003)

  1. 在 [Exchange 系統管理員] 中，依序展開 [伺服器]、要移動信箱的來源伺服器、要移動信箱的來源 [儲存群組]，以及包含要移動之信箱的 [信箱儲存區]，然後按一下 [信箱]。

  2. 在詳細資料窗格中，在要移動其信箱的使用者上按一下滑鼠右鍵，然後按一下 [Exchange 工作]。

  3. 在 [Exchange 工作精靈] 中的 [可用的工作] 頁面上，按一下 [移動信箱]，然後按 [下一步]。

  4. 請仔細閱讀並遵循精靈的其餘步驟。
只使用 Exchange Server 2007 的 Exchange 管理主控台來移動信箱

  1. 啟動 Exchange 管理主控台。

  2. 在主控台樹狀目錄中，展開 [收件者組態]，然後按一下 [信箱]。

  3. 在結果窗格中，按一下要移動的信箱。

  4. 在執行窗格中，按一下 [移動信箱]。

  5. 在 [移動信箱精靈] 的 [簡介] 頁面上，選取要將信箱移到哪個伺服器、儲存群組及信箱資料庫，然後按 [下一步]。

  6. 在 [移動選項] 頁面上，選取用來處理信箱中損毀郵件的選項，然後按 [下一步]。

  7. 在 [移動排程] 頁面上，指定移動的時間，然後按 [下一步]。

  8. 在 [移動信箱] 頁面上，檢閱摘要以確認移動信箱，然後按一下 [移動]。

  9. 在 [完成] 頁面上，按一下 [完成]。

若需有關使用「移動信箱」精靈及 Move-Mailbox 指令程式之支援案例的相關資訊，請參閱 Exchange Server 2007 產品文件中的＜移動信箱＞(http://go.microsoft.com/fwlink/?LinkId=85754) (英文)。

第二個方法 從已知良好的備份來復原資料庫。若需如何復原 Exchange Server 資料庫的相關資訊，請參閱下列文章：

  • Exchange Server 2007＜嚴重損壞修復＞(http://go.microsoft.com/fwlink/?LinkId=85802) (英文)

  • 《Exchange 2003 嚴重損壞修復操作手冊》(http://go.microsoft.com/fwlink/?linkid=30250) (英文)

第三個方法 使用 Eseutil 對受影響的資料庫執行強制修復。只有在前兩種方法都失敗時，才執行這個方法。執行強制修復之後，還必須對已修復的資料庫執行離線磁碟重組，並執行 Isinteg 工具來修復邏輯損毀。這些步驟可以使用「Exchange 資料庫疑難排解員修復工作」來執行。系統會自動執行 Eseutil /P、Eseutil /D 及 Isinteg。

詳細資訊

若需這個問題的相關資訊，請參閱下列 Microsoft 知識庫文章和 Exchange 資源：

  • 314917＜瞭解與分析 -1018、-1019 及 -1022 Exchange 資料庫錯誤＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=314917)

  • 867626＜Exchange Server 2003 SP1 提供新的錯誤修正程式碼＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=867626) (機器翻譯)

  • 259851＜在 Exchange 中執行 eseutil /p 或 edbutil /d /r 命令分支＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=259851)

  • ＜Exchange Server 錯誤 -1018＞(http://go.microsoft.com/fwlink/?LinkId=85807) (英文)


MSExchangeIS 1003：Exchange 資料庫磁碟機上剩餘的可用空間不足
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-01-22

Microsoft® Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一或多個 MSExchangeIS 1003 事件。如果磁碟機包含您嘗試裝載的資料庫，且該磁碟機的可用磁碟空間量不足，則會發生此錯誤。

說明

包含 Exchange 資料庫的磁碟用完可用的磁碟空間之後，Microsoft Exchange Information Store 服務會記錄 MSExchangeIS 1003 事件，並卸載受影響的資料庫。發生此錯誤之後，您可能會無法裝載受影響儲存群組的資料庫。此錯誤適用於下列 Exchange Server 版本：

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

使用者動作

若要解決這個問題，請清出資料庫所在磁碟機上的一些磁碟空間，然後嘗試重新裝載資料庫。若要執行這項作業，請執行下列一或多個動作：

  • 如果 Exchange 資料庫檔案是硬碟上的唯一一種檔案，則可能必須執行資料庫離線磁碟重組，以清出磁碟空間。

    附註：
    視資料庫中的可用空間量而定，此步驟可能無法解決您的問題。
    若需有關執行此步驟的詳細資訊，請參閱微軟知識庫文件 - 328804＜如何磁碟重組 Exchange 資料庫＞。

    另請參閱＜如何執行 Eseutil /D (磁碟重組)＞(英文)。

  • 如果 Exchange 交易記錄檔也位在此磁碟機上，則可以移除不必要的記錄檔，以清出磁碟空間。

    若需有關執行此步驟的詳細資訊，請參閱微軟知識庫文件 - 240145＜如何移除 Exchange Server 交易記錄檔＞。


MSExchangeIS 1088：因為 legacyExchangeDN 無效而無法裝載資料庫
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-01-23

Microsoft® Exchange 資料庫疑難排解員工具偵測到 MSExchangeIS 1088 事件。此事件指出因為 Exchange 資料庫的 legacyExchangeDN 屬性值與 Active Directory 中所儲存的值不同，而無法裝載 Exchange 資料庫。

說明

如果 Exchange 資料庫已還原為 legacyExchangeDN 屬性值與其原始系統管理群組不同的系統管理群組，則會發生 MSExchangeIS 1088 事件。此行為是根據設計原則運作的。若要將儲存庫裝載在 Exchange Server 上，Exchange 資料庫之組織與系統管理群組的 legacyExchangeDN 屬性值，必須符合 Active Directory 中之組織與系統管理群組的 legacyExchangeDN 屬性值。

使用者動作

若要解決這個問題，請執行下列動作：

  • 將 Exchange 資料庫還原為其原始系統管理群組。

  • 如果無法將 Exchange 資料庫還原為其原始系統管理群組，請重新命名預定目的地的 Active Directory 物件，讓它們的 legacyExchangeDN 屬性值與 Exchange 資料庫相同。您可以使用如 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或任何其他輕量型目錄存取通訊協定 (LDAP) 第 3 版用戶端等工具來更正此值。

注意：
使用 ADSI 編輯器、LDP 工具或其他 LDAP 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或 Exchange Server 2007，或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
若要更正此錯誤

  1. 使用 [ADSI 編輯器] 或類似的工具，在 Active Directory 中找出系統管理群組物件。

    legacyExchangeDN 屬性可以在以下位置找到：

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group

  2. 鍵入新的字串值，格式如下：

    /o= organization /ou= administrative group

若需有關使用 LDP 工具的詳細資訊，請參閱微軟知識庫文件 - 260745＜XADM：使用 LDP 公用程式來修改 Active Directory 物件屬性＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

若需有關使用 ADSI 編輯器的詳細資訊，請參閱主題＜Adsiedit.msc：ADSI 編輯器＞(位在 Windows Server 2003 說明中)。

若需有關 MSExchangeIS 事件 1088 的詳細資訊，請參閱下列資源：

  • 事件和錯誤訊息中心

  • 微軟知識庫文件 - 280652＜XADM：記錄「事件識別碼 1088」且無法裝載儲存庫＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=280652)


MSExchangeIS 5000 (0x3f5)：針對 Information Store Service 設定的服務帳戶無效
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-02-27

Microsoft® Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一個或多個錯誤碼為 0x3f5 的 MSExchangeIS 5000 事件。當 Microsoft Exchange Information Store 服務是設定為使用 Local Service 以外的帳戶啟動時，會發生此錯誤。

說明

當使用 Local Service 帳戶以外的帳戶啟動 Microsoft Exchange Information Store 服務 (Store.exe)，或是網域控制站、網域或「本機電腦安全性原則」的「產生安全性稽核」原則中未包含 Local Service 帳戶，就會發生此錯誤。發生此問題時，將無法初始化 Exchange Information Store 服務。此錯誤適用於下列 Exchange Server 版本：

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

使用者動作

若要解決這個問題，請執行下列一或多個動作：

  • 根據預設，Exchange Information Store 服務會使用 Local Service 帳戶來啟動 Information Store 服務 (MACHINENAME$)。請使用 Services.msc 嵌入式管理單元來檢查用來啟動 Information Store 服務的帳戶。如果是使用 Local Service 帳戶來啟動該服務，則必須將「產生安全性稽核」權限授與 Local Service 帳戶。若要執行這項作業，請使用下列其中一種方法：

    • 從此電腦重新執行 Exchange Setup /domainprep 命令。

    • 手動將下列其中一個原則的「產生安全性稽核」權限授與 Local Service 帳戶：

    1. 網域控制站原則

    2. 網域原則

    3. 本機電腦安全性原則

      若要將此權限重新授與成員伺服器的「本機電腦安全性原則」，請遵循下列步驟。

      附註：
      如果只有一部伺服器發生此問題，則這就是建議的解決方案。
      若要將稽核權限重新授與成員伺服器的「本機電腦安全性原則」

      1. 按一下 [開始]，並按一下 [系統管理工具]，然後按一下 [本機安全性原則]。

      2. 展開 [安全性設定]，並按一下 [本機原則]，然後按一下 [使用者權限指派]。

      3. 在右窗格中，按兩下 [產生安全性稽核]、按一下 [新增]、輸入 MACHINENAME$，然後按兩次 [確定]。

      4. 結束 [群組原則] 嵌入式管理單元。
  • 如果使用 Local System 帳戶以外的帳戶來啟動 Information Store 服務，則應該將它變更為 Local System 帳戶 (MACHINENAME$)。接著，請嘗試啟動 Information Store 服務。若需有關 Exchange 2000 Server 與 Exchange Server 2003 為何使用 Local System 帳戶來啟動 Exchange 服務的詳細資訊，請參閱微軟知識庫文件 - 239762＜Exchange 服務以 LocalSystem 執行＞。

詳細資訊

若需詳細資訊，請參閱微軟知識庫文件 - 281850＜Exchange 2000 Server 或 Exchange Server 2003 中的 Information Store 無法啟動，且產生事件識別碼 9530 與 5000 訊息＞。


MSExchangeIS 5000 (0x80004005)：因為服務帳戶不正確、SeSecurityPrivilege 權限遺失或群組成員資格不正確，而無法裝載資料庫
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-02-19

Microsoft Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一或多個具有錯誤碼 0x80004005 的 MSExchangeIS 5000 事件。此事件指出因為服務帳戶不正確、SeSecurityPrivilege 權限遺失或群組成員資格不正確，而無法裝載 Exchange 伺服器上的一或多個資料庫。

說明

如果符合下列其中一種情況，就會發生此事件：

  • 已自一或多個網域控制站的 Exchange Enterprise Servers 群組中移除「管理稽核與安全性記錄檔」權限 (SeSecurityPrivilege)。Exchange Enterprise Servers 群組必須要有網域中所有網域控制站的「管理稽核與安全性記錄檔」權限。符合此情況時，就無法啟動一或多個 Exchange Server 相關服務。

  • 使用 Local System 以外的帳戶啟動 Microsoft Exchange Information Store 服務，或是網域控制站、網域或「本機電腦安全性原則」的「產生安全性稽核」原則中未包含 Local System 帳戶。符合此情況時，就不會啟動 Exchange Information Store 服務。

  • 父系網域的 Exchange Enterprise Servers 群組未包含子網域的 Exchange Domain Servers 群組。

此事件也可能被識別為 MAPI_E_CALL_FAILED。此事件適用於下列 Exchange Server 版本：

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

使用者動作

若要解決這個問題，請執行下列一或多個動作：

  • 如果已從一或多個網域控制站的 Exchange Enterprise Servers 群組中移除「管理稽核與安全性記錄檔」權限 (SeSecurityPrivilege)，請遵循下列步驟：

    在一或多個網域控制站上新增權限

    1. 使用 Policytest.exe 來疑難排解權限問題。Policytest.exe 位於 Exchange 2000 Server CD 上的 Support\Utils\I386 資料夾，或是 Exchange Server 2003 CD 上的 Support\ExDeploy 資料夾。請使用 Policytest.exe 判定網域控制站的 Exchange Enterprise Servers 群組是否遺失「管理稽核與安全性記錄檔」權限。成功的結果會傳回類似以下的資訊：

      本機網域是 "<contoso.com>" (contoso)，帳戶是 "CONTOSO\Exchange Enterprise Servers" DC = "<ComputerName>" 於站台 = "<Default-First-Site-Name>" 發現的權限："SeSecurityPrivilege"

      附註 成功的結果會顯示「管理稽核與安全性記錄檔」權限已存在。您必須具有網域系統管理員權限才能執行 Policytest.exe。如需 Policytest.exe 公用程式的相關資訊，請參閱 Microsoft 知識庫文章 281537＜XADM：Policytest.exe 公用程式的描述＞(機器翻譯)。

    2. 在網域層級重設 Exchange Enterprise Server 預設權限。若要這樣做，請遵循下列步驟：

      1. 從 Exchange Server CD 或網路安裝點執行 setup /domainprep 命令。setup /domainprep 命令會將 Exchange Enterprise Servers 群組新增到具有預設權限的網域。當您執行 setup /domainprep 命令時，權限會立即新增到一個網域控制站。接著，變更會複寫至其他網域控制站。

      2. 將權限繼承還原至其他組織單位。然後等待網域控制站將變更複寫到整個網域內。

      3. 執行 Policytest.exe。請注意哪些網域控制站傳回下列成功結果：

        發現的權限："SeSecurityPrivilege"

        如果所有網域控制站都有正確的權限，請重新啟動 Exchange Server 服務。如果任何網域控制站都沒有正確的權限，請參閱步驟 3。

    3. 驗證預設網域控制站的原則。若要這樣做，請遵循下列步驟：

      1. 啟動 [Active Directory 使用者及電腦] 嵌入式管理單元。

      2. 在 [網域控制站] 容器上按一下滑鼠右鍵，然後按一下 [內容]。

      3. 按一下 [群組原則] 索引標籤，然後確定 [預設網域控制站原則] 列在 [群組原則物件連結] 方塊中。附註 如果未列出 [預設網域控制站原則]，請依序按一下 [新增]、[預設網域控制站原則]，然後按一下 [確定]。然後等待此變更複寫到所有其他網域控制站。

      4. 從 Exchange Server CD 或網路安裝點執行 setup /domainprep 命令。setup /domainprep 命令會將 Exchange Enterprise Servers 群組新增到具有預設權限的網域。

      5. 執行 Policytest.exe。請注意哪些網域控制站傳回下列成功結果：

      發現的權限："SeSecurityPrivilege"

      如果所有網域控制站都有正確的權限，請重新啟動 Exchange Server 服務。如果部份網域控制站沒有正確的權限，請參閱步驟 4。

    4. 手動新增權限至網域控制站。在您執行 setup /domainprep 命令之後，檔案複寫服務 (FRS) 可能不會將更新的安全性原則複寫到一或多個網域控制站。如果發生此問題，您必須手動指派正確的權限至 Exchange Enterprise Servers 群組。如果部份網域控制站或所有網域控制站沒有正確的權限，請將「管理稽核與安全性記錄檔」權限指派至 Exchange Enterprise Servers 群組。然後等待設定複寫到其他網域控制站。若要這樣做，請遵循下列步驟：

      1. 啟動 [Active Directory 使用者及電腦] 嵌入式管理單元。

      2. 在 [網域控制站] 容器上按一下滑鼠右鍵，然後按一下 [內容]。

      3. 按一下 [群組原則] 索引標籤，在 [群組原則物件連結] 方塊中按一下 [預設網域控制站原則]，然後按一下 [編輯]。

      4. 依序展開 [電腦組態]、[Windows 設定]、[安全性設定]、[本機原則]，然後按一下 [使用者權限指派]。

      5. 在右窗格中，連按兩下 [管理稽核與安全性記錄檔]，再依序按一下 [新增]、[瀏覽]，然後新增 [Exchange Enterprise Servers 群組]。

      6. 在 [新增使用者或群組] 對話方塊中，按一下 [確定]。然後再按一次 [確定]。

      7. 結束 [群組原則] 嵌入式管理單元，然後在 [網域控制站內容] 對話方塊中按一下 [確定]。附註 有時當您在 [新增使用者或群組] 對話方塊中按 [瀏覽] 時可能看不到 Exchange Enterprise Servers 群組。如果發生此行為，請新增 Exchange Enterprise Servers 群組。然後重新執行 setup /domainprep 命令。這個處理程序會讓所有網域控制站上都有新增 Exchange Enterprise Servers 群組的動作。
  • 如果使用 Local System 以外的帳戶啟動 Exchange Information Store 服務，或是網域控制站、網域或「本機電腦安全性原則」的「產生安全性稽核」原則中未包含 Local System 帳戶，請遵循此處所指示的解決方案。

    根據預設，Exchange Information Store 服務會使用 Local Service 帳戶來啟動 Information Store 服務 (MACHINENAME$)。請使用 Services.msc 嵌入式管理單元來檢查用來啟動 Information Store 服務的帳戶。如果是使用 Local Service 帳戶，則必須將「產生安全性稽核」權限重新授與 Local Service 帳戶。若要執行這項作業，請使用下列其中一種方法：

    將「產生安全性稽核」權限重新授與 Local Service 帳戶

    1. 從此電腦重新執行 Exchange Setup /domainprep 命令。

    2. 手動將下列其中一個原則的「產生安全性稽核」權限授與 Local Service 帳戶：

      • 網域控制站原則

      • 網域原則

      • 本機電腦安全性原則

    將產生安全性稽核權限重新授與成員伺服器的本機電腦安全性原則

    1. 按一下 [開始]，並按一下 [系統管理工具]，然後按一下 [本機安全性原則]。

    2. 展開 [安全性設定]，並按一下 [本機原則]，然後按一下 [使用者權限指派]。

    3. 在右窗格中，按兩下 [產生安全性稽核]、按一下 [新增]、輸入 MACHINENAME$，然後按兩次 [確定]。

    4. 結束 [群組原則] 嵌入式管理單元。

    如果使用 Local System 帳戶以外的帳戶來啟動 Information Store 服務，則應該將它變更為 Local System 帳戶 (MACHINENAME$)。接著，請嘗試啟動 Information Store 服務。如需 Exchange 2000 Server 與 Exchange Server 2003 為何使用 Local System 帳戶來啟動 Exchange 服務的相關資訊，請參閱 Microsoft 知識庫文章 239762＜Exchange 服務以 LocalSystem 執行＞。

  • 如果父系網域的 Exchange Enterprise Servers 群組未包含子網域的 Exchange Domain Servers 群組，請將子網域的 Exchange Domain Servers 群組新增至父系網域的 Exchange Enterprise Servers 群組中。而在根網域中建立收件者更新服務，也可以解決此問題。

    若要解決此問題，請在遠端 Windows 網域中的伺服器上，使用 /domainprep 參數執行 Exchange 安裝程式。然後在 Exchange 伺服器上使用 Exchange 系統管理員，建立遠端網域的收件者更新服務。若要這樣做，請遵循下列步驟：

    建立遠端網域的收件者更新服務

    1. 依序按一下 [開始]、[程式集]、[Microsoft Exchange] 及 [系統管理員]。

    2. 展開 [組織] 物件，然後展開 [收件者] 容器。

    3. 按一下 [收件者更新服務]。

    4. 在右窗格中，以滑鼠右鍵按一下 [新增]，然後按一下 [收件者更新服務]。

    5. 按一下沒有收件者更新服務執行個體且具有必須由 Exchange 更新之使用者的網域。

    6. 按 [下一步]。

    7. 選取您要執行收件者更新服務及處理所有具有 Exchange 屬性之必要使用者的伺服器。

    8. 按 [下一步]。

    9. 按一下 [完成]。

    10. 若要手動啟動該網域中的收件者更新，請以滑鼠右鍵按一下 [收件者更新服務]，然後按一下 [立即更新] 強制更新。
    如需相關資訊，請參閱 Microsoft 知識庫文章 253770＜Exchange 收件者更新服務所執行的工作＞(機器翻譯)。


MSExchangeIS 5000 (0x80040154)：SMTP 服務延伸模組遺失或損毀
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-02-19

Microsoft Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一或多個具有錯誤碼 0x80040154 的 MSExchangeIS 5000 事件。如果 Exchange Server 簡易郵件傳送通訊協定 (SMTP) 服務延伸模組遺失或損毀，則會發生此錯誤。

說明

此問題發生的原因是 Exchange SMTP 服務延伸模組遺失或損毀。此行為會讓 Exchange 與 SMTP 服務之間的功能遺失。SMTP 服務是安裝為 Microsoft Internet Information Services (IIS) 子元件的必要服務。

此錯誤可能因為下列原因而發生：

  • 已移除 IIS。

  • 已自 IIS 中移除 SMTP 服務子元件。

  • 已移除 IIS，然後重新安裝成沒有必要 SMTP 服務子元件的 Windows 元件。

  • 已移除 IIS，然後重新安裝成具有適當子元件清單的 Windows 元件。但尚未重新安裝 Exchange SMTP 服務延伸模組。

此錯誤適用於下列 Exchange Server 版本：

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

使用者動作

若要解決此錯誤，請參閱 Microsoft 知識庫文章 326305＜資訊儲存庫未啟動，並且在 Exchange 2000 Server 及 Exchange Server 2003 中發生 MSExchangeIS 事件 ID 5000 和 9538 訊息＞(機器翻譯)。

還原 SMTP 服務延伸模組

  1. 確認 Exchange SMTP 服務延伸模組遺失。若要這樣做，請遵循下列步驟：

    1. 使用具有系統管理認證的帳戶登入執行 Microsoft Exchange 的電腦。

    2. 依序按一下 [開始]、[執行]，輸入 cmd，然後按一下 [確定]。

    3. 在命令提示輸入 telnet 127.0.0.1 25，檢視 "220 server.domain.com Microsoft ESMTP Mail Service" 項目。

    4. 輸入 EHLO，然後按 Enter 鍵檢視 250 命令動詞清單。如果沒有動詞的名稱是以 "X" 開頭，則 SMTP 服務延伸模組便已遺失。

  2. 完整備份系統磁碟分割。包含系統狀態和 Exchange 資料庫檔案。如需此做法的相關資訊，請參閱 Microsoft 知識庫文章 258243＜如何使用 Windows 備份程式備份及還原 Exchange 電腦＞。

  3. 確認已正確重新安裝 IIS，包含必要的 Exchange 相依子元件。

    IIS 6.0

    1. 按一下 [開始]，然後指向 [設定]，再按 [控制台]。

    2. 按兩下 [新增/移除程式]。

    3. 在左邊的窗格中，按一下 [新增/移除 Windows 元件]。

    4. 在 [Windows 元件] 精靈的元件清單中找到 [Application Server]，然後按一下 [詳細資料]。

    5. 如果未安裝下列任何元件，請安裝它們：

      ASP.NET

      啟用網路 COM+ 存取

      網際網路資訊服務 (IIS)

    6. 按一下 [Internet Information Services (IIS)]，然後按一下 [詳細資料]。

    7. 如果未安裝下列任何元件，請安裝它們：

      共用檔案

      網際網路資訊服務管理員

      NNTP 服務

      SMTP 服務

      World Wide Web 服務

    8. 按兩次 [確定]。在主要的 [Windows 元件] 頁面上，按 [下一步]，再按 [完成]。

    IIS 5.0

    1. 按一下 [開始]，然後指向 [設定]，再按 [控制台]。

    2. 按兩下 [新增/移除程式]。

    3. 在左邊的窗格中，按一下 [新增/移除 Windows 元件]。

    4. 在 [Windows 元件] 精靈對話方塊的元件清單中，找到 [Internet Information Services (IIS)]。如果已選取 [Internet Information Services (IIS)] 核取方塊，表示已安裝 IIS。若要檢視安裝的 IIS 子元件，請按一下 [Internet Information Services (IIS)]，然後按一下 [詳細資料]。

    5. 如果未安裝 IIS，則請按一下 [Internet Information Services (IIS)] 核取方塊將它選取，然後按一下 [詳細資料]。安裝 IIS 5.0 子元件，然後按一下 [確定]。安裝 Exchange 2000 之前所需的最少 IIS 5.0 子元件如下：

      共用檔案

      網際網路資訊服務嵌入式管理單元

      SMTP 服務

      網路 News 傳輸通訊協定 (NNTP) 服務 (適用於新聞群組)

      World Wide Web 服務

    6. 按 [下一步]，然後按一下 [完成]。

  4. 還原 Exchange SMTP 服務延伸模組。

    Exchange Server 2003

    如果您在現有的 Exchange 2003 安裝之上又重新安裝 Exchange 2003，資料庫檔案和權限會維持不變。若要這樣做，請遵循下列步驟：

    1. 插入 Exchange 2003 CD。

    2. 在 \SETUP\I386 資料夾中，連按兩下 Setup.exe 檔案。

    3. 在 [歡迎使用] 頁面上，按 [下一步] 直到您看到 [元件選取項目] 頁面為止。

    4. 在 [元件選取項目] 頁面上，按一下 [動作] 欄位中的 [重新安裝]，然後按 [下一步]。

    5. 在 [安裝摘要] 頁面上驗證選取項目，然後按一下 [下一步] 繼續安裝 Exchange 2003。

    Exchange 2000 Server

    您用來還原 Exchange 2003 SMTP 服務延伸模組的方法，取決於移除了多少個 IIS 子元件。如果 SMTP 服務是唯一遭到移除的 IIS 子元件，且已安裝了 Exchange 2000 Server Service Pack 2 (SP2) 或更新的 Service Pack，請使用 Smtpreinstall.exe 命令列公用程式。Smtpreinstall.exe 命令列公用程式位於 Server\Support\Utils\I386 資料夾。

    使用 Smtpreinstall.exe 公用程式

    1. 將 Smtpreinstall.exe 檔案複製到 Exchsrvr\Bin 資料夾。

    2. 在命令提示字元中，變更至 Exchsrvr\Bin 資料夾，然後輸入下列命令：

      smtpreinstall.exe

    3. 看到提示時將電腦重新開機。

    如果 IIS 5.0 是整個元件移除，或是不只從 IIS 5.0 移除 SMTP 服務子元件，請在整合安裝 Microsoft Small Business Server 2000 時在現有的安裝上重新安裝 Exchange 2000。

    重新安裝 Exchange 2000 Server

    附註：
    如果您在現有的 Exchange 2000 安裝之上又重新安裝 Exchange 2000，資料庫檔案和權限會維持不變。
    1. 插入 Exchange 2000 Server CD。

    2. 在 \SETUP\I386 資料夾中，連按兩下 Setup.exe 檔案。

    3. 在 [歡迎使用] 頁面上按 [下一步]。

    4. 看到提示時輸入產品識別碼，然後按 [下一步]。

    5. 在 [元件選取項目] 頁面上，按一下 [動作] 欄位中的 [重新安裝]，然後按 [下一步]。

    6. 在 [安裝摘要] 頁面上驗證選取項目，然後按一下 [下一步] 繼續安裝 Exchange 2000。

  5. 重新安裝 Exchange Service Pack 及 Hotfix。

    若需詳細資訊，請參閱下列微軟知識庫文件：

    836993 ＜如何取得 Exchange Server 2003 的最新 Service Pack＞。

    301378 ＜如何取得最新的 Exchange 2000 Server Service Pack＞。


MSExchangeIS 5000 (0xc004038a)：因為權限不正確或路由群組已刪除而無法裝載資料庫
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-05-31

Microsoft Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一或多個具有錯誤碼 0xc004038a 的 MSExchangeIS 5000 事件。發生此錯誤時，將無法初始化 Microsoft Exchange Information Store 服務，也不會裝載資料庫。

說明

因為權限不正確或路由群組已刪除，所以發生錯誤碼為 0xc004038a 的事件 MSExchangeIS 5000。此事件的可能原因如下：

  • Exchange Server 不再是路由群組的成員，或已從 Active Directory 中刪除它的路由群組。

  • Exchange Domain Servers 群組沒有 Active Directory 中的適當權限。

此事件適用於下列 Exchange Server 版本：

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

使用者動作

若要解決這個錯誤，請執行下列一或多個動作：

  • 如果 Exchange Domain Servers 群組沒有適當權限，請使用 Active Directory 服務介面 (ADSI) 編輯器公用程式來確定 Exchange Domain Servers 群組具有 Active Directory 中的必要權限。請確定在 Administrators 群組、Exchange Domain Servers 群組以及其他與您組態相關之所有群組的 [安全性] 索引標籤上，選取 [允許從父項繼承權限套用到這個物件和所有的子物件，包括明確定義於此的項目] 核取方塊。

    附註：
    如果需要，請強制在網域控制站中進行複寫，以確定將變更傳播至整個網域。
    附註：
    在 Windows 2000 與 Windows 2003 安裝 CD 的 Microsoft Windows 2000 支援工具與 Microsoft Windows Server 2003 支援工具中，都附有 [ADSI 編輯器] 工具。
  • 如果 Exchange 伺服器不再是路由群組的成員，或已從 Active Directory 中刪除它的路由群組，則請新增路由群組或還原路由群組。請遵循以下最符合您問題情況的解決方案：

解決方案 1：將伺服器新增至路由群組。請遵循下列步驟，驗證伺服器不再是路由群組的成員：

  1. 啟動 [Exchange 系統管理員]。

  2. 依序展開 [組織]、[系統管理群組]、[AdministrativeGroupName]，然後展開 [路由群組]。

    附註：
    在此步驟中，AdministrativeGroupName 是系統管理群組的名稱。
  3. 瀏覽所有可用的路由群組，並驗證未列出此伺服器。

    附註：
    如果看不到路由群組，請參閱解決方案 2。
  4. 驗證完此伺服器不是路由群組的成員之後，請將伺服器新增回現有的路由群組。若要這樣做，請遵循下列步驟：

    重要事項：
    如果您使用 [ADSI 編輯器] 嵌入式管理單元、LDAP 公用程式或其他 LDAP 版本 3 用戶端，並且您錯誤地修改了 Active Directory 物件的屬性，將會導致嚴重的問題。您可能需要重新安裝 Microsoft Windows 2000 Server、Microsoft Windows Server 2003、Microsoft Exchange 2000 Server、Microsoft Exchange Server 2003，或 Windows 及 Exchange 兩者皆需重新安裝，才可解決這些問題。Microsoft 無法保證可以解決因為您錯誤地修改 Active Directory 物件屬性而造成的問題。修改這些屬性的風險由客戶自行負責。
將伺服器新增回路由群組

  1. 依序按一下 [開始]、[執行]，輸入 adsiedit.msc，然後按一下 [確定]。

    附註：
    [ADSI 編輯器] 工具包含在 Microsoft Windows 2000 支援工具和 Microsoft Windows Server 2003 支援工具中。若要安裝這些支援工具，請遵循下列步驟：
    • 若為 Windows 2000 Server 電腦，請在 Windows 2000 CD 中連按兩下 Support\Tools 資料夾內的 Setup.exe，然後遵循 Windows 支援工具安裝精靈中的步驟，完成 Windows 2000 支援工具的安裝。

    • 若為 Windows Server 2003 電腦，請用滑鼠右鍵按一下 Windows Server 2003 CD 上 Support\Tools 資料夾中的 Suptools.msi，按一下 [安裝]，然後遵循 Windows 支援工具安裝精靈中的步驟，完成 Windows 2003 支援工具的安裝。

  2. 依序展開 [Configuration [ servername.domain_name.com ]]、[CN=Configuration, DC= domain_name, DC= com]、[CN=Services、CN=Microsoft Exchange]、[CN= OrganizationName]、[CN=Administrative Groups]、[CN= AdministrativeGroupName]，最後按一下[CN=Routing Groups]。

    附註：
    在此步驟中，servername 是伺服器的名稱，domain_name.com 是網域的名稱，OrganizationName 是 Exchange Server 組織的名稱，而 AdministrativeGroupName 是系統管理群組的名稱。

  3. 在您要使此伺服器成為其成員的路由群組上按一下滑鼠右鍵，然後按一下 [內容]。

  4. 按一下 [distinguishedName] 屬性，然後按一下 [編輯]。

  5. 將 distinguishedName 屬性的值複製到記事本。

  6. 按兩次 [取消] 關閉內容。

  7. 在 ADSIEdit 工具中，依序展開 [Configuration [ servername.domain_name.com ]]、[CN=Configuration,DC= domain_name, DC= com]、[CN=Services]、[CN=Microsoft Exchange]、[CN= OrganizationName]、[CN=Administrative Groups]、[CN= AdministrativeGroupName]，最後展開 [CN=Servers]。

  8. 在 [servername] 上按一下滑鼠右鍵，然後按一下 [內容]。

  9. 按一下 [msExchHomeRoutingGroup] 屬性，然後按一下 [編輯]。

  10. 貼上您在步驟 5 中複製到記事本的值，然後連按兩次 [確定] 儲存新值。

  11. 在 Exchange 系統管理員中，找到您新增此伺服器的路由群組。

  12. 更新 Exchange 系統管理員以檢視此伺服器。

    附註：
    如果 Exchange 伺服器未立即出現，請等候進行 Active Directory 複寫。

  13. 如果此路由群組中沒有其他 Exchange 伺服器的 [伺服器類型] 設為 [主要]，請在 Exchange 伺服器上按一下滑鼠右鍵，然後按一下 [設定為主要]。

  14. 啟動 Information Store 服務及 MTA Stacks 服務。

解決方案 2：還原路由群組。如果您意外移除了路由群組，請使用最近的「系統狀態」資料備份來還原路由群組。若是最近未備份「系統狀態」資料，且有多個網域控制站，請對您移除的路由群組執行系統授權還原作業。

還原路由群組

  1. 啟動 Exchange 系統管理員，然後建立新的路由群組，其名稱與您移除的路由群組相同。若要這樣做，請遵循下列步驟：

    1. 依次展開 [系統管理群組] 及 [AdministrativeGroupName]，然後展開 [路由群組]。

      在此步驟中，AdministrativeGroupName 是系統管理群組的名稱。

    2. 在 [路由群組] 上按一下滑鼠右鍵、指向 [新增]，然後按一下 [路由群組]。

    3. 在 [名稱] 方塊中輸入路由群組名稱，然後按一下 [確定]。

      請使用與您意外移除之路由群組相同的名稱。

    4. 結束 [Exchange 系統管理員]。

  2. 啟動 [ADSI 編輯器]。若要這樣做，請依序按一下 [開始] 及 [執行]，並在 [開啟] 方塊中鍵入 [adsiedit.msc]，然後按一下 [確定]。

    附註：
    [ADSI 編輯器] 工具包含在 Microsoft Windows 2000 支援工具和 Microsoft Windows Server 2003 支援工具中。若要安裝這些支援工具：
    • 若為 Windows 2000 Server 電腦，請在兩下 Windows 2000 CD 中連按兩下 Support\Tools 資料夾內的 Setup.exe，然後遵循 Windows 支援工具安裝精靈中的步驟，完成 Windows 2000 支援工具的安裝。

    • 若為 Windows Server 2003 電腦，請用滑鼠右鍵按一下 Windows Server 2003 CD 上 Support\Tools 資料夾中的 Suptools.msi，按一下 [安裝]，然後遵循 Windows 支援工具安裝精靈中的步驟，完成 Windows 2003 支援工具的安裝。

  3. 依序展開 [Configuration [servername.domain_name.com]]、[CN=Configuration, DC=domain_name, DC=com]、[CN=Services]、[CN=Microsoft Exchange]、[CN=OrganizationName]、[CN=Administrative Groups]、[CN=AdministrativeGroupName]，最後按一下 [CN=Routing Groups]。

    在此步驟中，servername 是伺服器的名稱，domain_name.com 是網域的名稱，OrganizationName 是 Exchange Server 組織的名稱，而 AdministrativeGroupName 是系統管理群組的名稱。

  4. 在右窗格中，以滑鼠右鍵按一下您建立的新路由群組，然後按一下 [內容]。

  5. 如果尚未選取 [顯示必要屬性] 核取方塊以及 [顯示選用屬性] 核取方塊，請按一下以選取它們。

  6. 在 [屬性] 清單中，按一下 [msExchRoutingGroupMembersBL]，然後按一下 [編輯]。

    [值] 清單是空白的。

  7. 按一下 [取消]。

  8. 在 [屬性] 方塊中，連按兩下 [distinguishedName]。

  9. 在 [值] 方塊中以滑鼠右鍵按一下辨別名稱，然後按一下 [複製]。

  10. 啟動文字編輯器 (例如記事本)，然後按一下 [編輯] 功能表上的 [貼上]，貼上辨別名稱。

  11. 在 [字串屬性編輯器] 對話方塊中，按一下 [取消]，然後按一下 [取消] 關閉 [CN=RoutingGroupName] 對話方塊。

    在此步驟中，RoutingGroupName 是路由群組的名稱。

  12. 在 [ADSI 編輯器] 的 [CN=AdministrativeGroupName] 下，按一下 [CN=Servers]。

  13. 在右窗格中，在 [CN=ServerName] 上按一下滑鼠右鍵，然後按一下 [內容]。

    在此步驟中，ServerName 是此路由群組中的其中一台 Exchange 電腦。

  14. 在 [屬性] 清單中，按一下 [msExchHomeRoutingGroup]，然後按一下 [編輯]。

  15. 在 [值] 方塊中貼上您在步驟 9 和 10 複製的辨別名稱，然後按一下 [確定]。

  16. 按一下 [套用]，然後按一下 [確定]。

  17. 針對屬於意外移除之路由群組的每部伺服器，重複執行步驟 13 到 15。

  18. 在 [CN=AdministrativeGroupName] 下，按一下 [CN=Routing Groups]。

  19. 在右窗格中，以滑鼠右鍵按一下您建立的新路由群組，然後按一下 [內容]。

  20. 在 [屬性] 清單中，按一下 [msExchRoutingGroupMembersBL]，然後按一下 [編輯]。

    [值] 清單不再是空白的。

  21. 按兩次 [取消]。

  22. 結束 [ADSI 編輯器]。

  23. 使用 Exchange 系統管理員設定主要路由群組。若要這樣做，請遵循下列步驟：

    1. 啟動 [Exchange 系統管理員]。

    2. 依次展開 [系統管理群組] 及 [AdministrativeGroupName]，然後展開 [路由群組]。

    3. 展開您建立的新路由群組，然後按一下 [成員]。

    4. 在右窗格中，以滑鼠右鍵按一下要設定為主要路由群組的 Exchange 電腦，再按一下 [設定為主要]。

    5. 結束 [Exchange 系統管理員]。

  24. 等待變更傳播至網域。

  25. 啟動已停止的 Microsoft Exchange 服務。


MSExchangeIS 5000 (0x8004010f)：由於權限錯誤或組織名稱中的無效字元，無法裝載資料庫
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-01-23

Microsoft® Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一或多個具有錯誤碼 0x8004010f 的 MSExchangeIS 5000 事件。此事件表示由於權限錯誤或 Exchange 組織名稱中包含無效字元，因此無法裝載 Exchange 伺服器上的資料庫。

說明

若下列其中一個情況為真，就會發生具有錯誤碼 0x8004010f 的 MSExchangeIS 5000 事件：

  • 已驗證的使用者在 Active Directory 的網域容器或組態容器中沒有讀取權限。符合此情況時，若您嘗試在已經含有 Exchange 伺服器的系統管理群組中安裝第二部 Exchange 伺服器，可能無法成功。此外，Microsoft Exchange Information Store 服務也可能不會啟動。

  • Active Directory 之組態容器下的 WellKnown Security Principals 容器，遺失 Everyone 帳戶的讀取權限。符合此情況時，Exchange Information Store 服務不會在成員伺服器上啟動。

  • Exchange 組織名稱包含不支援的字元。符合此情況時，在您安裝 Exchange 2000 Server 或 Exchange Server 2003 之後，Exchange Information Store 服務不會啟動，而且會在應用程式記錄檔中記錄事件 MSExchangeIS 5000 及 MSExchangeIS 1121。

此事件也可能被識別為 MAPI_E_NOT_FOUND。此事件適用於下列 Exchange Server 版本：

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

使用者動作

若要解決這個問題，請執行下列一或多個動作。

重要事項：
如果您使用 [Active Directory Service Interfaces (ADSI) 編輯器] 嵌入式管理單元、LDP 公用程式，或任何其他 LDAP 版本 3 用戶端，並且您錯誤地修改了 Active Directory 物件的屬性，將會導致嚴重的問題。您可能需要重新安裝 Microsoft Windows® 2000 Server、Microsoft Windows Server™ 2003、Microsoft Exchange 2000 Server、Microsoft Exchange Server 2003，或 Windows 及 Exchange 兩者皆需重新安裝，才能解決這些問題。Microsoft 無法保證可以解決因為您錯誤地修改 Active Directory 物件屬性而造成的問題。修改這些屬性的風險由客戶自行負責。
  • 如果已驗證的使用者在 Active Directory 的網域容器或組態容器中沒有讀取權限，請使用 Exchange Server 2003 及 Exchange 2000 Server 中的 [ADSI 編輯器] 工具，將 Active Directory 的網域容器及組態容器中的讀取權限授與使用者。遵循下列步驟：

    附註：
    您可以在 Microsoft Windows 2000 支援工具或 Microsoft Windows Server 2003 支援工具中找到 [ADSI 編輯器] 工具。若要安裝 Windows 支援工具，請執行 Windows 光碟的 Support\Tools 資料夾中的安裝程式。若需有關 Windows 支援工具的詳細資訊，請參閱 Windows 光碟的 Support\Tools 資料夾中的 Sreadme.doc 檔案。
若要將 Active Directory 的網域容器或組態容器中的讀取權限授與使用者

  1. 依序按一下 [開始]、[執行]，輸入 adsiedit.msc，然後按一下 [確定]。

  2. 展開 [網域 NC] 容器，在網域 (DC=domain,DC=com) 的資料夾上按一下滑鼠右鍵，然後按一下 [內容] 以開啟資料夾內容。

  3. 按一下 [安全性] 索引標籤，然後確定已選取 [已驗證的使用者] 群組之 [讀取] 權限的 [允許] 欄位。如果未選取 [讀取]，請按一下以選取 [讀取]，然後按一下 [確定]。

  4. 展開 [組態容器]，在組態 (CN=Configuration,DC=domain,DC=com) 的資料夾上按一下滑鼠右鍵，然後按一下 [內容] 以開啟資料夾內容。

  5. 按一下 [安全性] 索引標籤，然後確定已選取 [已驗證的使用者] 群組之 [讀取] 權限的 [允許] 欄位。如果未選取 [讀取]，請按一下以選取 [讀取]，然後按一下 [確定]。

  6. 結束 [ADSI 編輯器]。

  7. 請稍候，等待此變更在網域控制站之間進行複寫。

  8. 啟動 Information Store 服務。
  • 如果 Active Directory 之組態容器下的 WellKnown Security Principals 容器遺失 Everyone 帳戶的讀取權限，請遵循下列步驟以解決此問題：

若要將讀取權限授與 Active Directory 之 WellKnown Security Principals 容器中的 Everyone 帳戶

  1. 以網域系統管理員的身分登入，然後啟動 [ADSI 編輯器]。

  2. 展開 [組態] 容器，然後按一下 [CN=WellKnown Security Principals] 容器。

  3. 在 [內容] 上按一下滑鼠右鍵，然後尋找 [安全性] 索引標籤。

  4. 按一下 [新增]、輸入 everyone，然後按一下 [確定]。

  5. 在 [允許] 欄位下，按一下以選取 [讀取] 核取方塊。
  • 如果 Exchange 組織名稱包含無效字元，請移除組織名稱中的無效字元。若需有關哪些是無效字元的詳細資訊，請參閱微軟知識庫文件 - 329599＜無法啟動 Exchange Information Store 並且會記錄 1121 及 5000 事件＞。


MSExchangeIS 9518 (0xfffffddc)：超過此儲存群組可用的交易記錄數目上限
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-01-22

Microsoft® Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一或多個具有錯誤碼 0xfffffddc 的 MSExchangeIS 9518 事件。這表示已經超過此儲存群組可用的交易記錄數目上限。

說明

嘗試裝載儲存群組的資料庫，且同時符合下列兩種狀況時，便會記錄錯誤碼為 0xfffffddc 的 MSExchangeIS 9518 事件：

  • 已經超過此儲存群組可用的交易記錄數目上限。

  • 此儲存群組中的所有資料庫都處於「正常關機」狀態

此外，在受影響的資料庫關閉之前，應該已經在應用程式記錄檔中記錄錯誤碼為 0xfffffdf9 的 MSExchangeIS 1159 事件。此事件表示 Exchange Server 已經使用此儲存群組的所有可用交易記錄檔。當最後一個交易記錄填滿之後，此儲存群組中的所有資料庫都會卸載，且無法重新啟動。

Exchange 依照編號順序使用交易記錄檔。在 Exchange 2000 Server 及 Exchange Server 2003 中，交易記錄檔從 Exx00001.log 開始，然後依序增加到 ExxFFFF0.log。單一序列中可產生的交易記錄檔數目上限為 1,048,560 (0xFFFF0)。一般而言，需要許多年的作業才會產生這麼多記錄檔。

在 Exchange Server 2007 中，交易記錄檔較大。一個記錄資料流最多可以有 2,147,483,647 個記錄檔 (換算成十六進位為 0x7FFFFFFF，因為記錄檔名稱是以十六進位表示)。每個交易記錄檔的大小是 1 MB。Exchange Server 2007 不太可能會發生此錯誤。

使用者動作

若要解決此錯誤，您必須移除所有交易記錄檔，並將交易記錄檔順序重設回 1。重設交易記錄檔順序之後，Exchange Server 2003 或更早版本中的記錄檔名稱為 Exx00001.log，而在 Exchange Server 2007 中的記錄檔名稱為 Exx00000001.log。

您可以使用資料庫復原管理工具 (屬於 Microsoft Exchange Troubleshooting Assistant 的一部分) 中的重設記錄檔產生編號工作來執行此作業。此工具會確認所有資料庫是否都已正確關閉，然後將所有交易記錄檔安全地移至備份位置。

附註：
您也可以手動移除交易記錄檔，但這樣可能會造成儲存群組中的資料庫無法正確關閉，且無法再次裝載該資料庫。若要避免發生這種失敗，建議您使用資料庫復原管理工具。

若需詳細資訊或要下載此工具，請參閱 Microsoft Exchange Troubleshooting Assistant v1.0。


MSExchangeIS 9518 (0xfffff745)：無法建立或存取 TMP 檔案
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-01-23

Microsoft® Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一或多個具有錯誤碼 0xfffff745 的 MSExchangeIS 9518 事件。如果 Exchange 無法在 TMP 或 TEMP 系統環境變數所指定的資料夾中建立或存取檔案，則會發生此錯誤。

說明

如果符合下列其中一種情況，就會發生此問題：

  • TMP 或 TEMP 環境變數所指向的路徑無法使用或為唯讀。例如，如果 TMP 環境變數是對應至遠端磁碟機或存放區域網路 (SAN)，且該對應磁碟機或 SAN 已無法使用，則會發生此問題。

  • TMP 或 TEMP 環境變數的登錄設定不正確。

  • Exchange 沒有磁碟機根目錄至交易記錄檔與資料庫所在目錄的完全控制權限。

使用者動作

若要解決這個問題，請執行下列一或多個動作：

附註 因為 Microsoft Windows 有數種版本，所以下列步驟在您電腦上可能會不同。如果不同，請參閱產品文件以完成這些步驟。

  • 確認 TMP 環境變數與 TEMP 環境變數都指向 Windows 中的有效位置。若要這樣做，請遵循下列步驟：

    為 Temp 與 TMP 變數設定有效路徑

    1. 按一下 [開始]，並指向 [設定]，然後按一下 [控制台]。

    2. 按兩下 [系統]，並按一下 [進階] 索引標籤，然後按一下 [環境變數]。

    3. 在 [系統變數] 下，按一下 [TEMP]，然後按一下 [編輯]。

    4. 如果 [變數值] 方塊並未顯示有效路徑，請輸入 TEMP 變數的有效路徑，然後按一下 [確定]。例如，輸入 %systemroot%\Temp，然後按一下 [確定]。

    5. 在 [系統變數] 下，按一下 [TMP]，然後按一下 [編輯]。

    6. 如果 [變數值] 方塊並未顯示有效路徑，請輸入 TMP 變數的有效路徑，然後按一下 [確定]。例如，輸入 %systemroot%\Temp，然後按一下 [確定]。

    7. 按兩次 [確定] 以關閉 [系統內容] 對話方塊。

    8. 重新啟動電腦。
  • 確認並將 Temp 資料夾的完全控制權限指派給本機 Administrators 群組或 SYSTEM 帳戶。將完全控制權限指派給 Domain Admins 群組是不夠的。根據預設，TMP 與 TEMP 系統環境變數會指定下列路徑：

    %SYSTEMROOT%\Temp

    Exchange 必須使用 SYSTEM 帳戶來存取此資料夾位置。若要檢視這些權限，請遵循下列步驟：

    若要確認 Temp 資料夾的權限

    1. 在 [開始] 上按一下滑鼠右鍵，然後按一下 [檔案總管]。

    2. 在系統環境變數所指定的 Temp 資料夾上按一下滑鼠右鍵，然後按一下 [內容]。一般而言，這是 %systemroot%\Temp。

    3. 按一下 [安全性] 索引標籤。

    4. 在 [名稱] 清單中，按一下 [SYSTEM]，然後檢視 [權限] 清單中出現的已指派權限。
    如果 Temp 資料夾的權限正確，請確認每個內含 Exchange 資料庫檔案或 Exchange 記錄檔之磁碟機的權限。SYSTEM 帳戶必須要有下列項目的完全控制權限：磁碟機根目錄，以及內含 Exchange 資料庫檔案或 Exchange 交易記錄檔的每個資料夾。例如，如果 [C:\Exchsrvr\Mdbdata] 資料夾中有交易記錄檔，則 SYSTEM 帳戶必須要有磁碟機 C 之根目錄、[Exchsrvr] 資料夾以及 [Mdbdata] 資料夾的完全控制權限。

  • 檢查是否因登錄設定不正確而發生問題。請遵循下列步驟：

    若要確認登錄設定

    1. 依序按一下 [開始] 及 [執行]，並輸入 Regedt32.exe，然後按一下 [確定]。

    2. 尋找下列登錄機碼：

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

    3. 尋找 TMP (或 TEMP) 名稱。此機碼應該是 REG_EXPAND_SZ 類型。

    4. 如果任一機碼不正確，請備份 Environment 子機碼，然後刪除右邊的 TMP 或 TEMP 值。

    5. 依序按一下 [開始] 及 [執行]，並輸入 Sysdm.cpl，然後按一下 [確定]。

    6. 在 [進階] 索引標籤上，按一下 [環境變數]。

    7. 在 [系統變數] 清單中，確認此清單中沒有您在步驟 4 中刪除的值。

      附註：
      您可能必須往下捲動才能看到 TEMP 或 TMP 變數。

    8. 按一下 [新增]。在 [變數名稱] 方塊中，輸入您在步驟 4 中刪除的名稱。例如，輸入 C:\Winnt\TEMP。

    9. 按三次 [確定]，然後重新啟動電腦。


MSExchangeIS 9518 0xfffffbc4：記錄檔路徑已使用
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-05-14

Microsoft Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一或多個具有錯誤碼 0xfffffbc4 的 MSExchangeIS 9518 事件。此錯誤碼指出有一或多個儲存群組的設定是使用相同的記錄檔路徑或系統檔路徑。

說明

如果有多個儲存群組已設定為使用同樣的記錄檔路徑或系統檔路徑，便會發生此錯誤。Exchange 要求每一個儲存群組的記錄檔和系統檔使用唯一路徑。

使用者動作

若要解決此問題，請確定每一個儲存群組都是設定為唯一的記錄檔路徑和系統檔路徑。

附註：
分離的儲存群組可以共用相同的記錄檔路徑和系統檔路徑。但相同路徑無法作為另一個儲存群組的記錄檔路徑或系統檔路徑使用。
驗證或設定 Exchange 2000 Server 或 Exchange Server 2003 上的記錄檔路徑和系統檔路徑

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [系統管理群組]、展開您的系統管理群組、展開 [伺服器]、在儲存群組上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 在 [一般] 索引標籤中，在 [交易記錄位置] 下面，按一下 [瀏覽]。

  4. 確認 [記錄檔路徑] 及 [系統檔案路徑] 對儲存群組來說都是唯一的。

  5. 如果儲存群組的 [記錄檔路徑] 和 [系統檔路徑] 對儲存群組而言不是唯一的，請輸入記錄檔和系統檔的新位置之路徑，然後按一下 [確定]。

  6. 按一下 [確定]。
驗證或設定 Exchange Server 2007 上儲存群組的記錄檔路徑和系統檔路徑

  1. 開啟 [Exchange 管理主控台]。

  2. 展開 [伺服器組態]，然後反白顯示 [信箱]。

  3. 在 [信箱] 窗格中，選取您要使用的伺服器。

  4. 在 [資料庫管理] 窗格中，以滑鼠右鍵按一下您要使用的儲存群組，並選取 [內容]。

  5. 確認 [記錄檔路徑] 及 [系統檔案路徑] 對儲存群組來說都是唯一的。

  6. 如果儲存群組的 [記錄檔路徑] 和 [系統檔路徑] 對儲存群組而言不是唯一的，請遵循 Exchange Server 2007 文件＜如何設定或變更儲存群組記錄檔的位置＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80702) 中的指導，將檔案路徑設定為每一個儲存群組唯一的位置。

若需在 Exchange Server 2003 上移動記錄檔的相關資訊，請參閱 Microsoft 知識庫文章 821915＜如何在 Exchange Server 2003 中移動 Exchange 資料庫和記錄檔＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915)。

若需如何在 Exchang 2000 Server 上移動記錄檔的相關資訊，請參閱 Microsoft 知識庫文章 239944＜XADM：如何將交易或系統記錄檔移至其他位置＞(機器翻譯) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=239944)。


MSExchangeIS 9518 (0xfffffd9a)：遺失檢查點檔案，以及有 1,008 個以上的交易記錄檔
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-01-23

Microsoft® Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一或多個具有錯誤碼 0xfffffd9a 的 MSExchangeIS 9518 事件。此錯誤指出此儲存群組的檢查點檔案 (Exx.chk) 遺失或已遭刪除，以及有 1,008 個以上的交易記錄檔顯示在資料庫中。

說明

如果符合下列情況，就可能會發生此問題：

  • 記錄檔與資料庫已正確關閉。因此，未發生需要進行復原的毀損。

  • 已重新命名或刪除 Exx.chk 檢查點檔案。

  • 在不同檢查點之間有 1,008 個以上的記錄檔要重新顯示在伺服器上。

  • 在「向前復原」復原中，儲存群組中的一或多個資料庫遺失，但是記錄檔在復原期間仍然保留在伺服器上。「向前復原」復原作業未順利完成。

在此情況下，Microsoft Exchange Information Store 服務會執行軟復原，並在啟動期間重新顯示所有記錄檔。因為記錄檔與資料庫已正確關閉，所以並不需要執行復原。由於沒有檢查點，所以 Exchange 會處理所有記錄檔，直到遇到正常關機的記錄。因為有 1,008 個以上的記錄檔，所以 Exchange 在遇到正常關機的記錄之前，已先達到 1,008 個記錄檔的限制。

附註：
如果符合先前所列的情況，而且使用 eseutil /r 命令重新顯示記錄檔，也可能會發生上述徵兆。eseutil /r 命令也會對信箱儲存區執行軟復原。

此錯誤也可能被識別為 JET_errCheckpointDepthTooDeep (-614)，而且只適用於 Microsoft Exchange Server 2003。

使用者動作

若要解決 Exchange Server 2003 中的這個問題，請套用微軟知識庫文件 - 836611＜未裝載 Information Store 資料庫，而且在啟動執行 Exchange Server 2003 的電腦時收到「作業因錯誤 -614 而結束」錯誤訊息＞中所述的 Hotfix。


MSExchangeIS 9518 0xfffffb40：遺失資料庫檔案
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-05-23

Microsoft Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一或多個具有錯誤碼 0xfffffb40 的 MSExchangeIS 9518 事件。這指出儲存群組有一或多個資料庫檔案遺失。

說明

當可延伸儲存引擎 (ESE) 嘗試在復原期間使儲存群組的所有資料庫成為一致狀態時，卻發現有資料庫檔案遺失，或已取代為不同版本，這時會發生此錯誤。

如果儲存群組中有任何資料庫檔案遺失，或已取代為不同版本，則 ESE 會傳回錯誤 -1216，中止復原，且不啟動儲存群組。

使用者動作

若要解決此問題，請執行下列一或多個動作：

  • 方法一：如果遺失的資料庫檔案已移動或重新命名，請在應用程式記錄檔中尋找發生在嘗試裝載資料庫之後的任何 ESE 494 事件。對於每一個事件，請記下報告遺失的特定資料庫檔案，尋找檔案的目前位置，並將它移到適當位置。

附註：
如果在此伺服器上安裝了檔案層級的防毒軟體，但未正確配置排除項目，則資料庫可能會遭到防毒軟體刪除或隔離。請務必檢查防毒隔離及刪除記錄檔，以查看是否發生此情形。
  • 方法二：

    • 方法二 A：如果遺漏的資料庫檔案遭到刪除或遺失，請從備份還原該檔案至實際執行時的儲存群組。您可以使用 Exchange 資料庫復原管理工具的 [驗證資料庫及交易記錄檔] 工作，來驗證還原的資料庫檔案是否可用於執行還原。

      還原此資料庫檔案時，您也可以在儲存群組中裝載及存取其他未受影響的資料庫，請透過下列步驟來達成此目的：

容許使用者信箱存取未受影響的資料庫

  1. 執行 eseutil /R /L <Path to Log Files> /S <Path to System Files> Log Base Name /I (其中 Log Base Name 是此儲存群組的記錄檔的前三個字元，例如 E00、E01...等等)。這可讓 ESE 將資料庫檔案呈現一致狀態，並忽略遺失的資料庫檔案。執行此命令之後，需要從備份中還原所有遺失的資料庫檔案。
附註：
/L 和 /S 參數是選用的，如果 eseutil 執行的位置與記錄檔和系統檔的位置相同，則不需要使用它們。
  1. 在儲存群組中裝載現行及一致的資料庫檔案。

  2. 具有由目前裝載之資料庫所主控信箱的使用者，現在可存取其郵件。
  • 方法二 B：從備份還原資料庫檔案至復原儲存群組。您可以儘快以新資料庫開始，以便立即提供傳送/接收功能 (即所謂的撥號音復原)。用戶端看到的是空白信箱，但比起要等待還原或修復完成後才能使用，這樣能夠比較快獲得傳送及接收功能。

附註：
撥號音選項最後仍需要將任何新的 (後撥號音) 資料與已還原的資料進行合併。

若需撥號音復原的相關資訊，請參閱 Exchange 2007 產品文件的「嚴重損壞修復」主題中的＜撥號音可攜性＞(英文)。

若需「復原儲存群組」的相關資訊，請參閱 Exchange 2007 產品文件的「嚴重損壞修復」主題的＜瞭解復原儲存群組＞(英文)。
  • 方法三：不論是以手動方式或從 Exchange Troubleshooting Assistant 的 [修復資料庫] 工作，只要針對儲存群組的一或多個資料庫執行了硬式修復，而且資料庫為一致狀態的話，則可能不會移除儲存群組的記錄檔。如果儲存群組的所有資料庫都在其正確位置，請執行下列命令，驗證所有資料庫都是一致狀態。

手動驗證資料庫檔案的一致狀態：

  1. 執行 eseutil /mh <path to database .edb file>

  2. 在此命令的輸出中，尋找 State: 欄位並確認其值為 Clean Shutdown (正常關機)。

  3. 如果儲存群組的所有資料庫都是在「正常關機」狀態，請將儲存群組的所有交易記錄檔和系統記錄檔移到備份位置，然後嘗試裝載儲存區。如果您可以正確裝載所有資料庫，建議您立即建立儲存群組的備份。

詳細資訊

若需 MSExchangeIS 9518 事件和錯誤碼 0xfffffb40 的相關資訊，請參閱＜事件和錯誤訊息中心＞(英文) (http://go.microsoft.com/fwlink/?LinkId=91705)。

若需從此錯誤中復原的相關資訊，請參閱 Microsoft 知識庫文章 296843＜如何在錯誤 -1216 之後復原 Exchange 2000 Server 資料庫＞(機器翻譯) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=296843)。

若需「Exchange 嚴重損壞修復規劃」的相關資訊，請參閱＜Exchange 嚴重損壞修復規劃指南＞(http://go.microsoft.com/fwlink/?LinkId=91706)。

若需資料庫復原管理和資料庫疑難排解員精靈的相關資訊，請參閱＜資料庫復原管理和資料庫疑難排解員工具＞(英文) (http://go.microsoft.com/fwlink/?LinkId=91707)。

若需撥號音復原的相關資訊，請參閱 Exchange 2007 產品文件的「嚴重損壞修復」主題中的＜撥號音可攜性＞(英文) (http://go.microsoft.com/fwlink/?LinkId=91703)。

若需「復原儲存群組」的相關資訊，請參閱 Exchange 2007 產品文件的「嚴重損壞修復」主題中的＜瞭解復原儲存群組＞(英文) (http://go.microsoft.com/fwlink/?LinkID=80784)。


MSExchangeIS 9518 (0xfffffea8)：資料庫檔案中的資料庫時間戳記不相符
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-01-23

Microsoft® Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一或多個具有錯誤碼 0xfffffea8 的 MSExchangeIS 9518 事件。如果受影響資料庫之目前頁面的 dbtime 大於資料庫的全域資料庫 dbtime，則會發生此錯誤。

說明

發生此錯誤時，將不會裝載受影響的信箱或公用資料夾資料庫。此錯誤也可能被識別為 JET_errDbTimeCorrupted。

此錯誤適用於下列 Exchange Server 版本：

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

使用者動作

若要解決資料庫時間戳記不相符的問題，請執行 eseutil /d 命令以重組發生此問題的資料庫，然後重新裝載資料庫。若需有關如何執行 eseutil /d 的詳細資訊，請參閱＜如何執行 Eseutil /D (磁碟重組)＞(英文)。另請參閱微軟知識庫文件 - 328804＜如何磁碟重組 Exchange 資料庫＞。


MSExchangeIS 9518 (0xfffff764)：資料流檔案遺失或無法存取
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-01-23

Microsoft® Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一或多個具有錯誤碼 0xfffff764 的 MSExchangeIS 9518 事件。如果 Exchange 無法存取與資料庫關聯的資料流檔案 (.stm)，則會發生此錯誤。

說明

如果已刪除或移動與資料庫關聯的資料流檔案 (.stm)，或 Exchange 因權限變更而無法存取此資料流檔案，則會發生此錯誤。

附註：
在特定情況下，如果未針對每個 Microsoft Exchange 最佳作法排除 Exchange 目錄不進行掃描，則防毒程式可能會刪除或變更 Exchange 檔案的權限 (包含 .stm 檔案)。若需有關此主題的詳細資訊，請參閱微軟知識庫文件 - 823166＜Exchange Server 2003 與防毒軟體概觀＞。

這個錯誤也可能被識別為 -2204。此錯誤適用於下列 Exchange Server 版本：

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

使用者動作

若要解決這個問題，請執行下列一或多個動作：

  • 從資料庫備份中還原資料流檔案。

  • 檢查資料流檔案是否已被防毒軟體移至 [隔離] 資料夾。如果檔案是在 [隔離] 資料夾中，請將檔案移至原始位置，然後將防毒程式設定成不掃描 Exchange Server 2003 資料夾。

    附註：
    某些防毒程式將檔案移至 [隔離] 資料夾之後，會將檔案屬性變更為唯讀。如果在 [隔離] 資料夾中找到資料流檔案，請在該檔案上按一下滑鼠右鍵，然後按一下 [內容]。嘗試裝載資料庫之前，請先按一下以清除 [唯讀] 核取方塊。
  • 您可以執行屬於 Microsoft Exchange Troubleshooting Assistant 的 Microsoft Exchange 資料庫復原管理工具。資料庫復原管理工具可以分析此儲存群組的資料庫與交易記錄檔，並提供關於此問題的其他詳細資料。若需詳細資訊或要下載此工具，請參閱 Microsoft Exchange Troubleshooting Assistant v1.0。


MSExchangeIS 9518 (0xfffffbf8)：缺少 Exchange 資料庫資料夾或磁碟機上的必要權限
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-03-15

Microsoft Exchange 資料庫疑難排解員工具在應用程式記錄檔中，偵測到一或多個具有錯誤碼 0xfffffbf8 的 MSExchangeIS 9518 事件。這表示尚未將適當的權限指派給含有 Exchange 資料庫的資料夾或磁碟機。

說明

這個錯誤表示尚未將執行最少功能時所需的權限，指派給主控 Exchange 資料庫檔案的資料夾或磁碟機。存取或裝載信箱儲存區或公用資料夾儲存區時，可能會遭遇困難。

使用者動作

若要解決此問題，請將預設權限授與含有 Exchange 資料庫的資料夾，以及此資料夾所在位置的磁碟機。

在 Exchange 2007 中，將預設權限授與含有 Exchange 資料庫的資料夾

  1. 啟動 [Windows 檔案總管]，然後瀏覽到含有 Exchange 資料庫的資料夾。這預設為 C:\Program Files\Microsoft\Exchange\Mailbox\儲存群組名稱\

  2. 在該資料夾上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 按一下 [安全性] 索引標籤，然後授與下列預設權限

帳戶 | 權限
Administrators | 完全控制
System | 完全控制
 在 Exchange 2007 中，將預設權限授與含有 Exchange 資料庫的磁碟機

  1. 啟動 [Windows 檔案總管]。

  2. 在含有 Exchange 資料庫資料夾的 [本機磁碟] 物件上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 選取 [安全性] 索引標籤，然後授與下列預設權限 (根據安裝的作業系統而定)：

若是 Windows 2000 Server：

帳戶 | 權限
Everyone | 完全控制

若是 Windows Server 2003：

帳戶 | 權限
Administrators | 完全控制
Creator Owner | 無
Everyone | 無
System | 完全控制
Users | 讀取及執行、清單資料夾內容、讀取
 在 Exchange 2000 Server 及 Exchange Server 2003 中，將預設權限授與 Mdbdata 資料夾

  1. 啟動 [Windows 檔案總管]，然後瀏覽至 Exchsvr 資料夾並將其展開。

  2. 在 [Mdbdata] 資料夾上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 按一下 [安全性] 索引標籤，然後授與下列預設權限：

帳戶 | 權限
Administrators | 完全控制
Authenticated Users | 讀取及執行、清單資料夾內容、讀取
Creator Owner | 無
Server Operators | 修改、讀取及執行、清單資料夾內容、讀取、寫入
System | 完全控制
 在 Exchange 2000 Server 及 Exchange Server 2003 中，將預設權限授與含有 Mdbdata 資料夾的磁碟機

  1. 啟動 [Windows 檔案總管]。

  2. 在含有 Mdbdata 資料夾的 [本機磁碟] 物件上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 選取 [安全性] 索引標籤，然後授與下列預設權限 (根據安裝的作業系統而定)：

若是 Windows 2000 Server：

帳戶 | 權限
Everyone | 完全控制

若是 Windows Server 2003：

帳戶 | 權限
Administrators | 完全控制
Creator Owner | 無
Everyone | 無
System | 完全控制
Users | 讀取及執行、清單資料夾內容、讀取

詳細資訊

若需這個問題的相關資訊，請參閱 Microsoft 知識庫文章 823022＜已記載事件識別碼 490，您嘗試在 Exchange Server 中裝載信箱儲存區或公用儲存區時，收到下列錯誤訊息：「識別碼：c1041724」＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823022) (機器翻譯)。


MSExchangeIS 9518 (0xfffff743)：太多暫存檔案
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-03-14

Microsoft Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一或多個具有錯誤碼 0xfffff743 的 MSExchangeIS 9518 事件。這表示伺服器的暫存檔命名空間已經用盡，或是沒有空間可供寫入 temp 資料夾。

說明

當大型物件 (例如郵件或檔案) 串流到儲存區，而 .stm 檔過於分散，無法讓整個物件寫入時，Exchange 2000 Server 及 Exchange Server 2003 就會在 Temp 資料夾中建立暫存檔。

在正常操作期間停止 Exchange 服務時，就會從 Temp 資料夾中移除這些檔案。如果 Exchange 伺服器異常關機，或是 Exchange 服務異常終止，則不會移除這些檔案。稍後重新啟動 Exchange 服務時，就會建立新的暫存檔。這樣會導致效能降低。64,000 個暫存檔命名空間用盡之後，Exchange 服務就無法啟動，並在事件檢視器應用程式日誌中，記錄錯誤碼為 0xfffff743 的 9518 事件。

使用者動作

若要解決此問題，請執行下列動作：

  • 檢查 Windows Temp 資料夾是否有 lb*.tmp 檔。如果有這類檔案，請遵循下列程序中的步驟來加以移除。

  • 檢查主控 Temp 資料夾的磁碟機是否有可用磁碟空間。如果磁碟機沒有可用空間，請使用下列程序，將 Temp 及 Tmp 資料夾移到不同的磁碟機。

從 Windows Temp 資料夾移除 lb*.tmp 檔

  1. 按一下 [開始]，並依序選取 [程式集] 及 [系統管理工具] 後，再按一下 [服務]。

  2. 向下捲動到 [Microsoft Exchange Information Store]。

  3. 如果服務狀態為 Started，請在服務上按一下滑鼠右鍵，然後按一下 [停止]。
附註：
這樣會中斷所有使用者與他們信箱的連線。
  1. 瀏覽至 %windir%\temp 資料夾，其中的 %windir% 是您的 Windows 系統根資料夾 (預設為 C:\Windows\Temp)。

  2. 刪除所有 lb*.tmp 檔。

  3. 在 [服務] 管理主控台的 [Microsoft Exchange Information Store] 服務上按一下滑鼠右鍵，然後按一下 [啟動]。

 將 Temp 及 Tmp 資料夾移到不同的磁碟機

  1. 在 Exchange Server 電腦上，依序按一下 [開始] 及 [控制台]，然後連按兩下 [系統]。

  2. 按一下 [進階] 索引標籤，再按 [環境變數]。

  3. 在 [系統變數] 下，按一下含有 TEMP 變數及磁碟機的那一行，再按 [編輯]，然後輸入新的磁碟機位置。

  4. 在 [系統變數] 下，按一下含有 TMP 變數及磁碟機的那一行，再按 [編輯]，然後輸入新的磁碟機位置
附註：
確定這項變更是套用到 [系統變數]，而非 [使用者變數]。
附註：
如果此處所述的程序無法解決這個問題，請參考 Microsoft 知識庫文章 307242＜資訊儲存庫無法裝載，錯誤為 0xfffff745 及 -2235＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307242) (機器翻譯) 中的資訊。

詳細資訊

若需此問題的相關資訊，請參閱下列 Microsoft 知識庫文章：

  • 294462＜Windows Temp 資料夾中的 Exchange lb*.tmp 檔造成 ESE -2237 錯誤＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=294462) (機器翻譯)

  • 307242＜資訊儲存庫無法裝載，錯誤為 0xfffff745 及 -2235＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307242) (機器翻譯)


MSExchangeIS 9519 (0xfffffb3a)：偵測到多個資料庫使用相同簽章
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-01-23

Microsoft® Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一或多個具有錯誤碼 0xfffffb3a 的 MSExchangeIS 9519 事件。此錯誤指出相同資料庫的另一個複本已在執行中。

說明

每個 Exchange 資料庫都有它自己的唯一簽章。如果 Microsoft Exchange Information Store 服務偵測到多個資料庫具有相同簽章，則會防止裝載重複的資料庫。

此事件也可能被識別為 -1222，JET_errDatabaseSignInUse。

使用者動作

您可以遵循下列步驟，來驗證相同資料庫的兩個複本是否位於單一儲存群組中：

  1. 卸載儲存群組中的所有其他資料庫，並嘗試裝載造成此錯誤訊息的資料庫。

  2. 如果可以裝載資料庫，則必須嘗試裝載儲存群組中的所有其他資料庫。

  3. 如果儲存群組中的不同資料庫現在也在應用程式記錄檔中顯示相同的錯誤，則表示這兩個資料庫的簽章相同；因此，它們都是相同資料庫的複本。

若要解決這個問題，請確定此特定儲存群組內只有一份資料庫複本。


MSExchangeIS 9519 (0xfffffe07)：因為正在執行備份處理而無法裝載資料庫
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-02-27

Microsoft Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一或多個具有錯誤碼 0xfffffe07 的 MSExchangeIS 9519 事件。此錯誤指出因為正在執行備份處理而無法裝載所指定的資料庫。

說明

如果此資料庫所屬的儲存群組具有多個資料庫 (信箱資料庫或公用資料夾資料庫)，而在您嘗試裝載上述其中一個資料庫時正在備份該資料庫，則會發生此錯誤。此行為是根據設計原則運作的。當您正在備份儲存群組中的某個資料庫時，無法裝載該儲存群組中的其他資料庫。

此錯誤也可能被識別為錯誤 -505，JET_errBackupInProgress。

使用者動作

請確定目前並未在儲存群組中執行任何資料庫備份作業，然後嘗試裝載資料庫。或者，您可以等待儲存群組中的另一個資料庫備份完成，再嘗試裝載此資料庫。


MSExchangeIS 9519 (0x3f3)：還原之後發現未核取的 [此資料庫可被還原覆寫] 核取方塊
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-01-23

Microsoft® Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一或多個錯誤碼為 0x3f3 的 MSExchangeIS 9519 事件。此錯誤指出已在資料庫上執行還原，但未選取 [此資料庫可被還原覆寫] 核取方塊。

說明

當您針對資料庫執行還原作業，且 Exchange 偵測到您未核取儲存庫內容上的 [此資料庫可被還原覆寫] 核取方塊時，會發生此事件。

使用者動作

若要解決這個問題，請執行下列動作，以確定還原可以覆寫資料庫。

若要在 Exchange Server 2003 與 Exchange 2000 Server 上啟用此選項

  1. 啟動 [Exchange 系統管理員]。

  2. 展開 [系統管理群組] (若可用)

  3. 依序展開 [伺服器]、[<伺服器名稱>] 及 [<儲存群組>]，然後按一下所還原的資料庫。

  4. 在資料庫上按一下滑鼠右鍵，然後按一下 [內容]。

  5. 按一下 [資料庫] 索引標籤。

  6. 按一下以選取 [此資料庫可被還原覆寫] 核取方塊。

  7. 按一下 [確定]。

  8. 若要裝載該資料庫，請在該資料庫上按一下滑鼠右鍵，然後按一下 [裝載儲存區]。
若要在 Exchange Server 2007 上啟用此選項

  1. 啟動 [Exchange 管理主控台]

  2. 在 [伺服器組態] 下，選取 [信箱]。

  3. 在 [資料庫管理] 窗格中，於所還原的資料庫上按一下滑鼠右鍵。

  4. 按一下 [內容]

  5. 選取 [一般] 索引標籤

  6. 按一下以選取 [此資料庫可被還原覆寫] 核取方塊。

  7. 按一下 [確定]。

  8. 若要裝載該資料庫，請在該資料庫上按一下滑鼠右鍵，然後按一下 [裝載資料庫]。


MSExchangeIS 9518 (0xfffffc01)：不正確的資料庫或交易記錄檔磁碟機或目錄
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-01-23

Microsoft® Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一或多個具有錯誤碼 0xfffffc01 的 MSExchangeIS 9518 事件。這表示您為 Exchange 資料庫或記錄檔設定的磁碟機代號或路徑不正確。

說明

此錯誤表示受影響之儲存群組中的資料庫或記錄檔路徑指向無效的磁碟機代號或檔案路徑不正確。發生此錯誤時，將無法裝載受影響之儲存群組中的所有資料庫。

如果防毒軟體封鎖 Exchange 資料庫或交易記錄檔所在之磁碟機的寫入存取權，也可能發生此問題。

此事件也可能被識別為 -1023，JET_errInvalidPath。

使用者動作

若要解決這個問題，請執行下列一或多個動作：

  • 若要判斷此問題是否為防毒軟體所造成，請暫時在 [服務] 主控台中停用您使用的防毒軟體。然後嘗試裝載受影響的資料庫。如果資料庫可以順利裝載，請與防毒軟體廠商連絡，以取得最新的軟體版本。

  • 確認並為每個受此錯誤影響的儲存群組與資料庫設定正確的系統、資料庫和交易記錄檔路徑。遵循下列步驟。

若要在 Exchange Server 2003 或 Exchange 2000 Server 確認並設定正確的檔案路徑

  1. 啟動 [Exchange 系統管理員]。按一下 [開始]，依序指向 [所有程式] 及 [Microsoft Exchange]，然後按一下 [系統管理員]。

  2. 如果 [Exchange 系統管理員] 顯示系統管理群組，請展開 [系統管理群組]，然後展開發生問題的系統管理群組。

  3. 展開 [伺服器]，然後展開發生問題的伺服器。

  4. 在包含無法裝載之儲存區的儲存群組上按一下滑鼠右鍵，然後按一下 [內容]。

  5. 在 [一般] 索引標籤上，檢查 [交易記錄位置] 方塊中顯示的路徑。檢查 [系統路徑位置] 方塊中的路徑。

    如果這些路徑不正確，請連絡 Microsoft 產品支援服務，取得協助以解決此問題。

  6. 針對每個儲存群組執行步驟 3 到 5，檢查資料庫路徑和交易記錄檔路徑是否正確。

  7. 檢查每個儲存群組的系統路徑和交易記錄檔路徑是否正確之後，請檢查每個儲存群組中每個儲存區的資料庫路徑。若要這樣做，請遵循下列步驟：

    1. 展開儲存群組。例如，展開 [預設儲存群組]。

    2. 在 [儲存區名稱] (伺服器名稱) 上按一下滑鼠右鍵，然後按一下 [內容]。

    3. 按一下 [資料庫] 索引標籤，然後檢查 [Exchange 資料庫] 方塊中顯示的路徑是否正確。接著，檢查 [Exchange 資料流資料庫] 方塊中顯示的路徑是否正確。

      如果某個路徑不正確，請連絡 Microsoft 產品支援服務，取得協助以解決此問題。

    4. 重複步驟 7b 和 7c，檢查每個儲存群組中的每個信箱儲存區 或公用資料夾儲存區的路徑是否正確。

  8. 裝載信箱儲存區或公用資料夾儲存區。

若要在 Exchange Server 2007 中確認並設定正確的檔案路徑

  1. 啟動 [Exchange 管理主控台]。按一下 [開始]，依序指向 [所有程式] 及 [Microsoft Exchange]，然後按一下 [Exchange 管理主控台]。

  2. 展開 [伺服器組態]，然後選取 [信箱]

  3. 在 [資料庫管理] 窗格中，選取包含無法裝載之資料庫的儲存群組。

  4. 在該儲存群組上按一下滑鼠右鍵，然後按一下 [內容]。

  5. 在 [一般] 索引標籤上，檢查 [記錄檔路徑] 和 [系統路徑] 位置中所列的路徑。

    如果這些路徑不正確，請在該儲存群組上按一下滑鼠右鍵，然後選取 [移動儲存群組路徑]。在 [記錄檔路徑] 和 [系統檔案路徑] 下，按一下 [瀏覽] 以尋找包含交易記錄檔或資料庫檔案的資料夾。根據預設，交易記錄檔或資料庫檔案位於下列資料夾：

    %PROGRAMFILES%\Microsoft\Exchange Server\Mailbox\<storage group name>

  6. 按一下 [確定]。

  7. 針對每個儲存群組執行步驟 3 到 5，檢查系統路徑和交易記錄檔路徑是否正確。

  8. 檢查每個儲存群組的系統路徑和交易記錄檔路徑是否正確之後，請檢查每個儲存群組中每個資料庫的資料庫路徑。若要這樣做，請遵循下列步驟：

    1. 展開儲存群組。例如，展開 [預設儲存群組]。

    2. 檢查 [資料庫管理] 窗格中 [資料庫檔案路徑] 下顯示的路徑是否正確。

    3. 如果某個路徑不正確，請在資料庫上按一下滑鼠右鍵，然後按一下 [移動資料庫路徑]。

    4. 按一下 [瀏覽] 以尋找資料庫檔案的正確資料夾。根據預設，Exchange 資料庫檔案 (.edb) 位於下列資料夾：

      %PROGRAMFILES%\Microsoft\Exchange Server\Mailbox\<storage group name>\<database name.edb>

    5. 按一下 [確定]。

    6. 遵循步驟 8b 到 8e，檢查每個儲存群組中的每個信箱或公用資料夾資料庫的路徑是否正確。

  9. 裝載信箱資料庫或公用資料夾資料庫。


MSExchangeIS 9519 (0xfffffbda)：遺失設定為預設系統地區設定的雙位元組字元集地區設定
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-01-23

Microsoft® Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一或多個具有錯誤碼 0xfffffbda 的 MSExchangeIS 9519 事件。此事件表示已安裝非英文的預設系統地區設定。安裝 Exchange Server 之後，會解除安裝預設的系統地區設定。

說明

如果錯誤碼為 0xfffffbda 的事件 MSExchangeIS 9519 觸發 Exchange 伺服器重新啟動，將不會裝載 Exchange 資料庫。此外，應用程式事件記錄檔中也會記錄錯誤事件 ESE 604 與 MSExchangeIS 9519。

如果您之前的預設系統地區設定是設定為非英文地區設定，可能會發生此狀況。如果您選擇其他地區設定做為預設系統地區設定、移除非英文地區設定，然後重新啟動 Exchange 2000 Server 或 Exchange Server 2003，就會發生此事件。

此事件也可能被識別為 -1062，JET_errInvalidLanguageId。此事件適用於下列 Exchange Server 版本：

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

使用者動作

若要解決這個問題，請重新安裝非英文的地區設定，或建立新的資料庫。如果重新安裝非英文的地區設定，不一定要將它設定為預設的系統地區設定。


MSExchangeIS 9519 (0xfffff05b)：在執行 Exchange Server 2000 SP3 或更新版本的伺服器上壓縮的資料庫或記錄檔
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-02-19

Microsoft Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一或多個具有錯誤碼 0xfffff05b 的 MSExchangeIS 9519 事件。此錯誤指出 Exchange 資料庫或交易記錄檔位在已啟用檔案系統壓縮的磁碟機上。

說明

如果 Exchange 2000 Server 包含使用 NTFS 檔案系統壓縮所壓縮的資訊儲存庫資料庫，則將 Exchange 2000 Server Service Pack 3 (SP3) 套用至此 Exchange 2000 Server 時，可能會發生此事件。將 Exchange 2000 Server 電腦升級至 Exchange Server 2003 時，也會發生此問題。Exchange 2000 Server SP3、Exchange Server 2003 以及 Exchange Server 2007 都會防止裝載壓縮的資訊儲存庫資料庫。

這個錯誤也可能被識別為 -4005，JET_errFileCompressed。此錯誤適用於下列 Exchange Server 版本：

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server SP3

使用者動作

若要解決這個問題，您必須解壓縮資訊儲存庫資料庫與記錄檔所在的資料夾，並重組資料庫，然後對資料庫與記錄檔所在的資訊儲存庫儲存群組執行線上 Exchange 感知備份。若要執行這項作業，請參閱 Microsoft 知識庫文件 - 327772＜將 SP3 套用至 Exchange 2000 之後無法裝載資料庫，且收到錯誤 0xfffff05b＞。


MSExchangeIS 9519 (0xfffffa84)：遺失或損毀的資料庫索引
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-01-22

Microsoft® Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一或多個具有錯誤碼 0xfffffa84 的 MSExchangeIS 9519 事件。此事件表示此資料庫的索引已損毀或遺失。

說明

下列原因會造成資料庫索引損毀或遺失：

  • 在您套用新版 Microsoft Windows Service Pack 後，進行 Exchange 資料庫的索引清理時，會發生這個問題。套用 Service Pack 後，您無法在 Exchange 伺服器中裝載信箱或公用資料夾資料庫。此外，應用程式事件記錄檔中也會記錄事件 ESE 609 與 ESE 611。

  • 在您執行資料庫修復作業 (eseutil /p) 後，會發生這個問題。這會移除首次建立資料庫時所產生的索引。執行 Eseutil 修復命令會移除索引。

這個錯誤也可能被識別為 -1404，JET_errIndexNotFound。此錯誤適用於下列 Exchange Server 版本：

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

使用者動作

若要解決這個問題，請依照稍早所述符合問題情況的解決方法操作：

  • 如果索引在您套用新版 Windows Service Pack 並進行 Exchange 資料庫的索引清理時損毀，請依照下列步驟操作：

    1. 從已知的良好備份還原受影響的信箱或公用資料夾資料庫。

    2. 執行 eseutil /d 針對受影響的資料庫執行離線磁碟重組。若需有關如何針對受影響的資料庫執行離線磁碟重組的資訊，請參閱下列主題：

      Exchange 2000 Server 與 Exchange Server 2003 資料庫：如何執行 Eseutil /D (磁碟重組) (英文)

      Exchange Server 2007 資料庫：如何執行 Eseutil /D (磁碟重組) (英文)

  • 如果索引在您執行資料庫修復 (eseutil /p) 作業時遺失，請套用微軟知識庫文件 -924627＜當您使用 Eseutil 與 Isinteg 公用程式修復 Exchange 2003 中的資料庫後嘗試裝載資料庫時，事件記錄中記錄了具有錯誤 0xfffffa84 的事件識別碼 9519＞中指定的 Hotfix。


MSExchangeIS 9519 0x972：公用資料夾容器已刪除，或遺失必要的屬性
Microsoft Exchange Server Analyzer - 文章 > 資料庫復原 >

主題上次修改日期： 2007-08-30

Microsoft Exchange 資料庫疑難排解員工具在應用程式記錄檔中偵測到一或多個錯誤碼為 0x972 的 MSExchangeIS 9519 事件。這表示公用資料夾資料庫裝載失敗，因為公用資料夾容器已刪除，或遺失所需要的屬性。

說明

若從 Active Directory 刪除公用資料夾容器，或者受影響的公用儲存區並未設定成使用公用資料夾容器，亦即公用資料夾容器 msExchOwningPFTreeBL 屬性的值未指向公用儲存區，就會發生此錯誤。此錯誤最可能的原因是包含公用資料夾容器的系統管理群組已遭刪除，但並沒有先將公用資料夾容器移到新的系統管理群組。

使用者動作

若要解決此問題，請使用 ADSI 編輯器或類似的工具，判定公用資料夾容器是否存在，以及 msExchOwningPFTreeBL 屬性是否正確地設定為指向相關的公用儲存區。

注意：
使用 ADSI 編輯器、LDP 工具或其他 LDAP 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或 Exchange Server 2007，或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
判定錯誤原因

  1. 使用 [ADSI 編輯器] 或類似的工具，在 Active Directory 中找出每個系統管理群組物件。

    系統管理群組物件位於：

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group

  2. 展開每個系統管理群組，並檢查 [CN=Folder Hierarchies] 容器是否存在。如果 [CN=Folder Hierarchies] 容器存在，請將該容器反白顯示，並確認右手邊的窗格中有 [CN=Public Folders] 物件存在。如果在任何系統管理群組下都沒有 [CN=Public Folders] 物件存在，請繼續到解決方案 1，重新建立資料夾階層及公用資料夾容器。如果有發現 [CN=Public Folders] 容器，請繼續到步驟 3。

  3. 在 [CN=Public Folders] 物件上按一下滑鼠右鍵，再按一下 [內容]。

  4. 在 [屬性] 清單中，選取 [msExchOwningPFTreeBL] 屬性，再按一下 [編輯]。

  5. 確定受影響的公用資料夾儲存區已顯示在 [值] 清單中。如果未列出，請繼續到解決方案 2。
解決方案 1：重新建立資料夾階層及公用資料夾容器

  1. 使用 [ADSI 編輯器] 或類似的工具，找到並展開 [Exchange Administrative Group (FYDIBOHF23SPDLT)]。

    [Exchange Administrative Group (FYDIBOHF23SPDLT)] 物件位於：

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups

  2. 在 [Exchange Administrative Group (FYDIBOHF23SPDLT)] 物件上按一下滑鼠右鍵，再依序按一下 [新增] 及 [物件]。

  3. 從 [選取類別] 清單中選取 [msExchPublicFolderTreeContainer]，再按 [下一步]。

  4. 針對 [值] 方塊，輸入 [資料夾階層]，再依序按 [下一步] 及 [完成]。

  5. 在新建立的 [資料夾階層] 物件上按一下滑鼠右鍵，再依序按一下 [新增] 及 [物件]。

  6. 從 [選取類別] 清單中選取 [msExchPFTree]，再按 [下一步]。

  7. 針對 [值] 方塊，輸入 [公用資料夾]，再依序按 [下一步] 及 [完成]。

  8. 按一下 [其他屬性]。

  9. 從 [選取內容來檢視] 下拉式清單，按一下 [msExchPFTree]。

  10. 針對 [編輯屬性] 方塊，輸入 1，再依序按一下 [設定]、[確定] 及 [完成]。

  11. 要將公用資料夾容器指派給每個公用儲存區，請在 [公用資料夾] 容器上按一下滑鼠右鍵，再選取 [內容]。

  12. 從 [屬性] 清單，選取 [distinguishedName]，然後按一下 [編輯]。

  13. 將 [值] 方塊的內容複製到剪貼簿，再按一下 [取消]。

  14. 針對每一台出現 MSExchangeIS 9519 事件並具有錯誤碼 0x972 的伺服器，瀏覽到公用資料夾儲存區物件。此物件的預設位置是：

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups, CN=Exchange Administrative Group (FYDIBOHF23SPDLT), CN=Servers, CN= ServerName , CN= InformationStore , CN=Second Storage Group。

  15. 在 [公用資料夾儲存區] 物件上按一下滑鼠右鍵，再按一下 [內容]。

  16. 從 [屬性] 清單，選取 [msExchOwningPFTree]，然後按一下 [編輯]。

  17. 將步驟 13 中複製到剪貼簿的值貼到 [值] 方塊，然後按兩次 [確定] 完成作業。

  18. 針對每一台出現 MSExchangeIS 9519 事件並具有錯誤碼 0x972 的伺服器，重複步驟 15 到 17。

  19. 在受影響的伺服器上重新啟動 Microsoft Exchange Information Store 服務。

解決方案 2：重新填入公用資料夾容器物件的 msExchOwningPFTreeBL 屬性值

  1. 使用 [ADSI 編輯器] 或類似工具，在 Active Directory 中找到 [公用資料夾] 物件。

    [公用資料夾] 物件位於：

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Folder Hierarchies,CN=Public Folders

  2. 在 [公用資料夾] 容器上按一下滑鼠右鍵，然後選取 [內容]。

  3. 從 [屬性] 清單，選取 [distinguishedName]，然後按一下 [編輯]。

  4. 將 [值] 方塊的內容複製到剪貼簿，再按一下 [取消]。

  5. 針對每一台出現 MSExchangeIS 9519 事件並具有錯誤碼 0x972 的伺服器，瀏覽到公用資料夾儲存區物件。此物件的預設位置是：

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups, CN=Exchange Administrative Group (FYDIBOHF23SPDLT), CN=Servers, CN= ServerName , CN= InformationStore , CN=Second Storage Group。

  6. 在 [公用資料夾儲存區] 物件上按一下滑鼠右鍵，再按一下 [內容]。

  7. 從 [屬性] 清單，選取 [msExchOwningPFTree]，然後按一下 [編輯]。

  8. 將步驟 4 中複製到剪貼簿的值貼到 [值] 方塊，然後按兩次 [確定] 完成作業。

  9. 針對每一台出現 MSExchangeIS 9519 事件並具有錯誤碼 0x972 的伺服器，重複步驟 6 到 8。

  10. 在受影響的伺服器上重新啟動 Microsoft Exchange Information Store 服務。


Exchange 叢集
Microsoft Exchange Server Analyzer - 文章 >

主題上次修改日期： 2005-11-18

本節中的文章詳細說明 Microsoft® Exchange Server Analyzer 工具會評估 Exchange 叢集的哪些方面。此外，這些文章也說明您可以採取哪些動作來解決 Exchange Server Analyzer 所發現的 Exchange 叢集相關錯誤、警告及非預設的組態。


已啟用叢集偵錯功能
Microsoft Exchange Server Analyzer - 文章 > Exchange 叢集 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定伺服器上是否已啟用叢集偵錯功能：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Cluster\Debug

如果 Exchange Server Analyzer 發現 Debug 值等於 1，就會顯示警告。

具有此登錄值的叢集偵錯功能，會使叢集資源無法在節點間進行容錯移轉。您應只有在需要進行問題偵錯，而不想進行資源容錯移轉時，才使用此登錄值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要停用叢集偵錯登錄機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽到 HKLM\Software\Microsoft\Exchange\Cluster。

  3. 將 Debug 值變更為 0。

  4. 結束登錄編輯程式。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Exchange 叢集的詳細資訊，請參閱《Exchange 2003 Server 系統管理手冊》(http://go.microsoft.com/fwlink/?LinkId=47617) 中的主題＜在 Exchange Server 2003 中管理 Exchange 叢集＞(英文)。


叢集固定活動訊號網路優先順序未正確設定
Microsoft Exchange Server Analyzer - 文章 > Exchange 叢集 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Exchange 伺服器叢集內之每個網路介面資源的優先順序：

HKEY_LOCAL_MACHINE\Cluster\Networks\<NetworkInterfaceGUID>\Priority

Priority 的值指出為網路介面資源設定的網路優先順序。此值為 1 表示網路介面資源的優先順序是最高、此值為 2 表示網路介面資源的優先順序是次高，以此類推。

Exchange Server Analyzer 也會讀取下列登錄項目，以判定 Exchange 伺服器叢集中每個網路的角色定義：

HKLM\Cluster\Networks\<NetworkInterfaceGUID>\Role

值為 1 表示網路資源被設定為專用的私人 (活動訊號) 網路。值為 2 表示網路資源被設定為專用的公用網路 (用戶端存取)。值 3 表示網路資源已設定為混合式網路，可同時允許活動訊號流量及用戶端存取流量。

如果 Exchange Server Analyzer 判定 Role 值為 1 的網路介面資源具有大於 1 的 Priority 值，就會顯示一則警告。此警告表示已找到固定活動訊號網路，但它的網路優先順序未正確設定。

設定專用的私人網路以使用於叢集活動訊號，是對所有 Exchange Server 叢集建議的最佳作法。節點之間的通訊對於平順的叢集作業來說非常重要。請使用下列指示，正確設定固定活動訊號網路的網路優先順序。

若要更正此警告

  1. 開啟 [叢集系統管理員]，並連線至 Exchange 伺服器叢集。

  2. 在左窗格中，在階層頂端的 [叢集] 物件上按一下滑鼠右鍵，然後再按 [內容]。

  3. 按一下 [網路優先順序]。

  4. 選取固定的活動訊號網路資源。

  5. 按一下 [上移]，直到固定的活動訊號網路資源出現在網路資源清單的頂端。

  6. 按一下 [確定]。

若需有關叢集活動訊號網路的詳細資訊，請參閱下列微軟知識庫文件：

  • 258750＜叢集伺服器上建議使用的私人「活動訊號」(Heartbeat) 設定＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)

  • 307962＜啟用叢集活動訊號的多點傳送支援＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307962)

若需其他詳細資料，請檢閱《Exchange Server 2003 叢集組態核取清單》(英文) (http://go.microsoft.com/fwlink/?linkid=36083)。


叢集節點的 Windows 組建編號與第一個節點不符
Microsoft Exchange Server Analyzer - 文章 > Exchange 叢集 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定叢集中每一個節點上執行之 Microsoft Windows® 作業系統的核心版本：

HKEY_LOCAL_MACHINE\Cluster\Nodes\<Node Number>\BuildNumber

如果 Exchange Server Analyzer 發現 Exchange 叢集中第二個節點或後續節點上的 BuildNumber 值與 Exchange 叢集中第一個節點上的 BuildNumber 值不同，就會顯示一則錯誤。

如果 Exchange 叢集在不同版本的 Windows 中執行，可能不會如原先的預期或所做的設定發生容錯移轉。在最典型的混合 Windows 環境中，只有從舊版作業系統到新版作業系統才會發生容錯移轉 (例如，從 Windows 2000 Advanced Server 到 Windows Server™ 2003 Enterprise Edition)。從新版作業系統到舊版作業系統不會發生容錯移轉 (例如，從 Windows Server 2003 到 Windows 2000 Server)。

若要解決這個問題，必須將所有節點升級為相同的作業系統和 Service Pack。若要將停機時間降到最低，可以針對您的叢集執行輪流升級。

若要更正此錯誤

  1. 請閱讀微軟知識庫文件 - 811272＜如何執行 Windows Server 2003 伺服器叢集的輪流升級＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=811272)，以檢閱執行叢集輪流升級的指示。

  2. 檢閱文件＜Windows 2000 叢集：執行輪流升級＞(英文) (http://go.microsoft.com/fwlink/?linkid=1718)。

  3. 對於其 BuildNumber 值與叢集中的第一個節點不同的每一個節點，執行輪流升級。

若需有關替代程序的詳細資訊，請參閱＜輪流升級的替代方案＞(英文) (http://go.microsoft.com/fwlink/?LinkId=41363)。


叢集節點 Windows Service Pack 版本與第一個節點不符
Microsoft Exchange Server Analyzer - 文章 > Exchange 叢集 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定安裝於叢集中每個節點上的 Microsoft Windows® Service Pack 版本：

HKEY_LOCAL_MACHINE\Cluster\Nodes\<Node Number>\CSDVersion

如果 Exchange Server Analyzer 發現 Exchange 叢集中第二個或後續節點的 CSDVersion 值，不同於 Exchange 叢集中第一個節點的 CSDVersion 值，就會顯示一則錯誤。

這個錯誤表示此 Exchange 叢集中的節點不是執行相同層級的 Windows Service Pack。建議的最佳作法是 Exchange 叢集中的所有節點都執行相同層級的作業系統與 Service Pack。

若要解決這個問題，必須將所有節點升級為相同的作業系統和 Service Pack。若要將停機時間降到最低，可以針對您的叢集執行輪流升級。

若要更正此警告

  1. 請閱讀微軟知識庫文件 - 811272＜如何執行 Windows Server 2003 伺服器叢集的輪流升級＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=811272)，以檢閱執行叢集輪流升級的指示。

  2. 檢閱文件＜Windows 2000 叢集：執行輪流升級＞(英文) (http://go.microsoft.com/fwlink/?linkid=34288)。

  3. 對於其 CSDVersion 值不同於叢集中第一個節點的每個節點，執行復原升級。

若需有關替代程序的詳細資訊，請參閱＜輪流升級的替代＞(英文) (http://go.microsoft.com/fwlink/?linkid=34289)。


叢集 TEMP/TMP 路徑與系統磁碟分割位於相同的磁碟機上
Microsoft Exchange Server Analyzer - 文章 > Exchange 叢集 >

主題上次修改日期： 2005-11-18

在非叢集式 Exchange Server 電腦上，Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 TEMP 及 TMP 環境變數的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

HKLM\System\CurrentControlSet\Control\Session Manager\Environment\TMP

當 Exchange Server Analyzer 對 Microsoft Windows® 伺服器叢集中的 Exchange 虛擬伺服器 (EVS) 執行時，不會讀取 HKLM 登錄區。相反的，它會讀取下列登錄項目：

HKEY_USERS\<Cluster service account SID>\Environment\TEMP

HKEY_USERS\<Cluster service account SID>\Environment\TMP

如果 Exchange Server Analyzer 發現 TEMP 及/或 TMP 環境變數的開頭為 %SYSTEMROOT，則會顯示警告訊息。

在不同作業期間 (例如郵件轉換及信箱移動作業)，Microsoft Exchange Information Store 服務處理程序會使用 TEMP 及 TMP 資料夾作為暫時儲存區。在非叢集的 Exchange 伺服器上，Microsoft Exchange Information Store 服務會使用 SYSTEM (例如，Local System)，而 SYSTEM 會對 TEMP 及 TMP 使用預設環境變數設定 %Systemroot%\Temp。

在 Windows 伺服器叢集中執行的 EVS 會使用叢集服務帳戶的環境變數設定，而此帳戶是在特定使用者安全性原則的內容下執行。對於使用者帳戶來說，TEMP 及 TMP 的預設環境變數是設定為 %Userprofile%\temp。

TEMP 與 TMP 環境變數用於指定需要臨時工作區的應用程式應該使用檔案系統中的哪個資料夾 (例如，哪個路徑)。TEMP 通常是由應用程式 (如 Exchange) 來使用，而 TMP 通常是由程式開發工具 (如 Microsoft Visual C++®) 來使用。每一個變數的路徑通常相對於應用程式或工具的安全性範圍。

為達到最佳效能，建議您不要使用含有 Exchange 所使用的 TEMP 及 TMP 資料夾的作業系統的磁碟。此外，您應該確定這些環境變數是設定為快速磁碟或磁碟子系統上的路徑，例如 RAID 0+1 Spindle Set。也建議您不要使用含有作業系統的磁碟來提供 Exchange 或 EVS 所用的 TEMP 及 TMP 資料夾。

若要更正此警告

  1. 以叢集服務帳戶登入叢集中的一個節點。

  2. 在 [我的電腦] 上按一下滑鼠右鍵，然後選取 [內容]。

  3. 選取 [進階]。

  4. 按一下 [環境變數]。

  5. 在 [<account name]> 的使用者變數] 區域中，選取 TEMP 再按一下 [編輯]。

  6. 在 [變數值] 欄位中，輸入 TEMP 環境變數的新路徑，然後按一下 [確定]。

  7. 在 [<account name> 的使用者變數] 區域中，選取 TMP 再按一下 [編輯]。

  8. 在 [變數值] 欄位中，輸入 TMP 環境變數的新路徑，然後按一下 [確定]。

  9. 按一下 [確定] 以關閉 [環境變數] 對話方塊，再按一下 [確定] 以關閉 [系統內容] 對話方塊。

  10. 重新啟動節點以套用變更。

  11. 針對叢集中的每個節點，重複步驟 1 至 10。

若需在非叢集的 Exchange Server 電腦上變更 TEMP/TMP 環境變數的相關資訊，請參閱 TEMP/TMP 變數會指向無效或不適當的資料夾。


找不到固定的叢集活動訊號
Microsoft Exchange Server Analyzer - 文章 > Exchange 叢集 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Exchange 伺服器叢集中為每個網路介面資源定義的角色：

HKEY_LOCAL_MACHINE\Cluster\Networks\<NetworkInterfaceGUID>\Role

值為 1 表示網路資源被設定為專用的私人 (活動訊號) 網路。值為 2 表示網路資源被設定為專用的公用網路 (用戶端存取)。值 3 表示網路資源已設定為混合式網路，可同時允許活動訊號流量及用戶端存取流量。

Exchange Server Analyzer 會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定叢集服務 (ClusSvc) 的 Started 機碼值。True 值表示叢集服務已啟動，而 False 值表示叢集服務未執行。

如果 Exchange Server Analyzer 在設為專用私人網路的 Exchange 叢集中找不到網路資源，就會顯示一則警告。

設定專用的私人網路以使用於叢集活動訊號，是對所有 Exchange Server 叢集建議的最佳作法。節點之間的通訊對於平順的叢集作業來說非常重要。您必須設定用於叢集通訊效能最佳的網路，並遵循所有硬體相容性清單需求。若為網路組態，則二個或以上的獨立網路必須連接叢集的節點，以避免單一點失敗。一般是使用兩個區域網路。Microsoft 產品支援服務不支援含有只透過一個網路來進行連線之節點的叢集組態。

若要更正此警告

  1. 如果不存在，請將網路介面卡新增到 Exchange 叢集的每個節點中，並在叢集系統管理員中，將網路介面卡設為私人網路。

  2. 如果其他網路介面卡存在，但已用於混合網路，則應重新設定適當的網路來修改組態，以當作固定私人網路。

若需叢集活動訊號網路的詳細資訊，請參閱下列微軟知識庫文件：

  • 258750＜叢集伺服器上建議使用的私人「活動訊號」(Heartbeat) 設定＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)

  • 307962＜啟用叢集活動訊號的多點傳送支援＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307962)

若需其他詳細資料，請檢閱文件《Exchange Server 2003 叢集組態核取清單》(英文) (http://go.microsoft.com/fwlink/?linkid=36083)。


cluster.log 的預設檔案大小應增加到 32 MB
Microsoft Exchange Server Analyzer - 文章 > Exchange 叢集 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已設定 ClusterLogSize 參數：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment\

若 Exchange Server Analyzer 發現 ClusterLogSize 的值不存在，或 ClusterLogSize 的值等於或小於 8，就會顯示警告。在忙碌的叢集上，cluster.log 檔輪替的速度非常快，因此，當您在下列情況下疑難排解容錯移轉問題時，可能已遺失所需項目：

  • 進行疑難排解需要詳細檢閱叢集記錄檔。

  • 叢集正在管理許多資源。

因此，當疑難排解需要使用 cluster.log 檔案時，請建立 ClusterLogSize 參數 (若參數尚未存在的話)，並將預設大小至少增加到 32、64 或 96。

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要建立 ClusterLogSize 參數並設定其值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedit32.exe。

  2. 瀏覽至： HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment.

  3. 在左窗格中，按一下 [環境]。

  4. 在 [編輯] 功能表中，指向 [新增]，然後按一下 [DWORD 值]。

  5. 鍵入 ClusterLogSize，然後按 ENTER 鍵，以命名新的登錄項目。

  6. 以滑鼠右鍵按一下 ClusterLogSize，然後按 [修改]。

  7. 將 ClusterLogSize [數值資料] 修改為新的記錄檔大小。例如，將 ClusterLogSize 值修改為 32、64 或 96，然後按 ENTER 鍵。

  8. 結束登錄編輯程式
若要修改 cluster.log 檔的預設大小

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment.

  3. 以滑鼠右鍵按一下 ClusterLogSize，然後按 [修改]。

  4. 將 ClusterLogSize [數值資料] 修改為新的記錄檔大小。例如，將 ClusterLogSize 值修改為 32、64 或 96，然後按 ENTER 鍵。

  5. 結束登錄編輯程式。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需 Microsoft 叢集伺服器中的叢集登入之相關資訊，請參閱微軟知識庫文件 - 168801＜如何開啟 Microsoft 叢集伺服器中的叢集登入＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=168801)


為 SMTP 啟用 Kerberos 驗證
Microsoft Exchange Server Analyzer - 文章 > Exchange 叢集 >

主題上次修改日期： 2006-05-12

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定安裝在 Windows™ Server 2003 叢集服務上的 Microsoft Exchange Server 2003 伺服器是否有將伺服器的完整網域名稱 (FQDN)，作為 servicePrincipalName 屬性上的 SMTPSVC 資源值。

如果 Exchange Server Analyzer 發現叢集服務上之 SMTPSVC Exchange 資源的 servicePrincipalName 屬性，並未將伺服器的 FQDN 作為其值，便會顯示最佳作法訊息。

最佳作法是在執行 Exchange Server 2003 的 Windows Server 2003 叢集伺服器上，為 Simple Mail Transfer Protocol (SMTP) 服務啟用 Kerberos 驗證。您可以用手動方式為 SMTPSVC Exchange 資源設定新的服務主要名稱 (SPN) 值。

依預設，Windows Server 2003 會使用 NTLM 驗證。Kerberos 通訊協定比 NTLM 更具有彈性與效率，也更加安全。使用 Kerberos 驗證能得到的好處如下：

  • 更快的連線速度。使用 NTLM 驗證時，應用程式伺服器必須連接網域控制站才能驗證每個用戶端。使用 Kerberos 驗證時，伺服器不必尋找網域控制站。伺服器可以檢查用戶端提出的認證來驗證該用戶端。用戶端只要取得特定伺服器的認證一次，便能在整個網路登入工作階段期間重複使用這些認證。

  • 互相驗證。NTLM 可讓伺服器驗證其用戶端的身分。NTLM 不會讓用戶端驗證伺服器的身分，也不會讓某個伺服器驗證另一個伺服器的身分。NTLM 驗證的設計是針對當中的伺服器均假設為真的網路環境。Kerberos 通訊設定並不那樣假設。位於網路連線兩端的雙方可以知道位在另一端的就是它所自稱的對象。

  • 委派驗證。當 Windows 服務代表用戶端存取資源時，它們會模擬用戶端。通常，服務可以存取本機電腦上的資源，為用戶端完成其工作。NTLM 及 Kerberos 都提供了服務必須具備的資訊，以在本機模擬其用戶端。但是，有些分散式應用程式的設計，使得前端服務必須在連接另一台電腦上的後端服務時模擬用戶端。Kerberos 通訊協定具有 Proxy 機制，此機制能讓服務在連接其他服務時模擬其用戶端。NTLM 沒有相等功能可用。

若要解決此問題，請遵循下列步驟，為受影響的屬性新增遺漏的值。

使用 SETSPN.exe 工具，新增有遺漏值的 SPN。

  1. 安裝 Setspn.exe 工具。若要取得 Setspn.exe 工具，請參閱＜Windows 2000 Resource Kit Tool :Setspn.exe＞(http://go.microsoft.com/fwlink/?LinkId=28103)。

    Windows Server 2003 版的 Setspn.exe 命令列工具可在 Windows Server 2003 CD 所包含的 Windows Server 2003 Support Tools 中取得。若要安裝 Server 2003 Support Tools，請在 Support/Tools 資料夾中連按兩下 Suptools.msi 檔案。

  2. 請遵循 SETSPN.EXE Setspn_d.txt 檔案中的引導，將遺漏的值新增至 Exchange 伺服器的 Active Directory 物件。下列範例示範如何為虛擬 SMTP 伺服器 SPN 新增 FQDN 值：

    • 啟動命令提示字元，然後切換至 Setspn.exe 的安裝目錄。

    • 在命令提示字元下，輸入下列命令：

      setspn.exe-a SMTPSVC/ mail.yourdomain.com YOURSERVERNAME

      附註：
      將 mail.yourdomain.com 取代為 SMTP 虛擬伺服器 FQDN，並將 YOURSERVERNAME 取代為 Exchange 伺服器的名稱。
    • 然後按 Enter 鍵。


無法連絡 Exchange 叢集節點
Microsoft Exchange Server Analyzer - 文章 > Exchange 叢集 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定叢集服務 (ClusSvc) 的 Started 機碼值。True 值表示叢集服務已啟動，而 False 值表示叢集服務未執行。

Exchange Server Analyzer 也會讀取下列登錄項目，以判定在 Exchange Server 電腦上執行的 Windows 版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 值為 4.0 表示電腦正在執行 Microsoft Windows NT® Server 4.0。值 5.0 表示電腦正在執行 Windows 2000 Server，而值 5.2 則表示電腦正在執行 Windows Server™ 2003。

如果 Exchange Server Analyzer 無法判定在叢集中執行的 Windows 版本，或 Exchange Server Analyzer 無法判定叢集服務是否在執行中，就會顯示一則錯誤。此錯誤表示 Exchange Server Analyzer 無法連絡 Exchange Server 叢集中的節點。

若要更正此錯誤

  1. 確定 Exchange Server 電腦已經啟動，並且已連線到網路。

  2. 使用 ping 命令，看看是否可以連上 Exchange Server 電腦。

  3. 如果安裝有防火牆，請檢查遠端程序呼叫 (RPC) 通訊埠是否被封鎖。

  4. 確定已啟動 Exchange Server 電腦上的 Remote Registry 服務。

  5. 檢查執行 Exchange Server Analyzer 的帳戶之權限，以確定該帳戶有足夠權限來讀取 Exchange Server 電腦上的登錄。

若需有關疑難排解網路連線問題的詳細資訊，請參閱微軟知識庫文件 - 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。


Active Directory 中的 Exchange 資料路徑不符合叢集登錄
Microsoft Exchange Server Analyzer - 文章 > Exchange 叢集 >

主題上次修改日期： 2006-04-28

Microsoft® Exchange Server Analyzer 工具會同時查詢叢集登錄 (HKEY_LOCAL_MACHINE\Cluster) 及 Active Directory® 目錄服務，以判定 Exchange 資料檔案 (例如，郵件追蹤記錄檔) 的路徑在這兩個位置是否相同。使用 Exchange 安裝程式將 Exchange 安裝在 Microsoft Windows® 伺服器叢集中的節點時，Exchange Server 會在登錄與 Active Directory 中設定這些值。

由 Exchange 安裝程式所建立並由 Exchange Server Analyzer 所讀取的登錄值為：

HKLM\Cluster\Resources\<資訊儲存庫資源的資源 GUID>\Parameters\DestPath

由 Exchange 安裝程式所建立並由 Exchange Server Analyzer 所讀取的 Active Directory 值為：msExchDataPath。此值是 Active Directory 中 Exchange Server 電腦物件的屬性，會出現在下列位置：

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN= OrganizationName =Administrative Groups, CN= AdministrativeGroupName , CN=Servers, CN= ServerName

如果 Exchange Server Analyzer 發現 DestPath 與 msExchDataPath 的值不相符，則會顯示錯誤訊息。

這些值不同的常見原因，就是在 Exchange 進入生產環境之後，某些或所有 Exchange 資料檔案的位置發生變更。例如，如果硬體已升級、郵件追蹤記錄檔已移動、磁碟機代號已變更，此類變更只會反映在叢集登錄中，但不會反映在 Active Directory 中。在執行此類變更之後，可能會導致服務啟動錯誤、資料庫裝載問題及其他問題，特別是在套用 Exchange Service Pack 或安裝彙總套件時。

附註：
您應該儘快解決這個差異。在更正此問題之前，請勿對 Exchange Server 安裝任何 Service Pack 或更新。

若要執行下列程序，您必須使用 Active Directory 編輯程式 (如 [Active Directory Service Interfaces (ADSI) 編輯器] 或 LDP (ldp.exe) 工具)。

注意：
使用 ADSI 編輯器、LDP 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要更正此錯誤

  1. 修改受影響之 Exchange 虛擬伺服器 (EVS) 的 msExchDataPath 值，使其符合叢集登錄中的 DestPath 值。msExchDataPath 屬性可以在以下位置找到：CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName=Administrative Groups, CN=AdministrativeGroupName, CN=Servers, CN=ServerName

  2. 重新啟動虛擬伺服器的 Exchange System Attendant 資源，讓變更生效。

若需有關使用 LDP 工具修改 Active Directory 的詳細資訊，請參閱微軟知識庫文件 - 260745＜XADM：使用 LDP 公用程式修改 Active Directory 物件屬性＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260745)。

若需有關如何使用 [ADSI 編輯器] 修改 msExchDataPath 屬性的詳細資訊，請參閱知識庫文件 - 288362＜XADM：Microsoft Exchange System Attendant 已記載事件識別碼 5007 訊息「系統找不到所指定的路徑」＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=288362)。


已啟用事件日誌複寫
Microsoft Exchange Server Analyzer - 文章 > Exchange 叢集 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取屬於叢集節點之每部伺服器的下列登錄項目：

HKEY_LOCAL_MACHINE\Cluster\Nodes\X\EnableEventLogReplication

附註：
X 是節點數，從 1 開始。

如果 Exchange Server Analyzer 發現 EnableEventLogReplication 的值為 1，就會顯示最佳作法的訊息。

如果 EnableEventLogReplication 登錄項目設為 1，則叢集節點會將事件日誌中的事件複寫到叢集中的所有其他節點。如果啟用事件日誌複寫，則如 Microsoft Operations Manager (MOM) 等監視多個伺服器的工具會多次報告單一事件 (一個節點一次)。若您使用自動監視，建議您停用叢集節點上的事件日誌複寫。

停用叢集中所有節點的事件日誌複寫

  1. 以網域使用者帳戶或屬於全域群組成員的帳戶登入叢集中的任何節點。

  2. 依序按一下 [開始]、[執行]，然後輸入

    cluster /prop EnableEventLogReplication=0
停用單一叢集節點的事件日誌複寫

  1. 以網域使用者帳戶或屬於全域群組成員的帳戶登入叢集中的任何節點。

  2. 依序按一下 [開始]、[執行]，然後輸入

    Cluster <name of node to disable> /prop EnableEventLogReplication=0

若需有關設定事件日誌複寫的詳細資訊，請參閱微軟知識庫文件 - 224969＜如何在 Windows 2000 叢集伺服器中設定事件記錄檔複寫＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224969)。

若需有關管理伺服器叢集的詳細資訊，請參閱＜管理伺服器叢集＞(英文) (http://go.microsoft.com/fwlink/?LinkId=45971)。


對網路名稱資源停用了 Kerberos
Microsoft Exchange Server Analyzer - 文章 > Exchange 叢集 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定在伺服器上執行的 Microsoft Windows® 作業系統版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 值為 4.0 表示電腦正在執行 Windows NT® Server 4.0。值 5.0 表示電腦正在執行 Windows 2000 Server 作業系統，而值 5.2 則表示電腦正在執行 Windows Server™ 2003 作業系統。

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定物件類別為 msExchExchangeServer 之所有物件的 serialNumber 屬性值。如果字串值包含 "Version 5.5"，則表示電腦正在執行 Exchange Server 5.5。如果字串值包含 "Version 6.0"，則表示電腦正在執行 Exchange 2000 Server。如果字串值包含 "Version 6.5"，則表示電腦正在執行 Exchange Server 2003。

最後，Exchange Server Analyzer 會讀取下列登錄值，以判定執行 Exchange Server 的叢集是否具有已啟用 Kerberos 功能的「網路名稱」叢集資源：

HKLM\Cluster\Resources\<Resource GUID for Network Name resource>\Parameters\RequireKerberos

RequireKerberos 的值為 0 表示網路名稱資源沒有啟用 Kerberos 功能，值為 1 表示網路名稱資源已啟用 Kerberos 功能。

如果 Exchange Server Analyzer 發現，在 Windows Server 2003 伺服器型叢集中執行的 Exchange Server 2003 虛擬伺服器上，RequireKerberos 的值設為 0，就會顯示警告。

這個警告表示 Exchange Server 2003 沒有使用具有 Kerberos 功能的「網路名稱」叢集資源。這種組態並不受支援，並且應該立即更正。

若要更正此警告

  1. 開啟 [叢集系統管理員] 程式。

  2. 使「網路名稱」資源離線。這麼做也會使所有與「網路名稱」資源相依的資源離線，包括 Microsoft Exchange System Attendant 資源。

  3. 用滑鼠右鍵按一下「網路名稱」資源，再按一下 [內容]。

  4. 在 [參數] 索引標籤上，按一下 [啟用 Kerberos 驗證] 選項，再按一下 [確定]。

  5. 使「網路名稱」資源上線，然後使其餘離線的資源上線。

若需有關在 Windows Server 2003 叢集中使用具有 Kerberos 功能之網路名稱資源的詳細資訊，請參閱微軟知識庫文件 - 302389＜Windows Server 2003 中叢集網路名稱資源的內容說明＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=302389)。

若需有關叢集的詳細資訊，請參閱下列主題：

  • 《Exchange Server 2003 部署手冊》(http://go.microsoft.com/fwlink/?linkid=21768) 中的＜在叢集中部署 Exchange Server 2003＞(英文)

  • 《Exchange Server 2003 高可用性手冊》(http://go.microsoft.com/fwlink/?linkid=47571) 中的＜規劃 Exchange 叢集＞(英文)


網路名稱資源已啟用 Kerberos
Microsoft Exchange Server Analyzer - 文章 > Exchange 叢集 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定在伺服器上執行的 Microsoft Windows® 作業系統版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 值為 4.0 表示電腦正在執行 Windows NT® Server 4.0。值 5.0 表示電腦正在執行 Windows 2000 Server 作業系統，而值 5.2 則表示電腦正在執行 Windows Server™ 2003 作業系統。

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定物件類別為 msExchExchangeServer 之所有物件的 serialNumber 屬性值。如果字串值包含 "Version 5.5"，則表示電腦正在執行 Exchange Server 5.5。如果字串值包含 "Version 6.0"，則表示電腦正在執行 Exchange 2000 Server。如果字串值包含 "Version 6.5"，則表示電腦正在執行 Exchange Server 2003。

最後，Exchange Server Analyzer 會讀取下列登錄值，以判定執行 Exchange 的叢集是否具有已啟用 Kerberos 功能的網路名稱叢集資源：

HKLM\Cluster\Resources\<Resource GUID for Network Name resource>\RequireKerberos

RequireKerberos 的值為 0 表示網路名稱資源沒有啟用 Kerberos 功能，值為 1 表示網路名稱資源已啟用 Kerberos 功能。

如果 Exchange Server Analyzer 發現，在 Windows 2000 Server 伺服器型叢集中執行的 Exchange 2000 Server 虛擬伺服器上，RequireKerberos 的值設為 1，就會顯示警告。

這個警告表示 Exchange 2000 Server 虛擬伺服器使用了已啟用 Kerberos 功能的網路名稱叢集資源。這種組態並不受支援，並且應該立即更正。如微軟知識庫文件 - 235529＜Windows 2000 網域環境中的 MSCS 虛擬伺服器限制＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=235529) 所述，不支援 Exchange 2000 Server 網路名稱資源的 Kerberos 驗證。尚未測試 Exchange 2000 Server 來證實叢集的 Exchange 2000 Server 虛擬伺服器支援 Kerberos 驗證功能。

若要更正此警告

  1. 在叢集中的任何節點上開啟命令提示字元。

  2. 執行下列命令：cluster res "Name of Network Name Resource" /priv requirekerberos=0:dword

    附註：
    資源名稱應以引號括住。

  3. 使網路名稱資源離線，並刪除它。

  4. 開啟 [Active Directory 使用者及電腦]。

  5. 尋找所刪除之網路名稱資源的電腦帳戶物件，並從 Active Directory 中刪除它。

  6. 為此 Exchange 虛擬伺服器 (EVS) 建立一個新的網路名稱資源，且不要讓它啟用 Kerberos 功能。您可以使用與您在步驟 3 中刪除之網路名稱資源相同的名稱和組態。

  7. 使新的網路名稱資源上線，然後使 EVS 中的其餘資源上線。

若需有關在 Windows 2000 Server 叢集中使用已啟用 Kerberos 功能之網路名稱資源的詳細資訊，請參閱微軟知識庫文件 - 235529＜Windows 2000 型伺服器叢集上的 Kerberos 支援＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=235529)。


MSDTC 似乎不在叢集中
Microsoft Exchange Server Analyzer - 文章 > Exchange 叢集 >

主題上次修改日期： 2006-04-20

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Microsoft Distributed Transaction Coordinator (MSDTC) 資源是否存在於叢集中：

HKEY_LOCAL_MACHINE\Cluster\Resources\

如果 ClusterMSDTCInstance 的值是 0，則 Exchange Server Analyzer 會顯示警告。

MSDTC 資源必須存在於 Exchange Server 叢集中，才能支援初始安裝及 Service Pack 升級。不過，它不是重要的元件，因此當 Exchange 執行時，不需要它。

您或組織中的另一個系統管理員可能已移除 MSDTC 資源，因為您知道當 Exchange 執行時，不需要它。

不過，建議您不要在初始安裝 Exchange Server 2003 之後移除 MSDTC 資源。如果將 MSDTC 資源保留在叢集中，您將能夠執行 Service Pack 安裝及其他更新。

若要解決這個警告，請建立新的 MSDTC 資源。若需如何建立 MSDTC 資源的特定步驟，請參閱《Exchange Server 2003 部署手冊》(http://go.microsoft.com/fwlink/?LinkId=47569) 的＜在叢集中部署 Exchange Server 2003＞中的＜如何在 Windows Server 2003 中安裝 Microsoft Distributed Transaction Coordinator＞(英文)。

詳細資訊

若需有關 MSDTC 及 Exchange 的詳細資訊，請參閱《Exchange Server 2003 高可用性手冊》(http://go.microsoft.com/fwlink/?LinkId=47571) 的＜瞭解 Exchange Server 2003 叢集＞中的＜叢集群組＞(英文)。

若需有關如何在 Microsoft Windows Server™ 2003 中新增 MSDTC 資源的詳細資訊，請參閱微軟知識庫文件 - 301600＜如何在 Windows Server 2003 叢集上設定 Microsoft Distributed Transaction Coordinator＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301600)。

附註：
知識庫文件 301600 包括對下列文件的參照 - 817064＜如何在 Windows Server 2003 中啟用網路 DTC 存取＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=817064)。它是 Exchange Server 安全性最佳作法，不對 Exchange 叢集啟用網路 DTC 存取。如果要為 Exchange 叢集設定 Distributed Transaction Coordinator 資源，請不要啟用網路 DTC 存取。


MSDTC 中斷會影響叢集群組
Microsoft Exchange Server Analyzer - 文章 > Exchange 叢集 >

主題上次修改日期： 2006-03-16

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定您是否已設定 Microsoft Distributed Transaction Coordinator (MSDTC) 資源的失敗來影響群組：

HKEY_LOCAL_MACHINE\Cluster\Resources\

如果 ClusterMSDTCInstance 的值是 2，則 Exchange Server Analyzer 就會顯示一則警告。

MSDTC 資源必須存在於 Exchange 叢集中，才能支援初始安裝及 Service Pack 升級。不過，當 Exchange 執行時，不需要它。

依預設，MSDTC 資源的失敗將影響群組。兩個資源失敗範例如下：

  • 記錄檔大小超出磁碟容量。

  • MSDTC 資源的實體磁碟失敗。

尤其，MSDTC 資源的失敗將導致正在該叢集節點上執行的所有 Exchange 服務容錯移轉至叢集中的不同節點。不過，因為 MSDTC 資源不是必要的資源，所以不必設定它來影響群組。

若要解決這個警告，請設定 Exchange 叢集，讓 MSDTC 資源的失敗不會影響群組。

設定 Exchange，讓 MSDTC 資源的失敗不會影響群組

  1. 登入叢集的任何節點。

  2. 按一下 [開始]，並依序指向 [所有程式] 及 [系統管理工具] 後，再按一下 [叢集系統管理員]。

  3. 在 [群組] 下，於包括 MSDTC 資源的叢集群組上按一下滑鼠右鍵。

  4. 在 MSDTC 資源上按一下滑鼠右鍵，再按一下 [內容]。

  5. 在 [進階] 索引標籤上，清除 [影響群組] 核取方塊，然後按一下 [確定]。

詳細資訊

若需如何建立 MSDTC 資源的特定步驟，請參閱《Exchange Server 2003 部署手冊》(http://go.microsoft.com/fwlink/?LinkId=47569) 的＜在叢集中部署 Exchange Server 2003＞中的＜如何在 Windows Server 2003 中安裝 Microsoft Distributed Transaction Coordinator＞(英文)。

若需有關 MSDTC 及 Exchange 的詳細資訊，請參閱《Exchange Server 2003 高可用性手冊》(http://go.microsoft.com/fwlink/?LinkId=47571) 的＜瞭解 Exchange Server 2003 叢集＞中的＜叢集群組＞(英文)。

若需有關如何在 Microsoft Windows Server™ 2003 中新增 MSDTC 資源的詳細資訊，請參閱微軟知識庫文件 - 301600＜如何在 Windows Server 2003 叢集上設定 Microsoft Distributed Transaction Coordinator＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301600)。

附註：
知識庫文件 301600 包括對下列文件的參照 - 817064＜如何在 Windows Server 2003 中啟用網路 DTC 存取＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=817064)。它是 Exchange Server 安全性最佳作法，不對 Exchange 叢集啟用網路 DTC 存取。如果要為 Exchange 叢集設定 Distributed Transaction Coordinator 資源，請不要啟用網路 DTC 存取。


MTA 中斷會影響叢集群組
Microsoft Exchange Server Analyzer - 文章 > Exchange 叢集 >

主題上次修改日期： 2006-03-16

Microsoft® Exchange Server Analyzer 工具會檢查 Exchange 伺服器系統的 Cluster\Resources 登錄設定。

HKEY_LOCAL_MACHINE\Cluster\Resources

如果 Exchange Server Analyzer 發現郵件傳輸代理程式 (MTA) 堆疊服務資源正在原生模式組織中的 Exchange Server 2003 叢集上執行，則 Exchange Server Analyzer 會顯示最佳作法訊息。

最佳作法就是建議 Exchange 系統管理員設定 MTA 資源，讓 MTA 不會在停止或失敗時導致可能的 Exchange 虛擬伺服器容錯移轉。

附註：
Microsoft Exchange 2000 Server 及 Microsoft Exchange Server 2003 中的 MTA 堆疊服務通常用來在混合模式環境中，於 Exchange 2000 Server 或 Exchange Server 2003 伺服器與 Microsoft Exchange Server 5.5 伺服器之間，提供舊版相容郵件轉送服務。對純 Exchange 2000 Server 或 Exchange Server 2003 原生模式環境進行轉換時，MTA 不是讓 Exchange 服務執行的重要資源。

如果 MTA 堆疊服務停止執行或失敗，可能的 Exchange 虛擬伺服器容錯移轉可能會開始。若要防止可能的 Exchange 虛擬伺服器 (EVS) 容錯移轉，建議的最佳作法就是執行下列動作，設定 MTA 堆疊服務來避免容錯移轉。

在 Exchange 伺服器叢集中將 MTA 堆疊服務設定為不受影響的狀態

  1. 開啟 [Cluster Administrator]

  2. 清除 MTA 堆疊服務資源的 [Affect this Group] 選項。

詳細資訊

若需 Exchange Server 2003 的 MTA 堆疊服務可支援性方針的相關資訊，請參閱微軟知識庫文件 - 810489＜Exchange 2000 Server 及 Exchange Server 2003 的 MTA 堆疊服務可支援性方針＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810489)。

若需有關 Exchange Server 2003 架構中的 MTA 的詳細資訊，請參閱＜Exchange Server 2003 架構中的 Exchange MTA＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63496)。

若需如何在叢集中部署 Exchange Server 2003 的相關資訊，請參閱＜在叢集中部署 Exchange Server 2003＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63495)。

若需如何使用叢集系統管理員的相關資訊，請參閱＜使用叢集系統管理員管理 Exchange 叢集＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63493)。


這是由兩個節點組成的「主動/主動」叢集
Microsoft Exchange Server Analyzer - 文章 > Exchange 叢集 >

主題上次修改日期： 2006-04-28

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定叢集服務 ClusSvc 的 Started 機碼值。值為 True 表示叢集服務正在執行，而值為 False 則表示該服務未執行。

Exchange Server Analyzer 也會讀取下列登錄項目，以判定叢集中的節點數目。

HKEY_LOCAL_MACHINE\Cluster\Nodes\ <節點號碼> \NodeName

NodeName 的執行個體計數代表叢集中的節點數目。此外，Exchange Server Analyzer 會讀取下列登錄項目，以判定叢集中的 Exchange Server 資源數目：

HKLM\Cluster\Resources\ <叢集資源 GUID> \Parameters\DestPath

Exchange Server 叢集上的下列資源都會有 DestPath 值：

  • Microsoft Exchange 郵件傳輸代理程式

  • Microsoft Exchange 資訊儲存庫

DestPath 的執行個體計數指出叢集中執行 Exchange 虛擬伺服器 (EVS) 的伺服器數目。

如果 Exchange Server Analyzer 判定具有 2 個 NodeName 執行個體的叢集中有 3 個 DestPath 執行個體，則會顯示一則警告。此警告表示這是由具有兩個執行 EVS 之伺服器的兩個節點組成的叢集，也稱為「主動/主動」叢集。

  • 在「主動/主動」叢集模型中，叢集中的 Exchange 虛擬伺服器數目等於或大於叢集中的實體節點數目。

附註：
在由兩個節點組成的叢集中才可建立「主動/主動」Exchange 叢集。如果叢集中有三個或以上的節點，則必須使用「主動/被動」模型。
  • 在「主動/被動」叢集模型中，叢集中的 Exchange 虛擬伺服器數目小於叢集中的實體節點數目。

雖然 Microsoft 支援 Exchange Server 的「主動/主動」叢集處理，但是強烈建議 Exchange 叢集使用「主動/被動」實作方式。Microsoft 僅支援遵守下列縮放比例限制的「主動/主動」Exchange 叢集：

  • 每個實體節點之每個 Exchange 虛擬伺服器上的使用者同時連線數目絕不可大於 1900。如果叢集中其中一個節點無法使用，而單一節點上的所有 Exchange 虛擬伺服器都處於連線狀態，則縮放比例限制會將這兩個 Exchange 虛擬伺服器的連線數目保持在 3800 個。因為每個使用者都可以進行多個連線，所以信箱數目不是評估連線數目的正確方式。

  • 每個 Exchange 儲存區處理程序的平均 CPU 使用不應大於百分之 40。如果節點上之 STORE.EXE 處理程序的 CPU 總計使用在 10 分鐘 (或以上) 的時間內大於百分之 40，則必須將使用者移動到另一個 Exchange 虛擬伺服器或 Exchange 伺服器中。請注意，此負載不包含因系統管理工作所消耗的 CPU 使用。

從「主動/主動」叢集組態遷移到「主動/被動」組態，包括將資源移出第二個 EVS，然後再將它解除委任。

若要從「主動/主動」叢集遷移到「主動/被動」叢集

  1. 將叢集中第二個 EVS 上主控的信箱移到第一個 EVS 中。叢集中的第一個 EVS 一定會含有叢集中唯一的 Microsoft Exchange 郵件傳輸代理程式 (MTA) 資源。

  2. 在所有的信箱都移動到第一個 EVS 後，請將第二個 EVS 離線。

  3. 執行下列其中一項，以移除第二個 EVS：

    • 在 Exchange Server 2003 叢集中，在 Microsoft Exchange 系統服務員資源上按一下滑鼠右鍵，再按 [移除 Exchange 虛擬伺服器]。

    • 在 Exchange 2000 Server 叢集中，在 Microsoft Exchange 系統服務員資源上按一下滑鼠右鍵，再按 [刪除]。

  4. 確認 EVS 物件已自 Active Directory® 目錄服務中移除。由於 Exchange Server 2003 中叢集服務帳戶權限的變更，您的帳戶必須擁有權限以移除 Active Directory 物件。

  5. 將在第二個 EVS 中的其餘資源 (如，實體磁碟、網路名稱及 IP 位址) 離線，然後將它們刪除。

  6. 將包含第二個 EVS 的資源群組刪除。

若需有關如何移除 EVS 的詳細資訊，請參閱《部署 Microsoft Exchange 2000 Server 的 Exchange 叢集》中的＜自叢集移除 Exchange 虛擬伺服器＞(英文) (http://go.microsoft.com/fwlink/?LinkId=9393)。

若需有關 Exchange 叢集的最佳作法及建議事項的詳細資訊，請參閱《Exchange 2003 部署手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47569)。

若需有關在 Windows 伺服器叢集中部署 Exchange 的詳細資訊，請參閱微軟知識庫文件 - 815180＜在主動/主動叢集上部署 Exchange 時的注意事項＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815180)。


仲裁記錄檔太小
Microsoft Exchange Server Analyzer - 文章 > Exchange 叢集 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定為叢集所設定的仲裁記錄檔大小：

HKEY_LOCAL_MACHINE\Cluster\Quorum\MaxQuorumLogSize

如果 Exchange Server Analyzer 發現 MaxQuorumLogSize 的值小於十進位值 4194304 (十六進位值 0x400000)，就會顯示警告。

MaxQuorumLogSize 登錄值代表 [由以下重設仲裁記錄檔] 叢集仲裁參數目前的設定值。如果 MaxQuorumLogSize 小於 4096 KB，就會產生此警告。

叢集會將叢集資料庫的所有變更記錄於仲裁記錄檔中。當仲裁記錄檔達到指定的大小時，叢集會儲存資料庫並重設記錄檔。在 MicrosoftR Windows® 2000 Server 型叢集上，預設仲裁大小限制是 64 KB。在 Windows Server™ 2003 架構的叢集上，預設仲裁大小限制是 4096 KB。對於 Exchange Server 叢集而言，建議將 [由以下重設仲裁記錄檔] 屬性設定為 4096 KB。這樣可確保會有足夠空間來儲存叢集組態資訊，例如哪些伺服器是叢集的一部分、在叢集中安裝了哪些資源，以及那些資源是處於什麼狀態 (例如，線上或離線)。

若要更正此警告

  1. 開啟 [叢集系統管理員]。

  2. 在左窗格中，在代表叢集的物件上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 在 [仲裁] 索引標籤上，將 [由以下重設仲裁記錄檔] 的值設定為 4096。

  4. 按一下 [確定]，儲存變更。

若需有關預設仲裁記錄檔大小限制的詳細資訊，請參閱微軟知識庫文件 - 225081＜叢集資源仲裁記錄檔大小預設為 64 KB＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=225081)。


Exchange Server
Microsoft Exchange Server Analyzer - 文章 >

主題上次修改日期： 2005-11-18

本節中的文章詳細說明 Microsoft® Exchange Server Analyzer 工具會評估 Exchange Server 電腦的哪些方面。此外，這些文章還說明您可以採取哪些動作來解決 Exchange Server Analyzer 所發現的 Exchange 相關錯誤、警告及非預設的組態。


已安裝帳戶鎖定
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-08-28

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定檔案名稱 ALockout.dll 是否存在於 Exchange 伺服器上的 System32 資料夾。ALockout.dll 是「帳戶鎖定和管理工具」(ALTools.exe) 的一部分。這些工具會協助系統管理員管理帳戶，與疑難排解帳戶鎖定的問題。

若 Exchange Server Analyzer 發現 ALockout.dll 存在於 Exchange 伺服器上，Exchange Server Analyzer 將會顯示錯誤。

「帳戶鎖定及管理工具」不應使用於主控網路應用程式或服務的伺服器上，包括 Exchange 伺服器。若 Exchange 伺服器上已安裝「帳戶鎖定及管理工具」，Exchange 服務將無法啟動。因此，強烈建議您解除安裝此 Exchange 伺服器上的「帳戶鎖定及管理工具」。

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要更正此錯誤

  1. 在命令提示字元下，鍵入 [regsvr32 /u alockout.dll]。

  2. 刪除位於下列登錄機碼中的 ALockout.dll 值：HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Windows\AppInit_DLLs
附註：
在您刪除 ALockout.dll 值後，AppInit_DLLs 登錄項目將為空白。重新啟動電腦。
  1. 從 System 32 資料夾中刪除 ALockout.dll 檔案。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

如需「帳戶鎖定及管理工具」的相關資訊，請參閱《帳戶密碼與原則》 中的＜帳戶鎖定工具＞(英文) (http://go.microsoft.com/fwlink/?LinkId=52465)。


Active Directory 站台不符
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-03-16

Microsoft® Exchange Server Analyzer 工具會實作 Win32 API DsGetSiteName 函數，以查詢網域控制站的 Active Directory® 目錄服務站台名稱，以及本機 Exchange Server 的 Active Directory 站台名稱。

如果 Exchange Server Analyzer 判定網域控制站的 Active Directory 站台名稱與本機 Exchange Server 的 Active Directory 站台名稱不符，則會顯示警告。

這個警告指出目錄服務存取 (DSAccess) 處理程序會走出本機 Active Directory 站台，來處理其輕量型目錄存取通訊協定 (LDAP) 要求，如此會導致 Exchange Server 效能嚴重下降。

導致這種情況的原因包括：靜態設定的離站網域控制站、網路或網域控制站電腦中斷執行 (造成無法連接站台常駐網域控制站)，或不正確設計的 Active Directory 拓樸 (與 Exchange Server 相同的站台中並不包括 Active Directory 網域控制站)。

DSAccess 是共用的 Exchange Server 元件，用來在快取中存取及儲存目錄資訊。DSAccess 會根據準則 (如 Active Directory 站台組態及 Active Directory 伺服器可用性)，動態偵測其他 Exchange 元件應該連絡的目錄伺服器。Exchange 前端伺服器會使用 DSAccess，判定哪一台伺服器包含特定使用者的信箱、為使用者物件而存在的簡易郵件傳送通訊協定 (SMTP) 位址，以及包含公用資料夾儲存區的伺服器。

初始設定時，如果 DSAccess 在登錄中找不到一組靜態設定的網域控制站或通用目錄，則 DSAccess 會使用探索處理程序來識別網路拓樸，並評定目錄伺服器的可用性及適用性。判定網域控制站的適用性時，會判定網域控制站是否位於與 Exchange Server 相同的 Active Directory 站台。

若要減少跨站台 LDAP 要求可能產生的延遲，Exchange Servers 應該位於有常駐網域控制站的 Active Directory 站台。

若要更正此問題：

  • 評估 Active Directory 拓樸的站台定義，以驗證每一個 Exchange Server 有權存取位於相同 Active Directory 站台的網域控制站。

  • 驗證任何靜態設定的網域控制站是否位在與 Exchange Server 相同的 Active Directory 站台。

詳細資訊

若需有關如何設定 DSAccess 及其疑難排解的詳細資訊，請參閱下列 Exchange 資源：

  • ＜目錄整合及 Exchange Server＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63447)

  • ＜瞭解目錄存取及其疑難排解＞(英文) (http://go.microsoft.com/fwlink/?LinkId=39012)

  • 微軟知識庫文件 - 250570＜目錄服務伺服器偵測及 DSAccess 使用方式＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)


已停用系統管理檔案共用
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已停用預設的系統管理共用：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters\AutoShareServer

如果 Exchange Server Analyzer 發現 AutoShareServer 的值設為 0，就會顯示錯誤。

此錯誤表示此伺服器上已停用預設由伺服器建立的系統管理共用。當預設的系統管理共用已經停用時，可能無法進行線上 Exchange Server 備份或還原。視備份程式而定，您可能會在嘗試還原資料時收到錯誤訊息。您也可以在磁帶備份記錄中查看錯誤訊息。

此外，當系統管理共用已被移除時，進行 Exchange Server 線上備份期間，您可能會收到下列訊息：「未預期的錯誤 0xc0040000 無法使用 Microsoft Exchange Server 電腦。」若要解決這個問題，建議您在編輯登錄後重新啟動 Server 服務，重新啟用預設的系統管理共用。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

  3. 在右窗格中，尋找並按兩下 AutoShareServer。

  4. 將值從 0 變更為 1。

  5. 關閉登錄編輯程式，然後重新啟動 Server 服務，以使變更生效。

在編輯登錄之前，若需如何編輯登錄的詳細資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關在 Microsoft Windows Server™ 2003 中還原預設系統管理共用的詳細資訊，請參閱知識庫文件 - 816113＜HOW TO：在 Windows Server 2003 中使用登錄編輯程式還原系統管理共用＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816113)。


AFD.SYS 驅動程式與 X.400 連接器的交互操作性
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

MicrosoftR Exchange Server Analyzer 工具會讀取下列登錄項目，以判定正在 Exchange Server 電腦上執行的 Microsoft Windows® 版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 值 4.0 表示 Exchange Server 電腦是在 Microsoft Windows NT® Server 4.0 上執行。值 5.0 表示 Exchange Server 電腦正在執行 Windows 2000 Server，而值 5.2 則表示 Exchange Server 電腦正在執行 Windows Server™ 2003。

Exchange Server Analyzer 工具也會查詢 Win32_ComputerSystem Microsoft Windows Management Instrumentation (WMI) 類別，以判定 NumberOfProcessors 機碼的設定值。此值代表安裝於電腦上的處理器數目。這些處理器包含實體處理器與邏輯處理器。實體處理器可使用來自 Intel 的超執行緒技術分為兩個邏輯處理器。

Exchange Server Analyzer 也會讀取下列登錄項目，以判定 Exchange Server 是否為 X.400 連接器的 Bridgehead：

HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeMTA

最後，Exchange Server Analyzer 會查詢 CIM_DatafileWindows Management Instrumentation (WMI) 類別，以判定名為 Afd.sys 之檔案的 Version 機碼值。

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • Exchange Server 電腦在 Windows Server 2000 上執行。

  • NumberOfProcessors 的值大於 1。

  • Exchange Server 是 X.400 連接器的 Bridgehead。

  • WINDOWSPATH%\\system32\\drivers\\afd.sys 之 Version 機碼的值在 5.0.2195.7036 到 5.0.2195.7060 的範圍內。

此警告表示，此伺服器上有 X.400 連接器，安裝於伺服器上之 Afd.sys 的版本可能造成郵件流問題。

若要解決此問題，請獲得微軟知識庫文件 - 904712＜在 Exchange Server 5.5 中，遠端站台之 X.400 連接器上的郵件傳遞比預期慢或停止＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=904712) 中所提到的更新。


資料庫的 Aging Keep Time 間隔並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已設定 msExchAgingKeepTime 屬性。此屬性表示可用來判定何時將移除索引、檢視與分類的時間值。若 Exchange Server Analyzer 發現已設定此屬性，便會顯示非預設的組態訊息。

Exchange 用戶端在 Exchange 資料庫表格中所建立用來檢視的索引，若經過一段指定的時間未使用，便會於此時清除。msExchAgingKeepTime 屬性指定刪除前的最小索引資齡。Exchange 2000 Server 原始版本中的預設值是 8 天。在 Exchange 2000 Server Service Pack 1 (SP1) 及 Exchange Server 的所有後續版本中 (包括 Exchange Server 2003 和 Exchange Server 2007)，預設值都是 40 天。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或 Exchange Server 2007，或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
檢視或修改 Aging Keep Time 值

  1. 啟動 [ADSI 編輯器]。

  2. 連按兩下 [Configuration] 容器，依序展開 CN=Services、 CN=Microsoft Exchange、 CN=<ExchangeOrganizationName>。

  3. 展開 CN=Administrative Groups、展開 CN=<AdministrativeGroupName>，然後展開 CN=Servers。

  4. 依序展開 [CN=<ServerName>]、[CN=InformationStore]，然後選取 [CN=<StorageGroupName>]。

  5. 在詳細資料窗格中的 CN=<MailboxStoreName> 上按一下滑鼠右鍵，再按一下 [內容]。

  6. 在 [屬性編輯器] 中，按一下 msExchAgingKeepTime 屬性，再按一下 [編輯]。

  7. 在 [編輯屬性] 方塊中，按一下 [清除] 以清除值。

  8. 按一下 [套用]，再按一下 [確定]。

  9. 關閉 [ADSI 編輯器]。如果做了變更，請重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

若需有關使用 LDP 工具的詳細資訊，請參閱 Microsoft 知識庫文章 - 260745＜XADM:使用 LDP 公用程式來修改 Active Directory 物件屬性＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

若需有關在 Exchange Server 中存取資訊儲存庫資料夾的潛在問題之詳細資訊，請參閱微軟知識庫文件 - 216076＜在 Exchange 中存取資訊儲存庫資料夾可能會變慢＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=216076)。


有可用的 Antigen 更新
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-06-20

Microsoft Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft® Windows® Management Instrumentation (WMI) 類別，以判斷 MimeNavigator.dll 的 Version 機碼值。此模組已併入 Microsoft Antigen 第 8 版和第 9 版中。

如果 Exchange Analyzer 發現 MimeNavigator.dll 的 Version 機碼值小於第 8 版的 8.00.1517.0 和第 9 版的 9.00.1055.0，Exchange Analyzer 會顯示警告。

此警告表示 Exchange 伺服器上安裝了 Microsoft Antigen 第 8 版或第 9 版，且有可用的軟體更新。強烈建議使用此更新，此更新可增進伺服器整體效能及可靠性。

若要解決此問題，請檢閱並採行 Microsoft 知識庫文章 928082＜在 Antigen 的掃描處理期間，SMTP 訊息的大小可能會增加＞(機器翻譯)。


應用程式記錄檔大小
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-11-09

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定應用程式記錄檔大小上限：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Eventlog\Application\MaxSize

如果 Exchange Server Analyzer 發現 MaxSize 的值小於 41,943,040 位元組 (40 MB)，就會顯示最佳作法訊息。

在預設的情況下，Windows Server 2003 中應用程式記錄檔的記錄檔大小上限是 16,777,216 個位元組 (16348 KB)，而 Windows 2000 Server 的則是524288 個位元組 (512 KB)。若為執行 Exchange Server 的電腦，最佳作法是將應用程式記錄檔的大小上限設為 40 MB (輸入為 40,960 KB) 或以上。增加應用程式記錄檔大小，可以保留更多的應用程式事件。額外的事件資訊有助於您進行疑難排解。

若要增加應用程式記錄檔的大小上限

  1. 開啟 [事件檢視器] Microsoft Management Console (MMC) 嵌入式管理單元。

  2. 在 [應用程式] 記錄檔上按一下滑鼠右鍵，再按 [內容]。

  3. 在 [一般] 索引標籤上，於 [記錄檔大小] 之下的 [最大記錄檔大小] 方塊中，輸入 40960 或以上的數字，然後按一下 [確定]。


ASP.NET Rootver 已毀損
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 ASP.NET 的 Rootver 機碼上的設定值：

HKEY_LOCAL_MACHINE\Software\Microsoft\ASP.NET

若下列條件存在，Exchange Server Analyzer 便會顯示錯誤：

  • Exchange Server Analyzer 發現 Rootver 值設為 0.0.0.0。

  • 叢集服務正在執行。

有時候，ASP.NET 安裝程式失敗時不會提供失敗的通知。在這種情況下，Rootver 機碼設為 0.0.0.0。將 Rootver 值設為 0.0.0.0 會造成 Microsoft Exchange System Attendant 服務或其他 Exchange Server 服務無法在 Exchange Server 2003 及 Exchange Server 2007 叢集上啟動。您必須將 Rootver 值設為下列其中之一，以更正此錯誤：

  • Exchange Server 2003 Rootver 機碼 = 1.1.4322.0。

  • Exchange Server 2007 Rootver 機碼 = 2.0.50727.0

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定您瞭解如何在發生問題時還原登錄。若需如何還原登錄的相關資訊，請檢視 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
將 Rootver 設為 1.1.4322.0

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\Software\Microsoft\ASP.NET\

  3. 在詳細資料窗格中，按兩下 RootVer 機碼。

  4. 在 [編輯字串] 對話方塊中，將 [數值資料] 設為上述的適當值，然後按一下 [確定]。

  5. 結束登錄編輯程式。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


已停用作業系統自動偵錯
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來判定是否已停用作業系統偵錯：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AeDebug\Auto

如果 Exchange Server Analyzer 發現 Auto 的值設定為 0，將會顯示警告。

在預設的情況下，Microsoft Windows® 2000 Server 及 Windows Server™ 2003 作業系統會安裝應用程式偵錯工具 Dr. Watson。偵錯工具是一種程式，可讓程式設計人員逐步執行程式、檢查資料及監視條件 (例如變數的值)，藉以偵測、尋找及修正其他程式的錯誤。

Dr. Watson 第一次執行時會設定預設選項，包括在程式發生錯誤時，或您自行啟動 Dr. Watson 時。

當應用程式發生錯誤時，Windows 會搜尋程式錯誤處理常式。程式錯誤處理常式可以處理在程式執行期間所發生的錯誤。如果 Windows 找不到程式錯誤處理常式，則會將程式辨識為目前未進行偵錯，就將錯誤視為未處理。接著，Windows 會在登錄中尋找一個程式錯誤偵錯工具來處理未處理的錯誤。

Windows 的行為視下列兩個登錄值的設定而定：HKLM\Software\Microsoft\Windows NT\CurrentVersion\AeDebug

項目名稱是 Debugger 和 Auto。Debugger 項目的值指定偵錯工具的命令，偵錯工具將用來分析程式錯誤。如果找到 Debugger 項目的值，Windows 會檢查 Auto 項目的值是否設定為 0 或 1：

  • 如果 Auto 項目的值設定為 0，則 Windows 會產生訊息方塊，向您通知已發生程式錯誤。如果 Debugger 項目的值指定有效偵錯工具的命令，則訊息方塊將顯示兩個按鈕：[確定] 和 [取消]。如果按下 [確定]，程式將停止。如果按下 [取消]，則將啟動指定的偵錯工具。如果 Debugger 項目的值是空的，則訊息方塊只會顯示 [確定]，不會啟動偵錯工具。

  • 如果 Auto 項目的值設定為 1，且 Debugger 項目的值指定有效偵錯工具的命令，則系統會自動啟動偵錯工具，且不會產生訊息方塊。

安裝 Windows 之後，Auto 項目的值預設會設定為 1，Debugger 項目的值會指定 Dr. Watson 的啟動命令 (drwtsn32 -p %ld -e %ld -g)。意即，當發生程式錯誤時，Dr. Watson 會自動診斷錯誤並記錄適當的診斷資訊。

建議的最佳作法是在 Exchange Server 電腦上使用程式錯誤偵錯工具。如果您使用 Dr. Watson 以外的程式作為預設的偵錯工具，但想要改用 Dr. Watson，請移至命令提示字元，鍵入命令 drwtsn32 -i 來啟動 Dr. Watson。鍵入 -i 會在登錄中執行必要的變更。

若要從命令提示字元註冊 Dr. Watson 作為預設偵錯工具

  1. 開啟 [命令提示字元] 視窗。

  2. 執行下列命令：drwtsn32 -i

  3. 您將收到「Dr. Watson 已經安裝為預設的應用程式偵錯工具。」的訊息。請按一下 [確定] 來認可這個訊息。

若要從使用者介面註冊 Dr. Watson 作為預設偵錯工具

  1. 依序按一下 [開始] 及 [執行]，鍵入 drwtsn32，然後按 ENTER 鍵。將出現 [Dr. Watson for Windows] 使用者介面。

  2. 選取 [建立損毀傾印檔案] 核取方塊。

  3. 按一下 [確定] 來儲存變更，然後關閉 [Dr. Watson for Windows] 使用者介面。

若需 Dr. Watson for Windows 的相關資訊，請在 Dr. Watson 使用者介面中按 F1 來參閱 Dr. Watson 說明檔。

如果打算使用 Dr. Watson 以外的程式錯誤偵錯工具，請參閱微軟知識庫文件 - 188296＜如何停用 Dr. Watson for Windows＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=188296) 的程序來停用 Dr. Watson。


平均 LDAP 讀取延遲已超過 50 毫秒
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-03-14

Microsoft Exchange Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 MSExchangeDSAccess Process 效能物件的 LDAP Read Time 效能計數器的資料，以分析效能資料。

LDAP Read Time 效能計數器會顯示要完成輕量型目錄存取通訊協定 (LDAP) 讀取要求所花費的時間 (以毫秒為單位)。Exchange Analyzer 會在 5 分鐘內每隔 5 秒擷取樣本一次。然後 Exchange Analyzer 會在收集間隔期間報告效能計數器的最大值。如果平均值超過 50 毫秒，Exchange Analyzer 就會顯示警告。

LDAP 讀取延遲很高可能是因為遠端程序呼叫 (RPC) 延遲很高以及不斷增大的佇列所造成。LDAP 讀取延遲很高通常表示發生下列其中一個問題：

  • 網域控制站之網路連線的效能問題。

  • 網域控制站本身的效能問題。

附註：
當使用者連接至位於不同實體站台的網域控制站時，LDAP 延遲通常更高。然而，通常應該遵照本文章中所述的建議最大延遲。

當已記錄這個警告的網域控制站位於不同的實體站台時，如果您可以判定 Exchange 伺服器並未使用報告這個警告的網域控制站，則可安全地略過這個警告。判定 Exchange 是否有使用網域控制站的一個方法，是將 MSExchangeDSAccess 服務之 [拓撲] 元件的診斷記錄增加為 [最小值]。如果沒有看到 MSExchangeDSAccess 事件識別碼事件 2080，就可以安全地略過這個警告。

若要解決此警告，請執行下列動作：

  • 確認到網域控制站的所有網路連線都可運作，並支援網路網路控制監督通訊協定 (ICMP) 流量。

  • 考慮下列文章中的最佳作法：

    • 若需 LDAP Read Time 效能計數器及其他您可以用來疑難排解 Active Directory 繫結問題之計數器的相關資訊，請參閱《Microsoft Exchange Server 效能疑難排解》中的＜排除 Active Directory 繫結問題＞主題 (英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。本文章也包括如何增進 Active Directory 效能的相關資訊。

    • 若需如何將 Active Directory 效能最大化的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》中的＜Active Directory 整合調整＞主題 (http://go.microsoft.com/fwlink/?LinkId=47576)。

    • 若需確保您的 Active Directory 伺服器具有高可用性的相關資訊，請參閱《Exchange 2003 高可用性手冊》的＜系統層級容錯方法＞主題中的＜確保對 Active Directory 及網域名稱系統有可靠的存取＞下的各節 (http://go.microsoft.com/fwlink/?LinkId=47571)。

    • 若需網路頻寬考量的相關資訊，請參閱《Exchange Server 2003 效能及延展性手冊》的＜瞭解 Exchange 效能＞主題中的＜網路效能＞一節 (http://go.microsoft.com/fwlink/?LinkId=47576)。


最大 LDAP 讀取延遲已超過 100 毫秒
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-03-14

Microsoft Exchange Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 MSExchangeDSAccess Process 效能物件的 LDAP Read Time 效能計數器的資料，以分析效能資料。

LDAP Read Time 效能計數器會顯示要完成輕量型目錄存取通訊協定 (LDAP) 讀取要求所花費的時間 (以毫秒為單位)。Exchange Analyzer 會在 5 分鐘內每隔 5 秒擷取樣本一次。然後 Exchange Analyzer 會在收集間隔期間報告效能計數器的最大值。如果最大值超過 100 毫秒，Exchange Analyzer 就會顯示錯誤。

LDAP 讀取延遲很高可能是因為遠端程序呼叫 (RPC) 延遲很高以及不斷增大的佇列所造成。LDAP 讀取延遲很高通常表示發生下列其中一個問題：

  • 網域控制站之網路連線的效能問題。

  • 網域控制站本身的效能問題。

附註：
當使用者連接至位於不同實體站台的網域控制站時，LDAP 延遲通常更高。然而，通常應該遵照本文章中所述的建議最大延遲。

Exchange 伺服器會每隔 15 分鐘查詢 out-of-domain 通用類別目錄伺服器，以保存一份含有通用類別目錄伺服器和網域控制站的最新清單。因為這些目錄伺服器中有些可能是遠端的，這些查詢的延遲可能很高。只要要求不頻繁，也就是說，頻率少於每秒 0.5 個要求，則這是可接受的。

當已記錄這個錯誤的網域控制站位於不同的實體站台時，如果您可以判定 Exchange 伺服器是否未使用報告這個錯誤的網域控制站，則可安全地略過這個錯誤。判定 Exchange 是否有使用網域控制站的一個方法，是將 MSExchangeDSAccess 服務之 [拓撲] 元件的診斷記錄增加為 [最小值]。如果沒有看到 MSExchangeDSAccess 事件識別碼事件 2080，就可以安全地略過這個錯誤。

重要事項：
(僅限混合模式環境) 此行為大約是在 Exchange 2000 SP2 時期開始發生於某些特定的安全相關使用者屬性，例如 tokenGroups 和 tokengroupsGlobalandUniversal，這些屬性是用來判定使用者屬於哪個安全群組的成員，及其因而擁有哪些權限可保護公用資料夾等資源的安全，而這需要 Exchange 伺服器去查詢使用者主網域的授權網域控制站。授權的網域控制站可能在遠端站台，而來自大量遠端主網域使用者、要存取本機公用資料夾的查詢，可能會導致 RPC 延遲偏高。

如需此行為的相關資訊，請參閱下列 Exchange Server 部落格主題：

  • Exchange 不一定都使用本機 GC (英文)

    附註：
    本主題也提供部落格的連結，協助您找到需要的技術資訊。每一個部落格及其 URL 的內容隨時都會變更，不另行通知。

若要解決此錯誤，請執行下列動作：

  • 確認到網域控制站的所有網路連線都可運作，並支援網路網路控制監督通訊協定 (ICMP) 流量。

  • 考慮下列文章中的最佳作法：

    • 若需 LDAP Read Time 效能計數器及其他您可以用來疑難排解 Active Directory 繫結問題之計數器的相關資訊，請參閱《Microsoft Exchange Server 效能疑難排解》中的＜排除 Active Directory 繫結問題＞主題 (英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。本文章也包括如何增進 Active Directory 效能的相關資訊。

    • 若需如何將 Active Directory 效能最大化的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》中的＜Active Directory 整合調整＞主題 (http://go.microsoft.com/fwlink/?LinkId=47576)。

    • 若需確保您的 Active Directory 伺服器具有高可用性的相關資訊，請參閱《Exchange 2003 高可用性手冊》的＜系統層級容錯方法＞主題中的＜確保對 Active Directory 及網域名稱系統有可靠的存取＞下的各節 (http://go.microsoft.com/fwlink/?LinkId=47571)。

    • 若需網路頻寬考量的相關資訊，請參閱《Exchange Server 2003 效能及延展性手冊》的＜瞭解 Exchange 效能＞主題中的＜網路效能＞一節 (http://go.microsoft.com/fwlink/?LinkId=47576)。


平均 LDAP 搜尋延遲已超過 50 毫秒
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-03-14

Microsoft Exchange Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 MSExchangeDSAccess Process 效能物件的 LDAP Search Time 效能計數器的資料，以分析效能資料。

LDAP Search Time 效能計數器會顯示要完成輕量型目錄存取通訊協定 (LDAP) 搜尋要求所花費的時間 (以毫秒為單位)。Exchange Analyzer 會在 5 分鐘內每隔 5 秒擷取樣本一次。然後 Exchange Analyzer 會在收集間隔期間報告效能計數器的最大值。如果平均值超過 50 毫秒，Exchange Analyzer 就會顯示警告。

LDAP 搜尋延遲很高可能是因為遠端程序呼叫 (RPC) 延遲很高以及不斷增大的佇列所造成。LDAP 搜尋延遲很高通常表示發生下列其中一個問題：

  • 網域控制站之網路連線的效能問題。

  • 網域控制站本身的效能問題。

附註：
當使用者連接至位於不同實體站台的網域控制站時，LDAP 延遲通常更高。然而，通常應該遵照本文章中所述的建議最大延遲。

當已記錄這個警告的網域控制站位於不同的實體站台時，如果您可以判定 Exchange 伺服器是否未使用報告這個警告的網域控制站，若是則可安全地略過這個警告。判定 Exchange 是否有使用網域控制站的一個方法，是將 MSExchangeDSAccess 服務之 [拓撲] 元件的診斷記錄增加為 [最小值]。如果沒有看到 MSExchangeDSAccess 事件識別碼事件 2080，就可以安全地略過這個警告。

若要解決此警告，請執行下列動作：

  • 確認到網域控制站的所有網路連線都可運作，並支援網路網路控制監督通訊協定 (ICMP) 流量。

  • 考慮下列文章中的最佳作法：

    • 若需 LDAP Read Time 效能計數器及其他您可以用來疑難排解 Active Directory 繫結問題之計數器的相關資訊，請參閱《Microsoft Exchange Server 效能疑難排解》中的＜排除 Active Directory 繫結問題＞主題 (英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。本文章也包括如何增進 Active Directory 效能的相關資訊。

    • 若需如何將 Active Directory 效能最大化的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》中的＜Active Directory 整合調整＞主題 (http://go.microsoft.com/fwlink/?LinkId=47576)。

    • 若需確保您的 Active Directory 伺服器具有高可用性的相關資訊，請參閱《Exchange 2003 高可用性手冊》的＜系統層級容錯方法＞主題中的＜確保對 Active Directory 及網域名稱系統有可靠的存取＞下的各節 (http://go.microsoft.com/fwlink/?LinkId=47571)。

    • 若需網路頻寬考量的相關資訊，請參閱《Exchange Server 2003 效能及延展性手冊》的＜瞭解 Exchange 效能＞主題中的＜網路效能＞一節 (http://go.microsoft.com/fwlink/?LinkId=47576)。


最大 LDAP 搜尋延遲已超過 100 毫秒
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-03-14

Microsoft Exchange Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 MSExchangeDSAccess Process 效能物件的 LDAP Search Time 效能計數器的資料，以分析效能資料。

LDAP Search Time 效能計數器會顯示要完成輕量型目錄存取通訊協定 (LDAP) 搜尋要求所花費的時間 (以毫秒為單位)。Exchange Analyzer 會在 5 分鐘內每隔 5 秒擷取樣本一次。然後 Exchange Analyzer 會在收集間隔期間報告效能計數器的最大值。如果最大值超過 100 毫秒，Exchange Analyzer 就會顯示錯誤。

LDAP 搜尋延遲很高可能是因為遠端程序呼叫 (RPC) 延遲很高以及不斷增大的佇列所造成。LDAP 搜尋延遲很高通常表示發生下列其中一個問題：

  • 網域控制站之網路連線的效能問題。

  • 網域控制站本身的效能問題。

附註：
當使用者連接至位於不同實體站台的網域控制站時，LDAP 延遲通常更高。然而，通常應該遵照本文章中所述的建議最大延遲。

Exchange 伺服器每 15 分鐘就會查詢網域外的通用類別目錄伺服器，讓通用類別目錄伺服器及網域控制站的清單保持為最新狀態。因為這些目錄伺服器中有些可能是遠端的，這些查詢的延遲可能很高。只要要求頻率不高 (也就是說，比率為每秒少於 0.5 個要求)，這就沒什麼問題。

當已記錄這個錯誤的網域控制站位於不同的實體站台時，如果您可以判定 Exchange 伺服器並未使用報告這個錯誤的網域控制站，則可安全地略過這個錯誤。判定 Exchange 是否有使用網域控制站的一個方法，是將 MSExchangeDSAccess 服務之 [拓撲] 元件的診斷記錄增加為 [最小值]。如果沒有看到 MSExchangeDSAccess 事件識別碼事件 2080，就可以安全地略過這個錯誤。

重要事項：
(僅限混合模式環境) 此行為大約是在 Exchange 2000 SP2 時期開始發生於某些特定的安全相關使用者屬性，例如 tokenGroups 及 tokengroupsGlobalandUniversal。這些屬性是用來判定使用者所屬的安全群組，以及因而對例如公用資料夾等安全資源具有何種權限 (這些公用資料夾需要 Exchange 伺服器去查詢使用者主網域的授權網域控制站)。授權網域控制站可能是在遠端站台，而來自大量遠端主網域使用者、要存取本機公用資料夾的查詢，可能會導致 RPC 延遲偏高。

如需此行為的相關資訊，請參閱下列 Exchange Server 部落格文章：

  • Exchange 不一定都使用本機 GC (英文)

    附註：
    本主題也提供部落格的連結，協助您找到需要的技術資訊。每一個部落格及其 URL 的內容隨時都會變更，不另行通知。

若要解決此錯誤，請執行下列動作：

  • 確認到網域控制站的所有網路連線都可運作，並支援網路網路控制監督通訊協定 (ICMP) 流量。

  • 考慮下列文章中的最佳作法：

    • 若需 LDAP Read Time 效能計數器及其他您可以用來疑難排解 Active Directory 繫結問題之計數器的相關資訊，請參閱《Microsoft Exchange Server 效能疑難排解》中的＜排除 Active Directory 繫結問題＞主題 (英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。本文章也包括如何增進 Active Directory 效能的相關資訊。

    • 若需如何將 Active Directory 效能最大化的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》中的＜Active Directory 整合調整＞主題 (http://go.microsoft.com/fwlink/?LinkId=47576)。

    • 若需確保您的 Active Directory 伺服器具有高可用性的相關資訊，請參閱《Exchange 2003 高可用性手冊》的＜系統層級容錯方法＞主題中的＜確保對 Active Directory 及網域名稱系統有可靠的存取＞下的各節 (http://go.microsoft.com/fwlink/?LinkId=47571)。

    • 若需網路頻寬考量的相關資訊，請參閱《Exchange Server 2003 效能及延展性手冊》的＜瞭解 Exchange 效能＞主題中的＜網路效能＞一節 (http://go.microsoft.com/fwlink/?LinkId=47576)。


無法識別指定的 Exchange 閘道
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-08-08

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以取得每一個目錄物件 (具有 msExchExchangeServer 的物件類別) 的名稱 (cn)，以判定使用者指定的 Exchange 閘道伺服器是否有相符者。

cn 值是包含 Exchange Server 電腦簡稱的字串。

如果 Exchange Server Analyzer 在 Active Directory 中找不到與使用者指定的 Exchange 閘道伺服器相符的 cn 值，則 Exchange Server Analyzer 會顯示錯誤。

此錯誤指出下列其中一個條件為真：

  • 使用者指定的 Exchange 閘道伺服器不存在於本機 Exchange Server 組織中。

  • 未正確地輸入使用者指定的 Exchange 閘道伺服器。

若要解決此錯誤，請驗證是否已正確輸入指定的 Exchange 閘道伺服器，然後重試作業。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
驗證伺服器名稱 (cn) 值

  1. 使用 [ADSI 編輯器] 或類似工具，在 Active Directory 中找出伺服器物件。

    CN 屬性可在下列位置找到：

    複製程式碼
    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Servers,CN=Server.


Categorizer Queue Length 超出閾值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-02-13

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 SMTP Server 效能物件的 Categorizer Queue Length 效能計數器的資料，以分析效能資料。

如果 Exchange Server Analyzer 判定 Categorizer Queue Length 計數器已在取樣時間配量期間超出尖峰值 10，則會顯示錯誤。

SMTP Server\Categorizer Queue Length 計數器指出在簡易郵件傳送通訊協定 (SMTP) 分類程式佇列中，等候使用通用類別目錄伺服器進行目錄服務屬性搜尋的郵件數。

分類程式會執行下列核心作業：

  • 解析及驗證所有收件者。

  • 判定對所有收件者的限制。

  • 展開通訊群組清單 (如果那是必需的)。

  • 判定郵件是本機傳遞還是遠端傳遞。

這個錯誤表示可能發生與下列有關的問題：伺服器或網路效能、目錄服務存取 (DSAccess)、Active Directory® 目錄服務，或 Exchange 伺服器組織中的關鍵伺服器中斷。Categorizer Queue Length 計數器若增加，表示在參考 Active Directory 或提交郵件進行本機傳遞或 SMTP 時，回應緩慢或無回應。這可能會導致郵件傳遞延遲。

若要更正這個錯誤：

  • 驗證有足夠的 Active Directory 資源可供 Exchange 伺服器使用。這同時包括網域控制站及通用目錄伺服器。建議的作法是在速度類似的 Exchange 伺服器處理器與通用目錄伺服器處理器之間維持 4:1 的比率。

  • 從 [Exchange 系統管理員] 中，驗證所有列示在 Exchange 伺服器的 [DSAccess] 索引標籤的網域控制站都運作正常。這包括在 ConfigDC、網域控制站及通用目錄伺服器角色中列出的伺服器。

  • 監視 Exchange 伺服器與其所選網域控制站及通用目錄伺服器之間的網路效能，以判定是否有網路效能瓶頸。

  • 監視 Exchange 伺服器上的處理器使用率，也監視 Inetinfo.exe 處理程序的處理器使用率。這包括分類程式元件。

  • 使用 Microsoft Exchange Server 部署工具 (http://go.microsoft.com/fwlink/?LinkId=21231) 中的 ConfigDSInteg 工具所提供的 e2kdsinteg 組態物件，來驗證 Exchange 相關使用者及群組物件的狀況。位址格式不對或資訊不完整的物件會導致收件者判定時發生延遲，因而延遲分類。

詳細資訊

若需疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


CDO.DLL 檔案遺失
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔是否存在：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要解決此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表中，按一下 [執行]，然後輸入 <drive>:\setup\i386\setup，其中的 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 Microsoft Exchange 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


有可用的 CimWin32.dll 更新
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-09-19

MicrosoftR Exchange Server Analyzer 工具會讀取下列登錄項目，以判定正在 Exchange Server 電腦上執行的 Microsoft Windows® 版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 值 4.0 表示 Exchange Server 電腦是在 Microsoft Windows NT® Server 4.0 上執行。值 5.0 表示 Exchange Server 電腦正在執行 Windows 2000 Server，而值 5.2 則表示 Exchange Server 電腦正在執行 Windows Server™ 2003。

Exchange Server Analyzer 也會查詢 CIM_Datafile Microsoft Windows Management Instrumentation (WMI) 類別，以判定 Cimwin32.dll 檔 Version 機碼的設定值。

若下列條件為真，Exchange Server Analyzer 就會顯示最佳作法訊息：

  • Exchange Server 電腦在 Windows 2000 Server 上執行。

  • Version 機碼的值與 Cimwin32.dll 檔的特定版本有對應關係。

有 Cimwin32.dll 檔的更新，可讓 Exchange Server Analyzer 運作更有效率。

若要解決此問題，請檢閱並採行 Microsoft 知識庫文章 820608＜對於 Windows 2000 中大於 2GB 的檔案，CIM_DataFile 類別會傳回不正確或 Null 值＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=820608) 中的建議事項。


用戶端應用程式對伺服器效能的影響
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具判斷有特定類型的用戶端電腦或用戶端應用程式可能會增加 Exchange 組織中的伺服器負載。

許多應用程式可能會增加伺服器上的負載。如果負載增加，應調查使用者在執行哪些應用程式，並決定是否要限制使用者執行特定應用程式。某些存取電子郵件的應用程式 (協力廠商應用程式或 Microsoft Office Outlook® 外掛程式) 可能會增加伺服器上的負載。如果伺服器遇到遠端程序呼叫 (RPC) 延遲增加或負載增加，建議您調查原因。

您可以使用 Exchange Server User Monitor (ExMon) 來識別遇到高延遲或增加伺服器上負載的使用者。若要下載 ExMon，請參閱 Microsoft 下載中心 (英文) (http://go.microsoft.com/fwlink/?LinkId=54983)。

程序

若要更正此警告

  • 使用 ExMon 識別哪些使用者造成伺服器負載增加。識別使用者之後，連絡使用者，判斷下列應用程式是否造成額外的負載：

    • 協力廠商用戶端電腦外掛程式

    • 桌面同步處理裝置，如 Exchange ActiveSync® 或 Blackberry

    • 其他 MAPI 應用程式，如桌面搜尋引擎

    如果這些應用程式不是業務用途所必需，或應用程式已發行 Hotfix，請關閉應用程式或更新應用程式，將負載降低至適當水準。

  • 將操作上最耗資源的用戶端電腦 (特別是 Restrict、SetColumns 或 FindRow 操作延遲長的用戶端電腦) 設定成使用 Exchange 快取模式。Exchange 快取模式會將伺服器與大部分的額外 RPC 流量隔離開來。

    另外，請鼓勵資料夾中有許多項目的使用者將較舊的資料封存為 .pst 檔案。或者，如果這些使用者想要在伺服器上保留其資料，請鼓勵他們將較舊的項目移至新建的資料夾。

    最後，建議您將收件匣、行事曆、寄件備份、連絡人及刪除的項目資料夾中的項目數保持在 5,000 以下。
附註：
某些應用程式可以不必發出大量 MAPI 作業即能大量增加伺服器負載。這是因為某些作業比其他作業更耗資源。耗資源的作業數目只要增加一些，可能就會明顯影響伺服器效能。在 ExMon 中，會將這些使用者報告為具有相對較高的 CPU 影響，而不一定發出了大量 MAPI 作業。

詳細資訊

  • 若需有關 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需有關 Exchange 伺服器效能問題疑難排解的詳細資訊，請參閱《Microsoft Exchange Server 2003 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • 若需有關 Outlook 用戶端效能問題疑難排解的詳細資訊，請參閱＜Outlook 使用者在執行 Exchange Server 2003 或 Exchange 2000 Server 的伺服器上使用包含許多項目的資料夾時遇到效能不佳的情況＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)

  • 若需有關桌面搜尋軟體的詳細資訊，請參閱微軟知識庫文件 - 905184＜在 Outlook 或其他 MAPI 用戶端電腦上執行桌面搜尋引擎軟體，可能會影響 Exchange 2000 Server 與 Exchange Server 2003 的效能＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184)。


叢集 TEMP 路徑無效或並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

在非叢集式 Exchange Server 電腦上，Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 TEMP 環境變數的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

當 Exchange Server Analyzer 對 Microsoft Windows® 伺服器叢集中的 Exchange 虛擬伺服器 (EVS) 執行時，不會讀取 HKLM 登錄區。而是會讀取下列登錄項目：

HKEY_USERS\<Cluster service account SID>\Environment\TEMP

如果 Exchange Server Analyzer 發現 TEMP 環境變數未設為目前系統上的可用路徑，就會顯示警告。如果此路徑無效，您的組織可能會經歷郵件傳遞失敗。依預設，採用其預設組態的 Exchange Server Analyzer 預期會找到預設路徑 %USERPROFILE%\Local Settings\Temp。儘管此路徑可修改為指向其他位置，但在套用 Hotfix 或更新，並重新啟動叢集節點之後，系統預期會找到預設路徑。

TEMP 環境變數用於指定需要臨時工作區的應用程式，應該使用檔案系統中的哪個資料夾。應用程式 (如 Exchange Server) 通常會使用 TEMP。每個變數的路徑通常相對於應用程式的內容。例如，在不同作業期間 (例如郵件轉換及信箱移動作業)，Microsoft Exchange Information Store 服務處理程序會使用 TEMP 資料夾作為暫時儲存區。

若要更正此警告

  1. 以叢集服務帳戶登入叢集中的一個節點。

  2. 在 [我的電腦] 上按一下滑鼠右鍵，然後選取 [內容]。

  3. 選取 [進階]。

  4. 按一下 [環境變數]。

  5. 在 [<帳戶名稱> 的使用者變數] 區域中，選取 [TEMP]，然後按一下 [編輯]。

  6. 在 [變數] 值欄位中，輸入 TEMP 環境變數的預設路徑，然後按一下 [確定]。

  7. 按一下 [確定] 關閉 [環境變數] 對話方塊，然後再按一次 [確定] 關閉 [系統內容] 對話方塊。

  8. 重新啟動節點以套用變更。

  9. 針對叢集中具有非預設設定的每個節點，重複步驟 1 至 8。


考量多份離線通訊錄複本
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-08-14

Microsoft® Exchange Server Analyzer 工具會查詢 root\MicrosoftExchangeV2 命名空間下的 Exchange_PublicFolder Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 ReplicaList 機碼中的項目數。此項目數代表存在於每個系統管理群組中的離線通訊錄複本數。

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定設有 legacyExchangeDN 屬性的公用資料夾資料庫物件數。設定有此屬性的物件數目代表組織中存在的公用資料夾儲存區數目。

如果 Exchange Server Analyzer 判定在具有多個公用資料夾儲存區的 Exchange 組織中只有一個離線通訊錄複本，Exchange Server Analyzer 會顯示最佳作法訊息。

基於可用性及效能的考量，建議您為每個離線通訊錄部署多個複本。某些時候，多個離線通訊錄複本可增加效能及彈性。在大型 Exchange 組織中，只有一個離線通訊錄複本的可能會超載。在所有 Exchange 組織中，一個離線通訊錄複本是一個失敗點。

雖然多個複本表示在網路上會有額外複寫流量，還是建議您使用多個複本。至少每個離線通訊錄要有兩個複本。

若要將離線通訊錄複本新增到 Exchange 組織中

  1. 開啟 [Exchange 系統管理員]

  2. 展開 [資料夾]，在 [公用資料夾] 上按一下滑鼠右鍵並選取 [檢視系統資料夾]。附註 如果看不到 [資料夾] 節點，請展開 [系統管理群組]，然後展開包含您想檢視之系統資料夾的系統管理群組。在 [公用資料夾] 上按一下滑鼠右鍵，然後選取 [檢視系統資料夾]。

  3. 展開 [離線通訊錄] 容器，然後在您要新增複本的離線通訊錄上按一下滑鼠右鍵，然後從出現的下拉式清單中選取 [內容]。

  4. 選取 [複寫] 索引標籤，然後按一下 [新增] 選取您要新增複本的公用儲存區。按一下 [確定] 結束。

  5. 針對您要新增複本之 [離線通訊錄] 容器下的所有子物件重複步驟 3 及 4。這個重複動作可確保所有支援的格式都會包含在複本中。特別是「新增」子物件 OAB Version 2、OAB Version 3a 等等。

若需有關管理及設定離線通訊錄的詳細資訊，請參閱下列 Microsoft Exchange Server TechCenter 文章

  • ＜離線通訊錄 - 考量事項＞(英文) (http://go.microsoft.com/fwlink/?LinkId=57581)

  • 《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595)。

  • 《離線通訊錄最佳作法手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47583)。

  • ＜Exchange Server 2003 Service Pack 2 中的 OAB Version 4＞(英文) (http://go.microsoft.com/fwlink/?linkid=53097)。

  • ＜Outlook 2003 SP2 及 Exchange Server 2003 SP2 OAB 版本 4 如何一起運作 ＞(英文) (http://go.microsoft.com/fwlink/?linkid=53099)。


連到收件者更新服務網域控制站的連線
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-05-18

Microsoft® Exchange Server Analyzer 工具會開啟到每一個網域控制站上之通訊埠 389 的 TCP 通訊端連線。此連線是使用自訂物件處理器建立的，如果連線成功，該處理器會傳回特定字串。

如果 Exchange Server Analyzer 收到的傳回字串中沒有 389 Available，則會顯示警告。

此警告指出網域控制站未回應 TCP 通訊埠 389 上的連線嘗試。TCP 通訊埠 389 是「輕量型目錄存取通訊協定 (LDAP)」通訊的預設通訊埠。如果您收到此警告，表示可能存在下列任一狀況：

  • Exchange Server Analyzer 與網域控制站之間可能存在連線問題。

  • 伺服器可能無法使用。

  • 伺服器可能已解除委任。

Exchange Server Analyzer 查詢網域控制站時，該網域控制站未正確服務 LDAP 要求的原因很多。

若要更正此警告

  1. 請確認執行 Exchange Server Analyzer 的帳戶有權去查詢網域控制站。在執行網域控制站的網域中，您必須擁有使用者等級的權限。您可以在 Exchange Server Analyzer 所包含的說明檔中，找到執行 Exchange Server Analyzer 時所需權限的詳細資訊。若要開啟 Exchange Server Analyzer 說明檔，請在 Exchange Server Analyzer 中按一下 [說明]，再按 [Microsoft Exchange Server Analyzer 工具說明]。

  2. 請確認執行 Exchange Server Analyzer 的電腦與未回應的網域控制站之間沒有防火牆或通訊埠限制。

  3. 請確認網域控制站有連線至網路而且正確運作。

  4. 請確認伺服器尚未解除委任，仍然列為 Exchange Server 可用的網域控制站。

若需詳細資訊，請參閱下列微軟知識庫文件：

  • 319065＜如何使用 Exchange 收件者更新服務＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319065)

  • 816103＜如何使用 Portqry 疑難排解 Active Directory 連線問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103)


已有內容更新可用
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-06-21

如需相關資訊，請參閱 Exchange Server 2007 文件下載 (英文) 網頁。


這個公用資料夾儲存區已啟用內容索引功能，但未排定更新
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

MicrosoftR® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個公用資料夾儲存區的 msExchCIAvailable 屬性值。此屬性值表示公用資料夾儲存區是否已啟用內容索引功能。True 值表示公用資料夾儲存區具有內容索引，並已選取 [Exchange 系統管理員] 設定 [此索引目前可供用戶端搜尋]。False 值表示公用資料夾儲存區具有內容索引，但已清除 [Exchange 系統管理員] 設定 [此索引目前可供用戶端搜尋]。<Not Set> 值表示公用資料夾儲存區沒有內容索引。

Exchange Server Analyzer 也會查詢 Active Directory，以判定每個公用資料夾儲存區的 msExchCIRebuildSchedule 屬性值。此屬性值表示內容索引的重建排程設定。此屬性儲存成含有 82 對十六進位值的 8 個位元的字元組合。

如果 Exchange Server Analyzer 發現 msExchCIAvailable 屬性值已設為 True，但 msExchCIRebuildSchedule 屬性的八位元資料組字串值卻轉譯為 [不執行]，就會顯示警告。

設定此更新間隔的建議最佳作法是排定一天至少遞增更新一次。您可能會想要排定更頻繁的更新，因為最後一次擴展的索引就是目前的索引。未定期更新的索引會產生不正確且過時的結果。

您也應該要考量完成遞增擴展所需的時間。例如，典型的排程會設定在每個小時開始時遞增更新。然而，如果更新會持續超過 1 小時，則會在下一個小時開始時才開始下一個遞增擴展。

一般而言，如果公用資料夾儲存區等於或小於 6 GB，您可以每小時執行一次遞增更新。如果儲存區大於 6 GB，或伺服器有高記憶體使用量，建議您不要經常更新索引。

若要設定特定公用資料夾儲存區的全文檢索更新間隔

  1. 開啟 [Exchange 系統管理員]。

  2. 依序展開 [系統管理群組]、您的系統管理群組、[伺服器]、您的伺服器及您的儲存群組，並以滑鼠右鍵按一下您的公用資料夾儲存區，然後按一下 [內容]。如果在 [Exchange 系統管理員] 中未顯示系統管理群組節點，請展開 [伺服器]、在您的伺服器上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 在 [全文檢索] 索引標籤上，選取 [不執行] 以外的選項。

  4. 如果選擇 [使用自訂排程]，請按一下 [自訂]，設定自己的自訂排程，然後按一下 [確定]。

  5. 按一下 [套用]。

若需有關 Exchange Server 全文檢索的詳細資訊，請參閱《部署全文檢索的最佳作法》(英文) (http://go.microsoft.com/fwlink/?linkid=5223)。


已針對此信箱儲存區啟用內容檢索但未排定更新
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個信箱儲存區的 msExchCIAvailable 屬性值。此屬性的值指示是否已針對信箱儲存區啟用內容檢索。值為 TRUE 表示信箱儲存區已存在內容索引，且已選取 [Exchange 系統管理員] 的 [此索引目前可供用戶端搜尋] 設定。值為 FALSE 表示信箱儲存區已存在內容索引，但未核取 Exchange 系統管理員設定 [此索引目前可供用戶端搜尋]。值為 <未設定> 表示信箱儲存區不存在內容索引。

Exchange Server Analyzer 也會查詢 Active Directory，以判定每個信箱儲存區的 msExchCIRebuildSchedule 屬性值。此屬性的值指示內容索引的重建排程設定。此屬性儲存成含有 82 對十六進位值的 8 個位元的字元組合。

如果 Exchange Server Analyzer 發現 msExchCIAvailable 屬性值已設為 TRUE，但是 msExchCIRebuildSchedule 屬性的八位元資料組字串值卻轉譯為 [不執行]，就會顯示警告。

設定此更新間隔的建議最佳作法是排定一天至少遞增更新一次。您可能會想要排定更頻繁的更新，因為最後一次擴展的索引就是目前的索引。未定期更新的索引會產生不正確且過時的結果。

您也應該考慮完成遞增擴展所需花費的時間。例如，典型的排程會設定在每個小時開始時遞增更新。然而，如果更新會持續超過 1 小時，則會在下一個小時開始時才開始下一個遞增擴展。

一般而言，如果信箱儲存區等於或小於 6 GB，您可以每小時執行遞增更新一次。如果儲存區大於 6 GB，或伺服器有高記憶體使用量，建議您不要經常更新索引。

設定特定信箱儲存區的全文檢索更新間隔

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [系統管理群組] 來展開您的系統管理群組、展開 [伺服器] 來展開您的伺服器、展開您的儲存群組，在您的信箱儲存區上按一下滑鼠右鍵，再按一下 [內容]。如果在 [Exchange 系統管理員] 中未顯示系統管理群組節點，請展開 [伺服器]、在您的伺服器上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 在 [全文檢索] 索引標籤上，選擇 [不執行] 以外的選項。

  4. 如果選擇 [使用自訂排程]，請按一下 [自訂]，設定自己的自訂排程，然後按一下 [確定]。

  5. 按一下 [套用]。

若需有關在 Exchange 中設定及疑難排解全文檢索的詳細資訊，請參閱微軟知識庫文件 - 822932＜HOW TO：在 Exchange 2003 中設定信箱儲存區的全文檢索＞(英文) (http://go.microsoft.com/fwlink/?LinkID=3052&kbid=822932)，以及 319436＜如何在 Exchange 2000 中設定信箱儲存區的全文檢索＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319436)。

若需有關 Exchange Server 全文檢索的詳細資訊，請參閱《部署全文檢索的最佳作法》(英文) (http://go.microsoft.com/fwlink/?LinkId=5223)。


有可用的 CQPCIDRV.SYS 驅動程式更新
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-08-14

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定正在執行 Exchange Server 之伺服器所執行的 Microsoft Windows® 版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 值為 4.0 指出 Exchange 伺服器正在執行 Microsoft Windows NT® Server 4.0。值為 5.0 則指出 Exchange 伺服器正在執行 Windows 2000 Server。值為 5.2 指出 Exchange Server 電腦正在執行 Windows Server™ 2003。

Exchange Server Analyzer 也會檢查 Win32_Processor Windows Management Instrumentation (WMI) 類別，以判定 DataWidth 機碼的值。

DataWidth 機碼值為 32 指出伺服器正在執行 32 位元版本的 Windows 作業系統，而 DataWidth 機碼值為 64 則指出伺服器正在執行 64 位元版本的 Windows 作業系統。

最後，Exchange Server Analyzer 會查詢 CIM_Datafile WMI 類別，以判定名為 CpqCiDrv.sys 之檔案的 Version 機碼值。

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • Exchange 伺服器正在執行 Exchange Server 2003。

  • Exchange 伺服器正在執行 64 位元版本的 Windows 作業系統。

  • HP Integrated Lights-Out Management Interface 驅動程式 CPQCIDRV.sys 的版本比 1.8 為舊。

此錯誤指出安裝在伺服器上的 CpqCiDrv.sys 版本，可能會導致核心記憶體配置錯誤。

若要解決此問題，請依照文件識別碼：c00688313 (http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c00688313) 中的廠商指引。

附註：
本主題也提供協力廠商網站資訊，協助您找到需要的技術資訊。URL 如有變更，恕不另行通知。


CrashOnAuditFail 生效
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已設定 CrashOnAuditFail 參數：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\LSA\CrashOnAuditFail

如果 Exchange Server Analyzer 發現 CrashOnAuditFail 的值等於 2，便會顯示一則錯誤。

CrashonAuditFail 登錄機碼的用途在於設定伺服器，使得當安全性記錄檔達到設定的大小限制時，一般使用者不得存取電腦。禁止電腦的存取可確保要記錄的稽核資訊不會遺失。

啟用時，CrashonAuditFail 登錄機碼的值會設為 1。但是，當達到安全性記錄檔限制時，伺服器會將登錄機碼的值設為 2，以便停止伺服器處理。有時候，此處理程序會造成完全失敗或 STOP 0xC0000244 錯誤 (也稱為「停止」錯誤)。而最輕的影響是，使用者會無法存取伺服器資源，且效能將會大幅降低。此外，當伺服器處於此狀態時，僅有具備系統管理員權限的使用者才可以存取電腦。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\SYSTEM\CurrentControlSet\Control\LSA。

  3. 刪除名為 CrashOnAuditFail 的值 (您必須刪除整個值，而不僅是數值資料而已)。

  4. 將安全性事件日誌複製到不同的位置。在預設的情況下，安全性事件日誌 (SecEvent.Evt) 位於 %SystemRoot%\System32\Config，其中 %SystemRoot% 是 Microsoft Windows® 作業系統的安裝路徑。

  5. 開啟 [事件檢視器]，在 [安全性] 上按一下滑鼠右鍵，然後按一下 [內容]。

  6. 在 [安全性內容] 頁面上，按一下 [清除記錄]。當系統提示您儲存記錄時，按一下 [是]，然後指定要儲存記錄檔的位置。

    附註 在 [安全性內容] 頁面上，您還可以編輯 [最大記錄檔大小] 欄位，再按一下 [套用]，以便增加記錄檔大小。

  7. 重新啟動伺服器。

  8. 藉由登入 Exchange 信箱，確認使用者可以存取伺服器資源。

  9. 重新建立 CrashonAuditFail 登錄機碼，並且將數值資料設為 1。

  10. 重新啟動伺服器，使 CrashonAuditFail 設定生效。

  11. 定期清除並儲存伺服器的安全性記錄檔，才不會超過記錄檔大小上限。若需詳細資訊，請參閱微軟知識庫文件 - 312571＜在達到記錄檔大小上限之前，事件日誌停止記錄事件＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=312571)。

在編輯登錄之前，若需有關如何編輯登錄的詳細資訊，請參閱知識庫文件＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關從 CrashOnAuditFail 失敗中復原的詳細資訊，請參閱下列知識庫文件：

  • 232564＜STOP 0xC0000244 when security log full＞ (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232564)

  • 829082＜You receive a "Stop error 0xC0000244 {Audit Failed}" error message when the crashonauditfail registry key is set to 1 on a Windows Server 2003-based computer＞ (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=829082)


自訂公用資料夾轉介清單
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-09

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 msExchFolderAffinityCustom 屬性是否包含任何 Exchange 伺服器名稱。如果 Exchange Server Analyzer 發現 msExchFolderAffinityCustom 屬性列出伺服器名稱，就會顯示非預設的組態訊息。

根據預設，Exchange Server 2003 會使用路由群組來判定公用資料夾轉介。

Exchange Server 2007 的預設值為使用 Active Directory 目錄服務站台間成本來判定公用資料夾轉介的路由。

如果 msExchFolderAffinityCustom 屬性列出伺服器名稱，則已在 Exchange 伺服器上設定自訂轉介。msExchFolderAffinityCustom 屬性是每個伺服器的屬性。

做為一般的最佳作法，建議您針對公用資料夾轉介使用預設行為。不過，您可能需要建立自訂轉介清單。非預設組態的訊息是參考訊息。不需要採取任何動作。

若要還原為 Exchange Server 2003 中的預設組態

  1. 開啟 [Exchange 系統管理員]。

  2. 找出設定自訂公用資料夾轉介的伺服器物件。在 Exchange Server Analyzer 訊息中會指定設定自訂公用資料夾轉介的 Exchange 伺服器名稱。

  3. 以滑鼠右鍵按一下 [Server_Name]，再按一下 [內容]。

  4. 在 [公用資料夾轉介] 索引標籤上，選取 [公用資料夾轉介選項] 下拉式方塊中的 [使用路由群組]。

  5. 按一下 [套用]，然後按一下 [確定]。
若要還原為 Exchange Server 2007 中的預設組態

  1. 下列程式碼為 Exchange 管理命令介面 Set-PublicFolderDatabase 命令的範例，可用來停用 [MyServer\First Storage Group\Public Folder Database] 公用資料夾資料庫的 PublicFolderRefferalServerList。
複製程式碼
Set-PublicFolderDatabase -Identity "MyServer\First Storage Group\Public Folder Database" -UseCustomReferralServerList $false

UseCustomReferralServerList 參數指定是否要使用 PublicFolderReferralServerList 參數所指定的伺服器成本。如果設定為 $true，伺服器就會使用 PublicFolderReferralServerList 參數成本來執行公用資料夾轉介。如果設定為 $false，伺服器就會使用 Active Directory 站台間成本來執行公用資料夾轉介。

附註：
將此參數設定為 $false 也會清除 PublicFolderReferralServerList 參數。

若需有關 Exchange 管理命令介面 Set-PublicFolderDatabase 命令的詳細資訊，請參閱 Exchange Server 2007 產品文件技術參考＜Set-PublicFolderDatabase＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80813)。

若需有關公用資料夾複寫的詳細資訊，請參閱《Exchange Server 公用資料夾的最佳作法》(英文) (http://go.microsoft.com/fwlink/?LinkId=46437)。


無法取得 Database 效能監視器物件
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Database 效能物件的 Log Record Stalls/sec 效能計數器的資料，以分析效能資料。如果計數器未傳回有效的資料，Exchange Server Analyzer 便會顯示基準線訊息。

如果效能資料收集引擎未傳回有效的資料，則發生了下列任意狀況組合：

  • Database 效能物件已停用。

  • Database 效能監視器物件已遺失或已損毀。

  • Exchange Server Analyzer 沒有適當的權限可存取效能物件。

如果某個可擴充的計數器損毀了登錄，或使用 Microsoft Windows® Management Instrumentation (WMI) 的程式修改了登錄，就會發生前兩個狀況。

下列程序解說如何修復前兩個狀況。在執行此程序前，請先確認 Exchange Server Analyzer 具有適當的權限。若需有關執行 Exchange Server Analyzer 所需權限的詳細資訊，請參閱包含在 Exchange Server Analyzer 中的說明文件。若需取得 [說明]，請開啟 Exchange Server Analyzer 並按 F1 鍵。

若要更正此錯誤

  1. 確認 Database 效能物件已啟用。

    1. 下載並安裝 Extensible Performance Counter List 工具 (Exctrlst.exe)。您可以在下列位置下載 Exctrlst.exe：「Exctrlst.exe：Extensible Performance Counter List」(英文) (http://go.microsoft.com/fwlink/?LinkId=34436)。

    2. 開啟 Exctrlst.exe，並依序按一下 [Sort Order] 及 [Service]。

    3. 找出要讓效能物件報告的服務，並確認已選取 [Performance Counters Enabled] 核取方塊。

      如果未選取 [Performance Counters Enabled] 核取方塊，請選取此核取方塊，然後重新啟動與效能計數器相關的服務，確認效能計數器可運作。如果效能計數器未運作，或已選取 [Performance Counters Enabled] 核取方塊，請繼續步驟 2。

  2. 依照微軟知識庫文件 - 300956＜如何手動重建效能計數器程式庫值＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) 中的指示，重建遺失或損毀的效能計數器。

  3. 如果遵循此知識庫文件的指示並不能解決問題，則必須以 [修復] 模式重新安裝 Exchange Server，並套用最新的 Exchange Server Service Pack。


DAVEX.DLL 檔案遺失
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔是否存在：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要解決此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 Microsoft Exchange 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


未執行 DHCP 用戶端服務
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Windows® Management Instrumentation (WMI) 類別，以判定動態主機設定通訊協定 (DHCP) 用戶端服務的 Started 機碼值。若 Exchange Server Analyzer 發現 Exchange 伺服器上，DHCP 用戶端服務的 Started 機碼值是設定為 [False]，則會顯示警告。

此警告會指出 DHCP 用戶端服務尚未執行。DHCP 用戶端服務會執行動態網域名稱系統 (DNS) 的更新。若未執行 DHCP 用戶端服務，動態更新將會失敗。若 Exchange Server 未執行此服務，最常見的問題是郵件流程問題。

要修正此問題，請將 DHCP 用戶端服務設為自動啟動，然後啟動服務。

附註：
即使將伺服器設定為使用靜態 IP 位址而非使用 DHCP，DHCP 用戶端服務也必須執行。
若要啟用 DHCP 用戶端服務

  1. 開啟 [服務] 嵌入式管理單元。

  2. 在詳細資料窗格中的 [DHCP 用戶端服務] 上按一下滑鼠右鍵，再按一下 [內容]。

  3. 在 [一般] 索引標籤上，按一下 [啟動類型]，並選取 [自動]。

  4. 按一下 [開始]，再按 [確定]。

若需有關 DHCP 用戶端服務的詳細資訊，請參閱微軟知識庫文件 - 264539＜若停止 DHCP 用戶端服務，將無法使用動態 DNS 更新＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264539)。

若需有關 DNS 動態更新通訊協定的詳細資訊，請參閱微軟知識庫文件 - 816592＜如何在 Windows Server 2003 中設定 DNS 動態更新＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592)。


Dr. Watson 未啟用
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄機碼的值，以判定 Dr. Watson 是否設定為 Microsoft Windows® 作業系統中的預設應用程式偵錯工具：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger

如果 Exchange Server Analyzer 發現 Debugger 的值不是以 drwtsn32 開頭，就會顯示非預設的組態訊息。

此訊息表示 Dr. Watson 未啟用。自 Windows NT® 起，Windows 已包含稱為 Dr. Watson 的應用程式模式偵錯工具。當應用程式當機時，Dr. Watson 會截獲此錯誤，它記錄多種不同資訊，例如平台資訊、執行中的處理程序清單、錯誤處理程序識別碼、錯誤處理程序的記憶體傾印、一或多個呼叫堆疊以及錯誤本身的指標。收集到的大部分資訊是專供錯誤處理程序的開發人員使用的低階偵錯資訊。

建議的最佳作法是在 Windows 中啟用應用程式模式偵錯程式。如果 Dr. Watson 未啟用而且您又沒有使用其他應用程式偵錯程式，建議您利用下列程序來啟用 Dr. Watson。

若要啟用 Dr. Watson

  1. 開啟 [命令提示字元] 視窗。

  2. 在命令提示字元中，鍵入 drwtsn32 -i。

若需有關啟用及停用 Dr. Watson 的詳細資訊，請參閱微軟知識庫文件 - 188296＜如何停用 Dr. Watson for Windows＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=188296)。


DSA Computer 名稱不符
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 DSA Computer 值的設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定每個 Exchange 伺服器物件的 name 屬性值。

最後，Exchange Server Analyzer 會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定叢集服務 (ClusSvc) 的 Started 機碼值。值為 True 表示已啟動叢集服務，值為 False 則表示叢集服務不在執行中。

針對不在 Windows Server 叢集中執行的任何 Exchange Server 電腦，如果 Exchange Server Analyzer 發現 DSA Computer 機碼值與 Active Directory 中伺服器物件的 name 屬性值不符，就會顯示一則錯誤。

若要更正此錯誤，您必須將 DSA Computer 登錄機碼編輯為符合 Active Directory 中的 name 屬性值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關如何編輯登錄的詳細資訊，請檢視 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右窗格中，連按兩下 DSA Computer，輸入此電腦的正確名稱，然後按一下 [確定]。

  4. 關閉登錄編輯程式，然後重新啟動 Exchange Server 電腦，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


DSACCESS.DLL 檔案遺失
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔是否存在：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要解決此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


DSAccess 組態快取已滿
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-05-24

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_PerfRawData_MSExchangeDSAccess_MSExchangeDSAccessCaches Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 TotalEntriesMemoryConfigurationData 目前的值。如果 Exchange Server Analyzer 工具發現 TotalEntriesMemoryConfigurationData 的值等於「目錄服務存取 (DSAccess)」組態快取 (MaxMemoryConfig) 的總大小，就會顯示一則警告。

DSAccess 為 Exchange 2000 Server 及 Exchange Server 2003 的內部元件，可控制所有 Exchange 元件存取 Active Directory® 目錄服務的方式。DSAccess 的主要功能是維護各種和目錄相關的事件及作業資訊。例如，DSAccess 會探索 Active Directory 拓樸，並且偵測網域控制站和通用類別目錄伺服器是否可用，並且回應查詢。此外，內部 Exchange 元件 (如 Microsoft Exchange 儲存區) 進行的所有目錄查詢都會經過 DSAccess 路由傳送，如收件者解析、組態設定查閱及其他等等。DSAccess 的工作之一，是在記憶體快取中維護這些查詢的某些結果，以便於再度要求相同的資訊時，可以直接從 DSAccess 快取中擷取資訊，而不用再對 Active Directory 發出另一個輕量型目錄存取通訊協定 (LDAP) 查詢。

因為 DSAccess 組態快取的預設設定大小上限，已從 Exchange 2000 Server 中的值 25 MB 減少為 Exchange Server 2003 中的值 5 MB，所以可能會在這兩個版本的 Exchange 電腦上產生此警告訊息。不論是哪一版 Exchange 產生這則警告訊息，都應該儘快解決問題。

MaxMemoryConfig 值常會與 MaxMemoryUser 值搭配使用，後者可控制 DSAccess 快取中之使用者資料物件可以耗用的記憶體數量上限。若您依下列程序所述來編輯或移除 MaxMemoryConfig 值，則同樣應該依照 DSAccess 使用者快取值並非預設值所述來編輯或移除 MaxMemoryUser 值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. 增加 MaxMemoryConfig 的值。如果 Instance0 機碼或 MaxMemoryConfig DWORD 值不存在，則可手動予以建立。MaxMemoryConfig 登錄項目的數值資料的單位是 KB；因此，輸入十進位數字 15000 就等於 15 MB。如果值存在，請將它增加百分之十。如果值不存在，則建議使用初始開始點 10 MB。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange System Attendant，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


DSAccess 組態快取值並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-17

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已將 Directory Service Access (DSAccess) 組態物件快取的大小修改為預設值以外的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0\MaxMemoryConfig

如果 Exchange Server Analyzer 發現 MaxMemoryConfig 存在而且已經設定，就會顯示非預設的組態訊息。

MaxMemoryConfig 是 Exchange Server 2003 中通常不再需要的 Exchange 2000 Server 登錄參數。MaxMemoryConfig 會控制允許 DSAccess 組態快取中的組態資料物件佔用的記憶體最大數量。DSAccess 是 Exchange 2000 Server 及 Exchange Server 2003 中的內部元件，可控制所有 Exchange 元件存取 Active Directory® 目錄服務的方式。DSAccess 的主要功能是維護各種和目錄相關的事件及作業資訊。例如，DSAccess 會探索 Active Directory 拓樸，並且偵測網域控制站和通用類別目錄伺服器是否可用，並且回應查詢。此外，內部 Exchange 元件 (如 Microsoft Exchange 儲存區) 進行的所有目錄查詢都會經過 DSAccess 路由傳送，如收件者解析、組態設定查閱及其他等等。DSAccess 的工作之一，是在記憶體快取中維護這些查詢的某些結果，以便於再度要求相同的資訊時，可以直接從 DSAccess 快取中擷取資訊，而不用再對 Active Directory 發出另一個輕量型目錄存取通訊協定 (LDAP) 查詢。

在 Exchange 2000 Server 中，組態快取大小初始設為 25 MB。在大部分的 Exchange 伺服器上，這個設定已經比所需的數量大許多。MaxMemoryConfig 設定原本是用來收回及重新配置 DSAccess 組態快取所使用的部分記憶體。通常是設定為 5 MB。但根據內部測試及顧客的反應，Microsoft 發現 3 MB 是最理想的大小，Exchange Server 2003 現在就是用這個大小來做為內建設定。從 Exchange 2000 Server 升級為 Exchange Server 2003 時，會保留所有的手動設定。如果這個 Exchange 伺服器是從 Exchange 2000 Server 升級至 Exchange Server 2003，您應確定 MaxMemoryConfig 的值大於 5 MB。

MaxMemoryConfig 值常會與 MaxMemoryUser 值搭配使用，後者可控制 DSAccess 快取中之使用者資料物件可以耗用的記憶體數量上限。若您依照下列程序編輯或移除 MaxMemoryConfig 值，則同樣應該依照 DSAccess 使用者快取值並非預設值中的描述編輯或移除 MaxMemoryUser 值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要使用收件者 MaxMemoryConfig 登錄值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. 檢查或編輯 MaxMemoryConfig 的值。
附註：
此登錄項目的值是以 KB 為單位。如果該值設為 3000 或以下，則應刪除 MaxMemoryConfig，並重新啟動 Microsoft Exchange System Attendant 服務，以回到 Exchange Server 2003 預設設定。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 DSAccess 的詳細資訊，請參閱知識庫文件 - 250570＜目錄服務伺服器偵測及 DSAccess 使用＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)。


DSAccess DisableNetLogonCheck 登錄參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已將 Directory Service Access (DSAccess) 設為使用非預設的 Ping 通訊協定：

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\DisableNetLogonCheck

如果 Exchange Server Analyzer 發現 DisableNetLogonCheck 存在，且設定的值大於 0，就會顯示非預設的組態訊息。

DSAccess 探索到 Active Directory® 目錄服務拓撲後，它會判定探索到的網域控制站及通用類別目錄伺服器是否適用。在初始探索及後續的重新探索期間，DSAccess 會執行一連串的測試來判斷伺服器是否適用。一個測試會將遠端程序呼叫 (RPC) 傳送給目錄伺服器，以測試其一般適用性。在通常不允許 RPC 流量的周邊網路案例中，DSAccess RPC 要求會失敗。不過，DSAccess 會繼續發出 RPC，直到失敗為止，這可能需要較長時間。此類重複檢查會對執行 Exchange Server 的電腦效能產生不良影響。因此，系統管理員通常會在位於周邊網路的 Exchange 伺服器上新增 DisableNetLogonCheck 登錄機碼，並將其設為值 1。

如果產生非預設組態訊息的 Exchange 伺服器位於停用 RPC 的周邊網路上，或如果您決定不要讓 DSAccess 執行此適用性測試，則應將 DisableNetLogonCheck 機碼設為 1。否則，就應該刪除 DisableNetLogonCheck 機碼。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要使用 DisableNetLogonCheck 機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. 按兩下 DisableNetLogonCheck 機碼，並將 DWORD 值設為 1.

  4. 關閉登錄編輯程式。不用重新啟動任何服務，變更即會生效。

若要刪除 DisableNetLogonCheck 機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. 刪除名為 DisableNetLogonCheck 的值。

  4. 關閉登錄編輯程式。不用重新啟動任何服務，變更即會生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 DisableNetLogonCheck 登錄機碼的詳細資訊，請參閱知識庫文件 - 320228＜XGEN：DisableNetLogonCheck 登錄值及其用法＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320228)。


已硬式編碼 DSAccess
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 ROOT\MicrosoftExchangeV2 命名空間中的 Exchange_DSAccessDC Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 ConfigurationType 機碼值。如果此機碼的值是 0，則會顯示非預設組態的訊息。

ConfigurationType 內容指出執行個體會描述自動偵測到的網域控制站，還是手動指定的網域控制站。Exchange Server 中的「目錄服務存取 (DSAccess)」元件非常好，它會自動偵測 Active Directory® 目錄服務拓撲，並自動尋找網域控制站及通用類別目錄伺服器。在執行 Exchange Server 2000 Service Pack 2 或更新版本或 Exchange Server 2003 的電腦上，Exchange 系統管理員能輸入供 DSAccess 使用之 Active Directory 伺服器的硬式編碼清單。

除非因特定原因而執行 DSAccess 之目錄伺服器的硬式編碼，否則應移除伺服器清單，並還原成自動探索的預設設定。建議您使用自動拓撲探索來利用通用類別目錄容錯移轉。

若要還原為預設設定

  1. 並依序按一下 [開始]、[程式集]、[Microsoft Exchange] 及 [系統管理員]。

  2. 展開 [系統管理群組 <AdminGroupName>]、[伺服器 <ServerName>] (其中 AdminGroupName 是包含 Exchange 伺服器的系統管理群組名稱，ServerName 則是您想要設定的 Exchange 伺服器之名稱)。

  3. 在 Exchange 伺服器上按一下滑鼠右鍵，再按一下 [內容]。

  4. 按一下 [目錄存取] 索引標籤。

  5. 在 [顯示] 清單方塊中，選取 [組態網域控制站]。

  6. 選取 [自動搜索伺服器] 核取方塊。

  7. 出現下列 [Exchange 系統管理員] 提示時，按一下 [是]：這會清除已指定之手動選取的伺服器。想要繼續嗎？

  8. 在 [顯示] 清單方塊中，選取 [網域控制站]。

  9. 選取 [自動搜索伺服器] 核取方塊。

  10. 出現下列 [Exchange 系統管理員] 提示時，按一下 [是]：這會清除已指定之手動選取的伺服器。想要繼續嗎？

  11. 在 [顯示] 清單方塊中，選取 [通用類別目錄伺服器]。

  12. 選取 [自動搜索伺服器] 核取方塊。

  13. 出現下列 [Exchange 系統管理員] 提示時，按一下 [是]：這會清除已指定之手動選取的伺服器。想要繼續嗎？

  14. 按一下 [確定]，儲存變更。

若需有關 DSAccess 及目錄服務偵測的詳細資訊，請參閱微軟知識庫文件 - 250570＜目錄服務伺服器偵測及 DSAccess 使用＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)。


DSAccess 不是使用通訊埠 389 來接受 LDAP 網域控制站要求
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 ROOT\MicrosoftExchangeV2 命名空間中的 Exchange_DSAccessDC Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 LDAPPort 機碼值。若 LDAPPort 機碼的值不是設為 389，就會顯示一則非預設組態的訊息。

LDAPPort 機碼代表網域控制站接聽「輕量型目錄存取通訊協定 (LDAP)」要求的 TCP 埠號。系統管理員可以在 TCP 通訊埠 636 (網域控制站) 或 TCP 通訊埠 3269 (通用類別目錄) 上使用 LDAP over Secure Sockets Layer (SSL)，作為安全措施。

在預設的情況下，通用類別目錄伺服器會在通訊埠 3268 接聽 LDAP 的通訊。不過，如有安裝企業憑證授權單位，則所有網域控制站都會自動要求憑證，並可在 TCP 通訊埠 636 上支援 LDAP over SSL 通訊。如果網域控制站同時也設定為通用類別目錄，則它也可以在 TCP 通訊埠 3269 上支援 LDAP over SSL 通訊

若要更正此錯誤

  • 不需要採取任何動作。Exchange Server Analyzer 識別出有非預設組態。

若需有關 DSAccess 及 LDAP 通訊埠的詳細資訊，請參閱下列微軟知識庫文件：

  • 247078＜如何為 Windows 2000 網域控制站啟用 LDAP 上的 Secure Sockets Layer (SSL) 通訊＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=247078)

  • 246228＜XGEN:DSAccess 設定檔＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246228)


DSAccess 不是使用通訊埠 3268 來接受 LDAP 通用類別目錄要求
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 ROOT\MicrosoftExchangeV2 命名空間中的 Exchange_DSAccessDC Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 LDAPPort 機碼值。若 LDAPPort 機碼的值不是設為 3268，就會顯示一則非預設組態的訊息。

LDAPPort 機碼代表網域控制站接聽「輕量型目錄存取通訊協定 (LDAP)」要求的 TCP 埠號。系統管理員可以在 TCP 通訊埠 636 (網域控制站) 或 TCP 通訊埠 3269 (通用類別目錄) 上使用 LDAP over Secure Sockets Layer (SSL)，作為安全措施。

在預設的情況下，通用類別目錄伺服器會在通訊埠 3268 接聽 LDAP 的通訊。不過，如有安裝企業憑證授權單位，則所有網域控制站都會自動要求憑證，並可在 TCP 通訊埠 636 上支援 LDAP over SSL 通訊。如果網域控制站同時也設定為通用類別目錄，則它也可以在 TCP 通訊埠 3269 上支援 LDAP over SSL 通訊

若需有關 DSAccess 及 LDAP 通訊埠的詳細資訊，請參閱下列微軟知識庫文件：

  • 247078＜如何為 Windows 2000 網域控制站啟用 LDAP 上的 Secure Sockets Layer (SSL) 通訊＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=247078)

  • 246228＜XGEN:DSAccess 設定檔＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246228)


DSAccess LdapKeepAliveSecs 登錄參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已將 Directory Service Access (DSAccess) 設定為使用輕量型目錄存取通訊協定 (LDAP) Microsoft Windows® 作業系統實作 (wLDAP) 通訊協定：

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\ LdapKeepAliveSecs

如果 Exchange Server Analyzer 發現 LdapKeepAliveSecs 存在，且設定的值為 0，就會顯示非預設的組態訊息。

DSAccess 探索到 Active Directory® 目錄服務拓撲後，它會判定探索到的作用中網域控制站及通用類別目錄伺服器清單是否適用。在初始探索及後續的重新探索期間，DSAccess 會執行一連串的測試來判斷伺服器是否適用。依預設，其中一個適用性測試會使用網路網路控制訊息通訊協定 (ICMP) 來 Ping 網域控制站，以確認伺服器是否可用。

不是網路中的所有連線都支援 ICMP。此情況的特定範例為周邊網路，其中並不允許 Exchange 伺服器及網域控制站間進行 ICMP 連線。在這些情況下，將 LdapKeepAliveSecs 登錄參數設為 0，會強制 DSAccess 使用 LDAP 的 Windows 實作 (wLDAP) 來進行適用性測試。

如果產生非預設組態訊息的 Exchange 伺服器位於已停用遠端程序呼叫 (RPC) 的周邊網路中，或位於不允許 ICMP 的網路中，您就應該保留原來所設定的 LdapKeepAliveSecs 機碼。否則，您應該刪除機碼。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要刪除 LdapKeepAliveSecs 機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. 刪除名為 LdapKeepAliveSecs 的值。

  4. 關閉登錄編輯程式。不用重新啟動任何服務，變更即會生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 LdapKeepAliveSecs 登錄機碼的詳細資訊，請參閱知識庫文件 - 320529＜XADM：在周邊網路防火牆案例中使用 DSAccess 需要登錄機碼設定＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320529)。


DSAccess LdapKeepAliveSecs 登錄參數已設為不支援的值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已將 Directory Service Access (DSAccess) 設定為使用輕量型目錄存取通訊協定 (LDAP) Microsoft Windows® 作業系統實作 (wLDAP) 通訊協定：

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\ LdapKeepAliveSecs

如果 Exchange Server Analyzer 發現 LdapKeepAliveSecs 存在，且設定為 0 以外的值，就會顯示警告。

DSAccess 探索到 Active Directory® 目錄服務拓撲後，它會判定探索到的作用中網域控制站及通用類別目錄伺服器清單是否適用。在初始探索及後續的重新探索期間，DSAccess 會執行一連串的測試來判斷伺服器是否適用。依預設，其中一個適用性測試會使用網路網路控制訊息通訊協定 (ICMP) 來 Ping 網域控制站，以確認伺服器是否可用。

不是網路中的所有連線都支援 ICMP。此情況的特定範例為周邊網路，其中並不允許 Exchange 伺服器及網域控制站間進行 ICMP 連線。在這些情況下，將 LdapKeepAliveSecs 登錄參數設為 0，會強制 DSAccess 使用 wLDAP 來進行適用性測試。

如果產生此警告的 Exchange 伺服器位於已停用遠端程序呼叫 (RPC) 的周邊網路中，或位於不允許 ICMP 的網路中，請將 LdapKeepAliveSecs 機碼設為 0。否則，您應該刪除機碼。零以外的任何值都不是此登錄機碼支援的值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要修改 LdapKeepAliveSecs 機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. 按兩下 LdapKeepAliveSecs 機碼，並將 DWORD 值設為 0 (零)。

  4. 關閉登錄編輯程式。不用重新啟動任何服務，變更即會生效。

若要刪除 LdapKeepAliveSecs 機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. 刪除名為 LdapKeepAliveSecs 的值。

  4. 關閉登錄編輯程式。不用重新啟動任何服務，變更即會生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 LdapKeepAliveSecs 登錄機碼的詳細資訊，請參閱知識庫文件 - 320529＜XADM：在周邊網路防火牆案例中使用 DSAccess 需要登錄機碼設定＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320529)。


DSAccess PreloadBaseDNs 登錄參數不是預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更 Directory Service Access (DSAccess) 的搜尋預先載入功能為非預設組態：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\PreloadBaseDNs

PreloadBaseDNs 的預設數值資料為：

'"'

'"'

'"'

'"'

'"'

如果 Exchange Server Analyzer 發現 PreloadBaseDNs 已修改為這些預設值以外的值，就會顯示警告訊息。因為此為僅應在諮詢 Microsoft 產品支援服務之後才可修改的設定，所以 Exchange Server Analyzer 會報告此組態。

DSAccess 快取位於 Exchange 伺服器上，並收集擷取自 Active Directory® 目錄服務的組態與使用者記錄。DSAccess 快取中的記錄可以使用物件的辨別名稱、全域唯一識別項 (GUID) 或機碼存取，該機碼是由範圍、BaseDN 及用於在 Active Directory 中尋找物件的搜尋篩選建構而成。使用相同辨別名稱、GUID 或機碼的後續存取會在快取中找到記錄。因此，會在 Active Directory 上阻止不必要的負載，以獲得相同的搜尋。不過，當搜尋篩選條件與快取中所包含的搜尋篩選條件不同時，儘管 DSAccess 要求使用者物件具有相同的屬性設定，DSAccess 也不會阻止載入到 Active Directory。

當在同一個使用者物件上發出不同的搜尋篩選條件時，會發生多個 Active Directory 搜尋問題，搜尋預先載入是避免這些問題的一種方法。搜尋預先載入是利用之前提到的機碼建構 (其中，搜尋項目是由範圍、BaseDN 及搜尋條件建構而成) 來運作。

若需有關設定 DSAccess 搜尋預先載入的詳細資訊，請參閱微軟知識庫文件 - 250572＜XCON：預先載入及 DSAccess 快取＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250572)。


DSAccess PreloadFilters 登錄參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更 Directory Service Access (DSAccess) 的搜尋預先載入功能預設組態：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\PreloadFilters

PreloadFilters 的預設數值資料為：

(&(|(msExchMasterAccountSID=%)(objectSid=%))(!(objectClass=foreignSecurityPrincipal)))(|(msExchMailboxGUID=%)(objectGUID=%))(legacyExchangeDN=%)(msExchMailboxGUID=%)(&(proxyAddresses=%)(|(objectClass=user)(objectClass=contact)))

如果 Exchange Server Analyzer 發現 PreloadFilters 值的預設值已經修改，就會顯示警告。因為您只應該在洽詢 Microsoft 產品支援服務後才變更 PreloadFilters 登錄設定，所以 Exchange Server Analyzer 會報告此組態。

DSAccess 快取位於 Exchange 伺服器中，可收集從 Active Directory® 目錄服務擷取到的組態及使用者記錄。　快取中的記錄可以使用物件的辨別名稱、全域唯一識別項 (GUID) 或機碼進行存取，該機碼是由範圍、BaseDN 及用於在 Active Directory 中尋找此物件的搜尋篩選建構而成。使用相同辨別名稱、GUID 或機碼的後續存取會在快取中找到記錄。因此，Active Directory 上會針對相同的搜尋防止不必要的載入，。然而，當搜尋篩選與快取中所含的搜尋篩選不同時，DSAccess 就不會防止 Active Directory 的載入，即使 DSAccess 要求為使用者物件設定相同的屬性，仍是如此。

當在同一個使用者物件上發出不同的搜尋篩選時，會發生各種 Active Directory 搜尋問題，搜尋預先載入是避免這些問題的一種方法。搜尋預先載入藉由前述的索引碼建構運作，其中的搜尋項目以範圍、BaseDN、或搜尋篩選所建構。

若需有關設定 DSAccess 搜尋預先載入的詳細資訊，請參閱微軟知識庫文件 - 250572＜XCON：預先載入及 DSAccess 快取＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250572)。


DSAccess 報告了這個 Active Directory 伺服器不在運作中
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 ROOT\MicrosoftExchangeV2 命名空間中的 Exchange_DSAccessDC Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 IsUp 機碼值。如果 IsUp 機碼設定為 False，就會顯示一則錯誤。

如果 IsUp 機碼設定為 True，則表示網域控制站在上次 Exchange 伺服器嘗試建立連線時，有做出回應。如果 IsUp 的設定為 False，則表示網域控制站沒有回應嘗試的連線作業。

沒有回應並不一定就表示網域控制站或通用類別目錄關閉或故障。有時候可能是因為 Exchange 伺服器與網域控制站之間的網路連線發生問題，才會導致失敗。失敗的原因也可能是 Exchange 伺服器與網域控制站之間的防火牆沒有開啟適當的通訊埠。

若要更正此錯誤

  1. 嘗試用 ping 來連線，以檢查網域控制站是否正在執行。

  2. 如果有防火牆，請確定防火牆上正確的連接埠已開啟。請注意，您也可以設定防火牆來捨棄 PING 封包。請查看您的防火牆文件，以取得有關如何開啟或關閉特定連接埠的詳細資料。

  3. 確定沒有其他相關的網路問題，例如交換機、路由器及纜線問題等等。

若需有關 DSAccess 及目錄服務偵測的詳細資訊，請參閱微軟知識庫文件 - 250570＜目錄服務伺服器偵測及 DSAccess 使用＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)。

若需有關疑難排解網路連線問題的詳細資訊，請參閱知識庫文件 - 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。


DSAccess 報告此 Active Directory 伺服器未與其他的拓樸保持同步
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-04-21

Microsoft® Exchange Server Analyzer 工具會查詢 ROOT\MicrosoftExchangeV2 命名空間中的 Exchange_DSAccessDC Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 IsInSync 機碼值。如果 IsInSync 的值為 FALSE，則會顯示錯誤訊息。

IsInSync 機碼指示網域控制站是否與通用類別目錄伺服器及組態網域控制站保持同步。值為 TRUE 表示伺服器已同步化，值為 FALSE 則表示網域控制站未同步化。

若要更正此錯誤

  1. 檢查網域控制站或通用控制站上的時間。確定已啟動時間服務，或手動同步化 Exchange 伺服器與通用類別目錄伺服器或組態網域控制站上的時間。

  2. 使用複寫監視器工具 (Replmon) 來檢查、確認，以及修正網域控制站複寫問題 (若有需要)。Replmon 是 Microsoft Windows 2000 Server 與 Microsoft Windows Server™ 2003 支援工具的一部分，這些工具位於 Windows Server CD 的 \Support\Tools 資料夾中。

若需 DSAccess 與目錄服務偵測的相關資訊，請參閱下列微軟知識庫文件：

  • 316300＜事件識別碼 2080 與 MSExchangeDSAccess＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316300)

  • 250570＜目錄服務伺服器偵測及 DSAccess 使用＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)


DSAccess 報告了此 Active Directory 伺服器回應 LDAP 要求的時間超過 2 秒。
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 ROOT\MicrosoftExchangeV2 命名空間中的 Exchange_DSAccessDC Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 IsFast 機碼及 IsUp 機碼的值。如果 IsUp 機碼的值是 True，表示 Exchange Server 中 Directory Service Access (DSAccess) 元件所使用的目錄伺服器已連線至網路而且有回應。False 值表示目錄伺服器沒有回應。如果 IsFast 的值是 True，表示此目錄伺服器的回應時間小於 2 秒。False 值表示回應時間超過 2 秒。如果 IsUp 的值是 True，但 IsFast 的值是 False，就會顯示一則錯誤。

若要更正此錯誤

  1. 檢查網域控制站及通用類別目錄的負載。超載的網域控制站及通用類別目錄會使得回應「輕量型目錄存取通訊協定 (LDAP)」呼叫的速度變慢。

  2. 確定本機 Active Directory® 目錄服務站台有至少一個通用類別目錄，以達到最佳效能。

若需有關 DSAccess 及目錄服務偵測的詳細資訊，請參閱微軟知識庫文件 - 250570＜目錄服務伺服器偵測及 DSAccess 使用＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)。


DSAccess TopoCreateTimeoutSecs 登錄參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更 Directory Service Access (DSAccess) 初始化逾時預設值：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess\TopoCreateTimeoutSecs

如果 Exchange Server Analyzer 發現 TopoCreateTimeoutSecs 機碼存在，且其值大於 0，就會顯示非預設的組態訊息。

在啟動時，DSAccess 會使用探索處理程序來識別 Active Directory® 目錄服務拓撲，以及存取網域控制站與通用類別目錄伺服器的可用性。啟動完成後，DSAccess 每隔 15 分鐘就會使用幾乎完全相同的處理程序重新探索拓撲，以及檢查伺服器可用性有無變更。根據預設，DSAccess 在啟動期間的起始設定必須在一分鐘之內完成。否則 DSAccess 就會停止。一般而言，一分鐘足夠讓 DSAccess 進行起始設定。

附註：
若您將 DSAccess 所使用的目錄伺服器硬式編碼，DSAccess 就會略過探索處理程序，而僅檢查伺服器可用性。
重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess

  3. 刪除名為 TopoCreateTimeoutSecs 的值。

  4. 關閉登錄編輯程式。

若此登錄機碼存在，您就應該考慮評估您的網路拓撲。若組織中的 DSAccess 起始設定時需要較多時間，就表示可能有設計或網路方面的問題。若要有最佳化的 Exchange 作業，則必須對網域控制站 (尤指通用類別目錄伺服器) 具有迅速而可靠的存取。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關目錄存取的詳細資訊，請參閱《瞭解及疑難排解目錄存取》(英文) (http://go.microsoft.com/fwlink/?LinkId=39012)。


DSAccess 使用者快取已滿
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-04-20

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_PerfRawData_MSExchangeDSAccess_MSExchangeDSAccessCaches Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 TotalEntriesMemoryUserData 目前的值。如果 Exchange Server Analyzer 工具發現 TotalEntriesMemoryUserData 的值等於目錄服務存取 (DSAccess) 使用者快取 (MaxMemoryUser) 的總大小，就會顯示一則警告。

DSAccess 為 Exchange 2000 Server 及 Exchange Server 2003 的內部元件，可控制所有 Exchange 元件存取 Active Directory® 目錄服務的方式。DSAccess 的主要功能是維護各種和目錄相關的事件及作業資訊。例如，DSAccess 會探索 Active Directory 拓樸，並且偵測網域控制站和通用類別目錄伺服器是否可用，並且回應查詢。此外，會透過 DSAccess (如收件者解析、組態設定查詢及其他) 來路由傳送內部 Exchange 元件 (如 Exchange 儲存區) 執行的所有目錄查詢。DSAccess 的工作之一，是在記憶體快取中維護這些查詢的某些結果，以便於再度要求相同的資訊時，可以直接從 DSAccess 快取中擷取資訊，而不用再對 Active Directory 發出另一個輕量型目錄存取通訊協定 (LDAP) 查詢。

在 Exchange 2000 Server 中，使用者快取一開始是設為 25 MB。在服務大量 Microsoft Office Outlook® 2003 用戶端的 Exchange 2000 Server 電腦上，預設的 DSAccess 使用者快取大小不夠。若要增進效能，則需在 Exchange Server 2003 中最佳化使用者快取的預設值，並設為 140 MB。

因為 DSAccess 使用者快取的預設設定大小上限已從 Exchange 2000 Server 中的值 25 MB 增加為 Exchange Server 2003 中的值 140 MB，所以可能會在 Exchange 2000 Server 電腦上產生此警告訊息。不論是哪一版 Exchange 產生這則警告訊息，都應該儘快解決問題。在 DSAccess 快取大小較小的系統上，本機郵件傳遞及通訊錄名稱解析可能會比您預期的慢。

可使用 Exchange 伺服器上的登錄項目來手動設定使用者快取的大小上限。MaxMemoryUser 是 Exchange 2000 Server 登錄參數，此參數可讓 Exchange 系統管理員控制 DSAccess 快取中的使用者資料物件可耗用的最大記憶體量。

MaxMemoryUser 值通常會與 MaxMemoryConfig 值搭配使用，以控制 DSAccess 快取中之組態資料物件可耗用的最大記憶體量。如果依照下列程序所述，編輯或移除 MaxMemoryUser 值，則您應該同樣地依照 DSAccess 組態快取值並非預設值所述，編輯或移除 MaxMemoryConfig 值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

更正 Exchange 2000 Server 電腦上的這個問題

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. 增加 MaxMemoryUser 的值。如果這個 DWORD 值不存在，您可以手動建立它。此登錄項目的數值資料是以 KB 為單位；因此，十進位項目 140000 等於 140 MB。

  4. 減少 MaxMemoryConfig 的值。如果這個 DWORD 值不存在，您可以手動建立它。此登錄項目的數值資料也是以 KB 為單位。建議使用十進位值 5000 (等於 5 MB)。

  5. 結束登錄編輯程式，然後重新啟動 Microsoft Exchange System Attendant，使變更生效。

更正 Exchange Server 2003 電腦上的這個問題

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. 如果 MaxMemoryUser 存在且設為小於 140 MB，請刪除 MaxMemoryUser 值。如果 MaxMemoryUser 存在且大於 140 MB，請將它的值增加 10%。

  4. 如果 MaxMemoryConfig 存在，請將它刪除。

  5. 結束登錄編輯程式，並重新啟動 Exchange System Attendant，使變更生效。

在編輯登錄之前，以及想瞭解有關如何編輯登錄的詳細資訊時，請閱讀微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需 DSAccess 的詳細資訊，請參閱知識庫文件 - 250570＜目錄服務伺服器偵測及 DSAccess 使用＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570)。


DSAccess 使用者快取值並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已修改 Directory Service Access (DSAccess) 使用者物件快取大小的預設值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0\MaxMemoryUser

如果 Exchange Server Analyzer 發現 MaxMemoryUser 已存在且已設定，就會顯示非預設的組態訊息。

MaxMemoryUser 是個 Exchange 伺服器登錄參數，該參數可讓 Exchange 系統管理員控制 DSAccess 快取中的使用者資料物件可以耗用的記憶體數量上限。

DSAccess 為 Exchange 2000 Server 及 Exchange Server 2003 的內部元件，可控制所有 Exchange 元件存取 Active Directory® 目錄服務的方式。DSAccess 的主要功能是維護各種和目錄相關的事件及作業資訊。例如，DSAccess 會探索 Active Directory 拓樸，並且偵測網域控制站和通用類別目錄伺服器是否可用，並且回應查詢。此外，內部 Exchange 元件 (如 Exchange 儲存區) 進行的所有目錄查詢都會經過 DSAccess 路由傳送，如收件者解析、組態設定查閱及其他等等。DSAccess 的工作之一，是在記憶體快取中維護這些查詢的某些結果，以便於再度要求相同的資訊時，可以直接從 DSAccess 快取中擷取資訊，而不用再對 Active Directory 發出另一個輕量型目錄存取通訊協定 (LDAP) 查詢。

在 Exchange 2000 Server 中，使用者快取大小最初是設為 25 MB。在服務大量 Microsoft Office Outlook® 2003 用戶端的 Exchange 2000 Server 電腦上，預設的 DSAccess 使用者快取大小不夠。在 DSAccess 快取不足的系統上，本機郵件傳遞及通訊錄名稱解析的速度可能會比較慢。

為了提高效能，已最佳化 Exchange Server 2003 中的使用者快取預設值，並設定為 140 MB。從 Exchange 2000 Server 升級到 Exchange Server 2003 時，任何手動設定都會保留。如果此 Exchange 伺服器是從 Exchange 2000 Server 升級到 Exchange Server 2003，您應該確定 MaxMemoryUser 的值至少有 140 MB。

MaxMemoryUser 值通常與 MaxMemoryConfig 值一起使用，該值控制 DSAccess 快取中的組態資料物件可以耗用的記憶體數量上限。如果依照下述程序編輯或移除 MaxMemoryUser 值，您同樣也應該依照 DSAccess 組態快取值並非預設值中的描述編輯或移除 MaxMemoryConfig 值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要使用 MaxMemoryUser 登錄機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. 檢查或編輯 MaxMemoryUser 的值。

    此登錄項目的值是以 KB 為單位。如果該值設為 140000 或以下，則應該刪除 MaxMemoryUser，然後重新啟動 Microsoft Exchange System Attendant，以將該值重設為 Exchange Server 2003 的預設設定。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 DSAccess 的詳細資訊，請參閱知識庫文件 - 250570＜目錄服務伺服器偵測及 DSAccess 使用＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)。


已停用 DSProxy RFR 服務
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已停用目錄服務 Proxy 轉介 (DSProxy RFR) 服務：

HKEY_LOCAL_MACHINE\ System\CurrentControlSet\Services\MSExchangeSA\Parameters\ No RFR Service

如果 Exchange Server Analyzer 發現 No RFR Service 存在且設為 1，則會顯示非預設的組態訊息。

Exchange 2000 Server 及 Exchange Server 2003 中的 DSProxy 元件，針對 Microsoft Outlook® 98 及 Outlook 97 用戶端，提供對網域控制站或通用類別目錄的目錄存取權。Outlook 2000 Service Release 2 (SR-2) 及更新版本可直接查詢通用類別目錄伺服器。

Outlook 2000 SR-2 或更新版本用戶端第一次連線到 Exchange 2000 伺服器或更新版本電腦時，它會在起始 Exchange 伺服器上尋找目錄服務。Outlook 會先進行一開始的工作階段之 DSProxy 處理程序。當用戶端連絡 DSProxy 服務 (它會嘗試所有可用的傳輸通訊協定) 之後，會將轉介傳送回用戶端，以通知它所有未來的目錄要求都應該移至通用類別目錄伺服器。Outlook 會在登錄中設定 MAPI 設定檔的轉介。DSProxy 轉介機制可減輕 Exchange 伺服器的負載，並縮短搜尋通訊錄的延遲時間。如果將明確宣告的伺服器名稱輸入設定檔中，則在 Active Directory® 目錄服務伺服器失敗時，必須重新啟動 Outlook。如果發生這種情形，Exchange 伺服器會傳給 Outlook 新的轉介。

在部份案例中，您可能會想要強制 Outlook 用戶端 (甚至最新版本) 在未進行轉介的情況下一律進行 DSProxy 處理程序。例如，如果 Outlook 與 Exchange 伺服器之間有防火牆，您可能需要這麼做。

新增 No RFR Service 登錄項目，並將它設為 1，Exchange 伺服器便會當成 Outlook 用戶端的 Proxy，而不是將用戶端轉介到適當的通用類別目錄伺服器來進行直接通訊。因為 Exchange 伺服器會擔任所有 Outlook 用戶端 (包括可直接與 Active Directory 通訊的 Outlook 2000 SR-2 及更新版的用戶端) 的 Proxy，所以將 No RFR Service 登錄參數設為 1 會降低 Exchange 伺服器的效能。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

啟用 DSProxy RFR 服務

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 建立新的 DWORD 值：No RFR Service。

  4. 將 No RFR Service 值設為 1。

若要停用 DSProxy RFR 服務，請刪除 No RFR Service 登錄值，或將它設為 0。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Outlook 2000 SR-2 及較新的用戶端如何與 Active Directory 互動的詳細資訊，請參閱知識庫文件 - 256976＜XCCC：Outlook 2000 如何存取 Active Directory＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914)。

若需有關 MAPI 用戶端如何存取 Active Directory 的詳細資訊，請參閱知識庫文件 - 256976＜XCLN：MAPI 用戶端如何存取 Active Directory＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976)


EMSMTA.EXE 檔案遺失
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔是否存在：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要解決此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


啟用 EnableAuthEpResolution 登錄機碼
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已啟用遠端程序呼叫 (RPC) 介面限制登錄機碼：

HKEY_LOCAL_MACHINE\ Software\Policies\Microsoft\Windows NT\RPC

如果 Exchange Server Analyzer 發現 EnableAuthEpResolution 登錄值已存在，就會顯示非預設的組態訊息。

RPC 介面限制提供更多的網路保護功能，可降低系統受到網路攻擊的機會。

從遠端匿名可用，且預設已在 Microsoft Windows® XP 上註冊的 RPC 介面呈現重大攻擊面。RPC 本身必須註冊這樣一個介面，為使用動態端點的呼叫提供端點解析。RestrictRemoteClients 登錄機碼會修改系統上所有 RPC 介面的行為。在預設的情況下，RestrictRemoteClients 登錄機碼會防止對系統上 RPC 介面的遠端匿名存取 (某些例外)。因此，不可再匿名使用 RPC 端點對應器介面。

使用動態端點進行呼叫的 RPC 用戶端，將首先查詢伺服器上的 RPC 端點對應器，以判定 RPC 用戶端應連接至哪一動態端點。即使 RPC 用戶端呼叫本身使用 RPC 安全性來執行，此查詢也會以匿名方式執行。在預設的情況下，對 RPC 端點對應器介面的匿名呼叫在 Microsoft Windows XP Service Pack 2 上將失敗，因為預設的 RestrictRemoteClients 功能會防止對系統上 RPC 介面的遠端匿名存取。因為此 RPC 介面限制，所以會修改 RPC 用戶端執行階段以執行對端點對應器的驗證查詢。此 RPC 介面限制是 Windows XP Service Pack 2 中的預設行為。RPC 用戶端執行階段然後會使用整合式 Windows 驗證 (之前稱為 NTLM) 來驗證端點對應器。如果實際 RPC 用戶端呼叫使用此種驗證，則會執行整合式 Windows 驗證。如果存在下列情況，則會存在非預設組態：

  • 已建立所說明的 RPC 登錄機碼及 EnableAuthEpResolution 值。

  • EnableAuthEpResolution 登錄值已設為 0。

若需有關 Windows XP Service Pack 2 中 RPC 服務之變更的詳細資訊，請參閱《RPC 介面限制》(英文) (http://go.microsoft.com/fwlink/?LinkId=47371)。


Epoxy Client Out Queue Length (IMAP) 超出閾值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-02-13

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Epoxy 效能物件的 Client Out Queue Length (IMAP) 效能計數器的資料，以分析效能資料。

Client Out Queue Length (IMAP) 效能計數器指出佇列中包含由 Inetinfo.exe 處理程序傳送到 Store.exe 處理程序的 IMAP4 郵件的郵件數目。不管在什麼時候，佇列都應在 50 以下。如果 Exchange Server Analyzer 判定 Client Out Queue Length (IMAP) 計數器已在取樣時間配量期間超出尖峰值 50，則會顯示錯誤。

Epoxy (ExIPC) 是共用記憶體機制，此機制可讓 Microsoft Internet Information Services (IIS) (Inetinfo.exe) 及 Microsoft Exchange Information Store 服務 (Store.exe) 的處理程序迅速地來回移動資料。這容許在 Inetinfo.exe 處理程序與 Store.exe 處理程序之間進行處理程序間的雙向通訊。

附註：
Inetinfo.exe 接受網際網路通訊協定 (例如 WebDAV、IMAP4、NNTP、POP3 及 SMTP) 所提出的要求。

DSAccess 也會使用這個記憶體，DSAccess 是快取 Active Directory® 資訊的 Exchange 元件。

這個錯誤表示在 Store.exe 處理程序中，或在 Store.exe 處理程序所依存的資源中發生效能問題，這些效能問題導致這個佇列變大。這將導致伺服器回應時間增加。

若要解決這個問題，請使用＜詳細資訊＞一節中所提到的資源，識別 Store.exe 處理程序或相關資源的效能瓶頸。這個瓶頸可能與不良的磁碟效能或高 CPU 使用率相關。

詳細資訊

  • 若需識別 Epoxy 中不斷增大之佇列的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》中的＜識別 Epoxy 中不斷增大的佇列＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 若需處理器瓶頸的詳細資訊，請參閱＜處理器瓶頸＞。

  • 若需磁碟瓶頸的詳細資訊，請參閱＜偵測到磁碟瓶頸＞。

  • 若需疑難排解儲存區效能的詳細資訊，請參閱微軟知識庫文件 - 257725＜XADM：如何收集診斷資料以進行資訊存放的疑難排解＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。

  • 若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


Epoxy Client Out Queue Length (POP) 超出閾值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-02-13

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Epoxy 效能物件的 Client Out Queue Length (POP) 效能計數器的資料，以分析效能資料。

Client Out Queue Length (POP) 計數器指出佇列中有多少郵件包含由 Inetinfo.exe 處理程序傳送至 Store.exe 處理程序的 POP3 郵件。不管在什麼時候，佇列都應在 50 以下。Exchange Server Analyzer 會在 5 分鐘內每隔 5 秒從這個計數器擷取樣本一次。如果 Exchange Server Analyzer 判定 Client Out Queue Length (POP) 計數器已在取樣時間配量期間超出尖峰值 50，則會顯示錯誤。

Epoxy (ExIPC) 是共用記憶體機制，此機制可讓 Microsoft Internet Information Services (IIS) (Inetinfo.exe) 及 Microsoft Exchange Information Store 服務 (Store.exe) 的處理程序迅速地來回移動資料。這容許在 Inetinfo.exe 處理程序與 Store.exe 處理程序之間進行處理程序間的雙向通訊。

附註：
Inetinfo.exe 接受網際網路通訊協定 (例如 WebDAV、IMAP4、NNTP、POP3 及 SMTP) 所提出的要求。

DSAccess 也會使用這個記憶體，DSAccess 是快取 Active Directory® 資訊的 Exchange 元件。

這個錯誤表示在 Store.exe 處理程序中，或在 Store.exe 處理程序所依存的資源中發生效能問題，這些效能問題導致這個佇列變大。這將導致伺服器回應時間增加。

若要解決這個問題，請使用＜詳細資訊＞一節中所提到的資源，識別 Store.exe 處理程序或相關資源的效能瓶頸。這個瓶頸可能與不良的磁碟效能或高 CPU 使用率相關。

詳細資訊

  • 若需識別 Epoxy 中不斷增大之佇列的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》中的＜識別 Epoxy 中不斷增大的佇列＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 若需處理器瓶頸的詳細資訊，請參閱＜處理器瓶頸＞。

  • 若需磁碟瓶頸的詳細資訊，請參閱＜偵測到磁碟瓶頸＞。

  • 若需疑難排解儲存區效能的詳細資訊，請參閱微軟知識庫文件 - 257725＜XADM：如何收集診斷資料以進行資訊存放的疑難排解＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。

  • 若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


EPOXY.DLL 檔案遺失
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要解決此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange Server 2000 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


無法取得 Epoxy 效能監視器物件
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Epoxy 效能物件的 Client Out Queue Length 效能計數器的資料，以分析效能資料。如果計數器未傳回有效的資料，Exchange Server Analyzer 便會顯示基準線訊息。

如果效能資料收集引擎未傳回有效的資料，則發生了下列任意狀況組合：

  • Epoxy 效能監視器物件已停用。

  • Epoxy 效能監視器物件已遺失或已損毀。

  • Exchange Server Analyzer 沒有適當的權限可存取效能物件。

如果某個可擴充的計數器損毀了登錄，或使用 Microsoft Windows® Management Instrumentation (WMI) 的程式修改了登錄，就會發生前兩個狀況。下列程序解說如何修復前兩個狀況。在執行此程序前，請先確認 Exchange Server Analyzer 具有適當的權限。若需有關執行 Exchange Server Analyzer 所需權限的詳細資訊，請參閱包含在 Exchange Server Analyzer 中的說明文件。若需取得 [說明]，請開啟 Exchange Server Analyzer 並按 F1 鍵。

若要更正此錯誤

  1. 確認 Epoxy 效能物件已啟用：

    1. 下載並安裝 Extensible Performance Counter List 工具 (Exctrlst.exe)。您可以在下列網站下載 Exctrlst.exe：「Exctrlst.exe：Extensible Performance Counter List」(英文) (http://go.microsoft.com/fwlink/?LinkId=34436)。

    2. 開啟 Exctrlst.exe，並依序按一下 [Sort Order] 及 [Service]。

    3. 找出要讓效能物件報告的服務，並確認已選取 [Performance Counters Enabled] 核取方塊。

      如果未選取 [Performance Counters Enabled] 核取方塊，請選取此核取方塊，然後重新啟動與效能計數器相關的服務，確認效能計數器可運作。如果效能計數器未運作，或已選取 [Performance Counters Enabled] 核取方塊，請繼續步驟 2。

  2. 依照微軟知識庫文件 - 300956＜如何手動重建效能計數器程式庫值＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) 中的指示，重建遺失或損毀的效能計數器。

  3. 如果遵循此知識庫文件的指示並不能解決問題，則必須以 [修復] 模式重新安裝 Exchange Server，並套用最新的 Exchange Server Service Pack。


Epoxy Store Out Queue Length (IMAP) 超出閾值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-02-13

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Epoxy 效能物件的 Store Out Queue Length (IMAP) 效能計數器的資料，以分析效能資料。

Store Out Queue Length (IMAP) 效能計數器指出佇列中包含由 Store.exe 處理程序傳送到 Inetinfo.exe 處理程序的 IMAP4 郵件的郵件數目。不管在什麼時候，佇列都應在 50 以下。Exchange Server Analyzer 會在 5 分鐘內每隔 5 秒從這個計數器擷取樣本一次。如果 Exchange Server Analyzer 判定 Store Out Queue Length (IMAP) 計數器已在取樣時間配量期間超出尖峰值 50，則會顯示錯誤。

Epoxy (ExIPC) 是共用記憶體機制，此機制可讓 Microsoft Internet Information Services (IIS) (Inetinfo.exe) 及 Microsoft Exchange Information Store 服務 (Store.exe) 的處理程序迅速地來回移動資料。這容許在 Inetinfo.exe 處理程序與 Store.exe 處理程序之間進行處理程序間的雙向通訊。

附註：
Inetinfo.exe 接受網際網路通訊協定 (例如 WebDAV、IMAP4、NNTP、POP3 及 SMTP) 所提出的要求。

DSAccess 也會使用這個記憶體，DSAccess 是快取 Active Directory® 資訊的 Exchange 元件。

這個錯誤表示在 Inetinfo.exe 處理程序中，或在 Inetinfo.exe 處理程序所依存的資源中發生效能問題，這些效能問題導致這個佇列變大。這會導致伺服器回應時間增加。因此，使用者將遇到伺服器回應延遲的問題。

若要解決這個問題，請使用＜詳細資訊＞一節中所提到的資源，識別 Inetinfo.exe 處理程序或相關資源的效能瓶頸。這個瓶頸可能與不良的磁碟效能或高 CPU 使用率相關。

詳細資訊

  • 若需識別 Epoxy 中不斷增大之佇列的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》中的＜識別 Epoxy 中不斷增大的佇列＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 若需處理器瓶頸的詳細資訊，請參閱＜處理器瓶頸＞。

  • 若需磁碟瓶頸的詳細資訊，請參閱＜偵測到磁碟瓶頸＞。

  • 若需疑難排解儲存區效能的詳細資訊，請參閱微軟知識庫文件 - 257725＜XADM：如何收集診斷資料以進行資訊存放的疑難排解＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。

  • 若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


Epoxy Store Out Queue Length (POP) 超出閾值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-02-13

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Epoxy 效能物件的 Store Out Queue Length (POP) 效能計數器的資料，以分析效能資料。

Store Out Queue Length (POP) 效能計數器指出佇列中有多少郵件包含由 Store.exe 處理程序傳送至 Inetinfo.exe 處理程序的 POP3 郵件。不管在什麼時候，佇列都應在 50 以下。Exchange Server Analyzer 會在 5 分鐘內每隔 5 秒擷取這個計數器的樣本。如果 Exchange Server Analyzer 判定 Store Out Queue Length (POP) 計數器已在取樣時間配量期間超出尖峰值 50，則會顯示錯誤。

Epoxy (ExIPC) 是共用記憶體機制，此機制可讓 Microsoft Internet Information Services (IIS) (Inetinfo.exe) 及 Microsoft Exchange Information Store 服務 (Store.exe) 的處理程序迅速地來回移動資料。這容許在 Inetinfo.exe 處理程序與 Store.exe 處理程序之間進行處理程序間的雙向通訊。

附註：
Inetinfo.exe 接受網際網路通訊協定 (例如 WebDAV、IMAP4、NNTP、POP3 及 SMTP) 所提出的要求。

DSAccess 也會使用這個記憶體，DSAccess 是快取 Active Directory® 資訊的 Exchange 元件。

這個錯誤表示在 Inetinfo.exe 處理程序中，或在 Inetinfo.exe 處理程序所依存的資源中發生效能問題，這些效能問題導致這個佇列變大。這會導致伺服器回應時間增加。因此，使用者將遇到伺服器回應延遲的問題。

若要解決這個問題，請使用＜詳細資訊＞一節中所提到的資源，識別 Inetinfo.exe 處理程序或相關資源的效能瓶頸。這個瓶頸可能與不良的磁碟效能或高 CPU 使用率相關。

詳細資訊

  • 若需識別 Epoxy 中不斷增大之佇列的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》中的＜識別 Epoxy 中不斷增大的佇列＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 若需處理器瓶頸的詳細資訊，請參閱＜處理器瓶頸＞。

  • 若需磁碟瓶頸的詳細資訊，請參閱＜偵測到磁碟瓶頸＞。

  • 若需疑難排解儲存區效能的詳細資訊，請參閱微軟知識庫文件 - 257725＜XADM：如何收集診斷資料以進行資訊存放的疑難排解＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。

  • 若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


存取 Exchange 伺服器時發生錯誤
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具無法存取您的 Exchange 伺服器。這個錯誤表示在 Active Directory® 目錄服務中找不到您指定的 Exchange 伺服器組態資訊。

若要更正此錯誤

  • 確定您輸入的伺服器名稱正確。

  • 只輸入伺服器的主機或 NetBIOS 名稱 (例如 Server1)，而不要輸入完整的網域名稱 (例如 Server1.example.com)。

  • 驗證您具有存取此伺服器之 Active Directory 組態資訊所需的權限。


存取 Exchange 伺服器資訊時發生錯誤
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具在存取 Exchange 伺服器的 Active Directory® 目錄服務組態資訊時發生問題。

若要更正此錯誤：

  • 驗證您目前的登入帳戶具有適當的權限，可在 Active Directory 中讀取 Exchange 伺服器組態資訊。

  • 請確認您有 Active Directory 網域控制站的網路連線。

  • 在 Exchange Server Analyzer 工具中輸入明確的帳戶認證來存取 Active Directory。

  • 在 Exchange Server Analyzer 中指定 Active Directory 網域控制站。

  • 確定您指定的 Exchange 伺服器存在，且您輸入的伺服器名稱正確。


存取郵件追蹤記錄檔時發生錯誤
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-06

Microsoft® Exchange Server Analyzer 工具會查詢 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 類別的每一個執行個體的 MessageID 內容。

如果 Exchange Server Analyzer 未從查詢收到結果，便會顯示錯誤。

此錯誤的最可能原因就是已停用郵件追蹤中心。

郵件追蹤中心啟用時會記錄寄件者、郵件訊息及郵件收件者的相關資訊。更明確地說，您可以檢閱郵件的傳送或接收時間、郵件大小與優先順序，以及郵件收件者清單之類的統計資料。郵件追蹤中心會搜尋系統郵件、公用資料夾郵件，以及電子郵件等各種郵件。

您必須在每個要追蹤郵件的伺服器上啟用郵件追蹤中心。一旦啟用它，透過伺服器路由傳送的所有郵件都會新增至郵件追蹤記錄檔。

必須啟用郵件追蹤，Exchange Server Analyzer 才能開始掃描。

附註：
若要執行這項程序，必須具備下列權限：本機 Administrators 群組的成員，以及已在系統管理群組層級套用了 Exchange 系統管理員角色之群組的成員
啟用伺服器的郵件追蹤中心

  1. 在 [Exchange 系統管理員] 中，展開 [伺服器]、在您要啟用郵件追蹤的伺服器上按一下滑鼠右鍵，然後按一下 [內容]。

  2. 在 [一般] 索引標籤上，選取 [啟用郵件追蹤] 核取方塊。

  3. 若要記錄傳入、傳出或經過該伺服器之任何郵件的主旨，請選取 [啟用並顯示主旨記錄] 核取方塊。

    附註：
    若啟用主旨記錄，可能會使效能稍微降低。

  4. 在 [記錄檔維護] 下方，可以防止記錄檔被移除，或修改保留記錄檔的時間長度。追蹤記錄檔的預設保留期間為 7 天。

    附註：
    在處理大量郵件的伺服器上，追蹤記錄檔會膨脹的非常快。請確定記錄檔以及使用該磁碟的其他服務或應用程式有足夠的磁碟空間可用。

  5. 按一下 [確定] 或 [套用]。您不必重新啟動服務，此變更便會生效。

若需如何使用郵件追蹤中心的詳細資訊，請參閱 Microsoft 知識庫文章 262162＜XADM：使用「郵件追蹤中心」來追蹤訊息＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162)。

若需如何疑難排解 Exchange Server 傳輸問題的詳細資訊，請參閱 Microsoft 知識庫文章 821910＜如何疑難排解 Exchange Server 2003 傳輸問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821910)。


升級 ACL 時發生錯誤
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-02-15

Microsoft Exchange Analyzer 工具會查詢 Win32_NTLogEvent Microsoft Windows Management Instrumentation (WMI) 類別，以判定過去一小時內是否曾記錄 MSExchangeIS 的「事件 9551」錯誤。

如果 Exchange Analyzer 發現過去一小時內曾記錄「事件 9551」錯誤，Exchange Analyzer 就會計算這一小時內所記錄的「事件 9551」錯誤總數。

最後，如果 Exchange Analyzer 發現過去一小時內曾記錄 20 次以上的「事件 9551」錯誤，Exchange Analyzer 就會顯示警告。

此錯誤表示：信箱資源或公用資料夾的存取控制清單 (ACL) 中，可能有使用者帳戶並未與有效的 Active Directory 目錄服務物件相關聯。

執行 Microsoft Exchange Server 2003 或 Exchange 2000 Server 之伺服器上的信箱，在 Active Directory 中必須由有效的 Active Directory 目錄服務使用者帳戶來代表，才能夠加以存取。

如果在 Exchange Server 5.5 型電腦上刪除信箱之後，並未更新 Exchange 2000 Server 或 Exchange Server 2003 信箱資源或公用資料夾，則可能建立在 Active Directory 中不具有效代表的帳戶。

如果信箱資源或公用資料夾的 ACL 中仍然保有已刪除的信箱帳戶，則每次存取信箱資源或公用資料夾而 Exchange 嘗試解析所列出的帳戶時，就無法解析在 Active Directory 中不具有效代表的帳戶。此程序會顯露為一個效能問題。

若要更正此問題：

  • 確認已安裝 Exchange 2000 Server Service Pack 3 (SP3) 或更新版本。若要取得最新的 Exchange 2000 Server Service Pack，請參閱 Microsoft 知識庫文章 301378＜如何取得最新的 Exchange 2000 Server Service Pack＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378)。

  • 使用 Exchange 系統管理員從 ACL 中手動移除無效的信箱帳戶。

  • 如果 Exchange 環境為 Exchange 混合模式，請針對資訊儲存庫執行 DS/IS 一致性檢查程式。

  • 如果 Exchange 環境為 Exchange 原生模式，請遵循 Microsoft 知識庫文章 324323＜XADM：在存取控制清單轉換期間，略過 Active Directory 中沒有代表的使用者帳戶＞(機器翻譯) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324323) 中的指導。

使用 Exchange 系統管理員從 ACL 中手動移除無效帳戶

  1. 啟動 Exchange 系統管理員，並找到 9551 錯誤所識別的資料夾。

  2. 在資料夾上按一下滑鼠右鍵，然後選取 [內容]。

  3. 選取 [權限] 索引標籤，然後按一下 [用戶端權限]。

  4. 在 [名稱] 窗格中，選取 9551 錯誤所識別的使用者帳戶，然後按一下 [移除] 按鈕，從 ACL 中移除該帳戶。
在 Exchange 混合模式下對資訊儲存庫執行 DS/IS 一致性檢查程式

  1. 在 Exchange Server 5.5 系統管理員程式中，按一下包含該資訊儲存庫的 Exchange 5.5 Server 電腦。

  2. 按一下 [檔案] 功能表上的 [內容]，然後按一下 [進階] 索引標籤。

  3. 按一下 [一致性調整]。

  4. 按一下以便勾選 [從公用資料夾權限移除未知的使用者帳戶] 和 [從信箱權限移除未知的使用者帳戶] 核取方塊，然後按一下 [所有不一致]。

  5. 按一下以清除其他所有核取方塊，然後按一下 [確定]。

詳細資訊

如需此問題的相關資訊，請參閱下列 Microsoft 知識庫文章和 Exchange Server 資源：

  • 事件和錯誤訊息中心：事件詳細資料：MSExchangeIS 信箱儲存區事件 9551 詳細資料 (英文) (http://go.microsoft.com/fwlink/?LinkId=83189)。

  • Microsoft 知識庫文章 301378＜如何取得最新的 Exchange 2000 Server Service Pack＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378)。

  • Microsoft 知識庫文章 324323＜XADM：在存取控制清單轉換期間，略過 Active Directory 中沒有代表的使用者帳戶＞(機器翻譯) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324323) 中的指導。


ESE.DLL 檔案遺失
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-04-21

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔是否存在：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要解決此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱＜Exchange Server 2000 下載＞(英文) (http://go.microsoft.com/fwlink/?linkid=33457)。


遺失 ESEUTIL.EXE 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔是否存在：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要解決此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 Microsoft Exchange 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange 2000 Server Service Pack、更新彙總套件及增益集的的詳細資訊，請參閱「Exchange 2000 Server 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


EXCDO.DLL 檔案遺失
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔是否存在：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要解決此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


遺失 EXCHMEM.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要修正此錯誤，請安裝您的 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 Microsoft Exchange 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


EXMIME.DLL 檔案遺失
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要解決此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange Server 2000 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange 2000 Server Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange 2000 Server 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


EXOLEDB.DLL 檔案遺失
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔是否存在：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要解決此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


遺失 EXPOP3.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要解決此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange Server 2000 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 Microsoft Exchange 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


EXPROX.DLL 檔案遺失
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要修正此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或彙總更新套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


遺失 EXRES.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔是否存在：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要修正此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或彙總更新套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 Microsoft Exchange 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


EXSMTP.DLL 檔案遺失
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔是否存在：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要解決此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


EXSMTP.DLL 檔案版本已過時
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

錯誤訊息

簡介

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 EXSMTP.DLL 的 Version 機碼值。如果 Exchange Server Analyzer 判定 EXSMTP.DLL 的 Version 機碼不等於 6556.0，便會顯示一則警告。

這個警告表示這部 Exchange Server 電腦上的 EXSMTP.DLL 版本是來自 2004 年 5 月第 1 版的 Exchange 2000 Server Post-Service Pack 3 更新彙總套件。有較新的更新彙總套件可供下載。

若要更正此警告

  1. 從「Exchange 2000 Server 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)，下載最新更新項目 (2004 年 8 月)。

  2. 請閱讀微軟知識庫文件 - 870540＜2004 年 8 月 Exchange 2000 Server Post-Service Pack 3 更新彙總套件的可用性＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540)，以取得最新更新的相關資訊。

  3. 製作 Exchange Server 電腦的完整備份。

  4. 套用 2004 年 8 月更新項目。

若需有關安裝這個更新及其他 Exchange Server 更新的詳細資訊，請參閱微軟知識庫文件 - 328839＜如何套用 Exchange Service Pack 及 Hotfix＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)。


目前已啟用 Exchange ActiveSync 追蹤
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來判定 Exchange ActiveSync® 是否已啟用追蹤：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Tracing\Microsoft Server ActiveSync\MasSync\Enabled

如果 Exchange Server Analyzer 發現 Enabled 的值存在且設定的值大於 0，則會顯示警告。

Exchange ActiveSync 是以 Internet Information Services (IIS) 中網際網路伺服器應用程式發展介面 (ISAPI) 延伸模組的形式來實作。IIS、Exchange ActiveSync 及許多使用 Exchange ActiveSync 的用戶端裝置皆包含原生追蹤功能，因此不需要使用 Microsoft Windows Server™ 2003 的原生追蹤功能。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\Software\Microsoft\Windows NT\CurrentVersion\Tracing\Microsoft Server ActiveSync\MasSync

  3. 刪除 Enabled 值。

  4. 關閉登錄編輯程式，然後重新啟動 Exchange Server 電腦，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Exchange ActiveSync 及 Exchange ActiveSync 用戶端追蹤及記錄的詳細資訊，請參閱下列知識庫文件：

  • 330463＜XCCC:如何疑難排解伺服器 ActiveSync HTTP 錯誤碼＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=330463)

  • 330461＜HOW TO: 疑難排解伺服器 ActiveSync＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=330461)

  • 822176＜疑難排解 Exchange 2003 保持最新通知＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822176)


Exchange 二進位檔案版本比已安裝的 Exchange 版本還新
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現有任何檔案的 Version 值大於 Exchange Server 的 Version 值，就會顯示一則警告。較高的版本號碼表示檔案比預期來得新。如果已安裝 Hotfix，就會發生這種情況。

若要解決此警告

  1. 這裡並不需要採取任何動作。此警告只表示發現較新的檔案，而這可能是安裝 Hotfix 或其他更新的結果。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


此 Exchange 叢集節點也是網域控制站
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Microsoft Windows® Management Instrumentation (WMI) 物件 (Win32_ComputerSystem 類別)，以判定伺服器的 DomainRole 值。DomainRole 值代表網域中的電腦角色。下表列出 DomainRole 的有效值。

值 | 意義
0 | 獨立工作站
1 | 成員工作站
2 | 獨立伺服器
3 | 成員伺服器
4 | 備份網域控制站
5 | 網域主控制站

此外，Exchange Server Analyzer 還會查詢 ClusSvc WMI 物件 (Windows 叢集服務物件，Win32_Service 類別)，以判定它的 Started 值。值為 True 表示已啟動叢集服務，值為 False 則表示未啟動叢集服務。

如果 Exchange Server Analyzer 判定啟動叢集服務的 Exchange Server 電腦上的 DomainRole 值大於 3，就會顯示一則錯誤。此錯誤表示 Exchange 伺服器已在其節點為網域控制站的 Windows 伺服器叢集中執行。

將 Exchange Server 叢集節點當成網域控制站來執行，是不受支援的組態。

若要更正此錯誤

  1. 選擇非叢集伺服器來擔任網域控制站，並執行 Active Directory 安裝精靈 (dcpromo) 來將該伺服器升階。

  2. 在新的網域控制站上設定 Active Directory® 目錄服務之後，請等待現有的 Active Directory 內容複寫到新的伺服器。

    此作業可能需要數個小時才能完成，視 Active Directory 的大小而定。

  3. 在叢集伺服器上執行 Active Directory 安裝精靈 (dcpromo)，將伺服器降階並移除 Active Directory。

若需有關升階及降階網域控制站的詳細資訊，請參閱微軟知識庫文件 - 238369＜HOW TO：升級和降級 Windows 2000 中的網域控制站＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=238369)。


已停用 Exchange 錯誤報告
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-04-21

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來判定是否已啟用 Exchange 錯誤報告：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\DisableErrorReporting

如果 Exchange Server Analyzer 發現 DisableErrorReporting 的值是 1，將會顯示警告。值為 1 表示「Exchange 錯誤報告」已停用。

「Microsoft 錯誤報告」的支援 (也稱為「Windows 錯誤報告」、「Microsoft 事件報告」及「自動錯誤報告」)，最初是在 Exchange 2000 Server Service Pack 2 中加入。Exchange Server 2003 提供加強版的「Microsoft 錯誤報告」(稱為「Exchange 錯誤報告」)，可以更有效率向系統管理員提供錯誤報告、與「企業錯誤回報工具」整合，以及為 Exchange Server 2003 收件者更新服務提供加強的報告。

「Exchange 錯誤報告」讓 Exchange Server 系統管理員可以在網際網路上透過 HTTPS，將當機及其他嚴重錯誤傳輸到 Microsoft 錯誤報告伺服器。建議您將錯誤傳送到「Microsoft 線上當機分析 (Online Crash Analysis)」。收集來自 Exchange 伺服器的嚴重錯誤資料，有助於 Exchange 產品團隊發現並修正您使用軟體時所發生的錯誤。

在使用 [Exchange 系統管理員] 時，或在已安裝 [Exchange 系統管理員] 的電腦上使用 [Active Directory 使用者及電腦] 來執行 Exchange 相關工作時，如果發生嚴重錯誤，「Exchange 錯誤報告」會向系統管理員通知錯誤，並提示是否要向 Microsoft 報告錯誤。此外，「Exchange 錯誤報告」也會設陷和報告 Microsoft Exchange System Attendant、Microsoft Exchange Information Store 及其他 Exchange 服務發現的錯誤。此外，因為「收件者更新服務」發現的錯誤會讓「系統服務員」元件處於不正常狀態，所以「Exchange 錯誤報告」也會報告存取違規及「收件者更新服務」中發生的其他內部錯誤。

您可以在 [Exchange 系統管理員] 的伺服器內容頁上選取方塊，設定每一個 Exchange 伺服器來傳送嚴重錯誤資訊。

若要設定 Exchange 2000 Server 或 Exchange Server 2003 將嚴重的伺服器錯誤資料傳送給 Microsoft

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [系統管理群組]、展開您的系統管理群組、展開 [伺服器]、在伺服器上按一下滑鼠右鍵，然後按一下 [內容]。如果 [Exchange 系統管理員] 中未顯示 [系統管理群組] 節點，請展開 [伺服器] 並在伺服器上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 在 [<伺服器名稱> 內容] 頁的 [一般] 索引標籤上，選取 [自動將嚴重服務錯誤資訊傳送至 Microsoft] 方塊，然後按一下 [套用]。

  4. 按一下 [是] 來確認您要啟用「Exchange 錯誤報告」。

  5. 按一下 [確定]。

遇到嚴重錯誤時，會建立一個壓縮的錯誤報告檔 (通常是 10-50 KB)。特別的是這個報告包含一個傾印檔案。傾印檔案包含發生錯誤的處理程序的相關資訊。雖然錯誤可能發生在各種不同的程式設計層級上 (例如，執行緒層級、介面層級和方法或函數層級)，但全部都是在單一處理程序的內容裡發生。傾印檔案通常包含錯誤處理程序的相關資訊，例如每一個執行緒的動作詳細資料、處理程序正在使用的不同記憶體區域、系統資訊及其他相關的偵錯資訊。若有 Exchange Server，錯誤報告也會包含 Exchange Server 的狀態資訊、作業系統版本資訊、電腦硬體的詳細資料、電腦的 IP 位址，以及用來識別產品授權的數位產品識別碼。

雖然 Microsoft 不會刻意收集個人資訊，但我們確認部份收集的資訊將包含可用來獨特辨識您系統的資訊。然而，Microsoft 並不將收集的資料用在這項用途上，只是用於當機報告及錯誤修正。若需詳細資訊，請參閱錯誤報告原則＜資料收集原則＞(英文) (http://go.microsoft.com/fwlink/?LinkId=33818)。


此 Exchange 前端伺服器的 Boot.ini 檔案中有 /3GB 啟動參數
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定在 Exchange Server 電腦上配置給使用者模式處理程序的虛擬位址空間量 (MaxProcessMemorySize)。Exchange Server Analyzer 也會檢查 root\MicrosoftExchangeV2 命名空間內的 Exchange_Server WMI 類別，以判斷 IsFrontEndServer 機碼的值。值 False 表示 Exchange Server 電腦不是前端伺服器。值 True 表示 Exchange Server 電腦是前端伺服器。

如果 Exchange Server Analyzer 判定 MaxProcessMemorySize 機碼的值不等於 2097024，且 IsFrontEndServer 機碼是設定成 True，就會顯示一則警告。

此警告表示，因為在 Boot.ini 檔案中有設定 /3GB 啟動參數，所以未正確設定 Exchange Server 電腦的最佳記憶體使用量。此參數只能用在具有 1 GB 或更多記憶體，且執行下列任一作業系統的 Exchange Server：

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

重要事項：
在 Windows 2000 Server 上不可以使用 /3GB 參數，因為該參數未受支援，並且會導致應用程式或作業系統當機。此外，只有在上述作業系統安裝了 1 GB 或更多實體記憶體時，才支援 /3GB 參數。

在執行 Microsoft Windows 2000 Server 或 Windows Server 2003 的伺服器上，若其 Boot.ini 檔案中有包括 /3GB 參數， Windows 會在最多 4 GB 的虛擬位址空間裡，分配 3 GB 給使用者處理程序，以及分配 1 GB 給核心程式。通常 (沒有使用 /3GB 參數時)， Windows 會配置 2 GB 給使用者處理程序，以及 2 GB 給核心程式。因此，有使用 /3GB 參數時，使用較多記憶體的應用程式，可以分配到較大的虛擬記憶體位址空間進行運作，因而可以改善效能。

使用 /3GB 參數最主要可以協助使用較多記憶體的應用程式，例如主控使用者信箱的 Exchange 伺服器上之 Store.exe 處理程序。前端伺服器並不主控使用者信箱，因此，在前端伺服器上使用 /3GB 參數，並不會有任何好處。

若要更正此警告

  1. 在 [Windows 檔案總管] 中，瀏覽至系統磁碟分割區。

  2. 如果您看不到 Boot.ini 檔案，則可能是因為 [資料夾選項] 設定為 [隱藏保護的作業系統檔案]。若是這樣，請在 [Windows 檔案總管] 視窗中，依序按一下 [工具]、[資料夾選項] 及 [檢視] 索引標籤。清除 [隱藏保護的作業系統檔案 (建議使用)] 核取方塊。出現警告方塊提示時，按一下 [是]。

  3. 如果在 [檔案總管] 中看見 Boot.ini 檔，請在該檔案上按一下滑鼠右鍵、按一下 [開啟檔案]，然後選擇 [記事本] 來開啟檔案。

  4. 在 [Operating Systems] 區段中，從所有啟動行中刪除下列參數：/3GB

  5. 儲存變更並結束 [記事本]。

  6. 重新啟動電腦，以使變更生效。

若需使用 /3GB 啟動參數的進一步詳細資料，請參閱下列微軟知識庫文件：

  • 297812＜如何使用 4GT RAM 調整功能＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901＜4GT 調整對系統分頁表項目的效果＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 31679＜如何在 Boot.ini 檔中使用 /USERVA 參數調整 /3GB 組態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044＜HOW TO: 疑難排解 Exchange 2003 及 Exchange 2000 的虛擬記憶體分散＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Exchange IFS 磁碟機尚未從 Windows 備份明確排除
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定已經使用 [備份] 從備份中排除的檔案及資料夾：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

Exchange Server Analyzer 會特別尋找名為 Exchange IFS 的字串值。

Exchange Server Analyzer 也會讀取下列登錄項目，來取得代表「Exchange 可安裝的檔案系統 (IFS)」磁碟機的磁碟機代號：

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

在 Exchange 2000 Server 中，預設磁碟機代號是 M。在 Exchange Server 2003 中，IFS 磁碟機預設會關閉。

如果 Exchange Server Analyzer 發現 FilesNotToBackup 機碼沒有包含名為 Exchange IFS 的字串值，或它包含 Exchange IFS，但 Exchange IFS 的值資料不等於 M:\* /s (其中 M 是代表 IFS 的磁碟機代號)，就會顯示一則警告。

在預設的情況下，當啟用 IFS 磁碟機代號對應時，Exchange IFS 會加入 FilesNotToBackup 登錄機碼中。M:\ 磁碟機是 Exchange 儲存區的邏輯檢視，不是真的磁碟機，因此備份該磁碟機會發生嚴重問題，如失去附件。此外，備份軟體可能會因未適當截斷記錄檔，而導致伺服器磁碟空間不足的意外狀況。

如果不是正在使用 [備份]，就不必理會此警告。如果您正在使用 [備份]，建議您從所有備份工作中排除 IFS 磁碟機。如果使用 [備份] 或其他備份程式來備份 IFS 磁碟機，資訊儲存庫資料庫可能會損毀、失去資料，而且無法從 IFS 磁碟機的備份還原資料。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

  3. 在 FilesNotToBackup 上按一下滑鼠右鍵，然後按一下 [新增 | 多字串值]。鍵入 Exchange IFS 作為名稱並按下 Enter 鍵。

  4. 在右窗格中，連按兩下 Exchange IFS，然後在 [數值資料] 中輸入 M:\* /s。您一定要使用正確的磁碟機代號，以防系統不是使用預設磁碟機代號 M。

  5. 關閉登錄編輯程式。

若需有關 Microsoft Windows® 登錄的詳細資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)。

若需有關備份及還原 Exchange 的詳細資訊，請參閱《Exchange Server 2003 嚴重損壞修復操作手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47570)。若需其他資訊，請參閱下列知識庫文件：

  • 258243＜如何使用 Windows 備份程式備份及還原 Exchange 電腦＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=258243)

  • 233427＜在 Windows Server 2003、Windows XP 及 Windows 2000 中使用 Ntbackup.exe 工具時未備份的檔案及資料夾＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=233427)

若需有關使用防毒軟體掃描 IFS 磁碟機時可能發生之問題的詳細資訊，請參閱下列知識庫文件：

  • 298924＜XADM：請勿備份或掃描 Exchange 2000 M 磁碟機＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608＜XADM：裝載資料庫時顯示的 C1041737 錯誤訊息＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046＜XADM：行事曆項目從使用者資料夾消失＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


此 Exchange 信箱伺服器具有 1 GB 或以上的記憶體，但 Boot.ini 檔案中未設定 /3GB
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢兩個 Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Exchange 伺服器上的實體記憶體量，以及配置給使用者模式處理程序的虛擬位址空間量。下表說明 Exchange Server Analyzer 會評估的類別與機碼。

查詢的類別 | 查詢的機碼 | 描述
Win32_OperatingSystem | MaxProcessMemorySize | 可以配置給處理程序的記憶體 KB 數上限。
Win32_OperatingSystem | OSProductSuite | 在作業系統上已安裝及授權的系統產品。
Win32_ComputerSystem | TotalPhysicalMemory | 電腦上已安裝的隨機存取記憶體 (RAM) 位元組數。

如果 Exchange Server Analyzer 判定 Exchange Server 電腦不是在執行 Windows 2000 Server，並已安裝 1 GB 或更多的實體記憶體，且 MaxProcessMemorySize 的值大於 2097024 但小於 3104640，就會顯示警告。

此警告表示 Exchange 伺服器不符合下列微軟知識庫文件中所提出的需求：266096＜Exchange 2000 必須具有 1 GB 以上的實體 RAM，才能使用 /3GB 參數＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096)。這不是建議的正式作業組態。

Microsoft Windows Server™ 2003 支援兩個啟動參數 (/3GB 及 /USERVA)，可讓您調整記憶體及記憶體位址空間的使用量配置。無論系統中的實體記憶體量為何，Windows 都會使用虛擬位址空間 4 GB，其中 2 GB 是配置給使用者模式處理程序 (例如，應用程式)，而另外 2 GB 是配置給核心模式處理程序 (例如，作業系統及核心模式驅動程式)。在具有 1 GB 或以上實體記憶體的系統上，可以使用這兩個啟動參數將較多的記憶體配置給應用程式 (3 GB)，而少配置一些記憶體給作業系統 (1 GB)。此額外的虛擬位址空間可協助減少 Exchange 資訊儲存庫處理程序之虛擬位址空間中的記憶體分散量。

/3GB 參數是用來達成此配置變更。此參數是在系統的 Boot.ini 檔案中輸入，重新啟動後就會生效。此參數只能用在具有 1 GB 或更多記憶體，且執行下列任一作業系統的 Exchange 伺服器：

  • Microsoft Windows Server 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

重要事項：
在 Windows 2000 Server 上不可以使用 /3GB 參數，因為該參數未受支援，並且會導致應用程式或作業系統當機。此外，只有在上述作業系統安裝了 1 GB 或更多實體記憶體時，才支援 /3GB 參數。

/USERVA 參數是 Windows Server 2003 的新參數。它的目的是要更完善地控制使用者模式處理程序與核心模式處理程序之間的虛擬位址空間分割。此參數應只用於支援它的應用程式 (如 Exchange 2000 Server 及 Exchange Server 2003)，且搭配那些應用程式所支援的特定值來使用。

附註：
Microsoft 產品支援服務不支援任意 /USERVA 設定。客戶只有在製造商的建議下，才應將此設定新增到 Boot.ini 檔案中。

用於 Exchange Server 2003 系統時，唯一支援的 /USERVA 值是 3030 (例如，/USERVA=3030)。此值會額外配置 40 MB 給作業系統，因此可讓您新增更多使用者而不會耗盡所有可用的系統資源。

若要更正此警告

  1. 在 [我的電腦] 上按一下滑鼠右鍵，然後選取 [內容]。即會出現 [系統內容] 對話方塊。

  2. 按一下 [進階] 標籤。

  3. 在 [啟動及修復] 區域中，按一下 [設定]。即會出現 [啟動及修復] 對話方塊。

  4. 在 [系統啟動] 區域中，按一下 [編輯]。這樣會用 [記事本] 開啟 Windows Boot.ini 檔。

  5. 在 [Operating Systems] 區段中，將下列參數新增到啟動行 (內含 /fastdetect 參數) 的結尾：/3GB /USERVA=3030

  6. 儲存變更並結束 [記事本]。

  7. 按兩次 [確定] 關閉開啟的對話方塊，然後重新啟動 Exchange Server 電腦，以讓變更生效。

若需最佳化 Exchange Server 記憶體使用量及效能的相關資訊，請參閱下列微軟知識庫文件：

  • 266096＜Exchange 2000 必須具有 1 GB 以上的實體 RAM，才能使用 /3GB 參數＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096)

  • 325044＜HOW TO: 疑難排解 Exchange 2003 及 Exchange 2000 的虛擬記憶體分散＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 810371＜XADM：在 Windows Server 2003 型的 Exchange Server 上使用 /Userva 參數＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371)

  • 823440＜在 Windows Server 2003 型的系統上安裝 Exchange Server 2003 時，必須使用 /3GB 參數＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440)

  • 822178＜Exchange Server 2003 功能的依存性及需求概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822178)


已啟用 Exchange Provider Tracing
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-06-20

Microsoft Exchange Server Analyzer 工具會查詢 Active Directory 目錄服務，以判定物件類別為 msExchExchangeServer 之所有物件的 serialNumber 屬性值。若字串值包含 Version 5.5，表示電腦執行的是 Microsoft Exchange Server 5.5。若字串值包含 Version 6.0，表示電腦執行的是 Microsoft Exchange 2000 Server。如果字串值包含 "Version 6.5"，表示電腦執行的是 Microsoft Exchange Server 2003。如果字串值包含 "Version 8.0"，則表示電腦執行的是 Microsoft Exchange Server 2007。

Exchange Analyzer 也會查詢 CIM_Datafile Microsoft® Windows® Management Instrumentation (WMI) 類別，以判定 Emsmdb32.dll (Exchange 傳輸層提供者) 的 Version 機碼值。Version WMI 機碼表示此檔案的組建編號。

最後，Exchange Analyzer 會查詢下列登錄項目，來判定是否已設定並啟用 Exchange 提供者追蹤。

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Enable Tracing

若下列條件為真，Exchange Analyzer 就會顯示錯誤訊息：

  • 伺服器未執行 Exchange Server 2007

  • Emsmdb32.dll 的 Version 機碼是 6.5.7233.47 或更新版本

  • HKML\Software\Microsoft\Exchange\Exchange Provider\Enable Tracing 項目存在，但設定的值不是 0

這個錯誤表示電腦已啟用 Exchange 傳輸層提供者追蹤。

Exchange 傳輸層提供者追蹤版本 6.5.7233.47 及更新版本都具有內建追蹤功能。.ttd 檔會啟用追蹤下列程式：

  • 在執行 Exchange Server 2003 的伺服器上使用 MAPI 的任何程式

  • 使用 Microsoft Exchange 系統管理工具所安裝的任何程式。

建議只有主動疑難排解時，才啟用 Exchange 傳輸層提供者追蹤，否則可能會對一般伺服器效能造成不良影響。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
停用 Exchange Server 2003 的 Exchange 提供者追蹤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKML\Software\Microsoft\Exchange\Exchange Provider\

  3. 在右瀏覽窗格中：

    1. 按一下滑鼠右鍵並刪除 Enable Tracing 子機碼，或是

    2. 連按兩下 Enable Tracing。

  4. 將 Enable Tracing 子機碼設定為 0 值。

  5. 關閉登錄編輯程式。

  6. 重新啟動 Exchange Information Store 服務，使這些變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱 Microsoft 知識庫文章 256986＜Microsoft Windows 登錄說明＞。


Exchange Management 服務未以 LocalSystem 身分執行
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Microsoft Exchange Management (MSExchangeMGMT) 服務的 StartName 屬性值。如果 Exchange Server Analyzer 發現 Exchange Management 服務在 LocalSystem (SYSTEM) 帳戶之外的任一帳戶下執行，則會顯示錯誤。

此錯誤指示 Exchange Management 服務未以受支援的組態執行。如果在任何其他帳戶下執行 Exchange Management 服務，會導致權限與存取錯誤。

若要解決此錯誤，您必須將 Exchange Management 服務設成以 LocalSystem (SYSTEM) 帳戶啟動。

設定 Exchange Management 服務帳戶

  1. 開啟 [服務] Microsoft Management Console (MMC) 嵌入式管理單元。

  2. 尋找並停止 [Microsoft Exchange Management] 服務。

  3. 連按兩下 [Microsoft Exchange Management] 服務。

  4. 在 [Microsoft Exchange Management 內容] 頁面的 [登入] 索引標籤上，在 [登入身分] 之下選取 [LocalSytem 帳戶]，然後按一下 [套用]。

  5. 在 [服務狀態] 下，按一下 [啟動]，再按一下 [確定]。

  6. 關閉 [服務] 嵌入式管理單元。

若需在 LocalSystem 帳戶之下執行 Exchange 服務的詳細資訊，請參閱微軟知識庫文件 - 239762＜Exchange Services Run Under LocalSystem＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)。


已停止 Exchange Management 服務
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Process Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 MSExchangeMGMT 執行個體 (代表 Microsoft Exchange Management 服務) 的 Started 機碼值。如果 Exchange Server Analyzer 發現 MSExchangeMGMT 執行個體的 Started 機碼值不等於 True，則會顯示一則警告。

Exchange Management 服務是在 Exchange 2000 Server Service Pack 2 時引進的。在眾多功能之中，Exchange Server 郵件追蹤中心功能及特定 [Exchange 系統管理員] 功能的運作必須依賴此服務。

Exchange Management 服務可讓您透過使用者介面來指定 Exchange Server 2003 或 Exchange 2000 Server 用來存取 Active Directory® 目錄服務的網域控制站或通用類別目錄伺服器。郵件追蹤時也需要此服務。您可以停用此服務，而不會影響 Exchange 的核心功能。然而，稽核 Exchange Server 功能時，在用來路由傳送郵件的所有 Exchange Server 電腦上可能需要郵件追蹤功能。

附註：
因為前端伺服器是最常用來存取郵件，而非路由傳送郵件，所以您可能會發現不需要在前端伺服器上執行 Exchange Management 服務。

若要將 Exchange Management 服務設定為自動啟動

  1. 開啟 [服務] Microsoft Management Console (MMC) 嵌入式管理單元。

  2. 連按兩下 Microsoft Exchange Management 服務。

  3. 在 [Microsoft Exchange Management 內容] 頁面的 [一般] 索引標籤上，從 [啟動類型] 對話方塊中選取 [自動]，然後按一下 [套用]。

  4. 在 [伺服器狀態] 下，按一下 [啟動]，再按一下 [確定]。

若需有關 Exchange Management 服務的詳細資訊，請參閱微軟知識庫文件 - 307413＜XGEN：Exchange Management 服務的一般資訊＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307413)。

若需有關管理 Exchange 的其他一般資訊，請參閱《Exchange Server 2003 系統管理手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47617)。


Exchange 2000 Server 未執行最新的 Service Pack
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每一個 Exchange Server 物件的 versionNumber 屬性值。versionNumber 屬性代表電腦中執行的 Exchange Server 版本。

Exchange Server Analyzer 也會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 STORE.EXE 處理程序的 Version 機碼值。如果 Exchange Server Analyzer 判定 STORE.EXE 的 Version 機碼值大於 4416，且小於或等於 6249，則會顯示警告。

這個警告指出 Exchange Server 電腦執行的程式碼，不是電腦中執行的 Exchange 版本可用的最新程式碼。

若要更正此警告

  1. 下載 Exchange 2000 Server Service Pack 3 (http://go.microsoft.com/fwlink/?LinkId=17058)。

  2. 檢閱《Exchange 2000 Server Service Pack 3 部署手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=12337)。

  3. 下載最新更新 (2004 年 8 月) (http://go.microsoft.com/fwlink/?LinkId=33457)。

  4. 檢閱微軟知識庫文件 - 870540＜2004 年 8 月 Exchange 2000 Server Post-Service Pack 3 更新彙總套件的可用性＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540)，以檢閱最新更新的相關資訊。

  5. 製作 Exchange Server 電腦的完整備份。

  6. 套用 Exchange 2000 Server Service Pack 3。

  7. 套用 2004 年 8 月更新項目。

若需有關取得 Exchange 2000 Server 最新 Service Pack 的詳細資訊，請參閱微軟知識庫文件 - 301378＜如何取得最新的 Exchange 2000 Server Service Pack＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378)。

若需有關安裝這個及其他 Exchange Server 更新的詳細資訊，請參閱知識庫文件 - 328839＜如何套用 Exchange Service Pack 及 Hotfix＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)。


Windows Server 2003 不支援 Exchange 2000 Server
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定在 Exchange Server 電腦上執行的 Microsoft Windows® 作業系統版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 值為 4.0 表示電腦正在執行 Microsoft Windows NT® Server 4.0。值 5.0 表示電腦正在執行 Windows 2000 Server，而值 5.2 則表示電腦正在執行 Windows Server™ 2003。

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定物件類別為 msExchExchangeServer 的所有物件之 serialNumber 屬性值。如果字串值包含 Version 5.5，則表示電腦正在執行 Microsoft Exchange Server 5.5 版。如果字串值包含 Version 6.0，則表示電腦正在執行 Exchange 2000 Server。如果字串值包含 Version 6.5，則表示電腦正在執行 Exchange Server 2003。

如果 Exchange Server Analyzer 發現 CurrentVersion 值等於 5.2，且 serialNumber 值包含 Version 6.0，就會顯示錯誤。這種組態並不受支援，並且您應該立即更正此錯誤。

若要更正此錯誤

  1. 執行下列其中一個動作：

    • 在執行受支援作業系統的伺服器上安裝 Exchange 2000 Server，並將信箱移到該伺服器。

    • 將 Exchange 2000 Server 升級到 Exchange Server 2003。

若需有關支援組態的詳細資訊，請參閱《Exchange Server 2003 部署手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47569)。

若需有關 Exchange Server 及 Windows Server 2003 的詳細資訊，請參閱微軟知識庫文件 - 810591＜Exchange Server 與 Windows Server 2003 的相容性＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810591)。


已安裝 Exchange 2007 發行前版本
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-02-20

Microsoft Exchange Server Analyzer 工具會查詢 Active Directory 目錄服務來判定目錄中所有 Exchange Server 物件的 serialNumber 屬性值。serialNumber 屬性是字串值，其中包含 Exchange Server 的版本及 Service Pack 版本 (如果已安裝)。例如，在未安裝 Service Pack 的 Exchange Server 2007 電腦上，serialNumber 屬性等於 Version 8.0 (Build 0685)。

如果 Exchange Server Analyzer 發現 serialNumber 屬性值的字串中包含 8.0，但該字串中的組建編號卻小於 0685，則會顯示錯誤。

此錯誤表示 Exchange Server 2007 電腦執行的是 Exchange Server 2007 的發行前版本。

生產環境不支援安裝 Exchange Server 2007 的發行前版本。

若要更正這個錯誤，請安裝 Exchange Server 2007 的最終版本。


已將 Exchange 2007 伺服器物件移至不同的系統管理群組
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-08-11

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定目錄中所有 Exchange Server 物件的 serialNumber 屬性值。

Exchange Server Analyzer 也會查詢執行 Exchange Server 之伺服器所屬系統管理群組的 cn 屬性值，以便判定其是否為固定的 Exchange 2007 系統管理群組 ([Exchange 系統管理群組 (FYDIBOHF23SPDLT)])。

如果 Exchange Server Analyzer 判定伺服器正在執行 Microsoft Exchange Server 2007，但該伺服器並非隸屬 [Exchange 系統管理群組 (FYDIBOHF23SPDLT)] 系統管理群組，則 Exchange Server Analyzer 便會顯示錯誤。

此錯誤指出已從固定 Exchange 2007 系統管理群組中手動移動伺服器，且可能造成郵件流程發生問題。

serialNumber 屬性為字串值，其中包括 Exchange Server 版本與 Service Pack 版本 (若已安裝的話)。serialNumber 屬性值等於 Version 8.0 表示伺服器正在執行 Exchange 2007。

Microsoft Exchange Server 2003 與 Microsoft Exchange 2000 Server 使用系統管理群組將 Exchange 物件分組，以達到委派權限來管理這些物件的目的。Exchange 2007 不會使用「系統管理群組」作為邏輯管理單位。為了支援 Exchange Server 2003 或 Exchange 2000 Server 與 Exchange 2007 之間的並存性，會在安裝 Exchange 2007 時，將所有 Exchange 2007 伺服器自動新增至單一系統管理群組。此系統管理群組會在 Exchange Server 2003 的 Exchange 系統管理員中辨識為 [Exchange 系統管理群組] (FYDIBOHF23SPDLT)。

若要解決此問題，請移除並重新安裝伺服器。


Exchange 位於不是通用類別目錄伺服器的網域控制站
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-09

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 DomainRole 機碼值。下表顯示這個機碼的有效值：

值 | 意義
0 | 獨立工作站
1 | 成員工作站
2 | 獨立伺服器
3 | 成員伺服器
4 | 備份網域控制站
5 | 網域主控制站

Exchange Server Analyzer 也會查詢 Win32_Service WMI 類別，以判定叢集服務 ClusSvc 的 Started 機碼值。此外，Exchange Server Analyzer 也會查詢 Win32_OperatingSystem WMI 類別，以判斷 OSProductSuite 機碼值。OSProductSuite 機碼的值表示電腦上執行的 Windows 版本。

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定物件類別為 msExchExchangeServer 之所有目錄物件的 serialNumber 屬性值。serialNumber 的屬性值表示使用的 Exchange Server 版本。

最後，Exchange Server Analyzer 會查詢 Active Directory，以判定此伺服器的 isGlobalCatalogReady 屬性值。此屬性值為 True 表示目錄伺服器也是一台正在運作的通用類別目錄伺服器，值為 False 表示 目錄伺服器不是通用類別目錄伺服器。

如果 Exchange Server Analyzer 判定 Exchange Server 電腦上的 DomainRole 機碼值大於 3，且 Exchange Server 電腦沒有執行 Windows Small Business Server、Exchange Server 版本 5.5 或不是在 Windows 叢集中執行，而且 isGlobalCatalogReady 屬性設為 False，就會顯示一則警告。

此警告表示 Exchange Server 執行所在的目錄伺服器並非運作中的通用類別目錄伺服器。這種組態並不受支援，而且可能會導致 Exchange 服務失敗。

如果您在沒有 Small Business Server 的網域控制站上執行 Exchange Server，請注意下列問題：

  • Exchange Server 和 Active Directory 兩者皆是需要大量資源的應用程式。當兩種應用程式皆於相同電腦上執行時，有效能上的意涵需要考量。

  • 如果 Exchange Server 在網域控制站上執行，您也必須將網域控制站當作通用類別目錄伺服器。

  • 有數個 Exchange Server 目錄元件，例如 Directory Service Access (DSAccess)、Directory Service Proxy (DSProxy) 及 [郵件分類程式]，將不會在容錯移轉到其他任何網域控制站或通用類別伺服器。

  • 請不要在 Windows 中使用 /3GB 啟動參數，因為這將導致 Exchange Server 耗盡全部記憶體，從而減少可供 Active Directory 使用的記憶體。

  • 在伺服器關機或重新啟動之前，如果未停止 Exchange Server 服務，系統關機將需要花費很長時間。

  • 這種組態較不安全，因為 Exchange 系統管理員將會具有 Active Directory 的本機系統管理存取權。造成他們能夠自行提高自己的權限。此外，如果 Exchange Server 或 Active Directory 任一方出現安全性漏洞，另一方也會有危險。

  • 如果您在網域控制站上執行 Exchange Server 2003 或 Exchange Server 2007，則不支援使用網域控制站升級工具 (DCPromo) 來變更電腦角色，且已經知道會中斷元件，例如 Microsoft Outlook® Mobile Access。

  • 不支援在同時也是 Active Directory 網域控制站的叢集節點上執行 Exchange Server 2003 或 Exchange Server 2007，而且應該避免做這樣的處理。也就是說，如果您在同時也是網域控制站的叢集節點上執行 Exchange 2000 Server，必須先將伺服器降階至成員伺服器，再將 Exchange 2000 Server 升級為 Exchange Server 2003。

如果電腦正在執行 Exchange 2000 Server，建議您儘早使用 DCPromo 將伺服器降級為成員伺服器。如果電腦正在執行 Exchange Server 2003 或 Exchange Server 2007，請利用下列其中一個程序來更正此警告。

若要將 Exchange 移動到其他電腦以更正此警告

  1. 將 Exchange Server 安裝在不同的電腦上。

  2. 使用 [Exchange 工作精靈] 的 [移動信箱]，將任何現有的信箱從網域控制站移動到新的 Exchange 伺服器。

  3. 將舊的 Exchange Server 電腦擁有的任何公用資料夾和角色，重新隸屬到新的 Exchange Server 電腦。

  4. 從網域控制站中解除安裝 Exchange Server。
若要將 Exchange 伺服器設為通用類別目錄伺服器以更正此警告

  1. 開啟 [Active Directory 站台及服務]。

  2. 依序展開 [站台]、 站台、[伺服器]。

  3. 選取要指定為通用類別目錄伺服器的網域控制站。

  4. 在右窗格中，在 [NTDS 設定] 上按一下滑鼠右鍵，並選取 [內容]。

  5. 在 [一般] 索引標籤上，選取 [通用類別目錄] 核取方塊。如果目錄伺服器正在執行具有 Service Pack 2 或更早版本的 Windows 2000 Server，則重新啟動伺服器以讓變更生效。如果目錄伺服器正在執行具有 Service Pack 3 或更新版本的 Windows 2000 Server，或者執行 Windows Server™ 2003，則會動態進行變更，而無需重新啟動伺服器。

若需有關在網域控制站上安裝 Exchange Server 的詳細資訊，請參閱微軟知識庫文件 - 250989＜XADM：在一部同樣執行 Exchange Server 的 Windows 2000 網域控制站上安裝 ADC＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250989)。


偵測到 Exchange Server 5.5
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-10-06

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定物件類別為 msExchExchangeServer 之所有物件的 serialNumber 屬性值。如果字串值包含 Version 5.5，則表示電腦正在執行 Microsoft Exchange Server 5.5 版。如果字串值包含 Version 6.0，則表示電腦正在執行 Exchange 2000 Server。如果字串值包含 Version 6.5，則表示電腦正在執行 Exchange Server 2003。

如果 Exchange Server Analyzer 發現 serialNumber 的值包含 Version 5.5，就會顯示一個錯誤。

此錯誤指出此 Exchange Server Analyzer 版本無法進一步分析所偵測到的 Exchange Server 版本。

Exchange Server Analyzer 所仰賴的各種特定程式介面，在偵測到的 Exchange Server 版本中無法使用。

若要更正此錯誤，請指定正在執行 Exchange 2000 或更新版本的 Exchange Server。

如果您認為是因為發生錯誤而觸發此規則，請驗證 Active Directory 中 Exchange Server 物件的 serialNumber 屬性值是否設定正確。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
檢視 serialNumber 屬性值

  1. 啟動 [ADSI 編輯器]。

  2. 連按兩下 [Configuration] 容器，依序展開 [CN=Services]、[CN=Microsoft Exchange] 及 [CN=<ExchangeOrganizationName>]。

  3. 展開 CN=Administrative Groups、展開 CN=<AdministrativeGroupName>，然後展開 CN=Servers。

  4. 在伺服器物件上按一下滑鼠右鍵，然後按一下 [內容]。

  5. 連接兩下 serialNumber 屬性，以顯示其目前值。

若需有關部署 Exchange Server 2003 的詳細資訊，請參閱《Exchange Server 2003 部署手冊》(http://go.microsoft.com/fwlink/?LinkId=47569)。

若需有關從 Exchange Server 5.5 遷移至 Exchange Server 2003 的詳細資訊，請參閱知識庫文章 259912＜將 Exchange Server 5.5 升級至 Exchange 2000 Server 或 Exchange Server 2003 的必要條件＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=259912)。

若需如何遷移及升級至 Exchange Server 2003 的相關資訊，請參閱＜升級至 Exchange Server 2003＞(英文) (http://go.microsoft.com/fwlink/?LinkId=34186)。


Exchange Server 5.5 未執行最新的 Service Pack
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每一個 Exchange Server 物件的 versionNumber 屬性值。versionNumber 屬性代表電腦中執行的 Exchange Server 版本。

Exchange Server Analyzer 也會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 STORE.EXE 處理程序的 Version 機碼值。如果 Exchange Server Analyzer 判定 STORE.EXE 的 Version 機碼值大於 1959，但小於 2653，則會顯示警告。這指出電腦執行的是 Exchange Server 5.5 Service Pack 4 之前的版本。

這個警告指出 Exchange Server 電腦執行的程式碼，不是電腦中執行的 Exchange 版本可用的最新程式碼。

若要更正此警告

  1. 下載 Exchange Server 5.5 Service Pack 4 (英文) (http://go.microsoft.com/fwlink/?LinkId=33456)。

  2. 從 Microsoft 下載中心 (英文) (http://go.microsoft.com/fwlink/?LinkId=33456) 下載 Exchange Server 5.5 的最新更新 (2004 年 5 月)。

  3. 檢閱微軟知識庫文件 - 841765＜2004 年 5 月的 Exchange Server 5.5 更新彙總套件＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=841765)，來檢閱此更新的詳細資訊。

  4. 製作 Exchange Server 電腦的完整備份。

  5. 套用 Exchange Server 5.5 Service Pack 4。

  6. 套用 2004 年 5 月的更新。

若需有關安裝這個更新及其他 Exchange Server 更新的詳細資訊，請參閱微軟知識庫文件 - 328839＜如何套用 Exchange Service Pack 及 Hotfix＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)。


在 Windows 2003 上不支援 Exchange Server 5.5
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定在 Exchange Server 電腦上執行的 Microsoft Windows® 作業系統版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 值為 4.0 表示電腦正在執行 Microsoft Windows NT® Server 4.0。值 5.0 表示電腦正在執行 Windows 2000 Server，而值 5.2 則表示電腦正在執行 Windows Server™ 2003。

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定物件類別為 msExchExchangeServer 的所有物件之 serialNumber 屬性值。如果字串值包含 Version 5.5，則表示電腦正在執行 Microsoft Exchange Server 5.5 版。如果字串值包含 Version 6.0，則表示電腦正在執行 Exchange 2000 Server。如果字串值包含 Version 6.5，則表示電腦正在執行 Exchange Server 2003。

如果 Exchange Server Analyzer 發現 CurrentVersion 值等於 5.2，且 serialNumber 值包含 Version 5.5，就會顯示錯誤。這種組態並不受支援，並且您應該立即更正此錯誤。

若要更正此錯誤

  • 執行下列其中一個動作：

    • 請將 Exchange Server 5.5 安裝在執行支援的作業系統的伺服器上，然後將信箱移至該伺服器。

    • 從 Exchange Server 5.5 遷移至 Exchange Server 2003。

若需有關部署 Exchange Server 2003 的詳細資訊，請參閱《Exchange Server 2003 部署手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47569)。

若需有關 Exchange Server 及 Windows Server 2003 的詳細資訊，請參閱微軟知識庫文件 - 810591＜Exchange Server 與 Windows Server 2003 的相容性＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810591)。

若需有關從 Exchange Server 5.5 遷移至 Exchange Server 2003 的詳細資訊，請參閱知識庫文件 - 259912＜將 Exchange Server 5.5 升級至 Exchange 2000 Server 或 Exchange Server 2003 的必要條件＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=259912)。

若需有關遷移及升級至 Exchange Server 2003 的詳細資訊，請參閱遷移及升級網頁「升級至 Exchange Server 2003」(英文) (http://go.microsoft.com/fwlink/?LinkId=34186)。


Exchange Server 5.0 不是執行最新的 Service Pack 或更新彙總套件
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每一個 Exchange Server 物件的 versionNumber 屬性值。versionNumber 屬性代表電腦中執行的 Exchange Server 版本。

Exchange Server Analyzer 也會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 STORE.EXE 處理程序的 Version 機碼值。如果 Exchange Server Analyzer 判斷 STORE.EXE 的 Version 機碼值大於 1456 且小於 1460，則會顯示一則警告。

這個警告指出 Exchange Server 電腦執行的程式碼，不是電腦中執行的 Exchange 版本可用的最新程式碼。

若要更正此警告

  1. 下載 Exchange Server 5.0 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168858)。

  2. 閱讀 Service Pack 2 README.TXT 檔案 (英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168735)。

  3. 請造訪 Microsoft 下載中心 (英文) (http://go.microsoft.com/fwlink/?LinkId=41361)，下載 Exchange Server 5.0 的最新更新 (2004 年 4 月)。

  4. 請閱讀微軟知識庫文件 - 834130＜Microsoft Exchange Server 5.0 更新彙總套件＞(英文)，來檢閱此更新的詳細資訊 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=841765)。

  5. 製作 Exchange Server 電腦的完整備份。

  6. 套用 Service Pack 2 for Exchange Server 5.0。

  7. 套用 2004 年 4 月更新項目。

若需有關安裝這個更新及其他 Exchange Server 更新的詳細資訊，請參閱微軟知識庫文件 - 328839＜如何套用 Exchange Service Pack 及 Hotfix＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)。


Exchange Server 5.5 位於 Active Directory 網域控制站
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 DomainRole 機碼值。下表顯示這個機碼的有效值：

值 | 意義
0 | 獨立工作站
1 | 成員工作站
2 | 獨立伺服器
3 | 成員伺服器
4 | 備份網域控制站
5 | 網域主控制站

Exchange Server Analyzer 也會查詢 Win32_Service WMI 類別，以判定叢集服務 ClusSvc 的 Started 機碼值。

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定物件類別為 msExchExchangeServer 之所有目錄物件的 serialNumber 屬性值。serialNumber 的屬性值表示使用的 Exchange Server 版本。

如果 Exchange Server Analyzer 判定 Exchange Server 電腦上的 DomainRole 機碼值大於 3，且 Exchange Server 電腦不是在 Windows 叢集中執行，而所執行的 Exchange 版本是 Exchange Server 版本 5.5，就會顯示一則警告。

此警告表示 Exchange Server 5.5 在 Active Directory 伺服器上執行。由於潛在的通訊埠衝突，這種情況可造成 Active Directory 連接器 (ADC) 的問題。如果 ADC 將此伺服器作為目標，您應確定使用正確的 Exchange 輕量型目錄存取通訊協定 (LDAP) 通訊埠編號。在預設的情況下，目錄伺服器會在 TCP 通訊埠 389 接聽 LDAP 要求。除非 Exchange 的通訊埠變更且 ADC 設定為使用 Exchange 通訊埠，否則 ADC 將無法與 Exchange 進行通訊。

Active Directory 使用標準 LDAP 通訊埠 389 來存取 LDAP。不過，使用標準通訊埠編號會覆寫位於相同伺服器上，同時也嘗試接聽 LDAP 通訊埠 389 的 Exchange 伺服器。您必須重新指派 Exchange LDAP 通訊埠，以授與 Exchange 伺服器對其目錄的 LDAP 存取權。

若要更正此警告

  1. 開啟 [Exchange 系統管理員]。

  2. 依序展開站台名稱、[組態]、[通訊協定] 和 [LDAP (目錄) 站台預設值]。

  3. 將通訊埠指派從 389 變更為目前尚未使用的通訊埠。

  4. 按一下 [確定] 儲存變更。

  5. 重新啟動 Microsoft Exchange Directory Service，使變更生效。

  6. 視需要重新設定將此伺服器作為目標的 ADC，以讓其使用新的通訊埠。

若需有關如何變更 Exchange Server 5.5 中 LDAP 通訊埠指派的詳細資訊，請參閱微軟知識庫文件 - 224447＜XADM：如何變更 Exchange Server 中的 LDAP 連接埠設定＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=224447)。


Exchange Server DNS 名稱解析失敗
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會對每個 Exchange Server 電腦所設定的 DNS 伺服器，嘗試進行網域名稱系統 (DNS) 查詢。透過使用自訂物件處理器建立此連線，該處理器執行名稱解析要求並分析結果。如果 Exchange Server Analyzer 未在查詢結果中收到網際網路通訊協定 (IP) 位址，就會顯示錯誤。

此錯誤表示在 DNS 中找不到 Exchange Server 電腦。Exchange Server 與 Active Directory® 目錄服務都需要有設定正確且狀況良好的 DNS，才能正常運作。DNS 註冊及解析問題對於傳送、接收及傳遞郵件的能力有廣泛的影響。

您必須正確設定 DNS 以確保 Active Directory 及 Exchange Server 會正確運作。若需有關為 Active Directory 處理 DNS 組態的深入資訊，請參閱微軟知識庫文件 - 237675＜為 Active Directory 設定網域名稱系統＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=237675)。

若要更正此錯誤

  1. 檢閱下列組態項目，確定 DNS 的狀況良好，而且將會正確地登錄 Exchange Server DNS 項目。

    • DNS IP 設定

    • 動態區域更新

    • DNS 轉寄站

  2. 檢查 [根區域] 項目是否存在。檢視 [DNS 管理] 主控台中的 [正向對應] 區域。此處應有此網域的項目。也可能有其他的區域項目。 此處不應有「點」(".") 的區域。如果「點」(".") 區域存在，請刪除該「點」(".") 區域。「點」(".") 區域會將 DNS 伺服器識別為根伺服器。一般來說，需要外部 (網際網路) 存取的 Active Directory 網域應設定為根 DNS 伺服器。在您刪除「點」(".")之後，請在目錄伺服器上，使用 Ipconfig /registerdns 來手動解除登錄 Exchange Server IP 位址。可能也需要重新啟動 Netlogon 服務。

  3. 在 Exchange Server 電腦上，使用 netdiag /fix 來手動重新填入 Exchange Server DNS 項目。

若需有關搭配使用 DNS 與 Active Directory 的詳細資訊，請參閱微軟知識庫文件 - 323418＜當 Windows Server 2003 中已啟用 Active Directory 時將 DNS 與現有的 DNS 基礎結構整合＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=323418)。

若需有關疑難排解 DNS 及 Active Directory 問題的詳細資訊，請參閱知識庫文件 - 260371＜疑難排解 Windows 2000 中常見的 Active Directory 安裝問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260371)。


Exchange 伺服器已指定為前端伺服器並對主機信箱顯示
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Exchange Server Microsoft Windows® Management Instrumentation (WMI) 物件 (Exchange_Server 類別)，以判定伺服器的 IsFrontEndServer 值。如果值為 True，則表示 Exchange 伺服器是前端伺服器。如果伺服器有信箱儲存區，則 Exchange Server Analyzer 會查詢 Active Directory® 目錄服務，以判定伺服器上有多少個信箱。每個信箱儲存區物件 (msExchPrivateMDB 類別) 都有一個多重值的屬性 homeMDBBL，可列出儲存區中的所有信箱。Exchange Server Analyzer 會計算這些值，以取得伺服器上的信箱總數。

如果 Exchange 伺服器已指定為前端伺服器，而且還已設定超過 20 個信箱，則會顯示一則警告。

Exchange 可能需要將服務信箱置於前端伺服器 (視您的組態而定)。例如，如果前端伺服器接受來自網際網路的簡易郵件傳送通訊協定 (SMTP) 郵件，則 Exchange SMTP 服務需要在伺服器上有專用的信箱。Exchange Server Analyzer 會計算這些服務信箱，如果 Exchange 伺服器已設定超過 20 個信箱，僅會顯示警告訊息。

您不該將使用者信箱置於前端伺服器。不支援此種組態。

如果使用者信箱位於前端伺服器，請使用 Exchange 系統管理員 (僅限 Exchange Server 2003) 或 Active Directory 使用者及電腦，將它們移到適合的後端伺服器。

若要移動信箱 (Exchange 2000 Server 或 Exchange Server 2003)

  1. 在 [Active Directory 使用者及電腦] 中，選取要移動其信箱的使用者。

  2. 在您於上一個步驟中選取的使用者清單上按一下滑鼠右鍵，然後按一下 [Exchange 工作]。

  3. 在 [Exchange 工作精靈] 中，在 [可用的工作] 頁面上，按一下 [移動信箱]，然後按 [下一步]。

  4. 請仔細閱讀並遵循精靈的其餘步驟。

若要移動信箱 (僅限於 Exchange Server 2003)

  1. 在 [Exchange 系統管理員] 中，展開 [伺服器]，展開要從那裡移動信箱的伺服器、展開要從那裡移動信箱的 [儲存群組]、展開含有要移動之信箱的 [信箱儲存區]，然後按一下 [信箱]。

  2. 在詳細資料窗格中，在要移動其信箱的使用者上按一下滑鼠右鍵，然後按一下 [Exchange 工作]。

  3. 在 [Exchange 工作精靈] 中，在 [可用的工作] 頁面上，按一下 [移動信箱]，然後按 [下一步]。

  4. 請仔細閱讀並遵循精靈的其餘步驟。

若需有關 Exchange 前端伺服器之正確組態的詳細資訊，請參閱微軟知識庫文件 - 822443＜Exchange Server 2003 中前端伺服器的注意事項＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822443)。

若需有關部署及設定 Exchange 前端伺服器的一般建議，請參閱《Exchange Server 2003 部署手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47569)。

若需有關在 Exchange 前端伺服器上執行使用者信箱所造成錯誤的詳細資訊，請參閱知識庫文件 - 273296＜XCON：使用者無法在前端伺服器上擷取郵件＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=273296)。

若需有關在 Exchange Server 2003 中移動信箱的詳細資訊，請參閱下列知識庫文件：

  • 821829＜在 Exchange Server 2003 中移動信箱＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)

  • 822892＜Exchange 2003 中移動信箱的改良功能＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)


此 Exchange 伺服器也是網域控制站，這不是建議的組態
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-03-28

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 DomainRole 機碼值。下表顯示這個機碼的有效值。

值 | 意義
0 | 獨立工作站
1 | 成員工作站
2 | 獨立伺服器
3 | 成員伺服器
4 | 備份網域控制站
5 | 網域主控制站

此外，Exchange Server Analyzer 也會查詢 Win32_Service WMI 類別，以判定叢集服務 ClusSvc 的 Started 機碼值。

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定物件類別為 msExchExchangeServer 的所有目錄物件的 serialNumber 屬性值。serialNumber 屬性的值指出正在使用的 Exchange Server 版本。

如果 Exchange Server Analyzer 判定 Exchange Server 電腦上的 DomainRole 機碼值大於 3，且 Exchange Server 電腦不是執行 Exchange Server 版本 5.5 或在 Windows 叢集中執行，就會顯示警告。

如果您要將 Exchange Server 當作 Microsoft Small Business Server 2000 或 Windows Small Business Server 2003 的一部分來執行，您可以在網域控制站上安裝 Exchange Server。然而，如果您不將 Exchange Server 當作 Small Business Server 的一部分來執行，建議您避免在網域控制站上執行 Exchange Server。

如果您在沒有 Small Business Server 的網域控制站上執行 Exchange Server，請注意下列問題：

  • Exchange Server 和 Active Directory 兩者皆是需要大量資源的應用程式。當兩者皆於相同電腦上執行時，有效能上的意涵需要考量。

  • 如果 Exchange Server 在網域控制站上執行，您也必須將網域控制站當作通用類別目錄伺服器。若需建立通用類別目錄伺服器的相關資訊，請參閱 Microsoft 知識庫文章 313994＜如何在 Windows Server 2003、Windows 2000 或 Small Business Server 2000 中建立或移動通用類別目錄＞ (英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid= 313994)。

  • 有數個 Exchange Server 目錄元件，例如 Directory Service Access (DSAccess)、Directory Service Proxy (DSProxy) 及「郵件分類程式」，將不會在錯誤後移轉到其他任何網域控制站或通用類別伺服器。

  • 請不要在 Windows 中使用 /3GB 啟動參數，因為這將導致 Exchange Server 耗盡全部記憶體，從而減少可供 Active Directory 使用的記憶體。

  • 在伺服器關機或重新啟動之前，如果未停止 Exchange Server 服務，系統關機將需要花費很長時間。

  • 這種組態較不安全，因為 Exchange 系統管理員將具有 Active Directory 的本機系統管理存取權，造成他們能夠自行提高自己的權限。此外，在 Exchange Server 或 Active Directory 中發現的任何安全性漏洞也曝露其他缺點。

  • 如果您在網域控制站上執行 Exchange Server 2003 或 Exchange Server 2007，則不支援使用網域控制站升級工具 (DCPromo) 來變更電腦角色，且已經知道會中斷元件，例如 Microsoft Outlook® Mobile Access。

  • 不支援在也是 Active Directory 網域控制站的叢集節點上執行 Exchange Server 2003 或 Exchange Server 2007，而且應該避免做這樣的處理。意即，如果您在也是網域控制站的叢集上執行 Exchange 2000 Server，您必須先將伺服器降級為成員伺服器，再將 Exchange 2000 Server 升級為 Exchange Server 2003。

如果電腦正在執行 Exchange 2000 Server，建議您儘早使用 DCPromo 將伺服器降級為成員伺服器。如果電腦正在執行 Exchange Server 2003，請使用下列程序來更正此警告。

若要更正此警告

  1. 將 Exchange Server 安裝在不同的電腦上。

  2. 使用 [Exchange 工作精靈] 的 [移動信箱]，將任何現有的信箱從網域控制站移動到新的 Exchange 伺服器。

  3. 將舊的 Exchange Server 電腦擁有的任何公用資料夾和角色，重新隸屬到新的 Exchange Server 電腦。

  4. 從網域控制站中解除安裝 Exchange Server。

若需有關在網域控制站上安裝 Exchange Server 的詳細資訊，請參閱 Microsoft 知識庫文章 250989＜XADM：在一部同樣執行 Exchange Server 的 Windows 2000 網域控制站上安裝 ADC＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250989)。


此 Exchange 伺服器已關機或無法與它連線
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-04-20

Microsoft® Exchange Server Analyzer 工具會使用遠端程序呼叫 (RPC)，在 Exchange Server 電腦上讀取下列登錄機碼的 CurrentVersion 字串值：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

若因為某些因素，Exchange Server Analyzer 無法讀取這個登錄值，就會顯示一則錯誤。

若要更正此錯誤

  1. 確定 Exchange Server 電腦已經啟動，並且已連線到網路。

  2. 使用 Ping 命令來檢查是否可以連接 Exchange Server 電腦。

  3. 若有裝置防火牆，檢查 RPC 連接埠是否被封鎖。

  4. 確定 Exchange Server 電腦上已啟動 Remote Registry 服務。

  5. 檢查用來執行 Exchange Server Analyzer 工具的帳戶權限，確定它有足夠的權限可以讀取 Exchange Server 電腦的登錄。

若需有關疑難排解網路連線問題的詳細資訊，請參閱微軟知識庫文件 - 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

若需有關疑難排解 Exchange Server Best Practices Analyzer 工具連線問題的詳細資訊，請參閱＜Microsoft Exchange Server Best Practices Analyzer 工具疑難排解連線問題＞(英文) http://go.microsoft.com/fwlink/?linkid=56285)。


此 Exchange 伺服器在 Windows NT 4.0 上執行 (可用的診斷資訊有限)
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定在 Exchange Server 電腦上執行的 Microsoft Windows® 作業系統版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 值為 4.0 表示電腦正在執行 Microsoft Windows NT® Server 4.0。值 5.0 表示電腦正在執行 Windows 2000 Server，而值 5.2 則表示電腦正在執行 Windows Server™ 2003。

如果 Exchange Server Analyzer 發現 CurrentVersion 的值等於 4.0，則會顯示一則警告。

此警告表示此 Exchange Server 電腦正在執行 Windows NT Server 4.0。Windows NT Server 4.0 提供的診斷資訊不像較新版的 Windows Server 那麼多。因此，Exchange Server Analyzer 只能夠蒐集及分析數量有限的資訊。

若要更正此警告

  1. 不需立即採取任何動作。此警告僅供參考。

  2. 因為 Windows NT Server 4.0 與 Exchange Server 版本 5.5 已接近其產品生命週期的尾聲，您應該考慮升級至 Windows Server 2003 與 Exchange Server 2003。

若需有關 Windows NT Server 4.0 及 Exchange Server 5.5 產品生命週期的詳細資訊，請參閱「Microsoft 產品技術支援週期」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=21759)。

若需有關 Windows Server 2003 的詳細資訊，請參閱 Microsoft Windows Server 2003 產品首頁 (英文) (http://go.microsoft.com/fwlink/?LinkId=26095)。

若需有關 Exchange Server 2003 的詳細資訊，請參閱 Microsoft Exchange Server 2003 產品首頁 (英文) (http://go.microsoft.com/fwlink/?LinkId=21573)。


此 Exchange 2003 伺服器未執行最新的 Service Pack 2 建置
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定目錄中所有 Exchange Server 物件的 serialNumber 屬性值。serialNumber 屬性是字串值，當中包含 Exchange Server 的版本及 Service Pack 的版本 (如果已安裝)。例如，在已安裝 Service Pack 1 的 Exchange Server 2003 電腦上，serialNumber 屬性等於 Version 6.5 (Build 7638:Service Pack 2)。

如果 Exchange Server Analyzer 發現 serialNumber 屬性的值在字串中包含 6.5 和 Service Pack 2，但未包含 7638，則會顯示警告。

此警告指出 Exchange Server 2003 電腦正在執行先前發行的 Exchange Server 2003 Service Pack 2 版本。

附註：
因為無法解除安裝 Exchange Service service Pack，在套用任何 Service Pack 之前，強烈建議您先對執行 Exchange Server 的電腦進行完整備份。
若要更正此警告

  1. Exchange Server 2003 Service Pack 2 的最新版本可於 Exchange Server 2003 Service Pack 2 網站上取得 (http://go.microsoft.com/fwlink/?linkid=52073)。

  2. 檢閱 Exchange Server 2003 Service Pack 2 版本資訊 (http://go.microsoft.com/fwlink/?linkid=52073)。

  3. 完整備份 Exchange Server 電腦。

  4. 套用 Exchange Server 2003 Service Pack 2。

  5. 對執行 Exchange Server 的電腦進行另一次完整備份。

若需有關如何安裝 Exchange Server Service Pack 的詳細資訊，請參閱微軟知識庫文件 - 328839＜如何套用 Exchange Service Pack 及 Hotfix＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)。


Exchange 伺服器正在執行 SharePoint Portal Server
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Microsoft Windows SharePoint® Portal Server (MSDMSERV) 的 Started 機碼值。值為 True 表示 SharePoint Portal Server 正在此 Exchange 伺服器上執行。

如果 Exchange Server Analyzer 判定 SharePoint Portal Server 正在 Exchange Server 電腦上執行，則會顯示警告。

SharePoint Portal Server 與 Exchange Server 不相容，應被移除。SharePoint Portal Server 及 Exchange Server 設計為一起工作，並在您組織的共同作業環境中起作用。不過，SharePoint Portal Serve 及 Exchange Server 設計為並存工作，而非設計為共存於相同的硬體中。

若要更正此警告

  • 將 Exchange Server 或 SharePoint Portal Server 移至其他電腦。建議您將其中一個程式從該電腦移除。

若需有關如何移動 Exchange Server 信箱的詳細資訊，請參閱微軟知識庫文件 - 821829＜在 Exchange Server 2003 中移動信箱＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)。

若需有關 Exchange Server 及 SharePoint Portal Server 相容性的詳細資訊，請參閱知識庫文件 - 277567＜無法在執行 Exchange Server 的電腦上安裝 SharePoint Portal Server＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=277567)。


在執行 Virtual Server 2005 的 Exchange Server 上，有另一部 Exchange Server 安裝成來賓
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄機碼中的值，以判定該伺服器是否為虛擬伺服器：

HKEY_LOCAL_MACHINE\Software\Classes\Installer\Products\354F2D7F395B57846953B997DF778AC1

Exchange Server Analyzer 也會檢查是否有下列登錄值：

HKLM\Software\Microsoft\Virtual Machine\Guest\Parameters

此外，Exchange Server Analyzer 會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定在執行 Microsoft Virtual Server 2005 的實體電腦上是否有執行 Microsoft Exchange Information Store 服務 (MSExchangeIS)。

如果 Exchange Server Analyzer 發現該伺服器是虛擬伺服器 (存在上述登錄分支)，而且 MSExchangeIS 是在實體電腦上執行，就會顯示錯誤。

HKLM\Software\Classes\Installer\Products\354F2D7F395B57846953B997DF778AC1 機碼存在表示 Exchange Server 電腦有安裝 Virtual Machine Additions。這件事實以及 HKLM\Software\Microsoft\Virtual Machine\Guest\Parameters 機碼的存在，表示在 Virtual Server 2005 中，Exchange Server 電腦是以來賓虛擬電腦在執行。

Microsoft 不支援在虛擬電腦或模擬器上，執行任何 Exchange Server 版本。對於在 Virtual Server 2005、Microsoft Virtual PC 2004 或任何協力廠商虛擬電腦程式上執行的 Exchange Server，這個情況會成立。Exchange Server 平台的設計和測試都只針對實體硬體來執行，特別是在 Windows Server Catalog (英文) (http://go.microsoft.com/fwlink/?linkid=17219) 中列出的那些硬體平台。

此外，在執行 Exchange Server 的電腦上以虛擬伺服器來賓的身分執行 Exchange 並不是最佳作法，因為這樣服務之間就不能有 適當的備援。

若要更正此錯誤

  1. 將在 Virtual Server 2005 上執行的 Exchange Server 之信箱，移到非虛擬 Exchange Server 電腦上。

  2. 視需要，將任何公用資料夾重新歸屬，並傳輸虛擬 Exchange 伺服器持有的角色。

  3. 在虛擬電腦上解除安裝 Exchange，將它從您的 Exchange 基礎結構與 Active Directory® 目錄服務中解除委任及移除。

若需有關移動信箱的詳細資訊，請參閱下列微軟知識庫文件：

  • 822892＜Exchange 2003 中移動信箱的改良功能＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975＜XADM：移動信箱方法間的差異＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

若需有關在虛擬環境中執行之 Exchange Server 電腦支援的詳細資訊，請參閱知識庫文件 - 320220＜虛擬機器或模擬機器上 Exchange Server 的支援邊界＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)。

若需有關 Virtual Server 2005 的詳細資訊，請參閱 "Microsoft Virtual Server 2005" (英文) (http://go.microsoft.com/fwlink/?linkid=34938)。

若需有關 Virtual PC 2004 的詳細資訊，請參閱 "Microsoft Virtual PC 2004" (英文) (http://go.microsoft.com/fwlink/?linkid=34663)。


執行 DNS 服務的 Exchange 伺服器
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 DNS 伺服器服務 (DNS) 的 Started 機碼值。True 值表示 DNS 伺服器服務正在 Exchange 伺服器上在執行。

Exchange Server Analyzer 也會查詢 Win32_OperatingSystem WMI 類別，來判定 OSProductSuite 機碼的值。此機碼傳回的值表示在 Exchange Server 電腦上執行的 Windows 作業系統版本。

此外，Exchange Server Analyzer 還會查詢 Active Directory® 目錄服務，以判定列在每個信箱儲存區之 homeMDBBL 屬性中的項目計數。這個屬性的計數代表信箱儲存區上的信箱數目。

如果 Exchange Server Analyzer 判定已在符合下列準則的 Exchange Server 電腦上啟動 DNS 伺服器服務，就會顯示警告：

  • Exchange Server 電腦可以主控 100 個以上的信箱。

  • Exchange Server 電腦不在 Windows Small Business Server 2003 或 Small Business Server 2000 上執行。

建議不要在與正式作業 Exchange 信箱伺服器相同的電腦上執行 DNS 伺服器服務。在正式作業環境中的同一台電腦上同時管理 DNS 伺服器服務和 Exchange Server，可能會導致其中一台伺服器或二台伺服器效能不佳。

若要更正此警告

  1. 您應該考慮採取下列其中一個選項，來更正此警告：

    • 將 Exchange Server 或 DNS Server 服務其中的一個移出該電腦。建議您將其中一個伺服器應用程式從該電腦完整移除。

    • 將 Exchange 信箱移出該伺服器。至少，您應將信箱移除，並將 Exchange 伺服器轉換到通訊協定或基礎結構伺服器上。如此可大量減少磁碟 I/O 及一些 CPU 的負載 (後者則仰賴於 Exchange 的基礎結構角色)。

    • 請改為考慮安裝 Small Business Server。如果您是在少於 75 個使用者的小型環境中執行 Exchange，在此環境中您不需要多部 Exchange 伺服器，則安裝 Small Business Server 便可讓您獲益。Small Business Server 同時包含 Microsoft SQL Server™、Exchange Server 及其他核心 Microsoft 伺服器應用程式，而且已針對單一電腦安裝進行開發、測試及最佳化。

若需有關移動信箱及 Exchange 伺服器的詳細資訊，請參閱下列微軟知識庫文件：

  • 822892＜Exchange 2003 中移動信箱的改良功能＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975＜XADM：移動信箱方法間的差異＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

  • 297289＜如何將 Exchange 2000 移動到新的硬體並維持相同的伺服器名稱＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=297289)

若需有關 Small Business Server 的詳細資訊，請參閱 "Microsoft Windows Small Business Server 2003" (英文) (http://go.microsoft.com/fwlink/?linkid=23456)。


Exchange 伺服器正在執行 SQL Server
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Microsoft SQL Server™ 服務 (MSSQLSERVER) 的 Started 機碼值。True 值表示 Exchange 伺服器上正在執行 SQL Server 服務。

Exchange Server Analyzer 也會查詢 Win32_OperatingSystem WMI 類別，來判定 OSProductSuite 機碼的值。此機碼傳回的值表示在 Exchange Server 電腦上執行的 Windows 作業系統版本。

此外，Exchange Server Analyzer 還會查詢 Active Directory® 目錄服務，以判定列在每個信箱儲存區之 homeMDBBL 屬性中的項目計數。這個屬性的計數代表信箱儲存區上的信箱數目。

如果 Exchange Server Analyzer 判定已在符合下列所有準則的 Exchange Server 電腦上啟動 SQL Server 服務，就會顯示警告：

  • Exchange Server 電腦可以主控 100 個以上的信箱。

  • Exchange Server 電腦不在 Windows Small Business Server 2003 或 Small Business Server 2000 上執行。

建議不要在與生產 Exchange 信箱伺服器相同的電腦上執行 SQL Server。SQL Server 及 Exchange 信箱伺服器都需要消耗大量的記憶體及磁碟資源，才能達到最佳效能。在生產環境中的同一台電腦上同時主控 SQL Server 和 Exchange Server，可能會導致其中一台或二台伺服器都效能不佳。此外，在為這種安裝進行疑難排解及安全性設定時，也不容易分辨清楚。

最後，如果您是在同一台電腦上執行 SQL Server 及 Exchange Server，還會發生一些已知的交互操作性問題。導致這些問題的原因，大部分都是因為這二種伺服器共用的檔案或程式版本不一致，例如 Microsoft Distributed Transaction Coordinator (MS DTC)、Microsoft ActiveX® Data Objects (ADO) 及 OLE Database (OLE DB)。

若要更正此警告

  • 您應該考慮採取下列其中一個選項，來更正此警告：

    • 將 Exchange Server 或 SQL Server 其中的一個移出該電腦。建議您將其中一個程式完整從該電腦移除。

    • 將 Exchange 信箱移出該伺服器。至少，您應將信箱移除，並將 Exchange 伺服器轉換到通訊協定或基礎結構伺服器上。如此可大量減少磁碟 I/O 及一些 CPU 的負載 (後者則仰賴於 Exchange 的基礎結構角色)。

    • 請改為考慮安裝 Small Business Server。如果您是在小型環境中執行 Exchange，在此環境中您不需要多部 Exchange 伺服器，則安裝 Small Business Server 便可讓您獲益。Small Business Server 同時包含 SQL Server 和 Exchange Server，還有其他的核心 Microsoft 伺服器應用程式，而且它已為單一電腦的安裝而開發、測試及最佳化。

若需有關移動信箱及 Exchange 伺服器的詳細資訊，請參閱下列微軟知識庫文件：

  • 822892＜Exchange 2003 中移動信箱的改良功能＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975＜XADM：移動信箱方法間的差異＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

  • 297289＜如何將 Exchange 2000 移動到新的硬體並維持相同的伺服器名稱＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=297289)

若需有關 Small Business Server 的詳細資訊，請參閱 "Microsoft Windows Small Business Server 2003" (英文) (http://go.microsoft.com/fwlink/?linkid=23456)，


在 VMware 之下執行的 Exchange 伺服器
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-10-26

若需有關支援在虛擬環境中執行之 Exchange Server 電腦的詳細資訊，請參閱知識庫文件 - 897615＜在非 Microsoft 硬體虛擬化軟體中執行之 Microsoft 軟體的支援原則＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=897615)。


此 Exchange 伺服器的記憶體低於 1 GB，但 boot.ini 檔案中有 /3GB 及 /USERVA=3030 參數
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢兩個 Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Exchange Server 電腦中的實體記憶體數量，以及已配置給使用者模式處理程序的虛擬位址空間數量。下表說明 Exchange Server Analyzer 會評估的類別與機碼。

類別 | 機碼 | 描述
Win32_OperatingSystem | MaxProcessMemorySize | 可以配置給處理程序的記憶體 KB 數上限。
Win32_OperatingSystem | OSProductSuite | 在作業系統上已安裝及授權的系統產品。
Win32_ComputerSystem | TotalPhysicalMemory | 電腦上已安裝的隨機存取記憶體 (RAM) 位元組數。

如果 Exchange Server Analyzer 判定 Exchange Server 電腦的 RAM 小於 950 MB，且 MaxProcessMemorySize 的值大於 2097024 但小於 3104640，就會顯示警告。

此警告指出 Exchange Server 電腦未正確設定成達到最佳記憶體使用量的原因有二個：

  • 已設定 /USERVA=3030 啟動參數。只有當 Exchange Server 電腦具有 1 GB 以上的記憶體，且是執行 Microsoft Windows Server™ 2003 作業系統時，才需要此參數。

  • 已設定 /3GB 啟動參數。此參數只能用在具有 1 GB 或更多記憶體，且執行下列任一作業系統的 Exchange Server：

    • Microsoft Windows Server 2003 Standard Edition

    • Microsoft Windows Server 2003 Enterprise Edition

    • Microsoft Windows Server 2003 Datacenter Edition

    • Microsoft Windows 2000 Advanced Server

    • Microsoft Windows 2000 Datacenter Server

重要事項：
在 Windows 2000 Server 上不可以使用 /3GB 參數，因為該參數未受支援，並且會導致應用程式或作業系統當機。此外，只有在上述作業系統安裝了 1 GB 或更多實體記憶體時，才支援 /3GB 參數。

如果您在已安裝 1 GB 實體記憶體的系統上遇到這個警告，可能是有其他元件 (例如視訊卡) 在硬體層級配置了一部分的實體記憶體，使得該部分配置的實體記憶體不能供作業系統使用。在這種情況下，實際安裝的記憶體數量，就 Windows 的角度來看，會小於電腦上已安裝的實體記憶體數量。如果您遇到這種情況，請將 BIOS 報告的已安裝記憶體數量，和 Windows 報告的已安裝記憶體數量相比。

若要在 Windows Server 2003 上更正這個警告

  1. 以滑鼠右鍵按一下 [我的電腦]，然後按一下 [內容]。即會出現 [系統內容] 對話方塊。

  2. 按一下 [進階]。

  3. 在 [啟動及修復] 區域中，按一下 [設定]。即會出現 [啟動及修復] 對話方塊。

  4. 在 [系統啟動] 區域中，按一下 [編輯]。這樣會用 [記事本] 開啟 Windows Boot.ini 檔。

  5. 在 [Operating Systems] 區段中，從所有啟動行刪除下列參數：/3GB /USERVA=3030

  6. 儲存變更並關閉 [記事本]。

  7. 按一下 [確定] 兩次來關閉已開啟的對話方塊，然後重新啟動電腦，使變更生效。

若要在 Windows 2000 Server 上更正這個警告

  1. 在 [Windows 檔案總管] 中，瀏覽至系統磁碟分割區。

  2. 如果看不見 Boot.ini 檔案，可能是因為 [資料夾選項] 設定為 [隱藏保護的作業系統檔案]。若是這樣，請在 [Windows 檔案總管] 中，依序按一下 [工具]、[資料夾選項] 及 [檢視]。清除 [隱藏保護的作業系統檔案 (建議使用)] 核取方塊。出現警告方塊提示時，按一下 [是]。

  3. 如果在 [Windows 檔案總管] 中看見 Boot.ini 檔，請在該檔案上按一下滑鼠右鍵、按一下 [開啟檔案]，然後按一下 [記事本] 來開啟該檔案。

  4. 移除 /3GB 及 /USERVA=3030 (如果存在)。

  5. 儲存變更並關閉 [記事本]。

  6. 重新啟動電腦，以使變更生效。

若需有關使用 /3GB 及 /USERVA 啟動參數的詳細資訊，請參閱下列微軟知識庫文件：

  • 308356＜在執行 Windows Server 2003 或 Windows 2000 Server 的網域控制站上，Lsass.exe 處理序使用的記憶體＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)

  • 297812＜如何使用 4GT RAM 調整功能＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901＜4GT 調整對系統分頁表項目的效果＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739＜如何在 Boot.ini 檔中使用 /USERVA 參數調整 /3GB 組態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044＜HOW TO: 疑難排解 Exchange 2003 及 Exchange 2000 的虛擬記憶體分散＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


此 Exchange 伺服器的記憶體小於 1 GB，但在 Boot.ini 檔案中設定 /3GB 參數
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢兩個 Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Exchange Server 電腦中的實體記憶體數量，以及已配置給在 Exchange Server 電腦上執行之使用者模式處理程序的虛擬位址空間數量。下表說明 Exchange Server Analyzer 會評估的類別與機碼。

查詢的類別 | 查詢的機碼 | 描述
Win32_OperatingSystem | MaxProcessMemorySize | 可以配置給處理程序的記憶體 KB 數上限。
Win32_ComputerSystem | TotalPhysicalMemory | 安裝於電腦上的隨機存取記憶體 (RAM) 位元組數。

如果 Exchange Server Analyzer 判定 TotalPhysicalMemory 的值小於 1073741824，且 MaxProcessMemorySize 的值等於 3145600，則會顯示警告。

此警告表示系統的實體記憶體少於 950 MB，但卻在 Boot.ini 檔案中設定 /3GB 啟動參數。此參數只能用在具有 1 GB 或更多記憶體，且執行下列任一作業系統的 Exchange Server：

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

重要事項：
在 Windows 2000 Server 上不可以使用 /3GB 參數，因為該參數未受支援，並且會導致應用程式或作業系統當機。此外，只有在上述作業系統安裝了 1 GB 或更多實體記憶體時，才支援 /3GB 參數。

如果您在已安裝 1 GB 實體記憶體的系統上遇到這個警告，可能是有其他元件 (例如視訊卡) 在硬體層級配置了一部分的實體記憶體，使得該部分配置的實體記憶體不能供作業系統使用。在這種情況下，實際安裝的記憶體數量，就 Windows 的角度來看，會小於電腦上已安裝的實體記憶體數量。如果您遇到這種情況，請將 BIOS 報告的已安裝記憶體數量，和 Windows 報告的已安裝記憶體數量相比。

若要在 Windows Server 2003 上更正這個警告

  1. 以滑鼠右鍵按一下 [我的電腦]，然後按一下 [內容]。即會出現 [系統內容] 對話方塊。

  2. 按一下 [進階]。

  3. 在 [啟動及修復] 區域中，按一下 [設定]。即會出現 [啟動及修復] 對話方塊。

  4. 在 [系統啟動] 區域中，按一下 [編輯]。這樣會用 [記事本] 開啟 Windows Boot.ini 檔。

  5. 在 [Operating Systems] 區段中，刪除所有啟動行中的下列參數：/3GB

  6. 儲存變更並結束 [記事本]。

  7. 按一下 [確定] 兩次來關閉已開啟的對話方塊，然後重新啟動電腦，使變更生效。

若要在 Windows 2000 Server 上更正這個警告

  1. 在 [Windows 檔案總管] 中，瀏覽至「系統磁碟分割」。這是存放硬體專用檔案 (例如 Boot.ini 和 NTLDR) 的磁碟分割。

  2. 如果看不見 Boot.ini 檔案，可能是因為 [資料夾選項] 設定為 [隱藏保護的作業系統檔案]。若是這樣，請在 [Windows 檔案總管] 中，依序按一下 [工具]、[資料夾選項] 及 [檢視]。清除 [隱藏保護的作業系統檔案 (建議使用)] 核取方塊。當出現提示時，按一下 [是]。

  3. 如果在 [Windows 檔案總管] 中看見 Boot.ini 檔，請在該檔案上按一下滑鼠右鍵、按一下 [開啟檔案]，然後按一下 [記事本] 來開啟該檔案。

  4. 在 [Operating Systems] 區段中，刪除所有啟動行中的下列參數：/3GB

  5. 儲存變更並結束 [記事本]。

  6. 重新啟動電腦，以使變更生效。

若需最佳化 Exchange Server 的記憶體使用量之詳細資訊，請參閱下列微軟知識庫文件：

  • 325044＜HOW TO:疑難排解 Exchange 2003 及 Exchange 2000 的虛擬記憶體分散＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


此 Exchange 伺服器在 Boot.ini 檔案中有設定 /3GB 啟動參數。
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定在 Exchange Server 電腦上配置給使用者模式處理程序的虛擬位址空間量 (MaxProcessMemorySize)。

Exchange Server Analyzer 也會檢查 root\MicrosoftExchangeV2 命名空間內的 Exchange_Server WMI 類別，以判斷 IsFrontEndServer 機碼的值。值 False 表示 Exchange Server 電腦不是前端伺服器。值 True 表示 Exchange Server 電腦是前端伺服器。

Exchange Server Analyzer 也會查詢 Win32_Service WMI 類別，以判定叢集服務 (ClusSvc) 是否存在且已經啟動。

最後，Exchange Server Analyzer 會查詢 Active Directory® 目錄服務，以判定信箱儲存區物件 (msExchPrivateMDB) 的 homeMDBBL 屬性之計數。結果計數是在 Exchange Server 電腦中找到的信箱數目。

如果 Exchange Server Analyzer 判定 MaxProcessMemorySize 機碼值不等於 2097024、IsFrontEndServer 機碼設為 False、叢集服務未執行、Exchange Server 信箱儲存區中的信箱數少於 20 個，且 Exchange 未在 Microsoft Windows Small Business Server 2003 上執行，就會顯示警告。

此警告表示因為 Boot.ini 檔案中已設定 /3GB 啟動參數，所以目錄伺服器未達到最佳記憶體使用設定。此參數只能用在具有 1 GB 或更多記憶體，且執行下列任一作業系統的 Exchange 伺服器：

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

重要事項：
在 Windows 2000 Server 上不可以使用 /3GB 參數，因為該參數未受支援，並且會導致應用程式或作業系統當機。此外，只有在上述作業系統安裝了 1 GB 或更多實體記憶體時，才支援 /3GB 參數。

在支援的作業系統上，若其 Boot.ini 檔案中包含 /3GB 參數，Windows 會在最多 4 GB 的虛擬位址空間裡，配置 3 GB 給使用者處理程序，以及配置 1 GB 給核心程式。通常 (沒有使用 /3GB 參數時)， Windows 會配置 2 GB 給使用者處理程序，以及 2 GB 給核心程式。因此，使用 /3GB 參數時，使用較多記憶體的應用程式，可以分配到較大的虛擬記憶體位址空間進行運作，因而可以改善效能。

使用 /3GB 參數最主要可以協助使用較多記憶體的應用程式，例如主控使用者信箱的 Exchange 伺服器上之 Store.exe 處理程序。前端伺服器並不主控使用者信箱，因此，在前端伺服器上使用 /3GB 參數，並不會有任何好處。

若要更正此警告

  1. 在 [Windows 檔案總管] 中，瀏覽至系統磁碟分割區。

  2. 如果您看不到 Boot.ini 檔案，則可能是因為 [資料夾選項] 設定為 [隱藏保護的作業系統檔案]。若是這樣，請在 [Windows 檔案總管] 視窗中，依序按一下 [工具]、[資料夾選項] 及 [檢視] 索引標籤。清除 [隱藏保護的作業系統檔案 (建議使用)] 核取方塊。出現警告框提示時，按一下 [是]。

  3. 在 [Windows 檔案總管] 中看到 Boot.ini 檔時，請在該檔案上按一下滑鼠右鍵、按一下 [開啟檔案]，然後選擇 [記事本] 來開啟檔案。

  4. 在 [Operating Systems] 區段中，從所有啟動行中刪除下列參數：/3GB

  5. 儲存變更並結束 [記事本]。

  6. 重新啟動電腦，以使變更生效。

若需使用 /3GB 參數的相關資訊，請參閱下列微軟知識庫文件:

  • 325044＜HOW TO: 疑難排解 Exchange 2003 及 Exchange 2000 中的虛擬記憶體分散＞(英文)

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)


此 Exchange 2003 伺服器未執行最新的 Service Pack 1 建置 (7226.6)
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-04-21

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務來判定目錄中所有 Exchange Server 物件的 serialNumber 屬性值。serialNumber 屬性是字串值，當中包含 Exchange Server 的版本及已安裝的 Service Pack 版本 (如果已安裝)。例如，在已安裝 Service Pack 1 的 Exchange Server 2003 電腦上，serialNumber 屬性等於 Version 6.5 (Build 7226.6:Service Pack 1)。

如果 Exchange Server Analyzer 發現 serialNumber 屬性的值在字串中包含 6.5 和 Service Pack 1，但字串中未包含 7226.6，則會顯示警告。

此警告指出 Exchange Server 2003 電腦正在執行先前發行的 Exchange Server 2003 Service Pack 1 版本。

附註：
因為無法解除安裝 Exchange Service Pack，在套用任何 Service Pack 之前，強烈建議您先對 Exchange Server 電腦執行完整備份。

若要更正此警告

  1. 取得 Exchange Server 2003 Service Pack 1 的正式版 (http://go.microsoft.com/fwlink/?linkid=29090)。

  2. 檢閱 Exchange Server 003 版本資訊 (英文) (http://go.microsoft.com/fwlink/?linkid=23235)。

  3. 檢閱 Service Pack 1 中包含的更新 (英文) (http://go.microsoft.com/fwlink/?linkid=34272)。

  4. 完整備份 Exchange Server 電腦。

  5. 套用 Service Pack 1 for Exchange Server 2003。

  6. 對 Exchange Server 電腦進行另一次完整備份。

若需有關安裝 Exchange Server Service Pack 的詳細資訊，請參閱微軟知識庫文件 - 328839＜如何套用 Exchange Service Pack 及 Hotfix＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)。


此 Exchange 伺服器正在執行 Windows 2000 Server，但 boot.ini 檔案中已設定 /3GB 參數
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢兩個 Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Exchange Server 電腦中的實體記憶體數量，以及已配置給使用者模式處理程序的虛擬位址空間數量。下表說明 Exchange Server Analyzer 會評估的類別與機碼。

類別 | 機碼 | 描述
Win32_OperatingSystem | MaxProcessMemorySize | 可以配置給處理程序的記憶體 KB 數上限。
Win32_OperatingSystem | OSProductSuite | 在作業系統上已安裝及授權的系統產品。
Win32_ComputerSystem | TotalPhysicalMemory | 電腦上已安裝的隨機存取記憶體 (RAM) 位元組數。

如果 Exchange Server Analyzer 判定 MaxProcessMemorySize 機碼的值不等於 2097024，且 OSProductSuite 機碼值解析為 Windows 2000 Server，則會顯示錯誤。

此警告表示因為 Boot.ini 檔案中已設定 /3GB 啟動參數，所以目錄伺服器未達到最佳記憶體使用設定。此參數只能用在具有 1 GB 或更多記憶體，且執行下列任一作業系統的 Exchange 伺服器：

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

重要事項：
在 Windows 2000 Server 上不可以使用 /3GB 參數，因為該參數未受支援，並且會導致應用程式或作業系統當機。此外，只有在上述作業系統安裝了 1 GB 或更多實體記憶體時，才支援 /3GB 參數。

若要在 Windows Server 2003 上更正此錯誤

  1. 在 [我的電腦] 上按一下滑鼠右鍵，然後選取 [內容]。即會出現 [系統內容] 對話方塊。

  2. 按一下 [進階] 標籤。

  3. 在 [啟動及修復] 區域中，按一下 [設定] 按鈕。即會出現 [啟動及修復] 對話方塊。

  4. 在 [系統啟動] 區域中，按一下 [編輯] 按鈕。這樣會用 [記事本] 開啟 Windows Boot.ini 檔。

  5. 在 [Operating Systems] 區段中，從所有啟動行刪除下列參數：/3GB。

  6. 儲存變更並結束 [記事本]。

  7. 按兩次 [確定] 來關閉已開啟的對話方塊，然後重新啟動目錄伺服器，使變更生效。

若要在 Windows 2000 Server 上更正此錯誤

  1. 在 [Windows 檔案總管] 中，瀏覽至系統磁碟分割區。

  2. 如果您看不到 Boot.ini 檔案，則可能是因為 [資料夾選項] 設定為 [隱藏保護的作業系統檔案]。若是這樣，請在 [Windows 檔案總管] 視窗中，依序按一下 [工具]、[資料夾選項] 及 [檢視] 索引標籤。清除 [隱藏保護的作業系統檔案 (建議使用)] 核取方塊。出現警告框提示時，按一下 [是]。

  3. 在 [Windows 檔案總管] 中看到 Boot.ini 檔時，請在該檔案上按一下滑鼠右鍵、按一下 [開啟檔案]，然後選擇 [記事本] 來開啟檔案。

  4. 移除 /3GB 並儲存檔案。

  5. 重新啟動目錄伺服器，讓變更生效。

若需使用 /3GB 及 /USERVA 啟動參數的進一步詳細資料，請參閱下列微軟知識庫文件：

  • 297812＜如何使用 4GT RAM 調整功能＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901＜4GT 調整對系統分頁表項目的效果＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739＜如何在 Boot.ini 檔中使用 /USERVA 參數調整 /3GB 組態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044＜HOW TO: 疑難排解 Exchange 2003 及 Exchange 2000 的虛擬記憶體分散＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


無法存取 Exchange Server WMI
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-08-24

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定是否已設定 Name 機碼值。如果 WMI 查詢失敗，且 Exchange Server 未在 Microsoft Windows NT® Server 4.0 上執行，Exchange Server Analyzer 就會顯示錯誤。

這項錯誤有兩個可能的原因：

  • 執行 Exchange Server Analyzer 的帳戶沒有足夠的權限可查詢 WMI 類別。

  • 發生網路問題，使得 Exchange Server Analyzer 無法與電腦連絡。

若要更正此錯誤

  1. 確定已啟動 Exchange Server 電腦，且已連接到網路。

  2. 使用 PING 命令來檢查是否可以連接 Exchange Server 電腦。

  3. 若有防火牆，請檢查遠端程序呼叫 (RPC) 通訊埠是否被封鎖。

  4. 檢查執行 Exchange Server Analyzer 的帳戶之權限。執行 Exchange Server Analyzer 的帳戶，在所掃描的每台 Exchange 伺服器上都必須擁有本機 Administrator 權限。

    或者，您也可以將特定的 WMI 權限授與執行 Exchange Server Analyzer 的帳戶：

    1. 在 Exchange 電腦上，開啟 [電腦管理] Microsoft Management Console (MMC) 樹狀目錄。

    2. 在 [服務及應用程式] 下的 [WMI 控制] 上按一下滑鼠右鍵，再按一下 [內容]。

    3. 在 [WMI 控制內容] 頁面上按一下 [安全性] 索引標籤，然後展開 [根]。

    4. 選取 CIMV2 資料夾，再按一下 [安全性]。

    5. 在 [安全性 ROOT\CIMV2] 頁面上，新增執行 Exchange Server Analyzer 的帳戶。

  5. 選取您在上述步驟 5 中新增的帳戶。在 [Selected_Account 的權限] 中，於 [允許] 直欄下，選取 [遠端啟用] 及 [讀取安全性]，再按一下 [確定]。

若需有關疑難排解網路連線問題的詳細資訊，請參閱微軟知識庫文件 - 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

若需有關疑難排解 Exchange Server Best Practices Analyzer 工具連線問題的詳細資訊，請參閱＜Microsoft Exchange Server Best Practices Analyzer 工具疑難排解連線問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56285)。

若需有關通訊埠需求的詳細資訊，請參閱知識庫文章 - 832017＜Windows Server 系統的服務概觀及網路通訊埠需求＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)。


此前端伺服器上未執行 Exchange System Attendant 服務。
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Microsoft Exchange System Attendant 服務的 Started 機碼值。False 值表示未執行 Exchange System Attendant 服務。True 值表示有執行 Exchange System Attendant 服務。

Exchange Server Analyzer 也會檢查位於 root\MicrosoftExchangeV2 命名空間內的 Exchange_Server WMI 類別，以判定 IsFrontEndServer 機碼的值。值 False 表示 Exchange Server 電腦不是前端伺服器。值 True 表示 Exchange Server 電腦是前端伺服器。

如果 Exchange Server Analyzer 發現 Exchange 前端伺服器上的 Started 機碼值設為 False，則會顯示一則警告。

通常大部分的 Exchange 伺服器都會讓 System Attendant 服務一直在執行中。然而，有時候不需要執行 System Attendant 服務。例如，在前端伺服器上，只有變更伺服器的組態時才需要 System Attendant 服務。

Exchange Server 會將所有組態資訊儲存在 Active Directory® 目錄服務中，這些資訊包括收件者原則、簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器組態、透過超文字傳送通訊協定 (HTTP) 的遠端程序呼叫 (RPC) 設定，以及使用者信箱。然而，SMTP 會從 Internet Information Services (IIS) Metabase 讀取其設定。為了將資訊填入 IIS Metabase，Exchange 需要 SMTP 及 RPC over HTTP 功能，System Attendant 的 Directory Service to Metabase (DS2MB) 元件會從 Active Directory 將組態資訊複寫到 IIS Metabase。如果系統服務員未執行，則對儲存在 Active Directory 中的 Exchange Server 組態設定所作的變更將不會複製到 Exchange Server IIS Metabase。如果沒有變更組態，而且未處理 SMTP 郵件，則 System Attendant 服務可以保持在停止狀態。

如果不要變更組態，請啟動 System Attendant 服務、進行組態變更，然後等候那些變更複寫到 IIS Metabase。若要判定變更是否已從 Active Directory 複寫到 IIS Metabase，請檢查 Exchange 伺服器的應用程式事件日誌中，是否有事件來源為 MSExchangeMU，且事件識別碼為 1005 的三個項目。這些事件會在 DS2MB 順利複寫後，被記錄下來。在這些事件被記錄之後，您可以立即停止 System Attendant 服務。

除非前端伺服器上使用 SMTP，否則建議的組態是停止 System Attendant 服務，然後將該服務設定為停用。在使用 SMTP 的前端伺服器上，以及所有其他的 Exchange Server 電腦上，必須執行 Exchange System Attendant 服務才能傳遞郵件、服務 SMTP 及信箱儲存區異動，然後執行 DS2MB 複寫。

Exchange System Attendant 服務應該一律在後端伺服器上及任何其他包含信箱或公用資料夾的 Exchange 伺服器上執行。

若要更正此警告

  1. 開啟 [服務] Microsoft Management Console (MMC) 嵌入式管理單元。

  2. 在右窗格中，向下捲動到 Microsoft Exchange System Attendant 服務，並連按兩下該服務。這樣會顯示 [System Attendant 服務內容] 對話方塊。

  3. 將 [啟動類型] 下拉式清單中的值設為 [自動]。

  4. 按一下 [啟動] 以啟動 System Attendant 服務。

  5. 按一下 [確定] 以儲存變更，並關閉 [系統服務員服務內容] 對話方塊。

  6. 關閉 [服務] 嵌入式管理單元。

若需有關停用系統服務員服務及設定 Exchange 伺服器安全性的詳細資訊，請參閱下列 Exchange Server 主題：

  • 《根據角色設定 Exchange 2000 Server 安全性》(英文) (http://go.microsoft.com/fwlink/?LinkId=35585)

  • 《Exchange Server 2003 安全性強化手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47578)


Exchange System Attendant 服務沒有執行
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-09

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Microsoft Exchange System Attendant 服務的 Started 機碼值。False 值表示未執行 Exchange System Attendant 服務。True 值表示有執行 Exchange System Attendant 服務。

Exchange Server Analyzer 也會檢查 root\MicrosoftExchangeV2 命名空間內的 Exchange_Server WMI 類別，以判斷 IsFrontEndServer 機碼的值。值 False 表示 Exchange Server 電腦不是前端伺服器。值 True 表示 Exchange Server 電腦是前端伺服器。

如果 Exchange Server Analyzer 發現，在非前端伺服器的 Exchange Server 電腦上，Started 機碼值是設定為 False，就會顯示一則警告。

通常大部分的 Exchange 伺服器都會讓 System Attendant 服務一直在執行中。然而，有時候不需要執行 System Attendant 服務。例如，在 Exchange 2000 Server 或 Exchange Server 2003 前端伺服器上，只有變更伺服器的組態時才需要 System Attendant 服務。

Exchange Server 會將所有組態資訊儲存在 Active Directory® 目錄服務中，這些資訊包括收件者原則、簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器組態、透過超文字傳送通訊協定 (HTTP) 的遠端程序呼叫 (RPC) 設定，以及使用者信箱。然而，SMTP 會從 Internet Information Services (IIS) Metabase 讀取其設定。為了將資訊填入 IIS Metabase，Exchange 需要 SMTP 及 RPC over HTTP 功能，System Attendant 的 Directory Service to Metabase (DS2MB) 元件會從 Active Directory 將組態資訊複寫到 IIS Metabase。如果系統服務員未執行，則對儲存在 Active Directory 中的 Exchange Server 組態設定所做的變更將不會複製到 Exchange Server IIS Metabase。如果沒有變更組態，而且未處理 SMTP 郵件，則 System Attendant 服務可以保持在停止狀態。

如果不要變更組態，請啟動 System Attendant 服務、進行組態變更，然後等候那些變更複寫到 IIS Metabase。若要判定變更是否已從 Active Directory 複寫到 IIS Metabase，請檢查 Exchange 伺服器的應用程式事件日誌中，是否有事件來源為 MSExchangeMU，且事件識別碼為 1005 的三個項目。這些事件會在 DS2MB 順利複寫後，被記錄下來。在這些事件被記錄之後，您可以立即停止 System Attendant 服務。

除非 Exchange 2000 Server 或 Exchange Server 2003 前端伺服器上使用 SMTP，否則建議的組態是停止 System Attendant 服務，然後將該服務設定為停用。在使用 SMTP 的 Exchange 2000 Server 或 Exchange Server 2003 前端伺服器上，以及所有其他 Exchange Server 電腦上，必須執行 Exchange System Attendant 服務，才能傳遞郵件、服務 SMTP 和信箱儲存區交易，以及執行 DS2MB 複寫作業。

Exchange System Attendant 服務應該一律在後端伺服器上及任何其他包含信箱或公用資料夾的 Exchange 伺服器上執行。

若要更正此警告

  1. 開啟 [服務] Microsoft Management Console (MMC) 嵌入式管理單元。

  2. 在右窗格中，向下捲動到 Microsoft Exchange System Attendant 服務，並連按兩下該服務。這樣會顯示 [System Attendant 服務內容] 對話方塊。

  3. 將 [啟動類型] 下拉功能表中的值設定為 [自動]。

  4. 按一下 [啟動] 以啟動 System Attendant 服務。

  5. 按一下 [確定] 以儲存變更，並關閉 [系統服務員服務內容] 對話方塊。

  6. 關閉 [服務] 嵌入式管理單元。

若需有關停用 System Attendant 服務及保護 Exchange Server 安全的詳細資訊，請參閱《根據角色保護 Exchange 2000 Server 安全》(英文) (http://go.microsoft.com/fwlink/?linkid=35585)。


Exchmem 堆集指出效能問題
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具已分析 [MSExchangeIS] 效能物件下的 [Exchmem Heap] 效能計數器，以判斷 Exchange 伺服器上的效能是否已降低。Exchange Server Analyzer 工具對 Exchmem 計數器報告如下：

  • 如果 [Exchmem: Number of heaps with memory errors] 的數目大於 0，則 Exchange Server Analyzer 會報告一則警告。如果此值大於 5，則 Exchange Server Analyzer 會報告一則錯誤。

  • 如果 [Exchmem: Number of memory errors] 的數目大於 500，則 Exchange Server Analyzer 會報告一則錯誤。

  • 如果 [Exchmem: Number Additional Heaps] 的數目大於 3，則 Exchange Server Analyzer 會報告一則錯誤。

Store.exe 處理程序會使用自己的堆集配置機制與結構。這些稱為 Exchmem。Store.exe 處理程序會在啟動時建立幾個 Exchmem 堆集。Store.exe 並不會增加堆集數目，除非現有的數目完全被使用或分散至配置找不到足夠的相鄰記憶體以繼續的程度。

如果有記憶體使用問題或內部分散 (即位於 Exchange 儲存區虛擬記憶體空間內之 Exchmem 堆集中的分散)，Store.exe 處理程序會建立新 Exchmem 堆集。

一般而言，如果 Store.exe 處理程序必須重複建立額外的堆集，整個 Exchange 儲存區虛擬記憶體會變得分散或耗竭。追蹤上列計數器可判斷 Exchmem 堆集是否為問題的原因，或是否因堆集分散而使其效能降低。

若要更正警告或錯誤

  • 下載並安裝最新的 Exchange 儲存區更新。

    • 若需最新的 Exchange Server 2003 下載，請參閱 Exchange Server 2003 下載網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

    • 若需最新的 Exchange 2000 Server 下載，請參閱 Exchange 2000 Server 下載網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。

  • 下載並安裝 Store.exe 處理程序中執行之所有應用程式的最新更新。有時 Store.exe 處理程序中執行的協力廠商應用程式可能造成堆集分散。

  • 請考慮將使用者信箱從受影響的伺服器移到其他伺服器，以減少伺服器負載。若需詳細資訊，請參閱＜將使用者信箱移至其他伺服器＞。

  • 識別問題原因之前，可以視需要重新啟動以重設記憶體。

詳細資訊

  • 若需有關 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需有關疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《疑難排解 Microsoft Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


EXCHMEM.DLL 出現在 Windows System32 資料夾中
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定它是否能讀取 \Windows\System32\Exchmem.dll 的 Version 機碼值。如果 Exchange Server Analyzer 可以讀取 Version 機碼，Exchmem.dll 就會出現在 System32 資料夾中。

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定物件類別為 msExchExchangeServer 之所有物件的 serialNumber 屬性值。如果字串值包含 "Version 6"，表示電腦正在執行 Exchange 2000 Server 或 Exchange Server 2003。

若下列條件為真，Exchange Server Analyzer 就會顯示最佳作法訊息：

  • Exchmem.dll 出現在 System32 資料夾中。

  • 電腦正在執行 Exchange 2000 Server 或 Exchange Server 2003。

一般來說，一部 Exchange 伺服器上不會有兩個 Exchmem.dll。不過，有時候從前版產品使用就地升級時，會新增第二個 Exchmem.dll 檔。在安裝 Service Pack 時，存在這兩個檔案版本會造成安裝失敗。若要防止發生問題，建議您重新命名或移除 \Windows\System32 資料夾中的 Exchmem.dll 檔。

若要移除或重新命名第二版 Exchmem.dll

  1. 停止所有 Exchange 服務。

  2. 重新命名或移除 \Windows\System32 資料夾中的 Exchmem.dll 檔。

  3. 重新啟動所有 Exchange 服務。


找到嚴重錯誤
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-10-06

Microsoft® Exchange Server Analyzer 工具會嘗試存取各種特定的資源，以執行其分析：

  • Microsoft Active Directory® 目錄服務

  • Exchange Server 郵件追蹤中心

  • Microsoft Windows® 登錄

  • Microsoft Windows® Management Instrumentation (WMI)

  • 網際網路資訊服務 (IIS) Metabase

如果 Exchange Server Analyzer 無法存取一或多個必要資源，Exchange Server Analyzer 會顯示錯誤。

此錯誤指出因為無法存取其中一個或多個基本資源，所以無法進行額外的分析。

若要更正此錯誤，請檢閱 Exchange Server Analyzer 所提供的資源特有錯誤指導及連結。


未啟用伺服器的 FCL 記錄
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-20

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判斷具有物件類別 msExchExchangeServer 之所有物件的 serialNumber 屬性值。如果字串值包括 Version 5.5，表示電腦正在執行 Microsoft Exchange Server 5.5 版。如果字串值包括 Version 6.0，表示電腦正在執行 Exchange 2000 Server。如果字串值包括 Version 6.5，表示電腦正在執行 Exchange Server 2003。

Exchange Server Analyzer 也會從下列登錄項目查詢 Disable Call Tracing 子機碼是否存在，以判斷是否要對 Exchange 伺服器啟用 Microsoft Exchange 函數呼叫記錄 (FCL) 功能：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server 可以追蹤 Microsoft Exchange Information Store 服務 (Store.exe) 所產生之內部呼叫的效能。您可以使用 FCL 來隔離可能是效能問題之起因的元件及函數呼叫。

Microsoft Exchange Information Store 服務中的 FCL 功能會繼續追蹤下列元件的相關呼叫：

  • 本機安全性驗證伺服器 (Lsass.exe)

  • DSAccess

  • 可延伸儲存引擎 (ESE)

  • IMAIL

  • Virusscan

FCL 是低負荷的記錄，當 Exchange Information Store 服務 (Store.exe) 顯出效能降低或沒有回應時，此功能會收集有關問題情況 (例如 Exchange Server 中的關機問題) 或狀況的資料。

一旦啟用它，FCL 便會自動記錄函數呼叫資料。不需要使用者介入或特定組態，例如取得實際執行伺服器的使用者傾印檔案或使用偵錯工具。

依預設，Exchange Server 2003 會啟用 FCL，但是 Exchange 2000 Server 必須特別地啟用它。

若下列條件為真，Exchange Server Analyzer 就會顯示最佳作法訊息：

  • 伺服器正在執行 Exchange 2000 Server，但 Disable Call Tracing 子機碼不存在，或 Disable Call Tracing 子機碼存在，但包含 0 以外的值。

  • 伺服器正在執行 Exchange Server 2003，且 Disable Call Tracing 子機碼存在並包含 0 以外的值

此最佳作法訊息指出已停用 FCL。

建議的最佳作法就是在所有 Exchange 伺服器上啟用 FCL。

重要事項：
這篇文章包含如何編輯登錄的相關資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
在 Exchange 2000 Server 上啟用函數呼叫記錄

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Disable Call Tracing

  3. 在右窗格中，按兩下 Disable Call Tracing。如果 Disable Call Tracing 子機碼不存在，請將它建立為新的 DWORD 值。

  4. 將 Disable Call Tracing 子機碼設定為 0 值。
附註：
依預設，Exchange 2000 Server 會關閉 FCL，而且此值會設為 1。
  1. 關閉登錄編輯程式。

  2. 重新啟動 Exchange Information Store 服務，使這些變更生效。

 在 Exchange Server 2003 上啟用函數呼叫記錄

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Disable Call Tracing.

  3. 在右窗格中，連按兩下 Disable Call Tracing。

  4. 將 Disable Call Tracing 子機碼設定為 0 值。
附註：
依預設，Exchange Server 2003 會啟用 FCL，而且已建立 Disable Call Tracing 子機碼，且其值設為 0 以外的值以關閉它。
  1. 關閉登錄編輯程式。

  2. 重新啟動 Exchange Information Store 服務，使這些變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱 Microsoft 知識庫文章 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


可用分頁表項目處於嚴重閥值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_PerfRawData_PerfOS_Memory Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 FreeSystemPageTableEntries 物件目前的值。如果 FreeSystemPageTableEntries 的值小於或等於 5000，就會顯示一則錯誤。

不管安裝的實體 RAM 是多少，Microsoft Windows Server™ 2003 及 Windows 2000 Server 最多可以直接定址 4 GB 的記憶體位址空間。從處理程序的角度來看，在觀念上，虛擬位址的每一個元素都可以指向實體記憶體的一個位元組。將每一個虛擬位址轉換或對應至相對應的實體位址，是「虛擬記憶體管理員 (VMM)」和處理器記憶體管理單元 (MMU) 兩者的共同責任。VMM 執行對應的方式，是將 RAM 劃分為固定大小的頁面框架，然後建立一些系統分頁表項目 (PTE)，來儲存和這些頁面框架有關的資訊，並進行對應。系統 PTE 是指記憶體的一些小型核心模式緩衝區，用來和磁碟 I/O 子系統及網路進行通訊。每一個 PTE 代表一個頁面框架，並且其中包含 VMM 用來找出分頁所需要的資訊。

在使用 4 KB 分頁大小的 x86 型系統上，對映 2 GB 位址空間需要的最大 PTE 數目是 524288 (2 GB/4 KB) 個。在使用 /3GB 參數的類似系統上，要對映 3 GB 位址空間所需要的 PTE 數目是 786,432 (3 GB/4 KB) 個。在一般的系統上，此空間的用法如下：

  • 最多保留 50000 個 PTE (大約 195 MB 位址空間) 供一般用途。

  • 其餘會用來對應系統快取、Hyperspace、分頁集區、未分頁集區、損毀傾印區域等等。

此 PTE 集區大小是在系統啟動時，依據系統中的實體記憶體數量自動決定。這個集區會擠在分頁集區和未分頁集區之間，也會隨著系統中的實體記憶體數量而成長。

系統 PTE 集區久而久之會變得使用過度，並且嚴重分散。這種情況會導致驅動程式無法載入的情形。此外，如果沒有刪除整個系統 PTE 集區，系統的其他部份會降級 (甚至不會建立執行緒)、系統會延遲，且可能會發生系統損毀。

狀況良好的 Exchange Server 電腦應該至少隨時有 8,000 個系統 PTE 可供使用。如果可用的系統 PTE 數降到 8,000 以下 (但仍維持在 5,000 以上)，就會顯示可用的分頁表項目達到警告閾值中所述的警告。當可用的系統 PTE 數降到 5,000 個以下，就會顯示一則錯誤訊息。

若要解決這個問題，您可以使用隨後的程序，針對 Exchange Server 電腦的作業系統來適當設定 SystemPages 登錄值。在 RAM 有 1 GB 以上的 Windows Server 2003 上執行 Exchange Server 2003 Service Pack 1 (SP1) 時，建議您將 SystemPages 登錄機碼設定為 0。這項建議與 Windows 2000 Server 的建議不同，後者建議將 SystemPages 的值設為 31000 (十進位)。

執行過隨後的程序之後，您應該監視可用的系統 PTE 數。您可以使用 [Windows 系統監視器] (亦稱為 [效能監視器]) 來監視記憶體 | 可用的系統分頁表項目效能計數器，以執行這個動作。如果在進行登錄變更之後，可用的系統 PTE 數目依舊很低，您應該檢查下列各項，確定已對您的 Exchange Server 電腦進行最佳設定：

  • 驅動程式 驅動程式故障是造成低系統 PTE 最常見的原因之一。請詢問您的硬體製造廠商，確定您所有的硬體都是使用最新的驅動程式。有時也許可以降級為使用較基本的驅動程式。例如，電腦若執行如 Exchange Server 之類的伺服器型應用程式，通常不需要使用包含所有功能的最進階視訊驅動程式。只要使用較基本的驅動程式就已夠用。從進階的視訊驅動程式切換為基本的視訊驅動程式，應該就會提高可用的系統 PTE 數目。

  • 系統組態 如果您的 Windows Server 2003 系統安裝 1 GB 或更大的實體記憶體，您應該檢查以確定其 Boot.ini 檔案已正確地設定 /3GB 及 /USERVA=3030 參數，內容詳見微軟知識庫文件 - 823440＜當您在 Windows Server 2003 型系統上安裝 Exchange Server 2003 時必須使用 /3GB 參數＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440) 及知識庫文件 - 810371＜XADM：在 Windows Server 2003 型的 Exchange Server 上使用 /Userva 參數＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371)。

  • 事件日誌 檢查 Exchange 伺服器的應用程式事件日誌是否有錯誤及警告，尤其是 MSExchangeIS 事件 9582 (錯誤及警告)、9665 (警告) 及 12880 (錯誤)。出現事件 9665 也可能表示 SystemPages 沒有設定為最佳效能。若需有關這些事件的詳細資訊，請參閱知識庫文件 - 325044＜HOW TO：疑難排解 Exchange 2003 及 Exchange 2000 的虛擬記憶體分散＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要在執行 Windows 2000 Server 的電腦上更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. 在右窗格中，連按兩下 [SystemPages]。

  4. 在數值資料欄位中，鍵入 31000 (十進位) 的值 (7918 (十六進位) 是以 31000 (十進位) 表示。Regedit.exe 則預設為十六進位值)，然後按一下 [確定]。

  5. 關閉登錄編輯程式，然後重新啟動電腦，以使變更生效。

若要在執行 Windows Server 2003 原始發行版本的電腦上更正此錯誤

  • 檢閱微軟知識庫文件 - 894067＜效能工具無法在 Windows Server 2003 中正確顯示可用的系統分頁表項目＞(英文) 中的資訊 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067)，以判定實際可用的系統分頁表項目。

若要在執行 Windows Server 2003 SP1 的電腦上更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. 在右窗格中，連按兩下 [SystemPages]。

  4. 在 [數值資料] 欄位中，鍵入 0，然後按一下 [確定]。

  5. 關閉登錄編輯程式。

  6. 以滑鼠右鍵按一下 [我的電腦]，然後按一下 [內容]。即會出現 [系統內容] 對話方塊。

  7. 按一下 [進階]。

  8. 在 [啟動及修復] 區域中，按一下 [設定]。即會出現 [啟動及修復] 對話方塊。

  9. 在 [系統啟動] 區域中，按一下 [編輯]。這樣會用 [記事本] 開啟 Windows Boot.ini 檔。

  10. 檢閱 [作業系統] 區段。

    1. 若存在的參數為 /3GB 而非 /USERVA=3030，請將 /USERVA=3030 參數新增到啟動列，以使其設定為 /3GB /USERVA=3030。

    2. 若已設定 /3GB /USERVA=3030 參數，請將 /USERVA 參數值變更為 /USERVA=2970。

  11. 儲存變更並結束 [記事本]。

  12. 按兩次 [確定] 關閉開啟的對話方塊，然後重新啟動電腦使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關最佳化 Exchange Server 記憶體的詳細資訊，請參閱下列知識庫文件：

  • 894067＜效能工具無法在 Windows Server 2003 中正確顯示可用的系統分頁表項目＞(英文) http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067

  • 325044＜HOW TO：疑難排解 Exchange 2003 及 Exchange 2000 的虛擬記憶體分散＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 823150＜如何收集資料以疑難排解 Exchange Server 2003 虛擬記憶體的問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823150)

  • 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)

  • 311901＜4GT 調整對系統分頁表項目的效果＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


可用的分頁表項目達到警告閾值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_PerfRawData_PerfOS_Memory Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 FreeSystemPageTableEntries 物件目前的值。如果 FreeSystemPageTableEntries 的值超過 5000 但小於或等於 8000，將會顯示警告。

不管安裝的實體 RAM 是多少，Microsoft Windows Server™ 2003 及 Windows 2000 Server 最多可以直接定址 4 GB 的記憶體位址空間。從處理程序的角度來看，在觀念上，虛擬位址的每一個元素都可以指向實體記憶體的一個位元組。將每一個虛擬位址轉換或對應到相對應的實體位址，是虛擬記憶體管理員 (VMM) 和處理器記憶體管理單位 (MMU) 兩者的共同責任。VMM 執行對應的方式，是將 RAM 劃分為固定大小的頁面框架，然後建立一些系統分頁表項目 (PTE)，來儲存和這些頁面框架有關的資訊，並進行對應。系統 PTE 是指記憶體的一些小型核心模式緩衝區，用來和磁碟 I/O 子系統及網路進行通訊。每一個 PTE 代表一個頁面框架，且包含 VMM 尋找頁面所需的資訊。

在使用 4 KB 分頁大小的 x86 型系統上，對映 2 GB 位址空間需要的最大 PTE 數目是 524288 (2 GB/4 KB) 個。在使用 /3GB 參數的類似系統上，要對映 3 GB 位址空間所需要的 PTE 數目是 786432 (3 GB/4 KB) 個。在一般的系統上，此空間的用法如下：

  • 最多保留 50000 個 PTE (大約 195 MB 位址空間) 供一般用途。

  • 其餘用於對應系統快取、Hyperspace、分頁集區、未分頁集區、損毀傾印區域等。

此 PTE 集區大小是在系統啟動時，依據系統中的實體記憶體數量自動決定。這個集區會夾在分頁集區和未分頁集區之間，也會隨著系統中的實體記憶體數量而成長。

系統 PTE 集區久而久之會變得使用過度，並且嚴重分散。這種情況會導致驅動程式無法載入的情形。同時，如果系統 PTE 集區完全耗竭，系統的其他部分會跟著降級，甚至於導致無法建立執行緒、系統停機以及可能的系統當機。

狀況良好的 Exchange Server 電腦應該至少隨時有 8,000 個系統 PTE 可供使用。如果可用的系統 PTE 數目掉到 5,000 以下，將顯示可用分頁表項目處於嚴重閥值中描述的錯誤。當可用的系統 PTE 數目降到低於 8,000，但仍在 5,000 以上時，將顯示此警告。

若要解決這個問題，您可以使用隨後的程序，針對 Exchange Server 電腦的作業系統來適當設定 SystemPages 登錄值。在 RAM 有 1 GB 以上的 Windows Server 2003 上執行 Exchange Server 2003 Service Pack 1 (SP1) 時，建議您將 SystemPages 登錄機碼設定為 0。這項建議與 Windows 2000 Server 的建議不同，後者建議將 SystemPages 的值設為 31000 (十進位)。

執行下列程序之後，請監視可用的系統 PTE 數目。您可以使用 [Windows 系統監視器] (亦稱為 [效能監視器]) 來監視記憶體 | 可用的系統分頁表項目 效能計數器，以執行這個動作。根據本文變更登錄之後，如果可用的系統 PTE 數目仍然很低，請檢查下列項目來確定 Exchange Server 電腦已完成最佳化設定：

  • 驅動程式 驅動程式故障是造成低系統 PTE 最常見的原因之一。請連絡您的硬體製造商，來確定全部硬體都使用最新的驅動程式。有時也許可以降級為使用較基本的驅動程式。例如，電腦若執行如 Exchange Server 之類的伺服器型應用程式，通常不需要使用包含所有功能的最進階視訊驅動程式。只要使用較基本的驅動程式就已夠用。從進階的視訊驅動程式切換為基本的視訊驅動程式，應該就會提高可用的系統 PTE 數目。

  • 系統組態 如果您的 Windows Server 2003 系統安裝 1 GB 以上的實體記憶體，您應該檢查以確定其 Boot.ini 檔案已正確地設定 /3GB 及 /USERVA=3030 參數，內容詳見微軟知識庫文件 - 823440＜在 Windows Server 2003 型的系統上安裝 Exchange Server 2003 時，必須使用 /3GB 參數＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440) 及＜XADM：在 Windows Server 2003 型的 Exchange Server 上使用 /Userva 參數＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371)。

  • 事件日誌 檢查 Exchange 伺服器的應用程式事件日誌是否有錯誤及警告，尤其是 MSExchangeIS 事件 9582 (錯誤及警告)、9665 (警告) 及 12880 (錯誤)。事件 9665 也可能指出 SystemPages 未達到最佳效能的設定。若需有關這些事件的詳細資訊，請參閱知識庫文件 - 324044＜HOW TO：疑難排解 Exchange 2003 及 Exchange 2000 的虛擬記憶體分散＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要在執行 Windows 2000 Server 的電腦上更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. 在右窗格中，連按兩下 [SystemPages]。

  4. 在 [數值資料] 欄位中，輸入十進位值 31000 (31000 是十六進位的 7918 之十進位表示法。Regedit.exe 則預設為十六進位值)，然後按一下 [確定]。

  5. 關閉登錄編輯程式，然後重新啟動電腦，以使變更生效。

若要在執行 Windows Server 2003 原始發行版本的電腦上更正此警告

  • 檢閱微軟知識庫文件 - 894067＜效能工具無法在 Windows Server 2003 中正確顯示可用的系統分頁表項目＞(英文) 中的資訊 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067，以判定實際可用的系統分頁表項目。

若要在執行 Windows Server 2003 SP1 的電腦上更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. 在右窗格中，連按兩下 [SystemPages]。

  4. 在 [數值資料] 欄位中，鍵入 0，然後按一下 [確定]。

  5. 關閉登錄編輯程式。

  6. 以滑鼠右鍵按一下 [我的電腦]，然後按一下 [內容]。即會出現 [系統內容] 對話方塊。

  7. 按一下 [進階]。

  8. 在 [啟動及修復] 區域中，按一下 [設定]。即會出現 [啟動及修復] 對話方塊。

  9. 在 [系統啟動] 區域中，按一下 [編輯]。這樣會用 [記事本] 開啟 Windows Boot.ini 檔。

  10. 檢閱 [作業系統] 區段。

    1. 若存在的參數為 /3GB 而非 /USERVA=3030，請將 /USERVA=3030 參數新增到啟動列，以使其設定為 /3GB /USERVA=3030。

    2. 若已設定 /3GB /USERVA=3030 參數，請將 /USERVA 參數值變更為 /USERVA=2970。

  11. 儲存變更並結束 [記事本]。

  12. 按兩次 [確定] 關閉開啟的對話方塊，然後重新啟動電腦使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關最佳化 Exchange Server 記憶體的詳細資訊，請參閱下列知識庫文件：

  • 894067＜效能工具無法在 Windows Server 2003 中正確顯示可用的系統分頁表項目＞(英文) http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067

  • 325044＜HOW TO：疑難排解 Exchange 2003 及 Exchange 2000 的虛擬記憶體分散＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 823150＜如何收集資料以疑難排解 Exchange Server 2003 虛擬記憶體的問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823150)

  • 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)

  • 311901＜4GT 調整對系統分頁表項目的效果＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


前端伺服器在執行站台複寫服務
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Exchange Server Microsoft Windows® Management Instrumentation (WMI) 物件 (Exchange_Server 類別)，以判定伺服器的 IsFrontEndServer 值。如果值為 True，則表示 Exchange 伺服器是前端伺服器。Exchange Server Analyzer 也會查詢 MSExchangeSRS WMI 物件 (Win32_Service 類別)，以判定該物件的 Started 屬性之值。如果該值為 True，則站台複寫服務正在此伺服器上執行。

如果 Exchange 伺服器被指定為前端伺服器，而且也有一個執行中的「站台複寫服務」執行個體，就會顯示一則警告。

如果您的拓撲包括執行 Exchange Server 版本 5.5 及 Exchange 2000 Server 或 Exchange Server 2003 的伺服器，則 Exchange 會使用站台複寫服務。透過這項服務，較新版本的 Exchange 可以採用與 Exchange Server 5.5 目錄相容的格式，將伺服器組態資訊複寫至 Exchange Server 5.5 伺服器，而且這些較新版本的 Exchange 也可以正確處理從 Exchange Server 5.5 目錄複寫的組態資訊，使該組態資訊可以儲存在 Active Directory® 目錄服務中。如果已設定拓樸使用前端伺服器及後端伺服器，則只應該在後端伺服器上執行「站台複寫服務」。從 Exchange 2000 Server Service Pack 2 開始，「站台複寫服務」在前端伺服器上無法正常運作，可能會發生問題。

若要解決此問題，請將前端伺服器轉換為後端伺服器，然後設定新的前端伺服器。不建議從伺服器移除「站台複寫服務」。

若要更正此錯誤

  1. 設定新的前端伺服器。

  2. 在有問題的前端伺服器上，在 [Exchange 系統管理員] 中的 [伺服器] 下面，以滑鼠右鍵按一下該伺服器，再按一下 [內容]。

  3. 清除 [此為前端伺服器] 核取方塊。

若需有關前端伺服器及站台複寫服務的詳細資訊，請參閱微軟知識庫文件 - 313646＜在 Exchange 2000 Server SP2 升級之後停用前端伺服器上的服務＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313646)。


遺失 bin 資料夾中的 GAPI32.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔是否存在：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要解決此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 Microsoft Exchange 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


遺失 system32 資料夾中的 GAPI32.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔是否存在：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要修正此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或彙總更新套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 Microsoft Exchange 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


已設定 GlobalFlag
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 GlobalFlag 項目的值：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\MAD.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\INETINFO.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\EMSMTA.EXE

如果 Exchange Server Analyzer 發現 GlobalFlag 的值，已設定為 0 或 Null 以外的值，則會顯示一則警告。

GlobalFlag 登錄值設定是一種位元遮罩，可決定已為特定處理程序啟用哪些偵錯選項。在此情況下，Exchange Server Analyzer 會特別查看是否已為各種 Exchange 元件啟用任何偵錯選項：

  • STORE.EXE (資訊儲存庫處理程序)

  • MAD.EXE (系統服務員處理程序)

  • INETINFO.EXE (IIS 管理及父處理序)

  • EMSMTA.EXE (郵件傳輸代理程式處理程序)

除非您是在 Microsoft 產品支援服務的協助下主動偵錯或追蹤問題，否則建議您一律將 GlobalFlag 值設為 0，或將它完全刪除，這兩者的效果相同。

根據預設值，GlobalFlag 登錄值不存在，如果 STORE.EXE 處理程序 (或任何其他處理程序) 需要偵錯功能，則必須手動新增。您可以使用包含在 Microsoft Windows Server™ 2003 支援工具中的 Gflags 工具，而這些工具位於 Windows 光碟的 \Support 資料夾中。除此之外，您可以使用登錄編輯程式，手動將此值設為 0，或完全刪除 GlobalFlag 值。兩個程序在本文件中都有說明。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

使用 Gflags 更正此錯誤

  1. 依序按一下 [開始] 及 [執行]，然後在 [開啟] 欄位中執行 GFlags。即會出現 Global Flags 使用者介面。

  2. 在 [映像檔案名稱] 欄位中，輸入 STORE.EXE。

  3. 選取 [映像檔案名稱]。

  4. 清除所有核取方塊，然後按一下 [套用]。

  5. 針對本文中列出的每一個 Exchange 處理程序，重複步驟 2 到 4。

  6. 按一下 [確定]，結束 GFlags 工具，然後重新啟動受影響的服務，使變更生效。

若要使用登錄編輯程式更正這個錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

  3. 刪除名稱為 GlobalFlag 的值。

  4. 針對本文中列出的每一個 Exchange 處理程序，重複步驟 2 及 3。

  5. 結束登錄編輯程式，然後重新啟動受影響的服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


發生大量的 ACL 升級失敗
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_PerfRawData_MSExchangeIS_MSExchangeIS Microsoft Windows® Management Instrumentation (WMI) 類別，以判定目前的 ACLUpgradefailures 機碼值。ACLUpgradefailures 機碼代表 MSExchangeIS 效能物件下的 ACL Upgrade: failures 效能計數器。

如果 Exchange Server Analyzer 發現 ACLUpgradefailures 機碼的值大於 500，就會顯示一則警告。

此警告表示 Exchange 伺服器已報告了許多存取控制清單 (ACL) 升級失敗。過多的 ACL 升級失敗可能導致嚴重的效能問題，包括資訊儲存庫處理程序 (store.exe) 中的隨機停止。

導致 ACL 升級失敗的原因各異，已知會在下列條件為真時發生失敗：

  • 在混合模式 Exchange 組織中，在實作 Active Directory 連接器 (ADC) 伺服器之前，沒有執行 Exchange Server 版本 5.5 一致性調節器。Exchange Server 5.5 一致性調節器移除孤立的 ACL。

  • Active Directory 複寫運作不正常。

  • Active Directory 連接器複寫未從 Exchange Server 5.5，將帳戶正確複寫到 Active Directory。

  • 使用者帳戶的遷移不正確。

若要更正此警告

  1. 請檢閱微軟知識庫文件 - 812963＜使用 Ignore Zombie Users 登錄機碼＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812963)。

  2. 瞭解使用 Ignore Zombie Users 登錄機碼的用意之後，請自行決定是否新增該機碼。

  3. 執行 Exchange Server Analyzer 或監視 ACL Upgrade: failures 效能計數器，以尋找過多的 ACL 升級失敗。


高度活動的 Exmon 使用者
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-04-21

Microsoft® Exchange Server Analyzer 工具會使用 Exchange Server User Monitor (ExMon) 工具來判定使用者或處理程序 (或使用者或處理程序群組) 是造成目前伺服器大量負載的成因。

ExMon 會評估數個案例：

  • 用戶端限制

  • 大量的遠端程序呼叫 (RPC) 作業

  • 高度的 RPC 同步作業

  • 大量的用戶端線上作業

  • 使用者檢視作業

下列各節提供每個案例的詳細資料及建議動作。

用戶端限制

在此案例中，ExMon RPC 資料指出用戶端電腦限制造成此伺服器的高負載。在 MAPI 的內容中，限制指的是名為 Restrict 的 MAPI 作業。此作業是用來選取符合特定準則的項目。Restrict 作業是處理程序的一部份，它要求 Exchange 在一個資料夾或一組資料夾 (實際上是與準則相關聯的資料庫表格) 上建立檢視。如果該資料夾或該組資料夾的檢視已經有相符的限制，Exchange 便會使用現有的檢視來滿足使用者的要求。如果檢視沒有相符的限制，Exchange 便會建立新的檢視。建立檢視的成本比使用現有檢視還要高。

許多信箱移動後，短時間內用戶端限制的成本會更高。move-mailbox 作業會讓伺服器重新建置資料夾上的索引。因此，當用戶端第一次檢視新伺服器上的資料夾時，必須重新建立所有限制，結果讓效能變差。如果您最近未移動過信箱，請調查下列事項：

  • 未在用戶端電腦上安裝其他 MAPI 應用程式。通常，Microsoft Office Outlook® 增益集或其他 MAPI 應用程式可能會建立太多限制。

  • 會適當分配組織內的信箱大小並設定限制。

若需信箱大小及項目數的詳細資訊，請參閱 Microsoft Exchange Team 網誌＜建議的信箱大小限制＞(英文) (http://go.microsoft.com/fwlink/?linkid=55097)。

大量的 RPC 作業

大量 RPC 作業的範例包括在數百或數千個項目中，以一次的作業來移動、刪除或設定屬性 (也就是「讀取旗標」)。這些作業類型可能會在短時間內造成伺服器效能不良。如果您經常執行大量的 RPC 作業，且伺服器在磁碟或處理器遭遇瓶頸，則相同伺服器之其他使用者的 Outlook 效能會降低。

若要更正此錯誤

  1. 驗證已設定信箱限制。

  2. 建議您的使用者將項目封存到 .pst 檔中。

    附註：
    一般的最佳作法是，經常使用的資料夾所包含的項目應該少於 5,000 個。

高度的 RPC 同步作業

高度的 RPC 同步作業表示有多位使用者正在同步項目。結果增加伺服器負載。

若要更正此錯誤

  • 確定您已根據以快取 Exchange 模式來執行 Outlook 的用戶端電腦數量來調整您的 Exchange 伺服器。若需詳細資訊，請參閱《Exchange Server 2003 RPC over HTTP 部署案例》(英文) (http://go.microsoft.com/fwlink/?LinkId=47577)。

  • 降低快取 Exchange 模式用戶端要求可能有助於防止高度的 RPC 同步作業變成效能問題。若需詳細資訊，請參閱微軟知識庫文件 - 818484＜可用來設定及監視 Outlook 用戶端同步的登錄值及計數器＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=818484)。

大量的用戶端線上作業

有時候，Exchange 會遇到效能問題帶來的不尋常中止，這是由不同使用者發佈之高負載所造成的。這也可能是組織成長後計畫不良所造成的。如果您遵循 Microsoft 最佳作法來調整組織，但是仍然遇到由多位用戶端線上作業造成的效能不良，這可能表示您的使用者正在執行協力廠商的 MAPI 應用程式或 Outlook 外掛程式。

使用者檢視作業

ExMon RPC 資料表示使用者正在建置新的檢視，而這造成了伺服器上的高負載。在此案例中，單一使用者帳戶是造成重大 RPC CPU 使用量的原因。

若要調查此問題，請考量下列案例：

  • 使用者可能在包含許多項目的資料夾上執行作業。若要修正此問題，請鼓勵使用者減少任一個資料夾中的項目數目。一般的最佳作法是，資料夾所包含的項目應該少於 2,000 個。

  • 使用者可能執行了寫入功能差的應用程式，因而造成過度的負載。若要修正此問題，請移除應用程式。

詳細資訊

  • 若需有關 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需有關疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《疑難排解 Microsoft Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 若需信箱大小及項目數的詳細資訊，請參閱 Microsoft Exchange Team 網誌＜建議的信箱大小限制＞(英文) (http://go.microsoft.com/fwlink/?linkid=55097)。

  • 若需信箱限制的詳細資訊，請參閱 Microsoft Exchange Team 網誌＜對限制所設定的限制＞(英文) (http://go.microsoft.com/fwlink/?linkid=55097)。

  • 若需 ExMon 的詳細資訊，請參閱 ExMon 下載網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=54983)。


IIS 在 64 位元的機器上建立 32 位元的處理程序
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-05-03

在執行 Exchange Server 2007 的所有 64 位元 Windows Server 2003 Service Pack 1 (SP1) 伺服器上，Microsoft Exchange Server Analyzer 工具會向網際網路資訊服務 (IIS) Metabase 查詢 w3svc/AppPools/Enable32BitAppOnWin64 Metabase 內容的值，以判斷 IIS 是否設定為建立 32 位元工作者處理程序。

1 (true) 值指出 IIS 是設定為建立 32 位元工作者處理程序。0 (false) 值指出 IIS 是設定為建立 64 位元工作者處理程序。

如果 Exchange Analyzer 判斷 w3svc/AppPools/Enable32BitAppOnWin64 Metabase 內容的值是設定為 1 (true)，則 Exchange Analyzer 會顯示錯誤。此錯誤指出 IIS 是設定為在執行 Exchange 2007 的 64 位元 Windows 伺服器上建立 32 位元工作者處理程序。此組態會導致 Exchange 2007 虛擬目錄運作不正常。

若要解決此錯誤，請設定 IIS 在執行 Exchange 2007 的 64 位元 Windows Server 2003 (SP1) 伺服器上，建立 64 位元工作者處理程序。

將 IIS 切換至 64 位元模式

  1. 開啟命令提示字元。

  2. 輸入下列內容：

    cscript c:\inetpub\adminscripts\adsutil.vbs SET /w3svc/AppPools/Enable32BitAppOnWin64 False

  3. 按 Enter 鍵

若需在 64 位元 Windows Server 2003 SP1 伺服器上執行 IIS 6.0 32 位元工作者處理程序的相關資訊，請參閱 Microsoft 知識庫文章 895976＜Windows Server 2003 SP1 啟用 IIS 6.0 中 32 位元 Web 應用程式的 WOW64 相容性＞(機器翻譯) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=895976)。


改善核心記憶體
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會測試系統記憶體層級，以確認其在可接受的範圍內。如果 Exchange Server Analyzer 發現任何一個效能監視器 (Perfmon) 核心記憶體計數器低於適當的層級，就會顯示疑難排解訊息。

Microsoft Windows® 核心記憶體是由數個記憶體結構所構成，包括分頁及非分頁集區記憶體與系統分頁表項目。作業系統使用這些記憶體結構 (亦稱為核心記憶體)，以提供應用程式 (如 Exchange) 的環境。若要維持健全的 Exchange 部署，請務必監視核心記憶體。

最佳化核心記憶體是一項複雜的工作。若需有關核心記憶體使用量的詳細資訊，包括疑難排解資訊，請參閱＜Exchange Server 2003 效能疑難排解＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。釋放伺服器資源的一項考量是伺服器上使用者信箱負載的考量。請考慮將使用者信箱移至其他伺服器，以減少伺服器負載，看看是否可以解決問題。若需詳細資訊，請參閱＜將使用者信箱移至其他伺服器＞。

詳細資訊

若需有關 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

若需有關移動使用者信箱以減少伺服器負載的詳細資訊，請參閱＜將使用者信箱移至其他伺服器＞


改進使用者記憶體
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-04-28

Microsoft® Exchange Server Analyzer 工具判定使用者記憶體效能計數器已超過 Exchange 伺服器認為狀況良好的閾值。Exchange Server Analyzer 會查詢位於 Memory 效能物件下的 Available Mbytes 效能計數器及 Memory Pages/sec 計數器。當伺服器的記憶體不足或具有高分頁時，表示有記憶體瓶頸。

Available MBytes 效能計數器會顯示可立即配置給處理程序或供系統使用的實體記憶體數量 (MB)。可用記憶體的數量等於指派給待命 (已快取的)、可用及零頁清單的記憶體總和。

Memory Pages/sec 效能計數器可指出在磁碟中讀取或寫入分頁的比率，以解決硬體分頁錯誤。當伺服器使用記憶體但可用記憶體不足時，作業系統會開始減少處理程序的工作組，並且會更頻繁地使用分頁檔。使用分頁檔會影響整體效能，原因是磁碟作業所花的時間會比記憶體作業來的長。此計數器是追蹤造成系統延遲這類錯誤的主要指示器。它包含為了彌補在檔案系統快取中的分頁錯誤而擷取的分頁。這些分頁通常為應用程式所要求。不管在什麼時候，此計數器都應低於 1,000。

如果 Exchange Server Analyzer 發現 Available Mbytes 效能計數器指出可用的記憶體少於 50 MB，或在磁碟中讀取或寫入記憶體分頁的比率大於每秒 1,000 個分頁，便會顯示錯誤。

下列清單描述改進使用者空間記憶體效能的方法。

若要更正此問題

  1. 使用 Microsoft Exchange Server Analyzer 工具 (http://go.microsoft.com/fwlink/?LinkId=34705)，驗證伺服器的記憶體設定是否正確。

  2. 移除不必要的軟體。若要讓 Exchange 使用更多的記憶體資源，請移除執行監視功能的所有協力廠商軟體工具，或移除任何不必要的服務。[效能] (Perfmon.msc) 嵌入式管理單元可以協助您瞭解應用程式正在耗用多少記憶體。

  3. 在離峰時間執行伺服器維護工作。在尖峰時間執行維護工具 (如 Eseutil) 或工作 (如信箱管理)，會用到應該由 Exchange 使用的記憶體。最佳作法是在非尖峰時間或在使用量較低的時段執行這些工具及工作。

  4. 請考慮將使用者信箱從受影響的伺服器移到其他伺服器，以減少伺服器負載。若需詳細資訊，請參閱＜將使用者信箱移至其他伺服器＞。

詳細資訊

若需相關資訊，請參閱下列 Microsoft 資源：

  • 將使用者信箱移至其他伺服器

  • 《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • 《Exchange Server 2003 效能及延展性手冊》中的＜將 Exchange Server 2003 中的記憶體使用量最佳化＞ (http://go.microsoft.com/fwlink/?LinkId=47576)

  • ＜Microsoft Exchange Server Best Practices Analyzer 工具＞(英文) (http://go.microsoft.com/fwlink/?LinkId=34705)

  • 微軟知識庫文件 - 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)

  • ＜Windows 2003 的 Exchange 2003 記憶體組態變更 (PAE 支援)＞(英文) (http://go.microsoft.com/fwlink/?LinkId=54979)

    附註：
    每一個部落格及其 URL 的內容隨時都會變更，不另行通知。


改善虛擬記憶體
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具判斷您的伺服器有虛擬記憶體分散的問題。

在 32 位元 Microsoft Windows® 系統中，有兩種記憶體：

  • 實體記憶體 系統中實際安裝的記憶體數量

  • 虛擬記憶體位址空間 虛擬的 4 GB 記憶體空間

無論在系統中安裝多少實體記憶體，虛擬位址空間總大小永遠相同：4 GB。雖然並非所有 32 位元應用程式都是這樣， 但就 Exchange Server 而言，虛擬位址空間等於虛擬記憶體。這兩個詞彙可以交替使用。

在正常操作期間，Exchange 儲存區將反覆配置、使用及解除配置虛擬記憶體。經常配置、使用及解除配置虛擬記憶體，可能會使虛擬記憶體分散。虛擬記憶體分散類似檔案系統分散，經過一段時間之後就會發生。一段時間之後，虛擬記憶體的配置區段就不再連續，因此效能開始降低。若為檔案系統，則可執行會對檔案系統執行磁碟重組的應用程式。在大部分情況中，可以在系統連線且正在存取系統時執行重組。虛擬記憶體分散的情況沒有重組工具可用。若要更正問題，必須停止再啟動 Microsoft Exchange Information Store 服務或重新啟動系統。

在 store/inetinfo 處理程序中執行的協力廠商軟體，可能會造成虛擬記憶體分散。請確定您有協力廠商應用程式的最新驅動程式。如果重新啟動之後，仍會發生此問題，請考慮停用協力廠商軟體或將使用者信箱移至其他伺服器，以減少伺服器負載，看看是否可解決問題。若需詳細資訊，請參閱＜將使用者信箱移至其他伺服器＞。

詳細資訊

  • 若需有關 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需有關疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《疑難排解 Microsoft Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 若需對 Exchange Server 2003 和 Exchange 2000 Server 中的虛擬記憶體分散進行疑難排解的詳細資訊，請參閱微軟知識庫文件 - 325044＜如何對 Exchange 2003 及 Exchange 2000 Server 中的虛擬記憶體分散進行疑難排解＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)。

  • 若需有關如何最佳化虛擬記憶體使用量的詳細資訊，請參閱微軟知識庫文件 - 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)。

  • 若需有關移動使用者信箱以減少伺服器負載的詳細資訊，請參閱＜將使用者信箱移至其他伺服器＞。


智慧型郵件篩選器未安裝在執行 Exchange Server 2003 的一或多個伺服器上
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定組織中每個 Exchange Server 物件的 msExchExchangeServer 屬性值。Exchange Server Analyzer 使用此查詢的結果，來判定組織中正在執行 Exchange Server 2003 的伺服器總數。它還會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定組織中的 Exchange Server 2003 伺服器是否全都有安裝 Microsoft Exchange 智慧型郵件篩選器。如果 Exchange Server Analyzer 發現有任何執行 Exchange Server 2003 的伺服器未安裝智慧型郵件篩選器，就會顯示最佳作法訊息。

智慧型郵件篩選器會識別可能是來路不明的商業電子郵件 (UCE) 之郵件。在一般 Exchange Server 2003 拓撲中，智慧型郵件篩選器是安裝在閘道伺服器上，用來篩選內送網際網路電子郵件。如果您使用非 Microsoft 電子郵件系統做為您的網際網路閘道伺服器，則您應該將智慧型郵件篩選器安裝在從閘道伺服器接收內送網際網路電子郵件的 Exchange Bridgehead 伺服器上。

若要安裝智慧型郵件篩選器，請使用具有本機系統管理權限的帳戶，且該帳戶應為已指派 Exchange 系統管理員角色之群組的成員。

若需詳細資訊，請參閱「Exchange 智慧型郵件篩選器」(英文) (http://go.microsoft.com/fwlink/?LinkId=21607)。


可使用 ISA Server 2000 更新
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Microsoft Internet Security and Acceleration (ISA) Server 2000 的簡易郵件傳送通訊協定 (SMTP) 訊息過濾程式功能所使用之 smtpfltr.dll 檔案的版本。如果 Exchange Server Analyzer 發現版本號碼的值比 2004 還舊，則會顯示警告。

此警告指出可使用更新版的 ISA Server 2000。建議安裝 ISA Server 2000 Service Pack 2。如果您要執行 SMTP 訊息過濾程式功能，則升級到 Service Pack 2 就特別重要。舊版的 SMTP 訊息過濾程式會造成瓶頸，其後會降低整個郵件輸送量的效能。

若要更正此警告

  1. 從 Microsoft 下載中心 (英文) (http://go.microsoft.com/fwlink/?linkid=37592) 下載 ISA Server 2000 Service Pack 2。

  2. 檢閱 Service Pack 2 版本資訊 (英文) (http://go.microsoft.com/fwlink/?linkid=37584)。

  3. 使用版本資訊中的指示來安裝 Service Pack 2。

若需有關 ISA Server 下載 (包括 ISA Server 2000 Service Pack 2) 的詳細資訊，請參閱「ISA Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=18919)。


日誌收件者無效
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-03-27

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定日誌收件者物件上的 mailNickname 屬性值是否有效。必須為 mailNickname 屬性設定暱稱才會有效。若指定之日誌收件者物件的 mailNickname 屬性無效，日誌郵件將會進入佇列。此外，無效的 mailNickname 可能也表示已將日誌設定為將日誌郵件複製到已停用信箱功能的收件者物件中。如果 Exchange Server Analyzer 發現日誌收件者物件的 mailNickname 屬性值無效，Exchange Server Analyzer 便會顯示錯誤。

若要在 Exchange Server 2003 中更正此錯誤，請使用 Active Directory 使用者及電腦和 Exchange 系統管理員，視需要完成下列工作：

  • 啟用日誌收件者物件的信箱功能。

  • 指派新的使用者信箱為日誌收件者。

若要在 Exchange Server 2003 中更正此錯誤，請使用 Active Directory 使用者及電腦和 Exchange 系統管理員，視需要完成下列工作

若要為 Exchange Server 2003 啟用日誌收件者物件的信箱功能

  1. 開啟 [Active Directory 使用者及電腦]。

  2. 在主控台樹狀目錄中，展開網域。

  3. 瀏覽到您要修改之收件者的父容器。

  4. 在詳細資料窗格中，以滑鼠右鍵按一下要修改的收件者，然後選取 [Exchange 工作]。

  5. 在 [Exchange 工作精靈] 的 [可用的工作] 對話方塊中，選取 [建立信箱]，再按 [下一步]。

  6. 在 [建立信箱] 對話方塊中，驗證 [別名]、[儲存區]、及 [信箱伺服器] 欄位的資訊，再按 [下一步]。

  7. 按一下 [完成]，關閉 [Exchange 工作精靈]。
若要在 Exchange Server 2003 中指定新的使用者信箱做為日誌收件者

  1. 啟動 [Exchange 系統管理員]。

  2. 依序展開 [伺服器]、<您的 Exchange 伺服器>、<儲存群組>，然後以滑鼠右鍵按一下信箱儲存區，再選取 [內容]。

  3. 按一下 [瀏覽]，在 [封存由此儲存區的信箱所傳送或接收的所有郵件] 文字右方，指定信箱作為日誌信箱。

    附註：
    此信箱儲存區上寄件者的所有日誌郵件都會傳送到您指定的信箱。

若要在 Exchange Server 2007 中更正此錯誤，請使用 Exchange 管理主控台或 Exchange 管理命令介面，視需要完成下列工作：

  • 為日誌收件者物件建立信箱。

  • 指定新的使用者信箱做為日誌收件者。

若要使用 Exchange 管理主控台為 Exchange Server 2007 啟用日誌收件者物件的信箱功能

  1. 在 [Exchange 管理主控台] 中，展開 [收件者組態]、在信箱物件上按一下滑鼠右鍵，然後選取 [新信箱] 以啟動 [新增信箱精靈]。

  2. 在 [簡介] 視窗中，選取 [使用者信箱]，然後按一下 [下一步]。

  3. 在 [使用者類型] 視窗中，選取 [現有的使用者]，然後使用 [瀏覽] 按鈕選取要建立信箱的日誌收件者物件。

  4. 在 [信箱設定] 視窗中，檢查 [別名]、[伺服器]、[儲存群組] 及 [信箱資料庫] 欄位的資訊，然後按一下 [下一步]。

  5. 在 [新增信箱] 視窗中，按一下 [新增]，為日誌收件者物件建立信箱。

  6. 按一下 [完成]，關閉 [新增信箱精靈]
若要使用 Exchange 管理命令介面為 Exchange Server 2007 啟用日誌收件者物件的信箱功能

  1. 請遵循 Exchange Server 2007 產品文件＜啟用信箱＞(英文) (http://go.microsoft.com/fwlink/?LinkID=80827) 中的指導

若要在 Exchange Server 2007 中指定新的使用者信箱做為日誌收件者

  1. 在 [Exchange 管理主控台] 中，依序展開 [伺服器組態]、[<您的 Exchange 伺服器>]、[<儲存群組>]，然後在信箱資料庫按一下滑鼠右鍵，再選取 [內容]。

  2. 在 [一般] 索引標籤中的 [日誌收件者] 下，按一下 [瀏覽] 以指定一個信箱作為日誌信箱。

若需有關部署 Exchange Server 2003 日誌解決方案的作法詳細資訊，請參閱＜Exchange Server 日誌功能＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47581)。

若需有關部署 Exchange Server 2007 日誌解決方案的作法詳細資訊，請參閱＜日誌功能概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80820)


已刪除物件的日誌收件者點
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-02-01

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 msExchMessageJournalRecipient 屬性值是否包含字串 DEL:。此屬性表示已將日誌設定為複製郵件到已刪除的信箱。若要使日誌正常運作，必須有可接收複製郵件的有效日誌收件者信箱。在信箱資料庫上啟用日誌後，會設定 msExchMessageJournalRecipient 屬性。此屬性是信箱資料庫屬性，含有日誌信箱的辨別名稱。

如果刪除了日誌收件者信箱，日誌郵件將開始佇列。如果 Exchange Server Analyzer 發現 msExchMessageJournalRecipient 屬性值包含 DEL: 字串，Exchange Server Analyzer 會顯示一則錯誤。

若要更正此錯誤，請使用 [Exchange 系統管理員] 或 [Exchange 管理主控台]，指定新的信箱做為日誌收件者。

若要在 Exchange Server 2003 中指定新的使用者信箱做為日誌收件者

  1. 啟動 [Exchange 系統管理員]。

  2. 依序展開 [伺服器]、[<您的 Exchange 伺服器>] 及 [<儲存群組>]，然後用滑鼠右鍵按一下信箱儲存區，並選取 [內容]。

  3. 按一下 [瀏覽]，在 [封存由此儲存區的信箱所傳送或接收的所有郵件] 文字右方，指定信箱作為日誌信箱。

    附註：
    此信箱儲存區上寄件者的所有日誌郵件都會傳送到您指定的信箱。
若要在 Exchange Server 2007 中指定新的使用者信箱做為日誌收件者

  1. 在 [Exchange 管理主控台] 中，依序展開 [伺服器組態]、[<您的 Exchange 伺服器>]、[<儲存群組>]，然後在信箱資料庫按一下滑鼠右鍵，再選取 [內容]。

  2. 在 [一般] 索引標籤中的 [日誌收件者] 下，按一下 [瀏覽] 以指定一個信箱作為日誌信箱。

若需有關部署 Exchange Server 2003 日誌解決方案的作法詳細資訊，請參閱《Exchange Server 日誌功能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47581)。

若需有關部署 Exchange Server 2007 日誌解決方案的作法詳細資訊，請參閱＜日誌功能概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80820)。


日誌收件者指向停用的帳戶
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-09

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定日誌收件者物件上的 msExchUserAccountControl 屬性值是否設定為指向停用的使用者帳戶。如果日誌收件者物件的 msExchUserAccountControl 屬性值為 2，表示已將日誌設定為將日誌郵件複製到已停用的使用者帳戶。這個組態會使日誌郵件進入佇列或被傳送到 Badmail 資料夾。如果 Exchange Server Analyzer 發現日誌收件者的 msExchUserAccountControl 屬性值設定為指向停用的日誌收件者使用者帳戶，便會顯示錯誤。

若要在 Exchange Server 2003 中更正此錯誤，請使用 Active Directory 使用者及電腦和 Exchange 系統管理員，視需要完成下列工作：

  • 啟用目前日誌收件者的使用者帳戶。

  • 指派新的使用者信箱為日誌收件者。

若要啟用 Exchange Server 2003 的日誌收件者帳戶

  1. 開啟 [Active Directory 使用者及電腦]。

  2. 在主控台樹狀目錄中，展開網域。

  3. 瀏覽到您要修改之日誌收件者的父容器。

  4. 在詳細資料窗格中，以滑鼠右鍵按一下要修改的收件者，然後選取 [啟用帳戶]。
若要指定新的使用者信箱做為 Exchange Server 2003 的日誌收件者

  1. 啟動 [Exchange 系統管理員]。

  2. 依序展開 [伺服器]、<您的 Exchange 伺服器>、<儲存群組>，然後以滑鼠右鍵按一下信箱儲存區，再選取 [內容]。

  3. 按一下 [瀏覽]，在 [封存由此儲存區的信箱所傳送或接收的所有郵件] 文字的右邊指定一個信箱為日誌信箱。

    附註：
    此信箱儲存區上寄件者的所有日誌郵件都會傳送到您指定的信箱。

若要在 Exchange Server 2007 中更正此錯誤，請使用 Exchange 管理主控台或 Exchange 管理命令介面，視需要完成下列工作：

  • 為日誌收件者物件建立信箱。

  • 指定新的使用者信箱做為日誌收件者。

若要使用 Exchange 管理主控台為 Exchange Server 2007 啟用日誌收件者物件的信箱功能

  1. 在 [Exchange 管理主控台] 中，展開 [收件者組態]、在信箱物件上按一下滑鼠右鍵，然後選取 [新信箱] 以啟動 [新增信箱精靈]。

  2. 在 [簡介] 視窗中，選取 [使用者信箱]，然後按一下 [下一步]。

  3. 在 [使用者類型] 視窗中，選取 [現有的使用者]，然後使用 [瀏覽] 按鈕選取要建立信箱的日誌收件者物件。

  4. 在 [信箱設定] 視窗中，檢查 [別名]、[伺服器]、[儲存群組] 及 [信箱資料庫] 欄位的資訊，然後按一下 [下一步]。

  5. 在 [新增信箱] 視窗中，按一下 [新增]，為日誌收件者物件建立信箱。

  6. 按一下 [完成]，關閉 [新增信箱精靈]
若要使用 Exchange 管理命令介面為 Exchange Server 2007 啟用日誌收件者物件的信箱功能

  1. 請遵循 Exchange Server 2007 產品文件＜啟用信箱＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80827) 中的指導。

若要在 Exchange Server 2007 中指定新的使用者信箱做為日誌收件者

  1. 在 [Exchange 管理主控台] 中，依序展開 [伺服器組態]、[<您的 Exchange 伺服器>]、[<儲存群組>]，然後在信箱資料庫按一下滑鼠右鍵，再選取 [內容]。

  2. 在 [一般] 索引標籤中的 [日誌收件者] 下，按一下 [瀏覽] 以指定一個信箱作為日誌信箱。

若需有關部署 Exchange Server 2003 日誌解決方案的作法詳細資訊，請參閱＜Exchange Server 日誌功能＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47581)。

若需有關部署 Exchange Server 2007 日誌解決方案的作法詳細資訊，請參閱＜日誌功能概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkID=80820)。


本機伺服器的日誌收件者點
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-09

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判斷信箱儲存區日誌收件者物件上的 msExchHomeServerName 屬性值是否符合本機伺服器的 legacyExchangeDN 屬性值。如果這些屬性值不相符，這表示日誌郵件是複製到對其執行作用中日誌之伺服器上的信箱。由於可能產生的日誌流量相當大，建議日誌收件者信箱應置於專用的日誌伺服器上。

如果 Exchange Server Analyzer 發現日誌收件者物件的 msExchHomeServerName 屬性值符合本機伺服器的 legacyExchangeDN 值，就會顯示一則最佳作法訊息。

若需有關部署 Exchange Server 2003 日誌解決方案的作法詳細資訊，請參閱＜Exchange Server 日誌功能＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47581)。

若需有關部署 Exchange Server 2007 日誌解決方案的作法詳細資訊，請參閱＜日誌功能概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80820)。


應該隱藏日誌收件者
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-09

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定日誌收件者物件上的 msExchHideFromAddressLists 屬性值是否設定為 True。若此屬性值不是 True，表示信箱儲存區的日誌收件者未在 Exchange Server 位址清單中隱藏，而且可能變成非日誌相關郵件的收件者。如果 Exchange Server Analyzer 發現日誌收件者物件的 msExchHideFromAddressLists 屬性值未設定為 True，則 Exchange Server Analyzer 會顯示最佳作法訊息。

若要解決 Exchange Server 2003 的這個問題，請使用 [Active Directory 使用者及電腦] 工具，在 Exchange Server 通訊清單中隱藏日誌收件者信箱。

若要解決 Exchange Server 2007 的這個問題，請使用 [Exchange 管理主控台]，在 Exchange Server 通訊清單中隱藏日誌收件者信箱。

若要隱藏 Exchange Server 2003 之 Exchange Server 通訊清單中指定的日誌收件者信箱

  1. 開啟 [Active Directory 使用者及電腦]。

  2. 在主控台樹狀目錄中，展開網域。

  3. 瀏覽到您要修改之收件者的父容器。

  4. 在詳細資料窗格中，連按兩下要修改的收件者。

  5. 在 [Exchange 進階] 索引標籤中，選取 [在 Exchange 通訊清單中隱藏] 核取方塊。

  6. 按一下 [確定]。
若要隱藏 Exchange Server 2007 之 Exchange Server 通訊清單中指定的日誌收件者信箱

  1. 開啟 [Exchange 管理主控台]

  2. 在主控台樹狀目錄中，瀏覽至您要修改之收件者的父容器。

  3. 在詳細資料窗格中，按兩下指定之日誌收件者的信箱物件，以顯示其內容。

  4. 在 [一般] 索引標籤上，選取 [在 Exchange 通訊清單中隱藏] 核取方塊。

  5. 按一下 [確定]。

若需有關部署 Exchange Server 2003 日誌解決方案的作法詳細資訊，請參閱＜Exchange Server 日誌功能＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47581)。

若需有關部署 Exchange Server 2007 日誌解決方案的作法詳細資訊，請參閱＜日誌功能概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80820)。


Junk store threshold not configured
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-07-30

Microsoft Exchange Analyzer 工具會查詢 Exchange 環境中是否有 Exchange Server 2007 Hub Transport server role 或 Mailbox server role。

如果有發現 Exchange Server 2007 Hub Transport server role 或 Mailbox server role，Exchange Analyzer 會執行下列 Exchange 管理命令介面指令程式，查詢 Exchange 組織的 SCLJunkThreshold 參數值：

Get-OrganizationConfig

組織的 SCLJunkThreshold 參數會指定將郵件移到垃圾郵件資料夾的垃圾郵件信賴等級 (SCL)。

如果 Exchange Analyzer 判定組織的 SCLJunkThreshold 參數是設為預設值 8，Exchange Analyzer 就會顯示警告。

此警告表示已設定將郵件移到垃圾郵件資料夾的垃圾郵件信賴等級閾值，因此來自合法使用者的郵件也可能遭到篩選並當作垃圾郵件移到垃圾郵件資料夾。SCLJunkThreshold 參數的建議值是 4。

若要解決此警告，請在 Exchange 管理命令介面中使用 Set-OrganizationConfig 指令程式，將 SCLJunkThreshold 參數的值設為 4。

使用 Set-OrganizationConfig 指令程式將 SCLJunkThreshold 參數值設為 4

  1. 下列程式碼是 Set-OrganizationConfig 命令的範例，它會將 SCLJunkThreshold 參數的值設為 4。

  2. Set-OrganizationConfig -SCLJunkThreshold 4


核心記憶體耗用
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-02-15

Microsoft Exchange Analyzer 工具會查詢 Win32_NTLogEvent Microsoft Windows Management Instrumentation (WMI) 類別，以判定在過去 24 小時內，是否曾針對 SRV (伺服器) 或 NCP 伺服器來源，記錄事件 2000、事件 2019 或事件 2020 錯誤。

  • SRV (伺服器) 事件 ID 2000 表示伺服器呼叫系統服務時，因為一般系統核心記憶體耗盡而意外失敗。

  • SRV 事件 ID 2019 表示系統未分頁集區記憶體耗盡。

  • SRV 事件 ID 2020 表示系統分頁集區記憶體耗盡。

如果 Exchange Analyzer 發現在過去 24 小時內曾記錄其中一個或多個上述事件，則 Exchange Analyzer 會顯示錯誤。

這項警告表示伺服器的核心記憶體已耗盡，而伺服器可能發生效能問題。

Microsoft Windows 核心記憶體是由數個記憶體結構所構成，包括分頁及未分頁集區記憶體與系統分頁表項目。作業系統使用這些記憶體結構 (亦稱為核心記憶體)，以提供應用程式 (如 Exchange) 的環境。

若要解決此問題，請遵循以下所列出的 Exchange Analyzer 相關問題文章的指引：

  • 改善核心記憶體

  • 分頁集區超過警告閾值

  • 未分頁集區超過警告閾值

  • 分頁集區超過錯誤閾值

一般而言，為了維護正常的 Exchange 部署，請確定您定期監控 Exchange Server 的核心記憶體。

詳細資訊

如需 SRV 事件 2000、2019 或 2020 的相關資訊，請參閱「事件及錯誤訊息中心：事件詳細資料」

  • ＜SRV 事件 ID 2000 http://go.microsoft.com/fwlink/?LinkId=83250＞(英文)

  • ＜SRV 事件 ID 2019 http://go.microsoft.com/fwlink/?LinkId=83251＞(英文)

  • ＜SRV 事件 ID 2020 http://go.microsoft.com/fwlink/?LinkId=83252＞(英文)

若需有關 Exchange Server 記憶體最佳化的詳細資訊，請參閱下列微軟知識庫文件：

  • 912376＜如何監控及疑難排解 Exchange Server 2003 或 Exchange 2000 Server 中的分頁集區記憶體使用＞(機器翻譯) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=912376)

  • 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)

  • 894067＜效能工具無法在 Windows Server 2003 中正確顯示可用的系統分頁表項目＞(英文) http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067

  • 311901＜4GT 調整對系統分頁表項目的效果＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 912376＜如何監控及疑難排解 Exchange Server 2003 或 Exchange 2000 Server 中的分頁集區記憶體使用＞(機器翻譯) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=912376)


核心資源耗盡：大量陰影複製服務更新
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-02-13

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows Management Instrumentation (WMI) 類別，以驗證 Vssvc.exe 檔是否存在。。

在登錄中，Exchange Server Analyzer 會查詢以判定大量陰影複製服務 (VSS) 或虛擬磁碟服務 (VDS) 是否正在 Windows 伺服器上執行：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VSS

此外，Exchange Server Analyzer 還會讀取下列登錄值，以判定在 Exchange 伺服器上執行的 Microsoft Windows® 作業系統版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

如果 CurrentVersion 值等於 5.0，表示 Exchange 伺服器是在 Microsoft Windows 2000 Server 上執行。如果 CurrentVersion 值為 5.2，表示 Exchange 伺服器是在 Microsoft Windows Server™ 2003 上。

最後，Exchange Server Analyzer 會查詢 Win32_OperatingSystem Windows Management Instrumentation (WMI) 類別，以判定 ServicePackMajorVersion 機碼值。ServicePackMajorVersion 機碼值表示電腦上所安裝的 Windows Service Pack。

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • Exchange 伺服器已安裝在 Windows Server 2003 Service Pack 1 (SP1) 上。

  • 大量陰影複製服務或虛擬磁碟服務正在 Windows Server 2003 SP1 上執行。

  • VSS 更新並未安裝在這個 Exchange 伺服器組態上。

如果套用 VSS 更新，將解決如核心資源耗盡的問題。

修正錯誤

  • 套用 VSS 更新，可從微軟知識庫文件 - 891957＜已有修正程式可解決 Windows Server 2003 中的各種大量陰影複製服務問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=891957) 下載。

若需使用 VSS 與 Exchange Server 2003 搭配之最佳作法的相關資訊，請參閱＜使用大量陰影複製服務與 Exchange Server 2003 搭配的最佳作法＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56571)。


已安裝 LeakDiag
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 LeakDiag.exe 是否已安裝在電腦上：

HKEY_LOCAL_MACHINE\Software\Microsoft\LeakDiag

如果 Exchange Server Analyzer 發現這個登錄分支存在，就會顯示非預設的組態訊息。

LeakDiag 是一組工具，可幫助開發人員、支援專業人員及資訊科技 (IT) 人員在執行 Microsoft Windows NT® Server 4.0、Windows® 2000 Server、Windows XP 及 Windows Server™ 2003 的電腦上，診斷應用程式或服務的記憶體流失、分散及其他記憶體相關問題。

LeakDiag 工具可以用來找出記憶體流失問題，可以深入到程式碼行。使用 Microsoft 的 Detours 技術，LeakDiag 可以攔截對指定記憶體配置的呼叫，並追蹤各種呼叫堆疊。它會報告已配置但尚未釋出的記憶體。這項資訊可讓您疑難排解記憶體流失的問題，以清楚地查看組成該配置的元件有哪些。利用正確的偵錯符號，即使要求配置的程式碼行也可以看到。

建議您不要在生產環境的 Exchange 伺服器上，執行 LeakDiag。若啟用 LeakDiag，每當 Exchange 伺服器啟動時，它就會追蹤所有處理程序的所有記憶體配置。這樣會消耗大量的處理器和記憶體資源，因此除非您正在如火如荼地進行記憶體相關問題的疑難排解，不然不建議這麼做。若沒有積極地進行記憶體相關問題的疑難排解，就應該關閉 LeakDiag。在生產的 Exchange Server 環境中執行 LeakDiag 時，可能會導致記憶體分散及耗盡，因而導致 Exchange 無法使用。

附註：
您一定要在離峰時段，使用 LeakDiag 進行問題的疑難排解。在繁忙或尖峰時段使用 LeakDiag，可能會導致 Exchange Server 電腦的效能顯著降低。

此訊息的相關資訊

  1. 此訊息僅作為資訊參考用途。如果只是安裝 LeakDiag，但沒有啟用及執行的話，並不會影響 Exchange Server 的效能。LeakDiag 需要將近 4 MB 的硬碟空間 (不包含記錄)。

  2. 若要釋出此硬碟空格間，您可以移除 LeakDiag.exe，請到 [控制台]，按一下 [新增/移除程式]，按一下 [LeakDiag]，再按一下 [移除]。

若需最新版的 LeakDiag，請參閱 Microsoft 公用 FTP 站台 (http://go.microsoft.com/fwlink/?LinkId=41401)。


已啟用 LeakDiag
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判斷是否已在電腦上啟用 LeakDiag.exe：

HKEY_LOCAL_MACHINE\Software\Microsoft\LeakDiag\EnableAutoStart

如果 Exchange Server Analyzer 發現 EnableAutoStart 的值已設為 1，則會顯示一則警告。使用 LeakDiag 使用者介面來設定 EnableAutoStart。預設值為 0。值為 1 表示已啟用 LeakDiag 且為作用中。

LeakDiag 是一組工具，可幫助開發人員、支援專業人員及資訊科技 (IT) 人員在執行 Microsoft Windows NT® Server 4.0、Windows® 2000 Server、Windows XP 及 Windows Server™ 2003 的電腦上，診斷應用程式或服務的記憶體流失、分散及其他記憶體相關問題。

LeakDiag 工具可以用來找出記憶體流失問題，可以深入到程式碼行。使用 Microsoft 提供的 Detours 技術，LeakDiag 會攔截對指定記憶體配置的呼叫，並且會追蹤各種呼叫堆疊。它會報告已配置但尚未釋出的記憶體。這項資訊讓解決記憶體流失問題的人員能夠精確地查看哪些元件組成配置。利用正確的偵錯符號，即使要求配置的程式碼行也可以看到。

建議您不要在生產環境的 Exchange 伺服器上，執行 LeakDiag。若啟用 LeakDiag，每當 Exchange 伺服器啟動時，它就會追蹤所有處理程序的所有記憶體配置。這樣會消耗大量的處理器和記憶體資源，因此除非您正在如火如荼地進行記憶體相關問題的疑難排解，不然不建議這麼做。若沒有積極地進行記憶體相關問題的疑難排解，就應該關閉 LeakDiag。在生產的 Exchange Server 環境中執行 LeakDiag 時，可能會導致記憶體分散及耗盡，因而導致 Exchange 無法使用。

附註：
您一定要在離峰時段，使用 LeakDiag 進行問題的疑難排解。在繁忙或尖峰時段使用 LeakDiag，可能會導致 Exchange Server 電腦的效能顯著降低。

關閉 LeakDiag.exe 的自動啟動功能

  1. 按一下 [開始]，再按一下 [LeakDiag]。

  2. 在 [工具] 功能表上，按一下 [選項]。

  3. 在 [選項] 頁面上，清除 [允許自動啟動] 核取方塊，然後按一下 [確定]。

若需最新版的 LeakDiag，請參閱 Microsoft 公用 FTP 站台 (http://go.microsoft.com/fwlink/?LinkId=41401)。


剩下的記錄檔空間少於 7 天
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-04-13

Microsoft Exchange Server Analyzer 工具會評估還剩下多少時間，Exchange Server 儲存群組上的交易記錄檔磁碟空間將變滿。Exchange Server Analyzer 會檢查磁碟機上交易記錄檔的時間戳記，來評估記錄檔磁碟達到其容量的時間。當 Exchange Server Analyzer 發現不到 7 天記錄檔磁碟就會變滿時，Exchange Server Analyzer 即會顯示錯誤。

存放 Exchange Server 資料庫之記錄檔的磁碟即將用光磁碟空間。

當記錄檔磁碟用光磁碟空間時，即會發生下列問題：

  • 資料庫將不會啟動或將關機。

  • 資料庫將進入不正常關機，並變成不一致。

  • 使用者無法存取郵件及 (或) 公用資料夾。

因為循環記錄已停用，所以記錄檔磁碟可能會變滿。因此交易記錄檔會留在磁碟上，直到執行會使用可察覺到 Exchange Server 之備份軟體的完整或增量線上備份。

在 Exchange 2003 之前的 Exchange Server 版本中，資料庫可能無法在停止之前達到正常關機狀態。兩個保留交易記錄檔 (Res1.log 及 Res2.log) 會在磁碟空間告急時轉換為普通的交易記錄檔。

在 Exchange Server 2003 中，已實作最佳化，以便可以將資料庫正常關機，直到保留記錄檔用光。當資料庫未正常關機時，不要刪除最後幾個與資料庫相關聯的交易記錄檔是非常重要的。這些交易記錄檔仍包含要將資料庫還原為一致狀態時必須套用的資訊。如果刪除這些記錄檔，則必須等到您修復或還原資料庫之後，才能重新啟動資料庫。

如果儲存群組中的所有資料庫都處於正常關機狀態，則移除所有交易記錄檔將不會妨礙資料庫啟動。不過，移除交易記錄檔將使得先前的備份無效。這個移除不表示無法還原先前的備份，但它的確表示您無法將資料庫還原到記錄檔被刪除之前的狀態。

Exchange Server Analyzer 中的記錄檔空間精靈將分析現有的交易記錄檔，並協助您移動資料庫不再需要的交易記錄檔。記錄檔空間精靈也將確定即使所有資料庫都處於正常關機狀態，也不會移除目前的記錄檔。如果未移除目前的記錄檔，先前的備份將持續有效。

若要重新取得記錄檔磁碟空間，您應該移除不必要的記錄檔。下列是建議的動作。

在記錄檔磁碟空間變滿或接近容量時重新取得記錄檔磁碟空間

  • 對資料庫採用可察覺到 Exchange 的線上資料流備份或磁碟區陰影複製服務 (VSS) 備份。若需有關 VSS 備份的詳細資訊，請參閱＜搭配 Exchange Server 2003 使用磁碟區陰影複製服務的最佳作法＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56571)。

    附註：
    清除不必要之記錄檔的偏好方法就是採用線上資料流備份或 VSS 備份。

  • 如果資料庫因為即將用光記錄檔磁碟空間而關機，您可以使用 Exchange Server Analyzer 記錄檔空間管理精靈。您可以使用精靈來移動多餘的記錄檔。或者，您可以手動移動多餘的記錄檔，然後重新裝載資料庫。

    若要手動移除記錄檔，請遵循微軟知識庫文件 - 240145＜如何移除 Exchange Server 交易記錄檔＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240145)。


此 Exchange 伺服器的 LegacyExchangeDN 與父系統管理群組不符
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-09

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務 ，以確認伺服器的 legacyExchangeDN 值，方法是將伺服器在 Active Directory 中的 [Server] 容器裡面之伺服器物件的屬性，與它所在之組織及系統管理群組的實際名稱互相比較，來檢查這些屬性是否正確。如果伺服器的 legacyExchangeDN 值與組織或系統管理群組不同，就會顯示一則錯誤。

Exchange 會使用 legacyExchangeDN 值來識別 Active Directory 內的 Exchange 物件。legacyExchangeDN 值是一個辨別名稱，指出物件隸屬於 Exchange 組織的何處，例如：

/o= organization /ou= administrative group /ou= server

信箱儲存區及公用資料夾儲存區等這類的物件會從伺服器繼承它們的一部分 legacyExchangeDN 值。這表示如果伺服器值有問題，則其他物件可能也有相同問題。

一般而言，若系統管理員直接修改該值，就會有 legacyExchangeDN 方面的問題。您必須使用如 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或任何其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端等工具來更正此值。

注意：
使用 ADSI 編輯器、LDP 工具或其他 LDAP 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或 Exchange Server 2007，或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要更正此錯誤

  1. 使用 [ADSI 編輯器] 或類似的工具，在 Active Directory 中找出系統管理群組物件。

    legacyExchangeDN 屬性可以在以下位置找到：

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Servers,CN=server

  2. 鍵入新的字串值，格式如下：

    /o= organization /ou= administrative group /ou= server

若需有關使用 LDP 工具的詳細資訊，請參閱微軟知識庫文件 - 260745＜XADM:使用 LDP 公用程式修改 Active Directory 物件屬性＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

若需有關使用 ADSI 編輯器的詳細資訊，請參閱主題＜Adsiedit.msc：ADSI 編輯器＞(位在 Windows Server 2003 說明中)。


這個 Exchange 伺服器的 LegacyExchangeDN 無效
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-09

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以驗證 Exchange 伺服器的 legacyExchangeDN 值。若 legacyExchangeDN 值指定的組織或系統管理群組名稱和實際的組織或系統管理群組的名稱不符，或值的一部分完全遺漏時，就會顯示此錯誤。

Exchange 會使用 legacyExchangeDN 值來識別 Active Directory 內的 Exchange 物件。legacyExchangeDN 值是一個辨別名稱，指出物件隸屬於 Exchange 組織的何處，例如：

/o= organization /ou= administrative group

像伺服器及資料夾階層之類的物件，會從系統管理群組繼承其 legacyExchangeDN 值的一部分。這表示如果系統管理群組值有問題，許多其他物件也會繼承相同的問題。

通常當系統管理員嘗試直接修改 legacyExchangeDN 時，就會發生問題。您必須使用如 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或任何其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端等工具來更正此值。

注意：
使用 ADSI 編輯器、LDP 工具或其他 LDAP 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或 Exchange Server 2007，或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要更正此錯誤

  1. 使用 [ADSI 編輯器] 或類似的工具，在 Active Directory 中找出系統管理群組物件。

    legacyExchangeDN 屬性可以在以下位置找到：

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group

  2. 鍵入新的字串值，格式如下：

    /o= organization /ou= administrative group

若需有關使用 LDP 工具的詳細資訊，請參閱微軟知識庫文件 - 260745＜XADM:Using the LDP Utility to Modify Active Directory Object Attributes＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

若需有關使用 ADSI 編輯器的詳細資訊，請參閱主題＜Adsiedit.msc：ADSI 編輯器＞(位在 Windows Server 2003 說明中)。


License Logging 服務設定為自動
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，來判定授權記錄服務 (LicenseService) 的 Started 機碼值。值 False 表示此 Exchange 伺服器未執行 License Logging 服務。值 True 表示 License Logging 服務正在執行。

Exchange Server Analyzer 也會在 root\MicrosoftExchangeV2 命名空間中查詢 Exchange_Server WMI 類別，來判定 IsFrontEndServer 機碼的值。值 False 表示 Exchange Server 電腦不是前端伺服器。值 True 表示 Exchange Server 電腦是前端伺服器。

Exchange Server Analyzer 也會查詢 Win32_OperatingSystem WMI 類別，來判定 OSProductSuite 機碼的值。此機碼傳回的值表示在 Exchange Server 電腦上執行的 Windows 作業系統版本。

此外，Exchange Server Analyzer 還會查詢 Active Directory® 目錄服務，以判定列在每個信箱儲存區之 homeMDBBL 屬性中的項目計數。這個屬性的計數代表信箱儲存區上的信箱數目。

如果 Exchange Server Analyzer 判定已在符合下列所有條件的 Exchange Server 電腦上啟用 License Logging 服務，將會顯示警告：

  • Exchange Server 電腦不是前端伺服器。

  • Exchange Server 電腦可以主控 20 個以上的信箱。

  • Exchange Server 電腦不在 Microsoft Windows Small Business Server 2003 或 Small Business Server 2000 上執行。

License Logging 服務是一項工具，原本是設計來協助客戶管理以「伺服器用戶端存取授權 (CAL)」模式授權的 Microsoft 伺服器產品的授權。

在預設的情況下，Microsoft Windows Server™ 2003 會停用授權記錄服務。因為原始設計上的限制，以及涉及到授權規定及條款，如果和單一伺服器或整個企業中使用的 CAL 總數相比，授權記錄服務無法為購買的 CAL 總數提供準確的數據。License Logging 服務報告的 CAL 可能與「使用者授權合約 (EULA)」及「產品使用權利 (PUR)」的解釋發生衝突。未來的 Windows 作業系統版本中將不再納入 License Logging 服務。

關於 License Logging 服務在 Exchange Server 電腦上的用法，Microsoft 有具體的需求和建議：

  • 在使用 Secure Sockets Layer (SSL) 的前端 Exchange 伺服器上，您必須啟用並啟動 License Logging 服務。如果授權記錄服務未執行，網際網路資訊服務 (IIS) 會將同時驗證的 SSL 連線數目限制為 10 個。

  • 在後端 Exchange 伺服器上，建議停止 License Logging 服務並設定為「停用」。

  • 在叢集 Exchange 伺服器上，建議停止 License Logging 服務並設定為「停用」。

  • 對於在 Microsoft Windows Small Business Server 2003 或 Small Business Server 2000 上執行的 Exchange 伺服器，只有在需要超過 10 個驗證的 SSL 連線時，才需要授權記錄服務。

若要設定授權記錄服務的狀態

  1. 從 [系統管理工具] 功能表中啟動 [服務] 嵌入式管理單元。

  2. 找到並連按兩下 License Logging Service。

  3. 在 [啟動類型] 下拉清單中，選取適當的選項：

    • 將使用 SSL 的前端 Exchange 伺服器上的服務設為 [自動]。

    • 將後端 Exchange 伺服器及叢集 Exchange 伺服器上的服務設為 [停用]。

  4. 如果您要停用 License Logging 服務，也請按 [停止] 以停止該服務。

  5. 按一下 [確定] 以儲存變更，然後關閉 [服務] 嵌入式管理單元。

若需 License Logging 服務的詳細資訊，請參閱下列微軟知識庫文件：

  • 824196＜Windows Server 作業系統的授權記錄服務說明＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=824196)

  • 316631＜如何關閉授權記錄服務＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316631)


記錄檔名不符合記錄檔產生編號
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-07

Microsoft® Exchange Server Analyzer 工具會對照交易記錄檔的檔名，比較來自交易記錄檔標頭的 lGeneration 內部產生編號值，藉此來判斷它們是否相符。

如果來自交易記錄檔的內部產生編號不符合交易記錄檔名稱中的內部產生編號所呈現的值，Exchange Server Analyzer 便會顯示錯誤。

除非記錄檔是目前的記錄檔，否則最新的可用記錄檔必須具有符合其產生編號的檔名。如果記錄檔是目前的記錄檔，則其檔名不應該包含其產生編號，而只應該包含儲存群組的記錄檔字首。例如，先前一系列的交易記錄檔可以命名為 E0154321.LOG、E0154322.LOG、E0154323.LOG，依此類推，目前的記錄檔則命名為 E01.LOG。

您可以使用 Eseutil /ML LOGFILE 命令，顯示記錄檔的內部 lGeneration 值。

若需 Exchange Server 交易記錄的詳細資訊，請參閱《使用 Exchange Server 2003 復原儲存群組》中的＜Exchange Server 2003 的 Exchange 交易記錄＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47589)。


記錄順序簽章不符
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-07

Microsoft® Exchange Server Analyzer 工具會某個記錄檔的 Signature 值與後續記錄檔的 Signature 值比較，以判定它們是否相符。

如果記錄檔的 Signature 值與後續記錄檔的 Signature 值不符，Exchange Server Analyzer 就會顯示錯誤。

Exchange 會使用一系列的記錄檔 (每個檔都正好 5 MB)，而不是將所有記錄資訊都寫入單一大型檔案。當一個記錄檔滿了之後，Exchange 會將其關閉，並以序號來將其重新命名。

為 Exchange 儲存群組初始化新的交易記錄檔順序之後，會將 Signature 寫入第一個記錄檔，並複製到每個後續的記錄檔中。Signature 能夠將特定的記錄檔識別為某個記錄檔順序的成員。

同一個資料夾中通常不會有不同簽章的記錄檔。若發生這種情形，表示已將外部記錄檔複製到儲存群組中，或是沒有先將之前的所有記錄檔刪除，就重設記錄檔。

Eseutil /ML LOGFILE 命令可用來顯示記錄檔的 Signature 值。

若需 Exchange Server 交易記錄的詳細資訊，請參閱《使用 Exchange Server 2003 復原儲存群組》中的＜Exchange Server 2003 的 Exchange 交易記錄＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47589)。


記錄簽章問題
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-07

Microsoft® Exchange Server Analyzer 工具對照儲存群組資料庫檔案中的記錄檔簽章，比較伺服器上目前 Exchange 交易記錄檔之標頭中的簽章。

如果交易記錄檔的簽章不符合任何資料庫檔案中的記錄檔簽章，Exchange Server Analyzer 便會顯示錯誤。

此錯誤指出下列其中一個條件為真：

  • 目前的交易記錄檔不存在。

  • 目前的交易記錄檔不符合儲存群組中的其中一個資料庫。

此行為可能因為下列原因而發生：

  • 已手動刪除儲存群組的交易記錄檔。

  • 另一個儲存群組的資料庫已還原或複製到此儲存群組。

  • 來自不同順序或儲存群組的交易記錄檔已複製到此儲存群組。

此條件是否將阻止資料庫裝載，視資料庫檔案處於正常關機或不正常關機狀態而定。

附註：
資料庫可能處於正常關機狀態，但是仍無法裝載，因為無法裝載儲存群組中的其他資料庫。請使用 Exchange Server Disaster Recovery Analyzer，診斷並建議您在這些情況中可以如何裝載資料庫。

當 Exchange 資料庫正確地關機時，所有未完成的資料都會寫入資料庫檔案。在一般關機之後，資料庫檔案集 (.edb 及 .stm 副檔名) 會被視為一致。然後 Exchange 會從其記錄檔串流中分離資料庫檔案集。這表示資料庫檔案現在是自我包含，亦即，它們全都是最新的。不需要先前的交易記錄檔，即可啟動資料庫檔案。

處於正常關機狀態中的資料庫已從其記錄檔中分離，而且可以連接至不同的記錄檔串流。因此，記錄檔與資料庫之間的不符不一定是問題。

處於不正常關機狀態中的資料庫已不正確地從其記錄檔中分離。這些資料庫必須利用其連接的記錄檔來進行復原。如果找不到連接的記錄檔，將無法裝載資料庫。您必須從備份進行還原或修復資料庫，然後才能裝載該資料庫。

如果輸入 Eseutil /mh 命令並檢查檔案標頭，則您可以識別資料庫是否已正常關機。在 Microsoft Exchange 2000 Service Pack 1 和更新版本中，標題中有一行顯示「狀態：正常關機」或「狀態：不正常關機」。在舊版的 Exchange 中，相同的狀態報告為「狀態：一致」或「狀態：不一致」。

若需 Exchange Server 交易記錄的詳細資訊，請參閱《使用 Exchange Server 2003 復原儲存群組》中的＜Exchange Server 2003 的 Exchange 交易記錄＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47589)。


Log Record Bytes/sec 超出錯誤閾值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-23

Microsoft® Exchange Server Analyzer 工具會使用 Exchange Server User Monitor (ExMon) 工具，來判斷使用者 MAPI 作業所花的時間，對於狀況良好的 Exchange 伺服器而言是否合理。

Exchange Server Analyzer 在分析過程中會檢閱交易記錄使用情況，判斷是否有任何使用者 MAPI 作業每分鐘寫入 5MB 以上的資料至 Exchange 交易記錄檔中。

如果 MAPI 作業寫入太多資料到交易記錄檔中，則可能會造成嚴重資源瓶頸與錯誤 (如超過檢查點深度、磁碟 I/O 瓶頸以及磁碟空間不足)。

如果 Exchange Server Analyzer 判斷一或多個使用者 MAPI 作業每分鐘會將 5MB 以上的資料寫入至 Exchange 交易記錄，則會顯示錯誤。

每分鐘寫入 5MB 以上之資料至 Exchange 交易記錄的 MAPI 作業不一定有問題。對於某些動作而言，以高速率進行寫入是正常的行為，如信箱移動或對許多信箱執行會產生大量交易記錄檔資料的其他大量作業。在此情況下，高速率只會維持數分鐘。

如果伺服器發生其他問題 (如高 RPC 延遲)，則請與產生交易記錄檔資料的使用者共同討論，以判斷哪個使用者活動造成高記錄寫入速率。

詳細資訊

若需詳細資訊，請參閱下列 Exchange Server 資源：

  • ＜Exchange Server 2003 效能及延展性手冊＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)

  • ＜Microsoft Exchange Server 2003 效能疑難排解＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • ＜Exchange Server 2003 效能：10 件要考慮的事情＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56460)

  • 微軟知識庫文件 - 905803＜Outlook 使用者在執行 Exchange Server 2003 或 Exchange 2000 Server 的伺服器上使用包含許多項目的資料夾時遇到效能不佳的情況＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


無法取得 LogicalDisk 效能監視器物件
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 LogicalDisk 效能物件的 Avg. Disk sec/Read 效能計數器的資料，以分析效能資料。如果計數器未傳回有效的資料，Exchange Server Analyzer 便會顯示基準線訊息。

如果效能資料收集引擎未傳回有效的資料，則發生了下列任意狀況組合：

  • LogicalDisk 效能物件已停用。在預設的情況下，Microsoft Windows Server™ 2003 中會啟用 LogicalDisk 效能物件。不過，在 Microsoft Windows® 2000 Server 中，預設不會啟用 LogicalDisk。

  • LogicalDisk 效能監視器物件已遺失或已損毀。

  • Exchange Server Analyzer 沒有適當的權限可存取效能物件。

如果某個可擴充的計數器損毀了登錄，或使用 Microsoft Windows Management Instrumentation (WMI) 的程式修改了登錄，就會發生前兩個狀況。

下列程序解說如何修復前兩個狀況。在執行此程序前，請先確認 Exchange Server Analyzer 具有適當的權限。若需有關執行 Exchange Server Analyzer 所需權限的詳細資訊，請參閱包含在 Exchange Server Analyzer 中的說明文件。若需取得 [說明]，請開啟 Exchange Server Analyzer 並按 F1 鍵。

若要更正此錯誤

  1. 確認 LogicalDisk 效能物件已啟用：

    1. 下載並安裝 Extensible Performance Counter List 工具 (Exctrlst.exe)。您可以在下列位置下載 Exctrlst.exe：「Exctrlst.exe：Extensible Performance Counter List」(英文) (http://go.microsoft.com/fwlink/?LinkId=34436)。

    2. 開啟 Exctrlst.exe，並依序按一下 [Sort Order] 及 [Service]。

    3. 找出要讓效能物件報告的服務，並確認已選取 [Performance Counters Enabled] 核取方塊。

      如果未選取 [Performance Counters Enabled] 核取方塊，請選取此核取方塊，然後重新啟動與效能計數器相關的服務，確認效能計數器可運作。如果效能計數器未運作，或已選取 [Performance Counters Enabled] 核取方塊，請繼續步驟 2。

  2. 依照微軟知識庫文件 - 300956＜如何手動重建效能計數器程式庫值＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) 中的指示，重建遺失或損毀的效能計數器。

  3. 如果遵循此知識庫文件的指示並不能解決問題，則必須以 [修復] 模式重新安裝 Windows 作業系統，並套用最新的 Windows Service Pack。


發現長時間延遲的 MAPI 作業
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-11-22

Microsoft® Exchange Server Analyzer 工具會使用 Exchange Server User Monitor (ExMon) 工具來收集資料 (取樣間隔時間為五分鐘)，以判斷使用者 MAPI 所花的時間，是否比在狀況良好的 Exchange 伺服器執行的合理預期時間更長。

如果 Exchange Server Analyzer 判斷使用者在收集資料期間有一或多個 MAPI 作業超過 30 秒，就會顯示錯誤，並在觸發該錯誤的使用者動作上執行額外的分析。

花費時間超過 30 秒的 MAPI 作業不一定有問題。儲存大量郵件資料或檔案附件，會讓 MAPI 作業的執行時間比一般還要長。

如果一或多位使用者經常發生延遲，或發生嚴重影響訊息傳遞的延遲，就必須更深入調查這些 MAPI 作業延遲，確定它們並不是資源瓶頸或巢狀相依等較嚴重的延遲問題徵兆。

若要更正這個錯誤：

  • 考慮使用 ExMon 工具擷取更多資料樣本，供 Exchange Server Analyzer 進行檢閱。因為 ExMon 會產生大量資料，所以建議將資料收集取樣時間保持在 30 分鐘以內。

  • 檢閱任何相關的延遲錯誤與隨附的文件，瞭解特定作業與解決問題的步驟。如果 Exchange Server Analyzer 未報告任何相關的延遲錯誤，則使用者動作的額外分析就會顯示沒有任何問題。


長時間執行的 MAPI 大量作業
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-23

Microsoft® Exchange Server Analyzer 工具會使用 Exchange Server User Monitor (ExMon) 工具來判斷使用者 MAPI 作業所花的時間，是否比在狀況良好的 Exchange 伺服器執行的合理預期時間更長。

Exchange Server Analyzer 在分析過程中，會檢閱 ExMon 資料中超過 30 秒才完成的使用者 MAPI 大量作業。

MAPI 大量作業是在多個物件上執行的作業，通常較耗資源 (需要許多 I/O)。

如果 Exchange Server Analyzer 判定使用者已經有一或多個 MAPI 大量作業花費的時間超過 30 秒，就會顯示錯誤。

花費時間超過 30 秒的 MAPI 大量作業不一定有問題。如果使用者一次對上千個訊息執行動作 (複製、刪除、設定屬性旗標等)，可能會使 MAPI 大量作業花費比平時更長的時間。

如果一或多位使用者經常發生延遲，或發生嚴重影響訊息傳遞的延遲，就必須更深入調查這些 MAPI 大量作業延遲，確定它們並不是資源瓶頸或巢狀相依等較嚴重的延遲問題徵兆。

若要更正這個錯誤：

  • 考慮使用 ExMon 工具擷取更多資料樣本，供 Exchange Server Analyzer 進行檢閱。因為 Exchange 會產生大量資料，所以建議將資料收集取樣時間保持在 30 分鐘以內。

詳細資訊

若需詳細資訊，請參閱下列 Exchange Server 資源：

  • ＜Exchange Server 2003 效能及延展性手冊＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)

  • ＜Microsoft Exchange Server 2003 效能疑難排解＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • ＜Exchange Server 2003 效能：10 件要考慮的事情＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56460)

  • 微軟知識庫文件 - 905803＜Outlook 使用者在執行 Exchange Server 2003 或 Exchange 2000 Server 的伺服器上使用包含許多項目的資料夾時遇到效能不佳的情況＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


長時間執行的 MAPI 'FindRow' 作業
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-11-22

Microsoft® Exchange Server Analyzer 工具會使用 Exchange Server User Monitor (ExMon) 工具來判斷使用者 MAPI 作業所花的時間，是否比在狀況良好的 Exchange 伺服器執行的合理預期時間更長。

Exchange Server Analyzer 在分析過程中，會檢閱 ExMon 資料中超過 30 秒才完成的使用者 MAPI FindRow 作業。

當每個資料夾的檢視數目增加時，MAPI 作業的負荷也會增加許多。用戶端應用程式使用 MAPI 作業 SeekRow 或 FindRow 在檢視的不同列間移動指標。SeekRow 指定指標移動的列數，並不會耗費太多 CPU 時間。FindRow 相當耗資源，因為它會將指標移至符合限制準則之非具體化 (不會被快取) 之檢視中的第一個項目，然後在用戶端應用程式完成動作後捨棄檢視。FindRow 的最終 CPU 成本取決於限制的複雜度及儲存區找到第一個符合準則的項目前必須檢閱的列數，因此與資料夾中的項目數無太大關係。

FindRow 所耗成本高，因此可執行快取模式，以降低伺服器的成本。請注意，有時此作業所耗用的高 CPU 百分比是共用行事曆所造成，而在此情況下，快取模式並沒有任何助益。FindRow 作業所耗用的高百分比 CPU 時間表示建立了大量的檢視、耗資源的檢視或大量資料夾項目。

如果 Exchange Server Analyzer 判定使用者發出的 MAPI FindRow 作業的執行時間超過 30 秒，就會顯示錯誤。

花費時間超過 30 秒的 MAPI FindRow 作業不一定有問題。如果識別的使用者經常遇到延遲的問題，或者延遲已嚴重影響他們的郵件傳送，您應該瞭解這些問題的原因。請與遇到嚴重延遲問題的使用者共同討論，以判斷是否有下列情形：

  • 資料夾中的項目數是否很多。

  • 使用者執行哪些應用程式。

若要更正此問題：

  • 對於資料夾中包含許多項目的使用者，建議他們減少每個資料夾中的項目數。建議您將 [收件匣]、[行事曆]、[寄件備份]、[連絡人] 及 [刪除的郵件] 資料夾中的項目數保持在 5,000 個以下。

  • 將作業最耗資源的用戶端電腦 (特別是 Restrict、SetColumns 或 FindRow 作業延遲時間較長的用戶端電腦) 設定成使用快取 Exchange 模式。快取 Exchange 模式會將伺服器與大部分的額外 RPC 流量隔離開來。

  • 請嘗試關閉所有應用程式，然後再逐一開啟應用程式，以找出可能造成問題的應用程式。如果這些應用程式不是業務用途所必需，或應用程式已發行 Hotfix，請永久關閉應用程式或更新應用程式，將負載降低至適當水準。

附註：
某些應用程式即使未發出大量 MAPI 作業，仍可能大幅增加伺服器負載。這是因為某些作業比其他作業更耗資源。耗資源的作業數目只要增加一些，可能就會明顯影響伺服器效能。在 ExMon 中，會將這些使用者報告為具有高度 CPU 影響 (即使他們並未發出大量 MAPI 作業)。

同時請注意，當發生資源瓶頸 (一般是磁碟或 CPU 瓶頸) 時，FindRow 作業的延遲也會增加。

詳細資訊

若需詳細資訊，請參閱下列 Exchange Server 資源：

  • ＜Exchange Server 2003 效能及延展性手冊＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)

  • ＜Microsoft Exchange Server 效能疑難排解＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • ＜Exchange Server 2003 效能：10 件要考慮的事情＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56460)

  • 微軟知識庫文件 - 905803＜Outlook 使用者在執行 Exchange Server 2003 或 Exchange 2000 Server 的伺服器上使用包含許多項目的資料夾時遇到效能不佳的情況＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


長時間執行的 MAPI 線上作業
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-23

Microsoft® Exchange Server Analyzer 工具會使用 Exchange Server User Monitor (ExMon) 工具來判斷使用者 MAPI 線上作業所花的時間，是否比在狀況良好的 Exchange 伺服器執行的合理預期時間更長。

QueryRows 作業是一種 MAPI 線上作業範例。

QueryRows 作業是用來傳回目前檢視的資料列。QueryRows 使用表格中的資料來滿足使用者要求。SetColumns 作業則決定 QueryRows 可用的資料。QueryRows 的成本會依據要求的內容大小、要求的內容數及要求的資料列數而增加。如果要求的資料欄及列太多，QueryRows 也會很耗資源。

當核心 Exchange Server 2003 資料夾中的項目數增加時，Outlook 使用者用來執行部分作業的實體磁碟成本也會增加。第一次依大小排序收件匣時會消耗很多資源 (需要大量磁碟 I/O)。後續依大小排序收件匣所消耗的資源就會大幅減少。

如果 Exchange Server Analyzer 判斷使用者在收集資料期間有一或多個 MAPI 線上作業超過 30 秒，就會顯示錯誤。

MAPI 線上作業的長時間延遲可能表示伺服器資源瓶頸。對 QueryRows 作業而言，也可表示資料夾的項目數過多，或在內部表格設定太多內容。

如果高度延遲線上作業同時處理大量資料，則高度延遲可能不是伺服器效能的問題。例如，當使用者在單一作業中選取資料夾中的所有項目，並將它們標示為已讀取。請與遇到嚴重延遲問題的使用者共同討論，以判斷是否有下列情形：

  • 資料夾中的項目數是否很多。

  • 使用者執行哪些應用程式。

若要更正此問題：

  • 對於資料夾中包含許多項目的使用者，建議他們減少每個資料夾中的項目數。建議您將 [收件匣]、[行事曆]、[寄件備份]、[連絡人] 及 [刪除的郵件] 資料夾中的項目數保持在 5,000 個以下。

  • 請嘗試關閉所有應用程式，然後再逐一開啟應用程式，以找出可能造成問題的應用程式。如果這些應用程式不是業務用途所必需，或應用程式已發行 Hotfix，請永久關閉應用程式或更新應用程式，將負載降低至適當水準。

附註：
某些應用程式即使未發出大量 MAPI 線上作業，仍可能大幅增加伺服器負載。這是因為某些作業比其他作業更耗資源。耗資源的作業數目只要增加一些，可能就會明顯影響伺服器效能。在 ExMon 中，會將這些使用者報告為具有相對較高的 CPU 影響 (即使他們並未發出大量 MAPI 作業)。

同時請注意，當發生資源瓶頸 (一般是磁碟或 CPU 瓶頸) 時，MAPI 線上作業的延遲也會增加。判斷伺服器資源瓶頸的來源，並增加伺服器資源處理能力，或將使用者移至負載較低的伺服器。

詳細資訊

若需詳細資訊，請參閱下列 Exchange Server 資源：

  • ＜Exchange Server 2003 效能及延展性手冊＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)

  • ＜Microsoft Exchange Server 2003 效能疑難排解＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • ＜Exchange Server 2003 效能：10 件要考慮的事情＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56460)

  • 微軟知識庫文件 - 905803＜Outlook 使用者在執行 Exchange Server 2003 或 Exchange 2000 Server 的伺服器上使用包含許多項目的資料夾時遇到效能不佳的情況＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


長時間執行的 MAPI 作業
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-11-22

Microsoft® Exchange Server Analyzer 工具會使用 Exchange Server User Monitor (ExMon) 工具來判斷使用者 MAPI 作業所花的時間，是否比在狀況良好的 Exchange 伺服器執行的合理預期時間更長。

如果 Exchange Server Analyzer 判定使用者已經有一或多個 MAPI 作業花費的時間超過 30 秒，就會顯示錯誤。

當每個資料夾的檢視數目增加時，MAPI 作業的負荷也會增加許多。此主題討論 SeekRow 和 FindRow 這兩個最常見的作業。由 Exchange Server Analyzer 識別為「長時間執行」的其他 MAPI 作業，通常都能以解決 SeekRow 和 FindRow MAPI 作業問題的相同動作來解決。

用戶端應用程式使用 MAPI 作業 SeekRow 或 FindRow 在檢視的不同列間移動指標。SeekRow 指定指標移動的列數，並不會耗費太多 CPU 時間。FindRow 相當耗資源，因為它會將指標移至符合限制準則之非具體化 (不會被快取) 之檢視中的第一個項目，然後在用戶端應用程式完成動作後捨棄檢視。FindRow 的耗費的 CPU 時間取決於限制的複雜度、對每封郵件存取的郵件內容數，以及儲存區找到第一個符合準則的項目前必須檢閱的列數，因此與資料夾中的項目數無太大關係。

花費時間超過 30 秒的 MAPI 作業不一定有問題。如果識別的使用者經常遇到延遲的問題，或者延遲已嚴重影響他們的郵件傳送，您應該瞭解這些問題的原因。請與遇到嚴重延遲問題的使用者共同討論，以判斷是否有下列情形：

  • 資料夾中的項目數是否很多。

  • 使用者執行哪些應用程式。

若要更正此問題：

  • 對於資料夾中包含許多項目的使用者，建議他們減少每個資料夾中的項目數。建議您將 [收件匣]、[行事曆]、[寄件備份]、[連絡人] 及 [刪除的郵件] 資料夾中的項目數保持在 5,000 個以下

  • 將作業最耗資源的用戶端電腦 (特別是 Restrict、SetColumns 或 FindRow 作業延遲時間較長的用戶端電腦) 設定成使用快取 Exchange 模式。快取 Exchange 模式會將伺服器與大部分的額外 RPC 流量隔離開來。

  • 請嘗試關閉所有應用程式，然後再逐一開啟應用程式，以找出可能造成問題的應用程式。如果這些應用程式不是業務用途所必需，或應用程式已發行 Hotfix，請永久關閉應用程式或更新應用程式，將負載降低至適當水準。

附註：
某些應用程式即使未發出大量 MAPI 作業，仍可能大幅增加伺服器負載。這是因為某些作業比其他作業更耗資源。耗資源的作業數目只要增加一些，可能就會明顯影響伺服器效能。在 ExMon 中，會將這些使用者報告為具有高度 CPU 影響 (即使他們並未發出大量 MAPI 作業)。

同時請注意，當發生資源瓶頸 (一般是磁碟或 CPU 瓶頸) 時，MAPI 作業的延遲也會增加。判斷伺服器資源瓶頸的來源，並增加伺服器資源處理能力，或將使用者移至負載較低的伺服器。

詳細資訊

若需詳細資訊，請參閱下列 Exchange Server 資源：

  • ＜Exchange Server 2003 效能及延展性手冊＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)

  • ＜Microsoft Exchange Server 效能疑難排解＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • ＜Exchange Server 2003 效能：10 件要考慮的事情＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56460)

  • 微軟知識庫文件 - 905803＜Outlook 使用者在執行 Exchange Server 2003 或 Exchange 2000 Server 的伺服器上使用包含許多項目的資料夾時遇到效能不佳的情況＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


長時間執行的 MAPI 'SaveChangesMessage' 作業
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-11-22

Microsoft® Exchange Server Analyzer 工具會使用 Exchange Server User Monitor (ExMon) 工具來判斷使用者 MAPI 作業所花的時間，是否比在狀況良好的 Exchange 伺服器執行的合理預期時間更長。

Exchange Server Analyzer 在分析過程中，會檢閱 ExMon 資料中超過 30 秒才完成的使用者 MAPI SaveChangesMessage 作業。

應用程式將郵件內容和/或屬性儲存至伺服器時，會呼叫 MAPI SaveChangesMessage 作業。完成作業所需的時間則視所寫入的資料、寫入至資料庫與交易記錄檔磁碟的速度，以及是否有資源瓶頸而定。

如果 Exchange Server Analyzer 判定使用者發出的 MAPI SaveChangesMessage 作業的執行時間超過 30 秒，就會顯示錯誤。

花費時間超過 30 秒的 MAPI SaveChangesMessage 作業不一定有問題。儲存大量郵件資料或檔案附件，會讓 MAPI SaveChangesMessage 作業的執行時間比一般還要長。如果一或多位使用者經常發生延遲，或發生嚴重影響訊息傳遞的延遲，則最可能的原因是磁碟瓶頸。

詳細資訊

  • 若需有關磁碟瓶頸的詳細資訊，請參閱＜偵測到磁碟瓶頸＞

  • 若需有關 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需有關如何疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 2003 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 如需有關設計存放結構的最佳作法，請參閱《多重結構通用的最佳作法》(英文) (http://go.microsoft.com/fwlink/?LinkId=72988)。

  • 若需如何移動使用者信箱以減少伺服器負載的詳細資訊，請參閱＜將使用者信箱移至其他伺服器＞。

  • 若需有關磁碟大小、延遲及 I/O 速率的詳細資訊，請參閱下列 Microsoft Exchange 團隊部落格網站上的部落格：

    • ＜磁碟大小的一些基本概念＞(英文) (http://go.microsoft.com/fwlink/?linkid=39538)

    • ＜一些有關磁碟 IO 及計算的其他想法...＞(英文)(http://go.microsoft.com/fwlink/?linkid=39539)

    • 《如何計算磁碟 I/O 需求》(英文) (http://go.microsoft.com/fwlink/?linkid=69747)


長時間執行的 MAPI 'SetColumns' 作業
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-23

Microsoft® Exchange Server Analyzer 工具會使用 Exchange Server User Monitor (ExMon) 工具來判斷使用者 MAPI 作業所花的時間，是否比在狀況良好的伺服器 (執行 Exchange Server) 執行的合理預期時間更長。

Exchange Server Analyzer 在分析過程中，會檢閱 ExMon 資料中超過 30 秒才完成的使用者 MAPI SetColumns 作業。

基本檢視是透過使用 MAPI 呼叫 SetColumns 所建立。SetColumns 的呼叫會定義將成為新檢視表格中之欄位的內容。

第一次在檢視中要求內容時，伺服器必須執行額外的工作才能產生檢視。在檢視中要求該內容之後，之後的檢視一律都會有該內容。這表示第一次要求新內容時，呼叫 SetColumns 所需的時間會比較久。所需的時間會與新內容數及資料夾中的項目數成正比。例如，使用者在移動信箱後第一次檢視收件匣時，伺服器會需要較久的時間才能產生檢視。原因是移動信箱時並未移動檢視。而是會重新建立檢視。

將內容新增至檢視通常十分耗資源。新增內容的成本會與資料夾中的項目數及所新增的內容數成正比。在正常使用情況下，Microsoft Office® Outlook® 並不會將太多內容新增至郵件資料夾表格中，但是如果是利用手動方式則可以新增較多內容。 這通常不會發生問題。然而，如果應用程式定期新增欄位、新增許多欄位，或任何用戶端為許多項目新增多個欄位，則可能會發生延遲。郵件資料夾表格中的欄位愈多，該資料夾中項目之其他所有動作的負荷也會愈大。一旦新增欄位，就無法將它移除。郵件資料夾表格中的每個內容都會增加在該資料夾中插入項目的負荷。

如果 Exchange Server Analyzer 判定使用者發出的 MAPI SetColumns 作業的執行時間超過 30 秒，就會顯示錯誤。

使用者在信箱移至新資料庫或新伺服器之後第一次存取信箱時，伺服器必須建立新的檢視。在此情況下，會發生長時間執行的 SetColumns 與 Restrict 呼叫。在您移動信箱後的數天內，都可以放心略過這些錯誤。

部分應用程式會建立新的檢視，使得內容提升為內部儲存區資料結構。當伺服器存取該使用者的資料時，這會對伺服器有較長期的效能影響。如果識別的使用者經常遇到延遲的問題，或者延遲已嚴重影響他們的郵件傳送，您應該瞭解這些問題的原因。請與遇到嚴重延遲問題的使用者共同討論，以判斷是否有下列情形：

  • 資料夾中的項目數是否很多。

  • 使用者執行哪些應用程式。

若要解決此問題，請遵循下列步驟：

  • 對於資料夾中包含許多項目的使用者，建議他們減少每個資料夾中的項目數。建議您將 [收件匣]、[行事曆]、[寄件備份]、[連絡人] 及 [刪除的郵件] 資料夾中的項目數保持在 5,000 個以下。

  • 將作業最耗資源的用戶端電腦設定成使用快取 Exchange 模式。請特別注意 Restrict、SetColumns 或 FindRow 作業具有較長延遲的用戶端電腦。快取 Exchange 模式會將伺服器與大部分的額外 RPC 流量隔離開來。

  • 嘗試關閉所有應用程式。然後再逐一開啟這些應用程式，以找出可能造成問題的應用程式。符合下列其中一種情況時，請永久關閉有問題的應用程式或更新應用程式，將負載降低至適當水準：

    • 應用程式不是業務用途所必需。

    • 應用程式已發行更新。

附註：
某些應用程式即使未發出大量 MAPI 作業，仍可能大幅增加伺服器負載。這是因為某些作業比其他作業更耗資源。耗資源的作業數目只要增加一些，可能就會明顯影響伺服器效能。在 ExMon 中，會將使用者報告為具有高度 CPU 影響 (即使他們並未發出大量 MAPI 作業)。

同時請注意，當發生資源瓶頸 (一般是磁碟或 CPU 瓶頸) 時，SetColumns 作業的延遲也會增加。

詳細資訊

若需詳細資訊，請參閱下列 Exchange Server 資源：

  • ＜Exchange Server 2003 效能及延展性手冊＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)

  • ＜Microsoft Exchange Server 效能疑難排解＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • ＜Exchange Server 2003 效能：10 件要考慮的事情＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56460)

  • 微軟知識庫文件 - 905803＜Outlook 使用者在執行 Exchange Server 2003 或 Exchange 2000 Server 的伺服器上使用包含許多項目的資料夾時遇到效能不佳的情況＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


長時間執行的 MAPI 同步作業
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-23

Microsoft® Exchange Server Analyzer 工具會使用 Exchange Server User Monitor (ExMon) 工具來判斷使用者 MAPI 作業所花的時間，是否比在狀況良好的 Exchange 伺服器執行的合理預期時間更長。

Exchange Server Analyzer 在分析過程中，會檢閱 ExMon 資料中超過 30 秒才完成的使用者 MAPI 同步作業。

執行 MAPI 同步作業的目的，是要讓 Microsoft Office® Outlook® 離線資料夾檔案 (.ost) 或使用者信箱的本機複本與伺服器上的使用者信箱資料同步。

花費時間超過 30 秒的 MAPI 同步作業不一定有問題。先在 Outlook 2003 中啟用快取 Exchange 模式之後，預設會將 Exchange Server 上儲存的所有電子郵件以及全域通訊清單之完整複本的所有電子郵件下載至使用者電腦。

首次與 Exchange Server 同步期間，Outlook 2003 使用者可能會遇到回應延遲的問題。

如果一或多位使用者經常發生延遲，或發生嚴重影響訊息傳遞的延遲 (由於首次執行快取模式同步)，就必須更深入調查這些 MAPI 同步作業延遲，確定它們並不是資源瓶頸等較嚴重的延遲問題徵兆。

當發生資源瓶頸 (一般是磁碟或 CPU 瓶頸) 時，MAPI 同步作業的延遲也會增加。請找出伺服器資源瓶頸的來源，並增加伺服器資源處理能力，或將使用者移至負載較低的伺服器。

詳細資訊

若需詳細資訊，請參閱下列 Exchange Server 資源：

  • ＜Exchange Server 2003 效能及延展性手冊＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)

  • ＜Microsoft Exchange Server 2003 效能疑難排解＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • ＜Exchange Server 2003 效能：10 件要考慮的事情＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56460)

  • 微軟知識庫文件 - 905803＜Outlook 使用者在執行 Exchange Server 2003 或 Exchange 2000 Server 的伺服器上使用包含許多項目的資料夾時遇到效能不佳的情況＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


長時間執行的 MAPI 'TaskQ' 作業
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-02-20

Microsoft Exchange Analyzer 工具會使用 Exchange Server 使用者監視器 (ExMon) 工具來判斷使用者 MAPI 作業所花的時間，是否比在狀況良好的 Exchange 伺服器執行的合理預期時間更長。

Exchange Analyzer 在分析過程中，會檢閱 ExMon 資料中超過 30 秒才完成的使用者 MAPI TaskQ 作業。

TaskQ 作業是在 RPC 呼叫內容外執行的非同步工作。TaskQ 和 TaskQ User Unknown 作業是在 Exchange 要求時執行的工作，並且包含儲存區維護。TaskQ User Known 作業是由直接使用者要求所啟動的非同步工作，並且包含搜尋資料夾擴展、排序和針對多封郵件的大量作業，例如移動、複製、刪除和將郵件標示為已讀取。

如果 Exchange Analyzer 判定使用者發出的 MAPI TaskQ 作業花費了超過 30 秒才完成，便會顯示警告。

這並不一定表示有效能問題，因為 TaskQ 作業通常是要長時間才能完成的作業。

若要解決這個問題，請執行下列動作：

  • 考慮使用 ExMon 工具擷取更多資料樣本，供 Exchange Server Analyzer 進行檢閱。因為 Exchange 會產生大量資料，所以建議將資料收集取樣時間保持在 30 分鐘以內。

詳細資訊

若需詳細資訊，請參閱下列 Exchange Server 資源：

  • ＜Exchange Server 2003 效能及延展性手冊＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)

  • ＜Microsoft Exchange Server 2003 效能疑難排解＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • ＜Exchange Server 2003 效能：10 件要考慮的事情＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56460)


因 MAPI 'Restrict' 作業而長時間執行的作業
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-23

Microsoft® Exchange Server Analyzer 工具會使用 Exchange Server User Monitor (ExMon) 工具來判斷使用者 MAPI 作業所花的時間，是否比在狀況良好的伺服器 (執行 Exchange Server) 執行的合理預期時間更長。

Exchange Server Analyzer 在分析過程中，會檢閱 ExMon 資料中超過 30 秒才完成的使用者 MAPI Restrict 作業。

用戶端應用程式會使用 MAPI Restrict 作業來選取符合特定準則的項目。伺服器會建立實際上是具有關聯準則 (稱為限制) 之表格的檢視。如果已有符合限制的檢視存在，伺服器會使用現有的檢視以滿足使用者要求。伺服器使用此檢視所耗用的資源，會少於伺服器建立新檢視所耗用的資源。儲存區預設只會為每個資料夾快取 11 個檢視。如果伺服器被要求建立第 12 個檢視，則伺服器會刪除最早快取的檢視，再建立新檢視。檢視會增加項目上所有動作的負荷。

如果 Exchange Server Analyzer 判定使用者發出的 MAPI Restrict 作業的執行時間超過 30 秒，就會顯示錯誤。

花費時間超過 30 秒的 MAPI Restrict 作業不一定有問題。然而，如果使用者經常遇到嚴重影響郵件使用體驗的延遲，則這些延遲可能表示使用者應用程式正在建立新檢視。

若要更正這個錯誤，請與遇到嚴重延遲問題的使用者共同討論，以判斷是否有下列情形：

  • 資料夾中的項目數是否很多。

  • 使用者執行哪些應用程式。

若要解決此問題，請遵循下列步驟：

  • 對於資料夾中包含許多項目的使用者，建議他們減少每個資料夾中的項目數。建議您將 [收件匣]、[行事曆]、[寄件備份]、[連絡人] 及 [刪除的郵件] 資料夾中的項目數保持在 5,000 個以下。

  • 將作業最耗資源的用戶端電腦設定成使用快取 Exchange 模式。請特別注意 Restrict、SetColumns 或 FindRow 作業具有較長延遲的用戶端電腦。快取 Exchange 模式會將伺服器與大部分的額外 RPC 流量隔離開來。

  • 遵循下節所述之 Exchange 團隊部落格中的指導，以開啟事件日誌限制追蹤。然後逐一開啟使用者應用程式，以追蹤可能造成長時間執行限制的應用程式。

  • 嘗試關閉所有應用程式。然後再逐一開啟這些應用程式，以找出可能造成問題的應用程式。符合下列其中一種情況時，請永久關閉有問題的應用程式或更新應用程式，將負載降低至適當水準：

    • 應用程式不是業務用途所必需。

    • 應用程式已發行更新。

附註：
某些應用程式即使未發出大量 MAPI 作業，仍可能大幅增加伺服器負載。這是因為某些作業比其他作業更耗資源。耗資源的作業數目只要增加一些，可能就會明顯影響伺服器效能。在 ExMon 中，會將使用者報告為具有高度 CPU 影響 (即使他們並未發出大量 MAPI 作業)。

同時請注意，當發生資源瓶頸 (一般是磁碟或 CPU 瓶頸) 時，Restrict 作業的延遲也會增加。

詳細資訊

若需 MAPI Restrict 作業的詳細資訊，請參閱 Microsoft Exchange 團隊部落格＜對限制所設定的限制＞(英文) (http://go.microsoft.com/fwlink/?linkid=55098)。

附註：
每一個部落格及其 URL 的內容隨時都會變更，不另行通知。

若需詳細資訊，請參閱下列 Exchange Server 資源：

  • ＜Exchange Server 2003 效能及延展性手冊＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)

  • ＜Microsoft Exchange Server 效能疑難排解＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • ＜Exchange Server 2003 效能：10 件要考慮的事情＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56460)

  • 微軟知識庫文件 - 905803＜Outlook 使用者在執行 Exchange Server 2003 或 Exchange 2000 Server 的伺服器上使用包含許多項目的資料夾時遇到效能不佳的情況＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


MAD.EXE 檔案遺失
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔是否存在：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要解決此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


MAD NSPI 通訊埠低於 5000
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Microsoft Exchange System Attendant 服務的 TCP/IP NSPI Port 設定。

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

如果 Exchange Server Analyzer 發現 TCP/IP NSPI Port 設定為低於 5000 (十進位) 的值，就會顯示警告。

如果您必須將 TCP/IP NSPI Port 設為靜態值，建議您將其設為高於 5000 的值。指派低於 5000 的靜態通訊埠編號可能造成通訊埠與其他處理程序相衝突，並導致 Exchange System Attendant 服務處理程序的失敗。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要設定 TCP/IP NSPI 通訊埠登錄機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 按兩下 TCP/IP NSPI Port 機碼，並將 [數值資料] 欄位設為略微超過 5000 (十進位) 的整數。

  4. 關閉登錄編輯程式。

  5. 重新啟動 Microsoft Exchange System Attendant 服務，使此變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關通訊埠限制的詳細資訊，請參閱知識庫文件 - 194952＜XADM：Exchange Server 的靜態對應通訊埠限制＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952)。


MAD RFR 通訊埠已經被手動覆寫
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已手動覆寫 Microsoft Exchange System Attendant 目錄轉介通訊埠的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

如果 Exchange Server Analyzer 發現 TCP/IP Port 存在且已設定，就會顯示非預設的組態訊息。

設定此值最常見的原因就是，讓 MAPI 用戶端能夠連線到在防火牆另一端的 Exchange 伺服器。此案例會開啟防火牆上的多個通訊埠，以讓 Microsoft Office Outlook® 2003 用戶端使用 MAPI 連線到 Exchange伺服器，這通常是透過網際網路連線。此為支援的組態。若需設定 MAPI 用戶端連線到防火牆後的 Exchange，請參閱微軟知識庫文件 - 270836＜Exchange 2000 及 Exchange 2003 靜態連接埠對應＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)。如果您不使用此案例，則應該移除該登錄機碼。

若要以 MAPI 模式使用 Outlook 透過網際網路連線到 Exchange 伺服器，建議的部署方式是使用 Microsoft Windows Server™ 2003、Exchange Server 2003、Outlook 2003 及 Windows® XP Professional 中的透過超文字傳送通訊協定 (HTTP) 的遠端程序呼叫 (RPC) 功能。MAPI 模式先前稱為「公司」或「工作群組」模式。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要移除 TCP/IP 通訊埠登錄值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 刪除名為 TCP/IP Port 的登錄值。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange System Attendant 服務。

若要部署 RPC over HTTPS

  1. 檢閱《Exchange Server 2003 RPC over HTTP 部署案例》(英文) (http://go.microsoft.com/fwlink/?linkid=47577)。

  2. 檢閱知識庫文件 - 833401＜如何在 Exchange Server 2003 中為單一伺服器設定 RPC over HTTP＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)。

  3. 檢閱知識庫文件 - 827330＜如何疑難排解 Office Outlook 2003 用戶端的 RPC over HTTP 連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)。

  4. 檢閱 Microsoft Support WebCast＜透過網際網路 (RPC/HTTP) 搭配使用 Microsoft Exchange 與 Microsoft Office Outlook 2003＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


MAD RFR 通訊埠低於 5000
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Microsoft Exchange System Attendant 服務的 TCP/IP Port 設定。

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

如果 Exchange Server Analyzer 發現 TCP/IP Port 設定為低於 5000 (十進位) 的值，就會顯示警告。

在您必須將 TCP/IP Port 設為靜態值的情況下，建議您將其設為略大於 5000 的值。指定低於 5000 的靜態通訊埠編號會造成與其他處理程序的通訊埠衝突，並導致 Microsoft Exchange System Attendant 服務處理程序失敗。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要設定 TCP/IP 通訊埠登錄機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 按兩下 TCP/IP Port 機碼，並將 [數值資料] 欄位設為略微超過 5000 (十進位) 的整數。

  4. 關閉登錄編輯程式。

  5. 重新啟動 Microsoft Exchange System Attendant 服務，使此變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關通訊埠設定的詳細資訊，請參閱知識庫文件 - 194952＜XADM：Exchange Server 的靜態對應通訊埠限制＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952)。


bin 資料夾遺失 MAPI32.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔是否存在：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要解決此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


system32 資料夾中的 MAPI32.DLL 檔案遺失
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔是否存在：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 Microsoft Exchange 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


MAPISTUB.DLL 檔案遺失
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔是否存在：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要解決此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


MAPISP32.EXE 檔案遺失
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔是否存在：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要修正此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或彙總更新套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 Microsoft Exchange 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


最大 ESE 快取大小大於 1.2 GB
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-02-13

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 DataBase 效能物件的 DataBase Cache Size (DBCacheSize) 效能計數器的資料，以分析效能資料。

DataBase Cache Size (DBCacheSize) 效能計數器代表儲存區目前使用的快取大小。如果 Exchange Server Analyzer 發現 DataBase Cache Size (DBCacheSize) 效能計數器大於 307200 (1.2 GB)，便會顯示錯誤。

此錯誤表示 Microsoft Exchange Information Store (MSExchangeIS) 物件的 msExchESEParamCacheSizeMax 屬性值已增加到超過最大建議值 307200 (1.2 GB)。

儲存區資料庫快取也稱為 ESE (可擴充儲存引擎) 緩衝區。在資料庫中確認資料庫交易之前，它會先快取這些交易。

在 Exchange 2000 Server 中，Store.exe 使用的虛擬記憶體有很大的區域是配置給「ESE 緩衝區」。Exchange 2000 Server 使用硬式編碼預設值 858 MB 作為此緩衝區大小。在 Exchange Server 2003 中，ESE 緩衝區配置是視 Boot.ini 檔案中是否有 /3GB 參數而定。如果有 /3GB 參數，ESE 緩衝區會調整成 896 MB。如果 /3GB 不存在，則 ESE 緩衝區會調整為 576 MB。雖然自動調整一向是很好的選擇，但是您可以覆寫自動調整並手動設定較適合您環境的值。

雖然您可以調整此值為任何數字，使配置的實際記憶體是 8,192 個位元組的倍數，但仍建議您只使用下表的值。

建議值 | 已配置的記憶體 | 註解
147456 | 576 MB | 這是建議的最小值。不要設定更小的值。在虛擬記憶體有限的伺服器，以及在 Microsoft Windows® 2000 Server 上執行的 Exchange Server 2003 電腦上，此值很有用。這不支援 /3GB 參數。在不使用 /3GB 參數的系統上，此值也是預設值。
196608 | 768 MB | 在含有許多虛擬記憶體且經常記錄事件 9582 的伺服器上，建議採用此值。
219726 | 858 MB | 這是 Exchange 2000 Server 中的預設值。在就地升級且含有許多虛擬記憶體的系統上，這是很適合的值。
229376 | 896 MB | 在 Exchange Server 2003 中，此值是預設值，除非應用程式事件日誌以不同的方式顯示 9582 事件，否則此值很適合在新的系統上使用。
307200 | 1.2 GB | 這是可以設定的最大值。此值只能用在含有 2 GB 或更多實體記憶體的系統上。

在重新設定這個值之前，您應該監視 Store.exe 處理程序耗用的虛擬記憶體量。您可以透過監視 Microsoft Windows 中的 Process 效能物件來達成此目的。在使用 /3GB 參數的系統上，Process 物件的 Store.exe 執行個體之 Virtual Bytes 計數器應小於 2.8 GB。在不使用 /3GB 參數的系統上，Process 物件的 Store.exe 執行個體之 Virtual Bytes 計數器應小於 1.8 GB。如果值大於這些數量，則需要減少 msExchESEParamCacheSizeMax 的值。如果這些值小於此值，則可增加 msExchESEParamCacheSizeMax 的值。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory® 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
若要調整 msExchESEParamCacheSizeMax 屬性

  1. 開啟 Active Directory 編輯程式，如 [ADSI 編輯器]。

  2. 連按兩下 [組態] 容器。

  3. 展開 CN=Services。

  4. 展開 CN=Microsoft Exchange。

  5. 展開 CN=<Exchange Organization Name>。

  6. 展開 CN=Administrative Groups。

  7. 展開 CN=<Administrative Group Name>。

  8. 展開 CN=Servers。

  9. 展開 CN=<Exchange Server Name>。

  10. 以滑鼠右鍵按一下 [CN=InformationStore]，然後按一下 [內容]。

  11. 在 [屬性] 欄位中，捲動至 msExchESEParamCacheSizeMax，然後連按兩下該屬性。

  12. 在 [值] 欄位中，輸入您要設定的值。請使用此表格來判定系統的最佳值。

  13. 按一下 [確定]，然後再按一下 [確定]。

  14. 關閉 Active Directory 編輯器，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

若需最佳化記憶體使用量的詳細資訊，請參閱《規劃 Microsoft Exchange Server 2003 郵件系統》中的＜將 Exchange Server 2003 中的記憶體使用量最佳化＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47584) 。

若需 msExchESEParamCacheSizeMax 屬性的詳細資訊，請參閱微軟知識庫文件 - 266768＜如何在 Exchange 2000 Server 中修改儲存區資料庫最大快取大小＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768)。


已變更收件者上限
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已變更 msExchRecipLimit 屬性的預設值。msExchRecipLimit 屬性會儲存每封電子郵件的收件者全域數目上限值。依預設，msExchRecipLimit 的屬性值為 5000。如果 Exchange Server Analyzer 發現 msExchRecipLimit 屬性值不等於 5000，就會顯示一則非預設組態的訊息。

全域收件者上限適用於整個 Exchange 組織。msExchRecipLimit 屬性值可限制單一電子郵件的收件者數。　系統郵件與非系統郵件都會受到全域收件者上限的影響。系統郵件包括公用資料夾複寫郵件。

附註：
您也可以使用 [Active Directory 使用者及電腦]，依使用者逐一設定收件者限制。依使用者逐一設定的優先順序在全域設定之上，且會覆寫全域設定。依使用者逐一設定的收件者限制，預設為使用全域收件者上限。
附註：
在簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器上，您可以針對寄給網際網路使用者的郵件，設定每封郵件的收件者數目限制。此限制不同於全域收件者上限與依使用者逐一設定的收件者限制。全域收件者上限和依使用者逐一設定的收件者限制，都會限制 Exchange 使用者傳送郵件時的收件者數。
將全域收件者上限變更為預設值

  1. 啟動 Exchange 系統管理員。

  2. 在左窗格中，展開 [通用設定]。

  3. 在 [郵件傳遞] 上按一下滑鼠右鍵，然後按一下 [內容]。

  4. 在 [預設值] 索引標籤的 [收件者限制] 下，按一下 [收件者上限]，然後鍵入 [5000]。

  5. 重新啟動 Microsoft Exchange Information Store 服務。

若需有關設定收件者限制及設定 Microsoft Office Outlook® Web Access 用戶端的詳細資訊，請參閱《Exchange Server 2003 郵件安全性手冊》(http://go.microsoft.com/fwlink/?LinkId=47574)中的＜ Outlook Web Access S/MIME 控制項相關設定＞(英文)。

若需有關最大收件者限制歷程的詳細資訊，請參閱 Exchange 網誌文章＜我也是！＞(英文)(http://go.microsoft.com/fwlink/?LinkId=41848)。


收件者上限太高
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定郵件的 msExchRecipLimit 值是否超過 7500。如果 Exchange Server Analyzer 發現 msExchRecipLimit 屬性值大於 7500，就會顯示一則警告。

msExchRecipLimit 屬性會儲存每封電子郵件的收件者全域數目上限值。此值可限制單一電子郵件的收件者數。　系統郵件與非系統郵件也會受到此值的影響。系統郵件包括公用資料夾複寫郵件。依預設，msExchRecipLimit 的屬性值為 5000。

如果 msExchRecipLimit 屬性值超過 7500，則具有多個收件者之郵件會導致問題的風險就會提高。

附註：
您也可以使用 [Active Directory 使用者及電腦]，依使用者逐一設定收件者限制。依使用者逐一設定的優先順序在全域設定之上，且會覆寫全域設定。依使用者逐一設定的收件者限制，預設為使用全域收件者上限。
附註：
在簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器上，您可以針對寄給網際網路使用者的郵件，設定每封郵件的收件者數目限制。此限制不同於全域收件者上限與依使用者逐一設定的收件者限制。全域收件者上限和依使用者逐一設定的收件者限制，都會限制 Exchange 使用者傳送郵件時的收件者數。
將全域收件者上限變更為預設值

  1. 啟動 Exchange 系統管理員。

  2. 在左窗格中，展開 [通用設定]。

  3. 在 [郵件傳遞] 上按一下滑鼠右鍵，然後按一下 [內容]。

  4. 在 [預設值] 索引標籤的 [收件者限制] 下，按一下 [收件者上限]，然後鍵入 [5000]。

  5. 重新啟動 Microsoft Exchange Information Store 服務。

若需有關設定收件者限制及設定 Microsoft Office Outlook® Web Access 用戶端的詳細資訊，請參閱《Exchange Server 2003 郵件安全性手冊》(http://go.microsoft.com/fwlink/?LinkId=47574)中的＜ Outlook Web Access S/MIME 控制項相關設定＞(英文)。

若需收件者全域數目上限的歷程資料，請參閱 Exchange 網誌文章＜我也是！＞(英文)(http://go.microsoft.com/fwlink/?LinkId=41848)。


收件者上限太低
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

MicrosoftR® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定郵件的 msExchRecipLimit 值是否小於 Exchange 組織中公用資料夾儲存區的數目。如果 Exchange Server Analyzer 發現 msExchRecipLimit 屬性的值小於公用資料夾儲存區的數目，則 Exchange Server Analyzer 會顯示錯誤。

msExchRecipLimit 屬性會儲存每封電子郵件的收件者全域數目上限值。此值可限制單一電子郵件的收件者數。　系統郵件與非系統郵件也會受到此值的影響。系統郵件包括公用資料夾複寫郵件。依預設，msExchRecipLimit 的屬性值為 5000。如果 msExchRecipLimit 屬性的值小於 Exchange 組織中公用資料夾儲存區的數目，則公用資料夾階層複寫將會出現問題。

附註：
您也可以使用 [Active Directory 使用者及電腦]，依使用者逐一設定收件者限制。依使用者逐一設定的優先順序在全域設定之上，且會覆寫全域設定。依使用者逐一設定的收件者限制，預設為使用全域收件者上限。
附註：
在簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器上，您可以針對寄給網際網路使用者的郵件，設定每封郵件的收件者數目限制。此限制不同於全域收件者上限與依使用者逐一設定的收件者限制。全域收件者上限和依使用者逐一設定的收件者限制，都會限制 Exchange 使用者傳送郵件時的收件者數。
將全域收件者上限變更為預設值

  1. 啟動 Exchange 系統管理員。

  2. 在左窗格中，展開 [通用設定]。

  3. 在 [郵件傳遞] 上按一下滑鼠右鍵，然後按一下 [內容]。

  4. 在 [預設值] 索引標籤上的 [收件者限制] 下，按一下 [收件者上限]，並確定其值不小於 Exchange 組織中的公用資料夾儲存區數。

  5. 重新啟動 Microsoft Exchange Information Store 服務。

若需有關設定收件者限制及設定 Microsoft Office Outlook® Web Access 用戶端的詳細資訊，請參閱《Exchange Server 2003 郵件安全性手冊》(http://go.microsoft.com/fwlink/?LinkId=47574)中的＜ Outlook Web Access S/MIME 控制項相關設定＞(英文)。

若需收件者全域數目上限的歷程資料，請參閱 Exchange 網誌文章＜我也是！＞(英文)(http://go.microsoft.com/fwlink/?LinkId=41848)。


MaxUserPort 機碼遺失或不是預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-03-23

Microsoft Exchange Analyzer 工具會查詢 Active Directory 目錄服務，以判定物件類別為 msExchExchangeServer 之所有物件的 serialNumber 屬性值。如果字串值包含 "Version 5.5"，表示電腦正在執行 Exchange Server 5.5。如果字串值包含 "Version 6.0"，表示電腦正在執行 Exchange 2000 Server。如果字串值包含 "Version 6.5"，表示電腦正在執行 Exchange Server 2003。如果字串值包含 "Version 8.0"，則表示電腦正在執行 Exchange Server 2007。

然後 Exchange Analyzer 工具會針對所找到的每部 Exchange Server 2007 伺服器讀取下列登錄分支，以判定 MaxUserPort 機碼值是否設為預設值 60000。

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

MaxUserPort 值可判定當應用程式向系統要求可用的使用者通訊埠時，TCP 可以指派的最高通訊埠編號。

在預設的情況下，Microsoft Windows Server 2003 會將 MaxUserPort 值設為 5000。Microsoft Windows 2000 不會將 MaxUserPort 值新增至登錄。但您可以手動新增。不過，在 Windows Server 2003 及 Windows 2000 Server 上，Exchange Server 2003 及 Exchange Server 2007 會將預設值設為 60000。Exchange 2000 Server 不會設定任何值。

建議您將 MaxUserPort 值設為 60000。如果您將 MaxUserPort 值設為低於 60000，則可能會引發名稱服務提供者介面 (NSPI) Proxy 警告，如事件 9040。下表為事件 9040 的說明：

事件識別碼 | 9040
事件類別 | NSPI Proxy
事件來源 | MSExchangeSA
事件類型 | 警告
事件說明 | NSPI Proxy 在接收封包時發生錯誤。目標網域控制站或網路或用戶端可能無法使用。Winsock 子系統傳回錯誤：[0x2746]。正在關閉接收到此錯誤的迴路。
重要事項：
這篇主題包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

  3. 連按兩下 [MaxUserPort]，將 [數值資料] 欄位設為 60000 (十進位)，再按 [確定]。

  4. 關閉登錄編輯程式，然後重新啟動電腦，使這項設定生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱 Microsoft 知識庫文章 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

這個問題與 TcpTimedWaitDelay 機碼遺失或不是預設值 的 Analyzer 問題有關。

若需 MaxUserPort 及 TcpTimedWaitDelay 登錄機碼之效果的相關資訊，請參閱 Windows 2000 Resource Kit 中的＜傳輸控制通訊協定＞主題 (英文) (http://go.microsoft.com/fwlink/?LinkId=85654)。


MaxUserPort 值太低
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄機碼，以判定 TCP 暫時通訊埠的最大值：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\MaxUserPort

暫時通訊埠是一種短時間使用的通訊埠。

如果 Exchange Server Analyzer 發現 MaxUserPort 登錄機碼的值小於 50000，就會顯示警告。

MaxUserPort 值指定當應用程式向系統要求可用的使用者通訊埠時，TCP 可以指派的最高通訊埠編號。一般而言，配置給暫時通訊埠的埠號都介於 1024 到 5000 之間。

在預設的情況下，Microsoft Windows Server™ 2003 會將 MaxUserPort 值設為 5000。Microsoft Windows® 2000 不會將 MaxUserPort 值新增至登錄。您可以手動將 MaxUserPort 值新增至登錄。不過，在 Windows Server 2003 及 Windows 2000 Server 上，Exchange Server 2003 會將預設值設為 60000。Exchange 2000 Server 不會設定任何值。

建議您將 MaxUserPort 值設為 60000。如果您將 MaxUserPort 值設為低於 60000，則可能會引發名稱服務提供者介面 (NSPI) Proxy 警告，如事件 9040。下表為事件 9040 的說明。

事件識別碼 | 9040
事件類別 | NSPI Proxy
事件來源 | MSExchangeSA
事件類型 | 警告
事件說明 | NSPI Proxy 在接收封包時發生錯誤。目標網域控制站或網路或用戶端可能無法使用。Winsock 子系統傳回錯誤：[0x2746]。正在關閉接收到此錯誤的迴路。

若要更正此警告，請將 MaxUserPort 登錄機碼的值設為 60000。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定您瞭解如何在發生問題時還原登錄。若需如何還原登錄的相關資訊，請檢視 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

  3. 按兩下 [MaxUserPort]，將 [數值資料] 欄位設為 ea60 (十六進位)，再按 [確定]。

  4. 關閉登錄編輯程式，然後重新啟動電腦，使這項設定生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


MDBSZ.DLL 檔案遺失
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要修正此錯誤，請安裝您的 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


記憶體效能監視器物件無法使用
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Memory 效能物件的 Available Mbytes 效能計數器的資料，以分析效能資料。如果計數器未傳回有效的資料，Exchange Server Analyzer 便會顯示基準線訊息。

如果效能資料收集引擎未傳回有效的資料，則發生了下列任意狀況組合：

  • Memory 效能物件已停用。

  • Memory 效能監視器物件已遺失或已損毀。

  • Exchange Server Analyzer 沒有適當的權限可存取效能物件。

如果某個可擴充的計數器損毀了登錄，或使用 Microsoft Windows® Management Instrumentation (WMI) 的程式修改了登錄，就會發生前兩個狀況。

在執行此程序前，請先確認 Exchange Server Analyzer 具有適當的權限。若需有關執行 Exchange Server Analyzer 所需權限的詳細資訊，請參閱包含在 Exchange Server Analyzer 中的說明文件。若需取得 [說明]，請開啟 Exchange Server Analyzer 並按 F1 鍵。

若要更正此錯誤

  1. 確認 Memory 效能物件已啟用：

    1. 下載並安裝 Extensible Performance Counter List 工具 (Exctrlst.exe)。您可以在下列位置下載 Exctrlst.exe：「Exctrlst.exe：Extensible Performance Counter List」(英文) (http://go.microsoft.com/fwlink/?LinkId=34436)。

    2. 開啟 Exctrlst.exe，並依序按一下 [Sort Order] 及 [Service]。

    3. 找出要讓效能物件報告的服務，並確認已選取 [Performance Counters Enabled] 核取方塊。

      如果未選取 [Performance Counters Enabled] 核取方塊，請選取此核取方塊，然後重新啟動與效能計數器相關的服務，確認效能計數器可運作。如果效能計數器未運作，或已選取 [Performance Counters Enabled] 核取方塊，請繼續步驟 2。

  2. 依照微軟知識庫文件 - 300956＜如何手動重建效能計數器程式庫值＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) 中的指示，重建遺失或損毀的效能計數器。

  3. 如果遵循此知識庫文件的指示並不能解決問題，則必須以 [修復] 模式重新安裝 Windows 作業系統，並套用最新的 Windows Service Pack。


MSExchangeDSAccess 處理程序效能監視器物件不可用
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 MSExchangeDSAccess 效能物件的 LDAP Read Time 效能計數器的資料，以分析效能資料。如果計數器未傳回有效的資料，Exchange Server Analyzer 便會顯示基準線訊息。

如果效能資料收集引擎未傳回有效的資料，則發生了下列任意狀況組合：

  • MSExchangeDSAccess 效能物件已停用。

  • MSExchangeDSAccess 效能監視器物件已遺失或已損毀。

  • Exchange Server Analyzer 沒有適當的權限可存取效能物件。

如果某個可擴充的計數器損毀了登錄，或使用 Microsoft Windows® Management Instrumentation (WMI) 的程式修改了登錄，就會發生前兩個狀況。下列程序解說如何修復前兩個狀況。在執行此程序前，請先確認 Exchange Server Analyzer 具有適當的權限。

若需有關執行 Exchange Server Analyzer 所需權限的詳細資訊，請參閱包含在 Exchange Server Analyzer 中的說明文件。若需取得 [說明]，請開啟 Exchange Server Analyzer 並按 F1 鍵。

若要更正此錯誤

  1. 確認 MSExchangeDSAccess 效能物件已啟用：

    1. 下載並安裝 Extensible Performance Counter List 工具 (Exctrlst.exe)。您可以在下列位置下載 Exctrlst.exe：「Exctrlst.exe：Extensible Performance Counter List」(英文) (http://go.microsoft.com/fwlink/?LinkId=34436)。

    2. 開啟 Exctrlst.exe，並依序按一下 [Sort Order] 及 [Service]。

    3. 找出要讓效能物件報告的服務，並確認已選取 [Performance Counters Enabled] 核取方塊。

      如果未選取 [Performance Counters Enabled] 核取方塊，請選取此核取方塊，然後重新啟動與效能計數器相關的服務，確認效能計數器可運作。如果效能計數器未運作，或已選取 [Performance Counters Enabled] 核取方塊，請繼續步驟 2。

  2. 依照微軟知識庫文件 - 300956＜如何手動重建效能計數器程式庫值＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) 中的指示，重建遺失或損毀的效能計數器。

  3. 如果遵循此知識庫文件的指示並不能解決問題，則必須以 [修復] 模式重新安裝 Exchange Server，並套用最新的 Exchange Server Service Pack。


MSExchangeIS 信箱效能監視器物件不可用
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 MSExchangeIS Mailbox 效能物件的 Send Queue Size 效能計數器的資料，以分析效能資料。如果計數器未傳回有效的資料，Exchange Server Analyzer 便會顯示基準線訊息。

如果效能資料收集引擎未傳回有效的資料，則發生了下列任意狀況組合：

  • MSExchangeIS Mailbox 效能物件已停用。

  • MSExchangeIS Mailbox 效能監視器物件已遺失或已損毀。

  • Exchange Server Analyzer 沒有適當的權限可存取效能物件。

如果某個可擴充的計數器損毀了登錄，或使用 Microsoft Windows® Management Instrumentation (WMI) 的程式修改了登錄，就會發生前兩個狀況。

在執行此程序前，請先確認 Exchange Server Analyzer 具有適當的權限。若需有關執行 Exchange Server Analyzer 所需權限的詳細資訊，請參閱包含在 Exchange Server Analyzer 中的說明文件。若需取得 [說明]，請開啟 Exchange Server Analyzer 並按 F1 鍵。

若要更正此錯誤

  1. 確認 MSExchangeIS Mailbox 效能物件已啟用：

    1. 下載並安裝 Extensible Performance Counter List 工具 (Exctrlst.exe)。您可以在下列位置下載 Exctrlst.exe：「Exctrlst.exe：Extensible Performance Counter List」(英文) (http://go.microsoft.com/fwlink/?LinkId=34436)。

    2. 開啟 Exctrlst.exe，並依序按一下 [Sort Order] 及 [Service]。

    3. 找出要讓效能物件報告的服務，並確認已選取 [Performance Counters Enabled] 核取方塊。

      如果未選取 [Performance Counters Enabled] 核取方塊，請選取此核取方塊，然後重新啟動與效能計數器相關的服務，確認效能計數器可運作。如果效能計數器未運作，或已選取 [Performance Counters Enabled] 核取方塊，請繼續步驟 2。

  2. 依照微軟知識庫文件 - 300956＜如何手動重建效能計數器程式庫值＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) 中的指示，重建遺失或損毀的效能計數器。

  3. 如果遵循此知識庫文件的指示並不能解決問題，則必須以 [修復] 模式重新安裝 Exchange Server，並套用最新的 Exchange Server Service Pack。


無法取得 MSExchangeIS 效能監視器物件
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-04-03

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 MSExchangeIS 效能物件的 RPC Operations/sec 效能計數器的資料，以分析效能資料。如果計數器未傳回有效的資料，Exchange Server Analyzer 便會顯示基準線訊息。

如果效能資料收集引擎未傳回有效的資料，則發生了下列任意狀況組合：

  • MSExchangeIS 效能物件已停用。

  • MSExchangeIS 效能監視器物件已遺失或已損毀。

  • Exchange Server Analyzer 沒有適當的權限可存取效能物件。

如果某個可擴充的計數器損毀了登錄，或使用 Microsoft Windows® Management Instrumentation (WMI) 的程式修改了登錄，就會發生前兩個狀況。在執行此程序前，請先確認 Exchange Server Analyzer 具有適當的權限。若需有關執行 Exchange Server Analyzer 所需權限的詳細資訊，請參閱包含在 Exchange Server Analyzer 中的說明文件。若需取得 [說明]，請開啟 Exchange Server Analyzer 並按 F1 鍵。

若要更正此錯誤

  1. 確認 MSExchangeIS 效能物件已啟用：

    1. 下載並安裝 Extensible Performance Counter List 工具 (Exctrlst.exe)。您可以在下列位置下載 Exctrlst.exe：「Exctrlst.exe：Extensible Performance Counter List」(英文) (http://go.microsoft.com/fwlink/?LinkId=34436)。

    2. 開啟 Exctrlst.exe，並依序按一下 [Sort Order] 及 [Service]。

    3. 找出要讓效能物件報告的服務，並確認已選取 [Performance Counters Enabled] 核取方塊。

      如果未選取 [Performance Counters Enabled] 核取方塊，請選取此核取方塊，然後重新啟動與效能計數器相關的服務，確認效能計數器可運作。如果效能計數器未運作，或已選取 [Performance Counters Enabled] 核取方塊，請繼續步驟 2。

  2. 依照微軟知識庫文件 - 300956＜如何手動重建效能計數器程式庫值＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) 中的指示，重建遺失或損毀的效能計數器。

  3. 如果遵循此知識庫文件的指示並不能解決問題，則必須以 [修復] 模式重新安裝 Exchange Server，並套用最新的 Exchange Server Service Pack。

若需有關疑難排解 Exchange Server Best Practices Analyzer 工具連線問題的詳細資訊，請參閱＜Microsoft Exchange Server Best Practices Analyzer 工具疑難排解連線問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56285)。


無法取得 MSExchangeIS Public 效能監視器物件
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 MSExchangeIS Public 效能物件的 Send Queue Size 效能計數器的資料，以分析效能資料。如果計數器未傳回有效的資料，Exchange Server Analyzer 便會顯示基準線訊息。

如果效能資料收集引擎未傳回有效的資料，則發生了下列任意狀況組合：

  • MSExchangeIS Public 效能物件已停用。

  • MSExchangeIS Public 效能監視器物件已遺失或已損毀。

  • Exchange Server Analyzer 沒有適當的權限可存取效能物件。

如果某個可擴充的計數器損毀了登錄，或使用 Microsoft Windows® Management Instrumentation (WMI) 的程式修改了登錄，就會發生前兩個狀況。在執行此程序前，請先確認 Exchange Server Analyzer 具有適當的權限。若需有關執行 Exchange Server Analyzer 所需權限的詳細資訊，請參閱包含在 Exchange Server Analyzer 中的說明文件。若需取得 [說明]，請開啟 Exchange Server Analyzer 並按 F1 鍵。

若要更正此錯誤

  1. 確認 MSExchangeIS Public 效能物件已啟用：

    1. 下載並安裝 Extensible Performance Counter List 工具 (Exctrlst.exe)。您可以在下列位置下載 Exctrlst.exe：「Exctrlst.exe：Extensible Performance Counter List」(英文) (http://go.microsoft.com/fwlink/?LinkId=34436)。

    2. 開啟 Exctrlst.exe，並依序按一下 [Sort Order] 及 [Service]。

    3. 找出要讓效能物件報告的服務，並確認已選取 [Performance Counters Enabled] 核取方塊。

      如果未選取 [Performance Counters Enabled] 核取方塊，請選取此核取方塊，然後重新啟動與效能計數器相關的服務，確認效能計數器可運作。如果效能計數器未運作，或已選取 [Performance Counters Enabled] 核取方塊，請繼續步驟 2。

  2. 依照微軟知識庫文件 - 300956＜如何手動重建效能計數器程式庫值＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) 中的指示，重建遺失或損毀的效能計數器。

  3. 如果遵循此知識庫文件的指示並不能解決問題，則必須以 [修復] 模式重新安裝 Exchange Server，並套用最新的 Exchange Server Service Pack。


有可用的 MSGINA.DLL 驅動程式更新
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-08-21

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定正在執行 Exchange Server 之伺服器所執行的 Microsoft Windows® 版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 值為 4.0 指出 Exchange 伺服器正在執行 Microsoft Windows NT® Server 4.0。值為 5.0 則指出 Exchange 伺服器正在執行 Windows 2000 Server。值為 5.2 指出 Exchange 伺服器正在執行 Windows Server™ 2003。

Exchange Server Analyzer 也會檢查 Win32_OperatingSystem Microsoft Windows Management Instrumentation (WMI) 類別，以判定 ServicePackMajorVersion 機碼的值。

ServicePackMajorVersion 機碼值為 1 指出伺服器已安裝 Service Pack 1 (SP1)。

最後，Exchange Server Analyzer 會查詢 CIM_Datafile WMI 類別，以判定 Msgina.dll 檔案的 Version 機碼值。

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • 伺服器正在執行 Windows Server™ 2003 SP1。

  • Msgina.dll 檔案的建置號碼小於 5.2.3790.2525。

此錯誤指出伺服器上安裝的 Msgina.dll 版本可能會導致過多頁面檔案活動，並降低效能。

若要解決此問題，請取得 Microsoft 知識庫文章 905865＜當您在執行 Windows Server 2003 的電腦使用終端機服務來登入或登出時，系統可能會裁切主控台工作階段中所有處理程序的工作集大小＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905865) 中所提到的更新。


MTA APDU logging required 參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

MicrosoftR Exchange Server Analyzer 工具會讀取下列登錄項目，來判定其目前的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\APDU logging required

如果 Exchange Server Analyzer 發現 APDU logging required 的值存在且已設定成 0 以外的任意值，就會顯示一則非預設組態的訊息。

「應用程式通訊協定資料單位 (APDU)」文字記錄是以二進位表示位於不同站台內 Exchange 郵件傳輸代理程式 (MTA) 之間的通訊，以及某個站台內 MTA 與用戶端應用程式之間的通訊。APDU 記錄可用來診斷 MTA 問題。然而，只有熟悉 X.400 通訊協定之 ASCII 轉譯方式的人員，才會覺得它們有用。

當 APDU logging required 登錄參數存在且設定的值是 0 時，MTA 所傳送或接收的所有 APDU 都會以二進位資料格式記錄在 MTADATA\BF*.LOG 中。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關如何編輯登錄的詳細資訊，請檢視 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原成預設的 MTA APDU 記錄組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右窗格中，尋找並連按兩下 APDU logging required 值。

  4. 在 [數值資料] 欄位中，輸入 0，然後按一下 [確定]。

  5. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange MTA Stacks 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 APDU 記錄的詳細資訊，請參閱知識庫文件 - 163324＜XCON：應用程式通訊協定資料單位 (APDU) 記錄 (BF0.LOG)＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=163324)。


MTA Call-stack diagnostics required 參數不是預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

MicrosoftR Exchange Server Analyzer 工具會讀取下列登錄項目，來判定其目前的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Call-stack diagnostics required

如果 Exchange Server Analyzer 發現 Call-stack diagnostics required 的值已存在且已設為 1 以外的值，則會顯示非預設的組態訊息。

Call-stack diagnostics required 登錄值僅用於進階偵錯用途，且只能由郵件傳輸代理程式 (MTA) 的偵錯版本來讀取。其數值資料應該一律設為 1。使用 MTA 的偵錯版本時，此值會在終止時為每個 MTA 執行緒提供呼叫堆疊。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右窗格中，尋找 Call-stack diagnostics required 值，並對它連按兩下。

  4. 在 [數值資料] 欄位中，輸入 1，然後按一下 [確定]。

  5. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange MTA Stacks 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


MTA Computer 名稱不符
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定郵件傳輸代理程式 (MTA) Computer 值的設定：HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定每個 Exchange 伺服器物件的 name 屬性值。

最後，Exchange Server Analyzer 會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定叢集服務 (ClusSvc) 的 Started 機碼值。值為 True 表示叢集服務已啟動，值為 False 則表示叢集服務不在執行中。

針對不在 Windows Server 叢集中執行的任何 Exchange Server 電腦，如果 Exchange Server Analyzer 發現 MTA Computer 機碼值與 Active Directory 中該伺服器物件的 name 屬性值不符，就會顯示錯誤。

若要更正此錯誤，您必須將 MTA Computer 登錄機碼編輯為符合 Active Directory 中的 name 屬性值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關如何編輯登錄的詳細資訊，請檢視 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右窗格中，連按兩下 MTA Computer，輸入此電腦的正確名稱，然後按一下 [確定]。

  4. 關閉登錄編輯程式，然後重新啟動 Exchange Server 電腦，使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


MTA Concurrent connections to LAN-MTAs 參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

MicrosoftR Exchange Server Analyzer 工具會讀取下列登錄項目，來判定其目前的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent connections to LAN-MTAs

如果 Exchange Server Analyzer 發現 Concurrent connections to LAN-MTAs 的值存在而且已設為 0x28 (十六進位) 或 40 (十進位) 以外的值，就會顯示非預設的組態訊息。

Concurrent connections to LAN-MTAs 登錄值可決定在區域網路 (LAN) 中同時連到郵件傳輸代理程式 (MTA) 的最大連線數目。透過 LAN 通訊的 MTA 也可稱為 LAN-MTA。視本機 MTA 組態及系統負載而定，本機 MTA 可以有多重遠端 MTA 連線。同時 LAN 型 MTA 連線的最大數目為 240。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設 MTA 同時連線組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右窗格中，尋找 Concurrent connections to LAN-MTAs 值並且連按兩下。

  4. 確定 [底數] 已設為十六進位，並且在 [數值資料] 欄位中輸入 28，然後按一下 [確定]。

  5. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange MTA Stacks 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關同時 LAN 型 MTA 連線最大數目的詳細資訊，請參閱知識庫文件 - 243402＜XCON：Exchange Server MTA 事件識別碼 9280＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=243402)。


MTA Concurrent connections to X.400 gateways 參數不是預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

MicrosoftR Exchange Server Analyzer 工具會讀取下列登錄項目，來判定其目前的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent connections to X.400 gateways

如果 Exchange Server Analyzer 發現 Concurrent connections to X.400 gateways 的值存在且設為 6 以外的任一值，則會顯示非預設的組態訊息。

Concurrent connections to X.400 gateways 登錄值是同時連線到遠端 X.400 郵件傳輸代理程式 (MTA) 的最大數目。大部份組織只要使用預設值 6 就夠了。在執行 Exchange Server 版本 5.5 的伺服器上使用 4 個以上的 EDK 連接器，而該伺服器需要 Concurrent connections to X.400 gateways 的值增加到 0x12 (十六進位) 或 18 (十進位) 時，會發生已知的問題。若需有關此問題的詳細資訊，請參閱微軟知識庫文件 - 282115＜安裝 4 個以上的 Exchange EDK 連接器時郵件流程停止＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=282115)。除非發生該文件中所描述的問題，否則您應該讓 Concurrent connections to X.400 gateways 登錄值維持設定為 6。

若要更正此問題，請還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右窗格中，尋找 Concurrent connections to X.400 gateways 值，並對它連按兩下。

  4. 在 [數值資料] 欄位中，輸入 6，然後按一下 [確定]。

  5. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange MTA Stacks 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


MTA Concurrent MDB/delivery queue clients 參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

MicrosoftR Exchange Server Analyzer 工具會讀取下列登錄項目，來判定其目前的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent MDB/delivery queue clients

如果 Exchange Server Analyzer 發現 Concurrent MDB/delivery queue clients 的值存在且已設定成 3 以外的任意值，則會顯示非預設的組態訊息。

Concurrent MDB/delivery queue clients 值是郵件傳輸代理程式 (MTA) 可支援的郵件資料庫 (MDB) 及 Exchange API 郵件存取傳遞佇列用戶端的最大數目。每個用戶端都可以有一個以上的階段作業。此值應至少設定成 2，以支援私人及公用的 MDB 實體。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右窗格中，尋找並連按兩下 Concurrent MDB/delivery queue clients 值。

  4. 在 [數值資料] 欄位中，輸入 3，然後按一下 [確定]。

  5. 結束登錄編輯程式，然後重新啟動 Microsoft Exchange MTA Stacks 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


將 MTA 資料檔案寫入壓縮的資料夾中
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 類別，以判定郵件傳輸代理程式 (MTA) 資料路徑的 Compressed 機碼值。若 Exchange Server Analyzer 判定 Compressed 機碼的值是 True，就會顯示一則錯誤。

微軟不支援將 Exchange 資料檔案存放在 NTFS 檔案系統壓縮磁碟區上。當您將 Exchange 資料檔案儲存在壓縮磁碟區時，額外的處理會顯著影響 Exchange 的效能。此外，當 Exchange 儲存區資料庫達到特定大小 (大約 4 GB) 之後，它可能不會始終裝載或可能會損毀。

Exchange 資料檔案包括下列檔案：

  • .edb 檔案

  • .stm 檔案

  • .log 檔案

  • .dat 檔案

  • .eml 檔案

  • .chk 檔案

由「可擴充儲存引擎 (ESE)」管理的檔案，並未設計為要儲存在壓縮的磁碟機上。ESE 依賴磁區獨立性來進行記錄型的復原，而壓縮檔案會破壞磁區獨立性。在主控 ESE 資料庫 (或任何使用預寫記錄的資料庫) 的磁碟區上，都不應該啟動壓縮功能。

在 Exchange 2000 Server Service Pack 3 之前，可裝載壓縮的 Exchange 儲存區資料庫。然而，使用 NTFS 壓縮來壓縮任何 Exchange 2000 Exchange 儲存區資料庫或記錄時，會發生損毀。

使用 Exchange 2000 Server Service Pack 3，會自動解壓縮 128 MB 或以下的已壓縮資訊儲存庫資料庫檔案。當資料庫檔案成長到超過 128 MB 時，資料庫將無法裝載，並且會在應用程式記錄檔中產生錯誤訊息。Exchange 2000 Server Service Pack 3 會禁止裝載大於 128 MB 的已壓縮資料庫。

若要關閉指定資料夾的檔案壓縮功能

  1. 以滑鼠右鍵按一下要關閉檔案壓縮功能的資料夾，然後按一下 [內容]。

  2. 在 [一般] 索引標籤中，按一下 [進階]。

  3. 在 [進階屬性] 對話方塊中，清除 [壓縮內容，節省磁碟空間] 核取方塊，然後按一下 [確定]。

移除 MTA 資料庫檔案位置的方法

  1. 在 Exchange Server 版本 5.5 上，您可以使用效能最佳化程式工具來移除 MTA 資料庫檔案。若需有關如何在 Exchange 2000 Server 或 Exchange Server 2003 上執行此動作的詳細資訊，請參閱微軟知識庫文件 - 259896＜XCON：如何變更 MTA 資料庫位置和執行目錄＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=259896。

若需有關 Exchange 資料檔案及 NTFS 壓縮的詳細資訊，請參閱下列微軟知識庫文件：

  • 170009＜XADM：NTFS 壓縮磁碟區造成儲存區失敗＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=170009)

  • 327772＜XADM：套用 SP3 後不但未裝載資料庫，還收到 0xfffff05b 錯誤＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327772)


MTA 資料檔案正在寫入加密的資料夾
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-17

Microsoft® Exchange Server Analyzer 會查詢 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 類別，以判定郵件傳輸代理程式 (MTA) 資料路徑的 Encrypted 機碼值。如果 Exchange Server Analyzer 發現此機碼值為 True，就會顯示錯誤。

在 Exchange 2000 Server 或 Exchange Server 2003 電腦上，MTA 檔案會寫入下列預設位置：

<drive> :\Program Files\Exchsrvr\MTAdata

Microsoft 不支援將 Exchange 資料檔案儲存在「加密檔案系統 (EFS)」加密磁碟區上。當您將 Exchange 資料檔案儲存在加密磁碟區上時，額外的處理會顯著影響 Exchange 的效能。Exchange 資料檔案包括下列檔案：

  • .edb 檔案

  • .stm 檔案

  • .log 檔案

  • .dat 檔案

  • .eml 檔案

  • .chk 檔案

為了協助保護您的 Exchange 資料檔案安全，建議您禁止未經授權者存取 Exchange 電腦，並且使用 S/MIME 郵件格式，將郵件資料加密。

若要關閉指定資料夾的檔案加密功能

  1. 在要關閉檔案壓縮的資料夾上按一下滑鼠右鍵，然後按一下 [內容]。

  2. 在 [一般] 索引標籤中，按一下 [進階]。

  3. 在 [進階屬性] 對話方塊中，清除 [加密內容，保護資料] 核取方塊，然後按一下 [確定]。

若需有關 Exchange Server 資料檔案及 EFS 的詳細資訊，請參閱微軟知識庫文件 - 834638＜Information about the storage of data files on an encrypted volume in Exchange Server＞ (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638)。

若需有關如何在 Microsoft Exchange Server 2003 中保護郵件安全的詳細資訊，請參閱《Exchange Server 2003 郵件安全性手冊》(英文) (http://go.microsoft.com/fwlink/?linkid=47574)。


將 MTA 資料檔案寫入非 NTFS 磁碟分割
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-17

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Exchange 郵件傳輸代理程式 (MTA) 資料之資料夾的 FSName 機碼值。如果 Exchange Server Analyzer 判定 FSName 機碼的值不等於 NTFS，則會顯示錯誤訊息。

Microsoft 不支援將 Exchange 資料檔案儲存在非 NTFS 磁碟區上。Exchange 資料檔案包含下列全部檔案：

  • .edb 檔案

  • .stm 檔案

  • .log 檔案

  • .dat 檔案

  • .eml 檔案

  • .chk 檔案

如果發生此錯誤，您必須將 MTA 資料的資料夾移到 NTFS 磁碟機。或是，如果用來儲存 MTA 資料之資料夾的磁碟機是格式化為檔案配置表 (FAT) 磁碟機，您可以使用 convert.exe 命令列工具將磁碟機轉換為 NTFS。

移動 Exchange 中繼資料的資料夾

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [系統管理群組]，展開您的系統管理群組，展開 [伺服器]，在儲存群組上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 在儲存群組內容頁的 [系統路徑位置] 欄位旁邊，按一下 [瀏覽]。

  4. 為中繼資料的資料夾輸入新的路徑，再按一下 [確定]。

  5. 按一下 [確定]。

除了上述程序之外，如果儲存檔案的磁碟機已格式化為 FAT 磁碟機，您還可以使用 convert.exe 命令列工具，將磁碟機轉換為 NTFS 格式。若需有關使用 convert.exe 命令列工具將 FAT 磁碟分割轉換為 NTFS 磁碟分割的詳細資訊，請參閱微軟知識庫文件 - 214579＜如何使用 Convert.exe 將磁碟分割轉換為 NTFS 檔案系統＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579)。


MTA DB data buffers per object 參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

MicrosoftR Exchange Server Analyzer 工具會讀取下列登錄項目，來判定其目前的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\DB data buffers per object

如果 Exchange Server Analyzer 發現 DB data buffers per object 的值大於 0 但設為 3 或 6 以外的值，就會顯示一則非預設的組態訊息。

DB data buffers per object value 是為每一個資料庫物件設定之 4 KB 資料庫伺服器緩衝區的數目。更多緩衝區需要更多記憶體，但資料庫物件很少會因為缺少緩衝區空間，而載出到磁碟上。建議變更此值的原因之一，是因為在某些情況下，郵件傳輸代理程式 (MTA) 會與站台內或站台之間的多部 Exchange Server 5.5 版電腦通訊。此時，建議將該值變更為 6。如果此 MTA 不符合這項準則，則應將該值變更回其預設設定 3。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右窗格中，尋找並連按兩下 DB data buffers per object 值。

  4. 在 [數值資料] 欄位中，輸入 3，然後按一下 [確定]。

  5. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange MTA Stacks 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


MTA DB file handles 參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

MicrosoftR Exchange Server Analyzer 工具會讀取下列登錄項目，來判定其目前的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\DB file handles

如果 Exchange Server Analyzer 發現 DB file handles 的值存在，且設為 192 以外的值，就會顯示非預設的組態訊息。

DB file handles 值是已設定的資料庫伺服器檔案控制代碼的數目。這決定可同時開啟的資料庫檔案數目上限。如果需要開啟的檔案數目超過已設定的值，資料庫物件會複製到磁碟上。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右窗格中，尋找並連按兩下 DB file handles 值。

  4. 在 [數值資料] 欄位中，輸入 192，然後按一下 [確定]。

  5. 結束登錄編輯程式，然後重新啟動 Microsoft Exchange MTA Stacks 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


MTA 診斷記錄級別大於 5 (MTA 處於偵錯模式)
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取一連串的登錄機碼，以判定 Exchange 伺服器上設定的郵件傳輸代理程式 (MTA) 診斷日誌的層級。登錄機碼位於：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Diagnostics

這些機碼的預設值是 0。如果 Exchange Server Analyzer 發現這些機碼中有任何值大於 5，就會顯示一則錯誤。

這些登錄機碼是您在特定伺服器內容頁的 [診斷記錄] 索引標籤上調整記錄級別時，由 [Exchange 系統管理員] 所設定的。[Exchange 系統管理員] 可讓系統管理員將指定的記錄級別設為 [無]、[最低]、[中] 及 [最高]。登錄機碼的對應值分別是 0、1、3 或 5。

因此，大於 5 的值只能以手動編輯登錄的方式來設定，而且只有在非尖峰時間進行極短期的偵錯及疑難排解作業時，才能設定這樣的級別。若將這些機碼設定成 5 以上的整數，會將記錄級別提高至偵錯級別，這樣相當耗費資源。除了偵錯級別的記錄之外，將這些機碼設為 5 以上還會每隔幾秒就輸出約 40 MB 大小的 "call.out" 偵錯追蹤檔。這樣會在一分鐘之內就填滿了電腦的事件日誌。

下表顯示在 [Exchange 系統管理員] 的 [診斷記錄] 索引標籤上列出的 MTA 記錄類別，以及它們在登錄中的對應機碼名稱。

顯示於 [Exchange 系統管理員] 的類別 | 對應的登錄機碼名稱
X.400 服務 | 1 X.400 Service
資源 | 2 Resource
安全性 | 3 Security
介面 | 4 Interface
欄位工程 | 5 Field Engineering
MTA 系統管理 | 6 MTA Administration
組態 | 7 Configuration
目錄存取 | 8 Directory Access
作業系統 | 9 Operating System
內部處理 | 10 Internal Processing
交互操作性 | 11 Interoperability
APDU (應用程式通訊協定資料單位) | 12 APDU

位於這份文件結尾的參考資訊提供每一個 MTA 類別記錄哪些內容的相關資訊。

建議您，除非您需要主動排解疑難問題，否則請將每個 MTA 類別的記錄功能都設定在 [無] (0) 的級別。此建議的原因是要使記錄的事件維持在能夠管理的數目。即使級別 [最低] (1) 都可能在短短幾天內產生數百筆事件記錄，視該級別是設定在哪一個類別而定。

如果您目前沒有在進行疑難排解，則有可能是因為在疑難排解的活動期間，這些值被設高了，而且一不小心就被繼續留著。您必須至少將這些值設定為 [最高] (5)，但除非您需要主動進行排解疑難，否則應考慮將每個 MTA 診斷記錄類別都設定在 [無] (0)。

若要將 MTA 診斷記錄類別設定為無

  1. 啟動 [Exchange 系統管理員]：按一下 [開始]，並依序指向 [所有程式] 及 [Microsoft Exchange] 後，再按 [系統管理員]。

  2. 在主控台樹狀目錄中，展開 [伺服器]，展開您要的伺服器，然後按一下 [內容]。

  3. 在 [<伺服器> 內容] 上，按一下 [診斷記錄]。

  4. 在 [服務] 之下，按一下 [MSExchangeMTA]。

  5. 針對 [類別] 下的每一個項目，先選取類別，然後選取 [記錄級別] 下的 [無]，將記錄級別設定為 [無]。

  6. 將所有類別設定為 [無] 之後，請按一下 [套用]，然後按一下 [確定]。

若需有關 Exchange 2000 Server 及 Exchange Server 2003 中之 MTA 診斷記錄的詳細資訊，請參閱微軟知識庫文件 - 163033＜XCON：MTA 診斷類別說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163033)。

若需有關 Exchange Server 版本 5.5 中之 MTA 診斷記錄的詳細資訊，請參閱知識庫文件 - 163032＜XCON：MTA 診斷記錄描述＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163032)。


MTA 診斷記錄等級是非零值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取一連串的登錄機碼，以判定 Exchange 伺服器上設定的郵件傳輸代理程式 (MTA) 診斷日誌的層級。登錄機碼位於：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Diagnostics

這些機碼的預設值是 0。如果 Exchange Server Analyzer 在這些機碼之中，發現有任何機碼的值大於 1 但小於 6，就會顯示非預設的組態訊息。

這些登錄機碼是您在 [Exchange 系統管理員] 中，於指定之伺服器的內容頁的 [診斷記錄] 索引標籤上調整記錄級別來設定。[Exchange 系統管理員] 允許系統管理員將指定的記錄級別設為 [無]、[最低]、[中] 及 [最高]。登錄機碼的對應值分別是 0、1、3 或 5。

下表顯示在 [Exchange 系統管理員] 的 [診斷記錄] 標籤上列出的 MTA 記錄類別，以及它們在登錄中的對應機碼名稱。

顯示於 [Exchange 系統管理員] 的類別 | 對應的登錄機碼名稱
X.400 服務 | 1 X.400 服務
資源 | 2 資源
安全性 | 3 安全性
介面 | 4 介面
欄位工程 | 5 欄位工程
MTA 系統管理 | 6 MTA 系統管理
組態 | 7 組態
目錄存取 | 8 目錄存取
作業系統 | 9 作業系統
內部處理 | 10 內部處理
交互操作性 | 11 交互操作性
APDU (應用程式通訊協定資料單位) | 12 APDU

位於這份文件結尾的參考資訊提供每一個 MTA 類別記錄哪些內容的相關資訊。

診斷記錄一般的最佳作法，是將每一個 MTA 類別的記錄設為 [無] (0)，除非您正在主動進行疑難排解。此建議的原因是要使記錄的事件維持在能夠管理的數目。即使等級最小 (1) 都可能在短短幾天內產生數百筆事件記錄，視該層級是設定在哪一個類別而定。

如果您目前未進行疑難排解，很可能是這些值在疑難排解操作期間設定太高，且不小心遺留設定。請考慮將每一個 MTA 診斷記錄類別的記錄等級設為 [無] (0)。

若要在 Exchange Server 2003 或 Exchange 2000 Server 上更正這個錯誤

  1. 開啟 [Exchange 系統管理員]。

  2. 在主控台樹狀目錄中，展開 [伺服器]，展開您要的伺服器，然後按一下 [內容]。

  3. 在 [<伺服器> 內容] 中，按一下 [診斷記錄] 索引標籤。

  4. 在 [服務] 之下，選取 MSExchangeMTA。

  5. 針對 [類別] 下的每一個項目，先選取類別，然後選取 [記錄級別] 下的 [無]，將記錄級別設定為 [無]。

  6. 將所有類別設定為 [無] 之後，請按一下 [套用]，然後按一下 [確定]。

若要在 Exchange Server 版本 5.5 上更正此錯誤

  1. 啟動「Microsoft Exchange Server 系統管理員」程式。

  2. 開啟代表 MTA 有問題的伺服器物件。

  3. 在右窗格中對 [郵件傳輸代理程式物件] 按兩下。

  4. 在 [診斷記錄] 索引標籤上，選取 [X.400 服務]，再按一下 [最高]。

  5. 選取 [資源]。

  6. 按住 CTRL 鍵，然後按一下您要偵錯的每一項資源。

  7. 按一下 [選項] 來設定 [無] 記錄等級。

  8. 按一下 [確定]。

若需 Exchange 2000 Server 上的 MTA 診斷記錄的詳細資訊，請參閱微軟知識庫文件 - 163033＜XCON:MTA 診斷類別說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163033)。

若需有關在 Exchange Server 5.5 上復原進階記錄的詳細資訊，請參閱知識庫文件 - 168906＜XCON：在 Exchange 5.0 及 5.5 MTA 上設定進階記錄＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168906)。

若需有關 Exchange Server 5.5 上之 MTA 診斷記錄的詳細資訊，請參閱知識庫文件 - 163032＜XCON：MTA 診斷類別說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163032)。


MTA Dispatcher threads 參數不是預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

錯誤訊息

簡介

MicrosoftR Exchange Server Analyzer 工具會讀取下列登錄項目，來判定其目前的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Dispatcher threads

如果 Exchange Server Analyzer 發現 Dispatcher threads 的值存在且大於零，但卻設為 1 或 2 以外的任何值，則會顯示非預設的組態訊息。

Dispatcher threads 值是郵件傳輸代理程式 (MTA) 發送程式執行緒的值。若是發送程式執行緒的三種子類型 (Router、Fanout、Result)，則此值要乘以 3。建議變更此值的一個原因，是因為 MTA 與站台內 (或站台間) 5 個以上的 Exchange Server 版本 5.5 電腦互相通訊，或經常使用通訊群組清單。在該情況下，建議將值變更為 3。如果此 MTA 不符合此條件，則應將值變更回它的預設設定 1。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右窗格中，尋找 Dispatcher threads 值，然後對它連按兩下。

  4. 在 [數值資料] 欄位中，輸入 1，然後按一下 [確定]。

  5. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange MTA Stacks 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


MTA 不是在 LocalSystem 帳戶之下執行
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Microsoft Exchange MTA Stacks 服務之 StartName 機碼的設定值。Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定目錄中 Exchange Server 物件的 serialNumber 屬性值。Exchange Server 物件的 serialNumber 屬性可識別在以物件來代表的電腦上所執行的 Exchange Server 版本。如果 StartName 機碼的值不等於執行 Exchange 2000 Server 或 Exchange Server 2003 之 Exchange 伺服器上的 LocalSystem，則會顯示錯誤訊息。

在任何其他帳戶之下執行 Exchange MTA Stacks 服務將會造成權限與存取錯誤，而且這不是受支援的組態。

若要解決此錯誤，您必須將 Exchange MTA Stacks 服務設定為在 LocalSystem (也稱為 SYSTEM) 帳戶之下啟動。

附註：
此錯誤不會在 Exchange Server 5.5 版中發生。只有 Exchange 2000 Server 與 Exchange Server 2003 要求在 LocalSystem 帳戶之下執行 Exchange MTA Stacks 服務。

設定 Exchange MTA Stacks 服務帳戶

  1. 開啟 [服務] Microsoft Management Console (MMC) 嵌入式管理單元。

  2. 尋找並停止 Microsoft Exchange MTA Stacks 服務。

  3. 連按兩下 Microsoft Exchange MTA Stacks 服務。

  4. 在 [Microsoft Exchange MTA Stacks 內容] 頁面的 [登入] 索引標籤上，在 [登入身分] 底下選取 [LocalSytem 帳戶]，然後按一下 [套用]。

  5. 在 [服務狀態] 下，按一下 [啟動]，再按 [確定]。

  6. 關閉 [服務] 嵌入式管理單元。

若需在 LocalSystem 帳戶之下執行 Exchange 服務的詳細資訊，請參閱微軟知識庫文件 - 239762＜Exchange Services Run Under LocalSystem＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)。


MTA Kernel threads 參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

MicrosoftR Exchange Server Analyzer 工具會讀取下列登錄項目，來判定其目前的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Kernel threads

如果 Exchange Server Analyzer 發現有 Kernel threads 的值而且大於 0，但設定為 1 或 3 以外的值，就會顯示非預設的組態訊息。

Kernel threads 值是平台執行緒數目，這些執行緒負責「處理開放式系統互連 (OSI)」堆疊的「簡報」層及「工作階段」層。這些執行緒位於郵件傳輸代理程式 (MTA) 郵件處理的核心。如果此 MTA 使用遠端程序呼叫 (RPC) 透過慢速或高度延遲網路連線與許多其他 Exchange Server 版本 5.5 伺服器通訊，建議您使用下表列出的值。

值 | 描述
0x3 (十六進位) | 標準建議。針對使用 RPC 透過慢速或高度延遲網路連線與其他 Exchange Server 5.5 伺服器通訊的任何 MTA，請使用這個值。
0x8 (十六進位) | 針對屬於包含 15 部以上 Exchange Server 5.5 電腦之站台的 Exchange 2000 Server 或 Exchange Server 2003 MTA，請使用這個值。
0xC (十六進位) | 針對屬於包含 30 部以上 Exchange Server 5.5 電腦之站台的 Exchange 2000 Server 或 Exchange Server 2003 MTA，請使用這個值。
重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關如何編輯登錄的詳細資訊，請檢視 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要設定 Kernel threads 值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右窗格中，尋找並連按兩下 Kernel threads 值。

  4. 在 [數值資料] 欄位中，輸入適合組織的值並按一下 [確定]。

  5. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange MTA Stacks 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


MTA LAN-MTAs 參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

MicrosoftR Exchange Server Analyzer 工具會讀取下列登錄項目，來判定其目前的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\LAN-MTAs

如果 Exchange Server Analyzer 發現 LAN-MTAs 的值存在而且已設為 20 以外的值，就會顯示非預設的組態訊息。

LAN-MTAs 值為網路郵件傳輸代理程式 (MTA) 所支援的 MTA 數目。建議您使用 20 作為此登錄的值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右窗格中，尋找 LAN-MTAs 值並且連按兩下。

  4. 在 [數值資料] 欄位中，輸入 20，然後按一下 [確定]。

  5. 結束登錄編輯程式，然後重新啟動 Microsoft Exchange MTA Stacks 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


MTA MDB users 參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

MicrosoftR Exchange Server Analyzer 工具會讀取下列登錄項目，來判定其目前的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\MDB users

如果 Exchange Server Analyzer 發現 MDB users 的值已存在且已設為 500 以外的值，就會顯示非預設的組態訊息。

MDB users 值是郵件傳輸代理程式 (MTA) 支援的最大郵件資料庫 (MDB) 使用者人數。除非已另外明確設定，否則預設所有 Exchange Server 使用者皆為 MDB 使用者。

MDB users 登錄值可定義要從目錄中快取的辨別名稱數目。如果您的組織包含超過 1500 位使用者，則您應該將此值變為全域通訊清單大小的三分之一，但最大值僅限於 5000。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右窗格中，尋找 MDB users 值並且連按兩下。

  4. 在 [數值資料] 欄位中，輸入 500，然後按一下 [確定]。

  5. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange MTA Stacks 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


MTA Max RPC Calls Outstanding 參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

MicrosoftR Exchange Server Analyzer 工具會讀取下列登錄項目，來判定其目前的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Max RPC Calls Outstanding

如果 Exchange Server Analyzer 發現 Max RPC Calls Outstanding 的值存在且設定為 50 以外的值，便會顯示非預設的組態訊息。

Max RPC Calls Outstanding 值是指遠端程序呼叫 (RPC) 執行緒數目上限。這個值限制保證要同時處理的 RPC 數目上限。RpcServerUseAllProtSeqs() 及 RpcServerListen() 會使用此值。

在 Exchange 2000 Server 及/或 Exchange Server 2003 與 Exchange Server 版本 5.5 電腦共存，而且您在 Store.exe 處理程序中增加「閘道輸入/輸出」執行緒數目的最典型混合案例中，建議您將數值資料增加至 0x80 (十六進位) 或 128 (十進位)。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右窗格中，尋找並連按兩下 Max RPC Calls Outstanding 值。

  4. 在 [數值資料] 欄位中，輸入 50，然後按一下 [確定]。

  5. 結束登錄編輯程式，然後重新啟動 Microsoft Exchange MTA Stacks 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


MTA Min RPC threads 參數不是預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

錯誤訊息

簡介

MicrosoftR Exchange Server Analyzer 工具會讀取下列登錄項目，來判定其目前的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Min RPC Threads

如果 Exchange Server Analyzer 發現 Min RPC Threads 的值存在且設為 4 以外的任一值，則會顯示非預設的組態訊息。

Min RPC Threads 值是最小的遠端程序呼叫 (RPC) 執行緒數目。這會識別最小的呼叫執行緒數目。此值是供 RpcServerListen() 所使用。一般而言，您不應修改此登錄值的預設設定。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右窗格中，尋找 Min RPC Threads 值，並對它連按兩下。

  4. 在 [數值資料] 欄位中，輸入 4，然後按一下 [確定]。

  5. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange MTA Stacks 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


MTA RTS 執行緒參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

MicrosoftR Exchange Server Analyzer 工具會讀取下列登錄項目，來判定其目前的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\RTS threads

如果 Exchange Server Analyzer 發現 RTS threads 的值存在，而且大於 0，但不是 1 或 3，就會顯示非預設的組態訊息。

RTS threads 值是處理「可靠的傳輸服務元素 (RTSE)」之「開放式系統互連 (OSI)」堆疊的平台執行緒個數。RTS 執行緒負責將資料放在佇列中。如果這個郵件傳輸代理程式 (MTA) 會與單一站台中或站台之間的多部 Exchange Server 版本 5.5 電腦通訊，則應將 RTS threads 登錄值從預設值 1 調整為 3。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要最佳化 RTS 執行緒登錄值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右窗格中，尋找並連按兩下 RTS threads 值。

  4. 在 [數值資料] 欄位中，輸入適當的值 (1 或 3)，再按一下 [確定]。

  5. 結束登錄編輯程式，然後重新啟動 Microsoft Exchange MTA Stacks 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


MTA 服務未執行
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-02-19

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定下列服務之 Started 機碼的設定值是 True 還是 False：

  • Microsoft Exchange MTA Stacks 服務

  • 叢集服務

值為 False 表示此 Exchange Server 電腦未執行這項服務。值 True 表示服務在執行中。

Exchange Server Analyzer 也會檢查 root\MicrosoftExchangeV2 命名空間內的 Exchange_Server WMI 類別，以判斷 IsFrontEndServer 機碼的值。值 False 表示 Exchange Server 電腦不是前端伺服器。值 True 表示 Exchange Server 電腦是前端伺服器。

如果三個評估的機碼值全部為 False，則會顯示警告。

建議所有以路由傳送郵件的 Exchange Server 電腦都啟動 Exchange MTA Stacks 服務。在混合模式環境中，郵件會在 Exchange Server 版本 5.5 與 Exchange Server 2003 及 (或) Exchange 2000 Server 之間進行傳輸，這尤其重要。此外，所有 X.400 連接器都需要 Exchange MTA Stacks 服務，所以停用此服務會產生錯誤並造成功能失敗。移動信箱也需要啟動 Exchange MTA Stacks 服務。

為了避免此警告，請啟動 Exchange MTA Stacks 服務。

若要啟動 Exchange MTA Stacks 服務

  1. 從 [開始] 功能表，依序選取 [程式集]、[系統管理工具]，然後選取 [服務] Microsoft Management Console (MMC) 嵌入式管理單元。

  2. 以滑鼠右鍵按一下 Microsoft Exchange MTA Stacks 服務，再按一下 [內容]。

  3. 在 [Microsoft Exchange MTA Stacks] 內容頁的 [一般] 索引標籤上，請確定 [啟動類型] 是設為 [自動]。如果不是，請按一下 [套用]，然後按一下 [確定]。

  4. 對 [Microsoft Exchange MTA Stacks] 服務按一下滑鼠右鍵，再按一下 [啟動]。

  5. 關閉 [服務] 嵌入式管理單元。

若需有關在混合模式 Exchange 環境中維持執行 Exchange MTA Stacks 服務的詳細資訊，請參閱微軟知識庫文件 - 810489＜MTA Stacks 服務必須始終 Exchange 2000 及 2003 上啟用＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810489)。


MTA 服務設定為已停用
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Microsoft Exchange MTA Stacks 服務之 StartMode 機碼的設定值。Disabled 這個值表示已停用 Exchange MTA Stacks 服務，要等到 StartMode 值變更為 Manual 或 Automatic 之後才能啟動該服務。

Exchange Server Analyzer 也會查詢 Win32_Service WMI 類別，以判定簡易郵件傳送通訊協定 (SMTP) 服務的 Started 機碼值。值 False 表示服務不在執行中。值 True 表示服務在執行中。

最後，Exchange Server Analyzer 會查詢 Win32_OperatingSystem WMI 類別，以判定 OSProductSuite 機碼的值。此機碼的值對應到 Microsoft Windows Server™ 2003 作業系統的特定版本。

如果 Exchange Server Analyzer 在已啟動 SMTP 服務的 Exchange Server 電腦上發現 StartMode 機碼值設為 Disabled，但 Exchange Server 電腦不是 Microsoft Windows Small Business Server 2003 安裝的一部分，就會顯示警告。

除非該伺服器是 Microsoft Windows Small Business Server 2003 安裝的一部分，或是在純 Exchange Server 2003 原生模式環境中，否則所有路由傳送郵件的 Exchange Server 電腦都必須將 Exchange MTA Stacks 服務設為 [自動]。在停用 Exchange MTA Stacks 服務的伺服器上路由傳送郵件可能會產生各種不同的錯誤訊息。在某些情況下，如果是在仍在執行 Exchange Server 版本 5.5 的 Exchange 2000 Server 或 Exchange Server 2003 環境中執行，則會記錄錯誤。此外，所有 X.400 連接器都需要 Exchange MTA Stacks 服務，所以停用此服務會產生錯誤並造成功能失敗。

附註：
除了與外部 X.400 郵件系統直接連線，或執行 Exchange Development Kit (EDK) 連接器 (例如 Novell GroupWise 連接器、Lotus Notes 連接器) 或執行協力廠商 Fax 連接器，MTA Stacks 服務上的依存性已由 Exchange Server 2003 中移除。因此，Microsoft 現在支援已停用 MTA Stacks 服務、純原生模式的 Exchange Server 2003 部署。

若要解決此錯誤，您必須設定 Exchange MTA Stacks 服務在路由傳送郵件的伺服器上自動啟動。

若要設定 Exchange MTA Stacks 服務自動啟動

  1. 開啟 [服務] Microsoft Management Console (MMC) 嵌入式管理單元。

  2. 連按兩下 Microsoft Exchange MTA Stacks 服務。

  3. 在 [Microsoft Exchange MTA Stacks 內容] 頁面的 [一般] 索引標籤上，從 [啟動類型] 下拉對話方塊選取 [自動]，然後按一下 [套用]。

  4. 在 [伺服器狀態] 下，按一下 [啟動]，再按一下 [OK]。

  5. 關閉 [服務] 嵌入式管理單元。

若需有關在 Exchange 中維持執行 Exchange MTA Stacks 服務的詳細資訊，請參閱微軟知識庫文件 - 810489＜Exchange 2000 Server 和 Exchange Server 2003 的 MTA Stacks 服務支援性方針＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810489)。


MTA Submit/deliver threads 參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

MicrosoftR Exchange Server Analyzer 工具會讀取下列登錄項目，來判定其目前的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\ Submit/deliver threads

如果 Exchange Server Analyzer 發現 Submit/deliver threads 的值已存在且已設為 2 以外的值，就會顯示非預設的組態訊息。

Submit/deliver threads 值為郵件傳輸代理程式 (MTA) 的「提交/傳遞」執行緒數目。MTA 會使用這些執行緒將郵件傳遞至資訊儲存庫。在某些 Exchange Server 版本 5.5 電腦上，Exchange Performance Optimizer 可能已將此值從其預設值 2 自動變更為更適合 Exchange 伺服器的值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關如何編輯登錄的詳細資訊，請檢視 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右窗格中，尋找 Submit/deliver threads 值並且連按兩下。

  4. 在 [數值資料] 欄位中，確定已輸入 2 這個值，並且按一下 [確定]。

  5. 結束登錄編輯程式，然後重新啟動 Microsoft Exchange MTA Stacks 服務，使變更生效。

在 Exchange 2000 Server 與 Exchange Server 2003 電腦上，此項目的值不得大於 3。至於 Exchange Server 5.5 電腦，則有一個取代上述程序的方法，就是您可以在詳細資訊模式中執行 Exchange Performance Optimizer (perfwiz.exe -v) 並使用該工具來設定此值。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需在哪些情況下應變更 MTA Submit/deliver threads 登錄預設值的詳細資訊，請參閱下列知識庫文件：

  • 234280＜XCON：如何增加 MTA 透過慢速網路連線傳遞郵件的能力＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=234280)

  • 265186＜XCON：MTA Fanout 在多處理器伺服器上速度緩慢，而且會在資訊儲存庫中備份郵件＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=265186)

  • 234702＜XGEN:從 MTA 佇列到資訊儲存庫的處理速度緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=234702)

  • 327260＜MTA 在 Exchange Server 5.5 上速度緩慢或停滯，而且會在私人資訊儲存庫中備份郵件＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327260)

  • 若需有關在詳細資訊模式中使用 Exchange Performance Optimizer 的詳細資訊，請參閱知識庫文件 - 246125＜XADM：Exchange Server 5.5 Performance Optimizer 詳細資訊模式＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246125)。


TCP/IP control blocks 參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

錯誤訊息

簡介

MicrosoftR Exchange Server Analyzer 工具會讀取下列登錄項目，來判定其目前的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\TCP/IP control blocks

如果 Exchange Server Analyzer 發現 TCP/IP control blocks 的值存在，而且是設為 20 以外的值，就會顯示一則非預設的組態訊息。

TCP/IP control blocks 值是支援的 RFC1006 (TCP/IP) 同時連線數目上限。此設定控制 X.400 連線可用的緩衝區數目。如果郵件傳輸代理程式 (MTA) 主控了超過一個 X.400 連接器，就應該調整 TCP/IP control blocks 的值。每一個被主控的 X.400 連接器都應該會有 10 個控制區塊，再加上一個用來服務傳入連線的控制區塊。因此對於具有 3 個 X.400 連線的系統來說，適當的值會是 33。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要設定 TCP/IP 控制區塊值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右窗格中，尋找並連按兩下 TCP/IP control blocks 值。

  4. 在 [數值資料] 欄位中，輸入適合此 MTA 的值，然後按一下 [確定]。

  5. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange MTA Stacks 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


MTA TCP/IP threads 參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

錯誤訊息

簡介

MicrosoftR Exchange Server Analyzer 工具會讀取下列登錄項目，來判定其目前的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\TCP/IP threads

如果 Exchange Server Analyzer 發現 TCP/IP threads 的值存在而且已設為 2 以外的值，就會顯示非預設的組態訊息。

TCP/IP threads 值是處理 RFC1006 連線的郵件傳輸代理程式 (MTA) 動態地址模組 (DMOD) 執行緒數目上限。對於 RFC1006 執行緒的兩種子類型 (Driver 和 Async Notify) 來說，這個數目要乘以 2。在 X.400 目錄複寫 Bridgehead 伺服器以及處理大量連線的固定公用資料夾伺服器上，建議將此值從其預設值 2 修改為 10。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關如何編輯登錄的詳細資訊，請檢視 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要設定 TCP/IP threads 值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右窗格中，尋找 TCP/IP threads 值並且連按兩下。

  4. 在 [數值資料] 欄位中輸入適當的值，然後按一下 [確定]。

  5. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange MTA Stacks 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


MTA Transfer threads 參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

錯誤訊息

簡介

MicrosoftR Exchange Server Analyzer 工具會讀取下列登錄項目，來判定其目前的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Transfer threads

如果 Exchange Server Analyzer 發現有 Transfer threads 的值而且大於 0，但設定為 1 或 2 以外的值，就會顯示非預設的組態訊息。

Transfer threads 值是郵件傳輸代理程式 (MTA) Transfer threads 的數目。對於每一個「傳輸」執行緒的兩種子類型來說 (Transfer In 和 Transfer Out)，這個數目要乘以 2。但對於閘道及 MTA 來說，這就相當於 Submit/deliver threads 值 (它與 MTA 及資訊儲存庫郵件傳輸相關)。若需有關 Submit/deliver threads 值的詳細資訊，請參閱 MTA Submit/deliver threads 參數並非預設值。

如果這是與多部 Exchange Server 版本 5.5 電腦 (不論是在站台內還是站台之間) 通訊的 Exchange 2000 Server 或 Exchange Server 2003 MTA，建議您將 Transfer threads 的值調整為 3。

在某些 Exchange Server 5.5 電腦上，Exchange Performance Optimizer 有可能會將這個值從預設值 2 自動變更為更適合 Exchange Server 電腦的值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要設定 Transfer threads 值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右窗格中，尋找並連按兩下 Transfer threads 值。

  4. 在 [數值資料] 欄位中輸入適當的值，然後按一下 [確定]。

  5. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange MTA Stacks 服務，使變更生效。

在 Exchange 2000 Server 及 Exchange Server 2003 電腦上，不可以將此項目的值設定為大於 3。除了上述程序以外，您也可以選擇在詳細資訊模式下執行 Exchange Performance Optimizer (perfwiz.exe -v)，然後使用該工具設定此值。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關在哪些情況下應變更 MTA Transfer threads 預設登錄值的詳細資訊，請參閱下列知識庫文件：

  • 234280＜XCON：如何增加 MTA 透過慢速網路連線傳遞郵件的能力＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=234280)

  • 265186＜XCON：MTA Fanout 在多處理器伺服器上速度緩慢，而且會在資訊儲存庫中備份郵件＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=265186)

  • 327260＜MTA 在 Exchange Server 5.5 上速度緩慢或停滯，而且會在私人資訊儲存庫中備份郵件＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327260)


MTA Transport threads 參數不是預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

錯誤訊息

簡介

MicrosoftR Exchange Server Analyzer 工具會讀取下列登錄項目，來判定其目前的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Transport threads

如果 Exchange Server Analyzer 發現 Transport threads 的值存在且設為 1 以外的值，則會顯示非預設的態組訊息。

Dispatcher threads 值是郵件傳輸代理程式 (MTA) 傳輸執行緒的數目。預設值 1 通常就足夠用於整個組織。除非 Microsoft 產品支援服務特別指示，否則您應將此值保持設定為 1。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

設定 Transport threads 值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. 在右窗格中，尋找 Transport threads 值，並對它連按兩下。

  4. 在 [數值資料] 欄位中，輸入 1，然後按一下 [確定]。

  5. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange MTA Stacks 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


已停用郵件追蹤
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-06

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判斷伺服器物件的 messageTrackingEnabled 內容是否設為 TRUE (已啟用) 或 FALSE (已停用)。

如果 Exchange Server Analyzer 判斷伺服器物件的 messageTrackingEnabled 內容設為 False，便會顯示錯誤。

伺服器物件的 messageTrackingEnabled 內容會判斷伺服器之郵件追蹤中心的狀態。

郵件追蹤中心啟用時會記錄寄件者、郵件訊息及郵件收件者的相關資訊。更明確地說，您可以檢閱郵件的傳送或接收時間、郵件大小與優先順序，以及郵件收件者清單之類的統計資料。郵件追蹤中心會搜尋系統郵件、公用資料夾郵件，以及電子郵件等各種郵件。

您必須在每個要追蹤郵件的伺服器上啟用郵件追蹤中心。一旦啟用它，透過伺服器路由傳送的所有郵件都會新增至郵件追蹤記錄檔。

必須啟用郵件追蹤，Exchange Server Analyzer 才能開始掃描。

附註：
若要執行這項程序，必須具備下列權限：本機 Administrators 群組的成員，以及已在系統管理群組層級套用了 Exchange 系統管理員角色之群組的成員
啟用伺服器的郵件追蹤中心

  1. 在 [Exchange 系統管理員] 中，展開 [伺服器]、在您要啟用郵件追蹤的伺服器上按一下滑鼠右鍵，然後按一下 [內容]。

  2. 在 [一般] 索引標籤上，選取 [啟用郵件追蹤] 核取方塊。

  3. 若要記錄傳入、傳出或經過該伺服器之任何郵件的主旨，請選取 [啟用並顯示主旨記錄] 核取方塊。

    附註：
    若啟用主旨記錄，可能會使效能稍微降低。

  4. 在 [記錄檔維護] 下方，可以防止記錄檔被移除，或修改保留記錄檔的時間長度。追蹤記錄檔的預設保留期間為 7 天。

    附註：
    在處理大量郵件的伺服器上，追蹤記錄檔會膨脹的非常快。請確定記錄檔以及使用該磁碟的其他服務或應用程式有足夠的磁碟空間可用。

  5. 按一下 [確定] 或 [套用]。您不必重新啟動服務，此變更便會生效。

若需如何使用郵件追蹤中心的詳細資訊，請參閱 Microsoft 知識庫文章 262162＜XADM：使用「郵件追蹤中心」來追蹤訊息＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162)。

若需如何疑難排解 Exchange Server 傳輸問題的詳細資訊，請參閱 Microsoft 知識庫文章 821910＜如何疑難排解 Exchange Server 2003 傳輸問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821910)。


郵件追蹤記錄正在寫入壓縮資料夾
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-17

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 類別，以判定郵件追蹤記錄檔路徑的 Compressed 機碼值。若 Exchange Server Analyzer 判定 Compressed 機碼的值是 True，就會顯示一則錯誤。

在 Exchange 2000 Server 或 Exchange Server 2003 電腦上啟用郵件追蹤時，追蹤記錄會寫入下列預設位置：

<drive> :\Program Files\Exchsrvr\ ServerName .log

其中的 <drive> 是包含 \Program Files\Exchsrvr 路徑的磁碟機，ServerName 是 Exchange Server 電腦的主機名稱。

Microsoft 不支援將 Exchange 資料檔案儲存在 NTFS 壓縮磁碟區上。當您將 Exchange 資料檔案儲存在壓縮的磁碟區上時，額外的處理將會顯著影響 Exchange 的效能。此外，在資訊儲存庫資料庫到達某個大小時 (大約 4 GB) 會無法裝載，或甚至損毀。

Exchange 資料檔案包括下列檔案：

  • .edb 檔案

  • .stm 檔案

  • .log 檔案

  • .dat 檔案

  • .eml 檔案

  • .chk 檔案

由「可擴充儲存引擎 (ESE)」管理的檔案，並未設計為要儲存在壓縮的磁碟機上。ESE 依賴磁區獨立性，來進行記錄型的復原，而壓縮檔案會導致破壞磁區獨立性。在主控 ESE 資料庫 (或任何使用預寫記錄的資料庫) 的磁碟區上，都不應該啟動壓縮功能。

在 Exchange 2000 Server Service Pack 3 之前，允許裝載已壓縮的資訊儲存庫資料庫。不過，若是毀損，則會使用 NTFS 壓縮來壓縮所有 Exchange 2000 Server 資訊儲存庫資料庫或資訊儲存庫記錄。

使用 Exchange 2000 Server Service Pack 3，會自動解壓縮 128 MB 或以下的已壓縮資訊儲存庫資料庫檔案。當資料庫檔案成長到超過 128 MB 時，資料庫將無法裝載，並且會在應用程式記錄檔中產生錯誤訊息。Exchange 2000 Server Service Pack 3 會禁止裝載大於 128 MB 的已壓縮資料庫。

若要關閉指定之資料夾的檔案壓縮功能

  1. 以滑鼠右鍵按一下要關閉檔案壓縮功能的資料夾，然後按一下 [內容]。

  2. 在 [一般] 索引標籤中，按一下 [進階]。

  3. 在 [進階屬性] 對話方塊中，清除 [壓縮內容，節省磁碟空間] 核取方塊，然後按一下 [確定]。

除了上述程序外，您也可以將郵件追蹤記錄檔移到另一個沒有壓縮的資料夾中。若需有關移動郵件追蹤記錄檔的詳細資訊，請參閱下列微軟知識庫文件：

  • 84103＜如何在 Exchange Server 2003 中變更郵件追蹤記錄的位置＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=841089)

  • 317700＜如何在 Exchange 2000 Server 中變更郵件追蹤記錄的位置＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700)

若需有關 Exchange 資料檔案及 NTFS 壓縮的詳細資訊，請參閱下列知識庫文件：

  • 170009＜XADM：NTFS 壓縮磁碟區造成儲存區失敗＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=170009)

  • 327772＜XADM：套用 SP3 後不但未裝載資料庫，還收到 0xfffff05b 錯誤＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327772)


將郵件追蹤記錄寫入非 NTFS 磁碟分割
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-17

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Exchange 郵件追蹤記錄檔案路徑的 FSName 機碼值。如果 Exchange Server Analyzer 判定 FSName 機碼的值不等於 NTFS，則會顯示錯誤訊息。

Microsoft 不支援將 Exchange 資料檔案儲存在非 NTFS 磁碟區上。Exchange 資料檔案包含下列所有檔案：

  • .edb 檔案

  • .stm 檔案

  • .log 檔案

  • .dat 檔案

  • .eml 檔案

  • .chk 檔案

如果發生此錯誤，您必須將郵件追蹤記錄移動到 NTFS 磁碟機上的資料夾中。或者，如果儲存郵件追蹤記錄檔的磁碟機已格式化為 FAT 磁碟機，您可以使用 convert.exe 命令列工具將磁碟機轉換為 NTFS。

在 Exchange Server 2003 中移動郵件追蹤記錄

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [系統管理群組]、展開您的系統管理群組、展開 [伺服器]、在伺服器上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 在 [一般] 索引標籤上，按一下 [變更]。

  4. 輸入郵件追蹤記錄的新路徑，再按一下 [確定]。

  5. 按一下 [確定]。
附註：
依預設，追蹤記錄檔位置的修改會在國際標準時間 (UTC) 的午夜生效。此變更生效後，Exchange 郵件追蹤元件會在您指定的新位置中建立新的記錄檔。然而，不會將上一個記錄檔移動到新的位置。因此，等到新記錄檔位置的變更生效後，再手動將記錄檔從舊的位置移動到新的記錄檔位置。如果重新啟動 Microsoft Exchange System Attendant 服務，則會立即將記錄檔路徑變更到新的位置。在此案例中，當使用者傳送郵件時，Exchange 郵件追蹤便會在新的位置中建立新的記錄檔。在此案例中，您可能會有兩個同名的記錄檔：一個記錄檔是位在原始位置中，另一個記錄檔則是位在您指定的新位置中。如果發生此行為，請先將存放在原始記錄檔位置中的記錄檔更名，再將它移動到新的記錄檔位置。使用 Exchange 郵件追蹤所使用的相同命名慣例 (yyyymmdd)。然而，在此狀況下，請使用比任何一個現有記錄檔還早的日期，這樣此更名過的記錄檔才不會干擾未來的記錄檔。

若需有關在執行 Exchange 2000 Server 的電腦上移動郵件追蹤記錄檔的詳細資訊，請參閱微軟知識庫文件 - 317700＜如何在 Exchange 2000 Server 中變更郵件追蹤記錄檔的位置＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700)。

除了上述程序之外，如果儲存檔案的磁碟機已格式化為 FAT 磁碟機，您還可以使用 convert.exe 命令列工具，將磁碟機轉換為 NTFS 格式。若需有關使用 convert.exe 命令列工具將 FAT 磁碟分割轉換為 NTFS 磁碟分割的詳細資訊，請參閱微軟知識庫文件 - 214579＜如何使用 Convert.exe 將磁碟分割轉換為 NTFS 檔案系統＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579)。


正將郵件追蹤記錄寫入加密的資料夾
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-17

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 類別，以判定郵件追蹤記錄檔的 Encrypted 機碼值。如果這個機碼的值是 True，就會顯示一則錯誤。

在 Exchange 2000 Server 或 Exchange Server 2003 電腦上啟用郵件追蹤時，追蹤記錄會寫入下列預設位置：

<drive>:\Program Files\Exchsrvr\ ServerName .log

其中的 <drive> 是包含 \Program Files\Exchsrvr 路徑的磁碟機，ServerName 是 Exchange Server 電腦的主機名稱。

Microsoft 不支援將 Exchange 資料檔案儲存在「加密檔案系統 (EFS)」加密磁碟區上。當您將 Exchange 資料檔案儲存在加密磁碟區上時，額外的處理將會顯著影響 Exchange 的效能。Exchange 資料檔案包括下列檔案：

  • .edb 檔案

  • .stm 檔案

  • .log 檔案

  • .dat 檔案

  • .eml 檔案

  • .chk 檔案

為了協助保護您的 Exchange 資料檔案安全，建議您禁止未經授權者存取 Exchange 電腦，並且使用 S/MIME 郵件格式，將郵件資料加密。

若要關閉所指定資料夾的檔案加密功能

  1. 以滑鼠右鍵按一下您要關閉檔案加密的資料夾，然後按一下 [內容]。

  2. 在 [一般] 索引標籤中，按一下 [進階]。

  3. 在 [進階屬性] 對話方塊中，清除 [加密內容，保護資料] 核取方塊，然後按一下 [確定]。

除了先前的程序外，您也可以將郵件追蹤記錄檔移到另一個未加密的資料夾。若需有關移動郵件追蹤記錄檔的詳細資訊，請參閱下列微軟知識庫文件：

  • 841089＜如何在 Exchange Server 2003 中變更郵件追蹤記錄的位置＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=841089)

  • 317700＜如何在 Exchange 2000 Server 中變更郵件追蹤記錄的位置＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700)


無法存取 Metabase
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-02-13

Microsoft® Exchange Server Analyzer 工具會嘗試從網際網路資訊服務 (IIS) Metabase 路徑，讀取簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器執行個體的各種內容：

/LM/SmtpSvc/<SMTP 虛擬伺服器執行個體>

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • Metabase 查詢失敗。

  • Exchange Server 未在 Microsoft Windows NT® Server 4.0 上執行。

此錯誤指出 Exchange Server Analyzer 無法連接至 IIS Metabase。

IIS Metabase 包含影響 Exchange Server 的資訊，例如 HTTP 通訊協定設定、信箱與行動裝置存取的虛擬目錄，以及 HTTP 安全性設定。

若要解決此問題，請驗證 Metabase 的完整性及是否已正確地安裝 IIS。

若要驗證 Metabase 是否完好且是否已正確地安裝 IIS，請參閱下列資源：

  • Microsoft 知識庫文章 240225＜用以修改 Metabase 的 Adsutil 及 MetaEdit 公用程式描述＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240225)。

  • Microsoft 知識庫文章 317678＜HOW TO:在 Exchange 2000 Server 上重新啟動網際網路資訊服務 (IIS)＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317678)。

如果這些資源中的指導無法解決問題，您可能需要解除安裝再重新安裝 IIS。

使用控制台中的 [新增或移除 Windows 元件] 來解除安裝 IIS

  1. 按一下 [開始]，再按 [控制台]。

  2. 按兩下 [新增或移除程式]。

  3. 按一下 [新增/移除 Windows 元件]。

  4. 在 [元件] 清單中，按一下 [應用程式伺服器] 核取方塊。

  5. 按一下 [詳細資料]。

  6. 按一下 [網際網路資訊服務管理員]。

  7. 按 [下一步]。

  8. 解除安裝 IIS 後，按一下 [完成]。
使用控制台安裝 IIS

  1. 按一下 [開始]，再按 [控制台]。

  2. 按兩下 [新增或移除程式]。

  3. 按一下 [新增/移除 Windows 元件]。

  4. 在 [元件] 清單中，按一下 [應用程式伺服器] 核取方塊。

  5. 按一下 [詳細資料]。

  6. 按一下 [網際網路資訊服務管理員] 核取方塊。

  7. 按 [確定] 直到回到 [Windows 元件精靈]。

  8. 請按 [下一步]，然後完成 [Windows 元件精靈]。


MinUserDC 值並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-02-08

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已手動將作為網域主控制站 (PDC) 模擬器的 Active Directory® 目錄服務網域控制站，排除在可供 Exchange 使用的網域控制站清單之外。

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default

如果 Exchange Server Analyzer 發現 MinUserDC 存在並且已設定，就會顯示非預設的組態訊息。

PDC 模擬器是擔任 Active Directory 操作主機角色的電腦，可處理來自 Microsoft Windows NT® Server 4.0 備份網域控制站的複寫要求，並可針對沒有執行 Active Directory 功能用戶端軟體的用戶端，處理所有的密碼更新作業。PDC 模擬器也是網域控制站，因此可供 Exchange 這類的應用程式使用。

Directory Service Access (DSAccess) 是 Exchange 2000 Server 及 Exchange Server 2003 的內部元件，可控制所有 Exchange 元件存取 Active Directory 的方式。DSAccess 的主要功能是維護各種和目錄相關的事件及作業資訊。例如，DSAccess 會探索 Active Directory 拓樸，並且偵測網域控制站和通用類別目錄伺服器是否可用，並且回應查詢。

在預設的情況下，DSAccess 會將 PDC 模擬器電腦包含在它的可用網域控制站清單中。如果非 Exchange 程式大量使用 PDC 模擬器，以 DSAccess 來使用 PDC 模擬器可能會導致 PDC 模擬器電腦發生效能問題，Exchange 伺服器和非 Exchange 程式電腦可能也會發生效能問題。

若要防止這類的效能問題，可以將 MinUserDC 登錄值加入 Exchange 伺服器上的登錄，以強制 DSAccess 先查詢所有其他可用的網域控制站，再查詢具有 PDC 模擬器作業主要角色的網域控制站。

附註：
以 MiniUserDC 登錄值設定的 Exchange 伺服器會先試著使用相同網域中的其他伺服器，因此，建議只有當網站至少包含兩個網域控制站時，才要對包含 Exchange 伺服器的網域設定此組態。
重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要檢查及編輯 MinUserDC 登錄值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default

  3. 尋找 MinUserDC 值，並執行任何必要的變更。如果這個 DWORD 值不存在，您可以手動建立。

  4. 設定給 MinUserDC 登錄項目的數值資料，是可以連絡之網域控制站的數量上限，達到此上限後才連絡 PDC 模擬器。例如，將 MinUserDC 設定為 4，就是設定 DSAccess 只有在共有 4 部網域控制站可以使用時，才會排除 PDC 模擬器。達到這個條件時，就會排除使用 PDC 模擬器，而 DSAccess 只會和剩下的 3 部網域控制站通訊。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關使用 MinUserDC 登錄項目的詳細資訊，請參閱知識庫文件 - 298879＜XADM：當 PDC 模擬器用於 DSAccess 時 Exchange 2000 可能會經歷效能問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298879)。


有 1000 個以上的信箱儲存區存在
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-12-13

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，並計算屬於 msExchPrivateMDB 物件類別的 Microsoft Exchange Information Store 物件數目。如果 Exchange Server Analyzer 判定組織有超過 1,000 個信箱儲存區，就會顯示一則警告。

顯示警告的原因，是存在一個已知的問題：當使用者從 Microsoft Office Outlook® Web Access 2003 透過組織中的前端伺服器來存取其信箱，而組織中的信箱儲存區數超過 1,000 個時，使用者就會無法成功存取。這個問題是由前端 Exchange 伺服器將經過 Proxy 處理的驗證要求轉送給後端 Exchange 伺服器的方式所引起的。

如果有使用者從前端 Exchange 伺服器存取自己的信箱儲存區，而您接獲此警告，就必須執行下列其中一個動作：

  • 取得並安裝微軟知識庫文件 - 899902＜使用者使用 Outlook Web Access 嘗試存取 Exchange Server 2003 前端伺服器時遇到 401 錯誤訊息＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=899902) 中說明的 Exchange Server Hotfix。

  • 可以的話，請將信箱合併成較少的信箱儲存區。

  • 設定前端伺服器使用「基本」驗證來驗證後端伺服器。這份文件的剩餘部分會描述此選項。

根據預設值，Exchange Server 2003 前端伺服器將會使用 Kerberos 驗證，以協助保護前端與後端伺服器之間的使用者認證。如果 Kerberos 驗證失敗，則會記錄警告事件，且前端伺服器會改而嘗試 NTLM。若 NTLM 失敗，就會記錄一則錯誤。30 分鐘後會重試一次 Kerberos 驗證。當 Exchange 2000 Server 或 Exchange Server 2003 前端電腦在 Exchange 2000 Server 後端電腦中進行驗證時，會使用 NTLM。網際網路資訊服務 (IIS) 或 [Exchange 系統管理員] 沒有用來選取驗證機制的使用者介面。

若要設定前端 Exchange 伺服器使用「基本」驗證，您需要在組織中的所有前端伺服器上設定登錄機碼。下列程序解說如何手動設定該機碼。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要設定 Exchange 前端伺服器對 Exchange 後端伺服器使用基本驗證

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

    瀏覽至：= HKEY_LOCAL_MACHINE\System\CurrentControlSet\Service\MSExchangeWeb

  2. 在 MSExchangeWeb 上按一下滑鼠右鍵，指向 [新增]，然後按一下 [機碼]。將新機碼命名為 Dav。

  3. 在新的 Dav 機碼上按一下滑鼠右鍵，指向 [新增]，然後按一下 [DWORD 值]。

  4. 將新的值命名為 UseBasicAuthToBE，然後將該值設為 1。

  5. 開啟 [服務] Microsoft Management Console (MMC) 嵌入式管理單元，在 [IIS 管理服務] 上按一下滑鼠右鍵，再按 [重新啟動]。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


大部分的持續性 store.exe 呼叫正在等候 ESE 的回應
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-13

Microsoft® Exchange Server Analyzer 工具會檢查 Exchange 函數呼叫記錄 (FCL) (即 Store.fcl 檔)，查看是否有事件指出 Microsoft Exchange Information Store 服務 (Store.exe) 對 Exchange 可延伸儲存引擎 (ESE) 發出持續的跨元件呼叫。

持續性呼叫是指 Microsoft Exchange Information Store 服務 (Store.exe) 發給其他元件的要求，且當 Exchange FCL 資料寫入 Store.fcl 檔時，該要求尚未收到回應。

Microsoft Exchange Information Store 位居 ESE 資料庫最上層。ESE 是一種複雜的交易型資料庫引擎。交易是由一連串被視為最小單位 (無法再分割) 的作業所組成。一筆交易中的所有作業若不是全部完成並永久儲存，就是全都沒有執行。

Exchange Server 使用 ESE 做為內嵌的資料庫引擎，用於判斷資料庫結構以及管理記憶體。資料庫引擎會將資料庫快取在記憶體中，方法是將 4 KB 的資料區塊 (分頁) 傳入與傳出記憶體。它會更新記憶體中的分頁，並將新增或更新的分頁寫回磁碟。當要求傳至系統時，資料庫引擎便從記憶體緩衝區擷取資料。如此就不用經常存取磁碟。

雖然快取記憶體中的資料是處理資料最快、最有效率的方式，然而，這也表示當 Exchange 在執行中時，磁碟上的資訊並不全是最新的。最新版的資料庫存在於記憶體中。不過，由於記憶體中的許多變更尚未寫入磁碟，所以資料庫和記憶體並不是同步的。交易記錄磁碟則一定會將每筆交易的相關資訊保持在最新。

如果 Exchange Server Analyzer 在 Store.fcl 記錄檔中發現有事件反映出 Exchange Information Store 服務 (Store.exe) 對 ESE 資料庫發出大量的呼叫，Exchange Server Analyzer 就會顯示錯誤。

當 Microsoft Exchange Information Store 服務 (Store.exe) 所發出的跨元件呼叫在等候回應時，遠端程序呼叫 (RPC) 執行緒會在這些要求的背景做備份，從而導致 Exchange Server 的效能問題，例如造成伺服器對用戶端的回應延遲。

下列狀況會使 Microsoft Exchange Information Store 服務對 ESE 發出持續性呼叫：

  • Exchange 線上磁碟重組。

  • 資料備份。

    附註：
    如果在 Exchange 呼叫追蹤記錄收集期間有資料備份或線上磁碟重組作業進行中，您可以放心忽略此錯誤訊息，因為那是 Exchange Server 效能問題方面的錯誤訊息。
  • 資料庫磁碟機的瓶頸，例如，相較於使用者人數所提供的伺服器容量不足。

  • TEMP 及 TMP 磁碟機的瓶頸。

若要解決這個錯誤，請採取下列步驟：

  • 我們建議的最佳作法是，不要讓備份時段或線上維護與使用者要求的尖峰期間重疊。

  • 確定資料庫磁碟機的狀況良好，而且其 I/O 負載有充足的輸送量。

  • 執行 Exchange Server Analyzer，針對其他伺服器問題進行分析。您可從＜Microsoft Exchange Server Best Practices Analyzer 工具版本 2.7＞(英文) (http://go.microsoft.com/fwlink/?LinkId=34705) 下載 Exchange Server Analyzer。

  • 檢閱本文＜詳細資訊＞一節中的文章。

詳細資訊

若需如何設定線上磁碟重組時段的詳細資訊，請參閱 Microsoft 知識庫文章 244524＜XADM：如何設定 Exchange Server 線上磁碟重組時段＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524)。

若需 Exchange Server 磁碟瓶頸問題的詳細資訊，請參閱偵測到磁碟瓶頸。

若需如何決定 Exchange Server 磁碟大小以及最佳化的詳細資訊，請參閱《最佳化 Exchange Server 2003 的儲存》中的＜如何計算磁碟 I/O 需求＞以及＜多種結構通用的最佳作法＞(英文) (http://go.microsoft.com/fwlink/?linkid=49324)。

若需 ESE 的詳細資訊，請參閱＜可延伸儲存引擎結構＞(英文) (http://go.microsoft.com/fwlink/?linkid=67009)。


大部分的持續性 store.exe 呼叫正在等候 IMAIL 的回應
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-13

Microsoft® Exchange Server Analyzer 工具會檢查 Exchange Server 函數呼叫記錄 (FCL) (即 Store.fcl 檔)，查看是否有事件指出 Microsoft Exchange Information Store 服務 (Store.exe) 對 MAPI 用戶端的 IMAIL 元件發出大量的跨元件呼叫。

持續性呼叫是指 Microsoft Exchange Information Store 服務 (Store.exe) 發給其他元件的要求，且當 Exchange FCL 資料寫入 Store.fcl 檔時，該要求尚未收到回應。

Exchange Server 的 IMAIL 元件是一項彈性的轉換服務，Microsoft Exchange Information Store 服務將其用在網際網路與 MAPI 郵件之間。這樣可以讓使用 RFC-822 或網際網路格式的用戶端，與使用 Exchange Server 內部儲存格式的用戶端 (例如MAPI 用戶端或內部 STORE 工作) 交互操作。

Exchange 使用 IMAIL 機制，將郵件格式 (例如在 [Exchange 系統管理員] 中為網際網路網域定義的格式，或是使用者在 Microsoft Office Outlook® 中為每個收件者指定的格式) 套用至內容。如果未傳遞任何格式參數給 IMAIL，則 IMAIL 會將 MAPI 郵件格式化為 Summary TNEF (S/TNEF) 格式，以便在伺服器之間傳輸。

如果 Exchange Server Analyzer 在 Store.fcl 記錄檔中發現有事件反映出 Microsoft Exchange Information Store 服務 (Store.exe) 對 MAPI 用戶端的 IMAIL 元件發出大量的持續性呼叫，Exchange Server Analyzer 就會顯示錯誤。

當 Microsoft Exchange Information Store 服務 (Store.exe) 所發出的跨元件呼叫在等候回應時，遠端程序呼叫 (RPC) 執行緒會在這些要求的背景做備份，從而導致 Exchange Server 的效能問題，例如造成伺服器對用戶端的回應延遲。

發生下列一或多種狀況時，Microsoft Exchange Information Store 服務就會對 MAPI 用戶端的 IMAIL 元件發出持續性呼叫：

  • IMAIL 嘗試處理郵件或附件中的眾多資料。

  • 太多用戶端要求轉換資料。

  • DSAccess 要求遇到過慢的回應。

  • TEMP 及 TMP 磁碟機上有瓶頸。

  • 正在進行信箱移動。

若要解決這個錯誤，請採取下列步驟：

  • 將信箱移動作業排定在離峰時段進行。

  • 執行 Exchange Server Analyzer，針對其他伺服器問題 (例如郵件及附件大小限制) 進行分析。您可從＜Microsoft Exchange Server Best Practices Analyzer 工具版本 2.7＞(英文) (http://go.microsoft.com/fwlink/?LinkId=34705) 下載 Exchange Server Analyzer。

  • 檢閱本文＜詳細資訊＞一節中的文章。

詳細資訊

若需 Exchange Server 磁碟瓶頸問題的詳細資訊，請參閱＜偵測到磁碟瓶頸＞。

若需如何決定 Exchange Server 磁碟大小以及最佳化的詳細資訊，請參閱《最佳化 Exchange Server 2003 的儲存》中的＜如何計算磁碟 I/O 需求＞以及＜多種結構通用的最佳作法＞(英文) (http://go.microsoft.com/fwlink/?linkid=49324)。

若需 Exchange Server 上郵件大小限制之最佳作法的詳細資訊，請參閱尚未設定最大外寄郵件大小。

若需 DSAccess 及 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》中的＜如何設定 DSAccess 使用者快取＞ (http://go.microsoft.com/fwlink/?LinkId=47576) (英文)。

若需如何疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

若需如何疑難排解資訊儲存庫效能的詳細資訊，請參閱 Microsoft 知識庫文章 257725＜XADM：如何收集診斷資料以進行資訊存放的疑難排解＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。


大部分的持續性 store.exe 呼叫正在等候 LSASS 的回應
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-11

Microsoft® Exchange Server Analyzer 工具會檢查 Exchange Server 函數呼叫記錄 (FCL) (Store.fcl 檔)，查看是否有事件指出從 Microsoft Exchange Information Store 服務 (Store.exe) 對本機安全性驗證伺服器 (Store.exe) 處理程序提出持續性跨元件呼叫的優勢。

持續性呼叫是指 Microsoft Exchange Information Store 服務 (Store.exe) 發給其他元件的要求，且當 Exchange FCL 資料寫入 Store.fcl 檔時，該要求尚未收到回應。

Local Security Authentication Server 處理程序 (Lsass.exe) 是一個安全性子系統，其他處理程序可予以呼叫，用以確認帳戶資訊及登入驗證。

每次只要有 Exchange 用戶端登入，執行 Exchange Server 的伺服器就會傳送要求以查詢用戶端的帳戶安全性識別碼 (SID)，並在 Local Security Authentication Server (Lsass.exe) 處理程序中建立呼叫。

如果 Exchange Server Analyzer 發現 Store.fcl 記錄檔中的事件對本機安全性驗證伺服器 (Lsass.exe) 處理程序反映來自 Microsoft Exchange Information Store 服務 (Store.exe) 之持續性呼叫的優勢，Exchange Server Analyzer 便會顯示錯誤。

當 Microsoft Exchange Information Store 服務 (Store.exe) 所發出的跨元件呼叫在等候回應時，遠端程序呼叫 (RPC) 執行緒會在這些要求的背景做備份，從而導致 Exchange Server 的效能問題，例如造成伺服器對用戶端的回應延遲。

下列狀況會導致從 Microsoft Exchange Information Store 服務對 LSASS 處理程序發出持續性呼叫：

  • 與同時間進行驗證的使用者人數相關的伺服器資源問題。

  • Exchange 伺服器與網域控制站或通用類別目錄伺服器之間的網路延遲。

  • 伺服器資源瓶頸的問題。

若要解決這個錯誤，請採取下列步驟：

  • 考慮實作 NeverPing 參數，如建議使用 'NeverPing' 參數中所述。

  • 檢閱本文＜詳細資訊＞一節中的文章。

詳細資訊

若需 Lsass.exe 處理程序及記憶體使用量的詳細資訊，請參閱 Microsoft 知識庫文章 308356＜在執行 Windows Server 2003 或 Windows 2000 Server 的網域控制站上，Lsass.exe 處理程序使用的記憶體＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)。

若需 Exchange 用戶端登入及 LSASS 問題的詳細資訊，請參閱 Microsoft 知識庫文章 161938＜因為資源鎖死而造成的 Exchange 用戶端登入過慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938)。

若需 Exchange 伺服器與網域控制站或通用類別目錄伺服器之間網路延遲的詳細資訊，請參閱下列 Exchange Server Team 部落格文章＜Exchange 不一定使用本機 GC＞(英文) (http://go.microsoft.com/fwlink/?LinkId=69166)。

附註：
每一個部落格及其 URL 的內容隨時都會變更，不另行通知。

若需伺服器資源瓶頸問題的詳細資訊，請參閱處理器瓶頸。

若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)。

若需如何疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

若需如何疑難排解資訊儲存庫效能的詳細資訊，請參閱 Microsoft 知識庫文章 257725＜XADM：如何收集診斷資料以進行資訊存放的疑難排解＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。


大部分的持續性 store.exe 呼叫正在等候目錄的回應
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-14

Microsoft® Exchange Server Analyzer 工具會檢查 Exchange 函數呼叫記錄 (FCL) (即 Store.fcl 檔)，查看是否有事件指出 Microsoft Exchange Information Store 服務 (Store.exe) 對 Active Directory® 目錄服務發出大量的持續性跨元件呼叫。

持續性呼叫是指 Microsoft Exchange Information Store 服務 (Store.exe) 發給其他元件的要求，且當 Exchange FCL 資料寫入 Store.fcl 檔時，該要求尚未收到回應。

Active Directory 提供了所有的信箱資訊、通訊清單服務以及其他收件者相關資訊。大部分的 Exchange Server 2003 組態資訊也都儲存在 Active Directory 中。

Exchange Server 服務會存取 Active Directory 中儲存的資訊，並將資訊寫入 Active Directory。

如果 Exchange Server Analyzer 在 Store.fcl 記錄檔中發現有事件反映出 Microsoft Exchange Information Store 服務 (Store.exe) 對 Active Directory 發出大量的呼叫，Exchange Server Analyzer 就會顯示錯誤。

當 Microsoft Exchange Information Store 服務 (Store.exe) 所發出的跨元件呼叫在等候回應時，遠端程序呼叫 (RPC) 執行緒會在這些要求的背景做備份，從而導致 Exchange Server 的效能問題，例如造成伺服器對用戶端的回應延遲。

下列狀況會使 Microsoft Exchange Information Store 服務對 Active Directory 發出持續性呼叫：

  • Exchange 伺服器與網域控制站之間的網路延遲。

  • DSAccess 的組態為靜態或不正確。

  • 網域控制站及通用類別目錄超載。

  • Active Directory 拓撲的設計不正確。

若要解決這個錯誤，請採取下列步驟：

  • 執行 Exchange Server Analyzer，針對其他伺服器問題 (例如郵件及附件大小限制) 進行分析。您可從＜Microsoft Exchange Server Best Practices Analyzer 工具版本 2.7＞(英文) (http://go.microsoft.com/fwlink/?LinkId=34705) 下載 Exchange Server Analyzer。

  • 檢查 Active Directory 網域控制站伺服器的效能。

  • 檢閱本文＜詳細資訊＞一節中的文章。

詳細資訊

若需 Exchange 效能及 DSAccess 的詳細資訊，請參閱 Microsoft 知識庫文章 250570＜目錄服務伺服器偵測及 DSAccess 使用＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570)。

若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)。

若需如何疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

若需如何疑難排解資訊儲存庫效能的詳細資訊，請參閱 Microsoft 知識庫文章 257725＜XADM：如何收集診斷資料以進行資訊存放的疑難排解＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。

若需網域控制站效能的詳細資訊，請參閱下列 Windows Server 資源：

  • ＜計劃網域控制站容量＞(英文) (http://go.microsoft.com/fwlink/?LinkId=70191)。

  • 《Windows 2000 Server Active Directory 計劃及部署手冊》中的＜網域控制站的 Active Directory 監視＞(英文) (http://go.microsoft.com/fwlink/?LinkId=70193)。


大部分的持續性 store.exe 呼叫正在等候病毒掃描程式的回應
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-13

Microsoft® Exchange Server Analyzer 工具會檢查 Exchange 函數呼叫記錄 (FCL) (Store.fcl 檔)，查看是否有事件指出從 Microsoft Exchange Information Store 服務 (Store.exe) 對 Virusscan Virus API (VAPI) 提出持續性跨元件呼叫的優勢。

持續性呼叫是指 Microsoft Exchange Information Store 服務 (Store.exe) 發給其他元件的要求，且當 Exchange FCL 資料寫入 Store.fcl 檔時，該要求尚未收到回應。

如果 Exchange Server Analyzer 發現 Store.fcl 記錄檔中的事件對 Virusscan VAPI 元件反映來自 Microsoft Exchange Information Store 服務 (Store.exe) 之持續性呼叫的優勢，Exchange Server Analyzer 便會顯示錯誤。

當 Microsoft Exchange Information Store 服務 (Store.exe) 所發出的跨元件呼叫在等候回應時，遠端程序呼叫 (RPC) 執行緒會在這些要求的背景做備份，從而導致 Exchange Server 的效能問題，例如造成伺服器對用戶端的回應延遲。

下列狀況會導致從 Microsoft Exchange Information Store 服務對 Virusscan VAPI 元件發出持續性呼叫：

  • 病毒掃描程式的更新，導致對資訊儲存庫中的項目重新掃描。

  • 病毒掃描程式的設定錯誤

  • 病毒掃描程式軟體處理大型郵件或附件

若要解決這個錯誤，請採取下列步驟：

  • 將病毒引擎的更新排程在資源消耗較輕的時候，也就是要求離峰時間。

  • 考慮重新安裝病毒掃描軟體，但請在要求離峰期間進行重新安裝。

  • 檢查病毒掃描引擎的組態以取得正確的執行緒組態、檔案層級排除等。請參閱 Microsoft 知識庫文章 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)。

  • 檢閱本文＜詳細資訊＞一節中的文章。

詳細資訊

若需有關通常搭配 Microsoft Exchange Server 2003 使用的病毒掃描程式詳細資訊，請參閱 Microsoft 知識庫文章 - 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)。

若需有關通常搭配 Microsoft Exchange 2000 Server 使用的病毒掃描程式詳細資訊，請參閱 Microsoft 知識庫文章 - 328841＜Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)。

若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)。

若需如何疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

若需如何疑難排解資訊儲存庫效能的詳細資訊，請參閱 Microsoft 知識庫文章 257725＜XADM：如何收集診斷資料以進行資訊存放的疑難排解＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。


大部分的持續性 store.exe 呼叫正在等候 VSS 快照集的回應
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-13

Microsoft® Exchange Server Analyzer 工具會檢查 Exchange 函數呼叫記錄 (FCL) (即 Store.fcl 檔)，查看是否有事件指出 Exchange Information Store 服務 (Store.exe) 對磁碟區陰影複製服務 (VSS) 快照發出持續性跨元件呼叫。

持續性呼叫是指 Microsoft Exchange Information Store 服務 (Store.exe) 發給其他元件的要求，且當 Exchange FCL 資料寫入 Store.fcl 檔時，該要求尚未收到回應。

VSS 是一組 COM API，在其實作的架構中，可以在系統上的應用程式持續寫入磁碟區時，同時執行磁碟區備份。

Microsoft Exchange Server 2003 會使用隨附於 Microsoft Windows Server™ 2003 作業系統的 VSS，來進行 Exchange Server 2003 資料庫及交易記錄檔的磁碟區陰影複製。

VSS 快照集並不是完全獨立於原始資料。通常，系統會根據您定義的時間標記，建立那個時間點的快照集，並確保能將資料回復到該時間點。

如果 Exchange Server Analyzer 在 Store.fcl 記錄檔中發現有事件反映出 Microsoft Exchange Information Store 服務 (Store.exe) 對 VSS 快照集元件發出持續性呼叫，Exchange Server Analyzer 就會顯示最佳作法訊息。

當 Microsoft Exchange Information Store 服務 (Store.exe) 所發出的跨元件呼叫在等候回應時，遠端程序呼叫 (RPC) 執行緒會在這些要求的背景做備份，從而導致 Exchange Server 的效能問題，例如造成伺服器對用戶端的回應延遲。

附註：
如果是故意在 Exchange 呼叫追蹤記錄收集期間的 20 秒內啟動 VSS 快照集，您可以放心忽略此訊息，因為那是 Exchange Server 效能問題方面的訊息。

我們建議的最佳作法是，不要讓備份時段與線上維護或使用者要求的尖峰期間重疊。

詳細資訊

若需 VSS 的詳細資訊，請參閱＜搭配 Exchange Server 2003 使用磁碟區陰影複製服務的最佳作法＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56571)。


MOUNTMGR.SYS 檔的版本不正確
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-02-13

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄機碼，以判定是否已安裝 Microsoft Windows® Server 2003：HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\

Exchange Server Analyzer 也會執行下列查詢：

  • Win32_OperatingSystem Microsoft Windows Management Instrumentation (WMI) 類別，以判定是否已安裝 Windows Server 2003 Service Pack 1。

  • Win32_Service WMI 類別，以判定叢集服務是否正在執行中。

  • Win32_Volume WMI 類別，以判定是否存在磁碟區裝載點。

  • CIM_Datafile WMI 類別，以判定 Mountmgr.sys 的 Version 機碼值是否小於 2443。

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • Mountmgr.sys 的 Version 機碼小於 2443。

  • 伺服器是執行 Windows Server 2003 Service Pack 1 之叢集的節點。

  • 伺服器有磁碟區裝載點。

叢集節點上安裝的 Mountmgr.sys 版本可能會導致磁碟區裝載點失敗。發生這個問題的原因是 Mountmgr.sys 驅動程式中有問題。這是間歇的計時問題，當要裝載至裝載點的磁碟區到來時，便會發生這個問題。

附註：
通常，這個問題不會發生在非叢集環境中。在非叢集環境中，磁碟區裝載處理程序的計時是不同的。

若需這個問題的詳細資訊，請參閱微軟知識庫文件 - 898790＜在您安裝 Windows Server 2003 Service Pack 1 之後，伺服器叢集中磁碟上的磁碟區裝載點可能會間歇地變成無法使用＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790)。


移動 Temp 及 TMP 目錄
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-09-01

Microsoft® Exchange Server Analyzer 工具判定伺服器的 TEMP 及 TMP 資料夾可能不在最佳磁碟效能的位置上。建議您最佳的作法是將 TEMP 及 TMP 資料夾儲存在磁碟子系統上，且此磁碟子系統不與系統資料夾或 Exchange 資料檔共用。

在不同作業期間 (例如郵件轉換、使用大型附件及信箱移動作業)，Microsoft Exchange Information Store 服務會使用 TEMP 及 TMP 資料夾作為暫時儲存區。TEMP 與 TMP 環境變數用於指定需要臨時工作區的應用程式應該使用檔案系統中的哪個資料夾 (例如，哪個路徑)。TEMP 一般是供應用程式 (如 Microsoft Exchange) 使用，而 TMP 一般是供程式開發工具 (如 Microsoft Visual C++®) 使用。每一個變數的路徑通常相對於應用程式或工具的安全性內容。

在非叢集的 Exchange 伺服器上，Exchange 儲存區所使用的 SYSTEM (例如，本機系統) 資料夾對 TEMP 與 TMP 均使用預設環境變數設定 %Systemroot%\Temp。在 Microsoft Windows® 伺服器叢集中執行的 Exchange 虛擬伺服器會使用叢集服務帳戶的環境變數設定，此帳戶是按照特定使用者安全性原則的內容來執行。對於使用者帳戶來說，TEMP 及 TMP 的預設環境變數是設定為 %Userprofile%\Temp。

本文章解釋如何在叢集及非叢集環境中移動 TEMP 及 TMP 目錄。在執行本文章的程序之前，請考量下列建議事項：

  • 為達到最佳效能，建議您不要使用含有 Exchange 所使用之 TEMP 及 TMP 資料夾的作業系統的磁碟。此外，您應該確定這些環境變數是設定為快速磁碟或磁碟子系統上的路徑，例如 RAID 0+1 Spindle Set。

  • 建議您不要使用 TEMP 及 TMP 資料夾所使用的 Exchange 交易記錄磁碟。

若要在非叢集環境中移動 TEMP 或 TMP 資料夾

  1. 使用具有系統管理權限的帳戶登入執行 Exchange Server 的電腦。

  2. 在 [我的電腦] 上按一下滑鼠右鍵，然後選取 [內容]。

  3. 選取 [進階] 索引標籤。

  4. 按一下 [環境變數]。

  5. 在 [系統變數] 區域中，選取 [TEMP] 並按一下 [編輯]。

  6. 在 [變數值] 欄位中，輸入 [TEMP] 環境變數的新路徑，然後按一下 [確定]。

  7. 在 [系統變數] 區域中，選取 [TMP] 並按一下 [編輯]。

  8. 在 [變數值] 欄位中，輸入 [TMP] 環境變數的新路徑，然後按一下 [確定]。

  9. 按一下 [確定] 關閉 [環境變數] 對話方塊，然後按一下 [確定] 關閉 [系統內容] 對話方塊。

  10. 重新啟動伺服器以套用所有變更。
若要在叢集環境中移動 TEMP 或 TMP 資料夾

  1. 以叢集服務帳戶登入叢集中的一個節點。

  2. 在 [我的電腦] 上按一下滑鼠右鍵，然後選取 [內容]。

  3. 選取 [進階]。

  4. 按一下 [環境變數]。

  5. 在 [<帳戶名稱> 的使用者變數] 區域中，選取 [TEMP]，然後按一下 [編輯]。

  6. 在 [變數值] 欄位中，輸入 [TEMP] 環境變數的新路徑，然後按一下 [確定]。

  7. 在 [<帳戶名稱> 的使用者變數] 區域中，選取 [TMP]，然後按一下 [編輯]。

  8. 在 [變數值] 欄位中，輸入 [TMP] 環境變數的新路徑，然後按一下 [確定]。

  9. 按一下 [確定] 關閉 [環境變數] 對話方塊，然後按一下 [確定] 關閉 [系統內容] 對話方塊。

  10. 重新啟動節點以套用變更。

  11. 針對叢集中的每個節點，重複步驟 1 至 10。
重要事項：
您必須對已驗證的使用者帳戶授予新路徑的適當權限，以存取 TMP 與 TEMP 資料夾。
若要對已驗證的使用者群組指定 TMP 或 TEMP 資料夾的權限

  1. 請開啟 Windows 檔案總管，然後找出 TEMP 變數與 TMP 變數指向的資料夾，並於其上按一下滑鼠右鍵，然後按一下 [內容]。

  2. 在 [暫時內容] 對話方塊，按一下 [安全性] 索引標籤，然後按一下 [新增]。

  3. 在 [選取使用者、電話或群組] 對話方塊中，新增 [已驗證的使用者] 群組至物件名稱清單，然後按一下 [確定]。

  4. 按一下 [進階] 以存取進階安全性設定。

  5. 在 [名稱] 清單中選取 [已驗證使用者]，然後按一下 [編輯] 以顯示 [權限項目] 對話方塊。

  6. 使用 [權限] 區域中的欄位，允許下列特殊權限：

    周遊資料夾 / 執行檔案

    建立檔案 / 寫入資料

    建立資料夾 / 附加資料

  7. 按三下 [確定] 以套用權限並結束。

詳細資訊

  • 若需有關 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需有關疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《疑難排解 Microsoft Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


將使用者信箱移至其他伺服器
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-09-06

Microsoft® Exchange Server Analyzer 工具判斷伺服器目前的使用者負載高於其所能有效率地支援的使用者負載。目前的使用者負載造成了效能問題。建議您將使用者移至其他位置，每晚移動一小部份使用者 (通常為全部使用者的 5%)，到效能問題解決為止。

建議這個方法是因為已發生下列其中一個問題：

  • 部分 Exchange 資料庫檔案所在磁碟已到達或超出其輸送量的容量限制。

  • 其他伺服器資源 (如記憶體或 CPU) 已超出容量。

  • 磁碟超出容量，表示目前支援一或多個 Exchange 儲存區的磁碟子系統，其平均磁碟 I/O 延遲超出目前的建議水準。您應將 5% 的使用者移至不同磁碟子系統上的資料庫，到問題解決為止。如果資料庫磁碟機是瓶頸，請將使用者移至位於不同磁碟機的資料庫。如果儲存群組磁碟機是瓶頸，請將使用者移至位於其他資料庫的其他儲存群組。如果有其他資源共用磁碟機，另一個可能的解決方案是減少其他應用程式在這些磁碟機上的負載。

  • 實體伺服器已超出容量。您目前沒有足夠的處理器或記憶體可支援使用者所產生的伺服器負載。您應將 5% 的使用者移至其他伺服器，到效能問題解決為止。

附註：
儘管在進行移動信箱作業期間並不需要 Exchange 用戶端與其信箱中斷連線，但還是建議在 Exchange 用戶端活動低時進行移動 (例如離峰時刻)，以避免可能的服務中斷。
若要在 Exchange Server 2003 上移動信箱

  1. 在想要執行處理程序的 Exchange Server 2003 電腦上啟動 [Exchange 系統管理員]。

  2. 連按兩下 [伺服器]，然後找出使用者信箱所在的伺服器容器。

    例如，若您要從預設的儲存群組及信箱儲存區移動信箱，請連按兩下 [預設儲存群組]，連按兩下 [信箱儲存區]，再按一下 [信箱]。

  3. 在詳細資料窗格中，按一下要移動的信箱。

  4. 在選取的使用者上按一下滑鼠右鍵，再按一下 [Exchange 工作]。

  5. 在 [Exchange 工作精靈] 中，請按 [下一步]。

  6. 在 [可用的工作] 頁面上，按一下 [選取要執行的工作] 下方的 [移動信箱]，再按 [下一步]。

  7. 在 [移動信箱] 頁面上的 [伺服器] 清單中，按一下想要的伺服器，然後在 [信箱儲存區] 清單中，按一下想要的信箱儲存區。

  8. 按 [下一步]。

  9. 設定移動期間發現之損毀郵件的處理方式，然後按 [下一步]。

  10. 按 [下一步]。

詳細資訊

  • 若需有關 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需有關疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《疑難排解 Microsoft Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 若需有關移動 Exchange Server 2003 信箱的詳細資訊，請參閱微軟知識庫文件 - 821829＜在 Exchange Server 2003 中移動信箱＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)。

  • 若需有關在 Exchange 2000 Server 及 Exchange Server 5.5 之間移動信箱的詳細資訊，請參閱微軟知識庫文件 - 328810＜在伺服器之間移動信箱＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810)。


NAS 組態問題
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個儲存群組物件的 msExchESEParamLogFilePath 屬性值。此屬性指定儲存群組中的資料庫所使用的交易記錄檔位置。

Exchange Server Analyzer 也會查詢 Active Directory，以判定每個信箱儲存區之 homeMDBBL 屬性列出的項目數。這個屬性的計數代表信箱儲存區上的信箱數目。

此外，Exchange Server Analyzer 也會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Microsoft Windows Storage Server 2003 Feature Pack 服務 (wssexchmap) 的 Started 機碼值。False 值表示此 Exchange 伺服器上沒有執行 Windows Storage Server 2003 Feature Pack 服務。True 值表示 Windows Storage Server 2003 Feature Pack 服務正在執行中。

如果 Exchange Server Analyzer 判定有任何 msExchESEParamLogFilePath 屬性的值是以 S:\{ 為開頭，而且在具有 1500 個以上信箱的 Exchange Server 電腦上啟動 Windows Storage Server 2003 Feature Pack 服務，便會顯示一則警告。

Windows Storage Server 2003 是 NAS 裝置的 Microsoft 平台。建議與 Exchange Server 2003 搭配使用 Windows Storage Server 2003 儲存配置，該配置與標準的 Exchange Server 配置有些不同。建議的組態是將 Exchange Server 資料庫放在 Windows Storage Server 2003 上，並將交易記錄檔放在 Exchange Server 電腦中的本機磁碟上。

Microsoft 針對三種特定類型的工作量來開發 Windows Storage Server 2003 Feature Pack：

  • 小型工作量：250 個以下的信箱，由一部 Exchange Server 代管，連線至一部 Windows Storage Server 電腦。在此情況下，建議的 Windows Storage Server 組態為 1 GHz 或更快的處理器，512 MB 的 RAM，四顆設定成 RAID-5 磁碟區的 SCSI 或 IDE/SATA 磁碟，以及二張網路介面卡 (NIC)：一張用以連接 LAN，另一張私人 Gigabit Ethernet 介面卡則用以直接連接 Exchange 伺服器。Exchange 資料庫儲存在 RAID-5 磁碟區上；交易記錄檔則保留在 Exchange 伺服器的本機 RAID-1 上。

  • 中型工作量：一個儲存群組中最多有 750 個信箱，由 Exchange Server 及單一 Windows Storage Server 電腦代管。在此組態中，Windows Storage Server 電腦應有一對 1 GHz 或更快的處理器，1 GB 的 RAM，六顆 SCSI 磁碟，以及一對 NIC。磁碟的設定方式如下：用 4 顆磁碟組成一個 RAID-5 陣列以儲存資料庫，並另外設定一個雙磁碟鏡像組以儲存交易記錄檔。

  • 大型工作量：由一或二部 Exchange Server 2003 伺服器代管 1,500 個以下的信箱，分成二個儲存群組。在此組態中，Windows Storage Server 電腦應有二個 1 GHz 或更快的處理器，2 GB 的 RAM，以及總計 14 顆磁碟：10 顆磁碟用於 RAID 0+1 陣列以保存資料庫，另外二組鏡像磁碟用於保存交易記錄檔。

這個警告表示已設定 Exchange Server 電腦使用 Windows Storage Server 2003 進行儲存。使用 Windows Storage Server for Exchange Server 資料儲存庫時，建議同時存取 Exchange Server 的使用者不要超過 1,500 個。

若要更正此警告

  • 執行下列其中一個動作：

    • 將交易記錄檔移至 Exchange Server 電腦中的本機磁碟

    • 將此 Exchange Server 電腦上的部分信箱移到其他 Exchange Server 電腦，讓 Exchange Server 電腦上使用 Windows Storage Server 的信箱不要超過 1,500 個。

若需有關使用 Windows Storage Server2003 Feature Pack 來搭配 Exchange Server 2003 的詳細資訊，請參閱文件《利用 Windows Storage Server 2003 Feature Pack 來管理 Exchange 儲存》(英文) (http://go.microsoft.com/fwlink/?linkid=34942)。

若需進一步資訊，請參閱下列其他資源：

  • 《Windows Storage Server 2003 結構及部署簡介》(英文) (http://go.microsoft.com/fwlink/?linkid=34943)

  • 《使用 Windows Storage Server 2003 建置更安全的儲存》(英文) (http://go.microsoft.com/fwlink/?linkid=34944)

  • 《使用 Exchange Server 2003 合併伺服器》(英文) (http://go.microsoft.com/fwlink/?linkid=47586)


未正確設定 networkAddress 屬性
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 networkAddress 屬性是否包含 ncacn_ip_tcp 字串。如果下列任一條件存在，Exchange Server Analyzer 便會顯示錯誤：

  • ncacn_ip_tcp 字串不存在。

  • ncacn_ip_tcp 字串已損毀。

在 Microsoft Office Outlook® Web Access for Exchange Server 2003 中，前端伺服器會在嘗試連線到 Exchange 後端伺服器時，檢查 networkaddress 屬性值。

附註：
Exchange 2000 Server 則無法使用 Outlook Web Access 這樣做。

前端伺服器需要完整網域名稱 (FQDN) 值。前端伺服器會檢查 networkaddress ncacn_ip_tcp 傳回值中是否有句點。如果下列條件存在，對特定後端伺服器上的信箱發出的連線要求會失敗，而且前端伺服器會將「HTTP 500 內部伺服器錯誤」錯誤訊息傳回給使用者：

  • networkaddress ncacn_ip_tcp 值只是主機名稱或網路基本輸入/輸出系統 (NetBIOS) 名稱。

  • networkaddress ncacn_ip_tcp 值不是 FQDN。

您必須更新 Active Directory 中之伺服器物件上的 networkaddress ncacn_ip_tcp 值，以確保 Outlook Web Access 2003 能正常運作。Exchange Server Analyzer 錯誤訊息中會提供受影響的伺服器名稱。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
附註：
更新 ncacn_ip_tcp 值前，請先閱讀本文章其餘的部分。若要將重新啟動 Exchange Server 服務所造成的停機時間降到最低，您應在重新啟動 Exchange Server 服務前，先執行額外的程序。
若要更新 networkAddress 屬性的 ncacn_ip_tcp 值

  1. 從 Windows 2000 Server 支援工具或 Windows Server 2003 支援工具啟動 ADSI 編輯器工具。

  2. 展開下列節點：

    • 組態容器

    • 組態

    • 服務

    • Microsoft Exchange

    • Organization_Name

    • 系統管理群組

    • Administrative_Group_Name

    • 伺服器

  3. 在 Exchange_Server_Name 上按一下滑鼠右鍵，然後再按 [內容]。

  4. 按一下 [屬性] 清單中的 networkaddress，再按一下[編輯]。

  5. 為 ncacn_ip_tcp 新增值。請使用伺服器的 FQDN，而不是伺服器的 NetBIOS 名稱或主機名稱。

    此值的語法是 ncacn_ip_tcp:FQDN。例如，如果 Exchange 後端伺服器的主機名稱為 EXCHANGE1 且 FQDN 為 EXCHANGE1.contoso.com，請為 ncacn_ip_tcp 使用下列值： ncacn_ip_tcp:EXCHANGE1.contoso.com

  6. 按兩次 [確定] 套用變更。

  7. 重新啟動伺服器上所有的 Exchange Server 服務。

  8. 如果有多個網域控制站，請等待複寫完成後，再嘗試從前端伺服器登入。如果複寫完成後問題仍未解決，請重新啟動前端伺服器的 IIS Admin Service。

如果在後端伺服器上保留主機檔案，以與具有簡短主機名稱的伺服器 IP 位址相互關聯，您還必須更新 UpdateProtocols registry 值。如果使用主機檔案，在重新啟動 Microsoft Exchange System Attendant 時，Exchange Server 可能會將 ncacn_ip_tcp 值變回原始值。如果後端伺服器是叢集式，Exchange Server 可能會在容錯移轉後將 ncacn_ip_tcp 值變回原始值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要在使用主機檔案的後端伺服器上修改 UpdateProtocols 登錄值

  1. 使用登錄編輯程式來設定後端伺服器上的下列登錄值： HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\UpdateProtocols

    附註：
    如果 UpdateProtocols 值不存在，則必須建立這個值。若要這樣做，請遵循下列步驟：

  2. 開啟登錄編輯程式，並尋找下列登錄子機碼： HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\

    1. 在 [Parameters] 上按一下滑鼠右鍵，指向 [新增]，然後按一下 [DWORD 值]。

    2. 鍵入 UpdateProtocols，然後按 ENTER 鍵。

  3. 以滑鼠右鍵按一下 [UpdateProtocols]，再按 [修改]，並在 [數值資料] 欄位中鍵入 0，然後按 [確定]。

  4. 如果您的網路在後端叢集節點上使用 Hosts 檔案，請修改項目的 UpdateProtocols 順序，如下所示：

    與 FQDN 對應的 IPAddress

    與 NetBIOS 對應的 IPAddress

    而非：

    與 NetBIOS 對應的 IPAddress

    與 FQDN 對應的 IPAddress

  5. 重新啟動伺服器上所有的 Exchange Server 服務。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


網路介面效能監視器物件無法使用
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Network Interface 效能物件的 Bytes Total/sec 效能計數器的資料，以分析效能資料。如果計數器未傳回有效的資料，Exchange Server Analyzer 便會顯示基準線訊息。

如果效能資料收集引擎未傳回有效的資料，則發生了下列任意狀況組合：

  • Network Interface 效能物件已停用。

  • Network Interface 效能監視器物件已遺失或已損毀。

  • Exchange Server Analyzer 沒有適當的權限可存取效能物件。

如果某個可擴充的計數器損毀了登錄，或使用 Microsoft Windows® Management Instrumentation (WMI) 的程式修改了登錄，就會發生前兩個狀況。在執行此程序前，請先確認 Exchange Server Analyzer 具有適當的權限。若需有關執行 Exchange Server Analyzer 所需權限的詳細資訊，請參閱包含在 Exchange Server Analyzer 中的說明文件。若需取得 [說明]，請開啟 Exchange Server Analyzer 並按 F1 鍵。

若要更正此錯誤

  1. 確認 Network Interface 效能物件已啟用。

    1. 下載並安裝 Extensible Performance Counter List 工具 (Exctrlst.exe)。您可以在下列位置下載 Exctrlst.exe：「Exctrlst.exe：Extensible Performance Counter List」(英文) (http://go.microsoft.com/fwlink/?LinkId=34436)。

    2. 開啟 Exctrlst.exe，並依序按一下 [Sort Order] 及 [Service]。

    3. 找出要讓效能物件報告的服務，並確認已選取 [Performance Counters Enabled] 核取方塊。

      如果未選取 [Performance Counters Enabled] 核取方塊，請選取此核取方塊，然後重新啟動與效能計數器相關的服務，確認效能計數器可運作。如果效能計數器未運作，或已選取 [Performance Counters Enabled] 核取方塊，請繼續步驟 2。

  2. 依照微軟知識庫文件 - 300956＜如何手動重建效能計數器程式庫值＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) 中的指示，重建遺失或損毀的效能計數器。

  3. 如果遵循此知識庫文件的指示並不能解決問題，則必須以 [修復] 模式重新安裝 Windows 作業系統，並套用最新的 Windows Server Service Pack。


有更新的 MSGTRACK.dll 可用
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-10-05

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可從處理器效能物件的多個效能計數器收集資料，以分析效能資料。

Exchange Server Analyzer 也會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Msgtrak.dll 檔案的 Version 機碼所設定的值。

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • 伺服器正逢高 CPU 使用量。

  • Msgtrak.dll 檔案的 Version 機碼值比 6.0.6373.0 還要早。

此警告指出找到的 Msgtrack.dll 版本可能會導致高 CPU 使用量。此警告也指出找到的 Msgtrack.dll 版本可能會導致 Inetinfo.exe 處理程序顯示非常高的記憶體用量。

若要更正此問題，請取得下列 Microsoft 知識庫文章 811409＜XADM:郵件追蹤可能導致 Inetinfo.exe 處理程序顯示非常高的記憶體用量＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=811409) 所參照的更新。


有更新的 WLDAP32.DLL 可用
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-10-06

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可從處理器效能物件的多個效能計數器收集資料，以分析效能資料。

Exchange Server Analyzer 也會讀取下列登錄項目，以判定正在 Exchange Server 電腦上執行的 Microsoft Windows® 版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 值 4.0 指出 Exchange Server 電腦正在執行 Microsoft Windows NT® Server 4.0。值 5.0 表示 Exchange Server 電腦正在執行 Windows 2000 Server，而值 5.2 則表示 Exchange Server 電腦正在執行 Windows Server™ 2003。

最後，Exchange Server Analyzer 也會查詢 CIM_Datafile Microsoft Windows Management Instrumentation (WMI) 類別，以判定 Wldap32.dll 檔案的 Version 機碼所設定的值。

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • Exchange Server Analyzer 在所分析的伺服器上偵測到高 CPU 使用量。

  • Exchange Server 電腦正在執行 Windows 2000 Server。

  • Wldap32.dll 檔案的 version 機碼值指出比版本 5.0.2195.7044 還要舊的版本。

此警告指出找到的 Wldap32.dll 版本可能會導致 Inetinfo.exe 處理程序在 Windows 2000 Server 系統上耗用 100% 的 CPU。

若要更正此問題，請取得下列 Microsoft 知識庫文章 899019 所參照的更新：＜Inetinfo.exe 處理程序可能在執行 Exchange 2000 Server 的 Windows 2000 Server 電腦上使用 100% 的 CPU 資源＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=899019).


已啟用 NNTP 服務
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定網路新聞傳送通訊協定服務 (NntpSvc) 的 Started 機碼值。值為 True 表示 Network News Transfer Protocol (NNTP) 服務正在此 Exchange 伺服器上執行。

Exchange Server Analyzer 也會在網際網路資訊服務 (IIS) Metabase 中讀取下列內容，以判定是否已為 Exchange 伺服器設定 NNTP 餵送：

/LM/NNTPSVC/1/Feeds

如果 Exchange Server Analyzer 發現 NNTP 服務已啟動，但尚未對伺服器設定餵送，則會顯示警告。

為了節省資源，同時基於一般的安全性因素，請不要對未使用的元件執行任何服務。執行的每一個服務都會使功能對外公開，而可能招來居心不良的使用者進行攻擊。建議您停用所有未使用的服務。

停用 NNTP 服務

  1. 按一下 [開始]、[程式集]、[系統管理工具]，再按一下 [服務]。

  2. 對 [Network News Transfer Protocol (NNTP)] 服務按一下滑鼠右鍵，再按一下 [內容]。

  3. 在 [一般] 索引標籤上，按一下 [停止]。

  4. 在 [啟動類型] 之下，選取 [停用]，再按一下 [確定]。

若需有關保護 Exchange Server 2003 安全的詳細資訊，請參閱《Exchange Server 2003 安全性強化手冊》(英文) (http://go.microsoft.com/fwlink/?linkid=47578)。


沒有 DNS 伺服器可用於測試
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-12-05

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_NetworkAdapterConfiguration Microsoft Windows® Management Instrumentation (WMI) 類別，以取得 Exchange Server 伺服器所嘗試傳送之郵件的目的遠端伺服器的 DNSServerSearchOrder 屬性。這個屬性是伺服器 IP 位址的陣列，用於查詢網域名稱系統 (DNS) 伺服器。

Exchange Server Analyzer 也會查詢 Microsoft Active Directory® 目錄服務，以判定 Exchange 2000 Server 和 Exchange Server 2003 伺服器物件之 protocolCfgSMTPServer 類別的 msExchSMTPExternalDNSServers 屬性值。protocolCfgSMTPServer 類別包含簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器的設定。如果已設定 msExchSMTPExternalDNSServers 屬性，則 SMTP 虛擬伺服器會使用外部 DNS 伺服器。

最後，Exchange Server Analyzer 會使用下列 Exchange 管理命令介面指令程式，來查詢任一目標 Exchange 2007 Transport server role 的 ExternalDNSServers 和 InternalDNSServers 屬性值。ExternalDNSServers 屬性指定伺服器在解析遠端網域時要查詢的外部 DNS 伺服器清單。InternalDNSServers 屬性則指定應用來解析目標伺服器之本機網域名稱的 DNS 伺服器清單。

複製程式碼
get-TransportServer -Identity %ExchangeServerName% -DomainController %DomainControllerName%

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • Exchange Server Analyzer 無法順利擷取 DNSServerSearchOrder 屬性值。此外，該屬性未包含任何資料。

  • 未設定 Exchange 2000 Server 和 Exchange Server 2003 伺服器物件的 msExchSMTPExternalDNSServers 屬性。

  • 目標 Exchange 2007 Transport server role 的 ExternalDNSServers 和 InternalDNSServers 屬性值不含任何資料。

此錯誤指出 Exchange Server Analyzer 無法識別目標 Exchange 伺服器所使用的任何 DNS 伺服器。此外，該狀況會對郵件流程產生不良影響。

造成此狀況的可能原因如下：

  • 目標伺服器上的 DNS 設定不正確。

  • WMI 失敗或無法存取。

若要解決此問題：

  • 檢閱目標伺服器上的 DNS 組態。

  • 確認可存取 Exchange WMI。

確認可存取 Exchange WMI

  1. 請確定已啟動 Exchange 伺服器，且已連接至網路。

  2. 使用 PING 命令，查看是否可以連接 Exchange 伺服器。

  3. 若有防火牆，請檢查遠端程序呼叫 (RPC) 通訊埠是否被封鎖。

  4. 檢查執行 Exchange Server Analyzer 的帳戶之權限。執行 Exchange Server Analyzer 的帳戶，在所掃描的每部 Exchange 伺服器上都必須擁有本機 Administrator 權限。

    或者，您也可以將特定的 WMI 權限授與執行 Exchange Server Analyzer 的帳戶：

    1. 在 Exchange 伺服器上，開啟 [電腦管理] Microsoft Management Console (MMC) 樹狀目錄。

    2. 在 [服務及應用程式] 下的 [WMI 控制] 上按一下滑鼠右鍵，再按一下 [內容]。

    3. 在 [WMI 控制內容] 頁面上按一下 [安全性] 索引標籤，然後展開 [根]。

    4. 選取 CIMV2 資料夾，再按一下 [安全性]。

    5. 在 [安全性 ROOT\CIMV2] 頁面上，新增執行 Exchange Server Analyzer 的帳戶。

  5. 選取您在步驟 4 新增的帳戶。在 [Selected_Account 的權限] 中，於 [允許] 直欄下，選取 [遠端啟用] 及 [讀取安全性]，再按一下 [確定]。

若需有關設定 DNS 以便與 Exchange Server 搭配運作的詳細資訊，請參閱 Microsoft 知識庫文章 322856＜HOW TO：設定 Exchange Server 所需的 DNS＞ (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322856)。

若需有關網路連線問題的詳細資訊，請參閱 Microsoft 知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

若需 Exchange Server Analyzer 連線問題的詳細資訊，請參閱＜Microsoft Exchange Server Best Practices Analyzer 工具疑難排解連線問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56285)。

若需有關通訊埠需求的詳細資訊，請參閱知識庫文章 832017＜Windows Server 系統的服務概觀及網路通訊埠需求＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)。


沒有主帳戶 SID
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-02-14

Microsoft Exchange Analyzer 工具會查詢 Win32_NTLogEvent Microsoft Windows Management Instrumentation (WMI) 類別，以判定過去一小時內是否曾記錄 MSExchangeIS 的「事件 9548」警告。

如果 Exchange Analyzer 發現過去一小時內曾記錄「事件 9548」警告，Exchange Analyzer 就會計算這一小時內所記錄的「事件 9548」警告總數。

最後，如果 Exchange Analyzer 發現過去一小時內曾記錄 20 次以上的「事件 9548」警告，Exchange Analyzer 就會顯示警告。

此警告表示可能有已停用的 Active Directory 目錄服務使用者帳戶與 Exchange Server 信箱相關聯，且該帳戶的 msExchMasterAccountSID 屬性無效。

執行 Microsoft Exchange Server 2003 或 Exchange 2000 Server 之伺服器上的信箱，必須連結到 Active Directory 目錄服務使用者帳戶才能加以使用。只要設定信箱上的 msExchMasterAccountSid Active Directory 屬性，就能夠完成此連結。Exchange 信箱所連結的 Active Directory 帳戶可以處於已啟用或已停用的狀態。只有已停用的帳戶應有具 msExchMasterAccountSid 屬性的使用者。

如果停用的使用者帳戶上的 msExchMasterAccountSid 屬性值為空白或已經損毀，且所建立的存取控制清單 (ACL) 中包含該使用者帳戶，則使用 ACL 存取信箱或公用資料夾資源時，可能會發生效能問題。

若要更正此警告：

  • 請確認 Exchange Server 2003 Service Pack 2 (SP2) 安裝了 Microsoft 知識庫文章 916783＜已有 Hotfix 可變更 Exchange Server 2003 SP2 處理與 Exchange Server 2003 信箱關聯的已停用 Active Directory 使用者帳戶的方式＞(機器翻譯) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=916783) 所提及的 Hotfix。

  • 檢查「事件 9548」警告中所提及的 ACL 和使用者帳戶，以判定 msExchMasterAccountSid 屬性值是否為空白或已損毀；如有需要，請遵循 Microsoft 知識庫文章 328880＜如何疑難排解 Exchange 2000 和 Exchange 2003 中與 ACL 轉換相關的公用資料夾效能問題＞(機器翻譯) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328880) 中的指導，為帳戶產生有效的 msExchMasterAccountSID 屬性值。

  • 遵循 Microsoft 知識庫文章 278966＜無法移動或登入至 Exchange 資源信箱＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=278966) 中的指導，從 ACL 移除已停用的使用者帳戶。

詳細資訊

如需此問題的相關資訊，請參閱下列 Microsoft 知識庫文章和 Exchange Server 資源：

  • 事件和錯誤訊息中心：事件詳細資料：MSExchangeIS 信箱儲存區事件 9548 詳細資料 (英文) (http://go.microsoft.com/fwlink/?LinkId=83135)

  • Microsoft 知識庫文章 916783＜已有 Hotfix 可變更 Exchange Server 2003 SP2 處理與 Exchange Server 2003 信箱關聯的已停用 Active Directory 使用者帳戶的方式＞(機器翻譯) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=916783)

  • Microsoft 知識庫文章 328880＜如何疑難排解 Exchange 2000 和 Exchange 2003中與 ACL 轉換相關的公用資料夾效能問題＞(機器翻譯) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=842273)

  • Microsoft 知識庫文章 278966＜無法移動或登入至 Exchange 資源信箱＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=278966)


找不到 SMTP 執行個體
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-08-08

Microsoft® Exchange Server Analyzer 工具會查詢 protocolCfgSMTPServer 物件類別的 Active Directory® 目錄服務 distingushedName 屬性，以判定簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器執行個體是否正在針對使用者指定的 Exchange 閘道伺服器名稱執行。

如果 Exchange Server Analyzer 找不到使用者指定之 Exchange 閘道伺服器的 SMTP 虛擬服務執行個體，則 Exchange Server Analyzer 會顯示錯誤。

此錯誤可能是由暫時網路問題所引起的，但也可能指出 Active Directory 中有不正確的資訊。

若要解決此問題，請檢閱使用者指定之 Exchange 閘道伺服器的 SMTP 虛擬伺服器組態。

檢視 SMTP 虛擬伺服器執行個體組態

  1. 啟動 [Exchange 系統管理員]：

    按一下 [開始]，並依序指向 [所有程式] 及 [Microsoft Exchange] 後，再按一下 [系統管理員]。

  2. 瀏覽至下列容器：

    \Administrative Groups\GroupName\Servers\ServerName\Protocols\SMTP\SMTP Virtual Server Instance\

  3. 在您想要的 SMTP 虛擬伺服器執行個體上按一下滑鼠右鍵，然後選取 [內容]。

  4. 驗證 SMTP 虛擬伺服器執行個體組態是否正確。

若需有關 SMTP 虛擬伺服器設定的詳細資訊，請參閱下列知識庫文件：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=266686)。

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)。

若需 SMTP 服務設計的詳細資訊，請參閱《Exchange Server 2003 技術參考手冊》中的＜SMTP 服務設計＞(英文) (http://go.microsoft.com/fwlink/?LinkId=58876) 。

若需網路連線問題的詳細資訊，請參閱 Microsoft 知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。


已手動覆寫 NSPI 目標伺服器
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來判斷是否已手動覆寫名稱服務提供者介面目標伺服器 (NSPI 目標伺服器) 服務：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\NSPI Target Server

如果 Exchange Server Analyzer 發現 NSPI Target Server 存在且已設定，就會顯示非預設的組態訊息。

不同類型的用戶端會以不同的方式來使用網域控制站及通用類別目錄伺服器，以取得全域通訊清單 (GAL) 的存取權。Microsoft Outlook® 2000 Service Release 2 (SR-2) 之前的 Exchange 用戶端預期會尋找 Exchange 伺服器上的目錄服務。Exchange 2000 Server 及 Exchange Server 2003 會使用名稱為「目錄服務 Proxy (DSProxy)」的機制，代表用戶端來與最近的通用類別目錄伺服器建立連線，並建立 Outlook 與通用類別目錄伺服器間的 Proxy 通訊。您可能要明確指定應該用來處理 DSProxy 要求的特定通用類別目錄伺服器 (視您的部署需求而定)。若要執行此作業，您可以硬式編碼 Exchange 伺服器登錄中的 NSPI Target Server 項目。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

手動指定 NSPI 伺服器

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 建立名稱為 NSPI Target Server 的新 REG_MULTISZ 值。

  4. 使用您想要指定之伺服器的完整網域名稱來設定 NSPI Target Server 值。

若要停用 NSPI 伺服器的靜態設定，請移除想要移除之伺服器的完整網域名稱項目。如果只輸入一個 NSPI 目標伺服器，請刪除 NSPI Target Server 登錄值。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Outlook 2000 SR-2 及更新版本的用戶端如何與 Active Directory® 目錄服務互動的詳細資訊，請參閱下列知識庫文件：

  • 302914＜XCCC:Outlook 2000 如何存取 Active Directory＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914)

  • 256976＜XCLN：MAPI 用戶端如何存取 Active Directory＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976)


已安裝非 Exchange Server MAPI 子系統
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定下列兩個資料夾中的 MAPI32.dll 版本：

<drive>:\Program Files\Exchsrvr\Bin

%Systemroot%\System32

如果在這兩個資料夾中找不到相同版本的 MAPI32.dll 與複本，就會顯示一則錯誤。

為了確保使用的是單一 MAPI 版本，Exchange Server 安裝程式會將 MAPI32.dll 複製到 <drive>:\Program Files\Exchsrvr\Bin 與 %Systemroot%\system32 這兩個目錄中。如果 Exchange Server 電腦上安裝了其他 MAPI 應用程式 (如 Microsoft Office Outlook® 2003 或協力廠商程式)，則此類程式可能會將不同版本的 MAPI32.dll 複製到 System32 資料夾，而使 Exchange 功能中斷。發生這些問題是因為這兩種產品的版本造成了 MAPI 子系統的衝突，若不中斷 Exchange Server 或 MAPI 應用程式兩者之一，便無法完全調解。

強烈建議您不要在同一台電腦上安裝 Outlook 2000 (或 Outlook 的更新版本) 與 Exchange Server 2003 (或 Exchange 2000 Server、Exchange Server 5.5)。

一個會將 Outlook 與 Exchange Server 安裝於同一部電腦上的常見原因，就是要在伺服器端程式中利用某些 Outlook 元件。對於大部分程式開發需求而言，Outlook 並不是 Exchange 電腦上的必要程式。Exchange Server 包含 Collaboration Data Object (CDO)，可提供類似於 Outlook 物件模型的功能。CDO 的設計專供伺服器端使用，還可避免 Outlook 更新版本中存在的衝突問題。如需詳細資訊，請參閱微軟知識庫文件 - 290500＜OL2002：電子郵件安全性功能的開發人員資訊＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=290500)。

另一個常見原因是建立 MAPI 設定檔的需求。Exchange Server 包含建立 MAPI 設定檔所需的一切功能，因此不需要 Outlook。如需在不安裝 Outlook 的情況下建立 MAPI 設定檔的作法詳細資訊，請參閱知識庫文件 - 306962＜如何在不安裝 Outlook 的情況下建立 MAPI 設定檔＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306962)。

如果您為了示範目的而必須將 Outlook 與 Exchange Server 安裝於同一部電腦，建議您使用下列其中一個經過測試的示範用組態：

  • Exchange 2000 Server 與 Outlook 2000 搭配使用

  • Exchange 2000 Server 與 Outlook 2002 搭配使用

若要更正此錯誤

  1. 從 Exchange 伺服器中解除安裝 Microsoft Outlook 或協力廠商 MAPI 應用程式。

  2. 重新執行 Exchange Server 安裝程式，並且按一下 [重新安裝]。

如需在同一部電腦上使用 Microsoft Office Outlook 2003 及 Microsoft Exchange Server 的詳細資訊，請參閱微軟知識庫文件 - 266418＜XCCC：Microsoft 不建議將 Exchange 2000 Server 及 Outlook 2000 或更新版本安裝在同一部電腦上＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266418)。

如需解決 MAPI 衝突的詳細資訊，請參閱知識庫文件 - 229700＜如何在 Microsoft Outlook 中找出 Mapisvc.inf 檔案的正確路徑＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=229700)。

若需有關 MAPI32 虛設常式程式庫的詳細資訊，請參閱＜郵件 API (MAPI)＞(英文) (http://go.microsoft.com/fwlink/?linkid=34395)。


偵測到非 Microsoft ESE 引擎
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Ese.dll (Exchange 資料庫儲存引擎，又稱為「可擴充儲存引擎 (ESE)」) 的 Version 機碼值。

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定物件類別為 msExchExchangeServer 的所有物件之 serialNumber 屬性值。若字串值包含 Version 5.5，表示電腦執行的是 Microsoft Exchange Server 5.5。若字串值包含 Version 6.0，表示電腦執行的是 Microsoft Exchange 2000 Server。若字串值包含 Version 6.5，表示電腦執行的是 Microsoft Exchange Server 2003。

如果 Exchange Server Analyzer 發現 Version 的值沒有包含 6 的子字串來做為其版本資訊的一部份，但是 serialNumber 的值指示已安裝 Exchange 2000 Server 或 Exchange Server 2003，就會顯示一則警告。這個警告指出這部 Exchange Server 電腦上已安裝並使用非 Microsoft 程式版本的 Ese.dll。您應該立即更正這個問題。

造成這個問題的可能原因之一是使用了 ESE 型的防毒軟體。某些 ESE 型的防毒程式會在 Exchange 資訊儲存庫及 ESE 之間，使用不受支援的介面。當您使用這類軟體時，如果軟體實作時發生錯誤，您就會冒著資料庫損毀及資料喪失的風險。

在安裝期間，ESE 型的掃描器會變更 Microsoft Exchange Information Store 服務，使該服務依賴 ESE 型防毒程式的服務。這樣可確保在 ESE 型防毒程式的服務啟動後，Microsoft Exchange Information Store 服務才會啟動。當 ESE 型的防毒程式啟動時，Exchange Server 隨附的 Ese.dll 版本會暫時重新命名為 Xese.dll，而 ESE 型的防毒程式之 Ese.dll 版本會取代原始的版本。載入 ESE 型防毒程式版的 Ese.dll 之後，Exchange 伺服器所包含的版本就會重新命名回 Ese.dll，而 Microsoft Exchange Information Store 服務就可以完成啟動程序。

強烈建議您絕對不要在 Exchange Server 電腦上，使用非 Microsoft 的 ESE 實作方式。用戶在連絡 Microsoft 產品支援服務時，可能會被要求停用 ESE 型防毒程式，以協助釐清問題，在問題的根本原因診斷出來之後，用戶可以自由重新啟用該軟體。

最廣為使用的 ESE 型防毒程式是 Sybari Software 的 Antigen for Microsoft Exchange。Microsoft 及 Sybari 都同意停用 Sybari Antigen，是判定問題發生原因的有效疑難排解步驟。若要連絡 Sybari Software，請造訪 Sybari Software 網站 (英文) (http://www.sybari.com)。

附註：
以下提供協力廠商網站資訊，協助您找到需要的技術資訊。URL 如有變更，恕不另行通知。

也建議您使用支援病毒掃描應用程式發展介面 (VSAPI) (也稱為「防毒 API (AVAPI)」) 的防毒程式。

若要更正此警告

  1. 執行 Exchange Server 電腦的完整備份。

  2. 在電腦上解除安裝 Exchange Server。

  3. 在電腦上重新安裝 Exchange Server。

  4. 套用 Exchange Server 的最新 Service Pack 及更新。

若需有關在 Exchange Server 上執行防毒軟體的詳細資訊，請參閱下列微軟知識庫文件：

  • 823166＜Overview of Exchange Server 2003 and antivirus software＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)

  • 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)


偵測到非 Microsoft Extensible Storage Engine
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Exchange 資料庫儲存引擎 Ese.dll (亦稱為「可擴充儲存引擎 (ESE)」) 的 Version 機碼值。

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定物件類別為 msExchExchangeServer 之所有物件的 serialNumber 屬性值。若字串值包含 Version 5.5，表示電腦執行的是 Microsoft Exchange Server 5.5。若字串值包含 Version 6.0，表示電腦執行的是 Microsoft Exchange 2000 Server。若字串值包含 Version 6.5，表示電腦執行的是 Microsoft Exchange Server 2003。

如果 Exchange Server Analyzer 發現 Version 值的版本資訊中沒有包含子字串 5.5，但 serialNumber 的值卻表示已安裝 Exchange Server 5.5，就會顯示一則警告。這個警告指出這部 Exchange Server 電腦上已安裝並使用非 Microsoft 程式版本的 Ese.dll。您應該立即更正這個問題。

造成這個問題的可能原因之一是使用了 ESE 型的防毒軟體。某些 ESE 型的防毒程式會在 Exchange 資訊儲存庫及 ESE 之間，使用不受支援的介面。當您使用這類軟體時，如果軟體實作時發生錯誤，您就會冒著資料庫損毀及資料喪失的風險。

在安裝期間，ESE 型的掃描器會變更 Microsoft Exchange Information Store 服務，使該服務依賴 ESE 型防毒程式的服務。這樣可確保在 ESE 型防毒程式的服務啟動後，Microsoft Exchange Information Store 服務才會啟動。當 ESE 型的防毒程式啟動時，Exchange Server 隨附的 Ese.dll 版本會暫時重新命名為 Xese.dll，而 ESE 型的防毒程式之 Ese.dll 版本會取代原始的版本。在載入 ESE 型防毒程式的 Ese.dll 版本之後，Exchange Server 隨附的版本就會重新命名回 Ese.dll，而 Exchange Information Store 服務就會完成啟動處理程序。

強烈建議您絕對不要在 Exchange Server 電腦上，使用非 Microsoft 的 ESE 實作方式。用戶在連絡 Microsoft 產品支援服務時，可能會被要求停用 ESE 型防毒程式，以協助釐清問題，在問題的根本原因診斷出來之後，用戶可以自由重新啟用該軟體。

若要更正此警告

  1. 執行 Exchange Server 電腦的完整備份。

  2. 在電腦上重新安裝 Exchange Server。

  3. 套用 Exchange Server 的最新 Service Pack 及更新，您可以從 Microsoft Exchange Server 網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=21573) 取得這些程式。
  • 若需有關在 Exchange Server 上執行防毒軟體的詳細資訊，請參閱微軟知識庫文件 - 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)。

  • 若需有關使用相同電腦名稱來重建 Exchange Server 5.5 電腦的詳細資訊，請參閱知識庫文件 - 155216＜XADM：如何將 Exchange Server 移至具有相同名稱的新電腦＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=155216)。


未分頁集區超過警告閾值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_PerfRawData_PerfOS_Memory Microsoft Windows® Management Instrumentation (WMI) 類別，以判定目前的 PoolNonpagedBytes 機碼值。Exchange Server Analyzer 所採取的動作，是根據基礎作業系統、Windows Boot.ini 檔中是否有 /3GB 參數，以及此機碼找到的值而定。

下表顯示一個評估矩陣，Exchange Server Analyzer 可使用它來判定此值是否超出指定 Exchange 伺服器的限制範圍。如果符合下表的條件，就會顯示一則警告。

作業系統 | Boot.ini 設定 | 目前的未分頁集區是
Microsoft Windows 2000 Server 或 Advanced Server | /3GB | 100 MB 或更多
Microsoft Windows 2000 Server 或 Advanced Server | 無 | 200 MB 或更多
Microsoft Windows Server™ 2003 | /3GB | 100 MB 或更多
Microsoft Windows Server 2003 | 無 | 200 MB 或更多

PoolNonpagedBytes 機碼值是核心記憶體未分頁集區的大小，以位元組為單位。這個實體系統記憶體區域是用來存放即使未使用，也無法寫入磁碟的物件。此機碼的這個值是最後找到的值。在狀況良好的 Exchange 伺服器上，除非發生備份或還原，否則不應該使用超過 85 MB 的未分頁集區記憶體。

在 Windows 2000 Server 及 Windows 2000 Advanced Server 中，未分頁集區記憶體的最大值是 256 MB。因為未分頁集區記憶體的上限不能增加到超過上述值，所以應該儘快更正此狀況。不論使用何種作業系統或有無 /3GB 參數，Windows 最多只能存取這麼多的未分頁集區記憶體。若 Windows 用盡了核心記憶體，就會顯示錯誤訊息和當機。由於核心記憶體對於系統正常運作很重要，因此您應該嚴密監視核心記憶體。

如果重新啟動 Exchange Server 之後又發生這種狀況，那麼下一步就是正確調整系統，並確定此系統完全使用最新的軟硬體。這包括安裝最新的：

  • Windows 作業系統 Service Pack

  • Exchange Server Service Pack

  • 硬體韌體及驅動程式

  • 系統 BIOS 更新

  • 已安裝並且執行中的任何協力廠商應用程式之更新

如果軟體及硬體更新都無法解決此問題，您應該停用全部的協力廠商軟體，然後重新啟動 Exchange Server 電腦，並且監視核心記憶體。

若要更正此錯誤

  1. 儘快將 Exchange Server 電腦重新開機。

  2. 監視 Memory | Pool Nonpaged Bytes 效能計數器，以確定它沒有超過上述列出的系統閾值。

若需有關正確調整 Exchange Server 的詳細資訊，請參閱下列微軟知識庫文件及白皮書：

  • 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 266096＜XGEN:Exchange 2000 必須具有 1 GB 以上的實體 RAM，才能使用 /3GB 參數＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096)

  • 《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • 《疑難排解 Exchange 2000 Server 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=18177)

  • 《Exchange Server 2003 效能及延展性手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)

若需有關未分頁集區記憶體及相關主題的詳細資訊，請參閱下列知識庫文件：

  • 294418＜32 位元與 64 位元記憶體結構的比較＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=294418)

  • 177415＜如何使用記憶體集區監視器 (Poolmon.exe) 疑難排解核心模式記憶體流失＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=177415)

  • 268343＜Umdhtools.exe：如何使用 Umdh.exe 尋找記憶體流失＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268343)


可用分頁表項目數過低，可能會導致系統不穩定
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 SystemPages 登錄值的設定：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

如果 Exchange Server Analyzer 發現 SystemPages 的值設定為 0，且可用的系統分頁表項目 (PTE) 數目小於 3001，就會顯示警告。

不論安裝的實體 RAM 是多少，Microsoft Windows Server™ 2003 及 Windows® 2000 Server 最多可以直接定址 4 GB 的記憶體位址空間。從處理程序的角度來看，在觀念上，虛擬位址的每一個元素都可以指向實體記憶體的一個位元組。將每一個虛擬位址轉換或對應至相對應的實體位址，是虛擬記憶體管理員 (VMM) 和處理器記憶體管理單元 (MMU) 兩者的共同責任。VMM 執行對應的方式，是將 RAM 劃分為固定大小的頁面框架，然後建立一些系統 PTE 來儲存與這些頁面框架有關的資訊，再將兩者互相對應。系統 PTE 是小型的記憶體核心模式緩衝區，用來與磁碟 I/O 子系統及網路進行通訊。每一個 PTE 代表一個頁面框架，並且其中包含 VMM 用來找出分頁所需要的資訊。

在使用 4 KB 分頁大小的 x86 系列系統上，需要對映 2 GB 位址空間的最大 PTE 數目是 524288 (2 GB/4 KB) 個。在使用 /3GB 參數的類似系統上，要對映 3 GB 位址空間所需要的 PTE 數目是 786432 (3 GB/4 KB) 個。在一般的系統上，此空間的用法如下：

  • 最多保留 50000 個 PTE (大約 195 MB 位址空間) 供一般用途。

  • 其餘會用來對應系統快取、hyperspace、分頁集區、未分頁集區、損毀傾印區域等等。

此 PTE 集區大小是在系統啟動時，依據系統中的實體記憶體數量自動決定。這個集區會夾在分頁集區和未分頁集區之間，同時會隨系統中的實體記憶體數量增長。

系統 PTE 集區久而久之會變得使用過度，並且嚴重分散。這種情況會導致驅動程式無法載入的情形。同時，如果系統 PTE 集區完全耗竭，系統的其他部分會跟著降級，甚至導致無法建立執行緒、系統停滯以及系統當機等問題。

狀況良好的 Exchange Server 電腦應該至少隨時有 5000 個系統 PTE 可供使用。如果可用的系統 PTE 數降到 5000 以下 (但仍維持在 3001 以上)，就會顯示可用的分頁表項目達到警告閾值中所述的警告。當可用的系統 PTE 數降到 3,001 個以下，就會顯示一則錯誤訊息。若要解決這個問題，可以依照下列程序，將 SystemPages 登錄值設定為適合您的 Exchange Server 電腦之作業系統。當您在安裝 1 GB 或更多 RAM 的 Windows Server 2003 上執行 Exchange Server 2003 Service Pack 1 (SP1) 時，建議您將 SystemPages 登錄機碼設為 0。這項建議與 Windows 2000 Server 的建議不同，後者建議將 SystemPages 設為介於 24,000 與 31,000 之間的值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

執行過以下說明的程序之後，您應該監視可用的系統 PTE 數。您可以使用 [Windows 系統監視器] (亦稱為 [效能監視器]) 來監視 Memory | Free System Page Table Entries 效能計數器，以執行這個動作。若在進行以下說明的登錄變更之後，可用的系統 PTE 數目依舊很低，您應該檢查下列事項，確定您的 Exchange Server 電腦已做最佳設定：

  • 驅動程式 驅動程式故障是造成系統 PTE 低的最常見原因。請洽詢您的硬體製造商，確定您的硬體使用的是最新的驅動程式。有時也許可以降級為使用較基本的驅動程式。例如，電腦若執行如 Exchange Server 之類的伺服器型應用程式，通常不需要使用包含所有功能的最進階視訊驅動程式。只要使用較基本的驅動程式就已夠用。從進階的視訊驅動程式切換為基本的視訊驅動程式，應該就會提高可用的系統 PTE 數目。

  • 系統組態 如果您的系統安裝 1 GB 以上的實體記憶體，您應該檢查以確定其 Boot.ini 檔案已正確地設定 /3GB 及 /USERVA=3030 參數，內容詳見下列微軟知識庫文件：

    • 823440＜在 Windows Server 2003 型的系統上安裝 Exchange Server 2003 時，必須使用 /3GB 參數＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440)

    • 810371＜XADM：在 Windows Server 2003 型的 Exchange Server 上使用 /Userva 參數＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371)

  • 事件日誌 檢查 Exchange Server 上的應用程式事件日誌內是否有出現錯誤及警告，特別是 MSExchangeIS 事件 9582 (錯誤及警告)、9665 (警告) 以及 12880 (錯誤)。出現事件 9665 也可能表示 SystemPages 沒有設定為最佳效能。若需有關這些事件的詳細資訊，請參閱知識庫文件 - 325044＜HOW TO：疑難排解 Exchange 2003 及 Exchange 2000 的虛擬記憶體分散＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

若要在 Windows 2000 Server 上更正這個警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. 在右窗格中，連按兩下 SystemPages。

  4. 在 [數值資料] 欄位中，輸入介於 24000 與 31000 (十進位) 之間的值，然後按一下 [確定]。

  5. 關閉登錄編輯程式，然後重新啟動電腦，以使變更生效。

若要在 Windows Server 2003 上更正這個警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. 在右窗格中，連按兩下 SystemPages。

  4. 在 [數值資料] 欄位中，鍵入 0，然後按一下 [確定]。

  5. 關閉登錄編輯程式，然後重新啟動電腦，以使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關最佳化 Exchange Server 記憶體的詳細資訊，請參閱下列知識庫文件：

  • 325044＜HOW TO: 疑難排解 Exchange 2003 及 Exchange 2000 的虛擬記憶體分散＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)

  • 311901＜4GT 調整對系統分頁表項目的效果＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


目前等候病毒掃描的持續性呼叫數目已接近上限
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-13

Microsoft® Exchange Server Analyzer 工具會檢查 Exchange 函數呼叫記錄 (FCL) (即 Store.fcl 檔)，以判定 Microsoft Exchange Information Store 服務 (Store.exe) 目前對 Virus API (VAPI) 元件發出的持續性跨元件呼叫數目。

Exchange Server Analyzer 也會從下列登錄項目查詢 ScanningThreads 機碼，以判定 VAPI 元件呼叫可使用的最大執行緒數目：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

持續性呼叫是指 Microsoft Exchange Information Store 服務 (Store.exe) 發給其他元件的要求，且當 Exchange FCL 資料寫入 Store.fcl 檔時，該要求尚未收到回應。

如果 Exchange Server Analyzer 發現 Exchange Information Store 服務 (Store.exe) 對 VAPI 元件發出的持續性呼叫數目接近所允許的最大執行緒數目，Exchange Server Analyzer 就會顯示錯誤。

當 Microsoft Exchange Information Store 服務 (Store.exe) 所發出的跨元件呼叫在等候回應時，遠端程序呼叫 (RPC) 執行緒會在這些要求的背景做備份，從而導致 Exchange Server 的效能問題，例如造成伺服器對用戶端的回應延遲。

下列狀況會使 Microsoft Exchange Information Store 服務對 VAPI 元件發出持續性呼叫：

  • 病毒掃描程式的更新，導致對資訊儲存庫中的項目重新掃描。

  • 病毒掃描程式的設定錯誤

  • 病毒掃描程式軟體處理大型郵件或附件

若要解決這個錯誤，請採取下列步驟：

  • 將病毒引擎的更新排定在資源消耗較輕的時候，也就是要求離峰期間。

  • 考慮重新安裝病毒掃描軟體，但請在要求離峰期間進行重新安裝。

  • 檢查病毒掃描引擎的組態，以取得正確的執行緒組態、檔案層級排除等。請參閱 Microsoft 知識庫文章 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)。

  • 增加病毒掃描 API 的執行緒計數：

    ScanningThreads 的最佳值為 (2 * NumberOfProcessors) + 1。例如，在安裝二顆處理器的 Exchange Server 的伺服器上，ScanningThreads 的最佳值為 5。

    附註：
    如果啟用「超執行緒」，則 NumberOfProcessors 值會是實體處理器數目的二倍。建議您洽詢您的防毒軟體製造商，以判定應在上述公式中使用實體還是邏輯處理器。
重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
增加執行緒計數

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

  3. 在右窗格中，連按兩下 ScanningThreads。

  4. 輸入上述公式傳回的值。

  5. 關閉 [登錄編輯程式]，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱 Microsoft 知識庫文章 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

  • 檢閱本文＜詳細資訊＞一節中的文章。

詳細資訊

若需有關通常搭配 Microsoft Exchange Server 2003 使用的病毒掃描程式詳細資訊，請參閱 Microsoft 知識庫文章 - 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)。

若需一般搭配 Microsoft Exchange 2000 Server 使用之病毒掃描程式的詳細資訊，請參閱知識庫文章 328841＜Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)。

若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)。

若需如何疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

若需如何疑難排解資訊儲存庫效能的詳細資訊，請參閱 Microsoft 知識庫文章 257725＜XADM：如何收集診斷資料以進行資訊存放的疑難排解＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。

若需超執行緒技術的詳細資訊，請參閱 Intel 網站 (英文) (http://www.intel.com/technology/hyperthread)。

附註：
本主題也提供協力廠商網站資訊，協助您找到需要的技術資訊。URL 如有變更，恕不另行通知。


OABGEN.DLL 檔案遺失
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔是否存在：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個上述檔案遺失，就會顯示一則錯誤。若要解決此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


取得 Exchange Server 5.0 的最新 Service Pack/更新彙總套件
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每一個 Exchange Server 物件的 versionNumber 屬性值。versionNumber 屬性代表電腦中執行的 Exchange Server 版本。

Exchange Server Analyzer 也會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 STORE.EXE 處理程序的 Version 機碼值。如果 Exchange Server Analyzer 判定 STORE.EXE 的 Version 機碼值大於或等於 1460 且小於 1462，就會顯示一則警告。

這個警告指出 Exchange Server 電腦執行的程式碼，不是電腦中執行的 Exchange 版本可用的最新程式碼。

若要更正此警告

  1. 請造訪 Microsoft 下載中心 (英文) (http://go.microsoft.com/fwlink/?LinkId=41361)，下載 Exchange Server 5.0 的最新更新 (2004 年 4 月)。

  2. 請閱讀微軟知識庫文件 - 834130＜Microsoft Exchange Server 5.0 更新彙總套件＞(英文)，來檢閱此更新的詳細資訊 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=841765)。

  3. 製作 Exchange Server 電腦的完整備份。

  4. 套用 2004 年 4 月更新項目。

若要取得 Exchange Server 5.0 Service Pack 2 最新的更新彙總套件，請參閱知識庫文件 - 168858＜XGEN：如何取得 Exchange Server 5.0 U.S. Service Pack 2＞ (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168858)。

若需有關安裝這個及其他 Exchange Server 更新的詳細資訊，請參閱知識庫文件 - 328839＜如何套用 Exchange Service Pack 及 Hotfix＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)。


取得 Exchange Server 5.5 的最新 Service Pack/更新彙總套件
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每一個 Exchange Server 物件的 versionNumber 屬性值。versionNumber 屬性代表電腦中執行的 Exchange Server 版本。

Exchange Server Analyzer 也會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 STORE.EXE 處理程序的 Version 機碼值。如果 Exchange Server Analyzer 判定 STORE.EXE 的 Version 機碼值大於或等於 2653，但小於 2658，就會顯示一則警告。這表示電腦執行的是 Exchange Server 5.5 Service Pack 4 或 Exchange Server 5.5 Service Pack 4 (含 Hotfix)。

這個警告指出 Exchange Server 電腦執行的程式碼，不是電腦中執行的 Exchange 版本可用的最新程式碼。

若要更正此警告

  1. 造訪「Microsoft 下載中心」(英文) (http://go.microsoft.com/fwlink/?LinkId=33456)，以下載 Exchange Server 5.5 的最新更新 (2004 年 5 月)。

  2. 檢閱微軟知識庫文件 - 841765＜2004 年 5 月的 Exchange Server 5.5 更新彙總套件＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=841765)，來檢閱此更新的詳細資訊。

  3. 製作 Exchange Server 電腦的完整備份。

  4. 套用 2004 年 5 月的更新。

若需有關安裝這個更新及其他 Exchange Server 更新的詳細資訊，請參閱微軟知識庫文件 - 328839＜如何套用 Exchange Service Pack 及 Hotfix＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)。


取得 Exchange Server 2003 的最新 Service Pack/更新彙總套件
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每一個 Exchange Server 物件的 versionNumber 屬性值。versionNumber 屬性代表電腦中執行的 Exchange Server 版本。

Exchange Server Analyzer 也會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 STORE.EXE 處理程序的 Version 機碼值。

  • Version 機碼的值 7638 表示 Exchange Server 2003 Service Pack 2

  • Version 機碼的值 7226 表示 Exchange Server 2003 Service Pack 1

  • Version 機碼的值 6944 表示原始版本的 Exchange Server 2003

  • 上列版本之間的值，表示伺服器執行的是 Hotfix 更新版本的 Store.exe 處理程序。

如果 Exchange Server Analyzer 判斷 Store.exe 的 Version 機碼值小於 7638，則會顯示一則警告。

此警告指出 Exchange Server 電腦執行的程式碼，不是電腦中執行的 Exchange Server 版本可用的最新程式碼。

若要更正此警告

  1. 從 Exchange Server 2003 Service Pack 2 網站 (http://go.microsoft.com/fwlink/?LinkId=54751) 下載或訂購 Exchange Server 2003 Service Pack 2。

  2. 於 Exchange Server 2003 Service Pack 2 (SP2) 版本資訊網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=52072) 檢閱 Service Pack 2 版本資訊。

  3. 建立 Exchange Server 電腦的完整備份。

  4. 套用 Exchange Server 2003 Service Pack 2。

若需有關安裝這個更新及其他 Exchange Server 更新的詳細資訊，請參閱微軟知識庫文件 - 328839＜如何套用 Exchange Service Pack 及 Hotfix＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)。


取得 Exchange 2000 Server 的最新 Service Pack/更新彙總套件
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每一個 Exchange Server 物件的 versionNumber 屬性值。versionNumber 屬性代表電腦中執行的 Exchange Server 版本。

Exchange Server Analyzer 也會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 STORE.EXE 處理程序的 Version 機碼值。如果 Exchange Server Analyzer 判定 STORE.EXE 的 Version 機碼的值在下列其中一個範圍中，將會顯示警告：

  • 大於 6249 且小於或等於 6396

  • 大於 6396 且小於或等於 6487

  • 大於 6487 且小於或等於 6556

  • 大於 6556 且小於或等於 6603

  • 大於 6603 且小於 6700

這個警告指出 Exchange Server 電腦執行的程式碼，不是電腦中執行的 Exchange 版本可用的最新程式碼。

若要更正此警告

  1. 從「Exchange 2000 Server 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457) 下載最新更新項目 (2004 年 8 月)。

  2. 請檢閱微軟知識庫文件 - 870540＜2004 年 8 月 Exchange 2000 Server Post-Service Pack 3 更新彙總套件的可用性＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540)，來檢閱有關最新更新項目的詳細資訊。

  3. 製作 Exchange Server 電腦的完整備份。

  4. 套用 2004 年 8 月更新項目。

若需有關安裝這個及其他 Exchange Server 更新的詳細資訊，請參閱知識庫文件 - 328839＜如何套用 Exchange Service Pack 及 Hotfix＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)。


已刪除離線通訊錄伺服器
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-12-03

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定離線通訊錄組態物件的 offLineABServer 屬性值。如果 Exchange Server Analyzer 發現 offLineABServer 屬性的值包含 DEL: 字串，就會顯示錯誤。

offLineABServer 屬性為由單一值組成的辨別名稱屬性，其會儲存負責產生離線通訊錄之 Exchange Server 電腦的辨別名稱。針對每一個離線通訊錄，Exchange 會產生離線通訊錄檔案並儲存在指定伺服器上的一組公用資料夾內。此錯誤表示在離線通訊錄組態物件的 offLineABServer 屬性中指定的伺服器不存在。如果舊的離線通訊錄伺服器已除役或已從拓撲中錯誤地移除，就會發生這種情況。要等到您指定新的伺服器之後，Exchange 才會產生離線通訊錄。

在 Exchange 2000 Server 及 Exchange Server 2003 更正此錯誤

  1. 在 [Exchange 系統管理員] 中的 [收件者] 之下，按一下 [離線通訊清單]。在右窗格中，在 [預設離線通訊清單] (或產生這封郵件的任何其他離線通訊清單) 上按一下滑鼠右鍵，然後按一下 [內容]。

  2. 在 [一般] 索引標籤上，在 [離線通訊清單伺服器] 下，按一下 [瀏覽]，然後按一下要使用的伺服器。

對 Exchange Server 2007 更正此警告

  1. 開啟 [Exchange 管理主控台]。

  2. 依序展開 [Microsoft Exchange]、[組織組態]，然後選取 [信箱]。

  3. 在結果窗格中，按一下 [離線通訊錄] 索引標籤。

  4. 在 [離線通訊錄] 索引標籤上，選取 [預設離線通訊錄]。在執行窗格中，按一下 [移動]，以啟動 [移動離線通訊錄] 精靈。此精靈可讓您移至不同的伺服器產生 OAB。它也會將現有的 OAB 檔案複製至指定的伺服器。

使用 Exchange 管理命令介面來設定將主控離線通訊錄產生的伺服器

  • 執行下列命令：

    複製程式碼
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    其中：<OAB> 是 OAB 的辨別名稱 (DN)、網域\帳戶名稱或 GUID，而 <Server> 則指定執行所選作業的 Exchange 伺服器。

    例如，若要移至 SERVER01. 產生 OAB，請輸入：
複製程式碼
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

若需有關在 Exchange Server 2003 使用離線通訊錄的詳細資訊，請參閱《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595)中的＜設定 Exchange Server 2003 離線通訊錄＞(英文)。

若需有關在 Exchange Server 2007 使用離線通訊錄的詳細資訊，請參閱＜組織組態 > 信箱 > 離線通訊錄＞(英文) (http://go.microsoft.com/fwlink/?LinkId=79247)。


離線通訊錄伺服器正在前端伺服器上執行
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定離線通訊錄組態物件的 offLineABServer 屬性值。offLineABServer 屬性為由單一值組成的辨別名稱屬性，其會儲存負責產生離線通訊錄之 Exchange Server 電腦的辨別名稱。

Exchange Server Analyzer 也會查詢 Exchange_Server Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Exchange 伺服器的 IsFrontEndServer 機碼值。如果 IsFrontEndServer 機碼值為 True，則 Exchange 伺服器就是作為前端伺服器使用。

如果 Exchange Server Analyzer 判定指定的離線通訊錄伺服器也是前端伺服器，就會顯示一則錯誤訊息。

此錯誤表示用於產生離線通訊錄的指定 Exchange 伺服器是前端伺服器。如果指定的離線通訊錄伺服器也是前端伺服器，則離線通訊錄的產生將失敗。應為此工作指定新的伺服器。將執行 Service Pack 2 或更新版本的 Microsoft Exchange 2000 Server 的伺服器指定為前端伺服器時，下列服務將不再執行：

  • DSProxy

  • 離線通訊清單產生

  • 收件者更新服務

  • 空閒及忙碌的工作

  • 信箱清理代理程式

  • Exchange Event Service

  • 站台複寫服務 (SRS)

前端伺服器是為處理來自 Microsoft Office Outlook® Web Access、POP3、IMAP4、Exchange ActiveSync、Outlook Mobile Access，以及設定為使用 RPC over HTTP 之 Outlook 用戶端的傳入用戶端要求而設計的。前端伺服器有時也用於將 SMTP 郵件轉送至內部的 Exchange 伺服器。

若要解決此問題，建議您指定後端 Exchange 伺服器做為離線通訊錄伺服器。

若要更正此錯誤

  1. 開啟 [Exchange 系統管理員]

  2. 在 [收件者] 之下，按一下 [離線通訊清單]。

  3. 在右窗格中，以滑鼠右鍵按一下 [預設離線通訊清單]，再按一下 [內容]。

    附註：
    請針對產生此訊息的任何其他離線通訊清單使用相同的程序。

  4. 在 [一般] 索引標籤上，於 [離線通訊清單伺服器] 下，按一下 [瀏覽]，再按一下要使用的後端 Exchange 伺服器。

若需有關如何使用離線通訊錄的詳細資訊，請參閱《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595) 中的＜設定 Exchange Server 2003 離線通訊錄＞(英文)。


離線通訊錄站台公用資料夾已刪除
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-12-03

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個公用資料夾儲存區物件的 siteFolderServer 屬性值。如果 Exchange Server Analyzer 發現 siteFolderServer 屬性的值包含 DEL: 字串，就會顯示錯誤。

siteFolderServer 屬性代表離線通訊錄伺服器使用的公用資料夾儲存區。在預設的情況下，Exchange Server 會在「站台資料夾伺服器」(在系統管理群組中安裝的第一部伺服器) 上，產生離線通訊錄檔案。如果您指定別的伺服器作為離線通訊錄伺服器，則這個屬性中列出的公用資料夾儲存區，將會成為新的離線通訊錄伺服器上的儲存區，而不是位在系統管理群組中實際「站台資料夾伺服器」上的儲存區。

當 Exchange Server 2003 產生離線通訊錄檔案時，它會將檔案附加在郵件訊息中，並且將郵件放在特殊的公用資料夾內。Microsoft Office Outlook® 2003 會從資料夾擷取郵件並下載附件檔。

離線通訊錄郵件儲存在 [離線通訊錄] 資料夾的子資料夾中，[離線通訊錄] 資料夾是預設的 [公用資料夾] 樹狀目錄的其中一個系統資料夾。這個資料夾內會包含子資料夾，對應到您的拓撲內的每一個系統管理群組或站台。在預設的情況下，特定系統管理群組資料夾的內容複本，會放在系統管理群組中安裝的第一部伺服器 (稱為「站台資料夾伺服器」) 上。

如果您的 Exchange 組織是 Exchange Server 2007，沒有向下層級 (Outlook 2003 或更舊版本) 用戶端，您可以安全地捨棄此警告或錯誤。如果您的 Exchange Server 2007 組織正在主控執行 Outlook 2003 或更舊版本的用戶端，請遵循以下程序，啟用離線通訊錄檔案的公用資料夾發佈。公用資料夾發佈是一種發佈方法，執行 Outlook 2003 或更舊版本且離線工作或透過撥號連線工作的用戶端會使用此方法存取 OAB。

若要更正此錯誤

  1. 如果您知道該伺服器已存在，請在 [Exchange 系統管理員] 的 [伺服器] 下，依序展開伺服器、儲存群組，然後按一下 [公用資料夾儲存區]。檢查右窗格以確定 Exchange 儲存區在執行中。

  2. 若要指定新的離線通訊錄伺服器，請在 [收件者] 之下，按一下 [離線通訊清單]。然後在右窗格中按一下 [預設離線通訊清單] (或產生此訊息的任何其他離線通訊清單)。

    如果不要使用離線通訊錄，請在 [預設離線通訊錄] 上按一下滑鼠右鍵，然後按一下 [刪除]。不然的話，使用本程序的其餘動作設定排程。

  3. 在 [預設離線通訊清單] 上按一下滑鼠右鍵，然後按一下 [內容]。

  4. 在 [一般] 索引標籤中的 [離線通訊錄伺服器] 之下，按一下 [瀏覽] 選取一部伺服器。

對 Exchange Server 2007 更正此警告

  1. 開啟 [Exchange 管理主控台]。

  2. 依序展開 [Microsoft Exchange]、[組織組態]，然後選取 [信箱]。

  3. 在結果窗格中，按一下 [離線通訊錄] 索引標籤。

  4. 在 [離線通訊錄] 索引標籤上，選取 [預設離線通訊錄]。

    1. 若要啟用離線通訊錄的公用資料夾發佈，請從 [發佈] 索引標籤選取 [啟用公用資料夾發佈]。

    2. 按一下 [確定]，儲存變更。

  5. 若要指定新的離線通訊錄伺服器，請從執行窗格按一下 [移動]，以啟動 [移動離線通訊錄] 精靈。此精靈可讓您移至不同的伺服器產生 OAB。它也會將現有的 OAB 檔案複製至指定的伺服器。

使用 Exchange 管理命令介面，啟用離線通訊錄檔案的公用資料夾發佈。

  • 執行下列命令：

    複製程式碼
    Set-OfflineAddressBook -Identity <OAB> -PublicFolderDistributionEnabled $true

    其中：<OAB> 是 OAB 的辨別名稱 (DN)、網域\帳戶名稱或 GUID。

    例如，若要啟用預設離線通訊錄的公用資料夾發佈，請輸入：
複製程式碼
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -PublicFolderDistributionEnabled $true

使用 Exchange 管理命令介面來設定將主控離線通訊錄產生的伺服器

  • 執行下列命令：

    複製程式碼
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    其中：<OAB> 是 OAB 的辨別名稱 (DN)、網域\帳戶名稱或 GUID，而 <Server> 則指定執行所選作業的 Exchange 伺服器。

    例如，若要移至 SERVER01. 產生 OAB，請輸入：
複製程式碼
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

若需有關在 Exchange Server 2003 使用離線通訊錄的詳細資訊，請參閱《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595)中的＜設定 Exchange Server 2003 離線通訊錄＞(英文)。

若需有關在 Exchange Server 2007 使用離線通訊錄的詳細資訊，請參閱＜組織組態 > 信箱 > 離線通訊錄＞(英文) (http://go.microsoft.com/fwlink/?LinkId=79247)。


偵測到較舊的 CDO.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 Microsoft Exchange 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


偵測到較舊的 DAVEX.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 Microsoft Exchange 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


偵測到較舊的 DRVIIS.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-10-06

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定數個核心 Exchange 二進位檔案的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • DrvIis.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現其中任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。舊版號碼指出可能使用過期的檔案。

若要更正此錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。如果在重新安裝模式中執行安裝程式，請只安裝二進位檔案。重新安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，還必須重新安裝所有先前安裝的 Exchange Service Pack 或更新。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 依序按一下 [開始]、[執行]，然後輸入 <drive>:\setup\i386\setup，其中 <drive> 是光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。如果您同意其中的條款，請按一下 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面的 [動作] 欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭、選取 [重新安裝]，再按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


偵測到較舊的 DSACCESS.DLL 檔
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


偵測到較舊的 EMSMTA.EXE 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 Microsoft Exchange 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


偵測到較舊的 EPOXY.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 Microsoft Exchange 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


偵測到較舊的 ESE.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-06-20

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


偵測到較舊的 ESEUTIL.EXE 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 Microsoft Exchange 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


偵測到較舊的 EXCDO.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


偵測到較舊的 EXCHMEM.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 Microsoft Exchange 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


存在較舊的 EXCHMEM.DLL
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定數個核心 Exchange Server 二進位檔的 Version 機碼值。這些檔案包括 Exchmem.dll。如果 Exchange Server Analyzer 判定 \%systemroot%\system32 資料夾中的 Exchmem.dll 檔比 \%exchangeroot%\bin 資料夾中的 Exchmem.dll 更舊，Exchange Server Analyzer 會顯示警告。

通常，伺服器上不會存在兩份 Exchmem.dll。不過，從前版產品就地升級時，有時會加入第二個 Exchmem.dll 檔。存在兩個檔案版本，安裝版本更新服務期間可能會造成安裝程式失敗。若要避免問題，建議您重新命名 \%systemroot%\system32 資料夾中的 Exchmem.dll 檔。

若要更正此警告

  1. 停止所有 Exchange 服務。

  2. 將 \%systemroot%\system32 資料夾中的 Exchmem.dll 檔重新命名為 Exchmem.dll.old。

  3. 重新啟動所有 Exchange 服務。


偵測到較舊的 EXMIME.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


偵測到較舊的 EXOLEDB.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


偵測到較舊的 EXPOP3.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


偵測到較舊的 EXPROX.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 Microsoft Exchange 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


偵測到較舊的 EXRES.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange 2000 Server Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


偵測到較舊的 EXSMTP.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


偵測到較舊的 MAD.EXE 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 Microsoft Exchange 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


偵測到較舊的 MAPI32.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


在 system32 資料夾中偵測到較舊的 MAPI32.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 Microsoft Exchange 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


偵測到較舊的 MDBSZ.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


偵測到較舊的 OABGEN.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 Microsoft Exchange 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


偵測到較舊的 PHATCAT.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


偵測到較舊的 PHATQ.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


偵測到較舊的 REAPI.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要補救這項錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


偵測到較舊的 RESVC.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定用於數個核心 Exchange 二進位檔的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現上述任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼表示可能使用的是過時的檔案。

若要解決此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


偵測到較舊的 STORE.EXE 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-10-06

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定數個核心 Exchange 二進位檔案的 Version 機碼值：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

如果 Exchange Server Analyzer 發現其中任一檔案的 Version 值低於 Exchange Server Version 值，就會顯示一則警告。較早的版本號碼指出可能使用的是過時的檔案。

若要更正此錯誤，請安裝適用您的 Exchange 版本之最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。如果在重新安裝模式中執行安裝程式，請只安裝二進位檔案。重新安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，還必須重新安裝所有先前安裝的 Exchange Service Pack 或更新。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 依序按一下 [開始]、[執行]，然後輸入 <drive>:\setup\i386\setup，其中 <drive> 是光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。如果您同意其中的條款，請按一下 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面的 [動作] 欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭、選取 [重新安裝]，再按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


發現針對 Active Directory 的持續性呼叫
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-14

Microsoft® Exchange Server Analyzer 工具會檢查 Exchange 函數呼叫記錄 (FCL) (即 Store.fcl 檔)，查看是否有事件指出 Microsoft Exchange Information Store 服務 (Store.exe) 對 Active Directory® 目錄服務發出持續性跨元件呼叫。

持續性呼叫是指 Microsoft Exchange Information Store 服務 (Store.exe) 發給其他元件的要求，且當 Exchange FCL 資料寫入 Store.fcl 檔時，該要求尚未收到回應。

Active Directory 提供了所有的信箱資訊、通訊清單服務以及其他收件者相關資訊。大部分的 Exchange Server 2003 設定資訊也都儲存在 Active Directory 中。

Exchange Server 服務會存取 Active Directory 中儲存的資訊，並將資訊寫入 Active Directory。

如果 Exchange Server Analyzer 在 Store.fcl 記錄檔中發現有事件反映出 Microsoft Exchange Information Store 服務 (Store.exe) 對 Active Directory 發出持續性呼叫，Exchange Server Analyzer 就會顯示警告。

此警告指出此伺服器可能會有效能問題。偶爾出現的持續性呼叫並不一定代表有問題，但針對相同區域一再重複的持續性呼叫就有可能是問題。

當 Microsoft Exchange Information Store 服務 (Store.exe) 所發出的跨元件呼叫在等候回應時，遠端程序呼叫 (RPC) 執行緒會在這些要求的背景做備份，從而導致 Exchange Server 的效能問題，例如造成伺服器對用戶端的回應延遲。

下列情況會使 Microsoft Exchange Information Store 服務對 Active Directory 發出持續性呼叫：

  • Exchange 伺服器與網域控制站之間的網路延遲。

  • DSAccess 的組態為靜態或不正確。

  • 網域控制站及通用類別目錄超載。

  • Active Directory 拓撲的設計不正確。

若要對付此警告，請採取下列步驟：

  • 執行 Exchange Server Analyzer，針對伺服器問題進行其他分析。您可從＜Microsoft Exchange Server Best Practices Analyzer 工具版本 2.7＞(英文) (http://go.microsoft.com/fwlink/?LinkId=34705) 下載 Exchange Server Analyzer。

  • 檢查 Active Directory 網域控制站伺服器的效能。

  • 檢閱本文＜詳細資訊＞一節中的文章。

詳細資訊

若需 Exchange 效能及 DSAccess 的詳細資訊，請參閱 Microsoft 知識庫文章 250570＜目錄服務伺服器偵測及 DSAccess 使用＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570)。

若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)。

若需如何疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

若需如何疑難排解資訊儲存庫效能的詳細資訊，請參閱 Microsoft 知識庫文章 257725＜XADM：如何收集診斷資料以進行資訊存放的疑難排解＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。

若需網域控制站效能的詳細資訊，請參閱下列 Windows Server 資源：

  • ＜計劃網域控制站容量＞(英文) (http://go.microsoft.com/fwlink/?LinkId=70191)。

  • 《Windows 2000 Server Active Directory 計劃及部署手冊》中的＜網域控制站的 Active Directory 監視＞(英文) (http://go.microsoft.com/fwlink/?LinkId=70193)。


發現針對 ESE 的持續性呼叫
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-13

Microsoft® Exchange Server Analyzer 工具會檢查 Exchange 函數呼叫記錄 (FCL) (即 Store.fcl 檔)，查看是否有事件指出 Microsoft Exchange Information Store 服務 (Store.exe) 對 Exchange 可延伸儲存引擎 (ESE) 發出持續的跨元件呼叫。

持續性呼叫是指 Microsoft Exchange Information Store 服務 (Store.exe) 發給其他元件的要求，且當 Exchange FCL 資料寫入 Store.fcl 檔時，該要求尚未收到回應。

Microsoft Exchange Information Store 位於可延伸儲存引擎 (ESE) 資料庫的頂端。ESE 是一種複雜的交易型資料庫引擎。交易是由一連串被視為不可部分完成 (無法再分割) 單位的作業所組成。交易中的所有作業不是全部完成並永久儲存，就是全都都沒有執行。

Exchange Server 使用 ESE 做為內嵌資料庫引擎，用於判斷資料庫結構以及管理記憶體。資料庫引擎會將資料區塊 (分頁) 傳入與傳出記憶體，藉此方式將資料庫快取至記憶體。它會更新記憶體中的分頁，並將新增或更新的分頁寫回磁碟。當對系統提出要求時，資料庫引擎便能從記憶體緩衝區擷取資料。如此就不必經常存取磁碟。

雖然快取記憶體中的資料是處理資料最快且最有效率的方式，這也表示當 Exchange 執行時，磁碟上的資訊不可能完全是最新的。最新版的資料庫位在記憶體中。不過，由於記憶體中的許多變更尚未寫入磁碟，所以資料庫和記憶體並不是同步的。交易記錄磁碟一定會保持每筆交易的最新相關資訊。

如果 Exchange Server Analyzer 發現 Store.fcl 記錄檔中的事件對可延伸儲存引擎 (ESE) 資料庫反映來自 Microsoft Exchange Information Store 服務 (Store.exe) 的持續性呼叫，Exchange Server Analyzer 便會顯示警告。

此警告指出此伺服器可能會有效能問題。偶爾出現的持續性呼叫並不一定代表有問題，但針對相同區域一再重複的持續性呼叫就有可能是問題。

當 Microsoft Exchange Information Store 服務 (Store.exe) 所發出的跨元件呼叫在等候回應時，遠端程序呼叫 (RPC) 執行緒會在這些要求的背景做備份，從而導致 Exchange Server 的效能問題，例如造成伺服器對用戶端的回應延遲。

下列狀況會導致從 Microsoft Exchange Information Store 服務對可延伸儲存引擎 (ESE) 發出持續性呼叫：

  • Exchange 線上磁碟重組。

  • 資料備份。

    附註：
    如果在 Exchange 呼叫追蹤記錄收集期間進行資料備份或線上磁碟重組，您可以安心地忽略此警告，因為它只是指出 Exchange 伺服器效能問題。
  • 資料庫磁碟機的瓶頸，例如，相較於使用者人數所提供的伺服器容量不足。

  • TEMP 及 TMP 磁碟機的瓶頸。

若要解決這個錯誤，請採取下列步驟：

  • 我們建議的最佳作法是，不要讓備份時段或線上維護與使用者要求的尖峰期間重疊。

  • 確定資料庫磁碟機的狀況良好，而且其 I/O 負載有充足的輸送量。

  • 執行 Exchange Server Analyzer，針對伺服器問題 (例如郵件及附件大小限制) 進行額外的分析。您可以在 Microsoft Exchange Server Best Practices Analyzer 工具 2.7 版 (英文) (http://go.microsoft.com/fwlink/?LinkId=34705) 網頁下載 Exchange Server Analyzer。

  • 檢閱本文＜詳細資訊＞一節中的文章。

詳細資訊

若需如何設定線上磁碟重組時間範圍的詳細資訊，請參閱 Microsoft 知識庫文章 244524＜XADM：如何設定 Exchange Server 線上磁碟重組時間範圍＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524)。

若需 Exchange Server 磁碟瓶頸問題的詳細資訊，請參閱偵測到磁碟瓶頸。

若需如何決定 Exchange Server 磁碟大小以及最佳化的詳細資訊，請參閱《最佳化 Exchange Server 2003 的儲存》中的＜如何計算磁碟 I/O 需求＞以及＜多種結構通用的最佳作法＞(英文) (http://go.microsoft.com/fwlink/?linkid=49324)。

若需 ESE 的詳細資訊，請參閱＜可延伸儲存引擎結構＞(英文) (http://go.microsoft.com/fwlink/?linkid=67009)。


發現針對 IMail 的持續性呼叫
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-13

Microsoft® Exchange Server Analyzer 工具會檢查 Exchange 函數呼叫記錄 (FCL) (亦即 Store.fcl 檔)，查看是否有事件指出 Microsoft Exchange Information Store 服務 (Store.exe) 對 MAPI 用戶端的 IMAIL 元件發出持續的跨元件呼叫。

持續性呼叫是指 Microsoft Exchange Information Store 服務 (Store.exe) 發給其他元件的要求，且當 Exchange FCL 資料寫入 Store.fcl 檔時，該要求尚未收到回應。

Exchange Server 的 IMAIL 元件是一項彈性的轉換服務，Microsoft Exchange Information Store 服務將其用在網際網路與 MAPI 郵件之間。這樣可以讓使用 RFC-822 或網際網路格式的用戶端，與使用 Exchange Server 內部儲存格式的用戶端 (例如 MAPI 用戶端或內部儲存工作) 交互操作。

Exchange 使用 IMAIL 機制，將郵件格式 (例如在 [Exchange 系統管理員] 中為網際網路網域定義的格式，或是使用者在 Microsoft Office Outlook® 中為每個收件者指定的格式) 套用至內容。如果未傳遞任何格式參數給 IMAIL，則 IMAIL 會將 MAPI 郵件格式化為 Summary TNEF (S/TNEF) 格式，以便在伺服器之間傳輸。

如果 Exchange Server Analyzer 在 Store.fcl 記錄檔中發現有事件反映出 Microsoft Exchange Information Store 服務 (Store.exe) 對 MAPI 用戶端的 IMAIL 元件發出持續性呼叫，Exchange Server Analyzer 就會顯示警告。

此警告指出此伺服器可能會有效能問題。偶爾出現的持續性呼叫並不一定代表有問題，但針對相同區域一再重複的持續性呼叫就有可能是問題。

當 Microsoft Exchange Information Store 服務 (Store.exe) 所發出的跨元件呼叫在等候回應時，遠端程序呼叫 (RPC) 執行緒會在這些要求的背景做備份，從而導致 Exchange Server 的效能問題，例如造成伺服器對用戶端的回應延遲。

發生下列一或多種狀況時，Exchange Information Store 服務就會對 MAPI 用戶端的 IMAIL 元件發出持續性呼叫：

  • IMAIL 嘗試處理郵件或附件中的眾多資料。

  • 太多用戶端要求轉換資料。

  • DSAccess 要求遇到過慢的回應。

  • TEMP 及 TMP 磁碟機上有瓶頸。

  • 正在進行信箱移動。

若要對付此警告，請採取下列步驟：

  • 將信箱移動作業排定在要求量較少的離峰期間進行。

  • 執行 Exchange Server Analyzer，針對其他伺服器問題 (例如郵件及附件大小限制) 進行分析。您可從＜Microsoft Exchange Server Best Practices Analyzer 工具版本 2.7＞(英文) (http://go.microsoft.com/fwlink/?LinkId=34705) 下載 Exchange Server Analyzer。

  • 檢閱本文＜詳細資訊＞一節中的文章。

詳細資訊

若需 Exchange Server 磁碟瓶頸問題的詳細資訊，請參閱＜偵測到磁碟瓶頸＞。

若需如何決定 Exchange Server 磁碟大小以及最佳化的詳細資訊，請參閱《最佳化 Exchange Server 2003 的儲存》中的＜如何計算磁碟 I/O 需求＞以及＜多種結構通用的最佳作法＞(英文) (http://go.microsoft.com/fwlink/?linkid=49324)。

若需 Exchange Server 上郵件大小限制之最佳作法的詳細資訊，請參閱尚未設定最大外寄郵件大小。

若需 DSAccess 及 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》中的＜如何設定 DSAccess 使用者快取＞ (http://go.microsoft.com/fwlink/?LinkId=47576) (英文)。

若需如何疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

若需如何疑難排解資訊儲存庫效能的詳細資訊，請參閱 Microsoft 知識庫文章 257725＜XADM：如何收集診斷資料以進行資訊存放的疑難排解＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。


發現針對 LSASS 的持續性呼叫
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-13

Microsoft® Exchange Server Analyzer 工具會檢查 Exchange 函數呼叫記錄 (FCL) (即 Store.fcl 檔)，查看是否有事件指出 Exchange Information Store 服務 (Store.exe) 對 Local Security Authentication Server (Lsass.exe) 程序發出持續性跨元件呼叫。

持續性呼叫是指 Microsoft Exchange Information Store 服務 (Store.exe) 發給其他元件的要求，且當 Exchange FCL 資料寫入 Store.fcl 檔時，該要求尚未收到回應。

Local Security Authentication Server 處理程序 (Lsass.exe) 是一個安全性子系統，其他處理程序可予以呼叫，用以確認帳戶資訊及登入驗證。

每次只要有 Exchange 用戶端登入，執行 Exchange Server 的伺服器就會傳送要求以查詢用戶端的帳戶安全性識別碼 (SID)，並在 Local Security Authentication Server (Lsass.exe) 處理程序中建立呼叫。

如果 Exchange Server Analyzer 在 Store.fcl 記錄檔中發現有事件反映出 Microsoft Exchange Information Store 服務 (Store.exe) 對 Local Security Authentication Server (Lsass.exe) 處理程序發出持續性呼叫，Exchange Server Analyzer 就會顯示警告。

此警告指出此伺服器可能會有效能問題。偶爾出現的持續性呼叫並不一定代表有問題，但針對相同區域一再重複的持續性呼叫就有可能是問題。

當 Microsoft Exchange Information Store 服務 (Store.exe) 所發出的跨元件呼叫在等候回應時，遠端程序呼叫 (RPC) 執行緒會在這些要求的背景做備份，從而導致 Exchange Server 的效能問題，例如造成伺服器對用戶端的回應延遲。

下列狀況會使 Exchange Information Store 服務對 LSASS 處理程序發出持續性呼叫：

  • 與同時間進行驗證的使用者人數相關的伺服器資源問題。

  • Exchange 伺服器與網域控制站或通用類別目錄伺服器之間的網路延遲。

  • 伺服器資源瓶頸的問題。

若要對付此警告，請採取下列步驟：

  • 考慮實作 NeverPing 參數，如＜建議使用 'NeverPing' 參數＞中所述。

  • 檢閱本文＜詳細資訊＞一節中的文章。

詳細資訊

若需 Lsass.exe 處理程序及記憶體使用量的詳細資訊，請參閱 Microsoft 知識庫文章 308356＜在執行 Windows Server 2003 或 Windows 2000 Server 的網域控制站上，Lsass.exe 處理程序使用的記憶體＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)。

若需 Exchange 用戶端登入及 LSASS 問題的詳細資訊，請參閱 Microsoft 知識庫文章 161938＜因為資源鎖死而造成的 Exchange 用戶端登入過慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938)。

若需 Exchange 伺服器與網域控制站或通用類別目錄伺服器之間網路延遲的詳細資訊，請參閱下列 Exchange Server Team 部落格文章＜Exchange 不一定使用本機 GC＞(英文) (http://go.microsoft.com/fwlink/?LinkId=69166)。

附註：
每一個部落格及其 URL 的內容隨時都會變更，不另行通知。

若需伺服器資源瓶頸問題的詳細資訊，請參閱處理器瓶頸。

若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)。

若需如何疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

若需如何疑難排解資訊儲存庫效能的詳細資訊，請參閱 Microsoft 知識庫文章 257725＜XADM：如何收集診斷資料以進行資訊存放的疑難排解＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。


發現針對病毒掃描的持續性呼叫
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-13

Microsoft® Exchange Server Analyzer 工具會檢查 Exchange 函數呼叫記錄 (FCL) (Store.fcl 檔)，查看是否有事件指出從 Microsoft Exchange Information Store 服務 (Store.exe) 對 Virusscan Virus API (VAPI) 提出持續性跨元件呼叫。

持續性呼叫是指 Microsoft Exchange Information Store 服務 (Store.exe) 發給其他元件的要求，且當 Exchange FCL 資料寫入 Store.fcl 檔時，該要求尚未收到回應。

如果 Exchange Server Analyzer 發現 Store.fcl 記錄檔中的事件對 VAPI 元件反映來自 Microsoft Exchange Information Store 服務 (Store.exe) 的持續性呼叫，Exchange Server Analyzer 便會顯示警告。

此警告指出此伺服器可能會有效能問題。偶爾出現的持續性呼叫並不一定代表有問題，但針對相同區域一再重複的持續性呼叫就有可能是問題。

當 Microsoft Exchange Information Store 服務 (Store.exe) 所發出的跨元件呼叫在等候回應時，遠端程序呼叫 (RPC) 執行緒會在這些要求的背景做備份，從而導致 Exchange Server 的效能問題，例如造成伺服器對用戶端的回應延遲。

下列狀況會導致從 Exchange Information Store 服務對 VAPI 元件發出持續性呼叫：

  • 病毒掃描程式的更新，導致對資訊儲存庫中的項目重新掃描。

  • 病毒掃描程式的設定錯誤

  • 病毒掃描程式軟體處理大型郵件或附件。

若要對付此警告，請採取下列步驟：

  • 將病毒引擎的更新排定在資源消耗較輕的時候，也就是要求離峰期間。

  • 考慮重新安裝病毒掃描軟體，但請在要求離峰期間進行重新安裝。

  • 檢查病毒掃描引擎的組態以取得正確的執行緒組態、檔案層級排除等。請參閱 Microsoft 知識庫文章 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)。

  • 檢閱本文＜詳細資訊＞一節中的文章。

詳細資訊

若需有關通常搭配 Microsoft Exchange Server 2003 使用的病毒掃描程式詳細資訊，請參閱 Microsoft 知識庫文章 - 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)。

若需有關通常搭配 Microsoft Exchange 2000 Server 使用的病毒掃描程式詳細資訊，請參閱 Microsoft 知識庫文章 - 328841＜Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)。

若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)。

若需如何疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

若需如何疑難排解資訊儲存庫效能的詳細資訊，請參閱 Microsoft 知識庫文章 257725＜XADM：如何收集診斷資料以進行資訊存放的疑難排解＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。


已設定作業系統 GlobalFlag
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 GlobalFlag 項目的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager

如果 Exchange Server Analyzer 發現 GlobalFlag 的值，已設定為 0 或 Null 以外的值，則會顯示一則警告。

  • GlobalFlag 登錄值設定是一種位元遮罩，可決定已針對作業系統啟用哪些偵錯選項。除非您要主動地透過 Microsoft 產品支援服務的協助來參與偵錯或追蹤問題，否則建議您一律將 GlobalFlag 值設為 0。

根據預設值，GlobalFlag 登錄值會設為 0。如果此值已自預設值 0 變更，您可以使用包含在 Microsoft Windows Server™ 2003 支援工具中的 Gflags 工具，這些工具位於 Windows Server 2003 光碟的 \Support 資料夾中。除此之外，您可以使用登錄編輯程式，手動將此值設為 0。這兩個程序的描述如下。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要使用 GFlags 更正這個錯誤

  1. 按一下 [開始]、再按一下 [執行]，然後在 [開啟] 欄位中輸入 GFlags。即會出現 Global Flags 使用者介面。

  2. 清除所有的核取方塊，然後按一下 [套用]。

  3. 按一下 [確定] 以結束 GFlags 工具，並重新啟動電腦，讓變更生效。

若要使用登錄編輯程式更正這個錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\ System\CurrentControlSet\Control\Session Manager

  3. 在名稱為 GlobalFlag 的值上連按兩下，並將其 [數值] 資料設為 0。

  4. 結束登錄編輯程式，然後重新啟動電腦，使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)。


作業系統在偵錯模式中
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定是否已設定 Debug 內容的值。如果在 Exchange Server 電腦上此機碼的值已設為 TRUE，則會顯示錯誤訊息。

在 Boot.ini 檔案中新增 /debug 參數可觸發 Windows 偵錯模式。在 Windows Server 電腦的 Boot.ini 檔案中指定 /debug 後，便會在啟動時載入核心偵錯程式，並且隨時保留在記憶體中。這可讓支援專業人員撥號連線到進行偵錯的系統，並中斷偵錯程式 (即使當時系統未在 [核心停止] 螢幕暫停)。不同於 /crashdebug 參數，不論您是否正在進行偵錯，/debug 參數都是使用 COM 連接埠。此參數是在對定期重複出現的問題進行偵錯時使用。/debug 參數有可能會被設為問題疑難排解的方法，而不小心地保留設定。

因為執行其他的處理程序，會使效能大受影響。因此，當電腦上的 Windows 是在偵錯模式中執行時，不建議在該電腦上執行 Exchange Server。

若要消除此錯誤，請編輯 Boot.ini 檔案並移除 /debug 參數。

若要更正此錯誤

  1. 在 [Windows 檔案總管] 中，瀏覽至「系統磁碟分割」。這是保留硬體專用檔案 (如 Boot.ini 及 NTLDR) 的磁碟分割。

  2. 如果看不見 Boot.ini 檔案，可能是因為 [資料夾選項] 設定為 [隱藏保護的作業系統檔案]。若是這樣，請在 [Windows 檔案總管] 中，依序按一下 [工具]、[資料夾選項] 及 [檢視]。清除 [隱藏保護的作業系統檔案 (建議使用)] 核取方塊。當出現提示時，按一下 [是]。

  3. 在 [Windows 檔案總管] 中看見 Boot.ini 檔案時，在該檔案上按一下滑鼠右鍵，再按 [開啟檔案]，然後選取 [記事本] 以開啟檔案。

  4. 在 [Operating Systems] 區段中，移除 /debug 參數。

  5. 儲存後關閉檔案，然後重新啟動 Exchange Server 電腦，讓變更生效。

若需可用於 Boot.ini 檔案中的參數之詳細資訊，請參閱微軟知識庫文件 - 833721＜Available switch options for the Windows XP and the Windows Server 2003 Boot.ini files＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833721)。


Outlook Web Access 需要 Windows Server 2003 SP1 的 Hotfix
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-08-28

Microsoft® Exchange Server Analyzer 工具會查詢不同的 Microsoft Windows® Management Instrumentation (WMI) 類別，以收集下列資訊：

  • 安裝 Exchange Server 的 Microsoft Windows Server 作業系統版本為何？

  • Exchange 伺服器是否執行於叢集上？

如果 Exchange Server Analyzer 判定下列條件符合，便會顯示警告：

  • 已安裝 Exchange Server 2003 Service Pack 1 (SP1)。

  • 未安裝 Microsoft Windows Server™ 2003 SP1。

  • 叢集服務執行中。

  • Davex.dll 的 Version 值小於 6.5.7232。

如果執行此組態，則必須在下載並安裝 Exchange Server Hotfix 後，才能安裝 Windows Server 2003 SP1。如果不安裝 Exchange Server Hotfix，則 Microsoft Office Outlook® Web Access for Exchange Server 2003 使用者將無法登入信箱。信箱主控於叢集上的使用者若嘗試使用 Outlook Web Access 進行連線，將會收到下列錯誤訊息：

  • 「內部伺服器錯誤」

這個錯誤是由 Windows Server 2003 SP1 中內含的部分安全性增強功能引起。

當使用者嘗試以 Outlook Web Access 登入信箱時，HTTP 會模擬登入的使用者提交要求至叢集 API。然而，Windows Server 2003 SP1 中的安全性已有所變更。執行遠端登錄存取的 API 安全性限制已變更。因此，登入嘗試會失敗。

若要修正此錯誤，您必須依照微軟知識庫文件 - 841561＜使用者嘗試以 Outlook Web Access 存取叢集 Exchange Server 2003 後端伺服器時，顯示「500 - 內部伺服器錯誤」錯誤訊息＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841561) 中的說明，下載並安裝 Exchange Server Hotfix。


Outlook Web Access 範本檔不符
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Wmtemplates.dll 檔案的版本號碼。然後，Exchange Server Analyzer 會比較系統管理群組中所有伺服器的 Wmtemplates.dll 版本號碼。如果 Exchange Server Analyzer 發現前端 Exchange 伺服器與後端 Exchange 伺服器的 Wmtemplates.dll 版本號碼不相符，就會顯示一則最佳作法訊息。

Wmtemplates.dll 檔案可用於 Microsoft Office Outlook® Web Access 控制。當使用者嘗試藉由存取前端 Exchange 伺服器來登入 Outlook Web Access 時，前端與後端 Exchange 伺服器上不符的 Wmtemplates.dll 版本會導致 400 層級的錯誤。

Microsoft 發行了兩個更新 Wmtemplates.dll 的最新更新：

  • 《安裝 Exchange Server 2003 SP1 之後 Microsoft Exchange Information Store 服務會定期無法運作》(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=872963)

  • 《當您在 Windows XP Service Pack 2 電腦上執行 Exchange Server 2003 OWA 用戶端時，S/MIME 控制項未載入 OWA 中》(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=883543)

如果您最近安裝過其中任何一個更新，則可能是發生下列情況：

  • 未以正確順序安裝更新。

  • 未同時在前端及後端伺服器上安裝更新。

當安裝 Outlook Web Access 的更新時，應先在前端伺服器上安裝更新，然後重新啟動伺服器，再將更新安裝到後端伺服器上。

如果您尚未安裝其中任何一個更新，請確定所有伺服器都執行最新的 Exchange Server Service Pack 及更新。

若需有關最新 Exchange Server Service Pack 及更新的詳細資訊，請造訪下列網站：

  • 「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=21236)。

  • 「Exchange 2000 Server 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


未處理的 RPC 要求已達到閾值上限
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-02-13

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 MSExchangeIS 效能物件的 RPC Requests 效能計數器的資料，以分析效能資料。

如果 Exchange Server Analyzer 判定 RPC 要求數已在取樣時間配量期間達到尖峰值 100，則會顯示錯誤。

RPC Requests 效能計數器指出目前正由 Microsoft Exchange Information Store 服務處理之 MAPI 遠端程序呼叫 (RPC) (或用戶端) 要求的數目。RPC Requests 效能計數器的平均值始終應在 30 以下。依預設，RPC 要求數的最大值是 100。因此，除非另外設定它，否則 Microsoft Exchange Information Store 服務只能在相同時間服務 100 個 RPC 要求，並且將拒絕所有新的 RPC 作業，而且使用者將無法連接至伺服器，直到 RPC 要求數掉至 100 以下。伺服器將變成沒有回應，郵件流程可能會停止。Outlook 使用者可能會收到 [RPC 取消要求] 對話方塊。

這個錯誤表示伺服器正遇到效能瓶頸，或處理程序已停止回應。

效能瓶頸可能與 CPU、磁碟、網路或記憶體相關，也可能是因為伺服器負載增加或伺服器資源不足所導致。使用效能監視器 (Perfmon.msc) 工具，判定導致瓶頸的原因是伺服器負載增加或是伺服器太小。如果伺服器負載增加了，請識別負載的來源並降低它。如果伺服器資源不足，請增加必要的資源，或將使用者移出伺服器。

處理程序可能停止回應，因為儲存區正在等待永不傳回的資源。例如：失去主控郵件追蹤之磁碟機的叢集，或病毒掃描程式問題。當處理程序停止回應時，RPC 要求數將永遠不會往下掉，因此必須重新啟動儲存區。

詳細資訊

  • 若需處理器瓶頸的詳細資訊，請參閱＜處理器瓶頸＞

  • 若需磁碟瓶頸的詳細資訊，請參閱＜偵測到磁碟瓶頸＞

  • 若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 若需如何規劃 Exchange 伺服器效能的詳細資訊，請參閱＜Exchange Server 2003 效能：10 件要考慮的事情＞(英文) (http://go.microsoft.com/fwlink/?LinkID=56460)。

  • 若需如何移動使用者信箱以減少伺服器負載的詳細資訊，請參閱＜將使用者信箱移至其他伺服器＞。


遺失 PHATCAT.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個上述檔案遺失，就會顯示一則錯誤。若要修正此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或彙總更新套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 Microsoft Exchange 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


PHATQ.DLL 檔案遺失
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個檔案遺失，就會顯示一則錯誤。若要解決此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange Server 2000 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


分頁檔效能問題
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-09-06

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Avg Disk sec/Read 及 Avg Disk sec/Write 計數器 (這些是 LogicalDisk 效能物件的 PAGEDISK 執行個體的計數器) 的資料，以分析效能資料。

如果 Exchange Server Analyzer 判定 Avg Disk sec/Read 及 Avg Disk sec/Write 計數器已在取樣時間配量期間超過 10 毫秒，則會顯示錯誤。

LogicalDisk 效能物件是由監視硬碟之邏輯磁碟分割的計數器 (例如，Avg Disk sec/Read 及 Avg Disk sec/Write) 組成。Avg Disk sec/Read 效能計數器顯示自磁碟中讀取資料的平均時間 (秒)。Avg Disk sec/Write 效能計數器顯示將資料寫入磁碟的平均時間 (秒)。Avg Disk sec/Read 及 Avg Disk sec/Write 效能計數器的平均值應該低於 10 毫秒。

伺服器上 LogicalDisk 效能物件的 PAGEDISK 執行個體代表分頁檔 (Pagefile.sys)。Pagefile.sys 是硬碟上的隱藏系統檔案，當您系統的 RAM 不足時，Microsoft Windows® 會使用它來儲存暫時資料。分頁檔又稱為分頁檔 (Paging file) 或交換檔。

這個錯誤表示主控分頁檔的磁碟發生延遲問題。

若要解決這個錯誤，請採取下列步驟：

  • 識別延遲的原因。如果這個問題是由過度分頁所引起，則它可能是伺服器記憶體問題所引起。

  • 考慮將分頁檔放在專用磁碟分割或高速磁碟上。

  • 考慮依照微軟知識庫文件 - 197379＜設定分頁檔以在 Windows Server 2003、Windows 2000 及 Windows NT 中進行最佳化及復原＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379) 所述，在替代磁蹀機上建立次要分頁檔。

  • 在離峰時間執行伺服器維護工作。如果您在尖峰時間執行維護工具 (如 Exchange Server 資料庫公用程式 (Eseutil.exe)) 或工作 (如信箱管理)，則可能會使用到 Exchange 要使用的記憶體。最佳作法是在離峰時間或在使用量較低的時段執行這些工具及工作。

詳細資訊

  • 若需磁碟瓶頸的詳細資訊，請參閱＜偵測到磁碟瓶頸＞

  • 若需最佳化分頁檔效能的詳細資訊，請參閱微軟知識庫文件 - 197379＜設定分頁檔以在 Windows Server 2003、Windows 2000 及 Windows NT 中進行最佳化及復原＞(英文) (http://go.microsoft.com/fwlink/??linkId=3052&kbid=197379)。

  • 若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 如需有關設計存放結構的最佳作法，請參閱《多重結構通用的最佳作法》(英文) (http://go.microsoft.com/fwlink/?LinkId=72988)。

  • 若需有關磁碟大小、延遲及 I/O 速率的詳細資訊，請參閱下列 Microsoft Exchange 團隊部落格網站上的部落格：

    • ＜磁碟大小的一些基本概念＞(英文) (http://go.microsoft.com/fwlink/?linkid=39538)

    • ＜一些有關磁碟 IO 及計算的其他想法...＞(英文) (http://go.microsoft.com/fwlink/?linkid=39539)

    • 《如何計算磁碟 I/O 需求》(英文) (http://go.microsoft.com/fwlink/?linkid=69747)


Page File Usage 計數器大於 50%
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-09-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Paging File 效能物件的 % Usage 計數器的資料，以分析效能資料。

如果 Exchange Server Analyzer 判定 % Usage 計數器已在取樣時間配量期間超出 50%，則會顯示錯誤。

分頁檔 (Pagefile.sys) 是硬碟上的隱藏系統檔案，當您系統的 RAM 不足時，Windows 會使用它來儲存暫時資料。分頁檔又稱為分頁檔 (Paging file) 或交換檔。使用分頁檔會影響整體效能，原因是磁碟作業所花的時間會比記憶體作業來的長。另外，當分頁進出磁碟變得足夠高時，最後會發生磁碟瓶頸，效能因而降低。在此情況下，真正的問題是記憶體，磁碟瓶頸只是徵兆而已。

記憶體競爭是可以容忍的，直到系統達到一個臨界點，在這個點系統會花費相當多的時間 (相對於實際工作所需的時間) 來管理有限的記憶體。如果對照平均回應時間繪製記憶體競爭圖，您會看到一條相當平滑的線條，從零競爭直到回應時間大增的那一點。這稱之為 thrashing 點。過了這一點，當記憶體競爭增加時，回應時間會以指數方式增加。在某些環境中，暫時 thrashing 是可以容忍的，但是您應該盡力避開它。

這個錯誤表示主控分頁檔的磁碟發生效能問題。這個問題最終可能與伺服器上的記憶體問題相關。

若要解決這個錯誤，請採取下列步驟：

  • 考慮依照微軟知識庫文件 - 197379＜設定分頁檔以在 Windows Server 2003、Windows 2000 及 Windows NT 中進行最佳化及復原＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379) 所述，在替代磁蹀機上建立次要分頁檔。

  • 考慮將分頁檔放在專用磁碟分割或高速磁碟上。

  • 移除不必要的軟體。若要讓 Exchange 能夠使用更多的記憶體資源，請移除任何會執行監視功能的協力廠商軟體工具，或移除任何一種不必要的服務。效能嵌入式管理單元 (http://go.microsoft.com/fwlink/?LinkId=56118) 可幫助您瞭解應用程式正在使用多少記憶體。

  • 在離峰時間執行伺服器維護工作。如果您在尖峰時間執行維護工具 (如 Exchange Server 資料庫公用程式 (Eseutil.exe)) 或工作 (如信箱管理)，則可能會使用到 Exchange 要使用的記憶體。最佳作法是在離峰時間或在使用量較低的時段執行這些工具及工作。

  • 請考慮將使用者信箱從受影響的伺服器移到其他伺服器，以減少伺服器負載。若需詳細資訊，請參閱將使用者信箱移至其他伺服器。

詳細資訊

  • 若需磁碟瓶頸的詳細資訊，請參閱＜偵測到磁碟瓶頸＞

  • 若需最佳化分頁檔效能的詳細資訊，請參閱微軟知識庫文件 - 197379＜設定分頁檔以在 Windows Server 2003、Windows 2000 及 Windows NT 中進行最佳化及復原＞(英文) (http://go.microsoft.com/fwlink/??linkId=3052&kbid=197379)。

  • 若需改進記憶體效能的詳細資訊，請參閱改進使用者記憶體。

  • 若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 如需有關設計存放結構的最佳作法，請參閱《多重結構通用的最佳作法》(英文) (http://go.microsoft.com/fwlink/?LinkId=72988)。

  • 若需有關磁碟大小、延遲及 I/O 速率的詳細資訊，請參閱下列 Microsoft Exchange 團隊部落格網站上的部落格：

    • ＜磁碟大小的一些基本概念＞(英文) (http://go.microsoft.com/fwlink/?linkid=39538)。

    • ＜一些有關磁碟 IO 及計算的其他想法...＞(英文) (http://go.microsoft.com/fwlink/?linkid=39539)。

    • 《如何計算磁碟 I/O 需求》(英文) (http://go.microsoft.com/fwlink/?linkid=69747)


已設定 PageHeapFlags
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 PageHeapFlags 項目的值：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\MAD.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\INETINFO.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\EMSMTA.EXE

如果 Exchange Server Analyzer 發現 PageHeapFlags 的值存在，且設定成 0 或 null 以外的任意值，就會顯示一則警告。

如已設定 GlobalFlag 中所描述，PageHeapFlags 選項須與 GlobalFlag 登錄值搭配使用。PageHeapFlags 選項可讓您選取標準堆集驗證 (可在每個堆集配置結尾寫入填入模式，並在釋出配置時檢查模式) 或整頁堆集驗證。這會將無法存取的頁面放到每個配置的結尾，這樣程式會在存取超出配置的記憶體時立即停止。因為整頁堆集驗證會將整頁記憶體用於每個配置，所以廣泛使用它將會造成系統記憶體不足。

在此狀況下，Exchange Server Analyzer 會特別查看各種 Exchange 元件是否都已啟用任何 PageHeapFlags 值：

  • STORE.EXE - 資訊儲存庫處理程序

  • MAD.EXE - 系統服務員處理程序

  • INETINFO.EXE - IIS 管理及父處理序

  • EMSMTA.EXE - 郵件傳輸代理程式處理程序

除非您是在 Microsoft 產品支援服務的協助下主動參與偵錯或追蹤問題，否則建議一律都將 PageHeapFlags 值設定成 0 或予以完全刪除 (效果相同)。

PageHeapFlags 預設並不存在，而在需要偵錯 STORE.EXE 處理程序 (或任何其他處理程序) 時，您必須手動予以新增。您可以使用 Microsoft Windows Server™ 2003 支援工具 (位於 Windows Server 2003 CD 的 \Support 資料夾中) 所附的 Gflags 工具。或是，可以手動將值設定成 0，或使用登錄編輯程式來完全刪除 PageHeapFlags 值。兩個程序在本文件中都有說明。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要使用 GFlags 更正這個錯誤

  1. 依序按一下 [開始] | [執行]，然後在 [開啟] 欄位中執行 GFlags。即會出現 Global Flags 使用者介面。

  2. 在 [Image File Name] 欄位中，輸入 STORE.EXE。

  3. 按一下 [Image File Options]。

  4. 清除所有核取方塊，然後按一下 [Apply]。

  5. 針對上面列出的每一個 Exchange 處理程序，重複步驟 2 到 4。

  6. 按一下 [OK]，結束 GFlags 工具，然後重新啟動受影響的服務，使變更生效。

  7. 使用 GFlags 工具來清除此值時，並不會刪除或變更 PageHeapFlags 的值。而是將 GlobalFlag 值設定成 0，此值會覆寫及停用使用 PageHeapFlags 項目所設定的行為。

若要使用登錄編輯程式更正這個錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

  3. 刪除 PageHeapFlags 值。

  4. 針對所列的所有 Exchange 處理程序，重複步驟 2 及 3。

  5. 結束登錄編輯程式，然後重新啟動受影響的服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


分頁集區超過錯誤閾值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_PerfRawData_PerfOS_Memory Microsoft Windows® Management Instrumentation (WMI) 類別，以判定目前的 PoolNonpagedBytes 機碼值。Exchange Server Analyzer 所採取的動作，是根據基礎作業系統、Windows Boot.ini 檔案中是否有 /3GB 參數，以及在此機碼中探索到的值而定。

下表顯示一個評估矩陣，Exchange Server Analyzer 可使用它來判定此值是否超出指定 Exchange 伺服器的限制範圍。如果符合矩陣中的條件，則會顯示錯誤訊息。

作業系統 | Boot.ini 設定 | 目前的未分頁集區為
Windows 2000 Server 或 Advanced Server | /3GB | 110 MB 或更多
Windows 2000 Server 或 Advanced Server | 無 | 220 MB 或更多
Windows Server™ 2003 | /3GB | 110 MB 或更多
Windows Server 2003 | 無 | 220 MB 或更多

PoolNonpagedBytes 機碼值為核心記憶體未分頁集區的大小 (以位元組為單位)。未分頁集區是物件的實體系統記憶體區域，此種物件無法寫入磁碟中，但只要配置它們後就必須保留在實體記憶體中。此機碼的這個值是最後找到的值。在狀況良好的 Exchange 伺服器中，此值應該保持平穩。如果此計數器的值穩定地增加，這就表示記憶體流失。

因為未分頁集區記憶體的限制無法增加到超過以上所列的值，所以應儘速更正此狀況。不論使用中的作業系統為何，或 /3GB 參數是否存在，Windows 作業系統只能存取這麼多的未分頁集區記憶體。若 Windows 用盡了核心記憶體，就會顯示錯誤訊息和當機。由於核心記憶體對於系統正常運作很重要，因此您應該嚴密監視核心記憶體。

如果在重新啟動 Exchange 伺服器之後，此狀況仍重複發生，下一步就是確定已正確地調整系統，而且這個系統上的所有軟體及硬體都是最新的。這包括安裝最新的：

  • Windows 作業系統 Service Pack

  • Exchange Server Service Pack

  • 硬體韌體及驅動程式

  • 系統 BIOS 更新

  • 任何已安裝及執行中協力廠商應用程式的更新

如果軟體及硬體更新無法解決這個問題，請停用所有協力廠商軟體、重新啟動 Exchange Server 電腦，並且監視核心記憶體。

若要更正此錯誤

  1. 儘快將 Exchange Server 電腦重新開機。

  2. 監視 [記憶體 | 集區未分頁位元組] 效能計數器，以確保計數器不會超過以上所列的系統閾值。

若需有關正確地調整 Exchange Server 的詳細資訊，請參閱下列微軟知識庫文件及主題：

  • 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 266096＜XGEN:Exchange 2000 必須具有 1 GB 以上的實體 RAM，才能使用 /3GB 參數＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096)

  • 《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • 《疑難排解 Exchange 2000 Server 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=18177)

  • 《Exchange Server 2003 效能及延展性手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)


分頁集區超過警告閾值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-03-16

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_PerfRawData_PerfOS_Memory Microsoft WWindows® Management Instrumentation (WMI) 類別，以判定目前的 PoolPagedBytes 機碼值。Exchange Server Analyzer 所採取的動作，是根據基礎作業系統、Windows Boot.ini 檔中是否有 /3GB 參數，以及此機碼找到的值而定。

表格顯示一個評估矩陣，Exchange Server Analyzer 可使用它來判定此值是否超出指定 Exchange 伺服器的限制範圍。如果符合表格中的條件，便會顯示警告。

作業系統 | Boot.ini 設定 | 目前的分頁集區是
Windows 2000 Server 或 Advanced Server | /3GB | 180 MB 或更多
Windows 2000 Server 或 Advanced Server | 無 | 180 MB 或更多
Windows Server™ 2003 | /3GB | 200 MB 或更多
Windows Server 2003 | 無 | 300 MB 或更多

PoolPagedBytes 機碼值是核心記憶體分頁集區的大小 (位元組)。分頁集區是物件之實體系統記憶體的區域，可在未使用這些物件時，將它們寫入磁碟中。此機碼的這個值是最後找到的值。在狀況良好的 Exchange 伺服器上，除非進行備份或還原，否則不應使用 180 MB 以上的分頁集區記憶體。

在 Windows 2000 Server 及 Windows 2000 Advanced Server 中，分頁集區記憶體的最大值是 470 MB。將 /3GB 參數新增到執行 Windows 2000 Advanced Server 的電腦時，分頁集區記憶體的最大值是 192 MB。在未含 /3GB 參數且執行 Windows Server 2003 的電腦上，分頁集區記憶體的最大值是 491 MB。在含有 /3GB 參數且執行 Windows Server 2003 的電腦上，分頁集區記憶體的最大值是 256 MB。

因為沒有方法可將分頁集區記憶體的限制增加成大於上述所列的值，所以應儘快更正此狀況。無論作業系統是否在使用中或是否有 /3GB 參數，Windows 都只能存取這麼多的分頁集區記憶體。若 Windows 用盡了核心記憶體，就會顯示錯誤訊息和當機。必須有核心記憶體才能讓系統正確運作，因此，應小心監視核心記憶體。

如果重新啟動 Exchange 伺服器後又發生此狀況，下一步就是確定已正確調整系統，且此系統上的所有軟體及硬體都是最新的版本。這包括安裝最新的：

  • Windows 作業系統 Service Pack

  • Exchange Server Service Pack

  • 硬體韌體及驅動程式

  • 系統 BIOS 更新

  • 已安裝並且執行中的任何協力廠商之應用程式更新

若軟體和硬體更新都無法解決此問題，您應該停用全部的協力廠商軟體，然後重新啟動 Exchange Server 電腦，並且監視核心記憶體。

若要更正此警告

  1. 儘快將 Exchange Server 電腦重新開機。

  2. 監視 [記憶體 | 分頁集區位元組] 效能計數器，以確定它未超過以上所列的系統閾值。

若需有關正確調整 Exchange Server 的詳細資訊，請參閱下列微軟知識庫文件及 Exchange 主題：

  • 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 266096＜XGEN:Exchange 2000 必須具有 1 GB 以上的實體 RAM，才能使用 /3GB 參數＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096)

  • 《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • 《疑難排解 Exchange 2000 Server 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=18177)

  • 《Exchange Server 2003 效能及延展性手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)

若需相關資訊，請參閱下列 Exchange 部落格文章：

  • ＜Microsoft Windows 核心記憶體管理及 Microsoft Exchange Server＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63477)

  • ＜設定 Exchange 2003 的熱新增及大型記憶體＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63478)

  • ＜大型安全性權杖及核心記憶體耗盡＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63479)

    附註：
    提供這些部落格的連結只是為了參考而已。內容隨時都會變更，不另行通知。


RPC Proxy 伺服器延伸模組的路徑不正確
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取網際網路資訊服務 (IIS) Metabase 中的下列內容，以判斷是否已正確地設定它的值：

LM/W3SVC/Filters/RpcProxy

此 Metabase 內容是 IIS 中網頁服務延伸模組的遠端程序呼叫 (RPC) Proxy 伺服器擴充功能內容。此內容的正確值如下：

<Windows Directory>\system32\rpcproxy\rpcproxy.dll

如果 Exchange Server Analyzer 發現內容值不正確，就會顯示警告。

當您安裝 Microsoft Windows® Networking Services 元件的 RPC over HTTP Proxy 子元件時，會設定 RPC Proxy 伺服器擴充功能內容。如果此內容設定錯誤，或是您手動變更此值，則應該執行下列作業：

  1. 移除錯誤的 RPC Proxy 伺服器延伸模組內容。

  2. 移除 RPC over HTTP proxy 子元件。

  3. 重新安裝 RPC over HTTP Proxy 子元件來 RPC。

移除不正確的 RPC Proxy 伺服器延伸模組內容

  1. 開啟 [網際網路資訊服務 (IIS) 管理員]。

  2. 在 [網際網路資訊服務 (IIS) 管理員] 視窗的左邊窗格中，展開伺服器名稱，然後按一下 [網頁延伸模組]。

  3. 在 [IIS 管理員] 視窗的右窗格中，在 [RPC Proxy 伺服器擴充功能] 上按一下滑鼠右鍵，再按 [內容]。

  4. 在 [必要檔案] 索引標籤上，從檔案清單中選取錯誤的檔案，按一下 [移除]，再按一下 [確定]。

    附註：
    若要查到完整路徑，請調整檔案清單中 [檔案名稱] 直欄的寬度。
移除 RPC over HTTP Proxy 子元件

  1. 依序按一下 [開始]、[控制台] 及 [新增或移除程式]。

  2. 在左邊的窗格中，按一下 [新增/移除 Windows 元件]。

  3. 選取 [網路服務]，然後按一下 [詳細資料]。

  4. 清除 [RPC over HTTP Proxy] 核取方塊，並按一下 [確定] 後，再按 [下一步]。

  5. 當完成 Windows 元件精靈時，按一下 [完成] 以關閉精靈。
重新安裝 RPC over HTTP Proxy 子元件

  1. 請依序按一下 [開始]、[控制台] 及 [新增或移除程式]。

  2. 在左邊的窗格中，按一下 [新增/移除 Windows 元件]。

  3. 選取 [網路服務]，然後按一下 [詳細資料]。

  4. 選取 [RPC over HTTP Proxy] 核取方塊，並按一下 [確定] 後，再按 [下一步]。

  5. 當完成 [Windows 元件精靈] 時，按一下 [完成] 關閉精靈。

若需有關 RPC Proxy 伺服器擴充功能未正確載入問題的詳細資訊，請參閱微軟知識庫文件 - 833401＜如何在 Exchange Server 2003 中為單一伺服器設定 RPC over HTTP＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=833401) 中的＜疑難排解＞。

若需有關在 Exchange Server 2003 上部署 RPC over HTTP 的詳細資訊，請參閱《Exchange Server 2003 RPC over HTTP 部署案例》(英文) (http://go.microsoft.com/fwlink/?LinkId=24823)。


PDC 模擬器未從 DSAccess 拓撲中排除
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已將作為網域主控制站 (PDC) 模擬器的 Active Directory® 網域控制站，手動排除在可供 Exchange Server 使用的網域控制站清單之外：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default\MinUserDC

若 Exchange Server Analyzer 發現作為 PDC 模擬器的網域控制站，尚未由 Exchange Server 可用的網域控制站清單中以手動排除，則 Exchange Server Analyzer 會顯示最佳作法的建議。

PDC 模擬器是擔任 Active Directory 操作主機角色的電腦，可處理來自 Microsoft Windows NT® Server 4.0 備份網域控制站的複寫要求，並可針對沒有執行 Active Directory 功能用戶端軟體的用戶端，處理所有的密碼更新作業。PDC 模擬器也是網域控制站，因此可供 Exchange Server 這類的應用程式使用。

Directory Service Access (DSAccess) 是 Exchange 2000 Server 及 Exchange Server 2003 的內部元件，可控制所有 Exchange Server 元件存取 Active Directory 的方式。DSAccess 的主要功能是維護各種和目錄相關的事件及作業資訊。例如，DSAccess 會探索 Active Directory 拓樸，並且偵測網域控制站和通用類別目錄伺服器是否可用，並且回應查詢。

依預設值，DSAccess 會將 PDC 模擬器電腦包含在它的可用網域控制站清單中。如果非 Exchange Server 程式大量使用 PDC 模擬器，以 DSAccess 來使用 PDC 模擬器可能會導致 PDC 模擬器電腦發生效能問題，Exchange 伺服器和非 Exchange Server 電腦可能也會發生效能問題。

若要防止這類的效能問題，可以將 MinUserDC 登錄值加入 Exchange 伺服器上的登錄，以強制 DSAccess 先查詢所有其他可用的網域控制站，再查詢具有 PDC 模擬器操作主機的網域控制站。

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要檢查及變更 MinUserDC 的登錄值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default

  3. 尋找 MinUserDC 值，並執行任何必要的變更。如果這個 DWORD 值不存在，您可以手動建立它。

    附註：
    設定給 MinUserDC 登錄項目的數值資料，是可以連絡之網域控制站的數量上限，達到此上限後才連絡 PDC 模擬器。例如，將 MinUserDC 設定為 4，就是設定 DSAccess 只有在共有 4 部網域控制站可以使用時，才會排除 PDC 模擬器。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關如何使用 MinUserDC 登錄項目的詳細資訊，請參閱知識庫文件 - 298879＜當 DSAccess 使用 PDC 模擬器時，Exchange 2000可能會發生效能上的問題。＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298879)。


Available MBytes 計數器的效能資料
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Memory 效能物件的 Available MBytes 效能計數器的資料，以分析效能資料。如果 Exchange Server Analyzer 收集到來自 Available MBytes 效能計數器的任何資料，則 Exchange Server Analyzer 會將這些收集到的資料顯示為基準線資訊。

Available MBytes 效能計數器會顯示可立即配置給處理程序或供系統使用的實體記憶體數量 (MB)。可用記憶體的數量等於指派給待命 (已快取的)、可用及零頁清單的記憶體總和。

依預設，Exchange Server Analyzer 會在兩小時內每隔 30 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。Exchange Server Analyzer 也會報告所有收集值之第九十個百分位的值。

附註：
如果您以遞增順序列出所有由 Exchange Server Analyzer 收集到的值，第九十個百分位就是清單中第九十個百分比位置的值。第九十個百分位值表示收集間隔期間此計數器的高值。

在某些情況下，最大值就是間隔中之尖峰點的值。因此，最大值並不能代表整個間隔。因為中間值包含了收集間隔期間的閒置時間，所以中間值並不一定能夠正確地表示負載。因此，Exchange Server Analyzer 會報告最大值及第九十個百分位值。

此基準線訊息中的資訊僅供參考。不需要採取任何動作。

若需有關效能計數器之建議閾值的詳細資訊，請參閱《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


LogicalDisk 效能物件之 Average Disk sec/Read 計數器的效能資料
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 LogicalDisk 效能物件的 Avg. Disk sec/Read 效能計數器的資料，以分析效能資料。如果 Exchange Server Analyzer 收集到來自 Avg. Disk sec/Read 效能計數器的任何資料，則 Exchange Server Analyzer 會將這些收集到的資料顯示為基準線資訊。

Logical Disk 效能物件是由監視硬碟邏輯分割區的 Avg. Disk sec/Read 所組成。Avg. Disk sec/Read 效能計數器顯示磁碟資料的平均讀取時間 (秒)。Avg. Disk sec/Read 效能計數器的平均值應該在 10 毫秒以下。Avg. Disk sec/Read 效能計數器的最大值不應該超過 50 毫秒。

依預設，Exchange Server Analyzer 會在兩小時內每隔 30 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。Exchange Server Analyzer 也會報告所有收集值之第九十個百分位的值。

附註：
如果您以遞增順序列出所有由 Exchange Server Analyzer 收集到的值，第九十個百分位就是清單中第九十個百分比位置的值。第九十個百分位值表示收集間隔期間此計數器的高值。

在某些情況下，最大值就是間隔中之尖峰點的值。因此，最大值並不能代表整個間隔。因為中間值包含了收集間隔期間的閒置時間，所以中間值並不一定能夠正確地表示負載。因此，Exchange Server Analyzer 會報告最大值及第九十個百分位值。

此基準線訊息中的資訊僅供參考。不需要採取任何動作。

若需有關如何最佳化 Exchange Server 2003 儲存系統的詳細資訊，請參閱《最佳化 Exchange Server 2003 的儲存》(英文) (http://go.microsoft.com/fwlink/?LinkId=49324)。

若需有關效能計數器之建議閾值的詳細資訊，請參閱《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


PhysicalDisk 效能物件之 Average Disk sec/Read 計數器的效能資料
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 PhysicalDisk 效能物件的 Avg. Disk sec/Read 效能計數器的資料，以分析效能資料。如果 Exchange Server Analyzer 收集到來自 Avg. Disk sec/Read 效能計數器的任何資料，則 Exchange Server Analyzer 會將這些收集到的資料顯示為基準線資訊。

Avg. Disk sec/Read 效能計數器表示讀取磁碟資料的平均讀取時間 (秒)。Avg. Disk sec/Read 效能計數器的平均值應該在 10 毫秒以下。Avg. Disk sec/Read 效能計數器的最大值不應該超過 50 毫秒。

如果您從 Disk Reads/sec 及 Disk Writes/sec 計數器收集結果，可以判定 Exchange Server 所產生的 I/O 隨時間的推移是在增加還是在降低。如果您從 Avg. Disk sec/Read 及 Avg. Disk sec/Write 計數器收集結果，可以判定儲存延遲是否已隨時間的推移而變更。例如，下列步驟將協助您預測儲存輸送量已經變成瓶頸還是即將變成瓶頸：

  1. 每月測量一次，最好在每個月的同一天同一小時進行。

  2. 分析收集的資料。

依預設，Exchange Server Analyzer 會在兩小時內每隔 30 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。Exchange Server Analyzer 也會報告所有收集值之第九十個百分位的值。

附註：
如果您以遞增順序列出所有由 Exchange Server Analyzer 收集到的值，第九十個百分位就是清單中第九十個百分比位置的值。第九十個百分位值表示收集間隔期間此計數器的高值。

在某些情況下，最大值就是間隔中之尖峰點的值。因此，最大值並不能代表整個間隔。因為中間值包含了收集間隔期間的閒置時間，所以中間值並不一定能夠正確地表示負載。因此，Exchange Server Analyzer 會報告最大值及第九十個百分位值。

此基準線訊息中的資訊僅供參考。不需要採取任何動作。

若需有關效能計數器之建議閾值的詳細資訊，請參閱《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


LogicalDisk 效能物件之 Average Disk sec/Write 計數器的效能資料
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 LogicalDisk 效能物件的 Avg. Disk sec/Write 效能計數器的資料，以分析效能資料。如果 Exchange Server Analyzer 收集到來自 Avg. Disk sec/Write 效能計數器的任何資料，則 Exchange Server Analyzer 會將這些收集到的資料顯示為基準線資訊。

Logical Disk 效能物件是由監視硬碟邏輯分割區的 Avg. Disk sec/Write 所組成。Avg. Disk sec/Write 效能計數器顯示將資料寫入磁碟所用的平均時間 (秒)。Avg. Disk sec/Write 效能計數器的平均值應該在 10 毫秒以下。Avg. Disk sec/Write 效能計數器的最大值不應該超過 50 毫秒。

依預設，Exchange Server Analyzer 會在兩小時內每隔 30 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。Exchange Server Analyzer 也會報告所有收集值之第九十個百分位的值。

附註：
如果您以遞增順序列出所有由 Exchange Server Analyzer 收集到的值，第九十個百分位就是清單中第九十個百分比位置的值。第九十個百分位值表示收集間隔期間此計數器的高值。

在某些情況下，最大值就是間隔中之尖峰點的值。因此，最大值並不能代表整個間隔。因為中間值包含了收集間隔期間的閒置時間，所以中間值並不一定能夠正確地表示負載。因此，Exchange Server Analyzer 會報告最大值及第九十個百分位值。

此基準線訊息中的資訊僅供參考。不需要採取任何動作。

若需有關如何最佳化 Exchange Server 2003 之儲存系統的詳細資訊，請造訪 Microsoft TechNet 網站《最佳化 Exchange Server 2003 的儲存》(英文) (http://go.microsoft.com/fwlink/?LinkId=34649)。

若需有關效能計數器之建議閾值的詳細資訊，請參閱《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


Average Disk sec/Write 計數器的效能資料
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Physical Disk 效能物件的 Avg. Disk sec/Write 效能計數器的資料，以分析效能資料。如果 Exchange Server Analyzer 收集到來自 Avg. Disk sec/Write 效能計數器的任何資料，則 Exchange Server Analyzer 會將這些收集到的資料顯示為基準線資訊。

Avg. Disk sec/Write 效能計數器顯示將資料寫入磁碟所用的平均時間 (秒)。Avg. Disk sec/Write 效能計數器的平均值應該在 10 毫秒以下。Avg. Disk sec/Write 效能計數器的最大值不應該超過 50 毫秒。

依預設，Exchange Server Analyzer 會在兩小時內每隔 30 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。Exchange Server Analyzer 也會報告所有收集值之第九十個百分位的值。

附註：
如果您以遞增順序列出所有由 Exchange Server Analyzer 收集到的值，第九十個百分位就是清單中第九十個百分比位置的值。第九十個百分位值表示收集間隔期間此計數器的高值。

在某些情況下，最大值就是間隔中之尖峰點的值。因此，最大值並不能代表整個間隔。因為中間值包含了收集間隔期間的閒置時間，所以中間值並不一定能夠正確地表示負載。因此，Exchange Server Analyzer 會報告最大值及第九十個百分位值。

此基準線訊息中的資訊僅供參考。不需要採取任何動作。

若需有關效能計數器之建議閾值的詳細資訊，請參閱《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


Epoxy Client Out Queue Length (DSAccess) 計數器的效能資料
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Epoxy 效能物件的 Client Out Queue Length (DSAccess) 效能計數器的資料，以分析效能資料。如果 Exchange Server Analyzer 收集到來自 Client Out Queue Length (DSAccess) 效能計數器的任何資料，則 Exchange Server Analyzer 會將這些收集到的資料顯示為基準線資訊。

Client Out Queue Length (DSAccess) 效能計數器表示佇列中所含由 Inetinfo.exe 處理程序傳送之目錄服務存取 (DSAccess) 郵件的郵件數目。不管在什麼時候，佇列都應少於 10 個。

依預設，Exchange Server Analyzer 會在兩小時內每隔 30 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。Exchange Server Analyzer 也會報告所有收集值之第九十個百分位的值。

附註：
如果您以遞增順序列出所有由 Exchange Server Analyzer 收集到的值，第九十個百分位就是清單中第九十個百分比位置的值。第九十個百分位值表示收集間隔期間此計數器的高值。

在某些情況下，最大值就是間隔中之尖峰點的值。因此，最大值並不能代表整個間隔。因為中間值包含了收集間隔期間的閒置時間，所以中間值並不一定能夠正確地表示負載。因此，Exchange Server Analyzer 會報告最大值及第九十個百分位值。

此基準線訊息中的資訊僅供參考。不需要採取任何動作。

若需有關效能計數器之建議閾值的詳細資訊，請參閱《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


Epoxy Client Out Queue Length (SMTP) 計數器的效能資料
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Epoxy 效能物件的 Client Out Queue Length (SMTP) 效能計數器的資料，以分析效能資料。如果 Exchange Server Analyzer 收集到來自 Client Out Queue Length (SMTP) 效能計數器的任何資料，則 Exchange Server Analyzer 會將這些收集到的資料顯示為基準線資訊。

Client Out Queue Length (SMTP) 效能計數器表示包含 Inetinfo.exe 處理程序傳送之簡易郵件傳送通訊協定 (SMTP) 郵件之佇列中的郵件數目。除非存在郵件佇列，否則佇列數目應該一律在 50 之下。

依預設，Exchange Server Analyzer 會在兩小時內每隔 30 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。Exchange Server Analyzer 也會報告所有收集值之第九十個百分位的值。

附註：
如果您以遞增順序列出所有由 Exchange Server Analyzer 收集到的值，第九十個百分位就是清單中第九十個百分比位置的值。第九十個百分位值表示收集間隔期間此計數器的高值。

在某些情況下，最大值就是間隔中之尖峰點的值。因此，最大值並不能代表整個間隔。因為中間值包含了收集間隔期間的閒置時間，所以中間值並不一定能夠正確地表示負載。因此，Exchange Server Analyzer 會報告最大值及第九十個百分位值。

此基準線訊息中的資訊僅供參考。不需要採取任何動作。

若需有關效能計數器之建議閥值的詳細資訊，請參閱《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


Epoxy Store Out Queue Length (DSAccess) 計數器的效能資料
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Epoxy 效能物件之 Store Out Queue Length (DSAccess) 效能計數器的資料，以分析效能資料。如果 Exchange Server Analyzer 收集到來自 Store Out Queue Length (DSAccess) 效能計數器的任何資料，就會將這些收集到的資料顯示為基準線資訊。

Store Out Queue Length (DSAccess) 效能計數器表示在包含由 Store.exe 處理程序傳送之 Directory Service Access (DSAccess) 郵件的佇列中，共有多少郵件。不管在什麼時候，佇列都應少於 10 個。

依預設，Exchange Server Analyzer 會在兩小時內每隔 30 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。Exchange Server Analyzer 也會報告所有收集值之第九十個百分位的值。

附註：
如果您以遞增順序列出所有由 Exchange Server Analyzer 收集到的值，第九十個百分位就是清單中第九十個百分比位置的值。第九十個百分位值表示收集間隔期間此計數器的高值。

在某些情況下，最大值就是間隔中之尖峰點的值。因此，最大值並不能代表整個間隔。因為中間值包含了收集間隔期間的閒置時間，所以中間值並不一定能夠正確地表示負載。因此，Exchange Server Analyzer 會報告最大值及第九十個百分位值。

此基準線訊息中的資訊僅供參考。不需要採取任何動作。

若需有關效能計數器之建議閾值的詳細資訊，請參閱《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


Epoxy Store Out Queue Length (SMTP) 計數器的效能資料
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Epoxy 效能物件之 Store Out Queue Length (SMTP) 效能計數器的資料，以分析效能資料。如果 Exchange Server Analyzer 收集到來自 Store Out Queue Length (SMTP) 效能計數器的任何資料，就會將這些收集到的資料顯示為基準線資訊。

Store Out Queue Length 效能計數器表示在包含 Store.exe 處理程序傳送之簡易郵件傳送通訊協定 (SMTP) 郵件的佇列中，共有多少郵件。除非存在郵件佇列，否則佇列數目應該一律在 50 之下。

依預設，Exchange Server Analyzer 會在兩小時內每隔 30 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。Exchange Server Analyzer 也會報告所有收集值之第九十個百分位的值。

附註：
如果您以遞增順序列出所有由 Exchange Server Analyzer 收集到的值，第九十個百分位就是清單中第九十個百分比位置的值。第九十個百分位值表示收集間隔期間此計數器的高值。

在某些情況下，最大值就是間隔中之尖峰點的值。因此，最大值並不能代表整個間隔。因為中間值包含了收集間隔期間的閒置時間，所以中間值並不一定能夠正確地表示負載。因此，Exchange Server Analyzer 會報告最大值及第九十個百分位值。

此基準線訊息中的資訊僅供參考。不需要採取任何動作。

若需有關效能計數器之建議閾值的詳細資訊，請參閱《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


RPC Averaged Latency 計數器的效能資料
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 MSExchangeIS 效能物件的 RPC Averaged Latency 效能計數器的資料，以分析效能資料。如果 Exchange Server Analyzer 收集到來自 RPC Averaged Latency 效能計數器的任何資料，則 Exchange Server Analyzer 會將這些收集到的資料顯示為基準線資訊。

RPC Averaged Latency 效能計數器會顯示過去 1,024 個封包的平均遠端程序呼叫 (RPC) 延遲時間 (毫秒)。RPC Averaged Latency 效能計數器的最大值應該一直小於 50 毫秒。

依預設，Exchange Server Analyzer 會在兩小時內每隔 30 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。Exchange Server Analyzer 也會報告所有收集值之第九十個百分位的值。

附註：
如果您以遞增順序列出所有由 Exchange Server Analyzer 收集到的值，第九十個百分位就是清單中第九十個百分比位置的值。第九十個百分位值表示收集間隔期間此計數器的高值。

在某些情況下，最大值就是間隔中之尖峰點的值。因此，最大值並不能代表整個間隔。因為中間值包含了收集間隔期間的閒置時間，所以中間值並不一定能夠正確地表示負載。因此，Exchange Server Analyzer 會報告最大值及第九十個百分位值。

此基準線訊息中的資訊僅供參考。不需要採取任何動作。

若需有關效能計數器之建議閾值的詳細資訊，請參閱《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


RPC Operations/sec 計數器的效能資料
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 MSExchangeIS 效能物件的 RPC Operations/sec 效能計數器的資料，以分析效能資料。如果 Exchange Server Analyzer 收集到來自 RPC Operations/sec 效能計數器的任何資料，則 Exchange Server Analyzer 會將這些收集到的資料顯示為基準線資訊。

RPC Operations/sec 效能計數器會顯示遠端程序呼叫 (RPC) 作業發生的頻率。因為所有 MAPI 型動作都使用 RPC 通訊協定，所以 RPC Operations/sec 效能計數器是一種測量 Exchange Server 工作量的良好頻率計數器。

依預設，Exchange Server Analyzer 會在兩小時內每隔 30 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。Exchange Server Analyzer 也會報告所有收集值之第九十個百分位的值。

附註：
如果您以遞增順序列出所有由 Exchange Server Analyzer 收集到的值，第九十個百分位就是清單中第九十個百分比位置的值。第九十個百分位值表示收集間隔期間此計數器的高值。

在某些情況下，最大值就是間隔中之尖峰點的值。因此，最大值並不能代表整個間隔。因為中間值包含了收集間隔期間的閒置時間，所以中間值並不一定能夠正確地表示負載。因此，Exchange Server Analyzer 會報告最大值及第九十個百分位值。

此基準線訊息中的資訊僅供參考。不需要採取任何動作。

若需有關效能計數器之建議閾值的詳細資訊，請參閱《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


RPC Requests 計數器的效能資料
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 MSExchangeIS 效能物件的 RPC Requests 效能計數器的資料，以分析效能資料。如果 Exchange Server Analyzer 收集到來自 RPC Requests 效能計數器的任何資料，則 Exchange Server Analyzer 會將這些收集到的資料顯示為基準線資訊。

RPC Requests 效能計數器指出 Microsoft Exchange Information Store 服務目前正處理之 MAPI 遠端程序呼叫 (RPC)、用戶端或要求的數目。RPC Requests 效能計數器的平均值始終應在 30 以下。在預設的情況下，RPC 要求的最大值是 100。因此，除非已設定，否則 Microsoft Exchange Information Store 服務僅能同時處理 100 個 RPC 要求，若超過此值就會拒絕用戶端要求。

依預設，Exchange Server Analyzer 會在兩小時內每隔 30 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。Exchange Server Analyzer 也會報告所有收集值之第九十個百分位的值。

附註：
如果您以遞增順序列出所有由 Exchange Server Analyzer 收集到的值，第九十個百分位就是清單中第九十個百分比位置的值。第九十個百分位值表示收集間隔期間此計數器的高值。

在某些情況下，最大值就是間隔中之尖峰點的值。因此，最大值並不能代表整個間隔。因為中間值包含了收集間隔期間的閒置時間，所以中間值並不一定能夠正確地表示負載。因此，Exchange Server Analyzer 會報告最大值及第九十個百分位值。

此基準線訊息中的資訊僅供參考。不需要採取任何動作。

若需有關效能計數器之建議閾值的詳細資訊，請參閱《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


SMTP Categorizer Queue Length 計數器的效能資料
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 SMTP Server 效能物件的 Categorizer Queue Length 效能計數器的資料，以分析效能資料。Exchange Server Analyzer 會報告在分類程式佇列中找到的郵件總數。

SMTP Server\Categorizer Queue Length 計數器表示在簡易郵件傳送通訊協定 (SMTP) 分類程式佇列中，等候使用通用類別目錄伺服器進行目錄服務屬性搜尋的郵件數。根據一般方針，最大值應小於 10。

依預設，Exchange Server Analyzer 會在兩小時內每隔 30 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。Exchange Server Analyzer 也會報告所有收集值之第九十個百分位的值。

附註：
如果您以遞增順序列出所有由 Exchange Server Analyzer 收集到的值，第九十個百分位就是清單中第九十個百分比位置的值。第九十個百分位值表示收集間隔期間此計數器的高值。

在某些情況下，最大值就是間隔中之尖峰點的值。因此，最大值並不能代表整個間隔。因為中間值包含了收集間隔期間的閒置時間，所以中間值並不一定能夠正確地表示負載。因此，Exchange Server Analyzer 會報告最大值及第九十個百分位值。

Categorizer Queue Length 計數器表示郵件分類程式佇列中的郵件數。分類程式會執行下列核心作業：

  • 解析及驗證所有收件者。

  • 判定對所有收件者的限制。

  • 展開通訊群組清單 (如果必要的話)。

  • 判定郵件是本機傳遞還是遠端傳遞。

Categorizer Queue Length 計數器中的增加，表示可能有伺服器效能問題、Directory Service Access (DSAccess)、Active Directory® 目錄服務問題，或 Exchange Server 組織中的關鍵伺服器中斷。Categorizer Queue Length 計數器中的增加，表示在參考 Active Directory 或提交郵件進行本機傳遞或 SMTP 時，執行速度緩慢或無回應。

此基準線訊息中的資訊僅供參考。不需要採取任何動作。

若需有關效能計數器之建議閾值的詳細資訊，請參閱《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


SMTP Local Queue Length 計數器的效能資料
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 SMTP Server 效能物件的 Local Queue Length 效能計數器的資料，以分析效能資料。Exchange Server Analyzer 會報告在簡易郵件傳送通訊協定 (SMTP) 本機佇列中找到的郵件總數。

SMTP Server\Local Queue Length 計數器指出 SMTP 本機傳遞佇列中的郵件數目。作為一般方針，最大值應小於 1,000。佇列應保持在平均值附近平穩地小幅度變化。

依預設，Exchange Server Analyzer 會在兩小時內每隔 30 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。Exchange Server Analyzer 也會報告所有收集值之第九十個百分位的值。

附註：
如果您以遞增順序列出所有由 Exchange Server Analyzer 收集到的值，第九十個百分位就是清單中第九十個百分比位置的值。第九十個百分位值表示收集間隔期間此計數器的高值。

在某些情況下，最大值就是間隔中之尖峰點的值。因此，最大值並不能代表整個間隔。因為中間值包含了收集間隔期間的閒置時間，所以中間值並不一定能夠正確地表示負載。因此，Exchange Server Analyzer 會報告最大值及第九十個百分位值。

在本機傳遞佇列中建立郵件表示伺服器發生效能問題或中斷，因為伺服器已無法及時傳遞傳入郵件。下列情況都會造成此延遲：

  • 未立即參考 Active Directory® 目錄服務。

  • 未立即處理本機傳遞或 SMTP 的郵件。

  • 資料庫已卸載。

此基準線訊息中的資訊僅供參考。不需要採取任何動作。

若需有關效能計數器之建議閾值的詳細資訊，請參閱《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


SMTP Remote Queue Length 計數器的效能資料
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 SMTP Server 效能物件的 Remote Queue Length 效能計數器的資料，以分析效能資料。Exchange Server Analyzer 會報告在簡易郵件傳送通訊協定 (SMTP) 遠端佇列中找到的郵件總數。

SMTP Server\Remote Queue Length 計數器表示 SMTP 遠端傳遞佇列中的郵件數目。根據一般方針，最大值應小於 1,000。佇列應保持在平均值附近平穩地小幅度變化。

依預設，Exchange Server Analyzer 會在兩小時內每隔 30 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。Exchange Server Analyzer 也會報告所有收集值之第九十個百分位的值。

附註：
如果您以遞增順序列出所有由 Exchange Server Analyzer 收集到的值，第九十個百分位就是清單中第九十個百分比位置的值。第九十個百分位值表示收集間隔期間此計數器的高值。

在某些情況下，最大值就是間隔中之尖峰點的值。因此，最大值並不能代表整個間隔。因為中間值包含了收集間隔期間的閒置時間，所以中間值並不一定能夠正確地表示負載。因此，Exchange Server Analyzer 會報告最大值及第九十個百分位值。

遠端佇列長度的增加表示郵件並未傳送至其他伺服器。無法傳送郵件的原因可能是網路或遠端伺服器發生中斷或效能問題。這些中斷或效能問題會造成網路或遠端伺服器無法有效率地接收郵件。

此基準線訊息中的資訊僅供參考。不需要採取任何動作。

若需有關效能計數器之建議閾值的詳細資訊，請參閱《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


Virus Scan Queue Length 計數器的效能資料
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 MSExchangeIS 效能物件的 Virus Scan Queue Length 效能計數器的資料，以分析效能資料。如果 Exchange Server Analyzer 收集到來自 Virus Scan Queue Length 效能計數器的任何資料，就會顯示收集到的資料作為基準線資訊。

Virus Scan Queue Length 效能計數器表示等候病毒掃描之目前未處理的要求數目。此計數器的建議值與您組織有關。

依預設，Exchange Server Analyzer 會在兩小時內每隔 30 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。Exchange Server Analyzer 也會報告所有收集值之第九十個百分位的值。

附註：
如果您以遞增順序列出所有 Exchange Server Analyzer 收集的值，第九十個百分位就是清單中第九十個百分比位置的值。第九十個百分位值表示收集間隔期間此計數器的高值。

在某些情況下，最大值就是間隔中之尖峰點的值。因此，最大值並不能代表整個間隔。因為中間值包含了收集間隔期間的閒置時間，所以中間值並不一定能夠正確地表示負載。因此，Exchange Server Analyzer 會報告最大值及第九十個百分位值。

此基準線訊息中的資訊僅供參考。不需要採取任何動作。

若需有關效能計數器之建議閾值的詳細資訊，請參閱《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


Log Record Stalls/sec 計數器的效能資料
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Database 效能物件的 Log Record Stalls/sec 效能計數器的資料，以分析效能資料。如果 Exchange Server Analyzer 收集到來自 Log Record Stalls/sec 效能計數器的任何資料，則 Exchange Server Analyzer 會將這些收集到的資料顯示為基準線資訊。

Log Record Stalls/sec 效能計數器顯示每秒無法新增到記錄緩衝區的記錄數 (原因是記錄緩衝區已滿)。Log Record Stalls/sec 效能計數器的平均值應該在每秒 10 個以下。最大值不得超過每秒 100 個。

依預設，Exchange Server Analyzer 會在兩小時內每隔 30 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。Exchange Server Analyzer 也會報告所有收集值之第九十個百分位的值。

附註：
如果您以遞增順序列出所有由 Exchange Server Analyzer 收集到的值，第九十個百分位就是清單中第九十個百分比位置的值。第九十個百分位值表示收集間隔期間此計數器的高值。

在某些情況下，最大值就是間隔中之尖峰點的值。因此，最大值並不能代表整個間隔。因為中間值包含了收集間隔期間的閒置時間，所以中間值並不一定能夠正確地表示負載。因此，Exchange Server Analyzer 會報告最大值及第九十個百分位值。

此基準線訊息中的資訊僅供參考。不需要採取任何動作。

若需有關效能計數器之建議閾值的詳細資訊，請參閱《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


Log Threads Waiting 計數器的效能資料
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Database 效能物件的 Log Threads Waiting 效能計數器的資料，以分析效能資料。如果 Exchange Server Analyzer 收集到來自 Log Threads Waiting 效能計數器的任何資料，則 Exchange Server Analyzer 會將這些收集到的資料顯示為基準線資訊。

Log Threads Waiting 效能計數器藉由將執行緒的資料寫入記錄檔，來顯示等待完成資料庫更新的執行緒數。如果 Log Threads Waiting 效能計數器的值太高，則記錄檔可能成為其他交易的瓶頸。

依預設，Exchange Server Analyzer 會在兩小時內每隔 30 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。Exchange Server Analyzer 也會報告所有收集值之第九十個百分位的值。

附註：
如果您以遞增順序列出所有由 Exchange Server Analyzer 收集到的值，第九十個百分位就是清單中第九十個百分比位置的值。第九十個百分位值表示收集間隔期間此計數器的高值。

在某些情況下，最大值就是間隔中之尖峰點的值。因此，最大值並不能代表整個間隔。因為中間值包含了收集間隔期間的閒置時間，所以中間值並不一定能夠正確地表示負載。因此，Exchange Server Analyzer 會報告最大值及第九十個百分位值。

此基準線訊息中的資訊僅供參考。不需要採取任何動作。

若需有關效能計數器之建議閥值的詳細資訊，請參閱《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


Pages/sec 計數器的效能資料
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Memory 效能物件的 Pages/sec 效能計數器的資料，以分析效能資料。如果 Exchange Server Analyzer 收集到來自 Pages/sec 效能計數器的任何資料，就會顯示收集到的資料基準線資訊。

Pages/sec 效能計數器會顯示為了解決硬體分頁錯誤，而在磁碟中進行讀取或寫入的頻率。此計數器是追蹤造成系統延遲這類錯誤的主要指示器。它包含為了彌補在檔案系統快取中的分頁錯誤而擷取的分頁。這些分頁通常為應用程式所要求。不管在什麼時候，此計數器都應低於 1,000。

依預設，Exchange Server Analyzer 會在兩小時內每隔 30 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。Exchange Server Analyzer 也會報告所有收集值之第九十個百分位的值。

附註：
如果您以遞增順序列出所有由 Exchange Server Analyzer 收集到的值，第九十個百分位就是清單中第九十個百分比位置的值。第九十個百分位值表示收集間隔期間此計數器的高值。

在某些情況下，最大值就是間隔中之尖峰點的值。因此，最大值並不能代表整個間隔。因為中間值包含了收集間隔期間的閒置時間，所以中間值並不一定能夠正確地表示負載。因此，Exchange Server Analyzer 會報告最大值及第九十個百分位值。

此基準線訊息中的資訊僅供參考。不需要採取任何動作。

若需有關效能計數器之建議閾值的詳細資訊，請參閱《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


% Processor Time 計數器的效能資料
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Processor 效能物件的 % Processor Time 效能計數器的資料，以分析效能資料。如果 Exchange Server Analyzer 收集到來自 % Processor Time 效能計數器的任何資料，則 Exchange Server Analyzer 會將這些收集到的資料顯示為基準線資訊。

% Processor Time 效能計數器顯示處理器執行非閒置執行緒所花費時間的百分比。您可用使用此計數器來檢視處理器的整體使用情況，或可以監視每個處理器的使用情況。平均 CPU 使用應始終小於 90%。

附註：
Exchange Server Analyzer 顯示的 % Processor Time 是一個彙總值，它是根據偵測到的 CPU 總數 (實體及邏輯) 除以 CPU 計數的總數而定。

依預設，Exchange Server Analyzer 會在兩小時內每隔 30 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。Exchange Server Analyzer 也會報告所有收集值之第九十個百分位的值。

附註：
如果您以遞增順序列出所有 Exchange Server Analyzer 收集的值，第九十個百分位就是清單中第九十個百分比位置的值。第九十個百分位值表示收集間隔期間此計數器的高值。

在某些情況下，最大值就是間隔中之尖峰點的值。因此，最大值並不能代表整個間隔。因為中間值包含了收集間隔期間的閒置時間，所以中間值並不一定能夠正確地表示負載。因此，Exchange Server Analyzer 會報告最大值及第九十個百分位值。

此基準線訊息中的資訊僅供參考。不需要採取任何動作。

若需有關效能計數器之建議閾值的詳細資訊，請參閱《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


Bytes Total/sec 計數器的效能資料
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Network Interface 效能物件的 Bytes Total/sec 效能計數器的資料，以分析效能資料。如果 Exchange Server Analyzer 收集到來自 Bytes Total/sec 效能計數器的任何資料，則 Exchange Server Analyzer 會將這些收集到的資料顯示為基準線資訊。

Bytes Total/sec 效能計數器會顯示網路介面卡處理資料位元組的速率。此計數器包括所有應用程式及檔案資料，此外還包括通訊協定資訊，如封包標頭。對於每秒鐘 100 MB (Mbps) 的網路介面卡，Bytes Total/sec 效能計數器的值應低於 7 MB/秒。對於 1000 Mbps 的網路介面卡，Bytes Total/sec 效能計數器的值應低於 70 MB/秒。

依預設，Exchange Server Analyzer 會在兩小時內每隔 30 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。Exchange Server Analyzer 也會報告所有收集值之第九十個百分位的值。

附註：
如果您以遞增順序列出所有由 Exchange Server Analyzer 收集到的值，第九十個百分位就是清單中第九十個百分比位置的值。第九十個百分位值表示收集間隔期間此計數器的高值。

在某些情況下，最大值就是間隔中之尖峰點的值。因此，最大值並不能代表整個間隔。因為中間值包含了收集間隔期間的閒置時間，所以中間值並不一定能夠正確地表示負載。因此，Exchange Server Analyzer 會報告最大值及第九十個百分位值。

此基準線訊息中的資訊僅供參考。不需要採取任何動作。

若需有關效能計數器之建議閾值的詳細資訊，請參閱《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


LDAP Read Time 計數器的效能資料
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-02-06

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 MSExchangeDSAccess Process 效能物件的 LDAP Read Time 效能計數器的資料，以分析效能資料。如果 Exchange Server Analyzer 收集到來自 LDAP Read Time 效能計數器的任何資料，則會將這些收集到的資料顯示為基準線資訊。

LDAP Read Time 效能計數器會顯示要完成輕量型目錄存取通訊協定 (LDAP) 讀取要求所花費的時間 (以毫秒為單位)。平均值應該要低於 50 毫秒。最大值不得超過 100 毫秒。

依預設，Exchange Server Analyzer 會在兩小時內每隔 30 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。Exchange Server Analyzer 也會報告所有收集值之第九十個百分位的值。

附註：
如果您以遞增順序列出所有由 Exchange Server Analyzer 收集到的值，第九十個百分位就是清單中第九十個百分比位置的值。第九十個百分位值表示收集間隔期間此計數器的高值。

在某些情況下，最大值就是間隔中之尖峰點的值。因此，最大值並不能代表整個間隔。因為中間值包含了收集間隔期間的閒置時間，所以中間值並不一定能夠正確地表示負載。因此，Exchange Server Analyzer 會報告最大值及第九十個百分位值。

此基準線訊息中的資訊僅供參考。不需要採取任何動作。

若需有關效能計數器之建議閾值的詳細資訊，請參閱《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


LDAP Search Time 計數器的效能資料
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 MSExchangeDSAccess Processes 效能物件的 LDAP Search Time 效能計數器的資料，以分析效能資料。如果 Exchange Server Analyzer 收集到來自 LDAP Search Time 效能計數器的任何資料，則 Exchange Server Analyzer 會將這些收集到的資料顯示為基準線資訊。

LDAP Search Time 效能計數器會顯示滿足輕量型目錄存取通訊協定 (LDAP) 搜尋要求所需的時間 (以毫秒為單位)。平均值應該要低於 50 毫秒。最大值不得超過 100 毫秒。

依預設，Exchange Server Analyzer 會在兩小時內每隔 30 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。Exchange Server Analyzer 也會報告所有收集值之第九十個百分位的值。

附註：
如果您以遞增順序列出所有由 Exchange Server Analyzer 收集到的值，第九十個百分位就是清單中第九十個百分比位置的值。第九十個百分位值表示收集間隔期間此計數器的高值。

在某些情況下，最大值就是間隔中之尖峰點的值。因此，最大值並不能代表整個間隔。因為中間值包含了收集間隔期間的閒置時間，所以中間值並不一定能夠正確地表示負載。因此，Exchange Server Analyzer 會報告最大值及第九十個百分位值。

此基準線訊息中的資訊僅供參考。不需要採取任何動作。

若需有關效能計數器之建議閾值的詳細資訊，請參閱《疑難排解 Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


PhysicalDisk 效能監視器物件不可用
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 PhysicalDisk 效能物件的 Avg. Disk sec/Read 效能計數器的資料，以分析效能資料。如果計數器未傳回有效的資料，Exchange Server Analyzer 便會顯示基準線訊息。

如果效能資料收集引擎未傳回有效的資料，則發生了下列任意狀況組合：

  • PhysicalDisk 效能物件已停用。

  • PhysicalDisk 效能監視器物件已遺失或已損毀。

  • Exchange Server Analyzer 沒有適當的權限可存取效能物件。

如果某個可擴充的計數器損毀了登錄，或使用 Microsoft Windows® Management Instrumentation (WMI) 的程式修改了登錄，就會發生前兩個狀況。下列程序解說如何修復前兩個狀況。在執行此程序前，請先確認 Exchange Server Analyzer 具有適當的權限。若需有關執行 Exchange Server Analyzer 所需權限的詳細資訊，請參閱包含在 Exchange Server Analyzer 中的說明文件。若需取得 [說明]，請開啟 Exchange Server Analyzer 並按 F1 鍵。

若要更正此錯誤

  1. 確認 PhysicalDisk 效能物件已啟用。

    1. 下載並安裝 Extensible Performance Counter List 工具 (Exctrlst.exe)。您可以在 Microsoft 網站下載 Exctrlst.exe：「Exctrlst.exe：Extensible Performance Counter List」(英文) (http://go.microsoft.com/fwlink/?LinkId=34436)。

    2. 開啟 Exctrlst.exe，並依序按一下 [Sort Order] 及 [Service]。

    3. 找出要讓效能物件報告的服務，並確認已選取 [Performance Counters Enabled] 核取方塊。

      如果未選取 [Performance Counters Enabled] 核取方塊，請選取此核取方塊，然後重新啟動與效能計數器相關的服務，確認效能計數器可運作。如果效能計數器未運作，或已選取 [Performance Counters Enabled] 核取方塊，請繼續步驟 2。

  2. 依照微軟知識庫文件 - 300956＜如何手動重建效能計數器程式庫值＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) 中的指示，重建遺失或損毀的效能計數器。

  3. 如果遵循此知識庫文件的指示並不能解決問題，則必須以 [修復] 模式重新安裝 Windows 作業系統，並套用最新的 Windows Service Pack。


通訊埠衝突：站台複寫服務
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否存在任何通訊埠衝突：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

如果 Exchange Server Analyzer 發現 HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP 的值符合本文稍早所列的其他 6 個通訊埠登錄值中的任何一個，就會顯示錯誤。Exchange Server Analyzer 也會顯示與 HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP 衝突的通訊埠錯誤。

若要更正此錯誤，您必須將此機碼或 Exchange Server Analyzer 輸出指定之衝突機碼的值，變更為唯一值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要設定 TCP/IP 登錄參數

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters

  3. 按兩下 TCP/IP 機碼並將 [數值資料] 欄位設為略微超過 5000 (十進位) 的唯一值。

  4. 關閉登錄編輯程式。

  5. 重新啟動電腦，使此設定生效。

若要部署 RPC over HTTP

  1. 檢閱《Exchange Server 2003 RPC over HTTP 部署案例》(英文) (http://go.microsoft.com/fwlink/?linkid=47577)。

  2. 檢閱微軟知識庫文件 - 833401＜如何在 Exchange Server 2003 中為單一伺服器設定 RPC over HTTP＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)。

  3. 檢閱知識庫文件 - 827330＜如何疑難排解 Office Outlook 2003 用戶端的 RPC over HTTP 連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)。

  4. 檢閱 Microsoft Support WebCast＜透過網際網路 (RPC/HTTP) 搭配使用 Microsoft Exchange 與 Microsoft Office Outlook 2003＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Exchange 使用之靜態對應通訊埠的詳細資訊，請參閱下列知識庫文件：

  • 194952＜XADM：Exchange Server 的靜態對應通訊埠限制＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952)

  • 270836＜Exchange 2000 及 Exchange 2003 靜態連接埠對應＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)。


通訊埠衝突：儲存區 HTTP
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-03-21

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否存在任何通訊埠衝突：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Rpc/HTTP Port 登錄機碼由 Exchange 用來支援 Microsoft Office Outlook® 2003 RPC/HTTP 與 Exchange Server 2007 Outlook Anywhere 功能。如果 Exchange Server Analyzer 發現 HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters\Rpc/HTTP Port 的值符合本文稍早所列的其他 6 個通訊埠登錄值中的任何一個，就會顯示錯誤。Exchange Server Analyzer 也會顯示與 HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters\Rpc/HTTP Port 衝突的通訊埠錯誤。

若要更正此錯誤，您必須將此機碼或 Exchange Server Analyzer 輸出指定之衝突機碼的值，變更為唯一值。

如果要支援 RPC/HTTP Outlook 2003 或 Outlook 2007 用戶端，應該將 Rpc/HTTP Port 機碼設為十進位值 6001。此外，您還應該檢閱環境中的 RPC/HTTP 組態。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要設定 Rpc/HTTP 通訊埠登錄值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters

  3. 按兩下 Rpc/HTTP Port 機碼並將 [數值資料] 欄位設為略微超過 5000 (十進位) 的唯一值。

  4. 關閉登錄編輯程式。

  5. 重新啟動電腦，使此設定生效。

若要檢閱 RPC over HTTP 組態

  1. 檢閱《Exchange Server 2003 RPC over HTTP 部署案例》(英文) (http://go.microsoft.com/fwlink/?linkid=47577)。

  2. 檢閱＜部署 Outlook Anywhere＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80831)。

  3. 檢閱 Microsoft 知識庫文章 833401＜如何在 Exchange Server 2003 中為單一伺服器設定 RPC over HTTP＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)。

  4. 檢閱知識庫文章 827330＜如何疑難排解 Office Outlook 2003 用戶端的 RPC over HTTP 連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)。

  5. 檢閱 Microsoft Support WebCast＜透過網際網路 (RPC/HTTP) 搭配使用 Microsoft Exchange 與 Microsoft Office Outlook 2003＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱知識庫文章 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


通訊埠衝突：儲存區 TCP
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-30

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否存在任何通訊埠衝突：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

如果 Exchange Server Analyzer 發現 HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port 的值符合本文稍早所列的其他 6 個通訊埠登錄值中的任何一個，就會顯示錯誤。Exchange Server Analyzer 也會顯示與 HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port 衝突的通訊埠錯誤。

設定此值最常見的原因就是，讓 MAPI 用戶端能夠連線到在防火牆另一端的 Exchange 伺服器。此案例會開啟防火牆上的多個通訊埠，讓 Microsoft Office Outlook® 2003 或 Outlook 2007 用戶端使用 MAPI 連線到 Exchange 伺服器 (通常是透過網際網路連線)。

若要以 MAPI 模式使用 Outlook 透過網際網路連線到 Exchange 伺服器，建議的部署方式是使用 Microsoft Windows Server™ 2003、Exchange Server 2003、Outlook 2003、Exchange Server 2007、Outlook 2007 及 Microsoft Windows® XP Professional 中的 RPC over HTTP 功能。MAPI 模式先前稱為「公司」或「工作群組」模式。

若要更正此錯誤，您必須將此機碼或 Exchange Server Analyzer 輸出指定之衝突機碼的值，變更為唯一值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要設定 TCP/IP 通訊埠登錄值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 按兩下 TCP/IP Port 機碼並將 [數值資料] 欄位設為略微超過 5000 (十進位) 的唯一值。

  4. 關閉登錄編輯程式。

  5. 重新啟動電腦，使此設定生效。

若要部署 RPC over HTTP

  1. 檢閱《Exchange Server 2003 RPC over HTTP 部署案例》(英文) (http://go.microsoft.com/fwlink/?linkid=47577)。

  2. 檢閱＜部署 Outlook Anywhere＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80831)。

  3. 檢閱微軟知識庫文件 - 833401＜如何在 Exchange Server 2003 中為單一伺服器設定 RPC over HTTP＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)。

  4. 檢閱知識庫文件 - 827330＜如何疑難排解 Office Outlook 2003 用戶端的 RPC over HTTP 連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)。

  5. 檢閱 Microsoft Support WebCast＜透過網際網路 (RPC/HTTP) 搭配使用 Microsoft Exchange 與 Microsoft Office Outlook 2003＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Exchange 使用之靜態對應通訊埠的詳細資訊，請參閱微軟知識庫文件 - 270836＜Exchange 2000 及 Exchange 2003 靜態連接埠對應＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)。


通訊埠衝突：系統服務員 HTTP
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-03-21

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否存在任何通訊埠衝突：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Exchange 會使用 HTTP Port 機碼來支援 Microsoft Office Outlook® 2003 RPC/HTTP 與 Exchange Server 2007 Outlook Anywhere 功能。如果 Exchange Server Analyzer 發現 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port 的值符合本文稍早所列的其他 6 個通訊埠登錄值中的任何一個，就會顯示錯誤。Exchange Server Analyzer 也會顯示與 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port 衝突的通訊埠錯誤。

若要更正此錯誤，您必須將此機碼或 Exchange Server Analyzer 輸出指定之衝突機碼的值，變更為唯一值。

如果要支援 RPC/HTTP Outlook 2003 或 Outlook 2007 用戶端，應該將 HTTP Port 機碼設為十進位值 6002。此外，您還應該檢閱環境中的 RPC/HTTP 組態。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要設定 HTTP Port 登錄值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 按兩下 HTTP Port 機碼並將 [數值資料] 欄位設為略微超過 5000 (十進位) 的唯一值。

  4. 關閉登錄編輯程式。

  5. 重新啟動電腦，使此設定生效。

若要檢閱 RPC over HTTP 組態

  1. 檢閱《Exchange Server 2003 RPC over HTTP 部署案例》(英文) (http://go.microsoft.com/fwlink/?linkid=47577)。

  2. 檢閱＜部署 Outlook Anywhere＞(英文) (http://www.microsoft.com/technet/prodtechnol/exchange/e2k7help/7b2d1ce2-b6df-4604-80fd-2f6cafc47e82.mspx)。

  3. 檢閱 Microsoft 知識庫文章 833401＜如何在 Exchange Server 2003 中為單一伺服器設定 RPC over HTTP＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)。

  4. 檢閱知識庫文章 827330＜如何疑難排解 Office Outlook 2003 用戶端的 RPC over HTTP 連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)。

  5. 檢閱 Microsoft Support WebCast＜透過網際網路 (RPC/HTTP) 搭配使用 Microsoft Exchange 與 Microsoft Office Outlook 2003＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱知識庫文章 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


通訊埠衝突：系統服務員 HTTP NSPI
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-30

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否存在任何通訊埠衝突：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Rpc/HTTP NSPI Port 登錄機碼由 Exchange 用來支援 Microsoft Office Outlook® 2003 RPC/HTTP 與 Exchange Server 2007 Outlook Anywhere 功能。如果 Exchange Server Analyzer 發現 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port 的值符合本文稍早所列的其他六個通訊埠登錄值中指定的任何一個，就會顯示一則錯誤。Exchange Server Analyzer 也會顯示與 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\ Rpc/HTTP NSPI Port 衝突的通訊埠錯誤。

若要更正此錯誤，您必須將此機碼或 Exchange Server Analyzer 輸出指定之衝突機碼的值，變更為唯一值。

如果要支援 RPC/HTTP Outlook 2003 用戶端 或 Outlook 2007，應該將 Rpc/HTTP NSPI Port 機碼設為十進位值 6004。此外，您還應該檢閱環境中的 RPC/HTTP 組態。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要設定 Rpc/HTTP NSPI Port 登錄值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 按兩下 Rpc/HTTP NSPI Port 機碼並將 [數值資料] 欄位設為略微超過 5000 (十進位) 的唯一值。

  4. 關閉登錄編輯程式。

  5. 重新啟動電腦，使此設定生效。

若要檢閱 RPC over HTTP 組態

  1. 檢閱《Exchange Server 2003 RPC over HTTP 部署案例》(英文) (http://go.microsoft.com/fwlink/?linkid=47577)。

  2. 檢閱＜部署 Outlook Anywhere＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80831)。

  3. 檢閱微軟知識庫文件 - 833401＜如何在 Exchange Server 2003 中為單一伺服器設定 RPC over HTTP＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)。

  4. 檢閱知識庫文件 - 827330＜如何疑難排解 Office Outlook 2003 用戶端的 RPC over HTTP 連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)。

  5. 檢閱 Microsoft Support WebCast＜透過網際網路 (RPC/HTTP) 搭配使用 Microsoft Exchange 與 Microsoft Office Outlook 2003＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


通訊埠衝突：系統服務員 NSPI
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-03-21

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否存在任何通訊埠衝突：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

如果 Exchange Server Analyzer 發現 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port 的值符合本文稍早所列的其他 6 個通訊埠登錄值中的任何一個，就會顯示錯誤。Exchange Server Analyzer 也會顯示與 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port 衝突的通訊埠錯誤。

設定此值最常見的原因就是，讓 MAPI 用戶端能夠連線到在防火牆另一端的 Exchange 伺服器。此案例會開啟防火牆上的多個通訊埠，讓 Microsoft Office Outlook® 2003 或 Outlook 2007 用戶端使用 MAPI 連線到 Exchange 伺服器 (通常是透過網際網路連線)。

若要以 MAPI 模式使用 Outlook 透過網際網路連線到 Exchange 伺服器，建議的部署方式是使用 Microsoft Windows Server™ 2003、Exchange Server 2003、Outlook 2003、Exchange Server 2007、Outlook 2007 及 Microsoft Windows® XP Professional 中的 RPC over HTTP 功能。MAPI 模式先前稱為「公司」或「工作群組」模式。

若要更正此錯誤，您必須將此機碼或 Exchange Server Analyzer 輸出指定之衝突機碼的值，變更為唯一值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要設定 TCP/IP NSPI Port 登錄值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 按兩下 TCP/IP NSPI Port 機碼並將 [數值資料] 欄位設為略微超過 5000 (十進位) 的唯一值。

  4. 關閉登錄編輯程式。

  5. 重新啟動電腦，使此設定生效。

若要部署 RPC over HTTP

  1. 檢閱《Exchange Server 2003 RPC over HTTP 部署案例》(英文) (http://go.microsoft.com/fwlink/?linkid=47577)。

  2. 檢閱＜部署 Outlook Anywhere＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80831)。

  3. 檢閱 Microsoft 知識庫文章 833401＜如何在 Exchange Server 2003 中為單一伺服器設定 RPC over HTTP＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)。

  4. 檢閱知識庫文章 827330＜如何疑難排解 Office Outlook 2003 用戶端的 RPC over HTTP 連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)。

  5. 檢閱 Microsoft Support WebCast＜透過網際網路 (RPC/HTTP) 搭配使用 Microsoft Exchange 與 Microsoft Office Outlook 2003＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱知識庫文章 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Exchange 使用之靜態對應通訊埠的詳細資訊，請參閱下列知識庫文章：

  • 270836＜Exchange 2000 及 Exchange 2003 靜態連接埠對應＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)。


通訊埠衝突：系統服務員 RFR
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-30

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否存在任何通訊埠衝突：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

如果 Exchange Server Analyzer 發現 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port 的值符合本文稍早所列的其他 6 個通訊埠登錄值中的任何一個，就會顯示錯誤。Exchange Server Analyzer 也會顯示與 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port 衝突的通訊埠錯誤。

設定此值最常見的原因就是，讓 MAPI 用戶端能夠連線到在防火牆另一端的 Exchange 伺服器。此案例會開啟防火牆上的多個通訊埠，讓 Microsoft Office Outlook® 2003 或 Outlook 2007 用戶端使用 MAPI 連線到 Exchange 伺服器 (通常是透過網際網路連線)。

若要以 MAPI 模式使用 Outlook 透過網際網路連線到 Exchange 伺服器，建議的部署方式是使用 Microsoft Windows Server™ 2003、Exchange Server 2003、Outlook 2003、Exchange Server 2007、Outlook 2007 及 Microsoft Windows® XP Professional 中的 RPC over HTTP 功能。MAPI 模式先前稱為「公司」或「工作群組」模式。

若要更正此錯誤，您必須將此機碼或 Exchange Server Analyzer 輸出指定之衝突機碼的值，變更為唯一值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要設定 TCP/IP 通訊埠登錄值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 按兩下 TCP/IP Port 機碼並將 [數值資料] 欄位設為略微超過 5000 (十進位) 的唯一值。

  4. 關閉登錄編輯程式。

  5. 重新啟動電腦，使此設定生效。

若要部署 RPC over HTTP

  1. 檢閱《Exchange Server 2003 RPC over HTTP 部署案例》(英文) (http://go.microsoft.com/fwlink/?linkid=47577)。

  2. 檢閱＜部署 Outlook Anywhere＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80831)。

  3. 檢閱微軟知識庫文件 - 833401＜如何在 Exchange Server 2003 中為單一伺服器設定 RPC over HTTP＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)。

  4. 檢閱知識庫文件 - 827330＜如何疑難排解 Office Outlook 2003 用戶端的 RPC over HTTP 連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)。

  5. 檢閱 Microsoft Support WebCast＜透過網際網路 (RPC/HTTP) 搭配使用 Microsoft Exchange 與 Microsoft Office Outlook 2003＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Exchange 使用之靜態對應通訊埠的詳細資訊，請參閱微軟知識庫文件 - 270836＜Exchange 2000 及 Exchange 2003 靜態連接埠對應＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)。


偵測到發行前 Service Pack 更新彙總套件
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每一個 Exchange Server 物件的 versionNumber 屬性值。versionNumber 屬性代表電腦中執行的 Exchange Server 版本。

Exchange Server Analyzer 還會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Exchange Collaboration Data Object (ExCDO) 程式庫檔案 ExCDO.dll 的 Version 機碼值。如果 Exchange Server Analyzer 判定 ExCDO.dll 的 Version 機碼值等於 6603.0，就會顯示一則警告。

執行 ExCDO.dll 版本 6603.0 的 Exchange 2000 Server 電腦，表示伺服器正在執行 2004 年 8 月版本 1 的 Exchange 2000 Server Post-Service Pack 3 (SP3) 更新彙總套件。目前可以使用第 2 版的此更新彙總套件。建議您安裝 2004 年 8 月的更新彙總套件。

若要更正此警告

  1. 若要瞭解最新的更新，請檢閱微軟知識庫文件 - 870540＜2004 年 8 月 Exchange 2000 Server Post-Service Pack 3 更新彙總套件的可用性＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540)。

  2. 從「Exchange 2000 Server 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=33457)，下載最新更新項目 (2004 年 8 月)。

  3. 備份 Exchange Server 電腦。

  4. 套用 2004 年 8 月的更新彙總套件。

若需有關取得 Exchange 2000 Server 最新 Service Pack 的詳細資訊，請參閱微軟知識庫文件 - 301378＜如何取得最新的 Exchange 2000 Server Service Pack＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378)

若需有關安裝這個及其他 Exchange Server 更新的詳細資訊，請參閱知識庫文件 - 328839＜如何套用 Exchange Service Pack 及 Hotfix＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)


分頁檔位置發生問題
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具判定您分頁檔所在的位置會影響伺服器的效能。分頁檔不應該位在與 Exchange 資料庫或 Exchange 記錄檔相同的磁碟上。讓分頁檔與系統檔案分開也是很好的作法。

建議您將分頁檔放置在專用的磁碟分割或高速磁碟上。

若要更正此警告

  • 將分頁檔移動到未包含 Exchange 資料庫或記錄檔的位置中，可能的話，請移動到未包含系統磁碟分割的位置。

詳細資訊

  • 若需設定分頁檔的詳細資訊，請參閱微軟知識庫文件 - 197379＜設定分頁檔以在 Windows Server 2003、Windows 2000 及 Windows NT 中進行最佳化及復原＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=197379)。

  • 若需有關 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需有關疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《疑難排解 Microsoft Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


處理器瓶頸
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-02-24

Microsoft® Exchange Server Analyzer 工具已識別出您的伺服器遇到 CPU 瓶頸。您的伺服器 CPU 使用率已超過建議的閾值。用來識別處理器瓶頸或處理器使用問題的計數器包含：

  • [系統] 效能物件下的 [Context Switches/sec] 效能計數器。

  • [處理器] 效能物件下的 [% Processor Time (_Total)] 效能計數器。

  • [系統] 效能物件下的 [Processor Queue Length] 效能計數器。

偵測處理器瓶頸

如果達到下列其中一個條件，則 Exchange Server Analyzer 會偵測到瓶頸：

  • [處理程序] 效能物件下的 [% Processor Time (_Total)] 效能計數器平均值大於 70%。

  • [處理程序] 效能物件下的 [% Processor Time (_Total)] 效能計數器最大值大於 90%。

  • [系統] 效能物件下的 [Context Switches/second] 效能計數器平均值大於 20,000。

  • [系統] 效能物件下的 [Processor Queue Length] 效能計數器大於 2。

  • [處理器] 效能物件下的 [% Processor Time (_Total)] 效能計數器提供處理器的整體使用情況。平均 CPU 使用應恆小於 80%。平均值更高，則表示有處理器瓶頸。如果平均處理器使用高於 70%，則會顯示警告。處理器時間高於 90% 的經常性尖峰值也表示有處理器瓶頸。

  • [系統] 效能物件下的 [Processor Queue Length] 效能計數器指出處理器佇列中的執行緒數目。處理器時間有單一佇列，即使在多處理器的電腦上亦然。數目若大於 2，則表示執行緒正在等候處理器時間且有處理器瓶頸。

判別處理器負載來源

若發現處理器瓶頸，必須辦別大部分 CPU 使用的來源。在 Exchange 後端伺服器上，大部分 CPU 使用的來源應為 Store.exe 處理程序。如果 CPU 使用有 20% 以上是來自 Store.exe 以外的處理程序，建議您找出其他有哪些處理程序在消耗 CPU 使用。

如果列於下表之處理程序的 CPU 使用大於閾值，則 Exchange Server Analyzer 會顯示錯誤。

處理程序 | [處理程序] 效能物件下的 [%Processor Time] 效能計數器閾值
儲存區 | 90%
Inetinfo | 20%
Emsmts | 40%
Lsass | 40%
System | 40%
Mad | 40%
ExMGMT | 20%
W3WP | 40%

Exchange Server Analyzer 也會測量由 [處理程序] 效能物件下 [%Processor Time] 效能計數器 ([Idle] 執行個體) 及 [%Processor Time] 效能計數器 ([_Total] 執行個體) 所測量之閒置處理器時間的差異。在狀況良好的 Exchange 後端伺服器上，使用中的處理器時間至少應有 70% 是用於 Store.exe 處理程序。

在下列情況中，Exchange Server Analyzer 即會顯示錯誤：

  • 如果不是用於 Exchange 伺服器相關處理程序 (Store.exe、inetinfo.exe、emsmta.exe、lsass.exe、w3wp.exe、exmgmt.exe 或 mad.exe 處理程序) 的處理器時間量高於 35%。

  • 如果非 Exchange 相關處理器時間大於 20%。

  • 如果有處理器瓶頸，且用於 Store.exe 處理程序的處理器時間小於 70%。

在這些情況中，建議您找出其他有哪些處理程序在耗用伺服器的 CPU 時間。

後端伺服器上處理器瓶頸的常見原因

效能瓶頸有許多可能的原因，包括：

  • 伺服器上其他應用程式耗用 CPU 使用

  • 高 RPC 率

  • 通訊群組清單延伸

  • 在尖峰作業期間執行備份及維護

  • 下列狀況造成的郵件內容轉換：

    • 執行多個通訊協定 (例如 HTTP、POP3、IMAP4、Microsoft Office Outlook®)

    • 使用離線資料夾 (.ost 檔) 的 Outlook 2000 或更早的版本

排除處理器瓶頸

有許多方式可從 Exchange 伺服器排除處理器瓶頸。

若要排除處理器瓶頸

  • 可能的話，在伺服器中加入更多或更快的處理器。另外，如果處理器支援的話，請啟用超執行緒。您可以設定系統 BIOS 來啟用超執行緒。若需相關資訊，請參閱電腦製造商的說明文件。

  • 如果提升處理能力不是可行的選項，則必須降低處理器上的負載。若要降低對伺服器的整體影響，建議您確認 I/O 密集、CPU 密集或消耗記憶體的工作是在正常操作期間之外的時間執行。

    首先，識別哪些應用程式或工作造成伺服器上的負載。如果非 Exchange 應用程式對該伺服器不重要，請在其他伺服器上執行該應用程式。可能的話，也請將伺服器角色移至其他電腦。例如，若 Inetinfo 處理程序耗用大量 CPU 使用，請考慮增加前端伺服器，以擔負 Inetinfo 執行之通訊協定工作的責任。您也可將公用資料夾存取移至專用的公用資料夾伺服器。最後，如果伺服器執行大量通訊群組清單延伸，可以將通訊群組清單延伸移至專用的通訊群組清單延伸伺服器，以降低 CPU 使用。

  • 請確定 CPU 密集的工作 (如備份及維護工作) 是在離峰時間執行。也請確定這些工作是以經過安排的方式執行。安排工作的意思是為每個工作設定不同的開始時間，並最好設定結束時間。安排資料庫或儲存群組的維護及備份也可減少這些資源密集工作的影響。

  • 如果您移除所有選擇性的負載來源之後，CPU 使用仍然太高，則必須將使用者移至其他伺服器以減少負載。若需詳細資訊，請參閱將使用者信箱移至其他伺服器

詳細資訊

  • 若需有關 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需有關疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《疑難排解 Microsoft Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 若需有關移動使用者信箱以減少伺服器負載的詳細資訊，請參閱將使用者信箱移至其他伺服器


無法取得處理器效能監視器物件
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Processor 效能物件的 % Processor Time 效能計數器的資料，以分析效能資料。如果計數器未傳回有效的資料，Exchange Server Analyzer 便會顯示基準線訊息。

如果效能資料收集引擎未傳回有效的資料，則發生了下列任意狀況組合：

  • Processor 效能物件已停用。

  • Processor 效能監視器物件已遺失或已損毀。

  • Exchange Server Analyzer 沒有適當的權限可存取效能物件。

如果某個可擴充的計數器損毀了登錄，或使用 Microsoft Windows® Management Instrumentation (WMI) 的程式修改了登錄，就會發生前兩個狀況。下列程序解說如何修復前兩個狀況。在執行此程序前，請先確認 Exchange Server Analyzer 具有適當的權限。若需有關執行 Exchange Server Analyzer 所需權限的詳細資訊，請參閱包含在 Exchange Server Analyzer 中的說明文件。若需取得 [說明]，請開啟 Exchange Server Analyzer 並按 F1 鍵。

若要更正此錯誤

  1. 確認 Processor 效能物件已啟用。

    1. 下載並安裝 Extensible Performance Counter List 工具 (Exctrlst.exe)。您可以在下列位置下載 Exctrlst.exe：「Exctrlst.exe：Extensible Performance Counter List」(英文) (http://go.microsoft.com/fwlink/?LinkId=34436)。

    2. 開啟 Exctrlst.exe，並依序按一下 [Sort Order] 及 [Service]。

    3. 找出要讓效能物件報告的服務，並確認已選取 [Performance Counters Enabled] 核取方塊。

      如果未選取 [Performance Counters Enabled] 核取方塊，請選取此核取方塊，然後重新啟動與效能計數器相關的服務，確認效能計數器可運作。如果效能計數器未運作，或已選取 [Performance Counters Enabled] 核取方塊，請繼續步驟 2。

  2. 依照微軟知識庫文件 - 300956＜如何手動重建效能計數器程式庫值＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) 中的指示，重建遺失或損毀的效能計數器。

  3. 如果遵循此知識庫文件的指示並不能解決問題，則必須以 [修復] 模式重新安裝 Windows 作業系統，並套用最新的 Windows Service Pack。


公用資料夾內容複寫已暫停
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已在 Exchange Server 組織上設定 heuristics 屬性。如果 Exchange Server Analyzer 發現在 heuristics 中已設定位元 1024，就會顯示警告。

Exchange Server 2003 SP2 納入了可讓系統管理員停止組織內所有公用資料夾內容複寫的功能。在 [Exchange 系統管理] 中的 [組織名稱] 上按一下滑鼠右鍵，再按 [停止公用資料夾內容複寫]，可停止所有公用資料夾複寫。當按一下 [停止公用資料夾內容複寫] 後，即會在 heuristics 屬性中設定位元 1024。只有在極特殊的情況下才可停止所有公用資料夾複寫，如疑難排解整個組織的公用資料夾或郵件流程問題。

如果下列條件屬實，則必須恢復公用資料夾內容複寫：

  • 您不是在疑難排解問題。

  • 您無需另外停止所有公用資料夾內容複寫。

若要恢復組織層級的公用資料夾內容複寫

  1. 開啟 [Exchange 系統管理員]。

  2. 在 [Organization_Name] 上按一下滑鼠右鍵，再按 [恢復公用資料夾內容複寫]。

若需有關公用資料夾複寫的詳細資訊，請參閱《Exchange Server 公用資料夾的最佳作法》(英文) (http://go.microsoft.com/fwlink/?LinkId=46437)。


前端伺服器上有公用資料夾儲存區
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-09-07

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個 Exchange 伺服器上是否有公用資料夾儲存區。如果 Exchange Server Analyzer 發現 InformationStore 物件屬於 msExchPublicMDB 物件類別，表示該伺服器主控公用資料夾儲存區。

Exchange Server Analyzer 也會查詢 MicrosoftExchangeV2 Microsoft Windows® Management Instrumentation (WMI) 類別，以判定是否已設定 IsFrontEndServer 機碼的值。值為 True 表示 Exchange 伺服器已設定為前端伺服器，值為 False 表示 Exchange 伺服器不是設定為前端伺服器。如果 Exchange Server Analyzer 發現設定為前端伺服器的 Exchange 伺服器主控公用資訊儲存庫，就會顯示一則警告。

建議您不要在前端伺服器上執行公用資料夾儲存區。前端伺服器上不需要有公用資料夾儲存區，因為前端伺服器並不主控信箱。此外，公用資料夾複寫、公用資料夾轉介及記憶體流失存在一些已知問題，其發生情況是當公用資料夾儲存區位於執行 Exchange 2000 Server 的前端伺服器上時。因此，您應卸載前端伺服器上所有的公用資料夾儲存區。

卸載公用資料夾儲存區之後，您可以停用 Microsoft Exchange Information Store 服務，因為它再也不會在前端伺服器上執行任何功能。移除不需要的服務之後，就可以減輕負荷，並增加安全性及效能。

附註：
如果前端伺服器也會接收來自網際網路的簡易郵件傳送通訊協定 (SMTP) 郵件，則 Microsoft Exchange Information Store 服務應繼續執行，而且必須繼續裝載信箱儲存區。然而，前端伺服器上不應有公用資料夾儲存區。

若要停止及停用信箱公用資料夾資料庫

  1. 在 [Exchange 系統管理員] 中，展開 [伺服器]]，展開您的伺服器，再展開 [預設儲存群組]。

    以滑鼠右鍵按一下 [信箱儲存區 (ServerName)]，按一下 [卸載儲存區]，再按一下 [是]，以卸載儲存區。

    重要事項：
    若您使用前端伺服器來作為 SMTP Bridgehead 伺服器，就必須在伺服器上裝載信箱儲存區。若是如此，請勿卸載及刪除這個儲存區，但請確定此伺服器上沒有儲存任何信箱。

  2. 以滑鼠右鍵按一下 [信箱儲存區 (ServerName)]，再按一下 [內容]。

  3. 按一下 [資料庫] 索引標籤，選取 [不要在啟動時裝載此儲存區] 核取方塊，然後按一下 [確定]。

    以滑鼠右鍵按一下 [公用資料夾儲存區 (ServerName)]，再按一下 [卸載儲存區]。

    注意：
    在您卸載公用資料夾儲存區之前，請確定其他公用資料夾儲存區上有該公用資料夾的複本。否則，資訊可能會流失。

  4. 按一下 [是]，以卸載公用資料夾儲存區。

若要停用 Microsoft Exchange Information Store 服務

  1. 在 [服務] Microsoft Management Console (MMC) 嵌入式管理單元中，在 [名稱] 清單中的 [Microsoft Exchange Information Store] 上按一下滑鼠右鍵，再按 [內容]。

  2. 在 [啟動類型] 清單中，選取 [已停用]，然後按一下 [停止]。

永久刪除信箱及公用資料夾資料庫

  • 請遵循《Exchange Server 安全性強化手冊》中＜如何卸載及刪除信箱及公用資料夾儲存區＞的指引 (http://go.microsoft.com/fwlink/?LinkId=25210)。

若需有關在前端伺服器上執行儲存區服務之相關問題的詳細資訊，請參閱下列微軟知識庫文件：

  • 286822＜XCCC:前端伺服器建立到其自身的大量連線＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=286822)

  • 320298＜在執行 Exchange 2000 Server 的前端伺服器上建立的大量連線＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320298)

若需有關前端及後端伺服器的詳細資訊，請參閱《Exchange Server 2003 及 Exchange 2000 Server 前端及後端拓撲》手冊 (英文) (http://go.microsoft.com/fwlink/?linkid=34216)。


REAPI.DLL 檔案遺失
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔是否存在：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個上述檔案遺失，就會顯示一則錯誤。若要解決此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


Recipient Update Service is missing or is not configured
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-07-11

Microsoft Exchange Server Analyzer 工具會查詢 Active Directory 目錄服務，以判定目錄中每一個「收件者更新服務」物件的 msExchAddressListServiceLink 屬性值。msExchAddressListServiceLink 屬性是通訊清單服務和應該在其中執行通訊清單服務的 Exchange Server 電腦兩者之間的連結。如果 Exchange Analyzer 發現「收件者更新服務」物件沒有 msExchAddressListServiceLink 屬性，或物件的 msExchAddressListServiceLink 屬性值並未填入，就會顯示錯誤。

每一個「收件者更新服務」執行個體通常會和一部執行「收件者更新服務」的 Exchange Server 電腦產生關聯。如果您收到此訊息，表示「收件者更新服務」執行個體未和任何 Exchange Server 電腦產生關聯。這可能導致 Exchange 通訊清單及收件者無法更新。

為了讓這個「收件者更新服務」執行個體執行，必須將其和現有的 Exchange 伺服器產生關聯。

更正此錯誤

  1. 開啟 [Exchange 系統管理員]。

  2. 在 [收件者] 之下，按一下 [收件者更新服務]。在右窗格中，以滑鼠右鍵按一下適當的 [收件者更新服務] 執行個體，再按一下 [內容]。

  3. 在 [一般] 索引標籤中，於 [Exchange Server] 之下，按一下 [瀏覽]，然後指定要執行此執行個體的伺服器。

  4. 按 [確定] 兩次，使變更生效。

  5. 關閉 [Exchange 系統管理員]。

若需有關收件者更新服務的相關資訊，請參閱下列主題及 Microsoft 知識庫文章：

  • 《Exchange Server 2003 系統管理手冊》中的＜在 Exchange Server 2003 中管理收件者及收件者原則＞(英文) (http://go.microsoft.com/fwlink/?linkid=47617)

  • 328738＜收件者更新服務如何套用收件者原則＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828＜收件者更新服務如何填入通訊清單＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127＜如何檢查 Exchange 收件者更新服務的進度＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770＜Exchange 收件者更新服務執行的工作＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


建議更新叢集上的 Windows 2000 Server SP 4
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定在 Exchange 伺服器上執行的 Microsoft Windows® 作業系統版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion

附註：
CurrentVersion 值為 4.0 表示電腦正在執行 Microsoft Windows NT® Server 4.0。若值為 5.0，表示電腦執行的是 Microsoft Windows 2000 Server。若值為 5.2，表示電腦執行的是 Microsoft Windows Server™ 2003。

Exchange Server Analyzer 也會查詢 Win32_OperatingSystem Windows Management Instrumentation (WMI) 類別，以判定 ServicePackMajorVersion 機碼值。

最後，Exchange Server Analyzer 會查詢 Win32_Service WMI 類別，以判定是否已啟動 ClusSvc 服務。

如果下列條件存在，Exchange Server Analyzer 就會顯示最佳作法的組態訊息：

  • Exchange 伺服器位於執行已升級為 Service Pack 4 之 Windows 2000 Server 的電腦上。

  • ClusSvc 服務已啟動。

建議您評估可用的更新與 Hotfix，並判斷它們是否可解決環境中的問題。

若需有關執行 Windows 2000 Server 之伺服器的詳細資訊及該伺服器可用之更新的清單，請參閱微軟知識庫文件 - 895090＜Windows 2000 Service Pack 4 型伺服器叢集的建議 Hotfix＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895090)。


Remote Queue Length 超出閾值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-04-09

Microsoft Exchange Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 SMTP Server 效能物件的 Remote Queue Length 效能計數器的資料，以分析效能資料。

如果 Exchange Analyzer 判定 Remote Queue Length 計數器已在取樣時間配量期間超出尖峰值 1000，則會顯示錯誤。

SMTP Server\Remote Queue Length 計數器指出在簡易郵件傳送通訊協定 (SMTP) 佇列中等待遠端傳遞的郵件數目。Remote Queue Length 增加，表示郵件未傳送到其他伺服器。

無法傳送郵件的原因可能是網路或遠端伺服器發生中斷或效能問題。這些中斷或效能問題會造成網路或遠端伺服器無法有效率地接收郵件。

若要解決此錯誤，請使用下列連結中的資源來識別問題伺服器或網路元件，並解決效能問題。

詳細資訊

  • 若需疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Exchange Server 2003 效能疑難排解》的＜識別不佳效能的徵兆＞一節中的＜識別增加的郵件佇列＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需 Exchange Server 效能的詳細資訊，請參閱＜Exchange Server 2003 效能：10 件要考慮的事情＞(英文) (http://go.microsoft.com/fwlink/?LinkID=56460)。


Remote Retry Queue Length 超出閾值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-02-13

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 SMTP Server 效能物件的 Remote Retry Queue Length 效能計數器的資料，以分析效能資料。

SMTP Server\Remote Retry Queue Length 計數器指出簡易郵件傳送通訊協定 (SMTP) 遠端重試佇列中有多少郵件無法傳送至目的地伺服器。如果 Exchange Server Analyzer 判定 Remote Retry Queue Length 計數器已在取樣時間配量期間超出尖峰值 1000，則會顯示錯誤。

無法傳送郵件的原因可能是網路或遠端伺服器發生中斷或效能問題。這些中斷或效能問題會造成網路或遠端伺服器無法有效率地接收郵件。

若要解決此錯誤，請使用下列連結中的資源來識別問題伺服器或網路元件，並解決效能問題。

詳細資訊

  • 若需疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Exchange Server 2003 效能疑難排解》的＜識別不佳效能的徵兆＞一節中的＜識別增加的郵件佇列＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需 Exchange Server 效能的詳細資訊，請參閱＜Exchange Server 2003 效能：10 件要考慮的事情＞(英文) (http://go.microsoft.com/fwlink/?LinkID=56460)。


找不到離線通訊錄版本 4 的複本
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-02-13

Microsoft® Exchange Server Analyzer 工具會查詢 Exchange_Public_Folder Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 HasLocalReplica 目前的值。如果 Exchange Server Analyzer 發現離線通訊清單之離線通訊錄版本 4 執行個體的 HasLocalReplica 值設為 [False]，則會顯示錯誤。

當離線通訊清單的離線通訊錄版本 4 執行個體的 HasLocalReplica 設為 [False] 時，便無法正確產生離線通訊清單。因此，Microsoft Office Outlook® 2003 的使用者無法下載任何離線通訊清單。

若未設定任何公用資料夾儲存區來存放離線通訊錄版本 4 的複本，就會發生這個問題。依預設，離線通訊錄會將其內容複寫到安裝它的伺服器之公用資料夾儲存區中。若從離線通訊錄的複寫組態中移除公用資料夾儲存區，便會產生上一段所提到的問題。

若要更正此錯誤

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [系統管理群組]，再按一下 [資料夾]。

  3. 以滑鼠右鍵按一下 [公用資料夾]，然後按一下 [檢視系統資料夾]。

  4. 按一下以展開 [離線通訊錄] 物件。

  5. 在 [離線通訊錄] 的 [o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List] 上按一下滑鼠右鍵，再按一下 [內容]。

  6. 在 [複寫] 索引標籤上，驗證已在 [將內容複寫到這些公用儲存區] 方塊中輸入公用資料夾儲存區。若未輸入公用資料夾儲存區，請按一下 [新增]，然後為離線通訊錄輸入適當的公用儲存區。

  7. 按一下 [套用]，然後按一下 [確定]。

  8. 按一下以展開 o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List。

  9. 在 o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List 下的 [離線通訊錄版本 4] 上按一下滑鼠右鍵，再按一下 [內容]。

  10. 在 [複寫] 索引標籤上，驗證已在 [將內容複寫到這些公用儲存區] 方塊中輸入公用資料夾儲存區。若未輸入公用資料夾儲存區，請按一下 [新增]，然後為離線通訊錄輸入適當的公用儲存區。

  11. 按一下 [套用]，然後按一下 [確定]。

若需此問題的詳細資訊，請參閱微軟知識庫文件 - 286328＜通訊錄遺失且無法在 Microsoft Exchange 中產生＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328)。

若需如何從系統管理群組正確移除預設 Exchange Server 2003 電腦的詳細資訊，請參閱知識庫文件 - 822931＜如何從系統管理群組中移除預設 Exchange Server 2003 電腦＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822931)。

若需通訊錄問題的詳細資訊，請參閱下列 Exchange Server 資源：

  • ＜離線通訊錄 - 考量事項＞(英文) (http://go.microsoft.com/fwlink/?LinkId=57581)

  • ＜Outlook 2003 SP2 及 Exchange Server 2003 SP2 OAB 版本 4 如何一起運作 ＞(英文) (http://go.microsoft.com/fwlink/?linkid=53099)

  • ＜Exchange Server 2003 Service Pack 2 中的 OAB 版本 4＞(英文) (http://go.microsoft.com/fwlink/?linkid=53097)


Replication Receive Queue 佇列長度超出閾值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-02-13

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 MSExchangeIS Public 效能物件的 Replication Receive Queue Size 效能計數器的資料，以分析效能資料。

如果 Exchange Server Analyzer 判定 Replication Receive Queue Size 計數器已在取樣時間配量期間超出尖峰值 1000，則會顯示錯誤。

由 SMTP 接收的公用資料夾複寫郵件，分類之後傳送到本機 SMTP 佇列。然後再將郵件提交到公用資料夾儲存區。將它們提交到公用資料夾儲存區之後，會將郵件放入複寫接收佇列中。然後會處理複寫接收佇列中的郵件，並在適當的公用資料夾上執行這些變更。Replication Receive Queue Size 效能計數器指出等候處理的公用資料夾複寫郵件數目。

複寫佇列變得越大，資料夾中的內容變得越來越不同步。當複寫佇列變大時，在處理複寫佇列中的郵件時，資源的負載也會隨之增加。同時，變大的複寫佇列也表示伺服器上的公用資料夾內容已過時。

在預期複寫接收佇列變大和可事先規劃複寫接收佇列變大的兩個案例中，不需要任何動作：

  • 在新推出的公用資料夾伺服器上，複寫接收佇列變大可能是由預期的初始回填複寫所造成。

  • 如果 Exchange 拓樸發生站台合併或其他重大變更，當內容移動時，預期應該會發生許多複寫。

對於目前不大幅變更公用資料夾複本而呈穩定狀態的伺服器，此錯誤可能指出：

  • 伺服器資源效能瓶頸，例如磁碟、CPU、網路或記憶體。如果伺服器有資源瓶頸，Store.exe 處理程序將無法太快處理複寫郵件，且佇列會變大。

  • 公用資料夾複寫間隔大小，使複寫作業無法在下一個複寫週期開始之前完成。

若要解決這個錯誤，請採取下列步驟：

  • 增加複寫間隔時間並監視 MSExchangeIS Public\Replication Receive Queue Size，直到它顯示已在下一個複寫週期開始之前完成複寫。

  • 在下列連結中使用資源來判斷效能瓶頸是否造成佇列變大，並解決瓶頸問題。

  • 考慮減少 Exchange 組織中的複本總數，以減少所需的複寫傳輸量。

詳細資訊

  • 若需疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》中的＜處理特殊 Exchange 角色和效能＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47588) 。

  • 若需 Exchange Server 公用資料夾複寫的詳細資訊，請參閱《使用 Exchange Server 2003 儲存區》中的＜控制 Exchange Server 2003 公用資料夾複寫＞(http://go.microsoft.com/fwlink/?LinkId=47595) 。

  • 若需 Exchange 公用資料夾最佳作法的詳細資訊，請參閱＜Exchange 公用資料夾最佳作法：實作複寫＞ (英文) (http://go.microsoft.com/fwlink/?LinkId=46440)。

  • 若需 Exchange Server 2003 Service Pack 2 所推出的公用資料夾管理功能改進的詳細資訊，請參閱＜Microsoft Exchange Server 2003 Service Pack 2 版本資訊＞ (英文) (http://go.microsoft.com/fwlink/?linkid=52072)。


遺失 RESVC.DLL 檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔是否存在：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個上述檔案遺失，就會顯示一則錯誤。若要解決此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 Microsoft Exchange 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


已啟用 RestrictRemoteClients 登錄機碼
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已啟用遠端程序呼叫 (RPC) 介面限制：

HKEY_LOCAL_MACHINE\ Software\Policies\Microsoft\Windows NT\RPC

如果 Exchange Server Analyzer 發現已設定 RestrictRemoteClients 登錄機碼，就會顯示非預設的組態訊息。

RPC 介面限制提供更多的網路保護功能，可降低系統受到網路攻擊的機會。RestrictRemoteClients 登錄值會修改系統中所有 RPC 介面的行為。在預設的情況下，RestrictRemoteClients 登錄值會禁止對系統上的 RPC 介面進行遠端匿名存取 (但有某些例外)。

如果介面是使用 RpcServerRegisterIf 註冊的，則 RPC 會允許伺服器應用程式限制對介面的存取 (通常透過安全性回呼進行)。RestrictRemoteClients 登錄值可讓 RPC 對所有介面執行其他安全性檢查，即使介面不具有已註冊的安全性回呼。

附註：
使用具名管道通訊協定順序的 RPC 用戶端免受所有限制。由於會有嚴重的舊版相容性問題，所有無法對管道通訊協定順序進行限制。
附註：
您也可使用群組原則物件編輯器來設定 the RestrictRemoteClients 登錄機碼。

使用 DWORD 值，可以設定 RestrictRemoteClients 登錄機碼。如果登錄值不存在，則不存在的值等於 RPC_Restrict_Remote_Client_Default。

下表提供有關 RestrictRemoteClients 組態設定的資訊。

登錄機碼值 (DWORD) 描述

0 (預設值)

RPC_RESTRICT_REMOTE_CLIENT_NONE (0) 代表 Microsoft Windows Server™ 2003 Service Pack 1 中的預設值。該預設值設定會讓系統略過 RPC 介面限制。

預設值設定對應於 RPC_RESTRICT_REMOTE_CLIENT_NONE 的值。伺服器應用程式負責實施適當的 RPC 限制。此預設設定等於更早版本 Windows 中的 RestrictRemoteClients 設定。

1

RestrictRemoteClients 登錄機碼上的值 1 代表 Microsoft Windows® XP Service Pack 2 中的預設值。值設定 1 會限制對所有 RPC 介面的存取。所有遠端匿名呼叫都會被 RPC 執行階段拒絕。

這個值設定對應於 RPC_RESTRICT_REMOTE_CLIENT_DEFAUL 的值。如果介面註冊安全性回呼，並提供 RPC_IF_ALLOW_CALLBACKS_WITH_NO_AUTH 旗標，則這個限制不會套用至該介面。

2

RestrictRemoteClients 登錄機碼上的值 2 表示所有遠端匿名呼叫都會被 RPC 執行階段拒絕 (無一例外)。

這個值設定對應於 RPC_RESTRICT_REMOTE_CLIENT_HIGH 的值。當 RestrictRemoteClients 值設為 2 時，系統無法使用 RPC 來接收遠端匿名呼叫。

若需有關 Windows XP Service Pack 2 的 RPC 服務有何變更的詳細資訊，請參閱 MSDN® 文件＜RPC 介面限制＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47371)。


RFR 目標伺服器已經被手動覆寫
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取 Exchange 伺服器上的下列登錄項目，以判定是否已手動覆寫目錄服務 Proxy 轉介 (DSProxy referral) 服務：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\RFR Target Server

如果 Exchange Server Analyzer 發現 RFR Target Server 存在而且已設定，就會顯示非預設的組態訊息。

Microsoft Outlook® 2000 Service Release 2 (SR-2) 或更新版本的用戶端在第一次連線至 Exchange 2000 Server 或 Exchange Server 2003 電腦時，會在 Exchange 主伺服器上尋找目錄服務。Outlook 最初會在第一個工作階段中進行 DSProxy 處理程序。在用戶端連絡上 DSProxy 服務之後，就會傳回一個 DSProxy 轉介給用戶端，通知它以後所有的目錄要求都應傳給通用類別目錄伺服器。Outlook 會在登錄的 MAPI 設定檔中設定 DSProxy 轉介資訊。

DSProxy 轉介機制可減輕 Exchange 伺服器的負載，並縮短搜尋通訊錄的延遲時間。如果已在設定檔中輸入明確的伺服器名稱，則該通用類別目錄伺服器若是失敗，就必須重新啟動 Outlook。如果發生這種情形，Exchange 伺服器會傳給 Outlook 新的轉介。

在某些情況下，將 RFR Target Server 項目進行硬式編碼是比較好的作法，這樣可以指定應該要用哪些伺服器來提供 MAPI 用戶端轉介服務。例如，在將通用類別目錄伺服器降階為成員伺服器之前的那一週，您應該將 RFR Target Server 項目硬式編碼成已定義的通用類別目錄伺服器群組。這樣才可確保降階的通用類別目錄伺服器不會再被 Outlook 用戶端的 MAPI 設定檔參考。若需有關 RFR Target Server 登錄項目此種特定用法的詳細資訊，請參閱微軟知識庫文件 - 305065＜XADM：將通用類別目錄伺服器降階為網域控制站的 Exchange Server 相關注意事項＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=305065)。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要使用 RFR Target Server 登錄值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 建立一個名為 RFR Target Server 的新 REG_MULTISZ 值。

  4. 將 RFR Target Server 值設定為所要指定伺服器的完整網域名稱。

  5. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange System Attendant 服務，以使變更生效。

若要停用 RFR 伺服器的靜態設定，請移除所要移除伺服器的完整網域名稱項目。如果只輸入一個 RFR 目標伺服器，請刪除 RFR Target Server 登錄值。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Outlook 2000 SR-2 及更新版本的用戶端如何與 Active Directory® 目錄服務互動的詳細資訊，請參閱下列微軟知識庫文件：

  • 302914＜XCCC:Outlook 2000 如何存取 Active Directory＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914)

  • 256976＜XCLN：MAPI 用戶端如何存取 Active Directory＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976)


目前已啟用 RegTrace
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已在 Exchange Server 電腦上啟用進階診斷追蹤功能：

HKEY_LOCAL_MACHINE\Software\Microsoft\MosTrace\CurrentVersion\DebugAsyncTrace\EnabledTraces

如果 Exchange Server Analyzer 發現 EnabledTraces 登錄項目存在，且已設定非 0 的值，就會顯示錯誤。

您可以使用 Regtrace 公用程式 (Regtrace.exe) 來完成 Exchange Server 傳輸及路由元件的進階診斷追蹤作業。對於診斷及疑難排解未傳遞回報 (NDR)，Regtrace 工具特別好用。您可以在 Exchange Server 光碟的 \Support\Utils\I386 資料夾中找到 Regtrace 公用程式。

追蹤檔案位於 Regtrace 公用程式之 [輸出] 索引標籤上所指定的位置。檔案的預設位置是 C:\Trace.atf。追蹤檔是二進位編碼的檔案，其中包含所追蹤之傳輸及路由元件的相關偵錯層次資訊。因此，Microsoft 產品支援服務需要客戶傳送追蹤檔，以進行內部分析。

除非您要主動疑難排解問題，否則 Microsoft 特別提醒您，啟用 Regtrace 會造成伺服器效能嚴重下降，因此只應在 Microsoft 產品支援服務的嚴密指導下短期使用此工具。除了效能之外，還會以每分鐘 10 MB 或以上的速率消耗追蹤檔的磁碟空間。如果您不排解問題，又想解決這個錯誤，則可使用 Regtrace 來停用追蹤功能。

以 Regtrace 來停用進階診斷追蹤功能

  1. 將 Regtrace.exe 從 Exchange Server 光碟複製到 Exchange Server 電腦。

  2. 在 Exchange Server 電腦上執行 Regtrace.exe。此時會出現 Regtrace 使用者介面。

  3. 在 [追蹤] 索引標籤上，清除所有核取方塊。

  4. 選取 [輸出] 索引標籤，再選取 [不追蹤]。

  5. 按一下 [確定]，以儲存您的變更，並關閉 Regtrace 公用程式。
  • 若需有關 Regtrace 工具的詳細資訊，請參閱微軟知識庫文件 - 238614＜XCON：如何設定 Exchange 2000 的 Regtrace＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=238614)。

  • 若需有關一般郵件t傳送疑難排解的詳細資訊，請參閱知識庫文件 - 281800＜XCON：疑難排解 Exchange 2000 的郵件失敗＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=281800)。


Rejection threshold not configured
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-07-30

Microsoft Exchange Analyzer 工具會查詢 Active Directory 目錄服務，取得類別為 ContentFilterConfig 之所有物件上的下列屬性值：

msExchAgentsFlags msExchAgentsFlag 屬性的值指出 Microsoft Exchange Server 2007 內容篩選器代理程式的狀態及垃圾郵件信賴等級 (SCL) 拒絕動作。在電腦上啟用內容篩選器代理程式之後，內容篩選器代理程式就會篩選那些透過該電腦上的所有接收連接器進入的所有郵件。SCL 拒絕動作若已啟用，會在 SMTP 交易期間針對超過 SCL 拒絕閾值的所有郵件傳送拒絕回應。

msExchMessageHygieneSCLRejectThreshold msExchMessageHygieneSCLRejectThreshold 屬性的值指出針對 SCL 拒絕動作所設定的等級。此值代表 SCL 分級，特定郵件必須超過此分級，內容篩選器代理程式才會拒絕郵件並傳送未傳遞回報 (NDR) 給寄件者。

Exchange Analyzer 也會執行下列 Exchange 管理命令介面指令程式，來查詢安裝了反垃圾郵件代理程式的所有 Hub Transport server role：

Get-TransportServer | where { $_.AntispamAgentsEnabled -eq $True}

如果 Exchange Analyzer 發現某伺服器下列所有狀況都存在，Exchange Analyzer 就會顯示警告：

  • 已啟用內容篩選

  • 已啟用 SCL 拒絕動作

  • SCL 拒絕閾值設為 9

  • 伺服器已啟用反垃圾郵件代理程式

此警告表示雖然已啟用內容篩選和 SCL 拒絕動作，但 SCL 拒絕動作閾值設為預設值 9。這可能導致來自合法使用者的郵件遭到拒絕。SCL 拒絕動作閾值的建議設定是 7。

若要解決此警告，請使用 Exchange 管理主控台中的 [反垃圾郵件] 索引標籤，或在 Exchange 管理命令介面中使用 Set-ContentFilterConfig 指令程式，將 SCL 拒絕動作閾值設為 7。

若要設定 SCL 拒絕動作閾值，請遵循 Exchange Server 2007 產品文件中，＜如何啟用及設定垃圾郵件信賴等級閾值》(http://go.microsoft.com/fwlink/?LinkId=96099) (英文) 主題中的指導。

詳細資訊

如需管理 Exchange Server 2007 反垃圾郵件及防毒功能的相關資訊，請參閱 Exchange Server 2007 產品文件中的＜管理反垃圾郵件及防毒功能＞(http://go.microsoft.com/fwlink/?LinkId=96103) (英文)。


收件者更新服務已刪除
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-04-20

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定目錄中每一個收件者更新服務物件的 msExchAddressListServiceLink 屬性值。msExchAddressListServiceLink 屬性是通訊清單服務與應該執行該通訊清單服務的 Exchange Server 電腦兩者之間的連結。如果 Exchange Server Analyzer 發現 msExchAddressListServiceLink 屬性值設為 DEL:，就會顯示錯誤。

每一個「收件者更新服務」執行個體都會和一部執行「收件者更新服務」的 Exchange Server 電腦產生關聯。如果您收到這則訊息，表示「收件者更新服務」執行個體是和不在 Exchange 組織內的 Exchange Server 電腦產生關聯。該伺服器可能已除役，或從拓樸中移除。

為了讓這個「收件者更新服務」執行個體執行，必須將其和現有的 Exchange 伺服器產生關聯。

若要更正此錯誤

  1. 開啟 [Exchange 系統管理員]。

  2. 在 [收件者] 之下，按一下 [收件者更新服務]。在右窗格中，以滑鼠右鍵按一下適當的 [收件者更新服務] 執行個體，再按一下 [內容]。

  3. 在 [一般] 索引標籤中，於 [Exchange Server] 之下，按一下 [瀏覽]，然後指定一部要執行此執行個體的新伺服器。

  4. 按 [確定] 兩次，使變更生效。

  5. 關閉 [Exchange 系統管理員]。

若需有關收件者更新服務的詳細資訊，請參閱下列 Exchange 主題及微軟知識庫文件：

  • 《Exchange Server 2003 系統管理手冊》(http://go.microsoft.com/fwlink/?linkid=47617) 中的＜管理收件者及收件者原則＞(英文)。

  • 328738＜XADM：收件者更新服務如何套用收件者原則＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828＜收件者更新服務如何擴展通訊清單＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127＜XADM：如何檢查收件者更新服務的進度＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770＜XADM：收件者更新服務執行的工作＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


RPC 繫結不包含 FQDN
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 networkAddress 屬性的 ncacn_ip_tcp 值是否包含完整網域名稱 (FQDN)。如果 Exchange Server Analyzer 發現 ncacn_ip_tcp 值不包含句點 (.)，就會顯示一則錯誤。

在 Microsoft Office Outlook® Web Access for Exchange Server 2003 中，前端伺服器會在嘗試連線到 Exchange 後端伺服器時，檢查 networkaddress 屬性值。

附註：
Outlook Web Access for Exchange 2000 Server 則無法這樣做。前端伺服器需要 FQDN 值。

前端伺服器會檢查 networkaddress ncacn_ip_tcp 傳回值中是否有句點。如果下列條件存在，對特定後端伺服器上的信箱發出的連線要求會失敗，而且前端伺服器會將「HTTP 500 內部伺服器錯誤」錯誤訊息傳回給使用者：

  • ncacn_ip_tcp 值只是主機名稱或網路基本輸入/輸出系統 (NetBIOS) 名稱。

  • ncacn_ip_tcp 值不是 FQDN。

您必須更新 Active Directory 中伺服器物件上的 ncacn_ip_tcp 值，以確保 Outlook Web Access for Exchange Server 2003 正常運作。會在 Exchange Server Analyzer 輸出中提供受影響的伺服器名稱。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
附註：
更新 ncacn_ip_tcp 值前，請先閱讀本文章其餘的部分。重新啟動 Exchange Server 服務前，可能要執行額外的程序。
若要更新 networkAddress 屬性的 ncacn_ip_tcp 值

  1. 從 Windows 2000 Server 支援工具或 Windows Server 2003 支援工具啟動 ADSI 編輯器工具。

  2. 展開下列節點：

    • 組態容器

    • 組態

    • 服務

    • Microsoft Exchange

    • Organization_Name

    • 系統管理群組

    • Administrative_Group_Name

    • 伺服器

  3. 在 Exchange_Server_Name 上按一下滑鼠右鍵，然後再按 [內容]。

  4. 按一下 [屬性] 清單中的 networkaddress，然後按一下 [編輯]。

  5. 為 ncacn_ip_tcp 新增值。請使用伺服器的 FQDN，而不是伺服器的 NetBIOS 名稱或主機名稱。

    此值的語法是 ncacn_ip_tcp:FQDN。例如，如果 Exchange 後端伺服器的主機名稱為 EXCHANGE1 且 FQDN 為 EXCHANGE1.contoso.com，請為 ncacn_ip_tcp 使用下列值：ncacn_ip_tcp:EXCHANGE1.contoso.com。

  6. 藉由選取原始值並按一下 [移除]，來移除包含後端伺服器之 NetBIOS 名稱或主機名稱的原始 ncacn_ip_tcp 值。按兩次 [確定] 套用變更。

  7. 重新啟動伺服器上所有的 Exchange Server 服務。

  8. 如果有多個網域控制站，請等待複寫完成後，再嘗試從前端伺服器登入。如果複寫完成後問題仍未解決，請重新啟動前端伺服器的 IIS Admin Service。

如果在後端伺服器上保留主機檔案，以與具有簡短主機名稱的伺服器 IP 位址相互關聯，您還必須更新 UpdateProtocols 登錄值。如果使用主機檔案，在重新啟動 Microsoft Exchange System Attendant 時，Exchange Server 可能會將 ncacn_ip_tcp 值變回原始值。如果後端伺服器是叢集式，Exchange Server 可能會在容錯移轉後將 ncacn_ip_tcp 值變回原始值。

若要將重新啟動 Exchange Server 服務所造成的停機時間降到最低，請先執行下列程序，然後再如前一程序中所述，藉由更新 networkaddress 屬性的 ncacn_ip_tcp 值來重新啟動 Exchange Server 服務。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要在使用主機檔案的後端伺服器上修改 UpdateProtocols 登錄值

  1. 使用登錄編輯程式來設定後端伺服器上的下列登錄值： HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\UpdateProtocols

    附註：
    如果 UpdateProtocols 值不存在，則必須建立這個值。若要這樣做，請遵循下列步驟：
    1. 開啟登錄編輯程式，並尋找下列登錄子機碼： HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\

    2. 在 [Parameters] 上按一下滑鼠右鍵，指向 [新增]，然後按一下 [DWORD 值]。

    3. 鍵入 UpdateProtocols，然後按 ENTER 鍵。

  2. 以滑鼠右鍵按一下 [UpdateProtocols]，再按 [修改]，並在 [數值資料] 欄位中鍵入 0，然後按 [確定]。

  3. 如果您的網路在後端叢集節點上使用 Hosts 檔案，請修改項目的 UpdateProtocols 順序，如下所示：

    與 FQDN 對應的 IPAddress

    與 NetBIOS 對應的 IPAddress

    而非：

    與 NetBIOS 對應的 IPAddress

    與 FQDN 對應的 IPAddress

  4. 重新啟動伺服器上所有的 Exchange Server 服務。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


RPC 繫結與 DNS 解析名稱不符
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-03-21

Microsoft® Exchange Server Analyzer 工具會對每個 Exchange Server 電腦所設定的 DNS 伺服器，嘗試進行網域名稱系統 (DNS) 查詢。此連線是透過自訂物件處理器建立，該處理器會執行名稱解析要求並分析結果。Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定 networkAddress 屬性的伺服器 ncacn_ip_tcp 值與解析 DNS 後傳回的網域全名 (FQDN) 是否不同。networkAddress 屬性是 Active Directory 中每個 Exchange Server 物件的屬性。如果 Exchange Server Analyzer 發現 Active Directory 中的伺服器 ncacn_ip_tcp 值與解析 DNS 後的 FQDN 不符，就會顯示警告。

如果在安裝 Exchange 之後變更伺服器的 FQDN，就會出現此情況。Exchange Server 和 Active Directory 都需要正確地設定及狀況良好的 DNS，才能正確地運作。網域命名服務註冊及解析問題，對於 Exchange Server 電腦傳送、接收及傳遞郵件的能力有顯著的影響。手動編輯 Active Directory 中 Exchange Server 物件的 networkAddress 屬性使兩個位址相符，即可防止這些問題。

您必須更新 Active Directory 中伺服器物件的 ncacn_ip_tcp 值，以確保 ncacn_ip_tcp 值與伺服器的 DNS FQDN 相符。會在 Exchange Server Analyzer 輸出中提供受影響的伺服器名稱。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或 Exchange Server 2007，或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
若要更新 networkAddress 屬性的 ncacn_ip_tcp 值

  1. 從 Windows® 2000 支援工具或 Windows Server 2003 支援工具啟動 [ADSI 編輯器] 工具。

  2. 展開下列節點：

    • 組態容器

    • 組態

    • 服務

    • Microsoft Exchange

    • Organization_Name

    • 系統管理群組

    • Administrative_Group_Name

    • 伺服器

  3. 在 Exchange_Server_Name 上按一下滑鼠右鍵，然後再按 [內容]。

  4. 按一下 [屬性] 清單中的 [networkaddress]，再按 [編輯]。

  5. 為 ncacn_ip_tcp 新增值。請使用伺服器的 FQDN，而不要使用目前值。

    此值的語法是 ncacn_ip_tcp:FQDN。例如，如果 Exchange 伺服器的主機名稱為 EXCHANGE1，且 FQDN 為 EXCHANGE1.contoso.com，請為 ncacn_ip_tcp 使用下列值：ncacn_ip_tcp:EXCHANGE1.contoso.com。

  6. 移除包含錯誤伺服器名稱的原始 ncacn_ip_tcp 值，方法為選取該原始值，再按 [移除]。按兩次 [確定] 套用變更。

  7. 重新啟動伺服器上所有的 Exchange Server 服務。

若需有關搭配使用 DNS 與 Active Directory 的詳細資訊，請參閱 Microsoft 知識庫文章 323418＜HOW TO：當 Windows Server 2003 中已啟用 Active Directory 時將 DNS 與現有的 DNS 基礎結構整合＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=323418)。


RPC 繫結順序不正確
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Exchange Server 電腦使用的遠端程序呼叫 (RPC) 繫結順序：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Svr_Binding_Order

如果 Exchange Server Analyzer 發現 Rpc_Svr_Binding_Order 的值不是以 ncacn_ip_tcp 為開頭，就會顯示一則錯誤。

在電腦上安裝 Exchange Server 時會建立 Rpc_Svr_Binding_Order 登錄項目。此項目決定用於伺服器對伺服器的 RPC 通訊的通訊協定順序。

在預設的情況下，Rpc_Svr_Binding_Order 項目包含下列值資料：

ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp

附註：
如果 Exchange Server 電腦上也安裝了其他通訊協定，則字串中還會有其他值。

此項目指定 Exchange Server 與其他伺服器進行 RPC 通訊時，要嘗試使用的網路通訊協定順序。例如，因為第一個指定的是 TCP/IP，所以 Exchange Server 會先嘗試使用 RPC over TCP/IP 來與其他伺服器通訊，然後才會嘗試透過其他通訊協定來進行 RPC 通訊。

建議您不要變更 RPC 繫結順序的預設值。如果有變更預設值，那麼在伺服器或服務啟動期間，或在伺服器對伺服器的通訊期間可能會發生問題。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\Software\Microsoft\Exchange\Exchange Provider

  3. 在右窗格中，連按兩下 Rpc_Svr_Binding_Order。

  4. 在 [數值資料] 對話方塊中，鍵入 ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp。

  5. 按一下 [確定]，然後關閉登錄編輯程式。

  6. 重新啟動所有的 Exchange Server 服務，或重新啟動 Exchange Server 電腦，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 RPC 繫結順序的詳細資訊，請參閱知識庫文件 - 325930＜如何疑難排解 RPC 用戶端通訊協定登錄項目造成的連線能力問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325930)。


Rpc_Binding_Order 登錄項目已存在
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，檢查用戶端導向的遠端程序呼叫 (RPC) 繫結順序登錄項目是否存在於 Exchange Server 電腦上：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Binding_Order

如果 Exchange Server Analyzer 發現 Rpc_Binding_Order 存在，將會顯示警告。

如果 Rpc_Binding_Order 值存在，則表示電腦上已安裝下列一個或多個項目：

  • Exchange Server 版本 5.5

  • Microsoft Office Outlook® 2003

  • Windows 叢集

  • RPC_Binding_Order 項目決定起始 Outlook RPC 通訊時使用的通訊協定順序。Exchange Server 2003 或 Exchange 2000 Server 中不會建立這個項目。這個項目僅會在 Exchange Server 5.5 及更早版本的 Exchange 中建立。如果此電腦上先前已安裝後來又移除 Exchange Server 5.5 或 Microsoft Outlook，您可手動移除此登錄項目。此外，由於不受支援，所以您應從執行 Exchange Server 的所有電腦上移除 Outlook。若需有關在同一台電腦上執行 Exchange 與 Outlook 的詳細資訊，請參閱微軟知識庫文件 - 266418＜Microsoft 不建議在同一台電腦上安裝 Exchange Server 與 Outlook＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266418)。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要移除 Rpc_Binding_Order 登錄項目

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\Software\Microsoft\Exchange\Exchange Provider

  3. 刪除 Rpc_Binding_Order 值。

  4. 關閉登錄編輯程式，重新啟動所有的 Exchange Server 服務或重新啟動 Exchange Server 電腦，以使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 RPC_Binding_Order 登錄項目的詳細資訊，請參閱下列知識庫文件：

  • 325930＜XCCC：如何疑難排解 RPC 用戶端通訊協定登錄項目造成的連線能力問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325930)

  • 326036＜XADM：無法使用正確的認證登入 Exchange 2000 Server 電腦＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326036)


Rpc_Svr_Binding_Order 登錄值已修改，不是預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Exchange Server 電腦使用的遠端程序呼叫 (RPC) 繫結順序：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Svr_Binding_Order

如果 Exchange Server Analyzer 發現 Rpc_Svr_Binding_Order 的值未設定成 ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp，就會顯示一則警告。

在電腦上安裝 Exchange Server 時會建立 Rpc_Svr_Binding_Order 登錄項目。此項目決定用於伺服器對伺服器的 RPC 通訊的通訊協定順序。

在預設的情況下，Rpc_Svr_Binding_Order 項目包含下列值資料：

ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp

附註：
如果 Exchange Server 電腦上也安裝了其他通訊協定，則上述字串中還會有其他值。

此項目指定 Exchange Server 與其他伺服器進行 RPC 通訊時，要嘗試使用的網路通訊協定順序。例如，因為第一個指定的是 TCP/IP，所以 Exchange Server 會先嘗試使用 RPC over TCP/IP 來與其他伺服器通訊，然後才會嘗試透過其他通訊協定來進行 RPC 通訊。

Microsoft 建議您不要變更 RPC 繫結順序的預設值。如果有變更預設值，那麼在伺服器或服務啟動期間，或在伺服器對伺服器的通訊期間可能會發生問題。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\Software\Microsoft\Exchange\Exchange Provider

  3. 在右窗格中，連按兩下 Rpc_Svr_Binding_Order。

  4. 在 [數值資料] 對話方塊中，鍵入 ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp。

  5. 按一下 [確定]，然後關閉登錄編輯程式。

  6. 重新啟動所有的 Exchange Server 服務，或重新啟動 Exchange Server 電腦，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 RPC 繫結順序的詳細資訊，請參閱知識庫文件 - 325930＜如何疑難排解 RPC 用戶端通訊協定登錄項目造成的連線能力問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325930)。


至 Active Directory 伺服器的來回行程時間超過 100 ms
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-03-16

Microsoft® Exchange Server Analyzer 工具會查詢 root\cimv2 命名空間中的 WIN32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 ResponseTime 機碼值。如果 Exchange Server Analyzer 發現 ResponseTime 機碼的值大於 100 毫秒 (ms)，就會顯示錯誤。

ResponseTime 機碼代表回應網際網路控制訊息通訊協定 (ICMP) 回應要求 (ping) 所經過的時間 (毫秒)。Exchange Server 電腦所使用網域控制站的回應時間一定要小於或等於 10 ms。若回應時間超過 100 ms，可能表示效能或連線發生問題。

若要更正此錯誤

  1. 確認有問題的網域控制站沒有超載。使用 ADTest.exe 工具測試網域控制站，查看硬體是否可處理預期的負載。

  2. 檢查 Exchange 伺服器及網域控制站上的事件日誌，看看是否有記載任何和網路相關的事件指出發生一或多個問題。

  3. 在網域控制站上使用 DCDiag.exe 及 NetDiag.exe 兩個命令，確認組態都正確並且運作正常。

  4. 最後，調查 Active Directory® 目錄服務站台的設計。Active Directory 站台是一個需要具有高頻寬和低延遲性的網路區段。若網路沒有根據這個規格分割，請考慮將網路分割為多個 Active Directory 站台。
附註：
當 Analyzer 工具執行 WMI 查詢以進行 ping 測試時，會置換預設的封包大小及逾時值。Analyzer 會改用 4096 ICMP 封包大小 (取代預設值 32 個位元組) 及 2000 毫秒的逾時值 (取代預設值 1000 毫秒)。

請遵循下列步驟，手動模擬 Analyzer 的 ping 行為。

手動執行 ping 測試

  • 在 Exchange 伺服器的命令列視窗中執行下列命令：ping -L 4096 -N 6 <Active Server server name>附註 這個命令會初始化六個 ping 要求，每一個要求有 4096 個位元組。

若需有關 ADTest.exe 工具的詳細資訊，請參閱「Active Directory 效能測試工具 (ADTest.exe)」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33758)。

若需有關 Win32_PingStatus WMI 類別的詳細資訊，請參閱 MSDN® 文件＜Win32_PingStatus＞(英文) (http://go.microsoft.com/fwlink/?LinkId=33549)。

若需有關 Active Directory 站台設計的詳細資訊，請參閱「設計站台拓撲」(英文) (http://go.microsoft.com/fwlink/?LinkId=33551)。


至 Active Directory 伺服器的來回行程時間超過 10 ms
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-03-16

Microsoft® Exchange Server Analyzer 工具會查詢 root\cimv2 命名空間中的 WIN32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 ResponseTime 機碼值。如果 Exchange Server Analyzer 發現 ResponseTime 機碼的值大於 10 ms (毫秒)，但小於 100 ms，將會顯示警告。

ResponseTime 機碼代表從 Exchange 伺服器傳送網際網路控制訊息通訊協定 (ICMP) 回應要求 (ping) 封包到網域控制站後，網域控制站做出回應所經過的時間 (毫秒)。Exchange Server 電腦所使用網域控制站的回應時間一定要小於或等於 10 ms。若回應時間超過 10 ms，可能表示效能或連線發生問題。

若要更正此警告

  1. 確認有問題的網域控制站沒有超載。使用 ADTest.exe 工具測試網域控制站，查看硬體是否可處理預期的負載。

  2. 檢查 Exchange 伺服器及網域控制站上的事件日誌，看看是否有記載任何和網路相關的事件指出發生一或多個問題。

  3. 在網域控制站上使用 DCDiag.exe 及 NetDiag.exe 兩個命令，確認組態都正確並且運作正常。

  4. 最後，調查 Active Directory® 目錄服務站台的設計。Active Directory 站台是一個需要具有高頻寬和低延遲性的網路區段。若網路沒有根據這個規格分割，請考慮將網路分割為多個 Active Directory 站台。
附註：
當 Analyzer 工具執行 WMI 查詢以進行 ping 測試時，會置換預設的封包大小及逾時值。Analyzer 會改用 4096 ICMP 封包大小 (取代預設值 32 個位元組) 及 2000 毫秒的逾時值 (取代預設值 1000 毫秒)。

請遵循下列步驟，手動模擬 Analyzer 的 ping 行為。

手動執行 ping 測試

  • 在 Exchange 伺服器的命令列視窗中執行下列命令：ping -L 4096 -N 6 <Active Server server name>附註 這個命令會初始化六個 ping 要求，每一個要求有 4096 個位元組。

若需有關 ADTest.exe 工具的詳細資訊，請參閱「Active Directory 效能測試工具 (ADTest.exe)」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33758)。

若需有關 Win32_PingStatus WMI 類別的詳細資訊，請參閱 MSDN® 文件＜Win32_PingStatus＞(英文) (http://go.microsoft.com/fwlink/?LinkId=33549)。

若需有關 Active Directory 站台設計的詳細資訊，請參閱「設計站台拓撲」(英文) (http://go.microsoft.com/fwlink/?LinkId=33551)。


至通用類別目錄伺服器的來回行程時間超過 100 ms
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-03-16

Microsoft® Exchange Server Analyzer 工具會查詢 root\cimv2 命名空間中的 WIN32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 ResponseTime 機碼值。如果 Exchange Server Analyzer 發現 ResponseTime 機碼的值超過 100 毫秒 (ms)，就會顯示一則錯誤。

ResponseTime 機碼代表從 Exchange Server 傳送網路網路控制訊息通訊協定 (ICMP) 回應要求 (ping) 封包到通用類別目錄伺服器後，通用類別目錄伺服器做出回應所經過的時間 (毫秒)。Exchange Server 電腦使用的通用類別目錄伺服器的回應時間應該恆小於或等於 10 毫秒。如果回應時間大於 10 毫秒，則可能有效能或連線問題。

若要更正此錯誤

  1. 請確認有問題的通用類別目錄伺服器沒有超載。使用 ADTest.exe 工具測試通用類別目錄，查看硬體是否可處理預期的負載。

  2. 檢查 Exchange 伺服器及通用類別目錄伺服器上的事件日誌，看看是否有記錄任何指出問題的網路相關事件。

  3. 在通用類別目錄伺服器上使用 DCDiag.exe 及 NetDiag.exe 兩個命令，確認組態都正確並且運作正常。

  4. 最後，調查 Active Directory® 目錄服務站台的設計。Active Directory 站台是一個需要具有高頻寬和低延遲性的網路區段。若網路沒有根據這個規格分割，請考慮將網路分割為多個 Active Directory 站台。
附註：
當 Analyzer 工具執行 WMI 查詢以進行 ping 測試時，會置換預設的封包大小及逾時值。Analyzer 會改用 4096 ICMP 封包大小 (取代預設值 32 個位元組) 及 2000 毫秒的逾時值 (取代預設值 1000 毫秒)。

請遵循下列步驟，手動模擬 Analyzer 的 ping 行為。

手動執行 ping 測試

  • 在 Exchange 伺服器的命令列視窗中執行下列命令：ping -L 4096 -N 6 <Active Server server name>附註 這個命令會初始化六個 ping 要求，每一個要求有 4096 個位元組。

若需有關 ADTest.exe 工具的詳細資訊，請參閱「Active Directory 效能測試工具 (ADTest.exe)」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33758)。

若需有關 Win32_PingStatus WMI 類別的詳細資訊，請參閱 MSDN® 文件＜Win32_PingStatus＞(英文) (http://go.microsoft.com/fwlink/?LinkId=33549)。

若需有關 Active Directory 站台設計的詳細資訊，請參閱＜設計站台拓撲＞(英文) (http://go.microsoft.com/fwlink/?LinkId=33551)。

若需有關安裝 Windows 2000 Server 支援工具的詳細資訊，請參閱微軟知識庫文件 - 301423＜如何在 Windows 2000 Server 電腦上安裝「Windows 2000 支援工具」＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=301423)。

若需有關安裝 Windows Server 2003 支援工具的詳細資訊，請參閱＜安裝 Windows 支援工具＞(英文) (http://go.microsoft.com/fwlink/?LinkId=41362)。


至通用類別目錄伺服器的來回行程時間超過 100 ms
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-03-16

Microsoft® Exchange Server Analyzer 工具會查詢 root\cimv2 命名空間中的 WIN32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 ResponseTime 機碼值。如果 Exchange Server Analyzer 發現 ResponseTime 機碼的值大於 10 毫秒，但小於 100 毫秒，就會顯示一則警告。

ResponseTime 機碼代表從 Exchange 伺服器傳送網路網路控制訊息通訊協定 (ICMP) 回應要求 (ping) 封包到通用類別目錄伺服器後，通用類別目錄伺服器做出回應所經過的時間 (毫秒)。Exchange Server 電腦使用的通用類別目錄伺服器的回應時間應該恆小於或等於 10 毫秒。如果回應時間超過 10 毫秒，則可能會發生效能或連線問題。

若要更正此警告

  1. 請確認有問題的通用類別目錄伺服器沒有超載。使用 ADTest.exe 工具測試通用類別目錄，查看硬體是否可處理預期的負載。

  2. 檢查 Exchange 伺服器及通用類別目錄伺服器上的事件日誌，查看是否有記錄任何指出一或多個問題的網路相關事件。

  3. 在通用類別目錄伺服器上使用 DCDiag.exe 及 NetDiag.exe 兩個命令，確認組態都正確並且運作正常。

  4. 最後，請檢查 Active Directory® 目錄服務站台設計。Active Directory 站台是一個需要具有高頻寬和低延遲性的網路區段。若網路沒有根據這個規格分割，請考慮將網路分割為多個 Active Directory 站台。
附註：
當 Analyzer 工具執行 WMI 查詢以進行 ping 測試時，會置換預設的封包大小及逾時值。Analyzer 會改用 4096 ICMP 封包大小 (取代預設值 32 個位元組) 及 2000 毫秒的逾時值 (取代預設值 1000 毫秒)。

請遵循下列步驟，手動模擬 Analyzer 的 ping 行為。

手動執行 ping 測試

  • 在 Exchange 伺服器的命令列視窗中執行下列命令：

    ping -L 4096 -N 6 <Active Server server name>

    附註：
    命令會初始化六個 ping 要求，每一個要求有 4096 個位元組。

若需有關 ADTest.exe 工具的詳細資訊，請參閱「Active Directory 效能測試工具 (ADTest.exe)」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33758)。

若需有關 Win32_PingStatus WMI 類別的詳細資訊，請參閱 MSDN® 文件＜Win32_PingStatus＞(英文) (http://go.microsoft.com/fwlink/?LinkId=33549)。

若需有關 Active Directory 站台設計的詳細資訊，請參閱「設計站台拓撲」(英文) (http://go.microsoft.com/fwlink/?linkid=33551)。


收件者原則必須變更搜尋篩選
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-02-21

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個 Exchange 收件者原則物件的 purportedSearch 屬性值。purportedSearch 屬性表示套用原則時所使用的搜尋引數。

Exchange Server Analyzer 也會查詢 Active Directory，以判定 Active Directory 中之樹系物件 (NTDS 設定) 的 msDS-Behavior-Version 屬性值。此值可指出 Active Directory 樹系的功能等級。msDS-Behavior-Version 屬性的有效值顯示在下表中。

值 | 樹系功能等級
0 | Microsoft Windows® 2000 Server 混合模式
1 | Microsoft Windows Server™ 2003 過渡模式
2 | Windows Server 2003 原生模式

Exchange Server Analyzer 也會查詢 Active Directory，以判定 Windows2003Update 容器的 revision 屬性值。此屬性的值可指出 Active Directory 準備工具 (ADPrep.exe) 是否已執行。

最後，Exchange Server Analyzer 會查詢 Win32_OperatingSystem Windows Management Instrumentation (WMI) 類別，以判定 OSProductSuite 機碼值。OSProductSuite 機碼值表示電腦上執行的 Windows 版本。

如果 Exchange Server Analyzer 發現下列準則符合，就會顯示警告：

  • 收件者原則的 purportedSearch 屬性值包含 homeMdb。

  • Active Directory 樹系功能層級為 Windows Server 2003 過渡模式或 Windows Server 2003 原生模式。

  • Exchange Server 電腦不在 Microsoft Windows Small Business Server 2003 上執行。

此警告表示已為 Windows Server 2003 備妥 Active Directory 樹系。為避免樹系升級至 Windows Server 2003 完整功能等級時發生電子郵件地址時間戳記問題，必須對收件者原則進行修改。會在 Exchange Server Analyzer 輸出中指定受影響的收件者原則。

如果 Windows Server 2003 用作網域控制站，但未更新收件者原則，則 Windows Server 2003 中的連結數值複寫會造成收件者更新服務不正確地寫入新使用者的電子郵件地址。由於連結數值複寫的關係，收件者更新服務第一次看到使用者的時間可能介於 mailnickname 複寫及 homeMDB 複寫之間。因此，使用者在這時會受預設原則限制，而非 homeMDB 型原則限制。幾分鐘後，當 homeMDB 複寫時，使用者將受其 homeMDB 原則限制。不過，使用者已經有了符合預設原則的地址。

若要更正此警告

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [收件者]，選取 [收件者原則]，然後在 RecipientPolicyName 上按一下滑鼠右鍵，再按一下 [內容]。

  3. 在 [RecipientPolicyName 內容] 頁面的 [一般] 索引標籤上，按一下 [篩選規則] 下的 [修改]。

  4. 在 [尋找 Exchange 收件者] 功能表上，選取 [自訂搜尋]。如果收件者原則最初由自訂搜尋建立，則在您按一下步驟 3 中的 [修改] 之後，會顯示 [尋找自訂搜尋] 頁面。

  5. 變更輕量型目錄存取通訊協定 (LDAP) 查詢，使 homeMdb 屬性不作為篩選條件的一部分。諸如 extensionAttribute、msExchHomeServerName 或 UPN 的屬性是有效引數，可以協助您取得相同搜尋結果。

  6. 按一下 [確定] 以儲存變更，然後關閉「Exchange 系統管理員」。


收件者原則需要變更搜尋篩選
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個 Exchange 收件者原則物件的 purportedSearch 屬性值。purportedSearch 屬性表示套用原則時所使用的搜尋引數。

Exchange Server Analyzer 也會查詢 Active Directory，以判定 Active Directory 中之樹系物件 (NTDS 設定) 的 msDS-Behavior-Version 屬性值。此值指示 Active Directory 樹系功能等級。msDS-Behavior-Version 屬性的有效值顯示在下表中。

值 | 樹系功能等級
0 | Windows® 2000 Server 混合模式
1 | Windows Server™ 2003 過渡模式
2 | Windows Server 2003 原生模式

Exchange Server Analyzer 也會查詢 Active Directory，以判定 Windows2003Update 容器的 revision 屬性值。此屬性的值指示是否已執行 Active Directory 準備工具 (ADPrep.exe)。

最後，Exchange Server Analyzer 會查詢 Win32_OperatingSystemWindows Management Instrumentation (WMI) 類別，以判定 OSProductSuite 機碼值。OSProductSuite 機碼的值表示電腦上執行的 Windows 版本。

如果 Exchange Server Analyzer 發現下列準則符合，則會顯示警告：

  • 收件者原則的 purportedSearch 屬性值包含 (homeMdb=)。

  • Active Directory 樹系功能層級為 Windows 2000 Server 混合模式。

  • 已備妥 Active Directory 樹系可供 Windows Server 2003 網域控制站使用。

  • Exchange Server 電腦不在 Microsoft Windows Small Business Server 2003 上執行。

此警告表示已為 Windows Server 2003 備妥 Active Directory 樹系。為避免 Active Directory 樹系升級至 Windows Server 2003 完整功能層級時發生電子郵件地址時間戳記問題，必須對收件者原則進行修改。會在 Exchange Server Analyzer 輸出中指定受影響的收件者原則。

如果將 Windows Server 2003 用作網域控制站，但未更新收件者原則，則 Windows Server 2003 中的連結數值複寫會造成收件者更新服務不正確地寫入新使用者的電子郵件地址。

由於連結數值複寫的關係，收件者更新服務第一次偵測到新使用者的時間，可能介於 mailnickname 複寫及 homeMdb 複寫之間。因此，使用者在這時會受預設原則限制，而非受到 homeMdb 型原則限制。幾分鐘後，當 homeMdb 複寫時，使用者會受 homeMdb 原則限制。不過，使用者已經有了符合預設原則的地址。

若要更正此警告

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [收件者] 並選取 [收件者原則] 後，以滑鼠右鍵按一下 [RecipientPolicyName]，然後按一下 [內容]。

  3. 在 [RecipientPolicyName 內容] 頁面中的 [一般] 索引標籤上，在 [篩選規則] 之下按一下 [修改]。

  4. 在 [尋找 Exchange 收件者] 功能表上，選取 [自訂搜尋]。如果收件者原則最初是由自訂搜尋建立，則在您按一下步驟 3 中的 [修改] 之後，會顯示 [尋找自訂搜尋] 頁面。

  5. 變更輕量型目錄存取通訊協定 (LDAP) 查詢，使 homeMdb 屬性不作為篩選條件的一部分。諸如 extensionAttribute、msExchHomeServerName 或 UPN 的屬性是有效引數，可以協助您取得相同搜尋結果。

  6. 按兩次 [確定] 以儲存變更，然後關閉 [Exchange 系統管理員]。


未設定寄件者識別碼
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-05-10

Microsoft Exchange Best Practices Analyzer 工具會使用下列 Exchange 管理命令介面指令程式，來查詢任一目標 Exchange Server 2007 Edge Transport 或 Hub Transport server role 之 SenderIdConfig 物件的 Enabled 及 ExternalMailEnabled 屬性值。

複製程式碼
- get-SenderIdConfig

Enabled 屬性值可指定是否啟用寄件者識別碼代理程式。Enabled 參數的有效輸入是 $true 或 $false。預設設定是 $true。當 Enabled 參數設為 $true 時，就表示啟用寄件者識別碼代理程式。

ExternalMailEnabled 屬性值可指定來自未驗證連線的所有郵件是否要通過寄件者識別碼代理程式，以進行處理。ExternalMailEnabled 參數的有效輸入是 $true 或 $false。預設設定是 $true。當 ExternalMailEnabled 參數設為 $true 時，來自未驗證連線的所有郵件都會通過寄件者識別碼代理程式，以進行處理。

如果 Exchange Best Practices Analyzer 判定 SenderIdConfig 物件之 Enabled 或 ExternalMailEnabled 屬性值不是設為 $true，Exchange Best Practices Analyzer 就會顯示最佳作法訊息。

這個訊息指出目標 Exchange 2007 Edge Transport 或 Hub Transport server role 沒有啟用寄件者識別碼。

寄件者識別碼會盡力確認每份電子郵件都來自寄件者自稱由該處寄出的網際網路網域。

在電腦上啟用寄件者識別碼之後，它就會篩選那些透過該電腦上的所有接收連接器進入的所有郵件。這樣只會篩選出來自外部來源的郵件。外部來源的定義是未驗證的來源。它們會被視為匿名的網際網路來源。

若要解決此問題，請在目標 Exchange 2007 Edge Transport 或 Hub Transport server role 上，啟用寄件者識別碼。

使用 Exchange 管理命令介面來啟用寄件者識別碼功能

  • 若要啟用寄件者篩選，請執行下列命令：

    複製程式碼
    Set-SenderIdConfig -Enabled $true -ExternalMailEnabled $true

若需有關寄件者識別碼的相關資訊，請參閱下列主題：

  • 寄件者識別碼首頁 (http://go.microsoft.com/fwlink/?linkid=50977) (英文)

  • Exchange 2007 寄件者識別碼 (http://go.microsoft.com/fwlink/?LinkId=89719) (英文)

  • 設定寄件者識別碼 (http://go.microsoft.com/fwlink/?LinkId=89720) (英文)


伺服器名稱大小寫不符
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定儲存在 Active Directory 中的值，來取得 Exchange 伺服器名稱 (CN=<ExchangeServerName>)。擷取此名稱後，Exchange Server Analyzer 會計算名稱中的字元數。

Exchange Server Analyzer 也會讀取下列登錄項目，以判定存放在 Exchange Server 電腦登錄中的值，以取得 Exchange 伺服器的主機名稱：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

Exchange Server Analyzer 工具也會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 ClusSvc (Windows® 叢集服務) 的 Started 機碼值。

若下列所有狀況均符合，Exchange Server Analyzer 就會顯示非預設的組態訊息：

  • CN=<ExchangeServerName> 的值與 Hostname 的值大小寫不相符。例如，CN=ComputerName，而 Hostname 設為 COMPUTERNAME。

    附註：
    雖然支援在登錄中變更伺服器名稱的大小寫，但是不建議這樣做。
  • Exchange 伺服器名稱的長度是 15 個字元或以下。

  • Exchange 伺服器不是在 Windows 叢集中執行。

此錯誤的最常見原因是已在登錄中手動變更 Exchange 伺服器的名稱。


伺服器名稱不相符
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 This Server 值的設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定每個 Exchange 伺服器物件的 name 屬性值。

最後，Exchange Server Analyzer 會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定叢集服務 (ClusSvc) 的 Started 機碼值。值為 TRUE 表示已啟動叢集服務，值為 FALSE 則表示未執行叢集服務。

針對不在伺服器叢集中執行的任何 Exchange Server 電腦，如果 Exchange Server Analyzer 發現 This Server 機碼值與 Active Directory 中伺服器物件的 name 屬性值不符，就會顯示一則錯誤。

若要更正此錯誤，您必須將 This Server 登錄機碼編輯為符合 Active Directory 中的 name 屬性值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem.

  3. 在右窗格中，連按兩下 This Server 並輸入此電腦的正確名稱，再按一下 [確定]。

  4. 關閉登錄編輯程式，然後重新啟動 Exchange Server 電腦，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


伺服器名稱太長
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-02-22

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定物件類別為 msExchExchangeServer 之每個目錄物件的名稱 (cn)。cn 值是包含 Exchange Server 電腦簡稱的字串。Exchange Server Analyzer 會擷取 cn，然後判定字串的長度。字串的長度是 Exchange 伺服器名稱的字元個數。如果 Exchange Server Analyzer 判定 Exchange 伺服器的名稱超過 15 個字元，就會顯示錯誤。

Exchange Server 2007、Exchange Server 2003 和 Exchange 2000 Server 有幾項 NetBIOS 依存性，可能需要您在不同的子網路之間使用 NetBIOS 名稱解析作業，讓所有 Exchange 元件 (視網路拓撲而定) 能夠順利運作。NetBIOS 命名慣例可允許 NetBIOS 名稱中有 16 個字元。然而 Microsoft 限制 NetBIOS 名稱只能有 15 個字元，並且會將第 16 個字元用作 NetBIOS 尾碼。

因為 Exchange Server 具有 NetBIOS 依存性，而且因為 NetBIOS 名稱不能超過 15 個字元，所以在 Exchange 組織中，不支援超過 15 個字元的伺服器名稱。此外，若將 Exchange Server 電腦重新命名，其影響會擴及整個 Active Directory 和 Exchange 組織，所以不支援將 Exchange Server 電腦重新命名。

若要更正此錯誤

  1. 使用 [移除] 選項來將命名錯誤的 Exchange Server 電腦移除。

  2. 將電腦重新命名為 15 個字元以下的名稱。

  3. 在電腦上重新安裝 Exchange Server。

若需移除 Exchange Server 2007 的詳細資訊，請參閱 Microsoft Exchange Server 2007 部署文件中的＜如何從伺服器中完全移除 Exchange 2007＞(英文) (http://go.microsoft.com/fwlink/?LinkId=79246)。

若需有關移除 Exchange Server 2003 的詳細資訊，請參閱《Exchange Server 2003 部署手冊》中的＜如何解除安裝 Exchange Server 2003＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47569)。

若需詳細資訊，請參閱下列微軟知識庫文件：

  • 833396＜如何從電腦中移除 Exchange Server 2003＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=833396)

  • 260378＜如何手動移除 Exchange 2000 安裝＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260378)

  • 328810＜在伺服器間移動信箱＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810)

  • 821829＜在 Exchange Server 2003 中移動信箱＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)


伺服器 RPC 網路位址與 Exchange 伺服器名稱不符
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定目錄中每個 Exchange Server 物件的 networkAddress 屬性值。一般會針對此多字串屬性列出數個項目 (如下列範例所解說)：

ncacn_ip_tcp：<Exchange Server 的完整網域名稱>

ncacn_np：<Exchange Server 的主機名稱>

ncacn_spx：<Exchange Server 的主機名稱>

ncacn_vns_spp：<Exchange Server 的主機名稱>

ncalrpc：<Exchange Server 的主機名稱>

netbios：<Exchange Server 的主機名稱>

Exchange Server Analyzer 也會查詢 Active Directory，以判定每個 Exchange Server 物件的 name 屬性值。

如果 Exchange Server Analyzer 發現 name 屬性的值與在 networkAddress 屬性中找到之任何字串的名稱部份不相符，則會顯示錯誤。

如果系統管理員手動變更了伺服器物件的 cn 值，則會發生此錯誤。Exchange Server 建立並維護 networkAddress 屬性之後，該屬性會含有多個字串值，以支援 Exchange Server 所支援的不同網路通訊協定。每個值都會將通訊協定與特定通訊協定所需之適當形式的伺服器名稱產生關聯。

若要更正此問題，請檢查以查看是否已變更伺服器名稱或值是否無效，然後採取適當的動作：

  • 如果已變更伺服器名稱，請使用本文件後面的程序來適當的修復這些值。

  • 如果這些值因某些其他原因而無效，請在伺服器上重新執行「Exchange 安裝程式」。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險，必須由您自行承擔。

若要更正此錯誤

  1. 使用 [ADSI 編輯器] 或類似的工具，在 Active Directory 中找出系統管理群組物件。

    可在下列位置找到 networkAddress 屬性：

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Administrative Groups, CN=Administrative Group Name, CN=Servers, CN=Server Name

  2. 請記下清單中每個值的格式。視需要更新值 (只變更每個值的伺服器名稱部份)。

    附註：
    請確定伺服器名稱之 ncacn_ip_tcp 值的格式是完整網域名稱，而非 NetBIOS 名稱或網際網路通訊協定位址。

  3. 關閉 Active Directory 編輯程式，然後重新啟動 Exchange Routing Engine 服務。

若需有關使用 LDP 工具的詳細資訊，請參閱微軟知識庫文件 - 260745＜XADM:Using the LDP Utility to Modify Active Directory Object Attributes＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

若需有關 Exchange 路由問題的詳細資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》(http://go.microsoft.com/fwlink/?LinkId=47579) 中的＜疑難排解路由＞(英文)。


服務主要名稱遺失
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-08-14

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，針對下表列出的 Exchange 資源，尋找其 Exchange 伺服器電腦帳戶的 servicePrincipalName 屬性的傳回值。

Exchange 資源 servicePrincipalName 值 | 預期的傳回值
exchangeMDB | 網域全名 (FQDN)
exchangeMDB | NetBIOS 名稱
exchangeRFR | 網域全名 (FQDN)
exchangeRFR | NetBIOS 名稱
SMTP | 網域全名 (FQDN)
SMTP | NetBIOS 名稱
SMTPSVC | 網域全名 (FQDN)
SMTPSVC | NetBIOS 名稱
HOST | 網域全名 (FQDN)
HOST | NetBIOS 名稱

如果 Exchange Server Analyzer 發現 Exchange 資源之電腦帳戶的 servicePrincipalName 屬性遺漏此處列出的任一個預期值，便會顯示錯誤。

服務主要名稱 (SPN) 是唯一的名稱，它能識別服務的執行個體，並且與用來執行服務執行個體的登入帳戶相關聯。若沒有適當地設定 SPN， Exchange 服務便無法使用 Kerberos 驗證。

  • 在執行 Microsoft Office Outlook® 2003 (或更新版本) 之用戶端與 Exchange 資訊儲存庫 (信箱資料) 之間的驗證問題，可能表示 exchangeMDB 資源缺少有效的 SPN。

  • 具有 Active Directory 驗證問題的 Outlook 2003 (或更新版本) 用戶端，可能表示 exchangeRFR 資源缺少有效的 SPN。

  • 在簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器之間的驗證失敗，可能表示 SMTPSVC 或 HOST 資源缺少有效的 SPN。

若要解決此問題，請遵循下列步驟，為受影響的屬性新增遺漏的值。

使用 SETSPN.exe 工具，新增有遺漏值的 SPN。

  1. 安裝 Setspn.exe 工具。若要取得 Setspn.exe 工具，請參閱＜Windows 2000 Resource Kit Tool :Setspn.exe＞(http://go.microsoft.com/fwlink/?LinkId=28103)。

    Windows Server 2003 版的 Setspn.exe 命令列工具可在 Windows Server 2003 CD 所包含的 Windows Server 2003 Support Tools 中取得。若要安裝 Server 2003 Support Tools，請在 Support/Tools 資料夾中連按兩下 Suptools.msi 檔案。

  2. 請遵循 SETSPN.EXE Setspn_d.txt 檔案中的引導，將遺漏的值新增至 Exchange 伺服器的 Active Directory 物件。下列範例示範如何為虛擬 SMTP 伺服器 SPN 新增 FQDN 值：

    • 啟動命令提示字元，然後切換至 Setspn.exe 的安裝目錄。

    • 在命令提示字元下，輸入下列命令：

      setspn.exe-a SMTPSVC/ mail.yourdomain.com YOURSERVERNAME

      附註：
      將 mail.yourdomain.com 取代為 SMTP 虛擬伺服器 FQDN，並將 YOURSERVERNAME 取代為 Exchange 伺服器的名稱。
      然後按 Enter 鍵。


過去 24 小時內有服務異常結束
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-02-14

Microsoft Exchange Analyzer 工具會查詢 Win32_NTLogEvent Microsoft Windows Management Instrumentation (WMI) 類別，以判定過去 24 小時內是否曾記錄服務控制管理員來源的「事件 7031」警告。

「事件 7031」警告表示指定的服務無法繼續執行。服務經過設定，會報告失敗次數，並且在報告了特定失敗次數之後，服務控制管理員會執行指定服務所設定的復原動作。

如果 Exchange Analyzer 發現已在過去 24 小時內記錄其中一個或多個上述事件，則 Exchange Analyzer 會顯示參考訊息。

此問題可能由各種問題所導致，包括 (但不限於) 以下最常見的原因：

  • 正在處理損毀的郵件。

  • 防毒應用程式組態問題。

若要更正此問題：

  • 遵循 Microsoft 知識庫文章 286350＜如何使用 ADPlus 疑難排解「擱置」及「損毀」＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=286350) 中的指引，隔離處理程序無回應 (擱置) 或異常停止 (損毀) 的起因。

  • 取得 Microsoft Windows 2000 最新的 Service Pack。

  • 取得 Microsoft Exchange Server 最新的 Service Pack。

  • 與防毒應用程式廠商連絡，取得最新的更新與組態資訊。

詳細資訊

如需事件 7031 警告詳細資料的相關資訊，請參閱「事件及錯誤訊息中心：事件詳細資料」(英文) (http://go.microsoft.com/fwlink/?LinkId=83114)。

如需如何取得 Windows 2000 Server 最新 Service Pack 的相關資訊，請參閱 Microsoft 知識庫文章 260910＜如何取得最新版的 Windows 2000 Service Pack＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=260910)。

如需如何取得 Exchange 2000 Server 最新 Service Pack 的相關資訊，請參閱 Microsoft 知識庫文章 301378＜如何取得最新的 Exchange 2000 Server Service Pack＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378)。

如需如何取得 Exchange Server 2003 最新 Service Pack 的相關資訊，請參閱＜為何要嘗試 Exchange Server 2003 的 Service Pack 2？＞(英文) (http://go.microsoft.com/fwlink/?LinkId=52073)。

若需將防毒軟體與 Exchange Server 搭配使用的相關資訊，請參閱下列微軟知識庫文件：

  • 328841＜Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需可在 Exchange Server 上使用之協力廠商的防毒軟體清單，請參閱 Exchange Server Partners:防毒網站 (英文) (http://go.microsoft.com/fwlink/?linkid=16226)。


Services Value is Missing or Inaccessible
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-07-24

Microsoft Exchange Analyzer 工具會讀取下列登錄項目，以驗證 Services 字串類型值是否存在：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Setup

如果 Exchange Analyzer 發現 Services 字串類型值遺失或無法存取，則 Exchange Analyzer 會顯示錯誤。

此錯誤指出用來保留 Exchange 安裝根目錄路徑的 Services 字串類型值遺失或無法存取。沒有 Exchange 安裝根目錄路徑，可能導致無法初始化重要的驅動程式及通訊協定，因而將導致 Exchange 資訊儲存庫與相依的服務在啟動時失敗。

若要更正此錯誤，請遵循 Microsoft 知識庫文章 285116＜Exchange 儲存庫不會啟動：錯誤 7024、1026、9542 及 5000＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285116) 中的指引。


找到一個空閒/忙碌資訊複本
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會查詢 root\MicrosoftExchangeV2 命名空間下的 Exchange_PublicFolder Microsoft Windows® Management Instrumentation (WMI) 類別，以判定每個系統管理群組中存在之空閒/忙碌資訊複本的數目。

如果 Exchange Server Analyzer 發現系統管理群組中只有一個空閒/忙碌資訊複本存在，就會顯示一則最佳作法訊息。

一般都會建議您在每個系統管理群組中，為空閒/忙碌資訊資料夾設定多個複本。有時多個空閒/忙碌資訊複本可以增加效能與彈性。在大型 Exchange 組織中，一個空閒/忙碌資料複本可能會超載。在所有 Exchange 組織中，一個空閒/忙碌資料複本會是單一失敗點。

儘管有下列考量，仍建議使用多個複本：

  • 多個複本會造成網路上額外的複寫流量。

  • 使用多個複本會增加排程衝突的風險。

每 10,000 個信箱至少應有 1 個複本。

若需有關空閒/忙碌資訊資料夾及發行空閒/忙碌資訊的詳細資訊，請參閱《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595)。


在大量的信箱中找到單一空閒/忙碌資訊複本
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會查詢 root\MicrosoftExchangeV2 命名空間下的 Exchange_PublicFolder Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 ReplicaList 機碼中的項目數。此項目數代表每個系統管理群組中的空閒/忙碌資訊複本數。

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定每一個信箱儲存區之 homeMDBBL 屬性中所列的項目計數。這個屬性的計數代表信箱儲存區上的信箱數目。

如果 Exchange Server Analyzer 發現包含 10,000 個信箱以上的系統管理群組只有一個空閒/忙碌資訊複本，便會顯示錯誤。

一般都會建議您在每個系統管理群組中，為空閒/忙碌資訊資料夾設定多個複本。有時多個空閒/忙碌資訊複本可以增加效能與彈性。在大型 Exchange 組織中，一個空閒/忙碌資料複本可能會超載。在所有 Exchange 組織中，一個空閒/忙碌資料複本會是單一失敗點。

儘管有下列考量，仍建議使用多個複本：

  • 多個複本會造成網路上額外的複寫流量。

  • 使用多個複本會增加排程衝突的風險。

每 10,000 個信箱至少應有 1 個複本。

若需有關空閒/忙碌資訊資料夾及發行空閒/忙碌資訊的詳細資訊，請參閱《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595)。


單一通用類別目錄存在於拓蹼中
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-09

Microsoft® Exchange Server Analyzer 工具會查詢 root\MicrosoftExchangeV2 命名空間中的 Exchange_DSAccess Microsoft Windows® Management Instrumentation (WMI) 類別，以判定拓撲中存在之通用類別目錄伺服器的數目。藉由計算 DSAccessNameGC WMI 機碼的項目數，可以判定通用類別目錄伺服器的數目。如果 Exchange Server Analyzer 發現只有一個通用類別目錄伺服器存在於拓撲中，則會顯示最佳的作法建議。

基於容錯目的，最佳的作法是至少要有二個通用類別目錄伺服器可為 Exchange Server 及使用者提供服務。單一通用類別目錄伺服器代表失敗的單一點。Exchange 2000 Server、Exchange Server 2003 以及 Exchange Server 2007 的各種功能視通用類別目錄伺服器而定。如果通用類別目錄伺服器無法使用，郵件傳遞會變慢或完全停止。此外，如果通用類別目錄伺服器無法使用，Exchange Server 服務也不會啟動。如果 Exchange Server 服務不啟動，使用者就不能存取他們的信箱。

基於延展性及容錯目的，建議您在每個 Active Directory® 目錄服務站台中至少設定兩個通用類別目錄伺服器。如果站台跨多個網域，則建議您為 Exchange 2000 Server 電腦、Exchange Server 2003 電腦或 Exchange Server 2007 電腦以及用戶端所在的每個網域，設定通用類別目錄。此外，還建議為每四台 Exchange Server 電腦處理器部署一台通用類別目錄伺服器。

若需如何建立其他通用類別目錄伺服器的詳細資料，請參閱微軟知識庫文件 - 313994＜如何在 Windows 2000 中建立或移除通用類別目錄＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313994)。

若需有關與 Exchange Server 相關之通用類別目錄伺服器位置及可用性的詳細資訊，請參閱下列知識庫文件：

  • 875427＜通用類別目錄伺服器在 Exchange 2000 Server 組織或 Exchange Server 2003 組織中的位置及比率＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=875427)

  • 322801＜Exchange 系統服務員未啟動，您收到「通用類別目錄伺服器沒有回應」錯誤訊息＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322801)

  • 829361＜Exchange Server 2003 電腦關閉所需時間比預期長＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829361)

  • 304403＜XADM：將網域控制站升級至通用類別目錄伺服器的 Exchange 注意事項＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=304403)

  • 305065＜將通用類別目錄伺服器降級為網域控制站的 Exchange Server 相關注意事項＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=304403)


站台資料夾伺服器已刪除
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-03-01

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個系統管理群組物件的 siteFolderServer 屬性值。如果 Exchange Server Analyzer 判定 siteFolderServer 屬性值包含 DEL: 字串，就會顯示一則錯誤。

siteFolderServer 屬性代表負責主控站台資料夾的公用資料夾儲存區辨別名稱 (DN) (通常是站台或系統管理群組中的第一部伺服器)。

依預設值，「站台資料夾伺服器」是在系統管理群組中安裝的第一部伺服器。在此伺服器上的公用資料夾儲存區，就是空閒/忙碌資訊資料夾，以及系統管理群組的離線通訊錄資料夾的預設位置。如果移除此伺服器或將其解除委任，但沒有將這些資料夾複寫到另一個伺服器及指定該伺服器作為離線通訊錄伺服器，則 Microsoft Office Outlook® 2003 使用者會發現離線通訊錄及空閒/忙碌資料有問題。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險，必須由您自行承擔。

若要更正此錯誤

  1. 開啟一個 Active Directory 編輯程式，如 [ADSI 編輯器]。

  2. 在 [Configuration] 容器中展開下列節點，尋找您要指定為站台資料夾伺服器的公用資料夾資訊儲存區：

    CN=Configuration,DC=<DomainName>,DC=com, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdministrativeGroupName> CN=Servers, CN=<ServerName>, CN=InformationStore, CN=<StorageGroupName>

  3. 在右窗格中，在 CN=<PublicFolderStoreName>, 上按一下滑鼠右鍵，再按 [內容]。

  4. 在 [Attributes] 欄位中，向下捲動並選取 distinguishedName 屬性。

  5. 按一下 [編輯]，然後將整個屬性複製到剪貼簿。

  6. 展開 [Configuration] 容器，接著展開 CN=Configuration,CN=<DomainName>、CN=com, CN=Services, CN=Microsoft Exchange、CN=<OrganizationName>、CN=Administrative Groups

  7. 在要修改的系統管理群組上按一下滑鼠右鍵，然後按一下 [Properties]。

  8. 在 [Attributes] 欄位中，向下捲動並選取 siteFolderServer 屬性。

  9. 按一下 [Edit]，然後將 distinguishedName 屬性的值貼到 [Value] 欄位中。

  10. 再次檢查 [Value] 欄位的內容以確定有正確執行貼上，然後按一下 [OK] 以儲存變更。

  11. 按一下 [OK] 以關閉 [Administrative Group properties]。

  12. 結束 Active Directory 編輯程式，然後重新啟動站台內所有 Exchange Server 電腦上的 Microsoft Exchange Server Information Store 服務，使變更生效。

若需有關重新建立系統資料夾以及重設「站台資料夾伺服器」的詳細資訊，請參閱下列微軟知識庫文件：

  • 822444＜如何在 Exchange Server 2003 中重設站台資料夾＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822444)

  • 275171＜如何在 Exchange 2000 Server 上重設系統資料夾＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=275171)

  • 284200＜Schedule+ 空閒/忙碌資訊系統資料夾遺失＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=284200)

若需有關使用 LDP 工具的詳細資訊，請參閱知識庫文件 - 260745＜XADM：Using the LDP Utility to Modify Active Directory Object Attributes＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

若需有關使用 ADSI 編輯器的詳細資訊，請參閱主題＜Adsiedit.msc：ADSI 編輯器＞(位在 Windows Server 說明中)。


Active Directory 目錄服務呼叫過慢
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-14

Microsoft® Exchange Server Analyzer 工具會檢查 Exchange 函數呼叫記錄 (FCL) (Store.fcl 檔)，找出是否有超出 2.5 秒回應時間的 Active Directory® 目錄服務元件事件。

Exchange FCL Active Directory 元件事件代表對 Active Directory 元件的 Microsoft Exchange Information Store 服務 (Store.exe) 函數呼叫。

Active Directory 提供所有信箱資訊、地址清單服務，以及其他收件者相關資訊。大多數的 Exchange Server 2003 組態資訊也會儲存在 Active Directory 中。

Exchange Server 服務會存取 Active Directory 中儲存的資訊，並將資訊寫入 Active Directory。

如果 Exchange Server Analyzer 發現 FCL 檔中的事件針對來自 Microsoft Exchange Information Store 服務 (Store.exe) 的 Active Directory 函數呼叫作出反映的回應時間超過 2.5 秒，Exchange Server Analyzer 便會顯示錯誤。

當 Microsoft Exchange Information Store 服務 (Store.exe) 所發出的跨元件呼叫在等候回應時，遠端程序呼叫 (RPC) 執行緒會在這些要求的背景做備份，從而導致 Exchange Server 的效能問題，例如造成伺服器對用戶端的回應延遲。

下列狀況會導致從 Microsoft Exchange Information Store 服務對 Active Directory 發出呼叫需要 2.5 秒以上的時間：

  • Exchange 伺服器與網域控制站之間的網路延遲。

  • DSAccess 的組態為靜態或不正確。

  • 網域控制站及通用類別目錄超載。

  • Active Directory 拓撲的設計不正確。

若要解決這個錯誤，請採取下列步驟：

  • 執行 Exchange Server Analyzer，針對伺服器問題進行額外的分析。您可以在 Microsoft Exchange Server Best Practices Analyzer 工具 2.7 版 (英文) (http://go.microsoft.com/fwlink/?LinkId=34705) 網頁下載 Exchange Server Analyzer。

  • 檢查 Active Directory 網域控制站伺服器的效能。

  • 檢閱本文＜詳細資訊＞一節中的文章。

詳細資訊

若需 Exchange 效能及 DSAccess 的詳細資訊，請參閱 Microsoft 知識庫文章 250570＜目錄服務伺服器偵測及 DSAccess 使用＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570)。

若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)。

若需如何疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

若需如何疑難排解資訊儲存庫效能的詳細資訊，請參閱 Microsoft 知識庫文章 257725＜XADM：如何收集診斷資料以進行資訊存放的疑難排解＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。

若需網域控制站效能的詳細資訊，請參閱下列 Windows Server 資源：

  • ＜計劃網域控制站容量＞(英文) (http://go.microsoft.com/fwlink/?LinkId=70191)。

  • 《Windows 2000 Server Active Directory 計劃及部署手冊》中的＜網域控制站的 Active Directory 監視＞(英文) (http://go.microsoft.com/fwlink/?LinkId=70193)。


ESE 呼叫過慢
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-13

Microsoft® Exchange Server Analyzer 工具會檢查 Exchange 函數呼叫記錄 (FCL) (Store.fcl 檔)，找出是否有超出 2.5 秒回應時間的 Exchange 可延伸儲存引擎 (ESE) 元件事件。

Exchange FCL ESE 元件事件代表對 ESE 元件的 Microsoft Exchange Information Store 服務 (Store.exe) 函數呼叫。

Exchange Information Store 位於 ESE 資料庫的頂端。ESE 是一種複雜的交易型資料庫引擎。交易是由一連串被視為不可部分完成 (無法再分割) 單位的作業所組成。交易中的所有作業不是全部完成並永久儲存，就是全部都沒有執行。

Exchange Server 使用 ESE 做為內嵌資料庫引擎，用於判斷資料庫結構以及管理記憶體。資料庫引擎會將 4 KB 的資料區塊 (分頁) 傳入與傳出記憶體，藉此方式將資料庫快取至記憶體。它會更新記憶體中的分頁，並將新增或更新的分頁寫回磁碟。當對系統提出要求時，資料庫引擎便能從記憶體緩衝區擷取資料。如此就不必經常存取磁碟。

雖然快取記憶體中的資料是處理資料最快且最有效率的方式，這也表示當 Exchange 執行時，磁碟上的資訊不可能完全是最新的，然而，交易記錄磁碟一定會保持每筆交易的最新相關資訊。不過，由於記憶體中的許多變更尚未寫入磁碟，所以資料庫和記憶體並不是同步的。

如果 Exchange Server Analyzer 發現 Store.fcl 檔中的事件針對來自 Microsoft Exchange Information Store 服務 (Store.exe) 的 ESE 元件函數呼叫作出反映的回應時間超過 2.5 秒，Exchange Server Analyzer 便會顯示錯誤。

當 Microsoft Exchange Information Store 服務 (Store.exe) 所發出的跨元件呼叫在等候回應時，遠端程序呼叫 (RPC) 執行緒會在這些要求的背景做備份，從而導致 Exchange Server 的效能問題，例如造成伺服器對用戶端的回應延遲。

下列狀況會導致來自 ESE 的持續性呼叫：

  • Exchange 線上磁碟重組。

  • 資料備份。

    附註：
    如果有意在 Exchange 呼叫追蹤記錄收集期間進行資料備份或線上磁碟重組，您可以安心地忽略此訊息，因為它只是指出 Exchange 伺服器效能問題
  • 資料庫磁碟機上的瓶頸。

若要解決這個錯誤，請採取下列步驟：

  • 我們建議的最佳作法是，不要讓備份時段或線上維護與使用者要求的尖峰期間重疊。

  • 執行 Exchange Server Analyzer，針對伺服器進行額外的分析。您可以在 Microsoft Exchange Server Best Practices Analyzer 工具 2.7 版 (英文) (http://go.microsoft.com/fwlink/?LinkId=34705) 網頁下載 Exchange Server Analyzer。

  • 檢閱本文＜詳細資訊＞一節中的文章。

詳細資訊

若需如何設定線上磁碟重組時間範圍的詳細資訊，請參閱 Microsoft 知識庫文章 244524＜XADM：如何設定 Exchange Server 線上磁碟重組時間範圍＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524)。

若需 Exchange Server 磁碟瓶頸問題的詳細資訊，請參閱偵測到磁碟瓶頸。

若需如何決定 Exchange Server 磁碟大小以及最佳化的詳細資訊，請參閱《最佳化 Exchange Server 2003 的儲存》中的＜如何計算磁碟 I/O 需求＞以及＜多種結構通用的最佳作法＞(英文) (http://go.microsoft.com/fwlink/?linkid=49324)。

若需 ESE 的詳細資訊，請參閱＜可延伸儲存引擎結構＞(英文) (http://go.microsoft.com/fwlink/?linkid=67009)。


IMAIL 呼叫過慢
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-12

Microsoft® Exchange Server Analyzer 工具會檢查 Exchange 函數呼叫記錄 (FCL) (即 Store.fcl 檔)，查看是否有事件指出 MAPI 用戶端之 IMAIL 元件的回應時間超過 2.5 秒。

Exchange FCL IMAIL MAPI 元件事件代表將郵件轉換成網際網路格式，以及從網際網路格式轉換成 MAPI 格式的 Microsoft Exchange Information Store 服務函數呼叫。

Exchange Server 的 IMAIL 元件是一項彈性的轉換服務，Microsoft Exchange Information Store 服務將其用在網際網路與 MAPI 郵件之間。這樣可以讓使用 RFC-822 或網際網路格式的用戶端，與使用 Exchange Server 內部儲存格式的用戶端 (例如 MAPI 用戶端或內部 STORE 工作) 交互操作。

Exchange 使用 IMAIL 機制，將郵件格式 (例如在 [Exchange 系統管理員] 中為網際網路網域定義的格式，或是使用者在 Microsoft Office Outlook® 中為每個收件者指定的格式) 套用至內容。如果未傳遞任何格式參數給 IMAIL，則 IMAIL 會將 MAPI 郵件格式化為 Summary TNEF (S/TNEF) 格式，以便在伺服器之間傳輸。

如果 Exchange Server Analyzer 在 Store.fcl 記錄檔中發現有事件反映出 MAPI 用戶端的 IMAIL 元件對 Microsoft Exchange Information Store 服務 (Store.exe) 所發出之函數呼叫的回應時間超過 2.5 秒，Exchange Server Analyzer 就會顯示錯誤。

當 Microsoft Exchange Information Store 服務 (Store.exe) 所發出的跨元件呼叫在等候回應時，遠端程序呼叫 (RPC) 執行緒會在這些要求的背景做備份，從而導致 Exchange Server 的效能問題，例如造成伺服器對用戶端的回應延遲。

IMAIL 對 Exchange Information Store 服務 (Store.exe) 函數呼叫的回應時間太慢，可能的原因如下：

  • IMAIL 嘗試處理郵件或附件中的眾多資料。

  • 太多用戶端要求轉換資料。

  • DSAccess 要求遇到過慢的回應。

  • TEMP 及 TMP 磁碟機上有瓶頸。

  • 正在進行信箱移動。

  • 若要解決這個錯誤，請採取下列步驟：

  • 將信箱移動作業排定在要求量較少的離峰期間進行。

  • 執行 Exchange Server Analyzer，針對其他伺服器問題 (例如郵件及附件大小限制) 進行分析。您可從＜Microsoft Exchange Server Best Practices Analyzer 工具版本 2.7＞(英文) (http://go.microsoft.com/fwlink/?LinkId=34705) 下載 Exchange Server Analyzer。

  • 檢閱本文＜詳細資訊＞一節中的文章。

詳細資訊

若需 Exchange Server 磁碟瓶頸問題的詳細資訊，請參閱偵測到磁碟瓶頸。

若需如何決定 Exchange Server 磁碟大小以及最佳化的詳細資訊，請參閱《最佳化 Exchange Server 2003 的儲存》中的＜如何計算磁碟 I/O 需求＞以及＜多種結構通用的最佳作法＞(英文) (http://go.microsoft.com/fwlink/?linkid=49324)。

若需 Exchange Server 上郵件大小限制之最佳作法的詳細資訊，請參閱尚未設定最大外寄郵件大小。


LSASS 呼叫過慢
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-12-04

Microsoft® Exchange Server Analyzer 工具會檢查 Exchange 函數呼叫記錄 (FCL) (即 Store.fcl 檔)，查看是否有 Local Security Authentication Server (Lsass.exe) 處理程序元件事件超過 25 毫秒的回應時間。

Exchange FCL LSASS 處理程序元件事件代表 Microsoft Exchange Information Store 服務 (Store.exe) 對 Local Security Authentication Server (Lsass.exe) 處理程序元件的函數呼叫。

Local Security Authentication Server 處理程序 (Lsass.exe) 是一個安全性子系統，其他處理程序可予以呼叫，用以確認帳戶資訊及登入驗證。

每次只要有 Exchange 用戶端登入，執行 Exchange Server 的伺服器就會傳送要求以查詢用戶端的帳戶安全性識別碼 (SID)，並在 Local Security Authentication Server (Lsass.exe) 處理程序中建立呼叫。

如果 Exchange Server Analyzer 在 Store.fcl 記錄檔中發現有事件反映出 Local Security Authentication Server (Lsass.exe) 元件對 Microsoft Exchange Information Store 服務 (Store.exe) 所發出之函數呼叫的回應時間超過 25 毫秒，Exchange Server Analyzer 就會顯示錯誤。

當 Microsoft Exchange Information Store 服務 (Store.exe) 所發出的跨元件呼叫在等候回應時，遠端程序呼叫 (RPC) 執行緒會在這些要求的背景做備份，從而導致 Exchange Server 的效能問題，例如造成伺服器對用戶端的回應延遲。

LSASS 對 Microsoft Exchange Information Store 服務 (Store.exe) 函數呼叫的回應時間太慢，可能的原因如下：

  • 與同時間進行驗證的使用者人數相關的伺服器資源問題。

  • Exchange 伺服器與網域控制站或通用類別目錄伺服器之間的網路延遲。

  • 伺服器資源瓶頸的問題。

若要解決這個錯誤，請採取下列步驟：

  • 考慮實作 NeverPing 參數，如＜建議使用 'NeverPing' 參數＞中所述。

  • 執行 Exchange Server Analyzer，以額外分析如郵件及附件大小限制的伺服器問題。您可以在＜Microsoft Exchange Server Best Practices Analyzer Tool v2.7＞(http://go.microsoft.com/fwlink/?LinkId=34705) 下載 Exchange Server Analyzer。

  • 檢閱本文＜詳細資訊＞一節中的文章。

詳細資訊

若需 Lsass.exe 處理程序及記憶體使用量的詳細資訊，請參閱 Microsoft 知識庫文章 308356＜在執行 Windows Server 2003 或 Windows 2000 Server 的網域控制站上，Lsass.exe 處理程序使用的記憶體＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)。

若需 Exchange 用戶端登入及 LSASS 問題的詳細資訊，請參閱 Microsoft 知識庫文章 161938＜因為資源鎖死而造成的 Exchange 用戶端登入過慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938)。

若需 Exchange 伺服器與網域控制站或通用類別目錄伺服器之間網路延遲的詳細資訊，請參閱下列 Exchange Server Team 部落格文章＜Exchange 不一定使用本機 GC＞(英文) (http://go.microsoft.com/fwlink/?LinkId=69166)。

附註：
每一個部落格及其 URL 的內容隨時都會變更，不另行通知。

若需伺服器資源瓶頸問題的詳細資訊，請參閱＜處理器瓶頸＞。

若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)。

若需如何疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

若需如何疑難排解資訊儲存庫效能的詳細資訊，請參閱 Microsoft 知識庫文章 257725＜XADM：如何收集診斷資料以進行資訊存放的疑難排解＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。


病毒掃描程式呼叫過慢
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-11

Microsoft® Exchange Server Analyzer 工具會檢查 Exchange 函數呼叫記錄 (FCL) (Store.fcl 檔)，找出是否有超出 2.5 秒回應時間的 Virusscan Virus API (VAPI) 元件事件。

Exchange FCL Virusscan VAPI 元件事件代表對外部病毒掃描程式軟體的 Microsoft Exchange Information Store 服務 (Store.exe) 函數呼叫。

為了加強對 VAPI 進行疑難排解，Exchange 伺服器會實作可以用來追蹤病毒掃描 API 之效能的事件記錄。

記錄的事件包括下列事件：

  • 載入及卸載廠商 DLL。

  • 順利掃描項目。

  • 位於資訊儲存庫的病毒。

  • VAPI 中的非預期行為。

如果 Exchange Server Analyzer 發現 Store.fcl 記錄檔中的事件針對來自 Microsoft Exchange Information Store 服務 (Store.exe) 的外部病毒掃描程式函數呼叫作出反映的回應時間超過 2.5 秒，Exchange Server Analyzer 便會顯示錯誤。

當 Microsoft Exchange Information Store 服務 (Store.exe) 所發出的跨元件呼叫在等候回應時，遠端程序呼叫 (RPC) 執行緒會在這些要求的背景做備份，從而導致 Exchange Server 的效能問題，例如造成伺服器對用戶端的回應延遲。

下列狀況會導致對病毒掃描軟體發出 Microsoft Exchange Information Store 服務 (Store.exe) 外部函數呼叫時的回應時間過慢：

  • 病毒掃描程式的更新，導致對資訊儲存庫中的項目重新掃描。

  • 病毒掃描程式的設定錯誤

  • 病毒掃描程式軟體處理大型郵件或附件。

若要解決這個錯誤，請採取下列步驟：

  • 將病毒引擎的更新排定在資源消耗較輕的時候，也就是要求離峰期間。

  • 考慮重新安裝病毒掃描軟體，但請在要求離峰期間重新安裝。

  • 檢查病毒掃描引擎的組態以取得正確的執行緒組態、檔案層級排除等。請參閱 Microsoft 知識庫文章 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)。

  • 檢閱本文＜詳細資訊＞一節中的文章。

詳細資訊

若需有關通常搭配 Microsoft Exchange Server 2003 使用的病毒掃描程式詳細資訊，請參閱 Microsoft 知識庫文章 - 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)。

若需有關通常搭配 Microsoft Exchange 2000 Server 使用的病毒掃描程式詳細資訊，請參閱 Microsoft 知識庫文章 - 328841＜Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)。

若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)。

若需如何疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

若需如何疑難排解資訊儲存庫效能的詳細資訊，請參閱 Microsoft 知識庫文章 257725＜XADM：如何收集診斷資料以進行資訊存放的疑難排解＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)。


VSS 快照集呼叫過慢
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-13

Microsoft® Exchange Server Analyzer 工具會檢查 Exchange 函數呼叫記錄 (FCL) (Store.fcl 檔)，找出是否有超出 20 秒回應時間的磁碟區陰影複製 (VSS) 快照集元件事件。

Exchange FCL VSS 元件事件代表對 VSS 快照集元件的 Microsoft Exchange Information Store 服務 (Store.exe) 函數呼叫。

VSS 是一組 COM API，在其實作的架構中，可以在系統上的應用程式持續寫入磁碟區時，同時執行磁碟區備份。

Microsoft Exchange Server 2003 會使用隨附於 Microsoft Windows Server™ 2003 作業系統的 VSS，來進行 Exchange Server 2003 資料庫及交易記錄檔的磁碟區陰影複製。

VSS 快照集並不是完全獨立於原始資料。通常，當您定義時間標記並確定資料可以回復到該時間時，就會建立快照集。

如果 Exchange Server Analyzer 發現 Store.fcl 檔中有事件指出 Microsoft Exchange Information Store 服務 (Store.exe) 對 VSS 快照集元件發出的函數呼叫，回應時間超過 20 秒，Exchange Server Analyzer 就會顯示錯誤。

當 Microsoft Exchange Information Store 服務 (Store.exe) 所發出的跨元件呼叫在等候回應時，遠端程序呼叫 (RPC) 執行緒會在這些要求的背景做備份，從而導致 Exchange Server 的效能問題，例如造成伺服器對用戶端的回應延遲。

附註：
如栗 VSS 快照集是有意在 Exchange 呼叫追蹤記錄收集的 20 秒內起始，則您可以安心地忽略此錯誤訊息，因為它只是指出 Exchange Server 效能問題。

我們建議的最佳作法是，不要讓備份時段與線上維護或使用者要求的尖峰期間重疊。

詳細資訊

若需 VSS 的詳細資訊，請參閱＜搭配 Exchange Server 2003 使用磁碟區陰影複製服務的最佳作法＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56571)。


'SMTPSVC' 錯誤事件 (識別碼：429)
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-03-16

Microsoft Exchange Analyzer 工具會查詢 IIS Metabase，以判定每個簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器執行個體的 LM/SmtpSvc/%SMTPInstance%/ServerState 內容值。

ServerState 內容代表伺服器執行個體目前的狀態。狀態及相對應的狀態代碼如下：1 (啟動中)、2 (已啟動)、3 (停止中)、4 (已停止)、5 (暫停中)、6 (已暫停) 或 7 (繼續中)。

如果 Exchange Analyzer 判定 SMTP 虛擬伺服器執行個體的 ServerState 內容值不等於 2 (已啟動)，則 Exchange Analyzer 會查詢 Win32_NTLogEvent Microsoft Windows Management Instrumentation (WMI) 類別，以判定過去 24 小時內是否曾記錄 SMTP 服務 (SMTPSVC) 的「事件 429」錯誤。

如果 Exchange Analyzer 發現 SMTP 虛擬伺服器執行個體 (VSI) 未啟動，且過去 24 小時內至少記錄到一個 SMTPSVC 的「事件 429」錯誤，Exchange Analyzer 就會顯示警告。

此警告指出 SMTP 虛擬伺服器執行個體的指定目錄可能有問題。

SMTP 是 Exchange Server 的原生郵件通訊協定，用來進行郵件提交與郵件傳輸。這表示用戶端使用 SMTP 來傳送郵件，而 Exchange 伺服器使用 SMTP 來傳遞郵件和郵件資料。

當郵件透過 SMTP 服務抵達 Exchange 電腦時，資料會以 .eml 檔格式寫入硬碟。在預設的情況下，這些檔案會儲存在 <drive>:\Program Files\Exchsrvr\Mailroot 資料夾中 (在安裝 Exchange 的相同磁碟分割區上)。

此問題可能由下列其中一項原因造成：

  • <drive>:\Program Files\Exchsrvr\Mailroot 目錄路徑或該目錄路徑下的資料夾已移除、遺漏或毀損。

  • 未適當地設定對 <drive>:\Program Files\Exchsrvr\Mailroot 或該目錄路徑下資料夾的權限。

  • 防毒應用程式對 <drive>:\Program Files\Exchsrvr\Mailroot 目錄路徑或該目錄路徑下的資料夾進行掃描。

若要解決此警告，請執行下列一或多個動作：

  • 確認 <drive>:\Program Files\Exchsrvr\Mailroot 目錄路徑和該目錄路徑下資料夾的位置和完整性。

  • 確認對 <drive>:\Program Files\Exchsrvr\Mailroot 目錄路徑和該目錄路徑下資料夾的權限。

  • 確定防毒應用程式未掃描 <drive>:\Program Files\Exchsrvr\Mailroot 目錄路徑中的資料夾。

確認 Exchange Server 2003 上的 Mailroot 目錄路徑

  1. 開啟 [Exchange 系統管理員]。

  2. 依序展開 [伺服器]、Exchange 伺服器、[通訊協定] 與 [SMTP]。

  3. 以滑鼠右鍵按一下 SMTP 虛擬伺服器 (例如預設 SMTP 虛擬伺服器)，然後按一下 [停止]。

  4. 再次在 SMTP 虛擬伺服器上按一下滑鼠右鍵，然後按一下 [內容]。

  5. 按一下 [郵件] 標籤。

  6. 在 [佇列目錄] 欄位中，確認適當 Mailroot 資料夾的完整路徑。您可以按一下 [瀏覽] 來瀏覽本機電腦的路徑。

  7. 按一下 [確定]，儲存變更。

  8. 在 SMTP 虛擬伺服器上按一下滑鼠右鍵，然後按一下 [啟動]。
確認 Exchange 2000 Server 上的 Mailroot 目錄路徑

  1. 在您要確認 SMTP 虛擬伺服器 Mailroot 資料夾的 Exchange 2000 Server 電腦上，停止所有 Exchange Server 和 IIS 服務。

  2. 確認受影響之 SMTP 虛擬伺服器的 msExchSmtpQueueDirectory 值，是否設定為適當的路徑。

  3. 等待 Active Directory 將這項變更複寫到這個 Exchange 伺服器使用的通用類別目錄伺服器。

  4. 啟動 Microsoft Exchange System Attendant 服務。

  5. 在 Exchange Server 電腦上，檢查應用程式事件記錄檔中是否存在著三個事件識別碼 1005，其事件來源為 MSExchangeMU，類別為 [一般]。

  6. 重新啟動 Exchange Server 電腦，以使變更生效。
確認對 Exchange 2000 Server 和 Exchange Server 2003 上的 Mailroot 目錄路徑的預設權限

  1. 啟動 [Windows 檔案總管]，然後瀏覽至 Exchsvr 資料夾並將其展開。

  2. 在 Mailroot 資料夾上按一下滑鼠右鍵，再按一下 [內容]。

  3. 按一下 [安全性] 索引標籤，然後確認下列預設權限：

帳戶 | 權限
Administrators | 完全控制
Authenticated Users | 讀取及執行、清單資料夾內容、讀取
Creator Owner | 無
Server Operators | 修改、讀取及執行、清單資料夾內容、讀取、寫入
System | 完全控制
  1. 確認每一個虛擬伺服器執行個體的所有資料夾，是否都擁有這些預設權限。

若需所描述之程序的相關資訊，請參閱下列 Microsoft 知識庫文章：

  • 822933＜如何變更 Exchange 2003 SMTP Mailroot 資料夾位置＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822933)

  • 318230＜XCON：如何變更 Exchange 2000 SMTP Mailroot 目錄位置＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=318230)

若需 SMTP 虛擬伺服器設定的相關資訊，請參閱下列 Microsoft 知識庫文章：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

若需設定防毒掃描應用程式與 Exchange 一起使用的相關資訊，請參閱＜尚未設定防毒資料夾排除＞。

若需有關如何在 Symantec AntiVirus Corporate Edition 中設定 RealTime 掃描排除的詳細資訊，請參閱 Symantec 防毒網站 (英文) (http://www.symantec.com)。

附註：
因為網站地址可能變更，所以您可能無法連接至該處所提及的網站。

若需有關加強 Exchange Server 環境對抗透過電子郵件傳輸病毒及蠕蟲的詳細資訊，請參閱《在 Exchange Serve 2003 環境中減緩及阻止電子郵件病毒》(英文) (http://go.microsoft.com/fwlink/?LinkId=47587)。

若需將防毒軟體與 Exchange Server 搭配使用的相關資訊，請參閱下列 Microsoft 知識庫文章：

  • 328841＜Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需可在 Exchange Server 上使用之協力廠商防毒軟體清單，請參閱＜Exchange Server 2007 合作夥伴：防毒、反垃圾郵件＞(英文) (http://go.microsoft.com/fwlink/?linkid=16226)。


SMTP 執行個體的完整網域名稱不符合伺服器名稱
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-07

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判斷伺服器物件的 networkAddress 屬性的 ncacn_ip_tcp: 字串值是否符合來自簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器物件之 msExchSmtpFullyQualifiedDomainName 屬性中的完整網域名稱 (FQDN)。

如果 Exchange Server Analyzer 判斷這些屬性值不相符，便會顯示警告。

此警告指出這些屬性值可能已手動變更，因此會在此伺服器上造成郵件流程問題。

msExchSmtpFullyQualifiedDomainName 屬性值指定 SMTP 虛擬伺服器的 FQDN，而且必須可以藉由網域名稱系統 (DNS) 網路通訊協定來解析。

此屬性值必須存在有效的 DNS HOST (A) 記錄，讓嘗試解析 SMTP 虛擬伺服器之 FQDN 的傳訊伺服器可以擷取正確的 IP 位址並適當地路由傳送郵件。

若需 Exchange 中的反向 DNS 查詢的詳細資訊，請參閱＜新增資源記錄至 DNS 區域＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63002)。

若需有關 SMTP 虛擬伺服器設定的詳細資訊，請參閱下列知識庫文件：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=266686)。

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)。

若需 SMTP 服務設計的詳細資訊，請參閱《Exchange Server 2003 技術參考手冊》中的＜SMTP 服務設計＞(英文) (http://go.microsoft.com/fwlink/?LinkId=58876) 。


SMTP Local Queue Length 超出閾值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-04-20

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 SMTP Server 效能物件的 Local Queue Length 效能計數器的資料，以分析效能資料。

如果 Exchange Server Analyzer 判定 Local Queue Length 計數器已在取樣時間配量期間超出尖峰值 1000，則會顯示錯誤。

SMTP Server\Local Queue Length 計數器指出簡易郵件傳送通訊協定 (SMTP) 佇列中有多少郵件要對 Microsoft Exchange Information Store 服務進行本機傳遞。當 Exchange 伺服器正在處理 SMTP 本機佇列資料 (Mailroot 目錄) 時，這個資料會暫時保留在儲存裝置中。這個設計可防止在伺服器故障時失去資料。例如，當無法連接目的伺服器時，應該路由傳送至該伺服器的郵件將會一直儲存在本機伺服器佇列目錄上，直到可以傳遞它們為止。

這個錯誤表示伺服器發生效能問題或中斷，因為伺服器不再能夠及時傳遞傳入郵件。下列情況都會造成此延遲：

  • 未立即參考 Active Directory® 目錄服務。

  • 未立即處理本機傳遞或 SMTP 的郵件。

  • 已卸載資料庫 (信箱儲存區及公用資料夾儲存區)。

  • 若要解決這個問題，請採取下列步驟：

  • 確定已裝載所有資料庫 (信箱儲存區及公用資料夾儲存區)。

  • 識別效能瓶頸的來源。效能瓶頸可能與 CPU、磁碟、網路或記憶體相關，也可能是因為伺服器負載增加或伺服器資源不足所導致。使用效能監視器 (Perfmon.msc) 工具，判定導致瓶頸的原因是伺服器負載增加或伺服器太小。如果伺服器負載增加了，請識別負載的來源並降低它。如果伺服器資源不足，請增加必要的資源，或將使用者移出伺服器。

  • 監視外部相依性 (例如 Active Directory 目錄服務)，找出效能問題，然後視需要疑難排解及更正。

詳細資訊

  • 若需 SMTP 傳輸調整的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》中的＜SMTP 傳輸調整＞ (http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需疑難排解郵件流程問題的詳細資訊，請參閱微軟知識庫文件 - 823489＜如何使用 [佇列檢視器] 疑難排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)。

  • 若需疑難排解傳輸問題的詳細資訊，請參閱微軟知識庫文件 - 257265 ＜Exchange 2000 Server 及 Exchange Server 2003 傳輸問題的一般疑難排解＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)。

  • 若需處理器瓶頸的詳細資訊，請參閱＜處理器瓶頸＞。

  • 若需磁碟瓶頸的詳細資訊，請參閱＜偵測到磁碟瓶頸＞。

  • 若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 若需如何移動使用者信箱以減少伺服器負載的詳細資訊，請參閱＜將使用者信箱移至其他伺服器＞。


SMTP Server 效能監視器物件不可用
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 SMTP Server 效能物件的 Local Queue Length 效能計數器的資料，以分析效能資料。如果計數器未傳回有效的資料，Exchange Server Analyzer 便會顯示基準線訊息。

如果效能資料收集引擎未傳回有效的資料，則可能發生了下列任意狀況組合：

  • SMTP Server 效能物件已停用。

  • SMTP Server 效能監視器物件已遺失或已損毀。

  • Exchange Server Analyzer 沒有適當的權限可存取效能物件。

如果某個可擴充的計數器損毀了登錄，或使用 Microsoft Windows® Management Instrumentation (WMI) 的程式修改了登錄，就會發生前兩個狀況。下列程序解說如何修復前兩個狀況。在執行此程序前，請先確認 Exchange Server Analyzer 具有適當的權限。若需有關執行 Exchange Server Analyzer 所需權限的詳細資訊，請參閱包含在 Exchange Server Analyzer 中的說明文件。若需取得 [說明]，請開啟 Exchange Server Analyzer 並按 F1 鍵。

若要更正此錯誤

  1. 確認 SMTP Server 效能物件已啟用。

    1. 下載並安裝 Extensible Performance Counter List 工具 (Exctrlst.exe)。您可以從 Exctrlst.exe：Extensible Performance Counter List 網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=34436) 下載 Exctrlst.exe。

    2. 開啟 Exctrlst.exe，並依序按一下 [Sort Order] 及 [Service]。

    3. 找出要讓效能物件報告的服務，並確認已選取 [Performance Counters Enabled] 核取方塊。

      如果未選取 [Performance Counters Enabled] 核取方塊，請選取此核取方塊，然後重新啟動與效能計數器相關的服務，確認效能計數器可運作。如果效能計數器未運作，或已選取 [Performance Counters Enabled] 核取方塊，請繼續步驟 2。

  2. 依照微軟知識庫文件 - 300956＜如何手動重建效能計數器程式庫值＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) 中的指示，重建遺失或損毀的效能計數器。

  3. 如果遵循此知識庫文件的指示並不能解決問題，則必須以 [修復] 模式重新安裝 Windows 作業系統，並套用最新的 Windows Service Pack。


SQL Server 正在執行已安裝 Exchange Server 為來賓的 Virtual Server 2005
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Model 機碼值是否設為 Virtual Machine。

Exchange Server Analyzer 也會檢查下列登錄值是否存在：

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

此外，Exchange Server Analyzer 還會查詢 Win32_Services WMI 類別，以判定 Microsoft SQL Server™ 服務 (MSSQLSERVER) 是否在執行 Microsoft Virtual Server 2005 的實體電腦上執行。

如果 Exchange Server Analyzer 發現 Model 機碼包含 Virtual Machine 字串，還發現上述登錄分支已存在，而且 MSSQLSERVER 正在執行中，就會顯示錯誤。

Model 機碼值為 Virtual Machine 表示 Exchange Server 電腦目前是以來賓虛擬機器的身分在 Virtual Server 2005 或 Microsoft Virtual PC 2004 上執行。因為上述登錄分支僅由 Virtual Server 2005 所建立，因此存在此登錄分支表示 Exchange Server 電腦目前是以來賓虛擬機器的身分在 Virtual Server 2005 中執行。

Microsoft 不支援在虛擬機器或模擬器上執行任何 Microsoft Exchange 版本。這項規則涵蓋在 Microsoft Virtual Server 2005、Microsoft Virtual PC 2004，或任何協力廠商的虛擬機器程式上執行的 Exchange Server。Microsoft Exchange Server 平台的設計和測試都只針對實體硬體來執行，特別是在 Windows Server Catalog (http://go.microsoft.com/fwlink/?linkid=17219) 中列出的那些硬體平台。

此外，在執行 SQL Server 的電腦上以虛擬伺服器來賓身分執行 Exchange 並不是最佳作法，因為這樣服務之間就不能有足夠的備援。

若要更正此錯誤

  1. 將在 Virtual Server 2005 上執行的 Exchange Server 之信箱，移到非虛擬 Exchange Server 電腦上。

  2. 視需要，將任何公用資料夾重新歸屬，並且轉移虛擬 Exchange 伺服器持有的角色。

  3. 從虛擬機器解除安裝 Exchange，以從 Exchange 基礎結構及 Active Directory® 目錄服務中解除委任及移除它。

若需有關移動信箱的詳細資訊，請參閱下列微軟知識庫文件：

  • 822892＜Exchange 2003 中移動信箱的改良功能＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975＜XADM：移動信箱方法間的差異＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

若需有關支援在虛擬環境中執行之 Exchange Server 電腦的詳細資訊，請參閱知識庫文件 - 320220＜虛擬機器或模擬機器上的 Exchange Server 支援界限＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)。

若需有關 Microsoft Virtual Server 2005 的詳細資訊，請參閱 Microsoft Virtual Server 2005 網站 (英文) (http://go.microsoft.com/fwlink/?linkid=34938)。

若需有關 Microsoft Virtual PC 2004 的詳細資訊，請參閱 Microsoft Virtual PC 2004 網站 (英文) (http://go.microsoft.com/fwlink/?linkid=34663)。


SRS port is below 5000
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Microsoft Exchange Site Replication Service 的 TCP/IP 設定。

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

如果 Exchange Server Analyzer 發現 TCP/IP 設為低於 5,000 (十進位) 的值，就會顯示警告。

如果您必須將 TCP/IP 設為靜態值，建議您將其設為略大於 5,000 的值。指派低於 5,000 的靜態通訊埠編號會造成與其他處理程序的通訊埠衝突，並導致 Microsoft Exchange System Attendant 服務處理程序失敗。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要設定 TCP/IP 登錄機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters

  3. 按兩下 TCP/IP 機碼，並將 [數值資料] 欄位設為略微超過 5000 (十進位) 的整數。

  4. 關閉登錄編輯程式。

  5. 重新啟動 Microsoft Exchange Site Replication Service，使此變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關通訊埠限制的詳細資訊，請參閱知識庫文件 - 194952＜XADM：Exchange Server 的靜態對應通訊埠限制＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952)。


SRS 通訊埠已經被手動覆寫
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已手動覆寫 Microsoft Exchange Site Replication Service 的通訊埠值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

如果 Exchange Server Analyzer 發現 TCP/IP 存在且已設定，就會顯示非預設的組態訊息。

設定此值最常見的原因就是，讓 MAPI 用戶端能夠連線到在防火牆另一端的 Exchange 伺服器。此案例會開啟防火牆上的多個通訊埠，以讓 Microsoft Office Outlook® 2003 用戶端使用 MAPI 連線到 Exchange伺服器，這通常是透過網際網路連線。這是支援的組態。若需設定 MAPI 用戶端連線到防火牆後的 Exchange，請參閱微軟知識庫文件 - 270836＜Exchange 2000 及 Exchange 2003 靜態連接埠對應＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)。如果您不使用此案例，則應該移除該登錄機碼。

若要以 MAPI 模式使用 Outlook 透過網際網路連線到 Exchange 伺服器，建議的部署方式是使用 Microsoft Windows Server™ 2003、Exchange Server 2003、Outlook 2003 及 Microsoft Windows® XP Professional 中的 RPC over HTTP 功能。API 模式先前稱為「公司」或「工作群組」模式。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要移除 TCP/IP 登錄項目

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters

  3. 刪除名為 TCP/IP 的登錄值。

  4. 結束登錄編輯程式，並重新啟動 Microsoft Exchange Site Replication Service。

若要部署 RPC over HTTP

  1. 檢閱《Exchange Server 2003 RPC over HTTP 部署案例》(英文) (http://go.microsoft.com/fwlink/?linkid=47577)。

  2. 檢閱微軟知識庫文件 - 833401＜如何在 Exchange Server 2003 中為單一伺服器設定 RPC over HTTP＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)。

  3. 檢閱知識庫文件 - 827330＜如何疑難排解 Office Outlook 2003 用戶端的 RPC over HTTP 連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)。

  4. 檢閱 Microsoft Support WebCast＜透過網際網路 (RPC/HTTP) 搭配使用 Microsoft Exchange 與 Microsoft Office Outlook 2003＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


不支援為系統服務員設定的啟動帳戶
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Services Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Microsoft Exchange System Attendant 服務 (MSExchangeSA) 之 StartName 內容中指定的啟動帳戶是否使用 LocalSystem 帳戶。如果 Exchange Server Analyzer 在 Exchange 2000 Server 或 Exchange Server 2003 電腦上，發現 StartName 內容值是 LocalSystem 帳戶以外的其他帳戶，就會顯示警告。LocalSystem 帳戶也可以指 SYSTEM 帳戶。

您必須在 Exchange 2000 Server 及 Exchange Server 2003 的 LocalSystem 安全性內容下啟動 MSExchangeSA。您不得籍由與特定使用者帳戶產生關聯來啟動 MSExchangeSA。當以 LocalSystem 身分執行的 Exchange 服務存取遠端伺服器時，會使用電腦帳戶的認證來驗證 Exchange 服務。

變更密碼的標準機制是每 7 天變更一次電腦帳戶上的密碼。藉由每 7 天變更一次密碼的方式，可增強電腦帳戶的安全性。電腦帳戶比一般使用者帳戶更安全的原因如下：

  • 一般使用者帳戶上的密碼不常變更。

  • 一般使用者帳戶上的密碼不像隨機產生的電腦帳戶密碼那麼隨機。

在 Exchange Server 5.5 中，會使用使用者帳戶執行服務。某些有 Exchange Server 5.5 使用經驗的系統管理員，會將 Exchange 2000 Server 服務及 Exchange Server 2003 服務的啟動帳戶，由使用預設 LocalSystem 帳戶變更為使用者帳戶。

在 Exchang 2000 Server 及 Exchange Server 2003 中，Microsoft 不支援在預設 LocalSystem 帳戶之外的任何帳戶中執行 MSExchangeSA。

更正這個錯誤

  1. 按一下 [開始]，並依序指向 [程式集] 及 [系統管理工具] 後，再按一下 [服務]。

  2. 在服務清單中，在 [Microsoft Exchange System Attendant] 上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 在 [登入] 索引標籤上，於 [登入身分] 底下，按一下 [本機系統帳戶]，然後按一下 [確定]。

  4. 在 [Microsoft Exchange System Attendant] 上按一下滑鼠右鍵，然後按一下 [重新啟動]。

若需有關 Exchange 服務的詳細資訊，請參閱微軟知識庫文件 - 239762＜在 LocalSystem 下執行的 Exchange 服務＞(英文) ( http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)。


STORE.EXE 檔案遺失
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，檢查數個核心 Exchange 二進位檔是否存在：

  • Exres.dll

  • Gapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapi32.dll (在 System32 及 \Exchsrvr\bin 兩個資料夾中檢查)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

若 Exchange Server Analyzer 發現有一或多個上述檔案遺失，就會顯示一則錯誤。若要解決此錯誤，請安裝您 Exchange 版本的最新 Service Pack 或更新彙總套件。若此錯誤持續存在，請執行 Exchange 2000 Server 或 Exchange Server 2003 安裝程式，並選取 [重新安裝]。以「重新安裝」模式執行安裝程式時，只會安裝二進位檔案。這種安裝模式並不會移除或重設任何使用者資料或組態資料。如果要重新安裝 Exchange Server，則還必須重新安裝所有先前安裝的 Exchange Service Pack 或 Hotfix。

若要重新安裝 Exchange 2000 Server 或 Exchange Server 2003

  1. 登入您要重新安裝 Exchange 的伺服器。將 Exchange 2000 Server 或 Exchange Server 2003 CD 插入光碟機。

  2. 在 [開始] 功能表上，按一下 [執行]，然後鍵入 <drive>:\setup\i386\setup，其中 <drive> 是您的光碟機。

  3. 在 [歡迎使用 Microsoft Exchange 安裝精靈] 頁面中，按 [下一步]。

  4. 在 [授權合約] 頁面中，閱讀合約內容。若您同意其中的條款，請按 [我同意]，然後按 [下一步]。

  5. 在 [產品識別] 頁面中，鍵入您的 25 位數產品金鑰，然後按 [下一步]。

  6. 在 [元件選取項目] 頁面中，於 [動作] 直欄中，使用 [Microsoft Exchange] 節點旁的下拉箭頭，並選取 [重新安裝]，然後按 [下一步]。

若需有關最新 Exchange Server 2003 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=25097)。

若需有關最新 Exchange Server 2000 Service Pack、更新彙總套件及增益集的詳細資訊，請參閱「Exchange Server 2000 下載」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33457)。


儲存區 HTTP 通訊埠低於 5000
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-03-21

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Microsoft Exchange Information Store 服務的 Rpc/HTTP Port 設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

如果 Exchange Server Analyzer 發現 Rpc/HTTP Port 設定為低於 5000 (十進位) 的值，就會顯示警告。

Exchange Server 2003 與 Exchange Server 2007 安裝程式會將 Rpc/HTTP Port 登錄機碼設為 6001。Rpc/HTTP Port 登錄機碼是用來支援 Microsoft Office Outlook® 2003 與 Microsoft Office Outlook 2007 的 RPC over HTTP 功能。

除非您透過 Microsoft 諮詢服務或採納來自 Microsoft 產品支援服務的建議自訂了 RPC over HTTP 部署，否則建議使用預設通訊埠值來部署 RPC over HTTP。

如果您必須將 Rpc/HTTP Port 設為 6001 以外的值，建議您將其設為稍高於 5000 的值。指派低於 5000 的靜態通訊埠編號可能會造成與其他處理程序的通訊埠衝突，從而導致 Microsoft Exchange Information Store 服務處理程序失敗。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要將 Rpc/HTTP Port 登錄設為其預設值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

  3. 連按兩下 [Rpc/HTTP Port] 機碼，並將 [數值資料] 欄位設為 6001 (十進位) 或稍高於 5000 的整數 (十進位)。

  4. 關閉登錄編輯程式。

  5. 重新啟動電腦，使此設定生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱 Microsoft 知識庫文章 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關設定 RPC over HTTP 的詳細資訊，請參閱下列知識庫文章：

  • 833401＜如何在 Exchange Server 2003 中為單一伺服器設定 RPC over HTTP＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330＜如何疑難排解 Office Outlook 2003 用戶端的 RPC over HTTP 連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


儲存區：HTTP 通訊埠並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-09

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 HTTP Port 是否設為預設值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

如果 Exchange Server Analyzer 發現 Rpc/HTTP Port 的值不是 6001 (十進位)，就會顯示非預設的組態訊息。

Exchange Server 2003 和 Exchange Server 2007 安裝程式會將 Rpc/HTTP Port 登錄機碼設為 6001。Rpc/HTTP Port 登錄機碼是用來支援 Microsoft Office Outlook® 2003 和 Microsoft Office Outlook 2007 的 RPC over HTTP 功能。

除非您透過 Microsoft 諮詢服務或採納來自 Microsoft 產品支援服務的建議自訂了 RPC over HTTP 部署，否則建議使用預設通訊埠值來部署 RPC over HTTP。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要將 Rpc/HTTP 通訊埠登錄機碼設為其預設值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 按兩下 Rpc/HTTP Port 機碼，並將 [數值資料] 欄位設為 6001 (十進位)。

  4. 關閉登錄編輯程式。

  5. 重新啟動電腦，使此設定生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關設定 RPC over HTTP 的詳細資訊，請參閱下列知識庫文件：

  • 833401＜如何在 Exchange Server 2003 中為單一伺服器設定 RPC over HTTP＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330＜如何疑難排解 Office Outlook 2003 用戶端的 RPC over HTTP 連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


次佳記憶體設定
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-02-15

Microsoft Exchange Analyzer 工具會查詢 Win32_NTLogEvent Microsoft Windows Management Instrumentation (WMI) 類別，以判定過去 24 小時內是否曾記錄 MSExchangeIS 的「事件 9665」錯誤。

Microsoft Exchange Server 2003 會在儲存區處理程序啟動時，執行最佳記憶體組態檢查。如果記憶體的設定並非最佳，您會在事件檢視器中看到事件 9665。

如果 Exchange Analyzer 發現過去 24 小時內曾記錄「事件 9665」，Exchange Analyzer 就會讀取事件的資料欄位，以判定事件中出現的是下方表格內的哪些標幟。

事件資料欄位標幟 | 顯示的 Exchange Server Analyzer 警告 | Exchange Server 2003 問題
0x00000001 | 未設定 /3GB 參數 | 執行 Microsoft Windows 2000 Advanced Server 或 Microsoft Windows 2000 Datacenter Server 的伺服器擁有 1 GB 以上的實體記憶體，但並未在 boot.ini 檔中設定 /3GB 參數。
0x00000002 | 未正確設定 /Userva 參數 | 執行 Microsoft Windows Server 2003 Standard Edition、Microsoft Windows Server 2003 Enterprise Edition 或 Microsoft Windows Server 2003 Datacenter Edition 的伺服器擁有 1 GB 以上的實體記憶體且已設定 /3GB 參數，但在 boot.ini 檔中並沒有 /USERVA 設定。
0x00000004 | 必須設定 'SystemPages' 設定。 | 伺服器執行的是 Microsoft Windows 2000 Server 的任一版本，而登錄中的 SystemPages 值設為 24000 至 31000 範圍以外的值。
0x00000008 | 必須重設 'SystemPages' 設定。 | 伺服器執行的是 Microsoft Windows Server 2003 Standard、Microsoft Windows Server 2003 Enterprise 或 Microsoft Windows Server 2003 Datacenter Edition，而登錄中的 SystemPages 值設為 0 以外的值。
0x00000010 | 未正確設定 HeapDecommitFreeBlockThreshold 設定 | 伺服器執行的是 Microsoft Windows 2000 Server 或 Microsoft Windows Server 2003 的任一版本，而登錄中的 HeapDeCommitFreeBlockThreshold 值設為 0x00040000 以外的值。

Exchange Analyzer 會根據「事件 9665」資料欄位中出現的標幟，顯示以上表格中相對應的警告。

這些警告表示 Exchange Server 記憶體的設定為次佳狀態。

若要更正這些警告，請遵循下方所列的 Exchange Analyzer 相關問題文章中的指導：

  • 此 Exchange 信箱伺服器具有 1 GB 或以上的記憶體，但 Boot.ini 檔案中未設定 /3GB

  • USERVA 設定不正確

  • SystemPages 設定太高

  • 此伺服器是執行 Windows Server 2003 且 SystemPages 值不等於 0

  • 此伺服器有 1 GB 以上的實體記憶體，且 HeapDeCommitFreeBlockThreshold 尚未設為 262144

詳細資訊

如需這些問題的相關資訊，請參閱 Microsoft 知識庫文章 325044＜如何疑難排解 Exchange Server 2003 及 Exchange 2000 Server 的虛擬記憶體分散＞(機器翻譯) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)。

如需 MSExchangeIS 事件 9665 的相關資訊，請參閱「事件及錯誤訊息中心：事件詳細資料」。

  • 若是信箱儲存區事件 9665，請參閱 http://go.microsoft.com/fwlink/?LinkId=83210。

  • 若是公用儲存區事件 9665，請參閱 http://go.microsoft.com/fwlink/?LinkId=83213。


用戶端上安裝了可疑的桌面搜尋
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-09-05

Microsoft® Exchange Server Analyzer 工具判斷有許多使用者使用桌面搜尋引擎。桌面搜尋引擎可能會對使用者裝載的信箱建立許多遠端程序呼叫 (RPC)，並對公用資料夾產生相當大的流量，因為這些搜尋引擎會尋檢公用資料夾儲存區的檔案結構。許多搜尋引擎只會尋檢列於使用者之公用資料夾我的最愛清單的公用資料夾。因此，您不一定能在公用資料夾伺服器上看得到來自桌面搜尋的負載。

為了減輕此問題，可以採取的動作如下：

  • 請使用者關閉掃描程式的 Microsoft Office Outlook® 功能，或將掃描限制於只針對其個人信箱。

  • 以 Exchange 快取模式 (離線) 執行 Outlook，使掃描只影響本機工作站，而不影響伺服器。

  • 請遵循 Microsoft 知識庫文章 889086＜嘗試存取 Exchange 2000 Server 上的公用資料夾時，可能在 Windows XP 型電腦上遭遇意外的行為＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=889086) 中的指引，以取得 Hofix 並在執行 Exchange Server 且由桌面搜尋使用者存取的電腦上設定 MaxObjsPerMapiSession 登錄機碼。

若要確認桌面搜尋應用程式是否為特定使用者之高負載的原因，請使用 Microsoft Exchange Server User Monitor (ExMon) 來監視搜尋引擎動作的 RPC 操作，確定已收集足夠時間間隔的資料 (至少 5 分鐘)。然後，移除搜尋引擎，再執行一次 ExMon 工具。如果 RPC 率顯著降低，即可確認桌面搜尋引擎會造成負載增加。如果觀察到平均 RPC 延遲降低，即可確認高負載會導致較高的 RPC 延遲。

附註：
RPC 延遲率在一天之中的變化相當大。因此，5 分鐘的測試可能不夠。您可能需要測量較長的時間間隔。

若要下載 ExMon，請參閱 Microsoft 下載中心 (英文) (http://go.microsoft.com/fwlink/?linkid=54983)。

詳細資訊

  • 若需有關桌面搜尋軟體的詳細資訊，請參閱：

    • 微軟知識庫文件 - 905184＜在 Outlook 或其他 MAPI 用戶端電腦上執行桌面搜尋引擎軟體，可能會影響 Exchange 2000 Server 與 Exchange Server 2003 的效能＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184)。

    • Microsoft Exchange 團隊部落格＜您的用戶端正在使用對 Exchange 信箱或公用資料夾進行索引的桌面搜尋引擎嗎？＞(英文) (http://go.microsoft.com/fwlink/?LinkId=54475)。

  • 若需有關 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需有關疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《疑難排解 Microsoft Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


SystemPages 設定太高
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-03-13

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目來判定 SystemPages 的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

如果 Exchange Server Analyzer 發現 SystemPages 的值大於 50000，就會顯示一則警告。

不管安裝的實體 RAM 是多少，Microsoft Windows Server™ 2003 及 Microsoft Windows® 2000 Server 最多可以直接定址 4 GB的記憶體位址空間。從處理程序的角度來看，在觀念上，虛擬位址的每一個元素都可以指向實體記憶體的一個位元組。將每一個虛擬位址轉換或對應至相對應的實體位址，是「虛擬記憶體管理員 (VMM)」和處理器記憶體管理單元 (MMU) 兩者的共同責任。VMM 執行對應的方式，是將 RAM 劃分為固定大小的頁面框架，然後建立一些系統分頁表項目 (PTE)，來儲存和這些頁面框架有關的資訊，並進行對應。系統 PTE 是小型的記憶體核心模式緩衝區，用來與磁碟 I/O 子系統及網路進行通訊。每一個 PTE 代表一個頁面框架，並且其中包含 VMM 用來找出分頁所需要的資訊。

在使用 4 KB 分頁大小的 x86 系列系統上，需要對映 2 GB 位址空間的最大 PTE 數目是 524288 (2 GB/4 KB) 個。在使用 /3GB 參數的類似系統上，要對映 3 GB 位址空間所需要的 PTE 數目是 786432 (3 GB/4 KB) 個。在一般的系統上，此空間的用法如下：

  • 最多保留 50000 個 PTE (大約 195 MB 位址空間) 供一般用途。

  • 其餘會用來對應系統快取、超空間 (Hyperspace)、分頁集區、未分頁集區、損毀傾印區域等等。

此 PTE 集區大小是在系統啟動時，依據系統中的實體記憶體數量自動決定。這個集區會擠在分頁集區和未分頁集區之間，也會隨著系統中的實體記憶體數量而成長。

系統 PTE 集區久而久之會變得使用過度，並且嚴重分散。這可能導致驅動程式未載入等狀況。同時，如果系統 PTE 集區完全耗竭，系統的其他部分會跟著降級，甚至導致無法建立執行緒、系統停滯以及系統當機等問題。

為了防止系統 PTE 集區嚴重分散，您一定要針對 Exchange Server 電腦的作業系統，適當地設定 SystemPages 登錄值。在 Windows Server 2003 上執行 Exchange Server 時，建議您將 SystemPages 登錄機碼設為 0。這項建議與 Windows 2000 Server 的建議剛好相反，Windows 2000 Server 建議將 SystemPages 設為介於 24000 與 31000 之間的值。

執行過以下說明的程序之後，您應該監視可用的系統 PTE 數。您可以使用 Windows 效能監視器 (亦稱為系統監視器) 來監視 Memory | Free System Page Table Entries 效能計數器，以執行這個動作。若在進行以下說明的登錄變更之後，可用的系統 PTE 數目依舊很低，您應該檢查下列事項，確定您的 Exchange Server 電腦已做最佳設定：

  • 驅動程式 驅動程式故障是造成系統 PTE 低的最常見原因。此外，已知 S3 Savage 4 視訊卡驅動程式的某些版本已將 SystemPages 設為 208896。此驅動程式常見於 IBM E-Series 伺服器上。請洽詢您的硬體製造商，確定您的硬體使用的是最新的驅動程式。有時也許可以降級為使用較基本的驅動程式。例如，電腦若執行如 Exchange Server 之類的伺服器型應用程式，通常不需要使用包含所有功能的最進階視訊驅動程式。只要使用較基本的驅動程式就已夠用。從進階的視訊驅動程式切換為基本的視訊驅動程式，應該就會提高可用的系統 PTE 數目。

  • 系統組態 如果 Windows Server 2003 系統安裝了 1 GB 或更多的實體記憶體，您應該進行檢查以確定其 Boot.ini 檔案已正確設定 /3GB 及 /USERVA=3030 參數，如下列微軟知識庫文件中所述：

    • 823440＜在 Windows Server 2003 型的系統上安裝 Exchange Server 2003 時，必須使用 /3GB 參數＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440)

    • 810371＜XADM：在 Windows Server 2003 型的 Exchange Server 上使用 /Userva 參數＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371)。

  • 事件日誌 檢查 Exchange Server 上的應用程式事件日誌內是否有出現錯誤及警告，特別是 MSExchangeIS 事件 9582 (錯誤及警告)、9665 (警告) 以及 12880 (錯誤)。出現事件 9665 也可能表示 SystemPages 沒有設定為最佳效能。若需有關這些事件的詳細資訊，請參閱知識庫文件 - 325044＜HOW TO：疑難排解 Exchange 2003 及 Exchange 2000 的虛擬記憶體分散＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要在 Windows 2000 Server 上變更 SystemPages 的值來更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. 在右窗格中，按兩下 SystemPages。

  4. 在 [數值資料] 欄位中，輸入介於 24000 和 31000 之間的值 (十進位)，再按一下 [確定]。如果您不確定要使用哪一個值，我們建議使用 31000 (十進位)。

  5. 關閉登錄編輯程式，然後重新啟動電腦，以使變更生效。

若要在 Windows Server 2003 上變更 SystemPages 的值來更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. 在右窗格中，按兩下 SystemPages。

  4. 在 [數值資料] 欄位中，鍵入 0，然後按一下 [確定]。

  5. 關閉登錄編輯程式，然後重新啟動電腦，以使變更生效。

若要更新或降級視訊驅動程式來更正此警告

  • 執行下列其中一個動作：

    • 連絡您的硬體製造商，來取得未設定 SystemPages 設定之更新的視訊驅動程式。

    • 將視訊驅動程式降級為標準 VGA 驅動程式，然後依上述內容來更正 SystemPages 值。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關最佳化 Exchange Server 記憶體的詳細資訊，請參閱下列知識庫文件：

  • 325044＜HOW TO: 疑難排解 Exchange 2003 及 Exchange 2000 的虛擬記憶體分散＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)

  • 311901＜4GT 調整對系統分頁表項目的效果＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


系統服務員 HTTP 通訊埠低於 5000
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-03-21

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Microsoft Exchange System Attendant 的 HTTP Port 設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

如果 Exchange Server Analyzer 發現 HTTP Port 的值設為低於 5000 (十進位) 的值，就會顯示一則警告。

Exchange Server 2003 與 Exchange Server 2007 安裝程式會將 HTTP Port 登錄機碼設為 6002。HTTP Port 登錄機碼是用來支援 Microsoft Office Outlook® 2003 與 Microsoft Office Outlook 2007 的 RPC over HTTP 功能。

除非您透過 Microsoft 諮詢服務或採納來自 Microsoft 產品支援服務的建議自訂了 RPC over HTTP 部署，否則建議使用預設通訊埠值來部署 RPC over HTTP。

您必須要將 HTTP Port 設為 6002 以外的值，建議您將它設為稍大於 5000 的值。指派低於 5000 的靜態通訊埠編號，可能會導致與其他處理程序的通訊埠衝突，從而導致 Microsoft Exchange System Attendant 處理程序失敗。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要將 HTTP Port 登錄機碼設為其預設值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 連按兩下 HTTP Port 機碼，並將 [數值資料] 欄位設為 6002 (十進位) 或稍大於 5000 (十進位) 的整數。

  4. 關閉登錄編輯程式。

  5. 重新啟動電腦，使此設定生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱 Microsoft 知識庫文章 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關設定 RPC over HTTP 的詳細資訊，請參閱下列知識庫文章：

  • 833401＜如何在 Exchange Server 2003 中為單一伺服器設定 RPC over HTTP＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330＜如何疑難排解 Office Outlook 2003 用戶端的 RPC over HTTP 連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


系統服務員 HTTP NSPI 通訊埠低於 5000
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-03-21

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Microsoft Exchange System Attendant 的 Rpc/HTTP NSPI Port 設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

如果 Exchange Server Analyzer 發現 Rpc/HTTP NSPI Port 設定為低於 5000 (十進位) 的值，就會顯示警告。

Exchange Server 2003 與 Exchange Server 2007 安裝程式會將 Rpc/HTTP NSPI Port 登錄機碼設為 6004。Rpc/HTTP NSPI Port 登錄機碼是用來支援 Microsoft Office Outlook® 2003 與 Microsoft Office Outlook 2007 的 RPC over HTTP 功能。

除非您透過 Microsoft 諮詢服務或採納來自 Microsoft 產品支援服務的建議自訂了 RPC over HTTP 部署，否則建議您使用預設通訊埠值來部署 RPC over HTTP。

如果您必須將 Rpc/HTTP NSPI Port 設為 6004 以外的值，建議您將其設為稍高於 5000 的值。指派低於 5000 的靜態通訊埠編號可能會造成與其他處理程序的通訊埠衝突，從而導致 Microsoft Exchange System Attendant 處理程序失敗。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要將 Rpc/HTTP NSPI 通訊埠登錄機碼設為其預設值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 連按兩下 [Rpc/HTTP NSPI Port] 機碼，並將 [數值資料] 欄位設為 6004 (十進位) 或稍高於 5000 的整數 (十進位)。

  4. 關閉登錄編輯程式。

  5. 重新啟動電腦，使此設定生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱 Microsoft 知識庫文章 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關設定 RPC over HTTP 的詳細資訊，請參閱下列知識庫文章：

  • 833401＜如何在 Exchange Server 2003 中為單一伺服器設定 RPC over HTTP＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330＜如何疑難排解 Office Outlook 2003 用戶端的 RPC over HTTP 連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


系統服務員：HTTP NSPI 通訊埠並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 HTTP Port 是否設為預設值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

如果 Exchange Server Analyzer 發現 Rpc/HTTP NSPI Port 的值不是 6004 (十進位)，就會顯示非預設的組態訊息。

Exchange Server 2003 安裝程式會將 Rpc/HTTP NSPI Port 登錄機碼設為 6004。Rpc/HTTP NSPI Port 登錄機碼用來支援 Microsoft Office Outlook® 2003 的 RPC over HTTP 功能。

除非您透過 Microsoft 諮詢服務或採納來自 Microsoft 產品支援服務的建議自訂了 RPC over HTTP 部署，否則建議使用預設通訊埠值來部署 RPC over HTTP。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要設定 Rpc/HTTP NSPI Port 登錄值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 按兩下 Rpc/HTTP NSPI Port 機碼，並將 [數值資料] 欄位設為 6004 (十進位)。

  4. 關閉登錄編輯程式。

  5. 重新啟動電腦，使此設定生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關設定 RPC over HTTP 的詳細資訊，請參閱下列知識庫文件：

  • 833401＜如何在 Exchange Server 2003 中為單一伺服器設定 RPC over HTTP＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330＜如何疑難排解 Office Outlook 2003 用戶端的 RPC over HTTP 連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


系統服務員：HTTP 通訊埠值並非預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-09

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 HTTP Port 是否設為預設值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

如果 Exchange Server Analyzer 發現 HTTP Port 的值不是 6002 (十進位)，就會顯示非預設的組態訊息。

Exchange Server 2003 與 Exchange Server 2007 安裝程式會將 HTTP Port 登錄機碼設為 6002。HTTP Port 登錄機碼是用來支援 Microsoft Office Outlook® 2003 與 Microsoft Office Outlook 2007 的 RPC over HTTP 功能。

除非您透過 Microsoft 諮詢服務或採納來自 Microsoft 產品支援服務的建議自訂了 RPC over HTTP 部署，否則建議使用預設通訊埠值來部署 RPC over HTTP。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要將 HTTP 通訊埠登錄機碼設為其預設值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 按兩下 HTTP Port 機碼，並將 [數值資料] 欄位設為 6002 (十進位)。

  4. 關閉登錄編輯程式。

  5. 重新啟動電腦，使此設定生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關設定 RPC over HTTP 的詳細資訊，請參閱下列知識庫文件：

  • 833401＜如何在 Exchange Server 2003 中為單一伺服器設定 RPC over HTTP＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330＜如何疑難排解 Office Outlook 2003 用戶端的 RPC over HTTP 連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


遺失系統服務員 legacyExchangeDN 值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-09

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個 Exchange Server 電腦之系統服務員物件的 legacyExchangeDN 屬性值。如果 Exchange Server Analyzer 發現有任何系統服務員物件沒有 legacyExchangeDN 屬性值，就會顯示錯誤訊息。

在失敗修復的情況下，系統管理員若是修改 Active Directory 以復原資料庫，可能會導致 legacyExchangeDN 遺失。若要解決此錯誤，必須使用 Active Directory 編輯程式 (如 LDP (ldp.exe) 工具或 [Active Directory Service Interfaces (ADSI) 編輯器]) 來修改 legacyExchangeDN 屬性。

為確保 legacyExchangeDN 屬性正確，您還應檢查此伺服器上或其他 Exchange 伺服器上未產生此錯誤的其他系統服務員物件，因為它們應具有類似的 legacyExchangeDN 屬性值。

若資料庫遺失 legacyExchangeDN 屬性，則其他幾個系統物件可能也同樣遺失此屬性。因此，若要使用 LDP 或 [ADSI 編輯器] 來新增 legacyExchangeDN 值，則必須也要在所有其他系統物件上新增 legacyExchangeDN 值。

注意：
使用 ADSI 編輯器、LDP 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或 Exchange Server 2007，或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
若要更正此錯誤

  1. 開啟一個 Active Directory 編輯程式，如 [ADSI 編輯器]。

  2. 依序展開 [組態 [DomainName]]、[CN=Configuration] 及 [DC=DomainName]、[DC=DomainSuffix]。

  3. 依序展開 CN=Services 及 CN=Microsoft Exchange。

  4. 依序展開 [CN=OrganizationName]、[CN=Administrative Groups] 及 [CN=AdminGroupName]。

  5. 依序展開 [CN=Servers] 及 [CN=ServerName]。

  6. 在 [CN=Microsoft System Attendant] 上按一下滑鼠右鍵，然後選取 [內容]。

  7. 向下捲動以尋找 legacyExchangeDN 並選取它，然後按一下 [編輯]。

  8. 在 [值] 欄位中，輸入正確的 legacyExchangeDN。

  9. 關閉 Active Directory 編輯器，並重新啟動 Exchange Server 電腦，讓變更生效。

若需有關使用 [ADSI 編輯器] 建立新 legacyExchangeDN 屬性的詳細資訊，請參閱微軟知識庫文件 - 273863＜如何在原生模式使用 ADSI 編輯器變更 LegacyExchangeDN 屬性＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863)。


系統服務員 NSPI 通訊埠已經被手動覆寫
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-17

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來判斷是否已手動覆寫名稱服務提供者介面目標伺服器 (NSPI 目標伺服器) 服務：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

如果 Exchange Server Analyzer 發現 TCP/IP NSPI Port 已存在且已設定，就會顯示非預設的組態訊息。

設定此值的最常見原因是要讓 MAPI 用戶端連線至位於防火牆另一邊的 Exchange 伺服器。此案例會開啟防火牆上的多個通訊埠，以讓 Microsoft Office Outlook® 2003 用戶端使用 MAPI 連線到 Exchange伺服器，這通常是透過網際網路連線。

在公司或工作群組模式下使用 Outlook 來透過網際網路連線到 Exchange 伺服器的建議部署，便是使用 Microsoft Windows Server™ 2003、Exchange Server 2003、Outlook 2003 及 Windows® XP Professional 所含有的遠端程序呼叫 (RPC) over HTTP 功能。

RPC over HTTP 讓您不需要使用虛擬私人網路 (VPN) 連線或在防火牆開啟多個通訊埠，即可從 Outlook 2003 對 Exchange Server 2003 進行 MAPI 存取。執行 Outlook 2003 的使用者可以透過網際網路連線至 Exchange 伺服器。RPC 用戶端可藉由透過 HTTP 通訊協定建立 RPC 流量通道來建立網際網路連線。如果 RPC 用戶端可以與執行 Internet Information Services (IIS) 的遠端電腦建立 HTTP/HTTPS 連線，該 RPC 用戶端就可以連線到遠端網路上的任何伺服器。遠端網路上的伺服器必須設定為可使用 RPC over HTTP 來透過網際網路存取。此外，RPC 用戶端及 RPC 伺服器程式可以經由網際網路來連線，即使這兩個程式分別在不同網路的防火牆背後。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要移除 TCP/IP NSPI Port 登錄項目

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. 刪除名為 TCP/IP NSPI Port 的登錄值。

  4. 結束登錄編輯程式，然後重新啟動 Exchange System Attendant 服務。

若要部署 RPC over HTTP

  1. 檢閱《Exchange Server 2003 RPC over HTTP 部署案例》(英文) (http://go.microsoft.com/fwlink/?linkid=47577)。

  2. 檢閱微軟知識庫文件 - 833401＜如何在 Exchange Server 2003 中為單一伺服器設定 RPC over HTTP＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)。

  3. 檢閱知識庫文件 - 827330＜如何疑難排解 Office Outlook 2003 用戶端的 RPC over HTTP 連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)。

  4. 檢閱 Microsoft Support Web Cast＜透過網際網路 (RPC/HTTP) 搭配使用 Microsoft Exchange 與 Microsoft Office Outlook 2003＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關在防火牆環境中使用 TCP/IP NSPI Port 登錄值的詳細資訊，請參閱知識庫文件 - 270836＜Exchange 2000 靜態連接埠對應＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)。


系統服務員服務設定為與桌面互動
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Microsoft Exchange System Attendant (MSExchangeSA) 服務的 DesktopInteract 屬性值。如果 Exchange Server Analyzer 發現 Exchange System Attendant 服務設定為與桌面互動，就會顯示一則錯誤。

此組態應該只在 Microsoft 產品支援服務的指導下使用。除非 Microsoft 產品支援服務已指示您以此組態執行系統服務員服務，否則建議您重新設定系統服務員服務內容，使它不會與桌面互動。

設定 Exchange 系統服務員服務帳戶

  1. 開啟 [服務] Microsoft Management Console (MMC) 嵌入式管理單元。

  2. 尋找並停止 [Microsoft Exchange 系統服務員] 服務。請注意，停止系統服務員服務還會停止依存於系統服務員服務的所有服務。這包括 Microsoft Exchange Information Store 服務。

  3. 連按兩下 [Microsoft Exchange 系統服務員] 服務。

  4. 在 [Microsoft Exchange 系統服務員內容] 頁面的 [登入] 索引標籤上，選取 [登入身分] 下的 [本機系統帳戶]。

  5. 清除 [允許服務與桌面互動] 核取方塊，然後按一下 [套用]。

  6. 在 [服務狀態] 下，按一下 [啟動]，再按一下 [確定]。

  7. 關閉 [服務] 嵌入式管理單元。

若需有關正確 Exchange 服務組態的詳細資訊，請參閱微軟知識庫文件 - 239762＜在 LocalSystem 下執行的 Exchange 服務＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)。


System Attendant 服務未以 LocalSystem 執行
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-01-09

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Microsoft Exchange System Attendant (MSExchangeSA) 服務的 StartName 屬性值。Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定目錄中 Exchange Server 物件的 serialNumber 屬性值。Exchange Server 物件的 serialNumber 屬性可識別在以物件代表的電腦上所執行的 Exchange Server 版本。如果 Exchange Server Analyzer 發現 Exchange System Attendant 服務在執行 Exchange 2000 Server、Exchange Server 2003 或 Exchange Server 2007 的 Exchange 伺服器上，於 LocalSystem (SYSTEM) 帳戶之外的任何帳戶下執行，就會顯示錯誤。

此錯誤指出 System Attendant 服務並未以支援的組態執行。若您以任何其他帳戶執行 System Attendant 服務，則會造成權限與存取錯誤。

若要解決此錯誤，您必須將 Exchange System Attendant 服務設成以 LocalSystem (SYSTEM) 帳戶啟動。

附註：
此錯誤不會在 Exchange Server 5.5 版中發生。只有 Exchange 2000 Server、Exchange Server 2003 及 Exchange Server 2007 要求在 LocalSystem 帳戶之下執行 Exchange System Attendant 服務。
設定 Exchange System Attendant 服務帳戶

  1. 開啟 [服務] Microsoft Management Console (MMC) 嵌入式管理單元。

  2. 尋找並停止 Microsoft Exchange System Attendant 服務。請注意，停止 System Attendant 服務，會一併停止仰賴 System Attendant 服務的所有服務。其中包括 Microsoft Exchange Information Store 服務。

  3. 連按兩下 Microsoft Exchange System Attendant 服務。

  4. 在 [Microsoft Exchange System Attendant 內容] 頁面的 [登入] 索引標籤上，選取 [登入身分] 下的 [本機系統帳戶]，再按一下 [套用]。

  5. 在 [服務狀態] 下，按一下 [啟動]，再按一下 [確定]。

  6. 關閉 [服務] 嵌入式管理單元。

若需在 LocalSystem 帳戶之下執行 Exchange 服務的詳細資訊，請參閱微軟知識庫文件 - 239762＜Exchange Services Run Under LocalSystem＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)。


TcpTimedWaitDelay 機碼遺失或不是預設值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-03-13

Microsoft Exchange Analyzer 工具會查詢 Active Directory 目錄服務，以判定物件類別為 msExchExchangeServer 之所有物件的 serialNumber 屬性值。如果字串值包含 "Version 5.5"，表示電腦正在執行 Exchange Server 5.5。如果字串值包含 "Version 6.0"，表示電腦正在執行 Exchange 2000 Server。如果字串值包含 "Version 6.5"，表示電腦正在執行 Exchange Server 2003。如果字串值包含 "Version 8.0"，則表示電腦正在執行 Exchange Server 2007。

然後 Exchange Analyzer 工具就會針對所找到的每部 Exchange Server 2007 伺服器讀取下列登錄分支，以判定 TcpTimedWaitDelay 機碼值是否設為預設值 60。

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

TcpTimedWaitDelay 機碼可判定 TCP 要經過多久才會釋放已關閉的連線並重複使用其資源。關閉與釋放之間的這個間隔稱為 TIME_WAIT 狀態或 2MSL 狀態。在這段期間內，可以重新開啟用戶端連線及伺服器連線，這樣會比建立新連線所耗費的成本少許多。

減少此項目的值可讓 TCP 更快釋放已關閉的連線，為新連線提供更多資源。不過，如果此值過低，TCP 就可能會在完成連線之前釋放連線資源，這就需要伺服器使用額外的資源來重新建立連線。

如果 Exchange Analyzer 判定 TcpTimedWaitDelay 機碼值遺失或不等於預設值 60，Exchange Analyzer 就會顯示警告。

為達到最佳效能，建議您將 Exchange Server 2007 伺服器上的 TcpTimedWaitDelay 機碼設為預設值 60。

重要事項：
這篇主題包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
將 TcpTimedWaitDelay 登錄機碼設為其預設值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\Tcpip\Parameters

  3. 連按兩下 TcpTimedWaitDelay，並將 [數值資料] 欄位設為 60 (十進位)。

  4. 關閉登錄編輯程式並重新啟動電腦。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱 Microsoft 知識庫文章 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

這個問題與 MaxUserPort 機碼遺失或不是預設值 Analyzer 問題有關。

若需 MaxUserPort 及 TcpTimedWaitDelay 登錄機碼之效果的相關資訊，請參閱 Windows 2000 Resource Kit 中的＜傳輸控制通訊協定＞主題 (英文) (http://go.microsoft.com/fwlink/?LinkId=85654)。


TEMP/TMP 變數會指向無效或不適當的資料夾
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

在非叢集式 Exchange Server 電腦上，Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 TEMP 及 TMP 環境變數的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

HKLM\System\CurrentControlSet\Control\Session Manager\Environment\TMP

在不同作業期間 (例如郵件轉換及信箱移動作業)，Microsoft Exchange Information Store 服務會使用 TEMP 及 TMP 資料夾作為暫時儲存區。在非叢集的 Exchange 伺服器上，Microsoft Exchange Information Store 服務會使用 SYSTEM (例如，Local System)，而 SYSTEM 會對 TEMP 及 TMP 使用預設環境變數設定 %Systemroot%\Temp。如果上述任一個或兩個 Exchange Server 的 TEMP 或 TMP 環境變數的開頭都是 %SYSTEMROOT，則會顯示一則警告。

TEMP 及 TMP 環境變數是用來指定需要臨時工作區的應用程式，應該使用檔案系統中的哪些資料夾 (哪個路徑)。TEMP 一般是供應用程式 (如 Microsoft Exchange) 使用，而 TMP 一般是供程式開發工具 (如 Microsoft Visual C++®) 使用。每一個變數的路徑通常相對於應用程式或工具的安全性範圍。

當 Exchange Server Analyzer 針對 Microsoft Windows Server™ 2003 叢集中的 Exchange 虛擬伺服器來執行時，它不會讀取 HKLM 登錄樹狀目錄。相反的，它會讀取下列登錄項目：

HKEY_USERS\<Cluster service account SID>\Environment\TEMP

HKEY_USERS\<Cluster service account SID>\Environment\TMP

在 Windows Server 2003 叢集中執行的 Exchange 虛擬伺服器會針對叢集服務帳戶使用環境變數設定，而此帳戶是在特定使用者安全性原則的內容下執行。對於使用者帳戶來說，TEMP 及 TMP 的預設環境變數是設定為 %Userprofile%\temp。如果 Exchange 虛擬伺服器的 TEMP 或 TMP 環境變數之一或兩者的開頭都是 %SYSTEMROOT，就會顯示警告。

為達到最佳效能，建議您不要使用含有 Exchange 所使用的 TEMP 及 TMP 資料夾的作業系統的磁碟。此外，您應該確定這些環境變數是設定為快速磁碟或磁碟子系統上的路徑，例如 RAID 0+1 Spindle Set。也建議您不要使用含有 Exchange 或 Exchange 虛擬伺服器使用的 TEMP 及 TMP 資料夾之作業系統的磁碟。

若要更正此警告

  1. 使用具有系統管理權限的帳戶登入 Exchange 伺服器電腦。

  2. 在 [我的電腦] 上按一下滑鼠右鍵，然後選取 [內容]。

  3. 選取 [進階] 標籤。

  4. 按一下 [環境變數] 按鈕。

  5. 在 [系統變數] 區域中，選取 TEMP 並按一下 [編輯] 按鈕。

  6. 在 [變數值] 欄位中，輸入 TEMP 環境變數的新路徑，然後按一下 [確定]。

  7. 在 [系統變數] 區域中，選取 TMP 並按一下 [編輯] 按鈕。

  8. 在 [變數值] 欄位中，輸入 TMP 環境變數的新路徑，然後按一下 [確定]。

  9. 按一下 [確定] 以關閉 [環境變數] 對話方塊，然後再按一次 [確定] 關閉 [系統內容] 對話方塊。

  10. 重新啟動節點，以套用變更。

若需在叢集式 Exchange 伺服器上變更 TEMP/TMP 環境變數的詳細資訊，請參閱 叢集 TEMP/TMP 路徑與系統磁碟分割位於相同的磁碟機上。


此伺服器有 1 GB 以上的實體記憶體，且 HeapDeCommitFreeBlockThreshold 尚未設為 262144
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-08-14

錯誤訊息

簡介

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已根據系統中的實體記憶體數量來調整 Exchange，以達到最佳化設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\HeapDeCommitFreeBlockThreshold

如果 Exchange Server Analyzer 在安裝 1 GB 以上的實體記憶體的 Exchange Server 電腦上發現尚未設定 HeapDeCommitFreeBlockThreshold 的值，則會顯示警告。

當在給定的位址上釋出記憶體時，作業系統堆集管理程式會檢查此位址附近有多少可用的連續位元組。完成檢查之後，堆集管理程式可以執行下列兩項動作之一：

  • 保持確認連續的記憶體區塊。

  • 取消確認連續的記憶體區塊，並將它標示為僅保留。

HeapDeCommitFreeBlockThreshold 登錄機碼指定連續的位元組數目，超過此數目就取消確認記憶體。依預設，堆集管理程式不一定會合併所有可用的區塊或執行新的配置；因此，區塊可能會被取消確認，然後在虛擬位址空間中變成無效的空洞。這會造成虛擬記憶體分散、效能不佳，最後導致系統不穩定。

在安裝 1 GB 以上的實體記憶體的系統上，可以控制取消確認的記憶體區塊大小來達到最佳化效能。HeapDeCommitFreeBlockThreshold 登錄機碼可以控制如何處理釋出的記憶體。將此值新增到登錄時，您必須以十六進位值 0x00040000 (十進位值是 262144) 來設定它。

Microsoft 不支援 HeapDeCommitFreeBlockThreshold 登錄機碼十六進位值 0x00040000 (十進位值是 262144) 以外的任何其他值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Control\Session Manager

  3. 建立名稱為 HeapDeCommitFreeBlockThreshold 的 DWORD 值。

  4. 連按兩下 HeapDeCommitFreeBlockThreshold 值，然後輸入十六進位值 0x00040000 (十進位值是 262144)。

  5. 關閉登錄編輯程式，然後重新啟動 Exchange Server 電腦，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 HeapDeCommitFreeBlockThreshold 登錄機碼的詳細資訊，請參閱下列知識庫文件：

  • 315407＜XADM："HeapDeCommitFreeBlockThreshold" 登錄機碼＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=315407)

  • 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 325044＜HOW TO: 疑難排解 Exchange 2003 及 Exchange 2000 的虛擬記憶體分散＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)


此伺服器是執行 Windows Server 2003 且 SystemPages 值不等於 0
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來判定 SystemPages 值的設定：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

Exchange Server Analyzer 也會查詢Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 OSProductSuite 機碼值。此機碼的值對應到 Microsoft Windows 作業系統的特定版本。

如果 Exchange Server Analyzer 發現在執行 Microsoft Windows Server™ 2003 (不是 Microsoft Windows Small Business Server 2003 安裝的一部份) 的 Exchange Server 電腦上，SystemPages 的值未設定為 0，就會顯示警告。

當您在安裝 1 GB 或更多 RAM 的 Microsoft Windows Server 2003 上執行 Exchange Server 2003 Service Pack 1 (SP1) 時，建議您將 SystemPages 登錄機碼設為 0。這項建議與 Microsoft Windows 2000 Server 的建議不同，後者建議將 SystemPages 設為介於 24000 與 31000 之間的值。

在不屬於 Microsoft Windows Small Business Server 2003 安裝的 Windows Server 2003 電腦上，請絕對不要將 SystemPages 登錄值設為 0 以外的值。變更此值會造成系統無法計算系統的最佳值，當系統變更時也無法調整值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
注意：
在執行 Windows Server 2003 的電腦上設定 SystemPages 登錄值，會使分頁集區的大小上限降低。這會導致分頁集區耗盡及伺服器不穩定。

若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. 在右窗格中，連按兩下 SystemPages。

  4. 在 [數值資料] 欄位中，鍵入 0，然後按一下 [確定]。

  5. 結束登錄編輯程式，然後重新啟動電腦，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關最佳化 Exchange Server 記憶體的詳細資訊，請參閱下列知識庫文件：

  • 325044＜HOW TO: 疑難排解 Exchange 2003 及 Exchange 2000 的虛擬記憶體分散＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)

  • 311901＜4GT 調整對系統分頁表項目的效果＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


此 Exchange 伺服器在 Boot.ini 檔案中有設定 /PAE 啟動參數
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_ComputerSystem Windows® Management Instrumentation (WMI) 類別，以判定 SystemStartupOptions 內容中設定了哪些選項。Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定信箱儲存區物件 (msExchPrivateMDB) 之 homeMDBBL 屬性的計數。結果計數是在 Exchange Server 電腦中找到的信箱數目。

如果 Exchange Server Analyzer 發現 /PAE 啟動參數已在信箱數目少於 500 之 Exchange 伺服器上的 Boot.ini 檔案中設定，並在 Windows 2000 Server 上執行，就會顯示一則警告。

實體位址擴充 (PAE) 會啟用電腦，以存取 4 GB 以上的實體記憶體 (RAM)。Exchange Server 不支援 PAE。PAE 可讓 Windows 存取 4 GB 以上的實體記憶體。Exchange Server 無法使用超過 4 GB 的實體記憶體，所以在專門執行 Exchange Server 的電腦上安裝超過 4 GB RAM 並無益處。Boot.ini 檔案中有 /PAE 啟動參數時，便會啟用 PAE。

若要僅針對 Windows 2000 更正此警告，建議您從 Boot.ini 檔案移除 /PAE 參數。

若要更正此警告

  1. 在 [Windows 檔案總管] 中，瀏覽至系統磁碟分割。這是保留硬體專用檔案 (如 Boot.ini 及 NTLDR) 的磁碟分割。

  2. 如果看不見 Boot.ini 檔案，可能是因為 [資料夾選項] 設定為 [隱藏保護的作業系統檔案]。如果是這種情形，在 [檔案總管] 視窗中，依序按一下 [工具]、[資料夾選項]，再按 [檢視]。按一下 [顯示隱藏的檔案及資料夾]。清除 [隱藏保護的作業系統檔案 (建議使用)] 核取方塊。當出現提示時，按一下 [是]。

  3. 如果在 [Windows 檔案總管] 中看見 Boot.ini 檔案，請以滑鼠右鍵按一下該檔案，再按 [開啟檔案] 及 [記事本] 來開啟該檔案。

  4. 在 [Operating Systems] 區段中，移除 /PAE 參數。

  5. 儲存後關閉檔案，並重新啟動 Exchange Server 電腦，讓變更生效。

若需有關 Boot.ini 中 /PAE 參數的詳細資訊，請參閱下列微軟知識庫文件：

  • 268363: ＜Intel Physical Addressing Extensions (PAE) in Windows 2000＞

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882: ＜Exchange Memory Use and the /3GB Switch＞

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882)


此 Exchange 伺服器目前在已啟用實體位址擴充的情況下執行
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-05-08

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定下列機碼的值：

  • PAEEnabled 此機碼的值表示是否已啟用實體位址擴充 (PAE)。True 值表示已啟用 PAE，False 值表示未啟用 PAE。

  • Version 此機碼的值表示電腦上執行的 Microsoft Windows 作業系統版本。值為 5.0.2195 表示正在執行 Microsoft Windows 2000 Server 作業系統，值為 5.2.3790 則表示正在執行 Microsoft Windows Server™ 2003 作業系統。

  • ServicePackMajorVersion 此機碼的值表示已安裝之 Windows Service Pack 的主要版本號碼。

Exchange Server Analyzer 也會查詢 CIM_Datafile WMI 類別，找出系統上執行的 ntoskrnl.exe 次要版本，以判定電腦上是否已安裝安全性更新 MS04-032。如果 ntoskrnl.exe 的次要版本為 174 或更低，則表示未安裝 MS04-032。如果 ntoskrnl.exe 的次要版本高於 174，則表示已安裝 MS04-032。

如果 Exchange Server Analyzer 發現執行 Exchange Server 的 Windows Server 2003 上未安裝安全性更新 MS04-032，但其 PAEEnabled 值設為 True，就會顯示錯誤。這個錯誤指出電腦會受一個已知的問題所影響，這個問題會導致 Microsoft Exchange Information Store 服務 (Store.exe) 損毀。

Exchange Server 並不使用 PAE。PAE 可讓 Windows 存取 4 GB 以上的實體記憶體。Exchange Server 無法使用超過 4 GB 的實體記憶體，所以在專門執行 Exchange Server 的電腦上安裝超過 4 GB RAM 並無益處。若啟動時，Boot.ini 檔案中存在 /PAE 啟動參數，或 Windows Server 2003 作業系統偵測到熱新增記憶體裝置，就會啟用 PAE。只有當伺服器使用熱新增記憶體裝置時，Windows Server 2003 Enterprise Edition 及 Windows Server 2003 Datacenter Edition 才會自動啟用 PAE。

若要安裝 MS04-032 更新以更正此錯誤

  1. 若要取得 MS04-032 更新，請參閱微軟知識庫文件 - 840987＜MS04-032：Microsoft Windows 的安全性更新＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=840987)。

  2. 完整備份系統。

  3. 套用更新，然後重新啟動電腦，讓更新生效。

若需有關 PAE 的詳細資訊，請參閱下列知識庫文件：

  • 268363: ＜Intel Physical Addressing Extensions (PAE) in Windows 2000＞

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882: ＜Exchange Memory Use and the /3GB Switch＞

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882)

若需有關 Boot.ini 中之 /NOPAE 參數的詳細資訊，請參閱 MSDN 文件＜/nopae＞(英文) (http://go.microsoft.com/fwlink/?LinkId=51490)。


這個正在執行的 Exchange 伺服器已啟用實體位址擴充並已設定 /3GB 啟動參數
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 PAEEnabled 機碼值。這個機碼的值指示是否已啟用實體位址擴充 (PAE)。True 值表示已啟用 PAE，False 值表示未啟用 PAE。Exchange Server Analyzer 也會查詢 Win32_OperatingSystem WMI 類別，以判定 MaxProcessMemorySize 機碼值。

如果 Exchange Server Analyzer 發現 PAEEnabled 值等於 True 且 MaxProcessMemorySize 值大於 2097024，就會顯示一則警告。此警告指出這些值並非預設值。Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要採取任何動作。

若需 PAE 的相關資訊，請參閱下列微軟知識庫文件：

  • 268363: Windows 2000 中的 Intel 實體位址擴充 (PAE)＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882: ＜Exchange 記憶體使用及 /3GB 參數＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882)


此 Exchange 伺服器與 /PAE 以及 /3GB 啟動參數搭配執行
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定已在 SystemStartupOptions 機碼中設定哪些選項。Exchange Server Analyzer 也會查詢 Win32_OperatingSystem WMI 類別，以判定 MaxProcessMemorySize 機碼值。

如果 Exchange Server Analyzer 發現 SystemStartupOptions 機碼值包含 /PAE，而 Win32_OperatingSystem 值表示 Microsoft Windows 2000 Server，且 MaxProcessMemorySize 的值大於 2097024，就會顯示錯誤。

此錯誤表示已在 Boot.ini 檔案中同時設定 /PAE 及 /3GB 啟動參數。實體位址擴充 (PAE) 可讓電腦存取超過 4 GB 的實體記憶體 (RAM)。Exchange Server 不支援 PAE。Exchange Server 無法使用超過 4 GB 的實體記憶體，所以在專門執行 Exchange Server 的電腦上安裝超過 4 GB RAM 並無益處。若開機時的 Boot.ini 檔案中有 /PAE 啟動參數，便會啟用 PAE。

若要只更正 Windows 2000 Server 的這個錯誤，建議您從 Boot.ini 檔案中移除 /PAE 參數。

若要更正此錯誤

  1. 在 [Windows 檔案總管] 中，瀏覽至「系統磁碟分割」。這是保留硬體專用檔案 (如 Boot.ini 及 NTLDR) 的磁碟分割。

  2. 如果看不見 Boot.ini 檔案，可能是因為 [資料夾選項] 設定為 [隱藏保護的作業系統檔案]。如果是這種情形，在 [Windows 檔案總管] 視窗中，依序按一下 [工具]、[資料夾選項]，再按 [檢視]。按一下 [顯示隱藏的檔案及資料夾]。清除 [隱藏保護的作業系統檔案 (建議使用)] 核取方塊。當出現提示時，按一下 [是]。

  3. 如果在 [Windows 檔案總管] 中看見 Boot.ini 檔案，請在該檔案上按一下滑鼠右鍵，再依序按一下 [開啟檔案] 及 [記事本] 來開啟該檔案。

  4. 在 [Operating Systems] 區段中，移除 /PAE 參數。

  5. 儲存後關閉檔案，然後重新啟動 Exchange Server 電腦，讓變更生效。

如需有關 Boot.ini 中 /PAE 參數的詳細資訊，請參閱下列微軟知識庫文件：

  • 268363＜Windows 2000 中的 Intel 實體位址擴充 (PAE)＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882＜Exchange 記憶體使用及 /3GB 參數＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882)


此前端伺服器是使用收件者更新服務進行設定
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定目錄中每個 Recipient Update Service 物件的 msExchAddressListServiceLink 屬性值。msExchAddressListServiceLink 屬性是從通訊清單服務到執行收件者更新服務 (RUS) 之 Exchange Server 電腦的連結。若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • Exchange Server 設定為前端伺服器。

  • Exchange Server 電腦在執行收件者更新服務。

收件者更新服務是 Exchange System Attendant 服務中的元件。收件者更新服務會在 Active Directory 中建立並維護 Exchange 特定的屬性值。如果您為使用者建立一個信箱，則收件者更新服務會負責自動產生其簡易郵件傳送通訊協定 (SMTP) 地址，以及您在收件者原則中定義的任何其他 Proxy 位址。

將設為使用收件者更新服務的 Exchange Server 同時設定為前端伺服器時，收件者更新服務不會處理新建立的使用者物件。其結果為使用者物件無法接收電子郵件地址，且收件者不會顯示在通訊清單中。而且，也不會處理對離線通訊錄的更新。

如果您收到此訊息，則收件者更新服務是在設定為前端伺服器的 Exchange Server 上執行。

若要更正此錯誤

  1. 開啟 [Exchange 系統管理員]。

  2. 在 [收件者] 之下，按一下 [收件者更新服務]。在右窗格中，以滑鼠右鍵按一下適當的 [收件者更新服務] 執行個體，再按一下 [內容]。

  3. 在 [一般] 索引標籤中，於 [Exchange Server] 之下，按一下 [瀏覽]，然後指定要執行此 RUS 執行個體的新伺服器。

  4. 按 [確定] 兩次，使變更生效。

若需有關收件者更新服務的詳細資訊，請參閱下列主題及微軟知識庫文件：

  • 328738＜收件者更新服務如何套用收件者原則＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)。

  • 253828＜收件者更新服務如何擴展通訊清單＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)。

  • 246127＜如何檢查 Exchange 收件者更新服務的進度＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)。

  • 253770＜XADM：收件者更新服務執行的工作＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)。


登錄與 Active Directory 間的 Exchange 伺服器名稱有所差異
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-12-03

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定儲存在 Active Directory 中的值，來取得 Exchange 伺服器名稱 (CN=<ExchangeServerName>)。擷取此名稱後，Exchange Server Analyzer 會計算名稱中的字元數。

Exchange Server Analyzer 也會讀取下列登錄項目，以判定存放在 Exchange Server 電腦登錄中的值，以取得 Exchange 伺服器的主機名稱：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

此外，Exchange Server Analyzer 也會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定叢集服務 ClusSvc 的 Started 機碼值。

如果 Exchange Server Analyzer 判定下列所有條件都為真，則會顯示錯誤：

  • CN=<ExchangeServerName> 的值與 Hostname 的值不相符。

  • Exchange 伺服器名稱的長度是 15 個字元或以下。

  • Exchange 伺服器不是在 Windows 叢集中執行。

此錯誤的最常見原因是 Exchange 伺服器的名稱已變更。這樣變更名稱會變更電腦登錄中的名稱，且會變更 Active Directory 中的電腦帳戶名稱，但不會變更許多對 Exchange 伺服器名稱的參照 (這些參照可在 Active Directory 中的 Exchange 屬性及物件中找到)。

附註：
部份協力廠商軟體也會變更電腦名稱，以提供叢集處理功能。如果使用的是此類軟體，則可能必須略過此問題。

不支援將 Exchange Server 電腦重新命名，且已經知道會造成問題 (如變更電腦名稱後，無法啟動 Microsoft Exchange System Attendant 服務)。如果重新命名的 Exchange Server 電腦似乎在所有方面都無法正確運作，則您可使用此文章中所提供的手動移除處理程序，從電腦中手動移除 Exchange Server。如果重新命名的 Exchange Server 電腦似乎在所有方面都可正確運作，則因為這是不支援的組態且未來可能會造成問題，所以應使用下面的重建程序來重建 Exchange 伺服器。

若要執行 Exchange Server 的手動移除以更正此錯誤

  1. 停止所有 Exchange Server 服務並完整備份電腦。

  2. 請根據您正執行的 Exchange Server 版本，參閱下列微軟知識庫文件：

    • 如果您執行的是 Exchange Server 2007，請遵循 Exchange Server 2007 文件＜如何從伺服器中完全移除 Exchange 2007＞(英文) 中概述的程序 (http://go.microsoft.com/fwlink/?LinkId=79246)。

    • 如果執行的是 Exchange Server 2003，請遵循知識庫文件 - 833396＜如何從電腦中移除 Exchange Server 2003＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833396) 中提供的程序。

    • 如果執行的是 Exchange 2000 Server，請遵循知識庫文件 - 260378＜如何手動移除 Exchange 2000 安裝＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=260378) 中提供的程序。

  3. 如果您執行的是 Exchange 2000 Server 或 Exchange Server 2003，且這是您組織中唯一的 Exchange 伺服器，請遵循知識庫文章 273478 ＜如何從 Active Directory 中完全移除 Exchange 2000 或 Exchange 2003＞中概述的程序 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=273478)。

重建 Exchange Server 電腦以更正此錯誤

  1. 將信箱、公用資料夾、連接器及角色移動到組織中的另一個 Exchange Server 電腦中。

  2. 在電腦上解除安裝 Exchange Server。

  3. 若要清理執行 Exchange Server 2003 或 Exchange Server 2000 之電腦上的登錄，請遵循下列 Microsoft 知識庫文章中所概述之程序的登錄清除章節：

    • 833396＜如何從電腦中移除 Exchange Server 2003＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833396)

    • 260378＜如何手動移除 Exchange 2000 安裝＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260378)

    或是，您可重建作業系統。

  4. 在電腦上安裝 Exchange Server。

  5. 將信箱、公用資料夾、連接器及角色移動到剛剛建置的 Exchange Server 電腦中。

若需如何在叢集中部署 Exchange Server 2003 的詳細資訊，請參閱微軟知識庫文件 - 810986＜Microsoft 對與協力廠商叢集服務一起執行之 Exchange Server 安裝的支援原則＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810986)。


與 Active Directory 中的 Exchange 伺服器名稱不一致
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-12-03

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定伺服器 (類別 msExchExchangeServer 的物件) 的 Name 屬性及 cn 屬性是否相符。如果 Exchange Server Analyzer 發現這些屬性不同，就會顯示一則錯誤。

Exchange 使用伺服器物件的 cn 值，在內部識別伺服器。它使用 Name 值來識別 [Microsoft Exchange 系統管理員] 使用者介面中的伺服器。

如果系統管理員使用如 Active Directory Service Interfaces (ADSI) 編輯器或 LDP (ldp.exe) 工具來變更 Name 值，就會發生此錯誤。雖然此動作會變更使用者介面中的伺服器名稱，但它所造成的差異會促成儲存區及系統服務員事件的產生。您必須使用如 ADSI 編輯器嵌入式管理單元、LDP 工具，或任何其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端之類的工具，更正該值。

注意：
使用 ADSI 編輯器、LDP 工具或其他 LDAP 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或 Exchange Server 2007，或兩者。修改 Active Directory 物件屬性的風險，必須由您自行承擔。

若要更正此錯誤

  1. 使用 [ADSI 編輯器] 或類似工具，在 Active Directory 中找出伺服器物件。

    CN 及 Name 屬性位於下列位置：

    複製程式碼
    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Servers,CN=Server

  2. 請在 Name 屬性中，鍵入符合 CN 屬性值的新字串值。

若需有關使用 LDP 工具的詳細資訊，請參閱微軟知識庫文件 - 260745＜XADM:使用 LDP 公用程式以修改 Active Directory 物件屬性＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

若需有關使用 ADSI 編輯器的詳細資訊，請參閱主題＜Adsiedit.msc：ADSI 編輯器＞(位在 Windows Server 說明中)。


在 Active Directory 伺服器與此 Exchange Server 之間有一個以上的網路
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 root\cimv2 命名空間中的 WIN32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 RouteRecord 機碼值。RouteRecord 機碼包含一個介於 Exchange Server 與網域控制站之間的中繼躍點記錄 (例如，路由器的數目)。Exchange Server Analyzer 會計算列在 RouteRecord 機碼中的路由器數目。如果 Exchange Server Analyzer 發現已列出一個以上的路由器，則會顯示錯誤訊息。

最佳的 Active Directory® 目錄服務，就是其設計確保 Exchange Server 電腦可與其子網路中的網域控制站或通用類別目錄伺服器進行通訊的目錄服務。此錯誤表示 Exchange Server 電腦正在與一個躍點外的網路上之網域控制站進行通訊。

若要更正此錯誤

  1. 檢查您的網路拓樸，並且重新評估 Active Directory 伺服器的位置。

  2. 監視 Exchange Server 及網域控制站上的事件日誌，以查看是否已記錄有指出潛在問題的任何網路相關事件。

  3. 調查 Active Directory 站台設計。如果您的網路未根據此規格進行分割，可考慮將網路分割為更多的 Active Directory 站台。

若需有關 Win32_PingStatus WMI 類別的詳細資料，請參閱 MSDN 文件＜Win32_PingStatus＞(英文) (http://go.microsoft.com/fwlink/?linkid=33549)。

若需有關 Active Directory 站台設計的詳細資訊，請參閱「設計站台拓撲」(英文) (http://go.microsoft.com/fwlink/?linkid=33551)。


太多躍點
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-07-06

Microsoft® Exchange Server Analyzer 工具會從 Exchange Server 傳送測試郵件至簡易郵件傳送通訊協定 (SMTP) 網域的郵件管理員帳戶或使用者定義的帳戶，然後掃描伺服器的郵件追蹤記錄檔，以判定傳遞測試郵件時是否有發生問題。

進行此掃描時，Exchange Server Analyzer 會在郵件所經歷之每部伺服器的 root\MicrosoftExchangeV2 命名空間之下，查詢 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 類別的 MessageID 內容。

郵件在到達其最終目的地之前，會經過許多不同的 SMTP 伺服器。此路由上的每部伺服器即為一個「躍點」。

如果特定 MessageID 的 Exchange_MessageTrackingEntry 執行個體數目增加到 30 個，Exchange Server Analyzer 就會顯示錯誤。

此錯誤表示測試郵件可能一直在迴圈中周遊。因此，Exchange Server Analyzer 已停止查詢其他 Exchange_MessageTrackingEntry 執行個體，這是預防無止境迴圈的安全措施。

Exchange Server Analyzer 輸出之「郵件追蹤記錄檔」區段的其他分析，可幫助您判定是否有迴圈的狀況發生。


不支援的虛擬機器組態 - 偵測到叢集 Exchange Server
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Model 機碼值是否設定為 "Virtual Machine"。

Exchange Server Analyzer 也會查詢 Win32_Service WMI 類別，以判定 Windows 叢集服務 ClusSvc 的 Started 機碼值。Started 機碼值為 True 表示已啟動叢集服務，值為 False 則表示未啟動叢集服務。

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • Model 機碼的值設定為 "Virtual Machine"。

  • 叢集服務的 Started 機碼值設定為 True。

此錯誤表示 Exchange 伺服器為在虛擬機器環境中執行的叢集 Exchange 伺服器。不支援此組態。

若要更正此錯誤

  1. 建置實體叢集並將信箱從虛擬環境中執行的叢集 Exchange 伺服器移至實體叢集。

  2. 如果您無法建置實體叢集，可以按下述方式更正此錯誤：

    1. 將信箱從虛擬環境中執行的 Exchange Server 移至非虛擬的獨立 Exchange Server 電腦。

    2. 視需要，將任何公用資料夾重新歸屬，並且轉移叢集 Exchange 伺服器執行的角色。

    3. 從虛擬機器解除安裝 Exchange Server，以從 Exchange Server 基礎結構及 Active Directory 中解除委任及移除它。

若需有關在虛擬環境中執行 Exchange Server 2003 之 Microsoft 支援原則的詳細資訊，請參閱微軟知識庫文件 - 320220＜在硬體虛擬化軟體中執行之 Exchange Server 2003 的支援原則＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)。


不支援的虛擬機器組態 - 未偵測到 Exchange Server 2003 Service Pack 2 或更新版本
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Model 機碼值是否設定為 "Virtual Machine"。

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定物件類別為 msExchExchangeServer 之所有物件的 serialNumber 屬性值。如果字串值包含 "Version 5.5"，表示電腦正在執行 Exchange Server 5.5。如果字串值包含 "Version 6.0"，表示電腦正在執行 Exchange 2000 Server。如果字串值包含 "Version 6.5"，表示電腦正在執行 Exchange Server 2003。如果字串包含 "Version 6.5" 及 "Service Pack 2"，則表示電腦正在執行 Exchange Server 2003 (含 SP2)。

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • Model 機碼設為 "Virtual Machine"。

  • 電腦並非執行 Exchange Server 2003 (含 SP2) 或更新版本。

此錯誤指出 Exchange 伺服器為虛擬機器，但未安裝 Exchange Server 2003 SP2 或更新版本。不支援此組態。

若要更正此錯誤

  1. 安裝 Exchange Server 2003 Service Pack 2 或更新版本。

  2. 檢閱微軟知識庫文件 - 320220＜在硬體虛擬化軟體中執行之 Exchange Server 2003 的支援原則＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)。

  3. 如果您無法套用 Service Pack 2 或更新版本，可以按下述方式更正此錯誤：

    1. 將在 Virtual Server 2005 上執行的 Exchange Server 之信箱，移到非虛擬的 Exchange Server 電腦上。

    2. 視需要，將任何公用資料夾重新隸屬，並且轉移虛擬 Exchange 伺服器執行的角色。

    3. 從虛擬機器解除安裝 Exchange Server，以從 Exchange Server 基礎結構及 Active Directory 中解除委任及移除它。


不支援的虛擬機器組態 - 未偵測到 Virtual Machine Additions
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Model 機碼值是否設定為 "Virtual Machine"。

Exchange Server Analyzer 也會讀取下列登錄項目，以判定是否已安裝 Virtual Machine Additions：

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

若此登錄路徑存在，表示已安裝 Virtual Machine Additions。若此登錄路徑不存在，表示未安裝 Virtual Machine Additions。

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • Model 機碼的值設定為 "Virtual Machine"。

  • 此登錄路徑不存在。

此錯誤表示 Exchange 伺服器為虛擬機器，但是卻未安裝 Virtual Machine Additions。不支援此組態。

若要安裝 Virtual Machine Additions

  1. 備份在虛擬環境中執行的 Exchange Server。

  2. 使用 Virtual Server 2005 管理主控台或網站來安裝 Virtual Machine Additions。

若需如何在虛擬環境中執行 Exchange Server 2003 的詳細資訊，請參閱知識庫文件 - 320220＜在硬體虛擬化軟體中執行之 Exchange Server 2003 的支援原則＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)。


有可用的日光節約時間更新
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-07-30

Microsoft Exchange Analyzer 工具會查詢 Active Directory 目錄服務，以判定每一個 Exchange Server 物件的 versionNumber 屬性值。versionNumber 屬性代表電腦中執行的 Exchange Server 版本。

Exchange Analyzer 也會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Store.exe 處理程序的 Version 機碼值。

  • Version 機碼值為 7638 表示是 Exchange Server 2003 Service Pack 2

  • Version 機碼值為 7226 表示是 Exchange Server 2003 Service Pack 1

  • Version 機碼值為 6944 表示是原始版本的 Exchange Server 2003

  • 上述版本之間的值，表示伺服器執行的是 Store.exe 處理程序的 Hotfix 更新版本。

如果 Exchange Analyzer 判定在執行 Exchange Server 2003 SP2 的伺服器上 Store.exe 的 Version 機碼值小於 7561，或者在執行 Exchange Server 2003 SP1 的伺服器上該機碼值小於 7234，就會顯示警告。

此警告表示 Exchange Server 電腦正在執行 Exchange Server 2003 Service Pack 1 或 Exchange Server 2003 SP2，但是沒有 2007 年日光節約時間變更的更新。

若沒有此更新，CDO 型程式和 Outlook Web Access 中的行事曆項目，在日光節約時間多出的那幾星期時，將以為當時是標準時間來運作。

對 Exchange Server 2003 SP2 更正此問題

  1. 請遵循 Microsoft 知識庫文章 926666＜Exchange 2003 Service Pack 2 的 2007 年日光節約時間變更的更新＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=926666) 中的指引。
對 Exchange Server 2003 SP1 更正此問題

  1. 請遵循 Microsoft 知識庫文章 931978＜Exchange 2003 Service Pack 1 的 2007 年日光節約時間變更的更新＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=931978) 中的指引。


未安裝 Windows 2000 SP4 的更新彙總套件
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 ServicePackMajorVersion 機碼值。Exchange Server Analyzer 也會檢查下列登錄項目，以判定在目的電腦上執行的 Windows 版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

如果 Exchange Server Analyzer 判定目標系統正在執行 Windows 2000 Server 作業系統，但未執行 Windows 2000 Server Service Pack 4 的更新彙總套件，就會顯示警告。

建議的最佳作法，是為 Exchange 部署中的所有軟體安裝最新的 Service Pack 及彙總套件。

若要更正此警告

  1. 將所有執行 Windows 2000 Server 的網域控制站及通用類別目錄伺服器更新為 Service Pack 4 的更新彙總套件，並且從 Windows Update 安裝最新的 Hotfix 及更新。

  2. 將所有 Exchange Server 電腦更新為最新的彙總套件及更新彙總套件。

如需有關 Windows 2000 SP4 之更新彙總套件的詳細資訊，請參閱微軟知識庫文件 - 891861＜Windows 2000 SP4 更新彙總套件 1 和已知問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=891861)。

若需有關取得及安裝 Exchange Server Service Pack 與彙總套件的詳細資訊，請參閱 Exchange Server 網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=21573)。


已安裝 URLScan
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-04-20

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定下列檔案是否存在於 Exchange 伺服器的下列位置：

%WINDOWSPATH%\\SYSTEM32\\INETSRV\URLSCAN\URLSCAN.DLL

如果 Urlscan.dll 存在，則表示 Exchange 伺服器上已安裝 URLScan 工具。如果 Exchange Server Analyzer 發現 URLScan 工具安裝於 Exchange 伺服器上，則會顯示最佳作法建議。

URLScan 是一個網際網路伺服器應用程式發展介面 (ISAPI) 篩選器，可讓網站系統管理員限制伺服器能處理的 HTTP 要求類型。藉由封鎖指定的 HTTP 要求，URLScan 篩選器會阻止可能有害的要求到達伺服器而造成毀損。

當您在 Exchange 伺服器上執行 URLScan 時，應確保已針對 Exchange 伺服器的角色調整 Urlscan.ini。為了協助加強 Exchange 伺服器的安全性，您必須編輯 Urlscan.ini 組態檔，以移除任何無關功能。若要針對特定的 Exchange Server 2003 電腦角色自訂 Urlscan.ini 檔案，您必須在 Urlscan.ini 檔案中移除 [AllowVerbs] 區段中的動作。不過，請確定有包括建議您電腦角色使用的動詞，以獲得適當的功能。如果單一電腦上需要多個 Web 型功能，則必須合併適當的 [AllowVerbs] 區段需求。

您可以依據 Exchange Server 2003 電腦的角色，修改 Urlscan.ini 檔案，方法是使用微軟知識庫文件 - 823175＜在 Exchange 2003 環境中使用 Urlscan 公用程式時的微調及已知問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823175) 中提供的 Exchange Server 2003 Urlscan 範本相關資訊。

若需有關 URLScan 的詳細資訊，請參閱＜UrlScan 安全性工具＞(英文) (http://go.microsoft.com/fwlink/?LinkId=24490)。

若需在 Exchange Server 環境中使用 URLScan 的相關資訊，請參閱下列微軟知識庫文件：

  • 309677＜XADM:在 Exchange 2000 環境中使用 IIS 鎖定精靈時的已知問題及微調＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=309677)

  • 309508＜Exchange 環境中的 IIS 鎖定與 URLscan 設定＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=309508)

  • 325965＜URLScan 工具可能會在 Outlook Web Access 中造成問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325965)

  • 326444＜如何設定 URLScan 工具＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326444)


USERVA 設定不正確
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-09-19

Microsoft® Exchange Server Analyzer 工具會查詢三個 Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Exchange Server 電腦中的實體記憶體數量，以及已配置給在 Exchange Server 電腦上執行之使用者模式處理程序的虛擬位址空間數量。下表描述 Exchange Server Analyzer 會評估的類別及機碼。

查詢的類別 | 查詢的機碼 | 描述
Win32_OperatingSystem | MaxProcessMemorySize | 可以配置給處理程序的記憶體 KB 數上限。
Win32_ComputerSystem | TotalPhysicalMemory | 安裝於電腦上的隨機存取記憶體 (RAM) 位元組數。
Win32_Service | Started | 服務的狀態。值為 True 表示服務正在執行，值為 False 表示服務未執行。

Exchange Server Analyzer 也會讀取下列登錄項目，以判定正在 Exchange Server 電腦上執行的 Microsoft Windows 版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 值 4.0 表示 Exchange Server 電腦是在 Microsoft Windows NT® Server 4.0 上執行。值 5.0 表示 Exchange Server 電腦正在執行 Windows 2000 Server，而值 5.2 則表示 Exchange Server 電腦正在執行 Windows Server™ 2003。

最後，Exchange Server Analyzer 會查詢 Active Directory® 目錄服務，以判定信箱儲存區物件 (msExchPrivateMDB) 的 homeMDBBL 屬性之計數。結果計數是在 Exchange Server 電腦中找到的信箱數目。

如果 Exchange Server Analyzer 判定下列條件全都符合，便會顯示警告：

  • Exchange Server 電腦在 Windows Server 2003 上執行。

  • TotalPhysicalMemory 的值大於 1073741824。

  • MaxProcessMemorySize 的值等於 3145600。

  • 叢集服務 (ClusSvc) 的 Win32_Service\Started 值是 True，或 Exchange Server 電腦包含的信箱超過 20 個。

此警告指出 Exchange Server 電腦未針對虛擬記憶體使用方式做最佳化設定。特別是 Exchange Server 電腦上的 Boot.ini 檔案中沒有 /USERVA=3030 啟動參數。增加這個參數可以提供更大的延展性和更高的效能。

Windows Server 2003 支援兩個 Boot.ini 啟動參數：/3GB 及 /USERVA，讓您可以調整記憶體及記憶體位址空間的使用量與配置。無論系統中的實體記憶體量為何，Windows 都會使用虛擬位址空間 4 GB，其中 2 GB 配置給使用者模式處理程序 (例如，應用程式)，而另外 2 GB 配置給核心模式處理程序 (例如，作業系統及核心模式驅動程式)。在具有 1 GB 或更多實體記憶體的系統上，這些啟動參數可以用來配置較多的記憶體給應用程式 (3 GB)，而少配置一些記憶體給作業系統 (1 GB)。在 Exchange Server 電腦上，此額外虛擬位址空間可以協助減少資訊儲存庫處理程序虛擬位址空間中的記憶體分散數量。/3GB 參數可用來影響這項配置變更。參數是在系統的 Boot.ini 檔案中輸入，將於重新開機之後生效。此參數只能用在具有 1 GB 或更多記憶體，且執行下列任一作業系統的 Exchange Server：

  • Microsoft Windows Server 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

重要事項：
在 Windows 2000 Server 上不可以使用 /3GB 參數，因為該參數未受支援，並且會導致應用程式或作業系統當機。此外，只有在上述作業系統上安裝 1 GB 以上的實體記憶體時，才會支援 /3GB 參數。而且，/3GB 參數不能用在 Windows Server 2003 Standard Edition 上執行的 Active Directory 伺服器 (網域控制站及通用類別目錄伺服器)。

/USERVA 參數是 Windows Server 2003 的新參數。它的目的是要更完善地控制使用者模式處理程序與核心模式處理程序之間的虛擬位址空間分割。這個參數應該只用於支援這個參數的應用程式 (例如 Exchange Server 2003)，且搭配那些應用程式所支援的特定值來使用。在 Exchange Server 2003 系統上使用時，/USERVA 必須一律等於 3030 (也就是 /USERVA=3030)。此值會使額外的 40 MB 配置給作業系統，因此可讓您新增更多使用者而不會耗盡所有可用的系統資源。

若要在 Windows Server 2003 上更正這個警告

  1. 在 [我的電腦] 上按一下滑鼠右鍵，然後選取 [內容]。即會出現 [系統內容] 對話方塊。

  2. 按一下 [進階] 標籤。

  3. 在 [啟動及修復] 區域中，按一下 [設定]。即會出現 [啟動及修復] 對話方塊。

  4. 在 [系統啟動] 區域中，按一下 [編輯]。這樣會用 [記事本] 開啟 Windows Boot.ini 檔。

  5. 在 [Operating Systems] 區段中，請在起始行新增下列參數：/3GB /USERVA=3030

  6. 儲存變更並結束 [記事本]。

  7. 按 [確定] 兩次以關閉已開啟的對話方塊，然後重新啟動 Exchange Server 電腦，使變更生效。

若需使用 /3GB 和 /USERVA 啟動參數的詳細資訊，請參閱下列 Microsoft 知識庫文章：

  • 297812＜如何使用 4GT RAM 調整功能＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)。

  • 311901＜4GT 調整對系統分頁表項目的影響＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)。

  • 316739＜如何搭配 /3GB 參數使用 /userva 參數，將使用者模式空間調整成介於 2 GB 與 3 GB 之間的值＞ (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)。

  • 325044＜HOW TO: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000＞ (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)。

  • 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)。


此電腦上安裝的 Tcpip.sys 檔案版本可能需要 Hotfix
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定為 Tcpip.sys 檔案的 Version 機碼設定的值。如果 Exchange Server Analyzer 發現 Version 機碼的值對應到 Tcpip.sys 檔案的特定版本，便會顯示一則警告。

若需有關此警告的詳細資訊，請遵循微軟知識庫文件 - 898060＜安裝安全性更新 MS05-019 或 Windows Server 2003 Service Pack 1 可能造成用戶端與伺服器之間的網路連線失敗＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=898060) 中的建議。


偵測到虛擬機器組態
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Model 機碼值是否設定為 "Virtual Machine"。

Exchange Server Analyzer 也會查詢 Win32_Service WMI 類別，以判定 Windows 叢集服務 ClusSvc 的 Started 機碼值。Started 機碼的值為 True，表示已啟動叢集服務。值為 False 表示未啟動叢集服務。

Exchange Server Analyzer 會查詢 Active Directory® 目錄服務，以判定物件類別為 msExchExchangeServer 之所有物件的 serialNumber 屬性值。如果字串值包含 "Version 6.5" 與 "Service Pack 2"，則電腦正在執行 Exchange Server 2003 Service Pack 2 (SP2)。

最後，Exchange Server Analyzer 會讀取下列登錄項目，以判定是否已安裝 Virtual Machine Additions。

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

若此登錄路徑存在，表示已安裝 Virtual Machine Additions。若此登錄路徑不存在，表示未安裝 Virtual Machine Additions。

若下列條件為真，Exchange Server Analyzer 就會顯示最佳作法訊息：

  • Exchange 伺服器是以來賓身分在 Microsoft Virtual Server 2005 下執行。

  • Exchange 伺服器正在執行 Exchange Server 2003 Service Pack 2 或更新版本。

  • Exchange 伺服器未作叢集處理。

  • Virtual Server 2005 的 Virtual Machine Additions 已安裝於 Exchange 伺服器上。

以此組態執行的需求，有一部份 Exchange Server Analyzer 無法偵測。因此，建議您在 Virtual Server 2005 環境中執行 Exchange Server 2003 之前，先檢閱下列文件，以取得此組態之可支援性與效能微調的最新資訊。

微軟知識庫文件 - 320220＜Exchange Server 2003 執行於硬體虛擬化軟體的支援原則＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)。


虛擬記憶體分散
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2007-02-15

Microsoft Exchange Analyzer 工具會查詢 Win32_NTLogEvent Microsoft Windows Management Instrumentation (WMI) 類別，以判定過去 24 小時內是否曾記錄 MSExchangeIS 的「事件 9582」錯誤。

如果 Exchange Analyzer 發現已在過去 24 小時內記錄事件 9582，則 Exchange Analyzer 會顯示錯誤。

這個錯誤表示執行 Exchange 伺服器所需的虛擬記憶體已分散。

在 32 位元 Microsoft Windows 系統中，有兩種記憶體：

  • 實體記憶體 系統中實際安裝的記憶體數量

  • 虛擬記憶體位址空間 虛擬的 4 GB 記憶體空間

無論在系統中安裝多少實體記憶體，虛擬位址空間總大小永遠相同：4 GB。雖然並非所有 32 位元應用程式都是這樣，但就 Exchange Server 而言，虛擬位址空間等於虛擬記憶體。這兩個詞彙可以交替使用。

在正常操作期間，Exchange 儲存區將反覆配置、使用及解除配置虛擬記憶體。經常配置、使用及解除配置虛擬記憶體，可能會使虛擬記憶體分散。虛擬記憶體分散類似於會隨著時間發生的檔案系統分散。一段時間之後，虛擬記憶體的配置區段就不再連續，因此效能開始降低。在檔案系統中，您可執行會對檔案系統執行磁碟重組的應用程式。在大部分情況中，可以在系統連線且正在存取系統時執行檔案系統的磁碟重組。針對虛擬記憶體分散，沒有磁碟重組工具。若要更正問題，必須停止再啟動 Microsoft Exchange Information Store 服務或重新啟動系統。

若要更正此問題：

  • 在 store/inetinfo 處理程序中執行的協力廠商軟體，可能會造成虛擬記憶體分散。請確定您有協力廠商應用程式的最新驅動程式。

  • 使用「效能記錄檔及警示」工具來監控 MSExchangeIS 效能物件的 VM Total Large Free Block Bytes 計數器。使用從這個計數器收集的資料來判定接下來 36 到 72 小時中，關閉並重新啟動伺服器的最佳時間範圍。

附註：
如果是叢集伺服器，請先停止並重新啟動被動節點，然後再將叢集資源移到該節點，以確定目標虛擬記憶體位址空間是乾淨的。
  • 如果重新啟動後仍然重複發生該問題，請考慮停用協力廠商軟體。

  • 請考慮將使用者信箱移至其他伺服器，以減少伺服器負載，看看是否可以解決問題。若需詳細資訊，請參閱將使用者信箱移至其他伺服器。

詳細資訊

  • 如需 MSExchangeIS 事件 9852 的相關資訊，請參閱「事件及錯誤訊息中心：事件詳細資料」(英文) (http://go.microsoft.com/fwlink/?LinkId=83209)。

  • 若需有關 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需有關如何疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 2003 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 如需對 Microsoft Exchange Server 2003 和 Exchange 2000 Server 中的虛擬記憶體分散進行疑難排解的相關資訊，請參閱 Microsoft 知識庫文章 325044＜如何對 Exchange 2003 及 Exchange 2000 Server 中的虛擬記憶體分散進行疑難排解＞(機器翻譯) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)。

  • 如需如何最佳化虛擬記憶體使用量的相關資訊，請參閱 Microsoft 知識庫文章 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)。

  • 若需如何移動使用者信箱以減少伺服器負載的詳細資訊，請參閱＜將使用者信箱移至其他伺服器＞。


未偵測到 Virtual Server 2005 R2 或更新版本
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Microsoft Virtual Server 2005 隨附之 Virtual Server 服務所代表的處理程序 Vssrvc.exe 的 Version 機碼值。如果 Exchange Server Analyzer 發現 Vssrvc.exe 的 Version 機碼值等於 1.1.465.0，就會顯示錯誤。

此錯誤表示此 Exchange 伺服器是以來賓身分在 Microsoft Virtual Server 2005 環境中執行，但該環境不是執行 Virtual Server 2005 R2 或更新版本。不支援此組態。Exchange Server 2003 Service Pack 2 或更新版本在 Microsoft Virtual Server 2005 R2 或更新版本下執行時，才支援以來賓身分在虛擬環境中執行。

若要更正此錯誤

  1. 檢閱微軟知識庫文件 - 320220＜在硬體虛擬化軟體中執行之 Exchange Server 2003 的支援原則＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)。

  2. 安裝 Microsoft Virtual Server 2005 R2 或更新版本。若需有關 Microsoft Virtual Server 2005 R2 的資訊，請參閱 Microsoft Virtual Server 2005 R2 網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=34938)。

  3. 如果您無法安裝 Virtual Server 2005 R2 或更新版本，可以按下述方式更正此錯誤：

    1. 將信箱從 Virtual Server 2005 下執行的 Exchange Server 移至非虛擬的 Exchange Server 電腦，或移至 Virtual Server 2005 R2 下執行的虛擬 Exchange Server 電腦。

    2. 視需要，將任何公用資料夾重新歸屬，並且轉移不支援的虛擬 Exchange 伺服器執行的角色。

    3. 從不支援的虛擬機器解除安裝 Exchange Server，以從 Exchange Server 基礎結構及 Active Directory 中解除委任及移除它。


Virus Scan Queue Length 超出閾值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-02-27

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 MSExchangeIS 效能物件的 Virus Scan Queue Length 效能計數器的資料，以分析效能資料。

如果 Exchange Server Analyzer 判定在取樣時間配量期間 Virus Scan Queue Length 計數器的第 90 個百分位值大於 10，則會顯示錯誤。

Virus Scan Queue Length 效能計數器指出目前在佇列中等候病毒掃描的未處理要求數。

此錯誤指出與下列有關的效能問題：

  • 伺服器效能減少，通常是因為 CPU 瓶頸所造成。

  • 高於平常的伺服器負載。

  • 過期的病毒掃描引擎。

  • 設定不正確的病毒掃描引擎。

若要解決這個錯誤，請採取下列步驟：

  • 尋找病毒引擎的更新。

  • 考慮重新安裝病毒掃描軟體。

  • 檢查病毒掃描引擎的組態以取得正確的執行緒組態、檔案層級排除等。請參閱微軟知識庫文件 - 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&k)。

  • 使用效能監視器 (Perfmon.msc) 工具，判定導致瓶頸的原因是伺服器負載增加或伺服器太小。如果伺服器負載增加了，請識別負載的來源並降低它。如果伺服器資源不夠，請增加所需的資源，或將使用者移出伺服器。

排除處理器瓶頸

有許多方式可排除 Exchange 伺服器中的處理器瓶頸。

  • 首先，檢閱造成伺服器上的負載的應用程式或工作。判斷應用程式是否應該使用本身是或可能是處理程序問題的處理器時間。

  • 如果非 Exchange 應用程式對該伺服器不重要，請在其他伺服器上執行該應用程式。如果您可以在另一個伺服器上執行該應用程式，請同時將伺服器角色移到其他電腦上。比方說，如果 Inetinfo 處理程序使用大量 CPU 使用，請考慮增加前端伺服器，以擔負 Inetinfo 執行之通訊協定工作的責任。您也可以將公用資料夾存取移至專用的公用資料夾伺服器。最後，如果伺服器執行大量通訊群組清單展開，則可以將通訊群組清單展開移至專用的通訊群組清單展開伺服器，以降低 CPU 使用。

  • 可以的話，請加入更多或更快的處理器到伺服器上。另外，如果處理器支援的話，請啟用超執行緒 (Hyper-threading)。您可以設定系統 BIOS 來啟用超執行緒。若需詳細資訊，請參閱電腦製造商的說明文件。

  • 如果提升處理能力不是可行的選項，則必須降低處理器上的負載。若要降低對伺服器的整體影響，請確定 I/O 密集、CPU 密集或使用記憶體的工作是在正常操作期間之外的時間執行。

  • 請確定 CPU 密集的工作 (如備份及維護) 是在離峰時間執行。也請確定這些工作是以經過安排的方式執行。安排工作的意思是為每個工作設定不同的開始時間，並最好設定結束時間。安排資料庫或儲存群組的維護及備份也可減少這些資源密集工作的影響。

詳細資訊

  • 若需 Exchange Server 和病毒掃描的概觀，請參閱微軟知識庫文件 - 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)。

  • 若需有關病毒掃描和 Exchange Server 的詳細資訊，請參閱微軟知識庫文件 - 285667＜XADM：認識 Exchange 2000 Server SP1 中的病毒掃描 API 2.0＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285667)。

  • 若需處理器瓶頸的詳細資訊，請參閱＜處理器瓶頸＞。

  • 若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 若需如何移動使用者信箱以減少伺服器負載的詳細資訊，請參閱＜將使用者信箱移至其他伺服器＞。


Virus Scan Queue Length 超出警告閾值
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-04-20

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 MSExchangeIS 效能物件的 Virus Scan Queue Length 效能計數器的資料，以分析效能資料。

如果 Exchange Server Analyzer 判定在取樣時間配量期間中 Virus Scan Queue Length 計數器的第 90 個百分位值大於 5，則會顯示警告。

Virus Scan Queue Length 效能計數器指出目前在佇列中等候病毒掃描的未處理要求數。

此警告指出此伺服器可能會有效能問題。效能問題可能與下列因素有關：

  • 伺服器效能減少，通常是因為 CPU 瓶頸所造成。

  • 高於平常的伺服器負載。

  • 過期的病毒掃描引擎。

  • 設定不正確的病毒掃描引擎。

若要對付此警告，請採取下列步驟：

  • 尋找病毒引擎的更新。

  • 考慮重新安裝病毒掃描軟體。

  • 檢查病毒掃描引擎的組態以取得正確的執行緒組態、檔案層級排除等。請參閱微軟知識庫文件 - 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)。

  • 使用效能監視器 (Perfmon.msc) 工具，識別導致瓶頸發生的原因是伺服器上的負載增加或伺服器太小。如果伺服器負載增加了，請識別負載的來源並降低它。如果伺服器資源不足，請增加必要的資源，或將使用者移出伺服器。

排除處理器瓶頸

有許多方式可解決 Exchange 伺服器上的處理器瓶頸。

  • 首先，檢閱造成伺服器上的負載的應用程式或工作。判斷應用程式是否應該使用本身是或可能是處理程序問題的處理器時間。

  • 如果非 Exchange 應用程式對該伺服器不重要，請在其他伺服器上執行該應用程式。可以的話，請同時將伺服器角色移到其他電腦上。比方說，如果 Inetinfo 處理程序使用大量 CPU 使用，請考慮增加前端伺服器，以擔負 Inetinfo 執行之通訊協定工作的責任。您也可以將公用資料夾存取移至專用的公用資料夾伺服器。最後，如果伺服器執行大量通訊群組清單展開，則可以將通訊群組清單展開移至專用的通訊群組清單展開伺服器，以降低 CPU 使用。

  • 可以的話，請加入更多或更快的處理器到伺服器上。另外，如果處理器支援的話，請啟用超執行緒 (Hyper-threading)。您可以設定系統 BIOS 來啟用超執行緒。若需詳細資訊，請參閱電腦製造商的說明文件。

  • 如果提升處理能力不是可行的選項，則必須降低處理器上的負載。若要降低對伺服器的整體影響，請確定 I/O 密集、CPU 密集或消耗記憶體的工作是在正常操作期間之外的時間執行。

  • 請確定 CPU 密集的工作 (如備份及維護) 是在離峰時間執行。也請確定這些工作是以經過安排的方式執行。安排工作的意思是為每個工作設定不同的開始時間，並最好設定結束時間。安排資料庫或儲存群組的維護及備份也可減少這些資源密集工作的影響。

詳細資訊

  • 若需 Exchange Server 和病毒掃描的概觀，請參閱微軟知識庫文件 - 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)。

  • 若需有關病毒掃描和 Exchange Server 的詳細資訊，請參閱微軟知識庫文件 - 285667＜XADM：認識 Exchange 2000 Server SP1 中的病毒掃描 API 2.0＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285667)。

  • 若需處理器瓶頸的詳細資訊，請參閱＜處理器瓶頸＞。

  • 若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 若需如何移動使用者信箱以減少伺服器負載的詳細資訊，請參閱＜將使用者信箱移至其他伺服器＞。


磁碟區裝載點失敗：未安裝 Windows Server 2003 SP1
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2006-02-13

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Windows® Management Instrumentation (WMI) 類別，以驗證 Mountmgr.sys 驅動程式是否存在。。

然後 Exchange Server Analyzer 會讀取下列登錄值，以判定在 Exchange 伺服器上執行的 Microsoft Windows® 作業系統版本： HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

如果 CurrentVersion 值等於 5.0，表示 Exchange 伺服器是在 Microsoft Windows 2000 Server 上執行。如果 CurrentVersion 值為 5.2，表示 Exchange 伺服器是在 Microsoft Windows Server™ 2003 上執行。

Exchange Server Analyzer 工具也會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定叢集服務 (ClusSvc) 的 Started 機碼值。值為 TRUE 表示已啟動叢集服務，值為 FALSE 則表示未執行叢集服務。

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • Exchange Server 電腦在 Windows Server 2003 上執行。

  • 未安裝 Windows Server 2003 SP1。

  • Exchange Server 在叢集環境中執行。

  • 磁碟區裝載點存在。

這個警告表示，如果 Exchange 叢集節點環境升級至 Windows Server 2003 SP1，您將需要下節中所提到的更新。若沒有這個更新，則在升級之後，您可能會遇到磁碟區裝載點失敗的問題。

若要更正此警告

  • 套用微軟知識庫文件 - 898790＜在您安裝 Windows Server 2003 Service Pack 1 之後，伺服器叢集中磁碟上的磁碟區裝載點可能會間歇地變成無法使用＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790) 中所提到的更新。


在 Exchange Server 上啟用了 Windows 防火牆服務
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Windows 防火牆服務 (SharedAccess) 的 Started 機碼值。True 值表示此 Exchange 伺服器已啟用 Windows 防火牆服務。

若 Exchange Server Analyzer 判定已在 Exchange Server 電腦上啟用 Windows 防火牆服務，則會顯示警告。啟動 Windows 防火牆服務時，可能會產生下列問題：

  • Exchange Server 的部份元件可能會停止回應，如「郵件追蹤服務」或遠端程序呼叫 (RPC) 通訊。

  • 您可能會收到一則表示可用記憶體不足的錯誤訊息。

在預設的情況下，套用 Microsoft Windows Server™ 2003 Service Pack 1 (SP1) 時，會停止 Windows 防火牆服務。不過，如果下列任一條件屬實，則會自動將該服務設為執行：

  • 系統管理員手動啟用 Windows 防火牆服務。

  • 您在執行「安全性設定精靈」後啟用 Windows 防火牆服務。

若要更正此警告

  • 檢查排除的程式。

  • 檢查排除的通訊埠。

  • 若用戶端無法連線至 Exchange 伺服器，請檢查防火牆例外狀況。

  • 手動開啟防火牆中的通訊埠，以便執行「Exchange 系統管理員」與「Microsoft Exchange 系統管理員」。當您在 Windows 防火牆服務中開啟通訊埠時，會增加其他程式可透過這些通訊埠存取您電腦的機會。在 Windows 防火牆服務中開啟通訊埠之前，請先仔細考量您的網路安全性需求。

  • 停止 Windows 防火牆服務。


Windows Management Instrumentation 服務未以 LocalSystem 執行
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 ObjectName 值的數值資料：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winmgmt

此登錄分支中的 ObjectName 值表示 Microsoft Windows® Management Instrumentation (WMI) 服務 (稱為 Winmgmt 服務) 的服務帳戶設定。如果 Exchange Server Analyzer 發現 ObjectName 的數值資料不等於 LocalSystem，就會顯示一則錯誤。

此錯誤表示 WMI 服務並未以支援的組態執行。若您以任何其他非 LocalSystem 的帳戶執行 WMI 服務，則會造成權限與存取錯誤。

若要解決此錯誤，您必須將 WMI 服務設成以 LocalSystem (SYSTEM) 帳戶啟動。

若要設定 WMI 服務帳戶

  1. 開啟 [服務] Microsoft Management Console (MMC) 嵌入式管理單元。

  2. 尋找並停止 Windows Management Instrumentation 服務。

  3. 連按兩下 Windows Management Instrumentation 服務。

  4. 在 [Windows Management Instrumentation 內容] 頁面的 [登入] 索引標籤上，選取 [登入身分] 下的 [本機系統帳戶]，然後按一下 [套用]。

  5. 在 [服務狀態] 下，按一下 [啟動]，再按一下 [確定]。

  6. 關閉 [服務] 嵌入式管理單元。


Windows Server 2003 SP1：需要 Outlook Web Access Hotfix
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢不同的 Microsoft Windows® Management Instrumentation (WMI) 類別，以收集下列資訊：

  • 安裝 Exchange Server 的 Microsoft Windows Server 作業系統版本為何？

  • Exchange Server 是否執行於叢集上？

如果 Exchange Server Analyzer 判定下列條件符合，則會顯示錯誤：

  • 已安裝 Exchange Server 2003 Service Pack 1 (SP1)。

  • 已安裝 Microsoft Windows Server™ 2003 Service Pack 1 (SP1)。

  • 叢集服務執行中。

  • Davex.dll 的 Version 值小於 6.5.7232。

如果執行此組態，則必須在下載並安裝 Exchange Server Hotfix 後，才能安裝 Windows Server 2003 SP1。如果不安裝 Exchange Server Hotfix，則 Microsoft Office Outlook® Web Access for Exchange Server 2003 使用者將無法登入信箱。使用者的信箱若是放置在叢集上，當他們嘗試使用 Outlook Web Access 進行連線時，將會收到下列錯誤訊息：

  • 「500 - 內部伺服器錯誤」

這個錯誤是由 Windows Server 2003 SP1 中內含的部分安全性增強功能引起。

當使用者嘗試以 Outlook Web Access 登入信箱時，HTTP 會模擬登入的使用者來提交要求至叢集 API。然而，Windows Server 2003 SP1 中的安全性已有所變更。執行遠端登錄存取的 API 安全性限制已變更。因此，登入嘗試會失敗。

若要修正此錯誤，您必須依照微軟知識庫文件 - 841561＜使用者嘗試以 Outlook Web Access 存取叢集 Exchange Server 2003 後端伺服器時，顯示「500 - 內部伺服器錯誤」錯誤訊息＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841561) 中的說明，下載並安裝 Exchange Server Hotfix。


偵測到 Windows Server 2003 SP1 安全性設定精靈
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄值，以判定 Exchange 伺服器上執行的 Microsoft Windows® 作業系統版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

如果 CurrentVersion 值等於 5.0，則表示 Exchange 伺服器執行於 Microsoft Windows 2000 Server 上。如果 CurrentVersion 值為 5.2，則表示 Exchange 伺服器執行於 Microsoft Windows Server™ 2003 上。

此外，Exchange Server Analyzer 會讀取下列登錄值，以判定 Windows Program Files 目錄的路徑：

HKLM\Software\Microsoft\Windows\CurrentVersion\ProgramFilesDir

然後，Exchange Server Analyzer 會檢查 Windows Program Files 目錄，以判定 Windows Program Files 目錄是否包含 Exchange Server 的 \Exchsrvr 資料夾。

最後，Exchange Server Analyzer 會查詢 Win32_OperatingSystem Windows Management Instrumentation (WMI) 類別，以判定 ServicePackMajorVersion 機碼值。ServicePackMajorVersion 機碼值表示電腦上安裝的 Windows Service Pack。

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • Exchange Server Analyzer 判定 Exchange Server 電腦執行於 Windows Server 2003 Service Pack 1。

  • Exchange Server Analyzer 判定 Exchange Server 2003 並未安裝在 \Program Files\Exchsrvr 的預設路徑中。

此警告表示 Exchange Server 2003 並未安裝在伺服器的預設 Program Files 資料夾中，且 Exchange 伺服器上已安裝 [安全性設定精靈]。[安全性設定精靈工具] 是 Windows Server 2003 Service Pack 1 所隨附的一項選用性元件。若在 Exchange 伺服器上安裝 [安全性設定精靈]，則需手動設定 [網路安全性] 區段。

附註：
若要安裝 [安全性設定精靈]，您必須先安裝 Windows Server 2003 Service Pack 1。安裝 Service Pack 1 後，開啟 [控制台] 中的 [新增/移除程式]，來安裝 [安全性設定精靈]。

[安全性設定精靈] 可藉由詢問使用者一連串可用來判定伺服器運作需求的問題，來降低 Windows 伺服器的攻擊面。特別是，[安全性設定精靈] 會協助您執行下列工作：

  • 自動停用不必要的服務。

  • 自動封鎖未使用的通訊埠。

  • 協助您針對開啟的通訊埠套用其他位址限制或安全性限制。

  • 防止不必要的網際網路資訊服務 (IIS) Web 延伸 (若可用)。

  • 降低伺服器訊息區 (SMB)、LanMan 以及輕量型目錄存取協定 (LDAP) 等通訊協定洩漏的情形。

  • 定義高訊雜比的稽核原則。

[安全性設定精靈] 可引導您完成建立、編輯、套用或復原安全性原則 (根據選取的伺服器角色) 的程序。以 [安全性設定精靈] 建立的安全性原則，是一種可加以套用而用來設定服務、網路安全性、特定登錄值及稽核原則的 XML 檔案。網際網路資訊服務 (IIS) 也可設定 (若可用)。

[安全性設定精靈] 除了可執行其他功能外，還包含一項可在 [Windows 防火牆] 中設定及新增例外狀況的 [網路安全性] 功能。[Windows 防火牆] 是 Windows Server 2003 Service Pack 1 中新版的狀態封包篩選器。[Windows 防火牆] 最早於 Windows XP Service Pack 2 中推出。當時在 Windows XP Service Pack 2 中稱為「網際網路連線防火牆」。

若在執行 [安全性設定精靈] 之 [網路安全性] 功能的 Exchange 伺服器上，Exchange Server 並非安裝在預設路徑中，就會產生一項已知問題。在此設定中，若使用結果原則，即可能會導致用戶端無法存取 Exchange Server。若在使用 [網路安全性] 功能的 Exchange 伺服器上，Exchange Server 並非安裝在預設路徑中，[安全性設定精靈] 就會將 [Windows 防火牆] 設定為封鎖 Exchange Server 處理程序所做的 TCP/IP 通訊埠存取，這些處理程序包括系統服務員 (Mad.exe)、Microsoft Exchange Information Store (Store.exe) 或郵件傳輸代理程式 (Emsmta.exe) 等。在此組態中，[安全性設定精靈] 會在每個處理程序旁顯示 [找不到!]。在 [安全性設定精靈] 執行完成之後，若某個處理程序旁顯示 [找不到!]，[安全性設定精靈] 就會對 Windows 防火牆套用安全性原則，封鎖該處理程序所做的網路存取。

若封鎖的處理程序包含一或多個 Exchange Server 處理程序，則用戶端與其他伺服器可能會無法存取 Exchange Server。若有這種情況，應執行下列其中一項程序來更正此問題。

更正問題

  • 請執行下列其中一項程序來更正問題：

    • 使用 [安全性設定精靈] 的復原功能，在套用安全性原則後予以復原。若需有關如何執行此動作的詳細資訊，請參閱 Windows Server 2003 Service Pack 1 內含的安全性設定精靈說明檔。若需有關 Windows Server 2003 Service Pack 1 及 [安全性設定精靈] 的詳細資訊，請參閱 Windows Server 2003 TechCenter (英文) (http://go.microsoft.com/fwlink/?LinkId=45315)。

    • 在 [安全性設定精靈] 中，手動填入 [應用程式路徑] 欄位，以指定 Exchange Server 處理程序可執行檔的位置。若要完成此動作，請選取旁邊顯示 [找不到！] 的處理程序，然後按一下 [編輯]。建議您在 Exchange 伺服器上執行 [安全性設定精靈]，以確保每個 Exchange Server 處理程序可執行檔的路徑都正確。在核准每個處理程序可執行檔之後，便可套用 [安全性設定精靈] 安全性原則，而 Exchange Server 也擁有運作所需的網路存取權。

若需有關 Windows Server 2003 Service Pack 1 及 [安全性設定精靈] 的詳細資訊，請參閱 Windows Server 2003 TechCenter (英文) (http://go.microsoft.com/fwlink/?LinkId=45315)。


XESE.DLL 檔案已存在
Microsoft Exchange Server Analyzer - 文章 > Exchange Server >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定名為 Xese.dll 之檔案的 Version 機碼值。

如果 Exchange Server Analyzer 能夠取得此檔案的 Version 值，就表示此檔案已存在，而且會顯示錯誤訊息。

有些 ESE 型防毒程式會在 Exchange 資訊儲存庫與可擴充儲存引擎 (ESE) 之間使用不支援的介面。當您使用此類軟體時，如果軟體實作發生錯誤，您會有資料庫毀損與資料遺失的風險。

在安裝期間，ESE 型掃描程式會變更 Microsoft Exchange Information Store 服務，使該服務依賴 ESE 型防毒程式的服務。這樣可確保在 ESE 型防毒程式的服務啟動後，Microsoft Exchange Information Store 服務才會啟動。當 ESE 型的防毒程式啟動時，Exchange Server 隨附的 Ese.dll 版本會暫時重新命名為 Xese.dll，而 ESE 型的防毒程式之 Ese.dll 版本會取代原始的檔案。載入 ESE 型防毒程式版的 Ese.dll 之後，Exchange 伺服器所包含的版本就會重新命名回 Ese.dll，而 Microsoft Exchange Information Store 服務就可以完成啟動程序。

若要解決此警告

  1. 強烈建議您絕對不要在 Exchange Server 電腦上，使用非 Microsoft 的 ESE 實作方式。用戶在連絡 Microsoft 產品支援服務時，可能會被要求停用 ESE 型防毒程式，以協助釐清問題，在問題的根本原因診斷出來之後，用戶可以自由重新啟用該軟體。

  2. 最廣為使用的 ESE 型防毒程式是 Sybari Software 的 Antigen for Microsoft Exchange。Microsoft 及 Sybari 都同意停用 Sybari Antigen，是判斷問題發生原因的有效疑難排解步驟。若要連絡 Sybari Software，請參閱 Sybari Software 網站 (英文) (http://www.sybari.com)。

    附註：
    以下提供協力廠商網站資訊，協助您找到需要的技術資訊。URL 如有變更，恕不另行通知。

  3. 建議您使用支援病毒掃描應用程式發展介面 (VSAPI) (也稱為「防毒 API (AVAPI)」) 的防毒程式。

若需有關在 Exchange Server 上執行防毒軟體的詳細資訊，請參閱下列微軟知識庫文件：

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=)。

  • 328841＜XADM：Exchange 和防毒軟體＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=)。


硬體
Microsoft Exchange Server Analyzer - 文章 >

主題上次修改日期： 2005-11-18

本節中的文件提供 Microsoft® Exchange Server Analyzer 工具對硬體進行評估的詳細資料。此外，這些文件還說明您可以採取哪些動作，來解決 Exchange Server Analyzer 所發現的硬體相關錯誤、警告及非預設組態。


BIOS 已過期
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_BIOS Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 SMBIOSBIOSVersion 及 ReleaseDate 機碼值。傳回的值分別代表電腦上安裝的 BIOS 之版本號碼和發行日期。Exchange Server Analyzer 也會檢查 Win32_ComputerSystem WMI 類別，以判定 Model 機碼的值。

如果 Exchange Server Analyzer 發現 ReleaseDate 的值指出已過時 1 年，且 Model 機碼包含下列任何字串，則會顯示警告：

  • ProLiant DL320

  • ProLiant DL320 G2

  • ProLiant DL320 G3

  • ProLiant DL360

  • ProLiant DL360 G2

  • ProLiant DL360 G3

  • ProLiant DL360 G4

  • ProLiant DL380

  • ProLiant DL380 G2

  • ProLiant DL380 G3

  • ProLiant DL380 G4

  • ProLiant DL560

  • ProLiant DL570 G3

  • ProLiant DL580

  • ProLiant DL580 G2

  • ProLiant DL580 G3

  • ProLiant DL585 G1

  • ProLiant ML350

  • ProLiant ML350 G2

  • ProLiant ML350 G3

  • ProLiant ML350 G4

  • ProLiant ML370

  • ProLiant ML370 G2

  • ProLiant ML370 G3

  • ProLiant ML370 G4

  • ProLiant ML530

  • ProLiant ML530 G2

  • ProLiant ML570

  • ProLiant ML570 G2

  • ProLiant ML750

若要更正此警告，並瞭解有關取得及更新較新 BIOS 版本的詳細資訊，請參閱 Hewlett-Packard 網站中的＜ROM-BIOS/韌體更新＞(英文) (http://h18023.www1.hp.com/support/files/server/us/romtabl.html)。

若需有關 Hewlett-Packard ProLiant 伺服器的詳細資訊，請參閱 Hewlett-Packard 網站 (英文) (http://www.hp.com)。

附註：
網址可能會變更，因此您可能無法連線到此處提到的網站。


Dell PowerEdge 伺服器上的 BIOS 已過時
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_BIOS Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 SMBIOSBIOSVersion 機碼的值。傳回的值代表在電腦上安裝的 BIOS 版本號碼。Exchange Server Analyzer 也會檢查 Win32_ComputerSystem WMI 類別，以判定 Model 機碼的值。

如果 Exchange Server Analyzer 發現 Model 機碼包含下列任一字串，而且 SMBBIOSBIOSVersion 不是該機型的最新版本，就會顯示警告：

  • PowerEdge 2400

  • PowerEdge 2450

  • PowerEdge 2500

  • PowerEdge 2550

  • PowerEdge 2600

  • PowerEdge 2650

  • PowerEdge 2800

  • PowerEdge 2850

  • PowerEdge 3250

  • PowerEdge 4300

  • PowerEdge 4350

  • PowerEdge 4400

  • PowerEdge 4600

  • PowerEdge 6300

  • PowerEdge 6350

  • PowerEdge 6400

  • PowerEdge 6450

  • PowerEdge 6600

  • PowerEdge 6650

  • PowerEdge 6800

  • PowerEdge 6850

  • PowerEdge 7150

  • PowerEdge 7250

  • PowerEdge 8450

若要更正此警告，或需瞭解有關取得及更新較新 BIOS 版本的詳細資訊，請參閱 Dell 網站的「下載」(英文) (http://support.dell.com/support/downloads)。

若需有關 Dell PowerEdge 伺服器的詳細資訊，請參閱 Dell 網站 (英文) (http://www.dell.com)。

附註：
網址可能會變更，因此您可能無法連線到此處提到的網站。


可使用 BIOS 更新
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_BIOS Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 SMBIOSBIOSVersion 機碼值。傳回的值代表電腦上安裝之 BIOS 的版本號碼和發行日期。Exchange Server Analyzer 也會檢查 Win32_ComputerSystem WMI 類別，以判定 Model 機碼值。如果 Exchange Server Analyzer 判定電腦為 IBM X445 系統，並安裝了 REJT48A 之前的 BIOS 版本，則會顯示錯誤。

若要更正此錯誤，以及想瞭解有關取得及更新為新版 BIOS 的詳細資訊，請參閱 IBM 網站「具有 RSA I 及 RSA II EXA 支援的 Flash BIOS 更新 (DOS 更新套件) - IBM eServer xSeries 445」(英文) (http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-54089)。

附註：
網址可能會變更，因此您可能無法連線到此處提到的網站。


叢集網路介面卡已啟用 DHCP
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_NetworkAdapterConfiguration Microsoft Windows® Management Instrumentation (WMI) 類別，以判定叢集中所有網路介面的 DHCPEnabled 機碼值。如果 Exchange Server Analyzer 發現叢集中任何私人網路介面的 DHCPEnabled 值設定為 TRUE，則會顯示錯誤訊息。

DHCPEnabled WMI 機碼的值為 TRUE，表示網路介面已設為使用動態主機設定通訊協定 (DHCP)。Microsoft 不支援將 DHCP 用於 Windows 伺服器叢集中的私人網路節點。此外，建議您將靜態 IP 位址用於 Windows 伺服器叢集中的公用網路節點。不建議使用透過 DHCP 之公用網路的動態組態， 因為更新 DHCP 租約失敗會阻礙叢集操作。此外，也不支援使用透過 DHCP 之私人網路的動態組態，而且永遠不能這樣執行。

若要解決這個問題，您必須將私人網路的網路介面重新設定為使用靜態 IP 位址。建議選用下列範圍內的位址：

  • 10.0.0.0 - 10.255.255.255 (類別 A 網路)

  • 172.16.0.0 - 172.31.255.255 (類別 B 網路)

  • 192.168.0.0 - 192.168.255.255 (類別 C 網路)

若要更正此錯誤

  1. 在 [網路連線] 中，在私人網路介面卡的網路連線上按一下滑鼠右鍵，再按一下 [內容]。

  2. 按一下 [網際網路通訊協定 (TCP/IP)]，再按一下 [內容]。

  3. 在 [一般] 索引標籤上，輸入與公用網路介面卡的其他 IP 位址不在相同子網路或網路上的靜態 IP 位址。針對私人介面卡所使用的良好 IP 位址範例是在節點 1 上使用 10.10.10.10，在節點 2 上使用 10.10.10.11，並使用子網路遮罩 255.0.0.0。如果公用網路使用 10.x.x.x 網路及 255.0.0.0 子網路遮罩，則會使用替代的私人網路 IP 及子網路。

  4. 確定未在 [設定閘道] 方塊中設定任何值。

  5. 確認未在 [使用下列 DNS 伺服器位址] 方塊中定義任何值。

  6. 按一下 [進階]。

  7. 在 [DNS] 索引標籤上，確認未定義任何值。確定已清除 [在 DNS 中登錄這個連線網路的位址] 及 [在 DNS 登錄中使用這個連線的 DNS 尾碼] 核取方塊。

  8. 在 [WINS] 索引標籤上，確認未定義任何值。按一下 [停用 NetBIOS over TCP/IP]。

  9. 當您關閉對話方塊時，您可能會收到下列提示。如果您看到此提示，請按一下 [是]：此連線有空的主要 WINS 位址。想要繼續嗎?

  10. 按一下 [確定] 以儲存變更。

  11. 在叢集中的所有其他節點上完成先前的步驟。

若需有關為 Windows 伺服器叢集最佳化網路組態的詳細資訊，請參閱＜伺服器叢集：Windows 2000 及 Windows Server 2003 的網路組態最佳作法＞(英文) (http://go.microsoft.com/fwlink/?linkid=34304)。

若需有關正確叢集活動訊號組態的詳細資訊，請參閱微軟知識庫文件 - 258750＜叢集伺服器上建議使用的私人「活動訊號」(Heartbeat) 設定＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)。


電腦的主要 DNS 尾碼不符合它所在之網域的 FQDN
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2006-05-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Exchange Server 的主要網域名稱系統 (DNS) 尾碼：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\NV Domain

HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Domain

如果 Exchange Server Analyzer 發現 NV Domain 及 Domain 的值不符合，則會顯示警告。

NV Domain 登錄值包含電腦的主要 DNS 尾碼。Domain 登錄值包含電腦的主要 DNS 網域。依預設，電腦完整網域名稱 (FQDN) 的主要 DNS 尾碼部份，必須與電腦所在的 Active Directory® 目錄服務網域名稱相同。不符合的名稱會讓 DNS 註冊無法正確執行。如果電腦的 DNS 網域名稱與 Active Directory 網域名稱不符，那麼每 22 分鐘就會在電腦的系統事件日誌中看到錯誤。這種狀況就是所謂的斷續名稱空間。若要允許不同的主要 DNS 尾碼，您可以在網域物件容器中建立名稱為 msDS-AllowedDNSSuffixes 的 Active Directory 屬性，即可建立允許之尾碼的限制清單。

用來確定您具有正確設定之解除結合名稱區的程序，需視用於 Active Directory 網域控制站的作業系統而定。

  • 如果在 Active Directory 網域控制站上執行 Microsoft Windows® 2000 Server 作業系統，則可使用下列微軟知識庫文件中概述的程序，正確地設定您的命名空間 - 258503＜當 DNS 網域及 Active Directory 網域名稱不同時，會發生 DNS 登錄錯誤 5788 及 5789＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258503)。此文件包含更正不想要的解除結合的命名空間之程序，以及在想要解除結合命名空間時，正確設定該解除結合命名空間的程序。

  • 如果您在 Active Directory 網域控制站上執行 Microsoft Windows Server™ 2003，且不想要有解除結合名稱區，您可以使用下面的第一個程序來更正不想要的解除結合名稱區，並解決此警告。如果您在 Active Directory 網域控制站上執行 Windows Server 2003，且想要有解除結合名稱區，您可以使用下面的第二個程序來正確設定該名稱區。

若要執行下面的第二個程序，則需要使用 Active Directory 編輯器 (例如，Active Directory Service Interfaces (ADSI) 編輯器或 LDP (Ldp.exe) 工具)。若需有關使用 LDP 工具修改 Active Directory 的詳細資訊，請參閱微軟知識庫文件 - 260745＜XADM：使用 LDP 公用程式修改 Active Directory 物件屬性＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260745)。

注意：
使用 ADSI 編輯器、LDP 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Windows Server 2003、Exchange Server 2003 (或兩者) 才能解決。修改 Active Directory 物件屬性的風險由客戶自行負責。

如果不想要有解除結合名稱區

  1. 以滑鼠右鍵按一下 [我的電腦]，然後按一下 [內容]。會出現 [系統內容] 對話方塊。

  2. 按一下 [電腦名稱] 索引標籤。

  3. 按一下 [變更]。此時會出現 [電腦名稱變更] 對話方塊。

  4. 按一下 [其他]。此時會出現 [DNS 尾碼和 NetBIOS 電腦名稱] 對話方塊。

  5. 選取 [當網域成員資格變更時，也變更主要 DNS 尾碼] 核取方塊。

  6. 按一下 [確定] 以儲存變更，再按一下 [確定] 以結束 [電腦名稱變更] 對話方塊。

  7. 按一下 [確定] 以關閉 [系統內容] 對話方塊，然後再重新啟動電腦，讓變更生效。

如果想要有解除結合命名空間

  1. 使用上面的程序，來確定已清除 [當網域成員資格變更時，也變更主要 DNS 尾碼] 核取方塊。

  2. 修改網域物件容器上的 msDS-AllowedDNSSuffixes Active Directory 屬性。您可以執行下列步驟，使用 [ADSI 編輯器] 來執行此作業：

    1. 針對您要修改的網域，連按兩下網域目錄磁碟分割。

    2. 在網域容器物件上按一下滑鼠右鍵，再按一下 [內容]。

    3. 在 [屬性編輯器] 索引標籤的 [屬性] 方塊中，連按兩下 [msDS-AllowedDNSSuffixes] 屬性。

    4. 在 [多重值字串編輯器] 對話方塊中，在要新增方塊的 [值] 中輸入 DNS 尾碼，再按一下 [新增]。

    5. 當您已為網域新增所有 DNS 尾碼後，請按一下 [確定]。

    6. 按一下 [確定]，關閉該網域的 [內容] 對話方塊。

    7. 如果您有多個網域，且您想要使用類似的設定，請重複這些步驟。

若需 msDS-AllowedDNSSuffixes 屬性的詳細資訊，請參閱 Windows Server 2003 說明及支援中心。若需用來編輯這個屬性的程序的相關資訊，請參閱＜實作網域重新命名的逐步指引＞(英文) (http://go.microsoft.com/fwlink/?LinkId=41359)。


可使用重要的 BIOS 更新
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2006-04-20

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_BIOS Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 SMBIOSBIOSVersion 機碼值。SMBIOSBIOSVersion 機碼值代表伺服器上所安裝的 BIOS 版本。Exchange Server Analyzer 也會查詢 Win32_ComputerSystem WMI 類別，以判定 Model 機碼值。Model 機碼值代表硬體製造商所提供的硬體機型資訊。

如果 Exchange Server Analyzer 發現伺服器 (其 Model 機碼的開頭是 eserver xSeries 445) 之 Version 機碼值為 42B，就會顯示一則錯誤。此錯誤指出必須更新這個 IBM xSeries 445 伺服器的 BIOS。

BIOS 韌體 42B 版的已知問題可能會有造成資料損毀。此問題僅發生在已安裝 BIOS 42B (1.15 版) 的 X445 系統。BIOS 45A 已更正此問題。您應該儘快將此伺服器的 BIOS 更新成 45A 或更新版本。

若要更正此錯誤

  1. 若需有關此問題的詳細資訊，請參閱 IBM 網站「Flash BIOS 更新 (DOS 更新套件) - IBM eServer xSeries 445」(英文) (http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-54089#BIOSVersion)。

  2. 若需相關資訊，請參閱＜BIOS 更新的讀我檔案＞(英文) (ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers/39y4888.txt)。

  3. 從 IBM 網站 (英文) (http://www-307.ibm.com/pc/support/site.wss/license.do?filename=pc_servers/26r0663.exe) 下載 BIOS 更新。

  4. 更新伺服器上的 BIOS。

若需有關套用此重要 BIOS 更新的詳細資訊，請參閱 IBM 網站 (英文) (http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=DSHY-3TEPF6)。

附註：
網址可能會變更，因此您可能無法連線到此處提到的網站。


目前的處理器速度低於最大可能速度
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Processor Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 MaxClockSpeed 及 CurrentClockSpeed 目前的值。如果 Exchange Server Analyzer 發現 CurrentClockSpeed 的值小於 MaxClockSpeed 的值，就會顯示一則警告。

CurrentClockSpeed 值是每一個處理器目前的速度 (MHz)。MaxClockSpeed 是每一個處理器的最高速度 (MHz)。如果顯示這則警告訊息，則表示您的 Exchange 伺服器上有一或數個處理器沒有全速運作。幾個已知的原因如下：

  1. Exchange Server 安裝於執行 Microsoft Windows® 2000 Server 或 Windows 2000 Advanced Server 的電腦上，其沒有安裝 Windows 2000 Service Pack 3 或更新的版本。Windows 2000 Service Pack 3 已更正 WMI 沒有傳回 MaxClockSpeed 或 CurrentClockSpeed 正確值的問題。

  2. Exchange 伺服器的 BIOS 中的省電設定值不正確，可能會強制處理器在省電模式下，以降低的速度來執行。

若要更正此警告

  1. 如果在執行 Windows 2000 Server 或 Windows 2000 Advanced Server 的電腦上安裝 Exchange Server，但沒有安裝 Windows 2000 Server Service Pack 3 或更新版本，則應該安裝最新的 Service Pack。若需有關最新 Windows 2000 Service Pack 的詳細資訊，請參閱 Microsoft Windows 2000 網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=18353。

  2. 如果在執行 Windows 2000 Server 或 Windows 2000 Advanced Server 的電腦上安裝 Exchange Server，並確實已安裝 Windows 2000 Server Service Pack 3 或更新版本，請檢查您 Exchange 伺服器的 BIOS 設定。您也應該檢查 BIOS、[控制台] 或 [裝置管理員] 中的電源管理設定。

請洽詢您的硬體製造商，以瞭解如何檢視及設定系統 BIOS、處理器及電源管理設定。

若需有關 Windows 2000 Server 電源管理功能的詳細資訊，請參閱微軟知識庫文件 - 244806＜Windows 2000 中的電源管理概要＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=244806)。

若需有關 Microsoft Windows Server™ 2003 電源管理功能的詳細資訊，請在 Windows Server 2003 說明及支援中心中搜尋「電源管理」及「電源選項」，您可以從執行 Windows Server 2003 之電腦的 [開始] 功能表執行 Windows Server 2003 說明及支援中心。

若需有關 Windows 2000 Server 電源管理功能的詳細資訊，請參閱 Windows 2000 Server 說明中的＜電源管理＞及＜電源選項＞主題，您可以從執行 Windows 2000 Server 之電腦的 [開始] 功能表執行 Windows 2000 Server 說明。


Windows Server 2003 上未正確設定 DisableDHCPMediaSense
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2006-10-02

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已正確設定媒體檢測偵測：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\DisableDHCPMediaSense

Exchange Server Analyzer 也會檢查下列登錄項目，以判定在目的電腦上執行的 Windows 版本：

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 值為 4.0 表示電腦正在執行 Microsoft Windows NT® Server 4.0。值 5.0 表示電腦正在執行 Windows® 2000 Server 作業系統，而值 5.2 則表示電腦正在執行 Windows Server™ 2003 作業系統。

此外，Exchange Server Analyzer 會查詢 Win32_Service Microsoft Windows Management Instrumentation (WMI) 類別，以判定 Microsoft Windows Cluster 服務 ClusSvc 的 Started 機碼值。值 True 表示 Windows Cluster 服務正在執行，而值 False 則表示該服務未執行。

如果 Exchange Server Analyzer 發現 Windows 叢集服務在 Windows Server 2003 Enterprise Edition 或 Windows Server 2003 Datacenter Edition 上執行，而且 DisableDHCPMediaSense 登錄機碼的值設為 1，就會顯示警告。

當您使用 Windows Server 2003 叢集服務時，如果網路連線中斷，則與在 Windows 2000 Server 一樣，預設不會卸載 TCP/IP 堆疊。所以您不再需要設定 DisableDHCPMediaSense 登錄機碼。在 Windows 2000 Server 中，如果網路連線中斷，就會卸載 TCP/IP 堆疊，這表示依賴 IP 位址的所有叢集資源都會離線，包括 Exchange 虛擬伺服器中的資源在內。當網路重新連線時，它們的網路角色會還原成預設設定 (也就是用戶端及私人角色)。在預設情況下會停用「媒體檢測」，這表示會保留網路角色，且所有 IP 位址依存資源都會保持在連線狀態。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：

    HKLM\System\CurrentControlSet\Services\Tcpip\Parameters

  3. 在右窗格中，按一下滑鼠右鍵以修改 (設定為 0 以停用) 或刪除 [DisableDHCPMediaSense] 登錄值。

  4. 關閉登錄編輯程式。

  5. 將所有叢集資源移到其他節點，或使其離線。然後，重新啟動叢集節點，以使變更生效。

  6. 在產生此警告的叢集中的所有其他節點上重複此處理程序。

若需有關 Microsoft Windows 登錄的詳細資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)。

若需有關媒體檢測偵測及 Windows 叢集的詳細資訊，請參閱下列知識庫文件：

  • 254651＜自動變更叢集網路角色＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=254651)

  • 239924＜如何停用 Windows 中 TCP/IP 的媒體檢測＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=239924)

  • 242430＜使用跳線設定叢集組態時，無法使用網路介面卡＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=242430)

  • 278007＜Windows Server 2003 叢集中可用的功能＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=278007)


未在 Windows 2000 Server 上正確地設定 DisableDHCPMediaSense
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已正確地設定媒體檢測偵測 (Media Sense Detection)。

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\DisableDHCPMediaSense

Exchange Server Analyzer 也會檢查下列登錄項目，來判定目標電腦上執行的 Windows 版本：

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 值為 4.0 表示電腦是執行 Microsoft Windows NT® Server 4.0。值 5.0 表示電腦是執行 Microsoft Windows® 2000 Server 作業系統，而值 5.2 則表示電腦是執行 Microsoft Windows Server™ 2003 作業系統。

此外，Exchange Server Analyzer 會查詢 Win32_Service Microsoft Windows Management Instrumentation (WMI) 類別，以判定 ClusSvc (Microsoft Windows 叢集服務) 的 Started 機碼值。值 True 表示 Windows Cluster 服務正在執行，而值 False 則表示該服務未執行。

如果 Exchange Server Analyzer 發現 Windows 2000 Advanced Server 或 Windows 2000 Datacenter Server 上執行的是 Windows 叢集服務，並且如果 DisableDHCPMediaSense 登錄機碼存在，且值未設為 1，就會顯示一則警告。

使用 Windows 2000 Server 叢集服務時，如果遺失網路連線，則會卸載 TCP/IP 堆疊。這表示所有依據 IP 位址的叢集資源 (包括 Exchange 虛擬伺服器中的資源) 都已離線。當網路重新連線時，它們的網路角色會還原成預設設定 (用戶端及私人)。若要避免發生此問題，建議您停用所有 Windows 2000 Server 型叢集上的媒體檢測偵測。便會自動停用 Windows Server 2003 型叢集上的媒體檢測偵測。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：

    HKLM\System\CurrentControlSet\Services\Tcpip\Parameters

  3. 在 [參數] 上按一下滑鼠右鍵，然後再按 [新增 | DWORD 值]。對名稱輸入 DisableDHCPMediaSense，再按 Enter 鍵。

  4. 在右窗格中，連按兩下 DisableDHCPMediaSense，並輸入數值資料 1。

  5. 關閉登錄編輯程式。

  6. 將所有叢集資源移到其他節點，或使其離線。然後，重新啟動叢集節點，以使變更生效。

  7. 針對產生此警告之叢集中的所有節點，重複此處理程序。

若需有關 Microsoft Windows 登錄的詳細資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)。

若需有關媒體檢測偵測及 Windows 叢集的詳細資訊，請參閱下列知識庫文件：

  • 254651＜自動變更叢集網路角色＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=254651)

  • 239924＜如何停用 Windows 中 TCP/IP 的媒體檢測＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=239924)

  • 242430＜使用跳線設定叢集組態時，無法使用網路介面卡＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=242430)

  • 278007＜Windows Server 2003 叢集中可用的功能＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=278007)


依預設未設定磁碟逾時
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目來判定是否已變更磁碟逾時值的預設值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Disk\TimeOutValue

如果 Exchange Server Analyzer 發現 TimeOutValue 存在且設為 10 以外的其他值，而且伺服器不是叢集式，則會顯示非預設的組態訊息。如果 Exchange Server Analyzer 發現 TimeOutValue 存在且設為 20 以外的其他值，而且伺服器是叢集式，則會顯示非預設的組態訊息。

磁碟逾時登錄設定會定義 Microsoft Windows® 等待硬碟回應命令的時間。在非叢集式系統上，此機碼不存在，且所有磁碟都使用預設值 10 秒。在 Windows 叢集上，此機碼存在且使用預設值 20 秒。如果逾時時間超過此登錄設定的值，Windows 將顯示錯誤並停止磁碟存取。有時候，如果您執行多重路徑磁碟存取軟體，這可以設為更大的值。多重路徑軟體可讓您將多重實體路徑 (例如光纖) 連接到單一磁碟機，達到備用目的。多重路徑軟體可以管理多重實體連線，所以 Windows 只需要處理磁碟的單一控制代碼。

安裝主匯流排介面卡 (HBA) 或其他存放控制站會建立和設定此機碼。當您安裝或重新安裝這些驅動程式時，將以這些驅動程式所需的值來覆寫 TimeOutValue 登錄值。您可能需要連絡硬體廠商來決定組態的正確 TimeOutValue 登錄值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：

    HKLM\System\CurrentControlSet\Services\Disk\TimeOutValue

  3. 在右窗格中，刪除 TimeOutValue 項目。或者，也可以連按兩下 TimeOutValue 項目，並將它設為下列其中一個值：

    • 在非叢集式伺服器上，請將此值設為 10。

    • 在叢集式伺服器上，請將此值設為 20。

    • 如果您的硬體製造商對於叢集式或非叢集系統建議使用不同的值，請改用您的硬體製造商所提供的值。

  4. 關閉登錄編輯程式，然後重新啟動電腦，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關叢集式系統的 TimeOutValue 項目的詳細資訊，請參閱知識庫文件 - 818877＜在您安裝或升級至 Windows Server 2003 中 Windows 叢集功能之後叢集伺服器可能會經歷磁碟機的連線逾時＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818877)。


DNS 搜尋順序空白
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_NetworkAdapterConfiguration Microsoft Windows® Management Instrumentation (WMI) 類別，以判定是否已設定 DNSServerSearchOrder 的值。如果在 Exchange 伺服器上此機碼的值是空白，則會顯示一則警告。

此警告指出此電腦上的一或多個網路介面卡沒有與它們產生關聯的 DNS IP 位址。因此，此電腦嘗試連線至另一台電腦時，會透過區域網路廣播來取得 IP 位址。所以名稱解析會變慢，因而讓 Exchange 變慢。

建議至少輸入一個有效 DNS 伺服器的 IP 位址。如果電腦上有一個以上的介面卡，請驗證所有介面卡都至少有一個有效的 DNS 伺服器 IP 位址。

若要在網路介面卡上設定 DNS IP 位址

  1. 在 [網路連線] 的適當「區域網路」介面卡上按一下滑鼠右鍵，然後再按 [內容]。

  2. 在 [一般] 索引標籤上，連按兩下 [Internet Protocol (TCP/IP)]。

  3. 在 [Internet Protocol (TCP/IP)] 頁面的 [一般] 索引標籤上，至少輸入一個有效 DNS 伺服器的 IP 位址，然後按一下 [確定]。

若需有關設定 DNS 以與 Exchange 搭配運作的詳細資訊，請參閱微軟知識庫文件 - 322856＜HOW TO：設定 Exchange Server 所需的 DNS＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322856)。


活動訊號連線有預設的閘道
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_NetworkAdapter Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 NetConnectionID 機碼值。若 NetConnectionID 機碼的值包含字串 Internal 或 HEART，表示該介面是叢集私人 (活動訊號) 網路。

Exchange Server Analyzer 也會查詢 Win32_NetworkAdapterConfiguration WMI 類別，以判定是否已設定 DefaultIPGateway 機碼的值。若已設定值，表示已設定此網路介面的預設閘道。

如果 Exchange Server Analyzer 發現在用於叢集活動訊號網路的網路介面上，已設定 DefaultIPGateway 機碼的值，就會顯示警告。

因為私人叢集網路是供內部叢集通訊使用，所以不需要設定預設閘道。若要消除可能的通訊問題，建議您從當作叢集私人網路介面卡的網路介面卡中移除所有不需要的網路流量。

若要更正此警告

  1. 開啟 [網路連線] 視窗。以滑鼠右鍵按一下 [網路上的芳鄰]，再按一下 [內容]；或者，若桌面上沒有顯示 [網路上的芳鄰]，依序按 [開始]、[程式集]、[附屬應用程式]、[通訊]、[網路連線]。

  2. 在 [網路連線] 視窗中，以滑鼠右鍵按一下用於私人網路的網路介面卡，再按一下 [內容]。

  3. 選取 [網際網路通訊協定 (TCP/IP)]，再按一下 [內容]。

  4. 在 [使用下列 IP 位址] 的區域中，刪除預設的閘道 IP 位址。

  5. 按 [確定] 兩次，儲存變更。

  6. 針對叢集中的每一個節點，重複步驟 1 到 5。

若需有關 Windows 伺服器叢集中之私人網路建議設定的詳細資訊，請參閱微軟知識庫文件 - 258750＜叢集伺服器上建議使用的私人「活動訊號」(Heartbeat) 設定＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)。


活動訊號連線有 DNS 搜尋位址
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_NetworkAdapter Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 NetConnectionID 機碼值。若 NetConnectionID 機碼的值包含字串 Internal 或 HEART，表示該介面是叢集私人 (活動訊號) 網路。

Exchange Server Analyzer 也會查詢 Win32_NetworkAdapterConfiguration WMI 類別，以判定是否已設定 DNSServerSearchOrder 機碼值。若已設定值，則表示已設定此網路介面的「網域名稱系統 (DNS)」搜尋位址。

如果 Exchange Server Analyzer 發現在用於叢集活動訊號網路的網路介面上，已設定 DNSServerSearchOrder 機碼值，就會顯示一則警告。

因為私人叢集網路是用於內部叢集通訊的，所以不需要設定任何 DNS 伺服器。若要消除可能的通訊問題，建議您從當作叢集私人網路介面卡的網路介面卡中移除所有不需要的網路流量。

若要更正此警告

  1. 開啟 [網路連線] 視窗。以滑鼠右鍵按一下 [網路上的芳鄰]，再按一下 [內容]；或者，若桌面上沒有顯示 [網路上的芳鄰]，請依序一下按 [開始]、[程式集]、[附屬應用程式]、[通訊] 及 [網路連線]。

  2. 在 [網路連線] 視窗中，以滑鼠右鍵按一下私人網路所使用的網路介面卡，然後按一下 [內容]。

  3. 選取 [Internet Protocol (TCP/IP)]，再按一下 [內容]。

  4. 按一下 [進階]。

  5. 在 [DNS] 索引標籤上，選取 DNS 伺服器位址，然後按一下 [移除]。針對所列出的每一個 DNS 伺服器位址，重複此步驟。

  6. 清除 [在 DNS 中登錄這個連線網路的位址] 和 [在 DNS 登錄中使用這個連線的 DNS 尾碼] 核取方塊。

  7. 按三次 [確定] 以儲存變更。

  8. 針對叢集中的每個節點，重複步驟 1 至 7。

若需有關 Windows 伺服器叢集中之私人網路建議設定的詳細資訊，請參閱微軟知識庫文件 - 258750＜叢集伺服器上建議使用的私人「活動訊號」(Heartbeat) 設定＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)。


活動訊號連線具有 WINS 地址
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_NetworkAdapter Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 NetConnectionID 機碼值。若 NetConnectionID 機碼的值包含字串 Internal 或 HEART，表示該介面是叢集專用 (活動訊號) 網路。

Exchange Server Analyzer 也會查詢 Win32_NetworkAdapterConfiguration WMI 類別，以判定是否已設定 WINSPrimaryServer 機碼的值。若已設定一個值，表示已設定此網路介面的主要「Windows 網際網路名稱服務 (WINS)」地址。

如果 Exchange Server Analyzer 在用於叢集活動訊號網路的網路介面上，發現已設定 WINSPrimaryServer 機碼的值，就會顯示警告。

因為私人叢集網路用於內部叢集通訊，所以您無需設定任何 WINS 伺服器，也無需使用 NetBIOS。若要消除可能的通訊問題，建議您從當作叢集私人網路介面卡的網路介面卡中移除所有不需要的網路流量。

若要更正此警告

  1. 開啟 [網路連線] 視窗。以滑鼠右鍵按一下 [網路上的芳鄰]，再按一下 [內容]；或者，若桌面上沒有顯示 [網路上的芳鄰]，依序按 [開始]、[程式集]、[附屬應用程式]、[通訊]、[網路連線]。

  2. 在 [網路連線] 視窗中，以滑鼠右鍵按一下用於專用網路的網路介面卡，再按一下 [內容]。

  3. 選取 [網際網路通訊協定 (TCP/IP)]，再按一下 [內容]。

  4. 按一下 [進階]。

  5. 在 WINS 索引標籤上，選取 WINS 地址，然後按一下 [移除]。針對所列出的 WINS 地址重複此步驟。

  6. 在 NetBIOS 設定區域中，選取 [停用 NetBIOS over TCP/IP]。

  7. 按三次 [確定] 以儲存變更。第一次按一下 [確定] 之後，您可能會收到下列提示。如果您看到此提示，請按一下 [是]："此連線有空的主要 WINS 位址。您要繼續嗎？"

  8. 針對叢集中的每個節點，重複步驟 1 至 7。

若需有關 Windows 伺服器叢集中之私人網路建議設定的詳細資訊，請參閱微軟知識庫文件 - 258750＜叢集伺服器上建議使用的私人「活動訊號」(Heartbeat) 設定＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)。


活動訊號連線是 TCP/IP 繫結順序中的第一個，不是公用連線
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢兩個 Microsoft Windows® Management Instrumentation (WMI) 類別來執行下列作業：

  • 查詢叢集中所有網路介面的 Win32_NetworkConfiguration WMI 類別，以判定 SettingID 機碼的值。SettingsID 機碼的值代表某個網路介面卡的 GUID。

  • 查詢 Win32_NetworkAdapter WMI 類別，以判定 Exchange 叢集中的私人網路通訊是使用哪些網路介面卡。私人網路是用於內部叢集通訊，包括叢集活動訊號通訊。

  • Exchange Server Analyzer 也會檢查下列登錄值，以判定網路介面卡的繫結順序：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Linkage\Bind

Bind 登錄值是多重字串值，其中包含依繫結順序排列的網路介面卡清單。清單中的第一個項目是第一個繫結的網路介面卡；第二個項目是繫結順序中的第二個介面網路介面卡；依此類推。

如果 Exchange Server Analyzer 判定叢集活動訊號網路介面卡是繫結順序中的第一個項目，就會顯示一則警告。

若要解決這個問題，請確定公用網路介面卡是繫結清單的第一個繫結 (位於清單頂端)。如果您有多個公用網路介面卡，請確定私人活動訊號網路介面卡排在最後面。如果活動訊號網路介面卡排在第一個，則可能無法正確安裝 Service Pack 及升級程式。

若要更正此警告

  1. 在 [網路連線] 視窗中，按一下 [進階]，再按 [進階設定]。

  2. 按一下 [介面卡及連結] 索引標籤。

  3. 在 [連線] 欄位中選取私人網路介面卡，並使用向下鍵將私人網路介面卡移到清單的底端。

  4. 針對叢集中的每一個節點，重複這些步驟。

若需有關為 Windows 伺服器叢集最佳化網路組態的詳細資訊，請參閱＜伺服器叢集：Windows 2000 及 Windows Server 2003 的網路組態最佳作法＞(英文) (http://go.microsoft.com/fwlink/?LinkId=34304)

若需有關正確叢集活動訊號組態的詳細資訊，請參閱微軟知識庫文件 - 258750＜叢集伺服器上建議使用的私人「活動訊號」(Heartbeat) 設定＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)。


活動訊號網路速度已設為自動感應/自動偵測
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_NetworkAdapter Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 NetConnectionID 機碼值。若 NetConnectionID 機碼的值包含字串 Internal 或 HEART，表示該介面是叢集專用 (活動訊號) 網路。

Exchange Server Analyzer 也會讀取下列登錄值，以判定用於叢集活動訊號網路之網路介面卡的連結速度與雙工設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\<NetworkCardDeviceID>\SpeedDuplex

此外，Exchange Server Analyzer 也會讀取下列登錄值，以判斷是否已啟用自動網路速度偵測：

HKLM\System\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\%NICDEVICEID%\Ndi\Params\SpeedDuplex\enum\0

如果 0 鍵值的值包含 AUTO 字串，則表示已啟用自動網路速度偵測。

如果 Exchange Server Analyzer 判定 SpeedDuplex 已設為 0，且已啟用叢集活動訊號網路的自動網路速度偵測，就會顯示警告。

伺服器叢集節點之間的通訊對於平順的叢集作業來說非常重要。如果您將多重速度 Ethernet 網路介面卡用於叢集通訊，並將介面卡設為自動偵測網路速度，則此介面卡可能會在叢集中造成問題。在偵測過程中，介面卡無法處理封包而必須將封包放入佇列中。有些介面卡可能會不小心地觸發自動偵測處理程序，偶爾會再次出現。因此，通訊會進入佇列並且會延遲。此種延遲可能會導致叢集節點無法立即接收重要的封包，且可能會造成叢集資源提前發生容錯移轉。建議手動將叢集中的活動訊號網路設為 10 MB 且半雙工。此組態將可提供足夠的頻寬及可靠的通訊。

若要更正此警告

  • 將活動訊號網路介面卡的連結速度設定為 10 MB，並將其雙工設定設為半雙工。由於每張網路介面卡的組態步驟都不同，請遵循硬體提供者的指示，正確地設定活動訊號網路。設定這些選項可能需要更新過的驅動程式。

若需有關 Windows 伺服器叢集中之私人網路建議設定的詳細資訊，請參閱微軟知識庫文件 - 258750＜叢集伺服器上建議使用的私人「活動訊號」(Heartbeat) 設定＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)。


主匯流排介面卡佇列深度已設為 32
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2006-10-11

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定安裝在 Exchange Server 電腦中的主匯流排介面卡 (HBA) 的佇列深度：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\elxstor\Parameters\Device\DriverParameter

如果 Exchange Server Analyzer 發現 DriverParameter 的值設為 32，就會顯示警告。

HBA 為儲存區域網路 (SAN) 的磁碟控制卡。HBA 佇列深度定義未完成佇列要求數目的上限。通常，DriverParameter 的建議值為 128。但是，此值並不是每個 Exchange Server 電腦中每個 HBA 之 HBA 佇列深度的最佳值。因此，您應該洽詢 HBA 製造商，以取得特定硬體的最佳值。

若要更正此警告

  1. 請連絡硬體製造商，以判定 HBA 的最佳設定。

  2. 使用 Microsoft Windows® System Monitor 公用程式來監視磁碟效能。

  3. 將您的 HBA 硬體更新為最新的韌體及驅動程式。

若需有關 Exchange Server 儲存設計及最佳化的詳細資訊，請參閱《Exchange Server 2003 儲存的最佳化》(英文) (http://go.microsoft.com/fwlink/?linkid=49324)。


熱新增記憶體組態
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2006-02-22

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Computer System Microsoft Windows® Management Instrumentation (WMI) 類別，以判定伺服器是否支援熱新增記憶體功能。Exchange Server Analyzer 也會查詢 Win32_OperatingSystem WMI 類別，以判定下列項目：

  • Boot.ini 檔中是否設定了 /3GB 選項。

  • 是否已載入實體位址擴充 (PAE) 核心。

  • 伺服器上執行哪一個版本的作業系統。

最後，Exchange Server Analyzer 會查詢下列登錄項目，以判定 DynamicMemory 組態參數是否存在，以及是否設定正確：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

如果 Exchange Server Analyzer 判定下列準則均為真，則會顯示錯誤訊息：

  • 電腦支援熱新增記憶體，且預設啟用此機能。

  • 電腦正在執行 Microsoft Windows Server™ 2003, Enterprise Edition 或 Windows Server 2003, Datacenter Edition。

  • 已載入 PAE 核心。

  • Boot.ini 中設定了 /3GB 選項。

  • DynamicMemory 登錄組態參數未設定、設定為 0 值，或設定為大於 3 的值。

附註：
如果電腦支援熱新增記憶體，但硬體製造商預設停用此機能，Exchange Server Analyzer 會顯示警告訊息而非錯誤訊息。

熱新增記憶體機能是 Windows Server 2003, Enterprise Edition 及 Windows Server 2003, Datacenter Edition 所引進，可讓系統管理員新增更多實體記憶體至電腦而無須重新啟動電腦。此功能對於支援記憶體密集的關聯式資料庫應用程式 (如 Microsoft SQL Server) 的伺服器相當有用。不過，因為 Exchange Server 無法使用 4GB 以上的實體記憶體，此功能對 Exchange Server 用處不大。

並非所有的電腦都支援熱新增記憶體。對於支援的電腦，有些硬體製造商預設啟用此機能，而另一些則在基本輸入輸出系統 (BIOS) 中提供控制。如果啟用了熱新增記憶體，在開機過程中，作業系統核心必須預先配置空間以處理未來可能新增至電腦的記憶體。因此，核心資源的配置是根據電腦的容量，而非實際安裝的記憶體。在執行 Microsoft Exchange Server 的電腦上，核心記憶體是珍貴的資源。因為核心可能會配置相當大量的資源給可能永遠不會安裝的記憶體，而且由於 Exchange Server 所用實體記憶體的本質，停用熱新增記憶體機能或許可以增加效能與延展性。啟用此功能可能會使分頁集區的大小上限比預期小許多。這可能會造成效能嚴重降低、系統鎖住，最後可能會造成服務中斷。

預期分頁集區大小上限的範例 (愈大愈好)：

  • 240 MB 具有 4 GB 實體記憶體的電腦，無熱新增記憶體支援或停用此支援

  • 210 MB 具有 4 GB 實體記憶體的電腦，但可支援最多 32 GB 的熱新增記憶體

  • 160 MB 具有 4 GB 實體記憶體的電腦，但可支援最多 64 GB 的熱新增記憶體

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要在執行 Windows Server 2003 Service Pack 1 (SP1) 或更新版本的電腦上更正此問題

  1. 設定下列登錄參數以停用熱新增記憶體功能：

    路徑

    HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

    值

    DynamicMemory

    類型

    REG_DWORD

    資料

    0x1
    附註：
    如果沒有超過在開機時間安裝的實體記憶體 (包括熱新增記憶體在內)，則此組態參數的值是以最大可定址實體記憶體數目 (GB) 來表示。將此值設為 1，核心程式便可保留總共 1 GB 的系統記憶體，或在開機時間安裝的實體記憶體總數量，以較大者為準。

  2. 重新啟動電腦
若要在執行 Windows Server 2003 但未安裝 SP1 的電腦上更正此問題

  • 與硬體廠商連絡，判定熱新增記憶體機能是否可以在 BIOS 中予以停用。

  • 如果熱新增記憶體無法透過硬體來控制，建議的方法是升級至 Windows Server 2003 SP1，然後按照此處的解決步驟來實作 DynamicMemory 參數。如果無法升級至 SP1，另一個方法是在 Boot.ini 檔中設定 /NOPAE 選項。設定此選項會強制電腦不要辨識大於 4 GB 上限的記憶體。請在執行 Windows Server 2003 SP1 之前電腦上使用此選項，但不應在執行 SP1 的電腦上使用它，因為這樣可能會非故意地停用資料執行防止 (DEP) 支援等新功能。

詳細資訊

若需有關 Windows Server 2003 中熱新增記憶體支援的詳細資訊，請參閱＜Windows Server 2003 中的熱新增記憶體支援＞(英文) (http://go.microsoft.com/fwlink/?linkid=57183)。


Internet SCSI Initiator 軟體已過時
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2006-04-03

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_SCSIController Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 iScsciPrt 驅動程式的 DriverName 機碼值。Exchange Server Analyzer 也會查詢 CIM_Datafile WMI 類別，以判定列在 iScsciPrt 驅動程式檔案中的 Version 機碼值。如果 Exchange Server Analyzer 發現 iScsciPrt 驅動程式 Version 機碼的子字串值小於 1748，則會顯示一則警告。

Internet Small Computer System Interface (iSCSI) 是一種以網際網路通訊協定為基礎 (IP 基礎) 的方式，其設計目的是要透過 TCP/IP 網路來傳送封裝在 IP 封包中的 Small Computer System Interface (SCSI) 命令。因為 iSCSI 是以 IP 為基礎，因此可透過區域網路 (LAN)、廣域網路 (WAN) 及網際網路，將資料傳輸至遠端存放位置。Microsoft Windows 作業系統會將 iSCSI 硬碟當作直接連接至 Exchange Server 電腦的硬碟，顯示在如 Exchange Server 2003 或 Exchange 2000 Server 的程式中。

當您部署含 iSCSI 的 Exchange Server 2003 或含 iSCSI 的 Exchange 2000 Server 時，Microsoft 建議您要謹慎。因為 iSCSI 會使用 SCSI 傳輸通訊協定透過 TCP/IP 網路來傳輸區塊資料，涉及網路可採用不是傳統認為是高速輸入/輸出路徑的元件。若要將輸送量放到最大，您必須設定 Exchange Server 以最大化快取處理活動，而且還必須測試以確認與 iSCSI 傳輸有關的延遲已縮到最小。除非您的儲存裝置廠商指示，否則也強烈建議您使用 Microsoft iSCSI Software Initiator 最新的可用組建。

若要更正此警告

  1. 從 Microsoft 下載中心 (英文) (http://go.microsoft.com/fwlink/?LinkId=33817) 下載最新版的 Microsoft iSCSI Software Initiator。

  2. 於 Microsoft 網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=40951) 檢閱版本資訊。

  3. 於 Microsoft 網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=40963) 檢閱《使用手冊》。

  4. 對電腦進行完整的備份。

  5. 套用最新的版本更新。

若需有關 Exchange 2000 Server 及 Exchange Server 2003 中之 iSCSI 支援的詳細資訊，請參閱微軟知識庫文件 - 839686＜Exchange Server 中的 iSCSI 技術元件支援＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839686)。

若需有關 iSCSI 技術及 Microsoft 對於 iSCSI 支援的詳細資訊，請參閱 Microsoft 網站「Microsoft 儲存技術 - iSCSI」(英文) (http://go.microsoft.com/fwlink/?LinkId=27514)。


已停用邏輯和實體磁碟效能計數器
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來判定是否已停用邏輯和實體磁碟效能計數器：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Perfdisk\Performance\Disable Performance Counters

如果 Exchange Server Analyzer 發現 Disable Performance Counters 的值存在且設定為 1，則會顯示警告。

執行 Microsoft Windows® 作業系統的伺服器電腦上已發行兩種磁碟相關的效能計數器：

  • Microsoft Win32® 效能子系統及 Windows Management Instrumentation (WMI) 所用的計數器。

  • 舊版應用程式使用的計數器，這些應用程式會呼叫 IOCTL_DISK_PERFORMANCE API 來擷取原始的計數器資訊。

  • 在預設的情況下，Microsoft Windows Server™ 2003 及 Windows 2000 Server 會啟用 Win32 及 WMI 使用的效能計數器。依預設，這兩種作業系統都會停用原始計數器。如果新增 Disable Performance Counters 登錄值 (依預設，不存在於任一作業系統上) 且其值設為 1，則會停用 Win32/WMI 效能計數器，而無法收集這些計數器的效能資料。

若要停用 Win32/WMI 計數器，最常用的方法是使用 Extensible Counter List 工具 (ExCtrLst.exe)。Windows 2000 Server 及 Windows Server 2003 Resource Kits 都提供此圖形化工具，系統管理員可以選擇啟用或停用發行效能物件。使用 ExCtrLst.exe 來停用效能物件時，會在登錄中新增 Disable Performance Counters 項目並設為值 1。如果後來又使用 ExCtrLst.exe 來重新啟用已停用的計數器，則會將 Disable Performance Counters 的值變更為 0 (請注意，這不會刪除 Disable Performance Counters 項目)。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\SYSTEM\CurrentControlSet\Services\Perfdisk\Performance

  3. 在右窗格中，對 Disable Performance Counters 連按兩下，並將其值設為 0。或者，您也可以刪除 Disable Performance Counters 項目來重新啟用計數器。

  4. 結束登錄編輯程式，然後重新啟動任何會收集效能資料的應用程式，使變更生效。

若需有關 ExCtrLst.exe 的詳細資訊，請參閱「Exctrlst.exe：Extensible Performance Counter List」(英文) (http://go.microsoft.com/fwlink/?linkid=34436)。


偵測到多重預設閘道
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_NetworkAdapterConfiguration Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 DefaultIPGateway 機碼的執行個體計數。每一張網路介面卡都會透過這個機碼來公佈已設定的預設閘道位址給 WMI。如果 Exchange Server Analyzer 判定已設定超過 1 個以上的 DefaultIPGateway 機碼執行個體，就會顯示警告。

此警告指出發現多張網路介面卡，且其中有多張網路介面卡已設定預設閘道。當使用多張網路介面卡且設定不同的預設閘道時，可能會與遠端網路上的電腦失去連線。此外，如果使用連結至不同網路子網路的多個預設閘道，則會在對 Microsoft Office Outlook® 2003 用戶端進行網域名稱系統 (DNS) 解析、簡易郵件傳送通訊協定 (SMTP) 郵件傳遞、輕量型目錄存取通訊協定 (LDAP) 查詢，以及發出新郵件通知時，造成已知的問題。這些問題大多會造成 Exchange Server 無法啟動，或無法傳送和接收郵件。

建議您從 Exchange Server 電腦的其中一張網路介面卡中移除所有預設閘道，只留下一個預設閘道。當 Exchange Server 電腦上也安裝 Microsoft Internet Security and Acceleration (ISA) Server 時，Exchange Server 電腦通常會成為多重主目錄電腦。即使在相同電腦上執行 Exchange Server 與 ISA Server，仍然不建議使用多重預設閘道。如果 Exchange Server 與 ISA Server 不是安裝在相同電腦上，則建議 Exchange Server 電腦不要使用多重主目錄。

若要更正此警告

  1. 開啟 [網路連線] 視窗。以滑鼠右鍵按一下 [網路上的芳鄰]，再按一下 [內容]；或者，若桌面上沒有顯示 [網路上的芳鄰]，依序按 [開始]、[程式集]、[附屬應用程式]、[通訊]、[網路連線]。

  2. 在 [網路連線] 視窗中，在包含您要移除的預設閘道項目之網路連線上按一下滑鼠右鍵，再按一下 [內容]。

  3. 選取 [網際網路通訊協定 (TCP/IP)]，再按一下 [內容]。

  4. 從 [預設閘道] 欄位中刪除 IP 位址。

  5. 按 [確定] 兩次，儲存變更。

  6. 請對含有預設閘道項目的所有其他網路連線重複這個處理程序，但您要保留的那一個項目除外。

若需有關在使用多個預設閘道之電腦上發生的問題的詳細資訊，請參閱微軟知識庫文件 - 159168＜多個預設閘道會導致連線問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159168)。

若需有關在多重主目錄電腦上設定預設閘道的詳細資訊，請參閱知識庫文件 - 157025＜多重主目錄電腦的預設閘道組態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=157025)。


分頁檔大小大於實體記憶體總數
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2007-07-30

Microsoft Exchange Analyzer 工具會查詢 Win32_PageFile Windows® Management Instrumentation (WMI) 類別，以判定 MaximumSize 機碼的值。此機碼代表目前設定的最大分頁檔大小。

Exchange Analyzer 也會查詢 Win32_ComputerSystem WMI 類別，以判定 TotalPhysicalMemory 機碼所設定的值。此值代表電腦上安裝的 RAM 數量。

如果 Exchange Analyzer 判定 Win32_PageFile MaximumSize 機碼的值比 Win32_ComputerSystem TotalPhysicalMemory 機碼的值大 1.5 倍，就會顯示錯誤。

分頁檔 (pagefile.sys) 是硬碟上的隱藏檔案，當系統的 RAM 不足時，Windows 會使用它來保留暫時資料。分頁檔又稱為分頁檔 (Paging file) 或交換檔。虛擬記憶體是由分頁檔與 RAM 組成。

建議的分頁檔大小等於 RAM 的 1.05 倍，最多可到 4,095 MB。這表示可為每個磁碟區設定的最大分頁檔大小為 4,095 MB。

附註：
若要防止分頁檔分散，建議您將分頁檔大小的初始值與最大值設為相同的值。如果降低分頁檔設定的初始值或最大值的大小，則必須重新啟動電腦，讓那些變更生效。增加值通常不需要重新啟動。
變更分頁檔設定

  1. 請依序按一下 [開始]、[控制台] 及 [系統]。

  2. 在 [進階] 索引標籤上，在 [效能] 下按一下 [設定]。

  3. 在 [效能選項] 對話方塊中，在 [進階] 索引標籤上，在 [虛擬記憶體] 下按一下 [變更]。

  4. 於 [磁碟機 [磁碟區標籤]] 之下，按一下包含您要變更之分頁檔的磁碟機。

  5. 在 [選擇磁碟的分頁檔大小] 之下，按一下 [自訂大小]，然後在 [起始大小 (MB)] 與 [最大值 (MB)] 欄位中輸入建議使用的分頁檔大小 (MB)，再按一下 [設定]。

若需分頁檔的相關資訊，請參閱下列 Microsoft 知識庫文章：

  • 197379＜設定分頁檔以在 Windows Server 2003、Windows 2000 及 Windows NT 中進行最佳化及復原＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379)

  • 307973＜HOW TO：在 Windows 中設定系統失敗和修復選項＞ (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307973)

  • 254649＜Windows Server 2003、Windows XP 和 Windows 2000 中記憶體傾印檔案選項的概觀＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=254649)

  • 241046＜無法在具有超過 4 GB RAM 的電腦上建立 Memory.dmp 檔＞ (http://go.microsoft.com/fwlink/?linkid=3052&kbid=241046)


次要 WINS 伺服器位址空白
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_NetworkAdapterConfiguration Microsoft Windows® Management Instrumentation (WMI) 類別，以判定是否已設定 WINSSecondaryServer 機碼值。如果在 Exchange 伺服器上此機碼的值是空白，則會顯示警告訊息。

Exchange Server 2003 和 Exchange 2000 Server 有幾項 NetBIOS 依存性。此外，執行 Microsoft Office Outlook 2003 之前版本 Microsoft Outlook® 的用戶端也需要 NetBIOS 名稱解析。例如，下列 Exchange 功能依靠 NetBIOS 名稱解析：

  • Exchange Server 2003 及 Exchange 2000 Server 安裝程式 (尤其是在叢集伺服器上)。

  • Exchange Server 2003 或 Exchange 2000 Server 電腦上的「Exchange 信箱合併精靈 (ExMerge)」。

  • 透過 Outlook Web Access 來變更 Exchange Server 2003 或 Exchange 2000 Server 信箱的密碼。

  • Exchange Server 2003 或 Exchange 2000 Server 電腦上的 [Exchange 系統管理員]。

根據您的組織的網路拓撲而定，或許您可以放心地忽略這則警告訊息。在由單一子網路 NetBIOS 組成的網路上，廣播通常就可以滿足 Exchange 部署的 NetBIOS 名稱解析需求。

在大型組織中，透過廣播的 NetBIOS 名稱解析可能無法正常運作。因為 NetBIOS 廣播通常不會跨越子網路，所以路由網路需要用另一種方法來解析 NetBIOS 名稱。解析該名稱的首選方法就是「Windows 網際網路名稱服務 (WINS)」。WINS 提供分散式資料庫來註冊及查詢您的網路中所使用電腦及群組的 NetBIOS 名稱的動態對應。WINS 會將 NetBIOS 名稱對應到 IP 位址，其設計目的是要解決路由環境中因為 NetBIOS 名稱解析所造成的問題。在使用 NetBIOS over TCP/IP 的路由網路中，WINS 是 NetBIOS 名稱解析的最佳選擇。

在沒有 WINS 的大型組織或子網路組織中，Exchange Server 2003 及 Exchange 2000 Server 作業和功能尚未充分測試過。Microsoft 需要在路由或分段式網路上執行 Exchange 的公司，使用 WINS 進行 NetBIOS 名稱解析。不支援在沒有 WINS 的路由或分段環境中執行 Exchange。

建議您部署至少包含兩個 WINS 伺服器的容錯 WINS 環境。WINS 伺服器可以作為用戶端的主要 WINS 伺服器或次要 WINS 伺服器。主要和次要 WINS 伺服器的差異在於用戶端連絡它們時的優先順序。主要 WINS 伺服器是用戶端執行其 NetBIOS 名稱服務作業時所連絡的第一台伺服器。只有當主要 WINS 伺服器無法滿足要求時，用戶端才會聯繫次要 WINS 伺服器，例如當用戶端發出要求，卻無法使用主要 WINS 伺服器，或當無法解析用戶端名稱時。

如果主要 WINS 伺服器沒有滿足要求，則用戶端會對次要 WINS 伺服器發出相同要求。如果為用戶端設定兩個以上的 WINS 伺服器，則用戶端會嘗試其他次要 WINS 伺服器，直到嘗試過清單列出的所有次要 WINS 伺服器，或其中一個 WINS 伺服器順利回應要求為止。用戶端使用次要 WINS 伺服器之後，會定期嘗試切回主要 WINS 伺服器來發出未來的名稱服務要求。

最佳作法是在路由網路或分段網路的 Exchange 伺服器電腦上設定至少一個次要 WINS 伺服器。

若要更正此警告

  1. 開啟 [網路連線]。

  2. 在要設定的網路連線上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 在 [一般] 標籤上 (用於區域連線) 或 [網路] 標籤上 (用於所有其他連線)，按一下 [Internet Protocol (TCP/IP)]，然後按一下 [內容]。

  4. 按一下 [進階]、按一下 [WINS] 標籤，然後按一下 [新增]。

  5. 在 [TCP/IP WINS 伺服器] 中，鍵入次要 WINS 伺服器的 IP 位址，再按一下 [新增]。

  6. 對於要新增的其他每一個 WINS 伺服器 IP 位址重複步驟 4 和 5，然後按一下 [確定]。您可以使用方向鍵來變更 WINS 伺服器的喜好設定順序。

  7. 請確定已選取 [啟用 NetBIOS over TCP/IP]。

  8. 按一下 [確定] 以儲存變更。

若需有關 Exchange 的 NetBIOS 名稱解析需求的詳細資訊，請參閱微軟知識庫文件 - 837391＜Exchange Server 2003 與 Exchange 2000 Server 需要 NetBIOS 名稱解析才能完整運作＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=837391)。


伺服器是虛擬 PC
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2007-03-28

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Exchange Server 電腦的Model 機碼值。如果此機碼的值包含 Virtual Machine 這個字串，就會顯示一則錯誤。

出現 Virtual Machine 這個字串表示 Exchange Server 電腦是在 Microsoft Virtual PC 200x 虛擬電腦內執行。Virtual PC 200x 是一個軟體虛擬化解決方案，它可讓您在一個工作站同時執行多個 PC 型作業系統。Microsoft 不支援在虛擬機器或模擬器上，執行任何 Microsoft Exchange Server 版本。這項規則涵蓋在 Microsoft Virtual Server 200x、Microsoft Virtual PC 200x，或任何協力廠商的虛擬機器程式上執行的 Exchange Server。Microsoft Exchange Server 平台的設計和測試都只針對實體硬體來執行，特別是在 Windows Server Catalog (http://go.microsoft.com/fwlink/?linkid=17219) 中列出的那些硬體平台。

若要更正此錯誤

  1. 從在 Virtual PC 200x 之下執行的 Exchange Server 中將信箱移到非虛擬的 Exchange Server 電腦。

  2. 視需要，將任何公用資料夾重新歸屬，並且轉移虛擬 Exchange 伺服器持有的角色。

  3. 從虛擬機器解除安裝 Exchange，以從 Exchange 基礎結構及 Active Directory® 目錄服務中進行解除及移除。

若需在虛擬環境中執行 Exchange Server 電腦之支援的相關資訊，請參閱 Microsoft 知識庫文章 320220＜在硬體虛擬化軟體中執行之 Exchange Server 2003 的支援原則＞(英文)(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320220)。

若需 Microsoft Virtual PC 的相關資訊，請參閱 Microsoft Virtual PC 首頁 (英文) (http://go.microsoft.com/fwlink/?linkid=34663)。


此磁碟報告錯誤
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_DiskDrive Microsoft Windows® Management Instrumentation (WMI) 類別，以判定每個磁碟的 Status 機碼值。如果 Exchange Server Analyzer 判斷任何磁碟的 Status 機碼值不等於 OK，則會顯示錯誤訊息。

Status 機碼提供磁碟物件目前的狀態。可定義各種可操作及不可操作的狀態。可操作的狀態包含：

  • 確定

  • 降級

  • 預測失敗 (指某個元件 (例如，具 SMART 功能的硬碟)，雖可正常運作，但預測不久後會失敗)。

  • 不可操作的狀態包含：

  • 錯誤

  • 正在啟動

  • 正在停止

  • 服務 (在磁碟鏡像重建、重新載入使用者權限清單，或執行其他系統管理工作期間，可以套用這個)。

Status 機碼繼承自 CIM_ManagedSystemElement WMI 類別，其包含下列值：

  • 確定

  • 錯誤

  • 降級

  • 未知

  • 預測失敗

  • 正在啟動

  • 正在停止

  • 服務

  • 已經過負荷測試

  • 無法恢復

  • 沒有連絡人

  • 遺失 Comm

Microsoft 通常不提供特定硬體廠商的磁碟失敗之疑難排解文件。

若要更正此錯誤

  1. 驗證所有磁碟及電纜連線，等待 10 分鐘，然後檢查 Status 的值。

  2. 如果傳回的值不是維護模式值 (例如，此值不等於「服務」，您就應該遵循硬碟製造商所建議的磁碟疑難排解步驟)。在某些情況下，硬碟製造商可能會有疑難排解軟體，您可安裝此軟體來分析問題。

若需與 Exchange 相關的一般儲存資訊，請參閱 Microsoft 下載中心的＜Microsoft Exchange 2000 Server 的儲存解決方案＞(英文) (http://go.microsoft.com/fwlink/?LinkId=1715)。

若需與 Microsoft Windows Server™ 2003 相關的一般儲存資訊，請參閱 Microsoft Windows Server 2003 TechCenter 的＜Windows Server 2003 儲存服務＞(英文) (http://go.microsoft.com/fwlink/?LinkId=33811)。

若需與 Windows 2000 Server 相關的一般儲存資訊，請參閱 Windows 2000 網站的＜Windows 2000 儲存服務＞(英文) (http://go.microsoft.com/fwlink/?LinkId=33812)。


此 Exchange 伺服器有超過 8 個處理器
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 NumberOfProcessors 目前的值。如果 Exchange Server Analyzer 發現 NumberOfProcessors 的值大於 8，就會顯示警告。然而，如果此伺服器已設定為使用 Intel 超執行緒技術，則可放心地忽略此警告。「超執行緒技術」讓多執行緒的軟體能夠平行執行執行緒。超執行緒技術要求電腦系統具備支援超執行緒技術的 Intel Pentium 4 處理器，以及支援超執行緒技術的晶片組、BIOS 及作業系統。

Exchange 2000 Server 與 Exchange Server 2003 只能在電腦上有效地使用 8 個處理器。特別是 Microsoft Exchange Information Store 服務已針對最多 8 個處理器進行最佳化。

在有超過 8 個處理器的電腦上，建議您使用硬體分割功能，將電腦分割為多部具有 8 個處理器的電腦，或分割為多部具有 4 個處理器的電腦。此外，您可以將 Microsoft Exchange Information Store 處理程序 (Store.exe) 的 CPU 相關性設為僅限 8 個處理器。

只要透過 CPU 相關性或透過硬體分割功能，將 Microsoft Exchange Information Store 處理程序限制為 8 個處理器後，建議您升級至最新可用的 Service Pack 與 Exchange 更新彙總套件。如果您正在執行 Exchange Server 2003，這格外重要。

之前，當後端伺服器中的處理器數目增加至超過 4 個時，Exchange 伺服器效能顯示最低限度的改善。有超過 8 個處理器時，效能提高至最極限，而有時候效能會降低。增加其他處理器所造成的效能衰退，會隨著用於最近電腦上的處理器類型而變得更加顯著。使用 Exchange Server 2003 Service Pack 1，其他處理器的延展性改善許多。已啟用超執行緒後，有 8 個處理器的伺服器即可提供比有 4 個處理器的伺服器多 50% 的效能提升。目前在許多情況下都適合將 8 個處理器的電腦用於後端伺服器。雙處理器的伺服器則仍建議用於前端伺服器。

如前面所述，如果此 Exchange Server 電腦採用「超執行緒技術」，則可放心地忽略此警告訊息。

更正未使用超執行緒技術的系統上的這項警告訊息

  1. 套用 Exchange 最新的 Service Pack 與更新彙總套件，您可以從「Exchange Server 2003 下載」網站 (英文) (http://go.microsoft.com/fwlink/?linkid=25097) 下載這些程式。

  2. 將 Microsoft Exchange Information Store 服務 (Store.exe) 的 CPU 相關性設為 8 個 CPU，或使用硬體分割功能來建立有 8 個處理器的 Exchange 伺服器。請連絡硬體製造商，以取得如何進行此作業的詳細資料。

若需有關 Exchange Server 資源延展性的詳細資訊，請參閱微軟知識庫文件 - 827281＜Exchange 2000 及 Exchange 2003 的 CPU 與記憶體延展性＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827281)。

若需詳細資訊，請參閱知識庫文件 - 271088＜XGEN：最佳化具有六個或八個處理器的 Windows 2000 Active Directory 伺服器以與 Exchange 2000 一起執行＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=271088)。

若需有關超執行緒技術的詳細資訊，請參閱 Intel 網站 (英文) (http://www.intel.com/info/hyperthreading)。

附註：
網址可能會變更，因此您可能無法連線到此處提到的網站。


此 Exchange 伺服器有超過 4 GB 的記憶體
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2006-06-20

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定每部 Exchange Server 電腦的 TotalPhysicalMemory 機碼值。

如果 Exchange Server Analyzer 發現 TotalPhysicalMemory 的值大於 4294967296 但小於 6442450944，則會顯示一則警告。

如果 Exchange Server Analyzer 發現 TotalPhysicalMemory 的值大於 6442450944，則會顯示一則錯誤。

若 TotalPhysicalMemory 的值大於 4294967296，表示 Exchange Server 電腦安裝超過 4 GB 的記憶體，若 TotalPhysicalMemory 的值大於 6442450944，表示 Exchange Server 電腦安裝超過 6 GB 的記憶體。在具有 4 GB 或更多實體記憶體的電腦上，Exchange Server 不會使用超過 3 GB 的記憶體。因此，如果電腦只是固定用於執行 Exchange Server，安裝超過 4 GB 的記憶體沒有任何好處。

更重要的是，有越多的實體 RAM，就需要越多的作業系統核心位址項目來執行必要的虛擬作業，以進行實體對應。這樣可減少系統的可用系統分頁表項目 (PTE) 及可用的分頁集區記憶體，而這兩項都是會造成系統不穩定的因素。

例如，具有 8 GB 實體 RAM 的電腦將會擁有少於 3,000 的可用系統分頁表項目 (PTE)，比起只具有 4 GB 實體 RAM 的電腦，會減少 30 MB 的最大分頁集區大小。

建議您遵循下列其中一種解決方案：

  • 將系統的記憶體數量縮小為 4 GB

  • 設定 Boot.ini 檔案中的 BurnMemory 參數，將實體記憶體減少到 4 GB，如本文件稍後所述。

此外，如果您正在執行需要額外記憶體的多個應用程式，則可執行 Windows Hotfix，以便在有 4 GB 以上的可用 RAM 時，協助避免可能發生的 Exchange 資訊儲存庫失敗。請注意，建議的最佳作法是讓某部電腦只執行 Exchange Server。若需有關 Hotfix 的詳細資訊，請參閱 Microsoft 知識庫文章 - 834628＜在 Windows Server 2003 型電腦上啟用 PAE 後資料損毀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052)。

若要更正此警告

  1. 在 [Windows 檔案總管] 中，瀏覽至系統磁碟分割區。

  2. 如果您看不到 boot.ini 檔，可能的原因是 [資料夾選項] 設為 [隱藏保護的作業系統檔案]。如果是這種情形，請在 [Windows 檔案總管] 中，依序按一下 [工具]、[資料夾選項] 及 [檢視] 索引標籤。清除 [隱藏保護的作業系統檔案 (建議使用)] 核取方塊。出現警告框提示時，按一下 [是]。

  3. 可以在 [檔案總管] 中看到 boot.ini 檔時，以滑鼠右鍵按一下該檔案，再按一下 [開啟檔案]，然後選擇 [記事本] 來開啟該檔案。

  4. 在 [Operating Systems] 區段中，將下列參數新增至啟動列：/BURNMEMORY=<Value in MB>

    例如：

    如果安裝了 6GB 的實體記憶體，請使用 /BURNMEMORY=2048 將可用的記憶體減少到 4GB。如果安裝了 8GB 的實體記憶體，請使用 /BURNMEMORY=4096。

  5. 儲存變更並結束 [記事本]。

  6. 重新啟動 Exchange Server 電腦，讓變更生效。

若需可用於 Boot.ini 檔案中的參數之相關資訊，請參閱下列 Microsoft 知識庫文章：

  • 833721: ＜Windows XP 和 Windows Server 2003 Boot.ini 檔可用的參數選項＞(http://go.microsoft.com/fwlink/?linkid=3052)

  • 102873: ＜BOOT.INI 與 ARC 路徑的命名慣例與用法＞(http://go.microsoft.com/fwlink/?linkid=3052)


此邏輯磁碟的可用空間低於 3 GB
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2007-03-14

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_LogicalDisk Microsoft Windows® Management Instrumentation (WMI) 類別，以判定將 Win32_LogicalDisk DriveType 機碼設定為 3 (表示本機磁碟) 之磁碟的 FreeSpace 機碼值。如果 Exchange Server 電腦的本機磁碟的 FreeSpace 機碼值小於 3 GB，就會顯示一則警告。建議包含信箱之 Exchange Server 電腦的所有磁碟都隨時保持至少 50% 的可用容量。

請務必確認有足夠的磁碟容量。當資料庫磁碟用盡空間時，資料庫就會離線。當交易記錄檔磁碟用盡空間時，就會使該儲存群組中的所有資料庫離線。您通常很難迅速提供額外空間，而執行離線壓縮以收回空間又會耗費很長的時間。大致說來，用盡磁碟空間會導致一或多個資料庫的可用性中斷一段時間，而這段時間通常會超過大部份的復原時間目標 (RTO)。

若要更正此警告

  1. 刪除此磁碟中不需要的檔案以釋放磁碟空間。

  2. 如果可用空間小於 50% 的磁碟包含可以安全移至另一個磁碟的資料 (如信箱或 Windows 分頁檔)，請執行要移動該資料所需的步驟。

  3. 增加 Exchange Server 電腦的磁碟容量。

若需移動 Exchange Server 2003 信箱的相關資訊，請參閱 Microsoft 知識庫文章 821829＜在 Exchange Server 2003 中移動信箱＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)。

若需有關在 Exchange 2000 Server 及 Exchange Server 5.5 之間移動信箱的詳細資訊，請參閱知識庫文章 328810＜在伺服器之間移動信箱＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810)。

若需有關在 Exchange Server 2003 上使用系統原則設定信箱限制的詳細資訊，請參閱知識庫文章 822938＜HOW TO：使用系統原則設定 Exchange Server 2003 的信箱儲存限制＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822938)。

若需有關在 Exchange 2000 Server 上使用系統原則設定信箱限制的詳細資訊，請參閱知識庫文章 319130＜HOW TO：使用系統原則設定 Exchange 2000 的信箱儲存限制＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319130)。

若需相關資訊


這個掛接點的可用空間小於 3 GB
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Volume Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Exchange Server 電腦所使用之磁碟區掛接點的 FreeSpace 機碼值。如果 FreeSpace 的值除以 1,000,000,000 後四捨五入的整數小於 4，就會顯示一則警告。

這個警告表示磁碟區掛接點的可用儲存空間小於 3 GB。若 Exchange Server 2003 是安裝在執行 Microsoft Windows Server™ 2003 Enterprise Edition 或 Windows Server 2003 Datacenter Edition 的電腦上，則在 Exchange Server 2003 中，磁碟區掛接點 (亦稱為 NTFS 檔案系統連接點) 會被當作叢集組態中的資料儲存位置來支援。使用「NTFS 磁碟區掛接點」功能可讓您免除 26 個磁碟機字母的限制。使用磁碟區掛接點可讓您將目標磁碟分割區轉移或裝載到其他實體磁碟上的資料夾中。磁碟區掛接點可直接供 Exchange Server 2003 之類的程式使用。

下列情況不支援掛接點：

  • 將掛接點當做 Exchange Server 2003 二進位檔案的儲存位置來使用時。

  • 與執行 Microsoft Exchange 2000 Server 或更舊版本的 Exchange 叢集搭配使用時。

  • 與執行 Microsoft Windows 2000 Server 或更舊版本的 Windows 叢集搭配使用時。

不論 Exchange Server 所使用的磁碟區是本機實體磁碟、邏輯磁碟區或磁碟區掛接點，Exchange Server 實作的最佳方式，就是所有磁碟機上至少都要有 50% 的可用空間。根據經驗，Microsoft 建議至少要有 25% 至 30% 的可用磁碟空間供 Exchange 維護作業使用，例如會使用資料庫公用程式 (如 Eseutil 和 Isinteg) 來執行的工作。此外，針對某些維護作業 (例如離線磁碟重組)，Microsoft 建議您要有磁碟重組數量一倍以上的可用空間。例如，如果您要磁碟重組 1 GB 資料庫，則至少要有 1 GB 的可用磁碟空間。

從安全性和可用性的角度來看，具備大量的可用磁碟空間亦有它的益處。若是大範圍地阻斷服務攻擊、訊息迴圈或病毒發作，由於郵件傳輸、交易記錄活動等等的數量增加，都會造成磁碟空間的過度耗用。

若要更正此警告

  1. 檢查各區域，以收回磁碟空間並增加可用的空間。

  2. 如果磁碟空間極低，則您應考慮將資料移至其他 Exchange Server 電腦或沒有空間限制的 Exchange 虛擬伺服器上。若沒有這麼做，設定信箱的限制對於管理磁碟的使用率也是很有用的。

若需有關在 Exchange Server 2003 叢集中使用磁碟區掛接點的詳細資訊，請參閱微軟知識庫文件 - 318458＜Windows Server 2003 型系統上 Exchange Server 2003 叢集的磁碟區掛接點支援＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=318458)。

若需有關在 Windows Server 2003 叢集中使用磁碟區掛接點的詳細資訊，請參閱知識庫文件 - 280297＜如何在叢集伺服器上設定磁碟區掛接點＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=280297)。


此網路介面卡已啟用 DHCP
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_NetworkAdapterConfiguration Microsoft Windows® Management Instrumentation (WMI) 類別，以判定是否已設定 DHCPEnabled 內容的值。如果在 Exchange 伺服器上此內容的值已設為 1，就會顯示一則錯誤。

在已啟用 DHCP 的網路介面卡上執行 Exchange 為可支援的組態。但是，並不建議使用此組態。在已啟用 DHCP 的電腦上執行 Exchange 並非最佳的作法，因為如果 DHCP 伺服器失敗或中斷，Exchange 可能會停止傳遞郵件，或甚至發生失敗。

建議您將所有執行 Exchange 的電腦設定為使用靜態 IP 位址。

若需有關設計 Windows TCP/IP 網路的詳細資訊，請造訪「Microsoft TechNet 網路」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=33819)。


主要 WINS 伺服器位址空白
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_NetworkAdapterConfiguration Microsoft Windows® Management Instrumentation (WMI) 類別，以判定是否已設定 WINSPrimaryServer 機碼值。如果 Exchange Server Analyzer 在 Exchange 伺服器上發現此機碼的值空白，則會顯示警告。

Exchange Server 2003 和 Exchange 2000 Server 有幾項 NetBIOS 依存性。此外，執行比 Microsoft Office Outlook 2003 更早之 Microsoft Outlook® 版本的用戶端也需要 NetBIOS 名稱解析。例如，下列 Exchange 功能依靠 NetBIOS 名稱解析：

  • Exchange Server 2003 及 Exchange 2000 Server 安裝程式 (尤其是在叢集伺服器上)。

  • Exchange Server 2003 或 Exchange 2000 Server 電腦上的「Exchange 信箱合併精靈 (ExMerge)」。

  • 透過 Outlook Web Access 來變更 Exchange Server 2003 或 Exchange 2000 Server 信箱的密碼。

  • Exchange Server 2003 或 Exchange 2000 Server 電腦上的 [Exchange 系統管理員]。

根據您的組織的網路拓撲而定，或許您可以放心地忽略這則警告訊息。在由單一子網路組成的網路上，NetBIOS 廣播通常就可以滿足 Exchange 部署的 NetBIOS 名稱解析需求。

在大型組織中，透過廣播的 NetBIOS 名稱解析可能無法正常運作。因為 NetBIOS 廣播通常不會跨越子網路，所以路由網路需要用另一種方法來解析 NetBIOS 名稱。解析該名稱的首選方法就是「Windows 網際網路名稱服務 (WINS)」。WINS 提供分散式資料庫來註冊及查詢您的網路中所使用電腦及群組的 NetBIOS 名稱的動態對應。WINS 會將 NetBIOS 名稱對應到 IP 位址，其設計目的是要解決路由環境中的 NetBIOS 名稱解析所引發的問題。在使用 NetBIOS over TCP/IP 的路由網路中，WINS 是 NetBIOS 名稱解析的最佳選擇。

在沒有 WINS 的大型組織或子網路組織中，Exchange Server 2003 及 Exchange 2000 Server 作業和功能尚未充分測試過。Microsoft 需要在路由或分段式網路上執行 Exchange 的公司，使用 WINS 進行 NetBIOS 名稱解析。不支援在沒有 WINS 的路由或分段環境中執行 Exchange。

建議部署至少包含兩個 WINS 伺服器的容錯 WINS 環境。WINS 伺服器可以作為用戶端的主要 WINS 伺服器或次要 WINS 伺服器。主要和次要 WINS 伺服器的差異只在於用戶端連絡它們的優先順序。主要 WINS 伺服器是用戶端執行其 NetBIOS 名稱服務作業時所連絡的第一台伺服器。只有當主要 WINS 伺服器無法滿足要求時，用戶端才會聯繫次要 WINS 伺服器，例如當用戶端發出要求，卻無法使用主要 WINS 伺服器，或當無法解析用戶端名稱時。

如果主要 WINS 伺服器沒有滿足要求，則用戶端會對次要 WINS 伺服器發出相同要求。如果為用戶端設定兩個以上的 WINS 伺服器，則用戶端會嘗試其他次要 WINS 伺服器，直到嘗試過清單列出的所有次要 WINS 伺服器，或其中一個 WINS 伺服器順利回應要求為止。用戶端使用次要 WINS 伺服器之後，會定期嘗試切回主要 WINS 伺服器來發出未來的名稱服務要求。

最佳作法是在路由網路或分段網路的 Exchange 伺服器電腦上設定至少一個次要 WINS 伺服器。

若要更正此警告

  1. 開啟 [網路連線]。

  2. 在要設定的網路連線上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 在 [一般] 標籤上 (用於區域連線) 或 [網路] 標籤上 (用於所有其他連線)，按一下 [Internet Protocol (TCP/IP)]，然後按一下 [內容]。

  4. 按一下 [進階]、按一下 [WINS] 標籤，然後按一下 [新增]。

  5. 在 [TCP/IP WINS 伺服器] 中，鍵入 WINS 伺服器的 IP 位址，再按一下 [新增]。

  6. 對於要新增的其他每一個 WINS 伺服器 IP 位址重複步驟 4 和 5，然後按一下 [確定]。您可以使用方向鍵來變更 WINS 伺服器的喜好設定順序。

  7. 請確定已選取 [啟用 NetBIOS over TCP/IP]。

  8. 按一下 [確定] 以儲存變更。

若需有關 Exchange 之 NetBIOS 名稱解析需求的詳細資訊，請參閱知識庫文件 - 837391＜Exchange Server 2003 與 Exchange 2000 Server 需要 NetBIOS 名稱解析才能完整運作＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=837391)。


偵測到虛擬伺服器
Microsoft Exchange Server Analyzer - 文章 > 硬體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Model 機碼值是否設為 Virtual Machine。

Exchange Server Analyzer 也會檢查下列登錄值是否存在：

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

如果 Exchange Server Analyzer 發現 Model 機碼包含 Virtual Machine 字串，而且上述登錄分支已存在，就會顯示錯誤。

Model 機碼的值為 Virtual Machine，表示 Exchange Server 電腦目前是以來賓虛擬機器的身分在 Microsoft Virtual Server 2005 或 Microsoft Virtual PC 2004 上執行。因為上述登錄分支僅由 Virtual Server 2005 所建立，因此存在此登錄分支表示 Exchange Server 電腦目前是以來賓虛擬機器的身分在 Virtual Server 2005 中執行。

Microsoft 不支援在虛擬機器或模擬器上，執行任何 Microsoft Exchange Server 版本。這項規則涵蓋在 Microsoft Virtual Server 2005、Microsoft Virtual PC 2004，或任何協力廠商的虛擬機器程式上執行的 Exchange Server。Microsoft Exchange Server 平台的設計和測試都只針對實體硬體來執行，特別是在 Microsoft Windows Server Catalog (英文) (http://go.microsoft.com/fwlink/?linkid=17219) 中列出的那些硬體平台。

若要更正此錯誤

  1. 將在 Virtual Server 2005 上執行的 Exchange Server 之信箱，移到非虛擬 Exchange Server 電腦上。

  2. 視需要，將任何公用資料夾重新歸屬，並且轉移虛擬 Exchange 伺服器持有的角色。

  3. 從虛擬機器解除安裝 Exchange，以從 Exchange 基礎結構及 Active Directory® 目錄服務中進行解除及移除。

若需有關移動信箱的詳細資訊，請參閱下列微軟知識庫文件：

  • 822892＜Exchange 2003 中移動信箱的改良功能＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975＜XADM：移動信箱方法間的差異＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

若需有關 Microsoft Virtual Server 2005 的詳細資訊，請參閱 Microsoft Virtual Server 2005 網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=34938)。

若需有關 Microsoft Virtual PC 2004 的詳細資訊，請參閱 Microsoft Virtual PC 2004 網站 (英文) (http://go.microsoft.com/fwlink/?linkid=34663)。


網路
Microsoft Exchange Server Analyzer - 文章 >

主題上次修改日期： 2005-11-18

本節的文章提供 Microsoft® Exchange Server Analyzer 工具對網路所評估的詳細資料。除此之外，這些文章還說明您可以採取哪些動作，以解決 Exchange Server Analyzer 發現的網路相關錯誤、警告及非預設組態。


DNS 'Host' 記錄似乎遺失了
Microsoft Exchange Server Analyzer - 文章 > 網路 >

主題上次修改日期： 2006-04-13

Microsoft® Exchange Server Analyzer 工具會在 DNS 伺服器上執行網域名稱系統 (DNS) 查閱，以擷取 Exchange 伺服器的主機 (A) 記錄。如果 DNS 查閱作業沒有傳回 IP 位址，Exchange Server Analyzer 即會顯示主機 (A) 記錄似乎遺失的警告。

來自 Exchange Server 2003 電腦的主機 (A) 記錄的 DNS 查閱可能會失敗，原因如下：

  • DNS 伺服器可能由於網路錯誤或其他原因而關閉或沒有回應。

  • DNS 伺服器可能遺失 Exchange Server 2003 的主機 (A) 記錄，因為該記錄可能無法使用、可能不正確，或 DNS 伺服器可能未設定為允許動態主機記錄更新。

當 DNS 伺服器關閉時，可能發生郵件路由延遲及其他服務失敗。

附註：
Exchange Server 2003 依賴網路中本機及外部 SMTP 型郵件系統兩者的主機名稱解析。主機名稱解析主要根據 DNS，而 DNS 是重要的網路服務。DNS 伺服器若發生失敗，會阻止使用者尋找您的郵件系統。若沒有 DNS，Active Directory 及 Exchange Server 2003 組織將無法運作。郵件用戶端將查詢 DNS 以尋找內部資源，例如網域控制站及信箱伺服器。另一方面，當 Exchange Server 2003 傳送郵件至網際網路時，Exchange Server 2003 會依賴 DNS，為目錄查閱及外部簡易郵件傳送通訊協定 (SMTP) 主機擷取網域控制站的網際網路通訊協定 (IP) 位址。

若要修正問題，請驗證 DNS 伺服器正在執行中，而且已登錄主機 (A) 記錄。

驗證 DNS 伺服器在線上且主機記錄存在

  1. 執行下列一或多個步驟，驗證 DNS 伺服器正在執行中：

    • 在 DNS 伺服器上使用 DNS 系統管理程式來檢查 DNS 伺服器狀態。

    • 重新啟動 DNS 伺服器。若需相關資訊，請參閱＜啟動、停止、暫停或重新啟動 DNS 伺服器＞(英文) (http://go.microsoft.com/fwlink/?LinkId=62999)。

    • 使用 nslookup 檢查 DNS伺服器回應。若需相關資訊，請參閱＜使用 nslookup 命令驗證 DNS 伺服器回應＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63000)。

  2. 使用 nslookup 驗證主機 (A) 記錄存在於 DNS 伺服器上。若需相關資訊，請參閱＜驗證 A 資源記錄存在於 DNS 中＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63001)。

  3. 如果主機 (A) 資源記錄不存在，請手動新增或修改 A 資源記錄，或設定 DNS 伺服器以允許動態記錄更新。

    • 手動新增 A 資源記錄。若需相關資訊，請參閱＜新增資源記錄至 DNS 區域＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63002)。

    • 手動修改 A 資源記錄。若需相關資訊，請參閱＜修改現有的資源記錄＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63014)。

    • 啟用 DNS 伺服器以允許動態主機記錄更新。若需相關資訊，請參閱微軟知識庫文件 - 816592＜如何在 Windows Server 2003 中設定 DNS 動態更新＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592)。
  • 若需 Exchange Server 2003 如何使用 DNS 來解析外部 IP 位址的相關資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》(http://go.microsoft.com/fwlink/?LinkId=47579) 中的＜Exchange Server 2003 的傳輸依存性＞(英文)。

  • 若需 DNS 名稱解析的相關資訊，請參閱微軟知識庫文件 - 322856＜HOW TO：設定 Exchange Server 所需的 DNS＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)。

  • 若需 DNS 疑難排解的相關資訊，請參閱＜DNS 的疑難排解＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63003)。

若需 Exchange Server 2003 系統監視的相關資訊，請參閱《MOM 2000 SP1 的 Exchange Server 2003 管理套件手冊》中的＜利用 Exchange Server 2003 管理套件的系統監視＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47573)。

  • 若需主機 (A) 資源記錄的相關資訊，請參閱＜管理資源記錄＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63004)。


DNS 回應在 UDP 及 TCP 之間有不同
Microsoft Exchange Server Analyzer - 文章 > 網路 >

主題上次修改日期： 2007-03-16

Microsoft Exchange Analyzer 工具會查詢 Win32_NetworkAdapterConfiguration Microsoft Windows Management Instrumentation (WMI) 類別，以取得 DNSServerSearchOrder 屬性。這個屬性是伺服器 IP 位址的陣列，用於查詢網域名稱系統 (DNS) 伺服器。

在擷取主要 DNS 伺服器的位址之後，Exchange Analyzer 會嘗試對每一個 Active Directory 目錄服務伺服器已設定的 DNS 伺服器使用 DNS 查詢。透過使用自訂物件處理器來建立此連線，該處理器會同時執行 (TCP) 傳輸控制通訊協定及使用者資料包通訊協定 (UDP) 名稱解析要求。

如果 TCP 及 UDP 名稱解析要求都成功，則 Exchange Analyzer 會比較成功的要求所傳回的回應。如果 TCP 及 UDP 查詢所傳回的回應不相同，則 Exchange Analyzer 會顯示警告。

這個警告指出可能有 DNS 伺服器組態問題，影響了郵件流程效能。

簡易郵件傳送通訊協定 (SMTP) 是 Exchange Server 的原生郵件通訊協定，可用來進行郵件提交與郵件傳輸。這表示用戶端使用 SMTP 來傳送郵件，而 Exchange 伺服器使用 SMTP 來傳遞郵件和郵件資料。

為了讓 Exchange Server 能夠透過 SMTP 服務傳遞輸出網際網路郵件，會以下列方法來使用 DNS：

  1. 內部使用者傳送郵件給遠端網域中的收件者。

  2. 為了判定收件者在本機還是遠端，寄件者的 Exchange 伺服器上的 SMTP 虛擬伺服器會使用內部傳輸功能，向通用類別目錄伺服器查詢收件者的地址。如果郵件上的收件者地址不在收件者原則中，則不是儲存在 Active Directory 中。因此，Exchange 會判定該郵件的目的地是遠端網域。

  3. 必要時，Exchange 伺服器會將郵件傳遞至適當的 SMTP 虛擬伺服器。

  4. SMTP 虛擬伺服器會使用其 IIS Metabase 資訊，來判定將郵件傳遞到遠端網域的方法。

  5. 接著，Exchange 伺服器上的 SMTP 虛擬伺服器會執行下列兩個動作之一：

    • 使用 DNS 來查閱目標網域的 IP 位址，然後嘗試傳遞郵件。

    • 將郵件轉寄到負責 DNS 解析及郵件傳遞的智慧主機。

若要更正此警告，請參考 Microsoft 知識庫文章 820284＜如果 Server OS 是 Windows Server 2003，則郵件可能不能傳送至特定網域＞(機器翻譯) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=820284) 中的指導。

若需 DNS 與 Exchange Server 的相關資訊，請參閱下列 Microsoft 知識庫文章與網路廣播：

  • 322856＜HOW TO：設定 Exchange Server 所需的 DNS＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237＜XCON：Windows 2000 與 Exchange 2000 SMTP 使用 TCP DNS 查詢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759＜Support WebCast:Microsoft Exchange 2000 Server：傳輸中的 DNS 疑難排解＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


DNS 伺服器正在執行 Virtual Server 2005 (含以來賓身分安裝的 Exchange Server)
Microsoft Exchange Server Analyzer - 文章 > 網路 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Model 機碼值是否設為 Virtual Machine。

Exchange Server Analyzer 也會檢查下列登錄值是否存在：

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

此外，Exchange Server Analyzer 也會查詢 Win32_Services WMI 類別，以判定網域名稱系統服務 (DNS) 是否在執行 Microsoft Virtual Server 2005 的實體電腦上執行。

如果 Exchange Server Analyzer 發現 Model 機碼含有 Virtual Machine 字串、存在上述登錄分支，且執行 DNS，就會顯示一則錯誤。

Model 機碼的值為 Virtual Machine 表示 Exchange Server 電腦目前是以來賓虛擬機器的身分在 Virtual Server 2005 或 Microsoft Virtual PC 2004 上執行。因為上述登錄分支僅由 Virtual Server 2005 所建立，因此存在此登錄分支表示 Exchange Server 電腦目前是以來賓虛擬機器的身分在 Virtual Server 2005 中執行。

Microsoft 不支援在虛擬機器或模擬器上，執行任何 Microsoft Exchange Server 版本。對於在 Virtual Server 2005、Virtual PC 2004 或任何協力廠商虛擬機器程式上執行的 Exchange Server，這個情況會成立。Microsoft Exchange Server 平台的設計和測試都只針對實體硬體來執行，特別是在 Windows Server Catalog (http://go.microsoft.com/fwlink/?linkid=17219) 中列出的那些硬體平台。

另外，在執行網域名稱系統的電腦上以 Virtual Server 2005 來賓身分執行 Exchange 並不是最佳作法，原因是在此狀況下，它不允許在服務間有足夠的備援。

若要更正此錯誤

  1. 將在 Virtual Server 2005 上執行的 Exchange Server 之信箱，移到非虛擬 Exchange Server 電腦上。

  2. 視需要，將任何公用資料夾重新歸屬，並且轉移虛擬 Exchange 伺服器持有的角色。

  3. 從虛擬機器解除安裝 Exchange，以從 Exchange 基礎結構及 Active Directory® 目錄服務中進行解除及移除。

若需有關移動信箱的詳細資訊，請參閱下列微軟知識庫文件：

  • 822892＜Exchange 2003 中移動信箱的改良功能＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975＜XADM：移動信箱方法間的差異＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

若需有關支援在虛擬環境中執行之 Exchange Server 電腦的詳細資訊，請參閱知識庫文件 - 320220＜虛擬機器或模擬機器上的 Exchange Server 支援界限＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)。

若需有關 Microsoft Virtual Server 2005 的詳細資訊，請參閱 Microsoft Virtual Server 2005 網站 (英文) (http://go.microsoft.com/fwlink/?linkid=34938)。

若需有關 Microsoft Virtual PC 2004 的詳細資訊，請參閱 Microsoft Virtual PC 2004 網站 (英文) (http://go.microsoft.com/fwlink/?linkid=34663)。


外部 DNS 伺服器的回應在 UDP 及 TCP 之間有不同
Microsoft Exchange Server Analyzer - 文章 > 網路 >

主題上次修改日期： 2007-03-16

Microsoft Exchange Analyzer 工具會查詢 Active Directory 目錄服務，以判定每個 Exchange Server 物件之 protocolCfgSMTPServer 類別中的 msExchSmtpExternalDNSServers 屬性值。msExchSmtpExternalDNSServers 屬性的值 (如果有設定) 會指定簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器執行個體所使用之外部網域名稱系統 (DNS) 伺服器的位址。

擷取主要外部 DNS 伺服器的位址之後，Exchange Analyzer 就會嘗試對每個 Active Directory 目錄服務伺服器的已設定 DNS 伺服器進行 DNS 查詢。這個連線是使用自訂物件處理器所建立，而該處理器會執行傳輸控制通訊協定 (TCP) 及使用者資料包通訊協定 (UDP) 名稱解析要求。

如果 TCP 及 UDP 名稱解析要求都成功，則 Exchange Analyzer 會比較成功的要求所傳回的回應。如果 TCP 及 UDP 查詢所傳回的回應不相同，則 Exchange Analyzer 會顯示警告。

這個警告表示可能有外部 DNS 伺服器組態問題影響到郵件流程效能。

SMTP 是 Exchange Server 的原生郵件通訊協定，用來進行郵件提交與郵件傳輸。這表示用戶端使用 SMTP 來傳送郵件，而 Exchange 伺服器使用 SMTP 來傳遞郵件和郵件資料。

為了讓 Exchange Server 能夠透過 SMTP 服務傳遞輸出網際網路郵件，會以下列方法來使用 DNS：

  1. 內部使用者傳送郵件給遠端網域中的收件者。

  2. 為了判定收件者在本機還是遠端，寄件者的 Exchange 伺服器上的 SMTP 虛擬伺服器會使用內部傳輸功能，向通用類別目錄伺服器查詢收件者的地址。如果郵件上的收件者地址不在收件者原則中，則不是儲存在 Active Directory 中。因此，Exchange 會判定該郵件的目的地是遠端網域。

  3. 必要時，Exchange 伺服器會將郵件傳遞至適當的 SMTP 虛擬伺服器。

  4. SMTP 虛擬伺服器會使用其 IIS Metabase 資訊，來判定將郵件傳遞到遠端網域的方法。

  5. 接著，Exchange 伺服器上的 SMTP 虛擬伺服器會執行下列兩個動作之一：

    • 使用 DNS 來查閱目標網域的 IP 位址，然後嘗試傳遞郵件。

    • 將郵件轉寄到負責 DNS 解析及郵件傳遞的智慧主機。

若要解決這個警告，請參閱 Microsoft 知識庫文章 820284＜如果伺服器作業系統是 Windows Server 2003，則郵件可能無法傳遞到特定網域＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=820284) (機器翻譯)。

若需 DNS 與 Exchange Server 的相關資訊，請參閱下列 Microsoft 知識庫文章與網路廣播：

  • 322856＜HOW TO：設定 Exchange Server 所需的 DNS＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237＜XCON：Windows 2000 與 Exchange 2000 SMTP 使用 TCP DNS 查詢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759＜Support WebCast:Microsoft Exchange 2000 Server：傳輸中的 DNS 疑難排解＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


Network Bytes Total/sec 超出閾值
Microsoft Exchange Server Analyzer - 文章 > 網路 >

主題上次修改日期： 2006-02-13

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Network Interface 效能物件的 Bytes Total/sec 效能計數器的資料，以分析效能資料。

Bytes Total/sec 效能計數器會顯示網路介面卡處理資料位元組的速率。此計數器包括所有應用程式及檔案資料，此外還包括通訊協定資訊，如封包標頭。Bytes Total/sec 效能計數器是 Network Interface\Bytes Received/sec 和 Network Interface/Bytes Sent/sec 的總和。

Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。若是每秒 100 MB (Mbps) 的網路介面卡，Bytes Total/sec 效能計數器的值應低於 7 MB/秒。若是 1000 Mbps 的網路介面卡，Bytes Total/sec 效能計數器的值應低於 70 MB/秒。如果 Bytes Total/sec 超出網路頻寬的 7%，Exchange Server Analyzer 就會顯示錯誤。

此錯誤通常表示伺服器遇到無回應時段，而造成郵件流程減緩或停止。另外，連接到此伺服器的 Microsoft Outlook® 用戶端可能會看到 [RPC 取消要求] 對話方塊。

以下是此錯誤的一些可能原因：

  • 電腦上的網路介面卡 (NIC) 無法支援網路基礎結構所支援的最大頻寬。

  • 伺服器上的負載太多。

  • 病毒或 SPAM 造成網路使用模式突然升高。

若要解決此錯誤，

  • 如果 NIC 不支援您網路的最大頻寬，請升級 NIC 以支援更快的頻寬。

  • 減少伺服器上的負載。您可以將信箱移到含有較少信箱的伺服器上，來達到此目的。如果有必要，請在環境中加入其他的 Exchange 伺服器。

  • 如果您懷疑不尋常的高負載不是因為伺服器上有太多信箱所造成，請試著識別不尋常高負載的來源，並停止它。

  • 考慮下列文章中的最佳作法：

    • 若需網路頻寬考量的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》的＜瞭解 Exchange 效能＞中的＜網路效能＞(http://go.microsoft.com/fwlink/?LinkId=47576) 。

    • 若需疑難排解網路問題的相關資訊，請參閱《Microsoft Exchange Server 2003 效能疑難排解》中的＜排除網路繫結問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


已啟用網路介面卡小組合作 (NIC Teaming)
Microsoft Exchange Server Analyzer - 文章 > 網路 >

主題上次修改日期： 2006-10-16

Microsoft® Exchange Server Analyzer 工具會查詢所有繫結到 TCP/IP 通訊協定的網路介面卡 (NIC) 的 Win32_NetworkAdapter Microsoft Windows® Management Instrumentation (WMI) 類別。

然後，Exchange Server Analyzer 會查詢下列登錄分支，以判定那些介面卡的 TeamAdapters 機碼是否存在：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\%NICDEVICEID%\

如果 Exchange Server Analyzer 判定在正在分析的伺服器上有一或多個 NIC 具有 TeamAdapters 機碼，Exchange Server Analyzer 就會顯示警告。

此警告指出在所分析的 Exchange 伺服器上已啟用 NIC 小組合作。雖然 NIC 小組合作通常不是郵件流程問題，但應該仔細確認是否已利用最新的可用 NIC 驅動程式正確設定小組合作。

若要更正此問題：

  • 如果已啟用 NIC 小組合作的伺服器發生郵件流程問題，請暫時停用小組合作，以查看是否已解決郵件流程問題。

  • 將 NIC 驅動程式更新為 NIC 製造商的最新可用驅動程式。

  • 嚴格遵循 NIC 製造商的小組合作組態建議。

若需有關 NIC 小組合作的詳細資訊，請參閱下列 Microsoft 知識庫文章：

  • 278431＜使用小組合作介面卡與網路負載平衡搭配可能會導致網路問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=278431)。

  • 814607＜Microsoft 支援具有協力廠商系統元件的伺服器叢集＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=814607)。


網路輸出封包超出閾值
Microsoft Exchange Server Analyzer - 文章 > 網路 >

主題上次修改日期： 2006-02-13

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來查詢效能計數器物件。效能資料收集引擎可收集來自 Network Interface 效能物件的 Packet Outbound errors 效能計數器的資料，以分析效能資料。

Packet Outbound errors 效能計數器指出因為錯誤而無法傳輸的外寄封包數。Packet Outbound errors 效能計數器的值應該為 0。如果 Exchange Server Analyzer 判定 Packet Outbound errors 效能計數器的值大於 0，就會顯示錯誤。

此錯誤通常表示伺服器遇到無回應時段，而造成郵件流程減緩或停止。另外，連接到此伺服器的 Microsoft Outlook® 用戶端可能會看到 [RPC 取消要求] 對話方塊。

此錯誤很可能是因為故障或損壞的網路介面卡 (NIC) 而造成。

若要解決此錯誤，您必須判斷外寄封包錯誤的原因，然後更正問題。如果外寄封包錯誤是因為 NIC 故障造成，請立即更換介面卡。

考慮下列文章中的最佳作法：

  • 若需網路頻寬考量的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》的＜瞭解 Exchange 效能＞中的＜網路效能＞(http://go.microsoft.com/fwlink/?LinkId=47576) 。

  • 若需疑難排解網路問題的相關資訊，請參閱《Microsoft Exchange Server 2003 效能疑難排解》中的＜排除網路繫結問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


Network Output Queue Length 超出閾值
Microsoft Exchange Server Analyzer - 文章 > 網路 >

主題上次修改日期： 2007-02-13

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Network Interface 效能物件的 Output Queue Length 效能計數器的資料，以分析效能資料。

Output Queue Length 效能計數器以封包數目顯示輸出封包佇列的長度。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的最大值。如果平均值超過 10，Exchange Server Analyzer 就會顯示錯誤。

此錯誤通常表示伺服器遇到無回應時段，而造成郵件流程減緩或停止。另外，連接到此伺服器的 Outlook 用戶端可能會看到 [RPC 取消要求] 對話方塊。

以下是此錯誤的一些可能原因：

附註：
在某些情況下，於執行 Microsoft Windows 2000 Server 作業系統的電腦上，Output Queue Length 效能計數器可能會持續地顯示大於零的隨機值。若需有關 Output Queue Length 效能可能顯示隨機值的情況，以及如何更正此情況的詳細資訊，請參閱 Microsoft 知識庫文章 834940＜在 Windows 2000 中，系統監視器可能會對 Output Queue Length 效能計數器顯示高值＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834940)。
  • 電腦上的網路介面卡 (NIC) 無法支援網路基礎結構所支援的最大頻寬。

  • 伺服器上的負載太多。

  • 病毒或 SPAM 造成網路使用模式突然升高。

若要解決此錯誤，請採取下列步驟：

  • 如果 NIC 不支援您網路的最大頻寬，請升級 NIC 以支援更快的頻寬。

  • 減少伺服器上的負載。您可以將信箱移到含有較少信箱的伺服器上，來達到此目的。如果有必要，請在環境中加入其他的 Exchange 伺服器。

  • 如果您懷疑不尋常的高負載不是因為伺服器上有太多信箱所造成，請試著識別不尋常高負載的來源，並停止它。

考慮下列文章中的最佳作法：

  • 若需網路頻寬考量的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》的＜瞭解 Exchange 效能＞中的＜網路效能＞(http://go.microsoft.com/fwlink/?LinkId=47576) 。

  • 若需疑難排解網路問題的相關資訊，請參閱《Microsoft Exchange Server 2003 效能疑難排解》中的＜排除網路繫結問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


主要 DNS 無法回應 UDP 連線
Microsoft Exchange Server Analyzer - 文章 > 網路 >

主題上次修改日期： 2007-03-16

Microsoft Exchange Analyzer 工具會查詢 Win32_NetworkAdapterConfiguration Microsoft Windows Management Instrumentation (WMI) 類別，以取得 DNSServerSearchOrder 屬性。這個屬性是伺服器 IP 位址的陣列，用於查詢 DNS 伺服器。

擷取主要網域名稱系統 (DNS) 伺服器的位址之後，Exchange Analyzer 就會嘗試對每個 Active Directory 目錄服務伺服器的已設定 DNS 伺服器進行 DNS 查詢。透過使用自訂物件處理器來建立此連線，該處理器會執行使用者資料包通訊協定 (UDP) 名稱解析要求並分析結果。

如果 UDP 名稱解析要求失敗，Exchange Analyzer 就會顯示警告。

此警告表示主要 DNS 伺服器可能已經設定為只接受 TCP 查詢。

簡易郵件傳送通訊協定 (SMTP) 是 Exchange Server 的原生郵件通訊協定，可用來進行郵件提交與郵件傳輸。這表示用戶端使用 SMTP 來傳送郵件，而 Exchange 伺服器使用 SMTP 來傳遞郵件和郵件資料。

為了讓 Exchange Server 能夠透過 SMTP 服務傳遞輸出網際網路郵件，會以下列方法來使用 DNS：

  1. 內部使用者傳送郵件給遠端網域中的收件者。

  2. 為了判定收件者在本機還是遠端，寄件者的 Exchange 伺服器上的 SMTP 虛擬伺服器會使用內部傳輸功能，向通用類別目錄伺服器查詢收件者的地址。如果郵件上的收件者地址不在收件者原則中，則不是儲存在 Active Directory 中。因此，Exchange 會判定該郵件的目的地是遠端網域。

  3. 必要時，Exchange 伺服器會將郵件傳遞至適當的 SMTP 虛擬伺服器。

  4. SMTP 虛擬伺服器會使用其 IIS Metabase 資訊，來判定將郵件傳遞到遠端網域的方法。

  5. 接著，Exchange 伺服器上的 SMTP 虛擬伺服器會執行下列兩個動作之一：

    • 使用 DNS 來查閱目標網域的 IP 位址，然後嘗試傳遞郵件。

    • 將郵件轉寄到負責 DNS 解析及郵件傳遞的智慧主機。

依預設，DNS 伺服器會接聽 UDP 通訊埠 53 上的通訊 (如名稱解析查詢)。

如果 Exchange Server 上的 SMTP 服務設定為只傳送 UDP 查詢，而主要 DNS 伺服器設定為只接受 TCP 查詢，則會發生郵件路由錯誤，並對郵件流程效能產生不良影響。

若要解決此警告，請執行下列動作：

  1. 確定 DNS 伺服器已啟動，並已連線至網路。

  2. 確認網路防火牆或封包篩選器並未刻意封鎖已知的 DNS 通訊埠 (如 UDP 通訊埠 53)。

  3. 驗證主要 DNS 伺服器設定為支援 UDP 名稱解析查詢。

若需 DNS 與 Exchange Server 的相關資訊，請參閱下列 Microsoft 知識庫文章與網路廣播：

  • 322856＜HOW TO：設定 Exchange Server 所需的 DNS＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237＜XCON：Windows 2000 與 Exchange 2000 SMTP 使用 TCP DNS 查詢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759＜Support WebCast:Microsoft Exchange 2000 Server：傳輸中的 DNS 疑難排解＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


無法連線主要 DNS 伺服器
Microsoft Exchange Server Analyzer - 文章 > 網路 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_NetworkAdapterConfiguration Microsoft Windows® Management Instrumentation (WMI) 類別，以取得 DNSServerSearchOrder 屬性。這個屬性是伺服器 IP 位址的陣列，用於查詢 DNS 伺服器。擷取主要 DNS 伺服器的位址之後，Exchange Server Analyzer 會開啟 TCP 通訊端連線，連接伺服器上的通訊埠 53。此連線是使用自訂物件處理器建立的，如果連線成功，該處理器會傳回特定字串。如果 Exchange Server Analyzer 收到的傳回字串中沒有 53 Available 部分，就會顯示一則警告。

此警告指出伺服器未回應 TCP 通訊埠 53 上的連線嘗試。DNS 伺服器預設會在 TCP 通訊端 53 上接聽通訊 (如名稱解析查詢)。

如果無法存取主要 DNS 伺服器，且您正在執行 Exchange 2000 Server，則郵件傳遞速度會變慢。當主要 DNS 伺服器無法使用時，Microsoft 會提供支援的 Hotfix 來更正郵件傳遞到外部收件者的速度比預期慢的問題。連絡 Microsoft 產品支援服務以取得 Hotfix。

此外，您可能要疑難排解主要 DNS 伺服器無法使用的原因，或變更 Exchange 伺服器上的 DNS 設定來使用其他 DNS 伺服器以進行名稱解析。

若要更正此警告

  1. 確定 DNS 伺服器已啟動，並已連線至網路。

  2. 使用 PING 命令來判定是否可與 DNS 伺服器連線。

若需有關在無法存取主要 DNS 伺服器時郵件傳遞速度緩慢，以及如何取得此問題之 Hotfix 的詳細資訊，請參閱微軟知識庫文件 - 829722＜無法存取主要 DNS 伺服器時，Exchange 2000 中的郵件傳遞速度緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829722)。

若需 DNS 與 Exchange Server 的相關資訊，請參閱下列微軟知識庫文件與網路廣播：

  • 322856＜HOW TO：設定 Exchange Server 所需的 DNS＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237＜XCON:Windows 2000 與 Exchange 2000 SMTP 使用 TCP DNS 查詢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759＜Support WebCast:Microsoft Exchange 2000 Server：傳輸中的 DNS 疑難排解＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


主要的外部 DNS 伺服器無法回應 TCP 連線
Microsoft Exchange Server Analyzer - 文章 > 網路 >

主題上次修改日期： 2007-03-16

Microsoft Exchange Analyzer 工具會查詢 Active Directory 目錄服務，以判定每個 Exchange Server 物件之 protocolCfgSMTPServer 類別中的 msExchSmtpExternalDNSServers 屬性值。msExchSmtpExternalDNSServers 屬性的值 (如果有設定) 會指定簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器執行個體所使用之外部網域名稱系統 (DNS) 伺服器的位址。

擷取主要外部 DNS 伺服器的位址之後，Exchange Server Analyzer 會開啟 TCP 通訊端連線，連接伺服器上的通訊埠 53。此連線是使用自訂物件處理器建立的，如果連線成功，該處理器會傳回特定字串。如果 Exchange Server Analyzer 收到的傳回字串中沒有 53 Available，則會顯示警告。

此警告指出伺服器未回應 TCP 通訊埠 53 上的連線嘗試。DNS 伺服器預設會在 TCP 通訊端 53 上接聽通訊 (如名稱解析查詢)。

SMTP 是 Exchange Server 的原生郵件通訊協定，用來進行郵件提交與郵件傳輸。這表示用戶端使用 SMTP 來傳送郵件，而 Exchange 伺服器使用 SMTP 來傳遞郵件和郵件資料。

為了讓 Exchange Server 能夠透過 SMTP 服務傳遞輸出網際網路郵件，會以下列方法來使用 DNS：

  1. 內部使用者傳送郵件給遠端網域中的收件者。

  2. 為了判定收件者在本機還是遠端，寄件者的 Exchange 伺服器上的 SMTP 虛擬伺服器會使用內部傳輸功能，向通用類別目錄伺服器查詢收件者的地址。如果郵件上的收件者地址不在收件者原則中，則不是儲存在 Active Directory 中。因此，Exchange 會判定該郵件的目的地是遠端網域。

  3. 必要時，Exchange 伺服器會將郵件傳遞至適當的 SMTP 虛擬伺服器。

  4. SMTP 虛擬伺服器會使用其 IIS Metabase 資訊，來判定將郵件傳遞到遠端網域的方法。

  5. 接著，Exchange 伺服器上的 SMTP 虛擬伺服器會執行下列兩個動作之一：

    • 使用 DNS 來查閱目標網域的 IP 位址，然後嘗試傳遞郵件。

    • 將郵件轉寄到負責 DNS 解析及郵件傳遞的智慧主機。

如果無法存取主要外部 DNS 伺服器，且您正在執行 Exchange 2000 Server，則郵件傳遞速度會變慢。當主要外部 DNS 伺服器無法使用時，Microsoft 會提供支援的 Hotfix 來更正郵件傳遞到外部收件者的速度比預期慢的問題。連絡 Microsoft 產品支援服務以取得 Hotfix。

此外，您可能要疑難排解主要外部 DNS 伺服器無法使用的原因，或變更 Exchange 伺服器上的 DNS 設定來使用其他 DNS 伺服器以進行名稱解析。

若要更正這個警告，請執行下列動作：

  1. 確定已經啟動外部 DNS 伺服器，且可以從 Exchange 網路連至該伺服器。

  2. 使用 PING 命令來判定是否可與外部 DNS 伺服器連線。

若需無法存取主要 DNS 伺服器時郵件傳遞速度緩慢，以及如何取得此問題之 Hotfix 的相關資訊，請參閱 Microsoft 知識庫文章 829722＜無法存取主要 DNS 伺服器時，Exchange 2000 中的郵件傳遞速度緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829722)。

若需 DNS 與 Exchange Server 的相關資訊，請參閱下列知識庫文章與網路廣播：

  • 322856＜HOW TO：設定 Exchange Server 所需的 DNS＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237＜XCON：Windows 2000 與 Exchange 2000 SMTP 使用 TCP DNS 查詢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759＜Support WebCast:Microsoft Exchange 2000 Server：傳輸中的 DNS 疑難排解＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


主要的外部 DNS 無法回應 UDP 連線
Microsoft Exchange Server Analyzer - 文章 > 網路 >

主題上次修改日期： 2007-03-16

Microsoft Exchange Analyzer 工具會查詢 Active Directory 目錄服務，以判定每個 Exchange Server 物件之 protocolCfgSMTPServer 類別中的 msExchSmtpExternalDNSServers 屬性值。msExchSmtpExternalDNSServers 屬性的值 (如果有設定) 會指定簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器執行個體所使用之外部網域名稱系統 (DNS) 伺服器的位址。

擷取主要外部 DNS 伺服器的位址之後，Exchange Analyzer 就會嘗試對每個 Active Directory 目錄服務伺服器的外部已設定 DNS 伺服器進行 DNS 查詢。透過使用自訂物件處理器來建立此連線，該處理器會執行使用者資料包通訊協定 (UDP) 名稱解析要求並分析結果。

如果 UDP 名稱解析要求失敗，Exchange Analyzer 就會顯示警告。

此警告表示主要外部 DNS 伺服器可能已經設定為只接受 TCP 查詢。

SMTP 是 Exchange Server 的原生郵件通訊協定，用來進行郵件提交與郵件傳輸。這表示用戶端使用 SMTP 來傳送郵件，而 Exchange 伺服器使用 SMTP 來傳遞郵件和郵件資料。

為了讓 Exchange Server 能夠透過 SMTP 服務傳遞輸出網際網路郵件，會以下列方法來使用 DNS：

  1. 內部使用者傳送郵件給遠端網域中的收件者。

  2. 為了判定收件者在本機還是遠端，寄件者的 Exchange 伺服器上的 SMTP 虛擬伺服器會使用內部傳輸功能，向通用類別目錄伺服器查詢收件者的地址。如果郵件上的收件者地址不在收件者原則中，則不是儲存在 Active Directory 中。因此，Exchange 會判定該郵件的目的地是遠端網域。

  3. 必要時，Exchange 伺服器會將郵件傳遞至適當的 SMTP 虛擬伺服器。

  4. SMTP 虛擬伺服器會使用其 IIS Metabase 資訊，來判定將郵件傳遞到遠端網域的方法。

  5. 接著，Exchange 伺服器上的 SMTP 虛擬伺服器會執行下列兩個動作之一：

    • 使用 DNS 來查閱目標網域的 IP 位址，然後嘗試傳遞郵件。

    • 將郵件轉寄到負責 DNS 解析及郵件傳遞的智慧主機。

依預設，DNS 伺服器會接聽 UDP 通訊埠 53 上的通訊 (如名稱解析查詢)。

如果 Exchange 伺服器上的 SMTP 服務設定為只傳送 UDP 查詢，而主要外部 DNS 伺服器設定為只接受 TCP 查詢，則會發生郵件路由錯誤，並對郵件流程效能產生不良影響。

若要解決此警告，請執行下列動作：

  1. 確定已經啟動外部 DNS 伺服器，且該伺服器可連至網路。

  2. 確認網路防火牆或封包篩選器並未刻意封鎖已知的 DNS 通訊埠 (如 UDP 通訊埠 53)。

  3. 驗證主要外部 DNS 伺服器設定為支援 UDP 名稱解析查詢。

若需 DNS 與 Exchange Server 的相關資訊，請參閱下列 Microsoft 知識庫文章與網路廣播：

  • 322856＜HOW TO：設定 Exchange Server 所需的 DNS＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237＜XCON：Windows 2000 與 Exchange 2000 SMTP 使用 TCP DNS 查詢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759＜Support WebCast:Microsoft Exchange 2000 Server：傳輸中的 DNS 疑難排解＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


主要 WINS 伺服器沒有回應
Microsoft Exchange Server Analyzer - 文章 > 網路 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_NetworkAdapterConfiguration Microsoft Windows® Management Instrumentation (WMI) 類別，以取得 WINSPrimaryServer 屬性。此屬性是 Exchange Server 電腦之主要 Windows 網際網路名稱服務 (WINS) 伺服器的 IP 位址。擷取主要 WINS 伺服器的位址之後，Exchange Server Analyzer 會開啟 TCP 通訊端連線，連接伺服器上的通訊埠 137。此連線是使用自訂物件處理器建立的，如果連線成功，該處理器會傳回特定字串。如果 Exchange Server Analyzer 收到的傳回字串中沒有 137 Available 部分，就會顯示一則警告。

這個警告表示伺服器未回應 TCP 通訊埠 137 上的連線嘗試。在預設的情況下，WINS 伺服器會在 TCP 通訊端 137 上接聽通訊 (如名稱解析查詢)。

如果無法存取主要 WINS 伺服器，且您正在執行 Exchange Server，則郵件傳遞速度會變慢，特別是在大型組織中。您應該疑難排解主要 WINS 伺服器無法使用的原因，或變更 Exchange 伺服器上的 WINS 設定，以使用其他 WINS 伺服器進行名稱解析。

若要更正此警告

  1. 請確定已啟動 WINS 伺服器，且已連線至網路。

  2. 使用 PING 命令來判定是否可與 WINS 伺服器連線。

若需有關 Exchange 2000 Server 及 Exchange Server 2003 為何需要 WINS 的詳細資訊，請參閱微軟知識庫文件 - 837391＜Exchange Server 2003 與 Exchange 2000 Server 需要 NetBIOS 名稱解析才能完整運作＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=837391)。


通訊埠 389 未回應
Microsoft Exchange Server Analyzer - 文章 > 網路 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 Active Directory 中所有網域控制站的 dNSHostName 屬性值。擷取網域控制站名稱之後，Exchange Server Analyzer 會開啟 TCP 通訊端連線，連接每一台網域控制站上的通訊埠 389。此連線是使用自訂物件處理器建立的，如果連線成功，該處理器會傳回特定字串。如果 Exchange Server Analyzer 收到的傳回字串中沒有 389 Available 部份，則會顯示警告訊息。

此警告指出網域控制站未回應 TCP 通訊埠 389 上的連線嘗試。TCP 通訊埠 389 是「輕量型目錄存取通訊協定 (LDAP)」通訊的預設通訊埠。

如果收到此警告訊息，可能是因為 Exchange Server Analyzer 與網域控制站之間的連線有問題。Exchange Server Analyzer 查詢網域控制站時，該網域控制站未適當服務 LDAP 要求的原因很多。

若要更正此警告

  1. 請確認執行該工具的帳戶有權去查詢網域控制站。在執行網域控制站的網域中，您需要使用者等級的權限。您可以在 Exchange Server Analyzer 所包含的說明檔中，找到有關執行該工具所需權限的詳細資訊。若要開啟說明檔，請先開啟 Exchange Server Analyzer，按一下 [說明]，再按 [Microsoft Exchange Server Analyzer 工具說明]。

  2. 確認執行 Exchange Server Analyzer 的電腦與未回應的網域控制站之間沒有防火牆或通訊埠限制。

  3. 請確認網域控制站有連線至網路而且正常運作。

若需有關疑難排解 Active Directory 連線問題的詳細資訊，請參閱微軟知識庫文件 - 816103＜HOW TO：使用 Portqry 疑難排解 Active Directory 連線問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103)。

若需有關在網域控制站上設定 Microsoft Windows® Time 的詳細資訊，請參閱知識庫文件 - 816042＜如何在 Windows Server 2003 中設定授權時間伺服器＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816042)。


通訊埠 636 未回應
Microsoft Exchange Server Analyzer - 文章 > 網路 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 Active Directory 中所有網域控制站的 dNSHostName 屬性值。擷取網域控制站名稱之後，Exchange Server Analyzer 會開啟 TCP 通訊端連線到每一台網域控制站上的通訊埠 636。此連線是使用自訂物件處理器建立的，如果連線成功，該處理器會傳回特定字串。如果 Exchange Server Analyzer 收到的傳回字串中沒有 636 Available，則會顯示警告。

這則警告表示網域控制站沒有回應在 TCP 通訊埠 636 上嘗試的連線作業。TCP 通訊埠 636 是「安全輕量型目錄存取通訊協定 (LDAP over SSL)」通訊的預設通訊埠。

導入 Exchange 2000 Server Service Pack 3 之後，如果 Exchange Server 電腦上的本機憑證儲存區中存在有效的憑證，Exchange Server 就會與 LDAP over SSL 連線。如果這樣的憑證不存在，或是傳回與憑證相關的錯誤 (例如，網域控制站不信任 Exchange 憑證，或是所使用的憑證需要增強金鑰的保護)，Exchange Server 就會自動回到沒有 SSL 的 LDAP 狀態。如果收到此警告，可能是因為 Exchange Server Analyzer 與網域控制站之間的連線有問題。這則警告不會揭露「公開金鑰基礎結構 (PKI)」或其他憑證的問題。

當 Exchange Server Analyzer 查詢網域控制站時，網域控制站無法適當服務 LDAP over SSL 要求的原因有很多。

若要更正此警告

  1. 確認執行該工具的帳戶有權去查詢網域控制站。在執行網域控制站的網域中，您需要使用者等級的權限。您可以在 Exchange Server Analyzer 所包含的說明檔中，找到有關執行該工具所需權限的詳細資訊。若要開啟說明檔，請先開啟 Exchange Server Analyzer，按一下 [說明]，再按 [Microsoft Exchange Server Analyzer 工具說明]。

  2. 請確認執行 Exchange Server Analyzer 的電腦與未回應的網域控制站之間沒有防火牆或通訊埠限制。

  3. 確認網域控制站有連線至網路而且正常運作。

  4. 確認執行 Exchange Server Analyzer 之電腦上的時間，與無法回應的網域控制站時間是一致的。如果網域控制站上的 Microsoft Windows® Time 服務已停止或停用，則網域控制站的本機時間可能不同步。在此情況下，要等到網域控制站的時鐘同步化之後，才會回應 LDAP over SSL 要求。

若需有關使用 LDAP over SSL 的詳細資訊，請參閱微軟知識庫文件 - 321051＜如何使用協力廠商憑證授權單位啟用 LDAP over SSL＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=321051)。

若需解決 Active Directory 連線問題的詳細資訊，請參閱知識庫文件 - 816103＜HOW TO：使用 Portqry 疑難排解 Active Directory 連線問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103)。

若需有關 Windows Times 服務的詳細資訊，請參閱知識庫文件 - 816042＜如何在 Windows Server 2003 中設定授權時間伺服器＞ (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816042)。


SMTP 伺服器不支援 X-LINK2STATE 動詞命令
Microsoft Exchange Server Analyzer - 文章 > 網路 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會和 Exchange 伺服器初始化一個 SMTP 工作階段，以確認是否列出正確的 Exchange SMTP 動詞命令。如果沒有列出 X-LINK2STATE 動詞命令，就會顯示警告。

Exchange 會使用 X-LINK2STATE 動詞命令來更新路由主機上的連結狀態表格。連結狀態表格會記錄整個 Exchange 組織最新的 SMTP 連結狀態資訊。Exchange 會使用這些資訊來選擇傳送郵件時，成本最低且最可靠的路由。這項功能亦稱為「智慧型路由」。

Exchange 需要有 X-LINK2STATE 動詞命令，才能有效地以路由傳送，而其他 SMTP 提供者不使用 X-LINK2STATE 動詞命令。因此，這項功能會在檔案 (xlsasink.dll) 中提供，而此檔案是由「Exchange 安裝程式」來安裝及註冊。

傳回這個警告的可能已知原因有二個。第一，有些系統管理員可能會停用 xlsasink.dll，以使用其提供的智慧型路由功能。這不是建議使用的最佳作法，而且可能會導致效能和穩定性的問題。若是如此，建議您在受影響的電腦上重新安裝 Exchange，以安裝及註冊 xlsasink.dll。

第二，如果您所執行的防毒產品會安裝並使用它自己的 SMTP 通訊協定堆疊來掃描郵件，可能就會傳回這個警告。若是如此，該防毒軟體可能會執行它自己的 SMTP 堆疊，在郵件到達 Exchange SMTP 堆疊之前，就攔截並掃描郵件。在這種情況下，防毒 SMTP 堆疊就不會使用 X-LINK2STATE 動作。建議您在不需要讓防毒軟體在 Exchange 伺服器上安裝自己的 SMTP 堆疊的模式下執行該防毒軟體。

若需有關 X-LINK2STATE 及 Exchange 所使用之其他專屬動作的詳細資訊，請參閱微軟知識庫文件 - 812455＜在兩部 Exchange 伺服器間使用之動作的定義＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=812455)。

若需有關如何檢視 Exchange 命令動詞及重新安裝 Exchange 2000 Server 的詳細資訊，請參閱知識庫文件 - 319885＜XCON：在 Exchange 2000 Server 組織中傳送的郵件未傳遞＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319885)。

若需有關如何檢視 Exchange 命令動詞及重新安裝 Exchange Server 2003 的詳細資訊，請參閱知識庫文件 - 822939＜在 Exchange Server 2003 組織中傳送的郵件未傳遞＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822939)。


SMTP 伺服器的郵件接受度測試失敗
Microsoft Exchange Server Analyzer - 文章 > 網路 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會執行下列工作，嘗試將郵件傳送到簡易郵件傳送通訊協定 (SMTP) 網域的郵件管理員帳戶：

  • 開啟與 SMTP 伺服器的通訊端連線。如果 Exchange Server Analyzer 收到 220 回應碼，則視同此步驟已順利完成。

  • 傳輸 EHLO SMTP 命令動詞。如果 Exchange Server Analyzer 收到一連串 250 回應碼，包括一個含有 250-X-LINK2STATE 和 250-XEXCH50 的回應，則視同此步驟已順利完成。

  • 傳輸 MAIL FROM:ExBPA-MailAcceptTest@Fabrikam.com SMTP 命令動詞。如果 Exchange Server Analyzer 收到 250 回應碼，則視同此步驟已順利完成。

  • 傳輸 RCPT TO:Postmaster@<domainname>.com SMTP 命令動詞。如果 Exchange Server Analyzer 收到 250 回應碼，則視同此步驟已順利完成。

如果 Exchange Server Analyzer 無法順利完成所有步驟，則會顯示錯誤。錯誤指出可能有一般的郵件流程問題。下列連結以您應該疑難排解的順序列出，從伺服器層級開始，一直到網路層級。

若要更正此錯誤

  1. 請參閱《Exchange Server 2003 傳輸及路由手冊》中的＜疑難排解路由＞(英文) (http://go.microsoft.com/fwlink/?linkid=47579)。

  2. 請參閱微軟知識庫文件 - 324867＜支援 WebCast：Microsoft Exchange 2000 Server：疑難排解郵件流程問題 (重新造訪)＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324867)。

  3. 請參閱微軟知識庫文件 - 823489＜如何使用佇列檢視器來疑難排解郵件流程問題＞(英文) ((http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  4. 請參閱微軟知識庫文件 - 324759＜支援 WebCast：Microsoft Exchange 2000 Server：傳輸中的 DNS 疑難排解＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324759)。

若需 Exchange Server 的郵件管理員帳戶的相關資訊，請參閱下列微軟知識庫文件：

  • 223860＜XCON：必須手動設定 SMTP 郵件管理員信箱＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=223860)

  • 313832＜HOW TO:設定 Exchange 2000 Server 中的 SMTP 郵件管理員帳戶＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313832)


SMTP 伺服器的開放式轉送測試失敗
Microsoft Exchange Server Analyzer - 文章 > 網路 >

主題上次修改日期： 2007-03-14

Microsoft® Exchange Server Analyzer 工具會執行下列工作，嘗試透過簡易郵件傳送通訊協定 (SMTP) 伺服器來轉送郵件：

  • 開啟與 SMTP 伺服器的通訊端連線。如果 Exchange Server Analyzer 收到 220 回應碼，則視同此步驟已順利完成。

  • 傳輸 EHLO SMTP 命令動詞。如果 Exchange Server Analyzer 收到一連串 250 回應碼，包括一個含有 250-X-LINK2STATE 和 250-XEXCH50 的回應，則視同此步驟已順利完成。

  • 傳輸 MAIL FROM:ExBPA-OpenRelayTest@Fabrikam.com SMTP 命令動詞。如果 Exchange Server Analyzer 收到 250 回應碼，則視同此步驟已順利完成。

  • 傳輸 RCPT TO:ExBPA-OpenRelayTest@Fabrikam.com SMTP 命令動詞。如果 Exchange Server Analyzer 收到 250 回應碼，則視同此步驟已順利完成。

Exchange Server Analyzer 也會查詢 Win32_OperatingSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 OSProductSuite 機碼值。此機碼的值對應到 Windows Server 作業系統的特定版本。

如果 Exchange Server Analyzer 可在 Exchange Server 電腦 (屬於 Microsoft Small Business Server 2000 或 Microsoft Windows Small Business Server 2003 安裝的一部分) 上順利完成所有步驟，就會顯示一則錯誤。

此錯誤指出此伺服器是設定成開放式轉送。

這不是允許開放式轉送的建議最佳作法。

電子郵件伺服器允許透過系統轉送電子郵件訊息時 (但不對所轉送的電子郵件進行任何限制或控制)，則會發生開放式轉送。

附註：
如果您的 Exchange 組織因某些原因而使用名為 Fabrikam.com 的 SMTP 網域，則可能會發生此錯誤。在此事件中，您可以放心地略過此錯誤。Fabrikam.com 網域是由 Microsoft Corporation 所擁有，且是用於訓練、說明文件及類似目的。

轉送並不是原本就不好，因為 SMTP 就是因此目的而設計的 (若需詳細資訊，請參閱 RFC 2821 文件的第 2.1 及 3.7 節 (http://ietf.org))。然而，如果未控制轉送 (未控制的主機稱為開放式轉送主機)，則惡意的使用者可能會使用轉送來傳送大量且主動提供的商業電子郵件訊息 (垃圾郵件或 UCE)。透過從中繼主機來傳播這些主動提供的電子郵件訊息，惡意的使用者會嘗試模糊他們的身分識別。這也會防礙轉送主機上的資源，且可能會讓轉送主機無法傳送有效的電子郵件訊息。特別的是，大部份傳送此類主動提供之電子郵件訊息的使用者，可將單一郵件傳送給數目異常多的收件者，而不會用到他們自己的頻寬來這樣做。

請確定朝向網際網路的 SMTP 虛擬伺服器上不允許匿名轉送。在其預設組態中，Exchange 只允許已驗證的使用者來轉送郵件。只有已驗證的使用者才可使用 Exchange 將郵件傳送到外部網域。如果將預設的轉送設定修改成允許未經驗證的使用者來進行轉送，或如果允許透過連接器進行網域的開放式轉送，則未經授權的使用者或惡意的蠕蟲可使用您的 Exchange 伺服器來傳送垃圾郵件。您的伺服器可能會被列在封鎖名單裡，而無法將郵件傳送到合法的遠端伺服器中。若要避免未經授權的使用者使用您的 Exchange 伺服器來轉送郵件，則至少要使用預設的轉送限制。

如果有合理的原因要進行轉送，請遵循方針以確定實作方式中有保留安全性。這主要是透過下列方式來完成：保留拒絕所有預設值且只新增用來接受所轉送郵件的 IP 位址，並停用已授權使用者的存取。

請檢閱如何將內建帳戶 (本機系統管理員) 及其他使用者用在閘道伺服器上。不可以使用內建帳戶來進行任何種類型的轉送。如果正在進行轉送，則可能是由已知的一組使用者或電腦來進行轉送。建議將轉送權限限制給明確宣告的使用者及電腦 (或 IP 位址)。

設定明確宣告的轉送權限對保護伺服器特別有幫助。惡意的使用者可能會使用暴力式攻擊，來嘗試取得內建帳戶的密碼或網際網路上所找到使用者帳戶的密碼，這樣他們就可將您的伺服器用來當成垃圾郵件 Proxy。因此，對於可從網際網路存取的電腦，不建議使用預設設定 (允許任何已驗證電腦轉送)。建議停用此設定。

下列程序解說如何依據 SMTP 虛擬伺服器是否朝向網際網路，來停用匿名轉送。如本文件先前所提及，只可在瞭解安全性危機且您的組織可接受的情況下，才可啟用任何形式的匿名轉送。此文件結尾的參照提供如何使用轉送的詳細資訊。

如果 SMTP 虛擬伺服器無法從網際網路存取，則建議將轉送組態重設成預設值。這會讓 SMTP 虛擬伺服器只允許從已驗證電腦進行內部轉送。

對於可從網際網路存取的 SMTP 虛擬伺服器，則建議特別保護預設的轉送組態，讓只有具有明確宣告之權限的使用者及電腦才可進行轉送。

如果已確認 Exchange 是設定成封鎖轉送，而在 Exchange Server Analyzer 中仍會接收到此錯誤，則應確認任何 Proxy 伺服器或處理程序 (如防火牆、防毒或防垃圾郵件軟體) 沒有允許匿名轉送。

若要在內部 SMTP 虛擬伺服器上將匿名轉送組態重設成預設的設定

  1. 開啟 [Exchange 系統管理員]。

  2. 在主控台樹狀目錄中，依序展開 [伺服器]、您要的伺服器、[通訊協定]，然後展開 [SMTP]。

  3. 在要套用轉送限制的 SMTP 虛擬伺服器上按一下滑鼠右鍵，然後按一下 [內容]。

  4. 在 [<SMTP Virtual Server> 內容] 中，按一下 [存取] 標籤，然後按一下 [轉送]。

  5. 在 [轉送限制] 的 [選取可透過此虛擬伺服器轉送的電腦] 之下，依序選取 [僅限下列清單]、[不考慮上述清單，允許所有通過驗證的電腦轉送。] 核取方塊，然後按一下 [確定]。

若要在 Exchange Server 2003 中朝向網際網路的 SMTP 虛擬伺服器上設定明確宣告的轉送權限

  1. 開啟 [Exchange 系統管理員]。

  2. 在主控台樹狀目錄中，依序展開 [伺服器]、您要的伺服器、[通訊協定]，然後展開 [SMTP]。

  3. 在要套用轉送限制的 SMTP 虛擬伺服器上按一下滑鼠右鍵，然後按一下 [內容]。

  4. 在 [<SMTP Virtual Server> 內容] 中，按一下 [存取] 標籤，然後按一下 [轉送]。

  5. 在 [轉送限制] 中，清除 [不考慮上述清單，允許所有通過驗證的電腦轉送。] 核取方塊，然後按一下 [使用者] 以指定想要在此 SMTP 虛擬伺服器上授與轉送權限的使用者子集。

  6. 在 [提交及轉送的權限] 中，若要移除使用者或群組，請選取群組或使用者，然後按一下 [移除]。

  7. 若要新增群組或使用者，請按一下 [新增]，然後選取想要指定權限的使用者或群組。選取下列其中一個選項：

    • 在 Microsoft Windows Server™ 2003 上，在 [選取使用者、電腦或群組] 的 [輸入要選取的物件名稱] 之下，鍵入使用者或群組的名稱。如果想要搜尋使用者或群組，請按一下 [進階]、搜尋使用者或群組名稱，然後按一下 [檢查名稱] 以確認輸入項目。

      提示：
      按一下 [範例] 連結，以檢視輸入項目的可接受格式。
    • 在 Windows 2000 Server 上，在 [選取使用者、電腦或群組] 中選取想要授與提交權限的群組或使用者，然後按一下 [新增]。

  8. 按一下 [確定] 回到 [提交及轉送的權限] 對話方塊。

  9. 在 [群組或使用者名稱清單] 之下，選取剛剛新增的群組。

  10. 在 [<選取的群組> 的權限] (在 [提交權限] 旁邊) 之下，如果需要，請選取 [允許] 之下的核取方塊，以允許選取的使用者或群組來透過此 SMTP 虛擬伺服器提交郵件。

  11. 在 [轉送權限] 旁邊，選取 [允許] 之下的核取方塊，以允許透過此 SMTP 虛擬伺服器來轉送所選取的物件，或選取 [拒絕] 之下的核取方塊，讓所選取的物件無法透過此虛擬伺服器進行轉送。

    附註：
    如果想要允許「轉送權限」，則必須允許「提交權限」。

  12. 按一下 [確定]。

若要在 Exchange 2000 Server 中朝向網際網路的 SMTP 虛擬伺服器上設定轉送權限

  1. 開啟 [Exchange 系統管理員]。

  2. 在主控台樹狀目錄中，依序展開 [伺服器]、想要設定的伺服器、[通訊協定] 及 [SMTP]。

  3. 在要套用轉送限制的 SMTP 虛擬伺服器上按一下滑鼠右鍵，然後按一下 [內容]。

  4. 在 [<SMTP Virtual Server> 內容] 中，按一下 [存取] 標籤，然後按一下 [轉送]。

  5. 在 [轉送限制] (在 [選取可透過此虛擬伺服器轉送的電腦] 之下) 中，選取 [僅限下列清單]。

  6. 按一下 [新增]，以新增單一電腦 (電腦群組或 SMTP 網域名稱)，然後再按 [確定]。針對每個其他想要新增的項目，重複此步驟。

  7. 選取 [不考慮上述清單，允許所有通過驗證的電腦轉送。] 核取方塊，然後按兩次 [確定]。

若需郵件轉送及安全性的相關資訊，請參閱 Exchange Server 2003 技術文件庫中的下列手冊：

  • 《Exchange Server 2003 傳輸及路由手冊》(英文) (http://go.microsoft.com/fwlink/?linkid=47579)。

  • 《在 Exchange 2003 環境中減緩及阻止電子郵件病毒》(英文) (http://go.microsoft.com/fwlink/?linkid=47587)

若需有關在 Exchange 及 Microsoft Windows 環境中測試及保護開放式轉送行為的相關資訊，請參閱 Microsoft 知識庫文章 304897＜XIMS：在協力廠商測試中，Microsoft SMTP Server 似乎接受並轉送電子郵件＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=304897)。


執行的 SMTP 版本不支援 XEXCH50 動詞命令
Microsoft Exchange Server Analyzer - 文章 > 網路 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會和 Exchange 伺服器初始化一個 SMTP 工作階段，以確認是否列出正確的 Exchange SMTP 動詞命令。如果未列出 XEXCH50 動詞命令，就會顯示一則警告。

此外，Exchange 會使用 XEXCH50 動詞命令來複寫公用資料夾。在 Exchange 伺服器上執行不支援 XEXCH50 動詞命令的 SMTP 版本會中斷公用資料夾的複寫。

其他 SMTP 提供者不會使用 XEXCH50 動作，因此，該功能是由 Exchange 安裝程式安裝及註冊的 peexch50.dll 檔案提供。

如果您執行的防毒產品會安裝及使用它自己的 SMTP 通訊協定堆疊來掃描郵件，則 Exchange Server Analyzer 可能會傳回此警告。這是因為在郵件到達 Exchange SMTP 堆疊之前，防毒軟體會先使用自己的 SMTP 堆疊來攔截及掃描郵件。在這種情況下，防毒軟體中的 SMTP 堆疊是不會使用 XEXCH50 動作的。

建議您在不需要防毒軟體於 Exchange 伺服器上安裝本身的 SMTP 堆疊的模式下執行防毒軟體，或在 SMTP 網路的傳入週邊執行這種軟體。如果已停用防毒軟體的 SMTP 堆疊，但仍然看到此警告訊息，請重新安裝 Exchange 來正確安裝及註冊 peexch50.dll。

若需有關 XEXCH50 及 Exchange 所使用之其他專屬動作的詳細資訊，請參閱微軟知識庫文件 - 812455＜2 個 Exchange 伺服器之間使用的動作定義＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=812455)。

若需有關如何檢視 Exchange 命令動詞及重新安裝 Exchange 2000 Server 的詳細資訊，請參閱知識庫文件 - 319885＜XCON：在 Exchange 2000 Server 組織中傳送的郵件未傳遞＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319885)。

若需有關如何檢視 Exchange 命令動詞及重新安裝 Exchange Server 2003 的詳細資訊，請參閱知識庫文件 - 822939＜在 Exchange Server 2003 組織中傳送的郵件未傳遞＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822939)。


通訊協定
Microsoft Exchange Server Analyzer - 文章 >

主題上次修改日期： 2005-11-18

本節的文章提供 Microsoft® Exchange Server Analyzer 工具對網際網路通訊協定所評估的詳細資料。此外，這些文章敘述了您可採取哪些動作，以解決 Exchange Server Analyzer 所發現的網際網路通訊協定相關錯誤、警告及非預設組態。


Active Directory 來回行程回應錯誤
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 類別，以判定從 Active Directory® 目錄服務伺服器傳回的值 (StatusCode 機碼)。Win32_PingStatus 傳回具有 24 個屬性的物件，該物件提供有關類別傳送之 Ping 封包的廣泛詳細資料。

如果 Exchange Server Analyzer 發現此機碼的值與下表中的其中一個值相符，將會顯示錯誤。

Exchange Server Analyzer 會顯示 Active Directory 伺服器名稱和連同此錯誤一起傳回的對應 StatusCode 值。

StatusCode 值 | 意義 | 描述
11001 | 緩衝區太小 | 因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會傳回此錯誤。
11002 | 無法與目的網路連線 | 無法與目的電腦所在的網路連線，所以要求失敗。無前往目的電腦的有效路由。 若需詳細資訊，請參閱微軟知識庫文件 - 325487＜如何疑難排解網路連線問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。
11003 | 無法與目的主機連線 | 無法與目的電腦連線，所以要求失敗。 若需詳細資訊，請參閱 Active Directory 伺服器當機或無法存取。 或者，導致此錯誤的原因可能是執行 Exchange Server Analyzer 所在的位置與目標網域控制站之間的防火牆，甚至可能為 DNS 錯誤。 若需有關詳細資訊，請參閱知識庫文件 - 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。
11004 | 無法與目的通訊協定連線 | 目的電腦沒有回應封包的通訊協定，所以要求失敗。 導致此錯誤的原因可能是執行 Exchange Server Analyzer 所在的位置與目標網域控制站之間的防火牆。
11005 | 無法與目的通訊埠連線 | 無法使用目的電腦的通訊埠，所以要求失敗。 若需有關詳細資訊，請參閱知識庫文件 - 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。
11006 | 沒有資源 | 網路資源不足，所以要求失敗。 若需有關詳細資訊，請參閱知識庫文件 - 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。
11007 | 錯誤的選項 | 內含無效的選項，所以要求失敗。 因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會傳回此錯誤。
11008 | 硬體錯誤 | 發生硬體錯誤，所以要求失敗。 執行電腦製造商的硬體狀況檢查工具，以驗證網域控制站是否正常運作。
11009 | 封包太大 | 包含要求的封包超過位於來源和目的地間之節點 (路由器或閘道) 的傳輸單元最大值 (MTU)，所以要求失敗。MTU 定義了可傳輸封包的大小上限。 Exchange Server Analyzer 傳送之要求的大小不大於 10 KB。請確認組織中的路由器和閘道都已適當設定。 若需詳細資訊，請參閱知識庫文件 - 159211＜黑洞路由器的診斷及處理＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211)。
11010 | 要求逾時 | 未在配置的時間內收到回覆。允許的回覆時間預設為 5 秒。 若需有關詳細資訊，請參閱知識庫文件 - 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。
11011 | 錯誤的要求 | 編碼方式不正確，所以要求失敗。 因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會傳回此錯誤。
11012 | 錯誤的路由 | 來源和目的電腦之間無有效的路由，所以要求失敗。 若需有關詳細資訊，請參閱知識庫文件 - 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。
11013 | TimeToLive 過期轉送 | Time to Live (TTL) 值達到零，導致轉寄節點 (路由器或閘道) 捨棄封包，所以要求失敗。 若需有關詳細資訊，請參閱知識庫文件 - 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。
11014 | TimeToLive 過期重組 | 封包已分割為片段以進行傳輸，但未能在配置的時間內收到所有片段進行重組，所以要求失敗。RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) 指定將 60 秒作為接收所有封包片段的時間限制。 若需有關詳細資訊，請參閱知識庫文件 - 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。
11015 | 參數問題 | 處理封包標頭時，節點 (路由器或閘道) 發生問題，所以要求失敗。例如，如果標頭包含無效的欄位資料或無法辨識的選項，便會出現此狀態。 因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會傳回此錯誤。
11016 | 來源抑制 | 封包被捨棄，所以要求失敗。來源電腦的輸出佇列沒有足夠的儲存空間，或封包太快抵達目的地而來不及處理時，便會發生此狀況。 因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會傳回此錯誤。
11017 | 選項太大 | 內含無效的選項，所以要求失敗。 因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會傳回此錯誤。
11018 | 錯誤的目的地 | 目的 IP 位址無法接收 PING 要求，或不該在任何 IP 資料包的目的位址欄位中出現，所以要求失敗。 導致此狀況的原因可能是執行 Exchange Server Analyzer 所在的位置與目標網域控制站之間的防火牆。
11032 | 交涉 IPSEC | 因為無法交涉 IPsec 連線，所以要求失敗。
11050 | 一般失敗 | 不明原因造成要求失敗。 若需有關詳細資訊，請參閱知識庫文件 - 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。


Active Directory 與 Exchange Server 來回行程回應錯誤
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2006-05-15

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 類別，以判定從 Active Directory® 目錄服務伺服器傳回的 StatusCode 機碼值。Win32_PingStatus 會傳回一個具有 24 個內容的物件，這些內容提供類別所傳送之 Ping 封包的詳盡資料。

如果 Exchange Server Analyzer 發現此機碼的值與下表中的其中一個值相符，將會顯示錯誤。

Exchange Server Analyzer 會顯示 Active Directory 伺服器名稱、Exchange Server 名稱，和連同此錯誤一起傳回的對應 StatusCode 值。

StatusCode 值 意義 描述

11001

緩衝區太小

因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會發生此錯誤。

11002

無法與目的網路連線

無法與包含目的電腦的網路連線，所以要求失敗。沒有通往目的電腦的有效路由存在。

如需相關資訊，請參閱 Microsoft 知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11003

無法與目的主機連線

無法與目的電腦連線，所以要求失敗。

如需相關資訊，請參閱 Active Directory 伺服器當機或無法存取。

或者，下列情況之一也可能造成此錯誤：

  • 執行 Exchange Server Analyzer 所在的位置與目標網域控制站之間的防火牆。

  • DNS 錯誤。

如需相關資訊，請參閱 Microsoft 知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11004

無法與目的通訊協定連線

目的電腦沒有回應封包的通訊協定，所以要求失敗。

導致此錯誤的原因可能是執行 Exchange Server Analyzer 所在的位置與目標網域控制站之間的防火牆。

11005

無法與目的通訊埠連線

無法使用目的電腦上的通訊埠，所以要求失敗。

如需相關資訊，請參閱 Microsoft 知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11006

沒有資源

網路資源不足，所以要求失敗。

如需相關資訊，請參閱 Microsoft 知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11007

錯誤的選項

內含無效的選項，所以要求失敗。

因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會發生此錯誤。

11008

硬體錯誤

發生硬體錯誤，所以要求失敗。

執行電腦製造商所提供的硬體狀況檢查工具，以驗證網域控制站是否正常運作。

11009

封包太大

包含要求的封包超過位於來源和目的地間之路由器或閘道節點的傳輸單元最大值 (MTU)，所以要求失敗。MTU 定義了可傳輸封包的大小上限。

Exchange Server Analyzer 傳送之要求的大小不大於 10 KB。請確認組織中的路由器和閘道都已適當設定。

如需相關資訊，請參閱 Microsoft 知識庫文章 159211＜黑洞路由器的診斷及處理＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211)。

11010

要求逾時

未在配置的時間內收到回覆。允許的回覆時間預設為 5 秒。

如需相關資訊，請參閱 Microsoft 知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11011

錯誤的要求

編碼方式不正確，所以要求失敗。

因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會發生此錯誤。

11012

錯誤的路由

來源和目的電腦之間無有效的路由，所以要求失敗。

如需相關資訊，請參閱 Microsoft 知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11013

TimeToLive 過期轉送

要求的存留時間 (TTL) 值已達零，所以要求失敗。這會使得轉寄的路由器或閘道節點將封包捨棄。

如需相關資訊，請參閱 Microsoft 知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11014

TimeToLive 過期重組

封包已分割為片段以進行傳輸，但未能在配置的時間內收到所有片段進行重組，所以要求失敗。RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) 指定將 60 秒作為接收所有封包片段的時間限制。

如需相關資訊，請參閱 Microsoft 知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11015

參數問題

處理封包標頭時，路由器或閘道節點發生問題，所以要求失敗。如果標頭包含無效的欄位資料或無法辨識的選項，便會出現此狀態。

因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會發生此錯誤。

11016

來源抑制

封包被捨棄，所以要求失敗。來源電腦的輸出佇列儲存空間不足時，便會出現此狀態。或者是在封包抵達目的地的速度太快，導致來不及處理時，也會發生。

因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會發生此錯誤。

11017

選項太大

內含無效的選項，所以要求失敗。

因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會發生此錯誤。

11018

錯誤的目的地

由於下列其中一個原因，所以要求失敗：

  • 目的 IP 位址無法接收 PING 要求。

  • 目的 IP 位址不該在任何 IP 資料包的目的位址欄位中出現。

導致此狀況的原因可能是執行 Exchange Server Analyzer 所在的位置與目標網域控制站之間的防火牆。

11032

交涉 IPSEC

因為無法交涉 IPsec 連線，所以要求失敗。

11050

一般失敗

不明原因造成要求失敗。

如需相關資訊，請參閱 Microsoft 知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。


內部 SMTP 虛擬伺服器和專用 SMTP 虛擬伺服器允許 IMAP 與 POP 用戶端匿名存取
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 Exchange Server 物件之 protocolCfgSMTPServer 類別中的 msExchAuthenticationFlags 屬性值。protocolCfgSMTPServer 類別包含 SMTP 虛擬伺服器的設定。msExchAuthenticationFlags 屬性代表 SMTP 伺服器上允許的驗證類型。如果下列條件存在，Exchange Server Analyzer 將會顯示警告訊息：

  • 已將 msExchAuthenticationFlags 屬性的驗證設定為允許匿名存取 SMTP 伺服器。

  • 伺服器沒有執行 Microsoft Small Business Server 2000 或 Microsoft Windows® Small Business Server 2003。

  • Exchange Server 可以主控 20 個以上的信箱。

為了加強安全性，請在不接受內送網際網路郵件的內部 SMTP 虛擬伺服器上停用匿名存取。為了加強安全性，您也可以在專用的 SMTP 虛擬伺服器上停用遠端 IMAP 和 POP 使用者匿名存取。

重要事項：
請不要停用網際網路 Bridgehead SMTP 虛擬伺服器上的匿名存取。可接受網際網路郵件的 SMTP 虛擬伺服器必須允許匿名存取。

當您傳送內部郵件時，您組織中的 Exchange 伺服器會相互驗證，以傳送郵件。因此，內部 SMTP 虛擬伺服器上不一定要啟用匿名存取。禁止內部伺服器上的匿名存取，不僅不會中斷郵件流程，還能在內部 SMTP 虛擬伺服器上提供多一層的安全保護。

同樣地，IMAP 和 POP 用戶端會先與 SMTP 虛擬伺服器進行驗證，再將郵件傳送給 SMTP 虛擬伺服器。因此，如果 IMAP 和 POP 用戶端使用專用的 SMTP 虛擬伺服器，您可以設定這些伺服器僅允許通過驗證的存取。如果在這些伺服器上停用匿名存取，即可協助防止未經授權的使用者進行存取。

如果由於商業因素 (例如，需由協力廠商進行驗證)，而無法在 SMTP 虛擬伺服器上停用驗證存取，請遵循下列步驟，協助增強您閘道伺服器上的安全性：

  • 強制所有使用者帳戶遵守強式密碼原則，特別是系統管理員帳戶。

  • 停用來賓帳戶。若需有關停用來賓帳戶的詳細資訊，請參閱微軟知識庫文件 - 320053＜如何重新命名 Windows 2000 中的系統管理員及來賓帳戶＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320053)。雖然這份文件適用於 Windows 2000 Server，但相似的原則也適用於 Windows Server 2003。

若要停用 SMTP 虛擬伺服器的匿名存取驗證

  1. 在 [Exchange 系統管理員] 中，依序展開 [伺服器]、[<your inbound Exchange server>]、[通訊協定] 及 [SMTP]。

  2. 以滑鼠右鍵按一下輸入的 SMTP 虛擬伺服器，再按一下 [內容]。

  3. 按一下 [存取] 索引標籤，然後再按 [驗證]。

  4. 在 [驗證] 中，清除 [匿名存取] 核取方塊。

若需有關設定 Exchange Server 2003 組織以更安全地傳送及接收網際網路郵件的詳細資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47579)。


已啟用背景防毒掃描
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已啟用背景防毒掃描：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

如果 Exchange Server Analyzer 發現 BackgroundScanning 項目的值設為 1，則會顯示警告。

如果 BackgroundScanning 登錄項目存在且已設為 1，則每次更新防毒程式的簽名檔時，就會在背景重新掃描所有郵件。每當更新防毒簽名檔時，這種行為會實質影響效能，因此 Microsoft 不建議使用它。

當您使用病毒掃描應用程式發展介面 (VSAPI) 2.0 架構的防毒程式且用戶端嘗試開啟郵件時，會進行比較來確定已使用目前的病毒簽名檔來掃描郵件內文和附件。如果未使用目前的簽章模式檔來掃描內容，則在用戶端可使用對應的郵件之前，會先將郵件提交給防毒程式。

如果安裝的防毒程式沒有可讓您停用背景掃描的使用者介面，您可以使用下列程序，修改 Exchange Server 電腦的登錄來控制這項行為。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

  3. 在右窗格中，對 BackgroundScanning 值連按兩下。

  4. 在 [數值資料] 欄位中，將數值變更為 0。

  5. 關閉登錄編輯程式，重新啟動 Microsoft Exchange Information Store 服務和您的防毒軟體服務，使變更生效。
  • 編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

  • 若需有關 Exchange 使用之不同類型防毒掃描程式的詳細資訊，請參閱知識庫文件 - 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)。


CheckPop3Tail 值已經變更
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來判斷下列登錄值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\CheckPop3Tail

如果 Exchange Server Analyzer 發現 CheckPop3Tail 值存在，並且設定為 1，則會顯示非預設的組態訊息。

Internet Engineering Task Force (IETF) Request for Comments (RFC) 1939 (http://www.ietf.org/rfc/rfc1939.txt) 指定了 POP3 郵件的 CRLF 終止順序。按照 Exchange 的說法，CRLF 順序稱為 POP3Tail。如果 POP3 用戶端 (如 Microsoft Office Outlook® 2003 或 Microsoft Outlook Express) 遇到含有錯誤 POP3Tail (例如，缺少 CRLF) 的不正確郵件，它會停止回應，並且無法下載收件匣中所有的郵件。CheckPop3Tail 登錄值代表的是一個組態機會，系統管理員可以利用此機會指示 Microsoft Exchange POP3 服務檢查每一封 POP3 郵件的 POP3Tail，如果缺少終止順序，就新增正確的終止順序。

附註：
此設定會更正不正確的郵件，讓 POP3 用戶端能夠下載使用者收件匣中所有的郵件；然而，因為它會檢查每一封郵件是否有適當 POP3Tail，所以效能會稍微下降。

如果需要，您可以利用以下程序來移除 CheckPop3Tail 登錄值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要刪除 CheckPop3Tail 登錄值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. 刪除名為 CheckPop3Tail 的值。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange POP3 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關使用 CheckPop3Tail 登錄值的詳細資訊，請參閱知識庫文件 - 816896＜XCCC：嘗試下載郵件時 POP3 用戶端停止回應 (懸置) 或逾時＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816896)。


已啟用防禦郵件系統
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 heuristics 屬性是否已設為啟用防禦郵件系統。依預設，未設定 heuristics 屬性。如果 Exchange Server Analyzer 發現 heuristics 屬性設為 256，則會顯示非預設的組態訊息。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要採取任何動作。

防禦郵件系統 (DMS) 程式由 Under Secretary of Defense (Acquisition) 建立，其目的是促進及協調整合式一般使用者郵件系統的開發，以滿足撰寫者及讀取者的需求，減少成本及人員配置層級，並改善功能、安全性、延續性及可用性。

若需有關防禦郵件系統的詳細資訊，請參閱 Lockheed Martin 網站 (英文) (http://www.lockheedmartin.com)。

附註：
網址可能會變更，因此您可能無法連線到此處提到的網站。


停用 MAPI 用戶端警告
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2007-05-01

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已設定 MAPI 用戶端封鎖：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable MAPI Clients

如果 Exchange Server Analyzer 發現 Disabled MAPI Clients 的值已設為以 -10、-11 或 -12 開頭的值，便會顯示警告。

在預設的情況下，未啟用 Disable MAPI Clients 機碼。因此系統管理員可以禁止特定版本的 Microsoft Office Outlook® 連接到執行 Exchange 2000 Server、Exchange Server 2003 或 Exchange Server 2007 的電腦。

將 Disabled MAPI Clients 機碼設為以 -10、-11 或 -12 開頭的值時，會封鎖整個範圍的 MAPI 版本。這些範圍對應至 Outlook 2000、Outlook 2003 及 Outlook 2007 版本，以及 Exchange Server 2003 中的 Exchange System Attendant。封鎖 Exchange System Attendant 服務可能會使 Exchange Server 運作不正常。

若要修正此警告，請遵循＜所有 Outlook 版本都可存取伺服器＞中的建議及程序。

若需有關禁止特定 MAPI 用戶端連接到執行 Exchange 2000 Server 或 Exchange Server 2003 之電腦的詳細資訊，請參閱下列微軟知識庫文件：

  • 328240＜如何在用來存取 Exchange 2000 信箱的用戶端上加上伺服器端限制＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328240)

  • 288894＜如何停用 MAPI 用戶端存取 Exchange Server 2003 電腦或 Exchange 2000 Server 電腦＞(英文)(http://go.microsoft.com/fwlink/?linkid=3052&kbid=288894)。

若需有關禁止特定 MAPI 用戶端連接到執行 Exchange Server 2007 之電腦的詳細資訊，請參閱 Exchange Server 2007 產品文件中的 Exchange 管理命令介面＜Set-CasMailbox＞指令程式 (英文) (http://go.microsoft.com/fwlink/?LinkId=80698)。

若需如何下載舊版 Outlook 的安全性更新及封鎖其他版本 Outlook 的詳細資訊，請參閱＜在 Exchange Server 2003 環境中減緩及阻止電子郵件病毒＞(英文) (http://go.microsoft.com/fwlink/?LinkId=30732)。


已設定 DisableSMTPMailboxAddressing 值
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2006-08-11

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定值是否設定為停用簡易郵件傳送通訊協定 (SMTP) 信箱定址：

HKeyLocalMachine\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\DisableSMTPMailboxAddressing

DisableSMTPMailboxAddressing 機碼的值若為 1，指出已停用 SMTP 信箱定址 (true)；若為 0，則指出未停用 SMTP 信箱定址 (false)。

如果 Exchange Server Analyzer 判定 DisableSMTPMailboxAddressing 機碼的值為 1，以設定為停用 SMTP 信箱定址，則 Exchange Server Analyzer 會顯示警告。

此錯誤指出已停用 SMTP 信箱定址。這會導致連接至此伺服器的 Microsoft Exchange ActiveSync 用戶端發生同步處理錯誤。

若要處理此警告，請將 DisableSMTPMailboxAddressing 機碼的值設定為 0。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
修改 DisableSMTPMailboxAddressing 機碼的值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：

HKeyLocalMachine\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA

  1. 在右窗格中，找到並按兩下 DisableSMTPMailboxAddressing。

  2. 將值從 1 變更為 0。

  3. 關閉登錄編輯程式，然後重新啟動 Server 服務，以使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需與此警告關聯之同步處理錯誤的詳細資訊，請參閱 Microsoft 知識庫文章 886346＜當同步處理行動裝置與 Microsoft Exchange Server 2003 時收到 HTTP_500 錯誤訊息＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=886346)。


發佈使用者負載
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2006-09-06

Microsoft® Exchange Server Analyzer 工具已判定您的伺服器具有高的每秒 RPC 作業數。

如果您的伺服器具有高的每秒 RPC 作業數，即可使用 Exchange Server User Monitor (ExMon) 來識別如何發佈負載。務必判定負載是否由下列其中一種情況造成：

  • 作用中的使用者人數為相對少數。

  • 將負載發佈給多個使用者。

若識別出造成高負載百分比的原因是某個使用者，Exchange Server Analyzer 會顯示警告，指出高使用量可追溯到某個使用者。如果不是這樣，Exchange Server Analyzer 會顯示訊息，指出已將負載發佈給多個使用者。

附註：
RPC 流量會隨時間改變。因此，若要擷取使用者如何使用 Exchange 的相關統計資料，您可能需要收集資料多次。

此外，有時會有某些一般的使用者作業在短時間內大量增加 CPU 的使用量。除非是同一位使用者經常大量增加 CPU 的使用量或是使用量長時間的增加，否則不需要擔心這個問題。

附註：
若高負載來源為預期會發生高負載的已知服務或處理程序，且其處理多位使用者的要求並產生比個別使用者較高的負載，您便能放心略過此警告。例如某些與行動裝置同步的服務、管理空閒/忙碌的伺服器處理程序、與語音信箱或整合通訊相關的服務，以及移動使用者的伺服器處理程序，均是比個別使用者產生更高負載的服務或處理程序。
若要更正此錯誤

  • 如果 RPC 比率很高 (針對單一使用者或每位使用者)，請查出使用者是否有桌面搜尋引擎、協力廠商用戶端外掛程式或行動裝置，可同步處理電子郵件與使用者的信箱。若需有關疑難排解協力廠商應用程式的詳細資訊，請參閱關閉用戶端上的協力廠商增益集。

  • 使用者在預設及常用資料夾中的項目應該少於 5,000 個。

  • 最佳作法是信箱大小應該為 1 GB 或更小。針對造成高負載的使用者，建議他們將其信箱的項目封存到 .pst 檔中。然後，您可以再次執行 Exchange Performance (Perfmon) 工具來查看使用者是否仍然造成高負載。

  • 連絡使用者，找出可能存取用戶端電子郵件程式的用戶端應用程式。移除這些應用程式，然後再逐一重新安裝它們，以觀察這些應用程式對伺服器的影響。

  • 疑難排解使用者負載時常會發生誤判。因此，建議您在高負載時再次執行 ExMon，查看分析是否一致。

詳細資訊

  • 若要下載 Exchange Server User Monitor (ExMon)，請參閱 Microsoft 下載中心 (英文) (http://go.microsoft.com/fwlink/?LinkId=54983)。

  • 若需有關 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需有關疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《疑難排解 Microsoft Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 若需有關 Outlook 用戶端效能問題疑難排解的詳細資訊，請參閱微軟知識庫文件 - 905803＜Outlook 使用者在執行 Exchange Server 2003 或 Exchange 2000 Server 的伺服器上使用包含許多項目的資料夾時遇到效能不佳的情況＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)。

  • 若需有關桌面搜尋軟體的詳細資訊，請參閱微軟知識庫文件 - 905184＜在 Outlook 或其他 MAPI 用戶端電腦上執行桌面搜尋引擎軟體，可能會影響 Exchange 2000 Server 與 Exchange Server 2003 的效能＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184)。


已覆寫 OMA 和 EAS 的 Exchange 虛擬目錄
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來判定是否已覆寫 Exchange ActiveSync® 的 SMTP Proxy 位址：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MasSync\Parameters\ExchangeVDir

如果 Exchange Server Analyzer 發現 ExchangeVDir 登錄項目存在且已設定，則會顯示非預設的組態訊息。

Microsoft Outlook® Mobile Access 和 Exchange ActiveSync 會使用 ExchangeVDir 登錄項目。此項目會指定虛擬目錄，供 Outlook Mobile Access 及 Exchange ActiveSync 於使用者信箱所在的 Exchange Server 2003 後端伺服器上，存取 Microsoft Office Outlook Web Access for Exchange Server 2003 範本及 WebDAV。

如果 ExchangeVDir 項目不存在或尚未對該項目設定值，則會使用預設值 /Exchange。否則，它包含虛擬目錄的名稱 (包括正斜線字元 "/")。當您要指定 Outlook Mobile Access 或 Exchange ActiveSync 的虛擬目錄時，您可以設定此值。

Exchange Server 2003 中的一個已知問題，就是在單一 Exchange Server 2003 電腦拓撲上使用表單型驗證時，Exchange 行動電話服務無法運作。當 Exchange Server 2003 後端伺服器的 /Exchange 虛擬目錄設為需要 Secure Sockets Layer (SSL) 時，或是當啟用表單型驗證時，Outlook Mobile Access 便無法存取此虛擬目錄。當您在前端伺服器的 /Exchange 虛擬目錄中啟用這些設定時，不會發生此問題。

透過設定可以解決此問題，包括建立 ExchangeVDir 登錄值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：

    HKLM\System\CurrentControlSet\Services\MasSync\Parameters

  3. 檢查並視需要變更 ExchangeVDir 值。

  4. 關閉登錄編輯程式。如果做了變更，請重新啟動 Exchange Server 電腦，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關解決此問題的詳細資訊，請參閱知識庫文件 - 817317＜不支援將多個 Proxy 位址對應至同一伺服器上的多個後端虛擬根目錄＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=817317)。


偵測到與 Exchange 病毒掃描 API 相容的產品，但是該產品目前並未啟用
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定在 Exchange Server 電腦上是否已啟用病毒掃描應用程式發展介面 (VSAPI) 相容軟體：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Exchange Server Analyzer 也會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Exchange 資料庫儲存引擎 Ese.dll (又稱為「可擴充儲存引擎 (ESE)」) 的 Version 機碼值。

最後，Exchange Server Analyzer 還會查詢 Active Directory® 目錄服務，以判定物件類別為 msExchExchangeServer 的所有物件之 serialNumber 屬性值。若字串值包含 Version 5.5，表示電腦執行的是 Microsoft Exchange Server 5.5。若字串值包含 Version 6.0，表示電腦執行的是 Microsoft Exchange 2000 Server。若字串值包含 Version 6.5，表示電腦執行的是 Microsoft Exchange Server 2003。

如果 Exchange Server Analyzer 發現 Version 的值沒有包含 6 這個子字串作為其版本資訊的一部分，但 serialNumber 的值表示已安裝 Exchange 2000 Server 或 Exchange Server 2003，則在 Exchange Server 上執行的是非 Exchange 版本的 ESE。

如果 Exchange Server Analyzer 判定執行的不是非 Exchange 版本的 ESE，而且 VirusScan \Enabled 登錄機碼的值等於 0，就會顯示一則警告。如果 Exchange Server Analyzer 判定 Exchange 伺服器上執行的是非 Exchange 版本的 ESE，就會顯示一則警告。

一般而言，我們會建議您在「簡易郵件傳送通訊協定」(SMTP) 閘道上，或是在主控信箱的 Exchange 伺服器上，部署專為郵件系統所設計開發的防毒軟體。為了達到最佳保護，可在閘道執行防毒軟體，掃描輸入的 MIME 郵件，以及在使用 VSAPI 2.0 (Exchange 2000 Server) 或 VSAPI 2.5 (Exchange Server 2003) 的 Exchange Server 電腦上執行掃描程式。

此外，您也應該在用戶端電腦上執行防毒軟體。如果您在閘道或 Exchange 伺服器上執行專門針對郵件系統所設計開發的防毒軟體 (意即該軟體可以剖析及掃描 MIME)，則用戶端電腦上只要執行檔案層級的掃描程式就已足夠。

若要更正此警告

  1. 在防毒軟體程式使用者介面中，啟用 VSAPI 掃描。

  2. 如果在啟用 VSAPI 掃描之後問題仍然存在，請連絡防毒軟體廠商以尋求協助。

若需有關通常搭配 Microsoft Exchange Server 2003 使用的病毒掃描程式詳細資訊，請參閱微軟知識庫文件 - 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)。

若需有關通常搭配 Microsoft Exchange 2000 Server 使用的病毒掃描程式詳細資訊，請參閱微軟知識庫文件 - 328841＜Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)。

若需有關加強 Exchange 環境，對抗以電子郵件傳遞之病毒的詳細資訊，請參閱《在 Exchange Server 2003 環境中減緩及阻止電子郵件病毒》(英文) (http://go.microsoft.com/fwlink/?LinkId=47587)。


偵測到 Exchange 病毒掃描 API 相容的產品，但該產品安裝不正確
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定病毒掃描應用程式發展介面 (VSAPI) 相容軟體是否在電腦上執行，以及它是否有參照有效程式庫：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

如果 Exchange Server Analyzer 發現 Library 的值未包含 VSAPI 防毒程式庫檔案 (DLL) 的有效路徑，就會顯示警告。

一般而言，我們會建議您在「簡易郵件傳送通訊協定」(SMTP) 閘道上，或是在主控信箱的 Exchange 伺服器上，部署專為郵件系統所設計開發的防毒軟體。為了達到最佳保護，可在閘道執行防毒軟體，掃描輸入的 MIME 郵件，以及在使用 VSAPI 2.0 (Exchange 2000 Server) 或 VSAPI 2.5 (Exchange Server 2003) 的 Exchange Server 電腦上執行掃描程式。

此外，您也應該在用戶端電腦上執行防毒軟體。如果您在閘道或 Exchange 伺服器上執行專門針對郵件系統所設計開發的防毒軟體 (意即該軟體可以剖析及掃描 MIME)，則用戶端電腦上只要執行檔案層級的掃描程式就已足夠。

若要更正此警告

  1. 解除安裝防毒軟體之後再重新安裝。

  2. 如果在重新安裝該軟體之後問題仍然存在，請連絡防毒軟體廠商以尋求協助。

若需有關通常搭配 Microsoft Exchange Server 2003 使用的病毒掃描程式詳細資訊，請參閱微軟知識庫文件 - 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)。

若需有關通常搭配 Microsoft Exchange 2000 Server 使用的病毒掃描程式詳細資訊，請參閱微軟知識庫文件 - 328841＜Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)。

若需有關加強 Exchange 環境，對抗以電子郵件傳遞之病毒的詳細資訊，請參閱《在 Exchange Server 2003 環境中減緩及阻止電子郵件病毒》(英文) (http://go.microsoft.com/fwlink/?LinkId=47587)。


Exchange 病毒掃描 API 的執行緒計數偏低
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來判定 ScanningThreads 的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

ScanningThreads 登錄值代表已配置來掃描的病毒掃描 API (VSAPI) 執行緒的最大數目。

Exchange Server Analyzer 也會讀取下列登錄項目，以判定是否已啟用 VSAPI 郵件掃描：

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Enabled 的值為 1 表示已啟用 VSAPI 掃描。值 0 表示未啟用 VSAPI 掃描。

此外，Exchange Server Analyzer 也會查詢 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定為 NumberOfProcessors 機碼設定的值。這個值代表電腦上安裝的處理器數目，包含了實體處理器及邏輯處理器。使用 Intel 的「超執行緒」技術，一個實體處理器可分割為兩個邏輯處理器。

如果 Exchange Server Analyzer 在已啟用 VSAPI 掃描的 Exchange Server 電腦上發現 ScanningThreads 的值小於 (2 × NumberOfProcessors) + 1，就會顯示一則警告。ScanningThreads 的最佳值等於 (2 × NumberOfProcessors) + 1。例如，在安裝兩顆處理器的 Exchange Server 電腦上，ScanningThreads 的最佳值是 5。

附註：
如果啟用「超執行緒」，則 NumberOfProcessors 值會是實體處理器數目的兩倍。建議您洽詢您的防毒軟體製造商，以判定應在上述公式中使用實體還是邏輯處理器。
重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

  3. 在右窗格中，連按兩下 ScanningThreads。

  4. 輸入上述公式傳回的值。

  5. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關超執行緒技術的詳細資訊，請參閱 Intel 網站 (英文) (http://www.intel.com/technology/hyperthread)。

附註：
網址可能會變更，因此您可能無法連線到此處提到的網站。


針對 SMTP 使用外部 DNS 伺服器
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 Exchange Server 物件之 protocolCfgSMTPServer 類別中的 msExchSMTPExternalDNSServers 屬性值。protocolCfgSMTPServer 類別包含 SMTP 虛擬伺服器的設定。如果已設定 msExchSMTPExternalDNSServers 屬性，則 SMTP 虛擬伺服器會使用外部 DNS 伺服器。如果 Exchange Server Analyzer 判定已設定 msExchSMTPExternalDNSServers 屬性，就會顯示一則警告。

如果將您的 SMTP 虛擬伺服器設定為使用外部 DNS 伺服器，則可能會遭遇到效能問題。因此，不建議使用此組態。

在 SMTP 虛擬伺服器上變更外部 DNS 設定

  1. 在 [Exchange 系統管理員] 中，依序展開 [伺服器]、<您的輸入 Exchange 伺服器> 及 [通訊協定]，然後展開 [SMTP]。

  2. 在您的 SMTP 虛擬伺服器上按一下滑鼠右鍵，再按 [內容]。

  3. 按一下 [傳遞] 索引標籤，再按一下 [進階]。

  4. 按一下 [設定]，以設定外部 DNS 伺服器。

  5. 若要新增外部 DNS 伺服器，請按一下 [新增]，在 [新增] 對話方塊中輸入外部 DNS 伺服器的 IP 位址，再按一下 [確定]。

  6. 若要移除外部 DNS 伺服器，請選取 IP 位址，然後按一下 [移除]。

  7. 按一下 [確定]。

若需有關在 Exchange Server 2003 組織中設定 DNS 的詳細資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》(http://go.microsoft.com/fwlink/?LinkId=47579) 中的＜設定 DNS＞(英文)。

若需有關在 Exchange 中設定 SMTP 連接器以連結至網際網路網域的詳細資訊，請參閱微軟知識庫文件 - 319426＜HOW TO：在 Exchange 2000 中設定 SMTP 連接器以連結至網際網路網域＞(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=319426)。


前端伺服器正在使用基本驗證
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判斷是否已在前端伺服器與後端伺服器之間設定基本驗證：

HKEY_LOCAL_MACHINE\CurrentControlSet\Services\MSExchangeWeb\DAV\UseBasicAuthToBE

如果 Exchange Server Analyzer 發現已設定 UseBasicAuthToBE 機碼，就會顯示非預設的組態訊息。

根據預設值，Exchange Server 2003 前端伺服器將會使用 Kerberos 驗證，以協助保護前端與後端伺服器之間的使用者認證。如果 Kerberos 驗證失敗，則會記錄警告事件，且前端伺服器會改而嘗試 NTLM。若 NTLM 失敗，就會記錄一則錯誤。會在 30 分鐘內重試 Kerberos。當 Exchange 2000 Server 或 Exchange Server 2003 前端電腦在 Exchange 2000 Server 後端電腦中進行驗證時，會使用 NTLM。

設定 UseBasicAuthToBE 登錄機碼會覆寫此預設邏輯，並強制 Exchange 前端伺服器對於所有與後端伺服器的通訊都使用基本驗證。如果您的 Exchange 組織中有超過 1,000 個信箱儲存區，則必須設定此登錄機碼。但目前有一個已知的問題，那就是在具有 1,000 個以上信箱儲存區的組織中，透過前端伺服器從 Microsoft Office Outlook® Web Access for Exchange Server 2003 存取信箱的使用者，無法存取其信箱。

如果您沒有 1,000 個以上的信箱儲存區，且沒有強制基本驗證的理由，可考慮刪除 UseBasicAuthToBE 登錄機碼。

基本驗證會傳送純文字的憑證。如果您執行的 Exchange 前端伺服器已設定 UseBasicAuthToBE 登錄機碼，強烈建議您使用 IPSec 加密。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

刪除 UseBasicAuthToBE 登錄機碼

  1. 在 Exchange 前端伺服器上，開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Service\MSExchangeWeb\Dav\ UseBasicAuthToBE。

  3. 在 UseBasicAuthToB 上按一下滑鼠右鍵，再按 [刪除] 及 [是]。

  4. 開啟 [服務] MMC 嵌入式管理單元，以滑鼠右鍵按一下 IIS Admin Service，再按一下 [重新啟動]。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


閘道伺服器 PING 失敗
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 類別，以判定從非 Exchange 的閘道伺服器傳回的 StatusCode 機碼值。Win32_PingStatus 會傳回一個具有 24 個內容的物件，這些內容提供類別所傳送之 Ping 封包的詳盡資料。

如果 Exchange Server Analyzer 發現此機碼的值與下表中的其中一個值相符，將會顯示錯誤。

Exchange Server Analyzer 會顯示閘道伺服器名稱、Exchange Server 名稱，和連同此錯誤一起傳回的對應 StatusCode 值。

StatusCode 值 意義 描述

11001

緩衝區太小

因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會發生此錯誤。

11002

無法與目的網路連線

無法與包含目的電腦的網路連線，所以要求失敗。沒有通往目的電腦的有效路由存在。

如需相關資訊，請參閱 Microsoft 知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11003

無法與目的主機連線

無法與目的電腦連線，所以要求失敗。

如需相關資訊，請參閱 Active Directory 伺服器當機或無法存取。

或者，下列情況之一也可能造成此錯誤：

  • 執行 Exchange Server Analyzer 所在的位置與目標網域控制站之間的防火牆。

  • DNS 錯誤。

如需相關資訊，請參閱知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11004

無法與目的通訊協定連線

目的電腦沒有回應封包的通訊協定，所以要求失敗。

導致此錯誤的原因可能是執行 Exchange Server Analyzer 所在的位置與目標網域控制站之間的防火牆。

11005

無法與目的通訊埠連線

無法使用目的電腦上的通訊埠，所以要求失敗。

如需相關資訊，請參閱知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11006

沒有資源

網路資源不足，所以要求失敗。

如需相關資訊，請參閱知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11007

錯誤的選項

內含無效的選項，所以要求失敗。

因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會發生此錯誤。

11008

硬體錯誤

發生硬體錯誤，所以要求失敗。

執行電腦製造商所提供的硬體狀況檢查工具，以驗證網域控制站是否正常運作。

11009

封包太大

包含要求的封包超過位於來源和目的地間之路由器或閘道節點的傳輸單元最大值 (MTU)，所以要求失敗。MTU 定義了可傳輸封包的大小上限。

Exchange Server Analyzer 傳送之要求的大小不大於 10 KB。請確認組織中的路由器和閘道都已適當設定。

如需相關資訊，請參閱知識庫文章 159211＜黑洞路由器的診斷及處理＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211)。

11010

要求逾時

未在配置的時間內收到回覆。允許的回覆時間預設為 5 秒。

如需相關資訊，請參閱知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11011

錯誤的要求

編碼方式不正確，所以要求失敗。

因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會發生此錯誤。

11012

錯誤的路由

來源和目的電腦之間無有效的路由，所以要求失敗。

如需相關資訊，請參閱知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11013

TimeToLive 過期轉送

要求的存留時間 (TTL) 值已達零，所以要求失敗。這會使得轉寄的路由器或閘道節點將封包捨棄。

如需相關資訊，請參閱知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11014

TimeToLive 過期重組

封包已分割為片段以進行傳輸，但未能在配置的時間內收到所有片段進行重組，所以要求失敗。RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) 指定將 60 秒作為接收所有封包片段的時間限制。

如需相關資訊，請參閱知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11015

參數問題

處理封包標頭時，路由器或閘道節點發生問題，所以要求失敗。如果標頭包含無效的欄位資料或無法辨識的選項，便會出現此狀態。

因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會發生此錯誤。

11016

來源抑制

封包被捨棄，所以要求失敗。來源電腦的輸出佇列儲存空間不足時，便會出現此狀態。或者是在封包抵達目的地的速度太快，導致來不及處理時，也會發生。

因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會發生此錯誤。

11017

選項太大

內含無效的選項，所以要求失敗。

因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會發生此錯誤。

11018

錯誤的目的地

由於下列其中一個原因，所以要求失敗：

  • 目的 IP 位址無法接收 PING 要求。

  • 目的 IP 位址不該在任何 IP 資料包的目的位址欄位中出現。

導致此狀況的原因可能是執行 Exchange Server Analyzer 所在的位置與目標網域控制站之間的防火牆。

11032

交涉 IPSEC

因為無法交涉 IPsec 連線，所以要求失敗。

11050

一般失敗

不明原因造成要求失敗。

如需相關資訊，請參閱知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。


IIS 6.0 MaxFieldLength 參數未正確設定
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已在下列登錄中將 HTTP 要求的欄位長度上限硬式編碼：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters\MaxFieldLength

Exchange Server Analyzer 也會檢查下列登錄項目，以判定在目的電腦上執行的 Microsoft Windows® 作業系統版本。

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 值為 4.0 表示電腦正在執行 Microsoft Windows NT® Server 4.0。值 5.0 表示電腦正在執行 Microsoft Windows 2000 Server 作業系統，而值 5.2 則表示電腦正在執行 Microsoft Windows Server™ 2003 作業系統。

最後，Exchange Server Analyzer 會檢查 root\MicrosoftExchangeV2 命名空間中的 Exchange_Server Windows Management Instrumentation (WMI) 類別，以判定 IsFrontEndServer 的機碼值。False 值表示 Exchange Server 電腦不是前端伺服器。True 值表示 Exchange Server 電腦是前端伺服器。

如果 Exchange Server Analyzer 發現在符合下列條件的 Exchange 後端伺服器上，MaxFieldLength 的值不是設為 32768，就會顯示警告：

  • Exchange 後端伺服器正在執行 Windows Server 2003。

  • Exchange 後端伺服器未設定為前端伺服器。

  • Exchange 後端伺服器具有超過 500 個信箱。

MaxFieldLength IIS 登錄參數 (依預設不存在) 可指定任何個別 HTTP 用戶端要求的大小上限。這個值通常會與結伴值 MaxRequestBytes 一起設定。在大型環境中，如果這些值未設為 32768，則 Microsoft Office Outlook® Web Access for Exchange Server 使用者會遇到登入失敗。尤其，缺少這些值會造成「HTTP 400 - 錯誤的要求」之錯誤。當設定 MaxFieldLength 登錄值時，您也必須將 MaxRequestBytes 參數設定為 32768，讓身為超過 75 個群組之成員的使用者能夠登入 Outlook Web Access。MaxRequestBytes 登錄值會判定要求行和各標題的總大小上限。如果它的值小於 MaxFieldLength，則會調整 MaxFieldLength 值。

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要設定 MaxRequestBytes 及 MaxFieldLength 參數

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：

    HKLM\System\CurrentControlSet\Services\HTTP\Parameters

  3. 以滑鼠右鍵按一下 [Parameters]，按一下 [新增] | [DWORD 值]，並將值命名為 MaxFieldLength。

  4. 以滑鼠右鍵按一下 [Parameters]，按一下 [新增] | [DWORD 值]，並將值命名為 MaxRequestBytes。

  5. 在右窗格中，連按兩下 [MaxFieldLength]，並將其值設定為 32768 (十進位)。

  6. 在右窗格中，連按兩下 [MaxRequestBytes]，並將其值設定為 32768 (十進位)。

  7. 關閉登錄編輯程式，然後重新啟動 IIS Admin 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Internet Information Service (IIS) 之 HTTP 登錄設定的詳細資訊，請參閱知識庫文件 - 820129＜INF：IIS Http.sys 登錄設定＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=820129)。


未正確設定 IIS 6.0 MaxRequestBytes 參數
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2007-01-05

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已將 HTTP 要求的最大大小硬式編碼到登錄中：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters\MaxRequestBytes

Exchange Server Analyzer 也會檢查下列登錄項目，以判定在目的電腦上執行的 Microsoft Windows® 作業系統版本：

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 值為 4.0 表示電腦正在執行 Microsoft Windows NT® Server 4.0。值 5.0 表示電腦正在執行 Microsoft Windows 2000 Server 作業系統，而值 5.2 則表示電腦正在執行 Microsoft Windows Server™ 2003 作業系統。

最後，Exchange Server Analyzer 會檢查 root\MicrosoftExchangeV2 命名空間中的 Exchange_Server Windows Management Instrumentation (WMI) 類別，以判定 IsFrontEndServer 機碼的值。False 值表示 Exchange Server 電腦不是前端伺服器。True 值表示 Exchange Server 電腦是前端伺服器。

如果 Exchange Server Analyzer 發現在符合下列條件的 Exchange 後端伺服器上，MaxRequestBytes 的值設為 32768，就會顯示一則警告。

  • Exchange 後端伺服器正在執行 Windows Server 2003。

  • Exchange 後端伺服器未設定為前端伺服器。

  • Exchange 後端伺服器具有超過 500 個信箱。

MaxRequestBytes 登錄值 (依預設，此值不存在) 會判定要求行及標題之總大小的較高限制。此值一般是與比較值 (MaxFieldLength) 一前一後來設定的。MaxFieldLength IIS 登錄參數會指定任何個別 HTTP 用戶端要求大小的上限。在大型環境中，如果這些值未設為 32768，則 Microsoft Office Outlook® Web Access for Exchange Server 使用者會遇到登入失敗。尤其，缺少這些值會造成「HTTP 400 - 錯誤的要求」之錯誤。當設定 MaxFieldLength 登錄值時，您也必須將 MaxRequestBytes 參數設定為 32768，讓身為超過 75 個群組之成員的使用者能夠登入 Outlook Web Access。如果它的值小於 MaxFieldLength 的值，則會調整 MaxFieldLength 值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要設定 MaxRequestBytes 及 MaxFieldLength 參數

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：

    HKLM\System\CurrentControlSet\Services\HTTP\Parameters

  3. 以滑鼠右鍵按一下 [參數]，並選取 [新增 | DWORD 值]，然後將值命名為 MaxFieldLength。

  4. 在 Parameters 上按一下滑鼠右鍵，並選取 [新增 | DWORD 值]，然後將值命名為 MaxRequestBytes。

  5. 在右窗格中，連按兩下 MaxFieldLength，然後將它的值設為 32768 (十進位)。

  6. 在右窗格中，連按兩下 MaxRequestBytes，然後將它的值設為 32768 (十進位)。

  7. 關閉登錄編輯程式，然後重新啟動 IIS Admin 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Internet Information Services (IIS) 之 HTTP 登錄設定的詳細資訊，請參閱知識庫文件 - 820129＜INF：IIS Http.sys 登錄設定＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=820129)。


在登錄中設定 IMAP4 相容性旗標
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來判斷下列登錄值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\Compatibility

如果 Exchange Server Analyzer 發現 Compatibility 值存在且設為值 0xfffffffe (十六進位)，則會顯示非預設的組態訊息。

使用 IMAP4 及郵局通訊協定第 3 版 (POP3) 的 Exchange Server 網際網路通訊協定 (IP) 用戶端電腦，將可以完整利用串流儲存區 (.stm) 檔案來讀取及寫入資料。當 IP 用戶端要求透過 POP3 或 IMAP4 下載郵件時，包含使用者信箱的 Exchange 資訊儲存庫會在傳送郵件之前，計算收件匣中要傳送給用戶端的郵件之實際大小。在大型環境中 (特別是主控的 Exchange 環境)，這需要一些時間來完成計算。Compatibility 值代表一個組態選項，讓系統管理員用來指示 Exchange 儲存區使用大概的郵件大小，而不用實際算出郵件大小。

Compatibility 登錄值可供 Exchange IMAP4 服務使用 (如本文件所描述)，也可供 Exchange POP3 服務使用 (如 登錄中已經設定 POP3 Compatibility 旗標 中所描述)。

Compatibility 登錄值也適用於在移動許多信箱期間或移動具有數個 MIME 郵件的信箱期間使用。移動資料時，資料會從串流儲存區提升到 MAPI 儲存區 (.edb 檔案) 中。若您將用戶端的信箱在資料庫或伺服器之間移動，當用戶端使用 POP3 和 IMAP4 存取其信箱時，可能會遇到效能問題。當使用者登入之後，就必須計算郵件大小，並且在伺服器的記憶體和磁碟上進行 MAPI 至 MIME 轉換。在進行此動作時，於極度異常的情況下，會在 Exchange Server 電腦上建立很大的暫存檔。

並非所有 POP3 和 IMAP4 郵件用戶端都可以和設定的 Compatibility 登錄值正確配合使用。變更此設定會讓一些較舊的郵件用戶端 (如 Fetchmail) 中斷。設定此登錄機碼也會中斷 IMAP4 通訊協定的 RFC 相容性。如果您在使用 POP3 及 IMAP4 來下載郵件時發生問題，且使用的是 Compatibility 登錄值，則可使用下列程序來刪除它，而此程序是郵件下載問題的疑難排解步驟。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要刪除 Compatibility 登錄值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. 刪除叫做 Compatibility 的值。

  4. 結束登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 及 IIS Admin 兩個服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關使用 Compatibility 登錄機碼的詳細資訊，請參閱下列知識庫文件：

  • 317722＜XADM：當 Exchange 2000 將郵件從 MAPI 轉換為 MIME 格式時，發生用戶端延遲＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317722)

  • 329067＜XADM：移動信箱功能會使 .stm 檔的內容升階＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329067)


IMAP4 MaxBufferSize 值已變更
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2007-08-07

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定下列登錄值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

如果 Exchange Server Analyzer 發現 MaxBufferSize 值存在，並設定成任何大於 0 的數值，就會顯示非預設的組態訊息。

MaxBufferSize 登錄值會用於 Exchange 前端/後端拓樸中。它定義前端伺服器與後端伺服器之間的 TCP/IP 緩衝區大小。預設的緩衝區大小是 1 KB。在具有高度延遲的網路中，調整 MaxBufferSize 值，可以改善 IMAP4 用戶端的效能。

在使用 MaxBufferSize 登錄值設定 TCP/IP 緩衝區大小時，一定要將緩衝區大小設為 1024 的倍數。建議您使用下列緩衝區大小來測試前端/後端伺服器組態效能，以決定您的組織的最佳值：

  • 8,192 位元組

  • 16,384 位元組

  • 32,768 位元組

建議您不要將 MaxBufferSize 登錄項目的值設定為大於 32,768。若緩衝區大小值為 65,536，您或許會發現效能增加了，但這得視您的網路條件而定。緩衝區大小愈大，會耗用更多 Exchange Server 電腦上的記憶體，並且可能會減少可以存取前端伺服器的使用者數目。您可用於 MaxBufferSize 登錄值的最大值並沒有任何限制，如果您對此登錄項目指定的值太大時，將會發生效能不穩定和記憶體問題。

附註：
若要使用 MaxBufferSize 登錄值，您必須執行 Exchange 2000 Server Service Pack 2 或更新版本。

如果 MaxBufferSize 登錄值設得太低，將無法增加效能，而且 Exchange Server Analyzer 會顯示一則錯誤訊息 (如 IMAP4 MaxBufferSize 值太低所述)。如果 MaxBufferSize 登錄值設得太高，則可能會導致系統不穩定，而且 Exchange Server Analyzer 會顯示一則錯誤訊息 (如 IMAP4 MaxBufferSize 值太高所述)。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要設定 MaxBufferSize 值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. 建立一個新的 DWORD 值，稱為 MaxBufferSize。

  4. 連按兩下 MaxBufferSize 值，並且將其設為新的緩衝區大小 (以位元組為單位)。例如，輸入 8192，將其設為 8192 位元組。

  5. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange IMAP4 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關使用 MaxBufferSize 登錄值的時機及作法詳細資訊，請參閱知識庫文件 - 823857＜XADM：前端伺服器及後端伺服器間的 IMAP4 及 POP3 效能緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857)。


IMAP4 MaxBufferSize 值太高
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2007-08-07

Microsoft® Exchange Server Analyzer 工具會讀取 Exchange Server 電腦上的登錄，以判定下列登錄值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

如果 Exchange Server Analyzer 發現 MaxBufferSize 值存在而且已設定為大於 32768 的數值，就會顯示一則警告。

MaxBufferSize 登錄值會用於 Exchange 前端/後端拓樸中。它定義前端伺服器與後端伺服器之間的 TCP/IP 緩衝區大小。預設的緩衝區大小是 1 KB。在具有高度延遲的網路中，調整 MaxBufferSize 值，可以改善 IMAP4 用戶端的效能。

在使用 MaxBufferSize 登錄值設定 TCP/IP 緩衝區大小時，一定要將緩衝區大小設為 1024 的倍數。建議您使用下列緩衝區大小，測試您的前端/後端伺服器組態效能：

  • 8,192 位元組

  • 16,384 位元組

  • 32,768 位元組

使用這個登錄項目時，至少要設為 1,024。建議您不要將 MaxBufferSize 登錄項目的值設為大於 32,768。若緩衝區大小值為 65,535，您或許會發現效能增加了，但這得視您的網路條件而定。緩衝區大小愈大，會耗用更多 Exchange Server 電腦上的記憶體，並且可能會減少可以存取前端伺服器的使用者數目。您可用於 MaxBufferSize 登錄值的最大值並沒有任何限制，如果您對此登錄項目指定的值太大時，將會發生效能不穩定和記憶體問題。

附註：
若要使用 MaxBufferSize 登錄值，您必須執行 Exchange 2000 Server Service Pack 2 或更新版本。

如果 MaxBufferSize 登錄值設得太低，將無法改善效能，而且 Exchange Server Analyzer 會顯示一則錯誤訊息 (如 IMAP4 MaxBufferSize 值太低中所述)。如果 MaxBufferSize 登錄值設得太高，則可能會導致系統不穩定，而且 Exchange Server Analyzer 會顯示一則訊息 (如本文所述)。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. 建立一個新的 DWORD 值，稱為 MaxBufferSize。

  4. 連按兩下 MaxBufferSize 值，並且將其設為新的緩衝區大小 (以位元組為單位)。例如，輸入 8192，將其設為 8192 位元組。

  5. 關閉登錄編輯程式並且重新啟動 Microsoft Exchange IMAP4 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關使用 MaxBufferSize 登錄值的時機及作法詳細資訊，請參閱知識庫文件 - 823857＜XADM：前端伺服器及後端伺服器間的 IMAP4 及 POP3 效能緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857)。


IMAP4 MaxBufferSize 值太低
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2007-08-07

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定下列登錄值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

如果 Exchange Server Analyzer 發現 MaxBufferSize 值存在，並且設定為大於 0 但小於 1024 的數值，則會顯示錯誤訊息。

MaxBufferSize 登錄值會用於 Exchange 前端/後端拓樸中。它定義前端伺服器與後端伺服器之間的 TCP/IP 緩衝區大小。預設的緩衝區大小是 1 KB。在具有高度延遲的網路中，調整 MaxBufferSize 值，可以改善 IMAP4 用戶端的效能。

在使用 MaxBufferSize 登錄值設定 TCP/IP 緩衝區大小時，一定要將緩衝區大小設為 1024 的倍數。建議您使用下列緩衝區大小來測試前端/後端伺服器組態效能，以決定您的組織的最佳值：

  • 8,192 位元組

  • 16,384 位元組

  • 32,768 位元組

使用這個登錄項目時，至少要設為 1,024。建議您不要將 MaxBufferSize 登錄項目的值設為大於 32,768。若緩衝區大小值為 65,536，您或許會發現效能增加了，但這得視您的網路條件而定。緩衝區大小愈大，會耗用更多 Exchange Server 電腦上的記憶體，並且可能會減少可以存取前端伺服器的使用者數目。您可用於 MaxBufferSize 登錄值的最大值並沒有任何限制，如果您對此登錄項目指定的值太大時，將會發生效能不穩定和記憶體問題。

附註：
若要使用 MaxBufferSize 登錄值，您必須執行 Exchange 2000 Server Service Pack 2 或更新版本。

如果 MaxBufferSize 登錄值設得太低，將無法改善效能，而且 Exchange Server Analyzer 會顯示一則錯誤訊息 (如本文所述)。如果 MaxBufferSize 登錄值設得太高，則可能會導致系統不穩定，而且 Exchange Server Analyzer 會顯示一則訊息 (如 IMAP4 MaxBufferSize 值太高所述)。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. 建立一個新的 DWORD 值，稱為 MaxBufferSize。

  4. 連按兩下 MaxBufferSize 值，並且將其設為新的緩衝區大小 (以位元組為單位)。例如，輸入 8192，將其設為 8192 位元組。

  5. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange IMAP4 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關使用 MaxBufferSize 登錄值的時機及作法詳細資訊，請參閱知識庫文件 - 823857＜XADM：前端伺服器及後端伺服器間的 IMAP4 及 POP3 效能緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857)。


MAPI 作業失敗
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具判斷伺服器已報告許多 MAPI 失敗。某些 MAPI 作業預期偶爾會傳回錯誤。不過，有時用戶端應用程式可能無法正確回應錯誤。因此，應用程式可能重新發出造成錯誤的 RPC 要求，從而增加伺服器上的負載。

經常性用戶端錯誤的一個例子是，MAPI 用戶端批次要求項目清單時，在 Exchange 傳回要求後仍繼續要求項目。例如，用戶端電腦可能會要求包含附件之某個給定資料夾中的所有項目。用戶端可能會進一步要求項目以每 30 個項目批次傳回。在某些情況中，Exchange 伺服器傳回要求中的最後一個項目後，用戶端會繼續要求新的 30 個項目批次。在這些情況中，Exchange 會傳回「找不到」錯誤。如果在傳回「找不到」錯誤之後，用戶端電腦仍繼續要求項目，用戶端電腦即未正確回應錯誤。在此案例中，Exchange Server User Monitor (ExMon) 會報告多個 MAPI 失敗。在此情況中，失敗對作業數目的比率雖然高，但此高失敗率是可以預期的。預期有高失敗率的 MAPI 作業包括 GetPerUserGuid、ImportMsgMove 及 Logon。

若要更正此錯誤

  1. 使用 ExMon 判斷哪一個使用者或使用者群組造成高 MAPI 失敗數目。

  2. 判斷用戶端電腦上哪一個應用程式造成此問題。

  3. 更正或移除造成問題的應用程式。

詳細資訊

  • 若需有關 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需有關疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《疑難排解 Microsoft Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


MaxClientRequestBuffer 設為非預設值
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄機碼，以判定該機碼是否存在：

HKEY_LOCAL_MACHINE System\CurrentControlSet\w3svc\Parameters\MaxClientRequestBuffer

如果 Exchange Server Analyzer 發現已設定 MaxClientRequestBuffer 機碼，則會顯示非預設的訊息。

在預設的情況下，此登錄值不存在。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要採取任何動作。

若需有關 MaxClientRequestBuffer 登錄機碼的詳細資訊，請參閱微軟知識庫文件 - 260694＜MaxClientRequestBuffer 登錄值說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260694)。


MaxClientRequestBuffer 設得太低
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄機碼，以判定 MaxClientRequestBuffer 值的數值資料：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer

如果 Exchange Server Analyzer 發現 MaxClientRequestBuffer 值的數值資料小於 16,384，就會顯示一則警告。

如果 MaxClientRequestBuffer 的值太低，就會造成 Microsoft Office Outlook® Web Access 使用者發生錯誤。特別是，它會造成 HTTP 400 - Bad Request 傳回瀏覽器。若要更正此警告，建議您將值增加至大於 16,384 的數字，或移除登錄值以還原為預設設定。MaxClientRequestBuffers 值預設不存在。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要藉由增加數值資料的值來更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer

  3. 連按兩下 [MaxClientRequestBuffer] 值，並編輯數值資料。將數值資料設為等於或大於 16,384 的十進位數字。

  4. 關閉登錄編輯程式，然後重新啟動 Exchange 伺服器。
若要藉由移除值來更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer

  3. 以滑鼠右鍵按一下 [MaxClientRequestBuffer] 值，再按一下 [刪除]。

  4. 關閉登錄編輯程式並重新啟動 Exchange 伺服器。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 MaxClientRequestBuffer 登錄值的詳細資訊，請參閱微軟知識庫文件 - 260694＜MaxClientRequestBuffer 登錄值描述＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260694)。


已設定多個 SMTP 通訊埠繫結
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定針對 msExchServerBindings 屬性所設定的值是否已設為多個通訊埠繫結。依預設，msExchServerBindings 屬性是設定為 TCP 通訊埠 25。如果 Exchange Server Analyzer 發現 msExchServerBindings 屬性已設為多個通訊埠繫結，就會顯示非預設的組態訊息。

msExchServerBindings 屬性代表簡易郵件傳送通訊協定 (SMTP) 伺服器用來接聽傳入連線的 TCP 通訊埠。SMTP 虛擬伺服器可設定成接聽一或多個 TCP 通訊埠。在預設的情況下，會將所有的 SMTP 虛擬伺服器設定成接聽 TCP 通訊埠 25。您可以變更 SMTP 接聽通訊埠，只要其餘的內部傳訊基礎結構也都隨之修改即可。不過，由於網際網路上的 SMTP 伺服器通常是透過通訊埠 25 傳送郵件，因此直接從網際網路接受郵件的 SMTP 虛擬伺服器，也應該使用通訊埠 25。

請注意，Exchange Server Analyzer 會檢查 Exchange SMTP 通訊協定虛擬伺服器的值。Exchange SMTP 通訊協定虛擬伺服器可能是 (也可能不是) 直接從網際網路接收郵件的 SMTP 伺服器。有些防毒產品及防垃圾郵件產品的設計是從通訊埠 25 從網際網路接收 SMTP 郵件，再從另一個通訊埠將郵件重新導向到 Exchange SMTP 虛擬伺服器。

若要檢視或修改 SMTP 虛擬伺服器接聽通訊埠

  1. 在 [Exchange 系統管理員] 中，展開 [伺服器]，接著展開一部 Exchange 伺服器，再依序展開 [通訊協定]、[SMTP]。

  2. 以滑鼠右鍵按一下 SMTP 虛擬伺服器 (例如，預設 SMTP 虛擬伺服器)，然後按一下 [內容]。

  3. 選取 [一般] 索引標籤，然後按一下 [進階]。

  4. 會顯示 IP 位址及通訊埠的清單。

    • 若要變更現有的通訊埠，請選取該 IP 位址，再按 [編輯]。

    • 若要移除現有的通訊埠，請選取該 IP 位址，再按 [移除]。

  5. 若要儲存變更，請按一下 [確定]，再按一下 [確定] 以結束 [進階] 對話方塊。

  6. 按一下 [確定]，關閉 SMTP 虛擬伺服器的 [內容] 對話方塊。

若需有關 SMTP 虛擬伺服器設定的詳細資訊，請參閱下列微軟知識庫文件：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163＜XCON: 如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


PING 回覆的大小不同
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會使用特定的 BufferSize 設定值查詢 Win32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 類別，並拿這些設定值與傳回的 BufferSize 值做比較，以判定它們是否相同。

如果傳回的 BufferSize 值不同於傳送的值，就會顯示警告。

此警告表示在傳輸中的某個時候封包遭到截斷。這表示可能發生一般網路失敗，或環境中存在黑洞路由器。

在 TCP/IP 廣域網路 (WAN) 上，透過某些路由進行的通訊會在下列情況失敗：中繼網路區段具有的封包大小比通訊主機上的小，而且路由器沒有針對此狀況傳送適當 ICMP 回應。或者，路徑上的防火牆可能捨棄了此類回應。造成此情況的路由器有時稱為「黑洞」路由器。

出現黑洞路由器可能導致發生各種錯誤，而這些錯誤在程式連接本機子網路上的電腦時是不會發生的。雖然這種行為似乎是間歇的，但在仔細觀察後，您會發現在某些情況下，此行為會重複出現，例如當用戶端讀取遠端主機所傳送的大型檔案時。

如需相關資訊，請遵循 Microsoft 知識庫文章 314825＜如何疑難排解黑洞路由器問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825) 中的指導。

詳細資訊

如需偵測及處理可能之黑洞路由器的相關資訊，請參閱下列資源：

  • Microsoft 知識庫文章 159211＜黑洞路由器的診斷及處理＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211)。

  • ＜路徑傳輸單元最大值 (PMTU) 黑洞路由器＞(英文) (http://go.microsoft.com/fwlink/?LinkId=66963)。


未執行 Ping 測試
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2006-08-09

Microsoft® Exchange Server Analyzer 工具會嘗試查詢 Win32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 類別，以分析各種郵件流程特有組態設定的回應物件。

Win32_PingStatus 通常會傳回具有 24 個內容的物件，這些內容提供類別所傳送之 Ping 封包的詳盡資料。

如果 Exchange Server Analyzer 在連續六次嘗試之後，未收到預期的物件以回應其查詢，則 Exchange Server Analyzer 會顯示警告。

此警告指出無法執行 Win32_PingStatus。

此失敗的最可能原因就是嘗試執行 Win32_PingStatus 命令的電腦正在 Microsoft Windows® 2000 Server 作業系統上執行。Windows 2000 Server 不支援 Win32_PingStatus WMI 類別。

如果嘗試執行 Win32_PingStatus 命令的電腦不在 Windows 2000 Server 作業系統上執行，則問題可能是一般網路問題或權限問題所造成。

更正此錯誤

  1. 確定已啟動 Exchange Server 電腦，且已連線到網路。

  2. 從執行 Exchange Server Analyzer 的電腦使用 PING 命令，以查看是否可以到達目標 Exchange Server 電腦。

  3. 從與目標 Exchange 伺服器位於同一子網路的伺服器執行 PING 命令，以查看是否可以到達目標 Exchange Server 電腦。

  4. 若有防火牆，請檢查遠端程序呼叫 (RPC) 通訊埠是否被封鎖。

  5. 檢查執行 Exchange Server Analyzer 的帳戶之權限。執行 Exchange Server Analyzer 的帳戶，在所掃描的每部 Exchange 伺服器上都必須擁有本機 Administrator 權限。

若需網路連線問題的詳細資訊，請參閱 Microsoft 知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

若需 Exchange Server Best Practices Analyzer 連線問題的詳細資訊，請參閱＜Microsoft Exchange Server Best Practices Analyzer 工具疑難排解連線問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56285)。

若需 Win32_PingStatus WMI 類別的詳細資訊，請參閱 MSDN® 文章＜Win32_PingStatus＞(英文) (http://go.microsoft.com/fwlink/?linkid=33549)。


已停用純文字防毒掃描
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 RTF 郵件防毒掃描的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

如果 Exchange Server Analyzer 發現 ScanPlainText 的值設為 0，就會顯示一則警告。

ScanPlainText 登錄機碼是由使用「Exchange 病毒掃描 API (VSAPI)」的防毒軟體協力廠商設定。建議您掃描所有的郵件類型以檢查是否有病毒，包括純文字郵件。您應該對通過 Exchange Server 電腦的所有郵件進行病毒掃描。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此錯誤

  • 在可察覺到 Exchange 的防毒應用程式中，啟用掃描全部郵件。

    - 或 -

  • 執行下列程序，手動修改登錄中的項目：

    1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

    2. 瀏覽至：

      HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

    3. 在 ScanPlainText 登錄項目上連按兩下，並將其 [數值資料] 設為 1。

    4. 結束登錄編輯程式，重新啟動 Microsoft Exchange Information Store 服務和代表您 Exchange 之防毒軟體的服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關對抗病毒的詳細資訊，請參閱網站的《在 Exchange 2003 環境中減緩及阻止電子郵件病毒》(英文) (http://go.microsoft.com/fwlink/?LinkId=47587)。


登錄中已經設定 POP3 Compatibility 旗標
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定下列登錄值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\Compatibility

如果 Exchange Server Analyzer 發現 Compatibility 值存在且設為值 0xfffffffe (十六進位)，則會顯示非預設的組態訊息。

使用 IMAP4 及郵局通訊協定第 3 版 (POP3) 的 Exchange Server 網際網路通訊協定 (IP) 用戶端電腦，將可以完整利用串流儲存區 (.stm) 檔案來讀取及寫入資料。當 IP 用戶端要求使用 POP3 或 IMAP4 來下載郵件時，包含該使用者信箱的 Exchange 儲存區會在計算收件匣中要傳送至此用戶端的郵件確實大小之後才傳送郵件。在大型環境中 (尤其是被主控的 Exchange 環境)，可能要花相當長時間來計算上述大小。Compatibility 值代表一個組態選項，讓系統管理員用來指示 Exchange 儲存區使用大概的郵件大小，而不用實際算出郵件大小。

依照這份文件的描述，Exchange POP3 服務可以使用 Compatibility 登錄值，依照 在登錄中設定 IMAP4 相容性旗標 的描述，Exchange IMAP4 服務也可以使用此登錄值。

在移動大量信箱或是移動含有大量多用途網際網路郵件延伸標準 (MIME) 郵件的信箱時，Compatibility 登錄值也很有用。移動資料時，資料會從串流儲存區提升到 MAPI 儲存區 (.edb 檔案) 中。若您將用戶端的信箱在資料庫或伺服器之間移動，當用戶端使用 POP3 和 IMAP4 存取其信箱時，可能會遇到效能問題。當使用者登入之後，就必須計算郵件大小，並且在伺服器的記憶體和磁碟上進行 MAPI 至 MIME 轉換。在進行此動作時，於極度異常的情況下，會在 Exchange Server 電腦上建立很大的暫存檔。

並非所有 POP3 和 IMAP4 郵件用戶端都可以和設定的 Compatibility 登錄值正確配合使用。變更此設定值將會導致某些較舊的郵件用戶端 (例如 Fetchmail) 作業中斷。設定此登錄機碼也會中斷 POP3 通訊協定的 RFC 相容性。如果使用 POP3 及 IMAP4 下載郵件時發生問題，而且您正使用 Compatibility 登錄值，可以使用下列程序來刪除該登錄值，作為郵件下載問題的一個疑難排解步驟。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要刪除 Compatibility 登錄值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. 刪除叫做 Compatibility 的值。

  4. 結束登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 及 IIS Admin 兩個服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關使用 Compatibility 登錄機碼的詳細資訊，請參閱下列知識庫文件：

  • 317722＜XADM：當 Exchange 2000 將郵件從 MAPI 轉換為 MIME 格式時，發生用戶端延遲＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317722)

  • 329067＜XADM：移動信箱功能會使 .stm 檔的內容升階＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329067)


POP3 MaxBufferSize 值已經變更
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來判斷下列登錄值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

如果 Exchange Server Analyzer 發現 MaxBufferSize 值存在，並已設定大於 0 的任何數值，就會顯示一則非預設組態的訊息。

MaxBufferSize 登錄值會用於 Exchange 前端/後端拓樸中。它定義前端伺服器與後端伺服器之間的 TCP/IP 緩衝區大小。預設的緩衝區大小是 1 KB。在具有高度延遲的網路中，調整 MaxBufferSize 值，可以改善 POP3 用戶端的效能。

在使用 MaxBufferSize 登錄值設定 TCP/IP 緩衝區大小時，一定要將緩衝區大小設為 1024 的倍數。建議您使用下列緩衝區大小，測試您的前端/後端伺服器組態效能：

  • 8,192 位元組

  • 16,384 位元組

  • 32,768 位元組

當您使用這個登錄項目時，至少要設定為 1,024。建議您不要將 MaxBufferSize 登錄項目的值設定超過 32,768。若緩衝區大小值為 65,536，您或許會發現效能增加了，但這得視您的網路條件而定。緩衝區大小愈大，會耗用更多 Exchange Server 電腦上的記憶體，並且可能會減少可以存取前端伺服器的使用者數目。您可用於 MaxBufferSize 登錄值的最大值並沒有任何限制，如果您對此登錄項目指定的值太大時，將會發生效能不穩定和記憶體問題。

附註：
若要使用 MaxBufferSize 登錄值，您必須執行 Exchange 2000 Server Service Pack 2 或更新的版本。

如果 MaxBufferSize 登錄值設得太低，將無法改善效能，而且 Exchange Server Analyzer 會顯示錯誤訊息 (如＜POP3 MaxBufferSize 值太低＞中所述)。如果設定的 MaxBufferSize 登錄值太高，則會導致系統不穩定，而且 Exchange Server Analyzer 會顯示錯誤訊息，如＜POP3 MaxBufferSize 值太高＞中所述。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. 建立一個新的 DWORD 值，稱為 MaxBufferSize。

  4. 連按兩下 MaxBufferSize 值，並且將其設為新的緩衝區大小 (以位元組為單位)。例如，輸入 8192，將其設為 8192 位元組。

  5. 結束登錄編輯程式，然後重新啟動 Microsoft Exchange POP3 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關使用 MaxBufferSize 登錄值的時機及作法詳細資訊，請參閱知識庫文件 - 823857＜XADM：前端伺服器及後端伺服器間的 IMAP4 及 POP3 效能緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857)。


POP3 MaxBufferSize 值太高
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定下列登錄值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

如果 Exchange Server Analyzer 發現 MaxBufferSize 值存在而且設為大於 32768 的數值，就會顯示一則警告。

MaxBufferSize 登錄值會用於 Exchange 前端/後端拓樸中。它定義前端伺服器與後端伺服器之間的 TCP/IP 緩衝區大小。預設的緩衝區大小是 1 KB。在具有高度延遲的網路中，調整 MaxBufferSize 值，可以改善 POP3 用戶端的效能。

在使用 MaxBufferSize 登錄值設定 TCP/IP 緩衝區大小時，一定要將緩衝區大小設為 1024 的倍數。建議您使用下列緩衝區大小，測試您的前端/後端伺服器組態效能：

  • 8192 位元組

  • 16,384 位元組

  • 32,768 位元組

使用此登錄項目時，至少要設為 1,024。建議您不要將 MaxBufferSize 登錄項目的值設為大於 32,768。不過，您可能會注意到緩衝區大小值為 65,535 時效能會提高，這亦視您的網路狀況而定。緩衝區大小愈大，會耗用更多 Exchange Server 電腦上的記憶體，並且可能會減少可以存取前端伺服器的使用者數目。您可用於 MaxBufferSize 登錄值的最大值並沒有任何限制，如果您對此登錄項目指定的值太大時，將會發生效能不穩定和記憶體問題。

附註：
若要使用 MaxBufferSize 登錄值，您必須執行 Exchange 2000 Server Service Pack 2 或更新版本。

如果 MaxBufferSize 登錄值設得太低，將無法改善效能，而且 Exchange Server Analyzer 會顯示一則錯誤訊息 (如 POP3 MaxBufferSize 值太低中所述)。如果 MaxBufferSize 登錄值設得太高，則可能會導致系統不穩定，而且 Exchange Server Analyzer 會顯示一則訊息 (如本文所述)。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. 建立一個新的 DWORD 值，稱為 MaxBufferSize。

  4. 連按兩下 MaxBufferSize 值，並且將其設為新的緩衝區大小 (以位元組為單位)。例如，輸入 8192，將其設為 8192 位元組。

  5. 結束登錄編輯程式，然後重新啟動 Microsoft Exchange POP3 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關使用 MaxBufferSize 登錄值的時機及作法詳細資訊，請參閱知識庫文件 - 823857＜XADM：前端伺服器及後端伺服器間的 IMAP4 及 POP3 效能緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857)。


POP3 MaxBufferSize 值太低
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定下列登錄值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

如果 Exchange Server Analyzer 發現 MaxBufferSize 值存在，並且設定為大於 0 但小於 1024 的數值，則會顯示錯誤訊息。

MaxBufferSize 登錄值會用於 Exchange 前端/後端拓樸中。它定義前端伺服器與後端伺服器之間的 TCP/IP 緩衝區大小。預設的緩衝區大小是 1 KB。在具有高度延遲的網路中，調整 MaxBufferSize 值，可以改善 POP3 用戶端的效能。

在使用 MaxBufferSize 登錄值設定 TCP/IP 緩衝區大小時，一定要將緩衝區大小設為 1024 的倍數。建議您使用下列緩衝區大小來測試前端/後端伺服器組態效能，以決定您的組織的最佳值：

  • 8192 位元組

  • 16,384 位元組

  • 32,768 位元組

使用此登錄項目時，至少要設為 1,024。建議您不要將 MaxBufferSize 登錄項目的值設為大於 32,768。不過，您可能會注意到緩衝區大小值為 65,535 時效能會提高，這亦視您的網路狀況而定。緩衝區大小愈大，會耗用更多 Exchange Server 電腦上的記憶體，並且可能會減少可以存取前端伺服器的使用者數目。您可用於 MaxBufferSize 登錄值的最大值並沒有任何限制，如果您對此登錄項目指定的值太大時，將會發生效能不穩定和記憶體問題。

附註：
若要使用 MaxBufferSize 登錄值，您必須執行 Exchange 2000 Server Service Pack 2 或更新版本。

如果 MaxBufferSize 登錄值設得太低，將無法改善效能，而且 Exchange Server Analyzer 會顯示一則錯誤訊息 (如本文所述)。如果 MaxBufferSize 登錄值設得太高，則可能會導致系統不穩定，而且 Exchange Server Analyzer 會顯示一則訊息 (如 POP3 MaxBufferSize 值太高所述)。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. 建立一個新的 DWORD 值，稱為 MaxBufferSize。

  4. 連按兩下 MaxBufferSize 值，並且將其設為新的緩衝區大小 (以位元組為單位)。例如，輸入 8192，將其設為 8192 位元組。

  5. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange POP3 服務，讓變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關使用 MaxBufferSize 登錄值的時機及作法詳細資訊，請參閱知識庫文件 - 823857＜XADM：前端伺服器及後端伺服器間的 IMAP4 及 POP3 效能緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857)。


通訊埠未回應
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2006-05-16

Microsoft® Exchange Server Analyzer 工具會查詢使用者定義的伺服器，並嘗試在 TCP 通訊埠 25 預設組態或使用者定義之通訊埠上開啟與所指定伺服器的通訊端連線。如果 Exchange Server Analyzer 沒有收到「有可用的 xx」 的預期自訂回應 (其中 xx 是預設通訊埠 25 或使用者定義的替代通訊埠編號)，就會顯示錯誤。

此錯誤表示無法於想要的 TCP 通訊埠上存取伺服器，且可能會失敗。若要更正此錯誤，您可以對伺服器的連線問題進行疑難排解。

疑難排解伺服器的連線問題

  1. 您能從指定的伺服器使用 Telnet 連線到想要的通訊埠嗎？如果不行，就不是網路問題。

  2. 已插入所有裝置嗎？所有的硬體都能正確運作嗎？

  3. DNS 是否在運作中並且已正確地設定？

  4. 路由器是否能正確運作？

  5. 是否有防火牆阻止您連線？

如需伺服器連線問題疑難排解的相關資訊，請參閱《Microsoft Exchange Server Best Practices Analyzer 工具疑難排解連線問題》(英文) (http://go.microsoft.com/fwlink/?LinkId=56285)。


可能的黑洞路由器
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會使用不同的特定 BufferSize 與 NoFragmentation 設定值來查詢 Win32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 WAN 環境是否具有黑洞路由器。

BufferSize 設定 | NoFragmentation 設定
548 | TRUE
1472 | TRUE
1472 | FALSE
4096 | TRUE
4096 | FALSE

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • 具有較小 BufferSize 與 NoFragmentation = True 的 PING 成功

  • 具有較大 BufferSize 與 NoFragmentation = True 的 PING 逾時

  • 具有較大 BufferSize 與 NoFragmentation = False 的 PING 成功，但回覆的 BufferSize 大小與傳送的 BufferSize 大小不同。

此錯誤表示廣域網路 (WAN) 可能具有一或多個黑洞路由器存在。

若下列條件為真，TCP/IP WAN 在某些路由上通訊可能會失敗：

  • 中繼網路區段具有的封包大小，小於通訊主機上的封包大小

  • 路由器沒有針對此狀況傳送適當 ICMP 回應。

或者，路徑上的防火牆可能捨棄了此類回應。造成此情況的路由器有時稱為「黑洞」路由器。

出現黑洞路由器可能導致發生各種錯誤，而這些錯誤在程式連接本機子網路上的電腦時是不會發生的。雖然這種行為似乎是間歇的，但您會發現在某些情況下，此行為會重複出現，例如當用戶端讀取遠端主機所傳送的大型檔案時。

如需相關資訊，請遵循 Microsoft 知識庫文章 314825＜如何疑難排解黑洞路由器問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825) 中的指導。

詳細資訊

如需偵測及處理可能之黑洞路由器的相關資訊，請參閱下列資源：

  • Microsoft 知識庫文章 159211＜黑洞路由器的診斷及處理＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211)。

  • 《2004 年 7 月 Cable Guy》專欄中的＜路徑傳輸單元最大值＞(英文) (http://go.microsoft.com/fwlink/?LinkId=66963)。


遠端主機 PING 失敗
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2006-05-03

Microsoft® Exchange Server Analyzer 工具會使用各種 BufferSize 及 NoFragmentation 設定，查詢 Win32_PingStatus Microsoft Windows® Management Instrumentation (WMI) 類別，以判定網路的傳輸單元最大值 (MTU)，並尋找可能的黑洞路由器。Exchange Server Analyzer 會檢查遠端主機在每種設定組合下傳回的 StatusCode 機碼值來做出判斷。

BufferSize 設定 | NoFragmentation 設定
548 | TRUE
1472 | TRUE
1472 | FALSE
4096 | TRUE
4096 | FALSE

Win32_PingStatus 會傳回具有 24 個內容的物件，這些內容提供類別所傳送之 Ping 封包的詳盡資料。

如果 Exchange Server Analyzer 發現此機碼的值與下表中的其中一個值相符，將會顯示錯誤。

Exchange Server Analyzer 會顯示遠端主機名稱、Exchange Server 名稱，和連同此錯誤一起傳回的對應 StatusCode 值。

StatusCode 值 意義 描述

11001

緩衝區太小

因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會發生此錯誤。

11002

無法與目的網路連線

無法與包含目的電腦的網路連線，所以要求失敗。沒有通往目的電腦的有效路由存在。

如需相關資訊，請參閱 Microsoft 知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11003

無法與目的主機連線

無法與目的電腦連線，所以要求失敗。

如需相關資訊，請參閱 Active Directory 伺服器當機或無法存取。

或者，下列情況之一也可能造成此錯誤：

  • 執行 Exchange Server Analyzer 所在的位置與目標網域控制站之間的防火牆。

  • DNS 錯誤。

如需相關資訊，請參閱知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11004

無法與目的通訊協定連線

目的電腦沒有回應封包的通訊協定，所以要求失敗。

導致此錯誤的原因可能是執行 Exchange Server Analyzer 所在的位置與目標網域控制站之間的防火牆。

11005

無法與目的通訊埠連線

無法使用目的電腦上的通訊埠，所以要求失敗。

如需相關資訊，請參閱知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11006

沒有資源

網路資源不足，所以要求失敗。

如需相關資訊，請參閱知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11007

錯誤的選項

內含無效的選項，所以要求失敗。

因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會發生此錯誤。

11008

硬體錯誤

發生硬體錯誤，所以要求失敗。

執行電腦製造商所提供的硬體狀況檢查工具，以驗證網域控制站是否正常運作。

11009

封包太大

包含要求的封包超過位於來源和目的地間之路由器或閘道節點的傳輸單元最大值 (MTU)，所以要求失敗。MTU 定義了可傳輸封包的大小上限。

Exchange Server Analyzer 傳送之要求的大小不大於 10 KB。請確認組織中的路由器和閘道都已適當設定。

如需相關資訊，請參閱知識庫文章 159211＜黑洞路由器的診斷及處理＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211)。

11010

要求逾時

未在配置的時間內收到回覆。允許的回覆時間預設為 5 秒。

如需相關資訊，請參閱知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11011

錯誤的要求

編碼方式不正確，所以要求失敗。

因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會發生此錯誤。

11012

錯誤的路由

來源和目的電腦之間無有效的路由，所以要求失敗。

如需相關資訊，請參閱知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11013

TimeToLive 過期轉送

要求的存留時間 (TTL) 值已達零，所以要求失敗。這會使得轉寄的路由器或閘道節點將封包捨棄。

如需相關資訊，請參閱知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11014

TimeToLive 過期重組

封包已分割為片段以進行傳輸，但未能在配置的時間內收到所有片段進行重組，所以要求失敗。RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) 指定將 60 秒作為接收所有封包片段的時間限制。

如需相關資訊，請參閱知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

11015

參數問題

處理封包標頭時，路由器或閘道節點發生問題，所以要求失敗。如果標頭包含無效的欄位資料或無法辨識的選項，便會出現此狀態。

因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會發生此錯誤。

11016

來源抑制

封包被捨棄，所以要求失敗。來源電腦的輸出佇列儲存空間不足時，便會出現此狀態。或者是在封包抵達目的地的速度太快，導致來不及處理時，也會發生。

因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會發生此錯誤。

11017

選項太大

內含無效的選項，所以要求失敗。

因為 Exchange Server Analyzer 產生的是標準要求，因此通常不會發生此錯誤。

11018

錯誤的目的地

由於下列其中一個原因，所以要求失敗：

  • 目的 IP 位址無法接收 PING 要求。

  • 目的 IP 位址不該在任何 IP 資料包的目的位址欄位中出現。

導致此狀況的原因可能是執行 Exchange Server Analyzer 所在的位置與目標網域控制站之間的防火牆。

11032

交涉 IPSEC

因為無法交涉 IPsec 連線，所以要求失敗。

11050

一般失敗

不明原因造成要求失敗。

如需相關資訊，請參閱知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

如需這些測試的相關資訊，請參閱 Microsoft 知識庫文章 314825＜如何疑難排解黑洞路由器問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825)。


Routing Engine 已停止
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Microsoft Exchange Routing Engine 服務 (RESvc) 及簡易郵件傳送通訊協定 (SMTP) 服務 (SMTPSVC) 是否正在執行。若 Exchange Server Analyzer 發現下列任一條件符合，便會顯示錯誤：

  • SMTPSVC 執行中。

  • 未執行 RESvc。

若 RESvc 並未在所有轉送郵件的 Exchange 伺服器上執行，即可能產生路由問題。在未執行 RESvc 的情況下轉送郵件，並不是受支援的 Exchange Server 組態。

如同 Exchange 2000 Server，Exchange Server 2003 會使用連結狀態路由演算法及路由通訊協定，來以連結狀態表格形式傳用連結狀態資訊。連結狀態表格儲存在組織內所有 Exchange 2000 Server 及 Exchange Server 2003 伺服器的記憶體中。

連結狀態演算法具有下列優點：

  • 每部 Exchange 伺服器皆可在來源選取最佳郵件路由，而不是沿用不具連結的路由傳送郵件。

  • 郵件不會再於伺服器之間相互反覆傳遞，因為每部 Exchange 伺服器都能獲得當時是否有替代路由或備援路由可供使用的相關資訊。

  • 不會再發生訊息迴圈。在 Exchange Server 的較早版本中，有時會出現訊息迴圈的問題。

Exchange Server 會從連結狀態表格中收集下列資訊：

  • 連結狀態表格會記載整個 Exchange 組織的路由拓撲。

  • 連結狀態表格會記載拓撲中每個連接器的可用性。可用的拓撲為「開啟」。無法使用的拓撲為「關閉」。

  • 連結狀態表格會記載每個可用連接器的相關成本與位址空間。

Exchange Server 會使用這項資訊來判定成本最低的目的地位址路由。若沒有沿用最低成本路由的連接器可供使用，Exchange Server 會根據成本與連接器可用性來判定最佳替代路由。使用連結狀態路由時必須要有 RESvc。

若要更正這項錯誤，必須將 RESvc 設為自行啟動。同時必須確定 RESvc 在生產期間處於執行中。

若要更正此錯誤

  1. 按一下 [開始]，依序指向 [程式集]、[系統管理工具]，然後按一下 [服務]。

  2. 在服務清單中的 Microsoft Exchange Routing Engine 上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 在 [啟動類型] 功能表的 [一般] 索引標籤上，選取 [自動]，然後按一下 [確定]。

  4. 在 Microsoft Exchange Routing Engine 上按一下滑鼠右鍵，然後按一下 [啟動]。

若需有關在 Exchange Server 2003 中路由傳送郵件的詳細資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47579)。


RPC Performance Counters Indicate Poor Server Performance
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2006-08-24

Microsoft® Exchange Server Analyzer 工具判定您伺服器未在最佳的效能中運作。Exchange Server Analyzer 會評估許多遠端程序呼叫 (RPC) 效能計數器。如果 RPC 效能計數器中報告的資料並未順利對照下表中的層級，將顯示警告。

Exchange Server 上的使用者數目 | RPC Averaged Latency 閾值
少於 500 | 平均值大於 15
大於或等於 500，但少於 3000 | 平均值大於 30
大於 3000 | 平均值大於 50

本文章會討論下列效能計數器，而這些計數器是由 MSExchangeIS 效能物件所管理：

  • RPC Averaged Latency

  • RPC Requests

RPC Averaged Latency

RPC Averaged Latency 效能計數器會記錄處理前 1024 個封包所需的平均時間 (以毫秒為單位)。延遲代表 Store.exe 處理程序接收封包到傳回封包所花的時間。RPC Averaged Latency 效能計數器不包含任何網路延遲或任何由其他非 Store.exe 處理程序的項目所造成的延遲。雖然 RPC Averaged Latency 效能計數器資料不包含網路傳輸時間，但是它會提供關於用戶端電腦等待伺服器回應的最短時間的資料。如果 RPC Averaged Latency 效能計數器資料低於 50 毫秒，伺服器就可以合理的時間來處理要求。如果計數器在數秒之後還是大於 50 毫秒，這表示伺服器在處理負載上發生困難。因此，使用者在存取電子郵件時可能會遭遇延遲。如果平均的延遲大於 100 毫秒，使用者會從其 Microsoft Office Outlook® 用戶端電腦接收到下列快顯視窗：[正在從 Exchange Server 擷取資料。]

解譯 RPC Averaged Latency 效能計數器

RPC Averaged Latency 計數器在下列兩個狀況中可能會被誤導：

  • 第一，某些 MAPI 作業應該花較長的時間。例如，如果用戶端電腦搜尋一個包含數以千計之項目的資料夾，嘗試找出所有符合複雜準則的項目，則這類作業通常會花上數秒。如果伺服器上有少數的使用者，則這個持續作業會造成 RPC Average Latency 受阻。如果伺服器上的 RPC 負載低，請以一段較長的時間 (至少數分鐘) 來觀察這個值的平均值，不要因其短暫表現而採取動作。

  • 當伺服器上的 RPC 負載非常低時，就可能會發生第二個狀況。有些時候，視最忙碌使用者的活動而定，延遲可能會有巨大的變化。因為伺服器負載通常是非常緊繃的，所以單一使用者若進行大量的作業會在無意間破壞 RPC 平均延遲資料。

RPC Requests

RPC Requests 效能計數器會記錄 Exchange 目前正在處理中的用戶端電腦要求數。該計數器的最大值為 100。在 Exchange 儲存區處理 100 個 RPC 作業後，通常會拒絕任何新的連線。在狀況良好的伺服器上，未完成的要求數應該要小於 50 個。如果此數目長時間大於 50，這表示已備份 RPC 並等候處理，而用戶端電腦就可能發生延遲的狀況。

解譯 RPC 要求

50 個要求的閾值不是絕對的閾值。負載較輕的伺服器在計數器達到 30 前可能會開始遇到效能的問題，然而負載較重的伺服器在達到 50 個要求時可能仍可以正常運作。理想的狀況是，應該為每部伺服器測量此計數器的基準值。Exchange Server Performance Troubleshooting Analyzer 使用閾值 50，這個數字適合多數大型伺服器。

與負載重的伺服器相較，負載輕的伺服器具有的 RPC 要求值較少。原因是，負載輕的伺服器需要較少的執行緒就可跟上負載的速度。若要避免落後並取得較大的 RPC 要求值，較忙碌的伺服器必須執行更多並行工作。因此，在負載重的伺服器上，較大的 RPC 要求值本身並不表示效能發生問題。若要存取較慢的伺服器，您也必須考量 RPC Average Latency 效能計數器。

延遲的原因

下列事項可能是增加延遲的原因：

  • RPC 負載增加

  • 一或多個伺服器資源發生瓶頸

此外，下列事項是可能造成瓶頸的原因：

  • 高 RPC 負載 (或伺服器上的任何其他負載)

  • 硬體故障或組態錯誤

若要更正此錯誤

  • 請遵照下列 Exchange Server 2003 手冊中提供的建議及最佳作法：

    • 《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)

    • 《Exchange Server 2003 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)


已在非叢集伺服器上設定 RPC 通訊埠範圍
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄機碼，以判定通訊埠的數值資料：

HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\Internet\Ports

如果 Exchange Server Analyzer 發現下列條件為真，則會顯示錯誤：

  • HKLM\Software\Microsoft\Rpc\Internet\Ports 機碼已存在。

  • 伺服器不是叢集 Exchange 伺服器。

  • 伺服器發生其他錯誤。

登錄機碼存在時，Exchange Server 會將 RPC 呼叫限制為特定的通訊埠範圍。如果 Exchange 伺服器正在承受負載，且需要的通訊埠比目前能提供的更多，就會發生錯誤。

若要更正此問題，您應該將 100 個額外通訊埠新增至 HKLM\Software\Microsoft\Rpc\Internet\Ports 機碼，直到問題解決為止。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要更正此警告

  1. 開啟登錄編輯程式 Regedt32.exe。

    附註：
    若要編輯 REG_MULTI_SZ 值，必須使用 Regedt32.exe 而不要使用 Regedit.exe。

  2. 瀏覽至：HKLM\Software\Microsoft\Rpc\Internet。

  3. 在右窗格中，按兩下 Ports 機碼。在數值方塊中，增加通訊埠範圍。

  4. 關閉登錄編輯程式並重新啟動 Exchange 伺服器。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 HKLM\Software\Microsoft\Rpc\Internet 登錄機碼的詳細資訊，請參閱微軟知識庫文件 - 154596＜HOWTO：設定 RPC 動態連接埠配置以使用防火牆 ＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=154596)。


已在叢集伺服器上設定 RPC 通訊埠範圍
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄機碼，以判定通訊埠的數值資料：HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\Internet\Ports

如果 Exchange Server Analyzer 發現下列條件為真，則會顯示錯誤：

  • HKLM\Software\Microsoft\Rpc\Internet\Ports 機碼已存在。

  • 伺服器是叢集 Exchange 伺服器。

  • 伺服器發生其他錯誤。

登錄機碼存在時，Exchange Server 會將 RPC 呼叫限制為特定的通訊埠範圍。如果 Exchange 伺服器正在承受負載，且需要的通訊埠比目前能提供的更多，就會發生錯誤。

若要更正此問題，您應該額外新增 100 個通訊埠至 HKLM\Software\Microsoft\Rpc\Internet\Ports 機碼的值，直到問題得到解決為止。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要更正此警告

  1. 開啟登錄編輯程式 Regedt32.exe。

    附註：
    若要編輯 REG_MULTI_SZ 值，必須使用 Regedt32.exe 而不要使用 Regedit.exe。

  2. 瀏覽至：HKLM\Software\Microsoft\Rpc\Internet。

  3. 在右窗格中，按兩下 Ports 機碼。在數值方塊中，增加通訊埠範圍。

  4. 關閉登錄編輯程式並重新啟動 Exchange 伺服器。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 HKLM\Software\Microsoft\Rpc\Internet 登錄機碼的詳細資訊，請參閱微軟知識庫文件 - 154596＜HOWTO：設定 RPC 動態連接埠配置以使用防火牆＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=154596)。


來自效能計數器的 RPC 使用者活動
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2007-02-14

Microsoft® Exchange Server Analyzer 工具判斷您的伺服器目前遇到高遠端程序呼叫 (RPC) 負載。

每秒 RPC 作業數的速率是伺服器上有多少 RPC 負載的指示。有時，RPC 操作負載的意外增加，可能會造成伺服器效能不佳。如果伺服器遇到效能問題，應該先識別伺服器上的負載是否高於預期。有幾個效能計數器可提供伺服器上 RPC 活動的相關資訊。本文所討論之下列效能計數器都是在 [MSExchangeIS]、[MSExchangeIS Public] 或 [MSExchangeIS Mailbox] 效能物件下：

  • RPC Operations/sec

  • Active User Count

  • Active Client Logons (MSExchangeIS Public)

  • Active Client Logons (MSExchangeIS Mailbox)

識別用戶端 RPC 負載

有兩個計數器可用來識別用戶端電腦的目前活動率。

  • RPC Operations/sec 此計數器提供用戶端電腦目前向伺服器要求的 RPC 每秒操作數。您可以按下列方式計算使用者：

    • 您可以計算伺服器上的信箱總數。

    • 您可以計算登入的總數 (MSExchangeIS Public 的 Active Client Logons 以及 MSExchangeIS Mailbox 的 Active Client Logons 之總和)。

    • 您可以由 [Active User Count] 計算登入總數。

    Exchange Server Analyzer 使用最後一個方法。若要計算每個作用中使用者的比率，請將平均 [RPC Operations/sec] 除以 [Active User Count]。

  • RPC Operations/sec per user 此計數器提供伺服器上使用者的活動程度指示。通常，使用 Microsoft Office Outlook® 的知識工作者在信箱伺服器上的比率為每個使用者每秒約 0.1 個操作數。如果伺服器上的使用者執行其他應用程式，則數目可能會增加。

如果 Exchange Server Analyzer 判斷 RPC 每秒每使用者的操作數大於 0.15 而小於 0.25，會將使用者視為中度活躍，且 Exchange Server Analyzer 會顯示警告。

如果 Exchange Server Analyzer 判斷 RPC 每秒每使用者的操作數大於 0.25，會將使用者視為經常活躍，且 Exchange Server Analyzer 會顯示錯誤。

RPC 負載高的應對方式

如果每秒操作數高於預期，應先嘗試識別高負載的原因，再減少負載。您可以使用 Exchange Server User Monitor (ExMon) 工具，識別是否有特定使用者發出高速率的 RPC 操作。

如果您無法減少伺服器上的負載，必須識別效能瓶頸，增加伺服器的處理能力。

識別高登入數

伺服器必須在記憶體 (使用者及核心記憶體) 中保留一些登入相關資訊。保留的記憶體數量有限。如果使用了這個記憶體，伺服器可能會遇到記憶體瓶頸。因此，若 Exchange 伺服器上遇到效能問題，應確定每個使用者的登入總數不可過多。

一般的知識工作者會有 2 到 3 個登入。如果使用者執行其他應用程式，登入數會增加。Exchange Server Analyzer 計算每個使用者登入數的方式是將伺服器登入總數除以伺服器上信箱數。您可以將 [MSExchangeIS Mailbox] 與 [MSExchangeIS Public] 效能物件上的 [Active Client Logons] 效能計數器加總，來判斷伺服器登入總數。若為信箱或信箱與公用資料夾混合伺服器，Exchange Server Analyzer 只會檢視此比率。

附註：
如果有許多使用者檢視其他使用者的共用資料夾 (如共用行事曆)，登入數可能也會比較高。

如果每個使用者平均登入數大於 5，且伺服器遇到記憶體瓶頸，這可能表示使用者執行了建立大量登入的應用程式。如果使用者執行非業務使用所必需的應用程式，請要求使用者不要執行造成對 Exchange 伺服器過多登入的應用程式。

如果不能減少使用者執行的應用程式數量，則必須將使用者移至其他伺服器以減少每個伺服器的使用者數。若要判斷登入是由許多使用者所造成，或是單一使用者不成比例的大量登入所致，可以使用 [Exchange 系統管理員] 來檢視每個使用者的作用中登入。

詳細資訊

  • 若需有關 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需有關疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《疑難排解 Microsoft Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


已停用 RTF 防毒掃描
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 RTF 郵件防毒掃描的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

如果 Exchange Server Analyzer 發現 ScanRTF 的值設為 0，則會顯示一則警告。

ScanRTF 登錄機碼是由使用「Exchange 病毒掃描 API (VSAPI)」的防毒軟體協力廠商所設定。RTF 郵件允許您使用色彩、字型及格式化，但只有 Microsoft Office Outlook® 2003 才可讀取 RTF 格式。Exchange Server RTF 格式的讀取方式與在文書處理器 (如 Microsoft Office Word 2003) 中讀取 RTF 格式的檔案不同。

建議您掃描所有郵件類型中的病毒，包含 RTF 郵件。您應該對通過 Exchange Server 電腦的所有郵件進行病毒掃描。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此錯誤

  1. 在可察覺到 Exchange 的防毒應用程式中，啟用掃描全部郵件。

    或

  2. 執行下列程序，手動修改登錄中的項目：

    • 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

    • 瀏覽至：

      HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

    • 在 ScanRTF 登錄項目上連按兩下，並將其 [數值資料] 設為 1。

    • 結束登錄編輯程式，重新啟動 Microsoft Exchange Information Store 服務和代表您 Exchange 之防毒軟體的服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關對抗病毒的詳細資訊，請參閱網站的《在 Exchange 2003 環境中減緩及阻止電子郵件病毒》(英文) (http://go.microsoft.com/fwlink/?LinkId=30732)。


SMTP 橫幅已經過自訂
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會嘗試傳送郵件至簡易郵件傳送通訊協定 (SMTP) 網域的郵件管理員帳戶或使用者定義的帳戶。如果 Exchange Server Analyzer 從該帳戶收到的回應不是下列預設回應，就會顯示警告：

"220 Computer Name .Domain Name .com Microsoft ESMTP MAIL Service, Version:Version Number ready at Date Time +0000"

此警告表示已經自訂當程式連接至 Exchange SMTP 虛擬伺服器時所出現的預設回應。

如果 Exchange Server 系統管理員是刻意按照下列文章所述變更橫幅，則自訂的 SMTP 橫幅就不是問題：Microsoft 知識庫文章 281224＜XCON：＜如何修改 SMTP 橫幅＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=281224)。

如果 Exchange Server 系統管理員並未刻意變更預設 SMTP 橫幅，則此警告表示 Exchange Server 可能位於會篩選 Exchange Server Extended SMPT (ESMTP) 命令的防火牆或 SMTP Proxy 後面。

如果篩選 Exchange Server ESMTP 命令，則 Exchange 效能可能會受到顯著的影響，因而產生 Microsoft 知識庫文章 320027＜無法在 Cisco PIX 防火牆後面傳送或接收電子郵件＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027) 所述的行為。

如需自訂的 SMTP 橫幅的相關資訊，請參閱下列 Microsoft 知識庫文章：

  • ＜XCON：＜如何修改 SMTP 橫幅＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=281224)。

  • ＜無法在 Cisco PIX 防火牆後面傳送或接收電子郵件＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027)。


SMTP 執行個體已暫停
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2006-05-16

Microsoft® Exchange Server Analyzer 工具會查詢 IIS Metabase，以判定每個簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器執行個體的 ServerState 內容值。

ServerState 內容代表伺服器執行個體目前的狀態。狀態及相對應的狀態代碼如下：1 (啟動中)、2 (已啟動)、3 (停止中)、4 (已停止)、5 (暫停中)、6 (已暫停) 或 7 (繼續中)。

如果 Exchange Server Analyzer 工具判定 SMTP 虛擬伺服器執行個體的 ServerState 內容值等於 6 (已暫停)，就會顯示錯誤。

SMTP 是 Exchange Server 的原生郵件通訊協定，用來進行郵件提交與郵件傳輸。這表示用戶端使用 SMTP 來傳送郵件，而 Exchange 伺服器使用 SMTP 來傳遞郵件和郵件資料。

虛擬伺服器執行所在的伺服器處理程序和其他伺服器處理程序很像，您可以予以啟動、停止及暫停。例如，如果您變更虛擬伺服器的組態或是執行其他維護工作，您可能必須停止虛擬伺服器、進行變更，然後再重新啟動它。停止虛擬伺服器時，它不會接受來自使用者的連線，您也不能用它來傳遞或擷取郵件。

另一種停止虛擬伺服器的方式就是暫停它。當您暫停虛擬伺服器時，會無法建立新的用戶端連線，但不會中斷目前的連線。當您暫停 SMTP 虛擬伺服器時，作用中用戶端可以繼續提交郵件，而虛擬伺服器可以傳遞已進入佇列等待傳遞的現有郵件。然而，不會接受任何新的連線。

若要如常進行郵件傳遞的作業，Exchange Server SMTP 虛擬伺服器執行個體應該要「已啟動」。

若要解決此錯誤，請遵循下列步驟，啟動 SMTP 虛擬伺服器執行個體。

啟動 SMTP 虛擬伺服器執行個體

  1. 在 [Exchange 系統管理員] 中，以滑鼠右鍵按一下您要啟動的虛擬伺服器執行個體。

  2. 在 [動作] 功能表上，按一下 [啟動]。

如需如何啟動、停止或暫停 SMTP 虛擬伺服器的相關資訊，請參閱下列 Microsoft 知識庫文章：

  • ＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=266686)。

  • ＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)。

  • ＜XIMS：如何在 Exchange 2000 Server 中清除 SMTP 郵件佇列＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=251087)。

  • ＜XGEN：在 Exchange 2000 中停用通訊協定＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=291330)。


SMTP 執行個體已停止
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2006-05-16

Microsoft® Exchange Server Analyzer 工具會查詢 IIS Metabase，以判定每個簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器執行個體的 ServerState 內容值。

ServerState 內容代表伺服器執行個體目前的狀態。狀態及相對應的狀態代碼如下：1 (啟動中)、2 (已啟動)、3 (停止中)、4 (已停止)、5 (暫停中)、6 (已暫停) 或 7 (繼續中)。

如果 Exchange Server Analyzer 工具判定 SMTP 虛擬伺服器執行個體的 ServerState 內容值等於 4 (已停止)，就會顯示錯誤。

SMTP 是 Exchange Server 的原生郵件通訊協定，用來進行郵件提交與郵件傳輸。這表示用戶端使用 SMTP 來傳送郵件，而 Exchange 伺服器使用 SMTP 來傳遞郵件和郵件資料。

虛擬伺服器執行所在的伺服器處理程序和其他伺服器處理程序很像，您可以予以啟動、停止及暫停。例如，如果您變更虛擬伺服器的組態或是執行其他維護工作，您可能必須停止虛擬伺服器、進行變更，然後再重新啟動它。停止虛擬伺服器時，它不會接受來自使用者的連線，您也不能用它來傳遞或擷取郵件。

若要如常進行郵件傳遞的作業，Exchange Server SMTP 虛擬伺服器執行個體應該要「已啟動」。

若要解決此錯誤，請遵循下列步驟，啟動 SMTP 虛擬伺服器執行個體。

啟動 SMTP 虛擬伺服器執行個體

  1. 在 [Exchange 系統管理員] 中，以滑鼠右鍵按一下您要啟動的虛擬伺服器執行個體。

  2. 在 [動作] 功能表上，按一下 [啟動]。

如需如何啟動、停止或暫停 SMTP 虛擬伺服器的相關資訊，請參閱下列 Microsoft 知識庫文章：

  • ＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • ＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)。

  • ＜XIMS：如何在 Exchange 2000 Server 中清除 SMTP 郵件佇列＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=251087)。

  • ＜XGEN：在 Exchange 2000 中停用通訊協定＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=291330)。


SMTP 最大收件者數目可能設得太低
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 msExchSmtpMaxRecipients 屬性的設定值是否小於 250。在預設的情況下，msExchSmtpMaxRecipients 屬性是設為 64,000 個收件者。如果 Exchange Server Analyzer 發現 msExchSmtpMaxRecipients 屬性設為小於 250 的值，就會顯示警告。

從安全性觀點來看，最佳作法是限制每封郵件的最大收件者數目。建議您將 msExchSmtpMaxRecipients 屬性設為預設值 64000。

每個組織都應以其自身業務需求為基礎，判定其可接受的最大收件者數目。不過，建議您不要將收件者最大數設為小於 250 的值。發送到多個通訊群組清單的郵件很可能具有 250 個以上的收件者。 如果您將最大收件者數目設為小於 250 的值，則 Exchange 必須使用額外的郵件複本來處理其餘收件者。這些額外複本將導致網路傳輸增加。

檢視及設定最大收件者數目

  1. 開啟 [Exchange 系統管理員]。

  2. 依序展開 [伺服器]、Exchange 伺服器、[通訊協定] 與 [SMTP]。

  3. 在 SMTP 虛擬伺服器 (例如，預設的 SMTP 虛擬伺服器) 上按一下滑鼠右鍵，然後選取 [內容]。

  4. 選取 [郵件] 索引標籤。

  5. 若要還原為預設設定 64000，請確定已選取 [將每封郵件的收件者數目限制為] 核取方塊，再輸入值 64000。或者，您可以將此欄位設為所需的任意值，或者清除核取方塊以允許無限制的收件者數目。

  6. 按一下 [確定] 以儲存變更並關閉 SMTP 虛擬伺服器的 [內容] 對話方塊。

若需 SMTP 虛擬伺服器設定的相關資訊，請參閱下列微軟知識庫文件：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163＜XCON:如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


已覆寫 EAS 的 SMTP Proxy 位址
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

錯誤訊息

簡介

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已覆寫 Exchange ActiveSync® 的 SMTP Proxy 位址：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MasSync\Parameters\SMTPProxy

如果 Exchange Server Analyzer 發現 SMTPProxy 登錄項目存在而且已設定，就會顯示非預設的組態訊息。

SMTP 地址是用來識別 Exchange Server 中的信箱路徑，而且這些地址必須是獨一無二的。每一個地址都有以 @ 符號分隔的左側 (LHS) 部分和右側 (RHS) 部分。例如，SMTP 地址的格式如下：

Username@domain.com = left-hand-side@right-hand-side (或 LHS@RHS)

Exchange ActiveSync 使用 WebDAV 要求來存取 Exchange 伺服器的信箱資訊。Exchange ActiveSync 會選取相關聯的 RHS 值以及代表 SMTP Proxy 位址的 LHS@RHS 來用於 WebDAV 要求中。在預設 RHS 地址與使用者的主要 SMTP 地址不同的環境中，SMTPProxy 登錄值會提供可讓 Exchange ActiveSync 使用其他 SMTP Proxy 位址的組態機會。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要檢視或修改 SMTPProxy 登錄值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：

    HKLM\System\CurrentControlSet\Services\MasSync\Parameters

  3. 檢查及 (如果需要) 變更 SMTPProxy 值。

  4. 如果做了變更，請關閉登錄編輯程式，然後重新啟動 Exchange Server 電腦，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Exchange ActiveSync 的詳細資訊，請參閱《Exchange Server 2003 ActiveSync 結構》(英文) (http://go.microsoft.com/fwlink/?linkid=34203)。

若需有關行動存取及 Exchange Server 2003 的詳細資訊，請參閱《使用 Exchange 2003 進行行動存取》(英文) (http://go.microsoft.com/fwlink/?linkid=20098)。


SMTP 伺服器接受基本驗證
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 Exchange Server 物件之 protocolCfgSMTPServer 類別中的 msExchAuthenticationFlags 屬性值。protocolCfgSMTPServer 類別包含 SMTP 虛擬伺服器的設定。msExchAuthenticationFlags 屬性代表 SMTP 伺服器上允許的驗證類型。如果 Exchange Server Analyzer 判定已在 SMTP 伺服器上設定基本驗證，且該伺服器並非 Microsoft Small Business Server 2000 或 Microsoft Windows® Small Business Server 2003，就會顯示一則警告訊息。

若 SMTP 伺服器上設定了基本驗證，則安全性漏洞的風險將會提高。基本驗證允許使用者名稱與密碼以純文字的方式在網路間傳送。在未加密的情況下，使用者名稱與密碼在網際網路上可輕易地被攔截。

若您使用基本驗證，強烈建議您同時使用 Transport Layer Security (TLS) 加密來強化安全性。TLS 可為使用者名稱、密碼與郵件資料進行加密。您可以要求即將連線到 SMTP 虛擬伺服器的用戶端使用 TLS 加密。根據設計，TLS 有助於保護外寄郵件，但無法用來保護從用戶端到伺服器的郵件傳輸。

Microsoft Outlook Express 支援 TLS。若要對 SMTP 虛擬伺服器使用 TLS 加密，您必須建立金鑰組並設定金鑰憑證。接著，用戶端就可以使用 TLS 為含有 SMTP 服務的工作階段進行加密。因此，所有郵件都會傳送。SMTP 服務也可以使用 TLS 為遠端伺服器的工作階段進行加密。

附註：
不支援 TLS 的用戶端即無法透過虛擬伺服器轉送電子郵件。

若您因為商業因素而無法停用 SMTP 虛擬伺服器上的已驗證存取 (例如合夥公司的驗證)，請遵循下列步驟來強化閘道伺服器上的安全性：

  • 對所有使用者帳戶強制執行強式密碼原則，特別是對系統管理員帳戶。

  • 停用來賓帳戶。若需有關停用來賓帳戶的詳細資訊，請參閱微軟知識庫文件 - 320053＜如何重新命名 Windows 2000 中的系統管理員及來賓帳戶＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320053)。雖然這份文件適用於 Microsoft Windows 2000 Server，但相似的原則也適用於 Windows Server™ 2003。

停用基本驗證

  1. 在 [Exchange 系統管理員] 中，展開 [伺服器]，接著展開 <your inbound Exchange server>，再依序展開 [通訊協定] 與 [SMTP]。

  2. 以滑鼠右鍵按一下輸入的 SMTP 虛擬伺服器，再按一下 [內容]。

  3. 按一下 [存取] 索引標籤，然後按一下 [驗證]。

    驗證對話方塊

  4. 在 [驗證] 中，清除 [基本驗證] 核取方塊。

    重要事項：
    若您使用基本驗證，請考慮實作 TLS 以強化安全性。若您具有數位憑證，請使用 [要求 TLS 加密] 核取方塊。數位憑證在高安全性的環境中很普遍。若選取此核取方塊，則在對應的 [預設網域] 方塊中，必須鍵入 Windows 2000 Server 網域名稱或 Windows Server 2003 網域名稱，使用者在未指定網域時應驗證該網域名稱。如需 TLS 加密的詳細資訊，請參閱 Exchange 線上文件。

若需有關如何設定 Exchange Server 2003 組織以更安全地收發網際網路郵件的詳細資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=26041)。


已停用 SMTP 服務
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2006-05-16

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定為簡易郵件傳送通訊協定 (SMTP) 服務 StartMode 機碼所設定的值。Disabled 值表示已停用簡易郵件傳送通訊協定 (SMTP) 服務，且除非將 StartMode 值變更為 Manual 或 Automatic，否則無法啟動。

Exchange Server Analyzer 會查詢 Win32_Service WMI 類別，以判斷 SMTP 服務的 Started 機碼值。False 值表示服務不在執行中。True 值表示服務正在執行中。

如果 Exchange Server Analyzer 在已啟動 SMTP 服務的 Exchange Server 電腦上發現 StartMode 機碼值設為 Disabled，就會顯示錯誤。

Windows SMTP 服務是網際網路資訊服務 (IIS) 的元件，是以 Inetinfo.exe 的一部份執行。Exchange Server 依賴 SMTP 服務作為其原始的傳輸通訊協定。因此，Exchange 使用 SMTP 來路由傳送所有的內部與外部郵件。

所有 Exchange Server 電腦的 SMTP 服務都應該設為 Automatic。

若要解決此錯誤，您必須設定 SMTP 服務在路由傳送郵件的伺服器上自動啟動。

設定簡易郵件傳送通訊協定 (SMTP) 服務自動啟動

  1. 開啟 [服務] Microsoft Management Console (MMC) 嵌入式管理單元。

  2. 按兩下 [Simple Mail Transfer Protocol (SMTP)] 服務。

  3. 在 [Simple Mail Transfer Protocol (SMTP) 內容] 頁面的 [一般] 索引標籤上，從 [啟動類型] 下拉對話方塊選取 [自動]，然後按一下 [套用]。

  4. 在 [服務狀態] 下，按一下 [啟動]，再按一下 [確定]。

  5. 關閉 [服務] 嵌入式管理單元。

如需 SMTP 服務及 Exchange 伺服器的相關資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》中的＜SMTP 傳輸結構＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

如需如何針對 Exchange 設定 SMTP 服務的相關資訊，請參閱＜在 Microsoft Exchange 2000 Server 中設定 SMTP＞(英文) (http://go.microsoft.com/fwlink/?linkid=24866)。


未啟動 SMTP 服務
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2007-03-13

Microsof® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定簡易郵件傳送通訊協定 (SMTP) 服務的 Started 機碼值。False 值表示 SMTP 服務不在執行中。True 值表示 SMTP 服務正在執行中。

如果 Exchange Server Analyzer 發現 Started 機碼值設為 False，就會顯示錯誤。

Windows SMTP 服務是網際網路資訊服務 (IIS) 的元件，是以 Inetinfo.exe 的一部份執行。Exchange Server 依賴 SMTP 服務作為其原始的傳輸通訊協定。因此，Exchange 使用 SMTP 來路由傳送所有的內部與外部郵件。

Exchange 伺服器上永遠都要執行 SMTP 服務。

更正此錯誤

  1. 開啟 [服務] Microsoft Management Console (MMC) 嵌入式管理單元。

  2. 在右窗格中，向下捲動至 [簡易郵件傳送通訊協定 (SMTP)] 服務，然後對它按兩下。如此將顯示 [簡易郵件傳送通訊協定 (SMTP) 內容] 對話方塊。

  3. 將 [啟動類型] 下拉功能表中的值設定為 [自動]。

  4. 按一下 [啟動] 以啟動 System Attendant 服務。

  5. 按一下 [確定] 以儲存變更，並關閉 [簡易郵件傳送通訊協定 (SMTP) 內容] 對話方塊。

  6. 關閉 [服務] 嵌入式管理單元。

如需簡易郵件傳送通訊協定 (SMTP) 服務及 Exchange 伺服器的相關資訊，請參閱《Exchange Server 2003 技術參考手冊》中的＜SMTP 傳輸結構＞(http://go.microsoft.com/fwlink/?LinkId=47891)。

如需如何針對 Exchange 設定 SMTP 服務的相關資訊，請參閱＜在 Microsoft Exchange 2000 Server 中設定 SMTP＞(英文) (http://go.microsoft.com/fwlink/?linkid=24866)。


SMTP 服務設為手動
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2006-05-16

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定為簡易郵件傳送通訊協定 (SMTP) 服務 StartMode 機碼所設定的值。Manual 值表示簡易郵件傳送通訊協定 (SMTP) 服務已設為需要手動啟動，因此將不會自動啟動。

Exchange Server Analyzer 也會查詢 Win32_Service WMI 類別，以判定 SMTP 服務的 Started 機碼值。False 值表示服務不在執行中。True 值表示服務正在執行中。

如果 Exchange Server Analyzer 在已啟動 SMTP 服務的 Exchange Server 電腦上發現 StartMode 機碼值設為 Manual，就會顯示警告。

Windows SMTP 服務是網際網路資訊服務 (IIS) 的元件，是以 Inetinfo.exe 的一部份執行。Exchange Server 依賴 SMTP 服務作為其原始的傳輸通訊協定。因此，Exchange 使用 SMTP 來路由傳送所有的內部與外部郵件。

如果 SMTP 服務並未在開機時自動啟動，可能會忘記啟動它。這會導致嚴重的郵件流程問題。

所有 Exchange Server 電腦的 SMTP 服務都應該設為 Automatic。

若要解決此錯誤，您必須設定 SMTP 服務在路由傳送郵件的伺服器上自動啟動。

設定簡易郵件傳送通訊協定 (SMTP) 服務自動啟動

  1. 開啟 [服務] Microsoft Management Console (MMC) 嵌入式管理單元。

  2. 按兩下 [Simple Mail Transfer Protocol (SMTP)] 服務。

  3. 在 [Simple Mail Transfer Protocol (SMTP) 內容] 頁面的 [一般] 索引標籤上，從 [啟動類型] 下拉對話方塊選取 [自動]，然後按一下 [套用]。

  4. 在 [服務狀態] 下，按一下 [啟動]，再按一下 [確定]。

  5. 關閉 [服務] 嵌入式管理單元。

如需 SMTP 服務及 Exchange 伺服器的相關資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》中的＜SMTP 傳輸結構＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

如需如何針對 Exchange 設定 SMTP 服務的相關資訊，請參閱＜在 Microsoft Exchange 2000 Server 中設定 SMTP＞(英文) (http://go.microsoft.com/fwlink/?linkid=24866)。


SMTP 服務狀態不明
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2006-10-06

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定簡易郵件傳送通訊協定 (SMTP) 服務的 Started 機碼值。值為 False 表示 SMTP 服務不在執行中。值為 True 表示 SMTP 服務正在執行中。

如果 Exchange Server Analyzer 無法判定 Started 機碼值，Exchange Server Analyzer 就會顯示錯誤。

此錯誤指出 WMI 查詢無法擷取所要求的資料。

發生這種錯誤的可能原因如下：

  • 執行 Exchange Server Analyzer 的帳戶沒有足夠的權限可查詢 WMI 類別。

  • 發生網路問題，使得 Exchange Server Analyzer 無法與電腦連絡。

  • 不明原因的暫時性狀況造成查詢逾時。

若要更正此錯誤

  1. 確定已啟動執行 Exchange Server 的伺服器，且已連接到網路。

  2. 使用 PING 命令，查看是否可以連接 Exchange 伺服器。

  3. 若有防火牆，請檢查遠端程序呼叫 (RPC) 通訊埠是否被封鎖。

  4. 檢查執行 Exchange Server Analyzer 的帳戶之權限。執行 Exchange Server Analyzer 的帳戶，在所掃描的每部 Exchange 伺服器上都必須擁有本機 Administrator 權限。

    或者，您也可以將特定的 WMI 權限授與執行 Exchange Server Analyzer 的帳戶：

    1. 在 Exchange 伺服器上，開啟 [電腦管理] Microsoft Management Console (MMC) 樹狀目錄。

    2. 在 [服務及應用程式] 下的 [WMI 控制] 上按一下滑鼠右鍵，再按一下 [內容]。

    3. 在 [WMI 控制內容] 對話方塊上按一下 [安全性] 索引標籤，然後展開 [根]。

    4. 選取 CIMV2 資料夾，再按一下 [安全性]。

    5. 在 [安全性 ROOT\CIMV2] 頁面上，新增執行 Exchange Server Analyzer 的帳戶。

  5. 選取您在步驟 5 新增的帳戶。在 [Selected_Account 的權限] 中，於 [允許] 直欄下，選取 [遠端啟用] 及 [讀取安全性]，再按一下 [確定]。

若需 SMTP 服務及 Exchange 伺服器的詳細資訊，請參閱《Exchange Server 2003 技術參考手冊》中的＜SMTP 傳輸結構＞ (http://go.microsoft.com/fwlink/?LinkId=47891) (英文)。

若需如何針對 Exchange 設定 SMTP 服務的相關資訊，請參閱＜在 Microsoft Exchange 2000 Server 中設定 SMTP＞(英文) (http://go.microsoft.com/fwlink/?linkid=24866)。

若需疑難排解網路連線問題的詳細資訊，請參閱 Microsoft 知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

若需疑難排解 Exchange Server Analyzer 連線問題的詳細資訊，請參閱＜Microsoft Exchange Server Best Practices Analyzer 工具疑難排解連線問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56285)。


已啟用 UseAltRegionalCharset 及 UseRegionalCharset 登錄值
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Microsoft Outlook® Web Access 用戶端使用的語言設定：

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

    設定為 1 會造成 UTF-8 郵件內文仍會以地區字元集或字碼頁 (而不是以 UTF-8 格式) 存在於儲存區中。這是 Exchange Server 2003 UseRegionalCharset 登錄值的預設設定。

  • HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseAltRegionalCharset

如果下列狀況符合，則瀏覽器的層級可判定郵件的編碼：

  • UseAltRegionalCharset 機碼未設定，或設為 0。

  • 相關的 UseRegionalCharset 也同樣未設定，或設為 0。

更新的瀏覽器 (如 Internet Explorer 5 或更新版本) 會以 UTF-8 來傳送郵件。而較早版本的瀏覽器或其他非 Internet Explorer 5 的瀏覽器則會以該瀏覽器接受之語言的適當編碼來傳送郵件。

UseAltRegionalCharset 機碼只會變更在下列語言清單中設定之瀏覽器的行為：

  • 韓文：KS_C_5601-1987

  • 日文：shift_jis

  • 西歐：windows-1252

  • 俄國：windows-1251

  • 中歐：windows-1250

如果 UseAltRegionalCharset 機碼設定為 1，則更新及較早版本的瀏覽器都會以下列編碼傳送郵件：

  • 韓文：euc_kr

  • 日文：iso-2022-jp (JIS)

  • 西歐：iso-8859-1

  • 俄國：koi8-r

  • 中歐：iso-8859-2

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定物件類別為 msExchExchangeServer 之所有物件的 serialNumber 屬性值。

  • 如果字串值包含 "Version 6.0"，表示電腦正在執行 Exchange 2000 Server。

  • 如果字串值包含 "Version 6.5"，表示電腦正在執行 Exchange Server 2003。

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • UseAltRegionalCharset 及 UseRegionalCharset 兩者皆存在

  • UseAltRegionalCharset 及 UseRegionalCharset 兩者在 Exchange 2000 伺服器或 Exchange 2003 伺服器上皆設定為使用值 1。

若為 Exchange 2000 Server 及 Exchange Server 2003，當下列狀況符合時，會優先使用其他的字元集：

  • 開啟使用地區字元 - UseRegionalCharset 登錄機碼 REG_DWORD 值設為 -1。

  • 開啟使用其他字元集 - UseAltRegionalCharset 登錄機碼 REG_DWORD 值設為 0x1。

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要更正此問題

  1. 在 Exchange 電腦上，開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 判定哪種 Outlook Web Access 語言設定適合 Exchange Server 環境，並移除不適合的機碼。

    1. 瀏覽至：HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

    2. 選取要移除的機碼，在機碼上按一下滑鼠右鍵，然後從下拉式清單中選取 [刪除]。

  3. 關閉登錄編輯程式。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Outlook Web Access 語言設定的詳細資訊，請參閱下列 Exchange Server 資源：

《Exchange Server 用戶端存取手冊》(英文)(http://go.microsoft.com/fwlink/?LinkId=47568)。

微軟知識庫文件 - 311342＜XCCC：Exchange 2000 Server SP2 伺服器端 OWA 登錄機碼＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311342)。


已在 Exchange 2000 Server 上啟用 UseAltRegionalCharset 登錄值
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已在 Microsoft Outlook® Web Access 的用戶端語言設定中使用 UseAltRegionalCharset。

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseAltRegionalCharset

如果下列狀況符合，則瀏覽器的層級可判定郵件的編碼：

  • UseAltRegionalCharset 機碼未設定，或設為 0。

  • 相關的 UseRegionalCharset 也同樣未設定，或設為 0。

UseAltRegionalCharset 機碼只會變更在下列語言清單中設定之瀏覽器的行為：

  • 韓文：KS_C_5601-1987

  • 日文：shift_jis

  • 西歐：windows-1252

  • 俄國：windows-1251

  • 中歐：windows-1250

如果 UseAltRegionalCharset 機碼設定為 1，則更新及較早版本的瀏覽器都會以下列編碼傳送郵件：

  • 韓文：euc_kr

  • 日文：iso-2022-jp (JIS)

  • 西歐：iso-8859-1

  • 俄國：koi8-r

  • 中歐：iso-8859-2

Exchange Server Analyzer 會查詢 Active Directory® 目錄服務，以判定物件類別為 msExchExchangeServer 之所有物件的 serialNumber 屬性值。如果字串值包含 "Version 6.0"，表示電腦正在執行 Exchange 2000 Server。

如果 Exchange Server Analyzer 發現 UseAltRegionalCharset 在執行 Exchange 2000 Server 的電腦上設定為大於 0 的任何數，則會顯示非預設的組態訊息。

此訊息指出已在此 Exchange 2000 伺服器上啟用 UseAltRegionalCharset 登錄參數。如果您預期組織內的 Outlook Web Access 使用者會經常傳送郵件至使用各種字元集的收件者，可以修改登錄設定，讓執行 Internet Explorer 5 或更新版本的使用者可以使用 UTF-8 編碼的 UNICODE 字元傳送郵件。如果您不需要多個字元集，則可以使用下列程序來還原預設的組態。

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要還原 Outlook Web Access 的預設語言設定

  1. 在 Exchange 電腦上，開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. 在右窗格中，刪除 UseAltRegionalCharSet 登錄值。

  4. 關閉登錄編輯程式。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

如需 Outlook Web Access 語言設定的詳細資訊，請參閱微軟知識庫文件 - 311342＜XCCC：Exchange 2000 Server SP2 伺服器端 OWA 登錄機碼＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311342)。


已在 Exchange Server 2003 上啟用 UseAltRegionalCharset 登錄值
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以尋找 UseAltRegionalCharset 登錄值是否存在：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\

UseAltRegionalCharset 登錄值可讓 Microsoft Outlook® Web Access 使用者使用其他的字元集來加密電子郵件。

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定物件類別為 msExchExchangeServer 之所有物件的 serialNumber 屬性值。如果字串值包含 "Version 6.5"，表示電腦正在執行 Exchange Server 2003。

如果 Exchange Server Analyzer 發現 UseAltRegionalCharset 登錄值在 Exchange 2003 伺服器上設定為大於 0 的任何數，則會顯示非預設的組態訊息。

這個訊息指出已在此 Exchange 2003 伺服器上設定 UseAltRegionalCharset。此設定可能會造成不想要的 Outlook Web Access 郵件字元集編碼，其中某些郵件可能無法由某些用戶端讀取。建議您驗證用戶端的語言設定是正確的。

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要在 Exchange Server 2003 上還原 Outlook Web Access 的預設語言設定

  1. 在 Exchange 電腦上，開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. 在右窗格中，刪除 UseAltRegionalCharSet 登錄值。

  4. 如果 UseRegionalCharset 登錄值不存在，請遵循下列步驟來建立它：

    1. 在 [編輯] 功能表上按一下 [新增]，再按一下 [DWORD 值]。

    2. 鍵入 UseRegionalCharset 作為 DWORD 的名稱，然後按 Enter 鍵。

  5. 如果 UseRegionalCharset 存在，連按兩下以修改它。

  6. 在 [數值資料] 方塊中輸入 1，再按一下 [確定]。

  7. 關閉登錄編輯程式。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

如需 UseAltRegionalCharSet 及 UseRegionalCharset 登錄值的詳細資訊，請參閱微軟知識庫文件 - 283214＜XCCC：Outlook Web Access 可能會傳送以 SJIS 加密的日文郵件＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=283214)。


Exchange 2000 Server 上啟用了 UseRegionalCharset 登錄值
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目以判斷 Microsoft Outlook® Web Access 用戶端所用的語言設定：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

UseRegionalCharset 登錄值會使 UTF-8 郵件內文以地區字元集或字碼頁而非以 UTF-8 格式存留於儲存區中。

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定物件類別為 msExchExchangeServer 之所有物件的 serialNumber 屬性值。如果字串值包含 "Version 6.0"，表示電腦正在執行 Exchange 2000 Server。

如果 Exchange Server Analyzer 在執行 Exchange 2000 Server 的電腦上發現 UseRegionalCharset 設為使用 1 或更大的值，就會顯示非預設組態的訊息。

此訊息表示此 Exchange 2000 伺服器上啟用了 UseRegionalCharset 登錄參數。如果您預期組織內的 Outlook Web Access 使用者會經常傳送郵件至使用各種字元集的收件者，可以修改登錄設定，讓執行 Internet Explorer 5 或更新版本的使用者可以使用 UTF-8 編碼的 UNICODE 字元傳送郵件。如果您不需要多個字元集，則可以使用下列程序來還原預設的組態。

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要還原 Outlook Web Access 的預設語言設定

  1. 在 Exchange 電腦上，開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. 在右窗格中，刪除 UseRegionalCharSet 登錄值。

  4. 關閉登錄編輯程式。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


已停用 UseRegionalCharset 登錄值
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目以判斷 Microsoft Outlook® Web Access 用戶端所用的語言設定：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

UseRegionalCharset 登錄值會使 UTF-8 郵件內文以地區字元集或字碼頁而非以 UTF-8 格式存留於儲存區中。

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定物件類別為 msExchExchangeServer 之所有物件的 serialNumber 屬性值。如果字串值包含 "Version 6.5"，表示電腦正在執行 Exchange Server 2003。

如果 Exchange Server Analyzer 在執行 Exchange Server 2003 的電腦上發現 UseRegionalCharset 設為使用 0 的值，就會顯示非預設組態的訊息。

此訊息表示此 Exchange 2003 伺服器上停用了 UseRegionalCharset 登錄參數。此設定可能會造成不想要的 Outlook Web Access 郵件字元集編碼，其中某些郵件可能無法由某些用戶端讀取。

當您使用 Microsoft Internet Explorer 5 或更新版本存取 Outlook Web Access 時，Exchange Server 2003 會使用瀏覽器的語言設定來判斷要使用哪一個字元集對電子郵件及會議要求等資訊進行編碼。

如果您預期組織內的 Outlook Web Access 使用者會經常傳送郵件至使用各種字元集的收件者，可以修改登錄設定，讓執行 Internet Explorer 5 或更新版本的使用者可以使用 UTF-8 編碼的 UNICODE 字元傳送郵件。

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要還原 Outlook Web Access 的預設語言設定

  1. 在 Exchange 電腦上，開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. 如果 UseRegionalCharset 不存在，請遵循下列步驟建立它：

    1. 在 [編輯] 功能表上按一下 [新增]，再按一下 [DWORD 值]。

    2. 鍵入 UseRegionalCharset 作為 DWORD 的名稱，然後按 Enter 鍵。

  4. 如果 UseRegionalCharset 存在，連按兩下以修改它。

  5. 在 [數值資料] 方塊中輸入 1，再按一下 [確定]。

  6. 關閉登錄編輯程式。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Outlook Web Access 語言設定的詳細資訊，請參閱《Exchange Server 2003 用戶端存取手冊》(http://go.microsoft.com/fwlink/?LinkId=47568)。


Exchange Server 2003 上已停用或遺漏 UseRegionalCharset 登錄值
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目以判斷 Microsoft Outlook® Web Access 用戶端所用的語言設定：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

UseRegionalCharset 登錄值會使 UTF-8 郵件內文以地區字元集或字碼頁而非以 UTF-8 格式存留於儲存區中。

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定物件類別為 msExchExchangeServer 之所有物件的 serialNumber 屬性值。如果字串值包含 "Version 6.5"，表示電腦正在執行 Exchange Server 2003。

如果下列任一條件為真，Exchange Server Analyzer 將會顯示警告訊息：

  • Exchange 2003 伺服器的 UseRegionalCharset 項目不存在。

  • UseRegionalCharset 項目的值為 1 以外的值。

此訊息表示此 Exchange 2003 伺服器上已停用或遺漏 UseRegionalCharset 登錄參數。此設定可能會造成不想要的 Outlook Web Access 郵件字元集編碼，其中某些郵件可能無法由某些用戶端讀取。

當您使用 Microsoft Internet Explorer 5 或更新版本存取 Outlook Web Access 時，Exchange Server 2003 會使用瀏覽器的語言設定來判斷要使用哪一個字元集對電子郵件及會議要求等資訊進行編碼。

如果您預期組織內的 Outlook Web Access 使用者會經常傳送郵件至使用各種字元集的收件者，可以修改登錄設定，讓執行 Internet Explorer 5 或更新版本的使用者可以使用 UTF-8 編碼的 UNICODE 字元傳送郵件。

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要還原 Outlook Web Access 的預設語言設定

  1. 在 Exchange 電腦上，開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. 如果 UseRegionalCharset 不存在，請遵循下列步驟建立它：

    1. 在 [編輯] 功能表上按一下 [新增]，再按一下 [DWORD 值]。

    2. 鍵入 UseRegionalCharset 作為 DWORD 的名稱，然後按 Enter 鍵。

  4. 如果 UseRegionalCharset 存在，連按兩下以修改它。

  5. 在 [數值資料] 方塊中輸入 1，再按一下 [確定]。

  6. 關閉登錄編輯程式。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Outlook Web Access 語言設定的詳細資訊，請參閱《Exchange Server 2003 用戶端存取手冊》(http://go.microsoft.com/fwlink/?LinkId=47568)。


使用者負載及 MAPI 作業
Microsoft Exchange Server Analyzer - 文章 > 通訊協定 >

主題上次修改日期： 2006-10-17

Microsoft® Exchange Server Analyzer 判斷伺服器上有一些 MAPI 作業造成高百分比的伺服器使用者負載。此判斷是經由查詢耗用 CPU 時間與處理所有 RPC 要求所用全部 CPU 時間比率超過 4% 的作業而認定。

高 CPU 百分比 MAPI 作業的常見原因

調查 Exchange Server 效能不佳的系統管理員應查看表現出效能不佳的伺服器上，平均信箱大小高不高。判斷方式是看個別資料夾是否過大 (使用者的收件匣、寄件備份、刪除的郵件或行事曆資料夾中有超過 5,000 個項目)。大型資料夾及信箱的成長可能導致 CPU 及 I/O 負載增加。每個資料夾的檢視數目增加，也可能會增加許多 MAPI 作業的負荷。

檢視

許多常見的、長時間執行的 MAPI 作業與檢視有關。知名的兩個是 Restrict 和 FindRow。這些作業不一定會花許多時間，如果其效能有問題，您應能了解原因。也請注意，除了下列原因，在任何時候若有資源瓶頸 (一般是磁碟或 CPU 瓶頸)，作業的延遲也會增加。

附註：
有時 TaskQ User Known 會連同 Restrict 或 FindRow 出現高成本的情況；這是因為這些作業有部分工作是在 TaskQ 中執行，其成本歸給 TaskQ User Known。

限制

MAPI Restrict 作業是用來選取符合特定準則的項目。伺服器會建立實際上是具有關聯準則 (稱為限制) 之表格的檢視。如果已有符合限制的檢視存在，伺服器會使用現有的檢視以滿足使用者要求。使用此檢視相對較不耗資源；不過，建立新檢視相對較耗資源。儲存區預設只會為每個資料夾快取 11 個檢視。如果伺服器被要求建立第 12 個檢視，伺服器會刪除最早快取的檢視，再建立新檢視。檢視會對符合檢視限制之項目的所有動作增加負荷。

Findrow

用戶端應用程式使用 MAPI 作業 SeekRow 或 FindRow 在檢視的不同列間移動指標。SeekRow 指定指標移動的列數，就 CPU 時間來說成本很低。FindRow 相當耗資源，因為它會將指標移至符合限制準則之非具體化 (不會被快取) 的檢視中的第一個項目，然後在用戶端應用程式完成動作後捨棄檢視。FindRow 的最終 CPU 成本取決於限制的複雜度及儲存區找到第一個符合準則的項目前必須檢閱的列數，因此與資料夾中的項目數無太大關係。

Restrict 與 FindRow 所耗成本高，因此可執行快取模式，以降低伺服器的成本。請注意，有時這些作業所耗用的高 CPU 百分比是共用行事曆所造成，在此情況中快取模式幫不上忙。這些作業所耗用之高百分比 CPU 時間可能表示有大量檢視建立、耗資源的檢視或大量資料夾項目。

詳細資訊

若需詳細資訊，請參閱下列 Exchange Server 資源：

  • 《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)

  • ＜Exchange Server 2003 效能：10 件要考慮的事情＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56460)


儲存
Microsoft Exchange Server Analyzer - 文章 >

主題上次修改日期： 2005-11-18

本節中的文章詳細說明 Microsoft® Exchange Server Analyzer 工具會評估有關儲存的哪些事項。 此外，這些文章還會說明您可以採取哪些動作來解決 Exchange Server Analyzer 發現的儲存相關錯誤、警告及非預設的組態問題。


信箱儲存區的 Aging Clean Interval 並非預設值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-05

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，判定是否已修改未使用之資料庫索引的移除間隔預設值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Aging Clean Interval

如果 Exchange Server Analyzer 發現 Aging Clean Interval 機碼存在且已設定，就會顯示非預設的組態訊息。

「可擴充儲存引擎」的功能之一是，以不同排序順序重新排序或要求資訊時，可以動態地建立索引。因此，Exchange 儲存區資料庫在一個表格中可有數以千計的索引。Exchange 儲存區可藉由指派索引到期時間，來處理這個狀況。索引的詳細資訊會新增到稱為索引過時表格的內部表格。在進行線上維護時，會檢視索引過時表格，而且每個項目的刪除時間值都會與現行時間進行比較。若索引已過期，則會被移除。在預設的情況下，此處理程序會每 24 小時在 Exchange 儲存區維護週期期間內執行一次，並會移除超過 8 天 (若為 Exchange Server 5.5) 或 40 天 (若為 Exchange 2000 Server、Exchange Server 2003 及 Exchange Server 2007) 的項目。Aging Clean Interval 機碼是 Exchange 儲存區嘗試移除未使用之索引的間隔 (毫秒)。此登錄機碼可用來覆寫這項預設值，並以自訂間隔執行這項功能。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. 刪除 Aging Clean Interval 機碼。

  4. 關閉登錄編輯程式。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Aging Clean Interval 機碼的詳細資訊，請參閱下列知識庫文件：

  • 159197＜XADM：控制資料夾索引過時＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=159197)

  • 216076＜在 Exchange 中存取資訊儲存庫資料夾可能會變慢＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=216076)


公用資料夾儲存區的 Aging Clean Interval 並非預設值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，判定是否已修改未使用之資料庫索引的移除間隔預設值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\Aging Clean Interval

如果 Exchange Server Analyzer 發現 Aging Clean Interval 機碼存在且已設定，就會顯示非預設的組態訊息。

「可擴充儲存引擎」的功能之一是，以不同排序順序重新排序或要求資訊時，可以動態地建立索引。因此，Exchange 儲存區資料庫在一個表格中可有數以千計的索引。Exchange 儲存區可藉由指派索引到期時間，來處理這個狀況。索引的詳細資訊會新增到稱為索引過時表格的內部表格。在進行線上維護時，會檢視索引過時表格，而且每個項目的刪除時間值都會與現行時間進行比較。若索引已過期，則會被移除。在預設的情況下，此處理程序在 Exchange 儲存區維護週期內每 24 小時執行一次，並移除超過 8 天 (若為 Exchange Server 5.5) 或 40 天 (若為 Exchange 2000 Server 及 Exchange Server 2003) 的項目。Aging Clean Interval 機碼是 Exchange 儲存區嘗試移除索引的間隔時間 (毫秒)。此登錄機碼可用來覆寫這項預設值，並以自訂間隔執行這項功能。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. 刪除 Aging Clean Interval 機碼。

  4. 關閉登錄編輯程式。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Aging Clean Interval 機碼的詳細資訊，請參閱下列知識庫文件：

  • 159197＜XADM：控制資料夾索引過時＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=159197)

  • 216076＜在 Exchange 中存取資訊儲存庫資料夾可能會變慢＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=216076)


所有 Outlook 版本都可存取伺服器
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-05

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已禁止任何 Microsoft Office Outlook® 版本連接到 Exchange Server：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server Analyzer 發現 Disable MAPI Clients 機碼不存在，將會顯示警告。

預設不啟用的 Disable MAPI Clients 機碼，可讓系統管理員禁止特定 Outlook 版本連接到執行 Exchange 2000 Server、Exchange Server 2003 或 Exchange Server 2007 的電腦。

新版 Outlook 及較新的 Service Pack 包含許多安全性及對抗病毒的增強功能。從 Outlook 2002 開始，就包含了附件封鎖和物件模型保護 (Object Model Guard)，並預設會啟用。這些功能是整個對抗病毒的戰爭中很重要的元件。Microsoft 產品支援服務支援的最舊版本 Outlook 是 Outlook 2000 Service Pack 3 (SP3)。如果您在組織中執行更早版本的 Outlook，請升級為 Outlook 2003，或至少將 Outlook 用戶端更新為最新的安全性版本。

在更新 Outlook 之後，您就可以禁止尚未更新的更早版本 Outlook 存取 Exchange。禁止不支援附件封鎖和「物件模型保護」的更早版本 Outlook，可以為 MAPI 用戶端連線提供一定程度的用戶端安全性。

為防止所有更早版本的 Outlook (未安裝 SP3 的 Outlook 97、Outlook 98、Outlook 2000 及更早版本)，強烈建議您拒絕組建編號等於或早於 5.3164.0.0 的所有 Outlook 版本連線到 Exchange Server。

用戶端本身會指出用戶端的版本字串。這個字串類似用戶端的 [關於] 對話方塊中報告的版本號碼。然而，請不要依靠這個版本號碼。相反地，請使用 [Exchange 系統管理員] 來檢視 [信箱儲存區登入] 頁面的 [用戶端版本] 內容。

重要事項：
在進行變更之前，請注意，Hotfix 及 Service Pack 版本可能會影響用戶端版本字串。當限制用戶端存取時請當心，因為伺服器端 Exchange 元件也必須使用 MAPI 來登入。儘管有一些元件會報告 Exchange 組建編號 (如 6.0.4712.0)，但某些元件也會將其用戶端版本報告為元件名稱 (如 SMTP 或 OLEDB)。因此，請避免限制版本號碼以 6.<x.x> 開頭的用戶端。例如，若要完全防止 MAPI 存取，請勿指定 0.0.0-65535.65535.65535，而是指定兩個範圍，以便伺服器元件可以登入，如下所示：0.0.0-5.9.9; 7.0.0-65535.65535.65535。 0.0.0-5.9.9; 7.0.0-65535.65535.65535.
重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 建立名為 Disable MAPI Clients 的新字串值項目。

  4. 連按兩下 Disable MAPI Clients 登錄項目，將數值資料設定為您要的層級。[數值資料] 字串中的數值清單代表您可以停用 MAPI 用戶端版本範圍的不同方式。版本 (vX) 通常是下列格式：

    • Microsoft Outlook 2003 及 Outlook 2007：Maj.Min.Build

    • 若是 Microsoft Outlook 2000：Maj.Build.Dot

    • 若是較早版本的 Microsoft Outlook：Maj.Min.Build

    您可以在此字串中指出您想要停用的所有特定版本或版本範圍。請使用 [Exchange 系統管理員]，判定連接至 Exchange Server 2003 信箱儲存區的 MAPI 用戶端版本。在 [Exchange 系統管理員] 中，找出信箱儲存區的登入容器。用戶端版本一欄顯示已連接至信箱儲存區的 MAPI 用戶端版本。

    在 Exchange Server 2007 中，請使用 [Exchange 管理命令介面] 的 Get-LogonStatistics 指令程式，擷取已連接至信箱資料庫之 MAPI 用戶端的版本。
重要事項：
MAPI 用戶端版本在 [Exchange 系統管理員] 和 [Exchange 管理命令介面] 中列示為 X.0.Y.Z。此版本必須在登錄值中輸入為 X.Y.Z。例如，如果 Exchange 系統管理員將 MAPI 用戶端版本列示為 5.0.2819.0，請在停用 MAPI 用戶端登錄值中輸入 5.2819.0。
  1. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)。

若需有關阻止特定 MAPI 用戶端連線到 Exchange 2000 伺服器或 Exchange Server 2003 電腦的詳細資訊，請參閱下列微軟知識庫文件：

  • 328240＜如何在用來存取 Exchange 2000 信箱的用戶端上加上伺服器端限制＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328240)

  • 288894＜XADM：停用 MAPI 用戶端的功能＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=288894)

若需有關下載較早版本 Outlook 的安全性更新及阻止其他版本 Outlook 的詳細資訊，請參閱《在 Exchange 2003 Server 環境中減緩及阻止電子郵件病毒》(英文) (http://go.microsoft.com/fwlink/?LinkId=47587)。

若需有關 Get-LogonStatistics 指令程式的詳細資訊，請參閱 Exchange Server 2007 產品文件中的＜Get-LogonStatistics＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80699)。


設定 AssertOnEvent
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已在 Microsoft Exchange Information Store 上啟用偵錯：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\AssertOnEvent

如果 Exchange Server Analyzer 發現已設定 AssertOnEvent 的值，則會顯示警告。

AssertOnEvent 登錄值會保存十進位值，其指定哪些儲存區事件會觸發 Microsoft Exchange Information Store 偵錯模式。只有在執行 store.exe 的偵錯版本時，才會引發 AssertOnEvent 登錄。當 Microsoft Exchange Information Store 在偵錯模式中執行時，會使用很多資源。在生產環境中對儲存區進行偵錯不是最佳作法。

除非您是在 Microsoft 產品支援服務的協助下，主動疑難排解 Exchange Information Store 問題，否則就應該刪除 AssertOnEvent 登錄值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需還原登錄的相關資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
刪除 AssertOnEvent 登錄機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右窗格中，尋找並刪除 AssertOnEvent 值。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


至少識別出一封毀損郵件
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-05

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 PoisonIDs 值中的項目計數：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<ExchangeServerName> \Private- <PrivateInformationStoreGUID>

如果 Exchange Server Analyzer 判定 PoisonIDs 值中的項目數大於 0，就會顯示一則警告。

Exchange Server 2003 Service Pack 1 以後的 Exchange Server 版本實作了一項功能，可幫助防止損毀或不當郵件導致 Microsoft Exchange Information Store 服務突然停止，或是阻礙 Exchange Information Store 服務順利啟動。

在 Exchange Server 2003 Service Pack 1 或更新的版本中，會追蹤在 MAPI 格式轉換為 MIME 格式期間，導致 Exchange Information Store 服務異常停止的郵件。發生當機的情況時，毀損郵件的郵件識別碼會儲存在登錄中。若有損毀的郵件導致儲存區異常停止三次，則當 Exchange Information Store 服務於第四次重新啟動時，就會使用此項資訊來防止再次處理該郵件。

當 Exchange Information Store 服務因為損毀的郵件而異常停止時，就會在以下位置建立 PoisonIDs 登錄值：

HKLM\System\CurrentControlSet\Services\MSExchangeIS \<ExchangeServerName> \Private- <PrivateInformationStoreGUID>

此外，系統管理員可以建立 PoisonThreshold 登錄項目。PoisonThreshold 機碼會控制在將郵件加入 PoisonIDs 登錄機碼之前，可允許郵件通過 Exchange 資訊儲存庫的次數上限。在預設的情況下，此閥值是 2。閥值必須已超過，才會觸發此行為。因此，Exchange Information Store 服務可以因為損毀的郵件停止 3 次，才會封鎖該郵件。例如，若郵件和 3 次當機有關，則該郵件就會被封鎖，因為 3 已超過閥值 2。

當損毀的郵件事件被寫入登錄時，[應用程式] 事件日誌中，就會出現錯誤事件訊息 (事件 ID 9680 及 9681)。在 Exchange Information Store 服務順利啟動後，Exchange 會封鎖該郵件，並且會嘗試為該郵件傳送一份未傳遞報告。在某些情況下，Exchange 可能無法傳送未傳遞報告。在這些情況下，被封鎖的郵件可能會一直留在佇列中，直到過期為止。PoisonIDs 登錄機碼最多可以包含 10 個郵件識別碼值。當超出 10 的限制時，即會新增一個新的損毀郵件事件。包含最舊當機日期的損毀郵件事件就會被移除。

若要更正此警告

  1. 若您的信箱儲存區無法處理毀損的郵件，則必須進一步調查這個問題。若需 Microsoft IT 如何復原損壞的 Exchange 資料庫的相關資訊，請參閱 http://go.microsoft.com/fwlink/?LinkId=56372。

  2. 如果您遇到 Exchange Server 2003 關機方面的問題，且原因是郵件損毀，則在 Exchange Server 電腦上啟用自動化錯誤報告功能可能會有幫助。錯誤報告資料可以用來在您使用的軟體中，尋找以及更正問題。若需有關如何啟用 Exchange 錯誤報告的詳細資訊，請參閱＜已停用 Exchange 錯誤報告＞。

若需有關 Exchange Server 2003 Service Pack 1 的詳細資訊，請參閱「Exchange Server 2003 的 Service Pack 1」(英文) (http://go.microsoft.com/fwlink/?linkid=29090)。


信箱儲存區的 Background Cleanup 並非預設值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Background Cleanup 登錄值目前的數值資料：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Background Cleanup

如果 Exchange Server Analyzer finds 發現 Background Cleanup 的數值資料為 60,000 (十進位) 或 0xEA60 (十六進位) 以外的任一值，就會顯示非預設的組態訊息。建議您將 Background Cleanup 設為預設值。

如果 Background Cleanup 值設得太高，背景清理處理程序可能無法經常執行，因而造成許多問題，這些問題包括：

  • 移動信箱失敗，且會記錄錯誤碼 0x4e3 的事件 1205。

  • Exchange 系統管理員或 Exchange 管理主控台中顯示的資料夾大小及項目數可能會與 Microsoft Outlook® 顯示的大不相同。此外，可能不會收回這些項目所佔用的資料庫空間。

  • 在特定情況下，可能不會為未讀取前即被刪除的項目，產生未讀取回條。

  • 將不清理 DeliveredTo 表格中的舊項目。DeliveredTo 表格由 Exchange 儲存區用來防止傳遞重複的郵件。

如果 Background Cleanup 值設得太低，背景清理處理程序可能會造成不必要的伺服器負載。

注意：
除非背景清理已清理完所有項目 (正常是以預設間隔清理)，否則遵循此主題中的程序將過高的值還原成預設組態，將會加重伺服器的負擔。因此，建議您在使用者所受影響最小的時候，進行這些變更。此外，如果要求讀取回條的郵件未讀取就遭刪除，而且因為此問題未被清理，在您更正這個警告後，將會為所有這些郵件個別產生未讀取回條。
重要事項：
這篇文章包含如何編輯登錄的相關資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. 將 Background Cleanup 的值變更為 60,000 (十進位) 或 0xEA60 (十六進位)。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


遺失信箱儲存區的背景清理間隔
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Background Cleanup 登錄值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Background Cleanup

如果 Exchange Server Analyzer 發現 Background Cleanup 值遺失，就會顯示警告。

如果 Background Cleanup 值遺失，則背景清理處理程序可能無法執行，因而造成許多問題，包括：

  • 移動信箱失敗，且會記錄錯誤碼 0x4e3 的事件 1205。

  • Exchange 系統管理員或 Exchange 管理主控台中顯示的信箱大小及項目數可能會與 Microsoft Outlook® 顯示的大不相同。此外，這些項目所佔用的資料庫空間不能收回。

  • 在特定情況下，未經讀取就刪除的項目不會產生未讀取回條。

  • 將不會清理 DeliveredTo 表格。DeliveredTo 表格由 Exchange 儲存區用來防止傳遞重複的郵件。Track Duplicates 值可以控制保留 DeliveredTo 表格中之項目的時間範圍。如果存在 Background Cleanup 值，但 Track Duplicates 值遺失，則背景清理會清除超過 24 小時的項目。Track Duplicates 的建議值是 1 (十進位或十六進位)。

建議將 Background Cleanup 設為預設值 60,000 (十進位) 或 0xEA60 (十六進位)。

注意：
遵循以下程序來更正此警告，會加重伺服器的負載，直到所有通常應定期清理的項目都完成背景清理為止。因此，建議您在使用者所受影響最小的時候，進行這些變更。此外，如果要求讀取回條的郵件未讀取就遭刪除，而且因為此問題未被清理，在您更正這個警告後，將會為所有這些郵件個別產生未讀取回條。
重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
更正這個警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. 建立名為 Background Cleanup 的 DWORD 值，數值資料為 60000 (十進位) 或 0xEA60 (十六進位)。

  4. 關閉登錄編輯程式。若要使變更生效，請執行下列其中一個動作：

    • 卸載再裝載受影響的資訊儲存庫。

    • 重新啟動 Microsoft Exchange Information Store 服務

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


公用資料夾儲存區的 Background Cleanup 間隔並非預設值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Background Cleanup 登錄值目前的數值資料：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<PublicStoreGUID>\Background Cleanup

如果 Exchange Server Analyzer finds 發現 Background Cleanup 的數值資料為 60,000 (十進位) 或 0xEA60 (十六進位) 以外的任一值，就會顯示非預設的組態訊息。建議您將 Background Cleanup 設為預設值。

如果 Background Cleanup 值設得太高，背景清理處理程序可能無法經常執行，因而造成許多問題，這些問題包括：

  • Exchange 系統管理員中顯示的資料夾大小及項目數可能會與 Microsoft Outlook® 顯示的大不相同。此外，可能不會收回這些項目所佔用的資料庫空間。

  • 在特定情況下，可能不會為未讀取前即被刪除的項目，產生未讀取回條。

  • 將不清理 DeliveredTo 表格中的舊項目。DeliveredTo 表格由 Exchange 儲存區用來防止傳遞重複的郵件。

如果 Background Cleanup 值設得太低，背景清理處理程序可能會造成不必要的伺服器負載。

注意：
除非背景清理已清理完所有項目 (正常是以預設間隔清理)，否則遵循下列的程序將過高的值還原成預設組態，將會加重伺服器的負擔。因此，建議您在對使用者的影響最小的時段進行這些變更。此外，如果要求讀取回條的郵件未讀取就遭刪除，而且因為此問題未被清理，在您更正這個警告後，將會為所有這些郵件個別產生未讀取回條。
重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<PublicStoreGUID>

  3. 將 Background Cleanup 的數值資料變更為 60,000 (十進位) 或 0xEA60 (十六進位)。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


遺失公用資料夾儲存區的 Background Cleanup 間隔
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-05

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Background Cleanup 登錄值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicStoreGUID>\Background Cleanup

如果 Exchange Server Analyzer 發現 Background Cleanup 值遺失，就會顯示警告。

如果缺少 Background Cleanup 值，則不但背景清理處理程序不會執行，而且還會造成許多問題，這些問題包括：

  • Exchange 系統管理員或 Exchange 管理主控台中顯示的資料夾大小及項目數可能會與 Microsoft Outlook® 顯示的大不相同。此外，還可能無法收回這些項目所佔用的資料庫空間。

  • 在特定的情況下，可能無法為未閱讀即刪除的項目產生未讀回條。

  • 將不會清理 DeliveredTo 表格。DeliveredTo 表格由 Exchange 儲存區用來防止傳遞重複的郵件。Track Duplicates 值可以控制要保留 DeliveredTo 表格中之項目的時間範圍。如果存在 Background Cleanup 值，但 Track Duplicates 值遺失，則背景清理會清除超過 24 小時的項目。Track Duplicates 的建議值是 1 (十進位或十六進位)。

建議將 Background Cleanup 設為預設值 60,000 (十進位) 或 0xEA60 (十六進位)。

注意：
若依循下列程序來更正這項警告，則可能會對伺服器造成更大的負荷，直到所有項目完成通常是定期性的背景清理為止。因此，建議您選擇對使用者影響最小的時間進行這些變更。此外，如果要求讀取回條的郵件未讀取就遭刪除，而且因為此問題未被清理，在您更正這個警告後，將會為所有這些郵件個別產生未讀取回條。
重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicStoreGUID>

  3. 建立名為 Background Cleanup 的 DWORD 值，數值資料為 60000 (十進位) 或 0xEA60 (十六進位)。

  4. 關閉登錄編輯程式。若要使變更生效，請執行下列其中一個動作：

    • 卸載再裝載受影響的資訊儲存庫。

    • 重新啟動 Microsoft Exchange Information Store 服務。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


設定 BreakOnEvent
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已在 Microsoft Exchange Information Store 上啟用偵錯：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\BreakOnEvent

如果 Exchange Server Analyzer 發現已設定 BreakOnEvent 登錄的值，就會顯示警告。

BreakOnEvent 登錄值會保存十進位值，其指定哪些儲存區事件會觸發 Microsoft Exchange Information Store 的偵錯模式。當 Microsoft Exchange Information Store 在偵錯模式中執行時，會使用很多資源。在生產環境中對儲存區進行偵錯不是最佳作法。

除非您是在 Microsoft 產品支援服務的協助下，主動疑難排解 Exchange Information Store 問題，否則就應該刪除 BreakOnEvent 登錄值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
刪除 BreakOnEvent 登錄機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右窗格中，尋找並刪除 BreakOnEvent 值。

  4. 關閉登錄編輯程式，然後重新啟動 [Microsoft Exchange Information Store] 服務，使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


已停用呼叫追蹤
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來判定是否已啟用呼叫追蹤記錄：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable Call Tracing

如果 Exchange Server Analyzer 發現 Disable Call Tracing 的登錄值存在，並設定成使用 1 值，且電腦正在執行 Exchange Server 2003，便會顯示非預設的組態訊息。

當啟用呼叫追蹤記錄時，會記錄 Store.exe 處理程序的函式呼叫資料。在預設的情況下，會在執行 Exchange Server 2003 的電腦上啟用呼叫追蹤。請注意，在預設的情況下，Exchange 2000 Server 會停用此功能。然而，如果您正在執行 Exchange Server 2003，應該啟用呼叫追蹤，除非 Microsoft 產品支援服務指示您不要這樣做。如果呼叫追蹤已啟用，它會收集重要資訊，您可用來疑難排解儲存區處理程序發生的任何問題。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要還原為預設組態

  1. 開啟 [登錄編輯程式] (Regedit.exe 或 Regedt32.exe)。

  2. 瀏覽至：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 將 Disable Call Tracing 登錄值設為 0。

  4. 關閉 [登錄編輯程式]，然後重新啟動 Microsoft Exchange Information Store 服務，以使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


已啟用呼叫追蹤
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來判定是否已啟用呼叫追蹤記錄：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable Call Tracing

如果 Exchange Server Analyzer 發現 Disable Call Tracing 的登錄值存在，且設定為值 0，就會顯示非預設的組態訊息。

當啟用呼叫追蹤記錄時，會記錄 Store.exe 處理程序的函式呼叫資料。呼叫追蹤記錄最多會使效能降低百分之四。只有當您要疑難排解較慢或無回應的 Store.exe 處理程序時才啟用它。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 將 Disable Call Tracing 登錄值設為 1。停用呼叫追蹤時，將不使用 Flush Call Traces 機碼、RPC Requests Threshold 機碼及 Call Tracing Logging Interval 機碼。

  4. 關閉登錄編輯程式，然後重新啟動 Exchange 伺服器，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


此叢集未正確設定檢查點深度
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每一個儲存群組上的 msExchESEParamCheckpointDepthMax 屬性值。如果 Exchange Server Analyzer 發現 Exchange 2000 Server 叢集上的 msExchESEParamCheckpointDepthMax 不等於 5242880，就會顯示一則警告。

msExchESEParamCheckpointDepthMax 屬性是以位元組為單位設定，它會決定最大檢查點深度。檢查點深度是等待 Exchange 儲存區確認的資料數量。最大檢查點深度是在任何時候可以保留未處理的最大資料數量。因此，如果最大檢查點深度設定為 20 MB，則這是在任何時候可以保留未處理 (Exchange 儲存區未確認) 的最大資料數量。在叢集環境中，此參數的值小一點會使容錯移轉時間快一點。Exchange Server 2003 的測試結果顯示此參數的值為 5 MB (5242880 個位元組，非 Exchange 2000 Server 預設的 20 MB) 時，會使容錯移轉時間快很多，卻不嚴重影響伺服器的 I/O 效能。

在 Exchange 2000 Server 叢集上，此值應該固定設為 5242880。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory® 目錄服務物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要使用 [ADSI 編輯器] 來設定 msExchESEParamCheckpointDepthMax 屬性

  1. 執行 [Active Directory Service Interfaces (ADSI) 編輯器]。Microsoft Windows® 2000 Server 及 Microsoft Windows Server™ 2003 Server 支援工具有提供 ADSI 編輯器。

  2. 在主控台樹狀目錄中，在 ADSIEdit 上按一下滑鼠右鍵，按一下 [連線至]，然後連線至 [組態命名內容]。

  3. 展開 [Configuration] 容器，CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdminGroupName>, CN=Servers, CN=<ServerName>, CN=Information Store。

  4. 以滑鼠右鍵按一下 CN=<StorageGroupName>，再按一下 [內容]。

  5. 在屬性清單中，選取 msExchESEParamCheckpointDepthMax。

  6. 按一下 [編輯]，然後鍵入您要以 5 MB 為增量來設定的大小。必須以位元組為單位來輸入該值。例如，5 MB 的檢查點深度是 5242880 個位元組，10 MB 的檢查點深度是 10485760 個位元組。您可以輸入的最小值是 5 MB。如果您輸入大於 20 MB 的值，將會增加 Microsoft Exchange Information Store 服務資源容錯移轉時間。

  7. 關閉 ADSIEdit，然後重新啟動 Microsoft Exchange Information Store 服務。

若需有關部署 Exchange 2000 Server 叢集的詳細資訊，請參閱＜部署 Microsoft Exchange 2000 Server 叢集＞(英文) (http://go.microsoft.com/fwlink/?LinkID=14578)。


檢查點檔案的位置
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-05

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 Exchange 伺服器上每個儲存群組的檢查點檔案路徑 (msExchESEParamSystemPath)，是否與該儲存群組的交易記錄檔路徑 (msExchESEParamLogFilePath) 相符。如果 Exchange Server Analyzer 發現檢查點檔案路徑不符合儲存群組的交易記錄檔路徑，則 Exchange Server Analyzer 會顯示一則最佳作法訊息。

如果檢查點檔案的位置不符合交易記錄檔的位置，當磁碟損壞時，您可能會經歷較長的當機時間。

若要變更 Exchange 2000 Server 與 Exchange Server 2003 之 Exchange 儲存群組檢查點檔案的位置

  1. 在 [Exchange 系統管理員] 中，在儲存群組上按一下滑鼠右鍵，然後按一下 [內容]。

  2. 在 [一般] 索引標籤上的 [系統路徑位置] 中按一下 [瀏覽]，然後選擇檢查點檔案的位置。
若要變更 Exchange 2000 Server 與 Exchange Server 2003 之 Exchange 儲存群組交易記錄檔的位置

  1. 在 [Exchange 系統管理員] 中，在儲存群組上按一下滑鼠右鍵，然後按一下 [內容]。

  2. 在 [一般] 索引標籤上的 [交易記錄位置] 中按一下 [瀏覽]，然後選擇交易記錄檔的位置。
若要變更 Exchange Server 2007 之 Exchange 儲存群組交易記錄檔的位置

  1. 請遵循核心 Exchange Server 2007 文件＜如何設定或變更儲存群組記錄檔的位置＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80702) 中的指導。

若需有關交易記錄檔位置的詳細資訊，請參閱《Exchange Server 2003 系統管理手冊》(http://go.microsoft.com/fwlink/?LinkId=47617) 中的＜管理信箱儲存區及公用資料夾儲存區＞(英文)。

若需有關檢查點檔案的詳細資訊，請參閱《使用 Exchange Server 2003 復原儲存群組》(http://go.microsoft.com/fwlink/?LinkId=47589) 中的＜交易記錄檔重新顯示：Exchange Server 2003 中的軟復原及硬復原＞(英文)。


此前端伺服器已停用循環記錄
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2006-03-27

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定所設定的循環記錄 (msExchESEParamCircularLog) 屬性值。如果 Exchange Server Analyzer 發現此屬性值設定為 0，就會顯示一則警告。

msExchESEParamCircularLog 屬性的值為 1 表示現已啟用循環記錄。msExchESEParamCircularLog 屬性的值為 0 則表示已停用循環記錄。

在 Exchange Server 使用的標準交易記錄中，儲存群組中的每筆資料庫交易會先寫入至記錄檔，然後再寫入至資料庫。當記錄檔達到某個大小時，會重新命名它並建立新的記錄檔。經過一段時間之後，就會產生一組記錄檔。如果有損毀，您可以將這些記錄檔的資料重新顯示在資料庫來復原交易。

在第一個記錄檔所包含的資料寫入資料庫之後，循環記錄會覆寫並重新使用該記錄檔。在 Exchange Server 中，循環記錄預設為停用。啟用它之後，可減少磁碟儲存空間需求，但沒有完整的交易記錄檔，您就不能復原上次完整備份之後的任何資料。因此，在包含信箱或公用資料夾資料的生產伺服器上，不建議使用循環記錄。但是，在沒有信箱或公用資料夾的前端 Exchange 伺服器上，由於唯一會確認的郵件僅限於未傳遞回報 (NDR)，因此不需要保留這些伺服器的交易檔，而且也沒理由要備份這些伺服器。在前端伺服器上啟用循環記錄可使交易記錄檔得以覆寫，而且永遠不會超過 20 MB 的資料。

若要啟用循環記錄

  1. 在 [Exchange 系統管理員] 中，展開 [伺服器]，再展開 Exchange 伺服器。

  2. 在您要啟用循環記錄的儲存群組上按一下滑鼠右鍵，並且選取 [內容]。儲存群組內容對話方塊將會出現。

  3. 選取 [啟用循環記錄] 核取方塊，然後按一下 [確定] 以儲存變更。

  4. 結束 [Exchange 系統管理員] 並重新啟動 Microsoft Exchange Information Store，以使變更生效。

若需有關循環記錄的詳細資訊，請參閱下列微軟知識庫文件：

  • 258470＜XADM：如何修改循環記錄設定＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=258470)

  • 147524＜XADM：循環記錄如何影響交易記錄的使用＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524)

  • 296788＜Exchange 的離線備份與還原程序＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296788)

  • 314605＜HOW TO: 在 Exchange 2000 Server 中開啟或關閉循環記錄＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314605)


已啟用循環記錄
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-05

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，來判定 Exchange 伺服器上每一個儲存群組的 msExchESEParamCircularLog 屬性值。值為 1 表示已針對儲存群組啟用循環記錄。值為 2 表示未針對儲存群組啟用循環記錄。此外，Exchange Server Analyzer 也會查詢 Active Directory，以判定每一個信箱儲存區的 homeMDBBL 屬性所列出的項目計數。這個屬性的計數代表信箱儲存區上的信箱數目。

Exchange Server Analyzer 也會查詢 root\MicrosoftExchangeV2 命名空間中的 Exchange_Server Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 IsFrontEndServer 機碼值。值為 True 表示 Exchange Server 電腦是前端伺服器。值 False 表示 Exchange Server 電腦不是前端伺服器。

如果 Exchange Server Analyzer 發現 msExchESEParamCircularLog 屬性的值設定為 1、IsFrontEndServer 機碼的值設定為 False，以及 homeMDBBL 屬性的值大於 20，將會顯示警告。

這些值的組合指出在含有超過 20 個信箱的信箱伺服器上已啟用循環記錄。在 Exchange 2000 Server、Exchange Server 2003 及 Exchange Server 2007 使用的標準交易記錄中，儲存群組中的每一筆資料庫交易會先寫入記錄檔，再寫入資料庫。當記錄檔達到某個大小時，會重新命名它並建立新的記錄檔。經過一段時間之後，就會產生一組記錄檔。如果有損毀，您可以將這些記錄檔的資料重新顯示在資料庫來復原交易。

在第一個記錄檔所包含的資料寫入資料庫之後，循環記錄會覆寫並重新使用該記錄檔。在 Exchange 2000 Server、Exchange Server 2003 及 Exchange Server 2007 中，預設會停用循環記錄。啟用它之後，可減少磁碟儲存空間需求，但沒有完整的交易記錄檔，您就不能復原上次完整備份之後的任何資料。因此，在一般生產環境中，不建議使用循環記錄。

若要對 Exchange 2000 Server 及 Exchange Server 2003 更正此警告

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [伺服器]，再展開要修改的伺服器。

  3. 以滑鼠右鍵按一下要變更的儲存群組，然後按一下 [內容]。

  4. 在 [內容] 對話方塊中，清除 [啟用循環記錄] 核取方塊。

  5. 按一下 [確定]，儲存設定。

  6. 關閉 [Exchange 系統管理員] 並重新啟動 Microsoft Exchange Information Store 服務，以使變更生效。

若要使用 Exchange 管理主控台對 Exchange Server 2007 更正此警告

  1. 開啟 [Exchange 管理主控台]。

  2. 展開 [伺服器組態]，然後展開要修改的伺服器。

  3. 以滑鼠右鍵按一下要變更的儲存群組，然後按一下 [內容]。

  4. 在 [內容] 對話方塊中，清除 [啟用循環記錄] 核取方塊。

  5. 按一下 [確定]，儲存設定。

  6. 關閉 [Exchange 管理主控台] 並重新啟動 Microsoft Exchange Information Store 服務，以使變更生效。

若要使用 Exchange 管理命令介面對 Exchange Server 2007 更正此警告

  1. 下列程式碼為 Set-StorageGroup 命令的範例，此命令可用來停用 MyStorageGroup 儲存群組的循環記錄。
複製程式碼
Set-StorageGroup -Identity MyStorageGroup -CircularLoggingEnabled $false
  • 若需循環記錄的詳細資訊，請參閱下列微軟知識庫文件：

  • 147524＜循環記錄如何影響交易記錄的使用＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524)

  • 240145＜如何移除 Exchange Server 交易記錄檔＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=240145)


已停用循環記錄
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-03-23

Microsoft Exchange Analyzer 工具會查詢 Active Directory 目錄服務，以判定為 msExchESEParamCircularLog 屬性設定的值。

msExchESEParamCircularLog 屬性的值為 1 表示已啟用循環記錄。msExchESEParamCircularLog 屬性的值為 0 表示已停用循環記錄。

Exchange Analyzer 也會判定下列條件是否存在：

  • Exchange Server 設為前端伺服器。

  • SMTP 服務正在執行，並判定已設定的信箱數目。

如果 Exchange Analyzer 發現下列條件存在，則會顯示警告：

  • msExchESEParamCircularLog 屬性值已設為 0。

  • 伺服器未設為前端伺服器。

  • 設定的信箱少於 20 個。

在 Exchange Server 使用的標準交易記錄中，儲存群組中的每筆資料庫交易都會先寫入至記錄檔，然後再寫入至資料庫。當記錄檔達到某個大小時，會重新命名它並建立新的記錄檔。經過一段時間之後，標準交易記錄就會建立一組記錄檔。如果系統失敗，您可以將這些記錄檔的資料重新顯示在資料庫來復原交易。

在第一個記錄檔所包含的資料寫入資料庫之後，循環記錄會覆寫並重新使用該記錄檔。在 Exchange Server 中，循環記錄預設為停用。

重要事項：
啟用循環記錄，可降低磁碟機儲存空間的需求。不過，如果沒有完整的交易記錄檔，則只能復原上次的完整備份，而無法復原到最新的狀態。因此，在包含信箱資料或公用資料夾資料的生產伺服器上，不建議使用循環記錄。

在沒有使用者信箱或公用資料夾的前端 Exchange 伺服器、郵件路由伺服器 (也稱為基礎結構伺服器) 和 Bridgehead 伺服器上，唯一會確認的訊息僅限於未傳遞回報 (NDR)。因此，不需要保留這些伺服器的交易檔。此外，您也不需要備份這些伺服器。如果在未主控使用者信箱的伺服器上啟用循環記錄，則可以覆寫交易記錄檔，而且交易記錄檔永遠不會超過 20 MB 的資料。

若要啟用 Exchange 2000 Server 與 Exchange Server 2003 的循環記錄

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [伺服器]，再展開 Exchange 伺服器。

  3. 在您要啟用循環記錄的儲存群組上按一下滑鼠右鍵，並且選取 [內容]。儲存群組內容對話方塊將會出現。

  4. 選取 [啟用循環記錄] 核取方塊，然後按一下 [確定] 以儲存變更。

  5. 關閉 [Exchange 系統管理員] 並重新啟動 Microsoft Exchange Information Store 服務，以使變更生效。
若要使用 Exchange 管理主控台來啟用 Exchange Server 2007 的循環記錄

  1. 開啟 [Exchange 管理主控台]。

  2. 展開 [伺服器組態]，然後展開要修改的伺服器。

  3. 以滑鼠右鍵按一下要變更的儲存群組，然後按一下 [內容]。

  4. 在 [內容] 對話方塊中，選取 [啟用循環記錄] 核取方塊。

  5. 按一下 [確定]，儲存設定。

  6. 關閉 [Exchange 管理主控台] 並重新啟動 Microsoft Exchange Information Store 服務，以使變更生效。
若要使用 Exchange 管理命令介面來啟用 Exchange Server 2007 的循環記錄

  1. 下列程式碼為 Set-StorageGroup 命令的範例，此命令可用來啟用 MyStorageGroup 儲存群組的循環記錄。
複製程式碼
Set-StorageGroup -Identity MyStorageGroup -CircularLoggingEnabled $true

若需有關循環記錄的詳細資訊，請參閱下列 Microsoft 知識庫文章：

  • 258470＜XADM：如何修改循環記錄設定＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=258470)

  • 147524＜XADM: 循環記錄如何影響交易記錄的使用＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524)

  • 296788＜Exchange 的離線備份與還原程序＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296788)

  • 314605＜如何在 Exchange 2000 Server 及 Exchange Server 2003 中開啟或關閉循環記錄＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314605)


已停用用戶端/伺服器 RPC 壓縮
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-05

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已啟用遠端程序呼叫 (RPC) 壓縮：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Rpc Compression Enabled

如果 Exchange Server Analyzer 發現 Rpc Compression Minimum Size 的值存在，且設定的值是 0，就會顯示非預設的組態訊息。

根據預設，不管大小為何，所有在 Microsoft Office Outlook® 2003 或 Outlook 2007 及 Exchange Server 2003 或 Exchange Server 2007 間移動的 RPC 資料都會經過壓縮。在某些案例中，您可能會想要控制 RPC 壓縮。例如，如果您要藉由檢視透過網路傳送的封包來嘗試疑難排解連線問題，RPC 壓縮可能會使得分析變得困難，因為您只會在追蹤中看見壓縮的資料。

若要設定 RPC 壓縮設定，您可以新增三個登錄機碼值到系統設定中：

  • Rpc Compression Minimum Size

  • Rpc Compression Enabled

  • Rpc Packing Enabled

Rpc Compression Enabled 登錄值決定是否使用 RPC 壓縮演算法。如果此機碼不存在，則會啟用並使用 RPC 壓縮。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 刪除 Rpc Compression Enabled 機碼。如果 Rpc Compression Minimum Size 及 Rpc Packing Enabled 機碼存在，請一併刪除。

  4. 關閉登錄編輯程式，然後重新啟動 Exchange 伺服器，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關控制 RPC 壓縮的詳細資訊，請參閱知識庫文件 - 825371＜在 Exchange Server 2003 中修改遠端程序呼叫壓縮＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=825371)。


ClientMonitoringReportLevel 參數不是預設值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄機碼，以判定 Exchange Server 2003 監視 Microsoft Office Outlook® 2003 網路效能資料的方式：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server Analyzer 發現 ClientMonitoringReportLevel 登錄機碼的值不是 1，就會顯示非預設的組態訊息。

Exchange Server 會使用 ClientMonitoringReportLevel 登錄機碼的值，來識別 Outlook 2003 用戶端的網路錯誤及延遲問題。ClientMonitoringReportLevel 登錄機碼的值具有三種可能的設定。

值 | 功能
0 | 不從任何 Outlook 2003 用戶端收集任何效能資料。
1 | 僅從具有高速網路連線的 Outlook 2003 用戶端收集效能資料。
2 | 從所有 Outlook 2003 收集效能資料。

當您以值 1 或 2 啟用 ClientMonitoringReportLevel 登錄機碼時，Outlook 2003 用戶端會傳送資料給伺服器。傳送到伺服器的資料指示網路連線的狀態。傳送到伺服器的資料包括失敗的遠端程序呼叫 (RPC) 要求及錯誤情況的相關資訊。伺服器會彙總這些資訊，並記錄在事件記錄項目中。

Exchange 安裝程式不會建立 ClientMonitoringReportLevel 登錄機碼。不過，Exchange Server 2003 中的預設行為，是僅從具有高速網路連線的 Outlook 2003 用戶端收集效能資料。此 Exchange Server 2003 預設行為的功能，與將 ClientMonitoringReportLevel 登錄機碼的值設為 1 時相同。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要採取任何動作。不過，如果您要還原預設值，可編輯 ClientMonitoringReportLevel 登錄機碼的值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需還原登錄的相關資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
還原預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 連按兩下 [ClientMonitoringReportLevel]。

  4. 在 [數值資料] 欄位中，鍵入 1，然後按一下 [確定]。

  5. 關閉登錄編輯程式。

Microsoft Exchange Information Store 服務可以在幾分鐘內偵測到變更。您不必重新啟動電腦。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


考慮實作儲存配額
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-03-21

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已在每一個 private 郵件資料庫 (MDB) 物件上設定信箱配額。如果 Exchange Server Analyzer 發現特定私人 MDB 包含的信箱超過 20 個，且未在 MDB 上設定配額，就會顯示最佳作法組態訊息。

最佳作法是將配額套用至主控使用者信箱之 Exchange Server 電腦上的所有資料庫。您應在資料庫層級設定三個限制。這些限制可在信箱儲存區內容頁的 [限制] 索引標籤上設定。每個限制都以 KB 表示

  • 警告 Issue warning 限制定義觸發傳送警告電子郵件給使用者的信箱大小。警告電子郵件會告訴使用者信箱大小將接近 Prohibit send 限制。

  • 禁止傳送 Prohibit send 限制定義禁止使用者傳送電子郵件的信箱大小。使用者將接收到來自 Exchange 伺服器的電子郵件，說明已超過信箱大小限制。

  • 禁止收發 Prohibit send and receive 限制定義禁止使用者傳送及接收電子郵件的信箱大小。傳送至使用者的所有郵件將退回給寄件者，並隨附未傳遞回報 (NDR)。

當您設定這些規則時，請務必使禁止傳送限制及禁止收發限制之間有足夠大的差異。如果這兩個限制之間的差異太小，在使用者清除其信箱前，信箱可能會拒絕郵件。因此，最佳作法是在禁止傳送限制及禁止收發限制之間提供至少 20% 的緩衝區。例如，如果當使用者的信箱達到 100 MB 時禁止其傳送新訊息，則禁止收發限制應至少是 120 MB。

若要在 Exchange 2000 Server 及 Exchange Server 2003 上設定信箱限制

  1. 開啟 [Exchange 系統管理員]。

  2. 尋找 Exchange Server Analyzer 中顯示之與此問題相關的信箱儲存區。

  3. 在 [MailboxStore_Name] 上按一下滑鼠右鍵，然後選取 [內容]。

  4. 選取 [限制] 索引標籤。

  5. 修改 [超過下列大小就發出警告 (KB)]、[超過下列大小就禁止傳送 (KB)] 限制及 [超過下列大小就禁止收發 (KB)] 限制。

  6. 按一下 [套用]，然後按一下 [確定]。
若要使用 Exchange 管理主控台在 Exchange Server 2007 上設定信箱限制

  1. 開啟 [Exchange 管理主控台]

  2. 尋找 Exchange Server Analyzer 中顯示之與此問題相關的信箱儲存區。

  3. 在 [MailboxStore_Name] 上按一下滑鼠右鍵，然後選取 [內容]。

  4. 選取 [限制] 索引標籤。

  5. 修改 [超過下列大小就發出警告 (KB)]、[超過下列大小就禁止傳送 (KB)] 限制及 [超過下列大小就禁止收發 (KB)] 限制。

  6. 按一下 [套用]，然後按一下 [確定]
若要使用 Exchange 管理命令介面設定 Exchange Server 2007 的信箱限制

  1. 下列範例顯示如何設定信箱大小限制，以便在信箱超過指定大小時傳送警告訊息給使用者。這個屬性適用於此信箱資料庫中所有未設定警告配額屬性的信箱。您必須指定整數或「無限制」。預設值為 1.9 GB。

    複製程式碼
    Set-MailboxDatabase "Mailbox Database Name" -IssueWarningQuota 1991680

  2. 下列範例顯示如何設定信箱大小，以便在信箱超過指定大小時，禁止與此信箱資料庫中之信箱關聯的使用者傳送郵件。這個屬性適用於此信箱資料庫中所有未設定禁止傳送配額屬性的信箱。所設定的限制值必須是整數或「無限制」。

    複製程式碼
    Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendQuota 2097152

  3. 下列範例顯示如何設定信箱大小，以便在信箱超過指定大小時，禁止與此信箱關聯的使用者傳送或接收郵件。這個屬性適用於此信箱資料庫中所有未設定禁止傳送/接收配額屬性的信箱。您必須指定整數或「無限制」。

    複製程式碼
    Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendReceiveQuota 2411520

若需有關如何在 Exchange Server 2003 中管理 Exchange 信箱的詳細資訊，請參閱＜使用 Exchange Server 2003 儲存區＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47595)。

若需有關如何在 Exchange Server 2007 中管理 Exchange 信箱限制的詳細資訊，請參閱＜如何設定資料庫限制與屬性＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80746)


此信箱儲存區上已啟用內容索引
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定內容索引重建排程 (msExchCIRebuildSchedule) 屬性是否已設為非 null 的值，且是否已設定內容索引重建樣式 (msExchCIRebuildStyle) 屬性。這些是每個私人信箱資料庫的屬性。如果 Exchange Server Analyzer 發現已設定這兩個屬性來進行索引製作，就會顯示一則警告。

因為全文檢索需要使用大量資源，且會變更頻繁信箱資料，所以不建議在信箱儲存區上執行內容索引 (也稱為「全文檢索」)。因此，隨時針對給定的資料庫維持一份最新索引是極需要耗用大量資源的處理程序。全文檢索較適用於公用資料夾。

如果想要在信箱儲存區上執行全文檢索，建議您設定索引排程來經常更新並監視電腦的效能狀態，以確定電腦在製作內容的索引時仍可以執行，且仍可傳遞郵件並回應用戶端要求。

否則，建議您刪除信箱儲存區上的全文檢索，以停用全文檢索。

若要停用給定信箱儲存區上的全文檢索

  1. 開啟 [Exchange 系統管理員]。

  2. 依序展開 [系統管理群組]、您的系統管理群組、[伺服器]、您的伺服器及您的儲存群組，並在 [信箱儲存區] 上按一下滑鼠右鍵，然後再按 [刪除全文檢索]。

若需有關在 Exchange 中設定及疑難排解全文檢索的詳細資訊，請參閱微軟知識庫文件＜HOW TO:設定 Exchange 2003 中信箱儲存區的全文檢索＞(英文) (http://go.microsoft.com/fwlink/?LinkID=3052&kbid=822932)。


此公用資料夾儲存區已啟用內容檢索
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判斷 [內容檢索重建排程] (msExchCIRebuildSchedule) 屬性及 [內容檢索重建樣式] (msExchCIRebuildStyle) 屬性是否存在且設定為 0 以外的值。這些是每個公用資訊儲存庫資料庫的屬性。

如果 Exchange Server Analyzer 發現這兩個屬性皆存在且設為 0 以外的值，就會顯示非預設的組態訊息。

當這兩個屬性皆設為 1 時，表示資訊儲存庫資料庫已啟用全文檢索。全文檢索功能可檢索指定資料庫中的每一個字，而能提供強大而快速的搜尋。當您部署全文檢索功能時，您可以選擇檢索個別的公用資料夾或信箱儲存區。使用者便可以在公用資料夾或信箱儲存區所包含的郵件及附件中，執行全文搜尋。

根據預設值，索引包含郵件的主旨及內文、寄件者與收件者的名稱，以及出現在 [副本] 與 [密件副本] 欄位中的所有名稱。索引還包含下列類型的附件中的文字：.doc, .xls, .ppt, .html, .htm, .asp, .txt 及 .eml (內嵌的 Multipurpose Internet Mail Extensions (MIME) 郵件) 檔案。但不會檢索二進位附件，如圖片及音效。

搜尋結果的準確度僅限於最後一次更新的索引。隨著公用資料夾或信箱儲存區的內容變更，必須更新索引以反映新的內容。您可以手動執行或依照排程自動執行索引更新。

全文檢索檔案可分為四個主要類別。您可以將這些檔案的磁碟位置排列如下，使全文檢索達到最佳的效能：

  • 類別目錄 類別目錄為主索引。每個 Exchange 儲存區可有一個類別目錄。請將類別目錄置於 RAID-0+1 陣列。當您建立類別目錄時，可以在 Exchange 系統管理員中指定類別目錄位置。

  • 內容儲存區 這是一資料庫，它包含了在類別目錄中受到檢索的各種項目內容。每個伺服器只有一個內容儲存區。將全文內容儲存區置於 RAID 陣列。根據預設值，檔案會安裝在與 Exchange Server 相同的磁碟機上。

  • 暫存檔 這些檔案包含 Microsoft Search 服務所使用的暫存資訊。將全文檢索暫存目錄置於 RAID 陣列。根據預設值，這些檔案會安裝在系統磁碟機上，此磁碟機通常沒有 RAID 陣列的 I/O 輸送量。

  • 收集器記錄檔 這些檔案包含索引服務的記錄檔資訊。每個類別目錄會有一組記錄檔。您可將收集器記錄檔保留在其預設位置，或可選擇移動它們。

啟用或停用全文檢索

  1. 開啟 [Exchange 系統管理員]。

  2. 依序展開 [伺服器]、Exchange 伺服器、包含您正處理之公用資料夾儲存區的儲存群組。

  3. 在公用資料夾儲存區上按一下滑鼠右鍵，然後選取 [內容]。

  4. 選取 [全文檢索] 索引標籤。

  5. 視需要編輯 [更新間隔] 欄位。

  6. 按一下 [確定] 以儲存變更，並結束公用資料夾儲存區的 [內容]。

若需有關全文檢索公用資料夾的詳細資訊，請參閱微軟知識庫文件 - 319433＜HOW TO：設定公用資料夾的全文檢索＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319433)。

若需有關在信箱儲存區上設定及疑難排解全文檢索的詳細資訊，請參閱下列知識庫文件：

  • 822932＜HOW TO: 設定 Exchange 2003 中信箱儲存區的全文檢索＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822932)

  • 319436＜HOW TO: 設定 Exchange 2000 中信箱儲存區的全文檢索＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319436)

若需有關多種語言環境中全文檢索的詳細資訊，請參閱知識庫文件 - 325624＜XGEN：多種語言的全文檢索＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325624)。

若需有關全文檢索最佳作法的詳細資訊，請參閱知識庫文件 - 326186＜XADM：白皮書 - 部署全文檢索的最佳作法＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326186)。


DSN 目前被轉譯成郵件
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-03-21

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已將 Exchange Server 電腦上的傳遞狀態通知 (DSN) 轉譯成標準郵件：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent\RenderDSNsAsMessages

如果 Exchange Server Analyzer 發現 RenderDSNsAsMessages 登錄項目存在且設為大於 0 的值，則會顯示非預設的組態訊息。

如同其名稱所指，RenderDSNsAsMessages 登錄項目代表組態機會，可讓系統管理員控制如何在 Exchange 2000 Server、Exchange Server 2003 及 Exchange Server 2007 電腦上轉譯 DSN：

  • 如果 RenderDSNsAsMessages 的數值資料設為 0，則會將 DSN (包括傳遞報告及未傳遞回報) 轉譯成標準 MAPI 郵件。

  • 如果 RenderDSNsAsMessages 的數值資料是設為 0 以外的任意數值，則會將 DSN 轉譯成多個/混合的 MIME 郵件。

此登錄值預設不存在，且必須手動新增才能使用它。此外，若為對 Exchange 2000 Server 有適當作用的項目，電腦就必須執行最小的 September 2003 Exchange 2000 Server Post-Service Pack 3 彙總套件。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

  3. 刪除 RenderDSNsAsMessages 登錄項目。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。
  • 編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱 Microsoft 知識庫文章 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

  • 若需傳遞狀態通知格式問題的相關資訊，請參閱知識庫文章 812806＜Exchange 使用者意外接收到標準 NDR 而非自訂 NDR＞(機器翻譯) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=812806)。

  • 若需 Exchange 2000 Server Post-Service Pack 3 彙總套件的相關資訊，請參閱知識庫文章 824282＜2003 年 9 月 Exchange 2000 Server Post-Service Pack 3 彙總套件＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=824282)。


資料庫 Aging Keep Time 間隔已經修改，不是預設值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已覆寫 Exchange 用戶端檢視資料庫索引的預設過時值︰

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Private-<Private Information Store GUID>\Aging Keep Time

如果 Exchange Server Analyzer 發現 Aging Keep Time 登錄項目存在而且已設定，就會顯示非預設的組態訊息。

用於 Exchange 用戶端在 Exchange 資料庫表格中所建立檢視的索引，一段指定時間未使用便會於此時清除。下列登錄項目用於控制索引過時︰

  • Aging Keep Time 刪除前的最小索引資齡。Exchange Server 5.5 的預設值為 8 天，而 Exchange 2000 Server、Exchange Server 2003 及 Exchange Server 2007 的預設值為 40 天。

  • Aging Clean Interval 執行索引資齡工作之間的最小時間間隔 (毫秒)。預設值為 24 小時。

  • Reset Views 如果此設定存在且不為零，則會在下次執行索引過時工作期間，強制刪除所有已快取的索引。當索引過時工作完成時，Reset Views 值會設為 0。

除非 Microsoft 產品支援服務指示，否則建議您不要新增 Aging Keep Time 登錄值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要檢視或修改 Aging Keep Time 登錄值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Private-<Private Information Store GUID>

  3. 檢查並視需要變更 Aging Keep Time 值。

  4. 關閉登錄編輯程式。如果做了變更，請重新啟動 Exchange Server 電腦，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


存放在相同磁碟區中的資料庫及記錄檔
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-05

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定此信箱儲存區的資料庫檔案是否和此儲存群組的交易記錄檔存放在相同的實體磁碟上。Exchange Server Analyzer 會特別查詢 Active Directory，以判定下列事項：

  • 信箱儲存區是否有 100 個以上的信箱，透過計算信箱儲存區物件 (類別 msExchPrivateMDB) 之 homeMDBBL 屬性的值來判定。如果信箱儲存區少於 100 個信箱，則檔案位置的效能影響就有限。

  • 信箱儲存區之資料庫檔案的路徑，透過讀取信箱儲存區物件的 msExchEDBFile 值來判定。

  • 儲存群組之交易記錄檔的路徑，透過讀取儲存群組物件 (類別 msExchStorageGroup) 的 msExchESEParamLogFilePath 值來判定。

  • msExchESEParamLogFilePath 中的路徑是否與 msExchEDBFile 中的路徑位在相同磁碟上。

此外，Exchange Server Analyzer 還會判定下列事項：

  • 伺服器上是否執行 Windows 型 NAS 的 Exchange Server 延伸模組，透過查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別以取得 Exchange Server NAS 延伸模組 (wssexchmap) 的 Started 屬性值來判定。如果 Windows 型 NAS 的 Exchange Server 延伸模組正在執行，則表示考慮中的檔案可能不是位於本機磁碟機，而效能考量可能不適用。

  • 檔案是否位於名稱超過 3 個字元的磁碟區上，透過查詢 Win32_Volume WMI 類別來判定。而且，這表示檔案可能不是位於本機磁碟機，而效能考量可能不適用。

若要在硬碟失敗的情況下提供容錯，請將 Exchange 交易記錄檔及資料庫檔案保留在不同的實體硬碟上。將這些記錄檔及資料庫檔案保留在不同的硬碟上，則可明顯增加硬碟 I/O 效能。

附註：
若要在必須還原資料庫的情況下提供容錯，則每個儲存群組都要有它自己的一組交易記錄檔。交易記錄檔會維護該儲存群組中每個資料庫之每個變更的記錄。除非完整備份儲存群組中的所有資料庫，否則不會刪除交易記錄檔。

下列範例說明如果您有備份且交易記錄檔位在不同的磁碟時，甚至是在極嚴重的情況 (如遺失內含資料庫檔案或交易記錄檔的硬碟) 下，要如何復原資料。

  • 如果內含資料庫檔案的硬碟失敗，則您可更換失敗的硬碟、還原最新的資料庫檔案備份，然後使用存放在不同硬碟上的目前記錄檔來還原 Exchange 伺服器上的資料，並將它帶到硬碟失敗的時間那天。

  • 如果內含交易記錄檔的硬碟失敗，但內含資料庫檔案的硬碟仍可運作，且慢慢地關閉資料庫儲存區檔案，則可能可修復失敗的交易記錄磁碟，並重新裝載資料庫儲存區。如果資料庫儲存區檔案未慢慢地關閉，則會留在不一致的狀態，且可能只有在使用 eseutil.exe 硬式修復後才可予以裝載，這樣可能會造成部份資料遺失。另一個選擇是從備份中還原資料庫儲存區檔案，這不包含備份後建立的新信箱資料。

重要事項：
如果將 Exchange 資料庫及交易記錄檔保留在相同實體硬碟上，而該硬碟失敗，則會遺失最後一次備份後所建立的資料。

此外，將資料庫檔案及交易記錄檔放在不同的實體磁碟上，會增加整體效能。Exchange 會先將每個交易寫入到交易記錄檔，然後再寫入到資料庫檔案中。此外，儲存群組中的所有信箱儲存區會共用交易記錄檔。當這些檔案位在相同的實體磁碟上時，則磁碟機讀寫頭必須在目前的交易記錄檔位置與資料庫檔案的位置間反覆移動，才能完成寫入作業。當檔案位在不同磁碟上時，一個磁碟機讀寫頭會停留在寫入交易記錄檔的位置，所以交易的完成速度會比檔案放在單一磁碟上時要快。單一交易的效能差異很小，但系統負載高時，差異就會十分可觀。

若要更正組態，則您可以移動交易記錄檔或資料庫檔案。

若要將交易記錄檔移到 Exchange 2000 Server 或 Exchange Server 2003 的新磁碟機

  1. 在 [Exchange 系統管理員] 中，展開適當的 Exchange 伺服器物件，並在想要的儲存群組上按一下滑鼠右鍵，然後再按 [內容]。

  2. 在 [一般] 索引標籤上，指定檔案的新位置。

    例如，如果 E:\ 磁碟機只包含此儲存群組的記錄檔，請在 [交易記錄位置] 中按一下 [瀏覽]，然後選擇 E:\ 磁碟機。

若要變更 Exchange Server 2007 之 Exchange 儲存群組交易記錄檔的位置

  1. 請遵循核心 Exchange Server 2007 文件＜如何設定或變更儲存群組記錄檔的位置＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80702) 中的指導。

若要將資料庫檔案移到 Exchange 2000 Server 或 Exchange Server 2003 的新磁碟機

  1. 在 [Exchange 系統管理員] 中，依序展開儲存區所在的 Exchange 伺服器物件及適當的儲存群組容器，並在想要的信箱儲存區物件上按一下滑鼠右鍵，然後再按 [內容]。

  2. 在 [內容] 對話方塊的 [資料庫] 標籤中，指定新的檔案位置。
注意：
若要移動資料庫檔案，必須先暫時卸載資料庫，然後再重新裝載。精靈會自動完成此步驟，但執行此程序時，所有使用者都無法存取資料庫。

若要使用 [移動資料庫路徑] 精靈將資料庫檔案移到 Exchange Server 2007 的新磁碟機

  1. 啟動儲存群組所在伺服器上的 [Exchange 管理主控台]。

  2. 在主控台樹狀目錄中，展開 [伺服器組態]，然後按一下 [信箱]。

  3. 在結果窗格中，展開適當的儲存群組容器，在您要的信箱資料庫物件上按一下滑鼠右鍵，然後按一下 [移動資料庫路徑]。即會出現 [移動資料庫路徑] 精靈。

  4. 在 [簡介] 頁面上，[資料庫] 檔案路徑方塊會顯示資料庫檔案的目前儲存位置。按一下 [瀏覽] 以指定要將這些檔案移動到哪個位置。

  5. 按一下 [移動]。

  6. 在 [完成] 頁面上，確認資料庫檔案路徑是否已順利變更。當狀態顯示為「已完成」時，代表精靈已順利完成工作。當狀態顯示為「失敗」時，代表工作未完成。如果工作失敗，請檢視摘要以取得說明，然後按一下 [上一步] 以變更組態。按一下 [完成] 以完成 [移動資料庫路徑] 精靈。
附註：
您也可以使用 Exchange 管理命令介面來移動 Exchange Server 2007 的資料庫檔案。如需相關資訊，請參閱＜移動資料庫路徑＞(英文)。

若需有關 Exchange Server 資料庫檔案的詳細資訊，請參閱下列主題：

  • 《Exchange Server 2003 系統管理手冊》(http://go.microsoft.com/fwlink/?LinkId=47617) 中的＜管理信箱儲存區及公用資料夾儲存區＞(英文)

  • 《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595)中的＜認識 Exchange Server 2003 儲存區＞(英文)

若需有關管理 Exchange Server 資料庫檔案的詳細資訊，請參閱微軟知識庫文件 - 328794＜如何防止 Exchange 資料遭遇硬碟失敗＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328794)

若需有關硬式修復 Exchange 資料庫儲存區的詳細資訊，請參閱知識庫文件 - 296788＜Exchange 的離線備份與還原程序＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296788)。

若需有關在 Exchange 資料庫儲存區檔案上執行硬式修復的詳細資訊，請參閱知識庫文件 - 810190＜XADM：記錄「資訊儲存庫異常終止」錯誤訊息及事件 ID 447＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810190)。


資料庫所有的記錄檔都存在
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具判斷復原此資料庫需要的所有記錄檔都存在，且位於正確的復原位置。因此，復原失敗不是交易記錄檔遺漏或不相符所造成。

原因可能是資料庫或交易記錄檔可能已損壞或有其他檔案在干擾復原程序。

若要更正此錯誤

  • 使用 [Exchange 系統管理員] 裝載儲存群組中的一個資料庫，再檢視應用程式記錄檔，尋找可能指出失敗原因的錯誤。

  • 單獨復原資料庫。分析資料庫之後，Exchange Server Analyzer 會顯示單獨復原資料庫的指示。

  • 執行 Eseutil.exe /ML 以驗證所需記錄檔的完整性。若需有關如何使用 Eseutil 的詳細資訊，請參閱微軟知識庫文件 - 248122＜如何使用 Eseutil 測試 Exchange 2000 Server 與 Exchange Server 2003 中交易記錄檔有無損壞＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=248122)。


資料庫處於正常關機狀態
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具判斷 Exchange 資料庫處於「正常關機」狀態。

「正常關機」狀態的資料庫已正確關機且與記錄檔資料流正確分離。因此，如果您要再次裝載資料庫，您可以這麼做而不用執行復原操作。

如果您無法裝載處於「正常關機」狀態的資料庫，原因不是因為資料庫需要額外的交易記錄檔重新顯示。不過，相同儲存群組中其他資料庫所需的交易記錄檔重新顯示可能會使「正常關機」的資料庫無法裝載。必須先復原該儲存群組中所有的資料庫並使其恢復可裝載的狀態，才能裝載 Exchange 儲存群組中的資料庫。

「正常關機」狀態中的資料庫可使用其先前的交易記錄檔或使用一組不同的交易記錄檔來裝載。如果裝載「正常關機」狀態的資料庫而交易記錄檔不存在，則會產生一組新的交易記錄檔。

附註：
一般而言，您不應刪除現有的交易記錄檔，即使儲存群組中的所有資料庫都處於「正常關機」狀態亦然。如果您刪除現有的交易記錄檔，將無法從先前的備份向前復原。不過，當儲存群組中的所有資料庫都在「正常關機」狀態時，刪除交易記錄檔並不會影響目前的資料庫。最佳作法是，如果刪除儲存群組的所有交易記錄檔，應立即建立儲存群組中所有資料庫的完整備份。


資料庫處於不正常關機狀態且不需要記錄檔
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2006-08-10

Microsoft® Exchange Server Analyzer 工具判斷資料庫處於「不正常關機」狀態。

根據定義，處於「不正常關機」狀態的資料庫需要重新顯示至少一個交易記錄檔。「不正常關機」不是可裝載的資料庫狀態，在一般操作期間不應發生。

更正此錯誤

  • 若需資料庫及記錄檔的進階分析，請連絡 Microsoft 技術支援服務 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=31845)。


狀態不明的資料庫
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具已經發現您的資料庫狀態不明。一般來說，您的資料庫應該處於正常關機或不正常關機狀態。(在 Exchange 2000 Server 及更早版本中，這些狀態分別稱為一致或不一致狀態。)

若要更正此錯誤

  • 若需資料庫狀態的進階分析，請連絡 Microsoft 技術支援服務 (http://go.microsoft.com/fwlink/?LinkId=31845)。


資料庫遺失選用及必要的記錄檔
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具判定在記錄檔資料夾中找不到復原此資料庫所需的記錄檔。如果所需的記錄檔遺失，則必須等找到記錄檔之後才能復原資料庫。

如果未正確關閉 Exchange 資料庫，一律必須將記錄檔重新顯示到資料庫中，才能再次裝載該資料庫。至少，必須重新顯示一個記錄檔。不過通常會有好幾個記錄檔。

除了所需的記錄檔之外，還有其他的記錄檔可顯示到資料庫中。雖然不需要將這些選用的記錄檔重新顯示也能裝載資料庫，然而您可以使用這些記錄檔來復原其他的資料。如果您不重新顯示這些選用的記錄檔，這些記錄檔中包含的所有資料就會遺失。

若要更正此錯誤

  • 找出遺失的交易記錄檔，並將它們新增到適當的資料夾中。

  • 如果您找不到所有的選用記錄檔，則可以只使用必要的記錄檔，分開復原資料庫。若要不使用選用記錄檔來復原資料庫，請遵循 Exchange Server Analyzer 中的指示。請記住，如果您不使用選用記錄檔來復原資料庫，將會遺失這些選用記錄檔中的資料。

    不過，視遺失的記錄檔而定，您還是可以將某些選用記錄檔重新顯示到資料庫中。例如，請考量下列案例。您的記錄檔號碼是從一到十。需要第十個記錄檔 (其餘的檔案是選用的)，而第六個記錄檔遺失。在此案例中，您應該可以重新顯示號碼七到十的記錄檔，因為到所需檔案間的順序是連續的。

  • 修復目前的資料庫。

    附註：
    雖然修復資料庫很可能會成功，但是不保證一定成功。即使是成功的修復，也可能會造成輕微或重大的資料遺失。若需有關如何修復 Exchange 資料庫的詳細資訊，請參閱微軟知識庫文件 - 812357＜使用 Eseutil /p 工具修復 Exchange 資料庫後的維護工作＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812357)。

  • 實作包含修復及還原資料庫的交互性策略。有些時候，即使資料庫無法使用其他記錄檔向前復原，您還是可以還原資料庫。在這些案例中，您可以一邊還原前版的資料庫，一邊同時修復目前無法裝載的資料庫。然後，您可以將這兩個資料庫的內容合併，盡可能挽救最多的資料。這是一種進階的策略，您可能需要在實作之前連絡 Microsoft 技術支援服務 (http://go.microsoft.com/fwlink/?LinkId=31845)。若需有關此策略的詳細資訊，請參閱《使用 Exchange Server 2003 復原儲存群組》(英文) (http://go.microsoft.com/fwlink/?LinkId=47589)。


資料庫遺失選用的記錄檔但沒有遺失必要的記錄檔
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具已判定其中一個資料庫未正確關閉。

如果未正確關閉 Exchange 資料庫，一律必須將記錄檔重新顯示到資料庫中，才能再次裝載該資料庫。至少，必須重新顯示一個記錄檔。不過通常會有好幾個記錄檔。

除了所需的記錄檔之外，還有其他的記錄檔可顯示到資料庫中。雖然不需要將這些選用的記錄檔重新顯示也能裝載資料庫，然而您可以使用這些記錄檔來復原其他的資料。如果您不重新顯示這些選用的記錄檔，這些記錄檔中包含的所有資料就會遺失。

若要更正此錯誤

  • 找出遺失的選用記錄檔，並將它們複製到交易記錄資料夾中。

  • 如果您找不到所有的選用記錄檔，則可以只使用必要的記錄檔，分開復原資料庫。若要不使用選用記錄檔來復原資料庫，請遵循 Exchange Server Analyzer 中的指示。請記住，如果您不使用選用記錄檔來復原資料庫，將會遺失這些選用記錄檔中的資料。

    不過，視遺失的記錄檔而定，您還是可以將某些選用記錄檔重新顯示到資料庫中。例如，請考量下列案例。您的記錄檔號碼是從一到十。需要第十個記錄檔 (其餘的檔案是選用的)，而第六個記錄檔遺失。在此案例中，您應該可以重新顯示號碼七到十的記錄檔，因為到所需檔案間的順序是連續的。


資料庫遺失所需的記錄檔
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具已判定在記錄檔資料夾中找不到復原此資料庫所需的記錄檔。如果所需的記錄檔遺失，則必須等找到記錄檔之後才能復原資料庫。

若要更正此錯誤

  • 找出遺失的交易記錄檔，並將它們新增到適當的資料夾中。

  • 從備份還原資料庫。然後將剩餘的交易記錄檔顯示到資料庫中，以向前復原資料庫。

    重要事項：
    遺失記錄檔中的資料及後續的記錄檔都會遺失。從備份還原資料庫之前，應該儲存一份現有的資料庫。如果還原不成功，還能修復現有的資料庫。

  • 修復目前的資料庫。

    附註：
    雖然修復資料庫很可能會成功，但是不保證一定成功。即使是成功的修復，也可能會造成輕微或重大的資料遺失。若需如何修復 Exchange 資料庫的詳細資訊，請參閱微軟知識庫文件 - 812357＜使用 Eseutil /p 工具修復 Exchange 資料庫後的維護工作＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812357)。

  • 實作包含修復及還原資料庫的交互性策略。有些時候，即使資料庫無法使用其他記錄檔向前復原，您還是可以還原資料庫。在這些案例中，您可以一邊還原前版的資料庫，一邊同時修復目前無法裝載的資料庫。然後，您可以將這兩個資料庫的內容合併，盡可能挽救最多的資料。這是一種進階的策略，您可能需要在實作之前連絡 Microsoft 技術支援服務 (http://go.microsoft.com/fwlink/?LinkId=31845)。若需有關此策略的詳細資訊，請參閱《使用 Exchange Server 2003 復原儲存群組》(英文) (http://go.microsoft.com/fwlink/?LinkId=47589)。


在備份期間此儲存群組中的資料庫設定為零頁
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-05

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定伺服器上每一個儲存群組的 msExchESEParamZeroDatabaseDuringBackup 屬性值。如果 Exchange Server Analyzer 發現 msExchESEParamZeroDatabaseDuringBackup 屬性設為 1，Exchange Server Analyzer 工具就會顯示非預設的組態訊息。

msExchESEParamZeroDatabaseDuringBackup 屬性代表在備份期間可以用零覆寫所刪除記錄/長數值的組態設定。這個處理程序稱為實體清空。您可以在儲存群組層級上控制資料庫分頁的實體清空。每一個儲存群組可以有不同原則來實體清空已刪除的資料庫分頁。

在預設的情況下，會停用實體清空，且 msExchESEParamZeroDatabaseDuringBackup 屬性值會設為 0。如果該屬性設為 1，在結束該儲存群組中的任何資料庫的線上備份時，會以其他字元覆寫已刪除的資料庫分頁。

依這份文件所述，您可以使用 [Exchange 系統管理員] 來啟用及停用 Exchange 2000 Server 及 Exchange Server 2003 的實體清空。此外，依這份文件所述，您也可以使用 [Exchange 管理命令介面] 來啟用及停用 Exchange Server 2007 的實體清空。雖然此選項提供更高安全性，但它會影響伺服器效能。

附註 如果您要在 Exchange 2000 Server 電腦上啟用實體清空，建議您安裝 Exchange 2000 Server Service Pack 3 或更新版本。Service Pack 3 會更正造成 Exchange 資訊儲存庫停止回應的已知問題。若需有關這個問題的詳細資訊，請參閱微軟知識庫文件 - 320883＜XADM：開啟資料庫實體清空時，資訊儲存庫會於線上備份期間停止回應＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320883)。

若要啟用或停用 Exchange 2000 Server 及 Exchange Server 2003 的實體清空

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [伺服器]，再展開要修改的伺服器。

  3. 以滑鼠右鍵按一下要變更的儲存群組，然後按一下 [內容]。

  4. 在 [內容] 對話方塊中，視需要來選取或清除 [實體清空已刪除的資料庫分頁] 核取方塊。選取該核取方塊會啟用實體清空，清除該核取方塊則會停用實體清空。

  5. 按一下 [確定]，儲存設定。

  6. 關閉 [Exchange 系統管理員]，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

若要啟用或停用 Exchange Server 2007 已刪除分頁的實體清空

  1. 下列程式碼是 Set-StorageGroup 命令的範例，此命令可啟用或停用 MyStorageGroup 儲存群組中之資料庫的實體清空。
複製程式碼
Set-StorageGroup -Identity MyStorageGroup -ZeroDatabasePages
 $false
Set-StorageGroup -Identity MyStorageGroup -ZeroDatabasePages
 $true

若需有關覆寫已刪除資料庫分頁會帶來何種效能影響的詳細資訊，請參閱知識庫文件 - 815068＜XADM：線上備份效能隨時間而降低＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815068)。


設定為在啟動時中斷偵錯
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已在 Microsoft Exchange Information Store 上啟用偵錯：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Debug Break At Startup

如果 Exchange Server Analyzer 發現已設定 Debug Break At Startup 的值，則會顯示警告。

在下次啟動 Microsoft Exchange Information Store 服務時，Debug Break At Startup 登錄值會啟用偵錯模式。Microsoft Exchange Information Store 在執行偵錯模式時會使用許多資源。在生產環境中的儲存區進行偵錯不是理想的作法。

除非您是在 Microsoft 產品支援服務的協助下，主動疑難排解儲存區問題，否則就應該刪除 Debug Break At Startup 登錄值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定您瞭解如何在發生問題時還原登錄。若需如何還原登錄的相關資訊，請檢視 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
刪除 Debug Break At Startup 登錄機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右窗格中，尋找並刪除 Debug Break At Startup 值。

  4. 關閉登錄編輯程式，然後重新啟動 [Microsoft Exchange Information Store] 服務，使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


已變更 ESE 記錄緩衝區的預設值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會搜尋 Active Directory® 目錄服務，以找出 Exchange Server 電腦上每個儲存群組的 msExchESEParamLogBuffers 屬性值。如果 Exchange Server Analyzer 發現 msExchESEParamLogBuffers 的值等於 512，則會顯示非預設的組態訊息。

msExchESEParamLogBuffers storage group 屬性控制 Exchange 資訊儲存庫使用的「可擴充儲存引擎 (ESE)」記錄檔緩衝區數。ESE 使用一組記錄緩衝區，先將資訊保留在 RAM 中，再將它寫入交易記錄檔中。使用這些緩衝區來改善交易記錄效能。若為大型伺服器，預設值 84 便會太低。這會讓交易記錄檔磁碟機有過多的磁碟 I/O 作業，因此，如果伺服器低於負載或使用者傳送大型郵件，便會使效能嚴重衰退。增加 ESE 記錄緩衝區的數目，雖然會使用更多的虛擬記憶體，但可改善效能。

若要正確設定這個值，請使用下列資訊：

  • 若為 Exchange 2000 Server、Exchange 2000 Server Service Pack 1 (SP1) 或 Exchange 2000 Server Service Pack 2 (SP2)，請將此值設為 9000。

  • 若為 Exchange 2000 Server Service Pack 3 (SP3)，請將此值設為 512。

  • 若為 Exchange Server 2003，會使用預設值 500，您應該將 msExchESEParamLogBuffers 屬性的值變更為 9000。

附註：
如果您先前將記錄檔緩衝區調整為 9000，請務必於套用 Exchange 2000 Server SP3 之後，手動縮小此設定。安裝 Exchange 2000 Server SP3 時，並不會自動執行此項變更。

如果發生記錄停滯，原因可能是緩衝區太少，最高可將此值增加到 9000。您可監視 Database\Log Record Stalls/sec 效能計數器以判定是否發生記錄停滯。請不要使用大於 9000 的值，因為這樣可能會損毀交易記錄檔。

附註：
Log Record Stalls/sec 是每秒無法新增到記錄緩衝區的記錄數 (原因是這些記錄緩衝區已滿)。如果此計數器大部份時間都不是零，則記錄緩衝區大小可能會是瓶頸。

您必須使用如 [Active Directory Service Interfaces (ADSI) 編輯器] 嵌入式管理單元、LDP (ldp.exe) 工具或任何其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端等工具來更正此值。

注意：
使用 ADSI 編輯器、LDP 工具或其他 LDAP 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要還原為預設組態

  1. 啟動 [ADSI 編輯器]。

  2. 連按兩下 [Configuration] 容器，依序展開 CN=Services、 CN=Microsoft Exchange、 CN=<ExchangeOrganizationName>。

  3. 展開 CN=Administrative Groups、展開 CN=<AdministrativeGroupName>，然後展開 CN=Servers。

  4. 依序展開 CN=<ServerName> 及 CN=InformationStore，並在 CN=<StorageGroupName> 上按一下滑鼠右鍵，再按一下 [內容]。

  5. 在 [屬性編輯器] 中按一下 msExchESEParamLogBuffers 屬性，再按一下 [編輯]。

  6. 在 [編輯屬性] 方塊中，若為 Exchange 2000 Server，請將值設為 512，若為 Exchange Server 2003，則設為 9000。

  7. 按一下 [套用]，再按一下 [確定]。

  8. 關閉 [ADSI 編輯器]，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

若需 ESE 記錄緩衝區的相關資訊，請參閱微軟知識庫文件 - 328466＜XADM:ESE Log Buffers That Are Set Too Low Can Cause the Store to Stop Responding＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466)。

若需有關使用 LDP 工具的詳細資訊，請參閱知識庫文件 - 260745＜XADM：Using the LDP Utility to Modify Active Directory Object Attributes＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

若需有關使用 ADSI 編輯器的詳細資訊，請參閱主題＜Adsiedit.msc：ADSI 編輯器＞(位在 Windows Server 說明中)。


預設公用資料夾儲存區位在遠端
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-03

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個信箱儲存區的 msExchHomePublicMDB 屬性是否包含本機 Exchange Server。在預設的情況下，信箱儲存區的公用資料夾儲存區位在本機 Exchange Server。如果 msExchHomePublicMDB 屬性不包含本機 Exchange Server，則信箱儲存區具有遠端預設公用資料夾儲存區。如果 Exchange Server Analyzer 發現信箱儲存區有遠端的預設公用資料夾儲存區，則會顯示非預設的組態訊息。

若要變更預設的公用資料夾儲存區

  1. 在 [Exchange 系統管理員] 中，依序展開 [伺服器]、<您的 Exchange 伺服器>、<儲存群組>，然後在信箱儲存區按一下滑鼠右鍵，再選取 [內容]。

  2. 在 [一般] 索引標籤上的 [預設公用儲存區] 之下，按一下 [瀏覽] 選取公用資料夾儲存區。

若需有關信箱儲存區及公用資料夾儲存區的詳細資訊，請參閱《Exchange Server 2003 系統管理手冊》(http://go.microsoft.com/fwlink/?LinkId=47617) 中的＜管理信箱儲存區及公用資料夾儲存區＞(英文)。


信箱儲存區的 Deletion Thread Period 並非預設值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已將已刪除郵件之移除間隔修改為預設值以外的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Deletion Thread Period

如果 Exchange Server Analyzer 發現 Deletion Thread Period 機碼存在且已設定，就會顯示非預設的組態訊息。

當您刪除郵件時，Exchange 會將郵件標示為待刪除。Exchange 也會將郵件標示為隱藏，直到從 Exchange 儲存區永久刪除該郵件為止。當Exchange 儲存區收到刪除特定資料夾中郵件識別碼所參照之郵件的要求時，Exchange 儲存區會判定是應該將郵件軟刪除還是硬刪除。超過已刪除郵件的保留期間時，就會永久刪除郵件。軟刪除也稱為邏輯刪除。硬刪除也稱為實體刪除。

在預設的情況下，大型垃圾筒清理處理程序每 24 小時執行一次，以判定是否該對郵件進行硬刪除。大型垃圾筒清理處理程序是 Exchange 儲存區線上維護程序的一部分。如果超過已刪除郵件的保留期間，就會強制刪除郵件。Deletion Thread Period 登錄值是用來覆寫預設的 24 小時間隔，並指定大型垃圾筒清理處理程序的自訂間隔。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. 刪除 Deletion Thread Period 機碼。

  4. 關閉登錄編輯程式。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關保留及復原已刪除郵件的詳細資訊，請參閱下列知識庫文件：

  • 249680＜XADM：瞭解保留已刪除郵件及郵件刪除處理程序＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=249680)

  • 287544＜XADM：啟用保留已刪除郵件功能時公用資訊儲存庫顯著增長＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=287544)

  • 822938＜HOW TO: 使用系統原則設定 Exchange Server 2003 中信箱儲存限制＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822938)


公用資料夾儲存區的 Deletion Thread Period 並非預設值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已將已刪除郵件之移除間隔修改為預設值以外的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\Deletion Thread Period

如果 Exchange Server Analyzer 發現 Deletion Thread Period 機碼存在且已設定，就會顯示非預設的組態訊息。

當您刪除郵件時，Exchange 會將郵件標示為待刪除。Exchange 也會將郵件標示為隱藏，直到從 Exchange 儲存區永久刪除該郵件為止。當資訊儲存庫收到在特定資料夾中刪除由郵件識別碼所參照之郵件的要求時，Exchange 儲存區會判定應該將郵件軟刪除還是硬刪除。軟刪除亦稱為邏輯刪除，而硬刪除亦稱為實體刪除。超過已刪除郵件的保留期間時，就會永久刪除郵件。

在預設的情況下，大型垃圾筒清理處理程序每 24 小時執行一次，以判定是否該對郵件進行硬刪除。大型垃圾筒清理處理程序是 Exchange 儲存區線上維護程序的一部分。如果超過已刪除郵件的保留期間，就會強制刪除郵件。Deletion Thread Period 登錄值是用來覆寫預設的 24 小時間隔，並指定大型垃圾筒清理處理程序的自訂間隔。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. 刪除 Deletion Thread Period 機碼。

  4. 關閉登錄編輯程式。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關保留及復原已刪除郵件的詳細資訊，請參閱下列知識庫文件：

  • 249680＜XADM：瞭解保留已刪除的郵件及郵件刪除處理程序＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=249680)

  • 287544＜XADM：啟用保留已刪除的郵件功能時，公用資訊儲存庫顯著成長＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=287544)

  • 319098＜HOW TO: 在 Exchange 2000 Server 中使用系統原則設定公用資料夾儲存限制＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319098)


偵測到磁碟瓶頸
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2006-11-14

Microsoft® Exchange Server Analyzer 工具判斷磁碟系統目前執行於預期可用傳輸量上限的 20% 之內。此判斷是由下列其中一項計算而認定：

  • 測量磁碟延遲。指出延遲的效能計數器為 [LogicalDisk\Avg.Disk sec/Read] 和 [LogicalDisk\Avg.Disk sec/Write.]

  • 將目前磁碟組態的每秒最大可能磁碟 I/O (IOPS) 及轉軸計數與效能監視器 (Perfmon) 所記錄的目前 IOPS 值比較。

可接受的延遲

視存取的資料類型而定，Exchange 伺服器有不同的容許延遲。因此，最大可接受平均延遲閾值是根據磁碟上資源的類型而定。除了下列清單所指示之外的所有情況中，最大可接受的讀取或寫入延遲值為 50 毫秒 (ms)。

  • 交易記錄檔磁碟機 主控交易記錄檔的磁碟機，其平均寫入延遲應小於 10 毫秒。寫入延遲中的中止應該低於 50 毫秒。交易記錄檔寫入動作是同步的。這表示 Store.exe 處理程序中的執行緒必須先等寫入完成，才能執行其他工作。交易記錄檔的寫入延遲低，對伺服器效能而言相當重要。交易記錄磁碟機的平均讀取延遲應小於 20ms。讀取延遲尖峰應小於 50ms。每秒資料庫記錄停滯應小於 10。等候的資料庫記錄執行緒應小於 10。

    通常，Exchange 伺服器不會讀取交易記錄檔。因此，該磁碟機的讀取延遲不重要。不過，因為交易記錄檔寫入延遲對 Exchange 效能相當重要，建議您在大型伺服器上，不要將主控交易記錄檔的磁碟機用於其他用途。在此情況中，讀取速率 (由 LogicalDisk\Disk Reads/sec 測量) 與寫入速率 (LogicalDisk\Disk Writes/sec) 比應為最小。Exchange Server Analyzer 會偵測交易記錄檔磁碟機上讀取對寫入的比率是否大於 0.10 (相對於每 10 次寫入有大於 1 次的讀取)。

    如果相對於每次寫入有大於 0.10 次的讀取，應識別哪一個應用程式在讀取交易記錄檔磁碟機，然後避免此動作發生。

  • 資料庫磁碟機 包含 Exchange 資料庫檔案 ( *edb 與 *stm 檔) 之磁碟機的可接受延遲如下 (較高的值表示磁碟瓶頸)：

    • 資料庫磁碟機上 [Logical Disk\Avg.Disk sec/Read] 的最大值應小於 50ms (0.050 秒)。

    • 資料庫磁碟機上 [Logical Disk\Avg.Disk sec/Read] 的平均值應小於 20ms (0.020 秒)。

  • TEMP 及 TMP 磁碟機 包含 TEMP 及 TMP 目錄之磁碟機的延遲，其讀取及寫入延遲應該低於 10 毫秒。讀取或寫入延遲的最大值應該低於 50 毫秒。

  • 分頁及系統磁碟機 包含分頁檔及 Windows 系統檔之磁碟機的讀取及寫入延遲應小於 10 ms。

  • SMTP 磁碟機 包含 SMTP 伺服器檔案之磁碟機的讀取及寫入延遲應小於 10 ms。

延遲的原因

以高於磁碟子系統所能支援的速率存取磁碟是磁碟延遲最常見的原因之一。在此情況中，該磁碟稱為「瓶頸」。這也表示磁碟子系統已到達或超出其輸送量的容量。

如果磁碟 IOPS 的速率 ([LogicalDisk\Disk Transfers/sec]) 接近或大於估計的容量，則該磁碟即「超過輸送量的容量」或「超過容量」。在這些情況中，若要改善伺服器效能，必須減少磁碟子系統上的負載 (將使用者移至其他伺服器) 或增加磁碟機的容量 (增加更多或更快的轉軸)。

如果硬體效能未達預期，即使 I/O 速率顯著低於估計容量，仍可觀察到延遲。

減少磁碟延遲

若要減少磁碟子系統上的負載，可以減少由伺服器所執行的工作。更明確地說，您應該移除造成磁碟負載的選擇性應用程式。Store.exe 處理程序是唯一應存取資料庫及交易記錄檔磁碟機的應用程式。

視目前的磁碟系統組態而定，可以採取幾個動作來減少此問題的影響。

若要減少磁碟延遲

  • 如果資料庫或交易記錄檔磁碟機遇到瓶頸，可以將使用者移至尚未接近最大容量的磁碟機上的資料庫或儲存群組，以減少該磁碟機的負載。如果所有的資料庫或交易記錄檔磁碟機都已接近容量，可能必須將使用者移至其他伺服器。若需詳細資訊，請參閱將使用者信箱移至其他伺服器

  • 有時高 I/O 速率的持續時間很短，因為是由耗資源的 MAPI 作業所致。在此情況中，若要判斷哪一個使用者或動作造成高 I/O 速率，可以配合邏輯磁碟效能計數器使用 Exchange Server User Monitor (ExMon) 工具。如果您可以分出使用者，可能可以識別哪一個用戶端應用程式產生較大的負載。您可以從 Microsoft 下載中心 (英文) (http://go.microsoft.com/fwlink/?LinkId=54983) 下載 ExMon。

  • 如果您正在執行 RAID-5 磁碟陣列，可能會想要變更為 RAID-10 磁碟陣列以改善磁碟子系統的可用支援 IOPS。

  • 若要改善可用支援 IOPS，請考慮增加額外的磁碟至磁碟系統。

詳細資訊

  • 若需有關 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需有關疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《疑難排解 Microsoft Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 如需有關設計存放結構的最佳作法，請參閱《多重結構通用的最佳作法》(英文) (http://go.microsoft.com/fwlink/?LinkId=72988)。

  • 若需有關移動使用者信箱以減少伺服器負載的詳細資訊，請參閱將使用者信箱移至其他伺服器。

  • 若需有關磁碟大小、延遲及 I/O 速率的詳細資訊，請參閱下列 Microsoft Exchange 團隊部落格網站上的部落格：

    • ＜磁碟大小的一些基本概念＞(英文) (http://go.microsoft.com/fwlink/?linkid=39538)

    • ＜一些有關磁碟 IO 及計算的其他想法...＞(英文)(http://go.microsoft.com/fwlink/?linkid=39539)

    • 《如何計算磁碟 I/O 需求》(英文) (http://go.microsoft.com/fwlink/?linkid=69747)


包含交易記錄檔的磁碟上發現磁碟瓶頸
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具判斷包含 Exchange Server 記錄檔的磁碟系統工作過多，造成效能瓶頸。此判斷是檢查一或多個下列效能計數器而認定：

  • 平均 [Database\Log Record Stalls/sec] 大於 10。

  • 最大 [Database\Log Record Stalls/sec] 大於 100。

  • 平均 [Database\Log Threads Waiting] 大於 10。

  • 最大 [Database\Log Threads Waiting] 大於 20。

如果達到這些閾值其中一個，就會顯示錯誤，說明記錄磁碟機是磁碟瓶頸。記錄檔需要低寫入延遲。備份或記錄檔寫入停滯可能造成伺服器效能問題。記錄停滯的原因可能是記錄緩衝設定 msExchESEParamLogBuffers 太低，或是連線至伺服器的使用者過多。

若要減少記錄磁碟延遲

  • 您可以將 ESE 緩衝區參數 msExchESEParamLogBuffers 提高為 9,000。請不要使用大於 9,000 的值，因為這樣可能會損毀交易記錄檔。若需詳細資訊，請參閱＜已變更 ESE 記錄緩衝區的預設值＞。

  • 如果資料庫或交易記錄檔磁碟機遇到瓶頸，可以將使用者移至尚未接近最大容量的磁碟機上的資料庫或儲存群組，以減少該磁碟機的負載。如果所有的資料庫或交易記錄檔磁碟機都已接近容量，可能必須將使用者移至其他伺服器。若需詳細資訊，請參閱＜將使用者信箱移至其他伺服器＞。


EnableChangeNotification 並非預設值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄值，以判定是否已啟用 Exchange 可安裝的檔案系統 (ExIFS) 的檔案變更通知：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIFS\Parameters\ EnableChangeNotification

如果 Exchange Server Analyzer 發現 EnableChangeNotification 機碼存在，且設定的值大於 0，就會顯示非預設的組態訊息。

在預設的情況下，已停用 ExIFS 的檔案變更通知。當 ExIFS 傳送檔案或目錄的變更通知時，它不會清除檔案或目錄的快取版本。因此，當 Exchange Server 或 Microsoft SharePoint® Portal Server 之類的應用程式收到變更通知並重新載入檔案或目錄時，應用程式會取得快取版本，而非新修改的檔案或目錄。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\EXIFS\Parameters

  3. 刪除 EnableChangeNotification 機碼。

  4. 關閉登錄編輯程式，然後重新啟動 Exchange 伺服器，使變更生效。

在編輯登錄之前，以及想瞭解有關如何編輯登錄的詳細資訊時，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Exchange 可安裝之檔案系統的詳細資訊，請參閱下列文件：

  • 《Exchange Server 2000 Resource Kit》(http://go.microsoft.com/fwlink/?LinkId=51224) 中的 第 26 章＜Exchange 2000 結構＞(英文)

  • 《Exchange Server 2003 技術參考手冊》(英文) (http://go.microsoft.com/fwlink/?linkid=47891)


存取記錄檔目錄時發生錯誤
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具判斷 Exchange 伺服器上為此儲存群組之交易記錄檔定義的路徑無法存取。

若要更正此錯誤

  • 確認伺服器上確實存在該路徑。

  • 確認您有讀取交易記錄檔路徑中所儲存之檔案的必要權限。


存取資料流資料庫檔時發生錯誤
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具已判定無法存取 Exchange 資料流資料庫 (.stm) 檔。

Exchange 2000 Server 及 Exchange Server 2003 的每個資料庫是由兩種檔案構成：.edb Exchange 資料庫檔及 .stm 資料流資料庫檔。必須同時存取與處理這些檔案。

若要更正此錯誤：

  • 找出 .stm 檔的路徑。在 [Exchange 系統管理員] 中，會在每個資料庫物件的資料庫內容頁中定義此路徑。

  • 驗證此資料庫的 .stm 檔存在。

  • 驗證您有權限可以存取 .stm 檔所在的資料夾。

  • 請確認檔案未被其他處理程序獨佔鎖定。一個確認的方法是嘗試重新命名檔案。如果可以順利重新命名檔案，這表示檔案未被獨佔鎖定。(請記得將檔案重新命名為其原來的名稱。)


檢查記錄檔時發生錯誤
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具無法讀取交易記錄檔。

若要更正此錯誤

  • 請確認您有存取交易記錄檔資料夾的必要權限。

  • 請確認檔案未被其他處理程序獨佔鎖定。一個確認的方法是嘗試重新命名檔案。如果可以順利重新命名檔案，這表示檔案未被獨佔鎖定。(請記得將檔案重新命名為其原來的名稱。)


此儲存群組的 ESE 記錄緩衝區已達最高上限
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個儲存群組的 msExchESEParamLogBuffers 屬性值。如果 Exchange Server Analyzer 發現 msExchESEParamLogBuffers 屬性的值等於 9,000，就會顯示一則非預設組態的訊息。

「可擴充儲存引擎 (ESE)」使用一組記錄緩衝區，先將資訊保留在 RAM 中，再將它寫入交易記錄檔中。使用這些緩衝區來改善交易記錄效能。若為大型伺服器，預設值 84 便會太低。這會讓交易記錄檔磁碟機有過多的磁碟 I/O 作業，因此，如果伺服器低於負載或使用者傳送大型郵件，便會使效能嚴重衰退。增加 ESE 記錄緩衝區的數目，雖然會使用更多的虛擬記憶體，但可改善效能。

若要正確設定這個值，請使用下列資訊：

  • 若為 Exchange 2000 Server、Exchange 2000 Server Service Pack 1 (SP1) 或 Exchange 2000 Server Service Pack 2 (SP2)，請將此值設為 9000。

  • 若為 Exchange 2000 Server Service Pack 3 (SP3)，請將此值設為 512。

  • 若是 Exchange Server 2003，預設值是使用 500，您應該將 msExchESEParamLogBuffers 屬性的值變更為 9000。

附註：
如果您先前將記錄檔緩衝區調整為 9000，請務必於套用 Exchange 2000 Server SP3 之後，手動縮小此設定。安裝 Exchange 2000 Server SP3 時，並不會自動執行此項變更。

如果發生記錄停滯，原因可能是緩衝區太少，最高可將此值增加到 9000。您可監視 Database\Log Record Stalls/sec 效能計數器以判定是否發生記錄停滯。請不要使用大於 9000 的值，因為這樣可能會損毀交易記錄檔。

附註：
Log Record Stalls/sec 是每秒無法新增到記錄緩衝區的記錄數 (原因是這些記錄緩衝區已滿)。如果此計數器大部份時間都不是零，則記錄緩衝區大小可能會是瓶頸。

您必須使用如 [Active Directory Service Interfaces (ADSI) 編輯器] 嵌入式管理單元、LDP (ldp.exe) 工具或任何其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端等工具來更正此值。

注意：
使用 ADSI 編輯器、LDP 工具或其他 LDAP 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要還原為預設組態

  1. 啟動 [ADSI 編輯器]。

  2. 連按兩下 [Configuration] 容器，依序展開 CN=Services、 CN=Microsoft Exchange、 CN=<ExchangeOrganizationName>。

  3. 展開 CN=Administrative Groups、展開 CN=<AdministrativeGroupName>，然後展開 CN=Servers。

  4. 依序展開 CN=<ServerName> 及 CN=InformationStore，並在 CN=<StorageGroupName> 上按一下滑鼠右鍵，再按一下 [內容]。

  5. 在 [屬性編輯器] 中按一下 msExchESEParamLogBuffers 屬性，再按一下 [編輯]。

  6. 在 [Edit Attribute] 方塊中，若為 Exchange 2000 Server，則將該值設定為 512，若為 Exchange Server 2003，則設定為 9000。

  7. 按一下 [Apply]，再按一下 [OK]。

  8. 關閉 [ADSI 編輯器]，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

若需有關設定 ESE 記錄緩衝區的詳細資訊，請參閱微軟知識庫文件 - 328466＜XADM：ESE Log Buffers That Are Set Too Low Can Cause the Store to Stop Responding＞(http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466)。


此儲存群組的 ESE 記錄緩衝區設定值太低
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 InformationStore 容器之每個儲存群組物件 (類別 msExchStorageGroup) 的 msExchESEParamLogBuffers 值。如果 Exchange Server Analyzer 發現此屬性的值小於 500，則會顯示警告。

「可擴充儲存引擎 (ESE)」使用一組記錄緩衝區，先將資訊保留在 RAM 中，再將它寫入交易記錄檔中。使用這些緩衝區來改善交易記錄效能。若為大型伺服器，預設值 84 便會太低。這會讓交易記錄檔磁碟機有過多的磁碟 I/O 作業，因此，如果伺服器低於負載或使用者傳送大型郵件，便會使效能嚴重衰退。增加 ESE 記錄緩衝區的數目，雖然會使用更多的虛擬記憶體，但可改善效能。

若要正確設定這個值，請使用下列資訊：

  • 若為 Exchange 2000 Server、Exchange 2000 Server Service Pack 1 (SP1) 或 Exchange 2000 Server Service Pack 2 (SP2)，請將此值設為 9000。

  • 若為 Exchange 2000 Server Service Pack 3 (SP3)，請將此值設為 512。

  • 若為 Exchange Server 2003，會使用預設值 500，您應該將 msExchESEParamLogBuffers 屬性的值變更為 9000。

附註：
如果您先前將記錄檔緩衝區調整為 9000，請務必於套用 Exchange 2000 Server SP3 之後，手動縮小此設定。安裝 Exchange 2000 Server SP3 時，並不會自動執行此項變更。

如果發生記錄停滯，原因可能是緩衝區太少，最高可將此值增加到 9000。您可監視 Database\Log Record Stalls/sec 效能計數器以判定是否發生記錄停滯。請不要使用大於 9000 的值，因為這樣可能會損毀交易記錄檔。

附註：
Log Record Stalls/sec 是每秒無法新增到記錄緩衝區的記錄數 (原因是這些記錄緩衝區已滿)。如果此計數器大部份時間都不是零，則記錄緩衝區大小可能會是瓶頸。

您必須使用如 [Active Directory Service Interfaces (ADSI) 編輯器] 嵌入式管理單元、LDP (ldp.exe) 工具或任何其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端等工具來更正此值。

注意：
使用 ADSI 編輯器、LDP 工具或其他 LDAP 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要更正此警告

  1. 啟動 [ADSI 編輯器]。

  2. 連按兩下 [Configuration] 容器，依序展開 CN=Services、 CN=Microsoft Exchange、 CN=<ExchangeOrganizationName>。

  3. 展開 CN=Administrative Groups、展開 CN=<AdministrativeGroupName>，然後展開 CN=Servers。

  4. 依序展開 CN=<ServerName> 及 CN=InformationStore，並在 CN=<StorageGroupName> 上按一下滑鼠右鍵，再按一下 [內容]。

  5. 在 [屬性編輯器] 中按一下 msExchESEParamLogBuffers 屬性，再按一下 [編輯]。

  6. 在 [編輯屬性] 方塊中，若為 Exchange 2000 Server，請將值設為 512，若為 Exchange Server 2003，則設為 9000。

  7. 按一下 [套用]，再按一下 [確定]。

  8. 關閉 [ADSI 編輯器]，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

若需 ESE 記錄緩衝區的相關資訊，請參閱微軟知識庫文件 - 328466＜XADM:ESE Log Buffers That Are Set Too Low Can Cause the Store to Stop Responding＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466)。

若需有關使用 LDP 工具的詳細資訊，請參閱知識庫文件 - 260745＜XADM：Using the LDP Utility to Modify Active Directory Object Attributes＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

若需有關設定 ESE 記錄緩衝區的詳細資訊，請參閱知識庫文件 - 328466＜XADM：ESE Log Buffers That Are Set Too Low Can Cause the Store to Stop Responding＞(http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466)。

若需有關使用 ADSI 編輯器的詳細資訊，請參閱主題＜Adsiedit.msc：ADSI 編輯器＞(位在 Windows Server 說明中)。


此儲存群組上的 ESE 記錄緩衝區設得太高
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個儲存群組的 msExchESEParamLogBuffers 屬性值。如果 Exchange Server Analyzer 判定有任何儲存群組的msExchESEParamLogBuffers 屬性值大於 9,000，就會顯示一則錯誤。

「可擴充儲存引擎 (ESE)」使用一組記錄緩衝區，先將資訊保留在 RAM 中，再將它寫入交易記錄檔中。使用這些緩衝區來改善交易記錄效能。若為大型伺服器，預設值 84 便會太低。這會讓交易記錄檔磁碟機有過多的磁碟 I/O 作業，因此，如果伺服器低於負載或使用者傳送大型郵件，便會使效能嚴重衰退。增加 ESE 記錄緩衝區的數目，雖然會使用更多的虛擬記憶體，但可改善效能。

若要正確設定這個值，請使用下列資訊：

  • 若為 Exchange 2000 Server、Exchange 2000 Server Service Pack 1 (SP1) 或 Exchange 2000 Server Service Pack 2 (SP2)，請將此值設為 9000。

  • 若為 Exchange 2000 Server Service Pack 3 (SP3)，請將此值設為 512。

  • 若為 Exchange Server 2003，會使用預設值 500，您應該將 msExchESEParamLogBuffers 屬性的值變更為 9000。

附註：
如果您先前將記錄檔緩衝區調整為 9000，請務必於套用 Exchange 2000 Server SP3 之後，手動縮小此設定。安裝 Exchange 2000 Server SP3 時，並不會自動執行此項變更。

如果發生記錄停滯，原因可能是緩衝區太少，最高可將此值增加到 9000。您可監視 Database\Log Record Stalls/sec 效能計數器以判定是否發生記錄停滯。請不要使用大於 9000 的值，因為這樣可能會損毀交易記錄檔。

附註：
Log Record Stalls/sec 是每秒無法新增到記錄緩衝區的記錄數 (原因是這些記錄緩衝區已滿)。如果此計數器大部份時間都不是零，則記錄緩衝區大小可能會是瓶頸。

您必須使用如 [Active Directory Service Interfaces (ADSI) 編輯器] 嵌入式管理單元、LDP (ldp.exe) 工具或任何其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端等工具來更正此值。

注意：
使用 ADSI 編輯器、LDP 工具或其他 LDAP 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要更正此錯誤

  1. 啟動 [ADSI 編輯器]。

  2. 連按兩下 [Configuration] 容器，依序展開 CN=Services、 CN=Microsoft Exchange、 CN=<ExchangeOrganizationName>。

  3. 展開 CN=Administrative Groups、展開 CN=<AdministrativeGroupName>，然後展開 CN=Servers。

  4. 依序展開 CN=<ServerName> 及 CN=InformationStore，並在 CN=<StorageGroupName> 上按一下滑鼠右鍵，再按一下 [內容]。

  5. 在 [屬性編輯器] 中按一下 msExchESEParamLogBuffers 屬性，再按一下 [編輯]。

  6. 在 [編輯屬性] 方塊中，若為 Exchange 2000 Server，請將值設為 512，若為 Exchange Server 2003，則設為 9000。

  7. 按一下 [Apply]，再按一下 [OK]。

  8. 關閉 [ADSI 編輯器]，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

若需有關使用 LDP 工具的詳細資訊，請參閱微軟知識庫文件 - 260745＜XADM:Using the LDP Utility to Modify Active Directory Object Attributes＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

若需有關設定 ESE 記錄緩衝區的詳細資訊，請參閱知識庫文件 - 328466＜XADM：ESE Log Buffers That Are Set Too Low Can Cause the Store to Stop Responding＞(http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466)。


已手動變更 ESE 記錄檔大小
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 InformationStore 容器的 msExchESEParamLogFileSize 屬性值。如果 Exchange Server Analyzer 發現 msExchESEParamLogFileSize 屬性的值不等於 5120，就會顯示錯誤。

這個值適用於伺服器上的所有儲存群組。如果這個屬性的值已變更為非預設值 (5120 KB 或 5 MB)，就會發生這個特殊的錯誤。這是唯一支援的值，永遠都不要變更它。

您必須使用如 [Active Directory Service Interfaces (ADSI) 編輯器] 嵌入式管理單元、LDP (ldp.exe) 工具，或任何其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端等公用程式來更正此值。

注意：
使用 ADSI 編輯器、LDP 工具或其他 LDAP 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要更正此錯誤

  1. 開啟 Active Directory 編輯器 (例如：ADSI 編輯器)，並且在 Active Directory 中尋找這台 Exchange Server 電腦的 InformationStore 物件。

    您可以在下列位置找到 msExchESEParamLogFileSize 屬性：

    CN=Configuration, DC=Domain, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Administrative Groups, CN=AdministrativeGroupName, CN=Servers, CN=ServerName, CN=InformationStore

  2. 連按兩下 msExchESEParamLogFileSize 屬性，並將其值設為 5120。

  3. 關閉 Active Directory 編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

若需有關使用 LDP.exe 來編輯 Active Directory 屬性的詳細資訊，請參閱微軟知識庫文件 - 260745＜XADM：Using the LDP Utility to Modify Active Directory Object Attributes＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

若需有關使用 ADSI 編輯器的詳細資訊，請參閱主題＜Adsiedit.msc：ADSI 編輯器＞(位在 Windows Server 說明中)。


ESE 最大開啟表格數目已經硬式編碼
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 Exchange Server 物件的 InformationStore 物件之下的任何儲存群組物件是否有 msExchESEParamMaxOpenTables 屬性。如果 Exchange Server Analyzer 發現 msExchESEParamMaxOpenTables 屬性存在而且已設定，就會顯示非預設的組態訊息。

在預設的情況下，若為 Exchange 2000 Server 及 Exchange Server 2003，此屬性存在但沒有設定任何值。Exchange Server 會快取關於目前未存取的資料夾之資料。在某些情況下，這樣可能會促使虛擬記憶體分散。減輕此問題的一個方法是減少可以同時開啟的資料庫表格數上限。這個上限的實際建議值會依安裝的 Exchange Server 及 Exchange Service Pack 版本而不同。對於 Exchange 2000 Server Service Pack 2 來說，8 個處理器的伺服器的預設設定是每個儲存群組 85000 個表格。在 8 個處理器的伺服器的 Exchange 2000 Server Service Pack 3 中，此預設值會減少為 27600 個。對於 4 個處理器的伺服器來說，該值是 13,800。降低這個值可以減少虛擬記憶體分散的問題。然而，降低這個值也會造成因為有太多開啟的表格而使作業失敗的狀況。會發生錯誤的原因，是因為降低可以同時開啟的表格數上限後，就會更快達到上限。

Exchange Server 2003 使用另一種方法來快取關於目前未存取的資料夾之資料。因此，對於減少虛擬記憶體分散問題來說，降低開啟的表格數上限既不需要也無作用。在 Exchange Server 2003 伺服器上不應設定此屬性。

除非 Microsoft 產品支援服務指示您在這裡輸入值，否則請使用 [Active Directory Service Interfaces (ADSI) 編輯器] 工具來清除在此屬性上設定的值。

注意：
使用 ADSI 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要清除 msExchESEParamMaxOpenTables 屬性值

  1. 開啟一個 Active Directory 編輯程式，如 [ADSI 編輯器]。

  2. 連按兩下 [Configuration] 容器，依序展開 CN=Services、 CN=Microsoft Exchange、 CN=ExchangeOrganizationName。

  3. 展開 CN=Administrative Groups、展開 CN=AdministrativeGroupName，然後展開 CN=Servers。

  4. 依序展開 CN=ExchangeServerName、CN=InformationStore，以滑鼠右鍵按一下 CN=StorageGroupName，再按一下 [Properties]。

  5. 在 [Select a property to view box] 中，按一下 msExchESEParamMaxOpenTables。

  6. 在 [Edit Attribute] 方塊中，按一下 [Clear]，將值變更為 <not set>。

  7. 按 [OK] 兩次。

  8. 關閉 Active Directory 編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

若需有關此屬性的詳細資訊，請參閱微軟知識庫文件 - 325044＜HOW TO：疑難排解 Exchange 2003 及 Exchange 2000 的虛擬記憶體分散＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

若需有關使用 LDP 工具的詳細資訊，請參閱知識庫文件 - 260745＜XADM：Using the LDP Utility to Modify Active Directory Object Attributes＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。


Exchange 資料庫的大小超過 100 GB
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-17

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_DataFile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定每個 Exchange 資訊儲存庫資料庫的 FileSize 機碼值。如果資訊儲存庫的 .edb 檔案及 .stm 檔案的大小合計超過 100 GB，就會顯示警告。

Microsoft 建議資訊儲存庫資料庫的大小不要大於 50 GB。只要適當的維護，執行大於 50 GB 的信箱儲存區也不會發生操作問題；然而，備份及還原時間可能會讓較大的信箱儲存區不符合某些服務等級協定 (SLA)。

如果您使用的信箱儲存區大於 50 GB，請確認您的硬體確實符合服務等級協定，確定大型資料庫的還原在您的 SLA 範圍內。否則，建議您將信箱分散到多個信箱儲存區，如此沒有任何單一的信箱儲存區大小會超過 50 GB。

若要更正此警告

  1. 請考慮將部份信箱從大型資訊儲存庫中移動到這台或其他 Exchange Server 電腦上的新資訊儲存庫。

  2. 如果您最近已將信箱從這個資訊儲存庫移動到其他儲存區，或最近已從這個資訊儲存庫中刪除信箱，則執行離線磁碟重組可以減少檔案的大小。

  3. 請考慮設定信箱或郵件的大小限制，以免資訊儲存庫資料庫無限制地成長。

若需有關 .stm 及 .edb 檔案的詳細資訊，請參閱微軟知識庫文件 - 232323＜Microsoft Exchange 中的原始內容儲存＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323)。

若需有關在 Exchange Server 2003 中移動信箱的詳細資訊，請參閱知識庫文件 - 821829＜在 Exchange Server 2003 中移動信箱＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)。

若需有關在 Exchange 2000 Server 中移動信箱的詳細資訊，請參閱知識庫文件 - 328810＜在伺服器間移動信箱＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810)。

若需有關執行 Exchange Server 資料庫離線磁碟重組的詳細資訊，請參閱知識庫文件 - 328804＜如何磁碟重組 Exchange 資料庫＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804)。

若需有關設定郵件大小限制的詳細資訊，請參閱知識庫文件 - 322679＜設定郵件大小限制＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679)。


Exchange 資料庫檔案正在寫入壓縮資料夾
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 類別，以判定含有 Exchange 資訊儲存庫資料庫檔案之資料夾的 Compressed 機碼值。若這個資料夾的 Compressed 值是設為 True，將會顯示一則錯誤。

在 Exchange 2000 Server 或 Exchange Server 2003 電腦上，資訊儲存庫資料庫會寫入下列預設位置：

<drive> :\Program Files\Exchsrvr\mdbdata

在 Exchange Server 2007 電腦上，資料庫檔案會寫入至下列預設位置：

<drive> :\Program Files\Microsoft\Exchange Server\Mailbox\<Storage Group Name>

Microsoft 不支援將 Exchange 資料檔案儲存在 NTFS 壓縮磁碟區上。當您將 Exchange 資料檔案儲存在壓縮的磁碟區上時，額外的處理將會顯著影響 Exchange 的效能。此外，在資訊儲存庫資料庫到達某個大小時 (大約 4 GB)，會無法裝載或甚至損毀。

Exchange 資料檔案包括下列檔案：

  • .edb 檔案

  • .stm 檔案

  • .log 檔案

  • .dat 檔案

  • .eml 檔案

  • .chk 檔案

由可擴充儲存引擎 (ESE) 管理的檔案，並未設計為要儲存在壓縮的磁碟機上。ESE 依賴磁區獨立性來進行記錄型的復原，而壓縮檔案會破壞磁區獨立性。在主控 ESE 資料庫 (或任何使用預寫記錄的資料庫) 的磁碟區上，都不應該啟動壓縮功能。

在 Exchange 2000 Server Service Pack 3 之前，允許裝載已壓縮的資訊儲存庫資料庫。不過，若是毀損，則會使用 NTFS 壓縮來壓縮所有 Exchange 2000 Server 資訊儲存庫資料庫或資訊儲存庫記錄。

利用 Exchange 2000 Server Service Pack 3，會自動解壓縮 128 MB 以內的已壓縮資訊儲存庫資料庫檔案。當資料庫檔案成長到超過 128 MB 時，資料庫將無法裝載，並且會在應用程式記錄檔中產生錯誤訊息。Exchange 2000 Server Service Pack 3 會禁止裝載大於 128 MB 的已壓縮資料庫。

若要關閉給定資料夾的檔案壓縮功能

  1. 以滑鼠右鍵按一下要關閉檔案壓縮功能的資料夾，然後按一下 [內容]。

  2. 在 [一般] 索引標籤中，按一下 [進階]。

  3. 在 [進階屬性] 對話方塊中，清除 [壓縮內容，節省磁碟空間] 核取方塊，然後按一下 [確定]。

若要在 Exchange 2000 Server 或 Exchange Server 2003 上移動資料庫檔案

  1. 開啟 [Exchange 系統管理員]。

  2. 依序展開 [系統管理群組]、您的系統管理群組、[伺服器]、您的伺服器及儲存群組，然後以滑鼠右鍵按一下 [信箱儲存區]，再按一下 [內容]。

  3. 在 [資料庫] 索引標籤上，在 [Exchange 資料庫] 或 [Exchange 資料流資料庫] 之下，按一下 [瀏覽]，鍵入未啟用壓縮之資料夾的路徑位置，然後按一下 [確定]。

  4. 按一下 [確定] 或 [套用]，套用您做的變更，然後在警告訊息中按一下 [是]。

    按一下 [是] 之後，會開始卸載、移動及重新裝載該儲存區 (資料庫)。順利完成這些程序後，您將會收到下列資訊訊息：

    資料庫檔案已經順利移動

若要移動 Exchange Server 2007 上 Exchange 儲存群組資料庫檔案的位置

  1. 請遵循核心 Exchange Server 2007 文件＜如何移動儲存群組路徑＞(英文) (http://go.microsoft.com/fwlink/?LinkID=80747) 中的指導。

若需有關 .stm 及 .edb 檔案的詳細資訊，請參閱微軟知識庫文件 - 232323＜Microsoft Exchange 中的原始內容儲存＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323)。


將 Exchange 資料庫檔案寫入非 NTFS 的磁碟分割
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Exchange 資料庫檔案路徑的 FSName 機碼值。如果 Exchange Server Analyzer 判定 FSName 機碼的值不等於 NTFS File System，就會顯示一則錯誤。

Microsoft 不支援將 Exchange 資料檔案儲存在非 NTFS 磁碟區上。Exchange 資料檔案包括下列檔案：

  • .edb 檔案

  • .stm 檔案

  • .log 檔案

  • .dat 檔案

  • .chk 檔案

  • .eml 檔案

如果您看到此警告，就必須將資料庫檔案移至 NTFS 磁碟機上的資料夾。另外，如果儲存資料庫檔案的磁碟機已格式化為 FAT 磁碟機，您可以使用 convert.exe 命令列工具將磁碟機轉換為 NTFS。

若要在 Exchange 2000 Server 或 Exchange Server 2003 上移動 Exchange 資料庫檔案

  1. 開啟 [Exchange 系統管理員]。

  2. 依序展開 [系統管理群組]、您的系統管理群組、[伺服器]、您的伺服器及儲存群組，然後以滑鼠右鍵按一下 [信箱儲存區]，再按一下 [內容]。

  3. 在 [資料庫] 索引標籤上，在 [Exchange 資料庫] 或 [Exchange 資料流資料庫] 之下，按一下 [瀏覽]、輸入 NTFS 磁碟區上的資料夾路徑位置，再按一下 [確定]。

  4. 按一下 [確定] 或 [套用] 以套用您的變更，或者若您不想套用變更，則按一下 [取消]。

  5. 如果您按一下 [確定] 或 [套用]，您會收到下列警告訊息：

    附註 您將要執行下列作業

    • 變更 Exchange 資料庫位置

    • 變更 Exchange 資料流資料庫位置

    若要執行要求的作業，必須卸載儲存區，如此會使任何使用者都無法存取此儲存區。

    您要繼續嗎？

    附註：
    警告訊息中僅會列出您選擇的作業。警告訊息中包含 [是] 及 [否] 按鈕。

  6. 若您已準備好要繼續，請按一下 [是]，否則請按一下 [否]。

  7. 如果您已按一下 [是]，會卸載、移動並重新裝載儲存區 (資料庫)。順利完成這些程序後，您將會收到下列資訊訊息：

    資料庫檔案已經順利移動

若要移動 Exchange Server 2007 上 Exchange 儲存群組資料庫檔案的位置

  1. 請遵循核心 Exchange Server 2007 文件＜如何移動儲存群組路徑＞(英文) (http://go.microsoft.com/fwlink/?LinkID=80747) 中的指導

上述程序還有一個替代方法，如果檔案的儲存磁碟是格式化為 FAT 磁碟，您可以使用 convert.exe 命令列工具將磁碟轉換為 NTFS。若需有關使用 convert.exe 命令列工具將 FAT 磁碟分割轉換為 NTFS 磁碟分割的詳細資訊，請參閱微軟知識庫文件 - 214579＜如何使用 Convert.exe 將磁碟分割轉換為 NTFS 檔案系統＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579)。


將 Exchange 資料庫檔案寫入已加密的資料夾
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 類別，以判定包含 Microsoft Exchange Information Store 資料庫檔案之資料夾的 Encrypted 機碼值。如果 Exchange Server Analyzer 發現 Encrypted 的值已設為 True，就會顯示一則錯誤。

在 Exchange 2000 Server 或 Exchange Server 2003 電腦上，會將資料庫檔案寫入下列預設位置：

<drive> :\Program Files\Exchsrvr\mdbdata

在 Exchange Server 2007 電腦上，資料庫檔案會寫入至下列預設位置：

<drive> :\Program Files\Microsoft\Exchange Server\Mailbox\<Storage Group Name>

Microsoft 不支援將 Exchange 資料檔案儲存在「加密檔案系統 (EFS)」加密磁碟區上。當您將 Exchange 資料檔案儲存在加密磁碟區上時，額外的處理會顯著影響 Exchange 的效能。Exchange 資料檔案包括下列檔案：

  • .edb 檔案

  • .stm 檔案

  • .log 檔案

  • .dat 檔案

  • .eml 檔案

  • .chk 檔案

為了協助保護您的 Exchange 資料檔案安全，建議您禁止未經授權者存取 Exchange 電腦，並且使用 S/MIME 郵件格式，將郵件資料加密。

若要解決這項錯誤，您必須關閉要寫入資料庫檔案之資料夾的檔案加密功能，或將資料庫檔案移到未啟用加密功能的資料夾。

若要關閉某個給定資料夾的檔案加密功能

  1. 在要關閉檔案加密的資料夾上按一下滑鼠右鍵，然後按一下 [內容]。

  2. 在 [一般] 索引標籤中，按一下 [進階]。

  3. 在 [進階屬性] 對話方塊中，清除 [加密內容，保護資料] 核取方塊，然後按一下 [確定]。

若要在 Exchange 2000 Server 或 Exchange Server 2003 上移動資料庫檔案

  1. 開啟 [Exchange 系統管理員]。

  2. 依序展開 [系統管理群組]、您的系統管理群組、[伺服器]、您的伺服器及儲存群組，然後以滑鼠右鍵按一下 [信箱儲存區]，再按一下 [內容]。

  3. 在 [資料庫] 索引標籤上，在 [Exchange 資料庫] 或 [Exchange 資料流資料庫] 底下，按一下 [瀏覽]、輸入已啟用加密功能的資料夾之路徑位置，再按一下 [確定]。

  4. 按一下 [確定] 或 [套用]，套用您做的變更，然後在警告訊息中按一下 [是]。

  5. 按一下 [是] 之後，會卸載、移動並重新裝載儲存區 (資料庫) 。順利完成這些程序後，您將會收到下列資訊訊息：

    資料庫檔案已經順利移動

若要移動 Exchange Server 2007 上 Exchange 儲存群組資料庫檔案的位置

  1. 請遵循核心 Exchange Server 2007 文件＜如何移動儲存群組路徑＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80747) 中的指導

若需有關移動資料庫檔案的詳細資訊，請參閱微軟知識庫文件 - 821915＜如何在 Exchange Server 2003 中移動 Exchange 資料庫和記錄檔＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915)。

若需有關 Exchange Server 資料檔及 EFS 的詳細資訊，請參閱知識庫文件 - 834638＜在 Exchange Server 中的加密磁碟區上儲存資料檔的詳細資訊＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638)。

若需有關如何在 Exchange Server 2003 中保護郵件安全的詳細資訊，請參閱《Exchange Server 2003 郵件安全性手冊》(英文) (http://go.microsoft.com/fwlink/?linkid=47574)。


Exchange 資料庫處於不正常關機狀態
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2006-10-30

Microsoft® Exchange Server Analyzer 工具判斷其中一個資料庫並未正確關機。因此，資料庫檔案仍附加到記錄檔。

「不正常關機」狀態不表示資料庫損毀。「不正常關機」狀態僅表示資料庫檔案未與記錄檔資料流正確分離。因此，您必須先復原資料庫檔案，才能重新啟動資料庫。

下次裝載資料庫時，會自動執行此復原。如果自動復原失敗，可以使用 Microsoft Exchange Server Disaster Recovery Analyzer 工具分析失敗的原因。分析後，Exchange Server Disaster Recovery Analyzer 會提供手動復原資料庫檔案的建議。

若要更正此錯誤

  • 將必要的交易記錄檔重新顯示在資料庫，使資料庫進入「正常關機」狀態。若要重新顯示記錄檔，請裝載資料庫。如果此動作失敗，請使用 Exchange Server Disaster Recovery Analyzer 工具以協助找出失敗的原因。

若需有關 Exchange Server Disaster Recovery Analyzer 工具的詳細資訊，請參閱 Microsoft 知識庫文章 922247＜Exchange Server 2003 的 Microsoft Exchange Server Disaster Recovery Analyzer 工具描述＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=922247)。


Exchange 資料庫線上維護排程已設為永不
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-05

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定信箱儲存區與公用儲存區上的 activationSchedule 屬性值。如果 Exchange Server Analyzer 發現 activationSchedule 的值是解析為 [永不]，就會顯示一則警告。

activationSchedule 屬性代表線上資料庫維護排程的設定。Exchange Server 的線上資料庫維護非常重要。在這段期間，系統會執行如下的工作：大型垃圾筒清理 (刪除已超過刪除郵件保留日期的郵件)、公用資料夾到期 (使公用資料夾中晚於特定日期的郵件過期)、已刪除信箱清理，以及線上磁碟重組 (偵測並移除不再使用的資料庫物件，以便挪出資料庫可用空間)。這些處理程序可使 Exchange Server 電腦狀況良好且效能穩定。您應該將線上維護設定為一天至少執行四個小時；若不這麼做的話，系統效能將會逐漸降低。

建議您將線上資料庫維護設定為每天在每個資料庫上 (信箱儲存區或公用資料夾儲存區) 執行四個小時。將備份排程與線上維護間隔錯開。例如，若午夜至上午 2:00 執行備份，則從上午 3:00 至上午 7:00 執行線上維護。

這很重要，因為只要備份工作階段仍在執行中，就無法啟動線上維護。如果發生重疊的情形，備份的順序優先於維護。在此情況下，Exchange 會每隔 15 分鐘查看備份是否已完成。在備份完成之後，就會開始維護。

執行維護時，儲存區會經歷 18 項工作。工作開始後，不論維護計時視窗為何，都會完成工作。但是，如果計時視窗已過期，維護就不會開始新的工作。因此，在某些情況下，並非所有的工作都會在指定的維護間隔內完成。如果維護時間被縮短，則它會在下一個維護週期內從上次停止的位置繼續執行。

若要啟用 Exchange 2000 Server 及 Exchange Server 2003 的線上資料庫維護

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [伺服器]，再展開要使用的伺服器。

  3. 展開要使用的儲存群組。

  4. 在詳細資料窗格內的可用資料儲存區清單中，於想要使用的儲存區上按一下滑鼠右鍵，然後按一下 [內容]。

  5. 在 [儲存區內容] 對話方塊中，按一下 [資料庫] 索引標籤。

  6. 執行下列其中一個動作：

    • 在 [維護] 間隔清單中，選取一個間隔。

    • 按一下 [自訂] 以存取 [排程] 對話方塊，然後建立自訂間隔。

  7. 按一下 [OK]。

若要對 Exchange Server 2007 更正此警告

  1. 開啟 [Exchange 管理主控台]

  2. 展開 [伺服器組態]，再選取要使用的伺服器。

  3. 展開要使用的儲存群組。

  4. 在您要使用的儲存區上按一下滑鼠右鍵，然後按一下 [內容]。

  5. 在 [一般] 索引標籤上，按一下 [維護排程] 下拉式清單，再選取間隔；或按一下 [自訂] 來建立自訂排程。

若需有關線上維護資料庫工作的詳細資訊，請參閱微軟知識庫文件 - 159196＜XADM：受 IS 維護排程控制的作業＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159196)。


Exchange Information Store 服務未設定為以 LocalSystem 的身分執行
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-02-27

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Sercives Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Microsoft Exchange Information Store 服務 (MSExchangeIS) 的 StartName 內容中所指定的啟動帳戶是否使用 LocalSystem 帳戶。如果 Exchange Server Analyzer 發現在 Exchange 2000 Server、Exchange Server 2003 或 Exchange Server 2007 電腦上此內容的值是 LocalSystem (也稱為 SYSTEM 帳戶) 以外的其他帳戶，就會顯示警告。在 Exchange Server 5.5 電腦中並不會觸發這項警告，因為 Microsoft Exchange Information Store 服務必須在使用者帳戶底下執行。

Exchange 2000 Server、Exchange Server 2003 及 Exchange Server 2007 都必須在 LocalSystem 安全性內容下啟動，而不是用特定關聯的使用者帳戶 (與密碼) 來啟動這些服務。這樣可確保變更密碼或刪除使用者帳戶時不會影響 Exchange 的正確運作。當 Exchange 服務以 LocalSystem 的身分存取遠端伺服器時，Microsoft Windows 2000 Server 或 Windows Server™ 2003 會使用電腦帳戶的認證來加以驗證。

電腦帳戶的密碼每隔七天會使用標準變更密碼機制來加以變更。這樣可協助使電腦帳戶比典型的使用者帳戶更為安全，因為典型的使用者帳戶不僅不常變更密碼，且其密碼的隨機程度也比隨機產生的電腦帳戶密碼更低。

某些具有 Exchange Server 5.5 (利用使用者帳戶來執行服務) 使用經驗的系統管理員，會將 Exchange 2000 Server、Exchange Server 2003 及 Exchange Server 2007 服務的啟動帳戶，由使用預設 LocalSystem 帳戶變更為使用者帳戶。

在 Exchange 2000 Server、Exchange Server 2003 及 Exchange Server 2007 上，Microsoft 不支援在 LocalSystem 以外的其他帳戶之下執行 Microsoft Exchange Information Store 服務。

若要更正此錯誤

  1. 按一下 [開始]，依序指向 [程式集] 及 [系統管理工具]，然後按一下 [服務]。

  2. 在服務清單中，在 Microsoft Exchange Information Store 上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 在 [登入] 索引標籤上，於 [登入身分] 底下，按一下 [本機系統帳戶]，然後按一下 [OK]。

  4. 在 Microsoft Exchange Information Store 上按一下滑鼠右鍵，然後按一下 [重新啟動]。

若需有關 Exchange 服務的詳細資訊，請參閱微軟知識庫文件 - 239762＜在 LocalSystem 下執行的 Exchange 服務＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)。


Exchange Information Store 服務未執行
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-05

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Microsoft Exchange Information Store 服務中的 Started 機碼設定的值是設為 True 還是 False。

False 值表示目前這部 Exchange Server 電腦沒有執行 Microsoft Exchange Information Store 服務。True 值表示有執行 Microsoft Exchange Information Store 服務。

Exchange Server Analyzer 也會檢查 root\MicrosoftExchangeV2 命名空間內的 Exchange_Server WMI 類別，以判斷 IsFrontEndServer 機碼的值。值 False 表示 Exchange Server 電腦不是前端伺服器。值 True 表示 Exchange Server 電腦是 Exchange Server 2003 或 Exchange 2000 Server 前端伺服器。

如果評估的兩個機碼值在 Exchange 2000 Server 與 Exchange Server 2003 系統皆為 False，就會顯示警告。

如果 Win32_Service Started 機碼傳回 False 值，且 Exchange Server 電腦正在執行 Exchange Server 2007，就會顯示警告。

如果啟動 Microsoft Exchange Information Store 服務失敗，則表示此 Exchange Server 電腦有更嚴重的問題。在此情況下，您應該檢查事件日誌中，和失敗有關的詳細資料。您也應該要確定您執行的是您的 Exchange Server 版本的最新 Service Pack。

您可以於「Exchange Server 2003 下載」(英文) (http://go.microsoft.com/fwlink/?LinkId=25097) 取得 Exchange Server 2003 的最新 Service Pack。

若需有關造成 Microsoft Exchange Information Store 服務失敗之已知原因的詳細資訊，請參閱下列微軟知識庫文件：

  • 827915＜在 Exchange 2003 中轉換不包含 PR_MESSAGE_CLASS 內容的郵件時，Information Store 服務可能會意外停止＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827915)

  • 830602＜Exchange Server 2003 Information Store 服務停止回應＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=830602)

  • 839115＜升級為 Exchange Server 2003 後，Information Store 服務未啟動＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839115)

  • 330197＜本機傳遞具有空網際網路郵件識別碼的郵件時，Information Store 服務意外停止＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=330197)

  • 831130＜使用 OWA 存取 Exchange Server 2003 電腦上的信箱時，資料夾窗格未出現或 Information Store 服務意外結束＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=831130)

  • 823163＜嘗試啟動資訊儲存庫服務時，出現「安裝程式找不到合格的通用類別目錄伺服器」錯誤訊息＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823163)

  • 822579＜事件識別碼 7024，安裝 Exchange Server 2003 後 Exchange Information Store 服務未啟動＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822579)

  • 833841＜Microsoft Exchange Information Store 服務意外停止回應＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833841)

若需有關使用 Exchange Server 2003 與 Exchange 2000 Server 前端伺服器的詳細資訊，請參閱下列網站：

  • 「使用 Microsoft Exchange 2000 前端伺服器」(英文) (http://go.microsoft.com/fwlink/?linkid=12055)

  • 「Exchange Server 2003 及 Exchange 2000 Server 前端及後端拓撲」(英文) (http://go.microsoft.com/fwlink/?linkid=47567)


此前端伺服器沒有執行 Exchange Information Store 服務
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定為 Microsoft Exchange Information Store 及 Simple Message Transfer Protocol (SMTP) 服務之 Started 機碼所設定的值。值 False 表示服務不在執行中。值 True 表示服務在執行中。

Exchange Server Analyzer 也會檢查位於 root\MicrosoftExchangeV2 命名空間內的 Exchange_Server WMI 類別，以判定 IsFrontEndServer 機碼的值。值 False 表示 Exchange Server 電腦不是前端伺服器。值 True 表示 Exchange Server 電腦是前端伺服器。

如果 Exchange Server Analyzer 發現 SMTP 服務的 Started 值是 true，Microsoft Exchange Information Store 服務的 Started 值是 False，IsFrontEndServer 的值是 True，就會顯示一則警告。

Exchange 2000 Server 及 Exchange Server 2003 會使用前端伺服器，以 Proxy 方式轉送 POP3、IMAP4 及 Microsoft Office Outlook® Web Access 用戶端要求。此外，它們可以作為面向網際網路的 SMTP 伺服器。如果此前端伺服器接受及路由傳送 SMTP 郵件，並支援 IMAP 用戶端 (其使用 SMTP 提交郵件)，或是此前端伺服器正執行病毒掃描 API (VSAPI) 相容軟體，則必須執行 Microsoft Exchange Information Store 服務。否則，前端伺服器將無法處理 SMTP 郵件，或使用 VSAPI 掃描郵件。

除非在前端伺服器上使用 SMTP 或 VSAPI 相容防毒軟體，否則建議的組態是中斷前端伺服器上所有公用資料夾儲存區的連線並刪除這些儲存區，停止 Microsoft Exchange Information Store 服務，然後將 Microsoft Exchange Information Store 服務設為停用。此外，如果未使用 SMTP 服務，就應該停止該服務。在使用 SMTP 或 VSAPI 相容軟體的 Exchange Server 電腦上，Microsoft Exchange Information Store 服務必須在執行中，才能傳遞郵件及服務於郵件用戶端。

若要更正此警告

  1. 開啟 [服務] MMC 嵌入式管理單元。

  2. 以滑鼠右鍵按一下 [Microsoft Exchange Information Store] 服務，再按一下 [內容]。

  3. 在 [Microsoft Exchange Information Store] 內容頁的 [一般] 索引標籤上，確定 [啟動類型] 設定為 [自動]。若不是，將其設為 [自動]，然後按一下 [套用]，再按一下 [確定]。

  4. 以滑鼠右鍵按一下 Microsoft Exchange Information Store 服務，再按一下 [啟動]。

  5. 關閉 [服務] 嵌入式管理單元。

如果啟動 Microsoft Exchange Information Store 服務失敗，則表示此 Exchange Server 電腦有更嚴重的問題。在此情況下，您應該檢查事件日誌中，和失敗有關的詳細資料。您也應該要確定您執行的是您的 Exchange Server 版本的最新 Service Pack。您可以在「Microsoft Exchange Server 首頁」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=21573)，取得 Exchange Server 的最新 Service Pack。

若需有關造成 Microsoft Exchange Information Store 服務失敗的已知原因之詳細資訊，請參閱下列微軟知識庫文件：

  • 827915＜在 Exchange 2003 中轉換不包含 PR_MESSAGE_CLASS 內容的郵件時，Information Store 服務可能會意外停止＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827915)

  • 830602＜Exchange Server 2003 Information Store 服務停止回應＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=830602)

  • 839115＜升級為 Exchange Server 2003 後，Information Store 服務未啟動＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839115)

  • 330197＜本機傳遞具有空網際網路郵件識別碼的郵件時，Information Store 服務意外停止＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=330197)

  • 831130＜使用 OWA 存取 Exchange Server 2003 電腦上的信箱時，資料夾窗格未出現或 Information Store 服務意外結束＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=831130)

  • 823163＜嘗試啟動資訊儲存庫服務時，出現「安裝程式找不到合格的通用類別目錄伺服器」錯誤訊息＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823163)

  • 822579＜事件識別碼 7024，安裝 Exchange Server 2003 後 Exchange Information Store 服務未啟動＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822579)

  • 833841＜Microsoft Exchange Information Store 服務意外停止回應＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833841)

若需有關使用前端伺服器的詳細資訊，請參閱《Exchange Server 2003 及 Exchange 2000 Server 前端及後端拓樸手冊》(英文) (http://go.microsoft.com/fwlink/?linkid=47567)。


已啟用 Exchange 可安裝的檔案系統磁碟機
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2006-02-28

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來判定是否已啟用 Exchange 可安裝的檔案系統 (ExIFS 或 IFS) 磁碟機代號對應：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

如果 Exchange Server Analyzer 發現 DriveLetter 登錄值已設定磁碟機代號 (例如，M)，則會顯示錯誤。

Exchange 2000 Server 導入名稱為 IFS 的功能。IFS 是核心層級驅動程式，可提供 Exchange 資訊儲存庫的部分資料給 Microsoft Windows® 檔案系統。在安裝新的 Exchange 2000 Server 和從 Exchange Server 5.5 升級為 Exchange 2000 Server 時，會自動安裝 IFS，而且會指派磁碟機代號 (依預設是磁碟機 M)，並對應到資訊儲存庫。這是以 \\.\BackOfficeStorage\ 命名空間來執行。

Exchange Server 2003 支援 IFS，但依預設會停用磁碟機代號對應。DriveLetter 登錄值不存在新安裝的 Exchange Server 2003 中，從 Exchange 2000 Server 升級為 Exchange Server 2003 時，也會移除登錄值資料及磁碟機代號對應。

建議使用的最佳作法是不要在 Exchange Server 2003 中啟用 IFS 磁碟機代號對應，然後在 Exchange 2000 Server 中移除磁碟機代號對應。如果防毒或檔案系統型應用程式存取或掃描對應至 IFS 的磁碟機代號，可能會發生已知的問題。因此，建議如果未使用 IFS 功能，請移除磁碟機代號對應。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：

    HKLM\System\CurrentControlSet\Services\EXIFS\Parameters

  3. 在右窗格中，對 DriveLetter 值連按兩下。

  4. 在 [數值資料] 欄位中，刪除列出的代號，讓 [數值資料] 欄位空白。

  5. 關閉登錄編輯程式，重新啟動 Microsoft Exchange System Attendant 服務和 World Wide Web Publishing 服務，使變更生效。當 System Attendant 服務重新啟動後，依存於 System Attendant 服務的所有服務 (包括 Microsoft Exchange MTA Stacks 和 Microsoft Exchange Information Store 服務) 也都會重新啟動。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關在 Exchange 2000 Server 中移除磁碟機 M 對應的詳細資訊，請參閱知識庫文件 - 305145＜如何在 Exchange 2000 Server 中移除磁碟機 M 的 IFS 對應＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=305145)。

若需有關在 Exchange Server 2003 中新增磁碟機 M 對應的詳細資訊，請參閱知識庫文件 - 821836＜Exchange Server 2003 中預設不存在磁碟機 M 到 IFS 的對應＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821836)。


Exchange Server 組態及效能
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2006-09-06

Microsoft® Exchange Server Analyzer 工具判定您的 Exchange 伺服器未設定為最佳效能。

在一般的作業中，Exchange 伺服器會存取不同的檔案。這些檔案的位置可能會造成效能瓶頸。相互依存的檔案群組 (如交易記錄檔磁碟機) 也稱為「資源」。

如果這些資源的散佈造成磁碟瓶頸，Exchange Server Analyzer 可能會顯示警告或錯誤，指出這些資源在 Exchange 伺服器上的位置。若要確定特定的資源與其他負載要求分開，請將資源放在專用的儲存裝置中。下列清單描述每個資源的使用狀況，包含設定資源方法的建議。

  • 交易記錄檔磁碟機 交易記錄檔會維護 .edb 及.stm 檔案的狀態及完整性。這表示這些記錄檔實際上即代表資料。每個儲存群組都會設定有交易記錄檔。因為交易記錄是 Exchange 伺服器資料庫檔案中資料的重要備份元件，因此 Exchange 伺服器必須先確認記錄檔的所有資料，才能完成資料上的多數交易。寫入交易記錄檔磁碟機時若發生任何延遲，可能會嚴重影響到伺服器的效能。因此，請務必分開交易記錄檔磁碟機，這樣磁碟機就可擁有本身的磁碟子系統而不和其他伺服器、應用程式或資源共用。基於最佳的效能的考量，請確定每個交易記錄都有專用的磁碟機。

  • TEMP 磁碟機的位置 首次安裝時，作業系統會將暫存檔位置設定在作業系統所使用的同一個磁碟機上。這表示 TEMP 磁碟機的任何 I/O 會與從該磁碟機執行的程式及分頁檔作業之 I/O 競爭。這樣的 I/O 競爭會影響效能。TEMP 磁碟機是用來傳遞郵件並轉換大型郵件的內容。如果 TEMP 磁碟機成為瓶頸，將會影響到郵件流程及某些用戶端應用程式。若要避免作業系統與 TEMP 磁碟機爭用 I/O，並減少 Exchange 伺服器上發生效能問題的風險，建議您採取下列動作：

    • 將 TEMP 的全域環境設定變更為指向其他磁碟。

    • 將 TEMP 磁碟機移到本身的磁碟上。

  • .edb 及 .stm 檔的位置 Exchange 資料庫包含兩種檔案：

    • .edb 檔 (MAPI 內容) 這個檔案會儲存所有 Store.exe 處理程序使用的 MAPI 郵件及表格，以尋找所有郵件和 .edb 與 .stm 檔兩者以及 MAPI 郵件的總和檢查碼。

    • .stm 檔 (非 MAPI 內容) 這個檔案包含使用郵件原生網際網路內容傳輸的郵件。

    因為存取這兩個檔案類型通常是隨機運作，因此這兩個檔案類型可以包含在同一個磁碟區中。不過，請務必將 .edb 及 .stm 檔放置在與交易記錄相同的磁碟機上。同時，為了避免包含資料庫檔案的磁碟機上發生效能瓶頸，建議您根據每個儲存群組將這些檔案放置在專用的磁碟機上。

  • SMTP 目錄的位置 SMTP 佇列會儲存 SMTP 郵件，直到 Exchange 將郵件寫入資料庫 (信箱儲存區或公用資料夾儲存區) 或將郵件傳送至其他伺服器或連接器為止。一般來說，SMTP 佇列會遭遇隨機且少量的 I/O。如果 SMTP 目錄所在的磁碟機與下列任一項目共用時，Exchange Server Analyzer 會顯示警告：

    • 任何其他 Exchange 資料檔

    • TEMP 或 TMP 目錄

    • 分頁檔

    • 系統磁碟機

    如果 SMTP 目錄未發生磁碟瓶頸，則您可以放心略過此警告。不過，若此磁碟機的流量高，且磁碟機發生效能瓶頸，請考慮將 SMTP 目錄移到其本身的磁碟機上或增加主控 SMTP 目錄之磁碟機的容量。

  • 分頁檔的位置 分頁檔是作為實體記憶體的延伸。更明確地說，分頁檔是系統儲存未使用之分頁或系統稍後會使用之分頁的位置。分頁檔會一直被使用，甚至會由具有足夠可用記憶體的伺服器來使用。因為作業系統嘗試只儲存必要分頁及足夠的可用空間供作業使用，因此會持續使用分頁檔。例如，僅在啟動時使用的列印工具可能會有部份記憶體分頁存在磁碟中，但如果從未使用過該列印工具，分頁記憶體也不會釋回。

    在大量使用實體記憶體的伺服器上，請確定可快速存取所有分頁檔。建議您在專門供分頁檔使用的磁碟機上建立第二個分頁檔。

詳細資訊

  • 若需有關 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需有關疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《疑難排解 Microsoft Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 如需有關設計存放結構的最佳作法，請參閱《多重結構通用的最佳作法》(英文) (http://go.microsoft.com/fwlink/?LinkId=72988)。

  • 如需調整磁碟大小、延遲及 I/O 比率的詳細資訊，請參閱《如何計算磁碟 I/O 需求》(英文) (http://go.microsoft.com/fwlink/?linkid=69747)。


Exchange 儲存區 TCP/IP 通訊埠已經被手動覆寫
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-03-21

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已經手動覆寫 Exchange 儲存區介面的通訊埠值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

如果 Exchange Server Analyzer 發現 TCP/IP Port 存在且已設定，就會顯示非預設的組態訊息。

設定此值最常見的原因就是，讓 MAPI 用戶端能夠連線到在防火牆另一端的 Exchange 伺服器。此案例會開啟防火牆上的多個通訊埠，讓 Microsoft Office Outlook® 2003 或 Outlook 2007 用戶端使用 MAPI 連線到 Exchange 伺服器 (通常是透過網際網路連線)。這是支援的組態。若需設定 MAPI 用戶端連線到防火牆後的 Exchange，請參閱 Microsoft 知識庫文章 270836＜Exchange 2000 及 Exchange 2003 靜態連接埠對應＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)。不過，如果您不使用此案例，就應該移除此登錄機碼。

若要以 MAPI 模式使用 Outlook 透過網際網路連線到 Exchange 伺服器，建議的部署方式是使用 Microsoft Windows Server™ 2003、Exchange Server 2003、Outlook 2003、Exchange Server 2007、Outlook 2007 及 Microsoft Windows® XP Professional 中的 RPC over HTTP 功能。MAPI 模式先前稱為「公司」或「工作群組」模式。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要移除 TCP/IP 通訊埠登錄機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 刪除名為 TCP/IP Port 的登錄值。

  4. 關閉登錄編輯程式，並重新啟動 Microsoft Exchange Information Store 服務。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱 Microsoft 知識庫文章 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若要部署 RPC over HTTPS

  1. 檢閱《Exchange Server 2003 RPC over HTTP 部署案例》(英文) (http://go.microsoft.com/fwlink/?linkid=47577)。

  2. 檢閱知識庫文章 833401＜如何在 Exchange Server 2003 中為單一伺服器設定 RPC over HTTP＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)。

  3. 檢閱知識庫文章 827330＜如何疑難排解 Office Outlook 2003 用戶端的 RPC over HTTP 連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)。

  4. 檢閱 Microsoft Support WebCast＜透過網際網路 (RPC/HTTP) 搭配使用 Microsoft Exchange 與 Microsoft Office Outlook 2003＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)。


Exchange 儲存區 TCP/IP 通訊埠低於 5000
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2006-01-11

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Exchange 儲存區的 TCP/IP Port 設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

如果 Exchange Server Analyzer 發現 TCP/IP Port 設定為低於 5000 (十進位) 的值，就會顯示警告。

如果您必須將 TCP/IP Port 設定設為靜態值，則建議您將其設為大於或等於 5000 的值。如果設定的值低於 5000，可能會使 Exchange 伺服器停止於該通訊埠上進行接聽。Exchange 伺服器將維持在這個狀態中，直到重新啟動服務為止 (要重新啟動的服務視硬式編碼的 Exchange 元件而定)。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要設定 TCP/IP 通訊埠登錄機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 按兩下 TCP/IP Port 機碼，並將 [數值資料] 欄位設為略微超過 5000 (十進位) 的整數。

  4. 關閉登錄編輯程式。

  5. 重新啟動 Microsoft Exchange Information Store 服務，使此變更生效。

在編輯登錄之前，以及想瞭解有關如何編輯登錄的資訊時，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關通訊埠設定的詳細資訊，請參閱知識庫文件 - 270836＜Exchange Server 靜態連接埠對應＞ (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)。


Exchange 交易記錄正在寫入非 NTFS 磁碟分割區
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-02-27

錯誤訊息

簡介

Microsoft Exchange Analyzer 工具會查詢 Win32_Directory Microsoft Windows Management Instrumentation (WMI) 類別，以判定 Exchange 交易記錄檔路徑的 FSName 機碼值。如果 Exchange Server Analyzer 判定 FSName 機碼的值不等於 NTFS，則會顯示錯誤訊息。

Microsoft 不支援將 Exchange 資料檔案儲存在非 NTFS 磁碟區上。Exchange 資料檔案包含下列全部檔案：

  • .edb 檔案

  • .stm 檔案

  • .log 檔案

  • .dat 檔案

  • .eml 檔案

如果發生此錯誤，就必須將交易記錄移至 NTFS 磁碟機上的資料夾。或者，如果用來儲存交易記錄目錄的磁碟機已格式化為 FAT 磁碟機，也可以使用 convert.exe 命令列工具將磁碟機轉換為 NTFS。

若要在 Exchange 2000 Server 或 Exchange Server 2003 上移動交易記錄檔

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [系統管理群組]，展開您的系統管理群組，展開 [伺服器]，在儲存群組上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 在 [一般] 索引標籤中，在 [交易記錄位置] 下面，按一下 [瀏覽]。

  4. 輸入記錄檔的新位置路徑，然後按一下 [確定]。

  5. 按一下 [確定]。

移動 Exchange Server 2007 之 Exchange 儲存群組交易記錄檔的位置

  1. 請遵循核心 Exchange Server 2007 文件＜如何設定或變更儲存群組記錄檔的位置＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80702) 中的指導。

上述程序還有一個替代方法，如果檔案的儲存磁碟是格式化為 FAT 磁碟，您可以使用 convert.exe 命令列工具將磁碟轉換為 NTFS。若需有關使用 convert.exe 命令列工具將 FAT 磁碟分割轉換為 NTFS 磁碟分割的詳細資訊，請參閱微軟知識庫文件 - 214579＜如何使用 Convert.exe 將磁碟分割轉換為 NTFS 檔案系統＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=214579)。


將 Exchange 交易記錄檔寫入壓縮的資料夾
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-05

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 類別，以判定含有 Exchange 資訊儲存庫交易記錄檔之資料夾的 Compressed 機碼值。若這個資料夾的 Compressed 值是設為 True，將會顯示一則錯誤。

當郵件傳遞至 Exchange 時，郵件會先寫入交易記錄檔，才會完成儲存區的確認並加以傳遞。在 Exchange 2000 Server 或 Exchange Server 2003 電腦上，交易記錄檔會寫入下列預設位置：

<drive> :\Program Files\Exchsrvr\mdbdata

在 Exchange Server 2007 電腦上，交易記錄檔會寫入至下列預設位置：

<drive> :\Program Files\Microsoft\Exchange Server\Mailbox\<Storage Group Name>

Microsoft 不支援將 Exchange 資料檔案儲存在 NTFS 壓縮磁碟區上。當您將 Exchange 資料檔案儲存在壓縮的磁碟區上時，額外的處理將會顯著影響 Exchange 的效能。此外，在資訊儲存庫資料庫到達某個大小時 (大約 4 GB)，會無法裝載或甚至損毀。

Exchange 資料檔案包括下列檔案：

  • .edb 檔案

  • .stm 檔案

  • .log 檔案

  • .dat 檔案

  • .eml 檔案

  • .chk 檔案

由「可擴充儲存引擎 (ESE)」管理的檔案，並未設計為要儲存在壓縮的磁碟機上。ESE 依賴磁區獨立性來進行記錄型的復原，而壓縮檔案會破壞磁區獨立性。在主控 ESE 資料庫 (或任何使用預寫記錄的資料庫) 的磁碟區上，都不應該啟動壓縮功能。

在 Exchange 2000 Server Service Pack 3 之前，允許裝載已壓縮的資訊儲存庫資料庫。不過，若是毀損，則會使用 NTFS 壓縮來壓縮所有 Exchange 2000 Server 資訊儲存庫資料庫或資訊儲存庫記錄。

利用 Exchange 2000 Server Service Pack 3，會自動解壓縮 128 MB 以內的已壓縮資訊儲存庫資料庫檔案。當資料庫檔案成長到超過 128 MB 時，資料庫將無法裝載，並且會在應用程式記錄檔中產生錯誤訊息。Exchange 2000 Server Service Pack 3 會禁止裝載大於 128 MB 的已壓縮資料庫。

若要為給定的資料夾關閉壓縮

  1. 在要關閉檔案壓縮的資料夾上按一下滑鼠右鍵，然後按一下 [內容]。

  2. 在 [一般] 索引標籤中，按一下 [進階]。

  3. 在 [進階屬性] 對話方塊中，清除 [壓縮內容，節省磁碟空間] 核取方塊，然後按一下 [確定]。

若要在 Exchange 2000 Server 或 Exchange Server 2003 上移動交易記錄檔

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [系統管理群組]，展開您的系統管理群組，展開 [伺服器]，在儲存群組上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 在 [一般] 標籤中，在 [交易記錄位置] 下面，按一下 [瀏覽]。

  4. 輸入記錄檔的新位置路徑，然後按一下 [確定]。

  5. 按一下 [確定]。

若要移動 Exchange Server 2007 之 Exchange 儲存群組交易記錄檔的位置

  1. 請遵循核心 Exchange Server 2007 文件＜如何設定或變更儲存群組記錄檔的位置＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80702) 中的指導。

若需有關在 Exchange Server 2003 上移動記錄檔的詳細資訊，請參閱微軟知識庫文件 - 821915＜如何在 Exchange Server 2003 中移動 Exchange 資料庫和記錄檔＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915)。

若需有關在 Exchange 2000 Server 上移動記錄檔的詳細資訊，請參閱知識庫文件 - 239944＜如何將交易或系統記錄檔移至其他位置＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239944)。


Exchange 交易記錄檔正在寫入加密的資料夾
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-02-27

Microsoft Exchange Analyzer 工具會查詢 Win32_Directory Microsoft Windows Management Instrumentation (WMI) 類別，以判定包含了資訊儲存庫交易記錄檔之資料夾的 Encrypted 機碼值。如果 Exchange Analyzer 發現 Encrypted 的值設為 True，就會顯示錯誤。

當郵件傳遞至 Exchange 時，郵件會先寫入交易記錄檔，才會完成儲存區的確認並加以傳遞。在 Exchange 2000 Server 或 Exchange Server 2003 電腦上，交易記錄檔會寫入下列預設位置：

<drive> :\Program Files\Exchsrvr\mdbdata

在 Exchange Server 2007 電腦上，交易記錄檔會寫入至下列預設位置：

<drive> :\Program Files\Microsoft\Exchange Server\Mailbox\<Storage Group Name>

Microsoft 不支援將 Exchange 資料檔案儲存在「加密檔案系統 (EFS)」加密磁碟區上。當您將 Exchange 資料檔案儲存在加密磁碟區上時，額外的處理會顯著影響 Exchange 的效能。Exchange 資料檔案包括下列檔案：

  • .edb 檔案

  • .stm 檔案

  • .log 檔案

  • .dat 檔案

  • .eml 檔案

  • .chk 檔案

為了協助保護您的 Exchange 資料檔案安全，建議您禁止未經授權者存取 Exchange 電腦，並且使用 S/MIME 郵件格式，將郵件資料加密。

若要解決這項錯誤，您必須關閉交易記錄檔所寫入資料夾的檔案加密功能，或將交易記錄檔移到未啟用加密功能的資料夾。

若要關閉指定資料夾的檔案加密功能

  1. 在要關閉檔案加密的資料夾上按一下滑鼠右鍵，然後按一下 [內容]。

  2. 在 [一般] 索引標籤中，按一下 [進階]。

  3. 在 [進階屬性] 對話方塊中，清除 [加密內容，保護資料] 核取方塊，然後按一下 [確定]。

若要在 Exchange 2000 Server 或 Exchange Server 2003 上移動交易記錄檔

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [系統管理群組]、展開您的系統管理群組、展開 [伺服器]、在儲存群組上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 在 [一般] 索引標籤中，在 [交易記錄位置] 下面，按一下 [瀏覽]。

  4. 輸入記錄檔的新位置路徑，然後按一下 [確定]。

  5. 按一下 [確定]。

移動 Exchange Server 2007 之 Exchange 儲存群組交易記錄檔的位置

  1. 請遵循核心 Exchange Server 2007 文件＜如何設定或變更儲存群組記錄檔的位置＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80702) 中的指導。

若需有關移動記錄檔的詳細資訊，請參閱微軟知識庫文件 - 821915 ＜如何在 Exchange Server 2003 中移動 Exchange 資料庫和記錄檔＞ (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915)。

若需 Exchange Server 資料檔及 EFS 的相關資訊，請參閱 Microsoft 知識庫文章 834638＜在 Exchange Server 中的加密磁碟區上儲存資料檔的詳細資訊＞(機器翻譯) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638)。

若需有關如何在 Microsoft Exchange Server 2003 保護郵件安全的詳細資訊，請參閱《Exchange Server 2003 郵件安全性手冊》(英文) (http://go.microsoft.com/fwlink/?linkid=47574)。


已啟用擴充的 ESE 效能計數器
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄機碼，以判定 Exchange 伺服器的效能計數器程式庫中是否包含可擴充儲存引擎 (ESE) 擴充計數器。

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ESE\Performance\Show Advanced Counters

如果 Exchange Server Analyzer 發現 Show Advanced Counters 登錄機碼的資料值是 1，就會顯示非預設的組態訊息。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要採取任何動作。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要停用擴充的 ESE 效能計數器

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 刪除登錄中 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ESE\Performance 機碼下方的 Show Advanced Counters 值。

  3. 關閉登錄編輯程式。

  4. 重新啟動 [效能監視器] 套用變更。

在編輯登錄之前，若需有關如何編輯登錄的詳細資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


已啟用擴充的儲存區效能計數器
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄機碼，以判定效能計數器的 Exchange 伺服器程式庫內是否有 Mdbperfx.dll：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\Performance

如果 Exchange Server Analyzer 發現 Library 值包含字串 mdbperfx.dll，Exchange Server Analyzer 將會顯示非預設的組態訊息。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要採取任何動作。

DLL Mdbperf.dll 包含一組預設的儲存區效能計數器。DLL Mdbperfx.dll 不僅包含同一組預設的儲存區效能計數器，也包含一組擴充的儲存區效能計數器。

在預設的情況下，Library 數值資料包含 DLL Mdbperf.dll。在預設的情況下，Library 數值資料不包含 DLL Mdbperfx.dll。下表列出 DLL Mdbperfx.dll 包含的擴充儲存區效能計數器。

計數器 | 目標
FXGetBufferRopsCalled | FXGetBuffer 遠端程序呼叫 (RPC) 作業的總數
FXGetBufferRopsCalledPerSec | 每秒的 FXGetBuffer RPC 作業數
FXGetBufferRopsAcceptedPerSec | 每秒所接受的 FXGetBuffer RPC 作業數
FXGetBufferRopsDenied | 被拒絕的 FXGetBuffer RPC 作業總數
FXGetBufferRopsDeniedPerSec | 每秒所拒絕的 FXGetBuffer RPC 作業數
FXGetBufferCurrentCallerCount | 同時存在的 FXGetBuffer RPC 作業數
FXGetBufferCurrentUsersExecuting | 同時執行的 FXGetBuffer RPC 作業數
Messages Scanned as MIME | 由病毒掃描程式處理為 MIME 的頂層郵件總數
Messages Scanned as MIME/sec | 病毒掃描程式將頂層郵件處理為 MIME 的速率
Messages Scanned as MAPI | 由病毒掃描程式處理為 MAPI 的頂層郵件總數
Messages Scanned as MAPI/sec | 病毒掃描程式將頂層郵件處理為 MAPI 的速率
Bytes Read | 由病毒掃描程式讀取的位元組總數
Bytes Written | 由病毒掃描程式寫入的位元組總數
Queue Length (Low Priority) | 等待病毒掃描的未完成之低優先順序要求的目前數
Threads | 執行緒集區中用於病毒掃描的執行緒目前數。此計數不包括用於背景掃描的執行緒數。
Checks Satisfied by MFT Stamp | 郵件資料夾表格的戳記符合病毒掃描檢查的次數
Checks Satisfied by MFT Stamp/sec | 郵件資料夾表格的戳記符合病毒掃描檢查的速率
Checks Satisfied by Instance Stamp | 執行個體戳記符合病毒掃描檢查的次數
Checks Satisfied by Instance Stamp/sec | 主要執行個體的戳記符合病毒掃描檢查的次數
Checks Satisfied by Master Instance Stamp/sec | 主要執行個體的戳記符合病毒掃描檢查的速率
Checks Not Satisfied | 任何戳記均不符合病毒掃描檢查的次數
Checks Not Satisfied/sec | 任何戳記均不符合病毒掃描檢查的速率
Checks Blocked | 停止處理以等待病毒掃描完成的次數
Checks Blocked/sec | 停止處理以等待病毒掃描完成的速率
Check Timeouts | 作業等待病毒掃描完成的逾時次數
Check Timeouts/sec | 作業等待病毒掃描完成逾時的速率
重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要僅啟用預設的儲存區效能計數器

  1. 啟動登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 於下列登錄機碼尋找 Library 值：

    HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\Performance

  3. 在 [編輯] 功能表上，按一下 [修改]。

  4. 在 [數值資料] 方塊中，將值從 c:\Program Files\Exchsrvr\bin\mdbperfx.dll 變更為 c:\Program Files\exchsrvr\bin\mdbperf.dll。

  5. 按一下 [確定]，然後關閉登錄編輯程式。

  6. 重新啟動 [效能監視器] 套用變更。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關收集 Exchange 儲存區相關效能資料的詳細資訊，請參閱知識庫文件 - 821912＜如何收集診斷資料來協助疑難排解資訊儲存庫問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821912)。


FXGetBuffer Backoff Constant 參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄機碼，以判定是否已建立 FXGetBuffer Backoff Constant 值：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server Analyzer 發現已在 ParametersSystem 登錄機碼下建立 FXGetBuffer Backoff Constant 機碼，則 Exchange Server Analyzer 會顯示非預設的組態訊息。

您可以使用 FXGetBuffer Backoff Constant值來控制可與 Exchange Server 2003 伺服器一次同步處理的 Microsoft Office Outlook® 2003 用戶端數目。設定 FXGetBuffer Backoff Constant 值，可以設定 Outlook 用戶端在再次嘗試同步處理之前所等候的時間。FXGetBuffer Backoff Constant 的預設值為 500 毫秒。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要採取任何動作。不過，如果您想要還原到預設的組態，可以刪除 FXGetBuffer Backoff Constant 登錄機碼。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需如何還原登錄的相關資訊，請檢視 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
還原預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 刪除 FXGetBuffer Backoff Constant 值。

  4. 關閉登錄編輯程式。

Microsoft Exchange Information Store 服務會馬上偵測變更。您不需重新啟動電腦。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關設定登錄機碼以控制可與 Exchange Server 2003 同步處理之 Outlook 用戶端數目的詳細資訊，請參閱知識庫文件 - 818484＜可用來設定並監視 Outlook 用戶端同步處理的登錄值及計數器＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484)。


FXGetBuffer Retry Count 參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄機碼，以判定是否已建立 FXGetBuffer Retry Count 值：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server Analyzer 發現 ParametersSystem 登錄機碼下已建立 FXGetBuffer Retry Count 值，則 Exchange Server Analyzer 會顯示非預設的組態訊息。

您可以使用 FXGetBuffer Retry Count 值來控制可與 Exchange Server 2003 伺服器一次同步處理的 Microsoft Office Outlook® 2003 用戶端數目。設定 FXGetBuffer Retry Count 值，便可以設定 Outlook 用戶端在得到存取權限之前，可以嘗試進行同步處理的次數。預設值是 10。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要採取任何動作。不過，如果您想要還原到預設的組態，可以刪除 FXGetBuffer Retry Count 登錄機碼。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定您瞭解如何在發生問題時還原登錄。若需如何還原登錄的相關資訊，請檢視 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
還原預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 刪除 FXGetBuffer Retry Count 值。

  4. 關閉登錄編輯程式。

Microsoft Exchange Information Store 服務會馬上偵測變更。您不需重新啟動電腦。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關設定登錄機碼以控制可與 Exchange Server 2003 同步處理之 Outlook 用戶端數目的詳細資訊，請參閱知識庫文件 - 818484＜可用來設定並監視 Outlook 用戶端同步處理的登錄值及計數器＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484)。


已經設定 Ignore Bad Oof Rule 登錄參數
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會讀取 Exchange Server 電腦的登錄，以檢查 Ignore Bad Oof Rule 登錄項目是否存在。此登錄值存在於：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

如果 Exchange Server Analyzer 發現 Ignore Bad Oof Rule 登錄項目存在且設定為大於或等於 1 的值，就會顯示非預設的組態訊息。

Ignore Bad Oof Rule 登錄項目是 Exchange 2000 Server、Exchange Server 2003 及 Exchange Server 2007 中的組態設定，這個組態設定是專門設計來與微軟知識庫文件 - 828875＜使用 Exmerge.exe 公用程式之後無法移動 Exchange 信箱＞(http://go.microsoft.com/fwlink/?LinkID=3052&kbid=828875) 中提到的 Hotfix 搭配使用。

當使用 [Microsoft Exchange 信箱合併] 程式 (Exmerge.exe) 將某個信箱儲存區之信箱中的郵件 (及其他項目) 移到不同信箱儲存區的信箱後，再移動第二個信箱可能會失敗。這是因為該信箱上的郵件答錄機 (OOF) 規則損壞，所以會發生此問題。如果需要，可使用此處所述的程序來還原成預設組態。

重要事項：
這篇文章包含如何編輯登錄的相關資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. 在右窗格中，尋找並刪除 Ignore Bad Oof Rule 值。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


已設定 Ignore Zombie Users 登錄參數
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會檢查 Exchange Server 電腦的登錄，以查看 Ignore Zombie users 登錄項目是否已存在。此登錄值存在於：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server Analyzer 發現 Ignore Zombie users 登錄項目已存在且已設為等於或大於 1 的值，則會顯示非預設的組態訊息。

在包含 Exchange Server 5.5 及 Exchange 2000 Server 的混合模式 Exchange Server 組織中，或在先前已混合的環境中，若符合下列條件則可能會發生問題：

  • 您將信箱及公用資料夾的存取控制清單 (ACL) 從 Exchange Server 5.5 升級至 Exchange 2000 Server。

  • ACL 包含未出現在 Active Directory® 目錄服務中的使用者帳戶。

這些未使用的存取控制項目 (ACE) 也稱為「廢止使用者 (zombie user)」。從 2003 年 3 月 Exchange 2000 Server Post-Service Pack 3 彙總套件起，已改變處理廢止使用者的預設行為。您可以使用 Ignore Zombie users 登錄機碼來控制此行為。

Ignore Zombie users 登錄值可用於已安裝 Exchange 2000 Server Service Pack 3 或較新版本的伺服器。您應謹慎使用此登錄項目，只有在您確定廢止使用者不是由於 Active Directory 連接器 (ADC) 複寫問題 (例如延遲) 所造成時，才可使用此登錄項目。此登錄值會導致 Exchange Server 忽略廢止使用者，並且從信箱或公用資料夾的 ACL 中將他們移除。如果使用者為有效狀態，但在升級 ACL 時不在 Active Directory 中，您就必須稍後將該名使用者手動新增至每個 ACL。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右窗格中，尋找並刪除 Ignore Zombie users 值。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關使用 Ignore Zombie Users 登錄機碼的詳細資訊，請參閱下列知識庫文件：

  • 812963＜使用 Ignore Zombie Users 登錄機碼＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812963)

  • 324323＜XADM：在存取控制清單轉換期間，略過 Active Directory 中不存在的使用者帳戶＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324323)


IMAIL 例外狀況處理已經被手動停用
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-17

Microsoft® Exchange Server Analyzer 工具會檢查下列登錄項目，以判定 ExceptionHandling 登錄值的設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

如果 Exchange Server Analyzer 發現 ExceptionHandling 登錄值是設定為 0，就會顯示一則警告。

在 Exchange Server 中，預設會開啟 IMAIL 例外狀況處理，而且無法透過使用者介面關閉它。然而，可以使用登錄來關閉 IMAIL 例外狀況處理。

除非您要主動進行疑難排解，否則 Microsoft 建議將 IMAIL 例外狀況處理保持為啟用。例如，如果您有一些自訂的應用程式會根據錯誤的「安全多用途網際網路郵件延伸 (MIME)」或 MAPI 內容來觸發事件，您可以關閉 IMAIL 例外狀況處理。Microsoft 建議只有在 Microsoft 產品支援服務支援人員的建議及指示下才關閉 IMAIL 例外狀況處理。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent。

  3. 連按兩下 [ExceptionHandling]：

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 ExceptionHandling 登錄值的詳細資訊，請參閱知識庫文件 - 832174＜在 Exchange 2000 Server 中沒有停用 IMAIL 例外狀況處理的選項＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832174)。


Information Store 服務設定為與桌面互動
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Microsoft Exchange Information Store (MSExchangeIS) 服務的 DesktopInteract 內容值。如果 Exchange Server Analyzer 發現 Microsoft Exchange Information Store 服務設定為與桌面互動，就會顯示錯誤。

此組態應該只在 Microsoft 產品支援服務的指導下使用。除非 Microsoft 產品支援服務已指示您以此組態執行 Microsoft Exchange Information Store 服務，否則建議您重新設定 Microsoft Exchange Information Store 服務內容，使它不會與桌面互動。

設定 Exchange Information Store 服務帳戶

  1. 開啟 [服務] MMC 嵌入式管理單元。

  2. 尋找並停止 Microsoft Exchange Information Store 服務。

  3. 連按兩下 Microsoft Exchange Information Store 服務。

  4. 在 [Microsoft Exchange Information Store 內容] 頁面的 [登入] 索引標籤上，選取 [登入身分] 下的 [本機系統帳戶]。

  5. 清除 [允許服務與桌面互動] 核取方塊，然後按一下 [套用]。

  6. 在 [服務狀態] 下，按一下 [啟動]，再按一下 [確定]。

  7. 關閉 [服務] 嵌入式管理單元。

若需有關正確 Exchange 服務組態的詳細資訊，請參閱微軟知識庫文件 - 239762＜在 LocalSystem 下執行的 Exchange 服務＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)。


增加信箱儲存區的資料庫大小上限
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_DataFile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定下列資訊：

  • Exchange 資料庫檔的完整路徑。

  • 信箱儲存區目前的大小。

Exchange Server Analyzer 也會查詢 Win32_OperatingSystem WMI 機碼，以判定其他資訊：

  • 在 Exchange 伺服器上執行的 Windows 作業系統版本。

  • 安裝的 Exchange Server 版本。

  • 安裝的 Exchange Server 版本。

  • Exchange Server 的 Service Pack 等級版本。

最後，Exchange Server Analyzer 也會讀取下列登錄項目，以判定是否已設定 Database Size in Gb 值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

若符合下列狀況，Exchange Server Analyzer 便會顯示錯誤：

  • 伺服器正在執行 Exchange Server 2003。

  • 服務安裝了 Exchange Server 2003 Service Pack 2。

  • Exchange Server 資料庫大小大於 16 GB。

  • 未設定 Database Size in Gb 登錄值。

此錯誤表示識別出的 Exchange 資料庫已接近其大小限制。Exchange Server 2003 Service Pack 2 可將資料庫儲存限制從 16 GB 增加到 75 GB。不過若要使用新限制，您必須手動在 Exchange Server 上新增 Database Size in Gb 登錄值。

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
新增 Database Size in Gb 登錄值來更正這個錯誤

  1. 在執行 Exchange Server 的電腦上，開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. 在 MailboxStoreGUID 上按一下滑鼠右鍵、指向 [新增]，然後按一下 [DWORD 值]。

  4. 針對新值的名稱，輸入 Database Size Limit in Gb。

  5. 連按兩下 Database Size Limit in Gb。在 [數值資料] 中，請鍵入資料庫大小上限的適當值 (GB)。按一下 [確定]。

  6. 在 MailboxStoreGUID 上按一下滑鼠右鍵、指向 [新增]，然後按一下 [DWORD 值]。

  7. 針對新值的名稱，輸入 Database Size Buffer in Percentage。

  8. 連按兩下 Database Size Buffer in Percentage。在 [數值資料] 中，輸入 1 到 100 之間的值，以指定您要在接近資料庫大小上限時記錄事件並警告您的時間。按一下 [確定]。

    附註：
    預設值為 10，表示系統會在資料庫剩下 10% 的空間便會達到其最大大小時記錄警告事件。

  9. 在 MailboxStoreGUID 上按一下滑鼠右鍵、指向 [新增]，然後按一下 [DWORD 值]。

  10. 針對新名稱，輸入 Database Size Check Start Time in Hours From Midnight。

  11. 連按兩下 Database Size Check Start Time in Hours From Midnight。在 [數值資料] 中，輸入 0 到 23 之間的值，以指定您要 Exchange 檢查資料庫大小的時間。按一下 [確定]。

    附註：
    預設值為 5，表示 Exchange Server 會在凌晨五點 (05:00) 檢查資料庫大小。

  12. 關閉登錄編輯程式。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需如何設定及管理 Exchange Server 資料庫大小限制的詳細資訊，請參閱＜資料庫大小限制組態及管理＞(英文) (http://go.microsoft.com/fwlink/?LinkId=57029)。

若需 Exchange Server 2003 Standard Edition 及 Exchange 2000 Server Standard Edition 資料庫大小上限的詳細資訊，請參閱知識庫文件 - 828070＜Exchange Server 信箱儲存區的資料庫達到 16 GB 上限時，無法裝載信箱儲存區＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070)。

若需 Exchange Server 2003 SP2 的詳細資訊，請參閱 Exchange Server 2003 Service Pack 2 網站＜為何要嘗試 Exchange Server 2003 Service Pack 2 呢？＞(英文)(http://go.microsoft.com/fwlink/?LinkId=52073)。


增加公用資料夾儲存區的資料庫大小上限
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_DataFile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定下列資訊：

  • Exchange Server 資料庫檔的完整路徑。

  • 公用資料夾儲存區目前的大小。

Exchange Server Analyzer 也會查詢 Win32_OperatingSystem WMI 機碼，以判定其他資訊：

  • 在 Exchange 伺服器上執行的 Windows 作業系統版本。

  • 安裝的 Exchange Server 版本。

  • 安裝的 Exchange Server 版本。

  • Exchange Server 的 Service Pack 等級版本。

最後，Exchange Server Analyzer 也會讀取下列登錄項目，以判定是否已設定 Database Size in Gb 值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicStoreGUID>

若符合下列狀況，Exchange Server Analyzer 便會顯示錯誤：

  • 伺服器正在執行 Exchange Server 2003。

  • 服務安裝了 Exchange Server 2003 Service Pack 2。

  • Exchange 資料庫大小大於 16 GB。

  • 未設定 Database Size in Gb 登錄值。

此錯誤表示識別出的 Exchange Server 資料庫已接近其大小限制。Exchange Server 2003 Service Pack 2 可將資料庫儲存限制從 16 GB 增加到 75 GB。不過若要使用新限制，您必須手動在 Exchange Server 上新增 Database Size in Gb 登錄值。

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
新增 Database Size in Gb 登錄值來更正這個錯誤

  1. 在執行 Exchange Server 的電腦上，開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicStoreGUID>

  3. 在 PublicStoreGUID 上按一下滑鼠右鍵、指向 [新增]，然後按一下 [DWORD 值]。

  4. 針對新值的名稱，輸入 Database Size Limit in Gb。

  5. 連按兩下 Database Size Limit in Gb。在 [數值資料] 中，輸入適當的資料庫大小上限值 (GB)。按一下 [確定]。

  6. 在 PublicStoreGUID 上按一下滑鼠右鍵、指向 [新增]，然後按一下 [DWORD 值]。

  7. 針對新值的名稱，輸入 Database Size Buffer in Percentage。

  8. 連按兩下 Database Size Buffer in Percentage。在 [數值資料] 中，輸入 1 到 100 之間的值，以指定您要在接近資料庫大小上限時記錄事件並警告您的時間。按一下 [確定]。

    附註：
    預設值為 10，表示系統會在資料庫剩下 10% 的空間便會達到其最大大小時記錄警告事件。

  9. 在 PublicStoreGUID 上按一下滑鼠右鍵、指向 [新增]，然後按一下 [DWORD 值]。

  10. 針對新名稱，輸入 Database Size Check Start Time in Hours From Midnight。

  11. 連按兩下 Database Size Check Start Time in Hours From Midnight。在 [數值資料] 中，輸入 0 到 23 之間的值，以指定您要 Exchange 檢查資料庫大小的時間。按一下 [確定]。

    附註：
    預設值為 5，表示 Exchange Server 會在凌晨五點 (05:00) 檢查資料庫大小。

  12. 關閉登錄編輯程式。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需如何設定及管理 Exchange 資料庫大小限制的詳細資訊，請參閱＜資料庫大小限制組態及管理＞(英文) (http://go.microsoft.com/fwlink/?LinkId=57029)。

若需 Exchange Server 2003 Standard Edition 及 Exchange 2000 Server Standard Edition 資料庫大小上限的詳細資訊，請參閱知識庫文件 - 828070＜Exchange Server 信箱儲存區的資料庫達到 16 GB 上限時，無法裝載信箱儲存區＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070)。

若需 Exchange Server 2003 SP2 的詳細資訊，請參閱 Exchange Server 2003 Service Pack 2 網站＜為何要嘗試 Exchange Server 2003 Service Pack 2 呢？＞(英文)(http://go.microsoft.com/fwlink/?LinkId=52073)。


增加交易記錄檔緩衝區設定
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具已判定您伺服器上的記錄緩衝區數量太低。工具已經偵測到伺服器的 Database (資訊儲存庫執行個體)\Log Record Stalls/sec 值大於 10 Stalls/sec。大於 10 的值表示正在將備份寫入交易記錄中。發生此狀況是因為交易記錄磁碟機的輸送量不足，或記錄緩衝區的設定太低。

記錄寫入 I/O 的執行緒為連續及單一執行緒，所以記錄 I/O 的延遲通常會是系統的瓶頸。記錄 I/O 會先寫入記錄緩衝區，然後緩衝區會被不延遲認可 (Non-lazy Commit) 或容量認可 (Capacity Commit) 清除。不延遲認可表示會立即將記錄緩衝區寫入磁碟中。容量認可表示記錄檔會在緩衝區滿的時候才寫入磁碟。

增加記錄緩衝區大小可減少清除容量的頻率、增加記錄寫入大小，進而減少整體的記錄寫入延遲。減少記錄 I/O 寫入延遲是改進 Exchange 部署之效能及延展性的重要方法。

一般的建議是將 Exchange Server 2003 的緩衝區大小上限增加到 9,000，將 Exchange 2000 Server 的增加到 512。

注意：
使用 ADSI 編輯器、LDP 工具或其他 LDAP 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
若要更正此警告

  1. 啟動 [ADSI 編輯器]。

  2. 連按兩下 [Configuration] 容器，依序展開 [CN=Services]、[CN=Microsoft Exchange] 及 [CN=ExchangeOrganizationName]。

  3. 依序展開 [CN=Administrative Groups]、[CN=AdministrativeGroupName] 及 [CN=Servers]。

  4. 依序展開 [CN=ExchangeServerName] 及 [CN=InformationStore]，在 [CN=Storage Group Name] 上按一下滑鼠右鍵，然後按一下 [內容]。

  5. 在 [選取要檢視的內容] 方塊中，按一下 [msExchESEParamLogBuffers]。

  6. 在 [編輯屬性] 方塊中，針對您 Exchange 版本的 msExchESEParamLogBuffers 輸入適當的值，然後按一下 [設定]。

    附註：
    若為執行 Exchange 2000 Server、Exchange 2000 Server Service Pack 1 (SP1)、Exchange 2000 Server SP2 或 Exchange 2000 SP3 的電腦，請將值設為 512。若為執行 Exchange Server 2003 原始版本或 Exchange Server 2003 SP1 的電腦，則將值設為 9,000。

  7. 按一下 [套用]，然後按一下 [確定]。

詳細資訊

  • 若需有關 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需有關疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《疑難排解 Microsoft Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 若需使用記錄檔緩衝的詳細資訊，請參閱微軟知識庫文件＜ESE 記錄檔緩衝區設得太低會使 Microsoft Exchange Information Store 服務停止回應＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328466)。


已經設定初始記憶體百分比
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-05

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已設定 Initial Memory Percentage 值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server Analyzer 發現 Initial Memory Percentage 的值存在而且是設定為 0 以外的值，就會顯示非預設的組態訊息。

已採用 Initial Memory Percentage 登錄設定的目的，是要作為一種機制，將配置給 Exchange 資訊儲存庫的記憶體初始數量微調至 Exchange 伺服器的實體記憶體總量的 10%。以這個初始配置開始，然後繼續成長，就比較不會經常發生虛擬記憶體分散的問題。不應該任意設定此登錄值，應該在 Microsoft 產品支援服務的建議及指示下才使用此值。

Exchange Server 2003 或更新版本的 Exchange Server 不僅支援 Microsoft Windows® 2000 Advanced Server 及 Windows Server™ 2003 中的特殊啟動參數可幫助減少虛擬記憶體分散，並增加其他變更以幫助防止 Exchange Server 叢集發生虛擬記憶體分散。因此，Exchange Server 2003 或更新版本的 Exchange Server 不再需要 Initial Memory Percentage 登錄值。

只有在執行 Exchange 2000 Server 的電腦上，Initial Memory Percentage 登錄值才有效。Exchange Server 2003 與 Exchange Server 2007 會忽略此值 (若此值存在)，所以此值不會有任何作用。因此，您應該先移除此登錄項目之後再將此 Exchange 伺服器從 Exchange 2000 Server 升級至 Exchange Server 2003。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要移除 Initial Memory Percentage 登錄設定值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右窗格中，刪除 Initial Memory Percentage 值。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。
  • 若需使用此登錄值時的已知問題的詳細資訊，請參閱微軟知識庫文件 - 810883＜Initial Memory Percentage 登錄值沒有作用＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810883)。

  • 在編輯登錄之前，以及想瞭解有關如何編輯登錄的詳細資訊時，請參閱知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)。


已設定 Initial Reserve Size KB 登錄項目
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2006-04-27

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Initial Reserve Size KB 登錄項目是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

如果 Exchange Server Analyzer 發現 Initial Reserve Size KB 登錄值存在且設定成大於 0 的值，就會顯示非預設的組態訊息。

Initial Reserve Size KB 登錄值是用來保留要作為堆集空間的其他記憶體。所指定值的單位是 KB。大部分 Exchange 伺服器的預設值是 655360 KB，相當於 640 MB。您可以降低此值以增加可用記憶體量，並減少虛擬記憶體分散。只有在 Microsoft 產品支援服務之支援專業人員的建議及指示下才可設定此值。此訊息是參考訊息，如果您是在 Microsoft 產品支援服務之支援專業人員的建議下新增此登錄值的話，就不需採取任何更正動作。

如果您確信此項目設定錯誤，可以將它移除，並還原成預設組態。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原成預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

  3. 刪除 Initial Reserve Size KB 值。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關疑難排解虛擬記憶體分散的詳細資訊，請參閱知識庫文件＜HOW TO：Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000＞ (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)。


此 Exchange 資料庫的 legacyExchangeDN 沒有與 Exchange 伺服器相對應
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 Exchange Server 電腦上所有信箱儲存區資料庫的 legacyExchangeDN 屬性值。如果 Exchange Server Analyzer 發現任何一個信箱儲存區上的 legacyExchangeDN 屬性值都不等於包含該信箱儲存區的 Exchange Server 電腦，則會顯示錯誤。

legacyExchangeDN 不相符的原因，可能是因為系統管理員修改 Active Directory，以復原處於嚴重損壞修復狀況的資料庫。若要解決此錯誤，必須使用 Active Directory 編輯器 (如 LDP (ldp.exe) 工具或 Active Directory Service Interfaces (ADSI) 編輯器) 來修改 legacyExchangeDN 屬性。

若要確定 legacyExchangeDN 屬性正確，請檢查此資料庫所在的伺服器的 legacyExchangeDN 屬性，因為身為該伺服器的子物件，此資料庫會有相同的 legacyExchangeDN。

您也應該檢查在此 Exchange 伺服器上未產生此錯誤的其他資料庫，因為它們應該具有相同的 legacyExchangeDN。請注意，有其他數個也具有此屬性的系統物件。在資料庫上的 legacyExchangeDN 屬性不相符的情況下，在其他數個系統物件上的屬性可能也不相符。因此，如果使用 LDP 或 [ADSI 編輯器] 來更正 legacyExchangeDN 值，您也必須在所有其他系統物件上進行更正。

注意：
使用 ADSI 編輯器、LDP 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或 Exchange Server 2007，或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要更正此錯誤

  1. 開啟一個 Active Directory 編輯程式，如 [ADSI 編輯器]。

  2. 依序展開 [組態 [DomainName]]及 [CN=Configuration,DC=DomainName,DC=DomainSuffix]。

  3. 依序展開 CN=Services 及 CN=Microsoft Exchange。

  4. 依序展開 CN=OrganizationName、CN=Administrative Groups 及 CN=AdminGroupName。

  5. 依序展開 CN=Servers、CN=ServerName 及 CN=InformationStore。

  6. 選取 CN=StorageGroupName，並在右窗格中，在其 legacyExchangeDN 屬性不相符的信箱儲存區上按一下滑鼠右鍵，再按一下 [內容]。

  7. 向下捲動到 legacyExchangeDN 並選取它，再按一下 [編輯]。

  8. 在 [值] 欄位中，輸入正確的 legacyExchangeDN。

  9. 關閉 Active Directory 編輯器，並重新啟動 Exchange Server 電腦，讓變更生效。

若需有關使用 ADSI 編輯器建立新 legacyExchangeDN 屬性的詳細資訊，請參閱微軟知識庫文件 - 273863＜如何在原生模式使用 ADSI 編輯器變更 LegacyExchangeDN 屬性＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863)。


此 Exchange 資料庫遺失 legacyExchangeDN 值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 Exchange Server 電腦上所有信箱儲存區資料庫的 legacyExchangeDN 屬性值。如果 Exchange Server Analyzer 在所有信箱儲存區上都找不到 legacyExchangeDN 屬性的值，就會顯示一則錯誤。

legacyExchangeDN 遺失的原因，可能是因為系統管理員在嚴重損壞修復狀況中，因為要復原資料庫而修改了 Active Directory。若要解決此錯誤，必須使用 Active Directory 編輯器 (如 LDP (ldp.exe) 工具或 Active Directory Service Interfaces (ADSI) 編輯器) 來修改 legacyExchangeDN 屬性。

若要確定 legacyExchangeDN 屬性正確，請檢查此資料庫所在的伺服器的 legacyExchangeDN 屬性，因為身為該伺服器的子物件，此資料庫會有相同的 legacyExchangeDN。

您也應該檢查在此 Exchange 伺服器上未產生此錯誤的其他資料庫，因為它們應該具有相同的 legacyExchangeDN。請注意，其他數個系統物件也有此屬性。若資料庫遺失 legacyExchangeDN 屬性，則表示其他系統物件也可能同樣遺失這個屬性。因此，如果要使用 LDP 或 [ADSI 編輯器] 來新增 legacyExchangeDN 值，則也必須在所有其他系統物件上做這樣的處理。

注意：
使用 ADSI 編輯器、LDP 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或 Exchange Server 2007，或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要更正此錯誤

  1. 開啟一個 Active Directory 編輯程式，如 [ADSI 編輯器]。

  2. 依序展開 Configuration [DomainName]，展開 CN=Configuration,DC=DomainName,DC=DomainSuffix。

  3. 依序展開 CN=Services 及 CN=Microsoft Exchange。

  4. 依序展開 CN=OrganizationName、CN=Administrative Groups 及 CN=AdminGroupName。

  5. 依序展開 CN=Servers、CN=ServerName 及 CN=InformationStore。

  6. 選取 CN=StorageGroupName，並在右窗格的信箱儲存區 (遺失 legacyExchangeDN 屬性的信箱儲存區) 上按一下滑鼠右鍵，然後按一下 [Properties]。

  7. 向下捲動以尋找 legacyExchangeDN 並選取它，然後按一下 [Edit]。

  8. 在 [Value] 欄位中，輸入正確的 legacyExchangeDN。

  9. 關閉 Active Directory 編輯器，並重新啟動 Exchange Server 電腦，讓變更生效。

若需有關使用 ADSI 編輯器建立新 legacyExchangeDN 屬性的詳細資訊，請參閱微軟知識庫文件 - 273863＜如何在原生模式使用 ADSI 編輯器變更 LegacyExchangeDN 屬性＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863)。


LimitBodyParts 參數已經被手動設定
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定郵件附件的預設限制是否已變更：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent\LimitBodyParts

如果 Exchange Server Analyzer 發現 LimitBodyParts 登錄項目存在且已設定，便會顯示非預設的組態訊息。

依照設計且基於安全考量，Exchange Server 會將附件數目 (是指內文部分) 限制在 250 個。如果郵件包含超過 250個附件，就會產生 MAPI_E_TOO_BIG 錯誤。此外，Microsoft Exchange Information Store 服務在處理包含大量附件的郵件時，可能會消耗過多的記憶體與 CPU 資源。

不過，有一個設定的機會，系統管理員可以新增 LimitBodyParts 登錄值並加以設定，以便使用大於 250 的值。若沒有設定這個項目，就會使用預設值 250。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要檢視或變更 LimitBodyParts 登錄值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

  3. 檢查並視需要變更 LimitBodyParts 值。此登錄可接受的值為介於 250 與 4294967295 之間的任何整數。

  4. 如果做了變更，請重新啟動 Exchange Server 電腦，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


LimitEmbeddingDepth 參數已經被手動設定
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-30

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來判定是否已變更 Exchange 中的預設 MIME 標頭限制：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

如果 Exchange Server Analyzer 發現已設定 LimitEmbeddingDepth 的值，就會顯示非預設的組態訊息。

Exchange 2000 Server Service Pack 3、Exchange Server 2003 及 Exchange Server 2007 的資訊儲存庫處理程序 (store.exe) 包含更新的功能，可定義如何處理大型或格式不正確的 MIME。新增此功能的目的，是要進一步保護 Exchange Server 免遭惡意及非故意地大型及複雜 MIME 郵件的阻斷服務攻擊。在送交到儲存區的 MIME 郵件中實施的一些限制範例，包括限制收件者人數、限制內嵌郵件的數目，以及限制個別 MIME 標頭的大小。

這些不同 MIME 標頭限制的預設值是在儲存區處理程序中設定。不過，如果已設定登錄機碼來定義其中一項限制，登錄機碼將會覆寫預設的 store.exe 值。當 MIME 郵件超過其中的任何一個限制時，就會傳送一份未傳遞回報 (NDR) 給寄件者。

限制 MIME 的內嵌深度，是指限制可以彼此內嵌的 MIME 郵件數目。例如，假設您收到郵件 (m1) 以及附加的郵件 (m2)。開啟附加的郵件 (m2) 時，您發現還有一封郵件 (m3) 也附加至該郵件 (m2)。因此，原始郵件 (m1) 有內嵌 3 層的郵件。在預設的情況下，Exchange 會允許內嵌深度層級 100 的郵件。當 Exchange 伺服器「拆開」內嵌郵件超過 100 層的郵件，剖析之後再轉換為 MAPI 時，該郵件可能會耗盡此伺服器的所有記憶體。任何電子郵件用戶端或伺服器會產生這樣深度的內嵌郵件的可能性很小。更確切地說，這樣的郵件很有可能是惡意使用者對您的郵件系統發動阻斷服務攻擊的結果。

若要還原為預設組態

  • 這裡並不需要採取任何動作。唯有在安裝微軟知識庫文件 - 833607＜Exchange 2000 Server 或 Exchange Server 2003 中的 Microsoft Exchange Information Store 服務使用 100% CPU 資源＞ (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833607) 的 Hotfix 之後，才會出現此登錄項目。這個 Hotfix 會建立 LimitEmbeddingDepth 登錄項目並將它設定為 10 的值。

若需有關 Exchange Server Service Pack 及 Hotfix 的詳細資訊，請參閱知識庫文件 - 328839＜如何套用 Exchange Service Pack 及 Hotfix＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)。


已手動設定 LimitNestingLevels 參數
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更 Exchange 中的預設多用途網際網路郵件延伸標準 (MIME) 標頭限制：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

如果 Exchange Server Analyzer 發現已對 LimitNestingLevels 設定任一值，則會顯示非預設的組態訊息。

郵件項目內的 MIME bodypart 可以是巢狀的。如果巢狀層次高，轉換處理程序就需要更多的資源才能將整個郵件解碼。具有巢狀層次為 700 之 MIME bodypart 的單一郵件，最多需要 10 分鐘的處理時間。從網際網路收到具有巢狀 MIME bodypart 的郵件時，MIME bodypart 的轉換處理程序可能會減慢這些郵件的傳遞。傳遞郵件時，伺服器將需要大量的系統資源，尤其是記憶體。如果同時收到大量的這類郵件，系統可能會回報虛擬記憶體太低。

限制 MIME 的巢狀層次指的是彼此之內可巢狀 MIME 內容類型的數目 (例如，多個/混合或多個/其他)。大部分電子郵件用戶端 (包括 Microsoft Outlook® 及 Outlook Express) 及電子郵件伺服器所產生的郵件，含有極少的巢狀 MIME 內容類型。例如，在 MIME 郵件中，僅會以單一內容類型來代表一般郵件 (即使具有多重回覆)。產生多重巢狀層次的原因通常是因為要針對特定用途 (例如，工作流程應用程式) 建置 MIME 郵件的自動處理程序，或是為了耗用郵件伺服器資源的特定目的所建構的惡意郵件。

除了依據內容類型強制使用巢狀層次外，Exchange Server 也會使用 LimitNestingLevels 值 (不論是在儲存區處理程序中定義成登錄值還是預設值) 來強制內嵌郵件上的限制。如果未定義 LimitNestingLevels 登錄值，則會強制使用預設值：30 個巢狀層次。將 LimitNestingLevels 值乘以 16，即可定義內嵌郵件限制。因此，內嵌郵件數目的預設值是 480。例如，如果將 LimitNestingLevels 值設為 5，則最多可接受 80 個附件。

若要還原為預設組態

  • 這裡並不需要採取任何動作。Exchange Server Analyzer 會顯示非預設的組態供您參考。

若需有關與 LimitNestingLevels 登錄值相關之 Exchange 2000 Server Hotfix 的詳細資訊，請參閱微軟知識庫文件 - 289775＜XADM：Exchange 2000 Server 由於內嵌郵件過多而經歷記憶體流失＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=289775)。


LimitRecipients 參數已經被手動設定
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來判定是否已變更 Exchange 中的預設 MIME 標頭限制：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

如果 Exchange Server Analyzer 發現已設定 LimitRecipients 的任何值，就會顯示非預設的組態訊息。

Exchange 2000 Server Service Pack 2 (SP2) 與更新版本 Exchange Server 的儲存庫處理程序 (store.exe) 中包含更新功能，可定義如何處理大型或格式不正確的 MIME。新增此功能的目的，是要進一步保護 Exchange，以免因為惡意及特殊的 (非故意傳送的大型及複雜) MIME 郵件，而成為阻斷服務攻擊的目標。在送交到儲存區的 MIME 郵件中實施的一些限制範例，包括限制收件者人數、限制內嵌郵件的數目，以及限制個別 MIME 標頭的大小。在舊版的 Exchange 中，可允許無限制的 MIME 標頭進入 Exchange 儲存區來進行處理，所以在剖析、製作索引及處理 MIME 時，過大或過於複雜的 MIME 郵件幾乎會消耗掉所有資源。

這些不同 MIME 標頭限制的預設值是在儲存區處理程序中設定。不過，如果已設定登錄機碼來定義其中一項限制，登錄機碼將會覆寫預設的 store.exe 值。當 MIME 郵件超過其中的任何一個限制時，就會傳送一份未傳遞回報 (NDR) 給寄件者。

如果已設定 LimitRecipients 登錄機碼，則可能是 Microsoft 產品支援服務的建議，因為這個機碼尚未公布。因此，Microsoft 建議您不要變更這個設定。

儲存區處理程序中的 LimitRecipients 預設值 (若沒有登錄機碼存在) 為每封 MIME 可以有 65,535 位收件者。


無法對執行 Exchange Server 2003 且具有複寫磁碟儲存體的伺服器，進行記錄緩衝區的最佳化
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定下列狀況是否符合：

  • 電腦正在執行 Exchange Server 2003。

  • msExchESEParamLogBuffers 的值介於 0 和 8,960 之間。

Exchange Server Analyzer 會查詢 Win32_PerfRawData_MSExchangeIS_MSExchangeIS Microsoft Windows® Management Instrumentation (WMI) 類別，以判定下列狀況是否符合：

  • VMLargestBlockSize 的值大於 150,000,000。

Exchange Server Analyzer 會判定下列其中一項服務是否正在執行：

  • GeoSpanService

  • SRDFService

如果上述所有狀況均屬實，就會顯示錯誤。

可擴充儲存引擎 (ESE) 會在將交易確認到交易記錄前，先使用記錄緩衝區將交易保存在記憶體中。如果記錄緩衝區不足，您會發現交易記錄檔磁碟機上有過多的磁碟 I/O 作業，這會降低效能。

注意：
使用 ADSI 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
若要更正此錯誤

  1. 在 Active Directory Service Interfaces (ADSI) 編輯器中，按兩下 [組態] 容器、並依序展開 [CN=Services]、[CN=Microsoft Exchange] 及 [CN=ExchangeOrganizationName]。

  2. 依序展開 [CN=Administrative Groups]、[CN=AdministrativeGroupName] 及 [CN=Servers]。

  3. 依序展開 [CN=ExchangeServerName] 及 [CN=InformationStore]，在 [CN=Storage Group Name] 上按一下滑鼠右鍵，然後按一下 [內容]。

  4. 在 [選取內容來檢視] 方塊中，按一下 msExchESEParamLogBuffers。

  5. 在 [編輯屬性] 方塊中，為 msExchESEParamLogBuffers 輸入 9000，然後按一下 [設定]。

  6. 按一下 [套用]，然後按一下 [確定]。

  7. 若要讓變更生效，您必須重新啟動 Microsoft Exchange Information Store 服務。

若需詳細資訊，請參閱微軟知識庫文件 - 328466＜ESE 記錄緩衝區設得太低會造成 Microsoft Exchange Information Store 服務停止回應＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466)。


對於執行 Exchange Server 2003 且具有大量信箱的伺服器來說記錄緩衝區可能不夠
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-03-27

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定下列條件是否符合：

  • 電腦正在執行 Exchange Server 2003。

  • msExchESEParamLogBuffers 的值介於 0 和 8,960 之間。

  • 儲存群組中的信箱數目大於 500。

Exchange Server Analyzer 會查詢 Win32_PerfRawData_MSExchangeIS_MSExchangeIS Microsoft Windows® Management Instrumentation (WMI) 類別，以判定下列條件是否符合：

  • VMLargestBlockSize 的值大於 150000000。

如果所有這些條件都屬實，就會顯示警告。

可延伸儲存引擎 (ESE) 在將交易確認到交易記錄檔之前，會使用記錄緩衝區，先將交易保留在記憶體內。如果記錄緩衝區不足，您會看到交易記錄檔磁碟機上有過多的磁碟 I/O 作業，這會降低效能。

若要更正此警告

  1. 在 Active Directory Service Interfaces (ADSI) 編輯器中，按兩下 [組態] 容器、並依序展開 [CN=Services]、[CN=Microsoft Exchange] 及 [CN=ExchangeOrganizationName]。

  2. 依序展開 [CN=Administrative Groups]、[CN=AdministrativeGroupName] 及 [CN=Servers]。

  3. 依序展開 [CN=ExchangeServerName] 及 [CN=InformationStore]，在 [CN=Storage Group Name] 上按一下滑鼠右鍵，然後按一下 [內容]。

  4. 在 [選取內容來檢視] 方塊中，按一下 msExchESEParamLogBuffers。

  5. 在 [編輯屬性] 方塊中，為 msExchESEParamLogBuffers 輸入 9000，然後按一下 [設定]。

  6. 按一下 [套用]，然後按一下 [確定]。

  7. 若要讓變更生效，您必須重新啟動 Microsoft Exchange Information Store 服務。
注意：
使用 ADSI 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若需詳細資訊，請參閱 Microsoft 知識庫文章 328466＜ESE 記錄緩衝區設得太低會造成 Microsoft Exchange Information Store 服務停止回應＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466)。


記錄檔儲存在網路磁碟機上
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個儲存群組物件的 msExchESEParamLogFilePath 屬性值。此屬性指定儲存群組中的資料庫所使用的交易記錄檔位置。

Exchange Server Analyzer 也會查詢 Active Directory，以判定每個信箱儲存區之 homeMDBBL 屬性列出的項目數。這個屬性的計數代表信箱儲存區上的信箱數目。

如果 Exchange Server Analyzer 在具有超過 50 個信箱的 Exchange Server 上，發現 msExchESEParamLogFilePath 屬性是以 \\ 為開頭，就會顯示錯誤。

此錯誤表示儲存群組的交易記錄檔儲存在網路共用磁碟機上。如果 msExchESEParamLogFilePath 屬性的開頭為 \\，就表示記錄檔路徑使用通用命名慣例 (UNC) 路徑。我們不建議這種作法，因為網路連線中斷將會造成交易記錄檔及資料庫發生錯誤，因而導致資料遺失或資料庫損毀。建議您要立即更正這個問題。

若要更正此錯誤

  • 將交易記錄檔從網路共用磁碟機移至本機磁碟機。若要取得最佳的效能，請將所有交易記錄檔放在個別的磁碟機上。

若需有關如何將交易記錄檔移到其他位置的詳細資訊，請參閱微軟知識庫文件 - 239944＜XADM：如何將交易或系統記錄檔移至其他位置＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=239944)。


記錄產生不一致
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具判定您具有記錄檔案產生不一致。此項錯誤指出已使用不適當的序號將交易記錄檔重新命名。

Exchange 交易記錄檔是根據下列格式來命名：EnnXXXXX.log

  • XXXXX = 5 位的十六進位序號。當產生新的一組交易記錄檔時，順序中的第一個記錄會是 000001，下一個是 00002，依此類推。因為每一個交易記錄會在各自的標頭中記錄自己的序號，所以您可判定記錄的檔案名稱是否有變更。

  • Enn = 記錄字首，這是此儲存群組中每個交易記錄共用的三個字元序號。一般來說，字首會是 E00、E01、E02、E03 或 R00 (若是復原儲存群組)。

目前正在寫入的記錄只會使用記錄字首來命名。這個記錄必須等到關閉並產生新記錄之後，才會取得序號。因此，目前的記錄檔可能會命名為 E00.log。當此記錄檔已滿時，就會重新命名為 E0012345.log。所產生的新 E00.log 會使用內部序號 12346。

若要更正此錯誤

  • 將記錄檔重新命名為適當的序號。
若要檢視內部序號

  • 執行下列命令：

    C:\Program Files\Exchsrvr\Bin\Eseutil.exe /ML [log filename]

    此命令輸出中的 lGeneration 值會列出記錄檔的實際序號。


記錄組不一致
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具判斷部分必要的記錄檔不一致。此錯誤表示記錄檔已被竄改、手動移動、複製、重新命名或刪除。

若要更正此錯誤

  • 若需記錄檔的進階分析，請連絡 Microsoft 技術支援服務 (http://go.microsoft.com/fwlink/?LinkId=31845)。


記錄簽章不一致
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具判定一或多個記錄檔中的記錄簽章與相同資料夾中的其他記錄檔不符。

只有在手動移動、刪除或重新排列記錄檔時才會發生此問題。

附註：
這是一個進階的修復案例，且您可能需要在實作之前連絡 Microsoft 技術支援服務 (http://go.microsoft.com/fwlink/?LinkId=31845)。

每個 Exchange 交易記錄檔會以名為「記錄簽章」的簽章來加以戳記。這個簽章可識別屬於相同記錄系列的個別記錄檔。每個 Exchange 資料庫會將交易記錄系列的記錄簽章記錄到上次附加的資料庫。

Exchange 資料庫也具有名為「DB 簽章」的簽章。首次建立資料庫時就會產生 DB 簽章。如果使用 Eseutil 來進行磁碟重組或修復資料庫，因為修復及磁碟重組處理程序會變更資料庫但不會將這些變更記錄到交易記錄中，因此此簽章會變更。基於記錄的目的，從修復或磁碟重組作業得來的資料庫會是新的或不同的資料庫。

與 DB 簽章不同的是，記錄簽章在記錄檔系列存留期間永遠不會變更。

記錄檔會在記錄建立時，記錄已附加之所有資料庫的 DB 簽章。資料庫則會將最新記錄系列的記錄簽章記錄到已附加的資料庫中。因此，DB 及記錄簽章在比對資料庫與交易記錄檔時相當有用。

您可以將 Exchange 資料庫與一組記錄分離，並將它附加到其他組記錄上。方法是將資料庫移至不同的儲存群組，或移除儲存群組的所有交易記錄並開始新的記錄系列。

如果資料庫處於「不正常關機」狀態，則只有簽章符合資料庫標頭之記錄簽章的交易記錄檔可以順利重新顯示到資料庫。在「不正常關機」狀態中，資料庫仍然會附加到特定的記錄資料流，且只可使用該記錄資料流來執行修復。

如果資料庫處於「正常關機」狀態，您可能可以播放簽章不符合資料庫標頭之目前記錄簽章的交易記錄檔。不過只有在下列狀況下此動作才會成功：

  1. 資料庫在前次記錄檔序列結束後正確關閉。

  2. 然後資料庫附加到新的交易記錄檔序列中，且您可存取交易記錄檔，其中資料庫首次附加到新記錄組。

若要更正此錯誤

  • 您必須知道資料庫的歷程記錄，以及在何種狀況下產生與資料庫相關的交易記錄。

  • 在此情況下，嘗試修復前請一律複製交易記錄及資料庫檔案。錯誤的修復嘗試可能會變更交易記錄或資料庫，以致於無法進行其他修復嘗試。

  • 一次只使用資料庫重新顯示一組交易記錄。將其他交易記錄移出修復資料夾。

  • 如果資料庫處於「不正常關機」狀態，您必須先順利將交易記錄重新顯示到附加的資料庫中，然後使資料庫進入「正常關機」狀態。接著才可以使用資料庫播放第二組記錄檔。

  • 如果資料庫處於「正常關機」狀態，就無法檢查記錄或資料庫，以最終驗證哪組交易記錄要先重新顯示。


某些使用者的登入已受到限制
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取 Exchange Server 電腦上的下列登錄項目，以判定獲准登入 Exchange 資訊儲存庫的使用者清單是否有限制：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Logon Only As

如果 Exchange Server Analyzer 發現 Logon Only As 登錄值存在，就會顯示一則警告。

Logon Only As 登錄值是一個多重字串值 (REG_MULTI_SZ)，其中包含經授權登入 Exchange 資訊儲存庫之帳戶的 legacyExchangeDN 屬性清單。這個登錄值預設不存在，通常只有在進行疑難排解、維護及移動信箱作業時，才會新增。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右窗格中，刪除 Logon Only As 登錄值。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)。

若需有關 Logon Only As 登錄值的詳細資訊，請參閱微軟知識庫文件 - 146764＜限制登入到資訊儲存庫＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=146764)。

若需有關如何在信箱移動作業期間限制登入的詳細資訊，請參閱知識庫文件 - 218920＜XADM：如何在移動信箱期間防止登入＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=218920)。


已設定查閱 SID 快取過期登錄值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄機碼，以判定 Lookup Sid Cache Expire 登錄項目是否存在。

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

若下列條件存在，Exchange Server Analyzer 便會顯示非預設的組態訊息：

  • Lookup Sid Cache Expire 登錄項目已存在。

  • Lookup Sid Cache Expire 登錄項目的值不是 3,600。

在執行 Exchange 2000 Server Service Pack 3 或更新版本的 Exchange 伺服器上，資訊儲存庫會建立包含安全性識別項 (SID) 的快取，並指示 SID 是否為使用者物件或群組物件。第一次觸控公用資料夾時，會建立並擴展此快取。在擴展快取後，系統會首先將所有查詢帳戶 SID 的呼叫，導向資訊儲存庫快取。若 SID 不在資訊儲存庫快取中，則系統會呼叫網域控制站，然後將該 SID 的資訊新增到快取。

依預設值，快取會維持一個小時。若快取超過項目所預設的 8 KB，則系統會移除較舊的快取項目，以讓出空間給新的項目。您可以使用兩個登錄機碼來調整預設快取時間 (Lookup Sid Cache Expire) 以及預設快取大小 (Lookup Sid Cache Size)。建議您不要變更這些預設的設定，除非確定此變更可增加效能。

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. 在右窗格中，尋找並刪除 Lookup Sid Cache Expire 值。如果也已設定 Lookup SID Cache Size 值，亦請將之刪除。

  4. 結束登錄編輯程式，並重新啟動 Microsoft Exchange Information Store 服務，以使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Lookup Sid Cache Expire 登錄值的詳細資訊，請參閱微軟知識庫文件 - 328907＜XADM：存取控制清單升級造成公用資訊夾效能變慢，需要 Exchange 2000 SP2 才能進行修正＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328907)。


已設定查閱 SID 快取大小登錄值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄機碼，以判定 Lookup Sid Cache Size 登錄項目是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

若下列條件存在，Exchange Server Analyzer 便會顯示非預設的組態訊息：

  • Lookup Sid Cache Size 登錄項目已存在。

  • Lookup Sid Cache Size 登錄項目的值不是 1,024。

在執行 Exchange 2000 Server Service Pack 3 或更新版本的 Exchange 伺服器上，資訊儲存庫會建立包含安全性識別項 (SID) 的快取，並指示 SID 是否為使用者物件或群組物件。第一次觸控公用資料夾時，會建立並擴展此快取。在擴展快取後，系統會首先將所有查詢帳戶 SID 的呼叫，導向資訊儲存庫快取。若 SID 不在資訊儲存庫快取中，則系統會呼叫網域控制站，然後將該 SID 的資訊新增到快取。

依預設值，快取會維持一個小時。若快取超過項目所預設的 8 KB，則系統會移除較舊的快取項目，以讓出空間給新的項目。您可以使用兩個登錄機碼來調整預設快取時間 (Lookup Sid Cache Expire) 以及預設快取大小 (Lookup Sid Cache Size)。建議您不要變更這些預設的設定，除非確定此變更可增加效能。

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. 在右窗格中，尋找並刪除 Lookup Sid Cache Size 值。如果也已設定 Lookup SID Cache Expire 值，亦請將之刪除。

  4. 結束登錄編輯程式，並重新啟動 Microsoft Exchange Information Store 服務，以使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Lookup Sid Cache Size 登錄值的詳細資訊，請參閱微軟知識庫文件 - 328907＜XADM：存取控制清單升級造成公用資訊夾效能變慢，需要 Exchange 2000 SP2 才能進行修正＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328907)。


已覆寫低虛擬記憶體錯誤事件
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來判定是否已手動覆寫記錄虛擬記憶體分散事件的閾值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\VM Error Level

如果 Exchange Server Analyzer 發現 VM Error Level 登錄值存在且已設定，就會顯示非預設的組態訊息。

在 32 位元 Microsoft Windows® 系統中，有兩種記憶體：實體記憶體 (安裝在系統中的實際記憶體數量) 和虛擬記憶體位址空間 (虛擬化的 4 GB 記憶體空間)。無論在系統中安裝多少實體記憶體，虛擬位址空間總大小永遠相同：4 GB。雖然並非所有 32 位元應用程式都是這樣， 但就 Exchange Server 而言，虛擬位址空間等於虛擬記憶體；也就是說，這兩個詞彙可以交替使用。

在正常操作期間，Exchange 資訊儲存庫將反覆配置、使用及解除配置虛擬記憶體。當經常配置、使用和解除虛擬記憶體的配置時，會造成虛擬記憶體過於分散。虛擬記憶體分散類似檔案系統分散，經過一段時間之後就會發生。一段時間之後，虛擬記憶體的配置區段就不再連續，因此效能開始降低。以檔案系統而言，您可以執行應用程式來執行檔案系統磁碟重組，在大部份的情形下，這可以在系統連線中且正在存取時完成。在虛擬記憶體分散的情況下，沒有磁碟重組工具可用；若要解決這個問題，您必須停止並啟動 Microsoft Exchange Information Store 服務，或重新啟動系統。

當 Exchange Server 電腦的可用連續虛擬位址空間小於 16 MB 時，應用程式事件日誌會記錄下列錯誤訊息：

來源： | MSExchangeIS
類別： | 效能
識別碼： | 9582
類型： | 錯誤
描述： | 執行您 Exchange 伺服器所需的虛擬記憶體已以此方式分割，但該方式會使正常的作業開始失敗。強烈建議您重新啟動所有的 Exchange 服務來更正這個問題。

VM Error Level 登錄值代表一種組態機會，可讓系統管理員覆寫預設的 16 MB 層級警告並設定替代值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右窗格中，刪除 VM Error Level 的值。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

若需解決 Exchange Server 2003 及 Exchange 2000 Server 的虛擬記憶體分散問題的詳細資訊，請參閱微軟知識庫文件 - 325044＜HOW TO:Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000＞ (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)。


已覆寫低虛擬記憶體警告事件
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已手動覆寫記錄虛擬記憶體分散事件的閾值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\VM Warning Level

如果 Exchange Server Analyzer 發現 VM Warning Level 登錄值存在且已設定，則會顯示非預設的組態訊息。

在 32 位元 Microsoft Windows® 系統中，有兩種記憶體：實體記憶體 (安裝在系統中的實際記憶體數量) 和虛擬記憶體位址空間 (虛擬化的 4 GB 記憶體空間)。無論在系統中安裝多少實體記憶體，虛擬位址空間總大小永遠相同：4 GB。雖然並非所有 32 位元應用程式都是這樣，但對於 Exchange Server 來說，虛擬位址空間等於虛擬記憶體；也就是說，這兩個詞彙可以交替使用。

在正常進行其作業的期間，Exchange 資訊儲存庫會重複配置、使用及解除配置虛擬記憶體。當經常配置、使用和解除虛擬記憶體的配置時，會造成虛擬記憶體過於分散。虛擬記憶體分散類似檔案系統分散，經過一段時間之後就會發生。一段時間之後，虛擬記憶體的配置區段就不再連續，因此效能開始降低。若為檔案系統，則可執行會對檔案執行磁碟重組的應用程式。一般而言，您可以在系統連線且正在存取系統時執行此作業。若為虛擬記憶體分散，則沒有磁碟重組工具；而若要更正問題，則必須先停止 Microsoft Exchange Information Store 服務再啟動它，或是重新啟動系統。

當 Exchange Server 電腦的可用連續虛擬位址空間小於 32 MB 時，依預設會將下列警告訊息記錄到應用程式事件記錄檔：

來源： | MSExchangeIS
類別： | 效能
識別碼： | 9582
類型： | 警告
描述： | 以此方法分散執行 Exchange 伺服器所需的虛擬記憶體，可能會影響效能。強烈建議您重新啟動所有的 Exchange 服務來更正這個問題。

VM Warning Level 登錄值代表組態機會，可讓系統管理員覆寫預設 32 MB 層級警告並設定其他值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右窗格中，刪除 VM Warning Level 的值。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

若需解決 Exchange Server 2003 及 Exchange 2000 Server 的虛擬記憶體分散問題的詳細資訊，請參閱微軟知識庫文件 - 325044＜HOW TO:Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000＞ (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)。


已設定 Mailbox Cache Age Limit
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-15

Microsoft® Exchange Server Analyzer 工具會檢查 Exchange Server 電腦的登錄，以查看 Mailbox Cache Age Limit 登錄項目是否存在。此登錄值存在於：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server Analyzer 發現 Mailbox Cache Age Limit 登錄項目存在且設為等於或大於 1 的值，就會顯示非預設的組態訊息。

Exchange Server 允許設定信箱的大小限制 (配額)。配額設定會儲存在 Active Directory® 目錄服務中，而且 Exchange Server 會定期讀取 Active Directory 中的資訊，以判定是否有更改這些限制。依預設，Exchange Server 會快取此資訊達兩個小時 (120 分鐘)，之後再重新讀取 Active Directory 中的資訊。

Mailbox Cache Age Limit 登錄值 (以分鐘表示) 可用來覆寫預設的時間期間。在達到信箱限制而讓使用者無法存取他們的信箱的情況下，特別有用。如果預設的快取歷時限制生效，則使用者最多會有二個小時無法存取他們的信箱。建議值是 20 分鐘。請不要將此值設定的太低，因為這樣會造成效能問題。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. 在右窗格中，尋找並刪除 Mailbox Cache Age Limit 值。

  4. 結束登錄編輯程式，並重新啟動 Microsoft Exchange Information Store 服務，讓變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Mailbox Cache Age Limit 登錄值的詳細資訊，請參閱知識庫文件 - 327378＜XADM：未在合理時間內強制使用 Exchange 2000 及 Exchange Server 2003 信箱大小限制；需要 Exchange 2000 SP3 才能進行修正＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378)。


已經設定 Mailbox Cache Idle Limit
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Mailbox Cache Idle Limit 是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server Analyzer 發現 Mailbox Cache Idle Limit 登錄項目存在，就會顯示非預設的組態訊息。

Exchange Server 允許設定信箱的大小限制 (配額)。配額設定會儲存在 Active Directory® 目錄服務中，並且 Exchange 伺服器會定期讀取 Active Directory 中的資訊，以判定這些限制是否有變更。Exchange Server 會在快取中保存這項資訊一段時間，之後就會重讀 Active Directory 中的資訊。

Mailbox Cache Age Limit 設定及 Mailbox Cache Idle Limit 設定會控制信箱資訊快取中項目的存留時間。如果郵件在快取中的時間超過 Mailbox Cache Age Limit 設定的時間 (秒)，就會從快取中移除該郵件。如果郵件未使用的時間 (秒) 達到 Mailbox Cache Idle Limit 中設定的時間，就會從快取中移除該郵件。這些設定的預設值分別為 Mailbox Cache Age Limit 設定的 7,200 秒 (120 分鐘)，和 Mailbox Cache Idle Limit 設定的 900 秒 (15 分鐘)。Mailbox Cache Idle Limit 設定的值不應大於 Mailbox Cache Age Limit 設定的值。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem.

  3. 在右窗格中，尋找並刪除 Mailbox Cache Idle Limit 值。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Mailbox Cache Age Limit 登錄值的詳細資訊，請參閱知識庫文件 - 327378＜XADM：未在合理的時間內強制使用 Exchange 2000 信箱大小限制；需要 Exchange 2000 SP3 才能進行修正＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378)。


已經設定 Mailbox Cache Size
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Mailbox Cache Size 是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server Analyzer 發現 Mailbox Cache Size 登錄項目存在，就會顯示非預設的組態訊息。

Mailbox Cache Size 值控制此信箱快取的大小。預設值是 256 MB。Exchange Server 允許設定信箱的大小限制 (配額)。配額設定會儲存在 Active Directory® 目錄服務中，並且 Exchange Server 會定期讀取 Active Directory 中的資訊，以判定這些限制是否有變更。在預設的情況下，Exchange Server 會在快取中保存這項資訊兩小時 (7,200 秒)，之後就會重讀 Active Directory 中的資訊。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右窗格中，找出並刪除 Mailbox Cache Size 值。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Mailbox Cache Age Limit 登錄值的詳細資訊，請參閱知識庫文件 - 327378＜XADM：未在合理的時間內強制使用 Exchange 2000 信箱大小限制；需要 Exchange 2000 SP3 才能進行修正＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378)。


信箱快取大小已設為零
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄機碼，以判定信箱快取大小值的設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server Analyzer 發現信箱快取大小登錄值設為 0，則會顯示錯誤訊息。

Exchange Server 允許設定信箱的大小限制 (配額)。配額設定會儲存在 Active Directory® 目錄服務中，而且 Exchange Server 會定期讀取 Active Directory 中的資訊，以判定是否有更改這些限制。[信箱快取大小] 值控制此信箱快取的大小。預設值是 256 MB。當此值設為 0 時，系統會關閉信箱快取。不建議將此值設為 0，因為這會導致「目錄服務存取 (DSAccess)」元件執行更多的 Active Directory 查閱。此外，將此值設為 0 會導致 Exchange 儲存區失敗，並且在移動信箱時發生錯誤。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右窗格中，找出並刪除 [信箱快取大小] 值。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Mailbox Cache Age Limit 登錄值的詳細資訊，請參閱知識庫文件 - 327378＜XADM：未在合理的時間內強制使用 Exchange 2000 信箱大小限制；需要 Exchange 2000 SP3 才能進行修正＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378)。


受原則控制的信箱儲存區
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2006-06-06

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個信箱儲存區物件的 msExchPolicyList 屬性值。msExchPolicyList 屬性判定是否已經建立 Exchange Server 信箱原則並指派給信箱儲存區。如果 Exchange Server Analyzer 發現已設定 msExchPolicyList 屬性，就會顯示非預設的組態訊息。

在預設的情況下，當建立信箱儲存區時，並未指派信箱原則。不過在大多數情況下，系統管理員會建立信箱原則，然後將它們指派給多個信箱儲存區。這些原則會將系統管理設定 (如儲存限制、檢索更新、維護間隔、對應) 套用到公用儲存區及離線通訊清單。如果已經建立信箱原則並已指派給信箱儲存區，Exchange Server Analyzer 就會顯示一則訊息，說明目前信箱儲存區受到信箱原則控制。不需要任何其他動作。

若要將信箱原則從信箱儲存區移除

  1. 開啟 [Exchange 系統管理員]，並展開主控台樹狀目錄中的 [系統管理群組]。

  2. 展開 [預設系統管理群組]，然後選取 [系統原則]。

  3. 在結果窗格中的 [信箱儲存區] 上按一下滑鼠右鍵，並選取 [自原則移除]。

  4. 在 [Exchange 系統管理員] 視窗中，按一下 [是] 以確認移除信箱儲存區。
附註：
如果在 [Exchange 系統管理員] 的主控台樹狀目錄中看不到 [系統原則] 節點，請將 [Exchange 系統管理員] 設定為顯示 [系統管理群組]。

若需有關信箱儲存區原則的詳細資訊，請參閱下列 Microsoft 知識庫文章：

  • 822938＜HOW TO：在 Exchange Server 2003 中使用系統原則設定信箱儲存限制＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822938)。

  • 256141＜如何在 Exchange 中建立系統原則＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256141)。

若需有關 Exchange Server 資料庫檔案的詳細資訊，請參閱下列 Exchange Server 2003 主題：

  • 《Exchange Server 2003 系統管理手冊》(http://go.microsoft.com/fwlink/?LinkId=47617) 中的＜管理信箱儲存區及公用資料夾儲存區＞(英文)。

  • 《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595) 中的＜瞭解 Exchange Server 2003 儲存區＞(英文)。


信箱儲存區資料庫檔案儲存在網路磁碟上
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每一個信箱儲存區物件的 msExchEDBFile 屬性值。此屬性指定這個信箱儲存區所使用的資料庫檔案位置。

Exchange Server Analyzer 也會查詢 Active Directory，以判定此伺服器上每個信箱儲存區之 homeMDBBL 屬性所列的值數。此屬性的計數代表信箱儲存區中的信箱數目。Exchange Server Analyzer 之後可以計算伺服器管理的信箱總數。

如果 Exchange Server Analyzer 發現在具有 50 個以上信箱的 Exchange 伺服器上，msExchEDBFile 屬性是以 \\ 為開頭，就會顯示一則錯誤。

此錯誤表示信箱儲存區的資料庫檔案是儲存在網路共用中。如果 msExchEDBFile 屬性的開頭為 \\，這表示記錄檔路徑使用通用命名慣例 (UNC) 路徑。我們不建議採用這種作法，因為中斷網路連線將會導致資料庫發生錯誤，因而造成資料遺失或資料庫損毀。建議您要立即更正這個問題。

若要將資料庫檔案移動到新的磁碟機

  1. 在 [Exchange 系統管理員] 中，展開儲存區所在的 Exchange 伺服器物件，展開適當的儲存群組容器，在想要的信箱儲存區物件上按一下滑鼠右鍵，然後按一下 [內容]。

  2. 在 [內容] 對話方塊的 [資料庫] 索引標籤中，指定新的檔案位置。

若需有關 Exchange Server 資料庫檔案的詳細資訊，請參閱下列主題：

  • 《Exchange Server 2003 系統管理手冊》(http://go.microsoft.com/fwlink/?LinkId=47617) 中的＜管理信箱儲存區及公用資料夾儲存區＞(英文)

  • 《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595)中的＜認識 Exchange Server 2003 儲存區＞(英文)

若需有關搭配使用 Exchange Server 與網路磁碟機的詳細資訊，請參閱下列微軟知識庫文件：

  • 328879＜搭配使用 Exchange Server 與儲存連接網路及網路連接儲存裝置＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328879)

  • 839687＜在搭配使用網路連接儲存裝置與 Exchange Server 2003 上，Microsoft 的支援原則＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839687)

  • 317173＜Exchange Server 及網路連接儲存裝置＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317173)

  • 317172＜Exchange Server 5.5 及網路連接儲存裝置＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317172)


已設定信箱儲存區資料庫大小限制
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定信箱儲存區資料庫的 Database Size Limit in Gb 登錄值是否存在且已設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

如果 Exchange Server Analyzer 發現 Database Size Limit in Gb 值存在且已設定，就會顯示非預設的組態訊息。

當 Exchange Server 2003 Service Pack 2 (SP2) 套用於 Exchange Server 2003 Standard Edition 中時，硬式編碼授權驗證資料庫的大小限制會由 16 GB 增加到 75 GB。您可以設定保護性資料庫大小限制，以防止無意的資料庫大小成長。SP2 中的預設大小限制值為 18 GB，且藉由建立 Database Size Limit in Gb 登錄值可覆寫此預設值。

透過建立 Database Size Limit in Gb 登錄值，也可以增加 Exchange Server 2007 Standard Edition 硬式編碼授權資料庫大小限制 (50 GB)。

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. 刪除 Database Size Limit in Gb 值。

  4. 關閉登錄編輯程式。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Exchange Server 2003 SP2 的詳細資訊，請參閱＜Exchange Server 2003 Service Pack 2 網站＞(英文) (http://go.microsoft.com/fwlink/?LinkId=52073)。


信箱儲存區沒有相關聯的預設公用資料夾儲存區
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 msExchPrivateMDB 屬性是否有指派給信箱儲存區的預設公用資料夾儲存區。

msExchPrivateMDB 屬性是信箱儲存區物件的私人資料庫組態。在預設的情況下，msExchHomePublicMDB 屬性與信箱儲存區關聯。msExchPrivateMDB 屬性是主要公用郵件資料庫 (MDB)。

如果 Exchange Server Analyzer 發現 msExchHomePublicMDB 屬性已被刪除或設定不正確，就會顯示非預設的組態訊息。

每個信箱儲存區必須與本機伺服器或其他伺服器上的預設公用資料夾儲存區相關聯。針對每位受特定信箱儲存區支援且啟用信箱的使用者使用者來說，相關聯的公用資料夾儲存區是使用者的主要公用資料夾儲存區。如果可以的話，請使用相同伺服器上的預設公用資料夾儲存區做為信箱儲存區。

附註：
使用相同伺服器上的預設公用資料夾儲存區做為信箱儲存區，可改進使用者存取公用資料夾時的效能，並可簡化公用資料夾存取問題的疑難排解。
將預設公用資料夾儲存區指派給信箱儲存區

  1. 在 [Exchange 系統管理員] 中，在 [信箱儲存區] 所在的儲存群組上按一下滑鼠右鍵。

  2. 在信箱儲存區上按一下滑鼠右鍵，再按一下 [內容]。

  3. 在 [一般] 索引標籤上的 [預設公用資料夾儲存區] 中按一下 [瀏覽]，然後選取要與此信箱儲存區相關聯的公用資料夾儲存區。

    附註：
    如果您正在建立新的信箱儲存區，Exchange Server 會自動選取與公用資料夾樹狀目錄相關聯的預設公用儲存區，以及使用者將會下載以供離線時使用的離線通訊錄。

若需有關管理信箱儲存區及公用資料夾儲存區的詳細資訊，請參閱《Exchange Server 2003 系統管理手冊》(英文) (http://go.microsoft.com/fwlink/?linkid=47617)。


信箱儲存區超過 12 GB
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2006-02-28

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_DataFile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定每個 Exchange 信箱儲存區資料庫檔案 (.edb 檔) 及資料流檔案 (.stm 檔) 的 FileSize 機碼值。Exchange Server Analyzer 也會讀取下列登錄分支，以判定所安裝的 Exchange Server 版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<Exchange Product GUID>

如果 Exchange Server Analyzer 發現在執行 Microsoft Exchange Server 2003 Standard Edition 或 Microsoft Exchange 2000 Server Standard Edition 的電腦上，信箱儲存區資料庫及資料流這一組檔案的合併大小超過 12 GB，則會顯示警告。

位於 Exchange Server 2003 Standard Edition 及 Exchange 2000 Server Standard Edition 的 Exchange 儲存區資料庫不可以超過 16 GB。到達到那個限制之後，信箱儲存區將不再裝載，而且無法存取 Exchange。位於 Exchange Server 2003 Enterprise Edition 及 Exchange 2000 Server Enterprise Edition 的 Exchange 儲存區資料庫則無 16 GB 的限制；它們只受限於可用的硬體，理論上其上限可達 16 TB。

若要更正此警告

  1. 請考慮從大型信箱儲存區將部份信箱移到這部或另一部 Exchange Server 電腦上的新信箱儲存區。

  2. 如果最近有從此資訊儲存庫將信箱移到另一個儲存區，或最近有從此信箱儲存區刪除信箱，那麼執行離線磁碟重組可減少檔案大小。

  3. 請考慮設定信箱及郵件大小限制，防止信箱儲存區無限地成長。
附註：
隨著 Exchange Server 2003 Standard Edition 中 Exchange Server 2003 Service Pack 2 (SP2) 的發行，硬式編碼授權資料庫的大小限制已由 16 GB 增加到 75 GB。管理員可設定保護性資料庫大小限制 (防止無意的資料庫大小成長)。SP2 Standard Edition 的預設值是 18 GB，藉由編輯 [Database Size Limit in Gb] 登錄機碼可覆寫 18 GB 的預設值。
重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要透過 Exchange Server 2003 SP2 設定資料庫的大小限制

  1. 在執行 Exchange Server 的電腦上，啟動 Regedit.exe。

  2. 開啟下列登錄機碼：HKLM\System\CurrentControlSet\Services\MSExchangeIS\伺服器名稱\Private-Mailbox Store GUID

  3. 在 Private Store GUID 上按一下滑鼠右鍵，指向 [新增]，然後按一下 [DWORD 值]。

  4. 針對新值名稱，請鍵入 [Database Size Limit in Gb]。

  5. 連按兩下 [Database Size Limit in Gb]。在 [數值資料] 中，請鍵入資料庫大小上限的適當值 (GB)。若為 Exchange Server 2003 Standard Edition，請鍵入 1 與 75 之間的十進位值 (預設值為 18 GB)。若為 Exchange Server 2003 Enterprise Edition，請鍵入 1 與 8000 之間的十進位值 (預設值為 8000 GB)。請按一下 [確定]。

  6. 在 Private Store GUID 上按一下滑鼠右鍵，指向 [新增]，然後按一下 [DWORD 值]。

  7. 針對新值名稱，請鍵入 [Database Size Buffer in Percentage]。

  8. 連按兩下 [Database Size Buffer in Percentage]。在 [數值資料] 中，鍵入 1 到 100 之間的十進位值，以指定您要在接近資料庫大小上限時記錄事件並警告您的時間。若將預設值設為 10，則系統會在資料庫空間尚餘 10% 時記錄警告事件。按一下 [確定]。

  9. 在 Private Store GUID 上按一下滑鼠右鍵，指向 [新增]，然後按一下 [DWORD 值]。

  10. 針對新名稱，請鍵入 [Database Size Check Start Time in Hours From Midnight]。

  11. 連按兩下 [Database Size Check Start Time in Hours From Midnight]。在 [數值資料] 中，請鍵入介於 0 到 23 之間的值，以指定您要 Exchange 檢查資料庫大小的時間。若將預設值設為 5，則 Exchange Server 會在凌晨五點 (5:00 AM) 檢查資料庫大小。按一下 [確定]。

  12. 關閉登錄編輯程式。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 .stm 及 .edb 檔案的詳細資訊，請參閱微軟知識庫文件 - 232323＜Microsoft Exchange 中的原始內容儲存＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323)。

若需有關在 Exchange Server 2003 中移動信箱的詳細資訊，請參閱知識庫文件 - 821829＜在 Exchange Server 2003 中移動信箱＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)。

若需有關在 Exchange 2000 Server 中移動信箱的詳細資訊，請參閱知識庫文件 - 328810＜在伺服器間移動信箱＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810)。

若需有關執行 Exchange Server 資料庫離線磁碟重組的詳細資訊，請參閱知識庫文件 - 328804＜如何磁碟重組 Exchange 資料庫＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804)。

若需有關設定郵件大小限制的詳細資訊，請參閱知識庫文件 - 322679＜設定郵件大小限制＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679)。

若需有關達到資料庫大小上限之 Exchange Server 2003 Standard Edition 或 Microsoft Exchange 2000 Server Standard Edition 的詳細資訊，請參閱知識庫文件 - 828070＜Exchange Server 信箱儲存區的資料庫達到 16 GB 上限時，無法裝載信箱儲存區＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070)。

若需有關 Exchange Server 2003 SP2 的詳細資訊，請參閱＜Exchange Server 2003 Service Pack 2 網站＞(英文) (http://go.microsoft.com/fwlink/?LinkId=52073)。


信箱儲存區超過 15 GB
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2006-02-28

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_DataFile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定每個 Exchange 信箱儲存區資料庫檔案 (.edb 檔) 及資料流檔案 (.stm 檔) 的 FileSize 機碼值。Exchange Server Analyzer 也會讀取下列登錄分支，以判定所安裝的 Exchange Server 版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<Exchange Product GUID>

如果 Exchange Server Analyzer 在執行 Microsoft Exchange Server 2003 Standard Edition 或 Microsoft Exchange 2000 Server Standard Edition 的電腦上，發現信箱儲存區資料庫及資料流檔案這一對的合併大小超過 15 GB，則會顯示錯誤訊息。

位於 Exchange Server 2003 Standard Edition 及 Exchange 2000 Server Standard Edition 的 Exchange 儲存區資料庫不可以超過 16 GB。到達到那個限制之後，信箱儲存區將不再裝載，而且無法存取 Exchange。位於 Exchange Server 2003 Enterprise Edition 及 Exchange 2000 Server Enterprise Edition 的 Exchange 儲存區資料庫則無 16 GB 的限制；它們只受限於可用的硬體，理論上其上限可達 16 TB。

若要更正此錯誤

  1. 請考慮從大型信箱儲存區將部份信箱移到這部或另一部 Exchange Server 電腦上的新信箱儲存區。

  2. 如果最近有從此資訊儲存庫將信箱移到另一個儲存區，或最近有從此信箱儲存區刪除信箱，那麼執行離線磁碟重組可減少檔案大小。

  3. 請考慮設定信箱及郵件大小限制，防止信箱儲存區無限地成長。
附註：
隨著 Exchange Server 2003 Standard Edition 中 Exchange Server 2003 Service Pack 2 (SP2) 的發行，硬式編碼授權資料庫的大小限制已由 16 GB 增加到 75 GB。管理員可設定保護性資料庫大小限制 (防止無意的資料庫大小成長)。SP2 Standard Edition 的預設值是 18 GB，藉由編輯 [Database Size Limit in GB] 登錄機碼可覆寫 18 GB 的預設值。
重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要透過 Exchange Server 2003 SP2 設定資料庫的大小限制

  1. 在執行 Exchange Server 的電腦上，啟動 Regedit.exe。

  2. 開啟下列登錄機碼：HKLM\System\CurrentControlSet\Services\MSExchangeIS\伺服器名稱\Private-Mailbox Store GUID

  3. 在 Private Store GUID 上按一下滑鼠右鍵，指向 [新增]，然後按一下 [DWORD 值]。

  4. 針對新值名稱，請鍵入 [Database Size Limit in Gb]。

  5. 連按兩下 [Database Size Limit in Gb]。在 [數值資料] 中，請鍵入資料庫大小上限的適當值 (GB)。若為 Exchange Server 2003 Standard Edition，請鍵入 1 與 75 之間的十進位值 (預設值為 18 GB)。若為 Exchange Server 2003 Enterprise Edition，請鍵入 1 與 8000 之間的十進位值 (預設值為 8000 GB)。請按一下 [確定]。

  6. 在 Private Store GUID 上按一下滑鼠右鍵，指向 [新增]，然後按一下 [DWORD 值]。

  7. 針對新值名稱，請鍵入 [Database Size Buffer in Percentage]。

  8. 連按兩下 [Database Size Buffer in Percentage]。在 [數值資料] 中，鍵入 1 到 100 之間的十進位值，以指定您要在接近資料庫大小上限時記錄事件並警告您的時間。若將預設值設為 10，則系統會在資料庫空間尚餘 10% 時記錄警告事件。按一下 [確定]。

  9. 在 Private Store GUID 上按一下滑鼠右鍵，指向 [新增]，然後按一下 [DWORD 值]。

  10. 針對新名稱，請鍵入 [Database Size Check Start Time in Hours From Midnight]。

  11. 連按兩下 [Database Size Check Start Time in Hours From Midnight]。在 [數值資料] 中，請鍵入介於 0 到 23 之間的值，以指定您要 Exchange 檢查資料庫大小的時間。若將預設值設為 5，則 Exchange Server 會在凌晨五點 (5:00 AM) 檢查資料庫大小。按一下 [確定]。

  12. 關閉登錄編輯程式。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 .stm 及 .edb 檔案的詳細資訊，請參閱微軟知識庫文件 - 232323＜Microsoft Exchange 中的原始內容儲存＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323)。

若需有關在 Exchange Server 2003 中移動信箱的詳細資訊，請參閱知識庫文件 - 821829＜在 Exchange Server 2003 中移動信箱＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)。

若需有關在 Exchange 2000 Server 中移動信箱的詳細資訊，請參閱知識庫文件 - 328810＜在伺服器間移動信箱＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810)。

若需有關執行 Exchange Server 資料庫離線磁碟重組的詳細資訊，請參閱知識庫文件 - 328804＜如何磁碟重組 Exchange 資料庫＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804)。

若需有關設定郵件大小限制的詳細資訊，請參閱知識庫文件 - 322679＜設定郵件大小限制＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679)。

若需有關到達資料庫大小上限之 Exchange Server 2003 Standard Edition 及 Exchange 2000 Server Standard Edition 的詳細資訊，請參閱知識庫文件 - 828070＜Exchange Server 信箱儲存區的資料庫達到 16 GB 上限時，無法裝載信箱儲存區＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070)。

若需有關 Exchange Server 2003 SP2 的詳細資訊，請參閱＜Exchange Server 2003 Service Pack 2 網站＞(英文) (http://go.microsoft.com/fwlink/?LinkId=52073)。


信箱儲存區已超過 8 天未進行完整備份
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會查詢每個信箱儲存區，以判定前次進行完整備份的日期與時間。Exchange Server Analyzer 還會查詢 Active Directory® 目錄服務，以判定每個信箱儲存區中具有信箱的使用者數目。若下列條件皆存在，Exchange Server Analyzer 便會顯示警告：

  • 信箱儲存區在前次進行完整備份後已經過八天以上。

  • 信箱儲存區中的信箱超過十個。

信箱儲存區是 Microsoft Exchange Server 2003 及 Exchange Server 2007 中儲存信箱的資料庫。信箱儲存區由 RTF (.edb) 檔案及資料流原生網際網路內容 (.stm) 檔案所組成。雖然有 .edb 與 .stm 兩種檔案，但它們屬於單一資料庫裡的兩個部分，而不是兩個不同的資料庫。

Exchange Server 資料庫中的信箱儲存區與公用資料夾儲存區資料，以及交易記錄檔，是 Exchange Server 組織中最需要備份的重要資料。您可以使用 Exchange Server 資料庫備份，將毀損的信箱還原到執行 Exchange Server 且在運作中的伺服器上。您也可以使用 Exchange Server 資料庫備份，將 Exchange Server 資料庫還原到另一部伺服器上。

最好的作法是：您每天執行資料庫檔案與交易記錄的完整備份。完成儲存群組的完整備份後，會從伺服器中刪除 Exchange Server 資料庫上的已確認交易記錄檔。完整備份在進行復原時具有速度上的優勢，因為您只需要一個磁帶組便可還原所有資料。

附註：
最佳的作法是將交易記錄檔保留在與資料庫檔案不同的專用磁碟上。這樣可在資料庫磁碟損毀時提供容錯，而且在某些情況下，還可改善資料庫效能。
重要事項：
嘗試備份或還原檔案與資料夾時，您必須具備指定給欲登入之使用者帳戶的必要權限或權利。若要建立 Exchange Server 備份，您必須具備網域層級的備份操作員權限。若要建立 Microsoft Windows Server™ 2003 作業系統的備份，您至少必須具備本機備份操作員權限。

為 Exchange Server 資料選擇備份策略時，應考慮儲存區的大小、備份軟硬體的速度、硬體容量，以及時間需求。

若需有關備份策略及嚴重損壞修復操作的詳細資訊，請參閱：

  • 《Exchange Server 2003 嚴重損壞修復操作手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47570)。

  • ＜資料庫備份及還原＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80766)。


信箱儲存區已超過 60 天未進行完整備份
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會查詢每個信箱儲存區，以判定前次進行完整備份的日期與時間。Exchange Server Analyzer 還會查詢 Active Directory® 目錄服務，以判定每個信箱儲存區中具有信箱的使用者數目。若同時存在下列兩種情況，Exchange Server Analyzer 便會顯示錯誤：

  • 信箱儲存區在前次進行完整備份後已經過 60 天以上。

  • 信箱儲存區中的信箱超過 10 個。

信箱儲存區是 Microsoft Exchange Server 2003 及 Microsoft Exchange Server 2007 中儲存信箱的資料庫。信箱儲存區由 RTF (.edb) 檔案及資料流原生網際網路內容 (.stm) 檔案所組成。儘管存在兩種檔案 (即 .edb 與 .stm 檔案)，但是它們代表單一資料庫的兩半部，而不是兩個不同的資料庫。

Exchange Server 資料庫中的信箱儲存區與公用資料夾儲存區資料以及交易記錄檔是最重要的資料，應備份在 Exchange Server 組織中。您可以使用 Exchange Server 資料庫備份，將毀損的信箱還原至正在執行 Exchange Server 的作用中伺服器。您還可以使用 Exchange 伺服器資料庫備份，將 Exchange 伺服器資料庫還原至其他伺服器。

最佳作法是，您應每天對資料庫檔案及交易記錄執行完整備份。完成對儲存群組的完整備份後，會將 Exchange 伺服器資料庫上已確認的交易記錄檔從伺服器上刪除。完整備份可加快還原方案的速度，因為您僅需一個磁帶便可還原所有資料。

附註：
最佳的作法是將交易記錄檔保留在與資料庫檔案不同的專用磁碟上。這樣可在資料庫磁碟損毀時提供容錯，而且在某些情況下，還可改善資料庫效能。
重要事項：
當您嘗試備份或還原檔案與資料夾時，必須將所需的權限指定給您所登入的使用者帳戶。 若要建立 Exchange 伺服器備份，您必須具有網域層級備份操作員權限。若要建立 Microsoft Windows Server™ 2003 作業系統備份，您必須至少具有本機備份操作員權限。

為 Exchange Server 資料選擇的備份策略將會視儲存區的大小、備份軟體與硬體的速度、硬體容量及時間需求而定。

若需有關備份策略及嚴重損壞修復操作的詳細資訊，請參閱：

  • 《Exchange Server 2003 嚴重損壞修復操作手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47570)。

  • ＜資料庫備份及還原＞(英文) (http://go.microsoft.com/fwlink/?LinkID=80766)。


信箱儲存區線上維護排程重疊
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定儲存群組中的所有信箱儲存區是否都有相同的維護排程。如果儲存群組容器 (類別 msExchStorageGroup) 具有兩個或更多信箱儲存區物件 (類別 msExchPrivMDB)，則 Exchange Server Analyzer 會檢查每一個信箱儲存區物件的 activationSchedule 屬性。如果 Exchange Server Analyzer 發現每一個信箱儲存區的這些值 (儲存為 8 位元字元組合) 相同或是重疊，就會顯示警告。

在預設的情況下，信箱儲存區維護處理程序是在凌晨 1:00 到 5:00 執行。由於維護處理程序需要伺服器資源，因此建議您修改維護排程，使信箱儲存區的排程至少相差 15 分鐘。

若要對 Exchange 2000 Server 及 Exchange Server 2003 更正此警告

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [伺服器]，再展開要使用的伺服器。

  3. 展開要使用的儲存群組。

  4. 在您要使用的儲存區上按一下滑鼠右鍵，然後按一下 [內容]。

  5. 在 [資料庫] 索引標籤上，按一下 [維護間隔]，再按一下新的間隔，或按一下 [自訂] 來建立自訂排程。

若要對 Exchange Server 2007 更正此警告

  1. 開啟 [Exchange 管理主控台]

  2. 展開 [伺服器組態]，再選取要使用的伺服器。

  3. 展開要使用的儲存群組。

  4. 在您要使用的儲存區上按一下滑鼠右鍵，然後按一下 [內容]。

  5. 在 [一般] 索引標籤上，按一下 [維護排程] 下拉式清單，再選取新的間隔；或按一下 [自訂] 來建立自訂排程。

若需有關 Exchange Server 2003 儲存區維護的詳細資訊，請參閱《Exchange Server 2003 系統管理手冊》(http://go.microsoft.com/fwlink/?LinkId=47617) 中的＜設定儲存區維護及備份選項＞(英文)。


信箱儲存區的禁止傳送及接收限制過於相似
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定在信箱上設定的信箱大小限制。如果 Exchange Server Analyzer 發現 Prohibit send 與 Prohibit send and receive 信箱限制之間的差異小於 20%，就會顯示一則最佳作法組態訊息。

最佳的作法是讓 Prohibit send 與 Prohibit send and receive 限制之間至少相差 20%。如果這些限制之間的差異小於 20%，則信箱使用者在信箱開始拒絕郵件之前，可能沒有足夠的時間清理其信箱。例如，如果在使用者信箱達到 100 MB 時禁止使用者傳送新郵件，則 Prohibit send and receive 限制至少應為 120 MB。

附註：
在信箱上設定警告限制也很重要。當信箱達到警告限制時，會向使用者傳送一封電子郵件，警告其信箱已接近 Prohibit send 限制中定義的限制。

若要更正此問題，您應增加 Prohibit send 與 Prohibit send and receive 信箱限制之間的差異，使其大於 20%。

若要設定信箱限制

  1. 開啟 [Exchange 系統管理員]。

  2. 找到 Exchange Server Analyzer 訊息中所顯示的信箱儲存區。

  3. 在 [MailboxStore_Name] 上按一下滑鼠右鍵，然後選取 [內容]。

  4. 選取 [限制] 索引標籤。

  5. 修改 [超過下列大小就禁止傳送 (KB)] 限制或 [超過下列大小就禁止收發 (KB)] 限制 (或兩者)。

  6. 按一下 [套用]，然後按一下 [確定]。
若要使用 Exchange 管理主控台設定 Exchange Server 2007 的信箱限制

  1. 開啟 [Exchange 管理主控台]

  2. 尋找 Exchange Server Analyzer 中顯示之與此問題相關的信箱儲存區。

  3. 在 [MailboxStore_Name] 上按一下滑鼠右鍵，然後選取 [內容]。

  4. 選取 [限制] 索引標籤。

  5. 修改 [超過下列大小就發出警告 (KB)]、[超過下列大小就禁止傳送 (KB)] 限制及 [超過下列大小就禁止收發 (KB)] 限制。

  6. 按一下 [套用]，然後按一下 [確定]
若要使用 Exchange 管理命令介面設定 Exchange Server 2007 的信箱限制

  1. 下列範例顯示如何設定信箱大小限制，以便在信箱超過指定大小時傳送警告訊息給使用者。這個屬性適用於此信箱資料庫中所有未設定警告配額屬性的信箱。您必須指定整數或「無限制」。預設值為 1.9 GB。
複製程式碼
Set-MailboxDatabase "Mailbox Database Name" -IssueWarningQuota 1991680
  1. 下列範例顯示如何設定信箱大小，以便在信箱超過指定大小時，禁止與此信箱資料庫中之信箱關聯的使用者傳送郵件。這個屬性適用於此信箱資料庫中所有未設定禁止傳送配額屬性的信箱。所設定的限制值必須是整數或「無限制」。

複製程式碼
Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendQuota 2097152
  1. 下列範例顯示如何設定信箱大小，以便在信箱超過指定大小時，禁止與此信箱關聯的使用者傳送或接收郵件。這個屬性適用於此信箱資料庫中所有未設定禁止傳送/接收配額屬性的信箱。您必須指定整數或「無限制」。

複製程式碼
Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendReceiveQuota 2411520

若需有關管理 Exchange 信箱的詳細資訊，請參閱《使用 Exchange Server 2003 儲存區》(英文) (http://go.microsoft.com/fwlink/?LinkId=47595)。

若需有關管理 Exchange Server 2007 之 Exchange 信箱限制的詳細資訊，請參閱＜如何設定資料庫限制與屬性＞(英文) (http://go.microsoft.com/fwlink/?LinkID=80746)


信箱儲存區不會在啟動時裝載
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定類別為 msExchPrivateMDB 之所有物件的 msExchEDBOffline 屬性值。具有這種類別的物件為信箱儲存區。

msExchEDBOffline 屬性值為 True，表示 Microsoft Exchange Information Store 服務啟動時不會自動裝載信箱儲存區。值為 False 表示啟動時將會自動裝載信箱儲存區。如果 Exchange Server Analyzer 發現此屬性的值為 True，就會顯示警告。

此警告指出已選取 [不要在啟動時裝載此儲存區] 核取方塊。此核取方塊位於信箱儲存區 [內容] 對話方塊的 [資料庫] 索引標籤上。如果選取該核取方塊，Microsoft Exchange Information Store 服務啟動時就不會自動裝載信箱儲存區。Microsoft Exchange Information Store 服務下次啟動時 (例如伺服器重新啟動之後)，將不會裝載此屬性設為 True 的信箱儲存區。建議在 Microsoft Exchange Information Store 服務啟動時自動裝載信箱儲存區。

若要對 Exchange 2000 Server 或 Exchange Server 2003 更正此警告

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [伺服器]，再展開內含欲修改之信箱儲存區的伺服器。

  3. 展開內含欲修改之信箱儲存區的儲存群組。

  4. 在 [信箱儲存區] 上按一下滑鼠右鍵，再按一下 [內容]。

  5. 在 [資料庫] 索引標籤上，清除 [不要在啟動時裝載此儲存區] 核取方塊。

  6. 按一下 [確定] 以儲存設定。

  7. 關閉 [Exchange 系統管理員]。

若要對 Exchange Server 2007 更正此警告

  1. 開啟 [Exchange 管理主控台]

  2. 展開 [伺服器組態]，再選取要使用的伺服器。

  3. 展開要使用的儲存群組。

  4. 在您要使用的資料庫上按一下滑鼠右鍵，然後按一下 [內容]。

  5. 在 [一般] 索引標籤上，清除 [不要在啟動時裝載此資料庫] 核取方塊。

  6. 按一下 [確定] 以儲存設定。

  7. 關閉 [Exchange 管理主控台]

如需此選項的詳細資訊，請參閱下列微軟知識庫文件：

  • 314218＜HOW TO: 在 Exchange 2000 Server 中關閉或開啟啟動時自動裝載資料儲存區的功能＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314218)

  • 285169＜XADM：在您使用 "/disasterrecovery" 參數之後資訊儲存庫不會裝載＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285169)


Max FXGetBuffer Users 參數不是預設值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已建立 Max FXGetBuffer Users 登錄機碼：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server Analyzer 發現已在 ParametersSystem 下建立 Max FXGetBuffer Users 登錄機碼，則會顯示非預設的組態訊息。

您可以使用 Max FXGetBuffer Users 登錄機碼來控制與 Exchange Server 2003 伺服器同時同步處理的 Microsoft Office Outlook® 2003 用戶端數目。您可設定 Max FXGetBuffer Users 登錄機碼的值，以覆寫 Outlook 用戶端所建立之同時遠端程序呼叫 (RPC) 連線的限制。這些連線有時也稱為 ropFXSrcGetBuffers。您可以將伺服器上處理器的數目乘以 2 再加上 3，來計算 Max FXGetBuffer Users 登錄機碼的預設值。例如，在具有兩個處理器的 Exchange Server 2003 伺服器上，預設值為 7 ([2*2] + 3=7)。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要採取任何動作。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需還原登錄的相關資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
還原預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 刪除 [Max FXGetBuffer Users] 值。

  4. 關閉登錄編輯程式。

Microsoft Exchange Information Store 服務可以在幾分鐘內偵測到變更。您不必重新啟動電腦。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關設定登錄機碼以控制可與 Exchange Server 2003 同步處理之 Outlook 用戶端數目的詳細資訊，請參閱知識庫文件 - 818484＜可用來設定並監視 Outlook 用戶端同步處理的登錄值及計數器＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484)。


已變更每個郵件提交的最大附件數
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更每個郵件提交的最大附件數之預設值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtAttachment

如果 Exchange Server Analyzer 發現 objtAttachment 登錄值存在，而且設定的值不是下表中所顯示的值，則會顯示非預設的組態訊息。

項目 | Exchange Server 2003 RTM 預設值 | Exchange Server 2003 SP1 與更新版本預設值 | Exchange Server 2007 預設值
objtAttachment | 100 | 500 | 500

手動新增及設定時，objtAttachment 登錄值會判定每個 MAPI 用戶端之每個郵件提交的最大附件數。當 MAPI 用戶端嘗試傳送的郵件含有超過所允許附件數的附件時，便會將下列事件記錄在 Exchange Server 電腦 (含有該用戶端的信箱) 的應用程式事件記錄中：

事件類型： | 錯誤
事件識別碼： | 9646
事件來源： | MSExchangeIS
事件類別： | 一般
描述： | 關閉 MAPI 工作階段 "/o=OrganizationName/ou=AdministrativeGroupName/cn=Recipients/cn=UserName"，因為它超過類型為 objtAttachment 的最大物件數：xxx。

objtAttachment 登錄值代表組態機會，此機會能將 MAPI 用戶端所使用之 Exchange Server 資源的較大控制層級提供給系統管理員。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession。

  3. 刪除 objtAttachment 登錄值。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

或是，如果您想要使用 objtAttachment 登錄值 (而非刪除它)，請將它保持設為它的現有值，或視需要來調整它。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)。

若需有關詳細資訊，請參閱知識庫文件 - 830829＜MAPI 用戶端開啟的特定伺服器物件超過預設值時，您的 Exchange Server 2003 電腦可能會停止回應＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829)。


已修改快取檢視最大值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已修改每個資料庫的快取檢視數目上限。如果 Exchange Server Analyzer 發現 msExchMaxCachedViews 屬性的預設值 11 已變更，就會顯示非預設的組態訊息。為每個資料庫所設定的快取檢視數目包括在 Exchange Server Analyzer 輸出中。最好能有 5 到 20 個快取檢視。

msExchMaxCachedViews 是 msExchangePrivateMDB 物件類別的屬性。因此，Active Directory 中的每個信箱資料庫儲存區都會有 msExchMaxCachedViews 屬性值。msExchMaxCachedViews 登錄值可指定為信箱中的特定資料夾快取的檢視數目上限。在此內容中，「檢視」指的是當使用者存取其他使用者的 Microsoft Office Outlook® 2003 信箱時，所顯示的資料夾。當使用者與其他使用者共用 Outlook 資料夾的存取時，Exchange Server 會產生一個隱藏私人項目的檢視。

Outlook 使用者首次檢視其他人的行事曆、聯絡人資料夾或其他資料時，可能會有延遲的現象。在使用者檢視過資料夾後，後續再嘗試檢視時，速度可能會變快，但過了一段時間以後，使用者在嘗試存取資料夾時又會發生延遲現象。一般而言，在資料夾含有大量項目時，此延遲現象最為明顯。5,000 個項目即算是大量。

將檢視套用至資料夾的這個動作，會為每一位存取 Outlook 資料夾的唯一使用者在 Exchange 儲存區中建立搜尋資料夾。當搜尋資料夾建立時，會進行其快取以供後續使用。Exchange Server 建立新的搜尋資料夾前，會判定是否已有搜尋資料夾存在。若有搜尋資料夾存在，Exchange Server 會使用快取搜尋資料夾來加速後續的檢視。

msExchMaxCachedViews 屬性會定義在特定資料夾中快取的搜尋資料夾數。例如，msExchMaxCachedViews 屬性可以定義在 [行事曆] 資料夾中快取的搜尋資料夾數。

若有許多使用者共用 Outlook 資料夾，您就必須思考應如何兼顧伺服器資源運用與堪用的用戶端效能。搜尋資料夾進行快取後，搜尋資料夾會隨著其資料的變更而保持在最新狀態。這種更新會用到 CPU 與磁碟資源。若有多個搜尋資料夾的快取同時進行維護，CPU 效能與磁碟效能就會進一步受到影響。

另一方面，在 Exchange Server 首次建立搜尋資料夾時，存取 Outlook 資料夾的使用者可能會在搜尋資料夾建置時遇到延遲的現象。

例如，假設 Exchange Server 設定了 11 個搜尋資料夾。11 是搜尋資料夾的預設數量。使用者 A 與其他 15 個使用者共用她的「行事曆」資料夾。使用者 B 存取該資料夾，並在本身的搜尋資料夾建置時產生延遲現象。在使用者 B 的搜尋資料夾建立完成後，使用者 A 的「行事曆」資料夾的存取速度就會變快。假設使用者 B 當天並未再存取該資料夾。於此同時，若有其他 11 個使用者存取該資料夾，則會建立他們的唯一搜尋資料夾。由於只有 11 個搜尋資料夾進行快取，因此在下次使用者 B 存取使用者 A 的行事曆時，使用者 B 在建置其新的搜尋資料夾時會再次經歷延遲現象。

最好的作法是，將搜尋資料夾快取的最大數量限制在 20 以下。若超過此數量，尤其是資料夾中的項目超過 5,000 個時，伺服器可能會在嘗試維護快取資料夾時發生超載現象。

此外，快取數最好不要低於五個。在使用者與多位使用者共用 Outlook 資料夾時，若僅快取四個搜尋資料夾，將會影響到用戶端的效能，並使伺服器因建立新快取的頻率增加而耗用更多資源。

msExchMaxCachedViews 屬性也可以設定在公用資料夾資料庫上。您也可以為公用資料夾建立搜尋資料夾。根據預設，公用資料夾是許多使用者可存取的共用資源。若公用資料夾收到許多公佈內容，您就應該儘可能減少搜尋資料夾的數量，因為 Exchange Server 在更新搜尋資料夾時可能會耗用大量 CPU 與磁碟空間。此外，若有許多不同的使用者存取公用資料夾，則最好不要提供許多搜尋資料夾快取，來試圖最佳化用戶端的效能。為新的使用者建立新的搜尋資料夾時，可能會捨棄這些快取。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
修改 msExchMaxCachedViews 屬性

  1. 從 Microsoft Windows® 2000 支援工具或 Windows Server 2003 支援工具啟動 [ADSI 編輯器] 工具。

  2. 展開下列節點：

    • 組態容器

    • 組態

    • 服務

    • Microsoft Exchange

    • Organization_Name

    • 系統管理群組

    • Administrative_Group_Name

    • 伺服器

    • InformationStore

    • Storage_Group_Name

  3. 在詳細資料窗格中，以滑鼠右鍵按一下 Database_Name，然後按一下 [內容]。

  4. 在 [屬性] 方塊中，按兩下 msExchMaxCachedViews。

  5. 在 [整數屬性編輯器] 對話方塊的 [值] 欄位中輸入 5 到 20 的整數，然後按一下 [確定]。

  6. 按一下 [套用]，然後關閉 ADSI 編輯器。

  7. 請至少等候 15 分鐘讓複寫完成，然後在經過修改的 Exchange Server 上重新啟動 Microsoft Exchange Information Store 服務。


快取檢視表的最大值設定得太高
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已修改每個資料庫的快取檢視數目上限。如果 Exchange Server Analyzer 發現 msExchMaxCachedViews 屬性設為大於 20 的值，就會顯示警告。為每個資料庫所設定的快取檢視數目包括在 Exchange Server Analyzer 輸出中。最好能有 5 到 20 個快取檢視。

msExchMaxCachedViews 是 msExchangePrivateMDB 物件類別的屬性。因此，Active Directory 中的每個信箱資料庫儲存區都會有 msExchMaxCachedViews 屬性值。msExchMaxCachedViews 登錄值可指定為信箱中的特定資料夾快取的檢視數目上限。在此內容中，「檢視」指的是當使用者存取其他使用者的 Microsoft Office Outlook® 2003 信箱時，所顯示的資料夾。當使用者與其他使用者共用對 Outlook 資料夾的存取權時，Exchange Server 會產生可隱藏私人項目的檢視表。

當 Outlook 使用者首次檢視其他人的行事曆、連絡人資料夾或其他資料時，使用者可能會經歷延遲。在檢視過資料夾之後，使用者在後續嘗試時可檢視得更快，但是經過一段時間後，當使用者再次嘗試存取資料夾時，可能還是會延遲。通常當資料夾包含大量項目時，此延遲最明顯。大量是指 5000 個以上的項目。

套用檢視表至資料夾可為存取 Outlook 資料夾的每位唯一使用者，在 Exchange 儲存區中建立搜尋資料夾。當建立搜尋資料夾時，會快取它以供之後使用。在 Exchange Server 建立新的搜尋資料夾之前，它會先判斷搜尋資料夾是否已存在。如果搜尋資料夾存在，則 Exchange Server 會使用快取的搜尋資料夾，以加速後續的檢視。

msExchMaxCachedViews 屬性會定義在特定資料夾中快取的搜尋資料夾數。例如，msExchMaxCachedViews 屬性可以定義在 [行事曆] 資料夾中快取的搜尋資料夾數。

如果您具有很多共用 Outlook 資料夾的使用者，則您必須決定如何讓伺服器資源與可接受的用戶端效能相平衡。當快取搜尋資料夾時，搜尋資料夾會隨著搜尋資料夾中資料的變更而跟著更新。此更新會使用 CPU 及磁碟資源。如果維護搜尋資料夾的多項快取，則 CPU 效能及磁碟效能會進一步受到影響。

在另外一方面，當 Exchange Server 第一次建立搜尋資料夾時，存取 Outlook 資料夾的使用者可能會在建立搜尋資料夾時經歷延遲。

例如，請考慮設定為具有 11 個搜尋資料夾的 Exchange Server。11 是搜尋資料夾的預設數目。使用者 A 與 15 位其他使用者共用其 [行事曆] 資料夾。使用者 B 存取資料夾，並在建立其搜尋資料夾時經歷延遲。在建立使用者 B 的搜尋資料夾之後，存取使用者 A 的 [行事曆] 資料夾就會變得很快。假設使用者 B 在當天的其他時間不存取資料夾。此時，如果 11 位其他使用者存取資料夾，則會為他們建立唯一的搜尋資料夾。因為只快取 11 個搜尋資料夾，所以使用者 B 下次存取使用者 A 的 [行事曆] 時，使用者 B 在建立新的搜尋資料夾時，會再次經歷延遲。

最佳的作法是將搜尋資料夾快取的最大值限制為等於或小於 20。當超過此數目時 (尤其是包括 5000 個項目以上的資料夾)，當伺服器嘗試維護快取資料夾時，您可能會使伺服器多載。

此外，它是讓快取不少於 5 項的最佳作法。如果使用者與多位使用者共用 Outlook 資料夾，則僅快取 4 個搜尋資料夾對用戶端經歷會有不良影響，並導致伺服器在更加頻繁地建立新快取時，使用更多的資源。

msExchMaxCachedViews 屬性也可以設定在公用資料夾資料庫上。也會為公用資料夾建立搜尋資料夾。依預設，公用資料夾是可供很多使用者存取的共用資源。如果公用資料夾接收到很多郵件，則應該最小化搜尋資料夾，因為 Exchange Server 在更新搜尋資料夾時，可能會使用大量的 CPU 及磁碟。此外，如果有很多不同的使用者存取公用資料夾，則提供很多搜尋資料夾快取來嘗試最佳化用戶端經歷不是最佳的作法。為新使用者建立新的搜尋資料夾時，可能會捨棄這些快取。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
修改 msExchMaxCachedViews 屬性

  1. 從 Microsoft Windows® 2000 支援工具或 Windows Server 2003 支援工具啟動 [ADSI 編輯器] 工具。

  2. 展開下列節點：

    • 組態容器

    • 組態

    • 服務

    • Microsoft Exchange

    • Organization_Name

    • 系統管理群組

    • Administrative_Group_Name

    • 伺服器

    • InformationStore

    • Storage_Group_Name

  3. 在詳細資訊窗格中，在 Database_Name 上按一下滑鼠右鍵，再按一下 [內容]。

  4. 在 [屬性] 方塊中，按兩下 msExchMaxCachedViews。

  5. 在 [整數屬性編輯器] 對話方塊的 [值] 欄位中輸入 5 到 20 的整數，然後按一下 [確定]。

  6. 按一下 [套用]，然後關閉[ADSI 編輯器] 。

  7. 請至少等候 15 分鐘讓複寫完成，然後在經過修改的 Exchange Server 上重新啟動 Microsoft Exchange Information Store 服務。


快取檢視最大值設定太低
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已修改每個資料庫的快取檢視數目上限。如果 Exchange Server Analyzer 發現 msExchMaxCachedViews 屬性設為小於 5 的值，就會顯示警告。您為每個資料庫設定的快取檢視數量會納入 Exchange Server Analyzer 輸出中。最好能有 5 到 20 個快取檢視。

msExchMaxCachedViews 是 msExchangePrivateMDB 物件類別的屬性。因此，Active Directory 中的每個信箱資料庫儲存區都會有 msExchMaxCachedViews 屬性值。msExchMaxCachedViews 屬性值可指定為信箱中的特定資料夾所快取的檢視數目上限。

在此內容中，「檢視」指的是當使用者存取其他使用者的 Microsoft Office Outlook® 2003 信箱時，所顯示的資料夾。當使用者與其他使用者共用 Outlook 資料夾的存取時，Exchange Server 會產生一個隱藏私人項目的檢視。

Outlook 使用者首次檢視其他人的行事曆、聯絡人資料夾或其他資料時，可能會有延遲的現象。在使用者檢視過資料夾後，後續再嘗試檢視時，速度可能會變快，但過了一段時間以後，使用者再嘗試存取資料夾時又會發生延遲現象。一般而言，在資料夾含有大量項目時，此延遲現象最為明顯。5,000 個項目以上即算是大量。

將檢視套用至資料夾的這個動作，會為每一位存取 Outlook 資料夾的唯一使用者在 Exchange 儲存區中建立搜尋資料夾。當搜尋資料夾建立時，會進行其快取以供後續使用。Exchange Server 建立新的搜尋資料夾前，會判定是否已有搜尋資料夾存在。若有搜尋資料夾存在，Exchange Server 會使用快取搜尋資料夾來加速後續的檢視。

msExchMaxCachedViews 屬性會定義在特定資料夾中快取的搜尋資料夾數。例如，msExchMaxCachedViews 屬性可以定義在 [行事曆] 資料夾中快取的搜尋資料夾數。

若有許多使用者共用 Outlook 資料夾，您就必須思考應如何兼顧伺服器資源運用與堪用的用戶端效能。搜尋資料夾進行快取後，搜尋資料夾會隨著其資料的變更而保持在最新狀態。這種更新會用到 CPU 與磁碟資源。若有多個搜尋資料夾的快取同時進行維護，CPU 效能與磁碟效能就會進一步受到影響。

另一方面，在 Exchange Server 首次建立搜尋資料夾時，存取 Outlook 資料夾的使用者可能會在搜尋資料夾建置時遇到延遲的現象。

例如，假設 Exchange Server 設定了 11 個搜尋資料夾。11 是搜尋資料夾的預設數量。使用者 A 與其他 15 個使用者共用她的「行事曆」資料夾。使用者 B 存取該資料夾，並在本身的搜尋資料夾建置時產生延遲現象。在使用者 B 的搜尋資料夾建立完成後，使用者 A 的「行事曆」資料夾的存取速度就會變快。假設使用者 B 當天並未再存取該資料夾。於此同時，若有其他 11 個使用者存取該資料夾，則會建立他們的唯一搜尋資料夾。由於只有 11 個搜尋資料夾進行快取，因此在下次使用者 B 存取使用者 A 的行事曆時，使用者 B 在建置其新的搜尋資料夾時會再次經歷延遲現象。

最好的作法是，將搜尋資料夾快取的最大數量限制在 20 以下。若超過此數量，尤其是資料夾中的項目超過 5,000 個時，伺服器可能會在嘗試維護快取資料夾時發生超載現象。

此外，快取數最好不要低於五個。在使用者與多位使用者共用 Outlook 資料夾時，若僅快取四個搜尋資料夾，將會影響到用戶端的效能，並使伺服器因建立新快取的頻率增加而耗用更多資源。

msExchMaxCachedViews 屬性也可以設定在公用資料夾資料庫上。您也可以為公用資料夾建立搜尋資料夾。根據預設，公用資料夾是許多使用者可存取的共用資源。若公用資料夾收到許多公佈內容，您就應該儘可能減少搜尋資料夾的數量，因為 Exchange Server 在更新搜尋資料夾時可能會耗用大量 CPU 與磁碟空間。此外，若有許多不同的使用者存取公用資料夾，則最好不要提供許多搜尋資料夾快取，來試圖最佳化用戶端的效能。為新的使用者建立新的搜尋資料夾時，可能會捨棄這些快取。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
修改 msExchMaxCachedViews 屬性

  1. 從 Microsoft Windows® 2000 支援工具或 Windows Server 2003 支援工具啟動 ADSI 編輯器工具。

  2. 展開下列節點：

    • 組態容器

    • 組態

    • 服務

    • Microsoft Exchange

    • Organization_Name

    • 系統管理群組

    • Administrative_Group_Name

    • 伺服器

    • InformationStore

    • Storage_Group_Name

  3. 在詳細資料窗格中，以滑鼠右鍵按一下 Database_Name，然後按一下 [內容]。

  4. 在 [屬性] 方塊中，按兩下 msExchMaxCachedViews。

  5. 在 [整數屬性編輯器] 對話方塊的 [值] 欄位中輸入 5 到 20 的整數，然後按一下 [確定]。

  6. 按一下 [套用]，然後關閉 ADSI 編輯器。

  7. 請至少等候 15 分鐘讓複寫完成，然後在經過修改的 Exchange 伺服器上重新啟動 Microsoft Exchange Information Store 服務。


已手動變更最大 ESE 快取
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2006-02-21

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定所有信箱儲存區物件的 msExchESEParamCacheSizeMax 屬性值。如果 Exchange Server Analyzer 發現任何一個信箱儲存區的 msExchESEParamCacheSizeMax 屬性值大於 0，但小於 219727，則會顯示非預設的組態訊息。

在 Exchange 2000 Server 中，STORE.EXE 使用的虛擬記憶體有一個很大的區域已配置給 ESE 緩衝區。Exchange 2000 Server 使用硬式編碼預設值 858 MB 做為此緩衝區大小。在 Exchange Server 2003 中，ESE 緩衝區配置是根據 Boot.ini 檔案中是否有 /3GB 參數而定。如果有 /3GB 參數，ESE 緩衝區會調整成 896 MB。如果 /3GB 不存在，則 ESE 緩衝區會調整為 576 MB。雖然自動調整在各種情況下都有用，還是建議您覆寫自動調整並手動設定更適合您環境的值。雖然您可以將此值調整成 8192 的任何倍數，還是建議您只使用下表中的值。

建議值 | 已配置的記憶體 | 註解
147456 | 576 MB | 這是建議的最小值。不要設定更小的值。在虛擬記憶體有限的伺服器，以及在 Microsoft Windows® 2000 Server (不支援 /3GB 參數) 上執行的 Exchange Server 2003 電腦上，此值很有用。在不使用 /3GB 參數的系統上，此值也是預設值。
196608 | 768 MB | 在含有大量虛擬記憶體且經常記錄事件 9582 的伺服器上，建議採用此值。
219726 | 858 MB | 在 Exchange 2000 Server 中，此值是預設值，而在就地升級且含有大量虛擬記憶體的系統上，此值是個很好用的值。
229376 | 896 MB | 在 Exchange Server 2003 中，此值是預設值，除非應用程式事件日誌以不同的方式顯示 9582 事件，否則此值很適合使用在新的系統上。
311296 | 1.2 GB | 這是可以設定的最大值。只有在實體記憶體 2 GB 以上的系統上才應該使用此值。

在重新設定這個值前，您應該監視 STORE.EXE 處理序耗用的虛擬記憶體量。您可以透過監視 Windows 中的 Process 效能物件來達成此目的。在使用 /3GB 參數的系統上，Process 物件的 STORE.EXE 執行個體之 Virtual Bytes 計數器應小於 2.8 GB。在沒有 /3GB 參數的系統上，該計數器應小於 1.8 GB。如果值大於這些數量，您可能需要減少 msExchESEParamCacheSizeMax 的值。如果值小於此數量，您可能需要增加 msExchESEParamCacheSizeMax 的值。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要調整 msExchESEParamCacheSizeMax 屬性

  1. 開啟一個 Active Directory 編輯程式，如 [ADSI 編輯器]。

  2. 連按兩下 [Configuration] 容器。

  3. 展開 CN=Services。

  4. 展開 CN=Microsoft Exchange。

  5. 展開 CN=<Exchange Organization Name>。

  6. 展開 CN=Administrative Groups。

  7. 展開 CN=<Administrative Group Name>。

  8. 展開 CN=Servers。

  9. 展開 CN=<Exchange Server Name>。

  10. 以滑鼠右鍵按一下 CN=InformationStore，再按一下 [內容]。

  11. 在 [屬性] 欄位中，捲動至 msExchESEParamCacheSizeMax，然後連按兩下該屬性。

  12. 在 [值] 欄位中，鍵入您要設定的值。使用這份文件中的表格來決定系統的最佳值。請注意，您使用的值必須是 8192 的倍數。

  13. 按 [確定] 兩次。

  14. 關閉 Active Directory 編輯器，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

若需有關最佳化記憶體使用量的詳細資訊，請參閱微軟知識庫文件 - 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)。

若需有關 msExchESEParamCacheSizeMax 屬性的詳細資訊，請參閱知識庫文件 - 266768＜XSTR：如何修改儲存區資料庫快取大小上限＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768)。


Maximum ESE Cache 設定得太高
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2006-02-21

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定所有信箱儲存區物件的 msExchESEParamCacheSizeMax 屬性值。Exchange Server Analyzer 也會查詢 Win32_PerfRawData_MSExchangeIS_MSExchangeIS Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 VMLargestBlockSize 機碼值。VMLargestBlockSize 機碼代表最大可用的虛擬記憶體區塊大小 (以位元組為單位)。

此外，Exchange Server Analyzer 會查詢 Active Directory，以判定每個信箱儲存區的 homeMDBBL 屬性中列出的項目數。這個屬性的計數代表信箱儲存區上的信箱數目。

如果 Exchange Server Analyzer 發現在具有 20 個以上信箱的 Exchange Server 電腦上，msExchESEParamCacheSizeMax 的值大於 219726，且 VMLargestBlockSize 的值大於 50000000 但小於 150000000，就會顯示一則錯誤。此錯誤表示此 Exchange Server 電腦上的 msExchESEParamCacheSizeMax 屬性設定得太高。

在 Exchange 2000 Server 中，STORE.EXE 使用的虛擬記憶體有一個很大的區域是配置給「ESE 緩衝區」。Exchange 2000 Server 使用硬式編碼預設值 858 MB 做為此緩衝區大小。在 Exchange Server 2003 中，ESE 緩衝區配置是視 Boot.ini 檔案中是否有 /3GB 參數而定。如果有 /3GB 參數，ESE 緩衝區會調整成 896 MB。如果 /3GB 不存在，則 ESE 緩衝區會調整為 576 MB。對值進行自動調整時，您可能會想要覆寫自動調整並手動設定較適合您環境的值。可將此值調整成 8192 的任意倍數，建議只使用下表中的值：

建議值 | 已配置的記憶體 | 註解
147456 | 576 MB | 這是建議的最小值。不要設定更小的值。在虛擬記憶體有限的伺服器，以及在 Microsoft Windows 2000 Server (不支援 /3GB 參數) 執行的 Exchange Server 2003 電腦上，此值很有用。在不使用 /3GB 參數的系統上，此值也是預設值。
196608 | 768 MB | 在含有大量虛擬記憶體且經常記錄事件 9582 的伺服器上，建議採用此值。
219726 | 858 MB | 在 Exchange 2000 Server 中，此值是預設值，而在就地升級且含有大量虛擬記憶體的系統上，此值是個很好用的值。
229376 | 896 MB | 在 Exchange Server 2003 中，此值是預設值，除非應用程式事件日誌以不同的方式顯示 9582 事件，否則此值很適合使用在新的系統上。
311296 | 1.2 GB | 這是可以設定的最大值。只有在實體記憶體 2 GB 以上的系統上才應該使用此值。

在重新設定這個值前，您應該監視 STORE.EXE 處理序耗用的虛擬記憶體量。您可以透過監視 Windows 中的 Process 效能物件來達成此目的。在使用 /3GB 參數的系統上，Process 物件的 STORE.EXE 執行個體之 Virtual Bytes 計數器應小於 2.8 GB。在沒有 /3GB 參數的系統上，該計數器應小於 1.8 GB。如果值大於這些數值，則需要減少 msExchESEParamCacheSizeMax 的值。如果值小於這些數值，則可能會想要增加 msExchESEParamCacheSizeMax 的值。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要調整 msExchESEParamCacheSizeMax 屬性

  1. 開啟一個 Active Directory 編輯程式，如 [ADSI 編輯器]。

  2. 連按兩下 [Configuration] 容器。

  3. 展開 CN=Services。

  4. 展開 CN=Microsoft Exchange。

  5. 展開 CN=<Exchange Organization Name>。

  6. 展開 CN=Administrative Groups。

  7. 展開 CN=<Administrative Group Name>。

  8. 展開 CN=Servers。

  9. 展開 CN=<Exchange Server Name>。

  10. 以滑鼠右鍵按一下 CN=InformationStore，再按一下 [內容]。

  11. 在 [屬性] 欄位中，捲動至 msExchESEParamCacheSizeMax，然後連按兩下該屬性。

  12. 在 [值] 欄位中，鍵入您要設定的值。請使用此表格來判定系統的最佳值。請注意，使用的值必須是 8192 的倍數。

  13. 按 [確定] 兩次。

  14. 關閉 Active Directory 編輯器，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

若需有關最佳化記憶體使用量的詳細資訊，請參閱微軟知識庫文件 - 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)。

若需有關 msExchESEParamCacheSizeMax 屬性的詳細資訊，請參閱知識庫文件 - 266768＜XSTR：如何修改儲存區資料庫快取大小上限＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768)。


最大 ESE 快取大小已增加
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2006-02-21

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定所有信箱儲存區物件的 msExchESEParamCacheSizeMax 屬性值。

Exchange Server Analyzer 也會查詢 Win32_PerfRawData_MSExchangeIS_MSExchangeIS Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 VMLargestBlockSize 機碼值。VMLargestBlockSize 機碼代表最大可用的虛擬記憶體區塊大小 (以位元組為單位)。

此外，Exchange Server Analyzer 會查詢 Active Directory，以判定每個信箱儲存區的 homeMDBBL 屬性中列出的項目數。這個屬性的計數代表信箱儲存區上的信箱數目。

如果 Exchange Server Analyzer 發現 msExchESEParamCacheSizeMax 值大於 219726，而且在具有超過 20 個信箱的 Exchange Server 電腦上，VMLargestBlockSize 的值不在下列範圍內，就會顯示警告：

  • 大於 50000000 且小於 150000000

  • 大於 0 且小於 50000001

這則警告表示這部 Exchange Server 電腦上的 msExchESEParamCacheSizeMax 屬性已增加，可能會造成虛擬記憶體降低。

在 Exchange 2000 Server 中，STORE.EXE 使用的虛擬記憶體有一個很大的區域已配置給 ESE 緩衝區。Exchange 2000 Server 使用硬式編碼預設值 858 MB 做為此緩衝區大小。在 Exchange Server 2003 中，ESE 緩衝區配置是根據 Boot.ini 檔案中是否有 /3GB 參數而定。如果有 /3GB 參數，ESE 緩衝區會調整成 896 MB。如果 /3GB 不存在，則 ESE 緩衝區會調整為 576 MB。雖然自動調整在各種情況下都有用，還是建議您覆寫自動調整並手動設定更適合您環境的值。雖然您可以將此值調整成 8192 的任何倍數，還是建議您只使用下表中的值：

建議值 | 已配置的記憶體 | 註解
147456 | 576 MB | 這是建議的最小值。不要設定更小的值。在虛擬記憶體有限的伺服器，以及在 Microsoft Windows 2000 Server (不支援 /3GB 參數) 執行的 Exchange Server 2003 電腦上，此值很有用。在不使用 /3GB 參數的系統上，此值也是預設值。
196608 | 768 MB | 在含有大量虛擬記憶體且經常記錄事件 9582 的伺服器上，建議採用此值。
219726 | 858 MB | 在 Exchange 2000 Server 中，此值是預設值，而在就地升級且含有大量虛擬記憶體的系統上，此值是個很好用的值。
229376 | 896 MB | 在 Exchange Server 2003 中，此值是預設值，除非應用程式事件日誌以不同的方式顯示 9582 事件，否則此值很適合使用在新的系統上。
311296 | 1.2 GB | 這是可以設定的最大值。只有在實體記憶體 2 GB 以上的系統上才應該使用此值。

在重新設定這個值前，您應該監視 STORE.EXE 處理序耗用的虛擬記憶體量。您可以透過監視 Windows 中的 Process 效能物件來達成此目的。在使用 /3GB 參數的系統上，Process 物件的 STORE.EXE 執行個體之 Virtual Bytes 計數器應小於 2.8 GB。在沒有 /3GB 參數的系統上，該計數器應小於 1.8 GB。如果值大於這些數量，您可能需要減少 msExchESEParamCacheSizeMax 的值。如果值小於此數量，您可能需要增加 msExchESEParamCacheSizeMax 的值。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要調整 msExchESEParamCacheSizeMax 屬性

  1. 開啟一個 Active Directory 編輯程式，如 [ADSI 編輯器]。

  2. 連按兩下 [Configuration] 容器。

  3. 展開 CN=Services。

  4. 展開 CN=Microsoft Exchange。

  5. 展開 CN=<Exchange Organization Name>。

  6. 展開 CN=Administrative Groups。

  7. 展開 CN=<Administrative Group Name>。

  8. 展開 CN=Servers。

  9. 展開 CN=<Exchange Server Name>。

  10. 以滑鼠右鍵按一下 CN=InformationStore，再按一下 [內容]。

  11. 在 [Attributes] 欄位中，捲動至 msExchESEParamCacheSizeMax，然後連按兩下該屬性。

  12. 在 [Value] 欄位中，鍵入您要設定的值。使用這份文件中的表格來決定系統的最佳值。請注意，您使用的值必須是 8192 的倍數。

  13. 按 [OK] 兩次。

  14. 關閉 Active Directory 編輯器，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

若需有關最佳化記憶體使用量的詳細資訊，請參閱微軟知識庫文件 - 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)。

若需有關 msExchESEParamCacheSizeMax 屬性的詳細資訊，請參閱知識庫文件 - 266768＜XSTR：如何修改儲存區資料庫快取大小上限＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768)。


已設定 MaxOpenMessagesPerLogon
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-05-14

Microsoft Exchange Analyzer 工具會讀取下列登錄項目，以判定 MaxOpenMessagesPerLogon 登錄值是否存在，以及是否已予以設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Analyzer 發現 MaxOpenMessagesPerLogon 登錄項目存在且設為大於 0 的值，則會顯示非預設的組態訊息。

每次 MAPI 用戶端或應用程式開啟 Exchange Server 電腦上的郵件時，它會讓 Microsoft Exchange Information Store 服務 (store.exe) 消耗小量的實體記憶體。Microsoft Office Outlook 2003 或 Outlook 2007 用戶端關閉郵件後，會釋出記憶體。為了防止一或多個 MAPI 用戶端造成 Exchange 儲存區服務連續配置記憶體，Exchange 2000 Server Service Pack 1 (SP1) 引進了新的組態功能，可讓系統管理員限制每個 MAPI 用戶端登入工作階段可同時開啟的郵件數目。如果特定用戶端應用程式不小心開啟許多郵件，而影響整體伺服器效能，在您的環境中設定此類限制便十分有用。

在 Exchange Server 電腦上會使用 MaxOpenMessagesPerLogon 登錄值來實作此功能。建議設定的限制不要大於 1000。值 1,000 允許每個用戶端使用大約 4 到 6 MB 的記憶體。針對部份環境，設為較小值 500 可能會比較適當。

重要事項：
這篇文章包含如何編輯登錄的相關資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

設定最大同時開啟郵件數目

  1. 開啟登錄編輯程式 (例如 Regedit.exe 或 Regedt32.exe)。

  2. 開啟：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在 ParametersSystem 上按一下滑鼠右鍵，並選取 [新增 | DWORD 值]，然後提供新的 MaxOpenMessagesPerLogon 名稱值。

  4. 在右窗格中，連按兩下 MaxOpenMessagesPerLogon 值，然後輸入同時開啟郵件的最大數目 (十進位)。

  5. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱 Microsoft 知識庫文章 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 MaxOpenMessagesPerLogon 登錄值的相關資訊，請參閱 Microsoft 知識庫文章 289109＜XADM：如何限制為每個 MAPI 登入開啟的郵件數目＞(機器翻譯) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=289109)。


已手動變更每個儲存群組的最大資料庫數目
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個儲存群組的 msExchMaxStoresPerGroup 屬性值。如果 Exchange Server Analyzer 發現所有儲存群組的 msExchMaxStoresPerGroup 屬性值都不等於 5，則會顯示錯誤。

這個值適用於伺服器上的所有儲存群組。如果已變更此屬性的預設值 5，則會發生此特殊錯誤。這是唯一支援的值，且絕不可變更。如果增加此值，Exchange Server 便無法正確運作。

您必須使用如 [Active Directory Service Interfaces (ADSI) 編輯器] 嵌入式管理單元、LDP (ldp.exe) 工具或任何其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端等工具來更正此值。

注意：
使用 ADSI 編輯器、LDP 工具或其他 LDAP 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要更正此錯誤

  1. 啟動 [ADSI 編輯器]。

  2. 連按兩下 [組態] 容器，依序展開 CN=Services、 CN=Microsoft Exchange、 CN=<ExchangeOrganizationName>。

  3. 展開 CN=Administrative Groups、展開 CN=<AdministrativeGroupName>，然後展開 CN=Servers。

  4. 展開 [CN=<ServerName>]，以滑鼠右鍵按一下 [CN=InformationStore]，再按 [內容]。

  5. 在 [屬性編輯器] 中，按一下 msExchMaxStoresPerGroup 屬性，再按 [編輯]。

  6. 在 [編輯屬性] 方塊中，將值設為 5。

  7. 按一下 [套用]，再按一下 [確定]。

  8. 關閉 [ADSI 編輯器]，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

若需有關使用 LDP 工具的詳細資訊，請參閱微軟知識庫文件 - 260745＜XADM:Using the LDP Utility to Modify Active Directory Object Attributes＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

若需有關允許之最大儲存群組數目的詳細資訊，請參閱知識庫文件 - 251123＜XADM：Exchange 2000 資料庫容量計劃的最大儲存群組數目＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=251123)。

若需有關使用 ADSI 編輯器的詳細資訊，請參閱主題＜Adsiedit.msc：ADSI 編輯器＞(位在 Windows Server 說明中)。


最大儲存群組數目已經手動變更
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每一個 InformationStore 容器的 msExchMaxStorageGroups 屬性值。如果 Exchange Server Analyzer 判定有任何 msExchMaxStorageGroups 屬性的值不等於 4，就會顯示一則錯誤。

msExchMaxStorageGroups 屬性唯一支援的值是 4，絕不可變更此值。如果修改此值，則 Exchange 將無法正常運作。

您必須使用 Active Directory 編輯程式 (如 Active Directory Service Interfaces (ADSI) 編輯器嵌入式管理單元、LDP (ldp.exe) 工具或任何其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端) 來更正此值。

注意：
使用 ADSI 編輯器、LDP 工具或其他 LDAP 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要更正此錯誤

  1. 使用 [ADSI 編輯器] 或類似工具，在 Active Directory 中找出此伺服器的 InformationStore 物件。

    msExchMaxStorageGroups 屬性位於下列位置：

    CN=Configuration,DC=Domain,CN=com, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Administrative Groups, CN=AdminGroupName, CN=Servers, CN=ServerName, CN=InformationStore

  2. 輸入 4 作為新的值，來編輯 msExchMaxStorageGroups 屬性。

  3. 關閉 Active Directory 編輯程式，然後重新啟動 Exchange Server 電腦，使變更生效。

若需有關使用 LDP 工具的詳細資訊，請參閱微軟知識庫文件 - 260745＜XADM:使用 LDP 公用程式修改 Active Directory 物件屬性＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。


每個登入的最大開啟資料夾物件數目已經變更
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更每個 MAPI 工作階段可開啟的最大資料夾數目預設值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtFolder

如果 Exchange Server Analyzer 發現 objtFolder 登錄值存在而且已設為 500 以外的任何值，就會顯示非預設的組態訊息。

手動新增與設定時，objtFolder 登錄值可決定每個 MAPI 用戶端可以開啟的資料夾最大數目。在預設的情況下，Exchange Server 2003 及 Exchange Server 2007 會將開啟資料夾的數目限制為 500。當 MAPI 用戶端嘗試開啟超過 500 個資料夾時，用戶端信箱所在 Exchange Server 電腦中的應用程式事件日誌就會記錄下列事件：

事件類型： | 錯誤
事件識別碼： | 9646
事件來源： | MSExchangeIS
事件類別： | 一般
描述： | 關閉 MAPI 工作階段 /o=OrganizationName/ou=AdministrativeGroupName/cn=Recipients/cn=UserName，因為其超過 objtFolder 類型的 500 個物件最大值。

objtFolder 登錄值代表的是一種組態設定機會，此登錄值讓系統管理員對於 MAPI 用戶端所用的 Exchange Server 資源有較高的控制層級。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession。

  3. 刪除 objtFolder 登錄值。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

  5. 此外，如果您想使用 objtFolder 登錄值，而非將它刪除，則可保留其現有的值，或視需要加以調整。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)。

若需有關詳細資訊，請參閱知識庫文件 - 830829＜MAPI 用戶端開啟的特定伺服器物件超過預設值時，您的 Exchange Server 2003 電腦可能會停止回應＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829)。


已變更每次登入的最大開啟資料夾檢視數
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更每個 MAPI 工作階段可開啟的預設最大資料夾檢視數：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtFolderView

如果 Exchange Server Analyzer 發現 objtFolderView 登錄值已存在，且 此值不是設為 500，則會顯示非預設的組態訊息。

手動新增與設定時，objtFolderView 登錄值可決定每個 MAPI 用戶端可以開啟的最大資料夾檢視數。根據預設，Exchange Server 2003 與 Exchange Server 2007 會將開啟資料夾檢視數限制為 500。當 MAPI 用戶端嘗試開啟超過 500 個資料夾檢視時，下列事件會記錄於包含用戶端信箱之 Exchange Server 電腦的應用程式事件日誌中：

事件類型：錯誤

事件來源：MSExchangeIS

事件類別：一般

描述：正在關閉 MAPI 工作階段 "/o= OrganizationName /ou= AdministrativeGroupName /cn=Recipients/cn= UserName "，因為它比類型為 objtFolderView 的最大物件數 500 還要大。

objtFolderView 登錄值代表組態機會，它讓系統管理員對 MAPI 用戶端所用的 Exchange Server 資源具有較大程度的控制。

重要事項：
這篇文章包含如何編輯登錄的相關資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession。

  3. 刪除 objtFolderView 登錄值。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

  5. 此外，如果您想使用 objtFolderView 登錄值，而非將它刪除，則讓它設為它現有的值，或視需要來調整它。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)。

若需詳細資訊，請參閱微軟知識庫文件 - 830829＜MAPI 用戶端開啟的特定伺服器物件超過預設值時，Exchange Server 2003 電腦可能會停止回應＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829)。


已變更每個登入的最大開啟郵件物件數
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更每個 MAPI 工作階段的預設最大開啟郵件數：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtMessage

如果 Exchange Server Analyzer 發現 objtMessage 登錄值存在且設為 250 以外的任一值，則會顯示非預設的組態訊息。

手動新增及設定時，objtMessage 登錄值會判定每個 MAPI 用戶端的最大開啟郵件數。Exchange Server 2003 與 Exchange Server 2007 預設會將開啟郵件數限制為 250。當 MAPI 用戶端嘗試開啟 250 封以上的郵件時，便會將下列事件記錄在 Exchange Server 電腦 (含有該用戶端的信箱) 的應用程式事件記錄中：

事件類型：錯誤

事件識別碼： 9646

事件來源：MSExchangeIS

事件類別：一般

描述：正在關閉 MAPI 工作階段 "/o= OrganizationName /ou= AdministrativeGroupName /cn=Recipients/cn= UserName "，因為它超過類型為 objtMessage 的最大物件數：250。

objtMessage 登錄值代表組態機會，此機會可將 MAPI 用戶端所使用之 Exchange Server 資源的較大控制層級提供給系統管理員。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession。

  3. 刪除 objtMessage 登錄值。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

  5. 或是，如果您想要使用 objtMessage 登錄值 ( 而非刪除它)，請讓它保持設為其現有值，或視需要來調整它。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)。

若需有關詳細資訊，請參閱知識庫文件 - 830829＜MAPI 用戶端開啟的特定伺服器物件超過預設值時，您的 Exchange Server 2003 電腦可能會停止回應＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829)。


輪詢頻率最大值並非預設值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄值，以判定是否已修改使用 RPC over HTTP 來存取 Exchange Server 2003 或 Exchange Server 2007 的 Microsoft Office Outlook® 2003 和 Outlook 2007 用戶端之輪詢間隔預設值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Maximum Polling Frequency

如果 Exchange Server Analyzer 發現 Maximum Polling Frequency 機碼存在，且設定的值大於 0，就會顯示非預設的組態訊息。

當 Outlook 對 Exchange 伺服器建立起始連線時，會針對新郵件通知進行其登錄。每當 Outlook 使用者的信箱收到新郵件時，Exchange 就會使用 User Datagram Protocol (UDP) 傳送通知到 Outlook。當 Outlook 收到此通知時，就會從 Exchange 伺服器擷取郵件，並將其顯示在適當的資料夾中。若 Outlook 未收到新郵件的通知，就會重新輪詢 Exchange 伺服器。雖然輪詢是由 Outlook 起始，但輪詢頻率卻是由 Exchange 伺服器所指定。

根據預設，Outlook 2003 每 60 秒會輪詢一次。您可以將 Maximum Polling Frequency 登錄項目新增至包含使用者信箱的 Exchange 伺服器，來變更頻率。您所輸入的值是以毫秒為單位的輪詢間隔最小值。如果 Maximum Polling Frequency 不存在，則會使用預設值 60 秒 (60,000 毫秒)。此預設值並不表示每 60 秒就會輪詢一次。此值是表示輪詢會在輪詢頻率間隔與該間隔的兩倍值之間隨時發生。例如，假設 Maximum Polling Frequency 設為 90 秒。在此範例中，輪詢將會在前次輪詢後的 90 與 180 秒之間發生。

此值不應降至預設值 60 秒以下，因為這麼做會降低 Exchange、Outlook 與網路的效能。此值應不需調整，因為許多使用者動作都會在內部作業的過程中檢查新郵件。例如，當使用者在資料夾之間切換，或開啟郵件時，就會顯示伺服器上的新項目。之所以產生這種結果，乃是因為當 Outlook 傳送必要的 RPC 要求給 Exchange 以影響使用者動作時，會檢查新郵件的旗標，若旗標存在，新郵件通知就會納入 RPC 回應傳回 Outlook。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 刪除 Maximum Polling Frequency 登錄值。

  4. 重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 RPC over HTTP 的詳細資訊，請參閱《Exchange Server 2003 RPC over HTTP 部署案例》手冊 (英文) (http://go.microsoft.com/fwlink/?LinkId=47577)。


最小 ESE 快取已經被手動變更
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2006-01-16

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定所有信箱儲存區物件的 msExchESEParamCacheSizeMin 屬性值。如果 Exchange Server Analyzer 發現有任何信箱儲存區的 msExchESEParamCacheSizeMin 屬性值大於 0，就會顯示非預設的組態訊息。

Microsoft Exchange Information Store 服務在將儲存區資料寫入到磁碟時，會使用「可擴充儲存引擎 (ESE)」快取作為緩衝區。Exchange 2000 Server 最多可使用 858 MB 的快取大小。Exchange Server 2003 則會根據伺服器中安裝的實體隨機存取記憶體 (RAM) 的數量，動態決定 msExchESEParamCacheSizeMin 內容的預設值。

例如，如果 Exchange Server 2003 電腦上的 boot.ini 檔案中有 /3GB 參數設定，則最大快取大小為 896 MB。如果電腦沒有 /3GB 參數設定，則最大快取大小為 576 MB。

您可以使用下列資訊，將 msExchESEParamCacheSizeMin 內容還原為其原始值：

  • 如果 Exchange Server 2003 執行於 Microsoft Windows Server™ 2003 上，且伺服器的 RAM 等於或大於 2 GB，則 msExchESEParamCacheSizeMin 將為 131072 (512 MB)。

  • 如果 Exchange Server 2003 執行於 Windows Server 2003 上，且伺服器的 RAM 等於或大於 768 MB，但是小於 2 GB，則 msExchESEParamCacheSizeMin 會等於 RAM/4*(4*1024)。

  • 如果 Exchange Server 2003 執行於 Windows Server 2003 上，且伺服器的 RAM 小於 768 MB，則 msExchESEParamCacheSizeMin 會等於 RAM/8*(4*1024)。

例如：

  • 在 RAM 為 512 MB 的 Windows Server 2003 中，msExchESEParamCacheSizeMin 的預設值為 16384 (4 KB 分頁)。

  • 在 RAM 為 1 GB 的 Windows Server 2003 中，msExchESEParamCacheSizeMin 的預設值為 65536 (4 KB 分頁)。

  • 在 RAM 為 4 GB 的 Windows Server 2003 中，msExchESEParamCacheSizeMin 的預設值為 131072 (4 KB 分頁)。

  • 如果 Exchange Server 2003 執行於 Microsoft Windows® 2000 Server 上，則不會設定 msExchESEParamCacheSizeMin 的預設值。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Windows Server 2003、Exchange Server 2003 (或兩者) 才能解決。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要更正此警告

  1. 開啟一個 Active Directory 編輯程式，如 [ADSI 編輯器]。

  2. 連按兩下 [Configuration] 容器。

  3. 展開 CN=Services。

  4. 展開 CN=Microsoft Exchange。

  5. 展開 CN=<Exchange Organization Name>。

  6. 展開 CN=Administrative Groups。

  7. 展開 CN=<Administrative Group Name>。

  8. 展開 CN=Servers。

  9. 展開 CN=<Exchange Server Name>。

  10. 以滑鼠右鍵按一下 CN=InformationStore，再按一下 [內容]。

  11. 在 [Attributes] 欄位中，捲動至 msExchESEParamCacheSizeMin，然後連按兩下該屬性。

  12. 在 [Value] 欄位中，鍵入您要設定的值。您可以使用預設公式，並且視您的情況加以編輯。您使用的值必須為 32 MB 的倍數。

  13. 按 [OK] 兩次。

  14. 關閉 Active Directory 編輯器，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

若需有關調整 msExchESEParamCacheSizeMin 屬性的詳細資訊，請參閱微軟知識庫文件 - 822894＜備份或內容索引作業期間 Jet 資料庫沒有正確運作＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822894)。


儲存區處理程序的執行緒數目很高
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Process Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Exchange 資訊儲存庫處理程序的 ThreadCount 值。此值代表伺服器上作用中的儲存區執行緒數目。如果有超過 400 個作用中儲存區執行緒，則會顯示一則警告。

此問題最常見的原因就是在同一部電腦上執行不相容的防毒軟體。

若要更正此警告

  1. 連絡您的廠商，以確定您執行的是最新且與 Exchange 相容的防毒軟體。

  2. 更新您的防毒軟體。

若需有關防毒軟體及 Exchange Server 2003 的詳細資訊，請參閱微軟知識庫文件 - 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)。


OAB Bandwidth Threshold (KBps) 登錄參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄機碼，以判定是否已建立 OAB Bandwidth Threshold (KBps) 登錄機碼：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

如果 Exchange Server Analyzer 發現已在 ParametersSystem 下建立 OAB Bandwidth Threshold (KBps) 登錄機碼，則會顯示非預設的組態訊息。

在 Microsoft Exchange Server 2003 Service Pack 1 (SP1) 中，系統管理員可以設定 OAB Bandwidth Threshold (KBps) 登錄機碼，以覆寫預設功能並限制用於從特定公用儲存區完整下載離線通訊錄的頻寬。

在預設的情況下，每個對完整下載離線通訊錄的用戶端要求都會立即得到滿足。而且，公用儲存區不會對離線通訊錄限制同時完整下載的數目。Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要採取任何動作。不過，如果您想要還原到預設的組態，可以刪除 OAB Bandwidth Threshold (KBps) 登錄機碼。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定您瞭解如何在發生問題時還原登錄。若需如何還原登錄的相關資訊，請檢視 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
還原預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 刪除 OAB Bandwidth Threshold (KBps) 值。

  4. 關閉登錄編輯程式。

Microsoft Exchange Information Store 服務會馬上偵測變更。您不需重新啟動電腦。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關對下載離線通訊錄期間所耗用之頻寬進行節流的詳細資訊，請參閱知識庫文件 - 867623＜對離線通訊錄的完整下載進行節流以限制對 Exchange Server 2003 中之 LAN 的影響＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=867623)。


離線通訊錄與特定信箱儲存區無關
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 msExchPrivateMDB 類別中的 msExchUseOAB 屬性是否已設為針對資料庫上的特定信箱儲存區使用特定離線通訊錄。msExchPrivateMDB 類別可判定私人資料庫的組態。msExchUseOAB 屬性可判定特定信箱儲存區使用的特定離線通訊錄。如果 Exchange Server Analyzer 發現資料庫上的信箱儲存區之離線通訊錄已遺失，則會顯示錯誤訊息。

在 Exchange 2000 Server 與更新的版本中，離線通訊清單會與資訊儲存庫中包含的所有使用者相關聯。您無法自動建立離線通訊清單與特定信箱的關聯性，也無法覆寫資訊儲存庫或儲存群組的全域離線通訊清單設定。

若要建立離線通訊清單與特定信箱的關聯性，您必須先建立包含篩選過的全域通訊清單複本的離線通訊清單。然後，您必須使用 [Active Directory Service Interfaces (ADSI) 編輯器] 或另一個輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端，將 msExchUseOAB 屬性設為離線通訊清單的完整辨別名稱，以將離線通訊清單關聯到特定信箱。

注意：
使用 [ADSI 編輯器]、LDP (ldp.exe) 工具或其他 LDAP 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或 Exchange Server 2007，或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若需有關如何為離線通訊錄與特定信箱建立關聯的詳細指示，請參閱微軟知識庫文件 - 275203＜離線通訊錄無法與特定信箱相關聯＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=275203)。

若要進一步瞭解離線通訊錄，請參閱《離線通訊錄最佳作法手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47583)。


公用資料夾儲存區的 OLD Completion Time 並非預設值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更線上磁碟重組的啟動延遲預設設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\OLD Completion Time

如果 Exchange Server Analyzer 發現 OLD Completion Time 機碼存在，就會顯示非預設的組態訊息。OLD Completion Time 機碼會指定在資訊儲存庫維護視窗之後，線上磁碟重組執行的時間 (秒)。預設值為 1 小時 (3600 秒)。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. 刪除 OLD Completion Time 機碼。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


公用資料夾儲存區的 OLD Minimum RunTime 並非預設值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，判定是否已修改線上磁碟重組之最短執行時間的預設值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\OLD Minimum RunTime

如果 Exchange Server Analyzer 發現 OLD Minimum RunTime 機碼存在，就會顯示非預設的組態訊息。OLD Minimum RunTime 機碼會指定線上磁碟重組所執行的一段最短時間 (秒)。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. 刪除 OLD Minimum RunTime 機碼。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


已停用線上磁碟重組
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個儲存群組物件的 msExchESEParamEnableOnlineDefrag 屬性值。值為 TRUE 表示線上資料庫維護將會根據已設定的排程來進行。值為 FALSE 表示不會發生線上維護。如果 Exchange Server Analyzer 發現 msExchESEParamEnableOnlineDefrag 屬性的值設為 False，則會顯示錯誤訊息。

在 Exchange Server 中，線上資料庫維護 (包括磁碟重組) 是非常重要的。在這段期間，會執行下列工作：清理大型垃圾筒 (刪除已超過其刪除項目保留日期的郵件)、公用資料夾到期 (位在晚於特定日期的公用資料夾中的郵件會過期)、清理已刪除的信箱、線上磁碟重組 (偵測並移除不再使用的資料庫物件，因而產生額外的資料庫可用空間) 等等。這些處理程序可使 Exchange 伺服器狀況良好且效能穩定。線上資料庫維護不得設為「不執行」，因為這樣會使效能隨時間而降低。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或 Exchange Server 2007，或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要更正此錯誤

  1. 按一下 [開始]、[執行]，輸入 MMC，再按一下 [確定]。

  2. 在 Microsoft Management Console (MMC) 中，按一下 [檔案]，再按一下 [新增/移除嵌入式管理單元]。

  3. 在 [可用的獨立嵌入式管理單元] 中，選取 [ADSI 編輯器] 並按一下 [新增]，再按一下 [關閉]。在 [新增/移除嵌入式管理單元] 方塊按一下 [確定]。

  4. 在 [ADSI 編輯器] 上按一下滑鼠右鍵，再按一下 [連線至]。在 [選取熟知的命名內容] 清單對話方塊中，選取 [組態]，再按一下 [確定]。

  5. 展開組態容器，CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdminGroupName>, CN=Servers, CN=<ServerName>, CN=Information Store。

  6. 以滑鼠右鍵按一下 CN=<StorageGroupName>，再按一下 [內容]。

  7. 在 [儲存群組內容] 對話方塊中，從屬性清單中選取 msExchESEParamEnableOnlineDefrag，再按一下 [編輯]，然後將值變更為 TRUE。

  8. 關閉 [ADSI 編輯器] 並重新啟動 Microsoft Exchange Information Store 服務，讓所做的變更生效。

若需有關線上資料庫維護的詳細資訊，請參閱下列 Exchange 資源：

  • 微軟知識庫文件 - 314214＜如何設定 Exchange 2000 Server 資料儲存庫的維護間隔＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=314214)。

  • Exchange Server 2007 內部文件＜Exchange 儲存庫維護＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80787)。


已啟用 Preferred Backfill Source
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判斷是否已將 Preferred Backfill Source 機碼修改為預設值以外的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Preferred Backfill Source

根據預設值，Preferred Backfill Source 不存在。如果 Exchange Server Analyzer 發現 Preferred Backfill Source 已存在，就會顯示非預設的組態訊息。

當公用資料夾儲存區判斷本身未收到某個複寫資料夾 (或階層) 的全部更新，並且必須從其他儲存庫擷取遺漏的更新時，就會發生回填。

為了簡化回填處理程序，Exchange Server 會將關於所遺漏更新的資訊儲存在回填陣列中。

回填陣列會將此項資訊儲存一段指定的時間 (稱為回填逾時)。若遺漏的更新在這段時間內，於後續的複寫郵件中抵達，就會從回填陣列中移除這些資訊。下表列出預設的回填逾時值，這個值是視所遺漏更新的位置，以及先前是否曾經提出要求而定。

要求類型 | 內容存在本機站台的儲存區內 | 內容存在遠端站台的儲存區內
初始回填 | 6 小時 | 12 小時
第一次回填重試 | 12 小時 | 24 小時
後續回填重試 | 24 小時 | 48 小時

若超過回填逾時，並且還是沒有取得更新，Exchange Server 2003 就會建立一或多個回填要求，並且判定要使用哪一部伺服器作為回填來源。

為了選取一部伺服器 (或者多部伺服器) 作為回填來源，Exchange Server 2003 會先建立一份具有資料夾複寫的所有伺服器清單，然後依據下列準則順序來排序清單：

  • 根據伺服器狀態排序。 已關機或無法使用的伺服器放在清單結尾。

  • 根據偏好的回填伺服器排序 (若有；此功能僅在 Exchange Server 2003 或更新版本中才有提供)。Exchange Server 2003 會在 Active Directory® 目錄服務中檢查公用資料夾儲存區物件，找出偏好的回填伺服器。這個設定很少用到。在大部分的情況下，如果 Exchange Server 2003 自動選取回填伺服器時，回填處理程序才最有效率。大部分的 Exchange Server 2003 部署，都不需要偏好的回填伺服器。Microsoft 產品支援服務可以提供一個指令碼，可於部署需要時設定偏好的回填伺服器。

  • 根據傳輸成本排序 (最低至最高)。同一站台中的伺服器順序優先於遠端站台中的伺服器。伺服器的傳輸成本是由 Exchange Server 2003 路由引擎計算，通常是用來計算傳遞郵件的最有效方法。請注意，在 Exchange Server 2003 之前的 Exchange 版本中，傳輸成本的優先順序較低，並且會被放在 Exchange 版本和可用的變更數目之後才考慮。

  • 根據 Exchange 版本排序 (最新至最舊)。

  • 根據伺服器上可用的必要變更號碼排序 (最大至最小)。不會從清單中除去沒有任何遺失變更的伺服器。

如果某個伺服器沒有全部所需的變更，Exchange Server 2003 會選取排序清單中的下一個伺服器，並且傳送回填要求給該伺服器。此處理程序會重複執行，直到已要求所有變更為止。此功能僅在 Exchange Server 2003 或更新版中才有提供；若沒有任何一部伺服器具有指定資料夾的所有遺漏更新時，各個 Exchange 版本一次會傳送回填要求至一部伺服器。在每一項要求之後，先前的 Exchange 版本都會等到過了重試逾時 (從 24 到 48 小時) 之後，才會傳送下一個要求。

若選取的伺服器沒有回應回填要求，則儲存區會將該伺服器標示為離線，並且重複選擇程序。被標示為離線的伺服器會移至清單尾端。

如果您允許 Exchange Server 自動選取回填伺服器，大多時候您的拓樸都能有效地運作。為了疑難排解目的，Microsoft 產品支援服務會建議您設定 Preferred Backfill Source。但是，您應該只在必須解決特定問題時才使用。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

重設 Preferred Backfill Source 登錄機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>

  3. 檢查或編輯 Preferred Backfill Source 的值。

    此登錄項目的值是以 KB 為單位。若要還原為預設值，您應刪除 Preferred Backfill Source，然後重新啟動 Microsoft Exchange Information Store 服務。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關公用資料夾複寫的詳細資訊，請參閱《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595) 中的＜控制 Exchange Server 2003 公用資料夾複寫＞(英文)。


已啟用偏好的公用資料夾回填來源
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已使用公用資料夾階層的偏好回填來源來設定 Exchange：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Public-<Public Information Store GUID>\Preferred Backfill Source

如果 Exchange Server Analyzer 發現 Preferred Backfill Source 登錄項目存在且已設定，則會顯示非預設的組態訊息。

Exchange Server 2003 引進名稱為 msexchPreferredBackfillSource 的新 Active Directory® 目錄服務屬性，可用來指定哪些 Exchange Server 要接收回填要求郵件。

當公用資料夾必須複寫內容時，它會送出查詢給 Exchange 組織，以取得回填要求。回應的第一個公用資料夾伺服器會用來回填資料。此邏輯假設回應的第一個公用資料夾伺服器是最靠近的公用資料夾伺服器；然而，這並一定永遠為真。Exchange Server 2003 引進組態機會，讓系統管理員指定偏好的伺服器來進行回填。

在 Exchange Server 2003 中，可使用 Active Directory 屬性或公用資料夾伺服器上的 Preferred Backfill Source 登錄項目，以設定用來回填公用資料夾階層及內容的偏好伺服器。會先檢查 Active Directory 參數。如果它是空的，則會檢查登錄參數。如果那也不存在，則會使用公用資料夾回填的預設演算法。

若要使用 Active Directory 屬性，請在公用資料夾儲存區物件的 msExchPreferredBackfillSource 屬性中設定所需回填公用資料夾儲存區的辨別名稱 (DN)。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

如果選擇要在 Active Directory 中編輯 msExchPreferredBackfillSource 屬性，則需要使用 Active Directory 編輯程式 (如 Active Directory Service Interfaces (ADSI) 編輯器或 LDP (ldp.exe) 工具)。

注意：
使用 ADSI 編輯器、LDP 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

在登錄中指定偏好的公用資料夾回填來源

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Public-<Public Information Store GUID>

  3. 檢查及(如果需要) 變更 Preferred Backfill Source 值。應該輸入的值是您偏愛從那裡接收郵件的 Exchange 公用資料夾儲存區之辨別名稱 (DN)。

  4. 如果做了變更，請先卸載再重新裝載公用資訊儲存庫，使變更生效。

在 Active Directory 中指定偏好的公用資料夾回填來源

  1. 修改 msExchPreferredBackfillSource 的受影響「公用資料夾儲存區」物件值，以指向所要的回填來源。msExchPreferredBackfillSource 屬性可以在以下位置找到：CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Administrative Groups, CN=AdministrativeGroupName, CN=Servers, CN=ServerName, CN=InformationStore, CN=StorageGroupName, CN=Public Folder Store

  2. 應該輸入的值是您偏愛從那裡接收郵件的 Exchange 公用資料夾儲存區之辨別名稱 (DN)。

  3. 如果做了變更，請先卸載再重新裝載公用資訊儲存庫，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關使用 LDP 工具修改 Active Directory 的詳細資訊，請參閱知識庫文件 - 260745＜XADM：使用 LDP 公用程式修改 Active Directory 物件屬性＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260745)。


提供更多磁碟空間
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2006-09-06

Microsoft® Exchange Server Analyzer 工具已判定執行 Exchange Server 之電腦的磁碟空間低於可接受的標準。Exchange Server Analyzer 會測量可用的磁碟空間，以驗證磁碟空間是在可接受的範圍內。如果工具發現磁碟空間低於可接受的標準，便會顯示錯誤訊息。建議執行 Exchange Server 之電腦的所有磁碟機，其信箱隨時要保持至少 10% 的可用容量。

Exchange Server Analyzer 會測試下列磁碟：

  • Database 磁碟

  • Temp 磁碟

  • MailRoot 磁碟

  • STM 磁碟

  • System 磁碟

  • Log 磁碟

    附註：
    狀態表會要求增加記錄磁碟大小並封存記錄。
  • Page 磁碟

若要更正此錯誤

  1. 若要釋放磁碟空間，請刪除磁碟中不需要的檔案。

  2. 如果可用空間小於 10% 的磁碟包含可以安全移至另一個磁碟的資料 (如信箱或 Microsoft Windows® 分頁檔)，請執行移動該資料所需的步驟。

  3. 增加執行 Exchange Server 之電腦的磁碟容量。

  4. 減少信箱大小或將使用者移到其他伺服器上。

詳細資訊

  • 若需在 Exchange Server 2003 中移動信箱的詳細資訊，請參閱知識庫文件 - 821829＜在 Exchange Server 2003 中移動信箱＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)。

  • 若需在 Exchange 2000 Server 及 Exchange 5.5 Server 之間移動信箱的詳細資訊，請參閱微軟知識庫文件 - 328810＜在伺服器之間移動信箱＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810)。

  • 若需在 Exchange Server 2003 上使用系統原則設定信箱限制的詳細資訊，請參閱微軟知識庫文件 - 822938＜如何在 Exchange Server 2003 中使用系統原則設定信箱儲存限制＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822938)。

  • 若需在 Exchange 2000 Server 上使用系統原則設定信箱限制的詳細資訊，請參閱微軟知識庫文件 - 319130＜如何在 Exchange 2000 上使用系統原則來設定信箱儲存限制＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319130)。

  • 若需有關 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需有關疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《疑難排解 Microsoft Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 如需有關設計存放結構的最佳作法，請參閱《多重結構通用的最佳作法》(英文) (http://go.microsoft.com/fwlink/?LinkId=72988)。

  • 如需調整磁碟大小、延遲及 I/O 比率的詳細資訊，請參閱《如何計算磁碟 I/O 需求》(英文) (http://go.microsoft.com/fwlink/?linkid=69747)。


公用資料夾儲存區資料庫檔案儲存在網路磁碟機上
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個公用資料夾儲存區物件的 msExchEDBFile 屬性值。此屬性指定此公用資料夾儲存區所使用的資料庫檔案位置。

Exchange Server Analyzer 也會查詢 Active Directory，以判定此伺服器上每個信箱儲存區之 homeMDBBL 屬性所列的值數。這個屬性的計數代表信箱儲存區上的信箱數目。Exchange Server Analyzer 之後可以計算伺服器管理的信箱總數。

如果 Exchange Server Analyzer 在具有超過 50 個信箱的 Exchange Server 上，發現 msExchEDBFile 屬性是以 \\ 為開頭，就會顯示錯誤。

此錯誤表示公用資料夾儲存區的資料庫檔案儲存在網路共用磁碟機上。如果 msExchEDBFile 屬性的開頭為 \\，這表示記錄檔路徑使用通用命名慣例 (UNC) 路徑。我們不建議採用這種作法，因為中斷網路連線將會導致資料庫發生錯誤，因而造成資料遺失或資料庫損毀。建議您要立即更正這個問題。

若要將資料庫檔案移動到新的磁碟機

  1. 在 Exchange System Manager 中，展開儲存區所在的 Exchange 伺服器物件、展開適當的儲存群組容器、在您想要的公用資料夾儲存區物件上按一下滑鼠右鍵，再按一下 [內容]。

  2. 在 [內容] 對話方塊的 [資料庫] 標籤中，指定新的檔案位置。

若需有關 Exchange Server 資料庫檔案的詳細資訊，請參閱下列主題：

  • 《Exchange Server 2003 系統管理手冊》的＜管理信箱儲存區及公用資料夾儲存區＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47617)

  • 《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595)中的＜認識 Exchange Server 2003 儲存區＞(英文)

若需有關搭配使用 Exchange Server 與網路磁碟機的詳細資訊，請參閱下列微軟知識庫文件：

  • 328879＜搭配使用 Exchange Server 與儲存連接網路及網路連接儲存裝置＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328879)

  • 839687＜在搭配使用網路連接儲存裝置與 Exchange Server 2003 上，Microsoft 的支援原則＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839687)

  • 317173＜Exchange Server 及網路連接儲存裝置＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317173)

  • 317172＜Exchange Server 5.5 及網路連接儲存裝置＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317172)


已設定公用資料夾儲存區資料庫大小限制
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定公用資料夾儲存區的 Database Size Limit in Gb 登錄值是否存在且已設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Server_Name>\Public-<MailboxStoreGUID>

如果 Exchange Server Analyzer 發現 Database Size Limit in Gb 值存在且已設定，就會顯示非預設的組態訊息。

當 Exchange Server 2003 Service Pack 2 (SP2) 套用於 Exchange Server 2003 Standard Edition 中時，硬式編碼授權資料庫大小限制會由 16 GB 增加到 75 GB。您可以設定保護性資料庫大小限制，以防止無意的資料庫大小成長。SP2 中的預設大小限制值為 18 GB，且藉由建立 Database Size Limit in Gb 登錄值可覆寫此預設值。

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<MailboxStoreGUID>

  3. 刪除 Database Size Limit in Gb 值。

  4. 關閉登錄編輯程式。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Exchange Server 2003 SP2 的詳細資訊，請參閱 Exchange Server Service Pack 2 網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=52073)。


公用資料夾儲存區已超過 8 天未進行完整備份
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會查詢公用資料夾儲存區，以判定上一次完整備份的日期與時間。如果 Exchange Server Analyzer 發現自前次完整備份公用資料夾儲存區以來的天數已超過 8 天，便會顯示警告。

公用資料夾儲存區保留與特定公用資料夾樹狀目錄相關的資訊，例如：樹狀目錄如何構成及樹狀目錄包含哪些資料夾。它還保留公用資料夾的內容。公用資料夾儲存區是由 RTF .edb 檔及資料流原生網際網路內容 .stm 檔案組成。

Exchange Server 資料庫中的信箱儲存區與公用資料夾儲存區資料以及交易記錄檔是最重要的資料，應備份在 Exchange Server 組織中。您可以使用 Exchange Server 資料庫備份，將損毀的公用資料夾儲存區還原至正在執行 Exchange Server 的作用中伺服器。您還可以使用 Exchange Server 資料庫備份，將 Exchange Server 資料庫還原至不同的伺服器。

最佳的作法是每天執行資料庫檔案與交易記錄的完整備份。完成儲存群組的完整備份之後，將從伺服器中刪除 Exchange Server 資料庫上已認可的交易記錄檔。因為您只需要使用一台磁帶機來還原所有的資料，所以完整備份在復原時的速度很快。

附註：
最佳的作法是將交易記錄檔保留在與資料庫檔案不同的專用磁碟上。萬一資料庫磁碟遭到毀損，這樣做可以提供容錯，而且在某些情況下，可以增進資料庫效能。
重要事項：
當您嘗試備份或還原檔案與資料夾時，必須將所需的權限指定給您所登入的使用者帳戶。 若要建立 Exchange Server 備份，您必須具有網域層級備份操作員權限。若要建立 Microsoft Windows Server™ 2003 作業系統備份，您必須至少具有本機備份操作員權限。

為 Exchange Server 資料選擇的備份策略將會視儲存區的大小、備份軟體及硬體的速度、硬體容量及時間需求而定。

若需有關備份策略以及嚴重損壞修復作業的詳細資訊，請參閱：

  • 《Exchange Server 2003 嚴重損壞修復操作手冊》(英文) (http://go.microsoft.com/fwlink/?linkid=47570)。

  • ＜資料庫備份及還原＞(英文) (http://go.microsoft.com/fwlink/?LinkID=80766)。


公用資料夾儲存區已超過 60 天未進行完整備份
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會查詢公用資料夾儲存區，以判定上一次完整備份的日期與時間。如果 Exchange Server Analyzer 發現自前次完整備份公用資料夾儲存區以來的天數已超過 60 天，就會顯示一則錯誤。

公用資料夾儲存區會保留與特定公用資料夾樹狀目錄相關聯的資訊，例如：樹狀目錄如何構成及樹狀目錄包括哪些資料夾。公用資料夾儲存區還會保留公用資料夾內容。公用資料夾儲存區是由 RTF .edb 檔及資料流原生網際網路內容 .stm 檔案組成。

Exchange Server 資料庫中的信箱儲存區資料與公用資料夾儲存區資料以及交易記錄檔是最重要的資料，應備份在 Exchange Server 組織中。您可以使用 Exchange Server 資料庫備份，將損毀的公用資料夾儲存區還原至正在執行 Exchange Server 的作用中伺服器。您還可以使用 Exchange Server 資料庫備份，將 Exchange Server 資料庫還原至不同的伺服器。

最佳的作法是每天執行資料庫檔案與交易記錄的完整備份。完成儲存群組的完整備份之後，將從伺服器中刪除 Exchange Server 資料庫上已認可的交易記錄檔。因為您只需要使用一台磁帶機來還原所有的資料，所以完整備份在復原時的速度很快。

附註：
最佳的作法是將交易記錄檔保留在與資料庫檔案不同的專用磁碟上。此最佳作法不僅能增進資料庫效能，還能在資料庫磁碟損毀時提供容錯。
重要事項：
當您嘗試備份或還原檔案與資料夾時，必須將所需的權限指定給您所登入的使用者帳戶。若要建立 Exchange Server 備份，您必須具有網域層級備份操作員權限。若要建立 Microsoft Windows Server™ 2003 作業系統備份，您必須至少具有本機備份操作員權限。

為 Exchange Server 資料選擇的備份策略將會視儲存區的大小、備份軟體及硬體的速度、硬體容量及時間需求而定。

若需有關備份策略以及嚴重損壞修復作業的詳細資訊，請參閱：

  • 《Exchange Server 2003 嚴重損壞修復操作手冊》(英文) (http://go.microsoft.com/fwlink/?linkid=47570)。

  • ＜資料庫備份及還原＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80766)。


公用資料夾儲存區超過 12 GB
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_DataFile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定每個 Exchange 公用資料夾儲存區資料庫檔案 (.edb 檔) 及資料流檔案 (.stm 檔) 的 FileSize 機碼值。Exchange Server Analyzer 也會讀取下列登錄分支，以判定所安裝的 Exchange Server 版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<Exchange Product GUID>

如果 Exchange Server Analyzer 在執行 Microsoft Exchange Server 2003 Standard Edition 或 Exchange 2000 Server Standard Edition 的電腦上，發現公用資料夾儲存區資料庫檔案及資料流檔案組的大小合計超過 12 GB，就會顯示警告。

位於 Exchange Server 2003 Standard Edition 及 Exchange 2000 Server Standard Edition 的 Exchange 儲存區資料庫不可以超過 16 GB。到達到那個限制之後，信箱儲存區將不再裝載，而且無法存取 Exchange。位於 Exchange Server 2003 Enterprise Edition 及 Exchange 2000 Server Enterprise Edition 的 Exchange 儲存區資料庫則無 16 GB 的限制；它們只受限於可用的硬體，理論上其上限可達 16 TB。

若要更正此警告

  1. 請考慮在公用資料夾上設定到期原則，以刪除超過特定天數的郵件。

  2. 請考慮在公用資料夾儲存區及個別公用資料夾上設定儲存限制，以防止公用資料夾儲存區無限制增大。

  3. 如果最近有從此公用資料夾儲存區刪除大量郵件或移除公用資料夾複本，那麼執行離線磁碟重組可減少檔案大小。
附註：
隨著 Exchange Server 2003 Standard Edition 中 Exchange Server 2003 Service Pack 2 (SP2) 的發行，硬式編碼授權資料庫的大小限制已由 16 GB 增加到 75 GB。系統管理員可設定保護性資料庫大小限制 (防止無意的資料庫大小成長)。SP2 Standard Edition 的預設值是 18 GB，藉由編輯 [Database Size Limit in Gb] 登錄機碼可覆寫 18 GB 的預設值。
重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要透過 Exchange Server 2003 SP2 設定資料庫的大小限制

  1. 在執行 Exchange Server 的電腦上，啟動 Regedit.exe。

  2. 開啟下列登錄機碼：HKLM\System\CurrentControlSet\Services\MSExchangeIS\Server name\Public-Public Store GUID

  3. 在 Public Store GUID 上按一下滑鼠右鍵，指向 [新增]，然後按一下 [DWORD 值]。

  4. 針對新值名稱，請鍵入 [Database Size Limit in Gb]。

  5. 連按兩下 [Database Size Limit in Gb]。在 [數值資料] 中，請鍵入資料庫大小上限的適當值 (GB)。針對 Exchange Server 2003 Standard Edition，請鍵入介於 1 到 75 之間的值 (預設值為 18 GB)。針對 Exchange Server 2003 Enterprise Edition，請鍵入介於 1 到 75 之間的值 (預設值為 18 GB)。按一下 [確定]。

  6. 在 Public Store GUID 上按一下滑鼠右鍵，指向 [新增]，然後按一下 [DWORD 值]。

  7. 針對新值名稱，請鍵入 [Database Size Buffer in Percentage]。

  8. 連按兩下 [Database Size Buffer in Percentage]。在 [數值資料] 中，請鍵入介於 1 到 100 的值，以在接近資料庫大小上限時，指定您要記錄事件並警告的時間。若將預設值設為 10，則系統會在資料庫空間尚餘 10% 時記錄警告事件。按一下 [確定]。

  9. 在 Public Store GUID 上按一下滑鼠右鍵，指向 [新增]，然後按一下 [DWORD 值]。

  10. 針對新名稱，請鍵入 [Database Size Check Start Time in Hours From Midnight]。

  11. 連按兩下 [Database Size Check Start Time in Hours From Midnight]。在 [數值資料] 中，請鍵入介於 0 到 23 之間的值，以指定您要 Exchange 檢查資料庫大小的時間。若將預設值設為 5，則 Exchange Server 會在凌晨五點 (5:00 AM) 檢查資料庫大小。按一下 [確定]。

  12. 關閉登錄編輯程式。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 .stm 及 .edb 檔案的詳細資訊，請參閱微軟知識庫文件 - 232323＜Microsoft Exchange 中的原始內容儲存＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323)。

若需有關在 Exchange Server 2003 中移動信箱的詳細資訊，請參閱知識庫文件 - 821829＜在 Exchange Server 2003 中移動信箱＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)。

若需有關在 Exchange 2000 Server 中移動信箱的詳細資訊，請參閱知識庫文件 - 328810＜在伺服器間移動信箱＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810)。

若需有關執行 Exchange Server 資料庫離線磁碟重組的詳細資訊，請參閱知識庫文件 - 328804＜如何磁碟重組 Exchange 資料庫＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804)。

若需有關在公用資料夾上設定儲存限制的詳細資訊，請參閱知識庫文件 - 823144＜HOW TO：在 Exchange 2003 的公用資料夾上設定儲存限制＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823144)。

若需有關達到資料庫大小上限之 Exchange Server 2003 Standard Edition 及 Exchange 2000 Server Standard Edition 的詳細資訊，請參閱微軟知識庫文件 - 828070＜Exchange Server 信箱儲存區的資料庫達到 16 GB 上限時，無法裝載信箱儲存區＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070)。

若需有關 Exchange Server 2003 SP2 的詳細資訊，請參閱＜Exchange Server 2003 Service Pack 2 網站＞(英文) (http://go.microsoft.com/fwlink/?LinkId=52073)。


公用資料夾儲存區超過 15 GB
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_DataFile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定每個 Exchange 公用資料夾儲存區資料庫檔案 (.edb 檔) 及資料流檔案 (.stm 檔) 的 FileSize 機碼值。Exchange Server Analyzer 也會讀取下列登錄分支，以判定所安裝的 Exchange Server 版本：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<Exchange Product GUID>

如果 Exchange Server Analyzer 發現，在執行 Microsoft Exchange Server 2003 Standard Edition 或 Exchange 2000 Server Standard Edition 的電腦上，公用資料夾儲存區資料庫與資料流檔案配對的大小合計超過 15 GB，就會顯示錯誤。

位於 Exchange Server 2003 Standard Edition 及 Exchange 2000 Server Standard Edition 的 Exchange 儲存區資料庫不可以超過 16 GB。到達到那個限制之後，信箱儲存區將不再裝載，而且無法存取 Exchange。位於 Exchange Server 2003 Enterprise Edition 及 Exchange 2000 Server Enterprise Edition 的 Exchange 儲存區資料庫則無 16 GB 的限制；它們只受限於可用的硬體，理論上其上限可達 16 TB。

若要更正此錯誤

  1. 請考慮在公用資料夾上設定到期原則，以刪除超過特定天數的郵件。

  2. 請考慮在公用資料夾儲存區及個別公用資料夾上設定儲存限制，以防止公用資料夾儲存區無限制增大。

  3. 如果最近有從此公用資料夾儲存區刪除大量郵件或移除公用資料夾複本，那麼執行離線磁碟重組可減少檔案大小。
附註：
隨著 Exchange Server 2003 Standard Edition 中 Exchange Server 2003 Service Pack 2 (SP2) 的發行，硬式編碼授權資料庫的大小限制已由 16 GB 增加到 75 GB。系統管理員可設定保護性資料庫大小限制 (防止無意的資料庫大小成長)。SP2 Standard Edition 的預設值是 18 GB，藉由編輯 [Database Size Limit in Gb] 登錄機碼可覆寫 18 GB 的預設值。
重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要透過 Exchange Server 2003 SP2 設定資料庫的大小限制

  1. 在執行 Exchange Server 的電腦上，啟動 Regedit.exe。

  2. 開啟下列登錄機碼：HKLM\System\CurrentControlSet\Services\MSExchangeIS\Server name\Public-Public Store GUID

  3. 在 Public Store GUID 上按一下滑鼠右鍵，指向 [新增]，然後按一下 [DWORD 值]。

  4. 針對新值名稱， 請鍵入 [Database Size Limit in Gb]。

  5. 連按兩下 [Database Size Limit in Gb]。在 [數值資料] 中，請鍵入資料庫大小上限的適當值 (GB)。針對 Exchange Server 2003 Standard Edition，請鍵入介於 1 到 75 之間的值 (預設值為 18 GB)。針對 Exchange Server 2003 Enterprise Edition，請鍵入介於 1 到 8000 之間的值 (預設值為 8000 GB)。按一下 [確定]。

  6. 在 [Public Store GUID] 上按一下滑鼠右鍵，指向 [新增]，然後按一下 [DWORD 值]。

  7. 針對新值名稱，請鍵入 [Database Size Buffer in Percentage]。

  8. 連按兩下 [Database Size Buffer in Percentage]。在 [數值資料] 中，請鍵入介於 1 到 100 的值，以在接近資料庫大小上限時，指定您要記錄事件並警告的時間。若將預設值設為 10，則系統會在資料庫空間尚餘 10% 時記錄警告事件。按一下 [確定]。

  9. 在 Public Store GUID 上按一下滑鼠右鍵，指向 [新增]，然後按一下 [DWORD 值]。

  10. 針對新名稱，請鍵入 [Database Size Check Start Time in Hours From Midnight]。

  11. 連按兩下 [Database Size Check Start Time in Hours From Midnight]。在 [數值資料] 中，請鍵入介於 0 到 23 之間的值，以指定您要 Exchange 檢查資料庫大小的時間。若將預設值設為 5，則 Exchange Server 會在凌晨五點 (5:00 AM) 檢查資料庫大小。按一下 [確定]。

  12. 關閉登錄編輯程式。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 .stm 及 .edb 檔案的詳細資訊，請參閱微軟知識庫文件 - 232323＜Microsoft Exchange 中的原始內容儲存＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323)。

若需有關在 Exchange Server 2003 中移動信箱的詳細資訊，請參閱知識庫文件 - 821829＜在 Exchange Server 2003 中移動信箱＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)。

若需有關在 Exchange 2000 Server 中移動信箱的詳細資訊，請參閱知識庫文件 - 328810＜在伺服器間移動信箱＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810)。

若需有關執行 Exchange Server 資料庫離線磁碟重組的詳細資訊，請參閱知識庫文件 - 328804＜如何磁碟重組 Exchange 資料庫＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804)。

若需有關在公用資料夾上設定儲存限制的詳細資訊，請參閱知識庫文件 - 823144＜HOW TO：在 Exchange 2003 的公用資料夾上設定儲存限制＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823144)。

若需有關到達資料庫大小上限之 Exchange Server 2003 Standard Edition 及 Exchange 2000 Server Standard Edition 的詳細資訊，請參閱知識庫文件 - 828070＜Exchange Server 信箱儲存區的資料庫達到 16 GB 上限時，無法裝載信箱儲存區＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070)。

若需有關 Exchange Server 2003 SP2 的詳細資訊，請參閱＜Exchange Server 2003 Service Pack 2 網站＞(英文) (http://go.microsoft.com/fwlink/?LinkId=52073)。


公用資料夾儲存區沒有電子郵件位址
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2006-03-28

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個公用資料夾儲存區之 mail 屬性的設定值。如果 Exchange Server Analyzer 發現有任何公用資料夾儲存區的 mail 屬性未經過設定，就會顯示錯誤。

如果公用資料夾儲存區並未設定「簡易郵件傳送通訊協定 (SMTP)」地址，則儲存區的公用資料夾階層複寫將無法正常運作。

技術上，公用資料夾儲存區為特殊的 Exchange 信箱類型。如同所有擁有信箱功能的物件，公用資料夾儲存區必須正確地設定下列屬性，才能寄送與接收郵件：

  • legacyExchangeDN 這是物件的 Exchange 樣式辨別名稱。

  • proxyAddresses 此屬性保存可用於傳送郵件給此收件者的所有電子郵件地址。

  • textEncodedORAddress 此屬性包含主要 X.400 地址。

  • Mail 此屬性包含物件的主要 SMTP 地址 (不含位址首碼)。

  • mailNickname 此屬性用於產生可存取信箱的 URL。

  • displayName 此屬性包含物件的顯示名稱，它會出現在全域通訊清單以及該物件為其成員的任何其他通訊清單中。

如果未設定公用資料夾儲存區的郵件屬性，通常表示收件者更新服務尚未設定好或其運作不正常。收件者更新服務有兩種類型。一種負責處理組態容器中的 Exchange 系統物件 (企業收件者更新服務)，另一種則負責處理每個網域中的收件者 (網域收件者更新服務)。

在整個 Active Directory 樹系中只有一個企業收件者更新服務，因為只有一個組態容器。在其他項目中，就是由收件者更新服務來負責設定公用資料夾儲存區的 mail 屬性。如果此收件者更新服務已停用、設定不正確，或是如果收件者更新服務遇到問題，則可能無法正確地設定屬性，那麼公用資料夾複寫功能將無法正常運作。您應該驗證企業收件者更新服務的組態，以解決此問題。

若要更正此錯誤

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [收件者]，然後選取 [收件者更新服務] 節點。

  3. 在右窗格中，在名稱包含「(企業組態)」的 [收件者更新服務] 上按一下滑鼠右鍵，再按 [內容]。

  4. 確認 [網域] 欄位中的網域名稱正確無誤。

  5. 確認列在 [Exchange 伺服器] 與 [Windows 網域控制站] 欄位中的電腦能正常運作，並且可以在網路上使用。如果這些系統已關機、無法使用，或不是執行收件者更新服務工作所需的系統，您可以使用欄位的 [瀏覽] 按鈕來指定其他機器。

  6. 確認 [更新間隔] 已設為 [永遠執行]。

  7. 按一下 [確定]，儲存變更。

  8. 在右窗格中，在名稱包含「(企業組態)」的收件者更新服務上按一下滑鼠右鍵，然後選取 [重建]。將會顯示下列訊息：

    在下次排程的更新週期時，此作業會重新計算通訊清單成員關係，以及 'contoso.com' 中所有收件者的收件者原則設定。所需時數端視網域中收件者的數量而定。想要繼續嗎？

  9. 按一下 [是] 以重建收件者更新服務。

  10. 在 15 分鐘之後，請遵循下列微軟知識庫文件 246127 中簡述的程序，開始監視收件者更新服務的進展：＜XADM:如何檢查收件者更新服務的進度＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)。

若需有關收件者更新服務的詳細資訊，請參閱下列知識庫文件：

  • 296479＜XADM：停用收件者更新服務的需求＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=296479)

  • 328738＜XADM：收件者更新服務如何套用收件者原則＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253770＜XADM：收件者更新服務執行的工作＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 288807＜疑難排解收件者更新服務＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=288807)

  • 319065＜HOW TO: 使用 Exchange 收件者更新服務＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319065)


啟動時將不裝載公用資料夾儲存區
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定類別為 msExchPublicMDB 之所有物件的 msExchEDBOffline 屬性值。具有這種類別的物件為公用資料夾儲存區。

msExchEDBOffline 屬性的值為 True，表示 Microsoft Exchange Information Store 服務啟動時不會自動裝載公用資料夾儲存區。值為 False 表示啟動時將裝載公用資料夾儲存區。如果 Exchange Server Analyzer 發現此屬性的值設為 True，就會顯示一則警告。

此警告指出已選取 [不要在啟動時裝載此儲存區] 核取方塊。此核取方塊位於公用資料夾儲存區 [內容] 對話方塊的 [資料庫] 索引標籤上。如果選取該核取方塊，則 Microsoft Exchange Information Store 服務啟動時不會自動裝載公用資料夾儲存區。Microsoft Exchange Information Store 服務下次啟動時 (例如，伺服器重新啟動之後)，將不會裝載這個屬性設為 True 的公用資料夾儲存區。建議在 Microsoft Exchange Information Store 服務啟動時自動裝載公用資料夾儲存區。

若要對 Exchange 2000 Server 及 Exchange Server 2003 更正此警告

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [伺服器]，然後展開內含欲修改之公用資料夾儲存區的伺服器。

  3. 展開內含欲修改之公用資料夾儲存區的儲存群組。

  4. 以滑鼠右鍵按一下該公用資料夾儲存區，再按一下 [內容]。

  5. 在 [資料庫] 索引標籤上，清除 [不要在啟動時裝載此儲存區] 核取方塊。

  6. 按一下 [確定] 以儲存設定。

  7. 關閉 [Exchange 系統管理員]。

若要對 Exchange Server 2007 更正此警告

  1. 開啟 [Exchange 管理主控台]

  2. 展開 [伺服器組態]，再選取要使用的伺服器。

  3. 展開要使用的儲存群組。

  4. 在想要使用的公用資料夾資料庫上按一下滑鼠右鍵，然後按一下 [內容]。

  5. 在 [一般] 索引標籤上，清除 [不要在啟動時裝載此資料庫] 核取方塊。

  6. 按一下 [確定] 以儲存設定。

  7. 關閉 [Exchange 管理主控台]

如需此選項的詳細資訊，請參閱下列微軟知識庫文件：

  • 314218＜HOW TO: 在 Exchange 2000 Server 中停用或啟用啟動時自動裝載資料儲存區＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314218)

  • 285169＜XADM：在您使用 "/disasterrecovery" 參數之後資訊儲存庫不會裝載＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=285169)


公用資料夾樹狀目錄資料庫指派
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個 msExchPFTree 物件類別的 msExchOwningPFTreeBL 屬性值。msExchOwningPFTreeBL 屬性會儲存公用資料夾儲存區 (包含公用資料夾樹狀目錄複本) 的辨別名稱清單。如果 Exchange Server Analyzer 發現公用資料夾樹狀目錄物件上的 msExchOwningPFTreeBL 屬性是空白，就會顯示一則警告。此警告表示某個公用資料夾樹狀目錄尚未被任何公用資料夾儲存區擁有。

每一個公用資料夾樹狀目錄 (亦稱為「公用資料夾階層」) 都會連回至一個公用資料夾儲存區。您必須先建立樹狀目錄，然後建立儲存區。如果尚未將樹狀目錄連結到資料庫，就會顯示此警告。在個別伺服器上，每一個公用資料夾樹狀目錄只能有一個儲存區。如果每一個儲存區都位於不同伺服器上，則一個樹狀目錄可以有多個儲存區。在這樣的組態下，Exchange 會在儲存區之間複寫資訊，使階層保持一致。

如果 Microsoft Office Outlook® Web Access 用戶端嘗試連線至樹狀目錄內沒有指派相關公用資料夾儲存區的公用資料夾，就會發生「服務無法使用 (HTTP 503)」錯誤。

若要更正此警告，您必須執行下列其中一個動作：

  • 連結公用資料夾樹狀目錄與公用資料夾資料庫。若要連結公用資料夾樹狀目錄與公用資料夾資料庫，您必須先建立新的公用資料夾資料庫，然後找出公用資料夾樹狀目錄並將它們連結起來。

  • 刪除公用資料夾樹狀目錄。如果尚未將公用資料夾樹狀目錄連結至公用資料夾資料庫，則當您刪除該樹狀目錄時，將不會失去任何使用者資料。

若要連結公用資料夾樹狀目錄與公用資料夾資料庫

  1. 在 [Exchange 系統管理員] 中，展開要新增公用資料夾儲存區的伺服器。

  2. 在特定儲存群組上按一下滑鼠右鍵，指向 [新增]，然後按一下 [公用儲存區]。

  3. 在 [名稱] 中，鍵入新資料庫的名稱。

  4. 若要使公用資料夾樹狀目錄與資料庫產生關聯，請按一下 [瀏覽]，然後選取 Exchange Server Analyzer 警告訊息中所顯示的公用資料夾樹狀目錄。

  5. 若要儲存設定，請按一下 [確定]。

  6. 若要裝載新的儲存區，請按一下 [是]。

若要刪除公用資料夾樹狀目錄

  1. 在 [Exchange 系統管理員] 中，展開公用資料夾樹狀目錄所在的 [資料夾] 節點。

  2. 在要刪除的公用資料夾樹狀目錄上按一下滑鼠右鍵，按一下 [刪除]，然後按一下 [是]。

若需有關公用資料夾管理的詳細資訊，請參閱《Exchange Server 2003 系統管理手冊》(http://go.microsoft.com/fwlink/?linkid=47617) 中的＜管理信箱儲存區及公用資料夾儲存區＞(英文)。

若需詳細資訊，請參閱＜Exchange Server 2003 Service Pack 1 (SP1) 線上說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=29847)。


已啟用復原儲存群組
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定類別為 msExchStorageGroup 之所有物件的 msExchESEParamBaseName 屬性值。具有這種類別的物件為儲存群組物件。msExchESEParamBaseName 屬性的值為 R00，表示儲存群組物件是復原儲存群組。如果 Exchange Server Analyzer 發現此屬性的值為 R00，就會顯示警告。

此警告指出復原儲存群組存在。建議您在完成復原程序後移除復原儲存群組。若未移除復原儲存群組，則不熟悉復原儲存群組的系統管理員於日後執行標準復原時，可能會有所混淆。

若要對 Exchange 2000 Server 及 Exchange Server 2003 更正此警告

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [伺服器]，然後再展開內含要刪除的復原儲存群組之伺服器。

  3. 在 [復原儲存群組] 上按一下滑鼠右鍵，再按一下 [刪除]。

  4. 關閉 [Exchange 系統管理員]。

若要對 Exchange Server 2007 更正此警告

  1. 請遵循核心 Exchange Server 2007 文件＜如何移除復原儲存群組＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80783) 的指導。

若需有關復原儲存群組及 Exchange Server 2003 的詳細資訊，請參閱《使用 Exchange Server 2003 復原儲存群組》(英文) (http://go.microsoft.com/fwlink/?LinkId=23233) 以及微軟知識庫文件 - 824126＜如何使用 Exchange Server 2003 中的復原儲存群組＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=824126)。

若需有關復原儲存群組及 Exchange Server 2007 的詳細資訊，請參閱＜瞭解復原儲存群組＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80784)。


已停用復原儲存群組的功能
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已修改 msExchMaxRestoreStorageGroups 屬性。如果 Exchange Server Analyzer 發現 msExchMaxRestoreStorageGroups 屬性已設為 0，就會顯示錯誤。

msExchMaxRestoreStorageGroups 屬性是每個 Exchange 電腦之資訊儲存庫物件的二進位屬性。如果 msExchMaxRestoreStorageGroups 屬性設為 0，則無法為指定的 Exchange 電腦建立復原儲存群組。

如果您在未使用 Exchange Server 2003 升級 Exchange 虛擬伺服器的 Windows 叢集上，執行從 Exchange 2000 Server SP3 至 Exchange Server 2003 SP1 的就地升級，則可能會發生此錯誤。請注意，有時此就地升級案例可能會使 Outlook® Mobile Access 失敗。

您必須將每個 Exchange 電腦之資訊儲存庫物件的 msExchMaxRestoreStorageGroups 屬性設為 1，來更正復原儲存群組錯誤。會在 Exchange Server Analyzer 輸出中顯示受影響的資訊儲存庫物件。如果您需要協助來解決 Outlook Mobile Access 問題，請連絡 Microsoft 支援。

注意：
使用 [Active Directory Service Interfaces (ADSI) 編輯器]、LDP 工具 (ldp.exe) 或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或 Exchange Server 2007，或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
若要更正復原儲存群組錯誤

  1. 啟動 [ADSI 編輯器]。

  2. 連按兩下 [Configuration] 容器，依序展開 [CN=Services]、[CN=Microsoft Exchange] 及 [CN=<ExchangeOrganizationName>]。

  3. 展開 CN=Administrative Groups、展開 CN=<AdministrativeGroupName>，然後展開 CN=Servers。

  4. 在詳細資料窗格的 CN=InformationStore 上按一下滑鼠右鍵，再按 [內容]。

  5. 在 [屬性編輯器] 中，按一下 msExchMaxRestoreStorageGroups 屬性，再按 [編輯]。

  6. 在 [編輯屬性] 方塊中，輸入 1。

  7. 按一下 [套用]，然後按一下 [確定]。

  8. 關閉 [ADSI 編輯器]。重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

若需有關如何使用 LDP 工具的詳細資訊，請參閱微軟知識庫文件 - 260745＜XADM：Using the LDP Utility to Modify Active Directory Object Attributes＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)。

若需有關 Exchange 復原儲存群組的詳細資訊，請參閱下列 Exchange 資源：

  • ＜使用 Exchange Server 2003 復原儲存群組＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47589)。

  • ＜瞭解復原儲存群組＞(英文) (http://go.microsoft.com/fwlink/?LinkID=80784)


公用資料夾伺服器的複寫到期並非預設值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2006-05-25

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄值，以判定是否已將進行移除作業的間隔時間 (其中，Exchange 儲存區會在此間隔時間將超過保留期間的項目移除) 修改為預設值以外的值：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>\Replication Expiry

如果 Exchange Server Analyzer 發現 Replication Expiry 登錄值且已設定，就會顯示非預設的組態訊息。

「郵件到期」是指公用資料夾中超過指定時間值的過期郵件處理程序。郵件到期的預設間隔為 24 小時。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>

  3. 刪除 Replication Expiry 登錄值。

  4. 重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需公用資料夾複寫的詳細資訊，請參閱《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595)，以及知識庫文件 273479＜說明 Exchange 2000 Server 及 Exchange Server 2003 中的公用資料夾參考功能＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=273479)。


公用資料夾儲存區的複寫資料夾衝突保留天數並非預設值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄值，以判定是否已將資料夾衝突過期修改為預設設定以外的值：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>\Replication Folder Conflict Age Limit

如果 Exchange Server Analyzer 發現 Replication Folder Conflict Age Limit 登錄值且已設定，就會顯示非預設的組態訊息。

當兩個使用者在公用資料夾中編輯並修改相同的郵件時，會使已儲存的郵件定義為發生衝突。當同一公用資料夾伺服器上發生同時儲存時，或在包含該資料夾複本的兩個伺服器上編輯郵件時，就會發生這種情況。如果公用資料夾的擁有者在衝突保留天數所設定的期間內未採取任何動作，則在超過保留天數之後，公用資料夾儲存區會解決衝突。Replication Folder Conflict Age Limit 登錄值會控制此保留天數。其值是允許發生衝突之郵件存在的天數。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>

  3. 刪除 Replication Folder Conflict Age Limit 登錄值。

  4. 重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需公用資料夾複寫的詳細資訊，請參閱知識庫文件 - 273479＜瞭解公用資料夾複寫及轉介＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=273479)。


Replication Folder Count Limit 值已變更
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已將 Replication Folder Count Limit 機碼修改為預設值以外的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Folder Count Limit

如果 Exchange Server Analyzer 發現 Replication Folder Count Limit 存在，就會顯示非預設的組態訊息。

在預設的情況下，Replication Folder Count Limit 不存在。Replication Folder Count Limit 值代表要在階層複寫郵件中封裝的最大資料夾數目 (用以複寫公用資料夾樹狀目錄的階層及公用資料夾的內容)。該值必須介於 1 到 1000 之間；預設值為 20。這個登錄機碼不適用於 Exchange Server 2003 及更新的版本，僅適用於之前的 Exchange Server 版本。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要重設 Replication Folder Count Limit 登錄機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>

  3. 檢查或編輯 Replication Folder Count Limit 的值。

    此登錄項目的值是以 KB 為單位。若要返回到預設值，您應該刪除 Replication Folder Count Limit，並重新啟動 Microsoft Exchange Information Store 服務。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關公用資料夾複寫的詳細資訊，請參閱《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595) 中的＜控制 Exchange Server 2003 公用資料夾複寫＞(英文)。


Replication Folder Tree RMQ Timeout 值已變更
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已將 Replication Folder Tree RMQ Timeout 機碼修改為預設值以外的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Folder Tree RMQ Timeout

如果 Exchange Server Analyzer 發現 Replication Folder Tree RMQ Timeout 存在，就會顯示非預設的組態訊息。

在預設的情況下，Replication Folder Tree RMQ Timeout 不存在。Exchange 利用階層郵件來複寫公用資料夾樹狀目錄的階層和公用資料夾的內容。當公用資料夾收到複寫變更之後，它會將複寫變更載入記憶體 (複寫郵件佇列) 進行處理。Replication Folder Tree RMQ Timeout 值代表複寫的階層變更保留在記憶體的時間長度上限。秒數值必須介於 3600 (一小時) 和 2592000 (30 天) 之間；預設值為 604800 (7 天)。順利處理的變更會立即從記憶體中刪除；否則，該變更會一直保留在記憶體中，直到可以進行處理或逾時為止，此時才加以刪除。

例如，假設複寫資料夾的變更之後，又複寫該資料夾的子資料夾的另一項變更。根據拓樸和介於兩次變更之間的經過時間，所做的變更可能以任何順序到達目的地公用資料夾儲存區。如果子資料夾的變更先到達，但要等到套用上層資料夾的變更之後才能正確處理，則公用資料夾儲存區會將子資料夾的變更保留在記憶體中，直到上層資料夾的變更到達並加以處理為止。如果在處理上層資料夾的變更之前就逾時了，就會從記憶體中刪除子資料夾的變更。稍後，等上層資料夾的變更處理完畢之後，公用資料夾儲存區會接收到子資料夾變更的另一個複本，然後就可以順利處理它。如果儲存區未接收到子資料夾變更的另一個複本，當公用資料夾儲存區比較其狀態與拓撲中其他公用資料夾儲存區的狀態時，會發現本身的公用資料夾儲存區樹狀目錄複本遺失了子資料夾的變更，而開始進行回填變更的處理。

在大部分情況下，我們不建議您變更 Replication Folder Tree RMQ Timeout 的預設值。如果變更了這個值，在大量複寫流量期間 (例如，在加入新的公用資料夾儲存區之後)，它可能會暫時增加。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要重設 Replication Folder Tree RMQ Timeout 登錄機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>

  3. 檢查或編輯 Replication Folder Tree RMQ Timeout 的值。

    此登錄項目的值是秒數。若要還原為預設值，您應該刪除 Replication Folder Tree RMQ Timeout，然後重新啟動 Microsoft Exchange Information Store 服務。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關公用資料夾複寫的詳細資訊，請參閱《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595)中的＜控制 Exchange Server 2003 公用資料夾複寫＞(英文)。


公用資料夾儲存區的複寫資料夾標記保留天數並非預設值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已將公用資料夾標記項目的移除間隔修改為預設值以外的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder Store GUID>\Replication Folder Tombstone Age Limit

如果 Exchange Server Analyzer 發現 Replication Folder Tombstone Age Limit 存在於登錄中，就會顯示非預設的組態訊息。

公用資料夾複寫會使用資料夾標記資訊。需要過期來防止資料夾標記清單無限制地成長。Replication Folder Tombstone Age Limit 登錄值可以覆寫預設值 (180 天)。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder Store GUID>

  3. 刪除 Replication Folder Tombstone Age Limit 登錄值。

  4. 重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Replication Folder Tombstone Age Limit 登錄值的詳細資訊，請參閱知識庫文件 - 159196＜XADM：受 IS 維護排程控制的作業＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159196)。


已變更 Replication Long Backfill Request Delay 值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判斷是否已將 Replication Long Backfill Request Delay 機碼修改為預設值以外的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Long Backfill Request Delay

如果 Exchange Server Analyzer 發現 Replication Long Backfill Request Delay 存在，則會顯示非預設的組態訊息。

根據預設值，Replication Long Backfill Request Delay 不存在。當公用資料夾儲存區判斷本身未收到某個複寫資料夾 (或階層) 的全部更新，並且必須從其他儲存區擷取遺漏的更新時，就會發生回填。

為了簡化回填處理程序，Exchange Server 會將關於所遺漏更新的資訊儲存在回填陣列中。回填陣列會將此項資訊儲存一段指定的時間 (稱為回填逾時)。若遺漏的更新在這段時間內，於後續的複寫郵件中抵達，就會從回填陣列中移除這些資訊。下表列出預設的回填逾時值，這個值是視所遺漏更新的位置，以及先前是否曾經提出要求而定。

要求類型 | 內容存在本機站台的儲存區內 | 內容存在遠端站台的儲存區內
初始回填 | 6 小時 | 12 小時
第一次回填重試 | 12 小時 | 24 小時
後續回填重試 | 24 小時 | 48 小時

若超過回填逾時，並且還是沒有取得更新，Exchange Server 2003 就會建立一或多個回填要求，並且判定要使用哪一部伺服器作為回填來源。

為了選取一部伺服器 (或者多部伺服器) 作為回填來源，Exchange Server 2003 會先建立一份具有資料夾複寫的所有伺服器清單，然後依據下列準則順序來排序清單：

  • 根據伺服器狀態排序 關機或無法使用的伺服器會排到清單尾端。

  • [根據偏好的回填伺服器排序] 若有偏好的伺服器；此功能僅在 Exchange Server 2003 或更新版中才有提供。Exchange Server 2003 會在 Active Directory® 目錄服務中檢查公用資料夾儲存區物件，找出偏好的回填伺服器。這個設定很少用到。在大部分的情況下，如果 Exchange Server 2003 自動選取回填伺服器時，回填處理程序才最有效率。大部分的 Exchange Server 2003 部署，都不需要偏好的回填伺服器。Microsoft 產品支援服務可以提供一個指令碼，可於部署需要時設定偏好的回填伺服器。

  • 根據傳輸成本排序 (最低到最高) 位於相同站台內的伺服器，其優先順序高於遠端站台內的伺服器。伺服器的傳輸成本是由 Exchange Server 2003 路由引擎計算，通常是用來計算傳遞郵件的最有效方法。請注意，在 Exchange Server 2003 之前的 Exchange 版本中，傳輸成本的優先順序較低，並且會被放在 Exchange 版本和可用的變更數目之後才考慮。

  • 根據 Exchange 版本排序 (最新到最舊)

  • 根據伺服器上可用的必要變更數目排序 (最大到最小) 伺服器上若沒有所缺的變更，就會從清單中移除。

若某部伺服器沒有包含所有需要的變更，Exchange Server 2003 會選取已排序清單內的下一部伺服器，並且傳送回填要求至該伺服器。這個處理程序會一直重複進行，直到取得所有要求的變更為止。此功能只在 Exchange Server 2003 及更新版本中才可使用；前版 Exchange 會在沒有單一伺服器保有特定資料夾的所有遺失更新時，傳送回填要求到一部伺服器。在每一項要求之後，先前的 Exchange 版本都會等到過了重試逾時 (從 24 到 48 小時) 之後，才會傳送下一個要求。

若選取的伺服器沒有回應回填要求，則儲存區會將該伺服器標示為離線，並且重複選擇程序。被標示為離線的伺服器會移至清單尾端。

Replication Long Backfill Request Delay 值代表儲存區延遲的時間長度，經過此時間之後便會傳送回填要求，以取得無法在相同的 Exchange 站台中使用的資料。值 (以秒為單位) 必須介於 900 到 2592000 秒之間 (30 天)；預設值為 43200 秒 (12 小時)。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

重設 Replication Long Backfill Request Delay 登錄機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>

  3. 檢查或編輯 Replication Long Backfill Request Delay 的值。

    此登錄項目的值是秒數。若要還原為預設值，您應刪除 Replication Long Backfill Request Delay ，然後重新啟動 Microsoft Exchange Information Store 服務。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關公用資料夾複寫的詳細資訊，請參閱《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595)中的＜控制 Exchange Server 2003 公用資料夾複寫＞(英文)。


Replication Long Backfill Request Timeout 值已變更
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已將 Replication Long Backfill Request Timeout 機碼修改為預設值以外的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Long Backfill Request Timeout

如果 Exchange Server Analyzer 發現 Replication Long Backfill Request Timeout 存在，就會顯示非預設的組態訊息。

依預設，Replication Long Backfill Request Timeout 不存在。當公用資料夾儲存區判斷本身未收到某個複寫資料夾 (或階層) 的全部更新，並且必須從其他儲存區擷取遺漏的更新時，就會發生回填。

為了簡化回填處理程序，Exchange Server 會將關於所遺漏更新的資訊儲存在回填陣列中。回填陣列會將此項資訊儲存一段指定的時間 (稱為回填逾時)。若遺漏的更新在這段時間內，於後續的複寫郵件中抵達，就會從回填陣列中移除這些資訊。下表列出預設的回填逾時值，這個值是視所遺漏更新的位置，以及先前是否曾經提出要求而定。

要求類型 | 內容存在本機站台的儲存區內 | 內容存在遠端站台的儲存區內
初始回填 | 6 小時 | 12 小時
第一次回填重試 | 12 小時 | 24 小時
後續回填重試 | 24 小時 | 48 小時

若超過回填逾時，並且還是沒有取得更新，Exchange Server 2003 就會建立一或多個回填要求，並且判定要使用哪一部伺服器作為回填來源。

為了選取一部伺服器 (或者多部伺服器) 作為回填來源，Exchange Server 2003 會先建立一份具有資料夾複寫的所有伺服器清單，然後依據下列準則順序來排序清單：

  • 根據伺服器狀態排序 關機或無法使用的伺服器會排到清單尾端。

  • [根據偏好的回填伺服器排序] 若有偏好的伺服器；此功能僅在 Exchange Server 2003 或更新版中才有提供。Exchange Server 2003 會在 Active Directory® 目錄服務中檢查公用資料夾儲存區物件，找出偏好的回填伺服器。這個設定很少用到。在大部分的情況下，如果 Exchange Server 2003 自動選取回填伺服器時，回填處理程序才最有效率。大部分的 Exchange Server 2003 部署，都不需要偏好的回填伺服器。Microsoft 產品支援服務可以提供一個指令碼，可於部署需要時設定偏好的回填伺服器。

  • 根據傳輸成本排序 (最低到最高) 位於相同站台內的伺服器，其優先順序高於遠端站台內的伺服器。伺服器的傳輸成本是由 Exchange Server 2003 路由引擎計算，通常是用來計算傳遞郵件的最有效方法。請注意，在 Exchange Server 2003 之前的 Exchange 版本中，傳輸成本的優先順序較低，並且會被放在 Exchange 版本和可用的變更數目之後才考慮。

  • 根據 Exchange 版本排序 (最新到最舊)

  • 根據伺服器上可用的必要變更數目排序 (最大到最小) 伺服器上若沒有所缺的變更，就會從清單中移除。

若某部伺服器沒有包含所有需要的變更，Exchange Server 2003 會選取已排序清單內的下一部伺服器，並且傳送回填要求至該伺服器。這個處理程序會一直重複進行，直到取得所有要求的變更為止。此功能只在 Exchange Server 2003 及更新版本中才可使用；前版 Exchange 會在沒有單一伺服器保有特定資料夾的所有遺失更新時，傳送回填要求到一部伺服器。在每一項要求之後，先前的 Exchange 版本都會等到過了重試逾時 (從 24 到 48 小時) 之後，才會傳送下一個要求。

若選取的伺服器沒有回應回填要求，則儲存區會將該伺服器標示為離線，並且重複選擇程序。被標示為離線的伺服器會移至清單尾端。

Replication Long Backfill Request Timeout 值代表在嘗試傳送回填要求來取得不在相同 Exchange 網站中的資料時，公用資料夾儲存區使用的逾時值。值 (以秒為單位) 必須介於 900 到 2592000 秒之間 (30 天)；預設值為 86400 秒 (24 小時)。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

重設 Replication Long Backfill Request Timeout 登錄機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>

  3. 檢查或編輯 Replication Long Backfill Request Timeout 的值。

    此登錄項目的值是秒數。若要還原為預設值，您應該刪除 Replication Long Backfill Request Timeout，然後重新啟動 Microsoft Exchange Information Store 服務。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關公用資料夾複寫的詳細資訊，請參閱《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595) 中的＜控制 Exchange Server 2003 公用資料夾複寫＞(英文)。


Replication Long Backfill Request Timeout Retry 值已變更
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已修改 Replication Long Backfill Request Timeout Retry 機碼的預設值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Long Backfill Request Timeout Retry

如果 Exchange Server Analyzer 發現 Replication Long Backfill Request Timeout Retry 存在，就會顯示非預設的組態訊息。

在預設的情況下，Replication Long Backfill Request Timeout Retry 不存在。當公用資料夾儲存區判定本身未收到某個複寫資料夾 (或階層) 的全部更新，並且必須從其他儲存區擷取遺漏的更新時，就會發生回填。

為了簡化回填處理程序，Exchange Server 會將關於所遺漏更新的資訊儲存在回填陣列中。回填陣列會將此項資訊儲存一段指定的時間 (稱為回填逾時)。若遺漏的更新在這段時間內，於後續的複寫郵件中抵達，就會從回填陣列中移除這些資訊。下表列出預設的回填逾時值，這個值是視所遺漏更新的位置，以及先前是否曾經提出要求而定。

要求類型 | 內容存在本機站台的儲存區內 | 內容存在遠端站台的儲存區內
初始回填 | 6 小時 | 12 小時
第一次回填重試 | 12 小時 | 24 小時
後續回填重試 | 24 小時 | 48 小時

若超過回填逾時，並且還是沒有取得更新，Exchange Server 2003 就會建立一或多個回填要求，並且判定要使用哪一部伺服器作為回填來源。

為了選取一部伺服器 (或者多部伺服器) 作為回填來源，Exchange Server 2003 會先建立一份具有資料夾複寫的所有伺服器清單，然後依據下列準則順序來排序清單：

  • 根據伺服器狀態排序 關機或無法使用的伺服器會排到清單尾端。

  • 根據偏好的回填伺服器排序 若有偏好的伺服器；此功能僅在 Exchange Server 2003 或更新版中才有提供。Exchange Server 2003 會在 Active Directory® 目錄服務中檢查公用資料夾儲存區物件，找出偏好的回填伺服器。這個設定很少用到。在大部分的情況下，如果 Exchange Server 2003 自動選取回填伺服器時，回填處理程序才最有效率。大部分的 Exchange Server 2003 部署，都不需要偏好的回填伺服器。Microsoft 產品支援服務可以提供一個指令碼，可於部署需要時設定偏好的回填伺服器。

  • 根據傳輸成本排序 (最低到最高) 位於相同站台內的伺服器，其優先順序高於遠端站台內的伺服器。伺服器的傳輸成本是由 Exchange Server 2003 路由引擎計算，通常是用來計算傳遞郵件的最有效方法。請注意，在 Exchange Server 2003 之前的 Exchange 版本中，傳輸成本的優先順序較低，並且會被放在 Exchange 版本和可用的變更數目之後才考慮。

  • 根據 Exchange 版本排序 (最新到最舊)

  • 根據伺服器上可用的必要變更數目排序 (最大到最小) 伺服器上若沒有所缺的變更，就會從清單中移除。

若某部伺服器沒有包含所有必要的變更，Exchange Server 2003 會選取已排序清單內的下一部伺服器，並且傳送回填要求至該伺服器。這個處理程序會一直重複進行，直到取得所有要求的變更為止。此功能只在 Exchange Server 2003 及更新版本中才可使用；前版 Exchange 會在沒有單一伺服器保有特定資料夾的所有遺失更新時，傳送回填要求到一部伺服器。在每一項要求之後，先前的 Exchange 版本都會等到過了重試逾時 (從 24 到 48 小時) 之後，才會傳送下一個要求。

若選取的伺服器沒有回應回填要求，則儲存區會將該伺服器標示為離線，並且重複選擇程序。被標示為離線的伺服器會移至清單尾端。

Replication Long Backfill Request Timeout Retry 值代表在先前傳送回填要求以取得相同站台內的資料失敗後，再次傳送要求時公用資料夾儲存區所使用的逾時值。值 (以秒為單位) 必須介於 900 到 2592000 秒之間 (30 天)；預設值為 172800 秒 (48 小時)。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要重設 Replication Long Backfill Request Timeout Retry 登錄機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>

  3. 檢查或編輯 Replication Long Backfill Request Timeout Retry 的值。

    此登錄項目的值是秒數。若要還原為預設值，您應該刪除 Replication Long Backfill Request Timeout Retry，然後重新啟動 Microsoft Exchange Information Store 服務。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關公用資料夾複寫的詳細資訊，請參閱《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595) 中的＜控制 Exchange Server 2003 公用資料夾複寫＞(英文)。


已啟用啟動時複寫郵件
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

MicrosoftR Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已將 Exchange 設為產生公用資料夾階層的狀態要求郵件：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Public-<Public Information Store GUID>\Enable Replication Messages At Startup

如果 Exchange Server Analyzer 發現 Enable Replication Messages At Startup 登錄項目存在且已設定，則會顯示非預設的組態訊息。

在 Exchange Server 5.5 中，具有公用資料夾儲存區的每個電腦每晚都會傳送狀態要求郵件，以判定公用資料夾階層的狀態。Exchange 2000 Server 及 Exchange Server 2003 則不會這樣做。一般而言，在 Exchange 2000 Server 及 Exchange Server 2003 中，只會在公用資料夾儲存區的存留時間期間送出狀態要求郵件一次；該郵件是在建立儲存區時送出。

然而，在特定情況下，您可能需要產生狀態要求郵件。例如，如果 Exchange 2000 Server 或 Exchange Server 2003 電腦上的公用資料夾階層似乎未進行複寫，或公用資料夾階層複寫的速度很慢，產生狀態要求郵件可讓公用資料夾階層複寫繼續進行。如果已丟棄且永不會認可在建立公用資料夾儲存區時所送出的原始狀態要求郵件，或如果傳送到伺服器的郵件具有十分不完整的階層，則公用資料夾階層複寫可能會發生問題。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要檢視或修改 Aging Keep Time 登錄值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Public-<Public Information Store GUID>

  3. 檢查或視需要變更 Enable Replication Messages At Startup 值。此 REG_DWORD 值必須設為 1 才會生效。如果您將值設為 0 (預設設定)，則在啟動公用資訊儲存庫時不會送出任何狀態要求郵件。

  4. 如果做了變更，請關閉登錄編輯程式，然後在卸載公用資訊儲存庫後再重新裝載它，讓變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關公用資料夾複寫狀態郵件及 Enable Replication Messages At Startup 登錄值的詳細資訊，請參閱下列知識庫文件：

  • 321082＜XADM：如何在 Exchange 2000 Server 中傳送複寫狀態要求郵件＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=321082)

  • 842273＜如何疑難排解 Exchange 2000 Server 及 Exchange Server 2003 中的公用資料夾複寫問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=842273)


Replication Short Backfill Request Delay 值已變更
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已將 Replication Short Backfill Request Delay 機碼修改為預設值以外的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Short Backfill Request Delay

如果 Exchange Server Analyzer 發現 Replication Short Backfill Request Delay 存在，就會顯示非預設的組態訊息。

在預設的情況下，Replication Short Backfill Request Delay 並不存在。當公用資料夾儲存區判定本身未收到某個複寫資料夾 (或階層) 的全部更新，並且必須從其他儲存庫擷取遺漏的更新時，就會發生回填。

為了簡化回填處理程序，Exchange Server 會將關於所遺漏更新的資訊儲存在回填陣列中。回填陣列會將此項資訊儲存一段指定的時間 (稱為回填逾時)。若遺漏的更新在這段時間內，於後續的複寫郵件中抵達，就會從回填陣列中移除這些資訊。下表列出預設的回填逾時值，這個值是視所遺漏更新的位置，以及先前是否曾經提出要求而定。

要求類型 | 內容存在本機站台的儲存區內 | 內容存在遠端站台的儲存區內
初始回填 | 6 小時 | 12 小時
第一次回填重試 | 12 小時 | 24 小時
後續回填重試 | 24 小時 | 48 小時

若超過回填逾時，並且還是沒有取得更新，Exchange Server 2003 就會建立一或多個回填要求，並且判定要使用哪一部伺服器作為回填來源。

為了選取一部伺服器 (或者多部伺服器) 作為回填來源，Exchange Server 2003 會先建立一份具有資料夾複寫的所有伺服器清單，然後依據下列準則順序來排序清單：

  • 根據伺服器狀態排序 關機或無法使用的伺服器會排到清單尾端。

  • 根據偏好的回填伺服器排序 若有偏好的伺服器；此功能僅在 Exchange Server 2003 或更新版中才有提供。Exchange Server 2003 會在 Active Directory® 目錄服務中檢查公用資料夾儲存區物件，找出偏好的回填伺服器。這個設定很少用到。在大部分的情況下，如果 Exchange Server 2003 自動選取回填伺服器時，回填處理程序才最有效率。大部分的 Exchange Server 2003 部署，都不需要偏好的回填伺服器。Microsoft 產品支援服務可以提供一個指令碼，可於部署需要時設定偏好的回填伺服器。

  • 根據傳輸成本排序 (最低到最高) 位於相同站台內的伺服器，其優先順序高於遠端站台內的伺服器。伺服器的傳輸成本是由 Exchange Server 2003 路由引擎計算，通常是用來計算傳遞郵件的最有效方法。請注意，在 Exchange Server 2003 之前的 Exchange 版本中，傳輸成本的優先順序較低，並且會被放在 Exchange 版本和可用的變更數目之後才考慮。

  • 根據 Exchange 版本排序 (最新到最舊)

  • 根據伺服器上可用的必要變更數目排序 (最大到最小) 伺服器上若沒有所缺的變更，就會從清單中移除。

若某部伺服器沒有包含所有需要的變更，Exchange Server 2003 會選取已排序清單內的下一部伺服器，並且傳送回填要求至該伺服器。這個處理程序會一直重複進行，直到取得所有要求的變更為止。此功能只在 Exchange Server 2003 及更新版本中才可使用；前版 Exchange 會在沒有單一伺服器保有特定資料夾的所有遺失更新時，傳送回填要求到一部伺服器。在每一項要求之後，先前的 Exchange 版本都會等到過了重試逾時 (從 24 到 48 小時) 之後，才會傳送下一個要求。

若選取的伺服器沒有回應回填要求，則儲存區會將該伺服器標示為離線，並且重複選擇程序。被標示為離線的伺服器會移至清單尾端。

Replication Short Backfill Request Delay 值代表在嘗試傳送回填要求來取得相同 Exchange 網站中的資料時，公用資料夾儲存區所延遲的時間。值 (以秒為單位) 必須介於 900 到 2592000 秒之間 (30 天)；預設值為 21600 秒 (6 小時)。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要重設 Short Backfill Request Delay 登錄機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>

  3. 檢查或編輯 Replication Short Backfill Request Delay 的值。

    此登錄項目的值是秒數。若要還原為預設值，您應刪除 Replication Short Backfill Request Delay，然後重新啟動 Microsoft Exchange Information Store 服務。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關公用資料夾複寫的詳細資訊，請參閱《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595) 中的＜控制 Exchange Server 2003 公用資料夾複寫＞(英文)。


Replication Short Backfill Request Timeout 值已變更
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已修改 Replication Short Backfill Request Timeout 機碼的預設值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Short Backfill Request Timeout

如果 Exchange Server Analyzer 發現有 Replication Short Backfill Request Timeout，就會顯示一則非預設的組態訊息。

在預設的情況下，Replication Short Backfill Request Timeout 不存在。當公用資料夾儲存區判定本身未收到某個複寫資料夾 (或階層) 的全部更新，並且必須從其他儲存區擷取遺漏的更新時，就會發生回填。

為了簡化回填處理程序，Exchange Server 會將關於所遺漏更新的資訊儲存在回填陣列中。回填陣列會將此項資訊儲存一段指定的時間 (稱為回填逾時)。若遺漏的更新在這段時間內，於後續的複寫郵件中抵達，就會從回填陣列中移除這些資訊。下表列出預設的回填逾時值，這個值是視所遺漏更新的位置，以及先前是否曾經提出要求而定。

要求類型 | 內容存在本機站台的儲存區內 | 內容存在遠端站台的儲存區內
初始回填 | 6 小時 | 12 小時
第一次回填重試 | 12 小時 | 24 小時
後續回填重試 | 24 小時 | 48 小時

若超過回填逾時，並且還是沒有取得更新，Exchange Server 2003 就會建立一或多個回填要求，並且判定要使用哪一部伺服器作為回填來源。

為了選取一部伺服器 (或者多部伺服器) 作為回填來源，Exchange Server 2003 會先建立一份具有資料夾複寫的所有伺服器清單，然後依據下列準則順序來排序清單：

  • 根據伺服器狀態排序 關機或無法使用的伺服器會排到清單尾端。

  • 根據偏好的回填伺服器排序 若有偏好的伺服器；此功能僅在 Exchange Server 2003 或更新版中才有提供。Exchange Server 2003 會在 Active Directory® 目錄服務中檢查公用資料夾儲存區物件，找出偏好的回填伺服器。這個設定很少用到。在大部分的情況下，如果 Exchange Server 2003 自動選取回填伺服器時，回填處理程序才最有效率。大部分的 Exchange Server 2003 部署，都不需要偏好的回填伺服器。Microsoft 產品支援服務可以提供一個指令碼，可於部署需要時設定偏好的回填伺服器。

  • 根據傳輸成本排序 (最低到最高) 位於相同站台內的伺服器，其優先順序高於遠端站台內的伺服器。伺服器的傳輸成本是由 Exchange Server 2003 路由引擎計算，通常是用來計算傳遞郵件的最有效方法。請注意，在 Exchange Server 2003 之前的 Exchange 版本中，傳輸成本的優先順序較低，並且會被放在 Exchange 版本和可用的變更數目之後才考慮。

  • 根據 Exchange 版本排序 (最新到最舊)

  • 根據伺服器上可用的必要變更數目排序 (最大到最小) 伺服器上若沒有所缺的變更，就會從清單中移除。

若某部伺服器沒有包含所有需要的變更，Exchange Server 2003 會選取已排序清單內的下一部伺服器，並且傳送回填要求至該伺服器。這個處理程序會一直重複進行，直到取得所有要求的變更為止。此功能只在 Exchange Server 2003 及更新版本中才可使用；前版 Exchange 會在沒有單一伺服器保有特定資料夾的所有遺失更新時，傳送回填要求到一部伺服器。在每一項要求之後，先前的 Exchange 版本都會等到過了重試逾時 (從 24 到 48 小時) 之後，才會傳送下一個要求。

若選取的伺服器沒有回應回填要求，則儲存區會將該伺服器標示為離線，並且重複選擇程序。被標示為離線的伺服器會移至清單尾端。

Replication Short Backfill Request Timeout 值代表在嘗試傳送回填要求以取得相同 Exchange 站台內的可用資料時，公用資料夾儲存區使用的逾時值。值 (以秒為單位) 必須介於 900 到 2592000 秒之間 (30 天)；預設值為 43200 秒 (12 小時)。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要重設 Replication Short Backfill Request Timeout 登錄機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>

  3. 檢查或編輯 Replication Short Backfill Request Timeout 的值。

    此登錄項目的值是秒數。若要還原為預設值，您應刪除 Replication Short Backfill Request Timeout，然後重新啟動 Microsoft Exchange Information Store 服務。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關公用資料夾複寫的詳細資訊，請參閱《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595) 中的＜控制 Exchange Server 2003 公用資料夾複寫＞(英文)。


Replication Short Backfill Request Timeout Retry 值已變更
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已將 Replication Short Backfill Request Timeout Retry 機碼修改為預設值以外的值。

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Short Backfill Request Timeout Retry

如果 Exchange Server Analyzer 發現有 Replication Short Backfill Request Timeout Retry，就會顯示非預設的組態訊息。

在預設的情況下，Replication Short Backfill Request Timeout Retry 不存在。當公用資料夾儲存區判定本身未收到某個複寫資料夾 (或階層) 的全部更新，並且必須從其他儲存區擷取遺漏的更新時，就會發生回填。

為了簡化回填處理程序，Exchange Server 會將關於所遺漏更新的資訊儲存在回填陣列中。回填陣列會將此項資訊儲存一段指定的時間 (稱為回填逾時)。若遺漏的更新在這段時間內，於後續的複寫郵件中抵達，就會從回填陣列中移除這些資訊。下表列出預設的回填逾時值，這個值是視所遺漏更新的位置，以及先前是否曾經提出要求而定。

要求類型 | 內容存在本機站台的儲存區內 | 內容存在遠端站台的儲存區內
初始回填 | 6 小時 | 12 小時
第一次回填重試 | 12 小時 | 24 小時
後續回填重試 | 24 小時 | 48 小時

若超過回填逾時，並且還是沒有取得更新，Exchange Server 2003 就會建立一或多個回填要求，並且判定要使用哪一部伺服器作為回填來源。

為了選取一部伺服器 (或者多部伺服器) 作為回填來源，Exchange Server 2003 會先建立一份具有資料夾複寫的所有伺服器清單，然後依據下列準則順序來排序清單：

  • 根據伺服器狀態排序 關機或無法使用的伺服器會排到清單尾端。

  • 根據偏好的回填伺服器排序 若有偏好的伺服器；此功能僅在 Exchange Server 2003 或更新版中才有提供。Exchange Server 2003 會在 Active Directory® 目錄服務中檢查公用資料夾儲存區物件，找出偏好的回填伺服器。這個設定很少用到。在大部分的情況下，如果 Exchange Server 2003 自動選取回填伺服器時，回填處理程序才最有效率。大部分的 Exchange Server 2003 部署，都不需要偏好的回填伺服器。Microsoft 產品支援服務可以提供一個指令碼，可於部署需要時設定偏好的回填伺服器。

  • 根據傳輸成本排序 (最低到最高) 位於相同站台內的伺服器，其優先順序高於遠端站台內的伺服器。伺服器的傳輸成本是由 Exchange Server 2003 路由引擎計算，通常是用來計算傳遞郵件的最有效方法。請注意，在 Exchange Server 2003 之前的 Exchange 版本中，傳輸成本的優先順序較低，並且會被放在 Exchange 版本和可用的變更數目之後才考慮。

  • 根據 Exchange 版本排序 (最新到最舊)

  • 根據伺服器上可用的必要變更數目排序 (最大到最小) 伺服器上若沒有所缺的變更，就會從清單中移除。

若某部伺服器沒有包含所有必要的變更，Exchange Server 2003 會選取已排序清單內的下一部伺服器，並且傳送回填要求至該伺服器。這個處理程序會一直重複進行，直到取得所有要求的變更為止。此功能只在 Exchange Server 2003 及更新版本中才可使用；前版 Exchange 會在沒有單一伺服器保有特定資料夾的所有遺失更新時，傳送回填要求到一部伺服器。在每一項要求之後，先前的 Exchange 版本都會等到過了重試逾時 (從 24 到 48 小時) 之後，才會傳送下一個要求。

若選取的伺服器沒有回應回填要求，則儲存區會將該伺服器標示為離線，並且重複選擇程序。被標示為離線的伺服器會移至清單尾端。

Replication Short Backfill Request Timeout Retry 值代表在先前傳送回填要求以取得相同站台內的資料失敗後，再次傳送要求時公用資料夾儲存區所使用的逾時值。值 (以秒為單位) 必須介於 900 到 2592000 秒之間 (30 天)；預設值為 86400 秒 (24 小時)。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要重設 Short Backfill Request Timeout Retry 登錄機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>

  3. 檢查或編輯 Replication Short Backfill Request Timeout Retry 的值。

    此登錄項目的值是秒數。若要返回到預設值，您應刪除 Replication Short Backfill Request Timeout Retry，然後重新啟動 Microsoft Exchange Information Store 服務。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關公用資料夾複寫的詳細資訊，請參閱《使用 Exchange Server 2003 儲存區》(http://go.microsoft.com/fwlink/?LinkId=47595) 中的＜控制 Exchange Server 2003 公用資料夾複寫＞(英文)。


保留增加大小設定
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-30

MicrosoftR Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已設定 Reserve Increment KB 的值：HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定物件類別為 msExchExchangeServer 之所有物件的 serialNumber 屬性值。若字串值包含 Version 5.5，表示電腦執行的是 Microsoft Exchange Server 5.5。若字串值包含 Version 6.0，表示電腦執行的是 Microsoft Exchange 2000 Server。如果字串值包含 "Version 6.5"，表示電腦執行的是 Microsoft Exchange Server 2003。如果字串值包含 "Version 8.0"，則表示電腦執行的是 Microsoft Exchange Server 2007。

如果 Exchange Server Analyzer 發現執行 Exchange Server 2003 的電腦上存在 Reserve Increment KB 登錄值，就會顯示非預設的組態訊息。

Reserve Increment KB 登錄值會覆寫 Microsoft Windows® 中的原生記憶體堆集值。Windows 包含與整個處理程序有關的堆集管理員，該管理員會處理所有處理程序的記憶體作業。每次處理程序產生實體時，便會為該處理程序建立預設堆集 (稱為處理程序堆集)。處理程序中所載入的程式或模組也可以建立其他堆集 (需要時)。需要時，Microsoft Exchange Information Store 服務 (Store.exe) 是建立其他堆集的處理程序範例。在預設的情況下，Store.exe 會將保留給堆集空間的初始記憶體設為實體 RAM 的 20%。Reserve Increment KB 值會將保留給堆集的初始記憶體變更為實體記憶體的 10%。

在有限制的情況下，Reserve Increment KB 登錄值才有用。此外，只有在 Microsoft 產品支援服務的建議及指示下才可設定此值。錯誤的設定或不正確地使用此值會導致效能降低，而且會加速虛擬記憶體的分散程度。如果在未詢問 Microsoft 產品支援服務的情況下設定此值，請考慮使用下列程序來移除它。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右窗格中，刪除 Reserve Increment KB 值。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

若需有關如何調整 Exchange Server 2003 的詳細資訊，請參閱下列微軟知識庫文件：

  • 325044＜HOW TO:疑難排解 Exchange 2003 及 Exchange 2000 的虛擬記憶體分散＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372＜如何將 Exchange Server 2003 中的記憶體使用量最佳化＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


RPC 緩衝區封裝已停用
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄機碼，以判定是否已停用遠端程序呼叫 (RPC) 緩衝區封裝：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc Packing Enabled

如果 Exchange Server Analyzer 發現 Rpc Packing Enabled 登錄機碼的數值資料已設為 0，則 Exchange Server Analyzer 會顯示非預設的組態訊息。Rpc Packing Enabled 登錄機碼在其數值資料設為 0 時會停用。

Rpc Packing Enabled 登錄機碼的數值資料，是系統管理員可新增之三個登錄項目的其中一個項目，以設定 Microsoft Office Outlook® 2003 與 Exchange Server 2003 之間的 RPC 壓縮。

Outlook 2003 可要求 96 KB 的資料緩衝區。然而，在 Exchange Server 2003 壓縮資料之後，資料緩衝區可能明顯小於 Outlook 2003 所要求的大小。

Exchange Server 2003 支援緩衝區封裝，以支援各種壓縮比率並讓緩衝區充滿以達到最大效率。

啟用 Rpc Packing Enabled 登錄機碼時，Exchange Server 2003 會繼續將壓縮的資料新增至緩衝區，直至緩衝區已滿。對於每個資料要求，與舊版 Outlook 相比，Outlook 2003 可下載的資料量明顯增加，其原因如下：

  • Outlook 2003 要求更大的緩衝區大小。

  • Exchange Server 2003 支援緩衝區封裝。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要採取任何動作。不過，如果您想要還原到預設的組態，可以刪除 Rpc Packing Enabled 登錄機碼。您還可以將 Rpc Packing Enabled 登錄機碼的數值資料設為 1，以啟用 RPC 緩衝區封裝。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定您瞭解如何在發生問題時還原登錄。若需如何還原登錄的相關資訊，請檢視 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
還原預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

    • 若要刪除項目，請刪除 [Rpc Packing Enabled] 值。

    • 若要保留該項目並啟用 RPC 緩衝區封裝，請連按兩下 [Rpc Packing Enable]，將值設為 1，再按一下 [確定]。

  3. 關閉登錄編輯程式。

Microsoft Exchange Information Store 服務會馬上偵測變更。您不需重新啟動電腦。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關設定登錄機碼以設定 Outlook 用戶端與 Exchange Server 2003 之間 RPC 壓縮的詳細資訊，請參閱知識庫文件 - 825371＜在 Exchange Server 2003 中修改遠端程序呼叫壓縮＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=825371)。


RPC 壓縮最小大小並非預設值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定遠端程序呼叫 (RPC) 壓縮的最小封包大小：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc Compression Minimum Size

如果 Exchange Server Analyzer 發現 Rpc Compression Minimum Size 值大於 0，就會顯示非預設的組態訊息。

根據預設，不管大小為何，所有在 Microsoft Office Outlook® 2003 或 Outlook 2007 及 Exchange Server 2003 或 Exchange Server 2007 間移動的 RPC 資料都會經過壓縮。在某些案例中，您可能會想要控制 RPC 壓縮。例如，如果您要藉由檢視透過網路傳送的封包來嘗試疑難排解連線問題，RPC 壓縮可能會使得分析變得困難，因為您只會在追蹤中看見壓縮的資料。

若要設定 RPC 壓縮設定，您可以新增三個登錄機碼值到系統設定中：

  • Rpc Compression Minimum Size

  • Rpc Compression Enabled

  • Rpc Packing Enabled

Rpc Compression Minimum Size 登錄值可決定在啟動壓縮之前，RPC 封包中所需位元組的最小數目。如果此機碼不存在，則會使用預設值 1,024 個位元組。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 刪除 Rpc Compression Minimum Size 機碼。如果 Rpc Compression Enabled 及 Rpc Packing Enabled 機碼存在，請一併刪除。

  4. 關閉登錄編輯程式，然後重新啟動 Exchange 伺服器，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關控制 RPC 壓縮的詳細資訊，請參閱知識庫文件 - 825371＜在 Exchange Server 2003 中修改遠端程序呼叫壓縮＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=825371)。


RpcEtwTracing 參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄機碼，以判定數值資料：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\RpcEtwTracing

如果 Exchange Server Analyzer 發現 RpcEtwTracing 登錄機碼的數值資料已設為 1，就會顯示非預設的組態訊息。

RpcEtwTracing 登錄機碼的數值資料僅用於疑難排解 Microsoft Office Outlook® 2003 與 Exchange Server 之間的網路問題。如果您目前未對問題進行疑難排解，建議您停用 RpcEtwTracing 登錄機碼。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要採取任何動作。不過，如果您想要還原到預設的組態，可以刪除 RpcEtwTracing 登錄機碼。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定您瞭解如何在發生問題時還原登錄。若需如何還原登錄的相關資訊，請檢視 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
還原預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 刪除 RpcEtwTracing 值。

  4. 關閉登錄編輯程式。

Microsoft Exchange Information Store 服務會馬上偵測變更。您不需重新啟動電腦。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


伺服器的儲存群組少於四個但定義的信箱儲存區多於四個
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以計算執行 Exchange Server 2003 之伺服器上的 StorageGroup 物件及 MailboxGroup 物件的數目。如果 Exchange Server Analyzer 判定 StorageGroup 物件的總數少於四個，但 MailboxStore 物件的總數多於四個，就會顯示錯誤。

如果您是在使用 Exchange Server 2003 Standard Edition，則每個 Exchange Server 電腦都可以具有一個儲存群組，該儲存群組可支援一個信箱儲存區及一個公用資料夾儲存區。如果您是在使用 Exchange Server 2003 Enterprise Edition，則每個伺服器同樣可以具有四個儲存群組，但每個群組可支援五個資料庫 (無論是信箱儲存區還是公用資料夾儲存區)。

為執行 Exchange Server 2003 Enterprise Edition 的電腦設定儲存群組的建議最佳作法是：為每個新資料庫各額外新增一個儲存群組，直到建立了最大數目的儲存群組為止。您可以將 Exchange Server 儲存拓撲中的信箱負載儘量分散到許多儲存群組中。此類拓撲有下列優點：

  • 儲存拓撲的可靠性得到增強。

  • 儲存拓撲的恢復能力得到增強。

  • 可以更好的管理磁碟機 I/O。

如果您在執行 Exchange Server 2003 Enterprise Edition 的伺服器上具有的儲存群組少於四個但信箱儲存區多於四個，請採取下列步驟以儘量讓信箱分散到大部分儲存群組中。

若要解決此錯誤

  1. 在 [Exchange 系統管理員] 中，選取報告此錯誤的伺服器。記下該伺服器上的儲存群組及信箱儲存區數目。記下包含多個信箱儲存區的儲存群組。

  2. 額外建立任何儲存群組，直到您在執行 Exchange Server 2003 Enterprise Edition 的電腦上有四個儲存群組為止。若需有關如何建立新儲存群組的詳細資訊，請參閱《Exchange Server 2003 系統管理手冊》(http://go.microsoft.com/fwlink/?LinkId=47617) 中的＜新增儲存群組＞(英文)。

  3. 在您所建立的每個新儲存群組中建立新信箱儲存區。若需有關如何建立新信箱儲存區的詳細資訊，請參閱《Exchange Server 2003 系統管理手冊》(http://go.microsoft.com/fwlink/?LinkId=47617) 中的＜新增信箱儲存區＞(英文)。

  4. 將信箱從儲存群組所包含的多個信箱儲存區之一，移至新建立之儲存群組中的信箱儲存區。使用 [移動信箱精靈] 移動信箱。若需有關如何使用 [移動信箱精靈] 的詳細資訊，請參閱《Exchange Server 2003 部署手冊》(http://go.microsoft.com/fwlink/?LinkId=47569) 中＜從 Exchange Server 5.5 遷移到 Exchange Server 2003＞的＜使用 Exchange 工作精靈移動信箱＞(英文)。

若需有關如何在 Exchange Server 2003 中設定儲存群組的詳細資訊，請參閱微軟知識庫文件 - 890699＜如何在 Exchange Server 2003 中設定儲存群組＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=890699)。

若需有關設定儲存群組的詳細資訊，請參閱《Exchange Server 2003 高可用性手冊》(http://go.microsoft.com/fwlink/?LinkId=47571) 中＜規劃可靠的後端儲存解決方案＞中的儲存群組設定一節 (英文)。

若需有關協助您最大化可用性、容錯及效能的整體建議，請參閱《最佳化 Exchange Server 2003 的儲存》(英文) (http://go.microsoft.com/fwlink/?LinkId=49324)。


資料庫與資料流檔案間簽章不一致
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具判斷 Exchange 資料庫 (.edb) 檔案與其對應的 Exchange 資料流資料庫 (.stm) 檔案間簽章不一致。

Exchange 2000 Server 與 Exchange Server 2003 中每個資料庫都由兩個檔案組成：.edb MAPI 資料庫檔案及 .stm 資料流資料庫檔案。這些對應的成對檔案共用相同的資料庫簽章。如果資料庫簽章不相符，檔案即不是對應的檔案。

您應將 .edb 與 .stm 檔案當成一個檔案來看待。它們應永遠一同移動或複製。

若要更正此錯誤

  • 調查資料庫檔案的歷程記錄。檔案可能被手動複製、移動或刪除。您必須先更正此問題，才能復原資料庫。

  • 如果您找不到對應的 .edb 與 .stm 檔案，可能可以使用 Eseutil.exe，它只能修復 .edb 檔案，然後使用 Eseutil 加上 /createstm 參數來捨棄 .stm 檔案。此方法會造成資料流資料庫中的所有資訊遺失。

    附註：
    如果所有資料庫使用者都是使用 MAPI 用戶端 (如 Microsoft Office Outlook®) 連線至資料庫，則儲存於資料流資料庫中的資訊非常少。如果使用者是使用 POP3、IMAP 或 Outlook Web Access 用戶端連線至資料庫，則資料流資料庫包含使用者信箱的部分或全部內容。

若需如何修復 Exchange 資料庫的詳細資訊，請參閱微軟知識庫文件 - 812357＜使用 Eseutil /p 工具修復 Exchange 資料庫後的維護工作＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812357)。


預設收件者原則中未定義 SMTP 地址
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2006-12-03

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已在 Exchange Server 組織中預設收件者原則的 gatewayProxy 屬性上指定 SMTP 地址。如果 Exchange Server Analyzer 發現 gatewayProxy 屬性不含 SMTP 地址，就會顯示錯誤。

這是很嚴重的錯誤。您必須將 SMTP 地址 (如 SMTP:@contoso.com) 新增到 Exchange Server 組織中預設收件者原則的 gatewayProxy 屬性中。預設收件者原則必須包含 SMTP 地址。如果預設收件者原則不包含 SMTP 地址，Microsoft Exchange Information Store 服務在重新啟動後將不會初始化。在下一次重新啟動 Microsoft Exchange Information Store 服務之後，此失敗將出現在 Exchange Server 組織中的所有 Exchange 伺服器中。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或 Exchange Server 2007，或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
將 SMTP 地址新增到預設收件者原則的 gatewayProxy 屬性

  1. 從 Microsoft Windows® 2000 支援工具或 Windows Server 2003 支援工具啟動 ADSI 編輯器工具。

  2. 展開下列節點：

    • 組態容器

    • 組態

    • 服務

    • Microsoft Exchange

    • Organization_Name

    • 收件者原則

  3. 在詳細資料窗格中，以滑鼠右鍵按一下 [CN=Default Policy]，再按一下 [內容]。

  4. 在 [屬性] 方塊中，連按兩下 [gatewayProxy]。

  5. 在 [多重值字串編輯器] 對話方塊中，於 [新增的值] 欄位中輸入 SMTP:@domain_name.com，然後按一下 [新增]。

    附註：
    您輸入的語法很重要。您必須先包括 SMTP:@，才可以輸入 Exchange Server 組織的網域名稱。在此字串中不包括空白。

  6. 按一下 [確定]，再按 [套用]，然後關閉 [ADSI 編輯器]。

  7. 等待 15 分鐘以進行複寫。


儲存區 RPC prorate 登錄參數未設為正確值
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取三個登錄機碼，以判定是否已將其值修改為預設值以外的值。所有這三個機碼都是 DWORD 值，您可以在下列位置找到它們：

HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Image File Execution Options\STORE.EXE\RpcThreadPoolThrottle

這些登錄機碼具有下列名稱和預設值：

DWORD 值 預設十進位值
  • ProrateStart
  • 40
  • ProrateMax
  • 10,000
  • ProrateFactor
  • 100

如果 Exchange Server Analyzer 發現上述預設值已有變更，就會顯示一則非預設的組態訊息。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原成預設值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\Software\Microsoft\WindowsNT\CurrentVersion\Image File Execution Options\STORE.EXE\RpcThreadPoolThrottle

  3. 在右窗格中，連按兩下其值已變更的項目，並設定其預設值。

  4. 如果已變更的值超過一個，請重複步驟 3。

  5. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關儲存區處理程序執行緒的詳細資訊，請參閱知識庫文件 - 267255＜Store.exe 執行緒耗盡了可用的記憶體＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=267255)。


儲存區工作目錄遺失或不正確
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-30

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以驗證 Microsoft Exchange Information Store 服務的工作目錄。

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Working Directory

若下列條件存在，Exchange Server Analyzer 便會顯示警告：

  • 指定為「工作目錄」的目錄不存在。

  • 您正在執行 Exchange 2000 Server、Exchange Server 2003 或 Exchange Server 2007。

Exchange Server 使用工作目錄作為暫時儲存區。例如，Exchange Server 會在訊息轉換程序中使用工作目錄。Exchange Server 也會在磁碟重組期間使用工作目錄來儲存暫存資料庫。若未正確指定工作目錄，可能會產生下列問題：

  • 含附件的郵件會在 SMTP 本機傳遞佇列中建立。

  • 接收到的郵件沒有附件。

  • 無法順利傳遞郵件。

根據預設，Exchange 2000 Server 及 Exchange Server 2003 會將工作目錄設為 Exchange Server 安裝目錄下的中繼資料目錄。例如，若您將 Exchange Server 安裝在 C:\Program Files\Exchsrvr 目錄中，Exchange Server 就會將工作目錄設定為 C:\Program Files\Exchsrvr\mdbdata。

根據預設，Exchange Server 2007 會將工作目錄設為 Exchange Server 安裝目錄下的信箱資料庫目錄。例如，若您將 Exchange Server 安裝在 C:\Program Files\Exchange Server 目錄中，Exchange Server 2007 就會將工作目錄設為 C:\ Program Files\Exchange Server\Mailbox\MDBTemp。

若要更正這項警告，請將工作目錄指定為 Exchange 伺服器上存在的目錄。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定您瞭解如何在發生問題時還原登錄。若需如何還原登錄的相關資訊，請檢視 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
使用 regedit 指定工作目錄

  1. 啟動登錄編輯程式 (regedit)。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 以 Microsoft Exchange Information Store 服務的正確工作目錄 (如 C:\Program Files\Exchsrvr\mdbdata)，來更新 Working Directory 登錄值。

    附註：
    這項變更不需重新啟動 Microsoft Exchange Information Store 服務即可生效。

  4. 關閉登錄編輯程式。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Working Directory 登錄值的詳細資訊，請參閱知識庫文件 - 298415＜有附件的郵件未如預期般被傳送，並在 Exchange 2000 Server 及 Exchange Server 2003 中記錄事件識別碼 12003 與 327 訊息＞(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=298415)。


對已設定的通訊群組清單隱藏郵件答錄機訊息
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-02-27

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判斷是否已對通訊群組清單隱藏郵件答錄機訊息：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\SuppressOOFsToDistributionLists

如果 Exchange Server Analyzer 發現 SuppressOOFsToDistributionLists 的值大於 0，就會顯示非預設的組態訊息。

將郵件寄送至已啟用 [郵件答錄機助理員] 的信箱時，寄件者會收到 [收件者] 或 [副本] 欄位中沒有地址的郵件，但是此郵件的 [密件副本] 欄位中卻有通訊群組清單，郵件答錄機訊息便會寄送至 [密件副本] 欄位中的通訊群組清單。

如果已將郵件寄送給收件者，而收件者的地址僅出現在 [密件副本] 欄位，但不在通訊群組清單中，而且收件者已啟動 [郵件答錄機助理員]，即使已設定 SuppressOOFsToDistributionLists 登錄值，收件者的信箱儲存區仍然會寄送郵件答錄機訊息。此限制只適用於收件者的地址出現在 [密件副本] 欄位中，且 [收件者] 及 [副本] 欄位均空白時。如果 [收件者] 或 [副本] 欄位中至少有一位使用者，則 Exchange Server 電腦上的登錄參數將會讓列在 [密件副本] 欄位中的收件者無法產生郵件答錄機訊息。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

修改郵件答錄機訊息產生行為

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在 ParametersSystem 上按一下滑鼠右鍵，指向 [新增]，然後按一下 [DWORD 值]。

  4. 替新值 SuppressOOFsToDistributionLists 命名。

  5. 在 SuppressOOFsToDistributionLists 上按一下滑鼠右鍵，再按一下 [修改]。

  6. 在 [數值資料] 方塊中，輸入 1，再按一下 [確定]。

  7. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 SuppressOOFsToDistributionLists 登錄值的詳細資訊，請參閱知識庫文件 - 825370＜將郵件答錄機訊息傳送至 [密件副本] 欄位中的通訊群組清單＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=825370)。


控制損毀郵件可通過儲存區次數之閾值已經變更
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-08

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 PoisonThreshold 的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<ExchangeServerName> \Private- <PrivateInformationStoreGUID>

如果 Exchange Server Analyzer 判定 PoisonThreshold 的值不等於 2，就會顯示一則非預設的組態訊息。

Exchange Server 2003 Service Pack 1 以後的 Exchange Server 版本實作了一項功能，可幫助防止損毀或不當郵件導致 Microsoft Exchange Information Store 服務突然停止，或是阻礙 Microsoft Exchange Information Store 服務順利啟動。

在 Exchange Server 2003 Service Pack 1 或更新的版本中，會追蹤在 MAPI 格式轉換為 MIME 格式期間，導致 Microsoft Exchange Information Store 服務異常停止的郵件。發生當機時，損毀郵件的郵件識別碼會儲存在登錄中。若有損毀的郵件導致儲存區異常停止三次，則當 Microsoft Exchange Information Store 服務於第四次重新啟動時，就會使用此項資訊來防止再次處理該郵件。

當 Microsoft Exchange Information Store 服務因為損毀的郵件而異常停止時，就會在以下位置建立 PoisonIDs 登錄值：

HKLM\System\CurrentControlSet\Services\MSExchangeIS \<ExchangeServerName> \Private- <PrivateInformationStoreGUID>

此外，系統管理員可以建立 PoisonThreshold 登錄項目。PoisonThreshold 機碼會控制在將郵件加入 PoisonIDs 登錄機碼之前，可允許郵件通過 Exchange 資訊儲存庫的次數上限。在預設的情況下，此閥值是 2。閥值必須已超過，才會觸發此行為。因此，在因損毀的郵件而停止 3 次後，Microsoft Exchange Information Store 服務才會封鎖該郵件。例如，若郵件和 3 次當機有關，則該郵件就會被封鎖，因為 3 已超過閥值 2。

當損毀的郵件事件被寫入登錄時，[應用程式] 事件日誌中，就會出現錯誤事件訊息 (事件 ID 9680 及 9681)。在 Microsoft Exchange Information Store 服務順利啟動後，Exchange 會封鎖該郵件，並嘗試為該郵件傳送一份未傳遞回報。在某些情況下，Exchange 可能無法傳送未傳遞回報。在這種情況下，被封鎖的郵件可能會一直留在佇列中，直到過期為止。PoisonIDs 登錄機碼最多可以保留 10 個郵件識別碼值。當超出 10 的限制時，且加入了一個新的損毀郵件事件，包含最舊當機日期的損毀郵件事件就會被移除。

附註：
個別損毀郵件的疑難排解步驟超出 Exchange Server Analyzer 的處理範圍。在某些情況下，Microsoft 產品支援服務可以協助您進行個別損毀郵件的疑難排解。如果您遇到 Exchange Server 2003 或更新的版本在關機方面的問題，且原因是郵件損毀，則在 Exchange Server 電腦上啟用自動化錯誤報告機能可能很有幫助。錯誤報告資料可以用來在您使用的軟體中，尋找以及更正問題。若需有關如何啟用 Exchange 錯誤報告的詳細資訊，請參閱＜已停用 Exchange 錯誤報告。

建議將 PoisonThreshold 的值變回其預設值 2。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ExchangeServerName>\Private-<PrivateInformationStoreGUID>

  3. 在右窗格中，連按兩下 PoisonThreshold。

  4. 在 [數值資料] 中，輸入 2 (十進位)，並按一下 [確定]。

  5. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


儲存區處理程序上已啟用追蹤
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會檢查登錄，以查看 Enable Tracing 登錄項目是否與 Trace User LegacyDN 登錄值同時存在。這兩個登錄值都存在於下列登錄機碼下：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

如果 Exchange Server Analyzer 發現這兩個登錄項目都存在且已予以設定，則會顯示警告。

Enable Tracing DWORD 登錄值可啟用 Microsoft Exchange Information Store 服務以進行追蹤。追蹤是用來疑難排解 Exchange 儲存區啟動問題，而且會嚴重影響效能。除非正在進行問題的疑難排解，否則請不要使用此登錄設定。新增 Trace User LegacyDN 登錄字串值，即可對特定使用者啟用追蹤 (篩選的追蹤)。如果 Trace User LegacyDN 值不存在，則會對所有使用者啟用追蹤。如果 Trace User LegacyDN 值存在，則會追蹤該機碼下所列的特定使用者。

如果未在 Exchange Server 電腦上執行疑難排解，則這些登錄值不應存在。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 刪除 Enable Tracing 及 Trace User LegacyDN 登錄值。

  4. 關閉登錄編輯程式，然後重新啟動電腦，以使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關在 Exchange 伺服器上以個別使用者為單位進行追蹤的詳細資訊，請參閱知識庫文件 - 296624＜Exchange 2000 Server Service Pack 2 (SP2) 新增以個別使用者為基礎的追蹤功能＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296624)。


已為 Microsoft Exchange Information Store 服務上的所有使用者啟用追蹤
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2007-01-17

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Enable Tracing 項目是否存在於下列位置：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

如果 Exchange Server Analyzer 發現 Enable Tracing 登錄值存在且已設定，就會顯示警告。

Enable Tracing DWORD 登錄值可以啟用 Microsoft Exchange Information Store 服務的追蹤。追蹤是用來疑難排解儲存區的啟動問題，可能會嚴重影響效能。除非您正在進行問題的疑難排解，否則不應使用此登錄設定。新增 Trace User LegacyDN 登錄字串值，即可對特定使用者啟用追蹤。如果此值不存在，則表示會對所有使用者啟用追蹤。

如果您沒有要在 Exchange Server 電腦上執行疑難排解，則此值不應存在。

附註：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需還原登錄的相關資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 開啟登錄編輯程式 (如 Regedit.exe 或 Regedt32.exe)

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 刪除 Enable Tracing 登錄值。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關在 Exchange 伺服器上以個別使用者為單位進行追蹤的詳細資訊，請參閱知識庫文件 - 296624＜Exchange 2000 Server Service Pack 2 (SP2) 新增以個別使用者為基礎的追蹤功能＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296624)。


交易記錄檔名稱用完
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會檢查伺服器磁碟機上的記錄檔，以驗證每個儲存群組之交易記錄檔的狀況良好。若要尋找記錄檔的位置，Exchange Server Analyzer 會查詢 Active Directory® 目錄服務。針對每個儲存群組物件 (類別 msExchStorageGroup)，記錄檔的檔案路徑存放在 msExchESEParamLogFilePath 屬性中。

交易記錄檔名稱包含用來識別記錄檔順序的十六進位序號。例如，預設「預設儲存群組」的第一個記錄檔名稱為 E0000001.log、第二個為 E0000002.log，以此類推。順序最高可到 E00FFFFF.log。Exchange 最多可建立 1,030,000 個唯一的記錄檔。然而，Exchange 到達順序結尾時，如果在到達限制後卸載受影響之儲存群組中的儲存區，就不會再裝載該儲存區。如果保持裝載狀態，則即使不會發生 Jet 作業，儲存區也不會卸載資料庫。一般而言，Exchange 會執行好幾年，才會到達此限制。

如果指定的伺服器已使用超過 950,000 個交易記錄檔，便會看到此警告訊息。

如果指定的伺服器已使用超過 1,020,000 個交易記錄檔，便會看到此錯誤訊息。

為在到達此限制時，可讓儲存區正確地卸載資料庫，已在 Exchange Server 2003 Service Pack 1 中納入修復程式。如微軟知識庫文件 - 830408＜雖然可用於儲存群組的全部交易記錄檔均已用完，但仍裝載 Exchange 資料庫儲存區＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830408) 中所述，Post-Service Pack 3 Hotfix 可用於 Exchange 2000 Server。

如果 Exchange 尚未達到 1,030,000 個交易記錄限制，請儘快對伺服器執行完整的線上備份。若需有關對 Exchange 儲存區執行完整線上備份的詳細資訊，請參閱《Exchange 2003 嚴重損壞修復操作手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47570)。

如果 Exchange 已到達此限制，您必須將所有現有的交易記錄移至其他位置。之後，會產生一個以 0x00001 開頭的新記錄檔順序。若要確保 Exchange 儲存區會正確地卸載資料庫，必須還要將適當的修復程式套用至您的 Exchange 版本。

附註：
移動交易記錄之前，必須驗證儲存群組中的所有資料庫均處於「正常關機」狀態。
重要事項：
執行完下面的程序後，先前所有的備份均會失效。這並不表示無法還原備份。但無法使用其他交易記錄向前復原備份。如果在移除交易記錄之後必須還原先前的備份，則您只能將資料還原至建立新記錄的時間。

若要解決此問題

  1. 若為 Exchange Server 2003，請安裝 Service Pack 1，可從 Exchange Server 下載網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=29090) 取得。

    - 或 -

    若為 Exchange 2000 Server，請取得並安裝微軟知識庫文件 - 830408＜雖然可用於儲存群組的全部交易記錄檔均已用完，但仍裝載 Exchange 資料庫儲存區＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830408) 中所參照的 Hotfix。

  2. 如果儲存群組的交易記錄檔已用完，請卸載所有資料庫。若要這樣做，請遵循下列步驟：

    1. 開啟 [Exchange 系統管理員]。

    2. 依序展開 [系統管理群組]、[<AdministrativeGroupName>]、[伺服器]、[<ServerName>] 及 [<StorageGroupName>]。

    3. 以滑鼠右鍵按一下此儲存群組中的第一個儲存區，再按 [卸載儲存區]。對此儲存群組中的每個儲存區重複此步驟。

  3. 驗證儲存群組中的每個資料庫均處於「正常關機」狀態。若要這樣做，請遵循下列步驟：

    1. 在 [Exchange 系統管理員] 中，以滑鼠右鍵按一下已用完交易記錄檔之儲存群組中的第一個儲存區，再按一下 [內容]。

    2. 按一下 [資料庫] 索引標籤，然後記下 Exchange 資料庫方塊及 Exchange 資料流資料庫方塊中資料庫檔案的路徑及檔案名稱。每個 Exchange 資料庫均由具有 .edb 副檔名及 .stm 副檔名的一組成對的檔案組成。對儲存群組中的每個儲存區重複此步驟。

    3. 在命令提示字元中，將目錄變更為 Exchange Server 的 bin 資料夾。例如，將目錄變更為 C:\Program Files\Exchsrvr\bin。

    4. 鍵入 Eseutil /mh DatabaseFileName，然後按 Enter 鍵。對儲存群組中的每個資料庫重複此步驟。此命令會顯示資料庫檔案標頭。標頭將包含下列兩行的其中一行：「狀態：正常關機」或「狀態：不正常關機」。

  4. 如果標頭包含「狀態：不正常關機」一行，則您在移除記錄檔之前，必須手動復原資料庫。若要這樣做，請遵循下列步驟：

    1. 在 [Exchange 系統管理員] 中，於用完交易記錄檔的儲存群組上按一下滑鼠右鍵，再按一下 [內容]。

    2. 按一下 [一般] 索引標籤，然後記下 [交易記錄位置] 方塊中交易記錄的路徑。

    3. 記下 [系統路徑位置] 方塊中檢查點檔案的路徑。

    4. 在命令提示字元中，將目錄變更為 Exchange Server 的 bin 資料夾。

    5. 鍵入下列命令，並按 [Enter] 鍵：Eseutil /r 3-CharacterLogfileBaseName /lDirectory:\LogfilePath /sDirectory:\CheckpointFilePath。

      附註：
      請勿在選項參數與目錄路徑之間鍵入空格。如果命令中所列之路徑中有拼寫錯誤，則復原會失敗。若要避免此錯誤，您可將檢查點檔案複製到交易記錄檔資料夾。在預設為記錄檔目錄的命令提示字元中，執行命令 Eseutil /r 3-CharacterLogfileBaseName。因為 /l 參數及 /s 參數預設為目前目錄，所以您不必提供記錄檔的路徑或檢查點檔案的路徑。
    6. 復原完成之後，請驗證在您移動交易記錄檔及檢查點檔案之前，所有資料庫檔案均處於「正常關機」狀態。如果您在資料庫處於「不正常關機」狀態時移動記錄檔，則將無法重新啟動該資料庫。如果您無法將所有的資料庫復原為「完全關閉」狀態，請連絡 Microsoft 產品支援服務以取得詳細資訊。

  5. 在 [Exchange 系統管理員] 中，於用完交易記錄檔的儲存群組上按一下滑鼠右鍵，再按一下 [內容]。

  6. 按一下 [一般] 索引標籤，然後記下 [交易記錄位置] 方塊中交易記錄的路徑。

  7. 記下 [系統路徑位置] 方塊中檢查點檔案的路徑。

  8. 將交易記錄檔及檢查點檔案移至其他位置。記錄檔的副檔名為 .log，檢查點檔案的副檔名為 .chk。

  9. 在 [Exchange 系統管理員] 中以滑鼠右鍵按一下儲存群組中第一個卸載的儲存區，再按一下 [裝載儲存區]。

  10. 對儲存群組中的每個儲存區重複此步驟。現在重設儲存群組中記錄檔的順序。

  11. 對儲存群組上的所有資料庫執行完整備份。

若需有關 Exchange Server Service Pack 的詳細資訊，請參閱 Exchange Server 網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=21573)。


VM 最大區塊大小偏低
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_PerfRawData_MSExchangeIS_MSExchangeIS Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 VMLargestBlockSize 機碼值。VMLargestBlockSize 機碼代表最大可用的虛擬記憶體區塊大小 (以位元組為單位)。

此外，Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定列於每個信箱儲存區之 homeMDBBL 屬性中的項目計數。這個屬性的計數代表信箱儲存區上的信箱數目。

如果 Exchange Server Analyzer 發現 Exchange Server 電腦 (具有超過 20 個信箱) 上的 VMLargestBlockSize 的值超過 50000000 但小於 150000000 ，將會顯示警告。

尤其，當您在 MIME 及 MAPI 格式之間轉換郵件時，Exchange Server 會使用虛擬記憶體來儲存郵件，而在確認交易記錄檔中的郵件和確認到儲存庫時，也會使用虛擬記憶體作為緩衝區。這些操作經常需要大量連續的虛擬記憶體區塊，才能快速和有效地完成。如果已顯示此警告，則表示 Exchange 電腦上的虛擬記憶體已耗竭到小於 150 MB 的連續空間。這就是所謂的虛擬記憶體分散。

如果虛擬記憶體嚴重耗竭，事件日誌中可能會開始出現錯誤訊息 (事件識別碼 9582)，這些是虛擬記憶體錯誤。如果虛擬記憶體太低，您將看到事件識別碼 12800，這表示因為記憶體不足，無法處理郵件，導致未傳遞郵件。

若要解決此警告，請依序遵循這些建議來執行。

在 Exchange Server Analyzer 輸出中尋找「最大 ESE 快取大小已增加」這則錯誤訊息。

如果在傳回這個虛擬記憶體分散警告的相同 Exchange 電腦上也傳回「最大 ESE 快取大小已增加」的錯誤，請依照Maximum ESE Cache 設定得太高一文中的建議事項。

這兩個訊息同時出現可能指出虛擬記憶體分散問題是因為手動增加 ESE 快取而導致的。

重新啟動 Exchange Information Store 服務

在這個錯誤訊息的描述中，Exchange Server Analyzer 會指出 Microsoft Exchange Information Store 服務已執行的天數。如果指定的天數超過 30 天，請重新啟動該服務。

若要重新啟動 Microsoft Exchange Information Store 服務

  1. 開啟 [服務] MMC 嵌入式管理單元。

  2. 在 Microsoft Exchange Information Store 服務上按一下滑鼠右鍵，然後按一下 [重新啟動]。

評估郵件大小限制

如果有許多使用者傳送大型郵件 (超過 30 MB)，虛擬記憶體可能比沒有許多使用者傳送大型郵件時更快分散。如上所述，當儲存區處理程序從記錄檔移動資料並確認到儲存區時，將使用虛擬記憶體作為緩衝區。如果移動的資料經常很大，則會很快消耗大型、連續的虛擬記憶體區塊。

如果經常使用電子郵件傳送大型資料，且該資料是在內部傳送，請考慮在檔案伺服器上設定共用的目錄，供使用者放置大量資料片段。

建議將最大郵件大小限制設定為不超過 30 MB。然而，如果您需要較高的郵件大小限制，讓含大型附件的郵件能夠透過您的 Exchange 組織來傳送，建議您將最大外寄郵件大小限制提高到 30 MB 以上。除了虛擬記憶體分散以外，增加郵件大小限制超過 30 MB 會使系統更容易遭受惡意的攻擊。不建議允許超過 30 MB 郵件大小限制。

若要設定郵件大小限制

  1. 在 [Exchange 系統管理員] 中，展開 [通用設定]，在 [郵件傳遞] 上按一下滑鼠右鍵，再按一下 [內容]。

  2. 在 [郵件傳遞內容] 對話方塊中，在 [預設值] 標籤上選取 [傳送的郵件大小限制] 選項，並輸入想要的大小限制。

請確認防毒軟體是最新的

有時候，在「Exchange 病毒掃描 API (VSAPI)」模式下執行的過期防毒軟體會造成虛擬記憶體分散。如果是在 VSAPI 模式下執行防毒軟體，請連絡您的防毒廠商以確認您有執行該廠商的最新版軟體和驅動程式。

將信箱移動到另一個 Exchange 伺服器

如果所有程序您都執行過了，但 Exchange Server Analyzer 仍然顯示此警告，則您必須從受影響的伺服器中移出信箱來降低負載。此伺服器上有太多信箱。

若要在 Exchange 2000 Server 及 Exchange Server 2003 上移動信箱

  1. 在 [Active Directory 使用者及電腦] 中，選取要移動其信箱的使用者。

  2. 在您於上一個步驟中選取的使用者清單上按一下滑鼠右鍵，然後按一下 [Exchange 工作]。

  3. 在 [Exchange 工作精靈] 中，在 [可用的工作] 頁面上，按一下 [移動信箱]，然後按 [下一步]。

  4. 請仔細閱讀並遵循精靈的其餘步驟。

若要在 Exchange Server 2003 上移動信箱

  1. 在 [Exchange 系統管理員] 中，展開 [伺服器]，展開要從那裡移動信箱的伺服器、展開要從那裡移動信箱的 [儲存群組]、展開含有要移動之信箱的 [信箱儲存區]，然後按一下 [信箱]。

  2. 在詳細資料窗格中，在要移動其信箱的使用者上按一下滑鼠右鍵，然後按一下 [Exchange 工作]。

  3. 在 [Exchange 工作精靈] 中，在 [可用的工作] 頁面上，按一下 [移動信箱]，然後按 [下一步]。

  4. 請仔細閱讀並遵循精靈的其餘步驟。

若需解決虛擬記憶體分散問題的詳細資訊，請參閱下列微軟知識庫文件：

  • 325044＜HOW TO: 疑難排解 Exchange 2003 及 Exchange 2000 的虛擬記憶體分散＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 838233＜您的電腦速度緩慢或停止回應，且重複地在 Exchange 2000 Server 中記錄事件識別碼 9582 及 1160＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=838233)

若需有關設定郵件大小限制的詳細資訊，請參閱知識庫文件 - 322679＜設定郵件的大小限制＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)

若需有關移動信箱的詳細資訊，請參閱下列知識庫文件：

  • 328810＜在伺服器之間移動信箱＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328810)

  • 821829＜在 Exchange Server 2003 中移動信箱＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821829)


VM 最大區塊大小達到臨界點
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_PerfRawData_MSExchangeIS_MSExchangeIS Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 VMLargestBlockSize 機碼值。VMLargestBlockSize 機碼代表最大可用的虛擬記憶體區塊大小 (以位元組為單位)。

此外，Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定每個信箱儲存區之 homeMDBBL 屬性中列出的項目計數。這個屬性的計數代表信箱儲存區上的信箱數目。

在超過 20 個信箱的 Exchange Server 電腦上，如果 Exchange Server Analyzer 發現 VMLargestBlockSize 的值大於 0 但小於 50000001，則會顯示錯誤。

尤其，當您在 MIME 及 MAPI 格式之間轉換郵件時，Exchange 伺服器會使用虛擬記憶體來儲存郵件，且會在確認交易記錄檔的郵件和確認到儲存區時，作為緩衝區。這些操作通常需要大量連續的虛擬記憶體區塊，才能快速和有效地完成。如果已顯示這個錯誤，表示 Exchange 電腦上的虛擬記憶體已耗竭到小於 50 MB 的連續空間。這就是所謂的虛擬記憶體分散。在小於 50 MB 的連續虛擬記憶體空間下執行 Exchange 信箱伺服器是嚴重錯誤。

如果虛擬記憶體嚴重耗竭，事件記錄中可能會開始出現錯誤警示 (事件識別碼 9582)，這些是虛擬記憶體錯誤。如果虛擬記憶體太低，您將看到事件識別碼 ID 12800，這表示因為記憶體不足而無法處理郵件，導致未傳遞郵件。

若要補救這個錯誤，請依序遵循下列建議。

在 Exchange Server Analyzer 輸出中尋找「最大 ESE 快取大小已增加」這則錯誤訊息。

如果在傳回這個虛擬記憶體分散警告的相同 Exchange 電腦上也傳回「最大 ESE 快取大小已增加」的錯誤，請依照Maximum ESE Cache 設定得太高一文中的建議事項。

這兩個警示同時出現可能指出因為手動增加 ESE 快取而導致虛擬記憶體分散問題

重新啟動 Exchange Information Store 服務

在這個警示的描述中，Exchange Server Analyzer 會指定 Microsoft Exchange Information Store 服務已執行的天數。如果指定的天數超過 30 天，請重新啟動該服務。

若要重新啟動 Exchange Information Store

  1. 開啟 [服務] MMC 嵌入式管理單元。

  2. 在 Microsoft Exchange Information Store 服務上按一下滑鼠右鍵，然後按一下 [重新啟動]。

評估郵件大小限制

如果有許多使用者傳送大型郵件 (超過 30 MB)，虛擬記憶體可能比沒有許多使用者傳送大型郵件時更快分散。如上所述，當儲存區處理程序從記錄檔移出資料並確認到儲存區時，將使用虛擬記憶體作為緩衝區。如果移動的資料經常很大，則會很快消耗大型、連續的虛擬記憶體區塊。

如果經常使用電子郵件傳送大型資料，且該資料是在內部傳送，請考慮在檔案伺服器上設定共用的目錄，供使用者張貼大量資料片段。

建議您將郵件大小限制的上限設為 30 MB 以下。然而，如果您需要較高的郵件大小限制，讓含大型附件的郵件能夠透過您的 Exchange 組織來傳送，建議您將最大外寄郵件大小限制提高到 30 MB 以上。除了虛擬記憶體分散以外，增加郵件大小限制超過 30 MB 會使系統更容易遭受惡意的攻擊。因此，不建議允許超過 30 MB 的郵件大小限制。

若要設定郵件大小限制

  1. 在 [Exchange 系統管理員] 中，展開 [通用設定]，在 [郵件傳遞] 上按一下滑鼠右鍵，再按一下 [內容]。

  2. 在 [郵件傳遞內容] 對話方塊中，在 [預設值] 標籤上選取 [傳送的郵件大小限制] 選項，並輸入想要的大小限制。

請確認防毒軟體是最新的

有時候，在 Exchange 病毒掃描 API (VSAPI) 模式下執行的過期防毒軟體會造成虛擬記憶體分散。如果是在 VSAPI 模式下執行防毒軟體，請連絡您的防毒廠商以確認您有執行該廠商的最新版軟體和驅動程式。

將信箱移動到另一個 Exchange 伺服器

如果您已徹底執行以上所有程序，但 Exchange Server Analyzer 仍然顯示這個錯誤，或這個警示的警告訊息 (剩下小於 150 MB 的連續虛擬記憶體空間)，則您必須從受影響的伺服器中移出信箱來降低其負載。此伺服器上有太多信箱。

若要在 Exchange 2000 Server 及 Exchange Server 2003 上移動信箱

  1. 在 [Active Directory 使用者及電腦] 中，選取要移動其信箱的使用者。

  2. 在您於上一個步驟中選取的使用者清單上按一下滑鼠右鍵，然後按一下 [Exchange 工作]。

  3. 在 [Exchange 工作精靈] 中，在 [可用的工作] 頁面上，按一下 [移動信箱]，然後按 [下一步]。

  4. 請仔細閱讀並遵循精靈的其餘步驟。

若要在 Exchange Server 2003 上移動信箱

  1. 在 [Exchange 系統管理員] 中，展開 [伺服器]，展開要從那裡移動信箱的伺服器、展開要從那裡移動信箱的 [儲存群組]、展開含有要移動之信箱的 [信箱儲存區]，然後按一下 [信箱]。

  2. 在詳細資料窗格中，在要移動其信箱的使用者上按一下滑鼠右鍵，然後按一下 [Exchange 工作]。

  3. 在 [Exchange 工作精靈] 中，在 [可用的工作] 頁面上，按一下 [移動信箱]，然後按 [下一步]。

  4. 請仔細閱讀並遵循精靈的其餘步驟。

若需解決虛擬記憶體分散問題的詳細資訊，請參閱下列微軟知識庫文件：

  • 325044＜HOW TO: 疑難排解 Exchange 2003 及 Exchange 2000 的虛擬記憶體分散＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 838233＜您的電腦速度緩慢或停止回應，且重複地在 Exchange 2000 Server 中記錄事件識別碼 9582 及 1160＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=838233)

若需有關設定郵件大小限制的詳細資訊，請參閱知識庫文件 - 322679＜設定郵件大小限制＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)。

若需有關移動信箱的詳細資訊，請參閱下列知識庫文件：

  • 328810＜在伺服器間移動信箱＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328810)

  • 821829＜在 Exchange Server 2003 中移動信箱＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821829)


VirtualReserveSize is non-default
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄值，以判定是否已變更 Exchange Interprocess Communication (ExIPC) 元件的初始記憶體配置預設值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIPC\Parameters\VirtualReserveSize

如果 Exchange Server Analyzer 發現 VirtualReserveSize 機碼存在，且設定的值大於 0，就會顯示非預設的組態訊息。

ExIPC 是一種佇列元件，其允許 Inetinfo.exe (Internet Information Services) 及 Store.exe (Microsoft Exchange Information Store 服務) 快速地來回移動資料。通常，ExIPC 的預設初始記憶體配置已經足夠。在預設的情況下，VirtualReserveSize 機碼不存在。它應該僅在 Microsoft 諮詢服務或 Microsoft 產品支援服務的指示下進行新增與設定。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\EXIPC\Parameters

  3. 刪除 VirtualReserveSize 機碼。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務及 IIS 管理服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 ExIPC 的詳細資訊，請參閱下列知識庫文件：

  • 821879＜Exchange Server 2003 中主要傳輸元件的定義＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821879)

  • 260995＜XCON：Exchange 2000 Server 中主要傳輸元件的定義＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260995)


已覆寫虛擬記憶體事件間隔
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已手動覆寫記錄虛擬記憶體分散事件的閾值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ VM Info Update Interval

如果 Exchange Server Analyzer 發現 VM Info Update Interval 登錄值已存在但不等於 3600，則會顯示非預設的組態訊息。

在 32 位元 Microsoft Windows® 系統中，有兩種記憶體：實體記憶體 (安裝在系統中的實際記憶體數量) 和虛擬記憶體位址空間 (虛擬化的 4 GB 記憶體空間)。無論在系統中安裝多少實體記憶體，虛擬位址空間總大小永遠相同：4 GB。雖然並非所有 32 位元應用程式都是這樣，但對於 Exchange Server 來說，虛擬位址空間等於虛擬記憶體；也就是說，這兩個詞彙可以交替使用。

在其操作的一般過程中，Microsoft Exchange Information Store 服務將會重複地配置、使用及解除配置虛擬記憶體。當經常配置、使用和解除虛擬記憶體的配置時，會造成虛擬記憶體過於分散。虛擬記憶體分散類似於會隨著時間發生的檔案系統分散。一段時間之後，虛擬記憶體的配置區段就不再連續，因此效能開始降低。對於檔案系統，您可以執行會執行檔案系統磁碟重組的應用程式，而且大多時候您都可以執行此作業 (儘管系統處於線上狀態且被其他程式存取)。對於虛擬記憶體分散而言，則沒有磁碟重組工具；若要更正問題，您必須先停止 Microsoft Exchange Information Store 服務再啟動它，或重新啟動系統。

根據預設值，Microsoft Exchange Information Store 服務每小時會檢查一次可用虛擬記憶體 (例如，每隔 3,600 秒)。VM Info Update Interval 登錄值代表可讓系統管理員覆寫預設 3,600 秒間隔的組態機會。如果您真的要覆寫預設層級，建議您不要將值設為低於 5 分鐘 (300 秒)。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 在右窗格中，刪除 VM Info Update Interval 的值。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Information Store 服務，使變更生效。

若需解決 Exchange Server 2003 及 Exchange 2000 Server 的虛擬記憶體分散問題的詳細資訊，請參閱微軟知識庫文件 - 325044＜HOW TO:Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000＞ (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)。


未啟用回寫式快取
Microsoft Exchange Server Analyzer - 文章 > 儲存 >

主題上次修改日期： 2006-08-18

Microsoft® Exchange Server Analyzer 工具判斷您的磁碟陣列控制器未正確設定用來主控交易記錄檔之磁碟機的回寫式快取。

建議您在所有主控交易記錄檔之磁碟機的陣列控制器上，將回寫式快取啟用為 100%。一般很少讀取交易記錄檔。交易記錄檔磁碟機的寫入速度愈快，執行 Exchange Server 之伺服器的執行效果也會更好。

若要更正此警告

  • 啟用回寫式快取。

若需有關如何設定 Exchange 伺服器硬碟的詳細資訊，請參閱微軟知識庫文件 - 188589＜Exchange DB 與快取硬碟及控制器＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=188589)。


協力廠商軟體
Microsoft Exchange Server Analyzer - 文章 >

主題上次修改日期： 2005-11-18

本節中的文章詳細說明 Microsoft® Exchange Server Analyzer 工具所評估的協力廠商軟體。此外，這些文章還會說明您可以採取哪些動作來解決 Exchange Server Analyzer 發現的協力廠商軟體相關錯誤、警告及非預設的組態。


尚未設定防毒資料夾排除
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Symantec AntiVirus Corporate Edition (Symantec AV) 是否安裝在 Exchange Server 上，以及是否啟用 RealTime Protection (RTP)：

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Storages\Filesystem\RealTimeScan

如果 Exchange Server Analyzer 發現 HaveExceptionDirs 登錄值設為 0，就會顯示錯誤。HaveExceptionDirs 登錄值為 0 表示已停用資料夾排除。

資料夾排除可以防止在即時防毒掃描期間掃描指定資料夾。如果您尚未在 Exchange Server 上啟用資料夾排除，則可能會發生下列問題：

  • Symantec AV RTP 可能會對在普通程式活動期間所存取的某些乾淨檔案提供錯誤正面報告。

  • Symantec AV RTP 可能會不正確地報告軟體中已由公司安全性原則允許在 Exchange Server 上執行的受感染檔案。

  • Symantec AV RTP 可能會掃描 Exchange Server 目錄結構，從而導致不正確的病毒偵測、在 Exchange Server 上發生非預期的行為，或對 Exchange Server 資料庫造成毀損。

重要事項：
請勿對 Exchange Server 資料庫、日誌、暫存檔、網際網路資訊服務 (IIS) 系統檔案，或可安裝的檔案系統 (IFS) 磁碟機 (磁碟機 M) 執行檔案型掃描軟體。設定防毒軟體，以避免掃描包含這些檔案的資料夾。

您可以對 Exchange Server 電腦的作業系統與 Exchange Server 程式檔案 (Exchsrvr\Bin 資料夾) 執行檔案型防毒軟體。不過，請勿對下列檔案及資料夾執行檔案型防毒軟體：

  • Exchange Server 資料庫 (.mdb 及 .stm 檔案) 及交易記錄檔 (.log) (預設位置為：\Exchsrvr\MDBData)

  • Exchange Server .mta 檔案 (預設位置為：\Exchsrvr\Mtadata)

  • Exchange Server 郵件追蹤記錄檔 (預設位置為：\Exchsrvr\Server_Name.log)

  • 虛擬伺服器資料夾 (預設位置為：\Exchsrvr\Mailroot)

  • 站台複寫服務 (SRS) 檔案 (預設位置為：\Exchsrvr\Srsdata)

  • 網際網路資訊服務 (IIS) 系統檔案 (預設位置為：\%SystemRoot%\System32\Inetsrv)

  • 網際網路郵件連接器檔案 (預設位置為：\Exchsrvr\IMCData)

  • 用來儲存用於郵件轉換之資料流暫存檔的工作資料夾。依預設，此工作資料夾的位置為 \Exchsrvr\MDBData

  • 與離線維護公用程式 (如 Eseutil.exe) 一起使用的暫存檔。依預設，此資料夾為 .exe 檔案的執行位置，但是當您執行此公用程式時，可以設定此位置。

您可以對下列資料夾執行檔案型掃描：

  • Exchsrvr\Address

  • Exchsrvr\Bin

  • Exchsrvr\Exchweb

  • Exchsrvr\Res

  • Exchsrvr\Schema

若需有關如何在 Symantec AntiVirus Corporate Edition 中設定 RealTime 掃描排除的詳細資訊，請參閱 Symantec 防毒網站 (英文) (http://www.symantec.com)。

附註：
網址可能會變更，因此您可能無法連線到此處提到的網站。

若需有關加強 Exchange Server 環境對抗透過電子郵件傳輸病毒及蠕蟲的詳細資訊，請參閱《在 Exchange Serve 2003 環境中減緩及阻止電子郵件病毒》(英文) (http://go.microsoft.com/fwlink/?LinkId=47587)。

若需將防毒軟體與 Exchange Server 搭配使用的相關資訊，請參閱下列微軟知識庫文件：

  • 328841＜Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN：Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需可在 Exchange Server 上使用之協力廠商的防毒軟體清單，請參閱 Exchange Server Partners：防毒網站 (英文) (http://go.microsoft.com/fwlink/?linkid=16226)。


Antigen 正在掃描公用資料夾複寫郵件
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2006-03-13

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個 Exchange 伺服器上是否有公用資料夾儲存區。如果 Exchange Server Analyzer 發現 InformationStore 物件的物件類別是 msExchPublicMDB，則該伺服器主控公用資料夾儲存區。

Microsoft® Exchange Server Analyzer 也會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 ANTIGENVSAPI.DLL 的 Version 機碼值。若 ANTIGENVSAPI.DLL 的 Version 機碼值為 1517 或更大，表示已在 Exchange Server 上安裝 Sybari Antigen for Microsoft Exchange 8.0 版 SR3 或更新版本。

最後，Exchange Server Analyzer 會查詢下列登錄分支，以判定 DoNotScanIPMReplicationMessages 機碼是否存在，而且沒有大於 0 的值：

HKEY_LOCAL_MACHINE\Software\Sybari Software\Antigen for Exchange\DoNotScanIPMReplicationMessages

DoNotScanIPMReplicationMessages 機碼的值會判定安裝的 Sybari Antigen 是否將掃描以及可能移除 Exchange Server 公用資料夾複寫郵件。若 DoNotScanIPMReplicationMessages 機碼值小於 1，表示 Antigen 將掃描 winmail.dat 檔案以找出病毒。伺服器會基於數個目的而使用 Winmail.dat 檔案，包括使伺服器之間更容易進行公用資料夾複寫。如果 Antigen 修改這些 Winmail.dat 檔案的任一個，則公用資料夾複寫處理程序將失敗。

如果 Exchange Server Analyzer 判定下列狀況存在，則會顯示錯誤：

  • Exchange Server 正在主控一或多個公用資料夾儲存區

  • Sybari Antigen 組建 1517 或更新版本已安裝在伺服器上

  • DoNotScanIPMReplicationMessages 機碼不存在，或存在但沒有大於 0 的值。

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\Software\Sybari Software\Antigen for Exchange

  3. 如果 DoNotScanIPMReplicationMessages 子機碼已存在於右窗格，請連按兩下這個子機碼，然後將值設為 1。

  4. 如果 DoNotScanIPMReplicationMessages 子機碼尚未存在，請在右窗格上按一下滑鼠右鍵，建立這個子機碼作為新的 DWORD 值。

  5. 將 DoNotScanIPMReplicationMessages 值設為 1。

    附註：
    如果病毒是透過公用資料夾複寫來複寫，則即使您啟用這個新的登錄機碼，Antigen 仍將在即時掃描工作時偵測病毒

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需將防毒軟體與 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Overview of Exchange Server 2003 and antivirus software＞ (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)。

  • 306105＜XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000＞ (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)。

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)。


CA eTrust：EML/LOG/EDB/STM/DAT 檔案不在即時檔案排除清單中
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以取得被排除在 eTrust Antivirus (來自 Computer Associates) 的即時檔案層級防毒掃描作業之外的副檔名清單：

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeExtList

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeExtList

如果 Exchange Server Analyzer 發現 szExcludeExtList 的值未包含對應到 Exchange 資料檔案類型的副檔名 (.eml, .log, .edb, .stm 或 .dat)，就會顯示警告。

eTrust Antivirus 是一個檔案層級的防毒掃描程式。若要判定 Exchange Server 電腦上所安裝的 eTrust Antivirus 版本，請執行下列動作：

  1. 瀏覽至 [開始] | [程式集] | eTrust Antivirus，然後按一下 eTrust Antivirus，啟動該應用程式。

  2. 在 eTrust Antivirus 應用程式功能表中，按一下 Help，再按一下 About eTrust Antivirus。

  3. 檢查 Product Version 欄位，判定 eTrust Antivirus 的版本。

在 Exchange Server 電腦上使用檔案層級的掃描程式時，可能會發生下列問題：

  • 檔案層級的掃描程式會在檔案被使用時 (或依排定的間隔) 掃描檔案，並且可能會在 Exchange 嘗試要使用檔案時，將 Exchange 記錄檔或資料庫檔案鎖定或隔離。這可能會導致 Exchange Server 發生嚴重的失敗，也可能會造成資料庫錯誤。

  • 如果您以檔案層級的掃描程式軟體掃描 Exchange 可安裝的檔案系統 (IFS) 代表的磁碟機 (通常是磁碟機 M) 時，可能會發生更多問題。

不論您使用的是哪一種檔案層次的防毒程式，都一定要在檔案層級的掃描程式中排除下列檔案：

  • .eml, .edb, .stm, .log, .dat 及 .chk 檔。

  • 由 IFS 代表的 Exchange Server 磁碟機。在預設的情況下，這是磁碟機 M。

  • Exchange 資料庫及記錄檔。在預設的情況下，這些檔案是位於 Exchsrvr\Mdbdata 資料夾中。

  • Exchsrvr\Mtadata 資料夾中的 Exchange MTA 檔案。

  • 其他記錄檔，例如 Exchsrvr\server_name.log 檔。

  • Exchsrvr\Mailroot 虛擬伺服器資料夾。

  • 用來儲存郵件轉換用的資料流暫存檔之工作資料夾。在預設的情況下，這個資料夾是位於 \Exchsrvr\MDBData，不過您可以設定其位置。

  • 離線維護工具 (如 Eseutil.exe) 使用之臨時資料夾。在預設的情況下，這個資料夾是 .exe 檔的執行位置，但是您可以在執行工具時，設定其位置。

  • Exchsrvr\Srsdata 資料夾中的「站台複寫服務 (SRS)」檔案。

  • %SystemRoot%\System32\Inetsrv 資料夾中的 Microsoft Internet Information Service (IIS) 系統檔案。

  • %SystemRoot%\IIS Temporary Compressed Files 資料夾中的 IIS 工作檔。

若要更正此警告

  1. 使用 eTrust Antivirus 使用者介面，將上述列出的資料夾及檔案，排除在檔案層次的防毒掃瞄作業之外。

  2. 若需有關在 Exchange Server 電腦上使用 eTrust Antivirus 的最新資訊，請造訪 CA eTrust Antivirus 網站 (英文) (http://www3.ca.com/Solutions/Product.asp?ID=156)。

    附註：
    網址可能會變更，因此您可能無法連線到此處提到的網站。

若需有關將防毒軟體和 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需可在 Exchange Server 上使用的協力廠商之防毒軟體清單，請參閱 Exchange Partners:防毒網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=16226)。

若需有關掃描 IFS 磁碟發生之問題的詳細資訊，請參閱下列知識庫文件：

  • 298924＜XADM：請勿備份或掃描 Exchange 2000 M 磁碟機＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608＜XADM：裝載資料庫時顯示的 C1041737 錯誤訊息＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046＜XADM：行事曆項目從使用者資料夾消失＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust：Exchange 資料磁碟機並未從手動工作掃描排除
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來取得被排除在 eTrust Antivirus (Computer Associates 公司的產品) 的手動檔案層級防毒掃描作業之外的目錄清單：

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

Exchange Server Analyzer 也會讀取 Active Directory® 目錄服務中的 MsExchESEParamSystemPath 屬性，該屬性是對應到 Exchange 系統資料檔位置的儲存群組屬性。

若 Exchange Server Analyzer 發現 szExcludeDirs 的值未包含對應到 Exchange 系統資料檔案位置的路徑，就會顯示一則警告。

eTrust Antivirus 是一個檔案層級的防毒掃描程式。若要判定 Exchange Server 電腦上安裝的 eTrust Antivirus 版本：

  1. 瀏覽至 [開始] | [程式集] | [eTrust Antivirus]，然後按一下 [eTrust Antivirus]，啟動該應用程式。

  2. 在 eTrust Antivirus 應用程式功能表中，按一下 [Help]，再按一下 [About eTrust Antivirus]。

  3. 檢查 [Product Version] 欄位，判定 eTrust Antivirus 的版本。

在 Exchange Server 電腦上使用檔案層級的掃描程式時，可能會發生下列問題：

  • 檔案層級的掃描程式會在檔案被使用時 (或依排定的間隔) 掃描檔案，並且可能會在 Exchange 嘗試要使用檔案時，將 Exchange 記錄檔或資料庫檔案鎖定或隔離。這可能會導致 Exchange Server 發生嚴重的失敗，也可能會造成資料庫錯誤。

  • 如果您以檔案層級的掃描程式軟體掃描 Exchange 可安裝的檔案系統 (IFS) 代表的磁碟機 (通常是磁碟機 M) 時，可能會發生更多問題。

不論您使用的是哪一種檔案層級的防毒程式，都一定要在檔案層級的掃描程式中排除下列檔案：

  • .eml, .edb, .stm, .log, .dat 及 .chk 檔。

  • 由 IFS 代表的 Exchange Server 磁碟機。在預設的情況下，這是 M 磁碟機。

  • Exchange 資料庫及記錄檔。在預設的情況下，這些檔案是位於 Exchsrvr\Mdbdata 資料夾中。

  • Exchsrvr\Mtadata 資料夾中的 Exchange MTA 檔案。

  • 其他記錄檔，例如 Exchsrvr\server_name.log 檔。

  • Exchsrvr\Mailroot 虛擬伺服器資料夾。

  • 用來儲存郵件轉換用的資料流暫存檔之工作資料夾。在預設的情況下，這個資料夾是位於 \Exchsrvr\MDBData，不過您可以設定其位置。

  • 搭配 Eseutil.exe 等離線維護工具使用的暫存資料夾。在預設的情況下，此資料夾就是 .exe 檔案的執行位置，不過您也可以在執行工具時設定此位置。

  • Exchsrvr\Srsdata 資料夾中的「站台複寫服務 (SRS)」檔案。

  • %SystemRoot%\System32\Inetsrv 資料夾中的 Microsoft Internet Information Service (IIS) 系統檔案。

  • %SystemRoot%\IIS Temporary Compressed Files 資料夾中的 IIS 工作檔。

若要更正此警告

  1. 使用 eTrust Antivirus 使用者介面，將上述列出的資料夾及檔案，排除在檔案層級的防毒掃描作業之外。

  2. 若需有關在 Exchange Server 電腦上使用 eTrust Antivirus 的最新資訊，請造訪 CA eTrust Antivirus 網站 (英文) (http://www3.ca.com/Solutions/Product.asp?ID=156)。

    附註：
    網址可能會變更，因此您可能無法連線到此處提到的網站。

若需有關將防毒軟體和 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需可在 Exchange Server 上使用的協力廠商之防毒軟體清單，請參閱 Exchange Partners:防毒網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=16226)。

若需有關掃描 IFS 磁碟發生之問題的詳細資訊，請參閱下列知識庫文件：

  • 298924＜XADM：請勿備份或掃描 Exchange 2000 M 磁碟機＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608＜XADM：裝載資料庫時顯示的 C1041737 錯誤訊息＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046＜XADM：行事曆項目從使用者資料夾消失＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust：Exchange 資料磁碟機並未從即時掃描排除
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以取得被排除在 eTrust Antivirus (Computer Associates 的產品) 的即時檔案層級防毒掃描作業之外的目錄清單：

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定每個儲存群組的 MsExchESEParamSystemPath 屬性值。此屬性代表 Exchange 資料檔案的路徑。

若 Exchange Server Analyzer 發現 szExcludeDirs 的值未包含對應到 Exchange 系統資料檔案位置的路徑，就會顯示一則警告。

eTrust Antivirus 是一個檔案層級的防毒掃描程式。若要判定 Exchange Server 電腦上安裝的 eTrust Antivirus 版本：

  1. 瀏覽至 [開始] | [程式集] | [eTrust Antivirus]，然後按一下 [eTrust Antivirus]，啟動該應用程式。

  2. 在 eTrust Antivirus 應用程式功能表中，按一下 [Help]，再按一下 [About eTrust Antivirus]。

  3. 檢查 [Product Version] 欄位，判定 eTrust Antivirus 的版本。

在 Exchange Server 電腦上使用檔案層級的掃描程式時，可能會發生下列問題：

  • 檔案層級的掃描程式會在檔案被使用時 (或依排定的間隔) 掃描檔案，並且可能會在 Exchange 嘗試要使用檔案時，將 Exchange 記錄檔或資料庫檔案鎖定或隔離。這可能會導致 Exchange Server 發生嚴重的失敗，也可能會造成資料庫錯誤。

  • 如果您以檔案層級的掃描程式軟體掃描 Exchange 可安裝的檔案系統 (IFS) 代表的磁碟機 (通常是磁碟機 M) 時，可能會發生更多問題。

無論使用的檔案層級防毒程式為何，一律都應從檔案層級的掃描程式中排除下列檔案及資料夾：

  • .eml, .edb, .stm, .log, .dat 及 .chk 檔。

  • 由 IFS 代表的 Exchange Server 磁碟機。在預設的情況下，這是磁碟機 M。

  • Exchange 資料庫及記錄檔。在預設的情況下，這些檔案是位於 Exchsrvr\Mdbdata 資料夾中。

  • Exchsrvr\Mtadata 資料夾中的 Exchange MTA 檔案。

  • 其他記錄檔，例如 Exchsrvr\server_name.log 檔。

  • Exchsrvr\Mailroot 虛擬伺服器資料夾。

  • 用來儲存郵件轉換用的資料流暫存檔之工作資料夾。在預設的情況下，這個資料夾是位於 \Exchsrvr\MDBData，不過您可以設定其位置。

  • 離線維護工具 (如 Eseutil.exe) 使用之臨時資料夾。在預設的情況下，這個資料夾是 .exe 檔的執行位置，但是您可以在執行工具時，設定其位置。

  • Exchsrvr\Srsdata 資料夾中的「站台複寫服務 (SRS)」檔案。

  • %SystemRoot%\System32\Inetsrv 資料夾中的 Microsoft Internet Information Service (IIS) 系統檔案。

  • %SystemRoot%\IIS Temporary Compressed Files 資料夾中的 IIS 工作檔。

若要更正此警告

  1. 使用 eTrust Antivirus 使用者介面，將上述列出的資料夾及檔案，排除在檔案層級的防毒掃描作業之外。

  2. 若需有關在 Exchange Server 電腦上使用 eTrust Antivirus 的最新資訊，請造訪 CA eTrust Antivirus 網站 (英文) (http://www3.ca.com/Solutions/Product.asp?ID=156)。

    附註：
    網址可能會變更，因此您可能無法連線到此處提到的網站。

若需有關將防毒軟體和 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需可在 Exchange Server 上使用的協力廠商之防毒軟體清單，請參閱 Exchange Partners:防毒網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=16226)。

若需有關掃描 IFS 磁碟發生之問題的詳細資訊，請參閱下列知識庫文件：

  • 298924＜XADM：請勿備份或掃描 Exchange 2000 M 磁碟機＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608＜XADM：裝載資料庫時顯示的 C1041737 錯誤訊息＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046＜XADM：行事曆項目從使用者資料夾消失＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust：Exchange IFS 路徑並未從手動工作掃描排除
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來取得被排除在 eTrust Antivirus (Computer Associates 公司的產品) 的手動檔案層級防毒掃描作業之外的目錄清單：

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

Exchange Server Analyzer 也會讀取下列登錄項目，來取得代表「Exchange 可安裝的檔案系統 (IFS)」磁碟機的磁碟機代號：

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

在 Exchange 2000 Server 上，預設磁碟機代號是 M。在 Exchange Server 2003 上，IFS 磁碟機預設為關閉。

若 Exchange Server Analyzer 發現 szExcludeDirs 的值未包含對應到 IFS 磁碟機的路徑，就會顯示一則警告。

eTrust Antivirus 是一個檔案層級的防毒掃描程式。若要判定 Exchange Server 電腦上所安裝的 eTrust Antivirus 版本，請執行下列動作：

  1. 瀏覽至 [開始] | [程式集] | [eTrust Antivirus]，然後按一下 [eTrust Antivirus]，啟動該應用程式。

  2. 在 eTrust Antivirus 應用程式功能表中，按一下 [Help]，再按一下 [About eTrust Antivirus]。

  3. 檢查 [Product Version] 欄位，判定 eTrust Antivirus 的版本。

在 Exchange Server 電腦上使用檔案層級的掃描程式時，可能會發生下列問題：

  • 檔案層級的掃描程式會在檔案被使用時 (或依排定的間隔) 掃描檔案，並且可能會在 Exchange 嘗試要使用檔案時，將 Exchange 記錄檔或資料庫檔案鎖定或隔離。這可能會導致 Exchange Server 發生嚴重的失敗，也可能會造成資料庫錯誤。

  • 如果您以檔案層級的掃描程式軟體掃描 IFS 代表的磁碟機 (通常是 M 磁碟機) 時，可能會發生更多問題。

不論您使用的是哪一種檔案層級的防毒程式，都一定要在檔案層級的掃描程式中排除下列檔案：

  • .eml, .edb, .stm, .log, .dat 及 .chk 檔。

  • 由 IFS 代表的 Exchange Server 磁碟機。在預設的情況下，這是 M 磁碟機。

  • Exchange 資料庫及記錄檔。在預設的情況下，這些檔案是位於 Exchsrvr\Mdbdata 資料夾中。

  • Exchsrvr\Mtadata 資料夾中的 Exchange MTA 檔案。

  • 其他記錄檔，例如 Exchsrvr\server_name.log 檔。

  • Exchsrvr\Mailroot 虛擬伺服器資料夾。

  • 用來儲存郵件轉換用的資料流暫存檔之工作資料夾。在預設的情況下，這個資料夾是位於 \Exchsrvr\MDBData，不過您可以設定其位置。

  • 離線維護工具 (如 Eseutil.exe) 使用之臨時資料夾。在預設的情況下，這個資料夾是 .exe 檔的執行位置，但是您可以在執行工具時，設定其位置。

  • Exchsrvr\Srsdata 資料夾中的「站台複寫服務 (SRS)」檔案。

  • %SystemRoot%\System32\Inetsrv 資料夾中的 Microsoft Internet Information Service (IIS) 系統檔案。

  • %SystemRoot%\IIS Temporary Compressed Files 資料夾中的 IIS 工作檔。

若要更正此警告

  1. 使用 eTrust Antivirus 使用者介面，將上述列出的資料夾及檔案，排除在檔案層級的防毒掃描作業之外。

  2. 若需有關在 Exchange Server 電腦上使用 eTrust Antivirus 的最新資訊，請造訪 Computer eTrust Antivirus 網站 (英文) (http://www3.ca.com/Solutions/Product.asp?ID=156)。

    附註：
    網址可能會變更，因此您可能無法連線到此處提到的網站。

若需有關將防毒軟體和 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需可在 Exchange Server 上使用的協力廠商之防毒軟體清單，請參閱 Exchange Partners:防毒網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=16226)。

若需有關掃描 IFS 磁碟發生之問題的詳細資訊，請參閱下列知識庫文件：

  • 298924＜XADM：請勿備份或掃描 Exchange 2000 M 磁碟機＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608＜XADM：裝載資料庫時顯示的 C1041737 錯誤訊息＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046＜XADM：行事曆項目從使用者資料夾消失＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust：Exchange IFS 路徑並未從即時掃描排除
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以取得被排除在 eTrust Antivirus (來自 Computer Associates) 的即時檔案層級防毒掃描作業之外的目錄清單：

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

Exchange Server Analyzer 也會讀取下列登錄項目，來取得代表「Exchange 可安裝的檔案系統 (IFS)」磁碟機的磁碟機代號：

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

在 Exchange 2000 Server 上，預設磁碟機代號是 M。在預設的情況下，Exchange Server 2003 上的 IFS 磁碟機是關閉的。

若 Exchange Server Analyzer 發現 szExcludeDirs 的值未包含對應到 IFS 磁碟機的路徑，就會顯示一則警告。

eTrust Antivirus 是一個檔案層級的防毒掃描程式。若要判定 Exchange Server 電腦上所安裝的 eTrust Antivirus 版本，請執行下列動作：

  1. 瀏覽至 [開始] | [程式集] | [eTrust Antivirus]，然後按一下 [eTrust Antivirus]，啟動該應用程式。

  2. 在 eTrust Antivirus 應用程式功能表中，按一下 [Help]，再按一下 [About eTrust Antivirus]。

  3. 檢查 [Product Version] 欄位，判定 eTrust Antivirus 的版本。

在 Exchange Server 電腦上使用檔案層級的掃描程式時，可能會發生下列問題：

  • 檔案層級的掃描程式會在檔案被使用時 (或依排定的間隔) 掃描檔案，並且可能會在 Exchange 嘗試要使用檔案時，將 Exchange 記錄檔或資料庫檔案鎖定或隔離。這可能會導致 Exchange Server 發生嚴重的失敗，也可能會造成資料庫錯誤。

  • 如果您以檔案層級的掃描程式軟體掃描 IFS 代表的磁碟機 (通常是磁碟機 M) 時，可能會發生更多問題。

不論您使用的是哪一種檔案層級的防毒程式，都一定要在檔案層級的掃描程式中排除下列檔案：

  • .eml, .edb, .stm, .log, .dat 及 .chk 檔。

  • 由 IFS 代表的 Exchange Server 磁碟機。在預設的情況下，這是磁碟機 M。

  • Exchange 資料庫及記錄檔。在預設的情況下，這些檔案是位於 Exchsrvr\Mdbdata 資料夾中。

  • Exchsrvr\Mtadata 資料夾中的 Exchange MTA 檔案。

  • 其他記錄檔，例如 Exchsrvr\server_name.log 檔。

  • Exchsrvr\Mailroot 虛擬伺服器資料夾。

  • 用來儲存郵件轉換用的資料流暫存檔之工作資料夾。在預設的情況下，這個資料夾是位於 \Exchsrvr\MDBData，不過您可以設定其位置。

  • 離線維護工具 (如 Eseutil.exe) 使用之臨時資料夾。在預設的情況下，這個資料夾是 .exe 檔的執行位置，但是您可以在執行工具時，設定其位置。

  • Exchsrvr\Srsdata 資料夾中的「站台複寫服務 (SRS)」檔案。

  • %SystemRoot%\System32\Inetsrv 資料夾中的 Microsoft Internet Information Service (IIS) 系統檔案。

  • %SystemRoot%\IIS Temporary Compressed Files 資料夾中的 IIS 工作檔。

若要更正此警告

  1. 使用 eTrust Antivirus 使用者介面，將上述列出的資料夾及檔案，排除在檔案層級的防毒掃描作業之外。

  2. 若需有關在 Exchange Server 電腦上使用 eTrust Antivirus 的最新資訊，請造訪 CA eTrust Antivirus 網站 (英文) (http://www3.ca.com/Solutions/Product.asp?ID=156)。

    附註：
    網址可能會變更，因此您可能無法連線到此處提到的網站。

若需有關將防毒軟體和 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需可在 Exchange Server 上使用的協力廠商之防毒軟體清單，請參閱 Exchange Partners:防毒網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=16226)。

若需有關掃描 IFS 磁碟發生之問題的詳細資訊，請參閱下列知識庫文件：

  • 298924＜XADM：請勿備份或掃描 Exchange 2000 M 磁碟機＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608＜XADM：裝載資料庫時顯示的 C1041737 錯誤訊息＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046＜XADM：行事曆項目從使用者資料夾消失＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust：即時掃描設為掃描所有檔案，忽略副檔名
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2006-04-21

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來取得被排除在 eTrust Antivirus (Computer Associates 公司的產品) 的即時檔案層級防毒掃描作業之外的副檔名清單：

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\dwFileFilterType

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\dwFileFilterType

如果 Exchange Server Analyzer 判定 dwFileFilterType 的值設為掃描所有檔案 (不論副檔名無何)，則會顯示警告。

eTrust Antivirus 是一個檔案層級的防毒掃描程式。若要判定 Exchange Server 電腦上所安裝的 eTrust Antivirus 版本，請執行下列動作:

  1. 瀏覽至 [開始] | [程式集] | eTrust Antivirus，然後按一下 eTrust Antivirus，啟動該應用程式。

  2. 在 eTrust Antivirus 應用程式功能表中，按一下 [說明]，再按一下 [關於 eTrust Antivirus]。

  3. 檢查 [產品版本] 欄位，判定 eTrust Antivirus 的版本。

當您在 Exchange Server 電腦上使用檔案層級的掃描程式時，可能會發生下列問題：

  • 檔案層級的掃描程式會在檔案被使用時 (或依排定的間隔) 掃描檔案，並且可能會在 Exchange 嘗試要使用檔案時，將 Exchange 記錄檔或資料庫檔案鎖定或隔離。這可能會導致 Exchange Server 發生嚴重的失敗，也可能會造成資料庫錯誤。

  • 如果您以檔案層級的掃描程式軟體掃描 Exchange 可安裝的檔案系統 (IFS) 代表的磁碟機 (通常是磁碟機 M) 時，可能會發生更多問題。

不論您使用的是哪一種檔案層次的防毒程式，都一定要在檔案層級的掃描程式中排除下列檔案：

  • .eml, .edb, .stm, .log, .dat 及 .chk 檔。

  • 由 IFS 代表的 Exchange Server 磁碟機。依預設，這是 M:磁碟機。

  • Exchange 資料庫及記錄檔。在預設的情況下，這些檔案是位於 Exchsrvr\Mdbdata 資料夾中。

  • Exchsrvr\Mtadata 資料夾中的 Exchange MTA 檔案。

  • 其他記錄檔，例如 Exchsrvr\server_name.log 檔。

  • Exchsrvr\Mailroot 虛擬伺服器資料夾。

  • 用來儲存郵件轉換用的資料流暫存檔之工作資料夾。在預設的情況下，這個資料夾是位於 \Exchsrvr\MDBData，不過您可以設定其位置。

  • 離線維護工具 (如 Eseutil.exe) 使用之臨時資料夾。在預設的情況下，這個資料夾是 .exe 檔的執行位置，但是您可以在執行工具時，設定其位置。

  • Exchsrvr\Srsdata 資料夾中的「站台複寫服務 (SRS)」檔案。

  • %SystemRoot%\System32\Inetsrv 資料夾中的 Microsoft Internet Information Service (IIS) 系統檔案。

  • %SystemRoot%\IIS Temporary Compressed Files 資料夾中的 IIS 工作檔。

若要更正此警告

  1. 使用 eTrust Antivirus 使用者介面，從檔案層級防毒掃描中排除列出的資料夾和檔案。

  2. 若需在 Exchange Server 電腦上使用 eTrust Antivirus 的最新資訊，請造訪 CA eTrust Antivirus 網站 (英文) (http://www3.ca.com/Solutions/Product.asp?ID=156)。

    附註：
    網址可能會變更，因此您可能無法連線到此處提到的網站。

若需有關將防毒軟體和 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需可在 Exchange Server 上使用的協力廠商之防毒軟體清單，請參閱 Exchange Partners:防毒網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=16226)。

若需有關掃描 IFS 磁碟發生之問題的詳細資訊，請參閱下列知識庫文件：

  • 298924＜XADM：請勿備份或掃描 Exchange 2000 M 磁碟機＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608＜XADM：裝載資料庫時顯示的 C1041737 錯誤訊息＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046＜XADM：行事曆項目從使用者資料夾消失＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust：儲存群組磁碟機並未從手動工作掃描排除
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來取得被排除在 eTrust Antivirus (Computer Associates 公司的產品) 的手動檔案層級防毒掃描作業之外的目錄清單：

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

Exchange Server Analyzer 也會讀取 Active Directory® 目錄服務中的 MsExchESEParamSystemPath 屬性，該屬性對應到 Exchange 系統記錄檔位置的儲存群組屬性。

如果 Exchange Server Analyzer 發現 szExcludeDirs 的值不包括對應到 Exchange 系統記錄檔位置的路徑，就會顯示一則警告。

eTrust Antivirus 是檔案層級的防毒掃描程式。若要判定安裝在 Exchange Server 電腦的 eTrust Antivirus 版本，請執行下列動作：

  1. 瀏覽至 [開始] | [程式集] | eTrust Antivirus，然後按一下 eTrust Antivirus，啟動該應用程式。

  2. 在 eTrust Antivirus 應用程式功能表中，按一下 [Help]，再按一下 [About eTrust Antivirus]。

  3. 檢查 [Product Version] 欄位，判定 eTrust Antivirus 的版本。

在 Exchange Server 電腦上使用檔案層級的掃描程式時，可能會發生下列問題：

  • 檔案層級的掃描程式會在檔案被使用時 (或依排定的間隔) 掃描檔案，並且可能會在 Exchange 嘗試要使用檔案時，將 Exchange 記錄檔或資料庫檔案鎖定或隔離。這可能會導致 Exchange Server 發生嚴重的失敗，也可能會造成資料庫錯誤。

  • 如果您以檔案層級的掃描程式軟體掃描 Exchange 可安裝的檔案系統 (IFS) 代表的磁碟機 (通常是磁碟機 M) 時，可能會發生更多問題。

不論您使用的是哪一種檔案層級的防毒程式，都一定要在檔案層級的掃描程式中排除下列檔案：

  • .eml, .edb, .stm, .log, .dat 及 .chk 檔。

  • 由 IFS 代表的 Exchange Server 磁碟機。在預設的情況下，這是磁碟機 M。

  • Exchange 資料庫及記錄檔。在預設的情況下，這些檔案是位於 Exchsrvr\Mdbdata 資料夾中。

  • Exchsrvr\Mtadata 資料夾中的 Exchange MTA 檔案。

  • 其他記錄檔，例如 Exchsrvr\server_name.log 檔。

  • Exchsrvr\Mailroot 虛擬伺服器資料夾。

  • 用來儲存郵件轉換用的資料流暫存檔之工作資料夾。在預設的情況下，這個資料夾是位於 \Exchsrvr\MDBData，不過您可以設定其位置。

  • 離線維護工具 (如 Eseutil.exe) 使用之臨時資料夾。在預設的情況下，這個資料夾是 .exe 檔的執行位置，但是您可以在執行工具時，設定其位置。

  • Exchsrvr\Srsdata 資料夾中的「站台複寫服務 (SRS)」檔案。

  • %SystemRoot%\System32\Inetsrv 資料夾中的 Microsoft Internet Information Service (IIS) 系統檔案。

  • %SystemRoot%\IIS Temporary Compressed Files 資料夾中的 IIS 工作檔。

若要更正此警告

  1. 使用 eTrust Antivirus 使用者介面，將上述列出的資料夾及檔案，排除在檔案層級的防毒掃描作業之外。

  2. 若需有關在 Exchange Server 電腦上使用 eTrust Antivirus 的最新資訊，請造訪 Computer eTrust Antivirus 網站 (英文) (http://www3.ca.com/Solutions/Product.asp?ID=156)。

    附註：
    網址可能會變更，因此您可能無法連線到此處提到的網站。

若需有關將防毒軟體和 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

  • 若需可在 Exchange Server 上使用的協力廠商之防毒軟體清單，請參閱 Exchange Partners:防毒網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=16226)。

若需有關掃描 IFS 磁碟發生之問題的詳細資訊，請參閱下列知識庫文件：

  • 298924＜XADM：請勿備份或掃描 Exchange 2000 M 磁碟機＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608＜XADM：裝載資料庫時顯示的 C1041737 錯誤訊息＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046＜XADM：行事曆項目從使用者資料夾消失＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust：儲存群組磁碟機並未從即時掃描排除
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以取得被排除在 eTrust Antivirus (Computer Associates 的產品) 的即時檔案層級防毒掃描作業之外的目錄清單：

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

Exchange Server Analyzer 也會在 Active Directory® 目錄服務中查詢 MsExchESEParamSystemPath 屬性的值，此值為對應到 Exchange 系統資料檔案位置的儲存群組屬性。

若 Exchange Server Analyzer 發現 szExcludeDirs 的值未包含對應到 Exchange 系統資料檔案位置的路徑，就會顯示一則警告。

eTrust Antivirus 是一個檔案層級的防毒掃描程式。若要判定 Exchange Server 電腦上安裝的 eTrust Antivirus 版本：

  1. 瀏覽至 [開始] | [程式集] | eTrust Antivirus，然後按一下 eTrust Antivirus，啟動該應用程式。

  2. 在 eTrust Antivirus 應用程式功能表中，按一下 Help，再按一下 About eTrust Antivirus。

  3. 檢查 Product Version 欄位，判定 eTrust Antivirus 的版本。

在 Exchange Server 電腦上使用檔案層級的掃描程式時，可能會發生下列問題：

  • 檔案層級的掃描程式會在檔案被使用時 (或依排定的間隔) 掃描檔案，並且可能會在 Exchange 嘗試要使用檔案時，將 Exchange 記錄檔或資料庫檔案鎖定或隔離。這可能會導致 Exchange Server 發生嚴重的失敗，也可能會造成資料庫錯誤。

  • 如果您以檔案層級的掃描程式軟體掃描 Exchange 可安裝的檔案系統 (IFS) 代表的磁碟機 (通常是磁碟機 M) 時，可能會發生更多問題。

不論您使用的是哪一種檔案層次的防毒程式，都一定要在檔案層級的掃描程式中排除下列檔案：

  • .eml, .edb, .stm, .log, .dat 及 .chk 檔。

  • 由 IFS 代表的 Exchange Server 磁碟機。在預設的情況下，這是磁碟機 M。

  • Exchange 資料庫及記錄檔。在預設的情況下，這些檔案是位於 Exchsrvr\Mdbdata 資料夾中。

  • Exchsrvr\Mtadata 資料夾中的 Exchange MTA 檔案。

  • 其他記錄檔，例如 Exchsrvr\server_name.log 檔。

  • Exchsrvr\Mailroot 虛擬伺服器資料夾。

  • 用來儲存郵件轉換用的資料流暫存檔之工作資料夾。在預設的情況下，這個資料夾是位於 \Exchsrvr\MDBData，不過您可以設定其位置。

  • 離線維護工具 (如 Eseutil.exe) 使用之臨時資料夾。在預設的情況下，這個資料夾是 .exe 檔的執行位置，但是您可以在執行工具時，設定其位置。

  • Exchsrvr\Srsdata 資料夾中的「站台複寫服務 (SRS)」檔案。

  • %SystemRoot%\System32\Inetsrv 資料夾中的 Microsoft Internet Information Service (IIS) 系統檔案。

  • %SystemRoot%\IIS Temporary Compressed Files 資料夾中的 IIS 工作檔。

若要更正此警告

  1. 使用 eTrust Antivirus 使用者介面，將上述列出的資料夾及檔案，排除在檔案層次的防毒掃瞄作業之外。

  2. 若需有關在 Exchange Server 電腦上使用 eTrust Antivirus 的最新資訊，請造訪 CA eTrust Antivirus 網站 (英文) (http://www3.ca.com/Solutions/Product.asp?ID=156)。

    附註：
    網址可能會變更，因此您可能無法連線到此處提到的網站。

若需有關將防毒軟體和 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需可在 Exchange Server 上使用的協力廠商之防毒軟體清單，請參閱 Exchange Partners:防毒網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=16226)。

若需有關掃描 IFS 磁碟發生之問題的詳細資訊，請參閱下列知識庫文件：

  • 298924＜XADM：請勿備份或掃描 Exchange 2000 M 磁碟機＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608＜XADM：裝載資料庫時顯示的 C1041737 錯誤訊息＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046＜XADM：行事曆項目從使用者資料夾消失＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust：尚未從即時掃描中排除 Exchange 處理程序
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以取得被排除在 eTrust Antivirus (Computer Associates 的產品) 的即時檔案層級防毒掃描作業之外的處理程序清單：

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\RealTime\szExcludeProcessNames

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeProcessNames

如果 Exchange Server Analyzer 發現 szExcludeProcessNames 的值未包含 STORE.EXE、EMSMTA.EXE 及 MAD.EXE，則會顯示警告。

當 Microsoft Exchange Information Store 處理程序 (Store.exe)、Exchange MTA 處理程序 (Emsmta.exe) 或「系統服務員」處理程序 (Mad.exe) 正在執行時，建議您不要使用檔案層級的防毒掃描程式來掃描這些處理程序。

eTrust Antivirus 是一個檔案層級的防毒掃描程式。若要判定 Exchange Server 電腦上所安裝的 eTrust Antivirus 版本，請執行下列動作:

  1. 瀏覽至 [開始] | [程式集] | eTrust Antivirus，然後按一下 eTrust Antivirus，啟動該應用程式。

  2. 在 eTrust Antivirus 應用程式功能表中，按一下 [說明]，再按一下 [關於 eTrust Antivirus]。

  3. 檢查 [產品版本] 欄位，判定 eTrust Antivirus 的版本。

在 Exchange Server 電腦上使用檔案層級的掃描程式時，可能會發生下列問題：

  • 檔案層級的掃描程式會在檔案被使用時 (或依排定的間隔) 掃描檔案，並且可能會在 Exchange 嘗試要使用檔案時，將 Exchange 記錄檔或資料庫檔案鎖定或隔離。這可能會導致 Exchange Server 發生嚴重的失敗，也可能會造成資料庫錯誤。

  • 如果您以檔案層級的掃描程式軟體掃描 IFS 代表的磁碟機 (通常是磁碟機 M) 時，可能會發生更多問題。

不論您使用的是哪一種檔案層次的防毒程式，都一定要在檔案層級的掃描程式中排除下列檔案：

  • .eml, .edb, .stm, .log, .dat 及 .chk 檔。

  • 由 IFS 代表的 Exchange Server 磁碟機。在預設的情況下，這是磁碟機 M。

  • Exchange 資料庫及記錄檔。在預設的情況下，這些檔案是位於 Exchsrvr\Mdbdata 資料夾中。

  • Exchsrvr\Mtadata 資料夾中的 Exchange MTA 檔案。

  • 其他記錄檔，例如 Exchsrvr\server_name.log 檔。

  • Exchsrvr\Mailroot 虛擬伺服器資料夾。

  • 用來儲存郵件轉換用的資料流暫存檔之工作資料夾。在預設的情況下，這個資料夾是位於 \Exchsrvr\MDBData，不過您可以設定其位置。

  • 離線維護工具 (如 Eseutil.exe) 使用之臨時資料夾。在預設的情況下，這個資料夾是 .exe 檔的執行位置，但是您可以在執行工具時，設定其位置。

  • Exchsrvr\Srsdata 資料夾中的「站台複寫服務 (SRS)」檔案。

  • %SystemRoot%\System32\Inetsrv 資料夾中的 Microsoft Internet Information Service (IIS) 系統檔案。

  • %SystemRoot%\IIS Temporary Compressed Files 資料夾中的 IIS 工作檔。

若要更正此警告

  1. 使用 eTrust Antivirus 使用者介面，將上述列出的資料夾及檔案，排除在檔案層級的防毒掃描作業之外。

  2. 若需有關在 Exchange Server 電腦上使用 eTrust Antivirus 的最新資訊，請造訪 Computer eTrust Antivirus 網站 (英文) (http://www3.ca.com/Solutions/Product.asp?ID=156)。

    附註：
    網址可能會變更，因此您可能無法連線到此處提到的網站。

若需有關將防毒軟體和 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需可在 Exchange Server 上使用的協力廠商之防毒軟體清單，請參閱 Exchange Partners:防毒網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=16226)。

若需有關掃描 IFS 磁碟發生之問題的詳細資訊，請參閱下列知識庫文件：

  • 298924＜XADM：請勿備份或掃描 Exchange 2000 M 磁碟機＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608＜XADM：裝載資料庫時顯示的 C1041737 錯誤訊息＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046＜XADM：行事曆項目從使用者資料夾消失＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


有可用的 Client Service Messaging Security for SMB v2.0 更新
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2006-02-13

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目：

HKEY_LOCAL_MACHINE\SOFTWARE\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

若 Version 值為 6.2100，表示已安裝 Trend Micro ScanMail Client Service Messaging Security for SMB v2.0。

Microsoft® Exchange Server Analyzer 也會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，判斷已安裝的 Client Service Messaging Security for SMB 2.0 版的版本。如果主要組建編號小於 1145，Exchange Server Analyzer 就會顯示警告。

此警告指出 Exchange 伺服器上安裝了 Client Server Messaging Security for SMB v2.0，而且有建議的軟體更新可用。建議的更新是適用於 Messaging Component 的 Client Server Messaging Security for SMB v2.0 Patch 2。強烈建議使用此更新，此更新可增進伺服器的整體效能及可靠性。

若要更正此警告

  1. 造訪 Trend Micro Update Center，以取得 Client Server Messaging Security for SMB (http://www.trendmicro.com/download/product.asp?productid=39)。

  2. 下載並安裝 Patch 2。
附註：
本主題也提供協力廠商網站資訊，協助您找到需要的技術資訊。URL 如有變更，恕不另行通知。

若需其他 Trend Micro 產品更新的詳細資訊，請參閱 Trend Micro Update Center 網站 (英文) (http://www.trendmicro.com/download/)。

若需將防毒軟體與 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN：Microsoft 在 Exchange 2000 防毒解決方案中的地位＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需 Exchange Server 可用的協力廠商防毒軟體清單，請參閱＜Exchange Server 合作夥伴：防毒＞(英文) (http://go.microsoft.com/fwlink/?linkid=16226)。


考慮安裝 HP Command View EVAPerf
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-12-09

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_SCSIController Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Name 機碼值。如果 Name 機碼值等於 Compaq HSV110CCL，則表示伺服器上至少有一個由 HP EVA 儲存區域網路 (SAN) 提供的磁碟區。

Exchange Server Analyzer 也會查詢 Win32_Service WMI 類別，以判定 HP StorageWorks Command View EVAPerf (EVSPDCS) 服務的 Started 機碼值。值為 False 表示服務不在執行中。值為 True 表示服務正在執行中。

如果下列狀況皆存在，Exchange Server Analyzer 就會顯示最佳作法建議：

  • 伺服器上至少有一個由 HP EVA SAN 提供的磁碟區。

  • HP StorageWorks Command View EVAPerf (EVSPDCS) 服務不存在或未執行。

HP 提供免費的軟體管理應用程式，可發行用於 HP StorageWorks SAN 的其他效能計數器。系統管理員可以使用此軟體管理應用程式，來監視 SAN 中個別控制站及實體磁碟的效能。

若要遵循建議的最佳作法

  1. 移至「HP StorageWorks Command View EVAPerf 軟體」網站，下載 HP Command View EVAPerf 應用程式 (英文) (http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?pnameOID=471498&locale=en_US&taskId=135&prodSeriesId=471497&prodTypeId=12169&swEnvOID=1005http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?pnameOID=471498&locale=en_US&taskId=135&prodSeriesId=471497&prodTypeId=12169&swEnvOID=1005)。

    附註：
    以下提供協力廠商網站資訊，協助您找到需要的技術資訊。URL 如有變更，恕不另行通知。

  2. 執行下載的自我解壓縮可執行檔，並遵循指示來安裝應用程式。


EMC PowerPath 服務已停止
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 EMC PowerPath Service 服務的 Started 機碼值。值為 TRUE 表示 EMC PowerPath Service 服務正在執行中，而值為 FALSE 表示 EMCPowerPath Service 服務不在執行中。如果 Exchange Server Analyzer 發現 Started 機碼值為 False，便會顯示一則警告。

EMC PowerPath 為一多路徑 I/O (MPIO) 軟體。多路徑可提供高可用性資料存取，方法是允許一部主機最多可擁有 32 個路徑來存取外部儲存裝置，這樣有助於容錯移轉及負載平衡。多路徑不是作業系統的功能，而是透過「MPIO 驅動程式開發套件 (DDK)」來支援的功能，該套件提供一個方法供儲存裝置廠商建立可交互操作的多路徑解決方案。

執行 MPIO 軟體時，MPIO 軟體會管理各種儲存裝置的多重連線，而 Microsoft Windows® 只會偵測到單一磁碟機。若已停止 MPIO 軟體，則 Windows 將偵測到所有已連接的儲存磁碟機，並且視為個別的磁碟機。這樣可能會導致儲存裝置錯誤及故障。

若要啟動 EMC PowerPath Service 服務

  1. 開啟 [服務] MMC 嵌入式管理單元。

  2. 以滑鼠右鍵按一下 [EMC PowerPath Service] 服務，再按一下 [內容]。

  3. 在 [EMC PowerPath Service] 內容頁的 [一般] 索引標籤上，確定 [啟動類型] 已設為 [自動]。如果不是，請按一下 [套用]，然後按一下 [確定]。

  4. 以滑鼠右鍵按一下 [EMC PowerPath Service] 服務，再按一下 [啟動]。

  5. 關閉 [服務] 嵌入式管理單元。

若需有關部署 Windows 不同儲存技術的一般資訊，請參閱＜計劃搭配使用 Windows 儲存功能及 SAN＞(英文) (http://go.microsoft.com/fwlink/?LinkId=33626)。


EMC PowerPath Version Mismatch Between Cluster Nodes
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2007-07-25

Microsoft Exchange Analyzer 工具會讀取下列登錄項目，以判定叢集中每個節點上安裝的 EMC PowerPath 版本：

HKEY_LOCAL_MACHINE\SOFTWARE\EMC\PowerPath\Version

如果 Exchange Analyzer 發現 Exchange 叢集中第二個節點或後續節點的 Version 值，不同於 Exchange 叢集中第一個節點的 Version 值，就會顯示錯誤。

此錯誤指出此 Exchange 叢集中的節點不是執行相同層級的 EMC PowerPath 驅動程式。建議的最佳作法是 Exchange 叢集中的所有節點都執行相同層級的 EMC PowerPath 驅動程式。

EMC PowerPath 為多路徑 I/O (MPIO) 軟體。多路徑可提供高可用性資料存取，方法是允許一部主機最多可擁有 32 個路徑來存取外部儲存裝置，這樣有助於容錯移轉及負載平衡。多路徑不是作業系統的功能，而是透過「MPIO 驅動程式開發套件 (DDK)」來支援的功能，該套件提供一個方法供儲存裝置廠商建立可交互操作的多路徑解決方案。

執行 MPIO 軟體時，MPIO 軟體會管理各種儲存裝置的多重連線，而 Microsoft Windows 只會偵測到單一磁碟機。如果叢集的不同節點之間 MPIO 驅動程式不符，可能會導致叢集容錯移轉問題。

若要解決此問題，必須將所有節點升級為相同的 EMC PowerPath 驅動程式版本。

詳細資訊

如需利用 Windows 部署不同儲存技術的相關資訊，請參閱＜計劃使用 Windows 儲存功能與 SAN 搭配＞(英文) (http://go.microsoft.com/fwlink/?LinkId=33626)。


Emulex FC Port 驅動程式已超過兩年未更新
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2006-04-19

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_SCSIController Microsoft® Windows® Management Instrumentation (WMI) 類別，以判定是否已設定 DriverName 機碼值。Exchange Server Analyzer 工具會判定下列狀況是否存在：

  • Exchange 伺服器已安裝 Emulex FC Port 驅動程式。

  • Exchange 伺服器上已安裝 Emulex FC Port 驅動程式的目前版本。

  • Emulex FC Port 驅動程式在過去兩年內已更新。

如果 Exchange Server Analyzer 發現 DriverName 機碼的值已超過兩年未更新，則會顯示警告。

Emulex FC Port 驅動程式在單一主匯流排介面卡 (HBA) 或數個 HBA 內，提供僅限 SCSI 或同時 SCSI 及 IP 功能。FC Port 驅動程式支援光纖通道仲裁迴圈 (FC-AL) 拓撲、點對點拓撲及結構拓撲。FC Port 驅動程式設計用於需要以主機為基礎的邏輯單元數 (LUN) 對應或持續繫結的特定應用程式。

若要更新 Emulex FC Port 驅動程式，請參閱《Windows 下載及手冊》(英文) (http://www.emulex.com/ts/docfc/winframe.htm)。如果需要特殊 OEM 驅動程式，請參閱 Emulex 軟體及文件網站 (http://www.emulex.com/ts/index.html)。

附註：
本主題之所以提供協力廠商網站資訊是為了協助您尋找您需要的技術資訊。URL 隨時都會變更，不另行通知。


Emulex SCSIport Miniport 驅動程式已超過兩年未更新
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2006-06-14

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_SCSIController Microsoft Windows® Management Instrumentation (WMI) 類別，以判定是否已設定 DriverName 機碼值。Exchange Server Analyzer 工具會判定下列狀況是否存在：

  • Exchange 伺服器上已安裝 Emulex SCSIport Miniport 驅動程式。

  • Exchange 伺服器上已安裝 Emulex SCSIport Miniport 驅動程式的目前版本。

  • Emulex SCSIport Miniport 驅動程式在過去兩年內已更新。

如果 Exchange Server Analyzer 發現 DriverName 機碼的值已超過兩年未更新，則會顯示警告。

SCSIport Miniport 驅動程式提供透過光纖通道仲裁迴圈 (FC-AL) 拓撲、點對點拓撲及結構拓撲的 SCSI 功能。

若要更新 Emulex SCSIport Miniport 驅動程式，請參閱＜Windows 的下載及手冊＞(英文) (http://www.emulex.com/ts/docfc/winframe.htm)。如果您需要特殊的 OEM 驅動程式，請參閱＜OEM 軟體及文件＞(英文) (http://www.emulex.com/ts/index.html)。

附註：
網址可能會變更，因此您可能無法連線到此處提到的網站。


Emulex Storport Miniport 驅動程式已超過兩年未更新
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2006-06-14

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_SCSIController Microsoft® Windows® Management Instrumentation (WMI) 類別，以判定是否已設定 DriverName 機碼值。Exchange Server Analyzer 工具會判定下列狀況是否存在：

  • Exchange 伺服器已安裝 Emulex Storport Miniport 驅動程式。

  • Exchange 伺服器已安裝目前版本的 Emulex Storport Miniport 驅動程式。

  • Emulex Storport Miniport 驅動程式在過去兩年內已更新。

如果 Exchange Server Analyzer 發現 DriverName 機碼的值已超過兩年未更新，則會顯示警告。

Emulex Storport Miniport 驅動程式可最佳化儲存區域網路 (SAN) 及以硬體為基礎之磁碟陣列的效能及管理能力。Emulex Storport Miniport 驅動程式支援光纖通道仲裁迴圈 (FC-AL) 拓撲、點對點拓撲及結構拓撲。

若要更新 Emulex Storport Miniport 驅動程式，請參閱《Windows 下載及手冊》(英文) (http://www.emulex.com/ts/docfc/winframe.htm)。如果您需要特別的 OEM 驅動程式，請參閱「OEM 軟體及說明文件」(英文) (http://www.emulex.com/ts/index.html)。

附註：
網址可能會變更，因此您可能無法連線到此處提到的網站。


非 Exchange 處理程序中的高 CPU 使用量
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

  • Microsoft® Exchange Server Analyzer 工具已找到一個非 Exchange Server 處理程序，它目前使用了超過百分之二十的伺服器可用 CPU。如果非 Exchange Server 處理程序使用了超過百分之二十的可用 CPU，便會顯示錯誤。

  • 建議您盡可能讓執行 Exchange Server 的伺服器只執行 Exchange Server，且在 Exchange 之外執行的應用程式或服務越少越好。

若要更正此錯誤

  • 如果其他的處理程序使用了大部分的 CPU，請嘗試下列其中一個選項：

    • 關閉處理程序並察看是否已解決問題。

    • 若可以，請將該處理程序移到其他伺服器上。

    • 確定已正確設定處理程序，並尋找 Microsoft 及處理程序提供者是否有任何更新程式可解決此問題。

    • 若不需要該處理程序，請將它解除安裝。

  • 如果無法移動或修復處理程序，則應該重新調整伺服器，允許非 Exchange Server 處理程序額外的負載。在這次重新調整中，您應該考慮將使用者移到其他的 Exchange 伺服器。


已停止 HP/Compaq Secure Path 服務
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 HP/Compaq Secure Path 服務是否正在執行中。如果 Exchange Server Analyzer 判定 HP/Compaq Secure Path 服務不在執行中，就會顯示警告。

HP/Compaq Secure Path 服務為多重路徑 I/O (MPIO) 軟體。多路徑可提供高可用性資料存取，方法是允許一部主機最多可擁有 32 個路徑來存取外部儲存裝置，這樣有助於容錯移轉及負載平衡。多路徑不是作業系統的功能，而是透過「MPIO 驅動程式開發套件 (DDK)」來支援的功能，該套件提供一個方法供儲存裝置廠商建立可交互操作的多路徑解決方案。

執行 MPIO 軟體時，MPIO 軟體會管理連到各種儲存裝置的多重連線，而 Windows 作業系統只會偵測到單一磁碟機。若已停止 MPIO 軟體，則 Windows 將偵測到所有已連接的儲存磁碟機，並且視為個別的磁碟機。這樣可能會導致儲存裝置錯誤及故障。

若要更正此警告

  1. 開啟 [服務] MMC 嵌入式管理單元。

  2. 在 HP/Compaq Secure Path 服務上按一下滑鼠右鍵，再按 [內容]。

  3. 在 [HP/Compaq Secure Path] 服務內容頁的 [一般] 索引標籤上，確定 [啟動類型] 已設為 [自動]。如果不是，請按一下 [套用]，然後按一下 [確定]。

  4. 在 HP/Compaq Secure Path 服務上按一下滑鼠右鍵，再按 [啟動]。

  5. 關閉 [服務] 嵌入式管理單元。

若需有關以 Windows 來部署不同儲存技術的一般資訊，請參閱＜規劃搭配使用 Windows 儲存功能與 SAN＞(英文) (http://go.microsoft.com/fwlink/?linkid=33626)。


協力廠商軟體的影響
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具判定您正在 Exchange 伺服器上執行協力廠商軟體。此協力廠商軟體可能是造成伺服器發生問題的成因。協力廠商軟體可能包含 (但不限於) 下列軟體：

  • 檔案層級的防毒產品

  • Exchange 感知的電子郵件防毒產品

  • 防垃圾郵件產品

  • 傳真伺服器軟體

  • 外部郵件或協同作業連接器

  • 檔案及列印服務

  • 行動裝置連接器

若要更正此錯誤

  • 如果您懷疑是協力廠商軟體降低了 Exchange Server 的效能，請解除安裝或停用協力廠商軟體，再測量 Exchange Server 的效能。

  • 如果您判定是協力廠商軟體造成效能降低，但是協力廠商軟體對於伺服器的功能而言十分重要，請考慮指定其他伺服器，將負載發佈到這兩個伺服器上。

詳細資訊

  • 若需有關 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需有關疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《疑難排解 Microsoft Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


有可用的 INO_FLPY.SYS 版本更新
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Ino_flpy.sys Computer Associates 防毒篩選器驅動程式的版本。

Exchange Server Analyzer 會查詢 CIM_Datafile WMI 類別，以判定 Ino_flpy.sys 的 Version 機碼值，並且會根據此版本組建編號來決定是否需要進行軟體更新。如果 Version 機碼值表示 Ino_flpy.sys 檔案的版本號碼小於 5.00.6100.109，就會顯示警告。

版本號碼小於 5.00.6100.109 表示 Exchange Server 電腦上未安裝 Ino_flpy.sys 檔案的最新版本，因此應安裝較新版本的篩選器驅動程式。您可以在 Computer Associates 網站找到 Ino_flpy.sys 檔案的防毒軟體更新。強烈建議您使用此防毒軟體更新，此更新可改善 Exchange Server 電腦的整體效能及可靠性。

當 Exchange 2000 Server 或 Exchange Server 2003 電腦上安裝了 Inoculan Computer Associates eTrust Antivirus 6.x 或 7.x 版及 InoculateIT 6.x 版防毒軟體程式時，安裝程式會將 Ino_flpy.sys 及 Ino_fltr.sys 防毒篩選器驅動程式檔案複製到 %systemroot%\system32\drivers 資料夾。防毒驅動程式檔案是一種 Windows NT® 核心模式驅動程式，可用來啟動必要的防毒服務。舊版的篩選器驅動程式會造成 Exchange Server 電腦發生意外的結果。

若要更正此警告

  1. 若要取得 ino_flpy.sys 檔案的最新防毒軟體更新，請造訪 Computer Associates 網站 (英文) (http://supportconnectw.ca.com/premium/antivirus/downloads/nt/4.5/ildrvupdate.asp)。

  2. 下載適當的 eTrust 或 InoculateIT 更新版本。

  3. 製作 Exchange Server 電腦的完整備份 (包括 Ino_flpy.sys 檔案的備份)。

  4. 安裝最新的更新到 eTrust 或 InoculateIT。
附註：
網址可能有所變更，因此可能會無法連線到此處所提的網站。

若需將防毒軟體與 Exchange Server 搭配使用的相關資訊，請參閱下列微軟知識庫文件：

  • 240309＜如何使防毒軟體完全不篩選檔案＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240309)

  • 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需 Exchange Server 可用的協力廠商防毒軟體清單，請參閱 Exchange 合作夥伴：防毒網站 (英文) (http://go.microsoft.com/fwlink/?linkid=16226)。


有可用的 INO_FLTR.SYS 版本更新
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Ino_fltr.sys Computer Associates 防毒篩選器驅動程式的版本。

Exchange Server Analyzer 會查詢 CIM_Datafile WMI 類別，以判定 Ino_fltr.sys 的 Version 機碼值，並且會根據此版本組建編號來決定是否需要進行軟體更新。如果Version 機碼值表示 Ino_fltr.sys 檔案的版本編號小於 5.00.6100.142，就會顯示警告。

小於 5.00.6100.142 的版本編號表示 Exchange Server 電腦上未安裝 Ino_fltr.sys 檔案的最新版本，因此應安裝較新版本的篩選器驅動程式。您可以在 Computer Associates 網站找到 Ino_fltr.sys 檔案的防毒軟體更新。強烈建議您使用此防毒軟體更新，此更新可改善 Exchange Server 電腦的整體效能及可靠性。

當 Exchange 2000 Server 或 Exchange Server 2003 電腦上安裝了 Inoculan Computer Associates eTrust Antivirus 6.x 或 7.x 版及 InoculateIT 6.x 版防毒軟體程式時，安裝程式會將 Ino_flpy.sys 及 Ino_fltr.sys 防毒篩選器驅動程式檔案複製到 %systemroot%\system32\drivers 資料夾。防毒驅動程式篩選器檔案是一種 Windows NT® 核心模式驅動程式，可用來啟動必要的防毒服務。舊版的篩選器驅動程式會造成 Exchange Server 電腦發生意外的結果。

若要更正此警告

  1. 若要取得 Ino_fltr.sys 檔案的最新防毒軟體更新，請造訪 Computer Associates 網站：(http://supportconnectw.ca.com/premium/antivirus/downloads/nt/4.5/ildrvupdate.asp)。

  2. 下載適當的 eTrust 或 InoculateIT 更新版本。

  3. 製作 Exchange Server 電腦的完整備份 (包括 Ino_fltr.sys 檔案的備份)。

  4. 安裝最新的更新到 eTrust 或 InoculateIT。
附註：
網址可能有所變更，因此可能會無法連線到此處所提的網站。

若需將防毒軟體與 Exchange Server 搭配使用的相關資訊，請參閱下列微軟知識庫文件：

  • 240309＜如何使防毒軟體完全不篩選檔案＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240309)

  • 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需 Exchange Server 可用的協力廠商防毒軟體清單，請參閱 Exchange Server 合作夥伴：防毒網站 (英文) (http://go.microsoft.com/fwlink/?linkid=16226)。


Exchange 有可用的 McAfee GroupShield 5.2 for Microsoft Exchange 更新
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2006-04-19

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄值，以判定是否已向 Microsoft Exchange Information Store 服務註冊病毒掃描應用程式發展介面 (Virus Scanning Application Programming Interface, VSAPI) 程式庫檔案：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

當 Exchange 2000 Server 或 Exchange Server 2003 上安裝有 McAfee GroupShield 5.2 for Microsoft Exchange 時，Library 登錄項目會有 GSEVS2.DLL 的值。此程式庫檔案會在 GroupShield 5.2 for Microsoft Exchange 中執行數個 VSAPI 相關功能。

Exchange Server Analyzer 也會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 GSEVS2.DLL 的 Version 機碼值。如果 Version 機碼值表示此檔案的組建編號小於 682，就會顯示警告。

GSEVS2.DLL 的版本號碼小於 682 表示未安裝 GroupShield 5.2 for Microsoft Exchange 的最新版本。可從 McAfee 網站取得 GroupShield 5.2 for Microsoft Exchange 的軟體更新。建烈建議使用此更新，且此更新可增進整體效能及可靠性。此外，升級至 GroupShield for Microsoft Exchange 5.2.682 可以保證您使用的是重要 DLL 的最新版本。使用最新版本的 gsevs2.dll 可顯著改善 Exchange Server 郵件傳送部署的效能及可靠性。

若要更正此警告

  1. 造訪 McAfee 網站 (http://knowledgemap.nai.com/) 的「引導知識搜尋」網頁 (英文)，以判定 GroupShield 5.2 for Microsoft Exchange Server 的最新版本。使用該網站上的下列 McAfee 解決方案知識庫文件及其他 McAfee 解決方案知識庫文件，來判定最新版本：

    • 解決方案識別碼 KB40567＜取得 GroupShield 及/或 SpamKiller 的最新版本＞(英文)

    • 解決方案識別碼 KB nai18117＜GroupShield for Exchange 2000 的產品版本資訊＞(英文)

  2. 造訪 McAfee 網站 (英文) (https://secure.nai.com/us/forms/downloads/upgrades/login.asp)。

  3. 為您的 GroupShield 5.2 for Microsoft Exchange Server 版本下載最新的更新。

  4. 對 Exchange Server 電腦進行完整備份。

  5. 將最新的更新安裝到 GroupShield 5.2 for Microsoft Exchange Server。
附註：
本主題之所以提供協力廠商網站資訊是為了協助您尋找您需要的技術資訊。URL 隨時都會變更，不另行通知。

若需將防毒軟體與 Exchange Server 搭配使用的相關資訊，請參閱下列微軟知識庫文件：

  • 328841＜Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需 Exchange Server 可用的協力廠商防毒軟體清單，請參閱 Exchange Server 合作夥伴：防毒網站 (英文) (http://go.microsoft.com/fwlink/?linkid=16226)


Exchange 有可用的 McAfee GroupShield 6.0 for Microsoft Exchange 更新
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄值，以判定是否已向 Microsoft Exchange Information Store 服務註冊病毒掃描應用程式發展介面 (VSAPI) 程式庫檔案：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

當 Exchange 2000 Server 或 Exchange Server 2003 上安裝有 McAfee GroupShield 6.0 for Microsoft Exchange 時，Library 登錄項目會有 VSAPISCANSOURCE.DLL 的值。此程式庫檔案會在 GroupShield 6.0 for Microsoft Exchange 中執行數個 VSAPI 相關功能。

Exchange Server Analyzer 工具也會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 VSAPISCANSOURCE.DLL 機碼的 Version 值。如果 Version 機碼值指出此檔案的組建編號小於 6.0.1148，就會顯示一則警告。

VSAPISCANSOURCE.DLL 的版本號碼小於 6.0.1148，表示未安裝 GroupShield 6.0 for Microsoft Exchange 最新的版本。可從 McAfee 網站取得 GroupShield 6.0 for Microsoft Exchange 的軟體更新。建烈建議使用此更新，且此更新可增進整體效能及可靠性。

若要更正此警告

  1. 造訪 McAfee 網站 (http://knowledgemap.nai.com/) 的引導知識搜尋網頁 (英文)，以判定 GroupShield 6.0 for Microsoft Exchange 最新的版本。使用下列 McAfee 解決方案文件，以及位在該站台上的其他 McAfee 解決方案文件，以判定最新的版本：

    • 解決方案識別碼 nai18117＜GroupShield for Exchange 2000 的產品版本資訊＞(英文)

    • 解決方案識別碼 KB37636＜McAfee GroupShield 6.x for Microsoft Exchange 的版本號碼＞(英文)

    • 解決方案識別碼 KB40567＜取得 GroupShield 及/或 SpamKiller 的最新版本＞(英文)

  2. 造訪 McAfee 網站的「產品下載」網頁 (英文) (https://secure.nai.com/us/forms/downloads/upgrades/login.asp)。

  3. 下載您 GroupShield 6.0 for Microsoft Exchange 版本的最新更新。

  4. 對 Exchange Server 電腦進行完整備份。

  5. 安裝 GroupShield 6.0 for Microsoft Exchange 的最新更新。
附註：
本主題也提供協力廠商網站資訊，協助您找到需要的技術資訊。URL 如有變更，恕不另行通知。

若需將防毒軟體與 Exchange Server 搭配使用的相關資訊，請參閱下列微軟知識庫文件：

  • 328841＜Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需 Exchange Server 可用的協力廠商防毒軟體清單，請參閱 Exchange Server 合作夥伴：防毒網站 (英文) (http://go.microsoft.com/fwlink/?linkid=16226)。


McAfee GroupShield 是安裝在此 Exchange 伺服器上，但服務已停止
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定是否已安裝 McAfee GroupShield for Microsoft Exchange，且是否已在 Exchange 電腦上執行 McAfee GroupShield 服務。

Exchange Server Analyzer 也會查詢 Win32_Service WMI 類別，以判定 Microsoft Exchange Information Store 服務中的 Started 機碼值是設定為 True 或 False。

False 值表示目前這部 Exchange Server 電腦沒有執行 Information Store 服務。True 值表示有執行 Microsoft Exchange Information Store 服務。

如果 Exchange Server Analyzer 發現 Microsoft Exchange Information Store 服務正在執行，且已安裝 McAfee GroupShield，但未啟動 McAfee GroupShield 服務，則會顯示警告。

McAfee GroupShield 針對 Exchange 提供防毒保護。此處列出可能會停止 McAfee GroupShield 服務的一些原因及解決方案。

  • 在 Exchange Server 上執行的軟體可能是過期的評估版或試用版。在此狀況下，您可能需要重新安裝 McAfee GroupShield。若要繼續使用軟體，至少要將其啟動。

  • 系統管理員可能已意外停止 McAfee GroupShield 服務。確認服務已設為自動啟動，然後啟動服務。

  • 服務可能是被惡意的蠕蟲、病毒或其他程式停止。確認服務已設為自動啟動，然後啟動服務。若服務持續異常停止，並且沒有相關的錯誤事件出現，請驗證電腦並未被惡意的蠕蟲感染，並於必要時清除該系統上的蠕蟲。

Microsoft 一般會建議在簡易郵件傳送通訊協定 (SMTP) 閘道或主控信箱的 Exchange 伺服器上，部署針對郵件系統設計的防毒軟體。為了獲得最大保護，請在閘道執行防毒軟體來掃描傳入的 MIME 郵件，以及在使用 VSAPI 2.5 的 Exchange Server 上執行掃描程式。

啟動 McAfee GroupShield 服務

  1. 開啟 [服務] MMC 嵌入式管理單元。

  2. 在 McAfee GroupShield 服務上按一下滑鼠右鍵，再按一下 [內容]。

  3. 在 McAfee GroupShield 內容頁的 [一般] 索引標籤上，請確定 [啟動類型] 是設為 [自動]。如果不是，請按一下 [套用]，然後按一下 [確定]。

  4. 在 McAfee GroupShield 服務上按一下滑鼠右鍵，再按一下 [啟動]。

  5. 關閉 [服務] 嵌入式管理單元。

此外，您應該要在使用者桌面系統執行用戶端防毒軟體。如果您在閘道或 Exchange 伺服器上執行專門針對郵件系統所設計開發的防毒軟體 (該軟體可以剖析及掃描 MIME)，則只要在桌上型電腦執行檔案層級的掃描程式就已足夠。

  • 若需有關一般搭配 Microsoft Exchange Server 2003 使用的病毒掃描程式類型詳細資訊，請參閱微軟知識庫文件 - 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)。

  • 若需有關一般與 Microsoft Exchange 2000 Server 搭配使用之不同類型的病毒掃描程式的詳細資訊，請參閱知識庫文件 - 328841＜Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)。

  • 若需有關加強 Exchange 環境對抗電子郵件傳送病毒及蠕蟲的詳細資訊，請參閱微軟白皮書《在 Exchange 2003 環境中減緩及阻止電子郵件病毒》(英文) (http://go.microsoft.com/fwlink/?LinkId=30732)。


已安裝 Messageware Plus Pack
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否將 Messageware Plus Pack 安裝在任何 Exchange Server 上：

HKEY_LOCAL_MACHINE\Software\Messageware Incorporated\Core Services\PlusPack\Load

如果 Exchange Server Analyzer 發現 Load 的數值資料等於 1，便會顯示非預設的組態訊息。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要採取任何動作。

Messageware Plus Pack 為 Messageware Incorporated 開發的 Microsoft Office Outlook® Web Access for Exchange Server 2003 增益集。Messageware Plus Pack 可為 Outlook Web Access Basic 及 Outlook Web Access Premium 的使用者，擴充和增強 Outlook Web Access 功能。

若需有關 Messageware Plus Pack 的詳細資訊，請參閱網站「Messageware OWA 套件」(英文) (http://www.messageware.com)。

附註：
網址或有變更，您可能無法連上此處提及的網站或站台。


Microsoft Antigen 資料執行防止 (DEP) 相容性
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2007-02-19

Microsoft Exchange Analyzer 工具會查詢 Win32_Service Microsoft Windows Management Instrumentation (WMI) 類別，以判定 Microsoft Antigen 服務的 Started 機碼值。值 False 表示服務不在執行中。值 True 表示服務在執行中。

Exchange Analyzer 也會讀取下列登錄項目，以判定是否在 Exchange Server 上安裝了 Microsoft Antigen 的 Kaspersky 掃描引擎。這個登錄項目只有在 Exchange Server 上安裝了 Kaspersky 掃描引擎時才會出現。

HKEY_LOCAL_MACHINE\Software\Sybari Software\Antigen for Exchange\Scan Engines\Kaspersky

最後，如果 Exchange Server 是在 Microsoft Windows Server 2003 Service Pack 1 (SP1) 或更新版本上執行，Exchange Analyzer 會查詢 Win32_ComputerSystem WMI 類別，以判定 SystemStartupOptions 機碼的值是否包含字串 '/NOEXECUTE=OPTOUT' 或 '/NOEXECUTE=ALWAYSON'。這表示伺服器上已啟用資料執行防止 (DEP)。資料執行防止是一組硬體與軟體技術，會對記憶體執行額外的檢查，以協助防止惡意程式碼在系統上執行。

如果 Exchange Analyzer 判定下列條件符合，便會顯示警告：

  • 伺服器上已啟用 Microsoft Antigen 服務。

  • 已安裝 Antigen 的 Kaspersky 掃描引擎。

  • Exchange 伺服器是在 Microsoft Windows Server 2003 Service Pack 1 (SP1) 或更新版本上執行。

  • 伺服器上已啟用資料執行防止。

此警告表示目前的伺服器組態可能會導致郵件傳遞與病毒掃描效能問題。

若要更正此警告，請遵循 Microsoft 知識庫文章 905952＜Antigen 中的郵件傳遞效能比預期慢，且 Antigen 用戶端停止回應＞(機器翻譯) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905952) 中的指引，選擇性地針對個別程式停用資料執行防止 (DEP)。

詳細資訊

如需資料執行防止的相關資訊，請參閱 Microsoft 知識庫文章 875352＜詳細說明 Windows XP Service Pack 2、Windows XP Tablet PC Edition 2005 和 Windows Server 2003 中的資料執行防止 (Data Execution Prevention，DEP) 功能＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=875352)。


已安裝 NSI Software Double-Take
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Double-Take 服務的 Started 機碼值。True 值表示 Exchange Server 上正在執行 Double-Take 服務。若在 Exchange Server 上偵測到 Double-Take 服務，則 Exchange Server Analyzer 便會顯示非預設的組態訊息。

Exchange Server Analyzer 的這項非預設組態報告僅供參考之用。不需要採取任何動作。

Double-Take 由 NSI Software, Inc. 所推出，可透過標準的網路連線，將使用者選取的檔案或完整的磁碟區從一或多部來源伺服器，複製到一或多部目標伺服器上。這些複製可讓企業在歷經嚴重損壞或系統故障後能夠迅速恢復作業，而使用者可不需執行動作。

若需有關 Double-Take 的詳細資訊，請參閱 "Double-Take" 網站 (英文) (http://www.nsisoftware.com/pro/doubletake)。

附註：
網址可能會變動，因此您有可能無法連線至此處所指的網站或站台。

Double-Take 是一種資料複寫軟體。若需有關 Exchange 2000 Server 及 Exchange Server 2003 多站台資料覆寫的詳細資訊，請 參閱微軟知識庫文件 - 895847＜Exchange 2003 及 Exchange 2000 的多站台資料複寫支援＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895847)。


非 Exchange 處理程序耗用超過 20% 的處理器時間
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2006-02-13

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Processor 效能物件的 %Processor Time (_Total) 計數器的資料，以分析效能資料。

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • 有處理器瓶頸。

  • 有一或多個非 Exchange 處理程序使用的時間超過總平均伺服器 CPU 時間的 20%。

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • 有處理器瓶頸。

  • 有一或多個非 Exchange 處理程序使用的時間超過總平均伺服器 CPU 時間的 10%。

Process 效能物件下的 % Processor Time (_Total) 效能計數器提供處理器的整體使用率。平均 CPU 使用應該一律小於 80%。平均值更高，則表示有處理器瓶頸。處理器時間高於 90% 的經常性尖峰值也表示有處理器瓶頸。

排除處理器瓶頸

有許多方式可排除 Exchange 伺服器中的處理器瓶頸。

  • 首先，檢閱造成伺服器上的負載的應用程式或工作。判斷應用程式是否應該使用本身是或可能是處理程序問題的處理器時間。

  • 如果非 Exchange 應用程式對該伺服器不重要，請在其他伺服器上執行該應用程式。如果您可以這麼做，請同時將伺服器角色移到其他電腦上。比方說，如果 Inetinfo 處理程序使用大量 CPU 使用，請考慮增加前端伺服器，以擔負 Inetinfo 執行之通訊協定工作的責任。您也可以將公用資料夾存取移至專用的公用資料夾伺服器。最後，如果伺服器執行大量通訊群組清單展開，則可以將通訊群組清單展開移至專用的通訊群組清單展開伺服器，以降低 CPU 使用。

  • 如果您可以這麼做，請在伺服器中加入更多或更快的處理器。另外，如果處理器支援的話，請啟用超執行緒 (Hyper-threading)。您可以設定系統 BIOS 來啟用超執行緒。若需詳細資訊，請參閱電腦製造商的說明文件。

  • 如果提升處理能力不是理想的選項，則必須降低處理器上的負載。若要降低對伺服器的整體影響，請確定 I/O 密集、CPU 密集或消耗記憶體的工作是在正常操作期間之外的時間執行。

  • 請確定 CPU 密集的工作 (如備份及維護) 是在離峰時間執行。也請確定這些工作是以經過安排的方式執行。安排工作的意思是為每個工作設定不同的開始時間，並最好設定結束時間。安排資料庫或儲存群組的維護及備份也可減少這些資源密集工作的影響。

詳細資訊

  • 若需處理器瓶頸的詳細資訊，請參閱＜處理器瓶頸＞。

  • 若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 2003 效能疑難排解》(http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 若需如何移動使用者信箱以減少伺服器負載的詳細資訊，請參閱＜將使用者信箱移至其他伺服器＞。


非 Exchange 處理程序耗用超過 50% 的處理器時間
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2006-02-13

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 Processor 效能物件的 %Processor Time (_Total) 計數器的資料，以分析效能資料。

Process 效能物件下的 % Processor Time (_Total) 效能計數器提供處理器的整體使用率。平均 CPU 使用應該一律小於 80%。平均值更高，則表示有處理器瓶頸。處理器時間高於 90% 的經常性尖峰值也表示有處理器瓶頸。

如果 Exchange Server Analyzer 判定有一個非 Exchange 處理程序正在使用大於 50% 的總平均伺服器 CPU 時間，即使沒有偵測到實際的處理器瓶頸，Exchange Server Analyzer 工具也會顯示警告。

排除可能的處理器瓶頸

有許多方式可從 Exchange 伺服器排除可能的處理器瓶頸。

  • 首先，檢閱造成伺服器上的負載的應用程式或工作。判斷應用程式是否應該使用本身是或可能是處理程序問題的處理器時間。

  • 如果非 Exchange 應用程式對該伺服器不重要，請在其他伺服器上執行該應用程式。如果您可以這麼做，請同時將伺服器角色移到其他電腦上。比方說，如果 Inetinfo 處理程序使用大量 CPU 使用，請考慮增加前端伺服器，以擔負 Inetinfo 執行之通訊協定工作的責任。您也可以將公用資料夾存取移至專用的公用資料夾伺服器。最後，如果伺服器執行大量通訊群組清單展開，則可以將通訊群組清單展開移至專用的通訊群組清單展開伺服器，以降低 CPU 使用。

  • 如果您可以這麼做，請在伺服器中加入更多或更快的處理器。另外，如果處理器支援的話，請啟用超執行緒 (Hyper-threading)。您可以設定系統 BIOS 來啟用超執行緒。若需詳細資訊，請參閱電腦製造商的說明文件。

  • 如果提升處理能力不是理想的選項，則必須降低處理器上的負載。若要降低對伺服器的整體影響，請確定 I/O 密集、CPU 密集或消耗記憶體的工作是在正常操作期間之外的時間執行。

  • 請確定 CPU 密集的工作 (如備份及維護) 是在離峰時間執行。也請確定這些工作是以經過安排的方式執行。安排工作的意思是為每個工作設定不同的開始時間，並最好設定結束時間。安排資料庫或儲存群組的維護及備份也可減少這些資源密集工作的影響。

詳細資訊

  • 若需處理器瓶頸的詳細資訊，請參閱＜處理器瓶頸＞。

  • 若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


已安裝過時的 HP/Compaq Secure Path 版本
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-12-13

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Exchange 伺服器上安裝的 HP/Compaq Secure Path 軟體版本。如果 Secure Path 版本不是 3.7.2.540，就會顯示一則警告。

若要補救此警告，請更新 Secure Path 軟體。請連絡 HP/Compaq 轉售商以更新此軟體。

若需有關 HP/Compaq Secure Path 軟體更新的詳細資訊，請造訪 HP 網站 "HP StorageWorks Secure Path" (英文) (http://h18006.www1.hp.com/products/sanworks/softwaredrivers/securepath/index.html)。

附註：
本主題也提供協力廠商網站資訊，協助您找到需要的技術資訊。URL 如有變更，恕不另行通知。


已封鎖通訊埠 25
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2006-10-06

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄值，以判定正在執行 Exchange Server 的伺服器上是否已安裝 McAfee VirusScan for Microsoft Exchange：

HKEY_LOCAL_MACHINE\Software\Network Associates\TVD\VirusScan Enterprise\CurrentVersion

Exchange Server Analyzer 也會查詢下列登錄分支，以判定 VirusScan 產品用來封鎖通訊埠的設定方式：

HKLM\Software\Network Associates\TVD\Shared Components\On Access Scanner\BehaviourBlocking

此分支中的機碼使用 VirusScan 產品的常駐 (On Access) 功能，來設定要封鎖或允許的處理程序和通訊埠。

最後，Exchange Server Analyzer 也會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，找出 McAfee VirusScan 服務的 Started 機碼值，以判定 Exchange 伺服器上是否正在執行此服務。

False 值表示此 Exchange 伺服器未執行 McAfee VirusScan 服務。True 值表示正在執行 McAfee VirusScan 服務。

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • McAfee VirusScan 已安裝且正在 Exchange 伺服器上執行。

  • 通訊埠 25 已啟用「防止大量散發郵件蠕蟲寄送郵件」封鎖規則。

  • 封鎖規則中未排除 Exchange 簡易郵件傳送通訊協定 (SMTP) 服務。

此警告指出 McAfee VirusScan 應用程式已設定，因此該程式會封鎖進出通訊埠 25 的正當 Exchange Server 通訊。

若要更正此問題：

  • 請考慮是否停用「防止大量散發郵件蠕蟲寄送郵件」封鎖規則。

  • 將 Exchange Server SMTP 服務新增到「防止大量散發郵件蠕蟲寄送郵件」封鎖規則的排除清單中。

詳細資訊

  • 若需如何設定 McAfee VirusScan for Microsoft Exchange 的詳細資訊，請造訪 McAfee 服務入口網站 (http://knowledge.mcafee.com/)。

    附註：
    以下提供協力廠商網站資訊，協助您找到需要的技術資訊。URL 如有變更，恕不另行通知。
  • 若需有關一般搭配 Microsoft Exchange Server 2003 使用的病毒掃描程式類型詳細資訊，請參閱微軟知識庫文件 - 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)。

  • 若需有關一般搭配 Microsoft Exchange 2000 Server 使用之不同病毒掃描程式類型的詳細資訊，請參閱知識庫文件 - 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)。

  • 若需加強 Exchange 環境對抗電子郵件傳送病毒及蠕蟲的詳細資訊，請參閱微軟白皮書《在 Exchange 環境中減緩及阻止電子郵件傳送病毒》(英文) (http://go.microsoft.com/fwlink/?LinkId=30732)。


Red Earth Software Policy Patrol for Exchange Server Needs Update
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2007-07-24

Microsoft Exchange Analyzer 工具會讀取登錄，以判定是否有下列兩個子機碼其中之一：

HKEY_LOCAL_MACHINE\Software\Red Earth Software\Policy Patrol\3.0

HKEY_LOCAL_MACHINE\Software\Wow6432Node\Red Earth Software\Policy Patrol\3.0

這些分支若有一個存在，則指出本機電腦上已安裝 Red Earth Software 的 Policy Patrol for Exchange Server 3.0 版。

如果 Exchange Analyzer 發現本機電腦上已安裝 Policy Patrol for Exchange Server 3.0 版，則 Exchange Analyzer 會顯示警告。

此警告指出有 Policy Patrol for Exchange Server 的建議更新可用。

若要更正此警告

  1. 請造訪 Red Earth Software Policy Patrol for Exchange Server 下載網站，網址為 http://www.policypatrol.com/download.htm

  2. 下載並安裝 Policy Patrol for Exchange Server 的任何必要或建議更新。
附註：
提供協力廠商網站資訊是為了協助您找到需要的技術資訊。URL 如有變更，恕不另行通知。


ScanMail for Microsoft Exchange 及 CA eTrust 一起執行
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定安裝在 Exchange 伺服器上的 Trend Micro ScanMail for Microsoft Exchange 版本：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

如果 Version 值的數值資料開頭為 7，表示已安裝 ScanMail for Microsoft Exchange 第 7 版。

Exchange Server Analyzer 也會讀取下列登錄項目，以判定 eTrust from Computer Associates 是否也安裝在 Exchange 伺服器上：

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\

如果 CurrentVersion 登錄值存在，表示在 Exchange 伺服器上已安裝 Computer Associates 的 eTrust Antivirus 第 7 版。

最後，Exchange Server Analyzer 會查詢 Win32_Service Microsoft Windows® Management Instrumentation 類別，以判定 InoRT 服務 (也稱為 eTrust Antivirus Realtime Server 服務) 在 eTrust Antivirus 的 Started 機碼值。

若下列條件為真，Exchange Server Analyzer 就會顯示最佳作法訊息：

  • ScanMail for Microsoft Exchange 及 eTrust Antivirus 兩者皆安裝在 Exchange 伺服器上。

  • eTrust Antivirus Realtime Server 服務已啟動。

Trend Micro 建議您在使用任何檔案系統型防毒軟體時 (如 eTrust Antivirus)，請不要掃描 ScanMail for Microsoft Exchange 資料夾。ScanMail for Microsoft Exchange 會使用本身路徑內的暫存資料夾來供掃描活動之用。如果檔案系統型防毒掃描程式掃描這些暫存資料夾，可能會干擾到 ScanMail for Microsoft Exchange 的正常作業。

最佳的作法是在檔案系統型防毒軟體 (如 eTrust Antivirus from Computer Associates) 進行即時掃描時，排除 ScanMail for Microsoft Exchange 資料夾。若需有關在已安裝檔案系統型防毒軟體之電腦上使用 ScanMail for Microsoft Exchange 的作法詳細資訊，請參閱 Trend Micro 知識庫文件＜在安裝 ScanMail for Exchange 的同一部伺服器上安裝其他防毒應用程式＞(英文) (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=8540)。

附註：
以下提供協力廠商網站資訊，協助您找到需要的技術資訊。URL 如有變更，恕不另行通知。


ScanMail for Microsoft Exchange 封存目錄包含太多檔案
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已安裝 Trend Micro ScanMail for Microsoft Exchange 7.0 版：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

然後，Exchange Server Analyzer 會計算 ScanMail for Microsoft Exchange 使用之封存目錄中存在的檔案數。依預設，封存目錄路徑如下所示：

C:\Program Files\Trend Micro\Smex\Storage\Archive

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • 已安裝 ScanMail for Microsoft Exchange 7.0 版。

  • ScanMail for Microsoft Exchange 使用的封存目錄中有超過 1,000 個檔案。

這個警告指出 ScanMail for Microsoft Exchange 所使用的封存目錄中有許多檔案。Trend Micro 建議您定期檢閱及清除 ScanMail for Microsoft Exchange 使用的封存資料夾。


ScanMail for Microsoft Exchange 備份目錄包含太多檔案
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判斷是否安裝了 7.0 版的 Trend Micro ScanMail for Microsoft Exchange：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server Analyzer 會接著計算 ScanMail for Microsoft Exchange 所用備份目錄中存在的檔案數。預設的備份目錄路徑如下：

C:\Program Files\Trend Micro\Smex\Storage\Backup

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • 已安裝 ScanMail for Microsoft Exchange 7.0 版。

  • ScanMail for Microsoft Exchange 所用備份目錄中有 1,000 個以上的檔案。

此警告表示 ScanMail for Microsoft Exchange 所用備份目錄中存在許多檔案。Trend Micro 建議您定期查看與清除 ScanMail for Microsoft Exchange 所用備份資料夾。


ScanMail for Microsoft Exchange 備份排除
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定已經使用 [Windows 備份] 從備份中排除的檔案及資料夾：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

Exchange Server Analyzer 會特別尋找包含 "SMEX\DATA" 的字串。

如果 Exchange Server Analyzer 發現 FilesNotToBackup 機碼包含的值含有 "SMEX\DATA" 字串，就會顯示警告。

如果不是正在使用 [Windows 備份]，就不必理會此警告。如果您正在使用 [Windows 備份]，建議您移除 SMEX\DATA 目錄的排除。Trend Micro 建議使用者在此資料夾中備份所有副檔名為 .mdb 的檔案。SMEX\DATA 資料夾中的實際執行 .mdb 檔毀損或被刪除時，可使用備份檔案。

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

  3. 在左窗格中選取 FilesNotToBackup。

  4. 在右窗格中，在包含 "SMEX\DATA" 字串的值上按一下滑鼠右鍵，然後選取 [刪除]。

  5. 關閉登錄編輯程式。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


已啟用 ScanMail for Microsoft Exchange 偵錯模式
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Trend Micro 是否已在 ScanMail for Microsoft Exchange 上啟用偵錯模式：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\DebugModule

如果 DebugModule 的數值資料包含一或多個下列字串，Exchange Server Analyzer 便會顯示警告：

  • HOST:1

  • CONFIG:1

  • MASTER:1

  • WATCHER:1

  • STORE:1

  • INETINFO:1

  • TCHER:1

  • MON:1

  • MONITOR:1

此警告表示目前已為一或多個 ScanMail for Microsoft Exchange 模組啟用偵錯模式。Trend Micro 建議您只在需要的時候才啟用偵錯模式，例如進行疑難排解時。否則，Trend Micro 建議您在進行一般操作時停用偵錯模式。

若要更正此警告

  1. 請檢閱下列 Trend Micro 知識庫文件＜透過登錄編輯程式啟用 ScanMail for Exchange (SMEX) 7.0 偵錯＞(英文) (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=25532)。

  2. 遵照下列 Trend Micro 知識庫文件的指示，停用所有模組的偵錯。
附註：
以下提供協力廠商網站資訊，協助您找到需要的技術資訊。URL 如有變更，恕不另行通知。


ScanMail for Microsoft Exchange 隔離目錄包含太多檔案
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已安裝 Trend Micro ScanMail for Microsoft Exchange 7.0 版：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server Analyzer 會接著計算 ScanMail for Microsoft Exchange 所用隔離目錄中的檔案數。隔離目錄的預設路徑如下：

C:\Program Files\Trend Micro\Smex\Storage\Quarantine

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • 已安裝 ScanMail for Microsoft Exchange 7.0 版。

  • ScanMail for Microsoft Exchange 所用隔離目錄中有 1,000 個以上的檔案。

此警告表示 ScanMail for Microsoft Exchange 所用隔離目錄中存在許多檔案。Trend Micro 建議您定期查看與清除 ScanMail for Microsoft Exchange 所用隔離資料夾。


預設路徑中的 ScanMail for Microsoft Exchange SharedResPool 目錄
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2007-06-05

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判斷安裝的 Trend Micro ScanMail for Microsoft Exchange 版本：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server Analyzer 也會讀取下列登錄項目以判斷 SharedResPool 資料夾的位置：

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\SharedResPool

最後，Exchange Server Analyzer 會讀取下列登錄項目以判斷 ScanMail for Microsoft Exchange 的安裝位置：

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\HomeDir

若下列條件為真，Exchange Server Analyzer 就會顯示最佳作法訊息：

  • 已安裝 ScanMail for Microsoft Exchange 版本：7。

  • SharedResPool 資料夾位於 ScanMail 根目錄的路徑中。

最佳作法是將 SharedResPool 目錄改置於比 ScanMail for Microsoft Exchange 所用根目錄之磁碟機更快的磁碟機中。Trend Micro 建議客戶將 SharedResPool 資料夾改置於較快的磁碟機，以獲得更好的效能。SharedResPool 目錄包含 ScanMail for Microsoft Exchange 第 7.0 版隨附之處理程序間共用資源的記憶體映射檔案。7.0. 您不應刪除此目錄的內容。

若需有關 SharedResPool 資料夾的詳細資訊，請參閱＜ScanMail for Exchange (SMEX) 7.0 SharedResPool 與引擎的目錄為何？＞(英文)(http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=26898)。

若需有關移動 SharedResPool 資料夾的詳細資訊，請參閱＜將 ScanMail for Exchange (SMEX) 7.0 SharedResPool 目錄移至其他位置＞(英文) (http://esupport.trendmicro.com/support/viewxml.do?ContentID=EN-127549&id=EN-127549)。

附註：
以下提供協力廠商網站資訊，協助您找到需要的技術資訊。URL 如有變更，恕不另行通知。


在信箱伺服器上啟用 ScanMail for Microsoft Exchange SMTP 掃描
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會讀取下列 Microsoft Internet Information Services (IIS) Metabase 中的內容，以判定 Trend Micro ScanMail for Microsoft Exchange 目前的組態設定：

LM/SmtpSvc/%SMTPINSTANCE%/EventManager/EventTypes/{76719654-05A6-11d2-9dfd-00C04FA322BA}/Bindings/{6BA0CE4C-AC34-411E-B58A-EB715D04019D}/Enabled

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定 Exchange 伺服器物件的 serverRole 屬性值。若 serverRole 的屬性值為 1，表示 Exchange 伺服器已設定為前端伺服器。值為 0 表示 Exchange 伺服器不是設定為前端伺服器。

Exchange Server Analyzer 也會查詢 Win32_OperatingSystem Windows® Management Instrumentation (WMI) 類別，以判定 Exchange 伺服器的 OSProductSuite 機碼值。執行此查詢的目的是判定在 Exchange 伺服器上執行的特定作業系統。

Exchange Server Analyzer 也會讀取下列登錄值，以判定在 Exchange 伺服器上執行的 ScanMail for Exchange 版本：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

如果 Version 值的數值資料開頭為 7，表示已安裝 ScanMail for Microsoft Exchange 第 7 版。

最後，Exchange Server Analyzer 會查詢 Active Directory，以判定已設定 homeMDBBL 屬性的物件數。有設定 homeMDBBL 屬性的物件為擁有信箱功能的物件。因此，有設定 homeMDBBL 的物件計數為存在的信箱數。

若下列條件為真，Exchange Server Analyzer 就會顯示最佳作法訊息：

  • 已安裝 ScanMail for Microsoft Exchange 第 7 版。

  • 已設定 ScanMail for Microsoft Exchange 在未設定為前端伺服器的 Exchange 伺服器上執行 SMTP 掃描。

  • Exchange 伺服器包含 20 個以上的信箱。

  • Exchange 伺服器未執行 Microsoft Windows Small Business Server 2003 或 Microsoft Small Business Server 2000。

Trend Micro 建議 ScanMail for Microsoft Exchange 第 7 版的使用者，若有個別的專用閘道或 Bridgehead 伺服器，請停用在信箱伺服器上使用 ScanMail 管理主控台的 SMTP 掃描。基於最佳效能及安全性的考量，Trend Micro 建議在閘道 Bridgehead 伺服器上 (而不是在信箱伺服器上) 啟用 SMTP 掃描。


ScanMail for Microsoft Exchange TEMP 目錄包含許多檔案
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已安裝 Trend Micro ScanMail for Microsoft Exchange 7.0 版：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server Analyzer 工具會接著計算 ScanMail for Microsoft Exchange 所用 TEMP 目錄中的檔案數。ScanMail for Microsoft Exchange 所用 TEMP 目錄的預設路徑如下：

C:\Program Files\Trend Micro\Smex\Temp

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • 已安裝 ScanMail for Microsoft Exchange 7.0 版。

  • ScanMail for Microsoft Exchange 所用 TEMP 目錄中有 100 個以上的檔案。

此警告表示 ScanMail for Microsoft Exchange 所用 TEMP 目錄中存在許多檔案。此資料夾中的檔案是 ScanMail for Microsoft Exchange 所用的暫存檔。ScanMail for Microsoft Exchange 應會自動刪除這些檔案。

如果有許多目前日期以前的檔案，Trend Micro 建議您刪除舊的檔案。


ScanMail for Microsoft Exchange TEMP 目錄包含太多檔案
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已安裝 Trend Micro ScanMail for Microsoft Exchange 7.0 版：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

如果安裝了 ScanMail for Microsoft Exchange 第 7 版，Exchange Server Analyzer 會讀取下列登錄項目，以判斷 ScanMail for Microsoft Exchange 所用 TEMP 目錄的位置：

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\TempFolderPath

Exchange Server Analyzer 會接著計算 ScanMail for Microsoft Exchange 所用 TEMP 目錄中的檔案數。

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • 已安裝 ScanMail for Microsoft Exchange 7.0 版。

  • ScanMail for Microsoft Exchange 所用 TEMP 目錄中有 100 個以上的檔案。

此警告表示 ScanMail for Microsoft Exchange 所用 TEMP 目錄中存在許多檔案。此資料夾中的檔案是 ScanMail for Microsoft Exchange 所用的暫存檔。ScanMail for Microsoft Exchange 應會自動刪除這些檔案。

如果有許多目前日期以前的檔案，Trend Micro 建議您刪除舊的檔案。


ScanMail for Microsoft Exchange 暫存資料夾路徑已變更
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已安裝 Trend Micro ScanMail for Microsoft Exchange 7.0 版：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server Analyzer 也會讀取下列項目，以判定 ScanMail for Microsoft Exchange 使用的暫存資料夾位置：

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\TempFolderPath

如果登錄中存在且設定了 TempFolderPath 值，其存在表示 ScanMail for Microsoft Exchange 所用的暫存資料夾已從其預設位置移動。

最後，Exchange Server Analyzer 會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 AdapterSMTP.dll 的 Version 機碼值。該模組是利用 Trend Micro 的 ScanMail for Microsoft Exchange 來併入。若 AdapterSMTP.dll 的 Version 機碼值小於 7.0.1366，表示需要 ScanMail for Microsoft Exchange 的更新版本。

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • 已安裝 ScanMail for Microsoft Exchange 第 7 版。

  • ScanMail for Microsoft Exchange 使用的暫存資料夾已從其原始位置移動。

  • adapterSMTP.dll 的檔案版本為 7.0.1366 或更新。

Trend Micro 在最新的 ScanMail for Microsoft Exchange 組建中，引進了變更暫存資料夾位置的能力。這個功能只有在 7.0.1366 之後的組建中有用。這項警告表示已重新放置暫存資料夾，但是因為此伺服器執行的是 ScanMail for Microsoft Exchange 較早的版本且不支援重新放置暫存資料夾，所以此重新放置動作不會生效。

若要更正此警告

  1. 造訪 Trend Micro 更新中心網站 (英文) (http://www.trendmicro.com/download)。

  2. 下載並安裝任何 ScanMail for Microsoft Exchange 需要或建議的更新。
附註：
以下提供協力廠商網站資訊，協助您找到需要的技術資訊。URL 如有變更，恕不另行通知。


ScanMail for Microsoft Exchange 暫存資料夾路徑最佳化
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已安裝 Trend Micro ScanMail for Microsoft Exchange 7.0 版：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server Analyzer 也會讀取下列項目，以判定 ScanMail for Microsoft Exchange 使用的暫存資料夾位置：

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\TempFolderPath

如果登錄中存在且設定了 TempFolderPath 值，其存在表示 ScanMail for Microsoft Exchange 所用的暫存資料夾已從其預設位置移動。

最後，Exchange Server Analyzer 會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判斷 AdapterSMTP.dll 的 Version 機碼值。該模組隨附於 Trend Micro 的 ScanMail for Microsoft Exchange。

若下列條件為真，Exchange Server Analyzer 就會顯示最佳作法訊息：

  • 已安裝 ScanMail for Microsoft Exchange 第 7 版。

  • ScanMail for Microsoft Exchange 所用暫存資料夾仍留在其原始預設位置。

  • 此版本的 AdapterSMTP.dll 是支援 ScanMail for Microsoft Exchange 所用暫存資料夾之重新導向的版本。

Trend Micro 在最新的 ScanMail for Microsoft Exchange 組建中，引進了變更暫存資料夾位置的能力。此功能只有在 7.0.1366 之後的組建才能使用。如果您正在使用 7.0.1366 版之後的 ScanMail for Microsoft Exchange 組建，Trend Micro 建議您將暫存資料夾改置於較快的磁碟機。

若要變更暫存資料夾位置

  1. 檢閱 Trend Micro 知識庫文件＜使用者可以變更 ScanMail for Exchange (SMEX) 7.0 暫存資料夾的位置嗎？＞(英文) (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=26343)。

  2. 執行該文中所示的程序，將暫存資料夾改置於較快的磁碟機。
附註：
以下提供協力廠商網站資訊，協助您找到需要的技術資訊。URL 如有變更，恕不另行通知。


有可用的 ScanMail for Microsoft Exchange 更新
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-12-15

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 adapterSMTP.dll 的 Version 機碼值。此模組隨附於 Trend Micro 的 ScanMail for Microsoft Exchange。

如果 Exchange Server Analyzer 發現 adapterSMTP.dll 的 Version 機碼值小於 7.0.1366，就會顯示警告。

此警告表示 Exchange 伺服器上安裝了 ScanMail for Microsoft Exchange 第 7 版，且有可用的建議軟體更新。強烈建議使用此更新，此更新可增進伺服器整體效能及可靠性。

若要更正此警告

  1. 請造訪 Trend Micro 更新中心網站 (http://www.trendmicro.com/download/)。

  2. 下載並安裝 ScanMail for Microsoft Exchange 的必要或建議更新。
附註：
以下提供協力廠商網站資訊，協助您找到需要的技術資訊。URL 如有變更，恕不另行通知。


SMTP 傳輸防毒掃描未啟用
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定是否已設定 SMSMSE (Symantec Mail Security for Microsoft Exchange) 服務的 Started 機碼值。Win32_Service 類別判定在 Exchange Server 2003 電腦上是否已安裝 SMSMSE。值 True 表示 SMSMSE 服務在執行中。值 False 表示 SMSMSE 服務未執行。若下列條件存在，Exchange Server Analyzer 便會顯示警告：

  • Exchange Server 2003 電腦上已安裝 SMSMSE。

  • SMTP 傳輸防毒掃描未啟用。

在 Exchange Server 2003 中，進階佇列引擎使用 Exchange Transport AntiVirus API 作為六個傳輸事件接收器之一，以將郵件傳遞至其目的地。Exchange Transport AntiVirus API 事件接收器是在 OnSubmit.dll 中實作，並可讓非 Microsoft 廠商 (如 Symantec) 實作病毒掃描程式，以在每個郵件到達目的地之前檢查其是否含有惡意附件及其資料結構。若是 OnSubmission 事件，已註冊此事件。

依預設不會啟用傳輸防毒掃描，因為這會導致對郵件掃描兩次，一次是在 SMTP 層掃描，另一次是在 Exchange 儲存區掃描。但是，如果您使用前端伺服器將 Exchange 組織連接至網際網路，則可在這些伺服器上啟用傳輸防毒掃描。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
啟用傳輸防毒掃描

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽到 HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\TransportAVAPI。

  3. 使用值名稱 Enabled 來建立新的 DWORD 值。將數值資料 1 指派給 Enabled 值名稱。

  4. 關閉登錄編輯程式。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

附註：
僅基於病毒掃描應用程式發展介面 (VSAPI) 2.5 的 Exchange 病毒掃描程式才提供傳輸掃描功能。

若需有關 SMTP 傳輸結構的詳細資訊，請參閱《Exchange Server 2003 技術參考手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47891)。

若需有關如何將防毒軟體與 Exchange Server 搭配使用的詳細資訊，請參閱下列知識庫文件：

  • 328841＜Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Overview of Exchange Server 2003 and antivirus software＞ (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)。

  • 306105＜XGEN:Microsoft's Position on Antivirus Solutions for Exchange 2000＞ (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)。

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)。

若需可在 Exchange Server 上使用之協力廠商的防毒軟體清單，請參閱 Exchange Server Partners:防毒網站 (英文) (http://go.microsoft.com/fwlink/?linkid=16226)。

附註：
網址可能會變更，因此您可能無法連線到此處提到的網站。


可使用 Simpler-Webb Exchange Resource Manager 更新
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2006-04-14

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定針對 ERME2KAsyncSink.dll 的 Version 機碼所設定的值。如果 Exchange Server Analyzer 發現 ERME2KAsyncSink.dll 之 Version 的值小於 1015，則會顯示警告。

ERME2KAsyncSink.dll 檔案是 Simpler-Webb Exchange Resource Manager (ERM) 的核心二進位檔。如果 ERME2KAsyncSink.dll 的版本小於 1015，表示伺服器上安裝的是 ERM 版本 1.2 或更早的版本。ERM 版本 1.2 的已知問題是會在 Exchange OLE DB 等待 ERM 事件接收器傳回呼叫時，讓 Exchange 本機傳遞佇列停止傳遞郵件。當 Exchange 儲存區在進行關機作業時，Microsoft Exchange OLEDB 正在等待要從 OnSyncSave 呼叫傳回的事件接收器 ERME2KAsyncSink.dll。

若無法從這個呼叫傳回，會阻止 Exchange 儲存區完成關機。ERM 1.35 版已解決這個問題。

若要更正此警告

  1. 使用 [新增或移除程式]，手動移除 ERM 1.2 版。

  2. 安裝 ERM 1.35 版，可在 Simpler-Webb 網站 (http://www.swinc.com/products/ERM/upgrade/) 取得它。

    附註：
    本主題也提供協力廠商網站資訊，以協助您找到需要的技術資訊。URL 隨時都會變更，恕不另行通知。


Exchange 有可用的 Sybari Antigen 7.5 for Microsoft Exchange 更新
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄值，以判定是否已向 Microsoft Exchange Information Store 服務註冊病毒掃描應用程式發展介面 (VSAPI) 程式庫檔案：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Antigen 7.5 for Microsoft Exchange 屬於 Sybari 產品。當 Exchange 2000 Server 或 Exchange Server 2003 上安裝有 Antigen 7.5 for Microsoft Exchange 時，Library 登錄項目會有 ANTIGENVSAPI.DLL 的值。此程式庫檔案會在 Antigen 7.5 for Microsoft Exchange 中執行數個 VSAPI 相關功能。

Exchange Server Analyzer 工具也會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 ANTIGENVSAPI.DLL 機碼的 Version 值。如果 Version 機碼值表示此檔案的組建編號小於 1316，就會顯示警告。

ANTIGENVSAPI.DLL 的版本號碼小於 1316 表示未安裝 Antigen 7.5 for Microsoft Exchange 的最新版本。可從 Sybari 網站取得 Antigen 7.5 for Microsoft Exchange 的軟體更新。建烈建議使用此更新，且此更新可增進整體效能及可靠性。

若要更正此警告

  1. 請造訪 Sybari 網站的「授權下載中心」(英文) (http://www.sybari.com/portal/alias__Rainbow/lang__en-US/tabID__3359/DesktopDefault.aspx)。

    附註：
    網址可能有所變更，因此可能會無法連線到此處所提的網站。

  2. 為您的 Antigen 7.5 for Microsoft Exchange 版本下載最新的更新。

  3. 對 Exchange Server 電腦進行完整備份。

  4. 將最新的更新安裝到 Antigen 7.5 for Microsoft Exchange。

若需將防毒軟體與 Exchange Server 搭配使用的相關資訊，請參閱下列微軟知識庫文件：

  • 328841＜Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需 Exchange Server 可用的協力廠商防毒軟體清單，請參閱「Exchange Server 合作夥伴：防毒」網站 (英文) (http://go.microsoft.com/fwlink/?linkid=16226)。


Exchange 有可用的 Sybari Antigen 8.0 for Microsoft Exchange 更新
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2006-01-09

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄值，以判定是否已向 Microsoft Exchange Information Store 服務註冊病毒掃描應用程式發展介面 (VSAPI) 程式庫檔案：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Antigen 8.0 for Microsoft Exchange 屬於 Sybari 產品。當 Exchange 2000 Server 或 Exchange Server 2003 上安裝有 Antigen 8.0 for Microsoft Exchange 時，Library 登錄項目會有 ANTIGENVSAPIEx.DLL 的值。此程式庫檔案會在 Antigen 8.0 for Microsoft Exchange 中執行數個 VSAPI 相關功能。

Exchange Server Analyzer 工具也會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 ANTIGENVSAPI.DLL 機碼的 Version 值。如果 Version 機碼值表示此檔案的組建編號小於 1517，就會顯示警告。

ANTIGENVSAPI.DLL 的版本號碼小於 1517 表示未安裝 Antigen 8.0 for Microsoft Exchange 的最新版本。可從 Sybari 網站取得 Antigen 8.0 for Microsoft Exchange 的軟體更新。建烈建議使用此更新，且此更新可增進整體效能及可靠性。

若要更正此警告

  1. 請造訪 Sybari 網站的「授權下載中心」(英文) (http://www.sybari.com/portal/alias__Rainbow/lang__en-US/tabID__3359/DesktopDefault.aspx)。

    附註：
    網址可能有所變更，因此可能會無法連線到此處所提的網站。

  2. 為您的 Antigen 8.0 for Microsoft Exchange 版本下載最新的更新。

  3. 對 Exchange Server 電腦進行完整備份。

  4. 將最新的更新安裝到 Antigen 8.0 for Microsoft Exchange。

若需將防毒軟體與 Exchange Server 搭配使用的相關資訊，請參閱下列微軟知識庫文件：

  • 328841＜Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需 Exchange Server 可用的協力廠商防毒軟體清單，請參閱「Exchange Server 合作夥伴：防毒」網站 (英文) (http://go.microsoft.com/fwlink/?linkid=16226)。


此 Exchange 伺服器上安裝了 Sybari Antigen，但 AntigenStore 服務未執行
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定是否已安裝 Sybari Antigen，以及是否在 Exchange 電腦上執行 AntigenStore 服務。

Exchange Server Analyzer 也會查詢 Win32_Service WMI 類別，以判定 Microsoft Exchange Information Store 服務中的 Started 機碼值是設定為 True 或 False。

False 值表示目前這部 Exchange Server 電腦沒有執行 Microsoft Exchange Information Store 服務。True 值表示有執行 Microsoft Exchange Information Store 服務。

如果 Exchange Server Analyzer 發現 Microsoft Exchange Information Store 服務正在執行，且已安裝 Sybari Antigen，但未啟動 AntigenStore 服務，就會顯示一則警告。

Sybari Antigen 提供 Exchange Server 的防毒保護。此處列出可能會停止 Sybari AntigenStore 服務的一些原因及解決方案。

  • 在 Exchange Server 上執行的軟體可能是過期的評估版或試用版。在此狀況下，可能需要重新安裝 Sybari Antigen。若要繼續使用軟體，至少要將其啟動。

  • 系統管理員可能無意中停止了 Sybari Antigen 服務。確認服務已設為自動啟動，然後啟動服務。

  • 服務可能是被惡意的蠕蟲、病毒或其他程式停止。確認服務已設為自動啟動，然後啟動服務。若服務持續異常停止，並且沒有相關的錯誤事件出現，請驗證電腦並未被惡意的蠕蟲感染，並於必要時清除該系統上的蠕蟲。

一般而言，我們會建議您在「簡易郵件傳送通訊協定」(SMTP) 閘道上，或是在主控信箱的 Exchange 伺服器上，部署專為郵件系統所設計開發的防毒軟體。為了獲得最大保護，請在閘道執行防毒軟體來掃描傳入的 MIME 郵件，以及在使用 VSAPI 2.5 的 Exchange Server 上執行掃描程式。此外，您應該要在使用者桌面系統執行用戶端防毒軟體。如果您在閘道或 Exchange 伺服器上執行專門針對郵件系統所設計開發的防毒軟體 (該軟體可以剖析及掃描 MIME)，則只要在桌上型電腦執行檔案層級的掃描程式就已足夠。

若要啟動 AntigenStore 服務

  1. 開啟 [服務] MMC 嵌入式管理單元。

  2. 在 AntigenStore 服務上按一下滑鼠右鍵，然後再按 [內容]。

  3. 在 [AntigenStore] 內容頁的 [一般] 索引標籤上，確定 [啟動類型] 是設定成 [自動]。若不是，將其設為 [自動]，按一下 [套用]，再按一下 [確定]。

  4. 在 AntigenStore 服務上按一下滑鼠右鍵，然後再按 [啟動]。

  5. 關閉 [服務] 嵌入式管理單元。

若需有關加強 Exchange 環境，對抗以電子郵件傳遞之病毒的詳細資訊，請參閱《在 Exchange Server 2003 環境中減緩及阻止電子郵件病毒》(英文) (http://go.microsoft.com/fwlink/?LinkId=47587)。

若需有關將防毒軟體和 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜XADM：Exchange 和防毒軟體＞http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166

  • 306105＜XGEN:Microsoft 在 Exchange 2000 防毒解決方案中的地位＞(英文) http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105

  • 245822＜XGEN：對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822

若需 Exchange Server 可用的協力廠商防毒軟體清單，請參閱「Exchange Server 合作夥伴：防毒」網站 (英文) (http://go.microsoft.com/fwlink/?linkid=16226)。


此 Exchange 伺服器上已安裝了 Sybari Antigen，但是服務已停止
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定是否已安裝 Sybari Antigen，以及是否在 Exchange Server 電腦上執行 AntigenService 服務。

Exchange Server Analyzer 也會查詢 Win32_Service WMI 類別，以判定 Microsoft Exchange Information Store 服務中的 Started 機碼值是設定為 True 或 False。

False 值表示目前這部 Exchange Server 電腦沒有執行 Microsoft Exchange Information Store 服務。True 值表示有執行 Microsoft Exchange Information Store 服務。

如果 Exchange Server Analyzer 發現 Microsoft Exchange Information Store 服務正在執行，且已安裝 Sybari Antigen，但未啟動 AntigenService 服務，就會顯示一則警告。

Sybari Antigen 提供 Exchange Server 的防毒保護。下列是可能會停止 Sybari Antigen 服務的一些原因及解決方案：

  • 在 Exchange 伺服器上執行的軟體可能是過期的評估版或試用版。在此狀況下，可能需要重新安裝 Sybari Antigen。若要繼續使用軟體，至少要將其啟動。

  • 系統管理員可能無意中停止了 Sybari Antigen 服務。確認服務已設為自動啟動，然後啟動服務。

  • 服務可能是被惡意的蠕蟲、病毒或其他程式停止。確認服務已設為自動啟動，然後啟動服務。若服務持續異常停止，並且沒有相關的錯誤事件出現，請驗證電腦並未被惡意的蠕蟲感染，並於必要時清除該系統上的蠕蟲。

一般而言，我們會建議您在「簡易郵件傳送通訊協定」(SMTP) 閘道上，或是在主控信箱的 Exchange 伺服器上，部署專為郵件系統所設計開發的防毒軟體。為了取得最大的保護，請在閘道上執行用來掃描傳入 MIME 郵件的防毒軟體，並在使用 VSAPI 2.5 的 Exchange 伺服器上執行掃描程式。此外，您也應該在用戶端電腦上執行防毒軟體。如果您在閘道或 Exchange 伺服器上執行專門針對郵件系統所設計開發的防毒軟體 (該軟體可以剖析及掃描 MIME)，則只要在桌上型電腦執行檔案層級的掃描程式就已足夠。

若要啟動 AntigenService 服務

  1. 開啟 [服務] MMC 嵌入式管理單元。

  2. 在 AntigenService 服務上按一下滑鼠右鍵，然後再按 [內容]。

  3. 在 [AntigenService] 內容頁的 [一般] 索引標籤上，確定 [啟動類型] 是設定成 [自動]。若不是，將其設為 [自動]，按一下 [套用]，再按一下 [確定]。

  4. 在 AntigenService 服務上按一下滑鼠右鍵，然後再按 [啟動]。

  5. 關閉 [服務] 嵌入式管理單元。
  • 若需有關加強 Exchange 環境，對抗以電子郵件傳遞之病毒的詳細資訊，請參閱《在 Exchange Server 2003 環境中減緩及阻止電子郵件病毒》(英文) (http://go.microsoft.com/fwlink/?LinkId=47587)。

若需有關將防毒軟體和 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需 Exchange Server 可用的協力廠商防毒軟體清單，請參閱「Exchange Server 合作夥伴：防毒」網站 (英文) (http://go.microsoft.com/fwlink/?linkid=16226)。


Symantec 防毒定義已超過 30 天未更新
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判斷下列條件是否符合：

  • 伺服器上已安裝 Symantec 防毒。

  • 下列防毒定義已更新：

    HKEY_LOCAL_MACHINE\Software\Symantec\SharedDefs\MicroDefs

如果 Exchange Server Analyzer 發現 BinHubStamp 登錄機碼的數值資料已超過 30 天未更新，就會顯示一則警告。

Microsoft Exchange Server 的 Symantec 防毒為 Exchange Server 提供防毒保護。建議您在發行最新的 Symantec 防毒定義時便下載它。請確定您有將防毒定義更新部署至您組織中的下列階層：

  • 郵件閘道伺服器

  • Exchange 伺服器

  • 用戶端工作站

若要下載最新的病毒定義，請參閱 Symantec 防毒網站「Symantec 首頁」(英文) (http://www.symantec.com)。

若需有關加強 Exchange 環境，對抗以電子郵件傳遞之病毒的詳細資訊，請參閱《在 Exchange Server 2003 環境中減緩及阻止電子郵件病毒》(英文) (http://go.microsoft.com/fwlink/?LinkId=47587)。

若需將防毒軟體與 Exchange Server 搭配使用的相關資訊，請參閱下列微軟知識庫文件：

  • 328841＜Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需 Exchange Server 可用的協力廠商防毒軟體清單，請參閱「Exchange Server 合作夥伴：防毒」網站 (英文) (http://go.microsoft.com/fwlink/?linkid=16226)。

附註：
因為網站地址可能變更，所以您可能無法連接至該處所提及的網站。


此 Exchange 伺服器上已安裝 Symantec Antivirus，但是服務已停止
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定是否已設定 Started 機碼值。Win32_Service 類別會判定是否已安裝 Exchange Server 的 Symantec Antivirus。Started 機碼的 True 值表示此 Exchange Server 電腦正在執行 Symantec Antivirus 服務。Started 機碼的 False 值表示此 Exchange Server 電腦並未執行 Symantec Antivirus 服務。

若 Exchange Server Analyzer 發現 Symantec Antivirus 已安裝在這部 Exchange Server 電腦上，但未啟動 Symantec Antivirus 服務，Exchange Server Analyzer 就會顯示警告。

Symantec Antivirus 可為 Exchange Server 提供防毒保護。此處列出可能會造成 Symantec Antivirus 服務停止的一些原因及解決方案。

  • 您在 Exchange 伺服器上執行的軟體可能是過期的評估版或試用版。在此情況下，可能必須重新安裝 Symantec Antivirus。最低限度，若要繼續使用軟體，您必須加以啟動。

  • 系統管理員可能無意中停止了 Symantec Antivirus 服務。確認服務已設為自動啟動，然後啟動服務。

  • 服務可能是被惡意的蠕蟲、病毒或其他程式停止。確認服務已設為自動啟動，然後啟動服務。若服務持續異常停止，並且沒有相關的錯誤事件出現，請驗證電腦並未被惡意的蠕蟲感染，並於受感染時清除該系統上的蠕蟲。

建議您在「簡易郵件傳送通訊協定」(SMTP) 閘道上，或是在主控信箱的 Exchange 伺服器上，部署專為郵件系統所設計的防毒軟體。為了獲得最大保護，請在閘道執行防毒軟體來掃描傳入的 MIME 郵件，以及在使用 VSAPI 2.5 的 Exchange Server 上執行掃描程式。

啟動 Symantec Antivirus 服務

  1. 開啟 [服務] MMC 嵌入式管理單元。

  2. 以滑鼠右鍵按一下 Symantec Antivirus 服務，然後按一下 [內容]。

  3. 在 Symantec Antivirus 內容頁的 [一般] 索引標籤上，確認 [啟動類型] 設為 [自動]。如果不是，請按一下 [套用]，然後按一下 [確定]。

  4. 以滑鼠右鍵按一下 Symantec Antivirus 服務，然後按一下 [啟動]。

  5. 關閉 [服務] 嵌入式管理單元。

此外，您應該要在使用者桌面系統上執行用戶端防毒軟體。如果下列任一條件屬實，桌上型電腦上檔案層級的掃描程式會提供足夠的保護措施：

  • 您所執行的防毒軟體是針對郵件系統所設計的，可剖析及掃描閘道上的 MIME。

  • 您所執行的防毒軟體是針對郵件系統所設計的，可剖析及掃描 Exchange 伺服器上的 MIME。

若需有關一般搭配 Microsoft Exchange Server 2003 使用之不同病毒掃描程式類型的詳細資訊，請參閱微軟知識庫文件 - 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)。

若需有關一般搭配 Microsoft Exchange 2000 Server 使用之不同病毒掃描程式類型的詳細資訊，請參閱知識庫文件 - 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)。

若需有關加強 Exchange Server 環境，對抗以電子郵件傳遞之病毒及蠕蟲的詳細資訊，請參閱《在 Exchange Server 2003 環境中減緩及阻止電子郵件病毒》(英文) (http://go.microsoft.com/fwlink/?LinkId=47587)。


Symantec Mail Security for Exchange 防毒掃描組態警示
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 SMSMSE (Symantec Mail Security for Microsoft Exchange) 服務之 Started 機碼的設定值。

值為 True 表示 Symantec Mail Security for Microsoft Exchange Server 已安裝在此 Exchange Server 電腦上，且 SMSMSE 服務正在執行。值為 False 表示 SMSMSE 服務未執行。

Exchange Server Analyzer 也會查詢 Win32_Service WMI 類別，以判定 Microsoft Exchange Information Store 服務中的 Started 機碼值是設定為 True 或 False。

False 值表示目前這部 Exchange Server 電腦沒有執行 Microsoft Exchange Information Store 服務。True 值表示有執行 Microsoft Exchange Information Store 服務。

如果 Exchange Server Analyzer 發現 Microsoft Exchange Information Store 服務正在執行，且已安裝 Symantec Mail Security for Microsoft Exchange，但 SMSMSE 服務未執行，則會顯示警告。

經由電子郵件傳送的病毒是造成您的環境受到重大威脅的禍源之一。電子郵件病毒可能以超過負荷量的郵件來癱瘓系統的方式，攻擊電腦系統本身，或攻擊電子郵件環境。您必須確定您有足夠的保護措施來對抗環境中的病毒。請考慮在防火牆、在 SMTP 閘道上或之外、在每個 Exchange 伺服器及每個用戶端上預防病毒攻擊。

若要更正此警告

  1. 在 Exchange Server 電腦上啟動 Windows [服務] 嵌入式管理單元。

  2. 在右窗格中，向下捲動到 Symantec Mail Security for Microsoft Exchange 服務，並對它連按兩下。

  3. 請確定 [啟動類型] 下拉方塊中的值設為 [自動]。

  4. 按一下 [啟動] 來啟動 Symantec Mail Security for Microsoft Exchange 服務。

  5. 按一下 [確定] 來儲存變更並關閉 [內容] 對話方塊，然後結束嵌入式管理單元。

若需有關加強 Exchange 環境，對抗以電子郵件傳遞之病毒的詳細資訊，請參閱《在 Exchange Server 2003 環境中減緩及阻止電子郵件病毒》(英文) (http://go.microsoft.com/fwlink/?LinkId=47587)。

若需有關將防毒軟體和 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需 Exchange Server 可用的協力廠商防毒軟體清單，請參閱「Exchange Server 合作夥伴：防毒」網站 (英文) (http://go.microsoft.com/fwlink/?linkid=16226)。


有可用的 Symantec Mail Security for Microsoft Exchange 4.5 更新
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2006-02-14

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Savfmsevsapi.dll 的 Version 機碼值。如果 Version 機碼的值指出這個檔案的組建號碼是 4.5，則會顯示警告。

Savfmsevsapi.dll 的版本號碼若為 4.5，表示您不是執行最新版的 Symantec Mail Security for Microsoft Exchange 4.6x。Symantec 網站有 Symantec Mail Security for Microsoft Exchange 4.6x 的軟體更新。強烈建議您升級至 4.63 版或更新版本，因為這樣可以改進整體效能及可靠性。

下列是您在執行 4.5 版 Savfmsevsapi.dll 時一些已知的問題。

  • 在例行作業期間，Exchange 伺服器郵件流程的程序可能會遇到效能降低的情形。

  • 已備份 SMTP 佇列，例如目錄查閱佇列及本機傳遞佇列。

  • 無法停止 Microsoft Exchange Information Store 服務。

  • Microsoft Outlook® 用戶端無法連接至 Exchange 伺服器。

  • 從 Outlook 用戶端傳送的郵件會花比平常更多的時間才能將郵件傳遞至 Exchange 伺服器。Outlook 用戶端可能會有 30 秒無法回應。

若要更正此警告

  1. 請造訪 Symantec 網站的企業支援網頁 (英文) (http://www.symantec.com/techsupp/enterprise/)。

  2. 升級至 4.63 版或更新的版本。
附註：
本主題也提供協力廠商網站資訊，協助您找到需要的技術資訊。URL 如有變更，恕不另行通知。

若需將防毒軟體與 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN：Microsoft 在 Exchange 2000 防毒解決方案中的地位＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需 Exchange Server 可用的協力廠商防毒軟體清單，請參閱＜Exchange Server 合作夥伴：防毒＞(英文) (http://go.microsoft.com/fwlink/?linkid=16226)。


可使用 Trend Micro ScanMail for Microsoft Exchange 更新
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2006-01-09

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄值，以判定是否已向 Microsoft Exchange Information Store 註冊病毒掃描應用程式發展介面 (Virus Scanning Application Programming Interface, VSAPI) 程式庫檔案：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

當 ScanMail for Microsoft Exchange (為 Trend Micro 產品) 安裝在 Exchange 2000 Server 或 Exchange Server 2003 時，Library 登錄項目的值會是 SMXS3DLL.DLL。此程式庫檔案執行 ScanMail for Microsoft Exchange 中數個與 VSAPI 相關的功能。

Exchange Server Analyzer 也會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 SMXS3DLL.DLL 的 Version 機碼值。如果 Version 機碼值表示此檔案的組建編號小於 1174，就會顯示警告。

SMXS3DLL.DLL 的版本號碼若小於 1174，表示未安裝最新版的 ScanMail for Microsoft Exchange。可從 Trend Micro 網站取得 ScanMail for Microsoft Exchange 的軟體更新。建烈建議使用此更新，且此更新可增進整體效能及可靠性。

若要更正此警告

  1. 請造訪 Trend Micro 網站「ScanMail for Microsoft Exchange 更新中心」(英文) (http://www.trendmicro.com/download/product.asp?productid=8)。

  2. 下載您 ScanMail for Microsoft Exchange 版本的最新更新。

  3. 對 Exchange Server 電腦進行完整備份。

  4. 安裝 ScanMail for Microsoft Exchange 的最新更新。

若需有關將防毒軟體和 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需 Exchange Server 可用的協力廠商防毒軟體清單，請參閱「Exchange Server 合作夥伴：防毒」網站 (英文) (http://go.microsoft.com/fwlink/?linkid=16226)。


Trend Micro ServerProtect for Microsoft Windows 已停止
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 SpntSvc 服務的 Started 機碼值。ServerProtect for Microsoft Windows 已安裝 SpntSvc 服務，ServerProtect for Microsoft Windows 為 Trend Micro 產品。Started 機碼的值為 True 表示服務正在執行，值為 False 則表示服務未執行。如果 Exchange Server Analyzer 發現未啟動 SpntSvc 服務，就會顯示警告。

ServerProtect for Microsoft Windows 提供檔案系統型的伺服器防毒掃描功能，包括即時偵測及移除病毒。

若要啟動 SpntSvc 服務

  1. 開啟 [服務] MMC 嵌入式管理單元。

  2. 以滑鼠右鍵按一下 ServerProtect Server 服務，再按一下 [內容]。

  3. 在 [ServerProtect Server] 內容頁的 [一般] 索引標籤上，確定 [啟動類型] 的設定為 [自動]。若不是，將其設為 [自動]，按一下 [套用]，再按一下 [確定]。

  4. 以滑鼠右鍵按一下 ServerProtect Server 服務，再按一下 [啟動]。

  5. 關閉 [服務] 嵌入式管理單元。

若需有關將防毒軟體和 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需 Exchange Server 可用的協力廠商防毒軟體清單，請參閱「Exchange Server 合作夥伴：防毒」網站 (英文) (http://go.microsoft.com/fwlink/?linkid=16226)。


Trend ScanMail 組態：可以改善效能
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2006-09-05

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來判定 TempFileThreshold 的值：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

TempFileThreshold 登錄值適用於郵件內文和附件掃描。如果郵件內文或附件的大小大於 TempFileThreshold 機碼中所指定的值，將在磁碟上建立 Temp 檔案。否則，將建立在記憶體中。TempFileThreshold 的預設值是 3,072 KB (3 MB)。

Exchange Server Analyzer 也會查詢 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 TotalPhysicalMemory 機碼的設定值。此值代表安裝在電腦上的隨機存取記憶體 (RAM) 數量。

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定位於以下位置之通用設定 delivContLength 屬性的值：

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN= OrganizationName , CN=Global Settings, CN=Message Delivery

此屬性代表內送 SMTP 郵件的大小上限。

在安裝 1 GB 以上的 RAM 的 Exchange Server 電腦上，如果 Exchange Server Analyzer 發現 TempFileThreshold 的值小於最大內送郵件大小的百分之 70，則會顯示警告。

此警告指出 TempFileThreshold 登錄值可能未針對您的環境做最佳化設定。此值應該設定為至少等於您在 Exchange 伺服器上設定的附件大小限制。

附註：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

  3. 在右窗格中，對 TempFileThreshold 連按兩下。

  4. 以 KB 為單位輸入等於貴組織平均郵件大小的值，例如，若您的平均郵件大小為 10 MB，您便要輸入 10240。
附註：
若您增加此值，便可能需要額外的系統記憶體。例如，若將 'ScanningThreads' 值設為 8，並將 'TempFileThreshold' 值設為 10240，則病毒掃描所需的最小記憶體將為 80 MB (ScanningThreads * TempFileThreshold)。
  1. 關閉登錄編輯程式，然後重新啟動 ScanMail_RealTimeScan 服務及 Microsoft Exchange Information Store 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


Trend ScanMail 組態：QuerySender 登錄值已啟用
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2006-04-20

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Trend Micro ScanMail for Microsoft Exchange ScanMail_Action 服務的 Started 機碼值。True 值表示有執行 ScanMail_Action 服務，False 值表示未執行該服務。

Exchange Server Analyzer 也會讀取下列登錄項目來判定 ScanMail for Microsoft Exchange 是否已設為可以對 Active Directory® 目錄服務執行萬用字元搜尋：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\QuerySender

QuerySender 登錄項目的值為 0 指出已停用萬用字元搜尋。QuerySender 項目的值為 1 指出已啟用萬用字元搜尋。

此外，Exchange Server Analyzer 也會查詢 Active Directory，來判定每一個信箱儲存區的 homeMDBBL 屬性中列出的項目計數。這個屬性的計數代表信箱儲存區上的信箱數目。

如果 Exchange Server Analyzer 判定 ScanMail_Action 服務正在執行、Exchange Server 包含超過 100 個信箱，以及 QuerySender 登錄項目未設定為 0，將會顯示警告。

Trend Micro ScanMail for Microsoft Exchange 為 Exchange Server 提供了防毒保護。當 ScanMail for Exchange 正在掃描傳送到通訊群組清單的郵件時，預設行為是在 Active Directory 通用類別目錄中查詢所有郵件收件者。如果通訊群組清單中有大量的收件者，則這項行為可能會造成效能問題。此外，如果未實作本文件的建議事項，下列效能計數器的計數會升高：

  • MSExchangeIS/Virus Scan Queue Length

  • MSExchangeIS/RPC Requests

  • MSExchangeIS/RPC Averaged Latency

如果將 QuerySender 值設定為 0，則當掃描傳送給通訊群組清單的郵件時，將造成 ScanMail for Microsoft Exchange 不會在通用類別目錄中查詢所有收件者。

若要更正此警告

  1. 若需有關使用 QuerySender 登錄值的詳細資訊，請連絡 Trend Micro (英文) (http://www.trendmicro.com/en/about/overview.htm)。

  2. 若需有關 QuerySender 登錄值的詳細資訊，請參閱 Trend Micro 解決方案識別碼 120393 (http://esupport.trendmicro.com/support/viewxml.do?ContentID=en-120393)。

    附註：
    網址可能會變更，因此您可能無法連線到此處提到的網站。

若需有關加強 Exchange 環境，對抗以電子郵件傳遞之病毒的詳細資訊，請參閱《在 Exchange Server 2003 環境中減緩及阻止電子郵件病毒》(英文) (http://go.microsoft.com/fwlink/?LinkId=47587)。

若需有關將防毒軟體和 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需 Exchange Server 可用的協力廠商防毒軟體清單，請參閱「Exchange Server 合作夥伴：防毒」網站 (http://go.microsoft.com/fwlink/?LinkId=16226)。


Trend ScanMail 組態：ScanMail_Monitor 服務未依存叢集服務
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2006-02-13

Microsoft® Exchange Server Analyzer 工具會讀取屬於叢集節點之每部伺服器的下列登錄項目：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Version 值為 6.2.000 表示已安裝 6.2 版的 ScanMail for Microsoft Exchange。

Exchange Server Analyzer 也會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 ClusSvc (叢集服務) 的 Started 機碼值。值為 True 表示叢集服務正在執行，而值為 False 則表示該服務未執行。

Exchange Server Analyzer 也會讀取屬於叢集節點之每部伺服器的下列登錄項目：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ScanMail_Monitor

如果 Exchange Server Analyzer 發現 ScanMail_Monitor 登錄機碼並未包括值為 ClusSvc 的多值登錄機碼 DependOnService，則 ScanMail_Monitor 服務未依存叢集服務。

若下列條件為真，Exchange Server Analyzer 就會顯示警告訊息：

  • 伺服器正在執行 TrendMicro ScanMail for Microsoft Exchange 6.2 版。

  • 伺服器正在執行叢集服務 (ClusSvc)。

  • ScanMail_Monitor 服務未設為依存叢集服務。

在安裝 ScanMail for Microsoft Exchange 6.2 組建之後，您必須將 ScanMail_Monitor 服務設為依存叢集服務。如果您未設定這個相依性，那麼每次重新啟動節點時，叢集服務都將停止回應。

若要更正此警告

  1. 請參閱＜在套用 ScanMail for Exchange (SMEX) 6.2 Patch 1 [解決方案識別碼：21441] 之後，Microsoft Exchange 叢集服務意外停止＞(英文)，其位置在 Trend Micro 網站 (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionId=21441&id=21441)。

    附註：
    雖然解決方案識別碼文章 21441 特別提到在安裝修補程式 1 之後需要設定這個相依性，但是這篇文章適用於正在執行任何 ScanMail for Microsoft Exchange 6.2 組建的伺服器。

  2. 將 DependOnService 多字串值新增至解決方案 ID 文章 21441 的＜解決方案＞一節中指定的登錄。
附註：
本主題也提供協力廠商網站資訊，協助您找到需要的技術資訊。URL 如有變更，恕不另行通知。

若需其他 Trend Micro 產品更新的詳細資訊，請參閱 Trend Micro Update Center 網站 (英文) (http://www.trendmicro.com/download/)。

若需將防毒軟體與 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN：Microsoft 在 Exchange 2000 防毒解決方案中的地位＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需 Exchange Server 可用的協力廠商防毒軟體清單，請參閱＜Exchange Server 合作夥伴：防毒＞(英文) (http://go.microsoft.com/fwlink/?linkid=16226)。


Trend ScanMail 組態：SkipWildcardSearchInGC 登錄值設為 0
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，來判定 Trend Micro ScanMail for Microsoft Exchange ScanMail_Action 服務的 Started 機碼值。True 值表示有執行 ScanMail_Action 服務，False 值表示未執行該服務。

Exchange Server Analyzer 也會讀取下列登錄項目來判定 ScanMail for Microsoft Exchange 是否已設為可以對 Active Directory® 目錄服務執行萬用字元搜尋：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\SkipWildcardSearchInGC

SkipWildcardSearchInGC 登錄項目的值為 1 代表停用萬用字元搜尋。SkipWildcardSearchInGC 項目的值為 0 代表啟用萬用字元搜尋。

此外，Exchange Server Analyzer 也會查詢 Active Directory，以判定每一個信箱儲存區的 homeMDBBL 屬性所列出的項目計數。這個屬性的計數代表信箱儲存區上的信箱數目。

如果 Exchange Server Analyzer 判定 ScanMail_Action 服務正在執行、Exchange server 包含超過 100 個信箱，以及 SkipWildcardSearchInGC 登錄項目設為 0，則會顯示警告。

Trend Micro ScanMail for Microsoft Exchange 為 Exchange Server 提供了防毒保護。將 SkipWildcardSearchInGC 值設為 1，可防止 ScanMail for Microsoft Exchange 解析含有萬用字元 (*) 的名稱。查詢含有萬用字元的名稱會嚴重降低 Exchange Server 電腦的效能，因為 ScanMail for Exchange 最後會檢查整個目錄。此外，如果未實作本文件的建議事項，下列效能計數器的計數會升高：

  • MSExchangeIS/Virus Scan Queue Length

  • MSExchangeIS/RPC Requests

  • MSExchangeIS/RPC Averaged Latency

若要更正此警告

  1. 若需有關使用 SkipWildcardSearchInGC 登錄值的詳細資訊，請連絡 Trend Micro (英文) (http://www.trendmicro.com/en/about/overview.htm)。

  2. 若需有關 SkipWildcardSearchInGC 登錄值的詳細資訊，請參閱 Trend Micro 解決方案識別碼 20393 (英文) (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=20393)。

    附註：
    網址可能會變更，因此您可能無法連線到此處提到的網站。

若需有關加強 Exchange 環境，對抗以電子郵件傳遞之病毒的詳細資訊，請參閱《在 Exchange Server 2003 環境中減緩及阻止電子郵件病毒》(英文) (http://go.microsoft.com/fwlink/?LinkId=47587)。

若需有關將防毒軟體和 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需 Exchange Server 可用的協力廠商防毒軟體清單，請參閱「Exchange Server 合作夥伴：防毒」網站 (http://go.microsoft.com/fwlink/?LinkId=16226)。


Trend ScanMail 組態：MaxMessageCount 登錄值小於 500
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目來判定 MaxMessageCount 的值：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion

此外，Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定每個信箱儲存區之 homeMDBBL 屬性中列出的項目計數。這個屬性的計數代表信箱儲存區上的信箱數目。

如果 Exchange Server Analyzer 判定 Exchange Server 包含超過 100 個信箱，且 MaxMessageCount 的值小於 500，就會顯示一則警告。

Trend Micro ScanMail for Microsoft Exchange 為 Exchange Server 提供了防毒保護。當 ScanMail for Exchange 掃描執行緒完成一項工作後，就會將掃描結果寫入佇列。如果此佇列中有太多項目，則掃描執行緒必須等待，直到可以寫入佇列並釋放執行緒為止。掃描結果佇列大小的閾值是由 MaxMessageCount 來控制。將 MaxMessageCount 值設為 500 可以讓 ScanMail for Exchange 達到最佳效能。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion

  3. 在右窗格中，對 MaxMessageCount 連按兩下。

  4. 輸入值 500 (十進位)。

  5. 關閉登錄編輯程式，然後重新啟動 ScanMail_RealTimeScan 服務及 Microsoft Exchange Information Store 服務，使變更生效。

編輯登錄之前，以及想瞭解有關如何編輯登錄的詳細資訊時，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需使用 MaxMessageCount 登錄值的相關資訊，請造訪 Trend Micro 網站，網址為 http://www.trendmicro.com/en/about/overview.htm。

附註：
網址可能會變更，因此您可能無法連線到此處提到的網站。

若需有關加強 Exchange 環境，對抗以電子郵件傳遞之病毒的詳細資訊，請參閱《在 Exchange Server 2003 環境中減緩及阻止電子郵件病毒》(英文) (http://go.microsoft.com/fwlink/?LinkId=47587)。

若需有關將防毒軟體和 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需 Exchange Server 可用的協力廠商防毒軟體清單，請參閱「Exchange Server 合作夥伴：防毒」網站 (http://go.microsoft.com/fwlink/?LinkId=16226)。


Trend ScanMail 是設定為刪除所有的附件
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取數個登錄項目，以判定是否將 ScanMail for Microsoft Exchange 設定為會刪除附件。讀取值位於下列位置的登錄中：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption\Advance

值 | 描述
ActionType | 指示要封鎖哪些附件 (如果已開啟附件封鎖的話)。值為 0 表示封鎖所有附件。值為 3 表示系統管理員指定了副檔名、檔名或真實檔案類型的清單。若要設定，請在 ScanMail Management Console 的 [Attachment Blocking Settings] 對話方塊中選取適當的選項。
EnableAlert | 指示是否已啟用附件封鎖。值為 1 表示已啟用附件封鎖。值 0 表示已停用它。此設定可以藉由在 ScanMail Management Console 選取 (啟用) 或清除 (停用) [Virus Scan] | [Options] 頁的 [Enable attachment blocking] 核取方塊來設定。

HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

值 | 描述
EnableEManager | 指示是否已啟用 ScanMail eManager。值為 1 表示已啟用 eManager。值 0 表示已停用它。此設定可以藉由在 ScanMail Management Console 選取 (啟用) 或清除 (停用) [Enable eManager] 核取方塊來設定。唯有另外安裝 ScanMail eManager 這項輔助產品之後才可使用此設定。
EnableWebStoreDelMail | 指示是否已針對輸入郵件啟用 ScanMail Active Message Filter。值為 1 表示已針對輸入郵件啟用 ScanMail Active Message Filter。值為 0 表示未針對輸入郵件啟用它。此設定可以藉由在 ScanMail Management Console 選取 (啟用) 或清除 (停用) [Active Message Filter] 對話方塊的 [Inbound Messages] 核取方塊來設定。

Exchange Server Analyzer 也會讀取下列登錄項目，以判定是否已啟用病毒掃描 API (VSAPI) 郵件掃描：

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Enabled 的值為 1 表示已啟用 VSAPI 掃描。值為 0 表示未啟用 VSAPI 掃描。此設定可以藉由在 ScanMail Management Console 選取 (啟用) 或清除 (停用) [Virus Scan] | [Options] 頁的 [Enable VS API virus scanning] 核取方塊來設定。

如果 Exchange Server Analyzer 發現下列所有準則都符合，就會顯示一則警告：

  • ScanMail 中已啟用 VSAPI 掃描。

  • EnableAlert 的值是 1

  • ActionType 的值是 0

  • EnableEManager的值是 1

  • EnableWebStoreDelMail 的值是 1

這則警告表示 ScanMail 已設定為在下一個排程掃描或手動掃描時，刪除所有附件。

若要更正此警告

  1. 確認您要刪除附件。

  2. 如果想要這樣做，請停用附件封鎖或將 Delete (刪除) 動作變更為 Quarantine (隔離) 動作。這樣可讓系統管理員檢查隔離檔案中可能需要保留的附件。

若需有關 ScanMail for Microsoft Exchange 及 ScanMail eManager 的詳細資訊，請造訪 Trend Micro 網站 (英文) (http://www.trend.com)。

附註：
網址可能會變更，因此您可能無法連線到此處提到的網站。


將 Trend ScanMail 設為刪除具有特定檔案名稱的附件
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取數個登錄項目，以判定是否將 ScanMail for Microsoft Exchange 設為刪除附件。讀取的值位在下列位置的登錄中：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption\Advance

值 | 描述
ActionType | 指示要封鎖哪些附件 (如果已開啟附件封鎖的話)。值為 0 表示封鎖所有附件。值為 3 表示系統管理員已指定副檔名、檔案名稱或真實檔案類型的清單。在 [ScanMail Management Console] 中，選取 [Attachment Blocking Settings] 對話方塊上想要的選項，即可做此設定。
EnableAlert | 指示是否已啟用附件封鎖。值為 1 表示已啟用附件封鎖。值 0 表示已停用它。此設定可以藉由在 ScanMail Management Console 選取 (啟用) 或清除 (停用) [Virus Scan] | [Options] 頁的 [Enable attachment blocking] 核取方塊來設定。
FileName | 以分號分隔的字串值，包含要刪除的檔案清單。封鎖所指定的檔案時，可在 [ScanMail Management Console] 的 [Attachment Blocking Settings] 對話方塊上輸入所要的檔案名稱，以設定此設定。

HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

值 | 描述
EnableEManager | 指示是否已啟用 ScanMail eManager。值為 1 表示已啟用 eManager。值 0 表示已停用它。此設定可以藉由在 ScanMail Management Console 選取 (啟用) 或清除 (停用) [Enable eManager] 核取方塊來設定。唯有另外安裝 ScanMail eManager 這項輔助產品之後才可使用此設定。
EnableWebStoreDelMail | 指示是否已針對輸入郵件啟用 ScanMail Active Message Filter。值為 1 表示已針對輸入郵件啟用 ScanMail Active Message Filter。值為 0 表示未針對輸入郵件啟用它。此設定可以藉由在 ScanMail Management Console 選取 (啟用) 或清除 (停用) [Active Message Filter] 對話方塊的 [Inbound Messages] 核取方塊來設定。

Exchange Server Analyzer 也會讀取下列登錄項目，以判定是否已啟用病毒掃描 API (VSAPI) 郵件掃描：

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Enabled 的值為 1 表示已啟用 VSAPI 掃描。值 0 表示未啟用 VSAPI 掃描。此設定可以藉由在 ScanMail Management Console 選取 (啟用) 或清除 (停用) [Virus Scan] | [Options] 頁的 [Enable VS API virus scanning] 核取方塊來設定。

如果 Exchange Server Analyzer 發現下列所有條件均符合，則會顯示一則警告。

  • 在 ScanMail for Exchange 中已啟用 VSAPI 掃描

  • EnableAlert 的值是 1

  • ActionType 的值是 3

  • EnableEManager的值是 1

  • EnableWebStoreDelMail 的值是 1

  • FileName 不是 Null 或空的

此警告指出已將 ScanMail 設為在下次排定的時間或手動掃描期間，刪除具有 FileName 機碼中所列名稱的所有附件。

若要更正此警告

  1. 請驗證想要刪除具有 FileName 機碼中所列之名稱的附件。

  2. 如果需要，請停用附件封鎖，或將動作從 Delete (刪除) 變更為 Quarantine (隔離)。這樣可讓系統管理員檢查隔離檔案中可能需要保留的附件。

若需有關 ScanMail for Microsoft Exchange 及 ScanMail eManager 的詳細資訊，請參閱 Trend Micro 網站 (http://www.trend.com)。

附註：
網址可能會變更，因此您可能無法連線到此處提到的網站。


Trend ScanMail 已設定為刪除具有特定副檔名的附件
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取數個登錄項目，以判斷 Microsoft Exchange Server 的 ScanMail 是否設為刪除附件。讀取值位於下列位置的登錄中：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption\Advance

值 | 描述
ActionType | 指示要封鎖哪些附件 (如果已開啟附件封鎖的話)。值為 0 表示封鎖所有附件。值為 3 表示系統管理員已指定副檔名、檔案名稱或真實檔案類型的清單。在 [ScanMail Management Console] 中，選取 [Attachment Blocking Settings] 對話方塊上想要的選項，即可做此設定。
EnableAlert | 指示是否已啟用附件封鎖。值為 1 表示已啟用附件封鎖。值 0 表示已停用它。此設定可以藉由在 ScanMail Management Console 選取 (啟用) 或清除 (停用) [Virus Scan] | [Options] 頁的 [Enable attachment blocking] 核取方塊來設定。
副檔名 | 以分號分隔的字串值，其中包含要刪除之附件的副檔名清單。指定的附件受到封鎖時，在 [ScanMail Management Console] 的 [Attachment Blocking Settings] 對話方塊中輸入想要的副檔名，即可設定此設定。

HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

值 | 描述
EnableEManager | 指示是否已啟用 ScanMail eManager。值為 1 表示已啟用 eManager。值 0 表示已停用它。此設定可以藉由在 ScanMail Management Console 選取 (啟用) 或清除 (停用) [Enable eManager] 核取方塊來設定。唯有另外安裝 ScanMail eManager 這項輔助產品之後才可使用此設定。
EnableWebStoreDelMail | 指示是否已針對輸入郵件啟用 ScanMail Active Message Filter。值為 1 表示已針對輸入郵件啟用 ScanMail Active Message Filter。值為 0 表示未針對輸入郵件啟用它。此設定可以藉由在 ScanMail Management Console 選取 (啟用) 或清除 (停用) [Active Message Filter] 對話方塊的 [Inbound Messages] 核取方塊來設定。

Exchange Server Analyzer 也會讀取下列登錄項目，以判定是否已啟用病毒掃描 API (VSAPI) 郵件掃描：

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Enabled 的值為 1 表示已啟用 VSAPI 掃描。值 0 表示未啟用 VSAPI 掃描。此設定可以藉由在 ScanMail Management Console 選取 (啟用) 或清除 (停用) [Virus Scan] | [Options] 頁的 [Enable VS API virus scanning] 核取方塊來設定。

如果 Exchange Server Analyzer 發現下列所有條件均符合，則會顯示一則警告。

  • ScanMail 中已啟用 VSAPI 掃描。

  • EnableAlert 的值是 1

  • ActionType 的值是 3

  • EnableEManager的值是 1

  • EnableWebStoreDelMail 的值是 1

  • Extension 不是 Null 或空的

此警告表示 ScanMail 已設為在下次已排程或手動掃描期間，刪除具有 Extension 機碼中所列副檔名的所有附件。

若要更正此警告

  1. 確認您想要刪除具有 Extension 機碼中所列副檔名的附件。

  2. 如果想要這樣做，請停用附件封鎖或將 Delete (刪除) 動作變更為 Quarantine (隔離) 動作。這樣可讓系統管理員檢查隔離檔案中可能需要保留的附件。

若需有關 ScanMail for Microsoft Exchange Server 及 ScanMail eManager 的詳細資訊，請造訪 Trend Micro 網站 (http://www.trend.com)。

附註：
網址可能會變更，因此您可能無法連線到此處提到的網站。


Trend ScanMail 已設為處理郵件兩次
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 ScanMail_RealTimeScan 服務的 Started 機碼值。值為 TRUE 表示已啟動 ScanMail_RealTimeScan 服務，值為 FALSE 則表示未啟動 ScanMail_RealTimeScan 服務。ScanMail_RealTimeScan 服務是 Trend Micro ScanMail for Microsoft Exchange 應用程式的元件。Trend Micro ScanMail for Microsoft Exchange 為 Exchange 提供防毒保護。

此外，Exchange Server Analyzer 會讀取下列登錄項目，以判定 Enabled 值的設定：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\TransportAVAPI

Enabled 的值為 1，表示已啟用傳輸層級的防毒掃描 (有時候是指簡易郵件傳送通訊協定 (SMTP) 掃描)，值為 0 則表示未啟用 SMTP 掃描。

如果 Exchange Server Analyzer 發現 Enabled 設為 1，且 ScanMail_RealTimeScan 服務的 Started 機碼值設為 TRUE，則會顯示一則警告。

此警告表示相同的應用程式及病毒掃描引擎會掃描流經此 Exchange Server 電腦的郵件兩次。當郵件通過 Exchange Server 的傳輸及儲存元件時掃描相同的郵件兩次，會不必要地消耗資源而且未提供任何額外的防護或好處。建議您使病毒掃描 API (VSAPI) 病毒掃描保持啟用狀態，並利用 ScanMail Management Console 來停用 SMTP 郵件掃描。

一般而言，我們會建議您在 SMTP 閘道上或主控信箱的 Exchange 伺服器上，部署專為郵件系統所設計開發的防毒軟體。若需最高防護，請執行可掃描輸入 MIME 郵件閘道處的防毒軟體，以及 Exchange Server 上使用 VSAPI 2.5 的掃描程式。此外，您應該執行使用者桌面上的用戶端防毒軟體。如果您在閘道或 Exchange 伺服器上執行專門針對傳訊系統所設計開發的防毒軟體 (該軟體可以剖析及掃描 MIME)，則只要在桌上型電腦執行檔案層級的掃描程式就已足夠。

若要更正此警告

  1. 開啟 [ScanMail Management Console] 並輸入您的登入憑證。

  2. 在 [Virus Scan] | [Options] 頁面上，確定已選取 [Enable VS API virus scanning] 核取方塊。

  3. 在相同的頁面上，清除 [Enable SMTP mail scanning] 核取方塊。

  4. 按一下 [Apply] 以儲存變更。

  5. 關閉 [ScanMail Management Console]。

若需有關 Trend Micro ScanMail for Microsoft Exchange 的詳細資訊，請參閱 Trend 網站 (http://kb.trendmicro.com/solutions/search)。

附註：
網址可能會變更，因此您可能無法連線到此處提到的網站。

若需有關將防毒軟體和 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)

  • 823166＜Overview of Exchange Server 2003 and antivirus software＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 在 Exchange 2000 防毒解決方案中的地位＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=306105)

  • 245822＜Recommendations for troubleshooting an Exchange computer with antivirus software installed＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=245822)


Trend ScanMail 低執行緒計數
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，來判定 MaxScanningThreadCount 的值：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

MaxScanningThreadCount 登錄值代表 ScanMail for Exchange 可以建立來掃描的執行緒最大數量。預設值是 12。

Exchange Server Analyzer 也會讀取下列登錄項目，以判定是否已啟用病毒掃描 API (VSAPI) 郵件掃描：

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Enabled 的值為 1 表示已啟用 VSAPI 掃描。值 0 表示未啟用 VSAPI 掃描。

Exchange Server Analyzer 也會查詢 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 NumberOfProcessors 機碼的設定值。這個值代表電腦上安裝的處理器數目，包含了實體處理器及邏輯處理器。使用 Intel 的「超執行緒」技術，一個實體處理器可分割為兩個邏輯處理器。

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定屬於 msExchPrivateMDB 物件類別的物件數目。這些物件的計數代表這部 Exchange Server 電腦上的信箱儲存區數目。

如果 Exchange Server Analyzer 在已啟用 VSAPI 掃描的 Exchange Server 電腦上發現 MaxScanningThreadCount 的值小於 (2 × NumberOfProcessors + 1) + 3 + 信箱儲存區數目)，將會顯示警示。

附註：
如果啟用「超執行緒」，則 NumberOfProcessors 值會是實體處理器數目的兩倍。建議您為具有實體處理器的系統，以及同時具有實體處理器及邏輯處理器的系統使用上述公式。

此警告指出 MaxScanningThreadCount 登錄值可能未針對您的環境做最佳化設定。此值應該設定為至少等於您在 Exchange 伺服器上設定的附件大小限制。若需相關登錄值的相關資訊，請參閱＜Trend ScanMail 低執行緒儲存區計數＞。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

  3. 在右窗格中，連按兩下 MaxScanningThreadCount。

  4. 輸入 Exchange Server Analyzer 建議的值。

  5. 關閉登錄編輯程式，然後重新啟動 ScanMail_RealTimeScan 以及 Microsoft Exchange Information Store 兩項服務，以使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需 MaxScanningThreadCount 登錄值的詳細資訊，請參閱 Trend Micro 解決方案識別碼 13176 (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=13176)。

若需有關超執行緒技術的詳細資訊，請參閱 Intel 網站 (英文) (http://www.intel.com/technology/hyperthread)。

附註：
網址可能會變更，因此您可能無法連線到此處提到的網站。


Trend ScanMail 低執行緒儲存區計數
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2006-04-21

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 ScanningThreadPoolCount 的值：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

ScanningThreadPoolCount 登錄值代表 ScanMail for Exchange 服務啟動時將初始化且隨時可用的掃描執行緒數目。預設值是 12。當用光所有在啟動時建立的執行緒時，ScanMail for Exchange 將建立其他要使用的執行緒，直到它達到 Trend ScanMail 低執行緒計數中描述的 MaxScanningThreadCount 登錄值所控制的執行緒數目。

Exchange Server Analyzer 也會讀取下列登錄項目，以判定是否已啟用病毒掃描 API (VSAPI) 郵件掃描：

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Enabled 的值為 1 表示已啟用 VSAPI 掃描。值 0 表示未啟用 VSAPI 掃描。

Exchange Server Analyzer 也會查詢 Win32_ComputerSystem Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 NumberOfProcessors 機碼的設定值。這個值代表電腦上安裝的處理器數目，包含了實體處理器及邏輯處理器。使用 Intel 的「超執行緒」技術，一個實體處理器可分割為兩個邏輯處理器。

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定屬於 msExchPrivateMDB 物件類別的物件數目。這些物件的計數代表這部 Exchange Server 電腦上的信箱儲存區數目。

如果 Exchange Server Analyzer 在已啟用 VSAPI 掃描的 Exchange Server 電腦上發現 ScanningThreadPoolCount 的值小於 (2 × NumberOfProcessors + 1) + 3 + 信箱儲存區數目)，將會顯示警示。

附註：
如果啟用「超執行緒」，則 NumberOfProcessors 值會是實體處理器數目的兩倍。建議您為具有實體處理器的系統，以及同時具有實體處理器及邏輯處理器的系統使用上述公式。

此警告指出 ScanningThreadPoolCount 登錄值可能未針對您的環境做最佳化設定。此值應該設定為至少等於您在 Exchange 伺服器上設定的附件大小限制。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption.

  3. 在右窗格中，連按兩下 ScanningThreadPoolCount。

  4. 輸入 Exchange Server Analyzer 建議的值。

  5. 關閉登錄編輯程式，然後重新啟動 ScanMail_RealTimeScan 服務及 Microsoft Exchange Information Store 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關超執行緒技術的詳細資訊，請造訪 Intel 網站 (英文) (http://www.intel.com/technology/hyperthread)。

附註：
網址可能會變更，因此您可能無法連線到此處提到的網站。


Trend ScanMail 正處於偵錯模式
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2006-06-22

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 ModuleName 的值：

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\Tools\Debug

ModuleName 登錄值代表使用中的偵錯模組檔案名稱。

Exchange Server Analyzer 也會讀取下列登錄項目，以判定是否已啟用病毒掃描 API (VSAPI) 郵件掃描：

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Enabled 的值為 1 表示已啟用 VSAPI 掃描。值 0 表示未啟用 VSAPI 掃描。

如果 Exchange Server Analyzer 發現已啟用 VSAPI 掃描，且 ModuleName 登錄值不是空的或 Null，就會顯示一則警告。

執行偵錯模式會造成效能大幅降低，因為涉及背景診斷追蹤。除非您需要在偵錯模式中對 Exchange 執行 ScanMail 以主動疑難排解問題，否則應該關閉偵錯模式。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\Software\TrendMicro\ScanMail for Exchange\Tools\Debug.

  3. 在右窗格中，連按兩下 ModuleName。

  4. 刪除這個項目的數值資料，將字串保留空白。請勿刪除 ModuleName 機碼。

  5. 關閉登錄編輯程式，然後重新啟動 ScanMail_RealTimeScan 以及 Microsoft Exchange Information Store 兩項服務，以使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱 Microsoft 知識庫文章 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052)。

如需確認是否已停用偵錯模式的詳細資訊，請參閱 Trend Micro 解決方案識別碼 119149 (http://esupport.trendmicro.com/support/viewxml.do?ContentID=en-119149)。

附註：
本主題也提供協力廠商網站資訊，以協助您找到需要的技術資訊。URL 隨時都會變更，恕不另行通知。


此 Exchange 伺服器上安裝了 Trend ScanMail Mail Action 服務，但是服務已停止
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定是否已安裝 Trend Micro ScanMail for Exchange，且是否已在 Exchange 電腦上執行 ScanMail_MailAction 服務。

Exchange Server Analyzer 也會查詢 Win32_Service WMI 類別，以判定 Microsoft Exchange Information Store 服務中的 Started 機碼值是設定為 True 或 False。

False 值表示目前這部 Exchange Server 電腦沒有執行 Microsoft Exchange Information Store 服務。True 值表示有執行 Microsoft Exchange Information Store 服務。

如果 Exchange Server Analyzer 發現 Microsoft Exchange Information Store 服務正在執行，且已安裝 Trend Micro ScanMail for Exchange，但未啟動 ScanMail_MailAction 服務，就會顯示一則警告。

Trend Micro ScanMail for Exchange 提供 Exchange 伺服器的防毒保護。此處列出可能會造成 Trend ScanMail 服務停止的一些原因及解決方案。

  • 在 Exchange 伺服器上執行的軟體可能是過期的評估版或試用版。在此狀況下，可能需要重新安裝 Trend ScanMail。若要繼續使用軟體，至少要將其啟動。

  • 系統管理員可能不小心停止了 ScanMail_MailAction 服務。確認服務已設為自動啟動，然後啟動服務。

  • 服務可能是被惡意的蠕蟲、病毒或其他程式停止。確認服務已設為自動啟動，然後啟動服務。若服務持續異常停止，並且沒有相關的錯誤事件出現，請驗證電腦並未被惡意的蠕蟲感染，並於必要時清除該系統上的蠕蟲。

一般而言，我們會建議您在「簡易郵件傳送通訊協定」(SMTP) 閘道上，或是在主控信箱的 Exchange 伺服器上，部署專為郵件系統所設計開發的防毒軟體。為了獲得最大保護，請在閘道執行防毒軟體來掃描傳入的 MIME 郵件，以及在使用 VSAPI 2.5 的 Exchange 伺服器上執行掃描程式。此外，您應該要在使用者桌面系統執行用戶端防毒軟體。如果您在閘道或 Exchange 伺服器上執行專門針對郵件系統所設計開發的防毒軟體 (該軟體可以剖析及掃描 MIME)，則只要在桌上型電腦執行檔案層級的掃描程式就已足夠。

若要啟動 ScanMail_MailAction 服務

  1. 開啟 [服務] MMC 嵌入式管理單元。

  2. 以滑鼠右鍵按一下 [ScanMail_MailAction] 服務，再按一下 [內容]。

  3. 在 [ScanMail_MailAction] 內容頁的 [一般] 索引標籤上，確定 [啟動類型] 是設定成 [自動]。若不是，將其設為 [自動]，然後按一下 [套用]，再按一下 [確定]。

  4. 以滑鼠右鍵按一下 [ScanMail_MailAction] 服務，再按一下 [啟動]。

  5. 關閉 [服務] 嵌入式管理單元。
  • 若需有關加強 Exchange 環境，對抗以電子郵件傳遞之病毒的詳細資訊，請參閱《在 Exchange Server 2003 環境中減緩及阻止電子郵件病毒》(英文) (http://go.microsoft.com/fwlink/?LinkId=47587)。

若需有關將防毒軟體和 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需 Exchange Server 可用的協力廠商防毒軟體清單，請參閱「Exchange Server 合作夥伴：防毒」網站 (英文) (http://go.microsoft.com/fwlink/?linkid=16226)。


此 Exchange 伺服器上安裝了 Trend ScanMail Real-Time 服務，但是服務已停止。
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Exchange Server 電腦上是否有安裝 Trend Micro ScanMail for Microsoft Exchange，以及是否有執行 ScanMail_RealTimeScan 服務。如果 Exchange Server Analyzer 發現有安裝 Trend Micro ScanMail for Microsoft Exchange，但未啟動 ScanMail_RealTimeScan 服務，就會顯示一則警告。

Trend Micro ScanMail for Microsoft Exchange 為 Exchange 提供防毒保護。基於某些原因，ScanMail_RealTimeScan 服務可能已停止，以下列出一些解決方案：

  • 您在 Exchange 伺服器上執行的軟體可能是過期的評估 (或試用) 版。在這種情況下，您可能需要重新安裝 Trend Micro ScanMail for Microsoft Exchange。若要繼續使用軟體，至少要將其啟動。

  • 系統管理員可能無意中停止了 ScanMail_RealTimeScan 服務。確認服務已設為自動啟動，然後啟動服務。

  • 服務可能是被惡意的蠕蟲、病毒或其他程式停止。確認服務已設為自動啟動，然後啟動服務。若服務持續異常停止，並且沒有相關的錯誤事件出現，請驗證電腦並未被惡意的蠕蟲感染，並於必要時清除該系統上的蠕蟲。

一般而言，我們會建議您在「簡易郵件傳送通訊協定」(SMTP) 閘道上，或是在主控信箱的 Exchange 伺服器上，部署專為郵件系統所設計開發的防毒軟體。為了達到最佳保護，可在閘道執行防毒軟體，掃描輸入的 MIME 郵件，以及在使用病毒掃描 API (VSAPI) 版本 2.5 的 Exchange 伺服器上執行掃描程式。此外，您應該要在使用者桌面系統執行用戶端防毒軟體。如果您在閘道或 Exchange 伺服器上執行專門針對郵件系統所設計開發的防毒軟體 (該軟體可以剖析及掃描 MIME)，則只要在桌上型電腦執行檔案層級的掃描程式就已足夠。

若要啟動 ScanMail_RealTimeScan 服務

  1. 開啟 [服務] MMC 嵌入式管理單元。

  2. 在 ScanMail_RealTimeScan 服務上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 在 [ScanMail_RealTimeScan] 內容頁的 [一般] 索引標籤上，確定 [啟動類型] 設定為 [自動]。若不是，將其設為 [自動]，然後按一下 [套用]，再按一下 [確定]。

  4. 在 ScanMail_RealTimeScan 服務上按一下滑鼠右鍵，然後按一下 [啟動]。

  5. 關閉 [服務] 嵌入式管理單元。
  • 若需有關加強 Exchange 環境，對抗以電子郵件傳遞之病毒的詳細資訊，請參閱《在 Exchange Server 2003 環境中減緩及阻止電子郵件病毒》(英文) (http://go.microsoft.com/fwlink/?LinkId=47587)。

若需有關將防毒軟體和 Exchange Server 搭配使用的詳細資訊，請參閱下列微軟知識庫文件：

  • 328841＜XADM：Exchange 和防毒軟體＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166＜Exchange Server 2003 及防毒軟體概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105＜XGEN:Microsoft 對 Exchange 2000 防毒解決方案的立場＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822＜對於已安裝防毒軟體的 Exchange 電腦疑難排解建議＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

若需 Exchange Server 可用的協力廠商防毒軟體清單，請參閱「Exchange Server 合作夥伴：防毒」網站 (http://go.microsoft.com/fwlink/?LinkId=16226)。


關閉用戶端上的協力廠商增益集
Microsoft Exchange Server Analyzer - 文章 > 協力廠商軟體 >

主題上次修改日期： 2006-04-21

Microsoft® Exchange Server Analyzer 工具判斷您正在執行下列其中一類協力廠商軟體：

  • Microsoft Office Outlook® 協力廠商增益集，如防毒軟體或傳真軟體

  • 存取 Exchange 伺服器的協力廠商應用程式

  • 行動裝置的協力廠商同步處理軟體

建議您調查使用者執行哪些類型的協力廠商應用程式，然後決定是否限制這些應用程式或完全移除應用程式。請記住執行協力廠商軟體可能會經常造成伺服器上的過多負載。

若要在 Outlook 中關閉協力廠商增益集

  1. 在 Outlook 中的 [工具] 功能表上，按一下 [選項]。

  2. 在 [選項] 中，按一下 [其他] 索引標籤，然後按一下 [進階選項]。

  3. 在 [進階選項] 中，按一下 [增益集管理員]。

  4. 清除協力廠商增益集的核取方塊。

  5. 按一下 [確定]。

  6. 重新啟動 Outlook。

詳細資訊

  • 若需有關 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若需有關疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《疑難排解 Microsoft Exchange Server 2003 效能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


傳輸
Microsoft Exchange Server Analyzer - 文章 >

主題上次修改日期： 2005-11-18

本節中的文章件提供 Microsoft® Exchange Server Analyzer 工具對 Exchange 傳輸元件評估的詳細資料。此外，這些文章還說明可用來解決 Exchange Server Analyzer 所發現之傳輸相關錯誤、警告及非預設組態的動作。


未註冊 8BITMIME
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-08-18

Microsoft® Exchange Server Analyzer 工具會傳輸 EHLO 延伸的簡易郵件傳送通訊協定 (ESMTP) 命令動詞到遠端伺服器的通訊埠 25 並分析回應，以判定遠端伺服器是否支援 8BITMIME ESMTP 動詞。

若從遠端伺服器收到的回應沒有包含字串 '250-8BITMIME'，Exchange Server Analyzer 便會顯示警告。

Exchange Server 2003 會使用 Exchange 特定延伸 SMTP 動詞，以便與組織中其他執行 Exchange Server 的伺服器通訊。使用 Exchange 特定延伸 SMTP 動詞通訊，比使用標準 SMTP 更有效率。如果支援 ESMTP 命令的設定已停用，則可能會妨礙 Exchange Server 的效能。

此錯誤指出遠端伺服器不支援 ESMTP 8BITMIME 命令動詞。錯誤並未指出遠端伺服器是或不是 Exchange 伺服器。無論是在哪種執行個體都不會路由傳送需要 8BITMIME 延伸模組的郵件。

若要處理此問題，請檢查需要 8BITMIME 延伸模組之郵件的 SMTP 佇列內容。

若需如何移除或還原這些動詞之預設支援的詳細資訊，請參閱 Microsoft 知識庫文章 257569＜如何在 Exchange 2000 Server 及 Exchange Server 2003 中關閉 ESMTP 動詞＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569)。

若需 Exchange Server 如何使用 ESMTP 命令動詞的詳細資訊，請參閱《Exchange Server 傳輸及路由手冊》中的＜如何正確載入 Exchange SMTP＞(http://go.microsoft.com/fwlink/?LinkId=71800)


ADAM LDAP Port Identified
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-07-23

Microsoft Exchange Analyzer 工具會讀取下列登錄項目，以判定 Edge Transport Server 上的 Active Directory 應用程式模式 (ADAM) 目錄服務所使用的通訊埠：

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\EdgeTransportRole\AdamSettings\MsExchangeAdam\LdapPort

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\EdgeTransportRole\AdamSettings\MsExchangeAdam\SslPort

ADAM 是一項輕量型目錄存取通訊協定 (LDAP) 目錄服務，它是特別設計來與擁有目錄功能的應用程式搭配使用。ADAM 只會儲存和複製應用程式特有的資訊，並不需要在網域控制站上部署，也不依存於 Active Directory 目錄服務。ADAM 不提供網路作業系統驗證或授權。

在 Microsoft Exchange Server 2007 中，Edge Transport server role 會使用 ADAM 來儲存組態資訊及收件者資料，以進行內容篩選。將 ADAM 與 Active Directory 同步後，ADAM 也可執行收件者查閱作業以提供郵件安全性。

當資料從 Active Directory 傳送至 ADAM 時，資料會透過下列非預設的通訊埠使用 LDAP 連線來傳送：

  • LDAP：通訊埠 50389/TCP

  • 安全 LDAP：通訊埠 50636/UDP

當 Exchange Analyzer 識別出 ADAM 使用的通訊埠時，Exchange Analyzer 會顯示最佳作法訊息。

建議的最佳作法是禁止從外部存取所有非必要的通訊埠。

若要解決此問題，請檢查 Exchange Analyzer 識別為 ADAM 使用的通訊埠並未開啟供外部存取。

注意：
通訊埠 50636/UDP 是用於 Exchange EdgeSync 服務，因此如果需要 EdgeSync 功能，應該保持開啟狀態。
使用 Windows 防火牆禁止從外部存取所識別的 ADAM 通訊埠

  1. 依序按一下 [開始] 及 [執行]，輸入 firewall.cpl，然後按一下 [確定]。

  2. 按一下 [例外] 索引標籤。

  3. 選取 [名稱] 方塊中列出的每一個程式或服務，然後按一下 [編輯] 來檢閱開啟的通訊埠。

  4. 驗證 Exchange Analyzer 報告為 ADAM 使用的通訊埠是否未列出。

  5. 如果識別的通訊埠有列出，請確定這些通訊埠並未用於其他必要通訊，然後在 [編輯服務] 視窗中取消選取這些通訊埠來將其關閉。

  6. 按兩次 [確定] 來結束 Windows 防火牆組態。

詳細資訊

如需 Exchange 2007 使用的所有資料路徑的通訊埠、驗證及加密的相關資訊，請參閱＜資料路徑安全性參照＞(英文) (http://go.microsoft.com/fwlink/?LinkId=95630)。


已安裝防毒外掛程式
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-08-18

Microsoft® Exchange Server Analyzer 工具會掃描下列登錄項目，以判定是否已安裝 Symantec Antivirus Corporate Edition 9.x 網際網路電子郵件自動保護外掛程式：

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail

此登錄子目錄若存在，指出 Symantec Antivirus Corporate Edition 9.x 網際網路電子郵件自動保護外掛程式已安裝在執行 Exchange Server 的伺服器上。

Exchange Server Analyzer 也會讀取下列登錄項目，以判定是否已啟用 Symantec Antivirus Corporate Edition 9.x 網際網路電子郵件自動保護外掛程式：

HKLM\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail\RealTimeScan\OnOff

OnOff 的值若為 1，指出已啟用自動保護外掛程式。若為 0 值，指出未啟用自動保護外掛程式。

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • 已安裝 Symantec Antivirus Corporate Edition 9.x 網際網路電子郵件自動保護外掛程式。

  • 未啟用 Symantec Antivirus Corporate 9.x 網際網路電子郵件自動保護外掛程式。

此警告指出應該對照目前廠商建議的最佳作法來檢閱外掛程式的安裝與組態。

若需廠商建議此外掛程式最佳作法的相關資訊，請參閱＜Microsoft Exchange 伺服器上 Symantec Antivirus Corporate Edition 9.x 自動保護的最佳作法＞(英文) (http://service1.symantec.com/SUPPORT/ent-security.nsf/c9b1ac1936fbf63488256e77006521df/3d1bcbc855fce10288256e9e007e01f0?OpenDocument&src=bar_sch_nam)。

附註：
本主題也提供協力廠商網站資訊，協助您找到需要的技術資訊。URL 如有變更，恕不另行通知。


已啟用防毒外掛程式
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-08-18

Microsoft® Exchange Server Analyzer 工具會掃描下列登錄項目，以判定是否已安裝 Symantec Antivirus Corporate Edition 9.x 網際網路電子郵件自動保護外掛程式。

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail

此登錄項目若存在，指出 Symantec Antivirus Corporate Edition 9.x 網際網路電子郵件自動保護外掛程式已安裝在執行 Exchange Server 的伺服器上。

Exchange Server Analyzer 也會讀取下列登錄項目，以判定是否已啟用 Symantec Antivirus Corporate Edition 9.x 網際網路電子郵件自動保護外掛程式：

HKLM\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail\RealTimeScan\OnOff

OnOff 的值若為 1，指出已啟用自動保護外掛程式。若為 0 值，指出未啟用自動保護外掛程式。

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • 已安裝 Symantec Antivirus Corporate Edition 9.x 網際網路電子郵件自動保護外掛程式。

  • 已安裝 Symantec Antivirus Corporate Edition 9.x 網際網路電子郵件自動保護外掛程式。

此錯誤指出應該對照目前廠商建議的最佳作法來檢閱外掛程式的安裝與組態。

若需廠商建議此外掛程式最佳作法的相關資訊，請參閱＜Microsoft Exchange 伺服器上 Symantec Antivirus Corporate Edition 9.x 自動保護的最佳作法＞(英文) (http://service1.symantec.com/SUPPORT/ent-security.nsf/c9b1ac1936fbf63488256e77006521df/3d1bcbc855fce10288256e9e007e01f0?OpenDocument&src=bar_sch_nam)。

附註：
本主題也提供協力廠商網站資訊，協助您找到需要的技術資訊。URL 如有變更，恕不另行通知。


BCC 日誌已啟用
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已啟用密件副本 (Bcc) 日誌：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\JournalBCC

如果 Exchange Server Analyzer 發現 JournalBCC 的值設為 1，就會顯示非預設的組態訊息。

Bcc 日誌是只限郵件的日誌，並且加入了擷取 Bcc 收件者的功能。啟用 Bcc 日誌時，Exchange Server 會擷取所有的收件者，包括原生伺服器上的 Bcc 收件者。如果此收件者清單包括隱藏的通訊群組清單、查詢式通訊群組清單或在其他伺服器上擴充的通訊群組清單，則這些清單的收件者不會包括在已寫入日誌的郵件中。

設定登錄機碼，即可啟用 Bcc 日誌功能。若需有關設定此登錄機碼的詳細資訊，請參閱微軟知識庫文件 - 810999＜XADM：Exchange 2000 中日誌郵件的密件副本資訊遺失＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810999)。

若要在特定的伺服器上啟用 Bcc 日誌，您必須先設定只限郵件的日誌。如果下列情況存在，則 JournalBCC 設定不處於作用中：

  • JournalBCC 登錄設為 1。

  • 未在同一個伺服器上的任何一個資料庫上啟用只限郵件的日誌。

日誌郵件會消耗許多磁碟、網絡及 CPU 資源。因此，日誌需要周密的部署計劃。應該只在整體日誌方案架構的環境中啟用日誌。

如果存在下列狀況，請忽略此非預設的組態訊息：

  • 您的公司需要日誌。

  • 您已部署日誌解決方案架構。

否則，您應該關閉日誌功能。您可以關閉資料庫上的日誌來停用日誌。

關閉資料庫上只限郵件的日誌

  1. 在 [Exchange 系統管理員]中，依序展開 [伺服器]、<您的 Exchange 伺服器> 及 <儲存群組>，然後在信箱儲存區上按一下滑鼠右鍵。

  2. 在 [一般] 索引標籤上，清除核取方塊 [封存由此儲存區的信箱所傳送或接收的所有郵件]。

  3. 等待 15 分鐘，讓 Exchange 儲存區套用變更。您不必重新啟動 Microsoft Exchange Information Store 服務。

如果不想要 Exchange Server Analyzer 再次顯示此訊息，必須刪除 JournalBCC 登錄機碼。停用日誌功能不需要刪除 JournalBCC 登錄機碼。

重要事項：
本篇文章包含有關編輯登錄的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需還原登錄的相關資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
刪除 JournalBCC 登錄機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\

  3. 在右窗格中，尋找並刪除 JournalBCC 值。

  4. 關閉登錄編輯程式。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關部署日誌解決方案的詳細資訊，請參閱《Exchange Server 2003 日誌》(英文) (http://go.microsoft.com/fwlink/?LinkId=47581)。


未註冊 BDAT
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-08-18

Microsoft® Exchange Server Analyzer 工具會傳輸 EHLO 延伸的簡易郵件傳送通訊協定 (ESMTP) 命令動詞到遠端伺服器的通訊埠 25 並分析回應，以判定遠端伺服器是否支援 BDAT ESMTP 動詞。

如果 Exchange Server Analyzer 從遠端伺服器收到一個回應，其字串指出不可擷取的錯誤，則 Exchange Server Analyzer 會顯示錯誤。

Exchange Server 2003 會使用 Exchange 特定延伸 SMTP 動詞，以便與組織中其他執行 Exchange Server 的伺服器通訊。使用 Exchange 特定延伸 SMTP 動詞通訊，比使用標準 SMTP 更有效率。如果支援 ESMTP 命令的設定已停用，則可能會妨礙 Exchange Server 的效能。

此錯誤指出遠端伺服器不支援 ESMTP BDAT 命令動詞。錯誤並未指出遠端伺服器是或不是 Exchange 伺服器。無論是在哪種執行個體都不會路由傳送需要 BDAT 延伸模組的郵件。

若要處理此問題，請檢查需要 BDAT 延伸模組之郵件的 SMTP 佇列內容。

若需如何移除或還原這些動詞之預設支援的詳細資訊，請參閱 Microsoft 知識庫文章 257569＜如何在 Exchange 2000 Server 及 Exchange Server 2003 中關閉 ESMTP 動詞＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569)。

若需 Exchange Server 如何使用 ESMTP 命令動詞的詳細資訊，請參閱《Exchange Server 傳輸及路由手冊》中的＜如何正確載入 Exchange SMTP＞ (http://go.microsoft.com/fwlink/?LinkID=71800)。


用以針對 RGC 檢查通訊群組傳遞限制的 Bridgehead 伺服器
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-09-18

Microsoft® Exchange Server Analyzer 工具會查詢在 Active Directory® 目錄服務中偵測到的每一個路由群組連接器物件 (msExchRoutingGroupConnector) 的下列屬性，以判定是否根據通訊群組成員來設定傳遞限制。

dLMemRejectPerms | 包含其成員可能未透過此路由群組連接器來傳送之通訊群組清單 (DL) 的網域名稱 (DN)。
dLMemSubmitPerms | 包含其成員可能透過此路由群組連接器來傳送之通訊群組清單 (DL) 的 DN。

如果 Exchange Server Analyzer 發現有路由群組連接器，根據通訊群組成員來設定傳遞限制，則 Exchange Server Analyzer 會查詢偵測到之路由群組連接器的 msExchSourceBridgeheadServersDN 屬性，以判定正在分析的伺服器是否已設定為那些連接器中任一個的 Bridgehead 伺服器。

最後，Exchange Server Analyzer 會讀取下列登錄機碼，以判定 CheckConnectorRestrictions 登錄值是否存在且已設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • 路由群組連接器是用來根據通訊群組成員來限制傳遞。

  • 正在分析的 Exchange 伺服器會被指定為該路由群組連接器的 Bridgehead 伺服器，並利用通訊群組擴充來進行作業。

  • CheckConnectorRestrictions 機碼已存在並設定為 1，因此已啟用。

分類程式的預設行為是：以遞迴方式展開通訊群組，並對每一封通過系統的郵件執行限制檢查。

當您建立路由群組時，請指定彼此可以直接通訊的伺服器群組。若要使不同路由群組中的伺服器可以彼此通訊，您必須連接這些路由群組。

偏好的連線方法就是路由群組連接器，因為此連接器是特別設計作為連接路由群組之用。

可以透過路由群組連接器來傳送郵件的伺服器都是 Bridgehead 伺服器。Bridgehead 伺服器是簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器與負責透過連接器來傳遞所有郵件之 Exchange 伺服器的組合。

建立路由群組連接器時，可以選擇將所有伺服器保留為該連接器的 Bridgehead 伺服器，否則指定只有選取的伺服器組可充當該連接器的 Bridgehead 伺服器。指定的 Bridgehead 伺服器是利用擴充通訊群組成員來進行作業的伺服器。

當您使用根據通訊群組成員來設定傳遞限制的路由群組連接器來傳送郵件時，郵件分類程式必須展開通訊群組的成員，並取得成員 DN 的完整清單，然後以該 DN 清單與寄件者 DN 清單進行比較。兩份清單的 DN 相符時，便會執行存取作業或拒絕作業。如果通訊群組是其他通訊群組中的巢狀通訊群組，則系統也會展開該巢狀通訊群組。

此警告指出根據通訊群組成員設定的傳遞限制，可能會造成傳送至 Bridgehead 伺服器的郵件，於分類程式檢查限制時的放入佇列。

若要更正此警告：

  • 參考 Microsoft 知識庫文章 329171＜XADM：若設定的收件者已根據群組成員設定傳遞限制，則郵件傳遞的速度會變慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)，將路由群組連接器設定為本機路由群組。

  • 使用固定且更穩固的通用類別目錄伺服器作為連接器指定的 Bridgehead 伺服器。

  • 請參考 Microsoft 知識庫文章 812298＜根據通訊群組清單設定傳遞限制後，郵件傳遞的速度緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)，針對個別信箱而非通訊群組設定傳遞限制。

  • 考慮執行 SMTP 寄件者篩選。

  • 對於執行 Microsoft Exchange Server 2003 Service Pack 2 (SP2) 或更新版本的伺服器，請考慮執行非階層式限制檢查。對於執行比 Exchange 2003 SP2 更舊之 Exchange 版本的伺服器，請考慮升級至 Exchange 2003 SP2。

詳細資訊

如需非階層式限制檢查的詳細資訊，請參閱考慮檢查非階層式限制。

如需 SMTP 寄件者篩選的詳細資訊，請參閱《Exchange Server 2003 系統管理手冊》中的＜如何啟用寄件者篩選＞(英文) (http://go.microsoft.com/fwlink/?LinkId=71832)。

如需通訊群組限制對 Exchange 郵件流程之影響的詳細資訊，請參閱下列 Microsoft 知識庫文章：

  • 329171＜XADM：若設定的收件者已根據群組成員設定傳遞限制，則郵件傳遞的速度會變慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)。

  • 895407＜在 Exchange Server 2003 中根據通訊群組設定傳遞限制後，將郵件傳遞到本機信箱及外部信箱的速度比預期慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 839949＜針對 Exchange 2000 Server 與 Exchange Server 2003 中的郵件傳輸與通訊群組進行疑難排解＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。


針對 SMTP 連接器用以檢查通訊群組傳遞限制的 Bridgehead 伺服器
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-08-21

Microsoft® Exchange Server Analyzer 工具會查詢在 Active Directory® 目錄服務中偵測到的每一個簡易郵件傳送通訊協定 (SMTP) 連接器物件 (msExchRoutingSMTPConnector)，以判定是否根據通訊群組成員來設定傳遞限制。

dLMemRejectPerms | 包含可能未透過此 SMTP 連接器將成員傳送至其中之通訊群組清單 (DL) 的網域名稱 (DN)。
dLMemSubmitPerms | 包含其成員可能透過此 SMTP 連接器來傳送之通訊群組清單 (DL) 的 DN。

如果 Exchange Server Analyzer 發現有 SMTP 連接器根據通訊群組成員來設定傳遞限制，則 Exchange Server Analyzer 會查詢偵測到之 SMTP 連接器的 msExchSourceBridgeheadServersDN 屬性，以判定正在分析的伺服器是否已設定為那些連接器中任一個的 Bridgehead 伺服器。

最後，Exchange Server Analyzer 會讀取下列登錄機碼，以判定 CheckConnectorRestrictions 登錄值是否存在且已設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • SMTP 連接器是用來根據通訊群組成員限制傳遞。

  • 正在分析的 Exchange 伺服器會被指定為該 SMTP 連接器的 Bridgehead 伺服器，並利用通訊群組擴充來進行作業。

  • CheckConnectorRestrictions 機碼已存在並設定為 1，因此已啟用。

分類程式的預設行為是：以遞迴方式展開通訊群組，並對每一封通過系統的郵件執行限制檢查。

當您使用接受或拒絕來自通訊群組之郵件的連接器來傳送郵件時，郵件分類程式必須展開通訊群組的成員，並取得成員 DN 的完整清單，然後以該 DN 清單與寄件者 DN 清單進行比較。兩份清單的 DN 相符時，便會執行存取作業或拒絕作業。如果通訊群組是其他通訊群組中的巢狀通訊群組，則系統也會展開該巢狀通訊群組。

指定的 Bridgehead 伺服器是利用擴充通訊群組成員來進行作業的伺服器。

限制檢查是由 CheckConnectorRestrictions 登錄值控制，而該登錄值必須在 Exchange Bridgehead 伺服器 (即所檢查的連接器的來源) 上設定。如果指定限制，但未建立 CheckConnectorRestrictions 登錄值，則不會檢查該限制。

連接器限制檢查預設會關閉。如果展開通訊群組，並對每一封通過系統的郵件檢查限制，將大大地影響系統效能。

此警告指出根據通訊群組成員設定的傳遞限制，可能會造成傳送至 Bridgehead 伺服器的郵件，於分類程式檢查限制時的放入佇列。

若要更正此警告：

  • 參考 Microsoft 知識庫文章 329171＜XADM：若設定的收件者已根據群組成員設定傳遞限制，則郵件傳遞的速度會變慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)，針對連接器限制設計專用的路由群組，並將之設定為本機路由群組。

  • 使用固定且更穩固的通用類別目錄伺服器作為連接器指定的 Bridgehead 伺服器。

  • 參考 Microsoft 知識庫文章 812298＜根據通訊群組清單設定傳遞限制後，郵件傳遞的速度緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)，針對個別信箱而非通訊群組設定傳遞限制。

  • 考慮執行 SMTP 寄件者篩選。

  • 對於執行 Microsoft Exchange Server 2003 Service Pack 2 (SP2) 或更新版本的伺服器，請考慮執行非階層式限制檢查。對於執行比 Exchange 2003 SP2 更舊之 Exchange 版本的伺服器，請考慮升級至 Exchange 2003 SP2。

詳細資訊

如需非階層式限制檢查的詳細資訊，請參閱考慮檢查非階層式限制。

如需 SMTP 寄件者篩選的詳細資訊，請參閱《Exchange Server 2003 系統管理手冊》中的＜如何啟用寄件者篩選＞(英文) (http://go.microsoft.com/fwlink/?LinkId=71832)。

如需通訊群組限制對 Exchange 郵件流程之影響的詳細資訊，請參閱下列 Microsoft 知識庫文章：

  • 329171＜XADM：若設定的收件者已根據群組資格設定傳遞限制，則郵件傳遞的速度會變慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)。

  • 895407＜在 Exchange Server 2003 中根據通訊群組設定傳遞限制後，將郵件傳遞到本機信箱及外部信箱的速度比預期慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 839949＜針對 Exchange 2000 Server 與 Exchange Server 2003 中的郵件傳輸與通訊群組進行疑難排解＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。


無法連線至通訊埠 25 上的路由主機
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-08-24

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定目前系統管理群組中，每個路由群組的 msExchRoutingMasterDN 屬性值。然後，Exchange Server Analyzer 會嘗試在 TCP 通訊埠 25 上開啟路由主機的通訊端連線。如果 Exchange Server Analyzer 沒有接收到預期的自訂回應 25 Available，則會顯示錯誤。

此錯誤表示無法透過 TCP 通訊埠 25 存取路由主機，路由可能會因此而失敗。若要更正此錯誤，您可以疑難排解路由主機的連線問題，或指派新的路由主機。

若要疑難排解路由主機的連線問題

  1. 可以從路由主機 Telnet 到通訊埠 25 嗎？如果不行，則問題不在網路。

  2. 是否已插入每個物件？所有的硬體都能正確運作嗎？

  3. DNS 是否在運作中並且已正確地設定？

  4. 路由器是否運作正常？

  5. 是否有防火牆或應用程式阻止您連線？
指派新的路由主機

  1. 開啟 [Exchange 系統管理員]

  2. 在左窗格 (該處的「組織名稱」就是您針對 Exchange 2000 組織的所選取的名稱) 中樹狀目錄最頂層的 [組織名稱 (Exchange)] 圖示上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 按一下 [顯示系統管理群組]，並按一下 [顯示路由群組]，然後按一下 [確定]。

  4. 依序展開 [系統管理群組]、<系統管理群組>、[路由群組]。

  5. 展開路由群組，然後按一下 [成員]。

  6. 在右窗格中，以滑鼠右鍵按一下要設定為主要路由群組的 Exchange 電腦，再按一下 [設定為主要]。

若需有關疑難排解路由、設定路由拓撲及進階路由概念的詳細資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》(http://go.microsoft.com/fwlink/?LinkId=47579) 中的＜疑難排解路由＞(英文)。


無法連線至通訊埠 691 上的路由主機
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-08-24

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定目前系統管理群組中，每個路由群組的 msExchRoutingMasterDN 屬性值。然後，Exchange Server Analyzer 會嘗試在 TCP 通訊埠 691 上開啟路由主機的通訊端連線。如果 Exchange Server Analyzer 沒有接收到預期的自訂回應 691 Available，則會顯示錯誤。

此錯誤指出無法在 TCP 通訊埠 691 上存取路由主機，因此可能會發生路由失敗。若要更正此錯誤，您可以疑難排解路由主機的連線問題，或指派新的路由主機。

若要疑難排解路由主機的連線問題

  1. 可以從路由主機本身 Telent 到通訊埠 691 嗎？如果不行，則問題不在網路。

  2. 是否已插入每個物件？所有的硬體都能正確運作嗎？

  3. DNS 是否在運作中並且已正確地設定？

  4. 路由器是否運作正常？

  5. 是否有防火牆阻止您連線？
指派新的路由主機

  1. 開啟 [Exchange 系統管理員]

  2. 在左窗格 (該處的「組織名稱」就是您針對 Exchange 2000 組織的所選取的名稱) 中樹狀目錄最頂層的 [組織名稱 (Exchange)] 圖示上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 按一下 [顯示系統管理群組]，並按一下 [顯示路由群組]，然後按一下 [確定]。

  4. 依次展開 [系統管理群組] 及 <AdministrativeGroup>，然後展開 [路由群組]。

  5. 展開路由群組，然後按一下 [成員]。

  6. 在右窗格中，以滑鼠右鍵按一下要設定為主要路由群組的 Exchange 電腦，再按一下 [設定為主要]。

若需有關疑難排解路由、設定路由拓撲及進階路由概念的詳細資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》(http://go.microsoft.com/fwlink/?LinkId=47579) 中的＜路由疑難排解＞(英文)。


找不到主機或 'MX' 記錄
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-05-10

Microsoft Exchange Analyzer 工具會執行網域名稱系統 (DNS) 查詢，以擷取網域的郵件交換者 (MX) 記錄。如果 Exchange Analyzer 工具無法從 DNS 伺服器擷取網域的 MX 記錄，則 Exchange Analyzer 會嘗試執行 DNS 查閱，以擷取 Exchange 伺服器正在對其傳送郵件之網域的主機 (A) 記錄。

若下列條件為真，Exchange Analyzer 就會顯示錯誤：

  • Exchange Analyzer 無法擷取網域的 MX 記錄。

  • DNS 查閱作業無法傳回任何一個主機 (A) 記錄的 IP 位址。

此錯誤表示網域和伺服器的 DNS 郵件交換者 (MX) 和主機 (A) 記錄似乎已遺失。此錯誤可能導致要送至遠端網域的郵件，累積在 Exchange 伺服器的「遠端傳遞」佇列中，此外還會有其他路由或服務延遲。

若要判定郵件主機，傳送的 Exchange 伺服器會檢查是否有 MX 記錄。接著，傳送伺服器會檢查位址記錄 (A 記錄)，來將 MX 記錄解析成 IP 位址。

無法對 Mail Exchanger (MX) 及主機 (A) 記錄進行 DNS 查閱，可能的原因如下：

  • DNS 伺服器由於網路錯誤或其他原因而關閉或無法存取。

  • 由於無法使用記錄或是記錄不正確，DNS 伺服器上遺失遠端伺服器的主機 (A) 記錄。

  • 未將 DNS 伺服器設定成允許動態主機記錄更新。

  • 系統正嘗試傳送未傳遞回報 (NDR)，以回應可能偽裝原始網域的垃圾郵件。若是如此，您應該刪除那些郵件。請參閱本文章＜詳細資訊＞段落中 Exchange Server 錯誤郵件刪除與封存工具的連結。

驗證 DNS 伺服器在線上且 MX 及主機記錄存在

  1. 執行下列一或多項檢查，驗證 DNS 伺服器正在執行中：

    • 在 DNS 伺服器上從 DNS 系統管理程式查看 DNS 伺服器狀態。

    • 重新啟動 DNS 伺服器。如需相關資訊，請參閱＜啟動、停止、暫停或重新啟動 DNS 伺服器＞(英文) (http://go.microsoft.com/fwlink/?LinkId=62999)。

    • 使用 nslookup 命令來驗證 DNS 伺服器回應。如需相關資訊，請參閱＜使用 nslookup 命令驗證 DNS 伺服器回應＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63000) 中的指示。

  2. 使用 nslookup 驗證郵件交換者 (MX) 記錄設定正確。如需相關資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》中＜驗證 DNS 設計及組態＞一節的＜如何使用 Nslookup 來驗證 MX 記錄組態＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  3. 使用 nslookup 驗證 DNS 伺服器上有主機 (A) 記錄存在。如需相關資訊，請參閱＜驗證 DNS 中有 A 資源記錄存在＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63001)。

  4. 如果主機 (A) 資源記錄不存在，請手動新增或修改 A 資源記錄，或設定 DNS 伺服器以啟用動態記錄更新：

    • 手動新增 A 資源記錄。如需相關資訊，請參閱＜新增資源記錄至 DNS 區域＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63002)。

    • 手動修改 A 資源記錄。請參閱＜修改現有的資源記錄＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63014)。

    • 將 DNS 伺服器設定成啟用動態主機記錄更新。如需相關資訊，請參閱 Microsoft 知識庫文章 816592＜如何在 Windows Server 2003 中設定 DNS 動態更新＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592)。

詳細資訊

  • 如需 Exchange Server 2003 如何使用 DNS 來解析外部 IP 位址的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中的＜Exchange Server 2003 的傳輸依存關係＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • 如需 DNS 名稱解析的相關資訊，請參閱 Microsoft 知識庫文章 322856＜HOW TO：設定 Exchange Server 所需的 DNS＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)。

  • 如需 DNS 疑難排解的相關資訊，請參閱＜DNS 的疑難排解＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63003)。

  • 若需 Exchange Server 2003 系統監視的相關資訊，請參閱 Exchange Server 2003 Management Pack for MOM 2005 (http://go.microsoft.com/fwlink/?LinkId=47573) 中的＜使用 Exchange 管理組件的系統監視＞(英文)。

  • 如需主機 (A) 資源記錄的相關資訊，請參閱＜管理資源記錄＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63004)。

  • 如需 Exchange Server 錯誤郵件刪除與封存的相關資訊，請參閱＜Exchange Server 錯誤郵件刪除與封存＞(英文) (http://go.microsoft.com/fwlink/?LinkId=84239)。


無法識別寄件者
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-08-08

Microsoft® Exchange Server Analyzer 工具會查詢所有使用者物件的 Active Directory® 目錄服務 proxyAddress 屬性值，以判定是否具有符合使用者指定的本機寄件者簡易郵件傳送通訊協定 (SMTP) 位址。

如果 Exchange Server Analyzer 找不到使用者指定的本機寄件者 SMTP 位址的 proxyAddress 相符者，則 Exchange Server Analyzer 會顯示錯誤。

此錯誤指出下列其中一個條件為真：

  • 本機寄件者不存在於本機 Exchange Server 組織中。

  • 未正確地輸入使用者指定的本機寄件者 SMTP 位址。

若要解決此錯誤，請驗證指定的本機寄件者的 SMTP 位址，然後重試作業。

驗證本機寄件者的位址

  1. 啟動 Exchange 系統管理員。

  2. 展開 [收件者]，再展開 [所有全域通訊清單]。

  3. 在 [預設全域通訊清單] 上按一下滑鼠右鍵，然後選取 [內容]。

  4. 按一下 [預覽]，以顯示預設全域通訊清單中所包括之收件者的 SMTP 位址。

  5. 驗證是否顯示指定的本機寄件者並記下 SMTP 位址。


已安裝 CatDbgSink 事件接收器
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取在 Internet Information Services (IIS) Metabase 的 LM/SmtpSvc/%SMTPINSTANCE%/EventManager/EventTypes 屬性中找到的資料，以判定將 CatDbgSink 郵件流程診斷應用程式安裝在執行 Exchange 2000 Server 還是執行 Exchange Server 2003 的電腦上。

CatDbgSink 應用程式是事件接收器，可用於疑難排解執行 Exchange 2000 Server 或 Exchange Server 2003 之電腦上的郵件流程問題。如果將 CatDbgSink 應用程式安裝在 Exchange 伺服器上，則 Exchange Server Analyzer 會顯示一則警告，說明已安裝 CatDbgSink 應用程式，並且只應在您疑難排解郵件流程問題時才使用該應用程式。

通常會將 CatDbgSink 應用程式傳送給客戶，以便疑難排解 Exchange 2000 Server 及 Exchange Server 2003 電腦上的郵件流程問題。CatDbgSink 應用程式一般是在 Microsoft 產品支援服務 (PSS) 的指導下安裝。安裝 CatDbgSink 應用程式並順利註冊後，客戶可以使用 CatDbgSink 應用程式建立記錄檔，以收集有關 Exchange 伺服器上郵件流程問題的疑難排解資訊。

有時，在您已隔離並解決問題之後，無法從生產 Exchange 伺服器移除 CatDbgSink 應用程式。如果無法從 Exchange 電腦移除 CatDbgSink 應用程式，則 CatDbgSink 應用程式會造成大量負載，從而導致 Exchange 伺服器上發生您不想要的效能問題。在您診斷生產 Exchange 伺服器上的郵件流程問題之後，必須移除 CatDbgSink 應用程式。

若要更正此警告

  1. 找到本機 CatDbgSink 安裝資料夾。此資料夾包含下列安裝檔：Setup.vbs、CatDbgSink.dll、CatDbgSink.pdb 及 MustReadMe.txt。

  2. 從 [命令提示字元] 視窗，將目錄變更為安裝檔的本機磁碟機位置，例如：C:\CatDbgSink。

  3. 在命令提示字元中，鍵入 cscript setup.vbs uninstall 1

附註：
命令列中的數字 1 指定 SMTP 虛擬伺服器執行個體，從 1 開始。

若需有關 CatDbgSink 應用程式的詳細資訊，請連絡 Microsoft 產品支援服務 (http://support.microsoft.com/default.aspx?pr=cntactms)。


已停用 SMTP 執行個體的分類程式
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取位於 Internet Information Services (IIS) Metabase 中 LM/SmtpSvc/%SMTPInstance%/RoutingSources 內容中的資料，來判斷執行 Exchange 2000 Server 或 Exchange Server 2003 之電腦上每個 SMTP 虛擬伺服器執行個體 (VSI) 的郵件分類程式狀態。

Exchange Server Analyzer 會判斷 IIS Metabase 中是否存在 SMTPDSUseCat 機碼，然後報告所得結果。如果 Exchange Server Analyzer 發現 SMTPDSUseCat 存在並設為停用 (0X000000)，就會顯示一則錯誤。如果郵件分類程式已停用，則 Exchange 伺服器會經歷嚴重的郵件流程問題。

在預設的情況下，在執行 Microsoft Windows® 2000 Server 或 Microsoft Windows Server™ 2003 的電腦上安裝 SMTP 服務時，會在 IIS Metabase 中建立 SMTPDSUseCat 機碼。在預設的情況下，會停用 SMTPDSUseCat 機碼 (0)。安裝 Exchange Server 時，會移除 SMTPDSUseCat IIS Metabase 機碼。此舉會啟用郵件分類程式。在執行 Windows 2000 Server 或 Windows Server 2003 的電腦上安裝 SMTP 服務或 Exchange Server 時，會建立預設 (1) STMP VSI。在電腦上已安裝 Exchange Server、但未安裝而是稍候重新安裝 SMTP 服務的情況下，郵件分類程式會變成停用狀態。安裝協力廠商軟體或發生系統管理組態錯誤時，也可能會停用郵件分類程式。

附註：
Exchange 伺服器上的每個 SMTP 虛擬伺服器執行個體都可單獨控制郵件分類程式的狀態。

郵件分類程式會檢查進入每個 SMTP VSI 的每封郵件，並判斷選項。郵件可能會被送到本機儲存庫、透過郵件傳輸代理程式 (MTA) 送到遠端主機，或透過 SMTP 送到遠端主機。郵件分類程式也會控制通訊群組清單 (DL) 展開。郵件分類程式會檢查進入 SMTP 伺服器的郵件，並且判斷應如何處置郵件。郵件分類程式是進階佇列引擎的外掛程式，該引擎會使用 TCP 連接埠 3268 針對通用類別目錄伺服器執行輕量型目錄存取通訊協定 (LDAP) 查詢。郵件分類程式基本上是一個事件接收器的集合，針對通過進階佇列引擎的每一封郵件，執行進階位址解析。

附註：
SMTP 重新安裝工具 (Smtpreinstall.exe) 位於 Exchange 2000 Server SP2 光碟上的 \SUPPORT\UTILS\I386 資料夾中。
若要使用 SMTP 重新安裝工具啟用郵件分類程式

  1. 將 Smtpreinstall.exe 複製到 \Exchsrvr\Bin 資料夾。

  2. 從 \Exchsrvr\Bin 資料夾連按兩下 Smtpreinstall.exe。

  3. 按一下 [Microsoft Exchange SMTP Reinstall] 對話方塊中的 [確定]，以重新啟動 Exchange 伺服器。

如果您必須檢視 IIS Metabase 中的內容，您可藉由在 IIS 4.0/5.0 上安裝 Metaedit 2.2 公用程式或在 IIS 6.0 上安裝 Metabase Explorer 公用程式，來檢視內容。

注意：
建議不要直接編輯 Metabase。

若需有關郵件分類程式或可用 IIS Metabase 公用程式的詳細資訊，請參閱下列微軟知識庫文件：

  • 290290＜XIMS：重新安裝 IIS SMTP 服務之後無法傳送郵件＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=290290)

  • 319885＜XCON：未傳遞在 Exchange 2000 Server Organization 中傳送的郵件＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319885)

  • 231729＜XCON：DSUseCat 機碼與郵件分類程式＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231729)

  • 232068＜FILE：如何下載、安裝及解除安裝 IIS MetaEdit 2.1 公用程式＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=232068)

若要下載 IIS 6.0 Resource Kit 工具，請參閱「Internet Information Services (IIS) 6.0 Resource Kit 工具」(英文) (http://go.microsoft.com/fwlink/?LinkId=33134)


已在過去 24 小時內記錄分類程式警告事件 (ID:6004)
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-10-05

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_NTLogEvent Microsoft Windows® Management Instrumentation (WMI) 類別，以判定過去 24 小時內是否曾記錄 MSExchangeTransport 的「事件 6004」警告。

如果 Exchange Server Analyzer 發現過去 24 小時內有記錄到 MSExchangeTransport 的「事件 6004」警告，Exchange Server Analyzer 便會顯示警告。

此警告指出分類程式在處理郵件時發生錯誤。

郵件分類程式會檢查進入簡易郵件傳送通訊協定 (SMTP) 伺服器的郵件，並且判斷應如何處置郵件。郵件可能會被送到本機資訊儲存庫、使用郵件傳輸代理程式 (MTA) 送到遠端主機，或使用 SMTP 送到遠端主機。分類程式也會控制通訊群組清單展開。分類程式是進階佇列引擎的外掛程式，該引擎會用 TCP 連接埠 3268 針對通用類別目錄伺服器執行輕量型目錄存取通訊協定 (LDAP) 查詢。分類程式基本上是一個事件接收器的集合，針對通過進階佇列引擎的每一封郵件，執行進階位址解析。分類程式會執行位址解析和郵件轉寄、設定內容轉換標幟、展開通訊群組清單、實施通用設定，以及產生傳遞狀態通知。分類程式也會偵測替代的收件者路由並執行複本發送、日誌記錄，以及許多其他功能。

郵件一進入郵件分類程式時，分類程式就會在 Active Directory® 目錄服務中的 Proxy 位址屬性中搜尋該位址，來解析信封寄件者。分類程式也會在 Active Directory 中的 Proxy 位址屬性搜尋每一個位址，來解析信封收件者。例如，如果清單中包含一個通訊群組清單，並且如果該伺服器容許展開通訊群組清單，則分類程式會展開該清單，使其包括那些成員。

Possible causes of MSExchangeTransport 警告事件 6004 包括下列情況：

  • 目錄服務存取 (DSAccess) 問題。

  • 目錄複寫延遲或失敗。

  • 多載的通用類別目錄伺服器

  • DNS 問題。

若要更正此警告：

  • 請確認 Exchange Server 可連接至一或多個通用目錄伺服器。Windows 中的 [網路監視器] 工具對於這點相當有用。

  • 檢查任何產生的傳遞狀態通知 (DSN) 郵件。DSN 可以包括未傳遞回報 (NDR)。DSN 可描述永久失敗的郵件，以及經常以永久傳遞之錯誤結束的暫時性失敗的郵件。

  • 請使用 [郵件追蹤] 以疑難排解停駐在分類程式中的郵件。

  • 使用 Archive Sink 工具，以封存並分析進入及離開 Exchange Server 的郵件。

  • 使用 [系統監視器]，監視分類程式的效能計數器。

若需 Exchange Server 2003 事件和錯誤的相關資訊，請參閱＜事件和錯誤訊息中心＞(英文) (http://go.microsoft.com/fwlink/?LinkId=34258)。

若需有關 Exchange Server 及 Microsoft Windows Small Business Server 產生之 DSN 與 NDR 的詳細資訊，請參閱微軟知識庫文件 - 284204＜Exchange 2000 Server 及 Small Business Server 的傳遞狀態通知＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204)。

若需如何在 Exchange Server 使用郵件追蹤中心的相關資訊，請參閱下列 Microsoft 知識庫文章：

  • 262162＜XADM：使用「郵件追蹤中心」來追蹤訊息＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)。

  • 246856＜XADM：如何在 Exchange 2000 Server 及 Exchange Server 2003 啟用郵件追蹤＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)。

  • 821905＜Exchange Server 2003 中的郵件追蹤事件識別碼＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)。

  • 823864＜Exchange Server 2003 中改良的郵件追蹤功能＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)。

若需有關如何疑難排解郵件分類程式問題的詳細資訊，請參閱 Microsoft Support WebCast＜Exchange 2000 Server：郵件分類程式及 NDR 疑難排解＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)。

若需有關 Archive Sink 工具的詳細資訊，請參閱微軟知識庫文件 - 307798＜Service Pack 2 提供 Archive Sink 公用程式＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)。

若需如何疑難排解傳輸相關問題的一般資訊，請參閱下列 Microsoft 知識庫文章及資源：

  • 821910＜如何疑難排解 Exchange Server 2003 傳輸問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265＜Exchange 2000 Server 及 Exchange Server 2003 傳輸問題的一般疑難排解＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)。

  • 895853＜如何疑難排解 Exchange Server 2003 和 Exchange 2000 Server 中的郵件轉送問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853)。

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(英文) (http://go.microsoft.com/fwlink/?LinkID=67875)。

郵件分類程式的效能計數器，會針對每一個 SMTP 虛擬伺服器執行個體分別公布。若需與郵件分類程式相關的可用效能計數器清單，請參閱微軟知識庫文件 - 231734＜XCON：郵件分類程式的效能監視計數器＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)。


已在過去 24 小時內記錄分類程式警告事件 (ID:6006)
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-10-06

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_NTLogEvent Microsoft Windows® Management Instrumentation (WMI) 類別，以判定過去 24 小時內是否曾記錄 MSExchangeTransport 的「事件 6006」警告。

如果 Exchange Server Analyzer 發現過去 24 小時內有記錄到 MSExchangeTransport 的「事件 6006」警告，Exchange Server Analyzer 便會顯示警告。

此警告指出郵件受陷在郵件分類程式中。

郵件分類程式會檢查進入簡易郵件傳送通訊協定 (SMTP) 伺服器的郵件，並且判斷應如何處置郵件。郵件可能會被送到本機資訊儲存庫、使用郵件傳輸代理程式 (MTA) 送到遠端主機，或使用 SMTP 送到遠端主機。分類程式也會控制通訊群組清單展開。分類程式是進階佇列引擎的外掛程式，該引擎會用 TCP 連接埠 3268 針對通用類別目錄伺服器執行輕量型目錄存取通訊協定 (LDAP) 查詢。分類程式基本上是一個事件接收器的集合，針對通過進階佇列引擎的每一封郵件，執行進階位址解析。分類程式會執行位址解析和郵件轉寄、設定內容轉換標幟、展開通訊群組清單、實施通用設定，以及產生傳遞狀態通知。分類程式也會偵測替代的收件者路由並執行複本發送、日誌記錄，以及許多其他功能。

郵件一進入郵件分類程式時，分類程式就會在 Active Directory® 目錄服務中的 Proxy 位址屬性中搜尋該位址，來解析信封寄件者。分類程式也會在 Active Directory 中的 Proxy 位址屬性搜尋每一個位址，來解析信封收件者。例如，如果清單中包含一個通訊群組清單，並且如果該伺服器容許展開通訊群組清單，則分類程式會展開該清單，使其包括那些成員。

Possible causes of MSExchangeTransport 警告事件 6006 包括下列情況：

  • 防毒軟體過期或設定不正確

  • 通訊群組大量展開。

  • 日誌收件者設定不正確。

  • Active Directory 中的 Exchange 物件權限設定不正確。

若要更正此警告：

  • 確定您已正確設定檔案層級防毒應用程式，以排除特定的 Exchange Server 目錄。若需掃描正在執行 Microsoft Exchange Serve 的伺服器時不應包括的資料夾的描述，請參閱 Microsoft 知識庫文章 823166＜Exchange Server 2003 及防毒軟體的概觀＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)。

  • 確定您執行的是最新版的防毒應用程式軟體。

  • 檢查通訊群組傳遞限制設定並移除不需要的限制。

  • 檢查日誌設定，找出可能不正確的組態。

  • 檢查 Active Directory 中的 Exchange 物件是否有未適當設定的權限。

詳細資訊

如需非階層式限制檢查的詳細資訊，請參閱考慮檢查非階層式限制。

如需通訊群組限制對 Exchange Server 郵件流程之影響的詳細資訊，請參閱下列 Microsoft 知識庫文章：

  • 895407＜在 Exchange Server 2003 中根據通訊群組設定傳遞限制後，將郵件傳遞到本機信箱及外部信箱的速度比預期慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 839949＜針對 Exchange 2000 Server 與 Exchange Server 2003 中的郵件傳輸與通訊群組進行疑難排解＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。

  • 812298＜根據通訊群組清單設定傳遞限制後，郵件傳遞的速度緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。

若需部署日誌解決方案的相關資訊，請參閱《Exchange Server 日誌》(英文) (http://go.microsoft.com/fwlink/?LinkId=47581)。

若需有關分類程式警告事件識別碼 6006 可能原因的詳細資訊，請參閱 Microsoft 知識庫文章 922256＜電子郵件留在 Exchange Server 2003 組織中的「等待中目錄查閱」佇列＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=922256)。

若需 Exchange Server 2003 事件和錯誤的相關資訊，請參閱＜事件和錯誤訊息中心＞(英文) (http://go.microsoft.com/fwlink/?LinkId=34258)。

若需有關 Exchange Server 及 Microsoft Windows Small Business Server 產生之 DSN 與 NDR 的詳細資訊，請參閱微軟知識庫文件 - 284204＜Exchange 2000 Server 及 Small Business Server 的傳遞狀態通知＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204)。

若需有關如何疑難排解郵件分類程式問題的詳細資訊，請參閱 Microsoft Support WebCast＜Exchange 2000 Server：郵件分類程式及 NDR 疑難排解＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)。

若需如何疑難排解傳輸相關問題的一般資訊，請參閱下列 Microsoft 知識庫文章及資源：

  • 821910＜如何疑難排解 Exchange Server 2003 傳輸問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)。

  • 257265＜Exchange 2000 Server 及 Exchange Server 2003 傳輸問題的一般疑難排解＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)。

  • 895853＜如何疑難排解 Exchange Server 2003 和 Exchange 2000 Server 中的郵件轉送問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853)。

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(英文) (http://go.microsoft.com/fwlink/?LinkID=67875)。

郵件分類程式的效能計數器，會針對每一個 SMTP 虛擬伺服器執行個體分別公布。若需與郵件分類程式相關的可用效能計數器清單，請參閱微軟知識庫文件 - 231734＜XCON：郵件分類程式的效能監視計數器＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)。


已在過去 24 小時內記錄分類程式警告事件 (ID:6008)
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-10-06

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_NTLogEvent Microsoft Windows® Management Instrumentation (WMI) 類別，以判定過去 24 小時內是否曾記錄 MSExchangeTransport 的「事件 6008」警告。

如果 Exchange Server Analyzer 發現過去 24 小時內有記錄到 MSExchangeTransport 的「事件 6008」警告，Exchange Server Analyzer 便會顯示警告。

此警告指出分類程式在處理郵件時發生錯誤。

郵件分類程式會檢查進入簡易郵件傳送通訊協定 (SMTP) 伺服器的郵件，並且判斷應如何處置郵件。郵件可能會被送到本機資訊儲存庫、使用郵件傳輸代理程式 (MTA) 送到遠端主機，或使用 SMTP 送到遠端主機。分類程式也會控制通訊群組清單展開。分類程式是進階佇列引擎的外掛程式，該引擎會用 TCP 連接埠 3268 針對通用類別目錄伺服器執行輕量型目錄存取通訊協定 (LDAP) 查詢。分類程式基本上是一個事件接收器的集合，針對通過進階佇列引擎的每一封郵件，執行進階位址解析。分類程式會執行位址解析和郵件轉寄、設定內容轉換標幟、展開通訊群組清單、實施通用設定，以及產生傳遞狀態通知。分類程式也會偵測替代的收件者路由並執行複本發送、日誌記錄，以及許多其他功能。

郵件一進入郵件分類程式時，分類程式就會在 Active Directory® 目錄服務中的 Proxy 位址屬性中搜尋該位址，來解析信封寄件者。分類程式也會在 Active Directory 中的 Proxy 位址屬性搜尋每一個位址，來解析信封收件者。例如，如果清單中包含一個通訊群組清單，並且如果該伺服器容許展開通訊群組清單，則分類程式會展開該清單，使其包括那些成員。

Possible causes of MSExchangeTransport 警告事件 6008 包括下列情況：

  • 目錄服務存取 (DSAccess) 問題。

  • 目錄複寫延遲或失敗。

  • 多載的通用類別目錄伺服器。

  • DNS 問題。

  • 過多的通訊群組展開。

若要更正此警告：

  • 請確認 Exchange Server 可連至一或多個通用目錄伺服器。Windows 中的 [網路監視器] 工具對於這點相當有用。

  • 請檢驗任何產生的傳遞狀態通知 (DSN) 郵件。DSN 可以包括未傳遞回報 (NDR)。DSN 可描述永久失敗的郵件，以及經常以永久傳遞之錯誤結束的暫時性失敗的郵件。

  • 請使用 [郵件追蹤] 以疑難排解停駐在分類程式中的郵件。

  • 使用 Archive Sink 工具，以封存並分析進入及離開 Exchange Server 的郵件。

  • 使用 [系統監視器]，監視分類程式的效能計數器。

  • 檢查通訊群組傳遞限制設定並移除不需要的限制。

若需 Exchange Server 2003 事件和錯誤的相關資訊，請參閱＜事件和錯誤訊息中心＞(英文) (http://go.microsoft.com/fwlink/?LinkId=34258)。

若需有關 Exchange Server 及 Microsoft Windows Small Business Server 產生之 DSN 與 NDR 的詳細資訊，請參閱微軟知識庫文件 - 284204＜Exchange 2000 Server 及 Small Business Server 的傳遞狀態通知＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204)。

若需如何在 Exchange Server 使用郵件追蹤中心的相關資訊，請參閱下列 Microsoft 知識庫文章：

  • 262162＜XADM：使用「郵件追蹤中心」來追蹤訊息＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)。

  • 246856＜XADM：如何在 Exchange 2000 Server 及 Exchange Server 2003 啟用郵件追蹤＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)。

  • 821905＜Exchange Server 2003 中的郵件追蹤事件識別碼＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)。

  • 823864＜Exchange Server 2003 中改良的郵件追蹤功能＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)。

若需有關如何疑難排解郵件分類程式問題的詳細資訊，請參閱 Microsoft Support WebCast＜Exchange 2000 Server：郵件分類程式及 NDR 疑難排解＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)。

若需有關 Archive Sink 工具的詳細資訊，請參閱微軟知識庫文件 - 307798＜Service Pack 2 提供 Archive Sink 公用程式＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)。

如需非階層式限制檢查的詳細資訊，請參閱考慮檢查非階層式限制。

如需通訊群組限制對 Exchange Server 郵件流程之影響的詳細資訊，請參閱下列 Microsoft 知識庫文章：

  • 895407＜在 Exchange Server 2003 中根據通訊群組設定傳遞限制後，將郵件傳遞到本機信箱及外部信箱的速度比預期慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 839949＜針對 Exchange 2000 Server 與 Exchange Server 2003 中的郵件傳輸與通訊群組進行疑難排解＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。

  • 812298＜根據通訊群組清單設定傳遞限制後，郵件傳遞的速度緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。

若需如何疑難排解傳輸相關問題的一般資訊，請參閱下列 Microsoft 知識庫文章及資源：

  • 821910＜如何疑難排解 Exchange Server 2003 傳輸問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265＜Exchange 2000 Server 及 Exchange Server 2003 傳輸問題的一般疑難排解＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)。

  • 895853＜如何疑難排解 Exchange Server 2003 和 Exchange 2000 Server 中的郵件轉送問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853)。

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(英文) (http://go.microsoft.com/fwlink/?LinkID=67875)。

郵件分類程式的效能計數器，會針對每一個 SMTP 虛擬伺服器執行個體分別公布。若需與郵件分類程式相關的可用效能計數器清單，請參閱微軟知識庫文件 - 231734＜XCON：郵件分類程式的效能監視計數器＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)。


已啟用連線篩選
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器物件的 msExchServerBindingsFiltering 內容是否表示已對 SMTP 虛擬伺服器執行個體啟用連線篩選。

Exchange Server Analyzer 也會查詢 Active Directory，以判定 msExchSmtpConnectionRulesPriority、msExchSMTPGlobalIPAcceptList 或 msExchSMTPGlobalIPDenyList 內容是否表示也在通用設定層級啟用了連線篩選。

如果下列條件存在，Exchange Server Analyzer 將會顯示警告訊息：

  • 已在 SMTP 虛擬伺服器中啟用連線篩選。

  • 已在通用設定層級啟用連線篩選。

此警告表示已有效啟用連線篩選。連線篩選通常不是問題。然而，如果您正在進行此特定伺服器的郵件流程問題疑難排解，則可能需要驗證篩選器組態，或暫時停用連線篩選，以判定是否錯誤封鎖了要傳送給有效收件者的郵件。

停用 SMTP 虛擬伺服器上的連線篩選器

  1. 啟動 [Exchange 系統管理員]：按一下 [開始]，依序指向 [所有程式] 及 [Microsoft Exchange]，然後按一下 [系統管理員]。

  2. 在主控台樹狀目錄中，依序展開 [伺服器]、您要的伺服器、[通訊協定]，然後展開 [SMTP]。

  3. 以滑鼠右鍵按一下您要停用篩選器的 SMTP 虛擬伺服器，然後按一下 [內容]。

  4. 在 [<SMTP 虛擬伺服器> 內容] 的 [一般] 索引標籤上，按一下 [進階]。

  5. 在 [進階] 中，選取您要停用篩選器的 IP 位址，然後按一下 [編輯]。

  6. 在 [識別] 中，清除 [套用連線篩選器] 核取方塊以停用篩選器。

  7. 如果您有多個虛擬伺服器，請針對每個要停用篩選器的虛擬伺服器，重複步驟 3 到 6。

如需如何設定連線篩選器的相關資訊，請參閱 Microsoft Knowledge Base 823866＜如何在 Exchange 2003 中使用即時封鎖清單 (RBL) 設定連線篩選和設定收件者篩選＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823866)。

如需智慧型郵件篩選的相關資訊，請參閱「Exchange 智慧型郵件篩選器」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=21607)。


連接器設定了接受限制
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定路由群組中，每個 SMTP 連接器的 dLMemDefault 屬性值。Exchange Server Analyzer 也會查詢 Active Directory，以判定每個連接器的 authOrig 及 unauthOrig 屬性值。unauthOrig 及 authOrig 屬性包含了帳戶的辨別名稱 (DN) 清單。

根據預設，所有 SMTP 連接器都允許所有使用者透過連接器傳送郵件。當 dLMemDefault 設為預設設定 1 時，除非是列在.unauthOrig 屬性的那些帳戶，否則會接受來自每一個人的郵件。當 dLMemDefault 設為 0 時，除非是列在 authOrig 屬性的那些帳戶，否則會拒絕來自每一個人的郵件。

若下列條件存在，Exchange Server Analyzer 便會顯示非預設的組態訊息：

  • dLMemDefault 屬性值設為 0。

  • authOrig 屬性包含值。

將 Exchange Server Analyzer 所指定的連接器，設定為只接受某些郵件。只有在連接器的 [傳遞限制] 索引標籤上被授與明確權限的帳戶，才能透過連接器傳送郵件。

Exchange Server Analyzer 只會顯示非預設的組態訊息供您參考。

若需有關連接器的詳細資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47579)。


連接器已設定拒絕限制
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定路由群組中，每個 SMTP 連接器的 dLMemDefault 屬性值。Exchange Server Analyzer 也會查詢 Active Directory，以判定每個連接器的 authOrig 及 unauthOrig 屬性值。unauthOrig 及 authOrig 屬性包含了帳戶的辨別名稱 (DN) 清單。

根據預設值，所有 SMTP 連接器都允許所有的使用者透過連接器來傳送郵件。當 dLMemDefault 設為預設設定 1 時，除非是列在 unauthOrig 屬性的那些帳戶，否則會接受來自每一個人的郵件。當 dLMemDefault 設為 0 時，除非是列在 authOrig 屬性的那些帳戶，否則會拒絕來自每一個人的郵件。

若下列條件存在，Exchange Server Analyzer 便會顯示非預設的組態訊息：

  • dLMemDefault 屬性值設為 1。

  • unauthOrig 屬性包含值。

將 Exchange Server Analyzer 所指定的連接器設定為拒絕某些郵件。不允許已明確拒絕連接器 [傳遞限制] 索引標籤權限的帳戶，透過連接器來傳送郵件。

Exchange Server Analyzer 只會顯示非預設的組態訊息供您參考。

若需有關連接器的詳細資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47579)。


連接器依預設拒絕所有郵件
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個連接器的 dLMemDefault 屬性值。dLMemDefault 屬性會控制在預設的情況下是接受還是拒絕郵件。

dLMemDefault 屬性值為 0，表示在預設的情況下會拒絕郵件。dLMemDefault 屬性值為 1，表示在預設的情況下會接受郵件。如果 Exchange Server Analyzer 發現 dLMemDefault 屬性值為 0，就會顯示非預設的組態訊息。

依預設，將 Exchange Server Analyzer 所指定的連接器設定為拒絕所有郵件。只有在連接器的 [傳遞限制] 索引標籤上被授與明確權限的帳戶，才能透過連接器傳送郵件。

Exchange Server Analyzer 只會顯示非預設的組態訊息供您參考。

若需有關連接器的詳細資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47579)。


已啟用連接器限制檢查
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄分支，以判定 CheckConnectorRestrictions 登錄值是否已存在且已設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

如果 Exchange Server Analyzer 發現 CheckConnectorRestrictions 的值存在而且設定為 1，就會顯示一則警告。

如果需要將通訊群組清單型限制套用至連接器，您必須手動啟用這些限制的檢查處理程序。限制檢查是由 CheckConnectorRestrictions 登錄值控制，而該登錄值必須在 Exchange Bridgehead 伺服器 (即所檢查的連接器的來源) 上設定。如果指定限制，但未建立 CheckConnectorRestrictions 登錄值，則不會檢查該限制。

在預設的情況下會關閉連接器限制檢查，因為展開通訊群組及對每一封通過系統的郵件執行限制檢查將會嚴重影響效能。可能的話，請只在需要的地方啟用此設定 (例如，在 Bridgehead 伺服器的受限制連接器上)。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要停用連接器限制檢查

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\Resvc\Parameters

  3. 在右窗格中，尋找 CheckConnectorRestrictions 並刪除它。

  4. 關閉登錄編輯程式，然後重新啟動 Microsoft Exchange Routing Engine 服務及 Simple Mail Transfer Protocol (SMTP) 服務，使變更生效。

若需有關如何編輯登錄的詳細資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關連接器限制檢查登錄值的詳細資訊，請參閱微軟知識庫文件 - 277872＜XCON：Connector Delivery Restrictions May Not Work Correctly＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872)。


連接器的範圍設定為本機路由
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-04-21

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個 SMTP 連接器的 msExchRoutingSMTPConnector 屬性值。如果 Exchange Server Analyzer 發現 msExchRoutingSMTPConnector 屬性值包含字串 "Local:"，就會顯示非預設的組態訊息。如果存在字串 "Local:"，則表示 SMTP 連接器的範圍設定為本機路由。

SMTP 連接器可指定個別的路由來傳送郵件。您可以使用 SMTP 連接器，來建立網際網路郵件的閘道，或連線到特定的網域或郵件系統。連接器可讓您針對指定的郵件路由定義特定的選項。

雖然您可以使用 SMTP 虛擬伺服器來收送網際網路郵件，但許多組織都會設定專用的 SMTP 連接器來路由傳送網際網路郵件。建議您使用 SMTP 連接器，因為它可以為要進入網際網路的郵件提供個別的路由。此外，SMTP 連接器的可用組態選項也比 SMTP 虛擬伺服器來得多。

Exchange Server Analyzer 只會顯示非預設的組態訊息供您參考。

若需有關 SMTP 連接器的詳細資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47579)。


考慮檢查非階層式限制
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定目錄中每個 Exchange Server 物件的 serialNumber 屬性值。如果 Exchange Server Analyzer 發現 Exchange Server 2003 伺服器物件的 serialNumber 屬性值在其字串值中包含 Service Pack 2，就會讀取下列登錄機碼，以判定 CheckConnectorRestrictions 登錄值是否存在且已設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

這種狀況表示伺服器在處理郵件之前，會先檢查傳送及接收限制。

如果 Exchange Server Analyzer 發現 CheckConnectorRestrictions 的值已存在且設為 1,，並因此已啟用，Exchange Server Analyzer 也會讀取 HKLM\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod 登錄機碼，以判定 RestrictionMethod 登錄值是否存在，以及它是如何設定的。

如果 Exchange Server Analyzer 發現 RestrictionMethod 登錄值遺失或已設為 2 以外的值，就會顯示一則最佳作法訊息。

總而言之，若符合下列條件，Exchange Server Analyzer 就會顯示一則最佳作法訊息：

  • Exchange Server 2003 伺服器已安裝 SP2。

  • HKLM\System\CurrentControlSet\Services\Resvc\Parameters 的 CheckConnectorRestrictions 登錄值設定為對本機電腦上連接器使用通訊群組清單型限制。

  • HKLM\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod 的 RestrictionMethod 登錄值遺失或已設為 2 以外的值。

RestrictionMethod 值可決定分類程式將如何處理限制。分類程式的預設行為是：以遞迴方式展開通訊群組，並對每一封通過系統的郵件執行限制檢查。此預設的分類程式行為會嚴重影響效能，因此不是最佳作法。

如果將 RestrictionMethod 的值設為 2，當伺服器檢查限制時，此 Exchange 伺服器上的傳輸元件將不會展開通訊群組的成員。此組態可為限制檢查提供最佳效能。此外，若要讓 RestrictionMethod 登錄項目生效，包含具有傳遞限制之使用者的所有通訊群組必須沒有子群組。也就是說，受限制的通訊群組必須沒有巢狀通訊群組。如果受限制的通訊群組是巢狀的，展開邏輯將不起作用。

針對在連接器限制中使用的通訊群組，建議您在沒有信箱的連接器 Bridgehead 伺服器上設定 RestrictionMethod 登錄項目值。針對 Active Directory 使用者限制，如果受限制的通訊群組具有擴充伺服器，建議您在擴充伺服器上建立 RestrictionMethod 登錄項目。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要建立 RestrictionMethod 登錄項目並將其值設為 2

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

  3. 在左窗格中，按一下 [參數]。

  4. 在 [編輯] 功能表中，指向 [新增]，然後按一下 [DWORD 值]。

  5. 鍵入 RestrictionMethod，然後按 ENTER 鍵，以命名新的登錄項目。

  6. 以滑鼠右鍵按一下 [RestrictionMethod]，再按一下 [修改]。

  7. 鍵入 2，然後按 ENTER 鍵。

  8. 結束登錄編輯程式。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 RestrictionMethod 登錄值的詳細資訊，請參閱微軟知識庫文件 - 895407＜在 Exchange Server 2003 中根據通訊群組設定傳遞限制後，傳遞到本機信箱及外部信箱的郵件速度比預期慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

若需有關登錄值的詳細資訊，請參閱微軟知識庫文件 - 277872＜XCON：Connector Delivery Restrictions May Not Work Correctly＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872)。


ConvertDSNInternetContent 登錄機碼設定為執行所有郵件的內容轉換
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已設定 ConvertDSNInternetContent 登錄值，來對 Exchange Server 2003 電腦上由 Exchange Information Store 所接收的所有郵件執行內容轉換：

HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • 已手動建立 ConvertDSNInternetContent 登錄值。

  • ConvertDSNInternetContent 登錄值資料設為 1。

ConvertDSNInternetContent 登錄值的數值資料為 0 或沒有值時，將停用 Exchange Information Store 對 SMTP 郵件所做的內容轉換。數值資料為 1 會啟用所有郵件的內容轉換，包括所有 SMTP 虛擬伺服器執行個體 (VSI) 或個別 VSI 中的 SMTP 郵件。

在預設的情況下，在 Exchange Server 2003 安裝期間不會建立 ConvertDSNInternetContent 登錄值。在安裝 Exchange Server 之後，可以手動建立 ConvertDSNInternetContent 登錄值，以變更 Exchange Server 2003 電腦的內容轉換行為。一般而言，不得對提交的 SMTP 郵件進行內容轉換。如果啟用所有郵件 (包括 SMTP 郵件) 的內容轉換，就會新增 Exchange 伺服器的處理負荷。此額外處理負荷可能會造成效能及記錄檔儲存問題。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。您必須編輯登錄，以讓 Exchange Server 2003 電腦的內容轉換行為重回最有效的內容轉換方法。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至下列登錄機碼： HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

  3. 在詳細資料窗格中的 ConvertDSNInternetContent 登錄值上按一下滑鼠右鍵、按一下 [修改]，然後將 [數值資料] 變更為 80。 按一下 [確定]。

    附註：
    若要刪除 ConvertDSNInternetContent 登錄值，請在詳細資料窗格中的 ConvertDSNInternetContent 登錄值上按一下滑鼠右鍵，再按 [刪除]。按一下對話方塊中的 [是]，確認刪除登錄值。

  4. 關閉登錄編輯程式。

  5. 重新啟動 Exchange 伺服器。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關編輯 Microsoft Windows 登錄的詳細資訊，請參閱下列微軟知識庫文件：

  • 322755＜HOW TO：備份、編輯和還原 Windows 2000 的登錄＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756＜如何在 Windows XP 和 Windows Server 2003 中備份、編輯及還原登錄＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


已識別為共用目的地的通訊群組
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-10-04

Microsoft® Exchange Server Analyzer 工具會查詢 Exchange_Queue Windows® Management Instrumentation (WMI) 類別，以判定 SMTP 虛擬伺服器的簡易郵件傳送通訊協定 (SMTP) 佇列的下列屬性值。

LinkId | 指出包含佇列的連結的識別碼。
QueueId | 指出佇列的識別碼。
QueueName | 指出佇列的名稱。
VirtualMachine | 指出包含佇列的虛擬機器的名稱。
VirtualServerName | 指出佇列所在的虛擬伺服器的名稱。
MessageCount | 指出佇列中的郵件數目。

Exchange Server Analyzer 會使用這裡取得的資訊，查詢 Exchange_QueuedSMTPMessage WMI 類別，以取得佇列中的郵件的下列屬性值：

Recipients | 指出郵件的收件者。
Received | 指出郵件的接收時間戳記。
MessageId | 指出已佇列郵件的識別碼。
StateRetry | 指出對未順利傳遞的郵件重試傳輸。

最後，Exchange Server Analyzer 會使用這裡取得的資料，查詢 Active Directory® 目錄服務，以取得每一個 Recipient 物件的 distinguishedName 值。然後，Exchange Server Analyzer 會判斷收件者是使用者、通訊群組、公用資料夾或公用資料夾儲存區。

如果 Exchange Server Analyzer 判定至少有百分之 25 留在佇列的郵件是要送給特定通訊群組 (出現在 To: 或 Cc: 欄位中)，Exchange Server Analyzer 會顯示警告。

如果 Exchange Server Analyzer 判定至少有百分之 50 留在佇列的郵件是要送給特定通訊群組 (出現在 To: 或 Cc: 欄位中)，Exchange Server Analyzer 會顯示錯誤。

此警告或錯誤表示所識別的通訊群組是留在 SMTP 佇列的郵件的共同目的地。

若要更正此問題，應該對通訊群組進行如下的調查，找出可能導致郵件置於佇列的組態問題或其他異常狀況：

  • 確定通訊群組物件屬性設定正確，而且在 Active Directory 包含正確值。

  • 檢閱通訊群組物件的 Active Directory 權限，以確定設定正確無誤。

  • 如果通訊群組包含特殊用途的使用者物件，亦即，指定的日誌收件者，請檢閱與使用者物件相關的服務或元件的組態，以確定組態正確無誤。

  • 尋找可能未經同意的廣告郵件 (UCE) 或垃圾郵件，或攻擊通訊群組的病毒。

  • 判定通訊群組的傳遞限制設定是否不正確。

若需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkID=67875)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

如需通訊群組限制對 Exchange Server 郵件流程之影響的詳細資訊，請參閱下列 Microsoft 知識庫文章：

  • 895407＜在 Exchange Server 2003 中根據通訊群組設定傳遞限制後，將郵件傳遞到本機信箱及外部信箱的速度比預期慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 329171＜XADM：若設定的收件者已根據群組成員設定傳遞限制，則郵件傳遞的速度會變慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)。

  • 839949＜針對 Exchange 2000 Server 與 Exchange Server 2003 中的郵件傳輸與通訊群組進行疑難排解＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。

  • 812298＜根據通訊群組清單設定傳遞限制後，郵件傳遞的速度緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。


先前的分類因有可重試的錯誤而失敗
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-09-06

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可於執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上，用來查詢效能計數器物件。效能資料收集引擎會從 SMTP Server 效能物件的 Cat:Categorizations in progress 與 Categorizer Queue length 效能計數器中收集資料，以便分析效能資料。

Cat:Categorizations in progress 效能計數器會顯示正在進行的分類數目，而 Categorizer Queue length 效能計數器則會顯示分類程式佇列中的郵件數目。

針對此查詢，Exchange Server Analyzer 會在兩分鐘內每隔 6 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的平均值。

Exchange Server Analyzer 會檢查進行中分類的平均數目，且會比較該數目與仍在佇列中的分類數目。

如果取樣期間下列條件為 true，則 Exchange Server Analyzer 便會顯示錯誤：

  • 進行中分類的平均數目為零。

  • 平均分類程式佇列長度超過零。

分類程式會執行下列核心作業：

  • 解析及驗證所有收件者。

  • 判定對所有收件者的限制。

  • 展開通訊群組清單 (如果那是必需的)。

  • 判定郵件是本機傳遞還是遠端傳遞。

此錯誤指出卡在分類程式佇列中的郵件因有可重試的錯誤而分類失敗。

通常是因為進階佇列引擎無法將郵件分類，才會使郵件累積在佇列之中。進階佇列引擎可能無法存取通用類別目錄伺服器及存取收件者資訊，或是無法存取通用類別目錄伺服器，或通用類別目錄伺服器效能低落。此外，郵件也可能因為下列原因而累積：

  • 無法使用 Active Directory® 目錄服務。

    附註：
    分類程式使用 Active Directory 來分類郵件。
  • 如果許多郵件佇列在前分類佇列裡，則 Active Directory 可能會負載過重。

  • 發生轉換失敗。分類程式也會控制內容轉換。

  • 郵件分類程式找不到信箱儲存區。

  • 如果重新安裝或移除簡易郵件傳送通訊協定 (SMTP)，這可能會使下列 IIS Metabase 機碼失效：/smtpsvc/DsUseCat 及 /smtpsvc/vsi#/DsUseCat。

    附註：
    判定是否重新安裝或移除了 SMTP。

您可檢查佇列內容，以判定失敗原因。例如，如果佇列內容顯示類似「已發生 SMTP 錯誤」的訊息，則應該檢閱伺服器的事件日誌，找出任何 SMTP 錯誤。如果記錄中沒有事件，則應該增加 SMTP 記錄等級。

若需如何疑難排解 Exchange 與 SMTP 佇列的詳細資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkID=67875)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  • Microsoft 知識庫文章 821877＜SMTP 及 X400 佇列內容索引標籤上的欄位說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821877)。

  • Microsoft 知識庫文章 264054＜XCON：瞭解 Exchange 2000 Server 中的佇列狀態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。

  • 《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

  • 《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

郵件分類程式的效能計數器，會針對每一個 SMTP 虛擬伺服器執行個體分別公布。若需與郵件分類程式相關之可用效能計數器的清單，請參閱微軟知識庫文件 - 231734＜XCON：郵件分類程式的效能監視計數器＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)。


啟用智慧型郵件篩選器自動更新
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-02-13

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定目錄中所有 Exchange Server 物件的 serialNumber 屬性值。serialNumber 屬性是字串值，當中包含 Exchange Server 的版本及 Service Pack 的版本 (如果已安裝)。serialNumber 屬性值若等於 Version 6.5 (Build 7638:Service Pack 2) 表示伺服器正在執行 Exchange Sever 2003 Service Pack 2。

Exchange Server Analyzer 也會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 ClusSvc (叢集服務) 的 Started 機碼值。值為 True 表示叢集服務正在執行，而值為 False 則表示該服務未執行。

Exchange Server Analyzer 也會讀取下列登錄項目，以判定伺服器上是否已安裝並啟用 Microsoft Exchange 智慧型郵件篩選器：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

如果 Exchange Server Analyzer 發現 ContentFilter 登錄機碼中出現 ContentFilterBindings 項目，但是未設定 ContentFilterBindings 值，則它表示未在伺服器上啟用智慧型郵件篩選器。

最後，Exchange Server Analyzer 會查詢下列登錄項目，以判定是否出現 ContentFilterState 子機碼，且在伺服器上啟用智慧型郵件篩選器自動更新：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\

ContentFilterState 子機碼的值若是 1 以外的值，則表示未啟用智慧型郵件篩選器的自動更新。

若下列條件為真，Exchange Server Analyzer 就會顯示最佳作法訊息：

  • 伺服器正在執行 Exchange Server 2003 Service Pack 2

  • Exchange 伺服器未作叢集處理

  • 已啟用智慧型郵件篩選器

  • 未啟用智慧型郵件篩選器的自動更新。

依預設，智慧型郵件篩選器功能會隨著 Exchange Server 2003 SP2 一起安裝。您必須手動啟用智慧型郵件篩選器功能，才能取得這個新郵件篩選技術的好處。在啟用智慧型郵件篩選器功能之後，必須定期更新 .dat 檔及 .dll 檔，篩選器才能保持最新且有效。下節中提到的文章說明讓智慧型郵件篩選器保持最新的更新處理程序。

若需如何啟用智慧型郵件篩選器的自動更新的相關資訊，請參閱微軟知識庫文件 - 907747＜如何更新 Exchange Server 2003 SP2 中的智慧型郵件篩選器第 2 版＞ (英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=907747)。


信封日誌已啟用
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-03-30

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已設定 heuristics 屬性來啟用信封日誌。依預設，未設定 heuristics 屬性。如果 Exchange Server Analyzer 發現 heuristics 屬性設為 512，則會顯示非預設的組態訊息。

信封日誌允許您封存 P1 郵件標頭。P1 郵件標頭是郵件傳輸代理程式 (MTA) 用來傳送郵件的地址資訊。此地址資訊包括實際接收郵件之收件者 (包括密件副本 (Bcc) 收件者及通訊群組收件者) 的相關資訊。信封日誌藉由使用包含日誌報表及原始郵件的信封郵件，以傳遞標幟為要封存的郵件。將原始郵件當成附件來傳遞。日誌報表的本文包含已封存郵件的傳輸信封資料。

若要在指定的伺服器上啟用 Bcc 日誌，您必須先在資料庫層級設定只限郵件的日誌。如果下列情況存在，則 heuristics 屬性不處於作用中：

  • heuristics 屬性設為 512。

  • 未在任何一個資料庫儲存區上啟用只限郵件的日誌。

日誌郵件會消耗許多磁碟、網絡及 CPU 資源。因此，日誌需要周密的部署計劃。應該只在整體日誌方案架構的環境中啟用日誌。

如果存在下列情況，請忽略此非預設的組態訊息：

  • 您的公司需要日誌。

  • 您已部署日誌解決方案架構。

否則，您應關閉日誌功能。

關閉資料庫上只限郵件的日誌

  1. 在 [Exchange 系統管理員] 中，依序展開 [伺服器]、<您的 Exchange 伺服器> 及 <儲存群組>，然後在信箱儲存區上按一下滑鼠右鍵。

  2. 在 [一般] 標籤上，清除核取方塊 [封存由此儲存區的信箱所傳送或接收的所有郵件]。

  3. 等待 15 分鐘以讓 Exchange 儲存區套用變更。您不必重新啟動 Microsoft Exchange Information Store 服務。

如果您不想要 Exchange Server Analyzer 再次顯示此訊息，必須停用 heuristics 屬性。停用日誌功能不需要停用 heuristics 屬性。

您可以使用電子郵件日誌進階組態工具 (Exejcfg.exe) 來停用信封日誌。您可以從具有 Active Directory 存取權的任一伺服器執行工具，但是建議您從網域控制站執行工具。

若要取得電子郵件日誌進階組態工具及文件，請在 http://go.microsoft.com/fwlink/?LinkId=33122 下載工具套件。電子郵件日誌進階組態工具可用於 Exchange 2000 Server 環境及 Exchange 2003 Server 環境。

停用 heuristics 屬性

  1. 下載電子郵件日誌進階組態工具，並將它解壓縮至您所選擇的目錄。

  2. 開啟命令提示字元。

  3. 移至電子郵件日誌進階組態工具的安裝目錄。

  4. 輸入下列命令，以停用信封日誌。

    複製程式碼
    exejcfg -d

若需有關部署日誌解決方案的詳細資訊，請參閱《Exchange Server 2003 日誌功能》(英文) (http://go.microsoft.com/fwlink/?LinkId=47581)。


不支援 ESMTP 動作
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器的每一個執行個體的 msExchSmtpInboundCommandSupportOptions 屬性值是否已設為支援連入連線的預設擴充 SMTP 動詞。

這些擴充 SMTP 動詞列在下表中。如果 Exchange Server Analyzer 發現不支援連入連線的任何一個列出的預設擴充 SMTP 動詞，就會顯示警告。

比起標準 SMTP，Exchange Server 2003 會使用這些 Exchange 特定的擴充 SMTP 動詞，更有效率地與組織中的其他 Exchange 伺服器通訊。這些動詞是以 Metabase 及 Exchange Server 事件接收器來控制。在 Exchange Server 2003 中，DS2MB 處理程序藉由複製 Active Directory 中的值，更新 Metabase 中的值。當停用事件接收器時，可能會阻礙 Exchange Server 效能。

擴充 SMTP 動詞 註解

8BITMIME

表示本機 SMTP 虛擬伺服器支援八位元 MIME 郵件。

BDAT, CHUNKING

DATA 命令的替代命令。此命令採用兩個引數。當 SMTP 虛擬伺服器使用 CHUNKING 回應 EHLO 關鍵字時，SMTP 伺服器在表示它支援 BDAT 命令，而且可接受分成區塊傳送的郵件。

  • 第一個引數表示二進位資料封包的長度。因此 SMTP 主機不必持續地掃描資料尾端。接收伺服器會計算郵件中的位元組。當郵件大小等於 BDAT 命令所傳送的值時，伺服器就會假設它已收到所有郵件資料。

  • 第二個引數表示資料封包是否為目前傳輸中的最後一個封包。第二個引數是選用的引數。

BINARYMIME

表示 SMTP 虛擬伺服器接受使用 MAIL 命令並搭配值為 BINARYMIME 的 BODY 參數所傳送的未經傳輸編碼的二進位資料郵件。當 SMTP 伺服器接受 BODY 參數為 BINARYMIME 的 MAIL 命令時，該伺服器同意保留使用 BDAT 命令所傳遞之每一個八位元中的所有位元。BINARYMIME SMTP 擴充只能與 CHUNKING 一起使用。

DSN

實現 Request for Comments (RFC) 1891 中所定義的傳遞狀態通知的 ESMTP 命令。

ENHANCEDSTATUSCODES

表示 SMTP 伺服器提供增強型錯誤狀態碼。所有 SMTP 狀態回應 (不包括初始問候語及對 HELO 或 EHLO 的任何回應) 的文字部份皆會以 RFC 1893 中定義的狀態碼作為前言。

ETRN

由 SMTP 伺服器傳送，要求本機虛擬伺服器為 ETRN 命令中所指定的網域傳送任何位於佇列的電子郵件。

TURN

允許遠端主機與本機主機互換角色，並以相反方向傳送郵件，而不需建立新的連線。

如需如何還原這些動詞的預設支援的相關資訊，請參閱 Microsoft 知識庫文章 257569＜如何在 Exchange 2000 Server 及 Exchange Server 2003 中關閉 ESMTP 動詞＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569)。


Exchange 伺服器不會宣傳擴充的動作
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會在網際網路資訊服務 (IIS) Metabase 中讀取 SmtpInboundCommandSupportOptions 屬性，以判定是否已設定 Exchange Server 支援擴充的動作。如果 Exchange Server Analyzer 發現 SmtpInboundCommandSupportOptions 設定未設為 7697601，就會顯示警告。

Exchange 2000 Server 及 Exchange Server 2003 均需要擴充的 SMTP 動作。IIS Metabase 中的值必須符合 Active Directory® 目錄服務中設定的值。如果在混合模式環境中執行 Exchange Server，就必須將此值設為 7697601。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
若要還原 SmtpInboundCommandSupportOptions 的預設值

  1. 開啟 [ADSI 編輯器] 並連線到網域控制站。

  2. 開啟 [組態容器]。

  3. 移至下列位置：

    Configuration/Services/Microsoft Exchange/<Your Organization>/Administrative Groups/<Your Administrative Group>/Servers/<Your Exchange Server>/Protocols/SMTP/<Your Virtual Server>。

  4. 在虛擬伺服器物件上按一下滑鼠右鍵，然後按一下 [內容]。

  5. 在 [選取內容來檢視] 中，選取 msExchSmtpInboundCommandsSupportOptions。

  6. 在 [編輯屬性] 中輸入 7697601。

  7. 依序按一下 [設定]、[套用] 及 [確定]。

  8. 關閉 [ADSI 編輯器]。


偵測到凍結的佇列
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-03

Microsoft® Exchange Server Analyzer 工具會查詢 ExchangeLink Microsoft Windows® Management Instrumentation (WMI) 類別，以判定伺服器上簡易郵件傳送通訊協定 (SMTP) 佇列的 StateFrozen 機碼值。

如果 Exchange Server Analyzer 發現 Exchange Server 上有任何一個 SMTP 佇列的 StateFrozen 機碼值設為 True，就會顯示錯誤。

佇列凍結表示該佇列的傳輸工作階段已停止。佇列凍結會導致郵件無法送出，但仍可以新增新的郵件。您可以使用每個連結佇列上的快顯功能表，手動變更連線狀態。使用 [強制連線] 命令將佇列狀態變更為作用中時，會立即啟用從該佇列傳送郵件的連線。

如需受影響之特定 SMTP 佇列與其可能原因的相關資訊，請參閱下列 Exchange Server Analyzer 工具文章：

  • 「正在等候目錄查閱的郵件」佇列已凍結

  • 「正在等候路由傳送的郵件」佇列已凍結

  • 「提交擱置的郵件」佇列已凍結

  • 「本機傳遞」佇列已凍結

  • 「遠端傳遞」佇列已凍結

如需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)

  • Microsoft 知識庫文章 821877＜SMTP 及 X400 佇列內容索引標籤上的欄位說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821877)

  • Microsoft 知識庫文章 264054＜XCON：瞭解 Exchange 2000 Server 中的佇列狀態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


智慧型郵件篩選器有可用的篩選器更新
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 MSExchange.UceContentFilter.dll 是否存在於 Exchange Server 的下列路徑：

<path to Exchange server binary files>\MSCFv2\MSExchange.UceContentFilter.dll

附註：
在此路徑中，<path to Exchange server binary files> 是指 bin 資料夾的位置。

若這個位置上沒有 MSExchange.UceContentFilter.dll，Exchange Server Analyzer 就會顯示最佳作法建議。

建議您在所有安裝有智慧型郵件篩選器的 Exchange Server 上，都安裝 Microsoft Exchange 智慧型郵件篩選器的篩選器更新。智慧型郵件篩選器的篩選器更新，可提供智慧型郵件篩選器最新的「智慧型郵件篩選器 SmartScreen™」篩選器更新。SmartScreen 篩選器的篩選器更新包含了更新的垃圾郵件處理功能，這些功能可讓智慧型郵件篩選器更能夠阻擋來路不明的商業電子郵件，也就是垃圾郵件。

附註：
安裝更新前，您必須先安裝智慧型郵件篩選器。若要安裝智慧型郵件篩選器，請使用具有本機系統管理權限的帳戶，和已套用 Exchange 系統管理員角色的群組成員。

安裝智慧型郵件篩選器後，請執行下列程序以安裝更新。

取得及安裝智慧型郵件篩選器更新

  1. 於 http://go.microsoft.com/fwlink/?LinkId=41026 (英文) 取得 Exchange 智慧型郵件篩選器的最新更新。

  2. 於 http://go.microsoft.com/fwlink/?LinkId=41027 (英文) 檢閱智慧型郵件篩選器更新的版本資訊。

  3. 執行更新套件，並遵循更新套件安裝精靈的指示。

若需詳細資訊，請參閱「Exchange 智慧型郵件篩選器」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=21607)。


已啟用一般限制檢查
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定目錄中每個 Exchange Server 物件的 serialNumber 屬性值。如果 Exchange Server 2003 伺服器物件之 serialNumber 屬性的字串值包含 Service Pack 2，則表示 Exchange 伺服器正在執行 Exchange Server 2003 Service Pack 2 的發行前版本。

Exchange Server Analyzer 也會讀取下列登錄項目，以判定 RestrictionMethod 登錄值是否存在：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

若符合下列條件，Exchange Server Analyzer 就會顯示非預設的組態訊息：

  • 已安裝 Exchange Server 2003 Service Pack 2。

  • RestrictionMethod 登錄值存在且已設為值 2。

此組態表示當伺服器檢查限制時，此 Exchange 伺服器上的傳輸元件將不會展開通訊群組的成員。此組態可為限制檢查提供最佳效能。

如果您確信 RestrictionMethod 登錄值的存在及設定有錯誤，可使用下列程序來還原為預設組態。不過，因為此機碼及 Exchange Server 2003 Service Pack 2 的組合可為檢查限制提供最佳效能，所以建議您保留 RestrictionMethod 登錄值的目前設定。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\

  3. 在右窗格中，以滑鼠右鍵按一下 [RestrictionMethod]，並選取 [刪除]。

  4. 關閉登錄編輯程式，然後重新啟動 IIS 管理及 Microsoft Exchange Routing Engine 服務，使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 RestrictionMethod 登錄值的詳細資訊，請參閱微軟知識庫文件 - 895407＜在 Exchange Server 2003 中根據通訊群組設定傳遞限制後，傳遞到本機信箱及外部信箱的郵件速度比預期慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。


找到主機記錄，但找不到 'MX' 記錄
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會查詢它使用的網域名稱系統 (DNS) 伺服器，看是否有 Exchange 傳送目標遠端網域的郵件交換者 (MX) 記錄。然後 Exchange Server Analyzer 會執行 DNS 查閱，以擷取遠端網域的主機 (A) 記錄。

如果 Exchange Server Analyzer DNS 查閱作業未傳回遠端網域的 MX 記錄，但是隨後可以擷取相同遠端網域的主機 (A) 記錄，Exchange Server Analyzer 就會顯示警告。

在此情況下，Exchange Server 會在擷取 MX 記錄失敗後，嘗試將郵件傳送至主機 (A) 記錄所指向的伺服器。因此那些主機 (A) 記錄必須指向正確的郵件伺服器。

有些網域會將其主機 (A) 記錄設為指向網際網路服務提供者 (ISP)，雖然 ISP 可能具有一些有效的郵件伺服器，但是它們可能不是所需收件者的授權郵件伺服器。在此情況下，將會拒絕郵件。

DNS 伺服器由於網路錯誤或其他原因而關閉或無法存取時，MX 記錄的 DNS 查閱可能會失敗。

驗證 DNS 伺服器在線上且 MX 記錄存在

  1. 執行下列一或多項檢查，驗證 DNS 伺服器正在執行中：

    • 在 DNS 伺服器上從 DNS 系統管理程式查看 DNS 伺服器狀態。

    • 重新啟動 DNS 伺服器。如需相關資訊，請參閱＜啟動、停止、暫停或重新啟動 DNS 伺服器＞(英文) (http://go.microsoft.com/fwlink/?LinkId=62999)。

    • 使用 nslookup 命令來驗證 DNS 伺服器回應。如需相關資訊，請參閱＜使用 nslookup 命令來驗證 DNS 伺服器回應＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63000)。

  2. 使用 nslookup 驗證 MX 記錄設定正確。如需相關資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》中＜驗證 DNS 設計及組態＞一節的＜如何使用 Nslookup 來驗證 MX 記錄組態＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

詳細資訊

  • 如需 Exchange Server 2003 如何使用 DNS 來解析外部 IP 位址的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中的＜Exchange Server 2003 的傳輸依存關係＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • 如需 DNS 名稱解析的相關資訊，請參閱 Microsoft 知識庫文章 322856＜HOW TO：設定 Exchange Server 所需的 DNS＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)。

  • 如需 DNS 疑難排解的相關資訊，請參閱＜DNS 的疑難排解＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63003)。


已手動新增並設定 IIS PoolThreadLimit 登錄值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已修改網際網路資訊服務 (IIS) 集區執行緒數目上限的預設值：

HKEY_LOCAL_MACHINE\ System\CurrentControlSet\Services\Inetinfo\Parameters\PoolThreadLimit

如果 Exchange Server Analyzer 發現 PoolThreadLimit 存在而且是設定為另一個值，就會顯示一則非預設的組態訊息。

PoolThreadLimit 登錄值指定可以在 Inetinfo.exe 處理程序中建立的輸入/輸出 (IO) 背景工作執行緒數目上限，此上限控制可與 IIS 建立同時連線的數目上限。每一個集區執行緒會監看是否有網路要求並處理該要求，處理的方式有傳回靜態檔案，或將該要求傳遞至 ISAPI 擴充程式 DLL (例如 ASP.DLL)，或傳遞至「通用閘道介面 (CGI)」應用程式。如果 ISAPI 擴充程式同步處理某個要求而且處理要求的時間很久，該擴充程式將會佔用背景工作執行緒，只剩下少數幾個執行緒供 IIS 用來處理其他要求。因此，撰寫良好的 ISAPI 擴充程式 (如 ASP) 會執行自己的執行緒集區、將要求放入佇列中，然後使用自己的執行緒來同步處理要求，以免佔用 IIS 背景工作執行緒。

在預設的情況下，IIS 會將 PoolThreadLimit 設定為：

2 * 電腦中的 RAM MB 數

如果此值大於 256，它會被縮減為 256。在預設的情況下，此登錄值不存在。如果此值存在於登錄中，它會覆寫 IIS 的預設計算結果。

通常如果您發現預設的 256 個執行緒數限制不夠用時，可能是有撰寫不良的 ISAPI 擴充程式佔用了 IIS 背景工作執行緒。256 表示有很多執行緒同時在作用中，會給同步處理及內容切換帶來很大的負荷。

PoolThreadLimit 登錄值是包括所有 IIS 背景工作執行緒的硬性限制，這些執行緒包含 HTTP、FTP、NNTP 及 SMTP 服務。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

  3. 檢查、刪除或修改 PoolThreadLimit 值。

  4. 關閉登錄編輯程式，然後重新啟動 IIS Admin 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請閱讀微軟知識庫文件＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)。


內送郵件與外寄郵件的大小限制
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-12-01

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定用於限制外寄郵件大小的屬性 submissionContLength，是否與用於限制內送郵件大小的屬性 delivContLength 不同。若 Exchange Server Analyzer 發現外寄郵件大小限制與內送郵件大小限制不同，便會顯示最佳作法建議訊息。

建議您將外寄郵件大小限制與內送郵件大小限制設為相同的值，以提供一致的郵件限制。

設定 Exchange 2000 Server 及 Exchange Server 2003 的外寄郵件大小限制

  1. 啟動 Exchange 系統管理員。

  2. 在左窗格中，展開 [通用設定]。

  3. 在 [郵件傳遞] 上按一下滑鼠右鍵，再按一下 [內容]。

  4. 在 [預設值] 索引標籤的 [傳送的郵件大小] 下，按一下 [最大值 (KB)]，然後鍵入一個數字。
設定 Exchange Server 2007 的外寄郵件大小限制

  1. 在 Exchange 管理命令介面中，執行下列命令，其中 <size> 會輸入為預設值 (無限制) 或大小 (以 B (位元組)、KB (千位元組) 或 MB (百萬位元組) 為單位)，範圍從 0 到 2147483647 個位元組：
複製程式碼
Set-TransportConfig -MaxSendSize <size>

例如，若要將 Exchange 組織中的使用者可以傳送的最大郵件大小設為 10 MB，請輸入：

複製程式碼
Set-TransportConfig -MaxSendSize 10MB

若要將 Exchange 組織中的使用者可以傳送的最大郵件大小設為預設值 (無限制)，請輸入：

複製程式碼
Set-TransportConfig -MaxSendSize unlimited
 變更內送郵件的大小限制

  1. 啟動 Exchange 系統管理員。

  2. 在左窗格中，展開 [通用設定]。

  3. 在 [郵件傳遞] 上按一下滑鼠右鍵，然後按一下 [內容]。

  4. 在 [預設值] 索引標籤的 [接收的郵件大小] 下，按一下 [最大值 (KB)]，然後鍵入一個數字。
設定 Exchange Server 2007 的內送郵件大小限制

  1. 在 Exchange 管理命令介面中，執行下列命令，其中 <size> 會輸入為預設值 (無限制) 或大小 (以 B (位元組)、KB (千位元組) 或 MB (百萬位元組) 為單位)，範圍從 0 到 2147483647 個位元組：
複製程式碼
Set-TransportConfig -MaxReceiveSize <size>

例如，若要將 Exchange 組織中的收件者可以接收的最大郵件大小設為 10 MB，請輸入：

複製程式碼
Set-TransportConfig -MaxReceiveSize 10MB

若要將 Exchange 組織中的收件者可以接收的最大郵件大小設為預設值 (無限制)，請輸入：

複製程式碼
Set-TransportConfig -MaxReceiveSize unlimited

若需有關如何在 Exchange 2000 Server 及 Exchange Server 2003 中設定郵件大小限制的詳細資訊，請參閱微軟知識庫文件 - 322679＜如何在 Exchange Server 中設定郵件大小的限制＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679)。

若需 Exchange Server 2007 之 TransportConfig 指令程式的詳細資訊，請參閱《Exchange Server 2007 技術參考手冊》中的＜Set-TransportConfig＞(英文) (http://go.microsoft.com/fwlink/?LinkId=79237)。


智慧型郵件篩選器自訂回覆存在
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄機碼，以判定 [CustomRejectResponse] 登錄值是否存在：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

若下列條件存在，Exchange Server Analyzer 便會顯示非預設的組態訊息：

  • [CustomRejectResponse] 值已存在。

  • 此值為有效字串。

    附註：
    回覆字串值必須以 [550 5.7.1] 開始，以辨識為有效值。

不需要採取任何改善動作。

在 Exchange Server 2003 Service Pack 2 (SP2) 中，已安裝智慧型郵件篩選器，且在安裝 SP2 後即可使用。Exchange Server 2003 SP2 允許自訂伺服器回覆字串。此字串會產生並附加於傳回給寄件者的未傳遞回報 (NDR) 上。可變更 [550 5.7.1 未採取要求動作：已拒絕郵件] 的預設回覆，以提供封鎖的合法使用者有意義的說明，解釋封鎖其郵件的原因。此說明可協助減少誤判的調查，並降低反垃圾郵件處理的相關支援成本。

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要變更自訂回覆字串

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\Software\Microsoft\Exchange\ContentFilter

  3. 在右工作窗格中，在 [CustomRejectResponse] 值上按一下滑鼠右鍵，並選取 [Modify]。

  4. 輸入您要用來作為自訂回覆的字串值，此字串的開頭要使用 [550 5.7.1]。例如，您可以輸入 [550 5.7.1 網域非允許的寄件者]，以將字串設定為附加到 NDR 的有效字串。

  5. 儲存變更，結束登錄編輯程式，並重新啟動 SMTP 服務以使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需智慧型郵件篩選的相關資訊，請參閱＜Exchange 智慧型郵件篩選器網站＞(英文) (http://go.microsoft.com/fwlink/?LinkId=21607)。

若需有關如何執行智慧型郵件篩選工作的詳細資訊，請參閱 Exchange Server 2003 SP2 線上說明中的 ＜設定智慧型郵件篩選＞(英文)。

若需有關 Exchange Server 2003 SP2 的詳細資訊，請參閱 ＜Exchange Server Service Pack 2 網站＞(英文) (http://go.microsoft.com/fwlink/?LinkId=52073)。


智慧型郵件篩選器自訂文字清單存在
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 CIM_Datafile Windows® Management Instrumentation (WMI) 類別，檢查 Exchange 伺服器上的 MSExchange.UCEContentFilter.xml 檔案是否存在。若 Exchange Server Analyzer 在 Exchange Server 上發現 MSExchange.UCEContentFilter.xml 檔案，則 Exchange Server Analyzer 會顯示非預設的組態訊息。不需要採取任何改善動作。

MSExchange.UCEContentFilter.xml 檔案是 Exchange Server 2003 Service Pack 2 (SP2) 智慧型郵件篩選器中，自訂權數功能的元件。

SP2 智慧型郵件篩選器中的自訂權數功能，可讓系統管理員根據電子郵件訊息、主旨行或兩者內容中的文句，來自訂智慧型郵件篩選器。自訂權數功能沒有相關的使用者介面。自訂權數的格式可以是 XML 組態檔案 (MSExchange.UCEContentFilter.xml)。其可在初始化時供智慧型郵件篩選器使用，並在每次檔案變更時重新載入。若智慧型郵件篩選器啟動時，MSExchange.UCEContentFilter.xml 檔案不存在，則您必須重新啟動 SMTP 服務。MSExchange.UceContentFilter.xml 自訂權數檔案應與 MSExchange.UceContentFilter.dll，以及 .dat 檔位於相同的目錄中。

若需有關自訂權數檔案的詳細資訊，請參閱 Exchange Server 2003 Service Pack 2 版本資訊。　Exchange Server 2003 Service Pack 2 的版本資訊可由 SP2 的 CD，及 Exchange Server 2003 Service Pack 2 版本資訊網站 (http://go.microsoft.com/fwlink/?LinkId=52072) 中取得。

若需有關 Exchange Server 2003 SP2 的詳細資訊，請參閱＜Exchange Server 2003 Service Pack 2 網站＞(英文) (http://go.microsoft.com/fwlink/?LinkId=52073)。


智慧型郵件篩選器無效自訂回覆
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄機碼，以判定 [CustomRejectResponse] 登錄值是否存在：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

若下列條件存在，Exchange Server Analyzer 便會顯示警告：

  • [CustomRejectResponse] 值已存在。

  • 此字串值不是從 [550 5.7.1] 開始。

    附註：
    回覆字串值必須以 [550 5.7.1] 開始，以辨識為有效值。

Exchange Server 2003 Pack 2 (SP2) 允許自訂伺服器回覆字串。此字串會產生並附加於傳回給寄件者的未傳遞回報 (NDR) 上。可變更 [550 5.7.1 未採取要求動作：已拒絕郵件] 的預設回覆，以提供封鎖的合法使用者有意義的說明，解釋封鎖其郵件的原因。此說明可協助減少誤判的調查，並降低反垃圾郵件處理的相關支援成本。

重要事項：
此文件包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\Software\Microsoft\Exchange\ContentFilter

  3. 在右工作窗格中，在 [CustomRejectResponse] 值上按一下滑鼠右鍵，並選取 [Modify]。

  4. 從含 [550 5.7.1] 的字串開始，輸入您要用來作為自訂回覆的字串值。例如，您可以輸入 [550 5.7.1 網域非允許的寄件者]，以將字串設定為附加到 NDR 的有效字串。

  5. 儲存變更，結束登錄編輯程式，並重新啟動 SMTP 服務以使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需智慧型郵件篩選的相關資訊，請參閱＜Exchange 智慧型郵件篩選器網站＞(英文) (http://go.microsoft.com/fwlink/?LinkId=21607)。

若需有關如何執行智慧型郵件篩選工作的詳細資訊，請參閱 Exchange Server 2003 SP2 線上說明中的＜設定智慧型郵件篩選＞(英文)。


信箱伺服器上已啟用智慧型郵件篩選器
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定伺服器上是否已安裝並啟用 Microsoft Exchange 智慧型郵件篩選器：

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

Exchange Server Analyzer 會讀取 ContentFilter 登錄機碼中的 ContentFilterBindings 值，以判定伺服器上是否已安裝並啟用智慧型郵件篩選器。

然後 Exchange Server Analyzer 會查詢 Active Directory® 目錄服務，以判定 Exchange Server 物件的 msExchAuthenticationFlags 屬性值。msExchAuthenticationFlags 屬性代表伺服器上允許的驗證類型。如果下列條件存在，Exchange Server Analyzer 將會顯示警告訊息：

  • 已將 msExchAuthenticationFlags 屬性上的驗證設定為允許匿名存取伺服器。

  • 伺服器上也已主控信箱。

智慧型郵件篩選器可識別出很可能是來路不明的商業電子郵件 (UCE)。如果在閘道使用非 Microsoft 電子郵件伺服器，而要有效篩選出 UCE，就必須在 Exchange 閘道伺服器或 Exchange Bridgehead 伺服器部署智慧型郵件篩選器。這些閘道伺服器會接受內送的網際網路郵件，並將這些郵件轉寄到適當的信箱伺服器。通常，並不會用閘道伺服器主控信箱。

此外，Exchange 閘道伺服器上每個會接受網際網路郵件的 SMTP 虛擬伺服器，也都必須啟用智慧型郵件篩選器。

重要事項：
請不要停用網際網路閘道 SMTP 虛擬伺服器上的匿名存取。這些會從網際網路接受郵件的 SMTP 虛擬伺服器都必須允許匿名存取。

若要篩選 UCE，您可以同時在閘道與 Exchange 信箱儲存區上設定智慧型郵件篩選器，為指派給內送郵件的郵件信賴等級 (SCL) 設定閾值。智慧型郵件篩選器會評估每封內送郵件，並根據郵件為 UCE 的可能性來指派 SCL 分級。Exchange 信箱伺服器會使用指定給信箱儲存區的 SCL 閾值和設定，判定應將郵件傳遞到使用者的收件匣，還是傳遞到垃圾郵件資料夾。

重要事項：
Exchange 信箱伺服器上不一定要安裝智慧型郵件篩選器。如果閘道 SMTP 虛擬伺服器上已安裝並啟用智慧型郵件篩選器，Exchange 信箱伺服器就會隨著每封內送郵件收到 SCL 分級，並採取適當的動作。

若需詳細資訊，請參閱「Exchange 智慧型郵件篩選器」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=21607)。若需有關設定 Microsoft Exchange Server 2003 組織來收發網際網路郵件的詳細資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47579)。


智慧型郵件篩選器未在伺服器上啟用
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定伺服器上是否已安裝並啟用 Microsoft Exchange 智慧型郵件篩選器：

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

如果 Exchange Server Analyzer 發現 ContentFilter 登錄機碼中存在 ContentFilterBindings 值項目，但未設定 ContentFilterBindings 值，就會顯示警告訊息。

附註：
若 ContentFilter 登錄機碼中存在 ContentFilterBindings 值項目，但未設定 ContentFilterBindings 值，就表示伺服器上未啟用智慧型郵件篩選器。
重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需還原登錄的相關資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

Microsoft Exchange 智慧型郵件篩選器會識別可能是來路不明的商業電子郵件 (UCE) 之郵件。在接受送入的電子郵件的 Exchange 閘道伺服器或 Exchange Bridgehead 伺服器上部署智慧型郵件篩選器之後，您必須在接受網際網路電子郵件的 SMTP 虛擬伺服器上啟用智慧型郵件篩選器。

檢視 ContentFilter 登錄機碼

  1. 在 [登錄編輯程式] (regedit) 的詳細資料窗格中，在 ContentFilter 上按一下滑鼠右鍵，以檢視 ContentFilterBindings 的設定。

    附註：
    如果尚未在 SMTP 虛擬伺服器上設定 Exchange 智慧型郵件篩選器，則 ContentFilterBindings 值將為 null。

    在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

建議在已安裝智慧型郵件篩選器的所有 Exchange Server 上啟用 Exchange 智慧型郵件篩選器。若要在 SMTP 虛擬伺服器上啟用智慧型郵件篩選器，請執行下列程序。啟用智慧型郵件篩選器之後，您可以在登錄中確認 ContentFilter 登錄機碼的值。

啟用智慧型郵件篩選器

  1. 按一下 [開始]，並依序指向 [所有程式] 及 [Microsoft Exchange] 後，再按一下 [系統管理員]。

  2. 在 [Exchange 系統管理員] 中，依序展開 [伺服器]、伺服器名稱、[通訊協定] 及 [SMTP] ，並在 [智慧型郵件篩選器] 上按一下滑鼠右鍵，再按一下 [內容]。

  3. 在 [一般] 索引標籤上，在 [將智慧型郵件篩選套用至下列虛擬伺服器的 IP 位址] 下，按一下想要啟用智慧型郵件篩選器之 SMTP 虛擬伺服器旁邊的核取方塊。

    [智慧型郵件篩選內容] 對話方塊

若需詳細資訊，請參閱「Exchange 智慧型郵件篩選器」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=21607)。


指定無效的收件者更新服務伺服器
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-07-30

Microsoft Exchange Analyzer 工具會查詢 Active Directory 目錄服務，以判定目錄中每一個「收件者更新服務」物件的 msExchAddressListServiceLink 屬性值。msExchAddressListServiceLink 屬性是從通訊清單服務到執行收件者更新服務 (RUS) 之 Exchange Server 電腦的連結。

Exchange Analyzer 接著會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定所識別之 Exchange Server 電腦上通訊錄檢視及動態群組服務 (abv_dg.dll) 的 Version 機碼值。Version WMI 機碼表示此檔案的組建編號。

如果 Exchange Analyzer 發現任一台所識別電腦上的 abv_dg.dll 檔案之組建編號開頭為 08，便會顯示錯誤。

此錯誤指出指定為 RUS 伺服器的電腦正在執行 Microsoft Exchange Server 2007。

收件者更新服務是 Exchange 2000 Server 及 Exchange Server 2003 上可找到的 Exchange System Attendant 服務的元件。Exchange 2000 和 Exchange 2003 的收件者更新服務會在 Active Directory 中建立並維護 Exchange 特有的屬性值。此項功能在 Exchange 2007 中是由收件者建立處理程序來處理，如果在 Exchange 2007 伺服器上執行，舊的收件者更新服務將不會處理更新。

若要解決此錯誤，請指定 Exchange 2000 Server 或 Exchange Server 2003 來主控收件者更新服務。

更正此錯誤

  1. 開啟 [Exchange 系統管理員]。

  2. 在 [收件者] 之下，按一下 [收件者更新服務]。在右邊的功能窗格中，在適當的收件者更新服務執行個體上按一下滑鼠右鍵，再按一下 [內容]。

  3. 在 [一般] 索引標籤中，於 [Exchange Server] 之下，按一下 [瀏覽]，然後指定要執行此 RUS 執行個體的新 Exchange 2000 Server 或 Exchange Server 2003 伺服器。

  4. 按 [確定] 兩次，使變更生效。


大量分類進行中
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-08-21

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可於執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上，用來查詢效能計數器物件。效能資料收集引擎會從 SMTP Server 效能物件的 Cat:Categorizations in progress 效能計數器收集資料，以便分析效能資料。

Cat:Categorizations in progress 效能計數器會顯示正在進行的分類數量。

針對此查詢，Exchange Server Analyzer 會在兩分鐘內每隔 6 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的平均值。

若 Exchange Server Analyzer 判定取樣期間進行中的分類平均數目超過 800，Exchange Server Analyzer 便會顯示錯誤。

分類程式會執行下列核心作業：

  • 解析及驗證所有收件者。

  • 判定對所有收件者的限制。

  • 展開通訊群組清單 (如果那是必需的)。

  • 判定郵件是本機傳遞還是遠端傳遞。

此錯誤可能指出伺服器發生極大負載或具有與效能相關的問題。

若要解決此錯誤：

  • 判定分類程式的壓力為預期負載，還是一般負載。若分類程式的壓力來自預期負載，請檢閱下列 Microsoft TechNet 文章的 Exchang 效能指引：

    • 《Exchange Server 2003 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

    • 《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若分類程式的壓力並非來自預期的負載，請檢查可能產生負載的病毒疫情或垃圾郵件。

郵件分類程式的效能計數器，會針對每一個簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器執行個體個別進行公佈。若需與郵件分類程式相關之可用效能計數器的清單，請參閱微軟知識庫文件 - 231734＜XCON：郵件分類程式的效能監視計數器＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)。


已設定通訊群組傳遞限制的大量信箱
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-08-21

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務中找到的所有網域內每一個使用者物件的下列屬性，以判定網域中的任何信箱是否有根據通訊群組成員設定的傳遞限制：

dLMemDefault | 控制是否會依預設接受或拒絕郵件。設定為預設值 1 時，將接受來自任何人的郵件。
dLMemRejectPerms | 包含其成員可能不會傳送到此收件者的通訊群組清單 DN。
dLMemSubmitPerms | 包含其成員可能會傳送到此收件者的通訊群組清單 DN。

如果 Exchange Server Analyzer 判定網域中有 500 個以上的信箱根據通訊群組成員設定傳遞限制，則 Exchange Server Analyzer 會顯示錯誤。

此錯誤指出根據許多信箱的通訊群組成員的傳遞限制，可能會影響 Exchange 郵件流程的效能。

分類程式預設會以遞迴方式展開通訊群組，並對每一封通過系統的郵件執行限制檢查。

當郵件分類程式傳送郵件給接受或拒絕來自通訊群組之郵件的使用者時，郵件分類程式必須展開通訊群組的成員，並取得成員 DN 的完整清單，然後以該 DN 清單與寄件者 DN 清單進行比較。兩份清單的 DN 相符時，便會執行存取作業或拒絕作業。如果通訊群組是其他通訊群組中的巢狀通訊群組，則系統也會展開該巢狀通訊群組。

若要更正這個錯誤：

  • 檢查已設定通訊群組傳遞限制的使用者，並移除不必要的限制。

  • 請參考 Microsoft 知識庫文章 812298＜根據通訊群組清單設定傳遞限制後，郵件傳遞的速度緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)，針對個別信箱而非通訊群組設定傳遞限制。

  • 對於執行 Exchange Server 2003 Service Pack 2 (SP2) 或更新版本的伺服器，請考慮執行非階層式限制檢查。對於執行比 Exchange Server 2003 SP2 更舊之 Exchange 版本的伺服器，請考慮升級至 Exchange Server 2003 SP2。

詳細資訊

如需非階層式限制檢查的詳細資訊，請參閱考慮檢查非階層式限制。

如需通訊群組限制對 Exchange Server 郵件流程之影響的詳細資訊，請參閱下列 Microsoft 知識庫文章：

  • 895407＜在 Exchange Server 2003 中根據通訊群組設定傳遞限制後，將郵件傳遞到本機信箱及外部信箱的速度比預期慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 839949＜針對 Exchange 2000 Server 與 Exchange Server 2003 中的郵件傳輸與通訊群組進行疑難排解＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。

  • 812298＜根據通訊群組清單設定傳遞限制後，郵件傳遞的速度緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。


混合模式組織中已啟用最低成本路由
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否在混合模式環境中執行 Exchange Server 版本 5.5 的伺服器上啟用最低成本路由。若下列條件存在，Exchange Server Analyzer 便會顯示警告：

  • 已啟用最低成本路由。

  • 組織在具有 Exchange Server 5.5 的混合模式環境下執行 Exchange Server 2003。

在混合模式環境下啟用最低成本路由時，可能會建立訊息迴圈。Exchange Server 2003 使用連結狀態路由。因此，當 Exchange Server 2003 偵測到連結無法使用時，就會將郵件重新路由傳送到其他伺服器。當 Exchange Server 5.5 伺服器使用 Message Transfer Agent 屬性頁面中的 Only use least cost routes 選項時，經常會判定最佳路由為傳回至剛剛送出郵件的 Exchange Server 2003 伺服器。在將郵件傳回 Exchange Server 2003 伺服器後，路由會成為迴圈。

在同時執行 Exchange Server 5.5 和 Exchange Server 2003 的混合模式組織中，建議在所有執行 Exchange Server 5.5 的伺服器上停用最低成本路由選項。

若要停用 Exchange Server 5.5 的最低成本路由選項

  1. 在 Microsoft Exchange Server Administrator 程式中，依序展開 [Organization] 容器、[Site] 容器、[Configuration] 容器、[Servers] 容器，再按一下伺服器物件。

  2. 在右窗格中，按一下 [郵件傳輸代理程式] 物件。

  3. 按一下 [檔案] 功能表，然後再按 [內容]。

  4. 在 [郵件傳輸代理程式內容] 對話方塊中，於 [一般] 索引標籤上清除 [僅使用最低成本路由]。

  5. 按一下 [確定]。


SMTP 之接聽通訊埠的預設值 25 似乎已變更
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已變更針對 msExchServerBindings 屬性所設定的預設值 25。依預設，msExchServerBindings 屬性會設為 TCP 通訊埠 25。如果 Exchange Server Analyzer 發現此屬性的值不是 25，就會顯示非預設的組態訊息。

msExchServerBindings 屬性代表此簡易郵件傳送通訊協定 (SMTP) 伺服器用來聆聽輸入連線的 TCP 通訊埠。可將 SMTP 虛擬伺服器設定成接聽一或多個 TCP 通訊埠。預設會將所有的 SMTP 虛擬伺服器設定成接聽 TCP 通訊埠 25 (預設的 SMTP 連接埠)。如果已修改預設的 SMTP 接聽通訊埠，且它的接聽通訊埠清單中不再包含 TCP 通訊埠 25，則會中斷郵件流程。

變更 SMTP 接聽通訊埠是可以接受的，假使其餘的內部傳訊基礎結構也都隨之修改。然而，一般而言，因為網際網路上的 SMTP 伺服器會透過通訊埠 25 來傳送郵件，所以直接從網際網路接受郵件的 SMTP 虛擬伺服器不可使用備用通訊埠。

請注意，Exchange Server Analyzer 會查看 Exchange SMTP 通訊協定虛擬伺服器的值。這台 SMTP 通訊協定虛擬伺服器可能是 (也可能不是) 直接從網際網路接收郵件的 SMTP 伺服器。有些防毒及防垃圾郵件的產品是設計成在通訊埠 25 上從網際網路接收 SMTP 郵件，並重新導向到另一個通訊埠上的 Exchange SMTP 虛擬伺服器。在此案例中，Exchange SMTP 虛擬伺服器在通訊埠 25 以外的通訊埠上進行接聽是可以接受的組態。

若要檢視或修改 SMTP 虛擬伺服器接聽通訊埠

  1. 在 [Exchange 系統管理員] 中，展開 [伺服器]，接著展開一部 Exchange 伺服器，再依序展開 [通訊協定]、[SMTP]。

  2. 在 SMTP 虛擬伺服器上按一下滑鼠右鍵 (例如，預設 SMTP 虛擬伺服器)，然後按一下 [內容]。

  3. 選取 [一般] 索引標籤，然後按一下 [進階]。

  4. 會顯示 IP 位址及通訊埠的清單。

    • 若要變更現有的通訊埠，請選取該 IP 位址，再按 [編輯]。將此 TCP 通訊埠欄位變更為 25。

    • 若要將通訊埠 25 新增為額外的接聽埠，按一下 [新增]，然後新增新的 IP 位址/通訊埠的組合。如果您使用的是 [連線]、[寄件者] 或 [收件者] 篩選，請確定您已選取適當的核取方塊。

  5. 按一下 [確定] 以儲存變更，再按一下 [確定] 以結束 [進階] 對話方塊。按一下 [確定]，關閉 SMTP 虛擬伺服器的 [內容] 對話方塊。

若需 SMTP 虛擬伺服器設定的相關資訊，請參閱下列微軟知識庫文件：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


「本機傳遞」佇列已凍結
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-03

Microsoft® Exchange Server Analyzer 工具會查詢 ExchangeLink Windows® Management Instrumentation (WMI) 類別，以判定簡易郵件傳送通訊協定 (SMTP) [本機傳遞] 佇列的 StateFrozen 機碼值。

如果 Exchange Server Analyzer 在 Exchange 伺服器上發現 [本機傳遞] 的 StateFrozen 機碼值設為 True，就會顯示錯誤。

佇列凍結表示該佇列的傳輸工作階段已停止。佇列凍結會導致郵件無法送出，但仍可以新增新的郵件。您可以使用每個連結佇列上的快顯功能表，手動變更連線狀態。使用 [強制連線] 命令將佇列狀態變更為作用中時，會立即啟用從該佇列傳送郵件的連線。

本機傳遞佇列包含了在 Exchange 伺服器上佇列等待本機傳遞至 Exchange Server 信箱或公用資料夾儲存區的郵件。

如果 Exchange 伺服器目前不接受本機傳遞的郵件，則郵件可能會累積在此佇列中。當郵件傳遞緩慢或斷斷續續時，可能表示有迴圈郵件或是效能問題。

若要解決此錯誤，請增加 MSExchangeTransport 服務的診斷記錄，以收集分類程式元件的相關資訊。

如需如何修改記錄設定的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中＜疑難排解郵件流程及 SMTP＞一節的＜如何修改 MSExchangeTransport 的記錄設定＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

如需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)

  • Microsoft 知識庫文章 821877＜SMTP 及 X400 佇列內容索引標籤上的欄位說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821877)

  • Microsoft 知識庫文章 264054＜XCON：瞭解 Exchange 2000 Server 中的佇列狀態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


「本機傳遞」佇列處於重試狀態
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-03

Microsoft® Exchange Server Analyzer 工具會查詢 ExchangeLink Windows® Management Instrumentation (WMI) 類別，以判定簡易郵件傳送通訊協定 (SMTP) [本機傳遞] 佇列的 StateRetry 機碼值。

如果 Exchange Server Analyzer 在 Exchange 伺服器上發現 [本機傳遞] 佇列的 StateRetry 機碼值設為 True，就會顯示錯誤。

如果佇列處於重試狀態，這個狀態表示在先前嘗試處理佇列中的郵件時，發生了至少一個錯誤。您可以使用 [強制連線] 命令，將處於重試或已排定狀態的佇列變更為作用中。這導致佇列在運作時彷彿重試間隔已過，或是排定的時間已到。但是，此方法並不一定有效。請記住佇列的內容可能表示佇列處於重試狀態的特定原因。

本機傳遞佇列包含了在 Exchange 伺服器上佇列等待本機傳遞至 Exchange Server 信箱或公用資料夾儲存區的郵件。

如果 Exchange 伺服器目前不接受本機傳遞的郵件，則郵件可能會累積在此佇列中。當郵件傳遞緩慢或斷斷續續時，可能表示有迴圈郵件或是效能問題。

若要解決此錯誤，請增加 MSExchangeTransport 服務的診斷記錄，以收集分類程式元件的相關資訊。

如需如何修改記錄設定的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中＜疑難排解郵件流程及 SMTP＞一節的＜如何修改 MSExchangeTransport 的記錄設定＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

如需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)

  • Microsoft 知識庫文章 821877＜SMTP 及 X400 佇列內容索引標籤上的欄位說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821877)

  • Microsoft 知識庫文章 264054＜XCON：瞭解 Exchange 2000 Server 中的佇列狀態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


郵件接收失敗
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會以下列方式，嘗試傳送郵件至簡易郵件傳送通訊協定 (SMTP) 網域之郵件管理員帳戶或使用者定義的帳戶：

  • Exchange Server Analyzer 會開啟與 SMTP 伺服器的通訊端連線。如果 Exchange Server Analyzer 收到 220 回應碼，則視同此步驟已順利完成。

  • Exchange Server Analyzer 傳輸 EHLO SMTP 命令動詞。若下列條件為真，則視同此步驟已順利完成：

    • Exchange Server Analyzer 收到一系列 250 回應碼。

    • 其中一個回應包含 250-X-LINK2STATE 與 250-XEXCH50。

  • Exchange Server Analyzer 傳輸 MAIL FROM:ExMFA-MailAcceptTest@Fabrikam.com SMTP 命令動詞。如果 Exchange Server Analyzer 收到 250 回應碼，則視同此步驟已順利完成。

  • Exchange Server Analyzer 傳輸 RCPT TO:Postmaster (或使用者定義的帳戶)@<網域名稱>.com SMTP 命令動詞。如果 Exchange Server Analyzer 收到 250 回應碼，則視同此步驟已順利完成。

  • Exchange Server Analyzer 傳輸 DATA SMTP 命令動詞，以及以句點結束的範例郵件。如果 Exchange Server Analyzer 收到 250 回應碼，則視同此步驟已順利完成。

如果 Exchange Server Analyzer 無法完成所有步驟，就會顯示錯誤。錯誤表示可能有一般郵件流程問題。以下會依照應疑難排解的順序 (從伺服器層級到網路層級)，列出相關連結。

更正此錯誤

  1. 請參閱《Exchange Server 2003 傳輸及路由手冊》中的＜路由疑難排解＞(http://go.microsoft.com/fwlink/?linkid=47579)。

  2. 請參閱 Microsoft 知識庫文章 324867＜支援 WebCast：Microsoft Exchange 2000 Server：疑難排解郵件流程問題 (再訪)＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324867)。

  3. 請參閱 Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  4. 請參閱 Microsoft 知識庫文章 324759＜支援 WebCast：Microsoft Exchange 2000 Server：DNS 傳輸疑難排解＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324759)。

如需 Exchange Server 的郵件管理員帳戶的相關資訊，請參閱下列 Microsoft 知識庫文章：

  • 223860＜XCON：必須手動設定 SMTP 郵件管理員信箱＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=223860)。

  • 313832＜如何設定 Exchange 2000 Server 中的 SMTP 郵件管理員帳戶＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313832)。


郵件接收失敗，BDAT 命令
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-08-21

Microsoft® Exchange Server Analyzer 工具會傳輸 EHLO 延伸的簡易郵件傳送通訊協定 (ESMTP) 命令動詞到遠端伺服器的通訊埠 25 並分析回應，以判定遠端伺服器是否支援 BDAT ESMTP 動詞。

如果從遠端伺服器收到以回覆 BDAT 命令動詞的回應並未指出不可擷取的錯誤，則 Exchange Server Analyzer 會將測試郵件傳輸至遠端伺服器，並分析回應以判定郵件傳送是否成功。

如果 Exchange Server Analyzer 未收到預期的回應字串 '250'，則 Exchange Server Analyzer 會顯示錯誤。

Exchange Server?2003 會使用 Exchange 專用延伸 SMTP 動詞，以便與組織中其他執行 Exchange Server 的伺服器通訊。使用 Exchange 特定延伸 SMTP 動詞通訊，比使用標準 SMTP 更有效率。如果支援 ESMTP 命令的設定已停用，則可能會妨礙 Exchange Server 的效能。

BDAT ESMTP 命令動詞替代 DATA 命令。當 SMTP 虛擬伺服器利用 CHUNKING 回應 EHLO 關鍵字時，SMTP 伺服器指出它支援 BDAT 命令，而且將接受大量的郵件。此命令採用兩個引數：

  • 第一個引數表示二進位資料封包的長度。因此 SMTP 主機不必持續地掃描資料尾端。接收伺服器會計算郵件中的位元組。當郵件大小等於 BDAT 命令所傳送的值時，伺服器就會假設它已收到所有郵件資料。

  • 第二個引數表示資料封包是否為目前傳輸中的最後一個封包。第二個引數是選用的引數。

此錯誤指出，雖然遠端伺服器支援 BDAT ESMTP 命令動詞，但是後續 BDAT 郵件接受性測試失敗。

若要解決此錯誤，請檢查郵件環境，找出可能封鎖 BDAT 命令動詞的問題或組態，如下所示：

  • 暫時性網路中斷執行

  • SMTP Proxy

  • 防火牆

  • 應用程式

若需如何移除或還原這些動詞之預設支援的詳細資訊，請參閱 Microsoft 知識庫文章 257569＜如何在 Exchange 2000 Server 及 Exchange Server 2003 中關閉 ESMTP 動詞＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569)。

若需 Exchange Server 如何使用 ESMTP 命令動詞的詳細資訊，請參閱《Exchange Server 傳輸及路由手冊》中的＜如何正確載入 Exchange SMTP＞ (http://go.microsoft.com/fwlink/?LinkID=71800)。


已識別為共用目的地的信箱儲存區
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-10-04

Microsoft® Exchange Server Analyzer 工具會查詢 Exchange_Queue Windows® Management Instrumentation (WMI) 類別，以判定 SMTP 虛擬伺服器的簡易郵件傳送通訊協定 (SMTP) 佇列的下列屬性值。

LinkId | 指出包含佇列的連結的識別碼。
QueueId | 指出佇列的識別碼。
QueueName | 指出佇列的名稱。
VirtualMachine | 指出包含佇列的虛擬機器的名稱。
VirtualServerName | 指出佇列所在的虛擬伺服器的名稱。
MessageCount | 指出佇列中的郵件數目。

Exchange Server Analyzer 會使用這裡取得的資訊，查詢 Exchange_QueuedSMTPMessage WMI 類別，以取得佇列中的郵件的下列屬性值：

Recipients | 指出郵件的收件者。
Received | 指出郵件的接收時間戳記。
MessageId | 指出已佇列郵件的識別碼。
StateRetry | 指出對未順利傳遞的郵件重試傳輸。

最後，Exchange Server Analyzer 會使用這裡取得的資料，查詢 Active Directory® 目錄服務，以取得每一個 Recipient 物件的下列值。然後，Exchange Server Analyzer 會判斷收件者是使用者、通訊群組、公用資料夾或公用資料夾儲存區：

distinguishedName | 指出物件的辨別名稱。
msExchHomeServerName | 指出收件者所在的伺服器。
homeMDB | 指出收件者的信箱儲存區。

如果 Exchange Server Analyzer 判定至少有百分之 25 留在佇列的郵件是要送給信箱位於相同信箱儲存區的收件者 (出現在 To: 或 Cc: 欄位中)，Exchange Server Analyzer 會顯示警告。

如果 Exchange Server Analyzer 判定至少有百分之 50 留在佇列的郵件是要送給信箱位於相同信箱儲存區的收件者 (出現在 To: 或 Cc: 欄位中)，Exchange Server Analyzer 會顯示錯誤。

此警告或錯誤表示所識別的信箱儲存區是留在 SMTP 佇列的郵件的共同目的地。

若要更正此問題，應該對信箱儲存區進行如下的調查，找出可能導致郵件置於佇列的組態問題或其他異常狀況：

  • 確定儲存區物件屬性設定正確，而且在 Active Directory 包含正確值。

  • 檢閱儲存區物件的 Active Directory 權限，以取得正確的設定。

  • 如果信箱儲存區是特殊用途的使用者物件的儲存區，亦即，指定的日誌收件者，請檢閱與使用者物件相關的服務或元件的組態，以確定組態正確無誤。

  • 尋找可能未經同意的廣告郵件 (UCE) 或垃圾郵件，或攻擊儲存區收件者的病毒。

若需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkID=67875)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。


「含有無法達到之目的地的郵件」佇列含有郵件
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-10-04

Microsoft® Exchange Server Analyzer 工具會查詢 ExchangeLink Microsoft Windows® Management Instrumentation (WMI) 類別，以判定伺服器上簡易郵件傳送通訊協定 (SMTP) 佇列的 TypeCurrentlyUnreachable、LinkName 及 NumberofMessages 屬性值。

TypeCurrentlyUnreachable 屬性若為 True，則指定連結 (Exchange 佇列) 保留目前無法達到之目的地的郵件。

LinkName 屬性指定連結的名稱。

NumberOfMessages 屬性指定正在等待跨連結傳輸的郵件數目。

如果 Exchange Server Analyzer 判定 [含有無法達到之目的地的郵件] SMTP 佇列包含任何郵件，則 Exchange Server Analyzer 會顯示錯誤。

此錯誤指出佇列中有無法達到預定目的伺服器的郵件。例如，Exchange 無法判斷最後目的地的路由或連接器。或者，所有可用的路由或連接器已標示為關閉。

若要更正此錯誤，請採取下列步驟：

  • 判定 [含有無法達到之目的地的郵件] 中的郵件是否合法。

  • 檢閱 Exchange Server Analyzer 所提供的錯誤指導及連結。

  • 遵循本主題稍後＜詳細資訊＞中的指導。

詳細資訊

若需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。


已凍結「含有無法達到之目的地的郵件」佇列
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-10-06

Microsof® Exchange Server Analyzer 工具會查詢 ExchangeLink Windows® Management Instrumentation (WMI) 類別，以判定簡易郵件傳送通訊協定 (SMTP) [含有無法達到之目的地的郵件] 佇列的 StateFrozen 機碼值。

如果 Exchange Server Analyzer 在 Exchange 伺服器上發現 [含有無法達到之目的地的郵件] 佇列的 StateFrozen 機碼值設為 True，Exchange Server Analyzer 會顯示錯誤。

佇列凍結表示該佇列的傳輸工作階段已停止。佇列凍結會導致郵件無法送出，但仍可以新增新的郵件。

[含有無法達到之目的地的郵件] 佇列含有無法達到預定目的伺服器的郵件。例如，Exchange 無法判斷最後目的地的路由或連接器。或者，所有可用的路由或連接器已標示為關閉。如果下列其中一個條件為真，郵件可以在此佇列中累積：

  • 沒有用於郵件傳遞的路由。

  • 無法使用 Exchange 連接器或遠端傳遞佇列。

  • 當 Exchange 連接器或遠端傳遞佇列處於重試狀態，且連接器或遠端目的地沒有替代的可用路由時，新的郵件會移至此佇列。

若要更正此錯誤，請使用每一個連結佇列上的捷徑功能表，手動變更連線的狀態。使用 [強制連線] 命令將佇列狀態變更為作用中時，會立即啟用從該佇列傳送郵件的連線。如果錯誤持續發生，請按本主題稍後的＜詳細資訊＞所述，升高診斷記錄等級。

詳細資訊

若需如何修改記錄設定的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中＜疑難排解郵件流程及 SMTP＞一節的＜如何修改 MSExchangeTransport 的記錄設定＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

若需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  • Microsoft 知識庫文章 821877＜SMTP 及 X400 佇列內容索引標籤上的欄位說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821877)。

  • Microsoft 知識庫文章 264054＜XCON：瞭解 Exchange 2000 Server 中的佇列狀態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


「含有無法達到之目的地的郵件」佇列處於重試
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-10-06

Microsoft® Exchange Server Analyzer 工具會查詢 ExchangeLink Microsoft Windows® Management Instrumentation (WMI) 類別，以判定簡易郵件傳送通訊協定 (SMTP) [含有無法達到之目的地的郵件] 佇列的 StateRetry 機碼值。

如果 Exchange Server Analyzer 在 Exchange 伺服器上發現 [含有無法達到之目的地的郵件] 佇列的 StateRetry 機碼值設為 True，Exchange Server Analyzer 會顯示錯誤。

如果佇列處於重試狀態，指出先前嘗試處理佇列中的郵件時，發生了至少一個錯誤。

附註：
佇列的內容可能指出佇列處於重試狀態的特定原因。

[含有無法達到之目的地的郵件] 佇列含有無法達到預定目的伺服器的郵件。例如，Exchange 無法判斷最後目的地的路由或連接器。或者，所有可用的路由或連接器已標示為關閉。如果下列其中一個條件為真，郵件可以在此佇列中累積：

  • 沒有用於郵件傳遞的路由。

  • 無法使用 Exchange 連接器或遠端傳遞佇列。

  • 當 Exchange 連接器或遠端傳遞佇列處於重試狀態，且連接器或遠端目的地沒有替代的可用路由時，新的郵件會移至此佇列。

若要更正此錯誤，請使用 [強制連線] 命令，將重試狀態變更為作用中。這導致佇列在運作時彷彿重試間隔已過。但是，此方法並不一定有效。如果錯誤持續發生，請按本主題稍後的＜詳細資訊＞所述，升高診斷記錄等級。

詳細資訊

若需如何修改記錄設定的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中＜疑難排解郵件流程及 SMTP＞一節的＜如何修改 MSExchangeTransport 的記錄設定＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

若需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  • Microsoft 知識庫文章 821877＜SMTP 及 X400 佇列內容索引標籤上的欄位說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821877)。

  • Microsoft 知識庫文章 264054＜XCON：瞭解 Exchange 2000 Server 中的佇列狀態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


已設定通訊群組傳遞限制的信箱
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-08-21

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務中找到的所有網域內每一個使用者物件的下列屬性，以判定網域中的任何信箱是否有根據通訊群組成員設定的傳遞限制：

dLMemDefault | 控制是否會依預設接受或拒絕郵件。設定為預設值 1 時，將接受來自任何人的郵件。
dLMemRejectPerms | 包含其成員可能不會傳送到此收件者的通訊群組清單 DN。
dLMemSubmitPerms | 包含其成員可能會傳送到此收件者的通訊群組清單 DN。

如果 Exchange Server Analyzer 判定網域中有信箱根據通訊群組成員設定傳遞限制，則 Exchange Server Analyzer 會顯示警告。

此警告指出根據通訊群組成員設定的傳遞限制，可能會影響 Exchange Server 郵件流程的效能。

分類程式預設會以遞迴方式展開通訊群組，並對每一封通過系統的郵件執行限制檢查。

當郵件分類程式傳送郵件給接受或拒絕來自通訊群組之郵件的使用者時，郵件分類程式必須展開通訊群組的成員，並取得成員 DN 的完整清單，然後以該 DN 清單與寄件者 DN 清單進行比較。兩份清單的 DN 相符時，便會執行存取作業或拒絕作業。如果通訊群組是其他通訊群組中的巢狀通訊群組，則系統也會展開該巢狀通訊群組。

若要更正此警告：

  • 檢查已設定通訊群組傳遞限制的使用者，並移除不必要的限制。

  • 請參考 Microsoft 知識庫文章 812298＜根據通訊群組清單設定傳遞限制後，郵件傳遞的速度緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)，針對個別信箱而非通訊群組設定傳遞限制。

  • 對於執行 Exchange Server 2003 Service Pack 2 (SP2) 或更新版本的伺服器，請考慮執行非階層式限制檢查。對於執行比 Exchange Server 2003 SP2 更舊之 Exchange 版本的伺服器，請考慮升級至 Exchange Server 2003 SP2。

詳細資訊

如需非階層式限制檢查的詳細資訊，請參閱考慮檢查非階層式限制。

如需通訊群組限制對 Exchange Server 郵件流程之影響的詳細資訊，請參閱下列 Microsoft 知識庫文章：

  • 895407＜在 Exchange Server 2003 中根據通訊群組設定傳遞限制後，將郵件傳遞到本機信箱及外部信箱的速度比預期慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 839949＜針對 Exchange 2000 Server 與 Exchange Server 2003 中的郵件傳輸與通訊群組進行疑難排解＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。

  • 812298＜根據通訊群組清單設定傳遞限制後，郵件傳遞的速度緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。


尚未設定最大內送郵件大小
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-01-05

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定位於以下位置之通用設 delivContLength 屬性的值：

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

如果 Exchange Server Analyzer 發現 delivContLength 屬性的值小於 1，則會顯示錯誤。

這個錯誤指出尚未設定最大內送郵件大小限制。根據您組織中的網路頻寬及使用者需求而定，建議您限制郵件大小。在 Exchange 2000 Server 及 Exchange Server 2007 中，沒有預設郵件大小限制。在 Exchange Server 2003 中，傳送及接收郵件的預設大小限制是 10240 KB。Exchange Server 2003 的預設大小限制適用於新的安裝，以及從 Exchange 2000 Server (沒有設定郵件大小限制) 升級的系統。

您可以藉由設定郵件大小限制，禁止使用者傳送及接受過大的電子郵件，以節省系統資源。這樣可以協助縮減網路傳輸、節省磁碟空間，並改善整體的網路效能。若為 Exchange 2000 Server 及 Exchange Server 2003，您可以使用 [通用設定] 的 [郵件傳遞內容] 中的 [預設值] 索引標籤，指定內送和外寄郵件的郵件傳遞限制。接著，若要設定個別郵件的大小上限，選取 [最大值 (KB)]，然後在文字方塊中輸入以 KB 為單位的大小上限。若不希望限制郵件的大小，則選取 [沒有限制]。如果您組織中的寄件者嘗試傳送郵件給超過指定大小限制的使用者，則寄件者會收到 NDR。外部的寄件者不一定會收到 NDR，這是視您在 [網際網路郵件格式] 中設定的 NDR 設定而定。

若為 Exchange Server 2007，您可以使用 [Exchange 管理命令介面] 來設定 Exchange 組織的 TransportConfig MaxReceiveSize 參數。

建議您將郵件大小限制的上限設定為 10 MB 以下。然而，如果您需要較大的郵件大小限制，讓包含大型附件的郵件能夠透過您的 Exchange 組織來傳送，則建議您將最大內送郵件大小限制增加到 30 MB。將郵件大小限制增加到超過 30 MB 會降低網路效能，甚至導致系統更容易受到安全性攻擊。

設定 Exchange 2000 Server 及 Exchange Server 2003 的郵件大小限制

  1. 在 [Exchange 系統管理員] 中，展開 [通用設定]，在 [郵件傳遞] 上按一下滑鼠右鍵，再按一下 [內容]。

  2. 在 [郵件傳遞內容] 對話方塊中，在 [預設值] 標籤上，選取 [接收的郵件大小限制] 選項，並鍵入您想要的大小限制。

設定 Exchange Server 2007 的郵件大小限制

  1. 在 Exchange 管理命令介面中，執行下列命令，其中 <size> 會輸入為預設值 (無限制) 或大小 (以 B (位元組)、KB (千位元組) 或 MB (百萬位元組) 為單位)，範圍從 0 到 2147483647 個位元組：
複製程式碼
Set-TransportConfig -MaxReceiveSize <size>

例如，若要將 Exchange 組織中的收件者可以接收的最大郵件大小設為 10 MB，請輸入：

複製程式碼
Set-TransportConfig -MaxReceiveSize 10MB

若要將 Exchange 組織中的收件者可以接收的最大郵件大小設為預設值 (無限制)，請輸入：

複製程式碼
Set-TransportConfig -MaxReceiveSize unlimited
  • 若需有關如何設定 Exchange 2000 Server 與 Exchange Server 2003 之郵件大小限制的詳細資訊，請參閱微軟知識庫文件＜設定郵件的大小限制＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)。

  • 若需有關 Exchange Server 2007 的 TransportConfig 指令程式的詳細資訊，請參閱《Exchange Server 2007 技術參考手冊》中的＜Set-TransportConfig＞(英文) (http://go.microsoft.com/fwlink/?LinkID=79237)。

  • 若需有關網際網路郵件格式的詳細資訊，請參閱《Exchange Server 2003 系統管理手冊》(http://go.microsoft.com/fwlink/?LinkId=47617) 中的＜設定 SMTP 原則來控制輸出郵件格式及自動回應＞(英文)。


最大內送郵件大小的設定太高 (>30MB)
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-02-27

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定位於以下位置之通用設 delivContLength 屬性的值：

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

如果 Exchange Server Analyzer 發現 delivContLength 屬性的值超過 30720，則會顯示錯誤。

此錯誤表示最大內送郵件大小限制已設為超過 30 MB 的值。在 Exchange 2000 Server 及 Exchange Server 2007 中，沒有預設郵件大小限制。在 Exchange Server 2003 中，傳送及接收郵件的預設大小限制是 10240 KB。此預設大小限制適用於新的安裝系統以及從 Exchange 2000 Server (沒有設定郵件大小限制) 升級的系統。

您可以設定郵件大小限制，防止使用者傳送及接收大型電子郵件，藉此保留系統資源。這樣可以協助縮減網路傳輸、節省磁碟空間，並改善整體的網路效能。若為 Exchange 2000 Server 及 Exchange Server 2003，您可以使用 [通用設定] 的 [郵件傳遞內容] 中的 [預設值] 索引標籤，指定內送和外寄郵件的郵件傳遞限制。若要設定個別郵件的大小上限，選取 [最大值 (KB)]，然後在文字方塊中輸入以 KB 為單位的大小上限。若不希望限制郵件的大小，則選取 [沒有限制]。如果您組織內的寄件者嘗試傳送郵件給超過指定大小限制的使用者時，就會收到一份未傳遞回報 (NDR)。外部的寄件者不一定會收到 NDR，這是視您在 [網際網路郵件格式] 中設定的 NDR 設定而定。

若為 Exchange Server 2007，您可以使用 [Exchange 管理命令介面] 來設定 Exchange 組織的 TransportConfig MaxSendSize 參數。

建議您將郵件大小限制的上限設定為 30 MB 以下。然而，如果您需要較大的郵件大小限制，讓包含大型附件的郵件能夠透過您的 Exchange 組織來傳送，則建議您將最大內送郵件大小限制增加到 30 MB 以上。將郵件大小限制增加到超過 30 MB 會降低網路效能，甚至導致系統更容易受到安全性攻擊。

重要事項：
雖然好像很類似，但下列設定的結果對於純 Exchange 2000 Server/Exchange Server 2003 環境和 Exchange Server 2007 環境會有極大的不同。

在純 Exchange 2000 Server/Exchange Server 2003 環境中，針對具有信箱功能的使用者，在通用設定中將傳送與接收郵件大小限制設為值 0，結果會完全移除郵件大小限制。

在純 Exchange 2007 環境中，將 TransportConfig -MaxSendSize 和 TransportConfig -MaxreceiveSize 參數設為值 0，結果會限制任何大小的郵件都無法傳送。

設定 Exchange 2000 Server 及 Exchange Server 2003 的郵件大小限制

  1. 在 [Exchange 系統管理員] 中，展開 [通用設定]，在 [郵件傳遞] 上按一下滑鼠右鍵，再按一下 [內容]。

  2. 在 [郵件傳遞內容] 對話方塊中，在 [預設值] 標籤上，選取 [接收的郵件大小限制] 選項，並鍵入您想要的大小限制。

設定 Exchange Server 2007 的郵件大小限制

  1. 在 Exchange 管理命令介面中，執行下列命令，其中 <size> 會輸入為預設值 (無限制) 或大小 (以 B (位元組)、KB (千位元組) 或 MB (百萬位元組) 為單位)，範圍從 0 到 2147483647 個位元組：
複製程式碼
Set-TransportConfig -MaxReceiveSize <size>

例如，若要將 Exchange 組織中的收件者可以接收的最大郵件大小設為 10 MB，請輸入：

複製程式碼
Set-TransportConfig -MaxReceiveSize 10MB

若要將 Exchange 組織中的收件者可以接收的最大郵件大小設為預設值 (無限制)，請輸入：

複製程式碼
Set-TransportConfig -MaxReceiveSize unlimited
  • 若需有關如何設定 Exchange 2000 Server 與 Exchange Server 2003 之郵件大小限制的詳細資訊，請參閱微軟知識庫文件 - 322679＜設定郵件的大小限制＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)。

若需有關 Exchange Server 2007 的 TransportConfig 指令程式的詳細資訊，請參閱《Exchange Server 2007 技術參考手冊》中的＜Set-TransportConfig＞(英文) (http://go.microsoft.com/fwlink/?LinkID=79237)。

  • 若需有關網際網路郵件格式的詳細資訊，請參閱《Exchange Server 2003 系統管理手冊》(http://go.microsoft.com/fwlink/?LinkId=47617) 中的＜設定 SMTP 原則來控制輸出郵件格式及自動回應＞(英文)。


最大內送郵件大小可能設得太低 (<1MB)
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-01-05

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定通用設定 delivContLength 屬性的值，該屬性位於：

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

如果 Exchange Server Analyzer 發現 delivContLength 屬性的值小於 1024 但大於 0，則會顯示錯誤。

此錯誤表示最大內送郵件大小限制已設為小於 1 MB 的值。這麼低的值可能會使 Exchange Server 無法接受某些傳送到您組織的郵件。在 Exchange 2000 Server 及 Exchange Server 2007 中，沒有預設郵件大小限制。在 Exchange Server 2003 中，傳送及接收郵件的預設大小限制是 10240 KB。此預設大小限制適用於新的安裝系統以及從 Exchange 2000 Server (沒有設定郵件大小限制) 升級的系統。

您可以設定郵件大小限制，防止使用者傳送及接收大型電子郵件，藉此保留系統資源。這樣可以協助縮減網路傳輸、節省磁碟空間，並改善整體的網路效能。若為 Exchange 2000 Server 及 Exchange Server 2003，您可以使用 [通用設定] 的 [郵件傳遞內容] 中的 [預設值] 索引標籤，指定內送和外寄郵件的郵件傳遞限制。若要設定個別郵件的大小上限，選取 [最大值 (KB)]，然後在文字方塊中輸入以 KB 為單位的大小上限。若不希望限制郵件的大小，則選取 [沒有限制]。如果您的組織的寄件者傳送郵件給超過指定大小限制的使用者，則寄件者會收到 NDR。外部的寄件者不一定會收到 NDR，這是視您在 [網際網路郵件格式] 中設定的 NDR 設定而定。

若為 Exchange Server 2007，您可以使用 [Exchange 管理命令介面] 來設定 Exchange 組織的 TransportConfig MaxSendSize 參數。

建議您將郵件大小限制的上限設定為 10 MB 以下。然而，如果您需要較大的郵件大小限制，讓包含大型附件的郵件能夠透過您的 Exchange 組織來傳送，則建議您將最大內送郵件大小限制增加到 30 MB。將郵件大小限制增加到超過 30 MB 會降低網路效能，甚至導致系統更容易受到安全性攻擊。

設定 Exchange 2000 Server 及 Exchange Server 2003 的郵件大小限制

  1. 在 [Exchange 系統管理員] 中，展開 [通用設定]，在 [郵件傳遞] 上按一下滑鼠右鍵，再按一下 [內容]。

  2. 在 [郵件傳遞內容] 對話方塊中，在 [預設值] 標籤上，選取 [接收的郵件大小限制] 選項，並鍵入您想要的大小限制。

設定 Exchange Server 2007 的郵件大小限制

  1. 在 Exchange 管理命令介面中，執行下列命令，其中 <size> 會輸入為預設值 (無限制) 或大小 (以 B (位元組)、KB (千位元組) 或 MB (百萬位元組) 為單位)，範圍從 0 到 2147483647 個位元組：
複製程式碼
Set-TransportConfig -MaxReceiveSize <size>

例如，若要將 Exchange 組織中的收件者可以接收的最大郵件大小設為 10 MB，請輸入：

複製程式碼
Set-TransportConfig -MaxReceiveSize 10MB

若要將 Exchange 組織中的收件者可以接收的最大郵件大小設為預設值 (無限制)，請輸入：

複製程式碼
Set-TransportConfig -MaxReceiveSize unlimited
  • 若需有關如何設定 Exchange 2000 Server 與 Exchange Server 2003 之郵件大小限制的詳細資訊，請參閱微軟知識庫文件 - 322679＜設定郵件的大小限制＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)。

若需有關 Exchange Server 2007 的 TransportConfig 指令程式的詳細資訊，請參閱《Exchange Server 2007 技術參考手冊》中的＜Set-TransportConfig＞(英文) (http://go.microsoft.com/fwlink/?LinkID=79237)。

  • 若需有關網際網路郵件格式的詳細資訊，請參閱《Exchange Server 2003 系統管理手冊》(http://go.microsoft.com/fwlink/?LinkId=47617)中的＜設定 SMTP 原則來控制輸出郵件格式及自動回應＞(英文)。


未設定 MaxDSNSize
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄值，來判定是否已設定傳遞狀態通知 (DSN) 郵件大小的上限：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MaxDSNSize

Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定物件類別為 msExchExchangeServer 的所有物件之 serialNumber 屬性值。若字串值包含 Version 5.5，表示電腦執行的是 Microsoft Exchange Server 5.5。若字串值包含 Version 6.0，表示電腦執行的是 Microsoft Exchange 2000 Server。若字串值包含 Version 6.5，表示電腦執行的是 Microsoft Exchange Server 2003。

如果 Exchange Server Analyzer 發現 MaxDSNSize 登錄值不存在於執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上，將會顯示警告。

MaxDSNSize 登錄值是 Exchange Server 的選用值，可限制 DSN 的大小。這個選項會設定 Exchange 在無法傳遞郵件時移除附件。如果新增這個登錄值，建議使用 10240000 位元組 (10 MB) 的值。

附註：
MaxDSNSize 登錄值是在 Service Pack 2 (SP2) for Exchange 2000 Server 中加入，因此需要 Exchange 2000 Server SP2 或更新版本才能使用。此外，在 Service Pack 1 for Exchange Server 2003 及更新版本中，找不到 MaxDSNSize 登錄值時將使用 10 MB 的值。如果需要，您可以新增 MaxDSNSize 登錄值來覆寫這個預設行為。

如果您啟用這個選項，就可以儲存伺服器和網路資源。然而，這種「簡易郵件傳送通訊協定 (SMTP)」附件移除的實作方式有些缺點。如果您啟用這個選項，從未傳遞回報 (NDR) 中移除附件，則在預覽窗格中顯示通知所需的詳細資料也會一併移除，且郵件建立者將無法使用 [重傳] 選項。如果郵件的建立者嘗試要從 NDR 使用 [重傳] 選項，郵件建立者將會收到下列錯誤訊息：無法重新傳送郵件。未傳遞回報未包含有關原始郵件的足夠資訊。若要重新傳送郵件，請在您的 [寄件備份] 資料夾中開啟郵件，按一下 [動作] 功能表，再按一下 [重新傳送這封郵件]。

不過，郵件的建立者即使使用錯誤訊息中的方法，也不能重寄郵件。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\SMTPSvc

  3. 在 SMTPSvc 上按一下滑鼠右鍵，選取 [新增] | [機碼]。將新機碼命名為 Queuing，類型保留空白。

  4. 在 Queuing 上按一下滑鼠右鍵，選取 [新增] | [DWORD 值]。將新數值命名為 MaxDSNSize。

  5. 在右窗格中，連按兩下 MaxDSNSize 登錄值，然後在 [數值資料] 欄位中輸入您要的大小限制 (以位元組為單位)。大於此值的郵件 (產生 NDR) 不會傳回附件或完整的郵件屬性。

  6. 關閉登錄編輯程式，然後重新啟動 Simple Mail Transfer Protocol (SMTP) 服務，以使變更生效。

若需 MaxDSNSize 登錄設定的相關資訊，請參閱下列微軟知識庫文件：

  • 308303＜XCON：將產生 NDR 之郵件中的附件移除的選項＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308303)

  • 323484＜XCON：Exchange 2000 中多重區段/報告網際網路郵件格式的說明＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=323484)


尚未設定最大外寄郵件大小
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-12-04

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定位於以下位置之通用設定 submissionContLength 屬性的值：

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

如果 Exchange Server Analyzer 發現 submissionContLength 屬性的值小於 1，將會顯示錯誤。

這個錯誤指出尚未設定最大外寄郵件大小限制。根據您組織中的網路頻寬及使用者需求而定，建議您限制郵件大小。在 Exchange 2000 Server 及 Exchange Server 2007 中，沒有預設郵件大小限制。在 Exchange Server 2003 中，傳送及接收郵件的預設大小限制是 10240 KB。此預設大小限制適用於新的安裝系統以及從 Exchange 2000 Server (沒有設定郵件大小限制) 升級的系統。

您可以設定郵件大小限制，防止使用者傳送及接收大型電子郵件，藉此保留系統資源。這樣可以協助縮減網路傳輸、節省磁碟空間，並改善整體的網路效能。若為 Exchange 2000 Server 及 Exchange Server 2003，您可以使用 [通用設定] 的 [郵件傳遞內容] 中的 [預設值] 索引標籤，指定內送和外寄郵件的郵件傳遞限制。若要設定個別郵件的大小上限，選取 [最大值 (KB)]，然後在文字方塊中輸入以 KB 為單位的大小上限。若不希望限制郵件的大小，則選取 [沒有限制]。如果您組織中的寄件者嘗試傳送郵件給超過指定大小限制的使用者，則寄件者會收到 NDR。外部的寄件者不一定會收到 NDR，這是視您在 [網際網路郵件格式] 中設定的 NDR 設定值而定。

若為 Exchange Server 2007，您可以使用 Exchange 管理命令介面，設定 Exchange 組織的 TransportConfig MaxSendSize 參數。

建議您將郵件大小限制的上限設為 10 MB 以下。然而，如果您需要較高的郵件大小限制，讓含大型附件的郵件能夠透過您的 Exchange 組織來傳送，建議您將最大外寄郵件大小限制增加到 30 MB。將郵件大小限制增加到超過 30 MB 會降低網路效能，甚至導致系統更容易受到安全性攻擊。

設定 Exchange 2000 Server 及 Exchange Server 2003 的郵件大小限制

  1. 在 [Exchange 系統管理員] 中，展開 [通用設定]，在 [郵件傳遞] 上按一下滑鼠右鍵，再按一下 [內容]。

  2. 在 [郵件傳遞內容] 對話方塊中，於 [預設值] 標籤內，選取 [傳送的郵件大小限制] 選項，然後鍵入您所要的大小限制。

設定 Exchange Server 2007 的郵件大小限制

  1. 在 Exchange 管理命令介面中，執行下列命令，其中 <size> 會輸入為預設值 (無限制) 或大小 (以 B (位元組)、KB (千位元組) 或 MB (百萬位元組) 為單位)，範圍從 0 到 2147483647 個位元組：
複製程式碼
Set-TransportConfig -MaxSendSize <size>

例如，若要將 Exchange 組織中的使用者可以傳送的最大郵件大小設為 10 MB，請輸入：

複製程式碼
Set-TransportConfig -MaxSendSize 10MB

若要將 Exchange 組織中的使用者可以傳送的最大郵件大小設為預設值 (無限制)，請輸入：

複製程式碼
Set-TransportConfig -MaxSendSize unlimited
  • 若需有關設定 Exchange 2000 Server 及 Exchange Server 2003 的郵件大小限制的詳細資訊，請參閱 Microsoft 知識庫文章 322679＜設定郵件的大小限制＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)。

  • 若需有關 Exchange Server 2007 的 TransportConfig 指令程式的詳細資訊，請參閱《Exchange Server 2007 技術參考手冊》中的＜Set-TransportConfig＞(英文) (http://go.microsoft.com/fwlink/?LinkID=79237)。

  • 若需有關網際網路郵件格式的詳細資訊，請參閱《Exchange Server 2003 系統管理手冊》(http://go.microsoft.com/fwlink/?LinkId=47617)中的主題＜設定 SMTP 原則來控制輸出郵件格式及自動回應＞(英文)。


最大外寄郵件大小的設定值太高 (>30 MB)
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-12-04

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定位於以下位置之通用設定 submissionContLength 屬性的值：

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

如果 Exchange Server Analyzer 發現 submissionContLength 屬性的值大於 30720，則會顯示錯誤。

此錯誤指出最大外寄郵件大小限制已設為大於 30 MB 的值。依據組織的網路頻寬及使用者需求，您可能想要將郵件大小限制為較小的郵件。在 Exchange 2000 Server 及 Exchange Server 2007 中，沒有預設郵件大小限制。在 Exchange Server 2003 中，傳送及接收郵件的預設大小限制是 10240 KB。此預設大小限制適用於新的安裝系統以及從 Exchange 2000 Server (沒有設定郵件大小限制) 升級的系統。

您可以設定郵件大小限制，防止使用者傳送及接收大型電子郵件，藉此保留系統資源。這對限制網路傳輸、節省磁碟空間及增進整體網路效能十分有幫助。若為 Exchange 2000 Server 及 Exchange Server 2003，您可以使用 [通用設定] 的 [郵件傳遞內容] 中的 [預設值] 索引標籤，指定內送和外寄郵件的郵件傳遞限制。若要設定個別郵件的大小上限，選取 [最大值 (KB)]，然後在文字方塊中輸入以 KB 為單位的大小上限。若不希望限制郵件的大小，則選取 [沒有限制]。如果您的組織的寄件者傳送郵件給超過指定大小限制的使用者，則寄件者會收到 NDR。外部的寄件者不一定會收到 NDR，這是視您在 [網際網路郵件格式] 中設定的 NDR 設定值而定。

若為 Exchange Server 2007，您可以使用 Exchange 管理命令介面，設定 Exchange 組織的 TransportConfig MaxSendSize 參數。

建議您將郵件大小限制的上限設為 10 MB 以下。然而，如果您需要較高的郵件大小限制，讓含大型附件的郵件能夠透過您的 Exchange 組織來傳送，建議您將最大外寄郵件大小限制增加到 30 MB。將郵件大小限制增加到超過 30 MB 會降低網路效能，甚至導致系統更容易受到安全性攻擊。

設定 Exchange 2000 Server 及 Exchange Server 2003 的郵件大小限制

  1. 在 [Exchange 系統管理員] 中，展開 [通用設定]，在 [郵件傳遞] 上按一下滑鼠右鍵，再按一下 [內容]。

  2. 在 [郵件傳遞內容] 對話方塊中，於 [預設值] 標籤內，選取 [傳送的郵件大小限制] 選項，然後鍵入您所要的大小限制。

設定 Exchange Server 2007 的郵件大小限制

  1. 在 Exchange 管理命令介面中，執行下列命令，其中 <size> 會輸入為預設值 (無限制) 或大小 (以 B (位元組)、KB (千位元組) 或 MB (百萬位元組) 為單位)，範圍從 0 到 2147483647 個位元組：
複製程式碼
Set-TransportConfig -MaxSendSize <size>

例如，若要將 Exchange 組織中的使用者可以傳送的最大郵件大小設為 10 MB，請輸入：

複製程式碼
Set-TransportConfig -MaxSendSize 10MB

若要將 Exchange 組織中的使用者可以傳送的最大郵件大小設為預設值 (無限制)，請輸入：

複製程式碼
Set-TransportConfig -MaxSendSize unlimited
  • 若需有關設定 Exchange 2000 Server 及 Exchange Server 2003 的郵件大小限制的詳細資訊，請參閱 Microsoft 知識庫文章 322679＜設定郵件的大小限制＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)。

若需有關 Exchange Server 2007 的 TransportConfig 指令程式的詳細資訊，請參閱《Exchange Server 2007 技術參考手冊》中的＜Set-TransportConfig＞(英文) (http://go.microsoft.com/fwlink/?LinkID=79237)。

  • 若需有關網際網路郵件格式的詳細資訊，請參閱《Exchange Server 2003 系統管理手冊》(http://go.microsoft.com/fwlink/?LinkId=21769) 中的主題＜設定 SMTP 原則來控制輸出郵件格式及自動回應＞(英文)。


最大外寄郵件大小可能設得太低
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-12-04

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定位於以下位置之通用設定 submissionContLength 屬性的值：

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN= OrganizationName , CN=Global Settings, CN=Message Delivery

如果 Exchange Server Analyzer 發現 submissionContLength 屬性的值小於 1024 但大於 0，就會顯示一則警告。

此警告表示最大外寄郵件大小被設定為小於 1 MB。根據您組織的網路頻寬及使用者需求而定，建議您增加郵件大小以便接受更大型郵件。在 Exchange 2000 Server 及 Exchange Server 2007 中，沒有預設郵件大小限制。在 Exchange Server 2003 中，傳送及接收郵件的預設大小限制是 10240 KB。此預設大小限制適用於新的安裝系統以及從 Exchange 2000 Server (沒有設定郵件大小限制) 升級的系統。

您可以設定郵件大小限制，防止使用者傳送及接收大型電子郵件，藉此保留系統資源。這樣可以協助縮減網路傳輸、節省磁碟空間，並改善整體的網路效能。若為 Exchange 2000 Server 及 Exchange Server 2003，您可以使用 [通用設定] 的 [郵件傳遞內容] 中的 [預設值] 索引標籤，指定內送和外寄郵件的郵件傳遞限制。若要設定個別郵件的大小上限，請選取 [最大值 (KB)]，然後在文字方塊中輸入以 KB 為單位的大小上限。若不希望限制郵件的大小，則選取 [沒有限制]。您的組織內的寄件者在傳送郵件給其他使用者時，若郵件超過指定的大小限制，就會收到一份未傳遞回報 (NDR)。外部的寄件者不一定會收到 NDR，這是視您在 [網際網路郵件格式] 中設定的 NDR 設定值而定。

若為 Exchange Server 2007，您可以使用 Exchange 管理命令介面，設定 Exchange 組織的 TransportConfig MaxSendSize 參數。

建議您將郵件大小限制的上限設為 30 MB 以下。然而，如果需要較高的郵件大小限制以便含有大型附件的郵件能夠經由 Exchange 組織傳送，則建議將最大外寄郵件大小限制增加到 30 MB 以上。將郵件大小限制增加到超過 30 MB 會降低網路效能，甚至導致系統更容易受到安全性攻擊。

設定 Exchange 2000 Server 及 Exchange Server 2003 的郵件大小限制

  1. 在 [Exchange 系統管理員] 中，展開 [通用設定]，在 [郵件傳遞] 上按一下滑鼠右鍵，再按一下 [內容]。

  2. 在 [郵件傳遞內容] 對話方塊中，於 [預設值] 索引標籤內，選取 [傳送的郵件大小限制] 選項，然後鍵入您所要的大小限制。

設定 Exchange Server 2007 的郵件大小限制

  1. 在 Exchange 管理命令介面中，執行下列命令，其中 <size> 會輸入為預設值 (無限制) 或大小 (以 B (位元組)、KB (千位元組) 或 MB (百萬位元組) 為單位)，範圍從 0 到 2147483647 個位元組：
複製程式碼
Set-TransportConfig -MaxSendSize <size>

例如，若要將 Exchange 組織中的使用者可以傳送的最大郵件大小設為 10 MB，請輸入：

複製程式碼
Set-TransportConfig -MaxSendSize 10MB

若要將 Exchange 組織中的使用者可以傳送的最大郵件大小設為預設值 (無限制)，請輸入：

複製程式碼
Set-TransportConfig -MaxSendSize unlimited
  • 若需有關設定 Exchange 2000 Server 及 Exchange Server 2003 的郵件大小限制的詳細資訊，請參閱 Microsoft 知識庫文章 322679＜設定郵件的大小限制＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)。

若需有關 Exchange Server 2007 的 TransportConfig 指令程式的詳細資訊，請參閱《Exchange Server 2007 技術參考手冊》中的＜Set-TransportConfig＞(英文) (http://go.microsoft.com/fwlink/?LinkID=79237)。

  • 若需有關網際網路郵件格式的詳細資訊，請參閱《Exchange Server 2003 系統管理手冊》(http://go.microsoft.com/fwlink/?LinkId=47617)中的主題＜設定 SMTP 原則來控制輸出郵件格式及自動回應＞(英文)。


已啟用僅郵件日誌功能
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-01-10

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已設定 msExchMessageJournalRecipient 屬性，以將郵件複製到收件者信箱。msExchMessageJournalRecipient 屬性是 Active Directory 中信箱儲存區物件的屬性。依預設，未設定 msExchMessageJournalRecipient 屬性。如果 Exchange Server Analyzer 發現已設定 msExchMessageJournalRecipient 屬性，就會顯示非預設的組態訊息。Exchange Server Analyzer 也會顯示啟用了僅郵件日誌功能的資料庫名稱與伺服器名稱。

Exchange Server 2003 僅郵件日誌功能或 Exchange Serverr 2007 標準日誌功能可將使用者所收發的所有郵件和對應的 P2 郵件標頭資料，在信箱資料庫上建立複本，並將郵件複本傳送到指定的信箱。P2 郵件標頭僅包含寄件者向收件者宣告的郵件收件者資料。如果從網際網路收到外部郵件，則 Exchange Server 會記錄 P1 郵件標頭。P1 郵件標頭是郵件傳輸代理程式 (MTA) 用來路由傳送郵件的位址資訊。在預設的情況下，當啟用僅記錄郵件功能時，Exchange Server 不對密件副本 (Bcc) 收件者、來自傳輸轉寄規則的收件者或來自通訊群組擴充的收件者負責。此外，Exchange Server 不會封存 MAPI 報告訊息，例如讀取回條和郵件答錄機通知。

建立郵件日誌會消耗許多磁碟、網路和 CPU 資源。因此，使用日誌功能前需要有完整的部署規劃。日誌功能應只在具有完整日誌解決方案架構的情況下啟用。

如果符合下列情況，請忽略此非預設的組態訊息：

  • 您的企業需要使用日誌功能。

  • 您已部署日誌解決方案架構。

否則，應該關閉日誌功能。

若要關閉 Exchange 2000 Server 與 Exchange Server 2003 之資料庫上的僅郵件日誌功能

  1. 在 [Exchange 系統管理員] 中，依序展開 [伺服器]、<您的 Exchange 伺服器>、<儲存群組>，然後在信箱儲存區按一下滑鼠右鍵。

  2. 在 [一般] 索引標籤中，清除 [封存由此儲存區的信箱所傳送或接收的所有郵件] 核取方塊。

  3. 等待 15 分鐘，讓 Exchange 儲存區套用變更。您不需要重新啟動 Microsoft Exchange Information Store 服務。
若要關閉 Exchange Server 2007 資料庫上的標準日誌功能

  1. 請遵循 Exchange Server 2007 產品文件＜如何停用每個信箱資料庫的日誌功能＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80889) 中的指導。

若需有關部署 Exchange Server 2003 日誌解決方案的作法詳細資訊，請參閱＜Exchange Server 2003 日誌功能＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47581)。

若需有關部署 Exchange Server 2007 日誌解決方案的作法詳細資訊，請參閱＜日誌功能概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkId=80820)。


郵件路由迴圈可能存在
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器的 msExchAlternateServer 屬性值。Exchange Server Best Practice Analyzer 還會判定是否已在組織中的任何收件者原則上設定 msExchNonAuthoritativeDomains 屬性。若下列條件存在，Exchange Server Analyzer 便會顯示警告：

  • 已設定 msExchAlternateServer 屬性的任何執行個體。

  • 已在任何收件者原則上設定 msExchNonAuthoritativeDomains 屬性。

因為上述的組態會造成郵件迴圈，所以 Exchange Server Analyzer 會顯示警告。當不同的郵件系統設定為在單一組織內共同作業時，會發生郵件迴圈。在此案例中，會使用 Exchange Server 收件者原則及 SMTP 組態來為存在於各個異質郵件系統中的使用者群組路由傳送及傳遞郵件。

當在 [SMTP 虛擬伺服器] 內容頁的 [將無法解析收件者的所有郵件轉寄至主機] 欄位中指定地址時，便會設定 msExchAlternateServer 屬性。

當清除指定收件者原則之 [SMTP 地址] 內容頁上的 [此 Exchange 組織負責將所有郵件傳遞至此地址] 核取方塊時，會設定 msExchNonAuthoritativeDomains 屬性。

因此，如果您藉由清除 [此 Exchange 組織負責將所有郵件傳遞至此地址] 核取方塊來指定 SMTP 網域為未經授權的網域，並且已在任何 SMTP 虛擬伺服器上指定無法解析收件者的地址，Exchange Server Analyzer 就會顯示一則警告。不過請注意，出現此警告不一定表示您的組織中存在郵件迴圈。

如果組織中有未經授權的網域且組織中至少有一個伺服器已設定 msExchAlternateServer，則可能會發生郵件路由迴圈。您應該確認下列條件存在：

  • 組織中所有的網域都存在授權網域。

  • 已設定 SMTP 虛擬伺服器，因此授權網域正在處理所有無法解析的郵件。

特別是，如果與其他組織共用網域名稱，建議該網域命名空間只有一個輸入路徑。網域應該有一個授權的郵件伺服器或郵件系統，這樣才不會發生迴圈。授權伺服器應該是輸入路徑上的最後一個系統。

哪個系統是初始接收器並不重要。初始接收器超過二個也沒關係。重要的是只有一個系統是最終目的地。

變更 msExchAlternateServer 屬性

  1. 在 [Exchange 系統管理員] 中，依序展開 [伺服器]、<伺服器名稱> 及 [通訊協定]，然後展開 [SMTP]。

  2. 在您的 SMTP 虛擬伺服器上按一下滑鼠右鍵，再按 [內容]。

  3. 在 SMTP 虛擬伺服器的 [內容] 中，按一下 [郵件] 索引標籤。

  4. 在 [將無法解析收件者的所有郵件轉寄至主機] 方塊中，鍵入將要接收無法解析郵件之伺服器的 FQDN。您也可以在方括號 ([ ]) 中輸入伺服器的 IP 位址。

  5. 按一下 [確定]。
變更 msExchNonAuthoritativeDomains 屬性

  1. 在 [Exchange 系統管理員] 中，展開 [收件者]，再按兩下 <收件者原則名稱>。

  2. 在 [電子郵件地址 (原則)] 索引標籤上，按兩下 SMTP 地址。

  3. 在 [SMTP 地址] 內容頁上，核取 [此 Exchange 組織負責將所有郵件傳遞至此地址]，則會清除 msExchNonAuthoritativeDomains 屬性。藉由清除該核取方塊，會以 [地址] 欄位中指定的 SMTP 地址設定 msExchNonAuthoritativeDomains 屬性。

若需有關共用 SMTP 位址空間的詳細資訊，請參閱微軟知識庫文件 - 321721＜在 Exchange 2000 Server 及 Exchange Server 2003 中共用 SMTP 位址空間＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=321721)。

若需有關網際網路連線部署案例的詳細資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》(http://go.microsoft.com/fwlink/?LinkId=47579)中的＜網際網路連線部署案例＞(英文)。


「正在等候目錄查閱的郵件」佇列已凍結
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsof® Exchange Server Analyzer 工具會查詢 ExchangeLink Windows® Management Instrumentation (WMI) 類別，以判定簡易郵件傳送通訊協定 (SMTP) [正在等候目錄查閱的郵件] 佇列的 StateFrozen 機碼值。

如果 Exchange Server Analyzer 發現 Exchange 伺服器上，[正在等候目錄查閱的郵件] 佇列的 StateFrozen 機碼值設為 True，就會顯示一則錯誤。

佇列凍結表示該佇列的傳輸工作階段已停止。佇列凍結會導致郵件無法送出，但仍可以新增新的郵件。您可以使用每個連結佇列上的快顯功能表，手動變更連線狀態。使用 [強制連線] 命令將佇列狀態變更為作用中時，會立即啟用從該佇列傳送郵件的連線。

[正在等候目錄查閱的郵件] 佇列包含了其收件者尚未針對 Active Directory® 目錄服務解析出來的郵件。在擴充通訊群組清單時，郵件也會留在佇列中。

一般說來，郵件累積在此佇列中的原因是進階佇列引擎無法分類郵件。進階佇列引擎可能無法存取通用類別目錄伺服器及存取收件者資訊，或是無法存取通用類別目錄伺服器，或通用類別目錄伺服器效能低落。此外，郵件也可能因為下列原因而累積：

  • 無法存取 Active Directory。

    附註：
    分類程式使用 Active Directory 來分類郵件。
  • 如果許多郵件佇列在前分類佇列裡，則 Active Directory 可能會負載過重。

  • 發生轉換失敗。分類程式也會控制內容轉換。

  • 郵件分類程式找不到信箱儲存區。

  • 如果重新安裝或移除了 SMTP，這可能會使下列 IIS Metabase 機碼失效：/smtpsvc/DsUseCat 及 /smtpsvc/vsi#/DsUseCat。

    附註：
    判定是否重新安裝或移除了 SMTP。

若要解決此錯誤，請增加 MSExchangeDSAccess 服務及 MSExchangeTransport 服務的診斷記錄，以收集分類程式元件的相關資訊。

如需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  • Microsoft 知識庫文章 821877＜SMTP 及 X400 佇列內容索引標籤上的欄位說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821877)。

  • Microsoft 知識庫文章 264054＜XCON：瞭解 Exchange 2000 Server 中的佇列狀態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


「正在等候目錄查閱的郵件」佇列處於重試狀態
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsof® Exchange Server Analyzer 工具會查詢 ExchangeLink Windows® Management Instrumentation (WMI) 類別，以判定簡易郵件傳送通訊協定 (SMTP) [正在等候目錄查閱的郵件] 佇列的 StateRetry 機碼值。

如果 Exchange Server Analyzer 發現 Exchange 伺服器上，[正在等候目錄查閱的郵件] 佇列的 StateRetry 機碼值設為 True，就會顯示一則錯誤。

如果佇列處於重試狀態，這個狀態表示在先前嘗試處理佇列中的郵件時，發生了至少一個錯誤。您可以使用 [強制連線] 命令，將處於重試或已排定狀態的佇列變更為作用中。這導致佇列在運作時彷彿重試間隔已過，或是排定的時間已到。但是，此方法並不一定有效。

附註：
佇列的內容可能指出佇列處於「重試」的特定原因。

[正在等候目錄查閱的郵件] 佇列包含了其收件者尚未針對 Active Directory® 目錄服務解析出來的郵件。在擴充通訊群組清單時，郵件也會留在佇列中。

一般說來，郵件累積在此佇列中的原因是進階佇列引擎無法分類郵件。進階佇列引擎可能無法存取通用類別目錄伺服器及存取收件者資訊，或是無法存取通用類別目錄伺服器，或通用類別目錄伺服器效能低落。此外，郵件也可能因為下列原因而累積：

  • 無法存取 Active Directory。

    附註：
    分類程式使用 Active Directory 來分類郵件。
  • 如果許多郵件佇列在前分類佇列裡，則 Active Directory 可能會負載過重。

  • 發生轉換失敗。分類程式也會控制內容轉換。

  • 郵件分類程式找不到信箱儲存區。

  • 如果重新安裝或移除了 SMTP，這可能會使下列 IIS Metabase 機碼失效：/smtpsvc/DsUseCat 及 /smtpsvc/vsi#/DsUseCat。

    附註：
    判定是否重新安裝或移除了 SMTP。

若要解決此錯誤，請檢查佇列的內容，以判定佇列處於重試狀態的原因。例如，如果佇列內容顯示類似「已發生 SMTP 錯誤」的訊息，則應該檢閱伺服器的事件日誌，找出任何 SMTP 錯誤。如果記錄中沒有事件，則應該增加 SMTP 通訊協定的記錄級別。

如需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  • Microsoft 知識庫文章 821877＜SMTP 及 X400 佇列內容索引標籤上的欄位說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821877)。

  • Microsoft 知識庫文章 264054＜XCON：瞭解 Exchange 2000 Server 中的佇列狀態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


「提交擱置的郵件」佇列已凍結
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-16

Microsof® Exchange Server Analyzer 工具會查詢 ExchangeLink Windows® Management Instrumentation (WMI) 類別，以判定簡易郵件傳送通訊協定 (SMTP) [提交擱置的郵件] 佇列的 StateFrozen 機碼值。

如果 Exchange Server Analyzer 在 Exchange 伺服器上發現 [提交擱置的郵件] 佇列的 StateFrozen 機碼值設為 True，就會顯示錯誤。

佇列凍結表示該佇列的傳輸工作階段已停止。佇列凍結會導致郵件無法送出，但仍可以新增新的郵件。您可以使用每個連結佇列上的快顯功能表，手動變更連線狀態。使用 [強制連線] 命令將佇列狀態變更為作用中時，會立即啟用從該佇列傳送郵件的連線。

[提交擱置的郵件] 佇列存放了 SMTP 服務已經認可和接受的郵件。

此佇列中的郵件尚未經過處理。如果郵件不斷地累積，可能會發生效能問題。偶爾出現的 CPU 效能高峰可能會導致郵件間歇性地出現在此佇列中。事件接收器的問題經常會導致郵件累積在此佇列中，例如防毒掃描和免責聲明用的自訂 SMTP 處理程式碼。

如需如何修改記錄設定的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中＜疑難排解郵件流程及 SMTP＞一節的＜如何修改 MSExchangeTransport 的記錄設定＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

如需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  • Microsoft 知識庫文章 821877＜SMTP 及 X400 佇列內容索引標籤上的欄位說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821877)。

  • Microsoft 知識庫文章 264054＜XCON：瞭解 Exchange 2000 Server 中的佇列狀態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


「提交擱置的郵件」佇列處於重試狀態
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsof® Exchange Server Analyzer 工具會查詢 ExchangeLink Windows® Management Instrumentation (WMI) 類別，以判定簡易郵件傳送通訊協定 (SMTP) [提交擱置的郵件] 佇列的 StateRetry 機碼值。

如果 Exchange Server Analyzer 在 Exchange 伺服器上發現 [提交擱置的郵件] 佇列的 StateRetry 機碼值設為 True，就會顯示錯誤。

如果佇列處於重試狀態，這個狀態表示在先前嘗試處理佇列中的郵件時，發生了至少一個錯誤。您可以使用 [強制連線] 命令，將處於重試或已排定狀態的佇列變更為作用中。這導致佇列在運作時彷彿重試間隔已過，或是排定的時間已到。但是，此方法並不一定有效。

附註：
佇列的內容可能指出佇列處於「重試」的特定原因。

[提交擱置的郵件] 佇列存放了 SMTP 服務已經認可和接受的郵件。

此佇列中的郵件尚未經過處理。如果郵件不斷地累積，可能會發生效能問題。偶爾出現的 CPU 效能高峰可能會導致郵件間歇性地出現在此佇列中。事件接收器的問題經常會導致郵件累積在此佇列中，例如防毒掃描和免責聲明用的自訂 SMTP 處理程式碼。

如需如何修改記錄設定的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中＜疑難排解郵件流程及 SMTP＞一節的＜如何修改 MSExchangeTransport 的記錄設定＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

如需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  • Microsoft 知識庫文章 821877＜SMTP 及 X400 佇列內容索引標籤上的欄位說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821877)。

  • Microsoft 知識庫文章 264054＜XCON：瞭解 Exchange 2000 Server 中的佇列狀態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


「正在等候路由傳送的郵件」佇列已凍結
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會查詢 ExchangeLink Windows® Management Instrumentation (WMI) 類別，以判定簡易郵件傳送通訊協定 (SMTP) [正在等候路由傳送的郵件] 佇列的 StateFrozen 機碼值。

如果 Exchange Server Analyzer 發現 Exchange 伺服器上，[正在等候目錄查閱的郵件] 佇列的 StateFrozen 機碼值設為 True，就會顯示一則錯誤。

佇列凍結表示該佇列的傳輸工作階段已停止。佇列凍結會導致郵件無法送出，但仍可以新增新的郵件。您可以使用每個連結佇列上的快顯功能表，手動變更連線狀態。使用 [強制連線] 命令將佇列狀態變更為作用中時，會立即啟用從該佇列傳送郵件的連線。

[正在等候路由傳送的郵件] 佇列會保留郵件，直到決定其下一個目的伺服器，然後便會將這些郵件移至對應的連結佇列。

如果有 Exchange Server 路由問題存在，郵件會在此佇列中累積。郵件路由可能會擁塞。

若要解決此錯誤，請增加 MSExchangeDSAccess 服務及 MSExchangeTransport 服務的診斷記錄，以收集分類程式元件的相關資訊。

如需如何修改記錄設定的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中＜疑難排解郵件流程及 SMTP＞一節的＜如何修改 MSExchangeTransport 的記錄設定＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

如需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  • Microsoft 知識庫文章 821877＜SMTP 及 X400 佇列內容索引標籤上的欄位說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821877)。

  • Microsoft 知識庫文章 264054＜XCON：瞭解 Exchange 2000 Server 中的佇列狀態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


「正在等候路由傳送的郵件」佇列處於重試狀態
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會查詢 ExchangeLink Microsoft Windows® Management Instrumentation (WMI) 類別，以判定簡易郵件傳送通訊協定 (SMTP) [正在等待路由傳送的郵件] 佇列的 StateRetry 機碼值。

如果 Exchange Server Analyzer 發現 Exchange 伺服器上，[正在等候目錄查閱的郵件] 佇列的 StateRetry 機碼值設為 True，就會顯示一則錯誤。

如果佇列處於重試狀態，這個狀態表示在先前嘗試處理佇列中的郵件時，發生了至少一個錯誤。您可以使用 [強制連線] 命令，將處於重試或已排定狀態的佇列變更為作用中。這導致佇列在運作時彷彿重試間隔已過，或是排定的時間已到。但是，此方法並不一定有效。

附註：
佇列的內容可能指出佇列處於「重試」的特定原因。

[正在等待路由傳送的郵件] 佇列會保留郵件，直到決定其下一個目的伺服器，然後將這些郵件移至對應的連結佇列。

如果有 Exchange Server 路由問題存在，郵件會在此佇列中累積。郵件路由可能會擁塞。

若要解決此錯誤，請增加 MSExchangeTransport 服務的診斷記錄，以收集分類程式元件的相關資訊。請停用不必要的連接器限制，因為限制可能會導致伺服器效能大幅降低。您可能必須針對部份限制開啟 CheckConnectorRestrictions 登錄機碼。

如需如何修改記錄設定的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中＜疑難排解郵件流程及 SMTP＞一節的＜如何修改 MSExchangeTransport 的記錄設定＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

如需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  • Microsoft 知識庫文章 821877＜SMTP 及 X400 佇列內容索引標籤上的欄位說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821877)。

  • Microsoft 知識庫文章 264054＜XCON：瞭解 Exchange 2000 Server 中的佇列狀態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


遺漏傳輸事件接收器繫結
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-01-11

Microsoft® Exchange Server Analyzer 工具會查詢 Microsoft Internet Information Server (IIS) Metabase，以列舉簡易郵件傳送通訊協定 (SMTP) 傳輸事件接收器繫結的清單。Exchange Server Analyzer 會根據 Exchange Server Analyzer 中預先擴展的下列清單，嘗試找出幾個標準事件繫結：

  • 自訂 Exchange DSN 接收器

  • XLSA 的 EHLO 輸入命令處理常式接收器

  • X-LSA 的 EHLO 回應處理常式接收器

  • EOD 輸入命令處理常式接收器

  • Exchange 分類程式

  • Exchange LoadBalancer

  • Exchange NTFS 儲存區驅動程式

  • Exchange 路由器

  • Exchange SMTP 通訊協定記錄接收器

  • Exchange SMTP 通訊協定安全性 EHLO 接收器

  • Exchange SMTP 通訊協定安全性 EXPS 接收器

  • Exchange SMTP 通訊協定安全性 EXPS-Aux 接收器

  • Exchange SMTP 通訊協定安全性 EXPS-EOD 接收器

  • Exchange SMTP 通訊協定安全性 Mail 接收器

  • Exchange SMTP 通訊協定 XEXCH50 資料前接收器

  • Exchange SMTP 通訊協定 XEXCH50 EHLO 回應接收器

  • Exchange SMTP 通訊協定 XEXCH50 EOD 接收器

  • Exchange SMTP 通訊協定 XEXCH50 輸入 EHLO 接收器

  • Exchange SMTP 通訊協定 XEXCH50 輸入 MAIL 接收器

  • Exchange SMTP 通訊協定 XEXCH50 輸入 RCPT 接收器

  • Exchange SMTP 通訊協定 XEXCH50 輸入 XEXCH50 接收器

  • Exchange SMTP 通訊協定 XEXCH50 每位收件者事件接收器

  • Exchange SMTP 通訊協定 XEXCH50 RCPT 回應接收器

  • Exchange SMTP 通訊協定 XEXCH50 回應接收器

  • Exchange 儲存區驅動程式

  • Exchange Transport AntiVirus API

  • Exchange 傳輸 XEXCH50 提交接收器

  • TURF 的 MAIL 輸入命令處理常式接收器

  • 行動分類程式

  • MSExchange 內容篩選 EOD 接收器

  • MsgTrackLog 接收器

  • RCPT 輸入命令處理常式接收器

  • SMTP Eventlog 接收器

  • UmConvSink

  • X-LSA 輸入命令處理常式接收器

  • X-LSA 回應處理常式接收器

  • X-LSA 接收器

如果 Exchange Server Analyzer 發現有遺漏一或多個標準事件繫結，就會產生警告。

SMTP 傳輸事件是在郵件資料傳入或傳出 SMTP 服務時發生。所有郵件都會經歷一些事件。這些包括 X.400 和 RPC 內送或外寄郵件。輸入傳輸事件的一個常見範例是，郵件經由網路或在 SMTP Pickup 目錄中到達 SMTP 服務。此傳輸事件發生時，此事件的來源會通知傳輸事件接收器，每個傳輸事件接受器就會根據郵件的資料內容採取某一類動作。在系統將郵件資料傳遞到接收器後，直到接收器完成其動作並傳回郵件為止，這段期間內系統不會對郵件資料執行其他動作。接收器在執行此動作時，對郵件資料與狀態有獨佔的控制權。

遺漏傳輸事件接收器繫結可能會造成郵件流程問題。如果 Exchange Server 顯示有郵件流程問題的徵兆 (如郵件在佇列中)，請重新登錄傳輸事件接收器。

若要重新登錄傳輸事件接收器

  1. 從 Microsoft Exchange Server 中開啟 [命令提示字元] 視窗，然後變更至 \Program Files\Exchsrvr\Bin 資料夾。

  2. 鍵入下列命令以重新登錄傳輸事件接收器：

    regsvr32 /i exps.dll

    regsvr32 /i miscat.dll

    regsvr32 /i onsubmit.dll

    regsvr32 /i peexch50.dll

    regsvr32 /i phatcat.dll

    regsvr32 /i protolog.dll

    regsvr32 /i reapi.dll

    regsvr32 /i regsinks.dll

    regsvr32 /i tranmsg.dll

    regsvr32 /i turflist.dll

    regsvr32 /i xlsasink.dll

    regsvr32 /i msgfilter.dll

  3. 重新執行 Exchange Server Analyzer，以確認不會再出現警告。如果繼續發生事件接收器警告且您遇到郵件流程問題，請連絡 Microsoft 產品支援服務 (PSS)。

若需有關傳輸事件接收器繫結的詳細資訊，請參閱下列 Exchange 資源：

  • 微軟知識庫文件 - 258224＜XCON：列舉已登錄的傳輸事件接收器＞(英文) (http://go.microsoft.com/fwlink/?linkID=3052&kbid=258224)

  • 《Exchange Server 2003 技術參考手冊》(http://go.microsoft.com/fwlink/?LinkId=58876) 中的＜SMTP 服務設計＞


已設定 msExchAlternateServer 屬性
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器的 msExchAlternateServer 屬性值。在預設的情況下，未設定 msExchAlternateServer 屬性值。如果 Exchange Server Analyzer 發現已設定 msExchAlternateServer 屬性，就會顯示非預設的組態訊息。

在下列範例案例中，您將設定 msExchAlternateServer 屬性。您會在 Exchange Server 2003 與其他電子郵件系統之間，共用 SMTP 位址空間 (如 SMTP 網域)。在此案例中，Exchange Server 2003 會接受來自網際網路的傳入郵件。Exchange Server 2003 會在 Exchange Server 組織中尋找相符的收件者。如果找不到對應收件者，Exchange Server 會將此郵件轉寄給外部郵件系統。接收的系統也會尋找對應收件者。如果找不到對應收件者，它會將此郵件轉寄給第 3 個電子郵件系統。此鏈中最後的系統必須具有管理此網域的權限。最後接收的系統必須尋找對應收件者。如果找不到對應收件者，則必須為郵件產生未傳遞回報 (NDR)。如果接收的系統尋找對應收件者，然後在找不到對應使用者時將郵件轉寄回原始系統，則會出現迴圈訊息。

變更 msExchAlternateServer 屬性

  1. 在 [Exchange 系統管理員] 中，依序展開 [伺服器]、<伺服器名稱> 及 [通訊協定]，然後展開 [SMTP]。

  2. 在您的 SMTP 虛擬伺服器上按一下滑鼠右鍵，再按一下 [內容]。

  3. 在 SMTP 虛擬伺服器的 [內容] 中，按一下 [郵件] 索引標籤。

  4. 在 [將無法解析收件者的所有郵件轉寄至主機] 方塊中，輸入將要接收無法解析的郵件之伺服器的 FQDN。您也可以在方括號 ([ ]) 中輸入伺服器的 IP 位址。

  5. 按一下 [確定]。

若需有關共用 SMTP 位址空間的詳細資訊，請參閱微軟知識庫文件 - 321721＜在 Exchange 2000 Server 及 Exchange Server 2003 中共用 SMTP 位址空間＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=321721)。

若需有關網際網路連線部署案例的詳細資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》(http://go.microsoft.com/fwlink/?LinkId=47579)中的＜網際網路連線部署案例＞(英文)。


已變更 msExchMaxIncomingConnections 值的預設設定
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定針對每個 SMTP 虛擬伺服器設定的 msExchSmtpMaxIncomingConnections 屬性值。

在不屬 Microsoft Windows® Small Business Server 2003 安裝之一部份的 Exchange Server 電腦上，預設會將 msExchSmtpMaxIncomingConnections 屬性設定成無限制的連線數 (以此屬性的預設值 2000000000 表示)。在屬於 Microsoft Windows Small Business Server 2003 安裝之一部份的 Exchange Server 電腦上，傳入連線的預設最大數目是 500。

Exchange Server Analyzer 也會查詢 Win32_OperatingSystem Windows Management Instrumentation (WMI) 類別，以判定 OSProductSuite 機碼的值。此機碼的值對應到 Windows Server 作業系統的特定版本。

如果 Exchange Server Analyzer 發現 Exchange Server 電腦 (不屬於 Microsoft Windows Small Business Server 2003 安裝的一部份) 的 msExchSmtpMaxIncomingConnections 屬性值不是 2000000000，則會顯示非預設的組態訊息。用於此屬性的值 2000000000 是假設性限制，也是加在用來設定此值之使用者介面元素上的限制。

或者，如果 Exchange Server Analyzer 發現 Exchange Server 電腦 (屬於 Microsoft Windows Small Business Server 2003 安裝的一部份) 的 msExchSmtpMaxIncomingConnections 屬性值不是 500，則會顯示非預設的組態訊息。

從安全性觀點來看，限制傳入連線數目可能十分重要。接受實際無限制之傳入 SMTP 連線數目的功能會將它自己帶入阻斷服務狀況。同時連到虛擬伺服器的連線太多會讓網路的負載過重，而讓效能變差。每個組織都應自行決定此屬性的適合值。

若要檢視或設定最大傳入連線數目

  1. 開啟 [Exchange 系統管理員]。

  2. 依序展開 [伺服器]、Exchange 伺服器、[通訊協定]，然後展開 [SMTP]。

  3. 以滑鼠右鍵按一下 SMTP 虛擬伺服器 (例如，預設 SMTP 虛擬伺服器)，然後按一下 [內容]。

  4. 按一下 [一般]：

    • 若要限制傳入連線的數量，請選取 [將連線數目限制為] 核取方塊，並輸入您想要的值。

    • 若要還原到未限制連入連線的預設值，請清除 [將連線數目限制為] 核取方塊。

  5. 按一下 [確定]，儲存變更。

若需 SMTP 虛擬伺服器設定的相關資訊，請參閱下列微軟知識庫文件：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部分＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpMaxHopCount 值已經改變，不是預設值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定針對 msExchSmtpMaxHopCount 屬性所設定的值是否已與其預設值不同。

在 Exchange 2000 Server 中，msExchSmtpMaxHopCount 屬性會設定成預設值 15。在 Exchange Server 2003 中，此屬性的預設值是 30。如果 Exchange Server Analyzer 發現此屬性不再設定成預設設定，就會顯示非預設的組態訊息。

郵件在到達它的最終目的地之前，會經由許多不同的 SMTP 伺服器 (每個都稱為一個躍點) 來路由傳送。若要防止郵件重複遞送錯誤 (即所謂的訊息迴圈狀況)，系統管理員可以控制允許的躍點數上限。mxExchSmtpMaxHopCount 屬性指定在嘗試透過多少部 SMTP 伺服器傳送之後，如果郵件仍寄不成功，就把郵件退回給寄件者作為未傳遞郵件。

建議 Exchange 2000 Server 及 Exchange Server 2003 SMTP 虛擬伺服器都使用值 30。

若要更正此錯誤

  1. 在 [Exchange 系統管理員] 中，展開 [伺服器]，接著展開一部 Exchange 伺服器，再依序展開 [通訊協定]、 [SMTP]。

  2. 在 SMTP 虛擬伺服器上按一下滑鼠右鍵 (例如，預設的 SMTP 虛擬伺服器)，並選取 [內容]。

  3. 選取 [傳遞] 索引標籤，然後按一下 [進階]。

  4. 在 [最大躍點計數] 欄位中輸入所要的值，並按一下 [確定] 儲存變更。

  5. 按一下 [確定]，關閉 SMTP 虛擬伺服器的 [內容] 對話方塊。

若需 SMTP 虛擬伺服器設定的相關資訊，請參閱下列微軟知識庫文件：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


已變更 msExchSmtpMaxMessageSize 值的預設值 0
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已變更 msExchSmtpMaxMessageSize 屬性的預設值 0。依預設，msExchSmtpMaxMessageSize 屬性是設為不限制郵件大小。如果 Exchange Server Analyzer 發現此屬性的值不是 0，且 Exchange 不是在 Windows® Small Business Server 2003上執行，就會顯示警告訊息。

msExchSmtpMaxMessageSize 屬性代表每個傳送及接收之 SMTP 郵件的大小上限。從安全性觀點來看，最好的作法是限制可從網際網路中傳送及接收之 SMTP 郵件的大小上限。然而，若為內部 SMTP 郵件 (如在同一組織內之 Exchange 伺服器間傳送的郵件)，則建議仍將 msExchSmtpMaxMessageSize 屬性設為 0。

在內部方面，Exchange 利用 SMTP 郵件來處理像是公用資料夾複寫等工作。如果 msExchSmtpMaxMessageSize 屬性的限制設定得太低，則會造成公用資料夾複寫問題及其他組織內郵件傳遞失敗。

如果此 Exchange 伺服器是在網際網路間轉送 SMTP 郵件的 Bridgehead 伺服器，則可放心地略過此警告。如果此 Exchange 伺服器處理的是內部 SMTP 郵件，則應將 msExchSmtpMaxMessageSize 屬性的值變更回它的預設設定 0。

附註：
如果您將郵件大小限制設得太低，則會無法在 Exchange Server 電腦間進行離線通訊錄複寫。若需有關這個問題的詳細資訊，請參閱微軟知識庫文件 - 326154＜XADM：在傳輸層級設定郵件大小限制不會複寫 OAB＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326154)。

若要檢視及設定最大 SMTP 郵件大小

  1. 在 [Exchange 系統管理員] 中，依序展開 [伺服器]、Exchange 伺服器、[通訊協定] 及 [SMTP]。

  2. 在 SMTP 虛擬伺服器上按一下滑鼠右鍵 (例如，預設的 SMTP 虛擬伺服器)，並選取 [內容]。

  3. 選取 [郵件] 標籤。

  4. 若要還原回預設設定 0，請清除 [將郵件大小限制為 (KB)] 核取方塊。或者，仍核取此方塊，並設定成任何想要的值。

  5. 按一下 [確定]，儲存變更並關閉 SMTP 虛擬伺服器的 [內容] 對話方塊。

若需 SMTP 虛擬伺服器設定的相關資訊，請參閱下列微軟知識庫文件：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpMaxOutboundMsgPerDomain 值的預設值 20 已變更
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-07-07

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已變更針對 msExchSmtpMaxOutboundMsgPerDomain 屬性所設定的預設值 20。msExchSmtpMaxOutboundMsgPerDomain 屬性預設會設定為每個連線最多 20 封輸出 SMTP 郵件。如果 Exchange Server Analyzer 發現此屬性沒有 20 這個值，則會顯示非預設的組態訊息。

msExchSmtpMaxOutboundMsgPerDomain 屬性代表 Exchange 伺服器上，SMTP 虛擬伺服器在每個連線上可傳送的郵件數上限。例如，如果 SMTP 伺服器有 35 封郵件要傳送到 microsoft.com，且 msExchSmtpMaxOutboundMsgPerDomain 屬性設定為 20，則對於負責 microsoft.com 郵件的郵件伺服器，將會建立兩個連線。第一個連線最多將傳送 20 封郵件，第二個連線將傳送剩餘的 15 封郵件。

一般而言，沒有什麼最有效的建議可以用來判定這個屬性的正確值。每一個組織必須自行決定要設定的適當值。

若要設定每個連線的郵件最大數目

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [伺服器]，接著展開一部 Exchange 伺服器，再依序展開 [通訊協定]、[SMTP]。

  3. 在 SMTP 虛擬伺服器上按一下滑鼠右鍵 (例如，預設 SMTP 虛擬伺服器)，然後按一下 [內容]。

  4. 按一下 [郵件]。

  5. msExchSmtpMaxOutboundMsgPerDomain 屬性的現行值會列在 [將連線數目限制為] 欄位中。視需要變更此欄位，然後按一下 [確定]，儲存所做的變更。此欄位可接受的值包括介於 1 到 1999999999 之間的任何整數。

  6. 按一下 [確定]，關閉 SMTP 虛擬伺服器的 [內容] 對話方塊。

若需 SMTP 虛擬伺服器設定的相關資訊，請參閱下列 Microsoft 知識庫文章：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpMaxOutgoingConnections 值的預設值 1000 已更動
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已將針對 msExchSmtpMaxOutgoingConnections 屬性所設定的值變更為預設值 1000 以外的值。msExchSmtpMaxOutgoingConnections 屬性預設會設定為最大 1000 個輸出「簡易郵件傳送通訊協定 (SMTP)」連線。如果 Exchange Server Analyzer 發現此屬性沒有 1000 這個值，則會顯示非預設的組態訊息。

msExchSmtpMaxOutgoingConnections 屬性代表 Exchange 伺服器上的 SMTP 虛擬伺服器可以建立的輸出連線最大數目。

一般而言，沒有什麼最有效的建議可以用來判定這個屬性的正確值。每一個組織必須自行決定要設定的適當值。不過，預設值對某些組織而言，可能太高了。您可以藉由收集 Exchange 伺服器的下列效能計數器，來監視及判斷 Exchange SMTP 虛擬伺服器產生的實際 SMTP 輸出連線數目：

物件 | 計數器 | 說明
SMTP Server | Outbound Connections Current | 目前輸出的連線數目。
SMTP Server | Outbound Connections Total | 所嘗試的輸出連線總數。

如果您的組織並未大量使用這個 Exchange 伺服器上的傳出 SMTP，請考慮降低這個屬性的值。將任意時間可建立的同時輸出 SMTP 連線的最大數目降低，或許能夠緩和不正確組態、疏忽的錯誤、惡意活動、訊息迴圈或其他異常，或病毒擴散或安全性破壞等造成的 SMTP 伺服器活動的任何傷害。

若要檢視和設定輸出連線限制

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [伺服器]，接著展開一部 Exchange 伺服器，再依序展開 [通訊協定]、[SMTP]。

  3. 在 SMTP 虛擬伺服器上按一下滑鼠右鍵 (例如，預設 SMTP 虛擬伺服器)，然後按一下 [內容]。

  4. 依序按 [傳遞]、[輸出連線]。

  5. msExchSmtpMaxOutgoingConnections 屬性的現行值會列在 [將連線數目限制為] 欄位中。視需要變更此欄位，然後按一下 [確定]，儲存所做的變更。此欄位可接受的值包括介於 1 到 1999999999 之間的任何整數。

  6. 按一下 [確定]，關閉 SMTP 虛擬伺服器的 [內容] 對話方塊。

若需 SMTP 虛擬伺服器設定的相關資訊，請參閱下列微軟知識庫文件：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpMaxOutgoingConnectionsPerDomain 值已變更，不是預設值 100
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已變更針對 msExchSmtpMaxOutgoingConnectionsPerDomain 屬性所設定的預設值。msExchSmtpMaxOutgoingConnectionsPerDomain 屬性代表在每個網域中 Microsoft Exchange 伺服器上的 SMTP 虛擬伺服器可以建立的輸出連線數上限。在預設的情況下，在並非 Microsoft Windows® Small Business Server 2003 安裝之一部分的 Exchange Server 電腦上，會使用預設值 100 來設定 msExchSmtpMaxOutgoingConnectionsPerDomain 屬性。在屬於 Windows Small Business Server 2003 安裝之一部分的 Exchange Server 電腦上，每個網域的預設傳出連線數上限是 10。

Exchange Server Analyzer 也會查詢 Win32_OperatingSystem Windows Management Instrumentation (WMI) 類別，以判定 OSProductSuite 機碼的值。此機碼的值對應到 Windows Server 作業系統的特定版本。

如果 Exchange Server Analyzer 在不是 Windows Small Business Server 2003 安裝之一部分的 Exchange Server 電腦上，發現 msExchSmtpMaxOutgoingConnectionsPerDomain 屬性沒有值 500，就會顯示非預設的組態訊息。

另外，如果 Exchange Server Analyzer 在屬於 Microsoft Windows Small Business Server 2003 安裝之一部分的 Exchange Server 電腦上，發現 msExchSmtpMaxOutgoingConnectionsPerDomain 屬性沒有值 10，就會顯示非預設的組態訊息。

一般而言，沒有什麼最有效的建議可以用來判定這個屬性的正確值。每一個組織必須自行決定要設定的適當值。不過，預設值對某些組織而言，可能太高了。您可以藉由收集 Exchange 伺服器的下列效能計數器，來監視及判定 Exchange SMTP 虛擬伺服器產生的實際 SMTP 輸出連線數目：

物件 | 計數器 | 說明
SMTP Server | Outbound Connections Current | 目前輸出的連線數目。
SMTP Server | Outbound Connections Total | 所嘗試的輸出連線總數。

如果您的組織在這個 Exchange 伺服器上不常使用傳出 SMTP，請考慮降低此屬性的值。降低在任一時刻可以建立的同時輸出 SMTP 連線數上限，將可減少下列因素對 SMTP 伺服器的影響，進而減慢 SMTP 伺服器達到活動尖峰的速度：不正確的組態、無心的錯誤、惡意的活動、訊息迴圈或其他功能失常，或病毒爆發或安全性缺口。

若要檢視及設定每個網域的傳出連線數上限

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [伺服器]，接著展開一部 Exchange 伺服器，再依序展開 [通訊協定]、[SMTP]。

  3. 以滑鼠右鍵按一下 SMTP 虛擬伺服器 (例如，預設 SMTP 虛擬伺服器)，然後按一下 [內容]。

  4. 依序按 [傳遞]、[輸出連線]。

  5. [將每個網域的連線數目限制為] 欄位中會列出 msExchSmtpMaxOutgoingConnectionsPerDomain 屬性目前的值。依您的需求來變更此欄位，然後按一下 [確定] 以儲存變更。此欄位可接受的值包括介於 1 到 1999999999 之間的任何整數。

  6. 按一下 [確定]，關閉 SMTP 虛擬伺服器的 [內容] 對話方塊。

若需 SMTP 虛擬伺服器設定的相關資訊，請參閱下列微軟知識庫文件：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpMaxRecipients 值的預設值 64000 已變更
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已變更針對 msExchSmtpMaxRecipients 屬性所設定的預設值 64,000。依預設，msExchSmtpMaxRecipients 屬性會設定為 64,000 個收件者。如果 Exchange Server Analyzer 發現此屬性的值不是 64000，就會顯示非預設的組態訊息。

從安全性觀點來看，最好的作法是限制每封郵件的收件者大小上限。每個組織應自行判定可接受的值為何。除非有特定原因要設定此值，否則建議仍將 msExchSmtpMaxRecipients 屬性設定成它的預設值 64000。

若要檢視及設定最大收件者數目

  1. 在 [Exchange 系統管理員] 中，依序展開 [伺服器]、Exchange 伺服器、[通訊協定] 及 [SMTP]。

  2. 在 SMTP 虛擬伺服器 (例如，預設的 SMTP 虛擬伺服器) 上按一下滑鼠右鍵，然後選取 [內容]。

  3. 選取 [郵件] 標籤。

  4. 若要還原成預設設定 64000，請確定已選取 [將每封郵件的收件者數目限制為] 核取方塊，並輸入值 64000。或者，可用任何想要的值來設定此欄位，或清除此核取方塊以允許無限制的收件者數目。

  5. 按一下 [確定]，儲存變更並關閉 SMTP 虛擬伺服器的 [內容] 對話方塊。

若需 SMTP 虛擬伺服器設定的相關資訊，請參閱下列微軟知識庫文件：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpMaxSessionSize 值已經變更，不是預設值 0
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定針對 msExchSmtpMaxSessionSize 屬性所設定的值是否已變更為預設值 0 以外的值。在預設的情況下，msExchSmtpMaxSessionSize 屬性是設定為不限制郵件大小。如果 Exchange Server Analyzer 發現此屬性的值不為 0，就會顯示一則警告。

msExchSmtpMaxSessionSize 屬性代表每個 SMTP 工作階段可接受的最大資料量 (KB)。從安全性觀點來看，針對所傳送及接收的網際網路郵件，限制 SMTP 工作階段大小是最佳的作法。但是，對於內部 SMTP 工作階段而言，例如相同組織內 Exchange 伺服器之間的工作階段，則建議您將 msExchSmtpMaxSessionSize 屬性的設定保留為 0。

在內部方面，Exchange 利用 SMTP 郵件來處理像是公用資料夾複寫等工作。如果 msExchSmtpMaxSessionSize 屬性設得太低，就可能會造成公用資料夾複寫問題與其他組織內部郵件傳遞失敗問題。

如果此 Exchange 伺服器是一個可在網際網路中往返 SMTP 郵件的 Bridgehead 伺服器，則不必理會此警告。如果此 Exchange 伺服器會處理內部 SMTP 郵件，您應該將 msExchSmtpMaxSessionSize 屬性的值改回其預設設定 0。

若要檢視及設定最大 SMTP 工作階段大小

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [伺服器]、再展開 Exchange 伺服器，然後展開 [通訊協定]、再展開 SMTP。

  3. 在 SMTP 虛擬伺服器 (例如，預設 SMTP 虛擬伺服器) 上按一下滑鼠右鍵，再按一下 [內容]。

  4. 按一下 [郵件]。

  5. 若要還原為預設設定 0，請清除 [將工作階段大小限制為 (KB)] 核取方塊。或者，可使此方塊保持核取狀態，並設定任何所要的值。

  6. 按一下 [確定]，儲存變更並關閉 SMTP 虛擬伺服器的 [內容] 對話方塊。

若需 SMTP 虛擬伺服器設定的相關資訊，請參閱下列微軟知識庫文件：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpOutgoingPort 值已經改變，不是預設值 25
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory®目錄服務，以判定是否已變更針對 msExchSmtpOutgoingPort 屬性所設定的預設值 25。依預設，msExchSmtpOutgoingPort 屬性是設定為 TCP 通訊埠 25。如果 Exchange Server Analyzer 發現是此屬性是設定為 25 以外的通訊埠，就會顯示一則警告。

在預設的情況下，簡易郵件傳送通訊協定 (SMTP) 伺服器是設定為在 TCP 通訊埠 25 上接受輸入連線。msExchSmtpOutgoingPort 參數代表此 Exchange 伺服器嘗試連線所有遠端 SMTP 伺服器時所使用的 TCP 通訊埠。如果未設定遠端 SMTP 伺服器在此通訊埠接聽，則無法建立連線。

除非您的部分或整個內部郵件基礎結構已修改為適用於非標準的通訊埠，否則建議您使用 TCP 通訊埠 25 來進行所有 SMTP 通訊。

若要檢視或變更預設的傳出 SMTP 通訊埠

  1. 在 [Exchange 系統管理員] 中，展開 [伺服器]，接著展開一部 Exchange 伺服器，再依序展開 [通訊協定]、[SMTP]。

  2. 以滑鼠右鍵按一下 SMTP 虛擬伺服器 (例如，預設 SMTP 虛擬伺服器)，再按一下 [內容]。

  3. 依序按 [傳遞]、[輸出連線]。

  4. 在 [TCP 通訊埠] 欄位中，輸入要用於輸出連線的通訊埠。必須設定您要通訊的每一個遠端 SMTP 在指定的通訊埠接受連線。通常不需要變更此值。

  5. 視需要變更此欄位，然後按一下 [確定]，儲存所做的變更。

  6. 按一下 [確定]，關閉 SMTP 虛擬伺服器的 [內容] 對話方塊。

若需 SMTP 虛擬伺服器設定的相關資訊，請參閱下列微軟知識庫文件：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpRelayForAuth 值已變更其值為 True 的預設值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已將針對 msExchSmtpRelayForAuth 屬性所設定的值變更為預設值以外的值。依預設，msExchSmtpRelayForAuth 屬性會設為 True 的值。如果 Exchange Server Analyzer 發現 msExchSmtpRelayForAuth 屬性的值未包含 True 值，則會顯示非預設的組態訊息。

當此值設為 True 時，只有已驗證的 SMTP 連線可以通過此 SMTP 虛擬伺服器來轉送 SMTP 郵件。如果此設定變更為 False，表示已清除 SMTP 虛擬伺服器 [內容] 對話方塊的 [轉送] 設定中的 [不考慮上述清單，允許所有通過驗證的電腦轉送] 核取方塊。

轉送是 SMTP 伺服器的輸入連線的動作，可用來將電子郵件傳送到外部網域。就像來路不明的商業電子郵件，傳送單一電子郵件到您的 SMTP 伺服器，並以組織之外的網域中的多個收件者為對象，謂之轉送。因為 SMTP 伺服器的預設設定採用匿名驗證，用來傳播來路不明的商業電子郵件的系統通常會接受輸入郵件。

接受郵件之後，SMTP 伺服器會辨識郵件收件者屬於外部網域，接著 SMTP 伺服器就會傳遞郵件。因此，傳送來路不明商業電子郵件的未經授權的使用者，只需要傳送一封輸入郵件到您的 SMTP 伺服器，就可以轉遞給數千位收件者，如此將降低 Exchange Server 電腦的回應效能、阻塞佇列，且當郵件送達收件者的 [收件匣] 時，將使收件者感到不悅。

不要授與轉送權限給其他任何主機是控制轉送的主要方法。然而，有時會需要轉送。例如，如果您有郵局通訊協定 (POP3) 和網際網路訊息存取通訊協定 (IMAP4) 用戶端，這些用戶端依賴 SMTP 來傳遞郵件，且有正當理由來傳送電子郵件到外部網域。您可以建立第二個 SMTP 虛擬伺服器，專門用來接收來自 POP3 和 IMAP4 用戶端的電子郵件，藉以解決這個問題。這個額外的 SMTP 虛擬伺服器可以使用結合 Secure Sockets Layer (SSL) 型加密的驗證，也可以設為允許為已驗證的用戶端進行轉送。若需有關實作此組態的相關資訊，請參閱微軟知識庫文件 - 319267＜HOW TO：保護 Exchange 2000 中的簡易郵件傳送通訊協定用戶端郵件傳遞安全＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319267)。

若要在「系統管理員」中檢視或修改 msExchSmtpRelayForAuth 值

  1. 開啟 [Exchange 系統管理員]。

  2. 依序展開 [伺服器]、Exchange 伺服器、[通訊協定]，然後展開 SMTP。

  3. 以滑鼠右鍵按一下 SMTP 虛擬伺服器 (例如，預設 SMTP 虛擬伺服器)，再按一下 [內容]。

  4. 選取 [存取] 索引標籤，然後按一下 [轉送]。

  5. 清除或選取 [不考慮上述清單，允許所有通過驗證的電腦轉送] 核取方塊。

  6. 按一下 [確定]，儲存變更。

若核取此方塊，msExchSmtpRelayForAuth 屬性會設為 True。若清除此方塊，msExchSmtpRelayForAuth 屬性會設為 False。

若需控制哪些帳戶可以轉送郵件的其他資訊，請參閱下列微軟知識庫文件：

  • 818778＜不具有郵件轉送權限的使用者仍可透過 SMTP 虛擬伺服器傳送郵件＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818778)

  • 310380＜HOW TO: 避免 Exchange 2000 在 Windows 2000 中被用於做為郵件轉送＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=310380)


msExchSmtpSmartHostType 值的預設值 0 已更動
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已變更針對 msExchSmtpSmartHostType 屬性所設定的預設值 0。依預設，msExchSmtpSmartHostType 屬性會設定為 0。如果 Exchange Server Analyzer 發現此屬性的值不是 0，就會顯示非預設的組態訊息。

msExchSmtpSmartHostType 屬性表示 SMTP 虛擬伺服器是否已設定為使用智慧主機來傳遞郵件。您可以經由智慧主機來路由傳送所有外寄郵件至遠端網域，而非直接將這些郵件傳送到收件者網域。當 Exchange 設定為使用智慧主機時，msExchSmtpSmartHostType 屬性值會變更，詳情請見下表。

智慧主機設定 | msExchSmtpSmartHostType 屬性值
無智慧主機 | 0
智慧主機 | 2
優先嘗試直接傳遞的智慧主機 | 1

在 Exchange Server 2003 電腦上，這個值會是 0 或 2。在 Exchange 2000 Server 電腦上，該值可以是 0、1 或 2。核取 [在傳送到智慧主機之前，嘗試直接傳遞] 核取方塊後，此值會設定為 1。只有 Exchange 2000 Server 電腦上才有這個核取方塊。Exchange Server 2003 不包含這個核取方塊。

除非您有特殊原因，否則建議您保留 msExchSmtpSmartHostType 屬性的預設設定 0。

如果您的環境需要智慧主機，且環境中具有 (或規劃會有) 超過一部的 Exchange Server 電腦，建議您使用 SMTP 連接器來處理任何智慧主機項目。這樣一來，所有內部郵件都會經由 Exchange Server 路由傳送，且只有外部郵件會經由智慧主機來路由傳送。

若要檢視和設定智慧主機設定

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [伺服器]，接著展開一部 Exchange 伺服器，再依序展開 [通訊協定]、[SMTP]。

  3. 在 SMTP 虛擬伺服器上按一下滑鼠右鍵 (例如，預設的 SMTP 虛擬伺服器)，並選取 [內容]。

  4. 選取 [傳遞] 標籤，然後按一下 [進階]。

  5. 輸入您要使用的智慧主機。您可以利用完整格式的網域名稱或 IP 位址來識別智慧主機。如果使用 IP 位址，則必須使用方括弧括住 ([ ])。Exchange 會先檢查伺服器名稱，再檢查 IP 位址。方括弧表示值為 IP 位址；因此會略過 DNS 查閱。

  6. 如果這是 Exchange 2000 Server 電腦，請自行決定選取 [在傳送到智慧主機之前，嘗試直接傳遞] 核取方塊。

  7. 按一下 [確定] 來儲存變更，再按一下 [確定] 來關閉 SMTP 虛擬伺服器的 [內容] 對話方塊。

若需 SMTP 虛擬伺服器設定的相關資訊，請參閱下列微軟知識庫文件：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部分＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=266686)

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部分＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


MTA Stacks 服務設定為與桌面互動
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Microsoft Exchange MTA Stacks (MSExchangeMTA) 服務的 DesktopInteract 內容值。如果 Exchange Server Analyzer 發現 MTA 服務設定為與桌面互動，則會顯示錯誤。

此組態只能在 Microsoft 產品支援服務 (PSS) 的指導之下使用。除非 PSS 已指示您以此組態執行 MTA 服務，否則建議您重新設定 MTA Stacks 服務內容，使它不會與桌面互動。

設定 Exchange MTA Stacks 服務帳戶

  1. 開啟 [服務] MMC 嵌入式管理單元。

  2. 尋找並停止 [Microsoft Exchange MTA Stacks] 服務。

  3. 按兩下 Microsoft Exchange MTA Stacks 服務。

  4. 在 [Microsoft Exchange MTA Stacks 內容] 頁面的 [登入] 索引標籤上，在 [登入身分] 底下選取 [本機系統帳戶]。

  5. 清除 [允許服務與桌面互動] 核取方塊，然後按一下 [套用]。

  6. 在 [服務狀態] 下，按一下 [啟動]，再按一下 [確定]。

  7. 關閉 [服務] 嵌入式管理單元。

若需有關正確 Exchange 服務組態的詳細資訊，請參閱微軟知識庫文件 - 239762＜在 LocalSystem 下執行的 Exchange 服務＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)。


找不到 'MX' 記錄的主機記錄
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-03

Microsoft® Exchange Server Analyzer 工具會執行網域名稱系統 (DNS) 查詢，以擷取網域的郵件交換者 (MX) 記錄。如果順利擷取 MX 記錄，Exchange Server Analyzer 就會執行 DNS 查閱，以擷取 MX 記錄指向之伺服器的主機 (A) 記錄。如果 DNS 查閱作業未傳回任何那些主機 (A) 記錄的 IP 位址，Exchange Server Analyzer 就會顯示錯誤。

此錯誤表示伺服器似乎遺失 DNS 主機 (A) 記錄。此錯誤會造成預定傳送至遠端網域的郵件雍塞在 Exchange 伺服器 [遠端傳遞] 佇列中。此錯誤也會造成其他路由或服務延遲。

無法對 MX 記錄的主機 (A) 記錄進行 DNS 查閱，可能的原因如下：

  • DNS 伺服器由於網路錯誤或其他原因而關閉或沒有回應。

  • 由於無法使用記錄或是記錄不正確，DNS 伺服器上遺失遠端伺服器的主機 (A) 記錄。

  • 未將 DNS 伺服器設定成啟用動態主機記錄更新。

驗證 DNS 伺服器在線上且主機記錄存在

  1. 執行下列一或多項檢查，驗證 DNS 伺服器正在執行中：

    • 在 DNS 伺服器上從 DNS 系統管理程式查看 DNS 伺服器狀態。

    • 重新啟動 DNS 伺服器。如需相關資訊，請參閱＜啟動、停止、暫停或重新啟動 DNS 伺服器＞(英文) (http://go.microsoft.com/fwlink/?LinkId=62999)。

    • 使用 nslookup 命令來驗證 DNS 伺服器回應。如需相關資訊，請參閱＜使用 nslookup 命令驗證 DNS 伺服器回應＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63000)。

  2. 使用 nslookup 驗證 DNS 伺服器上有主機 (A) 記錄存在。如需相關資訊，請參閱＜驗證 DNS 中有 A 資源記錄存在＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63001)。

  3. 如果主機 (A) 資源記錄不存在，請手動新增或修改 A 資源記錄，或設定 DNS 伺服器以啟用動態記錄更新：

    • 手動新增 A 資源記錄。如需相關資訊，請參閱＜新增資源記錄至 DNS 區域＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63002)。

    • 手動修改 A 資源記錄。如需相關資訊，請參閱＜修改現有的資源記錄＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63014)。

    • 將 DNS 伺服器設定成啟用動態主機記錄更新。如需相關資訊，請參閱 Microsoft 知識庫文章 816592＜如何在 Windows Server 2003 中設定 DNS 動態更新＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592)。

詳細資訊

  • 如需 Exchange Server 2003 如何使用 DNS 來解析外部 IP 位址的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中的＜Exchange Server 2003 的傳輸依存關係＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • 如需 DNS 名稱解析的相關資訊，請參閱 Microsoft 知識庫文章 322856＜HOW TO：設定 Exchange Server 所需的 DNS＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)。

  • 如需 DNS 疑難排解的相關資訊，請參閱＜DNS 的疑難排解＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63003)。

  • 如需 Exchange Server 2003 系統監視的相關資訊，請參閱：《MOM 2000 SP1 的 Exchange Server 2003 管理組件手冊》中的＜第 3 章：利用 Exchange Server 2003 管理組件的系統監視＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47573)。

  • 如需主機 (A) 資源記錄的相關資訊，請參閱＜管理資源記錄＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63004)。


找不到主機記錄
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-04

Microsoft® Exchange Server Analyzer 工具會執行網域名稱系統 (DNS) 查閱，以擷取 Exchange 伺服器正在對其傳送郵件之遠端伺服器的主機 (A) 記錄。如果 DNS 查閱作業未傳回 IP 位址，Exchange Server Analyzer 就會顯示錯誤。

此錯誤表示遠端伺服器似乎遺失 DNS 主機 (A) 記錄。此錯誤會造成郵件雍塞在 Exchange 伺服器 [遠端傳遞] 佇列中。

無法對來自遠端伺服器的主機 (A) 記錄進行 DNS 查閱，可能的原因如下：

  • DNS 伺服器由於網路錯誤或其他原因而關閉或沒有回應。

  • 由於無法使用記錄或是記錄不正確，DNS 伺服器上遺失遠端伺服器的主機 (A) 記錄。

  • 未將 DNS 伺服器設定成啟用動態主機記錄更新。

驗證 DNS 伺服器在線上且主機記錄存在

  1. 執行下列一或多項檢查，驗證 DNS 伺服器正在執行中：

    • 在 DNS 伺服器上從 DNS 系統管理程式查看 DNS 伺服器狀態。

    • 重新啟動 DNS 伺服器。如需相關資訊，請參閱＜啟動、停止、暫停或重新啟動 DNS 伺服器＞(英文) (http://go.microsoft.com/fwlink/?LinkId=62999)。

    • 使用 nslookup 命令來驗證 DNS 伺服器回應。如需相關資訊，請參閱＜使用 nslookup 命令驗證 DNS 伺服器回應＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63000)。

  2. 使用 nslookup 驗證 DNS 伺服器上有主機 (A) 記錄存在。如需相關資訊，請參閱＜驗證 DNS 中有 A 資源記錄存在＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63001)。

  3. 如果主機 (A) 資源記錄不存在，請手動新增或修改 A 資源記錄，或設定 DNS 伺服器以啟用動態記錄更新：

    • 手動新增 A 資源記錄。如需相關資訊，請參閱＜新增資源記錄至 DNS 區域＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63002)。

    • 手動修改 A 資源記錄。如需相關資訊，請參閱＜修改現有的資源記錄＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63014)。

    • 將 DNS 伺服器設定成啟用動態主機記錄更新。如需相關資訊，請參閱 Microsoft 知識庫文章 816592＜如何在 Windows Server 2003 中設定 DNS 動態更新＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592)。
  • 如需 Exchange Server 2003 如何使用 DNS 來解析外部 IP 位址的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中的＜Exchange Server 2003 的傳輸依存關係＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • 如需 DNS 名稱解析的相關資訊，請參閱 Microsoft 知識庫文章 322856＜HOW TO：設定 Exchange Server 所需的 DNS＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)。

  • 如需 DNS 疑難排解的相關資訊，請參閱＜DNS 的疑難排解＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63003)。

  • 如需 Exchange Server 2003 系統監視的相關資訊，請參閱：《MOM 2000 SP1 的 Exchange Server 2003 管理組件手冊》中的＜第 3 章：利用 Exchange Server 2003 管理組件的系統監視＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47573)。

  • 如需主機 (A) 資源記錄的相關資訊，請參閱＜管理資源記錄＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63004)。


找不到 MX 記錄
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會查詢它使用的網域名稱系統 (DNS) 伺服器，看是否有 Exchange 傳送目標遠端網域的郵件交換者 (MX) 記錄。

如果 Exchange Server Analyzer 無法從所使用的 DNS 伺服器中擷取遠端網域的 MX 記錄，就會顯示警告。

此警告表示遠端網域似乎遺失了 DNS MX 記錄。

若要判定郵件主機，傳送的 Exchange 伺服器會檢查是否有 MX 記錄。接著，傳送伺服器會檢查地址 (A) 記錄，來將 MX 記錄解析成 IP 位址。

如果遺失遠端網域的 MX 記錄，可能會造成預定傳送至遠端網域的郵件雍塞在 Exchange Server [遠端傳遞] 佇列中，且也會造成其他路由或服務延遲。

DNS 伺服器由於網路錯誤或其他原因而關閉或無法存取時，MX 記錄的 DNS 查閱可能會失敗。

驗證 DNS 伺服器在線上且 MX 記錄存在

  1. 執行下列一或多項檢查，驗證 DNS 伺服器正在執行中：

    • 在 DNS 伺服器上從 DNS 系統管理程式查看 DNS 伺服器狀態。

    • 重新啟動 DNS 伺服器。如需相關資訊，請參閱＜啟動、停止、暫停或重新啟動 DNS 伺服器＞(英文) (http://go.microsoft.com/fwlink/?LinkId=62999)。

    • 使用 nslookup 命令來驗證 DNS 伺服器回應。如需相關資訊，請參閱＜使用 nslookup 命令來驗證 DNS 伺服器回應＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63000)。

  2. 使用 nslookup 驗證 MX 記錄設定正確。如需相關資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》中＜驗證 DNS 設計及組態＞一節的＜如何使用 Nslookup 來驗證 MX 記錄組態＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

詳細資訊

  • 如需 Exchange Server 2003 如何使用 DNS 來解析外部 IP 位址的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中的＜Exchange Server 2003 的傳輸依存關係＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • 如需 DNS 名稱解析的相關資訊，請參閱 Microsoft 知識庫文章 - 322856＜HOW TO：設定 Exchange Server 所需的 DNS＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)。

  • 如需 DNS 疑難排解的相關資訊，請參閱＜DNS 的疑難排解＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63003)。

  • 如需 Exchange Server 2003 系統監視的相關資訊，請參閱：《MOM 2000 SP1 的 Exchange Server 2003 管理組件手冊》中的＜第 3 章：利用 Exchange Server 2003 管理組件的系統監視＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47573)。


傳遞限制中找到巢狀通訊群組
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-08-21

Microsoft® Exchange Server Analyzer 工具會在 Active Directory® 目錄服務中找到的所有網域中，針對每個通訊群組物件查詢下列屬性，以判定是否有任何群組根據群組中的成員用於設定傳遞限制：

dLMemRejectPermsBL | 包含不接受來自此群組之郵件的收件者或連接器 DN。
dLMemSubmitPermsBL | 包含接受來自此群組之郵件的收件者或連接器 DN。

如果 Exchange Server Analyzer 發現有用來設定傳遞限制的群組物件，則 Exchange Server Analyzer 會檢查那些群組，以判定它們是否包含任何巢狀群組。

Exchange Server Analyzer 也會讀取下列登錄機碼，以判定 RestrictionMethod 登錄值是否存在以及其設定方式：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • 通訊群組成員會是用來設定傳遞限制。

  • 已設定傳遞限制的通訊群組中，具有巢狀通訊群組。

  • RestrictionMethod 登錄值存在，且未設定強制一般限制檢查。

此錯誤指出根據通訊群組成員設定的傳遞限制，可能會嚴重影響 Exchange 郵件流程的效能。

分類程式的預設行為是：以遞迴方式展開通訊群組，並對每一封通過系統的郵件執行限制檢查。

當您傳送郵件給接受或拒絕來自通訊群組之郵件的使用者，或透過接受或拒絕來自通訊群組之郵件的連接器傳送郵件時，郵件分類程式必須展開通訊群組的成員，並取得成員 DN 的完整清單，然後以該 DN 清單與寄件者 DN 清單進行比較。兩份清單的 DN 相符時，便會執行存取操作或拒絕操作。如果通訊群組是其他通訊群組中的巢狀通訊群組，則系統也會展開該巢狀通訊群組。

RestrictionMethod 值決定分類程式將如何處理限制。如果將 RestrictionMethod 的值設為 2，則伺服器檢查限制時，此執行 Exchange Server 之伺服器上的傳輸元件將不會展開通訊群組成員。此組態可為限制檢查提供最佳效能。此外，若要讓 RestrictionMethod 登錄項目生效，包含具有傳遞限制之使用者的所有通訊群組必須沒有子群組。也就是說，受限制的通訊群組必須沒有巢狀通訊群組。如果受限制的通訊群組是巢狀的，展開邏輯將不起作用。

若為在連接器限制中使用的通訊群組，建議您在沒有信箱的連接器 Bridgehead 伺服器上設定 RestrictionMethod 登錄項目值。至於 Active Directory 使用者限制，如果限制的通訊群組具有擴充伺服器，則建議您在擴充伺服器上建立 RestrictionMethod 登錄項目。

若要更正這個錯誤：

  • 檢查已設定通訊群組傳遞限制的使用者，並移除不必要的限制。

  • 請參考 Microsoft 知識庫文章 812298＜根據通訊群組清單設定傳遞限制後，郵件傳遞的速度緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)，針對個別信箱而非通訊群組設定傳遞限制。

  • 對於執行 Microsoft Exchange Server 2003 Service Pack 2 (SP2) 或更新版本的伺服器，請考慮執行非階層式限制檢查。對於執行比 Exchange 2003 SP2 更舊之 Exchange 版本的伺服器，請考慮升級至 Exchange 2003 SP2。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要建立 RestrictionMethod 登錄項目並將其值設定為 2

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

  3. 在左窗格中，按一下 [參數]。

  4. 在 [編輯] 功能表中，指向 [新增]，然後按一下 [DWORD 值]。

  5. 鍵入 RestrictionMethod，然後按 ENTER 鍵，以命名新的登錄項目。

  6. 在 [RestrictionMethod] 上按一下滑鼠右鍵，然後按一下 [修改]。

  7. 鍵入 2，然後按 ENTER 鍵。

  8. 關閉登錄編輯程式。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

詳細資訊

如需非階層式限制檢查的詳細資訊，請參閱考慮檢查非階層式限制。

如需通訊群組限制對 Exchange 郵件流程之影響的詳細資訊，請參閱下列 Microsoft 知識庫文章：

  • 895407＜在 Exchange Server 2003 中根據通訊群組設定傳遞限制後，將郵件傳遞到本機信箱及外部信箱的速度比預期慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 839949＜針對 Exchange 2000 Server 與 Exchange Server 2003 中的郵件傳輸與通訊群組進行疑難排解＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。

  • 812298＜根據通訊群組清單設定傳遞限制後，郵件傳遞的速度緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。

若需 RestrictionMethod 登錄值的相關資訊，請參閱 Microsoft 知識庫文章 895407＜在 Exchange Server 2003 中根據通訊群組設定傳遞限制後，傳遞到本機信箱及外部信箱的郵件速度比預期慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

若需有關登錄值的詳細資訊，請參閱微軟知識庫文件 - 277872＜XCON：Connector Delivery Restrictions May Not Work Correctly＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872)。


找到巢狀通訊群組，但已啟用一般限制檢查
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-08-21

Microsoft® Exchange Server Analyzer 工具會在 Active Directory® 目錄服務中找到的所有網域中，針對每個通訊群組物件查詢下列屬性，以判定是否有任何群組根據群組中的成員用於設定傳遞限制：

dLMemRejectPermsBL | 包含不接受來自此群組之郵件的收件者或連接器 DN。
dLMemSubmitPermsBL | 包含接受來自此群組之郵件的收件者或連接器 DN。

如果 Exchange Server Analyzer 發現有用來設定傳遞限制的群組物件，則 Exchange Server Analyzer 會檢查那些群組，以判定它們是否包含任何巢狀群組。

Exchange Server Analyzer 也會讀取下列登錄機碼，以判定 RestrictionMethod 登錄值是否存在以及其設定方式：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • 通訊群組成員是用來設定傳遞限制。

  • 已設定傳遞限制的通訊群組中，具有巢狀通訊群組。

  • RestrictionMethod 登錄值存在且已設定強制一般限制檢查。

此警告指出，雖然 RestrictionMethod 登錄值設定為一般 (非階層式) 限制檢查，但是已設定傳遞限制的通訊群組內嵌其他通訊群組 (巢狀)。如果通訊群組包含巢狀通訊群組，則一般限制檢查將不會正確地識別允許或拒絕的寄件者。進行一般限制檢查時，不會展開巢狀通訊群組。

分類程式的預設行為是：以遞迴方式展開通訊群組，並對每一封通過系統的郵件執行限制檢查。

當您傳送郵件給接受或拒絕來自通訊群組之郵件的使用者，或透過接受或拒絕來自通訊群組之郵件的連接器傳送郵件時，郵件分類程式必須展開通訊群組的成員，並取得成員 DN 的完整清單，然後以該 DN 清單與寄件者 DN 清單進行比較。兩份清單的 DN 相符時，便會執行存取操作或拒絕操作。如果通訊群組是其他通訊群組中的巢狀通訊群組，則系統也會展開該巢狀通訊群組。

RestrictionMethod 值決定分類程式將如何處理限制。如果將 RestrictionMethod 的值設為 2，則伺服器檢查限制時，此執行 Exchange Server 之伺服器上的傳輸元件將不會展開通訊群組成員。此組態可為限制檢查提供最佳效能。此外，若要讓 RestrictionMethod 登錄項目生效，包含具有傳遞限制之使用者的所有通訊群組必須沒有子群組。也就是說，受限制的通訊群組必須沒有巢狀通訊群組。

若要處理此警告，請不要在啟用一般限制檢查時針對傳遞限制所使用的其他通訊群組內放入通訊群組，以形成巢狀。

詳細資訊

如需非階層式限制檢查的詳細資訊，請參閱考慮檢查非階層式限制。

如需通訊群組限制對 Exchange 郵件流程之影響的詳細資訊，請參閱下列 Microsoft 知識庫文章：

  • 895407＜在 Exchange Server 2003 中根據通訊群組設定傳遞限制後，將郵件傳遞到本機信箱及外部信箱的速度比預期慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 839949＜針對 Exchange 2000 Server 與 Exchange Server 2003 中的郵件傳輸與通訊群組進行疑難排解＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。

  • 812298＜根據通訊群組清單設定傳遞限制後，郵件傳遞的速度緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。

若需 RestrictionMethod 登錄值的相關資訊，請參閱 Microsoft 知識庫文章 895407＜在 Exchange Server 2003 中根據通訊群組設定傳遞限制後，傳遞到本機信箱及外部信箱的郵件速度比預期慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

若需有關登錄值的詳細資訊，請參閱微軟知識庫文件 - 277872＜XCON：Connector Delivery Restrictions May Not Work Correctly＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872)。


沒有來自指定寄件者的郵件
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-03-07

Microsoft Exchange Server Analyzer 工具會查詢所有使用者物件的 Active Directory 目錄服務 proxyAddress 屬性值，以判定是否具有符合使用者指定的本機寄件者簡易郵件傳送通訊協定 (SMTP) 位址。

若找到相符的使用者物件proxyAddress，則 Exchange Server Analyzer 會查詢使用者物件的 Active Directory msExchHomeServerName 屬性值，以判定值是否符合使用者指定的 Exchange Server 名稱。

最後，Exchange Server Analyzer 會查詢 Exchange_MessageTrackingEntry Microsoft Windows Management Instrumentation (WMI) 類別 (位於 root\MicrosoftExchangeV2 命名空間下) 的 SenderAddress 內容，識別郵件追蹤記錄檔所追蹤且來自使用者指定之寄件者的任何郵件。

如果 Exchange Server Analyzer 找不到郵件追蹤記錄項目 (其 senderAddress 內容值符合使用者指定之寄件者的 legacyDN 或 SMTP 位址)，則 Exchange Server Analyzer 會顯示錯誤。

  • 此錯誤指出下列其中一或多個條件為真：

  • 使用者指定的寄件者並未傳送任何郵件。

  • 已過了郵件追蹤記錄檔保留期間，而且已刪除相關記錄項目。

  • 未對伺服器啟用郵件追蹤。

若要解決此問題：

  • 指定寄件者已將其他郵件提交給指定收件者。

  • 啟用郵件追蹤中心。

  • 增加郵件追蹤記錄檔保留期間或追蹤更新的郵件。

若需如何啟用郵件追蹤中心的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》(http://go.microsoft.com/fwlink/?LinkID=67875) 中＜疑難排解郵件流程及 SMTP＞的＜如何啟用伺服器上的郵件追蹤中心＞(http://go.microsoft.com/fwlink/?LinkId=71257)。

若需如何使用郵件追蹤的相關資訊，請參閱 Microsoft 知識庫文章 262162＜XADM：使用「郵件追蹤中心」來追蹤訊息＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162)。


沒有傳送給指定收件者的郵件
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-12-07

Microsoft® Exchange Server Analyzer 工具會查詢所有使用者物件的 Active Directory® 目錄服務 proxyAddress 屬性值，以判定是否具有符合使用者指定的本機寄件者簡易郵件傳送通訊協定 (SMTP) 位址。

若找到相符的使用者物件proxyAddress，則 Exchange Server Analyzer 會查詢使用者物件的 Active Directory msExchHomeServerName 屬性值，以判定值是否符合使用者指定的 Exchange Server 名稱。

然後，Exchange Server Analyzer 會查詢 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 類別 (位於 root\MicrosoftExchangeV2 命名空間下) 的 SenderAddress 內容，識別郵件追蹤記錄檔所追蹤且來自使用者指定之寄件者的任何郵件。

最後，Exchange Server Analyzer 會查詢 Exchange_MessageTrackingEntry WMI 類別的 RecipientAddress 內容，識別郵件追蹤記錄檔所追蹤且傳送至使用者指定之收件者的任何郵件。

如果 Exchange Server Analyzer 找不到郵件追蹤記錄項目 (其 RecipientAddress 內容值符合使用者指定之收件者的 SMTP 位址)，則 Exchange Server Analyzer 會顯示錯誤。

此錯誤指出下列其中一或多個條件為真：

  • 使用者指定的寄件者並未將任何郵件傳送至使用者指定的收件者。

  • 已過了郵件追蹤記錄檔保留期間，而且已刪除相關記錄項目。

若要解決此問題：

  • 驗證指定的收件者位址是否正確。

  • 指定寄件者已將其他郵件提交給指定收件者。

  • 增加郵件追蹤記錄檔保留期間或追蹤更新的郵件。

若需有關如何增加郵件追蹤中心記錄檔保留期間的詳細資訊，請參閱＜如何啟用伺服器上的郵件追蹤中心＞(英文) (http://go.microsoft.com/fwlink/?LinkID=71257)。

若需有關如何使用郵件追蹤的詳細資訊，請參閱 Microsoft 知識庫文章 262162＜XADM：使用「郵件追蹤中心」來追蹤訊息＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162)。


沒有佇列狀態可用。SMTP 佇列分析已中止。
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-03-15

Microsoft Exchange Analyzer 工具會查詢 ExchangeLink Microsoft Windows Management Instrumentation (WMI) 類別，以檢查 Exchange 伺服器的簡易郵件傳送通訊協定 (SMTP) 佇列的狀態。

SMTP 是 Exchange Server 的原生郵件通訊協定，用來進行郵件提交與郵件傳輸。這表示用戶端使用 SMTP 來傳送郵件，而 Exchange 伺服器使用 SMTP 來傳遞郵件和郵件資料。

ExchangeLink WMI 類別的內容傳回關於郵件伺服器之間郵件處理連結 (佇列) 的資訊。連結可包括零或多個 ExchangeQueue 物件。此數目取決於連結上的目前郵件流量。

SMTP 使用 SMTP 佇列來傳送內部和外部郵件。在郵件分類及傳送期間，進階佇列引擎會透過 SMTP 虛擬伺服器的 SMTP 佇列傳送所有郵件。如果在處理程序進行中發生傳送郵件方面的問題，郵件會留在發生問題的佇列中。

SMTP 佇列的描述

SMTP 佇列 描述

[本機網域名稱] (本機傳遞)

包含在 Exchange 伺服器的佇列中等待本機傳遞至 Exchange 信箱或公用資料夾儲存區的郵件。

正在等候目錄查閱的郵件

包含其收件者尚未針對 Microsoft Active Directory 目錄服務解析出來的郵件。在擴充通訊群組清單時，郵件也會保留在這裡。

正在等待路由傳送的郵件

用於保留郵件，直到決定其下一個目的伺服器，然後便會將這些郵件移至對應的連結佇列。

遠端傳遞

[連接器名稱|

伺服器名稱| 遠端網域]

保留預定進行遠端傳遞的郵件。佇列的名稱符合遠端傳遞目的，它可能是連接器、伺服器或網域。

目前無法到達的最終目的地

無法到達這些郵件的最終目的伺服器。例如，Exchange 無法判斷最終目的地的網路路徑。

預先提交

保留 SMTP 服務已經認可和接受的郵件。這些郵件的處理尚未開始。

擱置準備提交的 DSN 郵件

包含傳遞狀態通知，亦稱為準備由 Exchange 傳遞的未傳遞回報 (NDR)。

附註 此佇列無法進行下列作業：

  • 刪除所有郵件 (無 DNR)

  • 刪除所有郵件 (DNR)

失敗郵件重試佇列

包含使某種類型的佇列提交失敗的郵件，通常是在其他處理發生之前。在預設的情況下，此佇列中的郵件會在 60 分鐘內重新處理。

因延遲傳遞而存放在佇列中的郵件

包含存放在佇列中等待稍後傳遞的郵件，包括舊版 Outlook 傳送的郵件在內。(您可以在 Outlook 用戶端電腦上設定此選項)。

舊版的 Outlook 依賴郵件傳輸代理程式 (MTA) 進行郵件傳遞。不過，現在是由 SMTP 而不是 MTA 來處理郵件傳遞。因此，由舊版 Outlook 傳送的郵件會以不同的方式處理延遲的傳遞。

這些郵件留在此佇列中，直到其排定的傳遞時間到了為止。

如果 Exchange Analyzer 無法順利完成對伺服器 ExchangeLink WMI 類別的查詢，Exchange Analyzer 會顯示錯誤。

此錯誤指出 WMI 查詢無法擷取所要求的資料。

發生這種錯誤的可能原因如下：

  • 執行 Exchange Analyzer 的帳戶沒有足夠的權限可查詢 WMI 類別。

  • 發生網路問題，使得 Exchange Analyzer 無法與電腦連絡。

  • 不明原因的暫時性狀況造成查詢逾時。

若要更正這個錯誤，請執行下列動作：

  1. 確定已啟動 Exchange Server 電腦，且已連接到網路。

  2. 使用 PING 命令來檢查是否可以連接 Exchange Server 電腦。

  3. 若有防火牆，請檢查遠端程序呼叫 (RPC) 通訊埠是否被封鎖。

  4. 檢查執行 Exchange Analyzer 的帳戶之權限。執行 Exchange Analyzer 的帳戶，在所掃描的每台 Exchange 伺服器上都必須擁有本機 Administrator 權限。

    或者，您也可以將特定的 WMI 權限授與執行 Exchange Analyzer 的帳戶：

    1. 在 Exchange 電腦上，開啟 [電腦管理] Microsoft Management Console (MMC) 樹狀目錄。

    2. 在 [服務及應用程式] 下的 [WMI 控制] 上按一下滑鼠右鍵，再按一下 [內容]。

    3. 在 [WMI 控制內容] 頁面上按一下 [安全性] 索引標籤，然後展開 [根]。

    4. 選取 CIMV2 資料夾，再按一下 [安全性]。

    5. 在 [安全性 ROOT\CIMV2] 頁面上，新增執行 Exchange Analyzer 的帳戶。

  5. 選取您在上述步驟 5 中新增的帳戶。在 [Selected_Account 的權限] 中，於 [允許] 直欄下，選取 [遠端啟用] 及 [讀取安全性]，再按一下 [確定]。

若需疑難排解網路連線問題的相關資訊，請參閱 Microsoft 知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

若需 Exchange Best Practices Analyzer 工具連線問題疑難排解的相關資訊，請參閱＜Microsoft Exchange Server Best Practices Analyzer 工具疑難排解連線問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56285)。

若需有關通訊埠需求的相關資訊，請參閱 Microsoft 知識庫文章 832017＜Windows Server 系統的服務概觀及網路通訊埠需求＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)。


沒有可用於 DNS 記錄測試的遠端伺服器或網域
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-07-06

Microsoft® Exchange Server Analyzer 工具會針對遠端傳遞佇列中郵件的傳送目的地，嘗試識別並建置該遠端伺服器的完整網域名稱 (FQDN)、IP 位址及網域名稱之清單。

遠端伺服器之 FQDN、IP 位址及網域名稱清單的建置流程如下：

  • 查詢簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器之 Active Directory® 目錄服務物件的 msExchSmtpFullyQualifiedDomainName 內容。

    附註：
    接著在查詢所指定的目標 Bridgehead 伺服器時，就會從路由群組連接器目錄物件的 msExchTargetBridgeheadServersDN 內容中讀取 msExchSmtpFullyQualifiedDomainName 內容
  • 針對 SMTP 連接器的指定智慧主機，查詢 SMTP 連接器 Active Directory 物件的 msExchSmtpSmartHost 內容。

  • 針對任何遠端伺服器直接連線，查詢 ExchangeLink Microsoft Windows® Management Instrumentation (WMI) 類別的 LinkName 內容。

如果 Exchange Server Analyzer 判定嘗試建置此清單的動作未產生任何項目，Exchange Server Analyzer 就會顯示錯誤。

這個錯誤表示：

  • 網路可能時斷時續，或 Active Directory 連線有問題，因而導致郵件流程問題。

  • 執行 Exchange Server Analyzer 的帳戶可能沒有查詢此項資訊的足夠權限。

更正此錯誤

  1. 確定已啟動 Exchange Server 電腦，且已連線到網路。

  2. 請確認您有 Active Directory 網域控制站的網路連線。

  3. 在 Exchange Server Analyzer 中指定 Active Directory 網域控制站。

  4. 使用 PING 命令檢查是否可以連接 Exchange Server 電腦。

  5. 若有裝置防火牆，檢查 RPC 通訊埠是否被封鎖。

  6. 檢查執行 Exchange Server Analyzer 的帳戶之權限。執行 Exchange Server Analyzer 的帳戶，在所掃描的每台 Exchange Server 電腦上都必須擁有本機 Administrator 權限。

若需網路連線問題的詳細資訊，請參閱 Microsoft 知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

若需 Exchange Server Analyzer 連線問題的詳細資訊，請參閱＜Microsoft Exchange Server Best Practices Analyzer 工具疑難排解連線問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56285)。

若需有關通訊埠需求的詳細資訊，請參閱知識庫文章 - 832017＜Windows Server 系統的服務概觀及網路通訊埠需求＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)。


沒有伺服器可用於 SMTP 命令測試
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-10-16

Microsoft® Exchange Server Analyzer 工具會針對遠端傳遞佇列中郵件的傳送目的地，嘗試識別並建置該遠端伺服器的網域全名 (FQDN)、IP 位址及網域名稱之清單。

遠端伺服器之 FQDN、IP 位址及網域名稱清單的建置流程如下：

  • 查詢簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器之 Active Directory® 目錄服務物件的 msExchSmtpFullyQualifiedDomainName 內容。

    附註：
    接著在查詢所指定的目標 Bridgehead 伺服器時，就會從路由群組連接器目錄物件的 msExchTargetBridgeheadServersDN 內容中讀取 msExchSmtpFullyQualifiedDomainName 內容
  • 針對 SMTP 連接器的指定智慧主機，查詢 SMTP 連接器 Active Directory 物件的 msExchSmtpSmartHost 內容。

  • 針對任何遠端伺服器直接連線，查詢 ExchangeLink Microsoft Windows® Management Instrumentation (WMI) 類別的 LinkName 內容。

如果 Exchange Server Analyzer 判定嘗試建置此清單的動作未產生任何項目，Exchange Server Analyzer 就會顯示錯誤。

此錯誤指出下列情況：

  • 斷斷續續的網路或 Active Directory 連線問題可能導致郵件流程問題。

  • 執行 Exchange Server Analyzer 的帳戶可能沒有查詢此項資訊的足夠權限。

若要更正此錯誤

  1. 確定執行 Exchange 伺服器的伺服器已啟動並連接至網路。

  2. 請確認您有 Active Directory 網域控制站的網路連線。

  3. 在 Exchange Server Analyzer 中指定 Active Directory 網域控制站。

  4. 使用 PING 命令，查看是否可以連接 Exchange 伺服器。

  5. 若有防火牆，請檢查遠端程序呼叫 (RPC) 通訊埠是否被封鎖。

  6. 檢查執行 Exchange Server Analyzer 的帳戶之權限。執行 Exchange Server Analyzer 的帳戶，在所掃描的每台 Exchange Server 電腦上都必須擁有本機 Administrator 權限。

若需有關網路連線問題的詳細資訊，請參閱 Microsoft 知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

若需 Exchange Server Analyzer 連線問題的詳細資訊，請參閱＜Microsoft Exchange Server Best Practices Analyzer 工具疑難排解連線問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56285)。

若需有關通訊埠需求的詳細資訊，請參閱知識庫文章 832017＜Windows Server 系統的服務概觀及網路通訊埠需求＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)。


沒有可用於連線測試的伺服器
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-07-07

Microsoft® Exchange Server Analyzer 工具會針對遠端傳遞佇列中郵件的傳送目的地，嘗試識別並建置該遠端伺服器的完整網域名稱 (FQDN)、IP 位址及網域名稱之清單。

  • 遠端伺服器之 FQDN、IP 位址及網域名稱清單的建置流程如下：

  • 查詢簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器之 Active Directory® 目錄服務物件的 msExchSmtpFullyQualifiedDomainName 內容。

    附註：
    接著在查詢所指定的目標 Bridgehead 伺服器時，就會從路由群組連接器目錄物件的 msExchTargetBridgeheadServersDN 內容中讀取 msExchSmtpFullyQualifiedDomainName 內容
  • 針對 SMTP 連接器的指定智慧主機，查詢 SMTP 連接器 Active Directory 物件的 msExchSmtpSmartHost 內容。

  • 針對任何遠端伺服器直接連線，查詢 ExchangeLink Microsoft Windows® Management Instrumentation (WMI) 類別的 LinkName 內容。

如果 Exchange Server Analyzer 判定嘗試建置此清單的動作未產生任何項目，Exchange Server Analyzer 就會顯示錯誤。

這個錯誤表示：

  • 網路可能時斷時續，或 Active Directory 連線有問題，因而導致郵件流程問題。

  • 執行 Exchange Server Analyzer 的帳戶可能沒有查詢此項資訊的足夠權限。

更正此錯誤

  1. 確定已啟動 Exchange Server 電腦，且已連線到網路。

  2. 請確認您有 Active Directory 網域控制站的網路連線。

  3. 在 Exchange Server Analyzer 中指定 Active Directory 網域控制站。

  4. 使用 PING 命令檢查是否可以連接 Exchange Server 電腦。

  5. 若有裝置防火牆，檢查 RPC 通訊埠是否被封鎖。

  6. 檢查執行 Exchange Server Analyzer 的帳戶之權限。執行 Exchange Server Analyzer 的帳戶，在所掃描的每台 Exchange Server 電腦上都必須擁有本機 Administrator 權限。

若需網路連線問題的詳細資訊，請參閱 Microsoft 知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

若需 Exchange Server Analyzer 連線問題的詳細資訊，請參閱＜Microsoft Exchange Server Best Practices Analyzer 工具疑難排解連線問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56285)。

若需有關通訊埠需求的詳細資訊，請參閱知識庫文章 - 832017＜Windows Server 系統的服務概觀及網路通訊埠需求＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)。


沒有可用於 SMTP 執行個體名稱檢查的伺服器
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-07-07

Microsoft® Exchange Server Analyzer 工具會針對遠端傳遞佇列中郵件的傳送目的地，嘗試識別並建置該遠端伺服器的完整網域名稱 (FQDN)、IP 位址及網域名稱之清單。

遠端伺服器之 FQDN、IP 位址及網域名稱清單的建置流程如下：

  • 查詢簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器之 Active Directory® 目錄服務物件的 msExchSmtpFullyQualifiedDomainName 內容。

    附註：
    接著在查詢所指定的目標 Bridgehead 伺服器時，就會從路由群組連接器目錄物件的 msExchTargetBridgeheadServersDN 內容中讀取 msExchSmtpFullyQualifiedDomainName 內容
  • 針對 SMTP 連接器的指定智慧主機，查詢 SMTP 連接器 Active Directory 物件的 msExchSmtpSmartHost 內容。

  • 針對任何遠端伺服器直接連線，查詢 ExchangeLink Microsoft Windows® Management Instrumentation (WMI) 類別的 LinkName 內容。

如果 Exchange Server Analyzer 判定嘗試建置此清單的動作未產生任何項目，Exchange Server Analyzer 就會顯示錯誤。

這個錯誤表示：

  • 網路可能時斷時續，或 Active Directory 連線有問題，因而導致郵件流程問題。

  • 執行 Exchange Server Analyzer 的帳戶可能沒有查詢此項資訊的足夠權限。

更正此錯誤

  1. 確定已啟動 Exchange Server 電腦，且已連線到網路。

  2. 請確認您有 Active Directory 網域控制站的網路連線。

  3. 在 Exchange Server Analyzer 中指定 Active Directory 網域控制站。

  4. 使用 PING 命令檢查是否可以連接 Exchange Server 電腦。

  5. 若有裝置防火牆，檢查 RPC 通訊埠是否被封鎖。

  6. 檢查執行 Exchange Server Analyzer 的帳戶之權限。執行 Exchange Server Analyzer 的帳戶，在所掃描的每台 Exchange Server 電腦上都必須擁有本機 Administrator 權限。

若需網路連線問題的詳細資訊，請參閱 Microsoft 知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

若需 Exchange Server Analyzer 連線問題的詳細資訊，請參閱＜Microsoft Exchange Server Best Practices Analyzer 工具疑難排解連線問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56285)。

若需有關通訊埠需求的詳細資訊，請參閱知識庫文章 - 832017＜Windows Server 系統的服務概觀及網路通訊埠需求＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)。


非預設的路由服務快取設定
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定路由服務快取的預設設定是否已變更：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\

如果 Exchange Server Analyzer 發現已手動建立 ServerCacheRefreshInterval 登錄值，而且變更了預設的 Exchange Server 二進位檔設定 900，就會顯示警告。依預設，ServerCacheRefreshInterval 登錄值不是由 Exchange Server 安裝所建立。不過，若要變更預設的路由服務快取設定，可以在安裝 Exchange Server 後，手動建立 ServerCacheRefreshInterval 登錄值。如果手動建立登錄值，且登錄值的設定不正確，則 Exchange 伺服器可能會遇到郵件流程問題。

建議您在慎重考慮後，才建立或修改 ServerCacheRefreshInterval 登錄值。Exchange Server 二進位檔中的預設值經過謹慎的選擇，可讓大部分 Exchange Server 環境獲得最佳效能。一般的最佳作法是解決問題的根本來源，而不是手動設定登錄來修改 Exchange Server 上的預設行為。為了遵守最佳作法，如果 ServerCacheRefreshInterval 登錄值已存在，則您可以刪除此登錄值，將 Exchange 伺服器設回路由服務快取的預設二進位檔設定。不過，請視 Exchange Server 自訂組態設定或 Exchange 環境來決定。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不過，您可能想要藉由編輯登錄將登錄值變回預設設定。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關執行此動作的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要更正此警告

  1. 依序按一下 [開始]、[執行]，輸入 Regedit，然後按一下 [確定]。

  2. 在主控台樹狀目錄中，尋找並按一下下列登錄機碼： HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\RESvc\Parameters\

  3. 在詳細資料窗格中的 ServerCacheRefreshInterval 登錄值上按一下滑鼠右鍵。將數值資料變更為 900。

  4. 此外，您可以選擇在詳細資料窗格中的 ServerCacheRefreshInterval 登錄值上按一下滑鼠右鍵，再按 [刪除]。按一下對話方塊中的 [是]，確認刪除登錄值。

  5. 重新啟動 Exchange 伺服器。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關編輯 Microsoft Windows 登錄的詳細資訊，請參閱下列微軟知識庫文件：

  • 322755＜如何備份、編輯和還原 Windows 2000 的登錄＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756＜如何在 Windows XP 和 Windows Server 2003 中備份、編輯及還原登錄＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)。


非預設的 SMTP LdapRequestTimeLimit 登錄值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更預設的 LdapRequestTimeLimit：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

如果 Exchange Server Analyzer 發現已手動建立 LdapRequestTimeLimit 登錄值，以變更預設的 Exchange 伺服器二進位設定值 (600 秒)，就會顯示非預設值的警告訊息。依預設，LdapRequestTimeLimit 登錄值不是由 Exchange Server 安裝所建立。不過，若要變更單一 LDAP 要求在佇列中等候的時間上限 (秒)，可以在安裝 Exchange Server 之後，手動建立 LdapRequestTimeLimit 登錄值。如果手動建立登錄值，且登錄值的設定不正確，則 Exchange 伺服器可能會遇到郵件傳輸問題。

建議您在慎重考慮後，才建立或修改 LdapRequestTimeLimit 登錄值。Exchange 伺服器二進位檔中的預設值經過謹慎的選擇，可讓大部分 Exchange 伺服器環境獲得最佳效能。一般的最佳作法是解決問題的根本來源，而不是手動設定登錄來修改 Exchange Server 上的預設行為。為了遵守最佳作法，如果 LdapRequestTimeLimit 登錄值已存在，則您可以刪除此登錄值，將 Exchange 伺服器設回預設的二進位檔設定。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不過，您可能想要藉由編輯登錄將登錄值變回預設設定。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關執行此動作的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要更正此警告

  1. 依序按一下 [開始]、[執行]，輸入 Regedit，然後按一下 [確定]。

  2. 在主控台樹狀目錄中，尋找並按一下下列登錄機碼： HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. 在詳細資料窗格中的 LdapRequestTimeLimit 登錄值上按一下滑鼠右鍵。將數值資料變更為 600。

  4. 此外，您可以選擇在詳細資料窗格中的 LdapRequestTimeLimit 登錄值上按一下滑鼠右鍵，然後按一下 [刪除]。按一下對話方塊中的 [是]，確認刪除登錄值。

  5. 重新啟動 Exchange 伺服器。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關編輯 Microsoft Windows 登錄的詳細資訊，請參閱下列微軟知識庫文件：

  • 322755＜HOW TO：備份、編輯和還原 Windows 2000 的登錄＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756＜如何在 Windows XP 和 Windows Server 2003 中備份、編輯及還原登錄＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


非預設的 SMTP LdapResultTimeout 登錄值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更預設的 LdapResultTimeout：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

如果 Exchange Server Analyzer 發現已手動建立 LdapResultTimeout 登錄機碼，而且變更了預設的 Exchange 伺服器二進位檔設定 (即 121 秒)，就會顯示非預設的警告訊息。在預設的情況下，LdapResultTimeout 登錄機碼不是由 Exchange Server 安裝所建立。不過，可以在安裝 Exchange Server 之後手動建立 LdapResultTimeout 登錄機碼，以變更逾時值。LdapResultTimeout 是 LDAP 完成執行緒 (用於分類程式的 LDAP 連線) 等候處理的最大時間 (秒)。如果逾時到期且尚未從通用類別目錄伺服器接收到新結果，則擱置的搜尋會因 LDAP_SERVER_DOWN 連線失效而失敗。然後此處理程序就會將這些擱置的搜尋重新發出到新連線。如果手動建立登錄值，且登錄值的設定不正確，則 Exchange 伺服器可能會遇到郵件傳輸問題。

建議您在慎重考慮後，才建立或修改 LdapResultTimeout 登錄值。Exchange Server 二進位檔中的預設值經過謹慎的選擇，可讓大部分 Exchange Server 環境獲得最佳效能。一般的最佳作法是解決問題的根本來源，而不是手動設定登錄來修改 Exchange 上的預設行為。為了遵守最佳作法，如果 LdapResultTimeout 登錄值已存在，則您可以刪除此登錄值，將 Exchange 伺服器設回預設的二進位檔設定。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不過，您可能想要藉由編輯登錄將登錄值變回預設設定。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關執行此動作的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要更正此警告

  1. 依序按一下 [開始]、[執行]，輸入 Regedit，然後按一下 [確定]。

  2. 在主控台樹狀目錄中，尋找並按一下下列登錄機碼： HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. 在詳細資料窗格中的 LdapResultTimeout 登錄值上按一下滑鼠右鍵。將數值資料變更為 121。

  4. 此外，您可以選擇在詳細資料窗格中的 LdapResultTimeout 登錄值上按一下滑鼠右鍵，然後按一下 [刪除]。按一下對話方塊中的 [是]，確認刪除登錄值。

  5. 重新啟動 Exchange 伺服器。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關編輯 Microsoft Windows 登錄的詳細資訊，請參閱下列微軟知識庫文件：

  • 322755＜如何備份、編輯和還原 Windows 2000 的登錄＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756＜如何在 Windows XP 和 Windows Server 2003 中備份、編輯及還原登錄＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


非預設的 SMTP MaxConnectionRetries 登錄值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更預設的 MaxConnectionRetries：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

如果 Exchange Server Analyzer 發現已手動建立 MaxConnectionRetries 登錄值，而且變更了預設的 Exchange Server 二進位檔設定 (20)，就會顯示非預設的警告訊息。依預設，MaxConnectionRetries 登錄值不是由 Exchange Server 安裝所建立。不過，若要變更 MaxConnectionRetries 登錄值，可以在安裝 Exchange Server 後，手動建立該值。MaxConnectionRetries 值會設定允許單一分類因其 LDAP 連線失敗，而在新連線上重新發出的最大次數。MaxConnectionRetries 連線分類會在失敗後，進入重試佇列。如果手動建立登錄值，且登錄值的設定不正確，則 Exchange Server 可能會遇到郵件傳輸問題。

建議您在慎重考慮後，才建立或修改 MaxConnectionRetries 登錄值。Exchange Server 二進位檔中的預設值經過謹慎的選擇，可讓大部分 Exchange Server 環境獲得最佳效能。一般的最佳作法是解決問題的根本來源，而不是手動設定登錄來修改 Exchange Server 上的預設行為。為了遵守最佳作法，如果 MaxConnectionRetries 登錄值已存在，則您可以刪除此登錄值，將 Exchange Server 設回預設的二進位檔設定。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不過，您可能想要藉由編輯登錄將登錄值變回預設設定。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關執行此動作的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要更正此警告

  1. 依序按一下 [開始]、[執行]，輸入 Regedit，然後按一下 [確定]。

  2. 在主控台樹狀目錄中，尋找並按一下下列登錄機碼： HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. 在詳細資料窗格中的 MaxConnectionRetries 登錄值上按一下滑鼠右鍵。將值變更為 20。

  4. 此外，您可以選擇在詳細資料窗格中的 MaxConnectionRetries 登錄值上按一下滑鼠右鍵，然後按一下 [刪除]。按一下對話方塊中的 [是]，確認刪除登錄值。

  5. 重新啟動 Exchange Server。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞。(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)

若需有關編輯 Microsoft Windows 登錄的詳細資訊，請參閱下列微軟知識庫文件：

  • 322755＜如何備份、編輯和還原 Windows 2000 的登錄＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756＜如何在 Windows XP 和 Windows Server 2003 中備份、編輯及還原登錄＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


非預設的 SMTP MaxLdapConnections 登錄值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更預設的 MaxLdapConnections：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

如果 Exchange Server Analyzer 發現已手動建立 MaxLdapConnections 登錄值，而且變更了預設的 Exchange 伺服器二進位檔設定 (8)，則 Exchange Server Analyzer 會顯示非預設的警告訊息。在預設的情況下，MaxLdapConnections 登錄值不是由 Exchange 安裝所建立。不過，若要變更 MaxLdapConnections 登錄值，可以在安裝 Exchange 後，手動建立該值。MaxLdapConnections 值設定分類程式開啟的單一通用類別目錄伺服器之 LDAP 連線數目上限。如果手動建立登錄值，且登錄值的設定不正確，則 Exchange 伺服器可能會遇到郵件傳輸問題。

注意：
MaxLdapConnections 登錄值應始終與 HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters\MaxPoolThreads 登錄值設定的值相符。

建議您在慎重考慮後，才建立或修改 MaxLdapConnections 登錄值。Exchange 伺服器二進位檔中的預設值經過謹慎的選擇，可讓大部分 Exchange 伺服器環境獲得最佳效能。一般的最佳作法是解決問題的根本來源，而不是手動設定登錄來修改 Exchange Server 上的預設行為。為了遵守最佳作法，如果 MaxLdapConnections 登錄值已存在，則您可以刪除此登錄值，將 Exchange 伺服器設回預設的二進位檔設定。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不過，您可能想要藉由編輯登錄將登錄值變回預設設定。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關執行此動作的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要更正此警告

  1. 依序按一下 [開始]、[執行]，輸入 Regedit，然後按一下 [確定]。

  2. 在主控台樹狀目錄中，尋找並按一下下列登錄機碼： HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. 在詳細資料窗格中的 MaxLdapConnections 登錄值上按一下滑鼠右鍵。將數值資料變更為 8。

  4. 此外，您可以選擇在詳細資料窗格中的 MaxLdapConnections 登錄值上按一下滑鼠右鍵，然後按一下 [刪除]。按一下對話方塊中的 [是]，確認刪除登錄值。

  5. 重新啟動 Exchange 伺服器。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞。(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)

若需有關編輯 Microsoft Windows 登錄的詳細資訊，請參閱下列微軟知識庫文件：

  • 322755＜如何備份、編輯和還原 Windows 2000 的登錄＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756＜如何在 Windows XP 和 Windows Server 2003 中備份、編輯及還原登錄＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


非預設的 SMTP MaxPendingSearches 登錄值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更預設的 MaxPendingSearches：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

如果 Exchange Server Analyzer 發現已手動建立 MaxPendingSearches 登錄值，而且變更了預設的 Exchange 伺服器二進位檔設定 (60)，則 Exchange Server Analyzer 會顯示非預設的警告訊息。依預設，MaxPendingSearches 登錄值不是由 Exchange Server 安裝所建立。不過，若要變更 MaxPendingSearches 登錄值，可以在安裝 Exchange Server 後，手動建立該值。MaxPendingSearches 值會設定針對特定通用類別目錄伺服器，分類程式一次保留的未處理 LDAP 搜尋數。在 SP3 之前的 Exchange 2000 Server 中，每個連線擱置的搜尋數目上限是 1024。Exchange 2000 Server SP3 及 Exchange Server 2003 中的預設值設為 60。例如，將此值從預設的 60 變更為 30，會減少分類程式針對通用類別目錄伺服器保留的整體 LDAP 搜尋數目。

如果手動建立登錄值，且登錄值的設定不正確，則 Exchange 伺服器可能會遇到郵件傳輸問題。

建議您在慎重考慮後，才建立或修改 MaxPendingSearches 登錄值。Exchange 伺服器二進位檔中的預設值經過謹慎的選擇，可讓大部分 Exchange 伺服器環境獲得最佳效能。一般的最佳作法是解決問題的根本來源，而不是手動設定登錄來修改 Exchange 上的預設行為。為了遵守最佳作法，如果 MaxPendingSearches 登錄值已存在，則您可以刪除此登錄值，將 Exchange 伺服器設回預設的二進位檔設定。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不過，您可能想要藉由編輯登錄將登錄值變回預設設定。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關執行此動作的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要更正此警告

  1. 依序按一下 [開始]、[執行]，輸入 Regedit，然後按一下 [確定]。

  2. 在主控台樹狀目錄中，尋找並按一下下列登錄機碼： HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. 在詳細資料窗格中的 MaxPendingSearches 登錄值上按一下滑鼠右鍵。將數值資料變更為 60。

  4. 此外，您可以選擇在詳細資料窗格中的 MaxPendingSearches 登錄值上按一下滑鼠右鍵，然後按一下 [刪除]。按一下對話方塊中的 [是]，確認刪除登錄值。

  5. 重新啟動 Exchange 伺服器。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關編輯 Microsoft Windows 登錄的詳細資訊，請參閱下列微軟知識庫文件：

•322755＜HOW TO：備份、編輯和還原 Windows 2000 的登錄＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

•322756＜如何在 Windows XP 和 Windows Server 2003 中備份、編輯及還原登錄＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


非預設的 SMTP MaxSearchBlockSize 登錄值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定預設的 MaxSearchBlockSize 是否已變更：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

如果 Exchange Server Analyzer 發現已手動建立 MaxSearchBlockSize 登錄值，而且變更了預設的 Exchange 伺服器二進位檔設定 (20)，則 Exchange Server Analyzer 會顯示非預設的警告訊息。依預設，MaxSearchBlockSize 登錄值不是由 Exchange Server 安裝所建立。不過，若要變更 MaxSearchBlockSize 登錄值，可以在安裝 Exchange Server 後，手動建立該值。MhelpsBlockSize 值會設定可作為單一 LDAP 搜尋一起提交之分類程式搜尋的最大數目。設定分類程式搜尋的最大數目，可協助簡化分類程式的搜尋篩選。

此處理程序可將擱置的搜尋重新發出到新的連線。如果手動建立登錄值，且登錄值的設定不正確，則 Exchange 伺服器可能會遇到郵件傳輸問題。

建議您在慎重考慮後，才建立或修改 MaxSearchBlockSize 登錄值。Exchange Server 二進位檔中的預設值經過謹慎的選擇，可讓大部分 Exchange 伺服器環境獲得最佳效能。一般的最佳作法是解決問題的根本來源，而不是手動設定登錄來修改 Exchange Server 上的預設行為。為了遵守最佳作法，如果 MaxSearchBlockSize 登錄值已存在，則您可以刪除此登錄值，將 Exchange 伺服器設回預設的二進位檔設定。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不過，您可能想要藉由編輯登錄將登錄值變回預設設定。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關執行此動作的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要更正此警告

  1. 依序按一下 [開始]、[執行]，輸入 Regedit，然後按一下 [確定]。

  2. 在主控台樹狀目錄中，尋找並按一下下列登錄機碼： HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. 在詳細資料窗格中的 MaxSearchBlockSize 登錄值上按一下滑鼠右鍵。將數值資料變更為 20。

  4. 此外，您可以選擇在詳細資料窗格中的 MaxSearchBlockSize 登錄值上按一下滑鼠右鍵，然後按一下 [刪除]。按一下對話方塊中的 [是]，確認刪除登錄值。

  5. 重新啟動 Exchange 伺服器。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關編輯 Microsoft Windows 登錄的詳細資訊，請參閱下列微軟知識庫文件：

  • 322755＜如何備份、編輯和還原 Windows 2000 的登錄＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756＜如何在 Windows XP 和 Windows Server 2003 中備份、編輯及還原登錄＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


非預設的 SMTP TopoRecheckSecs 登錄值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更其預設值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\TopoRecheckSecs.

如果 Exchange Server Analyzer 發現 TopoRecheckSecs 的值不等於預設值 (900 秒)，就會顯示非預設的組態訊息。Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要任何動作。因為 DSAccess 會使用 TopoRecheckSecs 登錄值來設定重建通用類別目錄清單的間隔，所以不正確的設定可能會造成效能降低。最佳作法是儘量讓 Exchange Server 使用預設組態設定。不過，如果此登錄值存在，則可能當初是在 Microsoft 產品支援服務的建議下新增及設定該值，以更正先前出現的問題。除非當初是在 Microsoft PSS 的建議或其他專家的指導下新增及設定此登錄值，否則您應考慮加以移除。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要刪除 TopoRecheckSecs 登錄機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess

  3. 在右窗格中，尋找並刪除 TopoRecheckSecs 值。

  4. 關閉登錄編輯程式。

  5. 若要讓此變更生效，請重新啟動 [系統服務員]。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關最佳化 Exchange Server 之通用類別目錄位置的詳細資訊，請參閱《瞭解及疑難排解目錄存取》(英文) (http://go.microsoft.com/fwlink/?LinkId=39012)。


未將非 Exchange 閘道伺服器設定為智慧主機
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-08-09

Microsoft® Exchange Server Analyzer 工具會針對 protocolCfgSMTPServer 物件類別的 distingushedName 屬性值查詢 Active Directory® 目錄服務，以便列出使用者指定的 Exchange 閘道上，所有簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器執行個體。

然後，Exchange Server Analyzer 會查詢 Active Directory，以取得每個找到的 msExchRoutingSMTPConnector 物件的 msExchSourceBridgeheadServersDN 與 routingList 屬性值，以判定 SMTP 連接器是否已正確將其中一個偵測到的 SMTP 虛擬伺服器執行個體，設定為 SMTP 位址空間的本機 Bridgehead。

最後，Exchange Server Analyzer 會查詢 Active Directory，以取得所有偵測到之 SMTP 連接器 (msExchRoutingSMTPConnector 物件) 的 msExchSmtpSmartHost 屬性值，以便判定是否已針對使用者定義的非-Exchange 閘道伺服器，將其中一個連接器指定為智慧主機。

若 Exchange Server Analyzer 判定未針對其中一個 SMTP 連接器，將使用者指定的非 Exchange 閘道伺服器設定為智慧主機，Exchange Server Analyzer 便會顯示警告。

此警告指出尚未明確從使用者指定的 Exchange 閘道伺服器設定路由至使用者指定的非 Exchange 閘道伺服器，而且非 Exchange 閘道的伺服器，可能會自動將郵件路由至組織外部。

若要解決此問題，請指定非 Exchange 閘道伺服器作為 SMTP 連接器的智慧主機。

若要檢視和設定智慧主機設定

  1. 開啟 [Exchange 系統管理員]。

  2. 依序展開 [伺服器]、Exchange 伺服器、[通訊協定] 與 [SMTP]。

  3. 在 SMTP 虛擬伺服器 (例如，[預設 SMTP 虛擬伺服器]) 上按一下滑鼠右鍵，並選取 [內容]。

  4. 選取 [傳遞] 索引標籤，然後按一下 [進階]。

  5. 輸入您要使用的智慧主機。您可以利用完整格式的網域名稱或 IP 位址來識別智慧主機。如果使用 IP 位址，則必須使用方括弧括住 ([ ])。Exchange 會先檢查伺服器名稱，再檢查 IP 位址。方括弧表示值為 IP 位址。因此會略過 DNS 查閱。

  6. 如果這是執行 Exchange 2000 Server 的伺服器，請自行決定選取 [在傳送到智慧主機之前，嘗試直接傳遞] 核取方塊。

  7. 按一下 [確定] 來儲存變更，再按一下 [確定] 來關閉 SMTP 虛擬伺服器的 [內容] 對話方塊。

若需如何設定智慧主機連接器的詳細資訊，請參閱 Microsoft 知識庫文章 821911＜如何設定 Exchange Server 2003 來使用智慧主機 IP 位址＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821911)。

若需如何使用 SMTP 連接器的詳細資訊，請參閱 Microsoft 知識庫文章 294736 ＜在 Exchange 2000 建立 SMTP 連接器的時機＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=294736)。

若需有關 SMTP 連接器的詳細資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47579)。


分類程式可能超載
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-09-06

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。效能資料收集引擎可收集來自 SMTP Server 效能物件的 Cat:Messages submitted/sec 及 Cat:Categorizations completed/sec 效能計數器的資料，以分析效能資料。

Cat:Messages submitted/sec 效能計數器顯示每秒提交給分類程式的郵件數目，Cat:Categorizations completed/sec 則顯示每秒完成分類的速率。

Exchange Server Analyzer 會比較這兩個計數器的平均總數，以判定持續提交的郵件是否超過已處理的郵件。

如果 Exchange Server Analyzer 判定每秒提交給分類程式的郵件平均總數比每秒完成的郵件平均總數多出兩封郵件，則 Exchange Server Analyzer 會顯示警告。

分類程式會執行下列核心作業：

  • 解析及驗證所有收件者。

  • 判定對所有收件者的限制。

  • 展開通訊群組清單 (如果那是必需的)。

  • 判定郵件是本機傳遞還是遠端傳遞。

此警告指出分類程式可能處於壓力下。應該檢查可能的原因，並在適時解決問題。

分類程式壓力可能是由於下列原因而需要處理許多郵件所引起的：

  • 未經同意的廣告郵件 (UCE) 或垃圾郵件。

  • 病毒擴散。

  • 伺服器效能問題。

若要更正此警告：

  • 判定分類程式的壓力是原先預期的，或是來自一般的負載。如果分類程式的壓力是來自預期的負載，請檢閱這些 Microsoft TechNet 文章中的 Exchange 效能指引。

    • 《Exchange Server 2003 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。

    • 《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)。

  • 若分類程式的壓力並非來自預期的負載，請檢查可能產生負載的病毒疫情或垃圾郵件。


可能是閘道問題
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-08-09

Microsoft® Exchange Server Analyzer 工具會從執行 Exchange Server 的伺服器傳送測試郵件至使用者定義的外部帳戶。然後，Exchange Server Analyzer 會掃描伺服器的郵件追蹤記錄檔，以判定在傳遞測試郵件時是否發現任何問題。

進行此掃描時，Exchange Server Analyzer 會查詢 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 類別 (位於 root\MicrosoftExchangeV2 命名空間下) 的 EntryType 內容，以判定建立一或數筆郵件追蹤記錄項目的原因。

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • 可以順利掃描郵件追蹤記錄檔。

  • 測試郵件並未順利從佇列轉送出去。

  • 未產生未傳遞回報 (NDR)。

  • EntryType 內容存在 1034 值。

  • 郵件已到達指定的本機 Exchange 輸出閘道伺服器。

此錯誤可能指出，使用者指定的本機 Exchange 輸出閘道伺服器與遠端伺服器之間有連線問題。

若要解決此問題，請使用 NSlookup 公用程式來檢閱網域名稱系統 (DNS) 解析的可能問題。對於像是無法存取主機錯誤的連線與通訊協定問題，請使用 Telnet.exe 嘗試連接目的電腦。若要疑難排解通訊協定錯誤，請增加簡易郵件傳送通訊協定 (SMTP) 元件之 MSExchangeTransport 服務的診斷記錄，然後檢閱記錄檔以找出錯誤。或者，您可以使用網路監視器 (Netmon.exe) 工具來取得網路連線錯誤的相關資訊。

若需如何修改記錄設定的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中＜疑難排解郵件流程及 SMTP＞一節的＜如何修改 MSExchangeTransport 的記錄設定＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

若需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  • Microsoft 知識庫文章 821877＜SMTP 及 X400 佇列內容索引標籤上的欄位說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821877)。

  • Microsoft 知識庫文章 264054＜XCON：瞭解 Exchange 2000 Server 中的佇列狀態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


可能有 Inetinfo 問題
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-09-06

Microsoft® Exchange Server Analyzer 工具包含效能資料收集引擎，可於執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上，用來查詢效能計數器物件。效能資料收集引擎會從 SMTP Server 效能物件的 Cat:Categorizations in progress 效能計數器收集資料，以便分析效能資料。

Cat:Categorizations in progress 效能計數器會顯示正在進行的分類數量。

針對此查詢，Exchange Server Analyzer 會在兩分鐘內每隔 6 秒擷取樣本一次。Exchange Server Analyzer 會在收集間隔期間報告效能計數器的平均值。

若 Exchange Server Analyzer 判定取樣期間進行的分類最小數量永不等於零，Exchange Server Analyzer 便會顯示警告。

分類程式會執行下列核心作業：

  • 解析及驗證所有收件者。

  • 判定對所有收件者的限制。

  • 展開通訊群組清單 (如果那是必需的)。

  • 判定郵件是本機傳遞還是遠端傳遞。

若伺服器的負載並不沉重，此警告可能是指出 Inetinfo.exe 處理程序，或 Inetinfo.exe 處理程序依存的資源已遭鎖死。

Inetinfo.exe 處理程序中會執行簡易郵件傳送通訊協定 (SMTP) 服務，而當郵件通過傳輸子系統時，SMTP 會大量使用網際網路資訊服務 (IIS) 資源。

兩個或更多處理程序 (或執行緒) 需要等待其他處理程序完成後，才能繼續處理程序時便會發生「鎖死」狀況。這會導致所有處理程序 (或執行緒) 停止回應 (當機)。鎖死期間，執行的處理程序永遠無法完成，而且會佔用系統資源。這會讓系統無法啟動其他工作。

若要更正此警告：

  • 判定分類程式的壓力來自預期負載，還是來自一般負載。若分類程式的負載並不沉重，請使用＜詳細資訊＞一節中的參考資源，來識別 Inetinfo.exe 處理程序或相關資源可能發生的效能問題。

  • 檢查是否已啟動並執行 Inetinfo.exe 處理程序。

  • 依照 Microsoft 知識庫文章 919791＜如何使用偵錯診斷工具，疑難排解 IIS 處理程序的 CPU 高使用量問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=919791) 中的偵錯指引，來檢查 Inetinfo.exe 的鎖死情況。

詳細資訊

若需 Inetinfo.exe 的詳細資訊，請參閱《Exchange Server 2003 技術參考手冊》中的 ＜網際網路資訊服務＞(http://go.microsoft.com/fwlink/?LinkId=72966)。

若需如何疑難排解鎖死處理程序的詳細資訊，請參閱 Microsoft 知識庫文章 919791＜如何使用偵錯診斷工具，疑難排解 IIS 處理程序的 CPU 高使用量問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=919791)。

若需 Exchange Server 效能的詳細資訊，請參閱《Exchange Server 2003 效能及延展性手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)。

若需如何疑難排解 Exchange Server 效能問題的詳細資訊，請參閱《Microsoft Exchange Server 效能疑難排解》(英文) (http://go.microsoft.com/fwlink/?LinkId=47588)。


可能是非閘道問題
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-08-09

Microsoft® Exchange Server Analyzer 工具會從執行 Exchange Server 的伺服器傳送測試郵件至使用者定義的外部收件者 SMTP 位址。然後，Exchange Server Analyzer 會掃描伺服器的郵件追蹤記錄檔，以判定在傳遞測試郵件時是否發現任何問題。

進行此掃描時，Exchange Server Analyzer 會查詢 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 類別 (位於 root\MicrosoftExchangeV2 命名空間下) 的 EntryType 內容，以判定建立一或數筆郵件追蹤記錄項目的原因。

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • 可以順利掃描郵件追蹤記錄檔。

  • 測試郵件並未順利從佇列轉送出去。

  • 並未產生未傳遞回報。

  • EntryType 內容存在 1034 值。

  • 郵件並未到達指定的本機 Exchange 輸出閘道伺服器。

此錯誤可能指出測試郵件仍在傳送伺服器的其中一個簡易郵件傳送通訊協定 (SMTP) 遠端傳遞佇列中，而且發生與佇列有關的問題。

遠端傳遞佇列保留預定進行遠端傳遞的郵件。佇列的名稱符合了遠端傳遞目的地。此目的地可能是連接器、伺服器，或是網域。

若要疑難排解通訊協定錯誤，請增加 SMTP 元件之 MSExchangeTransport 服務的診斷記錄，然後檢閱記錄中的錯誤。或者，您可以使用網路監視器 (Netmon.exe) 工具來取得網路連線錯誤的相關資訊。若要重現問題，您必須強制佇列再試一次。檢查事件日誌是否有與 Microsoft Exchange Information Store 服務相關的錯誤。

若需如何修改記錄設定的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中＜疑難排解郵件流程及 SMTP＞一節的＜如何修改 MSExchangeTransport 的記錄設定＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

若需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  • Microsoft 知識庫文章 821877＜SMTP 及 X400 佇列內容索引標籤上的欄位說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821877)。

  • Microsoft 知識庫文章 264054＜XCON：瞭解 Exchange 2000 Server 中的佇列狀態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


可能偵測到 SMTP Proxy
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-12-06

Microsoft® Exchange Server Analyzer 工具會嘗試傳送郵件至簡易郵件傳送通訊協定 (SMTP) 網域之郵件管理員帳戶或使用者定義的帳戶。

當 Exchange Server Analyzer 開啟與 SMTP 伺服器的通訊端連線時，應有下列預設回應：

"220 電腦名稱 .網域名稱 .com Microsoft ESMTP MAIL Service，版本:版本號碼已於日期時間 +0000 就緒"

如果 Exchange Server Analyzer 收到一個包含協力廠商特有字串的非預設回應，則 Exchange Server Analyzer 會顯示錯誤。

此錯誤指出可能有一部協力廠商 SMTP Proxy 伺服器正在遠端伺服器後面執行。

如果 Exchange Server 系統管理員並未刻意自訂預設 SMTP 橫幅，則此警告可能指出 Exchange Server 位於正在篩選 Exchange Server 延伸的簡易郵件傳送通訊協定 (ESMTP) 命令的 SMTP Proxy 後面。

如果篩選 Exchange Server ESMTP 命令，則 Exchange 效能可能會受到顯著的影響，因而產生 Microsoft 知識庫文章 320027＜無法在 Cisco PIX 防火牆後面傳送或接收電子郵件＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027) 所述的行為。

若需有關自訂的 SMTP 橫幅的詳細資訊，請參閱下列 Microsoft 知識庫文章：

  • 281224: ＜XCON：如何修改 SMTP 橫幅＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=281224)。


可能有分類程式效能問題
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-09-06

Microsoft® Exchange Server Analyzer 工具會針對簡易郵件傳送通訊協定 (SMTP) ProtocolName 執行個體的 TypePendingCategorization 屬性值，查詢 ExchangeLink Microsoft Windows® Management Instrumentation (WMI) 類別，以判定「正在等候目錄查閱的郵件」(MADL) SMTP 佇列中的郵件數目。

ExchangeLink WMI 類別內容會傳回關於郵件伺服器之間郵件處理連結 (佇列) 的資訊。連結可包括零或多個 ExchangeQueue 物件。此數目取決於連結上的目前郵件流量。

Exchange Server Analyzer 也包含效能資料收集引擎，可用來在執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上查詢效能計數器物件。

若 Exchange Server Analyzer 判定 MADL 佇列中目前具有超過五十封郵件，則 Exchange Server Analyzer 便會使用效能資料收集引擎，從 SMTP Server 效能物件的 Cat:Messages Categorized 與 Cat:Categorizations completed 效能計數器中收集資料，以便分析效能資料。

Cat:Messages Categorized 效能計數器會顯示分類程式已提交至佇列的郵件數目，而 Cat:Categorizations completed 效能計數器則會顯示提交至分類程式的已完成郵件總數。

分類程式會執行下列核心作業：

  • 解析及驗證所有收件者。

  • 判定對所有收件者的限制。

  • 展開通訊群組清單 (如果那是必需的)。

  • 判定郵件是本機傳遞還是遠端傳遞。

Exchange Server Analyzer 會檢查兩個計數器的平均總數，以判定其數目是否在取樣期間有所增加。

若下列條件為 true，Exchange Server Analyzer 便會顯示錯誤。

  • MADL 佇列中有五十或更多封郵件。

  • 表示所提交郵件傳送至下一個處理程序之進度的取樣期間中，Cat:Messages Categorized 效能計數器顯示有所增加。

  • 表示所提交郵件順利完成分類之進度的取樣期間中，Cat:Categorizations completed 效能計數器顯示有所增加。

此錯誤指出雖然分類程式已順利處理郵件，但是其佇列長度仍然很長，而且可能會對效能造成壞影響。

要求處理多封郵件，可能會影響分類程式效能，其原因如下：

  • 未經同意的廣告郵件 (UCE) 或垃圾郵件。

  • 病毒擴散。

  • 伺服器效能問題。

若要更正此警告：

  • 判定分類程式的壓力為預期負載，還是一般負載。若分類程式的壓力來自預期負載，請檢閱下列 Exchange 資源的 Exchang 效能指引：

    • 《Exchange Server 2003 效能疑難排解》(http://go.microsoft.com/fwlink/?LinkId=47588)

    • 《Exchange Server 2003 效能及延展性手冊》(http://go.microsoft.com/fwlink/?LinkId=47576)

  • 若分類程式的壓力並非來自預期的負載，請檢查可能產生負載的病毒疫情或垃圾郵件。


發現潛在的通訊群組擴充問題
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 Exchange 伺服器是否正在執行 Exchange Server 2003 Service Pack 2 (SP2)，且設定為在檢查傳遞限制時展開通訊群組。

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

  • 此項目的值若為 1，表示伺服器已設定為在檢查傳遞限制時展開通訊群組。

  • 此項目的值若為 2，則表示伺服器已設定為在檢查傳遞限制時不展開通訊群組。

如果 Exchange Server Analyzer 發現伺服器已設定為在檢查傳遞限制時展開通訊群組，則 Exchange Server Analyzer 會檢查伺服器事件日誌，以判定過去 24 小時是否同時發生了錯誤事件 6004、6006 及 6008。

這些事件指出郵件受陷在郵件分類程式。郵件分類程式是進階佇列引擎的元件，它會將輕量型目錄存取通訊協定 (LDAP) 查詢傳送到通用類別目錄伺服器，以執行目錄查閱。

最後，Exchange Server Analyzer 會查詢 Active Directory® 目錄服務，以判定下列情況：

  • 樹系中是否有超過 500 個信箱已設定傳遞限制，以便至少有一個通訊群組用來允許或禁止收件者。

  • 路由群組連接器是否有基於通訊群組成員資格的傳遞限制，以及 Bridgehead 伺服器是否已啟用連接器限制檢查。

  • SMTP 連接器是否有基於通訊群組成員資格的傳遞限制，以及 Bridgehead 伺服器是否已啟用連接器限制檢查。

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • Exchange Server 2003 SP2 伺服器已設定為在檢查傳遞限制時展開通訊群組。

  • Exchange 伺服器在過去 24 小時已記錄事件 6004、6006 及 6008。

  • 樹系中有超過 500 個信箱已設定傳遞限制，以便至少有一個通訊群組用來允許或禁止收件者；「或」有一個路由群組連接器有基於通訊群組成員資格的傳遞限制，且 Bridgehead 伺服器已啟用連接器限制檢查；「或」SMTP 連接器有基於通訊群組成員資格的傳遞限制，且 Bridgehead 伺服器已啟用連接器限制檢查。

RestrictionMethod 值會決定分類程式處理限制的方式。分類程式的預設行為就是重複展開通訊群組，並對每一封通過系統的郵件檢查相關限制。當電子郵件的收件者設有限制以拒絕來自特定通訊群組或安全性群組之成員的郵件，Exchange Server 便必須展開該群組，以確定寄件者不是所限制群組的成員。Exchange Server 不會快取此群組展開的結果，因此必須每次執行。這會導致郵件保留在分類程式佇列中，因而可能會延遲郵件處理。

如果您將 RestrictionMethod 的值設為 2，此 Exchange 伺服器上的傳輸元件便不會在伺服器檢查限制時展開通訊群組的成員資格。此組態可提供限制檢查的最佳效能。此外，若要讓 RestrictionMethod 登錄項目生效，所有含有設有傳遞限制之使用者的通訊群組都必須是單層的。換言之，限制的通訊群組內不得含有通訊群組。如果限制的通訊群組含有通訊群組，則展開邏輯將無法運作。

若為在連接器限制中使用的通訊群組，建議您在沒有信箱的連接器 Bridgehead 伺服器上設定 RestrictionMethod 登錄項目值。至於 Active Directory 使用者限制，如果限制的通訊群組具有擴充伺服器，則建議您在擴充伺服器上建立 RestrictionMethod 登錄項目。

如需設定傳遞限制時將發生什麼情況的相關資訊，請參閱 Microsoft 知識庫文章 812298＜在根據通訊群組清單設定傳遞限制之後，傳遞速度變慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。

如需 RestrictionMethod 登錄值的相關資訊，請參閱 Microsoft 知識庫文章 895407＜在 Exchange Server 2003 中根據通訊群組設定傳遞限制後，傳遞到本機信箱及外部信箱的郵件速度比預期慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

如需 Exchange Server 2003 事件和錯誤的相關資訊，請參閱＜事件和錯誤訊息中心＞(英文) (http://go.microsoft.com/fwlink/?LinkId=34258)。

如需連接器限制的相關資訊，請參閱 Microsoft 知識庫文章 277872＜XCON：連接器傳遞限制無法正常運作＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872)。

如需 SMTP 佇列的相關資訊，請參閱 Microsoft 知識庫文章 884996＜郵件保留在 Exchange Server 2003 或 Exchange 2000 Server 的「正在等候目錄查閱的郵件」SMTP 佇列中＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=884996)。


發現潛在的郵件日誌收件者問題
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_NTLogEvent Microsoft Windows® Management Instrumentation (WMI) 類別，以判定過去 24 小時是否曾發生下列分類程式警告/錯誤事件的組合：

  • 事件 9004 及事件 9003

  • 事件 9035 及事件 6004

這些事件指出郵件受陷在郵件分類程式。郵件分類程式是進階佇列引擎的元件，它會將輕量型目錄存取通訊協定 (LDAP) 查詢傳送到通用類別目錄伺服器，以執行目錄查閱。

  • Exchange Server Analyzer 也會查詢 Active Directory® 目錄服務，以判定下列條件是否也有其中一項為真：

  • 針對儲存區指定的日誌收件者指向已刪除的物件。

  • 針對儲存區指定的日誌收件者指向沒有有效 mailNickname 的物件。

  • 針對儲存區指定的日誌收件者指向已停用的帳戶。

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • 已發生上列警告/錯誤事件組合。

  • 其中一項指定的日誌收件者條件也為真。

此錯誤表示 Exchange 環境中的日誌可能有問題，可能會造成郵件進入佇列。

如需如何更正此問題的相關資訊，請參閱與您問題相關之特定 Exchange Server Analyzer 文章。

  • 已刪除物件的日誌收件者點

  • 日誌收件者無效

  • 日誌收件者指向停用的帳戶

  • 如需 Exchange Server 2003 事件和錯誤的相關資訊，請參閱「事件和錯誤訊息中心」(英文) (http://go.microsoft.com/fwlink/?LinkId=34258)。


發現潛在的郵件日誌及儲存服務問題
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_NTLogEvent Microsoft Windows® Management Instrumentation (WMI) 類別，以判定過去 24 小時是否曾發生分類程式警告事件 9004：

Exchange Server Analyzer 也會查詢 Win32_Service WMI 類別，以判定已啟動還是已經停止 Microsoft Exchange Information Store 服務 (MSExchangeIS)。MSExchangeIS 執行個體除了 [已啟動] 以外的值，均代表已停止 MSExchangeIS 服務。

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • 過去 24 小時內，伺服器曾記錄分類程式警告 9003 事件。

  • MSExchangeIS 服務已停止。

此錯誤表示郵件日誌或 Microsoft Exchange Information Store 服務有問題，可能會造成郵件進入佇列。

若下列其中一項條件為真，就可能會發生此問題：

  • 已從 Active Directory® 目錄服務中刪除日誌收件者物件。

  • 作為 SMTP Bridgehead 伺服器的 Exchange Server 電腦上，未執行或已停用 Information Store 服務。

  • 已卸載 SMTP Bridgehead 伺服器上一或多個信箱儲存區。

若要解決此問題：

  • 請確定 SMTP Bridgehead 伺服器已啟用並執行 Information Store 服務。並確定已在 SMTP Bridgehead 伺服器上裝載信箱儲存區。

  • 請確定未從 Active Directory 中刪除信箱儲存區的日誌收件者物件。

判定信箱儲存區的日誌收件者

  1. 啟動 [Exchange 系統管理員]。

  2. 依序展開 [伺服器]、[<您的 Exchange 伺服器>] 及 [<儲存群組>]，然後用滑鼠右鍵按一下信箱儲存區，並選取 [內容]。

  3. 在 [一般] 索引標籤上，檢視 [封存由此儲存區的信箱所傳送或接收的所有郵件] 核取方塊下顯示的帳戶。此為目前當作日誌收件者的帳戶。

    附註：
    請確定已經驗證每個信箱儲存區物件的日誌收件者。
指定新的使用者信箱作為日誌收件者

  1. 啟動 [Exchange 系統管理員]。

  2. 依序展開 [伺服器]、[<您的 Exchange 伺服器>] 及 [<儲存群組>]，然後用滑鼠右鍵按一下信箱儲存區，並選取 [內容]。

  3. 於 [一般] 索引上，按一下 [封存由此儲存區的信箱所傳送或接收的所有郵件] 文字右方的 [瀏覽]，以指定信箱作為日誌信箱。

    附註：
    此信箱儲存區上寄件者的所有日誌郵件都會傳送到您指定的信箱。

如需此問題的相關資訊，請參閱已刪除物件的日誌收件者點。

如需 Exchange Server 2003 事件和錯誤的相關資訊，請參閱＜事件和錯誤訊息中心＞(英文) (http://go.microsoft.com/fwlink/?LinkId=34258)。

如需部署日誌解決方案的相關資訊，請參閱《Exchange Server 日誌》(英文) (http://go.microsoft.com/fwlink/?LinkId=47581)。


發現潛在的權限問題
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_NTLogEvent Microsoft Windows® Management Instrumentation (WMI) 類別，以判定過去 24 小時是否曾發生下列 Exchange Server 錯誤事件：

  • 事件 929。

  • 事件 9035。

  • 事件 9003、9004 及 6004 的組合。

發生 Exchange Server 錯誤事件 929 的原因是對 Active Directory® 目錄服務中的 Exchange Server 物件不具正確的存取權限。

Exchange Server 錯誤事件 9003、9004 及 6004 表示郵件受困在郵件分類程式中。郵件分類程式是進階佇列引擎的元件，它會將輕量型目錄存取通訊協定 (LDAP) 查詢傳送到通用類別目錄伺服器，以執行目錄查閱。

Exchange Server Analyzer 也會查詢 Active Directory，以判定與 Exchange 相關之物件的屬性是否表示那些物件發生權限繼承問題。

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • 下列一或多項事件在過去 24 小時已記錄在 [正在等候目錄查閱的郵件] 佇列中有佇列郵件的伺服器：

    • 事件 929。

    • 事件 9035。

    • 事件 9003、9004 及 6004 的組合。

  • 與 Exchange 相關的物件已遺失或沒有正確的存取權限。

此錯誤表示在 Exchange 環境中發生可能造成會郵件進入佇列的權限繼承問題。

若要解決此問題，請遵循 Microsoft Knowledge Base 907969＜已記錄事件 ID 929，而且郵件並未在 Exchange 2000 Server 組織中從某個郵件伺服器傳遞至另一個郵件伺服器＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=907969) 中的步驟。

如需 Exchange Server 2003 事件和錯誤的相關資訊，請參閱＜事件和錯誤訊息中心＞(英文) (http://go.microsoft.com/fwlink/?LinkId=34258)。


已識別為共用目的地的公用資料夾
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-10-04

Microsoft® Exchange Server Analyzer 工具會查詢 Exchange_Queue Windows® Management Instrumentation (WMI) 類別，以判定 SMTP 虛擬伺服器的簡易郵件傳送通訊協定 (SMTP) 佇列的下列屬性值。

LinkId | 指出包含佇列的連結的識別碼。
QueueId | 指出佇列的識別碼。
QueueName | 指出佇列的名稱。
VirtualMachine | 指出包含佇列的虛擬機器的名稱。
VirtualServerName | 指出佇列所在的虛擬伺服器的名稱。
MessageCount | 指出佇列中的郵件數目。

Exchange Server Analyzer 會使用這裡取得的資訊，查詢 Exchange_QueuedSMTPMessage WMI 類別，以取得佇列中的郵件的下列屬性值：

Recipients | 指出郵件的收件者。
Received | 指出郵件的接收時間戳記。
MessageId | 指出已佇列郵件的識別碼。
StateRetry | 指出對未順利傳遞的郵件重試傳輸。

最後，Exchange Server Analyzer 會使用這裡取得的資料，查詢 Active Directory® 目錄服務，以取得每一個 Recipient 物件的 distinguishedName 值。然後，Exchange Server Analyzer 會判斷收件者是使用者、通訊群組、公用資料夾或公用資料夾儲存區。

如果 Exchange Server Analyzer 判定至少有百分之 25 留在佇列的郵件是要送到特定公用資料夾 (出現在 To: 或 Cc: 欄位中)，Exchange Server Analyzer 會顯示警告。

如果 Exchange Server Analyzer 判定至少有百分之 50 留在佇列的郵件是要送到特定公用資料夾 (出現在 To: 或 Cc: 欄位中)，Exchange Server Analyzer 會顯示錯誤。

此警告或錯誤表示所識別的公用資料夾是留在 SMTP 佇列的郵件的共同目的地。

若要更正此問題，應該對公用資料夾進行如下的調查，找出可能導致郵件置於佇列的組態問題或其他異常狀況：

  • 確定公用資料夾物件屬性設定正確，而且在 Active Directory 包含正確值。

  • 檢閱公用資料夾物件的 Active Directory 權限，以確定設定正確無誤。

  • 尋找可能未經同意的廣告郵件 (UCE) 或垃圾郵件，或攻擊公用資料夾的病毒。

若需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkID=67875)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。


已識別為共用目的地的公用資料夾儲存區
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-10-04

Microsoft® Exchange Server Analyzer 工具會查詢 Exchange_Queue Windows® Management Instrumentation (WMI) 類別，以判定 SMTP 虛擬伺服器的簡易郵件傳送通訊協定 (SMTP) 佇列的下列屬性值。

LinkId | 指出包含佇列的連結的識別碼。
QueueId | 指出佇列的識別碼。
QueueName | 指出佇列的名稱。
VirtualMachine | 指出包含佇列的虛擬機器的名稱。
VirtualServerName | 指出佇列所在的虛擬伺服器的名稱。
MessageCount | 指出佇列中的郵件數目。

Exchange Server Analyzer 會使用這裡取得的資訊，查詢 Exchange_QueuedSMTPMessage WMI 類別，以取得佇列中的郵件的下列屬性值：

Recipients | 指出郵件的收件者。
Received | 指出郵件的接收時間戳記。
MessageId | 指出已佇列郵件的識別碼。
StateRetry | 指出正在對未順利傳遞的郵件重試傳輸。

最後，使用這裡取得的資料，查詢 Active Directory® 目錄服務，以取得每一個 Recipient 物件的 distinguishedName 值。然後，Exchange Server Analyzer 會判斷收件者是使用者、通訊群組、公用資料夾或公用資料夾儲存區。

如果 Exchange Server Analyzer 判定至少有百分之 25 留在佇列的郵件是要送給信箱位於相同公用資料夾儲存區的收件者 (出現在 To: 或 Cc: 欄位中)，Exchange Server Analyzer 會顯示警告。

如果 Exchange Server Analyzer 判定至少有百分之 50 留在佇列的郵件是要送給信箱位於相同公用資料夾儲存區的收件者 (出現在 To: 或 Cc: 欄位中)，Exchange Server Analyzer 會顯示錯誤。

此警告或錯誤表示所識別的公用資料夾儲存區是留在 SMTP 佇列的郵件的共同目的地。

若要更正此問題，應該對公用資料夾儲存區進行如下的調查，找出可能導致郵件置於佇列的組態問題、複寫風暴或其他異常狀況：

  • 確定儲存區物件屬性設定正確，而且在 Active Directory 包含正確值。

  • 檢閱儲存區物件的 Active Directory 權限，以取得正確的設定。

  • 尋找可能未經同意的廣告郵件 (UCE) 或垃圾郵件，或攻擊公用資料夾的病毒。

  • 檢查公用資料夾階層或內容的變更是否會在公用資料夾儲存區之間產生許多複寫。

若需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkID=67875)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  • Microsoft 知識庫文章 842273＜如何疑難排解 Exchange 2000 Server 和 Exchange Server 2003 中公用資料夾複寫的問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=842273)。


已啟用收件者篩選
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器物件的 msExchServerBindingsFiltering 內容是否表示已對 SMTP 虛擬伺服器執行個體啟用收件者篩選。

Exchange Server Analyzer 工具也會查詢 Active Directory，以判定 msExchRecipTurfListNames 或 msExchRecipTurfListOptions 內容是否表示也在通用設定層級啟用了收件者篩選。

如果 Exchange Server Analyzer 工具發現已同時在 SMTP 虛擬伺服器執行個體及通用設定層級啟用收件者篩選，就會顯示警告。

此警告表示已有效啟用收件者篩選。收件者篩選通常不是問題。然而，如果您正在進行此特定伺服器的郵件流程問題疑難排解，則可能需要驗證篩選器組態，或暫時停用收件者篩選，以判定是否錯誤封鎖了要傳送給有效收件者的郵件。

停用 SMTP 虛擬伺服器上的收件者篩選器

  1. 啟動 [Exchange 系統管理員]：按一下 [開始]，依序指向 [所有程式] 及 [Microsoft Exchange]，然後按一下 [系統管理員]。

  2. 在主控台樹狀目錄中，依序展開 [伺服器]、您要的伺服器、[通訊協定]，然後展開 [SMTP]。

  3. 以滑鼠右鍵按一下您要停用篩選器的 SMTP 虛擬伺服器，然後按一下 [內容]。

  4. 在 [內容] 的 [一般] 索引標籤中，按一下 [進階]。

  5. 在 [進階] 中，選取您要停用篩選器的 IP 位址，然後按一下 [編輯]。

在 [識別] 中，清除 [套用收件者篩選器] 核取方塊以停用篩選器。

  1. 如果您有多個虛擬伺服器，請針對每個要停用篩選器的虛擬伺服器，重複步驟 3 到 6。

如需如何設定收件者篩選器的相關資訊，請參閱 Microsoft Knowledge Base 823866＜如何在 Exchange 2003 中使用即時封鎖清單 (RBL) 設定連線篩選和設定收件者篩選＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823866)。

如需智慧型郵件篩選的相關資訊，請參閱「Exchange 智慧型郵件篩選器」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=21607)。


「遠端傳遞」佇列已凍結
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會查詢 ExchangeLink Microsoft Windows® Management Instrumentation (WMI) 類別，以判定簡易郵件傳送通訊協定 (SMTP) [遠端傳遞] 佇列的 StateFrozen 機碼值。

如果 Exchange Server Analyzer 在 Exchange server 上發現 [遠端傳遞] 佇列的 StateFrozen 機碼值設為 True，就會顯示錯誤。

佇列凍結表示該佇列的傳輸工作階段已停止。佇列凍結會導致郵件無法送出，但仍可以新增新的郵件。您可以使用每個連結佇列上的快顯功能表，手動變更連線狀態。使用 [強制連線] 命令將佇列狀態變更為作用中時，會立即啟用從該佇列傳送郵件的連線。

[遠端傳遞] 佇列存放了要送往遠端傳遞的郵件。佇列的名稱符合了遠端傳遞目的地。此目的地可能是連接器、伺服器，或是網域。

若要解決此問題，請使用 NSlookup 公用程式來檢閱網域名稱系統 (DNS) 解析的可能問題。對於像是無法存取主機錯誤的連線與通訊協定問題，請使用 Telnet.exe 嘗試連接目的電腦。若要疑難排解通訊協定錯誤，請增加 SMTP 通訊協定元件之 MSExchangeTransport 服務的診斷記錄，然後檢閱記錄中的錯誤。或者，您可以使用網路監視器 (Netmon.exe) 工具來取得網路連線錯誤的相關資訊。若要重現問題，您必須強制佇列再試一次。檢查事件日誌是否有與 Microsoft Exchange Information Store 服務相關的錯誤。

如需如何修改記錄設定的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中＜疑難排解郵件流程及 SMTP＞一節的＜如何修改 MSExchangeTransport 的記錄設定＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

如需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  • Microsoft 知識庫文章 821877＜SMTP 及 X400 佇列內容索引標籤上的欄位說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821877)。

  • Microsoft 知識庫文章 264054＜XCON：瞭解 Exchange 2000 Server 中的佇列狀態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


「遠端傳遞」佇列處於重試狀態
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會查詢 ExchangeLink Windows® Management Instrumentation (WMI) 類別，以判定簡易郵件傳送通訊協定 (SMTP) [遠端傳遞] 佇列的 StateRetry 機碼值。

如果 Exchange Server Analyzer 在 Exchange 伺服器上發現 [遠端傳遞] 佇列的 StateRetry 機碼值設為 True，就會顯示錯誤。

如果佇列處於重試狀態，這個狀態表示在先前嘗試處理佇列中的郵件時，發生了至少一個錯誤。您可以使用 [強制連線] 命令，將處於重試或已排定狀態的佇列變更為作用中。這導致佇列在運作時彷彿重試間隔已過，或是排定的時間已到。但是，此方法並不一定有效。

附註：
佇列的內容可能指出佇列處於「重試」的特定原因。

[遠端傳遞] 佇列存放了要送往遠端傳遞的郵件。佇列的名稱符合了遠端傳遞目的地。此目的地可能是連接器、伺服器，或是網域。

若要解決此問題，請使用 NSlookup 公用程式來檢閱網域名稱系統 (DNS) 解析的可能問題。對於像是無法存取主機錯誤的連線與通訊協定問題，請使用 Telnet.exe 嘗試連接目的電腦。若要疑難排解通訊協定錯誤，請增加 SMTP 通訊協定元件之 MSExchangeTransport 服務的診斷記錄，然後檢閱記錄中的錯誤。或者，您可以使用網路監視器 (Netmon.exe) 工具來取得網路連線錯誤的相關資訊。若要重現問題，您必須強制佇列再試一次。檢查事件日誌是否有與 Microsoft Exchange Information Store 服務相關的錯誤。

如需如何修改記錄設定的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中＜疑難排解郵件流程及 SMTP＞一節的＜如何修改 MSExchangeTransport 的記錄設定＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

如需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  • Microsoft 知識庫文章 821877＜SMTP 及 X400 佇列內容索引標籤上的欄位說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821877)。

  • Microsoft 知識庫文章 264054＜XCON：瞭解 Exchange 2000 Server 中的佇列狀態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


「遠端傳遞」佇列問題
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會從 Exchange 伺服器傳送測試郵件至簡易郵件傳送通訊協定 (SMTP) 網域的郵件管理員帳戶或使用者定義的帳戶，然後掃描伺服器的郵件追蹤記錄檔，以判定傳遞測試郵件時是否有發現任何問題。

進行此掃描時，Exchange Server Analyzer 會查詢 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 類別 (位於 root\MicrosoftExchangeV2 命名空間下) 的 EntryType 內容，以判定建立郵件追蹤記錄項目的原因。

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • 可以順利掃描郵件追蹤記錄檔。

  • 測試郵件並未順利從佇列轉送出去。

  • 未產生未傳遞報告 (NDR)。

  • EntryType 內容存在 1034 值。

此錯誤表示測試郵件仍在傳送伺服器的其中一個簡易郵件傳送通訊協定 (SMTP) [遠端傳遞] 佇列中，而且發生與佇列有關的問題。

[遠端傳遞] 佇列保留預定進行遠端傳遞的郵件。佇列的名稱符合了遠端傳遞目的地。此目的地可能是連接器、伺服器，或是網域。

若要解決此問題，請使用 NSlookup 公用程式來檢閱網域名稱系統 (DNS) 解析的可能問題。對於像是無法存取主機錯誤的連線與通訊協定問題，請使用 Telnet.exe 嘗試連接目的電腦。若要疑難排解通訊協定錯誤，請增加 SMTP 通訊協定元件之 MSExchangeTransport 服務的診斷記錄，然後檢閱記錄中的錯誤。或者，您可以使用網路監視器 (Netmon.exe) 工具來取得網路連線錯誤的相關資訊。若要重現問題，您必須強制佇列再試一次。檢查事件日誌是否有與 Microsoft Exchange Information Store 服務相關的錯誤。

如需如何修改記錄設定的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中＜疑難排解郵件流程及 SMTP＞一節的＜如何修改 MSExchangeTransport 的記錄設定＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

如需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  • Microsoft 知識庫文章 821877＜SMTP 及 X400 佇列內容索引標籤上的欄位說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821877)。

  • Microsoft 知識庫文章 264054＜XCON：瞭解 Exchange 2000 Server 中的佇列狀態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


重試分類
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會從 Exchange 伺服器傳送測試郵件至簡易郵件傳送通訊協定 (SMTP) 網域的郵件管理員帳戶或是使用者定義的帳戶，然後掃描伺服器的郵件追蹤記錄檔，以判定傳遞測試郵件時是否有發現問題。

進行此掃描時，Exchange Server Analyzer 會查詢 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 類別 (位於 root\MicrosoftExchangeV2 命名空間下) 的 EntryType 內容，以判定造成郵件追蹤記錄項目的原因。

如果 Exchange Server Analyzer 發現 EntryType 內容的值為 1032，則會顯示警告。

此警告表示，測試郵件位於已排定重試分類的佇列中。如果佇列處於重試狀態，這個狀態表示在先前嘗試處理佇列中的郵件時，發生了至少一個錯誤。您可以使用 [強制連線] 命令，將處於重試或已排定狀態的佇列變更為作用中。這導致佇列在運作時彷彿重試間隔已過，或是排定的時間已到。但是，此方法並不一定有效。

附註：
佇列的內容可能指出佇列處於「重試」的特定原因。

通常因為進階佇列引擎無法將郵件分類，所以郵件會累積在佇列中等待重試。進階佇列引擎可能無法存取通用類別目錄伺服器及存取收件者資訊，或是無法存取通用類別目錄伺服器，或通用類別目錄伺服器效能低落。此外，郵件也可能因為下列原因而累積：

  • 無法存取 Active Directory。

    附註：
    分類程式使用 Active Directory 來分類郵件。
  • 如果許多郵件佇列在前分類佇列裡，則 Active Directory 可能會負載過重。

  • 發生轉換失敗。分類程式也會控制內容轉換。

  • 郵件分類程式找不到信箱儲存區。

  • 如果重新安裝或移除了 SMTP，這可能會使下列 IIS Metabase 機碼失效：/smtpsvc/DsUseCat 及 /smtpsvc/vsi#/DsUseCat。

    附註：
    判定是否重新安裝或移除了 SMTP。

如果佇列處於 [重試] 狀態，請檢查佇列內容以判定原因。例如，如果佇列內容顯示類似「已發生 SMTP 錯誤」的訊息，則應該檢閱伺服器的事件日誌，找出任何 SMTP 錯誤。如果記錄中沒有事件，則應該增加 SMTP 通訊協定的記錄級別。

如需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  • Microsoft 知識庫文章 821877＜SMTP 及 X400 佇列內容索引標籤上的欄位說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821877)。

  • Microsoft 知識庫文章 264054＜XCON：瞭解 Exchange 2000 Server 中的佇列狀態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


重試本機傳遞
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-04

Microsoft® Exchange Server Analyzer 工具會從 Exchange 伺服器傳送測試郵件至簡易郵件傳送通訊協定 (SMTP) 網域的郵件管理員帳戶或使用者定義的帳戶，然後掃描伺服器的郵件追蹤記錄檔，以判定傳遞測試郵件時是否有發現任何問題。

進行此掃描時，Exchange Server Analyzer 會查詢 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 類別 (位於 root\MicrosoftExchangeV2 命名空間下) 的 EntryType 內容，以判定造成郵件追蹤記錄項目的原因。

如果 Exchange Server Analyzer 發現 EntryType 內容的值為 1037，就會顯示警告。

此警告表示先前嘗試處理 [本機傳遞] 佇列中的郵件時，發生了至少一個錯誤。

本機傳遞佇列包含了在 Exchange 伺服器上佇列等待本機傳遞至 Exchange Server 信箱或公用資料夾儲存區的郵件。

如果 Exchange 伺服器目前不接受本機傳遞的郵件，則郵件可能會累積在此佇列中。當郵件傳遞緩慢或斷斷續續時，可能表示有迴圈郵件或是效能問題。

您可以使用 [強制連線] 命令，將處於重試或已排定狀態的佇列變更為作用中狀態。這導致佇列在運作時彷彿重試間隔已過，或是排定的時間已到。但是，此方法並不一定有效。

附註：
佇列的內容可能指出佇列處於「重試」的特定原因。

若要解決此錯誤，請增加 MSExchangeIS 及 MSExchangeTransport 服務 SMTP 儲存區驅動程式元件的診斷記錄。

如需如何修改記錄設定的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中＜疑難排解郵件流程及 SMTP＞一節的＜如何修改 MSExchangeTransport 的記錄設定＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

如需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  • Microsoft 知識庫文章 821877＜SMTP 及 X400 佇列內容索引標籤上的欄位說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821877)。

  • Microsoft 知識庫文章 264054＜XCON：瞭解 Exchange 2000 Server 中的佇列狀態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


重試路由傳送
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會從 Exchange 伺服器傳送測試郵件至簡易郵件傳送通訊協定 (SMTP) 網域的郵件管理員帳戶或是使用者定義的帳戶，然後掃描伺服器的郵件追蹤記錄檔，以判定傳遞測試郵件時是否有發現問題。

進行此掃描時，Exchange Server Analyzer 工具會查詢 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 類別 (位於 root\MicrosoftExchangeV2 命名空間下) 的 EntryType 內容，以判定造成郵件追蹤記錄項目的原因。

如果 Exchange Server Analyzer 發現 EntryType 內容的值為 1035，則會顯示警告。

此警告表示，測試郵件位於已排定重試路由傳送的佇列中。如果佇列處於重試狀態，這個狀態表示在先前嘗試處理佇列中的郵件時，發生了至少一個錯誤。您可以使用 [強制連線] 命令，將處於重試或已排定狀態的佇列變更為作用中。這導致佇列在運作時彷彿重試間隔已過，或是排定的時間已到。但是，此方法並不一定有效。

附註：
佇列的內容可能指出佇列處於「重試」的特定原因。

如果存在 Exchange Server 路由問題，則郵件會累積在佇列中等待重試。郵件未能被路由傳送出去的原因是某個暫時性錯誤，亦即路由引擎並未順利初始化。郵件位於預先路由佇列中，等待重試或重新路由傳送。

若要解決此錯誤，請增加 MSExchangeTransport 服務的診斷記錄，以收集路由類別元件的相關資訊。請停用不必要的連接器限制，因為限制可能會導致伺服器效能大幅降低。您可能必須針對部份限制開啟 CheckConnectorRestrictions 登錄機碼。

如需如何修改記錄設定的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中＜疑難排解郵件流程及 SMTP＞一節的＜如何修改 MSExchangeTransport 的記錄設定＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

如需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  • Microsoft 知識庫文章 821877＜SMTP 及 X400 佇列內容索引標籤上的欄位說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821877)。

  • Microsoft 知識庫文章 264054＜XCON：瞭解 Exchange 2000 Server 中的佇列狀態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


已在 Metabase 中啟用反向 DNS 查閱，但未在 Active Directory 中相關聯的 SMTP 伺服器上啟用
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-01-17

Microsoft® Exchange Server Analyzer 工具會在網際網路資訊服務 (IIS) Metabase 中讀取下列屬性，以判定該屬性的值是否符合在 Active Directory® 目錄服務中為 msExchSmtpPerformReverseDnsLookup 屬性設定的值：

/LM/SmtpSvc/<SMTP virtual server instance>/EnableReverseDnsLookup

若 Exchange Server Analyzer 發現值不相符，就會顯示一則警告訊息。

如果 IIS Metabase 中的值不符合 Active Directory 中的值， 這表示 Active Directory 複寫有問題，或 Exchange 中的 Directory-service-to-Metabase-replication 元件 (DS2MB) 有問題。

DS2MB 處理程序的功能是將組態資訊從 Active Directory 傳輸到本機 Metabase。將這個組態儲存在本機 Metabase 中，而不是儲存在登錄內的原因，是要提高效能和延展性。在 Exchange 2000 Server 和 Exchange Server 2003 中，所有網際網路通訊協定 (SMTP、NNTP、POP3、IMAP4 及 HTTP) 都是當做 IIS 的元件執行。

DS2MB 處理程序每隔 15 分鐘會從 Active Directory 複製整個樹狀子目錄，並且不會改變樹狀子目錄的形狀。這是從 Active Directory 到 Metabase 的單向寫入；Metabase 絕不會寫入 Active Directory。

EnableReverseDnsLookup 內容及 msExchSmtpPerformReverseDnsLookup 屬性的值都可以是 TRUE 或 FALSE。值為 TRUE 表示 SMTP 虛擬伺服器將對所有內送郵件執行反向 DNS 查閱。值為 FALSE 則表示不執行反向 DNS 查閱。因為設定錯誤的 DNS 記錄或斷斷續續的網際網路連線可能會造成效能下降，因此 EnableReverseDnsLookup 內容及 msExchSmtpPerformReverseDnsLookup 屬性預設都會設為 FALSE。

如果 EnableReverseDnsLookup 內容已設為 TRUE (已啟用) 而 msExchSmtpPerformReverseDnsLookup 屬性已設為 FALSE (已停用)，則表示 Active Directory 與 IIS Metabase 沒有保持同步。如果問題是因為 DS2MB 處理程序失敗引起的，您可以執行下列適用您的 Exchange Server 版本之程序，更正問題。如果問題是局部或完全因為 Active Directory 複寫失敗引起的，您可以使用 Active Directory Replication Monitor 公用程式 (ReplMon.exe)，檢查 Active Directory 複寫的健全狀態。您可以在 Windows Server 光碟的 Windows® 支援工具中找到 ReplMon.exe。

若要在 Exchange Server 2003 上更正此錯誤

  1. 檢查應用程式事件日誌項目中，是否有來源為 MSExchangeMU 的項目存在。若 DS2MB 失敗，它會在 Exchange Server 2003 上記錄一個事件。

  2. 若看不到任何 DS2MB 失敗的項目，請使用 ReplMon 診斷 Active Directory 複寫。特別要注意您的 SMTP 虛擬伺服器使用的通用類別目錄伺服器。

  3. 若有看到 DS2MB 失敗項目，或者在您排除或解決 Active Directory 複寫問題之後，重新啟動 Exchange System Attendant 服務。

若要在 Exchange 2000 Server 上更正此錯誤

  1. 使用 ReplMon 診斷 Active Directory 複寫。特別要注意您的 SMTP 虛擬伺服器使用的通用類別目錄伺服器。

  2. 在您排除或解決 Active Directory 複寫問題之後，重新啟動 Exchange System Attendant 服務。

若需 Exchange 中反轉 DNS 查閱功能的相關資訊，請參閱微軟知識庫文件 - 297412＜The 'Perform Reverse DNS Lookup for Incoming Messages' Option Is for Host Name Resolution＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412)。

若需 SMTP 虛擬伺服器設定的詳細資訊，請參閱微軟知識庫文件 - 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) 及 268163＜XCON：＜How to Configure a SMTP Virtual Server Part 2＞ (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)。

若需 Active Directory 複寫作業的詳細資訊，請參閱微軟知識庫文件 - 232072＜啟始 Active Directory 直接複寫協力電腦之間的複寫＞ (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072)。

若需有關 DS2MB 處理程序的詳細資訊，請參閱微軟知識庫文件 - 240105＜XGEN:General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105)。


路由引擎：AttachedTimeout 參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已修改簡易郵件傳送通訊協定 (SMTP) 連接器路由邏輯的預設設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\AttachedTimeout

如果 Exchange Server Analyzer 發現 AttachedTimeout 登錄機碼存在，且設定的值大於 300，就會顯示非預設的組態訊息。

AttachedTimeout 登錄項目是 Exchange Server 的自訂組態設定，其可判定 ORG_INFO 封包傳送的頻率。每次路由用戶端未連接至路由伺服器時，使用者版本的拓撲將增加，並會使 ORG_INFO 封包在整個組織內廣播。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. 刪除 AttachedTimeout 登錄機碼。

  4. 關閉登錄編輯程式。

  5. 重新啟動 IIS Admin Service，使此變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 AttachedTimeout 登錄值的詳細資訊，請參閱知識庫文件 - 832281＜Exchange 2000 Server 和 Exchange Server 2003中的連結狀態問題和路由問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832281)。


路由引擎：BestAddressMatchOnly 參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已修改簡易郵件傳送通訊協定 (SMTP) 連接器路由邏輯的預設設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\BestAddressMatchOnly

如果 Exchange Server Analyzer 發現 BestAddressMatchOnly 登錄機碼存在，且設定的值大於 0，就會顯示非預設的組態訊息。

BestAddressMatchOnly 登錄項目是 Exchange Server 的自訂組態設定，它強制將傳送至特定網域的郵件經由特定連接器來路由傳送 (不論現有的限制為何)。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. 刪除 BestAddressMatchOnly 登錄機碼。

  4. 關閉登錄編輯程式。

  5. 重新啟動 IIS Admin Service，使此變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


Routing Engine：CheckConnectorRestrictions 參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已修改簡易郵件傳送通訊協定 (SMTP) 連接器路由邏輯的預設設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\CheckConnectorRestrictions

如果 Exchange Server Analyzer 發現 CheckConnectorRestrictions 登錄機碼存在，且設定的值大於 0，就會顯示非預設的組態訊息。

CheckConnectorRestrictions 登錄項目是 Exchange Server 的自訂組態設定，其允許在 Exchange Bridgehead 伺服器 (即所檢查之連接器的來源) 上執行限制檢查。連接器限制檢查預設為關閉，因為它會明顯影響到效能，尤其是在使用大量通訊群組的組態中。對於每封郵件而言，只要其收件者屬於通過系統的任一通訊群組之任一成員，就必須進行限制檢查。若已指定限制，但此登錄項目不存在，限制檢查就不會執行。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. 刪除 CheckConnectorRestrictions 登錄機碼。

  4. 關閉登錄編輯程式。

  5. 重新啟動 IIS Admin 服務。

  6. 在連接器的 [傳遞限制] 索引標籤上，重新啟用限制選項。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 CheckConnectorRestrictions 登錄值的詳細資訊，請參閱知識庫文件 - 277872＜XCON：Connector Delivery Restrictions May Not Work Correctly＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872)。


路由引擎：組態參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已修改 Exchange 路由引擎設定的 Active Directory® 目錄服務讀取間隔預設設定：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RESvc\Parameters\ReloadOsInterval

如果 Exchange Server Analyzer 發現已將 ReloadOsInterval 的數值資料設為 3600 之外的任意值，就會顯示非預設的組態訊息。

該 ReloadOsInterval 值用於指定更新執行 Exchange 之伺服器間路由連結狀態資訊的間隔。Exchange 使用路由連結狀態資訊，讓每部伺服器都可以判定最省力的郵件傳遞路由，同時判定組成路由的連接器是否在運作中。在預設的情況下，Exchange 伺服器每隔 3,600 秒 (一小時) 就會從 Active Directory 讀取連結狀態資訊一次。

在某些情況下，路由狀態資訊並不會動態傳播到整個 Exchange 組織內的各伺服器。組織中有些伺服器會使用過時，甚至是錯誤的路由狀態資訊繼續運作。此情況所產生的結果，包括了使用 WinRoute 工具 (Winroute.exe) 來檢視遠端路由群組時，將會看不到新的連接器。您可以使用 WinRoute 工具，確認目前正在傳播連結狀態資訊。若要確認正在傳播該資訊，請使用 WinRoute 工具，從 Exchange 組織內數個不同的位置來檢視連結狀態資訊，接著比較每個路由群組的版本號碼。WinRoute 工具會與 Exchange Server 電腦上的連結狀態通訊埠進行連線，然後抽選 Exchange 組織的連結狀態資訊。雖然連結狀態資訊是一連串的全域唯一識別碼 (GUID)，但 WinRoute 會將連接器和 Bridgehead 伺服器的 GUID 與 Active Directory 的物件比對，再將資訊以可閱讀的格式呈現。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\SYSTEM\CurrentControlSet\Services\RESvc\Parameters

  3. 在右窗格中，連按兩下 [ReloadOsInterval]。

  4. 在 [數值資料] 方塊中，輸入 3600，再按一下 [確定]。

  5. 關閉登錄編輯程式。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關路由及連結狀態資訊的詳細資訊，請參閱下列微軟知識庫文件：

  • 842026＜路由狀態資訊沒有正確地傳播到 Exchange 2000 Server 或 Exchange Server 2003 中的所有伺服器＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=842026)

  • 285130＜XCON: 連結狀態資訊＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285130)

若要下載可協助您判定路由主機已知之連結狀態資訊的工具 WinRoute，請參閱 "Exchange Server WinRoute" (英文) (http://go.microsoft.com/fwlink/?LinkId=25049)。


路由引擎：PollingInterval 參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已修改「簡易郵件傳送通訊協定 (SMTP)」連接器路由邏輯的預設設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\PollingInterval

如果 Exchange Server Analyzer 發現 PollingInterval 登錄機碼存在，且設定的值大於 300，就會顯示非預設的組態訊息。

PollingInterval 登錄項目是 Exchange Server 的自訂組態設定，有助於控制路由群組之間連結狀態流量的頻率，尤其是往返於路由群組內路由群組主機的流量。增加此設定可以防止連線失敗，但會讓您無法解決路由群組成員之間連結緩慢這個較大的問題。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. 刪除 PollingInterval 登錄機碼。

  4. 關閉登錄編輯程式。

  5. 重新啟動 IIS Admin Service，使此變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


路由引擎：StateChangeDelay 參數並非預設值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已修改簡易郵件傳送通訊協定 (SMTP) 連接器路由邏輯的預設設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\StateChangeDelay

如果 Exchange Server Analyzer 發現 StateChangeDelay 登錄機碼存在，且設定的值大於 0，就會顯示非預設的組態訊息。

StateChangeDelay 登錄項目是 Exchange Server 的自訂組態設定，其可協助控制連接器受標示為不可用的時間間隔，及控制由於連接器及伺服器狀態變更而產生的通知。如果將 StateChangeDelay 設為大於 0，則在此值設定的每個時間間隔中僅可將伺服器標示為可用或不可用一次。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. 刪除 StateChangeDelay 登錄機碼。

  4. 關閉登錄編輯程式。

  5. 重新啟動 IIS Admin Service，使此變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


路由引擎：SuppressStateChanges 參數不是預設值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已修改簡易郵件傳送通訊協定 (SMTP) 連接器路由邏輯的預設設定：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\SuppressStateChanges

如果 Exchange Server Analyzer 發現 SuppressStateChanges 登錄機碼存在，且設定的值大於 0，就會顯示非預設的組態訊息。

Exchange Server 2003 具有自動偵測連結狀態變更的功能。此資訊可用於通知執行 Exchange Server 2003 的其他伺服器，應使用替代路由而不是成本最低的主要路由。連結狀態資訊可以分為主要變更與次要變更。當系統管理員變更路由拓撲時 (例如，新增新的連接器或成本變更)，即為主要變更。當系統自動偵測到連結發生失敗或還原時，即為次要更新。

此功能在小型與中型組織中運作良好。不過，在大型的多站台環境中，大量網路變化可能會導致次要版本的連結更新氾濫。若要真正有效，必須將連結狀態資料廣播給組織中的所有伺服器。此外，當狀態變更時，會重新廣播整個連結狀態表格，這將導致要透過網路傳送大量資料。在此情況下，抑制次要連結狀態變更可能會很有用。SuppressStateChanges 登錄項目是用來抑制次要連結狀態變更的自訂組態設定。當 SuppressStateChanges 設為大於 0 時，會抑制此 Exchange Server 電腦上的所有連結狀態變更。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. 刪除 SuppressStateChanges 登錄機碼。

  4. 關閉登錄編輯程式。

  5. 重新啟動簡易郵件傳送通訊協定 (SMTP)、Microsoft Exchange Routing Engine 及 Microsoft Exchange MTA Stacks 服務，使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 SuppressStateChanges 登錄機碼的詳細資訊，請參閱下列微軟手冊：

  • 《Exchange Server 2003 傳輸及路由手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47579)

  • 《Exchange Server 2003 效能及延展性手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47576)


已設定通訊群組傳遞限制的路由群組連接器
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-09-06

Microsoft® Exchange Server Analyzer 工具在 Active Directory® 目錄服務中偵測到的每一個路由群組連接器物件 (msExchRoutingGroupConnector) 的下列屬性，以判定是否已根據通訊群組成員設定傳遞限制。

dLMemRejectPerms | 包含其成員可能不會透過此路由群組連接器傳送之通訊群組清單 (DL) 的網域名稱 (DN)。
dLMemSubmitPerms | 包含其成員可能會透過此路由群組連接器傳送之通訊群組清單 (DL) 的網域名稱 (DN)。

若 Exchange Server Analyzer 判定路由群組連接器已根據通訊群組成員設定傳遞限制，Exchange Server Analyzer 便會顯示警告。

此警告指出根據通訊群組成員設定的傳遞限制，可能會影響 Exchange 郵件流程的效能。

當您使用根據通訊群組成員來設定傳遞限制的路由群組連接器來傳送郵件時，郵件分類程式必須展開通訊群組的成員，並取得成員 DN 的完整清單，然後以該 DN 清單與寄件者 DN 清單進行比較。兩份清單的 DN 相符時，便會執行存取作業或拒絕作業。如果通訊群組是其他通訊群組中的巢狀通訊群組，則系統也會展開該巢狀通訊群組。

若要更正此警告：

  • 參考 Microsoft 知識庫文章 329171＜XADM：若設定的收件者已根據群組成員設定傳遞限制，則郵件傳遞的速度會變慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)，針對連接器限制設計專用的路由群組，並將之設定為本機路由群組。

  • 使用固定且更穩固的通用類別目錄伺服器作為連接器指定的 Bridgehead 伺服器。

  • 請參考 Microsoft 知識庫文章 812298＜根據通訊群組清單設定傳遞限制後，郵件傳遞的速度緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)，針對個別信箱而非通訊群組設定傳遞限制。

  • 考慮執行簡易郵件傳送通訊協定 (SMTP) 寄件者篩選。

  • 對於執行 Exchange Server 2003 Service Pack 2 (SP2) 或更新版本的伺服器，請考慮執行非階層式限制檢查。對於執行比 Exchange 2003 SP2 更舊之 Exchange 版本的伺服器，請考慮升級至 Exchange 2003 SP2。

詳細資訊

如需非階層式限制檢查的詳細資訊，請參閱考慮檢查非階層式限制。

若需 SMTP 寄件者篩選的詳細資訊，請參閱《Exchange Server 2003 系統管理手冊》中的＜如何啟用寄件者篩選＞(英文) (http://go.microsoft.com/fwlink/?LinkId=72967)。

如需通訊群組限制對 Exchange 郵件流程之影響的詳細資訊，請參閱下列 Microsoft 知識庫文章：

  • 329171＜XADM：若設定的收件者已根據群組成員設定傳遞限制，則郵件傳遞的速度會變慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)。

  • 895407＜在 Exchange Server 2003 中根據通訊群組設定傳遞限制後，將郵件傳遞到本機信箱及外部信箱的速度比預期慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 839949＜針對 Exchange 2000 Server 與 Exchange Server 2003 中的郵件傳輸與通訊群組進行疑難排解＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。


主要路由群組已刪除
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定每個路由群組容器的 msExchRoutingMasterDN 屬性值。如果 Exchange Server Analyzer 發現 msExchRoutingMasterDN 屬性值包含 "DEL:" 字串，就會顯示一則錯誤。

msExchRoutingMasterDN 屬性是單一值的屬性，可儲存作為每個路由群組的路由群組主機之 Exchange Server 電腦的辨別名稱。存在 "DEL:" 字串表示已使用 Active Directory 使用者及電腦工具刪除先前的路由群組主機。若沒有主要路由群組，Exchange 將無法正確更新或維護路由拓樸。

建立路由群組時，該路由群組中的第一部伺服器會被指派主要路由群組的角色。主要路由群組會維護該路由群組的目前連結狀態資訊，並且將資訊傳播至該路由群組內的其他伺服器。主要路由群組只會監視其本身的路由群組寫入 Active Directory 的路由組態。成員伺服器可以將任何連接器狀態或伺服器可用資訊，傳達給主要路由群組。例如，如果成員伺服器嘗試透過連接器和不同路由群組內的其他伺服器通訊，但是該連結卻無法使用，則成員伺服器就會立即通知主要路由群組。同樣地，當非主要伺服器收到新的連結狀態資訊時，它會立即將連接器狀態資訊傳輸至主要路由群組，其他伺服器才可以收到有關路由變更的資訊。

若要更正此錯誤

  1. 在 [Exchange 系統管理員] 中，在 [系統管理群組] 之下，展開 Administrative_Group，再展開 [路由群組]。

  2. 展開路由群組，然後按一下 [成員]。

  3. 在右窗格中，以滑鼠右鍵按一下要設定為主要路由群組的 Exchange 電腦，再按一下 [設定為主要]。

若需有關主要路由群組的詳細資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》(http://go.microsoft.com/fwlink/?linkid=47579)中的＜設定路由拓撲＞(英文)。


路由群組成員錯誤
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-08-21

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以取得 Routing Group 物件上 msExchRoutingGroupMembersBL 屬性的每一個值，以判定背面連結的伺服器是否屬於專用 Microsoft Exchange Server 2007 系統管理群組 ([Exchange 系統管理群組 (FYDIBOHF23SPDLT)])。

Exchange Server Analyzer 也會查詢 Routing Group 物件的 CN 屬性值，以判定值是否等於 Exchange 2007 路由群組預設值 ([Exchange 路由群組 (DWBGZMFD01QNBJR)])。

若下列條件為真，Exchange Server Analyzer 就會顯示錯誤：

  • 背面連結的伺服器屬於專用 Exchange 2007 系統管理群組 ([Exchange 系統管理群組 (FYDIBOHF23SPDLT)])。

  • 路由群組不是 Exchange 2007 路由群組預設值 ([Exchange 路由群組 (DWBGZMFD01QNBJR)])。

此錯誤指出可能已從 Exchange 2007 預設路由群組中手動移動伺服器。這可能會導致路由問題。

Microsoft Exchange Server 2003 及 Microsoft Exchange 2000 Server 使用路由群組來定義 Exchange 特有的路由拓撲。Exchange 2007 使用 Active Directory 站台來定義其路由拓撲。Exchange 2003 及 Exchange 2000 使用以路由群組及連接器為基礎的路由拓撲。在純 Exchange 2007 組織中，不再需要 Exchange 特有的路由組態。純 Exchange 2007 組織使用 Active Directory 站台拓撲來決定其路由拓撲。

為了支援這兩個路由拓撲之間的並存性，會在安裝 Exchange 2007 時，將所有 Exchange 2007 伺服器自動新增至單一路由群組。Exchange 2007 路由群組會在 Exchange 2003 或 Exchange 2000 中的 Exchange 系統管理員中辨識為 [Exchange 系統管理群組] (FYDIBOHF23SPDLT) 內的 [Exchange 路由群組] (DWBGZMFD01QNBJR)。

若要解決此問題，請將 Exchange 2007 伺服器移至 Exchange 2007 專用路由群組，或移除並重新安裝伺服器。


已停用傳送連接器
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-07-30

Microsoft Exchange Analyzer 工具會使用下列 Exchange 管理命令介面指令程式，來查詢 Exchange 環境中將其 Enabled 屬性值設為 False 的所有傳送連接器。傳送連接器 Enabled 屬性的值若為 False，表示已停用傳送連接器。

Get-SendConnector | where { $_.Enabled -eq $False}

Exchange Analyzer 接著會查詢 Active Directory 目錄服務，取得物件類別為 msExchExchangeServer 之所有物件的 serialNumber 屬性值。

若字串值包含 Version 5.5，表示電腦正在執行 Microsoft Exchange Server 5.5。如果字串值包含 Version 6.0，則表示電腦正在執行 Exchange 2000 Server。如果字串值包含 Version 6.5，表示電腦正在執行 Exchange Server 2003。如果字串值包含 Version 8，則表示電腦正在執行 Exchange Server 2007。

如果 Exchange Analyzer 判定在 Exchange 環境中已停用傳送連接器，而該環境中也有 Exchange 2000 或 Exchange 2003 伺服器，Exchange Analyzer 就會顯示錯誤。

此錯誤指出 Exchange 2007 路由將忽略已停用的傳送連接器，但 Exchange 2000 和 Exchange 2003 將無法辨識連接器的已停用標幟，而可能仍然試圖透過連接器路由傳送郵件，因而導致路由迴圈。

若要解決此錯誤，請在執行 Exchange 2000 或 Exchange 2003 的 Exchange 環境中刪除任何已停用的傳送連接器。

若要刪除已停用的傳送連接器，請遵循 Exchange Server 2007 產品文件＜Remove-SendConnector＞(http://go.microsoft.com/fwlink/?LinkId=96007) (英文) 主題中，使用 Exchange 管理命令介面 Remove-SendConnector 指令程式的指導。


已啟用寄件者篩選
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器物件的 msExchServerBindingsTurflist 內容是否表示已對 SMTP 虛擬伺服執行個體啟用寄件者篩選。

Exchange Server Analyzer 也會查詢 Active Directory，以判定 msExchTurfListNames 或 msExchTurfListOptions 是否表示也在通用設定層級啟用了寄件者篩選。

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • 已在 SMTP 虛擬伺服器執行個體上啟用寄件者篩選。

  • 已在通用設定層級啟用寄件者篩選。

此警告表示已有效啟用寄件者篩選。除非您正在進行此特定伺服器的郵件流程問題疑難排解，否則寄件者篩選通常不是問題。如果您正在進行疑難排解，則可能需要驗證篩選組態，或暫時停用寄件者篩選，以判定是否錯誤封鎖了有效寄件者的合法郵件。

停用 SMTP 虛擬伺服器上的寄件者篩選

  1. 啟動 [Exchange 系統管理員]：按一下 [開始]，依序指向 [所有程式] 及 [Microsoft Exchange]，然後按一下 [系統管理員]。

  2. 在主控台樹狀目錄中，依序展開 [伺服器]、您要的伺服器、[通訊協定]，然後展開 [SMTP]。

  3. 以滑鼠右鍵按一下您要停用篩選器的 SMTP 虛擬伺服器，然後按一下 [內容]。

  4. 在 [<SMTP 虛擬伺服器> 內容] 中的 [一般] 索引標籤上，按一下 [進階]。

  5. 在 [進階] 中，選取您要停用篩選器的 IP 位址，然後按一下 [編輯]。

  6. 在 [識別] 中，清除 [套用寄件者篩選器] 核取方塊以停用篩選器。

  7. 如果您有多個虛擬伺服器，請針對每個要停用篩選器的虛擬伺服器，重複步驟 3 到 6。

如需智慧型郵件篩選的相關資訊，請參閱「Exchange 智慧型郵件篩選器」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=21607)。

如需如何設定篩選及控制垃圾郵件的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中的＜設定篩選及控制垃圾郵件＞(http://go.microsoft.com/fwlink/?LinkId=47579)。


已啟用寄件者識別碼篩選
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器物件的 msExchServerBindingsFiltering 內容是否表示已對 SMTP 虛擬伺服器執行個體啟用寄件者識別碼篩選。

Exchange Server Analyzer 也會查詢 Active Directory，以判定 [UCE 內容篩選] 物件的 wWWHomePage 屬性是否包含寄件者識別碼及連線篩選的項目。

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • 已在 SMTP 虛擬伺服器執行個體上啟用寄件者篩選。

  • 已在 [UCE 內容篩選] 物件層級啟用寄件者篩選。

此警告表示已有效啟用寄件者識別碼篩選。除非您正在進行此特定伺服器的郵件流程問題疑難排解，否則寄件者篩選通常不是問題。如果您正在進行疑難排解，則可能需要驗證篩選組態，或暫時停用寄件者篩選，以判定是否錯誤封鎖了有效寄件者的合法郵件。

停用 SMTP 虛擬伺服器上的寄件者識別碼篩選

  1. 啟動 [Exchange 系統管理員]：按一下 [開始]，依序指向 [所有程式] 及 [Microsoft Exchange]，然後按一下 [系統管理員]。

  2. 在主控台樹狀目錄中，依序展開 [伺服器]、您要的伺服器、[通訊協定]，然後展開 [SMTP]。

  3. 以滑鼠右鍵按一下您要停用篩選器的 SMTP 虛擬伺服器，然後按一下 [內容]。

  4. 在 [<SMTP 虛擬伺服器> 內容] 中的 [一般] 索引標籤上，按一下 [進階]。

  5. 在 [進階] 中，選取您要停用篩選器的 IP 位址，然後按一下 [編輯]。

  6. 在 [識別] 中，清除 [套用寄件者篩選器] 核取方塊以停用篩選器。

  7. 如果您有多個虛擬伺服器，請針對每個要停用篩選器的虛擬伺服器，重複步驟 3 到 6。

如需智慧型郵件篩選的相關資訊，請參閱「Exchange 智慧型郵件篩選器」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=21607)。


已識別為共用目的地的伺服器
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-10-04

Microsoft® Exchange Server Analyzer 工具會查詢 Exchange_Queue Windows® Management Instrumentation (WMI) 類別，以判定 SMTP 虛擬伺服器的簡易郵件傳送通訊協定 (SMTP) 佇列的下列屬性值。

LinkId | 指出包含佇列的連結的識別碼。
QueueId | 指出佇列的識別碼。
QueueName | 指出佇列的名稱。
VirtualMachine | 指出包含佇列的虛擬機器的名稱。
VirtualServerName | 指出佇列所在的虛擬伺服器的名稱。
MessageCount | 指出佇列中的郵件數目。

Exchange Server Analyzer 會使用這裡取得的資訊，查詢 Exchange_QueuedSMTPMessage WMI 類別，以取得佇列中的郵件的下列屬性值：

Recipients | 指出郵件的收件者。
Received | 指出郵件的接收時間戳記。
MessageId | 指出已佇列郵件的識別碼。
StateRetry | 指出正在對未順利傳遞的郵件重試傳輸。

最後，Exchange Server Analyzer 會使用這裡取得的資料，查詢 Active Directory® 目錄服務，以取得每一個 Recipient 物件的下列值。然後，Exchange Server Analyzer 會判斷收件者是使用者、通訊群組、公用資料夾或公用資料夾儲存區：

distinguishedName | 指出物件的辨別名稱。
msExchHomeServerName | 指出收件者所在的伺服器。
homeMDB | 指出收件者的信箱儲存區。

如果 Exchange Server Analyzer 判定至少有百分之 25 留在佇列的郵件是要送給位於特定伺服器上的收件者 (出現在 To: 或 Cc: 欄位中)，Exchange Server Analyzer 會顯示警告。

如果 Exchange Server Analyzer 判定至少有百分之 50 留在佇列的郵件是要送給位於特定伺服器上的收件者 (出現在 To: 或 Cc: 欄位中)，Exchange Server Analyzer 會顯示錯誤。

此警告或錯誤表示所識別的伺服器是留在 SMTP 佇列的郵件的共同目的地。

若要更正此問題，應該對伺服器進行如下的調查，找出可能導致郵件置於佇列的組態問題或其他異常狀況：

  • 確定伺服器物件屬性設定正確，而且在 Active Directory 包含正確值。

  • 檢閱伺服器物件的 Active Directory 權限，以確設定正確無誤。

  • 如果伺服器是特殊用途的使用者物件的主伺服器，亦即，指定的日誌收件者，請檢閱與使用者物件相關的服務或元件的組態，以確定組態正確無誤。

  • 尋找可能未經同意的廣告郵件 (UCE) 或垃圾郵件，或攻擊公用資料夾的病毒。

若需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkID=67875)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

如需通訊群組限制對 Exchange Server 郵件流程之影響的詳細資訊，請參閱下列 Microsoft 知識庫文章：

  • 895407＜在 Exchange Server 2003 中根據通訊群組設定傳遞限制後，將郵件傳遞到本機信箱及外部信箱的速度比預期慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 329171＜XADM：若設定的收件者已根據群組成員設定傳遞限制，則郵件傳遞的速度會變慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)。

  • 839949＜針對 Exchange 2000 Server 與 Exchange Server 2003 中的郵件傳輸與通訊群組進行疑難排解＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。

  • 812298＜根據通訊群組清單設定傳遞限制後，郵件傳遞的速度緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。


找不到接收器登錄
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-01-11

Microsoft® Exchange Server Analyzer 工具會查詢 Microsoft Internet Information Server (IIS) Metabase，以列舉簡易郵件傳送通訊協定 (SMTP) 傳輸事件接收器繫結的清單。Exchange Server Analyzer 會根據 Exchange Server Analyzer 中預先擴展的清單，嘗試找出一些標準事件繫結。對於每個繫結，Exchange Server Analyzer 會驗證登錄中下列分支底下的元件物件模型 (COM) 登錄詳細資料：

HKEY_CLASSES_ROOT\CLSID\

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • Metabase 中找到傳輸事件接收器繫結。

  • 登錄中遺漏對應的 COM 登錄。

SMTP 傳輸事件是在郵件資料傳入或傳出 SMTP 服務時發生。所有郵件都會經歷一些事件。這些包括 X.400 和 RPC 內送或外寄郵件。輸入傳輸事件的一個常見範例是，郵件經由網路或在 SMTP Pickup 目錄中到達 SMTP 服務。此傳輸事件發生時，此事件的來源會通知傳輸事件接收器，每個傳輸事件接受器就會根據郵件的資料內容採取某一類動作。在系統將郵件資料傳遞到接收器後，直到接收器完成其動作並傳回郵件為止，這段期間內系統不會對郵件資料執行其他動作。接收器在執行此動作時，對郵件資料與狀態有獨佔的控制權。

遺漏傳輸事件接收器繫結的 COM 登錄可能會造成郵件流程問題。如果 Exchange Server 顯示有郵件流程問題的徵兆 (如郵件在佇列中)，請重新登錄傳輸事件接收器。

若要重新登錄傳輸事件接收器

  1. 從 Microsoft Exchange Server 中開啟 [命令提示字元] 視窗，然後變更至 \Program Files\Exchsrvr\Bin 資料夾。

  2. 鍵入下列命令以重新登錄傳輸事件接收器：

    regsvr32 /i exps.dll

    regsvr32 /i miscat.dll

    regsvr32 /i onsubmit.dll

    regsvr32 /i peexch50.dll

    regsvr32 /i phatcat.dll

    regsvr32 /i protolog.dll

    regsvr32 /i reapi.dll

    regsvr32 /i regsinks.dll

    regsvr32 /i tranmsg.dll

    regsvr32 /i turflist.dll

    regsvr32 /i xlsasink.dll

    regsvr32 /i msgfilter.dll

  3. 重新執行 Exchange Server Analyzer，以確認不會再顯示警告。如果事件接收器登錄警告繼續出現且您遇到郵件流程問題，請連絡 Microsoft 產品支援服務 (PSS)。

若需有關傳輸事件接收器繫結的詳細資訊，請參閱下列 Exchange 資源：

  • 微軟知識庫文件 - 258224＜XCON：列舉已登錄的傳輸事件接收器＞(英文) (http://go.microsoft.com/fwlink/?linkID=3052&kbid=258224)

  • 《Exchange Server 2003 技術參考手冊》(http://go.microsoft.com/fwlink/?LinkId=58876) 中的＜SMTP 服務設計＞


已在 SMTP 虛擬伺服器上設定智慧主機
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已在特定的 SMTP 虛擬伺服器上設定 msExchSmtpSmartHost 屬性。如果 Exchange Server Analyzer 發現已設定 msExchSmtpSmartHost 屬性，就會顯示警告。

在 SMTP 虛擬伺服器上設定智慧主機不是最佳作法。相反地，您應建立 SMTP 連接器，並在該處設定智慧主機設定。

在 Exchange Server 2003 中，使用 [網際網路郵件精靈] 來設定網際網路郵件傳遞。若需詳細資訊，請參閱《Exchange Server 傳輸及路由手冊》中的＜如何使用網際網路郵件精靈＞(英文) (http://go.microsoft.com/fwlink/?LinkId=50099)。

若需有關如何建立 SMTP 連接器的詳細資訊，請參閱《Exchange Server 傳輸及路由手冊》中的＜如何建立 SMTP 連接器＞(英文) (http://go.microsoft.com/fwlink/?LinkId=50100)。


已手動設定 SMTP AdditionalPoolThreadsPerProc 登錄值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-01-17

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否有手動設定其他集區執行緒：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\AdditionalPoolThreadsPerProc

如果 Exchange Server Analyzer 發現 AdditionalPoolThreadsPerProc 已存在且已設定，則會顯示非預設的組態訊息。

在 SMTP 中有五個工作佇列是使用稱為 ATQ 執行緒的執行緒集區。根據設計，其中兩個佇列預設可以使用最多 90% 的可用執行緒。此執行緒集區是由接受 POP 及 IMAP 要求的處理程序所共用。因此，在中度到高度負載狀況下會發生 SMTP 防止 POP 及 IMAP 服務使用資源的情況。

您可以限制 SMTP 可使用的執行緒百分比，來保留足夠的執行緒數目供 POP 及 IMAP 使用。若要執行此變更，請增加可供 IIS 使用的整體執行緒數目。其唯一代價就是增加其他執行緒的記憶體使用量。

有兩個登錄值可讓您控制每個處理器的執行緒與其他執行緒的 SMTP 百分比：

位置：HKLM\System\CurrentControlSet\Services\SMTPSVC\Parameters

值：AdditionalPoolThreadsPerProc

類型：REG_DWORD

位置：HKLM\System\CurrentControlSet\Services\SMTPSVC\Parameters

值：MaxPercentPoolThreads

類型：REG_DWORD

如果高度 SMTP 活動造成 POP3 或 IMAP4 失敗或這兩個資源都失敗，您應該在叢集 Exchange Server 電腦上調整這兩個登錄值。您可以使用下列公式來計算叢集的最佳值：

登錄值 | 公式
AdditionalPoolThreadsPerProc | ((9 / (MaxPercentPoolThreads/100)) - 4) / 2
MaxPercentPoolThreads | 90 / (2 * 通訊協定虛擬伺服器數目)

例如，在有兩個通訊協定虛擬伺服器的 Exchange Server 叢集中，MaxPercentPoolThreads 的公式為 90 / (2*2) = 22。計算 MaxPercentPoolThreads 值時，如果計算結果為包含小數點的值，您應該將結果無條件捨去為整數。當計算 AdditionalPoolThreadsPerProc 值的時候， 如果計算結果會產生大於 200 的值，那麼您也需要將結果值指派給另一個登錄值：

位置：HKLM\System\CurrentControlSet\Services\InetInfo\Parameters\

值：PoolThreadLimit

類型：REG_DWORD

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要在 Exchange 叢集上設定最佳設定值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. 建立名為 AdditionalPoolThreadsPerProc 的 DWORD 登錄值，然後根據上面的公式將其值資料設定成適當數字。

  4. 建立名為 MaxPercentPoolThreads 的 DWORD 登錄值，然後根據上面的公式將其值資料設定成適當數字。

  5. 關閉登錄編輯程式，然後重新啟動 IIS Admin 服務，使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需這份文件所描述的特定叢集資源問題之詳細資訊，請參閱微軟知識庫文件 - 281868＜XADM：POP\IMAP4 虛擬伺服器在高負載下一再失敗＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=281868)。


SMTP 封存接收器：封存 P1 標頭設定
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已安裝並啟用 SMTP 封存接收器：

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Dump P1

如果 Exchange Server Analyzer 發現 Dump P1 值大於 0，就會顯示非預設的組態訊息。

值 0 表示已停用 P1 標頭封存。值 1 表示已啟用 P1 標頭封存。不支援 0 或 1 以外的值。

SMTP 封存接收器工具是一種自訂的指令碼，可封存傳入及傳出 Exchange 伺服器上之特定資料夾的所有郵件。在預設的情況下，啟用 SMTP 封存接收器時，所有郵件及其收件者都會封存到 .eml 檔中，除了密件副本收件者之外。

P1 標頭亦稱為「信封」資料。信封資料是在傳輸郵件時 Exchange 產生的實際收件者清單，其可讓郵件到達所有收件者。與 P2 標頭 (其為已接收之特定郵件中寄件者所宣告的收件者) 不同，在傳送至多個目的地的過程中信封資料會變更。這些變更是因通訊群組清單展開及隱藏通訊群組清單的行為而產生。

在預設的情況下，安裝及啟用 SMTP 封存接收器時，不會封存 P1 標頭。通常，僅會為疑難排解的目的而啟用 P1 標頭封存。

如果您不想在此 Exchange 電腦上封存 P1 標頭，可以將 Dump P1 登錄機碼設為 0，或可以解除安裝 SMTP 封存接收器。當您解除安裝 SMTP 封存接收器時，也會一併刪除 SMTP 封存接收器使用的所有登錄機碼。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要停用 P1 標頭封存

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. 按兩下 Dump P1 登錄機碼、在 [數值資料] 欄位中輸入 0，然後按一下 [確定]。

  4. 關閉登錄編輯程式，然後重新啟動 IIS Admin Service，使變更生效。

若要解除安裝 SMTP 封存接收器

  1. 依序按一下 [開始]、[執行]，輸入 cmd，然後按一下 [確定]。

  2. 在 C:\Program Files\Exchsrvr\bin 資料夾中，輸入 cscript archivesink_setup.vbs，然後按 Enter。

  3. 輸入 cscript archivesink_setup.vbs uninstall Virtual Server ID, ，其中 Virtual Server ID 是安裝 SMTP 封存接收器的虛擬伺服器編號。

  4. 結束 [命令提示字元] 視窗，然後重新啟動 IIS Admin Service，使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關在 Exchange Server 2003 中安裝及設定 SMTP 封存接收器的詳細資訊，請參閱知識庫文件 - 871110＜如何在 Exchange Server 2003 中安裝及使用封存接收器公用程式＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110)。

若需有關在 Exchange 2000 Server 安裝及設定 SMTP 封存接收器的詳細資訊，請參閱知識庫文件 - 307798＜Service Pack 2 提供了封存接收器公用程式＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798)。

若需有關部署完整日誌解決方案以達到調整相容性目的的詳細資訊，請參閱《Exchange Server 2003 日誌》(英文)(http://go.microsoft.com/fwlink/?LinkId=47581)。


啟用 SMTP 封存接收器
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已安裝並啟用 SMTP 封存接收器：

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable Smtp Messages

如果 Exchange Server Analyzer 發現 Enable Smtp Messages 值大於 0，就會顯示非預設的組態訊息。

值為 0 表示已停用 SMTP 封存接收器。值為 1 表示已啟用 SMTP 封存接收器。不支援 0 或 1 以外的值。

SMTP 封存接收器工具是一種自訂的指令碼，可封存傳入及傳出 Exchange 伺服器上之特定資料夾的所有郵件。依預設，啟用 SMTP 封存接收器時，所有郵件及其收件者都會封存到 .eml 檔中，除了密件副本收件者之外。

在預設的情況下，當您啟用使用 SMTP 封存接收器的 SMTP 封存時，簡易郵件傳送通訊協定 (SMTP)、Exchange 儲存區或任何其他接收器提交傳送的所有郵件都會觸發此事件。理論上，會為每封郵件引發一次這個事件，且這個事件只可以封存一次。在引發路由或分類程式事件前，會先引發 OnMessageSubmission 事件。因此，這些郵件就稱為 PreCat 郵件。在預設的情況下，安裝 SMTP 封存接收器工具時，會封存此事件的郵件。針對此事件封存的郵件包含字首檔案名稱：ARCH_random number.xml。

如果您不想在此 Exchange 電腦上封存郵件，可以將 Enable Smtp Messages 登錄機碼設為 0，或您可解除安裝 SMTP 封存接收器。當您解除安裝 SMTP 封存接收器時，也會一併刪除 SMTP 封存接收器使用的所有登錄機碼。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要停用 SMTP 封存接收器

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. 按兩下 Enable Smtp Messages 登錄機碼、在 [數值資料] 欄位中輸入 0，然後按一下 [確定]。

  4. 結束登錄編輯程式，然後重新啟動 IIS Admin Service，使變更生效。

若要解除安裝 SMTP 封存接收器

  1. 依序按一下 [開始]、[執行]，輸入 cmd，然後按一下 [確定]。

  2. 在 C:\Program Files\Exchsrvr\bin 資料夾中，輸入 cscript archivesink_setup.vbs，然後按 Enter。

  3. 輸入 cscript archivesink_setup.vbs uninstall Virtual Server ID, ，其中 Virtual Server ID 是安裝 SMTP 封存接收器的虛擬伺服器編號。

  4. 結束 [命令提示字元] 視窗，然後重新啟動 IIS Admin Service 使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關在 Exchange Server 2003 中安裝及設定 SMTP 封存接收器的詳細資訊，請參閱知識庫文件 - 871110＜如何在 Exchange Server 2003 中安裝及使用封存接收器公用程式＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110)。

若需有關在 Exchange 2000 Server 安裝及設定 SMTP 封存接收器的詳細資訊，請參閱知識庫文件 - 307798＜Service Pack 2 提供了封存接收器公用程式＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798)。

若需有關部署完整日誌解決方案以達到調整相容性目的的詳細資訊，請參閱《Exchange Server 2003 日誌》(英文) (http://go.microsoft.com/fwlink/?LinkId=47581)。


SMTP 封存接收器：已設定後分類
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已安裝並啟用 SMTP 封存接收器：

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable PostCat

如果 Exchange Server Analyzer 發現 Enable PostCat 值大於 0，就會顯示非預設的組態訊息。

值為 0 表示已停用後分類郵件封存。值為 1 表示已啟用後分類郵件封存。不支援 0 或 1 以外的值。

SMTP 封存接收器工具是一種自訂的指令碼，可封存傳入及傳出 Exchange 伺服器上之特定資料夾的所有郵件。依預設，啟用 SMTP 封存接收器時，所有郵件及其收件者都會封存到 .eml 檔中，除了密件副本收件者之外。

Enable PostCat 設為 1 時，會在郵件分類之後封存郵件。郵件可多次觸發此事件，但只有在將郵件分類、排入佇列並再次列舉時才會出現此情況。因此事件而封存的郵件會包含字首檔案名稱 ARCH_POSTCAT_random number.xml。

如果您不想封存此 Exchange 電腦上的後分類郵件，可將 Enable PostCat 登錄機碼設為 0。如果您完全不想在此電腦上進行封存，可以解除安裝 SMTP 封存接收器。當您解除安裝 SMTP 封存接收器時，也會一併刪除 SMTP 封存接收器使用的所有登錄機碼。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要停用後分類郵件封存

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. 按兩下 Enable PostCat 登錄機碼、在 [數值資料] 欄位中輸入 0，然後按一下 [確定]。

  4. 結束登錄編輯程式，然後重新啟動 IIS Admin Service，使變更生效。

若要解除安裝 SMTP 封存接收器

  1. 依序按一下 [開始]、[執行]，輸入 cmd，然後按一下 [確定]。

  2. 在 C:\Program Files\Exchsrvr\bin 資料夾中，輸入 cscript archivesink_setup.vbs，然後按 Enter。

  3. 輸入 cscript archivesink_setup.vbs uninstall Virtual Server ID, ，其中 Virtual Server ID 是安裝 SMTP 封存接收器的虛擬伺服器編號。

  4. 結束 [命令提示字元] 視窗，然後重新啟動 IIS Admin Service 使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關在 Exchange Server 2003 上安裝及設定 SMTP 封存接收器的詳細資訊，請參閱知識庫文件 - 871110＜如何在 Exchange Server 2003 中安裝及使用封存接收器公用程式＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110)。

若需有關在 Exchange 2000 Server 上安裝及設定 SMTP 封存接收器的詳細資訊，請參閱知識庫文件 - 307798＜Service Pack 2 提供了封存接收器公用程式＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798)。

若需有關部署完整日誌解決方案以達到調整相容性目的的詳細資訊，請參閱《Exchange Server 2003 日誌》(英文) (http://go.microsoft.com/fwlink/?LinkId=47581)。


SMTP 封存接收器：已設定前分類
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已安裝並啟用 SMTP 封存接收器：

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable PreCat

如果 Exchange Server Analyzer 發現 Enable PreCat 值大於 0，就會顯示非預設的組態訊息。

值 0 表示已停用前分類郵件封存。值 1 表示已啟用前分類郵件封存。不支援 0 或 1 以外的值。

SMTP 封存接收器工具是一種自訂的指令碼，可封存傳入及傳出 Exchange 伺服器上之特定資料夾的所有郵件。依預設，啟用 SMTP 封存接收器時，所有郵件及其收件者都會封存到 .eml 檔中，除了密件副本收件者之外。

由簡易郵件傳送通訊協定 (SMTP)、Exchange 儲存區或任何其他接收器提交傳輸的所有郵件都會觸發此事件。理論上，會為每封郵件引發一次這個事件，且這個事件只可以封存一次。在引發路由或分類程式事件前，會先引發 OnMessageSubmission 事件。因此，這些郵件就稱為 PreCat 郵件。在預設的情況下，安裝 SMTP 封存接收器公用程式後，會封存發生此事件的郵件。因此事件而封存的郵件會包含字首檔案名稱 RCH_random number.xml。

如果您不想封存此 Exchange 電腦上的前分類郵件，可將 Enable PreCat 登錄機碼設為 0。如果您完全不想在此電腦上進行封存，可以解除安裝 SMTP 封存接收器。當您解除安裝 SMTP 封存接收器時，也會一併刪除 SMTP 封存接收器使用的所有登錄機碼。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要停用前分類郵件封存

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. 按兩下 Enable PreCat 登錄機碼、在 [數值資料] 欄位中輸入 0，然後按一下 [確定]。

  4. 關閉登錄編輯程式，然後重新啟動 IIS 管理服務，使變更生效。

若要解除安裝 SMTP 封存接收器

  1. 依序按一下 [開始]、[執行]，輸入 cmd，然後按一下 [確定]。

  2. 在 C:\Program Files\Exchsrvr\bin 資料夾中，輸入 cscript archivesink_setup.vbs，然後按 Enter。

  3. 輸入 cscript archivesink_setup.vbs uninstall Virtual Server ID, ，其中 Virtual Server ID 是安裝 SMTP 封存接收器的虛擬伺服器編號。

  4. 結束 [命令提示字元] 視窗，然後重新啟動 IIS Admin Service 使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關在 Exchange Server 2003 中安裝及設定 SMTP 封存接收器的詳細資訊，請參閱知識庫文件 - 871110＜如何在 Exchange Server 2003 中安裝及使用封存接收器公用程式＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110)。

若需有關在 Exchange 2000 Server 中安裝及設定 SMTP 封存接收器的詳細資訊，請參閱知識庫文件 - 307798＜Service Pack 2 提供了封存接收器公用程式＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798)。

若需有關部署完整日誌解決方案以達到調整相容性目的的詳細資訊，請參閱《Exchange Server 2003 日誌》(英文)(http://go.microsoft.com/fwlink/?LinkId=47581)。


SMTP 封存接收器：正在封存系統郵件
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已安裝並啟用 SMTP 封存接收器：

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Archive System Messages

如果 Exchange Server Analyzer 發現 Archive System Messages 值大於 0，就會顯示非預設的組態訊息。

值 0 表示尚未封存系統郵件。值 1 表示已經封存系統郵件。不支援 0 或 1 以外的值。

SMTP 封存接收器工具是一種自訂的指令碼，可封存傳入及傳出 Exchange 伺服器上之特定資料夾的所有郵件。依預設，啟用 SMTP 封存接收器時，所有郵件及其收件者都會封存到 .eml 檔中，除了密件副本收件者之外。

如果您不想封存此 Exchange 電腦上的系統郵件，可將 Archive System Messages 登錄機碼設為 0。如果您完全不想在此電腦上進行封存，可以解除安裝 SMTP 封存接收器。當您解除安裝 SMTP 封存接收器時，也會一併刪除 SMTP 封存接收器使用的所有登錄機碼。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要停用系統郵件封存

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. 按兩下 Archive System Messages 登錄機碼、在 [數值資料] 欄位中輸入 0，然後按一下 [確定]。

  4. 關閉登錄編輯程式，然後重新啟動 IIS Admin Service，使變更生效。

若要解除安裝 SMTP 封存接收器

  1. 依序按一下 [開始]、[執行]，輸入 cmd，然後按一下 [確定]。

  2. 在 C:\Program Files\Exchsrvr\bin 資料夾中，輸入 cscript archivesink_setup.vbs，然後按 [Enter]。

  3. 輸入 cscript archivesink_setup.vbs uninstall Virtual Server ID, ，其中 Virtual Server ID 是安裝 SMTP 封存接收器的虛擬伺服器編號。

  4. 關閉 [命令提示字元] 視窗，然後重新啟動 IIS 管理服務，使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關在 Exchange Server 2003 中安裝及設定 SMTP 封存接收器的詳細資訊，請參閱知識庫文件 - 871110＜如何在 Exchange Server 2003 中安裝及使用封存接收器公用程式＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110)。

若需有關在 Exchange 2000 Server 安裝及設定 SMTP 封存接收器的詳細資訊，請參閱知識庫文件 - 307798＜Service Pack 2 提供了封存接收器公用程式＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798)。

若需有關部署完整日誌解決方案以達到調整相容性目的的詳細資訊，請參閱《Exchange Server 2003 日誌》(英文)(http://go.microsoft.com/fwlink/?LinkId=47581)。


SMTP BadMail 資料會寫入壓縮的資料夾
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 類別，以判定簡易郵件傳送通訊協定 (SMTP) BadMail 資料夾的 Compressed 機碼值。如果 Exchange Server Analyzer 發現 Compressed 的值設定為 True，則會顯示警告訊息。

當郵件透過 SMTP 服務抵達 Exchange 電腦時，資料會以 .eml 檔格式寫入硬碟。在預設的情況下，這些檔案會儲存在 <drive>:\Program Files\Exchsrvr\Mailroot 資料夾中 (在安裝 Exchange 的相同磁碟分割區上)。如果儲存 SMTP BadMail 資料的資料夾啟用檔案壓縮功能，則 Exchange 的效能可能會嚴重衰退。因此，不支援儲存 SMTP BadMail 資料之資料夾的壓縮功能。

如果您收到這則警告訊息，則必須關閉儲存 SMTP 錯誤郵件資料的資料夾壓縮功能，或必須將 SMTP BadMail 資料移到未壓縮的資料夾。

Microsoft 不支援將 Exchange 資料檔案儲存在壓縮磁碟區上。當您將 Exchange 資料檔案儲存在壓縮的磁碟區上時，額外的處理將會顯著影響 Exchange 的效能。Exchange 資料檔案包括下列檔案：

  • .edb 檔案

  • .stm 檔案

  • .log 檔案

  • .dat 檔案

  • .eml 檔案

  • .chk 檔案

若要關閉某個給定資料夾的檔案壓縮功能

  1. 在要關閉檔案壓縮的資料夾上按一下滑鼠右鍵，然後按一下 [內容]。

  2. 在 [一般] 索引標籤中，按一下 [進階]。

  3. 在 [進階屬性] 對話方塊中，清除 [壓縮內容，節省磁碟空間] 核取方塊，然後按一下 [確定]。

若要在 Exchange 2000 Server 或 Exchange Server 2003 上移動 BadMail 資料夾

  1. 開啟 [Exchange 系統管理員]。

  2. 按一下 [系統管理群組]，然後依序展開您的系統管理群組、[伺服器]、展開您的伺服器、[通訊協定]、[SMTP]。

  3. 以滑鼠右鍵按一下您的 SMTP 虛擬伺服器，再按一下 [停止]。

  4. 以滑鼠右鍵按一下您的 SMTP 虛擬伺服器，再按一下 [內容]。

  5. 在 [郵件] 標籤中，按一下 [錯誤郵件目錄] 方框旁的 [瀏覽]，然後鍵入 Queue 資料夾的新位置路徑。

  6. 按一下 [確定]。

  7. 以滑鼠右鍵按一下您的 SMTP 虛擬伺服器，再按一下 [啟動]。

若需有關移動 Mailroot 資料夾的詳細資訊，請參閱微軟知識庫文件 - 822933＜How to change the Exchange 2003 SMTP Mailroot folder location＞ (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)。


SMTP BadMail 資料會寫入非 NTFS 的磁碟分割
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Exchange SMTP BadMail 目錄的 FSName 機碼值。如果 Exchange Server Analyzer 判定 FSName 機碼值不等於 NTFS，就會顯示警告。

Microsoft 不支援將 Exchange 資料檔案儲存在非 NTFS 磁碟區上。Exchange 資料檔案包括下列檔案：

  • .edb 檔案

  • .stm 檔案

  • .log 檔案

  • .dat 檔案

  • .eml 檔案

如果您看到此警告，就必須將 SMTP BadMail 目錄移至 NTFS 檔案系統磁碟機上的資料夾。或者，如果用來儲存 BadMail 目錄的磁碟機已格式化為 FAT 磁碟機，也可使用 convert.exe 命令列工具將磁碟機轉換為 NTFS。

將 SMTP BadMail 目錄移動至其他資料夾

  1. 啟動 Exchange 系統管理員。

  2. 按一下 [系統管理群組]，然後依序展開您的系統管理群組、[伺服器]、展開您的伺服器、[通訊協定]、[SMTP]。

  3. 以滑鼠右鍵按一下您的 SMTP 虛擬伺服器，再按一下 [停止]。

  4. 以滑鼠右鍵按一下您的 SMTP 虛擬伺服器，再按一下 [內容]。

  5. 在 [郵件] 索引標籤中，按一下 [錯誤郵件目錄] 方塊旁的 [瀏覽]，然後鍵入 BadMail 資料夾的新位置路徑。

  6. 按一下 [確定]。

  7. 以滑鼠右鍵按一下您的 SMTP 虛擬伺服器，再按一下 [啟動]。

若需有關移動 Mailroot 資料夾的詳細資訊，請參閱微軟知識庫文件 - 822933＜How to change the Exchange 2003 SMTP Mailroot folder location＞ (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)。

除了上述程序之外，如果儲存檔案的磁碟機已格式化為 FAT 磁碟機，您也可以使用 convert.exe 命令列工具，將磁碟機轉換為 NTFS 格式。若需有關使用 convert.exe 命令列工具將 FAT 磁碟分割轉換為 NTFS 磁碟分割的詳細資訊，請參閱微軟知識庫文件 - 214579＜如何使用 Convert.exe 將磁碟分割轉換為 NTFS 檔案系統＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579)。


SMTP BadMail 資料會寫入已加密的資料夾
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 SMTP BadMail 資料夾的 Encrypted 機碼值。如果 Exchange Server Analyzer 發現 Encrypted 的值設定為 True，就會顯示一則警告。

當郵件透過 SMTP 服務抵達 Exchange 電腦時，資料會以 .eml 檔格式寫入硬碟。在預設的情況下，這些檔案會儲存在 <drive>:\Program Files\Exchsrvr\Mailroot 資料夾中 (在安裝 Exchange 的相同磁碟分割區上)。如果儲存 SMTP BadMail 資料的資料夾已啟用檔案加密功能，則 Exchange 的效能可能會嚴重衰退。因此，不支援將儲存 SMTP BadMail 資料的資料夾加密的功能。

如果您收到這則警告訊息，則必須關閉儲存 SMTP 錯誤郵件資料的資料夾之加密功能，或必須將 SMTP BadMail 資料移到未加密的資料夾。

Microsoft 不支援將 Exchange 資料檔案儲存在「加密檔案系統 (EFS)」加密磁碟區上。當您將 Exchange 資料檔案儲存在加密磁碟區上時，額外的處理會顯著影響 Exchange 的效能。Exchange 資料檔案包括下列檔案：

  • .edb 檔案

  • .stm 檔案

  • .log 檔案

  • .dat 檔案

  • .eml 檔案

  • .chk 檔案

為了協助保護您的 Exchange 資料檔案安全，建議您禁止未經授權者存取 Exchange 電腦，並且使用 S/MIME 郵件格式，將郵件資料加密。

若要解決這項錯誤，您必須關閉 BadMail 資料夾的檔案加密功能，或將 BadMail 資料夾移到未啟用加密功能的位置。

若要關閉某個給定資料夾的檔案加密功能

  1. 在要關閉檔案加密的資料夾上按一下滑鼠右鍵，然後按一下 [內容]。

  2. 在 [一般] 索引標籤中，按一下 [進階]。

  3. 在 [進階屬性] 對話方塊中，清除 [加密內容，保護資料] 核取方塊，然後按一下 [確定]。

若要在 Exchange 2000 Server 或 Exchange Server 2003 上移動 BadMail 資料夾

  1. 開啟 [Exchange 系統管理員]。

  2. 按一下 [系統管理群組]，然後依序展開您的系統管理群組、[伺服器]、展開您的伺服器、[通訊協定]、[SMTP]。

  3. 以滑鼠右鍵按一下您的 SMTP 虛擬伺服器，再按一下 [停止]。

  4. 以滑鼠右鍵按一下您的 SMTP 虛擬伺服器，再按一下 [內容]。

  5. 在 [郵件] 標籤中，按一下 [錯誤郵件目錄] 方框旁的 [瀏覽]，然後鍵入 Queue 資料夾的新位置路徑。

  6. 按一下 [確定]。

  7. 以滑鼠右鍵按一下您的 SMTP 虛擬伺服器，再按一下 [啟動]。

若需有關移動 Mailroot 資料夾的詳細資訊，請參閱微軟知識庫文件 - 822933＜How to change the Exchange 2003 SMTP Mailroot folder location＞ (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)。

若需有關 Exchange Server 資料檔案及 EFS 的詳細資訊，請參閱微軟知識庫文件 - 834638＜Information about the storage of data files on an encrypted volume in Exchange Server＞ (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638)。

若需有關如何在 Exchange Server 2003 保護郵件安全的詳細資訊，請參閱《Exchange Server 2003 郵件安全性手冊》(英文) (http://go.microsoft.com/fwlink/?linkid=47574)。


SMTP CatRetryMinutes 登錄值並非預設值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更預設的 SMTP 佇列組態：

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

如果 Exchange Server Analyzer 發現已設定 CatRetryMinutes 機碼，則會顯示非預設的訊息。

建議您在全面考量後，再進行預設佇列值的修改。這些預設值經過謹慎的選擇，可讓大部分環境獲得最佳效能。一般的最佳作法是解決問題的根本來源，而不是去修改 Exchange Server 上的佇列行為。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要採取任何動作。

若需有關 Exchange SMTP 佇列的詳細資訊，請參閱 Microsoft Exchange 團隊部落格中的＜解說神秘的 SMTP 進階佇列引擎＞項目 (英文) (http://go.microsoft.com/fwlink/?LinkId=48585)。


SMTP 組態警告
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-03

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已變更 msExchSmtpMaxMessageSize 屬性的預設值 0。依預設，msExchSmtpMaxMessageSize 屬性是設為不限制郵件大小。

若下列條件存在，Exchange Server Analyzer 便會顯示警告：

  • msExchSmtpMaxMessageSize 屬性的值不是 0。

  • Exchange 未在 Microsoft Windows® Small Business Server 2003 上執行。

msExchSmtpMaxMessageSize 屬性代表可收發之每一封 SMTP 郵件的大小上限。從安全性觀點來看，最佳作法是限制可以向網際網路收發之 SMTP 郵件的大小上限。然而，若為內部 SMTP 郵件，例如在相同組織的 Exchange 伺服器之間流通的郵件，建議您讓 msExchSmtpMaxMessageSize 屬性設為 0。

在內部，Exchange 會使用 SMTP 郵件來處理如公用資料夾複寫的工作。如果 msExchSmtpMaxMessageSize 屬性設定的限制太低，則可能會造成公用資料夾複寫問題，並造成其他組織內部郵件傳遞失敗。

如果此 Exchange 伺服器是向網際網路往來轉送 SMTP 郵件的 Bridgehead 伺服器，您就能夠放心地略過此警告。如果此 Exchange 伺服器負責處理內部 SMTP 郵件，您應該將 msExchSmtpMaxMessageSize 屬性值變回其預設值 0。

附註：
如果您設定的郵件大小太低，Exchange Server 電腦之間就會無法進行離線通訊錄複寫。如需相關資訊，請參閱 Microsoft 知識庫文章 326154＜您無法下載 Exchange 2000 Server 的 Microsoft Outlook 中的離線通訊錄＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326154)。
檢視及設定最大 SMTP 郵件大小

  1. 在 [Exchange 系統管理員] 中，依序展開 [伺服器]、Exchange 伺服器、[通訊協定] 及 SMTP。

  2. 在 SMTP 虛擬伺服器 (例如，預設的 SMTP 虛擬伺服器) 上按一下滑鼠右鍵，然後選取 [內容]。

  3. 選取 [郵件] 索引標籤。

  4. 若要還原為預設值 0，請清除 [將郵件大小限制為 (KB)] 核取方塊。或者，讓此方塊處於核取的狀態，然後設定您想要的任何值。

  5. 按一下 [確定] 以儲存變更並關閉 SMTP 虛擬伺服器的 [內容] 對話方塊。

如需 SMTP 虛擬伺服器設定的相關資訊，請參閱下列 Microsoft 知識庫文章：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=266686)。

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)。


具有已設定傳遞限制之通訊群組的 SMTP 連接器
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-09-06

Microsoft® Exchange Server Analyzer 工具會查詢在 Active Directory® 目錄服務中偵測到的每一個簡易郵件傳送通訊協定 (SMTP) 連接器物件 (msExchRoutingSMTPConnector) 的下列屬性，以判定它們是否根據通訊群組成員來設定傳遞限制。

dLMemRejectPerms | 包含其成員可能未透過此 SMTP 連接器來傳送之通訊群組清單 (DL) 的網域名稱 (DN)
dLMemSubmitPerms | 包含其成員可能透過此 SMTP 連接器來傳送之通訊群組清單 (DL) 的網域名稱 (DN)

如果 Exchange Server Analyzer 判定有 SMTP 連接器根據通訊群組成員來設定傳遞限制，則 Exchange Server Analyzer 會顯示警告。

此警告指出根據通訊群組成員設定的傳遞限制，可能會影響 Exchange 郵件流程的效能。

當您使用根據通訊群組成員來設定傳遞限制的 SMTP 連接器來傳送郵件時，郵件分類程式必須展開通訊群組的成員，並取得成員 DN 的完整清單，然後以該 DN 清單與寄件者 DN 清單進行比較。兩份清單的 DN 相符時，便會執行存取作業或拒絕作業。如果通訊群組是其他通訊群組中的巢狀通訊群組，則系統也會展開該巢狀通訊群組。

若要更正此警告：

  • 參考 Microsoft 知識庫文章 329171＜XADM：若設定的收件者已根據群組成員設定傳遞限制，則郵件傳遞的速度會變慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)，針對連接器限制設計專用的路由群組，並將之設定為本機路由群組。

  • 使用固定且更穩固的通用類別目錄伺服器作為連接器指定的 Bridgehead 伺服器。

  • 請參考 Microsoft 知識庫文章 812298＜根據通訊群組清單設定傳遞限制後，郵件傳遞的速度緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)，針對個別信箱而非通訊群組設定傳遞限制。

  • 考慮執行 SMTP 寄件者篩選。

  • 對於執行 Exchange Server 2003 Service Pack 2 (SP2) 或更新版本的伺服器，請考慮執行非階層式限制檢查。對於執行比 Exchange 2003 SP2 更舊之 Exchange 版本的伺服器，請考慮升級至 Exchange 2003 SP2。

詳細資訊

如需非階層式限制檢查的詳細資訊，請參閱考慮檢查非階層式限制。

若需 SMTP 寄件者篩選的詳細資訊，請參閱《Exchange Server 2003 系統管理手冊》中的＜如何啟用寄件者篩選＞(英文) (http://go.microsoft.com/fwlink/?LinkId=72967)。

如需通訊群組限制對 Exchange 郵件流程之影響的詳細資訊，請參閱下列 Microsoft 知識庫文章：

  • 329171＜XADM：若設定的收件者已根據群組成員設定傳遞限制，則郵件傳遞的速度會變慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)。

  • 895407＜在 Exchange Server 2003 中根據通訊群組設定傳遞限制後，將郵件傳遞到本機信箱及外部信箱的速度比預期慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 839949＜針對 Exchange 2000 Server 與 Exchange Server 2003 中的郵件傳輸與通訊群組進行疑難排解＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。


已啟用 SMTP 網域重新寫入
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定此 Exchange 伺服器之 SMTP 虛擬伺服器物件的 heuristics 屬性值。如果 Exchange Server Analyzer 發現 heuristics 屬性值並非預設值 131072，就會顯示一則錯誤。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要採取任何動作。

若需有關 Exchange Server Address Rewrite 工具的詳細資訊，請參閱 Exchange Server Address Rewrite (英文) (http://go.microsoft.com/fwlink/?LinkId=25932)。


SMTP FailedMsgQRetryMinutes 登錄值並非預設值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更預設的 SMTP 佇列組態：

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

如果 Exchange Server Analyzer 發現已設定 FailedMsgQRetryMinutes 機碼，則會顯示非預設的訊息。

建議您在全面考量後，再進行預設佇列值的修改。這些預設值經過謹慎的選擇，可讓大部分環境獲得最佳效能。一般的最佳作法是解決問題的根本來源，而不是去修改 Exchange Server 上的佇列行為。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要採取任何動作。

若需有關 Exchange SMTP 佇列的詳細資訊，請參閱 Microsoft Exchange 團隊部落格中的＜解說神秘的 SMTP 進階佇列引擎＞項目 (英文) (http://go.microsoft.com/fwlink/?LinkId=48585)。


SMTP LocalDeliveryMaxBatch 登錄值不是預設值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更 LocalDeliveryMaxBatch 登錄值的預設設定：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\StoreDriver\Exchange\%SMTPVirtualServerInstance%.

如果 Exchange Server Analyzer 發現已手動建立 LocalDeliveryMaxBatch 登錄值設定，而且變更了預設的 Exchange 伺服器二進位檔設定 80，就會顯示非預設的警告訊息。

在預設的情況下，在 Exchange Server 安裝期間不會建立 LocalDeliveryMaxBatch 登錄值。在安裝 Exchange Server 之後，可以手動建立 LocalDeliveryMaxBatch 登錄值，以變更 Exchange Information Store 在內部處理及傳遞郵件的方式。若下列狀況屬實，Exchange 伺服器可能會遇到郵件傳輸及儲存區效能問題。

  • 已手動建立 LocalDeliveryMaxBatch 登錄值。

  • LocalDeliveryMaxBatch 登錄值的設定不正確。

建議您在慎重考慮後，才建立或修改 LocalDeliveryMaxBatch 登錄值。Exchange 伺服器二進位檔中的預設值經過謹慎的選擇，可讓大部分 Exchange 伺服器環境獲得最佳效能。一般的最佳作法是解決問題的根本來源，而不是手動設定登錄來修改 Exchange Server 上的預設行為。為了遵循最佳作法，如果 LocalDeliveryMaxBatch 登錄值已存在，則您可以刪除此登錄值，將 Exchange 伺服器設回預設的二進位檔設定。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不過，您可能想要藉由編輯登錄將登錄值變回預設設定。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要更正此警告

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至下列登錄機碼： HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\StoreDriver\Exchange\%SMTPVirtualServerInstance%

  3. 在詳細資料窗格中的 LocalDeliveryMaxBatch 登錄值上按一下滑鼠右鍵、按一下 [修改]，然後將 [數值資料] 變更為 80。 按一下 [確定]。

    附註：
    若要刪除 LocalDeliveryMaxBatch 登錄值，請在詳細資料窗格中的 LocalDeliveryMaxBatch 登錄值上按一下滑鼠右鍵，再按 [刪除]。按一下對話方塊中的 [是]，確認刪除登錄值。

  4. 關閉登錄編輯程式。

  5. 重新啟動 Exchange 伺服器。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關編輯 Microsoft Windows 登錄的詳細資訊，請參閱下列微軟知識庫文件：

  • 322755＜HOW TO：備份、編輯和還原 Windows 2000 的登錄＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756＜如何在 Windows XP 和 Windows Server 2003 中備份、編輯及還原登錄＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


SMTP 執行個體 FQDN 不符合 DNS 解析的伺服器名稱
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-10-04

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以取得預設簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器物件的 msExchSmtpFullyQualifiedDomainName 屬性值。

Exchange Server Analyzer 也會對所設定的 DNS 伺服器嘗試進行網域名稱系統 (DNS) 查詢，以取得正在執行 Exchange Server 的伺服器的網域全名 (FQDN)。此連線是透過自訂物件處理器建立，該處理器會執行名稱解析要求並分析結果。

Exchange Server Analyzer 會比較兩個查詢的結果。如果預設簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器物件的 msExchSmtpFullyQualifiedDomainName 屬性值不符合 Exchange 伺服器的 DNS FQDN，Exchange Server Analyzer 會顯示警告。

此警告指出可能已手動變更這些屬性值。因此，這些已變更的值可能會造成此伺服器發生郵件流程問題。

msExchSmtpFullyQualifiedDomainName 屬性值指定 SMTP 虛擬伺服器的 FQDN，而且必須可以藉由網域名稱系統 (DNS) 網路通訊協定來解析。

此屬性值必須存在有效的 DNS HOST (A) 記錄，讓嘗試解析 SMTP 虛擬伺服器之 FQDN 的傳訊伺服器可以擷取正確的 IP 位址並適當地路由傳送郵件。

若要更正此警告，請判定是否因正當目的而刻意變更這些值。如果是因正當目的而變更這些值，請採取下列其中一個步驟：

  • 變更 msExchSmtpFullyQualifiedDomainName 屬性值以符合 DNS FQDN。

  • 將 Exchange Server DNS FQDN 設定成符合 msExchSmtpFullyQualifiedDomainName 屬性值。

注意：
使用 Active Directory Service Interfaces (ADSI) 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
更新 msExchSMTPFullyQualifiedDomainName 屬性值

  1. 開啟 [Exchange 系統管理員]。

  2. 依序展開 [系統管理群組]、[伺服器]、Exchange 伺服器、[通訊協定] 和 [SMTP]。

  3. 在預設 SMTP 虛擬伺服器上按一下滑鼠右鍵，然後選取 [內容]。

  4. 選取 [傳遞] 索引標籤，然後按一下 [進階]。

  5. 在網域全名下，輸入 msExchSmtpFullyQualifiedDomainName 屬性值。

  6. 按一下 [確定] 來儲存變更，再按一下 [確定] 來關閉 SMTP 虛擬伺服器的 [內容] 對話方塊。
設定 Exchange Server 的 DNS FQDN

  1. 遵循如何設定 DNS 伺服器上的設定中的指導 (英文)。

若需 Exchange 中的反向 DNS 查詢的詳細資訊，請參閱＜新增資源記錄至 DNS 區域＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63002)。

若需有關 SMTP 虛擬伺服器設定的詳細資訊，請參閱下列知識庫文件：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=266686)。

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)。

若需 SMTP 服務設計的詳細資訊，請參閱《Exchange Server 2003 技術參考手冊》中的＜SMTP 服務設計＞(英文) (http://go.microsoft.com/fwlink/?LinkId=58876) 。


未設定輸出 SMTP 連接器的 SMTP 執行個體
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-08-22

Microsoft® Exchange Server Analyzer 工具會針對 protocolCfgSMTPServer 物件類別的 distingushedName 屬性值查詢 Active Directory® 目錄服務，以便列出使用者指定的 Exchange 閘道上，所有簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器執行個體。

然後，Exchange Server Analyzer 會查詢 Active Directory，以取得每一個找到的 msExchRoutingSMTPConnector 物件的 msExchSourceBridgeheadServersDN 及 routingList 屬性值，以判定 SMTP 連接器是否具有其中一個偵測到的 SMTP 虛擬伺服器執行個體組，作為外部 SMTP 位址空間的本機 Bridgehead。

SMTP 連接器可指定個別的路由來傳送郵件。您可以使用 SMTP 連接器，來建立網際網路郵件的閘道，或連線到特定的網域或郵件系統。連接器可讓您針對指定的郵件路由定義特定的選項。

如果 Exchange Server Analyzer 判定並無 SMTP 連接器具有來自指定之 Exchange 閘道伺服器組的 SMTP 虛擬伺服器執行個體，作為其本機 Bridgehead 伺服器，則 Exchange Server Analyzer 會顯示警告。

此警告指出使用者指定的 Exchange 閘道伺服器以外的伺服器可能在無意中路由傳送組織外的郵件。

您可能想要建立一個 SMTP 連接器，將指定的 Exchange 閘道伺服器上的 SMTP 虛擬伺服器執行個體指定為其 Bridgehead，以避免發生此狀況，因為在此狀況中，使用者指定的 Exchange 閘道伺服器以外的伺服器可能在無意中路由傳送組織外的郵件。

雖然您可以只使用 SMTP 虛擬伺服器來傳送及接收網際網路郵件，但是建議的最佳作法就是設定專用的 SMTP 連接器來路由傳送網際網路郵件。建議您使用 SMTP 連接器，因為它可以為要進入網際網路的郵件提供個別的路由。此外，SMTP 連接器的可用組態選項也比 SMTP 虛擬伺服器來得多。

若需如何使用 SMTP 連接器的詳細資訊，請參閱 Microsoft 知識庫文章 294736＜在 Exchange 2000 建立 SMTP 連接器的時機＞ (http://go.microsoft.com/fwlink/?linkid=3052&kbid=294736)。

若需有關 SMTP 連接器的詳細資訊，請參閱《Exchange Server 傳輸及路由手冊》(http://go.microsoft.com/fwlink/?LinkId=47579)。


SMTP LocalRetryMinutes 登錄值並非預設值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更預設的 SMTP 佇列組態：

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

如果 Exchange Server Analyzer 發現已設定 LocalRetryMinutes 機碼，則會顯示非預設的訊息。

建議您在全面考量後，再進行預設佇列值的修改。這些預設值經過謹慎的選擇，可讓大部分環境獲得最佳效能。一般的最佳作法是解決問題的根本來源，而不是去修改 Exchange 上的佇列行為。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要採取任何動作。

若需有關 Exchange SMTP 佇列的詳細資訊，請參閱 Microsoft Exchange 團隊部落格中的＜解說神秘的 SMTP 進階佇列引擎＞項目 (英文) (http://go.microsoft.com/fwlink/?LinkId=48585)。


已手動新增 SMTP FileCacheLifeTimeSeconds 登錄值，但可能不再需要此值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已將每個快取網際網路資訊服務 (IIS) 檔案控制代碼之預設存留時間變更為預設值 1,880 秒 (30 分鐘) 以外的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Inetinfo\Parameters\FileCacheLifeTimeSeconds

如果 Exchange Server Analyzer 發現 FileCacheLifeTimeSeconds 存在且設為其他值，則會顯示非預設的組態訊息。

FileCacheLifeTimeSeconds 值指定所快取之 IIS 檔案控制代碼的存留時間。將檔案控制代碼快取以提高效能，因為快取的檔案控制代碼讓伺服器不必執行多餘的輸入/輸出 (I/O) 及 CPU 週期。每次 Exchange Server 電腦上的 SMTP 傳輸堆疊收到一封郵件時，該郵件會輸出到檔案系統等待傳送到它的目的地。為了寫入檔案系統，SMTP 傳輸堆疊會取得一個檔案控制代碼，然後將訊息傳遞到該檔案控制代碼。每一個檔案控制代碼消耗大約 2 KB 的分頁集區記憶體。IIS 快取檔案控制代碼的預設數目是每 32 MB 有 800 個。

在預設的情況下，此登錄值是不存在的，因為 Exchange 2000 Server Service Pack 2 (SP2) 及更新版本和 Exchange Server 2003 是設為快取最佳的檔案控制代碼數目。Exchange Server 2003 會動態計算 SMTP 檔案控制代碼的適當設定，所以不再需要這些設定。因此，在將含有這些設定的 Exchange 2000 Server 電腦升級到 Exchange Server 2003 之前，您應該從登錄中刪除這些項目。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

  3. 在右窗格中，刪除 FileCacheLifeTimeSeconds 值。

  4. 關閉登錄編輯程式並重新啟動 IIS Admin 服務，讓變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


已手動新增 SMTP FileCacheMaxHandles 登錄值，但可能不再需要此值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已修改最大網際網路資訊服務 (IIS) 檔案快取控制代碼數的預設值 800：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Inetinfo\Parameters\FileCacheMaxHandles

如果 Exchange Server Analyzer 發現 FileCacheMaxHandles 存在且已設為 800 以外的任一值，則會顯示非預設的組態訊息。

FileCacheMaxHandles 值指定 Exchange 每 32 MB 之實體記憶體所使用的最大 IIS 檔案控制代碼數目。將檔案控制代碼快取以提高效能，因為快取的檔案控制代碼讓伺服器不必執行多餘的輸入/輸出 (I/O) 及 CPU 週期。每次 Exchange Server 電腦上的 SMTP 傳輸堆疊收到郵件時，都會將它串流到檔案系統中，它會在此檔案系統上等待被路由傳送到其目的地。若要寫入檔案系統，SMTP 傳輸堆疊會取得檔案控制代碼，然後將郵件傳送給該控制代碼。每一個檔案控制代碼消耗大約 2 KB 的分頁集區記憶體。IIS 快取檔案控制代碼的預設數目是每 32 MB 有 800 個。

在 Exchange 2000 Server 的 Service Pack 2 (SP2) 之前，因為 SMTP 服務的最大檔案控制代碼數之預設值為 1,000，所以之前也發生過支援大型 SMTP 訊息佇列 (例如，平均 1,000 封或以上的郵件) 效能條件約束的 Exchange 伺服器。因為 Exchange 2000 Server 預設為最多 1000 個檔案控制代碼，所以 SMTP 服務只能將 1000 封同時傳入的郵件寫入檔案系統。

為了增進這些大型系統的效能，需要經常同時調整三個登錄項目，以增加 SMTP 服務可開啟的最大檔案控制代碼數目 (這樣才能處理更多的郵件)，以及減少可安裝檔案系統 (另一個 Exchange 元件) 的開啟檔案控制代碼數目 (來避免在佇列變大時，發生記憶體不足)。下面列出這些登錄值 (預設是不存在，因此需要手動新增它們)：

位置：HKLM\System\CurrentControlSet\Services\SMTPSVC\Queuing

值：MsgHandleThreshold

類型：REG_DWORD

位置：HKLM\System\CurrentControlSet\Services\SMTPSVC\Queuing

值：MsgHandleAsyncThreshold

類型：REG_DWORD

位置：HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

值：FileCacheMaxHandles

類型：REG_DWORD

MsgHandleThreshold 和 MsgHandleAsyncThreshold 項目一般會調整為相同的值 (通常是大於 1000 的值)，而 FileCacheMaxHandles 值通常會從 800 減少為 600。

預設是沒有此登錄值，因為 Exchange 2000 Server Service Pack 2 (SP2) 和更新版本會動態決定要使用的最佳值。如果此 Exchange 伺服器執行的是 Exchange 2000 Server Service Pack 1 或更早的版本，則建議最佳作法是升級成最新層級的 Service Pack 及彙總套件。升級成最新程式碼後，便能刪除這些登錄項目。

由於 Exchange Server 2003 會動態計算 SMTP 檔控制代碼的適當設定，所以不再需要這些設定。因此，在將含有這些設定的 Exchange 2000 Server 電腦升級到 Exchange Server 2003 之前，您應該從登錄中刪除這些項目。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

  3. 刪除 FileCacheMaxHandles 值。

  4. 關閉登錄編輯程式，然後重新啟動 IIS Admin 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


SMTP GlitchRetrySeconds 登錄值已經被手動設定
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-01-17

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已手動覆寫預設問題重試等候時間：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\GlitchRetrySeconds

如果 Exchange Server Analyzer 發現 GlitchRetrySeconds 已存在且已設定，就會顯示非預設的組態訊息。

如果 Exchange 2000 Server 或 Exchange Server 2003 嘗試將郵件路由傳送至負載沈重的外部 SMTP 系統，就會收到「伺服器忙碌中」的錯誤訊息。發生這種情形時，Exchange 會進入一個稱為「問題重試」的狀態。在此情況下，Exchange 會在嘗試重新傳送郵件之前等候 60 秒，並在採取其他動作之前重複此處理程序三次。如果外部 SMTP 伺服器持續忙碌中，建議您降低問題重試等候時間以防止大量郵件留在佇列中。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. 在右窗格中，刪除 GlitchRetrySeconds 值。或者，如果目前發生大量佇列的情形，您可以降低 GlitchRetrySeconds 的值。

  4. 關閉登錄編輯程式並重新啟動 Simple Mail Transfer Protocol (SMTP) 服務，以使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


SMTP IgnorePFTimeLimit 登錄值已經被手動設定
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-01-17

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已手動設定 SMTP 服務路由引擎略過新公用資料夾儲存區的天數︰

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\IgnorePFTimeLimit

如果 Exchange Server Analyzer 發現 IgnorePFTimeLimit 存在而且已設定，就會顯示非預設的組態訊息。

當新公用資料夾儲存區連線時，您會在 [佇列檢視器] 中發現到本機傳遞佇列持續成長中。如果公用資料夾階層很大，則本機佇列中的郵件會繼續成長，而且需要花額外的時間來傳遞。在某些情況下，郵件可能不會傳遞。

導入新伺服器時，其辨別名稱會加入至 Active Directory® 目錄服務中系統管理群組之資料夾階層公用資料夾物件的 msExchOwningPFTreeBL 屬性。當伺服器上的分類程式在收到寄往公用資料夾的郵件後讀取 msExchOwningPFTreeBL 屬性時，它應該會先選取本機公用資料夾儲存區 (如果本機公用資料夾儲存區已存在)。為了達到負載平衡的目的，它隨即會按照清單中的順序來選取公用資料夾儲存區。因為新伺服器列在清單中的第一個，所以郵件會路由傳送至此新伺服器，並加到它的本機傳遞佇列中。如果公用資料夾儲存區未收到階層的複本，伺服器便無法將郵件路由傳送至擁有目的地資料夾複本的儲存區。

在新公用資料夾伺服器的登錄中加入 IgnorePFTimeLimit，可以避免這個問題。這樣會指定路由引擎略過新公用資料夾儲存區的天數。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. 在右窗格中，刪除 IgnorePFTimeLimit。

  4. 關閉登錄編輯程式，然後重新啟動 IIS Admin Service，使變更生效。

若需有關此問題及本文所述之 IgnorePFTimeLimit 登錄值的詳細資訊，請參閱微軟知識庫文件 - 328870＜XADM：在複寫階層之前啟用公用資料夾路由＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328870)。

在編輯登錄之前，以及想瞭解有關如何編輯登錄的詳細資訊時，請閱讀微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


SMTP 執行個體設定了多個通訊埠連結
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已變更針對 msExchServerBindings 屬性所設定的預設值 25，或是否已設定多個值。依預設，會將 msExchServerBindings 屬性設為 TCP 通訊埠 25。如果 Exchange Server Analyzer 發現此屬性已設定多個值，就會顯示非預設的組態訊息，同時顯示已設定多個值之虛擬簡易郵件傳送通訊協定 (SMTP) 伺服器的名稱。

msExchServerBindings 屬性代表此 SMTP 伺服器用來聆聽輸入連線的 TCP 通訊埠。可將 SMTP 虛擬伺服器設定成接聽一或多個 TCP 通訊埠。預設會將所有的 SMTP 虛擬伺服器設定成接聽 TCP 通訊埠 25 (預設的 SMTP 連接埠)。若修改了預設的 SMTP 接聽通訊埠，而使通訊埠中含有多個通訊埠連結，則會中斷郵件流程。

您可以變更 SMTP 接聽通訊埠，只要其餘的內部傳訊基礎結構也都隨之修改即可。然而，一般而言，由於網際網路上的 SMTP 伺服器會透過通訊埠 25 來傳送郵件，因此直接從網際網路接受郵件的 SMTP 虛擬伺服器不可使用其他通訊埠。

Exchange Server Analyzer 會查看 Exchange SMTP 通訊協定虛擬伺服器的值。這台 SMTP 通訊協定虛擬伺服器可能是 (也可能不是) 直接從網際網路接收郵件的 SMTP 伺服器。有些防毒及防垃圾郵件的產品，設計成在通訊埠 25 上接收網際網路的 SMTP 郵件，並將其重新導向到另一個通訊埠上的 Exchange SMTP 虛擬伺服器。在此案例中，Exchange SMTP 虛擬伺服器在多個通訊埠上進行接聽是可以接受的組態。

若要檢視或修改 SMTP 虛擬伺服器接聽通訊埠

  1. 開啟 [Exchange 系統管理員]。

  2. 依序展開 [伺服器]、Exchange 伺服器、[通訊協定]，然後展開 [SMTP]。

  3. 以滑鼠右鍵按一下 SMTP 虛擬伺服器 (例如預設 SMTP 虛擬伺服器)，然後按一下 [內容]。

  4. 選取 [一般] 索引標籤，然後按一下 [進階]。

  5. 會顯示 IP 位址及通訊埠的清單。

    • 若要變更現有的通訊埠，請選取 IP 位址，再按一下 [編輯]。將此 TCP 通訊埠欄位變更為 25。

    • 若要將通訊埠 25 新增為額外的接聽通訊埠，請按一下 [新增]，然後新增新的 IP 位址/通訊埠組合。如果您使用的是 [連線]、[寄件者] 或 [收件者] 篩選，請確定您已選取適當的核取方塊。

  6. 按一下 [確定] 以儲存變更，再按一下 [確定] 以結束 [進階] 對話方塊。

  7. 按一下 [確定]，關閉 SMTP 虛擬伺服器的 [內容] 對話方塊。

若需有關 SMTP 虛擬伺服器設定的詳細資訊，請參閱下列微軟知識庫文件：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


SMTP 郵件失敗警告 - BadMail 郵件一般失敗
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 BadmailedMessagesGeneralFailure 機碼值。此機碼的值代表因為與特定計數器無關的原因而傳送到 Badmail 目錄的郵件數目。Badmail 目錄是用來存放無法傳送的郵件。若需部分其他 Badmail WMI 計數器的相關資訊，請參閱下列 Exchange Server Analyzer 文件：

  • SMTP 郵件失敗警告 - BadMail 郵件躍點計數閾值

  • SMTP 郵件失敗警告 - DSN 的 BadMail 郵件 NDR

當郵件因其他原因而傳送到 Badmail 目錄時也有一些計數器會增加，這些原因包括錯誤的收取檔案、無收件者及透過事件觸發。

Exchange Server Analyzer 也會查詢 Win32_PerfRawData_PerfOS_System WMI 機碼，以判定 SystemUpTime 的值。

如果 Exchange Server Analyzer 判定 SystemUpTime 機碼值大於 0，且 BadmailedMessagesGeneralFailure 值除以 SystemUpTime 值的結果大於 1000，就會顯示警告。

此警告指出每天平均有 1,000 封以上的郵件標示為無法傳遞，且儲存在 Badmail 目錄中。必須手動刪除 Badmail 目錄中的郵件。建議您定期執行 Exchange Server 維護來檢閱和刪除 Badmail 目錄中的郵件。允許 Badmail 目錄無限制地增大會耗盡所有可用的磁碟空間，而使 Exchange 資料庫卸載。

若要更正此警告

  1. 請檢查 Badmail 目錄中的郵件，來判定郵件來源是內部還是外部。Badmail 目錄中的郵件是以 ASCII 格式儲存，所以可以在記事本或其他文字編輯器中開啟及檢視這些郵件。

    • 如果郵件似乎是在內部產生，您可以檢查其郵件標頭以判定它的來源。

    • 如果郵件似乎是在外部產生，可能表示您的 Exchange Server 被用於郵件轉送。

若需有關如何控制及設定轉送選項的詳細資訊，起參閱下列微軟知識庫文件：

  • 310380＜HOW TO:避免 Exchange 2000 在 Windows 2000 中被用於做為郵件轉送＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=310380)

  • 313395＜HOW TO:檢查匿名 SMTP 連線的轉接限制＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=313395)

若需有關資料庫因為可用磁碟空間不足而卸載的詳細資訊，請參閱微軟知識庫文件 - 321825＜資料庫因為磁碟空間不足而卸載＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=321825)。


SMTP 郵件失敗警告 - BadMail 郵件躍點計數閾值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 BadmailedMessagesHopCountExceeded 機碼值。這個機碼的值代表因為超過最大躍點計數而被送到 Badmail 目錄的郵件數目。Badmail 目錄是用來存放無法傳送的郵件。若需有關部分其他 Badmail WMI 計數器的詳細資訊，請參閱 Exchange Server Analyzer 工具文件：＜SMTP 郵件失敗警告 - BadMail 郵件一般失敗＞及＜SMTP 郵件失敗警告 - DSN 的 BadMail 郵件 NDR＞。

當郵件因其他原因而傳送到 Badmail 目錄時也有一些計數器會增加，這些原因包括錯誤的收取檔案、無收件者及透過事件觸發。

Exchange Server Analyzer 也會查詢 Win32_PerfRawData_PerfOS_System WMI 機碼，以判定 SystemUpTime 的值。

如果 Exchange Server Analyzer 判定 SystemUpTime 機碼的值大於 0，且 BadmailedMessagesHopCountExceeded 值除以 SystemUpTime 值的結果大於100，就會顯示一則警告。

這個警告表示每天平均有 100 封以上的郵件因為超過最大躍點計數而被標示為無法傳遞，並儲存在 Badmail 目錄中。最大躍點計數是郵件從寄件者傳到收件者的過程中，所經過的 SMTP 伺服器最大數目。每當有郵件通過 SMTP 伺服器時，就會在郵件標頭加上一行代表躍點的文字。

依您網路和郵件傳遞需求的不同，最佳的郵件躍點數量會有差異。若要防止重複傳送郵件的錯誤 (即所謂的訊息迴圈狀況)，系統管理員可以控制允許的躍點數上限。您可以設定 SMTP 虛擬伺服器的最大躍點計數來執行此作業。在 Exchange 2000 Server 中，預設躍點計數為 15。在 Exchange Server 2003 中，預設值為 30。建議 Exchange 2000 Server 及 Exchange Server 2003 SMTP 虛擬伺服器都使用值 30。

必須手動刪除 Badmail 目錄中的郵件。建議您將定期檢閱及刪除 Badmail 目錄中的郵件當成 Exchange Server 定期維護工作的一部分。允許 Badmail 目錄無限制地增大會耗盡所有可用的磁碟空間，而使 Exchange 資料庫卸載。

若要更正此警告

  1. 檢查 Badmail 郵件目錄中的郵件，以判定該郵件的來源是內部還是外部。Badmail 目錄中的郵件是以 ASCII 格式儲存，所以可以在記事本或其他文字編輯器中開啟及檢視這些郵件。

    • 如果郵件似乎是在內部產生，您可以檢查其郵件標頭以判定它的來源。

    • 如果郵件似乎是在外部產生，可能表示您的 Exchange Server 被用於郵件轉送。

  2. 將 [最大躍點計數] 值設為 30。

    1. 開啟 [Exchange 系統管理員]。

    2. 展開 [伺服器]，接著展開一部 Exchange 伺服器，再依序展開 [通訊協定]、[SMTP]。

    3. 在 SMTP 虛擬伺服器上按一下滑鼠右鍵 (例如，預設的 SMTP 虛擬伺服器)，並選取 [內容]。

    4. 選取 [傳遞] 索引標籤，然後按一下 [進階]。

    5. 在 [最大躍點計數] 欄位中輸入所要的值，並按一下 [確定] 儲存變更。

    6. 按一下 [確定]，關閉 SMTP 虛擬伺服器的 [內容] 對話方塊。

若需有關如何控制及設定轉送選項的詳細資訊，起參閱下列微軟知識庫文件：

  • 310380＜HOW TO: 避免 Exchange 2000 在 Windows 2000 中被用於做為郵件轉送＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=310380)

  • 313395＜HOW TO: 檢查匿名 SMTP 連線的轉接限制＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=313395)

若需有關因可用磁碟空間不足而導致資料庫卸載的詳細資訊，請參閱微軟知識庫文件 - 321825＜資料庫因為磁碟空間不足而卸載＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=321825)。


SMTP 郵件失敗警告 - DSN 的 BadMail 郵件 NDR
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-23

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 BadmailedMessagesNDRofDSN 機碼的值。此機碼的值代表因為無法傳送而傳送至 Badmail 目錄的傳遞狀態通知 (DSN) 郵件數目。Badmail 目錄是用來存放無法傳送的郵件。若需部分其他 Badmail WMI 計數器的詳細資訊，請參閱 Exchange Server Analyzer 文件，SMTP 郵件失敗警告 - BadMail 郵件一般失敗及 SMTP 郵件失敗警告 - BadMail 郵件躍點計數閾值。

當郵件因其他原因而傳送到 Badmail 目錄時，計數器會累加，這些原因包括錯誤的收取檔案、無收件者及透過事件觸發。

Exchange Server Analyzer 也會查詢 Win32_PerfRawData_PerfOS_System WMI 機碼，以判定 SystemUpTime 的值。

如果 Exchange Server Analyzer 判定 SystemUpTime 機碼值大於 0，且 BadmailedMessagesNDRofDSN 值除以 SystemUpTime 值的結果大於 1000，就會顯示警告。

此警告表示每天平均有 1,000 個以上的 DSN 因為無法傳遞而儲存在 Badmail 目錄中。必須手動刪除 Badmail 目錄中的郵件。建議您將定期檢閱及刪除 Badmail 目錄中的郵件當成 Exchange Server 定期維護工作的一部分。允許 Badmail 目錄無限制地增大會耗盡所有可用的磁碟空間，而使 Exchange 資料庫卸載。

若要更正此警告

  • 請檢查 Badmail 目錄中的郵件，判定 DSN 是要寄給內部或外部收件者。Badmail 目錄中的郵件是以 ASCII 格式儲存，所以可以在記事本或其他文字編輯器中開啟及檢視這些郵件。

    • 如果 DSN 是要用於內部的收件者，它會指出郵件流向的問題。若要疑難排解此問題，將仰賴 DSN 傳回的特定數字型代碼。

    • 如果 DSN 是要用於外部的收件者，可能表示您的 Exchange Server 被用於郵件轉送。若要疑難排解此問題，也將仰賴傳回的特定數字型代碼。

若需傳遞 DSN 數值傳回碼的詳細資訊，請參閱微軟知識庫文件 284204＜Exchange Server 和 Small Business Server 中的傳遞狀態通知＞。

若需如何控制及設定轉送選項的相關資訊，請參閱微軟知識庫文件 313395＜HOW TO：在 Exchange 2000 Server 中檢查匿名 SMTP 連線的轉接限制及篩選未經要求的電子郵件訊息＞。

若需由於可用磁碟空間不足而導致資料庫卸載的詳細資訊，請參閱微軟知識庫文件 321825＜因為磁碟空間不足而卸載資料庫＞(英文) 。


SMTP 郵件失敗警告 - 找不到分類程式位址查詢
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-03-20

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 CatAddresslookupsnotfound 機碼值。此機碼的值代表郵件分類程式所執行且找不到目錄服務物件的網址查詢數目。Exchange Server Analyzer 也會查詢 Win32_PerfRawData_PerfOS_System WMI 機碼，以判定 SystemUpTime 的值。

如果 Exchange Server Analyzer 判定 SystemUpTime 機碼的值大於 0，且 CatAddresslookupsnotfound 之值除以 SystemUpTime 之值的結果大於 5000，就會顯示一則警告。

郵件分類程式會檢查進入 SMTP 伺服器的郵件，並且判斷應如何處置郵件。郵件可能會被送到本機的資訊儲存庫、使用郵件傳輸代理程式 (MTA) 送到遠端主機，或使用 SMTP 將郵件送到遠端主機。分類程式也會控制通訊群組清單展開。分類程式是進階佇列引擎的外掛程式，該引擎會用 TCP 連接埠 3268 針對通用類別目錄伺服器執行「輕量型目錄存取通訊協定 (LDAP)」查詢。分類程式基本上是一個事件接收器的集合，針對通過進階佇列引擎的每一封郵件，執行進階位址解析。它會執行位址解析、郵件轉寄、設定內容轉換旗標、展開通訊群組清單、實施通用設定、產生傳遞狀態通知，同時也會執行替代的收件者路徑偵測、分叉、記錄以及許多其他功能。

當郵件進入郵件分類程式時，分類程式會在 Active Directory® 目錄服務的 Proxy 位址屬性中搜尋位址，來解析信封寄件者。分類程式也會在 Active Directory 中的 Proxy 位址屬性搜尋每一個位址，來解析信封收件者。例如，如果清單中包含一個通訊群組清單，並且如果該伺服器容許展開通訊群組清單，則分類程式會展開該清單，使其包括那些成員。

此警告指出每天平均會發生 5,000 次或以上的分類程式位址查詢失敗。此問題有數個原因，包括目錄服務存取 (DSAccess) 問題、目錄複寫延遲或失敗、針對目錄的字典觸擊、DNS 問題或使用錯誤的位址。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 檢查 Exchange Server 電腦上的事件日誌是否有錯誤。

  2. 如果未發現可讓您用來解決問題的事件，請考慮在 MSExchangeTransport 分類程式上將診斷記錄調整到最高。啟用診斷記錄時，請重新檢查事件紀錄中是否有錯誤。如果將診斷記錄設定為最高，仍未產生任何事件日誌項目，請使用登錄將診斷記錄設定為第 7 級。當設定為第 7 級時，會記錄由郵件分類程式產生的事件識別碼 9000，該識別碼會詳細說明功能、失敗原因、失敗的收件者名稱及收件者類型。若要將診斷記錄設為等級 7：

    1. 開啟登錄編輯程式 (如 Regedit.exe 或 Regedt32.exe)

    2. 瀏覽至：

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. 在右窗格中，連按兩下 [2 分類程式]，將值資料設為 7，再按 [確定]。

    4. 關閉登錄編輯程式。

      附註：
      當您完成疑排解時，請將 [2 分類程式] 的值資料設回 0。

  3. 請確認 Exchange Server 可連至一或多個通用目錄伺服器。Windows 中的 [網路監視器] 工具對於這點相當有用。

  4. 請檢驗任何產生的傳遞狀態通知 (DSN) 郵件。DSN 可能包含未傳遞回報 (NDR)，可描述永久失敗的郵件，以及經常以永久傳遞之錯誤結束的暫時性失敗的郵件。

  5. 請使用 [郵件追蹤] 以疑難排解停駐在分類程式中的郵件。

  6. 請使用 Archive Sink 工具以封存和分析正在傳入和移出 Exchange Server 之郵件。

  7. 請使用 [系統監視器] 以監視分類程式的效能計數器。

若需有關 Exchange Server 及 Microsoft Windows Small Business Server 產生之 DSN 與 NDR 的詳細資訊，請參閱 Microsoft 知識庫文章 284204＜Exchange 2000 Server 及 Small Business Server 的傳遞狀態通知＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204)。

若需在 Exchange Server 使用「郵件追蹤中心」的相關資訊，請參閱下列 Microsoft 知識庫文章：

  • 262162＜XADM：使用「郵件追蹤中心」來追蹤訊息＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856＜XADM：如何在 Exchange 2000 Server 中啟用郵件追蹤＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905＜Exchange Server 2003 中的郵件追蹤事件識別碼＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864＜Exchange Server 2003 中改良的郵件追蹤功能＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

若需有關郵件分類程式問題的疑難排解資訊，請參閱 Microsoft Support WebCast: Exchange 2000 Server:郵件分類程式及 NDR 疑難排解＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)。

若需有關 Archive Sink 工具的詳細資訊，請參閱 Microsoft 知識庫文章 307798＜Service Pack 2 提供 Archive Sink 公用程式＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)。

若需疑難排解傳輸相關問題的一般資訊，請參閱下列 Microsoft 知識庫文章：

  • 821910＜如何疑難排解 Exchange Server 2003 傳輸問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265＜XCON：Exchange 2000 傳輸問題的一般疑難排解＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

郵件分類程式的效能計數器，會針對每一個 SMTP 虛擬伺服器執行個體分別公布。若需與郵件分類程式相關之可用效能計數器的清單，請參閱 Microsoft 知識庫文章 231734＜XCON：郵件分類程式的效能監視計數器＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)。

若需部份其他 Categorizer WMI 計數器的詳細資訊，請參閱下列 Exchange Server Analyzer 文件：

  • SMTP 郵件失敗警告 - 分類程式目錄服務失敗

  • SMTP 郵件失敗警告 - 分類程式目錄登入失敗

  • SMTP 郵件失敗警告 - 分類程式發生不可重試的錯誤

  • SMTP 郵件失敗警告 - 分類程式記憶體不足失敗

  • SMTP 郵件失敗警告 - 分類程式可重試錯誤


SMTP 郵件失敗警告 - 分類程式目錄登入失敗
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 CatCategorizationsfailedDSlogonfailure 機碼的值。此機碼的值代表因為目錄服務登入失敗而造成的分類失敗數目。Exchange Server Analyzer 也會查詢 Win32_PerfRawData_PerfOS_System WMI 機碼，以判定 SystemUpTime 的值。

如果 Exchange Server Analyzer 判定 SystemUpTime 機碼值大於 0，而且 CatCategorizationsfailedDSlogonfailure 值除以 SystemUpTime 值的結果大於 50，就會顯示警告。

郵件分類程式會檢查進入 SMTP 伺服器的郵件，並且判定應如何處置郵件。郵件可能會被送到本機的資訊儲存庫、使用郵件傳輸代理程式 (MTA) 送到遠端主機，或使用 SMTP 將郵件送到遠端主機。分類程式也會控制通訊群組清單展開。分類程式是進階佇列引擎的外掛程式，該引擎會用 TCP 通訊埠 3268 針對通用類別目錄伺服器執行「輕量型目錄存取通訊協定 (LDAP)」查詢。分類程式基本上是一個事件接收器的集合，針對通過進階佇列引擎的每一封郵件，執行進階位址解析。它會執行位址解析、郵件轉寄、設定內容轉換旗標、展開通訊群組清單、實施通用設定、產生傳遞狀態通知，同時也會執行替代的收件者路徑偵測、分叉、記錄以及許多其他功能。

郵件一進入郵件分類程式時，分類程式就會在 Active Directory® 目錄服務中的 Proxy 位址屬性搜尋該位址，來解析信封寄件者。分類程式也會在 Active Directory 中的 Proxy 位址屬性搜尋每一個位址，來解析信封收件者。例如，如果清單中包含一個通訊群組清單，並且如果該伺服器允許展開通訊群組清單，則分類程式會展開該清單，以便加入那些成員。

此警告訊息表示在郵件分類程式所做的目錄服務連線嘗試中，每天平均有 50 次以上的嘗試因為登入失敗而失敗。這個問題有很多個原因，包括目錄服務存取 (DSAccess) 方面的問題、目錄複寫延遲或失敗、超載的通用類別目錄伺服器，以及 DNS 方面的問題。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 請檢查 Exchange Server 電腦上的事件日誌所記載的錯誤。

  2. 若找不到任何事件能夠讓您解決問題，可以考慮將「MSExchangeTransport 分類程式」的診斷記錄調高為「最高」。啟用診斷記錄之後，請立即重新檢查事件日誌是否有錯誤。若將診斷記錄設為最高還是無法產生任何事件日誌項目，則請使用登錄，將診斷記錄設為等級 7。設為等級 7 時，就會記錄由郵件分類程式產生的事件識別碼 9000，這會詳細列出功能、失敗原因、失敗的收件者名稱，以及收件者類型。若要將診斷記錄設為等級 7：

    1. 開啟登錄編輯程式 (如 Regedit.exe 或 Regedt32.exe)

    2. 瀏覽至：

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. 在右側窗格中，連按兩下 [2 分類程式]，將值資料設為 7，再按 [確定]。

    4. 關閉登錄編輯程式。

      附註：
      當您完成疑排解時，請將 [2 分類程式] 的值資料設回 0。

  3. 請確認 Exchange Server 可連至一或多個通用目錄伺服器。Windows 中的 [網路監視器] 工具對於這點相當有用。

  4. 請檢驗任何產生的傳遞狀態通知 (DSN) 郵件。DSN 可能包含未傳遞回報 (NDR)，可描述永久失敗的郵件，以及經常以永久傳遞之錯誤結束的暫時性失敗的郵件。

  5. 請使用 [郵件追蹤] 以疑難排解停駐在分類程式中的郵件。

  6. 請使用 Archive Sink 工具以封存和分析正在傳入和移出 Exchange Server 之郵件。

  7. 請使用 [系統監視器] 以監視分類程式的效能計數器。

若需有關 Exchange Server 及 Microsoft Windows Small Business Server 產生之 DSN 與 NDR 的詳細資訊，請參閱微軟知識庫文件 - 284204＜XCON：Exchange 2000 Server 傳遞狀態通知＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204)。

若需在 Exchange Server 中使用 [郵件追蹤中心] 的相關資訊，請參閱下列知識庫文件：

  • 262162＜XADM：使用「郵件追蹤中心」來追蹤訊息＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856＜XADM：如何在 Exchange 2000 Server 中啟用郵件追蹤＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905＜Exchange Server 2003 中的郵件追蹤事件識別碼＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864＜Exchange Server 2003 中改良的郵件追蹤功能＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

若需有關疑難排解郵件分類程式問題的詳細資訊，請參閱 Microsoft Support WebCast＜Exchange 2000 Server：郵件分類程式及 NDR 疑難排解＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)。

若需有關 Archive Sink 工具的詳細資訊，請參閱微軟知識庫文件 - 307798＜Service Pack 2 提供 Archive Sink 公用程式＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)。

若需有關疑難排解傳輸相關問題的一般資訊，請參閱下列知識庫文件：

  • 821910＜如何疑難排解 Exchange Server 2003 傳輸問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265＜XCON：Exchange 2000 傳輸問題的一般疑難排解＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

郵件分類程式的效能計數器，會針對每一個 SMTP 虛擬伺服器執行個體分別公布。若需與郵件分類程式相關的可用效能計數器清單，請參閱微軟知識庫文件 - 231734＜XCON：郵件分類程式的效能監視計數器＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)。

若需部份其他 Categorizer WMI 計數器的詳細資訊，請參閱下列 Exchange Server Analyzer 文件

  • SMTP 郵件失敗警告 - 分類程式目錄服務失敗

  • SMTP 郵件失敗警告 - 找不到分類程式位址查詢

  • SMTP 郵件失敗警告 - 分類程式發生不可重試的錯誤

  • SMTP 郵件失敗警告 - 分類程式記憶體不足失敗

  • SMTP 郵件失敗警告 - 分類程式可重試錯誤


SMTP 郵件失敗警告 - 分類程式目錄服務失敗
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-03-20

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 CatCategorizationsfailedDSconnectionfailure 機碼值。此機碼的值代表因目錄服務連線服務失敗而失敗的類別數目。Exchange Server Analyzer 也會查詢 Win32_PerfRawData_PerfOS_System WMI 機碼，以判定 SystemUpTime 的值。

如果 Exchange Server Analyzer 判定 SystemUpTime 機碼的值大於 0，且 CatCategorizationsfailedDSconnectionfailure 值除以 SystemUpTime 值的結果大於 50，就會顯示一則警告。

郵件分類程式會檢查進入 SMTP 伺服器的郵件，並且判斷應如何處置郵件。郵件可能會被送到本機的資訊儲存庫、使用郵件傳輸代理程式 (MTA) 送到遠端主機，或使用 SMTP 將郵件送到遠端主機。分類程式也會控制通訊群組清單展開。分類程式是進階佇列引擎的外掛程式，該引擎會用 TCP 連接埠 3268 針對通用類別目錄伺服器執行「輕量型目錄存取通訊協定 (LDAP)」查詢。分類程式基本上是一個事件接收器的集合，針對通過進階佇列引擎的每一封郵件，執行進階位址解析。它會執行位址解析、郵件轉寄、設定內容轉換旗標、展開通訊群組清單、實施通用設定、產生傳遞狀態通知，同時也會執行替代的收件者路徑偵測、分叉、記錄以及許多其他功能。

當郵件進入郵件分類程式時，分類程式會在 Active Directory® 目錄服務的 Proxy 位址屬性中搜尋位址，來解析信封寄件者。分類程式也會在 Active Directory 中的 Proxy 位址屬性搜尋每一個位址，來解析信封收件者。例如，如果清單中包含一個通訊群組清單，並且如果該伺服器容許展開通訊群組清單，則分類程式會展開該清單，使其包括那些成員。

此警告指出郵件分類程式每天平均會造成 50 次或以上嘗試進行目錄服務連線失敗。這個問題有幾個原因，包括目錄服務存取 (DSAccess) 方面的問題、目錄複寫延遲或失敗、超載的通用類別目錄伺服器，以及 DNS 方面的問題。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 檢查 Exchange Server 電腦上的事件日誌是否有錯誤。

  2. 如果未發現可讓您用來解決問題的事件，請考慮在 MSExchangeTransport 分類程式上將診斷記錄調整到最高。啟用診斷記錄之後，請立即重新檢查事件日誌是否有錯誤。如果將診斷記錄設定為最高，仍未產生任何事件日誌項目，請使用登錄將診斷記錄設定為第 7 級。當設定為第 7 級時，會記錄由郵件分類程式產生的事件識別碼 9000，該識別碼會詳細說明功能、失敗原因、失敗的收件者名稱及收件者類型。若要將診斷記錄設為等級 7：

    1. 開啟登錄編輯程式 (如 Regedit.exe 或 Regedt32.exe)

    2. 瀏覽至：

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. 在右窗格中，連按兩下 [2 分類程式]，將數值資料設為 7，再按 [確定]。

    4. 關閉登錄編輯程式。

      附註：
      當您完成疑排解時，請將 [2 分類程式] 的值資料設回 0。

  3. 請確認 Exchange Server 可連至一或多個通用目錄伺服器。Windows 中的 [網路監視器] 工具對於這點相當有用。

  4. 請檢驗任何產生的傳遞狀態通知 (DSN) 郵件。DSN 可能包含未傳遞回報 (NDR)，可描述永久失敗的郵件，以及經常以永久傳遞之錯誤結束的暫時性失敗的郵件。

  5. 請使用 [郵件追蹤] 以疑難排解停駐在分類程式中的郵件。

  6. 請使用 Archive Sink 工具以封存和分析正在傳入和移出 Exchange Server 之郵件。

  7. 請使用 [系統監視器] 以監視分類程式的效能計數器。

若需有關 Exchange Server 及 Microsoft Windows Small Business Server 產生之 DSN 與 NDR 的詳細資訊，請參閱 Microsoft 知識庫文章 284204＜Exchange 2000 Server 及 Small Business Server 的傳遞狀態通知＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204)。

若需在 Exchange Server 使用「郵件追蹤中心」的相關資訊，請參閱下列 Microsoft 知識庫文章：

  • 262162＜XADM：使用「郵件追蹤中心」來追蹤訊息＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856＜XADM：如何在 Exchange 2000 Server 中啟用郵件追蹤＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905＜Exchange Server 2003 中的郵件追蹤事件識別碼＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864＜Exchange Server 2003 中改良的郵件追蹤功能＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

若需有關疑難排解郵件分類程式問題的詳細資訊，請參閱 Microsoft Support WebCast＜Exchange 2000 Server：郵件分類程式及 NDR 疑難排解＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)。

若需有關 Archive Sink 工具的詳細資訊，請參閱 Microsoft 知識庫文章 307798＜Service Pack 2 提供 Archive Sink 公用程式＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)。

若需疑難排解傳輸相關問題的一般資訊，請參閱下列 Microsoft 知識庫文章：

  • 821910＜如何疑難排解 Exchange Server 2003 傳輸問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265＜XCON：Exchange 2000 傳輸問題的一般疑難排解＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

郵件分類程式的效能計數器，會針對每一個 SMTP 虛擬伺服器執行個體分別公布。若需與郵件分類程式相關之可用效能計數器的清單，請參閱 Microsoft 知識庫文章 231734＜XCON：郵件分類程式的效能監視計數器＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)。

若需部份其他 Categorizer WMI 計數器的詳細資訊，請參閱下列 Exchange Server Analyzer 文件：

  • SMTP 郵件失敗警告 - 找不到分類程式位址查詢

  • SMTP 郵件失敗警告 - 分類程式目錄登入失敗

  • SMTP 郵件失敗警告 - 分類程式發生不可重試的錯誤

  • SMTP 郵件失敗警告 - 分類程式記憶體不足失敗

  • SMTP 郵件失敗警告 - 分類程式可重試錯誤


SMTP 郵件失敗警告 - 分類程式發生不可重試的錯誤
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 CatCategorizationsfailednonretryableerror 機碼值。此機碼的值代表因重大錯誤而失敗 (不可重試) 的類別數目。Exchange Server Analyzer 也會查詢 Win32_PerfRawData_PerfOS_System WMI 機碼，以判定 SystemUpTime 的值。

如果 Exchange Server Analyzer 判定 SystemUpTime 機碼值大於 0，且 CatCategorizationsfailednonretryableerror 之值除以 SystemUpTime 之值的結果大於 50，就會顯示一則警告。

郵件分類程式會檢查進入 SMTP 伺服器的郵件，並且判斷應如何處置郵件。郵件可能會被送到本機的資訊儲存庫、使用郵件傳輸代理程式 (MTA) 送到遠端主機，或使用 SMTP 將郵件送到遠端主機。分類程式也會控制通訊群組清單展開。分類程式是進階佇列引擎的外掛程式，該引擎會用 TCP 連接埠 3268 針對通用類別目錄伺服器執行「輕量型目錄存取通訊協定 (LDAP)」查詢。分類程式基本上是一個事件接收器的集合，針對通過進階佇列引擎的每一封郵件，執行進階位址解析。它會執行位址解析、郵件轉寄、設定內容轉換旗標、展開通訊群組清單、實施通用設定、產生傳遞狀態通知，同時也會執行替代的收件者路徑偵測、分叉、記錄以及許多其他功能。

郵件一進入郵件分類程式時，分類程式就會在 Active Directory® 目錄服務中的 Proxy 位址屬性中搜尋該位址，來解析信封寄件者。分類程式也會在 Active Directory 中的 Proxy 位址屬性搜尋每一個位址，來解析信封收件者。例如，如果清單中包含一個通訊群組清單，並且如果該伺服器容許展開通訊群組清單，則分類程式會展開該清單，使其包括那些成員。

此警告指出每天平均會發生 50 次或以上的重大錯誤。這個問題有幾個原因，包括目錄服務存取 (DSAccess) 方面的問題、目錄複寫延遲或失敗、超載的通用類別目錄伺服器，以及 DNS 方面的問題。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 請檢查 Exchange Server 電腦上的事件日誌所記載的錯誤。

  2. 若找不到任何事件能夠讓您解決問題，可以考慮將「MSExchangeTransport 分類程式」的診斷記錄調高為「最高」。在啟用診斷記錄之後，重新檢查事件日誌中的錯誤記錄。若將診斷記錄設為最高還是無法產生任何事件日誌項目，則請使用登錄，將診斷記錄設為等級 7。設為等級 7 時，就會記錄由郵件分類程式產生的事件識別碼 9000，這會詳細列出功能、失敗原因、失敗的收件者名稱，以及收件者類型。若要將診斷記錄設為等級 7：

    1. 開啟登錄編輯程式 (如 Regedit.exe 或 Regedt32.exe)

    2. 瀏覽至：

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. 在右窗格中，連按兩下 [2 分類程式]，將值資料設為 7，再按 [確定]。

    4. 關閉登錄編輯程式。

      附註：
      當您完成疑排解時，請將 [2 分類程式] 的值資料設回 0。

  3. 請確認 Exchange Server 可連至一或多個通用目錄伺服器。Windows 中的 [網路監視器] 工具對於這點相當有用。

  4. 請檢驗任何產生的傳遞狀態通知 (DSN) 郵件。DSN 可能包含未傳遞回報 (NDR)，可描述永久失敗的郵件，以及經常以永久傳遞之錯誤結束的暫時性失敗的郵件。

  5. 請使用 [郵件追蹤] 以疑難排解停駐在分類程式中的郵件。

  6. 請使用 Archive Sink 工具以封存和分析正在傳入和移出 Exchange Server 之郵件。

  7. 請使用 [系統監視器] 以監視分類程式的效能計數器。

若需有關 Exchange Server 及 Microsoft Windows Small Business Server 產生之 DSN 與 NDR 的詳細資訊，請參閱微軟知識庫文件 - 284204＜Exchange 2000 Server 及 Small Business Server 的傳遞狀態通知＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204)。

若需在 Exchange Server 使用「郵件追蹤中心」的相關資訊，請參閱下列微軟知識庫文件：

  • 262162＜XADM：使用「郵件追蹤中心」來追蹤訊息＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856＜XADM：如何在 Exchange 2000 Server 中啟用郵件追蹤＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905＜Exchange Server 2003 中的郵件追蹤事件識別碼＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864＜Exchange Server 2003 中改良的郵件追蹤功能＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

若需有關疑難排解郵件分類程式問題的詳細資訊，請參閱 Microsoft Support WebCast＜Exchange 2000 Server：郵件分類程式及 NDR 疑難排解＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)。

若需有關 Archive Sink 工具的詳細資訊，請參閱微軟知識庫文件 - 307798＜Service Pack 2 提供 Archive Sink 公用程式＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)。

若需疑難排解傳輸相關問題的一般資訊，請參閱下列微軟知識庫文件：

  • 821910＜如何疑難排解 Exchange Server 2003 傳輸問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265＜XCON：Exchange 2000 傳輸問題的一般疑難排解＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

郵件分類程式的效能計數器，會針對每一個 SMTP 虛擬伺服器執行個體分別公布。若需與郵件分類程式相關之可用效能計數器的清單，請參閱微軟知識庫文件 - 231734＜XCON：郵件分類程式的效能監視計數器＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)。

若需部份其他 Categorizer WMI 計數器的詳細資訊，請參閱下列 Exchange Server Analyzer 文件：

  • SMTP 郵件失敗警告 - 找不到分類程式位址查詢

  • SMTP 郵件失敗警告 - 分類程式目錄登入失敗

  • SMTP 郵件失敗警告 - 分類程式目錄服務失敗

  • SMTP 郵件失敗警告 - 分類程式記憶體不足失敗

  • SMTP 郵件失敗警告 - 分類程式可重試錯誤


SMTP 郵件失敗警告 - 分類程式記憶體不足失敗
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-03-28

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 CatCategorizationsfailedOutOfMemory 機碼的值。此機碼的值代表因為可用的記憶體不足而失敗的分類數目。Exchange Server Analyzer 也會查詢 Win32_PerfRawData_PerfOS_System WMI 機碼，以判定 SystemUpTime 的值。

如果 Exchange Server Analyzer 判定 SystemUpTime 機碼的值大於 0，而且 CatCategorizationsfailedOutOfMemory 值除以 SystemUpTime 值的結果大於 50，就會顯示一則警告。

郵件分類程式會檢查進入 SMTP 伺服器的郵件，並且判定應如何處置郵件。郵件可能會被送到本機的資訊儲存庫、使用郵件傳輸代理程式 (MTA) 送到遠端主機，或使用 SMTP 將郵件送到遠端主機。分類程式也會控制通訊群組清單展開。分類程式是進階佇列引擎的外掛程式，該引擎會用 TCP 通訊埠 3268 針對通用類別目錄伺服器執行「輕量型目錄存取通訊協定 (LDAP)」查詢。分類程式基本上是一個事件接收器的集合，針對通過進階佇列引擎的每一封郵件，執行進階位址解析。它會執行位址解析、郵件轉寄、設定內容轉換旗標、展開通訊群組清單、實施通用設定、產生傳遞狀態通知，同時也會執行替代的收件者路徑偵測、分叉、記錄以及許多其他功能。

郵件一進入郵件分類程式時，分類程式就會在 Active Directory® 目錄服務中的 Proxy 位址屬性搜尋該位址，來解析信封寄件者。分類程式也會在 Active Directory 中的 Proxy 位址屬性搜尋每一個位址，來解析信封收件者。例如，如果清單中包含一個通訊群組清單，並且如果該伺服器允許展開通訊群組清單，則分類程式會展開該清單，以便加入那些成員。

此警告表示因為可用的記憶體不足，所以每天平均有 50 個或更多個分類失敗。這個問題有幾個原因，包括目錄服務存取 (DSAccess) 方面的問題、目錄複寫延遲或失敗、超載的通用類別目錄伺服器，以及 DNS 方面的問題。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 請檢查 Exchange Server 電腦上的事件日誌所記載的錯誤。

  2. 若找不到任何事件能夠讓您解決問題，可以考慮將「MSExchangeTransport 分類程式」的診斷記錄調高為「最高」。在啟用診斷記錄之後，重新檢查事件日誌中的錯誤記錄。若將診斷記錄設為最高還是無法產生任何事件日誌項目，則請使用登錄，將診斷記錄設為等級 7。設為等級 7 時，就會記錄由郵件分類程式產生的事件識別碼 9000，這會詳細列出功能、失敗原因、失敗的收件者名稱，以及收件者類型。若要將診斷記錄設為等級 7：

    1. 開啟登錄編輯程式 (如 Regedit.exe 或 Regedt32.exe)

    2. 瀏覽至：

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. 在右窗格中，連按兩下 [2 分類程式]，將值資料設為 7，再按 [確定]。

    4. 關閉登錄編輯程式。

      附註：
      當您完成疑排解時，請將 [2 分類程式] 的值資料設回 0。

  3. 請確認 Exchange Server 可連至一或多個通用目錄伺服器。Windows 中的 [網路監視器] 工具對於這點相當有用。

  4. 請檢驗任何產生的傳遞狀態通知 (DSN) 郵件。DSN 可能包含未傳遞回報 (NDR)，可描述永久失敗的郵件，以及經常以永久傳遞之錯誤結束的暫時性失敗的郵件。

  5. 請使用 [郵件追蹤] 以疑難排解停駐在分類程式中的郵件。

  6. 請使用 Archive Sink 工具以封存和分析正在傳入和移出 Exchange Server 之郵件。

  7. 請使用 [系統監視器] 以監視分類程式的效能計數器。

若需有關 Exchange Server 及 Microsoft Windows Small Business Server 產生之 DSN 與 NDR 的詳細資訊，請參閱 Microsoft 知識庫文章 284204＜Exchange 2000 Server 及 Small Business Server 的傳遞狀態通知＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204)。

若需有關在 Exchange Server 使用「郵件追蹤中心」的詳細資訊，請參閱下列 Microsoft 知識庫文章：

  • 262162＜XADM：使用「郵件追蹤中心」來追蹤訊息＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856＜XADM：如何在 Exchange 2000 Server 及 Exchange Server 2003 啟用郵件追蹤＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905＜Exchange Server 2003 中的郵件追蹤事件識別碼＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864＜Exchange Server 2003 中改良的郵件追蹤功能＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

若需有關疑難排解郵件分類程式問題的詳細資訊，請參閱 Microsoft Support WebCast＜Exchange 2000 Server：郵件分類程式及 NDR 疑難排解＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)。

若需有關 Archive Sink 工具的詳細資訊，請參閱 Microsoft 知識庫文章 307798＜Service Pack 2 提供 Archive Sink 公用程式＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)。

若需疑難排解傳輸相關問題的一般資訊，請參閱下列 Microsoft 知識庫文章：

  • 821910＜如何疑難排解 Exchange Server 2003 傳輸問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265＜Exchange 2000 Server 及 Exchange Server 2003 傳輸問題的一般疑難排解＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)。

郵件分類程式的效能計數器，會針對每一個 SMTP 虛擬伺服器執行個體分別公布。若需與郵件分類程式相關之可用效能計數器的清單，請參閱 Microsoft 知識庫文章 231734＜XCON：郵件分類程式的效能監視計數器＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)。

若需部份其他 Categorizer WMI 計數器的詳細資訊，請參閱下列 Exchange Server Analyzer 文件：

  • SMTP 郵件失敗警告 - 找不到分類程式位址查詢

  • SMTP 郵件失敗警告 - 分類程式目錄登入失敗

  • SMTP 郵件失敗警告 - 分類程式目錄服務失敗

  • SMTP 郵件失敗警告 - 分類程式發生不可重試的錯誤

  • SMTP 郵件失敗警告 - 分類程式可重試錯誤


SMTP 郵件失敗警告 - 分類程式可重試錯誤
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-03-20

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 CatCategorizationsfailedretryableerror 機碼值。此機碼的值代表因為發生可重試的錯誤而失敗的分類數目。Exchange Server Analyzer 也會查詢 Win32_PerfRawData_PerfOS_System WMI 機碼，以判定 SystemUpTime 的值。

如果 Exchange Server Analyzer 判定 SystemUpTime 機碼的值大於 0，且 CatCategorizationsfailedretryableerror 值除以 SystemUpTime 值的結果大於 500，便會顯示一則警告。

郵件分類程式會檢查進入 SMTP 伺服器的郵件，並且判定應如何處置郵件。郵件可能會被送到本機的資訊儲存庫、使用郵件傳輸代理程式 (MTA) 送到遠端主機，或使用 SMTP 將郵件送到遠端主機。分類程式也會控制通訊群組清單展開。分類程式是進階佇列引擎的外掛程式，該引擎會用 TCP 通訊埠 3268 針對通用類別目錄伺服器執行「輕量型目錄存取通訊協定 (LDAP)」查詢。分類程式基本上是一個事件接收器的集合，針對通過進階佇列引擎的每一封郵件，執行進階位址解析。它會執行位址解析、郵件轉寄、設定內容轉換旗標、展開通訊群組清單、實施通用設定、產生傳遞狀態通知，同時也會執行替代的收件者路徑偵測、分叉、記錄以及許多其他功能。

郵件一進入郵件分類程式時，分類程式就會在 Active Directory® 目錄服務中的 Proxy 位址屬性中搜尋該位址，來解析信封寄件者。分類程式也會在 Active Directory 中的 Proxy 位址屬性搜尋每一個位址，來解析信封收件者。例如，如果清單中包含一個通訊群組清單，並且如果該伺服器允許展開通訊群組清單，則分類程式會展開該清單，以便加入那些成員。

此警告表示因為發生可重試的錯誤，所以每天平均有 500 個或更多個分類失敗。這個問題有很多個原因，包括目錄服務存取 (DSAccess) 方面的問題、目錄複寫延遲或失敗、超載的通用類別目錄伺服器，以及 DNS 方面的問題。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此警告

  1. 請檢查 Exchange Server 電腦上的事件日誌所記載的錯誤。

  2. 若找不到任何事件能夠讓您解決問題，可以考慮將「MSExchangeTransport 分類程式」的診斷記錄調高為「最高」。在啟用診斷記錄之後，重新檢查事件日誌中的錯誤記錄。若將診斷記錄設為最高還是無法產生任何事件日誌項目，則請使用登錄，將診斷記錄設為等級 7。設為等級 7 時，就會記錄由郵件分類程式產生的事件識別碼 9000，這會詳細列出功能、失敗原因、失敗的收件者名稱，以及收件者類型。若要將診斷記錄設為等級 7：

    1. 開啟登錄編輯程式 (如 Regedit.exe 或 Regedt32.exe)

    2. 瀏覽至：

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. 在右窗格中，連按兩下 [2 分類程式]，將值資料設為 7，再按 [確定]。

    4. 關閉登錄編輯程式。

      附註：
      當您完成疑排解時，請將 [2 分類程式] 的值資料設回 0。

  3. 請確認 Exchange Server 可連至一或多個通用目錄伺服器。Windows 中的 [網路監視器] 工具對於這點相當有用。

  4. 請檢驗任何產生的傳遞狀態通知 (DSN) 郵件。DSN 可能包含未傳遞回報 (NDR)，可描述永久失敗的郵件，以及經常以永久傳遞之錯誤結束的暫時性失敗的郵件。

  5. 請使用 [郵件追蹤] 以疑難排解停駐在分類程式中的郵件。

  6. 請使用 Archive Sink 工具以封存和分析正在傳入和移出 Exchange Server 之郵件。

  7. 請使用 [系統監視器] 以監視分類程式的效能計數器。

若需有關 Exchange Server 及 Microsoft Windows Small Business Server 產生之 DSN 與 NDR 的詳細資訊，請參閱 Microsoft 知識庫文章 284204＜Exchange 2000 Server 及 Small Business Server 的傳遞狀態通知＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204)。

若需在 Exchange Server 使用「郵件追蹤中心」的相關資訊，請參閱下列 Microsoft 知識庫文章：

  • 262162＜XADM：使用「郵件追蹤中心」來追蹤訊息＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856＜XADM：如何在 Exchange 2000 Server 中啟用郵件追蹤＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905＜Exchange Server 2003 中的郵件追蹤事件識別碼＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864＜Exchange Server 2003 中改良的郵件追蹤功能＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

若需有關疑難排解郵件分類程式問題的詳細資訊，請參閱 Microsoft Support WebCast＜Exchange 2000 Server：郵件分類程式及 NDR 疑難排解＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)。

若需有關 Archive Sink 工具的詳細資訊，請參閱 Microsoft 知識庫文章 307798＜Service Pack 2 提供 Archive Sink 公用程式＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)。

若需疑難排解傳輸相關問題的一般資訊，請參閱下列 Microsoft 知識庫文章：

  • 821910＜如何疑難排解 Exchange Server 2003 傳輸問題＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265＜XCON：Exchange 2000 傳輸問題的一般疑難排解＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

郵件分類程式的效能計數器，會針對每一個 SMTP 虛擬伺服器執行個體分別公布。若需與郵件分類程式相關之可用效能計數器的清單，請參閱 Microsoft 知識庫文章 231734＜XCON：郵件分類程式的效能監視計數器＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)。

若需有關其他一些 Categorizer WMI 計數器的詳細資訊，請參閱下列 Exchange Server Analyzer 工具文章：

  • SMTP 郵件失敗警告 - 找不到分類程式位址查詢

  • SMTP 郵件失敗警告 - 分類程式目錄登入失敗

  • SMTP 郵件失敗警告 - 分類程式目錄服務失敗

  • SMTP 郵件失敗警告 - 分類程式發生不可重試的錯誤

  • SMTP 郵件失敗警告 - 分類程式記憶體不足失敗


將 SMTP 郵件佇列資料寫入壓縮的資料夾中
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 SMTP 郵件佇列資料夾的 Compressed 機碼值。如果 Exchange Server Analyzer 發現 Compressed 的值設定為 True，則會顯示警告訊息。

當郵件透過 SMTP 服務抵達 Exchange 電腦時，資料會以 .eml 檔格式寫入硬碟。在預設的情況下，這些檔案會儲存在 <drive>:\Program Files\Exchsrvr\Mailroot 資料夾中 (在安裝 Exchange 的相同磁碟分割區上)。如果儲存 SMTP 郵件佇列的資料夾已啟用檔案壓縮功能，可能會使 Exchange 的效能嚴重衰退。因此，不支援用來儲存 SMTP 郵件佇列之資料夾的壓縮功能。

Microsoft 不支援將 Exchange 資料檔案儲存在壓縮磁碟區上。當您將 Exchange 資料檔案儲存在壓縮的磁碟區上時，額外的處理將會顯著影響 Exchange 的效能。Exchange 資料檔案包括下列檔案：

  • .edb 檔案

  • .stm 檔案

  • .log 檔案

  • .dat 檔案

  • .eml 檔案

  • .chk 檔案

若要關閉某個給定資料夾的檔案壓縮功能

  1. 在要關閉檔案壓縮的資料夾上按一下滑鼠右鍵，然後按一下 [內容]。

  2. 在 [一般] 索引標籤中，按一下 [進階]。

  3. 在 [進階屬性] 對話方塊中，清除 [壓縮內容，節省磁碟空間] 核取方塊，然後按一下 [確定]。

移動 Exchange 2000 Server 或 Exchange Server 2003 上的 Mailroot 資料夾

  1. 開啟 [Exchange 系統管理員]。

  2. 按一下 [系統管理群組]，然後依序展開您的系統管理群組、[伺服器]、展開您的伺服器、[通訊協定]、[SMTP]。

  3. 以滑鼠右鍵按一下您的 SMTP 虛擬伺服器，再按一下 [停止]。

  4. 以滑鼠右鍵按一下您的 SMTP 虛擬伺服器，再按一下 [內容]。

  5. 在 [郵件] 索引標籤的 [佇列目錄] 方塊旁邊，按一下 [瀏覽]，然後輸入 Queue 資料夾的新位置路徑。

  6. 按一下 [確定]。

  7. 以滑鼠右鍵按一下您的 SMTP 虛擬伺服器，再按一下 [啟動]。

若需有關移動 Mailroot 資料夾的詳細資訊，請參閱微軟知識庫文件 - 822933＜How to change the Exchange 2003 SMTP Mailroot folder location＞ (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)。


SMTP 郵件佇列資料正在寫入加密資料夾
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 類別，以判定簡易郵件傳送通訊協定 (SMTP) 郵件佇列資料夾的 Encrypted 機碼值。如果 Exchange Server Analyzer 發現 Encrypted 的值設定為 True，就會顯示一則警告。

當郵件透過 SMTP 服務抵達 Exchange 電腦時，資料會以 .eml 檔格式寫入硬碟。在預設的情況下，這些檔案會儲存在 <drive>:\Program Files\Exchsrvr\Mailroot 資料夾中 (在安裝 Exchange 的相同磁碟分割區上)。如果儲存 SMTP 郵件佇列的資料夾已啟用檔案加密功能，可能會使 Exchange 的效能嚴重衰退。因此，不支援加密用來儲存 SMTP 郵件佇列的資料夾。

Microsoft 不支援將 Exchange 資料檔案儲存在「加密檔案系統 (EFS)」加密磁碟區上。當您將 Exchange 資料檔案儲存在加密磁碟區上時，額外的處理將會顯著影響 Exchange 的效能。Exchange 資料檔案包括下列檔案：

  • .edb 檔案

  • .stm 檔案

  • .log 檔案

  • .dat 檔案

  • .eml 檔案

  • .chk 檔案

為了協助保護您的 Exchange 資料檔案安全，建議您禁止未經授權者存取 Exchange 電腦，並且使用 S/MIME 郵件格式，將郵件資料加密。

若要解決這項錯誤，您必須關閉 SMTP 郵件佇列資料夾的檔案加密功能，或是將 SMTP 郵件佇列資料夾移到沒有啟用加密功能的位置。

若要關閉給定資料夾的檔案加密功能

  1. 以滑鼠右鍵按一下要關閉檔案加密功能的資料夾，再按一下 [內容]。

  2. 在 [一般] 索引標籤中，按一下 [進階]。

  3. 在 [進階屬性] 對話方塊中，清除 [加密內容，保護資料] 核取方塊，然後按一下 [確定]。

若要在 Exchange 2000 Server 或 Exchange Server 2003 上移動 SMTP 郵件佇列資料夾

  1. 開啟 [Exchange 系統管理員]。

  2. 按一下 [系統管理群組]，然後依序展開您的系統管理群組、[伺服器]、展開您的伺服器、[通訊協定]、[SMTP]。

  3. 以滑鼠右鍵按一下您的 SMTP 虛擬伺服器，再按一下 [停止]。

  4. 以滑鼠右鍵按一下您的 SMTP 虛擬伺服器，再按一下 [內容]。

  5. 在 [郵件] 標籤中，按一下 [錯誤郵件目錄] 方框旁的 [瀏覽]，然後鍵入 Queue 資料夾的新位置路徑。

  6. 按一下 [確定]。

  7. 以滑鼠右鍵按一下您的 SMTP 虛擬伺服器，再按一下 [啟動]。

若需有關移動 Mailroot 資料夾的詳細資訊，請參閱微軟知識庫文件 - 822933＜How to change the Exchange 2003 SMTP Mailroot folder location＞ (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)。

若需有關 Exchange Server 資料檔案及 EFS 的詳細資訊，請參閱微軟知識庫文件 - 834638＜Information about the storage of data files on an encrypted volume in Exchange Server＞ (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638)。

若需有關如何在 Microsoft Exchange Server 2003 中保護郵件安全的詳細資訊，請參閱《Exchange Server 2003 郵件安全性手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47574)。


SMTP 郵件佇列資料正在寫入非 NTFS 磁碟分割
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Exchange SMTP 佇列目錄的 FSName 機碼值。如果 Exchange Server Analyzer 判定 FSName 機碼的值不等於 NTFS File System，就會顯示一則錯誤。

Microsoft 不支援將 Exchange 資料檔案儲存在非 NTFS 磁碟區上。Exchange 資料檔案包括下列檔案：

  • .edb 檔案

  • .stm 檔案

  • .log 檔案

  • .dat 檔案

  • .eml 檔案

如果發生此錯誤，就必須將 SMTP 佇列目錄移至 NTFS 磁碟機上的資料夾。或者，如果用來儲存佇列目錄的磁碟機是格式化為 FAT 磁碟機，也可使用 convert.exe 命令列工具將磁碟機轉換為 NTFS。

若要將 SMTP 佇列移動至其他資料夾

  1. 開啟 [Exchange 系統管理員]。

  2. 按一下 [系統管理群組]，然後依序展開您的系統管理群組、[伺服器]、展開您的伺服器、[通訊協定]、[SMTP]。

  3. 以滑鼠右鍵按一下您的 SMTP 虛擬伺服器，再按一下 [停止]。

  4. 以滑鼠右鍵按一下您的 SMTP 虛擬伺服器，再按一下 [內容]。

  5. 在 [郵件] 標籤中，按一下 [錯誤郵件目錄] 方框旁的 [瀏覽]，然後鍵入 Queue 資料夾的新位置路徑。

  6. 按一下 [確定]。

  7. 以滑鼠右鍵按一下您的 SMTP 虛擬伺服器，再按一下 [啟動]。

若需有關移動 Mailroot 資料夾的詳細資訊，請參閱微軟知識庫文件 - 822933＜How to change the Exchange 2003 SMTP Mailroot folder location＞ (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)。

另一個取代本文件中所描述程序的方法是，如果用來儲存檔案的磁碟機已格式化為 FAT 磁碟機，也可使用 convert.exe 命令列工具將磁碟機轉換為 NTFS。若需有關使用 convert.exe 命令列工具將 FAT 磁碟分割轉換為 NTFS 磁碟分割的詳細資訊，請參閱微軟知識庫文件 - 214579＜如何使用 Convert.exe 將磁碟分割轉換為 NTFS 檔案系統＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=214579)。


SMTP MaxDSNSize 值已經被手動設定
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-01-17

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄子機碼，以判定是否已手動覆寫傳遞狀態通知 (DSN) 郵件大小的上限：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MaxDSNSize

如果 Exchange Server Analyzer 發現 MaxDSNSize 存在而且已設定，就會顯示一則非預設的組態訊息。

如果無法傳遞郵件，則 MaxDSNSize 登錄值可讓執行 Exchange 2000 Server Service Pack 2 (SP2) 或更新版本的電腦移除附件。如果您啟用這個選項，就可以儲存伺服器和網路資源。然而，這項移除 SMTP 附件的實作有一些缺點。

如果啟用此選項以從未傳遞回報 (NDR) 中移除附件，也會移除在預覽窗格中顯示通知所需要的詳細資料，而且郵件建立者會無法使用 [重傳] 選項。如果郵件的建立者嘗試要從 NDR 使用 [重傳] 選項，郵件建立者將會收到下列錯誤訊息：

「無法重新傳送這個郵件，無法傳送郵件報告不含足夠的原始郵件資訊，要重新傳送這個郵件，將它開啟在您的已傳送郵件資料夾中，按 [動作] 功能表，然後按 [重新傳送這個郵件]。」

不過，郵件的建立者即使使用錯誤訊息中的方法，也不能重寄郵件。因此，建議您小心使用此選項。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要修改 MaxDSNSize 登錄值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. 建立名為 MaxDSNSize 的 DWORD 登錄值，然後將其數值資料 (以位元組計算) 設定為想要的數量。

  4. 結束登錄編輯程式，然後重新啟動 SMTP 服務，使變更生效。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 MaxDSNSize 登錄值的詳細資訊，請參閱下列知識庫文件：

  • 308303＜XCON：將產生 NDR 之郵件中的附件移除的選項＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308303)

  • 323484＜XCON：Exchange 2000 中多重區段/報告網際網路郵件格式的說明＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=323484)


SMTP MaxPendingCat 登錄值並非預設值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更預設的 SMTP 佇列組態：

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

如果 Exchange Server Analyzer 發現已設定 MaxPendingCat 機碼，則會顯示非預設的訊息。

建議您在全面考量後，再進行預設佇列值的修改。這些預設值經過謹慎的選擇，可讓大部分環境獲得最佳效能。一般的最佳作法是解決問題的根本來源，而不是去修改 Exchange 上的佇列行為。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要採取任何動作。

若需有關 Exchange SMTP 佇列的詳細資訊，請參閱 Microsoft Exchange 團隊部落格中的＜解說神秘的 SMTP 進階佇列引擎＞項目 (英文) (http://go.microsoft.com/fwlink/?LinkId=48585)。


SMTP MaxMessageObjects 的設定太低
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定系統可以配置的最大電子郵件數：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\MailMsg\MaxMessageObjects

如果 Exchange Server Analyzer 發現 MaxMessageObjects 的值小於 30001，則會顯示一則警告。

當佇列包含最大郵件數目時，「簡易郵件傳送通訊協定 (SMTP)」就不會再接受其他輸入郵件。位在 SMTP 佇列中的每個郵件訊息至少會使用 4 KB 的記憶體；因此，大型佇列可能會導致記憶體過低的情況。

依預設，MaxMessageObjects 值不存在，且最大郵件數目設為 100,000。設定較低的 MaxMessageObjects 值會減少佇列中可放置的最大郵件數目，因此會降低 SMTP 的最大記憶體支配。達到此限制之後，對伺服器所建立的每一個 SMTP 連線都會傳回記憶體不足的錯誤。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要設定可以進入佇列的 SMTP 郵件數目限制

  1. 啟動登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\Software\Microsoft\Exchange

  3. 在 Exchange 機碼上按一下滑鼠右鍵，然後按一下 [新增機碼]。將新機碼命名為 MailMsg。

  4. 在 MailMsg 機碼上按一下滑鼠右鍵，然後按一下 [新增 DWORD 值]。

  5. 在新值上按一下滑鼠右鍵，按一下 [重新命名]，然後鍵入 MaxMessageObjects。

  6. 按兩下 MaxMessageObjects 值，然後將該值設定為無論何時，佇列中都不可超過的郵件數上限。除非您需要處理更多郵件，否則建議使用最大值 100,000。

  7. 結束登錄編輯程式，然後重新啟動 SMTP 服務，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關對佇列中郵件設定限制的詳細資訊，請參閱微軟知識庫文件 - 258748＜如何設定佇列中 SMTP 郵件的數目限制＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258748)。


已變更 SMTP MaxMessageObjects 登錄參數的預設值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定系統可以配置的最大電子郵件數：

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\MailMsg\MaxMessageObjects

如果 Exchange Server Analyzer 發現 MaxMessageObjects 的值大於 0，就會顯示非預設的組態訊息。

當佇列包含最大數目的郵件時，SMTP 不會再接受其他的輸入郵件。留在 SMTP 佇列中的每個郵件訊息會使用至少 4 KB 的記憶體；因此，您會碰到有大量佇列而使記憶體變低的情況。

根據預設值，MaxMessageObjects 值不存在，而且最大郵件數目設為 100,000。將 MaxMessageObjects 設為較低的值，可減少留在佇列中的最大郵件數目，而能減少 SMTP 的最大記憶體支配。達到此限制之後，對伺服器所建立的每一個 SMTP 連線都會傳回記憶體不足的錯誤。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要設定可以進入佇列的 SMTP 郵件數目限制

  1. 啟動登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\Software\Microsoft\Exchange

  3. 在 Exchange 機碼上按一下滑鼠右鍵，然後按一下 [新增機碼]。將新機碼命名為 MailMsg。

  4. 在 MailMsg 機碼上按一下滑鼠右鍵，然後按一下 [新增 DWORD 值]。

  5. 在新值上按一下滑鼠右鍵，按一下 [重新命名]，然後鍵入 MaxMessageObjects。

  6. 按兩下 MaxMessageObjects 值，然後將該值設定為無論何時，佇列中都不可超過的郵件數上限。除非您需處理更多的郵件，否則建議您使用最大值 100,000。

  7. 結束登錄編輯程式並且重新啟動「簡易郵件傳送通訊協定 (SMTP)」服務，讓變更生效。

在編輯登錄之前，若需有關如何編輯登錄的詳細資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)。

若需有關設定佇列郵件數目限制的詳細資訊，請參閱知識庫文件 - 258748＜如何設定佇列的 SMTP 郵件數目限制＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258748)。


已手動設定 SMTP MaxPercentPoolThreads 登錄值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-01-17

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否有手動設定其他集區執行緒：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\MaxPercentPoolThreads

如果 Exchange Server Analyzer 發現 MaxPercentPoolThreads 已存在且已設定，則會顯示非預設的組態訊息。

在 SMTP 中有五個工作佇列是使用稱為 ATQ 執行緒的執行緒集區。根據設計，其中兩個佇列預設可以使用最多 90% 的可用執行緒。此執行緒集區是由接受 POP 及 IMAP 要求的處理程序所共用。因此，在中度到高度負載狀況下會發生 SMTP 防止 POP 及 IMAP 服務使用資源的情況。

您可以限制 SMTP 可使用的執行緒百分比，來保留足夠的執行緒數目供 POP 及 IMAP 使用。若要執行此變更，您必須增加可供 IIS 使用的整體執行緒數目。其唯一代價就是增加其他執行緒的記憶體使用量。

有兩個登錄值可讓您控制每個處理器的執行緒與其他執行緒的 SMTP 百分比：

位置：HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

值：AdditionalPoolThreadsPerProc

類型：REG_DWORD

位置：HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

值：MaxPercentPoolThreads

類型：REG_DWORD

如果高度 SMTP 活動造成 POP3 或 IMAP4 失敗或這兩個資源都失敗，您應該在叢集 Exchange Server 電腦上調整這兩個登錄值。您可以使用下列公式來計算叢集的最佳值：

登錄值 | 公式
AdditionalPoolThreadsPerProc | ((9 / (MaxPercentPoolThreads/100)) - 4) / 2
MaxPercentPoolThreads | 90 / (2 * 通訊協定虛擬伺服器數目)

例如，在有兩個通訊協定虛擬伺服器的 Exchange Server 叢集中，MaxPercentPoolThreads 的公式如下：90 / (2*2) = 22。計算 MaxPercentPoolThreads 值時，如果計算結果為包含小數點的值，您應該將結果無條件捨去而成為整數。當計算 AdditionalPoolThreadsPerProc 值的時候， 如果計算結果會產生大於 200 的值，那麼您也需要將結果值指派給另一個登錄值：

位置：HKLM\System\CurrentControlSet\Services\InetInfo\Parameters\

值：PoolThreadLimit

類型：REG_DWORD

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要在 Exchange 叢集上設定最佳設定值

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. 建立名為 AdditionalPoolThreadsPerProc 的 DWORD 登錄值，然後根據上面的公式將其值資料設定成適當數字。

  4. 建立名為 MaxPercentPoolThreads 的 DWORD 登錄值，然後根據上面的公式將其值資料設定成適當數字。

  5. 結束登錄編輯程式並重新啟動 IIS Admin 服務，讓變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關此文件所描述之特定叢集資源問題的詳細資訊，請參閱知識庫文件 - 281868＜XADM：POP\IMAP4 虛擬伺服器在高負載下一再失敗＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=281868)。


已手動新增 SMTP MsgHandleAsyncThreshold 登錄值，但可能不再需要此值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-01-17

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已將最大非同步網際網路資訊服務 (IIS) 檔案控制代碼數目修改為預設值 1,000 以外的值：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MsgHandleAsyncThreshold

如果 Exchange Server Analyzer 發現 MsgHandleAsyncThreshold 存在且設為其他值，就會顯示一則警告。

MsgHandleAsyncThreshold 值指定 IIS 可使用的最大非同步檔案控制代碼數目。將檔案控制代碼快取以提高效能，因為快取的檔案控制代碼讓伺服器不必執行多餘的輸入/輸出 (I/O) 及 CPU 週期。每次 Exchange Server 電腦上的 SMTP 傳輸堆疊收到一封郵件時，該郵件會輸出到檔案系統等待傳送到它的目的地。為了寫入檔案系統，SMTP 傳輸堆疊會取得一個檔案控制代碼，然後將訊息傳遞到該檔案控制代碼。每一個檔案控制代碼消耗大約 2 KB 的分頁集區記憶體。IIS 快取檔案控制代碼的預設數目是每 32 MB 有 800 個。

在 Exchange 2000 Server Service Pack 2 (SP2) 之前，因為 SMTP 服務的最大檔案控制代碼數目的預設設定是 1,000，所以承受大量 SMTP 郵件佇列 (例如，平均 1,000 封或更多的郵件) 的 Exchange 伺服器會遇到效能限制。因為 Exchange 2000 Server 預設為最多 1000 個檔案控制代碼，所以 SMTP 服務只能將 1000 封同時傳入的郵件寫入檔案系統。

為了提高這些大型系統的效能，經常同時調整這三個登錄項目來增加可讓 SMTP 服務開啟的檔案控制代碼數目上限 (以便可以處理更多郵件)，以及減少可安裝的檔案系統 (另一個 Exchange 元件) 的開啟檔案控制代碼數目 (以避免佇列變大時記憶體不足)。下面列出這些登錄值 (預設是不存在，因此需要手動新增它們)：

位置：HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

值：MsgHandleThreshold

類型：REG_DWORD

位置：HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

值：MsgHandleAsyncThreshold

類型：REG_DWORD

位置：HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

值：FileCacheMaxHandles

類型：REG_DWORD

MsgHandleThreshold 及 MsgHandleAsyncThreshold 項目一般會調整為相同的值 (通常是大於 1000 的值)，而 FileCacheMaxHandles 值通常會從 800 減少為 600。

此登錄值預設不存在，因為 Exchange 2000 Server (含 SP2 及更新版本) 會動態判定要使用的最佳值。如果此 Exchange 伺服器執行的是 Exchange 2000 Server Service Pack 1 (SP1) 或更早版本，建議使用的最佳作法是升級成最新的 Service Pack 及彙總套件。升級到最新的程式碼之後，您可以刪除這些登錄項目。

由於 Exchange Server 2003 會動態計算 SMTP 檔控制代碼的適當設定，所以不再需要這些設定。因此，除非 Microsoft 產品支援服務另有指示，否則在將含有這些設定的 Exchange 2000 Server 電腦升級到 Exchange Server 2003 之前，您應該從登錄中刪除這些項目。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要還原為預設組態

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. 在右窗格中，刪除 MsgHandleAsyncThreshold 值。

  4. 關閉登錄編輯程式，然後重新啟動 IIS Admin Service，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


已手動新增 SMTP MsgHandleThreshold 登錄值，但可能不再需要此值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-09-06

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已修改最大網際網路資訊服務 (IIS) 檔案控制代碼數目的預設值 1,000：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MsgHandleThreshold

如果 Exchange Server Analyzer 發現 MsgHandleThreshold 已存在且已設為替代值，則會顯示非預設的組態訊息。

MsgHandleThreshold 值指定 IIS 可以使用的最大檔案控制代碼數。將檔案控制代碼快取以提高效能，因為快取的檔案控制代碼讓伺服器不必執行多餘的輸入/輸出 (I/O) 及 CPU 週期。每次 Exchange Server 電腦上的 SMTP 傳輸堆疊收到一封郵件時，該郵件會輸出到檔案系統等待傳送到它的目的地。為了寫入檔案系統，SMTP 傳輸堆疊會取得一個檔案控制代碼，然後將訊息傳遞到該檔案控制代碼。每一個檔案控制代碼消耗大約 2 KB 的分頁集區記憶體。IIS 快取檔案控制代碼的預設數目是每 32 MB 有 800 個。

在 Exchange 2000 Server Service Pack 2 (SP2) 之前，因為 SMTP 服務的最大檔案控制代碼數目的預設設定是 1,000，所以過去承受大量 SMTP 郵件佇列 (例如，平均 1,000 封或更多的郵件) 的 Exchange 伺服器會遇到效能限制。因為 Exchange 2000 Server 預設為最多 1000 個檔案控制代碼，所以 SMTP 服務只能將 1000 封同時傳入的郵件寫入檔案系統。

為了提高這些大型系統的效能，經常同時調整這三個登錄項目來增加可讓 SMTP 服務開啟的檔案控制代碼數目上限 (以便可以處理更多郵件)，以及減少可安裝的檔案系統 (另一個 Exchange 元件) 的開啟檔案控制代碼數目 (以避免佇列變大時記憶體不足)。下面列出這些登錄值 (預設是不存在，因此需要手動新增它們)：

位置：HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

值：MsgHandleThreshold

類型：REG_DWORD

位置：HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

值：MsgHandleAsyncThreshold

類型：REG_DWORD

位置：HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

值：FileCacheMaxHandles

類型：REG_DWORD

MsgHandleThreshold 和 MsgHandleAsyncThreshold 項目一般會調整為相同的值 (通常是大於 1000 的值)，而 FileCacheMaxHandles 值通常會從 800 減少為 600。

若此 Exchange 伺服器正在執行 Exchange 2000 Server，則建議的最佳作法是升級為最新等級的 Service Pack 與彙總套件。升級為最新的代碼後，建議您將 MsgHandleThreshold 值預設為 1000。

Exchange Server 2003 預設的 MsgHandleThreshold 值為 1000，所以不再需要這些登錄覆寫設定。因此，除非 Microsoft 產品支援服務另有指示，否則在將含有這些設定的 Exchange 2000 Server 電腦升級到 Exchange Server 2003 之前，您應該從登錄中刪除這些項目。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。

若要更正此錯誤

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至：HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. 刪除 MsgHandleThreshold 值。

  4. 關閉登錄編輯程式，然後重新啟動 IIS Admin Service，使變更生效。

編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。


將 SMTP 收取檔案寫入壓縮的資料夾中
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 類別，以判定簡易郵件傳送通訊協定 (SMTP) PickUp 資料夾的 Compressed 機碼值。如果 Exchange Server Analyzer 發現 Compressed 的值設定為 True，則會顯示警告訊息。

當郵件透過 SMTP 服務抵達 Exchange 電腦時，資料會以 .eml 檔格式寫入硬碟。在預設的情況下，這些檔案會儲存在 <drive>:\Program Files\Exchsrvr\Mailroot 資料夾中 (在安裝 Exchange 的相同磁碟分割區上)。如果儲存 SMTP PickUp 資料的資料夾已啟用檔案壓縮功能，則 Exchange 效能可能會嚴重衰退。因此，不支援儲存 SMTP PickUp 資料之資料夾的壓縮功能。

如果收到此警告，您必須關閉用來存放 SMTP 收取資料的資料夾之壓縮功能，或必須將 SMTP 收取資料移動到未壓縮的資料夾中。

Microsoft 不支援將 Exchange 資料檔案儲存在壓縮磁碟區上。當您將 Exchange 資料檔案儲存在壓縮磁碟區時，額外的處理會顯著影響 Exchange 的效能。Exchange 資料檔案包括下列檔案：

  • .edb 檔案

  • .stm 檔案

  • .log 檔案

  • .dat 檔案

  • .eml 檔案

  • .chk 檔案

若要關閉某個給定資料夾的檔案壓縮功能

  1. 在要關閉檔案壓縮的資料夾上按一下滑鼠右鍵，然後按一下 [內容]。

  2. 在 [一般] 索引標籤中，按一下 [進階]。

  3. 在 [進階屬性] 對話方塊中，清除 [壓縮內容，節省磁碟空間] 核取方塊，然後按一下 [確定]。

若需有關移動 PickUp 資料夾的詳細資訊，請參閱微軟知識庫文件＜如何變更 Exchange 2003 SMTP Mailroot 資料夾位置＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)。


SMTP PickUp 檔案正在寫入加密的資料夾
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 類別，以判定簡易郵件傳送通訊協定 (SMTP) PickUp 資料夾的 Encrypted 機碼值。如果 Exchange Server Analyzer 發現 Encrypted 的值設定為 True，就會顯示一則警告。

當郵件透過 SMTP 服務抵達 Exchange 電腦時，資料會以 .eml 檔格式寫入硬碟。在預設的情況下，這些檔案會儲存在 <drive>:\Program Files\Exchsrvr\Mailroot 資料夾中 (在安裝 Exchange 的相同磁碟分割區上)。如果儲存 SMTP PickUp 資料的資料夾已啟用檔案加密，則 Exchange 效能可能會嚴重衰退。因此，不支援對儲存 SMTP PickUp 資料的資料夾啟用加密功能。

如果您收到這則警告，則必須在儲存 SMTP PickUp 資料的資料夾上關閉加密功能，或必須將 SMTP PickUp 資料移到未加密的資料夾。

Microsoft 不支援將 Exchange 資料檔案儲存在「加密檔案系統 (EFS)」加密磁碟區上。當您將 Exchange 資料檔案儲存在加密磁碟區上時，額外的處理會顯著影響 Exchange 的效能。Exchange 資料檔案包括下列檔案：

  • .edb 檔案

  • .stm 檔案

  • .log 檔案

  • .dat 檔案

  • .eml 檔案

  • .chk 檔案

為了協助保護您的 Exchange 資料檔案安全，建議您禁止未經授權者存取 Exchange 電腦，並且使用 S/MIME 郵件格式，將郵件資料加密。

若要解決這項錯誤，您必須關閉 PickUp 資料夾的檔案加密功能，或將 PickUp 資料夾移到未啟用加密的位置。

若要關閉給定資料夾的檔案加密功能

  1. 在要關閉檔案加密的資料夾上按一下滑鼠右鍵，然後按一下 [內容]。

  2. 在 [一般] 索引標籤中，按一下 [進階]。

  3. 在 [進階屬性] 對話方塊中，清除 [加密內容，保護資料] 核取方塊，然後按一下 [確定]。

若需有關移動 PickUp 資料夾的詳細資訊，請參閱微軟知識庫文件 - 822933＜如何變更 Exchange 2003 SMTP 郵件根目錄資料夾位置＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)。

若需有關 Exchange Server 資料檔及 EFS 的詳細資訊，請參閱知識庫文件 - 834638＜在 Exchange Server 中的加密磁碟區上儲存資料檔的詳細資訊＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638)。

若需有關如何在 Exchange Server 2003 保護郵件安全的詳細資訊，請參閱《Exchange Server 2003 郵件安全性手冊》(英文) (http://go.microsoft.com/fwlink/?linkid=47574)。


SMTP Pickup 檔正在寫入非 NTFS 磁碟分割
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Directory Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Exchange SMTP PickUp 目錄的 FSName 機碼值。如果 Exchange Server Analyzer 判定 FSName 機碼值不等於 NTFS，就會顯示警告。

Microsoft 不支援將 Exchange 資料檔案儲存在非 NTFS 磁碟區上。Exchange 資料檔案包括下列檔案：

  • .edb 檔案

  • .stm 檔案

  • .log 檔案

  • .dat 檔案

  • .eml 檔案

如果您看到這則警告，就必須將 SMTP PickUp 目錄移到 NTFS 檔案系統磁碟機上的資料夾。或者，如果儲存 PickUp 目錄的磁碟機已格式化為 FAT 磁碟機，也可以使用 convert.exe 命令列工具將磁碟機轉換為 NTFS。

若需有關移動 PickUp 資料夾的詳細資訊，請參閱微軟知識庫文件 - 822933＜如何變更 Exchange 2003 SMTP 郵件根目錄資料夾位置＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)。

或者，如果儲存檔案的磁碟機已格式化為 FAT 磁碟機，也可以使用 convert.exe 命令列工具將磁碟機轉換為 NTFS。若需有關使用 convert.exe 命令列工具將 FAT 磁碟分割轉換為 NTFS 磁碟分割的詳細資訊，請參閱知識庫文件 - 214579＜如何使用 Convert.exe 將磁碟分割轉換為 NTFS 檔案系統＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579)。


SMTP 通訊埠變更
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-11

Microsoft® Exchange Server Analyzer 工具會讀取網際網路資訊服務 (IIS) Metabase 中的下列內容，以判定其值是否符合預設值 25：

LM/SmtpSvc/<SMTP 虛擬伺服器執行個體>/SMTPPORT

如果 Exchange Server Analyzer 發現 SMTPPORT 內容的值不是 25，就會顯示警告。

SMTPPORT 內容代表此簡易郵件傳送通訊協定 (SMTP) 伺服器接聽連入連線時所使用的 TCP 通訊埠。SMTP 虛擬伺服器可以設定為接聽一或多個 TCP 通訊埠。依預設，所有 SMTP 虛擬伺服器皆會設定為接聽 TCP 通訊埠 25 (預設 SMTP 通訊埠)。如果已修改 SMTP 接聽通訊埠的預設值，且其接聽通訊埠清單中不再包含 TCP 通訊埠 25，則此修改會中斷郵件流程。

變更 SMTP 接聽通訊埠是可以接受的，前提是您內部其餘的郵件基礎結構也進行相應修改。不過，因為網際網路上的 SMTP 伺服器會透過通訊埠 25 來傳送郵件，所以替代通訊埠通常不適合用於直接從網際網路接受郵件的 SMTP 虛擬伺服器。

附註：
Exchange Server Analyzer 會檢查 Exchange SMTP 通訊協定虛擬伺服器的值。此 SMTP 通訊協定虛擬伺服器不一定是直接從網際網路接收郵件的 SMTP 伺服器。有一些防毒及防垃圾郵件的產品是設計來在通訊埠 25 上接收來自網際網路的 SMTP 郵件，然後重新導向至另一個通訊埠上的 ExchangeSMTP 虛擬伺服器。在此情況下，接聽埠號 25 以外的通訊埠的 Exchange SMTP 虛擬伺服器便是可接受的組態。
檢視或修改 SMTP 虛擬伺服器接聽通訊埠

  1. 在 [Exchange 系統管理員] 中，展開 [伺服器]，接著展開一部 Exchange 伺服器，再依序展開 [通訊協定]、[SMTP]。

  2. 在 SMTP 虛擬伺服器 (例如預設 SMTP 虛擬伺服器) 上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 選取 [一般] 索引標籤，然後按一下 [進階]。

  4. 會顯示 IP 位址及通訊埠的清單。

    • 若要變更現有的通訊埠，請選取 IP 位址，然後按一下 [編輯]。將 TCP 通訊埠欄位變更為 25。

    • 若要新增通訊埠 25 作為額外的接聽通訊埠，請按一下 [新增]，然後新增 IP 位址/通訊埠組合。如果您正在使用連線、寄件者或收件者篩選，請確定選取適當的核取方塊。

  5. 按一下 [確定] 以儲存變更，再按 [確定] 以結束 [進階] 對話方塊。按一下 [確定] 以關閉 SMTP 虛擬伺服器的 [內容] 對話方塊。

如需 SMTP 虛擬伺服器設定的相關資訊，請參閱下列 Microsoft 知識庫文章：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=266686)。

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)。


SMTP 佇列資料夾包含大量檔案
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-10-06

Microsoft® Exchange Server Analyzer 工具會查詢網際網路資訊服務 (IIS) Metabase，以判定每個簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器執行個體的 QueueDirectory 屬性值。

Exchange Server Analyzer 會接著計算每個 SMTP 虛擬伺服器所指定之佇列資料夾中的檔案數目。

如果 Exchange Server Analyzer 在 SMTP 虛擬伺服器的佇列資料夾中找到 50,000 個以上的檔案，Exchange Server Analyzer 就會顯示警告。

如果 Exchange Server Analyzer 在 SMTP 虛擬伺服器的佇列資料夾中找到 90,000 個以上的檔案，Exchange Server Analyzer 就會顯示錯誤。

此警告或錯誤表示有大量郵件需要 SMTP 虛擬伺服器執行個體進行處理。這個警告或錯誤指出伺服器發生嚴重效能問題或中斷，因為伺服器不再能夠及時傳遞內送郵件。下列情況都會造成此延遲：

  • 未立即參考 Active Directory® 目錄服務。

  • 未迅速處理本機傳遞或 SMTP 的郵件。

若要更正此問題：

  • 檢閱佇列資料夾中的郵件是否正當，以確認該服務並非因未經同意的廣告郵件 (UCE)、垃圾郵件或病毒攻擊而發生異常負載的情況。

  • 確認已啟用 SMTP 服務且正在執行。

確認已啟動 SMTP 服務

  1. 開啟 [服務] Microsoft Management Console (MMC) 嵌入式管理單元。

  2. 在右窗格中，向下捲動到 [簡易郵件傳送通訊協定 (SMTP)] 服務，並連按兩下該服務。隨即顯示[簡易郵件傳送通訊協定 (SMTP) 內容] 對話方塊。

  3. 確認 [啟動類型] 下拉功能表中的值已設定為 [自動]。

  4. 按一下 [啟動] 以啟動 System Attendant 服務。

  5. 按一下 [確定] 以儲存變更，並關閉 [簡易郵件傳送通訊協定 (SMTP) 內容] 對話方塊。

  6. 關閉 [服務] 嵌入式管理單元。

若需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  • Microsoft 知識庫文章 821877＜SMTP 及 X400 佇列內容索引標籤上的欄位說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821877)。

  • Microsoft 知識庫文章 264054＜XCON：瞭解 Exchange 2000 Server 中的佇列狀態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


SMTP 佇列資料夾與 pickup 資料夾相同
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以驗證收取郵件的來源目錄，不同於存放特定 SMTP 虛擬伺服器之佇列郵件的目錄。如果 Exchange Server Analyzer 發現 Queue 目錄的屬性 (msExchSmtpQueueDirectory) 與 Pickup 目錄的屬性 (msExchSmtpPickupDirectory) 相同，就會顯示一則錯誤。

此錯誤為嚴重錯誤。如果 msExchSmtpQueueDirectory 屬性與 msExchSmtpPickupDirectory 屬性設為相同的目錄，則會傳遞重複的郵件。您可以使用 Active Directory Service Interfaces (ADSI) 編輯器來更新這屬性。

注意：
使用 ADSI 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。
使用 ADSI 編輯器來更新 msExchSmtpPickupDirectory 或 msExchSmtpQueueDirectory 的屬性

  1. 從 Windows® 2000 支援工具或 Windows Server 2003 支援工具啟動 ADSI 編輯器工具。

  2. 展開下列節點：

    • 組態容器

    • 組態

    • 服務

    • Microsoft Exchange

    • Organization_Name

    • 收件者原則

    • Administrative_Group_Name

    • 伺服器

    • Server_Name

    • 通訊協定

    • SMTP

  3. 在詳細資料窗格中，以滑鼠右鍵按一下 CN=1 (其中 1 是預設的 SMTP 虛擬伺服器)，然後按一下 [內容]。

  4. 在 [選取要檢視的內容] 清單中，按一下 [兩者]。

  5. 更新 msExchSmtpPickupDirectory 的屬性，使其不再與 msExchSmtpQueueDirectory 衝突，完成後按一下 [設定]。

  6. 依序按一下 [確定]、[套用]，然後關閉 ADSI 編輯器。

  7. 至少等待 15 分鐘讓複寫完成。


SMTP 佇列和系統磁碟分割位在相同的磁碟機上
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 msExchSmtpQueueDirectory 屬性的設定值。

Exchange Server Analyzer 也會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定簡易郵件傳送通訊協定 (SMTP) 服務的 Started 機碼值。值 False 表示服務不在執行中。值 True 表示服務在執行中。此外，Exchange Server Analyzer 也會查詢 Win32_OperatingSystem WMI 類別，來判定 WindowsDirectory 機碼的值。這個機碼值表示 Windows 系統磁碟機的位置。

如果 Exchange Server Analyzer 發現 msExchSmtpQueueDirectory 屬性設定的路徑包含與系統磁碟機相同的磁碟機，且 SMTP 服務正在執行，而 Exchange 並未在 Microsoft Windows Small Business Server 上執行，便會顯示一則警告。

msExchSmtpQueueDirectory 屬性代表 SMTP 佇列資料夾的路徑，也稱為 Mailroot 資料夾。當郵件經由 SMTP 服務到達 Exchange 伺服器時，資料會寫入硬碟中成為 .eml 檔案。這些檔案預設會儲存在 Exchange 安裝磁碟分割的 <drive>:\Program Files\Exchsrvr\Mailroot 資料夾。

在某些情況下，例如當您設定 Bridgehead 伺服器時，如果將 SMTP Mailroot 目錄移動至不同的硬碟或磁碟分割，將可以提高 Exchange 伺服器的效能。最佳作法是 SMTP Mailroot 資料夾不要與 Windows 系統磁碟機放在同一個磁碟機上。相反地，應該放在快速磁碟或快速磁碟子系統上來發揮最佳效能。

雖然在 Exchange Server 2003 SMTP 虛擬伺服器上可以在 Exchange 系統管理員中移動 Mailroot 資料夾，但如果在 Exchange 2000 Server SMTP 虛擬伺服器中移動，則需要使用低階 Active Directory 編輯程式 (例如 Active Directory Service Interfaces (ADSI) 編輯器)。

注意：
使用 ADSI 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若要在 Exchange Server 2003 上更正此錯誤

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [伺服器]，接著展開一部 Exchange 伺服器，再依序展開 [通訊協定]、[SMTP]。

  3. 在 SMTP 虛擬伺服器上按一下滑鼠右鍵 (例如，預設 SMTP 虛擬伺服器)，然後按一下 [停止]。

  4. 再次在 SMTP 虛擬伺服器上按一下滑鼠右鍵，然後按一下 [內容]。

  5. 按一下 [郵件] 標籤。

  6. 在 [佇列目錄] 欄位中，指定適當 Mailroot 資料夾的完整路徑。您可以按一下 [瀏覽] 來瀏覽本機電腦的路徑。

  7. 按一下 [確定]，儲存變更。

  8. 在 SMTP 虛擬伺服器上按一下滑鼠右鍵，然後按一下 [啟動]。新的位置將立即生效。

若要在 Exchange 2000 Server 上更正此錯誤

  1. 在您要修改 SMTP 虛擬伺服器 Mailroot 資料夾的 Exchange 2000 Server 電腦上，停止所有 Exchange Server 和 IIS 服務。

  2. 修改受影響之 SMTP 虛擬伺服器的 msExchSmtpQueueDirectory 值，使其設定為適當的路徑。

  3. 等待 Active Directory 將這項變更複寫到這個 Exchange 伺服器使用的通用類別目錄伺服器。

  4. 啟動 Microsoft Exchange System Attendant 服務。

  5. 在 Exchange Server 電腦上，檢查應用程式事件日誌中是否存在三個事件識別碼 1005，事件來源為 MSExchangeMU，類別為 [一般]。

  6. 重新啟動 Exchange Server 電腦，以使變更生效。

若需這兩個提及的程序的相關資訊，請參閱下列微軟知識庫文件：

  • 822933＜如何變更 Exchange 2003 SMTP Mailroot 資料夾位置＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822933)

  • 318230＜XCON：如何變更 Exchange 2000 SMTP Mailroot 目錄位置＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=318230)

若需有關 SMTP 虛擬伺服器設定的詳細資訊，請參閱知識庫文件：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


SMTP ResetMessageStatus 登錄值並非預設值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更預設的 SMTP 佇列組態：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing

若下列條件存在，Exchange Server Analyzer 便會顯示錯誤：

  • ResetMessageStatus 機碼未設為 0 (零)。

  • 未在 Exchange Server 上執行叢集服務。

將 ResetMessageStatus 登錄機碼設為 1 後，當重新啟動 Exchange Server 時，目前在佇列中的所有郵件都會重新經過所有內部處理佇列。例如，當重新啟動 Exchange Server 時，目前在佇列中的所有郵件都會重新經過分類程式處理。因此，應該只為疑難排解 SMTP 安裝問題將 ResetMessageStatus 機碼設為 1，如微軟知識庫文件 - 279616＜XCON：新增登錄機碼以重新分類郵件＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=279616) 中所述。如果您不是在疑難排解 SMTP 安裝問題，則應刪除此登錄機碼。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要刪除 ResetMessageStatus 登錄機碼

  1. 開啟登錄編輯程式，例如 Regedit.exe 或 Regedt32.exe。

  2. 瀏覽至： HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. 在右窗格中，尋找並刪除 ResetMessageStatus 值。

  4. 關閉登錄編輯程式。

在編輯登錄之前，若需如何編輯登錄的相關資訊，請參閱微軟知識庫文件 - 256986＜Microsoft Windows 登錄說明＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)。

若需有關 Exchange SMTP 佇列的詳細資訊，請參閱 Microsoft Exchange 團隊部落格中的＜解說神秘的 SMTP 進階佇列引擎＞項目 (英文) (http://go.microsoft.com/fwlink/?LinkId=48585)。


The SMTP ResetRoutesRetryMinutes registry value is non-default
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更預設的 SMTP 佇列組態：

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

如果 Exchange Server Analyzer 發現已設定 ResetRoutesRetryMinutes 機碼，則會顯示非預設的訊息。

建議您在全面考量後，再進行預設佇列值的修改。這些預設值經過謹慎的選擇，可讓大部分環境獲得最佳效能。一般的最佳作法是解決問題的根本來源，而不是去修改 Exchange Server 上的佇列行為。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要採取任何動作。

若需有關 Exchange SMTP 佇列的詳細資訊，請參閱 Microsoft Exchange 團隊部落格中的＜解說神秘的 SMTP 進階佇列引擎＞項目 (英文) (http://go.microsoft.com/fwlink/?LinkId=48585)。


SMTP RoutingRetryMinutes 登錄值並非預設值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更預設的 SMTP 佇列組態：

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

如果 Exchange Server Analyzer 發現已設定 RoutingRetryMinutes 機碼，則會顯示非預設的訊息。

建議您在全面考量後，再進行預設佇列值的修改。這些預設值經過謹慎的選擇，可讓大部分環境獲得最佳效能。一般的最佳作法是解決問題的根本來源，而不是去修改 Exchange Server 上的佇列行為。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要採取任何動作。

若需有關 Exchange SMTP 佇列的詳細資訊，請參閱 Microsoft Exchange 團隊部落格中的＜解說神秘的 SMTP 進階佇列引擎＞項目 (英文) (http://go.microsoft.com/fwlink/?LinkId=48585)。


SMTP SecondsPerDSNPass 登錄值並非預設值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定 SecondsPerDSNPass 登錄值的設定：

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

如果 Exchange Server Analyzer 發現 SecondsPerDSNPass 機碼存在且未設為 10，就會顯示非預設的組態訊息。

此設定可用於最佳化傳遞狀態通知 (DSN)，並指定每個 DSN 處理經過的秒數。一旦超出此閾值，DSN 產生就會停止，稍後再重新啟動。建議您在慎重考慮後，才修改預設值。您應在洽詢 Microsoft 支援服務後，才修改此特定設定。這些預設值經過謹慎的選擇，可讓大部分環境獲得最佳效能。一般的最佳作法是解決問題的根本原因，而不是去修改 Exchange 伺服器上的佇列行為。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要採取任何動作。


SMTP 伺服器已停用 NTLM 驗證
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-11-10

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已設定 msExchAuthenticationFlags 屬性中的 NTLM 驗證通訊協定 (也稱為整合式 Windows 驗證) 位元。如果 Exchange Server Analyzer 判定未設定此位元，且未在 Microsoft Windows® Small Business Server 上執行 Exchange，就會顯示一則警告。

msExchAuthenticationFlags 屬性指出通訊協定虛擬伺服器接受的驗證類型。此屬性使用三位元的遮罩。

位元 | 驗證方法
0 | 匿名
1 | 基本
2 | NTLM (整合式 Windows 驗證)

如果未設定控制 NTLM 驗證的位元，SMTP 虛擬伺服器將不允許 NTLM 驗證。這可能導致 Exchange Server 電腦之間發生驗證問題。

若要更正此警告

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [伺服器]、伺服器名稱、[通訊協定]，然後展開 [SMTP]。

  3. 以滑鼠右鍵按一下 Exchange SMTP 虛擬伺服器，再按 [內容]。

  4. 按一下 [存取] 索引標籤，按一下 [驗證]，再按一下以選取 [整合式 Windows 驗證] 核取方塊。

  5. 按 [確定] 兩次。

  6. 關閉 [Exchange 系統管理員]。

若需有關 SMTP 驗證方法的詳細資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47579) 及微軟知識庫文件 - 319267＜HOW TO：保護 Exchange 2000 中的簡易郵件傳送通訊協定用戶端郵件傳遞安全＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319267)。


SMTP SubmissionRetryMinutes 登錄值並非預設值
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已變更預設的 SMTP 佇列組態：

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

如果 Exchange Server Analyzer 發現已設定 SubmissionRetryMinutes 機碼，則會顯示非預設的訊息。

建議您在全面考量後，再進行預設佇列值的修改。這些預設值經過謹慎的選擇，可讓大部分環境獲得最佳效能。一般的最佳作法是解決問題的根本來源，而不是去修改 Exchange 上的佇列行為。

Exchange Server Analyzer 報告此組態的目的只是要提供參考資訊。不需要採取任何動作。

若需有關 Exchange SMTP 佇列的詳細資訊，請參閱 Microsoft Exchange 團隊部落格中的＜解說神秘的 SMTP 進階佇列引擎＞項目 (英文) (http://go.microsoft.com/fwlink/?LinkId=48585)。


SMTP 虛擬伺服器的郵件大小限制高於通用郵件大小限制
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，將 SMTP 虛擬伺服器內送郵件大小限制與內送通用郵件大小限制互相比較。

代表內送與外寄郵件之 SMTP 虛擬伺服器郵件大小限制的 Active Directory 屬性是 msExchSmtpMaxMessageSize。這個值是 Active Directory 中的 SMTP 虛擬伺服器物件的屬性，它位於下列位置：

CN=<Virtual Server Number>, CN=SMTP, CN=Protocols, CN=<ServerName>, CN=Servers, CN=<AdministrativeGroupName>, CN=Administrative Groups, CN=<OrganizationName>, CN=Microsoft Exchange, CN=Services, CN=Configuration, DC=<DomainName>, DC=com

代表通用內送郵件大小限制的 Active Directory 屬性是 delivContLength。這個值是組織在 Active Directory 中的通用設定郵件傳遞物件屬性，它位於下列位置：

CN=Message Delivery, CN=Global Settings, CN=<OrganizationName>, CN=Microsoft Exchange, CN=Services, CN=Configuration, DC=<DomainName>, DC=com

如果 Exchange Server Analyzer 發現 msExchSmtpMaxMessageSize 的值大於 delivContLength 的值，就會顯示一則警告。

如果有 SMTP 虛擬伺服器的郵件大小限制高於通用郵件大小限制，會使超過大小的郵件被接受成為輸入郵件，隨後成為未傳遞的郵件。若要解決此問題，請使用等於或小於通用內送郵件大小限制的郵件大小限制來設定 SMTP 虛擬伺服器。

附註：
如果您將郵件大小限制設得太低，則會無法在 Exchange Server 電腦間進行離線通訊錄複寫。若需有關這個問題的詳細資訊，請參閱微軟知識庫文件 - 326154＜XADM：在傳輸層級設定郵件大小限制不會複寫 OAB＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326154)。

若要更正此警告

  1. 在 [Exchange 系統管理員] 中，展開 [伺服器]，接著展開一部 Exchange 伺服器，再依序展開 [通訊協定]、[SMTP]。

  2. 在 SMTP 虛擬伺服器上按一下滑鼠右鍵 (例如，預設的 SMTP 虛擬伺服器)，並選取 [內容]。

  3. 選取 [郵件] 索引標籤。

  4. 編輯 [將郵件大小限制為 (KB)] 欄位的值，使該值等於或小於通用郵件大小限制。

  5. 按一下 [確定]，儲存變更並關閉 SMTP 虛擬伺服器的 [內容] 對話方塊。

若需有關 SMTP 虛擬伺服器設定的詳細資訊，請參閱下列知識庫文件：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

若需有關檢視及編輯全組織設定的詳細資訊，請參閱知識庫文件 - 821881＜如何在 Exchange 系統管理員中修改通用設定＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821881)。

若需有關通用郵件大小限制的詳細資訊，請參閱下列知識庫文件：

  • 298572＜超過傳送郵件大小限制或接收郵件大小限制的電子郵件不會傳遞＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298572)

  • 322679＜設定郵件的大小限制＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679)

  • 824111＜Exchange Server 2003 中引入的安全性設定變更及更新＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=824111)


此 SMTP 虛擬伺服器是設定成執行內送郵件的反向 DNS 查閱
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-08-24

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已變更針對 msExchSmtpPerformReverseDnsLookup 屬性所設定的預設值 False。在預設的情況下，msExchSmtpPerformReverseDnsLookup 屬性會設定成不執行內送郵件的反向 DNS 查閱。如果 Exchange Server Analyzer 發現此屬性是設定成 True，則會顯示一則警告。

[對傳入的郵件執行反向 DNS 查閱] 選項沒有防止接收垃圾電子郵件的功能。使用此選項時，Exchange Server 會執行 DNS 查詢，將內送郵件的原始網際網路通訊協定 (IP) 位址解析為主機名稱。然後，會將主機名稱附加到電子郵件訊息的標題。

啟動此功能，可能會因為錯誤設定的 DNS 記錄或間接性網際網路連線，而發生效能衰退。因此，網際網路郵件傳遞比預期的還慢時，您可能會想要停用此選項。

若要啟用或停用傳入 SMTP 郵件的反向 DNS 查閱

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [伺服器]，接著展開一部 Exchange 伺服器，再依序展開 [通訊協定]、[SMTP]。

  3. 以滑鼠右鍵按一下 SMTP 虛擬伺服器 (例如，預設 SMTP 虛擬伺服器)，然後按一下 [內容]。

  4. 按一下 [傳遞] 標籤，然後再按 [進階]。

    • 若要啟用反向 DNS 查閱，請選取 [對傳入的郵件執行反向 DNS 查閱] 核取方塊。

    • 若要停用反向 DNS 查閱，請清除 [對傳入的郵件執行反向 DNS 查閱] 核取方塊。

  5. 按一下 [確定] 以儲存變更，再按一下 [確定] 以結束 [SMTP 虛擬伺服器內容] 對話方塊。

若需有關 Exchange 中反向 DNS 查閱功能的詳細資訊，請參閱微軟知識庫文件 - 297412＜[對傳入的郵件執行反向 DNS 查閱] 選項是供主機名稱解析之用＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412)。

若需有關 SMTP 虛擬伺服器設定的詳細資訊，請參閱下列知識庫文件：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


已啟用智慧型郵件篩選器的 SP1 版本
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定伺服器上是否已安裝並啟用 Microsoft Exchange 智慧型郵件篩選器：

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

Exchange Server Analyzer 會讀取 ContentFilter 登錄機碼中的 ContentFilterBindings 值，以判定伺服器上是否已安裝並啟用智慧型郵件篩選器。

然後 Exchange Server Analyzer 會查詢 CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) 類別，以判定 Exchange Server 2003 Service Pack 1 (SP1) 版本的智慧型郵件篩選器 MSExchange.UceContentFilter.dll 是否位於 Exchange Server 的下列路徑中：

<Exchange 伺服器二進位檔案的路徑>\MSCFv2\MSExchange.UceContentFilter.dll

附註：
在此路徑中，<Exchange 伺服器二進位檔案的路徑> 是指 bin 資料夾的位置。

如果伺服器上已安裝並啟用 Exchange Server 2003 SP1 版本的智慧型郵件篩選器，Exchange Server Analyzer 就會顯示警告。

此警告表示有更新版本的智慧型郵件篩選器。建議您安裝最新版本的智慧型郵件篩選器。若要疑難排解有關此特定伺服器的郵件流程問題，您可能要暫時停用智慧型郵件篩選器，以判定伺服器是否錯誤封鎖合法郵件。

停用智慧型郵件篩選器

  1. 按一下 [開始]，並依序指向 [所有程式] 及 [Microsoft Exchange] 後，再按一下 [系統管理員]。

  2. 在 [Exchange 系統管理員] 中，依序展開 [伺服器]、伺服器名稱、[通訊協定] 及 [SMTP] ，並在 [智慧型郵件篩選器] 上按一下滑鼠右鍵，再按一下 [內容]。

  3. 在 [一般] 索引標籤的 [將智慧型郵件篩選套用至下列虛擬伺服器的 IP 位址] 下，清除要停用智慧型郵件篩選器之 SMTP 虛擬伺服器旁邊的核取方塊。

    [智慧型郵件篩選內容] 對話方塊

如需詳細資訊，請參閱「Exchange 智慧型郵件篩選器」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=21607)。


已啟用智慧型郵件篩選器的 SP2 版本
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-04

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器物件的 msExchServerBindingsFiltering 內容是否表示已針對 SMTP 虛擬伺服器執行個體啟用智慧型郵件篩選器。

Exchange Server Analyzer 也會查詢 Active Directory，以判定是否已在通用設定層級中啟用 msExchUceEnabled。

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • 已對 SMTP 虛擬伺服器執行個體啟用智慧型郵件篩選器。

  • 已在通用設定層級啟用智慧型郵件篩選器。

此警告表示已有效啟用 Exchange Server 2003 Service Pack 2 (SP2) 版的智慧型郵件篩選器。除非您正在進行此特定伺服器的郵件流程問題疑難排解，否則寄件者篩選通常不是問題。如果您正在進行疑難排解，則可能需要驗證篩選組態，或暫時停用寄件者篩選，以判定是否錯誤封鎖了合法郵件。

停用智慧型郵件篩選器

  1. 按一下 [開始]，並依序指向 [所有程式] 及 [Microsoft Exchange] 後，再按一下 [系統管理員]。

  2. 在 [Exchange 系統管理員] 中，依序展開 [伺服器]、伺服器名稱 及 [通訊協定]，然後展開 [SMTP]。

  3. 在 [SMTP 虛擬伺服器 內容] 中的 [一般] 索引標籤上，按一下 [進階]。

  4. 選取您要停用智慧型郵件篩選器的 IP 位址，然後按一下 [編輯]。

  5. 在 [識別] 中，清除 [套用智慧型郵件篩選器]。

  6. 如果您有多個虛擬伺服器，請對每個要停用智慧型郵件篩選器的虛擬伺服器，重複步驟 3 到 6。

如需詳細資訊，請參閱「Exchange 智慧型郵件篩選器」網站 (英文) (http://go.microsoft.com/fwlink/?LinkId=21607)。


未使用指定的閘道伺服器
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-08-09

Microsoft® Exchange Server Analyzer 工具會從 Exchange 伺服器傳送測試郵件到使用者定義的外部帳戶，然後掃描伺服器的郵件追蹤記錄檔以判定在傳遞測試郵件時是否發現任何問題。

進行掃描時，Exchange Server Analyzer 會檢查用來將郵件路由至外部收件者的 Exchange 閘道伺服器，是否與 [伺服器名稱] 與 [認證] 步驟中，使用者於 [輸入伺服器] 與 [使用者] 資訊頁面中指定的伺服器相同。

若 Exchange Server Analyzer 判定郵件已順利路由至 Exchange 組織外部，但沒有使用指定的閘道伺服器，Exchange Server Analyzer 便會顯示警告。

此警告指出 Exchange 路由拓撲可能發生問題，且有未知的輸出閘道伺服器存在。

若於虛擬伺服器層級，而非連接器層級設定智慧主機項目，便可能會發生路由問題。建議的最佳作法是在 SMTP 連接器而非 SMTP 虛擬伺服器上，設定所有智慧主機項目。

若要疑難排解此警告，請執行下列步驟：

  • 檢閱簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器的組態，確定沒有設定智慧主機項目。

  • 檢閱本機 Bridgehead 伺服器組態，以取得連接器正確的位址空間與成本。

若要檢視和設定智慧主機設定

  1. 開啟 [Exchange 系統管理員]。

  2. 依序展開 [伺服器]、Exchange 伺服器、[通訊協定] 與 [SMTP]。

  3. 在 SMTP 虛擬伺服器 (例如，預設 SMTP 虛擬伺服器) 上按一下滑鼠右鍵，並選取 [內容]。

  4. 選取 [傳遞] 索引標籤，然後按一下 [進階]。

  5. 清除 [智慧主機] 下所有項目。

  6. 按一下 [確定] 來儲存變更，再按一下 [確定] 來關閉 SMTP 虛擬伺服器的 [內容] 對話方塊。

若需如何設定 SMTP 連接器的詳細資訊，請參閱 Microsoft 知識庫文章 822941＜如何在 Exchange 2003 中使用 SMTP 連接器來連接路由群組＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822941)。

若需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkID=67875)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。


在不同伺服器上指定寄件者
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-08-10

Microsoft® Exchange Server Analyzer 工具會查詢所有使用者物件的 Active Directory® 目錄服務 proxyAddress 屬性值，以判定是否具有符合使用者指定的本機寄件者簡易郵件傳送通訊協定 (SMTP) 位址。

如果找到相符的使用者物件proxyAddress，則 Exchange Server Analyzer 會查詢 Active Directory 來取得使用者物件的 msExchHomeServerName 屬性值，以判定該值是否符合使用者指定的 Exchange Server 名稱。

如果 Exchange Server Analyzer 判定使用者指定之寄件者的 msExchHomeServerName 屬性值不符合使用者指定的 Exchange Server 名稱，則 Exchange Server Analyzer 會顯示警告。

此警告指出所提供的 Exchange Server 名稱不正確，或郵件流程問題影響非使用者指定的伺服器。

若要處理此問題，請驗證是否輸入了正確的 Exchange Server 名稱。

檢視所指定之伺服器上的使用者信箱

  1. 啟動 [Exchange 系統管理員]：

    按一下 [開始]，並依序指向 [所有程式] 及 [Microsoft Exchange] 後，再按一下 [系統管理員]。

  2. 在 [Exchange 系統管理員] 中，瀏覽至下列容器並按一下該容器：

    \Administrative Groups\ GroupName \Servers\ ServerName \ StorageGroupName \Mailbox Store\Mailboxes

  3. 驗證在指定的 Exchange 伺服器上是否顯示指定的使用者信箱。


無法識別目標目的伺服器
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-07-06

Microsoft® Exchange Server Analyzer 工具會針對遠端傳遞佇列中郵件的傳送目的地，嘗試識別並建置該遠端伺服器的完整網域名稱 (FQDN)、IP 位址及網域名稱之清單。

遠端伺服器之 FQDN、IP 位址及網域名稱清單的建置流程如下：

  • 查詢簡易郵件傳送通訊協定 (SMTP) 虛擬伺服器之 Active Directory® 目錄服務物件的 msExchSmtpFullyQualifiedDomainName 內容。

    附註：
    接著在查詢所指定的目標 Bridgehead 伺服器時，就會從路由群組連接器目錄物件的 msExchTargetBridgeheadServersDN 內容中讀取 msExchSmtpFullyQualifiedDomainName 內容
  • 針對 SMTP 連接器的指定智慧主機，查詢 SMTP 連接器 Active Directory 物件的 msExchSmtpSmartHost 內容。

  • 針對任何遠端伺服器直接連線，查詢 ExchangeLink Microsoft Windows® Management Instrumentation (WMI) 類別的 LinkName 內容。

如果 Exchange Server Analyzer 判定嘗試建置此清單的動作未產生任何項目，Exchange Server Analyzer 就會顯示錯誤。

這個錯誤表示：

  • 網路可能時斷時續，或 Active Directory 連線有問題，因而導致郵件流程問題。

  • 執行 Exchange Server Analyzer 的帳戶可能沒有查詢此項資訊的足夠權限。

更正此錯誤

  1. 確定已啟動 Exchange Server 電腦，且已連線到網路。

  2. 請確認您有 Active Directory 網域控制站的網路連線。

  3. 在 Exchange Server Analyzer 中指定 Active Directory 網域控制站。

  4. 使用 PING 命令來檢查是否可以連接 Exchange Server 電腦。

  5. 若有裝置防火牆，檢查 RPC 通訊埠是否被封鎖。

  6. 檢查執行 Exchange Server Analyzer 的帳戶之權限。執行 Exchange Server Analyzer 的帳戶，在所掃描的每台 Exchange Server 電腦上都必須擁有本機 Administrator 權限。

若需網路連線問題的詳細資訊，請參閱 Microsoft 知識庫文章 325487＜如何疑難排解網路連線問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)。

若需 Exchange Server Analyzer 連線問題的詳細資訊，請參閱＜Microsoft Exchange Server Best Practices Analyzer 工具疑難排解連線問題＞(英文) (http://go.microsoft.com/fwlink/?LinkId=56285)。

若需有關通訊埠需求的詳細資訊，請參閱知識庫文章 - 832017＜Windows Server 系統的服務概觀及網路通訊埠需求＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)。


已實作 TarpitTime
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-02-21

Microsoft® Exchange Server Analyzer 工具會讀取下列登錄項目，以判定是否已設定收件者篩選的 Tar Pit 功能：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\TarpitTime

如果 Exchange Server Analyzer 發現 TarpitTime 的值大於 0 (零)，就會顯示一則非預設的訊息。

Tar Pitting 是刻意地減慢或延遲非法連線，以降低傳送自動垃圾郵件或執行字典蒐集攻擊之速率的作法。

若要使用收件者篩選，請新增 Microsoft Windows Server™ 2003 Service Pack 1 (SP1) 中的 Tar Pit 功能，如微軟知識庫文件 - 842851＜Microsoft Windows Server 2003 中 SMTP 的 Tar Pit 功能＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=842851) 中所述。特別是在 [通用設定] 中的 [收件者篩選] 索引標籤上選取 [篩選不在目錄中的收件者] 核取方塊時，Tar Pit 功能會讓收件者篩選更有用。

Tar Pit 功能是藉由設定 TarpitTime 登錄子機碼來實作。TarpitTime 登錄子機碼會使用十進位值。當收件者不在目標 Exchange Server 組織中時，十進位值可轉譯為 SMTP 工作階段回應寄件者所等待的秒數。

Tar Pit 功能會讓傳送來路不明之郵件的垃圾郵件傳送者更難自動進行目錄蒐集攻擊。「目錄蒐集攻擊」是從特定組織擷取已知的良好電子郵件地址清單的嘗試。

SMTP 通訊協定在 SMTP 工作階段期間藉由傳回 "2.1.5 Recipient OK" 來確認可接受的收件者。如果郵件傳送給未知的收件者，則 SMTP 通訊協定會傳回 "5.x.x" 錯誤。因此，垃圾郵件傳送者可以撰寫自動程式，它使用一般名稱或目錄條款來將電子郵件地址建構至特定網域。然後，程式可以收集傳回 "2.1.5 Recipient OK" 的所有電子郵件地址，並捨棄導致 "5.x.x" 錯誤的所有電子郵件地址。之後，垃圾郵件傳送者可以出售「良好」的電子郵件地址，或將其作為來路不明郵件的收件者。

如果已選取 [篩選不在目錄中的收件者] 核取方塊，但是未設定 TarpitTime 登錄子機碼，當目標 Active Directory® 目錄服務中不存在某收件者時，Exchange Server 會立即在 SMTP 工作階段期間將 "5.x.x" 錯誤傳回給寄件者。

相反，如果已設定 TarpitTime 登錄子機碼，而且已選取 [篩選不在目錄中的收件者] 核取方塊，SMTP 就會在傳回 "5.x.x" 錯誤之前等待。為 TarpitTime 登錄子機碼輸入的十進位值是 SMTP 在傳回錯誤之前等待的秒數。SMTP 工作階段中的這種暫停會使自動進行目錄蒐集攻擊更加困難。

如前所述，如果已設定 TarpitTime 登錄子機碼，Exchange Server Analyzer 就會顯示一則非預設的訊息。此訊息僅作為資訊參考用途。

重要事項：
這篇文章包含和編輯登錄有關的資訊。在編輯登錄之前，請確定若發生問題時，您知道如何還原登錄。若需有關還原登錄的詳細資訊，請參考 Regedit.exe 或 Regedt32.exe 中的＜還原登錄＞說明主題。
若要檢視或變更 TarpitTime 登錄子機碼

  1. 依序按一下 [開始] 及 [執行]，並在 [開啟] 方塊中鍵入 regedit 後，再按一下 [確定]。

  2. 尋找並按下列登錄子機碼：

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SMTPSVC\Parameters\TarpitTime

  3. [數值資料] 方塊包含十進位數字。此值代表針對 Active Directory 中不存在的每個地址，要延遲 SMTP 地址驗證回應的秒數。

  4. 如果變更此值或刪除 TarpitTime 登錄子機碼，您必須重新啟動簡易郵件傳送通訊協定 (SMTP) 服務。

若需詳細資訊，請參閱微軟知識庫文件 - 842851＜Microsoft Windows Server 2003 中 SMTP 的 Tar Pit 功能＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=842851)。


測試郵件產生 NDR
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會從 Exchange Server 傳送測試郵件至簡易郵件傳送通訊協定 (SMTP) 網域的郵件管理員帳戶或使用者定義的帳戶，然後掃描伺服器的郵件追蹤記錄檔，以判定傳遞測試郵件時是否有發現問題。

進行此掃描時，Exchange Server Analyzer 會查詢 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 類別 (位於 root\MicrosoftExchangeV2 命名空間下) 的 EntryType 內容，以判定建立郵件追蹤記錄項目的原因。

如果 Exchange Server Analyzer 發現 EntryType 內容的值為 1030，就會顯示警告。

此警告表示測試郵件已產生「未傳遞報告 (NDR)」，且伺服器的簡易郵件傳送通訊協定 (SMTP) 組態可能有問題。如果目標收件者不存在，則產生 NDR 是可以預期的，不過此問題是關於測試郵件是否已傳送給合法的收件者。

進行疑難排解的步驟是，嘗試傳送其他郵件給相同的收件者，然後檢閱 NDR 以判定原因。

如需如何進行 NDR 疑難排解的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中的＜疑難排解未傳遞報告郵件＞(http://go.microsoft.com/fwlink/?LinkId=47579)。


測試郵件傳送至錯誤郵件目錄
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-05-17

Microsoft® Exchange Server Analyzer 工具會從 Exchange Server 傳送測試郵件至簡易郵件傳送通訊協定 (SMTP) 網域的郵件管理員帳戶或使用者定義的帳戶，然後掃描伺服器的郵件追蹤記錄檔，以判定傳遞測試郵件時是否有發生問題。

進行此掃描時，Exchange Server Analyzer 會查詢 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 類別 (位於 root\MicrosoftExchangeV2 命名空間下) 的 EntryType 內容，以判定造成郵件追蹤記錄項目的原因。

如果 Exchange Server Analyzer 發現 EntryType 內容的值為 1021，則會顯示警告。

此警告表示測試郵件已傳送至 Exchange Server 的 Badmail 目錄，且伺服器的簡易郵件傳送通訊協定 (SMTP) 組態有問題。

郵件進入 Badmail 目錄的原因如下：

  • 無法傳遞郵件。

  • 已超過重試次數上限。

  • 無法將郵件作為未傳遞郵件退回給寄件者。

如需如何測試外寄郵件流程的相關資訊，請參閱 Microsoft 知識庫文章 297700＜如何使用收取資料夾中的檔案測試輸出郵件流程＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297700)。

如需如何進行郵件流程與 SMTP 疑難排解的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkId=47579)。


測試郵件停在 SMTP 佇列中
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-07-06

Microsoft® Exchange Server Analyzer 工具會從 Exchange 伺服器傳送測試郵件至簡易郵件傳送通訊協定 (SMTP) 網域的郵件管理員帳戶或使用者定義的帳戶，然後掃描伺服器的郵件追蹤記錄檔，以判定傳遞測試郵件時是否有發現任何問題。

進行此掃描時，Exchange Server Analyzer 會查詢 Exchange_MessageTrackingEntry Microsoft Windows® Management Instrumentation (WMI) 類別 (位於 root\MicrosoftExchangeV2 命名空間下) 的 EntryType 內容，以判定建立郵件追蹤記錄項目的原因。

下表列出可能傳回的 EntryType 值。

值名稱 | 值
已透過 X400 接收郵件 | 0
報告已接收 | 2
郵件已提交 | 4
郵件已傳出 | 7
報告已傳出 | 8
郵件已傳遞 | 9
報告已傳遞 | 10
通訊群組清單延伸 | 26
郵件已重新導向 | 28
郵件已重新路由 | 29
MTA 已將伺服器降級 | 31
報告已併入 | 33
報告已產生 | 34
無法路由傳送的報告已捨棄 | 43
系統管理員已刪除郵件 | 50
系統管理員已刪除探查 | 51
系統管理員已刪除報告 | 52
郵件在本機傳遞 | 1000
郵件已透過骨幹傳入 | 1001
郵件已透過骨幹傳出 | 1002
郵件已透過閘道傳出 | 1003
郵件已透過閘道傳入 | 1004
報告已透過閘道傳入 | 1005
報告已透過閘道傳出 | 1006
報告已產生 | 1007
SMTP：郵件已佇列要輸出 | 1010
SMTP：郵件已傳出 | 1011
SMTP：已接收輸入的郵件 | 1012
SMTP：已傳輸輸入的郵件 | 1013
SMTP：已重新路由傳送郵件 | 1014
SMTP：報告已傳入 | 1015
SMTP：報告已傳出 | 1016
SMTP：報告已產生 | 1017
SMTP：報告已併入 | 1018
SMTP：郵件已提交至進階佇列 | 1019
SMTP：已開始輸出郵件 | 1020
SMTP：郵件已傳送至錯誤郵件目錄 | 1021
SMTP：進階佇列失敗 | 1022
SMTP：郵件在本機傳遞 | 1023
SMTP：郵件已提交至分類程式 | 1024
SMTP：已開始將郵件提交至進階佇列 | 1025
SMTP：進階佇列無法傳遞郵件 | 1026
SMTP 儲存區驅動程式：已從儲存區提交郵件 | 1027
SMTP 儲存區驅動程式：郵件已在本機傳遞至儲存區 | 1028
SMTP 儲存區驅動程式：郵件已提交至 MTA | 1029
SMTP：產生未傳遞回報 (NDR) | 1030
SMTP：郵件已傳出 | 1031

如果傳回的 EntryType 值指出發生下列狀況，Exchange Server Analyzer 就會顯示錯誤：

  • 可以順利掃描測試郵件追蹤記錄檔。

  • 測試郵件並未順利從佇列轉送出去。

  • 沒有產生測試郵件的未傳遞回報 (NDR)。

  • 測試郵件沒有傳送至錯誤郵件目錄。

  • 沒有將測試郵件佇列以供遠端傳遞。

  • 未將測試郵件順利傳遞至本機儲存區。

  • 未將測試郵件排定重試分類。

  • 未將測試郵件排定重試路由傳送。

  • 未將測試郵件排定重試本機傳遞。

這個錯誤表示測試郵件停留在其中一個 SMTP 佇列中，必須另做分析，以判定它卡在那裡的原因。

若要解決此問題，請使用 NSlookup 公用程式來檢閱網域名稱系統 (DNS) 解析的可能問題。對於像是無法存取主機錯誤的連線與通訊協定問題，請使用 Telnet.exe 嘗試連接目的電腦。若要疑難排解通訊協定錯誤，請增加 SMTP 元件之 MSExchangeTransport 服務的記錄級別，然後檢閱記錄中的錯誤。或者，您可以使用網路監視器 (Netmon.exe) 工具來取得網路連線錯誤的相關資訊。若要重現問題，您必須強制佇列再試一次。檢查事件日誌是否有與 Microsoft Exchange Information Store 服務相關的錯誤。

若需如何修改記錄設定的相關資訊，請參閱《Exchange Server 傳輸及路由手冊》中＜疑難排解郵件流程及 SMTP＞一節的＜如何修改 MSExchangeTransport 的記錄設定＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

若需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkId=47579)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

  • Microsoft 知識庫文章 821877＜SMTP 及 X400 佇列內容索引標籤上的欄位說明＞(英文) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821877)。

  • Microsoft 知識庫文章 264054＜XCON：瞭解 Exchange 2000 Server 中的佇列狀態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)。


路由群組中有 900 個以上的連接器
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-01-17

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定出現在給定路由群組中的連接器數目 (包括 SMTP 連接器、路由群組連接器、X.400 連接器及 EDK 連接器)。如果 Exchange Server Analyzer 發現單一路由群組中總共有 900 個以上的連接器，就會顯示一則警告。

建議您對於任何一種 Exchange 物件類型，最多只使用 900 個執行個體。這是因為 Active Directory 對任意的給定要求傳回的最大分頁大小，預設為 1000。這表示如果針對物件提出了輕量型目錄存取通訊協定 (LDAP) 要求，且 Active Directory 中存在超過 1,000 個該物件的執行個體，則因為已超過分頁的大小上限，所以不會傳回任何結果。

在 Exchange Server 的情況中，許多處理要求都會要求特定物件類型的個體。例如，[Exchange 系統管理員] 會對 Active Directory 提出 LDAP 要求，以建立路由群組內之所有連接器的清單檢視。如果任一路由群組中有 1,000 個以上的連接器，Active Directory 就不會傳回任何查詢結果。發生此狀況時，會在 [Exchange 系統管理員] 中顯示錯誤。

雖然可增加 Active Directory 的最大分頁大小值，但 Exchange Serve 不建議也不支援這麼做。若提高最大分頁大小，Exchange 環境會出現異常行為及失敗現象。

雖然建議對 Exchange Server 中的任何一個物件類型維持在 900 或低於 900，但最多仍可支援 1000 個物件類型。

若要更正此警告

  1. 考慮合併連接器或建立更多的路由群組，以及負載平衡它們之間的現有連接器。

  2. 檢查 Active Directory 以找出孤立的連接器，並將它們從 Active Directory 中移除。

  3. 請考慮合併貴組織內的 Exchange 伺服器。

若需有關路由群組設計及連接器的詳細資訊，請參閱《Exchange Server 2003 傳輸及路由手冊》(英文) (http://go.microsoft.com/fwlink/?LinkId=47579)。

若需有關合併 Exchange 伺服器的詳細資訊，請參閱《使用 Exchange Server 2003 合併伺服器》(英文) (http://go.microsoft.com/fwlink/?linkid=47586)。


Active Directory 與 Metabase 間的完整格式網域名稱設定不一致
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2007-01-17

Microsoft® Exchange Server Analyzer 工具會在網際網路資訊服務 (IIS) Metabase 中讀取下列屬性，以判定該屬性的值是否符合在 Active Directory® 目錄服務中為 msExchSmtpFullyQualifiedDomainName 屬性設定的值：

/LM/SmtpSvc/<SMTP virtual server instance>/FullyQualifiedDomainName

如果 Exchange Server Analyzer 發現這兩個屬性的值不相符，則會顯示警告訊息。

如果 IIS Metabase 中的值不符合 Active Directory 中的值， 這表示 Active Directory 複寫有問題，或 Exchange 中的 Directory-service-to-Metabase-replication 元件 (DS2MB) 有問題。

DS2MB 處理程序的功能是將組態資訊從 Active Directory 傳輸到本機 Metabase。將這個組態儲存在本機 Metabase 中，而不是儲存在登錄內的原因，是要提高效能和延展性。在 Exchange 2000 Server 和 Exchange Server 2003 中，所有網際網路通訊協定 (SMTP、NNTP、POP3、IMAP4 及 HTTP) 都是當做 IIS 的元件執行。

DS2MB 處理程序每隔 15 分鐘會從 Active Directory 複製整個樹狀子目錄，並且不會改變樹狀子目錄的形狀。這是從 Active Directory 到 Metabase 的單向寫入；Metabase 絕不會寫入 Active Directory。

FullyQualifiedDomainName 屬性 (Property) 及 msExchSmtpFullyQualifiedDomainName 屬性 (Attribute) 使用預設的伺服器名稱，而該名稱對應於 Exchange 伺服器完整格式的網域名稱 (例如，server.domain.com)。如果 FullyQualifiedDomainName 屬性 (Property) 及 msExchSmtpFullyQualifiedDomainName 屬性 (Attribute) 的完整網域名稱值不相同，則表示 Active Directory 與 IIS Metabase 未保持同步。如果問題是因為 DS2MB 處理程序失敗引起的，您可以執行下列適用您的 Exchange Server 版本之程序，更正問題。如果問題是局部或完全因為 Active Directory 複寫失敗引起的，您可以使用 Active Directory Replication Monitor 公用程式 (ReplMon.exe)，檢查 Active Directory 複寫的健全狀態。您可以在 Windows Server™ 2003 光碟的 Microsoft Windows® 支援工具中找到 ReplMon.exe。

在 Exchange Server 2003 上更正這個警告

  1. 檢查應用程式事件日誌項目中，是否有來源為 MSExchangeMU 的項目存在。若 DS2MB 失敗，它會在 Exchange Server 2003 上記錄一個事件。

  2. 若看不到任何 DS2MB 失敗的項目，請使用 ReplMon 診斷 Active Directory 複寫。特別要注意您的 SMTP 虛擬伺服器使用的通用類別目錄伺服器。

  3. 若有看到 DS2MB 失敗項目，或者在您排除或解決 Active Directory 複寫問題之後，重新啟動 Exchange System Attendant 服務。

在 Exchange 2000 Server 上更正這個警告

  1. 使用 ReplMon 診斷 Active Directory 複寫。特別要注意您的 SMTP 虛擬伺服器使用的通用類別目錄伺服器。

  2. 在您排除或解決 Active Directory 複寫問題之後，重新啟動 Exchange System Attendant 服務。

若需 Exchange 中反轉 DNS 查閱功能的相關資訊，請參閱微軟知識庫文件 - 297412＜The 'Perform Reverse DNS Lookup for Incoming Messages' Option Is for Host Name Resolution＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412)。

若需有關 SMTP 虛擬伺服器設定的詳細資訊，請參閱知識庫文件 - 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) 及 268163＜XCON：＜How to Configure a SMTP Virtual Server Part 2＞ (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)。

若需有關 Active Directory 複寫的詳細資訊，請參閱知識庫文件 - 232072＜啟始 Active Directory 直接複寫協力電腦之間的複寫＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072)。

若需有關 DS2MB 處理程序的詳細資訊，請參閱知識庫文件 - 240105＜XGEN：General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105)。


Active Directory 與 Metabase 間的最大躍點計數設定不一致
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會在網際網路資訊服務 (IIS) Metabase 中讀取下列屬性，以判定該屬性的值是否符合在 Active Directory® 目錄服務中為 msExchSmtpMaxHopCount 屬性設定的值：

/LM/SmtpSvc/<SMTP virtual server instance>/HopCount

如果 Exchange Server Analyzer 發現值不符合，則會顯示一則警告。

如果 IIS Metabase 中的值不符合 Active Directory 中的值， 這表示 Active Directory 複寫有問題，或 Exchange 中的 Directory-service-to-Metabase-replication 元件 (DS2MB) 有問題。

DS2MB 處理程序的功能是將組態資訊從 Active Directory 傳輸到本機 Metabase。將這個組態儲存在本機 Metabase 中，而不是儲存在登錄內的原因，是要提高效能和延展性。在 Exchange 2000 Server 和 Exchange Server 2003 中，所有網際網路通訊協定 (SMTP、NNTP、POP3、IMAP4 及 HTTP) 都是當做 IIS 的元件執行。

DS2MB 處理程序每隔 15 分鐘會從 Active Directory 複製整個樹狀子目錄，並且不會改變樹狀子目錄的形狀。這是從 Active Directory 到 Metabase 的單向寫入；Metabase 絕不會寫入 Active Directory。

在 Exchange 2000 Server SMTP 虛擬伺服器上，預設躍點計數是 15。在 Exchange Server 2003 SMTP 虛擬伺服器上，預設躍點計數是 30。無論設定值為何，如果 HopCount 屬性 (Property) 與 msExchSmtpMaxHopCount 屬性 (Attribute) 不符，就表示 Active Directory 與 IIS Metabase 未保持同步。如果問題是因為 DS2MB 處理程序失敗引起的，您可以執行下列適用您的 Exchange Server 版本之程序，更正問題。如果問題是局部或完全因為 Active Directory 複寫失敗引起的，您可以使用 Active Directory Replication Monitor 公用程式 (ReplMon.exe)，檢查 Active Directory 複寫的健全狀態。您可以在 Windows Server™ 2003 光碟的 Microsoft Windows® 支援工具中找到 ReplMon.exe。

若要在 Exchange Server 2003 上更正此錯誤

  1. 檢查應用程式事件日誌項目中，是否有來源為 MSExchangeMU 的項目存在。若 DS2MB 失敗，它會在 Exchange Server 2003 上記錄一個事件。

  2. 若看不到任何 DS2MB 失敗的項目，請使用 ReplMon 診斷 Active Directory 複寫。特別要注意您的 SMTP 虛擬伺服器使用的通用類別目錄伺服器。

  3. 如果確實發生 DS2MB 失敗，或在您排除或解決關於 Active Directory 複寫的問題之後，請重新啟動 Exchange System Attendant 服務。

若要在 Exchange 2000 Server 上更正此錯誤

  1. 使用 ReplMon 診斷 Active Directory 複寫。特別要注意您的 SMTP 虛擬伺服器使用的通用類別目錄伺服器。

  2. 在您排除或解決關於 Active Directory 複寫的問題之後，請重新啟動 Exchange System Attendant 服務。

若需 Exchange 中反轉 DNS 查閱功能的相關資訊，請參閱微軟知識庫文件 - 297412＜The 'Perform Reverse DNS Lookup for Incoming Messages' Option Is for Host Name Resolution＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412)。

若需有關 SMTP 虛擬伺服器設定的詳細資訊，請參閱下列知識庫文件：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

若需有關 Active Directory 複寫的詳細資訊，請參閱知識庫文件 - 232072＜啟始 Active Directory 直接複寫協力電腦之間的複寫＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072)。

若需有關 DS2MB 處理程序的詳細資訊，請參閱知識庫文件 - 240105＜XGEN：General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105)。


Active Directory 與 Metabase 之間的最大郵件大小設定不一致
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會在網際網路資訊服務 (IIS) Metabase 中讀取下列屬性，以判定該屬性的值是否符合在 Active Directory® 目錄服務中為 msExchSmtpMaxMessageSize 屬性設定的值：

/LM/SmtpSvc/<SMTP virtual server instance>/MaxMessageSize

如果 Exchange Server Analyzer 發現值不符合，則會顯示一則警告。

如果 IIS Metabase 中的值不符合 Active Directory 中的值， 這表示 Active Directory 複寫有問題，或 Exchange 中的 Directory-service-to-Metabase-replication 元件 (DS2MB) 有問題。

DS2MB 處理程序的功能是將組態資訊從 Active Directory 傳輸到本機 Metabase。將這個組態儲存在本機 Metabase 中，而不是儲存在登錄內的原因，是要提高效能和延展性。在 Exchange 2000 Server 和 Exchange Server 2003 中，所有網際網路通訊協定 (SMTP、NNTP、POP3、IMAP4 及 HTTP) 都是當做 IIS 的元件執行。

DS2MB 處理程序每隔 15 分鐘會從 Active Directory 複製整個樹狀子目錄，並且不會改變樹狀子目錄的形狀。這是從 Active Directory 到 Metabase 的單向寫入；Metabase 絕不會寫入 Active Directory。

MaxMessageSize 內容及 msExchSmtpMaxMessageSize 屬性都使用預設設定 0，表示沒有施加郵件大小限制。如果 MaxMessageSize 內容及 msExchSmtpMaxMessageSize 屬性的值不相同，則表示 Active Directory 及 IIS Metabase 不同步。如果問題是因為 DS2MB 處理程序失敗引起的，您可以執行下列適用您的 Exchange Server 版本之程序，更正問題。如果問題是局部或完全因為 Active Directory 複寫失敗引起的，您可以使用 Active Directory Replication Monitor 公用程式 (ReplMon.exe)，檢查 Active Directory 複寫的健全狀態。您可以在 Windows Server™ 2003 光碟的 Microsoft Windows® 支援工具中找到 ReplMon.exe。

若要在 Exchange Server 2003 上更正此錯誤

  1. 檢查應用程式事件日誌項目中，是否有來源為 MSExchangeMU 的項目存在。若 DS2MB 失敗，它會在 Exchange Server 2003 上記錄一個事件。

  2. 若看不到任何 DS2MB 失敗的項目，請使用 ReplMon 診斷 Active Directory 複寫。特別要注意您的 SMTP 虛擬伺服器使用的通用類別目錄伺服器。

  3. 如果確實發生 DS2MB 失敗，或在您排除或解決關於 Active Directory 複寫的問題之後，請重新啟動 Exchange System Attendant 服務。

若要在 Exchange 2000 Server 上更正此錯誤

  1. 使用 ReplMon 診斷 Active Directory 複寫。特別要注意您的 SMTP 虛擬伺服器使用的通用類別目錄伺服器。

  2. 在您排除或解決關於 Active Directory 複寫的問題之後，請重新啟動 Exchange System Attendant 服務。

若需有關 Exchange 中反向 DNS 查閱功能的詳細資訊，請參閱微軟知識庫文件 - 297412＜[對傳入的郵件執行反向 DNS 查閱] 選項是供主機名稱解析之用＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412)。

若需有關 SMTP 虛擬伺服器設定的詳細資訊，請參閱下列知識庫文件：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

若需有關 Active Directory 複寫的詳細資訊，請參閱知識庫文件 - 232072＜啟始 Active Directory 直接複寫協力電腦之間的複寫＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072)。

若需有關 DS2MB 處理程序的詳細資訊，請參閱知識庫文件 - 240105＜XGEN：General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105)。


Active Directory 與 metabase 之間的最高工作階段大小設定不一致。
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會在網際網路資訊服務 (IIS) Metabase 中讀取 /LM/SmtpSvc/<SMTP virtual server instance>/MaxSessionSize 內容，以判定其值是否符合在 Active Directory® 目錄服務中為 msExchSmtpMaxSessionSize 屬性設定的值。

若 Exchange Server Analyzer 發現值不相符，就會顯示一則警告訊息。

如果 IIS metabase 中的值與 Active Directory 中的值不符，表示可能是 Active Directory 的複寫作業有問題，或是 Exchange 中的 Directory-service-to-Metabase (DS2MB) 複寫元件有問題。

DS2MB 處理程序的功能是將組態資訊從 Active Directory 傳輸到本機 Metabase。將這個組態儲存在本機 Metabase 中，而不是儲存在登錄內的原因，是要提高效能和延展性。在 Exchange 2000 Server 和 Exchange Server 2003 中，所有網際網路通訊協定 (SMTP、NNTP、POP3、IMAP4 及 HTTP) 都是當做 IIS 的元件執行。

DS2MB 處理程序每隔 15 分鐘會從 Active Directory 複製整個樹狀子目錄，並且不會改變樹狀子目錄的形狀。這是從 Active Directory 到 Metabase 的單向寫入；Metabase 絕不會寫入 Active Directory。

MaxSessionSize 內容及 msExchSmtpMaxSessionSize 屬性都使用預設設定 0，表示沒有施加工作階段大小的限制。如果 MaxSessionSize 內容及 msExchSmtpMaxSessionSize 屬性的值不相同，則表示 Active Directory 及 IIS Metabase 不同步。如果問題是因為 DS2MB 處理程序失敗引起的，您可以執行下列適用您的 Exchange Server 版本之程序，更正問題。如果問題是局部或完全因為 Active Directory 複寫失敗引起的，您可以使用 Active Directory Replication Monitor 公用程式 (ReplMon.exe)，檢查 Active Directory 複寫的健全狀態。您可以在 Windows Server™ 2003 光碟的 Microsoft Windows® 支援工具中找到 ReplMon。

若要在 Exchange Server 2003 上更正此錯誤

  1. 檢查應用程式事件日誌項目中，是否有來源為 MSExchangeMU 的項目存在。若 DS2MB 失敗，它會在 Exchange Server 2003 上記錄一個事件。

  2. 若看不到任何 DS2MB 失敗的項目，請使用 ReplMon 診斷 Active Directory 複寫。特別要注意您的 SMTP 虛擬伺服器使用的通用類別目錄伺服器。

  3. 若有看到 DS2MB 失敗項目，或者在您排除或解決 Active Directory 複寫問題之後，重新啟動 Exchange System Attendant 服務。

若要在 Exchange 2000 Server 上更正此錯誤

  1. 使用 ReplMon 診斷 Active Directory 複寫。特別要注意您的 SMTP 虛擬伺服器使用的通用類別目錄伺服器。

  2. 在您排除或解決 Active Directory 複寫問題之後，重新啟動 Exchange System Attendant 服務。

若需有關 Exchange 中反向 DNS 查閱功能的詳細資訊，請參閱微軟知識庫文件 - 297412＜[對傳入的郵件執行反向 DNS 查閱] 選項是供主機名稱解析之用＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412)。

若需有關 SMTP 虛擬伺服器設定的詳細資訊，請參閱下列知識庫文件：

  • 266686＜XCON：如何設定 SMTP 虛擬伺服器 - 第一部份＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163＜XCON：如何設定 SMTP 虛擬伺服器 - 第二部份＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

若需有關 Active Directory 複寫的詳細資訊，請參閱知識庫文件 - 232072＜啟始 Active Directory 直接複寫協力電腦之間的複寫＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072)。

若需有關 DS2MB 處理程序的詳細資訊，請參閱知識庫文件 - 240105＜XGEN：General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105)。


在過去 24 小時內記錄到傳輸連線管理員警告事件
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-07-07

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_NTLogEvent Microsoft Windows® Management Instrumentation (WMI) 類別，以判定過去 24 小時內是否曾記錄 MSExchangeTransport 的「事件 4006」警告。

如果 Exchange Server Analyzer 發現過去 24 小時內有記錄到 MSExchangeTransport 的「事件 4006」警告，Exchange Server Analyzer 便會顯示警告。

此警告通常指出嘗試傳送郵件到遠端伺服器失敗。

MSExchangeTransport 事件 4006 警告會因為下列狀況而發生：

  • 遠端主機已捨棄連線。

  • 遠端簡易郵件傳送通訊協定 (SMTP) 服務已拒絕 AUTH 協議。

  • 正在嘗試傳遞郵件的伺服器無法存取郵件中的郵件傳遞資訊。

  • 發生 SMTP 錯誤。

  • 正在嘗試傳遞郵件的伺服器無法連線至遠端伺服器。

  • 已在 SMTP 虛擬伺服器的內容中指定的智慧型主機由於任何原因而無法連線。

若需 MSExchangeTransport 事件 4006 警告的詳細資訊，您可以從事件及錯誤訊息中心 (http://go.microsoft.com/fwlink/?LinkId=34258) 尋找事件詳細資料。

若需 Exchange Server 中郵件轉送問題的詳細資訊，請參閱 Microsoft 知識庫文章 895853＜如何疑難排解 Exchange Server 2003 和 Exchange 2000 Server 中的郵件轉送問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853)。

若需郵件流程與 SMTP 問題的詳細資訊，請參閱《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkID=67875)。


在過去 24 小時內記錄到傳輸連線管理員警告事件
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-07-07

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_NTLogEvent Microsoft Windows® Management Instrumentation (WMI) 類別，以判定過去 24 小時內是否曾記錄 MSExchangeTransport 的「事件 4001」警告。

如果 Exchange Server Analyzer 發現過去 24 小時內有記錄到 MSExchangeTransport 的「事件 4001」警告，Exchange Server Analyzer 便會顯示警告。

此警告通常指出嘗試傳送郵件到遠端伺服器失敗。

當 Exchange 2000 Server 或 Exchange Server 2003 上的簡易郵件傳送通訊協定 (SMTP) 服務有一或多個郵件傳遞問題時，就會發生 MSExchangeTransport 事件 4001 警告。郵件傳遞問題的可能原因包括網域名稱系統 (DNS)、IP 組態或安裝錯誤 DLL 檔的問題。

若需事件 4001 警告的詳細資訊，您可以從事件及錯誤訊息中心 (http://go.microsoft.com/fwlink/?LinkId=34258) 尋找事件詳細資料。

若需 Exchange Server 中郵件轉送問題的詳細資訊，請參閱 Microsoft 知識庫文章 895853＜如何疑難排解 Exchange Server 2003 和 Exchange 2000 Server 中的郵件轉送問題＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853)。

若需郵件流程與 SMTP 問題的詳細資訊，請參閱《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(http://go.microsoft.com/fwlink/?LinkID=67875)。


找不到傳輸事件接收器檔案
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-01-10

Microsoft® Exchange Server Analyzer 工具會查詢 Microsoft Internet Information Server (IIS) Metabase，以列舉簡易郵件傳送通訊協定 (SMTP) 傳輸事件接收器繫結的清單。Exchange Server Analyzer 會根據 Exchange Server Analyzer 中預先擴展的清單，嘗試找出幾個標準事件繫結。對於每個繫結，Exchange Server Analyzer 會驗證登錄中下列分支底下的元件物件模型 (COM) 登錄詳細資料：

HKEY_CLASSES_ROOT\CLSID\

COM 登錄詳細資料包含相關聯之 .dll 檔案的完整路徑。Exchange Server Analyzer 會使用 Microsoft Windows® Management Instrumentation (WMI) 來找出 .dll 檔案並顯示其版本號碼。如果 Exchange Server Analyzer 找不到 .dll 檔案，就會顯示警告，其中詳細說明遺漏之 .dll 檔案的檔案名稱與路徑。

如果 Exchange Server Analyzer 發現有遺漏一或多個標準事件繫結，就會產生警告。

SMTP 傳輸事件是在郵件資料傳入或傳出 SMTP 服務時發生。所有郵件都會經歷一些事件。這些包括 X.400 和 RPC 內送或外寄郵件。輸入傳輸事件的一個常見範例是，郵件經由網路或在 SMTP Pickup 目錄中到達 SMTP 服務。此傳輸事件發生時，此事件的來源會通知傳輸事件接收器，每個傳輸事件接受器就會根據郵件的資料內容採取某一類動作。在系統將郵件資料傳遞到接收器後，直到接收器完成其動作並傳回郵件為止，這段期間內系統不會對郵件資料執行其他動作。接收器在執行此動作時，對郵件資料與狀態有獨佔的控制權。

遺漏傳輸事件接收器 COM 登錄的 .dll 檔案可能會造成郵件流程問題。如果 Exchange Server 顯示有郵件流程問題的徵兆 (如郵件在佇列中)，請確認所識別的 .dll 檔案確實存在，如有需要請重新安裝這些 .dll 檔案。

若要解決此問題

  1. 使用 [檔案總管] 手動找出所識別的 .dll 檔案。通常，這個檔案會在 \Program Files\Exchsrvr\Bin 資料夾中。

  2. 如果下列條件為真，則可放心略過 Exchange Server Analyzer 產生的警告：

    • 列出的資料夾中有 .dll 檔案。

    • 伺服器並未顯示有郵件流程問題的徵兆。

  3. 如果下列條件為真，請將遺漏的 .dll 檔案從原始的 Exchange Server 安裝媒體複製過來：

    • Exchange Server Analyzer 所列的資料夾中沒有 .dll 檔案。

    • 伺服器顯示有郵件流程問題的徵兆。

    或者，重新套用最新的 Exchange Service Pack。

  4. 重新執行 Exchange Server Analyzer 以確認不會再顯示警告。


連結狀態資訊的使用者版本變更已被抑制
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2005-11-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定是否已設定 heuristics 屬性，以抑制連結狀態資訊的使用者版本變更。依預設，未設定 heuristics 屬性。如果 Exchange Server Analyzer 發現 heuristics 屬性設為 2048，則 Exchange Server Analyzer 會顯示非預設的組態訊息。

連結狀態表格可保證有效可靠的郵件路由傳送。連結狀態表格包含每個路由群組的版本資訊，包括主要、次要及使用者版本號碼。主要版本變更的優先順序最高，其次是次要變更，最後是使用者版本號碼變更。

當執行基本層級目錄服務更新時，會發生使用者版本變更。這些細微的變更包括當啟動或停止 Exchange 伺服器上的服務、新增其他伺服器至路由群組，或成員伺服器遺失與路由群組主機的連線時，所發生的路由群組主機變更。

當 Exchange Server 系統管理員在路由群組層級進行變更時，會發生基本層級目錄服務更新。例如，當系統管理員變更路由群組名稱、新增伺服器或移除伺服器時，會發生使用者版本變更。然而，使用者版本變更主要源自每個伺服器中的 Microsoft Windows® Management Instrumentation (WMI) 資料。此資料陳述哪些服務正在執行。如果您停止再啟動服務，則會將連結狀態表格中的使用者版本變更，複寫到組織中所有的 Exchange Server 電腦。

頻繁進行使用者版本更新會產生不需要的網路流量，您可以從 Microsoft 產品支援服務取得 Hotfix，然後將 heuristics 屬性設為 2048 (十六進位為 0x800)，來加以抑制。

如果使用者版本更新並未產生過多的網路流量，建議您不要抑制更新。

若要還原為預設組態

  1. 開啟 [Active Directory Service Interfaces (ADSI) 編輯器]。

  2. 在 [ADSI 編輯器] 中，依序展開 [組態容器]、[CN=Configuration]、[DC=DomainName]、[DC=com]、[CN=Services] 及 [CN=Microsoft Exchange]。

  3. 在 CN=OrganizationName 上按一下滑鼠右鍵，再按 [內容]。

  4. 在 [選取內容來檢視] 方塊中，按一下 Heuristics。

  5. 在 [編輯屬性] 方塊中，清除值 0x800。

  6. 按一下 [設定]，再按 [確定]。

  7. 關閉 [ADSI 編輯器]。
注意：
使用 ADSI 編輯器、LDP (ldp.exe) 工具或其他輕量型目錄存取通訊協定 (LDAP) 版本 3 用戶端時，如果錯誤地修改了 Active Directory 物件的屬性，可能會造成嚴重的問題。這些問題可能需要您重新安裝 Microsoft Windows Server™ 2003、Exchange Server 2003 或兩者。修改 Active Directory 物件屬性的風險由客戶自行負責。

若需有關連結狀態及使用者版本號碼的詳細資訊，請參閱《Exchange Server 2003 技術參考手冊》中的＜連結狀態傳用＞(英文) (http://go.microsoft.com/fwlink/?LinkId=49367)。


已識別為共用目的地的使用者
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-09-06

Microsoft® Exchange Server Analyzer 工具會查詢 Exchange_Queue Windows® Management Instrumentation (WMI) 類別，以判定 SMTP 虛擬伺服器的簡易郵件傳送通訊協定 (SMTP) 佇列的下列屬性值。

LinkId | 指出包含佇列的連結的識別碼。
QueueId | 指出佇列的識別碼。
QueueName | 指出佇列的名稱。
VirtualMachine | 指出包含佇列的虛擬機器的名稱。
VirtualServerName | 指出佇列所在的虛擬伺服器的名稱。
MessageCount | 指出佇列中的郵件數目。

Exchange Server Analyzer 會使用以上取得的資訊，查詢 Exchange_QueuedSMTPMessage WMI 類別，以取得佇列中郵件的下列屬性值：

Recipients | 指出郵件的收件者。
Received | 指出郵件的接收時間戳記。
MessageId | 指出已佇列郵件的識別碼。
StateRetry | 指出正在對未順利傳遞的郵件重試傳輸。

最後，Exchange Server Analyzer 會使用在上述查詢中取得的資料，查詢 Active Directory® 目錄服務中每個 [Recipient] 物件的下列值，以判定收件者是使用者、通訊群組、公用資料夾或公用資料夾儲存區：

distinguishedName | 指出物件的辨別名稱。
msExchHomeServerName | 指出收件者所在的伺服器。
homeMDB | 指出收件者的信箱儲存區。

如果 Exchange Server Analyzer 判斷至少有百分之 25 留在佇列的郵件是要送給特定使用者 (出現在 [收件者:]或 [副本:]欄位)，Exchange Server Analyzer 就會顯示警告。

如果 Exchange Server Analyzer 判斷至少有百分之 50 留在佇列的郵件是要送給特定使用者 (出現在 [收件者:]或 [副本:]欄位)，Exchange Server Analyzer 就會顯示錯誤。

此警告或錯誤表示，所識別的使用者是留在 SMTP 佇列中的郵件共同目的地。

若要解決這個問題，請調查使用者的組態是否有問題，或是否有其他可能造成他們的郵件進入佇列的異常問題。

需要進行調查的部分包括：

  • 確認使用者的物件屬性設定正確，且 Active Directory 中所包含的值正確無誤。

  • 檢閱使用者物件的 Active Directory 權限，以確定設定正確無誤。

  • 尋找可能未經同意的廣告郵件 (UCE 或垃圾郵件)，或攻擊使用者的病毒。

  • 判斷使用者是否為未正確設定傳遞限制的通訊群組成員。

  • 如果使用者物件的用途特殊 (例如做為指定的日誌收件者)，請檢閱與使用者物件相關的服務或元件組態，以確定組態正確無誤。

若需如何疑難排解 SMTP 佇列的相關資訊，請參閱下列 Exchange 資源：

  • 《Exchange Server 傳輸及路由手冊》中的＜疑難排解郵件流程及 SMTP＞(英文)(http://go.microsoft.com/fwlink/?LinkID=67875)。

  • Microsoft 知識庫文章 823489＜如何使用「佇列檢視器」排解 Exchange Server 2003 中郵件流量的問題＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)。

如需通訊群組限制對 Exchange Server 郵件流程之影響的詳細資訊，請參閱下列 Microsoft 知識庫文章：

  • 895407＜在 Exchange Server 2003 中根據通訊群組設定傳遞限制後，將郵件傳遞到本機信箱及外部信箱的速度比預期慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)。

  • 329171＜XADM：若設定的收件者已根據群組成員設定傳遞限制，則郵件傳遞的速度會變慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)。

  • 839949＜針對 Exchange 2000 Server 與 Exchange Server 2003 中的郵件傳輸與通訊群組進行疑難排解＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)。

  • 812298＜根據通訊群組清單設定傳遞限制後，郵件傳遞的速度緩慢＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)。


不明 SMTP 問題
Microsoft Exchange Server Analyzer - 文章 > 傳輸 >

主題上次修改日期： 2006-10-06

Microsoft® Exchange Server Analyzer 工具會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 類別，以判定簡易郵件傳送通訊協定 (SMTP) 服務的 Started 機碼值。值為 False 表示 SMTP 服務不在執行中。值為 True 表示 SMTP 服務正在執行中。

Exchange Server Analyzer 也會查詢網際網路資訊服務 (IIS) Metabase，以判定 SMTP 虛擬伺服器執行個體的 ServerState 屬性值。

ServerState 內容代表伺服器執行個體目前的狀態。狀態代碼及相對應的狀態如下：

狀態代碼 | 狀態
1 | 正在啟動
2 | 機碼值
3 | 正在停止
4 | 已停止
5 | 暫停中
6 | 已暫停
7 | 繼續中

若下列條件為真，Exchange Server Analyzer 就會顯示警告：

  • SMTP 服務正在執行。

  • 伺服器上的所有 SMTP 虛擬伺服器執行個體都已啟動。

此警告指出，雖然 SMTP 服務和 SMTP 虛擬伺服器執行個體似乎正在運作，但發生了阻止 SMTP 通訊埠正確回應的問題，需要進一步加以調查。

下列事項可能是造成此問題的原因：

  • SMTP 服務處於無反應狀態。

  • 防火牆或防毒應用程式封鎖 SMTP 通訊埠的通訊。

若要更正此問題：

  • 重新啟動 SMTP 服務。

  • 檢閱與 SMTP 通訊埠相關的任何防火牆或防毒應用程式的組態。

  • 檢閱 Exchange Server Analyzer 提供之特定錯誤的指導和連結。

啟動、停止或暫停 SMTP 服務

  1. 按一下 [開始]，並指向 [系統管理工具]，然後按一下 [元件服務]。

  2. 在主控台樹狀目錄中，按一下 [服務 (本機)]。

  3. 在結果窗格中，於 [簡易郵件傳送通訊協定 (SMTP)] 上按一下滑鼠右鍵，然後依序按一下 [啟動]、[停止] 或 [暫停]。


Exchange Server 2007 整備
Microsoft Exchange Server Analyzer - 文章 >

主題上次修改日期： 2006-07-18

本節中的文章提供詳細資料，說明 Microsoft® Exchange Server Analyzer Tool 評估 Exchange Server 2007 的哪些準備工作。此外，這些文章也會說明您可以採取哪些動作來解決 Exchange Server Analyzer 所發現的必要條件相關錯誤、警告及非預設的組態。


存取控制清單 (ACL) 繼承被封鎖
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-06-19

因為無法傳播必要權限，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 安裝程式要求公用資料夾樹狀目錄物件上必須啟用權限繼承。

若要解決此問題，請確認已啟用「允許傳播權限以跟隨這個物件及子物件」設定，然後重新執行 Exchange Server 2007 安裝程式。

重新啟用公用資料夾樹狀目錄繼承

  1. 開啟 Exchange Server 2003 系統管理員。

  2. 以滑鼠右鍵按一下 [公用資料夾] 儲存區，再按一下 [內容]。

  3. 按一下 [安全性] 索引標籤，再按一下以選取 [允許繼承權限傳播到這個物件] 核取方塊。


Active Directory 架構延伸模組需要已安裝 Ldifde.exe
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-06-19

因為本機電腦無法更新 Active Directory 架構，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Microsoft Exchange 安裝程式要求本機電腦必須安裝 Ldifde.exe，才能對 Active Directory 架構進行必要的延伸。

若要解決此問題，請在本機電腦上安裝 Ldifde.exe，然後重新執行 Exchange Server 2007 安裝程式，或從網域控制站啟動 Exchange Server 2007 安裝程式。

附註：
延伸 Active Directory 架構之後，不需要安裝 ldifde.exe，就可以在本機電腦上安裝 Exchange 2007 伺服器角色。
在本機電腦上安裝 Ldifde.exe

  1. 依序按一下 [開始] 及 [執行]，然後在 [開啟] 欄位中執行 'ServerManagerCmd -i RSAT-ADDS'


ADAM 安裝路徑已存在
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-26

因為嘗試安裝 Active Directory 應用程式模式 (ADAM) 失敗，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

預設位置有先前安裝的 ADAM。Exchange 安裝程式無法將新的 ADAM 安裝至現有的 ADAM 目錄結構。

若要解決此問題，請移除現有的 ADAM 資料夾，然後重新執行 Exchange 安裝程式。


本機電腦上未安裝 ADAM
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-22

因為此電腦上未安裝 Active Directory 應用程式模式 (ADAM)，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

ADAM 是一項輕量型目錄存取通訊協定 (LDAP) 目錄服務，它是特別設計來與擁有目錄功能的應用程式搭配使用。ADAM 只會儲存和複製應用程式特有的資訊，並不需要在網域控制站上部署，也不依存於 Active Directory 目錄服務。ADAM 不提供網路作業系統驗證或授權。

在 Exchange 2007 中，Exchange Transport server role 會使用 ADAM 來儲存組態資訊。將 ADAM 與 Active Directory 同步後，ADAM 也可執行收件者查閱作業以提供郵件安全性。

Microsoft Exchange 安裝程式需要本機電腦上已安裝 ADAM 服務，才能繼續。

若要解決此問題，請從 Active Directory 應用程式模式 (ADAM) (http://go.microsoft.com/fwlink/?linkid=71063) 安裝 ADAM Service Pack 1 (SP1)，然後重新執行安裝程式。


本機電腦上未安裝 ADAM (Longhorn)
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-08-13

因為這部 Windows Server 2008 電腦並未安裝 Active Directory 應用程式模式 (ADAM)，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

ADAM 是一項輕量型目錄存取通訊協定 (LDAP) 目錄服務，它是特別設計來與擁有目錄功能的應用程式搭配使用。ADAM 只會儲存和複製應用程式特有的資訊，並不需要在網域控制站上部署，也不依存於 Active Directory 目錄服務。ADAM 不提供網路作業系統驗證或授權。

在 Exchange 2007 中，Exchange Transport server role 會使用 ADAM 來儲存組態資訊。將 ADAM 與 Active Directory 同步後，ADAM 也可執行收件者查閱作業以提供郵件安全性。

Microsoft Exchange 安裝程式需要本機電腦上已安裝 ADAM 服務，才能繼續。

若要解決此問題，請在執行 Windows Server 2008 作業系統的本機電腦上安裝 ADAM，然後再次執行安裝程式。

將 ADAM 安裝至 Windows Server 2008 作業系統

  1. 按一下 [開始]，選取 [執行]，然後輸入下列命令：

  2. cmd.exe /c start /w pkgmgr.exe /iu:"DirectoryServices-ADAM"

  3. 再次執行 Exchange 2007 安裝程式。


分析程式搜尋警告
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-08-09

本主題的目的是要說明 Exchange Server Analyzer 工具所引出的特定問題。您只應將它套用到已執行過 Exchange Server Analyzer 工具且有遇到該特定問題的系統。

Exchange Server Analyzer 工具可免費下載，它會從拓蹼中的每台伺服器遠端收集組態資料，並自動分析該資料。產生的報告會詳述重要的組態問題、潛在問題及非預設的產品設定。遵循這些建議，您便能達到較佳的效能、延展性、可靠性及執行時間。

如需此工具的相關資訊或是要下載最新版本，請參閱＜Microsoft Exchange Analyzer＞(http://go.microsoft.com/fwlink/?linkid=34707) (英文)。


32 位元相容性警告
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-08-13

因為您正在安裝 32 位元版本的 Microsoft Exchange，所以 Microsoft Exchange Server 2007 安裝程式顯示此警告。

Exchange 2007 提供兩種平台版本：一個平台版本 (64 位元版本) 使用於即時生產環境，另一個平台版本 (32 位元版本) 使用於非生產環境 (例如實驗室、訓練機構、展示會和評估環境)。因為您無法在生產環境中執行 32 位元 Exchange 2007 伺服器，所以只能購買 64 位元版本。

關於在生產和非生產環境中使用 32 位元平台，由於 Microsoft 允許在生產環境中以最少的支援使用 32 位元版本，因此有兩個例外情形。具體而言：

  • 您可以在生產環境中使用 32 位元版本的 Exchange 管理工具，以從 Windows Server 2003 或 Windows XP 管理 Exchange 2007。目前，您還不能在 Windows Vista 或 Windows Server 2008 上使用 32 位元版本或 64 位元版本。對於 Windows Vista 和 Windows Server 2008 的支援，預計在 Exchange 2007 的 Service Pack 1 中推出。

  • 您可以在生產環境中使用 32 位元版本的安裝程式，來延伸 Active Directory 目錄服務架構。如需針對 Exchange 2007 準備 Active Directory 的詳細步驟，請參閱＜如何準備 Active Directory 和網域＞(英文)。

在生產環境中使用 32 位元版本 Exchange 2007 的所有其他用法，均不受支援。

若要下載 32 位元版本的 Exchange 管理工具，請參閱＜Microsoft Exchange Server 2007 管理工具 (32 位元＞(英文) (http://go.microsoft.com/fwlink/?LinkId=82335)。若需 Exchange 2007 平台版本的相關資訊，請參閱 Exchange 2007 產品文件中的＜Exchange Server 2007：平台、版次和版本＞(英文) (http://go.microsoft.com/fwlink/?LinkId=88051)。


需要安裝 Microsoft Windows 作業系統的 2007 年時區更新
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-02-20

由於需要更新來更正此電腦的時區資訊設定，Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要安裝 Microsoft 知識庫文章 931836 所提及的 Windows 作業系統時區更新。

若要解決此問題，請安裝 Microsoft 知識庫文章 931836＜Microsoft Windows 作業系統的 2007 年 2 月累積時區更新＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=931836) 中所提及的更新，然後重新執行 Exchange 2007 安裝程式。


Active Directory 不存在或是無法連接
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-04-18

因為無法連接有效的 Active Directory 目錄服務站台，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Microsoft Exchange 安裝程式需要用於安裝 Microsoft Exchange 的伺服器能夠在 Active Directory 中找出組態命名內容。

若要解決此問題，請驗證執行 Microsoft Exchange 安裝程式的使用者帳戶是否已登入 Active Directory，然後重新執行安裝程式。如果這樣無法解決問題，請遵循下列主題中，有關使用 NETDIAG.Exe 及 DCDIAG.Exe 支援工具的指導，以進一步診斷問題。

如需 Active Directory 疑難排解及 Microsoft Exchange 組態的相關資訊，請參閱：

  • 《Windows Server 2003：操作》中的＜Active Directory 的疑難排解操作＞(英文) (http://go.microsoft.com/fwlink/?LinkId=68099)。

  • 《Active Directory 操作手冊》中的＜Active Directory 的疑難排解工具＞(英文) (http://go.microsoft.com/fwlink/?LinkId=68100)。

  • 《在 Exchange Server 中使用 Active Directory 權限》中的＜組態命名內容＞(英文) (http://go.microsoft.com/fwlink/?LinkId=47592)。

  • 《在 Exchange Server 中使用 Active Directory 權限》(英文) (http://go.microsoft.com/fwlink/?LinkId=47592)。

  • ＜Netdiag 概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkID=69481)。

  • ＜Dcdiag 概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkID=68936)。


Active Directory 網域使用混合模式
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-08-10

Microsoft® Exchange Server 2007 安裝程式無法繼續，因為現有的 Active Directory 網域不是設定為 Microsoft Windows®°2000 Server 原生模式或更佳模式。

Exchange 2007 安裝程式將會建立萬用安全性群組，該群組只能存在於 Windows 2000 Server 原生模式或更佳模式的網域。

若要解決此問題，請依照這些步驟，將網域功能等級至少提高為 Windows 2000 Server 原生模式，然後重新執行 Exchange 2007 安裝程式。

若要提高網域功能等級

  1. 開啟 Active Directory 網域與信任。

  2. 於主控台樹狀目錄中，在您要提高功能的網域上按一下滑鼠右鍵，然後按一下 [提高網域功能等級]。

  3. 在 [選取可用的網域功能等級] 中，使用下列其中一項程序：

    • 若要將網域功能等級提高至 Windows 2000 Server 原生模式，請按一下 [Windows 2000 原生模式]，再按一下 [提高]。

    • 若要將網域功能等級提高至 Windows Server® 2003，請按一下 [Windows Server 2003]，再按一下 [提高]。
注意：

若您現在或將來會有任何網域控制站執行 Windows NT® 4.0 與更舊版本，則請勿將網域功能等級提高至 Windows 2000 Server 原生模式。將網域功能等級設定為 Windows 2000 Server 原生模式之後，便無法將之變更回 Windows 2000 Server 混合模式。

若您現在或將來會有任何網域控制站執行 Windows NT® 4.0 與更舊版本或 Windows 2000 Server，則請勿將網域功能等級提高至 Windows Server 2003。將網域功能等級設定為 Windows Server 2003 之後，便無法將之變更回 Windows 2000 Server 混合模式或 Windows 2000 Server 原生模式。


需要進行 Active Directory 準備
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-26

因為嘗試進行網域準備失敗，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 安裝程式需要 Active Directory 目錄服務先針對 Exchange Server 2007 進行修改，Active Directory 中的網域才可以進行準備。

若要解決此問題，請使用 Setup /PrepareAD 命令來準備 Active Directory，然後準備網域。

若需如何執行 PrepareAD 程序的相關資訊，請參閱＜如何準備 Active Directory 和網域＞(英文) (http://go.microsoft.com/fwlink/?LinkId=78453)。


ADAM 通訊埠已在使用中
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-06

因為嘗試安裝 Gateway Server role 時，偵測到指派給 Active Directory® 應用程式模式 (ADAM) 的通訊埠已在使用中，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

ADAM 是一項輕量型目錄存取通訊協定 (LDAP) 目錄服務，它是特別設計來與擁有目錄功能的應用程式搭配使用。ADAM 只會儲存和複製應用程式特有的資訊，並不需要在網域控制站上部署，也不依存於 Active Directory 服務。ADAM 不提供網路作業系統驗證或授權。

在 Exchange 2007 中，閘道伺服器會使用 ADAM 來儲存組態資訊。將 ADAM 與 Active Directory 目錄服務同步後，ADAM 也可執行收件者查閱作業以提供郵件安全性。

Microsoft Exchange 安裝程式需要有可用 (未使用) 的通訊埠，這樣才能在安裝 Gateway Server role 時，將這些通訊埠指派給 ADAM 同步處理程序。

若要解決此問題，請識別並停止正在使用 ADAM 所需之通訊埠的處理程序，或執行 Exchange 2007 安裝程式並搭配命令列參數，以覆寫已指派的預設 ADAM 通訊埠。

執行安裝程式並覆寫已指派的預設 ADAM 通訊埠

  1. 在命令提示字元中，輸入下列命令：

    Setup.exe /adamport:xxxx /adamsslport:yyyy

    • /adamport:<要指派給 ADAM 的通訊埠編號>

    • /adamsslport:<要指派給 ADAM 的通訊埠編號>


出現應用程式公用資料夾階層
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-05

Microsoft® Exchange Server Analyzer 工具會在 Active Directory® 目錄服務網域中，搜尋應用程式公用資料夾階層。當 Exchange Server Analyzer 找到非 MAPI 公用資料夾樹狀目錄時，Exchange Server Analyzer 會顯示警告。該警告會指出 Exchange 組織中有非 MAPI 公用資料夾樹狀目錄存在。Exchange Server 2007 不支援這些自訂應用程式樹狀目錄。

非 MAPI 公用資料夾樹狀目錄適用於自訂應用程式開發。這些樹狀目錄會出現在 Microsoft Exchange 2000 Server 及 Microsoft Exchange Server 2003 中，但不受 Exchange 2007 支援。建議您在部署 Exchange 2007 之前，先執行下列其中一項作業：

  • 將非 MAPI 公用資料夾樹狀目錄移至 SharePoint Portal Server。

  • 在 Exchange 2003 伺服器上維護資料。

若需不同公用資料夾階層的詳細資訊，請參閱＜選取適用於 Exchange 公用資料夾存取的用戶端＞(英文) (http://go.microsoft.com/fwlink/?LinkId =46439)。


無法判定 Active Directory 站台的名稱
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-06

因為此伺服器似乎不屬於有效的 Active Directory® 目錄服務站台，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Microsoft Exchange 安裝程式需要用於安裝 Exchange 2007 的伺服器屬於有效的 Active Directory 站台。

若要解決此問題，請驗證本機伺服器是否為有效 Active Directory 站台的成員，然後重新執行 Exchange Server 2007 安裝程式。

您可以使用 Nltest.exe 命令列工具的 /DsGetSite 選項，以驗證並顯示站台成員資格。如需相關資訊，請參閱《Windows Server 2003 技術參考》的＜工具與設定集合＞中的＜Nltest.exe:NLTest 概觀＞(英文) (http://go.microsoft.com/fwlink/?LinkId=27734)。

如需 Active Directory 疑難排解的相關資訊，請參閱《Windows Server 2003：操作》中的＜Active Directory 的疑難排解操作＞(英文) (http://go.microsoft.com/fwlink/?linkid=68099)。


找不到收件者更新服務
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-05-16

因為在現有 Exchange 組織中找不到負責某個網域的收件者更新服務 (RUS)，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Microsoft Exchange 安裝程式需要現有 Exchange 組織中的每個網域都有一個收件者更新服務執行個體。

如果網域遺失收件者更新服務執行個體，則在網域中建立的新使用者物件將收不到發給它們的電子郵件地址。

若要解決此問題，請驗證每個網域是否都有收件者更新服務執行個體，並為沒有收件者更新服務執行個體的網域建立收件者更新服務執行個體，然後重新執行 Microsoft Exchange 安裝程式。

建立網域的收件者更新服務執行個體

  1. 開啟 [Exchange 系統管理員]。

  2. 展開 [收件者]。

  3. 在 [收件者更新服務] 節點上按一下滑鼠右鍵，再按 [新增] 及 [收件者更新服務]。

  4. 在 [新物件] 視窗中，按一下 [瀏覽] 以尋找網域名稱。

  5. 選取網域名稱，並按一下 [確定]。

  6. 在 [新物件] 視窗中，按 [下一步]，再按 [完成]。

若需「收件者更新服務」的相關資訊，請參閱下列 Microsoft 知識庫文章：

  • ＜收件者更新服務如何套用收件者原則＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)。

  • ＜收件者更新服務如何擴展通訊清單＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)。

  • ＜如何檢查 Exchange 收件者更新服務的進度＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)。

  • ＜Exchange 收件者更新服務執行的工作＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)。


無法移除信箱資料庫
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-06-20

因為解除安裝 Mailbox Server role 處理程序無法從本機伺服器移除使用者信箱資料庫 (儲存區) 而不遺失資料，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式移除 Mailbox server role 之前，會先檢查伺服器中的所有信箱儲存區是否均已移除。不過，伺服器上可能還有使用者信箱。

若要解決此問題，請移動或停用伺服器上的所有使用者信箱，然後重新執行 Exchange 2007 安裝程式。

若需在資料庫中識別信箱的相關資訊，請參閱 Exchange Server 2007 產品文件中的＜Get-Mailbox 指令程式＞(http://go.microsoft.com/fwlink/?LinkId=93470) (英文)。

若需停用信箱的相關資訊，請參閱 Exchange Server 2007 產品文件中的＜如何停用信箱＞(http://go.microsoft.com/fwlink/?LinkId=93471) (英文)。

若需如何在 Exchange Server 2007 中移除信箱資料庫的相關資訊，請參閱 Exchange Server 2007 產品文件中的＜如何移除信箱資料庫＞(http://go.microsoft.com/fwlink/?LinkId=93473) (英文)。

如需如何管理使用者信箱資料庫儲存區或複本的相關資訊，請參閱《Exchange Server 2003 系統管理手冊》中的＜管理信箱儲存區及公用資料夾儲存區＞(http://go.microsoft.com/fwlink/?LinkId=47617)。


無法移除公用資料夾資料庫
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-01-23

因為解除安裝 Mailbox Server role 處理程序無法從本機伺服器移除公用資料夾資料庫而不遺失資料，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要先從伺服器中移除公用資料夾資料庫，然後才能移除 Mailbox Server role。

伺服器中可能留有公用資料夾複本，或公用資料夾資料庫可能是 Exchange 組織中最後一個資料庫。

若要解決此問題，請移除或刪除伺服器上的公用資料夾資料庫，並重新執行 Exchange Server 2007 安裝程式。

若需有關移除 Exchange Server 2007 中之公用資料夾資料庫的詳細資訊，請參閱 Exchange Server 2007 產品文件中的＜如何移除公用資料夾資料庫＞(英文) (http://go.microsoft.com/fwlink/?LinkId=81409)。

如需如何管理公用資料夾資料庫儲存區或複本的相關資訊，請參閱《Exchange Server 2003 系統管理手冊》中的＜管理信箱儲存區及公用資料夾儲存區＞(http://go.microsoft.com/fwlink/?LinkId=47617)。


無法移除 Unified Messaging Server Role
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-26

因為嘗試解除安裝 Unified Messaging server role 失敗，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式會檢查要解除安裝的 Unified Messaging server role 是否主控撥號對應表的提示發行端點，以及該撥號對應表是否連結到其他伺服器。

如果 Unified Messaging server role 主控撥號對應表的提示發行端點，解除安裝處理程序就會失敗。

若要解決此問題，請將提示發行端點移到另一部伺服器，然後重新執行 Exchange 2007 安裝程式。

若需移動撥號對應表之提示發行端點的相關資訊，請參閱＜如何變更提示發行端點＞(http://go.microsoft.com/fwlink/?LinkId=82356) (英文)。


無法寫入 CMS 資料路徑
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-26

因為嘗試將叢集 Mailbox server role 安裝到共用叢集磁碟機失敗，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 安裝程式無法寫入提交給 /CMSDataPath 參數的目標安裝路徑。Exchange 安裝程式需要叢集信箱伺服器資料的目標路徑為可寫入的磁碟區。

若要解決此問題，請指定 /CMSDataPath 的目標路徑，讓它位於可寫入的儲存媒體上。

若需安裝叢集信箱伺服器的相關資訊，請參閱 Exchange Server 2007 產品文件中的＜如何在主動節點上安裝 Mailbox Server Role＞(英文) (http://go.microsoft.com/fwlink/?LinkId=86624)。


無法寫入 Exchange 組織容器
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-05-04

因為登入的使用者沒有必要的帳戶權限，無法寫入 Active Directory 目錄服務中的組織容器，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Microsoft Exchange 安裝程式需要登入的使用者在安裝 Exchange 2007 時具有企業系統管理員或 Exchange 組織系統管理認證。

在安裝的過程中，Exchange 2007 安裝程式可能必須在 Microsoft Exchange 組織容器中建立物件。

若要解決此問題，請對登入的使用者授與企業系統管理員或 Exchange 組織系統管理員權限，或是使用具有那些權限的帳戶來登入，然後重新執行 Exchange 2007 安裝程式。

重要事項：
不支援跨樹系安裝 Exchange 2007。請使用您要在其中安裝 Exchange 2007 之 Active Directory 樹系的成員帳戶。

若需使用 Microsoft Exchange 所需之 Active Directory 權限的相關資訊，請參閱《在 Exchange Server 中使用 Active Directory 權限》(英文) (http://go.microsoft.com/fwlink/?LinkId=47592)。


本機站台未偵測到 Client Access role
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-06

因為在本機 Active Directory® 目錄服務站台中偵測不到現有的 Client Access role，所以 Microsoft® Exchange Server 2007 安裝程式顯示此警告。

於 Active Directory 站台中安裝 Client Access role 執行個體之前，您已選擇安裝 Mailbox Server role。

Client Access Server role 會接受各種不同用戶端對 Exchange 2007 伺服器的連線。Microsoft Outlook Express 及 Eudora 這類的軟體用戶端會使用 POP3 或 IMAP4 連線與 Exchange 伺服器通訊。行動裝置這類的硬體用戶端則會使用 ActiveSync、POP3 或 IMAP4 與 Exchange 伺服器通訊。

如果使用者需要使用 Microsoft Office Outlook® 以外的用戶端存取其收件匣，您就必須在 Exchange 組織中安裝 Client Access Server role。

除非本機 Active Directory 站台中出現 Client Access role，否則使用者只能夠利用 Outlook 登入其信箱，而無法使用 Outlook Web Access 或行動裝置登入其信箱。


叢集管理的資源需要進行移動或使其離線
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-04-09

因為嘗試安裝新的作用中叢集 Mailbox server role 失敗，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange Server 2007 需要在安裝程式所執行的叢集節點上，受叢集管理的資源狀態為非作用中。

若要解決此問題，請將此節點擁有的所有受叢集管理資源，包括非 Exchange Server 叢集資源在內，移到叢集的另一個節點。或者，也可以使它們離線，然後重新執行安裝程式。

若需如何移動 Exchange 相關叢集管理服務的相關資訊，請參閱 Exchange Server 2007 產品文件中的＜Move-ClusteredMailboxServer＞ (http://go.microsoft.com/fwlink/?LinkId=86627) 指令程式主題 (英文)。

若需如何使 Exchange 相關之叢集管理服務離線的相關資訊，請參閱 Exchange Server 2007 產品文件中的＜Stop-ClusteredMailboxServer＞ (http://go.microsoft.com/fwlink/?LinkId=86635) 指令程式主題 (英文)。

若需管理非 Exchange 叢集資源的相關資訊，請參閱 Windows Server 2003 產品說明中的＜管理資源＞ (http://go.microsoft.com/fwlink/?LinkId=86637) (英文)。


叢集服務未啟動
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-26

因為沒有啟動 Microsoft Windows Server Cluster 服務，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式要求，本機電腦上若有安裝叢集服務時，必須啟動叢集服務。

若要解決此問題，請啟動本機電腦上的叢集服務，然後重新執行 Exchange 安裝程式。

若要啟動叢集服務，請參閱 Windows Server 2003 技術文件庫中的＜啟動叢集服務＞(http://go.microsoft.com/fwlink/?LinkId=86638)(英文)。


需有叢集更新 (KB921181)
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-08-11

因為需要更新叢集節點，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要安裝 Microsoft 知識庫文章 921181 所提及的叢集節點更新。

若要解決此問題，請安裝 Microsoft 知識庫文章 921181 ＜可安裝更新，將檔案共用旁觀功能與可設定叢集活動訊號功能新增至 Windows Server 2003 Service Pack 1 型的伺服器叢集＞(英文) (http://go.microsoft.com/fwlink/?LinkId=69785) 所提及的更新，然後重新執行 Exchange 2007 安裝程式。


CMS 資料路徑必須是 NTFS 磁碟區
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-26

因為嘗試將叢集 Mailbox server role 安裝到共用叢集磁碟機失敗，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

針對 /CMSDataPath 參數所提交的目標安裝路徑不是 NTFS 磁碟區。Exchange 安裝程式要求叢集信箱伺服器資料的目標路徑必須是 NTFS 磁碟區。

若要解決此問題，請為 /CMSDataPath 選取不同的目標路徑，或是將目標磁碟區轉換成 NTFS，然後重新執行 Exchange 2007 安裝程式。

若需將磁碟區轉換為 NTFS 的相關資訊，請參閱 Windows XP Professional 產品文件中的＜轉換＞(英文) (http://go.microsoft.com/fwlink/?LinkId=86642) 主題。


目前的叢集節點擁有叢集管理服務
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-04-09

因為嘗試解除安裝叢集被動節點失敗，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 叢集管理服務由此叢集節點所擁有。Exchange 2007 安裝程式需要從此節點移走 Exchange 叢集管理服務，然後才能移除 Exchange 檔案。

若要解決此問題，請將此節點擁有的所有受叢集管理資源 (包括非 Exchange Server 叢集資源在內) 移到叢集的另一個節點，或使它們離線，然後重新執行安裝程式。

若需如何移動 Exchange 相關叢集管理服務的相關資訊，請參閱 Exchange Server 2007 產品文件中的＜Move-ClusteredMailboxServer＞ (http://go.microsoft.com/fwlink/?LinkId=86627) 指令程式主題 (英文)。

若需如何使 Exchange 相關之叢集管理服務離線的相關資訊，請參閱 Exchange Server 2007 產品文件中的＜Stop-ClusteredMailboxServer＞ (http://go.microsoft.com/fwlink/?LinkId=86635) 指令程式主題 (英文)。

若需管理非 Exchange 叢集資源的相關資訊，請參閱 Windows Server 2003 產品說明中的＜管理資源＞ (http://go.microsoft.com/fwlink/?LinkId=86637) (英文)。


必須先啟動 COM+ Event System 服務，安裝程式才能繼續
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-16

因為嘗試安裝 Client Access Server 或 Edge Transport server roles 失敗 (原因是未啟動目標電腦上的 COM+ Event System 服務)，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式要求，安裝 Microsoft Exchange 的電腦必須將 COM+ Event System 服務狀態設為 [已啟動]。

COM+ Event System 服務可支援 COM+ 元件的系統事件通知，自動將事件分散到訂閱 COM 元件。

Client Access Server 及 Edge Transport server role 都有 COM+ 元件依存性，而這些元件會訂閱 COM+ Event System 服務。

若要解決此問題，請驗證本機電腦上的 COM+ Event System 服務狀態設為 [已啟動]，然後重新執行 Microsoft Exchange 安裝程式。

將 COM+ Event System 服務的狀態設為「已啟動」

  1. 以滑鼠右鍵按一下 [我的電腦]，然後按一下 [管理]。

  2. 展開 [服務及應用程式] 節點，再按一下 [服務] 節點。

  3. 在右窗格中，找出 [Com+ Event System]。

  4. 以滑鼠右鍵按一下 [Com+ Event System]，然後按一下 [內容]。

  5. 將 [啟動類型] 設定為 [自動]，而 [服務狀態] 設為 [已啟動]。

  6. 按一下 [套用]，然後按一下 [確定]。


偵測到複雜 Exchange 組織模型
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-08-10

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 Exchange Server 組織中的路由群組數目。Exchange Server Analyzer 也會查詢 Active Directory，以判定有多少個 Active Directory 站台的 Exchange 伺服器正在執行 Microsoft Exchange 2000 Server 或 Microsoft Exchange Server 2003。

如果下列條件為真，Exchange Server Analyzer 會將 Exchange 組織分類為複雜 Exchange 組織：

  • 有多個 Active Directory 樹系存在。

  • 已在一或多個樹系上安裝 Microsoft Identity Integration Server (MIIS)。

Microsoft Exchange Server 2007 有四個已定義的組織模型，其中複雜 Exchange 組織是唯一包括多個 Active Directory 樹系或使用同步處理技術的模型。

將複雜 Exchange 組織轉換至 Exchange 2007

  1. 請造訪 Exchange Server 2007 產品的線上文件 (英文) (http://go.microsoft.com/fwlink/?LinkId=69434)。

  2. 檢閱＜規劃複雜 Exchange 組織＞主題 (英文) (http://go.microsoft.com/fwlink/?LinkId=70505)。


本機電腦上找不到預設網站
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-06

Microsoft® Exchange Server 2007 安裝程式無法存取此伺服器上的預設網站，因此無法繼續。

Exchange 2007 安裝程式需要安裝的 Client Access role 能夠存取 Microsoft Internet Information Services (IIS) 所建立的預設網站。

Client Access Server role 提供用戶端存取功能，例如 Microsoft Office Outlook® (透過 HTTP 連線時)、Outlook Web Access、Exchange ActiveSync®，以及使用 POP3 或 IMAP4 通訊協定的用戶端。

IIS 會作為 HTTP、POP3、IMAP4、簡易郵件傳送通訊協定 (SMTP)，以及網路 NEWS 傳輸通訊協定 (NNTP) 的通訊協定引擎。

IIS 預設網站已不存在，可能會發生一些狀況。IIS 可能已遭刪除或已重新命名為「預設網站」以外的名稱。

若要解決此問題，請先移除此伺服器上的 IIS，再加以重新安裝。然後重新執行 Exchange 2007 安裝程式。

重要事項：
您必須解除安裝再重新安裝 IIS 才能解決此問題。重新建立或重新命名目錄並不足夠。
使用控制台中的 [新增或移除 Windows 元件] 來解除安裝 IIS

  1. 在 [開始] 功能表上，按一下 [控制台]。

  2. 按兩下 [新增或移除程式]。

  3. 按一下 [新增/移除 Windows 元件]。

  4. 在 [元件] 清單中，按一下 [應用程式伺服器] 核取方塊。

  5. 按一下 [詳細資料]。

  6. 按一下 [網際網路資訊服務管理員]。

  7. 按 [下一步]。

  8. 解除安裝完 IIS 後，按一下 [完成]。
使用控制台安裝 IIS

  1. 在 [開始] 功能表上，按一下 [控制台]。

  2. 按兩下 [新增或移除程式]。

  3. 按一下 [新增/移除 Windows 元件]。

  4. 在 [元件] 清單中，按一下 [應用程式伺服器] 核取方塊。

  5. 按一下 [詳細資料]。

  6. 按一下 [網際網路資訊服務管理員] 核取方塊。

  7. 按 [確定] 直到回到 [Windows 元件精靈]。

  8. 按 [下一步] 完成 [Windows 元件精靈]。


必須先啟動 Distributed Transaction Coordinator 服務，安裝程式才能繼續
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-16

因為嘗試安裝 Client Access Server 或 Unified Messaging server role 失敗 (原因是未啟動目標電腦上的 Distributed Transaction Coordinator 服務)，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式要求，安裝 Microsoft Exchange 的電腦必須將 Distributed Transaction Coordinator 服務狀態設為 [已啟動]。

Distributed Transaction Coordinator 服務提供的服務是設計來確保在系統失敗、處理程序失敗及通訊失敗時，也能順利完成交易。

參與分散式交易的每部電腦都會管理它自己的資源及資料，同時與交易中的其他電腦協調運作。最重要的是，分散式交易必須在所有參與電腦上，完全確認或中止其工作。Distributed Transaction Coordinator 可針對相關元件扮演交易協調角色，並當成管理交易之每部電腦的交易管理員。

Client Access Server 及 Unified Messaging server role 都有 Distributed Transaction Coordinator 服務依存性。

若要解決此問題，請驗證本機電腦上的 Distributed Transaction Coordinator 服務狀態設為 [已啟動]，然後重新執行 Microsoft Exchange 安裝程式。

將 Distributed Transaction Coordinator 服務的狀態設為「已啟動」

  1. 以滑鼠右鍵按一下 [我的電腦]，然後按一下 [管理]。

  2. 展開 [服務及應用程式] 節點，再按一下 [服務] 節點。

  3. 在右窗格中，找出 [Distributed Transaction Coordinator]。

  4. 以滑鼠右鍵按一下 [Distributed Transaction Coordinator]，然後按一下 [內容]。

  5. 將 [啟動類型] 設定為 [自動]，而 [服務狀態] 設為 [已啟動]。

  6. 按一下 [套用]，然後按一下 [確定]。


未在本機電腦上設定 DNS 尾碼
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-05

因為未設定本機電腦的完整網域名稱 (FQDN)，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要本機電腦已設定有效的網域名稱系統 (DNS) 尾碼。

若要解決此問題，請設定本機電腦的尾碼、重新啟動電腦，然後重新執行 Exchange 2007 安裝程式。

設定本機電腦的主要 DNS 尾碼

  1. 在 [我的電腦] 上按一下滑鼠右鍵，然後按一下 [內容]。此時會出現 [系統內容] 對話方塊。

  2. 按一下 [電腦名稱] 索引標籤。

  3. 按一下 [變更]。此時會出現 [電腦名稱變更] 對話方塊。

  4. 按一下 [其他]。此時會出現 [DNS 尾碼和 NetBIOS 電腦名稱] 對話方塊。

  5. 輸入網域的適當 DNS 尾碼。

  6. 選取 [當網域成員資格變更時，也變更主要 DNS 尾碼] 核取方塊。

  7. 按一下 [確定] 以儲存變更，再按 [確定] 以結束 [電腦名稱變更] 對話方塊。

  8. 按一下 [確定] 以關閉 [系統內容] 對話方塊，然後再重新啟動電腦，讓變更生效。

如需 DNS 名稱的相關資訊，請參閱 Microsoft 知識庫文章 909264＜Active Directory 中電腦、網域、站台及 OU 的命名慣例＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=909264)。


登錄中已設定網域控制站覆寫
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-27

因為嘗試使用指定的網域控制站失敗，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。已經在登錄中靜態對應網域控制站。

Exchange 2007 安裝程式要求，在安裝命令中指定的網域控制站必須符合已經使用登錄覆寫來靜態對應的網域控制站。

若要解決此問題，請再次執行安裝程式，並指定靜態對應的網域控制站給 /DomainController: < 靜態對應的網域控制站的 FQDN> 參數。

若需 DSAccess 及目錄服務偵測的相關資訊，請參閱 Microsoft 知識庫文章 250570＜目錄服務伺服器偵測及 DSAccess 使用＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)。


需要網域準備
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-27

因為嘗試安裝伺服器角色的動作失敗，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Microsoft Exchange 安裝程式要求在安裝某些伺服器角色之前，本機網域必須可供 Exchange Server 2007 使用。

準備網域供 Exchange Server 2007 使用的動作，包含下列工作：

  • 針對「Exchange 伺服器」、「Exchange 組織系統管理員」、「已驗證的使用者」及「Exchange 信箱系統管理員」設定網域容器的權限。

  • 建立「Microsoft Exchange 系統物件」容器 (如果沒有的話)，並針對「Exchange 伺服器」、「Exchange 組織系統管理員」及「已驗證的使用者」設定此容器的權限。

  • 在目前的網域中，建立一個名為「Exchange 安裝網域伺服器」的新網域全域群組。

  • 將「Exchange 安裝網域伺服器」群組新增至根網域中的 Exchange Servers USG。

若要解決此問題，請執行 setup /PrepareDomain 讓本機網域就緒，然後重試伺服器角色安裝。

若需如何執行 PrepareDomain 程序的相關資訊，請參閱＜如何準備 Active Directory 和網域＞(英文) (http://go.microsoft.com/fwlink/?LinkId=78453)。


本機電腦上不能安裝 Edge Transport role
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-01-03

因為嘗試安裝 Edge Server 角色時，發現此伺服器上已安裝其他 Microsoft Exchange 角色，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式無法在已安裝其他 Microsoft Exchange 角色的伺服器上安裝 Edge Server 角色。

Microsoft Exchange Edge Server 角色會部署在您組織的周邊網路，並處理所有網際網路對向的郵件流程。它可以為在信任的 Microsoft Exchange 組織之間傳送的郵件提供加密及解密，也可以提供防範垃圾郵件的保護。

若要解決此問題，請在未安裝其他 Microsoft Exchange 角色的電腦上安裝 Edge Server 角色。


拓撲中發現 EDK 連接器
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-04

Microsoft® Exchange Server Analyzer 工具會檢查 Active Directory® 目錄服務，在 Exchange 組織中尋找 Exchange 開發套件 (EDK) 連接器。如果在 Active Directory 中找到 EDK 連接器，Exchange Server Analyzer 便會顯示警告。此警告指出 Microsoft Exchange Server 2007 不支援 EDK 連接器。

建議您連絡協力廠商，以取得適用於 Exchange 2007 的替換連接器產品。或者，您可以保留 Exchange 2003 或 Microsoft Exchange 2000 Server，以支援 EDK 連接器。

附註：
EDK 連接器是協力廠商建置的應用程式，用來連接至通訊系統 (例如傳真機、Short Message Service (SMS)、telex) 或連接至使用閘道連接器的其他郵件系統 (例如 Lotus Notes)。非 Microsoft 廠商會使用 Exchange 開發套件 (EDK) 來開發專用的連接器。


Esm.dll 正由一或多個處理程序使用中
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-28

因為嘗試升級伺服器時發生模組存取問題，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要特定模組不執行，好讓升級程序修改二進位檔案。Esm.dll 檔就是此類模組。

若要解決此問題，請上傳已開啟 Esm.dll 的處理程序，然後執行 Exchange 2007 安裝程式。

停止已開啟 Esm.dll 的處理程序

  1. 啟動 Exchange 管理命令介面

  2. 使用 Get-Process 指令程式，尋找 Exchange Analyzer 所識別之處理程序的處理程序 ID。

  3. Get-Process < 處理程序名稱 >

  4. 使用 Stop-Process 指令程式停止處理程序。

  5. Stop-Process < 處理程序 ID >

  6. 其中 <process ID> 是此處步驟 2 中 Get-Process 指令程式所傳回的處理程序 ID 值。

若需 Get-Process 指令程式的相關資訊，請參閱＜Windows PowerShell 的用途？＞主題中的＜使用 Get-Process 指令程式＞(英文)。


'ExchHelp.chm' 已開啟
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-16

因為嘗試升級伺服器時發生檔案存取問題，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要關閉特定檔案，好讓升級處理程序可以修改檔案或存取它們的處理程序。本機 Exchange 說明 (ExchHelp.chm) 檔案就是此類檔案。

若要解決此問題，請關閉 ExchHelp.chm 檔案，然後重新執行 Exchange 2007 安裝程式。


Exchange 2000 Server 電腦需要升級為 SP3
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-27

因為現有組織中，有一或多部伺服器執行的是 Exchange 2000 Server，但卻沒有 Service Pack 3 或更新版本，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式要求組織中所有現有的 Exchange 2000 Server 電腦都必須執行 Exchange 2000 Server Service Pack 3 (SP3)。

若要解決此問題，請將組織中所有現有的 Exchange 2000 Server 電腦升級至 Exchange 2000 Server SP3 或更新版本，然後重新執行 Exchange 2007 安裝程式。

若需將 Exchange 2000 Server 電腦升級至 Exchange 2000 Server SP3 或更新版本的相關資訊，請參閱＜Exchange 2000 Server 的下載程式＞(http://go.microsoft.com/fwlink/?LinkId=86647) (英文)。


Exchange 組織處於混合模式
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-05

Microsoft® Exchange Server Analyzer 工具會查詢 Exchange 組織容器，以判斷 Exchange 組織的模式。Exchange Server Analyzer 會檢查 msExchangeMixedMode 屬性的值。如果 msExchangeMixedMode 屬性的值是 True，則 Exchange Server Analyzer 會顯示錯誤。此錯誤訊息指出 Exchange 組織正在混合模式中執行。Microsoft Exchange Server 2007 只能安裝在處於原生模式的組織中。因此，您必須將在混合模式中執行的組織切換至原生模式，以準備 Exchange 2007 部署。

附註：
在原生模式中執行的組織只能包含 Exchange 2000 或更新版本。

若要準備 Exchange 2007 部署，您必須遵循下列步驟，將 Exchange 組織轉換為原生模式：

  1. 移除或解除委任任何剩餘的 Exchange 5.5 伺服器。

  2. 在 Exchange 系統管理員中，開啟 Exchange 組織物件的內容，然後切換至原生模式。

若需如何將 Exchange 組織轉換為原生模式的詳細資訊，請參閱《Exchange Server 2003 部署手冊》中的＜如何在 Exchange 中從混合模式轉換至原生模式＞ (http://go.microsoft.com/fwlink/?LinkId=56642)。

若需 Microsoft Exchange 的混合模式及原生模式的詳細資訊，請參閱下列 Microsoft 知識庫文章：

  • 270143＜Exchange 2000 Server 及 Exchange Server 2003 中混合模式及原生模式的描述＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270143)。

  • 327779＜如何在 Exchange 中從混合模式轉換至原生模式＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779)。

  • 272314＜XADM：將混合模式準備就緒，以便轉換為原始模式＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=272314)。


Exchange Server 2003 電腦需要升級為 SP2
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-27

因為現有的組織中有一或多個伺服器執行 Exchange Server 2003 但不含 Service Pack 2 (或更新版本)，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要組織中所有現有的 Exchange Server 2003 電腦都執行 Exchange Server 2003 Service Pack 2 (SP2) 或更新版本。

若要解決此問題，請將組織中所有現有的 Exchange Server 2003 電腦升級至 Exchange Server 2003 SP2 或更新版本，然後重新執行 Exchange 2007 安裝程式。

若需 Exchange Server 2003 電腦升級至 Exchange Server 2003 SP2 或更新版本的相關資訊，請參閱＜Exchange Server 2003 的下載＞(英文) (http://go.microsoft.com/fwlink/?LinkId=21030)。


Exchange Server 2007 無法與此版的 Windows 搭配使用
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-27

因為 Exchange Server 2007 不支援本機電腦所執行的 Microsoft Windows Server 作業系統版本，所以 Microsoft Exchange Server 2007 安裝程式無法繼續進行。

Exchange 2007 安裝程式要求本機電腦上的 Windows Server 版本必須能夠支援執行 Exchange Server 2007，如「Exchange Server 2007 系統需求」所指定。

若要解決此問題，請在本機電腦上安裝可支援 Exchange Server 2007 的 Windows Server 作業系統版本，或是在執行 Windows Server 受支援版本的電腦上安裝 Exchange Server 2007。

若需 Exchange Server 2007 系統需求的相關資訊，請參閱＜Exchange Server 2007 系統需求＞(http://go.microsoft.com/fwlink/?LinkId=86651) (英文)。


未設定檔案共用見證
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-23

因為沒有為叢集連續複寫 (CCR) 叢集設定檔案共用見證，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

若要能夠承受多數節點組合 (MNS) 仲裁叢集中任何一個節點的失敗，您至少必須有三個裝置是可用的。檔案共用見證功能可讓您使用外部檔案共用作為見證。此見證可扮演雙節點 MNS 仲裁叢集中的第三個可用的裝置。

Exchange 2007 安裝程式需要為 CCR 環境中叢集式 Mailbox server role 的安裝，設定檔案共用見證功能。

若要解決此問題，請遵循＜如何設定檔案共用見證＞(http://go.microsoft.com/fwlink/?LinkId=78278) (英文) 所述程序，來建立及保護檔案共用見證的檔案共用安全。然後設定 MNSFileShare 值、移動叢集群組兩次，再重新嘗試 Microsoft Exchange 安裝程式。


不可委派第一次的角色安裝
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-06

因為登入的使用者沒有必要的帳戶權限，無法安裝拓撲中的第一個伺服器角色 (不論是什麼伺服器角色)，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

雖然 Microsoft Exchange 安裝程式允許使用委派來安裝後續的伺服器角色，但是登入的使用者必須在安裝拓撲中的第一個伺服器角色 (不論 Exchange 2007 什麼伺服器角色) 時具有 Exchange 組織系統管理認證。

安裝第一個伺服器角色 (不論是什麼伺服器角色) 時，Exchange 2007 可能必須在 Exchange 組織容器中建立物件。

若要解決此問題，請授與登入的使用者 Exchange 組織系統管理員權限，或是使用具有那些權限的帳戶登入，然後重新執行 Exchange 2007 安裝程式。


必須停用 Forefront Security for Exchange Server 服務
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-06-20

Microsoft Exchange Server 2007 安裝程式無法繼續進行 Exchange Server 2007 升級，因為 Microsoft Forefront Security for Exchange Server 服務正在本機電腦上執行。

Exchange 安裝程式需要將 Forefront Security for Exchange Server 服務停用，然後 Exchange Server 2007 升級才能繼續進行。

若要解決此問題，請停用 Forefront Security for Exchange Server 服務，再重新執行 Exchange Server 升級。

如需將 Service Pack 或軟體更新安裝到正在執行 Forefront Security 之 Exchange Server 的相關資訊，請參閱 Microsoft 知識庫文章 929080＜如何在執行 Forefront Security 之 Exchange Server 電腦上安裝 Service Pack 或軟體更新＞(英文)。


Forefront Security for Exchange Server 需要升級
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

套用至： Exchange Server 2007, Exchange Server 2007 SP1
主題上次修改日期： 2007-08-08

Microsoft Exchange Server 2007 安裝程式無法繼續進行 Exchange 2007 升級，因為 Exchange Server 2007 Service Pack 1 (SP1) 不支援本機電腦上執行的 Microsoft Forefront Security for Exchange Server 版本。

Exchange 安裝程式需要將 Microsoft Forefront Security for Exchange Server 的版本升級，且必須先停用其服務才能繼續進行 Exchange Server 2007 升級。

若要解決此問題，請將 Microsoft Forefront Security for Exchange Server 10.0 版升級成 Microsoft Forefront Security for Exchange Server SP1，並停用 Microsoft Forefront Security for Exchange Server 服務，然後才繼續進行 Exchange Server 升級。

詳細資訊

如需將 Service Pack 或軟體更新安裝到正在執行 Forefront Security 之 Exchange Server 的相關資訊，請參閱 Microsoft 知識庫文章 929080＜如何在執行 Forefront Security 之 Exchange Server 電腦上安裝 Service Pack 或軟體更新＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=929080) (機器翻譯)。


電腦的完整網域名稱符合收件者原則
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-05-16

因為本機電腦的完整網域名稱 (FQDN) 符合收件者原則的簡易郵件傳送通訊協定 (SMTP) 位址，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Microsoft Exchange 安裝程式需要 Exchange 組織中的伺服器的 FQDN 與相同 Exchange 組織中的收件者原則的任何 SMTP 位址都不符。

如果電腦的 FQDN 符合收件者原則的 SMTP 位址，則郵件會無法透過 SMTP 傳遞，而陷入 MTA 佇列中。

若要解決此問題，請重新命名本機電腦，或者移除或重新命名收件者原則，然後重新執行 Microsoft Exchange 安裝程式。

重新命名本機電腦

  1. 開啟 [控制台] 中的 [系統]。

  2. 在 [電腦名稱] 索引標籤上，按一下 [變更]。

  3. 在 [電腦名稱] 下方，輸入電腦的新名稱，然後按一下 確定]。系統將提示您提供使用者名稱及使用者密碼，以重新命名網域中的電腦。

  4. 按一下 [確定] 以關閉 [系統內容] 對話方塊。系統將提示您重新啟動電腦以套用變更。
重要事項：
如果您想要重新命名的電腦是網域控制站，請參閱＜重新命名網域控制站＞(英文) (http://go.microsoft.com/fwlink/?LinkId=66828)。
修改收件者原則 SMTP 位址

  1. 啟動 Exchange 系統管理員。

  2. 依序按一下 [組織]、[收件者]，再按一下 [收件者原則]。

  3. 按兩下您要變更的原則。

  4. 按一下 [電子郵件地址] 索引標籤，然後變更適當的 SMTP 位址

如需收件者原則命名問題的相關資訊，請參閱 Microsoft 知識庫文章＜XCON：收件者原則不可符合組織中任何伺服器的 FQDN (5.4.8 NDR)＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=288175)。


本機站台中沒有通用類別目錄伺服器存在
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-06

因為站台中沒有您正要嘗試安裝 Microsoft Exchange 的通用類別目錄伺服器，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Microsoft Exchange 安裝程式需要執行安裝程式之電腦的 Active Directory® 目錄服務包含一個充當通用類別目錄的伺服器。

若要解決這個問題，請採取下列其中一個步驟：

  • 使站台中的某個現有網域控制站成為通用類別目錄伺服器。

  • 以通用類別目錄伺服器角色安裝新的伺服器。

使現有的網域控制站成為通用類別目錄伺服器

  1. 開啟 [Active Directory 站台及服務]。

  2. 依序展開 [站台]、站台、[伺服器]。

  3. 選取要指定為通用類別目錄伺服器的網域控制站。

  4. 在右窗格中，在 [NTDS 設定] 上按一下滑鼠右鍵，並選取 [內容]。

  5. 在 [一般] 索引標籤上，選取 [通用類別目錄] 核取方塊。變更會動態發生，不需重新啟動伺服器。
  • 如需如何建立通用類別目錄伺服器的相關資訊，請參閱 Microsoft 知識庫文章 313994＜如何在 Windows 2000 中建立或移除通用類別目錄＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313994)。

  • 如需通用類別目錄伺服器與 Exchange Server 相關的位置及可用性相關資訊，請參閱 Microsoft 知識庫文章 875427＜通用類別目錄伺服器在 Exchange 2000 Server 組織或 Exchange Server 2003 組織中的位置及比率＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=875427)。


需要全域更新
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-09-19

因為登入的使用者沒有所需的帳戶權限，無法對 Active Directory® 目錄服務進行全域更新，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Microsoft Exchange 安裝程式需要在安裝 Exchange 2007 時登入的使用者，具有企業系統管理員的系統管理認證。

在安裝的過程中，Exchange 2007 安裝程式可能必須執行下列作業：

  • 建立或修改 Active Directory 目錄服務中的 Exchange 組織物件。

  • 為 Exchange 2007 準備 Active Directory 樹系中的所有網域。

  • 為 Exchange 2007 準備現有的 Exchange 2000 Server 及 Exchange Server 2003 網域。

若要解決此問題，請授與登入的使用者「企業系統管理員」權限，或是使用具有那些權限的帳戶登入，然後重新執行 Exchange 2007 安裝程式。

若需 Exchange 所需之 Active Directory 權限的詳細資訊，請參閱《在 Exchange Server 中使用 Active Directory 權限》(英文) (http://go.microsoft.com/fwlink/?LinkId=47592)。


DNS 資料庫中找不到本機電腦的主機記錄
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-05

因為在網域名稱系統 (DNS) 資料庫中找不到此電腦的主機 (A) 記錄，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要本機電腦具有一個已向網域的授權 DNS 資料庫註冊的有效主機 (A) 記錄。

Microsoft Exchange 依賴 DNS 主機 (A) 記錄來取得下一個內部或外部目的伺服器的 IP 位址。

若要解決此問題：

  • 驗證本機 TCP/IP 組態指向正確的 DNS 伺服器。

    驗證本機 TCP/IP 組態

    1. 檢閱本機 TCP/IP 組態。如需相關資訊，請參閱＜將 TCP/IP 設定為使用 DNS＞(英文) (http://go.microsoft.com/fwlink/?LinkId=68094)。
  • 使用 Nslookup.exe 驗證 DNS 伺服器上有主機 (A) 記錄存在。如需相關資訊，請參閱＜驗證 DNS 中有 A 資源記錄存在＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63001)。

如需 DNS 名稱解析、疑難排解及主機 (A) 記錄的相關資訊，請參閱：

  • Microsoft 知識庫文章 322856＜如何設定 Exchange Server 所需的 DNS＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)。

  • ＜DNS 的疑難排解＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63003)。

  • ＜管理資源記錄＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63004)。


本機站台未偵測到 Hub Transport role
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-06

因為本機的 Active Directory® 目錄服務站台中偵測不到現有的 Hub Transport Server role，所以 Microsoft® Exchange Server 2007 安裝程式顯示此警告。

於 Active Directory 站台中安裝 Hub Transport role 執行個體之前，您已選擇安裝 Mailbox Server role。

Exchange 2007 Hub Transport 服務會部署在您組織的 Active Directory 之中。Hub Transport 服務會處理組織中所有郵件流程、套用組織郵件流程的路由規則，並負責傳遞郵件到收件者信箱。

使用者可登入他們的信箱，但在安裝 Hub Transport role 之前，無法從此信箱伺服器傳送或接收郵件。


Hub Transport Server Not Present in Active Directory Site
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-07-25

Microsoft Exchange Analyzer 工具會查詢 Active Directory 目錄服務，以取得 Exchange 組織中含有 Exchange Server 2007 特有系統管理群組識別碼 FYDIBOHF23SPDLT 的任何 msExchAdminGroupContainer 類別物件的值。

如果 Exchange Analyzer 判定 Exchange 組織中有 Exchange Server 2007 系統管理群組，便會查詢組織中所有的 Active Directory 站台，取得每個 msExchExchangeServer 物件的 msExchCurrentServerRoles 屬性值，以判定找到的任何站台中是否有安裝 Mailbox server role。

最後，如果 Exchange Analyzer 判定站台中安裝了 Mailbox server role，便會查詢該站台中每個 msExchExchangeServer 物件的 msExchCurrentServerRoles 屬性，以判定該同一站台中是否也安裝了 Hub Transport server role。

如果 Exchange Analyzer 判定 Active Directory 站台中安裝了 Mailbox server role，但未安裝 Hub Transport server role，便會顯示錯誤。

此錯誤指出，雖然 Active Directory 站台中安裝了 Mailbox server role，但除非在站台中至少安裝一個 Hub Transport server role，否則郵件將不會在信箱之間傳送，即使這些信箱位於同一台伺服器上也是一樣。

Hub Transport server role 是部署在您組織的 Active Directory 目錄服務內。它會處理組織內的所有郵件流程、套用組織郵件原則，以及負責傳遞郵件到收件者的信箱。Hub Transport Server 提供下列功能：

郵件流程 Hub Transport server role 會先處理 Exchange 2007 組織內傳送的所有郵件，才將這些郵件傳遞至組織內的收件者收件匣，或路由傳送至組織外的使用者。此行為沒有例外。

分類 分類程式會對所有透過 Exchange 2007 傳輸管線移動的郵件執行收件者解析、路由傳送解析，以及內容轉換。

路由傳送 Hub Transport server role 會判定組織中傳送及接收之所有郵件的路由傳送路徑。

傳遞 郵件會由儲存區驅動程式傳遞至收件者的信箱。您組織中使用者所傳送的郵件會由儲存區驅動程式從寄件者的寄件匣中收取，再放入 Hub Transport Server 上的提交佇列。

若要更正此錯誤，請在已安裝 Mailbox server role 的站台中安裝 Hub Transport server role。

詳細資訊

如需在站台中部署 Hub Transport server role 的相關資訊，請參閱 Exchange Server 2007 產品文件中的＜部署伺服器角色＞(英文) (http://go.microsoft.com/fwlink/?LinkId=83282)。


未安裝 IIS 6 相容性元件
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-08-13

因為尚未安裝 Internet Information Server (IIS) 6 Metabase 相容性元件及 IIS 6 管理主控台元件，所以 Microsoft Exchange Server 2007 安裝程式無法在 Windows Server 2008 目的電腦上，繼續安裝 Client Access server role、Mailbox server role 或 Exchange 2007 系統管理工具。

Exchange 2007 安裝程式會要求，要安裝 Exchange 2007 Client Access server role、Mailbox server role 或 Exchange 2007 系統管理工具的 Windows Server 2008 電腦，必須已經安裝 IIS 6 Metabase 相容性元件及 IIS 6 管理主控台元件。

若要解決此問題，請將 IIS 6 Metabase 相容性元件安裝到目的電腦中，然後重新執行 Microsoft Exchange 安裝程式。

使用 Windows Server 2008 Server Manager 安裝 IIS 6.0 管理相容性元件

  1. 依序按一下 [開始]、[系統管理工具] 及 [Server Manager]。

  2. 在左瀏覽窗格中，展開 [角色]，然後在 [網頁伺服器 (IIS)] 上按一下滑鼠右鍵，再按一下 [新增角色服務]。

  3. 在 [選取角色服務] 窗格上，向下捲動到 [IIS 6 管理相容性]。

  4. 選取 [IIS 6 Metabase 相容性] 及 [IIS 6 管理主控台] 的核取方塊。

  5. 在 [選取角色服務] 窗格中選取 [下一步]，然後按一下 [確認安裝選項] 窗格中的 [安裝]。

  6. 按一下 [關閉]，離開「新增角色服務」精靈。


未安裝 IIS 7 元件
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-08-09

Microsoft Exchange Server 2007 安裝程式無法繼續在 Microsoft Windows Server 2008 系統上安裝 Client Access server role，因為未安裝所需的 Internet Information Server (IIS) 7 元件。

Exchange 2007 安裝程式會要求，要安裝 Client Access server role 的 Windows Server 2008 電腦上必須先安裝下列 IIS 7 元件，才能安裝 Client Access server role。

必要的 IIS 7 元件

動態內容壓縮

靜態內容壓縮

基本驗證

Windows 驗證

若要解決此問題，請將必要的 IIS 7 元件安裝到目的電腦中，然後重新執行 Microsoft Exchange 安裝程式。

使用 Windows Server 2008 Server Manager 安裝 IIS 7 元件

  1. 依序按一下 [開始]、[系統管理工具] 及 [Server Manager]。

  2. 在左瀏覽窗格中，展開 [角色]，然後在 [網頁伺服器 (IIS)] 上按一下滑鼠右鍵，再按一下 [新增角色服務]。

  3. 在 [選取角色服務] 窗格上，向下捲動到 [IIS]。

  4. 選取 [安全性] 底下的 [基本驗證] 及 [Windows 驗證] 核取方塊。

  5. 選取 [效能] 底下的 [靜態壓縮] 及 [動態壓縮] 核取方塊。

  6. 在 [選取角色服務] 窗格中選取 [下一步]，然後按一下 [確認安裝選項] 窗格中的 [安裝]。

  7. 按一下 [關閉]，離開「新增角色服務」精靈。


需有 IIS 命令檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-08-14

因為此伺服器上未安裝 Microsoft 網際網路資訊服務 (IIS) 通用檔案，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Microsoft Exchange 管理命令介面可能需要遠端 IIS Metabase 存取權。Metabase 為大部份 IIS 組態值的存放庫。若要從遠端存取 Metabase 則需在本機電腦上安裝適當的 COM+ DLL。

若要解決此問題，請在此伺服器上安裝 IIS 通用檔案，然後重新執行 Exchange 2007 安裝程式。

若要使用 Windows Server™ 2003 控制台來安裝 IIS 通用檔案

  1. 在 [開始] 功能表上，按一下 [控制台]。

  2. 按兩下 [新增或移除程式]。

  3. 按一下 [新增/移除 Windows 元件]。

  4. 在 [元件] 清單中，按一下 [應用程式伺服器] 核取方塊。

  5. 按一下 [詳細資料]。

  6. 在 [應用程式伺服器子元件] 清單中，按一下 [網際網路資訊服務 (IIS)] 核取方塊。

  7. 按一下 [詳細資料]。

  8. 按一下 [通用檔案] 核取方塊。

  9. 按 [確定] 直到回到 [Windows 元件精靈]。

  10. 按 [下一步] 完成 [Windows 元件精靈]。
若要使用 Windows® XP 控制台來安裝 IIS 通用檔案

  1. 在 [開始] 功能表上，按一下 [控制台]。

  2. 按兩下 [新增或移除程式]。

  3. 按一下 [新增/移除 Windows 元件]。

  4. 在 [元件] 清單中，按一下 [網際網路資訊服務 (IIS)] 核取方塊。

  5. 按一下 [詳細資料]。

  6. 按一下 [通用檔案] 核取方塊。

  7. 按 [確定] 直到回到 [Windows 元件精靈]。

  8. 按 [下一步] 完成 [Windows 元件精靈]。


IIS 是使用 32 位元相容性模式
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-08-11

Microsoft® Exchange Server 2007 安裝程式無法繼續，因為 Microsoft 網際網路資訊服務 (IIS) 正在此 64 位元電腦上以 32 位元模式執行。

Exchange 2007 在 64 位元電腦上執行時，需要 IIS 處於完整 64 位元模式。

若要解決此問題，請將 IIS 切換至 64 位元模式，然後重新執行 Microsoft Exchange 安裝程式。

將 IIS 切換至 64 位元模式

  1. 開啟命令提示字元。

  2. 輸入下列內容：

    cscript c:\inetpub\adminscripts\adsutil.vbs SET /w3svc/AppPools/Enable32BitAppOnWin64 False

  3. 按 Enter 鍵


權限不足以準備 Active Directory
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-21

因為嘗試進行網域準備失敗，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 安裝程式需要 Active Directory 目錄服務先針對 Exchange Server 2007 進行修改，Active Directory 中的網域才可以進行準備。

用來執行 setup /PrepareAD 命令的帳戶所擁有的權限不足以執行此命令，即使其似乎是隸屬於企業系統管理員群組。帳戶可能已經過期。

若要解決此問題，請確認登入的使用者帳戶是有效的且隸屬於企業系統管理員群組，或是以具有上述權限的帳戶登入，並重新執行 setup /PrepareAD。

若需如何執行 PrepareAD 程序的相關資訊，請參閱＜如何準備 Active Directory 和網域＞(英文) (http://go.microsoft.com/fwlink/?LinkId=78453)。

若需使用 Microsoft Exchange 所需之 Active Directory 權限的相關資訊，請參閱《在 Exchange Server 中使用 Active Directory 權限》(英文) (http://go.microsoft.com/fwlink/?LinkId=47592)。


權限不足以移除所有的伺服器角色
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-27

因為嘗試解除安裝所有伺服器角色失敗，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式要求在解除安裝所有伺服器角色時，登入的使用者必須是「Exchange 組織系統管理員」群組或「企業系統管理員」群組的成員。

若要解決此問題，請對登入的使用者授與 Exchange 組織系統管理員權限，或是在企業系統管理員群組中註冊這些使用者，或是以具有上述權限的帳戶登入，然後重新執行 Exchange 2007 安裝程式。

若需使用 Microsoft Exchange 所需之 Active Directory 權限的相關資訊，請參閱《在 Exchange Server 中使用 Active Directory 權限》(英文) (http://go.microsoft.com/fwlink/?LinkId=47592)。


權限不足以執行 /PrepareDomain
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-27

因為嘗試執行 /PrepareDomain 處理程序失敗，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。登入的使用者權限不足以執行 /PrepareDomain 處理程序。

Exchange 2007 安裝程式需要登入的使用者在執行 /PrepareDomain 處理程序時，為要準備之網域的 Domain Admins 群組成員之一，也是 Exchange Organization Administrators 群組或 Enterprise Admins 群組的成員之一。

若要解決此問題，請對登入的使用者授與要準備之網域的 Domain Admins 群組權限，並將他們登錄在 Exchange Organization Administrators 或 Enterprise Admins 群組中，或是使用具有那些權限的帳戶進行登入，然後重新執行 Exchange 2007 安裝程式。

若需使用 Microsoft Exchange 所需之 Active Directory 權限的相關資訊，請參閱《在 Exchange Server 中使用 Active Directory 權限》(英文) (http://go.microsoft.com/fwlink/?LinkId=47592)。


無效的網域名稱系統網域名稱
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-04-13

因為本機電腦上設定的網域名稱系統 (DNS) 網域名稱無效，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式要求 DNS 網域名稱只能包含 'A-Z'、'a-z'、'0-9'、'.' 及 '-' 這些字元。

若要解決此問題，請判定本機電腦名稱或實際的 DNS 網域名稱是否包含無效字元。

  • 如果本機電腦名稱含有無效字元，請使用不超出 'A-Z'、'a-z'、'0-9'、'.' 及 '-' 之範圍的有效字元，來重設本機電腦上網域的 DNS 網域名稱，然後重新啟動電腦並重新執行 Exchange 2007 安裝程式。

  • 如果組織的 DNS 網域名稱含有無效字元，請考慮重新命名 DNS 網域或是將 Exchange 2007 安裝到新網域樹狀目錄的可行性。

注意：
變更 DNS 網域名稱會大幅影響整個網路。對 DNS 網域名稱進行任何變更之前，請與網路系統管理員協調。
驗證本機電腦的 DNS 網域名稱

  1. 以滑鼠右鍵按一下 [我的電腦]，然後按一下 [內容]。會出現 [系統內容] 對話方塊。

  2. 按一下 [電腦名稱] 索引標籤。

  3. 按一下 [變更]。會出現 [電腦名稱變更] 對話方塊。

  4. 按一下 [其他]。會出現 [DNS 尾碼和 NetBIOS 電腦名稱] 對話方塊。

  5. 驗證使用的字元不超出 'A-Z'、'a-z'、'0-9'、'.' 及 '-' 的範圍。

  6. 選取 [當網域成員資格變更時，也變更主要 DNS 尾碼] 核取方塊。

  7. 按一下 [確定] 以儲存所有變更，再按 [確定] 以結束 [電腦名稱變更] 對話方塊。

  8. 按一下 [確定] 以關閉 [系統內容] 對話方塊，然後再重新啟動電腦，讓所有變更生效。

如需 DNS 名稱的相關資訊，請參閱 Microsoft 知識庫文章 909264＜Active Directory 中電腦、網域、站台及 OU 的命名慣例＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=909264)。


無效的安裝路徑
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-27

因為嘗試將 Mailbox server 或叢集 Mailbox server role 安裝到共用叢集磁碟機失敗，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 安裝程式要求將 Exchange 伺服器角色安裝在不是共用叢集資源的磁碟機中。

若要解決此問題，請將 Mailbox server role 或叢集信箱伺服器安裝到不是指定為共用叢集磁碟機的路徑。

若需叢集組態的相關資訊，請參閱 Exchange Server 2007 產品文件中的＜高可用性＞(http://go.microsoft.com/fwlink/?linkid=68190)。


無效的 CMS 目標路徑格式
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-27

因為嘗試將叢集 Mailbox server role 安裝到共用叢集磁碟機失敗，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

所提交的 /CMSDataPath: <PathToTheDatabase> 參數是無效的通用命名慣例 (UNC) 格式。Exchange 安裝程式要求所指定的 /CMSDataPath: <PathToTheDatabase> 參數必須使用有效的磁碟機代號指派方式 (例如，/CMSDataPath: s:\<PathToTheDatabase>)，而非 UNC 格式。

若要解決此問題，請針對 /CMSDataPath: <PathToTheDatabase> 參數使用有效的磁碟機代號指派方式。

若需安裝叢集信箱伺服器的相關資訊，請參閱 Exchange Server 2007 產品文件中的＜如何在主動節點上安裝 Mailbox Server Role＞(http://go.microsoft.com/fwlink/?LinkId=86624) (英文)。


安裝的 MOUNTMGR.SYS 版本與 Exchange Server 不相容
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-06

因為 Mountmgr.sys 的安裝版本與 Microsoft Exchange 不相容，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要叢集節點已安裝 Microsoft 知識庫文章 898790 所提及的更新。

叢集節點上目前安裝的 Mountmgr.sys 版本可能會造成磁碟區裝載點失敗。發生此問題的原因是 Mountmgr.sys 驅動程式有問題。這是間歇的計時問題，當磁碟區即將要裝載至裝載點時，便會發生此問題。

若要解決此問題，請安裝 Microsoft 知識庫文章 898790 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790) 所提及的更新，然後重新執行 Exchange 2007 安裝程式。

若需這個問題的詳細資訊，請參閱 Microsoft 知識庫文章 - 898790＜在您安裝 Windows Server 2003 Service Pack 1 之後，伺服器叢集中磁碟上的磁碟區裝載點可能會間歇地變成無法使用＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790)。


安裝的 TCPIP.SYS 版本與 Exchange Server 不相容
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-06

因為 Tcpip.sys 的安裝版本與 Microsoft Exchange 不相容，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要本機電腦已安裝 Microsoft 知識庫文章 898060 所提及的更新。

此電腦目前正在執行 Windows Server™ 2003 Service Pack 1 所提供的 Tcpip.sys 驅動程式。此驅動程式可能會在廣域網路中造成連線問題。

若要解決此問題，請安裝 Microsoft 知識庫文章 898060＜Windows Server x64 Edition 的更新 (KB898060)＞(英文) (http://go.microsoft.com/fwlink/?linkid=59272) 所提及的更新，然後重新執行 Exchange 2007 安裝程式。

如需此警告的相關資訊，請參閱 Microsoft 知識庫文章 898060＜安裝安全性更新 MS05-019 或 Windows Server 2003 Service Pack 1 可能造成用戶端與伺服器之間的網路連線失敗＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=898060)。


偵測到大型 Exchange 組織模型
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-08-10

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定 Exchange Server 組織中的路由群組數目。Exchange Server Analyzer 也會查詢 Active Directory，以判定有多少個 Active Directory 站台的 Exchange 伺服器正在執行 Microsoft Exchange 2000 Server 或 Microsoft Exchange Server 2003。

如果下列條件為真，Exchange Server Analyzer 會將 Exchange 組織分類為大型 Exchange 組織：

  • Exchange 組織中有 5 個以上的路由群組。

  • 已在 5 個以上的 Active Directory 站台上安裝正在執行 Exchange 2000 或 Exchange 2003 的伺服器。

將大型 Exchange 組織轉換至 Exchange 2007

  1. 請造訪 Microsoft Exchange Server 2007 產品的線上文件 (英文) (http://go.microsoft.com/fwlink/?LinkId=69434)。

  2. 檢閱＜規劃大型 Exchange 組織＞主題 (英文) (http://go.microsoft.com/fwlink/?LinkId=70504)。


本機電腦是子網域的網域控制站。
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-12-29

因為本機電腦為子網域的網域控制站，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

除非子網域的網域控制站為通用類別目錄伺服器，否則 Exchange 2007 將不會安裝在該網域控制站上。

若要解決此問題，請將網域控制站升級到通用類別目錄伺服器，或將 Exchange 2007 安裝在子網域中非網域控制站的成員伺服器，然後重新執行 Microsoft Exchange 安裝程式。

若要將 Exchange 伺服器設為通用類別目錄伺服器以更正此警告

  1. 在網域控制站上，按一下 [開始]，然後指向 [程式集]，再按一下 [系統管理工具]，然後按一下 [Active Directory 站台及服務]。

  2. 在主控台樹狀目錄中，按兩下 [站台]，再按兩下站台名稱，然後按兩下 [伺服器]。

  3. 按兩下目標網域控制站。

  4. 在結果窗格中的 [NTDS 設定] 上按一下滑鼠右鍵，然後按一下 [內容]。

  5. 在 [一般] 索引標籤上，按一下以選取 [通用類別目錄] 核取方塊。

  6. 重新啟動網域控制站。


本機電腦已經在執行 Exchange Server
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-01-15

因為本機電腦已經安裝舊版的 Microsoft Exchange 元件，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要本機電腦尚未安裝 Microsoft Exchange 元件。

若要解決此問題，請移除任何 Microsoft Exchange 2000 Server 或 Microsoft Exchange Server 2003 元件，然後重新執行 Microsoft Exchange 安裝程式。

移除 Microsoft Exchange 元件

  1. 按一下 [開始]，然後指向 [設定]，再按 [控制台]。

  2. 按兩下 [新增或移除程式]。

  3. 在 [目前安裝的程式] 清單中，按一下 [Microsoft Exchange]，再按 [新增/移除]。

  4. 在 [Microsoft Exchange 安裝精靈] 中，按 [下一步]。

  5. 在 [元件選取項目] 頁面的 [動作] 清單中，按一下已安裝的每一個元件旁邊的向下箭頭，再按 [移除]。

    附註：
    已安裝的元件在 [動作] 清單中會有一個核取記號。當您按一下 [移除] 時，核取記號會變成 [移除] 一詞。

  6. 按兩次 [下一步]。

  7. 按一下 [完成]。


本機電腦不是執行 Windows Server 2003 Service Pack 1 或更新版本
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-05

因為本機電腦不是執行 Microsoft Windows Server™ 2003 Service Pack 1 (SP1) 或更新版本，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要使用 Microsoft Exchange 的電腦執行 Windows Server 2003 SP1 或更新版本。

若要解決此問題：

  • 從執行 Windows Server 2003 SP1 或更新版本的電腦執行 Exchange 2007 安裝程式。

  • 將您想要用來執行 Exchange 2007 安裝程式的電腦升級至 Windows Server 2003 SP1 或更新版本。

如需如何升級至 Windows Server 2003 的相關資訊，請參閱 Microsoft Knowledge Base 810613＜升級至 Windows Server 2003 或 Windows Small Business Server 2003 的支援路徑＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810613)。

若要取得 Windows Server 2003 的最新 Service Pack，請參閱 Windows Server TechCenter (http://go.microsoft.com/fwlink/?LinkId=45315)。


本機電腦負責擴充群組成員資格
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-06

因為嘗試解除安裝負責擴充群組成員資格的 Hub Transport 失敗，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要先從目前的 Bridgehead 伺服器移除通訊群組清單擴充，然後才能解除安裝 Hub Transport role。

擴充通訊群組清單可以識別通訊群組清單內需要加以識別的個別收件者，或識別其他需要擴充的通訊群組清單。擴充的通訊群組清單可以傳回任何必要傳遞狀態通知 (DSN) 的路徑。DSN 會將特定電子郵件的狀態通知 Microsoft Exchange 系統管理員或電子郵件寄件者。此外，通訊群組清單擴充也會識別郵件答錄機郵件或自動產生的回覆是否應該傳送給原始郵件的寄件者。

若要解決此問題，請將通訊群組擴充作業移至另一個伺服器，然後重新執行 Microsoft Exchange 安裝程式。

變更通訊群組或動態通訊群組的擴充伺服器

  1. 開啟 [Exchange 管理主控台]。

  2. 在主控台樹狀目錄中，展開 [收件者組態]。

  3. 在主控台樹狀目錄中，按一下 [通訊群組]。

  4. 建立一個篩選器，以檢視所有使用目前的 Bridgehead 伺服器作為擴充伺服器的通訊群組及動態通訊群組。

    1. 在動作窗格中，按一下 [建立篩選器]。

    2. 在內容下拉清單中，按一下 [擴充伺服器]。

    3. 在運算子下拉清單中，按一下 [等於]。

    4. 在數值方塊中，按一下 [瀏覽] 按鈕，以選取目前充當擴充伺服器的 Bridgehead 伺服器。
附註：
以下是選用的步驟。
  1. 按一下 [新增運算式] 以指定其他的篩選篩選準則。只會顯示符合所有篩選準則的郵件。

  2. 按一下 [套用篩選器]。此時會顯示符合篩選準則的結果。

  1. 在結果窗格中，按一下您想要變更擴充伺服器的通訊群組，然後按一下動作窗格中的 [內容]。

  2. 在 [內容] 上，按一下 [進階] 索引標籤。

  3. 在擴充伺服器下拉清單中，從清單選取特定伺服器，或選取 [組織中的任何伺服器]。

  4. 對所有通訊群組或對正在使用 Bridgehead 伺服器作為擴充伺服器的動態通訊群組，重複步驟 5 到 7。


本機電腦負責產生離線通訊錄
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-06

因為嘗試解除安裝 Mailbox role (負責產生離線通訊錄) 失敗，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

除非 Mailbox role 是 Exchange 組織中的最後一個角色，否則 Exchange 2007 安裝程式需要先從目前的 Mailbox Server 移除離線通訊錄產生作業，然後才能解除安裝 Mailbox role。

若要解決此問題，請將離線通訊錄產生作業移至另一個伺服器，然後重新執行 Microsoft Exchange 安裝程式。

使用 Exchange 系統管理員來移動離線通訊錄產生作業

  1. 開啟 [Exchange 系統管理員]。

  2. 在 [收件者] 之下，按一下 [離線通訊清單]。

  3. 在右窗格中，以滑鼠右鍵按一下 [預設離線通訊清單]，再按一下 [內容]。

    附註：
    請針對產生此訊息的任何其他離線通訊清單使用相同的程序。

  4. 在 [一般] 索引標籤的 [離線通訊清單伺服器] 下，按一下 [瀏覽]，然後按一下要使用的 Exchange 伺服器。
使用 Exchange 管理主控台來移動離線通訊錄產生作業

  1. 開啟 [Exchange 管理主控台]。

  2. 依序展開 [Microsoft Exchange]、[組織組態]，然後選取 [信箱]。

  3. 在結果窗格中，按一下 [離線通訊錄] 索引標籤。

  4. 在 [離線通訊錄] 索引標籤上，選取您要移動的離線通訊錄。在動作窗格中，按一下 [移動]。

  5. 在 [移動離線通訊錄精靈] 出現之後，請使用 [瀏覽] 按鈕並按一下 [移動]，來選取要主控離線通訊錄產生作業的新伺服器。

  6. 若要關閉精靈，請按一下 [完成]。
使用 Exchange 管理命令介面來移動離線通訊錄產生作業

  • 執行下列命令：

    複製程式碼
    Move-OfflineAddressBook -Identity <OfflineAddressBookIdParameter> -Server <ServerIdParameter> [-DomainController <String>]


本機電腦正在執行 Edge Transport role
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-06

因為嘗試安裝 Exchange 2007 角色時發現此伺服器上已安裝 Gateway Server role，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式無法在已安裝 Microsoft Exchange Gateway Server role 的伺服器上安裝其他伺服器角色。

Microsoft Exchange Gateway Server role 會部署在您組織的周邊網路中，處理所有網際網路對向的郵件流程，而且除了提供防範垃圾郵件的保護外，還會為在信任的 Microsoft Exchange 組織之間傳送的郵件提供加密及解密。

若要解決此問題，請將其他 Microsoft Exchange 2007 角色安裝至未安裝 Gateway Server role 的電腦。


本機電腦正在執行 Windows Server 2003 Web Edition
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-06

因為本機電腦正在執行 Microsoft Windows Server ™ 2003 Web Edition，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要將 Microsoft Exchange 安裝至支援的作業系統電腦上。

若要解決此問題，請安裝 Microsoft Exchange 至非 Web Edition 的 Windows Server 2003 Service Pack 1 (SP1) 或更新版本。


本機網域需要進行更新
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-27

因為登入的使用者沒有進行網域準備的必要帳戶權限，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式要求在執行 Setup /PrepareDomain 時，登入的使用者必須是「網域系統管理員」及「Exchange 組織系統管理員」(或「企業系統管理員」) 群組的成員。

若要解決此問題，請對登入的使用者授與網域系統管理員及 Exchange 組織系統管理員權限、在企業系統管理員群組中註冊這些使用者，或是以具有上述權限的帳戶登入，然後重新執行 Exchange 2007 安裝程式。

若需使用 Microsoft Exchange 所需之 Active Directory 權限的相關資訊，請參閱《在 Exchange Server 中使用 Active Directory 權限》(英文) (http://go.microsoft.com/fwlink/?LinkId=47592)。


無法存取本機 Metabase
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-06

Microsoft® Exchange Server 2007 安裝程式無法讀取本機 Metabase 中的資料，因此無法繼續。

Exchange 2007 安裝程式需要安裝的 Mailbox Server role 或 Client Access role 能夠讀取 Microsoft Internet Information Services (IIS) Metabase。

IIS Metabase 包含影響 Microsoft Exchange 的資訊，例如 HTTP 通訊協定設定、信箱與行動裝置存取的虛擬目錄，以及 HTTP 安全性設定。

若要解決此問題，請驗證是否已正確安裝 IIS，然後重新執行 Microsoft Exchange 安裝程式。

若要驗證是否已正確安裝 IIS，請參閱下列資源：

  • Microsoft 知識庫文章 843093＜如何在安裝 Windows 2000 Server 並執行 Exchange 2000 Server 或 Exchange Server 2003 的電腦上，進行 IIS Metabase 損毀疑難排解＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=843093)。

  • Microsoft 知識庫文章 240225＜用以修改 Metabase 的 Adsutil 及 MetaEdit 公用程式描述＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240225)。

  • Microsoft 知識庫文章 317678＜HOW TO：在 Exchange 2000 Server 上重新啟動 Internet Information Services (IIS)＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317678)。

如果這些資源中的指導無法解決問題，您可能需要解除安裝再重新安裝 IIS。

使用控制台中的 [新增或移除 Windows 元件] 來解除安裝 IIS

  1. 在 [開始] 功能表上，按一下 [控制台]。

  2. 按兩下 [新增或移除程式]。

  3. 按一下 [新增/移除 Windows 元件]。

  4. 在 [元件] 清單中，按一下 [應用程式伺服器] 核取方塊。

  5. 按一下 [詳細資料]。

  6. 按一下 [網際網路資訊服務管理員]。

  7. 按 [下一步]。

  8. 解除安裝 IIS 後，按一下 [完成]。
使用控制台安裝 IIS

  1. 在 [開始] 功能表上，按一下 [控制台]。

  2. 按兩下 [新增或移除程式]。

  3. 按一下 [新增/移除 Windows 元件]。

  4. 在 [元件] 清單中，按一下 [應用程式伺服器] 核取方塊。

  5. 按一下 [詳細資料]。

  6. 按一下 [網際網路資訊服務管理員] 核取方塊。

  7. 按 [確定] 直到回到 [Windows 元件精靈]。

  8. 按 [下一步] 完成 [Windows 元件精靈]。


登入的使用者不是本機 Administrators 群組的成員
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-06

因為登入的使用者不是本機電腦的 Administrators 群組的成員，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要登入以安裝 Microsoft Exchange 的使用者對本機電腦具有完整存取權。

若要解決此問題，請使用具有本機系統管理員存取權的帳戶來登入電腦，然後重新執行 Microsoft Exchange 安裝程式。


登入的使用者不是本機 Schema Admins 群組的成員
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-09-06

因為架構更新處理程序沒有 Active Directory® 目錄服務架構系統管理及企業系統管理認證，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要登入以安裝 Microsoft Exchange 的使用者具有 Active Directory 樹系的架構系統管理及企業系統管理認證。

在安裝的過程中，Microsoft Exchange 安裝程式會擴充 Active Directory 架構，以新增 Exchange 2007 特有的類別及屬性。

如果登入的使用者沒有架構系統管理員及企業系統管理權限，架構更新處理程序便會失敗。

若要解決此問題，請將登入的使用者新增至 Schema Admins 及 Enterprise Admins 群組，然後登出並重新登入，或使用已具有 Active Directory 樹系的架構系統管理及企業認證的帳戶來登出並登入。


主動節點太多
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-23

因為嘗試建立新的主動叢集 Mailbox server role 失敗，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange Server 2007 要求叢集內至少要有一個被動節點以支援失敗復原。

若要解決此問題，請先在環境中安裝另一個被動叢集 Mailbox server role，然後重新執行安裝程式。

若需安裝主動與被動節點的相關資訊，請參閱 Exchange Server 2007 產品文件中的＜高可用性＞(英文) (http://go.microsoft.com/fwlink/?LinkId=68190)。


遺失信箱資料庫磁碟機規格
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-05-15

因為 Microsoft® Exchange Server 2007 嚴重損壞修復安裝程式無法存取此伺服器上次安裝所使用的信箱資料庫磁碟機規格，所以嚴重損壞修復安裝程式無法繼續。

在還原期間，Microsoft Exchange 嚴重損壞修復安裝程式需要能夠使用先前針對此伺服器所使用的相同信箱資料庫磁碟機規格。

若要解決這個情況，請將磁碟機設定為符合原始的邏輯磁碟機組態，然後重新執行 Microsoft Exchange 嚴重損壞修復安裝程式。

指派或變更磁碟機代號

  1. 開啟 [電腦管理 (本機)]。

  2. 在主控台樹狀目錄中，請依序按一下 [電腦管理 (本機)]、[存放] 及 [磁碟管理]。

  3. 在分割區、邏輯磁碟機或磁碟區上按一下滑鼠右鍵，再按 [變更磁碟機代號及路徑]。

  4. 使用下列其中一個程序：

    • 若要指派磁碟機代號，請依序按一下 [新增] 及您要使用的磁碟機代號，再按 [確定]。

    • 若要修改磁碟機代號，請按一下它，再依序按一下 [變更] 及您要使用的磁碟機代號，然後按 [確定]。

如需如何指派磁碟機代號的相關資訊，請參閱＜指派、變更或移除磁碟機代號＞(英文) (http://go.microsoft.com/fwlink/?linkid=66764)。


郵件目前存在於一個以上的佇列
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-05

因為嘗試解除安裝傳輸角色會造成傳輸佇列中的資料遺失，所以 Microsoft® Exchange Server 2007 安裝程式顯示此警告。

Exchange 2007 安裝程式會先檢查以確定傳輸佇列是空的，再移除與管理這些佇列相關的角色。

如果移除傳輸角色時，傳輸佇列中尚有要傳遞的郵件，則這些郵件可能會永遠留在該處。

若要解決此問題，請檢查參考的佇列，確定這些佇列均沒有郵件，再繼續執行安裝程式。

檢視佇列內容

  1. 開啟 [Exchange 管理主控台]。

  2. 在主控台樹狀目錄中，按一下 [工具箱]。

  3. 在結果窗格中，按一下 [Exchange 佇列檢視器]。

  4. 在動作窗格中，按一下 [開啟工具]。

  5. 在佇列檢視器中，按一下 [佇列] 索引標籤。畫面就會顯示您已連線之伺服器上的所有佇列清單。

  6. 在您要的佇列上按一下滑鼠右鍵，然後選取 [內容] 來檢視佇列內容。
檢視佇列中的郵件

  1. 請依照步驟 1 至 4 操作。

  2. 在佇列檢視器中，按一下 [郵件] 索引標籤。畫面就會顯示您已連線之伺服器上的所有郵件清單。若要調整為單一佇列檢視，按一下 [佇列] 索引標籤，然後按兩下佇列名稱，再按一下所顯示的 [伺服器\佇列] 索引標籤。

  3. 若要檢視郵件的詳細資訊，請選取郵件，然後按一下動作窗格中的 [內容]。


需要 Microsoft .NET Framework 更新
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-02-26

因為本機電腦需要軟體更新，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要在本機電腦上安裝以下所提及的適當 Microsoft .NET Framework 更新。

若要解決此問題，請結束 Exchange 2007 安裝程式、下載並安裝下列 URL 的適當 (32 位元或 64 位元) 更新，然後重新執行 Exchange 2007 安裝程式。

附註：
按一下此處的連結將提示您直接下載檔案。
  • 64 位元下載，http://go.microsoft.com/fwlink/?linkid=74465

  • 32 位元下載，http://go.microsoft.com/fwlink/?linkid=74469


需有 Microsoft Core XML Services (MSXML) 6.0
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-08-21

因為此伺服器上未安裝 Microsoft Core XML Services (MSXML) 6.0，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

安裝所有 Unified Messaging server role 期間，Exchange 2007 安裝程式均需要在電腦上安裝 MSXML 6.0，才能支援 Microsoft 語音服務。

若要解決這個問題，請從 http://go.microsoft.com/fwlink/?LinkId=70796 MSXML 6.0 軟體，然後重新執行 Exchange 2007 安裝程式。


MNSFileShare 路徑無效
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-27

因為 MNSFileShare 路徑無效，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

MNSFileShare 值必須設為字串值，並包含檔案共用 (位於叢集之外) 的通用命名慣例 (UNC) 路徑，例如 \\server\sharename。

若要解決此問題，請提供有效的 UNC 路徑來作為 MNSFileShare 內容的值。

若需如何設定 MNSFileShare 內容的相關資訊，請參閱＜如何設定檔案共用見證＞(http://go.microsoft.com/fwlink/?LinkId=78278)(英文)。


需要 MSDAPS.DLL 更新
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-12-05

因為本機電腦需要軟體更新，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要在本機電腦上安裝底下所參照的 MSDAPS.DLL 更新。

若要解決此問題，請下載並安裝底下連結的更新，然後重新執行 Exchange 2007 安裝程式。

  • http://go.microsoft.com/fwlink/?linkid=74467


目前已安裝 Network News Transport 服務
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-01-22

因為電腦上已安裝 Microsoft Windows® Server™ 2003 Network News Transport Protocol (NNTP) 服務，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Microsoft Exchange 安裝程式需要 Exchange 2007 所用的伺服器上未安裝 NNTP 服務。

若要解決此問題，請解除安裝 NNTP 服務並重新執行 Microsoft Exchange 安裝程式。

使用控制台中的新增或移除 Windows 元件來解除安裝 NNTP 服務

  1. 在 [開始] 功能表上，按一下 [控制台]。

  2. 按兩下 [新增或移除程式]。

  3. 按一下 [新增/移除 Windows 元件]。

  4. 在 [元件] 清單中，選取 [應用程式伺服器] 核取方塊，再按一下 [詳細資料]。

  5. 選取 [網際網路資訊服務管理員]，然後按一下 [詳細資料]。

  6. 選取 [NNTP 服務]，然後按一下以清除核取方塊。

  7. 按兩次 [確定] 以回到 [元件] 清單，然後按 [下一步]。

  8. 解除安裝 NNTP 服務後按一下 [完成]。


找不到 Client Access server role
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-02-16

Microsoft Exchange Analyzer 工具會查詢 Active Directory 目錄服務，以取得 Exchange 組織中含有 Exchange Server 2007 特有系統管理群組識別碼 FYDIBOHF23SPDLT 的任何 msExchAdminGroupContainer 類別物件的值。

如果 Exchange Analyzer 判定 Exchange 組織中有 Exchange Server 2007 系統管理群組，便會查詢組織中所有的 Active Directory 站台，取得每個 msExchExchangeServer 物件的 msExchCurrentServerRoles 屬性值，以判定找到的任何站台中是否有安裝 Mailbox server role。

最後，如果 Exchange Analyzer 判定站台中安裝了 Mailbox server role，便會查詢該站台中每個 msExchExchangeServer 物件的 msExchCurrentServerRoles 屬性，以判定該同一站台中是否也安裝了 Client Access server role。

如果 Exchange Analyzer 判定 Active Directory 站台中安裝了 Mailbox server role，但未安裝 Client Access server role，便會顯示警告。

這個警告表示，雖然 Active Directory 站台安裝了 Mailbox server role，但除非在站台中至少安裝一個 Client Access server role，否則 Microsoft Office Outlook Web Access 和 Exchange ActiveSync 行動裝置存取用戶端都將無法存取該信箱伺服器上的郵件。

Client Access server role 會接受來自各種不同用戶端到 Exchange 2007 伺服器的連線。例如 Microsoft Outlook Express 和 Eudora 等軟體用戶端會使用 POP3 或 IMAP4 連線來與 Exchange 伺服器通訊。硬體用戶端 (例如行動裝置) 則使用 ActiveSync、POP3 或 IMAP4 來與 Exchange 伺服器通訊。

如果使用者是使用 Microsoft Outlook 以外的用戶端存取其收件匣，您就必須在 Exchange 組織中安裝 Client Access server role。

若要更正此警告，如果在使用 Microsoft Outlook 的用戶端以外，還有其他用戶端必須存取信箱，請在安裝了 Mailbox server role 的站台上安裝 Client Access server role。

詳細資訊

如需如何在站台中安裝 Client Access server role 的相關資訊，請參閱 Exchange Server 2007 產品文件中的＜部署伺服器角色＞(英文) (http://go.microsoft.com/fwlink/?LinkId=83282)。


找到非標準的位址空間
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-08-21

若 Microsoft® Exchange Server Analyzer 工具判定一或多個收件者原則上有非標準的位址空間，便會顯示此警告。

非標準或 Proxy 位址空間為外部郵件系統中辨識 Exchange Server 收件者物件的位址。

在較舊版本之 Exchange Server，支援非標準位址空間是收件者更新服務的責任。

Microsoft Exchange Server 2007 中不會執行收件者更新服務。產生 Proxy 位址是 Exchange 2007 管理主控台的責任。

管理主控台必須針對每個偵測到的非標準位址空間載入 Proxy-產生器 DLL。

重要事項：
若於 64 位元電腦上執行管理主控台，則需要 64 位元版本的 Proxy-產生器 DLL。

若要更正此警告，請連絡支援外部位址空間的廠商，以取得與 Exchange 2007 相容的 Proxy-產生器 DLL。


不在架構主機站台/網域
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-08-10

Microsoft® Exchange Server 2007 安裝程式無法繼續，因為執行安裝程式的電腦與指派給網域架構主機角色 (也稱為彈性的單一主機作業或 FSMO) 的伺服器不在同一個 Active Directory® 目錄服務站台或網域中。

Exchange 2007 安裝程式需要充當網域架構主機的網域控制站與執行 Exchange 安裝程式的本機電腦位於同一站台及網域。

網域架構主機會控制 Active Directory 架構的所有更新及修改。

若要解決此問題，請從網域架構主機所在的站台及網域執行 Exchange Server 2007 安裝程式。

您可以使用架構主機工具來識別角色。不過，必須登錄 Schmmgmt.dll DLL，才能使架構工具作為 MMC 嵌入式管理單元來使用。

檢視目前的架構主機

  1. 在命令提示字元下，輸入 regsvr32 schmmgmt.dll

    附註：
    當顯示下列對話方塊時，表示已順利登錄 RegSvr32：

    已順利完成 schmmgmt.dll 中的 DllRegisterServer。

  2. 若要開啟新的管理主控台，請按一下 [開始]，再按 [執行]，然後輸入 mmc。

  3. 在 [主控台] 功能表上，按一下 [新增/移除嵌入式管理單元]。

  4. 按一下 [新增]，以開啟 [新增獨立嵌入式管理單元] 對話方塊。

  5. 選取 [Active Directory 架構]，然後按一下 [新增]。

  6. [Active Directory 架構] 會顯示在 [新增/移除嵌入式管理單元] 中。按一下 [關閉]，再按 [確定]，以返回主控台。

  7. 選取 [Active Directory 架構]，讓 [類別] 及 [屬性] 區段顯示在右側。

  8. 在 [Active Directory 架構] 上按一下滑鼠右鍵，然後按一下 [操作主機]。

  9. 隨即顯示目前的架構主機


網域中沒有 Windows Server 2003 SP1 網域控制站
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-27

因為 setup /PrepareLegacyExchangePermissions 處理程序在準備的網域中找不到執行 Microsoft Windows Server 2003 Service Pack 1 (SP1) 或更新版本的網域控制站，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

在您要執行 setup /PrepareLegacyExchangePermissions 的每一個網域中，安裝程式必須連上 Windows Server 2003 SP1 網域控制站。如果找不到至少一個 Windows Server 2003 SP1 網域控制站，將無法順利完成 Setup /PrepareLegacyExchangePermissions。

執行 setup /PrepareLegacyExchangePermissions 命令可使舊版「收件者更新服務」正確運作。在匯入新的 Exchange 2007 架構之前，Exchange 2007 必須在您已執行 Exchange Server 2003 或 Exchange 2000 Server DomainPrep 的每一個網域中授與新權限。setup /PrepareLegacyExchangePermissions 命令能授與這些新權限。

若要解決此問題，請在您要執行 setup /PrepareLegacyExchangePermissions 的每一個網域中，至少將一個網域控制站升級至 Windows Server 2003 SP1 或更新版本，然後重新執行安裝程式。

若需如何準備舊版 Exchange 權限的相關資訊，請參閱 Exchange Server 2007 產品文件中的＜準備舊版 Exchange 權限＞(英文) (http://go.microsoft.com/fwlink/?LinkId=81776)。


OAB 伺服器已被刪除
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-21

因為嘗試安裝 Client Access server role 失敗，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。指定來主控離線通訊錄 (OAB) 的 Exchange Mailbox server 已遭到刪除。

Exchange 2007 安裝程式需要有效的 Exchange Mailbox server 來主控 OAB 的產生，使 Client Access server role 安裝得以繼續。

若要解決此問題，請指定有效的 Exchange Mailbox server 作為 OAB 產生作業主機，然後重新執行 Exchange 2007 安裝程式。

若需如何指定 Exchange server 作為離線通訊錄產生作業之主機的相關資訊，請參閱 Exchange 2007 產品文件中的＜如何建立離線通訊錄＞(英文) (http://go.microsoft.com/fwlink/?LinkId=86314)。


存在較舊的資料庫檔案
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-06

因為偵測到目標安裝路徑中已有 Microsoft Exchange 資料庫檔案，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要 Microsoft Exchange 資料庫檔案的目標安裝路徑是空的。

若要解決此問題，請從目標安裝路徑移除所有的現有檔案，然後重新執行安裝程式。

從目標安裝路徑刪除現有的 Exchange Server 資料庫檔案

  1. 在 [我的電腦] 或 [Windows 檔案總管] 中，找出目標安裝路徑。

    附註：
    依預設，資料庫檔案位於：

    <系統磁碟機>:\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group。

  2. 在要移除的檔案上按一下滑鼠右鍵，然後選取 [刪除]。

  3. 在 [確認檔案移除] 對話方塊中，按一下 [是]。

  4. 對目標安裝路徑中的所有檔案重複步驟 2 及 3。


偵測到較舊版的 ADAM
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-06

因為嘗試安裝 Gateway Server role 時，偵測到目前的伺服器上有較舊版本的 Active Directory® 應用程式模式 (ADAM)，所以 Microsoft® Exchange Server 2007 安裝程式顯示此警告。

ADAM 是一項輕量型目錄存取通訊協定 (LDAP) 目錄服務，它是特別設計來與擁有目錄功能的應用程式搭配使用。ADAM 只會儲存和複製應用程式特有的資訊，並不需要在網域控制站上部署，也不依存於 Active Directory 服務。ADAM 不提供網路作業系統驗證或授權。

在 Exchange 2007 中，閘道伺服器會使用 ADAM 來儲存組態資訊。將 ADAM 與 Active Directory 同步後，ADAM 也可執行收件者查閱作業以提供郵件安全性。

Exchange 2007 安裝程式會自動將安裝的 ADAM 升級為 Service Pack 1 (SP1) 版本。

除非您不想升級 ADAM，否則不需要採取任何動作。如果您不想升級 ADAM，就不應該在本機電腦上安裝 Gateway Server role。


找到一部以上的 Active Directory 連接器伺服器
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-06

因為在目前的 Microsoft Exchange 環境中找到一或多個 Active Directory 連接器 (ADC)，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

ADC 會在混合模式的 Microsoft Exchange 環境中，將 Exchange Server 版本 5.5 中的物件複寫至 Active Directory® 目錄服務，但 Exchange 2007 並不支援這種作法。

Exchange 2007 安裝程式需要移除所有 ADC 元件。

若要解決此問題，請移除所有 ADC 元件，然後重新執行 Exchange 2007 安裝程式。

移除 Active Directory 連接器元件

  1. 若要在執行 ADC 服務的伺服器上停用 ADC 服務，請在桌面上的 [我的電腦] 按一下滑鼠右鍵，然後按一下 [管理]。

  2. 展開 [服務及應用程式] 節點，再按一下 [服務] 節點。

  3. 在右窗格中的 [Microsoft Active Directory Connector] 上按一下滑鼠右鍵，然後按一下 [內容]。

  4. 將 [啟動類型] 變更為 [已停用]。則下次啟動電腦時，便不會啟動 ADC 服務。

  5. 按一下 [套用]，然後按一下 [確定]。

  6. 若要解除安裝 ADC 服務，請使用 Microsoft Exchange 2000 Server 或 Microsoft Exchange Server 2003 CD 上的「Active Directory 安裝精靈」。開啟 \ADC\I386 資料夾並按兩下 Setup.exe 程式。接著依照提示將 ADC 服務元件「全部移除」。

    重要事項：
    您必須完成步驟 6 並將 ADC 元件「全部移除」才能解決此問題。停用 ADC 服務並不足夠。

如需 ADC 的相關資訊，請參閱下列 Microsoft 知識庫文章：

  • 325300＜支援 WebCast：Active Directory 連接器簡介＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325300)。

  • 325221＜支援 WebCast：Microsoft 進階 Active Directory 連接器＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325221)。

  • 312632＜如何在 Exchange 2000 Server 中安裝並設定 Active Directory 連接器＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=312632)。


只允許一台 CCR 伺服器
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-27

因為嘗試建立新叢集信箱伺服器的動作失敗，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange Server 2007 要求叢集連續複寫 (CCR) 叢集中，只能有一個叢集連續複寫叢集信箱伺服器。這個 CCR 叢集已有叢集信箱伺服器。

若要解決此問題，請不要嘗試在這個叢集內安裝額外的叢集連續複寫叢集信箱伺服器。

若需有關在 CCR 環境中安裝叢集信箱伺服器的詳細資訊，請參閱 Exchange Server 2007 產品文件中的＜如何在主動節點上安裝 Mailbox Server Role＞(http://go.microsoft.com/fwlink/?LinkId=86624) (英文)。


叢集伺服器上只能安裝 Mailbox role
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-07

因為嘗試在叢集伺服器上安裝 Mailbox Server role 以外的角色失敗，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

在已安裝叢集服務的伺服器上，Microsoft Exchange 不支援 Mailbox Server role 以外的 Exchange 2007 角色。

若要更正此問題，請參閱《Exchange Server 2007 操作手冊》中的＜Exchange 2007 的高可用性＞(英文) (http://go.microsoft.com/fwlink/?LinkId=68190)。


組織處於混合模式
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-05-15

因為現有的 Microsoft Exchange 組織不是原生模式，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要現有的 Exchange 組織為原生模式。

若要解決此問題，請在升級現有組織中的最後一個 Exchange Server 5.5 版之後，或在解除委任最後一個 Exchange 5.5 伺服器之前，遵循這些步驟。然後重新執行 Exchange 2007 安裝程式。

附註：
切換至原生模式之後，將無法切回混合模式。
切換至原生模式

  1. 啟動 [Exchange 系統管理員]：按一下 [開始]，依序指向 [所有程式] 及 [Microsoft Exchange]，然後按一下 [系統管理員]。

  2. 在主控台樹狀目錄中，在要切換到原生模式的組織上按一下滑鼠右鍵，再按一下 [內容]。

  3. 在 [<組織名稱> 內容] 中，按一下 [變更作業模式] 下的 [變更模式]。

  4. 在警告對話方塊中，如果確定想要永久切換至原生模式，請按一下 [是]。按一下 [套用] 以接受新的 Exchange 模式。

您必須在組織中的所有 Exchange 伺服器上重新啟動 Microsoft Exchange Information Store 服務，才能利用 Exchange 原生模式。您不必同時重新啟動所有 Microsoft Exchange Information Store 服務，但是必須重新啟動每個伺服器上的服務，這樣伺服器才能利用所有 Exchange 原生模式功能。在原生模式的變更複寫至本機 Microsoft Windows® 網域控制站之後，請重新啟動伺服器上的服務。

重新啟動 Microsoft Exchange Information Store 服務

  1. 按一下 [開始]、[執行]，輸入 services.msc，再按一下 [確定]。

  2. 在 [服務 (本機)] 窗格中，尋找 [Microsoft Exchange Information Store] 服務。

  3. 在服務上按一下滑鼠右鍵，再按一下 [重新啟動]。

如需如何從混合模式轉換為原生模式的相關資訊，請參閱 Microsoft 知識庫文章 32779＜如何在 Exchange 中從混合模式轉換為原生模式＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779)。


無法連接主要 DNS 伺服器
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-05

因為無法建立與主要網域名稱系統 (DNS) 伺服器的連線，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要本機電腦與網域的授權 DNS 資料庫通訊。

Microsoft Exchange 依賴 DNS 來解析下一個內部或外部目的伺服器的 IP 位址。

與主要 DNS 伺服器的通訊失敗，可能的原因如下：

  • 本機 TCP/IP 組態未指向正確的 DNS 伺服器。

  • DNS 伺服器由於網路錯誤或其他原因而關閉或無法存取。

若要解決此問題：

  • 驗證本機 TCP/IP 組態指向正確的 DNS 伺服器。

驗證本機 TCP/IP 組態

  1. 檢閱本機 TCP/IP 組態：

    如需相關資訊，請參閱＜將 TCP/IP 設定為使用 DNS＞(英文) (http://go.microsoft.com/fwlink/?LinkId=68094)。
  • 驗證 DNS 伺服器是否正在執行中且可以連接。

驗證 DNS 伺服器是否正在執行中且可以連接

  1. 執行下列一或多項檢查，驗證 DNS 伺服器正在執行中：

    • 在 DNS 伺服器上從 DNS 系統管理程式查看 DNS 伺服器狀態。

    • 重新啟動 DNS 伺服器。

      如需相關資訊，請參閱＜啟動、停止、暫停或重新啟動 DNS 伺服器＞(英文) (http://go.microsoft.com/fwlink/?LinkId=62999)。

    • 使用 nslookup 命令來驗證 DNS 伺服器回應。

      如需相關資訊，請參閱＜使用 nslookup 命令來驗證 DNS 伺服器回應＞(英文) (http://go.microsoft.com/fwlink/?LinkId=63000)。


遺失公用資料夾資料庫磁碟機規格
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-05-15

Microsoft® Exchange Server 2007 嚴重損壞修復安裝程式無法存取此伺服器上次安裝所使用的公用資料夾資料庫磁碟機規格，因此無法繼續。

在還原期間，Microsoft Exchange嚴重損壞修復安裝程式需要能夠使用先前針對此伺服器所使用的相同公用資料夾資料庫磁碟機規格。

若要解決這個情況，請將磁碟機設定為符合原始的邏輯磁碟機組態，然後重新執行 Microsoft Exchange 嚴重損壞修復安裝程式。

指派或變更磁碟機代號

  1. 開啟 [電腦管理 (本機)]。

  2. 在主控台樹狀目錄中，請依序按一下 [電腦管理 (本機)]、[存放] 及 [磁碟管理]。

  3. 在分割區、邏輯磁碟機或磁碟區上按一下滑鼠右鍵，再按 [變更磁碟機代號及路徑]。

  4. 使用下列其中一個程序：

    • 若要指派磁碟機代號，請依序按一下 [新增] 及您要使用的磁碟機代號，再按 [確定]。

    • 若要修改磁碟機代號，請按一下它，再依序按一下 [變更] 及您要使用的磁碟機代號，然後按 [確定]。

如需如何指派磁碟機代號的相關資訊，請參閱＜指派、變更或移除磁碟機代號＞(英文) (http://go.microsoft.com/fwlink/?linkid=66764)。


無法遠端存取叢集節點上的登錄
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-04-13

因為無法存取叢集節點上的登錄，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要存取叢集中所有節點的登錄，才能擷取各種設定。

若要解決此問題，請執行下列動作：

  • 確認遠端登錄服務在叢集的所有節點上執行。

  • 確認繫結順序中所列的第一張網路介面卡上，已啟用 File and Printer Sharing for Microsoft Networks。

  • 確認下列登錄機碼的值在叢集的每一個節點上都相同，且對相關群組原則有效：

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Lanmanworkstation\parameters\RequireSecuritySignature

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Rdr\Parameters\EnableSecuritySignature

若需登錄連線問題疑難排解的相關資訊，請參閱＜Microsoft Exchange Server Best Practices Analyzer 工具疑難排解連線問題＞(http://go.microsoft.com/fwlink/?LinkId=56285) 中的＜登錄連線問題疑難排解＞一節 (英文)。


先移除 Edge 訂閱，再解除安裝伺服器角色
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-21

因為解除安裝 Edge 或 Hub Transport server role 處理程序失敗 (因為伺服器角色有 Edge 訂閱)，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

您向 Active Directory 站台訂閱 Edge Transport server，使 Edge Transport server 與 Exchange 組織產生關聯。訂閱的 Edge Transport server 具有 Active Directory 站台屬性的戳記。此外，此關聯可讓您設定 Edge 訂閱，將其作為在 Exchange 組織中所建立傳送連接器的來源伺服器。Exchange 組織中的 Hub Transport server 使用隱含的組織內部傳送連接器，透過已訂閱的 Edge Transport server，將電子郵件傳送至網際網路。Active Directory 站台關聯性可讓 Hub Transport server 尋找 Edge Transport server，以進行傳送。

Exchange 2007 安裝程式需要目標 Edge Transport server role 的所有 Edge 訂閱、或站台中的最後一個 Hub Transport server role 先行移除，然後才能進行 Edge 或 Hub Transport server role 的解除安裝。

若要解決此錯誤，請使用 Get-EdgeSubscription 指令程式來擷取 Edge 訂閱的相關資訊，以及 Remove-EdgeSubscription 指令程式來移除目標伺服器中的 Edge 訂閱，然後再重新執行 Exchange 2007 安裝程式。

識別並移除 Edge 訂閱

  1. 遵循 Get-EdgeSubscription (http://go.microsoft.com/fwlink/?LinkId=86320) 指令程式主題中的指導，來識別目標伺服器的 Edge 訂閱。

  2. 遵循 Remove-EdgeSubscription (http://go.microsoft.com/fwlink/?LinkId=86321) 指令程式主題中的指導，來移除目標伺服器中的 Edge 訂閱。


架構 FSMO 不是 Windows Server 2003 Service Pack (SP1) 或更新版本
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-05

Microsoft® Exchange Server Analyzer 工具會檢查 Active Directory® 目錄服務樹系，以瞭解哪些伺服器作業系統版本正在 Active Directory 網域控制站架構主機上執行。如果 Exchange Server Analyzer 發現 Active Directory 作業網域主控站 (也稱為彈性單一主要作業或 FSMO) 並未執行 Microsoft Windows Server™ 2003 Service Pack 1 (SP1) 或更新版本，Exchange Server Analyzer 便會顯示錯誤。

此錯誤指出需要 Windows Server 2003 SP1 或更新版本，才能安裝 Microsoft Exchange Server 2007。需要 Windows Server 2003 SP1 或更新版本，才能支援新的 Exchange 2007 權限結構。

如果 Active Directory 架構 FSMO 網域控制站不是執行 Windows Server 2003 SP1 或更新版本，則 Exchange 2007 安裝將在安裝期間失敗。

部署 Exchange 2007 之前，此訊息是必要的檢查。如果計劃安裝 Exchange 2007，建議您在整個樹系 Active Directory 網域控制站架構主機中執行 Windows Server 2003 SP1 或更新版本。


架構主機正在執行 Windows 2000 Server
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-01-08

因為指派為 Active Directory® 目錄服務主要架構角色 (也稱為彈性單一主機操作 (FSMO)) 的網域控制站正在執行 Microsoft Windows® 2000 Server，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要充當架構 FSMO 的網域控制站執行 Microsoft Windows Server™ 2003 Service Pack 1 (SP1) 或更新版本。

FSMO 會控制 Active Directory 架構的所有更新及修改。

若要解決此問題，請將 FSMO 網域控制站升級或移動到 Windows Server 2003 SP1 或更新的伺服器版本，然後重新執行 Microsoft Exchange 安裝程式。

如需相關資訊，請參閱 Microsoft 知識庫文章 325379＜如何將 Windows 2000 網域控制站升級至 Windows Server 2003＞(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325379)。

若需有關將基礎結構主機角色從一個網域控制站轉移至另一個網域控制站的資訊，請參閱下列微軟知識庫文件：

  • 若為 Microsoft Windows Server™ 2003，請參閱 324801＜如何在 Windows Server 2003 中檢視及轉移 FSMO 角色＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)

  • 若為 Microsoft Windows 2000 Server，請參閱 255690＜如何在圖形使用者介面檢視傳送 FSMO 角色＞(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690)


架構主機不是執行 Windows Server 2003 Service Pack 1 或更新版本
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-27

因為指派為 Active Directory 目錄服務架構主要角色的網域控制站 (也稱為彈性的單一主要作業 (FSMO)) 並未執行 Microsoft Windows Server 2003 Service Pack 1 (SP1) 或更新版本，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要充當架構 FSMO 的網域控制站執行 Windows Server 2003 SP1 或更新版本。

FSMO 會控制 Active Directory 架構的所有更新及修改。

若要解決此問題，請執行下列一或多個動作：

  • 將 FSMO 網域控制站升級為 Windows Server 2003 SP1 或更新版本，然後重新執行 Microsoft Exchange 安裝程式。

  • 如果 Exchange 組織中有執行 Microsoft Windows Server 2003 Service Pack 1 (SP1) 或更新版本的 FSMO 網域控制站，請執行 Exchange 2007 安裝程式，並使用指向 FSMO 網域控制站的 /domaincontroller 參數：

    [/DomainController 或 /dc <網域控制站的 FQDN>]

    使用 /DomainController 參數來指定在安裝期間用於讀取和寫入 Active Directory 的網域控制站。您可以使用 NetBIOS 或網域全名 (FQDN) 格式。

若要取得 Windows Server 2003 的最新 Service Pack，請參閱 "Windows Server TechCenter" (http://go.microsoft.com/fwlink/?LinkId=45315)。

若需 Exchange Server 2007 安裝程式參數的相關資訊，請參閱 Exchange Server 2007 產品文件中的＜如何以自動模式安裝 Exchange 2007＞(http://go.microsoft.com/fwlink/?LinkId=86476) (英文)。


Setup Cannot Install Exchange to a Read-Only Domain Controller
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-07-23

Microsoft Exchange Server 2007 安裝程式無法繼續安裝，因為目標電腦是唯讀網域控制站 (RODC)。

唯讀網域控制站是 Windows Server 2008 Active Directory 的功能。RODC 是網域控制站安裝選項的一種類型，它可以安裝在實體安全性層級可能較低的遠端站台中。

Exchange 安裝程式需要對目標安裝電腦具有寫入權。

若要解決此問題，請選取未指定為 RODC 的目標安裝電腦，然後重新執行安裝程式。


安裝伺服器角色時發生安裝程式失敗
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-04-12

因為在安裝伺服器角色時發生前一版安裝失敗，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要失敗的伺服器角色安裝程序重新安裝成功，或從安裝處理程序中移除後，才能繼續進行其他的安裝工作。

若要解決此問題，請重新安裝失敗的伺服器角色，或移除伺服器角色。

從命令列重新安裝失敗的伺服器角色

  1. 開啟 [命令提示字元] 視窗，然後瀏覽至安裝檔案。

  2. 執行下列命令：

    複製程式碼
    Setup /roles:<Failed Server Role>

    從逗號分隔清單的一或多個下列角色中進行選取：

    ClientAccess (或 CA、C)

    EdgeTransport (或 ET、E)

    附註：
    Edge Transport server role 無法和任何其他伺服器角色在同一台電腦上並存。
    附註：
    您必須在周邊網路中以及 Active Directory 樹系之外部署 Edge Transport server role。

    HubTransport (或 HT、H)

    Mailbox (或 MB、M)

    UnifiedMessaging (或 UM、U)

    ManagementTools (或 MT、T)

    附註：
    如果您指定 ManagementTools，您可以安裝 Exchange 管理主控台、Exchange 管理命令介面的 Exchange 指令程式、Exchange 說明檔、Exchange Best Practices Analyzer 工具，以及 Exchange Troubleshooting Assistant。如果您安裝任何其他伺服器角色，則會自動安裝管理工具。

    例如，若要將 Hub Transport server role 新增至現有的 Mailbox server，請輸入下列命令：%LocalExchangeInstallationDir%\bin\Setup.com /role:HubTransport /Mode:Install

附註：
如果先前已成功安裝 Exchange Server 2007 server role，安裝精靈會在維護模式下執行。如果先前未成功安裝 Exchange Server 2007 server role，安裝精靈會從它停止之處開始。
在維護模式下使用 Exchange Server 2007 安裝精靈來重新安裝失敗的伺服器角色

  1. 登入您要重新安裝伺服器角色的伺服器。

  2. 開啟 [控制台]，然後按兩下 [新增或移除程式]。

  3. 在 [變更或移除程式] 頁面上，選取 [Microsoft Exchange Server]，然後按一下 [變更]。

  4. 在 Exchange Server 2007 安裝精靈的 [Exchange 維護模式] 頁面上，按 [下一步]。

  5. 在 [伺服器角色選取] 頁面上，選取您要安裝的伺服器角色的核取方塊，然後按 [下一步]。

    附註：
    Edge Transport server role 無法和任何其他伺服器角色在同一台電腦上並存。
    附註：
    您必須在周邊網路中以及 Active Directory 樹系之外部署 Edge Transport server role。
    附註：
    如果您選取管理工具，您可以安裝 Exchange 管理主控台、Exchange 管理命令介面的 Exchange 指令程式，以及 Exchange 說明檔。如果您安裝任何其他伺服器角色，則會自動安裝管理工具。

  6. 如果您已選取 [Hub Transport Role]，而且要在含有現有 Exchange Server 2003 或 Exchange 2000 Server 組織的樹系中安裝 Exchange 2007，請在 [郵件流程設定] 頁面上，選取現有組織中的 Bridgehead 伺服器，該組織為您要建立路由群組連接器的 Exchange 2003 或 Exchange 2000 路由群組的成員之一。

  7. 在 [整備檢查] 頁面上檢視狀態，以判斷該組織和伺服器角色的必要檢查是否順利完成。如果順利完成，按一下 [安裝] 來安裝 Exchange 2007。

  8. 在 [完成] 頁面上，按一下 [完成]。
若先前未順利安裝其他伺服器角色，則使用 Exchange Server 2007 安裝精靈重新安裝失敗的伺服器角色

  1. 遵循 Exchange Server 2007 產品文件中的＜如何使用 Exchange Server 2007 安裝程式執行自訂安裝＞(英文) (http://go.microsoft.com/fwlink/?LinkId=86648) 中的指導。
移除失敗的伺服器角色

  1. 遵循 Exchange Server 2007 產品文件中的＜如何使用移除 Exchange 2007 Server Role＞(英文) (http://go.microsoft.com/fwlink/?LinkId=86649) 中的指導。

詳細資訊

若需如何在自動模式下安裝 Exchange 2007 的相關資訊，請參閱＜如何在自動模式下安裝 Exchange 2007＞(英文) (http://go.microsoft.com/fwlink/?linkid=86476)。


此伺服器是路由群組連接器的來源
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-27

因為嘗試移除 Hub Transport server role 失敗，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。本機電腦是 Exchange 組織中一或多個路由群組連接器的來源。

路由群組連接器是用來傳送及接收 Exchange 2007 Hub Transport server 與 Exchange Server 2003 或 Exchange 2000 Server Bridgehead 伺服器之間的訊息。當 Exchange Server 2007 安裝在現有的 Exchange Server 2003 和 Exchange 2000 Server 組織時，會在安裝期間建立所需的路由群組連接器。

Exchange 2007 安裝程式在刪除伺服器角色之前，需要 Exchange 組織的所有路徑群組連接器，都先從 Hub Transport server 電腦中加以移走或刪除。

若要解決此問題，請從本機電腦移走或刪除所有的路由群組連接器，然後再重新執行安裝程式。

使用 Exchange 管理命令介面移動路由群組連接器

  1. 使用 Set-RoutingGroupConnector 指令程式修改 Microsoft Exchange Server 2007 路由群組和 Exchange Server 2003 或 Exchange 2000 Server 路由群組之間，現有路由群組連接器的內容。

  2. 此範例使用 Set-RoutingGroupConnector 指令程式來修改路由群組連接器的來源
複製程式碼
Set-RoutingGroupConnector -Identity "[[Administrative Group Name\]Routing Group Name]\Routing Group Connector Name" -SourceTransportServers [FQDN of desired Hub Transport Server]
 使用 Exchange 管理命令介面移除路由群組連接器

  1. 使用 Remove-RoutingGroupConnector 指令程式，移除 Microsoft Exchange Server 2007 路由群組和 Exchange Server 2003 或 Exchange 2000 Server 路由群組之間的路由群組連接器。

  2. 下面的範例顯示如何使用 Remove-RoutingGroupConnector 指令程式移除指定的路由群組連接器。
複製程式碼
Remove-RoutingGroupConnector -Identity"[[Administrative Group Name\]Routing Group Name]\Routing Group Connector Name"

若需修改或移除路由群組連接器的相關資訊，請參閱 Exchange Server 2007 產品文件的下列主題：

  • Set-RoutingGroupConnector (英文) (http://go.microsoft.com/fwlink/?LinkId=86659)。

  • Remove-RoutingGroupConnector (英文) (http://go.microsoft.com/fwlink/?LinkId=86660)。


此伺服器是傳送連接器的來源
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-27

因為嘗試移除 Hub Transport server role 失敗，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。本機電腦是 Exchange 組織中一或多個傳送連接器的來源。

傳送連接器代表用來傳送輸出郵件的邏輯閘道。

Exchange 2007 安裝程式要求在刪除伺服器角色之前，必須先移動或刪除 Hub Transport 伺服器電腦中的 Exchange 組織的所有傳送連接器。

若要解決此問題，請移動或刪除本機電腦中的所有傳送連接器，然後重新執行安裝程式。

若需修改或移除傳送連接器的相關資訊，請在 Exchange Server 2007 產品文件中參閱下列主題：

  • ＜如何移除傳送連接器＞(http://go.microsoft.com/fwlink/?LinkId=86655) (英文)。

  • ＜如何修改傳送連接器的組態＞(http://go.microsoft.com/fwlink/?LinkId=86656) (英文)。


偵測到簡易 Exchange 組織模型
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-08-18

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務，以判定伺服器上的信箱數目。每一個信箱儲存區物件 (msExchPrivateMDB 類別) 都有一個多重值的屬性 homeMDBBL，可列出儲存區中的所有信箱。Exchange Server Analyzer 會計算這些值，以取得伺服器上的信箱總數。

Exchange Server Analyzer 也會查詢 Active Directory，以判定包含 Exchange Server 的 Active Directory 站台數目。此外，Exchange Server Analyzer 還會查詢 Active Directory，以判定正在執行 Microsoft Exchange 2000 Server 或 Microsoft Exchange Server 2003 的伺服器數目。最後，Exchange Server Analyzer 會查詢 Win32_Service Microsoft Windows® Management Instrumentation (WMI) 物件，以判定 Windows 叢集服務是否存在並執行中。

如果下列條件為真，Exchange Server Analyzer 會將 Exchange 組織分類為簡易 Exchange 組織：

  • 組織中的信箱總數小於 1,000。

  • 只在某個 Active Directory 站台中安裝 Exchange 伺服器。

  • 少於 3 部電腦執行 Exchange 2000 或 Exchange 2003。

  • 沒有部署任何叢集 Exchange 伺服器。

Microsoft Exchange Server 2007 有四個已定義的組織模型，其中簡易 Exchange 組織代表可部署 Exchange 2007 的最基本拓撲。簡易 Exchange 組織包含：

  • 單一 Exchange 伺服器，用以提供所有 Exchange 服務及儲存整個組織的所有 Exchange 資料。

  • 多部 Exchange 伺服器，位於在周邊網路中包括多部備援目錄伺服器及一部 Edge Transport Server 的拓撲。

將簡易 Exchange 組織轉換至 Exchange 2007

  1. 請造訪 Exchange Server 2007 產品的線上文件 (英文) (http://go.microsoft.com/fwlink/?LinkId=69434)。

  2. 展開 [規劃與架構]，再展開 [規劃您的部署]，然後按一下 [規劃簡易 Exchange 組織]。


目前已安裝簡易郵件傳送通訊協定
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-01-22

因為此電腦上已安裝 Microsoft Windows Server™ 2003 簡易郵件傳送通訊協定 (SMTP) 服務，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Microsoft Exchange 安裝程式需要 Exchange 2007 所用的伺服器上未安裝 SMTP 服務。

若要解決此問題，請解除安裝 SMTP 服務並重新執行 Microsoft Exchange 安裝程式。

使用控制台中的新增或移除 Windows 元件來解除安裝 SMTP 服務

  1. 在 [開始] 功能表上，按一下 [控制台]。

  2. 按兩下 [新增或移除程式]。

  3. 按一下 [新增/移除 Windows 元件]。

  4. 在 [元件] 清單中，選取 [應用程式伺服器] 核取方塊，再按一下 [詳細資料]。

  5. 選取 [網際網路資訊服務管理員]，然後按一下 [詳細資料]。

  6. 選取 [SMTP 服務]，然後按一下以清除核取方塊。

  7. 按兩次 [確定] 以回到 [元件] 清單，然後按 [下一步]。

  8. 解除安裝 SMTP 服務後按一下 [完成]。


站台不支援 Exchange 2007 伺服器
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-08-11

Microsoft® Exchange Server Analyzer 工具會顯示此警告，因為 Active Directory 目錄服務樹系中有些站台，完全沒有任何通用類別目錄伺服器正在 Microsoft Windows Server™ 2003 Service Pack 1 (SP1) 或更新版本上執行。

Microsoft Exchange Server 2007 安裝程式需要每一個將主控正在執行 Exchange 2007 之伺服器的 Active Directory 站台，才能至少有一部在 Windows Server 2003 SP1 或更新版本上執行的通用類別目錄伺服器。

若要處理此問題，請將每一個 Active Directory 站台中至少一部通用類別目錄伺服器升級至 Windows Server 2003 SP1 或更新版本。

若需如何升級至 Windows Server 2003 的相關資訊，請參閱 Microsoft Knowledge Base 810613＜升級至 Windows Server 2003 或 Windows Small Business Server 2003 的支援路徑＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810613)。

若要取得 Windows Server 2003 的最新 Service Pack，請參閱 Windows Server TechCenter (http://go.microsoft.com/fwlink/?LinkId=45315)。


偵測到標準 Exchange 組織模型
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-08-10

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務以判定：

  • 組織中的信箱數目。

  • 組織中的路由群組數目。

  • 組織中的 Active Directory 站台數目。

  • 組織中的 Active Directory 樹系數目。

  • 是否安裝了 Microsoft Identity Integration Server (MIIS)。

每一個項目的數量會決定 Exchange 組織模型是簡單、標準、大型或複雜。任何未分類為簡單、大型或複雜的組織會自動分類為標準 Exchange 組織。

Microsoft Exchange Server 2007 有四個已定義的組織模型，其中標準 Exchange 組織代表已部署 Exchange 2007 的最常用拓撲。當郵件服務需求的成長超過單一電腦的資源限制時，將 Exchange 2007 服務分放在多部電腦上即會變成下一個拓撲分割：標準 Exchange 組織。標準 Exchange 組織藉由部署多部執行 Exchange 的電腦而建立在簡單 Exchange 組織之上。

若要將標準 Exchange 組織轉換至 Exchange 2007

  1. 請檢視 Exchange Server 2007 產品的線上文件 (英文) (http://go.microsoft.com/fwlink/?LinkId=69434)。

  2. 展開 [規劃與架構]，再展開 [規劃您的部署]，然後按一下 [規劃標準 Exchange 組織]。


叢集中建議使用靜態 IP 位址
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-05

因為已將一或多個網路介面設為使用動態主機設定通訊協定 (DHCP)，所以 Microsoft® Exchange Server 2007 安裝程式顯示此警告。

建議的最佳作法是在管理用戶端連線，與管理 Microsoft Windows 伺服器叢集中活動訊號連線的網路介面上使用靜態 IP 位址。不建議使用 DHCP 動態組態，因為更新 DHCP 租用失敗會使叢集作業中斷。

若要更正此警告，請將每個管理用戶端連線或活動訊號連線的網路介面，設為使用靜態 IP 位址。

設定網路連線的靜態 IP 位址

  1. 在 [開始] 功能表上按一下 [設定]，然後再按 [網路設定]。

  2. 在要設定的連線上按一下滑鼠右鍵，然後按一下 [內容]。

  3. 在 [一般] 索引標籤的 [這個連線使用下列項目] 中，按一下 [Internet Protocol (TCP/IP)]，然後按一下 [內容]。

  4. 按一下 [使用下列的 IP 位址]，然後在 [IP 位址] 中輸入 IP 位址。

  5. 按兩下 [確定] 結束。

如需 Windows Server 叢集最佳網路組態的相關資訊，請參閱＜伺服器叢集：Windows 2000 及 Windows Server 2003 網路組態最佳作法＞(英文)(http://go.microsoft.com/fwlink/?linkid=34304)。

如需叢集活動訊號正確組態的相關資訊，請參閱 Microsoft 知識庫文章 258750＜叢集伺服器上建議使用的私人「活動訊號」(Heartbeat) 組態＞(英文) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)。


單一副本叢集的儲存路徑必須是叢集的磁碟
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-27

因為單一副本叢集的儲存路徑必須是叢集磁碟，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

在 Exchange Server 2007 中，單一副本叢集 (SCC) 是一個叢集解決方案，它在叢集的各節點之間所共用的儲存空間上，使用儲存群組的單一副本。

若要解決此問題，請指定資料路徑的叢集磁碟機，然後重新執行 Exchange 2007 安裝程式。

若需單一副本叢集的相關資訊，請參閱 Exchange Server 2007 產品文件中的＜安裝單一副本叢集＞(英文) (http://go.microsoft.com/fwlink/?LinkId=76162)。


不支援 SMTP 定址格式
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-27

因為指定的收件者原則使用不受支援的簡易郵件傳送通訊協定 (SMTP) 位址格式，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要用於電子郵件位址原則的所有 SMTP 都不包含 IP 位址文字，例如：user@[10.10.1.1]。

若要解決此問題，請變更收件者原則的 SMTP 位址值，使它不包含 IP 位址文字。將 IP 位址文字的方括弧 ([]) 和數字 (10.10.1.1) 取代成網域名稱系統 (DNS) 命名格式，例如：user@contoso.com，然後重新執行 Exchange 安裝程式。

若需在 Exchange Server 2007 中管理收件者原則的相關資訊，請參閱＜管理電子郵件位址原則＞(英文) (http://go.microsoft.com/fwlink/?LinkId=86653)。


找到 SMTP 站台連結
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-12-07

如果 Microsoft® Exchange Server Analyzer 工具在 Active Directory® 目錄服務中找到簡易郵件傳送通訊協定 (SMTP) 型站台連結，則它會顯示此警告。

Microsoft Exchange Server 2007 路由會略過由 SMTP 站台連結所連接的 Active Directory 站台。如果 Exchange 2007 安裝在僅由 SMTP 站台連結所連接的站台中，就會發生路由錯誤。

若要處理此問題，請將 SMTP 站台連結換成 IP 型站台連結。

若需 Active Directory IP 站台連結的詳細資訊，請參閱＜規劃如何為路由郵件使用 Active Directory 站台＞(英文) (http://go.microsoft.com/fwlink/?LinkId=71803)。


遺失儲存群組磁碟機規格
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-05-15

因為 Microsoft® Exchange Server 2007 嚴重損壞修復安裝程式無法存取此伺服器上次安裝所使用的儲存群組資料庫磁碟機規格，所以嚴重損壞修復安裝程式無法繼續。

在還原期間，Microsoft Exchange 嚴重損壞修復安裝程式需要能夠使用先前針對此伺服器所使用的相同儲存群組資料庫磁碟機規格。

若要解決這個情況，請將磁碟機設定為符合原始的邏輯磁碟機組態，然後重新執行 Microsoft Exchange 嚴重損壞修復安裝程式。

指派或變更磁碟機代號

  1. 開啟 [電腦管理 (本機)]。

  2. 在主控台樹狀目錄中，請依序按一下 [電腦管理 (本機)]、[存放] 及 [磁碟管理]。

  3. 在分割區、邏輯磁碟機或磁碟區上按一下滑鼠右鍵，再按 [變更磁碟機代號及路徑]。

  4. 使用下列其中一個程序：

    • 若要指派磁碟機代號，請依序按一下 [新增] 及您要使用的磁碟機代號，再按 [確定]。

    • 若要修改磁碟機代號，請按一下它，再依序按一下 [變更] 及您要使用的磁碟機代號，然後按 [確定]。

如需如何指派磁碟機代號的相關資訊，請參閱＜指派、變更或移除磁碟機代號＞(英文) (http://go.microsoft.com/fwlink/?linkid=66764)。


目標安裝路徑不符
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-27

因為 Exchange 二進位檔案的目標路徑不符合其他叢集節點上的現有 Exchange 安裝路徑，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

Exchange Server 2007 要求相同叢集的節點上，Exchange 二進位檔案的目標安裝路徑必須一致。

若要解決此問題，請在叢集的所有節點上，都使用一致的 Exchange 二進位檔案目標安裝路徑。

若需有關「高可用性 Exchange Server 2007」安裝的相關資訊，請參閱 Exchange Server 2007 產品文件中的＜高可用性＞(英文) (http://go.microsoft.com/fwlink/?linkid=68190)。


已壓縮目標路徑
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-06

因為已壓縮 Microsoft Exchange 安裝的目標資料夾路徑，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Microsoft Exchange 安裝程式需要安裝目標路徑中的第一個資料夾不是壓縮資料夾。依預設，安裝目標路徑中的第一個資料夾是 C:\Program Files。

若要解決此問題，請停用目標路徑中第一個資料夾的壓縮，然後重新執行 Exchange 2007 安裝程式。

停用目標路徑的壓縮

  1. 在 [我的電腦] 或 [Windows 檔案總管] 中，於要解壓縮的資料夾上按一下滑鼠右鍵。

  2. 按一下 內容] 以顯示 [內容] 對話方塊。

  3. 在 [一般] 索引標籤中，按一下 [進階]。

  4. 在 [進階屬性] 對話方塊中，清除 [壓縮內容，節省磁碟空間] 核取方塊，然後按一下 [確定]。

  5. 在 [內容] 對話方塊中，按一下 [確定]。

  6. 當資料夾的壓縮狀態變更時，請在 [確認屬性變更] 對話方塊中，選取 [套用變更到這個資料夾、子資料夾和檔案]。

  7. 完成時按一下 [確定]。


叢集中建議使用兩個以上的網路介面
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-05

因為目前的 Microsoft Windows 叢集環境只有定義一個網路介面，所以 Microsoft® Exchange Server 2007 安裝程式顯示此警告。

建議的最佳作法就是為公用網路至少實作一個網路介面 (用戶端連線)，並為私人網路至少實作一個網路介面 (系統管理/活動訊號)，以避免單一點失敗。

若要更正此警告，請為 Microsoft Windows 叢集至少實作一個額外的網路介面。

如需 Windows 伺服器叢集最佳網路組態的相關資訊，請參閱＜伺服器叢集：Windows 2000 及 Windows Server 2003 網路組態最佳作法＞(英文) (http://go.microsoft.com/fwlink/?linkid=34304)。


無法連線至 Remote Registry 服務
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-01-23

因為無法存取本機電腦的登錄，Microsoft® Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式必須有本機登錄的存取權，才能擷取各種設定。

Exchange 安裝程式會嘗試使用網域名稱系統 (DNS) 取得本機電腦的完整網域名稱 (FQDN)，以存取登錄。

可能是因為網路錯誤導致安裝程式無法從 DNS 擷取 FQDN，或是安裝程式無法存取登錄。

若要解決此問題，請確認本機電腦正在執行 Remote Registry 服務，且已在繫結順序中第一張網路介面卡上啟用「檔案及列印共用」，然後重新執行 Exchange 安裝程式。

若要驗證 Remote Registry 服務是否正在執行

  1. 按一下 [開始]，並依序指向 [設定]、[控制台] 及 [系統管理工具]，然後按兩下 [服務]。

  2. 確認 Remote Registry 服務的狀態為「已啟動」。
若要在主要網路介面卡上啟用檔案及列印共用

  1. 按一下 [開始]，並依序指向 [設定]、[控制台]、[網路連線] 及 [區域連線]。

  2. 確認已啟用 [File and Printer Sharing for Microsoft Networks]，也就是已選取該核取方塊。
附註：
如果您使用叢集伺服器，必須確認叢集中的所有節點正在執行 Remote Registry 服務，且繫結順序中第一張網路介面卡上的 [File and Printer Sharing for Microsoft Networks] 已啟用。


需要 Windows Media 音訊聲音轉碼器更新
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-07-13

因為尚未安裝 Microsoft Windows Media 音訊聲音轉碼器，或是 Windows Media 音訊聲音轉碼器有較新的版本，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要您在伺服器上安裝最新的 Windows Media 音訊聲音轉碼器版本。需要有 Windows Media 音訊聲音轉碼器版本，才能支援 Exchange Server 2007 Unified Messaging Server role。

若要解決這個問題，請從 http://go.microsoft.com/fwlink/?LinkId=67407 安裝最新版 Windows Media 音訊聲音轉碼器，然後重新執行 Exchange 2007 安裝程式。


需要 Windows Media 編碼器更新
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-07-13

因為尚未安裝 Microsoft Windows Media 編碼器，或是 Windows Media 編碼器有較新的版本，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要您在伺服器上安裝最新的 Windows Media 編碼器版本。需要有 Windows Media 編碼器，才能支援 Exchange Server 2007 Unified Messaging Server role。

若要解決這個問題，請從 http://go.microsoft.com/fwlink/?LinkId=67406 安裝最新版的 Windows Media 編碼器，然後重新執行 Exchange 2007 安裝程式。


World Wide Web Publishing 服務已停用或遺失
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-02-14

因為嘗試安裝 Mailbox Server 或 Client Access role 時發現 World Wide Web Publishing 服務已停用，或未安裝在此電腦上，所以 Microsoft® Exchange Server 2007 安裝程式無法繼續。

Exchange 2007 安裝程式需要即將安裝 Microsoft Exchange 的電腦已安裝 World Wide Web Publishing 服務，且設為 [已停用] 以外的值。

若要解決此問題，請驗證是否已在本機電腦上安裝且未停用 World Wide Web Publishing 服務，然後重新執行 Microsoft Exchange 安裝程式。

驗證是否已在本機電腦上安裝且未停用 World Wide Web Publishing 服務

  1. 在桌面上的 [我的電腦] 上按一下滑鼠右鍵，然後按一下 [管理]。

  2. 展開 [服務及應用程式] 節點，再按一下 [服務] 節點。

  3. 在右窗格中，尋找 [World Wide Web Publishing 服務]。

    如果在已安裝的服務清單中沒有顯示 World Wide Web Publishing 服務，請遵循下列程序中的步驟來安裝它。

  4. 如果有顯示 World Wide Web Publishing 服務，但狀態不是 [已啟動]，請繼續執行下列步驟來啟動它。

  5. 在 [World Wide Web Publishing 服務] 上按一下滑鼠右鍵，然後按一下 [內容]。

  6. 驗證 [啟動類型] 是否為 [自動]，而且 [服務狀態] 是否設為 [已啟動]。

  7. 按一下 [套用]，然後按一下 [確定]。
安裝 World Wide Web Publishing 服務

  1. 在 [開始] 功能表上，依序選取 [設定]、[控制台]，再按一下 [新增或移除程式]。

  2. 按一下 [新增/移除 Windows 元件]。

  3. 在 [元件] 清單中，選取 [應用程式伺服器] 核取方塊，然後選取 [詳細資料]。

  4. 選取 [網際網路資訊服務管理員]，然後按一下 [詳細資料]。

  5. 選取 [World Wide Web Service]，然後選取核取方塊。

  6. 按兩次 [確定] 以回到 [元件] 清單，然後按 [下一步]。

  7. 安裝 IIS 服務後按一下 [完成]。


解除安裝整合通訊語言套件
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-16

因為 Unified Messaging server role 升級失敗，所以 Microsoft Exchange Server 2007 安裝程式無法繼續。

除了 US English 語言套件之外，Exchange 安裝程式需要所有 Unified Messaging server role 語言套件都解除安裝，Unified Messaging server role 升級才能繼續。

包括在 Exchange 2007 中的 Unified Messaging (UM) 語言套件，含有預先錄製的提示、給定語言的文字轉語音 (Text-to-Speech，TTS) 轉換支援。

Exchange 2007 UM 語言套件可讓呼叫者和 Outlook Voice Access 使用者，以多種語言和 Unified Messaging 系統互動。

現有的非 US English 語言套件需要先解除安裝，才能安裝新的語言套件。

若要解決此問題，除了 US English 語言套件之外，請將所有 Unified Messaging server role 語言套件解除安裝，然後重新執行 Exchange 2007 安裝程式。

若需解除安裝 Unified Messaging server role 語言套件的相關資訊，請參閱 Exchange 2007 產品文件中的＜如何從 Unified Messaging Server 移除 Unified Messaging 語言套件＞(英文)。


進行嚴重損壞修復所需要的更新
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2007-03-27

因為原先使用了較新版本的 Exchange Server 2007 在這部電腦上安裝 Exchange Server，所以 Microsoft Exchange Server 2007 嚴重損壞修復無法繼續。

Microsoft Exchange 嚴重損壞修復要求，用來執行 Exchange Server 修復的 Exchange Server 2007 版本，必須等於或大於原先用來安裝 Exchange Server 的版本。

若要解決此問題，請從等於或大於原先用來安裝 Exchange Server 的 Exchange Server 2007 版本中，啟動 Exchange Server 2007 嚴重損壞修復。


拓撲中發現 X400 連接器
Microsoft Exchange Server Analyzer - 文章 > Exchange Server 2007 整備 >

主題上次修改日期： 2006-06-05

Microsoft® Exchange Server Analyzer 工具會查詢 Active Directory® 目錄服務是否有 X.400 連接器。如果 Exchange Server Analyzer 發現 Microsoft Exchange 組織中有 X.400 連接器，便會顯示警告。此警告指出 Microsoft Exchange Server 2007 不支援 X.400 連接器，此連接器是用來在先前的郵件系統之間傳輸郵件的通訊協定。

在 Microsoft Exchange 2000 Server 及 Microsoft Exchange Server 2003 中，簡易郵件傳送通訊協定 (SMTP) 已成為預設的傳輸通訊協定。雖然 Exchange 2000 及 Exchange 2003 支援 X.400 連接器，但是 Exchange 2007 不支援它們，因為近幾年來 X.400 連接器的使用已下降。如果仍需要 X.400 支援，建議您保留 Exchange 2000 或 Exchange 2003 伺服器。否則，可以將 X.400 連接器換成 SMTP。

若需 Exchange 2003 中之 X.400 傳輸架構的詳細資訊，請參閱＜Exchange Server 2003 郵件路由＞(英文) (http://go.microsoft.com/fwlink/?LinkId=65578)。

若需如何在 Exchange 2003 中實作 X.400 連接器的詳細資訊，請參閱＜實作 X.400 連接器 - 它值得與 Exchange Server 2003 搭配使用嗎？＞(英文) (http://www.msexchange.org/tutorials/X400-Connector-Exchange-Server-2003.html)

附註：
本主題也提供協力廠商網站資訊，協助您找到需要的技術資訊。URL 如有變更，恕不另行通知。


法律資訊

主題上次修改日期： 2007-04-06

本文件中的資訊 (包含 URL 及其他網際網路網站參考資料) 如有變更恕不另行通知。除非另有說明，此處所描述之範例公司、組織、產品、網域名稱、電子郵件位址、商標圖樣、人員、地點及事件均屬虛構，並非影射任何真實的公司、組織、產品、網域名稱、電子郵件位址、商標圖樣、人員、地點及事件。遵守所有適用的著作權法是使用者的責任。在不限制任何依著作權本得享有之權利，未經 Microsoft Corporation 書面許可， 貴用戶不得為任何目的使用任何形式或方法 (電子形式、機械形式、影印、記錄或其他方式) 複製或傳送本文件的任何部份，也不得將本文件的任何部份儲存或放入檢索系統 (a retrieval system)。

Microsoft 可能擁有本文件所提及內容中所含之專利權、專利優先權、商標、著作權，或其他智慧財產權。除非 Microsoft 書面授權合約所明示規定者外，提供本文件並不授予 貴用戶上述專利權、商標、著作權或其他智慧財產權。

© 2004-2006 Microsoft Corporation.著作權所有並保留一切權利。

Microsoft、Active Directory、ActiveSync、ActiveX、MSDN、Outlook、SharePoint、Visual C++、Win32、Windows、Windows NT、Windows Server 及 Windows Server System 是 Microsoft Corporation 在美國及/或其他國家 (地區) 的註冊商標或商標。

本文件中所提實際公司和產品，可能為各所有人所有之商標。