Runtime Kit Readme

WIBU-KEY Runtime Kit

Dieser Abschnitt der Hilfedatei gibt einen Überblick über das WIBU-KEY Runtime Kit.
Installation der WIBU-KEY Software
Deinstallation der WIBU-KEY Software
Verzeichnis der mitgelieferten Dateien
Zielverzeichnisse für die Treiberdateien
Wie bekommt man die neuesten Treiber?


Installation der WIBU-KEY-Software

Mit Hilfe dieser Installationssoftware können alle Treiber, die unter dem jeweiligen Betriebssystem für den Einsatz von WIBU-KEY benötigt werden, automatisch installiert werden. Zur Installation der Software müssen Sie als erstes alle anderen Windows- Programme, insbesondere solche, die mit WIBU-KEY geschützt sind, beenden, da sonst eventuell nicht alle Dateien durch die neue Version ersetzt werden können. Starten Sie nun das Programm "WkRuntime.exe" und folgen Sie den Anweisungen auf dem Bildschirm. Das Installationsprogramm zeigt das erkannte Betriebssystem an und listet die Dateien auf, die auf diesem System zur Verwendung von WIBU-KEY benötigt werden. Durch das Drücken des "Weiter"-Knopfes werden alle benötigten Dateien auf die Festplatte kopiert und gegebenenfalls installiert. Nach Abschluss der Installation befindet sich in der Systemsteuerung ein neues Symbol mit dem Namen WIBU-KEY. Nach dem Start dieser Systemsteuerungserweiterung sollte der Inhalt der angeschlossenen WIBU-BOX angezeigt werden. Tritt bei der Installation oder beim Start der Systemsteuerungserweiterung ein Fehler auf, sollten Sie das Betriebssystem neu starten und die Installation von vorne beginnen.
Wichtig bei der Installation unter Windows 95:

Um WIBU-KEY korrekt unter Windows 95 einsetzen zu können, müssen einige System DLLs installiert bzw. aktualisiert werden. Es sollte hierzu der original Microsoft Installer msaardk.exe, der im Verzeichnis \Tools\Microsoft auf der WIBU-KEY CD zu finden ist, verwendet werden. Für das WIBU-KEY Development Kit ist diese Installation unbedingt notwendig. Für das WIBU-KEY Runtime Kit ist die Installation der DLLs nicht zwingend notwendig, wird jedoch empfohlen.
Wichtig bei der Installation unter Windows NT 4.0:

Unter Windows NT 4.0 muß die System DLL shlwapi.dll installiert werden. Die benötigte DLL ist schon installiert wenn der Internet Explorer Version 4.0 oder höher verwendet wird.


Verzeichnis der mitgelieferten Dateien

Treiberdateien:
Dateiname
Zielverzeichnis
WKUSEUS.CHM | Englische Version der Endbenutzer-Hilfe
WKUSEDE.CHM | Deutsche Version der Endbenutzer-Hilfe
WKUSEFR.CHM | Französische Version der Endbenutzer-Hilfe
SETUP32.EXE | Installationsprogramm für Windows
SETUP.EXE | Installationsprogramm für Windows (16 bit)
SETUP32.LDE | Deutsche Sprachdatei von SETUP.EXE
SETUP32.LFR | Französische Sprachdatei von SETUP.EXE
SETUP32.LHU | Ungarische Sprachdatei von SETUP.EXE
SETUP32.LES | Spanische Sprachdatei von SETUP.EXE
SETUP32.LJP | Japanische Sprachdatei von SETUP.EXE
SETUP32.LBR | Portugiesische Sprachdatei von SETUP.EXE
SETUP32.LIT | Italienische Sprachdatei von SETUP.EXE
SETUP32.LCN | Chinesische Sprachdatei von SETUP.EXE
SETUP.INI | Konfigurationsdatei für das Setup
WIBUKEY.INI | Konfigurationsdatei für WIBU-KEY
WKExt32.DLL | Aufruf-/ Treiber-DLL für erweitere WIBU-KEY API Befehle
WKDOS.EXE | WkDOS-Treiber für Windows NT/2000/XP/Server 2003, Windows 95/98/ME, Win 3.x und DOS
WKWIN.DLL | Aufruf-/ Treiber-DLL für 16-Bit-Windows
WKWIN16.LDE | Deutsche Sprachdatei der WKWIN16.DLL
WKWIN16.LFR | Französische Sprachdatei der WKWIN16.DLL
WKWIN16.LHU | Ungarische Sprachdatei der WKWIN16.DLL
WKWIN16.LES | Spanische Sprachdatei der WKWIN16.DLL
WKWIN16.LJP | Japanische Sprachdatei der WKWIN16.DLL
WKWIN16.LBR | Portugiesische Sprachdatei der WKWIN16.DLL
WKWIN16.LIT | Italienische Sprachdatei der WKWIN16.DLL
WKWIN16.LCN | Chinesische Sprachdatei der WKWIN16.DLL
WKWIN32.DLL | Aufruf-/ Treiber-DLL für Win32
WIBUKJNI.DLL | WIBU-KEY Java Native Interface Bibliothek
WKWIN32.LDE | Deutsche Sprachdatei der WKWIN32.DLL
WKWIN32.LFR | Französische Sprachdatei der WKWIN32.DLL
WKWIN32.LHU | Ungarische Sprachdatei der WKWIN32.DLL
WKWIN32.LES | Spanische Sprachdatei der WKWIN32.DLL
WKWIN32.LJP | Japanische Sprachdatei der WKWIN32.DLL
WKWIN32.LBR | Portugiesische Sprachdatei der WKWIN32.DLL
WKWIN32.LIT | Italienische Sprachdatei der WKWIN32.DLL
WKWIN32.LCN | Chinesische Sprachdatei der WKWIN32.DLL
WIBUKEY.SYS | Kerntreiber für Windows NT/2000/XP/Server 2003
WIBUKEY2.SYS | Kerntreiber für Windows 98/ME/2000/XP/Server 2003 für USB
WIBUKEY.VXD | Kerntreiber für Windows 95/98/ME
WIBUKEY.DLL | WIBU-KEY COM Control
WIBUSHELLEXT.DLL | WIBU-SYSTEMS Shell Extension
WIBUKE32.CPL | Systemsteuerungserweiterung für Windows
WIBUKE32.LDE | Deutsche Sprachdatei von WIBUKE32.CPL
WIBUKE32.LFR | Französische Sprachdatei von WIBUKE32.CPL
WIBUKE32.LHU | Ungarische Sprachdatei von WIBUKE32.CPL
WIBUKE32.LES | Spanische Sprachdatei von WIBUKE32.CPL
WIBUKE32.LJP | Japanische Sprachdatei von WIBUKE32.CPL
WIBUKE32.LBR | Portugiesische Sprachdatei von WIBUKE32.CPL
WIBUKE32.LIT | Italienische Sprachdatei von WIBUKE32.CPL
WIBUKE32.LCN | Chinesische Sprachdatei von WIBUKE32.CPL
WIBUKEY.INF | PnP-Installationsdatei für Windows 95/98/ME/2000/XP/Server 2003
WIBUKEY.INI | WIBU-KEY COM-Objekt (ActivX-Element)
Tools:

Dateiname
Zielverzeichnis
WKSVMON.EXE | Der WkNet/WkLAN-Netzwerk-Servermonitor für Win32
WKSVNW.NLM | WkNet-Serverprozeß als NLM für Novell Netware
WKSVW32.EXE | Netzwerk-Serverprozeß als 32-Bit-Anwendung (WkLAN/WkNet)
WKU.EXE | DOS-Programm für den WIBU-KEY Endanwender
WKU32.EXE | 32-Bit-Variante von WKU.EXE

Einige Tools besitzen zusätzliche Sprachdateien. Diese Dateien haben den gleichen Namen wie die entsprechende Datei. Als Extension haben diese Dateien Lxx, wobei hier xx für das Kürzel der unterstützen Sprache ist. Einige Dateien wurden vom Microsoft COMPRESS Utility gepackt. Diese Dateien enden immer auf einen Unterstrich ("_").


Deinstallation der WIBU-KEY-Software

Die WIBU-KEY Treiberdateien können unter Windows 95/98/ME/ NT/2000/XP/Server 2003 automatisch deinstalliert werden, wenn die WIBU-KEY Treiber über das WIBU-KEY Runtime Kit Setup installiert wurden.

In der Systemsteuerung das Kontrollfeld "Software" starten. In der dort angezeigten Liste den Eintrag "WIBU-KEY Remove" ausgewählen. Über "Ändern/Entfernen" bzw. "OK" wird der Deinstallationsvorgang gestartet und alle Treiberdateien, das WIBU-KEY Kontrollfeld, sowie die Einträge in der Registrierungsdatenbank entfernt.


Zielverzeichnisse für die Treiberdateien

Dateiname
Zielverzeichnis
WkExt32.dll Windows-Stammverzeichnis (%WINDOWS%) nur Windows 95/ME/98) bzw.
([%WINDOWS%\SYSTEM32)
WkDOS.exe Windows-Stammverzeichnis (%WINDOWS% nur Windows 95/ME/98) bzw.
(%WINDOWS%\SYSTEM32)
WkWin.dll | Windows-Systemverzeichnis (%WINDOWS%\SYSTEM32)
WkWin32.dll | Windows-Systemverzeichnis (%WINDOWS%\SYSTEM bzw. (%WINDOWS%\SYSTEM32)
WibuKJni.dll | Windows-Systemverzeichnis (%WINDOWS%\SYSTEM bzw. (%WINDOWS%\SYSTEM32)
WIBUKEY.dll | WIBU-KEY-Programmverzeichnis ([%ProgrammFiles%\WIBU-KEY\BIN)
WibuShellExt.dll | WIBU-KEY-Programmverzeichnis (%ProgrammFiles%\WIBU-SYSTEMS\System)
WibuKey.sys | Windows NT-Treiberverzeichnis (%WINDOWS%\SYSTEM32\DRIVERS)
WibuKey2.sys | Windows Treiberverzeichnis (%WINDOWS%\SYSTEM32\DRIVERS)
WibuKey.vxd | Windows Systemerzeichnis (%WINDOWS%\SYSTEM32)
WibuKe32.cpl | Windows-Systemverzeichnis (%WINDOWS%\SYSTEM bzw. (%WINDOWS%\SYSTEM32)
Eine Anwendung wird wahrscheinlich auch unter Windows 95/98/Me funktionieren, wenn sich einige Dateien, wie z.B. die DLLs oder WkDOS.exe nicht im Systemverzeichnis, sondern im Anwendungsverzeichnis befinden. WIBU-SYSTEMS empfiehlt aber ausdrücklich, die Dateien mittels des WIBU-KEY Runtime Kits zu installieren, um die volle Funktionalität der Anwendungen sicherzustellen! Unter Windows NT/2000/XP/Server 2003 ist eine Installation mit dem WIBU-KEY Runtime Kit unerlässlich, da hier die Komponenten im System registiert werden, um eine ordnungsgemäße Funktionalität der Anwendungen zu gewährleisten. Falls eine Sprachdatei zu einer DLL installiert wird, wird diese in das gleiche Verzeichnis kopiert wie die DLL. Die Sprachdateien heißen für WkWin.dll WkWin16.lxx und für WkWin32.dll WkWin32.lxx, wobei xx durch das Kürzel der entsprechenden Sprache ersetzt wird.


Wie bekommt man die neuesten Treiber?

Die neuesten Informationen über WIBU-KEY finden Sie im Internet. Besuchen Sie unsere Internetseite unter:
http://www.wibu.de
Die neueste Version des WIBU-KEY Runtime Kits kann von folgender Seite geladen werden:


WIBU-BOXen

Was ist eine WIBU-BOX?
Die WIBU-BOX ist die Verschlüsselungshardware von WIBU-SYSTEMS. Es ist ein kleiner farbiger Stecker für den PC oder Macintosh. Die WIBU-BOX kann verschiedene Farben haben, standardmäßig ist sie türkis. Die WIBU-BOX gibt es in verschiedenen Varianten für verschiedene Schnittstellen. Das Verhalten aller WIBU-BOXen ist gleich. Die WIBU-BOXen entsprechen nationalen und internationalen Normen. Detaillierte Konformitätsbescheinigungen erhalten Sie von uns gerne auf Anfrage.
WIBU-BOX/P(+)
WIBU-BOX/U(+)
WIBU-BOX/SP
WIBU-BOX/SX
WIBU-BOX/ST
WIBU-BOX/P36
WIBU-BOX/CI
WIBU-BOX/M
WIBU-BOX/A
WIBU-BOX/RP(+)
WIBU-BOX/RU(+)
CE Konformität
Einhaltungen der FCC Bestimmungen
VDE-Zulassung
UL-Zulassung
VCCI-Zulassung


WIBU-BOX/P

Die WIBU-BOX/P bzw. WIBU-BOX/P+ (mit 16kB Speicher) ist für die parallele Druckerschnittstelle eines IBM-PCs oder kompatiblen Systems. Sie unterstützt den erweiterten parallelen Anschluss (EPP) mit seinem bidirektionalem Modus, der zu IEEE 1284 kompatibel ist. Alle Geräte, die mit diesem Standard arbeiten, funktionieren in Verbindung mit der WIBU-BOX/P(+). Sie wird einfach an die 25polige Druckerschnittstelle in Pfeilrichtung an den PC angesteckt. Die Rändelschrauben dienen zum befestigen an das PC-Gehäuse. Die WIBU-BOX ist kaskadierbar, d.h. es können mehrere WIBU-BOXen hintereinander angesteckt werden. Wird die WIBU-BOX/P zusammen mit Dongels anderer Hersteller angeschlossen, dann soll die WIBU-BOX/P möglichst als erste am PC angeschlossen werden und die anderen dahinter. Meistens kann auch direkt an die letzte WIBU-BOX einen Drucker angeschlossen werden. Siehe Probleme mit Drucker.


WIBU-BOX/U

Die WIBU-BOX/U bzw. WIBU-BOX/U+ (mit 16kB Speicher) ist für den Universal Serial Bus (USB) von PCs und Macintosh. Sie kann an eine beliebige USB-Schnittstelle oder Verteiler (HUB) angeschlossen werden. Die WIBU-BOX/U(+) ist ein Endgerät, d.h. sie ist nicht kaskadierbar. Mit der WIBU-BOX/U(+) gibt es keine Konflikte mit anderen Geräten, da das jeweilige Betriebssystem die Zugriffe auf alle angeschlossenen USB-Geräte steuert und synchronisiert. Die WIBU-BOX/U unterstützt Mac OS ab der Version 8, Windows 98/ME/2000/XP/Server 2003 und alle von WIBU-KEY unterstützten Linux Distributionen.


WIBU-BOX/SP

Die WIBU-BOX/SP ist für die serielle Schnittstelle eines IBM-PCs oder kompatiblen Systems. Sie unterstützt verschiedene serielle Kommunikationsmodi. Der Standardmodus der WIBU-BOX/SP ist der Maus-Modus. Zusätzlich kann die WIBU-BOX/SP auf Terminalmodus umkonfiguriert werden. Alle Geräte, die einen dieser Modi für die serielle Kommunikation verwenden, können zusammen mit der WIBU-BOX/SP verwendet werden. Sie wird einfach an die 25polige serielle Schnittstelle in Pfeilrichtung an den PC angesteckt. Die Rändelschrauben dienen zum Befestigen an das PC-Gehäuse. Eine WIBU-BOX/SP kann auch an den 9poligen AT-Anschlüssen verwendet werden. Hierzu muß ein Adapterkabel zwischen der 25poligen Buchse der WIBU-BOX/SP und dem kleinen 9poligen Anschlussstecker eingefügt werden. An der WIBU-BOX/SP kann weiterhin eine Maus oder ein Gerät mit 3-Draht-Kommunikation (RS232) angeschlossen werden. Solche Geräte funktionieren aber an dem seriellen Anschluss möglicherweise nach einer WIBU-BOX/SP nicht mehr ganz so problemlos. Werden die zwischen Maus und seriellen Anschluss angeschlossenen WIBU-BOXen/SP sehr häufig und länger angesprochen, kann die Bewegung der Maus am Bildschirm leicht eingeschränkt sein. Keineswegs darf aber die Maus sich aufhängen, Positionen außerhalb des Bildschirms liefern oder Geister-Klicks verursachen.


WIBU-BOX/SX

Die WIBU-BOX/SX ist wie die WIBU-BOX/SP, jedoch nur für japanische NEC-PCs mit Standard RS232-Anschluss.


WIBU-BOX/ST

Die WIBU-BOX/ST ist wie die WIBU-BOX/SP, jedoch für die serielle, asynchrone Schnittstelle (RS232) beliebiger Systeme (z.B. Unix-Rechner, PC, Macintosh). Die WIBU-BOX/ST erkennt die Baudrate zwischen 4.800 Baud und 19.200 Baud automatisch und stellt sich darauf ein.


WIBU-BOX/P36

Die WIBU-BOX/P36 ist für die 36-polige Centronics-Schnittstelle und kann sowohl mit japanischen NEC-PC98 Systemen, als auch mit Standard PCs verwendet werden. Sie wird einfach an die 36polige Centronics-Schnittstelle in Pfeilrichtung an den PC angesteckt. Die Klammern dienen zum Befestigen des Druckerkabels zum PC.


WIBU-BOX/CI

Die WIBU-BOX/CI ist eine Einsteckkarte für den ISA-BUS von IBM-PCs oder kompatiblen Systemen. Für die Installation wird ein 8-Bit Steckplatz benötigt. Auch ein 16-Bit Steckplatz oder eine EISA-Steckplatzkarte können verwendet werden. Die Schnittstellen-Adresse kann zwischen 230H und 24FH sowie zwischen 330H und 34FH über Steckbrücken eingestellt werden. Die eingestellte Adresse muß in der WIBU-KEY Systemsteuerungserweiterung auf der Seite Einstellungen eingetragen werden. Meist wird die Basisadresse der WIBU-BOX/CI als Adresse von LPT4 eingetragen.


WIBU-BOX/M

Die WIBU-BOX/M ist eine PCMCIA-Karte vom Typ II. Sie funktioniert wie die anderen WIBU-BOX Varianten und ist somit völlig kompatibel und leistungsgleich. Die WIBU-KEY Treiber für PCMCIA unterstützen die Card Services und den direkten Zugriff auf Intel-kompatible PC Card-Controller, die keine Card Services benötigen. Die WIBU-BOX/M steckt man in Pfeilrichtung in den PC Card Slot am PC oder am Laptop ein. Sie wird automatisch als Plug&Play Hardware von Windows 98/ME und Windows 2000/XP/Server 2003 erkannt. Unter DOS und Windows 3.x müssen Card- und Socket Services installiert sein. Zur Verwendung mit Windows NT 4.0 muss die Award Cardware für NT 4 installiert werden.


WIBU-BOX/A

Die WIBU-BOX/A wurde speziell für die ADB-Schnittstelle des Apple Macintosh entwickelt. Sie basiert auf dem gleichen ASIC wie die anderen WIBU-BOX-Varianten und ist völlig kompatibel und leistungsgleich. Man steckt die WIBU-BOX/A mit dem Stecker am Kabel (dünnerer Stecker) an den ADB-Port des Macintosh (z.B. an die Tastatur, oder vor die Maus). An den Stecker (Wellenform) kann dann z.B. die Maus weitergeführt werden.


WIBU-BOX/RP

Die WIBU-BOX/RP bzw. WIBU-BOX/RP+ (mit 16kB Speicher) ist für die parallele Druckerschnittstelle eines IBM-PCs oder kompatiblen Systems. Sie unterstützt den erweiterten parallelen Anschluss (EPP) mit seinem bidirektionalem Modus, der zu IEEE 1284 kompatibel ist.
Alle Geräte, die mit diesem Standard arbeiten, funktionieren in Verbindung mit der WIBU-BOX/RP(+). Sie wird an die 25polige Druckerschnittstelle in Pfeilrichtung an den PC angesteckt. Die Schrauben dienen zum Befestigen an das PC-Gehäuse. Die WIBU-BOX ist kaskadierbar, d.h. es können mehrere WIBU-BOXen hintereinander angesteckt werden. Wird die WIBU-BOX/RP zusammen mit Dongels anderer Hersteller angeschlossen, dann sollte die WIBU-BOX/RP möglichst als erste am PC angeschlossen werden und die anderen dahinter. Meistens kann auch direkt an die letzte WIBU-BOX einen Drucker angeschlossen werden. Siehe Kapitel Probleme mit Drucker.


WIBU-BOX/RU

Die WIBU-BOX/RU bzw. WIBU-BOX/RU+ (mit 16kB Speicher) ist für den Universal Serial Bus (USB) von PCs und Macintosh. Sie kann an eine beliebige USB-Schnittstelle oder Verteiler (HUB) angeschlossen werden. Die WIBU-BOX/RU(+) ist ein Endgerät, d.h. sie ist nicht kaskadierbar. Mit der WIBU-BOX/RU(+) gibt es keine Konflikte mit anderen Geräten, da das jeweilige Betriebssystem die Zugriffe auf alle angeschlossenen USB-Geräte steuert und synchronisiert. Die WIBU-BOX/RU unterstützt Mac OS ab der Version 8, Windows 98/ME/2000/XP/Server 2003 und alle von WIBU-KEY unterstützten Linux Distributionen.


CE Konformität

Alle WIBU-BOXen entsprechen den Sicherheitsanforderungen der Richtline 89/336/EWG des Rates der Europäischen Union. Sie sind mit dem CE Logo gekennzeichnet. Sie entsprechen den folgenden geltenden Normen für elektromagnetische Verträglichkeit, Immunität und Empfindlichkeit: Die Produkte erfüllen die Grenzwerte für Geräte der Klasse B gemäß EN55022. Die Störunempfindlichkeit ist gemäß EN50082-1 und EN55024 erfüllt. Eine ausfühliche Konfomitätsbescheinigung ist auf Anfrage für jede WIBU-BOX Variante erhältlich.


Einhaltung der FCC Bestimmungen

Die WIBU-BOXen wurden auf Einhaltung der Grenzwerte für Digitalgeräte der Klasse B gemäß Teil 15 der FCC-Bestimmungen geprüft und zugelassen. Der Betrieb unterliegt folgenden Bedingungen:

1. Das Gerät darf keine schädliche Störausstrahlung verursachen.

2. Das Gerät muß Störstrahlungen verarbeiten können, einschließlich solcher Strahlungen, die zu einem unerwünschten Betrieb führen können.

Das Gerät erzeugt und nutzt Hochfrequenzenergie und kann Störstrahlungen verursachen, wenn es nicht gemäß Anweisung installiert und eingesetzt wird. Es gibt jedoch keine Gewähr dafür, daß in einer bestimmten Anlage keine Störungen auftreten werden. Wenn Störungen auftreten, schlagen Sie in Ihrem Systemhandbuch, das Vorschläge zur Beseitigung solcher Störungen enthalten sollte, nach. Zu den gängigen Abhilfen gehören: Vergrößerung des Abstands zwischen Computersystem und Fernsehgerät bzw. Radio oder Anschluß eines Computers an einen anderen Stromkreis oder eine andere Steckdose. Eine Änderung oder Modifizierung des Produkts ohne ausdrückliche Zustimmung der WIBU-SYSTEMS AG kann dazu führen, daß die FCC-Bestimmungen nicht mehr erfüllt sind. In diesem Fall erlischt das Nutzungsrecht des Anwenders für dieses Produkt. Die WIBU-BOXen wurden, wo anwendbar, mit einem abgeschirmten Verbindungskabel geprüft und zugelassen. Für den Gebrauch dieses Produkts ist daher ein abgeschirmtes Kabel erforderlich. Ein detailliertes FCC DoC (Declaration of Conformity) ist auf Anfrage erhältlich.


VDE-Zulassung

Die WIBU-BOXen entsprechen den Anforderungen an Produktsicherheit gemäß EN60950 (VDE 0805).


UL-Zulassung

Die WIBU-BOXen wurden erfolgreich den UL94 Tests für Brennbarkeit der Kunststoffe in Teilen und Geräten unterzogen. Die WIBU-BOXen entsprechen den Anforderungen der UL1950 (Safety of Information Technology Equipment) und sind UL (Underwriters Labaratories) gelistet.


VDE-Zulassung

Die WIBU-BOXen entsprechen den Anforderungen an Produktsicherheit gemäß VCCI in Japan (Voluntary Control Council for Interference by Information Technology Equipment).


WIBU-KEY FAQ

WIBU-KEY FAQs und Problemlösungen

Im folgenden Link finden Sie die Antworten auf die Fragen, die von unseren Kunden am häufigsten gestellt werden. Um die Suche zu vereinfachen, sind die Antworten in mehrere Bereiche aufgeteilt:
Aktuelle Seite der FAQs (Internetverbindung wird benötigt)
Support

Unseren Kunden und Endkunden steht ein professionelles Team bestens geschulter Mitarbeiter vom ersten Schritt an zur Seite. Der direkte Kontakt ermöglicht es uns, Wünsche und Anregungen schnell zu erfüllen.
Als Anwender oder Entwickler erhalten Sie unsere kompetente Unterstützung zu Ihrem jeweiligen Anliegen.
Als Endanwender helfen wir Ihnen gerne im Problemfall. Bitte beachten Sie unsere Supportzeiten und wählen Sie bitte von 8.00 bis 12.00 und von 13.00 bis 17.00 die Telefonnummer +49-721-93172-15 für Endkunden bzw. +49-721-93172-14 für Kunden oder schicken Sie einfach eine E-Mail an support@wibu.de.


WIBU-KEY Remote Programming Remote aus dem Windows-Explorer heraus

Remote Programming mit dem Windows Explorer

Mit der rechten Maustaste kann im Windows Explorer eine Remote-Update-Datei erzeugt werden:
  • Im Windows Explorer einen geeigneten Ordner, in dem die zu erzeugende Datei gespeichert werden soll, auwählen und mit der rechten Maustaste ins Explorerfenster des geöffneten Ordners klicken.
  • Aus dem Kontextmenü "Neu" und anschließend "WIBU Control File" auswählen.
  • In der nachfolgenden Dialogbox "WIBU-BOX Remote Programming Context file" wählen und mit Create bestätigen.
Im gleichen Ordner wird eine Datei MyWibuBox.wbc generiert.
Diese Datei wird an den Softwarehersteller gesendet (z.B. per Email, Diskette etc.).
Mit Hilfe dieser wbc-Datei kann nun der Softwarehersteller eine neue Datei generieren, welche die WIBU-BOX umprogrammieren kann.

Mit einem Doppelklick auf die Remote-Update-Datei wird diese Datei ausgeführt und die WIBU-BOX aktualisiert.


WIBU-KEY Remote Programming Remote mit WIBU-KEY Kontrollfeld

Remote Programming mit dem WIBU-KEY Kontrollfeld

WIBU-BOXen lassen sich auch nach wir vor mit dem WIBU-KEY Kontrollfeld umprogrammieren:
  • Erzeugen einer Remote-Kontext-Datei.
  • Aktualisieren der WIBU-BOXen mit einer Remote-Update-Datei.


WIBU-KEY Kontrollfeld Übersicht

WIBU-KEY Kontrollfeld

Übersicht:
Das WIBU-KEY Kontrollfeld
Seite Inhalt
Seite Test
Seite Server
Seite Server Zugriff
Seite Server WkNet
Seite Netzwerk
Seite WIBU-BOX Kontext
Seite WIBU-BOX Aktualisieren
Seite Einstellungen
Seite Installation
Seite Diagnose

Seite Info


WIBU-KEY Kontrollfeld

Das zentrale Kontrollinstrument für den Zugriff auf WIBU-BOXen ist das WIBU-KEY Kontrollfeld in der Windows Systemsteuerung. Das WIBU-KEY Kontrollfeld ist sowohl für den Softwareentwickler wie auch für den Benutzer einer mit WIBU-KEY geschützten Anwendung gedacht. Die Kontrolfeld-Datei WIBUKE32.CPL ist für die 32bit Betriebssysteme Windows 95/98/ME/NT//2000/XP/Server 2003. Je nach Betriebssystem und Benutzerrechten eines Anwenders stellt es auf verschiedenen Seiten die folgende Funktionen zur Verfügung:

Beim Starten des WIBU-KEY Kontrollfelds werden die vier wichtigsten Seiten angezeigt:

Inhalt Anzeige der lokal am PC angeschlossenen WIBU-BOXen und/oder die im Netzwerk gefundenen WIBU-BOXen.

Netzwerk Netzwerkeinstellungen für den Client (lokaler PC).

Installation Installierte Treiber.

Info Informationen über die Version des WIBU-KEY Kontrollfelds.

Um alle Seiten des WIBU-KEY Kontrollfelds zu nutzen, mussen in den sogenannten "Expertenmodus" gewechselt werden.
Hierfür wird im das Systemmenü des WIBU-KEY Kontrollfelds (oder per Rechtsklick auf die Titelleiste) die Option "Expertenmodus" aktiviert.

Nun werden alle Seiten des WIBU-KEY Kontrollfelds angezeigt.

Inhalt Anzeige der lokal am PC angeschlossenen WIBU-BOXen und/oder die im Netzwerk gefundenen WIBU-BOXen.
Test WIBU-BOX Funktiontest.
Server Konfiguration von Cluster Namen, HLM Dateien und WkLAN Servereinstellungen.
Server Zugriff Konfiguration der Clientzugriffsberechtigungen.
Server WkNet WkNet Serverprozesskonfiguration.
Netzwerk Konfiguration der Netzwerkeinstellungen.
WIBU-BOX Kontext Speichern des Inhalts einer WIBU-BOX in eine Datei.
WIBU-BOX Aktualisieren WIBU-BOX über eine Remote-Programming-Update-Datei aktualisieren.
Einstellungen Schnittstellenkonfiguration.
Installation Installierte Treiber.
Diagnose Diagnose und Reportmeldungen des Treibers.

Info Informationen über die Version des WIBU-KEY Kontrollfelds.


WIBU-KEY Kontrollfeld -INHALT-

Seite Inhalt

Die Inhaltsseite ist die erste und für die meisten Benutzer auch die wichtigste Seite des WIBU-KEY Kontrollfeldss. Auf dieser Seite werden die WIBU-BOXen aufgelistet, die lokal an diesem Rechner gefunden werden.
Um eine WIBU-BOX an einem WIBU-KEY Netzwerk Server anzeigen zu lassen, muss zunächst auf das Symbol Netzwerk doppelgeklickt werden. Nun wird das Netzwerk nach erreichbaren WIBU-KEY Servern durchsucht und diese angezeigt.

Über die Anschlussliste kann eine WIBU-BOX ausgewählt und über die Schaltfläche Bearbeiten deren User-Dateneinträge und Konfiguration geändert werden. Neu angesteckte WIBU-BOXen können mit der Schaltfläche Einlesen sichtbar gemacht werden. Mit der Anzeige der Eigenschaften (Adresse usw.) eines Anschlusses können Änderungen an den Einstellungen überprüft werden.
Das WIBU-KEY Kontrollfeld erlaubt keine Veränderungen an den geschützten Einträgen der WIBU-BOX!


WIBU-KEY Kontrollfeld-TEST-

Seite Test

Auf der Testseite kann die Funktion der angeschlossenen WIBU-BOXen überprüft werden. Standardmäßig werden alle gefundenen WIBU-BOXen im Testfenster auf der rechten Seite angezeigt. Über die Pfeiltasten können markierte WIBU-BOXen aus dem Testfenster entfernt bzw. in der WIBU-BOX Liste markierte WIBU-BOXen in das Testfenster übertragen werden.

Durch Betätigen von Start wird der Testvorgang gestartet, durch Stop kann er abgebrochen werden. Die Schaltfläche Neu dient zum Zurücksetzen der Fehlerzähler auf Null. Der Funktionstest der ausgewählten WIBU-BOXen erfolgt durch die Übertragung von zufälligen Datenfolgen zur Verschlüsselung und Entschlüsselung. Fehler werden in der letzten Spalte der obigen Liste angezeigt. Der Test läuft unendlich lange, stoppt aber automatisch, wenn die Auswahl der zu testenden Anschlüsse verändert wird. Die Schaltfläche Einlesen sucht nicht nur nach neu angeschlossenen WIBU-BOXen, sie setzt auch den Testzähler und die Fehlerzähler in der Liste wieder zurück. Wenn WIBU-BOXen vom Rechner entfernt werden oder neue WIBU-BOXen angeschlossen werden, muß zuerst die WIBU-BOX Liste über Einlesen aktualisiert werden, bevor mit dem Testen begonnen werden kann.

Die "Diagnose Funktion" des WIBU-KEY Treibers sollte vor der Durchführung von Tests aktiviert werden. Nur so werden eventuell auftretende Fehler auf der Seite Diagnose protokolliert.


WIBU-KEY Kontrollfeld -Server-

Seite Server

Diese Seite dient der Konfiguration des WIBU-KEY WkLAN Servers. Über die Serverseite werden Cluster Namen, HLM Dateien und grundsätzliche WkLAN Einstellungen konfiguriert.
Cluster Name
HLM Dateien
Einstellungen für WkLAN


WIBU-KEY Kontrollfeld -Cluster Name-

Cluster Name
Das Feld Cluster Name definiert für ein Firm Code/User Code-Paar einen Cluster Namen. Sie können Namen hinzufügen, verändern oder löschen. Pro Firm Code/User Code-Paar ist nur ein Cluster Name möglich.


WIBU-KEY Kontrollfeld - HLM-Dateien -

HLM Dateien
Das Feld HLM Dateien erlaubt die Verwendung von Huge License Management Dateien. Sie können einen Dateinamen eingeben oder mit dem "..."-Button nach Dateien suchen. Um zu testen ob die angegebene Datei gültig ist, können Sie den "Test"-Button drücken.

Huge License Managment Dateien können nur vom jeweiligen Softwarehersteller erzeugt werden, bitte vergewissern Sie sich ob der Softwarehersteller Sie zur Benutzung einer "*.wbb" Datei auffordert.


WIBU-KEY Kontrollfeld -Einstellungen für WkLAN-

Einstellungen für WkLAN
Die CheckBox WKLAN aktiviert den WkLAN Serverprozess. Ist die CheckBox deaktiviert, kann nicht mehr per TCP/IP auf den Server zugegriffen werden. Für den Zugriff über das Subsystem WkLAN können auf der Serverseite drei weitere Parameter festgelegt werden:
  • Wenn die Option Zugriff auf FSB aktiviert ist, sind über das Netzwerk Zugriffe auf Firm-Codes im Bereich von 90 - 99 gestattet, die für Firm-Security-Boxen (FSB) reserviert sind. Für diese Option muss eine Firm-Security-Box an den WkLAN-Server angeschlossen sein. Jeder Benutzer kann dann über das Netzwerk auf diese FSB zugreifen, um beispielsweise WIBU-BOXen zu programmieren.
  • Die aktivierte Option Keine WIBU-BOX-Programmierung verhindert, dass an den WkLAN-Server angeschlossene WIBU-BOXen von anderen Computern aus umprogrammiert werden können.
  • Der Timeout Wert gibt an, nach welcher Zeit in Minuten eine nicht mehr benutzte WkLAN-Lizenz vom WIBU-KEY-Server wieder freigegeben wird. Der Default-Wert ist 1440 Minuten (24 Stunden).


WIBU-KEY Kontrollfeld -Server-Zugriff-

Seite Server Zugriff

Diese Seite dient der Konfiguration der Client Zugiffsberechtigung des WkLAN Servers. Hier können einzelnen Client-PCs über die IP-Adresse oder den Hostnamen des Clients verschiedene Zugriffberechtigungen zuorden:
  • Lesen: erlaubt das Auslesen des WIBU-KEY Servers vom Client aus, Server wird im WIBU-KEY Kontrollfeld und dem Netzwerkmonitor angezeigt.
  • Lizenz belegen: erlaubt dem Client eine Netzwerklizenz zu belegen.
  • Benutzer löschen: erlaubt dem Client über den WIBU-KEY Netzwerkmonitor, Benutzer auf dem WIBU-KEY Server zu löschen.
Die Standardeinstellung ist so gewählt, das alle Clients alle Rechte auf dem WIBU-KEY Server haben.
Server Zugriff über die Registry administrieren


WIBU-KEY Kontrollfeld -SERVER WKNET-

Seite Server WkNet

Diese Seite dient der Konfiguration des WkNet-Servers.
Einstellungen für WkNet


WIBU-KEY Kontrollfeld -WkNet Konfiguration-

Konfiguration von WkNet
Im WkNet-Teil der Serverseite können Sie die folgenden Parameter für den WkNet-Server eingestellt werden:
  • Die Aktiv-Check-Box aktiviert das WkNet Subsystem des WIBU-KEY Servers. Ist diese Box deaktiviert, sind die WkNet spezifischen Einstellungen nicht sichtbar und können nicht bearbeitet werden.
  • Das Feld Firm-Code/User-Code enthält die Verschlüsselungsparameter, die für den WkNet-Prozeß gelten. Diese Parameter müssen in einer WIBU-BOX an diesem Server vorhanden sein.
  • Über die Serverdatei erfolgt die Kommunikation zwischen WkNet-Server und den Clients. Die WkNet-Serverdatei kann auf einem beliebigen Computer im Netzwerk liegen. Es muss nur sichergestellt sein, dass sowohl WkNet-Server als auch alle Clients lesend und schreibend auf diese Datei zugreifen können. Über die Schaltfläche Suchen können Sie ein Windows-Dialogfenster öffnen.
  • Die Refresh Time gibt in Sekunden an, wie oft der WkNet-Server den Inhalt der Server-Datei aktualisiert. Mögliche Werte liegen zwischen 10 Sekunden und 1 Stunde. Der Standardwert ist 10 Sekunden.

 Es reicht nicht, die Refresh Time beim WkNet-Server zu ändern. Die geschützte Anwendung muss auch an den geänderten Wert angepasst werden.
Alle folgenden Angaben sollten Ihnen von Softwarehersteller mitgeteilt werden, da diese genau auf die verschlüsselte Anwendung abgestimmt sind!
  • Der Timeout-Wert gibt an, nach welcher Zeit der WkNet-Server Arbeitsstationen, die nicht mehr auf die Serverdatei zugreifen, aus seiner Liste streicht. Der Standardwert für diesen Eintrag ist 30 Minuten. Der Bereich des Timeout-Werts ist abhängig von der gewählten Refresh Time. Der Timeout-Wert muss mindestens das Dreifache und kann maximal das 249-fache des Wertes der Refresh Time betragen. Ist dieser Wert nicht gesetzt, werden Einträge in der Serverdatei nicht freigegeben.
  • Der Selection-Code geht als Parameter in die Verschlüsselung mit ein. Dieser Wert wird nicht in der WIBU-BOX gespeichert. Da dieser Wert auch in der Anwendung verwendet werden muss, gibt ihn der Softwarehersteller vor. Der Standardwert ist 1234.
Ein WkNet-Server kann mehrere Serverdateien gleichzeitig überwachen. Über die Schaltfläche Hinzufügen übertragen Sie die Werte in den Eingabefeldern in die Liste, über Entfernen löschen Sie markierte Einträge aus der Liste und über Ändern aktualisieren Sie markierte Einträge.


WIBU-KEY Kontrollfeld -NETZWERK-

Seite Netzwerk

Die "Netzwerkseite" dient zur Konfiguration der Arbeitsstationen (Clients), die mit WkNet- oder WkLAN-Servern über das Netzwerk kommunizieren sollen.
Der obere Teil der Seite zeigt die Einstellungen für die Suche nach WkNet-Servern an, im unteren Teil werden die Einstellungen für die Suche nach WkLAN-Servern dargestellt.

Einstellungen für WkNet
Einstellungen für WkLAN
Einstellungen für Subsysteme


WIBU-KEY Kontrollfeld -Einstellungen für WkNet-

Einstellungen für WkNet
Damit eine Anwendung auf eine WIBU-BOX an einem WkNet-Server zugreifen kann, muss bekannt sein, welche Serverdatei zur Kommunikation verwendet wird. Die Anwendung übergibt dem WIBU-KEY Treiber daher den Namen der Anwendung. Der Treiber greift dann auf die dem Namen zugeordnete WkNet-Server-Datei zu. Auf der Netzwerkseite können diese Zuordnungen zwischen Anwendung und WkNet-Server-Datei eingestellt werden. Über die Schaltfläche Hinzufügen werden die Werte in den Eingabefenstern in die Liste übertragen, über Entfernen können Einträge wieder entfernt werden. Ändern dient zur Modifikation von Einträgen. Über die Schaltfläche Suchen kann ein Windows-Dialog zur Suche nach der WkNet-Server-Datei geöffnet werden.

DrvTest H:\WIBUKEY\WKNET\WKNET.DAT

Die "WkNet-Datei" und der "WkNet-Name" der Anwendung wird Ihnen vom Softwarehersteller mitgeteilt. Bitte verwenden Sie genau diese Angaben.

Im Beispieleintrag wird der Anwendung mit dem Name DrvTest die WkNet-Server-Datei H:\WIBUKEY\WKNET\WKNET.DAT zugewiesen.


WIBU-KEY Kontrollfeld -Einstellungen für WkLAN-

Einstellungen für WkLAN

Im oberen Auswahlfeld können Sie definieren ob die folgenden Einstellungen nur für den aktuellen Benutzer oder für den ganzen Computer (alle Benutzer) gelten sollen. Beim Einsatz in einer Domäne ist die Einstellung "Computer" vorzuziehen. Sie benötigen hierfür aber lokale Administratorrechte.

Sowie bei WkNet bekannt sein muss, auf welche WkNet-Server-Datei zugegriffen werden soll, muss bei WkLAN ein WkLAN-Server im Netzwerk gefunden werden. In der WkLAN-Server-Suchliste können Rechnernamen oder IP-Adressen angegeben werden, unter denen nach einem WkLAN-Server gesucht werden soll. Wenn Rechnernamen verwendet werden, muss sichergestellt sein dass ein Namenservice wie DNS (Domain Name Service) oder WINS (Windows Name Service) installiert ist, der die Zuordnung zwischen Rechnername und IP-Adresse übernimmt. Die Angaben müssen lediglich von der eingesetzten TCP/IP Implementierung unterstützt werden.
Falls kein Server gesetzt ist, wird intern die Standardeinstellung 255.255.255.255 (Broadcast) benutzt. Dieser Broadcast bezieht sich nur auf das lokale Netzwerk und wird nicht über Router hinweg weitergegeben.
Über die Schaltfläche Hinzufügen werden die Werte in den Textfenstern in die Liste übertragen, über Entfernen können Einträge wieder entfernt werden. Ändern dient zur Modifikation von Einträgen. Über die Schaltfläche Suchen wird das Netzwerk nach WkLAN-Servern durchsucht, die dann in einer Liste angezeigt werden. Über die Schaltflächen Auf und Ab kann die Reihenfolge der Serveradressen geändert werden.
Die WIBU-KEY-Treiber gehen die Liste von oben nach unten durch und benutzen den ersten WkLAN-Server, in dem der gesuchte Eintrag gefunden wird.

10.10.10.13
10.10.10.147
10.10.10.123
Bei diesen Beispieleinstellungen würde zuerst auf dem Rechner mit der IP-Adresse 10.10.10.13 nach einem WkLAN-Server gesucht werden, danach auf dem Rechner 10.10.10.147 und als letztes auf dem Rechner mit der IP-Adresse 10.10.10.123.

Neben den Einstellungen für die Suche nach WkLAN-Servern kann man auf der Netzwerkseite auch die WkLAN-Port-Adresse für die Kommunikation mit dem WkLAN-Server einstellen. Standardmäßig benutzt WkLAN TCP/UDP Port 22347 um auf einen WkLAN-Server zuzugreifen. Sollte der Port bereits durch einen anderen Prozess belegt sein, kann sie an dieser Stelle geändert werden. Diese Änderung muß gleichzeitig auch für den WkLAN-Server vorgenommen werden, sonst scheitert jede Kommunikation zwischen Anwendung und Server.


WIBU-KEY Kontrollfeld -Einstellungen für Subsysteme-

Einstellungen für Subsysteme
WIBU-KEY verwendet drei verschiedene Subsysteme:
  • Kernel (Zugriff auf lokale WIBU-BOXen)
  • WkLAN (Protokollbasierter (TCP/IP) Zugriff auf WIBU-BOXen über Netzwerk)
  • WkNet (Dateibasierter Zugriff auf WIBU-BOXen über Netzwerk)
Auf der Netzwerkseite kann angegeben werden, in welchen Subsystemen und in welcher Reihenfolge gesucht werden soll. Ein Haken vor der Option bedeutet, das dieses Subsystem für die Suche aktiviert ist. Über die Schaltflächen Auf und Ab kann die Suchreihenfolge der Subsysteme geändert werden.


WIBU-KEY Kontrollfeld -Kontext-

Seite WIBU-BOX Kontext

Die Seite WIBU-BOX Kontext dient zum Erzeugen von Remote-Programming-Kontextdateien (.RTC), diese Dateien beinhalten den verschlüsselten Kontext der angeschlossenen WIBU-BOXen.
Diese Seite bildet dadurch eine der Benutzerschnittstellen zum Erzeugen dieser Dateien.

Standardmäßig werden alle gefundenen WIBU-BOXen im Fenster auf der rechten Seite angezeigt. Über die Pfeiltasten können markierte WIBU-BOXen aus dem Fenster entfernt werden bzw. in der WIBU-BOX Liste markierte WIBU-BOXen in das Fenster übertragen werden.
Befindet sich mindestens eine WIBU-BOX im Fenster "Selektierte WIBU-BOXen:" und wurde ein korrekter Dateiname eingegeben, wird die Schaltfläche Übernehmen aktiviert. Wird Übernehmen betätigt, wird der Inhalt der selektierten WIBU-BOXen in verschlüsselter Form in die angegebene Datei geschrieben. Wenn die Aktion erfolgreich abschlossen wurde, erscheint ein "Hinweisfenster" mit der Nachricht wieviele Bytes geschrieben wurden.
Wird die Option nur leere Einträge aktiviert, werden in der Kontextdatei nicht die vorhandenen Dateneinträge gespeichert, sondern nur eine Liste der noch nicht belegten Einträge. Die Größe der Datei wird dadurch reduziert.
Über die Option An vorhandene Datei anhängen kann gesteuert werden, ob eine neue Datei geschrieben werden soll, oder ob die Daten an eine bereits vorhandene Kontextdatei angehängt werden sollen.
Das WIBU-KEY Kontrollfeld bemerkt nicht von selbst, wenn WIBU-BOXen abgezogen oder neue WIBU-BOXen angeschlossen werden. Es ist daher immer notwendig, die WIBU-BOX Liste durch Betätigen der Schaltfläche Einlesen zu aktualisieren.


WIBU-KEY Kontrollfeld -Aktualisieren-

Seite WIBU-BOX Aktualisierung

Die Seite WIBU-BOX Aktualisierung dient zum Einlesen von Remote Programming Update-Dateien zum Umprogrammieren von WIBU-BOXen. Diese Seite bildet damit das Gegenstück zur "Kontextseite".

Standardmäßig werden alle gefundenen WIBU-BOXen im Fenster auf der rechten Seite angezeigt. Wie bei der Kontext-Seite können über die Pfeiltasten markierte WIBU-BOXen aus dem Fenster entfernt werden bzw. in der WIBU-BOX Liste markierte WIBU-BOXen in das Fenster übertragen werden. Befindet sich mindestens eine WIBU-BOX im Fenster der selektierten WIBU-BOXen und wurde ein korrekter Dateiname angegeben, wird die Schaltfläche Übernehmen aktiviert. Wird Übernehmen betätigt, wird die Remote Programming Update Datei gelesen und die entsprechenden WIBU-BOXen werden umprogrammiert. Wenn die Aktion erfolgreich abschlossen wurde, erscheint ein Hinweisfeld mit der Nachricht, dass eine oder mehrere WIBU-BOXen umprogrammiert wurden.
Es können nur genau die WIBU-BOXen umprogrammiert werden, die in der Remote-Programming-Update-Datei aufgeführt sind. Die Liste dient dazu, die Anzahl der WIBU-BOXen weiter einzuschränken, zusätzlich WIBU-BOXen können dadurch nicht umprogrammiert werden. Weiterhin kann eine WIBU-BOX mit einer bestimmten Remote Programming Update Datei nur genau einmal umprogrammiert werden, eine Wiederholung ist nicht möglich!
Wird die Option Nach Benutzung löschen aktiviert, wird die Remote Programming Update Datei nach erfolgreichem Programmieren der WIBU-BOXen gelöscht.


WIBU-KEY Kontrollfeld -Einstellungen-

Seite Einstellungen

Auf dieser Seite können alle Einstellungen betreffend der Suche nach WIBU-BOXen und die Konfiguration der einzelnen Schnittstellen durchgeführt werden. Wenn alle WIBU-KEY Treiber richtig installiert sind und trotzdem keine WIBU-BOXen gefunden werden, sollte man die Einstellungen auf dieser Seite als erstes überprüfen.

Für einen Windows PC können verschiedene WIBU-BOX Typen verwendet werden:
die WIBU-BOX/P(+) bzw. /RP(+) für die parallele Schnittstelle,
die WIBU-BOX/SP und /ST für die serielle Schnittstelle,
die WIBU-BOX/U(+) bzw. /RU(+) für die USB-Schnittstelle,
die WIBU-BOX/M als PC Card und
die WIBU-BOX/CI als Einsteckkarte (ISA), die aber über die parallele Schnittstelle angesprochen wird.

In diesem Kapitel werden die Konfigurationsattribute für die verschiedenen WIBU-BOX Varianten vorgestellt.

Allgemeine Einstellungen
Besondere Einstellungen für die WIBU-BOX/P(+) bzw. WIBU-BOX/RP(+)
Besondere Einstellungen für die WIBU-BOX/SP und /ST
Besondere Einstellungen für die WIBU-BOX/U bzw. WIBU-BOX/RU
Besondere Einstellungen für die WIBU-BOX/M
Besondere Einstellungen für die WIBU-BOX/CI


WIBU-KEY Kontrollfeld -Allgemeine Einstellungen-

Allgemeine Einstellungen
Die wichtigste Einstellung, die für jede WIBU-BOX Variante vorhanden ist, ist die Option Aktiviert, mit welcher der Zugriff auf die entsprechende Schnittstelle freigeschaltet wird.

Die Einstellung Wartezeit bei belegtem Anschluss gibt die maximale Zeit in Sekunden (mit Auflösung in Millisekunden) an, die der WIBU-KEY Treiber wartet, bis ein anderer Treiber einen benötigten Anschluss freigibt. Wird diese Zeit überschritten, beendet der Treiber den Zugriff und eine angeschlossene WIBU-BOX wird nicht gefunden.

Wenn das Feld Delay Factor gesetzt ist, verlangsamt er die Hardwarekommunikation. Dieser Wert wird nur sehr selten benötigt und sollte nur von erfahrenen Benutzern oder in Absprache mit Support-Mitarbeitern gesetzt werden.


WIBU-KEY Kontrollfeld -Besondere Einstellungen BOX/P-

Besondere Einstellungen für die WIBU-BOX/P, WIBU-BOX/P+, WIBU-BOX/RP und WIBU-BOX/RP+
In der Gruppe Anschlussposition können für die parallelen Schnittstellen die Anschlussadresse (I/O port address) und für Windows NT/2000/XP/Server 2003 der Bustyp und der Index festgelegt werden. Standardmäßig ist die Option Systemstandard aktiviert, wodurch die WIBU-KEY Treiber die entsprechenden Werte vom Betriebssystem übernehmen. In bestimmten Fällen kann es aber vorkommen, dass das Betriebssystem die Schnittstelle nicht richtig erkennt oder aus anderen Gründen eine falsche oder keine Adresse an die WIBU-KEY Treiber zurückliefert. In diesem Fall muss die Schnittstellenadresse manuell eingetragen werden. Typische Schnittstellenadressen sind 0x378 für LPT1, 0x278 für LPT2 und 0x3BC für LPT3. Oft sind die Adressen für LPT1 und LPT2 vertauscht.
Die Schnittstellenadressen (E/A Bereich) können im Gerätemanager des Betriebsystems überprüft werden. Viele moderne BIOS-Versionen zeigen beim Start des Rechners die Anschlussadressen in einem Fenster an. Meistens kann man die Anschlussadressen auch im BIOS-Setup umkonfigurieren.

In der Gruppe Anschlusseinstellungen gibt es neben Aktiviert weitere Optionen:
  • Geteilt mit gleichzeitigem Druckerzugriff regelt den konkurrierenden Zugriff mehrerer Anwendungen auf eine parallele Schnittstelle. Normalerweise sollte jede Anwendung vor dem Zugriff auf eine Schnittstelle das Betriebssystem um Erlaubnis fragen. Greift bereits eine andere Anwendung auf diese Schnittstelle zu, wird der Zugriff verweigert. Die WIBU-KEY Treiber warten dann für die Wartezeit bei belegtem Anschluß und versuchen erneut auf die Schnittstelle zuzugreifen. Wird der Zugriff wieder abgelehnt, wird eine entsprechende Fehlermeldung an die Anwendung zurückgegeben. Wird der Zugriff auf die Schnittstelle gestattet, belegt der WIBU-KEY Treiber für die Dauer der Kommunikation mit der WIBU-BOX die Schnittstelle und gibt sie danach wieder frei. Unglücklicherweise gibt es einige Programme die sich nicht an diese Regel halten: Diese Programme belegen zwar die Schnittstelle, geben diese aber nicht mehr frei. Um trotz solcher Programme noch mit der WIBU-BOX kommunizieren zu können wurde die Option Geteilt mit gleichzeitigem Druckerzugriff eingeführt. Ist die Option aktiviert, wird die Anfrage beim Betriebssystem nicht durchgeführt, sondern der Treiber greift direkt auf die Schnittstelle zu. Es kann dabei aber zu Zugriffskonflikten und Übertragungsfehlern kommen. Standardmäßig ist die Option daher abgeschaltet.
  • Nur UD-Modus bestimmt, dass der Treiber nur im unidirektionalen Modus sucht. Das heißt, dass auch nur WIBU-BOX/P bzw. /RP gefunden werden, deren Konfigurationsattribut auf unidirektional steht. WIBU-BOXen im bidirektionalen Modus werden nicht gefunden. Standardmäßig ist sowohl diese Option als auch die Option nur BD-Modus abgeschaltet, wodurch der Treiber in beiden Modi nach WIBU-BOXen sucht.
Die WIBU-BOXen der Version 1 (silberfarbenes Gehäuse) kennen nur den unidirektionalen Modus.
  • Nur BD-Modus bestimmt, dass der Treiber nur im bidirektionalen Modus sucht. Das heißt, daß auch nur WIBU-BOX/P(+) bzw. /RP(+) gefunden werden, deren Konfigurationsattribut auf bidirektional steht. WIBU-BOXen im unidirektionalen Modus werden nicht gefunden. Standardmäßig ist die Option abgeschaltet. Bitte beachten Sie auch die Erklärung zum Unidirektionalen Modus (UD).


WIBU-KEY Kontrollfeld -Besondere Einstellungen BOX/SP und /ST-

Besondere Einstellungen für die WIBU-BOX/SP und /ST
In der Gruppe Anschlussposition können für die seriellen Schnittstellen die Anschlussadresse (I/O port address) und für Windows NT/2000/XP/Server 2003 der Bustyp und der Index festgelegt werden. Standardmäßig ist die Option Systemstandard aktiviert, wodurch die WIBU-KEY Treiber die entsprechenden Werte vom Betriebssystem übernehmen. In bestimmten Fällen kann es aber vorkommen, dass das Betriebssystem die Schnittstelle nicht richtig erkennt oder aus anderen Gründen eine falsche oder keine Adresse an die WIBU-KEY Treiber zurückliefert. In diesem Fall muss die Schnittstellenadresse manuell eingetragen werden. Typische Schnittstellenadressen sind 0x3F8 für COM1, 0x2F8 für COM2, 0x3E8 für COM3 und 0x2E8 für COM4. Viele modernen BIOS-Versionen zeigen beim Start des Rechners die Anschlussadressen in einem Fenster an. Meistens kann man die Anschlussadressen auch im BIOS-Setup umkonfigurieren.

In der Gruppe Anschlusseinstellungen gibt es neben Abgeschaltet folgende weitere Optionen:
  • RTS ständig eingeschaltet bedeutet, dass der WIBU-KEY Treiber die Leitung RTS der seriellen Schnittstelle immer auf high setzt. Normalerweise ist die Option nicht aktiviert. Sie sollte erst dann eingeschaltet werden, wenn eine WIBU-BOX/SP oder /ST an der seriellen Schnittstelle nicht erkannt wird. Eine der Ursachen kann eine zu schwache Spannungsversorgung sein. Über eine aktivierte RTS-Leitung steht einer WIBU-BOX/SP eine weitere Leitung für Versorgungsspannung bereit, wodurch eine WIBU-BOX oft wieder erkannt wird.
  • DTR ständig eingeschaltet bedeutet, dass der WIBU-KEY-Treiber die Leitung DTR der seriellen Schnittstelle immer auf high setzt. Diese Option erfüllt die gleiche Aufgabe wie auch das ständige Einschalten der RTS-Leitung, nur dass eine andere Leitung verwendet wird. Standardmäßig ist diese Option nicht aktiviert.
  • Geteilt mit geleichzeitigem Modem-/Mauszugriff regelt den konkurrierenden Zugriff mehrerer Anwendungen auf eine serielle Schnittstelle. Normalerweise sollte jede Anwendung vor dem Zugriff auf eine Schnittstelle das Betriebssystem um Erlaubnis fragen. Greift bereits eine andere Anwendung auf diese Schnittstelle zu, wird der Zugriff verweigert. Die WIBU-KEY Treiber warten dann für die Wartezeit bei belegtem Anschluß und versuchen erneut auf die Schnittstelle zuzugreifen. Wird der Zugriff wieder abgelehnt, wird eine entsprechende Fehlermeldung an die Anwendung zurückgegeben. Wird der Zugriff auf die Schnittstelle gestattet, belegt der WIBU-KEY Treiber für die Dauer der Kommunikation mit der WIBU-BOX die Schnittstelle und gibt sie danach wieder frei. Unglücklicherweise gibt es einige Programme die sich nicht an diese Regel halten: Diese Programme belegen zwar die Schnittstelle, geben diese aber nicht mehr frei. Um trotz solcher Programme noch mit der WIBU-BOX kommunizieren zu können wurde die Option Geteilt mit gleichzeitigem Modem-/Mauszugriff eingeführt. Ist die Option aktiviert, wird die Anfrage beim Betriebssystem nicht durchgeführt, sondern der Treiber greift direkt auf die Schnittstelle zu. Es kann dabei aber zu Zugriffskonflikten und Übertragungsfehlern kommen. Standardmäßig ist die Option daher abgeschaltet.
  • Nur /SP bewirkt, daß nur nach WIBU-BOX/SP gesucht wird. Ist diese Option aktiviert, werden keine WIBU-BOX/ST gefunden. Sie ist standardmäßig abgeschaltet
  • Nur /ST bewirkt, daß nur nach WIBU_BOX/ST gesucht wird. Ist diese Option aktiviert, werden keine WIBU-BOX/SP gefunden. Sie ist standardmäßig abgeschaltet


WIBU-KEY Kontrollfeld -Besondere Einstellungen BOX/U-

Besondere Einstellungen für die WIBU-BOX/U, WIBU-BOX/U+, WIBU-BOX/RU und WIBU-BOX/RU+
Unter Windows 98/ME/ 2000/XP/Server 2003 kann man den Zugriff auf eine WIBU-BOX/U, WIBU-BOX/U+, WIBU-BOX/RU, bzw. WIBU-BOX/RU+ nur ein- oder abschalten.

Unter Windows 95 und Windows NT ist die Verwendung einer WIBU-BOX/U bzw. /RU nicht möglich!


WIBU-KEY Kontrollfeld -Besondere Einstellungen BOX/M-

Besondere Einstellungen für die WIBU-BOX/M
Unter Windows 98/ME/2000/XP/Server 2003 kann man den Zugriff auf eine WIBU-BOX/M nur ein- oder abschalten.


WIBU-KEY Kontrollfeld -Besondere Einstellungen BOX/CI-

Besondere Einstellungen für die WIBU-BOX/CI
Vom PC aus wird die WIBU-BOX/CI genauso wie eine WIBU-BOX/P angesprochen. Da die WIBUBOX/CI vom BIOS aber nicht als parallele Schnittstelle erkannt wird, muss man die Anschlussadresse von Hand unter einer der parallelen Schnittstellen eintragen. Die Anschlussadresse kann man über Steckbrücken (Jumper) auf der Karte festlegen. Standardmäßig liegt die Adresse bei 0x330H, möglich ist eine von 16 Möglichkeiten im Bereich von 0x230 bis 0x33C.


WIBU-KEY Kontrollfeld -Installation-

Seite Installation

Auf der Seite "Installation" können die WIBU-KEY Treiber installiert, deinstalliert und überprüft werden.

Welche Treiberkomponenten für welches Betriebssystem benötigt werden finden Sie in dieser Liste.
Die Liste der installierten Komponenten zeigt alle installierten WIBU-KEY Treiberkomponenten an. Ist eine Komponente ordnungsgemäß installiert, wird sie durch ein "Häkchen" markiert und die Versionsnummer wird angezeigt. Weiter unten auf der Seite wird eine kurze Beschreibung dieser Treiberkomponenten angezeigt, zusammen mit der Größe der Datei. Der Speicherplatzbedarf aller Treiber und der freie Speicherplatz auf dem Systemlaufwerk werden ebenfalls angezeigt.
Ist eine Komponente nicht durch einen Häkchen markiert, ist sie entweder nicht oder nicht an der richtigen Stelle installiert.
Aktivieren/Deaktivieren des WIBU-KEY-Kerntreibers
Plug&Play - Button
Installieren/Aktualisieren von WIBU-KEY-Treibern
Entfernen von WIBU-KEY-Treibern


WIBU-KEY Kontrollfeld -Aktivieren / Deaktivieren des WIBU-KEY-Kerntreibers-

Aktivieren/Deaktivieren des WIBU-KEY Kerntreibers
Dieser Dialog öffnet sich beim Aktivieren des WIBU-KEY Kerntreibers (WIBUKEY.SYS) auf der Installationsseite. In diesem Dialog kann anhand dreier verschiedener Möglichkeiten angegeben werden, wie der Kerntreiber gestartet werden soll. Möchte man den Kerntreiber Deaktivieren, so wird dieser sofort deaktiviert.

Es wird empfohlen die Startart "System startup (Automatic)" zu verwenden!


WIBU-KEY Kontrollfeld -Plug&Play - Button-

Plug&Play Button
Dieser Button setzt die Plug&Play Einstellungen für die WIBU-BOX/U(+), WIBU-BOX/RU(+) oder WIBU-BOX/M zurück. Bevor die Einstellungen zurückgesetzt werden können, muss die WIBU-BOX von der Schnittstelle entfernt werden.
Folgenden Sie nun den Anweisungen des erscheinenden Hinweisfensters. Wird nach dem Neustart des PCs die WIBU-BOX wieder angesteckt, erkennt der Plug&Play Mechanismus automatisch die Hardware und installiert den passenden WIBU-BOX Treiber.


WIBU-KEY Kontrollfeld -Installieren/Aktualisieren von WIBU-KEY-Treibern-

Installieren/Aktualisieren von WIBU-KEY Treibern
Um neue Treiber zu installieren bzw. die aktuellen Treiber durch neuere Treiberversionen zu ersetzen, müssen die entsprechenden Komponenten angehakt werden und der Pfad zu den Quelldateien angegeben werden. Die Quelldateien können auch durch das Microsoft Compress Programm gepackt sein. Durch Betätigen der Schaltfläche Übernehmen werden die entsprechenden Treiber installiert. Falls bei der Installation Probleme auftreten, wird ein entsprechender Dialog angezeigt.

Wichtig:
Von dieser Vorgehensweise wird abgeraten, da so einzelne Systemkomponenten versehentlich nicht ersetzt werden könnten. Alle Anwendungen die WIBU-KEY verwenden sollten geschlossen und die neuen WIBU-KEY Treiber wie auf der Seite "Installation der WIBU-KEY Software" beschrieben installiert werden.


WIBU-KEY Kontrollfeld -Entfernen von WIBU-KEY-Treibern-

Entfernen von WIBU-KEY Treibern
Die installierten WIBU-KEY Treiber lassen sich entfernen, indem man die betreffenden "Active" Makierung entfernt (Häkchen) und Übernehmen betätigt. Die Treiberdateien lassen sich nur entfernen, wenn keine Anwendung (außer dem WIBU-KEY Kontrollfeld selbst) mehr auf sie zugreift.

Wichtig:
Es wird dringend empfohlen die WIBU-KEY Treiber nicht auf diese Weise zu deinstallieren, sondern den auf der Seite "Deinstallation der WIBU-KEY Software" Weg zu verwenden!


WIBU-KEY Kontrollfeld -Diagnose-

Seite Diagnose

Die WIBU-KEY Treiber sind in der Lage, Informationen über Probleme beim Zugriff auf die WIBU-BOX zu protokollieren. Diese Informationen sind keine normalen Fehlermeldungen, sondern liefern ein Zustandsbericht über treiberinterne Vorgänge. Normalerweise ist der Diagnosemodus nicht aktiviert und es werden keine Meldungen ausgegeben. In Problemfällen kann man über die Diagnoseseite den entsprechenden Modus aktivieren und sich die Ergebnisse ausgeben lassen:

Um den Diagnosemodus zu aktivieren, muß die Option Aktiv in der linken unteren Ecke angekreuzt und die Schaltfläche Neu betätigt werden. Alle folgenden Operationen der WIBU-KEY Treiber werden überwacht und Fehlermeldungen protokolliert. Um das Diagnoseprotokoll aus dem Treiber auszulesen Aktualisieren wählen. Ein solches Protokoll kann über Speichern in eine Textdatei gesichert und zusammen mit einer MSD-Diagnosedatei per Email oder auf anderen Wege an den Softwarehersteller bzw. WIBU-SYSTEMS geschickt werden.
Vor einem Test der WIBU-KEY Treiber, sollten Sie die Diagnose aktivieren, auf der Seite Test einen Test der lokalen WIBU-BOXen durchführen und bei auftretenden Fehlern die aktuelle Diagnosedatei speichern.
Mit der Report Schaltfläche wird eine Reportdatei erzeugt, welche die wichtigsten Informationen über die WIBU-KEY Installation sowie die Systemeinstellungen enthält.


WIBU-KEY Kontrollfeld -Info-

Seite Info

Auf dieser Seite werden Informationen über die Version des WIBU-KEY Kontrollfelds, des verwendeten Kerntreibers und der eventuell installierten WIBU-KEY COM Schnittstelle angezeigt.


WIBU-KEY Netzwerk-Server Inhalt

WkSvW - Die WIBU-KEY Netzwerkserver

Inhalt:
Übersicht
WkSvW32 für Win32
WkSvNW für Netware
Konfigurationsoptionen
Wie kann man ...
Problemlösungen


WIBU-KEY Server Übersicht

Übersicht

Der WIBU-KEY Netzwerk-Server ermöglicht den Zugriff auf WIBU-BOXen im Netzwerk. Dies ermöglicht sowohl die Realisierung des Kopierschutzes für eine Anwendung als auch die Festlegung von Benutzern, die auf eine Anwendung zur gleichen Zeit zugreifen können. Ein WIBU-KEY Netzwerkserver kann jeder Computer im Netzwerk sein.

WIBU-KEY bietet mit WkNet und WkLAN zwei verschiedene Methoden um Anwendungen im Netzwerk zu schützen.

Der Schutz mit WkNet basiert auf einer gemeinsamen Datei. Dadurch ist es möglich, WkNet in vielen existierenden Netzwerken (Windows, Novell Netware) zu verwenden.

WkLAN basiert auf der TCP/IP Protokollsuite, die Daten werden unmittelbar zwischen den Arbeitsstationen und dem Server über das Netzwerk übertragen. Die aktuelle Version von WkLAN unterstützt fast alle gängigen Betriebsysteme (Windows 95/98/ME/NT/2000/XP/Server 2003, MacOS 8, 9, X, Linux (IA32)) und ist so für den Einsatz in heterogenen Netzwerken bestens geeignet.
Zur Zeit sind die folgenden Versionen der WIBU-KEY Netzwerkserver verfügbar:
  • WkSvW32.exe eine 32 Bit Windows-Anwendung für Windows 95/98/ME/NT/2000/XP/Server 2003: Diese Anwendung kann unter Windows NT/2000/XP/Server 2003 auch als Dienst installiert werden.
  • WkSvNW.nlm, ein NLM für Novell Netware Server (Version 3.11, 3.12 und 4.01).
  • WkSvMac, eine Anwendung für Mac OS 8+9.
  • WkSvMacX, eine Anwendung für Mac OS X.
  • WkSvLin, eine Anwendung für Linux.


WIBU-KEY Server WkSvW32 für Win32

WkSvW32 für Windows

WkSvW32.EXE, der Serverprozeß für Windows kann auf zwei Arten gestartet werden:
  • Als Anwendung
  • Als Dienst
Unter Windows 95/98/ME kann der WIBU-KEY Server nur als Anwendung gestartet werden!
Nach dem Starten des WIBU-KEY Servers erscheint das Netzwerkserver Icon in der Taskleiste.

Das Kontextmenü (rechte Maustaste) des WIBU-KEY Server bietet folgende Optionen:

Beenden | Beendet die WIBU-KEY Server Anwendung.
Über | Zeigt ein Informationsfenster mit der Version des WIBU-KEY Servers an.
Hilfe | Öffnet die WIBU-KEY Endbenutzerhilfe.
Logging | Aktiviert die Logging Funktion, ist diese Aktiviert wird der WIBU-KEY Server Status in der Datei "WkServer.log" unter [%Programme%\WibuKey\Server] gespeichert.
Dienst deinstallieren | Deinstalliert den WIBU-KEY Server Dienst, falls dieser installiert ist.
Dienst stoppen | Stoppt den WIBU-KEY Server Dienst, falls dieser läuft.
Als Dienst starten | Startet den WIBU-KEY Server als Dienst.
Status | Öffnet ein Fenster mit dem WIBU-KEY Serverstatus. Dieser enthält alle Anfragen an den WIBU-KEY Server und eventuell aufgeteretene Probleme.

Der WIBU-KEY Serverdienst kann auch wahlweise über die Diensteverwaltung des Betriebssystems oder über die Kommandozeile kontrolliert werden:
Kommandozeilen Befehle:

net start wksvw32 startet den Dienst und

net stop wksvw32 stoppt den Dienst.

Eine genaue Beschreibung der Einstellungen folgt im Abschnitt Konfigurationsoptionen. Die einfachste Art, die Einstellungen für den Windows-Serverprozess zu ändern ist die Serverseite des WIBU-KEY Kontrollfelds in der Systemsteuerung.


WIBU-KEY Server WkSvNW für Novell

WkSvNW für Novell Netware

Die Datei WKSVNW.NLM muss in das SYSTEM-Verzeichnis des Servers kopiert werden und kann mit der folgenden Befehlszeile gestartet werden:

LOAD WKSVNW.NLM WibuKeyIniFile [/L:Logfile] [/V3]

Die Datei WIBUKEY.INI wird zur Übergabe der Steuerungsparameter an den Serverprozess verwendet. Diese Datei ist eine lesbare Textdatei und benutzt die Syntax von Windows-INI-Dateien. Eine genaue Beschreibung der Einstellungen befindet sich im Abschnitt Konfigurationsoptionen. Um sicherzugehen, daß WKSVNW.NLM die WkNet-Datei findet, ist es notwendig, den vollständigen Pfad der Datei in der WIBUKEY.INI anzugeben. Beachten Sie bitte, daß Novell Netware keine Laufwerkbuchstaben wie C: verwendet, sondern normalerweise Laufwerksnamen wie SYS: oder DOS:.
WKSVNW.NLM benutzt auch Umgebungseinstellungen aus dem Bereich [DRIVER] der WIBUKEY.INI.

Die Option /V3 aktiviert den erweiterten Modus. Der Server erstellt genauere Fehlerberichte. Diese Option sollte genutzt werden, um weitergehende Informationen bei Problemen mit dem Serverprozeß zu erhalten. In der Grundeinstellung ist diese Option ausgeschaltet.

Die Option /L erlaubt die Angabe einer Logbuchdatei. Alle Ausgaben werden dann nicht mehr auf den Bildschirm sondern in diese Datei ausgegeben. Über einen Texteditor kann man dieses Logbuch von einer beliebigen Arbeitsstation aus betrachten.

Hinweis: WkSvNW kann Anschlußadressen nicht dynamisch bestimmen, um auf die WIBU-BOX zuzugreifen. Stattdessen benutzt der Treiber festgesetzte Adressen, die in der folgenden Tabelle aufgelistet sind:
Anschluss: | Adresse:
LPT1 | 0x3BC
LPT2 | 0x378
LPT3 | 0x278
COM1 | 0x3F8
COM1 | 0x2F8


WIBU-KEY Netzwerk-Server Konfigurationsoptionen

Konfigurationsoptionen

Die Konfigurationseinstellungen werden in der Registry gespeichert. Die wichtigsten Einstellungen können über die WIBU-KEY Systemsteuerungserweiterung eingestellt werden. Die Konfigurationsoptionen für den WIBU-KEY Netzwerkserver sind in fünf Abschnitte unterteilt:
WkNet Konfiguration
Konfiguration von Huge License Management
Treiberkonfiguration (nur WkSvNW)


WIBU-KEY Netzwerk-Server WkNet-Konfiguration

WkNet Konfiguration

Die folgenden Die Konfiguration eines WkNet Servers, sollte auf der Seite Server WkNet des WIBU-KEY Kontrollfeldes durchgeführt werden.
Für den WkNet-Schutz werden nur Abschnitte mit dem Titel in der Form

[WkNet FirmCode:UserCode]

benutzt, in denen Firm-Code und UserCode gültige Firm-Codes und User Codes festlegen, z.B.:
[WkNet 10:13]
ServerFile=dos:\test\wknet.dat
RefreshTime=10
TimeOut=30
Selection=1234
Dieser Abschnitt enthält im folgenden Einträge in der Registry im Verzeichnis [Network].
Schlüsselwort Bedeutung
ServerFile | enthält den vollständigen Pfad der WkNet-Serverdatei, z.B.: d:\srv\wknet.dat
RefreshTime | legt das Zeitintervall in Sekunden fest, in dem die WkNet Serverdatei überarbeitet wird. Ist dieser Eintrag nicht festgelegt, werden 10 Sekunden als Grundeinstellung verwendet.
TimeOut | legt den Zeitraum in Minuten fest, nach dem ein Slot einer WkNet Datei automatisch freigegeben wird, wenn der dazugehörige Prozeß innerhalb des Zeitraums nicht auf den Slot zugegriffen hat. Ist dieser Wert nicht festgelegt, gibt es keine automatische Freigabe von Slots.
Selection | legt den SelectionCode fest, der von der Software benutzt wird, die von WIBU-KEY WkNet geschützt wird. Dieser Wert wird vom Softwarehersteller bestimmt. Als Grundeinstellung wird der Wert 1234 eingesetzt.


WIBU-KEY Server Konfiguration von Huge License Management

Konfiguration von Huge License Management
Eine HLM-Kontrolldatei wird in der Registry im Abschnitt [Server] gespeichert. Unter dem Topic "[Server HLM files]" können Variablen "FileN" angegeben werden. Jeder dieser Variablen wird der Pfad einer HLM-Kontrolldatei zugewiesen.

Die Verwendung von HLM-Dateien lässt sich sehr einfach auf der Server Seite des WIBU-KEY Kontrollfeldes konfigurieren. Dies sollte ausschließlich über diese Seite geschehen!

Die HLM-Einstellungen werden nur beim Start des WIBU-KEY-Servers interpretiert. Wenn die Einstellungen geändert wurden, muß der Server gestoppt und neu gestartet werden, damit die neuen Einstellungen übernommen werden.


WIBU-KEY Netzwerk-Server Treiberkonfiguration

Treiberkonfiguration

Die Konfigurationsoptionen für den Treiber werden nur von WkSvNW, dem WIBU-KEY Netzwerkserver für Novell Netware ausgewertet, weil diese Anwendung einen speziellen Treiber für den Zugriff auf die WIBU-BOX benutzt.

Die folgenden Werte sind im Verzeichnis [Driver] in der Registry gespeichert.
Schlüsselwort Bedeutung
WkCom | bestimmt die Adressen für COM1 bis COM4.
WkLpt | bestimmt die Adressen für LPT1 bis LPT4.
WkPort | legt die Anschlußtypen fest.


WIBU-KEY Netzwerk-Server FAQ / Wie kann man ...

Wie kann man ...

1) ... WkSvW32 als Dienst starten?
2) ... einen Benutzer im Netzwerk löschen?
3) ... eine defekte WkNet Datei reparieren?
4) ... WkSvNW für Novell Netware starten?
5) ... einen WkNet/WkLAN Benutzer konfigurieren?
6) ... einen WkNet/WkLAN Server konfigurieren?

Seitenanfang 1)
Lösung: Starten Sie WkSvW32.exe als Anwendung. Klicken Sie nun mit der rechten Maustaste auf das Icon im System Tray und wählen Sie "Als Dienst starten".

Seitenanfang 2)
Lösung: Einen WkNet/WkLAN Benutzer kann man mit WkSvMon löschen, indem man den Benutzer auswählt und den "Cancel User"-Button drückt oder das entsprechende Symbol in der Menüleiste wählt.

Seitenanfang 3)
Lösung: Es gibt keine Möglichkeit, eine defekte WkNet Datei zu reparieren. Der Server muß gestoppt und die Originaldatei vom Installationsmedium auf die Festplatte kopiert werden.

Seitenanfang 4)
Lösung: Der Serverprozeß WkSvNW muß in den SYS:\SYSTEM Ordner des Netware Server kopiert werden. Dann kann er von der Netware Konsole aus mit der Befehlszeile

LOAD WKSVNW WibuKeyIniFileSpec

gestartet werden. Mehr Informationen finden Sie im Abschnitt WkSvNW.

Seitenanfang 5)
WkNet Benutzer

Normalerweise sollten die Einstellungen während der Installation der geschützten Anwendung vorbereitet werden. In jedem Fall können die Einstellungen auch auf der Seite Netzwerk des WIBU-KEY Kontrollfelds geändert werden.
WkLAN Benutzer

Normalerweise muß ein WkLAN Benutzer nicht konfiguriert werden. Der WIBU-KEY Treiber auf der Benutzerseite (Client) sucht im lokalen Netz und wählt den ersten WkLAN Server mit passenden Einstellungen. Auf der Seite Netzwerk des WIBU-KEY Kontrollfelds kann festgelegt werden, wo nach WkLAN Servern gesucht werden soll. Dadurch ist es auch möglich, WkLAN Server zu finden, die sich nicht im lokalen Netz befinden.

Seitenanfang 6)
WkNet-Server

Für jeden eigenständigen WkNet Prozeß muß in der Datei WIBUKEY.INI ein Abschnitt [WkNet FC:UC] vorhanden sein. Der Aufbau des Abschnitts und die Bedeutung der Parameter werden im Abschnitt WkNet-Konfiguration erklärt.
WkLAN-Server

Ein WkLAN Server muß nicht konfiguriert werden. Als Grundeinstellung sind alle Einträge angeschlossener WIBU-BOXen im Netzwerk verfügbar. Die Parameter, welche die Grundeinstellungen des Servers ändern, sind im Abschnitt WkLAN Konfiguration aufgeführt. Die meisten können auf der Seite Server des WIBU-KEY Kontrollfelds geändert werden.


WIBU-KEY Netzwerk-Server FAQ / Problemlösungen

Fehler beheben

1) WkNet/WkLAN Server meldet einen Fehler
2) WkNet Benutzer kann Server nicht finden
3) WkLAN Benutzer kann Server nicht finden
4) WkSvNW läuft nicht unter Novell SFT3
5) WkNet/WkLAN Server meldet: 0 Benutzer erlaubt

Über folgenden Link finden Sie die Antworten auf die Fragen, die von unseren Kunden am häufigsten gestellt werden. Um die Suche zu vereinfachen, sind die Antworten in mehrere Bereiche aufgeteilt:

Aktuelle Seite der FAQs (Internetverbindung wird benötigt)

Support

Unseren Kunden und Endkunden steht ein professionelles Team bestens geschulter Mitarbeiter vom ersten Schritt an zur Seite. Der direkte Kontakt ermöglicht es uns, Wünsche und Anregungen schnell zu erfüllen.
Als Anwender oder Entwickler erhalten Sie unsere kompetente Unterstützung zu Ihrem jeweiligen Anliegen.
Als Endanwender helfen wir Ihnen gerne im Problemfall. Bitte beachten Sie unsere Supportzeiten und wählen Sie bitte von 8.00 bis 12.00 und von 13.00 bis 17.00 die Telefonnummer +49-721-93172-15 für Endkunden bzw. +49-721-93172-14 für Kunden oder schicken Sie einfach eine E-Mail an support@wibu.de.

Seitenanfang 1)
Hinweis: Als Grundeinstellung zeigt WkSvNW nur einige Meldungen. Sollte ein Problem auftauchen, ist es ratsam, die Option /V3 zu benutzen, wenn man den Serverprozeß startet. Damit aktiviert man den erweiterten Modus, der mehr Statusmeldungen anzeigt.
Mögliche Fehlermeldungen

The WIBU-KEY network is not ready
Es wurde kein WIBU-KEY Server gefunden.

The specified server was not found in the WIBU-KEY network
Der angegebene WIBU-KEY Server wurde im Netzwerk nicht gefunden.

File [name] not found.
Die WkNet-Datei wird nicht gefunden.

No access to kernel driver.
Die WIBU-KEY Treiberdateien sind nicht sauber installiert.

No access to service manager.
Der Zugriff auf den System-Dienst-Manager funktioniert nicht - eventuell haben Sie nicht das Benutzerrecht, um diesen Befehl auszuführen.

File encryption sequence cannot be created.
Die Datei-Verschlüsselungssequenz, die für den Zugriff auf die WkNet-Datei nötig ist, kann nicht erzeugt werden. Eventuell kann der Serverprozeß nicht auf den benötigten WIBU-BOX Eintrag zugreifen.

No access to WkLAN: WINSOCK.DLL not found.
Das TCP/IP-Protokoll ist unter Windows 3.x nicht sauber installiert.

No access to WkLAN: WSOCK32.DLL not found.
Das TCP/IP-Protokoll ist unter Windows 95/Windows NT nicht sauber installiert.

Error: WIBU-BOX entry [FC:UC] not found.
Der benötigte WIBU-BOX Eintrag wurde nicht gefunden. Überprüfen Sie bitte, ob die richtige WIBU-BOX an den Computer angeschlossen ist.

Error: Data for encryption of user [user] cannot be read.
Es ist nicht möglich, Informationen für einen bestimmten Benutzer aus der WkNet-Datei auszulesen. Entweder ist die gesamte WkNet-Datei nicht in Ordnung, oder - ein Problem auf der Benutzerseite - unbrauchbare Informationen wurden in die WkNet-Datei geschrieben.

Error: Encryption Firm Code of user [user] is 0.
Die Benutzeranwendung hat einen ungültigen FirmCode übertragen.

Error: Global Access to [FC:UC] failed with error [error code].
Der Serverprozeß ist nicht in der Lage, auf den vorgegebenen Eintrag der WIBU-BOX zuzugreifen. Eventuell wurde die WIBU-BOX entfernt oder eine andere Anwendung greift bereits auf den WIBU-BOX Eintrag zu.

Error: File is no valid WkNet file.
Die WkNet-Datei ist unbrauchbar.

Seitenanfang 2)
Checkliste
  • Ist in der WIBU-KEY Systemsteuerungserweiterung auf der Seite Server WkNet die richtige WkNet-Datei eingetragen und ist der richtige FC:UC zugeordnet?
  • Meldet der WkNet-Server irgendwelche Fehler (benutzen Sie die Option /V3 unter Novell)?
  • Wird die WkNet-Datei im festgelegten Zeitintervall (Timeout) überarbeitet? Dies kann mit WkSvMon oder WkNetLst überprüft werden. Beide Programme zeigen den letzten Zugriff auf die WkNet-Datei durch den Server.
  • Haben alle Computer Lese-/Schreibzugriff auf die WkNet-Datei?
  • Unter Novell Netware: Gibt es eine Begrenzung der gleichzeitigen Benutzer, welche auf die WkNet-Datei zugreifen können oder des Platzes an dem sie liegt?

Seitenanfang 3)
Checkliste
  • Meldet der WkLAN Server irgendwelche Fehler?
  • Findet das WIBU-KEY Kontrollfeld in der Systemsteuerung des Client-Rechners den WkLAN-Server?
  • Ist das TCP/IP-Protokoll richtig konfiguriert?
  • Funktioniert PING [IP address] zwischen Benutzer und Server und umgekehrt?
  • Funktioniert PING [Name] Befehl zwischen Benutzer und Server und umgekehrt?
  • Läuft der WIBU-KEY Server auf dem richtigen Port? Überprüfen Sie die Ausgabe im Statusfenster nach dem Start.
  • Benutzt der WIBU-KEY Server die richtige IP-Adresse? Überprüfen Sie die Ausgabe im Statusfenster nach dem Start und tragen Sie ggf. eine IP-Adresse in BindAddress ein.
  • Werden Firewalls oder ähnliche Tools verwendet? Es muß sichergestellt werden das der verwendete Port (Standard: 22347) für TCP und UDP freigegeben ist.

Seitenanfang 4)
Problem: Wenn WkSvNW läuft und der Spiegelserver SFT3 benutzt wird, kann kein WkNet-Benutzer auf die WkNet-Datei zugreifen.
Grund: SFT3 spiegelt ständig alle Serverdateien. Dadurch wird die WkNet-Datei ständig kopiert. Während die WkNet-Datei kopiert wird, kann keine andere Anwendung auf die Datei zugreifen. Weder der WkNet-Server noch die WkNet-Benutzer können auf die WkNet-Datei zugreifen.
Lösung: Alle WIBU-KEY Komponenten (WKSVNW.NLM, WIBUKEY.INI und die WkNet-Datei) müssen im Ordner SYS:\SYSTEM des Novell-Servers liegen. Weil normalerweise ein Schreibzugriff auf diesen Ordner nicht erlaubt ist, muß dies für die WkNet-Datei geändert werden.

Seitenanfang 5)
Checkliste
  • Listet der Server alle WIBU-BOXen auf, die am Computer angeschlossen sind?
  • Gibt es den benötigten Abschnitt [WkNet FC:UC] in der WIBUKEY.INI des Servers?
  • Zeigt der Eintrag im Abschnitt [WkNet FC:UC] der Server WIBUKEY.INI auf die richtige WkNet-Datei?
  • Ist der Lese-/Schreibzugriff auf die WkNet-Datei gegeben?


WkSvMon - Der WIBU-KEY Netzwerk Monitor -Inhalt-

WkSvMon - Der WIBU-KEY Netzwerk Monitor

Inhalt:
Übersicht
Verwalten von WkLAN
Verwalten von WkNet
Die Menüleiste
Die Werkzeugleiste
Wie ...
Problemlösungen


WkSvMon - Der WIBU-KEY Netzwerk Monitor -Übersicht-

Übersicht

Was ist der WIBU-KEY Netzwerk Monitor (WkSvMon)?
Der WIBU-KEY Netzwerk Monitor (WkSvMon) ist das wichtigste Werkzeug zur Verwaltung von WIBU-KEY in einer Netzwerkumgebung. Von jedem beliebigen, im Netzwerk befindlichen Rechner hat man die Möglichkeit sowohl die Anzahl der Benutzer, die gegenwärtig Zugriff auf einen WIBU-KEY Server haben, als auch die Zeit eines Benutzerzugriffs, bzw. den Zeitpunkt des letzten Zugriffs zu überprüfen. Sie können Zugriffsrechte eines Benutzers löschen, die internen Statusinformationen des Netzwerk Serverprozesses und des Kerntreibers, der den Zugriff auf die WIBU-BOX steuert, anzeigen.
Der WIBU-KEY Netzwerkserver
Der WIBU-KEY Netzwerkserver erlaubt den Zugriff auf WIBU-BOXen über das Netzwerk. Dies ermöglicht zudem die Limitierung von Benutzern, die gleichzeitig auf die selbe Anwendung zugreifen möchten. Ein WIBU-KEY Netzwerkserverprozess ist auf jedem Rechner im Netzwerk einsatzfähig. Es ist nicht notwendig ein spezielles Serverbetriebssystem auf dem Server zu installieren.

WIBU-KEY bietet mit WkNet und WkLAN zwei verschiedene Lösungen an, um eine Anwendung im Netzwerk zu schützen.

Der Schutz mit WkNet basiert auf einer von Server und Client gemeinsam benutzten Datei. WkNet ist das ältere der beiden WIBU-KEY Netzwerksysteme und sollte nur dann eingesetzt werden, wenn die Verwendung von WkLAN nicht möglich ist, da WkLAN deutlich schneller ist und auch leichter zu administrieren ist.

WkLAN basiert verwendet die TCP/IP Protokollsuite. Daten werden direkt zwischen den Arbeitsstationen und dem Server über das Netzwerk übertragen. Die aktuelle Version von WkLAN unterstützt fast alle gängige Betriebsysteme (Windows 95/98/ME/NT/2000/XP/Server 2003, Mac OS 8, 9, X, Linux (alle unterstützen Distributionen)) und ist so für den Einsatz in heterogenen Netzwerken bestens geeignet.

Folgende Versionen des WIBU-KEY Netzwerkservers sind momentan erhältlich:
  • WkSvW32 (32 Bit Windows Anwendung für Windows 95/98/ME/NT/2000/XP/Server 2003 . Diese Version kann auf Windows NT/2000/XP/Server 2003 auch als Dienst laufen.
  • WkSvNW (NLM für Novell Netware Server, Version 3.11, 3.12 und 4.10).
  • WkSvMac Server für Mac OS 8+9.
  • WkSvMacX Server für Mac OS X.
  • WkSvLin Server für alle unterstützten Linux Distributionen.


WIBU-KEY Netzwerk-Server Die Werkzeugleiste

Die Werkzeugleiste

"Aktualisieren": Aktualisiert die Serverbaumstruktur. Lediglich die Informationen über die Server die bereits registriert (gefunden) wurden, werden aktualisiert. Neu hinzugekommene Server werden nicht gesucht.
"Netzwerk durchsuchen": Durchsucht das lokale Netzwerk nach WkLAN oder WkNet Servern.
"WkLAN": Aktiviert/deaktiviert die Anzeige von WkLAN Servern.
"WkNet": Aktiviert/deaktiviert die Anzeige von WkNet Servern.
"Systemsteuerung": Öffnet die WIBU-KEY Kontrollfeld in der Systemsteuerung.
"Optionen": Öffnet ein Fenster mit verschiedenen Konfigurationsoptionen.
"Benutzer löschen": Löscht einen einzelnen WkNet oder WkLAN Benutzer. Dieser Button ist nur aktiv, wenn ein oder mehrere Benutzer in der Baumstruktur oder in der Liste ausgewählt sind.
"Alle Benutzer löschen": Löscht alle Benutzer des gewählten Servers. Dieser Button ist nur aktiv, wenn ein Server oder ein Cluster in der Baumstruktur oder in der Liste ausgewählt ist.
"Statistik": Zeigt eine statistische Zusammenfassung über die Benutzung eines gewählten WkLAN Servers (Noch nicht Implementiert).
"Server Status": Zeigt das Status Kontrollfenster (Serverstatus) eines gewählten WkLAN Servers an. Dieser Button ist nur aktiv, wenn ein Server in der Baumstruktur ausgewählt ist.
"Hilfe": Öffnet die Onlinehilfe.
"Kontexthilfe": Startet den kontextsensitiven Hilfemodus. Wenn Sie Kontexthilfe im Kontrollmenü aktivieren, wird sich ein spezifisches Hilfefenster öffnen (falls eine spezielle Hilfe für eine Option verfügbar ist) (Noch nicht Implementiert).


WkSvMon - Der WIBU-KEY Netzwerk Monitor FAQ / Wie ...

Wie ...

Hier ist erklärt, wie Sie häufig auftretende Aufgaben lösen:
1) ... zeige ich Informationen über einen bestimmten WkLAN Server?
2) ... zeige ich Informationen über einen bestimmten WkNet Server?
3) ... überprüfe ich, ob eine WkNet Datei vom WkNet Server korrekt aktualisiert wird ?
4) ... lösche ich einen Benutzer?
5) ... zeige ich die Status Anzeige eines WkLAN Servers?

Seitenanfang 1)
  • Klicken Sie auf den "Netzwerk durchsuchen" Button um nach WkLAN Servern zu suchen.
  • Klicken Sie auf das Serversymbol in der Baumstruktur, welches den Namen des gewünschten WkLAN Servers beinhaltet.

Seitenanfang 2)
  • Benutzen Sie "WkNet Datei öffnen" im "Datei" Menü um die gewünschte WkNet Datei zu öffnen. Die WkNet Datei wird im WIBU-KEY Server Baumstruktur als ein normaler Server angezeigt.
  • Klicken Sie auf das Symbol auf der rechten Seite um die Server Informationen Anzeigen zu lassen.

Seitenanfang 3)
  • Benutzen Sie "WkNet Datei öffnen" im "Datei" Menü um die gewünschte WkNet Datei zu öffnen. Die WkNet Datei wird in der WIBU-KEY Server Baumstruktur als ein normaler Server angezeigt.
  • Klicken Sie auf das Symbol auf der rechten Seite um die Server Informationen Anzeigen zu lassen.
  • Die Zeit des letzten Zugriffs wird in festen Zeitintervallen erneuert. Die Dauer eines Zeitintervalls ist im Parameter Refreshtime festgelegt. Benutzen Sie F5 oder den "Aktualisieren" Button um die Anzeige zu erneuern, falls sich etwas geändert hat. Wenn sich nichts geändert hat, wird die falsche WkNet Datei angezeigt oder der Serverprozess funktioniert nicht mehr korrekt.

Seitenanfang 4)
Es ist relativ einfach, einen Benutzer zu löschen, schauen Sie für mehr Informationen unter WkLAN Benutzer löschen oder WkNet Benutzer löschen.

Seitenanfang 5)
  • Klicken Sie auf den "Netzwerk durchsuchen" Button um nach WkLAN Servern zu suchen.
  • Klicken Sie auf das Server Symbol in der Baumstruktur, welches den Namen des gewünschten WkLAN Servers beinhaltet.
  • Klicken Sie auf den "Server Status" Button in der Werkzeugleiste.


WkSvMon - Verwalten von WkNet-

Verwalten von WkNet

Suchen nach einem WkNet Server
Angezeigte Informationen über einen WkNet Server
Angezeigte Informationen über einen WkNet Client
Löschen von WkNet Benutzern


WkSvMon -Suchen nach einem WkNet Server-

Suchen nach einem WkNet Server
WkNet Server werden nicht automatisch von WkSvMon gefunden. Es handelt sich um normale Dateien und sie müssen wie andere Dateien über "WkNet Datei öffnen" im "Datei" Menü geöffnet werden.

Eine Standard WkNet Datei, die geöffnet werden soll, kann in dem "Allgemeine Einstellungen" Dialog angegeben werden.


WkSvMon -Angezeigte Informationen über einen WkNet Server-

Angezeigte Informationen über einen WkNet Server

Die angezeigten Informationen über einen WkNet Server ist der Anzeige der WkLAN Informationen sehr ähnlich. Wenn der Benutzer das Server Symbol auswählt, werden in der WIBU-KEY Server Baumstruktur auf der rechten Seite Informationen über diesen Server angezeigt. Der Name des Servers (in diesem Fall der komplette Pfad zur WkNet Datei), das aktive Subsystem (prinzipiell WkNet) und die Zeit des letzten Zugriffs auf den Server zu dieser WkNet Datei werden angezeigt.

Die Kontrollliste in der unteren Hälfte des Fensters zeigt eine Liste von verfügbaren Clustern. Ein Cluster ist ein Informationssegment, das sowohl einen Firm Code als auch einen User Code beinhaltet, die maximale Anzahl von Benutzern, die möglichen Zugriff über diese Parameter erhalten, die momentane Anzahl freier Benutzer, bzw. die Art des Subsystems, zu dem dieser Cluster gehört.

Hinweis: Derzeitig sind nicht viele Informationen in der WkNet Datei gespeichert. Beispielsweise ist es nicht möglich, den Firm Code und den User Code gleichzeitig anzuzeigen, der den Zugriff zu dieser WkNet Datei steuert. In der Kontrollliste Firm Code und User Code werden "Nullwerte" angezeigt.


WkSvMon -Angezeigte Informationen über einen WkNet Client-

Angezeigte Informationen über einen WkNet Client

Wenn der Benutzer das Client Symbol in der WIBU-KEY Server Baumstruktur auswählt, werden Informationen über diesen Benutzer im rechten Fenster angezeigt. Der Name des Client Rechners wird zusammen mit dem Namen der Anwendung des WkLAN Clients (wird momentan noch nicht unterstützt), der Art des Subsystems und dem User ID angezeigt. Das Datum des ersten Logins und das Datum des letzten Zugangs zum WkNet Server werden ebenfalls angezeigt.

Hinweis: WkLAN Clients die auf Cluster zugreifen, die auch unter WkNet existent sind, werden ebenfalls angezeigt, da sie einen Platz im der WkNet Datei belegen. Dort sind allerdings keine Informationen über den WkLAN Client in der WkNet Datei gespeichert. Station ID, Anwendungs ID und die Zugangsdaten sind also lediglich Beispielwerte.


WkSvMon -Löschen von WkNet Benutzern-

Löschen von WkNet Benutzern

WkNet Benutzer werden auf die gleiche Art und Weise wie WkLAN Benutzer gelöscht: Ein einzelner Benutzer kann durch den "Benutzer löschen" Button in der Werkzeugleiste, über "Benutzer löschen" im Menü "Benutzer" oder über den "Benutzer löschen" Button auf der Client Seite gelöscht werden.

Alle Benutzer können mit dem entsprechenden Button in der Werkzeugleiste oder in der Menüleiste unter "Benutzer" gelöscht werden.

Ein bereits gelöschter Benutzer wird von den internen Listen des WkLAN Servers entfernt. Beim nächsten Versuch des Clients auf den Server zuzugreifen wird dieser eine Fehlermeldung ("Benutzer gelöscht") erhalten. Die Dauer dieses Vorgangs (in Sekunden) wird im Parameter Refreshtime angegeben - Erwarten Sie nicht, dass die Client Anwendung sofort informiert wird.


WkSvMon - Der WIBU-KEY Netzwerk Monitor -Verwalten von WkLAN-

Verwalten von WkLAN

Suchen nach einem WkLAN Server
Angezeigte Informationen über einen WkLAN Server
Angezeigte Informationen über ein WkLAN Cluster
Angezeigte Informationen über einen WkLAN Client
Anzeigen des Serverstatus eines WkLAN Servers
Anzeigen des Kerntreiberstatus eines WkLAN Servers
Löschen von WkLAN Benutzern


WkSvMon -Suchen nach einem WkLAN Server-

Suchen nach einem WkLAN Server

Die Suche nach einem WkLAN Server ist entweder über den "Netzwerk durchsuchen" Button in der Werkzeugleiste oder über "Netzwerk durchsuchen" im Menü "Ansicht" möglich. Der WIBU-KEY Treiber wird einen speziellen Dialog "Scanning network" anzeigen, während nach WkLAN Servern gesucht wird. Nachdem sich dieses Dialogfenster wieder schließt, sollten alle gefundenen WkLAN Server in der WIBU-KEY Server Baumstruktur angezeigt werden.

Ein Standard WkLAN Server, der angezeigt werden soll, kann in dem Dialog "Optionen" angegeben werden.

Hinweis: Der WIBU-KEY Treiber durchsucht das Netzwerk mittels eines Broadcast im lokalen IP Netz. Diese Suche wird lediglich Server in diesem Netzwerkabschnitt (Subnetz) erreichen. Rechner, die sich in einem anderen Netzwerkabschnitt (Subnetz) befinden, müssen in der Serversuchliste auf der Seite Netzwerkseite im WIBU-KEY Kontrollfeld eingetragen werden. Man sollte hierfür die IP Adresse des WIBU-KEY Servers verwenden um möglichen DNS Probleme zu vermeiden.


WkSvMon -Angezeigte Informationen über einen WkLAN Server-

Angezeigte Informationen über einen WkLAN Server

Wird das Server Symbol in der WIBU-KEY Server Baumstruktur auswählt, werden Informationen über den ausgewählten Server in den beiden rechten oberen Fenstern angezeigt: Name des Servers, seine IP Adresse und die aktiven WIBU-KEY Subsysteme werden angezeigt.

Die Kontrollliste im unteren größeren Fenster zeigt eine Liste von verfügbaren Clustern an. Ein Cluster ist ein Informationssegment, dass sowohl einen Firm Code als auch einen User Code beinhaltet, die maximale Anzahl von Benutzern, die momentane Anzahl freier Benutzer und die Art des WIBU-KEY Subsystems, zu dem dieser Cluster gehört.


WkSvMon -Angezeigte Informationen über einen WkLAN Client-

Angezeigte Informationen über einen WkLAN Client

Wenn der Benutzer das Client Symbol in der WIBU-KEY Server Baumstruktur auswählt, werden Informationen über diesen Benutzer im rechten Fenster angezeigt.
Der Name des Client Rechners wird zusammen mit dem Namen der Anwendung des WkLAN Clients, der Art des WIBU-KEY Subsystems und der User ID angezeigt. Das Datum des ersten Logins und das Datum des letzten Zugangs zum WkLAN Server werden ebenfalls angezeigt.

Hinweis: WkLAN Benutzer sind absteigend registriert, d.h. bei 200 möglichen Benutzern wird der erste Benutzer der User ID 200 erhalten, der zweite 199 und so weiter.


WkSvMon -Anzeigen des Serverstatus eines WkLAN Servers-

Anzeigen des Serverstatus eines WkLAN Servers

WkSvMon ermöglicht die Anzeige des kompletten Statusmonitors des WkLAN Servers. Die Anzeige ist die gleiche wie auf dem Rechner, auf dem der Server momentan aktiviert ist. Der Status Dialog kann über den "Server Status" Button in der Werkzeugleiste, über das "Server Status" Symbol im "Ansicht" Menü oder über den Button auf der Server Seite geöffnet werden.


WkSvMon -Anzeigen des Kerntreiberstatus eines WkLAN Servers-

Anzeigen des Kerntreiberstatus eines WkLAN Servers

Auf die gleiche Art und Weise wie der Server Status angezeigt wird ist es möglich, sich den Status des WIBU-KEY Kerntreibers anzeigen zu lassen, der auf dem WIBU-KEY Server Rechner in Betrieb ist. Die angezeigten Statusmeldungen können in der unteren linken Ecke des Status Dialogfensters ausgewählt werden.


WkSvMon -Löschen von WkLAN Benutzern-

Löschen von WkLAN Benutzern

Es ist möglich einen einzelnen als auch alle Benutzer eines bestimmten WkLAN Servers zu löschen. Ein einzelner Benutzer kann mit dem "Benutzer löschen" Button in der Werkzeugleiste, bzw. mit "Benutzer löschen" im Menü "Benutzer" oder mit dem "Benutzer löschen" Button auf der "Client" Seite gelöscht werden.

Alle Benutzer können mit dem entsprechenden Button in der Werkzeugleiste oder in der Menüleiste unter "Benutzer" gelöscht werden.

Ein bereits gelöschter Benutzer wird von den internen Listen des WkLAN Servers entfernt. Beim nächsten Versuch des Clients auf den Server zuzugreifen wird dieser eine Fehlermeldung ("Benutzer gelöscht") erhalten.


WkSvMon - Der WIBU-KEY Netzwerk Monitor FAQ / Problemlösungen

Fehlersuche

1) WkSvMon findet meinen WkLAN Server nicht
2) WkSvMon findet meinen WkNet Server nicht

Über folgenden Link finden Sie die Antworten auf die Fragen, die von unseren Kunden am häufigsten gestellt werden. Um die Suche zu vereinfachen, sind die Antworten in mehrere Bereiche aufgeteilt:

Aktuelle Seite der FAQs (Internetverbindung wird benötigt)

Support

Unseren Kunden und Endkunden steht ein professionelles Team bestens geschulter Mitarbeiter vom ersten Schritt an zur Seite. Der direkte Kontakt ermöglicht es uns, Wünsche und Anregungen schnell zu erfüllen.
Als Anwender oder Entwickler erhalten Sie unsere kompetente Unterstützung zu Ihrem jeweiligen Anliegen.
Als Endanwender helfen wir Ihnen gerne im Problemfall. Bitte beachten Sie unsere Supportzeiten und wählen Sie bitte von 8.00 bis 12.00 und von 13.00 bis 17.00 die Telefonnummer +49-721-93172-15 für Endkunden bzw. +49-721-93172-14 für Kunden oder schicken Sie einfach eine E-Mail an support@wibu.de.

Seitenanfang 1)
Der WIBU-KEY Treiber durchsucht das Netzwerk mittels eines TCP/IP Broadcast Aufrufes. Dieser Aufruf erreicht lediglich die Rechner im aktuellen Netzwerkabschnitt (Subnetz). WIBU-KEY Server, welche sich in einem anderen Netzwerkabschnitt (anderes Subnetz) befinden (über Router verbunden), müssen in der "Server Suchliste" auf der Seite "Netzwerk" im WIBU-KEY Tool eingetragen werden.Man sollte hierfür die IP-Adresse des WIBU-KEY Servers verwenden um möglichen DNS Problemen aus dem Wege zu gehen.

Seitenanfang 2)
WkNet Server werden nicht automatisch von WkSvMon gefunden. Es handelt sich um normale Dateien und sie müssen wie andere Dateien über "WkNet Datei öffnen" im "Datei" Menü geöffnet werden.


WIBU-KEY HILFE Version

WIBU-KEY Benutzer Hilfe Version 5.0 von März 2005


WIBU-KEY HILFE

Runtime Kit

WIBU-BOXen

WIBU-KEY Kontrollfeld

WIBU-KEY Server

WIBU-KEY Netzwerk Monitor

FAQ

Version


WkSvMon

WkSvMon ist ein Programm zur Überwachung und Steuerung von WkLAN- und WkNet-Serverprozessen.

Mit WkSvMon kann man sich von einer beliebigen Arbeitsstation aus die Belegung der WIBU-KEY Serverlizenzen durch die Benutzer anzeigen lassen und die Serverlizenzen wieder freigeben. Wenn das WkLAN Subsystem aktiv ist, kann man sich darüber hinaus den gesamten Status des Serverprozesses und des darunterliegenden Kerntreibers anzeigen lassen.

WkSvMon ist in sieben Sprachen verfügbar. Die dazugehörenden Sprachdateien haben den gleichen Namen wie WkSvMon (WkSvMon). Als Erweiterung führen diese Dateien lxx, wobei xx für das Kürzel der unterstützen Sprache steht.


Netzwerkserver

Die WIBU-KEY Netzwerkserver

Im Moment gibt es folgende WIBU-KEY Netzwerkserver:
  • WkSvW32 für alle Windows Betriebsysteme. WkSvW32 kann auf Windows NT basierenden Betriebsystemen wahlweise auch als Dienst gestartet werden.
  • WkSvMacX (Mac OS X) bzw. WkSvMac (Mac OS 8+9).
  • WkSvLin für alle von WIBU-KEY unterstützten Linux Distributionen.
  • WkSvNW für Novell Netware (nur WkNet).
Die Einstellungen für den WIBU-KEY Windows Serverprozess lassen sich einfach über die Serverseite des WIBU-KEY Kontrollfelds konfigurieren.

Unter Novell Netware muß die Datei WIBUKEY.INI editiert werden um den WkNet Serverprozess zu konfigurieren.

Für den Betrieb von WkLAN (TCP/IP basiert) sind normalerweise keine zusätzlichen Konfigurationsschritte notwendig.


WKU

WKU / WKU32

WKU32 ist die universelle WIBU-KEY Konsolenanwendung für den WIBU-KEY Benutzer. Das Programm steht als WKU.EXE für DOS und als WKU32.EXE für Win32 ( Windows 95/98/ME/NT/2000/XP/Server 2003) zur Verfügung.

WKU.EXE kann auch unter Windows 95/98/ME/NT/2000/XP/Server2003 zusammen mit dem installierten DOS-Treiber WKDOS.EXE verwendet werden. Es ist damit ein ideales Programm, um zu testen, ob der WIBU-KEY Zugriff aus DOS-Programmen einwandfrei funktioniert. WKU32.EXE spricht dagegen direkt den Win32-Treiber an.

WKU32 umfasst viele Möglichkeiten, die auch das WIBU-KEY Kontrollfeld in der Systemsteuerung bietet. Diese werden durch folgende Argumente bestimmt:
  • Wird das Programm ohne Argument aufgerufen, listet es alle gefundenen Anschlüsse und die Anzahl der angeschlossenen WIBU-BOXen auf.
  • Der Befehl WKU32 LIST bewirkt, dass die Inhalte einer oder mehrerer WIBU-BOXen an einem oder mehreren Anschlüssen angezeigt werden.
  • Mit dem Befehl WKU32 TEST wird durch eine bestimmte Anzahl von Prüfungen die Verschlüsselungsfunktionalität aller oder nur der angegebenen WIBU-BOXen überprüft.
  • Mit dem Befehl WKU32 DATA kann der Benutzer User-Dateneinträge einer WIBU-BOX anzeigen und modifizieren.
  • Mit dem Befehl WKU32 CONFIG werden die Konfigurationsattribute einer WIBU-BOX geändert.
  • Mit dem Befehl WKU32 REMOTE kann der Benutzer eine Datei erzeugen, die Informationen über eine WIBU-BOX für das Remote Programming enthält. Außerdem kann er mit Hilfe einer Remote-Programming-Update-Datei WIBU-BOX-Einträge umprogrammieren.
  • Mit dem Befehl WKU32 DIAGNOSE kann der Benutzer die Diagnoseergebnisse des residenten DOS-Treibers WKDOS.EXE lesen und in eine Datei sichern.
  • WKU32 NETWORK dient zur Suche nach WkLAN Servern im Netzwerk.
  • Mit dem Befehl WKU32 RESET kann der Benutzer den Treiber zurücksetzen oder die Freigabe dauerhaft blockierter WIBU-BOXen erreichen.
  • WKU32 PORTS erlaubt das Testen und Setzen der gegebenen physikalischen Adressen für LPT1 bis LPT4 und COM1 bis COM4.
  • WKU32 INSTALL dient zum Installieren des Kerntreiber WIBUKEY.SYS unter Windows NT basierten Betriebsystemen.
  • WKU32 DEINSTALL deinstalliert den Kerntreiber unter Windows NT basierten Betriebsystemen.
  • WKU32 START startet den Kerntreiber unter Windows NT basierten Betriebsystemen.
  • WKU32 STOP hält den Kerntreiber unter Windows NT basierten Betriebsystemen an.
  • WKU32 CHECK zeigt die Versionsnummer der Windows Kerntreiber an.
Mehr Details über den Gebrauch von WKU32 sind über die Soforthilfe dieser Anwendung zu erfahren. Allgemeine Hinweise erscheinen bei der Eingabe von:

WKU32 /?

Detaillierte Hinweise zu den Befehlen von WKU32 erhält man durch Angabe der Hilfeoption /? nach dem betreffenden Befehlswort, beispielsweise:

WKU32 TEST /?

Die WKU32 spezifischen Befehlsnamen und die Anschlussnamen können abgekürzt werden, es sei denn die Angabe wird dadurch mehrdeutig. Gültige Abkürzungen sind beispielsweise:

WKU32 L L1 L2

alternativ zu

WKU32 LIST LPT1 LPT2

Eine mehrdeutige Abkürzung wäre dagegen:

WKU32 D

da "D" sowohl die Abkürzung von DATA als auch von DIAGNOSE ist.
Der Einsatz von WKU für Remote Programming beim Anwender
WKU32 kann eine Remote Programming Kontext Datei für eine oder mehrere angeschlossene WIBU-BOXen mit Hilfe des REMOTE GET Befehls erstellen:
WKU32 REMOTE GET ALL TO X
kopiert die Inhalte aller angeschlossenen WIBU-BOXen in die Datei X.RTC. Um die Größe dieser Datei zu reduzieren, kann der Benutzer die Anschlüsse oder die angeschlossenen WIBU-BOXen auswählen, deren Inhalte gespeichert werden sollen. Die Auswahl des Anschlusses und der WIBU-BOX erfolgt wie andere WKU32 Befehle auch:
WKU32 REMOTE l1:1 c1 GET ALL TO X.RTC
kopiert den Inhalt der ersten WIBU-BOX an LPT1 und aller WIBU-BOXen an COM1 in die Datei X.RTC.

Eine weitere Reduzierung der Größe der Remote ProgrammingKontext-Datei kann durch die Angabe der Anzahl der benötigten Einträge erreicht werden. Dies erfolgt durch die Angabe von einer oder mehreren Zahlen von 1 bis 10 anstatt des Schlüsselwortes ALL.
WKU32 REMOTE l1:2 GET 1,5 TO X.RTC
kopiert nur die Inhalte der Einträge 1 und 5 der zweiten WIBU-BOX an LPT1 in die Remote Programming Kontext-Datei.

Um einen neuen Eintrag hinzuzufügen, benötigt der Programmierer nur eine Liste aller leeren Einträge einer WIBU-BOX. Dies erfolgt durch das Schlüsselwort EMPTY:
WKU32 REMOTE * GET EMPTY TO X.RTC
Der Stern (*) ist ein Schlüsselwort zur Angabe aller gefundenen WIBU-BOXen und hat die gleiche Funktion wie das Leerzeichen zwischen REMOTE und GET.
Die Datei ( z.B. X.RTC) kann nun in verschiedener Form (Diskette, E-Mail," gedruckt als Brief oder Fax oder wörtlich über Telefon") an den Softwarehersteller verschickt werden. Dieser benutzt die Datei für Veränderungen in der WIBU-BOX.

Der Software Hersteller schickt nun eine Remote Progamming Update-Datei zum Benutzer der WIBU-BOX zurück. Diese neue Datei enthält Befehle zur Änderung der speziellen Inhalte der WIBU-BOX. Zur Ausführung der WIBU-BOX Programmier-Befehle wird WKU32 benutzt, was im folgenden erklärt wird.
Um eine Remote Programming Update-Datei in eine angeschlossene WIBU-BOX zu übermitteln wird, der SET Befehl von WKU32 benutzt:
WKU32 REMOTE SET FROM X.RTU
Sucht an allen Anschlüssen nach WIBU-BOXen mit der gleichen Seriennummer und dem gleichen Programmierzählerwert wie in der Remote Programming Update-Datei. Eine optionale Liste von WIBU-KEY Anschlüssen oder speziellen WIBU-BOXen kann den Update-Vorgang auf die angeschlossenen WIBU-BOXen begrenzen.
Setzen der Anschlussadressen
Der Befehl PORTS dient zum Abfragen und Setzen der Adressen von Anschlüssen, an denen mehrere WIBU-BOXen oder zusätzlich Kopierschutzmodule anderer Hersteller angebracht sind, und die von einigen (wenigen) BIOS-Varianten nicht korrekt erkannt werden. In diesem Fall funktioniert beispielsweise die Druckausgabe über diese Anschlüsse nicht mehr.

Durch Eingabe von WKU32 PORTS ohne Argument können die Anschlussadressen ausgegeben werden, wie sie vom BIOS ermittelt wurden. Sind die angegebenen Werte nach dem Hochfahren des Systems (Bootvorgang) mit und ohne angeschlossene WIBU-BOXen gleich, hat das BIOS die Anschlüsse korrekt erkannt.

Andernfalls muss WKU32 PORTS dazu verwendet werden, die Anschlüsse nachträglich zu erkennen und in das BIOS-RAM einzutragen. Erst dann stehen sie wieder wie gewohnt zur Verfügung (z.B. zum Drucken), und können von WIBU-KEY Treibern erkannt werden. Dies betrifft vorwiegend parallele Anschlüsse (LPT). Ein solcher WKU32 PORTS Aufruf wird sinnvollerweise in AUTOEXEC.BAT eingetragen.

Zum Setzen von Anschlüssen wird folgende Syntax verwendet:

WKU PORTS ((LPT|COM) [=(HexAdresse|*|0)[,]...]) ...

Wird nur LPT oder COM ohne weiteres Argument angegeben, sucht WKU32 an folgenden Adressen nach Anschlüssen und setzt sie bei positivem Resultat in das BIOS-RAM:
Anschluss: | Standardadresse:
LPT1 | 0x3BC
LPT2 | 0x378
LPT3 | 0x278
COM1 | 0x3F8
COM1 | 0x2F8
Wird ein Gleichheitszeichen verwendet, sucht WKU PORTS an den angegebenen Adressen nach Anschlüssen und setzt sie in das BIOS-RAM. Die Adressen müssen in der Reihenfolge LPT1 bis LPT4 bzw. COM1 bis COM4 angegeben werden. Adressen werden grundsätzlich hexadekadisch angegeben, aber als pure Zahl ohne führendes Präfix wie "0X" oder abschließendes "H" (siehe Beispiele). Durch Angabe der Adresse "0" wird der entsprechende Anschluss deaktiviert. Wird statt einer Adresse der Stern (*) angegeben, wird die Standardadresse aus der obigen Tabelle verwendet.

Die Option /? zeigt auf dem Bildschirm eine kurze Beschreibung des Programms, zusammen mit Beispielen.

Hinweis: WKU PORTS läuft nur unter DOS und in AUTOEXEC.BAT von Windows 95/98/Me.
Installation von Kerntreibern
Über WKU32 kann der Kerntreiber von Windows NT basierten Betriebsystemen (NT/2000/XP/Server 2003) installiert und gestartet und auch wieder deinstalliert werden. WKU32 ist als Konsolenanwendung eine Alternative zur Installationsseite des WIBU-KEY Kontrollfelds in der Systemsteuerung. WKU32 kann die Treiberinstallation unter Windows NT basierten Betriebsystemen auch auf anderen Netzwerkrechnern durchführen.

Die Installation bzw. Deinstallation des Kerntreibers für Windows NT basierte Betriebsysteme, WIBUKEY.SYS, ist nur von Benutzern mit entsprechenden Administratorrechten möglich. Normalerweise verfügt jeder lokale oder Domänenadministrator über diese Rechte. Über den Benutzermanager kann das Recht zum Installieren und Deinstallieren von Kerntreibern aber auch einzelnen Benutzern verliehen werden. Die genaue Bezeichnung dieses Benutzerrechtes lautet Load and unload device drivers bzw. SeLoadDriverPrivilege.

Die Kerntreiberbefehle von WKU32 haben folgende Syntax:

WKU32 INSTALL KERNEL DRIVER [AUTOMATIC|MANUAL]

Dieser Befehl (re-)installiert den Treiber WIBUKEY.SYS, welcher im Treiberverzeichnis von Windows stehen muss. Über MANUAL wird der Treiber so installiert, dass er (manuell) gestartet wird, sobald er das erste Mal über WIBU-KEY Software angesprochen wird. Diese Variante setzt voraus, dass der Benutzer, der die WIBU-KEY Software aufruft, Benutzerrechte hat, die es ihm ermöglichen, einen Windows Kerntreiber zu installieren und zu starten.

Wird keine Spezifikation oder AUTOMATIC angegeben, wird der Treiber so installiert, dass er jedes mal (automatisch) gestartet wird, wenn das Betriebsystem gestartet wird. Diese Startvariante verlängert die Windows Startphase ein wenig, ist jedoch auch für Benutzer geeignet, die keine Rechte haben, einen Kerntreiber zu installieren oder zu starten.

Das INSTALL Kommando kann auch benutzt werden, um WIBUKEY.VXD als statischen VXD-Treiber zu installieren. Dieser wird dann jedes mal automatisch gestartet, wenn Windows 95/98/Me startet. WKU32 trägt WIBUKEY.VXD in die Liste der statischen Gerätetreiber in der Registry ein.

Nachdem Windows 95/98/Me neu gestartet wurde, wird die Zeile "WIBUKEY.VXD statically started" in das Diagnosesprotokoll des Treibers eingetragen (falls dieses aktiviert ist). Die WIBU-BOX/M sollte dann von jeder Anwendung sofort gefunden werden.

WKU32 DEINSTALL KERNEL DRIVER

Dieser Befehl ist das Gegenstück zu INSTALL. Der Kerntreiber wird gestoppt und deinstalliert. Die Datei WIBUKEY.SYS bleibt weiterhin im Treiberverzeichnis des Betriebsystems erhalten.

WKU32 START KERNEL DRIVER

Dieser Befehl startet den Kerntreiber. Normalerweise wird der Kerntreiber beim Start des Betriebssystems automatisch mitgestartet. Trotzdem kann es in manchen Fällen günstig sein, den Kerntreiber per Hand zu starten.

WKU32 STOP KERNEL DRIVER

Dieser Befehl stoppt den Kerntreiber. Wenn noch eine Anwendung auf den Kerntreiber zugreift, kann dieser nicht beendet werden und eine entsprechende Meldung wird ausgegeben.

WKU32 CHECK KERNEL DRIVER

Durch diesen Befehl wird der Kerntreiber gestartet und seine Versionsnummer ausgelesen und auf dem Bildschirm ausgegeben.

AT Computername

Über den AT-Befehl können alle Kerntreiberbefehle außer CHECK auf einem anderen Rechner ausgeführt werden. AT muß dabei entweder vor dem Hauptbefehl angegeben werden (z. B. WKU32 AT "Computername" STOP KERNEL DRIVER) oder nach dem Hauptbefehl (z. B. WKU32 STOP AT "Computername" KERNEL DRIVER).


WIBU-KEY Kontrollfeld - Report-Schaltfläche -

Report Dialog
Mit diesem Dialog kann ausgewählt werden, welche Information in die Report-Datei übertragen werden.


WIBU-KEY Kontrollfeld -S

Seite Server

Diese Seite dient der Konfiguration des WIBU-KEY WkLAN Servers. Über die Serverseite werden Cluster Namen, HLM Dateien und grundsätzliche WkLAN Einstellungen konfiguriert.
Cluster Name
HLM Dateien
Einstellungen für WkLAN


.topic 0x20A58
Testet die ausgewählte HLM-Datei.

.topic 0x20A5E
Re-Initialisiert die Plug&Play Einstellungen für WIBU-BOX/(R)U und WIBU-BOX/M
auf diesem Computer.

.topic 0x20A4A
Liste aller vorhanden Cluster Namen.

.topic 0x20A4B
Cluster-Firm-/User-Code des ausgewählten Clusters.

.topic 0x20A4C
Name des ausgewählten Clusters.

.topic 0x20A5C
Neuen Cluster hinzufügen.

.topic 0x20A5D
Löscht den ausgewählten Cluster.

.topic 0x20A4E
Ändert Daten des ausgewählten Clusters.

.topic 0x20A51
Liste der registrierten HLM-Dateien.

.topic 0x20A52
Name der ausgewählten HLM-Datei.

.topic 0x20A49
(De-)Aktiviert den WKLAN-Server.

.topic 0x20A48
Timeout des WKLAN-Servers.

.topic 0x20A53
Neue HLM-Datei hinzufügen.

.topic 0x20A54
Löscht den ausgewählten HLM-Eintrag.

.topic 0x20A55
Ändert den ausgewählten HLM-Eintrag.

.topic 0x20A56
Öffnet den Dialog um HLM-Dateien auszuwählen.

.topic 0x207D0
Dies ist die Darstellung des Inhalts der selektierten WIBU-BOX.
Eine WIBU-BOX kann bis zu 10 Einträge enthalten. WIBU-BOX/RU und /RP
haben jedoch nur einen einzigen Eintrag. Im unteren Teil
der Darstellung ist die Seriennummer der WIBU-BOX angegeben.
Rechts daneben befindet sich die Anzeige der Konfigurationsattribute.

.topic 0x207D4
Durch diese Schaltfläche selektiert man die erste gefundene WIBU-BOX.

.topic 0x207D5
Durch diese Schaltfläche selektiert man die nächste WIBU-BOX.

.topic 0x207D6
Durch diese Schaltfläche selektiert man die vorhergehende WIBU-BOX.

.topic 0x207D7
Durch diese Schaltfläche selektiert man die letzte gefundene WIBU-BOX.

.topic 0x207DC
Diese Schaltfläche öffnet einen Dialog zur Suche nach einem Quellverzeichnis für
Treiberdateien.

.topic 0x207DD
Diese Schaltfläche löscht den selektierten WkNet-Datei-Eintrag.

.topic 0x20834
In diesem Feld kann ein Ordner mit Treiberdateien angegeben werden.

.topic 0x20835
Benötigter Speicherplatz für alle installierten Treiberdateien.

.topic 0x20836
Freier Speicherplatz auf dem Systemlaufwerk.

.topic 0x20839
Diese Liste zeigt die für dieses Betriebssystem auf diesem Computer benötigten
Treiberdateien. Ein markiertes Kästchen zeigt an, daß diese Komponente installiert ist.

.topic 0x2083A
Zähler für die erfolgten Test-Durchläufe.

.topic 0x2083B
Die Schaltfläche überträgt die selektierte WIBU-BOX von der WIBU-BOX-Liste in
die Liste der zu bearbeitenden WIBU-BOXen.

.topic 0x2083C
Diese Schaltfläche entfernt die selektierte WIBU-BOX aus der Liste der zu bearbeitenden
WIBU-BOXen.

.topic 0x208A6
Diese Anzeige zeigt wie weit der Test der einzelnen WIBU-BOXen fortgeschritten ist.

.topic 0x208A7
Diese Liste enthält die für diesen Vorgang selektierten WIBU-BOXen.

.topic 0x208A8
Diese Schaltfläche startet den Test der selektierten WIBU-BOXen.

.topic 0x208A9
Diese Schaltfläche stoppt den Test der selektierten WIBU-BOXen.

.topic 0x208AA
Diese Schaltfläche setzt den Fehlerzähler zurück auf Null.

.topic 0x208AC
Wenn diese Option aktiviert ist, werden die neuen Informationen an eine bereits
existierende Remote-Context-Datei angehängt.

.topic 0x208AD
Wenn diese Option aktiviert ist, werden nur Informationen über leere WIBU-BOX-Einträge
in der Remote-Context-Datei gespeichert.

.topic 0x208FD
Diese Liste enthält Einträge des WIBU-KEY-Diagnoseprotokolls.

.topic 0x208FF
Diese Schaltfläche liest die Liste der angeschlossenen WIBU-BOXen erneut ein.

.topic 0x20904
Durch diese Option schaltet man die Diagnose-Aufzeichnung ein.

.topic 0x2092E
Diese Schaltfläche startet die Diagnose-Aufzeichnung neu.

.topic 0x2092F
Diese Schaltfläche dient zum Speichern des Diagnoseprotokolls.

.topic 0x20930
Diese Schaltfläche dient zum Einlesen der Diagnoseinformationen aus dem internen Speicher
des Kerntreibers.

.topic 0x20961
Symbol des Eintrags.

.topic 0x20962
Dies ist das Firm-Code/User-Code Paar für die entsprechende WkNet-Datei.

.topic 0x20963
Eintrag ist Mastereintrag.

.topic 0x20964
Eintrag enthält Benutzerdaten.

.topic 0x20965
Eintrag ist leer.

.topic 0x2096A
Firmcode: Jeder Lizenznehmer erhält einen eigenen Firmcode. Firmcode 10 ist jedermann zugänglich.

.topic 0x2096B
Usercode (24 Bit): frei wählbar im Bereich 0 - 16.777.215, 15.728.640 - 16.777.215 nur für HLM.

.topic 0x2096C
Obere 8 Bit des Dateneintrags; Bereich 0 - 239, der Rest ist reserviert und darf nicht benutzt werden.

.topic 0x2096D
Untere 32 Bit des Dateneintrags; Bereich 0 - 1.073.741.823.

.topic 0x20992
Symbol des Zusatzeintrags.

.topic 0x20994
Begrenzungszähler zum Basiseintrag hinzufügen.

.topic 0x20995
Verfallsdatum zum Basiseintrag hinzufügen.

.topic 0x20996
Dateneintrag zum Basiseintrag hinzufügen.

.topic 0x20997
Kein Zusatzeintrag zum Basiseintrag.

.topic 0x2099C
Obere 8 Bit des Zusatzdateneintrags; Bereich 0 - 239, der Rest ist reserviert und darf nicht benutzt werden.

.topic 0x2099D
Untere 32 Bit des Zusatzdateneintrags; Bereich 0 - 1.073.741.824.

.topic 0x2099E
Programmiersequenz zur Umprogrammierung hängt von der Seriennummer der WIBU-BOX ab.

.topic 0x2099F
Programmiersequenz zur Umprogrammierung hängt vom internen Programmierzähler der WIBU-BOX ab.

.topic 0x209A0
Programmiersequenz zur Umprogrammierung hängt vom aktuellen Dateninhalt ab.

.topic 0x209A2
So oft kann der Basiseintrag noch benutzt werden.

.topic 0x209A4
Anzahl Tage bis zum Verfalldatum.

.topic 0x209AB
Wochentag des Verfallsdatums.

.topic 0x209AC
Jahr des Verfalldatums.

.topic 0x209AD
Monat des Verfalldatums.

.topic 0x209B0
Tag des Verfalldatums.

.topic 0x209BA
Diese Schaltfläche nimmt die letzte Änderung zurück.

.topic 0x209BB
Diese Schaltfläche schaltet weiter zum nächsten Eintrag.

.topic 0x209BC
Diese Schaltfläche schaltet weiter zum vorherigen Eintrag.

.topic 0x209BD
Alle Zahlen hexadezimal anzeigen.

.topic 0x209C9
Diese Schaltfläche öffnet einen Dialog zum Bearbeiten der Konfigurationsattribute der selektierten WIBU-BOX.

.topic 0x20A2A
Diese Liste zeigt alle für WIBU-KEY aktivierten Schnittstellen und
Netzwerk-Server und listet die an diesen Schnittstellen gefundenen
WIBU-BOXen auf.

.topic 0x20A42
Diese Schaltfläche aktiviert bzw. deaktiviert den Kerntreiber für Windows NT/2000/XP/Server 2003.

.topic 0x20802
Diese Liste zeigt die Schnittstellen an denen WIBU-KEY-Treiber nach WIBU-BOXen suchen
können.

.topic 0x20804
Wenn diese Option nicht markiert ist, werden an dieser Schnittstelle keine WIBU-BOXen gesucht.

.topic 0x20805
Maximale Zeit in Sekunden (mit Auflösung in Millisekunden) die der WIBU-KEY-Treiber
wartet, bis ein anderer Treiber einen benötigten Anschluss freigibt. Wird diese Zeit
überschritten beendet der Treiber den Zugriff und eine angeschlossene WIBU-BOX wird
nicht gefunden.

.topic 0x20A64
Bei parallelen Anschlüssen (LPT) kann hier die Suche auf den bidirektionalen Modus (BD)
beschränkt werden. Bei seriellen Anschlüssen (COM) kann die Suche auf die WIBU-BOX/SP
beschränkt werden. Mehr dazu unter besondere Einstellungen für die WIBU-BOX/P bzw.
besondere Einstellungen für die WIBU-BOX/SP in der Hilfe.

.topic 0x20A65
Bei parallelen Anschlüssen (LPT) kann hier die Suche auf den unidirektionalen Modus (UD)
beschränkt werden. Bei seriellen Anschlüssen (COM) kann die Suche auf die WIBU-BOX/ST
beschränkt werden. Mehr dazu unter besondere Einstellungen für die WIBU-BOX/P bzw.
besondere Einstellungen für die WIBU-BOX/ST in der Hilfe.

.topic 0x20A66
Ist diese Option markiert, greift der WIBU-KEY-Treiber auch dann auf die Anschluss,
wenn er von anderen Geräten belegt wird. Dabei können sowohl Fehler mit diesem Gerät
als auch mit der WIBU-BOX selbst entstehen. Die Option ist aber wichtig und sollte
gesetzt werden, wenn ein fehlerhaft programmierter Treiber, etwa für einen Drucker,
den Anschluss permanent belegt und damit der WIBU-KEY-Treiber keinen Zugriff auf die
WIBU-BOX erhält.

.topic 0x20A67
Ist diese Option gesetzt, ist die RTS-Leitung des Anschlusses ständig eingeschaltet.
Damit die WIBU-BOX/ST eine stabile Spannungsversorgung erhält sollte zumindest eine der
beiden RTS- und DTR-Leitungen eingeschaltet sein. Mehr dazu unter Besondere Einstellungen
für die WIBU-BOX/ST in der Hilfe.

.topic 0x20A68
Ist diese Option gesetzt, ist die DTR-Leitung des Anschlusses ständig eingeschaltet.
Damit die WIBU-BOX/ST eine stabile Spannungsversorgung erhält sollte zumindest eine der
beiden RTS- und DTR-Leitungen eingeschaltet sein. Mehr dazu unter Besondere Einstellungen
für die WIBU-BOX/ST in der Hilfe.

.topic 0x20A6B
Ist diese Option gesetzt, verwendet der WIBU-KEY-Treiber die Einstellungen, die
das System (BIOS, Betriebssystem etc.) diesem Anschluss zugewiesen hat. Ist die
Option nicht gesetzt können diese Einstellungen im unteren Teil des Dialogs explizit
und manuell ausgewählt werden, was insbesondere für die WIBU-BOX/CI und Anschlüsse
erforderlich ist, die nicht vom System erkannt werden.

.topic 0x20A6C
Hier kann die Adresse der Schnittstelle individuell in hexadezimaler Form angegeben
werden, wobei es empfehlenswert ist, eine der Werte aus der Liste zu verwenden.

.topic 0x20A6D
Bei Windows NT/2000/XP/Server 2003 kann hier der Bustyp der Schnittstelle angegeben werden.
Dies ist beim PC typischerweise ISA, EISA, PCI oder Internal.

.topic 0x20815
Diese Schaltfläche öffnet einen Dialog zur Suche nach WkNet-Dateien.

.topic 0x20A6E
Bei Windows NT/2000/XP kann hier der Busindex der Schnittstelle angegeben werden.
Sofern ein PC nicht mehrere Bussysteme gleichen Typs verwendet muss 0 angegeben werden.

.topic 0x20816
Diese Schaltfläche öffnet einen Dialog zur Suche nach einer Remote-Programming-Kontext-Datei.

.topic 0x20817
Diese Schaltfläche öffnet einen Dialog zur Suche nach einer Remote-Programming-Aktualisierungsdatei.

.topic 0x20A74
Hier wird der Pfad zu einer Wknet-Steuerungsdatei angegeben.

.topic 0x20A75
Pfad zu einer Remote-Programming-Kontext-Datei.

.topic 0x20A76
Wenn diese Option eingeschaltet ist, kann über das Netzwerk auf die an den WkLAN-Server
angeschlossenen Firm-Security-Box (FSB) zugegriffen werden.

.topic 0x20A77
Pfad zu einer Remote-Programming-Aktualisierungsdatei.

.topic 0x20A78
Wenn diese Option eingeschaltet ist, können an einen WkLAN-Sever angeschlosene WIBU-BOXen
nicht über das Netzwerk programmiert werden.

.topic 0x20A79
Wenn diese Option aktiviert ist, wird die Remote-Update-Datei nach dem Aktualisieren der
WIBU-BOXen automatisch gelöscht.

.topic 0x20A7B
Dieser Bereich enthält Einstellungen für das WkNet-Subsystem.

.topic 0x20A7C
Dieser Bereich enthält Einstellungen für das WkLAN-Subsystem.

.topic 0x20A7F
Hier wird die Refresh-Zeit für diese WkNet-Datei angegeben. Gültige Werte liegen im
Bereich von 10 Sekunden bis zu mehreren Stunden. Dieser Wert muss mit der in den
Anwendung verankerten Refresh-Zeit übereinstimmen oder kleiner sein.

.topic 0x20A80
Hier wird der Timeout-Wert für diese WkNet-Datei angegeben. Der Wertebereich des
Timeout-Werts ist abhängig von der gewählten Refresh Time. Der Timeout-Wert muss
mindestens das dreifache und maximal das 249-fache des Wertes der Refresh Time betragen.

.topic 0x20A81
Hier wird der Selection-Code für diese WkNet-Datei angegeben. Da dieser Wert auch in der
Anwendung verwendet werden muss, wird er von Softwarehersteller vorgegeben.

.topic 0x20A82
Diese Feld enthält die Adresse für den WkLAN-Port.

.topic 0x20A86
Diese Schaltfläche verschiebt den selektierten WkLAN-Server-Einträg um einen Position nach oben.

.topic 0x20A87
Diese Schaltfläche verschiebt den selektierten WkLAN-Server-Einträg um einen Position nach oben.

.topic 0x20A88
Diese Schaltfläche fügt einen WkNet-Datei-Eintrag hinzu.

.topic 0x20A89
Diese Schaltfläche löscht den selektierten WkNet-Datei-Eintrag.

.topic 0x20A8A
Diese Schaltfläche ändert den selektierten WkNet-Datei-Eintrag.

.topic 0x20A8B
Diese Schaltfläche öffnet einen Dialog zur Suche nach einer WkNet-Datei.

.topic 0x20A8C
Hier wird der Pfad zur WkNet-Datei der selektierten Applikation angegeben.

.topic 0x20A8D
Hier wird der Name der selektierten Applikation angegeben.

.topic 0x20A8E
Diese Liste dient zur Zuordnung von Applikationen zu den entsprechenden WkNet-Dateien.

.topic 0x20A8F
Das ist die Liste der Namen oder IP-Adressen unter denen der Treiber nach WkLAN-Servern
suchen soll. Die IP-Adresse 255.255.255.255 gibt an, dass das gesamte Subnetz nach
WkLAN-Servern durchsucht werden soll.

.topic 0x20A90
In diesem Feld wird der selektierte WkLAN-Server angezeigt.

.topic 0x20A91
Diese Schaltfläche fügt einen WkLAN-Server-Eintrag hinzu.

.topic 0x20A92
Diese Schaltfläche löscht den selektierten WkLAN-Server-Eintrag.

.topic 0x20A93
Diese Schaltfläche ändert den selektierten WkLAN-Server-Eintrag.

.topic 0x20A94
Diese Schaltfläche dient zur Suche nach WkLAN-Servern.

.topic 0x20A95
Das ist die Liste der WIBU-KEY-Subsysteme. Ein Haken zeigt an, dass diese Subsystem für
den Treiber aktiviert ist. Die Subsysteme werden in der angegeben Reihenfolge von oben
nach unten durchsucht.

.topic 0x20A96
Diese Schaltfläche verschiebt den selektierten Subsystem-Eintrag um einen Position nach oben.

.topic 0x20A97
Diese Schaltfläche verschiebt den selektierten Subsystem-Eintrag um einen Position nach unten.

.topic 0x20A98
Diese Schaltfläche setzt den Standardadresse für den WkLAN-Port ein (22347).

.topic 0x20A99
Diese Schaltfläche ändert den selektierten WkNet-Datei-Eintrag.

.topic 0x20A9A
Diese Schaltfläche fügt einen WkNet-Datei-Eintrag hinzu.

.topic 0x20A9B
Wählt den markierten Server aus und überträgt ihn in die Suchliste.

.topic 0x20A9E
Diese Liste zeigt in im Netzwerk gefundenen WkLAN-Server an.

.topic 0x20A57
Aktiviert das WkNet-Subsystem des WIBU-KEY Servers.

.topic 0x20AB2
Hier wird der aktuell verwendete Delay Factor angezeigt.
Die Anzeige "--" bedeutet das standardmäßig kein Delay Factor verwendet wird.
Ein Delay Factor muß in der Registry gesetzt werden und sollte nur auf anraten von Supportmitarbeitern
verwendet werden.

.topic 0x20AAA
Diese Schaltfläche öffnet ein Reportauswahlfenster mit dessen Hilfe Sie eine WIBU-SYSTEMS Report Datei
erzeugen können. Der Report beinhaltet Informationen über die WIBU-KEY Treiber den Benutzerstatus und
Informationen über das verwendete Betriebsystem.

.topic 0x20AC5
Mit diesem Auswahlfeld können Sie bestimmen ob die Einstellungen für folgenden WkLAN Netzwerkeinstellungen
für den „aktuellen Benutzer“ oder für den „gesamten PC“, d.h. alle Benutzer gelten sollen.

.topic 0x20820
Diese Liste zeigt alle WIBU-KEY Clients mit den
entsprechenden Berechtigungen an. Die Standardeinstellung
"Default" ist so gewählt, dass alle WIBU-KEY Clients im Netzwerk
alle Berechtigungen besitzen.

.topic 0x20821
Hier kann man den DNS-Name oder die IP-Adresse des Client-PCs definieren,
für den die speziellen Berechtigungen gelten sollen.

.topic 0x20822
Diese Option definiert ob ein Client die Berechtigung hat einen
WIBU-KEY Server zu suchen und sich die WIBU-BOX anzeigen zu lassen

.topic 0x20824
Diese Option definiert ob ein Client die Berechtigung hat eine Lizenz
auf dem WIBU-KEY Server zu belegen.

.topic 0x20826
Diese Option definiert ob ein Client die Berechtigung hat Netzwerk Benutzer
auf dem WIBU-KEY Server zu verwalten.

.topic 0x20827
Neu Berechtigung hinzufügen.

.topic 0x20828
Ausgewählte Berechtigung löschen.

.topic 0x20829
Ausgewählte Berechtigung ändern.


WkSvMon -Angezeigte Informationen über ein WkLAN Cluster-

Angezeigte Informationen über ein WkLAN Cluster

Wenn der Benutzer das Cluster Symbol in der WIBU-KEY Server Baumstruktur auswählt, werden Informationen über diesen Cluster im rechten Fenster angezeigt.
Der Name des Clusters, der Firm- und Usercode, die Art des WIBU-KEY Subsystems und die Anzahl der Server, auf die der Cluster verteilt ist, werden angezeigt. Die maximale Anzahl der Benutzer sowie die Anzahl freier Slots werden ebenfalls angezeigt.

Hinweis: Ein Cluster kann auf mehrere WkLAN Server verteilt sein. Wenn Sie das Netzwerk Symbol in der WIBU-KEY Baumstruktur auswählen, werden auf der rechten Seite alle Cluster im gesamten Netzwerk angezeigt, sofern die Ansicht "Serveransicht" oder "Clusteransicht" ausgewählt ist.


WIBU-KEY Netzwerk-Server Die Menüleiste

Die Menüleiste

Menü Datei

WkNet Datei öffnen...

Öffnet eine Dialogbox um eine WkNet Datei zu suchen die in der Server Baumstruktur angezeigt werden soll.

WkNet Datei schliessen

Entfernt eine WkNet Datei von der Server Baumstruktur.

Beenden

Beendet WkSvMon.

Menü Ansicht

Server Status

Zeigt das Statusfenster des gewählten WkLAN Servers. Dieser Menüpunkt ist nur aktiv, wenn ein Server in der Baumstruktur ausgewählt wurde.

Statistik

Zeigt eine statistische Auflistung von Zugriffen auf den gewählten WkLAN Server (derzeit noch nicht integriert).

Beenden

Beendet WkSvMon.

WkLAN Server

Aktiviert die Anzeige von WkLAN Servern.

WkNet Server

Aktiviert die Anzeige von WkNet Servern.

Clusteransicht

Die WIBU-KEY Baumstruktur zeigt an:Netzwerk - Cluster - Client - Server

Benutzeransicht

Die WIBU-KEY Baumstruktur zeigt an:Netzwerk - Client - Cluster - Server

Aktualisieren

Aktualisiert die Server Baumstruktur. Lediglich die Informationen über die Server, die schon registriert wurden, werden aktualisiert. Neu hinzugekommene Server werden nicht gesucht.

Netzwerk durchsuchen

Durchsucht das lokale Netzwerk nach WkLAN oder WkNet Servern.

Menü Benutzer

Benutzer löschen

Löscht einen einzelnen WkLAN oder WkNet Benutzer. Dieser Menüpunkt ist nur aktiv, wenn ein oder mehrere Benutzer in der Baumstruktur oder in der Liste ausgewählt wurden.

Alle Benutzer löschen

Löscht alle Benutzer des ausgewählten/aktivierten Servers. Dieser Menüpunkt ist nur aktiv, wenn Sie einen Server oder ein Cluster in der Baumstruktur oder in der Liste ausgewählt haben.

Menü Extras

Optionen…

Öffnet ein Fenster mit verschiedenen Konfigurationsoptionen. Auswählbar sind die WkSvMon Startart oder Einstellung der automatischen Aktualisierung.

Menü Hilfe

WkSvMon Hilfe

Öffnet die Onlinehilfe.

Info…

Zeigt Informationen über die verwendete Version an.


WIBU-KEY Netzwerk-Server Remote Access (Fernzugriff)

Benutzerberechtigungen (Fernzugriff)

Über die Seite Serverzugriff des WIBU-KEY Kontrollfelds können verschiedene Berechtigungsstufen für verschiede Clients (PCs) definiert werden.
Dies kann auch in der Registry des WIBU-KEY Servers gesetzt werden.Im Verzeichnis [RemoteAccess] in der Registry können Zugriffsrechte für den Zugriff auf den WIBU-KEY Server vergeben werden. Die Einträge hierfür lauten ;<ip adresse des clients>=(DWORD)<Zugriffsrechte>, wobei <Zugriffsrechte> bedeutet:
Schlüsselwort Bedeutung
1 | Inhalt lesen.
2 | Inhalt lesen (Details) (noch nicht implementiert).
4 | Lizenz belegen.
8 | Benutzer löschen.
16 | alle Benutzer löschen (noch nicht implementiert)
Kombinationen sind möglich, z.B. 7 = Inhalt lesen und Lizenz beglegen erlaubt, Benutzer löschen verboten. Der Eintrag Default = 31 bezeichnet die Rechte der Benutzer, die nicht explizit angegeben sind. Auch diese Rechte können eingeschränkt werden. Aus Kompatibilitätsgründen sind hier alle Aktionen per default erlaubt.


WIBU-KEY Netzwerk-Server Serverkonfiguration

Serverkonfiguration

Die grundlegenden Konfigurationseinstellungen des WIBU-KEY Netzwerk-Servers werden im Verzeichnis [Server] der Registry gespeichert. Die folgenden Werte können bestimmt werden:
Schlüsselwort Bedeutung
BindAddress | legt fest, an welcher IP-Adresse der WIBU-KEY-Server gebunden wird.
WkLAN | aktiviert (1) oder deaktiviert (0) die WkLAN-Funktionalität. -> "Einstellbar auf der Seite Server des WIBU-KEY Kontrollfelds"
WkNet | aktiviert (1) oder deaktiviert (0) die WkNet-Funktionalität -> "Einstellbar auf der Seite Server WkNet des WIBU-KEY Kontrollfelds".
Logging | aktiviert (1) oder deaktiviert (0) das Festhalten aller Aktionen in einer Datei. -> "Einstellbar im Kontextmenü des WIBU-KEY Server Icons"
LoggingPath | legt fest, in welchem Pfad die LOG-Datei gespeichert wird.


WIBU-KEY Netzwerk-Server WkLAN-Konfiguration

WkLAN Konfiguration

Die WkLAN-Server-Konfigurationseinstellungen für den WIBU-KEY Netzwerk-Server werden in das Verzeichnis [Network] in der Registry gespeichert.

Die folgenden Werte die man auf der Seite Netzwerk des WIBU-KEY Kontrollfelds einstellt ,können Sie auch im Abschnitt [WkLAN] festgelegen:
Schlüsselwort Bedeutung
IpPort legt die TCP/UDP Portnummer fest, die für die WkLAN-Kommunikation benutzt wird. Die WkLAN Verwaltung benutzt als Grundeinstellung Portnummer 22347 für den Zugriff auf einen WkLAN Server. Sollte diese Nummer bereits von einem anderen Serverprozess verwendet werden, kann sie an dieser Stelle geändert werden. Diese Änderung muß allerdings gleichzeitig für die WkLAN Benutzer vorgenommen werden. Ansonsten gibt es keine Kommunikation zwischen Anwendung und Server.
Die folgenden Werte die man auf der Seite Server des WIBU-KEY Kontrollfelds einstellt können auch im Abschnitt [WkLAN Server] festgelegt werden:
Schlüsselwort Bedeutung
AccessFsb | Ist diese Option aktiviert (1), so ist der Zugriff auf Firm Codes im Bereich 90-99 vom Netzwerk aus möglich. Dieser Bereich ist für Firm-Security-Boxen (FSB) belegt. Diese Option muß aktiviert sein, wenn die Firm-Security-Box an einen WkLAN-Server angeschlossen ist und jeder Benutzer Zugriff auf die FSB haben soll, um WIBU-BOXen über das Netzwerk programmieren zu können.
NoBoxPgm | muß aktiviert sein (1), um zu vermeiden, daß WIBU-BOXen, die an einen WkLAN-Server angeschlossen sind, von anderen Stationen aus umprogrammiert werden können.
Timeout | legt den Zeitraum in Minuten fest, nach dem ein belegter Slot in der WkLAN Benutzerliste automatisch freigegeben wird, wenn der dazugehörige Prozess innerhalb des Zeitraums nicht auf den Slot zugegriffen hat. Ist dieser Wert nicht festgelegt, wird ein Slot nach 1440 Minuten (24 Stunden) automatisch freigegeben.