Справка по AutoCAD 2010 для разработчиков

Добро пожаловать в справочную систему по AutoCAD 2010 для разработчиков

Справка по AutoCAD для разработчиков содержит исчерпывающую информацию по адаптации и расширению AutoCAD. Для перемещения по разделам можно воспользоваться ссылками справа или вкладкой "Содержание".

Общие сведения

Справочные документы

Руководство по адаптации

AutoLISP Reference (Справочник по AutoLISP)

AutoLISP Developer's Guide (Руководство по AutoLisp для разработчиков)

AutoLISP Tutorial (Учебное пособие по AutoLISP)

DXF Reference (Справочник по DXF)

ActiveX and VBA Developer's Guide (Руководство по ActiveX и VBA для разработчиков)

ActiveX and VBA Reference (Справочник по ActiveX и VBA)

Sheet Set Objects Reference (Справочник по объектам подшивок)

Connectivity Automation Reference (Справочник по автоматизации взаимосвязей)

ObjectARX
Интернет-ресурсы


AutoCAD 2010

Руководство по адаптации

В Руководстве по адаптации приведена информация по адаптации AutoCAD, предназначенная для опытных пользователей. Для перемещения по разделам Руководства по адаптации следует воспользоваться вкладкой "Содержание" в левой части окна "Справка".

  • Основные принципы адаптации
  • Настройка типов линий
  • Пользовательские образцы штриховки
  • Адаптация пользовательского интерфейса
  • DIESEL
  • Слайды и командные сценарии
  • Введение в интерфейсы программирования
  • Формы и шрифты
Общие сведения

Справочные документы

Руководство по адаптации

AutoLISP Reference (Справочник по AutoLISP)

AutoLISP Developer's Guide (Руководство по AutoLisp для разработчиков)

AutoLISP Tutorial (Учебное пособие по AutoLISP)

DXF Reference (Справочник по DXF)

ActiveX and VBA Developer's Guide (Руководство по ActiveX и VBA для разработчиков)


AutoLISP Reference (Справочник по AutoLISP)

AutoLISP Reference (Справочник по AutoLISP) представляет собой полное справочное руководство по AutoLISP® — интерпретируемому языку программирования, с помощью которого можно обращаться к командам AutoCAD, системным переменным и диалоговым окнам. Перечень разделов, включенных в документ AutoLISP Reference (Справочник по AutoLISP):

  • AutoLISP Functions (Функции AutoLISP): Operators (Операторы), A, B, C, D, E, F, G, H, I, J, K, L, M, N, O, P, Q, R, S, T, U, V, W, X, Y, Z.
  • Externally Defined Commands (Внешние команды)
Общие сведения

Справочные документы

Руководство по адаптации

AutoLISP Reference (Справочник по AutoLISP)

AutoLISP Developer's Guide (Руководство по AutoLisp для разработчиков)

AutoLISP Tutorial (Учебное пособие по AutoLISP)

DXF Reference (Справочник по DXF)


AutoLISP Developer's Guide (Руководство по AutoLisp для разработчиков)

AutoLISP Developer's Guide (Руководство по AutoLisp для разработчиков) содержит сведения по работе в интегрированной среде разработки приложений Visual LISP®, в которой пишутся и тестируются программы на языке AutoLISP®. Здесь также описывается использование программ, входящих в Visual LISP, для использования технологии ActiveX® Automation. Перечень разделов, включенных в документ AutoLISP Developer's Guide (Руководство по AutoLisp для разработчиков):

  • Introduction (Введение)
  • Using the Visual LISP Environment (Использование среды Visual LISP)
  • Using the AutoLISP Language (Использование языка AutoLISP)
  • Working with Programmable Dialog Boxes (Работа с программируемыми диалоговыми окнами)
  • Appendixes (Приложения)
Общие сведения

Справочные документы

Руководство по адаптации

AutoLISP Reference (Справочник по AutoLISP)

AutoLISP Developer's Guide (Руководство по AutoLisp для разработчиков)

AutoLISP Tutorial (Учебное пособие по AutoLISP)


AutoLISP Tutorial (Учебное пособие по AutoLISP)

AutoLISP Tutorial (Учебное пособие по AutoLISP) содержит упражнения с пошаговыми инструкциями, иллюстрирующие на практике использование Visual LISP™ для разработки программ на языке AutoLISP®. Перечень разделов, включенных в документ AutoLISP Tutorial (Учебное пособие по AutoLISP):

  • Introduction (Введение)
  • Designing and Beginning the Program (Постановка задачи и начало программирования)
  • Using Visual LISP Debugging Tools (Средства отладки Visual LISP)
  • Drawing the Path Boundary (Построение границы дорожки)
  • Creating a Project and Adding the Interface (Создание проекта и добавление элементов интерфейса)
  • Drawing the Tiles (Вычерчивание плиток)
  • Acting with Reactors (Использование реакторов)
  • Putting It All Together (Окончательная компоновка)
Общие сведения

Справочные документы

Руководство по адаптации

AutoLISP Reference (Справочник по AutoLISP)

AutoLISP Developer's Guide (Руководство по AutoLisp для разработчиков)

AutoLISP Tutorial (Учебное пособие по AutoLISP)


DXF Reference (Справочник по DXF)

DXF Reference (Справочник по DXF) содержит полное и исчерпывающее описание формата файлов DXF. Перечень разделов документа DXF Reference (Справочник по DXF):

  • DXF Format (Формат DXF)
  • HEADER Section (Раздел ЗАГОЛОВОК)
  • CLASSES Section (Раздел КЛАССЫ)
  • TABLES Section (Раздел ТАБЛИЦЫ)
  • BLOCKS Section (Раздел БЛОКИ)
  • ENTITIES Section (Раздел ПРИМИТИВЫ)
  • OBJECTS Section (Раздел ОБЪЕКТЫ)
  • THUMBNAILIMAGE Section (Раздел THUMBNAILIMAGE (миниатюры изображений))
  • Drawing Interexchange File Formats (Форматы DXF для обмена графической информацией)
  • Advanced DXF Issues (Дополнительные вопросы DXF)
Общие сведения

Справочные документы

Руководство по адаптации

AutoLISP Reference (Справочник по AutoLISP)

AutoLISP Developer's Guide (Руководство по AutoLisp для разработчиков)

AutoLISP Tutorial (Учебное пособие по AutoLISP)


ActiveX and VBA Developer's Guide (Руководство по ActiveX и VBA для разработчиков)

В документе ActiveX and VBA Developer's Guide (Руководство по ActiveX и VBA для разработчиков) разъясняется использование ActiveX и VBA для разработки приложений с целью адаптации AutoCAD. Документ включает в себя примеры программ и пошаговые инструкции. Перечень разделов, включенных в документ ActiveX and VBA Developer's Guide (Руководство по ActiveX и VBA для разработчиков):

  • Introduction (Введение)
  • Getting Started with VBA (Начало работы с VBA)
  • ActiveX Automation Basics (Основы работы с ActiveX Automation)
  • Control the AutoCAD Environment (Управление средой AutoCAD)
  • Create and Edit AutoCAD Entities (Создание и редактирование объектов AutoCAD)
  • Dimensions and Tolerances (Размеры и допуски)
  • Customize Toolbars and Menus (Адаптация панелей инструментов и меню)
  • Use Events (Использование событий)
  • Work in Three-Dimensional Space (Работа в 3D пространстве)
  • Define Layouts and Plot (Задание листов и печать)
  • Advanced Drawing and Organizational Techniques (Дополнительные методы работы с чертежами и их организации)
  • Develop Applications with VBA (Разработка приложений на VBA)
  • Interact with Other Applications and Windows APIs (Взаимодействие с другими приложениями и интерфейсами Windows API)
  • ActiveX/VBA Tutorial: Design the Garden Path (Учебное пособие по ActiveX/VBA: Проектирование садовой дорожки)
  • Visual LISP and ActiveX/VBA Comparison (Сравнение Visual LISP и ActiveX/VBA)
Общие сведения

Справочные документы

Руководство по адаптации

AutoLISP Reference (Справочник по AutoLISP)

AutoLISP Developer's Guide (Руководство по AutoLisp для разработчиков)

AutoLISP Tutorial (Учебное пособие по AutoLISP)


ActiveX and VBA Reference (Справочник по ActiveX и VBA)

ActiveX and VBA Reference (Справочник по ActiveX и VBA) является справочным руководством по объектной модели ActiveX и связанным с ней компонентам интерфейса. Перечень разделов, включенных в документ ActiveX and VBA Reference (Справочник по ActiveX и VBA):

  • Object Model (Объектная модель)
  • Events (События)
  • Methods (Методы)
  • Properties (Свойства)
  • Objects (Объекты)
  • Code Examples (Примеры кода)
Общие сведения

Справочные документы

Руководство по адаптации

AutoLISP Reference (Справочник по AutoLISP)

AutoLISP Developer's Guide (Руководство по AutoLisp для разработчиков)

AutoLISP Tutorial (Учебное пособие по AutoLISP)


Sheet Set Objects Reference (Справочник по объектам подшивок)

Документ Sheet Set Objects Reference (Справочник по объектам подшивок) содержит справочник по объектам для Диспетчера подшивок. Перечень разделов документа Sheet Set Objects Reference (Справочник по объектам подшивок):

  • Overview of Sheet Set Manager Objects (Обзор объектов Диспетчера подшивок)
  • Objects (Объекты)
  • Methods (Методы)
  • Properties (Свойства)
  • Enums (Перечни)
Общие сведения

Справочные документы

Руководство по адаптации

AutoLISP Reference (Справочник по AutoLISP)

AutoLISP Developer's Guide (Руководство по AutoLisp для разработчиков)

AutoLISP Tutorial (Учебное пособие по AutoLISP)


Connectivity Automation Reference (Справочник по автоматизации взаимосвязей)

Connectivity Automation Reference (Справочник по автоматизации взаимосвязей) содержит сведения об объектной модели Connectivity Automation и связанных с ней компонентах интерфейса. Перечень разделов документа Connectivity Automation Reference (Справочник по автоматизации взаимосвязей):

  • Connectivity Automation Objects (Объекты Connectivity Automation)
  • Object Model (Объектная модель)
  • Objects (Объекты)
  • Methods (Методы)
  • Properties (Свойства)
  • Events (События)
Общие сведения

Справочные документы

Руководство по адаптации

AutoLISP Reference (Справочник по AutoLISP)

AutoLISP Developer's Guide (Руководство по AutoLisp для разработчиков)

AutoLISP Tutorial (Учебное пособие по AutoLISP)


ObjectARX

ObjectARX® (среда программирования AutoCAD® Runtime Extension) включает в себя библиотеки для языка C++, с помощью которых можно разрабатывать приложения для AutoCAD, расширять набор классов и протоколов AutoCAD, создавать новые команды, неотличимые по способам выполнения от встроенных команд AutoCAD.

Если этот документ выглядит на вкладке "Содержание" как одна страничка ( [image]), документация по ObjectARX пока еще отсутствует на данном компьютере.

Документацию по ObjectARX AutoCAD можно загрузить из раздела Центр разработчика веб-узла Autodesk. Для включения документации по ObjectARX в документацию AutoCAD необходимо скопировать файлы справки ObjectARX в папку AutoCAD \HELP\.
Общие сведения

Справочные документы

Руководство по адаптации

AutoLISP Reference (Справочник по AutoLISP)

AutoLISP Developer's Guide (Руководство по AutoLisp для разработчиков)

AutoLISP Tutorial (Учебное пособие по AutoLISP)


Комментарии пользователя

Данная форма предназначена для ввода замечаний и предложений, которые будут отправлены в группу технической документации компании Autodesk.

Заголовок и расположение раздела (не изменять):
Имя и фамилия (не обязательно):
         E-mail (не обязательно):
Текст комментария:

Замечание: Форма не может служить средством получения советов или технической поддержки. Информация из нее будет использована для улучшения документации по продукту. Благодарим Вас!


Заполнение "Моих разделов"

Для добавления справочных сведений в "Мои разделы" необходимо вначале создать их в формате HTML, а затем скомпилировать программой Microsoft HTML Help Workshop, чтобы получился файл myhelp.chm. Этот файл следует поместить в папку AutoCAD\Help.

Включение подразделов в "Мои разделы"

  • Добавить к числу исходных компилируемых файлов файл со списком подразделов. Он должен иметь имя myhelp_toc.html.

Отображение заголовков подразделов на вкладке "Содержание"

  • Добавить к числу исходных компилируемых файлов HHC-файл содержания.

Возможность поиска разделов по ключевым словам

  • Добавить к числу исходных компилируемых файлов HHK-файл.

Даже если в CHM-файл пользовательской справки не включены ни myhelp_toc.html, ни HHC/HHK-файлы, сохраняется возможность показа содержимого "Моих разделов" через вкладку "Поиск".