Краткое руководство по сетевому лицензированию

Установка Network License Manager
Краткое руководство по сетевому лицензированию
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Настройка сетевых лицензий для продуктов Autodesk ® требует тщательного планирования и соответствующего исполнения. В этом разделе приведены пошаговые инструкции по формированию среды лицензирования в сети. Предполагается, что пользователь знаком с терминологией и процедурами, необходимыми для успешной сетевой работы продуктов Autodesk. Тем, кто вообще не знаком с сетевым лицензированием, перед установкой и настройкой системы сетевых лицензий следует прочитать весь документ Руководство по сетевому лицензированию.

Темы в этом разделе

  • Установка Network License Manager
  • Установка и использование программы активации сетевой лицензии
  • Настройка сервера лицензий (Windows)
  • Установка и использование SAMreport-Lite (не обязательно)
Отправьте ваши комментарии по поводу этой страницы


Установка Network License Manager

Краткое руководство по сетевому лицензированию
Краткое руководство по сетевому лицензированию
Установка и использование программы активации сетевой лицензии
Краткое руководство по сетевому лицензированию >
Установка Network License Manager
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Network License Manager служит для настройки серверов лицензий и управления ими.

Для установки Network License Manager

  1. В Мастере установки Autodesk выберите "Install Tools and Utilities" (Установка инструментов и утилит).
  2. На странице "Select the Products to Install" (Выберите устанавливаемые программы) выберите Autodesk Network License Manager и нажмите "Next" (Далее).
  3. Просмотрите лицензионный договор по программным продуктам Autodesk для своей страны или территории. Для продолжения установки следует принять условия данного договора. Выберите свою страну или область, нажмите кнопку "I Accept" (Принимаю) и нажмите кнопку "Далее".
    ПримечаниеВ случае несогласия с условиями договора и необходимости прервать установку нажмите "Cancel" (Отмена).
  4. На странице "Review - Configure - Install" (Обзор - Настройка - Установка) проверьте данные о выборе продукта и текущие настройки. Если изменять настройки не требуется, нажмите "Install" (Установить). Если необходимо изменить вариант установки или путь к программе, нажмите "Configure" (Настройка).
  5. На странице "Select the Installation Type" (Выбор варианта установки) выберите вариант "Typical" (Типовая) или "Custom" (Выборочная) и примите путь к программе, принятый по умолчанию (C:\Program Files\Autodesk Network License Manager\), или нажмите "Browse" (Обзор), чтобы указать другой путь. Если выбранная папка не существует, программа создаст новую папку с именем и местоположением, указанным пользователем. Нажмите "Далее".
    ПредупреждениеНе следует устанавливать программу Network License Manager на удаленном диске. При установке файлов Network License Manager необходимо задать путь, указывающий на локальный жесткий диск. Необходимо указать букву, которая обозначает диск; использовать универсальное соглашение об именах (UNC) не разрешается.
  6. На странице "Configuration Complete" (Настройка завершена) нажмите кнопку "Configuration Complete" (Настройка завершена), чтобы вернуться на страницу подтверждения.
  7. На странице "Обзор - Настройка - Установка" нажмите "Установить".
  8. Когда появится страница "Установка завершена", нажмите "Готово".


Установка и использование программы активации сетевой лицензии

Установка Network License Manager
Краткое руководство по сетевому лицензированию
Настройка сервера лицензий (Windows)
Краткое руководство по сетевому лицензированию >
Установка и использование программы активации сетевой лицензии
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Программа активации сетевой лицензии служит для получения лицензий через Интернет. Тем самым экономятся время и силы, затрачиваемые на подготовку программы к работе в сетевой среде. Кроме того, утилита позволяет зарегистрировать программу, получить помощь по электронной почте (в случаях, когда не удается получить лицензию через Интернет), а также автоматически сохранять и переносить файлы с лицензиями.

Для установки программы активации сетевой лицензии

  1. В Мастере установки Autodesk выберите "Install Tools and Utilities" (Установка инструментов и утилит).
    ПримечаниеКаждая установка программы активации сетевой лицензии выполняется для конкретного программного продукта. При наличии нескольких программ Autodesk и при необходимости установить программу активации сетевой лицензии для всех этих программ, следует установить ее отдельно для каждой программы.
  2. На странице "Select the Products to Install" (Выберите устанавливаемые программы) выберите Autodesk Network License Manager и нажмите "Next" (Далее).
  3. Просмотрите лицензионный договор по программным продуктам Autodesk для своей страны или территории. Для продолжения установки следует принять условия данного договора. Выберите свою страну или область, нажмите кнопку "I Accept" (Принимаю) и нажмите кнопку "Далее".
    ПримечаниеВ случае несогласия с условиями договора и необходимости прервать установку нажмите "Cancel" (Отмена).
  4. На странице "Review - Configure - Install" (Обзор - Настройка - Установка) проверьте данные о выборе продукта и текущие настройки. Если изменять настройки не требуется, нажмите "Install" (Установить).

    Если необходимо изменить вариант установки или путь к программе, нажмите "Configure" (Настройка).

  5. На странице "Select the Installation Type" (Выбор варианта установки) выберите вариант "Typical" (Типовая) или "Custom" (Выборочная) и задайте установочную папку, принятую по умолчанию (C:\Program Files\Autodesk Network License Manager\Network License Activation Utility), или нажмите "Browse" (Обзор), чтобы указать другой путь. Если выбранная папка не существует, программа создаст новую папку с именем и местоположением, указанным пользователем. Нажмите "Далее".
  6. На странице "Configuration Complete" (Настройка завершена) нажмите кнопку "Configuration Complete" (Настройка завершена), чтобы вернуться на страницу подтверждения.
  7. На странице "Обзор - Настройка - Установка" нажмите "Установить".
  8. Когда появится страница "Установка завершена", нажмите "Готово".

Для использования программы активации сетевой лицензии (интерактивный запрос)

  1. Выполните одно из следующих действий:
    • (Windows XP) Выберите меню "Пуск" [image] "Программы" [image] Autodesk [image] Network License Manager [image] [Программа Autodesk] Network License Activation Utility.
    • (Windows Vista) Выберите меню "Пуск" [image] "Все программы" [image] Autodesk [image] Network License Manager [image] [Программа Autodesk] Network License Activation Utility.
  2. На странице "Obtain a Network License" (Получение сетевой лицензии) убедитесь, что установлено прямое подключение к сети Интернет (активна кнопка "Direct Connect"), введите ключ программного продукта и нажмите кнопку "Next" (Далее).
  3. На странице "Server Information" (Информация о сервере) введите следующие данные:
    • Серийный номер программного продукта
      ПримечаниеВ случае изменения существующего файла лицензии или получения новой лицензии для существующего продукта может отобразиться ранее введенная информация. Убедитесь, что отображается именно тот серийный номер, который необходимо лицензировать. Если это не так, введите правильный серийный номер.
    • Модель сервера лицензий

      Более подробную информацию об имеющихся вариантах модели можно получить, нажав кнопку с вопросительным знаком.

    • Имя хоста

      (Windows) Если имя хоста неизвестно, введите в командной строке указанный ниже запрос для поиска имени каждого сервера, который планируется использовать:

      <запрос> lmutil lmhostid -hostname
      ПримечаниеВ модели "Распределенный сервер" введено ограничение на максимально возможное количество серверов - 20. Как только будет выбрано 20 серверов, кнопка "Add" (Добавить) исчезнет.
    • Идентификатор узла, для которого было введено имя сервера

      (Windows) Если не удается найти идентификатор хоста, нажмите кнопку "Lookup" (Поиск), чтобы утилита автоматически определила местонахождение идентификатора хоста для сервера (серверов).

      ПримечаниеЕсли на сервере установлено несколько сетевых адаптеров, необходимо выбрать тот из них, который соответствует физическому устройству. Чтобы определить, какие адаптеры являются физическими, в командной строке Windows введите ipconfig/all и просмотрите содержание поля "Description" (Описание), расположенного выше каждого физического адреса. Если физических сетевых адаптеров несколько, можно использовать любой из них, поскольку при выполнении командой ipconfig /all его имя выводится в список. Логические устройства (VPN-адаптеры, PPP-адаптеры, модемы и др.) могут также попасть в указанный выше список, но для работы с лицензиями не годятся.
    • Количество рабочих мест для каждого сервера лицензий

      Если выбрана модель "Распределенный сервер", появляется поле "Seats" (Рабочие места). Введите количество рабочих мест для каждого сервера лицензий.

    Нажмите "Далее".

  4. На странице "Confirm Server Information" (Подтверждение сведений о сервере) проверьте введенную информацию и нажмите "Next" (Далее).
  5. На странице "Log In" (Вход в систему) введите идентификатор пользователя и пароль, и затем нажмите кнопку " Log In" (Вход в систему).

    Если учетная запись пользователя не создана, нажмите кнопку "Create a User ID Now" (Создание идентификатора нового пользователя) и далее руководствуйтесь экранными инструкциями для создания новой учетной записи.

  6. На странице "Choose Account" (Выбор учетной записи) выберите учетную записи и нажмите кнопку "Next" (Далее).
  7. На странице "License(s) Received" (Полученные лицензии) в поле "Save License File" (Сохранить файл лицензий) для [имя компьютера] укажите папку для сохранения файла лицензии или нажмите "Browse" (Обзор) для выбора места сохранения.
    ПримечаниеРекомендуется сохранить файл лицензий в папкеC:\Program Files\Autodesk Network License Manager\License.

    Содержимое этой страницы зависит от выбранной модели сервера.

    Нажмите "Далее".

  8. На странице "License Activation Successful" (Активация лицензии успешно выполнена) нажать кнопку "Print" (Печать), чтобы вывести информацию о лицензии на печать, либо нажать "Done" (Готово) для завершения групповой операции и выхода из программы активации сетевой лицензии.

(Windows) После получения и сохранения файла лицензии следует обратиться к разделу Настройка сервера лицензий (Windows), чтобы настроить Диспетчер лицензий.

Для использования программы активации сетевой лицензии (автономный запрос)

  1. Выполните одно из следующих действий:
    • (Windows XP) Выберите меню "Пуск [image] "Программы" [image] Autodesk [image] Network License Manager [image] [Программа Autodesk] Network License Activation Utility.
    • (Windows Vista) Выберите меню "Пуск" [image] "Все программы" [image] Autodesk [image] Network License Manager [image] [Программа Autodesk] Network License Activation Utility.
  2. На странице "Obtain a Network License" (Получение сетевой лицензии) выберите "Email" (По электронной почте), "Fax" (По факсу), "Phone" (По телефону) или "Send request by postal mail" (Послать запрос по почте), введите ключ программного продукта и нажмите кнопку "Next" (Далее).
  3. На странице "Server Information" (Информация о сервере) введите следующие данные:
    • Серийный номер программного продукта
      ПримечаниеВ случае изменения существующего файла лицензии или получения новой лицензии для существующего продукта может отобразиться ранее введенная информация. Убедитесь, что отображается именно тот серийный номер, который необходимо лицензировать. Если это не так, введите правильный серийный номер.
    • Модель сервера лицензий

      Более подробную информацию об имеющихся вариантах модели можно получить, нажав на кнопку с вопросительным знаком.

    • Имя хоста

      (Windows) Если имя хоста неизвестно, введите в командной строке указанный ниже запрос для поиска имени каждого сервера, который планируется использовать:

      <запрос> lmutil lmhostid -hostname
      ПримечаниеВ модели "Распределенный сервер", введено ограничение максимум 20 серверов. Как только будет выбрано 20 серверов, кнопка "Add" (Добавить) исчезнет.
    • Идентификатор узла, для которого было введено имя сервера

      (Windows) Если не удается найти идентификатор хоста, нажмите кнопку "Lookup" (Поиск), чтобы утилита автоматически определила местонахождение идентификатора хоста для сервера (серверов).

      ПримечаниеЕсли на сервере установлено несколько сетевых адаптеров, необходимо выбрать тот из них, который соответствует физическому устройству. Чтобы определить, какие адаптеры являются физическими, в командной строке Windows введите ipconfig/all и просмотрите содержание поля "Description" (Описание), расположенного выше каждого физического адреса. Если физических сетевых адаптеров несколько, можно использовать любой из них; для этого необходимо, чтобы его имя выводилось в список командой ipconfig /all. Логические устройства (VPN-адаптеры, PPP-адаптеры, модемы и др.) могут также попасть в указанный выше список, но для работы с лицензиями не годятся.
    • Количество рабочих мест для каждого сервера лицензий

      Если выбрана модель "Распределенный сервер", появляется поле "Seats" (Рабочие места). Введите количество рабочих мест для каждого сервера лицензий.

    Нажмите "Далее".

  4. На странице "Confirm Server Information" (Подтверждение сведений о сервере) проверьте введенную информацию и нажмите "Next" (Далее).
  5. На странице "Product Registration" (Регистрация продукта) укажите следующую информацию.
    • Предоставляется ли регистрируемая программа организации или физическому лицу.
    • Страна или регион, где будет использоваться программа.
    • Является ли программа обновленной версией ранее установленной программы. В этом случае потребуется также серийный номер предыдущей версии программы.

    Нажмите "Далее".

  6. На странице "Customer Information" (Данные о пользователе) введите личные данные и укажите предпочтительный способ получения кода активации - "Email" (По электронной почте), "Fax" (По факсу) или "Postal mail" (По почте). Нажмите "Далее".
  7. На странице "Confirm Information" (Подтверждение данных) проверьте личные данные и укажите способ передачи запроса. Запрос можно отправить по электронной почте, по факсу или по телефону.

    При выборе варианта "Send my request by Email" (Отправить запрос по электронной почте) на экран выводится страница электронного сообщения для заполнения. При выборе варианта отправки запроса по факсу или по телефону на экране отобразится страница "Contact Autodesk" (Связаться с Autodesk), содержащая соответствующие контактные данные.

    Код активации будет прислан вам способом, указанным на странице "Customer Information" (Данные о пользователе).

  8. Если требуется вывести на печать страницу с регистрационной информацией, выберите "Select Open Activation Request Form" (Выбор открытой формы запроса на активацию). По завершении нажмите кнопку "Закрыть".

(Windows) После получения и сохранения файла лицензии следует обратиться к разделу Настройка сервера лицензий (Windows), чтобы настроить Диспетчер лицензий.

ПримечаниеРекомендуется сохранять файл лицензий там же, где установлен "Network License Manager" (Диспетчер сетевых лицензий).


Настройка сервера лицензий (Windows)

Установка и использование программы активации сетевой лицензии
Краткое руководство по сетевому лицензированию
Установка и использование SAMreport-Lite (не обязательно)
Краткое руководство по сетевому лицензированию >
Настройка сервера лицензий (Windows)
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Настройка сервера лицензий осуществляется таким образом, чтобы можно было управлять лицензиями на продукт Autodesk, полученными с помощью программы активации сетевой лицензии. Для настройки параметров сервера используется утилита lmtools.exe.

Для настройки параметров сервера лицензий

Для работы с утилитой LMTOOLS необходимо войти в систему с правами администратора.

  1. Выполните одно из следующих действий:
    • (Windows XP) Выберите меню "Пуск" [image] "Программы" [image] Autodesk [image] Network License Manager [image] LMTOOLS.
    • (Windows Vista) Дважды щелкните на значке LMTOOLS на рабочем столе.
  2. На вкладке "Service/License File" (Службы/Файлы лицензий) программы LMTOOLS убедитесь, что установлен флажок "Configure Using Services" (Настроить, используя службы).
  3. Перейти на вкладку "Config Services" (Настроить службу).
  4. В списке "Service Name" (Имя службы) выберите имя службы, которое требуется использовать для управления лицензиями.

    По умолчанию установлена служба Flexlm Service 1. Если FLEXnet® на данном компьютере управляет не только программами Autodesk, но и другим программным обеспечением, можно изменить имя службы, чтобы избежать путаницы. Например, службу Flexlm Service 1 можно переименовать в Autodesk Server1.

    ПримечаниеЕсли для управления лицензиями имеется несколько поставщиков программного обеспечения, использующего FLEXnet®, в списке "Service Name" (Имя службы) отображается несколько вариантов. Убедитесь, что указана только одна служба Autodesk.
  5. В поле "Path to Lmgrd.exe File" (Путь к файлу Lmgrd.exe) задайте путь к демону Network License Manager (lmgrd.exe), или найдите его с помощью кнопки "Browse" (Обзор).

    По умолчанию этот демон устанавливается в папку C:\Program Files\Autodesk Network License Manager.

  6. В поле "Path to the License File" (Путь к файлу лицензий) введите путь к файлу лицензий или найти его с помощью кнопки "Browse" (Обзор).

    Это задает путь к файлу лицензии, полученному программой активации сетевой лицензии, или местоположение, куда был помещен файл лицензии, если он был получен в автономном режиме.

  7. В поле "Path to the Debug Log File" (Путь к файлу отладочного журнала) введите путь, по которому формируется отладочный журнал, или найдите с помощью кнопки "Browse" (Обзор) существующий журнал.

    Рекомендуется сохранять свои файлы в папке C:\Program Files\Autodesk Network License Manager. Файл журнала должен иметь расширение .log. Для открытия нового файла журнала введите расширение.log вручную.

  8. Для запуска lmgrd.exe в качестве службы установить флажок "Use Services".
  9. Для автоматической загрузки lmgrd.exe при запуске системы установите флажок "Start Server at Power Up" (Запуск сервера при включении питания).
  10. Для сохранения настроек с именем, заданным в пункте 4, нажать кнопку "Save Service" (Сохранить службу). Нажмите "Yes" (Да) при выводе запроса на сохранение настроек для службы.
  11. Выбрать вкладку "Start/Stop/Reread" (Начать/Остановить/Перечитать) и выполнить одно из следующих действий.
    • Если службы для продуктов Autodesk еще не созданы, нажать кнопку "Start Server" (Запустить сервер) для запуска сервера лицензий.
    • Если служба для продукта Autodesk уже создана и запущена, нажать кнопку "ReRead License File" (Прочитать еще раз файл лицензий) для обновления Диспетчера сетевых лицензий и всех изменений файла лицензий или параметров.

    Сервер лицензий запускается и готов обрабатывать запросы клиентов.

  12. Закрыть lmtools.exe.


Установка и использование SAMreport-Lite (не обязательно)

Настройка сервера лицензий (Windows)
Краткое руководство по сетевому лицензированию
Введение в принципы работы с инструментами сетевого лицензирования Autodesk
Краткое руководство по сетевому лицензированию >
Установка и использование SAMreport-Lite (не обязательно)
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

SAMreport-Lite - это инструмент для составления отчетов, помогающий отслеживать использование сетевых лицензий. С помощью технологии SAMreport-Lite, разработанной корпорацией Acresso™ Software, можно контролировать использование клиентами программных продуктов Autodesk, имеющих сетевые лицензии.

Более подробная информация об установке и использовании технологии SAMreport-Lite содержится в Руководстве пользователя SAMreport-Lite; щелкните на ссылке "Documentation" (Документация) в нижнем левом углу мастера установки или обратитесь к справочной системе по данному программному продукту Autodesk.


Введение в принципы работы с инструментами сетевого лицензирования Autodesk

Установка и использование SAMreport-Lite (не обязательно)
Диспетчер сетевых лицензий (Network License Manager)
Введение в принципы работы с инструментами сетевого лицензирования Autodesk
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Инструментами сетевого лицензирования для продуктов Autodesk являются Диспетчер сетевых лицензий Network License Manager, программа активации сетевой лицензии, средства настройки FLEXnet и SAMreport-Lite. Описание каждого инструмента приведено в следующих разделах.

Темы в этом разделе

  • Диспетчер сетевых лицензий (Network License Manager)
  • Программа активации сетевой лицензии
  • Инструменты настройки FLEXnet
  • Инструмент составления отчетов о лицензиях SAMreport-Lite


Диспетчер сетевых лицензий (Network License Manager)

Введение в принципы работы с инструментами сетевого лицензирования Autodesk
Введение в принципы работы с инструментами сетевого лицензирования Autodesk
Системные требования для установки Network License Manager
Введение в принципы работы с инструментами сетевого лицензирования Autodesk >
Диспетчер сетевых лицензий (Network License Manager)
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Network License Manager служит для настройки серверов лицензий и управления ими. При создании развертывания мастер установки выдает запросы о вводе сведений о диспетчере лицензий, например о модели сервера лицензий и имени сервера.

Более подробная информация о развертывании продуктов Autodesk в сети содержится в руководстве сетевого администратора, доступном в документации (кнопка в левом нижнем углу мастера установки) или в справочной системе программы.

Темы в этом разделе

  • Системные требования для установки Network License Manager


Системные требования для установки Network License Manager

Диспетчер сетевых лицензий (Network License Manager)
Диспетчер сетевых лицензий (Network License Manager)
Программа активации сетевой лицензии
Введение в принципы работы с инструментами сетевого лицензирования Autodesk > Диспетчер сетевых лицензий (Network License Manager) >
Системные требования для установки Network License Manager
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Сервер лицензий должен удовлетворять минимальным требованиям к рекомендуемой конфигурации системы. Предъявляемые к системе требования изложены в следующей таблице.

ПримечаниеНе все программные продукты могут работать в любой операционной системе. Сведения о поддерживаемых данным программным продуктом операционных системах см. в документе Руководство сетевого администратора.
Требования к аппаратным средствам и программному обеспечению сервера лицензий
Элемент | Требование | Замечания
Операционная система | Windows Vista®, 32-разрядный пакет SP1 Windows Vista, 64-разрядный пакет SP1 Windows® XP, 32-разрядный пакет SP3 Windows XP, 64-разрядный пакет SP2 Windows 2003 R2 Server Edition Windows 2003 Server Edition Windows 2000 Server Edition* ®® | Network License Manager поддерживает только сети Ethernet. *Если используется Windows 2000 Server, следует вручную установить Network License Manager, имеющийся в установочной папке данного программного продукта: CDROM1\x86\support\NLM\en-US\NLM.msi.
Компьютер/процессор | Pentium® III или выше 450 МГц (минимум) Intel Mac |
Сетевой адаптер | Совместимый с имеющейся инфраструктурой сети Ethernet | Network License Manager поддерживает несколько типов сетевых адаптеров, но хотя бы один из них должен быть адаптером Ethernet.
Коммуникационный протокол | TCP/IP | Network License Manager работает с пакетами типа TCP.


Программа активации сетевой лицензии

Системные требования для установки Network License Manager
Введение в принципы работы с инструментами сетевого лицензирования Autodesk
Инструменты настройки FLEXnet
Введение в принципы работы с инструментами сетевого лицензирования Autodesk >
Программа активации сетевой лицензии
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Программа активации сетевой лицензии служит для получения лицензий через Интернет. Ее использование позволяет сэкономить время и силы, затрачиваемые на подготовку продукта Autodesk к работе в сетевой среде.

Кроме того, эта программа отвечает за регистрацию программного продукта, обеспечивает автоматическое формирование сообщений электронной почты в случае отсутствия возможности получить лицензию в реальном времени через Интернет, а также автоматически сохраняет и перемещает файлы лицензий.

ПримечаниеДля получения файла лицензии рекомендуется использовать программу активации сетевой лицензии. Если возможность выхода в Интернет для получения файла лицензии отсутствует, см. Использование программы "Network License Activation" (Активации сетевой лицензии).


Инструменты настройки FLEXnet

Программа активации сетевой лицензии
Введение в принципы работы с инструментами сетевого лицензирования Autodesk
Утилиты для управления сервером лицензий
Введение в принципы работы с инструментами сетевого лицензирования Autodesk >
Инструменты настройки FLEXnet
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Диспетчер Network License Manager использует технологию управления лицензиями FLEXnet®, разработанную компанией Acresso Software. Технология FLEXnet предоставляет средства администрирования, которые позволяют упростить управление сетевыми лицензиями. Средства FLEXnet можно использовать для просмотра статуса сетевых лицензий, восстановления лицензий, утерянных вследствие сбоев системы, устранения ошибок на серверах лицензий, а также для быстрого обновления существующих файлов лицензий.

Темы в этом разделе

  • Утилиты для управления сервером лицензий
  • Файл параметров


Утилиты для управления сервером лицензий

Инструменты настройки FLEXnet
Инструменты настройки FLEXnet
Файл параметров
Введение в принципы работы с инструментами сетевого лицензирования Autodesk > Инструменты настройки FLEXnet >
Утилиты для управления сервером лицензий
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Для управления сервером лицензий FLEXnet предоставляет две утилиты. Эти программы хранятся в папке C:\Program Files\Autodesk Network License Manager.

lmtools.exe

Утилита управления сервером лицензий, обладающая графическим пользовательским интерфейсом Microsoft® Windows.

lmutil.exe

Утилита управления сервером лицензий, имеющая интерфейс командной строки.

Утилиты lmtools.exe и lmutil.exe используются для решения следующих задач по управлению сервером лицензий:

  • Запуск, остановка работы и перезапуск сервера.
  • Настройка, обновление и повторный запуск файла лицензий.
  • Диагностирование системы и проблем с лицензированием.
  • Просмотр статуса сервера, включая статус лицензий.


Файл параметров

Утилиты для управления сервером лицензий
Инструменты настройки FLEXnet
Инструмент составления отчетов о лицензиях SAMreport-Lite
Введение в принципы работы с инструментами сетевого лицензирования Autodesk > Инструменты настройки FLEXnet >
Файл параметров
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Другим компонентом FLEXnet является файл параметров. С помощью этого файла можно настраивать специальные параметры. Подробнее о создании и использовании файлов параметров см. Настройка и использование файла параметров.

Файл параметров используется для настройки следующих параметров сервера:

Отчет об использовании лицензий

Создание сжатого зашифрованного файла, содержащего отчет об использовании лицензий с помощью SAMreport-Lite. Для получения дополнительной информации о SAMreport-Lite см. Руководство пользователя SAMreport-Lite, доступное с помощью вкладки "Documentation" (Документация) Обозревателя меню.

Заимствование лицензий

Если продукт Autodesk поддерживает заимствование лицензий, пользователям разрешено заимствовать лицензии с сервера и работать с продуктом локально, без подключения к серверу лицензий. Лицензия заимствуется на ограниченный период времени.

Тайм-аут лицензий

Тайм-аут лицензий позволяет устанавливать на сервере лицензий период пользования отдельно для каждого программного продукта Autodesk. Благодаря этой функции при потере связи с рабочей станцией, или если лицензия забрана, а продукт Autodesk не используется на рабочей станции дольше заданного для тайм-аута времени, лицензия автоматически возвращается на сервер лицензий.

Функция timeoutall для настройки лицензий

С помощью функции timeoutall можно установить на сервере лицензий одно значение периода пользования для всех программных продуктов Autodesk, установленных на данном компьютере. Благодаря этой функции при потере связи с рабочей станцией, или если лицензия забрана, а продукт Autodesk не используется на рабочей станции дольше заданного для тайм-аута времени, лицензия автоматически возвращается на сервер лицензий.

Для получения более подробной информации о параметрах настройки см. Настройка и использование файла параметров.

Дополнительная информация об использовании инструментов конфигурирования FLEXnet приведена в справочной документации по FLEXnet, находящейся в файле C:\Program Files\Autodesk Network License Manager\Docs\FlexUser\LicenseAdministration.pdf.


Инструмент составления отчетов о лицензиях SAMreport-Lite

Файл параметров
Введение в принципы работы с инструментами сетевого лицензирования Autodesk
Выбор модели лицензирования
Введение в принципы работы с инструментами сетевого лицензирования Autodesk >
Инструмент составления отчетов о лицензиях SAMreport-Lite
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Версия SAMreport, называемая SAMreport-Lite, не включена в установку, но с ее помощью можно отслеживать сетевые лицензии. С помощью технологии SAMreport-Lite, разработанной корпорацией Acresso Software, можно контролировать использование клиентами программных продуктов Autodesk, имеющих сетевые лицензии.

SAMreport-Lite позволяет формировать отчеты об использовании лицензий в различных форматах, в том числе в HTML-формате, текстовом формате и формате Report Interchange. Дополнительную информацию о SAMreport-Lite, в том числе инструкции по установке этого средства, можно найти в Руководстве пользователя SAMreport-Lite.

ПримечаниеУстановить SAMreport-Lite, а также ознакомиться с Руководством пользователя SAMreport-Lite можно с помощью обозревателя меню данного программного продукта Autodesk.

Для получения дополнительной информации о SAMreport-Lite, а также обновлений этой программы посетите веб-узел Autodesk по адресу:

www.autodesk.com/samreportlite


Выбор модели лицензирования

Инструмент составления отчетов о лицензиях SAMreport-Lite
Выбор конфигурации серверов лицензий
Выбор модели лицензирования
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

В этом разделе представлена информация, которую требуется знать до начала установки сервера сетевых лицензий. В этом разделе содержится информация о поддерживаемых моделях сервера лицензий, о действии и наличии лицензии, а также определения и параметры, примеры файлов лицензий, типы и варианты поведения лицензий, а также сведения о тактовом сигнале сервера лицензий.

Темы в этом разделе

  • Выбор конфигурации серверов лицензий
  • Сведения о лицензиях


Выбор конфигурации серверов лицензий

Выбор модели лицензирования
Выбор модели лицензирования
Конфигурация с одним сервером лицензий
Выбор модели лицензирования >
Выбор конфигурации серверов лицензий
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Прежде всего необходимо выбрать модель конфигурации сервера лицензий, которая будет использоваться для управления лицензиями на программу Autodesk. Autodesk поддерживает следующие модели конфигурации серверов лицензий:

  • Конфигурация с одним сервером лицензий
  • Конфигурация с несколькими серверами лицензий
  • Конфигурация с резервными серверами лицензий

Темы в этом разделе

  • Конфигурация с одним сервером лицензий
  • Конфигурация с несколькими серверами лицензий
  • Конфигурация с резервными серверами лицензий


Конфигурация с одним сервером лицензий

Выбор конфигурации серверов лицензий
Выбор конфигурации серверов лицензий
Конфигурация с несколькими серверами лицензий
Выбор модели лицензирования > Выбор конфигурации серверов лицензий >
Конфигурация с одним сервером лицензий
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

В модели с одним сервером лицензий Network License Manager устанавливается на одном сервере, на котором и осуществляется вся деятельность по управлению лицензиями. Все лицензии, доступные на сервере, представлены в едином файле лицензий.

Преимущества конфигурации с одним сервером лицензий

  • Поскольку управление лицензиями осуществляется на одном сервере, то пункт администрирования и источник возможных сбоев сосредоточены в одном месте.
  • Из всех трех моделей серверов лицензий такая конфигурация наиболее проста в обслуживании.

Недостатки конфигурации с одним сервером лицензий

  • При сбое единственного сервера лицензий работа с продуктом Autodesk становится невозможной до устранения неполадок.


Конфигурация с несколькими серверами лицензий

Конфигурация с одним сервером лицензий
Выбор конфигурации серверов лицензий
Конфигурация с резервными серверами лицензий
Выбор модели лицензирования > Выбор конфигурации серверов лицензий >
Конфигурация с несколькими серверами лицензий
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

В модели с несколькими серверами источники лицензий распределены в сети. Для каждого сервера необходим собственный уникальный файл лицензий. Для создания распределенного сервера лицензий необходимо запустить Network License Manager на каждом из серверов, входящих в распределенный серверный пул.

Преимущества конфигурации с несколькими серверами лицензий

  • Серверы могут работать в территориально распределенных сетях (WAN). Нахождения в единой подсети от них не требуется.
  • При сбое одного из серверов распределенного пула лицензии на остальных серверах остаются доступными.
  • Для замены одного из серверов в распределенном пуле нет необходимости перестраивать весь пул.
  • Замена серверов осуществляется проще, чем в модели с резервными серверами, где для этого необходимо возобновить работу всего пула.

Недостатки конфигурации с несколькими серверами лицензий

  • При сбое одного из серверов распределенного пула лицензии на нем становятся недоступными.


Конфигурация с резервными серверами лицензий

Конфигурация с несколькими серверами лицензий
Выбор конфигурации серверов лицензий
Сведения о лицензиях
Выбор модели лицензирования > Выбор конфигурации серверов лицензий >
Конфигурация с резервными серверами лицензий
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

В конфигурации с резервными серверами лицензий для удостоверения одного файла лицензии используются три сервера. Один из них является основным, а два других — резервными, используемыми при сбое основного сервера. В этой конфигурации выдача лицензий не прекращается, если функционируют хотя бы два из этих трех серверов. Файл лицензий одинаков на всех трех серверах. На каждом из серверов необходимо установить Network License Manager.

В конфигурации с резервными серверами лицензий необходимо, чтобы все серверы находились в одной подсети и имели надежное соединение. Серверы с медленным, неустойчивым или коммутируемым соединением не поддерживаются.

Преимущества конфигурации с резервными серверами лицензий

  • При сбое одного из трех серверов все лицензии, управляемые распределенным пулом, остаются доступными.

Недостатки конфигурации с резервными серверами лицензий

  • Если сбои произошли более чем на одном сервере, все лицензии становятся недоступными.
  • Все три сервера должны входить в одну подсеть и иметь надежные сетевые связи. Конфигурация с резервными серверами неустойчива при сбоях в сети.
  • При замене любого из трех серверов необходимо перестроить весь пул серверов.
  • Если установленный на компьютере продукт Autodesk поддерживает заимствование лицензий и лицензии заимствуются с пула резервного сервера лицензий, после останова Network License Manager необходимо перезапустить сервер лицензий.


Сведения о лицензиях

Конфигурация с резервными серверами лицензий
Выбор модели лицензирования
Действия с лицензиями и свободные лицензии
Выбор модели лицензирования >
Сведения о лицензиях
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

В данном разделе приводятся сведения о работе и доступности лицензий, о файле лицензий, типах и видах лицензий и о тактовом сигнале.

Темы в этом разделе

  • Действия с лицензиями и свободные лицензии
  • Файлы лицензий
  • Примеры файлов лицензий
  • Примеры пакетных файлов лицензий
  • Типы и виды лицензий
  • Тактовый сигнал


Действия с лицензиями и свободные лицензии

Сведения о лицензиях
Сведения о лицензиях
Файлы лицензий
Выбор модели лицензирования > Сведения о лицензиях >
Действия с лицензиями и свободные лицензии
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

При открытии продукта Autodesk на рабочей станции программа определяет, к какому из серверов лицензий следует обратиться за лицензией. После этого продукт запрашивает на сервере лицензию по сетевому протоколу TCP/IP.

Если количество свободных лицензий не исчерпано, то Network License Manager выдает лицензию для рабочей станции. После этого на рабочей станции запускается сеанс продукта, а число свободных лицензий на сервере сокращается на единицу.

Аналогичным образом, по окончании работы одного пользователя с продуктом Network License Manager освобождает лицензию для другого пользователя. Параллельные сеансы продукта Autodesk на одной рабочей станции используют только одну лицензию. При закрытии последнего из таких параллельных сеансов лицензия высвобождается.

За управление распределением и наличием свободных лицензий отвечают следующие три процесса:

  • Демон Диспетчера лицензий (lmgrd.exe). Осуществляет первичное соединение с приложением, а затем устанавливает соединение с демоном поставщика. Демон lmgrd.exe используется исключительно для связи с демоном поставщика. Он не устанавливает подлинность лицензий и не распределяет их. Он просто передает запросы пользователей демону поставщика. Такой подход обеспечивает возможность использования одного демона диспетчера лицензий lmgrd.exe для выдачи лицензий по различным программным продуктам. Демон lmgrd.exe запускает и перезапускает по мере необходимости демон поставщика.
  • Демон поставщика Autodesk (adskflex.exe). Постоянно следит за выданными лицензиями и за использующими их рабочими станциями. Для каждого поставщика программного обеспечения имеется свой демон поставщика, отвечающий за управление лицензиями программ именно этого поставщика. Как следует из наименования, adskflex.exe - это демон поставщика, отвечающий за лицензирование только программных продуктов фирмы Autodesk.
ПримечаниеЕсли демон поставщика adskflex.exe по каким-либо причинам прекращает работу, все пользователи утрачивают свои лицензии, пока демон диспетчера лицензий lmgrd.exe вновь не запустит демона поставщика или не будут устранены неполадки, вызвавшие прекращение работы демона поставщика.
  • Файл лицензий. Текстовый файл, в котором содержится информация о лицензиях, специфичная для каждого поставщика программного обеспечения.


Файлы лицензий

Действия с лицензиями и свободные лицензии
Сведения о лицензиях
Примеры файлов лицензий
Выбор модели лицензирования > Сведения о лицензиях >
Файлы лицензий
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Полученный вами от компании Autodesk файл сетевых лицензий содержит лицензионную информацию, необходимую для установки в сети. Эти данные покупатель получает при регистрации продукта Autodesk.

Файл лицензий содержит информацию об узлах сетевых серверов и о демонах поставщика. Он также содержит шифрованную цифровую подпись, созданную при генерации файла в компании Autodesk.

Файл лицензий располагается в сетевой папке, указанной пользователем в мастере развертывания. Доступ к папке должен быть открыт для каждого пользователя, запускающего программу, установленную в сети.

В следующей таблице приведено описание параметров в файле лицензий.

Параметры в файле лицензий

Отрезок

Параметр

Определение

Пример

SERVER

Имя хоста

Имя хоста сервера, где установлен Network License Manager

LABSERVER

Идентификатор хоста

Ethernet-адрес сервера, где установлен Диспетчер сетевых лицензий

03D054C0149B

USE_SERVER

[Нет]

VENDOR

Демон поставщика

Имя серверного демона поставщика фирмы Autodesk.

adskflex.exe

Номер порта

Сетевой порт, зарезервированный и предназначенный только для работы с программными продуктами Autodesk, запускающими демон поставщика фирмы Autodesk

port=2080

PACKAGE

Имя

Имя группы кодов продукта

SERIES_1

Версия

Внутренний номер версии

1,000

COMPONENTS

Список кодов продукта, содержащихся в пакете

COMPONENTS= "526000REVIT_9_OF\ 51200ACD_2007_OF\ 513001INVBUN_11_OF"

НАСТРОЙКА

OPTIONS=SUITE

SUPERSEDE

Замена всех существующих строк INCREMENT с тем же кодом продукта во всех файлах лицензий на том же сервере лицензий, если в них указана более ранняя дата генерации

SUPERSEDE

SIGN

Зашифрованная цифровая подпись, используемая для подтверждения подлинности файла лицензий.

SIGN=0 SIGN2=0

INCREMENT

Код продукта

Программа, для которой используется файл лицензий

51200ACD_2007_0F

Срок действия

Срок действия лицензий

постоянный

Число лицензий

Число лицензий, предусмотренных в файле лицензий

25

VENDOR_STRING

Тип использования и поведение лицензии продукта, поддерживаемые файлом лицензии

COMMERCIAL

BORROW

Определение периода заимствования для тех лицензий, которые описаны в одной и той же строке INCREMENT.

Для данного примера максимальный срок заимствования лицензий составляет 4320 часов (180 дней), если не указан иной срок (например, BORROW=2880 означает, что лицензии могут быть заимствованы не более чем на 2880 часов, т.е. 120 дней).

Если данный параметр отсутствует в файле лицензий, возможность заимствования лицензий отключается.

BORROW=4320

DUP_GROUP

Определение множественных запросов лицензий при использовании лицензии одним и тем же пользователем на одном и том же компьютере

DUP_GROUP=UH

ISSUED

Дата создания файла лицензии в Autodesk

15-jul-2006

Серийный номер

Серийный номер программного продукта Autodesk.

123-12345678

SIGN

Зашифрованная цифровая подпись, используемая для подтверждения подлинности файла лицензий.

SIGN=6E88EFA8D44C


Примеры файлов лицензий

Файлы лицензий
Сведения о лицензиях
Пример файла лицензий, не привязанного к определенному продукту
Выбор модели лицензирования > Сведения о лицензиях >
Примеры файлов лицензий
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Примеры файлов лицензий приводятся в данном документе для пояснения работы файлов лицензий в определенной сетевой среде. Компания Autodesk предоставляет стандартный файл лицензий для отдельных продуктов и файл лицензий с дополнительными параметрами для продуктов, которые продаются как в составе пакета продуктов, так и отдельно.

  • Стандартный файл лицензий. Если пользователь приобретает один или несколько продуктов, которые не входят в комплект поставки пакета продуктов, он получит стандартный файл лицензий.
  • Стандартный файл лицензий с дополнительными параметрами.Если пользователь приобретает продукты Autodesk, которые поставляются в составе пакета продуктов, а также продаются отдельно, он получит стандартный файл лицензий с дополнительными параметрами. Дополнительные параметры определяют последовательность использования лицензии, при этом лицензия на отдельный продукт используется ранее лицензии на пакет продуктов.

В составе примеров файлов лицензий Autodesk имеются файл лицензий, не связанный с конкретным продуктом, полные файлы лицензий для конфигурации с одним сервером, с несколькими серверами и с резервным сервером, комбинированный файл лицензий на различные версии продуктов, а также пример добавления дополнительных параметров к стандартному файлу лицензий.

Темы в этом разделе

  • Пример файла лицензий, не привязанного к определенному продукту
  • Пример файла лицензий для конфигурации с одним или несколькими серверами лицензий
  • Пример файла лицензий для конфигурации с резервными серверами лицензий
  • Пример комбинированного файла лицензий для различных версий продуктов Autodesk
  • Пример дополнительных параметров файла лицензий


Пример файла лицензий, не привязанного к определенному продукту

Примеры файлов лицензий
Примеры файлов лицензий
Пример файла лицензий для конфигурации с одним или несколькими серверами лицензий
Выбор модели лицензирования > Сведения о лицензиях > Примеры файлов лицензий >
Пример файла лицензий, не привязанного к определенному продукту
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Далее приводится пример содержания файла лицензий с параметрами, связанными с каждой из строк:

SERVER Имя_сервера ID_хоста
USE_SERVER
VENDOR adskflex port=portnumber
INCREMENT feature_code Adskflex Version ExpDate NumberofLicenses \
VENDOR_STRING=UsageType:Behavior BORROW=4320 SUPERSEDE \ DUP_GROUP=DupGrp ISSUED=IssueDate SN=SerialNumber SIGN= \


Пример файла лицензий для конфигурации с одним или несколькими серверами лицензий

Пример файла лицензий, не привязанного к определенному продукту
Примеры файлов лицензий
Пример файла лицензий для конфигурации с резервными серверами лицензий
Выбор модели лицензирования > Сведения о лицензиях > Примеры файлов лицензий >
Пример файла лицензий для конфигурации с одним или несколькими серверами лицензий
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Полный файл лицензий для конфигурации с одним сервером или конфигурации с несколькими серверами лицензий может выглядеть, например, следующим образом:

SERVER XXHP0528 0019bbd68993
USE_SERVER
VENDOR adskflex port=2080
INCREMENT 57600ACD_2009_0F adskflex 1.000 permanent 5 \
   VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
   DUP_GROUP=UH ISSUED=09-Jan-2008 SN=123-12345678 SIGN="1393 \
   E368 816E D417 C1CD 7DBD 7B90 1354 D6F0 48FE EBB8 9C84 C3AF \
   7D79 BEE1 0181 0655 76FF 996C B707 14B5 D4DE A3FE 0B2D 2D36 \
   057C A579 7866 26BF 44E2" SIGN2="1280 943B 53A7 9B93 E00B D967 \
   D821 BD37 BE6D B78A F074 B223 88AA 242C DD0A 1292 D56F 4108 \
   62CD FA35 E365 0736 A011 7833 8B35 7BFF DAD8 34A8 452F 2EB4"


Пример файла лицензий для конфигурации с резервными серверами лицензий

Пример файла лицензий для конфигурации с одним или несколькими серверами лицензий
Примеры файлов лицензий
Пример комбинированного файла лицензий для различных версий продуктов Autodesk
Выбор модели лицензирования > Сведения о лицензиях > Примеры файлов лицензий >
Пример файла лицензий для конфигурации с резервными серверами лицензий
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Полный файл лицензий для конфигурации с резервными серверами лицензий может выглядеть, например, следующим образом:

SERVER CCN12378042 001cc4874b03 27005
SERVER XXHP0528 0019bbd68993 27005
SERVER CCN12378043 001cc4874b10 27005
USE_SERVER
VENDOR adskflex port=2080
INCREMENT 57600ACD_2009_0F adskflex 1.000 permanent 5 \
   VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
   DUP_GROUP=UH ISSUED=10-Jan-2008 SN=123-12345678 SIGN="11C4 \
   CA79 07FC 7AD0 409A 6E04 6E98 D76C 197C 0416 076C B211 1CDD \
   D0AB 698B 16BF 7A0E D4F8 1CFE 2985 644F 64CD CECE 0DDB 5951 \
   3262 7C31 13A8 F08F 55B2" SIGN2="19A6 FDA3 2ED5 5301 8675 7B81 \
   1B0E 451B 19F1 1A99 C8E9 CBA6 8CB3 6AC3 8B38 1519 13F2 2373 \
   82AE 55E5 1A25 4952 4458 F3A2 6F28 D25D 1DC0 E066 209B 0953"
ПримечаниеВ конфигурации с резервными серверами необходимо задавать номер порта (по умолчанию 27005) для каждого сервера.


Пример комбинированного файла лицензий для различных версий продуктов Autodesk

Пример файла лицензий для конфигурации с резервными серверами лицензий
Примеры файлов лицензий
Пример дополнительных параметров файла лицензий
Выбор модели лицензирования > Сведения о лицензиях > Примеры файлов лицензий >
Пример комбинированного файла лицензий для различных версий продуктов Autodesk
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Один файл лицензий может использоваться для различных версий одного и того же продукта Autodesk и запускать все эти продукты с одним сервером лицензий. Например, можно скомбинировать файл лицензий для AutoCAD 2009 с файлами лицензий для Maya® 2009 и для AutoCAD Map.

Комбинированный файл лицензий для AutoCAD 2008 и AutoCAD 2009 может иметь, например, следующий вид:

SERVER XXHP0528 0019bbd68993
USE_SERVER
VENDOR adskflex port=2080
INCREMENT 57600ACD_2009_0F adskflex 1.000 permanent 5 \
   VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
   DUP_GROUP=UH ISSUED=09-Jan-2008 SN=123-12345678 SIGN="1393 \
   E368 816E D417 C1CD 7DBD 7B90 1354 D6F0 48FE EBB8 9C84 C3AF \
   7D79 BEE1 0181 0655 76FF 996C B707 14B5 D4DE A3FE 0B2D 2D36 \
   057C A579 7866 26BF 44E2" SIGN2="1280 943B 53A7 9B93 E00B D967 \
   D821 BD37 BE6D B78A F074 B223 88AA 242C DD0A 1292 D56F 4108 \
   62CD FA35 E365 0736 A011 7833 8B35 7BFF DAD8 34A8 452F 2EB4"
INCREMENT 54600ACD_2008_0F adskflex 1.000 permanent 3 \
   VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
   DUP_GROUP=UH ISSUED=09-Jan-2008 SN=123-12345678 SIGN="1E6E \
   4B61 5712 4766 92A0 6782 9EF4 3F47 56A1 1F38 6DE8 C0C7 90AC \
   7289 152E 0EA2 CC0D 3F10 577A 0489 CEB6 10D5 FBCC B552 0C9D \
   5966 91A6 59F0 2788 FACE" SIGN2="1DDF 3B9D 3392 71D5 AB08 7E05 \
   8497 111E 092F 0E54 8DC2 2BED 17C2 2CC1 981B 0EC2 BC15 8F00 \
   C79A ABFD 2136 BABA 2EDF E941 EA53 32C6 597F F805 5A8A 599A"


Пример дополнительных параметров файла лицензий

Пример комбинированного файла лицензий для различных версий продуктов Autodesk
Примеры файлов лицензий
Примеры пакетных файлов лицензий
Выбор модели лицензирования > Сведения о лицензиях > Примеры файлов лицензий >
Пример дополнительных параметров файла лицензий
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Для продуктов Autodesk, которые поставляются в составе пакета продуктов, а также продаются отдельно, лицензии назначаются на основе порядка приоритетов, установленного в файле лицензий. Для таких продуктов в файле лицензий имеется информация, сходная с данными из приведенного ниже примера:

SERVER Server1 1a34567c90d2
USE_SERVER
VENDOR adskflex port=2080
INCREMENT 54600ACD_2008_0F adskflex 1.000 permanent 5 \
   VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
   DUP_GROUP=UH ISSUED=09-Jan-2007 SN=123-12345678 SIGN="0247 \
   45D6 87C4 27A5 7F9E F24A ED3D 61E4 6B3B CC5C AD77 B865 9EA8 \
   3D62 0792 0F67 19E7 57E7 FAFA A48B D582 335A EC16 1FE5 B70D \
   76AB 6488 61CC DE5E F5B7" SIGN2="09FD 0850 7CF1 F447 9F05 9FA3 \
   2A0A 38D6 83FC 1746 F3F5 5A72 6250 E002 DE0B 0E6E F88C AC95 \
   136F 87F2 A945 E4C4 A97F 44B5 74EE 83F3 3F3E 1579 B981 8994"


Примеры пакетных файлов лицензий

Пример дополнительных параметров файла лицензий
Сведения о лицензиях
Пример пакетного файла лицензий для конфигурации с одним или несколькими серверами лицензий
Выбор модели лицензирования > Сведения о лицензиях >
Примеры пакетных файлов лицензий
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Autodesk предлагает вариант пакетного файла лицензии, который позволяет использовать несколько программных продуктов, собранных вместе и приобретенных в виде пакета. Пакетный файл лицензии содержит установленное количество лицензий для четырех разных версий программного обеспечения. При запуске любой из версий используется одна лицензия из пакета. Пакетные файлы лицензий поддерживают более ранние версии программ, полученные пользователями по подписке. Принципы функционирования пакетных файлов лицензий:

  • Пакетный файл лицензии предназначается для текущей версии программы и трех предыдущих версий этой же программы.
  • Файлы лицензий можно комбинировать с файлами лицензий других программных продуктов. Подробные сведения о комбинировании файлов лицензий содержатся в разделе Пример комбинированного файла лицензий для различных версий продуктов Autodesk.
  • Пакетные файлы лицензий не могут быть скомбинированы с отдельными файлами лицензий на версии программных продуктов, которые входят в данный пакет. Например, невозможно скомбинировать пакетный файл лицензии на продукт Autodesk 2009 с обычным файлом лицензии на продукт Autodesk 2008, 2007 или 2006.
  • Чтобы программа функционировала должным образом, для ее лицензирования требуются оба раздела лицензии: и PACKAGE, и INCREMENT. Совмещая файлы лицензий, следует убедиться в наличии этих разделов.
  • Для пакетных лицензий функция заимствования лицензий, файлы параметров и каскадное лицензирование работают так же, как и для обычных файлов лицензий.
  • Новый файл лицензии заменяет собой прежний файл.

В последующих разделах приведены примеры пакетных файлов лицензий для конфигураций с одним сервером, с несколькими серверами, с резервным сервером, а также пример комбинированного файла для различных версий продуктов Autodesk.

Темы в этом разделе

  • Пример пакетного файла лицензий для конфигурации с одним или несколькими серверами лицензий
  • Пример пакетного файла лицензий для конфигурации с резервными серверами лицензий
  • Пример комбинированного файла лицензий для различных версий программных продуктов Autodesk


Пример пакетного файла лицензий для конфигурации с одним или несколькими серверами лицензий

Примеры пакетных файлов лицензий
Примеры пакетных файлов лицензий
Пример пакетного файла лицензий для конфигурации с резервными серверами лицензий
Выбор модели лицензирования > Сведения о лицензиях > Примеры пакетных файлов лицензий >
Пример пакетного файла лицензий для конфигурации с одним или несколькими серверами лицензий
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Полный файл лицензий для конфигурации с одним сервером или конфигурации с несколькими серверами лицензий может выглядеть, например, следующим образом:

SERVER Server1 1a34567c90d2
USE_SERVER
VENDOR adskflex port=2080
PACKAGE SERIES_1 adskflex 1.000 COMPONENTS="54700REVIT_2009_0F \
   54600ACD_2009_0F 51300INVBUN_11_0F" OPTIONS=SUITE SUPERSEDE \
   ISSUED=09-Jan-2008 SIGN="1707 9EAC CBCB 2405 692E 4A89 \
   AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 4E75 193A DA82" \
   FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A BE5F 3827 \
   SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 98E2 \
   5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \
   CD68 1D77 27F8 8555 9CF7 DEDD 9380"
INCREMENT SERIES_1 adskflex 1.000 permanent 100 \
   VENDOR_STRING=commercial:permanent BORROW=4320 DUP_GROUP=UH \
   SUITE_DUP_GROUP=UHV SN=123-12345678 SIGN="1707 9EAC CBCB \
   692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 BE5F \
   3827 AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 DA82" \
   SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \
   5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \
   CD68 1D77 27F8 8555 9CF7 DEDD 9380"


Пример пакетного файла лицензий для конфигурации с резервными серверами лицензий

Пример пакетного файла лицензий для конфигурации с одним или несколькими серверами лицензий
Примеры пакетных файлов лицензий
Пример комбинированного файла лицензий для различных версий программных продуктов Autodesk
Выбор модели лицензирования > Сведения о лицензиях > Примеры пакетных файлов лицензий >
Пример пакетного файла лицензий для конфигурации с резервными серверами лицензий
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Полный файл лицензий для конфигурации с резервными серверами лицензий может выглядеть, например, следующим образом:

SERVER 1a34567c90d2 27005
SERVER 2a34567c90d2 27005
SERVER 3a34567c90d2 27005
USE_SERVER
VENDOR adskflex port=2080
PACKAGE 64300ACD_F adskflex 1.000 COMPONENTS="57600ACD_2009_0F \
   54600ACD_2008_0F 51200ACD_2007_0F 48800ACD_2006_0F" \
   OPTIONS=SUITE SUPERSEDE ISSUED=27-May-2008 SIGN="1092 05D8 \
   A206 276B 2C84 EFAD ACA5 C54B 68A4 653E C61F 31DE C8CE B532 \
   CFBB 0006 5388 347B FDD6 A3F4 B361 7FD4 CDE4 4AAC 0D11 B0EF \
   4B44 BFD6 3426 97DD" SIGN2="0670 B01A D060 0069 FF25 F1CD D06B \
   314E E7C9 3552 5FFA 4AC7 28A7 C897 F56A 19BB FB1C 754E 6704 \
   DEEA AC4E F859 2E9B 64B6 0DD0 9CCE 9556 269F EAC0 2326"
INCREMENT 64300ACD_F adskflex 1.000 permanent 50 \
   VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
   DUP_GROUP=UH SUITE_DUP_GROUP=UHV ISSUED=27-May-2008 \
   SN=399-99999999 SIGN="1B5B 8D70 4CAD 32E5 9CA2 82E0 5C47 291C \
   35AB 9B9C 5B3E 5067 F61B 4139 1B32 0716 1FD3 5105 A991 B78E \
   9D1E 63AB BC23 0D1E B70C 2A05 E1C1 F605 ABB1 2EA8" SIGN2="01D6 \
   31F5 2951 4500 E5C8 058F 7490 9789 9EF4 CBED DA27 5F06 6780 \
   9033 2018 0C3B E1E0 3580 E60E C2BB B4AB 8D6A 4245 3059 8CA6 \
   2EFE DFAE 027F 2ABE 3F2B"


Пример комбинированного файла лицензий для различных версий программных продуктов Autodesk

Пример пакетного файла лицензий для конфигурации с резервными серверами лицензий
Примеры пакетных файлов лицензий
Типы и виды лицензий
Выбор модели лицензирования > Сведения о лицензиях > Примеры пакетных файлов лицензий >
Пример комбинированного файла лицензий для различных версий программных продуктов Autodesk
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Ниже приведен пример полного файла лицензий, скомбинированного для нескольких версий программного продукта Autodesk:

SERVER servername 123456789111
USE_SERVER
VENDOR adskflex port=2080
PACKAGE 64300ACD_F adskflex 1.000 COMPONENTS="57600ACD_2009_0F \
   54600ACD_2008_0F 51200ACD_2007_0F 48800ACD_2006_0F" \
   OPTIONS=SUITE SUPERSEDE ISSUED=25-Jun-2008 SIGN="03EF DE18 \
   8046 0124 4EA4 6953 F82D 3169 7C24 D0DE E58E 8168 FFA3 D891 \
   B43B 08D8 7E7F C6ED CBCC FE2A BB0A 4566 C2AE F1C1 D373 8348 \
   E6E3 884A E398 1C78" SIGN2="07AC D696 8844 D19F AB00 8B75 53A3 \
   2F76 91DF AED0 3231 1506 0E6B ADC6 C3B8 1797 93B5 9756 8C0F \
   8811 56E6 B2BA 0523 FE2E 82B7 1628 076F 173B F37C 7240"
INCREMENT 64300ACD_F adskflex 1.000 permanent 2 \
   VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
   DUP_GROUP=UH SUITE_DUP_GROUP=UHV ISSUED=25-Jun-2008 \
   SN=399-99999999 SIGN="1CCB E88D B819 8604 06FA 9AEE 42F1 CBEA \
   37B9 3CFA A0A8 697F 9CB1 8354 6256 05ED 69D4 D2FF D512 6A2E \
   D5DD B722 EF5B 3172 BA95 4625 F8D3 DD24 BB39 6A58" SIGN2="0DFF \
   FA6F C378 20E0 2622 BE52 B434 F99F 2681 2B93 64F2 CE0C 7F4A \
   7024 B3D1 051A 6920 72BD DE35 8920 E6A1 C8D6 AF23 7BE7 CC91 \
   6916 70B1 9E80 AB07 1644"
PACKAGE 64800INVPRO_F adskflex 1.000 \
COMPONENTS="59600INVPRO_2009_0F \
   55300INVPRO_2008_0F 51400INVPRO_11_0F 49000INVPRO_10_0F" \
   OPTIONS=SUITE SUPERSEDE ISSUED=25-Jun-2008 SIGN="1306 5990 \
   F8A1 56FB 1D8A 9DA7 D6AE 8E9E F6EC 2862 367A 36E2 C5FB E6E1 \
   4AAA 0128 8C2D 95FD 09B2 ABA1 6F98 A0A3 70DE 3220 6835 7E51 \
   3849 9D81 8BDC 9DC1" SIGN2="0021 AA08 F2E7 8AEB 5345 341A 7E42 \
   3001 B8C5 DFC2 6EB8 87C5 C04A AE43 A10F 1DA1 EF8A F0FA 10F5 \
   AC81 1E22 789F A18D 650F 6BBB 563A BDA5 DD1C 82EC 27F6"
INCREMENT 64800INVPRO_F adskflex 1.000 permanent 2 \
   VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
   DUP_GROUP=UH SUITE_DUP_GROUP=UHV ISSUED=25-Jun-2008 \
   SN=399-99999966 SIGN="0BE4 51F4 570C DC48 5E66 F952 629E EDF0 \
   019C 6FF7 0509 1FF0 D4FB 3B16 1981 073F 31EC A241 8CB3 8782 \
   E655 00C6 E097 D5EF B0D8 67D3 199D 699D 2E09 B16F" SIGN2="1254 \
   3E37 0CE4 F42D B7CD 858C 92FC A963 5274 770F 9354 FE29 E117 \
   205D C632 0C4E AEC0 7501 9D9E FFEB D84D F154 16A1 E120 339A \
   FDBF 3F07 4477 B8B3 5DA4"


Типы и виды лицензий

Пример комбинированного файла лицензий для различных версий программных продуктов Autodesk
Сведения о лицензиях
Тактовый сигнал
Выбор модели лицензирования > Сведения о лицензиях >
Типы и виды лицензий
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Autodesk поддерживает динамическое изменение типа и вида лицензий. Это означает, что, купив лицензию определенного типа и вида, в дальнейшем пользователь может изменить тип и вид лицензий без переустановки продукта Autodesk.

По условиям использования лицензии делятся на следующие типы:

  • Коммерческая. Лицензия на продукт, приобретенный коммерческим путем.
  • Не для перепродажи. Лицензия на продукт, полученный некоммерческими способами. Программные продукты с маркировкой "не для перепродажи" распространяются исключительно для оценки и демонстрации их возможностей. Они не могут быть использованы в коммерческих или производственных целях.
  • Для учебных заведений. Лицензии этого типа предназначены для учебных заведений.
  • Для студентов. Лицензии для студентов, использующих продукты Autodesk в рамках учебного плана.

По своему поведению лицензии бывают следующих видов:

  • Постоянная. Предполагает использование продукта Autodesk в течение неограниченного срока.
  • Временная с возможностью продления. Обеспечивает доступ к программе Autodesk в течение ограниченного периода времени. Продлить действие таких лицензий можно в любой момент.
  • Ограниченная. Обеспечивает доступ к программе Autodesk в течение ограниченного периода времени. Продлить действие таких лицензий нельзя.


Тактовый сигнал

Типы и виды лицензий
Сведения о лицензиях
Инструменты сетевого лицензирования
Выбор модели лицензирования > Сведения о лицензиях >
Тактовый сигнал
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Во время работы продукт Autodesk регулярно связывается с сервером лицензий через определенные интервалы времени, используя метод связи, который называют “тактовым сигналом“. При отсутствии на каком-либо такте соединения сервер повторно пытается установить связь. Если это не удается, пользователь получает сообщение об ошибке лицензирования.

Если продукт прекратил работу из-за отсутствия соединения с сервером, требуется закрыть его, а затем запустить заново. Если проблемы, вызвавшие сбой в регулярном соединении, устранены и имеются свободные лицензии, программа заново начнет работу.


Инструменты сетевого лицензирования

Тактовый сигнал
Обновление предыдущей версии FLEXnet
Инструменты сетевого лицензирования
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Данная глава содержит сведения об обновлении FLEXnet, об установке и настройке Диспетчера сетевых лицензий Autodesk в сети, а также об установке и использовании программы активации сетевой лицензии.

Темы в этом разделе

  • Обновление предыдущей версии FLEXnet
  • Установка программы Network License Manager ("Диспетчер сетевых лицензий")от Autodesk
  • Установка программы активации сетевой лицензии
  • Использование программы "Network License Activation" (Активации сетевой лицензии)
  • Получение имени и идентификатора хоста вручную
  • Настройка сервера лицензий (Windows)
  • Остановка работы и перезапуск сервера лицензий
  • Настройка и использование файла параметров
  • Удаление Network License Manager


Обновление предыдущей версии FLEXnet

Инструменты сетевого лицензирования
Инструменты сетевого лицензирования
Установка программы Network License Manager ("Диспетчер сетевых лицензий")от Autodesk
Инструменты сетевого лицензирования >
Обновление предыдущей версии FLEXnet
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Для данной и для последующих версий программных продуктов Autodesk требуется FLEXnet 11.5 или более поздняя версия. Если на компьютере установлена более ранняя версия FLEXnet , чем 11.5, необходимо обновить ее до версии 11.5 или более поздней.

ПримечаниеЕсли на сервере, на который планируется установить Диспетчер сетевых лицензий Autodesk, уже имеются средства настройки FLEXnet для другого программного продукта, необходимо убедиться в том, что используется самая последняя версия lmgrd.exe.

Для определения версии FLEXnet, установленной на компьютере, необходимо проверить версии следующих файлов:

Windows

  • lmgrd.exe
  • lmtools.exe
  • lmutil.exe
  • adskflex.exe

Чтобы проверить версию файлов lmutil.exe, lmtools.exe или adskflex.exe (Windows)

Для работы с утилитой LMTOOLS необходимо войти в систему с правами администратора.

  1. Выполните одно из следующих действий:
    • (Windows XP) Выберите меню "Пуск" [image] "Программы" [image] Autodesk [image] Network License Manager [image] LMTOOLS.
    • (Windows Vista) Дважды щелкните на значке LMTOOLS на рабочем столе.
  2. В lmtools.exe перейти на вкладку "Utility" (Программы).
  3. На вкладке "Utility" (Программы) введите путь к файлу или нажать кнопку "Browse" (Обзор), найти файл и нажать "Open" (Открыть). Путь к файлу должен выглядеть подобно следующему:

    C:\Program Files\Autodesk Network License Manager\lmutil.exe

  4. На вкладке "Utility" (Программы) выбрать "Find Version" (Найти версию).

    На экране отобразится версия выбранного файла. При необходимости обновления версии FLEXnet следует руководствоваться следующей процедурой.

Чтобы обновить FLEXnet (Windows)

Для работы с утилитой LMTOOLS необходимо войти в систему с правами администратора.

  1. Создать резервные копии файлов лицензий.
  2. Выполните одно из следующих действий:
    • (Windows XP) Выберите меню "Пуск" [image] "Программы" [image] Autodesk [image] Network License Manager [image] LMTOOLS.
    • (Windows Vista) Дважды щелкните на значке LMTOOLS на рабочем столе.
  3. На вкладке "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз) нажать кнопку "Stop Server" (Остановить сервер).
  4. На вкладке "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз) нажать кнопку "Stop Server" (Остановить сервер).
  5. Закрыть lmtools.exe.
  6. Обратите внимание, в какой папке установлен Network License Manager, и удалите его. Более подробную информацию об удалении Network License Manager см. в Удаление Network License Manager.
  7. Установить Network License Manager. Подробные сведения об установке Network License Manager в ту же папку, где была установлена предыдущая версия, см. раздел Установка программы Network License Manager ("Диспетчер сетевых лицензий")от Autodesk.
  8. Выполните одно из следующих действий:
    • (Windows XP) Выберите меню "Пуск" [image] "Программы" [image] Autodesk [image] Network License Manager [image] LMTOOLS.
    • (Windows Vista) Дважды щелкните на значке LMTOOLS на рабочем столе.
  9. На вкладке "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз) нажать кнопку "Stop Server" (Остановить сервер).
  10. На вкладке "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз) нажмите кнопку "Start Server" (Запустить сервер).
  11. Закрыть lmtools.exe.


Установка программы Network License Manager ("Диспетчер сетевых лицензий")от Autodesk

Обновление предыдущей версии FLEXnet
Инструменты сетевого лицензирования
Установка программы активации сетевой лицензии
Инструменты сетевого лицензирования >
Установка программы Network License Manager ("Диспетчер сетевых лицензий")от Autodesk
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Network License Manager можно установить как до, так и после сетевой установки программы. Сетевые приложения могут быть установлены в любой последовательности, при этом для всех приложений должен быть обеспечен доступ к серверу лицензий.

Если на компьютере имеется более ранняя версия Network License Manager, следует обновить ее, установив Autodesk Network License Manager в ту же папку, где хранится старая версия.

Для установки программы Network License Manager от Autodesk

  1. В Мастере установки Autodesk выберите "Install Tools and Utilities" (Установка инструментов и утилит).
  2. На странице "Select the Products to Install" (Выберите устанавливаемые программы) выберите Network License Manager и нажмите "Next" (Далее).
  3. Просмотрите лицензионное соглашение по программным продуктам Autodesk для своей страны или территории. Для продолжения установки надо принять данное соглашение. Выберите свою страну или область, нажмите кнопку "Я согласен" и нажмите кнопку "Далее".
    ПримечаниеВ случае несогласия с условиями договора и необходимости прервать установку нажмите "Cancel" (Отмена).
  4. На странице "Обзор - Настройка - Установка" нажмите "Настройка".
  5. Если на предыдущем шаге было выбрано несколько программных продуктов, перейдите на вкладку "Network License Manager".
  6. На странице "Select the Installation Location" (Выбор папки установки) примите заданную по умолчанию папку (C:\Program Files\Autodesk Network License Manager\) или нажмите кнопку [...], чтобы указать другую папку для установки. Если выбранная папка не существует, программа создаст новую папку с именем и местоположением, указанным пользователем. Нажмите кнопку "Настройка завершена".
    ПредупреждениеНе следует устанавливать программу Network License Manager на удаленном диске. При установке файлов Network License Manager необходимо задать путь, указывающий на локальный жесткий диск. Необходимо указать букву, которая обозначает диск; использовать универсальное соглашение об именах (UNC) не разрешается.
  7. После возвращения на страницу "Обзор - Настройка - Установка" нажмите "Установить", чтобы начать установку Network License Manager и других выбранных инструментов и утилит.
  8. Когда появится страница "Установка завершена", нажмите "Готово".


Установка программы активации сетевой лицензии

Установка программы Network License Manager ("Диспетчер сетевых лицензий")от Autodesk
Инструменты сетевого лицензирования
Использование программы "Network License Activation" (Активации сетевой лицензии)
Инструменты сетевого лицензирования >
Установка программы активации сетевой лицензии
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Программа активации сетевой лицензии предназначена для получения файлов лицензий через Интернет.

Для установки программы активации сетевой лицензии

  1. В Мастере установки Autodesk выберите "Install Tools and Utilities" (Установка инструментов и утилит).
  2. На странице "Select the Products to Install" (Выберите устанавливаемые программы) выберите Network License Activation Utility и нажмите "Next" (Далее).
  3. Просмотрите лицензионное соглашение по программным продуктам Autodesk для своей страны или территории. Для продолжения установки надо принять данное соглашение. Выберите свою страну или область, нажмите кнопку "Я согласен" и нажмите кнопку "Далее".
    ПримечаниеВ случае несогласия с условиями договора и необходимости прервать установку нажмите "Cancel" (Отмена).
  4. На странице "Обзор - Настройка - Установка" нажмите "Настройка".
  5. Если в предыдущем шаге было выбрано несколько программных продуктов, перейдите на вкладку "Network License Activation Utility" (Активация сетевой лицензии).
  6. На странице "Выбор папки установки" примите путь установки по умолчанию ( C:\Program Files\Autodesk Network License Manager\Network License Activation Utility) или нажмите [...] и укажите другой путь. Если выбранная папка не существует, программа создаст новую папку с именем и местоположением, указанным пользователем. Нажмите кнопку "Настройка завершена".
  7. После возвращения на страницу "Обзор - Настройка - Установка" нажмите "Установить", чтобы начать установку программы активации сетевой лицензии и других выбранных инструментов и утилит.
  8. Когда появится страница "Установка завершена", нажмите "Готово".


Использование программы "Network License Activation" (Активации сетевой лицензии)

Установка программы активации сетевой лицензии
Инструменты сетевого лицензирования
Получение имени и идентификатора хоста вручную
Инструменты сетевого лицензирования >
Использование программы "Network License Activation" (Активации сетевой лицензии)
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Программа активации сетевой лицензии позволяет получать лицензии через Интернет. Кроме того, эта утилита отвечает за регистрацию программного продукта, обеспечивает автоматическое формирование сообщений электронной почты в случае отсутствия возможности получить лицензию через Интернет, а также автоматически сохраняет и перемещает файлы лицензий.

Перед тем как использовать программу активации сетевой лицензии для получения файла лицензий, необходимо убедиться в наличии следующей информации:

  • Сведения о сервере лицензий, включая имя (имена) хоста и идентификаторы хоста
  • Серийный номер предыдущей версии продукта (для обновлений)
  • Доступ к папке для сохранения файлов лицензий

Для использования программы активации сетевой лицензии (интерактивный запрос)

  1. Выполните одно из следующих действий:
    • (Windows XP) Выберите меню "Пуск" [image] "Программы" [image] Autodesk [image] Network License Manager [image] [Программа Autodesk] Network License Activation Utility.
    • (Windows Vista) Выберите меню "Пуск" [image] "Все программы" [image] Autodesk [image] Network License Manager [image] [Программа Autodesk] Network License Activation Utility.
  2. На странице "Obtain a Network License" (Получение сетевой лицензии) убедитесь, что установлено прямое подключение к сети Интернет (активна кнопка "Direct Connect"), введите ключ программного продукта и нажмите кнопку "Next" (Далее).
  3. На странице "Server Information" (Информация о сервере) введите следующие данные:
    • Серийный номер программного продукта
      ПримечаниеВ случае изменения существующего файла лицензии или получения новой лицензии для существующего продукта может отобразиться ранее введенная информация. Убедитесь, что отображается именно тот серийный номер, который необходимо лицензировать. Если это не так, введите правильный серийный номер.
    • Модель сервера лицензий

      Более подробную информацию об имеющихся вариантах модели можно получить, нажав на кнопку с вопросительным знаком.

    • Имя хоста

      (Windows) Если имя хоста неизвестно, введите в командной строке указанный ниже запрос для поиска имени каждого сервера, который планируется использовать:

      <запрос> lmutil lmhostid -hostname
      ПримечаниеВ модели "Распределенный сервер", введено ограничение максимум 20 серверов. Как только будет выбрано 20 серверов, кнопка "Add" (Добавить) исчезнет.
    • Идентификатор узла, для которого было введено имя сервера

      (Windows) Если не удается найти идентификатор хоста, нажмите кнопку "Lookup" (Поиск), чтобы утилита автоматически определила местонахождение идентификатора хоста для сервера (серверов).

      ПримечаниеЕсли на сервере установлено несколько сетевых адаптеров, необходимо выбрать тот из них, который соответствует физическому устройству. Чтобы определить, какие адаптеры являются физическими, в командной строке Windows введите ipconfig/all и просмотрите содержание поля "Description" (Описание), расположенного выше каждого физического адреса. Если физических сетевых адаптеров несколько, можно использовать любой из них; для этого необходимо, чтобы его имя выводилось в список командой ipconfig /all. Логические устройства (VPN-адаптеры, PPP-адаптеры, модемы и др.) могут также попасть в указанный выше список, но для работы с лицензиями не годятся.
    • Количество рабочих мест для каждого сервера лицензий

      Если выбрана модель "Распределенный сервер", появляется поле "Seats" (Рабочие места). Введите количество рабочих мест для каждого сервера лицензий.

    Нажмите "Далее".

  4. На странице "Confirm Server Information" (Подтверждение сведений о сервере) проверьте введенную информацию и нажмите "Next" (Далее).
  5. На странице "Log In" (Вход в систему) введите идентификатор пользователя и пароль, и затем нажмите кнопку " Log In" (Вход в систему).

    Если учетная запись пользователя не создана, нажмите кнопку "Create a User ID Now" (Создание идентификатора нового пользователя) и далее руководствуйтесь экранными инструкциями для создания новой учетной записи.

  6. На странице "Choose Account" (Выбор учетной записи) выберите учетную записи и нажмите кнопку "Next" (Далее).
  7. На странице "License(s) Received" (Полученные лицензии) в поле "Save License File" (Сохранить файл лицензий) для [имя компьютера] укажите папку для сохранения файла лицензии или нажмите "Browse" (Обзор) для выбора места сохранения.
    ПримечаниеРекомендуется сохранить файл лицензий в папкеC:\Program Files\Autodesk Network License Manager\License.

    Содержимое этой страницы зависит от выбранной модели сервера.

    Нажмите "Далее".

  8. На странице "License Activation Successful" (Активация лицензии успешно выполнена) нажать кнопку "Print" (Печать), чтобы вывести информацию о лицензии на печать, либо нажать "Done" (Готово) для завершения групповой операции и выхода из программы активации сетевой лицензии.

(Windows) После получения и сохранения файла лицензии следует обратиться к разделу Настройка сервера лицензий (Windows), чтобы настроить Диспетчер лицензий.

Для использования программы активации сетевой лицензии (автономный запрос)

  1. Выполните одно из следующих действий:
    • (Windows XP) Выберите меню "Пуск" [image] "Программы" [image] Autodesk [image] Network License Manager [image] [Программа Autodesk] Network License Activation Utility.
    • (Windows Vista) Выберите меню "Пуск" [image] "Все программы" [image] Autodesk [image] Network License Manager [image] [Программа Autodesk] Network License Activation Utility.
  2. На странице "Obtain a Network License" (Получение сетевой лицензии) выберите "Email" (По электронной почте), "Fax" (По факсу), "Phone" (По телефону) или "Send request by postal mail" (Послать запрос по почте) и нажмите кнопку "Next" (Далее).
  3. На странице "Server Information" (Информация о сервере) введите следующие данные:
    • Серийный номер программного продукта
      ПримечаниеВ случае изменения существующего файла лицензии или получения новой лицензии для существующего продукта может отобразиться ранее введенная информация. Убедитесь, что отображается именно тот серийный номер, который необходимо лицензировать. Если это не так, введите правильный серийный номер.
    • Модель сервера лицензий

      Более подробную информацию об имеющихся вариантах модели можно получить, нажав на кнопку с вопросительным знаком.

    • Имя хоста

      (Windows) Если имя хоста неизвестно, введите в командной строке указанный ниже запрос для поиска имени каждого сервера, который планируется использовать:

      <запрос> lmutil lmhostid -hostname
      ПримечаниеВ модели "Распределенный сервер", введено ограничение максимум 20 серверов. Как только будет выбрано 20 серверов, кнопка "Add" (Добавить) исчезнет.
    • Идентификатор узла, для которого было введено имя сервера

      (Windows) Если не удается найти идентификатор хоста, нажмите кнопку "Lookup" (Поиск), чтобы утилита автоматически определила местонахождение идентификатора хоста для сервера (серверов).

      ПримечаниеЕсли на сервере установлено несколько сетевых адаптеров, необходимо выбрать тот из них, который соответствует физическому устройству. Чтобы определить, какие адаптеры являются физическими, в командной строке Windows введите ipconfig/all и просмотрите содержание поля "Description" (Описание), расположенного выше каждого физического адреса. Если физических сетевых адаптеров несколько, можно использовать любой из них; для этого необходимо, чтобы его имя выводилось в список командой ipconfig /all. Логические устройства (VPN-адаптеры, PPP-адаптеры, модемы и др.) могут также попасть в указанный выше список, но для работы с лицензиями не годятся.
    • Количество рабочих мест для каждого сервера лицензий

      Если выбрана модель "Распределенный сервер", появляется поле "Seats" (Рабочие места). Введите количество рабочих мест для каждого сервера лицензий.

    Нажмите "Далее".

  4. На странице "Confirm Server Information" (Подтверждение сведений о сервере) проверьте введенную информацию и нажмите "Next" (Далее).
  5. На странице "Product Registration" (Регистрация продукта) укажите следующую информацию.
    • Предоставляется ли регистрируемая программа организации или физическому лицу.
    • Страна или регион, где будет использоваться программа.
    • Является ли программа обновленной версией ранее установленной программы. В этом случае потребуется также серийный номер предыдущей версии программы.

    Нажмите "Далее".

  6. На странице "Customer Information" (Данные о пользователе) введите личные данные и укажите предпочтительный способ получения кода активации - "Email" (По электронной почте), "Fax" (По факсу) или "Postal mail" (По почте). Нажмите "Далее".
  7. На странице "Confirm Information" (Подтверждение данных) проверьте личные данные и укажите способ передачи запроса. Запрос можно отправить по электронной почте, по факсу или по телефону.

    При выборе варианта "Send my request by Email" (Отправить запрос по электронной почте) на экран выводится страница электронного сообщения для заполнения. При выборе варианта отправки запроса по факсу или по телефону на экране отобразится страница "Contact Autodesk" (Связаться с Autodesk), содержащая соответствующие контактные данные.

    Код активации будет передан способом, указанным на странице "Customer Information" (Данные о пользователе).

  8. Если требуется вывести на печать страницу с регистрационной информацией, выберите "Select Open Activation Request Form" (Выбор открытой формы запроса на активацию). По завершении нажмите кнопку "Закрыть".

(Windows) После получения и сохранения файла лицензии следует обратиться к разделу Настройка сервера лицензий (Windows), чтобы настроить Диспетчер лицензий.

ПримечаниеРекомендуется сохранять файл лицензий там же, где установлен "Network License Manager" (Диспетчер сетевых лицензий).


Получение имени и идентификатора хоста вручную

Использование программы "Network License Activation" (Активации сетевой лицензии)
Инструменты сетевого лицензирования
Настройка сервера лицензий (Windows)
Инструменты сетевого лицензирования >
Получение имени и идентификатора хоста вручную
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

При отсутствии возможности использовать программу активации сетевой лицензии для получения имени и кода хоста сервера можно получить данную информацию вручную. Для генерации файла лицензий компании Autodesk требуется имя хоста, идентификатор хоста и серийный номер продукта.

Для получения информации вручную можно использовать командную строку Windows или запустить утилиту lmtools.exe . Утилиту lmtools.exe нельзя запускать на удаленной рабочей станции.

Для получения имени и идентификатора хоста с использованием командной строки Windows

  1. Выполните одно из следующих действий:
    • (Windows XP) Выберите "Пуск" [image] "Программы" [image] "Стандартные" [image] "Командная строка".
    • (Windows Vista) Выберите "Пуск" [image] "Все программы" [image] "Стандартные" [image] "Командная строка".
  2. В командной строке Windows введите следующую команду и нажать ENTER:

    ipconfig /all

  3. Найти строку "Имя хоста" и введите имя хоста.
  4. Найти строку "Физический адрес". Записать физический адрес, игнорируя дефисы в нем. Это и будет двенадцатисимвольный идентификатор хоста.
    ПримечаниеЕсли на сервере установлено несколько сетевых адаптеров, необходимо выбрать тот из них, который соответствует физическому устройству. Чтобы определить, какие адаптеры являются физическими, в командной строке Windows введите ipconfig/all и изучите область Description (Описание), которая расположена выше каждого физического адреса. Если сетевых адаптеров несколько, можно использовать любой из них. Такие устройства, как VPN- и PPP-адаптеры, а также модемы, не поддерживаются.
  5. Закрыть командную строку Windows.

Получение имени и идентификатора хоста с помощью lmtools.exe

Для работы с утилитой LMTOOLS необходимо войти в систему с правами администратора.

  1. Выполните одно из следующих действий:
    • (Windows XP) Выберите меню "Пуск" [image] "Программы" [image] Autodesk [image] Network License Manager [image] LMTOOLS.
    • (Windows Vista) Дважды щелкните на значке LMTOOLS на рабочем столе.
  2. В окне программы LMTOOLS перейдите на вкладку "Systems Settings" (Настройки системы).
  3. На вкладке "Systems Settings" (Настройки системы) найти поле "Computer/Hostname" (). Скопировать имя хоста и вставить информацию в текстовый редактор.
  4. Найти поле "Ethernet Address" (Адрес Ethernet узла сервера). Адрес Ethernet является идентификатором хоста. Он состоит из двенадцати символов. Записать информацию. Если длина адреса Ethernet слишком велика, следует записать только первые двенадцать символов.
    ПримечаниеЕсли на сервере установлено несколько адаптеров Ethernet, необходимо выбрать тот из них, который соответствует физическому устройству.
  5. Закрыть lmtools.exe.


Настройка сервера лицензий (Windows)

Получение имени и идентификатора хоста вручную
Инструменты сетевого лицензирования
Остановка работы и перезапуск сервера лицензий
Инструменты сетевого лицензирования >
Настройка сервера лицензий (Windows)
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Настройка сервера лицензий осуществляется таким образом, чтобы можно было управлять лицензиями на продукт Autodesk, полученными с помощью программы активации сетевой лицензии. Для настройки параметров сервера используется утилита lmtools.exe.

Для настройки параметров сервера лицензий

Для работы с утилитой LMTOOLS необходимо войти в систему с правами администратора.

  1. Выполните одно из следующих действий:
    • (Windows XP) Выберите меню "Пуск" [image] "Программы" [image] Autodesk [image] Network License Manager [image] LMTOOLS.
    • (Windows Vista) Дважды щелкните на значке LMTOOLS на рабочем столе.
  2. На вкладке "Service/License File" (Службы/Файлы лицензий) программы LMTOOLS убедитесь, что установлен флажок "Configure Using Services" (Настроить, используя службы).
  3. Перейти на вкладку "Config Services" (Настроить службу).
  4. В списке "Service Name" (Имя службы) выберите имя службы, которое требуется использовать для управления лицензиями.

    По умолчанию установлена служба Flexlm Service 1. Если FLEXnet® на данном компьютере управляет не только программами Autodesk, но и другим программным обеспечением, можно во избежание путаницы изменить имя службы, например, можно переименовать Flexlm Service 1 в Autodesk Server1.

    ПримечаниеЕсли для управления лицензиями имеется несколько поставщиков программного обеспечения, использующего FLEXnet®, в списке "Service Name" (Имя службы) отображается несколько вариантов. Убедитесь, что указана только одна служба Autodesk.
  5. В поле "Path to Lmgrd.exe File" (Путь к файлу Lmgrd.exe) задайте путь к демону Network License Manager (lmgrd.exe), или найдите его с помощью кнопки "Browse" (Обзор).

    По умолчанию этот демон устанавливается в папку C:\Program Files\Autodesk Network License Manager.

  6. В поле "Path to the License File" (Путь к файлу лицензий) введите путь к файлу лицензий или найти его с помощью кнопки "Browse" (Обзор).

    Это задает путь к файлу лицензии, полученному программой активации сетевой лицензии, или местоположение, куда был помещен файл лицензии, если он был получен в автономном режиме.

  7. В поле "Path to the Debug Log File" (Путь к файлу отладочного журнала) введите путь, по которому формируется отладочный журнал, или найдите с помощью кнопки "Browse" (Обзор) существующий журнал.

    Рекомендуется сохранять свои файлы в папке C:\Program Files\Autodesk Network License Manager. Файл журнала должен иметь расширение .log. Для открытия нового файла журнала введите расширение.log вручную.

  8. Для запуска lmgrd.exe в качестве службы установить флажок "Use Services".
  9. Для автоматической загрузки lmgrd.exe при запуске системы установите флажок "Start Server at Power Up" (Запуск сервера при включении питания).
  10. Для сохранения настроек с именем, заданным в пункте 4, нажать кнопку "Save Service" (Сохранить службу). Нажмите "Yes" (Да) при выводе запроса на сохранение настроек для службы.
  11. Выбрать вкладку "Start/Stop/Reread" (Начать/Остановить/Перечитать) и выполнить одно из следующих действий.
    • Если службы для продуктов Autodesk еще не созданы, нажать кнопку "Start Server" (Запустить сервер) для запуска сервера лицензий.
    • Если служба для продукта Autodesk уже создана и запущена, нажать кнопку "ReRead License File" (Прочитать еще раз файл лицензий) для обновления Диспетчера сетевых лицензий и всех изменений файла лицензий или параметров.

    Сервер лицензий запускается и готов обрабатывать запросы клиентов.

  12. Закрыть lmtools.exe.


Остановка работы и перезапуск сервера лицензий

Настройка сервера лицензий (Windows)
Инструменты сетевого лицензирования
Настройка и использование файла параметров
Инструменты сетевого лицензирования >
Остановка работы и перезапуск сервера лицензий
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Для внесения системных изменений в работу сервера лицензий требуется остановить сервер лицензий. После того как все изменения внесены, необходимо перезапустить сервер лицензий.

Для остановки сервера лицензий (Windows)

Для работы с утилитой LMTOOLS необходимо войти в систему с правами администратора.

  1. Выполните одно из следующих действий:
    • (Windows XP) Выберите меню "Пуск" [image] "Программы" [image] Autodesk [image] Network License Manager [image] LMTOOL
    • (Windows Vista) Дважды щелкните на значке LMTOOLS на рабочем столе.
  2. На вкладке "Service/License File" (Службы/Файлы лицензии)программы LMTOOLS установите переключатель в положение "Configure Using Services" (Настроить, используя службы).
  3. Выбрать имя службы того сервера лицензий, который требуется запустить вручную.
  4. Перейти на вкладку "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз).
  5. Для остановки сервера лицензий нажать кнопку "Stop Server" (Остановить сервер) на вкладке "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз).
  6. Закрыть lmtools.exe.

Для перезапуска сервера лицензий (Windows)

Для работы с утилитой LMTOOLS необходимо войти в систему с правами администратора.

  1. Выполните одно из следующих действий:
    • (Windows XP) Выберите меню "Пуск" [image] "Программы" [image] Autodesk [image] Network License Manager [image] LMTOOL
    • (Windows Vista) Дважды щелкните на значке LMTOOLS на рабочем столе.
  2. На вкладке "Service/License File" (Службы/Файлы лицензии)программы LMTOOLS установите переключатель в положение "Configure Using Services" (Настроить, используя службы).
  3. Выбрать имя службы того сервера лицензий, который требуется запустить вручную.
  4. Перейти на вкладку "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз).
  5. Для перезапуска сервера лицензий нажать кнопку "Start Server" (Запустить сервер) на вкладке "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз).


Настройка и использование файла параметров

Остановка работы и перезапуск сервера лицензий
Инструменты сетевого лицензирования
Создание отчета об использовании лицензий
Инструменты сетевого лицензирования >
Настройка и использование файла параметров
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

С помощью файла параметров можно настроить параметры, необходимые для управления лицензиями на всех настраиваемых серверах лицензий. Параметры, заданные в этом файле, считываются файлом лицензий и выполняются программой lmgrd.

Если нужно иметь лицензии одного вида на нескольких или сразу на всех серверах лицензий, следует сохранить одинаковый файл параметров на каждом сервере. Если на разных серверах нужно иметь различные виды лицензий, следует создать файл параметров для каждого вида лицензий отдельно. Каждый файл параметров должен быть сохранен на сервере, на котором будут храниться лицензии определенного вида.

ПримечаниеДля того чтобы произведенные в файле параметров изменения вступили в силу, необходимо сохранить файл параметров, а затем запустить lmtools.exe для перезапуска файла лицензий.

С помощью файла параметров можно производить следующие действия:

  • Создание отчета об использовании лицензий
  • Настройка параметров заимствования лицензий
  • Настройка параметров тайм-аута лицензий

Файл параметров имеет следующий вид:

REPORTLOG=c:\test\report.rl

BORROW_LOWWATER Autodesk_f1 3

TIMEOUT Autodesk_f1 7200

Существует также возможность настройки дополнительных параметров, таких как резервирование лицензии, ограничение использования лицензии и определение групп пользователей. Более подробную информацию о дополнительных настройках файла параметров см. в документации по FLEXnet в папке C:\Program Files\Autodesk Network License Manager\docs\FlexUser.

Для создания файла параметров

Для работы с утилитой LMTOOLS необходимо войти в систему с правами администратора.

  1. Откройте текстовый редактор, введите желаемые параметры и сохранить документ под именем adskflex.opt в той же папке, в которой был сохранен файл лицензий.
    ПримечаниеСохранять файл следует с расширением .opt. Расширение .txt, используемое текстовым редактором по умолчанию, не распознается программой Network License Manager.
  2. Выполните одно из следующих действий:
    • (Windows XP) Выберите меню "Пуск" [image] "Программы" [image] Autodesk [image] Network License Manager [image] LMTOOL
    • (Windows Vista) Дважды щелкните на значке LMTOOLS на рабочем столе.
  3. В программе перейдите на вкладку "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз) и выберите "ReRead License File" (Прочитать файл лицензий еще раз).
  4. (Windows) Закройте lmtools.exe.

Темы в этом разделе

  • Создание отчета об использовании лицензий
  • Настройка параметров заимствования лицензий
  • Настройка параметров тайм-аута лицензий


Создание отчета об использовании лицензий

Настройка и использование файла параметров
Настройка и использование файла параметров
Настройка параметров заимствования лицензий
Инструменты сетевого лицензирования > Настройка и использование файла параметров >
Создание отчета об использовании лицензий
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

С помощью файла параметров можно создать файл отчета о лицензиях, который может быть использован в SAMreport-Lite.

Для создания отчета об использовании лицензий

  1. В текстовом редакторе открыть файл adskflex.opt.
  2. В файле параметров введите строку со следующим синтаксисом (REPORTLOG вводится прописными буквами, как показано ниже):

    REPORTLOG [+]report_log_path

    Например (Windows), конструкция REPORTLOG +"c:\Мои документы\report.rl" означает, что файл отчета с именем report.rl находится в папке c:\Мои документы.

    ПримечаниеЕсли имя пути содержит пробелы, оно должно заключаться в кавычки.

    Знак “[+]“ в конструкции REPORTLOG означает, что новые записи добавляются в файл отчета, а не заменяются при каждом перезапуске Диспетчера сетевых лицензий. Рекомендуется использовать эту опцию для сохранения всех записей.


Настройка параметров заимствования лицензий

Создание отчета об использовании лицензий
Настройка и использование файла параметров
Настройка параметров тайм-аута лицензий
Инструменты сетевого лицензирования > Настройка и использование файла параметров >
Настройка параметров заимствования лицензий
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Если продукт Autodesk поддерживает возможность заимствования лицензий, для настройки процесса заимствования можно использовать файл параметров лицензий. Например, там можно задать максимальное количество лицензий, которые не могут быть одновременно заимствованы из сети. Кроме того, можно определить, какие пользователи имеют право на заимствование лицензии продукта Autodesk. Лицензии заимствуются на количество пользователей, а не на количество компьютеров.

ПримечаниеЕсли установленный на компьютере продукт Autodesk поддерживает заимствование лицензий и лицензии заимствуются с пула резервного сервера лицензий, после останова Network License Manager необходимо перезапустить сервер лицензий.

По окончании периода заимствования заимствованная лицензия автоматически отключается на компьютере пользователя и снова становится доступной на сервере лицензий. Пользователь также имеет возможность вернуть лицензию до окончания срока ее заимствования.

Для настройки параметров заимствования лицензий

  1. В файле параметров введите строку со следующим синтаксисом (BORROW_LOWWATER вводится прописными буквами, как показано ниже):

    BORROW_LOWWATER feature_code n

    В строке BORROW “код_продукта“ представляет собой имя продукта в файле лицензий, а “n“ - число лицензий, которое не допускается заимствовать.

    Например, строка BORROW_LOWWATER Autodesk_f1 3 означает, что для продукта Autodesk_f1 с сервера лицензий нельзя заимствовать три лицензии.

  2. Далее введите строку со следующим синтаксисом (MAX_BORROW_HOURS вводится прописными буквами, как показано ниже):

    MAX_BORROW_HOURS feature_code n

    В данной строке “n“ – это количество часов действия заимствованной лицензии.

    Например, строка MAX_BORROW_HOURS Autodesk_f1 360 означает, что для продукта Autodesk_f1 лицензии могут заимствоваться на 360 часов (т.е. 15 дней).

    ПримечаниеЛицензии заимствуются на количество часов, кратное 24. Не кратное числу 24 количество часов подвергается округлению. Например, 365 округляется до 360 часов, или 15 дней.

Дополнительную информацию о настройке функции заимствования лицензий можно найти в документации по FLEXnet в папке C:\Program Files\Autodesk Network License Manager\Docs\FlexUser.

ПримечаниеДля заимствования лицензии в продукте Autodesk выберите меню "Сервис" [image] "Заимствование лицензии" или введите команду заимлиц в командной строке продукта Autodesk. Справочные сведения по этой функции можно получить в окне команды заимствования лицензий [продукт Autodesk], а также в файле C:\Program Files\[продукт Autodesk]\Help\adsk_brw.chm.


Настройка параметров тайм-аута лицензий

Настройка параметров заимствования лицензий
Настройка и использование файла параметров
Удаление Network License Manager
Инструменты сетевого лицензирования > Настройка и использование файла параметров >
Настройка параметров тайм-аута лицензий
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

В файле параметров можно задать тайм-аут лицензий, для того чтобы определить временной интервал, по истечении которого неактивная лицензия отзывается сервером лицензий. При установке этого флага в файле параметров лицензия возвращается на сервер лицензий, если продукт не используется на рабочей станции дольше времени, заданного тайм-аутом.

Если лицензия была потеряна из-за превышения времени тайм-аута, при возврате пользователя к работе с продуктом будет предпринята попытка получить новую лицензию. Если доступных лицензий нет, пользователь получает возможность сохранить свою работу перед закрытием продукта.

С помощью параметра TIMEOUT можно по отдельности установить значения тайм-аута для лицензий на каждый программный продукт Autodesk, установленный на компьютере. Кроме того, с помощью параметра TIMEOUTALL можно установить одно значение тайм-аута лицензий на все установленные на компьютере продукты Autodesk.

Для настройки параметров тайм-аута лицензий

  • Для отдельных программных продуктов Autodesk: d файле параметров введите строку со следующим синтаксисом (TIMEOUT вводится прописными буквами, как показано ниже):

    TIMEOUT feature_code n

    В строке TIMEOUT “код_продукта” является наименованием продукта (см. в строке INCREMENT в файле лицензий), а “n” – число секунд до повторного запроса неактивной лицензии сервером лицензий.

    Например, синтаксис TIMEOUT Autodesk_f1 7200 означает, что для программного продукта Autodesk_f1 установленный период тайм-аута лицензии равен 7200 секундам или двум часам.

  • Для всех программных продуктов Autodesk: в файле параметров введите строку со следующим синтаксисом (TIMEOUTALL вводится прописными буквами, как показано ниже):

    TIMEOUTALL n

    В конструкции TIMEOUTALL “n” – число секунд до повторного запроса неактивной лицензии сервером лицензий.

    Например, синтаксис TIMEOUTALL Autodesk 7200 означает, что для всех программных продуктов Autodesk установленный период тайм-аута лицензии равен 7200 секундам или двум часам.

Дополнительную информацию о тайм-ауте лицензий можно найти в документации по FLEXnet , находящейся в папке C:\Program Files\Autodesk Network License Manager\Docs\FlexUser.


Удаление Network License Manager

Настройка параметров тайм-аута лицензий
Инструменты сетевого лицензирования
Словарь терминов
Инструменты сетевого лицензирования >
Удаление Network License Manager
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.

Network License Manager можно удалить с сервера лицензий. После удаления Network License Manager лицензии становятся недоступными для пользователей.

Для удаления Network License Manager

  1. Выполните одно из следующих действий:
    • (Windows XP) Выберите меню "Пуск" [image] "Программы" [image] Autodesk [image] Network License Manager [image] LMTOOL
    • (Windows Vista) Дважды щелкните на значке LMTOOLS на рабочем столе.
  2. На вкладке "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз) нажать кнопку "Stop Server" (Остановить сервер).
  3. На вкладке "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз) нажать кнопку "Stop Server" (Остановить сервер).
  4. Закрыть lmtools.exe.
  5. В "Панели управления" Windows произвести двойной щелчок на значке "Установка и удаление программ".
  6. В окне "Add/Remove Programs" (Установка и удаление программ) выбрать Autodesk Network License Manager. Нажмите кнопку "Исключить".
  7. Если потребуется, перезагрузить компьютер.
ПримечаниеСозданные в ходе работы Network License Manager файлы должны быть удалены вручную; это относится, например, к файлам журнала, лицензий и параметров. При удалении Network License Manager эти файлы автоматически не удаляются.


Словарь терминов

Удаление Network License Manager
Словарь терминов
Развернуть все
Развернуть все свернутые разделы.
Свернуть все
Свернуть все развернутые разделы.
adskflex.exe

Демон поставщика Autodesk, использующийся в технологии лицензирования FLEXnet. Демон поставщика постоянно следит за выданными лицензиями Autodesk и рабочими станциями, на которых они используются.

ADSKFLEX_LICENSE_FILE

Переменная среды, использующаяся в конфигурации с несколькими серверами лицензий для определения сервера, к которому рабочая станция должна обратиться за лицензией.

feature code

Параметр файла лицензии, представляющий программный продукт, поддерживаемый данным файлом лицензии.

FLEXnet

Предоставленная компанией Acresso Software технология, используемая для управления лицензиями на продукты Autodesk.

JRE (Java Runtime Environment)

Программа, требующаяся для запуска Java-программ. Эту программу следует устанавливать вместе с SAMreport-Lite.

licpath.lic

Файл, использующийся в конфигурациях с одним сервером и с резервными серверами для определения сервера лицензий FLEXnet, к которому обращается рабочая станция. Файл Licpath.lic находится в корневой папке устанавливаемого программного продукта.

lmgrd.exe

Демон диспетчера лицензий. Этот демон осуществляет первичное соединение с приложением, а затем устанавливает соединение с демоном поставщика (adskflex.exe).

lmtools.exe

Утилита управления технологией лицензирования FLEXnet с графическим пользовательским интерфейсом. (Lmutil.exe является версией данной утилиты с интерфейсом командной строки)

lmutil.exe

Утилита управления технологией лицензирования FLEXlm с интерфейсом командной строки. (Lmtools.exe является версией этой утилиты с графическим интерфейсом пользователя.)

Network License Manager

Технология, используемая Autodesk для управления сетевыми лицензиями.

SAMreport-Lite

Версия программы SAMreport, разработанной компанией Acresso Softwares. Программа SAMreport-Lite входит в комплект поставки продуктов Autodesk и имеется на установочных дисках продукта.

адрес Ethernet (Ethernet address)

См. идентификатор хоста.

демон (daemon)

Постоянно работающая фоновая программа. Демон обрабатывает сделанные компьютером запросы и передает их другим программам или процессам. В диспетчере сетевых лицензий используются два демона: демон поставщика (adskflex.exe) и демон диспетчера лицензий (lmgrd.exe).

демон поставщика (vendor daemon)

См. adskflex.exe.

заимствованная лицензия (borrowed license)

Лицензия, позволяющая в течение ограниченного периода времени работать с продуктом Autodesk без необходимости в приобретении отдельной лицензии или без доступа к серверу лицензий.

идентификатор хоста (host ID)

Уникальный физический адрес сетевого адаптера. Также известен как адрес Ethernet или физический адрес.

имя хоста (host name)

TCP/IP-имя, присваиваемое компьютеру. В технологии FLEXnet имя хоста используется в качестве параметра. Имя хоста должно отличаться от имени NetBIOS (имени сервера).

конфигурация с несколькими серверами (distributed server)

Конфигурация с несколькими серверами лицензий, в которой для управления распределением лицензий используется несколько серверов. Каждый сервер имеет собственный уникальный файл лицензий и определенное количество лицензий. При сбое одного из серверов распределенного пула лицензии на остальных серверах остаются доступными.

конфигурация с резервными серверами (redundant server)

Конфигурация, в которой для управления лицензиями используется три сервера. Серверы в этой конфигурации имеют общий файл и пул лицензий. Пул резервного сервера действует до тех пор, пока хотя бы два из трех серверов функционируют и взаимодействуют друг с другом.

мастер-демон (master daemon)

См. lmgrd.exe.

отчет об использовании лицензий (report log file)

Файл, используемый FLEXnet и SAMreport-Lite. Этот файл предоставляет информацию об использовании сетевых лицензий. Файл отчета создается при участии файла параметров.

период неактивности (idle)

Период, в течение которого продукт остается неактивным, в результате чего сервер лицензий отзывает лицензию. Неактивность, определяемая отсутствием действий с мышью или клавиатурой, неиспользованием команд, выражений LISP, макросов, сценариев в течение времени, указанного в файле параметров. См. также тайм-аут лицензий.

Программа активации сетевой лицензии (Network License Activation utility)

Утилита, позволяющая сетевым администраторам получать лицензии и авторизовывать сетевые версии продуктов Autodesk через Интернет.

рабочая станция (workstation)

Подключенный к сети компьютер, на котором работает один пользователь.

развертывание (deployment)

Набор файлов и папок, созданный на сервере и использующийся рабочими станциями для установки программ Autodesk.

сервер лицензий (license server)

Сервер, на котором установлен Network License Manager.

сетевая установка (network license installation)

Вариант установки, при котором Network License Manager устанавливается и запускается на сервере. Network License Manager необходимо установить и настроить до того, как пользователи начнут работать с продуктом Autodesk.

тайм-аут лицензий (license timeout)

Параметр, позволяющий задавать временной интервал, по истечении которого неактивные лицензии автоматически возвращаются на сервер и становятся вновь доступными для использования.

тактовый сигнал (heartbeat signal)

Метод связи, использующийся для обмена информацией между Network License Manager и рабочей станцией для подтверждения того, что рабочая станция доступна и на ней производится активный сеанс работы с продуктом Autodesk.

файл журнала отладки (debug log file)

Файл, который FLEXnet использует для записи всех действий (таких как ошибки лицензирования или запуск и останов сервера), происходящих во время подключений Network License Manager к рабочей станции.

файл лицензий (license file)

Файл, используемый FLEXnet для управления количеством рабочих мест. Этот файл должен быть в простом текстовом формате с кодировкой ASCII.

файл параметров (Options file)

Файл, используемый FLEXnet для настройки параметров, необходимых для управления лицензиями, таких как резервирование лицензий и создание файлов отчета об использовании лицензий с помощью SAMreport-Lite.

физический адрес (physical address)

См. идентификатор хоста.


Комментарии пользователя

Данная форма предназначена для ввода замечаний и предложений, которые будут отправлены в группу технической документации компании Autodesk.

Заголовок и расположение раздела (не изменять):
Имя и фамилия (не обязательно):
         E-mail (не обязательно):
Текст комментария:

Замечание: Форма не может служить средством получения советов или технической поддержки. Информация из нее будет использована для улучшения документации по продукту. Благодарим Вас!