Использование Мастера Регистрации

Лицензирование программных продуктов компании CSoft Development с использованием Мастера Регистрации

В данной справке описан процесс лицензирования программных продуктов компании CSoft Development, с использованием Мастера Регистрации, который позволяет осуществить:
- запрос и получение локальной лицензии,
- активизацию локальной лицензии,
- подключение к Серверу Лицензий в случае сетевого лицензирования,
- отсылку сообщений в Службу Поддержки в случае ошибок.

Этапы осуществления локального лицензирования

Для осуществления локального лицензирования программных продуктов CSoft Development, необходимо:

С помощью Мастера Регистрации программного продукта:

1. Запросить и получить, локальную лицензию на продукт CSoft Development.

2. Активизировать полученную лицензию.

Этапы осуществления сетевого лицензирования

Для осуществления сетевого лицензирования программных продуктов CSoft Development, необходимо:

С помощью Мастера Установки Сервера Лицензий:

1. Запросить и получить, по крайней мере, одну сетевую лицензию на продукт CSoft Development, который требуется лицензировать по сети.

2. Установить и запустить Сервер Лицензий, указав файл лицензий.

3. Запросить и получить остальные сетевые лицензии, если это необходимо.

4. Добавить оставшиеся сетевые лицензии к Серверу Лицензий, если это необходимо.

С помощью Мастера Регистрации программного продукта:

5. Подключить программный продукт, лицензируемый по сети, к Серверу Лицензий.

Замечание: Процесс установки и запуска Сервера Лицензий, а так же получения сетевых лицензий для него, производится сетевым администратором и описан в руководстве по использованию Мастера Установки Сервера Лицензий.

Запуск Мастера Регистрации

Мастер Регистрации может быть запущен одним из следующих способов:

Сразу по окончании установки программного продукта

Для этого следует оставить взведенным флаг Запустить мастер регистрации в заключительном диалоге Мастера Установки (InstallShield Wizard).

Из папки, в которую была установлена программа

Для этого выберите и запустите в этой папке исполняемый файл [image] RegWizard.exe.

С панели задач Windows

Для этого нажмите кнопку Пуск (Start) на панели задач, затем выберите Программы (Programs) и далее из подраздела установленной программы выберите пункт [image] Мастер регистрации.

Замечание: При наличии ключа аппаратной защиты, необходимо выполнить подготовительные действия перед запуском Мастера Регистрации.


Предварительные действия

Предварительные действия при наличии ключа аппаратной защиты

При наличии ключа аппаратной защиты, необходимо проделать следующие действия перед запуском Мастера Регистрации:

1. В зависимости от типа ключа аппаратной защиты, установите на компьютер драйвер WIBU или SENTINEL, который находится на установочном диске в соответствующей папке.

2. Установите ключ аппаратной защиты в соответствующий (LPT или USB) порт компьютера.

3. Если на компьютере установлены ключи аппаратной защиты других программ, снимите их на время запроса лицензии.


Запрос локальной лицензии

В случае отсутствия локальной лицензии на программный продукт CSoft Development производится ее запрос у Службы Лицензирования.

Для осуществления запроса лицензии выполните следующие действия:

1. Запустите Мастер Регистрации того программного продукта, на который требуется получить локальную лицензию.

2. В стартовом окне выберите пункт Запросить Лицензию и нажмите кнопку Далее (Next).

3. В окне Ввод регистрационных данных укажите серийный номер того продукта CSoft Development, на который требуется получить файл лицензии.

4. Пройдите два следующие окна, заполнив поля анкеты.

5. Проверьте все введенные данные в окне Подтверждение регистрационных данных и подтвердите их нажатием кнопки Далее (Next). В случае обнаружения ошибки, вернитесь назад, используя кнопку Назад (Back) и исправьте информацию в тех полях, где это необходимо.

6. Далее, необходимо передать регистрационные данные в Службу Лицензирования компании CSoft Development. Выберите способ запроса лицензии в окне Способ запроса лицензии и нажмите кнопку Далее (Next).

7. Осуществите отправку запроса выбранным способом.
В случае лицензирования on-line способом, в открывшемся окне Ответ Службы Лицензирования будет отображена информация о состоянии процесса передачи данных и выдаче лицензии on-line, о его результате и о причинах в случае неудачи. Нажмите кнопку Далее (Next).

8. Для завершения нажмите кнопку Готово (Finish) в появившемся окне, содержащем контактную информацию.

Дальнейшие действия по осуществлению лицензирования

В том случае если лицензирование производилось по электронной почте или по факсу следует осуществить дальнейшие действия.
В случае on-line лицензирования производить данные действия не следует.

Смотри также:

Общая схема осуществления локального лицензирования


Мастер Регистрации

Мастер Регистрации предназначен для осуществления лицензирования продуктов компании CSoft Development. С помощью него могут решаться такие задачи как: запрос и получение локальной лицензии, активизация локальной лицензии, подключение к Серверу Лицензий в случае сетевого лицензирования, отсылка сообщений в Службу Поддержки в случае ошибок.

В стартовом окне Мастера Регистрации выберите одну из текущих задач:

· В случае отсутствия лицензии на программный продукт, следует выбрать пункт Запросить Лицензию, для составления и отсылки запроса на получение файла локальной лицензии.

· При наличии локальной лицензии, полученной от Службы Лицензирования компании CSoft Development, следует выбрать пункт Активизировать лицензию.

· При наличии установленного и запущенного Сервера Лицензий следует выбрать пункт Подключиться к Серверу Лицензий.

Для продолжения нажмите кнопку Далее (Next).

Смотри также:

Использование Мастера Регистрации


Ввод регистрационных данных (сведения о продукте)

В данном окне отображается информация о продукте, для которого вы хотите получить локальную лицензию: название программы и серийный номер.

Если вы производите обновление с пробной версии на полнофункциональную, введите новый номер в поле Серийный номер. При покупке программного обеспечения новый номер выдается дилером.

В случае, если к компьютеру подключено устройство аппаратной защиты (электронный ключ), то в диалоге будет отображаться его серийный номер, а также станет доступен флажок Использовать аппаратную защиту. Взведите его для запроса лицензии, которая будет привязана к данному электронному ключу.

Для продолжения нажмите кнопку Далее (Next).


Ввод регистрационных данных (сведения о компании)

В этом окне вводится информация о Вашей компании. Для перехода к следующему этапу Вам необходимо заполнить все поля этого диалога.

Для продолжения нажмите кнопку Далее (Next).


Ввод регистрационных данных (сведения о пользователе)

В этом окне Вам предложено ввести контактную информацию, а также выбрать область или области применения нашего продукта. Если нужный вариант отсутствует, то просто введите его в список самостоятельно.

Для продолжения нажмите кнопку Далее (Next).


Подтверждение регистрационных данных

В данном окне отображается информация, собранная Мастером регистрации в процессе работы. Текст содержит как чисто техническую информацию, на основе которой будет выдана локальная лицензия, так и информацию которую Вы сообщили о своей компании и персоне. Если Вы планируете отправлять собранную информацию по факсу, то необходимо указать контактный телефон, чтобы наш сотрудник мог связаться с Вами.

Проверьте все введенные данные и подтвердите их нажатием кнопки Далее (Next). В случае обнаружения ошибки, вернитесь назад, используя клавишу Назад (Back) и исправьте информацию в тех полях, где это необходимо.

Замечание: Пожалуйста, внимательно проверьте ваши регистрационные данные. При неправильном заполнении регистрационных полей компания CSoft Development оставляет за собой право отказать в выдаче лицензии.

Для продолжения нажмите кнопку Далее (Next).


Способ запроса лицензии

В данном окне, необходимо выбрать способ передачи регистрационных данных в службу технической поддержки компании CSoft Development. Запрос на получение локальных лицензий может производиться напрямую по сети Интернет (on-line), либо по электронной почте, либо по факсу. Так же, лицензионный запрос может быть сохранен в файл, для последующей его отправки с другого компьютера.

1. Запрос лицензии on-line и ее автоматическая активизация

Данный вариант является предпочтительным, поскольку в этом случае будет произведен не только запрос файла локальной лицензии, но и его автоматическое получение и активизация. В случае успешной обработки запроса, Вы можете приступать к работе с продуктом.

Для осуществления запроса данным способом, выберите пункт Запросить лицензию on-line и нажмите кнопку Далее (Next). При этом будет осуществлена попытка отправки запроса.

2. Запрос лицензии по электронной почте

Данный вариант является менее предпочтительным, чем запрос лицензии on-line, поскольку в этом случае запрашиваемый файл локальной лицензии будет выслан по электронной почте, и для его активизации будет необходимо выполнить дополнительные действия.

Для осуществления запроса данным способом:

1. Выберите пункт Запросить лицензию по электронной почте и нажмите клавишу Далее (Next). При этом будет автоматически создано электронное письмо с запросом в Службу Лицензирования. Не изменяйте ни тему (subject), ни текст письма: любые изменения могут привести к ошибке при выдаче и при работе лицензии.

2. Нажмите кнопку Отправить (Send) в окне почтового клиента.

3. В появившемся окне, содержащем контактную информацию, нажмите кнопку Готово (Finish).

Поздравляем! Запрос на получение файла лицензии на установленный программный продукт отправлен. Запросы, отправленные по электронной почте, обрабатывает робот лицензий. Робот лицензий обрабатывает письма в автоматическом режиме и ответит на запрос в кратчайшие сроки.

При получении электронного письма, содержащего файл лицензии, повторно запустите Мастер Регистрации, в стартовом окне выберите пункт Активизировать лицензию и нажмите кнопку Далее (Next).

3. Запрос лицензии по факсу

Запрос файла локальной лицензии может быть также осуществлен по факсу.

Для этого:

1. Выберите пункт Распечатать лицензионный запрос и нажмите клавишу Далее (Next).

2. В появившемся диалоге печати установите требуемые параметры и распечатайте регистрационные данные.

3. В окне, содержащем контактную информацию, нажмите кнопку Готово (Finish).

4. Передайте запрос в компанию CSoft Development по номеру факса, указанному на распечатанной странице, с пометкой "Получение лицензии для программы <укажите название программы>".

При получении электронного письма содержащего файл локальной лицензии, или информации на факс, повторно запустите Мастер Регистрации, в стартовом окне выберите пункт Активизировать лицензию и нажмите кнопку Далее (Next).

4. Отправка запроса с другого компьютера

Если сетевые службы на компьютере не доступны, имеется возможность сохранить лицензионный запрос в файл и передать его с другого компьютера.

Для этого:

1. Выберите пункт Сохранить лицензионный запрос и нажмите кнопку Далее (Next).

2. В появившемся диалоге выберите в качестве формата файла в котором будет записан запрос – почтовый формат EML, имя файла и место сохранения.

3. В окне, содержащем контактную информацию, нажмите кнопку Готово (Finish).

4. Перенесите файл на компьютер, с которого может быть отправлен запрос.

5. Откройте файл его почтовым клиентом, и нажав в нем кнопку Ответить (Reply) отправьте электронное письмо. Обязательно сохраните тему (subject) и содержание исходного письма без изменений, в противном случае это может привести к ошибке при выдаче и при работе лицензии.

При получении электронного письма содержащего файл локальной лицензии, повторно запустите Мастер Регистрации, в стартовом окне выберите пункт Активизировать лицензию и нажмите кнопку Далее (Next).


Ответ системы лицензирования

В данном окне отображается информация о состоянии процесса передачи данных on-line и выдаче локальной лицензии, о его результате и о причинах в случае неудачи.

В случае успешного завершения

В случае успешного завершения, нажмите кнопку Далее (Next), и в последующем окне, содержащем контактную информацию, нажмите кнопку Готово (Finish).

Поздравляем! Процесс лицензирования продукта CSoft Development успешно завершен. Никаких других действий по лицензированию установленного продукта производить не требуется.

Замечание: Файлы лицензий, полученные таким способом, помещаются в следующую директорию:
<ИМЯ ДИСКА>:\ Documents And Settings \ All Users \ Application Data \ CSoft \ RegWizard \ Licenses \
В случае если пользователь не обладает правами записи в директорию All Users\, тогда файлы размещаются по следующему пути:
<ИМЯ ДИСКА>:\ Documents And Settings \ <ИМЯ ПОЛЬЗОВАТЕЛЯ> \ Application Data \ CSoft \ RegWizard \ Licenses \

Сделайте резервную копию файла лицензии и сохраните ее в безопасном месте.

В случае отказа в выдаче лицензии

В случае отказа в выдаче локальной лицензии сервером по той или иной причине, нажмите кнопку Далее (Next), и в последующем окне, содержащем контактную информацию, нажмите кнопку Готово (Finish), завершив работу.

В случае неудачного соединения

В случае неудачного соединения с сервером, а так же в случае отсутствия возможности выдачи лицензии выбранным способом, нажмите кнопку Далее (Next) и, вернувшись обратно в окно Способ запроса лицензии, выберите другой вариант осуществления запроса.

Так же имеется возможность послать автоматически созданное электронное письмо в Службу Поддержки CSoft Development с полным протоколом работы Мастера Регистрации. Для этого установите флажок Послать e-mail в Службу Поддержки перед тем как нажать кнопку Далее (Next). Данный вариант имеет смысл в том случае, если Вы уверены, что причиной неудачи on-line лицензирования может являться неправильная работа программного обеспечения CSoft Development либо ошибка обработки запроса и выдачи лицензии.


Контактная информация

Это финальное окно содержит контактную информацию CSoft Development.

Для завершения работы с Мастером Регистрации нажмите кнопку Готово (Finish), в противном случае нажмите Назад (Back).


Действия после получения локальной лицензии

Данные действия следует выполнить после получения локальной лицензии от Службы Лицензирования по электронной почте или по факсу. В случае on-line лицензирования, производить нижеприведенные действия не следует.

· Если запрос лицензии производился по электронной почте, то через некоторое время на обратный адрес, указанный в запросе, будет выслано электронное письмо, содержащее файл лицензии.

· Если текст файла лицензии был получен по указанному в запросе номеру факса, нужно аккуратно переписать текст файла лицензии в любом текстовом редакторе и сохранить созданный файл с расширением LIC.

· Сделайте резервную копию файла лицензии и сохраните ее в безопасном месте.

· Также следуйте дополнительным инструкциям, в электронном письме или факсе, если таковые содержатся.

Смотри также:

Общая схема осуществления локального лицензирования

Запрос локальной лицензии


Выбор файла лицензии

Выбор файла лицензии (активизация локальной лицензии)

В этом окне следует указать местонахождение файла локальной лицензии, с целью ее активизации.

Выбор файла лицензии

1. В текущем диалоговом окне нажмите кнопку Обзор (Browse) и укажите местонахождение файла лицензии.

2. Нажмите кнопку Далее (Next).

3. В появившемся окне, содержащем контактную информацию, нажмите кнопку Готово (Finish).

Поздравляем! Процесс лицензирования продукта CSoft Development успешно завершен. Никаких других действий по лицензированию установленного продукта производить не требуется.


Определение Сервера Лицензий

Определение Сервера Лицензий (активизация сетевой лицензии)

Это окно используется для подключения к Серверу Лицензий в случае использования сетевой системы лицензирования. Данное окно открывается после выбора пункта Подключиться к Серверу Лицензий в окне Мастер Регистрации.

Замечание: Установка и запуск Сервера Лицензий производится сетевым администратором. Процесс установки Сервера Лицензий, а так же получения сетевых лицензий для него, описан в руководстве по использованию Мастера Установки Сервера Лицензий.

Для подключения к Серверу Лицензий компьютер должен иметь постоянный доступ к установленному и запущенному серверу по сети с установленным и активизированным протоколом TCP/IP.

Подключение к Серверу Лицензий

1. В текущем диалоговом окне введите IP адрес компьютера, на котором установлен Сервер Лицензий, например: 192.168.0.1, либо укажите NetBIOS имя машины, например: CORPSRV.

2. Нажмите кнопку Далее (Next).

3. В появившемся окне, содержащем контактную информацию, нажмите кнопку Готово (Finish).

Поздравляем! Процесс сетевого лицензирования продукта CSoft Development успешно завершен. Никаких других действий по лицензированию установленного продукта производить не требуется.

Смотри также:

Общая схема осуществления сетевого лицензирования


Список терминов

Заглушка (Dongle)

Смотри Ключ аппаратной защиты.

Ключ аппаратной защиты (Hardware lock)

Электронное устройство (заглушка), используемое для лицензирования. Совместимое с USB или LPT портом компьютера, оно должно быть подключено во время процесса запроса лицензии, а так же в процессе работы с программным продуктом. Без использования ключа, лицензия выдается на определенный компьютер и жестко связывает программу с той машиной, на которой она установлена. Лицензирование с использованием ключа аппаратной защиты привязывает программу не к компьютеру, а к ключу, что делает возможным ее перенос на другую машину.

Локальная лицензия (Local license)

Лицензия, размещенная в файле лицензии, необходимая для работы с программой. Выдается на определенный компьютер с установленным программным продуктом. Запрос и активизация такой лицензии производится с помощью Мастера Регистрации.

Мастер Регистрации (Registration Wizard)

Программный продукт, предназначенный для запроса, получения и активизации локальных лицензий для программных продуктов CSoft Development, а так же для подключения к Серверу Лицензий в случае лицензирования по сети.

Мастер Установки Сервера Лицензий (License Server Setup)

Программный продукт, предназначенный для установки и запуска Сервера Лицензий, предоставления возможности его обслуживания и получения сетевых лицензий.

Сервер Лицензий (License Server)

Сервер, осуществляющий лицензирование программных продуктов по сети.

Сетевая лицензия (Network license)

Лицензия, размещенная в файле лицензии, необходимая для работы с программой. Выдается для Сервера Лицензий на определенный программный продукт. Запрос и активизация такой лицензии производится с помощью Мастера Установки Сервера Лицензий.

Служба Лицензирования (Licensing Service)

Удаленная Интернет-служба, предназначенная для отсылки лицензий, на запросы, осуществленные с помощью Мастера Регистрации и Мастера Установки Сервера Лицензий.

Файл лицензии (License file)

Файл с LIC расширением, содержащий одну или несколько лицензий.

LicServSetup.exe

Выполняемый файл Мастера Установки Сервера Лицензий.

Regwizard.exe

Выполняемый файл Мастера Регистрации.


Ввод кода авторизации

Это окно используется для ввода кода авторизации, в случае его наличия.


Активизация локальной лицензии

Это окно используется для указания способа активизации лицензии, полученной от Службы Лицензирования компании CSoft Development. Данное окно открывается после выбора пункта Активизировать лицензию в окне Мастер Регистрации.

Внимание: В случае если запрос на лицензию был отправлен по сети Интернет (on-line) с помощью Мастера Регистрации и был успешно завершен, то активизация лицензии уже проведена, и никаких других действий по лицензированию установленного продукта производить не требуется.

Дополнительные действия перед активизацией локальной лицензии

В том случае если лицензирование производилось по электронной почте или по факсу следует осуществить дополнительные действия перед активизацией локальной лицензии.

Выбор способа активизации

В текущем окне Мастера Регистрации выберите пункт Файл лицензии. Нажмите кнопку Далее (Next).

Замечание: В случае наличия кода авторизации следует выбрать пункт - Код авторизации

Смотри также:

Общая схема осуществления локального лицензирования


Запуск внешней программы активизации

Данное окно информирует о необходимости запуска внешней программы для активизации лицензии.

Взведите флажок для запуска внешней программы.

Нажмите кнопку Далее (Next).